All Classes (Java SE 9 & JDK 9 )

所有类

  • AboutEvent
  • AboutHandler
  • AbsentInformationException
  • AbstractAction
  • AbstractAnnotationValueVisitor6
  • AbstractAnnotationValueVisitor7
  • AbstractAnnotationValueVisitor8
  • AbstractAnnotationValueVisitor9
  • AbstractBorder
  • AbstractButton
  • AbstractCellEditor
  • AbstractChronology
  • AbstractCollection
  • AbstractColorChooserPanel
  • AbstractDocument
  • AbstractDocument.AttributeContext
  • AbstractDocument.Content
  • AbstractDocument.ElementEdit
  • AbstractElementVisitor6
  • AbstractElementVisitor7
  • AbstractElementVisitor8
  • AbstractElementVisitor9
  • AbstractExecutorService
  • AbstractInterruptibleChannel
  • AbstractJSObject
  • AbstractLayoutCache
  • AbstractLayoutCache.NodeDimensions
  • AbstractList
  • AbstractListModel
  • AbstractMap
  • AbstractMap.SimpleEntry
  • AbstractMap.SimpleImmutableEntry
  • AbstractMarshallerImpl
  • AbstractMethodError
  • AbstractMultiResolutionImage
  • AbstractNotificationHandler
  • AbstractOwnableSynchronizer
  • AbstractPreferences
  • AbstractProcessor
  • AbstractQueue
  • AbstractQueuedLongSynchronizer
  • AbstractQueuedSynchronizer
  • AbstractRegionPainter
  • AbstractRegionPainter.PaintContext
  • AbstractRegionPainter.PaintContext.CacheMode
  • AbstractRelinkableCallSite
  • AbstractResourceBundleProvider
  • AbstractScriptEngine
  • AbstractSelectableChannel
  • AbstractSelectionKey
  • AbstractSelector
  • AbstractSequentialList
  • AbstractSet
  • AbstractSpinnerModel
  • AbstractTableModel
  • AbstractTypeVisitor6
  • AbstractTypeVisitor7
  • AbstractTypeVisitor8
  • AbstractTypeVisitor9
  • AbstractUndoableEdit
  • AbstractUnmarshallerImpl
  • AbstractView
  • AbstractWriter
  • AcceptPendingException
  • AccessControlContext
  • AccessControlException
  • AccessController
  • AccessDeniedException
  • AccessException
  • AccessibilityEventMonitor
  • AccessibilityListenerList
  • AccessibilityProvider
  • Accessible
  • Accessible
  • AccessibleAction
  • AccessibleAction
  • AccessibleAttribute
  • AccessibleAttributeSequence
  • AccessibleBundle
  • AccessibleComponent
  • AccessibleContext
  • AccessibleEditableText
  • AccessibleExtendedComponent
  • AccessibleExtendedTable
  • AccessibleExtendedText
  • AccessibleHyperlink
  • AccessibleHypertext
  • AccessibleIcon
  • AccessibleKeyBinding
  • AccessibleObject
  • AccessibleRelation
  • AccessibleRelationSet
  • AccessibleResourceBundle
  • AccessibleRole
  • AccessibleRole
  • AccessibleSelection
  • AccessibleState
  • AccessibleStateSet
  • AccessibleStreamable
  • AccessibleTable
  • AccessibleTableModelChange
  • AccessibleText
  • AccessibleTextSequence
  • AccessibleValue
  • AccessMode
  • AccessWatchpointEvent
  • AccessWatchpointRequest
  • Accordion
  • AccordionSkin
  • AccountException
  • AccountExpiredException
  • AccountLockedException
  • AccountNotFoundException
  • Acl
  • AclEntry
  • AclEntry
  • AclEntry.Builder
  • AclEntryFlag
  • AclEntryPermission
  • AclEntryType
  • AclFileAttributeView
  • AclNotFoundException
  • Action
  • Action
  • ActionEvent
  • ActionEvent
  • ActionListener
  • ActionMap
  • ActionMapUIResource
  • Activatable
  • ActivateFailedException
  • ActivationDataFlavor
  • ActivationDesc
  • ActivationException
  • ActivationGroup
  • ActivationGroup_Stub
  • ActivationGroupDesc
  • ActivationGroupDesc.CommandEnvironment
  • ActivationGroupID
  • ActivationID
  • ActivationInstantiator
  • ActivationMonitor
  • ActivationSystem
  • Activator
  • ACTIVE
  • ActiveEvent
  • ACTIVITY_COMPLETED
  • ACTIVITY_REQUIRED
  • ActivityCompletedException
  • ActivityRequiredException
  • AdapterActivator
  • AdapterActivatorOperations
  • AdapterAlreadyExists
  • AdapterAlreadyExistsHelper
  • AdapterInactive
  • AdapterInactiveHelper
  • AdapterManagerIdHelper
  • AdapterNameHelper
  • AdapterNonExistent
  • AdapterNonExistentHelper
  • AdapterStateHelper
  • AddressHelper
  • Addressing
  • AddressingFeature
  • AddressingFeature.Responses
  • Adjustable
  • AdjustmentEvent
  • AdjustmentListener
  • Adler32
  • AEADBadTagException
  • Affine
  • AffineTransform
  • AffineTransformOp
  • AgentInitializationException
  • AgentLoadException
  • Alert
  • Alert.AlertType
  • AlgorithmConstraints
  • AlgorithmMethod
  • AlgorithmParameterGenerator
  • AlgorithmParameterGeneratorSpi
  • AlgorithmParameters
  • AlgorithmParameterSpec
  • AlgorithmParametersSpi
  • AllPermission
  • AlphaComposite
  • AlreadyBound
  • AlreadyBoundException
  • AlreadyBoundException
  • AlreadyBoundHelper
  • AlreadyBoundHolder
  • AlreadyConnectedException
  • AmbientLight
  • AncestorEvent
  • AncestorListener
  • AnchorPane
  • Animation
  • Animation.Status
  • AnimationTimer
  • AnnotatedArrayType
  • AnnotatedConstruct
  • AnnotatedElement
  • AnnotatedParameterizedType
  • AnnotatedType
  • AnnotatedType
  • AnnotatedTypeTree
  • AnnotatedTypeVariable
  • AnnotatedWildcardType
  • Annotation
  • Annotation
  • AnnotationDesc
  • AnnotationDesc.ElementValuePair
  • AnnotationFormatError
  • AnnotationMirror
  • AnnotationTree
  • AnnotationTypeDoc
  • AnnotationTypeElementDoc
  • AnnotationTypeMismatchException
  • AnnotationValue
  • AnnotationValue
  • AnnotationValueVisitor
  • Any
  • AnyHolder
  • AnySeqHelper
  • AnySeqHelper
  • AnySeqHolder
  • AppConfigurationEntry
  • AppConfigurationEntry.LoginModuleControlFlag
  • Appendable
  • AppEvent
  • AppForegroundEvent
  • AppForegroundListener
  • AppHiddenEvent
  • AppHiddenListener
  • Applet
  • AppletContext
  • AppletInitializer
  • AppletStub
  • Application
  • Application.Parameters
  • ApplicationException
  • AppReopenedEvent
  • AppReopenedListener
  • Arc
  • Arc2D
  • Arc2D.Double
  • Arc2D.Float
  • ArcTo
  • ArcType
  • Area
  • AreaAveragingScaleFilter
  • AreaChart
  • ARG_IN
  • ARG_INOUT
  • ARG_OUT
  • ArithmeticException
  • Array
  • Array
  • ArrayAccessTree
  • ArrayAccessTree
  • ArrayBlockingQueue
  • ArrayChangeListener
  • ArrayDeque
  • ArrayIndexOutOfBoundsException
  • ArrayList
  • ArrayLiteralTree
  • ArrayReference
  • Arrays
  • ArrayStoreException
  • ArrayType
  • ArrayType
  • ArrayType
  • ArrayTypeTree
  • AssertionError
  • AssertTree
  • AssignmentTree
  • AssignmentTree
  • Association
  • AssociationChangeNotification
  • AssociationChangeNotification.AssocChangeEvent
  • AsyncBoxView
  • AsyncHandler
  • AsynchronousByteChannel
  • AsynchronousChannel
  • AsynchronousChannelGroup
  • AsynchronousChannelProvider
  • AsynchronousCloseException
  • AsynchronousFileChannel
  • AsynchronousServerSocketChannel
  • AsynchronousSocketChannel
  • AtomicBoolean
  • AtomicInteger
  • AtomicIntegerArray
  • AtomicIntegerFieldUpdater
  • AtomicLong
  • AtomicLongArray
  • AtomicLongFieldUpdater
  • AtomicMarkableReference
  • AtomicMoveNotSupportedException
  • AtomicReference
  • AtomicReferenceArray
  • AtomicReferenceFieldUpdater
  • AtomicStampedReference
  • ATR
  • AttachingConnector
  • AttachmentMarshaller
  • AttachmentPart
  • AttachmentUnmarshaller
  • AttachNotSupportedException
  • AttachOperationFailedException
  • AttachPermission
  • AttachProvider
  • Attr
  • Attribute
  • Attribute
  • Attribute
  • Attribute
  • AttributeChangeNotification
  • AttributeChangeNotificationFilter
  • AttributedCharacterIterator
  • AttributedCharacterIterator.Attribute
  • AttributedString
  • AttributeException
  • AttributeInUseException
  • AttributeList
  • AttributeList
  • AttributeList
  • AttributeListImpl
  • AttributeModificationException
  • AttributeNotFoundException
  • Attributes
  • Attributes
  • Attributes
  • Attributes.Name
  • Attributes2
  • Attributes2Impl
  • AttributeSet
  • AttributeSet
  • AttributeSet.CharacterAttribute
  • AttributeSet.ColorAttribute
  • AttributeSet.FontAttribute
  • AttributeSet.ParagraphAttribute
  • AttributeSetUtilities
  • AttributesImpl
  • AttributeTree
  • AttributeTree.ValueKind
  • AttributeValueExp
  • AttributeView
  • AudioClip
  • AudioClip
  • AudioEqualizer
  • AudioFileFormat
  • AudioFileFormat.Type
  • AudioFileReader
  • AudioFileWriter
  • AudioFormat
  • AudioFormat.Encoding
  • AudioInputStream
  • AudioPermission
  • AudioSpectrumListener
  • AudioSystem
  • AudioTrack
  • AuthenticationException
  • AuthenticationException
  • AuthenticationNotSupportedException
  • Authenticator
  • Authenticator
  • Authenticator.Failure
  • Authenticator.RequestorType
  • Authenticator.Result
  • Authenticator.Retry
  • Authenticator.Success
  • AuthorizationDataEntry
  • AuthorizeCallback
  • AuthorTree
  • AuthPermission
  • AuthProvider
  • AutoCloseable
  • Autoscroll
  • AWTError
  • AWTEvent
  • AWTEventListener
  • AWTEventListenerProxy
  • AWTEventMonitor
  • AWTEventMulticaster
  • AWTException
  • AWTKeyStroke
  • AWTPermission
  • Axis
  • Axis.TickMark
  • Background
  • BackgroundFill
  • BackgroundImage
  • BackgroundPosition
  • BackgroundRepeat
  • BackgroundSize
  • BackingStoreException
  • BAD_CONTEXT
  • BAD_INV_ORDER
  • BAD_OPERATION
  • BAD_PARAM
  • BAD_POLICY
  • BAD_POLICY_TYPE
  • BAD_POLICY_VALUE
  • BAD_QOS
  • BAD_TYPECODE
  • BadAttributeValueExpException
  • BadBinaryOpValueExpException
  • BadKind
  • BadKindHelper
  • BadLocationException
  • BadPaddingException
  • BadStringOperationException
  • BandCombineOp
  • BandedSampleModel
  • BarChart
  • Base64
  • Base64.Decoder
  • Base64.Encoder
  • BaselineTIFFTagSet
  • BaseMultiResolutionImage
  • BaseRowSet
  • BaseStream
  • BasicArrowButton
  • BasicAttribute
  • BasicAttributes
  • BasicAuthenticator
  • BasicBorders
  • BasicBorders.ButtonBorder
  • BasicBorders.FieldBorder
  • BasicBorders.MarginBorder
  • BasicBorders.MenuBarBorder
  • BasicBorders.RadioButtonBorder
  • BasicBorders.RolloverButtonBorder
  • BasicBorders.SplitPaneBorder
  • BasicBorders.ToggleButtonBorder
  • BasicButtonListener
  • BasicButtonUI
  • BasicCheckBoxMenuItemUI
  • BasicCheckBoxUI
  • BasicColorChooserUI
  • BasicComboBoxEditor
  • BasicComboBoxEditor.UIResource
  • BasicComboBoxRenderer
  • BasicComboBoxRenderer.UIResource
  • BasicComboBoxUI
  • BasicComboPopup
  • BasicControl
  • BasicDesktopIconUI
  • BasicDesktopPaneUI
  • BasicDirectoryModel
  • BasicEditorPaneUI
  • BasicFileAttributes
  • BasicFileAttributeView
  • BasicFileChooserUI
  • BasicFormattedTextFieldUI
  • BasicGraphicsUtils
  • BasicHTML
  • BasicIconFactory
  • BasicInternalFrameTitlePane
  • BasicInternalFrameUI
  • BasicLabelUI
  • BasicListUI
  • BasicLookAndFeel
  • BasicMenuBarUI
  • BasicMenuItemUI
  • BasicMenuUI
  • BasicOptionPaneUI
  • BasicOptionPaneUI.ButtonAreaLayout
  • BasicPanelUI
  • BasicPasswordFieldUI
  • BasicPermission
  • BasicPopupMenuSeparatorUI
  • BasicPopupMenuUI
  • BasicProgressBarUI
  • BasicRadioButtonMenuItemUI
  • BasicRadioButtonUI
  • BasicRootPaneUI
  • BasicScrollBarUI
  • BasicScrollPaneUI
  • BasicSeparatorUI
  • BasicService
  • BasicSliderUI
  • BasicSpinnerUI
  • BasicSplitPaneDivider
  • BasicSplitPaneUI
  • BasicStroke
  • BasicTabbedPaneUI
  • BasicTableHeaderUI
  • BasicTableUI
  • BasicTextAreaUI
  • BasicTextFieldUI
  • BasicTextPaneUI
  • BasicTextUI
  • BasicTextUI.BasicCaret
  • BasicTextUI.BasicHighlighter
  • BasicToggleButtonUI
  • BasicToolBarSeparatorUI
  • BasicToolBarUI
  • BasicToolTipUI
  • BasicTreeUI
  • BasicViewportUI
  • BatchUpdateException
  • BeanContext
  • BeanContextChild
  • BeanContextChildComponentProxy
  • BeanContextChildSupport
  • BeanContextContainerProxy
  • BeanContextEvent
  • BeanContextMembershipEvent
  • BeanContextMembershipListener
  • BeanContextProxy
  • BeanContextServiceAvailableEvent
  • BeanContextServiceProvider
  • BeanContextServiceProviderBeanInfo
  • BeanContextServiceRevokedEvent
  • BeanContextServiceRevokedListener
  • BeanContextServices
  • BeanContextServicesListener
  • BeanContextServicesSupport
  • BeanContextServicesSupport.BCSSServiceProvider
  • BeanContextSupport
  • BeanContextSupport.BCSIterator
  • BeanDescriptor
  • BeanInfo
  • BeanProperty
  • Beans
  • BeansLinker
  • BevelBorder
  • BiConsumer
  • Bidi
  • BiFunction
  • BigDecimal
  • BigDecimalStringConverter
  • BigInteger
  • BigIntegerStringConverter
  • BinaryOperator
  • BinaryRefAddr
  • BinaryTree
  • BinaryTree
  • Binder
  • BindException
  • Binding
  • Binding
  • Binding
  • Binding
  • BindingHelper
  • BindingHolder
  • BindingIterator
  • BindingIteratorHelper
  • BindingIteratorHolder
  • BindingIteratorOperations
  • BindingIteratorPOA
  • BindingListHelper
  • BindingListHolder
  • BindingProvider
  • Bindings
  • Bindings
  • BindingType
  • BindingType
  • BindingTypeHelper
  • BindingTypeHolder
  • BiPredicate
  • BitSet
  • Blend
  • BlendMode
  • Blob
  • BlockingDeque
  • BlockingQueue
  • BlockTagTree
  • BlockTree
  • BlockTree
  • BlockView
  • Bloom
  • BlurType
  • BMPImageWriteParam
  • Book
  • Boolean
  • BooleanBinding
  • BooleanControl
  • BooleanControl.Type
  • BooleanConverter
  • BooleanExpression
  • BooleanHolder
  • BooleanProperty
  • BooleanPropertyBase
  • BooleanSeqHelper
  • BooleanSeqHolder
  • BooleanStringConverter
  • BooleanSupplier
  • BooleanType
  • BooleanValue
  • Bootstrap
  • BootstrapMethodError
  • Border
  • Border
  • BorderFactory
  • BorderImage
  • BorderLayout
  • BorderPane
  • BorderRepeat
  • BorderStroke
  • BorderStrokeStyle
  • BorderUIResource
  • BorderUIResource.BevelBorderUIResource
  • BorderUIResource.CompoundBorderUIResource
  • BorderUIResource.EmptyBorderUIResource
  • BorderUIResource.EtchedBorderUIResource
  • BorderUIResource.LineBorderUIResource
  • BorderUIResource.MatteBorderUIResource
  • BorderUIResource.TitledBorderUIResource
  • BorderWidths
  • BoundedRangeModel
  • BoundingBox
  • Bounds
  • Bounds
  • Bounds
  • BoundsHelper
  • BoundsHelper
  • Box
  • Box
  • Box.Filler
  • BoxBlur
  • BoxedValueHelper
  • BoxLayout
  • BoxView
  • BreakIterator
  • BreakIteratorProvider
  • BreakpointEvent
  • BreakpointRequest
  • BreakTree
  • BreakTree
  • BrokenBarrierException
  • BubbleChart
  • Buffer
  • BufferCapabilities
  • BufferCapabilities.FlipContents
  • BufferedImage
  • BufferedImageFilter
  • BufferedImageOp
  • BufferedInputStream
  • BufferedOutputStream
  • BufferedReader
  • BufferedWriter
  • BufferOverflowException
  • BufferPoolMXBean
  • BufferStrategy
  • BufferUnderflowException
  • Builder
  • BuilderFactory
  • Button
  • Button
  • ButtonBar
  • ButtonBar.ButtonData
  • ButtonBarSkin
  • ButtonBase
  • ButtonGroup
  • ButtonModel
  • ButtonSkin
  • ButtonType
  • ButtonUI
  • Byte
  • ByteArrayInputStream
  • ByteArrayOutputStream
  • ByteBuffer
  • ByteChannel
  • ByteHolder
  • ByteLookupTable
  • ByteOrder
  • ByteStringConverter
  • ByteType
  • ByteValue
  • C14NMethodParameterSpec
  • CachedRowSet
  • CacheHint
  • CacheRequest
  • CacheResponse
  • Calendar
  • Calendar.Builder
  • CalendarDataProvider
  • CalendarNameProvider
  • Callable
  • CallableStatement
  • Callback
  • Callback
  • CallbackHandler
  • CallSite
  • CallSiteDescriptor
  • Camera
  • CancelablePrintJob
  • CancellationException
  • CancelledKeyException
  • CannotProceed
  • CannotProceedException
  • CannotProceedHelper
  • CannotProceedHolder
  • CannotRedoException
  • CannotUndoException
  • CanonicalizationMethod
  • Canvas
  • Canvas
  • Card
  • CardChannel
  • CardException
  • CardLayout
  • CardNotPresentException
  • CardPermission
  • CardTerminal
  • CardTerminals
  • CardTerminals.State
  • Caret
  • CaretEvent
  • CaretListener
  • CaseTree
  • CaseTree
  • Catalog
  • CatalogException
  • CatalogFeatures
  • CatalogFeatures.Builder
  • CatalogFeatures.Feature
  • CatalogManager
  • CatalogResolver
  • CatchTree
  • CatchTree
  • CategoryAxis
  • CDATASection
  • Cell
  • CellEditor
  • CellEditorListener
  • CellRendererPane
  • CellSkinBase
  • Certificate
  • Certificate
  • Certificate
  • Certificate.CertificateRep
  • CertificateEncodingException
  • CertificateEncodingException
  • CertificateException
  • CertificateException
  • CertificateExpiredException
  • CertificateExpiredException
  • CertificateFactory
  • CertificateFactorySpi
  • CertificateNotYetValidException
  • CertificateNotYetValidException
  • CertificateParsingException
  • CertificateParsingException
  • CertificateRevokedException
  • CertPath
  • CertPath.CertPathRep
  • CertPathBuilder
  • CertPathBuilderException
  • CertPathBuilderResult
  • CertPathBuilderSpi
  • CertPathChecker
  • CertPathParameters
  • CertPathTrustManagerParameters
  • CertPathValidator
  • CertPathValidatorException
  • CertPathValidatorException.BasicReason
  • CertPathValidatorException.Reason
  • CertPathValidatorResult
  • CertPathValidatorSpi
  • CertSelector
  • CertStore
  • CertStoreException
  • CertStoreParameters
  • CertStoreSpi
  • ChainedCallSite
  • ChangedCharSetException
  • ChangeEvent
  • ChangeListener
  • ChangeListener
  • Channel
  • ChannelBinding
  • Channels
  • Character
  • Character.Subset
  • Character.UnicodeBlock
  • Character.UnicodeScript
  • CharacterCodingException
  • CharacterData
  • CharacterIterator
  • Characters
  • CharacterStringConverter
  • CharArrayReader
  • CharArrayWriter
  • CharBuffer
  • CharConversionException
  • CharHolder
  • CharSeqHelper
  • CharSeqHolder
  • CharSequence
  • Charset
  • CharsetDecoder
  • CharsetEncoder
  • CharsetProvider
  • Chart
  • CharType
  • CharValue
  • Checkbox
  • CheckBox
  • CheckboxGroup
  • CheckBoxListCell
  • CheckboxMenuItem
  • CheckBoxSkin
  • CheckBoxTableCell
  • CheckBoxTreeCell
  • CheckBoxTreeItem
  • CheckBoxTreeItem.TreeModificationEvent
  • CheckBoxTreeTableCell
  • CheckedInputStream
  • CheckedOutputStream
  • CheckMenuItem
  • Checksum
  • Choice
  • ChoiceBox
  • ChoiceBoxListCell
  • ChoiceBoxSkin
  • ChoiceBoxTableCell
  • ChoiceBoxTreeCell
  • ChoiceBoxTreeTableCell
  • ChoiceCallback
  • ChoiceDialog
  • ChoiceFormat
  • Chromaticity
  • ChronoField
  • ChronoLocalDate
  • ChronoLocalDateTime
  • Chronology
  • ChronoPeriod
  • ChronoUnit
  • ChronoZonedDateTime
  • Cipher
  • CipherInputStream
  • CipherOutputStream
  • CipherSpi
  • Circle
  • Class
  • ClassCastException
  • ClassCircularityError
  • ClassDeclarationTree
  • ClassDefinition
  • ClassDesc
  • ClassDoc
  • ClassExpressionTree
  • ClassFileTransformer
  • ClassFilter
  • ClassFormatError
  • ClassLoader
  • ClassLoaderReference
  • ClassLoaderRepository
  • ClassLoadingMXBean
  • ClassNotFoundException
  • ClassNotLoadedException
  • ClassNotPreparedException
  • ClassObjectReference
  • ClassPrepareEvent
  • ClassPrepareRequest
  • ClassTree
  • ClassType
  • ClassUnloadEvent
  • ClassUnloadRequest
  • ClassValue
  • Cleaner
  • Cleaner.Cleanable
  • ClientInfoStatus
  • ClientRequestInfo
  • ClientRequestInfoOperations
  • ClientRequestInterceptor
  • ClientRequestInterceptorOperations
  • Clip
  • Clipboard
  • Clipboard
  • ClipboardContent
  • ClipboardOwner
  • ClipboardService
  • Clob
  • Clock
  • Cloneable
  • CloneNotSupportedException
  • Closeable
  • ClosedByInterruptException
  • ClosedChannelException
  • ClosedConnectionException
  • ClosedDirectoryStreamException
  • ClosedFileSystemException
  • ClosedSelectorException
  • ClosedWatchServiceException
  • ClosePath
  • CMMException
  • Codec
  • CodecFactory
  • CodecFactoryHelper
  • CodecFactoryOperations
  • CodecOperations
  • CoderMalfunctionError
  • CoderResult
  • CODESET_INCOMPATIBLE
  • CodeSets
  • CodeSigner
  • CodeSource
  • CodingErrorAction
  • CollapsedStringAdapter
  • Collation
  • CollationElementIterator
  • CollationKey
  • Collator
  • CollatorProvider
  • Collection
  • CollectionCertStoreParameters
  • Collections
  • Collector
  • Collector.Characteristics
  • Collectors
  • Color
  • Color
  • ColorAdjust
  • ColorChooserComponentFactory
  • ColorChooserUI
  • ColorConverter
  • ColorConvertOp
  • ColorInput
  • ColorModel
  • ColorPicker
  • ColorPickerSkin
  • ColorSelectionModel
  • ColorSpace
  • ColorSupported
  • ColorType
  • ColorUIResource
  • ColumnConstraints
  • ComboBox
  • ComboBoxBase
  • ComboBoxBaseSkin
  • ComboBoxEditor
  • ComboBoxListCell
  • ComboBoxListViewSkin
  • ComboBoxModel
  • ComboBoxPopupControl
  • ComboBoxTableCell
  • ComboBoxTreeCell
  • ComboBoxTreeTableCell
  • ComboBoxUI
  • ComboPopup
  • COMM_FAILURE
  • CommandAPDU
  • CommandInfo
  • CommandMap
  • CommandObject
  • Comment
  • Comment
  • CommentTree
  • CommonDataSource
  • CommunicationException
  • Comparable
  • Comparator
  • Compilable
  • CompilationMXBean
  • CompilationUnitTree
  • CompilationUnitTree
  • CompiledScript
  • Compiler
  • CompletableFuture
  • CompletableFuture.AsynchronousCompletionTask
  • Completion
  • CompletionException
  • CompletionHandler
  • Completions
  • CompletionService
  • CompletionStage
  • CompletionStatus
  • CompletionStatusHelper
  • Component
  • Component.BaselineResizeBehavior
  • ComponentAdapter
  • ComponentColorModel
  • ComponentEvent
  • ComponentIdHelper
  • ComponentInputMap
  • ComponentInputMapUIResource
  • ComponentListener
  • ComponentOrientation
  • ComponentSampleModel
  • ComponentUI
  • ComponentView
  • Composite
  • CompositeContext
  • CompositeData
  • CompositeDataInvocationHandler
  • CompositeDataSupport
  • CompositeDataView
  • CompositeGuardingDynamicLinker
  • CompositeName
  • CompositeType
  • CompositeTypeBasedGuardingDynamicLinker
  • CompositeView
  • CompoundAssignmentTree
  • CompoundAssignmentTree
  • CompoundBorder
  • CompoundControl
  • CompoundControl.Type
  • CompoundEdit
  • CompoundName
  • CompoundSelector
  • Compression
  • ConcurrentHashMap
  • ConcurrentHashMap.KeySetView
  • ConcurrentLinkedDeque
  • ConcurrentLinkedQueue
  • ConcurrentMap
  • ConcurrentModificationException
  • ConcurrentNavigableMap
  • ConcurrentSkipListMap
  • ConcurrentSkipListSet
  • Condition
  • ConditionalExpressionTree
  • ConditionalExpressionTree
  • ConditionalFeature
  • ConditionalLoopTree
  • ConfigFile
  • Configuration
  • Configuration
  • Configuration.Parameters
  • ConfigurationException
  • ConfigurationSpi
  • ConfirmationCallback
  • ConnectException
  • ConnectException
  • ConnectIOException
  • Connection
  • Connection
  • ConnectionBuilder
  • ConnectionEvent
  • ConnectionEventListener
  • ConnectionPendingException
  • ConnectionPoolDataSource
  • Connector
  • Connector.Argument
  • Connector.BooleanArgument
  • Connector.IntegerArgument
  • Connector.SelectedArgument
  • Connector.StringArgument
  • Console
  • ConsoleHandler
  • ConstantCallSite
  • ConstraintsBase
  • Constructor
  • ConstructorDoc
  • ConstructorParameters
  • ConstructorProperties
  • Consumer
  • Container
  • ContainerAdapter
  • ContainerEvent
  • ContainerListener
  • ContainerOrderFocusTraversalPolicy
  • ContentDisplay
  • ContentHandler
  • ContentHandler
  • ContentHandlerFactory
  • ContentModel
  • ContentSigner
  • ContentSignerParameters
  • Context
  • Context
  • ContextList
  • ContextMenu
  • ContextMenuEvent
  • ContextMenuSkin
  • ContextNotEmptyException
  • ContextualRenderedImageFactory
  • ContinueTree
  • ContinueTree
  • Control
  • Control
  • Control
  • Control.Type
  • ControlFactory
  • ControllerEventListener
  • ConversionComparator
  • ConversionComparator.Comparison
  • ConvolveOp
  • CookieHandler
  • CookieHolder
  • CookieManager
  • CookiePolicy
  • CookieStore
  • Copies
  • CopiesSupported
  • CopyOnWriteArrayList
  • CopyOnWriteArraySet
  • CopyOption
  • CornerRadii
  • CountDownLatch
  • CountedCompleter
  • Counter
  • CounterMonitor
  • CounterMonitorMBean
  • CRC32
  • CRC32C
  • CredentialException
  • CredentialExpiredException
  • CredentialNotFoundException
  • CRL
  • CRLException
  • CRLReason
  • CRLSelector
  • CropImageFilter
  • CryptoPrimitive
  • CSS
  • CSS.Attribute
  • CSS2Properties
  • CSSCharsetRule
  • CSSFontFaceRule
  • CSSImportRule
  • CSSMediaRule
  • CssMetaData
  • CSSPageRule
  • CssParser
  • CssParser.ParseError
  • CssParser.ParseError.InlineStyleParsingError
  • CssParser.ParseError.PropertySetError
  • CssParser.ParseError.StringParsingError
  • CssParser.ParseError.StylesheetParsingError
  • CSSPrimitiveValue
  • CSSRule
  • CSSRuleList
  • CSSStyleDeclaration
  • CSSStyleRule
  • CSSStyleSheet
  • CSSUnknownRule
  • CSSValue
  • CSSValueList
  • CTX_RESTRICT_SCOPE
  • CubicCurve
  • CubicCurve2D
  • CubicCurve2D.Double
  • CubicCurve2D.Float
  • CubicCurveTo
  • CullFace
  • Currency
  • CurrencyNameProvider
  • CurrencyStringConverter
  • Current
  • Current
  • Current
  • CurrentHelper
  • CurrentHelper
  • CurrentHelper
  • CurrentHolder
  • CurrentOperations
  • CurrentOperations
  • CurrentOperations
  • Cursor
  • Cursor
  • CursorConverter
  • Customizer
  • CustomMarshal
  • CustomMenuItem
  • CustomValue
  • CycleMethod
  • CyclicBarrier
  • Cylinder
  • Data
  • DATA_CONVERSION
  • DatabaseMetaData
  • DataBindingException
  • DataBuffer
  • DataBufferByte
  • DataBufferDouble
  • DataBufferFloat
  • DataBufferInt
  • DataBufferShort
  • DataBufferUShort
  • DataContentHandler
  • DataContentHandlerFactory
  • DataFlavor
  • DataFormat
  • DataFormatException
  • DatagramChannel
  • DatagramPacket
  • DatagramSocket
  • DatagramSocketImpl
  • DatagramSocketImplFactory
  • DataHandler
  • DataInput
  • DataInputStream
  • DataInputStream
  • DataLine
  • DataLine.Info
  • DataOutput
  • DataOutputStream
  • DataOutputStream
  • DataSource
  • DataSource
  • DataTruncation
  • DatatypeConfigurationException
  • DatatypeConstants
  • DatatypeConstants.Field
  • DatatypeConverter
  • DatatypeConverterInterface
  • DatatypeFactory
  • Date
  • Date
  • DateCell
  • DateCellSkin
  • DateFormat
  • DateFormat.Field
  • DateFormatProvider
  • DateFormatSymbols
  • DateFormatSymbolsProvider
  • DateFormatter
  • DatePicker
  • DatePickerSkin
  • DateStringConverter
  • DateTimeAtCompleted
  • DateTimeAtCreation
  • DateTimeAtProcessing
  • DateTimeException
  • DateTimeFormatter
  • DateTimeFormatterBuilder
  • DateTimeParseException
  • DateTimeStringConverter
  • DateTimeSyntax
  • DayOfWeek
  • DebuggerTree
  • DebugGraphics
  • DecimalFormat
  • DecimalFormatSymbols
  • DecimalFormatSymbolsProvider
  • DecimalStyle
  • Declaration
  • DeclarationSnippet
  • DeclaredType
  • DeclHandler
  • DefaultBoundedRangeModel
  • DefaultButtonModel
  • DefaultCaret
  • DefaultCellEditor
  • DefaultColorSelectionModel
  • DefaultComboBoxModel
  • DefaultDesktopManager
  • DefaultEditorKit
  • DefaultEditorKit.BeepAction
  • DefaultEditorKit.CopyAction
  • DefaultEditorKit.CutAction
  • DefaultEditorKit.DefaultKeyTypedAction
  • DefaultEditorKit.InsertBreakAction
  • DefaultEditorKit.InsertContentAction
  • DefaultEditorKit.InsertTabAction
  • DefaultEditorKit.PasteAction
  • DefaultFocusManager
  • DefaultFocusTraversalPolicy
  • DefaultFormatter
  • DefaultFormatterFactory
  • DefaultHandler
  • DefaultHandler2
  • DefaultHighlighter
  • DefaultHighlighter.DefaultHighlightPainter
  • DefaultInternalObjectFilter
  • DefaultKeyboardFocusManager
  • DefaultListCellRenderer
  • DefaultListCellRenderer.UIResource
  • DefaultListModel
  • DefaultListSelectionModel
  • DefaultLoaderRepository
  • DefaultLoaderRepository
  • DefaultMenuLayout
  • DefaultMetalTheme
  • DefaultMutableTreeNode
  • DefaultPersistenceDelegate
  • DefaultProperty
  • DefaultRowSorter
  • DefaultRowSorter.ModelWrapper
  • DefaultSingleSelectionModel
  • DefaultStringConverter
  • DefaultStyledDocument
  • DefaultStyledDocument.AttributeUndoableEdit
  • DefaultStyledDocument.ElementSpec
  • DefaultTableCellRenderer
  • DefaultTableCellRenderer.UIResource
  • DefaultTableColumnModel
  • DefaultTableModel
  • DefaultTextUI
  • DefaultTreeCellEditor
  • DefaultTreeCellRenderer
  • DefaultTreeModel
  • DefaultTreeSelectionModel
  • DefaultValidationEventHandler
  • DefinitionKind
  • DefinitionKindHelper
  • Deflater
  • DeflaterInputStream
  • DeflaterOutputStream
  • Delayed
  • DelayQueue
  • Delegate
  • Delegate
  • Delegate
  • DelegationPermission
  • 已过时的
  • DeprecatedTree
  • DepthTest
  • Deque
  • DeriveColorConverter
  • DeriveSizeConverter
  • Descriptor
  • DescriptorAccess
  • DescriptorKey
  • DescriptorRead
  • DescriptorSupport
  • DESedeKeySpec
  • DesignMode
  • DESKeySpec
  • Desktop
  • Desktop.Action
  • DesktopIconUI
  • DesktopManager
  • DesktopPaneUI
  • Destination
  • Destroyable
  • DestroyFailedException
  • Detail
  • DetailEntry
  • DGC
  • DHGenParameterSpec
  • DHKey
  • DHParameterSpec
  • DHPrivateKey
  • DHPrivateKeySpec
  • DHPublicKey
  • DHPublicKeySpec
  • Diag
  • Diagnostic
  • Diagnostic
  • Diagnostic.Kind
  • Diagnostic.Kind
  • DiagnosticCollector
  • DiagnosticCommandMBean
  • DiagnosticListener
  • DiagnosticListener
  • Dialog
  • Dialog
  • Dialog.ModalExclusionType
  • Dialog.ModalityType
  • DialogEvent
  • DialogPane
  • DialogTypeSelection
  • Dictionary
  • DigestException
  • DigestInputStream
  • DigestMethod
  • DigestMethodParameterSpec
  • DigestOutputStream
  • Dimension
  • Dimension2D
  • Dimension2D
  • DimensionUIResource
  • DirContext
  • DirectColorModel
  • DirectExecutionControl
  • DirectiveTree
  • DirectoryChooser
  • DirectoryIteratorException
  • DirectoryManager
  • DirectoryNotEmptyException
  • DirectoryStream
  • DirectoryStream.Filter
  • DirObjectFactory
  • DirStateFactory
  • DirStateFactory.Result
  • DISCARDING
  • Dispatch
  • DisplacementMap
  • DisplayMode
  • DnDConstants
  • Doc
  • Doc
  • DocAttribute
  • DocAttributeSet
  • DocCommentTree
  • DocErrorReporter
  • DocFlavor
  • DocFlavor.BYTE_ARRAY
  • DocFlavor.CHAR_ARRAY
  • DocFlavor.INPUT_STREAM
  • DocFlavor.READER
  • DocFlavor.SERVICE_FORMATTED
  • DocFlavor.STRING
  • DocFlavor.URL
  • Doclet
  • Doclet
  • Doclet.Option
  • Doclet.Option.Kind
  • DocletEnvironment
  • DocletEnvironment.ModuleMode
  • DocPrintJob
  • DocRootTree
  • DocSourcePositions
  • DocTree
  • DocTree.Kind
  • DocTreeFactory
  • DocTreePath
  • DocTreePathScanner
  • DocTrees
  • DocTreeScanner
  • DocTreeVisitor
  • Document
  • Document
  • DocumentationTool
  • DocumentationTool.DocumentationTask
  • DocumentationTool.Location
  • DocumentBuilder
  • DocumentBuilderFactory
  • DocumentCSS
  • Documented
  • DocumentEvent
  • DocumentEvent
  • DocumentEvent.ElementChange
  • DocumentEvent.EventType
  • DocumentFilter
  • DocumentFilter.FilterBypass
  • DocumentFragment
  • DocumentHandler
  • DocumentListener
  • DocumentName
  • DocumentParser
  • DocumentRange
  • DocumentStyle
  • DocumentTraversal
  • DocumentType
  • DocumentView
  • DomainCombiner
  • DomainLoadStoreParameter
  • DomainManager
  • DomainManagerOperations
  • DOMConfiguration
  • DOMCryptoContext
  • DOMError
  • DOMErrorHandler
  • DOMException
  • DomHandler
  • DOMImplementation
  • DOMImplementationCSS
  • DOMImplementationList
  • DOMImplementationLS
  • DOMImplementationRegistry
  • DOMImplementationSource
  • DOMLocator
  • DOMLocator
  • DOMResult
  • DOMSignContext
  • DOMSource
  • DOMStringList
  • DOMStructure
  • DOMURIReference
  • DOMValidateContext
  • DosFileAttributes
  • DosFileAttributeView
  • Double
  • DoubleAccumulator
  • DoubleAdder
  • DoubleBinaryOperator
  • DoubleBinding
  • DoubleBuffer
  • DoubleConsumer
  • DoubleExpression
  • DoubleFunction
  • DoubleHolder
  • DoublePredicate
  • DoubleProperty
  • DoublePropertyBase
  • DoubleSeqHelper
  • DoubleSeqHolder
  • DoubleStream
  • DoubleStream.Builder
  • DoubleStringConverter
  • DoubleSummaryStatistics
  • DoubleSupplier
  • DoubleToIntFunction
  • DoubleToLongFunction
  • DoubleType
  • DoubleUnaryOperator
  • DoubleValue
  • DoWhileLoopTree
  • DoWhileLoopTree
  • DownloadService
  • DownloadService2
  • DownloadService2.ResourceSpec
  • DownloadServiceListener
  • Dragboard
  • DragEvent
  • DragGestureEvent
  • DragGestureListener
  • DragGestureRecognizer
  • DragSource
  • DragSourceAdapter
  • DragSourceContext
  • DragSourceDragEvent
  • DragSourceDropEvent
  • DragSourceEvent
  • DragSourceListener
  • DragSourceMotionListener
  • DrawMode
  • DrbgParameters
  • DrbgParameters.Capability
  • DrbgParameters.Instantiation
  • DrbgParameters.NextBytes
  • DrbgParameters.Reseed
  • Driver
  • DriverAction
  • DriverManager
  • DriverPropertyInfo
  • DropMode
  • DropShadow
  • DropTarget
  • DropTarget.DropTargetAutoScroller
  • DropTargetAdapter
  • DropTargetContext
  • DropTargetDragEvent
  • DropTargetDropEvent
  • DropTargetEvent
  • DropTargetListener
  • DSAGenParameterSpec
  • DSAKey
  • DSAKeyPairGenerator
  • DSAParameterSpec
  • DSAParams
  • DSAPrivateKey
  • DSAPrivateKeySpec
  • DSAPublicKey
  • DSAPublicKeySpec
  • DTD
  • DTD
  • DTDConstants
  • DTDHandler
  • DuplicateFormatFlagsException
  • DuplicateName
  • DuplicateNameHelper
  • DuplicateRequestException
  • Duration
  • Duration
  • Duration
  • DurationConverter
  • DynamicImplementation
  • DynamicImplementation
  • DynamicLinker
  • DynamicLinkerFactory
  • DynamicMBean
  • DynAny
  • DynAny
  • DynAnyFactory
  • DynAnyFactoryHelper
  • DynAnyFactoryOperations
  • DynAnyHelper
  • DynAnyOperations
  • DynAnySeqHelper
  • DynArray
  • DynArray
  • DynArrayHelper
  • DynArrayOperations
  • DynEnum
  • DynEnum
  • DynEnumHelper
  • DynEnumOperations
  • DynFixed
  • DynFixed
  • DynFixedHelper
  • DynFixedOperations
  • DynSequence
  • DynSequence
  • DynSequenceHelper
  • DynSequenceOperations
  • DynStruct
  • DynStruct
  • DynStructHelper
  • DynStructOperations
  • DynUnion
  • DynUnion
  • DynUnionHelper
  • DynUnionOperations
  • DynValue
  • DynValue
  • DynValueBox
  • DynValueBoxOperations
  • DynValueCommon
  • DynValueCommonOperations
  • DynValueHelper
  • DynValueOperations
  • ECField
  • ECFieldF2m
  • ECFieldFp
  • ECGenParameterSpec
  • ECKey
  • ECParameterSpec
  • ECPoint
  • ECPrivateKey
  • ECPrivateKeySpec
  • ECPublicKey
  • ECPublicKeySpec
  • EditorKit
  • Effect
  • EffectConverter
  • EffectConverter.DropShadowConverter
  • EffectConverter.InnerShadowConverter
  • Element
  • Element
  • Element
  • Element
  • Element
  • ElementCSSInlineStyle
  • ElementFilter
  • ElementIterator
  • ElementKind
  • ElementKindVisitor6
  • ElementKindVisitor7
  • ElementKindVisitor8
  • ElementKindVisitor9
  • Elements
  • Elements.Origin
  • ElementScanner6
  • ElementScanner7
  • ElementScanner8
  • ElementScanner9
  • ElementTraversal
  • ElementType
  • ElementVisitor
  • Ellipse
  • Ellipse2D
  • Ellipse2D.Double
  • Ellipse2D.Float
  • EllipticCurve
  • EmptyBorder
  • EmptyStackException
  • EmptyStatementTree
  • EmptyStatementTree
  • EncodedKeySpec
  • Encoder
  • Encoding
  • ENCODING_CDR_ENCAPS
  • EncryptedPrivateKeyInfo
  • EncryptionKey
  • EndDocument
  • EndElement
  • EndElementTree
  • Endpoint
  • EndpointContext
  • EndpointReference
  • EnhancedForLoopTree
  • Entity
  • Entity
  • EntityDeclaration
  • EntityReference
  • EntityReference
  • EntityResolver
  • EntityResolver2
  • EntityTree
  • Enum
  • EnumConstantNotPresentException
  • EnumControl
  • EnumControl.Type
  • EnumConverter
  • Enumeration
  • EnumMap
  • EnumSet
  • EnumSyntax
  • Environment
  • EOFException
  • EqualizerBand
  • Era
  • ErroneousSnippet
  • ErroneousTree
  • ErroneousTree
  • ErroneousTree
  • Error
  • ErrorHandler
  • ErrorListener
  • ErrorManager
  • ErrorType
  • EtchedBorder
  • EvalException
  • Event
  • Event
  • Event
  • Event
  • EventContext
  • EventDirContext
  • EventDispatchChain
  • EventDispatcher
  • EventException
  • EventFilter
  • EventHandler
  • EventHandler
  • EventID
  • EventIterator
  • EventListener
  • EventListener
  • EventListenerList
  • EventListenerProxy
  • EventObject
  • EventQueue
  • EventQueue
  • EventQueueMonitor
  • EventReaderDelegate
  • EventRequest
  • EventRequestManager
  • EventSet
  • EventSetDescriptor
  • EventTarget
  • EventTarget
  • EventType
  • ExcC14NParameterSpec
  • 异常
  • ExceptionDetailMessage
  • ExceptionEvent
  • ExceptionInInitializerError
  • ExceptionList
  • ExceptionListener
  • ExceptionRequest
  • Exchanger
  • Executable
  • ExecutableElement
  • ExecutableMemberDoc
  • ExecutableType
  • ExecutionControl
  • ExecutionControl.ClassBytecodes
  • ExecutionControl.ClassInstallException
  • ExecutionControl.EngineTerminationException
  • ExecutionControl.ExecutionControlException
  • ExecutionControl.InternalException
  • ExecutionControl.NotImplementedException
  • ExecutionControl.ResolutionException
  • ExecutionControl.RunException
  • ExecutionControl.StoppedException
  • ExecutionControl.UserException
  • ExecutionControlProvider
  • ExecutionEnv
  • ExecutionException
  • Executor
  • ExecutorCompletionService
  • Executors
  • ExecutorService
  • ExemptionMechanism
  • ExemptionMechanismException
  • ExemptionMechanismSpi
  • ExifGPSTagSet
  • ExifInteroperabilityTagSet
  • ExifParentTIFFTagSet
  • ExifTIFFTagSet
  • ExpandVetoException
  • ExportEntryTree
  • ExportException
  • ExportsTree
  • Expression
  • ExpressionSnippet
  • ExpressionStatementTree
  • ExpressionStatementTree
  • ExpressionTree
  • ExpressionTree
  • ExtendedGSSContext
  • ExtendedGSSCredential
  • ExtendedRequest
  • ExtendedResponse
  • ExtendedService
  • ExtendedSocketOptions
  • ExtendedSSLSession
  • Extension
  • ExtensionInstallerService
  • Externalizable
  • FactoryConfigurationError
  • FactoryConfigurationError
  • FadeTransition
  • FailedLoginException
  • FailOverExecutionControlProvider
  • FaultAction
  • FaxTIFFTagSet
  • FeatureDescriptor
  • Fidelity
  • Field
  • Field
  • FieldDoc
  • FieldNameHelper
  • FieldNameHelper
  • FieldPosition
  • FieldView
  • File
  • FileAlreadyExistsException
  • FileAttribute
  • FileAttributeView
  • FileCacheImageInputStream
  • FileCacheImageOutputStream
  • FileChannel
  • FileChannel.MapMode
  • FileChooser
  • FileChooser.ExtensionFilter
  • FileChooserUI
  • FileContents
  • FileDataSource
  • FileDescriptor
  • FileDialog
  • FileFilter
  • FileFilter
  • FileHandler
  • FileImageInputStream
  • FileImageOutputStream
  • FileInputStream
  • FileLock
  • FileLockInterruptionException
  • FileNameExtensionFilter
  • FilenameFilter
  • FileNameMap
  • FileNotFoundException
  • FileObject
  • FileOpenService
  • FileOutputStream
  • FileOwnerAttributeView
  • FilePermission
  • Filer
  • FileReader
  • FilerException
  • Files
  • FileSaveService
  • FilesEvent
  • FileStore
  • FileStoreAttributeView
  • FileSystem
  • FileSystemAlreadyExistsException
  • FileSystemException
  • FileSystemLoopException
  • FileSystemNotFoundException
  • FileSystemProvider
  • FileSystems
  • FileSystemView
  • FileTime
  • FileTypeDetector
  • FileTypeMap
  • FileView
  • FileVisitOption
  • FileVisitor
  • FileVisitResult
  • FileWriter
  • FillRule
  • FillTransition
  • Filter
  • Filter
  • Filter.Chain
  • FilteredImageSource
  • FilteredList
  • FilteredRowSet
  • FilterInputStream
  • FilterOutputStream
  • FilterReader
  • FilterWriter
  • FindException
  • Finishings
  • FixedHeightLayoutCache
  • FixedHolder
  • FlatteningPathIterator
  • FlavorEvent
  • FlavorException
  • FlavorListener
  • FlavorMap
  • FlavorTable
  • Float
  • FloatBinding
  • FloatBuffer
  • FloatControl
  • FloatControl.Type
  • FloatExpression
  • FloatHolder
  • FloatMap
  • FloatProperty
  • FloatPropertyBase
  • FloatSeqHelper
  • FloatSeqHolder
  • FloatStringConverter
  • FloatType
  • FloatValue
  • Flow
  • Flow.Processor
  • Flow.Publisher
  • Flow.Subscriber
  • Flow.Subscription
  • FlowLayout
  • FlowPane
  • FlowView
  • FlowView.FlowStrategy
  • Flushable
  • FocusAdapter
  • FocusEvent
  • FocusEvent.Cause
  • FocusListener
  • FocusManager
  • FocusModel
  • FocusTraversalPolicy
  • Font
  • Font
  • FontConverter
  • FontConverter.FontSizeConverter
  • FontConverter.FontStyleConverter
  • FontConverter.FontWeightConverter
  • FontCssMetaData
  • FontFace
  • FontFormatException
  • FontMetrics
  • FontPosture
  • FontRenderContext
  • FontSmoothingType
  • FontUIResource
  • FontWeight
  • ForInLoopTree
  • ForkJoinPool
  • ForkJoinPool.ForkJoinWorkerThreadFactory
  • ForkJoinPool.ManagedBlocker
  • ForkJoinTask
  • ForkJoinWorkerThread
  • ForLoopTree
  • ForLoopTree
  • Format
  • Format.Field
  • FormatConversionProvider
  • FormatFlagsConversionMismatchException
  • FormatMismatch
  • FormatMismatchHelper
  • FormatStringConverter
  • FormatStyle
  • Formattable
  • FormattableFlags
  • Formatter
  • Formatter
  • Formatter.BigDecimalLayoutForm
  • FormatterClosedException
  • FormSubmitEvent
  • FormSubmitEvent.MethodType
  • FormView
  • ForOfLoopTree
  • ForwardingFileObject
  • ForwardingJavaFileManager
  • ForwardingJavaFileObject
  • ForwardRequest
  • ForwardRequest
  • ForwardRequestHelper
  • ForwardRequestHelper
  • Frame
  • FREE_MEM
  • Function
  • FunctionalInterface
  • FunctionCallTree
  • FunctionDeclarationTree
  • FunctionExpressionTree
  • Future
  • FutureTask
  • FXCollections
  • FXML
  • FXMLLoader
  • FXPermission
  • GapContent
  • GarbageCollectionNotificationInfo
  • GarbageCollectorMXBean
  • GarbageCollectorMXBean
  • GatheringByteChannel
  • GaugeMonitor
  • GaugeMonitorMBean
  • GaussianBlur
  • GcInfo
  • GCMParameterSpec
  • GeneralPath
  • GeneralSecurityException
  • Generated
  • Generated
  • GenericArrayType
  • GenericDeclaration
  • GenericSignatureFormatError
  • GeoTIFFTagSet
  • GestureEvent
  • Glow
  • GlyphJustificationInfo
  • GlyphMetrics
  • GlyphVector
  • GlyphView
  • GlyphView.GlyphPainter
  • GotoTree
  • GradientPaint
  • GraphicAttribute
  • Graphics
  • Graphics2D
  • GraphicsConfigTemplate
  • GraphicsConfiguration
  • GraphicsContext
  • GraphicsDevice
  • GraphicsDevice.WindowTranslucency
  • GraphicsEnvironment
  • GrayFilter
  • GregorianCalendar
  • GridBagConstraints
  • GridBagLayout
  • GridBagLayoutInfo
  • GridLayout
  • GridPane
  • Group
  • Group
  • GroupLayout
  • GroupLayout.Alignment
  • GroupPrincipal
  • GSSContext
  • GSSCredential
  • GSSException
  • GSSManager
  • GSSName
  • GSSUtil
  • Guard
  • GuardedInvocation
  • GuardedInvocationTransformer
  • GuardedObject
  • GuardingDynamicLinker
  • GuardingDynamicLinkerExporter
  • GuardingTypeConverterFactory
  • Guards
  • GUIInitializedListener
  • GZIPInputStream
  • GZIPOutputStream
  • Handler
  • Handler
  • HandlerBase
  • HandlerChain
  • HandlerResolver
  • HandlerResult
  • HandshakeCompletedEvent
  • HandshakeCompletedListener
  • HasControls
  • HashAttributeSet
  • HashDocAttributeSet
  • HashMap
  • HashPrintJobAttributeSet
  • HashPrintRequestAttributeSet
  • HashPrintServiceAttributeSet
  • HashSet
  • Hashtable
  • HBox
  • Headers
  • HeadlessException
  • HexBinaryAdapter
  • HiddenTree
  • HierarchyBoundsAdapter
  • HierarchyBoundsListener
  • HierarchyEvent
  • HierarchyListener
  • Highlighter
  • Highlighter.Highlight
  • Highlighter.HighlightPainter
  • HijrahChronology
  • HijrahDate
  • HijrahEra
  • HitInfo
  • HLineTo
  • HMACParameterSpec
  • Holder
  • HOLDING
  • HorizontalDirection
  • HostnameVerifier
  • HostServices
  • HotSpotDiagnosticMXBean
  • HPos
  • HTML
  • HTML.Attribute
  • HTML.Tag
  • HTML.UnknownTag
  • HTMLAnchorElement
  • HTMLAppletElement
  • HTMLAreaElement
  • HTMLBaseElement
  • HTMLBaseFontElement
  • HTMLBodyElement
  • HTMLBRElement
  • HTMLButtonElement
  • HTMLCollection
  • HTMLDirectoryElement
  • HTMLDivElement
  • HTMLDListElement
  • HTMLDocument
  • HTMLDocument
  • HTMLDocument.Iterator
  • HTMLDOMImplementation
  • HTMLEditor
  • HTMLEditorKit
  • HTMLEditorKit.HTMLFactory
  • HTMLEditorKit.HTMLTextAction
  • HTMLEditorKit.InsertHTMLTextAction
  • HTMLEditorKit.LinkController
  • HTMLEditorKit.Parser
  • HTMLEditorKit.ParserCallback
  • HTMLEditorSkin
  • HTMLEditorSkin.Command
  • HTMLElement
  • HTMLFieldSetElement
  • HTMLFontElement
  • HTMLFormElement
  • HTMLFrameElement
  • HTMLFrameHyperlinkEvent
  • HTMLFrameSetElement
  • HTMLHeadElement
  • HTMLHeadingElement
  • HTMLHRElement
  • HTMLHtmlElement
  • HTMLIFrameElement
  • HTMLImageElement
  • HTMLInputElement
  • HTMLIsIndexElement
  • HTMLLabelElement
  • HTMLLegendElement
  • HTMLLIElement
  • HTMLLinkElement
  • HTMLMapElement
  • HTMLMenuElement
  • HTMLMetaElement
  • HTMLModElement
  • HTMLObjectElement
  • HTMLOListElement
  • HTMLOptGroupElement
  • HTMLOptionElement
  • HTMLParagraphElement
  • HTMLParamElement
  • HTMLPreElement
  • HTMLQuoteElement
  • HTMLScriptElement
  • HTMLSelectElement
  • HTMLStyleElement
  • HTMLTableCaptionElement
  • HTMLTableCellElement
  • HTMLTableColElement
  • HTMLTableElement
  • HTMLTableRowElement
  • HTMLTableSectionElement
  • HTMLTextAreaElement
  • HTMLTitleElement
  • HTMLUListElement
  • HTMLWriter
  • HTTPBinding
  • HttpClient
  • HttpClient.Builder
  • HttpClient.Redirect
  • HttpClient.Version
  • HttpContext
  • HttpContext
  • HttpCookie
  • HTTPException
  • HttpExchange
  • HttpExchange
  • HttpHandler
  • HttpHandler
  • HttpHeaders
  • HttpPrincipal
  • HttpRequest
  • HttpRequest.BodyProcessor
  • HttpRequest.Builder
  • HttpResponse
  • HttpResponse.BodyHandler
  • HttpResponse.BodyProcessor
  • HttpResponse.MultiProcessor
  • HttpRetryException
  • HttpsConfigurator
  • HttpServer
  • HttpServerProvider
  • HttpsExchange
  • HttpsParameters
  • HttpsServer
  • HttpsURLConnection
  • HttpTimeoutException
  • HttpURLConnection
  • Hyperlink
  • HyperlinkEvent
  • HyperlinkEvent.EventType
  • HyperlinkListener
  • HyperlinkSkin
  • ICC_ColorSpace
  • ICC_Profile
  • ICC_ProfileGray
  • ICC_ProfileRGB
  • Icon
  • IconUIResource
  • IconView
  • ID_ASSIGNMENT_POLICY_ID
  • ID_UNIQUENESS_POLICY_ID
  • IdAssignmentPolicy
  • IdAssignmentPolicyOperations
  • IdAssignmentPolicyValue
  • IdentifierHelper
  • IdentifierTree
  • IdentifierTree
  • IdentifierTree
  • Identity
  • IdentityHashMap
  • IdentityScope
  • IDLEntity
  • IDLType
  • IDLTypeHelper
  • IDLTypeOperations
  • IDN
  • IdUniquenessPolicy
  • IdUniquenessPolicyOperations
  • IdUniquenessPolicyValue
  • IfTree
  • IfTree
  • IIOByteBuffer
  • IIOException
  • IIOImage
  • IIOInvalidTreeException
  • IIOMetadata
  • IIOMetadataController
  • IIOMetadataFormat
  • IIOMetadataFormatImpl
  • IIOMetadataNode
  • IIOParam
  • IIOParamController
  • IIOReadProgressListener
  • IIOReadUpdateListener
  • IIOReadWarningListener
  • IIORegistry
  • IIOServiceProvider
  • IIOWriteProgressListener
  • IIOWriteWarningListener
  • IllegalAccessError
  • IllegalAccessException
  • IllegalArgumentException
  • IllegalBlockingModeException
  • IllegalBlockSizeException
  • IllegalCallerException
  • IllegalChannelGroupException
  • IllegalCharsetNameException
  • IllegalClassFormatException
  • IllegalComponentStateException
  • IllegalConnectorArgumentsException
  • IllegalFormatCodePointException
  • IllegalFormatConversionException
  • IllegalFormatException
  • IllegalFormatFlagsException
  • IllegalFormatPrecisionException
  • IllegalFormatWidthException
  • IllegalMonitorStateException
  • IllegalPathStateException
  • IllegalReceiveException
  • IllegalSelectorException
  • IllegalStateException
  • IllegalThreadStateException
  • IllegalUnbindException
  • IllformedLocaleException
  • Image
  • Image
  • ImageCapabilities
  • ImageConsumer
  • ImageCursor
  • ImageFilter
  • ImageGraphicAttribute
  • ImageIcon
  • ImageInput
  • ImageInputStream
  • ImageInputStreamImpl
  • ImageInputStreamSpi
  • ImageIO
  • ImageObserver
  • ImageOutputStream
  • ImageOutputStreamImpl
  • ImageOutputStreamSpi
  • ImagePattern
  • ImageProducer
  • ImageReader
  • ImageReaderSpi
  • ImageReaderWriterSpi
  • ImageReadParam
  • ImageTranscoder
  • ImageTranscoderSpi
  • ImageTypeSpecifier
  • ImageView
  • ImageView
  • ImageWriteParam
  • ImageWriter
  • ImageWriterSpi
  • ImagingOpException
  • ImmutableDescriptor
  • IMP_LIMIT
  • IMPLICIT_ACTIVATION_POLICY_ID
  • ImplicitActivationPolicy
  • ImplicitActivationPolicyOperations
  • ImplicitActivationPolicyValue
  • ImportEntryTree
  • ImportSnippet
  • ImportTree
  • InaccessibleObjectException
  • INACTIVE
  • IncompatibleClassChangeError
  • IncompatibleThreadStateException
  • IncompleteAnnotationException
  • InconsistentDebugInfoException
  • InconsistentTypeCode
  • InconsistentTypeCode
  • InconsistentTypeCodeHelper
  • IndexColorModel
  • IndexedCell
  • IndexedPropertyChangeEvent
  • IndexedPropertyDescriptor
  • IndexOutOfBoundsException
  • IndexRange
  • IndexTree
  • IndirectionException
  • Inet4Address
  • Inet6Address
  • InetAddress
  • InetSocketAddress
  • Inflater
  • InflaterInputStream
  • InflaterOutputStream
  • InheritableThreadLocal
  • InheritDocTree
  • Inherited
  • InitialContext
  • InitialContextFactory
  • InitialContextFactoryBuilder
  • InitialDirContext
  • Initializable
  • INITIALIZE
  • InitialLdapContext
  • InitParam
  • InlineTagTree
  • InlineView
  • InnerShadow
  • InputContext
  • InputEvent
  • InputEvent
  • InputMap
  • InputMapUIResource
  • InputMethod
  • InputMethodContext
  • InputMethodDescriptor
  • InputMethodEvent
  • InputMethodEvent
  • InputMethodHighlight
  • InputMethodHighlight
  • InputMethodListener
  • InputMethodRequests
  • InputMethodRequests
  • InputMethodTextRun
  • InputMismatchException
  • InputSource
  • InputStream
  • InputStream
  • InputStream
  • InputStreamReader
  • InputSubset
  • InputVerifier
  • InquireSecContextPermission
  • InquireType
  • Insets
  • Insets
  • InsetsConverter
  • InsetsConverter.SequenceConverter
  • InsetsUIResource
  • InstanceAlreadyExistsException
  • InstanceNotFoundException
  • InstanceOfTree
  • InstanceOfTree
  • Instant
  • InstantiationError
  • InstantiationException
  • Instrument
  • Instrumentation
  • InsufficientResourcesException
  • IntBinaryOperator
  • IntBuffer
  • IntConsumer
  • Integer
  • IntegerBinding
  • IntegerExpression
  • IntegerProperty
  • IntegerPropertyBase
  • IntegerStringConverter
  • IntegerSyntax
  • IntegerType
  • IntegerValue
  • IntegrationService
  • Interceptor
  • InterceptorOperations
  • InterfaceAddress
  • InterfaceType
  • INTERNAL
  • InternalError
  • InternalException
  • InternalFrameAdapter
  • InternalFrameEvent
  • InternalFrameFocusTraversalPolicy
  • InternalFrameListener
  • InternalFrameUI
  • InternationalFormatter
  • Interpolatable
  • Interpolator
  • InterruptedByTimeoutException
  • InterruptedException
  • InterruptedIOException
  • InterruptedNamingException
  • InterruptibleChannel
  • IntersectionType
  • IntersectionTypeTree
  • INTF_REPOS
  • IntFunction
  • IntHolder
  • IntPredicate
  • IntrospectionException
  • IntrospectionException
  • Introspector
  • IntStream
  • IntStream.Builder
  • IntSummaryStatistics
  • IntSupplier
  • IntToDoubleFunction
  • IntToLongFunction
  • IntUnaryOperator
  • INV_FLAG
  • INV_IDENT
  • INV_OBJREF
  • INV_POLICY
  • Invalid
  • INVALID_ACTIVITY
  • INVALID_TRANSACTION
  • InvalidActivityException
  • InvalidAddress
  • InvalidAddressHelper
  • InvalidAddressHolder
  • InvalidAlgorithmParameterException
  • InvalidApplicationException
  • InvalidationListener
  • InvalidAttributeIdentifierException
  • InvalidAttributesException
  • InvalidAttributeValueException
  • InvalidAttributeValueException
  • InvalidClassException
  • InvalidCodeIndexException
  • InvalidDnDOperationException
  • InvalidKeyException
  • InvalidKeyException
  • InvalidKeySpecException
  • InvalidLineNumberException
  • InvalidMarkException
  • InvalidMidiDataException
  • InvalidModuleDescriptorException
  • InvalidModuleException
  • InvalidName
  • InvalidName
  • InvalidName
  • InvalidNameException
  • InvalidNameHelper
  • InvalidNameHelper
  • InvalidNameHelper
  • InvalidNameHolder
  • InvalidObjectException
  • InvalidOpenTypeException
  • InvalidParameterException
  • InvalidParameterSpecException
  • InvalidPathException
  • InvalidPolicy
  • InvalidPolicyHelper
  • InvalidPreferencesFormatException
  • InvalidPropertiesFormatException
  • InvalidRelationIdException
  • InvalidRelationServiceException
  • InvalidRelationTypeException
  • InvalidRequestStateException
  • InvalidRoleInfoException
  • InvalidRoleValueException
  • InvalidSearchControlsException
  • InvalidSearchFilterException
  • InvalidSeq
  • InvalidSlot
  • InvalidSlotHelper
  • InvalidStackFrameException
  • InvalidStreamException
  • InvalidTargetObjectTypeException
  • InvalidTransactionException
  • InvalidTypeException
  • InvalidTypeForEncoding
  • InvalidTypeForEncodingHelper
  • InvalidValue
  • InvalidValue
  • InvalidValueHelper
  • Invocable
  • InvocationEvent
  • InvocationException
  • InvocationHandler
  • InvocationTargetException
  • InvokeHandler
  • Invoker
  • IOError
  • IOException
  • IOR
  • IORHelper
  • IORHolder
  • IORInfo
  • IORInfoOperations
  • IORInterceptor
  • IORInterceptor_3_0
  • IORInterceptor_3_0Helper
  • IORInterceptor_3_0Holder
  • IORInterceptor_3_0Operations
  • IORInterceptorOperations
  • IRObject
  • IRObjectOperations
  • IsoChronology
  • IsoEra
  • IsoFields
  • IstringHelper
  • ItemEvent
  • ItemListener
  • ItemSelectable
  • Iterable
  • Iterator
  • IvParameterSpec
  • JapaneseChronology
  • JapaneseDate
  • JapaneseEra
  • JApplet
  • JarEntry
  • JarException
  • JarFile
  • JarInputStream
  • JarOutputStream
  • JarSigner
  • JarSigner.Builder
  • JarSignerException
  • JarURLConnection
  • JavaBean
  • JavaBeanBooleanProperty
  • JavaBeanBooleanPropertyBuilder
  • JavaBeanDoubleProperty
  • JavaBeanDoublePropertyBuilder
  • JavaBeanFloatProperty
  • JavaBeanFloatPropertyBuilder
  • JavaBeanIntegerProperty
  • JavaBeanIntegerPropertyBuilder
  • JavaBeanLongProperty
  • JavaBeanLongPropertyBuilder
  • JavaBeanObjectProperty
  • JavaBeanObjectPropertyBuilder
  • JavaBeanProperty
  • JavaBeanStringProperty
  • JavaBeanStringPropertyBuilder
  • JavaCompiler
  • JavaCompiler.CompilationTask
  • JavacTask
  • JavaFileManager
  • JavaFileManager.Location
  • JavaFileObject
  • JavaFileObject.Kind
  • JavaFXBuilderFactory
  • JavaShellToolBuilder
  • JAXB
  • JAXBContext
  • JAXBContextFactory
  • JAXBElement
  • JAXBElement.GlobalScope
  • JAXBException
  • JAXBIntrospector
  • JAXBPermission
  • JAXBResult
  • JAXBSource
  • JButton
  • JCheckBox
  • JCheckBoxMenuItem
  • JColorChooser
  • JComboBox
  • JComboBox.KeySelectionManager
  • JComponent
  • JConsoleContext
  • JConsoleContext.ConnectionState
  • JConsolePlugin
  • JdbcRowSet
  • JDBCType
  • JDesktopPane
  • JDialog
  • JdiDefaultExecutionControl
  • JdiExecutionControl
  • JdiExecutionControlProvider
  • JdiInitiator
  • JDIPermission
  • JEditorPane
  • JFileChooser
  • JFormattedTextField
  • JFormattedTextField.AbstractFormatter
  • JFormattedTextField.AbstractFormatterFactory
  • JFrame
  • JFXPanel
  • JInternalFrame
  • JInternalFrame.JDesktopIcon
  • JLabel
  • JLayer
  • JLayeredPane
  • JList
  • JList.DropLocation
  • JMenu
  • JMenuBar
  • JMenuItem
  • JMException
  • JMRuntimeException
  • JMX
  • JMXAddressable
  • JMXAuthenticator
  • JMXConnectionNotification
  • JMXConnector
  • JMXConnectorFactory
  • JMXConnectorProvider
  • JMXConnectorServer
  • JMXConnectorServerFactory
  • JMXConnectorServerMBean
  • JMXConnectorServerProvider
  • JMXPrincipal
  • JMXProviderException
  • JMXServerErrorException
  • JMXServiceURL
  • JndiLoginModule
  • JNLPRandomAccessFile
  • JobAttributes
  • JobAttributes.DefaultSelectionType
  • JobAttributes.DestinationType
  • JobAttributes.DialogType
  • JobAttributes.MultipleDocumentHandlingType
  • JobAttributes.SidesType
  • JobHoldUntil
  • JobImpressions
  • JobImpressionsCompleted
  • JobImpressionsSupported
  • JobKOctets
  • JobKOctetsProcessed
  • JobKOctetsSupported
  • JobMediaSheets
  • JobMediaSheetsCompleted
  • JobMediaSheetsSupported
  • JobMessageFromOperator
  • JobName
  • JobOriginatingUserName
  • JobPriority
  • JobPrioritySupported
  • JobSettings
  • JobSheets
  • JobState
  • JobStateReason
  • JobStateReasons
  • Joinable
  • JoinRowSet
  • JOptionPane
  • JPanel
  • JPasswordField
  • JPEGHuffmanTable
  • JPEGImageReadParam
  • JPEGImageWriteParam
  • JPEGQTable
  • JPopupMenu
  • JPopupMenu.Separator
  • JProgressBar
  • JRadioButton
  • JRadioButtonMenuItem
  • JRootPane
  • JScrollBar
  • JScrollPane
  • JSeparator
  • JSException
  • JShell
  • JShell.Builder
  • JShellException
  • JSlider
  • JSObject
  • JSObject
  • JSpinner
  • JSpinner.DateEditor
  • JSpinner.DefaultEditor
  • JSpinner.ListEditor
  • JSpinner.NumberEditor
  • JSplitPane
  • JTabbedPane
  • JTable
  • JTable.DropLocation
  • JTable.PrintMode
  • JTableHeader
  • JTextArea
  • JTextComponent
  • JTextComponent.DropLocation
  • JTextComponent.KeyBinding
  • JTextField
  • JTextPane
  • JToggleButton
  • JToggleButton.ToggleButtonModel
  • JToolBar
  • JToolBar.Separator
  • JToolTip
  • JTree
  • JTree.DropLocation
  • JTree.DynamicUtilTreeNode
  • JTree.EmptySelectionModel
  • JulianFields
  • JViewport
  • JWindow
  • KerberosCredMessage
  • KerberosKey
  • KerberosPrincipal
  • KerberosTicket
  • Kernel
  • Key
  • KeyAdapter
  • KeyAgreement
  • KeyAgreementSpi
  • KeyAlreadyExistsException
  • KeyboardFocusManager
  • KeyCharacterCombination
  • KeyCode
  • KeyCodeCombination
  • KeyCombination
  • KeyCombination.Modifier
  • KeyCombination.ModifierValue
  • KeyEvent
  • KeyEvent
  • KeyEventDispatcher
  • KeyEventPostProcessor
  • KeyException
  • KeyFactory
  • KeyFactorySpi
  • KeyFrame
  • KeyGenerator
  • KeyGeneratorSpi
  • KeyInfo
  • KeyInfoFactory
  • KeyListener
  • KeyManagementException
  • KeyManager
  • KeyManagerFactory
  • KeyManagerFactorySpi
  • Keymap
  • KeyName
  • KeyPair
  • KeyPairGenerator
  • KeyPairGeneratorSpi
  • KeyRep
  • KeyRep.Type
  • KeySelector
  • KeySelector.Purpose
  • KeySelectorException
  • KeySelectorResult
  • KeySpec
  • KeyStore
  • KeyStore.Builder
  • KeyStore.CallbackHandlerProtection
  • KeyStore.Entry
  • KeyStore.Entry.Attribute
  • KeyStore.LoadStoreParameter
  • KeyStore.PasswordProtection
  • KeyStore.PrivateKeyEntry
  • KeyStore.ProtectionParameter
  • KeyStore.SecretKeyEntry
  • KeyStore.TrustedCertificateEntry
  • KeyStoreBuilderParameters
  • KeyStoreException
  • KeyStoreLoginModule
  • KeyStoreSpi
  • KeyStroke
  • KeyTab
  • KeyValue
  • KeyValue
  • Krb5LoginModule
  • Label
  • Label
  • Labeled
  • LabeledSkinBase
  • LabeledStatementTree
  • LabeledStatementTree
  • LabelSkin
  • LabelUI
  • LabelView
  • LadderConverter
  • LambdaConversionException
  • LambdaExpressionTree
  • LambdaExpressionTree.BodyKind
  • LambdaMetafactory
  • LanguageCallback
  • LanguageVersion
  • LastOwnerException
  • LaunchingConnector
  • LayeredHighlighter
  • LayeredHighlighter.LayerPainter
  • LayerInstantiationException
  • LayerUI
  • LayoutFocusTraversalPolicy
  • LayoutManager
  • LayoutManager2
  • LayoutPath
  • LayoutQueue
  • LayoutStyle
  • LayoutStyle.ComponentPlacement
  • LDAPCertStoreParameters
  • LdapContext
  • LdapLoginModule
  • LdapName
  • LdapPrincipal
  • LdapReferralException
  • Lease
  • Level
  • LexicalHandler
  • LIFESPAN_POLICY_ID
  • LifespanPolicy
  • LifespanPolicyOperations
  • LifespanPolicyValue
  • Light
  • Light.Distant
  • Light.Point
  • Light.Spot
  • LightBase
  • Lighting
  • LimitExceededException
  • Line
  • Line
  • Line.Info
  • Line2D
  • Line2D.Double
  • Line2D.Float
  • LinearGradient
  • LinearGradientPaint
  • LineBorder
  • LineBreakMeasurer
  • LineChart
  • LineChart.SortingPolicy
  • LineEvent
  • LineEvent.Type
  • LineListener
  • LineMap
  • LineMap
  • LineMetrics
  • LineNumberInputStream
  • LineNumberReader
  • LineTo
  • LineUnavailableException
  • LinkageError
  • LinkedBlockingDeque
  • LinkedBlockingQueue
  • LinkedHashMap
  • LinkedHashSet
  • LinkedList
  • LinkedTransferQueue
  • LinkerServices
  • LinkException
  • LinkLoopException
  • LinkOption
  • LinkPermission
  • LinkRef
  • LinkRequest
  • LinkStyle
  • LinkTree
  • List
  • List
  • ListBinding
  • ListCell
  • ListCellRenderer
  • ListCellSkin
  • ListChangeListener
  • ListChangeListener.Change
  • ListDataEvent
  • ListDataListener
  • ListenerNotFoundException
  • ListeningConnector
  • ListExpression
  • ListIterator
  • ListModel
  • ListProperty
  • ListPropertyBase
  • ListResourceBundle
  • ListSelectionEvent
  • ListSelectionListener
  • ListSelectionModel
  • ListUI
  • ListView
  • ListView
  • ListView.EditEvent
  • ListViewSkin
  • LiteralTree
  • LiteralTree
  • LiteralTree
  • LoaderDelegate
  • LoaderHandler
  • LoadException
  • LoadListener
  • LocalDate
  • LocalDateStringConverter
  • LocalDateTime
  • LocalDateTimeStringConverter
  • Locale
  • Locale.Builder
  • Locale.Category
  • Locale.FilteringMode
  • Locale.IsoCountryCode
  • Locale.LanguageRange
  • LocaleNameProvider
  • LocaleServiceProvider
  • LocalExecutionControl
  • LocalExecutionControlProvider
  • LocalObject
  • LocalTime
  • LocalTimeStringConverter
  • LocalVariable
  • Locatable
  • LocatableEvent
  • LocateRegistry
  • Location
  • Location
  • LOCATION_FORWARD
  • Locator
  • Locator2
  • Locator2Impl
  • LocatorImpl
  • Lock
  • LockInfo
  • LockSupport
  • Logger
  • LoggingMXBean
  • LoggingPermission
  • LogicalHandler
  • LogicalMessage
  • LogicalMessageContext
  • LoginContext
  • LoginException
  • LoginModule
  • LogManager
  • LogRecord
  • LogStream
  • Long
  • LongAccumulator
  • LongAdder
  • LongBinaryOperator
  • LongBinding
  • LongBuffer
  • LongConsumer
  • LongExpression
  • LongFunction
  • LongHolder
  • LongLongSeqHelper
  • LongLongSeqHolder
  • LongPredicate
  • LongProperty
  • LongPropertyBase
  • LongSeqHelper
  • LongSeqHolder
  • LongStream
  • LongStream.Builder
  • LongStringConverter
  • LongSummaryStatistics
  • LongSupplier
  • LongToDoubleFunction
  • LongToIntFunction
  • LongType
  • LongUnaryOperator
  • LongValue
  • LookAndFeel
  • Lookup
  • LookupOp
  • LookupTable
  • LoopTree
  • LSException
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter
  • Mac
  • MacSpi
  • MailcapCommandMap
  • Main
  • Main
  • MalformedInputException
  • MalformedLinkException
  • MalformedObjectNameException
  • MalformedParameterizedTypeException
  • MalformedParametersException
  • MalformedURLException
  • ManagementFactory
  • ManagementPermission
  • ManageReferralControl
  • ManagerFactoryParameters
  • Manifest
  • Manifest
  • Map
  • Map.Entry
  • MapBinding
  • MapChangeListener
  • MapChangeListener.Change
  • MapExpression
  • MappedByteBuffer
  • MapProperty
  • MapPropertyBase
  • MapValueFactory
  • MARSHAL
  • MarshalException
  • MarshalException
  • MarshalException
  • MarshalledObject
  • Marshaller
  • Marshaller.Listener
  • MaskFormatter
  • Match
  • Matcher
  • MatchResult
  • Material
  • Math
  • MathContext
  • MatrixType
  • MatteBorder
  • MBeanAttributeInfo
  • MBeanConstructorInfo
  • MBeanException
  • MBeanFeatureInfo
  • MBeanInfo
  • MBeanNotificationInfo
  • MBeanOperationInfo
  • MBeanParameterInfo
  • MBeanPermission
  • MBeanRegistration
  • MBeanRegistrationException
  • MBeanServer
  • MBeanServerBuilder
  • MBeanServerConnection
  • MBeanServerDelegate
  • MBeanServerDelegateMBean
  • MBeanServerFactory
  • MBeanServerForwarder
  • MBeanServerInvocationHandler
  • MBeanServerNotification
  • MBeanServerNotificationFilter
  • MBeanServerPermission
  • MBeanTrustPermission
  • Media
  • Media
  • MediaErrorEvent
  • MediaException
  • MediaException.Type
  • MediaList
  • MediaMarkerEvent
  • MediaName
  • MediaPlayer
  • MediaPlayer.Status
  • MediaPrintableArea
  • MediaSize
  • MediaSize.Engineering
  • MediaSize.ISO
  • MediaSize.JIS
  • MediaSize.NA
  • MediaSize.Other
  • MediaSizeName
  • MediaTracker
  • MediaTray
  • MediaView
  • Member
  • MemberDoc
  • MemberReferenceTree
  • MemberReferenceTree.ReferenceMode
  • MemberSelectTree
  • MemberSelectTree
  • MembershipKey
  • MemoryCacheImageInputStream
  • MemoryCacheImageOutputStream
  • MemoryHandler
  • MemoryImageSource
  • MemoryManagerMXBean
  • MemoryMXBean
  • MemoryNotificationInfo
  • MemoryPoolMXBean
  • MemoryType
  • MemoryUsage
  • Menu
  • Menu
  • MenuBar
  • MenuBar
  • MenuBarSkin
  • MenuBarUI
  • MenuButton
  • MenuButtonSkin
  • MenuButtonSkinBase
  • MenuComponent
  • MenuContainer
  • MenuDragMouseEvent
  • MenuDragMouseListener
  • MenuElement
  • MenuEvent
  • MenuItem
  • MenuItem
  • MenuItemUI
  • MenuKeyEvent
  • MenuKeyListener
  • MenuListener
  • MenuSelectionManager
  • MenuShortcut
  • Mesh
  • MeshView
  • MessageContext
  • MessageContext.Scope
  • MessageDigest
  • MessageDigestSpi
  • MessageFactory
  • MessageFormat
  • MessageFormat.Field
  • MessageInfo
  • MessageProp
  • Messager
  • MetaEventListener
  • MetalBorders
  • MetalBorders.ButtonBorder
  • MetalBorders.Flush3DBorder
  • MetalBorders.InternalFrameBorder
  • MetalBorders.MenuBarBorder
  • MetalBorders.MenuItemBorder
  • MetalBorders.OptionDialogBorder
  • MetalBorders.PaletteBorder
  • MetalBorders.PopupMenuBorder
  • MetalBorders.RolloverButtonBorder
  • MetalBorders.ScrollPaneBorder
  • MetalBorders.TableHeaderBorder
  • MetalBorders.TextFieldBorder
  • MetalBorders.ToggleButtonBorder
  • MetalBorders.ToolBarBorder
  • MetalButtonUI
  • MetalCheckBoxIcon
  • MetalCheckBoxUI
  • MetalComboBoxButton
  • MetalComboBoxEditor
  • MetalComboBoxEditor.UIResource
  • MetalComboBoxIcon
  • MetalComboBoxUI
  • MetalDesktopIconUI
  • MetalFileChooserUI
  • MetalIconFactory
  • MetalIconFactory.FileIcon16
  • MetalIconFactory.FolderIcon16
  • MetalIconFactory.PaletteCloseIcon
  • MetalIconFactory.TreeControlIcon
  • MetalIconFactory.TreeFolderIcon
  • MetalIconFactory.TreeLeafIcon
  • MetalInternalFrameTitlePane
  • MetalInternalFrameUI
  • MetalLabelUI
  • MetalLookAndFeel
  • MetalMenuBarUI
  • MetalPopupMenuSeparatorUI
  • MetalProgressBarUI
  • MetalRadioButtonUI
  • MetalRootPaneUI
  • MetalScrollBarUI
  • MetalScrollButton
  • MetalScrollPaneUI
  • MetalSeparatorUI
  • MetalSliderUI
  • MetalSplitPaneUI
  • MetalTabbedPaneUI
  • MetalTextFieldUI
  • MetalTheme
  • MetalToggleButtonUI
  • MetalToolBarUI
  • MetalToolTipUI
  • MetalTreeUI
  • MetaMessage
  • 方法
  • 方法
  • MethodDescriptor
  • MethodDoc
  • MethodEntryEvent
  • MethodEntryRequest
  • MethodExitEvent
  • MethodExitRequest
  • MethodHandle
  • MethodHandleInfo
  • MethodHandleProxies
  • MethodHandles
  • MethodHandles.Lookup
  • MethodHandleTransformer
  • MethodInvocationTree
  • MethodSnippet
  • MethodTree
  • MethodType
  • MethodTypeConversionStrategy
  • MGF1ParameterSpec
  • MidiChannel
  • MidiDevice
  • MidiDevice.Info
  • MidiDeviceProvider
  • MidiDeviceReceiver
  • MidiDeviceTransmitter
  • MidiEvent
  • MidiFileFormat
  • MidiFileReader
  • MidiFileWriter
  • MidiMessage
  • MidiSystem
  • MidiUnavailableException
  • MimeHeader
  • MimeHeaders
  • MimeType
  • MimeTypeParameterList
  • MimeTypeParseException
  • MimeTypeParseException
  • MimetypesFileTypeMap
  • MinguoChronology
  • MinguoDate
  • MinguoEra
  • MinimalHTMLWriter
  • Mirror
  • MirroredTypeException
  • MirroredTypesException
  • MissingFormatArgumentException
  • MissingFormatWidthException
  • MissingMemberHandlerFactory
  • MissingResourceException
  • Mixer
  • Mixer.Info
  • MixerProvider
  • MLet
  • MLetContent
  • MLetMBean
  • Mnemonic
  • Modality
  • ModelMBean
  • ModelMBeanAttributeInfo
  • ModelMBeanConstructorInfo
  • ModelMBeanInfo
  • ModelMBeanInfoSupport
  • ModelMBeanNotificationBroadcaster
  • ModelMBeanNotificationInfo
  • ModelMBeanOperationInfo
  • ModifiableObservableListBase
  • ModificationItem
  • ModificationWatchpointEvent
  • ModificationWatchpointRequest
  • Modifier
  • Modifier
  • ModifiersTree
  • Module
  • ModuleDescriptor
  • ModuleDescriptor.Builder
  • ModuleDescriptor.Exports
  • ModuleDescriptor.Exports.Modifier
  • ModuleDescriptor.Modifier
  • ModuleDescriptor.Opens
  • ModuleDescriptor.Opens.Modifier
  • ModuleDescriptor.Provides
  • ModuleDescriptor.Requires
  • ModuleDescriptor.Requires.Modifier
  • ModuleDescriptor.Version
  • ModuleElement
  • ModuleElement.Directive
  • ModuleElement.DirectiveKind
  • ModuleElement.DirectiveVisitor
  • ModuleElement.ExportsDirective
  • ModuleElement.OpensDirective
  • ModuleElement.ProvidesDirective
  • ModuleElement.RequiresDirective
  • ModuleElement.UsesDirective
  • ModuleFinder
  • ModuleLayer
  • ModuleLayer.Controller
  • ModuleReader
  • ModuleReference
  • ModuleReference
  • ModuleTree
  • ModuleTree
  • ModuleTree.ModuleKind
  • Monitor
  • MonitorContendedEnteredEvent
  • MonitorContendedEnteredRequest
  • MonitorContendedEnterEvent
  • MonitorContendedEnterRequest
  • MonitorInfo
  • MonitorInfo
  • MonitorMBean
  • MonitorNotification
  • MonitorSettingException
  • MonitorWaitedEvent
  • MonitorWaitedRequest
  • MonitorWaitEvent
  • MonitorWaitRequest
  • Month
  • MonthDay
  • MotionBlur
  • MouseAdapter
  • MouseButton
  • MouseDragEvent
  • MouseDragGestureRecognizer
  • MouseEvent
  • MouseEvent
  • MouseEvent
  • MouseInfo
  • MouseInputAdapter
  • MouseInputListener
  • MouseListener
  • MouseMotionAdapter
  • MouseMotionListener
  • MouseWheelEvent
  • MouseWheelListener
  • MoveTo
  • MTOM
  • MTOMFeature
  • MultiButtonUI
  • MulticastChannel
  • MulticastSocket
  • MultiColorChooserUI
  • MultiComboBoxUI
  • MultiDesktopIconUI
  • MultiDesktopPaneUI
  • MultiDoc
  • MultiDocPrintJob
  • MultiDocPrintService
  • MultiFileChooserUI
  • MultiInternalFrameUI
  • MultiLabelUI
  • MultiListUI
  • MultiLookAndFeel
  • MultiMapResult
  • MultiMenuBarUI
  • MultiMenuItemUI
  • MultiOptionPaneUI
  • MultiPanelUI
  • MultiPixelPackedSampleModel
  • MultipleComponentProfileHelper
  • MultipleComponentProfileHolder
  • MultipleDocumentHandling
  • MultipleGradientPaint
  • MultipleGradientPaint.ColorSpaceType
  • MultipleGradientPaint.CycleMethod
  • MultipleMaster
  • MultipleSelectionModel
  • MultiPopupMenuUI
  • MultiProgressBarUI
  • MultiResolutionImage
  • MultiRootPaneUI
  • MultiScrollBarUI
  • MultiScrollPaneUI
  • MultiSeparatorUI
  • MultiSliderUI
  • MultiSpinnerUI
  • MultiSplitPaneUI
  • MultiTabbedPaneUI
  • MultiTableHeaderUI
  • MultiTableUI
  • MultiTextUI
  • MultiToolBarUI
  • MultiToolTipUI
  • MultiTreeUI
  • MultiViewportUI
  • MutableAttributeSet
  • MutableCallSite
  • MutableComboBoxModel
  • MutableTreeNode
  • MutationEvent
  • MXBean
  • Name
  • Name
  • Name
  • NameAlreadyBoundException
  • NameCallback
  • NameClassPair
  • NameComponent
  • NameComponentHelper
  • NameComponentHolder
  • NamedArg
  • NamedNodeMap
  • NamedOperation
  • NamedValue
  • NameDynAnyPair
  • NameDynAnyPairHelper
  • NameDynAnyPairSeqHelper
  • NameHelper
  • NameHolder
  • NameList
  • NameNotFoundException
  • NameParser
  • Namespace
  • Namespace
  • NamespaceChangeListener
  • NamespaceContext
  • NamespaceOperation
  • NamespaceSupport
  • NameValuePair
  • NameValuePair
  • NameValuePairHelper
  • NameValuePairHelper
  • NameValuePairSeqHelper
  • Naming
  • NamingContext
  • NamingContextExt
  • NamingContextExtHelper
  • NamingContextExtHolder
  • NamingContextExtOperations
  • NamingContextExtPOA
  • NamingContextHelper
  • NamingContextHolder
  • NamingContextOperations
  • NamingContextPOA
  • NamingEnumeration
  • NamingEvent
  • NamingException
  • NamingExceptionEvent
  • NamingListener
  • NamingManager
  • NamingSecurityException
  • NashornException
  • NashornScriptEngine
  • NashornScriptEngineFactory
  • Native
  • NativeMethodException
  • NavigableMap
  • NavigableSet
  • NavigationFilter
  • NavigationFilter.FilterBypass
  • NClob
  • NegativeArraySizeException
  • NestedTableColumnHeader
  • NestingKind
  • NetPermission
  • NetworkChannel
  • NetworkInterface
  • NetworkPermission
  • NewArrayTree
  • NewClassTree
  • NewTree
  • NimbusLookAndFeel
  • NimbusStyle
  • NO_IMPLEMENT
  • NO_MEMORY
  • NO_PERMISSION
  • NO_RESOURCES
  • NO_RESPONSE
  • NoClassDefFoundError
  • NoConnectionPendingException
  • NoContext
  • NoContextHelper
  • Node
  • Node
  • Node
  • NodeChangeEvent
  • NodeChangeListener
  • NodeFilter
  • NodeIterator
  • NodeList
  • NodeOrientation
  • NodeSetData
  • NoInitialContextException
  • NON_EXISTENT
  • NoninvertibleTransformException
  • NonInvertibleTransformException
  • NonReadableChannelException
  • NonWritableChannelException
  • NoPermissionException
  • NormalizedStringAdapter
  • Normalizer
  • Normalizer.Form
  • NoRouteToHostException
  • NoServant
  • NoServantHelper
  • NoSuchAlgorithmException
  • NoSuchAttributeException
  • NoSuchDynamicMethodException
  • NoSuchElementException
  • NoSuchFieldError
  • NoSuchFieldException
  • NoSuchFileException
  • NoSuchMechanismException
  • NoSuchMethodError
  • NoSuchMethodException
  • NoSuchObjectException
  • NoSuchPaddingException
  • NoSuchProviderException
  • NotActiveException
  • Notation
  • NotationDeclaration
  • NotBoundException
  • NotCompliantMBeanException
  • NotContextException
  • NotDirectoryException
  • NotEmpty
  • NotEmptyHelper
  • NotEmptyHolder
  • NotFound
  • NotFoundHelper
  • NotFoundHolder
  • NotFoundReason
  • NotFoundReasonHelper
  • NotFoundReasonHolder
  • NotIdentifiableEvent
  • NotIdentifiableEventImpl
  • Notification
  • Notification
  • NotificationBroadcaster
  • NotificationBroadcasterSupport
  • NotificationEmitter
  • NotificationFilter
  • NotificationFilterSupport
  • NotificationHandler
  • NotificationListener
  • NotificationResult
  • NotLinkException
  • NotOwnerException
  • NotSerializableException
  • NotYetBoundException
  • NotYetConnectedException
  • NoType
  • NTDomainPrincipal
  • NTLoginModule
  • NTNumericCredential
  • NTSid
  • NTSidDomainPrincipal
  • NTSidGroupPrincipal
  • NTSidPrimaryGroupPrincipal
  • NTSidUserPrincipal
  • NTSystem
  • NTUserPrincipal
  • NullCipher
  • NullPointerException
  • NullType
  • Number
  • NumberAxis
  • NumberAxis.DefaultFormatter
  • NumberBinding
  • NumberExpression
  • NumberExpressionBase
  • NumberFormat
  • NumberFormat.Field
  • NumberFormatException
  • NumberFormatProvider
  • NumberFormatter
  • NumberOfDocuments
  • NumberOfInterveningJobs
  • NumberStringConverter
  • NumberUp
  • NumberUpSupported
  • NumericShaper
  • NumericShaper.Range
  • NVList
  • OAEPParameterSpec
  • OBJ_ADAPTER
  • ObjDoubleConsumer
  • Object
  • Object
  • OBJECT_NOT_EXIST
  • ObjectAlreadyActive
  • ObjectAlreadyActiveHelper
  • ObjectBinding
  • ObjectChangeListener
  • ObjectCollectedException
  • ObjectExpression
  • ObjectFactory
  • ObjectFactoryBuilder
  • ObjectHelper
  • ObjectHolder
  • ObjectIdHelper
  • ObjectIdHelper
  • ObjectImpl
  • ObjectImpl
  • ObjectInput
  • ObjectInputFilter
  • ObjectInputFilter.Config
  • ObjectInputFilter.FilterInfo
  • ObjectInputFilter.Status
  • ObjectInputStream
  • ObjectInputStream.GetField
  • ObjectInputValidation
  • ObjectInstance
  • ObjectLiteralTree
  • ObjectName
  • ObjectNotActive
  • ObjectNotActiveHelper
  • ObjectOutput
  • ObjectOutputStream
  • ObjectOutputStream.PutField
  • ObjectProperty
  • ObjectPropertyBase
  • ObjectReference
  • ObjectReferenceFactory
  • ObjectReferenceFactoryHelper
  • ObjectReferenceFactoryHolder
  • ObjectReferenceTemplate
  • ObjectReferenceTemplateHelper
  • ObjectReferenceTemplateHolder
  • ObjectReferenceTemplateSeqHelper
  • ObjectReferenceTemplateSeqHolder
  • Objects
  • ObjectStreamClass
  • ObjectStreamConstants
  • ObjectStreamException
  • ObjectStreamField
  • ObjectView
  • ObjID
  • ObjIntConsumer
  • ObjLongConsumer
  • Observable
  • Observable
  • ObservableArray
  • ObservableArrayBase
  • ObservableBooleanValue
  • ObservableDoubleValue
  • ObservableFaceArray
  • ObservableFloatArray
  • ObservableFloatValue
  • ObservableIntegerArray
  • ObservableIntegerValue
  • ObservableList
  • ObservableListBase
  • ObservableListValue
  • ObservableLongValue
  • ObservableMap
  • ObservableMapValue
  • ObservableNumberValue
  • ObservableObjectValue
  • ObservableSet
  • ObservableSetValue
  • ObservableStringValue
  • ObservableValue
  • ObservableValueBase
  • Observer
  • OceanTheme
  • OctetSeqHelper
  • OctetSeqHolder
  • OctetStreamData
  • OffsetDateTime
  • OffsetTime
  • Oid
  • OMGVMCID
  • Oneway
  • OpenDataException
  • OpenFilesEvent
  • OpenFilesHandler
  • OpenMBeanAttributeInfo
  • OpenMBeanAttributeInfoSupport
  • OpenMBeanConstructorInfo
  • OpenMBeanConstructorInfoSupport
  • OpenMBeanInfo
  • OpenMBeanInfoSupport
  • OpenMBeanOperationInfo
  • OpenMBeanOperationInfoSupport
  • OpenMBeanParameterInfo
  • OpenMBeanParameterInfoSupport
  • OpenOption
  • OpensTree
  • OpenType
  • OpenType
  • OpenURIEvent
  • OpenURIHandler
  • OperatingSystemMXBean
  • OperatingSystemMXBean
  • Operation
  • Operation
  • OperationNotSupportedException
  • OperationsException
  • Option
  • Optional
  • OptionalDataException
  • OptionalDouble
  • OptionalInt
  • OptionalLong
  • OptionChecker
  • OptionPaneUI
  • ORB
  • ORB
  • ORBIdHelper
  • ORBInitializer
  • ORBInitializerOperations
  • ORBInitInfo
  • ORBInitInfoOperations
  • Orientation
  • OrientationRequested
  • OutOfMemoryError
  • OutputDeviceAssigned
  • OutputKeys
  • OutputStream
  • OutputStream
  • OutputStream
  • OutputStreamWriter
  • OverlappingFileLockException
  • OverlayLayout
  • Override
  • OverrunStyle
  • Owner
  • Pack200
  • Pack200.Packer
  • Pack200.Unpacker
  • 软件包
  • PackageDoc
  • PackageElement
  • PackageTree
  • PackedColorModel
  • Pageable
  • PageAttributes
  • PageAttributes.ColorType
  • PageAttributes.MediaType
  • PageAttributes.OrientationRequestedType
  • PageAttributes.OriginType
  • PageAttributes.PrintQualityType
  • PagedResultsControl
  • PagedResultsResponseControl
  • PageFormat
  • PageLayout
  • PageOrientation
  • PageRange
  • PageRanges
  • PagesPerMinute
  • PagesPerMinuteColor
  • Pagination
  • PaginationSkin
  • Paint
  • Paint
  • PaintContext
  • PaintConverter
  • PaintConverter.ImagePatternConverter
  • PaintConverter.LinearGradientConverter
  • PaintConverter.RadialGradientConverter
  • PaintConverter.RepeatingImagePatternConverter
  • PaintConverter.SequenceConverter
  • Painter
  • PaintEvent
  • Pair
  • Pane
  • Panel
  • PanelUI
  • Paper
  • Paper
  • PaperSource
  • ParagraphView
  • ParagraphView
  • ParallelCamera
  • ParallelTransition
  • Parameter
  • Parameter
  • Parameter
  • ParameterBlock
  • ParameterDescriptor
  • Parameterizable
  • ParameterizedType
  • ParameterizedType
  • ParameterizedTypeTree
  • ParameterMetaData
  • ParameterMode
  • ParameterModeHelper
  • ParameterModeHolder
  • ParamTag
  • ParamTree
  • Parent
  • ParenthesizedTree
  • ParenthesizedTree
  • ParseConversionEvent
  • ParseConversionEventImpl
  • ParsedValue
  • ParseException
  • ParsePosition
  • Parser
  • Parser
  • Parser
  • ParserAdapter
  • ParserConfigurationException
  • ParserDelegator
  • ParserFactory
  • PartialResultException
  • PasswordAuthentication
  • PasswordCallback
  • PasswordField
  • PasswordView
  • Patch
  • Path
  • Path
  • Path2D
  • Path2D.Double
  • Path2D.Float
  • PathElement
  • PathIterator
  • PathMatcher
  • Paths
  • PathSearchingVirtualMachine
  • PathTransition
  • PathTransition.OrientationType
  • Pattern
  • PatternSyntaxException
  • PauseTransition
  • PBEKey
  • PBEKeySpec
  • PBEParameterSpec
  • PDLOverrideSupported
  • PeerAddressChangeNotification
  • PeerAddressChangeNotification.AddressChangeEvent
  • PercentageStringConverter
  • Period
  • Permission
  • Permission
  • PermissionCollection
  • Permissions
  • PERSIST_STORE
  • PersistenceDelegate
  • PersistenceService
  • PersistentMBean
  • PersistentSnippet
  • PerspectiveCamera
  • PerspectiveTransform
  • PGPData
  • PhantomReference
  • Phaser
  • PhongMaterial
  • PickResult
  • PieChart
  • PieChart.Data
  • Pipe
  • Pipe.SinkChannel
  • Pipe.SourceChannel
  • PipedInputStream
  • PipedOutputStream
  • PipedReader
  • PipedWriter
  • PixelFormat
  • PixelFormat.Type
  • PixelGrabber
  • PixelInterleavedSampleModel
  • PixelReader
  • PixelWriter
  • PKCS12Attribute
  • PKCS8EncodedKeySpec
  • PKIXBuilderParameters
  • PKIXCertPathBuilderResult
  • PKIXCertPathChecker
  • PKIXCertPathValidatorResult
  • PKIXParameters
  • PKIXReason
  • PKIXRevocationChecker
  • PKIXRevocationChecker.Option
  • PlainDocument
  • PlainView
  • Platform
  • PlatformLoggingMXBean
  • PlatformManagedObject
  • Plugin
  • POA
  • POAHelper
  • POAManager
  • POAManagerOperations
  • POAOperations
  • Point
  • Point2D
  • Point2D
  • Point2D.Double
  • Point2D.Float
  • Point3D
  • PointerInfo
  • PointLight
  • Policy
  • Policy
  • Policy
  • Policy.Parameters
  • PolicyError
  • PolicyErrorCodeHelper
  • PolicyErrorHelper
  • PolicyErrorHolder
  • PolicyFactory
  • PolicyFactoryOperations
  • PolicyFile
  • PolicyHelper
  • PolicyHolder
  • PolicyListHelper
  • PolicyListHolder
  • PolicyNode
  • PolicyOperations
  • PolicyQualifierInfo
  • PolicySpi
  • PolicyTypeHelper
  • Polygon
  • Polygon
  • Polyline
  • PooledConnection
  • PooledConnectionBuilder
  • Popup
  • Popup
  • PopupControl
  • PopupFactory
  • PopupFeatures
  • PopupMenu
  • PopupMenuEvent
  • PopupMenuListener
  • PopupMenuUI
  • PopupWindow
  • PopupWindow.AnchorLocation
  • Port
  • Port.Info
  • PortableRemoteObject
  • PortableRemoteObjectDelegate
  • PortInfo
  • PortUnreachableException
  • Pos
  • Position
  • Position.Bias
  • PosixFileAttributes
  • PosixFileAttributeView
  • PosixFilePermission
  • PosixFilePermissions
  • PostConstruct
  • PreDestroy
  • Predicate
  • Predicate
  • PreferenceChangeEvent
  • PreferenceChangeListener
  • Preferences
  • PreferencesEvent
  • PreferencesFactory
  • PreferencesHandler
  • Preloader
  • Preloader.ErrorNotification
  • Preloader.PreloaderNotification
  • Preloader.ProgressNotification
  • Preloader.StateChangeNotification
  • Preloader.StateChangeNotification.Type
  • PreparedStatement
  • PresentationDirection
  • PrimitiveIterator
  • PrimitiveIterator.OfDouble
  • PrimitiveIterator.OfInt
  • PrimitiveIterator.OfLong
  • PrimitiveType
  • PrimitiveType
  • PrimitiveTypeTree
  • PrimitiveValue
  • Principal
  • Principal
  • PrincipalComparator
  • PrincipalHolder
  • Printable
  • PrintColor
  • PrintConversionEvent
  • PrintConversionEventImpl
  • Printer
  • Printer.MarginType
  • PrinterAbortException
  • PrinterAttributes
  • PrinterException
  • PrinterGraphics
  • PrinterInfo
  • PrinterIOException
  • PrinterIsAcceptingJobs
  • PrinterJob
  • PrinterJob
  • PrinterJob.JobStatus
  • PrinterLocation
  • PrinterMakeAndModel
  • PrinterMessageFromOperator
  • PrinterMoreInfo
  • PrinterMoreInfoManufacturer
  • PrinterName
  • PrinterResolution
  • PrinterState
  • PrinterStateReason
  • PrinterStateReasons
  • PrinterURI
  • PrintEvent
  • PrintException
  • PrintFilesEvent
  • PrintFilesHandler
  • PrintGraphics
  • PrintJob
  • PrintJobAdapter
  • PrintJobAttribute
  • PrintJobAttributeEvent
  • PrintJobAttributeListener
  • PrintJobAttributeSet
  • PrintJobEvent
  • PrintJobListener
  • PrintQuality
  • PrintQuality
  • PrintRequestAttribute
  • PrintRequestAttributeSet
  • PrintResolution
  • PrintService
  • PrintService
  • PrintServiceAttribute
  • PrintServiceAttributeEvent
  • PrintServiceAttributeListener
  • PrintServiceAttributeSet
  • PrintServiceLookup
  • PrintSides
  • PrintStream
  • PrintWriter
  • Priority
  • PriorityBlockingQueue
  • PriorityQueue
  • PRIVATE_MEMBER
  • PrivateClassLoader
  • PrivateCredentialPermission
  • PrivateKey
  • PrivateMLet
  • PrivilegedAction
  • PrivilegedActionException
  • PrivilegedExceptionAction
  • Process
  • ProcessBuilder
  • ProcessBuilder.Redirect
  • ProcessBuilder.Redirect.Type
  • ProcessHandle
  • ProcessHandle.Info
  • ProcessingEnvironment
  • ProcessingInstruction
  • ProcessingInstruction
  • Processor
  • ProfileDataException
  • ProfileIdHelper
  • ProgramElementDoc
  • ProgressBar
  • ProgressBarSkin
  • ProgressBarTableCell
  • ProgressBarTreeTableCell
  • ProgressBarUI
  • ProgressIndicator
  • ProgressIndicatorSkin
  • ProgressMonitor
  • ProgressMonitorInputStream
  • PromptData
  • Properties
  • Property
  • PropertyChangeEvent
  • PropertyChangeListener
  • PropertyChangeListenerProxy
  • PropertyChangeSupport
  • PropertyDescriptor
  • PropertyEditor
  • PropertyEditorManager
  • PropertyEditorSupport
  • PropertyException
  • PropertyPermission
  • PropertyResourceBundle
  • PropertyTree
  • PropertyValueFactory
  • PropertyVetoException
  • ProtectionDomain
  • ProtocolException
  • ProtocolException
  • ProtocolFamily
  • Provider
  • Provider
  • Provider
  • Provider.Service
  • ProviderException
  • ProviderMismatchException
  • ProviderNotFoundException
  • ProvidesTree
  • ProvidesTree
  • Proxy
  • Proxy
  • Proxy.Type
  • ProxySelector
  • PseudoClass
  • PseudoColumnUsage
  • PSource
  • PSource.PSpecified
  • PSSParameterSpec
  • PUBLIC_MEMBER
  • PublicKey
  • PushbackInputStream
  • PushbackReader
  • QName
  • QuadCurve
  • QuadCurve2D
  • QuadCurve2D.Double
  • QuadCurve2D.Float
  • QuadCurveTo
  • QualifiedNameable
  • Query
  • QueryEval
  • QueryExp
  • Queue
  • QueuedJobCount
  • QuitEvent
  • QuitHandler
  • QuitResponse
  • QuitStrategy
  • RadialGradient
  • RadialGradientPaint
  • RadioButton
  • RadioButtonSkin
  • RadioMenuItem
  • Random
  • RandomAccess
  • RandomAccessFile
  • Range
  • RangeException
  • Raster
  • RasterFormatException
  • RasterOp
  • RC2ParameterSpec
  • RC5ParameterSpec
  • Rdn
  • Readable
  • ReadableByteChannel
  • Reader
  • ReadOnlyBooleanProperty
  • ReadOnlyBooleanPropertyBase
  • ReadOnlyBooleanWrapper
  • ReadOnlyBufferException
  • ReadOnlyDoubleProperty
  • ReadOnlyDoublePropertyBase
  • ReadOnlyDoubleWrapper
  • ReadOnlyFileSystemException
  • ReadOnlyFloatProperty
  • ReadOnlyFloatPropertyBase
  • ReadOnlyFloatWrapper
  • ReadOnlyIntegerProperty
  • ReadOnlyIntegerPropertyBase
  • ReadOnlyIntegerWrapper
  • ReadOnlyJavaBeanBooleanProperty
  • ReadOnlyJavaBeanBooleanPropertyBuilder
  • ReadOnlyJavaBeanDoubleProperty
  • ReadOnlyJavaBeanDoublePropertyBuilder
  • ReadOnlyJavaBeanFloatProperty
  • ReadOnlyJavaBeanFloatPropertyBuilder
  • ReadOnlyJavaBeanIntegerProperty
  • ReadOnlyJavaBeanIntegerPropertyBuilder
  • ReadOnlyJavaBeanLongProperty
  • ReadOnlyJavaBeanLongPropertyBuilder
  • ReadOnlyJavaBeanObjectProperty
  • ReadOnlyJavaBeanObjectPropertyBuilder
  • ReadOnlyJavaBeanProperty
  • ReadOnlyJavaBeanStringProperty
  • ReadOnlyJavaBeanStringPropertyBuilder
  • ReadOnlyListProperty
  • ReadOnlyListPropertyBase
  • ReadOnlyListWrapper
  • ReadOnlyLongProperty
  • ReadOnlyLongPropertyBase
  • ReadOnlyLongWrapper
  • ReadOnlyMapProperty
  • ReadOnlyMapPropertyBase
  • ReadOnlyMapWrapper
  • ReadOnlyObjectProperty
  • ReadOnlyObjectPropertyBase
  • ReadOnlyObjectWrapper
  • ReadOnlyProperty
  • ReadOnlySetProperty
  • ReadOnlySetPropertyBase
  • ReadOnlySetWrapper
  • ReadOnlyStringProperty
  • ReadOnlyStringPropertyBase
  • ReadOnlyStringWrapper
  • ReadPendingException
  • ReadWriteLock
  • RealmCallback
  • RealmChoiceCallback
  • REBIND
  • Receiver
  • Rect
  • Rectangle
  • Rectangle
  • Rectangle2D
  • Rectangle2D
  • Rectangle2D.Double
  • Rectangle2D.Float
  • RectangularShape
  • RecursiveAction
  • RecursiveTask
  • ReentrantLock
  • ReentrantReadWriteLock
  • ReentrantReadWriteLock.ReadLock
  • ReentrantReadWriteLock.WriteLock
  • Ref
  • RefAddr
  • Reference
  • Reference
  • Reference
  • Referenceable
  • ReferenceQueue
  • ReferenceTree
  • ReferenceType
  • ReferenceType
  • ReferenceUriSchemesSupported
  • ReferralException
  • Reflection
  • ReflectionException
  • ReflectiveOperationException
  • ReflectPermission
  • Refreshable
  • RefreshFailedException
  • RegExpLiteralTree
  • Region
  • Region
  • RegisterableService
  • Registry
  • RegistryHandler
  • RejectedExecutionException
  • RejectedExecutionHandler
  • Relation
  • RelationException
  • RelationNotFoundException
  • RelationNotification
  • RelationService
  • RelationServiceMBean
  • RelationServiceNotRegisteredException
  • RelationSupport
  • RelationSupportMBean
  • RelationType
  • RelationTypeNotFoundException
  • RelationTypeSupport
  • RelinkableCallSite
  • RemarshalException
  • Remote
  • RemoteCall
  • RemoteException
  • RemoteExecutionControl
  • RemoteObject
  • RemoteObjectInvocationHandler
  • RemoteRef
  • RemoteServer
  • RemoteStub
  • RenderableImage
  • RenderableImageOp
  • RenderableImageProducer
  • RenderContext
  • RenderedImage
  • RenderedImageFactory
  • Renderer
  • RenderingHints
  • RenderingHints.Key
  • RepaintManager
  • Repeatable
  • ReplicateScaleFilter
  • Reporter
  • RepositoryIdHelper
  • Request
  • REQUEST_PROCESSING_POLICY_ID
  • RequestInfo
  • RequestInfoOperations
  • RequestingUserName
  • RequestProcessingPolicy
  • RequestProcessingPolicyOperations
  • RequestProcessingPolicyValue
  • RequestWrapper
  • RequiredModelMBean
  • RequiresTree
  • RescaleOp
  • ResizeFeaturesBase
  • ResolutionException
  • ResolutionSyntax
  • ResolvedModule
  • Resolver
  • ResolveResult
  • ResolverStyle
  • Resource
  • Resource.AuthenticationType
  • ResourceBundle
  • ResourceBundle.Control
  • ResourceBundleControlProvider
  • ResourceBundleProvider
  • Resources
  • RespectBinding
  • RespectBindingFeature
  • Response
  • ResponseAPDU
  • ResponseCache
  • ResponseHandler
  • ResponseWrapper
  • Result
  • ResultSet
  • ResultSetMetaData
  • Retention
  • RetentionPolicy
  • RetrievalMethod
  • ReturnTree
  • ReturnTree
  • ReturnTree
  • ReverbType
  • RGBColor
  • RGBImageFilter
  • RMIClassLoader
  • RMIClassLoaderSpi
  • RMIClientSocketFactory
  • RMIConnection
  • RMIConnectionImpl
  • RMIConnectionImpl_Stub
  • RMIConnector
  • RMIConnectorServer
  • RMICustomMaxStreamFormat
  • RMIFailureHandler
  • RMIIIOPServerImpl
  • RMIJRMPServerImpl
  • RMISecurityException
  • RMISecurityManager
  • RMIServer
  • RMIServerImpl
  • RMIServerImpl_Stub
  • RMIServerSocketFactory
  • RMISocketFactory
  • Robot
  • Role
  • RoleInfo
  • RoleInfoNotFoundException
  • RoleList
  • RoleNotFoundException
  • RoleResult
  • RoleStatus
  • RoleUnresolved
  • RoleUnresolvedList
  • RootDoc
  • RootPaneContainer
  • RootPaneUI
  • Rotate
  • RotateEvent
  • RotateTransition
  • RoundEnvironment
  • RoundingMode
  • RoundRectangle2D
  • RoundRectangle2D.Double
  • RoundRectangle2D.Float
  • RowConstraints
  • RowFilter
  • RowFilter.ComparisonType
  • RowFilter.Entry
  • RowId
  • RowIdLifetime
  • RowMapper
  • RowSet
  • RowSetEvent
  • RowSetFactory
  • RowSetInternal
  • RowSetListener
  • RowSetMetaData
  • RowSetMetaDataImpl
  • RowSetProvider
  • RowSetReader
  • RowSetWarning
  • RowSetWriter
  • RowSorter
  • RowSorter.SortKey
  • RowSorterEvent
  • RowSorterEvent.Type
  • RowSorterListener
  • RSAKey
  • RSAKeyGenParameterSpec
  • RSAMultiPrimePrivateCrtKey
  • RSAMultiPrimePrivateCrtKeySpec
  • RSAOtherPrimeInfo
  • RSAPrivateCrtKey
  • RSAPrivateCrtKeySpec
  • RSAPrivateKey
  • RSAPrivateKeySpec
  • RSAPublicKey
  • RSAPublicKeySpec
  • RTFEditorKit
  • Rule
  • RuleBasedCollator
  • Runnable
  • RunnableFuture
  • RunnableScheduledFuture
  • Runtime
  • RunTime
  • Runtime.Version
  • RuntimeErrorException
  • RuntimeException
  • RuntimeMBeanException
  • RuntimeMXBean
  • RunTimeOperations
  • RuntimeOperationsException
  • RuntimePermission
  • SAAJMetaFactory
  • SAAJResult
  • SafeVarargs
  • SampleModel
  • Sasl
  • SaslClient
  • SaslClientFactory
  • SaslException
  • SaslServer
  • SaslServerFactory
  • Savepoint
  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException
  • SAXParser
  • SAXParserFactory
  • SAXResult
  • SAXSource
  • SAXTransformerFactory
  • Scale
  • ScaleTransition
  • Scanner
  • ScatterChart
  • ScatteringByteChannel
  • Scene
  • SceneAntialiasing
  • ScheduledExecutorService
  • ScheduledFuture
  • ScheduledService
  • ScheduledThreadPoolExecutor
  • Schema
  • SchemaFactory
  • SchemaFactoryConfigurationError
  • SchemaFactoryLoader
  • SchemaOutputResolver
  • SchemaViolationException
  • Scope
  • Screen
  • ScreenSleepEvent
  • ScreenSleepListener
  • ScriptContext
  • ScriptEngine
  • ScriptEngineFactory
  • ScriptEngineManager
  • ScriptException
  • ScriptObjectMirror
  • ScriptUtils
  • Scrollable
  • Scrollbar
  • ScrollBar
  • ScrollBarSkin
  • ScrollBarUI
  • ScrollEvent
  • ScrollEvent.HorizontalTextScrollUnits
  • ScrollEvent.VerticalTextScrollUnits
  • ScrollPane
  • ScrollPane
  • ScrollPane.ScrollBarPolicy
  • ScrollPaneAdjustable
  • ScrollPaneConstants
  • ScrollPaneLayout
  • ScrollPaneLayout.UIResource
  • ScrollPaneSkin
  • ScrollPaneUI
  • ScrollToEvent
  • SctpChannel
  • SctpMultiChannel
  • SctpServerChannel
  • SctpSocketOption
  • SctpStandardSocketOptions
  • SctpStandardSocketOptions.InitMaxStreams
  • SealedObject
  • SearchControls
  • SearchResult
  • SecondaryLoop
  • SecretKey
  • SecretKeyFactory
  • SecretKeyFactorySpi
  • SecretKeySpec
  • SecureCacheResponse
  • SecureClassLoader
  • SecureDirectoryStream
  • SecureLookupSupplier
  • SecureRandom
  • SecureRandomParameters
  • SecureRandomSpi
  • Security
  • SecurityException
  • SecurityManager
  • SecurityPermission
  • SeekableByteChannel
  • SeeTag
  • SeeTree
  • Segment
  • SelectableChannel
  • SelectionKey
  • SelectionMode
  • SelectionModel
  • Selector
  • Selector
  • SelectorProvider
  • Semaphore
  • SendFailedNotification
  • Separator
  • SeparatorMenuItem
  • SeparatorSkin
  • SeparatorUI
  • SepiaTone
  • Sequence
  • SequenceInputStream
  • Sequencer
  • Sequencer.SyncMode
  • SequentialTransition
  • SerialArray
  • SerialBlob
  • SerialClob
  • SerialDatalink
  • SerialDataTree
  • SerialException
  • SerialFieldTag
  • SerialFieldTree
  • Serializable
  • SerializablePermission
  • SerializedLambda
  • SerialJavaObject
  • SerialRef
  • SerialStruct
  • SerialTree
  • Servant
  • SERVANT_RETENTION_POLICY_ID
  • ServantActivator
  • ServantActivatorHelper
  • ServantActivatorOperations
  • ServantActivatorPOA
  • ServantAlreadyActive
  • ServantAlreadyActiveHelper
  • ServantLocator
  • ServantLocatorHelper
  • ServantLocatorOperations
  • ServantLocatorPOA
  • ServantManager
  • ServantManagerOperations
  • ServantNotActive
  • ServantNotActiveHelper
  • ServantObject
  • ServantRetentionPolicy
  • ServantRetentionPolicyOperations
  • ServantRetentionPolicyValue
  • ServerCloneException
  • ServerError
  • ServerException
  • ServerIdHelper
  • ServerNotActiveException
  • ServerRef
  • ServerRequest
  • ServerRequestInfo
  • ServerRequestInfoOperations
  • ServerRequestInterceptor
  • ServerRequestInterceptorOperations
  • ServerRuntimeException
  • ServerSocket
  • ServerSocketChannel
  • ServerSocketFactory
  • Service
  • Service
  • Service.Mode
  • ServiceConfigurationError
  • ServiceContext
  • ServiceContextHelper
  • ServiceContextHolder
  • ServiceContextListHelper
  • ServiceContextListHolder
  • ServiceDelegate
  • ServiceDetail
  • ServiceDetailHelper
  • ServiceIdHelper
  • ServiceInformation
  • ServiceInformationHelper
  • ServiceInformationHolder
  • ServiceLoader
  • ServiceLoader.Provider
  • ServiceManager
  • ServiceManagerStub
  • ServiceMode
  • ServiceNotFoundException
  • ServicePermission
  • ServiceRegistry
  • ServiceRegistry.Filter
  • ServiceUI
  • ServiceUIFactory
  • ServiceUnavailableException
  • Set
  • SetBinding
  • SetChangeListener
  • SetChangeListener.Change
  • SetExpression
  • SetOfIntegerSyntax
  • SetOverrideType
  • SetOverrideTypeHelper
  • SetProperty
  • SetPropertyBase
  • Severity
  • Shadow
  • Shape
  • Shape
  • Shape3D
  • ShapeConverter
  • ShapeGraphicAttribute
  • ShardingKey
  • ShardingKeyBuilder
  • Shear
  • SheetCollate
  • Short
  • ShortBuffer
  • ShortBufferException
  • ShortHolder
  • ShortLookupTable
  • ShortMessage
  • ShortSeqHelper
  • ShortSeqHolder
  • ShortStringConverter
  • ShortType
  • ShortValue
  • ShutdownChannelGroupException
  • ShutdownNotification
  • Side
  • Sides
  • Signature
  • SignatureException
  • SignatureMethod
  • SignatureMethodParameterSpec
  • SignatureProperties
  • SignatureProperty
  • SignatureSpi
  • SignedInfo
  • SignedObject
  • Signer
  • SignStyle
  • SimpleAnnotationValueVisitor6
  • SimpleAnnotationValueVisitor7
  • SimpleAnnotationValueVisitor8
  • SimpleAnnotationValueVisitor9
  • SimpleAttributeSet
  • SimpleBeanInfo
  • SimpleBindings
  • SimpleBooleanProperty
  • SimpleDateFormat
  • SimpleDoc
  • SimpleDocTreeVisitor
  • SimpleDoubleProperty
  • SimpleElementVisitor6
  • SimpleElementVisitor7
  • SimpleElementVisitor8
  • SimpleElementVisitor9
  • SimpleFileVisitor
  • SimpleFloatProperty
  • SimpleFormatter
  • SimpleIntegerProperty
  • SimpleJavaFileObject
  • SimpleLinkRequest
  • SimpleListProperty
  • SimpleLongProperty
  • SimpleMapProperty
  • SimpleObjectProperty
  • SimpleRelinkableCallSite
  • SimpleScriptContext
  • SimpleSelector
  • SimpleSetProperty
  • SimpleStringProperty
  • SimpleStyleableBooleanProperty
  • SimpleStyleableDoubleProperty
  • SimpleStyleableFloatProperty
  • SimpleStyleableIntegerProperty
  • SimpleStyleableLongProperty
  • SimpleStyleableObjectProperty
  • SimpleStyleableStringProperty
  • SimpleTimeZone
  • SimpleTreeVisitor
  • SimpleTreeVisitorES5_1
  • SimpleTreeVisitorES6
  • SimpleType
  • SimpleTypeVisitor6
  • SimpleTypeVisitor7
  • SimpleTypeVisitor8
  • SimpleTypeVisitor9
  • SinceTree
  • SingleInstanceListener
  • SingleInstanceService
  • SinglePixelPackedSampleModel
  • SingleSelectionModel
  • SingleSelectionModel
  • Size
  • Size2DSyntax
  • SizeConverter
  • SizeConverter.SequenceConverter
  • SizeLimitExceededException
  • SizeRequirements
  • SizeSequence
  • SizeUnits
  • Skeleton
  • SkeletonMismatchException
  • SkeletonNotFoundException
  • Skin
  • SkinBase
  • Skinnable
  • Slider
  • SliderSkin
  • SliderUI
  • SnapshotParameters
  • SnapshotResult
  • SNIHostName
  • SNIMatcher
  • Snippet
  • Snippet.Kind
  • Snippet.Status
  • Snippet.SubKind
  • SnippetEvent
  • SNIServerName
  • SOAPBinding
  • SOAPBinding
  • SOAPBinding.ParameterStyle
  • SOAPBinding.Style
  • SOAPBinding.Use
  • SOAPBody
  • SOAPBodyElement
  • SOAPConnection
  • SOAPConnectionFactory
  • SOAPConstants
  • SOAPElement
  • SOAPElementFactory
  • SOAPEnvelope
  • SOAPException
  • SOAPFactory
  • SOAPFault
  • SOAPFaultElement
  • SOAPFaultException
  • SOAPHandler
  • SOAPHeader
  • SOAPHeaderElement
  • SOAPMessage
  • SOAPMessageContext
  • SOAPMessageHandler
  • SOAPMessageHandlers
  • SOAPPart
  • Socket
  • SocketAddress
  • SocketChannel
  • SocketException
  • SocketFactory
  • SocketFlow
  • SocketFlow.Status
  • SocketHandler
  • SocketImpl
  • SocketImplFactory
  • SocketOption
  • SocketOptions
  • SocketPermission
  • Sockets
  • SocketSecurityException
  • SocketTimeoutException
  • SoftBevelBorder
  • SoftReference
  • SolarisLoginModule
  • SolarisNumericGroupPrincipal
  • SolarisNumericUserPrincipal
  • SolarisPrincipal
  • SolarisSystem
  • SortControl
  • SortedList
  • SortedMap
  • SortedSet
  • SortEvent
  • SortingFocusTraversalPolicy
  • SortKey
  • SortOrder
  • SortResponseControl
  • Soundbank
  • SoundbankReader
  • SoundbankResource
  • Source
  • SourceCodeAnalysis
  • SourceCodeAnalysis.Completeness
  • SourceCodeAnalysis.CompletionInfo
  • SourceCodeAnalysis.Documentation
  • SourceCodeAnalysis.QualifiedNames
  • SourceCodeAnalysis.SnippetWrapper
  • SourceCodeAnalysis.Suggestion
  • SourceDataLine
  • SourceLocator
  • SourcePosition
  • SourcePositions
  • SourceVersion
  • Sphere
  • Spinner
  • SpinnerDateModel
  • SpinnerListModel
  • SpinnerModel
  • SpinnerNumberModel
  • SpinnerSkin
  • SpinnerUI
  • SpinnerValueFactory
  • SpinnerValueFactory.DoubleSpinnerValueFactory
  • SpinnerValueFactory.IntegerSpinnerValueFactory
  • SpinnerValueFactory.ListSpinnerValueFactory
  • SPIResolutionException
  • SplashScreen
  • Spliterator
  • Spliterator.OfDouble
  • Spliterator.OfInt
  • Spliterator.OfLong
  • Spliterator.OfPrimitive
  • Spliterators
  • Spliterators.AbstractDoubleSpliterator
  • Spliterators.AbstractIntSpliterator
  • Spliterators.AbstractLongSpliterator
  • Spliterators.AbstractSpliterator
  • SplitMenuButton
  • SplitMenuButtonSkin
  • SplitPane
  • SplitPane.Divider
  • SplitPaneSkin
  • SplitPaneUI
  • SplittableRandom
  • SpreadTree
  • Spring
  • SpringLayout
  • SpringLayout.Constraints
  • SQLClientInfoException
  • SQLData
  • SQLDataException
  • SQLException
  • SQLFeatureNotSupportedException
  • SQLInput
  • SQLInputImpl
  • SQLIntegrityConstraintViolationException
  • SQLInvalidAuthorizationSpecException
  • SQLNonTransientConnectionException
  • SQLNonTransientException
  • SQLOutput
  • SQLOutputImpl
  • SQLPermission
  • SQLRecoverableException
  • SQLSyntaxErrorException
  • SQLTimeoutException
  • SQLTransactionRollbackException
  • SQLTransientConnectionException
  • SQLTransientException
  • SQLType
  • SQLWarning
  • SQLXML
  • SSLContext
  • SSLContextSpi
  • SSLEngine
  • SSLEngineResult
  • SSLEngineResult.HandshakeStatus
  • SSLEngineResult.Status
  • SSLException
  • SSLHandshakeException
  • SSLKeyException
  • SSLParameters
  • SSLPeerUnverifiedException
  • SSLPermission
  • SSLProtocolException
  • SslRMIClientSocketFactory
  • SslRMIServerSocketFactory
  • SSLServerSocket
  • SSLServerSocketFactory
  • SSLSession
  • SSLSessionBindingEvent
  • SSLSessionBindingListener
  • SSLSessionContext
  • SSLSocket
  • SSLSocketFactory
  • Stack
  • StackedAreaChart
  • StackedBarChart
  • StackFrame
  • StackOverflowError
  • StackPane
  • StackTraceElement
  • StackWalker
  • StackWalker.Option
  • StackWalker.StackFrame
  • Stage
  • StageStyle
  • StampedLock
  • Standard
  • StandardCharsets
  • StandardConstants
  • StandardCopyOption
  • StandardDoclet
  • StandardEmitterMBean
  • StandardJavaFileManager
  • StandardJavaFileManager.PathFactory
  • StandardLocation
  • StandardMBean
  • StandardNamespace
  • StandardOpenOption
  • StandardOperation
  • StandardProtocolFamily
  • StandardSocketOptions
  • StandardWatchEventKinds
  • StartDocument
  • StartElement
  • StartElementTree
  • StartTlsRequest
  • StartTlsResponse
  • State
  • State
  • StateEdit
  • StateEditable
  • StateFactory
  • Statement
  • Statement
  • StatementEvent
  • StatementEventListener
  • StatementSnippet
  • StatementTree
  • StatementTree
  • StaticClass
  • StAXResult
  • StAXSource
  • StepEvent
  • StepRequest
  • Stop
  • StopConverter
  • Stream
  • Stream.Builder
  • Streamable
  • StreamableValue
  • StreamCorruptedException
  • StreamFilter
  • StreamHandler
  • StreamingExecutionControl
  • StreamPrintService
  • StreamPrintServiceFactory
  • StreamReaderDelegate
  • StreamResult
  • StreamSource
  • StreamSupport
  • StreamTokenizer
  • StrictMath
  • String
  • StringBinding
  • StringBuffer
  • StringBufferInputStream
  • StringBuilder
  • StringCharacterIterator
  • StringConcatException
  • StringConcatFactory
  • StringContent
  • StringConverter
  • StringConverter
  • StringConverter.SequenceConverter
  • StringExpression
  • StringHolder
  • StringIndexOutOfBoundsException
  • StringJoiner
  • StringMonitor
  • StringMonitorMBean
  • StringNameHelper
  • StringProperty
  • StringPropertyBase
  • StringReader
  • StringRefAddr
  • StringReference
  • StringSelection
  • StringSeqHelper
  • StringSeqHolder
  • StringTokenizer
  • StringValueExp
  • StringValueHelper
  • StringWriter
  • Stroke
  • StrokeBorder
  • StrokeLineCap
  • StrokeLineJoin
  • StrokeTransition
  • StrokeType
  • Struct
  • StructMember
  • StructMemberHelper
  • Stub
  • StubDelegate
  • StubNotFoundException
  • Style
  • Style
  • Styleable
  • StyleableBooleanProperty
  • StyleableDoubleProperty
  • StyleableFloatProperty
  • StyleableIntegerProperty
  • StyleableLongProperty
  • StyleableObjectProperty
  • StyleableProperty
  • StyleablePropertyFactory
  • StyleableStringProperty
  • StyleClass
  • StyleConstants
  • StyleConstants.CharacterConstants
  • StyleConstants.ColorConstants
  • StyleConstants.FontConstants
  • StyleConstants.ParagraphConstants
  • StyleContext
  • StyleConverter
  • StyleConverter.StringStore
  • StyledDocument
  • StyledEditorKit
  • StyledEditorKit.AlignmentAction
  • StyledEditorKit.BoldAction
  • StyledEditorKit.FontFamilyAction
  • StyledEditorKit.FontSizeAction
  • StyledEditorKit.ForegroundAction
  • StyledEditorKit.ItalicAction
  • StyledEditorKit.StyledTextAction
  • StyledEditorKit.UnderlineAction
  • StyleOrigin
  • Stylesheet
  • StyleSheet
  • StyleSheet
  • StyleSheet.BoxPainter
  • StyleSheet.ListPainter
  • StyleSheetList
  • Subject
  • SubjectDelegationPermission
  • SubjectDomainCombiner
  • SubmissionPublisher
  • SubScene
  • SubtitleTrack
  • SUCCESSFUL
  • Supplier
  • SupportedAnnotationTypes
  • SupportedOptions
  • SupportedSourceVersion
  • SupportedValuesAttribute
  • SuppressWarnings
  • SVGPath
  • SwingConstants
  • SwingContainer
  • SwingEventMonitor
  • SwingFXUtils
  • SwingNode
  • SwingPropertyChangeSupport
  • SwingUtilities
  • SwingWorker
  • SwingWorker.StateValue
  • SwipeEvent
  • SwitchPoint
  • SwitchTree
  • SwitchTree
  • SYNC_WITH_TRANSPORT
  • SyncFactory
  • SyncFactoryException
  • SyncFailedException
  • SynchronizedTree
  • SynchronousQueue
  • SyncProvider
  • SyncProviderException
  • SyncResolver
  • SyncScopeHelper
  • SynthButtonUI
  • SynthCheckBoxMenuItemUI
  • SynthCheckBoxUI
  • SynthColorChooserUI
  • SynthComboBoxUI
  • SynthConstants
  • SynthContext
  • SynthDesktopIconUI
  • SynthDesktopPaneUI
  • SynthEditorPaneUI
  • Synthesizer
  • SynthFormattedTextFieldUI
  • SynthGraphicsUtils
  • SynthIcon
  • SynthInternalFrameUI
  • SynthLabelUI
  • SynthListUI
  • SynthLookAndFeel
  • SynthMenuBarUI
  • SynthMenuItemUI
  • SynthMenuUI
  • SynthOptionPaneUI
  • SynthPainter
  • SynthPanelUI
  • SynthPasswordFieldUI
  • SynthPopupMenuUI
  • SynthProgressBarUI
  • SynthRadioButtonMenuItemUI
  • SynthRadioButtonUI
  • SynthRootPaneUI
  • SynthScrollBarUI
  • SynthScrollPaneUI
  • SynthSeparatorUI
  • SynthSliderUI
  • SynthSpinnerUI
  • SynthSplitPaneUI
  • SynthStyle
  • SynthStyleFactory
  • SynthTabbedPaneUI
  • SynthTableHeaderUI
  • SynthTableUI
  • SynthTextAreaUI
  • SynthTextFieldUI
  • SynthTextPaneUI
  • SynthToggleButtonUI
  • SynthToolBarUI
  • SynthToolTipUI
  • SynthTreeUI
  • SynthUI
  • SynthViewportUI
  • SysexMessage
  • System
  • SYSTEM_EXCEPTION
  • System.Logger
  • System.Logger.Level
  • System.LoggerFinder
  • SystemColor
  • SystemEventListener
  • SystemException
  • SystemFlavorMap
  • SystemSleepEvent
  • SystemSleepListener
  • SystemTray
  • Tab
  • TabableView
  • TabbedPaneUI
  • TabExpander
  • TableCell
  • TableCellEditor
  • TableCellRenderer
  • TableCellSkin
  • TableCellSkinBase
  • TableColumn
  • TableColumn
  • TableColumn.CellDataFeatures
  • TableColumn.CellEditEvent
  • TableColumn.SortType
  • TableColumnBase
  • TableColumnHeader
  • TableColumnModel
  • TableColumnModelEvent
  • TableColumnModelListener
  • TableFocusModel
  • TableHeaderRow
  • TableHeaderUI
  • TableModel
  • TableModelEvent
  • TableModelListener
  • TablePosition
  • TablePositionBase
  • TableRow
  • TableRowSkin
  • TableRowSkinBase
  • TableRowSorter
  • TableSelectionModel
  • TableStringConverter
  • TableUI
  • TableView
  • TableView
  • TableView.ResizeFeatures
  • TableView.TableViewFocusModel
  • TableView.TableViewSelectionModel
  • TableViewSkin
  • TableViewSkinBase
  • TabPane
  • TabPane.TabClosingPolicy
  • TabPaneSkin
  • TabSet
  • TabStop
  • TabularData
  • TabularDataSupport
  • TabularType
  • Tag
  • TAG_ALTERNATE_IIOP_ADDRESS
  • TAG_CODE_SETS
  • TAG_INTERNET_IOP
  • TAG_JAVA_CODEBASE
  • TAG_MULTIPLE_COMPONENTS
  • TAG_ORB_TYPE
  • TAG_POLICIES
  • TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • TagElement
  • TaggedComponent
  • TaggedComponentHelper
  • TaggedComponentHolder
  • TaggedProfile
  • TaggedProfileHelper
  • TaggedProfileHolder
  • Taglet
  • Taglet
  • Taglet.Location
  • Target
  • TargetDataLine
  • TargetedNotification
  • Task
  • Taskbar
  • Taskbar.Feature
  • Taskbar.State
  • TaskEvent
  • TaskEvent.Kind
  • TaskListener
  • TCKind
  • TemplateLiteralTree
  • Templates
  • TemplatesHandler
  • Temporal
  • TemporalAccessor
  • TemporalAdjuster
  • TemporalAdjusters
  • TemporalAmount
  • TemporalField
  • TemporalQueries
  • TemporalQuery
  • TemporalUnit
  • TerminalFactory
  • TerminalFactorySpi
  • Text
  • Text
  • Text
  • TextAction
  • TextAlignment
  • TextArea
  • TextArea
  • TextAreaSkin
  • TextAttribute
  • TextBoundsType
  • TextCallbackHandler
  • TextComponent
  • TextEvent
  • TextField
  • TextField
  • TextFieldListCell
  • TextFieldSkin
  • TextFieldTableCell
  • TextFieldTreeCell
  • TextFieldTreeTableCell
  • TextFlow
  • TextFormatter
  • TextFormatter.Change
  • TextHitInfo
  • TextInputCallback
  • TextInputControl
  • TextInputControl.Content
  • TextInputControlSkin
  • TextInputControlSkin.Direction
  • TextInputControlSkin.TextUnit
  • TextInputDialog
  • TextLayout
  • TextLayout.CaretPolicy
  • TextListener
  • TextMeasurer
  • TextOutputCallback
  • TextStyle
  • TextSyntax
  • TextTree
  • TextUI
  • TexturePaint
  • ThaiBuddhistChronology
  • ThaiBuddhistDate
  • ThaiBuddhistEra
  • Thread
  • THREAD_POLICY_ID
  • Thread.State
  • Thread.UncaughtExceptionHandler
  • ThreadDeath
  • ThreadDeathEvent
  • ThreadDeathRequest
  • ThreadFactory
  • ThreadGroup
  • ThreadGroupReference
  • ThreadInfo
  • ThreadLocal
  • ThreadLocalRandom
  • ThreadMXBean
  • ThreadMXBean
  • ThreadPolicy
  • ThreadPolicyOperations
  • ThreadPolicyValue
  • ThreadPoolExecutor
  • ThreadPoolExecutor.AbortPolicy
  • ThreadPoolExecutor.CallerRunsPolicy
  • ThreadPoolExecutor.DiscardOldestPolicy
  • ThreadPoolExecutor.DiscardPolicy
  • ThreadReference
  • ThreadStartEvent
  • ThreadStartRequest
  • Throwable
  • ThrowsTag
  • ThrowsTree
  • ThrowTree
  • ThrowTree
  • Tie
  • TIFFDirectory
  • TIFFField
  • TIFFImageReadParam
  • TIFFTag
  • TIFFTagSet
  • TileObserver
  • TilePane
  • Time
  • TimeLimitExceededException
  • Timeline
  • TIMEOUT
  • TimeoutException
  • Timer
  • Timer
  • Timer
  • TimerMBean
  • TimerNotification
  • TimerTask
  • Timestamp
  • Timestamp
  • TimeStringConverter
  • TimeUnit
  • TimeZone
  • TimeZoneNameProvider
  • TitledBorder
  • TitledPane
  • TitledPaneSkin
  • ToDoubleBiFunction
  • ToDoubleFunction
  • Toggle
  • ToggleButton
  • ToggleButtonSkin
  • ToggleGroup
  • ToIntBiFunction
  • ToIntFunction
  • ToLongBiFunction
  • ToLongFunction
  • Tool
  • ToolBar
  • ToolBarSkin
  • ToolBarUI
  • Toolkit
  • ToolProvider
  • ToolProvider
  • Tooltip
  • ToolTipManager
  • TooltipSkin
  • ToolTipUI
  • TooManyListenersException
  • TopLevelWindowListener
  • TouchEvent
  • TouchPoint
  • TouchPoint.State
  • Track
  • Track
  • TRANSACTION_MODE
  • TRANSACTION_REQUIRED
  • TRANSACTION_ROLLEDBACK
  • TRANSACTION_UNAVAILABLE
  • TransactionalWriter
  • TransactionRequiredException
  • TransactionRolledbackException
  • TransactionService
  • Transferable
  • TransferHandler
  • TransferHandler.DropLocation
  • TransferHandler.TransferSupport
  • TransferMode
  • TransferQueue
  • Transform
  • Transform
  • TransformationList
  • TransformAttribute
  • TransformChangedEvent
  • Transformer
  • TransformerConfigurationException
  • TransformerException
  • TransformerFactory
  • TransformerFactoryConfigurationError
  • TransformerHandler
  • TransformException
  • TransformParameterSpec
  • TransformService
  • Transient
  • TRANSIENT
  • Transition
  • Translate
  • TranslateTransition
  • Translator
  • Transmitter
  • Transparency
  • Transport
  • TRANSPORT_RETRY
  • TransportService
  • TransportService.Capabilities
  • TransportService.ListenKey
  • TransportTimeoutException
  • TrayIcon
  • TrayIcon.MessageType
  • 树
  • 树
  • Tree.Kind
  • Tree.Kind
  • TreeCell
  • TreeCellEditor
  • TreeCellRenderer
  • TreeCellSkin
  • TreeExpansionEvent
  • TreeExpansionListener
  • TreeItem
  • TreeItem.TreeModificationEvent
  • TreeItemPropertyValueFactory
  • TreeMap
  • TreeModel
  • TreeModelEvent
  • TreeModelListener
  • TreeNode
  • TreePath
  • TreePath
  • TreePathScanner
  • Trees
  • TreeScanner
  • TreeSelectionEvent
  • TreeSelectionListener
  • TreeSelectionModel
  • TreeSet
  • TreeSortMode
  • TreeTableCell
  • TreeTableCellSkin
  • TreeTableColumn
  • TreeTableColumn.CellDataFeatures
  • TreeTableColumn.CellEditEvent
  • TreeTableColumn.SortType
  • TreeTablePosition
  • TreeTableRow
  • TreeTableRowSkin
  • TreeTableView
  • TreeTableView.EditEvent
  • TreeTableView.ResizeFeatures
  • TreeTableView.TreeTableViewFocusModel
  • TreeTableView.TreeTableViewSelectionModel
  • TreeTableViewSkin
  • TreeUI
  • TreeView
  • TreeView.EditEvent
  • TreeViewSkin
  • TreeVisitor
  • TreeVisitor
  • TreeWalker
  • TreeWillExpandListener
  • TriangleMesh
  • TrustAnchor
  • TrustManager
  • TrustManagerFactory
  • TrustManagerFactorySpi
  • TryTree
  • TryTree
  • Type
  • Type
  • Type
  • TypeBasedGuardingDynamicLinker
  • TypeCastTree
  • TypeCode
  • TypeCodeHolder
  • TypeComponent
  • TypeConstraintException
  • TypeDeclSnippet
  • TypeElement
  • TypeInfo
  • TypeInfoProvider
  • TypeKind
  • TypeKindVisitor6
  • TypeKindVisitor7
  • TypeKindVisitor8
  • TypeKindVisitor9
  • TypeMirror
  • TypeMismatch
  • TypeMismatch
  • TypeMismatch
  • TypeMismatchHelper
  • TypeMismatchHelper
  • TypeNotPresentException
  • TypeParameterElement
  • TypeParameterTree
  • Types
  • Types
  • TypeUtilities
  • TypeVariable
  • TypeVariable
  • TypeVariable
  • TypeVisitor
  • UIClientPropertyKey
  • UID
  • UIDefaults
  • UIDefaults.ActiveValue
  • UIDefaults.LazyInputMap
  • UIDefaults.LazyValue
  • UIDefaults.ProxyLazyValue
  • UIEvent
  • UIManager
  • UIManager.LookAndFeelInfo
  • UIResource
  • ULongLongSeqHelper
  • ULongLongSeqHolder
  • ULongSeqHelper
  • ULongSeqHolder
  • UnaryOperator
  • UnaryTree
  • UnaryTree
  • UnavailableServiceException
  • UncheckedIOException
  • UndeclaredThrowableException
  • UndoableEdit
  • UndoableEditEvent
  • UndoableEditListener
  • UndoableEditSupport
  • UndoManager
  • UnexpectedException
  • UnicastRemoteObject
  • UnionMember
  • UnionMemberHelper
  • UnionType
  • UnionTypeTree
  • UnixLoginModule
  • UnixNumericGroupPrincipal
  • UnixNumericUserPrincipal
  • UnixOperatingSystemMXBean
  • UnixPrincipal
  • UnixSystem
  • UNKNOWN
  • UNKNOWN
  • UnknownAnnotationValueException
  • UnknownBlockTagTree
  • UnknownDirectiveException
  • UnknownElementException
  • UnknownEncoding
  • UnknownEncodingHelper
  • UnknownEntityException
  • UnknownError
  • UnknownException
  • UnknownFormatConversionException
  • UnknownFormatFlagsException
  • UnknownGroupException
  • UnknownHostException
  • UnknownHostException
  • UnknownInlineTagTree
  • UnknownObjectException
  • UnknownServiceException
  • UnknownTreeException
  • UnknownTypeException
  • UnknownUserException
  • UnknownUserExceptionHelper
  • UnknownUserExceptionHolder
  • UnmappableCharacterException
  • UnmarshalException
  • UnmarshalException
  • Unmarshaller
  • Unmarshaller.Listener
  • UnmarshallerHandler
  • UnmodifiableClassException
  • UnmodifiableModuleException
  • UnmodifiableSetException
  • UnrecoverableEntryException
  • UnrecoverableKeyException
  • Unreferenced
  • UnresolvedAddressException
  • UnresolvedPermission
  • UnresolvedReferenceException
  • UnsatisfiedLinkError
  • UnsolicitedNotification
  • UnsolicitedNotificationEvent
  • UnsolicitedNotificationListener
  • UNSUPPORTED_POLICY
  • UNSUPPORTED_POLICY_VALUE
  • UnsupportedAddressTypeException
  • UnsupportedAudioFileException
  • UnsupportedCallbackException
  • UnsupportedCharsetException
  • UnsupportedClassVersionError
  • UnsupportedDataTypeException
  • UnsupportedEncodingException
  • UnsupportedFlavorException
  • UnsupportedLookAndFeelException
  • UnsupportedOperationException
  • UnsupportedTemporalTypeException
  • URI
  • URICertStoreParameters
  • URIDereferencer
  • URIException
  • URIParameter
  • URIReference
  • URIReferenceException
  • URIResolver
  • URISyntax
  • URISyntaxException
  • URL
  • URLClassLoader
  • URLConnection
  • URLConverter
  • URLConverter.SequenceConverter
  • URLDataSource
  • URLDecoder
  • URLEncoder
  • URLPermission
  • URLReader
  • URLStreamHandler
  • URLStreamHandlerFactory
  • URLStreamHandlerProvider
  • URLStringHelper
  • USER_EXCEPTION
  • UserDataHandler
  • UserDefinedFileAttributeView
  • UserException
  • UserJvmOptionsService
  • UserPrincipal
  • UserPrincipal
  • UserPrincipalLookupService
  • UserPrincipalNotFoundException
  • UserSessionEvent
  • UserSessionEvent.Reason
  • UserSessionListener
  • UsesTree
  • UsesTree
  • UShortSeqHelper
  • UShortSeqHolder
  • UTFDataFormatException
  • Util
  • Util
  • UtilDelegate
  • Utilities
  • UUID
  • ValidationEvent
  • ValidationEventCollector
  • ValidationEventHandler
  • ValidationEventImpl
  • ValidationEventLocator
  • ValidationEventLocatorImpl
  • ValidationException
  • Validator
  • Validator
  • ValidatorHandler
  • Value
  • ValueAxis
  • ValueBase
  • ValueBaseHelper
  • ValueBaseHolder
  • ValueExp
  • ValueFactory
  • ValueHandler
  • ValueHandlerMultiFormat
  • ValueInputStream
  • ValueMember
  • ValueMemberHelper
  • ValueOutputStream
  • ValueRange
  • ValueTree
  • VarHandle
  • VarHandle.AccessMode
  • VariableElement
  • VariableHeightLayoutCache
  • VariableTree
  • VariableTree
  • VarSnippet
  • VBox
  • Vector
  • VerifyError
  • VersionSpecHelper
  • VersionTree
  • VertexFormat
  • VerticalDirection
  • VetoableChangeListener
  • VetoableChangeListenerProxy
  • VetoableChangeSupport
  • VideoTrack
  • View
  • ViewCSS
  • ViewFactory
  • ViewportLayout
  • ViewportUI
  • VirtualContainerBase
  • VirtualFlow
  • VirtualMachine
  • VirtualMachine
  • VirtualMachineDescriptor
  • VirtualMachineError
  • VirtualMachineManager
  • Visibility
  • VisibilityHelper
  • VLineTo
  • VM_ABSTRACT
  • VM_CUSTOM
  • VM_NONE
  • VM_TRUNCATABLE
  • VMCannotBeModifiedException
  • VMDeathEvent
  • VMDeathRequest
  • VMDisconnectedException
  • VMDisconnectEvent
  • VMID
  • VMMismatchException
  • VMOption
  • VMOption.Origin
  • VMOutOfMemoryException
  • VMStartEvent
  • VMStartException
  • VoiceStatus
  • Void
  • VoidType
  • VoidValue
  • VolatileCallSite
  • VolatileImage
  • VPos
  • W3CDomHandler
  • W3CEndpointReference
  • W3CEndpointReferenceBuilder
  • Watchable
  • WatchEvent
  • WatchEvent.Kind
  • WatchEvent.Modifier
  • WatchKey
  • WatchpointEvent
  • WatchpointRequest
  • WatchService
  • WCharSeqHelper
  • WCharSeqHolder
  • WeakChangeListener
  • WeakEventHandler
  • WeakHashMap
  • WeakInvalidationListener
  • WeakListChangeListener
  • WeakListener
  • WeakMapChangeListener
  • WeakReference
  • WeakSetChangeListener
  • WebEndpoint
  • WebEngine
  • WebErrorEvent
  • WebEvent
  • WebFault
  • WebHistory
  • WebMethod
  • WebParam
  • WebParam.Mode
  • WebResult
  • WebRowSet
  • WebService
  • WebServiceClient
  • WebServiceContext
  • WebServiceException
  • WebServiceFeature
  • WebServiceFeatureAnnotation
  • WebServicePermission
  • WebServiceProvider
  • WebServiceRef
  • WebServiceRefs
  • WebSocket
  • WebSocket.Builder
  • WebSocket.Listener
  • WebSocket.MessagePart
  • WebSocketHandshakeException
  • WebView
  • WeekFields
  • When
  • WhileLoopTree
  • WhileLoopTree
  • WildcardTree
  • WildcardType
  • WildcardType
  • WildcardType
  • Window
  • Window
  • Window.Type
  • WindowAdapter
  • WindowConstants
  • WindowEvent
  • WindowEvent
  • WindowFocusListener
  • WindowListener
  • WindowStateListener
  • WithTree
  • Worker
  • Worker.State
  • WorkerStateEvent
  • WrappedPlainView
  • Wrapper
  • WritableBooleanValue
  • WritableByteChannel
  • WritableDoubleValue
  • WritableFloatValue
  • WritableImage
  • WritableIntegerValue
  • WritableListValue
  • WritableLongValue
  • WritableMapValue
  • WritableNumberValue
  • WritableObjectValue
  • WritablePixelFormat
  • WritableRaster
  • WritableRenderedImage
  • WritableSetValue
  • WritableStringValue
  • WritableValue
  • WriteAbortedException
  • WritePendingException
  • Writer
  • WrongAdapter
  • WrongAdapterHelper
  • WrongMethodTypeException
  • WrongPolicy
  • WrongPolicyHelper
  • WrongTransaction
  • WrongTransactionHelper
  • WrongTransactionHolder
  • WStringSeqHelper
  • WStringSeqHolder
  • WStringValueHelper
  • X500Principal
  • X500Principal
  • X500PrivateCredential
  • X509Certificate
  • X509Certificate
  • X509CertSelector
  • X509CRL
  • X509CRLEntry
  • X509CRLSelector
  • X509Data
  • X509EncodedKeySpec
  • X509ExtendedKeyManager
  • X509ExtendedTrustManager
  • X509Extension
  • X509IssuerSerial
  • X509KeyManager
  • X509TrustManager
  • XAConnection
  • XAConnectionBuilder
  • XADataSource
  • XAException
  • XAResource
  • Xid
  • XmlAccessOrder
  • XmlAccessorOrder
  • XmlAccessorType
  • XmlAccessType
  • XmlAdapter
  • XmlAnyAttribute
  • XmlAnyElement
  • XmlAttachmentRef
  • XmlAttribute
  • XMLConstants
  • XMLCryptoContext
  • XMLDecoder
  • XmlElement
  • XmlElement.DEFAULT
  • XmlElementDecl
  • XmlElementDecl.GLOBAL
  • XmlElementRef
  • XmlElementRef.DEFAULT
  • XmlElementRefs
  • XmlElements
  • XmlElementWrapper
  • XMLEncoder
  • XmlEnum
  • XmlEnumValue
  • XMLEvent
  • XMLEventAllocator
  • XMLEventConsumer
  • XMLEventFactory
  • XMLEventReader
  • XMLEventWriter
  • XMLFilter
  • XMLFilterImpl
  • XMLFormatter
  • XMLGregorianCalendar
  • XmlID
  • XmlIDREF
  • XmlInlineBinaryData
  • XMLInputFactory
  • XmlJavaTypeAdapter
  • XmlJavaTypeAdapter.DEFAULT
  • XmlJavaTypeAdapters
  • XmlList
  • XmlMimeType
  • XmlMixed
  • XmlNs
  • XmlNsForm
  • XMLObject
  • XMLOutputFactory
  • XMLParseException
  • XmlReader
  • XMLReader
  • XMLReaderAdapter
  • XMLReaderFactory
  • XmlRegistry
  • XMLReporter
  • XMLResolver
  • XmlRootElement
  • XmlSchema
  • XmlSchemaType
  • XmlSchemaType.DEFAULT
  • XmlSchemaTypes
  • XmlSeeAlso
  • XMLSignature
  • XMLSignature.SignatureValue
  • XMLSignatureException
  • XMLSignatureFactory
  • XMLSignContext
  • XMLStreamConstants
  • XMLStreamException
  • XMLStreamReader
  • XMLStreamWriter
  • XMLStructure
  • XmlTransient
  • XmlType
  • XmlType.DEFAULT
  • XMLValidateContext
  • XmlValue
  • XmlWriter
  • XPath
  • XPathConstants
  • XPathEvaluationResult
  • XPathEvaluationResult.XPathResultType
  • XPathEvaluator
  • XPathException
  • XPathException
  • XPathExpression
  • XPathExpression
  • XPathExpressionException
  • XPathFactory
  • XPathFactoryConfigurationException
  • XPathFilter2ParameterSpec
  • XPathFilterParameterSpec
  • XPathFunction
  • XPathFunctionException
  • XPathFunctionResolver
  • XPathNamespace
  • XPathNodes
  • XPathNSResolver
  • XPathResult
  • XPathType
  • XPathType.Filter
  • XPathVariableResolver
  • XSLTTransformParameterSpec
  • XYChart
  • XYChart.Data
  • XYChart.Series
  • Year
  • YearMonth
  • YieldTree
  • ZipEntry
  • ZipError
  • ZipException
  • ZipFile
  • ZipInputStream
  • ZipOutputStream
  • ZonedDateTime
  • ZoneId
  • ZoneOffset
  • ZoneOffsetTransition
  • ZoneOffsetTransitionRule
  • ZoneOffsetTransitionRule.TimeDefinition
  • ZoneRules
  • ZoneRulesException
  • ZoneRulesProvider
  • ZoneView
  • ZoomEvent
  • _BindingIteratorImplBase
  • _BindingIteratorStub
  • _DynAnyFactoryStub
  • _DynAnyStub
  • _DynArrayStub
  • _DynEnumStub
  • _DynFixedStub
  • _DynSequenceStub
  • _DynStructStub
  • _DynUnionStub
  • _DynValueStub
  • _IDLTypeStub
  • _NamingContextExtStub
  • _NamingContextImplBase
  • _NamingContextStub
  • _PolicyStub
  • _Remote_Stub
  • _ServantActivatorStub
  • _ServantLocatorStub


API Help (Java SE 9 & JDK 9 )

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

  • 概述

    The 概述 page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

  • 软件包

    Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain six categories:

    • Interfaces (italic)
    • Classes
    • Enums
    • Exceptions
    • Errors
    • 注解类型

  • Class/Interface

    Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

    • Class inheritance diagram
    • Direct Subclasses
    • All Known Subinterfaces
    • All Known Implementing Classes
    • Class/interface declaration
    • Class/interface description
    • Nested Class Summary
    • Field Summary
    • 构造方法摘要
    • 方法摘要
    • 字段详细信息
    • 构造方法详细信息
    • 方法详细信息

    Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

  • Annotation Type

    Each annotation type has its own separate page with the following sections:

    • Annotation Type declaration
    • Annotation Type description
    • Required Element Summary
    • Optional Element Summary
    • Element Detail

  • Enum

    Each enum has its own separate page with the following sections:

    • Enum declaration
    • Enum description
    • Enum Constant Summary
    • Enum Constant Detail

  • 使用

    Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

  • Tree (Class Hierarchy)

    There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.

    • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
    • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

  • Deprecated API

    The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

  • 索引

    The 索引 contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

  • Prev/Next

    These links take you to the next or previous class, interface, package, or related page.

  • Frames/No Frames

    These links show and hide the HTML frames. All pages are available with or without frames.

  • 所有类

    The 所有类 link shows all classes and interfaces except non-static nested types.

  • Serialized Form

    Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

  • Constant Field Values

    The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement
For further API reference and developer documentation see the Java SE Documentation, which contains more detailed, developer-targeted descriptions with conceptual overviews, definitions of terms, workarounds, and working code examples.
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2017, Oracle and/or its affiliates, 500 Oracle Parkway, Redwood Shores, CA 94065 USA.
All rights reserved. Use is subject to license terms and the documentation redistribution policy.

本帮助文档是使用 《谷歌翻译》翻译，请与英文版配合使用 by--QQ:654638585


Constant Field Values (Java SE 9 & JDK 9 )

  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Constant Field Values

Contents

  • com.sun.*
  • java.awt.*
  • java.beans.*
  • java.io.*
  • java.lang.*
  • java.math.*
  • java.net.*
  • java.nio.*
  • java.rmi.*
  • java.security.*
  • java.sql.*
  • java.text.*
  • java.time.*
  • java.util.*
  • javafx.animation.*
  • javafx.application.*
  • javafx.fxml.*
  • javafx.scene.*
  • javax.accessibility.*
  • javax.crypto.*
  • javax.imageio.*
  • javax.jnlp.*
  • javax.management.*
  • javax.naming.*
  • javax.net.*
  • javax.print.*
  • javax.script.*
  • javax.security.*
  • javax.sound.*
  • javax.sql.*
  • javax.swing.*
  • javax.tools.*
  • javax.transaction.*
  • javax.xml.*
  • jdk.dynalink.*
  • jdk.incubator.*
  • jdk.jshell.*
  • jdk.nashorn.*
  • jdk.net.*
  • org.ietf.*
  • org.omg.*
  • org.w3c.*
  • org.xml.*

com.sun.*

  • com.sun.java.accessibility.util.EventID
    Modifier and Type | Constant Field | Value
    public static final int | ACTION | 0
    public static final int | ADJUSTMENT | 1
    public static final int | ANCESTOR | 12
    public static final int | CARET | 13
    public static final int | CELLEDITOR | 14
    public static final int | CHANGE | 15
    public static final int | COLUMNMODEL | 16
    public static final int | COMPONENT | 2
    public static final int | CONTAINER | 3
    public static final int | DOCUMENT | 17
    public static final int | FOCUS | 4
    public static final int | INTERNALFRAME | 29
    public static final int | ITEM | 5
    public static final int | KEY | 6
    public static final int | LISTDATA | 18
    public static final int | LISTSELECTION | 19
    public static final int | MENU | 20
    public static final int | MOTION | 8
    public static final int | MOUSE | 7
    public static final int | POPUPMENU | 21
    public static final int | PROPERTYCHANGE | 27
    public static final int | TABLEMODEL | 22
    public static final int | TEXT | 10
    public static final int | TREEEXPANSION | 23
    public static final int | TREEMODEL | 24
    public static final int | TREESELECTION | 25
    public static final int | UNDOABLEEDIT | 26
    public static final int | VETOABLECHANGE | 28
    public static final int | WINDOW | 11
  • com.sun.jdi.ClassType
    Modifier and Type | Constant Field | Value
    public static final int | INVOKE_SINGLE_THREADED | 1
  • com.sun.jdi.ObjectReference
    Modifier and Type | Constant Field | Value
    public static final int | INVOKE_NONVIRTUAL | 2
    public static final int | INVOKE_SINGLE_THREADED | 1
  • com.sun.jdi.ThreadReference
    Modifier and Type | Constant Field | Value
    public static final int | THREAD_STATUS_MONITOR | 3
    public static final int | THREAD_STATUS_NOT_STARTED | 5
    public static final int | THREAD_STATUS_RUNNING | 1
    public static final int | THREAD_STATUS_SLEEPING | 2
    public static final int | THREAD_STATUS_UNKNOWN | -1
    public static final int | THREAD_STATUS_WAIT | 4
    public static final int | THREAD_STATUS_ZOMBIE | 0
  • com.sun.jdi.VirtualMachine
    Modifier and Type | Constant Field | Value
    public static final int | TRACE_ALL | 16777215
    public static final int | TRACE_EVENTS | 4
    public static final int | TRACE_NONE | 0
    public static final int | TRACE_OBJREFS | 16
    public static final int | TRACE_RECEIVES | 2
    public static final int | TRACE_REFTYPES | 8
    public static final int | TRACE_SENDS | 1
  • com.sun.jdi.request.EventRequest
    Modifier and Type | Constant Field | Value
    public static final int | SUSPEND_ALL | 2
    public static final int | SUSPEND_EVENT_THREAD | 1
    public static final int | SUSPEND_NONE | 0
  • com.sun.jdi.request.StepRequest
    Modifier and Type | Constant Field | Value
    public static final int | STEP_INTO | 1
    public static final int | STEP_LINE | -2
    public static final int | STEP_MIN | -1
    public static final int | STEP_OUT | 3
    public static final int | STEP_OVER | 2
  • com.sun.management.GarbageCollectionNotificationInfo
    Modifier and Type | Constant Field | Value
    public static final String | GARBAGE_COLLECTION_NOTIFICATION | "com.sun.management.gc.notification"
  • com.sun.security.auth.module.JndiLoginModule
    Modifier and Type | Constant Field | Value
    public final String | GROUP_PROVIDER | "group.provider.url"
    public final String | USER_PROVIDER | "user.provider.url"
  • com.sun.tools.jconsole.JConsoleContext
    Modifier and Type | Constant Field | Value
    public static final String | CONNECTION_STATE_PROPERTY | "connectionState"

java.awt.*

  • java.awt.Adjustable
    Modifier and Type | Constant Field | Value
    public static final int | HORIZONTAL | 0
    public static final int | NO_ORIENTATION | 2
    public static final int | VERTICAL | 1
  • java.awt.AlphaComposite
    Modifier and Type | Constant Field | Value
    public static final int | CLEAR | 1
    public static final int | DST | 9
    public static final int | DST_ATOP | 11
    public static final int | DST_IN | 6
    public static final int | DST_OUT | 8
    public static final int | DST_OVER | 4
    public static final int | SRC | 2
    public static final int | SRC_ATOP | 10
    public static final int | SRC_IN | 5
    public static final int | SRC_OUT | 7
    public static final int | SRC_OVER | 3
    public static final int | XOR | 12
  • java.awt.AWTEvent
    Modifier and Type | Constant Field | Value
    public static final long | ACTION_EVENT_MASK | 128L
    public static final long | ADJUSTMENT_EVENT_MASK | 256L
    public static final long | COMPONENT_EVENT_MASK | 1L
    public static final long | CONTAINER_EVENT_MASK | 2L
    public static final long | FOCUS_EVENT_MASK | 4L
    public static final long | HIERARCHY_BOUNDS_EVENT_MASK | 65536L
    public static final long | HIERARCHY_EVENT_MASK | 32768L
    public static final long | INPUT_METHOD_EVENT_MASK | 2048L
    public static final long | INVOCATION_EVENT_MASK | 16384L
    public static final long | ITEM_EVENT_MASK | 512L
    public static final long | KEY_EVENT_MASK | 8L
    public static final long | MOUSE_EVENT_MASK | 16L
    public static final long | MOUSE_MOTION_EVENT_MASK | 32L
    public static final long | MOUSE_WHEEL_EVENT_MASK | 131072L
    public static final long | PAINT_EVENT_MASK | 8192L
    public static final int | RESERVED_ID_MAX | 1999
    public static final long | TEXT_EVENT_MASK | 1024L
    public static final long | WINDOW_EVENT_MASK | 64L
    public static final long | WINDOW_FOCUS_EVENT_MASK | 524288L
    public static final long | WINDOW_STATE_EVENT_MASK | 262144L
  • java.awt.BasicStroke
    Modifier and Type | Constant Field | Value
    public static final int | CAP_BUTT | 0
    public static final int | CAP_ROUND | 1
    public static final int | CAP_SQUARE | 2
    public static final int | JOIN_BEVEL | 2
    public static final int | JOIN_MITER | 0
    public static final int | JOIN_ROUND | 1
  • java.awt.BorderLayout
    Modifier and Type | Constant Field | Value
    public static final String | AFTER_LAST_LINE | "Last"
    public static final String | AFTER_LINE_ENDS | "After"
    public static final String | BEFORE_FIRST_LINE | "First"
    public static final String | BEFORE_LINE_BEGINS | "Before"
    public static final String | CENTER | "Center"
    public static final String | EAST | "East"
    public static final String | LINE_END | "After"
    public static final String | LINE_START | "Before"
    public static final String | NORTH | "North"
    public static final String | PAGE_END | "Last"
    public static final String | PAGE_START | "First"
    public static final String | SOUTH | "South"
    public static final String | WEST | "West"
  • java.awt.Component
    Modifier and Type | Constant Field | Value
    public static final float | BOTTOM_ALIGNMENT | 1.0f
    public static final float | CENTER_ALIGNMENT | 0.5f
    public static final float | LEFT_ALIGNMENT | 0.0f
    public static final float | RIGHT_ALIGNMENT | 1.0f
    public static final float | TOP_ALIGNMENT | 0.0f
  • java.awt.Cursor
    Modifier and Type | Constant Field | Value
    public static final int | CROSSHAIR_CURSOR | 1
    public static final int | CUSTOM_CURSOR | -1
    public static final int | DEFAULT_CURSOR | 0
    public static final int | E_RESIZE_CURSOR | 11
    public static final int | HAND_CURSOR | 12
    public static final int | MOVE_CURSOR | 13
    public static final int | N_RESIZE_CURSOR | 8
    public static final int | NE_RESIZE_CURSOR | 7
    public static final int | NW_RESIZE_CURSOR | 6
    public static final int | S_RESIZE_CURSOR | 9
    public static final int | SE_RESIZE_CURSOR | 5
    public static final int | SW_RESIZE_CURSOR | 4
    public static final int | TEXT_CURSOR | 2
    public static final int | W_RESIZE_CURSOR | 10
    public static final int | WAIT_CURSOR | 3
  • java.awt.DisplayMode
    Modifier and Type | Constant Field | Value
    public static final int | BIT_DEPTH_MULTI | -1
    public static final int | REFRESH_RATE_UNKNOWN | 0
  • java.awt.Event
    Modifier and Type | Constant Field | Value
    public static final int | ACTION_EVENT | 1001
    public static final int | ALT_MASK | 8
    public static final int | BACK_SPACE | 8
    public static final int | CAPS_LOCK | 1022
    public static final int | CTRL_MASK | 2
    public static final int | DELETE | 127
    public static final int | DOWN | 1005
    public static final int | END | 1001
    public static final int | ENTER | 10
    public static final int | ESCAPE | 27
    public static final int | F1 | 1008
    public static final int | F10 | 1017
    public static final int | F11 | 1018
    public static final int | F12 | 1019
    public static final int | F2 | 1009
    public static final int | F3 | 1010
    public static final int | F4 | 1011
    public static final int | F5 | 1012
    public static final int | F6 | 1013
    public static final int | F7 | 1014
    public static final int | F8 | 1015
    public static final int | F9 | 1016
    public static final int | GOT_FOCUS | 1004
    public static final int | HOME | 1000
    public static final int | INSERT | 1025
    public static final int | KEY_ACTION | 403
    public static final int | KEY_ACTION_RELEASE | 404
    public static final int | KEY_PRESS | 401
    public static final int | KEY_RELEASE | 402
    public static final int | LEFT | 1006
    public static final int | LIST_DESELECT | 702
    public static final int | LIST_SELECT | 701
    public static final int | LOAD_FILE | 1002
    public static final int | LOST_FOCUS | 1005
    public static final int | META_MASK | 4
    public static final int | MOUSE_DOWN | 501
    public static final int | MOUSE_DRAG | 506
    public static final int | MOUSE_ENTER | 504
    public static final int | MOUSE_EXIT | 505
    public static final int | MOUSE_MOVE | 503
    public static final int | MOUSE_UP | 502
    public static final int | NUM_LOCK | 1023
    public static final int | PAUSE | 1024
    public static final int | PGDN | 1003
    public static final int | PGUP | 1002
    public static final int | PRINT_SCREEN | 1020
    public static final int | RIGHT | 1007
    public static final int | SAVE_FILE | 1003
    public static final int | SCROLL_ABSOLUTE | 605
    public static final int | SCROLL_BEGIN | 606
    public static final int | SCROLL_END | 607
    public static final int | SCROLL_LINE_DOWN | 602
    public static final int | SCROLL_LINE_UP | 601
    public static final int | SCROLL_LOCK | 1021
    public static final int | SCROLL_PAGE_DOWN | 604
    public static final int | SCROLL_PAGE_UP | 603
    public static final int | SHIFT_MASK | 1
    public static final int | TAB | 9
    public static final int | UP | 1004
    public static final int | WINDOW_DEICONIFY | 204
    public static final int | WINDOW_DESTROY | 201
    public static final int | WINDOW_EXPOSE | 202
    public static final int | WINDOW_ICONIFY | 203
    public static final int | WINDOW_MOVED | 205
  • java.awt.FileDialog
    Modifier and Type | Constant Field | Value
    public static final int | LOAD | 0
    public static final int | SAVE | 1
  • java.awt.FlowLayout
    Modifier and Type | Constant Field | Value
    public static final int | CENTER | 1
    public static final int | LEADING | 3
    public static final int | LEFT | 0
    public static final int | RIGHT | 2
    public static final int | TRAILING | 4
  • java.awt.Font
    Modifier and Type | Constant Field | Value
    public static final int | BOLD | 1
    public static final int | CENTER_BASELINE | 1
    public static final String | DIALOG | "Dialog"
    public static final String | DIALOG_INPUT | "DialogInput"
    public static final int | HANGING_BASELINE | 2
    public static final int | ITALIC | 2
    public static final int | LAYOUT_LEFT_TO_RIGHT | 0
    public static final int | LAYOUT_NO_LIMIT_CONTEXT | 4
    public static final int | LAYOUT_NO_START_CONTEXT | 2
    public static final int | LAYOUT_RIGHT_TO_LEFT | 1
    public static final String | MONOSPACED | "Monospaced"
    public static final int | PLAIN | 0
    public static final int | ROMAN_BASELINE | 0
    public static final String | SANS_SERIF | "SansSerif"
    public static final String | SERIF | "Serif"
    public static final int | TRUETYPE_FONT | 0
    public static final int | TYPE1_FONT | 1
  • java.awt.Frame
    Modifier and Type | Constant Field | Value
    public static final int | CROSSHAIR_CURSOR | 1
    public static final int | DEFAULT_CURSOR | 0
    public static final int | E_RESIZE_CURSOR | 11
    public static final int | HAND_CURSOR | 12
    public static final int | ICONIFIED | 1
    public static final int | MAXIMIZED_BOTH | 6
    public static final int | MAXIMIZED_HORIZ | 2
    public static final int | MAXIMIZED_VERT | 4
    public static final int | MOVE_CURSOR | 13
    public static final int | N_RESIZE_CURSOR | 8
    public static final int | NE_RESIZE_CURSOR | 7
    public static final int | NORMAL | 0
    public static final int | NW_RESIZE_CURSOR | 6
    public static final int | S_RESIZE_CURSOR | 9
    public static final int | SE_RESIZE_CURSOR | 5
    public static final int | SW_RESIZE_CURSOR | 4
    public static final int | TEXT_CURSOR | 2
    public static final int | W_RESIZE_CURSOR | 10
    public static final int | WAIT_CURSOR | 3
  • java.awt.GraphicsConfigTemplate
    Modifier and Type | Constant Field | Value
    public static final int | PREFERRED | 2
    public static final int | REQUIRED | 1
    public static final int | UNNECESSARY | 3
  • java.awt.GraphicsDevice
    Modifier and Type | Constant Field | Value
    public static final int | TYPE_IMAGE_BUFFER | 2
    public static final int | TYPE_PRINTER | 1
    public static final int | TYPE_RASTER_SCREEN | 0
  • java.awt.GridBagConstraints
    Modifier and Type | Constant Field | Value
    public static final int | ABOVE_BASELINE | 1024
    public static final int | ABOVE_BASELINE_LEADING | 1280
    public static final int | ABOVE_BASELINE_TRAILING | 1536
    public static final int | BASELINE | 256
    public static final int | BASELINE_LEADING | 512
    public static final int | BASELINE_TRAILING | 768
    public static final int | BELOW_BASELINE | 1792
    public static final int | BELOW_BASELINE_LEADING | 2048
    public static final int | BELOW_BASELINE_TRAILING | 2304
    public static final int | BOTH | 1
    public static final int | CENTER | 10
    public static final int | EAST | 13
    public static final int | FIRST_LINE_END | 24
    public static final int | FIRST_LINE_START | 23
    public static final int | HORIZONTAL | 2
    public static final int | LAST_LINE_END | 26
    public static final int | LAST_LINE_START | 25
    public static final int | LINE_END | 22
    public static final int | LINE_START | 21
    public static final int | NONE | 0
    public static final int | NORTH | 11
    public static final int | NORTHEAST | 12
    public static final int | NORTHWEST | 18
    public static final int | PAGE_END | 20
    public static final int | PAGE_START | 19
    public static final int | RELATIVE | -1
    public static final int | REMAINDER | 0
    public static final int | SOUTH | 15
    public static final int | SOUTHEAST | 14
    public static final int | SOUTHWEST | 16
    public static final int | VERTICAL | 3
    public static final int | WEST | 17
  • java.awt.GridBagLayout
    Modifier and Type | Constant Field | Value
    protected static final int | MAXGRIDSIZE | 512
    protected static final int | MINSIZE | 1
    protected static final int | PREFERREDSIZE | 2
  • java.awt.Image
    Modifier and Type | Constant Field | Value
    public static final int | SCALE_AREA_AVERAGING | 16
    public static final int | SCALE_DEFAULT | 1
    public static final int | SCALE_FAST | 2
    public static final int | SCALE_REPLICATE | 8
    public static final int | SCALE_SMOOTH | 4
  • java.awt.KeyboardFocusManager
    Modifier and Type | Constant Field | Value
    public static final int | BACKWARD_TRAVERSAL_KEYS | 1
    public static final int | DOWN_CYCLE_TRAVERSAL_KEYS | 3
    public static final int | FORWARD_TRAVERSAL_KEYS | 0
    public static final int | UP_CYCLE_TRAVERSAL_KEYS | 2
  • java.awt.Label
    Modifier and Type | Constant Field | Value
    public static final int | CENTER | 1
    public static final int | LEFT | 0
    public static final int | RIGHT | 2
  • java.awt.MediaTracker
    Modifier and Type | Constant Field | Value
    public static final int | ABORTED | 2
    public static final int | COMPLETE | 8
    public static final int | ERRORED | 4
    public static final int | LOADING | 1
  • java.awt.Scrollbar
    Modifier and Type | Constant Field | Value
    public static final int | HORIZONTAL | 0
    public static final int | VERTICAL | 1
  • java.awt.ScrollPane
    Modifier and Type | Constant Field | Value
    public static final int | SCROLLBARS_ALWAYS | 1
    public static final int | SCROLLBARS_AS_NEEDED | 0
    public static final int | SCROLLBARS_NEVER | 2
  • java.awt.SystemColor
    Modifier and Type | Constant Field | Value
    public static final int | ACTIVE_CAPTION | 1
    public static final int | ACTIVE_CAPTION_BORDER | 3
    public static final int | ACTIVE_CAPTION_TEXT | 2
    public static final int | CONTROL | 17
    public static final int | CONTROL_DK_SHADOW | 22
    public static final int | CONTROL_HIGHLIGHT | 19
    public static final int | CONTROL_LT_HIGHLIGHT | 20
    public static final int | CONTROL_SHADOW | 21
    public static final int | CONTROL_TEXT | 18
    public static final int | DESKTOP | 0
    public static final int | INACTIVE_CAPTION | 4
    public static final int | INACTIVE_CAPTION_BORDER | 6
    public static final int | INACTIVE_CAPTION_TEXT | 5
    public static final int | INFO | 24
    public static final int | INFO_TEXT | 25
    public static final int | MENU | 10
    public static final int | MENU_TEXT | 11
    public static final int | NUM_COLORS | 26
    public static final int | SCROLLBAR | 23
    public static final int | TEXT | 12
    public static final int | TEXT_HIGHLIGHT | 14
    public static final int | TEXT_HIGHLIGHT_TEXT | 15
    public static final int | TEXT_INACTIVE_TEXT | 16
    public static final int | TEXT_TEXT | 13
    public static final int | WINDOW | 7
    public static final int | WINDOW_BORDER | 8
    public static final int | WINDOW_TEXT | 9
  • java.awt.TextArea
    Modifier and Type | Constant Field | Value
    public static final int | SCROLLBARS_BOTH | 0
    public static final int | SCROLLBARS_HORIZONTAL_ONLY | 2
    public static final int | SCROLLBARS_NONE | 3
    public static final int | SCROLLBARS_VERTICAL_ONLY | 1
  • java.awt.Transparency
    Modifier and Type | Constant Field | Value
    public static final int | BITMASK | 2
    public static final int | OPAQUE | 1
    public static final int | TRANSLUCENT | 3
  • java.awt.color.ColorSpace
    Modifier and Type | Constant Field | Value
    public static final int | CS_CIEXYZ | 1001
    public static final int | CS_GRAY | 1003
    public static final int | CS_LINEAR_RGB | 1004
    public static final int | CS_PYCC | 1002
    public static final int | CS_sRGB | 1000
    public static final int | TYPE_2CLR | 12
    public static final int | TYPE_3CLR | 13
    public static final int | TYPE_4CLR | 14
    public static final int | TYPE_5CLR | 15
    public static final int | TYPE_6CLR | 16
    public static final int | TYPE_7CLR | 17
    public static final int | TYPE_8CLR | 18
    public static final int | TYPE_9CLR | 19
    public static final int | TYPE_ACLR | 20
    public static final int | TYPE_BCLR | 21
    public static final int | TYPE_CCLR | 22
    public static final int | TYPE_CMY | 11
    public static final int | TYPE_CMYK | 9
    public static final int | TYPE_DCLR | 23
    public static final int | TYPE_ECLR | 24
    public static final int | TYPE_FCLR | 25
    public static final int | TYPE_GRAY | 6
    public static final int | TYPE_HLS | 8
    public static final int | TYPE_HSV | 7
    public static final int | TYPE_Lab | 1
    public static final int | TYPE_Luv | 2
    public static final int | TYPE_RGB | 5
    public static final int | TYPE_XYZ | 0
    public static final int | TYPE_YCbCr | 3
    public static final int | TYPE_Yxy | 4
  • java.awt.color.ICC_Profile
    Modifier and Type | Constant Field | Value
    public static final int | CLASS_ABSTRACT | 5
    public static final int | CLASS_COLORSPACECONVERSION | 4
    public static final int | CLASS_DEVICELINK | 3
    public static final int | CLASS_DISPLAY | 1
    public static final int | CLASS_INPUT | 0
    public static final int | CLASS_NAMEDCOLOR | 6
    public static final int | CLASS_OUTPUT | 2
    public static final int | icAbsoluteColorimetric | 3
    public static final int | icCurveCount | 8
    public static final int | icCurveData | 12
    public static final int | icHdrAttributes | 56
    public static final int | icHdrCmmId | 4
    public static final int | icHdrColorSpace | 16
    public static final int | icHdrCreator | 80
    public static final int | icHdrDate | 24
    public static final int | icHdrDeviceClass | 12
    public static final int | icHdrFlags | 44
    public static final int | icHdrIlluminant | 68
    public static final int | icHdrMagic | 36
    public static final int | icHdrManufacturer | 48
    public static final int | icHdrModel | 52
    public static final int | icHdrPcs | 20
    public static final int | icHdrPlatform | 40
    public static final int | icHdrProfileID | 84
    public static final int | icHdrRenderingIntent | 64
    public static final int | icHdrSize | 0
    public static final int | icHdrVersion | 8
    public static final int | icICCAbsoluteColorimetric | 3
    public static final int | icMediaRelativeColorimetric | 1
    public static final int | icPerceptual | 0
    public static final int | icRelativeColorimetric | 1
    public static final int | icSaturation | 2
    public static final int | icSigAbstractClass | 1633842036
    public static final int | icSigAToB0Tag | 1093812784
    public static final int | icSigAToB1Tag | 1093812785
    public static final int | icSigAToB2Tag | 1093812786
    public static final int | icSigBlueColorantTag | 1649957210
    public static final int | icSigBlueMatrixColumnTag | 1649957210
    public static final int | icSigBlueTRCTag | 1649693251
    public static final int | icSigBToA0Tag | 1110589744
    public static final int | icSigBToA1Tag | 1110589745
    public static final int | icSigBToA2Tag | 1110589746
    public static final int | icSigCalibrationDateTimeTag | 1667329140
    public static final int | icSigCharTargetTag | 1952543335
    public static final int | icSigChromaticAdaptationTag | 1667785060
    public static final int | icSigChromaticityTag | 1667789421
    public static final int | icSigCmyData | 1129142560
    public static final int | icSigCmykData | 1129142603
    public static final int | icSigColorantOrderTag | 1668051567
    public static final int | icSigColorantTableTag | 1668051572
    public static final int | icSigColorSpaceClass | 1936744803
    public static final int | icSigCopyrightTag | 1668313716
    public static final int | icSigCrdInfoTag | 1668441193
    public static final int | icSigDeviceMfgDescTag | 1684893284
    public static final int | icSigDeviceModelDescTag | 1684890724
    public static final int | icSigDeviceSettingsTag | 1684371059
    public static final int | icSigDisplayClass | 1835955314
    public static final int | icSigGamutTag | 1734438260
    public static final int | icSigGrayData | 1196573017
    public static final int | icSigGrayTRCTag | 1800688195
    public static final int | icSigGreenColorantTag | 1733843290
    public static final int | icSigGreenMatrixColumnTag | 1733843290
    public static final int | icSigGreenTRCTag | 1733579331
    public static final int | icSigHead | 1751474532
    public static final int | icSigHlsData | 1212961568
    public static final int | icSigHsvData | 1213421088
    public static final int | icSigInputClass | 1935896178
    public static final int | icSigLabData | 1281450528
    public static final int | icSigLinkClass | 1818848875
    public static final int | icSigLuminanceTag | 1819635049
    public static final int | icSigLuvData | 1282766368
    public static final int | icSigMeasurementTag | 1835360627
    public static final int | icSigMediaBlackPointTag | 1651208308
    public static final int | icSigMediaWhitePointTag | 2004119668
    public static final int | icSigNamedColor2Tag | 1852009522
    public static final int | icSigNamedColorClass | 1852662636
    public static final int | icSigOutputClass | 1886549106
    public static final int | icSigOutputResponseTag | 1919251312
    public static final int | icSigPreview0Tag | 1886545200
    public static final int | icSigPreview1Tag | 1886545201
    public static final int | icSigPreview2Tag | 1886545202
    public static final int | icSigProfileDescriptionTag | 1684370275
    public static final int | icSigProfileSequenceDescTag | 1886610801
    public static final int | icSigPs2CRD0Tag | 1886610480
    public static final int | icSigPs2CRD1Tag | 1886610481
    public static final int | icSigPs2CRD2Tag | 1886610482
    public static final int | icSigPs2CRD3Tag | 1886610483
    public static final int | icSigPs2CSATag | 1886597747
    public static final int | icSigPs2RenderingIntentTag | 1886597737
    public static final int | icSigRedColorantTag | 1918392666
    public static final int | icSigRedMatrixColumnTag | 1918392666
    public static final int | icSigRedTRCTag | 1918128707
    public static final int | icSigRgbData | 1380401696
    public static final int | icSigScreeningDescTag | 1935897188
    public static final int | icSigScreeningTag | 1935897198
    public static final int | icSigSpace2CLR | 843271250
    public static final int | icSigSpace3CLR | 860048466
    public static final int | icSigSpace4CLR | 876825682
    public static final int | icSigSpace5CLR | 893602898
    public static final int | icSigSpace6CLR | 910380114
    public static final int | icSigSpace7CLR | 927157330
    public static final int | icSigSpace8CLR | 943934546
    public static final int | icSigSpace9CLR | 960711762
    public static final int | icSigSpaceACLR | 1094929490
    public static final int | icSigSpaceBCLR | 1111706706
    public static final int | icSigSpaceCCLR | 1128483922
    public static final int | icSigSpaceDCLR | 1145261138
    public static final int | icSigSpaceECLR | 1162038354
    public static final int | icSigSpaceFCLR | 1178815570
    public static final int | icSigTechnologyTag | 1952801640
    public static final int | icSigUcrBgTag | 1650877472
    public static final int | icSigViewingCondDescTag | 1987405156
    public static final int | icSigViewingConditionsTag | 1986618743
    public static final int | icSigXYZData | 1482250784
    public static final int | icSigYCbCrData | 1497588338
    public static final int | icSigYxyData | 1501067552
    public static final int | icTagReserved | 4
    public static final int | icTagType | 0
    public static final int | icXYZNumberX | 8
  • java.awt.color.ICC_ProfileRGB
    Modifier and Type | Constant Field | Value
    public static final int | BLUECOMPONENT | 2
    public static final int | GREENCOMPONENT | 1
    public static final int | REDCOMPONENT | 0
  • java.awt.datatransfer.DataFlavor
    Modifier and Type | Constant Field | Value
    public static final String | javaJVMLocalObjectMimeType | "application/x-java-jvm-local-objectref"
    public static final String | javaRemoteObjectMimeType | "application/x-java-remote-object"
    public static final String | javaSerializedObjectMimeType | "application/x-java-serialized-object"
  • java.awt.dnd.DnDConstants
    Modifier and Type | Constant Field | Value
    public static final int | ACTION_COPY | 1
    public static final int | ACTION_COPY_OR_MOVE | 3
    public static final int | ACTION_LINK | 1073741824
    public static final int | ACTION_MOVE | 2
    public static final int | ACTION_NONE | 0
    public static final int | ACTION_REFERENCE | 1073741824
  • java.awt.dnd.DragSourceContext
    Modifier and Type | Constant Field | Value
    protected static final int | CHANGED | 3
    protected static final int | DEFAULT | 0
    protected static final int | ENTER | 1
    protected static final int | OVER | 2
  • java.awt.event.ActionEvent
    Modifier and Type | Constant Field | Value
    public static final int | ACTION_FIRST | 1001
    public static final int | ACTION_LAST | 1001
    public static final int | ACTION_PERFORMED | 1001
    public static final int | ALT_MASK | 8
    public static final int | CTRL_MASK | 2
    public static final int | META_MASK | 4
    public static final int | SHIFT_MASK | 1
  • java.awt.event.AdjustmentEvent
    Modifier and Type | Constant Field | Value
    public static final int | ADJUSTMENT_FIRST | 601
    public static final int | ADJUSTMENT_LAST | 601
    public static final int | ADJUSTMENT_VALUE_CHANGED | 601
    public static final int | BLOCK_DECREMENT | 3
    public static final int | BLOCK_INCREMENT | 4
    public static final int | TRACK | 5
    public static final int | UNIT_DECREMENT | 2
    public static final int | UNIT_INCREMENT | 1
  • java.awt.event.ComponentEvent
    Modifier and Type | Constant Field | Value
    public static final int | COMPONENT_FIRST | 100
    public static final int | COMPONENT_HIDDEN | 103
    public static final int | COMPONENT_LAST | 103
    public static final int | COMPONENT_MOVED | 100
    public static final int | COMPONENT_RESIZED | 101
    public static final int | COMPONENT_SHOWN | 102
  • java.awt.event.ContainerEvent
    Modifier and Type | Constant Field | Value
    public static final int | COMPONENT_ADDED | 300
    public static final int | COMPONENT_REMOVED | 301
    public static final int | CONTAINER_FIRST | 300
    public static final int | CONTAINER_LAST | 301
  • java.awt.event.FocusEvent
    Modifier and Type | Constant Field | Value
    public static final int | FOCUS_FIRST | 1004
    public static final int | FOCUS_GAINED | 1004
    public static final int | FOCUS_LAST | 1005
    public static final int | FOCUS_LOST | 1005
  • java.awt.event.HierarchyEvent
    Modifier and Type | Constant Field | Value
    public static final int | ANCESTOR_MOVED | 1401
    public static final int | ANCESTOR_RESIZED | 1402
    public static final int | DISPLAYABILITY_CHANGED | 2
    public static final int | HIERARCHY_CHANGED | 1400
    public static final int | HIERARCHY_FIRST | 1400
    public static final int | HIERARCHY_LAST | 1402
    public static final int | PARENT_CHANGED | 1
    public static final int | SHOWING_CHANGED | 4
  • java.awt.event.InputEvent
    Modifier and Type | Constant Field | Value
    public static final int | ALT_DOWN_MASK | 512
    public static final int | ALT_GRAPH_DOWN_MASK | 8192
    public static final int | ALT_GRAPH_MASK | 32
    public static final int | ALT_MASK | 8
    public static final int | BUTTON1_DOWN_MASK | 1024
    public static final int | BUTTON1_MASK | 16
    public static final int | BUTTON2_DOWN_MASK | 2048
    public static final int | BUTTON2_MASK | 8
    public static final int | BUTTON3_DOWN_MASK | 4096
    public static final int | BUTTON3_MASK | 4
    public static final int | CTRL_DOWN_MASK | 128
    public static final int | CTRL_MASK | 2
    public static final int | META_DOWN_MASK | 256
    public static final int | META_MASK | 4
    public static final int | SHIFT_DOWN_MASK | 64
    public static final int | SHIFT_MASK | 1
  • java.awt.event.InputMethodEvent
    Modifier and Type | Constant Field | Value
    public static final int | CARET_POSITION_CHANGED | 1101
    public static final int | INPUT_METHOD_FIRST | 1100
    public static final int | INPUT_METHOD_LAST | 1101
    public static final int | INPUT_METHOD_TEXT_CHANGED | 1100
  • java.awt.event.InvocationEvent
    Modifier and Type | Constant Field | Value
    public static final int | INVOCATION_DEFAULT | 1200
    public static final int | INVOCATION_FIRST | 1200
    public static final int | INVOCATION_LAST | 1200
  • java.awt.event.ItemEvent
    Modifier and Type | Constant Field | Value
    public static final int | DESELECTED | 2
    public static final int | ITEM_FIRST | 701
    public static final int | ITEM_LAST | 701
    public static final int | ITEM_STATE_CHANGED | 701
    public static final int | SELECTED | 1
  • java.awt.event.KeyEvent
    Modifier and Type | Constant Field | Value
    public static final char | CHAR_UNDEFINED | 65535
    public static final int | KEY_FIRST | 400
    public static final int | KEY_LAST | 402
    public static final int | KEY_LOCATION_LEFT | 2
    public static final int | KEY_LOCATION_NUMPAD | 4
    public static final int | KEY_LOCATION_RIGHT | 3
    public static final int | KEY_LOCATION_STANDARD | 1
    public static final int | KEY_LOCATION_UNKNOWN | 0
    public static final int | KEY_PRESSED | 401
    public static final int | KEY_RELEASED | 402
    public static final int | KEY_TYPED | 400
    public static final int | VK_0 | 48
    public static final int | VK_1 | 49
    public static final int | VK_2 | 50
    public static final int | VK_3 | 51
    public static final int | VK_4 | 52
    public static final int | VK_5 | 53
    public static final int | VK_6 | 54
    public static final int | VK_7 | 55
    public static final int | VK_8 | 56
    public static final int | VK_9 | 57
    public static final int | VK_A | 65
    public static final int | VK_ACCEPT | 30
    public static final int | VK_ADD | 107
    public static final int | VK_AGAIN | 65481
    public static final int | VK_ALL_CANDIDATES | 256
    public static final int | VK_ALPHANUMERIC | 240
    public static final int | VK_ALT | 18
    public static final int | VK_ALT_GRAPH | 65406
    public static final int | VK_AMPERSAND | 150
    public static final int | VK_ASTERISK | 151
    public static final int | VK_AT | 512
    public static final int | VK_B | 66
    public static final int | VK_BACK_QUOTE | 192
    public static final int | VK_BACK_SLASH | 92
    public static final int | VK_BACK_SPACE | 8
    public static final int | VK_BEGIN | 65368
    public static final int | VK_BRACELEFT | 161
    public static final int | VK_BRACERIGHT | 162
    public static final int | VK_C | 67
    public static final int | VK_CANCEL | 3
    public static final int | VK_CAPS_LOCK | 20
    public static final int | VK_CIRCUMFLEX | 514
    public static final int | VK_CLEAR | 12
    public static final int | VK_CLOSE_BRACKET | 93
    public static final int | VK_CODE_INPUT | 258
    public static final int | VK_COLON | 513
    public static final int | VK_COMMA | 44
    public static final int | VK_COMPOSE | 65312
    public static final int | VK_CONTEXT_MENU | 525
    public static final int | VK_CONTROL | 17
    public static final int | VK_CONVERT | 28
    public static final int | VK_COPY | 65485
    public static final int | VK_CUT | 65489
    public static final int | VK_D | 68
    public static final int | VK_DEAD_ABOVEDOT | 134
    public static final int | VK_DEAD_ABOVERING | 136
    public static final int | VK_DEAD_ACUTE | 129
    public static final int | VK_DEAD_BREVE | 133
    public static final int | VK_DEAD_CARON | 138
    public static final int | VK_DEAD_CEDILLA | 139
    public static final int | VK_DEAD_CIRCUMFLEX | 130
    public static final int | VK_DEAD_DIAERESIS | 135
    public static final int | VK_DEAD_DOUBLEACUTE | 137
    public static final int | VK_DEAD_GRAVE | 128
    public static final int | VK_DEAD_IOTA | 141
    public static final int | VK_DEAD_MACRON | 132
    public static final int | VK_DEAD_OGONEK | 140
    public static final int | VK_DEAD_SEMIVOICED_SOUND | 143
    public static final int | VK_DEAD_TILDE | 131
    public static final int | VK_DEAD_VOICED_SOUND | 142
    public static final int | VK_DECIMAL | 110
    public static final int | VK_DELETE | 127
    public static final int | VK_DIVIDE | 111
    public static final int | VK_DOLLAR | 515
    public static final int | VK_DOWN | 40
    public static final int | VK_E | 69
    public static final int | VK_END | 35
    public static final int | VK_ENTER | 10
    public static final int | VK_EQUALS | 61
    public static final int | VK_ESCAPE | 27
    public static final int | VK_EURO_SIGN | 516
    public static final int | VK_EXCLAMATION_MARK | 517
    public static final int | VK_F | 70
    public static final int | VK_F1 | 112
    public static final int | VK_F10 | 121
    public static final int | VK_F11 | 122
    public static final int | VK_F12 | 123
    public static final int | VK_F13 | 61440
    public static final int | VK_F14 | 61441
    public static final int | VK_F15 | 61442
    public static final int | VK_F16 | 61443
    public static final int | VK_F17 | 61444
    public static final int | VK_F18 | 61445
    public static final int | VK_F19 | 61446
    public static final int | VK_F2 | 113
    public static final int | VK_F20 | 61447
    public static final int | VK_F21 | 61448
    public static final int | VK_F22 | 61449
    public static final int | VK_F23 | 61450
    public static final int | VK_F24 | 61451
    public static final int | VK_F3 | 114
    public static final int | VK_F4 | 115
    public static final int | VK_F5 | 116
    public static final int | VK_F6 | 117
    public static final int | VK_F7 | 118
    public static final int | VK_F8 | 119
    public static final int | VK_F9 | 120
    public static final int | VK_FINAL | 24
    public static final int | VK_FIND | 65488
    public static final int | VK_FULL_WIDTH | 243
    public static final int | VK_G | 71
    public static final int | VK_GREATER | 160
    public static final int | VK_H | 72
    public static final int | VK_HALF_WIDTH | 244
    public static final int | VK_HELP | 156
    public static final int | VK_HIRAGANA | 242
    public static final int | VK_HOME | 36
    public static final int | VK_I | 73
    public static final int | VK_INPUT_METHOD_ON_OFF | 263
    public static final int | VK_INSERT | 155
    public static final int | VK_INVERTED_EXCLAMATION_MARK | 518
    public static final int | VK_J | 74
    public static final int | VK_JAPANESE_HIRAGANA | 260
    public static final int | VK_JAPANESE_KATAKANA | 259
    public static final int | VK_JAPANESE_ROMAN | 261
    public static final int | VK_K | 75
    public static final int | VK_KANA | 21
    public static final int | VK_KANA_LOCK | 262
    public static final int | VK_KANJI | 25
    public static final int | VK_KATAKANA | 241
    public static final int | VK_KP_DOWN | 225
    public static final int | VK_KP_LEFT | 226
    public static final int | VK_KP_RIGHT | 227
    public static final int | VK_KP_UP | 224
    public static final int | VK_L | 76
    public static final int | VK_LEFT | 37
    public static final int | VK_LEFT_PARENTHESIS | 519
    public static final int | VK_LESS | 153
    public static final int | VK_M | 77
    public static final int | VK_META | 157
    public static final int | VK_MINUS | 45
    public static final int | VK_MODECHANGE | 31
    public static final int | VK_MULTIPLY | 106
    public static final int | VK_N | 78
    public static final int | VK_NONCONVERT | 29
    public static final int | VK_NUM_LOCK | 144
    public static final int | VK_NUMBER_SIGN | 520
    public static final int | VK_NUMPAD0 | 96
    public static final int | VK_NUMPAD1 | 97
    public static final int | VK_NUMPAD2 | 98
    public static final int | VK_NUMPAD3 | 99
    public static final int | VK_NUMPAD4 | 100
    public static final int | VK_NUMPAD5 | 101
    public static final int | VK_NUMPAD6 | 102
    public static final int | VK_NUMPAD7 | 103
    public static final int | VK_NUMPAD8 | 104
    public static final int | VK_NUMPAD9 | 105
    public static final int | VK_O | 79
    public static final int | VK_OPEN_BRACKET | 91
    public static final int | VK_P | 80
    public static final int | VK_PAGE_DOWN | 34
    public static final int | VK_PAGE_UP | 33
    public static final int | VK_PASTE | 65487
    public static final int | VK_PAUSE | 19
    public static final int | VK_PERIOD | 46
    public static final int | VK_PLUS | 521
    public static final int | VK_PREVIOUS_CANDIDATE | 257
    public static final int | VK_PRINTSCREEN | 154
    public static final int | VK_PROPS | 65482
    public static final int | VK_Q | 81
    public static final int | VK_QUOTE | 222
    public static final int | VK_QUOTEDBL | 152
    public static final int | VK_R | 82
    public static final int | VK_RIGHT | 39
    public static final int | VK_RIGHT_PARENTHESIS | 522
    public static final int | VK_ROMAN_CHARACTERS | 245
    public static final int | VK_S | 83
    public static final int | VK_SCROLL_LOCK | 145
    public static final int | VK_SEMICOLON | 59
    public static final int | VK_SEPARATER | 108
    public static final int | VK_SEPARATOR | 108
    public static final int | VK_SHIFT | 16
    public static final int | VK_SLASH | 47
    public static final int | VK_SPACE | 32
    public static final int | VK_STOP | 65480
    public static final int | VK_SUBTRACT | 109
    public static final int | VK_T | 84
    public static final int | VK_TAB | 9
    public static final int | VK_U | 85
    public static final int | VK_UNDEFINED | 0
    public static final int | VK_UNDERSCORE | 523
    public static final int | VK_UNDO | 65483
    public static final int | VK_UP | 38
    public static final int | VK_V | 86
    public static final int | VK_W | 87
    public static final int | VK_WINDOWS | 524
    public static final int | VK_X | 88
    public static final int | VK_Y | 89
    public static final int | VK_Z | 90
  • java.awt.event.MouseEvent
    Modifier and Type | Constant Field | Value
    public static final int | BUTTON1 | 1
    public static final int | BUTTON2 | 2
    public static final int | BUTTON3 | 3
    public static final int | MOUSE_CLICKED | 500
    public static final int | MOUSE_DRAGGED | 506
    public static final int | MOUSE_ENTERED | 504
    public static final int | MOUSE_EXITED | 505
    public static final int | MOUSE_FIRST | 500
    public static final int | MOUSE_LAST | 507
    public static final int | MOUSE_MOVED | 503
    public static final int | MOUSE_PRESSED | 501
    public static final int | MOUSE_RELEASED | 502
    public static final int | MOUSE_WHEEL | 507
    public static final int | NOBUTTON | 0
  • java.awt.event.MouseWheelEvent
    Modifier and Type | Constant Field | Value
    public static final int | WHEEL_BLOCK_SCROLL | 1
    public static final int | WHEEL_UNIT_SCROLL | 0
  • java.awt.event.PaintEvent
    Modifier and Type | Constant Field | Value
    public static final int | PAINT | 800
    public static final int | PAINT_FIRST | 800
    public static final int | PAINT_LAST | 801
    public static final int | UPDATE | 801
  • java.awt.event.TextEvent
    Modifier and Type | Constant Field | Value
    public static final int | TEXT_FIRST | 900
    public static final int | TEXT_LAST | 900
    public static final int | TEXT_VALUE_CHANGED | 900
  • java.awt.event.WindowEvent
    Modifier and Type | Constant Field | Value
    public static final int | WINDOW_ACTIVATED | 205
    public static final int | WINDOW_CLOSED | 202
    public static final int | WINDOW_CLOSING | 201
    public static final int | WINDOW_DEACTIVATED | 206
    public static final int | WINDOW_DEICONIFIED | 204
    public static final int | WINDOW_FIRST | 200
    public static final int | WINDOW_GAINED_FOCUS | 207
    public static final int | WINDOW_ICONIFIED | 203
    public static final int | WINDOW_LAST | 209
    public static final int | WINDOW_LOST_FOCUS | 208
    public static final int | WINDOW_OPENED | 200
    public static final int | WINDOW_STATE_CHANGED | 209
  • java.awt.font.GlyphJustificationInfo
    Modifier and Type | Constant Field | Value
    public static final int | PRIORITY_INTERCHAR | 2
    public static final int | PRIORITY_KASHIDA | 0
    public static final int | PRIORITY_NONE | 3
    public static final int | PRIORITY_WHITESPACE | 1
  • java.awt.font.GlyphMetrics
    Modifier and Type | Constant Field | Value
    public static final byte | COMBINING | 2
    public static final byte | COMPONENT | 3
    public static final byte | LIGATURE | 1
    public static final byte | STANDARD | 0
    public static final byte | WHITESPACE | 4
  • java.awt.font.GlyphVector
    Modifier and Type | Constant Field | Value
    public static final int | FLAG_COMPLEX_GLYPHS | 8
    public static final int | FLAG_HAS_POSITION_ADJUSTMENTS | 2
    public static final int | FLAG_HAS_TRANSFORMS | 1
    public static final int | FLAG_MASK | 15
    public static final int | FLAG_RUN_RTL | 4
  • java.awt.font.GraphicAttribute
    Modifier and Type | Constant Field | Value
    public static final int | BOTTOM_ALIGNMENT | -2
    public static final int | CENTER_BASELINE | 1
    public static final int | HANGING_BASELINE | 2
    public static final int | ROMAN_BASELINE | 0
    public static final int | TOP_ALIGNMENT | -1
  • java.awt.font.NumericShaper
    Modifier and Type | Constant Field | Value
    public static final int | ALL_RANGES | 524287
    public static final int | ARABIC | 2
    public static final int | BENGALI | 16
    public static final int | DEVANAGARI | 8
    public static final int | EASTERN_ARABIC | 4
    public static final int | ETHIOPIC | 65536
    public static final int | EUROPEAN | 1
    public static final int | GUJARATI | 64
    public static final int | GURMUKHI | 32
    public static final int | KANNADA | 1024
    public static final int | KHMER | 131072
    public static final int | LAO | 8192
    public static final int | MALAYALAM | 2048
    public static final int | MONGOLIAN | 262144
    public static final int | MYANMAR | 32768
    public static final int | ORIYA | 128
    public static final int | TAMIL | 256
    public static final int | TELUGU | 512
    public static final int | THAI | 4096
    public static final int | TIBETAN | 16384
  • java.awt.font.OpenType
    Modifier and Type | Constant Field | Value
    public static final int | TAG_ACNT | 1633906292
    public static final int | TAG_AVAR | 1635148146
    public static final int | TAG_BASE | 1111577413
    public static final int | TAG_BDAT | 1650745716
    public static final int | TAG_BLOC | 1651273571
    public static final int | TAG_BSLN | 1651731566
    public static final int | TAG_CFF | 1128678944
    public static final int | TAG_CMAP | 1668112752
    public static final int | TAG_CVAR | 1668702578
    public static final int | TAG_CVT | 1668707360
    public static final int | TAG_DSIG | 1146308935
    public static final int | TAG_EBDT | 1161970772
    public static final int | TAG_EBLC | 1161972803
    public static final int | TAG_EBSC | 1161974595
    public static final int | TAG_FDSC | 1717859171
    public static final int | TAG_FEAT | 1717920116
    public static final int | TAG_FMTX | 1718449272
    public static final int | TAG_FPGM | 1718642541
    public static final int | TAG_FVAR | 1719034226
    public static final int | TAG_GASP | 1734439792
    public static final int | TAG_GDEF | 1195656518
    public static final int | TAG_GLYF | 1735162214
    public static final int | TAG_GPOS | 1196445523
    public static final int | TAG_GSUB | 1196643650
    public static final int | TAG_GVAR | 1735811442
    public static final int | TAG_HDMX | 1751412088
    public static final int | TAG_HEAD | 1751474532
    public static final int | TAG_HHEA | 1751672161
    public static final int | TAG_HMTX | 1752003704
    public static final int | TAG_JSTF | 1246975046
    public static final int | TAG_JUST | 1786082164
    public static final int | TAG_KERN | 1801810542
    public static final int | TAG_LCAR | 1818452338
    public static final int | TAG_LOCA | 1819239265
    public static final int | TAG_LTSH | 1280594760
    public static final int | TAG_MAXP | 1835104368
    public static final int | TAG_MMFX | 1296909912
    public static final int | TAG_MMSD | 1296913220
    public static final int | TAG_MORT | 1836020340
    public static final int | TAG_NAME | 1851878757
    public static final int | TAG_OPBD | 1869636196
    public static final int | TAG_OS2 | 1330851634
    public static final int | TAG_PCLT | 1346587732
    public static final int | TAG_POST | 1886352244
    public static final int | TAG_PREP | 1886545264
    public static final int | TAG_PROP | 1886547824
    public static final int | TAG_TRAK | 1953653099
    public static final int | TAG_TYP1 | 1954115633
    public static final int | TAG_VDMX | 1447316824
    public static final int | TAG_VHEA | 1986553185
    public static final int | TAG_VMTX | 1986884728
  • java.awt.font.ShapeGraphicAttribute
    Modifier and Type | Constant Field | Value
    public static final boolean | FILL | false
    public static final boolean | STROKE | true
  • java.awt.geom.AffineTransform
    Modifier and Type | Constant Field | Value
    public static final int | TYPE_FLIP | 64
    public static final int | TYPE_GENERAL_ROTATION | 16
    public static final int | TYPE_GENERAL_SCALE | 4
    public static final int | TYPE_GENERAL_TRANSFORM | 32
    public static final int | TYPE_IDENTITY | 0
    public static final int | TYPE_MASK_ROTATION | 24
    public static final int | TYPE_MASK_SCALE | 6
    public static final int | TYPE_QUADRANT_ROTATION | 8
    public static final int | TYPE_TRANSLATION | 1
    public static final int | TYPE_UNIFORM_SCALE | 2
  • java.awt.geom.Arc2D
    Modifier and Type | Constant Field | Value
    public static final int | CHORD | 1
    public static final int | OPEN | 0
    public static final int | PIE | 2
  • java.awt.geom.Path2D
    Modifier and Type | Constant Field | Value
    public static final int | WIND_EVEN_ODD | 0
    public static final int | WIND_NON_ZERO | 1
  • java.awt.geom.PathIterator
    Modifier and Type | Constant Field | Value
    public static final int | SEG_CLOSE | 4
    public static final int | SEG_CUBICTO | 3
    public static final int | SEG_LINETO | 1
    public static final int | SEG_MOVETO | 0
    public static final int | SEG_QUADTO | 2
    public static final int | WIND_EVEN_ODD | 0
    public static final int | WIND_NON_ZERO | 1
  • java.awt.geom.Rectangle2D
    Modifier and Type | Constant Field | Value
    public static final int | OUT_BOTTOM | 8
    public static final int | OUT_LEFT | 1
    public static final int | OUT_RIGHT | 4
    public static final int | OUT_TOP | 2
  • java.awt.im.InputMethodHighlight
    Modifier and Type | Constant Field | Value
    public static final int | CONVERTED_TEXT | 1
    public static final int | RAW_TEXT | 0
  • java.awt.image.AffineTransformOp
    Modifier and Type | Constant Field | Value
    public static final int | TYPE_BICUBIC | 3
    public static final int | TYPE_BILINEAR | 2
    public static final int | TYPE_NEAREST_NEIGHBOR | 1
  • java.awt.image.BufferedImage
    Modifier and Type | Constant Field | Value
    public static final int | TYPE_3BYTE_BGR | 5
    public static final int | TYPE_4BYTE_ABGR | 6
    public static final int | TYPE_4BYTE_ABGR_PRE | 7
    public static final int | TYPE_BYTE_BINARY | 12
    public static final int | TYPE_BYTE_GRAY | 10
    public static final int | TYPE_BYTE_INDEXED | 13
    public static final int | TYPE_CUSTOM | 0
    public static final int | TYPE_INT_ARGB | 2
    public static final int | TYPE_INT_ARGB_PRE | 3
    public static final int | TYPE_INT_BGR | 4
    public static final int | TYPE_INT_RGB | 1
    public static final int | TYPE_USHORT_555_RGB | 9
    public static final int | TYPE_USHORT_565_RGB | 8
    public static final int | TYPE_USHORT_GRAY | 11
  • java.awt.image.ConvolveOp
    Modifier and Type | Constant Field | Value
    public static final int | EDGE_NO_OP | 1
    public static final int | EDGE_ZERO_FILL | 0
  • java.awt.image.DataBuffer
    Modifier and Type | Constant Field | Value
    public static final int | TYPE_BYTE | 0
    public static final int | TYPE_DOUBLE | 5
    public static final int | TYPE_FLOAT | 4
    public static final int | TYPE_INT | 3
    public static final int | TYPE_SHORT | 2
    public static final int | TYPE_UNDEFINED | 32
    public static final int | TYPE_USHORT | 1
  • java.awt.image.ImageConsumer
    Modifier and Type | Constant Field | Value
    public static final int | COMPLETESCANLINES | 4
    public static final int | IMAGEABORTED | 4
    public static final int | IMAGEERROR | 1
    public static final int | RANDOMPIXELORDER | 1
    public static final int | SINGLEFRAME | 16
    public static final int | SINGLEFRAMEDONE | 2
    public static final int | SINGLEPASS | 8
    public static final int | STATICIMAGEDONE | 3
    public static final int | TOPDOWNLEFTRIGHT | 2
  • java.awt.image.ImageObserver
    Modifier and Type | Constant Field | Value
    public static final int | ABORT | 128
    public static final int | ALLBITS | 32
    public static final int | ERROR | 64
    public static final int | FRAMEBITS | 16
    public static final int | HEIGHT | 2
    public static final int | PROPERTIES | 4
    public static final int | SOMEBITS | 8
    public static final int | WIDTH | 1
  • java.awt.image.VolatileImage
    Modifier and Type | Constant Field | Value
    public static final int | IMAGE_INCOMPATIBLE | 2
    public static final int | IMAGE_OK | 0
    public static final int | IMAGE_RESTORED | 1
  • java.awt.image.renderable.RenderableImage
    Modifier and Type | Constant Field | Value
    public static final String | HINTS_OBSERVED | "HINTS_OBSERVED"
  • java.awt.print.Pageable
    Modifier and Type | Constant Field | Value
    public static final int | UNKNOWN_NUMBER_OF_PAGES | -1
  • java.awt.print.PageFormat
    Modifier and Type | Constant Field | Value
    public static final int | LANDSCAPE | 0
    public static final int | PORTRAIT | 1
    public static final int | REVERSE_LANDSCAPE | 2
  • java.awt.print.Printable
    Modifier and Type | Constant Field | Value
    public static final int | NO_SUCH_PAGE | 1
    public static final int | PAGE_EXISTS | 0

java.beans.*

  • java.beans.BeanInfo
    Modifier and Type | Constant Field | Value
    public static final int | ICON_COLOR_16x16 | 1
    public static final int | ICON_COLOR_32x32 | 2
    public static final int | ICON_MONO_16x16 | 3
    public static final int | ICON_MONO_32x32 | 4
  • java.beans.DesignMode
    Modifier and Type | Constant Field | Value
    public static final String | PROPERTYNAME | "designTime"
  • java.beans.Introspector
    Modifier and Type | Constant Field | Value
    public static final int | IGNORE_ALL_BEANINFO | 3
    public static final int | IGNORE_IMMEDIATE_BEANINFO | 2
    public static final int | USE_ALL_BEANINFO | 1

java.io.*

  • java.io.ObjectStreamConstants
    Modifier and Type | Constant Field | Value
    public static final int | baseWireHandle | 8257536
    public static final int | PROTOCOL_VERSION_1 | 1
    public static final int | PROTOCOL_VERSION_2 | 2
    public static final byte | SC_BLOCK_DATA | 8
    public static final byte | SC_ENUM | 16
    public static final byte | SC_EXTERNALIZABLE | 4
    public static final byte | SC_SERIALIZABLE | 2
    public static final byte | SC_WRITE_METHOD | 1
    public static final short | STREAM_MAGIC | -21267
    public static final short | STREAM_VERSION | 5
    public static final byte | TC_ARRAY | 117
    public static final byte | TC_BASE | 112
    public static final byte | TC_BLOCKDATA | 119
    public static final byte | TC_BLOCKDATALONG | 122
    public static final byte | TC_CLASS | 118
    public static final byte | TC_CLASSDESC | 114
    public static final byte | TC_ENDBLOCKDATA | 120
    public static final byte | TC_ENUM | 126
    public static final byte | TC_EXCEPTION | 123
    public static final byte | TC_LONGSTRING | 124
    public static final byte | TC_MAX | 126
    public static final byte | TC_NULL | 112
    public static final byte | TC_OBJECT | 115
    public static final byte | TC_PROXYCLASSDESC | 125
    public static final byte | TC_REFERENCE | 113
    public static final byte | TC_RESET | 121
    public static final byte | TC_STRING | 116
  • java.io.PipedInputStream
    Modifier and Type | Constant Field | Value
    protected static final int | PIPE_SIZE | 1024
  • java.io.StreamTokenizer
    Modifier and Type | Constant Field | Value
    public static final int | TT_EOF | -1
    public static final int | TT_EOL | 10
    public static final int | TT_NUMBER | -2
    public static final int | TT_WORD | -3

java.lang.*

  • java.lang.Byte
    Modifier and Type | Constant Field | Value
    public static final int | BYTES | 1
    public static final byte | MAX_VALUE | 127
    public static final byte | MIN_VALUE | -128
    public static final int | SIZE | 8
  • java.lang.Character
    Modifier and Type | Constant Field | Value
    public static final int | BYTES | 2
    public static final byte | COMBINING_SPACING_MARK | 8
    public static final byte | CONNECTOR_PUNCTUATION | 23
    public static final byte | CONTROL | 15
    public static final byte | CURRENCY_SYMBOL | 26
    public static final byte | DASH_PUNCTUATION | 20
    public static final byte | DECIMAL_DIGIT_NUMBER | 9
    public static final byte | DIRECTIONALITY_ARABIC_NUMBER | 6
    public static final byte | DIRECTIONALITY_BOUNDARY_NEUTRAL | 9
    public static final byte | DIRECTIONALITY_COMMON_NUMBER_SEPARATOR | 7
    public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER | 3
    public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR | 4
    public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR | 5
    public static final byte | DIRECTIONALITY_FIRST_STRONG_ISOLATE | 21
    public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT | 0
    public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING | 14
    public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT_ISOLATE | 19
    public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE | 15
    public static final byte | DIRECTIONALITY_NONSPACING_MARK | 8
    public static final byte | DIRECTIONALITY_OTHER_NEUTRALS | 13
    public static final byte | DIRECTIONALITY_PARAGRAPH_SEPARATOR | 10
    public static final byte | DIRECTIONALITY_POP_DIRECTIONAL_FORMAT | 18
    public static final byte | DIRECTIONALITY_POP_DIRECTIONAL_ISOLATE | 22
    public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT | 1
    public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC | 2
    public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING | 16
    public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_ISOLATE | 20
    public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE | 17
    public static final byte | DIRECTIONALITY_SEGMENT_SEPARATOR | 11
    public static final byte | DIRECTIONALITY_UNDEFINED | -1
    public static final byte | DIRECTIONALITY_WHITESPACE | 12
    public static final byte | ENCLOSING_MARK | 7
    public static final byte | END_PUNCTUATION | 22
    public static final byte | FINAL_QUOTE_PUNCTUATION | 30
    public static final byte | FORMAT | 16
    public static final byte | INITIAL_QUOTE_PUNCTUATION | 29
    public static final byte | LETTER_NUMBER | 10
    public static final byte | LINE_SEPARATOR | 13
    public static final byte | LOWERCASE_LETTER | 2
    public static final byte | MATH_SYMBOL | 25
    public static final int | MAX_CODE_POINT | 1114111
    public static final char | MAX_HIGH_SURROGATE | 56319
    public static final char | MAX_LOW_SURROGATE | 57343
    public static final int | MAX_RADIX | 36
    public static final char | MAX_SURROGATE | 57343
    public static final char | MAX_VALUE | 65535
    public static final int | MIN_CODE_POINT | 0
    public static final char | MIN_HIGH_SURROGATE | 55296
    public static final char | MIN_LOW_SURROGATE | 56320
    public static final int | MIN_RADIX | 2
    public static final int | MIN_SUPPLEMENTARY_CODE_POINT | 65536
    public static final char | MIN_SURROGATE | 55296
    public static final char | MIN_VALUE | 0
    public static final byte | MODIFIER_LETTER | 4
    public static final byte | MODIFIER_SYMBOL | 27
    public static final byte | NON_SPACING_MARK | 6
    public static final byte | OTHER_LETTER | 5
    public static final byte | OTHER_NUMBER | 11
    public static final byte | OTHER_PUNCTUATION | 24
    public static final byte | OTHER_SYMBOL | 28
    public static final byte | PARAGRAPH_SEPARATOR | 14
    public static final byte | PRIVATE_USE | 18
    public static final int | SIZE | 16
    public static final byte | SPACE_SEPARATOR | 12
    public static final byte | START_PUNCTUATION | 21
    public static final byte | SURROGATE | 19
    public static final byte | TITLECASE_LETTER | 3
    public static final byte | UNASSIGNED | 0
    public static final byte | UPPERCASE_LETTER | 1
  • java.lang.Double
    Modifier and Type | Constant Field | Value
    public static final int | BYTES | 8
    public static final int | MAX_EXPONENT | 1023
    public static final double | MAX_VALUE | 1.7976931348623157E308
    public static final int | MIN_EXPONENT | -1022
    public static final double | MIN_NORMAL | 2.2250738585072014E-308
    public static final double | MIN_VALUE | 4.9E-324
    public static final double | NaN | 0d/0d
    public static final double | NEGATIVE_INFINITY | -1d/0d
    public static final double | POSITIVE_INFINITY | 1d/0d
    public static final int | SIZE | 64
  • java.lang.Float
    Modifier and Type | Constant Field | Value
    public static final int | BYTES | 4
    public static final int | MAX_EXPONENT | 127
    public static final float | MAX_VALUE | 3.4028234663852886E38f
    public static final int | MIN_EXPONENT | -126
    public static final float | MIN_NORMAL | 1.1754943508222875E-38f
    public static final float | MIN_VALUE | 1.401298464324817E-45f
    public static final float | NaN | 0f/0f
    public static final float | NEGATIVE_INFINITY | -1f/0f
    public static final float | POSITIVE_INFINITY | 1f/0f
    public static final int | SIZE | 32
  • java.lang.Integer
    Modifier and Type | Constant Field | Value
    public static final int | BYTES | 4
    public static final int | MAX_VALUE | 2147483647
    public static final int | MIN_VALUE | -2147483648
    public static final int | SIZE | 32
  • java.lang.Long
    Modifier and Type | Constant Field | Value
    public static final int | BYTES | 8
    public static final long | MAX_VALUE | 9223372036854775807L
    public static final long | MIN_VALUE | -9223372036854775808L
    public static final int | SIZE | 64
  • java.lang.Math
    Modifier and Type | Constant Field | Value
    public static final double | E | 2.718281828459045
    public static final double | PI | 3.141592653589793
  • java.lang.Short
    Modifier and Type | Constant Field | Value
    public static final int | BYTES | 2
    public static final short | MAX_VALUE | 32767
    public static final short | MIN_VALUE | -32768
    public static final int | SIZE | 16
  • java.lang.StrictMath
    Modifier and Type | Constant Field | Value
    public static final double | E | 2.718281828459045
    public static final double | PI | 3.141592653589793
  • java.lang.Thread
    Modifier and Type | Constant Field | Value
    public static final int | MAX_PRIORITY | 10
    public static final int | MIN_PRIORITY | 1
    public static final int | NORM_PRIORITY | 5
  • java.lang.invoke.LambdaMetafactory
    Modifier and Type | Constant Field | Value
    public static final int | FLAG_BRIDGES | 4
    public static final int | FLAG_MARKERS | 2
    public static final int | FLAG_SERIALIZABLE | 1
  • java.lang.invoke.MethodHandleInfo
    Modifier and Type | Constant Field | Value
    public static final int | REF_getField | 1
    public static final int | REF_getStatic | 2
    public static final int | REF_invokeInterface | 9
    public static final int | REF_invokeSpecial | 7
    public static final int | REF_invokeStatic | 6
    public static final int | REF_invokeVirtual | 5
    public static final int | REF_newInvokeSpecial | 8
    public static final int | REF_putField | 3
    public static final int | REF_putStatic | 4
  • java.lang.invoke.MethodHandles.Lookup
    Modifier and Type | Constant Field | Value
    public static final int | MODULE | 16
    public static final int | PACKAGE | 8
    public static final int | PRIVATE | 2
    public static final int | PROTECTED | 4
    public static final int | PUBLIC | 1
    public static final int | UNCONDITIONAL | 32
  • java.lang.management.ManagementFactory
    Modifier and Type | Constant Field | Value
    public static final String | CLASS_LOADING_MXBEAN_NAME | "java.lang:type=ClassLoading"
    public static final String | COMPILATION_MXBEAN_NAME | "java.lang:type=Compilation"
    public static final String | GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE | "java.lang:type=GarbageCollector"
    public static final String | MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE | "java.lang:type=MemoryManager"
    public static final String | MEMORY_MXBEAN_NAME | "java.lang:type=Memory"
    public static final String | MEMORY_POOL_MXBEAN_DOMAIN_TYPE | "java.lang:type=MemoryPool"
    public static final String | OPERATING_SYSTEM_MXBEAN_NAME | "java.lang:type=OperatingSystem"
    public static final String | RUNTIME_MXBEAN_NAME | "java.lang:type=Runtime"
    public static final String | THREAD_MXBEAN_NAME | "java.lang:type=Threading"
  • java.lang.management.MemoryNotificationInfo
    Modifier and Type | Constant Field | Value
    public static final String | MEMORY_COLLECTION_THRESHOLD_EXCEEDED | "java.management.memory.collection.threshold.exceeded"
    public static final String | MEMORY_THRESHOLD_EXCEEDED | "java.management.memory.threshold.exceeded"
  • java.lang.reflect.Member
    Modifier and Type | Constant Field | Value
    public static final int | DECLARED | 1
    public static final int | PUBLIC | 0
  • java.lang.reflect.Modifier
    Modifier and Type | Constant Field | Value
    public static final int | ABSTRACT | 1024
    public static final int | FINAL | 16
    public static final int | INTERFACE | 512
    public static final int | NATIVE | 256
    public static final int | PRIVATE | 2
    public static final int | PROTECTED | 4
    public static final int | PUBLIC | 1
    public static final int | STATIC | 8
    public static final int | STRICT | 2048
    public static final int | SYNCHRONIZED | 32
    public static final int | TRANSIENT | 128
    public static final int | VOLATILE | 64

java.math.*

  • java.math.BigDecimal
    Modifier and Type | Constant Field | Value
    public static final int | ROUND_CEILING | 2
    public static final int | ROUND_DOWN | 1
    public static final int | ROUND_FLOOR | 3
    public static final int | ROUND_HALF_DOWN | 5
    public static final int | ROUND_HALF_EVEN | 6
    public static final int | ROUND_HALF_UP | 4
    public static final int | ROUND_UNNECESSARY | 7
    public static final int | ROUND_UP | 0

java.net.*

  • java.net.HttpURLConnection
    Modifier and Type | Constant Field | Value
    public static final int | HTTP_ACCEPTED | 202
    public static final int | HTTP_BAD_GATEWAY | 502
    public static final int | HTTP_BAD_METHOD | 405
    public static final int | HTTP_BAD_REQUEST | 400
    public static final int | HTTP_CLIENT_TIMEOUT | 408
    public static final int | HTTP_CONFLICT | 409
    public static final int | HTTP_CREATED | 201
    public static final int | HTTP_ENTITY_TOO_LARGE | 413
    public static final int | HTTP_FORBIDDEN | 403
    public static final int | HTTP_GATEWAY_TIMEOUT | 504
    public static final int | HTTP_GONE | 410
    public static final int | HTTP_INTERNAL_ERROR | 500
    public static final int | HTTP_LENGTH_REQUIRED | 411
    public static final int | HTTP_MOVED_PERM | 301
    public static final int | HTTP_MOVED_TEMP | 302
    public static final int | HTTP_MULT_CHOICE | 300
    public static final int | HTTP_NO_CONTENT | 204
    public static final int | HTTP_NOT_ACCEPTABLE | 406
    public static final int | HTTP_NOT_AUTHORITATIVE | 203
    public static final int | HTTP_NOT_FOUND | 404
    public static final int | HTTP_NOT_IMPLEMENTED | 501
    public static final int | HTTP_NOT_MODIFIED | 304
    public static final int | HTTP_OK | 200
    public static final int | HTTP_PARTIAL | 206
    public static final int | HTTP_PAYMENT_REQUIRED | 402
    public static final int | HTTP_PRECON_FAILED | 412
    public static final int | HTTP_PROXY_AUTH | 407
    public static final int | HTTP_REQ_TOO_LONG | 414
    public static final int | HTTP_RESET | 205
    public static final int | HTTP_SEE_OTHER | 303
    public static final int | HTTP_SERVER_ERROR | 500
    public static final int | HTTP_UNAUTHORIZED | 401
    public static final int | HTTP_UNAVAILABLE | 503
    public static final int | HTTP_UNSUPPORTED_TYPE | 415
    public static final int | HTTP_USE_PROXY | 305
    public static final int | HTTP_VERSION | 505
  • java.net.IDN
    Modifier and Type | Constant Field | Value
    public static final int | ALLOW_UNASSIGNED | 1
    public static final int | USE_STD3_ASCII_RULES | 2
  • java.net.SocketOptions
    Modifier and Type | Constant Field | Value
    public static final int | IP_MULTICAST_IF | 16
    public static final int | IP_MULTICAST_IF2 | 31
    public static final int | IP_MULTICAST_LOOP | 18
    public static final int | IP_TOS | 3
    public static final int | SO_BINDADDR | 15
    public static final int | SO_BROADCAST | 32
    public static final int | SO_KEEPALIVE | 8
    public static final int | SO_LINGER | 128
    public static final int | SO_OOBINLINE | 4099
    public static final int | SO_RCVBUF | 4098
    public static final int | SO_REUSEADDR | 4
    public static final int | SO_REUSEPORT | 14
    public static final int | SO_SNDBUF | 4097
    public static final int | SO_TIMEOUT | 4102
    public static final int | TCP_NODELAY | 1

java.nio.*

  • java.nio.channels.SelectionKey
    Modifier and Type | Constant Field | Value
    public static final int | OP_ACCEPT | 16
    public static final int | OP_CONNECT | 8
    public static final int | OP_READ | 1
    public static final int | OP_WRITE | 4

java.rmi.*

  • java.rmi.activation.ActivationSystem
    Modifier and Type | Constant Field | Value
    public static final int | SYSTEM_PORT | 1098
  • java.rmi.registry.Registry
    Modifier and Type | Constant Field | Value
    public static final int | REGISTRY_PORT | 1099
  • java.rmi.server.LoaderHandler
    Modifier and Type | Constant Field | Value
    public static final String | packagePrefix | "sun.rmi.server"
  • java.rmi.server.LogStream
    Modifier and Type | Constant Field | Value
    public static final int | BRIEF | 10
    public static final int | SILENT | 0
    public static final int | VERBOSE | 20
  • java.rmi.server.ObjID
    Modifier and Type | Constant Field | Value
    public static final int | ACTIVATOR_ID | 1
    public static final int | DGC_ID | 2
    public static final int | REGISTRY_ID | 0
  • java.rmi.server.RemoteRef
    Modifier and Type | Constant Field | Value
    public static final String | packagePrefix | "sun.rmi.server"
    public static final long | serialVersionUID | 3632638527362204081L
  • java.rmi.server.ServerRef
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -4557750989390278438L

java.security.*

  • java.security.Key
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 6603384152749567654L
  • java.security.PrivateKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 6034044314589513430L
  • java.security.PublicKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 7187392471159151072L
  • java.security.Signature
    Modifier and Type | Constant Field | Value
    protected static final int | SIGN | 2
    protected static final int | UNINITIALIZED | 0
    protected static final int | VERIFY | 3
  • java.security.interfaces.DSAPrivateKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 7776497482533790279L
  • java.security.interfaces.DSAPublicKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 1234526332779022332L
  • java.security.interfaces.ECPrivateKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -7896394956925609184L
  • java.security.interfaces.ECPublicKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -3314988629879632826L
  • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 618058533534628008L
  • java.security.interfaces.RSAPrivateCrtKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -5682214253527700368L
  • java.security.interfaces.RSAPrivateKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 5187144804936595022L
  • java.security.interfaces.RSAPublicKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -8727434096241101194L

java.sql.*

  • java.sql.Connection
    Modifier and Type | Constant Field | Value
    public static final int | TRANSACTION_NONE | 0
    public static final int | TRANSACTION_READ_COMMITTED | 2
    public static final int | TRANSACTION_READ_UNCOMMITTED | 1
    public static final int | TRANSACTION_REPEATABLE_READ | 4
    public static final int | TRANSACTION_SERIALIZABLE | 8
  • java.sql.DatabaseMetaData
    Modifier and Type | Constant Field | Value
    public static final short | attributeNoNulls | 0
    public static final short | attributeNullable | 1
    public static final short | attributeNullableUnknown | 2
    public static final int | bestRowNotPseudo | 1
    public static final int | bestRowPseudo | 2
    public static final int | bestRowSession | 2
    public static final int | bestRowTemporary | 0
    public static final int | bestRowTransaction | 1
    public static final int | bestRowUnknown | 0
    public static final int | columnNoNulls | 0
    public static final int | columnNullable | 1
    public static final int | columnNullableUnknown | 2
    public static final int | functionColumnIn | 1
    public static final int | functionColumnInOut | 2
    public static final int | functionColumnOut | 3
    public static final int | functionColumnResult | 5
    public static final int | functionColumnUnknown | 0
    public static final int | functionNoNulls | 0
    public static final int | functionNoTable | 1
    public static final int | functionNullable | 1
    public static final int | functionNullableUnknown | 2
    public static final int | functionResultUnknown | 0
    public static final int | functionReturn | 4
    public static final int | functionReturnsTable | 2
    public static final int | importedKeyCascade | 0
    public static final int | importedKeyInitiallyDeferred | 5
    public static final int | importedKeyInitiallyImmediate | 6
    public static final int | importedKeyNoAction | 3
    public static final int | importedKeyNotDeferrable | 7
    public static final int | importedKeyRestrict | 1
    public static final int | importedKeySetDefault | 4
    public static final int | importedKeySetNull | 2
    public static final int | procedureColumnIn | 1
    public static final int | procedureColumnInOut | 2
    public static final int | procedureColumnOut | 4
    public static final int | procedureColumnResult | 3
    public static final int | procedureColumnReturn | 5
    public static final int | procedureColumnUnknown | 0
    public static final int | procedureNoNulls | 0
    public static final int | procedureNoResult | 1
    public static final int | procedureNullable | 1
    public static final int | procedureNullableUnknown | 2
    public static final int | procedureResultUnknown | 0
    public static final int | procedureReturnsResult | 2
    public static final int | sqlStateSQL | 2
    public static final int | sqlStateSQL99 | 2
    public static final int | sqlStateXOpen | 1
    public static final short | tableIndexClustered | 1
    public static final short | tableIndexHashed | 2
    public static final short | tableIndexOther | 3
    public static final short | tableIndexStatistic | 0
    public static final int | typeNoNulls | 0
    public static final int | typeNullable | 1
    public static final int | typeNullableUnknown | 2
    public static final int | typePredBasic | 2
    public static final int | typePredChar | 1
    public static final int | typePredNone | 0
    public static final int | typeSearchable | 3
    public static final int | versionColumnNotPseudo | 1
    public static final int | versionColumnPseudo | 2
    public static final int | versionColumnUnknown | 0
  • java.sql.ParameterMetaData
    Modifier and Type | Constant Field | Value
    public static final int | parameterModeIn | 1
    public static final int | parameterModeInOut | 2
    public static final int | parameterModeOut | 4
    public static final int | parameterModeUnknown | 0
    public static final int | parameterNoNulls | 0
    public static final int | parameterNullable | 1
    public static final int | parameterNullableUnknown | 2
  • java.sql.ResultSet
    Modifier and Type | Constant Field | Value
    public static final int | CLOSE_CURSORS_AT_COMMIT | 2
    public static final int | CONCUR_READ_ONLY | 1007
    public static final int | CONCUR_UPDATABLE | 1008
    public static final int | FETCH_FORWARD | 1000
    public static final int | FETCH_REVERSE | 1001
    public static final int | FETCH_UNKNOWN | 1002
    public static final int | HOLD_CURSORS_OVER_COMMIT | 1
    public static final int | TYPE_FORWARD_ONLY | 1003
    public static final int | TYPE_SCROLL_INSENSITIVE | 1004
    public static final int | TYPE_SCROLL_SENSITIVE | 1005
  • java.sql.ResultSetMetaData
    Modifier and Type | Constant Field | Value
    public static final int | columnNoNulls | 0
    public static final int | columnNullable | 1
    public static final int | columnNullableUnknown | 2
  • java.sql.Statement
    Modifier and Type | Constant Field | Value
    public static final int | CLOSE_ALL_RESULTS | 3
    public static final int | CLOSE_CURRENT_RESULT | 1
    public static final int | EXECUTE_FAILED | -3
    public static final int | KEEP_CURRENT_RESULT | 2
    public static final int | NO_GENERATED_KEYS | 2
    public static final int | RETURN_GENERATED_KEYS | 1
    public static final int | SUCCESS_NO_INFO | -2
  • java.sql.Types
    Modifier and Type | Constant Field | Value
    public static final int | ARRAY | 2003
    public static final int | BIGINT | -5
    public static final int | BINARY | -2
    public static final int | BIT | -7
    public static final int | BLOB | 2004
    public static final int | BOOLEAN | 16
    public static final int | CHAR | 1
    public static final int | CLOB | 2005
    public static final int | DATALINK | 70
    public static final int | DATE | 91
    public static final int | DECIMAL | 3
    public static final int | DISTINCT | 2001
    public static final int | DOUBLE | 8
    public static final int | FLOAT | 6
    public static final int | INTEGER | 4
    public static final int | JAVA_OBJECT | 2000
    public static final int | LONGNVARCHAR | -16
    public static final int | LONGVARBINARY | -4
    public static final int | LONGVARCHAR | -1
    public static final int | NCHAR | -15
    public static final int | NCLOB | 2011
    public static final int | NULL | 0
    public static final int | NUMERIC | 2
    public static final int | NVARCHAR | -9
    public static final int | OTHER | 1111
    public static final int | REAL | 7
    public static final int | REF | 2006
    public static final int | REF_CURSOR | 2012
    public static final int | ROWID | -8
    public static final int | SMALLINT | 5
    public static final int | SQLXML | 2009
    public static final int | STRUCT | 2002
    public static final int | TIME | 92
    public static final int | TIME_WITH_TIMEZONE | 2013
    public static final int | TIMESTAMP | 93
    public static final int | TIMESTAMP_WITH_TIMEZONE | 2014
    public static final int | TINYINT | -6
    public static final int | VARBINARY | -3
    public static final int | VARCHAR | 12

java.text.*

  • java.text.Bidi
    Modifier and Type | Constant Field | Value
    public static final int | DIRECTION_DEFAULT_LEFT_TO_RIGHT | -2
    public static final int | DIRECTION_DEFAULT_RIGHT_TO_LEFT | -1
    public static final int | DIRECTION_LEFT_TO_RIGHT | 0
    public static final int | DIRECTION_RIGHT_TO_LEFT | 1
  • java.text.BreakIterator
    Modifier and Type | Constant Field | Value
    public static final int | DONE | -1
  • java.text.CharacterIterator
    Modifier and Type | Constant Field | Value
    public static final char | DONE | 65535
  • java.text.CollationElementIterator
    Modifier and Type | Constant Field | Value
    public static final int | NULLORDER | -1
  • java.text.Collator
    Modifier and Type | Constant Field | Value
    public static final int | CANONICAL_DECOMPOSITION | 1
    public static final int | FULL_DECOMPOSITION | 2
    public static final int | IDENTICAL | 3
    public static final int | NO_DECOMPOSITION | 0
    public static final int | PRIMARY | 0
    public static final int | SECONDARY | 1
    public static final int | TERTIARY | 2
  • java.text.DateFormat
    Modifier and Type | Constant Field | Value
    public static final int | AM_PM_FIELD | 14
    public static final int | DATE_FIELD | 3
    public static final int | DAY_OF_WEEK_FIELD | 9
    public static final int | DAY_OF_WEEK_IN_MONTH_FIELD | 11
    public static final int | DAY_OF_YEAR_FIELD | 10
    public static final int | DEFAULT | 2
    public static final int | ERA_FIELD | 0
    public static final int | FULL | 0
    public static final int | HOUR_OF_DAY0_FIELD | 5
    public static final int | HOUR_OF_DAY1_FIELD | 4
    public static final int | HOUR0_FIELD | 16
    public static final int | HOUR1_FIELD | 15
    public static final int | LONG | 1
    public static final int | MEDIUM | 2
    public static final int | MILLISECOND_FIELD | 8
    public static final int | MINUTE_FIELD | 6
    public static final int | MONTH_FIELD | 2
    public static final int | SECOND_FIELD | 7
    public static final int | SHORT | 3
    public static final int | TIMEZONE_FIELD | 17
    public static final int | WEEK_OF_MONTH_FIELD | 13
    public static final int | WEEK_OF_YEAR_FIELD | 12
    public static final int | YEAR_FIELD | 1
  • java.text.NumberFormat
    Modifier and Type | Constant Field | Value
    public static final int | FRACTION_FIELD | 1
    public static final int | INTEGER_FIELD | 0

java.time.*

  • java.time.Year
    Modifier and Type | Constant Field | Value
    public static final int | MAX_VALUE | 999999999
    public static final int | MIN_VALUE | -999999999

java.util.*

  • java.util.Calendar
    Modifier and Type | Constant Field | Value
    public static final int | ALL_STYLES | 0
    public static final int | AM | 0
    public static final int | AM_PM | 9
    public static final int | APRIL | 3
    public static final int | AUGUST | 7
    public static final int | DATE | 5
    public static final int | DAY_OF_MONTH | 5
    public static final int | DAY_OF_WEEK | 7
    public static final int | DAY_OF_WEEK_IN_MONTH | 8
    public static final int | DAY_OF_YEAR | 6
    public static final int | DECEMBER | 11
    public static final int | DST_OFFSET | 16
    public static final int | ERA | 0
    public static final int | FEBRUARY | 1
    public static final int | FIELD_COUNT | 17
    public static final int | FRIDAY | 6
    public static final int | HOUR | 10
    public static final int | HOUR_OF_DAY | 11
    public static final int | JANUARY | 0
    public static final int | JULY | 6
    public static final int | JUNE | 5
    public static final int | LONG | 2
    public static final int | LONG_FORMAT | 2
    public static final int | LONG_STANDALONE | 32770
    public static final int | MARCH | 2
    public static final int | MAY | 4
    public static final int | MILLISECOND | 14
    public static final int | MINUTE | 12
    public static final int | MONDAY | 2
    public static final int | MONTH | 2
    public static final int | NARROW_FORMAT | 4
    public static final int | NARROW_STANDALONE | 32772
    public static final int | NOVEMBER | 10
    public static final int | OCTOBER | 9
    public static final int | PM | 1
    public static final int | SATURDAY | 7
    public static final int | SECOND | 13
    public static final int | SEPTEMBER | 8
    public static final int | SHORT | 1
    public static final int | SHORT_FORMAT | 1
    public static final int | SHORT_STANDALONE | 32769
    public static final int | SUNDAY | 1
    public static final int | THURSDAY | 5
    public static final int | TUESDAY | 3
    public static final int | UNDECIMBER | 12
    public static final int | WEDNESDAY | 4
    public static final int | WEEK_OF_MONTH | 4
    public static final int | WEEK_OF_YEAR | 3
    public static final int | YEAR | 1
    public static final int | ZONE_OFFSET | 15
  • java.util.FormattableFlags
    Modifier and Type | Constant Field | Value
    public static final int | ALTERNATE | 4
    public static final int | LEFT_JUSTIFY | 1
    public static final int | UPPERCASE | 2
  • java.util.GregorianCalendar
    Modifier and Type | Constant Field | Value
    public static final int | AD | 1
    public static final int | BC | 0
  • java.util.Locale
    Modifier and Type | Constant Field | Value
    public static final char | PRIVATE_USE_EXTENSION | 120
    public static final char | UNICODE_LOCALE_EXTENSION | 117
  • java.util.Locale.LanguageRange
    Modifier and Type | Constant Field | Value
    public static final double | MAX_WEIGHT | 1.0
    public static final double | MIN_WEIGHT | 0.0
  • java.util.ResourceBundle.Control
    Modifier and Type | Constant Field | Value
    public static final long | TTL_DONT_CACHE | -1L
    public static final long | TTL_NO_EXPIRATION_CONTROL | -2L
  • java.util.SimpleTimeZone
    Modifier and Type | Constant Field | Value
    public static final int | STANDARD_TIME | 1
    public static final int | UTC_TIME | 2
    public static final int | WALL_TIME | 0
  • java.util.Spliterator<T>
    Modifier and Type | Constant Field | Value
    public static final int | CONCURRENT | 4096
    public static final int | DISTINCT | 1
    public static final int | IMMUTABLE | 1024
    public static final int | NONNULL | 256
    public static final int | ORDERED | 16
    public static final int | SIZED | 64
    public static final int | SORTED | 4
    public static final int | SUBSIZED | 16384
  • java.util.TimeZone
    Modifier and Type | Constant Field | Value
    public static final int | LONG | 1
    public static final int | SHORT | 0
  • java.util.jar.JarEntry
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
  • java.util.jar.JarFile
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
    public static final String | MANIFEST_NAME | "META-INF/MANIFEST.MF"
  • java.util.jar.JarInputStream
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
  • java.util.jar.JarOutputStream
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
  • java.util.jar.Pack200.Packer
    Modifier and Type | Constant Field | Value
    public static final String | CLASS_ATTRIBUTE_PFX | "pack.class.attribute."
    public static final String | CODE_ATTRIBUTE_PFX | "pack.code.attribute."
    public static final String | DEFLATE_HINT | "pack.deflate.hint"
    public static final String | EFFORT | "pack.effort"
    public static final String | ERROR | "error"
    public static final String | FALSE | "false"
    public static final String | FIELD_ATTRIBUTE_PFX | "pack.field.attribute."
    public static final String | KEEP | "keep"
    public static final String | KEEP_FILE_ORDER | "pack.keep.file.order"
    public static final String | LATEST | "latest"
    public static final String | METHOD_ATTRIBUTE_PFX | "pack.method.attribute."
    public static final String | MODIFICATION_TIME | "pack.modification.time"
    public static final String | PASS | "pass"
    public static final String | PASS_FILE_PFX | "pack.pass.file."
    public static final String | PROGRESS | "pack.progress"
    public static final String | SEGMENT_LIMIT | "pack.segment.limit"
    public static final String | STRIP | "strip"
    public static final String | TRUE | "true"
    public static final String | UNKNOWN_ATTRIBUTE | "pack.unknown.attribute"
  • java.util.jar.Pack200.Unpacker
    Modifier and Type | Constant Field | Value
    public static final String | DEFLATE_HINT | "unpack.deflate.hint"
    public static final String | FALSE | "false"
    public static final String | KEEP | "keep"
    public static final String | PROGRESS | "unpack.progress"
    public static final String | TRUE | "true"
  • java.util.logging.ErrorManager
    Modifier and Type | Constant Field | Value
    public static final int | CLOSE_FAILURE | 3
    public static final int | FLUSH_FAILURE | 2
    public static final int | FORMAT_FAILURE | 5
    public static final int | GENERIC_FAILURE | 0
    public static final int | OPEN_FAILURE | 4
    public static final int | WRITE_FAILURE | 1
  • java.util.logging.Logger
    Modifier and Type | Constant Field | Value
    public static final String | GLOBAL_LOGGER_NAME | "global"
  • java.util.logging.LogManager
    Modifier and Type | Constant Field | Value
    public static final String | LOGGING_MXBEAN_NAME | "java.util.logging:type=Logging"
  • java.util.prefs.Preferences
    Modifier and Type | Constant Field | Value
    public static final int | MAX_KEY_LENGTH | 80
    public static final int | MAX_NAME_LENGTH | 80
    public static final int | MAX_VALUE_LENGTH | 8192
  • java.util.regex.Pattern
    Modifier and Type | Constant Field | Value
    public static final int | CANON_EQ | 128
    public static final int | CASE_INSENSITIVE | 2
    public static final int | COMMENTS | 4
    public static final int | DOTALL | 32
    public static final int | LITERAL | 16
    public static final int | MULTILINE | 8
    public static final int | UNICODE_CASE | 64
    public static final int | UNICODE_CHARACTER_CLASS | 256
    public static final int | UNIX_LINES | 1
  • java.util.zip.Deflater
    Modifier and Type | Constant Field | Value
    public static final int | BEST_COMPRESSION | 9
    public static final int | BEST_SPEED | 1
    public static final int | DEFAULT_COMPRESSION | -1
    public static final int | DEFAULT_STRATEGY | 0
    public static final int | DEFLATED | 8
    public static final int | FILTERED | 1
    public static final int | FULL_FLUSH | 3
    public static final int | HUFFMAN_ONLY | 2
    public static final int | NO_COMPRESSION | 0
    public static final int | NO_FLUSH | 0
    public static final int | SYNC_FLUSH | 2
  • java.util.zip.GZIPInputStream
    Modifier and Type | Constant Field | Value
    public static final int | GZIP_MAGIC | 35615
  • java.util.zip.ZipEntry
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | DEFLATED | 8
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
    public static final int | STORED | 0
  • java.util.zip.ZipFile
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
    public static final int | OPEN_DELETE | 4
    public static final int | OPEN_READ | 1
  • java.util.zip.ZipInputStream
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
  • java.util.zip.ZipOutputStream
    Modifier and Type | Constant Field | Value
    public static final int | CENATT | 36
    public static final int | CENATX | 38
    public static final int | CENCOM | 32
    public static final int | CENCRC | 16
    public static final int | CENDSK | 34
    public static final int | CENEXT | 30
    public static final int | CENFLG | 8
    public static final int | CENHDR | 46
    public static final int | CENHOW | 10
    public static final int | CENLEN | 24
    public static final int | CENNAM | 28
    public static final int | CENOFF | 42
    public static final long | CENSIG | 33639248L
    public static final int | CENSIZ | 20
    public static final int | CENTIM | 12
    public static final int | CENVEM | 4
    public static final int | CENVER | 6
    public static final int | DEFLATED | 8
    public static final int | ENDCOM | 20
    public static final int | ENDHDR | 22
    public static final int | ENDOFF | 16
    public static final long | ENDSIG | 101010256L
    public static final int | ENDSIZ | 12
    public static final int | ENDSUB | 8
    public static final int | ENDTOT | 10
    public static final int | EXTCRC | 4
    public static final int | EXTHDR | 16
    public static final int | EXTLEN | 12
    public static final long | EXTSIG | 134695760L
    public static final int | EXTSIZ | 8
    public static final int | LOCCRC | 14
    public static final int | LOCEXT | 28
    public static final int | LOCFLG | 6
    public static final int | LOCHDR | 30
    public static final int | LOCHOW | 8
    public static final int | LOCLEN | 22
    public static final int | LOCNAM | 26
    public static final long | LOCSIG | 67324752L
    public static final int | LOCSIZ | 18
    public static final int | LOCTIM | 10
    public static final int | LOCVER | 4
    public static final int | STORED | 0

javafx.animation.*

  • javafx.animation.Animation
    Modifier and Type | Constant Field | Value
    public static final int | INDEFINITE | -1

javafx.application.*

  • javafx.application.Application
    Modifier and Type | Constant Field | Value
    public static final String | STYLESHEET_CASPIAN | "CASPIAN"
    public static final String | STYLESHEET_MODENA | "MODENA"

javafx.fxml.*

  • javafx.fxml.FXMLLoader
    Modifier and Type | Constant Field | Value
    public static final String ARRAY_COMPONENT_DELIMITER ","
    public static final String BI_DIRECTIONAL_BINDING_PREFIX "#{"
    public static final String BI_DIRECTIONAL_BINDING_SUFFIX "}"
    public static final String BINDING_EXPRESSION_PREFIX "${"
    public static final String BINDING_EXPRESSION_SUFFIX "}"
    public static final String | CHANGE_EVENT_HANDLER_SUFFIX | "Change"
    public static final String | CONTROLLER_KEYWORD | "controller"
    public static final String CONTROLLER_METHOD_PREFIX "#"
    public static final String | CONTROLLER_SUFFIX | "Controller"
    public static final String | COPY_SOURCE_ATTRIBUTE | "source"
    public static final String | COPY_TAG | "copy"
    public static final String | DEFAULT_CHARSET_NAME | "UTF-8"
    public static final String | DEFINE_TAG | "define"
    public static final String ESCAPE_PREFIX "\\"
    public static final String | EVENT_HANDLER_PREFIX | "on"
    public static final String | EVENT_KEY | "event"
    public static final String EXPRESSION_PREFIX "$"
    public static final String | FX_CONSTANT_ATTRIBUTE | "constant"
    public static final String | FX_CONTROLLER_ATTRIBUTE | "controller"
    public static final String | FX_FACTORY_ATTRIBUTE | "factory"
    public static final String | FX_ID_ATTRIBUTE | "id"
    public static final String | FX_NAMESPACE_PREFIX | "fx"
    public static final String | FX_NAMESPACE_VERSION | "1"
    public static final String | FX_VALUE_ATTRIBUTE | "value"
    public static final String | IMPORT_PROCESSING_INSTRUCTION | "import"
    public static final String | INCLUDE_CHARSET_ATTRIBUTE | "charset"
    public static final String | INCLUDE_RESOURCES_ATTRIBUTE | "resources"
    public static final String | INCLUDE_SOURCE_ATTRIBUTE | "source"
    public static final String | INCLUDE_TAG | "include"
    public static final String | INITIALIZE_METHOD_NAME | "initialize"
    public static final String | LANGUAGE_PROCESSING_INSTRUCTION | "language"
    public static final String | LOCATION_KEY | "location"
    public static final String | NULL_KEYWORD | "null"
    public static final String | REFERENCE_SOURCE_ATTRIBUTE | "source"
    public static final String | REFERENCE_TAG | "reference"
    public static final String RELATIVE_PATH_PREFIX "@"
    public static final String RESOURCE_KEY_PREFIX "%"
    public static final String | RESOURCES_KEY | "resources"
    public static final String | ROOT_TAG | "root"
    public static final String | ROOT_TYPE_ATTRIBUTE | "type"
    public static final String | SCRIPT_CHARSET_ATTRIBUTE | "charset"
    public static final String | SCRIPT_SOURCE_ATTRIBUTE | "source"
    public static final String | SCRIPT_TAG | "script"

javafx.scene.*

  • javafx.scene.Node
    Modifier and Type | Constant Field | Value
    public static final double | BASELINE_OFFSET_SAME_AS_HEIGHT | -1d/0d
  • javafx.scene.control.ButtonBar
    Modifier and Type | Constant Field | Value
    public static final String | BUTTON_ORDER_LINUX | "L_HE+UNYACBXIO_R"
    public static final String | BUTTON_ORDER_MAC_OS | "L_HE+U+FBIX_NCYOA_R"
    public static final String BUTTON_ORDER_NONE ""
    public static final String | BUTTON_ORDER_WINDOWS | "L_E+U+FBXI_YNOCAH_R"
  • javafx.scene.control.ColorPicker
    Modifier and Type | Constant Field | Value
    public static final String | STYLE_CLASS_BUTTON | "button"
    public static final String | STYLE_CLASS_SPLIT_BUTTON | "split-button"
  • javafx.scene.control.IndexRange
    Modifier and Type Constant Field Value
    public static final String VALUE_DELIMITER ","
  • javafx.scene.control.Pagination
    Modifier and Type | Constant Field | Value
    public static final int | INDETERMINATE | 2147483647
    public static final String | STYLE_CLASS_BULLET | "bullet"
  • javafx.scene.control.PopupControl
    Modifier and Type | Constant Field | Value
    public static final double | USE_COMPUTED_SIZE | -1.0
    public static final double | USE_PREF_SIZE | -1d/0d
  • javafx.scene.control.ProgressIndicator
    Modifier and Type | Constant Field | Value
    public static final double | INDETERMINATE_PROGRESS | -1.0
  • javafx.scene.control.Spinner<T>
    Modifier and Type | Constant Field | Value
    public static final String | STYLE_CLASS_ARROWS_ON_LEFT_HORIZONTAL | "arrows-on-left-horizontal"
    public static final String | STYLE_CLASS_ARROWS_ON_LEFT_VERTICAL | "arrows-on-left-vertical"
    public static final String | STYLE_CLASS_ARROWS_ON_RIGHT_HORIZONTAL | "arrows-on-right-horizontal"
    public static final String | STYLE_CLASS_SPLIT_ARROWS_HORIZONTAL | "split-arrows-horizontal"
    public static final String | STYLE_CLASS_SPLIT_ARROWS_VERTICAL | "split-arrows-vertical"
  • javafx.scene.control.TabPane
    Modifier and Type | Constant Field | Value
    public static final String | STYLE_CLASS_FLOATING | "floating"
  • javafx.scene.control.TextArea
    Modifier and Type | Constant Field | Value
    public static final int | DEFAULT_PREF_COLUMN_COUNT | 40
    public static final int | DEFAULT_PREF_ROW_COUNT | 10
  • javafx.scene.control.TextField
    Modifier and Type | Constant Field | Value
    public static final int | DEFAULT_PREF_COLUMN_COUNT | 12
  • javafx.scene.input.PickResult
    Modifier and Type | Constant Field | Value
    public static final int | FACE_UNDEFINED | -1
  • javafx.scene.layout.BackgroundSize
    Modifier and Type | Constant Field | Value
    public static final double | AUTO | -1.0
  • javafx.scene.layout.BorderWidths
    Modifier and Type | Constant Field | Value
    public static final double | AUTO | -1.0
  • javafx.scene.layout.ConstraintsBase
    Modifier and Type | Constant Field | Value
    public static final double | CONSTRAIN_TO_PREF | -1d/0d
  • javafx.scene.layout.GridPane
    Modifier and Type | Constant Field | Value
    public static final int | REMAINING | 2147483647
  • javafx.scene.layout.Region
    Modifier and Type | Constant Field | Value
    public static final double | USE_COMPUTED_SIZE | -1.0
    public static final double | USE_PREF_SIZE | -1d/0d
  • javafx.scene.media.AudioClip
    Modifier and Type | Constant Field | Value
    public static final int | INDEFINITE | -1
  • javafx.scene.media.AudioEqualizer
    Modifier and Type | Constant Field | Value
    public static final int | MAX_NUM_BANDS | 64
  • javafx.scene.media.EqualizerBand
    Modifier and Type | Constant Field | Value
    public static final double | MAX_GAIN | 12.0
    public static final double | MIN_GAIN | -24.0
  • javafx.scene.media.MediaPlayer
    Modifier and Type | Constant Field | Value
    public static final int | INDEFINITE | -1
  • javafx.scene.shape.Box
    Modifier and Type | Constant Field | Value
    public static final double | DEFAULT_SIZE | 2.0

javax.accessibility.*

  • javax.accessibility.AccessibleContext
    Modifier and Type | Constant Field | Value
    public static final String | ACCESSIBLE_ACTION_PROPERTY | "accessibleActionProperty"
    public static final String | ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY | "AccessibleActiveDescendant"
    public static final String | ACCESSIBLE_CARET_PROPERTY | "AccessibleCaret"
    public static final String | ACCESSIBLE_CHILD_PROPERTY | "AccessibleChild"
    public static final String | ACCESSIBLE_COMPONENT_BOUNDS_CHANGED | "accessibleComponentBoundsChanged"
    public static final String | ACCESSIBLE_DESCRIPTION_PROPERTY | "AccessibleDescription"
    public static final String | ACCESSIBLE_HYPERTEXT_OFFSET | "AccessibleHypertextOffset"
    public static final String | ACCESSIBLE_INVALIDATE_CHILDREN | "accessibleInvalidateChildren"
    public static final String | ACCESSIBLE_NAME_PROPERTY | "AccessibleName"
    public static final String | ACCESSIBLE_SELECTION_PROPERTY | "AccessibleSelection"
    public static final String | ACCESSIBLE_STATE_PROPERTY | "AccessibleState"
    public static final String | ACCESSIBLE_TABLE_CAPTION_CHANGED | "accessibleTableCaptionChanged"
    public static final String | ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED | "accessibleTableColumnDescriptionChanged"
    public static final String | ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED | "accessibleTableColumnHeaderChanged"
    public static final String | ACCESSIBLE_TABLE_MODEL_CHANGED | "accessibleTableModelChanged"
    public static final String | ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED | "accessibleTableRowDescriptionChanged"
    public static final String | ACCESSIBLE_TABLE_ROW_HEADER_CHANGED | "accessibleTableRowHeaderChanged"
    public static final String | ACCESSIBLE_TABLE_SUMMARY_CHANGED | "accessibleTableSummaryChanged"
    public static final String | ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED | "accessibleTextAttributesChanged"
    public static final String | ACCESSIBLE_TEXT_PROPERTY | "AccessibleText"
    public static final String | ACCESSIBLE_VALUE_PROPERTY | "AccessibleValue"
    public static final String | ACCESSIBLE_VISIBLE_DATA_PROPERTY | "AccessibleVisibleData"
  • javax.accessibility.AccessibleExtendedText
    Modifier and Type | Constant Field | Value
    public static final int | ATTRIBUTE_RUN | 5
    public static final int | LINE | 4
  • javax.accessibility.AccessibleRelation
    Modifier and Type | Constant Field | Value
    public static final String | CHILD_NODE_OF | "childNodeOf"
    public static final String | CHILD_NODE_OF_PROPERTY | "childNodeOfProperty"
    public static final String | CONTROLLED_BY_PROPERTY | "controlledByProperty"
    public static final String | CONTROLLER_FOR_PROPERTY | "controllerForProperty"
    public static final String | EMBEDDED_BY | "embeddedBy"
    public static final String | EMBEDDED_BY_PROPERTY | "embeddedByProperty"
    public static final String | EMBEDS | "embeds"
    public static final String | EMBEDS_PROPERTY | "embedsProperty"
    public static final String | FLOWS_FROM | "flowsFrom"
    public static final String | FLOWS_FROM_PROPERTY | "flowsFromProperty"
    public static final String | FLOWS_TO | "flowsTo"
    public static final String | FLOWS_TO_PROPERTY | "flowsToProperty"
    public static final String | LABEL_FOR_PROPERTY | "labelForProperty"
    public static final String | LABELED_BY_PROPERTY | "labeledByProperty"
    public static final String | MEMBER_OF_PROPERTY | "memberOfProperty"
    public static final String | PARENT_WINDOW_OF | "parentWindowOf"
    public static final String | PARENT_WINDOW_OF_PROPERTY | "parentWindowOfProperty"
    public static final String | SUBWINDOW_OF | "subwindowOf"
    public static final String | SUBWINDOW_OF_PROPERTY | "subwindowOfProperty"
  • javax.accessibility.AccessibleTableModelChange
    Modifier and Type | Constant Field | Value
    public static final int | DELETE | -1
    public static final int | INSERT | 1
    public static final int | UPDATE | 0
  • javax.accessibility.AccessibleText
    Modifier and Type | Constant Field | Value
    public static final int | CHARACTER | 1
    public static final int | SENTENCE | 3
    public static final int | WORD | 2

javax.crypto.*

  • javax.crypto.Cipher
    Modifier and Type | Constant Field | Value
    public static final int | DECRYPT_MODE | 2
    public static final int | ENCRYPT_MODE | 1
    public static final int | PRIVATE_KEY | 2
    public static final int | PUBLIC_KEY | 1
    public static final int | SECRET_KEY | 3
    public static final int | UNWRAP_MODE | 4
    public static final int | WRAP_MODE | 3
  • javax.crypto.SecretKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -4795878709595146952L
  • javax.crypto.interfaces.DHPrivateKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | 2211791113380396553L
  • javax.crypto.interfaces.DHPublicKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -6628103563352519193L
  • javax.crypto.interfaces.PBEKey
    Modifier and Type | Constant Field | Value
    public static final long | serialVersionUID | -1430015993304333921L
  • javax.crypto.spec.DESedeKeySpec
    Modifier and Type | Constant Field | Value
    public static final int | DES_EDE_KEY_LEN | 24
  • javax.crypto.spec.DESKeySpec
    Modifier and Type | Constant Field | Value
    public static final int | DES_KEY_LEN | 8

javax.imageio.*

  • javax.imageio.ImageWriteParam
    Modifier and Type | Constant Field | Value
    public static final int | MODE_COPY_FROM_METADATA | 3
    public static final int | MODE_DEFAULT | 1
    public static final int | MODE_DISABLED | 0
    public static final int | MODE_EXPLICIT | 2
  • javax.imageio.metadata.IIOMetadataFormat
    Modifier and Type | Constant Field | Value
    public static final int | CHILD_POLICY_ALL | 1
    public static final int | CHILD_POLICY_CHOICE | 3
    public static final int | CHILD_POLICY_EMPTY | 0
    public static final int | CHILD_POLICY_MAX | 5
    public static final int | CHILD_POLICY_REPEAT | 5
    public static final int | CHILD_POLICY_SEQUENCE | 4
    public static final int | CHILD_POLICY_SOME | 2
    public static final int | DATATYPE_BOOLEAN | 1
    public static final int | DATATYPE_DOUBLE | 4
    public static final int | DATATYPE_FLOAT | 3
    public static final int | DATATYPE_INTEGER | 2
    public static final int | DATATYPE_STRING | 0
    public static final int | VALUE_ARBITRARY | 1
    public static final int | VALUE_ENUMERATION | 16
    public static final int | VALUE_LIST | 32
    public static final int | VALUE_NONE | 0
    public static final int | VALUE_RANGE | 2
    public static final int | VALUE_RANGE_MAX_INCLUSIVE | 10
    public static final int | VALUE_RANGE_MAX_INCLUSIVE_MASK | 8
    public static final int | VALUE_RANGE_MIN_INCLUSIVE | 6
    public static final int | VALUE_RANGE_MIN_INCLUSIVE_MASK | 4
    public static final int | VALUE_RANGE_MIN_MAX_INCLUSIVE | 14
  • javax.imageio.metadata.IIOMetadataFormatImpl
    Modifier and Type | Constant Field | Value
    public static final String | standardMetadataFormatName | "javax_imageio_1.0"
  • javax.imageio.plugins.tiff.BaselineTIFFTagSet
    Modifier and Type | Constant Field | Value
    public static final int | COMPRESSION_CCITT_RLE | 2
    public static final int | COMPRESSION_CCITT_T_4 | 3
    public static final int | COMPRESSION_CCITT_T_6 | 4
    public static final int | COMPRESSION_DEFLATE | 32946
    public static final int | COMPRESSION_JPEG | 7
    public static final int | COMPRESSION_LZW | 5
    public static final int | COMPRESSION_NONE | 1
    public static final int | COMPRESSION_OLD_JPEG | 6
    public static final int | COMPRESSION_PACKBITS | 32773
    public static final int | COMPRESSION_ZLIB | 8
    public static final int | EXTRA_SAMPLES_ASSOCIATED_ALPHA | 1
    public static final int | EXTRA_SAMPLES_UNASSOCIATED_ALPHA | 2
    public static final int | EXTRA_SAMPLES_UNSPECIFIED | 0
    public static final int | FILL_ORDER_LEFT_TO_RIGHT | 1
    public static final int | FILL_ORDER_RIGHT_TO_LEFT | 2
    public static final int | GRAY_RESPONSE_UNIT_HUNDRED_THOUSANDTHS | 5
    public static final int | GRAY_RESPONSE_UNIT_HUNDREDTHS | 2
    public static final int | GRAY_RESPONSE_UNIT_TEN_THOUSANDTHS | 4
    public static final int | GRAY_RESPONSE_UNIT_TENTHS | 1
    public static final int | GRAY_RESPONSE_UNIT_THOUSANDTHS | 3
    public static final int | INK_SET_CMYK | 1
    public static final int | INK_SET_NOT_CMYK | 2
    public static final int | JPEG_PROC_BASELINE | 1
    public static final int | JPEG_PROC_LOSSLESS | 14
    public static final int | NEW_SUBFILE_TYPE_REDUCED_RESOLUTION | 1
    public static final int | NEW_SUBFILE_TYPE_SINGLE_PAGE | 2
    public static final int | NEW_SUBFILE_TYPE_TRANSPARENCY | 4
    public static final int | ORIENTATION_ROW_0_BOTTOM_COLUMN_0_LEFT | 4
    public static final int | ORIENTATION_ROW_0_BOTTOM_COLUMN_0_RIGHT | 3
    public static final int | ORIENTATION_ROW_0_LEFT_COLUMN_0_BOTTOM | 8
    public static final int | ORIENTATION_ROW_0_LEFT_COLUMN_0_TOP | 5
    public static final int | ORIENTATION_ROW_0_RIGHT_COLUMN_0_BOTTOM | 7
    public static final int | ORIENTATION_ROW_0_RIGHT_COLUMN_0_TOP | 6
    public static final int | ORIENTATION_ROW_0_TOP_COLUMN_0_LEFT | 1
    public static final int | ORIENTATION_ROW_0_TOP_COLUMN_0_RIGHT | 2
    public static final int | PHOTOMETRIC_INTERPRETATION_BLACK_IS_ZERO | 1
    public static final int | PHOTOMETRIC_INTERPRETATION_CIELAB | 8
    public static final int | PHOTOMETRIC_INTERPRETATION_CMYK | 5
    public static final int | PHOTOMETRIC_INTERPRETATION_ICCLAB | 9
    public static final int | PHOTOMETRIC_INTERPRETATION_PALETTE_COLOR | 3
    public static final int | PHOTOMETRIC_INTERPRETATION_RGB | 2
    public static final int | PHOTOMETRIC_INTERPRETATION_TRANSPARENCY_MASK | 4
    public static final int | PHOTOMETRIC_INTERPRETATION_WHITE_IS_ZERO | 0
    public static final int | PHOTOMETRIC_INTERPRETATION_Y_CB_CR | 6
    public static final int | PLANAR_CONFIGURATION_CHUNKY | 1
    public static final int | PLANAR_CONFIGURATION_PLANAR | 2
    public static final int | PREDICTOR_HORIZONTAL_DIFFERENCING | 2
    public static final int | PREDICTOR_NONE | 1
    public static final int | RESOLUTION_UNIT_CENTIMETER | 3
    public static final int | RESOLUTION_UNIT_INCH | 2
    public static final int | RESOLUTION_UNIT_NONE | 1
    public static final int | SAMPLE_FORMAT_FLOATING_POINT | 3
    public static final int | SAMPLE_FORMAT_SIGNED_INTEGER | 2
    public static final int | SAMPLE_FORMAT_UNDEFINED | 4
    public static final int | SAMPLE_FORMAT_UNSIGNED_INTEGER | 1
    public static final int | SUBFILE_TYPE_FULL_RESOLUTION | 1
    public static final int | SUBFILE_TYPE_REDUCED_RESOLUTION | 2
    public static final int | SUBFILE_TYPE_SINGLE_PAGE | 3
    public static final int | T4_OPTIONS_2D_CODING | 1
    public static final int | T4_OPTIONS_EOL_BYTE_ALIGNED | 4
    public static final int | T4_OPTIONS_UNCOMPRESSED | 2
    public static final int | T6_OPTIONS_UNCOMPRESSED | 2
    public static final int | TAG_ARTIST | 315
    public static final int | TAG_BITS_PER_SAMPLE | 258
    public static final int | TAG_CELL_LENGTH | 265
    public static final int | TAG_CELL_WIDTH | 264
    public static final int | TAG_COLOR_MAP | 320
    public static final int | TAG_COMPRESSION | 259
    public static final int | TAG_COPYRIGHT | 33432
    public static final int | TAG_DATE_TIME | 306
    public static final int | TAG_DOCUMENT_NAME | 269
    public static final int | TAG_DOT_RANGE | 336
    public static final int | TAG_EXTRA_SAMPLES | 338
    public static final int | TAG_FILL_ORDER | 266
    public static final int | TAG_FREE_BYTE_COUNTS | 289
    public static final int | TAG_FREE_OFFSETS | 288
    public static final int | TAG_GRAY_RESPONSE_CURVE | 291
    public static final int | TAG_GRAY_RESPONSE_UNIT | 290
    public static final int | TAG_HALFTONE_HINTS | 321
    public static final int | TAG_HOST_COMPUTER | 316
    public static final int | TAG_ICC_PROFILE | 34675
    public static final int | TAG_IMAGE_DESCRIPTION | 270
    public static final int | TAG_IMAGE_LENGTH | 257
    public static final int | TAG_IMAGE_WIDTH | 256
    public static final int | TAG_INK_NAMES | 333
    public static final int | TAG_INK_SET | 332
    public static final int | TAG_JPEG_AC_TABLES | 521
    public static final int | TAG_JPEG_DC_TABLES | 520
    public static final int | TAG_JPEG_INTERCHANGE_FORMAT | 513
    public static final int | TAG_JPEG_INTERCHANGE_FORMAT_LENGTH | 514
    public static final int | TAG_JPEG_LOSSLESS_PREDICTORS | 517
    public static final int | TAG_JPEG_POINT_TRANSFORMS | 518
    public static final int | TAG_JPEG_PROC | 512
    public static final int | TAG_JPEG_Q_TABLES | 519
    public static final int | TAG_JPEG_RESTART_INTERVAL | 515
    public static final int | TAG_JPEG_TABLES | 347
    public static final int | TAG_MAKE | 271
    public static final int | TAG_MAX_SAMPLE_VALUE | 281
    public static final int | TAG_MIN_SAMPLE_VALUE | 280
    public static final int | TAG_MODEL | 272
    public static final int | TAG_NEW_SUBFILE_TYPE | 254
    public static final int | TAG_NUMBER_OF_INKS | 334
    public static final int | TAG_ORIENTATION | 274
    public static final int | TAG_PAGE_NAME | 285
    public static final int | TAG_PAGE_NUMBER | 297
    public static final int | TAG_PHOTOMETRIC_INTERPRETATION | 262
    public static final int | TAG_PLANAR_CONFIGURATION | 284
    public static final int | TAG_PREDICTOR | 317
    public static final int | TAG_PRIMARY_CHROMATICITES | 319
    public static final int | TAG_REFERENCE_BLACK_WHITE | 532
    public static final int | TAG_RESOLUTION_UNIT | 296
    public static final int | TAG_ROWS_PER_STRIP | 278
    public static final int | TAG_S_MAX_SAMPLE_VALUE | 341
    public static final int | TAG_S_MIN_SAMPLE_VALUE | 340
    public static final int | TAG_SAMPLE_FORMAT | 339
    public static final int | TAG_SAMPLES_PER_PIXEL | 277
    public static final int | TAG_SOFTWARE | 305
    public static final int | TAG_STRIP_BYTE_COUNTS | 279
    public static final int | TAG_STRIP_OFFSETS | 273
    public static final int | TAG_SUBFILE_TYPE | 255
    public static final int | TAG_T4_OPTIONS | 292
    public static final int | TAG_T6_OPTIONS | 293
    public static final int | TAG_TARGET_PRINTER | 337
    public static final int | TAG_THRESHHOLDING | 263
    public static final int | TAG_TILE_BYTE_COUNTS | 325
    public static final int | TAG_TILE_LENGTH | 323
    public static final int | TAG_TILE_OFFSETS | 324
    public static final int | TAG_TILE_WIDTH | 322
    public static final int | TAG_TRANSFER_FUNCTION | 301
    public static final int | TAG_TRANSFER_RANGE | 342
    public static final int | TAG_WHITE_POINT | 318
    public static final int | TAG_X_POSITION | 286
    public static final int | TAG_X_RESOLUTION | 282
    public static final int | TAG_Y_CB_CR_COEFFICIENTS | 529
    public static final int | TAG_Y_CB_CR_POSITIONING | 531
    public static final int | TAG_Y_CB_CR_SUBSAMPLING | 530
    public static final int | TAG_Y_POSITION | 287
    public static final int | TAG_Y_RESOLUTION | 283
    public static final int | THRESHHOLDING_NONE | 1
    public static final int | THRESHHOLDING_ORDERED_DITHER | 2
    public static final int | THRESHHOLDING_RANDOMIZED_DITHER | 3
    public static final int | Y_CB_CR_POSITIONING_CENTERED | 1
    public static final int | Y_CB_CR_POSITIONING_COSITED | 2
  • javax.imageio.plugins.tiff.ExifGPSTagSet
    Modifier and Type | Constant Field | Value
    public static final int | ALTITUDE_REF_SEA_LEVEL | 0
    public static final int | ALTITUDE_REF_SEA_LEVEL_REFERENCE | 1
    public static final String | DEST_DISTANCE_REF_KILOMETERS | "K"
    public static final String | DEST_DISTANCE_REF_KNOTS | "N"
    public static final String | DEST_DISTANCE_REF_MILES | "M"
    public static final int | DIFFERENTIAL_CORRECTION_APPLIED | 1
    public static final int | DIFFERENTIAL_CORRECTION_NONE | 0
    public static final String | DIRECTION_REF_MAGNETIC | "M"
    public static final String | DIRECTION_REF_TRUE | "T"
    public static final String | GPS_VERSION_2_2 | "2200"
    public static final String | LATITUDE_REF_NORTH | "N"
    public static final String | LATITUDE_REF_SOUTH | "S"
    public static final String | LONGITUDE_REF_EAST | "E"
    public static final String | LONGITUDE_REF_WEST | "W"
    public static final String | MEASURE_MODE_2D | "2"
    public static final String | MEASURE_MODE_3D | "3"
    public static final String | SPEED_REF_KILOMETERS_PER_HOUR | "K"
    public static final String | SPEED_REF_KNOTS | "N"
    public static final String | SPEED_REF_MILES_PER_HOUR | "M"
    public static final String | STATUS_MEASUREMENT_IN_PROGRESS | "A"
    public static final String | STATUS_MEASUREMENT_INTEROPERABILITY | "V"
    public static final int | TAG_GPS_ALTITUDE | 6
    public static final int | TAG_GPS_ALTITUDE_REF | 5
    public static final int | TAG_GPS_AREA_INFORMATION | 28
    public static final int | TAG_GPS_DATE_STAMP | 29
    public static final int | TAG_GPS_DEST_BEARING | 24
    public static final int | TAG_GPS_DEST_BEARING_REF | 23
    public static final int | TAG_GPS_DEST_DISTANCE | 26
    public static final int | TAG_GPS_DEST_DISTANCE_REF | 25
    public static final int | TAG_GPS_DEST_LATITUDE | 20
    public static final int | TAG_GPS_DEST_LATITUDE_REF | 19
    public static final int | TAG_GPS_DEST_LONGITUDE | 22
    public static final int | TAG_GPS_DEST_LONGITUDE_REF | 21
    public static final int | TAG_GPS_DIFFERENTIAL | 30
    public static final int | TAG_GPS_DOP | 11
    public static final int | TAG_GPS_IMG_DIRECTION | 17
    public static final int | TAG_GPS_IMG_DIRECTION_REF | 16
    public static final int | TAG_GPS_LATITUDE | 2
    public static final int | TAG_GPS_LATITUDE_REF | 1
    public static final int | TAG_GPS_LONGITUDE | 4
    public static final int | TAG_GPS_LONGITUDE_REF | 3
    public static final int | TAG_GPS_MAP_DATUM | 18
    public static final int | TAG_GPS_MEASURE_MODE | 10
    public static final int | TAG_GPS_PROCESSING_METHOD | 27
    public static final int | TAG_GPS_SATELLITES | 8
    public static final int | TAG_GPS_SPEED | 13
    public static final int | TAG_GPS_SPEED_REF | 12
    public static final int | TAG_GPS_STATUS | 9
    public static final int | TAG_GPS_TIME_STAMP | 7
    public static final int | TAG_GPS_TRACK | 15
    public static final int | TAG_GPS_TRACK_REF | 14
    public static final int | TAG_GPS_VERSION_ID | 0
  • javax.imageio.plugins.tiff.ExifInteroperabilityTagSet
    Modifier and Type | Constant Field | Value
    public static final String | INTEROPERABILITY_INDEX_R98 | "R98"
    public static final String | INTEROPERABILITY_INDEX_THM | "THM"
    public static final int | TAG_INTEROPERABILITY_INDEX | 1
  • javax.imageio.plugins.tiff.ExifParentTIFFTagSet
    Modifier and Type | Constant Field | Value
    public static final int | TAG_EXIF_IFD_POINTER | 34665
    public static final int | TAG_GPS_INFO_IFD_POINTER | 34853
  • javax.imageio.plugins.tiff.ExifTIFFTagSet
    Modifier and Type | Constant Field | Value
    public static final int | COLOR_SPACE_SRGB | 1
    public static final int | COLOR_SPACE_UNCALIBRATED | 65535
    public static final int | COMPONENTS_CONFIGURATION_B | 6
    public static final int | COMPONENTS_CONFIGURATION_CB | 2
    public static final int | COMPONENTS_CONFIGURATION_CR | 3
    public static final int | COMPONENTS_CONFIGURATION_DOES_NOT_EXIST | 0
    public static final int | COMPONENTS_CONFIGURATION_G | 5
    public static final int | COMPONENTS_CONFIGURATION_R | 4
    public static final int | COMPONENTS_CONFIGURATION_Y | 1
    public static final int | CONTRAST_HARD | 2
    public static final int | CONTRAST_NORMAL | 0
    public static final int | CONTRAST_SOFT | 1
    public static final int | CUSTOM_RENDERED_CUSTOM | 1
    public static final int | CUSTOM_RENDERED_NORMAL | 0
    public static final String | EXIF_VERSION_2_1 | "0210"
    public static final String | EXIF_VERSION_2_2 | "0220"
    public static final int | EXPOSURE_MODE_AUTO_BRACKET | 2
    public static final int | EXPOSURE_MODE_AUTO_EXPOSURE | 0
    public static final int | EXPOSURE_MODE_MANUAL_EXPOSURE | 1
    public static final int | EXPOSURE_PROGRAM_ACTION_PROGRAM | 6
    public static final int | EXPOSURE_PROGRAM_APERTURE_PRIORITY | 3
    public static final int | EXPOSURE_PROGRAM_CREATIVE_PROGRAM | 5
    public static final int | EXPOSURE_PROGRAM_LANDSCAPE_MODE | 8
    public static final int | EXPOSURE_PROGRAM_MANUAL | 1
    public static final int | EXPOSURE_PROGRAM_MAX_RESERVED | 255
    public static final int | EXPOSURE_PROGRAM_NORMAL_PROGRAM | 2
    public static final int | EXPOSURE_PROGRAM_NOT_DEFINED | 0
    public static final int | EXPOSURE_PROGRAM_PORTRAIT_MODE | 7
    public static final int | EXPOSURE_PROGRAM_SHUTTER_PRIORITY | 4
    public static final int | FILE_SOURCE_DSC | 3
    public static final int | FLASH_DID_NOT_FIRE | 0
    public static final int | FLASH_FIRED | 1
    public static final int | FLASH_MASK_FIRED | 1
    public static final int | FLASH_MASK_FUNCTION_NOT_PRESENT | 32
    public static final int | FLASH_MASK_MODE_AUTO | 24
    public static final int | FLASH_MASK_MODE_FLASH_FIRING | 8
    public static final int FLASH_MASK_MODE_FLASH_SUPPRESSION 16
    public static final int FLASH_MASK_RED_EYE_REDUCTION 64
    public static final int FLASH_MASK_RETURN_DETECTED 6
    public static final int FLASH_MASK_RETURN_NOT_DETECTED 4
    public static final int FLASH_STROBE_RETURN_LIGHT_DETECTED 7
    public static final int FLASH_STROBE_RETURN_LIGHT_NOT_DETECTED 5
    public static final int FOCAL_PLANE_RESOLUTION_UNIT_CENTIMETER 3
    public static final int FOCAL_PLANE_RESOLUTION_UNIT_INCH 2
    public static final int FOCAL_PLANE_RESOLUTION_UNIT_NONE 1
    public static final int GAIN_CONTROL_HIGH_GAIN_DOWN 4
    public static final int GAIN_CONTROL_HIGH_GAIN_UP 2
    public static final int GAIN_CONTROL_LOW_GAIN_DOWN 3
    public static final int GAIN_CONTROL_LOW_GAIN_UP 1
    public static final int GAIN_CONTROL_NONE 0
    public static final int LIGHT_SOURCE_CLOUDY_WEATHER 10
    public static final int LIGHT_SOURCE_COOL_WHITE_FLUORESCENT 14
    public static final int LIGHT_SOURCE_D50 23
    public static final int LIGHT_SOURCE_D55 20
    public static final int LIGHT_SOURCE_D65 21
    public static final int LIGHT_SOURCE_D75 22
    public static final int LIGHT_SOURCE_DAY_WHITE_FLUORESCENT 13
    public static final int LIGHT_SOURCE_DAYLIGHT 1
    public static final int LIGHT_SOURCE_DAYLIGHT_FLUORESCENT 12
    public static final int LIGHT_SOURCE_FINE_WEATHER 9
    public static final int LIGHT_SOURCE_FLASH 4
    public static final int LIGHT_SOURCE_FLUORESCENT 2
    public static final int LIGHT_SOURCE_ISO_STUDIO_TUNGSTEN 24
    public static final int LIGHT_SOURCE_OTHER 255
    public static final int LIGHT_SOURCE_SHADE 11
    public static final int LIGHT_SOURCE_STANDARD_LIGHT_A 17
    public static final int LIGHT_SOURCE_STANDARD_LIGHT_B 18
    public static final int LIGHT_SOURCE_STANDARD_LIGHT_C 19
    public static final int LIGHT_SOURCE_TUNGSTEN 3
    public static final int LIGHT_SOURCE_UNKNOWN 0
    public static final int LIGHT_SOURCE_WHITE_FLUORESCENT 15
    public static final int METERING_MODE_AVERAGE 1
    public static final int METERING_MODE_CENTER_WEIGHTED_AVERAGE 2
    public static final int METERING_MODE_MAX_RESERVED 254
    public static final int METERING_MODE_MIN_RESERVED 7
    public static final int METERING_MODE_MULTI_SPOT 4
    public static final int METERING_MODE_OTHER 255
    public static final int METERING_MODE_PARTIAL 6
    public static final int METERING_MODE_PATTERN 5
    public static final int METERING_MODE_SPOT 3
    public static final int METERING_MODE_UNKNOWN 0
    public static final int SATURATION_HIGH 2
    public static final int SATURATION_LOW 1
    public static final int SATURATION_NORMAL 0
    public static final int SCENE_CAPTURE_TYPE_LANDSCAPE 1
    public static final int SCENE_CAPTURE_TYPE_NIGHT_SCENE 3
    public static final int SCENE_CAPTURE_TYPE_PORTRAIT 2
    public static final int SCENE_CAPTURE_TYPE_STANDARD 0
    public static final int SCENE_TYPE_DSC 1
    public static final int SENSING_METHOD_COLOR_SEQUENTIAL_AREA_SENSOR 5
    public static final int SENSING_METHOD_COLOR_SEQUENTIAL_LINEAR_SENSOR 8
    public static final int SENSING_METHOD_NOT_DEFINED 1
    public static final int SENSING_METHOD_ONE_CHIP_COLOR_AREA_SENSOR 2
    public static final int SENSING_METHOD_THREE_CHIP_COLOR_AREA_SENSOR 4
    public static final int SENSING_METHOD_TRILINEAR_SENSOR 7
    public static final int SENSING_METHOD_TWO_CHIP_COLOR_AREA_SENSOR 3
    public static final int SHARPNESS_HARD 2
    public static final int SHARPNESS_NORMAL 0
    public static final int SHARPNESS_SOFT 1
    public static final int SUBJECT_DISTANCE_RANGE_CLOSE_VIEW 2
    public static final int SUBJECT_DISTANCE_RANGE_DISTANT_VIEW 3
    public static final int SUBJECT_DISTANCE_RANGE_MACRO 1
    public static final int SUBJECT_DISTANCE_RANGE_UNKNOWN 0
    public static final int TAG_APERTURE_VALUE 37378
    public static final int TAG_BRIGHTNESS_VALUE 37379
    public static final int TAG_CFA_PATTERN 41730
    public static final int TAG_COLOR_SPACE 40961
    public static final int TAG_COMPONENTS_CONFIGURATION 37121
    public static final int TAG_COMPRESSED_BITS_PER_PIXEL 37122
    public static final int TAG_CONTRAST 41992
    public static final int TAG_CUSTOM_RENDERED 41985
    public static final int TAG_DATE_TIME_DIGITIZED 36868
    public static final int TAG_DATE_TIME_ORIGINAL 36867
    public static final int TAG_DEVICE_SETTING_DESCRIPTION 41995
    public static final int TAG_DIGITAL_ZOOM_RATIO 41988
    public static final int TAG_EXIF_VERSION 36864
    public static final int TAG_EXPOSURE_BIAS_VALUE 37380
    public static final int TAG_EXPOSURE_INDEX 41493
    public static final int TAG_EXPOSURE_MODE 41986
    public static final int TAG_EXPOSURE_PROGRAM 34850
    public static final int TAG_EXPOSURE_TIME 33434
    public static final int TAG_F_NUMBER 33437
    public static final int TAG_FILE_SOURCE 41728
    public static final int TAG_FLASH 37385
    public static final int TAG_FLASH_ENERGY 41483
    public static final int TAG_FLASHPIX_VERSION 40960
    public static final int TAG_FOCAL_LENGTH 37386
    public static final int TAG_FOCAL_LENGTH_IN_35MM_FILM 41989
    public static final int TAG_FOCAL_PLANE_RESOLUTION_UNIT 41488
    public static final int TAG_FOCAL_PLANE_X_RESOLUTION 41486
    public static final int TAG_FOCAL_PLANE_Y_RESOLUTION 41487
    public static final int TAG_GAIN_CONTROL 41991
    public static final int TAG_GPS_INFO_IFD_POINTER 34853
    public static final int TAG_IMAGE_UNIQUE_ID 42016
    public static final int TAG_INTEROPERABILITY_IFD_POINTER 40965
    public static final int TAG_ISO_SPEED_RATINGS 34855
    public static final int TAG_LIGHT_SOURCE 37384
    public static final int TAG_MAKER_NOTE 37500
    public static final int TAG_MARKER_NOTE 37500
    public static final int TAG_MAX_APERTURE_VALUE 37381
    public static final int TAG_METERING_MODE 37383
    public static final int TAG_OECF 34856
    public static final int TAG_PIXEL_X_DIMENSION 40962
    public static final int TAG_PIXEL_Y_DIMENSION 40963
    public static final int TAG_RELATED_SOUND_FILE 40964
    public static final int TAG_SATURATION 41993
    public static final int TAG_SCENE_CAPTURE_TYPE 41990
    public static final int TAG_SCENE_TYPE 41729
    public static final int TAG_SENSING_METHOD 41495
    public static final int TAG_SHARPNESS 41994
    public static final int TAG_SHUTTER_SPEED_VALUE 37377
    public static final int TAG_SPATIAL_FREQUENCY_RESPONSE 41484
    public static final int TAG_SPECTRAL_SENSITIVITY 34852
    public static final int TAG_SUB_SEC_TIME 37520
    public static final int TAG_SUB_SEC_TIME_DIGITIZED 37522
    public static final int TAG_SUB_SEC_TIME_ORIGINAL 37521
    public static final int TAG_SUBJECT_AREA 37396
    public static final int TAG_SUBJECT_DISTANCE 37382
    public static final int TAG_SUBJECT_DISTANCE_RANGE 41996
    public static final int TAG_SUBJECT_LOCATION 41492
    public static final int TAG_USER_COMMENT 37510
    public static final int TAG_WHITE_BALANCE 41987
    public static final int WHITE_BALANCE_AUTO 0
    public static final int WHITE_BALANCE_MANUAL 1
  • javax.imageio.plugins.tiff.FaxTIFFTagSet
    Modifier and Type Constant Field Value
    public static final int CLEAN_FAX_DATA_ERRORS_CORRECTED 1
    public static final int CLEAN_FAX_DATA_ERRORS_UNCORRECTED 2
    public static final int CLEAN_FAX_DATA_NO_ERRORS 0
    public static final int TAG_BAD_FAX_LINES 326
    public static final int TAG_CLEAN_FAX_DATA 327
    public static final int TAG_CONSECUTIVE_BAD_LINES 328
  • javax.imageio.plugins.tiff.GeoTIFFTagSet
    Modifier and Type Constant Field Value
    public static final int TAG_GEO_ASCII_PARAMS 34737
    public static final int TAG_GEO_DOUBLE_PARAMS 34736
    public static final int TAG_GEO_KEY_DIRECTORY 34735
    public static final int TAG_MODEL_PIXEL_SCALE 33550
    public static final int TAG_MODEL_TIE_POINT 33922
    public static final int TAG_MODEL_TRANSFORMATION 34264
  • javax.imageio.plugins.tiff.TIFFTag
    Modifier and Type Constant Field Value
    public static final int MAX_DATATYPE 13
    public static final int MIN_DATATYPE 1
    public static final int TIFF_ASCII 2
    public static final int TIFF_BYTE 1
    public static final int TIFF_DOUBLE 12
    public static final int TIFF_FLOAT 11
    public static final int TIFF_IFD_POINTER 13
    public static final int TIFF_LONG 4
    public static final int TIFF_RATIONAL 5
    public static final int TIFF_SBYTE 6
    public static final int TIFF_SHORT 3
    public static final int TIFF_SLONG 9
    public static final int TIFF_SRATIONAL 10
    public static final int TIFF_SSHORT 8
    public static final int TIFF_UNDEFINED 7
    public static final String UNKNOWN_TAG_NAME "UnknownTag"

javax.jnlp.*

  • javax.jnlp.DownloadService2
    Modifier and Type Constant Field Value
    public static final int ALL 0
    public static final int APPLET 2
    public static final int APPLICATION 1
    public static final int CLASS 6
    public static final int EXTENSION 3
    public static final int IMAGE 5
    public static final int JAR 4
  • javax.jnlp.PersistenceService
    Modifier and Type Constant Field Value
    public static final int CACHED 0
    public static final int DIRTY 2
    public static final int TEMPORARY 1

javax.management.*

  • javax.management.AttributeChangeNotification
    Modifier and Type Constant Field Value
    public static final String ATTRIBUTE_CHANGE "jmx.attribute.change"
  • javax.management.JMX
    Modifier and Type Constant Field Value
    public static final String DEFAULT_VALUE_FIELD "defaultValue"
    public static final String IMMUTABLE_INFO_FIELD "immutableInfo"
    public static final String INTERFACE_CLASS_NAME_FIELD "interfaceClassName"
    public static final String LEGAL_VALUES_FIELD "legalValues"
    public static final String MAX_VALUE_FIELD "maxValue"
    public static final String MIN_VALUE_FIELD "minValue"
    public static final String MXBEAN_FIELD "mxbean"
    public static final String OPEN_TYPE_FIELD "openType"
    public static final String ORIGINAL_TYPE_FIELD "originalType"
  • javax.management.MBeanOperationInfo
    Modifier and Type Constant Field Value
    public static final int ACTION 1
    public static final int ACTION_INFO 2
    public static final int INFO 0
    public static final int UNKNOWN 3
  • javax.management.MBeanServerNotification
    Modifier and Type Constant Field Value
    public static final String REGISTRATION_NOTIFICATION "JMX.mbean.registered"
    public static final String UNREGISTRATION_NOTIFICATION "JMX.mbean.unregistered"
  • javax.management.Query
    Modifier and Type Constant Field Value
    public static final int DIV 3
    public static final int EQ 4
    public static final int GE 2
    public static final int GT 0
    public static final int LE 3
    public static final int LT 1
    public static final int MINUS 1
    public static final int PLUS 0
    public static final int TIMES 2
  • javax.management.monitor.Monitor
    Modifier and Type Constant Field Value
    protected static final int capacityIncrement 16
    protected static final int OBSERVED_ATTRIBUTE_ERROR_NOTIFIED 2
    protected static final int OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED 4
    protected static final int OBSERVED_OBJECT_ERROR_NOTIFIED 1
    protected static final int RESET_FLAGS_ALREADY_NOTIFIED 0
    protected static final int RUNTIME_ERROR_NOTIFIED 8
  • javax.management.monitor.MonitorNotification
    Modifier and Type Constant Field Value
    public static final String OBSERVED_ATTRIBUTE_ERROR "jmx.monitor.error.attribute"
    public static final String OBSERVED_ATTRIBUTE_TYPE_ERROR "jmx.monitor.error.type"
    public static final String OBSERVED_OBJECT_ERROR "jmx.monitor.error.mbean"
    public static final String RUNTIME_ERROR "jmx.monitor.error.runtime"
    public static final String STRING_TO_COMPARE_VALUE_DIFFERED "jmx.monitor.string.differs"
    public static final String STRING_TO_COMPARE_VALUE_MATCHED "jmx.monitor.string.matches"
    public static final String THRESHOLD_ERROR "jmx.monitor.error.threshold"
    public static final String THRESHOLD_HIGH_VALUE_EXCEEDED "jmx.monitor.gauge.high"
    public static final String THRESHOLD_LOW_VALUE_EXCEEDED "jmx.monitor.gauge.low"
    public static final String THRESHOLD_VALUE_EXCEEDED "jmx.monitor.counter.threshold"
  • javax.management.relation.RelationNotification
    Modifier and Type Constant Field Value
    public static final String RELATION_BASIC_CREATION "jmx.relation.creation.basic"
    public static final String RELATION_BASIC_REMOVAL "jmx.relation.removal.basic"
    public static final String RELATION_BASIC_UPDATE "jmx.relation.update.basic"
    public static final String RELATION_MBEAN_CREATION "jmx.relation.creation.mbean"
    public static final String RELATION_MBEAN_REMOVAL "jmx.relation.removal.mbean"
    public static final String RELATION_MBEAN_UPDATE "jmx.relation.update.mbean"
  • javax.management.relation.RoleInfo
    Modifier and Type Constant Field Value
    public static final int ROLE_CARDINALITY_INFINITY -1
  • javax.management.relation.RoleStatus
    Modifier and Type Constant Field Value
    public static final int LESS_THAN_MIN_ROLE_DEGREE 4
    public static final int MORE_THAN_MAX_ROLE_DEGREE 5
    public static final int NO_ROLE_WITH_NAME 1
    public static final int REF_MBEAN_NOT_REGISTERED 7
    public static final int REF_MBEAN_OF_INCORRECT_CLASS 6
    public static final int ROLE_NOT_READABLE 2
    public static final int ROLE_NOT_WRITABLE 3
  • javax.management.remote.JMXConnectionNotification
    Modifier and Type Constant Field Value
    public static final String CLOSED "jmx.remote.connection.closed"
    public static final String FAILED "jmx.remote.connection.failed"
    public static final String NOTIFS_LOST "jmx.remote.connection.notifs.lost"
    public static final String OPENED "jmx.remote.connection.opened"
  • javax.management.remote.JMXConnector
    Modifier and Type Constant Field Value
    public static final String CREDENTIALS "jmx.remote.credentials"
  • javax.management.remote.JMXConnectorFactory
    Modifier and Type Constant Field Value
    public static final String DEFAULT_CLASS_LOADER "jmx.remote.default.class.loader"
    public static final String PROTOCOL_PROVIDER_CLASS_LOADER "jmx.remote.protocol.provider.class.loader"
    public static final String PROTOCOL_PROVIDER_PACKAGES "jmx.remote.protocol.provider.pkgs"
  • javax.management.remote.JMXConnectorServer
    Modifier and Type Constant Field Value
    public static final String AUTHENTICATOR "jmx.remote.authenticator"
  • javax.management.remote.JMXConnectorServerFactory
    Modifier and Type Constant Field Value
    public static final String DEFAULT_CLASS_LOADER "jmx.remote.default.class.loader"
    public static final String DEFAULT_CLASS_LOADER_NAME "jmx.remote.default.class.loader.name"
    public static final String PROTOCOL_PROVIDER_CLASS_LOADER "jmx.remote.protocol.provider.class.loader"
    public static final String PROTOCOL_PROVIDER_PACKAGES "jmx.remote.protocol.provider.pkgs"
  • javax.management.remote.rmi.RMIConnectorServer
    Modifier and Type Constant Field Value
    public static final String CREDENTIAL_TYPES "jmx.remote.rmi.server.credential.types"
    public static final String JNDI_REBIND_ATTRIBUTE "jmx.remote.jndi.rebind"
    public static final String RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE "jmx.remote.rmi.client.socket.factory"
    public static final String RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE "jmx.remote.rmi.server.socket.factory"
  • javax.management.timer.Timer
    Modifier and Type Constant Field Value
    public static final long ONE_DAY 86400000L
    public static final long ONE_HOUR 3600000L
    public static final long ONE_MINUTE 60000L
    public static final long ONE_SECOND 1000L
    public static final long ONE_WEEK 604800000L

javax.naming.*

  • javax.naming.Context
    Modifier and Type Constant Field Value
    public static final String APPLET "java.naming.applet"
    public static final String AUTHORITATIVE "java.naming.authoritative"
    public static final String BATCHSIZE "java.naming.batchsize"
    public static final String DNS_URL "java.naming.dns.url"
    public static final String INITIAL_CONTEXT_FACTORY "java.naming.factory.initial"
    public static final String LANGUAGE "java.naming.language"
    public static final String OBJECT_FACTORIES "java.naming.factory.object"
    public static final String PROVIDER_URL "java.naming.provider.url"
    public static final String REFERRAL "java.naming.referral"
    public static final String SECURITY_AUTHENTICATION "java.naming.security.authentication"
    public static final String SECURITY_CREDENTIALS "java.naming.security.credentials"
    public static final String SECURITY_PRINCIPAL "java.naming.security.principal"
    public static final String SECURITY_PROTOCOL "java.naming.security.protocol"
    public static final String STATE_FACTORIES "java.naming.factory.state"
    public static final String URL_PKG_PREFIXES "java.naming.factory.url.pkgs"
  • javax.naming.Name
    Modifier and Type Constant Field Value
    public static final long serialVersionUID -3617482732056931635L
  • javax.naming.directory.Attribute
    Modifier and Type Constant Field Value
    public static final long serialVersionUID 8707690322213556804L
  • javax.naming.directory.DirContext
    Modifier and Type Constant Field Value
    public static final int ADD_ATTRIBUTE 1
    public static final int REMOVE_ATTRIBUTE 3
    public static final int REPLACE_ATTRIBUTE 2
  • javax.naming.directory.SearchControls
    Modifier and Type Constant Field Value
    public static final int OBJECT_SCOPE 0
    public static final int ONELEVEL_SCOPE 1
    public static final int SUBTREE_SCOPE 2
  • javax.naming.event.EventContext
    Modifier and Type Constant Field Value
    public static final int OBJECT_SCOPE 0
    public static final int ONELEVEL_SCOPE 1
    public static final int SUBTREE_SCOPE 2
  • javax.naming.event.NamingEvent
    Modifier and Type Constant Field Value
    public static final int OBJECT_ADDED 0
    public static final int OBJECT_CHANGED 3
    public static final int OBJECT_REMOVED 1
    public static final int OBJECT_RENAMED 2
  • javax.naming.ldap.Control
    Modifier and Type Constant Field Value
    public static final boolean CRITICAL true
    public static final boolean NONCRITICAL false
  • javax.naming.ldap.LdapContext
    Modifier and Type Constant Field Value
    public static final String CONTROL_FACTORIES "java.naming.factory.control"
  • javax.naming.ldap.ManageReferralControl
    Modifier and Type Constant Field Value
    public static final String OID "2.16.840.1.113730.3.4.2"
  • javax.naming.ldap.PagedResultsControl
    Modifier and Type Constant Field Value
    public static final String OID "1.2.840.113556.1.4.319"
  • javax.naming.ldap.PagedResultsResponseControl
    Modifier and Type Constant Field Value
    public static final String OID "1.2.840.113556.1.4.319"
  • javax.naming.ldap.SortControl
    Modifier and Type Constant Field Value
    public static final String OID "1.2.840.113556.1.4.473"
  • javax.naming.ldap.SortResponseControl
    Modifier and Type Constant Field Value
    public static final String OID "1.2.840.113556.1.4.474"
  • javax.naming.ldap.StartTlsRequest
    Modifier and Type Constant Field Value
    public static final String OID "1.3.6.1.4.1.1466.20037"
  • javax.naming.ldap.StartTlsResponse
    Modifier and Type Constant Field Value
    public static final String OID "1.3.6.1.4.1.1466.20037"
  • javax.naming.spi.NamingManager
    Modifier and Type Constant Field Value
    public static final String CPE "java.naming.spi.CannotProceedException"

javax.net.*

  • javax.net.ssl.StandardConstants
    Modifier and Type Constant Field Value
    public static final int SNI_HOST_NAME 0

javax.print.*

  • javax.print.ServiceUIFactory
    Modifier and Type Constant Field Value
    public static final int ABOUT_UIROLE 1
    public static final int ADMIN_UIROLE 2
    public static final String DIALOG_UI "java.awt.Dialog"
    public static final String JCOMPONENT_UI "javax.swing.JComponent"
    public static final String JDIALOG_UI "javax.swing.JDialog"
    public static final int MAIN_UIROLE 3
    public static final String PANEL_UI "java.awt.Panel"
    public static final int RESERVED_UIROLE 99
  • javax.print.URIException
    Modifier and Type Constant Field Value
    public static final int URIInaccessible 1
    public static final int URIOtherProblem -1
    public static final int URISchemeNotSupported 2
  • javax.print.attribute.ResolutionSyntax
    Modifier and Type Constant Field Value
    public static final int DPCM 254
    public static final int DPI 100
  • javax.print.attribute.Size2DSyntax
    Modifier and Type Constant Field Value
    public static final int INCH 25400
    public static final int MM 1000
  • javax.print.attribute.standard.MediaPrintableArea
    Modifier and Type Constant Field Value
    public static final int INCH 25400
    public static final int MM 1000
  • javax.print.event.PrintJobEvent
    Modifier and Type Constant Field Value
    public static final int DATA_TRANSFER_COMPLETE 106
    public static final int JOB_CANCELED 101
    public static final int JOB_COMPLETE 102
    public static final int JOB_FAILED 103
    public static final int NO_MORE_EVENTS 105
    public static final int REQUIRES_ATTENTION 104

javax.script.*

  • javax.script.ScriptContext
    Modifier and Type Constant Field Value
    public static final int ENGINE_SCOPE 100
    public static final int GLOBAL_SCOPE 200
  • javax.script.ScriptEngine
    Modifier and Type Constant Field Value
    public static final String ARGV "javax.script.argv"
    public static final String ENGINE "javax.script.engine"
    public static final String ENGINE_VERSION "javax.script.engine_version"
    public static final String FILENAME "javax.script.filename"
    public static final String LANGUAGE "javax.script.language"
    public static final String LANGUAGE_VERSION "javax.script.language_version"
    public static final String NAME "javax.script.name"

javax.security.*

  • javax.security.auth.callback.ConfirmationCallback
    Modifier and Type Constant Field Value
    public static final int CANCEL 2
    public static final int ERROR 2
    public static final int INFORMATION 0
    public static final int NO 1
    public static final int OK 3
    public static final int OK_CANCEL_OPTION 2
    public static final int UNSPECIFIED_OPTION -1
    public static final int WARNING 1
    public static final int YES 0
    public static final int YES_NO_CANCEL_OPTION 1
    public static final int YES_NO_OPTION 0
  • javax.security.auth.callback.TextOutputCallback
    Modifier and Type Constant Field Value
    public static final int ERROR 2
    public static final int INFORMATION 0
    public static final int WARNING 1
  • javax.security.auth.kerberos.KerberosPrincipal
    Modifier and Type Constant Field Value
    public static final int KRB_NT_PRINCIPAL 1
    public static final int KRB_NT_SRV_HST 3
    public static final int KRB_NT_SRV_INST 2
    public static final int KRB_NT_SRV_XHST 4
    public static final int KRB_NT_UID 5
    public static final int KRB_NT_UNKNOWN 0
  • javax.security.auth.x500.X500Principal
    Modifier and Type Constant Field Value
    public static final String CANONICAL "CANONICAL"
    public static final String RFC1779 "RFC1779"
    public static final String RFC2253 "RFC2253"
  • javax.security.sasl.Sasl
    Modifier and Type Constant Field Value
    public static final String BOUND_SERVER_NAME "javax.security.sasl.bound.server.name"
    public static final String CREDENTIALS "javax.security.sasl.credentials"
    public static final String MAX_BUFFER "javax.security.sasl.maxbuffer"
    public static final String POLICY_FORWARD_SECRECY "javax.security.sasl.policy.forward"
    public static final String POLICY_NOACTIVE "javax.security.sasl.policy.noactive"
    public static final String POLICY_NOANONYMOUS "javax.security.sasl.policy.noanonymous"
    public static final String POLICY_NODICTIONARY "javax.security.sasl.policy.nodictionary"
    public static final String POLICY_NOPLAINTEXT "javax.security.sasl.policy.noplaintext"
    public static final String POLICY_PASS_CREDENTIALS "javax.security.sasl.policy.credentials"
    public static final String QOP "javax.security.sasl.qop"
    public static final String RAW_SEND_SIZE "javax.security.sasl.rawsendsize"
    public static final String REUSE "javax.security.sasl.reuse"
    public static final String SERVER_AUTH "javax.security.sasl.server.authentication"
    public static final String STRENGTH "javax.security.sasl.strength"

javax.sound.*

  • javax.sound.midi.MetaMessage
    Modifier and Type Constant Field Value
    public static final int META 255
  • javax.sound.midi.MidiFileFormat
    Modifier and Type Constant Field Value
    public static final int UNKNOWN_LENGTH -1
  • javax.sound.midi.Sequence
    Modifier and Type Constant Field Value
    public static final float PPQ 0.0f
    public static final float SMPTE_24 24.0f
    public static final float SMPTE_25 25.0f
    public static final float SMPTE_30 30.0f
    public static final float SMPTE_30DROP 29.969999313354492f
  • javax.sound.midi.Sequencer
    Modifier and Type Constant Field Value
    public static final int LOOP_CONTINUOUSLY -1
  • javax.sound.midi.ShortMessage
    Modifier and Type Constant Field Value
    public static final int ACTIVE_SENSING 254
    public static final int CHANNEL_PRESSURE 208
    public static final int CONTINUE 251
    public static final int CONTROL_CHANGE 176
    public static final int END_OF_EXCLUSIVE 247
    public static final int MIDI_TIME_CODE 241
    public static final int NOTE_OFF 128
    public static final int NOTE_ON 144
    public static final int PITCH_BEND 224
    public static final int POLY_PRESSURE 160
    public static final int PROGRAM_CHANGE 192
    public static final int SONG_POSITION_POINTER 242
    public static final int SONG_SELECT 243
    public static final int START 250
    public static final int STOP 252
    public static final int SYSTEM_RESET 255
    public static final int TIMING_CLOCK 248
    public static final int TUNE_REQUEST 246
  • javax.sound.midi.SysexMessage
    Modifier and Type Constant Field Value
    public static final int SPECIAL_SYSTEM_EXCLUSIVE 247
    public static final int SYSTEM_EXCLUSIVE 240
  • javax.sound.sampled.AudioSystem
    Modifier and Type Constant Field Value
    public static final int NOT_SPECIFIED -1
  • javax.sound.sampled.Clip
    Modifier and Type Constant Field Value
    public static final int LOOP_CONTINUOUSLY -1

javax.sql.*

  • javax.sql.rowset.BaseRowSet
    Modifier and Type Constant Field Value
    public static final int ASCII_STREAM_PARAM 2
    public static final int BINARY_STREAM_PARAM 1
    public static final int UNICODE_STREAM_PARAM 0
  • javax.sql.rowset.CachedRowSet
    Modifier and Type Constant Field Value
    public static final boolean COMMIT_ON_ACCEPT_CHANGES true
  • javax.sql.rowset.JoinRowSet
    Modifier and Type Constant Field Value
    public static final int CROSS_JOIN 0
    public static final int FULL_JOIN 4
    public static final int INNER_JOIN 1
    public static final int LEFT_OUTER_JOIN 2
    public static final int RIGHT_OUTER_JOIN 3
  • javax.sql.rowset.WebRowSet
    Modifier and Type Constant Field Value
    public static final String PUBLIC_XML_SCHEMA "--//Oracle Corporation//XSD Schema//EN"
    public static final String SCHEMA_SYSTEM_ID "http://java.sun.com/xml/ns/jdbc/webrowset.xsd"
  • javax.sql.rowset.spi.SyncFactory
    Modifier and Type Constant Field Value
    public static final String ROWSET_SYNC_PROVIDER "rowset.provider.classname"
    public static final String ROWSET_SYNC_PROVIDER_VERSION "rowset.provider.version"
    public static final String ROWSET_SYNC_VENDOR "rowset.provider.vendor"
  • javax.sql.rowset.spi.SyncProvider
    Modifier and Type Constant Field Value
    public static final int DATASOURCE_DB_LOCK 4
    public static final int DATASOURCE_NO_LOCK 1
    public static final int DATASOURCE_ROW_LOCK 2
    public static final int DATASOURCE_TABLE_LOCK 3
    public static final int GRADE_CHECK_ALL_AT_COMMIT 3
    public static final int GRADE_CHECK_MODIFIED_AT_COMMIT 2
    public static final int GRADE_LOCK_WHEN_LOADED 5
    public static final int GRADE_LOCK_WHEN_MODIFIED 4
    public static final int GRADE_NONE 1
    public static final int NONUPDATABLE_VIEW_SYNC 6
    public static final int UPDATABLE_VIEW_SYNC 5
  • javax.sql.rowset.spi.SyncResolver
    Modifier and Type Constant Field Value
    public static final int DELETE_ROW_CONFLICT 1
    public static final int INSERT_ROW_CONFLICT 2
    public static final int NO_ROW_CONFLICT 3
    public static final int UPDATE_ROW_CONFLICT 0

javax.swing.*

  • javax.swing.AbstractButton
    Modifier and Type Constant Field Value
    public static final String BORDER_PAINTED_CHANGED_PROPERTY "borderPainted"
    public static final String CONTENT_AREA_FILLED_CHANGED_PROPERTY "contentAreaFilled"
    public static final String DISABLED_ICON_CHANGED_PROPERTY "disabledIcon"
    public static final String DISABLED_SELECTED_ICON_CHANGED_PROPERTY "disabledSelectedIcon"
    public static final String FOCUS_PAINTED_CHANGED_PROPERTY "focusPainted"
    public static final String HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY "horizontalAlignment"
    public static final String HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY "horizontalTextPosition"
    public static final String ICON_CHANGED_PROPERTY "icon"
    public static final String MARGIN_CHANGED_PROPERTY "margin"
    public static final String MNEMONIC_CHANGED_PROPERTY "mnemonic"
    public static final String MODEL_CHANGED_PROPERTY "model"
    public static final String PRESSED_ICON_CHANGED_PROPERTY "pressedIcon"
    public static final String ROLLOVER_ENABLED_CHANGED_PROPERTY "rolloverEnabled"
    public static final String ROLLOVER_ICON_CHANGED_PROPERTY "rolloverIcon"
    public static final String ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY "rolloverSelectedIcon"
    public static final String SELECTED_ICON_CHANGED_PROPERTY "selectedIcon"
    public static final String TEXT_CHANGED_PROPERTY "text"
    public static final String VERTICAL_ALIGNMENT_CHANGED_PROPERTY "verticalAlignment"
    public static final String VERTICAL_TEXT_POSITION_CHANGED_PROPERTY "verticalTextPosition"
  • javax.swing.Action
    Modifier and Type Constant Field Value
    public static final String ACCELERATOR_KEY "AcceleratorKey"
    public static final String ACTION_COMMAND_KEY "ActionCommandKey"
    public static final String DEFAULT "Default"
    public static final String DISPLAYED_MNEMONIC_INDEX_KEY "SwingDisplayedMnemonicIndexKey"
    public static final String LARGE_ICON_KEY "SwingLargeIconKey"
    public static final String LONG_DESCRIPTION "LongDescription"
    public static final String MNEMONIC_KEY "MnemonicKey"
    public static final String NAME "Name"
    public static final String SELECTED_KEY "SwingSelectedKey"
    public static final String SHORT_DESCRIPTION "ShortDescription"
    public static final String SMALL_ICON "SmallIcon"
  • javax.swing.BoxLayout
    Modifier and Type Constant Field Value
    public static final int LINE_AXIS 2
    public static final int PAGE_AXIS 3
    public static final int X_AXIS 0
    public static final int Y_AXIS 1
  • javax.swing.DebugGraphics
    Modifier and Type Constant Field Value
    public static final int BUFFERED_OPTION 4
    public static final int FLASH_OPTION 2
    public static final int LOG_OPTION 1
    public static final int NONE_OPTION -1
  • javax.swing.DefaultButtonModel
    Modifier and Type Constant Field Value
    public static final int ARMED 1
    public static final int ENABLED 8
    public static final int PRESSED 4
    public static final int ROLLOVER 16
    public static final int SELECTED 2
  • javax.swing.FocusManager
    Modifier and Type Constant Field Value
    public static final String FOCUS_MANAGER_CLASS_PROPERTY "FocusManagerClassName"
  • javax.swing.GroupLayout
    Modifier and Type Constant Field Value
    public static final int DEFAULT_SIZE -1
    public static final int PREFERRED_SIZE -2
  • javax.swing.JCheckBox
    Modifier and Type Constant Field Value
    public static final String BORDER_PAINTED_FLAT_CHANGED_PROPERTY "borderPaintedFlat"
  • javax.swing.JColorChooser
    Modifier and Type Constant Field Value
    public static final String CHOOSER_PANELS_PROPERTY "chooserPanels"
    public static final String PREVIEW_PANEL_PROPERTY "previewPanel"
    public static final String SELECTION_MODEL_PROPERTY "selectionModel"
  • javax.swing.JComponent
    Modifier and Type Constant Field Value
    public static final String TOOL_TIP_TEXT_KEY "ToolTipText"
    public static final int UNDEFINED_CONDITION -1
    public static final int WHEN_ANCESTOR_OF_FOCUSED_COMPONENT 1
    public static final int WHEN_FOCUSED 0
    public static final int WHEN_IN_FOCUSED_WINDOW 2
  • javax.swing.JDesktopPane
    Modifier and Type Constant Field Value
    public static final int LIVE_DRAG_MODE 0
    public static final int OUTLINE_DRAG_MODE 1
  • javax.swing.JEditorPane
    Modifier and Type Constant Field Value
    public static final String HONOR_DISPLAY_PROPERTIES "JEditorPane.honorDisplayProperties"
    public static final String W3C_LENGTH_UNITS "JEditorPane.w3cLengthUnits"
  • javax.swing.JFileChooser
    Modifier and Type Constant Field Value
    public static final String ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY "acceptAllFileFilterUsedChanged"
    public static final String ACCESSORY_CHANGED_PROPERTY "AccessoryChangedProperty"
    public static final String APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY "ApproveButtonMnemonicChangedProperty"
    public static final String APPROVE_BUTTON_TEXT_CHANGED_PROPERTY "ApproveButtonTextChangedProperty"
    public static final String APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY "ApproveButtonToolTipTextChangedProperty"
    public static final int APPROVE_OPTION 0
    public static final String APPROVE_SELECTION "ApproveSelection"
    public static final int CANCEL_OPTION 1
    public static final String CANCEL_SELECTION "CancelSelection"
    public static final String CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY "ChoosableFileFilterChangedProperty"
    public static final String CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY "ControlButtonsAreShownChangedProperty"
    public static final int CUSTOM_DIALOG 2
    public static final String DIALOG_TITLE_CHANGED_PROPERTY "DialogTitleChangedProperty"
    public static final String DIALOG_TYPE_CHANGED_PROPERTY "DialogTypeChangedProperty"
    public static final int DIRECTORIES_ONLY 1
    public static final String DIRECTORY_CHANGED_PROPERTY "directoryChanged"
    public static final int ERROR_OPTION -1
    public static final String FILE_FILTER_CHANGED_PROPERTY "fileFilterChanged"
    public static final String FILE_HIDING_CHANGED_PROPERTY "FileHidingChanged"
    public static final String FILE_SELECTION_MODE_CHANGED_PROPERTY "fileSelectionChanged"
    public static final String FILE_SYSTEM_VIEW_CHANGED_PROPERTY "FileSystemViewChanged"
    public static final String FILE_VIEW_CHANGED_PROPERTY "fileViewChanged"
    public static final int FILES_AND_DIRECTORIES 2
    public static final int FILES_ONLY 0
    public static final String MULTI_SELECTION_ENABLED_CHANGED_PROPERTY "MultiSelectionEnabledChangedProperty"
    public static final int OPEN_DIALOG 0
    public static final int SAVE_DIALOG 1
    public static final String SELECTED_FILE_CHANGED_PROPERTY "SelectedFileChangedProperty"
    public static final String SELECTED_FILES_CHANGED_PROPERTY "SelectedFilesChangedProperty"
  • javax.swing.JFormattedTextField
    Modifier and Type Constant Field Value
    public static final int COMMIT 0
    public static final int COMMIT_OR_REVERT 1
    public static final int PERSIST 3
    public static final int REVERT 2
  • javax.swing.JInternalFrame
    Modifier and Type Constant Field Value
    public static final String CONTENT_PANE_PROPERTY "contentPane"
    public static final String FRAME_ICON_PROPERTY "frameIcon"
    public static final String GLASS_PANE_PROPERTY "glassPane"
    public static final String IS_CLOSED_PROPERTY "closed"
    public static final String IS_ICON_PROPERTY "icon"
    public static final String IS_MAXIMUM_PROPERTY "maximum"
    public static final String IS_SELECTED_PROPERTY "selected"
    public static final String LAYERED_PANE_PROPERTY "layeredPane"
    public static final String MENU_BAR_PROPERTY "JMenuBar"
    public static final String ROOT_PANE_PROPERTY "rootPane"
    public static final String TITLE_PROPERTY "title"
  • javax.swing.JLayeredPane
    Modifier and Type Constant Field Value
    public static final String LAYER_PROPERTY "layeredContainerLayer"
  • javax.swing.JList<E>
    Modifier and Type Constant Field Value
    public static final int HORIZONTAL_WRAP 2
    public static final int VERTICAL 0
    public static final int VERTICAL_WRAP 1
  • javax.swing.JOptionPane
    Modifier and Type Constant Field Value
    public static final int CANCEL_OPTION 2
    public static final int CLOSED_OPTION -1
    public static final int DEFAULT_OPTION -1
    public static final int ERROR_MESSAGE 0
    public static final String ICON_PROPERTY "icon"
    public static final int INFORMATION_MESSAGE 1
    public static final String INITIAL_SELECTION_VALUE_PROPERTY "initialSelectionValue"
    public static final String INITIAL_VALUE_PROPERTY "initialValue"
    public static final String INPUT_VALUE_PROPERTY "inputValue"
    public static final String MESSAGE_PROPERTY "message"
    public static final String MESSAGE_TYPE_PROPERTY "messageType"
    public static final int NO_OPTION 1
    public static final int OK_CANCEL_OPTION 2
    public static final int OK_OPTION 0
    public static final String OPTION_TYPE_PROPERTY "optionType"
    public static final String OPTIONS_PROPERTY "options"
    public static final int PLAIN_MESSAGE -1
    public static final int QUESTION_MESSAGE 3
    public static final String SELECTION_VALUES_PROPERTY "selectionValues"
    public static final String VALUE_PROPERTY "value"
    public static final String WANTS_INPUT_PROPERTY "wantsInput"
    public static final int WARNING_MESSAGE 2
    public static final int YES_NO_CANCEL_OPTION 1
    public static final int YES_NO_OPTION 0
    public static final int YES_OPTION 0
  • javax.swing.JRootPane
    Modifier and Type Constant Field Value
    public static final int COLOR_CHOOSER_DIALOG 5
    public static final int ERROR_DIALOG 4
    public static final int FILE_CHOOSER_DIALOG 6
    public static final int FRAME 1
    public static final int INFORMATION_DIALOG 3
    public static final int NONE 0
    public static final int PLAIN_DIALOG 2
    public static final int QUESTION_DIALOG 7
    public static final int WARNING_DIALOG 8
  • javax.swing.JSplitPane
    Modifier and Type Constant Field Value
    public static final String BOTTOM "bottom"
    public static final String CONTINUOUS_LAYOUT_PROPERTY "continuousLayout"
    public static final String DIVIDER "divider"
    public static final String DIVIDER_LOCATION_PROPERTY "dividerLocation"
    public static final String DIVIDER_SIZE_PROPERTY "dividerSize"
    public static final int HORIZONTAL_SPLIT 1
    public static final String LAST_DIVIDER_LOCATION_PROPERTY "lastDividerLocation"
    public static final String LEFT "left"
    public static final String ONE_TOUCH_EXPANDABLE_PROPERTY "oneTouchExpandable"
    public static final String ORIENTATION_PROPERTY "orientation"
    public static final String RESIZE_WEIGHT_PROPERTY "resizeWeight"
    public static final String RIGHT "right"
    public static final String TOP "top"
    public static final int VERTICAL_SPLIT 0
  • javax.swing.JTabbedPane
    Modifier and Type Constant Field Value
    public static final int SCROLL_TAB_LAYOUT 1
    public static final int WRAP_TAB_LAYOUT 0
  • javax.swing.JTable
    Modifier and Type Constant Field Value
    public static final int AUTO_RESIZE_ALL_COLUMNS 4
    public static final int AUTO_RESIZE_LAST_COLUMN 3
    public static final int AUTO_RESIZE_NEXT_COLUMN 1
    public static final int AUTO_RESIZE_OFF 0
    public static final int AUTO_RESIZE_SUBSEQUENT_COLUMNS 2
  • javax.swing.JTextField
    Modifier and Type Constant Field Value
    public static final String notifyAction "notify-field-accept"
  • javax.swing.JTree
    Modifier and Type Constant Field Value
    public static final String ANCHOR_SELECTION_PATH_PROPERTY "anchorSelectionPath"
    public static final String CELL_EDITOR_PROPERTY "cellEditor"
    public static final String CELL_RENDERER_PROPERTY "cellRenderer"
    public static final String EDITABLE_PROPERTY "editable"
    public static final String EXPANDS_SELECTED_PATHS_PROPERTY "expandsSelectedPaths"
    public static final String INVOKES_STOP_CELL_EDITING_PROPERTY "invokesStopCellEditing"
    public static final String LARGE_MODEL_PROPERTY "largeModel"
    public static final String LEAD_SELECTION_PATH_PROPERTY "leadSelectionPath"
    public static final String ROOT_VISIBLE_PROPERTY "rootVisible"
    public static final String ROW_HEIGHT_PROPERTY "rowHeight"
    public static final String SCROLLS_ON_EXPAND_PROPERTY "scrollsOnExpand"
    public static final String SELECTION_MODEL_PROPERTY "selectionModel"
    public static final String SHOWS_ROOT_HANDLES_PROPERTY "showsRootHandles"
    public static final String TOGGLE_CLICK_COUNT_PROPERTY "toggleClickCount"
    public static final String TREE_MODEL_PROPERTY "model"
    public static final String VISIBLE_ROW_COUNT_PROPERTY "visibleRowCount"
  • javax.swing.JViewport
    Modifier and Type Constant Field Value
    public static final int BACKINGSTORE_SCROLL_MODE 2
    public static final int BLIT_SCROLL_MODE 1
    public static final int SIMPLE_SCROLL_MODE 0
  • javax.swing.ListSelectionModel
    Modifier and Type Constant Field Value
    public static final int MULTIPLE_INTERVAL_SELECTION 2
    public static final int SINGLE_INTERVAL_SELECTION 1
    public static final int SINGLE_SELECTION 0
  • javax.swing.ScrollPaneConstants
    Modifier and Type Constant Field Value
    public static final String COLUMN_HEADER "COLUMN_HEADER"
    public static final String HORIZONTAL_SCROLLBAR "HORIZONTAL_SCROLLBAR"
    public static final int HORIZONTAL_SCROLLBAR_ALWAYS 32
    public static final int HORIZONTAL_SCROLLBAR_AS_NEEDED 30
    public static final int HORIZONTAL_SCROLLBAR_NEVER 31
    public static final String HORIZONTAL_SCROLLBAR_POLICY "HORIZONTAL_SCROLLBAR_POLICY"
    public static final String LOWER_LEADING_CORNER "LOWER_LEADING_CORNER"
    public static final String LOWER_LEFT_CORNER "LOWER_LEFT_CORNER"
    public static final String LOWER_RIGHT_CORNER "LOWER_RIGHT_CORNER"
    public static final String LOWER_TRAILING_CORNER "LOWER_TRAILING_CORNER"
    public static final String ROW_HEADER "ROW_HEADER"
    public static final String UPPER_LEADING_CORNER "UPPER_LEADING_CORNER"
    public static final String UPPER_LEFT_CORNER "UPPER_LEFT_CORNER"
    public static final String UPPER_RIGHT_CORNER "UPPER_RIGHT_CORNER"
    public static final String UPPER_TRAILING_CORNER "UPPER_TRAILING_CORNER"
    public static final String VERTICAL_SCROLLBAR "VERTICAL_SCROLLBAR"
    public static final int VERTICAL_SCROLLBAR_ALWAYS 22
    public static final int VERTICAL_SCROLLBAR_AS_NEEDED 20
    public static final int VERTICAL_SCROLLBAR_NEVER 21
    public static final String VERTICAL_SCROLLBAR_POLICY "VERTICAL_SCROLLBAR_POLICY"
    public static final String VIEWPORT "VIEWPORT"
  • javax.swing.Spring
    Modifier and Type Constant Field Value
    public static final int UNSET -2147483648
  • javax.swing.SpringLayout
    Modifier and Type Constant Field Value
    public static final String BASELINE "Baseline"
    public static final String EAST "East"
    public static final String HEIGHT "Height"
    public static final String HORIZONTAL_CENTER "HorizontalCenter"
    public static final String NORTH "North"
    public static final String SOUTH "South"
    public static final String VERTICAL_CENTER "VerticalCenter"
    public static final String WEST "West"
    public static final String WIDTH "Width"
  • javax.swing.SwingConstants
    Modifier and Type Constant Field Value
    public static final int BOTTOM 3
    public static final int CENTER 0
    public static final int EAST 3
    public static final int HORIZONTAL 0
    public static final int LEADING 10
    public static final int LEFT 2
    public static final int NEXT 12
    public static final int NORTH 1
    public static final int NORTH_EAST 2
    public static final int NORTH_WEST 8
    public static final int PREVIOUS 13
    public static final int RIGHT 4
    public static final int SOUTH 5
    public static final int SOUTH_EAST 4
    public static final int SOUTH_WEST 6
    public static final int TOP 1
    public static final int TRAILING 11
    public static final int VERTICAL 1
    public static final int WEST 7
  • javax.swing.TransferHandler
    Modifier and Type Constant Field Value
    public static final int COPY 1
    public static final int COPY_OR_MOVE 3
    public static final int LINK 1073741824
    public static final int MOVE 2
    public static final int NONE 0
  • javax.swing.WindowConstants
    Modifier and Type Constant Field Value
    public static final int DISPOSE_ON_CLOSE 2
    public static final int DO_NOTHING_ON_CLOSE 0
    public static final int EXIT_ON_CLOSE 3
    public static final int HIDE_ON_CLOSE 1
  • javax.swing.border.BevelBorder
    Modifier and Type Constant Field Value
    public static final int LOWERED 1
    public static final int RAISED 0
  • javax.swing.border.EtchedBorder
    Modifier and Type Constant Field Value
    public static final int LOWERED 1
    public static final int RAISED 0
  • javax.swing.border.TitledBorder
    Modifier and Type Constant Field Value
    public static final int ABOVE_BOTTOM 4
    public static final int ABOVE_TOP 1
    public static final int BELOW_BOTTOM 6
    public static final int BELOW_TOP 3
    public static final int BOTTOM 5
    public static final int CENTER 2
    public static final int DEFAULT_JUSTIFICATION 0
    public static final int DEFAULT_POSITION 0
    protected static final int EDGE_SPACING 2
    public static final int LEADING 4
    public static final int LEFT 1
    public static final int RIGHT 3
    protected static final int TEXT_INSET_H 5
    protected static final int TEXT_SPACING 2
    public static final int TOP 2
    public static final int TRAILING 5
  • javax.swing.colorchooser.AbstractColorChooserPanel
    Modifier and Type Constant Field Value
    public static final String TRANSPARENCY_ENABLED_PROPERTY "TransparencyEnabled"
  • javax.swing.event.AncestorEvent
    Modifier and Type Constant Field Value
    public static final int ANCESTOR_ADDED 1
    public static final int ANCESTOR_MOVED 3
    public static final int ANCESTOR_REMOVED 2
  • javax.swing.event.InternalFrameEvent
    Modifier and Type Constant Field Value
    public static final int INTERNAL_FRAME_ACTIVATED 25554
    public static final int INTERNAL_FRAME_CLOSED 25551
    public static final int INTERNAL_FRAME_CLOSING 25550
    public static final int INTERNAL_FRAME_DEACTIVATED 25555
    public static final int INTERNAL_FRAME_DEICONIFIED 25553
    public static final int INTERNAL_FRAME_FIRST 25549
    public static final int INTERNAL_FRAME_ICONIFIED 25552
    public static final int INTERNAL_FRAME_LAST 25555
    public static final int INTERNAL_FRAME_OPENED 25549
  • javax.swing.event.ListDataEvent
    Modifier and Type Constant Field Value
    public static final int CONTENTS_CHANGED 0
    public static final int INTERVAL_ADDED 1
    public static final int INTERVAL_REMOVED 2
  • javax.swing.event.TableModelEvent
    Modifier and Type Constant Field Value
    public static final int ALL_COLUMNS -1
    public static final int DELETE -1
    public static final int HEADER_ROW -1
    public static final int INSERT 1
    public static final int UPDATE 0
  • javax.swing.plaf.basic.BasicComboPopup
    Modifier and Type Constant Field Value
    protected static final int SCROLL_DOWN 1
    protected static final int SCROLL_UP 0
  • javax.swing.plaf.basic.BasicHTML
    Modifier and Type Constant Field Value
    public static final String documentBaseKey "html.base"
    public static final String propertyKey "html"
  • javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
    Modifier and Type Constant Field Value
    protected final int RESIZE_NONE 0
  • javax.swing.plaf.basic.BasicListUI
    Modifier and Type Constant Field Value
    protected static final int cellRendererChanged 64
    protected static final int fixedCellHeightChanged 16
    protected static final int fixedCellWidthChanged 8
    protected static final int fontChanged 4
    protected static final int modelChanged 1
    protected static final int prototypeCellValueChanged 32
    protected static final int selectionModelChanged 2
  • javax.swing.plaf.basic.BasicOptionPaneUI
    Modifier and Type Constant Field Value
    public static final int MinimumHeight 90
    public static final int MinimumWidth 262
  • javax.swing.plaf.basic.BasicScrollBarUI
    Modifier and Type Constant Field Value
    protected static final int DECREASE_HIGHLIGHT 1
    protected static final int INCREASE_HIGHLIGHT 2
    protected static final int NO_HIGHLIGHT 0
  • javax.swing.plaf.basic.BasicSliderUI
    Modifier and Type Constant Field Value
    public static final int MAX_SCROLL 2
    public static final int MIN_SCROLL -2
    public static final int NEGATIVE_SCROLL -1
    public static final int POSITIVE_SCROLL 1
  • javax.swing.plaf.basic.BasicSplitPaneDivider
    Modifier and Type Constant Field Value
    protected static final int ONE_TOUCH_OFFSET 2
    protected static final int ONE_TOUCH_SIZE 6
  • javax.swing.plaf.basic.BasicSplitPaneUI
    Modifier and Type Constant Field Value
    protected static final String NON_CONTINUOUS_DIVIDER "nonContinuousDivider"
  • javax.swing.plaf.metal.MetalIconFactory
    Modifier and Type Constant Field Value
    public static final boolean DARK false
    public static final boolean LIGHT true
  • javax.swing.plaf.metal.MetalScrollBarUI
    Modifier and Type Constant Field Value
    public static final String FREE_STANDING_PROP "JScrollBar.isFreeStanding"
  • javax.swing.plaf.metal.MetalSliderUI
    Modifier and Type Constant Field Value
    protected final String SLIDER_FILL "JSlider.isFilled"
    protected final int TICK_BUFFER 4
  • javax.swing.plaf.metal.MetalToolTipUI
    Modifier and Type Constant Field Value
    public static final int padSpaceBetweenStrings 12
  • javax.swing.plaf.nimbus.NimbusStyle
    Modifier and Type Constant Field Value
    public static final String LARGE_KEY "large"
    public static final double LARGE_SCALE 1.15
    public static final String MINI_KEY "mini"
    public static final double MINI_SCALE 0.714
    public static final String SMALL_KEY "small"
    public static final double SMALL_SCALE 0.857
  • javax.swing.plaf.synth.SynthConstants
    Modifier and Type Constant Field Value
    public static final int DEFAULT 1024
    public static final int DISABLED 8
    public static final int ENABLED 1
    public static final int FOCUSED 256
    public static final int MOUSE_OVER 2
    public static final int PRESSED 4
    public static final int SELECTED 512
  • javax.swing.table.TableColumn
    Modifier and Type Constant Field Value
    public static final String CELL_RENDERER_PROPERTY "cellRenderer"
    public static final String COLUMN_WIDTH_PROPERTY "columWidth"
    public static final String HEADER_RENDERER_PROPERTY "headerRenderer"
    public static final String HEADER_VALUE_PROPERTY "headerValue"
  • javax.swing.text.AbstractDocument
    Modifier and Type Constant Field Value
    protected static final String BAD_LOCATION "document location failure"
    public static final String BidiElementName "bidi level"
    public static final String ContentElementName "content"
    public static final String ElementNameAttribute "$ename"
    public static final String ParagraphElementName "paragraph"
    public static final String SectionElementName "section"
  • javax.swing.text.AbstractWriter
    Modifier and Type Constant Field Value
    protected static final char NEWLINE 10
  • javax.swing.text.DefaultCaret
    Modifier and Type Constant Field Value
    public static final int ALWAYS_UPDATE 2
    public static final int NEVER_UPDATE 1
    public static final int UPDATE_WHEN_ON_EDT 0
  • javax.swing.text.DefaultEditorKit
    Modifier and Type Constant Field Value
    public static final String backwardAction "caret-backward"
    public static final String beepAction "beep"
    public static final String beginAction "caret-begin"
    public static final String beginLineAction "caret-begin-line"
    public static final String beginParagraphAction "caret-begin-paragraph"
    public static final String beginWordAction "caret-begin-word"
    public static final String copyAction "copy-to-clipboard"
    public static final String cutAction "cut-to-clipboard"
    public static final String defaultKeyTypedAction "default-typed"
    public static final String deleteNextCharAction "delete-next"
    public static final String deleteNextWordAction "delete-next-word"
    public static final String deletePrevCharAction "delete-previous"
    public static final String deletePrevWordAction "delete-previous-word"
    public static final String downAction "caret-down"
    public static final String endAction "caret-end"
    public static final String endLineAction "caret-end-line"
    public static final String EndOfLineStringProperty "__EndOfLine__"
    public static final String endParagraphAction "caret-end-paragraph"
    public static final String endWordAction "caret-end-word"
    public static final String forwardAction "caret-forward"
    public static final String insertBreakAction "insert-break"
    public static final String insertContentAction "insert-content"
    public static final String insertTabAction "insert-tab"
    public static final String nextWordAction "caret-next-word"
    public static final String pageDownAction "page-down"
    public static final String pageUpAction "page-up"
    public static final String pasteAction "paste-from-clipboard"
    public static final String previousWordAction "caret-previous-word"
    public static final String readOnlyAction "set-read-only"
    public static final String selectAllAction "select-all"
    public static final String selectionBackwardAction "selection-backward"
    public static final String selectionBeginAction "selection-begin"
    public static final String selectionBeginLineAction "selection-begin-line"
    public static final String selectionBeginParagraphAction "selection-begin-paragraph"
    public static final String selectionBeginWordAction "selection-begin-word"
    public static final String selectionDownAction "selection-down"
    public static final String selectionEndAction "selection-end"
    public static final String selectionEndLineAction "selection-end-line"
    public static final String selectionEndParagraphAction "selection-end-paragraph"
    public static final String selectionEndWordAction "selection-end-word"
    public static final String selectionForwardAction "selection-forward"
    public static final String selectionNextWordAction "selection-next-word"
    public static final String selectionPreviousWordAction "selection-previous-word"
    public static final String selectionUpAction "selection-up"
    public static final String selectLineAction "select-line"
    public static final String selectParagraphAction "select-paragraph"
    public static final String selectWordAction "select-word"
    public static final String upAction "caret-up"
    public static final String writableAction "set-writable"
  • javax.swing.text.DefaultStyledDocument
    Modifier and Type Constant Field Value
    public static final int BUFFER_SIZE_DEFAULT 4096
  • javax.swing.text.DefaultStyledDocument.ElementSpec
    Modifier and Type Constant Field Value
    public static final short ContentType 3
    public static final short EndTagType 2
    public static final short JoinFractureDirection 7
    public static final short JoinNextDirection 5
    public static final short JoinPreviousDirection 4
    public static final short OriginateDirection 6
    public static final short StartTagType 1
  • javax.swing.text.Document
    Modifier and Type Constant Field Value
    public static final String StreamDescriptionProperty "stream"
    public static final String TitleProperty "title"
  • javax.swing.text.JTextComponent
    Modifier and Type Constant Field Value
    public static final String DEFAULT_KEYMAP "default"
    public static final String FOCUS_ACCELERATOR_KEY "focusAcceleratorKey"
  • javax.swing.text.PlainDocument
    Modifier and Type Constant Field Value
    public static final String lineLimitAttribute "lineLimit"
    public static final String tabSizeAttribute "tabSize"
  • javax.swing.text.StyleConstants
    Modifier and Type Constant Field Value
    public static final int ALIGN_CENTER 1
    public static final int ALIGN_JUSTIFIED 3
    public static final int ALIGN_LEFT 0
    public static final int ALIGN_RIGHT 2
    public static final String ComponentElementName "component"
    public static final String IconElementName "icon"
  • javax.swing.text.StyleContext
    Modifier and Type Constant Field Value
    public static final String DEFAULT_STYLE "default"
  • javax.swing.text.TabStop
    Modifier and Type Constant Field Value
    public static final int ALIGN_BAR 5
    public static final int ALIGN_CENTER 2
    public static final int ALIGN_DECIMAL 4
    public static final int ALIGN_LEFT 0
    public static final int ALIGN_RIGHT 1
    public static final int LEAD_DOTS 1
    public static final int LEAD_EQUALS 5
    public static final int LEAD_HYPHENS 2
    public static final int LEAD_NONE 0
    public static final int LEAD_THICKLINE 4
    public static final int LEAD_UNDERLINE 3
  • javax.swing.text.View
    Modifier and Type Constant Field Value
    public static final int BadBreakWeight 0
    public static final int ExcellentBreakWeight 2000
    public static final int ForcedBreakWeight 3000
    public static final int GoodBreakWeight 1000
    public static final int X_AXIS 0
    public static final int Y_AXIS 1
  • javax.swing.text.html.HTML
    Modifier and Type Constant Field Value
    public static final String NULL_ATTRIBUTE_VALUE "#DEFAULT"
  • javax.swing.text.html.HTMLDocument
    Modifier and Type Constant Field Value
    public static final String AdditionalComments "AdditionalComments"
  • javax.swing.text.html.HTMLEditorKit
    Modifier and Type Constant Field Value
    public static final String BOLD_ACTION "html-bold-action"
    public static final String COLOR_ACTION "html-color-action"
    public static final String DEFAULT_CSS "default.css"
    public static final String FONT_CHANGE_BIGGER "html-font-bigger"
    public static final String FONT_CHANGE_SMALLER "html-font-smaller"
    public static final String IMG_ALIGN_BOTTOM "html-image-align-bottom"
    public static final String IMG_ALIGN_MIDDLE "html-image-align-middle"
    public static final String IMG_ALIGN_TOP "html-image-align-top"
    public static final String IMG_BORDER "html-image-border"
    public static final String ITALIC_ACTION "html-italic-action"
    public static final String LOGICAL_STYLE_ACTION "html-logical-style-action"
    public static final String PARA_INDENT_LEFT "html-para-indent-left"
    public static final String PARA_INDENT_RIGHT "html-para-indent-right"
  • javax.swing.text.html.parser.DTD
    Modifier and Type Constant Field Value
    public static final int FILE_VERSION 1
  • javax.swing.text.html.parser.DTDConstants
    Modifier and Type Constant Field Value
    public static final int ANY 19
    public static final int CDATA 1
    public static final int CONREF 4
    public static final int CURRENT 3
    public static final int DEFAULT 131072
    public static final int EMPTY 17
    public static final int ENDTAG 14
    public static final int ENTITIES 3
    public static final int ENTITY 2
    public static final int FIXED 1
    public static final int GENERAL 65536
    public static final int ID 4
    public static final int IDREF 5
    public static final int IDREFS 6
    public static final int IMPLIED 5
    public static final int MD 16
    public static final int MODEL 18
    public static final int MS 15
    public static final int NAME 7
    public static final int NAMES 8
    public static final int NMTOKEN 9
    public static final int NMTOKENS 10
    public static final int NOTATION 11
    public static final int NUMBER 12
    public static final int NUMBERS 13
    public static final int NUTOKEN 14
    public static final int NUTOKENS 15
    public static final int PARAMETER 262144
    public static final int PI 12
    public static final int PUBLIC 10
    public static final int RCDATA 16
    public static final int REQUIRED 2
    public static final int SDATA 11
    public static final int STARTTAG 13
    public static final int SYSTEM 17
  • javax.swing.tree.DefaultTreeSelectionModel
    Modifier and Type Constant Field Value
    public static final String SELECTION_MODE_PROPERTY "selectionMode"
  • javax.swing.tree.TreeSelectionModel
    Modifier and Type Constant Field Value
    public static final int CONTIGUOUS_TREE_SELECTION 2
    public static final int DISCONTIGUOUS_TREE_SELECTION 4
    public static final int SINGLE_TREE_SELECTION 1
  • javax.swing.undo.AbstractUndoableEdit
    Modifier and Type Constant Field Value
    protected static final String RedoName "Redo"
    protected static final String UndoName "Undo"
  • javax.swing.undo.StateEdit
    Modifier and Type Constant Field Value
    protected static final String RCSID "$Id: StateEdit.java,v 1.6 1997/10/01 20:05:51 sandipc Exp $"
  • javax.swing.undo.StateEditable
    Modifier and Type Constant Field Value
    public static final String RCSID "$Id: StateEditable.java,v 1.2 1997/09/08 19:39:08 marklin Exp $"

javax.tools.*

  • javax.tools.Diagnostic<S>
    Modifier and Type Constant Field Value
    public static final long NOPOS -1L

javax.transaction.*

  • javax.transaction.xa.XAException
    Modifier and Type Constant Field Value
    public static final int XA_HEURCOM 7
    public static final int XA_HEURHAZ 8
    public static final int XA_HEURMIX 5
    public static final int XA_HEURRB 6
    public static final int XA_NOMIGRATE 9
    public static final int XA_RBBASE 100
    public static final int XA_RBCOMMFAIL 101
    public static final int XA_RBDEADLOCK 102
    public static final int XA_RBEND 107
    public static final int XA_RBINTEGRITY 103
    public static final int XA_RBOTHER 104
    public static final int XA_RBPROTO 105
    public static final int XA_RBROLLBACK 100
    public static final int XA_RBTIMEOUT 106
    public static final int XA_RBTRANSIENT 107
    public static final int XA_RDONLY 3
    public static final int XA_RETRY 4
    public static final int XAER_ASYNC -2
    public static final int XAER_DUPID -8
    public static final int XAER_INVAL -5
    public static final int XAER_NOTA -4
    public static final int XAER_OUTSIDE -9
    public static final int XAER_PROTO -6
    public static final int XAER_RMERR -3
    public static final int XAER_RMFAIL -7
  • javax.transaction.xa.XAResource
    Modifier and Type Constant Field Value
    public static final int TMENDRSCAN 8388608
    public static final int TMFAIL 536870912
    public static final int TMJOIN 2097152
    public static final int TMNOFLAGS 0
    public static final int TMONEPHASE 1073741824
    public static final int TMRESUME 134217728
    public static final int TMSTARTRSCAN 16777216
    public static final int TMSUCCESS 67108864
    public static final int TMSUSPEND 33554432
    public static final int XA_OK 0
    public static final int XA_RDONLY 3
  • javax.transaction.xa.Xid
    Modifier and Type Constant Field Value
    public static final int MAXBQUALSIZE 64
    public static final int MAXGTRIDSIZE 64

javax.xml.*

  • javax.xml.XMLConstants
    Modifier and Type Constant Field Value
    public static final String ACCESS_EXTERNAL_DTD "http://javax.xml.XMLConstants/property/accessExternalDTD"
    public static final String ACCESS_EXTERNAL_SCHEMA "http://javax.xml.XMLConstants/property/accessExternalSchema"
    public static final String ACCESS_EXTERNAL_STYLESHEET "http://javax.xml.XMLConstants/property/accessExternalStylesheet"
    public static final String DEFAULT_NS_PREFIX ""
    public static final String FEATURE_SECURE_PROCESSING "http://javax.xml.XMLConstants/feature/secure-processing"
    public static final String NULL_NS_URI ""
    public static final String RELAXNG_NS_URI "http://relaxng.org/ns/structure/1.0"
    public static final String USE_CATALOG "http://javax.xml.XMLConstants/feature/useCatalog"
    public static final String W3C_XML_SCHEMA_INSTANCE_NS_URI "http://www.w3.org/2001/XMLSchema-instance"
    public static final String W3C_XML_SCHEMA_NS_URI "http://www.w3.org/2001/XMLSchema"
    public static final String W3C_XPATH_DATATYPE_NS_URI "http://www.w3.org/2003/11/xpath-datatypes"
    public static final String XML_DTD_NS_URI "http://www.w3.org/TR/REC-xml"
    public static final String XML_NS_PREFIX "xml"
    public static final String XML_NS_URI "http://www.w3.org/XML/1998/namespace"
    public static final String XMLNS_ATTRIBUTE "xmlns"
    public static final String XMLNS_ATTRIBUTE_NS_URI "http://www.w3.org/2000/xmlns/"
  • javax.xml.bind.JAXBContext
    Modifier and Type Constant Field Value
    public static final String JAXB_CONTEXT_FACTORY "javax.xml.bind.JAXBContextFactory"
  • javax.xml.bind.Marshaller
    Modifier and Type Constant Field Value
    public static final String JAXB_ENCODING "jaxb.encoding"
    public static final String JAXB_FORMATTED_OUTPUT "jaxb.formatted.output"
    public static final String JAXB_FRAGMENT "jaxb.fragment"
    public static final String JAXB_NO_NAMESPACE_SCHEMA_LOCATION "jaxb.noNamespaceSchemaLocation"
    public static final String JAXB_SCHEMA_LOCATION "jaxb.schemaLocation"
  • javax.xml.bind.ValidationEvent
    Modifier and Type Constant Field Value
    public static final int ERROR 1
    public static final int FATAL_ERROR 2
    public static final int WARNING 0
  • javax.xml.bind.annotation.XmlSchema
    Modifier and Type Constant Field Value
    public static final String NO_LOCATION "##generate"
  • javax.xml.crypto.dsig.CanonicalizationMethod
    Modifier and Type Constant Field Value
    public static final String EXCLUSIVE "http://www.w3.org/2001/10/xml-exc-c14n#"
    public static final String EXCLUSIVE_WITH_COMMENTS "http://www.w3.org/2001/10/xml-exc-c14n#WithComments"
    public static final String INCLUSIVE "http://www.w3.org/TR/2001/REC-xml-c14n-20010315"
    public static final String INCLUSIVE_WITH_COMMENTS "http://www.w3.org/TR/2001/REC-xml-c14n-20010315#WithComments"
  • javax.xml.crypto.dsig.DigestMethod
    Modifier and Type Constant Field Value
    public static final String RIPEMD160 "http://www.w3.org/2001/04/xmlenc#ripemd160"
    public static final String SHA1 "http://www.w3.org/2000/09/xmldsig#sha1"
    public static final String SHA256 "http://www.w3.org/2001/04/xmlenc#sha256"
    public static final String SHA512 "http://www.w3.org/2001/04/xmlenc#sha512"
  • javax.xml.crypto.dsig.Manifest
    Modifier and Type Constant Field Value
    public static final String TYPE "http://www.w3.org/2000/09/xmldsig#Manifest"
  • javax.xml.crypto.dsig.SignatureMethod
    Modifier and Type Constant Field Value
    public static final String DSA_SHA1 "http://www.w3.org/2000/09/xmldsig#dsa-sha1"
    public static final String HMAC_SHA1 "http://www.w3.org/2000/09/xmldsig#hmac-sha1"
    public static final String RSA_SHA1 "http://www.w3.org/2000/09/xmldsig#rsa-sha1"
  • javax.xml.crypto.dsig.SignatureProperties
    Modifier and Type Constant Field Value
    public static final String TYPE "http://www.w3.org/2000/09/xmldsig#SignatureProperties"
  • javax.xml.crypto.dsig.Transform
    Modifier and Type Constant Field Value
    public static final String BASE64 "http://www.w3.org/2000/09/xmldsig#base64"
    public static final String ENVELOPED "http://www.w3.org/2000/09/xmldsig#enveloped-signature"
    public static final String XPATH "http://www.w3.org/TR/1999/REC-xpath-19991116"
    public static final String XPATH2 "http://www.w3.org/2002/06/xmldsig-filter2"
    public static final String XSLT "http://www.w3.org/TR/1999/REC-xslt-19991116"
  • javax.xml.crypto.dsig.XMLObject
    Modifier and Type Constant Field Value
    public static final String TYPE "http://www.w3.org/2000/09/xmldsig#Object"
  • javax.xml.crypto.dsig.XMLSignature
    Modifier and Type Constant Field Value
    public static final String XMLNS "http://www.w3.org/2000/09/xmldsig#"
  • javax.xml.crypto.dsig.keyinfo.KeyValue
    Modifier and Type Constant Field Value
    public static final String DSA_TYPE "http://www.w3.org/2000/09/xmldsig#DSAKeyValue"
    public static final String RSA_TYPE "http://www.w3.org/2000/09/xmldsig#RSAKeyValue"
  • javax.xml.crypto.dsig.keyinfo.PGPData
    Modifier and Type Constant Field Value
    public static final String TYPE "http://www.w3.org/2000/09/xmldsig#PGPData"
  • javax.xml.crypto.dsig.keyinfo.X509Data
    Modifier and Type Constant Field Value
    public static final String RAW_X509_CERTIFICATE_TYPE "http://www.w3.org/2000/09/xmldsig#rawX509Certificate"
    public static final String TYPE "http://www.w3.org/2000/09/xmldsig#X509Data"
  • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
    Modifier and Type Constant Field Value
    public static final String DEFAULT "#default"
  • javax.xml.datatype.DatatypeConstants
    Modifier and Type Constant Field Value
    public static final int APRIL 4
    public static final int AUGUST 8
    public static final int DECEMBER 12
    public static final int EQUAL 0
    public static final int FEBRUARY 2
    public static final int FIELD_UNDEFINED -2147483648
    public static final int GREATER 1
    public static final int INDETERMINATE 2
    public static final int JANUARY 1
    public static final int JULY 7
    public static final int JUNE 6
    public static final int LESSER -1
    public static final int MARCH 3
    public static final int MAX_TIMEZONE_OFFSET -840
    public static final int MAY 5
    public static final int MIN_TIMEZONE_OFFSET 840
    public static final int NOVEMBER 11
    public static final int OCTOBER 10
    public static final int SEPTEMBER 9
  • javax.xml.datatype.DatatypeFactory
    Modifier and Type Constant Field Value
    public static final String DATATYPEFACTORY_PROPERTY "javax.xml.datatype.DatatypeFactory"
  • javax.xml.soap.SOAPConstants
    Modifier and Type Constant Field Value
    public static final String DEFAULT_SOAP_PROTOCOL "SOAP 1.1 Protocol"
    public static final String DYNAMIC_SOAP_PROTOCOL "Dynamic Protocol"
    public static final String SOAP_1_1_CONTENT_TYPE "text/xml"
    public static final String SOAP_1_1_PROTOCOL "SOAP 1.1 Protocol"
    public static final String SOAP_1_2_CONTENT_TYPE "application/soap+xml"
    public static final String SOAP_1_2_PROTOCOL "SOAP 1.2 Protocol"
    public static final String SOAP_ENV_PREFIX "env"
    public static final String URI_NS_SOAP_1_1_ENVELOPE "http://schemas.xmlsoap.org/soap/envelope/"
    public static final String URI_NS_SOAP_1_2_ENCODING "http://www.w3.org/2003/05/soap-encoding"
    public static final String URI_NS_SOAP_1_2_ENVELOPE "http://www.w3.org/2003/05/soap-envelope"
    public static final String URI_NS_SOAP_ENCODING "http://schemas.xmlsoap.org/soap/encoding/"
    public static final String URI_NS_SOAP_ENVELOPE "http://schemas.xmlsoap.org/soap/envelope/"
    public static final String URI_SOAP_1_2_ROLE_NEXT "http://www.w3.org/2003/05/soap-envelope/role/next"
    public static final String URI_SOAP_1_2_ROLE_NONE "http://www.w3.org/2003/05/soap-envelope/role/none"
    public static final String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER "http://www.w3.org/2003/05/soap-envelope/role/ultimateReceiver"
    public static final String URI_SOAP_ACTOR_NEXT "http://schemas.xmlsoap.org/soap/actor/next"
  • javax.xml.soap.SOAPMessage
    Modifier and Type Constant Field Value
    public static final String CHARACTER_SET_ENCODING "javax.xml.soap.character-set-encoding"
    public static final String WRITE_XML_DECLARATION "javax.xml.soap.write-xml-declaration"
  • javax.xml.stream.XMLInputFactory
    Modifier and Type Constant Field Value
    public static final String ALLOCATOR "javax.xml.stream.allocator"
    public static final String IS_COALESCING "javax.xml.stream.isCoalescing"
    public static final String IS_NAMESPACE_AWARE "javax.xml.stream.isNamespaceAware"
    public static final String IS_REPLACING_ENTITY_REFERENCES "javax.xml.stream.isReplacingEntityReferences"
    public static final String IS_SUPPORTING_EXTERNAL_ENTITIES "javax.xml.stream.isSupportingExternalEntities"
    public static final String IS_VALIDATING "javax.xml.stream.isValidating"
    public static final String REPORTER "javax.xml.stream.reporter"
    public static final String RESOLVER "javax.xml.stream.resolver"
    public static final String SUPPORT_DTD "javax.xml.stream.supportDTD"
  • javax.xml.stream.XMLOutputFactory
    Modifier and Type Constant Field Value
    public static final String IS_REPAIRING_NAMESPACES "javax.xml.stream.isRepairingNamespaces"
  • javax.xml.stream.XMLStreamConstants
    Modifier and Type Constant Field Value
    public static final int ATTRIBUTE 10
    public static final int CDATA 12
    public static final int CHARACTERS 4
    public static final int COMMENT 5
    public static final int DTD 11
    public static final int END_DOCUMENT 8
    public static final int END_ELEMENT 2
    public static final int ENTITY_DECLARATION 15
    public static final int ENTITY_REFERENCE 9
    public static final int NAMESPACE 13
    public static final int NOTATION_DECLARATION 14
    public static final int PROCESSING_INSTRUCTION 3
    public static final int SPACE 6
    public static final int START_DOCUMENT 7
    public static final int START_ELEMENT 1
  • javax.xml.transform.OutputKeys
    Modifier and Type Constant Field Value
    public static final String CDATA_SECTION_ELEMENTS "cdata-section-elements"
    public static final String DOCTYPE_PUBLIC "doctype-public"
    public static final String DOCTYPE_SYSTEM "doctype-system"
    public static final String ENCODING "encoding"
    public static final String INDENT "indent"
    public static final String MEDIA_TYPE "media-type"
    public static final String METHOD "method"
    public static final String OMIT_XML_DECLARATION "omit-xml-declaration"
    public static final String STANDALONE "standalone"
    public static final String VERSION "version"
  • javax.xml.transform.Result
    Modifier and Type Constant Field Value
    public static final String PI_DISABLE_OUTPUT_ESCAPING "javax.xml.transform.disable-output-escaping"
    public static final String PI_ENABLE_OUTPUT_ESCAPING "javax.xml.transform.enable-output-escaping"
  • javax.xml.transform.dom.DOMResult
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.dom.DOMResult/feature"
  • javax.xml.transform.dom.DOMSource
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.dom.DOMSource/feature"
  • javax.xml.transform.sax.SAXResult
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.sax.SAXResult/feature"
  • javax.xml.transform.sax.SAXSource
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.sax.SAXSource/feature"
  • javax.xml.transform.sax.SAXTransformerFactory
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.sax.SAXTransformerFactory/feature"
    public static final String FEATURE_XMLFILTER "http://javax.xml.transform.sax.SAXTransformerFactory/feature/xmlfilter"
  • javax.xml.transform.stax.StAXResult
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.stax.StAXResult/feature"
  • javax.xml.transform.stax.StAXSource
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.stax.StAXSource/feature"
  • javax.xml.transform.stream.StreamResult
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.stream.StreamResult/feature"
  • javax.xml.transform.stream.StreamSource
    Modifier and Type Constant Field Value
    public static final String FEATURE "http://javax.xml.transform.stream.StreamSource/feature"
  • javax.xml.ws.BindingProvider
    Modifier and Type Constant Field Value
    public static final String ENDPOINT_ADDRESS_PROPERTY "javax.xml.ws.service.endpoint.address"
    public static final String PASSWORD_PROPERTY "javax.xml.ws.security.auth.password"
    public static final String SESSION_MAINTAIN_PROPERTY "javax.xml.ws.session.maintain"
    public static final String SOAPACTION_URI_PROPERTY "javax.xml.ws.soap.http.soapaction.uri"
    public static final String SOAPACTION_USE_PROPERTY "javax.xml.ws.soap.http.soapaction.use"
    public static final String USERNAME_PROPERTY "javax.xml.ws.security.auth.username"
  • javax.xml.ws.Endpoint
    Modifier and Type Constant Field Value
    public static final String WSDL_PORT "javax.xml.ws.wsdl.port"
    public static final String WSDL_SERVICE "javax.xml.ws.wsdl.service"
  • javax.xml.ws.RespectBindingFeature
    Modifier and Type Constant Field Value
    public static final String ID "javax.xml.ws.RespectBindingFeature"
  • javax.xml.ws.handler.MessageContext
    Modifier and Type Constant Field Value
    public static final String HTTP_REQUEST_HEADERS "javax.xml.ws.http.request.headers"
    public static final String HTTP_REQUEST_METHOD "javax.xml.ws.http.request.method"
    public static final String HTTP_RESPONSE_CODE "javax.xml.ws.http.response.code"
    public static final String HTTP_RESPONSE_HEADERS "javax.xml.ws.http.response.headers"
    public static final String INBOUND_MESSAGE_ATTACHMENTS "javax.xml.ws.binding.attachments.inbound"
    public static final String MESSAGE_OUTBOUND_PROPERTY "javax.xml.ws.handler.message.outbound"
    public static final String OUTBOUND_MESSAGE_ATTACHMENTS "javax.xml.ws.binding.attachments.outbound"
    public static final String PATH_INFO "javax.xml.ws.http.request.pathinfo"
    public static final String QUERY_STRING "javax.xml.ws.http.request.querystring"
    public static final String REFERENCE_PARAMETERS "javax.xml.ws.reference.parameters"
    public static final String SERVLET_CONTEXT "javax.xml.ws.servlet.context"
    public static final String SERVLET_REQUEST "javax.xml.ws.servlet.request"
    public static final String SERVLET_RESPONSE "javax.xml.ws.servlet.response"
    public static final String WSDL_DESCRIPTION "javax.xml.ws.wsdl.description"
    public static final String WSDL_INTERFACE "javax.xml.ws.wsdl.interface"
    public static final String WSDL_OPERATION "javax.xml.ws.wsdl.operation"
    public static final String WSDL_PORT "javax.xml.ws.wsdl.port"
    public static final String WSDL_SERVICE "javax.xml.ws.wsdl.service"
  • javax.xml.ws.http.HTTPBinding
    Modifier and Type Constant Field Value
    public static final String HTTP_BINDING "http://www.w3.org/2004/08/wsdl/http"
  • javax.xml.ws.soap.AddressingFeature
    Modifier and Type Constant Field Value
    public static final String ID "http://www.w3.org/2005/08/addressing/module"
  • javax.xml.ws.soap.MTOMFeature
    Modifier and Type Constant Field Value
    public static final String ID "http://www.w3.org/2004/08/soap/features/http-optimization"
  • javax.xml.ws.soap.SOAPBinding
    Modifier and Type Constant Field Value
    public static final String SOAP11HTTP_BINDING "http://schemas.xmlsoap.org/wsdl/soap/http"
    public static final String SOAP11HTTP_MTOM_BINDING "http://schemas.xmlsoap.org/wsdl/soap/http?mtom=true"
    public static final String SOAP12HTTP_BINDING "http://www.w3.org/2003/05/soap/bindings/HTTP/"
    public static final String SOAP12HTTP_MTOM_BINDING "http://www.w3.org/2003/05/soap/bindings/HTTP/?mtom=true"
  • javax.xml.ws.spi.http.HttpExchange
    Modifier and Type Constant Field Value
    public static final String REQUEST_CIPHER_SUITE "javax.xml.ws.spi.http.request.cipher.suite"
    public static final String REQUEST_KEY_SIZE "javax.xml.ws.spi.http.request.key.size"
    public static final String REQUEST_X509CERTIFICATE "javax.xml.ws.spi.http.request.cert.X509Certificate"
  • javax.xml.ws.wsaddressing.W3CEndpointReference
    Modifier and Type Constant Field Value
    protected static final String NS "http://www.w3.org/2005/08/addressing"
  • javax.xml.xpath.XPathConstants
    Modifier and Type Constant Field Value
    public static final String DOM_OBJECT_MODEL "http://java.sun.com/jaxp/xpath/dom"
  • javax.xml.xpath.XPathFactory
    Modifier and Type Constant Field Value
    public static final String DEFAULT_OBJECT_MODEL_URI "http://java.sun.com/jaxp/xpath/dom"
    public static final String DEFAULT_PROPERTY_NAME "javax.xml.xpath.XPathFactory"

jdk.dynalink.*

  • jdk.dynalink.SecureLookupSupplier
    Modifier and Type Constant Field Value
    public static final String GET_LOOKUP_PERMISSION_NAME "dynalink.getLookup"
  • jdk.dynalink.linker.GuardingDynamicLinkerExporter
    Modifier and Type Constant Field Value
    public static final String AUTOLOAD_PERMISSION_NAME "dynalink.exportLinkersAutomatically"

jdk.incubator.*

  • jdk.incubator.http.WebSocket
    Modifier and Type Constant Field Value
    public static final int NORMAL_CLOSURE 1000

jdk.jshell.*

  • jdk.jshell.Diag
    Modifier and Type Constant Field Value
    public static final long NOPOS -1L
  • jdk.jshell.execution.JdiExecutionControlProvider
    Modifier and Type Constant Field Value
    public static final String PARAM_HOST_NAME "hostname"
    public static final String PARAM_LAUNCH "launch"
    public static final String PARAM_REMOTE_AGENT "remoteAgent"
    public static final String PARAM_TIMEOUT "timeout"

jdk.nashorn.*

  • jdk.nashorn.api.scripting.NashornScriptEngine
    Modifier and Type Constant Field Value
    public static final String NASHORN_GLOBAL "nashorn.global"
  • jdk.nashorn.api.tree.Diagnostic
    Modifier and Type Constant Field Value
    public static final long NOPOS -1L

jdk.net.*

  • jdk.net.SocketFlow
    Modifier and Type Constant Field Value
    public static final int HIGH_PRIORITY 2
    public static final int NORMAL_PRIORITY 1
    public static final int UNSET -1

org.ietf.*

  • org.ietf.jgss.GSSContext
    Modifier and Type Constant Field Value
    public static final int DEFAULT_LIFETIME 0
    public static final int INDEFINITE_LIFETIME 2147483647
  • org.ietf.jgss.GSSCredential
    Modifier and Type Constant Field Value
    public static final int ACCEPT_ONLY 2
    public static final int DEFAULT_LIFETIME 0
    public static final int INDEFINITE_LIFETIME 2147483647
    public static final int INITIATE_AND_ACCEPT 0
    public static final int INITIATE_ONLY 1
  • org.ietf.jgss.GSSException
    Modifier and Type Constant Field Value
    public static final int BAD_BINDINGS 1
    public static final int BAD_MECH 2
    public static final int BAD_MIC 6
    public static final int BAD_NAME 3
    public static final int BAD_NAMETYPE 4
    public static final int BAD_QOP 14
    public static final int BAD_STATUS 5
    public static final int CONTEXT_EXPIRED 7
    public static final int CREDENTIALS_EXPIRED 8
    public static final int DEFECTIVE_CREDENTIAL 9
    public static final int DEFECTIVE_TOKEN 10
    public static final int DUPLICATE_ELEMENT 17
    public static final int DUPLICATE_TOKEN 19
    public static final int FAILURE 11
    public static final int GAP_TOKEN 22
    public static final int NAME_NOT_MN 18
    public static final int NO_CONTEXT 12
    public static final int NO_CRED 13
    public static final int OLD_TOKEN 20
    public static final int UNAUTHORIZED 15
    public static final int UNAVAILABLE 16
    public static final int UNSEQ_TOKEN 21

org.omg.*

  • org.omg.CORBA.ARG_IN
    Modifier and Type Constant Field Value
    public static final int value 1
  • org.omg.CORBA.ARG_INOUT
    Modifier and Type Constant Field Value
    public static final int value 3
  • org.omg.CORBA.ARG_OUT
    Modifier and Type Constant Field Value
    public static final int value 2
  • org.omg.CORBA.BAD_POLICY
    Modifier and Type Constant Field Value
    public static final short value 0
  • org.omg.CORBA.BAD_POLICY_TYPE
    Modifier and Type Constant Field Value
    public static final short value 2
  • org.omg.CORBA.BAD_POLICY_VALUE
    Modifier and Type Constant Field Value
    public static final short value 3
  • org.omg.CORBA.CompletionStatus
    Modifier and Type Constant Field Value
    public static final int _COMPLETED_MAYBE 2
    public static final int _COMPLETED_NO 1
    public static final int _COMPLETED_YES 0
  • org.omg.CORBA.CTX_RESTRICT_SCOPE
    Modifier and Type Constant Field Value
    public static final int value 15
  • org.omg.CORBA.DefinitionKind
    Modifier and Type Constant Field Value
    public static final int _dk_AbstractInterface 24
    public static final int _dk_Alias 9
    public static final int _dk_all 1
    public static final int _dk_Array 16
    public static final int _dk_Attribute 2
    public static final int _dk_Constant 3
    public static final int _dk_Enum 12
    public static final int _dk_Exception 4
    public static final int _dk_Fixed 19
    public static final int _dk_Interface 5
    public static final int _dk_Module 6
    public static final int _dk_Native 23
    public static final int _dk_none 0
    public static final int _dk_Operation 7
    public static final int _dk_Primitive 13
    public static final int _dk_Repository 17
    public static final int _dk_Sequence 15
    public static final int _dk_String 14
    public static final int _dk_Struct 10
    public static final int _dk_Typedef 8
    public static final int _dk_Union 11
    public static final int _dk_Value 20
    public static final int _dk_ValueBox 21
    public static final int _dk_ValueMember 22
    public static final int _dk_Wstring 18
  • org.omg.CORBA.OMGVMCID
    Modifier and Type Constant Field Value
    public static final int value 1330446336
  • org.omg.CORBA.ParameterMode
    Modifier and Type Constant Field Value
    public static final int _PARAM_IN 0
    public static final int _PARAM_INOUT 2
    public static final int _PARAM_OUT 1
  • org.omg.CORBA.PRIVATE_MEMBER
    Modifier and Type Constant Field Value
    public static final short value 0
  • org.omg.CORBA.PUBLIC_MEMBER
    Modifier and Type Constant Field Value
    public static final short value 1
  • org.omg.CORBA.SetOverrideType
    Modifier and Type Constant Field Value
    public static final int _ADD_OVERRIDE 1
    public static final int _SET_OVERRIDE 0
  • org.omg.CORBA.TCKind
    Modifier and Type Constant Field Value
    public static final int _tk_abstract_interface 32
    public static final int _tk_alias 21
    public static final int _tk_any 11
    public static final int _tk_array 20
    public static final int _tk_boolean 8
    public static final int _tk_char 9
    public static final int _tk_double 7
    public static final int _tk_enum 17
    public static final int _tk_except 22
    public static final int _tk_fixed 28
    public static final int _tk_float 6
    public static final int _tk_long 3
    public static final int _tk_longdouble 25
    public static final int _tk_longlong 23
    public static final int _tk_native 31
    public static final int _tk_null 0
    public static final int _tk_objref 14
    public static final int _tk_octet 10
    public static final int _tk_Principal 13
    public static final int _tk_sequence 19
    public static final int _tk_short 2
    public static final int _tk_string 18
    public static final int _tk_struct 15
    public static final int _tk_TypeCode 12
    public static final int _tk_ulong 5
    public static final int _tk_ulonglong 24
    public static final int _tk_union 16
    public static final int _tk_ushort 4
    public static final int _tk_value 29
    public static final int _tk_value_box 30
    public static final int _tk_void 1
    public static final int _tk_wchar 26
    public static final int _tk_wstring 27
  • org.omg.CORBA.UNSUPPORTED_POLICY
    Modifier and Type Constant Field Value
    public static final short value 1
  • org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
    Modifier and Type Constant Field Value
    public static final short value 4
  • org.omg.CORBA.VM_ABSTRACT
    Modifier and Type Constant Field Value
    public static final short value 2
  • org.omg.CORBA.VM_CUSTOM
    Modifier and Type Constant Field Value
    public static final short value 1
  • org.omg.CORBA.VM_NONE
    Modifier and Type Constant Field Value
    public static final short value 0
  • org.omg.CORBA.VM_TRUNCATABLE
    Modifier and Type Constant Field Value
    public static final short value 3
  • org.omg.CosNaming.BindingType
    Modifier and Type Constant Field Value
    public static final int _ncontext 1
    public static final int _nobject 0
  • org.omg.CosNaming.NamingContextPackage.NotFoundReason
    Modifier and Type Constant Field Value
    public static final int _missing_node 0
    public static final int _not_context 1
    public static final int _not_object 2
  • org.omg.IOP.CodeSets
    Modifier and Type Constant Field Value
    public static final int value 1
  • org.omg.IOP.ENCODING_CDR_ENCAPS
    Modifier and Type Constant Field Value
    public static final short value 0
  • org.omg.IOP.ExceptionDetailMessage
    Modifier and Type Constant Field Value
    public static final int value 14
  • org.omg.IOP.RMICustomMaxStreamFormat
    Modifier and Type Constant Field Value
    public static final int value 17
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
    Modifier and Type Constant Field Value
    public static final int value 3
  • org.omg.IOP.TAG_CODE_SETS
    Modifier and Type Constant Field Value
    public static final int value 1
  • org.omg.IOP.TAG_INTERNET_IOP
    Modifier and Type Constant Field Value
    public static final int value 0
  • org.omg.IOP.TAG_JAVA_CODEBASE
    Modifier and Type Constant Field Value
    public static final int value 25
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
    Modifier and Type Constant Field Value
    public static final int value 1
  • org.omg.IOP.TAG_ORB_TYPE
    Modifier and Type Constant Field Value
    public static final int value 0
  • org.omg.IOP.TAG_POLICIES
    Modifier and Type Constant Field Value
    public static final int value 2
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
    Modifier and Type Constant Field Value
    public static final int value 38
  • org.omg.IOP.TransactionService
    Modifier and Type Constant Field Value
    public static final int value 0
  • org.omg.Messaging.SYNC_WITH_TRANSPORT
    Modifier and Type Constant Field Value
    public static final short value 1
  • org.omg.PortableInterceptor.ACTIVE
    Modifier and Type Constant Field Value
    public static final short value 1
  • org.omg.PortableInterceptor.DISCARDING
    Modifier and Type Constant Field Value
    public static final short value 2
  • org.omg.PortableInterceptor.HOLDING
    Modifier and Type Constant Field Value
    public static final short value 0
  • org.omg.PortableInterceptor.INACTIVE
    Modifier and Type Constant Field Value
    public static final short value 3
  • org.omg.PortableInterceptor.LOCATION_FORWARD
    Modifier and Type Constant Field Value
    public static final short value 3
  • org.omg.PortableInterceptor.NON_EXISTENT
    Modifier and Type Constant Field Value
    public static final short value 4
  • org.omg.PortableInterceptor.SUCCESSFUL
    Modifier and Type Constant Field Value
    public static final short value 0
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
    Modifier and Type Constant Field Value
    public static final short value 1
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
    Modifier and Type Constant Field Value
    public static final short value 4
  • org.omg.PortableInterceptor.UNKNOWN
    Modifier and Type Constant Field Value
    public static final short value 5
  • org.omg.PortableInterceptor.USER_EXCEPTION
    Modifier and Type Constant Field Value
    public static final short value 2
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
    Modifier and Type Constant Field Value
    public static final int value 19
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
    Modifier and Type Constant Field Value
    public static final int value 18
  • org.omg.PortableServer.IdAssignmentPolicyValue
    Modifier and Type Constant Field Value
    public static final int _SYSTEM_ID 1
    public static final int _USER_ID 0
  • org.omg.PortableServer.IdUniquenessPolicyValue
    Modifier and Type Constant Field Value
    public static final int _MULTIPLE_ID 1
    public static final int _UNIQUE_ID 0
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
    Modifier and Type Constant Field Value
    public static final int value 20
  • org.omg.PortableServer.ImplicitActivationPolicyValue
    Modifier and Type Constant Field Value
    public static final int _IMPLICIT_ACTIVATION 0
    public static final int _NO_IMPLICIT_ACTIVATION 1
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
    Modifier and Type Constant Field Value
    public static final int value 17
  • org.omg.PortableServer.LifespanPolicyValue
    Modifier and Type Constant Field Value
    public static final int _PERSISTENT 1
    public static final int _TRANSIENT 0
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
    Modifier and Type Constant Field Value
    public static final int value 22
  • org.omg.PortableServer.RequestProcessingPolicyValue
    Modifier and Type Constant Field Value
    public static final int _USE_ACTIVE_OBJECT_MAP_ONLY 0
    public static final int _USE_DEFAULT_SERVANT 1
    public static final int _USE_SERVANT_MANAGER 2
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
    Modifier and Type Constant Field Value
    public static final int value 21
  • org.omg.PortableServer.ServantRetentionPolicyValue
    Modifier and Type Constant Field Value
    public static final int _NON_RETAIN 1
    public static final int _RETAIN 0
  • org.omg.PortableServer.THREAD_POLICY_ID
    Modifier and Type Constant Field Value
    public static final int value 16
  • org.omg.PortableServer.ThreadPolicyValue
    Modifier and Type Constant Field Value
    public static final int _ORB_CTRL_MODEL 0
    public static final int _SINGLE_THREAD_MODEL 1
  • org.omg.PortableServer.POAManagerPackage.State
    Modifier and Type Constant Field Value
    public static final int _ACTIVE 1
    public static final int _DISCARDING 2
    public static final int _HOLDING 0
    public static final int _INACTIVE 3

org.w3c.*

  • org.w3c.dom.DOMError
    Modifier and Type Constant Field Value
    public static final short SEVERITY_ERROR 2
    public static final short SEVERITY_FATAL_ERROR 3
    public static final short SEVERITY_WARNING 1
  • org.w3c.dom.DOMException
    Modifier and Type Constant Field Value
    public static final short DOMSTRING_SIZE_ERR 2
    public static final short HIERARCHY_REQUEST_ERR 3
    public static final short INDEX_SIZE_ERR 1
    public static final short INUSE_ATTRIBUTE_ERR 10
    public static final short INVALID_ACCESS_ERR 15
    public static final short INVALID_CHARACTER_ERR 5
    public static final short INVALID_MODIFICATION_ERR 13
    public static final short INVALID_STATE_ERR 11
    public static final short NAMESPACE_ERR 14
    public static final short NO_DATA_ALLOWED_ERR 6
    public static final short NO_MODIFICATION_ALLOWED_ERR 7
    public static final short NOT_FOUND_ERR 8
    public static final short NOT_SUPPORTED_ERR 9
    public static final short SYNTAX_ERR 12
    public static final short TYPE_MISMATCH_ERR 17
    public static final short VALIDATION_ERR 16
    public static final short WRONG_DOCUMENT_ERR 4
  • org.w3c.dom.Node
    Modifier and Type Constant Field Value
    public static final short ATTRIBUTE_NODE 2
    public static final short CDATA_SECTION_NODE 4
    public static final short COMMENT_NODE 8
    public static final short DOCUMENT_FRAGMENT_NODE 11
    public static final short DOCUMENT_NODE 9
    public static final short DOCUMENT_POSITION_CONTAINED_BY 16
    public static final short DOCUMENT_POSITION_CONTAINS 8
    public static final short DOCUMENT_POSITION_DISCONNECTED 1
    public static final short DOCUMENT_POSITION_FOLLOWING 4
    public static final short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC 32
    public static final short DOCUMENT_POSITION_PRECEDING 2
    public static final short DOCUMENT_TYPE_NODE 10
    public static final short ELEMENT_NODE 1
    public static final short ENTITY_NODE 6
    public static final short ENTITY_REFERENCE_NODE 5
    public static final short NOTATION_NODE 12
    public static final short PROCESSING_INSTRUCTION_NODE 7
    public static final short TEXT_NODE 3
  • org.w3c.dom.TypeInfo
    Modifier and Type Constant Field Value
    public static final int DERIVATION_EXTENSION 2
    public static final int DERIVATION_LIST 8
    public static final int DERIVATION_RESTRICTION 1
    public static final int DERIVATION_UNION 4
  • org.w3c.dom.UserDataHandler
    Modifier and Type Constant Field Value
    public static final short NODE_ADOPTED 5
    public static final short NODE_CLONED 1
    public static final short NODE_DELETED 3
    public static final short NODE_IMPORTED 2
    public static final short NODE_RENAMED 4
  • org.w3c.dom.bootstrap.DOMImplementationRegistry
    Modifier and Type Constant Field Value
    public static final String PROPERTY "org.w3c.dom.DOMImplementationSourceList"
  • org.w3c.dom.css.CSSPrimitiveValue
    Modifier and Type Constant Field Value
    public static final short CSS_ATTR 22
    public static final short CSS_CM 6
    public static final short CSS_COUNTER 23
    public static final short CSS_DEG 11
    public static final short CSS_DIMENSION 18
    public static final short CSS_EMS 3
    public static final short CSS_EXS 4
    public static final short CSS_GRAD 13
    public static final short CSS_HZ 16
    public static final short CSS_IDENT 21
    public static final short CSS_IN 8
    public static final short CSS_KHZ 17
    public static final short CSS_MM 7
    public static final short CSS_MS 14
    public static final short CSS_NUMBER 1
    public static final short CSS_PC 10
    public static final short CSS_PERCENTAGE 2
    public static final short CSS_PT 9
    public static final short CSS_PX 5
    public static final short CSS_RAD 12
    public static final short CSS_RECT 24
    public static final short CSS_RGBCOLOR 25
    public static final short CSS_S 15
    public static final short CSS_STRING 19
    public static final short CSS_UNKNOWN 0
    public static final short CSS_URI 20
  • org.w3c.dom.css.CSSRule
    Modifier and Type Constant Field Value
    public static final short CHARSET_RULE 2
    public static final short FONT_FACE_RULE 5
    public static final short IMPORT_RULE 3
    public static final short MEDIA_RULE 4
    public static final short PAGE_RULE 6
    public static final short STYLE_RULE 1
    public static final short UNKNOWN_RULE 0
  • org.w3c.dom.css.CSSValue
    Modifier and Type Constant Field Value
    public static final short CSS_CUSTOM 3
    public static final short CSS_INHERIT 0
    public static final short CSS_PRIMITIVE_VALUE 1
    public static final short CSS_VALUE_LIST 2
  • org.w3c.dom.events.Event
    Modifier and Type Constant Field Value
    public static final short AT_TARGET 2
    public static final short BUBBLING_PHASE 3
    public static final short CAPTURING_PHASE 1
  • org.w3c.dom.events.EventException
    Modifier and Type Constant Field Value
    public static final short UNSPECIFIED_EVENT_TYPE_ERR 0
  • org.w3c.dom.events.MutationEvent
    Modifier and Type Constant Field Value
    public static final short ADDITION 2
    public static final short MODIFICATION 1
    public static final short REMOVAL 3
  • org.w3c.dom.ls.DOMImplementationLS
    Modifier and Type Constant Field Value
    public static final short MODE_ASYNCHRONOUS 2
    public static final short MODE_SYNCHRONOUS 1
  • org.w3c.dom.ls.LSException
    Modifier and Type Constant Field Value
    public static final short PARSE_ERR 81
    public static final short SERIALIZE_ERR 82
  • org.w3c.dom.ls.LSParser
    Modifier and Type Constant Field Value
    public static final short ACTION_APPEND_AS_CHILDREN 1
    public static final short ACTION_INSERT_AFTER 4
    public static final short ACTION_INSERT_BEFORE 3
    public static final short ACTION_REPLACE 5
    public static final short ACTION_REPLACE_CHILDREN 2
  • org.w3c.dom.ls.LSParserFilter
    Modifier and Type Constant Field Value
    public static final short FILTER_ACCEPT 1
    public static final short FILTER_INTERRUPT 4
    public static final short FILTER_REJECT 2
    public static final short FILTER_SKIP 3
  • org.w3c.dom.ranges.Range
    Modifier and Type Constant Field Value
    public static final short END_TO_END 2
    public static final short END_TO_START 3
    public static final short START_TO_END 1
    public static final short START_TO_START 0
  • org.w3c.dom.ranges.RangeException
    Modifier and Type Constant Field Value
    public static final short BAD_BOUNDARYPOINTS_ERR 1
    public static final short INVALID_NODE_TYPE_ERR 2
  • org.w3c.dom.traversal.NodeFilter
    Modifier and Type Constant Field Value
    public static final short FILTER_ACCEPT 1
    public static final short FILTER_REJECT 2
    public static final short FILTER_SKIP 3
    public static final int SHOW_ALL -1
    public static final int SHOW_ATTRIBUTE 2
    public static final int SHOW_CDATA_SECTION 8
    public static final int SHOW_COMMENT 128
    public static final int SHOW_DOCUMENT 256
    public static final int SHOW_DOCUMENT_FRAGMENT 1024
    public static final int SHOW_DOCUMENT_TYPE 512
    public static final int SHOW_ELEMENT 1
    public static final int SHOW_ENTITY 32
    public static final int SHOW_ENTITY_REFERENCE 16
    public static final int SHOW_NOTATION 2048
    public static final int SHOW_PROCESSING_INSTRUCTION 64
    public static final int SHOW_TEXT 4
  • org.w3c.dom.xpath.XPathException
    Modifier and Type Constant Field Value
    public static final short INVALID_EXPRESSION_ERR 1
    public static final short TYPE_ERR 2
  • org.w3c.dom.xpath.XPathNamespace
    Modifier and Type Constant Field Value
    public static final short XPATH_NAMESPACE_NODE 13
  • org.w3c.dom.xpath.XPathResult
    Modifier and Type Constant Field Value
    public static final short ANY_TYPE 0
    public static final short ANY_UNORDERED_NODE_TYPE 8
    public static final short BOOLEAN_TYPE 3
    public static final short FIRST_ORDERED_NODE_TYPE 9
    public static final short NUMBER_TYPE 1
    public static final short ORDERED_NODE_ITERATOR_TYPE 5
    public static final short ORDERED_NODE_SNAPSHOT_TYPE 7
    public static final short STRING_TYPE 2
    public static final short UNORDERED_NODE_ITERATOR_TYPE 4
    public static final short UNORDERED_NODE_SNAPSHOT_TYPE 6

org.xml.*

  • org.xml.sax.helpers.NamespaceSupport
    Modifier and Type Constant Field Value
    public static final String NSDECL "http://www.w3.org/xmlns/2000/"
    public static final String XMLNS "http://www.w3.org/XML/1998/namespace"
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement
For further API reference and developer documentation see the Java SE Documentation, which contains more detailed, developer-targeted descriptions with conceptual overviews, definitions of terms, workarounds, and working code examples.


Deprecated List (Java SE 9 & JDK 9 )

  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Deprecated API

Contents

  • Deprecated For Removal
  • Deprecated Modules
  • Deprecated Interfaces
  • Deprecated Classes
  • Deprecated Enums
  • Deprecated Exceptions
  • Deprecated Annotation Types
  • Deprecated Fields
  • 弃用的方法
  • Deprecated Constructors
  • Deprecated Enum Constants
  • Deprecated Annotation Type Elements
  • Deprecated For Removal
    Element 描述
    com.sun.java.accessibility.util.AWTEventMonitor.actionListener
    此字段未使用。
    com.sun.java.accessibility.util.AWTEventMonitor.adjustmentListener
    此字段未使用。
    java.lang.SecurityManager.checkAwtEventQueueAccess()
    此方法最初用于检查调用线程是否可以访问AWT事件队列。 该方法已经过时，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessEventQueue") 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.checkMemberAccess(Class<?>, int)
    该方法依赖于调用者的堆栈深度为4，容易出错，并且不能由运行时执行。 该方法的用户应直接调用SecurityManager.checkPermission(java.security.Permission) 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.checkSystemClipboardAccess()
    该方法最初用于检查调用线程是否可以访问系统剪贴板。 该方法已被废弃，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessClipboard") 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.checkTopLevelWindow(Object)
    该方法最初用于检查调用线程是否被信任以启动顶级窗口。 该方法已被废弃，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("showWindowWithoutWarningBanner") 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.classDepth(String)
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.classLoaderDepth()
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.Compiler
    JIT编译器及其技术变化太大，可以通过标准化界面有效地进行控制。 因此，许多JIT编译器实现忽略此接口，而是由特定于实现的机制（如命令行选项）控制。 此类可能在将来的Java SE版本中被删除。
    com.sun.java.accessibility.util.AWTEventMonitor.componentListener
    此字段未使用。
    com.sun.java.accessibility.util.AWTEventMonitor.componentWithFocus
    此字段未使用; 使用getComponentWithFocus方法获取焦点的组件。
    com.sun.java.accessibility.util.AWTEventMonitor.containerListener
    此字段未使用。
    java.lang.Thread.countStackFrames()
    此呼叫的定义取决于Thread.suspend() ，已被弃用。 此外，此呼叫的结果从未明确。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.currentClassLoader()
    不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.currentLoadedClass()
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.Thread.destroy()
    这种方法最初是为了销毁这个线程而没有任何清理。 它所持有的任何监视器都将保持锁定。 但是，该方法从未实现。 如果要实施，这将是Thread.suspend()的方式是死锁的倾向。 如果目标线程在销毁时保护关键系统资源的锁，则无法再次访问该资源。 如果另一个线程曾尝试锁定此资源，将导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
    com.sun.java.accessibility.util.AWTEventMonitor.focusListener
    此字段未使用。
    java.lang.SecurityManager.getInCheck()
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.Runtime.getLocalizedInputStream(InputStream)
    从JDK 1.1开始，将本地编码中的字节流转换为Unicode中的字符流的首选方法是通过InputStreamReader和BufferedReader类。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.Runtime.getLocalizedOutputStream(OutputStream)
    从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。
    javafx.application.HostServices.getWebContext()
    此方法自JDK 9起已被弃用，因为不推荐使用Applet API。
    java.lang.SecurityManager.inCheck
    不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此字段在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.inClass(String)
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.inClassLoader()
    不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
    com.sun.java.accessibility.util.AWTEventMonitor.itemListener
    此字段未使用。
    java.activation
    java.corba
    java.se.ee
    java.transaction
    java.xml.bind
    java.xml.ws
    java.xml.ws.annotation
    jdk.policytool
    com.sun.java.accessibility.util.AWTEventMonitor.keyListener
    此字段未使用。
    com.sun.java.accessibility.util.AWTEventMonitor.mouseListener
    此字段未使用。
    com.sun.java.accessibility.util.AWTEventMonitor.mouseMotionListener
    此字段未使用。
    com.sun.security.auth.PolicyFile
    截至JDK 1.4，由sun.security.provider.PolicyFile替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    java.lang.Runtime.runFinalizersOnExit(boolean)
    这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.System.runFinalizersOnExit(boolean)
    这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
    com.sun.security.auth.module.SolarisLoginModule
    截至JDK1.4，由com.sun.security.auth.module.UnixLoginModule替代。 这个LoginModule已经完全被废弃了，这里允许平滑过渡到新的UnixLoginModule。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.SolarisNumericGroupPrincipal
    截至JDK 1.4，由UnixNumericGroupPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.SolarisNumericUserPrincipal
    截至JDK 1.4，由UnixNumericUserPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.SolarisPrincipal
    截至JDK 1.4，由UnixPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.module.SolarisSystem
    替换为UnixSystem 。 此类可能在将来的Java SE版本中被删除。
    com.sun.tools.doclets.standard.Standard
    该文件已取代其替换， StandardDoclet 。
    java.lang.Thread.stop(Throwable)
    该方法最初是为了强制线程停止并抛出一个给定的Throwable作为例外。 它本质上是不安全的（有关详细信息，请参阅Thread.stop() ），此外还可用于生成目标线程未准备处理的异常。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
    com.sun.java.accessibility.util.AWTEventMonitor.textListener
    此字段未使用。
    java.lang.Runtime.traceInstructions(boolean)
    该方法旨在控制指令跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.Runtime.traceMethodCalls(boolean)
    此方法旨在控制方法调用跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
    com.sun.java.accessibility.util.AWTEventMonitor.windowListener
    此字段未使用。
    com.sun.security.auth.X500Principal
    Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。
  • Deprecated Modules
    Module 描述
    java.activation
    java.corba
    java.se.ee
    java.transaction
    java.xml.bind
    java.xml.ws
    java.xml.ws.annotation
    jdk.policytool
  • Deprecated Interfaces
    接口 描述
    java.security.acl.Acl
    该软件包自java.security.Policy已被java.security.Policy及相关课程所取代。
    java.security.acl.AclEntry
    该软件包自java.security.Policy已被替换为java.security.Policy和相关类。
    com.sun.javadoc.AnnotatedType
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.AnnotationDesc
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.AnnotationDesc.ElementValuePair
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.AnnotationTypeDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.AnnotationTypeElementDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.AnnotationValue
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    java.applet.AppletContext
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    java.beans.AppletInitializer
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    java.applet.AppletStub
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    org.xml.sax.AttributeList
    该接口已被SAX2 Attributes接口所取代，其中包括命名空间支持。
    java.applet.AudioClip
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    java.security.Certificate
    Java平台中创建了一个新的证书处理包。 此证书界面已完全弃用，并在此允许平滑过渡到新软件包。
    com.sun.javadoc.ClassDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.ConstructorDoc
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.jarsigner.ContentSignerParameters
    此类已被弃用。
    com.sun.javadoc.Doc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.DocErrorReporter
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    org.xml.sax.DocumentHandler
    该接口已被SAX2 ContentHandler接口所取代，其中包括Namespace支持。
    org.omg.CORBA.DynAny
    改用新的DynAny
    org.omg.CORBA.DynArray
    改用新的DynArray
    org.omg.CORBA.DynEnum
    改用新的DynEnum
    org.omg.CORBA.DynFixed
    使用新的DynFixed代替
    org.omg.CORBA.DynSequence
    改用新的DynSequence
    org.omg.CORBA.DynStruct
    改用新的DynStruct
    org.omg.CORBA.DynUnion
    改用新的DynUnion
    org.omg.CORBA.DynValue
    使用新的DynValue代替
    com.sun.javadoc.ExecutableMemberDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.FieldDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    java.security.acl.Group
    该软件包自java.security.Policy已被替换为java.security.Policy和相关类。
    java.rmi.server.LoaderHandler
    没有替换
    java.util.logging.LoggingMXBean
    LoggingMXBean不再是platform MXBean ，而是被PlatformLoggingMXBean所取代。 它不会在平台上注册MBeanServer 。 改用ManagementFactory.getPlatformMXBean(PlatformLoggingMXBean.class) 。
    com.sun.javadoc.MemberDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.MethodDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    java.util.Observer
    此接口已被弃用。 有关详细信息，请参阅Observable课程。
    java.security.acl.Owner
    自1.2版本以来，该软件包已被java.security.Policy和相关课程所取代。
    com.sun.javadoc.PackageDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.Parameter
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.ParameterizedType
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.ParamTag
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    org.xml.sax.Parser
    该接口已被SAX2 XMLReader接口所取代，其中包括命名空间支持。
    java.security.acl.Permission
    自1.2版起，该软件包已被java.security.Policy及相关课程所取代。
    com.sun.javadoc.ProgramElementDoc
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    java.rmi.registry.RegistryHandler
    没有替换
    java.rmi.server.RemoteCall
    没有替换。
    com.sun.javadoc.RootDoc
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.SeeTag
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.SerialFieldTag
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    java.rmi.server.ServerRef
    没有替换 此接口未使用，已过时。
    java.rmi.server.Skeleton
    没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
    com.sun.javadoc.SourcePosition
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.Tag
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.tools.doclets.Taglet
    该接口已被替换， Taglet替代。
    com.sun.javadoc.ThrowsTag
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.Type
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    com.sun.javadoc.TypeVariable
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    javax.xml.bind.Validator
    自JAXB 2.0起
    com.sun.javadoc.WildcardType
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
  • Deprecated Classes
    Class 描述
    javax.accessibility.AccessibleResourceBundle
    从Java平台1.3版开始，此类已被弃用
    java.applet.Applet
    Applet API已被弃用。 详见java.applet package documentation 。
    org.xml.sax.helpers.AttributeListImpl
    这个类实现了一个不推荐的接口， AttributeList ; 该接口已被替换为Attributes ，它是在AttributesImpl帮助类中实现的。
    javax.security.cert.Certificate
    使用java.security.cert的类。
    java.lang.Compiler
    JIT编译器及其技术变化太大，可以通过标准化界面有效地进行控制。 因此，许多JIT编译器实现忽略此接口，而是由特定于实现的机制（如命令行选项）控制。 此类可能在将来的Java SE版本中被删除。
    com.sun.jarsigner.ContentSigner
    此类已被弃用。
    javax.management.DefaultLoaderRepository
    改用MBeanServer.getClassLoaderRepository() 。
    javax.management.loading.DefaultLoaderRepository
    改用MBeanServer.getClassLoaderRepository() 。
    javax.swing.text.DefaultTextUI
    com.sun.javadoc.Doclet
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    org.omg.CORBA.DynamicImplementation
    org.omg.CORBA.DynamicImplementation
    java.awt.Event
    建议使用AWTEvent及其子类
    org.xml.sax.HandlerBase
    此类与已弃用的DocumentHandler接口配合使用。 它已被SAX2 DefaultHandler类所取代。
    java.security.Identity
    此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
    java.security.IdentityScope
    此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
    javax.swing.JApplet
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
    此类不再使用或需要。 java.awt.Component.AccessibleAWTComponent提供相同的功能，它在Component处理。
    java.io.LineNumberInputStream
    该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。
    java.rmi.server.LogStream
    没有替换
    com.sun.tools.javadoc.Main
    此类现在已被弃用，可能会在将来的版本中删除。 有关替换功能，请参阅javax.tools.ToolProvider::getSystemDocumentationTool和javax.tools.DocumentationTool 。
    javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
    从Java 2平台v1.4开始。
    javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
    截至JDK版本9.过时的课程。
    javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
    截至JDK版本9.过时的课程。
    java.util.Observable
    此类和Observer接口已被弃用。 Observer和Observable支持的事件模式是非常有限的， Observable发送的通知的Observable是未指定的，状态更改不与通知一一对应。 对于更丰富的事件模型，请考虑使用java.beans软件包。 对于线程之间的可靠和有序的消息传递，请考虑使用java.util.concurrent包中的并发数据结构之一。 对于反应流样式编程，请参阅Flow API。
    java.rmi.server.Operation
    没有替换
    org.xml.sax.helpers.ParserFactory
    此类与已弃用的Parser接口配合使用。
    javax.security.auth.Policy
    从JDK版本1.4开始 - 由java.security.Policy替代。 java.security.Policy有一个方法：
      public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
    和ProtectionDomain有一个构造函数：
      public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
    这两个API为呼叫者提供查询基于Principal权限条目的策略的方法。
    com.sun.security.auth.PolicyFile
    截至JDK 1.4，由sun.security.provider.PolicyFile替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    org.omg.CORBA.Principal
    被CORBA弃用2.2。
    org.omg.CORBA.PrincipalHolder
    被CORBA弃用2.2。
    java.rmi.server.RemoteStub
    静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
    javax.management.remote.rmi.RMIIIOPServerImpl
    此运输已不再受支持。
    java.rmi.RMISecurityManager
    改用SecurityManager 。
    java.security.Signer
    此类不再使用。 其功能已被java.security.KeyStore替代， java.security.cert包，以及java.security.Principal 。
    javax.xml.soap.SOAPElementFactory
    - 使用javax.xml.soap.SOAPFactory创建SOAPElements。
    com.sun.security.auth.module.SolarisLoginModule
    截至JDK1.4，由com.sun.security.auth.module.UnixLoginModule取代。 这个LoginModule已经完全被废弃了，这里允许平滑过渡到新的UnixLoginModule。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.SolarisNumericGroupPrincipal
    截至JDK 1.4，由UnixNumericGroupPrincipal取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.SolarisNumericUserPrincipal
    截至JDK 1.4，由UnixNumericUserPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.SolarisPrincipal
    截至JDK 1.4，由UnixPrincipal取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
    com.sun.security.auth.module.SolarisSystem
    替换为UnixSystem 。 此类可能在将来的Java SE版本中被删除。
    com.sun.tools.doclets.standard.Standard
    该文件夹已被替换， StandardDoclet取代。
    java.io.StringBufferInputStream
    此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。
    javax.swing.text.TableView.TableCell
    一个表单元格现在可以是任何View实现。
    com.sun.security.auth.X500Principal
    Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。
    javax.security.cert.X509Certificate
    使用java.security.cert的类。
    org.xml.sax.helpers.XMLReaderFactory
    建议使用SAXParserFactory 。
  • Deprecated Enums
    Enum 描述
    com.sun.javadoc.LanguageVersion
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
  • Deprecated Exceptions
    Exceptions 描述
    java.security.acl.AclNotFoundException
    自1.2版本以来，该软件包已被java.security.Policy和相关类替代。
    javax.security.cert.CertificateEncodingException
    使用java.security.cert的类。
    javax.security.cert.CertificateException
    使用java.security.cert的类。
    javax.security.cert.CertificateExpiredException
    使用java.security.cert的类。
    javax.security.cert.CertificateNotYetValidException
    使用java.security.cert的类。
    javax.security.cert.CertificateParsingException
    使用java.security.cert的类。
    com.sun.jdi.InvalidCodeIndexException
    不再抛出此异常
    com.sun.jdi.InvalidLineNumberException
    不再抛出此异常
    java.security.acl.LastOwnerException
    自1.2版本以来，该软件包已被java.security.Policy和相关类替代。
    java.security.acl.NotOwnerException
    该软件包自java.security.Policy已被替换为java.security.Policy和相关类。
    java.rmi.RMISecurityException
    改用SecurityException 。 应用程式代码永远不要直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。
    java.rmi.ServerRuntimeException
    没有替换
    java.rmi.server.SkeletonMismatchException
    没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
    java.rmi.server.SkeletonNotFoundException
    没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
    java.rmi.server.SocketSecurityException
    这个班已经过时了 改用ExportException 。
  • Deprecated Annotation Types
    Annotation Type 描述
    javax.jws.soap.InitParam
    javax.jws.soap.SOAPMessageHandler
    javax.jws.soap.SOAPMessageHandlers
  • Deprecated Fields
    Field 描述
    javax.swing.JComponent.AccessibleJComponent.accessibleFocusHandler
    com.sun.java.accessibility.util.AWTEventMonitor.actionListener
    此字段未使用。
    com.sun.java.accessibility.util.AWTEventMonitor.adjustmentListener
    此字段未使用。
    javax.management.openmbean.OpenType.ALLOWED_CLASSNAMES
    改用ALLOWED_CLASSNAMES_LIST 。
    javax.management.monitor.Monitor.alreadyNotified
    相当于Monitor.alreadyNotifieds [0]。
    java.awt.event.InputEvent.ALT_GRAPH_MASK
    建议使用ALT_GRAPH_DOWN_MASK和InputEvent.getModifiersEx()
    java.awt.event.InputEvent.ALT_MASK
    建议使用ALT_DOWN_MASK和InputEvent.getModifiersEx()
    javax.naming.Context.APPLET
    在构建初始上下文时，将忽略具有此名称的环境属性。 此常量最初用作属性名称，以在创建初始上下文时指定Applet以从中检索参数。 目前需要传递给初始上下文的任何applet属性都应该复制到环境哈希表中：
       Hashtable env = new Hashtable(); env.put(Context.INITIAL_CONTEXT_FACTORY, ((Applet) this).getParameter(Context.INITIAL_CONTEXT_FACTORY)); env.put(Context.PROVIDER_URL, ((Applet) this).getParameter(Context.PROVIDER_URL)); // ... other properties ... Context ctx = new InitialContext(env);
    javax.swing.JViewport.backingStore
    从Java 2平台v1.3开始
    java.awt.event.InputEvent.BUTTON1_MASK
    建议使用BUTTON1_DOWN_MASK和InputEvent.getModifiersEx()
    java.awt.event.InputEvent.BUTTON2_MASK
    建议使用BUTTON2_DOWN_MASK和InputEvent.getModifiersEx() 。 请注意，BUTTON2_MASK的值与ALT_MASK相同。
    java.awt.event.InputEvent.BUTTON3_MASK
    建议使用BUTTON3_DOWN_MASK和InputEvent.getModifiersEx() 。 请注意，BUTTON3_MASK与META_MASK具有相同的值。
    javax.swing.plaf.basic.BasicDesktopPaneUI.closeKey
    截至1.3。
    javax.sql.rowset.CachedRowSet.COMMIT_ON_ACCEPT_CHANGES
    因为这个字段是final（它是接口的一部分），所以它的值不能被改变。
    javax.swing.ImageIcon.component
    自1.8
    com.sun.java.accessibility.util.AWTEventMonitor.componentListener
    此字段未使用。
    com.sun.java.accessibility.util.AWTEventMonitor.componentWithFocus
    此字段未使用; 使用getComponentWithFocus方法获取焦点的组件。
    com.sun.java.accessibility.util.AWTEventMonitor.containerListener
    此字段未使用。
    java.awt.Frame.CROSSHAIR_CURSOR
    由Cursor.CROSSHAIR_CURSOR取代。
    java.awt.event.InputEvent.CTRL_MASK
    建议使用CTRL_DOWN_MASK和InputEvent.getModifiersEx()
    javax.management.monitor.Monitor.dbgTag
    没有替换
    java.awt.Frame.DEFAULT_CURSOR
    替换为Cursor.DEFAULT_CURSOR 。
    javax.swing.plaf.basic.BasicSplitPaneUI.dividerResizeToggleKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.downKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicTabbedPaneUI.downKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicToolBarUI.downKey
    从Java 2平台v1.3开始。
    java.awt.Frame.E_RESIZE_CURSOR
    取代Cursor.E_RESIZE_CURSOR 。
    javax.swing.plaf.basic.BasicSplitPaneUI.endKey
    从Java 2平台v1.3开始。
    java.util.jar.Attributes.Name.EXTENSION_INSTALLATION
    扩展机制不再受支持。
    com.sun.java.accessibility.util.AWTEventMonitor.focusListener
    此字段未使用。
    java.util.logging.Logger.global
    此字段的初始化容易出现死锁。 该字段必须由Logger类初始化初始化，这可能会导致与LogManager类初始化的死锁。 在这种情况下，两个类初始化等待彼此完成。 获取全局记录器对象的首选方法是通过调用Logger.getGlobal() 。 为了兼容Logger.getGlobal()不可用的旧JDK版本，请使用电话Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)或Logger.getLogger("global") 。
    java.awt.Frame.HAND_CURSOR
    替换为Cursor.HAND_CURSOR 。
    javax.swing.plaf.basic.BasicSplitPaneUI.homeKey
    从Java 2平台v1.3开始。
    java.net.HttpURLConnection.HTTP_SERVER_ERROR
    它是错误的，不应该存在。
    java.util.jar.Attributes.Name.IMPLEMENTATION_URL
    扩展机制不再受支持。
    java.util.jar.Attributes.Name.IMPLEMENTATION_VENDOR_ID
    扩展机制不再受支持。
    java.lang.SecurityManager.inCheck
    不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此字段在将来的Java SE版本中可能会被删除。
    com.sun.java.accessibility.util.AWTEventMonitor.itemListener
    此字段未使用。
    javax.swing.plaf.basic.BasicSplitPaneUI.keyboardDownRightListener
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.keyboardEndListener
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.keyboardHomeListener
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.keyboardResizeToggleListener
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.keyboardUpLeftListener
    从Java 2平台v1.3开始。
    com.sun.java.accessibility.util.AWTEventMonitor.keyListener
    此字段未使用。
    javax.swing.plaf.basic.BasicSplitPaneUI.leftKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicTabbedPaneUI.leftKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicToolBarUI.leftKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicDesktopPaneUI.maximizeKey
    截至1.3。
    java.awt.event.InputEvent.META_MASK
    建议使用META_DOWN_MASK和InputEvent.getModifiersEx()
    javax.swing.plaf.basic.BasicDesktopPaneUI.minimizeKey
    截至1.3。
    com.sun.java.accessibility.util.AWTEventMonitor.mouseListener
    此字段未使用。
    com.sun.java.accessibility.util.AWTEventMonitor.mouseMotionListener
    此字段未使用。
    java.awt.Frame.MOVE_CURSOR
    取代Cursor.MOVE_CURSOR 。
    java.awt.Frame.N_RESIZE_CURSOR
    取代Cursor.N_RESIZE_CURSOR 。
    javax.swing.plaf.basic.BasicDesktopPaneUI.navigateKey
    截至1.3。
    javax.swing.plaf.basic.BasicDesktopPaneUI.navigateKey2
    截至1.3。
    java.awt.Frame.NE_RESIZE_CURSOR
    替换为Cursor.NE_RESIZE_CURSOR 。
    java.awt.Frame.NW_RESIZE_CURSOR
    替换为Cursor.NW_RESIZE_CURSOR 。
    javax.swing.plaf.basic.BasicInternalFrameUI.openMenuKey
    从Java 2平台v1.3开始。
    java.awt.datatransfer.DataFlavor.plainTextFlavor
    截至1.3。 使用DataFlavor.getReaderForText(java.awt.datatransfer.Transferable)而不是Transferable.getTransferData(DataFlavor.plainTextFlavor) 。
    java.awt.Cursor.predefined
    从JDK 1.7版开始，应该使用Cursor.getPredefinedCursor(int)方法。
    javax.swing.text.html.FormView.RESET
    从1.3开始，值来自UIManager UIManager属性FormView.resetButtonText
    javax.swing.table.TableColumn.resizedPostingDisableCount
    从Java 2平台v1.3开始
    javax.swing.plaf.basic.BasicSplitPaneUI.rightKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicTabbedPaneUI.rightKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicToolBarUI.rightKey
    从Java 2平台v1.3开始。
    java.math.BigDecimal.ROUND_CEILING
    改用RoundingMode.CEILING 。
    java.math.BigDecimal.ROUND_DOWN
    改用RoundingMode.DOWN 。
    java.math.BigDecimal.ROUND_FLOOR
    改用RoundingMode.FLOOR 。
    java.math.BigDecimal.ROUND_HALF_DOWN
    改用RoundingMode.HALF_DOWN 。
    java.math.BigDecimal.ROUND_HALF_EVEN
    改用RoundingMode.HALF_EVEN 。
    java.math.BigDecimal.ROUND_HALF_UP
    改用RoundingMode.HALF_UP 。
    java.math.BigDecimal.ROUND_UNNECESSARY
    请改用RoundingMode.UNNECESSARY 。
    java.math.BigDecimal.ROUND_UP
    改用RoundingMode.UP 。
    java.awt.Frame.S_RESIZE_CURSOR
    替换为Cursor.S_RESIZE_CURSOR 。
    java.awt.Frame.SE_RESIZE_CURSOR
    替换为Cursor.SE_RESIZE_CURSOR 。
    java.awt.event.InputEvent.SHIFT_MASK
    建议使用SHIFT_DOWN_MASK和InputEvent.getModifiersEx()
    javax.imageio.spi.ImageReaderSpi.STANDARD_INPUT_TYPE
    而不是使用此字段，直接创建等效的数组{ ImageInputStream.class } 。
    javax.imageio.spi.ImageWriterSpi.STANDARD_OUTPUT_TYPE
    而不是使用这个字段，直接创建等效的数组{ ImageOutputStream.class } 。
    javax.swing.text.html.FormView.SUBMIT
    从1.3起，现在的值来自UIManager属性FormView.submitButtonText
    java.lang.Character.UnicodeBlock.SURROGATES_AREA
    取而代之的SURROGATES_AREA ，使用Character.UnicodeBlock.HIGH_SURROGATES ， Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES ，并Character.UnicodeBlock.LOW_SURROGATES 。 这些常量符合Unicode标准的块定义。 Character.UnicodeBlock.of(char)和Character.UnicodeBlock.of(int)方法返回标准常数。
    java.awt.Frame.SW_RESIZE_CURSOR
    替换为Cursor.SW_RESIZE_CURSOR 。
    java.awt.Frame.TEXT_CURSOR
    替换为Cursor.TEXT_CURSOR 。
    com.sun.java.accessibility.util.AWTEventMonitor.textListener
    此字段未使用。
    javax.swing.ImageIcon.tracker
    自1.8
    javax.swing.plaf.basic.BasicSplitPaneUI.upKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicTabbedPaneUI.upKey
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicToolBarUI.upKey
    从Java 2平台v1.3开始。
    java.awt.Frame.W_RESIZE_CURSOR
    替换为Cursor.W_RESIZE_CURSOR 。
    java.awt.Frame.WAIT_CURSOR
    替换为Cursor.WAIT_CURSOR 。
    com.sun.java.accessibility.util.AWTEventMonitor.windowListener
    此字段未使用。
  • 弃用的方法
    方法 描述
    java.awt.Component.action(Event, Object)
    从JDK 1.1版开始，应该在组件上注册此组件作为ActionListener，该组件将触发动作事件。
    javax.swing.RepaintManager.addDirtyRegion(Applet, int, int, int, int)
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    java.awt.List.addItem(String)
    取代add(String) 。
    java.awt.List.addItem(String, int)
    替换为add(String, int) 。
    java.awt.BorderLayout.addLayoutComponent(String, Component)
    替换为addLayoutComponent(Component, Object) 。
    java.awt.CardLayout.addLayoutComponent(String, Component)
    替换为addLayoutComponent(Component, Object) 。
    java.awt.List.allowsMultipleSelections()
    从JDK 1.1版开始，由isMultipleMode()替代。
    java.lang.ThreadGroup.allowThreadSuspension(boolean)
    此呼叫的定义取决于ThreadGroup.suspend() ，已被弃用。 此外，从未指定此调用的行为。
    java.awt.TextArea.appendText(String)
    自JDK 1.1版起，由append(String)替代。
    java.awt.Window.applyResourceBundle(String)
    截至J2SE 1.4，由Component.applyComponentOrientation替代。
    java.awt.Window.applyResourceBundle(ResourceBundle)
    截至J2SE 1.4，由Component.applyComponentOrientation替代。
    java.awt.Component.bounds()
    从JDK 1.1版开始，由getBounds()替代。
    java.lang.SecurityManager.checkAwtEventQueueAccess()
    此方法最初用于检查调用线程是否可以访问AWT事件队列。 该方法已经过时，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessEventQueue") 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.checkMemberAccess(Class<?>, int)
    该方法依赖于调用者的堆栈深度为4，容易出错，并且不能由运行时执行。 该方法的用户应直接调用SecurityManager.checkPermission(java.security.Permission) 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.checkMulticast(InetAddress, byte)
    请改用#checkPermission（java.security.Permission）
    java.lang.SecurityManager.checkSystemClipboardAccess()
    该方法最初用于检查调用线程是否可以访问系统剪贴板。 该方法已被废弃，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessClipboard") 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.checkTopLevelWindow(Object)
    该方法最初用于检查调用线程是否被信任以启动顶级窗口。 该方法已被废弃，代码应使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("showWindowWithoutWarningBanner") 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.classDepth(String)
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.classLoaderDepth()
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.awt.List.clear()
    从JDK 1.1版开始，由removeAll()替代。
    java.awt.image.renderable.RenderContext.concetenateTransform(AffineTransform)
    替换为concatenateTransform(AffineTransform) 。
    java.awt.Container.countComponents()
    从JDK 1.1版开始，由getComponentCount（）替换。
    java.awt.Choice.countItems()
    从JDK 1.1版开始，由getItemCount()替代。
    java.awt.List.countItems()
    从JDK 1.1版开始，由getItemCount()替代。
    java.awt.Menu.countItems()
    从JDK 1.1版开始，由getItemCount()替代。
    java.awt.MenuBar.countMenus()
    从JDK 1.1版开始，由getMenuCount()替代。
    java.lang.Thread.countStackFrames()
    此呼叫的定义取决于Thread.suspend() ，已被弃用。 此外，此呼叫的结果从未明确。 此方法在将来的Java SE版本中可能会被删除。
    javax.xml.soap.SOAPElementFactory.create(String)
    改用javax.xml.soap.SOAPFactory.createElement（String localName）
    javax.xml.soap.SOAPElementFactory.create(String, String, String)
    改用javax.xml.soap.SOAPFactory.createElement（String localName，String prefix，String uri）
    javax.xml.soap.SOAPElementFactory.create(Name)
    改用javax.xml.soap.SOAPFactory.createElement（javax.xml.soap.Name）
    org.omg.CORBA.ORB.create_basic_dyn_any(TypeCode)
    使用新的DynAnyFactory API
    org.omg.CORBA.ORB.create_dyn_any(Any)
    使用新的DynAnyFactory API
    org.omg.CORBA.ORB.create_dyn_array(TypeCode)
    使用新的DynAnyFactory API
    org.omg.CORBA.ORB.create_dyn_enum(TypeCode)
    使用新的DynAnyFactory API
    org.omg.CORBA.ORB.create_dyn_sequence(TypeCode)
    使用新的DynAnyFactory API
    org.omg.CORBA.ORB.create_dyn_struct(TypeCode)
    使用新的DynAnyFactory API
    org.omg.CORBA.ORB.create_dyn_union(TypeCode)
    使用新的DynAnyFactory API
    org.omg.CORBA.ORB.create_recursive_sequence_tc(int, int)
    使用create_recursive_tc和create_sequence_tc的组合
    javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardDownRightListener()
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardEndListener()
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardHomeListener()
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardResizeToggleListener()
    从Java 2平台v1.3开始。
    javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardUpLeftListener()
    从Java 2平台v1.3开始。
    javax.swing.JTable.createScrollPaneForTable(JTable)
    截至Swing 1.0.2版，由new JScrollPane(aTable)替换。
    javax.swing.text.TableView.createTableCell(Element)
    表格单元现在可以是任意的View实现，应该由ViewFactory而不是表生成。
    javax.xml.bind.JAXBContext.createValidator()
    自JAXB2.0起
    java.lang.SecurityManager.currentClassLoader()
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.currentLoadedClass()
    不推荐使用这种类型的安全检查。 建议使用checkPermission呼叫。 此方法在将来的Java SE版本中可能会被删除。
    java.net.URLDecoder.decode(String)
    结果字符串可能会因平台的默认编码而异。 而是使用decode（String，String）方法来指定编码。
    java.lang.ClassLoader.defineClass(byte[], int, int)
    替换为defineClass(String, byte[], int, int)
    java.awt.List.delItem(int)
    由remove(String)和remove(int)取代。
    java.awt.List.delItems(int, int)
    从JDK 1.1版开始，未来不会公开使用。 这种方法只能作为一个包私有方法保留。
    java.awt.Component.deliverEvent(Event)
    截至JDK 1.1版，由dispatchEvent(AWTEvent e)替代。
    java.awt.Container.deliverEvent(Event)
    从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代
    javax.management.MBeanServer.deserialize(String, byte[])
    使用MBeanServer.getClassLoaderRepository()获取类加载器存储库并将其用于反序列化。
    javax.management.MBeanServer.deserialize(String, ObjectName, byte[])
    使用getClassLoader获取反序列化的类加载器。
    javax.management.MBeanServer.deserialize(ObjectName, byte[])
    使用getClassLoaderFor获取适当的反序列化类加载器。
    java.lang.Thread.destroy()
    这种方法最初是为了销毁这个线程而没有任何清理。 它所持有的任何监视器都将保持锁定。 但是，该方法从未实现。 如果要实施，这将是Thread.suspend()的方式是非常容易死锁的。 如果目标线程在销毁时保护关键系统资源的锁，则无法再次访问该资源。 如果另一个线程曾尝试锁定此资源，将导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
    java.awt.Component.disable()
    从JDK 1.1版开始，由setEnabled(boolean)替代。
    java.awt.MenuItem.disable()
    从JDK 1.1版开始，由setEnabled(boolean)替代。
    javax.swing.JComponent.disable()
    从JDK 1.1版开始，由java.awt.Component.setEnabled(boolean)替代。
    javax.swing.table.TableColumn.disableResizedPosting()
    从Java 2平台v1.3开始
    javax.swing.FocusManager.disableSwingFocusManager()
    截至1.4，由KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)取代
    java.rmi.server.Skeleton.dispatch(Remote, RemoteCall, int, long)
    没有替换
    java.math.BigDecimal.divide(BigDecimal, int)
    应该优先使用方法BigDecimal.divide(BigDecimal, RoundingMode) ，这种传统方法。
    java.math.BigDecimal.divide(BigDecimal, int, int)
    应该优先使用方法BigDecimal.divide(BigDecimal, int, RoundingMode)用于该传统方法。
    javafx.util.Duration.divide(Duration)
    这种方法通过不考虑单位产生令人惊讶的结果。 改用Duration.divide(double) 。
    java.rmi.server.RemoteCall.done()
    没有替换
    java.rmi.server.RemoteRef.done(RemoteCall)
    1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
    javax.swing.text.PasswordView.drawEchoCharacter(Graphics, int, int, char)
    替换为PasswordView.drawEchoCharacter(Graphics2D, float, float, char)
    javax.swing.text.PlainView.drawLine(int, Graphics, int, int)
    替换为PlainView.drawLine(int, Graphics2D, float, float)
    javax.swing.text.WrappedPlainView.drawLine(int, int, Graphics, int, int)
    取代WrappedPlainView.drawLine(int, int, Graphics2D, float, float)
    javax.swing.text.PasswordView.drawSelectedText(Graphics, int, int, int, int)
    替换为PasswordView.drawSelectedText(Graphics2D, float, float, int, int)
    javax.swing.text.PlainView.drawSelectedText(Graphics, int, int, int, int)
    替换为PlainView.drawSelectedText(Graphics2D, float, float, int, int)
    javax.swing.text.WrappedPlainView.drawSelectedText(Graphics, int, int, int, int)
    替换为WrappedPlainView.drawSelectedText(Graphics2D, float, float, int, int)
    javax.swing.text.Utilities.drawTabbedText(Segment, int, int, Graphics, TabExpander, int)
    替换为Utilities.drawTabbedText(Segment, float, float, Graphics2D, TabExpander, int)
    javax.swing.text.PasswordView.drawUnselectedText(Graphics, int, int, int, int)
    替换为PasswordView.drawUnselectedText(Graphics2D, float, float, int, int)
    javax.swing.text.PlainView.drawUnselectedText(Graphics, int, int, int, int)
    替换为PlainView.drawUnselectedText(Graphics2D, float, float, int, int)
    javax.swing.text.WrappedPlainView.drawUnselectedText(Graphics, int, int, int, int)
    替换为WrappedPlainView.drawUnselectedText(Graphics2D, float, float, int, int)
    javax.swing.plaf.metal.MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent)
    从Java 2平台v1.4开始。
    java.awt.Component.enable()
    从JDK 1.1版开始，由setEnabled(boolean)替代。
    java.awt.Component.enable(boolean)
    自JDK 1.1版起，由setEnabled(boolean)取代。
    java.awt.MenuItem.enable()
    从JDK 1.1版开始，由setEnabled(boolean)替代。
    java.awt.MenuItem.enable(boolean)
    从JDK 1.1版开始，由setEnabled(boolean)替代。
    javax.swing.JComponent.enable()
    从JDK 1.1版开始，由java.awt.Component.setEnabled(boolean)替代。
    javax.swing.table.TableColumn.enableResizedPosting()
    从Java 2平台v1.3开始
    java.net.URLEncoder.encode(String)
    结果字符串可能会因平台的默认编码而异。 而是使用encode（String，String）方法来指定编码。
    java.security.SignatureSpi.engineGetParameter(String)
    java.security.SignatureSpi.engineSetParameter(String, Object)
    替换为engineSetParameter 。
    java.awt.datatransfer.DataFlavor.equals(String)
    与hashCode()合同不一致，请改用DataFlavor.isMimeTypeEqual(String) 。
    org.omg.CORBA.ServerRequest.except(Any)
    使用set_exception（）
    java.rmi.server.RemoteCall.executeCall()
    没有替换
    java.rmi.server.UnicastRemoteObject.exportObject(Remote)
    此方法已被弃用，因为它仅支持静态存根。 请改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
    org.omg.CORBA.Any.extract_Principal()
    被CORBA弃用2.2。
    java.awt.color.ICC_Profile.finalize()
    finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.awt.Graphics.finalize()
    finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.awt.image.ColorModel.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.awt.image.IndexColorModel.finalize()
    已弃用finalize方法。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.awt.PrintJob.finalize()
    finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.io.FileInputStream.finalize()
    finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.io.FileOutputStream.finalize()
    finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.lang.Object.finalize()
    定稿机制本质上是有问题的。 定稿可能导致性能问题，死锁和挂起。 敲定错误可能导致资源泄漏; 如果不再需要，无法取消定稿; 并且在对不同对象的finalize方法的调用中没有指定排序。 此外，关于定稿的时间并不保证。 finalize方法可能只有在无限延迟之后才能在可终止对象上调用，如果有的话。 其实例持有非堆资源的类应提供一种方法来实现这些资源的显式释放，如果合适，它们还应实现AutoCloseable 。 当对象变得不可达时， Cleaner和PhantomReference提供了更灵活和更有效的方式来释放资源。
    java.util.concurrent.ThreadPoolExecutor.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.util.zip.Deflater.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.util.zip.Inflater.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    java.util.zip.ZipFile.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    javax.imageio.spi.ServiceRegistry.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应该被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    javax.imageio.stream.FileCacheImageInputStream.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    javax.imageio.stream.FileImageInputStream.finalize()
    finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    javax.imageio.stream.FileImageOutputStream.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    javax.imageio.stream.ImageInputStreamImpl.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    javax.imageio.stream.MemoryCacheImageInputStream.finalize()
    finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
    javax.swing.SwingUtilities.findFocusOwner(Component)
    截至1.4，由KeyboardFocusManager.getFocusOwner()取代。
    org.omg.CORBA.ORB.get_current()
    使用resolve_initial_references 。
    java.security.Security.getAlgorithmProperty(String, String)
    此方法用于返回“SUN”加密服务提供程序的主文件中的专有属性的值，以确定如何解析特定于算法的参数。 AlgorithmParameters使用新的基于提供者和算法的AlgorithmParameters和KeyFactory引擎类（在J2SE版本1.2平台中引入）。
    java.sql.CallableStatement.getBigDecimal(int, int)
    使用getBigDecimal(int parameterIndex)或getBigDecimal(String parameterName)
    java.sql.ResultSet.getBigDecimal(int, int)
    使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
    java.sql.ResultSet.getBigDecimal(String, int)
    使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
    java.awt.Polygon.getBoundingBox()
    从JDK 1.1版开始，由getBounds()替代。
    javax.swing.text.Utilities.getBreakLocation(Segment, FontMetrics, int, int, TabExpander, int)
    替换为Utilities.getBreakLocation(Segment, FontMetrics, float, float, TabExpander, int)
    java.lang.String.getBytes(int, int, byte[], int)
    此方法无法将字符正确转换为字节。 从JDK 1.1开始，首选的方法是通过String.getBytes()方法，它使用平台的默认字符集。
    java.awt.Graphics.getClipRect()
    从JDK 1.1版开始，由getClipBounds()取代。
    javax.swing.JMenuBar.getComponentAtIndex(int)
    替换为getComponent(int i)
    javax.swing.JPopupMenu.getComponentAtIndex(int)
    替换为Container.getComponent(int)
    java.awt.CheckboxGroup.getCurrent()
    截至JDK 1.1版，由getSelectedCheckbox()替代。
    java.awt.Frame.getCursorType()
    从JDK 1.1版开始，由Component.getCursor()替代。
    java.sql.Time.getDate()
    java.util.Date.getDate()
    从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_MONTH)替代。
    java.sql.Time.getDay()
    java.util.Date.getDay()
    从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_WEEK)替代。
    java.net.URLConnection.getDefaultRequestProperty(String)
    在获得适当的URLConnection实例之后，应该使用实例特定的getRequestProperty方法。
    java.rmi.server.LogStream.getDefaultStream()
    没有替换
    jdk.nashorn.api.scripting.AbstractJSObject.getDefaultValue(JSObject, Class<?>)
    使用JSObject.getDefaultValue(Class)代替。
    javax.management.monitor.CounterMonitor.getDerivedGauge()
    截至JMX 1.2，由CounterMonitor.getDerivedGauge(ObjectName)取代
    javax.management.monitor.CounterMonitorMBean.getDerivedGauge()
    截至JMX 1.2，由CounterMonitorMBean.getDerivedGauge(ObjectName)替代
    javax.management.monitor.GaugeMonitor.getDerivedGauge()
    截至JMX 1.2，由GaugeMonitor.getDerivedGauge(ObjectName)取代
    javax.management.monitor.GaugeMonitorMBean.getDerivedGauge()
    截至JMX 1.2，由GaugeMonitorMBean.getDerivedGauge(ObjectName)替代
    javax.management.monitor.StringMonitor.getDerivedGauge()
    截至JMX 1.2，由StringMonitor.getDerivedGauge(ObjectName)替代
    javax.management.monitor.StringMonitorMBean.getDerivedGauge()
    截至JMX 1.2，由StringMonitorMBean.getDerivedGauge(ObjectName)替代
    javax.management.monitor.CounterMonitor.getDerivedGaugeTimeStamp()
    截至JMX 1.2，由CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)取代
    javax.management.monitor.CounterMonitorMBean.getDerivedGaugeTimeStamp()
    截至JMX 1.2，由CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)替代
    javax.management.monitor.GaugeMonitor.getDerivedGaugeTimeStamp()
    截至JMX 1.2，由GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)替代
    javax.management.monitor.GaugeMonitorMBean.getDerivedGaugeTimeStamp()
    截至JMX 1.2，由GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)替代
    javax.management.monitor.StringMonitor.getDerivedGaugeTimeStamp()
    截至JMX 1.2，由StringMonitor.getDerivedGaugeTimeStamp(ObjectName)替代
    javax.management.monitor.StringMonitorMBean.getDerivedGaugeTimeStamp()
    截至JMX 1.2，由StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)取代
    javax.swing.plaf.basic.BasicSplitPaneUI.getDividerBorderSize()
    从Java 2平台v1.3开始，将边框设置在分隔线上。
    javax.xml.bind.Validator.getEventHandler()
    自JAXB2.0起
    java.awt.Toolkit.getFontList()
    见GraphicsEnvironment.getAvailableFontFamilyNames()
    java.awt.Toolkit.getFontMetrics(Font)
    截至JDK 1.2版，由Font方法getLineMetrics 。
    javax.swing.text.LabelView.getFontMetrics()
    在JDK中运行时，FontMetrics不用于字形渲染。
    java.sql.Date.getHours()
    java.util.Date.getHours()
    从JDK 1.1版开始，替换为Calendar.get(Calendar.HOUR_OF_DAY) 。
    java.lang.SecurityManager.getInCheck()
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.rmi.server.RemoteCall.getInputStream()
    没有替换
    java.awt.event.KeyEvent.getKeyModifiersText(int)
    建议使用扩展修饰键和InputEvent.getModifiersExText(int)
    javax.swing.KeyStroke.getKeyStroke(char, boolean)
    使用getKeyStroke（char）
    javax.swing.AbstractButton.getLabel()
    - 替换为getText
    javafx.scene.media.AudioTrack.getLanguage()
    改用Track.getLocale() 。
    java.awt.Scrollbar.getLineIncrement()
    从JDK 1.1版开始，由getUnitIncrement()替代。
    java.lang.Runtime.getLocalizedInputStream(InputStream)
    从JDK 1.1开始，将本地编码中的字节流转换为Unicode中的字符流的首选方法是通过InputStreamReader和BufferedReader类。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.Runtime.getLocalizedOutputStream(OutputStream)
    从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。
    java.util.logging.LogManager.getLoggingMXBean()
    java.util.logging.LoggingMXBean已被弃用，替换为java.lang.management.PlatformLoggingMXBean 。 请改用ManagementFactory.getPlatformMXBean （PlatformLoggingMXBean.class）。
    java.sql.DriverManager.getLogStream()
    使用getLogWriter
    java.awt.FontMetrics.getMaxDecent()
    自JDK 1.1.1版起，由getMaxDescent()替代。
    javax.swing.JInternalFrame.getMenuBar()
    截至Swing 1.0.3版本，由getJMenuBar()替代。
    javax.swing.JRootPane.getMenuBar()
    从Swing版本1.0.3替换为getJMenuBar() 。
    java.sql.Date.getMinutes()
    java.util.Date.getMinutes()
    从JDK 1.1版开始，由Calendar.get(Calendar.MINUTE)替代。
    java.awt.event.InputEvent.getModifiers()
    建议使用扩展修饰键和InputEvent.getModifiersEx()
    java.sql.Time.getMonth()
    java.util.Date.getMonth()
    从JDK 1.1版开始，替换为Calendar.get(Calendar.MONTH) 。
    javax.swing.JComponent.getNextFocusableComponent()
    截至1.4，由FocusTraversalPolicy取代。
    javafx.scene.control.TreeTableView.getNodeLevel(TreeItem<?>)
    此方法无法正确计算从给定TreeItem到TreeTableView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeTableView.getTreeItemLevel(TreeItem)
    javafx.scene.control.TreeView.getNodeLevel(TreeItem<?>)
    此方法无法正确计算从给定TreeItem到TreeView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeView.getTreeItemLevel(TreeItem)
    javax.management.monitor.Monitor.getObservedObject()
    截至JMX 1.2，由Monitor.getObservedObjects()替代
    javax.management.monitor.MonitorMBean.getObservedObject()
    截至JMX 1.2，由MonitorMBean.getObservedObjects()取代
    java.rmi.server.Operation.getOperation()
    没有替换
    java.rmi.server.Skeleton.getOperations()
    没有替换
    java.awt.ComponentOrientation.getOrientation(ResourceBundle)
    从J2SE 1.4开始，使用ComponentOrientation.getOrientation(java.util.Locale) 。
    java.rmi.server.LogStream.getOutputStream()
    没有替换
    java.rmi.server.RemoteCall.getOutputStream()
    没有替换
    java.lang.ClassLoader.getPackage(String)
    如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅公开由父加载程序定义的package-info.class文件中的注释，即使子载入程序定义的package-info.class文件中存在注释。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
    java.lang.Package.getPackage(String)
    如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使子载入程序定义的package-info.class文件中存在注释。 更强大的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
    java.awt.Scrollbar.getPageIncrement()
    自JDK 1.1版起，由getBlockIncrement()替代。
    java.security.Signature.getParameter(String)
    javax.net.ssl.HandshakeCompletedEvent.getPeerCertificateChain()
    应该使用返回java.security.cert.Certificate数组的HandshakeCompletedEvent.getPeerCertificates()方法。
    javax.net.ssl.SSLSession.getPeerCertificateChain()
    该SSLSession.getPeerCertificates()方法返回的数组java.security.cert.Certificate应改为使用。
    javax.swing.text.Utilities.getPositionAbove(JTextComponent, int, int)
    替换为Utilities.getPositionAbove(JTextComponent, int, float)
    javax.swing.text.Utilities.getPositionBelow(JTextComponent, int, int)
    替换为Utilities.getPositionBelow(JTextComponent, int, float)
    javax.xml.bind.Validator.getProperty(String)
    自JAXB2.0起
    java.lang.reflect.Proxy.getProxyClass(ClassLoader, Class<?>...)
    在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在不可访问的代理类上调用时抛出IllegalAccessException 。 使用Proxy.newProxyInstance(ClassLoader, Class[], InvocationHandler)创建代理实例。
    java.rmi.server.RemoteCall.getResultStream(boolean)
    没有替换
    java.sql.Date.getSeconds()
    java.util.Date.getSeconds()
    从JDK 1.1版开始，由Calendar.get(Calendar.SECOND)代替。
    java.rmi.server.LoaderHandler.getSecurityContext(ClassLoader)
    没有替换
    java.rmi.server.RMIClassLoader.getSecurityContext(ClassLoader)
    没有替换。 从Java 2平台v1.2开始，RMI不再使用此方法来获取类加载器的安全上下文。
    javax.swing.JList.getSelectedValues()
    截至JDK 1.7，由JList.getSelectedValuesList()替代
    javax.tools.ToolProvider.getSystemToolClassLoader()
    此方法在将来的Java SE版本中可能会被删除。 使用system tool provider或service loader机制来定位系统工具以及用户安装的工具。
    javax.swing.text.Utilities.getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int)
    取代Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)
    javax.swing.text.Utilities.getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int, boolean)
    替换为Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)
    javax.swing.text.Utilities.getTabbedTextWidth(Segment, FontMetrics, int, TabExpander, int)
    取代Utilities.getTabbedTextWidth(Segment, FontMetrics, float, TabExpander, int)
    javax.swing.JPasswordField.getText()
    从Java 2平台v1.2开始，由getPassword替代。
    javax.swing.JPasswordField.getText(int, int)
    从Java 2平台v1.2开始，由getPassword代替。
    javax.management.monitor.CounterMonitor.getThreshold()
    截至JMX 1.2，由CounterMonitor.getThreshold(ObjectName)替代
    javax.management.monitor.CounterMonitorMBean.getThreshold()
    截至JMX 1.2，由CounterMonitorMBean.getThreshold(ObjectName)替代
    java.util.Date.getTimezoneOffset()
    自JDK 1.1版起，由-(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000)替代。
    javax.swing.plaf.TextUI.getToolTipText(JTextComponent, Point)
    取代TextUI.getToolTipText2D(JTextComponent, Point2D)
    java.net.DatagramSocketImpl.getTTL()
    使用getTimeToLive代替。
    java.net.MulticastSocket.getTTL()
    使用getTimeToLive方法，它返回一个int而不是一个字节 。
    java.sql.ResultSet.getUnicodeStream(int)
    使用getCharacterStream代替getUnicodeStream
    java.sql.ResultSet.getUnicodeStream(String)
    改用getCharacterStream
    java.security.Provider.getVersion()
    改用Provider.getVersionStr() 。
    javax.swing.ScrollPaneLayout.getViewportBorderBounds(JScrollPane)
    由JDK版本Swing1.1替换为JScrollPane.getViewportBorderBounds() 。
    java.awt.Scrollbar.getVisible()
    从JDK 1.1版开始，由getVisibleAmount()替代。
    javafx.application.HostServices.getWebContext()
    此方法自JDK 9起已被弃用，因为不推荐使用Applet API。
    netscape.javascript.JSObject.getWindow(Applet)
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    java.sql.Time.getYear()
    java.util.Date.getYear()
    从JDK 1.1版开始，由Calendar.get(Calendar.YEAR) - 1900替换。
    java.awt.Component.gotFocus(Event, Object)
    从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
    java.awt.Component.handleEvent(Event)
    从JDK版本1.1替换为processEvent（AWTEvent）。
    java.awt.Component.hide()
    从JDK 1.1版开始，由setVisible(boolean)替代。
    java.awt.Dialog.hide()
    自JDK版本1.5起，由setVisible(boolean)替代。
    java.awt.Window.hide()
    从JDK版本1.5开始，由Window.setVisible(boolean)替代。
    javax.swing.JComponent.hide()
    com.sun.javadoc.ClassDoc.importedClasses()
    导入声明是不应该在这里公开的实现细节。 另外，并不是所有导入的类都是通过单一类型导入的声明导入的。
    com.sun.javadoc.ClassDoc.importedPackages()
    导入声明是不应该在这里公开的实现细节。 此外，此方法的返回类型不允许返回所有类型导入按需的声明。
    java.lang.SecurityManager.inClass(String)
    不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.SecurityManager.inClassLoader()
    不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
    org.omg.CORBA.Any.insert_Principal(Principal)
    被CORBA弃用2.2。
    javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag)
    从Java 2平台v1.3开始，使用insertAtBoundary
    java.awt.TextArea.insertText(String, int)
    从JDK 1.1版开始，由insert(String, int)代替。
    java.awt.Container.insets()
    自JDK 1.1版起，由getInsets()取代。
    java.awt.Component.inside(int, int)
    从JDK 1.1版开始，由contains（int，int）替换。
    java.awt.Polygon.inside(int, int)
    从JDK 1.1版开始，由contains(int, int)替代。
    java.awt.Rectangle.inside(int, int)
    从JDK 1.1版开始，由contains(int, int)替代。
    java.beans.Beans.instantiate(ClassLoader, String, BeanContext, AppletInitializer)
    建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    java.rmi.server.RemoteRef.invoke(RemoteCall)
    1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
    org.omg.CORBA.DynamicImplementation.invoke(ServerRequest)
    便携式对象适配器已弃用
    java.lang.reflect.AccessibleObject.isAccessible()
    此方法已被弃用，因为它的名称提示它检查反射对象是否可访问，当它实际指示是否抑制对Java语言访问控制的检查。 此方法可能会在调用者可访问的反射对象上返回false 。 要测试此反射对象是否可访问，应使用AccessibleObject.canAccess(Object) 。
    javax.swing.JViewport.isBackingStoreEnabled()
    从Java 2平台v1.3开始，由getScrollMode()代替。
    javax.swing.FocusManager.isFocusManagerEnabled()
    截至1.4，由KeyboardFocusManager.getDefaultFocusTraversalPolicy()取代
    java.awt.Component.isFocusTraversable()
    截至1.4，由isFocusable()替代。
    java.lang.Character.isJavaLetter(char)
    替换为isJavaIdentifierStart（char）。
    java.lang.Character.isJavaLetterOrDigit(char)
    由isJavaIdentifierPart（char）替代。
    javax.swing.JComponent.isManagingFocus()
    截至1.4，由Component.setFocusTraversalKeys(int, Set)和Container.setFocusCycleRoot(boolean)取代。
    java.awt.List.isSelected(int)
    从JDK 1.1版开始，由isIndexSelected(int)替代。
    java.lang.Character.isSpace(char)
    替换为isWhitespace（char）。
    java.rmi.dgc.VMID.isUnique()
    javax.xml.bind.Unmarshaller.isValidating()
    由于JAXB2.0 ，请参阅Unmarshaller.getSchema()
    java.awt.Component.keyDown(Event, int)
    从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
    java.awt.Component.keyUp(Event, int)
    从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
    java.awt.Component.layout()
    从JDK 1.1版开始，由doLayout()替代。
    java.awt.Container.layout()
    从JDK 1.1版开始，由doLayout()替代。
    java.awt.ScrollPane.layout()
    从JDK 1.1版开始，由doLayout()替代。
    java.rmi.server.LoaderHandler.loadClass(String)
    没有替换
    java.rmi.server.LoaderHandler.loadClass(URL, String)
    没有替换
    java.rmi.server.RMIClassLoader.loadClass(String)
    替换为loadClass(String,String)方法
    javafx.fxml.FXMLLoader.loadType(String)
    此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
    javafx.fxml.FXMLLoader.loadType(String, String)
    此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
    java.awt.Component.locate(int, int)
    从JDK 1.1版开始，由getComponentAt（int，int）替换。
    java.awt.Container.locate(int, int)
    从JDK 1.1版开始，由getComponentAt(int, int)替代。
    java.awt.Component.location()
    从JDK 1.1版开始，由getLocation()替代。
    java.rmi.server.LogStream.log(String)
    没有替换
    java.util.logging.Logger.logrb(Level, String, String, String, String)
    改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
    java.util.logging.Logger.logrb(Level, String, String, String, String, Object)
    改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)
    java.util.logging.Logger.logrb(Level, String, String, String, String, Object[])
    改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
    java.util.logging.Logger.logrb(Level, String, String, String, String, Throwable)
    改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。
    java.awt.Component.lostFocus(Event, Object)
    从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
    java.awt.Component.minimumSize()
    从JDK 1.1版开始，由getMinimumSize()替代。
    java.awt.Container.minimumSize()
    从JDK 1.1版开始，由getMinimumSize()替代。
    java.awt.List.minimumSize()
    从JDK 1.1版开始，由getMinimumSize()替代。
    java.awt.List.minimumSize(int)
    从JDK 1.1版开始，由getMinimumSize(int)替代。
    java.awt.TextArea.minimumSize()
    从JDK 1.1版开始，由getMinimumSize()替代。
    java.awt.TextArea.minimumSize(int, int)
    从JDK 1.1版开始，由getMinimumSize(int, int)替代。
    java.awt.TextField.minimumSize()
    从JDK 1.1版开始，由getMinimumSize()替代。
    java.awt.TextField.minimumSize(int)
    从JDK 1.1版开始，由getMinimumSize(int)替代。
    javax.swing.plaf.basic.BasicTextUI.modelToView(JTextComponent, int)
    取代BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
    javax.swing.plaf.basic.BasicTextUI.modelToView(JTextComponent, int, Position.Bias)
    替换为BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
    javax.swing.plaf.multi.MultiTextUI.modelToView(JTextComponent, int)
    取代MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)
    javax.swing.plaf.multi.MultiTextUI.modelToView(JTextComponent, int, Position.Bias)
    由MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)代替
    javax.swing.plaf.TextUI.modelToView(JTextComponent, int)
    替换为TextUI.modelToView2D(JTextComponent, int, Position.Bias)
    javax.swing.plaf.TextUI.modelToView(JTextComponent, int, Position.Bias)
    取代TextUI.modelToView2D(JTextComponent, int, Position.Bias)
    javax.swing.text.JTextComponent.modelToView(int)
    替换为JTextComponent.modelToView2D(int)
    javax.swing.text.View.modelToView(int, Shape)
    java.awt.Component.mouseDown(Event, int, int)
    从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
    java.awt.Component.mouseDrag(Event, int, int)
    从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
    java.awt.Component.mouseEnter(Event, int, int)
    从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
    java.awt.Component.mouseExit(Event, int, int)
    从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
    java.awt.Component.mouseMove(Event, int, int)
    从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
    java.awt.Component.mouseUp(Event, int, int)
    从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
    java.awt.Component.move(int, int)
    从JDK 1.1版开始，由setLocation(int, int)替代。
    java.awt.Rectangle.move(int, int)
    从JDK 1.1版开始，替换为setLocation(int, int) 。
    javafx.util.Duration.multiply(Duration)
    这种方法通过不考虑单位产生令人惊讶的结果。 改用Duration.multiply(double) 。
    org.omg.CORBA.Principal.name()
    被CORBA弃用2.2。
    org.omg.CORBA.Principal.name(byte[])
    被CORBA弃用2.2。
    java.rmi.server.RemoteRef.newCall(RemoteObject, Operation[], int, long)
    1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
    javax.xml.stream.XMLInputFactory.newFactory()
    java.lang.Class.newInstance()
    此方法传播由nullary构造函数抛出的任何异常，包括已检查的异常。 使用此方法有效地绕过编译器异常检查，否则将由编译器执行。 Constructor.newInstance方法通过将构造函数抛出的任何异常包装在（已检查）的InvocationTargetException中来避免此问题。

    电话

       clazz.newInstance()
    可以替换
       clazz.getDeclaredConstructor().newInstance()
    推断后一个调用序列能够抛出额外的异常类型InvocationTargetException和NoSuchMethodException 。 这两个异常类型都是ReflectiveOperationException的子类。
    javax.xml.stream.XMLEventFactory.newInstance(String, ClassLoader)
    该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替换XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
    javax.xml.stream.XMLInputFactory.newInstance(String, ClassLoader)
    该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替换XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
    javax.xml.stream.XMLOutputFactory.newInstance(String, ClassLoader)
    此方法已被弃用，因为它返回一个XMLInputFactory的实例，该实例是错误的类。 改用新的方法XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) 。
    java.awt.Component.nextFocus()
    从JDK 1.1版开始，由transferFocus（）替换。
    java.awt.datatransfer.DataFlavor.normalizeMimeType(String)
    此方法从1.1开始就不会被此实现所调用
    javax.activation.ActivationDataFlavor.normalizeMimeType(String)
    java.awt.datatransfer.DataFlavor.normalizeMimeTypeParameter(String, String)
    此方法从1.1开始就不会被此实现所调用
    javax.activation.ActivationDataFlavor.normalizeMimeTypeParameter(String, String)
    javax.swing.tree.DefaultTreeSelectionModel.notifyPathChange(Vector<?>, TreePath)
    从JDK版本1.7开始
    org.omg.CORBA.ServerRequest.op_name()
    使用操作（）
    org.omg.CORBA.ServerRequest.params(NVList)
    使用方法arguments
    java.util.Date.parse(String)
    截至JDK 1.1版，由DateFormat.parse(String s)取代。
    java.rmi.server.LogStream.parseLevel(String)
    没有替换
    java.awt.Component.postEvent(Event)
    从JDK 1.1版开始，由dispatchEvent（AWTEvent）替换。
    java.awt.MenuComponent.postEvent(Event)
    从JDK 1.1版开始，由dispatchEvent替代。
    java.awt.MenuContainer.postEvent(Event)
    由JDK版本1.1替换为dispatchEvent（AWTEvent）。
    java.awt.Window.postEvent(Event)
    由JDK版本1.1替换为dispatchEvent(AWTEvent) 。
    java.awt.image.renderable.RenderContext.preConcetenateTransform(AffineTransform)
    替换为preConcatenateTransform(AffineTransform) 。
    java.awt.Component.preferredSize()
    从JDK 1.1版开始，由getPreferredSize()替代。
    java.awt.Container.preferredSize()
    自JDK 1.1版起，由getPreferredSize()替代。
    java.awt.List.preferredSize()
    从JDK 1.1版开始，由getPreferredSize()替代。
    java.awt.List.preferredSize(int)
    从JDK 1.1版开始，由getPreferredSize(int)替代。
    java.awt.TextArea.preferredSize()
    从JDK 1.1版开始，由getPreferredSize()替代。
    java.awt.TextArea.preferredSize(int, int)
    从JDK 1.1版开始，由getPreferredSize(int, int)替代。
    java.awt.TextField.preferredSize()
    从JDK 1.1版开始，由getPreferredSize()替代。
    java.awt.TextField.preferredSize(int)
    从JDK 1.1版开始，由getPreferredSize(int)替代。
    org.omg.CORBA.portable.InputStream.read_Principal()
    被CORBA弃用2.2。
    java.io.DataInputStream.readLine()
    此方法无法将字节正确转换为字符。 从JDK 1.1开始，读取文本行的首选方式是通过BufferedReader.readLine()方法。 使用DataInputStream类读取行的程序可以转换为使用BufferedReader类替换以下形式的代码：
         DataInputStream d = new DataInputStream(in);
    有：
         BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
    java.io.ObjectInputStream.readLine()
    此方法无法将字节正确转换为字符。 有关详细信息和替代方案，请参阅DataInputStream。
    java.awt.AWTKeyStroke.registerSubclass(Class<?>)
    java.rmi.registry.RegistryHandler.registryImpl(int)
    没有替换。 从Java 2平台v1.2起，RMI不再使用RegistryHandler获取注册表的实现。
    java.rmi.registry.RegistryHandler.registryStub(String, int)
    没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler获取注册表的存根。
    java.rmi.server.RemoteCall.releaseInputStream()
    没有替换
    java.rmi.server.RemoteCall.releaseOutputStream()
    没有替换
    javax.swing.plaf.metal.MetalComboBoxUI.removeListeners()
    从Java 2平台v1.4开始。
    java.awt.TextArea.replaceText(String, int, int)
    从JDK 1.1版开始，由replaceRange(String, int, int)替代。
    javax.swing.JComponent.requestDefaultFocus()
    截至1.4，由FocusTraversalPolicy.getDefaultComponent(Container).requestFocus()取代
    java.awt.Component.reshape(int, int, int, int)
    从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
    java.awt.Rectangle.reshape(int, int, int, int)
    从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
    java.awt.Window.reshape(int, int, int, int)
    从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
    javax.swing.JComponent.reshape(int, int, int, int)
    截至JDK 5，由Component.setBounds(int, int, int, int)取代。

    移动并调整此组件的大小。

    java.awt.Component.resize(int, int)
    从JDK 1.1版开始，由setSize(int, int)替代。
    java.awt.Component.resize(Dimension)
    自JDK 1.1版起，由setSize(Dimension)取代。
    java.awt.Rectangle.resize(int, int)
    从JDK 1.1版开始，由setSize(int, int)替代。
    org.omg.CORBA.ServerRequest.result(Any)
    使用方法set_result
    java.lang.Thread.resume()
    该方法仅供Thread.suspend()使用，由于它是易死的 ，因此已被弃用。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
    java.lang.ThreadGroup.resume()
    该方法仅与Thread.suspend和ThreadGroup.suspend结合使用，因为它们本身就是非常容易死锁的。 详见Thread.suspend() 。
    java.lang.Runtime.runFinalizersOnExit(boolean)
    这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.System.runFinalizersOnExit(boolean)
    这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
    java.util.Properties.save(OutputStream, String)
    如果在保存属性列表时发生I / O错误，此方法不会抛出IOException。 保存属性列表的首选方法是通过store(OutputStream out, String comments)方法或storeToXML(OutputStream os, String comment)方法。
    java.net.MulticastSocket.send(DatagramPacket, byte)
    使用以下代码或其等价物：...... int ttl = mcastSocket.getTimeToLive（）;
mcastSocket.setTimeToLive（newttl）;
mcastSocket.send（P）;
mcastSocket.setTimeToLive（TTL）;
......
    javafx.css.CssMetaData.set(S, V, StyleOrigin)
    此方法不再从CSS代码调用。 使用StyleableProperty.applyStyle(javafx.css.StyleOrigin, java.lang.Object)
    javax.swing.JViewport.setBackingStoreEnabled(boolean)
    从Java 2平台v1.3开始，由setScrollMode()替代。
    java.awt.CheckboxGroup.setCurrent(Checkbox)
    从JDK 1.1版开始，由setSelectedCheckbox(Checkbox)取代。
    java.awt.Frame.setCursor(int)
    从JDK 1.1版开始，由Component.setCursor(Cursor)取代。
    java.sql.Time.setDate(int)
    java.util.Date.setDate(int)
    截至JDK 1.1版，由Calendar.set(Calendar.DAY_OF_MONTH, int date)取代。
    java.net.URLConnection.setDefaultRequestProperty(String, String)
    在获得适当的URLConnection实例之后，应该使用实例特定的setRequestProperty方法。 调用此方法将不起作用。
    java.rmi.server.LogStream.setDefaultStream(PrintStream)
    没有替换
    java.awt.TextField.setEchoCharacter(char)
    从JDK 1.1版开始，由setEchoChar(char)替代。
    javax.xml.bind.Validator.setEventHandler(ValidationEventHandler)
    自JAXB2.0起
    java.sql.Date.setHours(int)
    java.util.Date.setHours(int)
    从JDK 1.1版开始，由Calendar.set(Calendar.HOUR_OF_DAY, int hours)替代。
    javax.swing.AbstractButton.setLabel(String)
    - 由setText(text)
    java.awt.Scrollbar.setLineIncrement(int)
    从JDK 1.1版开始，由setUnitIncrement(int)替代。
    java.sql.DriverManager.setLogStream(PrintStream)
    使用setLogWriter
    javax.management.AttributeValueExp.setMBeanServer(MBeanServer)
    此方法无效。 用于获取属性值的MBean Server为QueryEval.getMBeanServer() 。
    javax.management.StringValueExp.setMBeanServer(MBeanServer)
    javax.management.ValueExp.setMBeanServer(MBeanServer)
    不需要此方法，因为ValueExp可以访问在其中它被通过使用评估的MBean服务器QueryEval.getMBeanServer() 。
    javax.swing.JInternalFrame.setMenuBar(JMenuBar)
    从Swing版本1.0.3替换为setJMenuBar(JMenuBar m) 。
    javax.swing.JRootPane.setMenuBar(JMenuBar)
    从Swing版本1.0.3替换为setJMenuBar(JMenuBar menu) 。
    java.util.logging.LogRecord.setMillis(long)
    LogRecord使用Instant值维护纳秒分辨率的时间戳。 因此， setInstant()应优先于setMillis() 。
    java.sql.Date.setMinutes(int)
    java.util.Date.setMinutes(int)
    从JDK 1.1版开始，由Calendar.set(Calendar.MINUTE, int minutes)替代。
    java.awt.event.KeyEvent.setModifiers(int)
    截至JDK1.1.4
    java.sql.Time.setMonth(int)
    java.util.Date.setMonth(int)
    从JDK 1.1版开始，由Calendar.set(Calendar.MONTH, int month)替代。
    java.awt.List.setMultipleSelections(boolean)
    从JDK 1.1版开始，由setMultipleMode(boolean)替代。
    javax.swing.JComponent.setNextFocusableComponent(Component)
    截至1.4，由FocusTraversalPolicy替代
    javax.management.monitor.Monitor.setObservedObject(ObjectName)
    截至JMX 1.2，由Monitor.addObservedObject(javax.management.ObjectName)替代
    javax.management.monitor.MonitorMBean.setObservedObject(ObjectName)
    截至JMX 1.2，由MonitorMBean.addObservedObject(javax.management.ObjectName)替代
    java.rmi.server.LogStream.setOutputStream(OutputStream)
    没有替换
    java.awt.Scrollbar.setPageIncrement(int)
    从JDK 1.1版开始，由setBlockIncrement()替代。
    java.security.Signature.setParameter(String, Object)
    使用setParameter 。
    javax.xml.bind.Validator.setProperty(String, Object)
    自JAXB2.0起
    java.rmi.server.RemoteStub.setRef(RemoteStub, RemoteRef)
    没有替换 setRef方法用于设置远程存根的远程引用。 这是不必要的，因为RemoteStub可以创建和通过使用的远程引用初始化小号RemoteStub(RemoteRef)构造。
    java.math.BigDecimal.setScale(int, int)
    应该优先使用方法BigDecimal.setScale(int, RoundingMode) 。
    java.sql.Date.setSeconds(int)
    java.util.Date.setSeconds(int)
    从JDK 1.1版开始，由Calendar.set(Calendar.SECOND, int seconds)替代。
    javax.management.monitor.CounterMonitor.setThreshold(Number)
    截至JMX 1.2，由CounterMonitor.setInitThreshold(java.lang.Number)取代
    javax.management.monitor.CounterMonitorMBean.setThreshold(Number)
    截至JMX 1.2，由CounterMonitorMBean.setInitThreshold(java.lang.Number)取代
    java.net.DatagramSocketImpl.setTTL(byte)
    使用setTimeToLive代替。
    java.net.MulticastSocket.setTTL(byte)
    使用setTimeToLive方法，它使用int而不是byte作为ttl的类型。
    java.sql.PreparedStatement.setUnicodeStream(int, InputStream, int)
    使用setCharacterStream
    javax.sql.rowset.BaseRowSet.setUnicodeStream(int, InputStream, int)
    getCharacterStream应该用于它的位置
    java.net.URLStreamHandler.setURL(URL, String, String, int, String, String)
    使用setURL（URL，String，String，int，String，String，String，String）;
    javax.xml.bind.Unmarshaller.setValidating(boolean)
    由于JAXB2.0 ，请参阅Unmarshaller.setSchema(javax.xml.validation.Schema)
    java.sql.Time.setYear(int)
    java.util.Date.setYear(int)
    从JDK 1.1版开始，由Calendar.set(Calendar.YEAR, year + 1900)替代。
    javax.swing.InputVerifier.shouldYieldFocus(JComponent)
    请改用InputVerifier.shouldYieldFocus(JComponent, JComponent) 。
    java.awt.Component.show()
    从JDK 1.1版开始，由setVisible(boolean)代替。
    java.awt.Component.show(boolean)
    从JDK 1.1版开始，由setVisible(boolean)替代。
    java.awt.Dialog.show()
    从JDK版本1.5开始，替换为setVisible(boolean) 。
    java.awt.Window.show()
    从JDK版本1.5开始，由Window.setVisible(boolean)代替。
    java.awt.Component.size()
    从JDK 1.1版开始，由getSize()替代。
    javax.swing.JTable.sizeColumnsToFit(boolean)
    截至Swing 1.0.3版本，由doLayout()替代。
    javafx.scene.control.SkinBase.snapPosition(double)
    由snapPositionX()和snapPositionY()取代
    javafx.scene.layout.Region.snapPosition(double)
    替换为snapPositionX()和snapPositionY()
    javafx.scene.control.SkinBase.snapSize(double)
    替换为snapSizeX()和snapSizeY()
    javafx.scene.layout.Region.snapSize(double)
    替换为snapSizeX()和snapSizeY()
    javafx.scene.control.SkinBase.snapSpace(double)
    替换为snapSpaceX()和snapSpaceY()
    javafx.scene.layout.Region.snapSpace(double)
    由snapSpaceX()和snapSpaceY()取代
    java.lang.Thread.stop()
    这种方法本质上是不安全的。 使用Thread.stop停止线程可以解锁所有已锁定的监视器（作为未经检查的ThreadDeath异常在堆栈中传播的自然结果）。 如果先前受这些监视器保护的任何对象处于不一致的状态，则损坏的对象将变得对其他线程可见，可能导致任意行为。 stop许多用途应该被代替，只需修改一些变量来指示目标线程应该停止运行。 目标线程应该定期检查此变量，如果变量表示要停止运行，则以有序方式从其运行方法返回。 如果目标线程长时间等待（例如，在条件变量上），则应使用interrupt方法来中断等待。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
    java.lang.Thread.stop(Throwable)
    此方法最初设计为强制线程停止并抛出给定的Throwable作为例外。 它本质上是不安全的（有关详细信息，请参阅Thread.stop() ），此外还可用于生成目标线程未准备处理的异常。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.ThreadGroup.stop()
    这种方法本质上是不安全的。 详见Thread.stop() 。
    java.lang.Thread.suspend()
    这种方法已被弃用，因为它本身就是死锁的。 如果目标线程在挂起时保护关键系统资源的监视器上的锁定，则在目标线程恢复之前，线程不能访问该资源。 如果要恢复目标线程的线程尝试在调用resume之前锁定此监视器， resume导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
    java.lang.ThreadGroup.suspend()
    这种方法本质上是死锁的。 详见Thread.suspend() 。
    java.util.Date.toGMTString()
    从JDK 1.1版开始，用DateFormat.format(Date date)替代，使用GMT TimeZone 。
    java.util.Date.toLocaleString()
    截至JDK 1.1版，由DateFormat.format(Date date)取代。
    jdk.nashorn.api.scripting.AbstractJSObject.toNumber()
    使用JSObject.getDefaultValue(Class)与Number提示相反。
    jdk.nashorn.api.scripting.JSObject.toNumber()
    使用JSObject.getDefaultValue(Class)与Number提示相反。
    jdk.nashorn.api.scripting.ScriptObjectMirror.toNumber()
    java.io.ByteArrayOutputStream.toString(int)
    此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过toString(String enc)方法，该方法采用encoding-name参数，或toString()方法，该方法使用平台的默认字符编码。
    java.rmi.server.LogStream.toString()
    没有替换
    java.rmi.server.Operation.toString()
    没有替换
    java.io.File.toURL()
    此方法不会自动转义URL中非法的字符。 建议在新的代码转换的抽象路径到URL通过先转换成URI，经由toURI方法，然后经由转换URI为URL URI.toURL方法。
    java.lang.Runtime.traceInstructions(boolean)
    该方法旨在控制指令跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
    java.lang.Runtime.traceMethodCalls(boolean)
    此方法旨在控制方法调用跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
    javax.swing.plaf.metal.MetalScrollPaneUI.uninstallListeners(JScrollPane)
    - 替换为MetalScrollPaneUI.uninstallListeners(JComponent)
    java.util.Date.UTC(int, int, int, int, int, int)
    从JDK 1.1版开始，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec) ，使用UTC TimeZone ，其次是Calendar.getTime().getTime() 。
    javax.xml.bind.Validator.validate(Object)
    自JAXB2.0起
    javax.xml.bind.Validator.validateRoot(Object)
    自JAXB2.0起
    javax.swing.plaf.basic.BasicTextUI.viewToModel(JTextComponent, Point)
    取代BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
    javax.swing.plaf.basic.BasicTextUI.viewToModel(JTextComponent, Point, Position.Bias[])
    替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
    javax.swing.plaf.multi.MultiTextUI.viewToModel(JTextComponent, Point)
    javax.swing.plaf.multi.MultiTextUI.viewToModel(JTextComponent, Point, Position.Bias[])
    javax.swing.plaf.TextUI.viewToModel(JTextComponent, Point)
    取代TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
    javax.swing.plaf.TextUI.viewToModel(JTextComponent, Point, Position.Bias[])
    替换为TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
    javax.swing.text.JTextComponent.viewToModel(Point)
    取代JTextComponent.viewToModel2D(Point2D)
    javax.swing.text.View.viewToModel(float, float, Shape)
    java.util.concurrent.atomic.AtomicBoolean.weakCompareAndSet(boolean, boolean)
    该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicBoolean.compareAndExchange(boolean, boolean)和AtomicBoolean.compareAndSet(boolean, boolean) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicBoolean.weakCompareAndSetPlain(boolean, boolean) 。
    java.util.concurrent.atomic.AtomicInteger.weakCompareAndSet(int, int)
    该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicInteger.compareAndExchange(int, int)和AtomicInteger.compareAndSet(int, int) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法AtomicInteger.weakCompareAndSetPlain(int, int) 。
    java.util.concurrent.atomic.AtomicIntegerArray.weakCompareAndSet(int, int, int)
    该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicIntegerArray.compareAndExchange(int, int, int)和AtomicIntegerArray.compareAndSet(int, int, int) ）。 为了避免在平常或易失性记忆效应上的混淆，建议使用方法AtomicIntegerArray.weakCompareAndSetPlain(int, int, int) 。
    java.util.concurrent.atomic.AtomicLong.weakCompareAndSet(long, long)
    该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicLong.compareAndExchange(long, long)和AtomicLong.compareAndSet(long, long) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicLong.weakCompareAndSetPlain(long, long) 。
    java.util.concurrent.atomic.AtomicLongArray.weakCompareAndSet(int, long, long)
    该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicLongArray.compareAndExchange(int, long, long)和AtomicLongArray.compareAndSet(int, long, long) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicLongArray.weakCompareAndSetPlain(int, long, long) 。
    java.util.concurrent.atomic.AtomicReference.weakCompareAndSet(V, V)
    该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicReference.compareAndExchange(V, V)和AtomicReference.compareAndSet(V, V) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法AtomicReference.weakCompareAndSetPlain(V, V) 。
    java.util.concurrent.atomic.AtomicReferenceArray.weakCompareAndSet(int, E, E)
    该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicReferenceArray.compareAndExchange(int, E, E)和AtomicReferenceArray.compareAndSet(int, E, E) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法AtomicReferenceArray.weakCompareAndSetPlain(int, E, E) 。
    java.io.ObjectOutputStream.PutField.write(ObjectOutput)
    此方法不会以适当的格式写入此PutField对象所包含的值，并可能导致序列化流的损坏。 写PutField数据的正确方法是通过调用ObjectOutputStream.writeFields()方法。
    java.rmi.server.LogStream.write(byte[], int, int)
    没有替换
    java.rmi.server.LogStream.write(int)
    没有替换
    org.omg.CORBA.portable.OutputStream.write_Principal(Principal)
    被CORBA弃用2.2。
  • Deprecated Constructors
    Constructor 描述
    javax.lang.model.util.AbstractAnnotationValueVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.AbstractElementVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.AbstractTypeVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.management.AttributeValueExp()
    使用此构造函数创建的实例不能在查询中使用。
    java.security.AuthProvider(String, double, String)
    改用AuthProvider(String, String, String) 。
    java.awt.AWTEvent(Event)
    建议使用AWTEvent(Object, int)
    java.lang.Boolean(boolean)
    很少使用这个构造函数。 静态工厂Boolean.valueOf(boolean)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。 还可以考虑使用最终字段Boolean.TRUE和Boolean.FALSE 。
    java.lang.Boolean(String)
    很少使用这个构造函数。 使用Boolean.parseBoolean(String)将字符串转换为boolean原语，或使用Boolean.valueOf(String)将字符串转换为Boolean对象。
    java.lang.Byte(byte)
    很少使用这个构造函数。 静态工厂Byte.valueOf(byte)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
    java.lang.Byte(String)
    很少使用这个构造函数。 使用Byte.parseByte(String)将字符串转换为byte原语，或使用Byte.valueOf(String)将字符串转换为Byte对象。
    java.lang.Character(char)
    很少使用这个构造函数。 静态工厂Character.valueOf(char)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
    java.sql.Date(int, int, int)
    而是使用构造函数Date(long date)
    java.util.Date(int, int, int)
    自JDK 1.1版起，由Calendar.set(year + 1900, month, date)或GregorianCalendar(year + 1900, month, date)取代。
    java.util.Date(int, int, int, int, int)
    自JDK 1.1版起，由Calendar.set(year + 1900, month, date, hrs, min)或GregorianCalendar(year + 1900, month, date, hrs, min)取代。
    java.util.Date(int, int, int, int, int, int)
    从JDK 1.1版开始，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec)取代。
    java.util.Date(String)
    从JDK 1.1版开始，由DateFormat.parse(String s)替代。
    java.lang.Double(double)
    很少使用这个构造函数。 静态工厂Double.valueOf(double)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
    java.lang.Double(String)
    很少使用这个构造函数。 使用Double.parseDouble(String)将字符串转换为double原语，或使用Double.valueOf(String)将字符串转换为Double对象。
    javax.lang.model.util.ElementKindVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.ElementKindVisitor6(R)
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.ElementScanner6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.ElementScanner6(R)
    第6版已经过时了 更新到访问者较新的版本级别。
    javafx.event.EventType()
    不要使用这个构造函数，因为只有一个这样的EventType可以存在
    java.lang.Float(double)
    很少使用这个构造函数。 相反，使用静态工厂方法Float.valueOf(float)方法如下： Float.valueOf((float)value) 。
    java.lang.Float(float)
    很少使用这个构造函数。 静态工厂Float.valueOf(float)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
    java.lang.Float(String)
    很少使用这个构造函数。 使用Float.parseFloat(String)将字符串转换为float原语，或使用Float.valueOf(String)将字符串转换为Float对象。
    javafx.scene.input.GestureEvent(Object, EventTarget, EventType<? extends GestureEvent>)
    不要使用这个构造函数。 构造空事件。
    javafx.scene.input.GestureEvent(EventType<? extends GestureEvent>)
    不要使用这个构造函数。 构造空事件。
    java.lang.Integer(int)
    很少使用这个构造函数。 静态工厂Integer.valueOf(int)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
    java.lang.Integer(String)
    很少使用这个构造函数。 使用Integer.parseInt(String)将字符串转换为int原语，或使用Integer.valueOf(String)将字符串转换为Integer对象。
    java.awt.event.KeyEvent(Component, int, long, int, int)
    截至JDK1.1; 改用KeyEvent(Component, int, long, int, int, char)
    java.lang.Long(long)
    很少使用这个构造函数。 静态工厂Long.valueOf(long)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
    java.lang.Long(String)
    很少使用这个构造函数。 使用Long.parseLong(String)将字符串转换为long原语，或使用Long.valueOf(String)将字符串转换为Long对象。
    java.rmi.server.Operation(String)
    没有替换
    java.security.Provider(String, double, String)
    改用Provider(String, String, String) 。
    java.rmi.RMISecurityException(String)
    没有替换
    java.rmi.RMISecurityException(String, String)
    没有替换
    java.rmi.ServerRuntimeException(String, Exception)
    没有替换
    java.lang.Short(short)
    很少使用这个构造函数。 静态工厂Short.valueOf(short)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
    java.lang.Short(String)
    很少使用这个构造函数。 使用Short.parseShort(String)将字符串转换为short原语，或使用Short.valueOf(String)将字符串转换为Short对象。
    javax.lang.model.util.SimpleAnnotationValueVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.SimpleAnnotationValueVisitor6(R)
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.SimpleElementVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.SimpleElementVisitor6(R)
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.SimpleTypeVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.SimpleTypeVisitor6(R)
    第6版已经过时了 更新到访问者较新的版本级别。
    java.rmi.server.SkeletonMismatchException(String)
    没有替换
    java.net.Socket(String, int, boolean)
    使用DatagramSocket代替UDP传输。
    java.net.Socket(InetAddress, int, boolean)
    使用DatagramSocket代替UDP传输。
    java.io.StreamTokenizer(InputStream)
    从JDK版本1.1开始，将输入流标记化的首选方法是将其转换为字符流，例如：
       Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
    java.lang.String(byte[], int)
    此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过String构造函数获取Charset ，字符集名称，或者使用平台的默认字符集。
    java.lang.String(byte[], int, int, int)
    此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过使用Charset ，字符集名称的String构造函数，或者使用平台的默认字符集。
    org.omg.CORBA.TCKind(int)
    不要使用这个构造函数，因为这个方法应该根据OMG规范是私有的。 改用TCKind.from_int(int) 。
    java.sql.Time(int, int, int)
    使用构造函数，该构造函数需要一个毫秒值来代替此构造函数
    java.sql.Timestamp(int, int, int, int, int, int, int)
    而是使用构造函数Timestamp(long millis)
    javax.lang.model.util.TypeKindVisitor6()
    第6版已经过时了 更新到访问者较新的版本级别。
    javax.lang.model.util.TypeKindVisitor6(R)
    第6版已经过时了 更新到访问者较新的版本级别。
  • Deprecated Enum Constants
    Enum Constant 描述
    com.sun.security.jgss.InquireType.KRB5_GET_SESSION_KEY
    as of 9, replaced by InquireType.KRB5_GET_SESSION_KEY_EX which returns an instance of EncryptionKey that implements the SecretKey interface and has similar methods with KerberosKey.
  • Deprecated Annotation Type Elements
    Annotation Type Element 描述
    javax.jws.HandlerChain.name()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.activation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module java.activation

Deprecated, for removal: This API element is subject to removal in a future version.
定义JavaBean激活框架（JAF）API。

此模块可升级。

Module Graph:
Module graph for java.activation Module graph for java.activation
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.activation
      Indirect Exports
      From Packages
      java.datatransfer java.awt.datatransfer

    • Modules

      Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.activation (Java SE 9 & JDK 9 )

java.activation

Interfaces

  • CommandObject
  • DataContentHandler
  • DataContentHandlerFactory
  • DataSource

Classes

  • ActivationDataFlavor
  • CommandInfo
  • CommandMap
  • DataHandler
  • FileDataSource
  • FileTypeMap
  • MailcapCommandMap
  • MimeType
  • MimeTypeParameterList
  • MimetypesFileTypeMap
  • URLDataSource

Exceptions

  • MimeTypeParseException
  • UnsupportedDataTypeException


java.base (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.base

定义Java SE平台的基础API。
供应商：
该模块的JDK实现提供了一个jrt file system provider的实现，以枚举和读取运行时映像中的类和资源文件。 可以通过调用FileSystems.newFileSystem(URI.create("jrt:/"))创建jrt文件系统。

工具指南：
java launcher ， keytool
Module Graph:
Module graph for java.base
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.io
      通过数据流，序列化和文件系统提供系统输入和输出。
      java.lang
      提供对Java编程语言设计至关重要的类。
      java.lang.annotation
      为Java编程语言注释工具提供库支持。
      java.lang.invoke
      java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
      java.lang.module
      通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
      java.lang.ref
      提供参考对象类，它支持与垃圾收集器的有限度的交互。
      java.lang.reflect
      提供用于获取关于类和对象的反射信息的类和接口。
      java.math
      提供用于执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
      java.net
      提供实现网络应用程序的类。
      java.net.spi
      java.net包的服务提供商类。
      java.nio
      定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
      java.nio.channels
      定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
      java.nio.channels.spi
      java.nio.channels软件包的服务提供程序类。
      java.nio.charset
      定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
      java.nio.charset.spi
      java.nio.charset包的服务提供商类。
      java.nio.file
      定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
      java.nio.file.attribute
      提供访问文件和文件系统属性的接口和类。
      java.nio.file.spi
      java.nio.file包的服务提供商类。
      java.security
      提供安全框架的类和接口。
      java.security.acl
      此包中的类和接口已被弃用。
      java.security.cert
      提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
      java.security.interfaces
      提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
      java.security.spec
      提供关键规范和算法参数规范的类和接口。
      java.text
      提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
      java.text.spi
      java.text包中类的服务提供者类。
      java.time
      日期，时间，瞬间和持续时间的主要API。
      java.time.chrono
      除默认ISO之外的日历系统的通用API。
      java.time.format
      提供打印和解析日期和时间的类。
      java.time.temporal
      使用字段和单位访问日期和时间，以及日期时间调整器。
      java.time.zone
      支持时区及其规则。
      java.util
      包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
      java.util.concurrent
      实用程序类通常用于并发编程。
      java.util.concurrent.atomic
      一个小型工具包，支持单个变量上的无锁线程安全编程。
      java.util.concurrent.locks
      接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
      java.util.function
      功能界面提供了lambda表达式和方法引用的目标类型。
      java.util.jar
      提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
      java.util.regex
      匹配字符序列与正则表达式指定的模式的类。
      java.util.spi
      java.util包中类的服务提供者类。
      java.util.stream
      支持元素流功能性操作的类，例如集合上的map-reduce转换。
      java.util.zip
      提供读写标准ZIP和GZIP文件格式的类。
      javax.crypto
      提供加密操作的类和接口。
      javax.crypto.interfaces
      提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
      javax.crypto.spec
      提供关键规范和算法参数规范的类和接口。
      javax.net
      提供网络应用程序的类。
      javax.net.ssl
      为安全套接字包提供类。
      javax.security.auth
      此软件包提供了认证和授权的框架。
      javax.security.auth.callback
      该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
      javax.security.auth.login
      该包提供了一个可插拔的认证框架。
      javax.security.auth.spi
      该包提供了用于实现可插拔认证模块的接口。
      javax.security.auth.x500
      该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
      javax.security.cert
      提供公钥证书类。

    • Services

      Provides
      Type 描述
      FileSystemProvider
      文件系统的服务提供者类。
      Uses
      Type 描述
      AbstractChronology
      用于组织和识别日期的日历系统的抽象实现。
      AsynchronousChannelProvider
      用于异步通道的服务提供程序类。
      BreakIteratorProvider
      提供BreakIterator类的具体实现的服务提供者的抽象类。
      CalendarDataProvider
      服务提供商的抽象类，提供与区域相关的Calendar参数。
      CalendarNameProvider
      提供 Calendar字段值的本地化字符串表示（显示名称）的服务提供者的抽象类。
      CharsetProvider
      字符集服务提供者类。
      Chronology
      用于组织和识别日期的日历系统。
      CollatorProvider
      提供Collator类的具体实现的服务提供者的抽象类。
      ContentHandlerFactory
      该界面为内容处理程序定义了一个工厂。
      CurrencyNameProvider
      为Currency类提供本地化货币符号和显示名称的服务提供商的抽象类。
      DateFormatProvider
      提供DateFormat类的具体实现的服务提供者的抽象类。
      DateFormatSymbolsProvider
      提供DateFormatSymbols类实例的服务提供者的抽象类。
      DecimalFormatSymbolsProvider
      提供DecimalFormatSymbols类的实例的服务提供者的抽象类。
      FileSystemProvider
      文件系统的服务提供者类。
      FileTypeDetector
      用于探测文件以猜测其文件类型的文件类型检测器。
      LocaleNameProvider
      为Locale类提供本地化名称的服务提供商的抽象类。
      LoginModule
      用于认证技术提供商的服务提供者接口。
      NumberFormatProvider
      提供NumberFormat类的具体实现的服务提供者的抽象类。
      Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
      ResourceBundleControlProvider
      服务提供商的接口，提供ResourceBundle.Control的实现。
      ResourceBundleProvider
      ResourceBundleProvider是一个提供者接口，用于加载命名模块的资源束。
      SelectorProvider
      选择器和可选择通道的服务提供者类。
      System.LoggerFinder
      LoggerFinder服务负责创建，管理和配置记录器到其使用的基础框架。
      TimeZoneNameProvider
      为TimeZone类提供本地化时区名称的服务提供商的抽象类。
      ToolProvider
      一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。
      URLStreamHandlerProvider
      URL流处理程序服务提供程序类。
      ZoneRulesProvider
      提供给系统的时区规则。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.base (Java SE 9 & JDK 9 )

java.base

Interfaces

  • Acl
  • AclEntry
  • AclFileAttributeView
  • AlgorithmConstraints
  • AlgorithmParameterSpec
  • AnnotatedArrayType
  • AnnotatedElement
  • AnnotatedParameterizedType
  • AnnotatedType
  • AnnotatedTypeVariable
  • AnnotatedWildcardType
  • Annotation
  • Appendable
  • AsynchronousByteChannel
  • AsynchronousChannel
  • AttributedCharacterIterator
  • AttributeView
  • AutoCloseable
  • BaseStream
  • BasicFileAttributes
  • BasicFileAttributeView
  • BiConsumer
  • BiFunction
  • BinaryOperator
  • BiPredicate
  • BlockingDeque
  • BlockingQueue
  • BooleanSupplier
  • ByteChannel
  • Callable
  • Callback
  • CallbackHandler
  • Certificate
  • CertPathBuilderResult
  • CertPathChecker
  • CertPathParameters
  • CertPathValidatorException.Reason
  • CertPathValidatorResult
  • CertSelector
  • CertStoreParameters
  • Channel
  • CharacterIterator
  • CharSequence
  • Checksum
  • ChronoLocalDate
  • ChronoLocalDateTime
  • Chronology
  • ChronoPeriod
  • ChronoZonedDateTime
  • Cleaner.Cleanable
  • Cloneable
  • Closeable
  • Collection
  • Collector
  • Comparable
  • Comparator
  • CompletableFuture.AsynchronousCompletionTask
  • CompletionHandler
  • CompletionService
  • CompletionStage
  • ConcurrentMap
  • ConcurrentNavigableMap
  • Condition
  • Configuration.Parameters
  • Consumer
  • ContentHandlerFactory
  • CookiePolicy
  • CookieStore
  • CopyOption
  • CRLSelector
  • DatagramSocketImplFactory
  • DataInput
  • DataOutput
  • Delayed
  • Deque
  • Destroyable
  • DHKey
  • DHPrivateKey
  • DHPublicKey
  • DirectoryStream
  • DirectoryStream.Filter
  • DomainCombiner
  • DosFileAttributes
  • DosFileAttributeView
  • DoubleBinaryOperator
  • DoubleConsumer
  • DoubleFunction
  • DoublePredicate
  • DoubleStream
  • DoubleStream.Builder
  • DoubleSupplier
  • DoubleToIntFunction
  • DoubleToLongFunction
  • DoubleUnaryOperator
  • DSAKey
  • DSAKeyPairGenerator
  • DSAParams
  • DSAPrivateKey
  • DSAPublicKey
  • ECField
  • ECKey
  • ECPrivateKey
  • ECPublicKey
  • Enumeration
  • Era
  • EventListener
  • Executor
  • ExecutorService
  • Extension
  • Externalizable
  • FileAttribute
  • FileAttributeView
  • FileFilter
  • FilenameFilter
  • FileNameMap
  • FileOwnerAttributeView
  • FileStoreAttributeView
  • FileVisitor
  • Flow.Processor
  • Flow.Publisher
  • Flow.Subscriber
  • Flow.Subscription
  • Flushable
  • ForkJoinPool.ForkJoinWorkerThreadFactory
  • ForkJoinPool.ManagedBlocker
  • Formattable
  • Function
  • Future
  • GatheringByteChannel
  • GenericArrayType
  • GenericDeclaration
  • Group
  • GroupPrincipal
  • Guard
  • HandshakeCompletedListener
  • HostnameVerifier
  • IntBinaryOperator
  • IntConsumer
  • InterruptibleChannel
  • IntFunction
  • IntPredicate
  • IntStream
  • IntStream.Builder
  • IntSupplier
  • IntToDoubleFunction
  • IntToLongFunction
  • IntUnaryOperator
  • InvocationHandler
  • Iterable
  • Iterator
  • Key
  • KeyManager
  • KeySpec
  • KeyStore.Entry
  • KeyStore.Entry.Attribute
  • KeyStore.LoadStoreParameter
  • KeyStore.ProtectionParameter
  • List
  • ListIterator
  • Lock
  • LoginModule
  • LongBinaryOperator
  • LongConsumer
  • LongFunction
  • LongPredicate
  • LongStream
  • LongStream.Builder
  • LongSupplier
  • LongToDoubleFunction
  • LongToIntFunction
  • LongUnaryOperator
  • ManagerFactoryParameters
  • Map
  • Map.Entry
  • MatchResult
  • Member
  • MethodHandleInfo
  • ModuleFinder
  • ModuleReader
  • MulticastChannel
  • NavigableMap
  • NavigableSet
  • NetworkChannel
  • ObjDoubleConsumer
  • ObjectInput
  • ObjectInputFilter
  • ObjectInputFilter.FilterInfo
  • ObjectInputValidation
  • ObjectOutput
  • ObjectStreamConstants
  • ObjIntConsumer
  • ObjLongConsumer
  • Observer
  • OpenOption
  • Owner
  • Pack200.Packer
  • Pack200.Unpacker
  • ParameterizedType
  • Path
  • PathMatcher
  • PBEKey
  • Permission
  • Policy.Parameters
  • PolicyNode
  • PosixFileAttributes
  • PosixFileAttributeView
  • Predicate
  • PrimitiveIterator
  • PrimitiveIterator.OfDouble
  • PrimitiveIterator.OfInt
  • PrimitiveIterator.OfLong
  • Principal
  • PrivateKey
  • PrivilegedAction
  • PrivilegedExceptionAction
  • ProcessHandle
  • ProcessHandle.Info
  • ProtocolFamily
  • PublicKey
  • Queue
  • RandomAccess
  • Readable
  • ReadableByteChannel
  • ReadWriteLock
  • Refreshable
  • RejectedExecutionHandler
  • ResourceBundleControlProvider
  • ResourceBundleProvider
  • RSAKey
  • RSAMultiPrimePrivateCrtKey
  • RSAPrivateCrtKey
  • RSAPrivateKey
  • RSAPublicKey
  • Runnable
  • RunnableFuture
  • RunnableScheduledFuture
  • ScatteringByteChannel
  • ScheduledExecutorService
  • ScheduledFuture
  • SecretKey
  • SecureDirectoryStream
  • SecureRandomParameters
  • SeekableByteChannel
  • Serializable
  • ServiceLoader.Provider
  • Set
  • SocketImplFactory
  • SocketOption
  • SocketOptions
  • SortedMap
  • SortedSet
  • Spliterator
  • Spliterator.OfDouble
  • Spliterator.OfInt
  • Spliterator.OfLong
  • Spliterator.OfPrimitive
  • SSLSession
  • SSLSessionBindingListener
  • SSLSessionContext
  • StackWalker.StackFrame
  • Stream
  • Stream.Builder
  • Supplier
  • System.Logger
  • Temporal
  • TemporalAccessor
  • TemporalAdjuster
  • TemporalAmount
  • TemporalField
  • TemporalQuery
  • TemporalUnit
  • Thread.UncaughtExceptionHandler
  • ThreadFactory
  • ToDoubleBiFunction
  • ToDoubleFunction
  • ToIntBiFunction
  • ToIntFunction
  • ToLongBiFunction
  • ToLongFunction
  • ToolProvider
  • TransferQueue
  • TrustManager
  • Type
  • TypeVariable
  • UnaryOperator
  • URLStreamHandlerFactory
  • UserDefinedFileAttributeView
  • UserPrincipal
  • Watchable
  • WatchEvent
  • WatchEvent.Kind
  • WatchEvent.Modifier
  • WatchKey
  • WatchService
  • WildcardType
  • WritableByteChannel
  • X509Extension
  • X509KeyManager
  • X509TrustManager

Classes

  • AbstractChronology
  • AbstractCollection
  • AbstractExecutorService
  • AbstractInterruptibleChannel
  • AbstractList
  • AbstractMap
  • AbstractMap.SimpleEntry
  • AbstractMap.SimpleImmutableEntry
  • AbstractOwnableSynchronizer
  • AbstractQueue
  • AbstractQueuedLongSynchronizer
  • AbstractQueuedSynchronizer
  • AbstractResourceBundleProvider
  • AbstractSelectableChannel
  • AbstractSelectionKey
  • AbstractSelector
  • AbstractSequentialList
  • AbstractSet
  • AccessControlContext
  • AccessController
  • AccessibleObject
  • AclEntry
  • AclEntry.Builder
  • Adler32
  • AlgorithmParameterGenerator
  • AlgorithmParameterGeneratorSpi
  • AlgorithmParameters
  • AlgorithmParametersSpi
  • AllPermission
  • Annotation
  • AppConfigurationEntry
  • AppConfigurationEntry.LoginModuleControlFlag
  • Array
  • ArrayBlockingQueue
  • ArrayDeque
  • ArrayList
  • Arrays
  • AsynchronousChannelGroup
  • AsynchronousChannelProvider
  • AsynchronousFileChannel
  • AsynchronousServerSocketChannel
  • AsynchronousSocketChannel
  • AtomicBoolean
  • AtomicInteger
  • AtomicIntegerArray
  • AtomicIntegerFieldUpdater
  • AtomicLong
  • AtomicLongArray
  • AtomicLongFieldUpdater
  • AtomicMarkableReference
  • AtomicReference
  • AtomicReferenceArray
  • AtomicReferenceFieldUpdater
  • AtomicStampedReference
  • AttributedCharacterIterator.Attribute
  • AttributedString
  • Attributes
  • Attributes.Name
  • Authenticator
  • AuthPermission
  • AuthProvider
  • Base64
  • Base64.Decoder
  • Base64.Encoder
  • BasicPermission
  • Bidi
  • BigDecimal
  • BigInteger
  • BitSet
  • Boolean
  • BreakIterator
  • BreakIteratorProvider
  • Buffer
  • BufferedInputStream
  • BufferedOutputStream
  • BufferedReader
  • BufferedWriter
  • Byte
  • ByteArrayInputStream
  • ByteArrayOutputStream
  • ByteBuffer
  • ByteOrder
  • CacheRequest
  • CacheResponse
  • Calendar
  • Calendar.Builder
  • CalendarDataProvider
  • CalendarNameProvider
  • CallSite
  • Certificate
  • Certificate
  • Certificate.CertificateRep
  • CertificateFactory
  • CertificateFactorySpi
  • CertPath
  • CertPath.CertPathRep
  • CertPathBuilder
  • CertPathBuilderSpi
  • CertPathTrustManagerParameters
  • CertPathValidator
  • CertPathValidatorSpi
  • CertStore
  • CertStoreSpi
  • Channels
  • Character
  • Character.Subset
  • Character.UnicodeBlock
  • CharArrayReader
  • CharArrayWriter
  • CharBuffer
  • Charset
  • CharsetDecoder
  • CharsetEncoder
  • CharsetProvider
  • CheckedInputStream
  • CheckedOutputStream
  • ChoiceCallback
  • ChoiceFormat
  • Cipher
  • CipherInputStream
  • CipherOutputStream
  • CipherSpi
  • Class
  • ClassLoader
  • ClassValue
  • Cleaner
  • Clock
  • CoderResult
  • CodeSigner
  • CodeSource
  • CodingErrorAction
  • CollationElementIterator
  • CollationKey
  • Collator
  • CollatorProvider
  • CollectionCertStoreParameters
  • Collections
  • Collectors
  • Compiler
  • CompletableFuture
  • ConcurrentHashMap
  • ConcurrentHashMap.KeySetView
  • ConcurrentLinkedDeque
  • ConcurrentLinkedQueue
  • ConcurrentSkipListMap
  • ConcurrentSkipListSet
  • Configuration
  • Configuration
  • ConfigurationSpi
  • ConfirmationCallback
  • Console
  • ConstantCallSite
  • Constructor
  • ContentHandler
  • CookieHandler
  • CookieManager
  • CopyOnWriteArrayList
  • CopyOnWriteArraySet
  • CountDownLatch
  • CountedCompleter
  • CRC32
  • CRC32C
  • CRL
  • Currency
  • CurrencyNameProvider
  • CyclicBarrier
  • DatagramChannel
  • DatagramPacket
  • DatagramSocket
  • DatagramSocketImpl
  • DataInputStream
  • DataOutputStream
  • Date
  • DateFormat
  • DateFormat.Field
  • DateFormatProvider
  • DateFormatSymbols
  • DateFormatSymbolsProvider
  • DateTimeFormatter
  • DateTimeFormatterBuilder
  • DecimalFormat
  • DecimalFormatSymbols
  • DecimalFormatSymbolsProvider
  • DecimalStyle
  • Deflater
  • DeflaterInputStream
  • DeflaterOutputStream
  • DelayQueue
  • DESedeKeySpec
  • DESKeySpec
  • DHGenParameterSpec
  • DHParameterSpec
  • DHPrivateKeySpec
  • DHPublicKeySpec
  • Dictionary
  • DigestInputStream
  • DigestOutputStream
  • DomainLoadStoreParameter
  • Double
  • DoubleAccumulator
  • DoubleAdder
  • DoubleBuffer
  • DoubleSummaryStatistics
  • DrbgParameters
  • DrbgParameters.Instantiation
  • DrbgParameters.NextBytes
  • DrbgParameters.Reseed
  • DSAGenParameterSpec
  • DSAParameterSpec
  • DSAPrivateKeySpec
  • DSAPublicKeySpec
  • Duration
  • ECFieldF2m
  • ECFieldFp
  • ECGenParameterSpec
  • ECParameterSpec
  • ECPoint
  • ECPrivateKeySpec
  • ECPublicKeySpec
  • EllipticCurve
  • EncodedKeySpec
  • EncryptedPrivateKeyInfo
  • Enum
  • EnumMap
  • EnumSet
  • EventListenerProxy
  • EventObject
  • Exchanger
  • Executable
  • ExecutorCompletionService
  • Executors
  • ExemptionMechanism
  • ExemptionMechanismSpi
  • ExtendedSSLSession
  • Field
  • FieldPosition
  • File
  • FileChannel
  • FileChannel.MapMode
  • FileDescriptor
  • FileInputStream
  • FileLock
  • FileOutputStream
  • FilePermission
  • FileReader
  • Files
  • FileStore
  • FileSystem
  • FileSystemProvider
  • FileSystems
  • FileTime
  • FileTypeDetector
  • FileWriter
  • FilterInputStream
  • FilterOutputStream
  • FilterReader
  • FilterWriter
  • Float
  • FloatBuffer
  • Flow
  • ForkJoinPool
  • ForkJoinTask
  • ForkJoinWorkerThread
  • Format
  • Format.Field
  • FormattableFlags
  • Formatter
  • FutureTask
  • GCMParameterSpec
  • GregorianCalendar
  • GuardedObject
  • GZIPInputStream
  • GZIPOutputStream
  • HandshakeCompletedEvent
  • HashMap
  • HashSet
  • Hashtable
  • HijrahChronology
  • HijrahDate
  • HttpCookie
  • HttpsURLConnection
  • HttpURLConnection
  • Identity
  • IdentityHashMap
  • IdentityScope
  • IDN
  • Inet4Address
  • Inet6Address
  • InetAddress
  • InetSocketAddress
  • Inflater
  • InflaterInputStream
  • InflaterOutputStream
  • InheritableThreadLocal
  • InputStream
  • InputStreamReader
  • Instant
  • IntBuffer
  • Integer
  • InterfaceAddress
  • IntSummaryStatistics
  • IsoChronology
  • IsoFields
  • IvParameterSpec
  • JapaneseChronology
  • JapaneseDate
  • JapaneseEra
  • JarEntry
  • JarFile
  • JarInputStream
  • JarOutputStream
  • JarURLConnection
  • JulianFields
  • KeyAgreement
  • KeyAgreementSpi
  • KeyFactory
  • KeyFactorySpi
  • KeyGenerator
  • KeyGeneratorSpi
  • KeyManagerFactory
  • KeyManagerFactorySpi
  • KeyPair
  • KeyPairGenerator
  • KeyPairGeneratorSpi
  • KeyRep
  • KeyStore
  • KeyStore.Builder
  • KeyStore.CallbackHandlerProtection
  • KeyStore.PasswordProtection
  • KeyStore.PrivateKeyEntry
  • KeyStore.SecretKeyEntry
  • KeyStore.TrustedCertificateEntry
  • KeyStoreBuilderParameters
  • KeyStoreSpi
  • LambdaMetafactory
  • LanguageCallback
  • LDAPCertStoreParameters
  • LineNumberInputStream
  • LineNumberReader
  • LinkedBlockingDeque
  • LinkedBlockingQueue
  • LinkedHashMap
  • LinkedHashSet
  • LinkedList
  • LinkedTransferQueue
  • LinkPermission
  • ListResourceBundle
  • LocalDate
  • LocalDateTime
  • Locale
  • Locale.Builder
  • Locale.LanguageRange
  • LocaleNameProvider
  • LocaleServiceProvider
  • LocalTime
  • LockSupport
  • LoginContext
  • Long
  • LongAccumulator
  • LongAdder
  • LongBuffer
  • LongSummaryStatistics
  • Mac
  • MacSpi
  • Manifest
  • MappedByteBuffer
  • Matcher
  • Math
  • MathContext
  • MembershipKey
  • MessageDigest
  • MessageDigestSpi
  • MessageFormat
  • MessageFormat.Field
  • 方法
  • MethodHandle
  • MethodHandleProxies
  • MethodHandles
  • MethodHandles.Lookup
  • MethodType
  • MGF1ParameterSpec
  • MinguoChronology
  • MinguoDate
  • Modifier
  • Module
  • ModuleDescriptor
  • ModuleDescriptor.Builder
  • ModuleDescriptor.Exports
  • ModuleDescriptor.Opens
  • ModuleDescriptor.Provides
  • ModuleDescriptor.Requires
  • ModuleDescriptor.Version
  • ModuleLayer
  • ModuleLayer.Controller
  • ModuleReference
  • MonthDay
  • MulticastSocket
  • MutableCallSite
  • NameCallback
  • NetPermission
  • NetworkInterface
  • Normalizer
  • NullCipher
  • Number
  • NumberFormat
  • NumberFormat.Field
  • NumberFormatProvider
  • OAEPParameterSpec
  • Object
  • ObjectInputFilter.Config
  • ObjectInputStream
  • ObjectInputStream.GetField
  • ObjectOutputStream
  • ObjectOutputStream.PutField
  • Objects
  • ObjectStreamClass
  • ObjectStreamField
  • Observable
  • OffsetDateTime
  • OffsetTime
  • Optional
  • OptionalDouble
  • OptionalInt
  • OptionalLong
  • OutputStream
  • OutputStreamWriter
  • Pack200
  • 软件包
  • Parameter
  • ParsePosition
  • PasswordAuthentication
  • PasswordCallback
  • Paths
  • Pattern
  • PBEKeySpec
  • PBEParameterSpec
  • Period
  • Permission
  • PermissionCollection
  • Permissions
  • PhantomReference
  • Phaser
  • Pipe
  • Pipe.SinkChannel
  • Pipe.SourceChannel
  • PipedInputStream
  • PipedOutputStream
  • PipedReader
  • PipedWriter
  • PKCS12Attribute
  • PKCS8EncodedKeySpec
  • PKIXBuilderParameters
  • PKIXCertPathBuilderResult
  • PKIXCertPathChecker
  • PKIXCertPathValidatorResult
  • PKIXParameters
  • PKIXRevocationChecker
  • Policy
  • Policy
  • PolicyQualifierInfo
  • PolicySpi
  • PosixFilePermissions
  • PrintStream
  • PrintWriter
  • PriorityBlockingQueue
  • PriorityQueue
  • PrivateCredentialPermission
  • Process
  • ProcessBuilder
  • ProcessBuilder.Redirect
  • Properties
  • PropertyPermission
  • PropertyResourceBundle
  • ProtectionDomain
  • Provider
  • Provider.Service
  • Proxy
  • Proxy
  • ProxySelector
  • PSource
  • PSource.PSpecified
  • PSSParameterSpec
  • PushbackInputStream
  • PushbackReader
  • Random
  • RandomAccessFile
  • RC2ParameterSpec
  • RC5ParameterSpec
  • Reader
  • RecursiveAction
  • RecursiveTask
  • ReentrantLock
  • ReentrantReadWriteLock
  • ReentrantReadWriteLock.ReadLock
  • ReentrantReadWriteLock.WriteLock
  • Reference
  • ReferenceQueue
  • ReflectPermission
  • ResolvedModule
  • ResourceBundle
  • ResourceBundle.Control
  • ResponseCache
  • RSAKeyGenParameterSpec
  • RSAMultiPrimePrivateCrtKeySpec
  • RSAOtherPrimeInfo
  • RSAPrivateCrtKeySpec
  • RSAPrivateKeySpec
  • RSAPublicKeySpec
  • RuleBasedCollator
  • Runtime
  • Runtime.Version
  • RuntimePermission
  • Scanner
  • ScheduledThreadPoolExecutor
  • SealedObject
  • SecretKeyFactory
  • SecretKeyFactorySpi
  • SecretKeySpec
  • SecureCacheResponse
  • SecureClassLoader
  • SecureRandom
  • SecureRandomSpi
  • Security
  • SecurityManager
  • SecurityPermission
  • SelectableChannel
  • SelectionKey
  • Selector
  • SelectorProvider
  • Semaphore
  • SequenceInputStream
  • SerializablePermission
  • SerializedLambda
  • ServerSocket
  • ServerSocketChannel
  • ServerSocketFactory
  • ServiceLoader
  • Short
  • ShortBuffer
  • Signature
  • SignatureSpi
  • SignedObject
  • Signer
  • SimpleDateFormat
  • SimpleFileVisitor
  • SimpleTimeZone
  • SNIHostName
  • SNIMatcher
  • SNIServerName
  • Socket
  • SocketAddress
  • SocketChannel
  • SocketFactory
  • SocketImpl
  • SocketPermission
  • SoftReference
  • Spliterators
  • Spliterators.AbstractDoubleSpliterator
  • Spliterators.AbstractIntSpliterator
  • Spliterators.AbstractLongSpliterator
  • Spliterators.AbstractSpliterator
  • SplittableRandom
  • SSLContext
  • SSLContextSpi
  • SSLEngine
  • SSLEngineResult
  • SSLParameters
  • SSLPermission
  • SSLServerSocket
  • SSLServerSocketFactory
  • SSLSessionBindingEvent
  • SSLSocket
  • SSLSocketFactory
  • Stack
  • StackTraceElement
  • StackWalker
  • StampedLock
  • StandardCharsets
  • StandardConstants
  • StandardSocketOptions
  • StandardWatchEventKinds
  • StreamSupport
  • StreamTokenizer
  • StrictMath
  • String
  • StringBuffer
  • StringBufferInputStream
  • StringBuilder
  • StringCharacterIterator
  • StringConcatFactory
  • StringJoiner
  • StringReader
  • StringTokenizer
  • StringWriter
  • Subject
  • SubjectDomainCombiner
  • SubmissionPublisher
  • SwitchPoint
  • SynchronousQueue
  • System
  • System.LoggerFinder
  • TemporalAdjusters
  • TemporalQueries
  • TextInputCallback
  • TextOutputCallback
  • ThaiBuddhistChronology
  • ThaiBuddhistDate
  • Thread
  • ThreadGroup
  • ThreadLocal
  • ThreadLocalRandom
  • ThreadPoolExecutor
  • ThreadPoolExecutor.AbortPolicy
  • ThreadPoolExecutor.CallerRunsPolicy
  • ThreadPoolExecutor.DiscardOldestPolicy
  • ThreadPoolExecutor.DiscardPolicy
  • Throwable
  • Timer
  • TimerTask
  • Timestamp
  • TimeZone
  • TimeZoneNameProvider
  • TreeMap
  • TreeSet
  • TrustAnchor
  • TrustManagerFactory
  • TrustManagerFactorySpi
  • UnresolvedPermission
  • URI
  • URICertStoreParameters
  • URIParameter
  • URL
  • URLClassLoader
  • URLConnection
  • URLDecoder
  • URLEncoder
  • URLPermission
  • URLStreamHandler
  • URLStreamHandlerProvider
  • UserPrincipalLookupService
  • UUID
  • ValueRange
  • VarHandle
  • Vector
  • Void
  • VolatileCallSite
  • WeakHashMap
  • WeakReference
  • WeekFields
  • Writer
  • X500Principal
  • X500PrivateCredential
  • X509Certificate
  • X509Certificate
  • X509CertSelector
  • X509CRL
  • X509CRLEntry
  • X509CRLSelector
  • X509EncodedKeySpec
  • X509ExtendedKeyManager
  • X509ExtendedTrustManager
  • Year
  • YearMonth
  • ZipEntry
  • ZipFile
  • ZipInputStream
  • ZipOutputStream
  • ZonedDateTime
  • ZoneId
  • ZoneOffset
  • ZoneOffsetTransition
  • ZoneOffsetTransitionRule
  • ZoneRules
  • ZoneRulesProvider

Enums

  • AccessMode
  • AclEntryFlag
  • AclEntryPermission
  • AclEntryType
  • Authenticator.RequestorType
  • CertPathValidatorException.BasicReason
  • Character.UnicodeScript
  • ChronoField
  • ChronoUnit
  • Collector.Characteristics
  • CRLReason
  • CryptoPrimitive
  • DayOfWeek
  • DrbgParameters.Capability
  • ElementType
  • FileVisitOption
  • FileVisitResult
  • FormatStyle
  • Formatter.BigDecimalLayoutForm
  • HijrahEra
  • IsoEra
  • KeyRep.Type
  • LinkOption
  • Locale.Category
  • Locale.FilteringMode
  • Locale.IsoCountryCode
  • MinguoEra
  • ModuleDescriptor.Exports.Modifier
  • ModuleDescriptor.Modifier
  • ModuleDescriptor.Opens.Modifier
  • ModuleDescriptor.Requires.Modifier
  • Month
  • Normalizer.Form
  • ObjectInputFilter.Status
  • PKIXReason
  • PKIXRevocationChecker.Option
  • PosixFilePermission
  • ProcessBuilder.Redirect.Type
  • Proxy.Type
  • ResolverStyle
  • RetentionPolicy
  • RoundingMode
  • SignStyle
  • SSLEngineResult.HandshakeStatus
  • SSLEngineResult.Status
  • StackWalker.Option
  • StandardCopyOption
  • StandardOpenOption
  • StandardProtocolFamily
  • System.Logger.Level
  • TextStyle
  • ThaiBuddhistEra
  • Thread.State
  • TimeUnit
  • VarHandle.AccessMode
  • ZoneOffsetTransitionRule.TimeDefinition

Exceptions

  • AcceptPendingException
  • AccessControlException
  • AccessDeniedException
  • AccountException
  • AccountExpiredException
  • AccountLockedException
  • AccountNotFoundException
  • AclNotFoundException
  • AEADBadTagException
  • AlreadyBoundException
  • AlreadyConnectedException
  • AnnotationTypeMismatchException
  • ArithmeticException
  • ArrayIndexOutOfBoundsException
  • ArrayStoreException
  • AsynchronousCloseException
  • AtomicMoveNotSupportedException
  • BadPaddingException
  • BindException
  • BrokenBarrierException
  • BufferOverflowException
  • BufferUnderflowException
  • CancellationException
  • CancelledKeyException
  • CertificateEncodingException
  • CertificateEncodingException
  • CertificateException
  • CertificateException
  • CertificateExpiredException
  • CertificateExpiredException
  • CertificateNotYetValidException
  • CertificateNotYetValidException
  • CertificateParsingException
  • CertificateParsingException
  • CertificateRevokedException
  • CertPathBuilderException
  • CertPathValidatorException
  • CertStoreException
  • CharacterCodingException
  • CharConversionException
  • ClassCastException
  • ClassNotFoundException
  • CloneNotSupportedException
  • ClosedByInterruptException
  • ClosedChannelException
  • ClosedDirectoryStreamException
  • ClosedFileSystemException
  • ClosedSelectorException
  • ClosedWatchServiceException
  • CompletionException
  • ConcurrentModificationException
  • ConnectException
  • ConnectionPendingException
  • CredentialException
  • CredentialExpiredException
  • CredentialNotFoundException
  • CRLException
  • DataFormatException
  • DateTimeException
  • DateTimeParseException
  • DestroyFailedException
  • DigestException
  • DirectoryIteratorException
  • DirectoryNotEmptyException
  • DuplicateFormatFlagsException
  • EmptyStackException
  • EnumConstantNotPresentException
  • EOFException
  • 异常
  • ExecutionException
  • ExemptionMechanismException
  • FailedLoginException
  • FileAlreadyExistsException
  • FileLockInterruptionException
  • FileNotFoundException
  • FileSystemAlreadyExistsException
  • FileSystemException
  • FileSystemLoopException
  • FileSystemNotFoundException
  • FindException
  • FormatFlagsConversionMismatchException
  • FormatterClosedException
  • GeneralSecurityException
  • HttpRetryException
  • IllegalAccessException
  • IllegalArgumentException
  • IllegalBlockingModeException
  • IllegalBlockSizeException
  • IllegalCallerException
  • IllegalChannelGroupException
  • IllegalCharsetNameException
  • IllegalFormatCodePointException
  • IllegalFormatConversionException
  • IllegalFormatException
  • IllegalFormatFlagsException
  • IllegalFormatPrecisionException
  • IllegalFormatWidthException
  • IllegalMonitorStateException
  • IllegalSelectorException
  • IllegalStateException
  • IllegalThreadStateException
  • IllformedLocaleException
  • InaccessibleObjectException
  • IncompleteAnnotationException
  • IndexOutOfBoundsException
  • InputMismatchException
  • InstantiationException
  • InterruptedByTimeoutException
  • InterruptedException
  • InterruptedIOException
  • InvalidAlgorithmParameterException
  • InvalidClassException
  • InvalidKeyException
  • InvalidKeySpecException
  • InvalidMarkException
  • InvalidModuleDescriptorException
  • InvalidObjectException
  • InvalidParameterException
  • InvalidParameterSpecException
  • InvalidPathException
  • InvalidPropertiesFormatException
  • InvocationTargetException
  • IOException
  • JarException
  • KeyException
  • KeyManagementException
  • KeyStoreException
  • LambdaConversionException
  • LastOwnerException
  • LayerInstantiationException
  • LoginException
  • MalformedInputException
  • MalformedParameterizedTypeException
  • MalformedParametersException
  • MalformedURLException
  • MissingFormatArgumentException
  • MissingFormatWidthException
  • MissingResourceException
  • NegativeArraySizeException
  • NoConnectionPendingException
  • NonReadableChannelException
  • NonWritableChannelException
  • NoRouteToHostException
  • NoSuchAlgorithmException
  • NoSuchElementException
  • NoSuchFieldException
  • NoSuchFileException
  • NoSuchMethodException
  • NoSuchPaddingException
  • NoSuchProviderException
  • NotActiveException
  • NotDirectoryException
  • NotLinkException
  • NotOwnerException
  • NotSerializableException
  • NotYetBoundException
  • NotYetConnectedException
  • NullPointerException
  • NumberFormatException
  • ObjectStreamException
  • OptionalDataException
  • OverlappingFileLockException
  • ParseException
  • PatternSyntaxException
  • PortUnreachableException
  • PrivilegedActionException
  • ProtocolException
  • ProviderException
  • ProviderMismatchException
  • ProviderNotFoundException
  • ReadOnlyBufferException
  • ReadOnlyFileSystemException
  • ReadPendingException
  • ReflectiveOperationException
  • RefreshFailedException
  • RejectedExecutionException
  • ResolutionException
  • RuntimeException
  • SecurityException
  • ShortBufferException
  • ShutdownChannelGroupException
  • SignatureException
  • SocketException
  • SocketTimeoutException
  • SSLException
  • SSLHandshakeException
  • SSLKeyException
  • SSLPeerUnverifiedException
  • SSLProtocolException
  • StreamCorruptedException
  • StringConcatException
  • StringIndexOutOfBoundsException
  • SyncFailedException
  • TimeoutException
  • TooManyListenersException
  • TypeNotPresentException
  • UncheckedIOException
  • UndeclaredThrowableException
  • UnknownFormatConversionException
  • UnknownFormatFlagsException
  • UnknownHostException
  • UnknownServiceException
  • UnmappableCharacterException
  • UnrecoverableEntryException
  • UnrecoverableKeyException
  • UnresolvedAddressException
  • UnsupportedAddressTypeException
  • UnsupportedCallbackException
  • UnsupportedCharsetException
  • UnsupportedEncodingException
  • UnsupportedOperationException
  • UnsupportedTemporalTypeException
  • URISyntaxException
  • UserPrincipalNotFoundException
  • UTFDataFormatException
  • WriteAbortedException
  • WritePendingException
  • WrongMethodTypeException
  • ZipException
  • ZoneRulesException

Errors

  • AbstractMethodError
  • AnnotationFormatError
  • AssertionError
  • BootstrapMethodError
  • ClassCircularityError
  • ClassFormatError
  • CoderMalfunctionError
  • Error
  • ExceptionInInitializerError
  • GenericSignatureFormatError
  • IllegalAccessError
  • IncompatibleClassChangeError
  • InstantiationError
  • InternalError
  • IOError
  • LinkageError
  • NoClassDefFoundError
  • NoSuchFieldError
  • NoSuchMethodError
  • OutOfMemoryError
  • ServiceConfigurationError
  • StackOverflowError
  • ThreadDeath
  • UnknownError
  • UnsatisfiedLinkError
  • UnsupportedClassVersionError
  • VerifyError
  • VirtualMachineError
  • ZipError

注解类型

  • 已过时的
  • Documented
  • FunctionalInterface
  • Inherited
  • Native
  • Override
  • Repeatable
  • Retention
  • SafeVarargs
  • SuppressWarnings
  • Target


java.compiler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.compiler

定义语言模型，注释处理和Java编译器API。

这些API模拟了Java编程语言的声明和类型，并定义了可以从程序调用的编译器等工具的接口。

此模块可升级。

Module Graph:
Module graph for java.compiler Module graph for java.compiler
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.annotation.processing
      用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
      javax.lang.model
      用于建模Java编程语言的软件包的类和层次结构。
      javax.lang.model.element
      用于建模Java编程语言元素的接口。
      javax.lang.model.type
      用于建模Java编程语言类型的接口。
      javax.lang.model.util
      协助处理 program elements及 types的公用事业 。
      javax.tools
      Provides interfaces for tools which can be invoked from a program, for example, compilers.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.compiler (Java SE 9 & JDK 9 )

java.compiler

Interfaces

  • AnnotatedConstruct
  • AnnotationMirror
  • AnnotationValue
  • AnnotationValueVisitor
  • ArrayType
  • Completion
  • DeclaredType
  • Diagnostic
  • DiagnosticListener
  • DocumentationTool
  • DocumentationTool.DocumentationTask
  • Element
  • Elements
  • ElementVisitor
  • ErrorType
  • ExecutableElement
  • ExecutableType
  • FileObject
  • Filer
  • IntersectionType
  • JavaCompiler
  • JavaCompiler.CompilationTask
  • JavaFileManager
  • JavaFileManager.Location
  • JavaFileObject
  • Messager
  • ModuleElement
  • ModuleElement.Directive
  • ModuleElement.DirectiveVisitor
  • ModuleElement.ExportsDirective
  • ModuleElement.OpensDirective
  • ModuleElement.ProvidesDirective
  • ModuleElement.RequiresDirective
  • ModuleElement.UsesDirective
  • Name
  • NoType
  • NullType
  • OptionChecker
  • PackageElement
  • Parameterizable
  • PrimitiveType
  • ProcessingEnvironment
  • Processor
  • QualifiedNameable
  • ReferenceType
  • RoundEnvironment
  • StandardJavaFileManager
  • StandardJavaFileManager.PathFactory
  • Tool
  • TypeElement
  • TypeMirror
  • TypeParameterElement
  • Types
  • TypeVariable
  • TypeVisitor
  • UnionType
  • VariableElement
  • WildcardType

Classes

  • AbstractAnnotationValueVisitor6
  • AbstractAnnotationValueVisitor7
  • AbstractAnnotationValueVisitor8
  • AbstractAnnotationValueVisitor9
  • AbstractElementVisitor6
  • AbstractElementVisitor7
  • AbstractElementVisitor8
  • AbstractElementVisitor9
  • AbstractProcessor
  • AbstractTypeVisitor6
  • AbstractTypeVisitor7
  • AbstractTypeVisitor8
  • AbstractTypeVisitor9
  • Completions
  • DiagnosticCollector
  • ElementFilter
  • ElementKindVisitor6
  • ElementKindVisitor7
  • ElementKindVisitor8
  • ElementKindVisitor9
  • ElementScanner6
  • ElementScanner7
  • ElementScanner8
  • ElementScanner9
  • ForwardingFileObject
  • ForwardingJavaFileManager
  • ForwardingJavaFileObject
  • SimpleAnnotationValueVisitor6
  • SimpleAnnotationValueVisitor7
  • SimpleAnnotationValueVisitor8
  • SimpleAnnotationValueVisitor9
  • SimpleElementVisitor6
  • SimpleElementVisitor7
  • SimpleElementVisitor8
  • SimpleElementVisitor9
  • SimpleJavaFileObject
  • SimpleTypeVisitor6
  • SimpleTypeVisitor7
  • SimpleTypeVisitor8
  • SimpleTypeVisitor9
  • ToolProvider
  • TypeKindVisitor6
  • TypeKindVisitor7
  • TypeKindVisitor8
  • TypeKindVisitor9

Enums

  • Diagnostic.Kind
  • DocumentationTool.Location
  • ElementKind
  • Elements.Origin
  • JavaFileObject.Kind
  • Modifier
  • ModuleElement.DirectiveKind
  • NestingKind
  • SourceVersion
  • StandardLocation
  • TypeKind

Exceptions

  • FilerException
  • MirroredTypeException
  • MirroredTypesException
  • UnknownAnnotationValueException
  • UnknownDirectiveException
  • UnknownElementException
  • UnknownEntityException
  • UnknownTypeException

注解类型

  • Generated
  • SupportedAnnotationTypes
  • SupportedOptions
  • SupportedSourceVersion


java.corba (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module java.corba

Deprecated, for removal: This API element is subject to removal in a future version.
定义OMG CORBA API和RMI-IIOP API的Java绑定。

此模块可升级。

Module Graph:
Module graph for java.corba Module graph for java.corba
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.activity
      包含ORB机械在解组时抛出的活动服务相关异常。
      javax.rmi
      包含RMI-IIOP的用户API。
      javax.rmi.CORBA
      包含RMI-IIOP的可移植API。
      org.omg.CORBA
      提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能对象请求代理（ORB）。
      org.omg.CORBA_2_3
      CORBA_2_3包定义了Java [tm]标准版6中现有CORBA接口的添加。这些更改发生在由OMG定义的CORBA API的最新修订版本中。 将新方法添加到从CORBA包中相应接口派生的接口。 这提供向后兼容性，并避免破坏JCK测试。
      org.omg.CORBA_2_3.portable
      提供输入和输出值类型的方法，并包含 org/omg/CORBA/portable包的其他更新。
      org.omg.CORBA.DynAnyPackage
      提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。
      org.omg.CORBA.ORBPackage
      提供异常 InvalidName ，它由方法 ORB.resolve_initial_references抛出，异常 InconsistentTypeCode由ORB类中的动态任何创建方法抛出。
      org.omg.CORBA.portable
      提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
      org.omg.CORBA.TypeCodePackage
      提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。
      org.omg.CosNaming
      为Java IDL提供命名服务。
      org.omg.CosNaming.NamingContextExtPackage
      此软件包包含以下类别，用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress
      org.omg.CosNaming.NamingContextPackage
      此包包含 org.omg.CosNaming包的异常类。
      org.omg.Dynamic
      该包包含OMG便携式拦截器规范 ptc/2000-08-06第21.9节中指定的 Dynamic模块。
      org.omg.DynamicAny
      提供类和接口，可以在运行时遍历与 any相关联的数据值，并提取数据值的原始组成部分。
      org.omg.DynamicAny.DynAnyFactoryPackage
      该包包含OMG “通用对象请求代理：体系结构和规范”中的 DynamicAny模块的 DynAnyFactory接口的类和异常， formal/99-10-07 ，第9.2.2节。
      org.omg.DynamicAny.DynAnyPackage
      该包包含OMG “公共对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。
      org.omg.IOP
      该包包含OMG文档 “通用对象请求代理：体系结构和规范 ” formal/99-10-07第13.6节中指定的 IOP模块。
      org.omg.IOP.CodecFactoryPackage
      该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。
      org.omg.IOP.CodecPackage
      该包是从IOP :: Codec IDL接口定义生成的。
      org.omg.Messaging
      该包包含OMG CORBA消息传递规范 formal/99-10-07中指定的 Messaging模块。
      org.omg.PortableInterceptor
      提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。
      org.omg.PortableInterceptor.ORBInitInfoPackage
      该包包含OMG便携式拦截器规范 ptc/2000-08-06第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。
      org.omg.PortableServer
      提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
      org.omg.PortableServer.CurrentPackage
      提供方法实现，访问方法被调用的对象的标识。
      org.omg.PortableServer.POAManagerPackage
      封装与之相关的POA的处理状态。
      org.omg.PortableServer.POAPackage
      允许程序员构建可在不同ORB产品之间移植的对象实现。
      org.omg.PortableServer.portable
      提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
      org.omg.PortableServer.ServantLocatorPackage
      提供用于定位仆人的类和接口。
      org.omg.SendingContext
      为组合值类型提供支持。
      org.omg.stub.java.rmi
      包含 java.rmi软件包中出现的远程类型的RMI-IIOP存根。
      Indirect Exports
      From Packages
      java.datatransfer java.awt.datatransfer
      java.desktop java.applet java.awt java.awt.color java.awt.desktop java.awt.dnd java.awt.event java.awt.font java.awt.geom java.awt.im java.awt.im.spi java.awt.image java.awt.image.renderable java.awt.print java.beans java.beans.beancontext javax.accessibility javax.imageio javax.imageio.event javax.imageio.metadata javax.imageio.plugins.bmp javax.imageio.plugins.jpeg javax.imageio.plugins.tiff javax.imageio.spi javax.imageio.stream javax.print javax.print.attribute javax.print.attribute.standard javax.print.event javax.sound.midi javax.sound.midi.spi javax.sound.sampled javax.sound.sampled.spi javax.swing javax.swing.border javax.swing.colorchooser javax.swing.event javax.swing.filechooser javax.swing.plaf javax.swing.plaf.basic javax.swing.plaf.metal javax.swing.plaf.multi javax.swing.plaf.nimbus javax.swing.plaf.synth javax.swing.table javax.swing.text javax.swing.text.html javax.swing.text.html.parser javax.swing.text.rtf javax.swing.tree javax.swing.undo
      java.rmi java.rmi java.rmi.activation java.rmi.dgc java.rmi.registry java.rmi.server javax.rmi.ssl
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.desktop
      定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
      transitive java.rmi
      定义远程方法调用（RMI）API。
      Indirect Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.corba (Java SE 9 & JDK 9 )

java.corba

Interfaces

  • ACTIVE
  • AdapterActivator
  • AdapterActivatorOperations
  • ARG_IN
  • ARG_INOUT
  • ARG_OUT
  • BAD_POLICY
  • BAD_POLICY_TYPE
  • BAD_POLICY_VALUE
  • BindingIterator
  • BindingIteratorOperations
  • BoxedValueHelper
  • ClientRequestInfo
  • ClientRequestInfoOperations
  • ClientRequestInterceptor
  • ClientRequestInterceptorOperations
  • Codec
  • CodecFactory
  • CodecFactoryOperations
  • CodecOperations
  • CodeSets
  • CTX_RESTRICT_SCOPE
  • Current
  • Current
  • Current
  • CurrentOperations
  • CurrentOperations
  • CurrentOperations
  • CustomMarshal
  • CustomValue
  • DataInputStream
  • DataOutputStream
  • Delegate
  • DISCARDING
  • DomainManager
  • DomainManagerOperations
  • DynAny
  • DynAny
  • DynAnyFactory
  • DynAnyFactoryOperations
  • DynAnyOperations
  • DynArray
  • DynArray
  • DynArrayOperations
  • DynEnum
  • DynEnum
  • DynEnumOperations
  • DynFixed
  • DynFixed
  • DynFixedOperations
  • DynSequence
  • DynSequence
  • DynSequenceOperations
  • DynStruct
  • DynStruct
  • DynStructOperations
  • DynUnion
  • DynUnion
  • DynUnionOperations
  • DynValue
  • DynValue
  • DynValueBox
  • DynValueBoxOperations
  • DynValueCommon
  • DynValueCommonOperations
  • DynValueOperations
  • ENCODING_CDR_ENCAPS
  • ExceptionDetailMessage
  • HOLDING
  • ID_ASSIGNMENT_POLICY_ID
  • ID_UNIQUENESS_POLICY_ID
  • IdAssignmentPolicy
  • IdAssignmentPolicyOperations
  • IDLEntity
  • IDLType
  • IDLTypeOperations
  • IdUniquenessPolicy
  • IdUniquenessPolicyOperations
  • IMPLICIT_ACTIVATION_POLICY_ID
  • ImplicitActivationPolicy
  • ImplicitActivationPolicyOperations
  • INACTIVE
  • Interceptor
  • InterceptorOperations
  • InvokeHandler
  • IORInfo
  • IORInfoOperations
  • IORInterceptor
  • IORInterceptor_3_0
  • IORInterceptor_3_0Operations
  • IORInterceptorOperations
  • IRObject
  • IRObjectOperations
  • LIFESPAN_POLICY_ID
  • LifespanPolicy
  • LifespanPolicyOperations
  • LOCATION_FORWARD
  • NamingContext
  • NamingContextExt
  • NamingContextExtOperations
  • NamingContextOperations
  • NON_EXISTENT
  • Object
  • ObjectReferenceFactory
  • ObjectReferenceTemplate
  • OMGVMCID
  • ORBInitializer
  • ORBInitializerOperations
  • ORBInitInfo
  • ORBInitInfoOperations
  • POA
  • POAManager
  • POAManagerOperations
  • POAOperations
  • Policy
  • PolicyFactory
  • PolicyFactoryOperations
  • PolicyOperations
  • PortableRemoteObjectDelegate
  • PRIVATE_MEMBER
  • PUBLIC_MEMBER
  • REQUEST_PROCESSING_POLICY_ID
  • RequestInfo
  • RequestInfoOperations
  • RequestProcessingPolicy
  • RequestProcessingPolicyOperations
  • ResponseHandler
  • RMICustomMaxStreamFormat
  • RunTime
  • RunTimeOperations
  • SERVANT_RETENTION_POLICY_ID
  • ServantActivator
  • ServantActivatorOperations
  • ServantLocator
  • ServantLocatorOperations
  • ServantManager
  • ServantManagerOperations
  • ServantRetentionPolicy
  • ServantRetentionPolicyOperations
  • ServerRequestInfo
  • ServerRequestInfoOperations
  • ServerRequestInterceptor
  • ServerRequestInterceptorOperations
  • Streamable
  • StreamableValue
  • StubDelegate
  • SUCCESSFUL
  • SYNC_WITH_TRANSPORT
  • SYSTEM_EXCEPTION
  • TAG_ALTERNATE_IIOP_ADDRESS
  • TAG_CODE_SETS
  • TAG_INTERNET_IOP
  • TAG_JAVA_CODEBASE
  • TAG_MULTIPLE_COMPONENTS
  • TAG_ORB_TYPE
  • TAG_POLICIES
  • TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • THREAD_POLICY_ID
  • ThreadPolicy
  • ThreadPolicyOperations
  • Tie
  • TransactionService
  • TRANSPORT_RETRY
  • UNKNOWN
  • UNSUPPORTED_POLICY
  • UNSUPPORTED_POLICY_VALUE
  • USER_EXCEPTION
  • UtilDelegate
  • ValueBase
  • ValueFactory
  • ValueHandler
  • ValueHandlerMultiFormat
  • ValueInputStream
  • ValueOutputStream
  • VM_ABSTRACT
  • VM_CUSTOM
  • VM_NONE
  • VM_TRUNCATABLE

Classes

  • _BindingIteratorImplBase
  • _BindingIteratorStub
  • _DynAnyFactoryStub
  • _DynAnyStub
  • _DynArrayStub
  • _DynEnumStub
  • _DynFixedStub
  • _DynSequenceStub
  • _DynStructStub
  • _DynUnionStub
  • _DynValueStub
  • _IDLTypeStub
  • _NamingContextExtStub
  • _NamingContextImplBase
  • _NamingContextStub
  • _PolicyStub
  • _Remote_Stub
  • _ServantActivatorStub
  • _ServantLocatorStub
  • AdapterAlreadyExistsHelper
  • AdapterInactiveHelper
  • AdapterManagerIdHelper
  • AdapterNameHelper
  • AdapterNonExistentHelper
  • AdapterStateHelper
  • AddressHelper
  • AlreadyBoundHelper
  • AlreadyBoundHolder
  • Any
  • AnyHolder
  • AnySeqHelper
  • AnySeqHelper
  • AnySeqHolder
  • BadKindHelper
  • Binding
  • BindingHelper
  • BindingHolder
  • BindingIteratorHelper
  • BindingIteratorHolder
  • BindingIteratorPOA
  • BindingListHelper
  • BindingListHolder
  • BindingType
  • BindingTypeHelper
  • BindingTypeHolder
  • BooleanHolder
  • BooleanSeqHelper
  • BooleanSeqHolder
  • BoundsHelper
  • BoundsHelper
  • ByteHolder
  • CannotProceedHelper
  • CannotProceedHolder
  • CharHolder
  • CharSeqHelper
  • CharSeqHolder
  • ClassDesc
  • CodecFactoryHelper
  • CompletionStatus
  • CompletionStatusHelper
  • ComponentIdHelper
  • Context
  • ContextList
  • CookieHolder
  • CurrentHelper
  • CurrentHelper
  • CurrentHelper
  • CurrentHolder
  • DefinitionKind
  • DefinitionKindHelper
  • Delegate
  • Delegate
  • DoubleHolder
  • DoubleSeqHelper
  • DoubleSeqHolder
  • DuplicateNameHelper
  • DynamicImplementation
  • DynamicImplementation
  • DynAnyFactoryHelper
  • DynAnyHelper
  • DynAnySeqHelper
  • DynArrayHelper
  • DynEnumHelper
  • DynFixedHelper
  • DynSequenceHelper
  • DynStructHelper
  • DynUnionHelper
  • DynValueHelper
  • Encoding
  • Environment
  • ExceptionList
  • FieldNameHelper
  • FieldNameHelper
  • FixedHolder
  • FloatHolder
  • FloatSeqHelper
  • FloatSeqHolder
  • FormatMismatchHelper
  • ForwardRequestHelper
  • ForwardRequestHelper
  • IdAssignmentPolicyValue
  • IdentifierHelper
  • IDLTypeHelper
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • InconsistentTypeCodeHelper
  • InputStream
  • InputStream
  • IntHolder
  • InvalidAddressHelper
  • InvalidAddressHolder
  • InvalidNameHelper
  • InvalidNameHelper
  • InvalidNameHelper
  • InvalidNameHolder
  • InvalidPolicyHelper
  • InvalidSlotHelper
  • InvalidTypeForEncodingHelper
  • InvalidValueHelper
  • IOR
  • IORHelper
  • IORHolder
  • IORInterceptor_3_0Helper
  • IORInterceptor_3_0Holder
  • IstringHelper
  • LifespanPolicyValue
  • LocalObject
  • LongHolder
  • LongLongSeqHelper
  • LongLongSeqHolder
  • LongSeqHelper
  • LongSeqHolder
  • MultipleComponentProfileHelper
  • MultipleComponentProfileHolder
  • NameComponent
  • NameComponentHelper
  • NameComponentHolder
  • NamedValue
  • NameDynAnyPair
  • NameDynAnyPairHelper
  • NameDynAnyPairSeqHelper
  • NameHelper
  • NameHolder
  • NameValuePair
  • NameValuePair
  • NameValuePairHelper
  • NameValuePairHelper
  • NameValuePairSeqHelper
  • NamingContextExtHelper
  • NamingContextExtHolder
  • NamingContextExtPOA
  • NamingContextHelper
  • NamingContextHolder
  • NamingContextPOA
  • NoContextHelper
  • NoServantHelper
  • NotEmptyHelper
  • NotEmptyHolder
  • NotFoundHelper
  • NotFoundHolder
  • NotFoundReason
  • NotFoundReasonHelper
  • NotFoundReasonHolder
  • NVList
  • ObjectAlreadyActiveHelper
  • ObjectHelper
  • ObjectHolder
  • ObjectIdHelper
  • ObjectIdHelper
  • ObjectImpl
  • ObjectImpl
  • ObjectNotActiveHelper
  • ObjectReferenceFactoryHelper
  • ObjectReferenceFactoryHolder
  • ObjectReferenceTemplateHelper
  • ObjectReferenceTemplateHolder
  • ObjectReferenceTemplateSeqHelper
  • ObjectReferenceTemplateSeqHolder
  • OctetSeqHelper
  • OctetSeqHolder
  • ORB
  • ORB
  • ORBIdHelper
  • OutputStream
  • OutputStream
  • Parameter
  • ParameterMode
  • ParameterModeHelper
  • ParameterModeHolder
  • POAHelper
  • PolicyErrorCodeHelper
  • PolicyErrorHelper
  • PolicyErrorHolder
  • PolicyHelper
  • PolicyHolder
  • PolicyListHelper
  • PolicyListHolder
  • PolicyTypeHelper
  • PortableRemoteObject
  • Principal
  • PrincipalHolder
  • ProfileIdHelper
  • RepositoryIdHelper
  • Request
  • RequestProcessingPolicyValue
  • Servant
  • ServantActivatorHelper
  • ServantActivatorPOA
  • ServantAlreadyActiveHelper
  • ServantLocatorHelper
  • ServantLocatorPOA
  • ServantNotActiveHelper
  • ServantObject
  • ServantRetentionPolicyValue
  • ServerIdHelper
  • ServerRequest
  • ServiceContext
  • ServiceContextHelper
  • ServiceContextHolder
  • ServiceContextListHelper
  • ServiceContextListHolder
  • ServiceDetail
  • ServiceDetailHelper
  • ServiceIdHelper
  • ServiceInformation
  • ServiceInformationHelper
  • ServiceInformationHolder
  • SetOverrideType
  • SetOverrideTypeHelper
  • ShortHolder
  • ShortSeqHelper
  • ShortSeqHolder
  • State
  • StringHolder
  • StringNameHelper
  • StringSeqHelper
  • StringSeqHolder
  • StringValueHelper
  • StructMember
  • StructMemberHelper
  • Stub
  • SyncScopeHelper
  • TaggedComponent
  • TaggedComponentHelper
  • TaggedComponentHolder
  • TaggedProfile
  • TaggedProfileHelper
  • TaggedProfileHolder
  • TCKind
  • ThreadPolicyValue
  • TypeCode
  • TypeCodeHolder
  • TypeMismatchHelper
  • TypeMismatchHelper
  • ULongLongSeqHelper
  • ULongLongSeqHolder
  • ULongSeqHelper
  • ULongSeqHolder
  • UnionMember
  • UnionMemberHelper
  • UnknownEncodingHelper
  • UnknownUserExceptionHelper
  • UnknownUserExceptionHolder
  • URLStringHelper
  • UShortSeqHelper
  • UShortSeqHolder
  • Util
  • ValueBaseHelper
  • ValueBaseHolder
  • ValueMember
  • ValueMemberHelper
  • VersionSpecHelper
  • VisibilityHelper
  • WCharSeqHelper
  • WCharSeqHolder
  • WrongAdapterHelper
  • WrongPolicyHelper
  • WrongTransactionHelper
  • WrongTransactionHolder
  • WStringSeqHelper
  • WStringSeqHolder
  • WStringValueHelper

Exceptions

  • ACTIVITY_COMPLETED
  • ACTIVITY_REQUIRED
  • ActivityCompletedException
  • ActivityRequiredException
  • AdapterAlreadyExists
  • AdapterInactive
  • AdapterNonExistent
  • AlreadyBound
  • ApplicationException
  • BAD_CONTEXT
  • BAD_INV_ORDER
  • BAD_OPERATION
  • BAD_PARAM
  • BAD_QOS
  • BAD_TYPECODE
  • BadKind
  • Bounds
  • Bounds
  • CannotProceed
  • CODESET_INCOMPATIBLE
  • COMM_FAILURE
  • DATA_CONVERSION
  • DuplicateName
  • FormatMismatch
  • ForwardRequest
  • ForwardRequest
  • FREE_MEM
  • IMP_LIMIT
  • InconsistentTypeCode
  • InconsistentTypeCode
  • IndirectionException
  • INITIALIZE
  • INTERNAL
  • INTF_REPOS
  • INV_FLAG
  • INV_IDENT
  • INV_OBJREF
  • INV_POLICY
  • Invalid
  • INVALID_ACTIVITY
  • INVALID_TRANSACTION
  • InvalidActivityException
  • InvalidAddress
  • InvalidName
  • InvalidName
  • InvalidName
  • InvalidPolicy
  • InvalidSeq
  • InvalidSlot
  • InvalidTypeForEncoding
  • InvalidValue
  • InvalidValue
  • MARSHAL
  • NO_IMPLEMENT
  • NO_MEMORY
  • NO_PERMISSION
  • NO_RESOURCES
  • NO_RESPONSE
  • NoContext
  • NoServant
  • NotEmpty
  • NotFound
  • OBJ_ADAPTER
  • OBJECT_NOT_EXIST
  • ObjectAlreadyActive
  • ObjectNotActive
  • PERSIST_STORE
  • PolicyError
  • REBIND
  • RemarshalException
  • ServantAlreadyActive
  • ServantNotActive
  • SystemException
  • TIMEOUT
  • TRANSACTION_MODE
  • TRANSACTION_REQUIRED
  • TRANSACTION_ROLLEDBACK
  • TRANSACTION_UNAVAILABLE
  • TRANSIENT
  • TypeMismatch
  • TypeMismatch
  • TypeMismatch
  • UNKNOWN
  • UnknownEncoding
  • UnknownException
  • UnknownUserException
  • UserException
  • WrongAdapter
  • WrongPolicy
  • WrongTransaction


java.datatransfer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.datatransfer

定义用于在应用程序之间和之间传输数据的API。
Module Graph:
Module graph for java.datatransfer Module graph for java.datatransfer
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.awt.datatransfer
      提供用于在应用程序之间和之间传输数据的接口和类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.datatransfer (Java SE 9 & JDK 9 )

java.datatransfer

Interfaces

  • ClipboardOwner
  • FlavorListener
  • FlavorMap
  • FlavorTable
  • Transferable

Classes

  • Clipboard
  • DataFlavor
  • FlavorEvent
  • StringSelection
  • SystemFlavorMap

Exceptions

  • MimeTypeParseException
  • UnsupportedFlavorException


java.desktop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.desktop

定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
Module Graph:
Module graph for java.desktop Module graph for java.desktop
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.applet
      提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
      java.awt
      包含用于创建用户界面和绘制图形和图像的所有类。
      java.awt.color
      提供颜色空间的类。
      java.awt.desktop
      提供与各种桌面功能交互的接口和类。
      java.awt.dnd
      拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
      java.awt.event
      提供用于处理AWT组件触发的不同类型事件的接口和类。
      java.awt.font
      提供与字体相关的类和界面。
      java.awt.geom
      提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
      java.awt.im
      提供输入法框架的类和接口。
      java.awt.im.spi
      提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
      java.awt.image
      提供创建和修改图像的类。
      java.awt.image.renderable
      提供用于生成与渲染无关的图像的类和接口。
      java.awt.print
      提供通用打印API的类和接口。
      java.beans
      包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
      java.beans.beancontext
      提供与bean上下文相关的类和接口。
      javax.accessibility
      定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
      javax.imageio
      Java Image I / O API的主要包。
      javax.imageio.event
      一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
      javax.imageio.metadata
      处理读写元数据的Java Image I / O API的一个包。
      javax.imageio.plugins.bmp
      包含内置BMP插件使用的公共类的软件包。
      javax.imageio.plugins.jpeg
      支持内置JPEG插件的类。
      javax.imageio.plugins.tiff
      内置TIFF插件使用的公共类。
      javax.imageio.spi
      包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
      javax.imageio.stream
      Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
      javax.print
      提供Java®打印服务API的主要类和接口。
      javax.print.attribute
      提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
      javax.print.attribute.standard
      包javax.print.attribute.standard包含特定打印属性的类。
      javax.print.event
      程序包javax.print.event包含事件类和侦听器接口。
      javax.sound.midi
      提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
      javax.sound.midi.spi
      为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
      javax.sound.sampled
      提供用于捕获，处理和播放采样音频数据的接口和类。
      javax.sound.sampled.spi
      为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
      javax.swing
      提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
      javax.swing.border
      提供用于绘制Swing组件周围特殊边框的类和接口。
      javax.swing.colorchooser
      包含 JColorChooser组件使用的类和接口。
      javax.swing.event
      提供Swing组件触发的事件。
      javax.swing.filechooser
      包含 JFileChooser组件使用的类和接口。
      javax.swing.plaf
      提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
      javax.swing.plaf.basic
      提供根据“基本”外观构建的用户界面对象。
      javax.swing.plaf.metal
      提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
      javax.swing.plaf.multi
      提供组合两种或多种外观和感觉的用户界面对象。
      javax.swing.plaf.nimbus
      提供根据跨平台Nimbus外观构建的用户界面对象。
      javax.swing.plaf.synth
      合成是一种可以让所有绘画委托的外观和感觉。
      javax.swing.table
      提供处理 javax.swing.JTable类和接口。
      javax.swing.text
      提供处理可编辑和不可编辑文本组件的类和接口。
      javax.swing.text.html
      提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
      javax.swing.text.html.parser
      提供默认的HTML解析器以及支持类。
      javax.swing.text.rtf
      提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
      javax.swing.tree
      提供处理 javax.swing.JTree类和接口。
      javax.swing.undo
      允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
      Indirect Exports
      From Packages
      java.datatransfer java.awt.datatransfer
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。

    • Services

      Uses
      Type 描述
      AccessibilityProvider
      用于辅助技术的服务提供商接口（SPI）。
      AudioFileReader
      音频文件阅读服务提供商。
      AudioFileWriter
      音频文件写入服务提供商。
      FormatConversionProvider
      格式转换提供者将一种或多种输入格式的格式转换服务提供给一种或多种输出格式。
      ImageInputStreamSpi
      ImageInputStream的服务提供商接口（SPI）。
      ImageOutputStreamSpi
      ImageOutputStream的服务提供商接口（SPI）。
      ImageReaderSpi
      服务提供商接口（SPI），用于 ImageReader s。
      ImageTranscoderSpi
      ImageTranscoder的服务提供商接口（SPI）。
      ImageWriterSpi
      ImageWriter的服务提供商接口（SPI）。
      InputMethodDescriptor
      定义提供有关输入法的足够信息以启用该输入法的选择和加载的方法。
      MidiDeviceProvider
      A MidiDeviceProvider是特定类型的MIDI设备的工厂或提供商。
      MidiFileReader
      A MidiFileReader提供MIDI文件阅读服务。
      MidiFileWriter
      A MidiFileWriter提供MIDI文件写入服务。
      MixerProvider
      特定搅拌机型号的供应商或工厂。
      PrintServiceLookup
      该类的实现为特定类型的打印服务（通常相当于打印机）提供查找服务。
      SoundbankReader
      A SoundbankReader提供 SoundbankReader文件阅读服务。
      StreamPrintServiceFactory
      A StreamPrintServiceFactory是StreamPrintService实例的工厂，可以以描述为MIME类型的特定文档格式打印到输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.desktop (Java SE 9 & JDK 9 )

java.desktop

Interfaces

  • AboutHandler
  • AbstractDocument.AttributeContext
  • AbstractDocument.Content
  • Accessible
  • AccessibleAction
  • AccessibleComponent
  • AccessibleEditableText
  • AccessibleExtendedComponent
  • AccessibleExtendedTable
  • AccessibleExtendedText
  • AccessibleHypertext
  • AccessibleIcon
  • AccessibleKeyBinding
  • AccessibleSelection
  • AccessibleStreamable
  • AccessibleTable
  • AccessibleTableModelChange
  • AccessibleText
  • AccessibleValue
  • Action
  • ActionListener
  • ActiveEvent
  • Adjustable
  • AdjustmentListener
  • AncestorListener
  • AppForegroundListener
  • AppHiddenListener
  • AppletContext
  • AppletInitializer
  • AppletStub
  • AppReopenedListener
  • Attribute
  • AttributeException
  • AttributeSet
  • AttributeSet
  • AttributeSet.CharacterAttribute
  • AttributeSet.ColorAttribute
  • AttributeSet.FontAttribute
  • AttributeSet.ParagraphAttribute
  • AudioClip
  • Autoscroll
  • AWTEventListener
  • BeanContext
  • BeanContextChild
  • BeanContextChildComponentProxy
  • BeanContextContainerProxy
  • BeanContextMembershipListener
  • BeanContextProxy
  • BeanContextServiceProvider
  • BeanContextServiceProviderBeanInfo
  • BeanContextServiceRevokedListener
  • BeanContextServices
  • BeanContextServicesListener
  • BeanInfo
  • Border
  • BoundedRangeModel
  • BufferedImageOp
  • ButtonModel
  • CancelablePrintJob
  • Caret
  • CaretListener
  • CellEditor
  • CellEditorListener
  • ChangeListener
  • Clip
  • ColorSelectionModel
  • ComboBoxEditor
  • ComboBoxModel
  • ComboPopup
  • ComponentListener
  • Composite
  • CompositeContext
  • ContainerListener
  • ContextualRenderedImageFactory
  • ControllerEventListener
  • Customizer
  • DataLine
  • DesignMode
  • DesktopManager
  • Doc
  • DocAttribute
  • DocAttributeSet
  • DocPrintJob
  • Document
  • DocumentEvent
  • DocumentEvent.ElementChange
  • DocumentListener
  • DragGestureListener
  • DragSourceListener
  • DragSourceMotionListener
  • DropTargetListener
  • DTDConstants
  • Element
  • ExceptionListener
  • FlavorException
  • FocusListener
  • HierarchyBoundsListener
  • HierarchyListener
  • Highlighter
  • Highlighter.Highlight
  • Highlighter.HighlightPainter
  • HyperlinkListener
  • Icon
  • IIOMetadataController
  • IIOMetadataFormat
  • IIOParamController
  • IIOReadProgressListener
  • IIOReadUpdateListener
  • IIOReadWarningListener
  • IIOWriteProgressListener
  • IIOWriteWarningListener
  • ImageConsumer
  • ImageInputStream
  • ImageObserver
  • ImageOutputStream
  • ImageProducer
  • ImageTranscoder
  • InputMethod
  • InputMethodContext
  • InputMethodDescriptor
  • InputMethodListener
  • InputMethodRequests
  • InternalFrameListener
  • ItemListener
  • ItemSelectable
  • JComboBox.KeySelectionManager
  • KeyEventDispatcher
  • KeyEventPostProcessor
  • KeyListener
  • Keymap
  • LayoutManager
  • LayoutManager2
  • Line
  • LineListener
  • ListCellRenderer
  • ListDataListener
  • ListModel
  • ListSelectionListener
  • ListSelectionModel
  • MenuContainer
  • MenuDragMouseListener
  • MenuElement
  • MenuKeyListener
  • MenuListener
  • MetaEventListener
  • MidiChannel
  • MidiDevice
  • MidiDeviceReceiver
  • MidiDeviceTransmitter
  • Mixer
  • MouseInputListener
  • MouseListener
  • MouseMotionListener
  • MouseWheelListener
  • MultiDoc
  • MultiDocPrintJob
  • MultiDocPrintService
  • MultipleMaster
  • MultiResolutionImage
  • MutableAttributeSet
  • MutableComboBoxModel
  • MutableTreeNode
  • OpenFilesHandler
  • OpenType
  • OpenURIHandler
  • Pageable
  • Paint
  • PaintContext
  • Painter
  • PathIterator
  • PopupMenuListener
  • Port
  • Position
  • PreferencesHandler
  • Printable
  • PrinterGraphics
  • PrintFilesHandler
  • PrintGraphics
  • PrintJobAttribute
  • PrintJobAttributeListener
  • PrintJobAttributeSet
  • PrintJobListener
  • PrintRequestAttribute
  • PrintRequestAttributeSet
  • PrintService
  • PrintServiceAttribute
  • PrintServiceAttributeListener
  • PrintServiceAttributeSet
  • PropertyChangeListener
  • PropertyEditor
  • QuitHandler
  • QuitResponse
  • RasterOp
  • Receiver
  • RegisterableService
  • RenderableImage
  • RenderedImage
  • RenderedImageFactory
  • Renderer
  • RootPaneContainer
  • RowMapper
  • RowSorterListener
  • ScreenSleepListener
  • Scrollable
  • ScrollPaneConstants
  • SecondaryLoop
  • Sequencer
  • ServiceRegistry.Filter
  • Shape
  • SingleSelectionModel
  • Soundbank
  • SourceDataLine
  • SpinnerModel
  • StateEditable
  • Stroke
  • Style
  • StyledDocument
  • SupportedValuesAttribute
  • SwingConstants
  • SynthConstants
  • Synthesizer
  • SynthIcon
  • SynthUI
  • SystemEventListener
  • SystemSleepListener
  • TabableView
  • TabExpander
  • TableCellEditor
  • TableCellRenderer
  • TableColumnModel
  • TableColumnModelListener
  • TableModel
  • TableModelListener
  • TargetDataLine
  • TextListener
  • TileObserver
  • Transmitter
  • Transparency
  • TreeCellEditor
  • TreeCellRenderer
  • TreeExpansionListener
  • TreeModel
  • TreeModelListener
  • TreeNode
  • TreeSelectionListener
  • TreeSelectionModel
  • TreeWillExpandListener
  • UIClientPropertyKey
  • UIDefaults.ActiveValue
  • UIDefaults.LazyValue
  • UIResource
  • UndoableEdit
  • UndoableEditListener
  • URIException
  • UserSessionListener
  • VetoableChangeListener
  • ViewFactory
  • Visibility
  • WindowConstants
  • WindowFocusListener
  • WindowListener
  • WindowStateListener
  • WritableRenderedImage

Classes

  • AboutEvent
  • AbstractAction
  • AbstractBorder
  • AbstractButton
  • AbstractCellEditor
  • AbstractColorChooserPanel
  • AbstractDocument
  • AbstractDocument.ElementEdit
  • AbstractLayoutCache
  • AbstractLayoutCache.NodeDimensions
  • AbstractListModel
  • AbstractMultiResolutionImage
  • AbstractRegionPainter
  • AbstractRegionPainter.PaintContext
  • AbstractSpinnerModel
  • AbstractTableModel
  • AbstractUndoableEdit
  • AbstractWriter
  • AccessibilityProvider
  • AccessibleAttributeSequence
  • AccessibleBundle
  • AccessibleContext
  • AccessibleHyperlink
  • AccessibleRelation
  • AccessibleRelationSet
  • AccessibleResourceBundle
  • AccessibleRole
  • AccessibleState
  • AccessibleStateSet
  • AccessibleTextSequence
  • ActionEvent
  • ActionMap
  • ActionMapUIResource
  • AdjustmentEvent
  • AffineTransform
  • AffineTransformOp
  • AlphaComposite
  • AncestorEvent
  • AppEvent
  • AppForegroundEvent
  • AppHiddenEvent
  • Applet
  • AppReopenedEvent
  • Arc2D
  • Arc2D.Double
  • Arc2D.Float
  • Area
  • AreaAveragingScaleFilter
  • AsyncBoxView
  • AttributeList
  • AttributeSetUtilities
  • AudioFileFormat
  • AudioFileFormat.Type
  • AudioFileReader
  • AudioFileWriter
  • AudioFormat
  • AudioFormat.Encoding
  • AudioInputStream
  • AudioPermission
  • AudioSystem
  • AWTEvent
  • AWTEventListenerProxy
  • AWTEventMulticaster
  • AWTKeyStroke
  • AWTPermission
  • BandCombineOp
  • BandedSampleModel
  • BaselineTIFFTagSet
  • BaseMultiResolutionImage
  • BasicArrowButton
  • BasicBorders
  • BasicBorders.ButtonBorder
  • BasicBorders.FieldBorder
  • BasicBorders.MarginBorder
  • BasicBorders.MenuBarBorder
  • BasicBorders.RadioButtonBorder
  • BasicBorders.RolloverButtonBorder
  • BasicBorders.SplitPaneBorder
  • BasicBorders.ToggleButtonBorder
  • BasicButtonListener
  • BasicButtonUI
  • BasicCheckBoxMenuItemUI
  • BasicCheckBoxUI
  • BasicColorChooserUI
  • BasicComboBoxEditor
  • BasicComboBoxEditor.UIResource
  • BasicComboBoxRenderer
  • BasicComboBoxRenderer.UIResource
  • BasicComboBoxUI
  • BasicComboPopup
  • BasicDesktopIconUI
  • BasicDesktopPaneUI
  • BasicDirectoryModel
  • BasicEditorPaneUI
  • BasicFileChooserUI
  • BasicFormattedTextFieldUI
  • BasicGraphicsUtils
  • BasicHTML
  • BasicIconFactory
  • BasicInternalFrameTitlePane
  • BasicInternalFrameUI
  • BasicLabelUI
  • BasicListUI
  • BasicLookAndFeel
  • BasicMenuBarUI
  • BasicMenuItemUI
  • BasicMenuUI
  • BasicOptionPaneUI
  • BasicOptionPaneUI.ButtonAreaLayout
  • BasicPanelUI
  • BasicPasswordFieldUI
  • BasicPopupMenuSeparatorUI
  • BasicPopupMenuUI
  • BasicProgressBarUI
  • BasicRadioButtonMenuItemUI
  • BasicRadioButtonUI
  • BasicRootPaneUI
  • BasicScrollBarUI
  • BasicScrollPaneUI
  • BasicSeparatorUI
  • BasicSliderUI
  • BasicSpinnerUI
  • BasicSplitPaneDivider
  • BasicSplitPaneUI
  • BasicStroke
  • BasicTabbedPaneUI
  • BasicTableHeaderUI
  • BasicTableUI
  • BasicTextAreaUI
  • BasicTextFieldUI
  • BasicTextPaneUI
  • BasicTextUI
  • BasicTextUI.BasicCaret
  • BasicTextUI.BasicHighlighter
  • BasicToggleButtonUI
  • BasicToolBarSeparatorUI
  • BasicToolBarUI
  • BasicToolTipUI
  • BasicTreeUI
  • BasicViewportUI
  • BeanContextChildSupport
  • BeanContextEvent
  • BeanContextMembershipEvent
  • BeanContextServiceAvailableEvent
  • BeanContextServiceRevokedEvent
  • BeanContextServicesSupport
  • BeanContextServicesSupport.BCSSServiceProvider
  • BeanContextSupport
  • BeanContextSupport.BCSIterator
  • BeanDescriptor
  • Beans
  • BevelBorder
  • BlockView
  • BMPImageWriteParam
  • Book
  • BooleanControl
  • BooleanControl.Type
  • BorderFactory
  • BorderLayout
  • BorderUIResource
  • BorderUIResource.BevelBorderUIResource
  • BorderUIResource.CompoundBorderUIResource
  • BorderUIResource.EmptyBorderUIResource
  • BorderUIResource.EtchedBorderUIResource
  • BorderUIResource.LineBorderUIResource
  • BorderUIResource.MatteBorderUIResource
  • BorderUIResource.TitledBorderUIResource
  • Box
  • Box.Filler
  • BoxLayout
  • BoxView
  • BufferCapabilities
  • BufferCapabilities.FlipContents
  • BufferedImage
  • BufferedImageFilter
  • BufferStrategy
  • Button
  • ButtonGroup
  • ButtonUI
  • ByteLookupTable
  • Canvas
  • CardLayout
  • CaretEvent
  • CellRendererPane
  • ChangeEvent
  • Checkbox
  • CheckboxGroup
  • CheckboxMenuItem
  • Choice
  • Chromaticity
  • Color
  • ColorChooserComponentFactory
  • ColorChooserUI
  • ColorConvertOp
  • ColorModel
  • ColorSpace
  • ColorSupported
  • ColorType
  • ColorUIResource
  • ComboBoxUI
  • Component
  • ComponentAdapter
  • ComponentColorModel
  • ComponentEvent
  • ComponentInputMap
  • ComponentInputMapUIResource
  • ComponentOrientation
  • ComponentSampleModel
  • ComponentUI
  • ComponentView
  • CompositeView
  • CompoundBorder
  • CompoundControl
  • CompoundControl.Type
  • CompoundEdit
  • Compression
  • Container
  • ContainerAdapter
  • ContainerEvent
  • ContainerOrderFocusTraversalPolicy
  • ContentModel
  • Control
  • Control.Type
  • ConvolveOp
  • Copies
  • CopiesSupported
  • CropImageFilter
  • CSS
  • CSS.Attribute
  • CubicCurve2D
  • CubicCurve2D.Double
  • CubicCurve2D.Float
  • Cursor
  • DataBuffer
  • DataBufferByte
  • DataBufferDouble
  • DataBufferFloat
  • DataBufferInt
  • DataBufferShort
  • DataBufferUShort
  • DataLine.Info
  • DateFormatter
  • DateTimeAtCompleted
  • DateTimeAtCreation
  • DateTimeAtProcessing
  • DateTimeSyntax
  • DebugGraphics
  • DefaultBoundedRangeModel
  • DefaultButtonModel
  • DefaultCaret
  • DefaultCellEditor
  • DefaultColorSelectionModel
  • DefaultComboBoxModel
  • DefaultDesktopManager
  • DefaultEditorKit
  • DefaultEditorKit.BeepAction
  • DefaultEditorKit.CopyAction
  • DefaultEditorKit.CutAction
  • DefaultEditorKit.DefaultKeyTypedAction
  • DefaultEditorKit.InsertBreakAction
  • DefaultEditorKit.InsertContentAction
  • DefaultEditorKit.InsertTabAction
  • DefaultEditorKit.PasteAction
  • DefaultFocusManager
  • DefaultFocusTraversalPolicy
  • DefaultFormatter
  • DefaultFormatterFactory
  • DefaultHighlighter
  • DefaultHighlighter.DefaultHighlightPainter
  • DefaultKeyboardFocusManager
  • DefaultListCellRenderer
  • DefaultListCellRenderer.UIResource
  • DefaultListModel
  • DefaultListSelectionModel
  • DefaultMenuLayout
  • DefaultMetalTheme
  • DefaultMutableTreeNode
  • DefaultPersistenceDelegate
  • DefaultRowSorter
  • DefaultRowSorter.ModelWrapper
  • DefaultSingleSelectionModel
  • DefaultStyledDocument
  • DefaultStyledDocument.AttributeUndoableEdit
  • DefaultStyledDocument.ElementSpec
  • DefaultTableCellRenderer
  • DefaultTableCellRenderer.UIResource
  • DefaultTableColumnModel
  • DefaultTableModel
  • DefaultTextUI
  • DefaultTreeCellEditor
  • DefaultTreeCellRenderer
  • DefaultTreeModel
  • DefaultTreeSelectionModel
  • Desktop
  • DesktopIconUI
  • DesktopPaneUI
  • Destination
  • Dialog
  • DialogTypeSelection
  • Dimension
  • Dimension2D
  • DimensionUIResource
  • DirectColorModel
  • DisplayMode
  • DnDConstants
  • DocFlavor
  • DocFlavor.BYTE_ARRAY
  • DocFlavor.CHAR_ARRAY
  • DocFlavor.INPUT_STREAM
  • DocFlavor.READER
  • DocFlavor.SERVICE_FORMATTED
  • DocFlavor.STRING
  • DocFlavor.URL
  • DocumentEvent.EventType
  • DocumentFilter
  • DocumentFilter.FilterBypass
  • DocumentName
  • DocumentParser
  • DragGestureEvent
  • DragGestureRecognizer
  • DragSource
  • DragSourceAdapter
  • DragSourceContext
  • DragSourceDragEvent
  • DragSourceDropEvent
  • DragSourceEvent
  • DropTarget
  • DropTarget.DropTargetAutoScroller
  • DropTargetAdapter
  • DropTargetContext
  • DropTargetDragEvent
  • DropTargetDropEvent
  • DropTargetEvent
  • DTD
  • EditorKit
  • Element
  • ElementIterator
  • Ellipse2D
  • Ellipse2D.Double
  • Ellipse2D.Float
  • EmptyBorder
  • Encoder
  • Entity
  • EnumControl
  • EnumControl.Type
  • EnumSyntax
  • EtchedBorder
  • Event
  • EventHandler
  • EventListenerList
  • EventQueue
  • EventSetDescriptor
  • ExifGPSTagSet
  • ExifInteroperabilityTagSet
  • ExifParentTIFFTagSet
  • ExifTIFFTagSet
  • Expression
  • FaxTIFFTagSet
  • FeatureDescriptor
  • Fidelity
  • FieldView
  • FileCacheImageInputStream
  • FileCacheImageOutputStream
  • FileChooserUI
  • FileDialog
  • FileFilter
  • FileImageInputStream
  • FileImageOutputStream
  • FileNameExtensionFilter
  • FilesEvent
  • FileSystemView
  • FileView
  • FilteredImageSource
  • Finishings
  • FixedHeightLayoutCache
  • FlatteningPathIterator
  • FloatControl
  • FloatControl.Type
  • FlowLayout
  • FlowView
  • FlowView.FlowStrategy
  • FocusAdapter
  • FocusEvent
  • FocusManager
  • FocusTraversalPolicy
  • Font
  • FontMetrics
  • FontRenderContext
  • FontUIResource
  • FormatConversionProvider
  • FormSubmitEvent
  • FormView
  • Frame
  • GapContent
  • GeneralPath
  • GeoTIFFTagSet
  • GlyphJustificationInfo
  • GlyphMetrics
  • GlyphVector
  • GlyphView
  • GlyphView.GlyphPainter
  • GradientPaint
  • GraphicAttribute
  • Graphics
  • Graphics2D
  • GraphicsConfigTemplate
  • GraphicsConfiguration
  • GraphicsDevice
  • GraphicsEnvironment
  • GrayFilter
  • GridBagConstraints
  • GridBagLayout
  • GridBagLayoutInfo
  • GridLayout
  • GroupLayout
  • HashAttributeSet
  • HashDocAttributeSet
  • HashPrintJobAttributeSet
  • HashPrintRequestAttributeSet
  • HashPrintServiceAttributeSet
  • HierarchyBoundsAdapter
  • HierarchyEvent
  • HTML
  • HTML.Attribute
  • HTML.Tag
  • HTML.UnknownTag
  • HTMLDocument
  • HTMLDocument.Iterator
  • HTMLEditorKit
  • HTMLEditorKit.HTMLFactory
  • HTMLEditorKit.HTMLTextAction
  • HTMLEditorKit.InsertHTMLTextAction
  • HTMLEditorKit.LinkController
  • HTMLEditorKit.Parser
  • HTMLEditorKit.ParserCallback
  • HTMLFrameHyperlinkEvent
  • HTMLWriter
  • HyperlinkEvent
  • HyperlinkEvent.EventType
  • ICC_ColorSpace
  • ICC_Profile
  • ICC_ProfileGray
  • ICC_ProfileRGB
  • IconUIResource
  • IconView
  • IIOByteBuffer
  • IIOImage
  • IIOMetadata
  • IIOMetadataFormatImpl
  • IIOMetadataNode
  • IIOParam
  • IIORegistry
  • IIOServiceProvider
  • Image
  • ImageCapabilities
  • ImageFilter
  • ImageGraphicAttribute
  • ImageIcon
  • ImageInputStreamImpl
  • ImageInputStreamSpi
  • ImageIO
  • ImageOutputStreamImpl
  • ImageOutputStreamSpi
  • ImageReader
  • ImageReaderSpi
  • ImageReaderWriterSpi
  • ImageReadParam
  • ImageTranscoderSpi
  • ImageTypeSpecifier
  • ImageView
  • ImageWriteParam
  • ImageWriter
  • ImageWriterSpi
  • IndexColorModel
  • IndexedPropertyChangeEvent
  • IndexedPropertyDescriptor
  • InlineView
  • InputContext
  • InputEvent
  • InputMap
  • InputMapUIResource
  • InputMethodEvent
  • InputMethodHighlight
  • InputSubset
  • InputVerifier
  • Insets
  • InsetsUIResource
  • Instrument
  • IntegerSyntax
  • InternalFrameAdapter
  • InternalFrameEvent
  • InternalFrameFocusTraversalPolicy
  • InternalFrameUI
  • InternationalFormatter
  • Introspector
  • InvocationEvent
  • ItemEvent
  • JApplet
  • JButton
  • JCheckBox
  • JCheckBoxMenuItem
  • JColorChooser
  • JComboBox
  • JComponent
  • JDesktopPane
  • JDialog
  • JEditorPane
  • JFileChooser
  • JFormattedTextField
  • JFormattedTextField.AbstractFormatter
  • JFormattedTextField.AbstractFormatterFactory
  • JFrame
  • JInternalFrame
  • JInternalFrame.JDesktopIcon
  • JLabel
  • JLayer
  • JLayeredPane
  • JList
  • JList.DropLocation
  • JMenu
  • JMenuBar
  • JMenuItem
  • JobAttributes
  • JobAttributes.DefaultSelectionType
  • JobAttributes.DestinationType
  • JobAttributes.DialogType
  • JobAttributes.MultipleDocumentHandlingType
  • JobAttributes.SidesType
  • JobHoldUntil
  • JobImpressions
  • JobImpressionsCompleted
  • JobImpressionsSupported
  • JobKOctets
  • JobKOctetsProcessed
  • JobKOctetsSupported
  • JobMediaSheets
  • JobMediaSheetsCompleted
  • JobMediaSheetsSupported
  • JobMessageFromOperator
  • JobName
  • JobOriginatingUserName
  • JobPriority
  • JobPrioritySupported
  • JobSheets
  • JobState
  • JobStateReason
  • JobStateReasons
  • JOptionPane
  • JPanel
  • JPasswordField
  • JPEGHuffmanTable
  • JPEGImageReadParam
  • JPEGImageWriteParam
  • JPEGQTable
  • JPopupMenu
  • JPopupMenu.Separator
  • JProgressBar
  • JRadioButton
  • JRadioButtonMenuItem
  • JRootPane
  • JScrollBar
  • JScrollPane
  • JSeparator
  • JSlider
  • JSpinner
  • JSpinner.DateEditor
  • JSpinner.DefaultEditor
  • JSpinner.ListEditor
  • JSpinner.NumberEditor
  • JSplitPane
  • JTabbedPane
  • JTable
  • JTable.DropLocation
  • JTableHeader
  • JTextArea
  • JTextComponent
  • JTextComponent.DropLocation
  • JTextComponent.KeyBinding
  • JTextField
  • JTextPane
  • JToggleButton
  • JToggleButton.ToggleButtonModel
  • JToolBar
  • JToolBar.Separator
  • JToolTip
  • JTree
  • JTree.DropLocation
  • JTree.DynamicUtilTreeNode
  • JTree.EmptySelectionModel
  • JViewport
  • JWindow
  • Kernel
  • KeyAdapter
  • KeyboardFocusManager
  • KeyEvent
  • KeyStroke
  • Label
  • LabelUI
  • LabelView
  • LayeredHighlighter
  • LayeredHighlighter.LayerPainter
  • LayerUI
  • LayoutFocusTraversalPolicy
  • LayoutPath
  • LayoutQueue
  • LayoutStyle
  • Line.Info
  • Line2D
  • Line2D.Double
  • Line2D.Float
  • LinearGradientPaint
  • LineBorder
  • LineBreakMeasurer
  • LineEvent
  • LineEvent.Type
  • LineMetrics
  • List
  • ListDataEvent
  • ListSelectionEvent
  • ListUI
  • ListView
  • LookAndFeel
  • LookupOp
  • LookupTable
  • MaskFormatter
  • MatteBorder
  • Media
  • MediaName
  • MediaPrintableArea
  • MediaSize
  • MediaSize.Engineering
  • MediaSize.ISO
  • MediaSize.JIS
  • MediaSize.NA
  • MediaSize.Other
  • MediaSizeName
  • MediaTracker
  • MediaTray
  • MemoryCacheImageInputStream
  • MemoryCacheImageOutputStream
  • MemoryImageSource
  • Menu
  • MenuBar
  • MenuBarUI
  • MenuComponent
  • MenuDragMouseEvent
  • MenuEvent
  • MenuItem
  • MenuItemUI
  • MenuKeyEvent
  • MenuSelectionManager
  • MenuShortcut
  • MetalBorders
  • MetalBorders.ButtonBorder
  • MetalBorders.Flush3DBorder
  • MetalBorders.InternalFrameBorder
  • MetalBorders.MenuBarBorder
  • MetalBorders.MenuItemBorder
  • MetalBorders.OptionDialogBorder
  • MetalBorders.PaletteBorder
  • MetalBorders.PopupMenuBorder
  • MetalBorders.RolloverButtonBorder
  • MetalBorders.ScrollPaneBorder
  • MetalBorders.TableHeaderBorder
  • MetalBorders.TextFieldBorder
  • MetalBorders.ToggleButtonBorder
  • MetalBorders.ToolBarBorder
  • MetalButtonUI
  • MetalCheckBoxIcon
  • MetalCheckBoxUI
  • MetalComboBoxButton
  • MetalComboBoxEditor
  • MetalComboBoxEditor.UIResource
  • MetalComboBoxIcon
  • MetalComboBoxUI
  • MetalDesktopIconUI
  • MetalFileChooserUI
  • MetalIconFactory
  • MetalIconFactory.FileIcon16
  • MetalIconFactory.FolderIcon16
  • MetalIconFactory.PaletteCloseIcon
  • MetalIconFactory.TreeControlIcon
  • MetalIconFactory.TreeFolderIcon
  • MetalIconFactory.TreeLeafIcon
  • MetalInternalFrameTitlePane
  • MetalInternalFrameUI
  • MetalLabelUI
  • MetalLookAndFeel
  • MetalMenuBarUI
  • MetalPopupMenuSeparatorUI
  • MetalProgressBarUI
  • MetalRadioButtonUI
  • MetalRootPaneUI
  • MetalScrollBarUI
  • MetalScrollButton
  • MetalScrollPaneUI
  • MetalSeparatorUI
  • MetalSliderUI
  • MetalSplitPaneUI
  • MetalTabbedPaneUI
  • MetalTextFieldUI
  • MetalTheme
  • MetalToggleButtonUI
  • MetalToolBarUI
  • MetalToolTipUI
  • MetalTreeUI
  • MetaMessage
  • MethodDescriptor
  • MidiDevice.Info
  • MidiDeviceProvider
  • MidiEvent
  • MidiFileFormat
  • MidiFileReader
  • MidiFileWriter
  • MidiMessage
  • MidiSystem
  • MinimalHTMLWriter
  • Mixer.Info
  • MixerProvider
  • MouseAdapter
  • MouseDragGestureRecognizer
  • MouseEvent
  • MouseInfo
  • MouseInputAdapter
  • MouseMotionAdapter
  • MouseWheelEvent
  • MultiButtonUI
  • MultiColorChooserUI
  • MultiComboBoxUI
  • MultiDesktopIconUI
  • MultiDesktopPaneUI
  • MultiFileChooserUI
  • MultiInternalFrameUI
  • MultiLabelUI
  • MultiListUI
  • MultiLookAndFeel
  • MultiMenuBarUI
  • MultiMenuItemUI
  • MultiOptionPaneUI
  • MultiPanelUI
  • MultiPixelPackedSampleModel
  • MultipleDocumentHandling
  • MultipleGradientPaint
  • MultiPopupMenuUI
  • MultiProgressBarUI
  • MultiRootPaneUI
  • MultiScrollBarUI
  • MultiScrollPaneUI
  • MultiSeparatorUI
  • MultiSliderUI
  • MultiSpinnerUI
  • MultiSplitPaneUI
  • MultiTabbedPaneUI
  • MultiTableHeaderUI
  • MultiTableUI
  • MultiTextUI
  • MultiToolBarUI
  • MultiToolTipUI
  • MultiTreeUI
  • MultiViewportUI
  • NavigationFilter
  • NavigationFilter.FilterBypass
  • NimbusLookAndFeel
  • NimbusStyle
  • NumberFormatter
  • NumberOfDocuments
  • NumberOfInterveningJobs
  • NumberUp
  • NumberUpSupported
  • NumericShaper
  • ObjectView
  • OceanTheme
  • OpenFilesEvent
  • OpenURIEvent
  • Option
  • OptionPaneUI
  • OrientationRequested
  • OutputDeviceAssigned
  • OverlayLayout
  • PackedColorModel
  • PageAttributes
  • PageAttributes.ColorType
  • PageAttributes.MediaType
  • PageAttributes.OrientationRequestedType
  • PageAttributes.OriginType
  • PageAttributes.PrintQualityType
  • PageFormat
  • PageRanges
  • PagesPerMinute
  • PagesPerMinuteColor
  • PaintEvent
  • Panel
  • PanelUI
  • Paper
  • ParagraphView
  • ParagraphView
  • ParameterBlock
  • ParameterDescriptor
  • Parser
  • ParserDelegator
  • PasswordView
  • Patch
  • Path2D
  • Path2D.Double
  • Path2D.Float
  • PDLOverrideSupported
  • PersistenceDelegate
  • PixelGrabber
  • PixelInterleavedSampleModel
  • PlainDocument
  • PlainView
  • Point
  • Point2D
  • Point2D.Double
  • Point2D.Float
  • PointerInfo
  • Polygon
  • Popup
  • PopupFactory
  • PopupMenu
  • PopupMenuEvent
  • PopupMenuUI
  • Port.Info
  • Position.Bias
  • PreferencesEvent
  • PresentationDirection
  • PrinterInfo
  • PrinterIsAcceptingJobs
  • PrinterJob
  • PrinterLocation
  • PrinterMakeAndModel
  • PrinterMessageFromOperator
  • PrinterMoreInfo
  • PrinterMoreInfoManufacturer
  • PrinterName
  • PrinterResolution
  • PrinterState
  • PrinterStateReason
  • PrinterStateReasons
  • PrinterURI
  • PrintEvent
  • PrintFilesEvent
  • PrintJob
  • PrintJobAdapter
  • PrintJobAttributeEvent
  • PrintJobEvent
  • PrintQuality
  • PrintServiceAttributeEvent
  • PrintServiceLookup
  • ProgressBarUI
  • ProgressMonitor
  • ProgressMonitorInputStream
  • PropertyChangeEvent
  • PropertyChangeListenerProxy
  • PropertyChangeSupport
  • PropertyDescriptor
  • PropertyEditorManager
  • PropertyEditorSupport
  • QuadCurve2D
  • QuadCurve2D.Double
  • QuadCurve2D.Float
  • QueuedJobCount
  • QuitEvent
  • RadialGradientPaint
  • Raster
  • Rectangle
  • Rectangle2D
  • Rectangle2D.Double
  • Rectangle2D.Float
  • RectangularShape
  • ReferenceUriSchemesSupported
  • Region
  • RenderableImageOp
  • RenderableImageProducer
  • RenderContext
  • RenderingHints
  • RenderingHints.Key
  • RepaintManager
  • ReplicateScaleFilter
  • RequestingUserName
  • RescaleOp
  • ResolutionSyntax
  • ReverbType
  • RGBImageFilter
  • Robot
  • RootPaneUI
  • RoundRectangle2D
  • RoundRectangle2D.Double
  • RoundRectangle2D.Float
  • RowFilter
  • RowFilter.Entry
  • RowSorter
  • RowSorter.SortKey
  • RowSorterEvent
  • RTFEditorKit
  • SampleModel
  • ScreenSleepEvent
  • Scrollbar
  • ScrollBarUI
  • ScrollPane
  • ScrollPaneAdjustable
  • ScrollPaneLayout
  • ScrollPaneLayout.UIResource
  • ScrollPaneUI
  • Segment
  • SeparatorUI
  • Sequence
  • Sequencer.SyncMode
  • ServiceRegistry
  • ServiceUI
  • ServiceUIFactory
  • SetOfIntegerSyntax
  • Severity
  • ShapeGraphicAttribute
  • SheetCollate
  • ShortLookupTable
  • ShortMessage
  • Sides
  • SimpleAttributeSet
  • SimpleBeanInfo
  • SimpleDoc
  • SinglePixelPackedSampleModel
  • Size2DSyntax
  • SizeRequirements
  • SizeSequence
  • SliderUI
  • SoftBevelBorder
  • SortingFocusTraversalPolicy
  • SoundbankReader
  • SoundbankResource
  • SpinnerDateModel
  • SpinnerListModel
  • SpinnerNumberModel
  • SpinnerUI
  • SplashScreen
  • SplitPaneUI
  • Spring
  • SpringLayout
  • SpringLayout.Constraints
  • State
  • StateEdit
  • Statement
  • StreamPrintService
  • StreamPrintServiceFactory
  • StringContent
  • StrokeBorder
  • StyleConstants
  • StyleConstants.CharacterConstants
  • StyleConstants.ColorConstants
  • StyleConstants.FontConstants
  • StyleConstants.ParagraphConstants
  • StyleContext
  • StyledEditorKit
  • StyledEditorKit.AlignmentAction
  • StyledEditorKit.BoldAction
  • StyledEditorKit.FontFamilyAction
  • StyledEditorKit.FontSizeAction
  • StyledEditorKit.ForegroundAction
  • StyledEditorKit.ItalicAction
  • StyledEditorKit.StyledTextAction
  • StyledEditorKit.UnderlineAction
  • StyleSheet
  • StyleSheet.BoxPainter
  • StyleSheet.ListPainter
  • SwingPropertyChangeSupport
  • SwingUtilities
  • SwingWorker
  • SynthButtonUI
  • SynthCheckBoxMenuItemUI
  • SynthCheckBoxUI
  • SynthColorChooserUI
  • SynthComboBoxUI
  • SynthContext
  • SynthDesktopIconUI
  • SynthDesktopPaneUI
  • SynthEditorPaneUI
  • SynthFormattedTextFieldUI
  • SynthGraphicsUtils
  • SynthInternalFrameUI
  • SynthLabelUI
  • SynthListUI
  • SynthLookAndFeel
  • SynthMenuBarUI
  • SynthMenuItemUI
  • SynthMenuUI
  • SynthOptionPaneUI
  • SynthPainter
  • SynthPanelUI
  • SynthPasswordFieldUI
  • SynthPopupMenuUI
  • SynthProgressBarUI
  • SynthRadioButtonMenuItemUI
  • SynthRadioButtonUI
  • SynthRootPaneUI
  • SynthScrollBarUI
  • SynthScrollPaneUI
  • SynthSeparatorUI
  • SynthSliderUI
  • SynthSpinnerUI
  • SynthSplitPaneUI
  • SynthStyle
  • SynthStyleFactory
  • SynthTabbedPaneUI
  • SynthTableHeaderUI
  • SynthTableUI
  • SynthTextAreaUI
  • SynthTextFieldUI
  • SynthTextPaneUI
  • SynthToggleButtonUI
  • SynthToolBarUI
  • SynthToolTipUI
  • SynthTreeUI
  • SynthViewportUI
  • SysexMessage
  • SystemColor
  • SystemSleepEvent
  • SystemTray
  • TabbedPaneUI
  • TableColumn
  • TableColumnModelEvent
  • TableHeaderUI
  • TableModelEvent
  • TableRowSorter
  • TableStringConverter
  • TableUI
  • TableView
  • TabSet
  • TabStop
  • TagElement
  • Taskbar
  • TextAction
  • TextArea
  • TextAttribute
  • TextComponent
  • TextEvent
  • TextField
  • TextHitInfo
  • TextLayout
  • TextLayout.CaretPolicy
  • TextMeasurer
  • TextSyntax
  • TextUI
  • TexturePaint
  • TIFFDirectory
  • TIFFField
  • TIFFImageReadParam
  • TIFFTag
  • TIFFTagSet
  • Timer
  • TitledBorder
  • ToolBarUI
  • Toolkit
  • ToolTipManager
  • ToolTipUI
  • Track
  • TransferHandler
  • TransferHandler.DropLocation
  • TransferHandler.TransferSupport
  • TransformAttribute
  • TrayIcon
  • TreeExpansionEvent
  • TreeModelEvent
  • TreePath
  • TreeSelectionEvent
  • TreeUI
  • UIDefaults
  • UIDefaults.LazyInputMap
  • UIDefaults.ProxyLazyValue
  • UIManager
  • UIManager.LookAndFeelInfo
  • UndoableEditEvent
  • UndoableEditSupport
  • UndoManager
  • URISyntax
  • UserSessionEvent
  • Utilities
  • VariableHeightLayoutCache
  • VetoableChangeListenerProxy
  • VetoableChangeSupport
  • View
  • ViewportLayout
  • ViewportUI
  • VoiceStatus
  • VolatileImage
  • Window
  • WindowAdapter
  • WindowEvent
  • WrappedPlainView
  • WritableRaster
  • XMLDecoder
  • XMLEncoder
  • ZoneView

Enums

  • AbstractRegionPainter.PaintContext.CacheMode
  • Component.BaselineResizeBehavior
  • Desktop.Action
  • Dialog.ModalExclusionType
  • Dialog.ModalityType
  • DropMode
  • FocusEvent.Cause
  • FormSubmitEvent.MethodType
  • GraphicsDevice.WindowTranslucency
  • GroupLayout.Alignment
  • JTable.PrintMode
  • LayoutStyle.ComponentPlacement
  • MultipleGradientPaint.ColorSpaceType
  • MultipleGradientPaint.CycleMethod
  • NumericShaper.Range
  • QuitStrategy
  • RowFilter.ComparisonType
  • RowSorterEvent.Type
  • SortOrder
  • SwingWorker.StateValue
  • Taskbar.Feature
  • Taskbar.State
  • TrayIcon.MessageType
  • UserSessionEvent.Reason
  • Window.Type

Exceptions

  • AWTException
  • BadLocationException
  • CannotRedoException
  • CannotUndoException
  • ChangedCharSetException
  • CMMException
  • ExpandVetoException
  • FontFormatException
  • HeadlessException
  • IIOException
  • IIOInvalidTreeException
  • IllegalComponentStateException
  • IllegalPathStateException
  • ImagingOpException
  • IntrospectionException
  • InvalidDnDOperationException
  • InvalidMidiDataException
  • LineUnavailableException
  • MidiUnavailableException
  • NoninvertibleTransformException
  • PrinterAbortException
  • PrinterException
  • PrinterIOException
  • PrintException
  • ProfileDataException
  • PropertyVetoException
  • RasterFormatException
  • UnmodifiableSetException
  • UnsupportedAudioFileException
  • UnsupportedLookAndFeelException

Errors

  • AWTError

注解类型

  • BeanProperty
  • ConstructorProperties
  • JavaBean
  • SwingContainer
  • Transient


java.instrument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.instrument

定义允许代理程序在JVM上运行程序的服务。
Module Graph:
Module graph for java.instrument Module graph for java.instrument
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.lang.instrument
      提供允许Java编程语言代理仪器在JVM上运行程序的服务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.instrument (Java SE 9 & JDK 9 )

java.instrument

Interfaces

  • ClassFileTransformer
  • Instrumentation

Classes

  • ClassDefinition

Exceptions

  • IllegalClassFormatException
  • UnmodifiableClassException
  • UnmodifiableModuleException


java.jnlp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.jnlp

定义Java网络启动协议API（JNLP）。

这个模块是可升级的。

Module Graph:
Module graph for java.jnlp Module graph for java.jnlp
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.jnlp
      JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
      Indirect Exports
      From Packages
      java.datatransfer java.awt.datatransfer
      java.desktop java.applet java.awt java.awt.color java.awt.desktop java.awt.dnd java.awt.event java.awt.font java.awt.geom java.awt.im java.awt.im.spi java.awt.image java.awt.image.renderable java.awt.print java.beans java.beans.beancontext javax.accessibility javax.imageio javax.imageio.event javax.imageio.metadata javax.imageio.plugins.bmp javax.imageio.plugins.jpeg javax.imageio.plugins.tiff javax.imageio.spi javax.imageio.stream javax.print javax.print.attribute javax.print.attribute.standard javax.print.event javax.sound.midi javax.sound.midi.spi javax.sound.sampled javax.sound.sampled.spi javax.swing javax.swing.border javax.swing.colorchooser javax.swing.event javax.swing.filechooser javax.swing.plaf javax.swing.plaf.basic javax.swing.plaf.metal javax.swing.plaf.multi javax.swing.plaf.nimbus javax.swing.plaf.synth javax.swing.table javax.swing.text javax.swing.text.html javax.swing.text.html.parser javax.swing.text.rtf javax.swing.tree javax.swing.undo
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
      transitive java.desktop
      定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
      Indirect Requires
      Modifier Module 描述
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.jnlp (Java SE 9 & JDK 9 )

java.jnlp

Interfaces

  • BasicService
  • ClipboardService
  • DownloadService
  • DownloadService2
  • DownloadServiceListener
  • ExtendedService
  • ExtensionInstallerService
  • FileContents
  • FileOpenService
  • FileSaveService
  • IntegrationService
  • JNLPRandomAccessFile
  • PersistenceService
  • PrintService
  • ServiceManagerStub
  • SingleInstanceListener
  • SingleInstanceService

Classes

  • DownloadService2.ResourceSpec
  • ServiceManager

Exceptions

  • UnavailableServiceException


java.logging (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.logging

定义Java Logging API。
Module Graph:
Module graph for java.logging Module graph for java.logging
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.util.logging
      提供Java¢2平台核心日志记录工具的类和接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.logging (Java SE 9 & JDK 9 )

java.logging

Interfaces

  • Filter
  • LoggingMXBean

Classes

  • ConsoleHandler
  • ErrorManager
  • FileHandler
  • Formatter
  • Handler
  • Level
  • Logger
  • LoggingPermission
  • LogManager
  • LogRecord
  • MemoryHandler
  • SimpleFormatter
  • SocketHandler
  • StreamHandler
  • XMLFormatter


java.management (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.management

定义Java管理扩展（JMX）API。

JMX API由用于监视和管理Java运行时中的JVM和其他组件的接口组成。

Module Graph:
Module graph for java.management Module graph for java.management
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.lang.management
      提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
      javax.management
      提供Java管理扩展的核心类。
      javax.management.loading
      提供实现高级动态加载的类。
      javax.management.modelmbean
      提供ModelMBean类的定义。
      javax.management.monitor
      提供监视器类的定义。
      javax.management.openmbean
      提供打开的数据类型和Open MBean描述符类。
      javax.management.relation
      提供关系服务的定义。
      javax.management.remote
      用于远程访问JMX MBean服务器的接口。
      javax.management.timer
      提供定时器MBean的定义。

    • Services

      Uses
      Type 描述
      JMXConnectorProvider
      使用给定协议创建JMX API连接器客户端的提供程序。
      JMXConnectorServerProvider
      使用给定协议创建JMX API连接器服务器的提供程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.management (Java SE 9 & JDK 9 )

java.management

Interfaces

  • BufferPoolMXBean
  • ClassLoaderRepository
  • ClassLoadingMXBean
  • CompilationMXBean
  • CompositeData
  • CompositeDataView
  • CounterMonitorMBean
  • Descriptor
  • DescriptorAccess
  • DescriptorRead
  • DynamicMBean
  • GarbageCollectorMXBean
  • GaugeMonitorMBean
  • JMXAddressable
  • JMXAuthenticator
  • JMXConnector
  • JMXConnectorProvider
  • JMXConnectorServerMBean
  • JMXConnectorServerProvider
  • MBeanRegistration
  • MBeanServer
  • MBeanServerConnection
  • MBeanServerDelegateMBean
  • MBeanServerForwarder
  • MemoryManagerMXBean
  • MemoryMXBean
  • MemoryPoolMXBean
  • MLetMBean
  • ModelMBean
  • ModelMBeanInfo
  • ModelMBeanNotificationBroadcaster
  • MonitorMBean
  • NotificationBroadcaster
  • NotificationEmitter
  • NotificationFilter
  • NotificationListener
  • OpenMBeanAttributeInfo
  • OpenMBeanConstructorInfo
  • OpenMBeanInfo
  • OpenMBeanOperationInfo
  • OpenMBeanParameterInfo
  • OperatingSystemMXBean
  • PersistentMBean
  • PlatformLoggingMXBean
  • PlatformManagedObject
  • PrivateClassLoader
  • QueryExp
  • Relation
  • RelationServiceMBean
  • RelationSupportMBean
  • RelationType
  • RuntimeMXBean
  • StringMonitorMBean
  • TabularData
  • ThreadMXBean
  • TimerMBean
  • ValueExp

Classes

  • ArrayType
  • Attribute
  • AttributeChangeNotification
  • AttributeChangeNotificationFilter
  • AttributeList
  • AttributeValueExp
  • CompositeDataInvocationHandler
  • CompositeDataSupport
  • CompositeType
  • CounterMonitor
  • DefaultLoaderRepository
  • DefaultLoaderRepository
  • DescriptorSupport
  • GaugeMonitor
  • ImmutableDescriptor
  • JMX
  • JMXConnectionNotification
  • JMXConnectorFactory
  • JMXConnectorServer
  • JMXConnectorServerFactory
  • JMXPrincipal
  • JMXServiceURL
  • LockInfo
  • ManagementFactory
  • ManagementPermission
  • MBeanAttributeInfo
  • MBeanConstructorInfo
  • MBeanFeatureInfo
  • MBeanInfo
  • MBeanNotificationInfo
  • MBeanOperationInfo
  • MBeanParameterInfo
  • MBeanPermission
  • MBeanServerBuilder
  • MBeanServerDelegate
  • MBeanServerFactory
  • MBeanServerInvocationHandler
  • MBeanServerNotification
  • MBeanServerNotificationFilter
  • MBeanServerPermission
  • MBeanTrustPermission
  • MemoryNotificationInfo
  • MemoryUsage
  • MLet
  • MLetContent
  • ModelMBeanAttributeInfo
  • ModelMBeanConstructorInfo
  • ModelMBeanInfoSupport
  • ModelMBeanNotificationInfo
  • ModelMBeanOperationInfo
  • Monitor
  • MonitorInfo
  • MonitorNotification
  • Notification
  • NotificationBroadcasterSupport
  • NotificationFilterSupport
  • NotificationResult
  • ObjectInstance
  • ObjectName
  • OpenMBeanAttributeInfoSupport
  • OpenMBeanConstructorInfoSupport
  • OpenMBeanInfoSupport
  • OpenMBeanOperationInfoSupport
  • OpenMBeanParameterInfoSupport
  • OpenType
  • PrivateMLet
  • Query
  • QueryEval
  • RelationNotification
  • RelationService
  • RelationSupport
  • RelationTypeSupport
  • RequiredModelMBean
  • Role
  • RoleInfo
  • RoleList
  • RoleResult
  • RoleStatus
  • RoleUnresolved
  • RoleUnresolvedList
  • SimpleType
  • StandardEmitterMBean
  • StandardMBean
  • StringMonitor
  • StringValueExp
  • SubjectDelegationPermission
  • TabularDataSupport
  • TabularType
  • TargetedNotification
  • ThreadInfo
  • Timer
  • TimerNotification

Enums

  • MemoryType

Exceptions

  • AttributeNotFoundException
  • BadAttributeValueExpException
  • BadBinaryOpValueExpException
  • BadStringOperationException
  • InstanceAlreadyExistsException
  • InstanceNotFoundException
  • IntrospectionException
  • InvalidApplicationException
  • InvalidAttributeValueException
  • InvalidKeyException
  • InvalidOpenTypeException
  • InvalidRelationIdException
  • InvalidRelationServiceException
  • InvalidRelationTypeException
  • InvalidRoleInfoException
  • InvalidRoleValueException
  • InvalidTargetObjectTypeException
  • JMException
  • JMRuntimeException
  • JMXProviderException
  • JMXServerErrorException
  • KeyAlreadyExistsException
  • ListenerNotFoundException
  • MalformedObjectNameException
  • MBeanException
  • MBeanRegistrationException
  • MonitorSettingException
  • NotCompliantMBeanException
  • OpenDataException
  • OperationsException
  • ReflectionException
  • RelationException
  • RelationNotFoundException
  • RelationServiceNotRegisteredException
  • RelationTypeNotFoundException
  • RoleInfoNotFoundException
  • RoleNotFoundException
  • RuntimeErrorException
  • RuntimeMBeanException
  • RuntimeOperationsException
  • ServiceNotFoundException
  • XMLParseException

注解类型

  • ConstructorParameters
  • DescriptorKey
  • MXBean


java.management.rmi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.management.rmi

定义Java管理扩展（JMX）Remote API的RMI connector 。
供应商：
该模块提供JMXConnectorProvider服务，它使用RMI协议创建JMX连接器客户端。 JMXConnector实例可以通过JMXConnectorFactory.newJMXConnector工厂方法获得。 它还提供JMXConnectorServerProvider服务，它使用RMI协议创建JMX连接器服务器。 JMXConnectorServer实例可以通过JMXConnectorServerFactory.newJMXConnectorServer工厂方法获得。
Module Graph:
Module graph for java.management.rmi Module graph for java.management.rmi
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.management.remote.rmi
      RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
      Indirect Exports
      From Packages
      java.management java.lang.management javax.management javax.management.loading javax.management.modelmbean javax.management.monitor javax.management.openmbean javax.management.relation javax.management.remote javax.management.timer
      java.rmi java.rmi java.rmi.activation java.rmi.dgc java.rmi.registry java.rmi.server javax.rmi.ssl

    • Modules

      Requires
      Modifier Module 描述
      transitive java.management
      定义Java管理扩展（JMX）API。
      transitive java.rmi
      定义远程方法调用（RMI）API。

    • Services

      Provides
      Type 描述
      JMXConnectorProvider
      使用给定协议创建JMX API连接器客户端的提供程序。
      JMXConnectorServerProvider
      使用给定协议创建JMX API连接器服务器的提供程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.management.rmi (Java SE 9 & JDK 9 )

java.management.rmi

Interfaces

  • RMIConnection
  • RMIServer

Classes

  • RMIConnectionImpl
  • RMIConnectionImpl_Stub
  • RMIConnector
  • RMIConnectorServer
  • RMIIIOPServerImpl
  • RMIJRMPServerImpl
  • RMIServerImpl
  • RMIServerImpl_Stub


java.naming (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.naming

定义Java命名和目录接口（JNDI）API。
Module Graph:
Module graph for java.naming Module graph for java.naming
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.naming
      提供用于访问命名服务的类和接口。
      javax.naming.directory
      扩展 javax.naming包以提供访问目录服务的功能。
      javax.naming.event
      访问命名和目录服务时，提供对事件通知的支持。
      javax.naming.ldap
      提供对LDAPv3扩展操作和控件的支持。
      javax.naming.spi
      提供通过 javax.naming及相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.naming (Java SE 9 & JDK 9 )

java.naming

Interfaces

  • Attribute
  • Attributes
  • Context
  • Control
  • DirContext
  • DirObjectFactory
  • DirStateFactory
  • EventContext
  • EventDirContext
  • ExtendedRequest
  • ExtendedResponse
  • HasControls
  • InitialContextFactory
  • InitialContextFactoryBuilder
  • LdapContext
  • Name
  • NameParser
  • NamespaceChangeListener
  • NamingEnumeration
  • NamingListener
  • ObjectChangeListener
  • ObjectFactory
  • ObjectFactoryBuilder
  • Referenceable
  • Resolver
  • StateFactory
  • UnsolicitedNotification
  • UnsolicitedNotificationListener

Classes

  • BasicAttribute
  • BasicAttributes
  • BasicControl
  • BinaryRefAddr
  • Binding
  • CompositeName
  • CompoundName
  • ControlFactory
  • DirectoryManager
  • DirStateFactory.Result
  • InitialContext
  • InitialDirContext
  • InitialLdapContext
  • LdapName
  • LinkRef
  • ManageReferralControl
  • ModificationItem
  • NameClassPair
  • NamingEvent
  • NamingExceptionEvent
  • NamingManager
  • PagedResultsControl
  • PagedResultsResponseControl
  • Rdn
  • RefAddr
  • Reference
  • ResolveResult
  • SearchControls
  • SearchResult
  • SortControl
  • SortKey
  • SortResponseControl
  • StartTlsRequest
  • StartTlsResponse
  • StringRefAddr
  • UnsolicitedNotificationEvent

Exceptions

  • AttributeInUseException
  • AttributeModificationException
  • AuthenticationException
  • AuthenticationNotSupportedException
  • CannotProceedException
  • CommunicationException
  • ConfigurationException
  • ContextNotEmptyException
  • InsufficientResourcesException
  • InterruptedNamingException
  • InvalidAttributeIdentifierException
  • InvalidAttributesException
  • InvalidAttributeValueException
  • InvalidNameException
  • InvalidSearchControlsException
  • InvalidSearchFilterException
  • LdapReferralException
  • LimitExceededException
  • LinkException
  • LinkLoopException
  • MalformedLinkException
  • NameAlreadyBoundException
  • NameNotFoundException
  • NamingException
  • NamingSecurityException
  • NoInitialContextException
  • NoPermissionException
  • NoSuchAttributeException
  • NotContextException
  • OperationNotSupportedException
  • PartialResultException
  • ReferralException
  • SchemaViolationException
  • ServiceUnavailableException
  • SizeLimitExceededException
  • TimeLimitExceededException


java.prefs (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.prefs

定义首选项API。
Module Graph:
Module graph for java.prefs Module graph for java.prefs
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.util.prefs
      该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

    • Services

      Uses
      Type 描述
      PreferencesFactory
      生成首选项对象的工厂对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.prefs (Java SE 9 & JDK 9 )

java.prefs

Interfaces

  • NodeChangeListener
  • PreferenceChangeListener
  • PreferencesFactory

Classes

  • AbstractPreferences
  • NodeChangeEvent
  • PreferenceChangeEvent
  • Preferences

Exceptions

  • BackingStoreException
  • InvalidPreferencesFormatException


java.rmi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.rmi

定义远程方法调用（RMI）API。

JDK实现这个模块的包括rmiregistry工具启动远程对象注册表，并且rmid工具启动激活系统守护进程。

工具指南：
rmiregistry ， rmid
Module Graph:
Module graph for java.rmi Module graph for java.rmi
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.rmi
      提供RMI包。
      java.rmi.activation
      提供对RMI对象激活的支持。
      java.rmi.dgc
      提供RMI分布式垃圾收集（DGC）的类和接口。
      java.rmi.registry
      为RMI注册表提供一个类和两个接口。
      java.rmi.server
      提供用于支持RMI服务器端的类和接口。
      javax.rmi.ssl
      通过安全套接层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。

    • Services

      Uses
      Type 描述
      RMIClassLoaderSpi
      RMIClassLoaderSpi是服务提供者接口 RMIClassLoader 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.rmi (Java SE 9 & JDK 9 )

java.rmi

Interfaces

  • ActivationInstantiator
  • ActivationMonitor
  • ActivationSystem
  • Activator
  • DGC
  • LoaderHandler
  • Registry
  • RegistryHandler
  • Remote
  • RemoteCall
  • RemoteRef
  • RMIClientSocketFactory
  • RMIFailureHandler
  • RMIServerSocketFactory
  • ServerRef
  • Skeleton
  • Unreferenced

Classes

  • Activatable
  • ActivationDesc
  • ActivationGroup
  • ActivationGroup_Stub
  • ActivationGroupDesc
  • ActivationGroupDesc.CommandEnvironment
  • ActivationGroupID
  • ActivationID
  • Lease
  • LocateRegistry
  • LogStream
  • MarshalledObject
  • Naming
  • ObjID
  • Operation
  • RemoteObject
  • RemoteObjectInvocationHandler
  • RemoteServer
  • RemoteStub
  • RMIClassLoader
  • RMIClassLoaderSpi
  • RMISecurityManager
  • RMISocketFactory
  • SslRMIClientSocketFactory
  • SslRMIServerSocketFactory
  • UID
  • UnicastRemoteObject
  • VMID

Exceptions

  • AccessException
  • ActivateFailedException
  • ActivationException
  • AlreadyBoundException
  • ConnectException
  • ConnectIOException
  • ExportException
  • MarshalException
  • NoSuchObjectException
  • NotBoundException
  • RemoteException
  • RMISecurityException
  • ServerCloneException
  • ServerError
  • ServerException
  • ServerNotActiveException
  • ServerRuntimeException
  • SkeletonMismatchException
  • SkeletonNotFoundException
  • SocketSecurityException
  • StubNotFoundException
  • UnexpectedException
  • UnknownGroupException
  • UnknownHostException
  • UnknownObjectException
  • UnmarshalException


java.scripting (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.scripting

定义脚本API。

该模块的JDK实现包括一个独立于语言的命令行脚本shell，即jrunscript ，它支持执行JavaScript和其他语言（如果安装了相应的脚本引擎）。

工具指南：
jrunscript
Module Graph:
Module graph for java.scripting Module graph for java.scripting
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.script
      脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。

    • Services

      Uses
      Type 描述
      ScriptEngineFactory
      ScriptEngineFactory用于描述和实例化 ScriptEngines 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.scripting (Java SE 9 & JDK 9 )

java.scripting

Interfaces

  • Bindings
  • Compilable
  • Invocable
  • ScriptContext
  • ScriptEngine
  • ScriptEngineFactory

Classes

  • AbstractScriptEngine
  • CompiledScript
  • ScriptEngineManager
  • SimpleBindings
  • SimpleScriptContext

Exceptions

  • ScriptException


java.se (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.se

定义核心Java SE API。

此模块不需要定义CORBA和Java EE API的模块，但java.se.ee模块需要这些模块。

可选Java SE平台：
Java Native Interface (JNI)
Java Virtual Machine Tool Interface (JVM TI)
Java Debug Wire Protocol (JDWP)
Module Graph:
Module graph for java.se Module graph for java.se
从以下版本开始：
9

    • Packages

      Indirect Exports
      From Packages
      java.compiler javax.annotation.processing javax.lang.model javax.lang.model.element javax.lang.model.type javax.lang.model.util javax.tools
      java.datatransfer java.awt.datatransfer
      java.desktop java.applet java.awt java.awt.color java.awt.desktop java.awt.dnd java.awt.event java.awt.font java.awt.geom java.awt.im java.awt.im.spi java.awt.image java.awt.image.renderable java.awt.print java.beans java.beans.beancontext javax.accessibility javax.imageio javax.imageio.event javax.imageio.metadata javax.imageio.plugins.bmp javax.imageio.plugins.jpeg javax.imageio.plugins.tiff javax.imageio.spi javax.imageio.stream javax.print javax.print.attribute javax.print.attribute.standard javax.print.event javax.sound.midi javax.sound.midi.spi javax.sound.sampled javax.sound.sampled.spi javax.swing javax.swing.border javax.swing.colorchooser javax.swing.event javax.swing.filechooser javax.swing.plaf javax.swing.plaf.basic javax.swing.plaf.metal javax.swing.plaf.multi javax.swing.plaf.nimbus javax.swing.plaf.synth javax.swing.table javax.swing.text javax.swing.text.html javax.swing.text.html.parser javax.swing.text.rtf javax.swing.tree javax.swing.undo
      java.instrument java.lang.instrument
      java.logging java.util.logging
      java.management java.lang.management javax.management javax.management.loading javax.management.modelmbean javax.management.monitor javax.management.openmbean javax.management.relation javax.management.remote javax.management.timer
      java.management.rmi javax.management.remote.rmi
      java.naming javax.naming javax.naming.directory javax.naming.event javax.naming.ldap javax.naming.spi
      java.prefs java.util.prefs
      java.rmi java.rmi java.rmi.activation java.rmi.dgc java.rmi.registry java.rmi.server javax.rmi.ssl
      java.scripting javax.script
      java.security.jgss javax.security.auth.kerberos org.ietf.jgss
      java.security.sasl javax.security.sasl
      java.sql java.sql javax.sql javax.transaction.xa
      java.sql.rowset javax.sql.rowset javax.sql.rowset.serial javax.sql.rowset.spi
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers
      java.xml.crypto javax.xml.crypto javax.xml.crypto.dom javax.xml.crypto.dsig javax.xml.crypto.dsig.dom javax.xml.crypto.dsig.keyinfo javax.xml.crypto.dsig.spec

    • Modules

      Requires
      Modifier Module 描述
      transitive java.compiler
      定义语言模型，注释处理和Java编译器API。
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
      transitive java.desktop
      定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
      transitive java.instrument
      定义允许代理程序在JVM上运行程序的服务。
      transitive java.logging
      定义Java Logging API。
      transitive java.management
      定义Java管理扩展（JMX）API。
      transitive java.management.rmi
      定义Java管理扩展（JMX）Remote API的 RMI connector 。
      transitive java.naming
      定义Java命名和目录接口（JNDI）API。
      transitive java.prefs
      定义首选项API。
      transitive java.rmi
      定义远程方法调用（RMI）API。
      transitive java.scripting
      定义脚本API。
      transitive java.security.jgss
      定义IETF通用安全服务API（GSS-API）的Java绑定。
      transitive java.security.sasl
      定义IETF简单认证和安全层（SASL）的Java支持。
      transitive java.sql
      定义JDBC API。
      transitive java.sql.rowset
      定义JDBC RowSet API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
      transitive java.xml.crypto
      定义XML加密的API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.se (Java SE 9 & JDK 9 )

java.se


java.se.ee (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module java.se.ee

Deprecated, for removal: This API element is subject to removal in a future version.
定义Java SE平台的完整API。

该模块需要java.se模块，并使用定义CORBA和Java EE API的模块进行补充。 这些模块可升级。

Module Graph:
Module graph for java.se.ee Module graph for java.se.ee
从以下版本开始：
9

    • Packages

      Indirect Exports
      From Packages
      java.activation javax.activation
      java.compiler javax.annotation.processing javax.lang.model javax.lang.model.element javax.lang.model.type javax.lang.model.util javax.tools
      java.corba javax.activity javax.rmi javax.rmi.CORBA org.omg.CORBA org.omg.CORBA_2_3 org.omg.CORBA_2_3.portable org.omg.CORBA.DynAnyPackage org.omg.CORBA.ORBPackage org.omg.CORBA.portable org.omg.CORBA.TypeCodePackage org.omg.CosNaming org.omg.CosNaming.NamingContextExtPackage org.omg.CosNaming.NamingContextPackage org.omg.Dynamic org.omg.DynamicAny org.omg.DynamicAny.DynAnyFactoryPackage org.omg.DynamicAny.DynAnyPackage org.omg.IOP org.omg.IOP.CodecFactoryPackage org.omg.IOP.CodecPackage org.omg.Messaging org.omg.PortableInterceptor org.omg.PortableInterceptor.ORBInitInfoPackage org.omg.PortableServer org.omg.PortableServer.CurrentPackage org.omg.PortableServer.POAManagerPackage org.omg.PortableServer.POAPackage org.omg.PortableServer.portable org.omg.PortableServer.ServantLocatorPackage org.omg.SendingContext org.omg.stub.java.rmi
      java.datatransfer java.awt.datatransfer
      java.desktop java.applet java.awt java.awt.color java.awt.desktop java.awt.dnd java.awt.event java.awt.font java.awt.geom java.awt.im java.awt.im.spi java.awt.image java.awt.image.renderable java.awt.print java.beans java.beans.beancontext javax.accessibility javax.imageio javax.imageio.event javax.imageio.metadata javax.imageio.plugins.bmp javax.imageio.plugins.jpeg javax.imageio.plugins.tiff javax.imageio.spi javax.imageio.stream javax.print javax.print.attribute javax.print.attribute.standard javax.print.event javax.sound.midi javax.sound.midi.spi javax.sound.sampled javax.sound.sampled.spi javax.swing javax.swing.border javax.swing.colorchooser javax.swing.event javax.swing.filechooser javax.swing.plaf javax.swing.plaf.basic javax.swing.plaf.metal javax.swing.plaf.multi javax.swing.plaf.nimbus javax.swing.plaf.synth javax.swing.table javax.swing.text javax.swing.text.html javax.swing.text.html.parser javax.swing.text.rtf javax.swing.tree javax.swing.undo
      java.instrument java.lang.instrument
      java.logging java.util.logging
      java.management java.lang.management javax.management javax.management.loading javax.management.modelmbean javax.management.monitor javax.management.openmbean javax.management.relation javax.management.remote javax.management.timer
      java.management.rmi javax.management.remote.rmi
      java.naming javax.naming javax.naming.directory javax.naming.event javax.naming.ldap javax.naming.spi
      java.prefs java.util.prefs
      java.rmi java.rmi java.rmi.activation java.rmi.dgc java.rmi.registry java.rmi.server javax.rmi.ssl
      java.scripting javax.script
      java.security.jgss javax.security.auth.kerberos org.ietf.jgss
      java.security.sasl javax.security.sasl
      java.sql java.sql javax.sql javax.transaction.xa
      java.sql.rowset javax.sql.rowset javax.sql.rowset.serial javax.sql.rowset.spi
      java.transaction javax.transaction
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers
      java.xml.bind javax.xml.bind javax.xml.bind.annotation javax.xml.bind.annotation.adapters javax.xml.bind.attachment javax.xml.bind.helpers javax.xml.bind.util
      java.xml.crypto javax.xml.crypto javax.xml.crypto.dom javax.xml.crypto.dsig javax.xml.crypto.dsig.dom javax.xml.crypto.dsig.keyinfo javax.xml.crypto.dsig.spec
      java.xml.ws javax.jws javax.jws.soap javax.xml.soap javax.xml.ws javax.xml.ws.handler javax.xml.ws.handler.soap javax.xml.ws.http javax.xml.ws.soap javax.xml.ws.spi javax.xml.ws.spi.http javax.xml.ws.wsaddressing
      java.xml.ws.annotation javax.annotation

    • Modules

      Requires
      Modifier Module 描述
      transitive java.activation
      定义JavaBean激活框架（JAF）API。
      transitive java.corba
      定义OMG CORBA API和RMI-IIOP API的Java绑定。
      transitive java.se
      定义核心Java SE API。
      transitive java.transaction
      定义Java Transaction API（JTA）的一个子集来支持CORBA互操作。
      transitive java.xml.bind
      定义用于XML绑定（JAXB）API的Java体系结构。
      transitive java.xml.ws
      定义基于XML的Web服务（JAX-WS）的Java API和Web服务元数据API。
      transitive java.xml.ws.annotation
      定义Common Annotations API的一个子集，以支持在Java SE平台上运行的程序。
      Indirect Requires
      Modifier Module 描述
      transitive java.compiler
      定义语言模型，注释处理和Java编译器API。
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
      transitive java.desktop
      定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
      transitive java.instrument
      定义允许代理程序在JVM上运行程序的服务。
      transitive java.logging
      定义Java Logging API。
      transitive java.management
      定义Java管理扩展（JMX）API。
      transitive java.management.rmi
      定义Java管理扩展（JMX）Remote API的 RMI connector 。
      transitive java.naming
      定义Java命名和目录接口（JNDI）API。
      transitive java.prefs
      定义首选项API。
      transitive java.rmi
      定义远程方法调用（RMI）API。
      transitive java.scripting
      定义脚本API。
      transitive java.security.jgss
      定义IETF通用安全服务API（GSS-API）的Java绑定。
      transitive java.security.sasl
      定义IETF简单认证和安全层（SASL）的Java支持。
      transitive java.sql
      定义JDBC API。
      transitive java.sql.rowset
      定义JDBC RowSet API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
      transitive java.xml.crypto
      Defines the API for XML cryptography.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.se.ee (Java SE 9 & JDK 9 )

java.se.ee


java.security.jgss (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.security.jgss

定义IETF通用安全服务API（GSS-API）的Java绑定。

该模块还包含GSS-API机制，包括Kerberos v5和SPNEGO。

Module Graph:
Module graph for java.security.jgss Module graph for java.security.jgss
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.security.auth.kerberos
      此包包含与Kerberos网络身份验证协议相关的实用程序类。
      org.ietf.jgss
      该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.security.jgss (Java SE 9 & JDK 9 )

java.security.jgss

Interfaces

  • GSSContext
  • GSSCredential
  • GSSName

Classes

  • ChannelBinding
  • DelegationPermission
  • EncryptionKey
  • GSSManager
  • KerberosCredMessage
  • KerberosKey
  • KerberosPrincipal
  • KerberosTicket
  • KeyTab
  • MessageProp
  • Oid
  • ServicePermission

Exceptions

  • GSSException


java.security.sasl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.security.sasl

定义IETF简单认证和安全层（SASL）的Java支持。

该模块还包含SASL机制，包括DIGEST-MD5，CRAM-MD5和NTLM。

Module Graph:
Module graph for java.security.sasl Module graph for java.security.sasl
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.security.sasl
      包含用于支持SASL的类和接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.security.sasl (Java SE 9 & JDK 9 )

java.security.sasl

Interfaces

  • SaslClient
  • SaslClientFactory
  • SaslServer
  • SaslServerFactory

Classes

  • AuthorizeCallback
  • RealmCallback
  • RealmChoiceCallback
  • Sasl

Exceptions

  • AuthenticationException
  • SaslException


java.smartcardio (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.smartcardio

定义Java智能卡I / O API。
Module Graph:
Module graph for java.smartcardio Module graph for java.smartcardio
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.smartcardio
      Java™智能卡I / O API
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.smartcardio (Java SE 9 & JDK 9 )

java.smartcardio

Classes

  • ATR
  • Card
  • CardChannel
  • CardPermission
  • CardTerminal
  • CardTerminals
  • CommandAPDU
  • ResponseAPDU
  • TerminalFactory
  • TerminalFactorySpi

Enums

  • CardTerminals.State

Exceptions

  • CardException
  • CardNotPresentException


java.sql (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.sql

定义JDBC API。
Module Graph:
Module graph for java.sql Module graph for java.sql
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      java.sql
      提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
      javax.sql
      通过Java编程语言为服务器端数据源访问和处理提供API。
      javax.transaction.xa
      提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。
      Indirect Exports
      From Packages
      java.logging java.util.logging
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.logging
      定义Java Logging API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。

    • Services

      Uses
      Type 描述
      Driver
      The interface that every driver class must implement.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.sql (Java SE 9 & JDK 9 )

java.sql

Interfaces

  • Array
  • Blob
  • CallableStatement
  • Clob
  • CommonDataSource
  • Connection
  • ConnectionBuilder
  • ConnectionEventListener
  • ConnectionPoolDataSource
  • DatabaseMetaData
  • DataSource
  • Driver
  • DriverAction
  • NClob
  • ParameterMetaData
  • PooledConnection
  • PooledConnectionBuilder
  • PreparedStatement
  • Ref
  • ResultSet
  • ResultSetMetaData
  • RowId
  • RowSet
  • RowSetInternal
  • RowSetListener
  • RowSetMetaData
  • RowSetReader
  • RowSetWriter
  • Savepoint
  • ShardingKey
  • ShardingKeyBuilder
  • SQLData
  • SQLInput
  • SQLOutput
  • SQLType
  • SQLXML
  • Statement
  • StatementEventListener
  • Struct
  • Wrapper
  • XAConnection
  • XAConnectionBuilder
  • XADataSource
  • XAResource
  • Xid

Classes

  • ConnectionEvent
  • Date
  • DriverManager
  • DriverPropertyInfo
  • RowSetEvent
  • SQLPermission
  • StatementEvent
  • Time
  • Timestamp
  • Types

Enums

  • ClientInfoStatus
  • JDBCType
  • PseudoColumnUsage
  • RowIdLifetime

Exceptions

  • BatchUpdateException
  • DataTruncation
  • SQLClientInfoException
  • SQLDataException
  • SQLException
  • SQLFeatureNotSupportedException
  • SQLIntegrityConstraintViolationException
  • SQLInvalidAuthorizationSpecException
  • SQLNonTransientConnectionException
  • SQLNonTransientException
  • SQLRecoverableException
  • SQLSyntaxErrorException
  • SQLTimeoutException
  • SQLTransactionRollbackException
  • SQLTransientConnectionException
  • SQLTransientException
  • SQLWarning
  • XAException


java.sql.rowset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.sql.rowset

定义JDBC RowSet API。
Module Graph:
Module graph for java.sql.rowset Module graph for java.sql.rowset
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.sql.rowset
      JDBC RowSet实现的标准接口和基类。
      javax.sql.rowset.serial
      提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
      javax.sql.rowset.spi
      第三方供应商在实施同步提供程序时必须使用的标准类和接口。
      Indirect Exports
      From Packages
      java.logging java.util.logging
      java.naming javax.naming javax.naming.directory javax.naming.event javax.naming.ldap javax.naming.spi
      java.sql java.sql javax.sql javax.transaction.xa
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.logging
      定义Java Logging API。
      transitive java.naming
      定义Java命名和目录接口（JNDI）API。
      transitive java.sql
      定义JDBC API。
      Indirect Requires
      Modifier Module 描述
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。

    • Services

      Uses
      Type 描述
      RowSetFactory
      一个定义工厂实现的接口，用于获取不同类型的 RowSet实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.sql.rowset (Java SE 9 & JDK 9 )

java.sql.rowset

Interfaces

  • CachedRowSet
  • FilteredRowSet
  • JdbcRowSet
  • Joinable
  • JoinRowSet
  • Predicate
  • RowSetFactory
  • SyncResolver
  • TransactionalWriter
  • WebRowSet
  • XmlReader
  • XmlWriter

Classes

  • BaseRowSet
  • RowSetMetaDataImpl
  • RowSetProvider
  • SerialArray
  • SerialBlob
  • SerialClob
  • SerialDatalink
  • SerialJavaObject
  • SerialRef
  • SerialStruct
  • SQLInputImpl
  • SQLOutputImpl
  • SyncFactory
  • SyncProvider

Exceptions

  • RowSetWarning
  • SerialException
  • SyncFactoryException
  • SyncProviderException


java.transaction (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module java.transaction

Deprecated, for removal: This API element is subject to removal in a future version.
定义Java Transaction API（JTA）的一个子集来支持CORBA互操作。

该子集由通过Java语言映射到IDL映射规范的 CORBA系统异常的RMI异常类型组成。

Module Graph:
Module graph for java.transaction Module graph for java.transaction
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.transaction
      包含ORB机械在解组期间抛出的三个异常。
      Indirect Exports
      From Packages
      java.rmi java.rmi java.rmi.activation java.rmi.dgc java.rmi.registry java.rmi.server javax.rmi.ssl

    • Modules

      Requires
      Modifier Module 描述
      transitive java.rmi
      定义远程方法调用（RMI）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.transaction (Java SE 9 & JDK 9 )

java.transaction

Exceptions

  • InvalidTransactionException
  • TransactionRequiredException
  • TransactionRolledbackException


java.xml (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.xml

定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
Module Graph:
Module graph for java.xml Module graph for java.xml
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.xml
      定义XML处理的常量。
      javax.xml.catalog
      提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
      javax.xml.datatype
      定义XML / Java类型映射。
      javax.xml.namespace
      定义XML命名空间处理。
      javax.xml.parsers
      提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
      javax.xml.stream
      定义Streaming API for XML（StAX）的接口和类。
      javax.xml.stream.events
      定义Streaming API for XML（StAX）的事件接口。
      javax.xml.stream.util
      为Streaming API for XML（StAX）提供实用程序类。
      javax.xml.transform
      定义用于处理转换指令的通用API，以及执行从源到结果的转换。
      javax.xml.transform.dom
      提供DOM特定的转换类。
      javax.xml.transform.sax
      提供SAX特定的转换类。
      javax.xml.transform.stax
      提供StAX特定的转换类。
      javax.xml.transform.stream
      提供流和URI特定的转换类。
      javax.xml.validation
      提供用于验证XML文档的API。
      javax.xml.xpath
      提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
      org.w3c.dom
      提供文档对象模型（DOM）的接口。
      org.w3c.dom.bootstrap
      提供一个工厂来获取 DOMImplementation实例。
      org.w3c.dom.events
      提供DOM Level 2事件的接口。
      org.w3c.dom.ls
      提供DOM Level 3加载和保存的界面。
      org.w3c.dom.ranges
      提供DOM Level 2范围的界面。
      org.w3c.dom.traversal
      提供DOM Level 2遍历的界面。
      org.w3c.dom.views
      提供DOM Level 2 Views的界面。
      org.xml.sax
      提供核心SAX API。
      org.xml.sax.ext
      提供与符合SAX驱动程序不一定支持的SAX2设施的接口。
      org.xml.sax.helpers
      提供帮助类，包括支持引导基于SAX的应用程序。

    • Services

      Uses
      Type 描述
      DatatypeFactory
      创建新的 javax.xml.datatype Object的工厂， javax.xml.datatype XML映射到/从Java Object s。
      DocumentBuilderFactory
      定义工厂API，使应用程序能够从XML文档获取生成DOM对象树的解析器。
      SAXParserFactory
      定义工厂API，使应用程序能够配置和获取基于SAX的解析器来解析XML文档。
      SchemaFactory
      创建Schema对象的工厂。
      TransformerFactory
      TransformerFactory实例可用于创建Transformer和Templates对象。
      XMLEventFactory
      该界面定义了一个用于创建XMLEvents实例的实用程序类
      XMLInputFactory
      定义了一个工厂的抽象实现来获取流。
      XMLOutputFactory
      定义用于获取XMLEventWriters和XMLStreamWrit的工厂的抽象实现。
      XMLReader
      使用回调读取XML文档的界面。
      XPathFactory
      可以使用XPathFactory实例来创建XPath对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.xml (Java SE 9 & JDK 9 )

java.xml

Interfaces

  • AbstractView
  • Attr
  • Attribute
  • AttributeList
  • Attributes
  • Attributes2
  • Catalog
  • CatalogResolver
  • CDATASection
  • CharacterData
  • Characters
  • Comment
  • Comment
  • ContentHandler
  • DeclHandler
  • Document
  • DocumentEvent
  • DocumentFragment
  • DocumentHandler
  • DocumentRange
  • DocumentTraversal
  • DocumentType
  • DocumentView
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationLS
  • DOMImplementationSource
  • DOMLocator
  • DOMLocator
  • DOMStringList
  • DTD
  • DTDHandler
  • Element
  • ElementTraversal
  • EndDocument
  • EndElement
  • Entity
  • EntityDeclaration
  • EntityReference
  • EntityReference
  • EntityResolver
  • EntityResolver2
  • ErrorHandler
  • ErrorListener
  • Event
  • EventFilter
  • EventListener
  • EventTarget
  • LexicalHandler
  • Location
  • Locator
  • Locator2
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter
  • MouseEvent
  • MutationEvent
  • NamedNodeMap
  • NameList
  • Namespace
  • NamespaceContext
  • Node
  • NodeFilter
  • NodeIterator
  • NodeList
  • Notation
  • NotationDeclaration
  • Parser
  • ProcessingInstruction
  • ProcessingInstruction
  • Range
  • Result
  • Source
  • SourceLocator
  • StartDocument
  • StartElement
  • StreamFilter
  • Templates
  • TemplatesHandler
  • Text
  • TransformerHandler
  • TreeWalker
  • TypeInfo
  • UIEvent
  • URIResolver
  • UserDataHandler
  • XMLEvent
  • XMLEventAllocator
  • XMLEventConsumer
  • XMLEventReader
  • XMLEventWriter
  • XMLFilter
  • XMLReader
  • XMLReporter
  • XMLResolver
  • XMLStreamConstants
  • XMLStreamReader
  • XMLStreamWriter
  • XPath
  • XPathEvaluationResult
  • XPathExpression
  • XPathFunction
  • XPathFunctionResolver
  • XPathNodes
  • XPathVariableResolver

Classes

  • AttributeListImpl
  • Attributes2Impl
  • AttributesImpl
  • CatalogFeatures
  • CatalogFeatures.Builder
  • CatalogManager
  • DatatypeConstants
  • DatatypeConstants.Field
  • DatatypeFactory
  • DefaultHandler
  • DefaultHandler2
  • DocumentBuilder
  • DocumentBuilderFactory
  • DOMImplementationRegistry
  • DOMResult
  • DOMSource
  • Duration
  • EventReaderDelegate
  • HandlerBase
  • InputSource
  • Locator2Impl
  • LocatorImpl
  • NamespaceSupport
  • OutputKeys
  • ParserAdapter
  • ParserFactory
  • QName
  • SAXParser
  • SAXParserFactory
  • SAXResult
  • SAXSource
  • SAXTransformerFactory
  • Schema
  • SchemaFactory
  • SchemaFactoryLoader
  • StAXResult
  • StAXSource
  • StreamReaderDelegate
  • StreamResult
  • StreamSource
  • Transformer
  • TransformerFactory
  • TypeInfoProvider
  • Validator
  • ValidatorHandler
  • XMLConstants
  • XMLEventFactory
  • XMLFilterImpl
  • XMLGregorianCalendar
  • XMLInputFactory
  • XMLOutputFactory
  • XMLReaderAdapter
  • XMLReaderFactory
  • XPathConstants
  • XPathFactory

Enums

  • CatalogFeatures.Feature
  • XPathEvaluationResult.XPathResultType

Exceptions

  • CatalogException
  • DatatypeConfigurationException
  • DOMException
  • EventException
  • LSException
  • ParserConfigurationException
  • RangeException
  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException
  • TransformerConfigurationException
  • TransformerException
  • XMLStreamException
  • XPathException
  • XPathExpressionException
  • XPathFactoryConfigurationException
  • XPathFunctionException

Errors

  • FactoryConfigurationError
  • FactoryConfigurationError
  • SchemaFactoryConfigurationError
  • TransformerFactoryConfigurationError


java.xml.bind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module java.xml.bind

Deprecated, for removal: This API element is subject to removal in a future version.
定义用于XML绑定（JAXB）API的Java体系结构。

此模块可升级。

Module Graph:
Module graph for java.xml.bind Module graph for java.xml.bind
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.xml.bind
      为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
      javax.xml.bind.annotation
      定义用于将Java程序元素定制到XML模式映射的注释。
      javax.xml.bind.annotation.adapters
      XmlAdapter及其指定的子类允许任意Java类与JAXB一起使用。
      javax.xml.bind.attachment
      该包由基于MIME的包处理器实现，可以在基于MIME的包格式中解释和创建优化的二进制数据。
      javax.xml.bind.helpers
      仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
      javax.xml.bind.util
      有用的客户端工具类。
      Indirect Exports
      From Packages
      java.activation javax.activation
      java.datatransfer java.awt.datatransfer
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.activation
      定义JavaBean激活框架（JAF）API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
      Indirect Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。

    • Services

      Uses
      Type 描述
      JAXBContextFactory
      创建新的 JAXBContext实例的工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.xml.bind (Java SE 9 & JDK 9 )

java.xml.bind

Interfaces

  • DatatypeConverterInterface
  • DomHandler
  • Element
  • JAXBContextFactory
  • Marshaller
  • NotIdentifiableEvent
  • ParseConversionEvent
  • PrintConversionEvent
  • Unmarshaller
  • UnmarshallerHandler
  • ValidationEvent
  • ValidationEventHandler
  • ValidationEventLocator
  • Validator

Classes

  • AbstractMarshallerImpl
  • AbstractUnmarshallerImpl
  • AttachmentMarshaller
  • AttachmentUnmarshaller
  • Binder
  • CollapsedStringAdapter
  • DatatypeConverter
  • DefaultValidationEventHandler
  • HexBinaryAdapter
  • JAXB
  • JAXBContext
  • JAXBElement
  • JAXBElement.GlobalScope
  • JAXBIntrospector
  • JAXBPermission
  • JAXBResult
  • JAXBSource
  • Marshaller.Listener
  • NormalizedStringAdapter
  • NotIdentifiableEventImpl
  • ParseConversionEventImpl
  • PrintConversionEventImpl
  • SchemaOutputResolver
  • Unmarshaller.Listener
  • ValidationEventCollector
  • ValidationEventImpl
  • ValidationEventLocatorImpl
  • W3CDomHandler
  • XmlAdapter
  • XmlElement.DEFAULT
  • XmlElementDecl.GLOBAL
  • XmlElementRef.DEFAULT
  • XmlJavaTypeAdapter.DEFAULT
  • XmlSchemaType.DEFAULT
  • XmlType.DEFAULT

Enums

  • XmlAccessOrder
  • XmlAccessType
  • XmlNsForm

Exceptions

  • DataBindingException
  • JAXBException
  • MarshalException
  • PropertyException
  • TypeConstraintException
  • UnmarshalException
  • ValidationException

注解类型

  • XmlAccessorOrder
  • XmlAccessorType
  • XmlAnyAttribute
  • XmlAnyElement
  • XmlAttachmentRef
  • XmlAttribute
  • XmlElement
  • XmlElementDecl
  • XmlElementRef
  • XmlElementRefs
  • XmlElements
  • XmlElementWrapper
  • XmlEnum
  • XmlEnumValue
  • XmlID
  • XmlIDREF
  • XmlInlineBinaryData
  • XmlJavaTypeAdapter
  • XmlJavaTypeAdapters
  • XmlList
  • XmlMimeType
  • XmlMixed
  • XmlNs
  • XmlRegistry
  • XmlRootElement
  • XmlSchema
  • XmlSchemaType
  • XmlSchemaTypes
  • XmlSeeAlso
  • XmlTransient
  • XmlType
  • XmlValue


java.xml.crypto (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module java.xml.crypto

定义XML加密的API。
Module Graph:
Module graph for java.xml.crypto Module graph for java.xml.crypto
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.xml.crypto
      XML加密的通用类。
      javax.xml.crypto.dom
      针对 javax.xml.crypto包的DOM特定类。
      javax.xml.crypto.dsig
      用于生成和验证XML数字签名的类。
      javax.xml.crypto.dsig.dom
      针对 javax.xml.crypto.dsig包的DOM特定类。
      javax.xml.crypto.dsig.keyinfo
      用于解析和处理KeyInfo元素和结构的类。
      javax.xml.crypto.dsig.spec
      XML数字签名的参数类。
      Indirect Exports
      From Packages
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.xml.crypto (Java SE 9 & JDK 9 )

java.xml.crypto

Interfaces

  • AlgorithmMethod
  • C14NMethodParameterSpec
  • CanonicalizationMethod
  • Data
  • DigestMethod
  • DigestMethodParameterSpec
  • DOMURIReference
  • KeyInfo
  • KeyName
  • KeySelectorResult
  • KeyValue
  • Manifest
  • NodeSetData
  • PGPData
  • Reference
  • RetrievalMethod
  • SignatureMethod
  • SignatureMethodParameterSpec
  • SignatureProperties
  • SignatureProperty
  • SignedInfo
  • Transform
  • TransformParameterSpec
  • URIDereferencer
  • URIReference
  • X509Data
  • X509IssuerSerial
  • XMLCryptoContext
  • XMLObject
  • XMLSignature
  • XMLSignature.SignatureValue
  • XMLSignContext
  • XMLStructure
  • XMLValidateContext

Classes

  • DOMCryptoContext
  • DOMSignContext
  • DOMStructure
  • DOMValidateContext
  • ExcC14NParameterSpec
  • HMACParameterSpec
  • KeyInfoFactory
  • KeySelector
  • KeySelector.Purpose
  • OctetStreamData
  • TransformService
  • XMLSignatureFactory
  • XPathFilter2ParameterSpec
  • XPathFilterParameterSpec
  • XPathType
  • XPathType.Filter
  • XSLTTransformParameterSpec

Exceptions

  • KeySelectorException
  • MarshalException
  • NoSuchMechanismException
  • TransformException
  • URIReferenceException
  • XMLSignatureException


java.xml.ws (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module java.xml.ws

Deprecated, for removal: This API element is subject to removal in a future version.
定义基于XML的Web服务（JAX-WS）的Java API和Web服务元数据API。

此模块可升级。

Module Graph:
Module graph for java.xml.ws Module graph for java.xml.ws
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.jws
      javax.jws.soap
      javax.xml.soap
      提供用于创建和构建SOAP消息的API。
      javax.xml.ws
      此软件包包含核心JAX-WS API。
      javax.xml.ws.handler
      新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
      javax.xml.ws.handler.soap
      此包定义SOAP消息处理程序的API。
      javax.xml.ws.http
      该包定义了特定于HTTP绑定的API。
      javax.xml.ws.soap
      该包定义了SOAP绑定专用的API。
      javax.xml.ws.spi
      此套件为JAX-WS定义了SPI。
      javax.xml.ws.spi.http
      提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
      javax.xml.ws.wsaddressing
      此包定义与WS-Addressing相关的API。
      Indirect Exports
      From Packages
      java.activation javax.activation
      java.datatransfer java.awt.datatransfer
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers
      java.xml.bind javax.xml.bind javax.xml.bind.annotation javax.xml.bind.annotation.adapters javax.xml.bind.attachment javax.xml.bind.helpers javax.xml.bind.util

    • Modules

      Requires
      Modifier Module 描述
      transitive java.activation
      定义JavaBean激活框架（JAF）API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
      transitive java.xml.bind
      定义用于XML绑定（JAXB）API的Java体系结构。
      Indirect Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。

    • Services

      Uses
      Type 描述
      MessageFactory
      一个创建 SOAPMessage对象的工厂。
      Provider
      ServiceDelegate和 Endpoint对象的服务提供商。
      SAAJMetaFactory
      在SAAJ API中定义的工厂的实现类的接入点。
      SOAPConnectionFactory
      一个创建 SOAPConnection对象的工厂。
      SOAPFactory
      SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.xml.ws (Java SE 9 & JDK 9 )

java.xml.ws

Interfaces

  • AsyncHandler
  • Binding
  • BindingProvider
  • Detail
  • DetailEntry
  • Dispatch
  • Handler
  • HandlerResolver
  • HTTPBinding
  • LogicalHandler
  • LogicalMessage
  • LogicalMessageContext
  • MessageContext
  • Name
  • Node
  • PortInfo
  • Provider
  • Response
  • SOAPBinding
  • SOAPBody
  • SOAPBodyElement
  • SOAPConstants
  • SOAPElement
  • SOAPEnvelope
  • SOAPFault
  • SOAPFaultElement
  • SOAPHandler
  • SOAPHeader
  • SOAPHeaderElement
  • SOAPMessageContext
  • Text
  • WebServiceContext

Classes

  • AddressingFeature
  • AttachmentPart
  • Endpoint
  • EndpointContext
  • EndpointReference
  • Holder
  • HttpContext
  • HttpExchange
  • HttpHandler
  • Invoker
  • MessageFactory
  • MimeHeader
  • MimeHeaders
  • MTOMFeature
  • Provider
  • RespectBindingFeature
  • SAAJMetaFactory
  • SAAJResult
  • Service
  • ServiceDelegate
  • SOAPConnection
  • SOAPConnectionFactory
  • SOAPElementFactory
  • SOAPFactory
  • SOAPMessage
  • SOAPPart
  • W3CEndpointReference
  • W3CEndpointReferenceBuilder
  • WebServiceFeature
  • WebServicePermission

Enums

  • AddressingFeature.Responses
  • MessageContext.Scope
  • Service.Mode
  • SOAPBinding.ParameterStyle
  • SOAPBinding.Style
  • SOAPBinding.Use
  • WebParam.Mode

Exceptions

  • HTTPException
  • ProtocolException
  • SOAPException
  • SOAPFaultException
  • WebServiceException

注解类型

  • Action
  • Addressing
  • BindingType
  • FaultAction
  • HandlerChain
  • InitParam
  • MTOM
  • Oneway
  • RequestWrapper
  • RespectBinding
  • ResponseWrapper
  • ServiceMode
  • SOAPBinding
  • SOAPMessageHandler
  • SOAPMessageHandlers
  • WebEndpoint
  • WebFault
  • WebMethod
  • WebParam
  • WebResult
  • WebService
  • WebServiceClient
  • WebServiceFeatureAnnotation
  • WebServiceProvider
  • WebServiceRef
  • WebServiceRefs


java.xml.ws.annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module java.xml.ws.annotation

Deprecated, for removal: This API element is subject to removal in a future version.
Defines a subset of the Common Annotations API to support programs running on the Java SE Platform.

This module is upgradeable.

Module Graph:
Module graph for java.xml.ws.annotation Module graph for java.xml.ws.annotation
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javax.annotation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


java.xml.ws.annotation (Java SE 9 & JDK 9 )

java.xml.ws.annotation

Enums

  • Resource.AuthenticationType

注解类型

  • Generated
  • PostConstruct
  • PreDestroy
  • Resource
  • Resources


javafx.base (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module javafx.base

定义JavaFX UI工具包的基本API，包括用于绑定，属性，集合和事件的API。
Module Graph:
Module graph for javafx.base Module graph for javafx.base
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javafx.beans
      包 javafx.beans包含定义最通用形式的可观察性的接口。
      javafx.beans.binding
      提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
      javafx.beans.property
      程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
      javafx.beans.property.adapter
      提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
      javafx.beans.value
      包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
      javafx.collections
      包含基本的JavaFX集合和集合实用程序
      javafx.collections.transformation
      提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
      javafx.event
      为FX事件，交付和处理提供基本框架。
      javafx.util
      包含各种实用程序和助手类。
      javafx.util.converter
      此包用于JavaFX的标准字符串转换器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


javafx.base (Java SE 9 & JDK 9 )

javafx.base

Interfaces

  • ArrayChangeListener
  • Binding
  • Builder
  • BuilderFactory
  • Callback
  • ChangeListener
  • EventDispatchChain
  • EventDispatcher
  • EventHandler
  • EventTarget
  • InvalidationListener
  • JavaBeanProperty
  • ListChangeListener
  • MapChangeListener
  • NumberBinding
  • NumberExpression
  • Observable
  • ObservableArray
  • ObservableBooleanValue
  • ObservableDoubleValue
  • ObservableFloatArray
  • ObservableFloatValue
  • ObservableIntegerArray
  • ObservableIntegerValue
  • ObservableList
  • ObservableListValue
  • ObservableLongValue
  • ObservableMap
  • ObservableMapValue
  • ObservableNumberValue
  • ObservableObjectValue
  • ObservableSet
  • ObservableSetValue
  • ObservableStringValue
  • ObservableValue
  • Property
  • ReadOnlyJavaBeanProperty
  • ReadOnlyProperty
  • SetChangeListener
  • WeakListener
  • WritableBooleanValue
  • WritableDoubleValue
  • WritableFloatValue
  • WritableIntegerValue
  • WritableListValue
  • WritableLongValue
  • WritableMapValue
  • WritableNumberValue
  • WritableObjectValue
  • WritableSetValue
  • WritableStringValue
  • WritableValue

Classes

  • ActionEvent
  • BigDecimalStringConverter
  • BigIntegerStringConverter
  • Bindings
  • BooleanBinding
  • BooleanExpression
  • BooleanProperty
  • BooleanPropertyBase
  • BooleanStringConverter
  • ByteStringConverter
  • CharacterStringConverter
  • CurrencyStringConverter
  • DateStringConverter
  • DateTimeStringConverter
  • DefaultStringConverter
  • DoubleBinding
  • DoubleExpression
  • DoubleProperty
  • DoublePropertyBase
  • DoubleStringConverter
  • Duration
  • Event
  • EventType
  • FilteredList
  • FloatBinding
  • FloatExpression
  • FloatProperty
  • FloatPropertyBase
  • FloatStringConverter
  • FormatStringConverter
  • FXCollections
  • FXPermission
  • IntegerBinding
  • IntegerExpression
  • IntegerProperty
  • IntegerPropertyBase
  • IntegerStringConverter
  • JavaBeanBooleanProperty
  • JavaBeanBooleanPropertyBuilder
  • JavaBeanDoubleProperty
  • JavaBeanDoublePropertyBuilder
  • JavaBeanFloatProperty
  • JavaBeanFloatPropertyBuilder
  • JavaBeanIntegerProperty
  • JavaBeanIntegerPropertyBuilder
  • JavaBeanLongProperty
  • JavaBeanLongPropertyBuilder
  • JavaBeanObjectProperty
  • JavaBeanObjectPropertyBuilder
  • JavaBeanStringProperty
  • JavaBeanStringPropertyBuilder
  • ListBinding
  • ListChangeListener.Change
  • ListExpression
  • ListProperty
  • ListPropertyBase
  • LocalDateStringConverter
  • LocalDateTimeStringConverter
  • LocalTimeStringConverter
  • LongBinding
  • LongExpression
  • LongProperty
  • LongPropertyBase
  • LongStringConverter
  • MapBinding
  • MapChangeListener.Change
  • MapExpression
  • MapProperty
  • MapPropertyBase
  • ModifiableObservableListBase
  • NumberExpressionBase
  • NumberStringConverter
  • ObjectBinding
  • ObjectExpression
  • ObjectProperty
  • ObjectPropertyBase
  • ObservableArrayBase
  • ObservableListBase
  • ObservableValueBase
  • Pair
  • PercentageStringConverter
  • ReadOnlyBooleanProperty
  • ReadOnlyBooleanPropertyBase
  • ReadOnlyBooleanWrapper
  • ReadOnlyDoubleProperty
  • ReadOnlyDoublePropertyBase
  • ReadOnlyDoubleWrapper
  • ReadOnlyFloatProperty
  • ReadOnlyFloatPropertyBase
  • ReadOnlyFloatWrapper
  • ReadOnlyIntegerProperty
  • ReadOnlyIntegerPropertyBase
  • ReadOnlyIntegerWrapper
  • ReadOnlyJavaBeanBooleanProperty
  • ReadOnlyJavaBeanBooleanPropertyBuilder
  • ReadOnlyJavaBeanDoubleProperty
  • ReadOnlyJavaBeanDoublePropertyBuilder
  • ReadOnlyJavaBeanFloatProperty
  • ReadOnlyJavaBeanFloatPropertyBuilder
  • ReadOnlyJavaBeanIntegerProperty
  • ReadOnlyJavaBeanIntegerPropertyBuilder
  • ReadOnlyJavaBeanLongProperty
  • ReadOnlyJavaBeanLongPropertyBuilder
  • ReadOnlyJavaBeanObjectProperty
  • ReadOnlyJavaBeanObjectPropertyBuilder
  • ReadOnlyJavaBeanStringProperty
  • ReadOnlyJavaBeanStringPropertyBuilder
  • ReadOnlyListProperty
  • ReadOnlyListPropertyBase
  • ReadOnlyListWrapper
  • ReadOnlyLongProperty
  • ReadOnlyLongPropertyBase
  • ReadOnlyLongWrapper
  • ReadOnlyMapProperty
  • ReadOnlyMapPropertyBase
  • ReadOnlyMapWrapper
  • ReadOnlyObjectProperty
  • ReadOnlyObjectPropertyBase
  • ReadOnlyObjectWrapper
  • ReadOnlySetProperty
  • ReadOnlySetPropertyBase
  • ReadOnlySetWrapper
  • ReadOnlyStringProperty
  • ReadOnlyStringPropertyBase
  • ReadOnlyStringWrapper
  • SetBinding
  • SetChangeListener.Change
  • SetExpression
  • SetProperty
  • SetPropertyBase
  • ShortStringConverter
  • SimpleBooleanProperty
  • SimpleDoubleProperty
  • SimpleFloatProperty
  • SimpleIntegerProperty
  • SimpleListProperty
  • SimpleLongProperty
  • SimpleMapProperty
  • SimpleObjectProperty
  • SimpleSetProperty
  • SimpleStringProperty
  • SortedList
  • StringBinding
  • StringConverter
  • StringExpression
  • StringProperty
  • StringPropertyBase
  • TimeStringConverter
  • TransformationList
  • WeakChangeListener
  • WeakEventHandler
  • WeakInvalidationListener
  • WeakListChangeListener
  • WeakMapChangeListener
  • WeakSetChangeListener
  • When

注解类型

  • DefaultProperty
  • NamedArg


javafx.controls (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module javafx.controls

定义可用于JavaFX UI工具包的UI控件，图表和外观。
Module Graph:
Module graph for javafx.controls Module graph for javafx.controls
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javafx.scene.chart
      JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
      javafx.scene.control
      JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
      javafx.scene.control.cell
      所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
      javafx.scene.control.skin
      javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
      Indirect Exports
      From Packages
      javafx.base javafx.beans javafx.beans.binding javafx.beans.property javafx.beans.property.adapter javafx.beans.value javafx.collections javafx.collections.transformation javafx.event javafx.util javafx.util.converter
      javafx.graphics javafx.animation javafx.application javafx.concurrent javafx.css javafx.css.converter javafx.geometry javafx.print javafx.scene javafx.scene.canvas javafx.scene.effect javafx.scene.image javafx.scene.input javafx.scene.layout javafx.scene.paint javafx.scene.shape javafx.scene.text javafx.scene.transform javafx.stage

    • Modules

      Requires
      Modifier Module 描述
      transitive javafx.base
      定义JavaFX UI工具包的基本API，包括用于绑定，属性，集合和事件的API。
      transitive javafx.graphics
      Defines the core scenegraph APIs for the JavaFX UI toolkit (such as layout containers, application lifecycle, shapes, transformations, canvas, input, painting, image handling, and effects), as well as APIs for animation, css, concurrency, geometry, printing, and windowing.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


javafx.controls (Java SE 9 & JDK 9 )

javafx.controls

Interfaces

  • Skin
  • Skinnable
  • TextInputControl.Content
  • Toggle

Classes

  • Accordion
  • AccordionSkin
  • Alert
  • AreaChart
  • Axis
  • Axis.TickMark
  • BarChart
  • BubbleChart
  • Button
  • ButtonBar
  • ButtonBarSkin
  • ButtonBase
  • ButtonSkin
  • ButtonType
  • CategoryAxis
  • Cell
  • CellSkinBase
  • Chart
  • CheckBox
  • CheckBoxListCell
  • CheckBoxSkin
  • CheckBoxTableCell
  • CheckBoxTreeCell
  • CheckBoxTreeItem
  • CheckBoxTreeItem.TreeModificationEvent
  • CheckBoxTreeTableCell
  • CheckMenuItem
  • ChoiceBox
  • ChoiceBoxListCell
  • ChoiceBoxSkin
  • ChoiceBoxTableCell
  • ChoiceBoxTreeCell
  • ChoiceBoxTreeTableCell
  • ChoiceDialog
  • ColorPicker
  • ColorPickerSkin
  • ComboBox
  • ComboBoxBase
  • ComboBoxBaseSkin
  • ComboBoxListCell
  • ComboBoxListViewSkin
  • ComboBoxPopupControl
  • ComboBoxTableCell
  • ComboBoxTreeCell
  • ComboBoxTreeTableCell
  • ContextMenu
  • ContextMenuSkin
  • Control
  • CustomMenuItem
  • DateCell
  • DateCellSkin
  • DatePicker
  • DatePickerSkin
  • Dialog
  • DialogEvent
  • DialogPane
  • FocusModel
  • Hyperlink
  • HyperlinkSkin
  • IndexedCell
  • IndexRange
  • Label
  • Labeled
  • LabeledSkinBase
  • LabelSkin
  • LineChart
  • ListCell
  • ListCellSkin
  • ListView
  • ListView.EditEvent
  • ListViewSkin
  • MapValueFactory
  • Menu
  • MenuBar
  • MenuBarSkin
  • MenuButton
  • MenuButtonSkin
  • MenuButtonSkinBase
  • MenuItem
  • MultipleSelectionModel
  • NestedTableColumnHeader
  • NumberAxis
  • NumberAxis.DefaultFormatter
  • Pagination
  • PaginationSkin
  • PasswordField
  • PieChart
  • PieChart.Data
  • PopupControl
  • ProgressBar
  • ProgressBarSkin
  • ProgressBarTableCell
  • ProgressBarTreeTableCell
  • ProgressIndicator
  • ProgressIndicatorSkin
  • PropertyValueFactory
  • RadioButton
  • RadioButtonSkin
  • RadioMenuItem
  • ResizeFeaturesBase
  • ScatterChart
  • ScrollBar
  • ScrollBarSkin
  • ScrollPane
  • ScrollPaneSkin
  • ScrollToEvent
  • SelectionModel
  • Separator
  • SeparatorMenuItem
  • SeparatorSkin
  • SingleSelectionModel
  • SkinBase
  • Slider
  • SliderSkin
  • SortEvent
  • Spinner
  • SpinnerSkin
  • SpinnerValueFactory
  • SpinnerValueFactory.DoubleSpinnerValueFactory
  • SpinnerValueFactory.IntegerSpinnerValueFactory
  • SpinnerValueFactory.ListSpinnerValueFactory
  • SplitMenuButton
  • SplitMenuButtonSkin
  • SplitPane
  • SplitPane.Divider
  • SplitPaneSkin
  • StackedAreaChart
  • StackedBarChart
  • Tab
  • TableCell
  • TableCellSkin
  • TableCellSkinBase
  • TableColumn
  • TableColumn.CellDataFeatures
  • TableColumn.CellEditEvent
  • TableColumnBase
  • TableColumnHeader
  • TableFocusModel
  • TableHeaderRow
  • TablePosition
  • TablePositionBase
  • TableRow
  • TableRowSkin
  • TableRowSkinBase
  • TableSelectionModel
  • TableView
  • TableView.ResizeFeatures
  • TableView.TableViewFocusModel
  • TableView.TableViewSelectionModel
  • TableViewSkin
  • TableViewSkinBase
  • TabPane
  • TabPaneSkin
  • TextArea
  • TextAreaSkin
  • TextField
  • TextFieldListCell
  • TextFieldSkin
  • TextFieldTableCell
  • TextFieldTreeCell
  • TextFieldTreeTableCell
  • TextFormatter
  • TextFormatter.Change
  • TextInputControl
  • TextInputControlSkin
  • TextInputDialog
  • TitledPane
  • TitledPaneSkin
  • ToggleButton
  • ToggleButtonSkin
  • ToggleGroup
  • ToolBar
  • ToolBarSkin
  • Tooltip
  • TooltipSkin
  • TreeCell
  • TreeCellSkin
  • TreeItem
  • TreeItem.TreeModificationEvent
  • TreeItemPropertyValueFactory
  • TreeTableCell
  • TreeTableCellSkin
  • TreeTableColumn
  • TreeTableColumn.CellDataFeatures
  • TreeTableColumn.CellEditEvent
  • TreeTablePosition
  • TreeTableRow
  • TreeTableRowSkin
  • TreeTableView
  • TreeTableView.EditEvent
  • TreeTableView.ResizeFeatures
  • TreeTableView.TreeTableViewFocusModel
  • TreeTableView.TreeTableViewSelectionModel
  • TreeTableViewSkin
  • TreeView
  • TreeView.EditEvent
  • TreeViewSkin
  • ValueAxis
  • VirtualContainerBase
  • VirtualFlow
  • XYChart
  • XYChart.Data
  • XYChart.Series

Enums

  • Alert.AlertType
  • ButtonBar.ButtonData
  • ContentDisplay
  • LineChart.SortingPolicy
  • OverrunStyle
  • ScrollPane.ScrollBarPolicy
  • SelectionMode
  • TableColumn.SortType
  • TabPane.TabClosingPolicy
  • TextInputControlSkin.Direction
  • TextInputControlSkin.TextUnit
  • TreeSortMode
  • TreeTableColumn.SortType


javafx.fxml (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module javafx.fxml

定义JavaFX UI工具包的FXML API。
Module Graph:
Module graph for javafx.fxml Module graph for javafx.fxml
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javafx.fxml
      包含用于从标记加载对象层次结构的类。
      Indirect Exports
      From Packages
      javafx.base javafx.beans javafx.beans.binding javafx.beans.property javafx.beans.property.adapter javafx.beans.value javafx.collections javafx.collections.transformation javafx.event javafx.util javafx.util.converter

    • Modules

      Requires
      Modifier Module 描述
      transitive javafx.base
      定义JavaFX UI工具包的基本API，包括用于绑定，属性，集合和事件的API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


javafx.fxml (Java SE 9 & JDK 9 )

javafx.fxml

Interfaces

  • Initializable
  • LoadListener

Classes

  • FXMLLoader
  • JavaFXBuilderFactory

Exceptions

  • LoadException

注解类型

  • FXML


javafx.graphics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module javafx.graphics

定义JavaFX UI工具包的核心场景API（如布局容器，应用程序生命周期，形状，转换，画布，输入，绘画，图像处理和效果），以及用于动画，CSS，并发，几何，打印的API和窗口。
Module Graph:
Module graph for javafx.graphics Module graph for javafx.graphics
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javafx.animation
      提供一组类，便于使用基于过渡的动画。
      javafx.application
      提供应用程序生命周期类。
      javafx.concurrent
      提供javafx.task的一组类。
      javafx.css
      提供API，通过CSS使属性变得风格，并支持伪类状态。
      javafx.css.converter
      提供各种转换CSS解析值的StyleConverter类。
      javafx.geometry
      提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
      javafx.print
      提供JavaFX Printing API的公共类。
      javafx.scene
      为JavaFX Scene Graph API提供核心的基类集。
      javafx.scene.canvas
      为canvas提供一组类，即渲染API的立即模式样式。
      javafx.scene.effect
      提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
      javafx.scene.image
      提供加载和显示图像的一组类。
      javafx.scene.input
      提供一组用于鼠标和键盘输入事件处理的类。
      javafx.scene.layout
      提供类来支持用户界面布局。
      javafx.scene.paint
      提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
      javafx.scene.shape
      提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
      javafx.scene.text
      为字体和可渲染的文本节点提供一组类。
      javafx.scene.transform
      提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
      javafx.stage
      提供JavaFX内容的顶级容器类。
      Indirect Exports
      From Packages
      javafx.base javafx.beans javafx.beans.binding javafx.beans.property javafx.beans.property.adapter javafx.beans.value javafx.collections javafx.collections.transformation javafx.event javafx.util javafx.util.converter

    • Modules

      Requires
      Modifier Module 描述
      transitive javafx.base
      定义JavaFX UI工具包的基本API，包括用于绑定，属性，集合和事件的API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


javafx.graphics (Java SE 9 & JDK 9 )

javafx.graphics

Interfaces

  • InputMethodRequests
  • Interpolatable
  • ObservableFaceArray
  • PixelReader
  • PixelWriter
  • Preloader.PreloaderNotification
  • Styleable
  • StyleableProperty
  • Worker

Classes

  • Affine
  • AmbientLight
  • AnchorPane
  • Animation
  • AnimationTimer
  • Application
  • Application.Parameters
  • Arc
  • ArcTo
  • Background
  • BackgroundFill
  • BackgroundImage
  • BackgroundPosition
  • BackgroundSize
  • Blend
  • Bloom
  • BooleanConverter
  • Border
  • BorderImage
  • BorderPane
  • BorderStroke
  • BorderStrokeStyle
  • BorderWidths
  • BoundingBox
  • Bounds
  • Box
  • BoxBlur
  • Camera
  • Canvas
  • Circle
  • Clipboard
  • ClipboardContent
  • ClosePath
  • Color
  • ColorAdjust
  • ColorConverter
  • ColorInput
  • ColumnConstraints
  • CompoundSelector
  • ConstraintsBase
  • ContextMenuEvent
  • CornerRadii
  • CssMetaData
  • CssParser
  • CssParser.ParseError
  • CssParser.ParseError.InlineStyleParsingError
  • CssParser.ParseError.PropertySetError
  • CssParser.ParseError.StringParsingError
  • CssParser.ParseError.StylesheetParsingError
  • CubicCurve
  • CubicCurveTo
  • Cursor
  • CursorConverter
  • Cylinder
  • DataFormat
  • Declaration
  • DeriveColorConverter
  • DeriveSizeConverter
  • Dimension2D
  • DirectoryChooser
  • DisplacementMap
  • Dragboard
  • DragEvent
  • DropShadow
  • DurationConverter
  • Effect
  • EffectConverter
  • EffectConverter.DropShadowConverter
  • EffectConverter.InnerShadowConverter
  • Ellipse
  • EnumConverter
  • FadeTransition
  • FileChooser
  • FileChooser.ExtensionFilter
  • FillTransition
  • FloatMap
  • FlowPane
  • Font
  • FontConverter
  • FontConverter.FontSizeConverter
  • FontConverter.FontStyleConverter
  • FontConverter.FontWeightConverter
  • FontCssMetaData
  • FontFace
  • GaussianBlur
  • GestureEvent
  • Glow
  • GraphicsContext
  • GridPane
  • Group
  • HBox
  • HitInfo
  • HLineTo
  • HostServices
  • Image
  • ImageCursor
  • ImageInput
  • ImagePattern
  • ImageView
  • InnerShadow
  • InputEvent
  • InputMethodEvent
  • InputMethodTextRun
  • Insets
  • InsetsConverter
  • InsetsConverter.SequenceConverter
  • Interpolator
  • JobSettings
  • KeyCharacterCombination
  • KeyCodeCombination
  • KeyCombination
  • KeyCombination.Modifier
  • KeyEvent
  • KeyFrame
  • KeyValue
  • LadderConverter
  • Light
  • Light.Distant
  • Light.Point
  • Light.Spot
  • LightBase
  • Lighting
  • Line
  • LinearGradient
  • LineTo
  • Match
  • Material
  • Mesh
  • MeshView
  • Mnemonic
  • MotionBlur
  • MouseDragEvent
  • MouseEvent
  • MoveTo
  • Node
  • PageLayout
  • PageRange
  • Paint
  • PaintConverter
  • PaintConverter.ImagePatternConverter
  • PaintConverter.LinearGradientConverter
  • PaintConverter.RadialGradientConverter
  • PaintConverter.RepeatingImagePatternConverter
  • PaintConverter.SequenceConverter
  • Pane
  • Paper
  • PaperSource
  • ParallelCamera
  • ParallelTransition
  • Parent
  • ParsedValue
  • Path
  • PathElement
  • PathTransition
  • PauseTransition
  • PerspectiveCamera
  • PerspectiveTransform
  • PhongMaterial
  • PickResult
  • PixelFormat
  • Platform
  • Point2D
  • Point3D
  • PointLight
  • Polygon
  • Polyline
  • Popup
  • PopupWindow
  • Preloader
  • Preloader.ErrorNotification
  • Preloader.ProgressNotification
  • Preloader.StateChangeNotification
  • Printer
  • PrinterAttributes
  • PrinterJob
  • PrintResolution
  • PseudoClass
  • QuadCurve
  • QuadCurveTo
  • RadialGradient
  • Rectangle
  • Rectangle2D
  • Reflection
  • Region
  • Rotate
  • RotateEvent
  • RotateTransition
  • RowConstraints
  • Rule
  • Scale
  • ScaleTransition
  • Scene
  • SceneAntialiasing
  • ScheduledService
  • Screen
  • ScrollEvent
  • Selector
  • SepiaTone
  • SequentialTransition
  • Service
  • Shadow
  • Shape
  • Shape3D
  • ShapeConverter
  • Shear
  • SimpleSelector
  • SimpleStyleableBooleanProperty
  • SimpleStyleableDoubleProperty
  • SimpleStyleableFloatProperty
  • SimpleStyleableIntegerProperty
  • SimpleStyleableLongProperty
  • SimpleStyleableObjectProperty
  • SimpleStyleableStringProperty
  • Size
  • SizeConverter
  • SizeConverter.SequenceConverter
  • SnapshotParameters
  • SnapshotResult
  • Sphere
  • StackPane
  • Stage
  • Stop
  • StopConverter
  • StringConverter
  • StringConverter.SequenceConverter
  • StrokeTransition
  • Style
  • StyleableBooleanProperty
  • StyleableDoubleProperty
  • StyleableFloatProperty
  • StyleableIntegerProperty
  • StyleableLongProperty
  • StyleableObjectProperty
  • StyleablePropertyFactory
  • StyleableStringProperty
  • StyleClass
  • StyleConverter
  • StyleConverter.StringStore
  • Stylesheet
  • SubScene
  • SVGPath
  • SwipeEvent
  • Task
  • Text
  • TextFlow
  • TilePane
  • Timeline
  • TouchEvent
  • TouchPoint
  • Transform
  • TransformChangedEvent
  • Transition
  • Translate
  • TranslateTransition
  • TriangleMesh
  • URLConverter
  • URLConverter.SequenceConverter
  • VBox
  • VertexFormat
  • VLineTo
  • Window
  • WindowEvent
  • WorkerStateEvent
  • WritableImage
  • WritablePixelFormat
  • ZoomEvent

Enums

  • AccessibleAction
  • AccessibleAttribute
  • AccessibleRole
  • Animation.Status
  • ArcType
  • BackgroundRepeat
  • BlendMode
  • BlurType
  • BorderRepeat
  • CacheHint
  • Collation
  • ConditionalFeature
  • CullFace
  • CycleMethod
  • DepthTest
  • DrawMode
  • FillRule
  • FontPosture
  • FontSmoothingType
  • FontWeight
  • HorizontalDirection
  • HPos
  • InputMethodHighlight
  • KeyCode
  • KeyCombination.ModifierValue
  • MatrixType
  • Modality
  • MouseButton
  • NodeOrientation
  • Orientation
  • PageOrientation
  • PathTransition.OrientationType
  • PixelFormat.Type
  • PopupWindow.AnchorLocation
  • Pos
  • Preloader.StateChangeNotification.Type
  • PrintColor
  • Printer.MarginType
  • PrinterJob.JobStatus
  • PrintQuality
  • PrintSides
  • Priority
  • ScrollEvent.HorizontalTextScrollUnits
  • ScrollEvent.VerticalTextScrollUnits
  • Side
  • SizeUnits
  • StageStyle
  • StrokeLineCap
  • StrokeLineJoin
  • StrokeType
  • StyleOrigin
  • TextAlignment
  • TextBoundsType
  • TouchPoint.State
  • TransferMode
  • VerticalDirection
  • VPos
  • Worker.State

Exceptions

  • NonInvertibleTransformException


javafx.media (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module javafx.media

定义用于播放媒体和音频内容的API，作为JavaFX UI工具包的一部分，包括MediaView和MediaPlayer 。
Module Graph:
Module graph for javafx.media Module graph for javafx.media
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javafx.scene.media
      提供用于将音频和视频集成到Java FX应用程序中的一组类。
      Indirect Exports
      From Packages
      javafx.base javafx.beans javafx.beans.binding javafx.beans.property javafx.beans.property.adapter javafx.beans.value javafx.collections javafx.collections.transformation javafx.event javafx.util javafx.util.converter
      javafx.graphics javafx.animation javafx.application javafx.concurrent javafx.css javafx.css.converter javafx.geometry javafx.print javafx.scene javafx.scene.canvas javafx.scene.effect javafx.scene.image javafx.scene.input javafx.scene.layout javafx.scene.paint javafx.scene.shape javafx.scene.text javafx.scene.transform javafx.stage

    • Modules

      Requires
      Modifier Module 描述
      transitive javafx.base
      定义JavaFX UI工具包的基本API，包括用于绑定，属性，集合和事件的API。
      transitive javafx.graphics
      定义JavaFX UI工具包的核心场景API（如布局容器，应用程序生命周期，形状，转换，画布，输入，绘画，图像处理和效果），以及用于动画，CSS，并发，几何，打印的API和窗口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


javafx.media (Java SE 9 & JDK 9 )

javafx.media

Interfaces

  • AudioSpectrumListener

Classes

  • AudioClip
  • AudioEqualizer
  • AudioTrack
  • EqualizerBand
  • Media
  • MediaErrorEvent
  • MediaMarkerEvent
  • MediaPlayer
  • MediaView
  • SubtitleTrack
  • Track
  • VideoTrack

Enums

  • MediaException.Type
  • MediaPlayer.Status

Exceptions

  • MediaException


javafx.swing (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module javafx.swing

定义JavaFX UI工具包中包含的JavaFX / Swing互操作支持的API，包括SwingNode （用于嵌入JavaFX应用程序中的Swing）和JFXPanel （用于在Swing应用程序中嵌入JavaFX）。
Module Graph:
Module graph for javafx.swing Module graph for javafx.swing
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javafx.embed.swing
      提供一组在Swing应用程序中使用JavaFX的类。
      Indirect Exports
      From Packages
      java.desktop java.applet java.awt java.awt.color java.awt.desktop java.awt.dnd java.awt.event java.awt.font java.awt.geom java.awt.im java.awt.im.spi java.awt.image java.awt.image.renderable java.awt.print java.beans java.beans.beancontext javax.accessibility javax.imageio javax.imageio.event javax.imageio.metadata javax.imageio.plugins.bmp javax.imageio.plugins.jpeg javax.imageio.plugins.tiff javax.imageio.spi javax.imageio.stream javax.print javax.print.attribute javax.print.attribute.standard javax.print.event javax.sound.midi javax.sound.midi.spi javax.sound.sampled javax.sound.sampled.spi javax.swing javax.swing.border javax.swing.colorchooser javax.swing.event javax.swing.filechooser javax.swing.plaf javax.swing.plaf.basic javax.swing.plaf.metal javax.swing.plaf.multi javax.swing.plaf.nimbus javax.swing.plaf.synth javax.swing.table javax.swing.text javax.swing.text.html javax.swing.text.html.parser javax.swing.text.rtf javax.swing.tree javax.swing.undo
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers
      javafx.graphics javafx.animation javafx.application javafx.concurrent javafx.css javafx.css.converter javafx.geometry javafx.print javafx.scene javafx.scene.canvas javafx.scene.effect javafx.scene.image javafx.scene.input javafx.scene.layout javafx.scene.paint javafx.scene.shape javafx.scene.text javafx.scene.transform javafx.stage

    • Modules

      Requires
      Modifier Module 描述
      transitive java.desktop
      定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
      transitive javafx.graphics
      定义JavaFX UI工具包的核心场景API（如布局容器，应用程序生命周期，形状，转换，画布，输入，绘画，图像处理和效果），以及用于动画，CSS，并发，几何，打印的API和窗口。
      Indirect Requires
      Modifier Module 描述
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


javafx.swing (Java SE 9 & JDK 9 )

javafx.swing

Classes

  • JFXPanel
  • SwingFXUtils
  • SwingNode


javafx.web (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module javafx.web

定义JavaFX UI工具包中包含的WebView功能的API。
Module Graph:
Module graph for javafx.web Module graph for javafx.web
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      javafx.scene.web
      该软件包提供了加载和显示Web内容的方法。
      Indirect Exports
      From Packages
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers
      javafx.base javafx.beans javafx.beans.binding javafx.beans.property javafx.beans.property.adapter javafx.beans.value javafx.collections javafx.collections.transformation javafx.event javafx.util javafx.util.converter
      javafx.controls javafx.scene.chart javafx.scene.control javafx.scene.control.cell javafx.scene.control.skin
      javafx.graphics javafx.animation javafx.application javafx.concurrent javafx.css javafx.css.converter javafx.geometry javafx.print javafx.scene javafx.scene.canvas javafx.scene.effect javafx.scene.image javafx.scene.input javafx.scene.layout javafx.scene.paint javafx.scene.shape javafx.scene.text javafx.scene.transform javafx.stage

    • Modules

      Requires
      Modifier Module 描述
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
      transitive javafx.base
      定义JavaFX UI工具包的基本API，包括用于绑定，属性，集合和事件的API。
      transitive javafx.controls
      定义可用于JavaFX UI工具包的UI控件，图表和外观。
      transitive javafx.graphics
      定义JavaFX UI工具包的核心场景API（如布局容器，应用程序生命周期，形状，转换，画布，输入，绘画，图像处理和效果），以及用于动画，CSS，并发，几何，打印的API和窗口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


javafx.web (Java SE 9 & JDK 9 )

javafx.web

Classes

  • HTMLEditor
  • HTMLEditorSkin
  • PopupFeatures
  • PromptData
  • WebEngine
  • WebErrorEvent
  • WebEvent
  • WebHistory
  • WebView

Enums

  • HTMLEditorSkin.Command


jdk.accessibility (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.accessibility

定义Assistive Technologies实施者使用的JDK实用程序类。
Module Graph:
Module graph for jdk.accessibility Module graph for jdk.accessibility
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.java.accessibility.util
      提供组成Java辅助功能实用程序的接口和类的集合。
      Indirect Exports
      From Packages
      java.datatransfer java.awt.datatransfer
      java.desktop java.applet java.awt java.awt.color java.awt.desktop java.awt.dnd java.awt.event java.awt.font java.awt.geom java.awt.im java.awt.im.spi java.awt.image java.awt.image.renderable java.awt.print java.beans java.beans.beancontext javax.accessibility javax.imageio javax.imageio.event javax.imageio.metadata javax.imageio.plugins.bmp javax.imageio.plugins.jpeg javax.imageio.plugins.tiff javax.imageio.spi javax.imageio.stream javax.print javax.print.attribute javax.print.attribute.standard javax.print.event javax.sound.midi javax.sound.midi.spi javax.sound.sampled javax.sound.sampled.spi javax.swing javax.swing.border javax.swing.colorchooser javax.swing.event javax.swing.filechooser javax.swing.plaf javax.swing.plaf.basic javax.swing.plaf.metal javax.swing.plaf.multi javax.swing.plaf.nimbus javax.swing.plaf.synth javax.swing.table javax.swing.text javax.swing.text.html javax.swing.text.html.parser javax.swing.text.rtf javax.swing.tree javax.swing.undo
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.desktop
      定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
      Indirect Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.accessibility (Java SE 9 & JDK 9 )

jdk.accessibility

Interfaces

  • GUIInitializedListener
  • TopLevelWindowListener

Classes

  • AccessibilityEventMonitor
  • AccessibilityListenerList
  • AWTEventMonitor
  • EventID
  • EventQueueMonitor
  • SwingEventMonitor
  • Translator


jdk.attach (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.attach

定义附加API。
Module Graph:
Module graph for jdk.attach Module graph for jdk.attach
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.tools.attach
      提供API附加到Java的虚拟机。
      com.sun.tools.attach.spi
      只有定义新附加提供商的开发者才需要直接使用这个包。

    • Services

      Uses
      Type 描述
      AttachProvider
      附加提供程序类以附加到Java虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.attach (Java SE 9 & JDK 9 )

jdk.attach

Classes

  • AttachPermission
  • AttachProvider
  • VirtualMachine
  • VirtualMachineDescriptor

Exceptions

  • AgentInitializationException
  • AgentLoadException
  • AttachNotSupportedException
  • AttachOperationFailedException


jdk.charsets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.charsets

提供charsets不在java.base （主要是双字节和IBM字符集）。
Module Graph:
Module graph for jdk.charsets Module graph for jdk.charsets
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      CharsetProvider
      字符集服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.charsets (Java SE 9 & JDK 9 )

jdk.charsets


jdk.compiler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.compiler

定义了system Java compiler及其命令行等效的实现， javac以及javah 。

javac的

该模块通过ToolProvider和Tool服务提供商接口（SPI）提供对javac的命令行访问等效，并通过JavaCompiler SPI更灵活地访问。

可通过致电ToolProvider.findFirst或名称为"javac"的service loader获取工具实例。

此外，从JavaCompiler获得的JavaCompiler.CompilationTask的实例可以下调到JavacTask以访问javac的较低级别的方面，例如Abstract Syntax Tree （AST）。

该模块使用FileSystemProvider API来定位文件系统提供程序。 特别是，这意味着如果编译器能够读取JAR文件，则jar文件系统提供程序（如jdk.zipfs模块中的）必须可用。

JAVAH

javah只作为一个命令行工具存在，不提供任何直接的API。 截至JDK 9，已被弃用。 在javac中使用-h选项。

工具指南：
javac ， javah
Module Graph:
Module graph for jdk.compiler Module graph for jdk.compiler
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.source.doctree
      提供用于将文档注释表示为抽象语法树（AST）的接口。
      com.sun.source.tree
      提供用于将源代码表示为抽象语法树（AST）的接口。
      com.sun.source.util
      为抽象语法树（AST）的操作提供实用程序。
      com.sun.tools.javac
      该包提供了 javac工具的传统入口点。
      Indirect Exports
      From Packages
      java.compiler javax.annotation.processing javax.lang.model javax.lang.model.element javax.lang.model.type javax.lang.model.util javax.tools

    • Modules

      Requires
      Modifier Module 描述
      transitive java.compiler
      定义语言模型，注释处理和Java编译器API。

    • Services

      Provides
      Type 描述
      JavaCompiler
      从程序中调用Java编程语言编译器的接口。
      Tool
      可以从程序调用的工具的通用界面。
      ToolProvider
      一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。
      Uses
      Type 描述
      Plugin
      javac插件的接口。
      Processor
      注释处理器的界面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.compiler (Java SE 9 & JDK 9 )

jdk.compiler

Interfaces

  • AnnotatedTypeTree
  • AnnotationTree
  • ArrayAccessTree
  • ArrayTypeTree
  • AssertTree
  • AssignmentTree
  • AttributeTree
  • AuthorTree
  • BinaryTree
  • BlockTagTree
  • BlockTree
  • BreakTree
  • CaseTree
  • CatchTree
  • ClassTree
  • CommentTree
  • CompilationUnitTree
  • CompoundAssignmentTree
  • ConditionalExpressionTree
  • ContinueTree
  • DeprecatedTree
  • DirectiveTree
  • DocCommentTree
  • DocRootTree
  • DocSourcePositions
  • DocTree
  • DocTreeFactory
  • DocTreeVisitor
  • DoWhileLoopTree
  • EmptyStatementTree
  • EndElementTree
  • EnhancedForLoopTree
  • EntityTree
  • ErroneousTree
  • ErroneousTree
  • ExportsTree
  • ExpressionStatementTree
  • ExpressionTree
  • ForLoopTree
  • HiddenTree
  • IdentifierTree
  • IdentifierTree
  • IfTree
  • ImportTree
  • IndexTree
  • InheritDocTree
  • InlineTagTree
  • InstanceOfTree
  • IntersectionTypeTree
  • LabeledStatementTree
  • LambdaExpressionTree
  • LineMap
  • LinkTree
  • LiteralTree
  • LiteralTree
  • MemberReferenceTree
  • MemberSelectTree
  • MethodInvocationTree
  • MethodTree
  • ModifiersTree
  • ModuleTree
  • NewArrayTree
  • NewClassTree
  • OpensTree
  • PackageTree
  • ParameterizedTypeTree
  • ParamTree
  • ParenthesizedTree
  • Plugin
  • PrimitiveTypeTree
  • ProvidesTree
  • ProvidesTree
  • ReferenceTree
  • RequiresTree
  • ReturnTree
  • ReturnTree
  • Scope
  • SeeTree
  • SerialDataTree
  • SerialFieldTree
  • SerialTree
  • SinceTree
  • SourcePositions
  • StartElementTree
  • StatementTree
  • SwitchTree
  • SynchronizedTree
  • TaskListener
  • TextTree
  • ThrowsTree
  • ThrowTree
  • 树
  • TreeVisitor
  • TryTree
  • TypeCastTree
  • TypeParameterTree
  • UnaryTree
  • UnionTypeTree
  • UnknownBlockTagTree
  • UnknownInlineTagTree
  • UsesTree
  • UsesTree
  • ValueTree
  • VariableTree
  • VersionTree
  • WhileLoopTree
  • WildcardTree

Classes

  • DocTreePath
  • DocTreePathScanner
  • DocTrees
  • DocTreeScanner
  • JavacTask
  • Main
  • SimpleDocTreeVisitor
  • SimpleTreeVisitor
  • TaskEvent
  • TreePath
  • TreePathScanner
  • Trees
  • TreeScanner

Enums

  • AttributeTree.ValueKind
  • DocTree.Kind
  • LambdaExpressionTree.BodyKind
  • MemberReferenceTree.ReferenceMode
  • ModuleTree.ModuleKind
  • TaskEvent.Kind
  • Tree.Kind


jdk.crypto.cryptoki (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.crypto.cryptoki

提供SunPKCS11安全提供程序的实现。
Module Graph:
Module graph for jdk.crypto.cryptoki Module graph for jdk.crypto.cryptoki
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.crypto.cryptoki (Java SE 9 & JDK 9 )

jdk.crypto.cryptoki


jdk.crypto.ec (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.crypto.ec

提供SunEC安全提供商的实施。
Module Graph:
Module graph for jdk.crypto.ec Module graph for jdk.crypto.ec
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.crypto.ec (Java SE 9 & JDK 9 )

jdk.crypto.ec


jdk.dynalink (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.dynalink

定义用于动态链接对象上的高级操作的API。

Dynalink是用于动态链接对象上的高级操作的库。 这些操作包括“读取属性”，“写入属性”，“调用函数”等。 Dynalink主要用于实现至少有一些表达式具有动态类型（即不能静态决定的类型）的编程语言，并且动态类型的操作表示为call sites 。 这些呼叫站点将在运行时根据所计算的表达式的值的实际类型链接到适当的目标method handles 。 这些可以在调用之间改变，需要多次重新链接呼叫站点以适应新类型; Dynalink处理所有这些和更多。

Dynalink支持使用与JVM基于类的模型不同（甚至根本不同）的对象模型来实现编程语言，并具有自定义类型转换。

Dynalink与java.lang.invoke封装密切相关，并依赖于此 。

虽然java.lang.invoke为invokedynamic调用站点的动态链接提供了一个低级别的API，但它并没有提供一种方式来表达对对象的更高级别的操作，也不提供实现它们的方法。 这些操作是面向对象环境中的常见操作：属性访问，集合元素的访问，方法和构造函数的调用（可能具有多个调度，例如Java重载方法解析的链接和运行时等价物）。 这些都是JVM中一种语言通常需要的功能。 如果语言是静态类型，其类型系统相匹配的是，JVM的，它可以与使用通常的调用，现场访问等指令（如实现这一目标invokevirtual ， getfield ）。 然而，如果语言是动态的（因此，在运行时评估之前，某些表达式的类型是不知道的），或者其对象模型或类型系统与JVM不匹配，则应该使用invokedynamic调用站点，让Dynalink管理他们。

例

Dynalink可能是最好的例子，说明它的用途。 让我们假设你有一个语言的程序，你不必声明一个对象的类型，并且你想访问它上的一个属性：
  var color = obj.color;
如果您生成了一个Java类来表示上述单行程序，其字节码将如下所示：
  aload 2 // load "obj" on stack
 invokedynamic "GET:PROPERTY:color"(Object)Object // invoke property getter on object of unknown type
 astore 3 // store the return value into local variable "color"
为了链接invokedynamic指令，我们需要一个引导方法。 Dynalink的简约引导方法可能如下所示：
  import java.lang.invoke.*;
 import jdk.dynalink.*;
 import jdk.dynalink.support.*;

 class MyLanguageRuntime {
     private static final DynamicLinker dynamicLinker = new DynamicLinkerFactory().createLinker();

     public static CallSite bootstrap(MethodHandles.Lookup lookup, String name, MethodType type) {
         return dynamicLinker.link(
             new SimpleRelinkableCallSite(
                 new CallSiteDescriptor(lookup, parseOperation(name), type)));
     }

     private static Operation parseOperation(String name) {
         ...
     }
 }
上述代码段中有几个重要的对象：
  • DynamicLinker是Dynalink的主要对象，它将调用站点的链接协调到实现其中命名的操作的方法句柄。 它使用DynamicLinkerFactory进行配置和创建。
  • 当引导引导方法被调用时，需要创建一个CallSite对象。 在Dynalink中，这些呼叫站点需要另外实现RelinkableCallSite接口。 “可重新链接”这里指出，如果调用站点在运行时遇到不同类型的对象，其目标将被更改为可以对新遇到的类型执行操作的方法句柄。 SimpleRelinkableCallSite和ChainedCallSite （在上述示例中未使用）是由库提供的两个实现。
  • Dynalink使用CallSiteDescriptor对象来保存引导方法的参数：查找和方法类型，因为它需要它们，只要它需要重新链接一个呼叫站点。
  • Dynalink使用Operation对象来表达动态操作。 然而，它并没有规定如何对您的呼叫站点中的操作进行编码。 这就是为什么在上面的例子中，这个parseOperation函数是空的，你可能希望提供代码来将调用站点的名字中的字符串"GET:PROPERTY:color"解析为一个命名的属性getter操作对象作为StandardOperation.GET.withNamespace(StandardNamespace.PROPERTY).named("color") 。

您以前的设置可以做些什么？ DynamicLinkerFactory默认创建一个DynamicLinker ，可以链接与通常的Java语义的Java对象。 如果你有这三个简单的课程：

  public class A {
     public String color;
     public A(String color) { this.color = color; }
 }

 public class B {
     private String color;
     public B(String color) { this.color = color; }
     public String getColor() { return color; }
 }

 public class C {
     private int color;
     public C(int color) { this.color = color; }
     public int getColor() { return color; }
 }
您以某种方式创建自己的实例，并以编程语言将其传递给您的呼叫站点：
  for each(var obj in [new A("red"), new B("green"), new C(0x0000ff)]) {
     print(obj.color);
 }
然后在第一次调用时，Dynalink会将.color getter操作与.color的field getter连接A.color ，在第二次调用时，它将重新链接到B.getColor()返回一个String ，最后在第三次调用时将重新链接到C.getColor()返回一个int 。 我们上面使用的SimpleRelinkableCallSite只记住上次遇到的类型的连接（它实现了所谓的单态内联缓存 ）。 另一个已经提供的实现， ChainedCallSite将记住几种不同类型的链接（它是一个多态内联缓存 ），并且可能是严重应用程序中更好的选择。

动态链接和字节码创建

CallSite对象通常被创建为引导字节码invokedynamic指令的一部分。 因此，Dynalink通常用作将程序编译成Java .class字节码格式的语言运行时的一部分。 Dynalink并不涉及创建字节码类或将其加载到JVM中的方面。 也就是说，Dynalink也可以在没有字节码编译的情况下使用（例如在语言解释器中），通过明确地创建CallSite对象并将它们与解释程序中的动态操作的表示相关联（例如典型的表示法将是语法树中的一些节点对象）。

可用操作

Dynalink在其StandardOperation类中定义了几个标准操作。 用于Java对象的链接器可以链接所有这些操作，并鼓励您至少支持并使用您的语言操作。 标准操作GET和SET需要与至少一个Namespace组合使用，例如表示属性吸气剂，您将使用StandardOperation.GET.withNamespace(StandardNamespace.PROPERTY) 。 Dynalink在StandardNamespace类中定义了三个标准命名空间。 要将固定名称与操作相关联，可以像上例一样使用NamedOperation ： StandardOperation.GET.withNamespace(StandardNamespace.PROPERTY).named("color")表示名为“color”的属性的getter。

多个命名空间的操作

某些语言在属性，元素和方法的对象上可能没有单独的命名空间，源语言结构可能会同时解决其中的几个。 Dynalink支持使用NamespaceOperation指定多个Namespace对象。

语言特定的链接器

定义自己的对象模型不同于基于JVM类的模型和/或使用自己的类型转换的语言将需要创建自己的语言特定的链接器。 请参阅jdk.dynalink.linker软件包，特别是GuardingDynamicLinker接口开始使用。

Dynalink和Java对象

该DynamicLinker由创建的对象DynamicLinkerFactory默认包含的内部实例BeansLinker ，这是一个实现了通常的Java语义上述所有操作，并可以链接，没有其他特定于语言的链接已设法任何Java对象特定于语言的链接链接。 这样，所有语言运行时都具有与普通Java对象的内置互操作性。 有关如何链接各种操作的详细信息，请参阅BeansLinker 。

跨语言互操作性

A DynamicLinkerFactory可配置class loader 。 它将尝试实例化该类加载器可见的所有GuardingDynamicLinkerExporter类，并将其提供的链接组成其创建的DynamicLinker 。 这允许语言之间的互操作性：如果您的JVM中部署了两个语言运行时A和B，并通过上述机制导出其连接器，则语言运行时A将在其DynamicLinker对象中具有来自B的语言特定的链接器实例，反之亦然。 这意味着如果来自语言运行时间B的对象从语言运行时间A传递给代码，则从B接收到的对象时，来自B的链接器将有机会将A中的调用站点链接起来。
Module Graph:
Module graph for jdk.dynalink Module graph for jdk.dynalink
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      jdk.dynalink
      包含用于链接 invokedynamic通话网站的接口和类。
      jdk.dynalink.beans
      包含普通Java对象的链接器。
      jdk.dynalink.linker
      包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
      jdk.dynalink.linker.support
      包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
      jdk.dynalink.support
      包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。

    • Services

      Uses
      Type 描述
      GuardingDynamicLinkerExporter
      A class acting as a supplier of guarding dynamic linkers that can be automatically loaded by other language runtimes.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.dynalink (Java SE 9 & JDK 9 )

jdk.dynalink

Interfaces

  • ConversionComparator
  • GuardedInvocationTransformer
  • GuardingDynamicLinker
  • GuardingTypeConverterFactory
  • LinkerServices
  • LinkRequest
  • MethodHandleTransformer
  • MethodTypeConversionStrategy
  • MissingMemberHandlerFactory
  • Namespace
  • Operation
  • RelinkableCallSite
  • TypeBasedGuardingDynamicLinker

Classes

  • AbstractRelinkableCallSite
  • BeansLinker
  • CallSiteDescriptor
  • ChainedCallSite
  • CompositeGuardingDynamicLinker
  • CompositeTypeBasedGuardingDynamicLinker
  • DefaultInternalObjectFilter
  • DynamicLinker
  • DynamicLinkerFactory
  • GuardedInvocation
  • GuardingDynamicLinkerExporter
  • Guards
  • Lookup
  • NamedOperation
  • NamespaceOperation
  • SecureLookupSupplier
  • SimpleLinkRequest
  • SimpleRelinkableCallSite
  • StaticClass
  • TypeUtilities

Enums

  • ConversionComparator.Comparison
  • StandardNamespace
  • StandardOperation

Exceptions

  • NoSuchDynamicMethodException


jdk.editpad (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.editpad

Provides the implementation of the edit pad service used by jdk.jshell.
Module Graph:
Module graph for jdk.editpad Module graph for jdk.editpad
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.editpad (Java SE 9 & JDK 9 )

jdk.editpad


jdk.hotspot.agent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.hotspot.agent

Defines the implementation of the HotSpot Serviceability Agent.

This module includes the jhsdb tool to attach to a running Java Virtual Machine (JVM) or launch a postmortem debugger to analyze the content of a core-dump from a crashed JVM.

Tool Guides:
jhsdb
Module Graph:
Module graph for jdk.hotspot.agent Module graph for jdk.hotspot.agent
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.hotspot.agent (Java SE 9 & JDK 9 )

jdk.hotspot.agent


jdk.httpserver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.httpserver

定义JDK特定的HTTP服务器API。
Module Graph:
Module graph for jdk.httpserver Module graph for jdk.httpserver
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.net.httpserver
      提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
      com.sun.net.httpserver.spi
      提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。

    • Services

      Uses
      Type 描述
      HttpServerProvider
      HttpServer的服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.httpserver (Java SE 9 & JDK 9 )

jdk.httpserver

Interfaces

  • HttpHandler

Classes

  • Authenticator
  • Authenticator.Failure
  • Authenticator.Result
  • Authenticator.Retry
  • Authenticator.Success
  • BasicAuthenticator
  • Filter
  • Filter.Chain
  • Headers
  • HttpContext
  • HttpExchange
  • HttpPrincipal
  • HttpsConfigurator
  • HttpServer
  • HttpServerProvider
  • HttpsExchange
  • HttpsParameters
  • HttpsServer


jdk.incubator.httpclient (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.incubator.httpclient

定义高级HTTP和WebSocket API。
Incubating Feature.将在以后的版本中删除。
Module Graph:
Module graph for jdk.incubator.httpclient Module graph for jdk.incubator.httpclient
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      jdk.incubator.http
      高级HTTP和WebSocket API
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.incubator.httpclient (Java SE 9 & JDK 9 )

jdk.incubator.httpclient

Interfaces

  • HttpHeaders
  • HttpRequest.BodyProcessor
  • HttpResponse.BodyHandler
  • HttpResponse.BodyProcessor
  • HttpResponse.MultiProcessor
  • WebSocket
  • WebSocket.Builder
  • WebSocket.Listener

Classes

  • HttpClient
  • HttpClient.Builder
  • HttpRequest
  • HttpRequest.Builder
  • HttpResponse
  • MultiMapResult

Enums

  • HttpClient.Redirect
  • HttpClient.Version
  • WebSocket.MessagePart

Exceptions

  • HttpTimeoutException
  • WebSocketHandshakeException


jdk.jartool (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jartool

定义用于操作Java Archive（JAR）文件的工具，包括jar和jarsigner工具。

该模块通过ToolProvider SPI提供了相当于对jar的命令行访问。 可通过致电ToolProvider.findFirst或名称为"jar"的service loader获得该工具的实例。

工具指南：
jar ， jarsigner
Module Graph:
Module graph for jdk.jartool Module graph for jdk.jartool
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.jarsigner
      该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
      jdk.security.jarsigner
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jartool (Java SE 9 & JDK 9 )

jdk.jartool

Interfaces

  • ContentSignerParameters

Classes

  • ContentSigner
  • JarSigner
  • JarSigner.Builder

Exceptions

  • JarSignerException


jdk.javadoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.javadoc

定义system documentation tool及其命令行等效的实现， javadoc 。

的javadoc

该模块通过ToolProvider和Tool服务提供商接口（SPI）提供对javadoc的命令行访问等效，并通过DocumentationTool SPI更灵活地访问。

可通过致电ToolProvider.findFirst或名称为"javadoc"的service loader获取工具实例。

工具指南：
javadoc
Module Graph:
Module graph for jdk.javadoc Module graph for jdk.javadoc
从以下版本开始：
9
另请参见：
Documentation Comment Specification for the Standard Doclet

    • Packages

      Exports
      软件包 描述
      com.sun.javadoc
      注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
      com.sun.tools.doclets
      注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
      com.sun.tools.doclets.standard
      注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
      com.sun.tools.javadoc
      此软件包及其内容已被弃用，可能会在将来的版本中删除。
      jdk.javadoc.doclet
      Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
      Indirect Exports
      From Packages
      java.compiler javax.annotation.processing javax.lang.model javax.lang.model.element javax.lang.model.type javax.lang.model.util javax.tools
      jdk.compiler com.sun.source.doctree com.sun.source.tree com.sun.source.util com.sun.tools.javac

    • Modules

      Requires
      Modifier Module 描述
      transitive java.compiler
      定义语言模型，注释处理和Java编译器API。
      transitive jdk.compiler
      定义了 system Java compiler及其命令行等效的实现， javac以及 javah 。

    • Services

      Provides
      Type 描述
      DocumentationTool
      从程序中调用Java编程语言文档工具的接口。
      Tool
      可以从程序调用的工具的通用界面。
      ToolProvider
      一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.javadoc (Java SE 9 & JDK 9 )

jdk.javadoc

Interfaces

  • AnnotatedType
  • AnnotationDesc
  • AnnotationDesc.ElementValuePair
  • AnnotationTypeDoc
  • AnnotationTypeElementDoc
  • AnnotationValue
  • ClassDoc
  • ConstructorDoc
  • Doc
  • DocErrorReporter
  • Doclet
  • Doclet.Option
  • DocletEnvironment
  • ExecutableMemberDoc
  • FieldDoc
  • MemberDoc
  • MethodDoc
  • PackageDoc
  • Parameter
  • ParameterizedType
  • ParamTag
  • ProgramElementDoc
  • Reporter
  • RootDoc
  • SeeTag
  • SerialFieldTag
  • SourcePosition
  • Tag
  • Taglet
  • Taglet
  • ThrowsTag
  • Type
  • TypeVariable
  • WildcardType

Classes

  • Doclet
  • Main
  • Standard
  • StandardDoclet

Enums

  • Doclet.Option.Kind
  • DocletEnvironment.ModuleMode
  • LanguageVersion
  • Taglet.Location


jdk.jcmd (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jcmd

Defines tools for diagnostics and troubleshooting a JVM such as the jcmd, jps, jstat tools.
Tool Guides:
jcmd, jinfo, jmap, jps, jstack, jstat
Module Graph:
Module graph for jdk.jcmd Module graph for jdk.jcmd
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jcmd (Java SE 9 & JDK 9 )

jdk.jcmd


jdk.jconsole (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jconsole

定义JMX图形工具， jconsole ，用于监视和管理正在运行的应用程序。
工具指南：
jconsole ， Using JConsole
Module Graph:
Module graph for jdk.jconsole Module graph for jdk.jconsole
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.tools.jconsole
      此程序包包含JConsole API。
      Indirect Exports
      From Packages
      java.datatransfer java.awt.datatransfer
      java.desktop java.applet java.awt java.awt.color java.awt.desktop java.awt.dnd java.awt.event java.awt.font java.awt.geom java.awt.im java.awt.im.spi java.awt.image java.awt.image.renderable java.awt.print java.beans java.beans.beancontext javax.accessibility javax.imageio javax.imageio.event javax.imageio.metadata javax.imageio.plugins.bmp javax.imageio.plugins.jpeg javax.imageio.plugins.tiff javax.imageio.spi javax.imageio.stream javax.print javax.print.attribute javax.print.attribute.standard javax.print.event javax.sound.midi javax.sound.midi.spi javax.sound.sampled javax.sound.sampled.spi javax.swing javax.swing.border javax.swing.colorchooser javax.swing.event javax.swing.filechooser javax.swing.plaf javax.swing.plaf.basic javax.swing.plaf.metal javax.swing.plaf.multi javax.swing.plaf.nimbus javax.swing.plaf.synth javax.swing.table javax.swing.text javax.swing.text.html javax.swing.text.html.parser javax.swing.text.rtf javax.swing.tree javax.swing.undo
      java.management java.lang.management javax.management javax.management.loading javax.management.modelmbean javax.management.monitor javax.management.openmbean javax.management.relation javax.management.remote javax.management.timer
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.desktop
      定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
      transitive java.management
      定义Java管理扩展（JMX）API。
      Indirect Requires
      Modifier Module 描述
      transitive java.datatransfer
      定义用于在应用程序之间和之间传输数据的API。
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。

    • Services

      Uses
      Type 描述
      JConsolePlugin
      A JConsole plugin class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jconsole (Java SE 9 & JDK 9 )

jdk.jconsole

Interfaces

  • JConsoleContext

Classes

  • JConsolePlugin

Enums

  • JConsoleContext.ConnectionState


jdk.jdeps (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jdeps

定义用于分析Java库和程序，包括依赖工具jdeps ， javap ，并jdeprscan工具。

该模块通过ToolProvider服务提供程序接口（SPI）提供对javap和jdeps工具的命令行访问权限，

可以通过调用ToolProvider.findFirst或service loader （名称为"javap"或"jdeps"获取工具的实例。

jdeprscan仅作为命令行工具存在，并且不提供任何直接的API。

工具指南：
javap ， jdeprscan ， jdeps
Module Graph:
Module graph for jdk.jdeps Module graph for jdk.jdeps
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      ToolProvider
      一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jdeps (Java SE 9 & JDK 9 )

jdk.jdeps


jdk.jdi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jdi

定义Java调试接口。

Java调试接口（JDI）是一种高级别的Java API，它为调试器和需要访问（通常为远程）虚拟机的运行状态的类似系统提供有用的信息。

JDI提供对运行的虚拟机的状态，类，数组，接口和原始类型以及这些类型的实例的内省访问。

JDI还提供对虚拟机执行的显式控制。 能够暂停和恢复线程，并设置断点，观察点等异常，类加载，线程创建等的通知检查挂起的线程的状态，局部变量，堆栈回溯等的能力

JDI是Java Platform Debugger Architecture (JPDA)的最高层 。

该模块包括一个简单的命令行调试器， jdb 。

全球例外

本节记录适用于整个API的异常，因此不会在单个方法上记录。

VMMismatchException

Any method on a Mirror that takes a Mirror as an parameter directly or indirectly (e.g., as a element in a List) will throw VMMismatchException if the mirrors are from different virtual machines.

NullPointerException

Any method which takes a Object as an parameter will throw NullPointerException if null is passed directly or indirectly -- unless null is explicitly mentioned as a valid parameter.

注意：当满足指定的条件时，可能会抛出以下异常，但是仅当无法返回有效结果时才能保证它们被抛出。

VMDisconnectedException

Any method on ObjectReference, ReferenceType, EventRequest, StackFrame, or VirtualMachine or which takes one of these directly or indirectly as an parameter may throw VMDisconnectedException if the target VM is disconnected and the VMDisconnectEvent has been or is available to be read from the EventQueue.

VMOutOfMemoryException

Any method on ObjectReference, ReferenceType, EventRequest, StackFrame, or VirtualMachine or which takes one of these directly or indirectly as an parameter may throw VMOutOfMemoryException if the target VM has run out of memory.

ObjectCollectedException

Any method on ObjectReference or which directly or indirectly takes ObjectReference as parameter may throw ObjectCollectedException if the mirrored object has been garbage collected.

Any method on ReferenceType or which directly or indirectly takes ReferenceType as parameter may throw ObjectCollectedException if the mirrored type has been unloaded.

工具指南：
jdb
Module Graph:
Module graph for jdk.jdi Module graph for jdk.jdi
从以下版本开始：
9
另请参见：
Java Platform Debugger Architecture (JPDA)

    • Packages

      Exports
      软件包 描述
      com.sun.jdi
      这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
      com.sun.jdi.connect
      该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
      com.sun.jdi.connect.spi
      该包包括用于开发新的TransportService实现的接口和类。
      com.sun.jdi.event
      该包定义了JDI事件和事件处理。
      com.sun.jdi.request
      该包用于请求在指定条件下发送JDI事件。

    • Services

      Provides
      Type 描述
      Connector
      调试器和目标VM之间的连接方法。
      Uses
      Type 描述
      Connector
      调试器和目标VM之间的连接方法。
      TransportService
      用于调试器和目标VM之间连接的传输服务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jdi (Java SE 9 & JDK 9 )

jdk.jdi

Interfaces

  • Accessible
  • AccessWatchpointEvent
  • AccessWatchpointRequest
  • ArrayReference
  • ArrayType
  • AttachingConnector
  • BooleanType
  • BooleanValue
  • BreakpointEvent
  • BreakpointRequest
  • ByteType
  • ByteValue
  • CharType
  • CharValue
  • ClassLoaderReference
  • ClassObjectReference
  • ClassPrepareEvent
  • ClassPrepareRequest
  • ClassType
  • ClassUnloadEvent
  • ClassUnloadRequest
  • Connector
  • Connector.Argument
  • Connector.BooleanArgument
  • Connector.IntegerArgument
  • Connector.SelectedArgument
  • Connector.StringArgument
  • DoubleType
  • DoubleValue
  • Event
  • EventIterator
  • EventQueue
  • EventRequest
  • EventRequestManager
  • EventSet
  • ExceptionEvent
  • ExceptionRequest
  • Field
  • FloatType
  • FloatValue
  • IntegerType
  • IntegerValue
  • InterfaceType
  • LaunchingConnector
  • ListeningConnector
  • LocalVariable
  • Locatable
  • LocatableEvent
  • Location
  • LongType
  • LongValue
  • 方法
  • MethodEntryEvent
  • MethodEntryRequest
  • MethodExitEvent
  • MethodExitRequest
  • Mirror
  • ModificationWatchpointEvent
  • ModificationWatchpointRequest
  • ModuleReference
  • MonitorContendedEnteredEvent
  • MonitorContendedEnteredRequest
  • MonitorContendedEnterEvent
  • MonitorContendedEnterRequest
  • MonitorInfo
  • MonitorWaitedEvent
  • MonitorWaitedRequest
  • MonitorWaitEvent
  • MonitorWaitRequest
  • ObjectReference
  • PathSearchingVirtualMachine
  • PrimitiveType
  • PrimitiveValue
  • ReferenceType
  • ShortType
  • ShortValue
  • StackFrame
  • StepEvent
  • StepRequest
  • StringReference
  • ThreadDeathEvent
  • ThreadDeathRequest
  • ThreadGroupReference
  • ThreadReference
  • ThreadStartEvent
  • ThreadStartRequest
  • Transport
  • Type
  • TypeComponent
  • Value
  • VirtualMachine
  • VirtualMachineManager
  • VMDeathEvent
  • VMDeathRequest
  • VMDisconnectEvent
  • VMStartEvent
  • VoidType
  • VoidValue
  • WatchpointEvent
  • WatchpointRequest

Classes

  • Bootstrap
  • Connection
  • JDIPermission
  • TransportService
  • TransportService.Capabilities
  • TransportService.ListenKey

Exceptions

  • AbsentInformationException
  • ClassNotLoadedException
  • ClassNotPreparedException
  • ClosedConnectionException
  • DuplicateRequestException
  • IllegalConnectorArgumentsException
  • IncompatibleThreadStateException
  • InconsistentDebugInfoException
  • InternalException
  • InvalidCodeIndexException
  • InvalidLineNumberException
  • InvalidModuleException
  • InvalidRequestStateException
  • InvalidStackFrameException
  • InvalidTypeException
  • InvocationException
  • NativeMethodException
  • ObjectCollectedException
  • TransportTimeoutException
  • VMCannotBeModifiedException
  • VMDisconnectedException
  • VMMismatchException
  • VMOutOfMemoryException
  • VMStartException


jdk.jdwp.agent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jdwp.agent

Provides the implementation of the Java Debug Wire Protocol (JDWP) agent.
Module Graph:
Module graph for jdk.jdwp.agent Module graph for jdk.jdwp.agent
从以下版本开始：
9
另请参见：
JDWP Specification, JDWP Transport Specification
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jdwp.agent (Java SE 9 & JDK 9 )

jdk.jdwp.agent


jdk.jlink (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jlink

定义jlink创建运行时图像，工具jmod工具，用于创建和操纵JMOD文件，以及jimage工具用于检查类和资源的JDK实现特定的容器文件。

该模块通过ToolProvider SPI提供对jlink和jmod工具的命令行访问。 可以通过调用ToolProvider.findFirst或service loader （名称为"jlink"或"jmod"获取工具实例。

jimage仅作为命令行工具存在，不提供任何直接的API。

工具指南：
jlink ， jmod ， jimage
Module Graph:
Module graph for jdk.jlink Module graph for jdk.jlink
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      ToolProvider
      一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jlink (Java SE 9 & JDK 9 )

jdk.jlink


jdk.jshell (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jshell

该模块提供对Java编程语言“片段”评估工具的支持，如读取评估打印循环（REPL），包括jshell工具。 单独的软件包支持构建工具，配置工具的执行，并以编程方式启动现有的Java Shell工具。

jdk.jshell是用于创建“代码段”评估工具的软件包。 通常，这只是创建工具所需的软件包。

jdk.jshell.spi包指定了基于jdk.jshell API的工具定义执行引擎实现的服务提供程序接口（SPI）。 jdk.jshell.execution包提供了jdk.jshell.spi接口和支持代码的标准实现。 它还用作定义新的执行引擎实现的功能库。

jdk.jshell.tool软件包支持以编程方式启动jshell工具。

jdk.jshell.execution包包含jdk.jshell.spi中的接口的实现 。 否则，这四个软件包是独立的，操作在不同的级别，不共享功能或定义。

工具指南：
jshell
Module Graph:
Module graph for jdk.jshell Module graph for jdk.jshell
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      jdk.jshell
      提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
      jdk.jshell.execution
      提供构建JShell执行引擎的实现支持。
      jdk.jshell.spi
      定义可插拔JShell执行引擎的服务提供程序接口。
      jdk.jshell.tool
      提供一种启动Javaâ壳工具实例的机制。
      Indirect Exports
      From Packages
      java.compiler javax.annotation.processing javax.lang.model javax.lang.model.element javax.lang.model.type javax.lang.model.util javax.tools
      java.prefs java.util.prefs
      jdk.jdi com.sun.jdi com.sun.jdi.connect com.sun.jdi.connect.spi com.sun.jdi.event com.sun.jdi.request

    • Modules

      Requires
      Modifier Module 描述
      transitive java.compiler
      定义语言模型，注释处理和Java编译器API。
      transitive java.prefs
      定义首选项API。
      transitive jdk.jdi
      定义Java调试接口。

    • Services

      Provides
      Type 描述
      ExecutionControlProvider
      JShell使用的提供程序来生成评估代码段所需的执行引擎。
      Tool
      可以从程序调用的工具的通用界面。
      Uses
      Type 描述
      ExecutionControlProvider
      JShell使用的提供程序来生成评估代码段所需的执行引擎。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jshell (Java SE 9 & JDK 9 )

jdk.jshell

Interfaces

  • ExecutionControl
  • ExecutionControlProvider
  • ExecutionEnv
  • JavaShellToolBuilder
  • LoaderDelegate
  • SourceCodeAnalysis.CompletionInfo
  • SourceCodeAnalysis.Documentation
  • SourceCodeAnalysis.SnippetWrapper
  • SourceCodeAnalysis.Suggestion

Classes

  • DeclarationSnippet
  • Diag
  • DirectExecutionControl
  • ErroneousSnippet
  • ExecutionControl.ClassBytecodes
  • ExpressionSnippet
  • FailOverExecutionControlProvider
  • ImportSnippet
  • JdiDefaultExecutionControl
  • JdiExecutionControl
  • JdiExecutionControlProvider
  • JdiInitiator
  • JShell
  • JShell.Builder
  • LocalExecutionControl
  • LocalExecutionControlProvider
  • MethodSnippet
  • PersistentSnippet
  • RemoteExecutionControl
  • Snippet
  • SnippetEvent
  • SourceCodeAnalysis
  • SourceCodeAnalysis.QualifiedNames
  • StatementSnippet
  • StreamingExecutionControl
  • TypeDeclSnippet
  • Util
  • VarSnippet

Enums

  • Snippet.Kind
  • Snippet.Status
  • Snippet.SubKind
  • SourceCodeAnalysis.Completeness

Exceptions

  • EvalException
  • ExecutionControl.ClassInstallException
  • ExecutionControl.EngineTerminationException
  • ExecutionControl.ExecutionControlException
  • ExecutionControl.InternalException
  • ExecutionControl.NotImplementedException
  • ExecutionControl.ResolutionException
  • ExecutionControl.RunException
  • ExecutionControl.StoppedException
  • ExecutionControl.UserException
  • JShellException
  • SPIResolutionException
  • UnresolvedReferenceException


jdk.jsobject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jsobject

定义JavaScript对象的API。
Module Graph:
Module graph for jdk.jsobject Module graph for jdk.jsobject
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      netscape.javascript
      使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jsobject (Java SE 9 & JDK 9 )

jdk.jsobject

Classes

  • JSObject

Exceptions

  • JSException


jdk.jstatd (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.jstatd

Defines the jstatd tool for starting a daemon for the jstat tool to monitor JVM statistics remotely.
Tool Guides:
jstatd
Module Graph:
Module graph for jdk.jstatd Module graph for jdk.jstatd
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.jstatd (Java SE 9 & JDK 9 )

jdk.jstatd


jdk.localedata (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.localedata

Provides the locale data for locales other than US locale.
Module Graph:
Module graph for jdk.localedata Module graph for jdk.localedata
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.localedata (Java SE 9 & JDK 9 )

jdk.localedata


jdk.management (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.management

为JVM定义JDK特定的管理界面。
Module Graph:
Module graph for jdk.management Module graph for jdk.management
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.management
      该包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
      Indirect Exports
      From Packages
      java.management java.lang.management javax.management javax.management.loading javax.management.modelmbean javax.management.monitor javax.management.openmbean javax.management.relation javax.management.remote javax.management.timer

    • Modules

      Requires
      Modifier Module 描述
      transitive java.management
      定义Java管理扩展（JMX）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.management (Java SE 9 & JDK 9 )

jdk.management

Interfaces

  • DiagnosticCommandMBean
  • GarbageCollectorMXBean
  • HotSpotDiagnosticMXBean
  • OperatingSystemMXBean
  • ThreadMXBean
  • UnixOperatingSystemMXBean

Classes

  • GarbageCollectionNotificationInfo
  • GcInfo
  • VMOption

Enums

  • VMOption.Origin


jdk.management.agent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.management.agent

Defines the JMX management agent.

This module allows a Java Virtual Machine to be monitored and managed via JMX API. See more information from the Monitoring and Management Using JMX guide.

Module Graph:
Module graph for jdk.management.agent Module graph for jdk.management.agent
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.management.agent (Java SE 9 & JDK 9 )

jdk.management.agent


jdk.naming.dns (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.naming.dns

提供DNS Java命名提供程序的实现。
Module Graph:
Module graph for jdk.naming.dns Module graph for jdk.naming.dns
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      InitialContextFactory
      此接口表示创建初始上下文的工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.naming.dns (Java SE 9 & JDK 9 )

jdk.naming.dns


jdk.naming.rmi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.naming.rmi

提供RMI Java命名提供程序的实现。
Module Graph:
Module graph for jdk.naming.rmi Module graph for jdk.naming.rmi
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      InitialContextFactory
      此接口表示创建初始上下文的工厂。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.naming.rmi (Java SE 9 & JDK 9 )

jdk.naming.rmi


jdk.net (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.net

定义JDK特定的网络API。
Module Graph:
Module graph for jdk.net Module graph for jdk.net
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      jdk.net
      适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.net (Java SE 9 & JDK 9 )

jdk.net

Classes

  • ExtendedSocketOptions
  • NetworkPermission
  • SocketFlow
  • Sockets

Enums

  • SocketFlow.Status


jdk.pack (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.pack

Defines tools for transforming a JAR file into a compressed pack200 file and transforming a packed file into a JAR file, including the pack200 and unpack200 tools.
Tool Guides:
pack200, unpack200
Module Graph:
Module graph for jdk.pack Module graph for jdk.pack
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.pack (Java SE 9 & JDK 9 )

jdk.pack


jdk.packager.services (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.packager.services

定义Java Packager工具使用的服务。
Module Graph:
Module graph for jdk.packager.services Module graph for jdk.packager.services
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      jdk.packager.services
      定义Java Packager工具使用的服务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.packager.services (Java SE 9 & JDK 9 )

jdk.packager.services

Interfaces

  • UserJvmOptionsService


jdk.policytool (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

@Deprecated(since="9", forRemoval=true)

Module jdk.policytool

Deprecated, for removal: This API element is subject to removal in a future version.
Defines the GUI tool for managing policy files called policytool.
Tool Guides:
policytool
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.policytool (Java SE 9 & JDK 9 )

jdk.policytool


jdk.rmic (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.rmic

Defines the rmic compiler for generating stubs and skeletons using the Java Remote Method Protocol (JRMP) and stubs and tie class files (IIOP protocol) for remote objects.
Tool Guides:
rmic
Module Graph:
Module graph for jdk.rmic Module graph for jdk.rmic
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.rmic (Java SE 9 & JDK 9 )

jdk.rmic


jdk.scripting.nashorn (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.scripting.nashorn

提供Nashorn脚本引擎的实现和用ECMAScript 5.1编写的程序的运行时环境。

Nashorn是用ECMAScript 5.1编写的程序的运行时环境。

用法

推荐使用Nashorn的方法是通过javax.script包中的JSR-223 "Scripting for the Java Platform" API。 通常，您将获得一个ScriptEngine的实例，用于Nashorn：
  import javax.script.*;
...
ScriptEngine nashornEngine = new ScriptEngineManager().getEngineByName("nashorn");
然后像其他JSR-223脚本引擎一样使用它。 有关详细信息，请参阅jdk.nashorn.api.scripting包。

兼容性

Nashorn 100％符合ECMA-262 Standard, Edition 5.1 。 它需要一个实现JSR-292 "Supporting Dynamically Typed Languages on the Java Platform"规范的Java虚拟机（通常被称为“invokedynamic”）以及已经提到的JSR-223。

与Java平台的互操作性

除了作为100％的ECMAScript 5.1运行时，Nashorn还提供了ECMAScript程序与Java平台的互操作性。 通常，脚本中可以看到放入脚本引擎上下文的任何Java对象。 在标准方面，这样的Java对象不被认为是“本地对象”，而是“4.3”中定义的“主机对象”。 与本地对象相比，这种区别允许处理它们时的某些语义上的差异。 对于大多数目的，Java对象的行为就像本地对象一样：您可以调用其方法，获取和设置其属性。 在大多数情况下，您不能向其添加任意属性，也不能删除现有属性。

Java集合处理

本地Java数组和List支持通过属性访问器对其元素进行索引访问，而Map通过点和方括号属性访问器支持属性和元素访问，区别在于点操作符优先于对象属性（其字段和属性定义为getXxx和setXxx方法），而方括号操作符优先于映射元素。 Native Java数组暴露length属性。

ECMAScript原始类型

ECMAScript的原始类型为数字，字符串，和布尔被表示与Number ， CharSequence ，和Boolean对象。 虽然最常用的号码类型为Double和最经常使用的字符串类型为String ，不依赖于它作为各种内部优化造成的其他子类Number及内部实现CharSequence使用。

输入转换

当调用Java对象上的方法时，使用所有允许的ECMAScript转换将参数转换为Java方法的形式参数类型。 这可能是令人惊讶的，因为一般来说，从字符串到数字的转换将根据标准的第9.3节“ToNumber”等进行成功; string to boolean，number to boolean，Object to number，Object to string all work。 请注意，如果Java方法声明的参数类型为java.lang.Object ，那么Nashorn对象就不会转换任何转换; 具体来说，如果传递的JavaScript值是原始字符串类型，那么您只能依靠它作为一个java.lang.CharSequence ，如果该值是一个数字，那么您只能依靠它作为一个java.lang.Number 。 如果Java方法声明的参数类型更具体（例如java.lang.String或java.lang.Double ），那么Nashorn当然会确保所需的类型被传递。

SAM类型

作为调用Java方法时的特殊扩展，ECMAScript函数对象可以被传递代替其Java类型是所谓的“单抽象方法”或“SAM”类型的参数。 虽然这个名字通常包含单一方法的接口，但是Nashorn的功能更为多样，如果所有的抽象方法都是同名的重载，那么它就会被识别为一个SAM类型，它是一个接口，也可以是一个抽象类与无arg构造函数。 类型本身必须是public的，而构造函数和方法可以是public或protected。 如果同一个名称有多个抽象重载，则单个函数将作为所有这些重用的共享实现， 并且还将覆盖相同名称的任何非抽象方法 。 这样做与ECMAScript不具有重载方法的概念相一致。

Java对象

Nashorn公开了一个名为Java的非标准全局对象，它是将Java平台特定功能的主要API入口点。 您可以使用它创建Java类的实例，从Java数组转换为本地数组并返回等等。

其他非标内置对象

除了Java ，犀牛也暴露了一些其他非标准内置对象： JSAdapter ， JavaImporter ， Packages
Module Graph:
Module graph for jdk.scripting.nashorn Module graph for jdk.scripting.nashorn
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      jdk.nashorn.api.scripting
      这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
      jdk.nashorn.api.tree
      Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
      Indirect Exports
      From Packages
      java.scripting javax.script

    • Modules

      Requires
      Modifier Module 描述
      transitive java.scripting
      定义脚本API。

    • Services

      Provides
      Type 描述
      ScriptEngineFactory
      ScriptEngineFactory用于描述和实例化 ScriptEngines 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.scripting.nashorn (Java SE 9 & JDK 9 )

jdk.scripting.nashorn

Interfaces

  • ArrayAccessTree
  • ArrayLiteralTree
  • AssignmentTree
  • BinaryTree
  • BlockTree
  • BreakTree
  • CaseTree
  • CatchTree
  • ClassDeclarationTree
  • ClassExpressionTree
  • ClassFilter
  • CompilationUnitTree
  • CompoundAssignmentTree
  • ConditionalExpressionTree
  • ConditionalLoopTree
  • ContinueTree
  • DebuggerTree
  • Diagnostic
  • DiagnosticListener
  • DoWhileLoopTree
  • EmptyStatementTree
  • ErroneousTree
  • ExportEntryTree
  • ExpressionStatementTree
  • ExpressionTree
  • ForInLoopTree
  • ForLoopTree
  • ForOfLoopTree
  • FunctionCallTree
  • FunctionDeclarationTree
  • FunctionExpressionTree
  • GotoTree
  • IdentifierTree
  • IfTree
  • ImportEntryTree
  • InstanceOfTree
  • JSObject
  • LabeledStatementTree
  • LineMap
  • LiteralTree
  • LoopTree
  • MemberSelectTree
  • ModuleTree
  • NewTree
  • ObjectLiteralTree
  • ParenthesizedTree
  • Parser
  • PropertyTree
  • RegExpLiteralTree
  • ReturnTree
  • SpreadTree
  • StatementTree
  • SwitchTree
  • TemplateLiteralTree
  • ThrowTree
  • 树
  • TreeVisitor
  • TryTree
  • UnaryTree
  • VariableTree
  • WhileLoopTree
  • WithTree
  • YieldTree

Classes

  • AbstractJSObject
  • NashornScriptEngine
  • NashornScriptEngineFactory
  • ScriptObjectMirror
  • ScriptUtils
  • SimpleTreeVisitorES5_1
  • SimpleTreeVisitorES6
  • URLReader

Enums

  • Diagnostic.Kind
  • Tree.Kind

Exceptions

  • NashornException
  • UnknownTreeException


jdk.sctp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.sctp

定义用于SCTP的JDK特定API。
Module Graph:
Module graph for jdk.sctp Module graph for jdk.sctp
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.nio.sctp
      用于流控制传输协议的Java API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.sctp (Java SE 9 & JDK 9 )

jdk.sctp

Interfaces

  • Notification
  • NotificationHandler
  • SctpSocketOption

Classes

  • AbstractNotificationHandler
  • Association
  • AssociationChangeNotification
  • MessageInfo
  • PeerAddressChangeNotification
  • SctpChannel
  • SctpMultiChannel
  • SctpServerChannel
  • SctpStandardSocketOptions
  • SctpStandardSocketOptions.InitMaxStreams
  • SendFailedNotification
  • ShutdownNotification

Enums

  • AssociationChangeNotification.AssocChangeEvent
  • HandlerResult
  • PeerAddressChangeNotification.AddressChangeEvent

Exceptions

  • IllegalReceiveException
  • IllegalUnbindException
  • InvalidStreamException


jdk.security.auth (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.security.auth

提供 javax.security.auth.*接口和各种认证模块的实现。
Module Graph:
Module graph for jdk.security.auth Module graph for jdk.security.auth
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.security.auth
      提供Principal的实现。
      com.sun.security.auth.callback
      提供CallbackHandler的实现。
      com.sun.security.auth.login
      提供Configuration的实现。
      com.sun.security.auth.module
      提供LoginModule的实现。
      Indirect Exports
      From Packages
      java.naming javax.naming javax.naming.directory javax.naming.event javax.naming.ldap javax.naming.spi

    • Modules

      Requires
      Modifier Module 描述
      transitive java.naming
      定义Java命名和目录接口（JNDI）API。

    • Services

      Provides
      Type 描述
      LoginModule
      Service-provider interface for authentication technology providers.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.security.auth (Java SE 9 & JDK 9 )

jdk.security.auth

Interfaces

  • PrincipalComparator

Classes

  • ConfigFile
  • JndiLoginModule
  • KeyStoreLoginModule
  • Krb5LoginModule
  • LdapLoginModule
  • LdapPrincipal
  • NTDomainPrincipal
  • NTLoginModule
  • NTNumericCredential
  • NTSid
  • NTSidDomainPrincipal
  • NTSidGroupPrincipal
  • NTSidPrimaryGroupPrincipal
  • NTSidUserPrincipal
  • NTSystem
  • NTUserPrincipal
  • PolicyFile
  • SolarisLoginModule
  • SolarisNumericGroupPrincipal
  • SolarisNumericUserPrincipal
  • SolarisPrincipal
  • SolarisSystem
  • TextCallbackHandler
  • UnixLoginModule
  • UnixNumericGroupPrincipal
  • UnixNumericUserPrincipal
  • UnixPrincipal
  • UnixSystem
  • UserPrincipal
  • X500Principal


jdk.security.jgss (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.security.jgss

定义GSS-API的Java扩展和SASL GSSAPI机制的实现。
Module Graph:
Module graph for jdk.security.jgss Module graph for jdk.security.jgss
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      com.sun.security.jgss
      Indirect Exports
      From Packages
      java.security.jgss javax.security.auth.kerberos org.ietf.jgss

    • Modules

      Requires
      Modifier Module 描述
      transitive java.security.jgss
      定义IETF通用安全服务API（GSS-API）的Java绑定。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.security.jgss (Java SE 9 & JDK 9 )

jdk.security.jgss

Interfaces

  • ExtendedGSSContext
  • ExtendedGSSCredential

Classes

  • AuthorizationDataEntry
  • GSSUtil
  • InquireSecContextPermission

Enums

  • InquireType


jdk.snmp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.snmp

Defines the SNMP management agent.

This module allows a Java Virtual Machine to be monitored and managed via SNMP. See more information from the SNMP Monitoring and Management guide.

Module Graph:
Module graph for jdk.snmp Module graph for jdk.snmp
从以下版本开始：
9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.snmp (Java SE 9 & JDK 9 )

jdk.snmp


jdk.xml.dom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.xml.dom

定义不属于Java SE API的W3C文档对象模型（DOM）API的子集。
Module Graph:
Module graph for jdk.xml.dom Module graph for jdk.xml.dom
从以下版本开始：
9

    • Packages

      Exports
      软件包 描述
      org.w3c.dom.css
      提供DOM Level 2 Style Specification的界面。
      org.w3c.dom.html
      提供DOM Level 2 HTML规范的接口。
      org.w3c.dom.stylesheets
      提供DOM Level 2 Style Specification的界面。
      org.w3c.dom.xpath
      提供DOM Level 3 XPath规范的接口。
      Indirect Exports
      From Packages
      java.xml javax.xml javax.xml.catalog javax.xml.datatype javax.xml.namespace javax.xml.parsers javax.xml.stream javax.xml.stream.events javax.xml.stream.util javax.xml.transform javax.xml.transform.dom javax.xml.transform.sax javax.xml.transform.stax javax.xml.transform.stream javax.xml.validation javax.xml.xpath org.w3c.dom org.w3c.dom.bootstrap org.w3c.dom.events org.w3c.dom.ls org.w3c.dom.ranges org.w3c.dom.traversal org.w3c.dom.views org.xml.sax org.xml.sax.ext org.xml.sax.helpers

    • Modules

      Requires
      Modifier Module 描述
      transitive java.xml
      定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.xml.dom (Java SE 9 & JDK 9 )

jdk.xml.dom

Interfaces

  • Counter
  • CSS2Properties
  • CSSCharsetRule
  • CSSFontFaceRule
  • CSSImportRule
  • CSSMediaRule
  • CSSPageRule
  • CSSPrimitiveValue
  • CSSRule
  • CSSRuleList
  • CSSStyleDeclaration
  • CSSStyleRule
  • CSSStyleSheet
  • CSSUnknownRule
  • CSSValue
  • CSSValueList
  • DocumentCSS
  • DocumentStyle
  • DOMImplementationCSS
  • ElementCSSInlineStyle
  • HTMLAnchorElement
  • HTMLAppletElement
  • HTMLAreaElement
  • HTMLBaseElement
  • HTMLBaseFontElement
  • HTMLBodyElement
  • HTMLBRElement
  • HTMLButtonElement
  • HTMLCollection
  • HTMLDirectoryElement
  • HTMLDivElement
  • HTMLDListElement
  • HTMLDocument
  • HTMLDOMImplementation
  • HTMLElement
  • HTMLFieldSetElement
  • HTMLFontElement
  • HTMLFormElement
  • HTMLFrameElement
  • HTMLFrameSetElement
  • HTMLHeadElement
  • HTMLHeadingElement
  • HTMLHRElement
  • HTMLHtmlElement
  • HTMLIFrameElement
  • HTMLImageElement
  • HTMLInputElement
  • HTMLIsIndexElement
  • HTMLLabelElement
  • HTMLLegendElement
  • HTMLLIElement
  • HTMLLinkElement
  • HTMLMapElement
  • HTMLMenuElement
  • HTMLMetaElement
  • HTMLModElement
  • HTMLObjectElement
  • HTMLOListElement
  • HTMLOptGroupElement
  • HTMLOptionElement
  • HTMLParagraphElement
  • HTMLParamElement
  • HTMLPreElement
  • HTMLQuoteElement
  • HTMLScriptElement
  • HTMLSelectElement
  • HTMLStyleElement
  • HTMLTableCaptionElement
  • HTMLTableCellElement
  • HTMLTableColElement
  • HTMLTableElement
  • HTMLTableRowElement
  • HTMLTableSectionElement
  • HTMLTextAreaElement
  • HTMLTitleElement
  • HTMLUListElement
  • LinkStyle
  • MediaList
  • Rect
  • RGBColor
  • StyleSheet
  • StyleSheetList
  • ViewCSS
  • XPathEvaluator
  • XPathExpression
  • XPathNamespace
  • XPathNSResolver
  • XPathResult

Exceptions

  • XPathException


jdk.zipfs (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • Module:
  • 描述 | Modules | Packages | Services

Module jdk.zipfs

提供zip文件系统提供程序的实现。

zip文件系统提供程序将zip或JAR文件视为文件系统，并提供操作文件内容的功能。 如果安装了zip文件系统提供程序，可以通过FileSystems.newFileSystem创建。

Module Graph:
Module graph for jdk.zipfs Module graph for jdk.zipfs
从以下版本开始：
9

    • Services

      Provides
      Type 描述
      FileSystemProvider
      文件系统的服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Module
  • Next Module
  • 框架
  • 无框架
  • 所有类
  • Module:
  • 描述 | Modules | Packages | Services

Report a bug or suggest an enhancement


jdk.zipfs (Java SE 9 & JDK 9 )

jdk.zipfs


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.activation Packages

  • javax.activation


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.base Packages

  • java.io
  • java.lang
  • java.lang.annotation
  • java.lang.invoke
  • java.lang.module
  • java.lang.ref
  • java.lang.reflect
  • java.math
  • java.net
  • java.net.spi
  • java.nio
  • java.nio.channels
  • java.nio.channels.spi
  • java.nio.charset
  • java.nio.charset.spi
  • java.nio.file
  • java.nio.file.attribute
  • java.nio.file.spi
  • java.security
  • java.security.acl
  • java.security.cert
  • java.security.interfaces
  • java.security.spec
  • java.text
  • java.text.spi
  • java.time
  • java.time.chrono
  • java.time.format
  • java.time.temporal
  • java.time.zone
  • java.util
  • java.util.concurrent
  • java.util.concurrent.atomic
  • java.util.concurrent.locks
  • java.util.function
  • java.util.jar
  • java.util.regex
  • java.util.spi
  • java.util.stream
  • java.util.zip
  • javax.crypto
  • javax.crypto.interfaces
  • javax.crypto.spec
  • javax.net
  • javax.net.ssl
  • javax.security.auth
  • javax.security.auth.callback
  • javax.security.auth.login
  • javax.security.auth.spi
  • javax.security.auth.x500
  • javax.security.cert


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.compiler Packages

  • javax.annotation.processing
  • javax.lang.model
  • javax.lang.model.element
  • javax.lang.model.type
  • javax.lang.model.util
  • javax.tools


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.corba Packages

  • javax.activity
  • javax.rmi
  • javax.rmi.CORBA
  • org.omg.CORBA
  • org.omg.CORBA_2_3
  • org.omg.CORBA_2_3.portable
  • org.omg.CORBA.DynAnyPackage
  • org.omg.CORBA.ORBPackage
  • org.omg.CORBA.portable
  • org.omg.CORBA.TypeCodePackage
  • org.omg.CosNaming
  • org.omg.CosNaming.NamingContextExtPackage
  • org.omg.CosNaming.NamingContextPackage
  • org.omg.Dynamic
  • org.omg.DynamicAny
  • org.omg.DynamicAny.DynAnyFactoryPackage
  • org.omg.DynamicAny.DynAnyPackage
  • org.omg.IOP
  • org.omg.IOP.CodecFactoryPackage
  • org.omg.IOP.CodecPackage
  • org.omg.Messaging
  • org.omg.PortableInterceptor
  • org.omg.PortableInterceptor.ORBInitInfoPackage
  • org.omg.PortableServer
  • org.omg.PortableServer.CurrentPackage
  • org.omg.PortableServer.POAManagerPackage
  • org.omg.PortableServer.POAPackage
  • org.omg.PortableServer.portable
  • org.omg.PortableServer.ServantLocatorPackage
  • org.omg.SendingContext
  • org.omg.stub.java.rmi


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.datatransfer Packages

  • java.awt.datatransfer


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.desktop Packages

  • java.applet
  • java.awt
  • java.awt.color
  • java.awt.desktop
  • java.awt.dnd
  • java.awt.event
  • java.awt.font
  • java.awt.geom
  • java.awt.im
  • java.awt.im.spi
  • java.awt.image
  • java.awt.image.renderable
  • java.awt.print
  • java.beans
  • java.beans.beancontext
  • javax.accessibility
  • javax.imageio
  • javax.imageio.event
  • javax.imageio.metadata
  • javax.imageio.plugins.bmp
  • javax.imageio.plugins.jpeg
  • javax.imageio.plugins.tiff
  • javax.imageio.spi
  • javax.imageio.stream
  • javax.print
  • javax.print.attribute
  • javax.print.attribute.standard
  • javax.print.event
  • javax.sound.midi
  • javax.sound.midi.spi
  • javax.sound.sampled
  • javax.sound.sampled.spi
  • javax.swing
  • javax.swing.border
  • javax.swing.colorchooser
  • javax.swing.event
  • javax.swing.filechooser
  • javax.swing.plaf
  • javax.swing.plaf.basic
  • javax.swing.plaf.metal
  • javax.swing.plaf.multi
  • javax.swing.plaf.nimbus
  • javax.swing.plaf.synth
  • javax.swing.table
  • javax.swing.text
  • javax.swing.text.html
  • javax.swing.text.html.parser
  • javax.swing.text.rtf
  • javax.swing.tree
  • javax.swing.undo


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.instrument Packages

  • java.lang.instrument


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.jnlp Packages

  • javax.jnlp


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.logging Packages

  • java.util.logging


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.management Packages

  • java.lang.management
  • javax.management
  • javax.management.loading
  • javax.management.modelmbean
  • javax.management.monitor
  • javax.management.openmbean
  • javax.management.relation
  • javax.management.remote
  • javax.management.timer


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.management.rmi Packages

  • javax.management.remote.rmi


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.naming Packages

  • javax.naming
  • javax.naming.directory
  • javax.naming.event
  • javax.naming.ldap
  • javax.naming.spi


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.prefs Packages

  • java.util.prefs


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.rmi Packages

  • java.rmi
  • java.rmi.activation
  • java.rmi.dgc
  • java.rmi.registry
  • java.rmi.server
  • javax.rmi.ssl


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.scripting Packages

  • javax.script


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.se Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.se.ee Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.security.jgss Packages

  • javax.security.auth.kerberos
  • org.ietf.jgss


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.security.sasl Packages

  • javax.security.sasl


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.smartcardio Packages

  • javax.smartcardio


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.sql Packages

  • java.sql
  • javax.sql
  • javax.transaction.xa


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.sql.rowset Packages

  • javax.sql.rowset
  • javax.sql.rowset.serial
  • javax.sql.rowset.spi


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.transaction Packages

  • javax.transaction


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.xml Packages

  • javax.xml
  • javax.xml.catalog
  • javax.xml.datatype
  • javax.xml.namespace
  • javax.xml.parsers
  • javax.xml.stream
  • javax.xml.stream.events
  • javax.xml.stream.util
  • javax.xml.transform
  • javax.xml.transform.dom
  • javax.xml.transform.sax
  • javax.xml.transform.stax
  • javax.xml.transform.stream
  • javax.xml.validation
  • javax.xml.xpath
  • org.w3c.dom
  • org.w3c.dom.bootstrap
  • org.w3c.dom.events
  • org.w3c.dom.ls
  • org.w3c.dom.ranges
  • org.w3c.dom.traversal
  • org.w3c.dom.views
  • org.xml.sax
  • org.xml.sax.ext
  • org.xml.sax.helpers


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.xml.bind Packages

  • javax.xml.bind
  • javax.xml.bind.annotation
  • javax.xml.bind.annotation.adapters
  • javax.xml.bind.attachment
  • javax.xml.bind.helpers
  • javax.xml.bind.util


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.xml.crypto Packages

  • javax.xml.crypto
  • javax.xml.crypto.dom
  • javax.xml.crypto.dsig
  • javax.xml.crypto.dsig.dom
  • javax.xml.crypto.dsig.keyinfo
  • javax.xml.crypto.dsig.spec


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.xml.ws Packages

  • javax.jws
  • javax.jws.soap
  • javax.xml.soap
  • javax.xml.ws
  • javax.xml.ws.handler
  • javax.xml.ws.handler.soap
  • javax.xml.ws.http
  • javax.xml.ws.soap
  • javax.xml.ws.spi
  • javax.xml.ws.spi.http
  • javax.xml.ws.wsaddressing


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

java.xml.ws.annotation Packages

  • javax.annotation


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

javafx.base Packages

  • javafx.beans
  • javafx.beans.binding
  • javafx.beans.property
  • javafx.beans.property.adapter
  • javafx.beans.value
  • javafx.collections
  • javafx.collections.transformation
  • javafx.event
  • javafx.util
  • javafx.util.converter


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

javafx.controls Packages

  • javafx.scene.chart
  • javafx.scene.control
  • javafx.scene.control.cell
  • javafx.scene.control.skin


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

javafx.fxml Packages

  • javafx.fxml


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

javafx.graphics Packages

  • javafx.animation
  • javafx.application
  • javafx.concurrent
  • javafx.css
  • javafx.css.converter
  • javafx.geometry
  • javafx.print
  • javafx.scene
  • javafx.scene.canvas
  • javafx.scene.effect
  • javafx.scene.image
  • javafx.scene.input
  • javafx.scene.layout
  • javafx.scene.paint
  • javafx.scene.shape
  • javafx.scene.text
  • javafx.scene.transform
  • javafx.stage


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

javafx.media Packages

  • javafx.scene.media


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

javafx.swing Packages

  • javafx.embed.swing


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

javafx.web Packages

  • javafx.scene.web


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.accessibility Packages

  • com.sun.java.accessibility.util


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.attach Packages

  • com.sun.tools.attach
  • com.sun.tools.attach.spi


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.charsets Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.compiler Packages

  • com.sun.source.doctree
  • com.sun.source.tree
  • com.sun.source.util
  • com.sun.tools.javac


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.crypto.cryptoki Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.crypto.ec Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.dynalink Packages

  • jdk.dynalink
  • jdk.dynalink.beans
  • jdk.dynalink.linker
  • jdk.dynalink.linker.support
  • jdk.dynalink.support


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.editpad Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.hotspot.agent Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.httpserver Packages

  • com.sun.net.httpserver
  • com.sun.net.httpserver.spi


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.incubator.httpclient Packages

  • jdk.incubator.http


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jartool Packages

  • com.sun.jarsigner
  • jdk.security.jarsigner


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.javadoc Packages

  • com.sun.javadoc
  • com.sun.tools.doclets
  • com.sun.tools.doclets.standard
  • com.sun.tools.javadoc
  • jdk.javadoc.doclet


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jcmd Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jconsole Packages

  • com.sun.tools.jconsole


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jdeps Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jdi Packages

  • com.sun.jdi
  • com.sun.jdi.connect
  • com.sun.jdi.connect.spi
  • com.sun.jdi.event
  • com.sun.jdi.request


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jdwp.agent Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jlink Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jshell Packages

  • jdk.jshell
  • jdk.jshell.execution
  • jdk.jshell.spi
  • jdk.jshell.tool


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jsobject Packages

  • netscape.javascript


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.jstatd Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.localedata Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.management Packages

  • com.sun.management


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.management.agent Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.naming.dns Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.naming.rmi Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.net Packages

  • jdk.net


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.pack Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.packager.services Packages

  • jdk.packager.services


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.policytool Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.rmic Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.scripting.nashorn Packages

  • jdk.nashorn.api.scripting
  • jdk.nashorn.api.tree


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.sctp Packages

  • com.sun.nio.sctp


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.security.auth Packages

  • com.sun.security.auth
  • com.sun.security.auth.callback
  • com.sun.security.auth.login
  • com.sun.security.auth.module


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.security.jgss Packages

  • com.sun.security.jgss


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.snmp Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.xml.dom Packages

  • org.w3c.dom.css
  • org.w3c.dom.html
  • org.w3c.dom.stylesheets
  • org.w3c.dom.xpath


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages
  • All Modules

jdk.zipfs Packages


Overview List (Java SE 9 & JDK 9 )

Java SE 9 & JDK 9

  • 所有类
  • All Packages

Modules

  • java.activation
  • java.base
  • java.compiler
  • java.corba
  • java.datatransfer
  • java.desktop
  • java.instrument
  • java.jnlp
  • java.logging
  • java.management
  • java.management.rmi
  • java.naming
  • java.prefs
  • java.rmi
  • java.scripting
  • java.se
  • java.se.ee
  • java.security.jgss
  • java.security.sasl
  • java.smartcardio
  • java.sql
  • java.sql.rowset
  • java.transaction
  • java.xml
  • java.xml.bind
  • java.xml.crypto
  • java.xml.ws
  • java.xml.ws.annotation
  • javafx.base
  • javafx.controls
  • javafx.fxml
  • javafx.graphics
  • javafx.media
  • javafx.swing
  • javafx.web
  • jdk.accessibility
  • jdk.attach
  • jdk.charsets
  • jdk.compiler
  • jdk.crypto.cryptoki
  • jdk.crypto.ec
  • jdk.dynalink
  • jdk.editpad
  • jdk.hotspot.agent
  • jdk.httpserver
  • jdk.incubator.httpclient
  • jdk.jartool
  • jdk.javadoc
  • jdk.jcmd
  • jdk.jconsole
  • jdk.jdeps
  • jdk.jdi
  • jdk.jdwp.agent
  • jdk.jlink
  • jdk.jshell
  • jdk.jsobject
  • jdk.jstatd
  • jdk.localedata
  • jdk.management
  • jdk.management.agent
  • jdk.naming.dns
  • jdk.naming.rmi
  • jdk.net
  • jdk.pack
  • jdk.packager.services
  • jdk.policytool
  • jdk.rmic
  • jdk.scripting.nashorn
  • jdk.sctp
  • jdk.security.auth
  • jdk.security.jgss
  • jdk.snmp
  • jdk.xml.dom
  • jdk.zipfs


com.sun.jarsigner (Java SE 9 & JDK 9 )

com.sun.jarsigner

Interfaces

  • ContentSignerParameters

Classes

  • ContentSigner


com.sun.jarsigner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.jartool

Package com.sun.jarsigner

该包包含用于定义jarsigner工具使用的签名机制的接口和类。

客户可以覆盖的默认签名机制jarsigner通过提供替代实现的工具ContentSigner 。 此包中的类已被弃用。 新的类不应该添加到这个包中。 使用JarSigner API来签名JAR文件。

  • 接口摘要
    接口 描述
    ContentSignerParameters Deprecated.
    此类已被弃用。
  • 类摘要
    Class 描述
    ContentSigner Deprecated.
    此类已被弃用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.jarsigner Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.jarsigner

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.jarsigner.ContentSigner

Interface Hierarchy

  • com.sun.jarsigner.ContentSignerParameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ContentSigner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jartool
软件包 com.sun.jarsigner

Class ContentSigner

  • java.lang.Object
    • com.sun.jarsigner.ContentSigner
  • 已过时。
    此类已被弃用。

    @Deprecated(since="9")
public abstract class ContentSigner
extends Object
    此类定义了内容签名服务。 实现必须使用零参数构造函数来实例化。
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContentSigner​()
      已过时。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      abstract byte[] generateSignedData​(ContentSignerParameters parameters, boolean omitContent, boolean applyTimestamp)
      已过时。
      生成PKCS＃7签名的数据消息。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ContentSigner

        public ContentSigner​()
        已过时。

    • 方法详细信息

      • generateSignedData

        public abstract byte[] generateSignedData​(ContentSignerParameters parameters,
                                          boolean omitContent,
                                          boolean applyTimestamp)
                                   throws NoSuchAlgorithmException,
                                          CertificateException,
                                          IOException
        已过时。
        生成PKCS＃7签名的数据消息。 当已经生成签名时使用此方法。 签名，签名者的详细信息，以及可选的签名时间戳和签名的内容都被打包成签名的数据消息。
        参数
        parameters - 非空输入参数。
        omitContent - 如果内容应从签名的数据消息中省略， omitContent true。 否则包含内容。
        applyTimestamp - 如果签名应该是时间戳的， applyTimestamp true。 否则不执行时间戳。
        结果
        PKCS＃7签署了数据消息。
        异常
        NoSuchAlgorithmException - 如果签名算法无法识别，则抛出异常。
        CertificateException - 如果在处理签名者的证书或TSA的证书时发生错误，则抛出异常。
        IOException - 如果在生成签名时间戳或生成签名数据消息时发生错误，则抛出异常。
        NullPointerException - 如果参数为null，则抛出异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContentSignerParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jartool
软件包 com.sun.jarsigner

Interface ContentSignerParameters

  • 已过时。
    此类已被弃用。

    @Deprecated(since="9")
public interface ContentSignerParameters
    该接口封装了ContentSigner对象的参数。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods 弃用的方法
      Modifier and Type 方法 描述
      String[] getCommandLine​()
      已过时。
      检索传递给jarsigner工具的命令行参数。
      byte[] getContent​()
      已过时。
      检索已签名的内容。
      byte[] getSignature​()
      已过时。
      检索JAR文件的签名。
      String getSignatureAlgorithm​()
      已过时。
      检索签名算法的名称。
      X509Certificate[] getSignerCertificateChain​()
      已过时。
      检索签名人的X.509证书链。
      ZipFile getSource​()
      已过时。
      在签署之前检索原始的ZIP文件。
      URI getTimestampingAuthority​()
      已过时。
      检索时间戳管理机构（TSA）的标识符。
      X509Certificate getTimestampingAuthorityCertificate​()
      已过时。
      检索时间戳管理局（TSA）的证书。
      default String getTSADigestAlg​()
      已过时。
      检索用于生成要发送到TSA服务器的消息印记的消息摘要算法。
      default String getTSAPolicyID​()
      已过时。
      检索时间戳权限（TSA）的TSAPolicyID。

    • 方法详细信息

      • getCommandLine

        String[] getCommandLine​()
        已过时。
        检索传递给jarsigner工具的命令行参数。
        结果
        命令行参数。 可能为null。

      • getTimestampingAuthority

        URI getTimestampingAuthority​()
        已过时。
        检索时间戳管理机构（TSA）的标识符。
        结果
        TSA标识符。 可能为null。

      • getTimestampingAuthorityCertificate

        X509Certificate getTimestampingAuthorityCertificate​()
        已过时。
        检索时间戳管理局（TSA）的证书。
        结果
        TSA证书。 可能为null。

      • getTSAPolicyID

        default String getTSAPolicyID​()
        已过时。
        检索时间戳权限（TSA）的TSAPolicyID。
        结果
        TSAPolicyID。 可能为null。

      • getTSADigestAlg

        default String getTSADigestAlg​()
        已过时。
        检索用于生成要发送到TSA服务器的消息印记的消息摘要算法。
        结果
        消息摘要算法名称的非空字符串。
        从以下版本开始：
        9

      • getSignature

        byte[] getSignature​()
        已过时。
        检索JAR文件的签名。
        结果
        签名字节的非空数组。

      • getSignatureAlgorithm

        String getSignatureAlgorithm​()
        已过时。
        检索签名算法的名称。
        结果
        签名算法的非空字符串名称。

      • getSignerCertificateChain

        X509Certificate[] getSignerCertificateChain​()
        已过时。
        检索签名人的X.509证书链。
        结果
        X.509公钥证书的非空数组。

      • getContent

        byte[] getContent​()
        已过时。
        检索已签名的内容。 内容是JAR文件的签名文件。
        结果
        内容字节。 可能为null。

      • getSource

        ZipFile getSource​()
        已过时。
        在签署之前检索原始的ZIP文件。
        结果
        The original ZIP file. May be null.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.jarsigner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.jarsigner

  • Packages that use com.sun.jarsigner
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
  • Classes in com.sun.jarsigner used by com.sun.jarsigner
    Class 描述
    ContentSignerParameters
    已过时。
    此类已被弃用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jarsigner.ContentSigner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jarsigner.ContentSigner

No usage of com.sun.jarsigner.ContentSigner
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jarsigner.ContentSignerParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jarsigner.ContentSignerParameters

  • Packages that use ContentSignerParameters
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。

    • Uses of ContentSignerParameters in com.sun.jarsigner

      Methods in com.sun.jarsigner with parameters of type ContentSignerParameters
      Modifier and Type 方法 描述
      abstract byte[] ContentSigner.generateSignedData​(ContentSignerParameters parameters, boolean omitContent, boolean applyTimestamp)
      已过时。
      生成PKCS＃7签名的数据消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AccessibilityEventMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Class AccessibilityEventMonitor

  • java.lang.Object
    • com.sun.java.accessibility.util.AccessibilityEventMonitor

  • public class AccessibilityEventMonitor
extends Object

    AccessibilityEventMonitor在实现Java虚拟机中接口Accessible每个UI对象上实现PropertyChange监听器。 这些侦听器捕获的事件可通过AccessibilityEventMonitor支持的侦听器提供。 通过这一点，每个UI对象实例上的所有单个事件都会被汇集到一组PropertyChange监听器中。

    该类依赖于EventQueueMonitor ，它为创建顶级容器提供了基本级别的支持。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected static AccessibilityListenerList listenerList
      目前注册的人数为PropertyChangeListener 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibilityEventMonitor​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static void addPropertyChangeListener​(PropertyChangeListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个UI对象实例上接收所有PropertyChange事件。
      static void removePropertyChangeListener​(PropertyChangeListener l)
      删除指定的监听器，使其在发生时不再接收PropertyChange事件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected static final AccessibilityListenerList listenerList
        目前已注册的PropertyChangeListener课程。
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， removePropertyChangeListener(java.beans.PropertyChangeListener)

    • 构造方法详细信息

      • AccessibilityEventMonitor

        public AccessibilityEventMonitor​()

    • 方法详细信息

      • addPropertyChangeListener

        public static void addPropertyChangeListener​(PropertyChangeListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个UI对象实例上接收所有PropertyChange事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的UI对象实例中。

        参数
        l - 要添加的收听者
        另请参见：
        removePropertyChangeListener(java.beans.PropertyChangeListener)

      • removePropertyChangeListener

        public static void removePropertyChangeListener​(PropertyChangeListener l)
        删除指定的监听器，使其在发生时不再接收PropertyChange事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AccessibilityListenerList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Class AccessibilityListenerList

  • java.lang.Object
    • com.sun.java.accessibility.util.AccessibilityListenerList

  • public class AccessibilityListenerList
extends Object

    AccessibilityListenerList是Swing EventListerList课程的副本。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Object[] listenerList
      侦听器类型列表，侦听器对

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibilityListenerList​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(Class<? extends EventListener> t, EventListener l)
      将侦听器添加为指定类型的侦听器。
      int getListenerCount​()
      返回此侦听器列表的侦听器总数。
      int getListenerCount​(Class<? extends EventListener> t)
      返回此侦听器列表提供的类型的侦听器总数。
      Object[] getListenerList​()
      将事件侦听器列表作为侦听器类型，侦听器对的数组传回。
      void remove​(Class<? extends EventListener> t, EventListener l)
      将侦听器作为指定类型的侦听器删除。
      String toString​()
      返回一个字符串表示的 AccessibilityListenerList 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected transient Object[] listenerList
        侦听器类型列表，侦听器对

    • 构造方法详细信息

      • AccessibilityListenerList

        public AccessibilityListenerList​()

    • 方法详细信息

      • getListenerList

        public Object[] getListenerList​()
        将事件侦听器列表作为侦听器类型，侦听器对的数组传回。 请注意，出于性能原因，此实现会传回内部存储侦听器数据的实际数据结构。 该方法保证传回一个非空数组，以便在fire方法中不需要空检。 如果目前没有侦听器，则返回一个零长度的Object数组。

        绝对不能修改这个数组中包含的数据。 如果需要这样的操作，应该在返回的数组的副本而不是数组本身上完成。

        结果
        一组侦听器类型，侦听器对。

      • getListenerCount

        public int getListenerCount​()
        返回此侦听器列表的侦听器总数。
        结果
        此侦听器列表的侦听器总数。

      • getListenerCount

        public int getListenerCount​(Class<? extends EventListener> t)
        返回此侦听器列表提供的类型的侦听器总数。
        参数
        t - 要计数的侦听器的类型
        结果
        发现的听众数量

      • add

        public void add​(Class<? extends EventListener> t,
                EventListener l)
        将侦听器添加为指定类型的侦听器。
        参数
        t - 要添加的侦听器的类型
        l - 要添加的侦听器

      • remove

        public void remove​(Class<? extends EventListener> t,
                   EventListener l)
        将侦听器作为指定类型的侦听器删除。
        参数
        t - 要删除的侦听器的类型
        l - 要删除的侦听器

      • toString

        public String toString​()
        返回一个字符串表示的 AccessibilityListenerList 。
        重写：
        toString在 Object
        结果
        a string representation of the AccessibilityListenerList.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTEventMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Class AWTEventMonitor

  • java.lang.Object
    • com.sun.java.accessibility.util.AWTEventMonitor
  • 已知直接子类：
    SwingEventMonitor

    public class AWTEventMonitor
extends Object

    AWTEventMonitor实现了一套监听器，它们有条件地安装在Java虚拟机中的每个AWT组件实例上。 这些侦听器捕获的事件可以通过AWTEventMonitor支持的统一的侦听器提供。 通过这一点，每个AWT组件实例上的所有单个事件都会被汇总到按类别细分的一组监听器中（有关类别，请参阅EventID ）。

    该类依赖于EventQueueMonitor ，它为创建顶级容器提供了基本级别的支持。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected static ActionListener actionListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static AdjustmentListener adjustmentListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static ComponentListener componentListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static Component componentWithFocus
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用; 使用getComponentWithFocus方法获取焦点的组件。
      protected static ContainerListener containerListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static FocusListener focusListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static ItemListener itemListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static KeyListener keyListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static MouseListener mouseListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static MouseMotionListener mouseMotionListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static TextListener textListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static WindowListener windowListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AWTEventMonitor​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static void addActionListener​(ActionListener l)
      添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 ACTION事件。
      static void addAdjustmentListener​(AdjustmentListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ADJUSTMENT个事件。
      static void addComponentListener​(ComponentListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 COMPONENT事件。
      static void addContainerListener​(ContainerListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 CONTAINER事件。
      static void addFocusListener​(FocusListener l)
      添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有 FOCUS事件。
      static void addItemListener​(ItemListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ITEM事件。
      static void addKeyListener​(KeyListener l)
      添加指定的侦听器，以便在Java虚拟机发生时的每个组件实例上接收所有 KEY事件。
      static void addMouseListener​(MouseListener l)
      添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有 MOUSE事件。
      static void addMouseMotionListener​(MouseMotionListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有鼠标 MOTION事件。
      static void addTextListener​(TextListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 TEXT事件。
      static void addWindowListener​(WindowListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 WINDOW事件。
      static Component getComponentWithFocus​()
      返回当前具有键盘焦点的组件。
      static void removeActionListener​(ActionListener l)
      删除指定的侦听器，使其在发生事件时不再接收 ACTION事件。
      static void removeAdjustmentListener​(AdjustmentListener l)
      删除指定的侦听器，使其不再接收 ADJUSTMENT事件。
      static void removeComponentListener​(ComponentListener l)
      删除指定的侦听器，使其不再接收 COMPONENT事件。
      static void removeContainerListener​(ContainerListener l)
      移除指定的侦听器，使其在发生事件时不再接收 27043443678256事件。
      static void removeFocusListener​(FocusListener l)
      删除指定的侦听器，使其不再接收 27043443642207个事件。
      static void removeItemListener​(ItemListener l)
      删除指定的侦听器，使其不再接收 ITEM事件。
      static void removeKeyListener​(KeyListener l)
      移除指定的侦听器，使其不再接收 KEY事件。
      static void removeMouseListener​(MouseListener l)
      删除指定的侦听器，使其不再接收 MOUSE个事件。
      static void removeMouseMotionListener​(MouseMotionListener l)
      移除指定的侦听器，使其不再接收 MOTION事件。
      static void removeTextListener​(TextListener l)
      移除指定的侦听器，使其不再接收 TEXT事件。
      static void removeWindowListener​(WindowListener l)
      删除指定的侦听器，使其不再接收 2704344372761事件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • componentWithFocus

        @Deprecated(since="8",
            forRemoval=true)
protected static Component componentWithFocus
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用; 使用getComponentWithFocus方法获取焦点的组件。
        当前组件与键盘焦点。
        另请参见：
        getComponentWithFocus()

      • componentListener

        @Deprecated(since="8",
            forRemoval=true)
protected static ComponentListener componentListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        注册的ComponentListener类的当前列表。
        另请参见：
        addComponentListener(java.awt.event.ComponentListener) ， removeComponentListener(java.awt.event.ComponentListener)

      • containerListener

        @Deprecated(since="8",
            forRemoval=true)
protected static ContainerListener containerListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前列出的已注册的ContainerListener类。
        另请参见：
        addContainerListener(java.awt.event.ContainerListener) ， removeContainerListener(java.awt.event.ContainerListener)

      • focusListener

        @Deprecated(since="8",
            forRemoval=true)
protected static FocusListener focusListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前注册的FocusListener类列表。
        另请参见：
        addFocusListener(java.awt.event.FocusListener) ， removeFocusListener(java.awt.event.FocusListener)

      • keyListener

        @Deprecated(since="8",
            forRemoval=true)
protected static KeyListener keyListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前的注册KeyListener类列表。
        另请参见：
        addKeyListener(java.awt.event.KeyListener) ， removeKeyListener(java.awt.event.KeyListener)

      • mouseListener

        @Deprecated(since="8",
            forRemoval=true)
protected static MouseListener mouseListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前的注册MouseListener类列表。
        另请参见：
        addMouseListener(java.awt.event.MouseListener) ， removeMouseListener(java.awt.event.MouseListener)

      • mouseMotionListener

        @Deprecated(since="8",
            forRemoval=true)
protected static MouseMotionListener mouseMotionListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前的注册MouseMotionListener类的列表。
        另请参见：
        addMouseMotionListener(java.awt.event.MouseMotionListener) ， removeMouseMotionListener(java.awt.event.MouseMotionListener)

      • windowListener

        @Deprecated(since="8",
            forRemoval=true)
protected static WindowListener windowListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前注册的WindowListener类列表。
        另请参见：
        addWindowListener(java.awt.event.WindowListener) ， removeWindowListener(java.awt.event.WindowListener)

      • actionListener

        @Deprecated(since="8",
            forRemoval=true)
protected static ActionListener actionListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        注册的ActionListener类的当前列表。
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， removeActionListener(java.awt.event.ActionListener)

      • adjustmentListener

        @Deprecated(since="8",
            forRemoval=true)
protected static AdjustmentListener adjustmentListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前注册的AdjustmentListener类列表。
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener) ， removeAdjustmentListener(java.awt.event.AdjustmentListener)

      • itemListener

        @Deprecated(since="8",
            forRemoval=true)
protected static ItemListener itemListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        当前列表中已注册的ItemListener类。
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， removeItemListener(java.awt.event.ItemListener)

      • textListener

        @Deprecated(since="8",
            forRemoval=true)
protected static TextListener textListener
        不推荐用于删除：此API元素将在以后的版本中被删除。 此字段未使用。
        注册的TextListener类的当前列表。
        另请参见：
        addTextListener(java.awt.event.TextListener) ， removeTextListener(java.awt.event.TextListener)

    • 构造方法详细信息

      • AWTEventMonitor

        public AWTEventMonitor​()

    • 方法详细信息

      • getComponentWithFocus

        public static Component getComponentWithFocus​()
        返回当前具有键盘焦点的组件。 返回值可以为null。
        结果
        具有键盘焦点的组件

      • addComponentListener

        public static void addComponentListener​(ComponentListener l)
        添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有COMPONENT事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的监听器
        另请参见：
        removeComponentListener(java.awt.event.ComponentListener)

      • removeComponentListener

        public static void removeComponentListener​(ComponentListener l)
        删除指定的侦听器，使其不再接收事件 COMPONENT 。
        参数
        l - 要删除的侦听器
        另请参见：
        addComponentListener(java.awt.event.ComponentListener)

      • addContainerListener

        public static void addContainerListener​(ContainerListener l)
        添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有CONTAINER事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeContainerListener(java.awt.event.ContainerListener)

      • removeContainerListener

        public static void removeContainerListener​(ContainerListener l)
        删除指定的侦听器，使其不再接收 CONTAINER个事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addContainerListener(java.awt.event.ContainerListener)

      • addFocusListener

        public static void addFocusListener​(FocusListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有FOCUS事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public static void removeFocusListener​(FocusListener l)
        删除指定的侦听器，使其不再接收 FOCUS个事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addFocusListener(java.awt.event.FocusListener)

      • addKeyListener

        public static void addKeyListener​(KeyListener l)
        添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有KEY事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeKeyListener(java.awt.event.KeyListener)

      • removeKeyListener

        public static void removeKeyListener​(KeyListener l)
        删除指定的侦听器，使其在发生事件时不再接收 KEY事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addKeyListener(java.awt.event.KeyListener)

      • addMouseListener

        public static void addMouseListener​(MouseListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有MOUSE事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的监听器
        另请参见：
        removeMouseListener(java.awt.event.MouseListener)

      • removeMouseListener

        public static void removeMouseListener​(MouseListener l)
        删除指定的侦听器，使其不再接收 MOUSE个事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addMouseListener(java.awt.event.MouseListener)

      • addMouseMotionListener

        public static void addMouseMotionListener​(MouseMotionListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有鼠标MOTION事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的监听器
        另请参见：
        removeMouseMotionListener(java.awt.event.MouseMotionListener)

      • removeMouseMotionListener

        public static void removeMouseMotionListener​(MouseMotionListener l)
        删除指定的侦听器，使其在发生事件时不再接收 27043444292989事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addMouseMotionListener(java.awt.event.MouseMotionListener)

      • addWindowListener

        public static void addWindowListener​(WindowListener l)
        添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有27043444441945事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的收听者
        另请参见：
        removeWindowListener(java.awt.event.WindowListener)

      • removeWindowListener

        public static void removeWindowListener​(WindowListener l)
        删除指定的侦听器，使其不再接收 WINDOW事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addWindowListener(java.awt.event.WindowListener)

      • addActionListener

        public static void addActionListener​(ActionListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有ACTION事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的收听者
        另请参见：
        removeActionListener(java.awt.event.ActionListener)

      • removeActionListener

        public static void removeActionListener​(ActionListener l)
        删除指定的侦听器，使其在发生事件时不再接收 ACTION事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addActionListener(java.awt.event.ActionListener)

      • addAdjustmentListener

        public static void addAdjustmentListener​(AdjustmentListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有ADJUSTMENT事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeAdjustmentListener(java.awt.event.AdjustmentListener)

      • removeAdjustmentListener

        public static void removeAdjustmentListener​(AdjustmentListener l)
        移除指定的侦听器，使其在发生事件时不再接收 ADJUSTMENT事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener)

      • addItemListener

        public static void addItemListener​(ItemListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有ITEM事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeItemListener(java.awt.event.ItemListener)

      • removeItemListener

        public static void removeItemListener​(ItemListener l)
        移除指定的侦听器，使其不再接收 2704349869966事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addItemListener(java.awt.event.ItemListener)

      • addTextListener

        public static void addTextListener​(TextListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有TEXT事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeTextListener(java.awt.event.TextListener)

      • removeTextListener

        public static void removeTextListener​(TextListener l)
        移除指定的侦听器，使其不再接收 TEXT事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addTextListener(java.awt.event.TextListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.java.accessibility.util (Java SE 9 & JDK 9 )

com.sun.java.accessibility.util

Interfaces

  • GUIInitializedListener
  • TopLevelWindowListener

Classes

  • AccessibilityEventMonitor
  • AccessibilityListenerList
  • AWTEventMonitor
  • EventID
  • EventQueueMonitor
  • SwingEventMonitor
  • Translator


com.sun.java.accessibility.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.accessibility

Package com.sun.java.accessibility.util

提供组成Java辅助功能实用程序的接口和类的集合。 辅助技术使用这些类，例如盲人使用的屏幕阅读器，并帮助提供实现Java Accessibility API的GUI工具包的访问。 重要课程概述如下。

类AccessibilityEventMonitor在实现Java虚拟机中的接口Accessible每个UI对象上实现PropertyChange侦听器。

AWTEventMonitor类实现了一套有条件地安装在Java虚拟机中的每个AWT组件实例上的监听器。

EventQueueMonitor为辅助技术提供了关键的核心功能（以及需要与辅助技术需要的相同内容的其他系统级技术）。

GUIInitializedMulticaster类用于维护GUIInitializedListener类的列表，由EventQueueMonitor类用于在GUI子系统初始化时通知有关方。 请注意，此类旨在主要用于EventQueueMonitor类中的内部支持，并不适用于Java Accessibility Utility包以外的类。

通过在Java虚拟机中的每个Swing组件实例上有条件地安装一组监听器，类SwingEventMonitor扩展了AWTEventMonitor 。

TopLevelWindowMulticaster类用于维护TopLevelWindowListener类的列表，由EventQueueMonitor类使用，以在Java虚拟机中创建或销毁顶级窗口时通知感兴趣方注意，此类主要用于内部支持EventQueueMonitor类，并且不适用于Java Accessibility Utility包以外的类。

Translator Accessible为不实现接口Accessible对象提供了一个到接口Accessible的翻译。

从以下版本开始：
JDK1.7
  • 接口摘要
    接口 描述
    GUIInitializedListener
    GUIInitializedListener接口由EventQueueMonitor类用于在GUI子系统初始化时通知感兴趣方。
    TopLevelWindowListener
    当在Java虚拟机中创建或销毁顶级窗口时， EventQueueMonitor类使用TopLevelWindowListener接口通知有关方。
  • 类摘要
    Class 描述
    AccessibilityEventMonitor
    AccessibilityEventMonitor在实现Java虚拟机中的接口 Accessible每个UI对象上实现PropertyChange监听器。
    AccessibilityListenerList
    AccessibilityListenerList是Swing EventListerList类的副本。
    AWTEventMonitor
    AWTEventMonitor实现了一套监听器，它们有条件地安装在Java虚拟机中的每个AWT组件实例上。
    EventID
    EventID包含映射到AWT和Swing中的事件支持的整型常量。
    EventQueueMonitor
    EventQueueMonitor类为辅助技术提供了关键的核心功能（以及需要辅助技术需要的一些相同功能的其他系统级技术）。
    SwingEventMonitor
    SwingEventMonitor通过在Java虚拟机中的每个Swing组件实例上添加一个有条件地安装的监听SwingEventMonitor扩展AWTEventMonitor 。
    Translator
    Translator类为不实现接口Accessible对象提供了一个到接口Accessible的转换。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.java.accessibility.util Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.java.accessibility.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.java.accessibility.util.AccessibilityEventMonitor
    • com.sun.java.accessibility.util.AccessibilityListenerList
    • javax.accessibility.AccessibleContext
      • com.sun.java.accessibility.util.Translator (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
    • com.sun.java.accessibility.util.AWTEventMonitor
      • com.sun.java.accessibility.util.SwingEventMonitor
    • com.sun.java.accessibility.util.EventID
    • com.sun.java.accessibility.util.EventQueueMonitor (implements java.awt.event.AWTEventListener)

Interface Hierarchy

  • java.util.EventListener
    • com.sun.java.accessibility.util.GUIInitializedListener
    • com.sun.java.accessibility.util.TopLevelWindowListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


EventID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Class EventID

  • java.lang.Object
    • com.sun.java.accessibility.util.EventID

  • public class EventID
extends Object
    EventID包含映射到AWT和Swing中的事件支持的整型常量。 它们主要由AWTEventMonitor，AWTEventsListener，SwingEventMonitor和SwingEventListener使用，但可以由任何其他类自由使用。
    另请参见：
    AWTEventMonitor ， SwingEventMonitor

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ACTION
      映射到AWT Action支持（即ActionListener和ActionEvent）
      static int ADJUSTMENT
      映射到AWT调整支持（即AdjustmentListener和AdjustmentEvent）
      static int ANCESTOR
      映射到Swing Ancestor支持（即AncestorListener和AncestorEvent）
      static int CARET
      映射到Swing Text Caret支持（即CaretListener和CaretEvent）
      static int CELLEDITOR
      映射到Swing CellEditor支持（即CellEditorListener和CellEditorEvent）
      static int CHANGE
      映射到Swing Change支持（即ChangeListener和ChangeEvent）
      static int COLUMNMODEL
      映射到Swing TableColumnModel支持（即TableColumnModelListener和TableColumnModelEvent）
      static int COMPONENT
      映射到AWT组件支持（即ComponentListener和ComponentEvent）
      static int CONTAINER
      映射到AWT容器支持（即ContainerListener和ContainerEvent）
      static int DOCUMENT
      映射到Swing Document支持（即DocumentListener和DocumentEvent）
      static int FOCUS
      映射到AWT Focus支持（即FocusListener和FocusEvent）
      static int INTERNALFRAME
      映射到Swing InternalFrame支持（即InternalFrameListener）
      static int ITEM
      映射到AWT项目支持（即ItemListener和ItemEvent）
      static int KEY
      映射到AWT键支持（即KeyListener和KeyEvent）
      static int LISTDATA
      映射到Swing ListData支持（即ListDataListener和ListDataEvent）
      static int LISTSELECTION
      映射到Swing ListSelection支持（即ListSelectionListener和ListSelectionEvent）
      static int MENU
      映射到Swing菜单支持（即MenuListener和MenuEvent）
      static int MOTION
      映射到AWT MouseMotion支持（即MouseMotionListener和MouseMotionEvent）
      static int MOUSE
      映射到AWT鼠标支持（即MouseListener和MouseEvent）
      static int POPUPMENU
      映射到Swing PopupMenu支持（即PopupMenuListener和PopupMenuEvent）
      static int PROPERTYCHANGE
      映射到Bean PropertyChange支持（即PropertyChangeListener和PropertyChangeEvent）
      static int TABLEMODEL
      映射到Swing TableModel支持（即TableModelListener和TableModelEvent）
      static int TEXT
      映射到AWT文本支持（即TextListener和TextEvent）
      static int TREEEXPANSION
      映射到Swing TreeExpansion支持（即TreeExpansionListener和TreeExpansionEvent）
      static int TREEMODEL
      映射到Swing TreeModel支持（即TreeModelListener和TreeModelEvent）
      static int TREESELECTION
      映射到Swing TreeSelection支持（即TreeSelectionListener和TreeSelectionEvent）
      static int UNDOABLEEDIT
      映射到Swing UndoableEdit支持（即UndoableEditListener和UndoableEditEvent）
      static int VETOABLECHANGE
      Maps to Beans VetoableChange支持（即VetoableChangeListener和VetoableChangeEvent）
      static int WINDOW
      映射到AWT窗口支持（即WindowListener和WindowEvent）

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventID​()

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ACTION

        public static final int ACTION
        映射到AWT Action支持（即ActionListener和ActionEvent）
        另请参见：
        Constant Field Values

      • ADJUSTMENT

        public static final int ADJUSTMENT
        映射到AWT调整支持（即AdjustmentListener和AdjustmentEvent）
        另请参见：
        Constant Field Values

      • COMPONENT

        public static final int COMPONENT
        映射到AWT组件支持（即ComponentListener和ComponentEvent）
        另请参见：
        Constant Field Values

      • CONTAINER

        public static final int CONTAINER
        映射到AWT容器支持（即ContainerListener和ContainerEvent）
        另请参见：
        Constant Field Values

      • FOCUS

        public static final int FOCUS
        映射到AWT Focus支持（即FocusListener和FocusEvent）
        另请参见：
        Constant Field Values

      • ITEM

        public static final int ITEM
        映射到AWT项目支持（即ItemListener和ItemEvent）
        另请参见：
        Constant Field Values

      • KEY

        public static final int KEY
        映射到AWT键支持（即KeyListener和KeyEvent）
        另请参见：
        Constant Field Values

      • MOUSE

        public static final int MOUSE
        映射到AWT鼠标支持（即MouseListener和MouseEvent）
        另请参见：
        Constant Field Values

      • MOTION

        public static final int MOTION
        映射到AWT MouseMotion支持（即MouseMotionListener和MouseMotionEvent）
        另请参见：
        Constant Field Values

      • TEXT

        public static final int TEXT
        映射到AWT文本支持（即TextListener和TextEvent）
        另请参见：
        Constant Field Values

      • WINDOW

        public static final int WINDOW
        映射到AWT窗口支持（即WindowListener和WindowEvent）
        另请参见：
        Constant Field Values

      • ANCESTOR

        public static final int ANCESTOR
        映射到Swing Ancestor支持（即AncestorListener和AncestorEvent）
        另请参见：
        Constant Field Values

      • CARET

        public static final int CARET
        映射到Swing Text Caret支持（即CaretListener和CaretEvent）
        另请参见：
        Constant Field Values

      • CELLEDITOR

        public static final int CELLEDITOR
        映射到Swing CellEditor支持（即CellEditorListener和CellEditorEvent）
        另请参见：
        Constant Field Values

      • CHANGE

        public static final int CHANGE
        映射到Swing Change支持（即ChangeListener和ChangeEvent）
        另请参见：
        Constant Field Values

      • COLUMNMODEL

        public static final int COLUMNMODEL
        映射到Swing TableColumnModel支持（即TableColumnModelListener和TableColumnModelEvent）
        另请参见：
        Constant Field Values

      • DOCUMENT

        public static final int DOCUMENT
        映射到Swing Document支持（即DocumentListener和DocumentEvent）
        另请参见：
        Constant Field Values

      • LISTDATA

        public static final int LISTDATA
        映射到Swing ListData支持（即ListDataListener和ListDataEvent）
        另请参见：
        Constant Field Values

      • LISTSELECTION

        public static final int LISTSELECTION
        映射到Swing ListSelection支持（即ListSelectionListener和ListSelectionEvent）
        另请参见：
        Constant Field Values

      • MENU

        public static final int MENU
        映射到Swing菜单支持（即MenuListener和MenuEvent）
        另请参见：
        Constant Field Values

      • POPUPMENU

        public static final int POPUPMENU
        映射到Swing PopupMenu支持（即PopupMenuListener和PopupMenuEvent）
        另请参见：
        Constant Field Values

      • TABLEMODEL

        public static final int TABLEMODEL
        映射到Swing TableModel支持（即TableModelListener和TableModelEvent）
        另请参见：
        Constant Field Values

      • TREEEXPANSION

        public static final int TREEEXPANSION
        映射到Swing TreeExpansion支持（即TreeExpansionListener和TreeExpansionEvent）
        另请参见：
        Constant Field Values

      • TREEMODEL

        public static final int TREEMODEL
        映射到Swing TreeModel支持（即TreeModelListener和TreeModelEvent）
        另请参见：
        Constant Field Values

      • TREESELECTION

        public static final int TREESELECTION
        映射到Swing TreeSelection支持（即TreeSelectionListener和TreeSelectionEvent）
        另请参见：
        Constant Field Values

      • UNDOABLEEDIT

        public static final int UNDOABLEEDIT
        映射到Swing UndoableEdit支持（即UndoableEditListener和UndoableEditEvent）
        另请参见：
        Constant Field Values

      • PROPERTYCHANGE

        public static final int PROPERTYCHANGE
        映射到Bean PropertyChange支持（即PropertyChangeListener和PropertyChangeEvent）
        另请参见：
        Constant Field Values

      • VETOABLECHANGE

        public static final int VETOABLECHANGE
        Maps to Beans VetoableChange支持（即VetoableChangeListener和VetoableChangeEvent）
        另请参见：
        Constant Field Values

      • INTERNALFRAME

        public static final int INTERNALFRAME
        映射到Swing InternalFrame支持（即InternalFrameListener）
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • EventID

        public EventID​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventQueueMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Class EventQueueMonitor

  • java.lang.Object
    • com.sun.java.accessibility.util.EventQueueMonitor
  • All Implemented Interfaces:
    AWTEventListener ， EventListener

    public class EventQueueMonitor
extends Object
implements AWTEventListener
    EventQueueMonitor类为辅助技术提供了关键的核心功能（以及需要辅助技术需要的一些相同功能的其他系统级技术）。
    另请参见：
    AWTEventMonitor ， SwingEventMonitor

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventQueueMonitor​()
      创建一个新的 EventQueueMonitor实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static void addGUIInitializedListener​(GUIInitializedListener l)
      添加指定的监听器，以在GUI子系统初始化时通知。
      static void addTopLevelWindowListener​(TopLevelWindowListener l)
      添加当创建或销毁顶级窗口时通知的指定侦听器。
      void eventDispatched​(AWTEvent theEvent)
      在maybeInitialize()的EventQueue注册一个监听器处理事件。
      static Accessible getAccessibleAt​(Point p)
      在屏幕上的给定点获取Accessible对象。
      static Point getCurrentMousePosition​()
      将鼠标的最后记录位置返回到屏幕坐标。
      static Window[] getTopLevelWindows​()
      返回在Java虚拟机中使用的顶级Windows的列表。
      static Window getTopLevelWindowWithFocus​()
      返回当前具有键盘焦点的顶级 Window 。
      static boolean isGUIInitialized​()
      说明GUI子系统是否已被初始化？
      static void maybeInitialize​()
      告诉 EventQueueMonitor开始听事件。
      static void removeGUIInitializedListener​(GUIInitializedListener l)
      删除指定的监听器以在GUI子系统初始化时通知。
      static void removeTopLevelWindowListener​(TopLevelWindowListener l)
      删除指定的侦听器，以便在创建或销毁顶级窗口时通知该侦听器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EventQueueMonitor

        public EventQueueMonitor​()
        创建一个新的EventQueueMonitor实例。 通常情况下，AWT Toolkit在初始化时间内才会被调用。 辅助技术本身不应该创建EventQueueMonitor实例。 相反，他们应该直接通过这个类中的静态方法来引用它，例如， getCurrentMousePosition()或者通过询问Toolkit来获取实例，例如Toolkit.getSystemEventQueue() 。

    • 方法详细信息

      • maybeInitialize

        public static void maybeInitialize​()
        告诉 EventQueueMonitor开始听事件。

      • eventDispatched

        public void eventDispatched​(AWTEvent theEvent)
        因为在maybeInitialize()的EventQueue注册一个监听器来处理事件。
        Specified by:
        eventDispatched在接口 AWTEventListener
        参数
        theEvent - 要处理的事件

      • getAccessibleAt

        public static Accessible getAccessibleAt​(Point p)
        在屏幕上的给定点获取Accessible对象。 如果在特定点找不到Accessible对象，返回值可能为null。
        参数
        p - 要访问的点
        结果
        在指定点 Accessible

      • isGUIInitialized

        public static boolean isGUIInitialized​()
        说明GUI子系统是否已被初始化？ 如果返回true，辅助技术可以自由地创建GUI组件实例。 如果返回值为false，则辅助技术应该注册一个GUIInitializedListener，并等待创建GUI组件实例，直到调用该监听器。
        结果
        如果GUI子系统已初始化，则为true
        另请参见：
        addGUIInitializedListener(com.sun.java.accessibility.util.GUIInitializedListener)

      • addGUIInitializedListener

        public static void addGUIInitializedListener​(GUIInitializedListener l)
        添加指定的监听器，以在GUI子系统初始化时通知。 在调用此方法之前，辅助技术应该得到isGUIInitialized()的结果。
        参数
        l - 要添加的收听者
        另请参见：
        isGUIInitialized() ， removeTopLevelWindowListener(com.sun.java.accessibility.util.TopLevelWindowListener)

      • removeGUIInitializedListener

        public static void removeGUIInitializedListener​(GUIInitializedListener l)
        删除指定的监听器以在GUI子系统初始化时通知。
        参数
        l - 要删除的侦听器
        另请参见：
        addGUIInitializedListener(com.sun.java.accessibility.util.GUIInitializedListener)

      • addTopLevelWindowListener

        public static void addTopLevelWindowListener​(TopLevelWindowListener l)
        添加当创建或销毁顶级窗口时通知的指定侦听器。
        参数
        l - 要添加的侦听器
        另请参见：
        removeTopLevelWindowListener(com.sun.java.accessibility.util.TopLevelWindowListener)

      • removeTopLevelWindowListener

        public static void removeTopLevelWindowListener​(TopLevelWindowListener l)
        删除指定的侦听器，以便在创建或销毁顶级窗口时通知该侦听器。
        参数
        l - 要删除的侦听器
        另请参见：
        addTopLevelWindowListener(com.sun.java.accessibility.util.TopLevelWindowListener)

      • getCurrentMousePosition

        public static Point getCurrentMousePosition​()
        将鼠标的最后记录位置返回到屏幕坐标。
        结果
        鼠标在屏幕坐标中的最后记录位置

      • getTopLevelWindows

        public static Window[] getTopLevelWindows​()
        返回在Java虚拟机中使用的顶级Windows的列表。
        结果
        在Java虚拟机中使用的顶级数组 Window

      • getTopLevelWindowWithFocus

        public static Window getTopLevelWindowWithFocus​()
        返回当前具有键盘焦点的顶级 Window 。
        结果
        目前拥有键盘焦点的顶级 Window
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GUIInitializedListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Interface GUIInitializedListener

  • All Superinterfaces:
    EventListener

    public interface GUIInitializedListener
extends EventListener
    GUIInitializedListener接口由EventQueueMonitor类用于在GUI子系统初始化时通知感兴趣方。 这是必要的，因为可以在GUI子系统初始化之前加载辅助技术。 其结果是，辅助技术应检查isGUIInitialized的方法EventQueueMonitor创建任何GUI组件之前。 如果返回值为true，则辅助技术可以按照与任何其他应用程序相同的线程限制来创建GUI组件。 如果返回值为false，则辅助技术应注册GUIInitializedListener与EventQueueMonitor ，以在GUI子系统初始化时通知。
    另请参见：
    EventQueueMonitor ， EventQueueMonitor.isGUIInitialized() ， EventQueueMonitor.addGUIInitializedListener(com.sun.java.accessibility.util.GUIInitializedListener) ， EventQueueMonitor.removeGUIInitializedListener(com.sun.java.accessibility.util.GUIInitializedListener)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void guiInitialized​()
      当GUI子系统初始化时调用，并且辅助技术可以创建GUI对象的实例。

    • 方法详细信息

      • guiInitialized

        void guiInitialized​()
        当GUI子系统初始化时调用，并且辅助技术可以创建GUI对象的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SwingEventMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Class SwingEventMonitor

  • java.lang.Object
    • com.sun.java.accessibility.util.AWTEventMonitor
      • com.sun.java.accessibility.util.SwingEventMonitor

  • public class SwingEventMonitor
extends AWTEventMonitor

    SwingEventMonitor通过添加一个有条件地安装在Java虚拟机中的每个Swing组件实例上的监听SwingEventMonitor扩展AWTEventMonitor 。 这些听众捕获的事件可以通过SwingEventMonitor支持的统一的监听器提供。 这样，每个AWT和Swing组件实例上的所有个别事件都会被汇总到按类别细分的一组监听器中（有关类别，请参阅EventID ）。

    该类依赖于EventQueueMonitor ，它为创建顶级容器提供了基本级别的支持。

    因为这个类扩展了AWTEventMonitor ，所以没有必要同时使用这个类和AWTEventMonitor 。 如果你想监视AWT和Swing组件，你应该只使用这个类。

    另请参见：
    AWTEventMonitor

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected static EventListenerList listenerList
      其他类注册的所有听众的主列表。

      • Fields inherited from class com.sun.java.accessibility.util.AWTEventMonitor

        actionListener, adjustmentListener, componentListener, componentWithFocus, containerListener, focusListener, itemListener, keyListener, mouseListener, mouseMotionListener, textListener, windowListener

    • 构造方法摘要

      构造方法
      Constructor 描述
      SwingEventMonitor​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static void addAncestorListener​(AncestorListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ANCESTOR事件。
      static void addCaretListener​(CaretListener l)
      添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 CARET事件。
      static void addCellEditorListener​(CellEditorListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 CELLEDITOR事件。
      static void addChangeListener​(ChangeListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 CHANGE事件。
      static void addColumnModelListener​(TableColumnModelListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 COLUMNMODEL事件。
      static void addDocumentListener​(DocumentListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 DOCUMENT事件。
      static void addInternalFrameListener​(InternalFrameListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 INTERNALFRAME事件。
      static void addListDataListener​(ListDataListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 LISTDATA个事件。
      static void addListSelectionListener​(ListSelectionListener l)
      添加指定的侦听器，以便在Java虚拟机中发生的每个组件实例上接收所有 LISTSELECTION事件。
      static void addMenuListener​(MenuListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 MENU事件。
      static void addPopupMenuListener​(PopupMenuListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 POPUPMENU事件。
      static void addPropertyChangeListener​(PropertyChangeListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 PROPERTYCHANGE事件。
      static void addTableModelListener​(TableModelListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 TABLEMODEL事件。
      static void addTreeExpansionListener​(TreeExpansionListener l)
      添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 TREEEXPANSION事件。
      static void addTreeModelListener​(TreeModelListener l)
      添加指定的侦听器，以在Java虚拟机中发生的每个组件实例上接收所有 TREEMODEL事件。
      static void addTreeSelectionListener​(TreeSelectionListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 TREESELECTION事件。
      static void addUndoableEditListener​(UndoableEditListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 UNDOABLEEDIT事件。
      static void addVetoableChangeListener​(VetoableChangeListener l)
      添加指定的侦听器，以在Java虚拟机中发生的每个组件实例上接收所有 VETOABLECHANGE事件。
      static void removeAncestorListener​(AncestorListener l)
      删除指定的侦听器，使其不再接收 ANCESTOR事件。
      static void removeCaretListener​(CaretListener l)
      移除指定的侦听器，使其不再接收 CARET事件。
      static void removeCellEditorListener​(CellEditorListener l)
      删除指定的侦听器，使其不再接收 CELLEDITOR事件。
      static void removeChangeListener​(ChangeListener l)
      删除指定的侦听器，使其不再接收 CHANGE个事件。
      static void removeColumnModelListener​(TableColumnModelListener l)
      移除指定的侦听器，使其不再接收 COLUMNMODEL个事件。
      static void removeDocumentListener​(DocumentListener l)
      删除指定的侦听器，使其不再接收 DOCUMENT事件。
      static void removeInternalFrameListener​(InternalFrameListener l)
      删除指定的侦听器，使其不再接收 INTERNALFRAME个事件。
      static void removeListDataListener​(ListDataListener l)
      移除指定的侦听器，使其在发生事件时不再接收 LISTDATA事件。
      static void removeListSelectionListener​(ListSelectionListener l)
      删除指定的侦听器，使其不再接收 LISTSELECTION事件。
      static void removeMenuListener​(MenuListener l)
      删除指定的侦听器，使其不再接收 270434312045454事件。
      static void removePopupMenuListener​(PopupMenuListener l)
      移除指定的侦听器，使其不再接收 POPUPMENU事件。
      static void removePropertyChangeListener​(PropertyChangeListener l)
      删除指定的侦听器，使其不再接收 PROPERTYCHANGE事件。
      static void removeTableModelListener​(TableModelListener l)
      删除指定的侦听器，使其不再接收 TABLEMODEL事件。
      static void removeTreeExpansionListener​(TreeExpansionListener l)
      删除指定的侦听器，使其不再接收 TREEEXPANSION个事件。
      static void removeTreeModelListener​(TreeModelListener l)
      移除指定的侦听器，使其不再接收 TREEMODEL个事件。
      static void removeTreeSelectionListener​(TreeSelectionListener l)
      删除指定的侦听器，使其不再接收 TREESELECTION事件。
      static void removeUndoableEditListener​(UndoableEditListener l)
      删除指定的侦听器，使其不再接收 UNDOABLEEDIT事件。
      static void removeVetoableChangeListener​(VetoableChangeListener l)
      删除指定的侦听器，使其不再接收 VETOABLECHANGE事件。

      • Methods inherited from class com.sun.java.accessibility.util.AWTEventMonitor

        addActionListener, addAdjustmentListener, addComponentListener, addContainerListener, addFocusListener, addItemListener, addKeyListener, addMouseListener, addMouseMotionListener, addTextListener, addWindowListener, getComponentWithFocus, removeActionListener, removeAdjustmentListener, removeComponentListener, removeContainerListener, removeFocusListener, removeItemListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeTextListener, removeWindowListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected static final EventListenerList listenerList
        其他类注册的所有听众的主列表。 这只能通过调用此类中的add或remove listener方法来公开修改。

    • 构造方法详细信息

      • SwingEventMonitor

        public SwingEventMonitor​()

    • 方法详细信息

      • addAncestorListener

        public static void addAncestorListener​(AncestorListener l)
        添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有ANCESTOR事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeAncestorListener(javax.swing.event.AncestorListener)

      • removeAncestorListener

        public static void removeAncestorListener​(AncestorListener l)
        删除指定的侦听器，使其在发生事件时不再接收 ANCESTOR事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addAncestorListener(javax.swing.event.AncestorListener)

      • addCaretListener

        public static void addCaretListener​(CaretListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有CARET事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeCaretListener(javax.swing.event.CaretListener)

      • removeCaretListener

        public static void removeCaretListener​(CaretListener l)
        删除指定的侦听器，使其在发生事件时不再接收 CARET事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addCaretListener(javax.swing.event.CaretListener)

      • addCellEditorListener

        public static void addCellEditorListener​(CellEditorListener l)
        添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有CELLEDITOR事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的收听者
        另请参见：
        removeCellEditorListener(javax.swing.event.CellEditorListener)

      • removeCellEditorListener

        public static void removeCellEditorListener​(CellEditorListener l)
        删除指定的侦听器，使其不再接收 CELLEDITOR事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addCellEditorListener(javax.swing.event.CellEditorListener)

      • addChangeListener

        public static void addChangeListener​(ChangeListener l)
        添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有CHANGE事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        public static void removeChangeListener​(ChangeListener l)
        删除指定的侦听器，使其不再接收 CHANGE事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener)

      • addColumnModelListener

        public static void addColumnModelListener​(TableColumnModelListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有COLUMNMODEL事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeColumnModelListener(javax.swing.event.TableColumnModelListener)

      • removeColumnModelListener

        public static void removeColumnModelListener​(TableColumnModelListener l)
        删除指定的侦听器，使其不再接收 COLUMNMODEL事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addColumnModelListener(javax.swing.event.TableColumnModelListener)

      • addDocumentListener

        public static void addDocumentListener​(DocumentListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有DOCUMENT个事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeDocumentListener(javax.swing.event.DocumentListener)

      • removeDocumentListener

        public static void removeDocumentListener​(DocumentListener l)
        移除指定的侦听器，使其不再接收 DOCUMENT事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addDocumentListener(javax.swing.event.DocumentListener)

      • addListDataListener

        public static void addListDataListener​(ListDataListener l)
        添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有LISTDATA事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的收听者
        另请参见：
        removeListDataListener(javax.swing.event.ListDataListener)

      • removeListDataListener

        public static void removeListDataListener​(ListDataListener l)
        删除指定的侦听器，使其不再接收 LISTDATA事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addListDataListener(javax.swing.event.ListDataListener)

      • addListSelectionListener

        public static void addListSelectionListener​(ListSelectionListener l)
        添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有LISTSELECTION事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeListSelectionListener(javax.swing.event.ListSelectionListener)

      • removeListSelectionListener

        public static void removeListSelectionListener​(ListSelectionListener l)
        移除指定的侦听器，使其不再接收 LISTSELECTION事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)

      • addMenuListener

        public static void addMenuListener​(MenuListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有MENU事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeMenuListener(javax.swing.event.MenuListener)

      • removeMenuListener

        public static void removeMenuListener​(MenuListener l)
        移除指定的侦听器，使其不再接收 MENU事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addMenuListener(javax.swing.event.MenuListener)

      • addPopupMenuListener

        public static void addPopupMenuListener​(PopupMenuListener l)
        添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有POPUPMENU事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removePopupMenuListener(javax.swing.event.PopupMenuListener)

      • removePopupMenuListener

        public static void removePopupMenuListener​(PopupMenuListener l)
        删除指定的侦听器，使其不再接收 POPUPMENU事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addPopupMenuListener(javax.swing.event.PopupMenuListener)

      • addTableModelListener

        public static void addTableModelListener​(TableModelListener l)
        添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有TABLEMODEL事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的监听器
        另请参见：
        removeTableModelListener(javax.swing.event.TableModelListener)

      • removeTableModelListener

        public static void removeTableModelListener​(TableModelListener l)
        移除指定的侦听器，使其不再接收 TABLEMODEL事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addTableModelListener(javax.swing.event.TableModelListener)

      • addTreeExpansionListener

        public static void addTreeExpansionListener​(TreeExpansionListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有TREEEXPANSION事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeTreeExpansionListener(javax.swing.event.TreeExpansionListener)

      • removeTreeExpansionListener

        public static void removeTreeExpansionListener​(TreeExpansionListener l)
        删除指定的侦听器，使其在发生事件时不再接收 TREEEXPANSION事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addTreeExpansionListener(javax.swing.event.TreeExpansionListener)

      • addTreeModelListener

        public static void addTreeModelListener​(TreeModelListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有TREEMODEL事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeTreeModelListener(javax.swing.event.TreeModelListener)

      • removeTreeModelListener

        public static void removeTreeModelListener​(TreeModelListener l)
        移除指定的侦听器，使其不再接收 TREEMODEL事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addTreeModelListener(javax.swing.event.TreeModelListener)

      • addTreeSelectionListener

        public static void addTreeSelectionListener​(TreeSelectionListener l)
        添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有TREESELECTION个事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeTreeSelectionListener(javax.swing.event.TreeSelectionListener)

      • removeTreeSelectionListener

        public static void removeTreeSelectionListener​(TreeSelectionListener l)
        删除指定的侦听器，使其不再接收 TREESELECTION事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addTreeSelectionListener(javax.swing.event.TreeSelectionListener)

      • addUndoableEditListener

        public static void addUndoableEditListener​(UndoableEditListener l)
        添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有UNDOABLEEDIT事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeUndoableEditListener(javax.swing.event.UndoableEditListener)

      • removeUndoableEditListener

        public static void removeUndoableEditListener​(UndoableEditListener l)
        删除指定的侦听器，使其不再接收到 UNDOABLEEDIT事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addUndoableEditListener(javax.swing.event.UndoableEditListener)

      • addInternalFrameListener

        public static void addInternalFrameListener​(InternalFrameListener l)
        添加指定的侦听器，以便在Java虚拟机中发生的每个组件实例上接收所有INTERNALFRAME事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeInternalFrameListener(javax.swing.event.InternalFrameListener)

      • removeInternalFrameListener

        public static void removeInternalFrameListener​(InternalFrameListener l)
        删除指定的侦听器，使其在发生事件时不再接收 INTERNALFRAME事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addInternalFrameListener(javax.swing.event.InternalFrameListener)

      • addPropertyChangeListener

        public static void addPropertyChangeListener​(PropertyChangeListener l)
        添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有PROPERTYCHANGE事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的监听器
        另请参见：
        removePropertyChangeListener(java.beans.PropertyChangeListener)

      • removePropertyChangeListener

        public static void removePropertyChangeListener​(PropertyChangeListener l)
        删除指定的侦听器，使其在发生事件时不再接收 PROPERTYCHANGE事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener)

      • addVetoableChangeListener

        public static void addVetoableChangeListener​(VetoableChangeListener l)
        添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有VETOABLECHANGE事件。

        注意：此侦听器将自动添加到在调用此方法之后创建的所有组件实例。 此外，它仅添加到支持此侦听器类型的组件实例。

        参数
        l - 要添加的侦听器
        另请参见：
        removeVetoableChangeListener(java.beans.VetoableChangeListener)

      • removeVetoableChangeListener

        public static void removeVetoableChangeListener​(VetoableChangeListener l)
        移除指定的侦听器，使其在发生事件时不再接收 VETOABLECHANGE事件。
        参数
        l - 要删除的侦听器
        另请参见：
        addVetoableChangeListener(java.beans.VetoableChangeListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TopLevelWindowListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Interface TopLevelWindowListener

  • All Superinterfaces:
    EventListener

    public interface TopLevelWindowListener
extends EventListener
    TopLevelWindowListener接口由EventQueueMonitor类用于在Java虚拟机中创建或销毁顶级窗口时通知感兴趣方。 希望对顶级窗口事件表达兴趣的课程应实现此接口，并通过调用EventQueueMonitor.addTopLevelWindowListener类方法向EventQueueMonitor注册。
    另请参见：
    EventQueueMonitor ， EventQueueMonitor.addTopLevelWindowListener(com.sun.java.accessibility.util.TopLevelWindowListener) ， EventQueueMonitor.removeTopLevelWindowListener(com.sun.java.accessibility.util.TopLevelWindowListener)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void topLevelWindowCreated​(Window w)
      当创建新的顶级窗口时调用。
      void topLevelWindowDestroyed​(Window w)
      当顶级窗口被销毁时调用。

    • 方法详细信息

      • topLevelWindowCreated

        void topLevelWindowCreated​(Window w)
        当创建新的顶级窗口时调用。
        参数
        w - 创建的窗口

      • topLevelWindowDestroyed

        void topLevelWindowDestroyed​(Window w)
        当顶级窗口被销毁时调用。
        参数
        w - 被破坏的窗口
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Translator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.accessibility
软件包 com.sun.java.accessibility.util

Class Translator

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • com.sun.java.accessibility.util.Translator
  • All Implemented Interfaces:
    Accessible ， AccessibleComponent

    public class Translator
extends AccessibleContext
implements Accessible, AccessibleComponent

    Translator类为不实现接口Accessible对象提供了一个到接口Accessible的翻译。 辅助技术可以使用getAccessible的类方法Translator以获得实现接口的对象Accessible 。 如果传入的对象已经实现了接口Accessible ， getAccessible只返回对象。

    辅助技术如何使用Translator课程的一个例子如下：

      Accessible accessible = Translator.getAccessible(someObj);
    // obtain information from the 'accessible' object.

    注意：此实现缺少许多事情，而不是实现工具包的辅助功能的推荐方法。 一个工具包的组件应该直接实现Accessible接口，而不是依赖这个代码。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Object source
      源对象需要翻译。

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Constructor 描述
      Translator​()
      创建一个新的 Translator 。
      Translator​(Object o)
      创建一个新的 Translator与源对象o。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addFocusListener​(FocusListener l)
      添加指定的 FocusListener以从该组件接收焦点事件。
      void addPropertyChangeListener​(PropertyChangeListener l)
      添加 PropertyChangeListener到侦听器列表。
      boolean contains​(Point p)
      检查指定的 Point是否在该对象的边界内，其中 Point是相对于对象的坐标系。
      boolean equals​(Object o)
      如果此对象与传入的对象相同，则返回true。
      static Accessible getAccessible​(Object o)
      获取实现接口 Accessible的对象。
      Accessible getAccessibleAt​(Point p)
      返回包含在本地坐标Point（如果存在）的可访问子项。
      Accessible getAccessibleChild​(int i)
      返回对象的第n个可访问的小孩。
      int getAccessibleChildrenCount​()
      返回对象中可访问的子项数。
      AccessibleContext getAccessibleContext​()
      返回此对象。
      String getAccessibleDescription​()
      获取此对象的可访问描述。
      int getAccessibleIndexInParent​()
      在其可访问的父项中获取此对象的索引。
      String getAccessibleName​()
      获取此对象的可访问名称。
      Accessible getAccessibleParent​()
      获取此对象的可访问父级。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      给定一个已经填充的状态的这个对象的状态。
      Color getBackground​()
      获取此对象的背景 Color 。
      Rectangle getBounds​()
      返回此对象的当前边界。
      Cursor getCursor​()
      获取此对象的 Cursor 。
      Font getFont​()
      获取此对象的 Font 。
      FontMetrics getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      Color getForeground​()
      获取此对象的前景 Color 。
      Locale getLocale​()
      获取组件的 Locale 。
      Point getLocation​()
      返回对象相对于父对象的位置。
      Point getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Dimension getSize​()
      返回此对象的当前大小。
      Object getSource​()
      获取来源 Object的 Translator 。
      protected static Class<?> getTranslatorClass​(Class<?> c)
      找到这个班的翻译。
      int hashCode​()
      返回哈希码。
      boolean isEnabled​()
      确定对象是否已启用。
      boolean isFocusTraversable​()
      返回此对象是否可以接受焦点。
      boolean isShowing​()
      确定对象是否显示。
      boolean isVisible​()
      确定对象是否可见。
      void removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void removePropertyChangeListener​(PropertyChangeListener l)
      从侦听器列表中删除 PropertyChangeListener 。
      void requestFocus​()
      请求关注此对象。
      void setAccessibleDescription​(String s)
      设置此对象的可访问性描述。
      void setAccessibleName​(String s)
      设置此对象的名称。
      void setBackground​(Color c)
      设置此对象的背景 Color 。
      void setBounds​(Rectangle r)
      设置此对象的当前边界。
      void setCursor​(Cursor c)
      设置这个对象的 Cursor 。
      void setEnabled​(boolean b)
      设置对象的已启用状态。
      void setFont​(Font f)
      设置此对象的 Font 。
      void setForeground​(Color c)
      设置此对象的前台 Color 。
      void setLocation​(Point p)
      设置对象相对于父对象的位置。
      void setSize​(Dimension d)
      设置此对象的当前大小。
      void setSource​(Object o)
      设置 Translator的源对象。
      void setVisible​(boolean b)
      设置对象的可见状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleComponent, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleParent

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • source

        protected Object source
        源对象需要翻译。

    • 构造方法详细信息

      • Translator

        public Translator​()
        创建一个新的Translator 。 调用该构造函数后，您必须调用setSource方法来设置要翻译的对象。

      • Translator

        public Translator​(Object o)
        创建一个新的 Translator与源对象o。
        参数
        o - 不实现接口的组件Accessible

    • 方法详细信息

      • getTranslatorClass

        protected static Class<?> getTranslatorClass​(Class<?> c)
        找到这个班的翻译。 如果这个类不明确存在，请尝试其超类等等。
        参数
        c - 一类
        结果
        Translator通过的 Translator类

      • getAccessible

        public static Accessible getAccessible​(Object o)
        获取实现接口Accessible的对象。 如果传入的对象已经实现了接口Accessible ， getAccessible只返回对象。
        参数
        o - 一个对象; 如果在null中传递null，则返回null
        结果
        一个 Object ，可能是 Object传入，实现 Accessible接口为 Object通过了

      • getSource

        public Object getSource​()
        获取来源 Object的 Translator 。
        结果
        来源 Object的 Translator

      • setSource

        public void setSource​(Object o)
        设置源对象的 Translator 。
        参数
        o - 不实现接口可访问的组件

      • equals

        public boolean equals​(Object o)
        如果此对象与传入的对象相同，则返回true。
        重写：
        equals在 Object
        参数
        o - Object反对
        结果
        如果这是相同的对象，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回哈希码。
        重写：
        hashCode中的 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        返回此对象。
        Specified by:
        getAccessibleContext在接口 Accessible
        结果
        AccessibleContext与此对象关联

      • getAccessibleName

        public String getAccessibleName​()
        获取此对象的可访问名称。
        重写：
        getAccessibleName在 AccessibleContext
        结果
        对象的本地化名称; 如果此对象没有名称，则可以为null
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • setAccessibleName

        public void setAccessibleName​(String s)
        设置此对象的名称。
        重写：
        setAccessibleName在 AccessibleContext
        参数
        s - 对象的新的本地化名称
        另请参见：
        AccessibleContext.getAccessibleName() ， AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleDescription

        public String getAccessibleDescription​()
        获取此对象的可访问描述。
        重写：
        getAccessibleDescription在 AccessibleContext
        结果
        对象的描述; 如果此对象没有描述，则可以为null
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • setAccessibleDescription

        public void setAccessibleDescription​(String s)
        设置此对象的可访问性描述。
        重写：
        setAccessibleDescription在 AccessibleContext
        参数
        s - 对象的新的本地化描述
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String) ， AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        Specified by:
        getAccessibleRole在 AccessibleContext
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        给定一个已经填充的状态的这个对象的状态。 这个方法是由子类使用，所以它们不需要检查一切。
        Specified by:
        getAccessibleStateSet在 AccessibleContext
        结果
        包含对象的当前状态的 AccessibleStateSet的实例
        另请参见：
        AccessibleStateSet ， AccessibleState ， AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleParent

        public Accessible getAccessibleParent​()
        获取此对象的可访问父级。
        重写：
        getAccessibleParent在 AccessibleContext
        结果
        该对象的可访问父级; 如果此对象没有可访问的父对象，则可以为null

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent​()
        在其可访问的父项中获取此对象的索引。
        Specified by:
        getAccessibleIndexInParent在 AccessibleContext
        结果
        -1对象没有可访问的父项; 否则，其可访问父级中的子级索引
        另请参见：
        AccessibleContext.getAccessibleParent() ，
AccessibleContext.getAccessibleChildrenCount() ，
AccessibleContext.getAccessibleChild(int)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount​()
        返回对象中可访问的子项数。
        Specified by:
        getAccessibleChildrenCount在 AccessibleContext
        结果
        对象中可访问的孩子的数量

      • getAccessibleChild

        public Accessible getAccessibleChild​(int i)
        返回对象的第n个可访问的小孩。
        Specified by:
        getAccessibleChild在 AccessibleContext
        参数
        i - 基于零的儿童索引
        结果
        对象的第n个可访问的小孩
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale​()
                 throws IllegalComponentStateException
        获取组件的Locale 。 如果组件没有区域设置，则返回其父项的区域设置。
        Specified by:
        getLocale在 AccessibleContext
        结果
        对象的 Locale
        异常
        IllegalComponentStateException - 如果组件没有自己的区域设置，并且尚未添加到包含层次结构中，以便可以从包含的父项确定区域设置

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener l)
        添加一个PropertyChangeListener到监听器列表。 所有属性都注册了监听器。
        重写：
        addPropertyChangeListener在 AccessibleContext
        参数
        l - 要添加的PropertyChangeListener
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY ， AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY ， AccessibleContext.ACCESSIBLE_STATE_PROPERTY ， AccessibleContext.ACCESSIBLE_VALUE_PROPERTY ， AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY ， AccessibleContext.ACCESSIBLE_TEXT_PROPERTY ， AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener l)
        从侦听器列表中删除 PropertyChangeListener 。
        重写：
        removePropertyChangeListener在 AccessibleContext
        参数
        l - 要删除的PropertyChangeListener

      • getBackground

        public Color getBackground​()
        获取此对象的背景 Color 。
        Specified by:
        getBackground在接口 AccessibleComponent
        结果
        如果支持，对象的背景Color ; 否则为null
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • setBackground

        public void setBackground​(Color c)
        设置此对象的背景 Color 。
        Specified by:
        setBackground在接口 AccessibleComponent
        参数
        c - 新的 Color为背景
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • getForeground

        public Color getForeground​()
        获取该对象的前台 Color 。
        Specified by:
        getForeground在接口 AccessibleComponent
        结果
        如果支持，则该对象的前景Color ; 否则为null
        另请参见：
        AccessibleComponent.setForeground(java.awt.Color)

      • setForeground

        public void setForeground​(Color c)
        设置该对象的前景 Color 。
        Specified by:
        setForeground在接口 AccessibleComponent
        参数
        c - 新的 Color为前景
        另请参见：
        AccessibleComponent.getForeground()

      • getCursor

        public Cursor getCursor​()
        获取此对象的 Cursor 。
        Specified by:
        getCursor在接口 AccessibleComponent
        结果
        如果支持，则该对象的Cursor; 否则为null
        另请参见：
        AccessibleComponent.setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor​(Cursor c)
        设置此对象的 Cursor 。
        Specified by:
        setCursor在接口 AccessibleComponent
        参数
        c - 该对象的新 Cursor
        另请参见：
        AccessibleComponent.getCursor()

      • getFont

        public Font getFont​()
        获取此对象的 Font 。
        Specified by:
        getFont在接口 AccessibleComponent
        结果
        如果支持，则该对象为Font ; 否则为null
        另请参见：
        AccessibleComponent.setFont(java.awt.Font)

      • setFont

        public void setFont​(Font f)
        设置此对象的 Font 。
        Specified by:
        setFont在接口 AccessibleComponent
        参数
        f - 该对象的新 Font
        另请参见：
        AccessibleComponent.getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics​(Font f)
        获取此对象的 FontMetrics 。
        Specified by:
        getFontMetrics在接口 AccessibleComponent
        参数
        f - Font
        结果
        如果支持， FontMetrics的对象; 否则为null
        另请参见：
        getFont()

      • isEnabled

        public boolean isEnabled​()
        确定对象是否已启用。
        Specified by:
        isEnabled在接口 AccessibleComponent
        结果
        如果对象启用，则为true; 否则，假
        另请参见：
        AccessibleComponent.setEnabled(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.ENABLED ， AccessibleStateSet

      • setEnabled

        public void setEnabled​(boolean b)
        设置对象的已启用状态。
        Specified by:
        setEnabled在接口 AccessibleComponent
        参数
        b - 如果为true，则启用此对象; 否则，禁用它
        另请参见：
        AccessibleComponent.isEnabled()

      • isVisible

        public boolean isVisible​()
        确定对象是否可见。
        Specified by:
        isVisible在接口 AccessibleComponent
        结果
        如果对象可见，则为true; 否则，假
        另请参见：
        AccessibleComponent.setVisible(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.VISIBLE ， AccessibleStateSet

      • setVisible

        public void setVisible​(boolean b)
        设置对象的可见状态。
        Specified by:
        setVisible在接口 AccessibleComponent
        参数
        b - 如果为true，则显示此对象; 否则隐藏它
        另请参见：
        AccessibleComponent.isVisible()

      • isShowing

        public boolean isShowing​()
        确定对象是否显示。 这是通过检查对象和对象的祖先的可见性来确定的。
        Specified by:
        isShowing在接口 AccessibleComponent
        结果
        如果对象显示，则为true; 否则，假

      • contains

        public boolean contains​(Point p)
        检查指定的 Point是否在该对象的边界内，其中 Point是相对于对象的坐标系。
        Specified by:
        contains在接口 AccessibleComponent
        参数
        p - 相对于对象的坐标系的 Point
        结果
        如果对象包含Point ; 否则为虚假
        另请参见：
        AccessibleComponent.getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen​()
        返回对象在屏幕上的位置。
        Specified by:
        getLocationOnScreen在接口 AccessibleComponent
        结果
        屏幕上物体的位置; 如果此对象不在屏幕上，则可以为null
        另请参见：
        AccessibleComponent.getBounds() ， AccessibleComponent.getLocation()

      • getLocation

        public Point getLocation​()
        返回对象相对于父对象的位置。
        Specified by:
        getLocation在接口 AccessibleComponent
        结果
        对象相对于父对象的位置; 如果此对象或其父对象不在屏幕上，则可以为null
        另请参见：
        AccessibleComponent.getBounds() ， AccessibleComponent.getLocationOnScreen()

      • setLocation

        public void setLocation​(Point p)
        设置对象相对于父对象的位置。
        Specified by:
        setLocation在接口 AccessibleComponent
        参数
        p - 左上角的新位置
        另请参见：
        AccessibleComponent.getLocation()

      • getBounds

        public Rectangle getBounds​()
        返回此对象的当前边界。
        Specified by:
        getBounds接口 AccessibleComponent
        结果
        物体的当前界限 如果此对象不在屏幕上，则可以为null
        另请参见：
        AccessibleComponent.contains(java.awt.Point)

      • setBounds

        public void setBounds​(Rectangle r)
        设置此对象的当前边界。
        Specified by:
        setBounds在接口 AccessibleComponent
        参数
        r - 表示此组件边界的矩形
        另请参见：
        AccessibleComponent.getBounds()

      • getSize

        public Dimension getSize​()
        返回此对象的当前大小。
        Specified by:
        getSize在接口 AccessibleComponent
        结果
        物体的当前大小; 如果此对象不在屏幕上，则可以为null
        另请参见：
        AccessibleComponent.setSize(java.awt.Dimension)

      • setSize

        public void setSize​(Dimension d)
        设置此对象的当前大小。
        Specified by:
        setSize在接口 AccessibleComponent
        参数
        d - 指定对象的新大小的维度
        另请参见：
        AccessibleComponent.getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt​(Point p)
        返回包含在本地坐标Point（如果存在）的可访问子项。
        Specified by:
        getAccessibleAt在接口 AccessibleComponent
        参数
        p - 相对于该对象的坐标系的点
        结果
        在指定位置的可访问（如果存在）

      • isFocusTraversable

        public boolean isFocusTraversable​()
        返回此对象是否可以接受焦点。
        Specified by:
        isFocusTraversable在接口 AccessibleComponent
        结果
        true如果对象可以接受焦点; 否则为虚假
        另请参见：
        AccessibleContext.getAccessibleStateSet() ， AccessibleState.FOCUSABLE ， AccessibleState.FOCUSED ， AccessibleStateSet

      • requestFocus

        public void requestFocus​()
        请求关注此对象。
        Specified by:
        requestFocus在接口 AccessibleComponent
        另请参见：
        AccessibleComponent.isFocusTraversable()

      • addFocusListener

        public void addFocusListener​(FocusListener l)
        添加指定的 FocusListener以从该组件接收焦点事件。
        Specified by:
        addFocusListener接口 AccessibleComponent
        参数
        l - 焦点侦听器
        另请参见：
        AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener​(FocusListener l)
        删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
        Specified by:
        removeFocusListener在接口 AccessibleComponent
        参数
        l - 焦点听众; 该方法不执行任何功能，如果指定的侦听器以前未添加到此组件中，也不会抛出异常; 如果listener为null，则不会抛出异常，并且不执行任何操作。
        另请参见：
        AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.java.accessibility.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.java.accessibility.util

  • Packages that use com.sun.java.accessibility.util
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
  • Classes in com.sun.java.accessibility.util used by com.sun.java.accessibility.util
    Class 描述
    AccessibilityListenerList
    AccessibilityListenerList是Swing EventListerList课程的副本。
    AWTEventMonitor
    AWTEventMonitor实现了一套监听器，它们有条件地安装在Java虚拟机中的每个AWT组件实例上。
    GUIInitializedListener
    GUIInitializedListener接口由EventQueueMonitor类用于在GUI子系统初始化时通知感兴趣方。
    TopLevelWindowListener
    当在Java虚拟机中创建或销毁顶级窗口时， EventQueueMonitor类将使用TopLevelWindowListener接口通知有关方。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.java.accessibility.util.AccessibilityEventMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.java.accessibility.util.AccessibilityEventMonitor

No usage of com.sun.java.accessibility.util.AccessibilityEventMonitor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.java.accessibility.util.AccessibilityListenerList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.java.accessibility.util.AccessibilityListenerList

  • Packages that use AccessibilityListenerList
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。

    • Uses of AccessibilityListenerList in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as AccessibilityListenerList
      Modifier and Type Field 描述
      protected static AccessibilityListenerList AccessibilityEventMonitor.listenerList
      目前注册的人数为PropertyChangeListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.java.accessibility.util.AWTEventMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.java.accessibility.util.AWTEventMonitor

  • Packages that use AWTEventMonitor
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。

    • Uses of AWTEventMonitor in com.sun.java.accessibility.util

      Subclasses of AWTEventMonitor in com.sun.java.accessibility.util
      Modifier and Type Class 描述
      class  SwingEventMonitor
      SwingEventMonitor通过添加一个有条件地安装在Java虚拟机中的每个Swing组件实例上的监听SwingEventMonitor扩展AWTEventMonitor 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.java.accessibility.util.EventID (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.java.accessibility.util.EventID

No usage of com.sun.java.accessibility.util.EventID
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.java.accessibility.util.EventQueueMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.java.accessibility.util.EventQueueMonitor

No usage of com.sun.java.accessibility.util.EventQueueMonitor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.java.accessibility.util.SwingEventMonitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.java.accessibility.util.SwingEventMonitor

No usage of com.sun.java.accessibility.util.SwingEventMonitor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.java.accessibility.util.Translator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.java.accessibility.util.Translator

No usage of com.sun.java.accessibility.util.Translator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.java.accessibility.util.GUIInitializedListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.java.accessibility.util.GUIInitializedListener

  • Packages that use GUIInitializedListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。

    • Uses of GUIInitializedListener in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util with parameters of type GUIInitializedListener
      Modifier and Type 方法 描述
      static void EventQueueMonitor.addGUIInitializedListener​(GUIInitializedListener l)
      添加指定的监听器，以在GUI子系统初始化时通知。
      static void EventQueueMonitor.removeGUIInitializedListener​(GUIInitializedListener l)
      删除指定的监听器以在GUI子系统初始化时通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.java.accessibility.util.TopLevelWindowListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.java.accessibility.util.TopLevelWindowListener

  • Packages that use TopLevelWindowListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。

    • Uses of TopLevelWindowListener in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util with parameters of type TopLevelWindowListener
      Modifier and Type 方法 描述
      static void EventQueueMonitor.addTopLevelWindowListener​(TopLevelWindowListener l)
      添加当创建或销毁顶级窗口时通知的指定侦听器。
      static void EventQueueMonitor.removeTopLevelWindowListener​(TopLevelWindowListener l)
      删除指定的侦听器，以便在创建或销毁顶级窗口时通知该侦听器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AnnotatedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface AnnotatedType

  • All Superinterfaces:
    Type
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface AnnotatedType
extends Type
    表示注释类型。 例如：
      @NonNull String
      @Positive int
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationDesc[] annotations​()
      已过时。
      返回与此类型相关联的注释。
      Type underlyingType​()
      已过时。
      返回底层类型。

      • Methods inherited from interface com.sun.javadoc.Type

        asAnnotatedType, asAnnotationTypeDoc, asClassDoc, asParameterizedType, asTypeVariable, asWildcardType, dimension, getElementType, isPrimitive, qualifiedTypeName, simpleTypeName, toString, typeName

    • 方法详细信息

      • annotations

        AnnotationDesc[] annotations​()
        已过时。
        返回与此类型相关联的注释。
        结果
        与此类型相关联的注释

      • underlyingType

        Type underlyingType​()
        已过时。
        返回底层类型。
        结果
        底层类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationDesc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface AnnotationDesc

  • 已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface AnnotationDesc
    表示注释。 注释将值与注释类型的每个元素相关联。
    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  AnnotationDesc.ElementValuePair
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationTypeDoc annotationType​()
      已过时。
      返回此注释的注释类型。
      AnnotationDesc.ElementValuePair[] elementValues​()
      已过时。
      返回此注释的元素及其值。
      boolean isSynthesized​()
      已过时。
      检查注释上的合成位。

    • 方法详细信息

      • annotationType

        AnnotationTypeDoc annotationType​()
        已过时。
        返回此注释的注释类型。
        结果
        此注释的注释类型。

      • elementValues

        AnnotationDesc.ElementValuePair[] elementValues​()
        已过时。
        返回此注释的元素及其值。 只有包含在注释中明确存在的那些，而不是那些假定它们的默认值。 如果没有，返回一个空数组。
        结果
        这个注释的元素及其值。

      • isSynthesized

        boolean isSynthesized​()
        已过时。
        检查注释上的合成位。
        结果
        如果注释是合成的，则为true。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationDesc.ElementValuePair (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface AnnotationDesc.ElementValuePair

  • Enclosing interface:
    AnnotationDesc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public static interface AnnotationDesc.ElementValuePair
    表示注释类型元素与其值之一的关联。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationTypeElementDoc element​()
      已过时。
      返回注释类型元素。
      AnnotationValue value​()
      已过时。
      返回与注释类型元素关联的值。

    • 方法详细信息

      • element

        AnnotationTypeElementDoc element​()
        已过时。
        返回注释类型元素。
        结果
        注释类型元素。

      • value

        AnnotationValue value​()
        已过时。
        返回与注释类型元素关联的值。
        结果
        与注释类型元素关联的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationTypeDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface AnnotationTypeDoc

  • All Superinterfaces:
    ClassDoc ， Comparable<Object> ， Doc ， ProgramElementDoc ， Type
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface AnnotationTypeDoc
extends ClassDoc
    表示注释类型。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationTypeElementDoc[] elements​()
      已过时。
      返回此注释类型的元素。

      • Methods inherited from interface com.sun.javadoc.ClassDoc

        constructors, constructors, definesSerializableFields, enumConstants, fields, fields, findClass, importedClasses, importedPackages, innerClasses, innerClasses, interfaces, interfaceTypes, isAbstract, isExternalizable, isSerializable, methods, methods, serializableFields, serializationMethods, subclassOf, superclass, superclassType, typeParameters, typeParamTags

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName

      • Methods inherited from interface com.sun.javadoc.Type

        asAnnotatedType, asAnnotationTypeDoc, asClassDoc, asParameterizedType, asTypeVariable, asWildcardType, dimension, getElementType, isPrimitive, qualifiedTypeName, simpleTypeName, toString, typeName

    • 方法详细信息

      • elements

        AnnotationTypeElementDoc[] elements​()
        已过时。
        返回此注释类型的元素。 如果没有，返回一个空数组。
        结果
        这个注释类型的元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationTypeElementDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface AnnotationTypeElementDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， ExecutableMemberDoc ， MemberDoc ， MethodDoc ， ProgramElementDoc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface AnnotationTypeElementDoc
extends MethodDoc
    表示注释类型的元素。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationValue defaultValue​()
      已过时。
      返回此元素的默认值。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.ExecutableMemberDoc

        flatSignature, isNative, isSynchronized, isVarArgs, parameters, paramTags, receiverType, signature, thrownExceptions, thrownExceptionTypes, throwsTags, typeParameters, typeParamTags

      • Methods inherited from interface com.sun.javadoc.MemberDoc

        isSynthetic

      • Methods inherited from interface com.sun.javadoc.MethodDoc

        isAbstract, isDefault, overriddenClass, overriddenMethod, overriddenType, overrides, returnType

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName

    • 方法详细信息

      • defaultValue

        AnnotationValue defaultValue​()
        已过时。
        返回此元素的默认值。 如果此元素没有默认值，则返回null。
        结果
        该元素的默认值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface AnnotationValue

  • 已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface AnnotationValue
    表示注释类型元素的值。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      String toString​()
      已过时。
      返回值的字符串表示形式。
      Object value​()
      已过时。
      返回值。

    • 方法详细信息

      • value

        Object value​()
        已过时。
        返回值。 返回的对象的类型是以下之一：
        • 一个原始类型的包装类
        • String
        • Type （代表一个类文字）
        • FieldDoc （表示枚举常数）
        • AnnotationDesc
        • AnnotationValue[]
        结果
        价值。

      • toString

        String toString​()
        已过时。
        返回值的字符串表示形式。
        重写：
        toString在 Object
        结果
        Java语言注释值表达式的文本，其值为此元素的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface ClassDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， ProgramElementDoc ， Type
    All Known Subinterfaces:
    AnnotationTypeDoc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface ClassDoc
extends ProgramElementDoc, Type
    表示一个java类或接口，并提供对类的信息，类的注释和标签以及类的成员的访问。 如果在此运行javadoc中处理了ClassDoc，则仅存在ClassDoc。 在本次运行中可能已经或可能未被处理过的类的引用使用Type（如果可能的话可以转换为ClassDoc）。
    从以下版本开始：
    1.2
    另请参见：
    Type

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      ConstructorDoc[] constructors​()
      已过时。
      返回这个类中的 included构造函数。
      ConstructorDoc[] constructors​(boolean filter)
      已过时。
      在此类中返回构造函数，过滤到指定的 access modifier option 。
      boolean definesSerializableFields​()
      已过时。
      如果使用特殊类成员 serialPersistentFields显式定义可序列化字段，则返回true。
      FieldDoc[] enumConstants​()
      已过时。
      如果这是枚举类型，则返回枚举常量。
      FieldDoc[] fields​()
      已过时。
      返回 此类或接口中的 included字段。
      FieldDoc[] fields​(boolean filter)
      已过时。
      返回此类或接口中的字段，过滤到指定的 access modifier option 。
      ClassDoc findClass​(String className)
      已过时。
      在该类doc的上下文中找到指定的类或接口。
      ClassDoc[] importedClasses​()
      已过时。
      导入声明是不应该在这里公开的实现细节。 另外，并不是所有导入的类都是通过单一类型导入的声明导入的。
      PackageDoc[] importedPackages​()
      已过时。
      导入声明是不应该在这里公开的实现细节。 此外，此方法的返回类型不允许返回所有类型导入按需的声明。
      ClassDoc[] innerClasses​()
      已过时。
      返回 included此类或接口中的嵌套类和接口。
      ClassDoc[] innerClasses​(boolean filter)
      已过时。
      返回此类或接口中的嵌套类和接口，过滤到指定的 access modifier option 。
      ClassDoc[] interfaces​()
      已过时。
      返回由此类实现的接口或此接口扩展的接口。
      Type[] interfaceTypes​()
      已过时。
      返回由此类实现的接口或此接口扩展的接口。
      boolean isAbstract​()
      已过时。
      如果这个类是抽象的，返回true。
      boolean isExternalizable​()
      已过时。
      如果这个类实现或者接口扩展，返回true java.io.Externalizable 。
      boolean isSerializable​()
      已过时。
      如果这个类实现或者接口扩展，返回true java.io.Serializable 。
      MethodDoc[] methods​()
      已过时。
      返回 此类或接口中的 included方法。
      MethodDoc[] methods​(boolean filter)
      已过时。
      在此类或接口中返回方法，过滤到指定的 access modifier option 。
      FieldDoc[] serializableFields​()
      已过时。
      返回此类或接口的Serializable字段。
      MethodDoc[] serializationMethods​()
      已过时。
      返回此类或接口的序列化方法。
      boolean subclassOf​(ClassDoc cd)
      已过时。
      测试这个类是否是指定类的子类。
      ClassDoc superclass​()
      已过时。
      返回此类的超类。
      Type superclassType​()
      已过时。
      返回此类的超类。
      TypeVariable[] typeParameters​()
      已过时。
      返回此类或接口的形式类型参数。
      ParamTag[] typeParamTags​()
      已过时。
      返回此类或接口的类型参数标签。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName

      • Methods inherited from interface com.sun.javadoc.Type

        asAnnotatedType, asAnnotationTypeDoc, asClassDoc, asParameterizedType, asTypeVariable, asWildcardType, dimension, getElementType, isPrimitive, qualifiedTypeName, simpleTypeName, toString, typeName

    • 方法详细信息

      • isAbstract

        boolean isAbstract​()
        已过时。
        如果这个类是抽象的，返回true。 为所有接口返回true。
        结果
        如果这个类是抽象的，则为true。 为所有接口返回true。

      • isSerializable

        boolean isSerializable​()
        已过时。
        如果这个类实现或者接口扩展，返回true java.io.Serializable 。 由于java.io.Externalizable扩展了java.io.Serializable ，Externalizable对象也是Serializable。
        结果
        如果此类实现或接口扩展， java.io.Serializable 。

      • isExternalizable

        boolean isExternalizable​()
        已过时。
        如果这个类实现或者接口扩展，返回true java.io.Externalizable 。
        结果
        如果此类实现或接口扩展， java.io.Externalizable 。

      • serializationMethods

        MethodDoc[] serializationMethods​()
        已过时。
        返回此类或接口的序列化方法。
        结果
        MethodDoc对象数组，表示此类或接口的序列化方法。

      • serializableFields

        FieldDoc[] serializableFields​()
        已过时。
        返回此类或接口的Serializable字段。

        返回由serial标记记录的默认字段列表
        或返回一个FieldDoc的serialPersistentField成员。 每个可序列化字段应该有一个serialField标记，由ObjectStreamField阵列组件serialPersistentField 。

        结果
        一个 FieldDoc对象的数组，用于此类或接口的可序列化字段。
        另请参见：
        definesSerializableFields() ， SerialFieldTag

      • definesSerializableFields

        boolean definesSerializableFields​()
        已过时。
        如果使用特殊类成员 serialPersistentFields显式定义可序列化字段，则返回true。
        结果
        如果使用特殊类成员 serialPersistentFields显式定义可序列化字段， serialPersistentFields 。
        另请参见：
        serializableFields() ， SerialFieldTag

      • superclass

        ClassDoc superclass​()
        已过时。
        返回此类的超类。 如果这是一个接口，则返回null。

        此方法无法适应某些通用类型的构造。 应该使用superclassType方法。

        结果
        这个类的超类的ClassDoc，如果没有超类，则为null。
        另请参见：
        superclassType()

      • superclassType

        Type superclassType​()
        已过时。
        返回此类的超类。 如果这是一个接口，则返回null。 超类由ClassDoc或ParametrizedType 。
        结果
        这个类的超类，如果没有超类，则为null。
        从以下版本开始：
        1.5

      • subclassOf

        boolean subclassOf​(ClassDoc cd)
        已过时。
        测试这个类是否是指定类的子类。 如果这是一个接口，对于除了java.lang.Object之外的所有类，返回false（为了兼容性原因，我们必须保留这个意外的行为）。
        参数
        cd - 候选超类。
        结果
        如果cd是这个类的超类，则为true。

      • interfaces

        ClassDoc[] interfaces​()
        已过时。
        返回由此类实现的接口或此接口扩展的接口。 只包括直接声明的接口，而不是继承接口。 如果没有接口，返回一个空数组。

        此方法无法适应某些通用类型的构造。 应该使用interfaceTypes方法。

        结果
        表示接口的ClassDoc对象数组。
        另请参见：
        interfaceTypes()

      • interfaceTypes

        Type[] interfaceTypes​()
        已过时。
        返回由此类实现的接口或此接口扩展的接口。 只包括直接声明的接口，而不是继承接口。 如果没有接口，返回一个空数组。
        结果
        接口阵列，每一个由 ClassDoc或 ParametrizedType 。
        从以下版本开始：
        1.5

      • typeParameters

        TypeVariable[] typeParameters​()
        已过时。
        返回此类或接口的形式类型参数。 如果没有，返回一个空数组。
        结果
        该类或接口的正式类型参数。
        从以下版本开始：
        1.5

      • typeParamTags

        ParamTag[] typeParamTags​()
        已过时。
        返回此类或接口的类型参数标签。 如果没有，返回一个空数组。
        结果
        该类或接口的类型参数标签。
        从以下版本开始：
        1.5

      • fields

        FieldDoc[] fields​()
        已过时。
        返回此类或接口中的included字段。 如果这是枚举类型，则排除枚举常量。
        结果
        表示此类或接口中包含的字段的FieldDoc对象数组。

      • fields

        FieldDoc[] fields​(boolean filter)
        已过时。
        返回此类或接口中的字段，过滤到指定的access modifier option 。 如果这是枚举类型，则排除枚举常量。
        参数
        filter - 根据指定的访问修饰符选项指定true进行过滤。 指定false以包括所有字段，而不考虑访问修饰符选项。
        结果
        表示此类或接口中包含的字段的FieldDoc对象数组。

      • enumConstants

        FieldDoc[] enumConstants​()
        已过时。
        如果这是枚举类型，则返回枚举常量。 如果没有枚举常量，或者这不是枚举类型，则返回一个空数组。
        结果
        枚举常量，如果这是一个枚举类型。

      • methods

        MethodDoc[] methods​()
        已过时。
        返回此类或接口中的included方法。 与methods(true)相同。
        结果
        表示此类或接口中包含的方法的MethodDoc对象数组。 不包括构造函数或注释类型元素。

      • methods

        MethodDoc[] methods​(boolean filter)
        已过时。
        返回此类或接口中的方法，过滤到指定的access modifier option 。 不包括构造函数或注释类型元素。
        参数
        filter - 根据指定的访问修饰符选项指定true进行过滤。 指定false以包括所有方法，而不考虑访问修饰符选项。
        结果
        表示此类或接口中包含的方法的MethodDoc对象数组。

      • constructors

        ConstructorDoc[] constructors​()
        已过时。
        在此类中返回included构造函数。 如果没有其他构造函数存在，则返回包含默认无参构造函数的数组。 如果这是一个接口，返回空数组。
        结果
        一组ConstructorDoc对象，表示此类中包含的构造函数。

      • constructors

        ConstructorDoc[] constructors​(boolean filter)
        已过时。
        在此类中返回构造函数，过滤到指定的access modifier option 。 如果没有其他构造函数存在，返回一个包含默认的无参数构造函数的数组。
        参数
        filter - 根据指定的访问修饰符选项指定true进行过滤。 指定false以包含所有构造函数，而不管访问修饰符选项如何。
        结果
        一组ConstructorDoc对象，表示此类中包含的构造函数。

      • innerClasses

        ClassDoc[] innerClasses​()
        已过时。
        返回included此类或接口中的嵌套类和接口。 这包括静态和非静态嵌套类。 （这种方法应该被命名为nestedClasses() ，因为内部类在技术上是非静态的。）不包括匿名和本地类或接口。
        结果
        一组ClassDoc对象，表示在此类或接口中定义的包含的类和接口。

      • innerClasses

        ClassDoc[] innerClasses​(boolean filter)
        已过时。
        返回此类或接口中的嵌套类和接口，过滤到指定的access modifier option 。 这包括静态和非静态嵌套类。 不包括匿名和本地课程。
        参数
        filter - 根据指定的访问修饰符选项指定true进行过滤。 指定false以包括所有嵌套类，而不考虑访问修饰符选项。
        结果
        一个过滤的ClassDoc对象数组，表示在此类或接口中定义的包含的类和接口。

      • findClass

        ClassDoc findClass​(String className)
        已过时。
        在该类doc的上下文中找到指定的类或接口。 搜索顺序：1）限定名称，2）嵌套在此类或接口中，3）在此包中，4）在类中导入，5）在包导入中。 如果找到，返回ClassDoc，如果找不到则返回null。
        参数
        className - 指定要以String形式查找的类名。
        结果
        如果找到ClassDoc，如果找不到则为null。

      • importedClasses

        @Deprecated
ClassDoc[] importedClasses​()
        已过时。 导入声明是不应该在这里公开的实现细节。 另外，并不是所有导入的类都是通过单一类型导入的声明导入的。
        获取声明为导入的类和接口的列表。 这些在The Java™ Language Specification中称为“单一类型导入声明”。
        结果
        一个代表导入类的ClassDoc数组。

      • importedPackages

        @Deprecated
PackageDoc[] importedPackages​()
        已过时。 导入声明是不应该在这里公开的实现细节。 此外，此方法的返回类型不允许返回所有类型导入按需的声明。
        获取声明为导入的包的列表。 这些在The Java™ Language Specification中称为“类型导入按需申报”。
        结果
        一个PackageDoc数组，表示导入的包。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.javadoc (Java SE 9 & JDK 9 )

com.sun.javadoc

Interfaces

  • AnnotatedType
  • AnnotationDesc
  • AnnotationDesc.ElementValuePair
  • AnnotationTypeDoc
  • AnnotationTypeElementDoc
  • AnnotationValue
  • ClassDoc
  • ConstructorDoc
  • Doc
  • DocErrorReporter
  • ExecutableMemberDoc
  • FieldDoc
  • MemberDoc
  • MethodDoc
  • PackageDoc
  • Parameter
  • ParameterizedType
  • ParamTag
  • ProgramElementDoc
  • RootDoc
  • SeeTag
  • SerialFieldTag
  • SourcePosition
  • Tag
  • ThrowsTag
  • Type
  • TypeVariable
  • WildcardType

Classes

  • Doclet

Enums

  • LanguageVersion


com.sun.javadoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.javadoc

Package com.sun.javadoc

注意：此包中的声明已被包装jdk.javadoc.doclet中的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

Doclet API（也称为Javadoc API）为客户端提供了一种机制，可以检查程序和库的源代码级结构，包括源代码中嵌入的javadoc注释。 这对于文档，程序检查，自动代码生成和许多其他工具非常有用。

Doclet由javadoc调用，并使用此API将程序信息写入文件。 例如，默认情况下调用标准doclet，并将文档写入HTML文件。

调用由抽象的Doclet类定义 - 入门点是start方法：

  public static boolean start(RootDoc root)
RootDoc实例保存程序结构信息的根。 从此根可以提取所有其他程序结构信息。

术语

调用javadoc时，传递包名称和源文件名称 - 这些名称称为指定的包和类。 您还传递Javadoc选项; 访问控制 Javadoc选项（ -public ， -protected ， -package ，和-private ）过滤程序元件，产生一个结果集，被称为包含组，或“记录”集。 （未过滤的套件也可通过allClasses(false)获得 。）

整个API，术语类通常为“类或接口”的简写，如： ClassDoc ， allClasses() ，和findClass(String) 。 在其他几个地方，它意味着“类，而不是接口”，如： Doc.isClass() 。 在第二个意义上说，这个API调用出来4种类： ordinary classes ， enums ， errors和exceptions 。 在整个API中，每个程序元素的详细描述明确地描述了正在使用的含义。

限定类或接口名称是其前缀的名称，如java.lang.String 。 非限定名称没有包名称，如String 。

例

以下是一个示例doclet，显示已处理类的@param标记中的信息：
  import com.sun.javadoc.*;

public class ListParams extends Doclet {

    public static boolean start(RootDoc root) {
        ClassDoc[] classes = root.classes();
        for (int i = 0; i < classes.length; ++i) {
            ClassDoc cd = classes[i];
            printMembers(cd.constructors());
            printMembers(cd.methods());
        }
        return true;
    }

    static void printMembers(ExecutableMemberDoc[] mems) {
        for (int i = 0; i < mems.length; ++i) {
            ParamTag[] params = mems[i].paramTags();
            System.out.println(mems[i].qualifiedName());
            for (int j = 0; j < params.length; ++j) {
                System.out.println("   " + params[j].parameterName()
                    + " - " + params[j].parameterComment());
            }
        }
    }
}
来自Javadoc API的接口和方法标记为红色 。 Doclet是指定用于doclet的调用接口的抽象类， Doclet保存类或接口信息， ExecutableMemberDoc是MethodDoc和ConstructorDoc的超级 接口 ，并且ParamTag保存来自“ @param ”标签的信息。

当使用以下命令行调用此doclet时：

  javadoc -doclet ListParams -sourcepath <source-location> java.util
产出如下：
  ...
    java.util.ArrayList.add
       index - index at which the specified element is to be inserted.
       element - element to be inserted.
    java.util.ArrayList.remove
       index - the index of the element to removed.
    ...
另请参见：
Doclet, RootDoc
  • 接口摘要
    接口 描述
    AnnotatedType Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    AnnotationDesc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    AnnotationDesc.ElementValuePair Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    AnnotationTypeDoc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    AnnotationTypeElementDoc Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
    AnnotationValue Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    ClassDoc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    ConstructorDoc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    Doc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    DocErrorReporter Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
    ExecutableMemberDoc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    FieldDoc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    MemberDoc Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
    MethodDoc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    PackageDoc Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    Parameter Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    ParameterizedType Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    ParamTag Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    ProgramElementDoc Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
    RootDoc Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
    SeeTag Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
    SerialFieldTag Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    SourcePosition Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    Tag Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    ThrowsTag Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
    Type Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
    TypeVariable Deprecated.
    该包裹中的声明已被包装jdk.javadoc.doclet的声明所取代。
    WildcardType Deprecated.
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。
  • 类摘要
    Class 描述
    Doclet Deprecated.
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。
  • 枚举摘要
    Enum 描述
    LanguageVersion Deprecated.
    The declarations in this package have been superseded by those in the package jdk.javadoc.doclet.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.javadoc Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.javadoc

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.javadoc.Doclet

Interface Hierarchy

  • com.sun.javadoc.AnnotationDesc
  • com.sun.javadoc.AnnotationDesc.ElementValuePair
  • com.sun.javadoc.AnnotationValue
  • java.lang.Comparable<T>
    • com.sun.javadoc.Doc
      • com.sun.javadoc.PackageDoc
      • com.sun.javadoc.ProgramElementDoc
        • com.sun.javadoc.ClassDoc (also extends com.sun.javadoc.Type)
          • com.sun.javadoc.AnnotationTypeDoc
        • com.sun.javadoc.MemberDoc
          • com.sun.javadoc.ExecutableMemberDoc
            • com.sun.javadoc.ConstructorDoc
            • com.sun.javadoc.MethodDoc
              • com.sun.javadoc.AnnotationTypeElementDoc
          • com.sun.javadoc.FieldDoc
      • com.sun.javadoc.RootDoc (also extends com.sun.javadoc.DocErrorReporter)
    • com.sun.javadoc.SerialFieldTag (also extends com.sun.javadoc.Tag)
  • com.sun.javadoc.DocErrorReporter
    • com.sun.javadoc.RootDoc (also extends com.sun.javadoc.Doc)
  • com.sun.javadoc.Parameter
  • com.sun.javadoc.SourcePosition
  • com.sun.javadoc.Tag
    • com.sun.javadoc.ParamTag
    • com.sun.javadoc.SeeTag
    • com.sun.javadoc.SerialFieldTag (also extends java.lang.Comparable<T>)
    • com.sun.javadoc.ThrowsTag
  • com.sun.javadoc.Type
    • com.sun.javadoc.AnnotatedType
    • com.sun.javadoc.ClassDoc (also extends com.sun.javadoc.ProgramElementDoc)
      • com.sun.javadoc.AnnotationTypeDoc
    • com.sun.javadoc.ParameterizedType
    • com.sun.javadoc.TypeVariable
    • com.sun.javadoc.WildcardType

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.javadoc.LanguageVersion
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ConstructorDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface ConstructorDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， ExecutableMemberDoc ， MemberDoc ， ProgramElementDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface ConstructorDoc
extends ExecutableMemberDoc
    表示java类的构造函数。
    从以下版本开始：
    1.2

    • 方法摘要

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.ExecutableMemberDoc

        flatSignature, isNative, isSynchronized, isVarArgs, parameters, paramTags, receiverType, signature, thrownExceptions, thrownExceptionTypes, throwsTags, typeParameters, typeParamTags

      • Methods inherited from interface com.sun.javadoc.MemberDoc

        isSynthetic

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Doc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface Doc

  • All Superinterfaces:
    Comparable<Object>
    All Known Subinterfaces:
    AnnotationTypeDoc ， AnnotationTypeElementDoc ， ClassDoc ， ConstructorDoc ， ExecutableMemberDoc ， FieldDoc ， MemberDoc ， MethodDoc ， PackageDoc ， ProgramElementDoc ， RootDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface Doc
extends Comparable<Object>
    表示Java语言构造（包，类，构造函数，方法，字段），它们具有注释，并由此运行的javadoc进行处理。 所有Doc对象都是唯一的，也就是说，它们是可比较的。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      String commentText​()
      已过时。
      返回此文档项目的注释文本。
      int compareTo​(Object obj)
      已过时。
      将此doc对象与指定的对象进行比较以进行排序。
      Tag[] firstSentenceTags​()
      已过时。
      将注释的第一个句子作为标签数组返回。
      String getRawCommentText​()
      已过时。
      返回评论的完整未处理文本。
      Tag[] inlineTags​()
      已过时。
      将注释作为标签数组返回。
      boolean isAnnotationType​()
      已过时。
      这个Doc项目是否是注释类型？
      boolean isAnnotationTypeElement​()
      已过时。
      这个Doc项目是否是注释类型元素？
      boolean isClass​()
      已过时。
      这个Doc项目是一个 class （而不是一个接口或注释类型）？
      boolean isConstructor​()
      已过时。
      这个Doc项目是否是构造函数？
      boolean isEnum​()
      已过时。
      这个Doc项目是枚举类型吗？
      boolean isEnumConstant​()
      已过时。
      这个Doc项目是否是一个常量？
      boolean isError​()
      已过时。
      这个Doc项目是错误类吗？
      boolean isException​()
      已过时。
      这个Doc项目是异常类吗？
      boolean isField​()
      已过时。
      这个Doc项目是一个字段（但不是枚举常量）？
      boolean isIncluded​()
      已过时。
      如果此文档项目是结果集中的 included ，则返回true。
      boolean isInterface​()
      已过时。
      这个Doc项目是否是一个界面（但不是注释类型）？
      boolean isMethod​()
      已过时。
      这个Doc项目是一种方法（但不是构造函数或注释类型元素）？
      boolean isOrdinaryClass​()
      已过时。
      这个文件是 ordinary class吗？
      String name​()
      已过时。
      返回此Doc文件的非限定名称。
      SourcePosition position​()
      已过时。
      返回相应声明的第一行的源位置，如果没有位置可用，则返回null。
      SeeTag[] seeTags​()
      已过时。
      返回此文件中的参见标签。
      void setRawCommentText​(String rawDocumentation)
      已过时。
      设置注释的完整未处理文本。
      Tag[] tags​()
      已过时。
      返回此文件中的所有标签。
      Tag[] tags​(String tagname)
      已过时。
      返回本文档中指定的 kind的标签。

    • 方法详细信息

      • commentText

        String commentText​()
        已过时。
        返回此文档项目的注释文本。 标签已被删除
        结果
        该文档项目的注释文本。

      • tags

        Tag[] tags​()
        已过时。
        返回此文件中的所有标签。
        结果
        包含此Doc文件上所有标签的Tag个对象的数组。

      • tags

        Tag[] tags​(String tagname)
        已过时。
        返回本文档中指定的kind的标签。 例如，如果“tagname”的值为“@serial”，则将返回此Doc文件中的所有标签“@serial”。
        参数
        tagname - 要搜索的标签种类的名称。
        结果
        一个包含“kind（）”匹配“tagname”的所有标签的Tag的数组。

      • seeTags

        SeeTag[] seeTags​()
        已过时。
        返回此文件中的参见标签。
        结果
        一个包含所有@see标签的SeeTag数组。

      • inlineTags

        Tag[] inlineTags​()
        已过时。
        将注释作为标签数组返回。 包括内联标签（即{@link reference }标签）），但不包括块标签。 纯文本的每个部分被表示为Tag的kind “文本”。 内联标签表示为类似“@see”的SeeTag ，名称为“@link”。
        结果
        代表该评论的Tag的数组

      • firstSentenceTags

        Tag[] firstSentenceTags​()
        已过时。
        将注释的第一个句子作为标签数组返回。 包括内联标签（即{@link reference }标签）），但不包括块标签。 纯文本的每个部分被表示为Tag的kind “文本”。 内联标签表示为类似“@see”的SeeTag ，名称为“@link”。

        如果语言环境是英语，则第一句由Java语言规范（第一版）中描述的规则确定：“这句话在第一个句点结束，后面是空白，制表符或行终止符，或者在第一个句子标签“，另外一行将被块HTML标签终止：<p> </ p> <h1> <h2> <h3> <h4> <h5> <h6> <hr> <pre>或<预>。 如果语言环境不是英文，则句子结束将由BreakIterator.getSentenceInstance(Locale)决定。

        结果
        代表评论第一句的Tag s的数组

      • getRawCommentText

        String getRawCommentText​()
        已过时。
        返回评论的完整未处理文本。 标签被包括为文本。 主要用于存储和检索操作，如内部化。
        结果
        评论的完整未经处理的文本。

      • setRawCommentText

        void setRawCommentText​(String rawDocumentation)
        已过时。
        设置注释的完整未处理文本。 标签被包括为文本。 主要用于存储和检索操作，如内部化。
        参数
        rawDocumentation - 包含注释的完整未处理文本的字符串。

      • name

        String name​()
        已过时。
        返回此Doc文件的非限定名称。
        结果
        名字

      • compareTo

        int compareTo​(Object obj)
        已过时。
        将此doc对象与指定的对象进行比较以进行排序。 返回一个负整数，零或正整数，因为该doc对象小于，等于或大于给定对象。

        该方法满足Comparable接口。

        Specified by:
        compareTo在接口 Comparable<Object>
        参数
        obj - 要比较的 Object 。
        结果
        一个负整数，零或一个正整数，因为该对象小于，等于或大于给定的对象。
        异常
        ClassCastException - 指定的对象的类型阻止它与此对象进行比较。

      • isField

        boolean isField​()
        已过时。
        这个Doc项目是一个字段（但不是枚举常量）？
        结果
        如果它代表一个字段，则为true

      • isEnumConstant

        boolean isEnumConstant​()
        已过时。
        这个Doc项目是否是一个常量？
        结果
        如果它代表枚举常数，则为true
        从以下版本开始：
        1.5

      • isConstructor

        boolean isConstructor​()
        已过时。
        这个Doc项目是否是构造函数？
        结果
        如果它代表构造函数，则为true

      • isMethod

        boolean isMethod​()
        已过时。
        这个Doc项目是一种方法（但不是构造函数或注释类型元素）？
        结果
        如果它代表一种方法，则为true

      • isAnnotationTypeElement

        boolean isAnnotationTypeElement​()
        已过时。
        这个Doc项目是否是注释类型元素？
        结果
        如果它代表注释类型元素，则为true
        从以下版本开始：
        1.5

      • isInterface

        boolean isInterface​()
        已过时。
        这个Doc项目是否是一个界面（但不是注释类型）？
        结果
        如果它代表一个接口，则为true

      • isException

        boolean isException​()
        已过时。
        这个Doc项目是异常类吗？
        结果
        如果它代表一个异常，则为true

      • isError

        boolean isError​()
        已过时。
        这个Doc项目是错误类吗？
        结果
        如果它代表错误，则为true

      • isEnum

        boolean isEnum​()
        已过时。
        这个Doc项目是枚举类型吗？
        结果
        如果它代表枚举类型，则为true
        从以下版本开始：
        1.5

      • isAnnotationType

        boolean isAnnotationType​()
        已过时。
        这个Doc项目是否是注释类型？
        结果
        如果它代表注释类型，则为true
        从以下版本开始：
        1.5

      • isOrdinaryClass

        boolean isOrdinaryClass​()
        已过时。
        这个文件是ordinary class吗？ （即不是接口，注释类型，枚举，异常或错误）？
        结果
        如果它代表一个普通的类，则为true

      • isClass

        boolean isClass​()
        已过时。
        这个Doc项目是class （而不是接口或注释类型）？ 这包括普通类，枚举，错误和异常。
        结果
        如果它代表一个类，则为true

      • isIncluded

        boolean isIncluded​()
        已过时。
        如果此文档项目是结果集中的 included ，则返回true。
        结果
        如果此文档项目是结果集中的 included ，则为 true 。

      • position

        SourcePosition position​()
        已过时。
        返回相应声明的第一行的源位置，如果没有位置可用，则返回null。 默认构造函数返回null，因为源文件中没有位置。
        结果
        相应声明的第一行的来源定位，如果没有位置可用，则为null。 默认构造函数返回null，因为源文件中没有位置。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocErrorReporter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface DocErrorReporter

  • All Known Subinterfaces:
    RootDoc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface DocErrorReporter
    此界面提供错误，警告和通知打印。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void printError​(SourcePosition pos, String msg)
      已过时。
      打印错误消息并增加错误计数。
      void printError​(String msg)
      已过时。
      打印错误消息和增量错误计数。
      void printNotice​(SourcePosition pos, String msg)
      已过时。
      打印信息。
      void printNotice​(String msg)
      已过时。
      打印信息。
      void printWarning​(SourcePosition pos, String msg)
      已过时。
      打印警告信息并增加警告计数。
      void printWarning​(String msg)
      已过时。
      打印警告信息并增加警告计数。

    • 方法详细信息

      • printError

        void printError​(String msg)
        已过时。
        打印错误消息和增量错误计数。
        参数
        msg - 要打印的消息

      • printError

        void printError​(SourcePosition pos,
                String msg)
        已过时。
        打印错误消息并增加错误计数。
        参数
        pos - 发生错误的位置项
        msg - 要打印的消息
        从以下版本开始：
        1.4

      • printWarning

        void printWarning​(String msg)
        已过时。
        打印警告信息并增加警告计数。
        参数
        msg - 要打印的消息

      • printWarning

        void printWarning​(SourcePosition pos,
                  String msg)
        已过时。
        打印警告信息并增加警告计数。
        参数
        pos - 发生警告的位置项
        msg - 要打印的消息
        从以下版本开始：
        1.4

      • printNotice

        void printNotice​(String msg)
        已过时。
        打印信息。
        参数
        msg - 要打印的消息

      • printNotice

        void printNotice​(SourcePosition pos,
                 String msg)
        已过时。
        打印信息。
        参数
        pos - 消息发生的位置项
        msg - 要打印的消息
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Doclet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Class Doclet

  • java.lang.Object
    • com.sun.javadoc.Doclet
  • 已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public abstract class Doclet
extends Object
    这是doclet的起始类的示例，显示了入门点方法。 起始类必须导入com.sun.javadoc。*并实现start(RootDoc)方法，如package description所述 。 如果doclet采用命令行选项，则还必须实现optionLength和validOptions 。

    支持自1.1之后添加的语言特性（如泛型和注释）的doclet应通过实现languageVersion来表明。 在没有这个的情况下，doclet不应该调用自1.5以来添加的任何Doclet API方法，并且修改了其他几种方法的结果，以便从doclet中隐藏新的结构（例如类型参数）。

    要启动doclet，请传递-doclet后跟javadoc工具命令行上的起始类的完全限定名。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Doclet​()
      已过时。

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static LanguageVersion languageVersion​()
      已过时。
      返回此doclet支持的Java编程语言版本。
      static int optionLength​(String option)
      已过时。
      检查doclet添加的选项。
      static boolean start​(RootDoc root)
      已过时。
      在此生成文档。
      static boolean validOptions​(String[][] options, DocErrorReporter reporter)
      已过时。
      检查选项是否具有正确的参数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Doclet

        public Doclet​()
        已过时。

    • 方法详细信息

      • start

        public static boolean start​(RootDoc root)
        已过时。
        在此生成文档。 所有doclet都需要此方法。
        参数
        root - 将RootDoc提供给方法。
        结果
        真正的成功。

      • optionLength

        public static int optionLength​(String option)
        已过时。
        检查doclet添加的选项。 返回必须在给定选项的命令行上指定的参数数。 例如，“-d docs”将返回2。

        如果doclet包含任何选项，则需要此方法。 如果缺少此方法，Javadoc将会为每个选项打印一个无效的标志错误。

        参数
        option - 返回争用次数的选项。
        结果
        在包含选项名称本身的选项的命令行上的参数数。 零返回意味着未知的选项。 负值表示发生错误。

      • validOptions

        public static boolean validOptions​(String[][] options,
                                   DocErrorReporter reporter)
        已过时。
        检查选项是否具有正确的参数。

        此方法不是必需的，但建议，因为如果此方法不存在，每个选项都将被视为有效。 如果缺席，它会默认默认（true）。

        打印选项相关的错误消息（使用提供的DocErrorReporter）是此方法的责任。

        参数
        options - 提供有效的选项作为字符串数组。
        reporter - 负责这些选项的DocErrorReporter。
        结果
        如果选项有效，则为true。

      • languageVersion

        public static LanguageVersion languageVersion​()
        已过时。
        返回此doclet支持的Java编程语言版本。

        任何支持语言版本比1.1更新的doclet都需要这种方法。

        结果
        该doclet支持的语言版本。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExecutableMemberDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface ExecutableMemberDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， MemberDoc ， ProgramElementDoc
    All Known Subinterfaces:
    AnnotationTypeElementDoc ， ConstructorDoc ， MethodDoc
    已过时。
    该包裹中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface ExecutableMemberDoc
extends MemberDoc
    表示java类的方法或构造函数。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      String flatSignature​()
      已过时。
      得到平面签名。
      boolean isNative​()
      已过时。
      如果这个方法是原生的，返回true
      boolean isSynchronized​()
      已过时。
      如果此方法同步，返回true
      boolean isVarArgs​()
      已过时。
      如果此方法被声明为使用可变数量的参数，则返回true。
      Parameter[] parameters​()
      已过时。
      获取参数信息。
      ParamTag[] paramTags​()
      已过时。
      返回此方法中的参数标签，不包括类型参数标签。
      Type receiverType​()
      已过时。
      获取此可执行元素的接收器类型。
      String signature​()
      已过时。
      签名。
      ClassDoc[] thrownExceptions​()
      已过时。
      返回此方法或构造函数抛出的异常。
      Type[] thrownExceptionTypes​()
      已过时。
      返回此方法或构造函数抛出的异常。
      ThrowsTag[] throwsTags​()
      已过时。
      在此方法中返回throws标签。
      TypeVariable[] typeParameters​()
      已过时。
      返回此方法或构造函数的形式类型参数。
      ParamTag[] typeParamTags​()
      已过时。
      在此方法中返回类型参数标签。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.MemberDoc

        isSynthetic

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName

    • 方法详细信息

      • thrownExceptions

        ClassDoc[] thrownExceptions​()
        已过时。
        返回此方法或构造函数抛出的异常。 如果异常的类型是类型变量，则返回其擦除的ClassDoc 。

        thrownExceptions方法thrownExceptions某些通用类型的构造。 应该使用thrownExceptionTypes方法。

        结果
        一个表示此方法抛出的异常的ClassDoc []的数组。
        另请参见：
        thrownExceptionTypes()

      • thrownExceptionTypes

        Type[] thrownExceptionTypes​()
        已过时。
        返回此方法或构造函数抛出的异常。
        结果
        一个表示此方法抛出的异常的数组。 每个数组元素都是ClassDoc或TypeVariable 。
        从以下版本开始：
        1.5

      • isNative

        boolean isNative​()
        已过时。
        如果这个方法是原生的，返回true
        结果
        如果此方法是本机的，则为true

      • isSynchronized

        boolean isSynchronized​()
        已过时。
        如果此方法同步，返回true
        结果
        如果此方法同步，则为true

      • isVarArgs

        boolean isVarArgs​()
        已过时。
        如果此方法被声明为使用可变数量的参数，则返回true。
        结果
        如果此方法被声明为使用可变数量的参数，则为true。
        从以下版本开始：
        1.5

      • parameters

        Parameter[] parameters​()
        已过时。
        获取参数信息。
        结果
        一个Parameter数组，每个参数有一个元素，按参数的顺序存在。
        另请参见：
        Parameter

      • receiverType

        Type receiverType​()
        已过时。
        获取此可执行元素的接收器类型。
        结果
        该可执行元素的接收器类型。
        从以下版本开始：
        1.8

      • throwsTags

        ThrowsTag[] throwsTags​()
        已过时。
        在此方法中返回throws标签。
        结果
        一个包含所有 @exception和 @throws标签的ThrowTag数组。

      • paramTags

        ParamTag[] paramTags​()
        已过时。
        返回此方法中的参数标签，不包括类型参数标签。
        结果
        一个ParamTag数组，其中包含与此方法参数相对应的所有 @param标签。

      • typeParamTags

        ParamTag[] typeParamTags​()
        已过时。
        在此方法中返回类型参数标签。
        结果
        一个ParamTag数组，其中包含与此方法的类型参数相对应的所有 @param标签。
        从以下版本开始：
        1.5

      • signature

        String signature​()
        已过时。
        签名。 它是参数列表，类型是合格的。 例如，对于方法mymethod(String x, int y) ，它将返回(java.lang.String,int) 。
        结果
        参数列表，其中type是合格的。

      • flatSignature

        String flatSignature​()
        已过时。
        得到平面签名。 所有类型都不合格。 返回一个String，这是该成员的平面签名。 它是参数列表，类型不合格。 例如，对于方法mymethod(String x, int y) ，它将返回(String, int) 。
        结果
        一个字符串，这是该成员的平面签名。

      • typeParameters

        TypeVariable[] typeParameters​()
        已过时。
        返回此方法或构造函数的形式类型参数。 如果此方法或构造函数不是通用的，则返回一个空数组。
        结果
        该方法或构造函数的正式类型参数。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FieldDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface FieldDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， MemberDoc ， ProgramElementDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface FieldDoc
extends MemberDoc
    表示java类中的一个字段。
    从以下版本开始：
    1.2
    另请参见：
    MemberDoc

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      Object constantValue​()
      已过时。
      获取常量字段的值。
      String constantValueExpression​()
      已过时。
      获取常量字段的值。
      boolean isTransient​()
      已过时。
      如果这个字段是短暂的，返回true
      boolean isVolatile​()
      已过时。
      如果此字段不稳定，返回true
      SerialFieldTag[] serialFieldTags​()
      已过时。
      返回此FieldDoc项中的serialField标记。
      Type type​()
      已过时。
      获取此字段的类型。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.MemberDoc

        isSynthetic

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName

    • 方法详细信息

      • type

        Type type​()
        已过时。
        获取此字段的类型。
        结果
        该字段的类型。

      • isTransient

        boolean isTransient​()
        已过时。
        如果这个字段是短暂的，返回true
        结果
        如果该字段是短暂的，则为真

      • isVolatile

        boolean isVolatile​()
        已过时。
        如果此字段不稳定，返回true
        结果
        如果此字段为volatile，则为true

      • serialFieldTags

        SerialFieldTag[] serialFieldTags​()
        已过时。
        返回此FieldDoc项中的serialField标记。
        结果
        一个包含 @serialField标签的 SerialFieldTag对象的数组。

      • constantValue

        Object constantValue​()
        已过时。
        获取常量字段的值。
        结果
        恒定字段的值。 如果该对象具有原始类型，则该值将自动包装在对象中。 如果该字段不是常量，则返回null。

      • constantValueExpression

        String constantValueExpression​()
        已过时。
        获取常量字段的值。
        结果
        Java语言表达式的文本，其值是常量的值。 该表达式不使用除原始文字之外的标识符。 如果该字段不是常量，则返回null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LanguageVersion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Enum LanguageVersion

  • java.lang.Object
    • java.lang.Enum<LanguageVersion>
      • com.sun.javadoc.LanguageVersion
  • All Implemented Interfaces:
    Serializable ， Comparable<LanguageVersion>
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public enum LanguageVersion
extends Enum<LanguageVersion>
    Java编程语言版本。 此枚举的常量标识包含与doclet相关的语言更改的JDK和J2SE版本。

    所有doclets至少支持1.1语言版本。 之后的第一个版本与影响doclets的语言更改是1.5。

    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      JAVA_1_1
      已过时。
      1.1添加了嵌套类和接口。
      JAVA_1_5
      已过时。
      1.5添加通用类型，注释，枚举和varArgs。

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static LanguageVersion valueOf​(String name)
      已过时。
      以指定的名称返回此类型的枚举常量。
      static LanguageVersion[] values​()
      已过时。
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • JAVA_1_1

        public static final LanguageVersion JAVA_1_1
        已过时。
        1.1添加了嵌套类和接口。

      • JAVA_1_5

        public static final LanguageVersion JAVA_1_5
        已过时。
        1.5添加通用类型，注释，枚举和varArgs。

    • 方法详细信息

      • values

        public static LanguageVersion[] values​()
        已过时。
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (LanguageVersion c : LanguageVersion.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static LanguageVersion valueOf​(String name)
        已过时。
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


MemberDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface MemberDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， ProgramElementDoc
    All Known Subinterfaces:
    AnnotationTypeElementDoc ， ConstructorDoc ， ExecutableMemberDoc ， FieldDoc ， MethodDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface MemberDoc
extends ProgramElementDoc
    表示java类的成员：字段，构造函数或方法。 这是一个处理方法，构造函数和字段成员通用信息的抽象类。 Class（类）的类成员被ClassDoc代替。
    另请参见：
    MethodDoc ， FieldDoc ， ClassDoc

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean isSynthetic​()
      已过时。
      如果该成员由编译器合成，则返回true。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName

    • 方法详细信息

      • isSynthetic

        boolean isSynthetic​()
        已过时。
        如果该成员由编译器合成，则返回true。
        结果
        如果此成员由编译器合成，则为true。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface MethodDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， ExecutableMemberDoc ， MemberDoc ， ProgramElementDoc
    All Known Subinterfaces:
    AnnotationTypeElementDoc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface MethodDoc
extends ExecutableMemberDoc
    表示java类的方法。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean isAbstract​()
      已过时。
      如果这个方法是抽象的，返回true
      boolean isDefault​()
      已过时。
      如果此方法为默认值，则返回true
      ClassDoc overriddenClass​()
      已过时。
      返回包含此方法覆盖的方法的类。
      MethodDoc overriddenMethod​()
      已过时。
      返回此方法覆盖的方法。
      Type overriddenType​()
      已过时。
      返回包含此方法覆盖的方法的类型。
      boolean overrides​(MethodDoc meth)
      已过时。
      测试此方法是否覆盖其他方法。
      Type returnType​()
      已过时。
      获取返回类型。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.ExecutableMemberDoc

        flatSignature, isNative, isSynchronized, isVarArgs, parameters, paramTags, receiverType, signature, thrownExceptions, thrownExceptionTypes, throwsTags, typeParameters, typeParamTags

      • Methods inherited from interface com.sun.javadoc.MemberDoc

        isSynthetic

      • Methods inherited from interface com.sun.javadoc.ProgramElementDoc

        annotations, containingClass, containingPackage, isFinal, isPackagePrivate, isPrivate, isProtected, isPublic, isStatic, modifiers, modifierSpecifier, qualifiedName

    • 方法详细信息

      • isAbstract

        boolean isAbstract​()
        已过时。
        如果这个方法是抽象的，返回true
        结果
        如果此方法是抽象的，则为true

      • isDefault

        boolean isDefault​()
        已过时。
        如果此方法为默认值，则返回true
        结果
        如果此方法为默认值，则为true

      • returnType

        Type returnType​()
        已过时。
        获取返回类型。
        结果
        此方法的返回类型，如果是构造函数，则为null。

      • overriddenClass

        ClassDoc overriddenClass​()
        已过时。
        返回包含此方法覆盖的方法的类。

        overriddenClass方法不能容纳某些通用类型的构造。 应该使用overriddenType方法。

        结果
        一个ClassDoc表示定义此方法覆盖的方法的超类，如果此方法不覆盖，则为null。

      • overriddenType

        Type overriddenType​()
        已过时。
        返回包含此方法覆盖的方法的类型。 它可能是一个ClassDoc或ParameterizedType 。
        结果
        该方法被覆盖的超类型，如果此方法不覆盖超类中的另一个，则为null
        从以下版本开始：
        1.5

      • overriddenMethod

        MethodDoc overriddenMethod​()
        已过时。
        返回此方法覆盖的方法。
        结果
        一个MethodDoc表示超类中的方法定义，此方法覆盖，如果此方法不覆盖，则为null。

      • overrides

        boolean overrides​(MethodDoc meth)
        已过时。
        测试此方法是否覆盖其他方法。 重写的方法可以是在超类或超级界面中声明的方法（不同于overriddenMethod() ）。

        当一个非抽象方法覆盖一个抽象方法时，它也被称为实现另一个。

        参数
        meth - 另一种检查方法
        结果
        true如果此方法覆盖其他
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PackageDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface PackageDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface PackageDoc
extends Doc
    代表一个java包。 提供对包的信息，包的注释和标签以及包中的类的访问。

    返回类型为数组的每个方法将在结果中没有对象时返回一个空数组（从不为null）。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      ClassDoc[] allClasses​()
      已过时。
      在包中获取所有 included类和接口。
      ClassDoc[] allClasses​(boolean filter)
      已过时。
      获取包中的所有类和接口，过滤到指定的 access modifier option 。
      AnnotationDesc[] annotations​()
      已过时。
      获取此包的注释。
      AnnotationTypeDoc[] annotationTypes​()
      已过时。
      在此包中获取包含的注释类型。
      ClassDoc[] enums​()
      已过时。
      在此包中获取包含的枚举类型。
      ClassDoc[] errors​()
      已过时。
      获取包含此包中的错误类。
      ClassDoc[] exceptions​()
      已过时。
      在此包中包含异常类。
      ClassDoc findClass​(String className)
      已过时。
      在此包中查找类或接口。
      ClassDoc[] interfaces​()
      已过时。
      在此包中获取包含的接口，省略注释类型。
      ClassDoc[] ordinaryClasses​()
      已过时。
      在此包中包含 ordinary类（即，排除异常，错误，枚举，接口和注释类型）。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

    • 方法详细信息

      • allClasses

        ClassDoc[] allClasses​(boolean filter)
        已过时。
        获取包中的所有类和接口，过滤到指定的 access modifier option 。
        参数
        filter - 根据指定的访问修饰符选项指定真实的过滤器。 指定false包括所有类和接口，无论访问修饰符选项如何。
        结果
        过滤的类和接口
        从以下版本开始：
        1.4

      • allClasses

        ClassDoc[] allClasses​()
        已过时。
        在包中获取所有included类和接口。 与allClasses（true）相同。
        结果
        所有包含此包中的类和接口。

      • ordinaryClasses

        ClassDoc[] ordinaryClasses​()
        已过时。
        在此包中包含 ordinary类（即排除异常，错误，枚举，接口和注释类型）。
        结果
        包括这个包中的普通课。

      • exceptions

        ClassDoc[] exceptions​()
        已过时。
        在此包中包含异常类。
        结果
        包括此包中的异常。

      • errors

        ClassDoc[] errors​()
        已过时。
        获取包含此包中的错误类。
        结果
        在这个包中包含错误。

      • enums

        ClassDoc[] enums​()
        已过时。
        在此包中获取包含的枚举类型。
        结果
        在这个包中包含枚举类型。
        从以下版本开始：
        1.5

      • interfaces

        ClassDoc[] interfaces​()
        已过时。
        在此包中获取包含的接口，省略注释类型。
        结果
        包括此包中的接口。

      • annotationTypes

        AnnotationTypeDoc[] annotationTypes​()
        已过时。
        在此包中获取包含的注释类型。
        结果
        在此包中添加注释类型。
        从以下版本开始：
        1.5

      • annotations

        AnnotationDesc[] annotations​()
        已过时。
        获取此包的注释。 如果没有，返回一个空数组。
        结果
        这个包的注释。
        从以下版本开始：
        1.5

      • findClass

        ClassDoc findClass​(String className)
        已过时。
        在此包中查找类或接口。
        参数
        className - 包含要查找的类的名称的字符串。
        结果
        ClassDoc of found class or interface, or null if not found.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Parameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface Parameter

  • 已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface Parameter
    参数信息。 这包括参数类型和参数名称。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationDesc[] annotations​()
      已过时。
      获取此参数的注释。
      String name​()
      已过时。
      获取此参数的本地名称。
      String toString​()
      已过时。
      返回参数的字符串表示形式。
      Type type​()
      已过时。
      获取此参数的类型。
      String typeName​()
      已过时。
      获取此参数的类型名称。

    • 方法详细信息

      • type

        Type type​()
        已过时。
        获取此参数的类型。
        结果
        该参数的类型。

      • name

        String name​()
        已过时。
        获取此参数的本地名称。 例如，如果参数是short'index'，则返回“index”。
        结果
        此参数的名称作为字符串。

      • typeName

        String typeName​()
        已过时。
        获取此参数的类型名称。 例如，如果参数是short'index'，则返回“short”。

        此方法返回类型的完整字符串表示形式，包括数组的维度和参数化类型的类型参数。 名称合格

        结果
        一个完整的字符串表示形式。

      • toString

        String toString​()
        已过时。
        返回参数的字符串表示形式。

        例如，如果参数是short'index'，则返回“short index”。

        重写：
        toString在 Object
        结果
        此参数的类型和参数名称。

      • annotations

        AnnotationDesc[] annotations​()
        已过时。
        获取此参数的注释。 如果没有，返回一个空数组。
        结果
        该参数的注释。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ParameterizedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface ParameterizedType

  • All Superinterfaces:
    Type
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface ParameterizedType
extends Type
    表示通用类或接口的调用。 例如，给定通用接口List<E> ，可能的调用包括：
      List<String>
      List<T extends Number>
      List<?>
    通用内部类Outer<T>.Inner<S>可能被调用为：
      Outer<Number>.Inner<String>
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      ClassDoc asClassDoc​()
      已过时。
      返回声明此类型的泛型类或接口。
      Type containingType​()
      已过时。
      将包含此类型的类型作为成员返回。
      Type[] interfaceTypes​()
      已过时。
      返回由该参数化类型直接实现或扩展的接口类型。
      Type superclassType​()
      已过时。
      返回该类的直接超类型。
      Type[] typeArguments​()
      已过时。
      返回此类型的实际类型参数。

      • Methods inherited from interface com.sun.javadoc.Type

        asAnnotatedType, asAnnotationTypeDoc, asParameterizedType, asTypeVariable, asWildcardType, dimension, getElementType, isPrimitive, qualifiedTypeName, simpleTypeName, toString, typeName

    • 方法详细信息

      • asClassDoc

        ClassDoc asClassDoc​()
        已过时。
        返回声明此类型的泛型类或接口。
        Specified by:
        asClassDoc接口 Type
        结果
        声明此类型的通用类或接口。

      • typeArguments

        Type[] typeArguments​()
        已过时。
        返回此类型的实际类型参数。 对于嵌套在其他通用类型（例如Outer<T>.Inner<S> ）中的通用类型，仅包含最内部类型的类型参数。
        结果
        这种类型的实际类型参数。

      • superclassType

        Type superclassType​()
        已过时。
        返回该类的直接超类型。 这是这种类型的声明类的超类，类型参数被替换。如果这是接口类型，则返回null。

        例如，如果此参数化类型为java.util.ArrayList<String> ，则结果为java.util.AbstractList<String> 。

        结果
        这个类的直接超类型。

      • interfaceTypes

        Type[] interfaceTypes​()
        已过时。
        返回由该参数化类型直接实现或扩展的接口类型。 这些是通过此类型的声明类或接口直接实现或扩展的接口，类型参数被替换。如果没有接口，则返回一个空数组。

        例如，扩展java.util.Set<String>的接口是java.util.Collection<String> 。

        结果
        由该参数化类型直接实现或扩展的接口类型。

      • containingType

        Type containingType​()
        已过时。
        将包含此类型的类型作为成员返回。 返回null是这是一个顶级类型。

        例如， AnInterface.Nested<Number>的包含类型是ClassDoc代表AnInterface ，而包含类型的Outer<String>.Inner<Number>是ParameterizedType代表Outer<String> 。

        结果
        the type that contains this type as a member.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ParamTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface ParamTag

  • All Superinterfaces:
    Tag
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface ParamTag
extends Tag
    表示@param文档标签。 存储参数标签的名称和注释部分。 @param标签可以表示方法或构造函数参数或类型参数。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      boolean isTypeParameter​()
      已过时。
      如果这个 ParamTag对应一个类型参数，返回true。
      String parameterComment​()
      已过时。
      返回与此 ParamTag相关联的参数注释。
      String parameterName​()
      已过时。
      返回与此 ParamTag相关联的参数或类型参数的名称。

      • Methods inherited from interface com.sun.javadoc.Tag

        firstSentenceTags, holder, inlineTags, kind, name, position, text, toString

    • 方法详细信息

      • parameterName

        String parameterName​()
        已过时。
        返回与此ParamTag相关联的参数或类型参数的名称。 定义类型参数的尖括号不属于其名称。
        结果
        参数名称。

      • parameterComment

        String parameterComment​()
        已过时。
        返回与此 ParamTag相关联的参数注释。
        结果
        参数注释。

      • isTypeParameter

        boolean isTypeParameter​()
        已过时。
        如果这个ParamTag对应一个类型参数返回true。 如果它对应于方法或构造函数的普通参数，则返回false。
        结果
        如果此 ParamTag对应于类型参数， ParamTag true。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProgramElementDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface ProgramElementDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc
    All Known Subinterfaces:
    AnnotationTypeDoc ， AnnotationTypeElementDoc ， ClassDoc ， ConstructorDoc ， ExecutableMemberDoc ， FieldDoc ， MemberDoc ， MethodDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface ProgramElementDoc
extends Doc
    表示一个java程序元素：class，interface，field，constructor或method。 这是一个处理这些元素共同的信息的抽象类。
    另请参见：
    MemberDoc ， ClassDoc

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationDesc[] annotations​()
      已过时。
      获取此程序元素的注释。
      ClassDoc containingClass​()
      已过时。
      获取该程序元素的包含类或接口。
      PackageDoc containingPackage​()
      已过时。
      获取包含该程序元素的包。
      boolean isFinal​()
      已过时。
      如果此程序元素为final，则返回true。
      boolean isPackagePrivate​()
      已过时。
      如果这个程序元素是私有的，返回true。
      boolean isPrivate​()
      已过时。
      如果此程序元素是私有的，则返回true。
      boolean isProtected​()
      已过时。
      如果该程序元素被保护，返回true。
      boolean isPublic​()
      已过时。
      如果此程序元素为public，则返回true。
      boolean isStatic​()
      已过时。
      如果此程序元素是静态的，则返回true。
      String modifiers​()
      已过时。
      获取修饰符字符串。
      int modifierSpecifier​()
      已过时。
      获取修饰符说明符整数。
      String qualifiedName​()
      已过时。
      获取此程序元素的完全限定名称。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

    • 方法详细信息

      • containingClass

        ClassDoc containingClass​()
        已过时。
        获取该程序元素的包含类或接口。
        结果
        这个元素包含类或接口的ClassDoc。 如果这是顶级类或接口，返回null。

      • containingPackage

        PackageDoc containingPackage​()
        已过时。
        获取包含该程序元素的包。
        结果
        这个包含包的包的PackageDoc。 如果在未命名的包中，该PackageDoc将具有名称“”。

      • qualifiedName

        String qualifiedName​()
        已过时。
        获取此程序元素的完全限定名称。 例如，对于类java.util.Hashtable ，返回“java.util.Hashtable”。

        对于bar()在Foo中未命名的包中，返回“Foo.bar”。

        结果
        程序元素的限定名称作为String。

      • modifierSpecifier

        int modifierSpecifier​()
        已过时。
        获取修饰符说明符整数。
        结果
        获取修饰符说明符整数。
        另请参见：
        Modifier

      • modifiers

        String modifiers​()
        已过时。
        获取修饰符字符串。 例如：
          public abstract int foo() { ... }
        返回“公共摘要”。 注释不包括在内。
        结果
        “公共摘要”。

      • annotations

        AnnotationDesc[] annotations​()
        已过时。
        获取此程序元素的注释。 如果没有，返回一个空数组。
        结果
        该程序元素的注释。
        从以下版本开始：
        1.5

      • isPublic

        boolean isPublic​()
        已过时。
        如果此程序元素为public，则返回true。
        结果
        如果此程序元素是公开的，则为true。

      • isProtected

        boolean isProtected​()
        已过时。
        如果该程序元素被保护，返回true。
        结果
        如果此程序元素受保护，则为true。

      • isPrivate

        boolean isPrivate​()
        已过时。
        如果此程序元素是私有的，则返回true。
        结果
        如果此程序元素是私有的，则为true。

      • isPackagePrivate

        boolean isPackagePrivate​()
        已过时。
        如果这个程序元素是私有的，返回true。
        结果
        如果此程序元素是私有的，则为true。

      • isStatic

        boolean isStatic​()
        已过时。
        如果此程序元素是静态的，则返回true。
        结果
        如果此程序元素是静态的，则为true。

      • isFinal

        boolean isFinal​()
        已过时。
        如果此程序元素为final，则返回true。
        结果
        如果此程序元素是final，则为true。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RootDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface RootDoc

  • All Superinterfaces:
    Comparable<Object> ， Doc ， DocErrorReporter
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface RootDoc
extends Doc, DocErrorReporter
    表示一次运行javadoc的程序结构信息的根。 从此根可以提取所有其他程序结构信息。 还表示命令行信息 - 用户指定的包，类和选项。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      ClassDoc[] classes​()
      已过时。
      返回所有包中的 included类和接口。
      ClassDoc classNamed​(String qualifiedName)
      已过时。
      为指定的类或接口名返回ClassDoc。
      String[][] options​()
      已过时。
      命令行选项。
      PackageDoc packageNamed​(String name)
      已过时。
      为指定的包名返回一个PackageDoc。
      ClassDoc[] specifiedClasses​()
      已过时。
      在命令行上返回类和接口 specified作为源文件名。
      PackageDoc[] specifiedPackages​()
      已过时。
      在命令行上返回包 specified 。

      • Methods inherited from interface com.sun.javadoc.Doc

        commentText, compareTo, firstSentenceTags, getRawCommentText, inlineTags, isAnnotationType, isAnnotationTypeElement, isClass, isConstructor, isEnum, isEnumConstant, isError, isException, isField, isIncluded, isInterface, isMethod, isOrdinaryClass, name, position, seeTags, setRawCommentText, tags, tags

      • Methods inherited from interface com.sun.javadoc.DocErrorReporter

        printError, printError, printNotice, printNotice, printWarning, printWarning

    • 方法详细信息

      • options

        String[][] options​()
        已过时。
        命令行选项。

        例如，给出：

          javadoc -foo this that -bar other ...
        此方法将返回：
          options()[0][0] = "-foo"
      options()[0][1] = "this"
      options()[0][2] = "that"
      options()[1][0] = "-bar"
      options()[1][1] = "other"
        结果
        一组数组的String。

      • specifiedPackages

        PackageDoc[] specifiedPackages​()
        已过时。
        返回命令行中的软件包specified 。 如果使用-subpackages和-exclude选项，则返回所有未排除的包。
        结果
        在命令行中指定的包。

      • specifiedClasses

        ClassDoc[] specifiedClasses​()
        已过时。
        返回类和接口 specified作为命令行上的源文件名。
        结果
        在命令行上指定的类和接口。

      • classes

        ClassDoc[] classes​()
        已过时。
        返回所有包中的 included类和接口。
        结果
        包括所有包中的类和接口。

      • packageNamed

        PackageDoc packageNamed​(String name)
        已过时。
        为指定的包名返回一个PackageDoc。
        参数
        name - 软件包名称
        结果
        一个包含指定包的PackageDoc，如果未引用此包，则为null。

      • classNamed

        ClassDoc classNamed​(String qualifiedName)
        已过时。
        为指定的类或接口名返回ClassDoc。
        参数
        qualifiedName - qualified类或包名称
        结果
        a ClassDoc holding the specified class, null if this class is not referenced.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SeeTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface SeeTag

  • All Superinterfaces:
    Tag
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface SeeTag
extends Tag
    表示用户定义的相关文档的交叉引用。 标签可以引用包，类或成员，或者可以包含纯文本。 （纯文本可能是对不在线的东西的引用，例如打印的书，或者是硬编码的HTML链接。）引用可以与注释一起使用，使用{@link}或单独的块注释，使用@see 。 方法name()根据标签返回“@link”（无花括号）或“@see”。 方法kind()为两个标签返回“@see”。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      String label​()
      已过时。
      获取 @see标签的标签。
      ClassDoc referencedClass​()
      已过时。
      获取由@see的类名称引用的类文档。
      String referencedClassName​()
      已过时。
      获取 @see参考的类或接口名称。
      MemberDoc referencedMember​()
      已过时。
      获取 @see引用的字段，构造函数或方法的成员文档。
      String referencedMemberName​()
      已过时。
      获取 @see参考的字段，构造函数或方法子字符串。
      PackageDoc referencedPackage​()
      已过时。
      当 @see仅引用包时，获取包文档。

      • Methods inherited from interface com.sun.javadoc.Tag

        firstSentenceTags, holder, inlineTags, kind, name, position, text, toString

    • 方法详细信息

      • label

        String label​()
        已过时。
        获取@see标签的标签。 如果没有标签，则返回null。 例如：

        @see String#trim() the trim method

        返回“修剪方法”。
        结果
        “修剪法”。

      • referencedPackage

        PackageDoc referencedPackage​()
        已过时。
        当@see仅引用包时，获取包文档。 返回null如果包不能被发现，或者如果@see参考文献的任何其它元件（类，接口，域，构造，方法）或非元件。 例如：

        @see java.lang

        返回PackageDoc为java.lang 。
        结果
        PackageDoc为 java.lang 。

      • referencedClassName

        String referencedClassName​()
        已过时。
        获取@see参考的类或接口名称。 如果原始@see标记中指定的名称已经完全限定，或者可以找到类或接口，则该名称是完全限定的; 否则是不合格的。 如果@see仅引用包名称，则返回包名称。 例如：

        @see String#valueOf(java.lang.Object)

        返回“java.lang.String”。 对于“ @see java.lang ”，返回“java.lang”。 如果@see引用非元素（如@see <a href="java.sun.com"> ，则返回null。
        结果
        如果 @see引用非元素（如 @see <a href="java.sun.com"> 。

      • referencedClass

        ClassDoc referencedClass​()
        已过时。
        获取由@see的类名称引用的类文档。 如果找不到类，返回null。 例如：

        @see String#valueOf(java.lang.Object)

        返回ClassDoc为java.lang.String 。
        结果
        ClassDoc为 java.lang.String 。

      • referencedMemberName

        String referencedMemberName​()
        已过时。
        获取@see参考的字段，构造函数或方法子字符串。 如果引用是任何其他元素或任何非元素，则返回null。 引用成员类（嵌套类）返回null。 例如：

        @see String#startsWith(String)

        return“startsWith（String）”。
        结果
        “startsWith（字符串）”。

      • referencedMember

        MemberDoc referencedMember​()
        已过时。
        获取@see引用的字段，构造函数或方法的成员文档。 如果无法找到该成员或者引用是否为任何其他元素或任何非元素，则返回null。 引用成员类（嵌套类）返回null。 例如：

        @see String#startsWith(java.lang.String)

        返回MethodDoc为startsWith 。
        结果
        MethodDoc为 startsWith 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SerialFieldTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface SerialFieldTag

  • All Superinterfaces:
    Comparable<Object> ， Tag
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface SerialFieldTag
extends Tag, Comparable<Object>
    文档由ObjectStreamField定义的可序列化字段。
      The class parses and stores the three serialField tag parameters:

 - field name
 - field type name
      (fully-qualified or visible from the current import context)
 - description of the valid values for the field
    该标签只允许在特殊成员serialPersistentFields的javadoc中使用。
    另请参见：
    ObjectStreamField

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      int compareTo​(Object obj)
      已过时。
      将此对象与指定的对象进行比较。
      String description​()
      已过时。
      返回字段注释。
      String fieldName​()
      已过时。
      返回可序列化的字段名称。
      String fieldType​()
      已过时。
      返回字段类型字符串。
      ClassDoc fieldTypeDoc​()
      已过时。
      返回ClassDoc的字段类型。

      • Methods inherited from interface com.sun.javadoc.Tag

        firstSentenceTags, holder, inlineTags, kind, name, position, text, toString

    • 方法详细信息

      • fieldName

        String fieldName​()
        已过时。
        返回可序列化的字段名称。
        结果
        可序列化字段名称。

      • fieldType

        String fieldType​()
        已过时。
        返回字段类型字符串。
        结果
        字段类型字符串。

      • fieldTypeDoc

        ClassDoc fieldTypeDoc​()
        已过时。
        返回ClassDoc的字段类型。
        结果
        null如果没有ClassDoc的字段类型可以从containsClass上下文中看到。

      • description

        String description​()
        已过时。
        返回字段注释。 如果没有serialField注释，则返回相应FieldDoc的javadoc注释。
        结果
        现场评论。 如果没有serialField注释，则返回相应FieldDoc的javadoc注释。

      • compareTo

        int compareTo​(Object obj)
        已过时。
        将此对象与指定的对象进行比较。 返回负整数，零或正整数，因为该对象小于，等于或大于给定的对象。

        包括使SerialFieldTag项目java.lang.Comparable。

        Specified by:
        compareTo接口 Comparable<Object>
        参数
        obj - 要比较的 Object 。
        结果
        一个负整数，零或一个正整数，因为该对象小于，等于或大于给定的对象。
        异常
        ClassCastException - 指定的对象的类型阻止它与此对象进行比较。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SourcePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface SourcePosition

  • 已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface SourcePosition
    该界面描述了源位置：文件名，行号和列号。
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      int column​()
      已过时。
      源文件中的列。
      File file​()
      已过时。
      源文件。
      int line​()
      已过时。
      源文件中的行。
      String toString​()
      已过时。
      将源位置转换为“Filename：line”形式。

    • 方法详细信息

      • file

        File file​()
        已过时。
        源文件。 如果没有文件信息可用，则返回null。
        结果
        源文件作为文件。

      • line

        int line​()
        已过时。
        源文件中的行。 第一行编号为1; 0表示没有行号信息可用。
        结果
        源文件中的行号为整数。

      • column

        int column​()
        已过时。
        源文件中的列。 第一列编号为1; 0表示没有列信息可用。 列计算输入流中的字符; 一个选项卡将列号前进到下一个8列选项卡停止。
        结果
        源行上的列为整数。

      • toString

        String toString​()
        已过时。
        将源位置转换为“Filename：line”形式。
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Tag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface Tag

  • All Known Subinterfaces:
    ParamTag ， SeeTag ， SerialFieldTag ， ThrowsTag
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface Tag
    代表一个简单的文档标签，如@since，@author，@version。 给定标签（例如“@since 1.2”），保存标签名称（例如“@since”）和标签文本（例如“1.2”）。 具有结构或需要特殊处理的标签由ParamTag（for @param），SeeTag（for @see和）和ThrowsTag（for @ throws）等子类处理。
    另请参见：
    SeeTag ， ParamTag ， ThrowsTag ， SerialFieldTag ， Doc.tags()

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      Tag[] firstSentenceTags​()
      已过时。
      将注释的第一个句子作为标签数组返回。
      Doc holder​()
      已过时。
      返回此Tag元素的包含Doc 。
      Tag[] inlineTags​()
      已过时。
      有关嵌入式 {@link}标签的文档注释，请返回 Tag对象的数组。
      String kind​()
      已过时。
      返回这个标签的种类。
      String name​()
      已过时。
      返回此标签的名称。
      SourcePosition position​()
      已过时。
      返回此标签的源位置。
      String text​()
      已过时。
      返回此标签的文本，即超出标签名称的部分。
      String toString​()
      已过时。
      将此对象转换为字符串。

    • 方法详细信息

      • name

        String name​()
        已过时。
        返回此标签的名称。 名称是以@return注释中使用的“@”开头的字符串，如@return 。 对于内联标签，例如{@link} ，大括号不是名称的一部分，因此在此示例中，名称将仅为@link 。
        结果
        该标签的名称

      • holder

        Doc holder​()
        已过时。
        返回包含此Tag元素的Doc 。
        结果
        包含此Tag元素的Doc

      • kind

        String kind​()
        已过时。
        返回这个标签的种类。 对于大多数标签， kind() == name() ; 下表列出了某种类型的多个标签的情况： Related Tags kind() name() @throws @throws @throws @exception @see @see @see @link @see @linkplain @serial @serial @serial @serialData
        结果
        这个标签的种类。

      • text

        String text​()
        已过时。
        返回此标签的文本，即超出标签名称的部分。
        结果
        这个标签的文字

      • toString

        String toString​()
        已过时。
        将此对象转换为字符串。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • inlineTags

        Tag[] inlineTags​()
        已过时。
        有关嵌入式{@link}标签的文档注释，请返回Tag对象的数组。 整个文档注释被分解成由{@link}标记分隔的字符串，其中数组的每个连续元素按照{@link}顺序代表一个字符串或{@link}标记。 每个字符串由名称为“Text”的Tag对象表示，其中text()返回字符串。 每个{@link}标签由名称“@link”和种类“@see”的SeeTag表示。 例如，给出以下注释标签：

        This is a {@link Doc commentlabel} example.

        返回一个Tag对象数组：

        • 标签[0]是一个Tag ，名称为“文本”，文本由“这是一个”
        • 标签[1]是一个SeeTag ，名称为“@link”，引用类为Doc ，标签为“commentlabel”
        • 标签[2]是一个Tag ，名称为“文本”，文本由“示例”组成。
        结果
        标签[]数组的标签
        另请参见：
        ParamTag ， ThrowsTag

      • firstSentenceTags

        Tag[] firstSentenceTags​()
        已过时。
        将注释的第一个句子作为标签数组返回。 包括内联标签（即{@link reference }标签）），但不包括块标签。 纯文本的每一部分表示为类似“文本”的Tag 。 内联代码表示为“@link”类型的SeeTag 。 如果语言环境是英语，则第一句由Java语言规范（第一版）中描述的规则确定：“这句话在第一个句点结束，后面是空白，制表符或行终止符，或者在第一个句子标签“，另外一行将由终止HTML标签的段落和部分终止：<p> </ p> <h1> <h2> <h3> <h4> <h5> <h6> <hr> <pre>或</ pre>。 如果语言环境不是英文，则句子结束将由BreakIterator.getSentenceInstance(Locale)确定。
        结果
        代表评论第一句的Tag个对象的数组

      • position

        SourcePosition position​()
        已过时。
        返回此标签的源位置。
        结果
        该标签的源位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThrowsTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface ThrowsTag

  • All Superinterfaces:
    Tag
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface ThrowsTag
extends Tag
    代表@throws或@exception文档标签。 解析并保存异常名称和异常注释。 注意：@exception是@throws的向后兼容同义词。
    另请参见：
    ExecutableMemberDoc.throwsTags()

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      ClassDoc exception​()
      已过时。
      返回代表异常的 ClassDoc 。
      String exceptionComment​()
      已过时。
      返回与此 ThrowsTag相关联的异常注释。
      String exceptionName​()
      已过时。
      返回与此 ThrowsTag关联的异常的名称。
      Type exceptionType​()
      已过时。
      返回与此 ThrowsTag相关联的异常的类型。

      • Methods inherited from interface com.sun.javadoc.Tag

        firstSentenceTags, holder, inlineTags, kind, name, position, text, toString

    • 方法详细信息

      • exceptionName

        String exceptionName​()
        已过时。
        返回与此 ThrowsTag相关联的异常的名称。
        结果
        例外的名称

      • exceptionComment

        String exceptionComment​()
        已过时。
        返回与此 ThrowsTag相关联的异常注释。
        结果
        例外评论。

      • exception

        ClassDoc exception​()
        已过时。
        返回代表异常的ClassDoc 。 如果异常的类型是类型变量，则返回其擦除的ClassDoc 。

        此方法无法适应某些通用类型的构造。 应该使用exceptionType方法。

        结果
        ClassDoc表示异常。
        另请参见：
        exceptionType()

      • exceptionType

        Type exceptionType​()
        已过时。
        返回与此ThrowsTag相关联的异常的类型。 这可能是ClassDoc或TypeVariable 。
        结果
        异常的类型。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface Type

  • All Known Subinterfaces:
    AnnotatedType ， AnnotationTypeDoc ， ClassDoc ， ParameterizedType ， TypeVariable ， WildcardType
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface Type
    代表一种类型。 A型可以是一个类或接口，一个调用（像List<String>的通用类或接口），一个类型变量，通配符类型（“ ? ”），或者一个基本数据类型（如char ）。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotatedType asAnnotatedType​()
      已过时。
      如果它代表注释类型，则返回此类型为 AnnotatedType 。
      AnnotationTypeDoc asAnnotationTypeDoc​()
      已过时。
      如果它代表注释类型，则返回此类型为 AnnotationTypeDoc 。
      ClassDoc asClassDoc​()
      已过时。
      如果它代表一个类或接口，则返回此类型为 ClassDoc 。
      ParameterizedType asParameterizedType​()
      已过时。
      如果它代表泛型类或接口的调用，则返回此类型为 ParameterizedType 。
      TypeVariable asTypeVariable​()
      已过时。
      如果它代表一个类型变量，则返回此类型为 TypeVariable 。
      WildcardType asWildcardType​()
      已过时。
      如果表示通配符类型，则返回此类型为 WildcardType 。
      String dimension​()
      已过时。
      返回类型的维度信息，作为字符串。
      Type getElementType​()
      已过时。
      如果此类型是数组类型，则返回数组的元素类型。
      boolean isPrimitive​()
      已过时。
      如果此类型表示原始类型，则返回true。
      String qualifiedTypeName​()
      已过时。
      返回不包括任何维度信息的类型的限定名称。
      String simpleTypeName​()
      已过时。
      返回此类型的简单名称，不包括任何维度信息。
      String toString​()
      已过时。
      返回类型的字符串表示形式。
      String typeName​()
      已过时。
      返回类型的不合格的名称，不包括任何维度信息。

    • 方法详细信息

      • typeName

        String typeName​()
        已过时。
        返回类型的不合格的名称，不包括任何维度信息。

        例如，String的二维数组返回“ String ”。

        结果
        类型不合格的名称，不包括任何维度信息。

      • qualifiedTypeName

        String qualifiedTypeName​()
        已过时。
        返回不包括任何维度信息的类型的限定名称。

        例如，String的二维数组返回“ java.lang.String ”。

        结果
        此类型的限定名称，不包括任何维度信息。

      • simpleTypeName

        String simpleTypeName​()
        已过时。
        返回此类型的简单名称，不包括任何维度信息。 这是类型的不合格的名称，除了对于嵌套类型，只包括最内部类型的标识符。

        例如， Outer.Inner类返回“ Inner ”。

        结果
        此类型的简单名称不包括任何维度信息。
        从以下版本开始：
        1.5

      • dimension

        String dimension​()
        已过时。
        返回类型的维度信息，作为字符串。

        例如，String的二维数组返回“ [][] ”。

        结果
        该类型的维度信息作为字符串。

      • toString

        String toString​()
        已过时。
        返回类型的字符串表示形式。 这包括任何维度信息和类型参数。

        例如，String的二维数组可以返回“ java.lang.String[][] ”，参数化类型List<Integer>可以返回“ java.util.List<java.lang.Integer> ”。

        重写：
        toString在 Object
        结果
        类型的字符串表示形式。

      • isPrimitive

        boolean isPrimitive​()
        已过时。
        如果此类型表示原始类型，则返回true。
        结果
        如果此类型表示原始类型，则为true。
        从以下版本开始：
        1.5

      • asClassDoc

        ClassDoc asClassDoc​()
        已过时。
        如果表示类或接口，则返回此类型为ClassDoc 。 阵列尺寸被忽略。 如果这个类型是ParameterizedType ， TypeVariable ，或WildcardType ，返回ClassDoc类型的擦除。 如果这是一个AnnotationTypeDoc ， AnnotationTypeDoc其作为ClassDoc （但请参阅asAnnotationTypeDoc() ）。 如果这是一个原始类型，返回null。
        结果
        这种类型的 ClassDoc ，如果是原始类型，则为null。

      • asParameterizedType

        ParameterizedType asParameterizedType​()
        已过时。
        如果它代表通用类或接口的调用，则返回此类型为ParameterizedType 。 阵列尺寸被忽略。
        结果
        一个 ParameterizedType如果类型是泛型类型的调用，或者null（如果不是）。
        从以下版本开始：
        1.5

      • asTypeVariable

        TypeVariable asTypeVariable​()
        已过时。
        如果它代表一个类型变量，则返回此类型为TypeVariable 。 阵列尺寸被忽略。
        结果
        一个 TypeVariable如果类型是一个类型变量，或者如果不是类型变量则为null。
        从以下版本开始：
        1.5

      • asWildcardType

        WildcardType asWildcardType​()
        已过时。
        如果表示通配符类型，则返回此类型为 WildcardType 。
        结果
        一个 WildcardType如果该类型是通配符类型，或者为null，如果不是。
        从以下版本开始：
        1.5

      • asAnnotatedType

        AnnotatedType asAnnotatedType​()
        已过时。
        如果它代表注释类型，则返回此类型为 AnnotatedType 。
        结果
        一个 AnnotatedType如果类型为注释类型，或者为null，如果不是
        从以下版本开始：
        1.8

      • asAnnotationTypeDoc

        AnnotationTypeDoc asAnnotationTypeDoc​()
        已过时。
        如果它代表注释类型，则返回此类型为AnnotationTypeDoc 。 阵列尺寸被忽略。
        结果
        如果类型是注释类型， AnnotationTypeDoc ，否则为null。
        从以下版本开始：
        1.5

      • getElementType

        Type getElementType​()
        已过时。
        如果此类型是数组类型，则返回数组的元素类型。 否则返回null。
        结果
        一个 Type表示元素类型或null。
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TypeVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface TypeVariable

  • All Superinterfaces:
    Type
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface TypeVariable
extends Type
    表示一个类型变量。 例如，通用接口List<E>具有单个类型变量E 。 类型变量可能有明确的界限，如C<R extends Remote> 。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      AnnotationDesc[] annotations​()
      已过时。
      获取此程序元素的注释。
      Type[] bounds​()
      已过时。
      返回此类型变量的边界。
      ProgramElementDoc owner​()
      已过时。
      返回声明此类型变量的类，接口，方法或构造函数。

      • Methods inherited from interface com.sun.javadoc.Type

        asAnnotatedType, asAnnotationTypeDoc, asClassDoc, asParameterizedType, asTypeVariable, asWildcardType, dimension, getElementType, isPrimitive, qualifiedTypeName, simpleTypeName, toString, typeName

    • 方法详细信息

      • bounds

        Type[] bounds​()
        已过时。
        返回此类型变量的边界。 这些是由extends子句给出的类型。 如果没有显式界限，则返回一个空数组。
        结果
        这种类型变量的界限。

      • owner

        ProgramElementDoc owner​()
        已过时。
        返回声明此类型变量的类，接口，方法或构造函数。
        结果
        声明此类型变量的类，接口，方法或构造函数。

      • annotations

        AnnotationDesc[] annotations​()
        已过时。
        获取此程序元素的注释。 如果没有，返回一个空数组。
        结果
        该程序元素的注释或空数组，如果没有。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.javadoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.javadoc

  • Packages that use com.sun.javadoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets.standard
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
  • Classes in com.sun.javadoc used by com.sun.javadoc
    Class 描述
    AnnotatedType
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    AnnotationDesc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    AnnotationDesc.ElementValuePair
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    AnnotationTypeDoc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    AnnotationTypeElementDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    AnnotationValue
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    ClassDoc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    ConstructorDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    Doc
    已过时。
    该包裹中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    DocErrorReporter
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    ExecutableMemberDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    FieldDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    LanguageVersion
    已过时。
    该包裹中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    MemberDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    MethodDoc
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    PackageDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    Parameter
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    ParameterizedType
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    ParamTag
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    ProgramElementDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    RootDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    SeeTag
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    SerialFieldTag
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    SourcePosition
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    Tag
    已过时。
    该包裹中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    ThrowsTag
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    Type
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    TypeVariable
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    WildcardType
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
  • Classes in com.sun.javadoc used by com.sun.tools.doclets
    Class 描述
    Tag
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
  • Classes in com.sun.javadoc used by com.sun.tools.doclets.standard
    Class 描述
    DocErrorReporter
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    LanguageVersion
    已过时。
    该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
    RootDoc
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


WildcardType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.javadoc

Interface WildcardType

  • All Superinterfaces:
    Type
    已过时。
    该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    @Deprecated
public interface WildcardType
extends Type
    表示通配符类型参数。 示例包括：
      <?>
 <? extends E>
 <? super T>
    通配符类型可以具有明确的扩展边界或显式超级边界或两者，但不能两者。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      Type[] extendsBounds​()
      已过时。
      返回由 扩展子句给出的此通配符类型参数的上限。
      Type[] superBounds​()
      已过时。
      返回由 超级子句给出的此通配符类型参数的下限。

      • Methods inherited from interface com.sun.javadoc.Type

        asAnnotatedType, asAnnotationTypeDoc, asClassDoc, asParameterizedType, asTypeVariable, asWildcardType, dimension, getElementType, isPrimitive, qualifiedTypeName, simpleTypeName, toString, typeName

    • 方法详细信息

      • extendsBounds

        Type[] extendsBounds​()
        已过时。
        返回由扩展子句给出的此通配符类型参数的上限。 如果没有明确给出这样的边界，则返回一个空数组。
        结果
        该通配符类型参数的扩展范围

      • superBounds

        Type[] superBounds​()
        已过时。
        返回由超级子句给出的此通配符类型参数的下限。 如果没有明确给出这样的边界，则返回一个空数组。
        结果
        这个通配符类型参数的超级边界
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.javadoc.Doclet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.javadoc.Doclet

No usage of com.sun.javadoc.Doclet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.javadoc.LanguageVersion (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.javadoc.LanguageVersion

  • Packages that use LanguageVersion
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets.standard
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

    • Uses of LanguageVersion in com.sun.javadoc

      Methods in com.sun.javadoc that return LanguageVersion
      Modifier and Type 方法 描述
      static LanguageVersion Doclet.languageVersion​()
      已过时。
      返回此doclet支持的Java编程语言版本。
      static LanguageVersion LanguageVersion.valueOf​(String name)
      已过时。
      以指定的名称返回此类型的枚举常量。
      static LanguageVersion[] LanguageVersion.values​()
      已过时。
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of LanguageVersion in com.sun.tools.doclets.standard

      Methods in com.sun.tools.doclets.standard that return LanguageVersion
      Modifier and Type 方法 描述
      static LanguageVersion Standard.languageVersion​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.AnnotatedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.AnnotatedType

  • Packages that use AnnotatedType
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of AnnotatedType in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotatedType
      Modifier and Type 方法 描述
      AnnotatedType Type.asAnnotatedType​()
      已过时。
      如果它代表注释类型，则返回此类型为 AnnotatedType 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.AnnotationDesc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.AnnotationDesc

  • Packages that use AnnotationDesc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of AnnotationDesc in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationDesc
      Modifier and Type 方法 描述
      AnnotationDesc[] AnnotatedType.annotations​()
      已过时。
      返回与此类型相关联的注释。
      AnnotationDesc[] PackageDoc.annotations​()
      已过时。
      获取此包的注释。
      AnnotationDesc[] Parameter.annotations​()
      已过时。
      获取此参数的注释。
      AnnotationDesc[] ProgramElementDoc.annotations​()
      已过时。
      获取此程序元素的注释。
      AnnotationDesc[] TypeVariable.annotations​()
      已过时。
      获取此程序元素的注释。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.AnnotationDesc.ElementValuePair (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.AnnotationDesc.ElementValuePair

  • Packages that use AnnotationDesc.ElementValuePair
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of AnnotationDesc.ElementValuePair in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationDesc.ElementValuePair
      Modifier and Type 方法 描述
      AnnotationDesc.ElementValuePair[] AnnotationDesc.elementValues​()
      已过时。
      返回此注释的元素及其值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.AnnotationTypeDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.AnnotationTypeDoc

  • Packages that use AnnotationTypeDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of AnnotationTypeDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationTypeDoc
      Modifier and Type 方法 描述
      AnnotationTypeDoc AnnotationDesc.annotationType​()
      已过时。
      返回此注释的注释类型。
      AnnotationTypeDoc[] PackageDoc.annotationTypes​()
      已过时。
      在此包中获取包含的注释类型。
      AnnotationTypeDoc Type.asAnnotationTypeDoc​()
      已过时。
      Return this type as an AnnotationTypeDoc if it represents an annotation type.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.AnnotationTypeElementDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.AnnotationTypeElementDoc

  • Packages that use AnnotationTypeElementDoc
    软件包 描述
    com.sun.javadoc
    注意：该包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of AnnotationTypeElementDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationTypeElementDoc
      Modifier and Type 方法 描述
      AnnotationTypeElementDoc AnnotationDesc.ElementValuePair.element​()
      已过时。
      返回注释类型元素。
      AnnotationTypeElementDoc[] AnnotationTypeDoc.elements​()
      已过时。
      返回此注释类型的元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.AnnotationValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.AnnotationValue

  • Packages that use AnnotationValue
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of AnnotationValue in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationValue
      Modifier and Type 方法 描述
      AnnotationValue AnnotationTypeElementDoc.defaultValue​()
      已过时。
      返回此元素的默认值。
      AnnotationValue AnnotationDesc.ElementValuePair.value​()
      已过时。
      返回与注释类型元素关联的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.ClassDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.ClassDoc

  • Packages that use ClassDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of ClassDoc in com.sun.javadoc

      Subinterfaces of ClassDoc in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotationTypeDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc that return ClassDoc
      Modifier and Type 方法 描述
      ClassDoc[] PackageDoc.allClasses​()
      已过时。
      在包中获取所有 included类和接口。
      ClassDoc[] PackageDoc.allClasses​(boolean filter)
      已过时。
      获取包中的所有类和接口，过滤到指定的 access modifier option 。
      ClassDoc ParameterizedType.asClassDoc​()
      已过时。
      返回声明此类型的泛型类或接口。
      ClassDoc Type.asClassDoc​()
      已过时。
      如果表示类或接口，则返回此类型为 ClassDoc 。
      ClassDoc[] RootDoc.classes​()
      已过时。
      返回所有包中的 included类和接口。
      ClassDoc RootDoc.classNamed​(String qualifiedName)
      已过时。
      为指定的类或接口名返回ClassDoc。
      ClassDoc ProgramElementDoc.containingClass​()
      已过时。
      获取该程序元素的包含类或接口。
      ClassDoc[] PackageDoc.enums​()
      已过时。
      在此包中获取包含的枚举类型。
      ClassDoc[] PackageDoc.errors​()
      已过时。
      获取包含此包中的错误类。
      ClassDoc ThrowsTag.exception​()
      已过时。
      返回代表异常的 ClassDoc 。
      ClassDoc[] PackageDoc.exceptions​()
      已过时。
      在此包中包含异常类。
      ClassDoc SerialFieldTag.fieldTypeDoc​()
      已过时。
      返回ClassDoc的字段类型。
      ClassDoc ClassDoc.findClass​(String className)
      已过时。
      在该类doc的上下文中找到指定的类或接口。
      ClassDoc PackageDoc.findClass​(String className)
      已过时。
      在此包中查找类或接口。
      ClassDoc[] ClassDoc.importedClasses​()
      已过时。
      导入声明是不应该在这里公开的实现细节。 另外，并不是所有导入的类都是通过单一类型导入的声明导入的。
      ClassDoc[] ClassDoc.innerClasses​()
      已过时。
      返回 included此类或接口中的嵌套类和接口。
      ClassDoc[] ClassDoc.innerClasses​(boolean filter)
      已过时。
      返回此类或接口中的嵌套类和接口，过滤到指定的 access modifier option 。
      ClassDoc[] ClassDoc.interfaces​()
      已过时。
      返回由此类实现的接口或此接口扩展的接口。
      ClassDoc[] PackageDoc.interfaces​()
      已过时。
      在此包中获取包含的接口，省略注释类型。
      ClassDoc[] PackageDoc.ordinaryClasses​()
      已过时。
      在此包中包含 ordinary类（即，排除异常，错误，枚举，接口和注释类型）。
      ClassDoc MethodDoc.overriddenClass​()
      已过时。
      返回包含此方法覆盖的方法的类。
      ClassDoc SeeTag.referencedClass​()
      已过时。
      获取由@see的类名称引用的类文档。
      ClassDoc[] RootDoc.specifiedClasses​()
      已过时。
      在命令行上返回类和接口 specified作为源文件名。
      ClassDoc ClassDoc.superclass​()
      已过时。
      返回此类的超类。
      ClassDoc[] ExecutableMemberDoc.thrownExceptions​()
      已过时。
      返回此方法或构造函数抛出的异常。
      Methods in com.sun.javadoc with parameters of type ClassDoc
      Modifier and Type 方法 描述
      boolean ClassDoc.subclassOf​(ClassDoc cd)
      已过时。
      Test whether this class is a subclass of the specified class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.ConstructorDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.ConstructorDoc

  • Packages that use ConstructorDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of ConstructorDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return ConstructorDoc
      Modifier and Type 方法 描述
      ConstructorDoc[] ClassDoc.constructors​()
      已过时。
      返回这个类中的 included构造函数。
      ConstructorDoc[] ClassDoc.constructors​(boolean filter)
      已过时。
      在此类中返回构造函数，过滤到指定的 access modifier option 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.Doc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.Doc

  • Packages that use Doc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of Doc in com.sun.javadoc

      Subinterfaces of Doc in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotationTypeDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationTypeElementDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ClassDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ConstructorDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ExecutableMemberDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  FieldDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MemberDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MethodDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  PackageDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ProgramElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  RootDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc that return Doc
      Modifier and Type 方法 描述
      Doc Tag.holder​()
      已过时。
      Return the containing Doc of this Tag element.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.DocErrorReporter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.DocErrorReporter

  • Packages that use DocErrorReporter
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets.standard
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

    • Uses of DocErrorReporter in com.sun.javadoc

      Subinterfaces of DocErrorReporter in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  RootDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc with parameters of type DocErrorReporter
      Modifier and Type 方法 描述
      static boolean Doclet.validOptions​(String[][] options, DocErrorReporter reporter)
      已过时。
      检查选项是否具有正确的参数。

    • Uses of DocErrorReporter in com.sun.tools.doclets.standard

      Methods in com.sun.tools.doclets.standard with parameters of type DocErrorReporter
      Modifier and Type 方法 描述
      static boolean Standard.validOptions​(String[][] options, DocErrorReporter reporter)
      Deprecated, for removal: This API element is subject to removal in a future version.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.ExecutableMemberDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.ExecutableMemberDoc

  • Packages that use ExecutableMemberDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of ExecutableMemberDoc in com.sun.javadoc

      Subinterfaces of ExecutableMemberDoc in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotationTypeElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ConstructorDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MethodDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.FieldDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.FieldDoc

  • Packages that use FieldDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of FieldDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return FieldDoc
      Modifier and Type 方法 描述
      FieldDoc[] ClassDoc.enumConstants​()
      已过时。
      如果这是枚举类型，则返回枚举常量。
      FieldDoc[] ClassDoc.fields​()
      已过时。
      返回 此类或接口中的 included字段。
      FieldDoc[] ClassDoc.fields​(boolean filter)
      已过时。
      返回此类或接口中的字段，过滤到指定的 access modifier option 。
      FieldDoc[] ClassDoc.serializableFields​()
      已过时。
      返回此类或接口的Serializable字段。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.MemberDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.MemberDoc

  • Packages that use MemberDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of MemberDoc in com.sun.javadoc

      Subinterfaces of MemberDoc in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotationTypeElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ConstructorDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ExecutableMemberDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  FieldDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MethodDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc that return MemberDoc
      Modifier and Type 方法 描述
      MemberDoc SeeTag.referencedMember​()
      已过时。
      Get the member doc for the field, constructor or method referenced by @see.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.MethodDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.MethodDoc

  • Packages that use MethodDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of MethodDoc in com.sun.javadoc

      Subinterfaces of MethodDoc in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotationTypeElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc that return MethodDoc
      Modifier and Type 方法 描述
      MethodDoc[] ClassDoc.methods​()
      已过时。
      返回 此类或接口中的 included方法。
      MethodDoc[] ClassDoc.methods​(boolean filter)
      已过时。
      返回这个类或接口的方法，过滤到指定的 access modifier option 。
      MethodDoc MethodDoc.overriddenMethod​()
      已过时。
      返回此方法覆盖的方法。
      MethodDoc[] ClassDoc.serializationMethods​()
      已过时。
      返回此类或接口的序列化方法。
      Methods in com.sun.javadoc with parameters of type MethodDoc
      Modifier and Type 方法 描述
      boolean MethodDoc.overrides​(MethodDoc meth)
      已过时。
      Tests whether this method overrides another.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.PackageDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.PackageDoc

  • Packages that use PackageDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of PackageDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return PackageDoc
      Modifier and Type 方法 描述
      PackageDoc ProgramElementDoc.containingPackage​()
      已过时。
      获取包含该程序元素的包。
      PackageDoc[] ClassDoc.importedPackages​()
      已过时。
      导入声明是不应该在这里公开的实现细节。 此外，此方法的返回类型不允许返回所有类型导入按需的声明。
      PackageDoc RootDoc.packageNamed​(String name)
      已过时。
      为指定的包名返回一个PackageDoc。
      PackageDoc SeeTag.referencedPackage​()
      已过时。
      当 @see仅引用包时，获取包文档。
      PackageDoc[] RootDoc.specifiedPackages​()
      已过时。
      在命令行上返回包 specified 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.Parameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.Parameter

  • Packages that use Parameter
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of Parameter in com.sun.javadoc

      Methods in com.sun.javadoc that return Parameter
      Modifier and Type 方法 描述
      Parameter[] ExecutableMemberDoc.parameters​()
      已过时。
      获取参数信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.ParameterizedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.ParameterizedType

  • Packages that use ParameterizedType
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of ParameterizedType in com.sun.javadoc

      Methods in com.sun.javadoc that return ParameterizedType
      Modifier and Type 方法 描述
      ParameterizedType Type.asParameterizedType​()
      已过时。
      如果它代表泛型类或接口的调用，则返回此类型为 ParameterizedType 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.ParamTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.ParamTag

  • Packages that use ParamTag
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of ParamTag in com.sun.javadoc

      Methods in com.sun.javadoc that return ParamTag
      Modifier and Type 方法 描述
      ParamTag[] ExecutableMemberDoc.paramTags​()
      已过时。
      返回此方法中的参数标签，不包括类型参数标签。
      ParamTag[] ClassDoc.typeParamTags​()
      已过时。
      返回此类或接口的类型参数标签。
      ParamTag[] ExecutableMemberDoc.typeParamTags​()
      已过时。
      Return the type parameter tags in this method.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.ProgramElementDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.ProgramElementDoc

  • Packages that use ProgramElementDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of ProgramElementDoc in com.sun.javadoc

      Subinterfaces of ProgramElementDoc in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotationTypeDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationTypeElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ClassDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ConstructorDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ExecutableMemberDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  FieldDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MemberDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MethodDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc that return ProgramElementDoc
      Modifier and Type 方法 描述
      ProgramElementDoc TypeVariable.owner​()
      已过时。
      Return the class, interface, method, or constructor within which this type variable is declared.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.RootDoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.RootDoc

  • Packages that use RootDoc
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets.standard
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

    • Uses of RootDoc in com.sun.javadoc

      Methods in com.sun.javadoc with parameters of type RootDoc
      Modifier and Type 方法 描述
      static boolean Doclet.start​(RootDoc root)
      已过时。
      在此生成文档。

    • Uses of RootDoc in com.sun.tools.doclets.standard

      Methods in com.sun.tools.doclets.standard with parameters of type RootDoc
      Modifier and Type 方法 描述
      static boolean Standard.start​(RootDoc root)
      不推荐用于删除：此API元素将在以后的版本中被删除。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.SeeTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.SeeTag

  • Packages that use SeeTag
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of SeeTag in com.sun.javadoc

      Methods in com.sun.javadoc that return SeeTag
      Modifier and Type 方法 描述
      SeeTag[] Doc.seeTags​()
      已过时。
      返回此文件中的参见标签。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.SerialFieldTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.SerialFieldTag

  • Packages that use SerialFieldTag
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of SerialFieldTag in com.sun.javadoc

      Methods in com.sun.javadoc that return SerialFieldTag
      Modifier and Type 方法 描述
      SerialFieldTag[] FieldDoc.serialFieldTags​()
      已过时。
      返回此FieldDoc项中的serialField标记。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.SourcePosition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.SourcePosition

  • Packages that use SourcePosition
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of SourcePosition in com.sun.javadoc

      Methods in com.sun.javadoc that return SourcePosition
      Modifier and Type 方法 描述
      SourcePosition Doc.position​()
      已过时。
      返回相应声明的第一行的源位置，如果没有位置可用，则返回null。
      SourcePosition Tag.position​()
      已过时。
      返回此标签的源位置。
      Methods in com.sun.javadoc with parameters of type SourcePosition
      Modifier and Type 方法 描述
      void DocErrorReporter.printError​(SourcePosition pos, String msg)
      已过时。
      打印错误消息并增加错误计数。
      void DocErrorReporter.printNotice​(SourcePosition pos, String msg)
      已过时。
      打印信息。
      void DocErrorReporter.printWarning​(SourcePosition pos, String msg)
      已过时。
      打印警告信息并增加警告计数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.Tag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.Tag

  • Packages that use Tag
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

    • Uses of Tag in com.sun.javadoc

      Subinterfaces of Tag in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  ParamTag
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  SeeTag
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  SerialFieldTag
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ThrowsTag
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc that return Tag
      Modifier and Type 方法 描述
      Tag[] Doc.firstSentenceTags​()
      已过时。
      将注释的第一个句子作为标签数组返回。
      Tag[] Tag.firstSentenceTags​()
      已过时。
      将注释的第一个句子作为标签数组返回。
      Tag[] Doc.inlineTags​()
      已过时。
      将注释作为标签数组返回。
      Tag[] Tag.inlineTags​()
      已过时。
      有关嵌入式 {@link}标签的文档注释，请返回 Tag对象的数组。
      Tag[] Doc.tags​()
      已过时。
      返回此文件中的所有标签。
      Tag[] Doc.tags​(String tagname)
      已过时。
      返回本文档中指定的 kind的标签。

    • Uses of Tag in com.sun.tools.doclets

      Methods in com.sun.tools.doclets with parameters of type Tag
      Modifier and Type 方法 描述
      String Taglet.toString​(Tag tag)
      已过时。
      给定此自定义标签的 Tag表示，返回其字符串表示，将其输出到生成的页面。
      String Taglet.toString​(Tag[] tags)
      已过时。
      给出一个代表这个自定义标签的数组 Tag s，返回它的字符串表示，输出到生成的页面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.ThrowsTag (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.ThrowsTag

  • Packages that use ThrowsTag
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of ThrowsTag in com.sun.javadoc

      Methods in com.sun.javadoc that return ThrowsTag
      Modifier and Type 方法 描述
      ThrowsTag[] ExecutableMemberDoc.throwsTags​()
      已过时。
      在此方法中返回throws标签。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.Type

  • Packages that use Type
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of Type in com.sun.javadoc

      Subinterfaces of Type in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotatedType
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationTypeDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ClassDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ParameterizedType
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  TypeVariable
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  WildcardType
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc that return Type
      Modifier and Type 方法 描述
      Type[] TypeVariable.bounds​()
      已过时。
      返回此类型变量的边界。
      Type ParameterizedType.containingType​()
      已过时。
      将包含此类型的类型作为成员返回。
      Type ThrowsTag.exceptionType​()
      已过时。
      返回与此 ThrowsTag关联的异常的类型。
      Type[] WildcardType.extendsBounds​()
      已过时。
      返回由 扩展子句给出的此通配符类型参数的上限。
      Type Type.getElementType​()
      已过时。
      如果此类型是数组类型，则返回数组的元素类型。
      Type[] ClassDoc.interfaceTypes​()
      已过时。
      返回由此类实现的接口或此接口扩展的接口。
      Type[] ParameterizedType.interfaceTypes​()
      已过时。
      返回由该参数化类型直接实现或扩展的接口类型。
      Type MethodDoc.overriddenType​()
      已过时。
      返回包含此方法覆盖的方法的类型。
      Type ExecutableMemberDoc.receiverType​()
      已过时。
      获取此可执行元素的接收器类型。
      Type MethodDoc.returnType​()
      已过时。
      获取返回类型。
      Type[] WildcardType.superBounds​()
      已过时。
      返回由 超级子句给出的此通配符类型参数的下限。
      Type ClassDoc.superclassType​()
      已过时。
      返回此类的超类。
      Type ParameterizedType.superclassType​()
      已过时。
      返回该类的直接超类型。
      Type[] ExecutableMemberDoc.thrownExceptionTypes​()
      已过时。
      返回此方法或构造函数抛出的异常。
      Type FieldDoc.type​()
      已过时。
      获取此字段的类型。
      Type Parameter.type​()
      已过时。
      获取此参数的类型。
      Type[] ParameterizedType.typeArguments​()
      已过时。
      返回此类型的实际类型参数。
      Type AnnotatedType.underlyingType​()
      已过时。
      Returns the underlying type.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.TypeVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.TypeVariable

  • Packages that use TypeVariable
    软件包 描述
    com.sun.javadoc
    注意：该包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of TypeVariable in com.sun.javadoc

      Methods in com.sun.javadoc that return TypeVariable
      Modifier and Type 方法 描述
      TypeVariable Type.asTypeVariable​()
      已过时。
      如果它表示一个类型变量，则返回此类型为 TypeVariable 。
      TypeVariable[] ClassDoc.typeParameters​()
      已过时。
      返回此类或接口的形式类型参数。
      TypeVariable[] ExecutableMemberDoc.typeParameters​()
      已过时。
      Return the formal type parameters of this method or constructor.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.javadoc.WildcardType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.javadoc.WildcardType

  • Packages that use WildcardType
    软件包 描述
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

    • Uses of WildcardType in com.sun.javadoc

      Methods in com.sun.javadoc that return WildcardType
      Modifier and Type 方法 描述
      WildcardType Type.asWildcardType​()
      已过时。
      如果表示通配符类型，则返回此类型为 WildcardType 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AbsentInformationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class AbsentInformationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.jdi.AbsentInformationException
  • All Implemented Interfaces:
    Serializable

    public class AbsentInformationException
extends 异常
    抛出以表示行号或变量信息不可用。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AbsentInformationException​()
      AbsentInformationException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AbsentInformationException

        public AbsentInformationException​()

      • AbsentInformationException

        public AbsentInformationException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Accessible (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Accessible

  • All Known Subinterfaces:
    ArrayType ， ClassType ， Field ， InterfaceType ， 方法 ， ReferenceType ， TypeComponent

    public interface Accessible
    提供有关类型或类型组件的可访问性的信息。 允许访问说明符（私有，受保护，公共）的程序元素的镜像通过该接口提供该声明部分的信息。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean isPackagePrivate​()
      确定此对象是否反映包私有项。
      boolean isPrivate​()
      确定此对象是否反映私有项目。
      boolean isProtected​()
      确定此对象是否反映受保护的项目。
      boolean isPublic​()
      确定此对象是否反映公共项目。
      int modifiers​()
      返回编码为整数的Java编程语言修饰符。

    • 方法详细信息

      • modifiers

        int modifiers​()
        返回编码为整数的Java编程语言修饰符。

        修改符编码在The Java™ Virtual Machine Specification中的access_flag表（4.1节），字段（第4.5节）和方法（第4.6节）中定义。

      • isPrivate

        boolean isPrivate​()
        确定此对象是否反映私有项目。 对于ArrayType ，返回值取决于数组组件类型。 对于原始数组，返回值始终为false。 对于对象数组，返回值与组件类型返回的值相同。 对于原始类，如Integer.TYPE ，返回值始终为false。
        结果
        true用于true的项目; false否则。

      • isPackagePrivate

        boolean isPackagePrivate​()
        确定此对象是否反映包私有项。 一个包私有项被声明，没有访问说明符。 对于ArrayType ，返回值取决于数组组件类型。 对于原始数组，返回值始终为false。 对于对象数组，返回值与组件类型返回的值相同。 对于原始类，例如Integer.TYPE ，返回值始终为false。
        结果
        true的项目; 否则为false 。

      • isProtected

        boolean isProtected​()
        确定此对象是否反映受保护的项目。 对于ArrayType ，返回值取决于数组组件类型。 对于原始数组，返回值始终为false。 对于对象数组，返回值与组件类型返回的值相同。 对于原始类，如Integer.TYPE ，返回值始终为false。
        结果
        true用于true的项目; false否则。

      • isPublic

        boolean isPublic​()
        确定此对象是否反映公共项目。 对于ArrayType ，返回值取决于数组组件类型。 对于原始数组，返回值始终为真。 对于对象数组，返回值与组件类型返回的值相同。 对于原始类，如Integer.TYPE ，返回值始终为true。
        结果
        true用于公共访问的项目; false否则。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ArrayReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ArrayReference

  • All Superinterfaces:
    Mirror ， ObjectReference ， Value

    public interface ArrayReference
extends ObjectReference
    提供对目标虚拟机中数组对象及其组件的访问。 每个阵列组件由Value对象镜像。 集合中的数组组件放置在List对象中，而不是数组，以与API的其余部分保持一致，并与其他API的互操作性。
    从以下版本开始：
    1.3

    • Field Summary

      • Fields inherited from interface com.sun.jdi.ObjectReference

        INVOKE_NONVIRTUAL, INVOKE_SINGLE_THREADED

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Value getValue​(int index)
      返回数组组件值。
      List<Value> getValues​()
      返回此数组中的所有组件。
      List<Value> getValues​(int index, int length)
      返回一系列数组组件。
      int length​()
      返回此数组中的组件数。
      void setValue​(int index, Value value)
      用另一个值替换数组组件。
      void setValues​(int index, List<? extends Value> values, int srcIndex, int length)
      用其他值替换一系列阵列组件。
      void setValues​(List<? extends Value> values)
      用其他值替换所有数组组件。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ObjectReference

        disableCollection, enableCollection, entryCount, equals, getValue, getValues, hashCode, invokeMethod, isCollected, owningThread, referenceType, referringObjects, setValue, uniqueID, waitingThreads

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • length

        int length​()
        返回此数组中的组件数。
        结果
        该数组中的组件的整数计数。

      • getValue

        Value getValue​(int index)
        返回数组组件值。
        参数
        index - 要检索的组件的索引
        结果
        在指定的Value 。
        异常
        IndexOutOfBoundsException - 如果index在此数组的范围之外，也就是说，如果满足以下任一条件：
          index < 0
    index >= length()

      • getValues

        List<Value> getValues​()
        返回此数组中的所有组件。
        结果
        一个Value个对象的列表，每个数组组件一个由数组索引排序。 对于零长度数组，返回一个空列表。

      • getValues

        List<Value> getValues​(int index,
                      int length)
        返回一系列数组组件。
        参数
        index - 要检索的第一个组件的索引
        length - 要检索的组件的数量，或-1将所有组件检索到该数组的末尾。
        结果
        一个Value对象的列表，每个请求的数组组件一个由数组索引排序。 当指定范围内没有元素（例如， length为零）时，将返回一个空列表
        异常
        IndexOutOfBoundsException - 如果使用index和length指定的范围不在数组范围内，也就是说，如果满足以下任一条件：
          index < 0
    index > length()
        或者如果是length != -1并且以下任一项为真：
          length < 0
    index + length >  length()

      • setValue

        void setValue​(int index,
              Value value)
       throws InvalidTypeException,
              ClassNotLoadedException
        用另一个值替换数组组件。

        对象值必须与组件类型分配兼容（这意味着组件类型必须通过声明类的类加载器加载）。 原始值必须与组件类型兼容，或必须可转换为组件类型，而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。

        参数
        value - 新值
        index - 要设置的组件的索引
        异常
        IndexOutOfBoundsException - 如果index在此数组的范围之外，也就是说，如果以下任一项为真：
          index < 0
    index >= length()
        InvalidTypeException -如果类型 value不与声明的类型阵列组件的兼容。
        ClassNotLoadedException - 如果数组组件类型尚未通过适当的类加载器加载。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。
        另请参见：
        ArrayType.componentType()

      • setValues

        void setValues​(List<? extends Value> values)
        throws InvalidTypeException,
               ClassNotLoadedException
        用其他值替换所有数组组件。 如果给定的列表的大小大于数组，列表末尾的值将被忽略。

        对象值必须与元素类型分配兼容（这意味着组件类型必须通过封闭类的加载器加载）。 原始值必须与组件类型兼容，或必须可转换为组件类型，而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。

        参数
        values - 要放置在此数组中的Value对象的列表。 如果values.size()小于数组的长度，则首先设置values.size()元素。
        异常
        InvalidTypeException - 如果任何新的 values与声明的阵列组件类型不兼容。
        ClassNotLoadedException - 如果数组组件类型尚未通过适当的类加载器加载。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 VirtualMachine.canBeModified() 。
        另请参见：
        ArrayType.componentType()

      • setValues

        void setValues​(int index,
               List<? extends Value> values,
               int srcIndex,
               int length)
        throws InvalidTypeException,
               ClassNotLoadedException
        用其他值替换一系列阵列组件。

        对象值必须与组件类型分配兼容（这意味着组件类型必须通过封闭类的加载器加载）。 原始值必须与组件类型兼容，或必须可转换为组件类型，而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。

        参数
        index - 要设置的第一个组件的索引。
        values - 要放置在此数组中的Value对象的列表。
        srcIndex - 要使用的第一个源值的索引。
        length - 要设置的组件的数量，或-1将所有组件设置为此阵列的末尾或 values的结尾（以先到者为准）。
        异常
        InvalidTypeException -如果任何元件 values不与声明的类型阵列组件的兼容。
        IndexOutOfBoundsException -如果与指定的数组范围index和length不是阵列的范围内，或如果与指定的源范围srcIndex和length不是内values ，即，如果以下任意一项为真：
          index < 0
    index > length()
    srcIndex < 0
    srcIndex > values.size()
        或者如果length != -1和以下任何一个是真的：
          length < 0
    index + length > length()
    srcIndex + length > values.size()
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 VirtualMachine.canBeModified() 。
        ClassNotLoadedException
        另请参见：
        ArrayType.componentType()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ArrayType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ArrayType

  • All Superinterfaces:
    Accessible ， Comparable<ReferenceType> ， Mirror ， ReferenceType ， Type

    public interface ArrayType
extends ReferenceType
    提供对数组类的访问及其在目标虚拟机中的组件类型。
    从以下版本开始：
    1.3
    另请参见：
    ArrayReference

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String componentSignature​()
      获取该数组类的组件的JNI签名。
      Type componentType​()
      返回数组声明中指定的该数组的组件类型。
      String componentTypeName​()
      返回此数组的组件类型的文本表示形式。
      ArrayReference newInstance​(int length)
      在目标VM中创建此数组类的新实例。

      • Methods inherited from interface com.sun.jdi.Accessible

        isPackagePrivate, isPrivate, isProtected, isPublic, modifiers

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ReferenceType

        allFields, allLineLocations, allLineLocations, allMethods, availableStrata, classLoader, classObject, constantPool, constantPoolCount, defaultStratum, equals, failedToInitialize, fieldByName, fields, genericSignature, getValue, getValues, hashCode, instances, isAbstract, isFinal, isInitialized, isPrepared, isStatic, isVerified, locationsOfLine, locationsOfLine, majorVersion, methods, methodsByName, methodsByName, minorVersion, module, name, nestedTypes, sourceDebugExtension, sourceName, sourceNames, sourcePaths, visibleFields, visibleMethods

      • Methods inherited from interface com.sun.jdi.Type

        signature

    • 方法详细信息

      • newInstance

        ArrayReference newInstance​(int length)
        在目标VM中创建此数组类的新实例。 数组以给定长度创建，每个组件初始化为标准默认值。
        参数
        length - 新数组中的组件数
        结果
        新创建的ArrayReference镜像目标虚拟机中的新对象。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • componentSignature

        String componentSignature​()
        获取该数组类的组件的JNI签名。 签名描述了声明的组件类型。 如果组件是对象，则它们在特定运行时上下文中的实际类型可能是已声明类的子类。
        结果
        一个包含数组组件的JNI签名的字符串。

      • componentTypeName

        String componentTypeName​()
        返回此数组的组件类型的文本表示形式。
        结果
        组件类型的文本表示。

      • componentType

        Type componentType​()
            throws ClassNotLoadedException
        返回数组声明中指定的该数组的组件类型。

        注意：数组的组件类型将始终在阵列之前创建或加载 - 请参阅第The Java™ Virtual Machine Specification节第5.3.3节 - 创建数组类。 然而，尽管组件类型将被加载，但可能尚未准备好，在这种情况下将返回类型，但是尝试对返回的类型（例如fields() ）执行一些操作将抛出一个ClassNotPreparedException 。 使用ReferenceType.isPrepared()来确定是否准备了引用类型。

        结果
        该阵列组件的Type 。
        异常
        ClassNotLoadedException
        另请参见：
        Type ， Field.type() - for usage examples
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BooleanType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface BooleanType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface BooleanType
extends PrimitiveType
    在目标VM中访问的所有原语boolean值的类型。 致电Value.type()将返回此界面的实现者。
    从以下版本开始：
    1.3
    另请参见：
    BooleanValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BooleanValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface BooleanValue

  • All Superinterfaces:
    Mirror ， PrimitiveValue ， Value

    public interface BooleanValue
extends PrimitiveValue
    提供对目标VM中原始数据 boolean值的访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此BooleanValue进行比较以获得相等性。
      int hashCode​()
      返回此BooleanValue的哈希码值。
      boolean value​()
      将BooleanValue返回为布尔值。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        boolean value​()
        将BooleanValue返回为布尔值。
        结果
        这个对象镜像的 boolean 。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此BooleanValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是BooleanValue，并且如果对两个镜像的原语应用“==”，则该值为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此BooleanValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Bootstrap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class Bootstrap

  • java.lang.Object
    • com.sun.jdi.Bootstrap

  • public class Bootstrap
extends Object
    提供对JDI接口的默认实现的初始类。 调试器应用程序使用此类来访问VirtualMachineManager接口的单个实例。
    从以下版本开始：
    1.3

    • 构造方法摘要

      构造方法
      Constructor 描述
      Bootstrap​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static VirtualMachineManager virtualMachineManager​()
      返回虚拟机管理器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Bootstrap

        public Bootstrap​()

    • 方法详细信息

      • virtualMachineManager

        public static VirtualMachineManager virtualMachineManager​()
        返回虚拟机管理器。

        如果VirtualMachineManager的初始化失败或虚拟机管理器无法找到或创建任何Connectors，则可能会抛出未指定的错误。

        异常
        SecurityException - 如果安全管理器已安装，并且它拒绝了JDIPermission （“ virtualMachineManager ”）或实施所需的其他未指定的权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ByteType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ByteType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface ByteType
extends PrimitiveType
    在目标VM中访问的所有原始字节值的类型。 调用Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    ByteValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ByteValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ByteValue

  • All Superinterfaces:
    Comparable<ByteValue> ， Mirror ， PrimitiveValue ， Value

    public interface ByteValue
extends PrimitiveValue, Comparable<ByteValue>
    提供对目标虚拟机中原始数据 byte值的访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的对象与此ByteValue进行比较以获得相等性。
      int hashCode​()
      返回此BooleanValue的哈希码值。
      byte value​()
      将此ByteValue返回为 byte 。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        byte value​()
        将此ByteValue返回为 byte 。
        结果
        这个对象镜像的 byte 。

      • equals

        boolean equals​(Object obj)
        将指定的对象与此ByteValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是ByteValue，并且如果对两个镜像的原语应用“==”，则该值为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此BooleanValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CharType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface CharType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface CharType
extends PrimitiveType
    在目标虚拟机中访问的所有原始字符值的类型。 调用Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    CharValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CharValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface CharValue

  • All Superinterfaces:
    Comparable<CharValue> ， Mirror ， PrimitiveValue ， Value

    public interface CharValue
extends PrimitiveValue, Comparable<CharValue>
    提供对目标虚拟机中基元 char值的访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的对象与此CharValue进行比较以获得相等性。
      int hashCode​()
      返回此CharValue的哈希码值。
      char value​()
      将此CharValue返回为 char 。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        char value​()
        将此CharValue返回为 char 。
        结果
        这个对象镜像的 char 。

      • equals

        boolean equals​(Object obj)
        将指定的对象与此CharValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是CharValue，并且如果将“==”应用于两个镜像的原始元素，则该值将为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此CharValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassLoaderReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ClassLoaderReference

  • All Superinterfaces:
    Mirror ， ObjectReference ， Value

    public interface ClassLoaderReference
extends ObjectReference
    来自目标VM的类加载器对象。 ClassLoaderReference是一个ObjectReference ，可以从目标VM访问类加载器特定的信息。 实例ClassLoaderReference是通过调用ReferenceType.classLoader()获得的
    从以下版本开始：
    1.3
    另请参见：
    ObjectReference

    • Field Summary

      • Fields inherited from interface com.sun.jdi.ObjectReference

        INVOKE_NONVIRTUAL, INVOKE_SINGLE_THREADED

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<ReferenceType> definedClasses​()
      返回由此类加载器定义的所有加载类的列表。
      List<ReferenceType> visibleClasses​()
      返回此类加载器已被记录为目标VM中的启动加载程序的所有类的列表。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ObjectReference

        disableCollection, enableCollection, entryCount, equals, getValue, getValues, hashCode, invokeMethod, isCollected, owningThread, referenceType, referringObjects, setValue, uniqueID, waitingThreads

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • definedClasses

        List<ReferenceType> definedClasses​()
        返回由此类加载器定义的所有加载类的列表。 没有这个列表的排序保证。

        返回的列表将包括至少准备的参考类型和未定义准备的类型（如数组）。

        结果
        这个类加载器加载的ReferenceType对象镜像类型的列表。 如果此类加载器没有定义类型，列表的长度为0。

      • visibleClasses

        List<ReferenceType> visibleClasses​()
        返回此类加载器已被记录为目标VM中的启动加载程序的所有类的列表。 该列表包含由此加载器直接定义的ReferenceTypes（由definedClasses()返回）以及此类加载器委托加载到另一个类加载器的任何类型。

        可见类列表对类型命名空间有有用的属性。 列表中最多会出现一个特定类型的名称。 在此类加载器定义的类中，使用该类型名称声明的每个字段或变量必须解析为该类型。

        没有保证退货清单的订购。

        有关启动类加载器的更多信息，请参见“ The Java™ Virtual Machine Specification第5.3节 - 创建和加载”。

        请注意，与definedClasses()和VirtualMachine.allClasses()不同，某些返回的引用类型可能无法准备。 尝试对未准备的参考类型执行某些操作（例如fields() ）将抛出一个ClassNotPreparedException 。 使用ReferenceType.isPrepared()来确定是否准备了参考类型。

        结果
        由此类加载器启动的ReferenceType对象镜像类的列表。 如果此类加载器中没有类可见，列表的长度为0。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassNotLoadedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class ClassNotLoadedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.jdi.ClassNotLoadedException
  • All Implemented Interfaces:
    Serializable

    public class ClassNotLoadedException
extends 异常
    抛出，表示请求的类尚未通过适当的类加载器加载。

    由于许多VM执行的懒惰类链接，在相关类加载之前，可以在程序中看到字段或变量。 在加载类之前，所有可用的都是签名字符串。 如果尝试从JDI设置这样的字段或变量的值，则由于目标类未加载，所以无法进行适当的类型检查。 数组元素的元素类也是如此。

    在这种情况下，通过尝试类加载来解决这个问题是不可取的。 让调试器加载一个类而不是等待它加载正常的事件过程有两个问题。

    • 不能保证运行相应的类加载器不会在加载类时造成死锁。 类装载器可以由任意的Java编程语言代码组成，类加载方法通常是同步的。 当线程被暂停时，调试器完成的大部分工作都会发生。 如果另一个应用程序线程在同一个类加载器中挂起，那么死锁是非常可能的。
    • 更改正常加载类的顺序可能会掩盖或显示应用程序中的错误。 一个无意识的调试器应该努力保持正在调试的应用程序的行为不变。
    为了避免这些潜在的问题，抛出了这个异常。

    请注意，这个异常将被抛出，直到相关类对于封闭类的类加载器是可见的。 （也就是说，封装类的类加载器必须是有问题的类的启动类加载器。）有关详细信息，请参阅The Java™ Virtual Machine Specification 。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClassNotLoadedException​(String className)
      ClassNotLoadedException​(String className, String message)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String className​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClassNotLoadedException

        public ClassNotLoadedException​(String className)

      • ClassNotLoadedException

        public ClassNotLoadedException​(String className,
                               String message)

    • 方法详细信息

      • className

        public String className​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassNotPreparedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class ClassNotPreparedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.ClassNotPreparedException
  • All Implemented Interfaces:
    Serializable

    public class ClassNotPreparedException
extends RuntimeException
    抛出以指示由于指定的类尚未准备而请求的操作无法完成。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClassNotPreparedException​()
      ClassNotPreparedException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClassNotPreparedException

        public ClassNotPreparedException​()

      • ClassNotPreparedException

        public ClassNotPreparedException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassObjectReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ClassObjectReference

  • All Superinterfaces:
    Mirror ， ObjectReference ， Value

    public interface ClassObjectReference
extends ObjectReference
    来自目标VM的java.lang.Class实例。 使用此界面访问此对象反映的类，数组或接口的类型信息。
    从以下版本开始：
    1.3
    另请参见：
    ReferenceType

    • Field Summary

      • Fields inherited from interface com.sun.jdi.ObjectReference

        INVOKE_NONVIRTUAL, INVOKE_SINGLE_THREADED

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ReferenceType reflectedType​()
      返回与此类对象相对应的ReferenceType 。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ObjectReference

        disableCollection, enableCollection, entryCount, equals, getValue, getValues, hashCode, invokeMethod, isCollected, owningThread, referenceType, referringObjects, setValue, uniqueID, waitingThreads

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • reflectedType

        ReferenceType reflectedType​()
        返回与此类对象相对应的ReferenceType 。 返回的类型可以用于获取有关该类的详细信息。
        结果
        the ReferenceType reflected by this class object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ClassType

  • All Superinterfaces:
    Accessible ， Comparable<ReferenceType> ， Mirror ， ReferenceType ， Type

    public interface ClassType
extends ReferenceType
    目标VM中的类的镜像。 ClassType是一个ReferenceType的改进，适用于定义中JLS意义上的真类（不是接口，而不是数组类型）。 任何反映这种类的实例的ObjectReference将具有ClassType作为其类型。
    从以下版本开始：
    1.3
    另请参见：
    ObjectReference

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int INVOKE_SINGLE_THREADED
      仅执行调用线程执行方法调用

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<InterfaceType> allInterfaces​()
      获取由此类直接和间接实现的接口。
      方法 concreteMethodByName​(String name, String signature)
      返回从该类可见的具有给定名称和签名的单个非抽象方法 。
      List<InterfaceType> interfaces​()
      获取由此类直接实现的接口。
      Value invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      boolean isEnum​()
      确定这个类是否被声明为一个枚举。
      ObjectReference newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      构造此类型的新实例，使用给定的构造方法目标VM。
      void setValue​(Field field, Value value)
      为静态字段分配一个值。
      List<ClassType> subclasses​()
      获取此类的当前加载的直接子类。
      ClassType superclass​()
      获取此类的超类。

      • Methods inherited from interface com.sun.jdi.Accessible

        isPackagePrivate, isPrivate, isProtected, isPublic, modifiers

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ReferenceType

        allFields, allLineLocations, allLineLocations, allMethods, availableStrata, classLoader, classObject, constantPool, constantPoolCount, defaultStratum, equals, failedToInitialize, fieldByName, fields, genericSignature, getValue, getValues, hashCode, instances, isAbstract, isFinal, isInitialized, isPrepared, isStatic, isVerified, locationsOfLine, locationsOfLine, majorVersion, methods, methodsByName, methodsByName, minorVersion, module, name, nestedTypes, sourceDebugExtension, sourceName, sourceNames, sourcePaths, visibleFields, visibleMethods

      • Methods inherited from interface com.sun.jdi.Type

        signature

    • 字段详细信息

      • INVOKE_SINGLE_THREADED

        static final int INVOKE_SINGLE_THREADED
        仅执行调用线程执行方法调用
        另请参见：
        Constant Field Values

    • 方法详细信息

      • superclass

        ClassType superclass​()
        获取此类的超类。
        结果
        一个ClassType镜像目标VM中此类的超类。 如果没有这样的类存在，返回null

      • interfaces

        List<InterfaceType> interfaces​()
        获取由此类直接实现的接口。 只有包含在该类中使用“implements”关键字声明的接口。
        结果
        一个InterfaceType对象的列表，每个镜像目标VM中直接接口此ClassType。 如果不存在，返回零长度列表。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • allInterfaces

        List<InterfaceType> allInterfaces​()
        获取由此类直接和间接实现的接口。 返回的接口返回interfaces()以及所有超级接口。
        结果
        每个镜像目标VM中此ClassType的接口的InterfaceType对象的列表。 如果不存在，返回零长度列表。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • subclasses

        List<ClassType> subclasses​()
        获取此类的当前加载的直接子类。 此列表的订购不保证。
        结果
        一个ClassType对象的列表， 每个对象镜像目标VM中此类的加载子类。 如果不存在这样的类，则该方法返回零长度列表。

      • isEnum

        boolean isEnum​()
        确定这个类是否被声明为一个枚举。
        结果
        true如果这个类被声明为一个枚举; 否则为假。

      • setValue

        void setValue​(Field field,
              Value value)
       throws InvalidTypeException,
              ClassNotLoadedException
        为静态字段分配一个值。 Field必须对此ClassType有效; 也就是说，它必须来自镜像对象的类或该类的超类。 该领域不能是最终的。

        对象值必须与字段类型分配兼容（这意味着字段类型必须通过封装类的加载器加载）。 原始值必须与字段类型兼容，或必须可转换为字段类型，而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。

        参数
        field - 要设置的字段。
        value - 要分配的值。
        异常
        IllegalArgumentException - 如果该字段不是静态的，该字段是final，或该类不存在该字段。
        ClassNotLoadedException - 如果字段类型尚未通过适当的类加载器加载。
        InvalidTypeException - 如果值的类型与字段的声明类型不匹配。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • invokeMethod

        Value invokeMethod​(ThreadReference thread,
                   方法 method,
                   List<? extends Value> arguments,
                   int options)
            throws InvalidTypeException,
                   ClassNotLoadedException,
                   IncompatibleThreadStateException,
                   InvocationException
        在目标虚拟机中调用指定的静态方法 。 指定的方法可以在此类中定义，也可以在超类中定义。 该方法必须是静态方法，而不是静态初始化程序。 使用newInstance(com.sun.jdi.ThreadReference, com.sun.jdi.Method, java.util.List<? extends com.sun.jdi.Value>, int)创建一个新对象并运行其构造函数。

        方法调用将发生在指定的线程中。 只有指定线程已被该线程中发生的事件挂起，才能进行方法调用。 当目标VM已通过悬浮不支持方法调用VirtualMachine.suspend()时，或者当指定的线程通过挂起ThreadReference.suspend() 。

        使用指定参数列表中的参数调用指定的方法。 方法调用是同步的 该方法直到被调用的方法在目标VM中返回才返回。 如果调用的方法抛出异常，该方法将抛出一个InvocationException ，其中包含抛出异常对象的镜像。

        对象参数必须与参数类型分配兼容（这意味着参数类型必须通过封装类的加载器加载）。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 如果被调用的方法接受可变数量的参数，则最后一个参数类型是某种组件类型的数组。 可以省略匹配位置中的参数，或者可以为null，相同组件类型的数组，或组件类型的参数，后跟任意数量的相同类型的其他参数。 如果省略参数，则传递组件类型的0长度数组。 组件类型可以是原始类型。 不支持自动装箱。 有关分配兼容性的更多信息，请参见The Java™ Language Specification的第5.2节。

        默认情况下，如果方法被先前被事件挂起，或者由VirtualMachine.suspend()或ThreadReference.suspend()暂停，那么将重新启动目标虚拟机中的所有线程。 这样做是为了防止如果任何线程拥有调用方法需要的监视器，将会发生死锁。 但是请注意，这个隐式的恢复与ThreadReference.resume()完全一致 ，所以如果线程的挂起计数大于1，那么在调用期间它将保持暂停状态，从而仍然会发生死锁。 默认情况下，当调用完成时，目标VM中的所有线程都将被暂停，而不管调用之前的状态如何。 在调用期间可能会发生断点或其他事件。 这可能会导致如上所述的死锁。 如果从客户端的事件处理程序线程调用invokeMethod，它也可能导致死锁。 在这种情况下，该线程将等待invokeMethod完成，并且不会读取新事件引入的EventSet。 如果这个新的EventSet是SUSPEND_ALL，那么会发生死锁，因为没有人会恢复EventSet。 为避免这种情况，在执行invokeMethod之前，应该禁用所有EventRequests，否则不应该从客户端的事件处理程序线程中完成invokeMethod。

        在调用期间恢复其他线程可以通过在options参数中指定INVOKE_SINGLE_THREADED位标志来防止; 然而，没有保护或恢复上述僵局，所以这个选择应该非常小心。 只有指定的线程将被恢复（如上面所有线程所述）。 完成单个线程调用后，调用线程将再次被挂起。 请注意，在调用完成时，单线程调用期间启动的任何线程都不会被挂起。

        如果在调用期间目标VM断开连接（例如，通过VirtualMachine.dispose() ），方法调用将继续。

        参数
        thread - 要调用的线程。
        method - 要调用的方法 。
        arguments - 绑定到被调用方法的Value参数的列表。 列表中的值按照它们在方法签名中显示的顺序分配给参数。
        options - 整数位标志选项。
        结果
        一个Value镜像的调用方法的返回值。
        异常
        IllegalArgumentException - 如果方法不是此类或超类的成员，如果参数列表的大小与方法的声明参数的数量不匹配，或者方法是初始化程序，构造函数或静态初始化程序。
        ClassNotLoadedException - 如果任何参数类型尚未通过适当的类加载器加载。
        IncompatibleThreadStateException - 如果指定的线程未被事件挂起。
        InvocationException - 如果方法调用导致目标VM中的异常。
        InvalidTypeException - 如果参数不符合此要求 - 对象参数必须与参数类型兼容。 这意味着参数类型必须通过封装类'类加载器加载。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • newInstance

        ObjectReference newInstance​(ThreadReference thread,
                            方法 method,
                            List<? extends Value> arguments,
                            int options)
                     throws InvalidTypeException,
                            ClassNotLoadedException,
                            IncompatibleThreadStateException,
                            InvocationException
        构造此类型的新实例，使用给定的构造方法目标VM。 指定的构造函数必须在此类中定义。

        实例创建将发生在指定的线程中。 只有当指定的线程已被该线程中发生的事件挂起时，才能执行实例创建。 当目标VM已通过暂停不支持实例创建VirtualMachine.suspend()或在指定的线程通过暂停ThreadReference.suspend() 。

        使用指定参数列表中的参数调用指定的构造函数。 调用是同步的 该方法直到构造函数在目标VM中返回为止。 如果调用的方法抛出异常，此方法将抛出一个InvocationException ，其中包含抛出异常对象的镜像。

        对象参数必须与参数类型分配兼容（这意味着参数类型必须通过封装类的加载器加载）。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 如果被调用的方法接受可变数量的参数，则最后一个参数类型是某种组件类型的数组。 可以省略匹配位置中的参数，或者可以为null，相同组件类型的数组或组件类型的参数，后跟任何数量的相同类型的其他参数。 如果省略参数，则传递组件类型的0长度数组。 组件类型可以是原始类型。 不支持自动装箱。 有关分配兼容性的更多信息，请参见The Java™ Language Specification的 5.2节。

        默认情况下，如果事件先前被某个事件挂起，或VirtualMachine.suspend()或ThreadReference.suspend()，则该方法将被调用，则目标VM中的所有线程都将被恢复。 这样做是为了防止如果任何线程拥有调用方法需要的监视器，将会发生死锁。 在调用期间可能会发生断点或其他事件。 但是请注意，这个隐式恢复与ThreadReference.resume()完全一致 ，因此如果该线程的挂起计数大于1，则在调用期间它将保持暂停状态。 默认情况下，当调用完成时，目标VM中的所有线程都将被暂停，而不管调用之前的状态如何。

        可以通过在options参数中指定INVOKE_SINGLE_THREADED位标志来防止在调用期间恢复其他线程; 然而，没有保护或恢复上述僵局，所以这个选择应该非常小心。 只有指定的线程将被恢复（如上面所有线程所述）。 完成单个线程调用后，调用线程将再次被挂起。 请注意，在调用完成时，单线程调用期间启动的任何线程都不会被挂起。

        如果目标VM在调用期间断开连接（例如，通过VirtualMachine.dispose() ），方法调用将继续。

        参数
        thread - 要调用的线程。
        method - 要调用的构造函数方法 。
        arguments - 绑定到被调用的构造函数的Value参数的列表。 列表中的值按照它们在构造函数签名中出现的顺序分配给参数。
        options - 整数位标志选项。
        结果
        一个ObjectReference镜像的新创建的对象。
        异常
        IllegalArgumentException - 如果方法不是此类的成员，如果参数列表的大小与构造函数的已声明参数的数量不匹配，或者该方法不是构造函数。
        ClassNotLoadedException - 如果任何参数类型尚未通过适当的类加载器加载。
        IncompatibleThreadStateException - 如果指定的线程未被事件挂起。
        InvocationException - 如果方法调用导致目标VM中的异常。
        InvalidTypeException - 如果参数不符合此要求 - 对象参数必须与参数类型兼容。 这意味着参数类型必须通过封装类'类加载器加载。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • concreteMethodByName

        方法 concreteMethodByName​(String name,
                            String signature)
        返回从该类可见的具有给定名称和签名的单个非抽象的27044498881730306 。 有关签名格式的信息，请参阅ReferenceType.methodsByName(java.lang.String, java.lang.String) 。

        返回的方法（如果非空）是ClassType的组件。

        参数
        name - 要查找的方法的名称。
        signature - 方法的签名查找
        结果
        该方法匹配给定的名称和签名或null ，如果没有匹配。
        异常
        ClassNotPreparedException - 如果方法尚未可用，因为类尚未准备好。
        另请参见：
        ReferenceType.visibleMethods() ，
ReferenceType.methodsByName(java.lang.String name) ，
ReferenceType.methodsByName(java.lang.String name, java.lang.String signature)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.jdi (Java SE 9 & JDK 9 )

com.sun.jdi

Interfaces

  • Accessible
  • ArrayReference
  • ArrayType
  • BooleanType
  • BooleanValue
  • ByteType
  • ByteValue
  • CharType
  • CharValue
  • ClassLoaderReference
  • ClassObjectReference
  • ClassType
  • DoubleType
  • DoubleValue
  • Field
  • FloatType
  • FloatValue
  • IntegerType
  • IntegerValue
  • InterfaceType
  • LocalVariable
  • Locatable
  • Location
  • LongType
  • LongValue
  • 方法
  • Mirror
  • ModuleReference
  • MonitorInfo
  • ObjectReference
  • PathSearchingVirtualMachine
  • PrimitiveType
  • PrimitiveValue
  • ReferenceType
  • ShortType
  • ShortValue
  • StackFrame
  • StringReference
  • ThreadGroupReference
  • ThreadReference
  • Type
  • TypeComponent
  • Value
  • VirtualMachine
  • VirtualMachineManager
  • VoidType
  • VoidValue

Classes

  • Bootstrap
  • JDIPermission

Exceptions

  • AbsentInformationException
  • ClassNotLoadedException
  • ClassNotPreparedException
  • IncompatibleThreadStateException
  • InconsistentDebugInfoException
  • InternalException
  • InvalidCodeIndexException
  • InvalidLineNumberException
  • InvalidModuleException
  • InvalidStackFrameException
  • InvalidTypeException
  • InvocationException
  • NativeMethodException
  • ObjectCollectedException
  • VMCannotBeModifiedException
  • VMDisconnectedException
  • VMMismatchException
  • VMOutOfMemoryException


com.sun.jdi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.jdi

Package com.sun.jdi

这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。 VirtualMachine镜像目标虚拟机，是JDI提供的所有信息的起源。 通常通过使用VirtualMachineManager创建与目标虚拟机的连接来创建VirtualMachine（请参阅com.sun.jdi.connect软件包）。 反过来， VirtualMachineManager通常是通过调用Bootstrap.virtualMachineManager()创建的。

这个包中的大多数方法都可以抛出未经检查的异常VMDisconnectedException 。

方法可能会在以后的版本中添加到JDI包中的接口。 如果JDI成为标准扩展名，则可能会重命名现有的包。

  • 接口摘要
    接口 描述
    Accessible
    提供有关类型或类型组件的可访问性的信息。
    ArrayReference
    提供对目标虚拟机中数组对象及其组件的访问。
    ArrayType
    提供对数组类的访问及其在目标虚拟机中的组件类型。
    BooleanType
    在目标虚拟机中访问的所有原始 boolean类型 boolean 。
    BooleanValue
    提供对目标VM boolean语 boolean值的访问。
    ByteType
    在目标VM中访问的所有原始字节值的类型。
    ByteValue
    提供对目标VM中原始数据 byte访问。
    CharType
    在目标虚拟机中访问的所有原始字符值的类型。
    CharValue
    提供对目标虚拟机 char语 char值的访问。
    ClassLoaderReference
    来自目标VM的类加载器对象。
    ClassObjectReference
    来自目标VM的java.lang.Class实例。
    ClassType
    目标VM中的类的镜像。
    DoubleType
    在目标VM中访问的所有原始双值的类型。
    DoubleValue
    提供对目标虚拟机中原始值 double值的访问。
    Field
    目标VM中的类或实例变量。
    FloatType
    在目标VM中访问的所有原始浮点值的类型。
    FloatValue
    提供对目标虚拟机中原始值 float值的访问。
    IntegerType
    在目标VM中访问的所有原语 int值的类型。
    IntegerValue
    提供对目标虚拟机 int语 int值的访问。
    InterfaceType
    目标虚拟机中的接口的镜像。
    LocalVariable
    目标VM中的局部变量。
    Locatable
    一个镜子有一个Location 。
    Location
    目标VM的执行代码中的一个点。
    LongType
    在目标VM中访问的所有原语 long值的类型。
    LongValue
    提供对目标VM long语 long值的访问。
    方法
    目标VM中的静态或实例方法。
    Mirror
    调试器使用的代理来检查或操纵另一个虚拟机中的某个实体。
    ModuleReference
    目标虚拟机中的一个模块。
    MonitorInfo
    有关线程拥有的监视器的信息。
    ObjectReference
    当前存在于目标VM中的对象。
    PathSearchingVirtualMachine
    通过路径搜索类的虚拟机
    PrimitiveType
    与目标VM中的非对象值相关联的类型。
    PrimitiveValue
    分配给目标VM中的原始类型的字段或变量的值。
    ReferenceType
    目标虚拟机中对象的类型。
    ShortType
    在目标VM中访问的所有原语 short值的类型。
    ShortValue
    提供对目标虚拟机 short语 short值的访问。
    StackFrame
    线程调用堆栈上的一种方法调用的状态。
    StringReference
    来自目标VM的字符串对象。
    ThreadGroupReference
    来自目标VM的线程组对象。
    ThreadReference
    来自目标VM的线程对象。
    Type
    目标VM中类型的镜像。
    TypeComponent
    在用户定义的类型（类或接口）内声明的实体。
    Value
    目标VM中的值的镜像。
    VirtualMachine
    用于调试的虚拟机。
    VirtualMachineManager
    目标虚拟机的连接经理。
    VoidType
    在目标VM中访问的所有原语 void值的类型。
    VoidValue
    提供对目标虚拟机 void语 void值的访问。
  • 类摘要
    Class 描述
    Bootstrap
    提供对JDI接口的默认实现的初始类。
    JDIPermission
    JDIPermission类代表对 VirtualMachineManager访问权限。
  • 异常摘要
    异常 描述
    AbsentInformationException
    抛出以表示行号或变量信息不可用。
    ClassNotLoadedException
    抛出，表示请求的类尚未通过适当的类加载器加载。
    ClassNotPreparedException
    抛出以指示由于指定的类尚未准备而请求的操作无法完成。
    IncompatibleThreadStateException
    抛出以指示所请求的操作在指定线程处于当前状态时无法完成。
    InconsistentDebugInfoException
    被抛出以表明目标VM提供的调试信息有不一致之处。
    InternalException
    抛出，表示出现意外的内部错误。
    InvalidCodeIndexException Deprecated.
    不再抛出此异常
    InvalidLineNumberException Deprecated.
    不再抛出此异常
    InvalidModuleException
    抛出以表明所请求的模块在卸载模块后无效或无效。
    InvalidStackFrameException
    抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。
    InvalidTypeException
    抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。
    InvocationException
    抛出以指示目标VM中的调用方法中发生异常。
    NativeMethodException
    抛出表示操作无法完成，因为它对本机方法无效。
    ObjectCollectedException
    抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。
    VMCannotBeModifiedException
    抛出以表示操作无效，因为它会修改VM，VM是只读的。
    VMDisconnectedException
    抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。
    VMMismatchException
    抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。
    VMOutOfMemoryException
    抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.jdi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.jdi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.jdi.Bootstrap
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • com.sun.jdi.JDIPermission
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • com.sun.jdi.AbsentInformationException
        • com.sun.jdi.ClassNotLoadedException
        • com.sun.jdi.IncompatibleThreadStateException
        • com.sun.jdi.InvalidTypeException
        • com.sun.jdi.InvocationException
        • java.lang.RuntimeException
          • com.sun.jdi.ClassNotPreparedException
          • com.sun.jdi.InconsistentDebugInfoException
          • com.sun.jdi.InternalException
          • com.sun.jdi.InvalidCodeIndexException
          • com.sun.jdi.InvalidLineNumberException
          • com.sun.jdi.InvalidModuleException
          • com.sun.jdi.InvalidStackFrameException
          • com.sun.jdi.NativeMethodException
          • com.sun.jdi.ObjectCollectedException
          • java.lang.UnsupportedOperationException
            • com.sun.jdi.VMCannotBeModifiedException
          • com.sun.jdi.VMDisconnectedException
          • com.sun.jdi.VMMismatchException
          • com.sun.jdi.VMOutOfMemoryException

Interface Hierarchy

  • com.sun.jdi.Accessible
    • com.sun.jdi.ReferenceType (also extends java.lang.Comparable<T>, com.sun.jdi.Type)
      • com.sun.jdi.ArrayType
      • com.sun.jdi.ClassType
      • com.sun.jdi.InterfaceType
    • com.sun.jdi.TypeComponent (also extends com.sun.jdi.Mirror)
      • com.sun.jdi.Field (also extends java.lang.Comparable<T>)
      • com.sun.jdi.方法 (also extends java.lang.Comparable<T>, com.sun.jdi.Locatable)
  • java.lang.Comparable<T>
    • com.sun.jdi.ByteValue (also extends com.sun.jdi.PrimitiveValue)
    • com.sun.jdi.CharValue (also extends com.sun.jdi.PrimitiveValue)
    • com.sun.jdi.DoubleValue (also extends com.sun.jdi.PrimitiveValue)
    • com.sun.jdi.Field (also extends com.sun.jdi.TypeComponent)
    • com.sun.jdi.FloatValue (also extends com.sun.jdi.PrimitiveValue)
    • com.sun.jdi.IntegerValue (also extends com.sun.jdi.PrimitiveValue)
    • com.sun.jdi.LocalVariable (also extends com.sun.jdi.Mirror)
    • com.sun.jdi.Location (also extends com.sun.jdi.Mirror)
    • com.sun.jdi.LongValue (also extends com.sun.jdi.PrimitiveValue)
    • com.sun.jdi.方法 (also extends com.sun.jdi.Locatable, com.sun.jdi.TypeComponent)
    • com.sun.jdi.ReferenceType (also extends com.sun.jdi.Accessible, com.sun.jdi.Type)
      • com.sun.jdi.ArrayType
      • com.sun.jdi.ClassType
      • com.sun.jdi.InterfaceType
    • com.sun.jdi.ShortValue (also extends com.sun.jdi.PrimitiveValue)
  • com.sun.jdi.Locatable
    • com.sun.jdi.方法 (also extends java.lang.Comparable<T>, com.sun.jdi.TypeComponent)
    • com.sun.jdi.StackFrame (also extends com.sun.jdi.Mirror)
  • com.sun.jdi.Mirror
    • com.sun.jdi.LocalVariable (also extends java.lang.Comparable<T>)
    • com.sun.jdi.Location (also extends java.lang.Comparable<T>)
    • com.sun.jdi.MonitorInfo
    • com.sun.jdi.StackFrame (also extends com.sun.jdi.Locatable)
    • com.sun.jdi.Type
      • com.sun.jdi.PrimitiveType
        • com.sun.jdi.BooleanType
        • com.sun.jdi.ByteType
        • com.sun.jdi.CharType
        • com.sun.jdi.DoubleType
        • com.sun.jdi.FloatType
        • com.sun.jdi.IntegerType
        • com.sun.jdi.LongType
        • com.sun.jdi.ShortType
      • com.sun.jdi.ReferenceType (also extends com.sun.jdi.Accessible, java.lang.Comparable<T>)
        • com.sun.jdi.ArrayType
        • com.sun.jdi.ClassType
        • com.sun.jdi.InterfaceType
      • com.sun.jdi.VoidType
    • com.sun.jdi.TypeComponent (also extends com.sun.jdi.Accessible)
      • com.sun.jdi.Field (also extends java.lang.Comparable<T>)
      • com.sun.jdi.方法 (also extends java.lang.Comparable<T>, com.sun.jdi.Locatable)
    • com.sun.jdi.Value
      • com.sun.jdi.ObjectReference
        • com.sun.jdi.ArrayReference
        • com.sun.jdi.ClassLoaderReference
        • com.sun.jdi.ClassObjectReference
        • com.sun.jdi.ModuleReference
        • com.sun.jdi.StringReference
        • com.sun.jdi.ThreadGroupReference
        • com.sun.jdi.ThreadReference
      • com.sun.jdi.PrimitiveValue
        • com.sun.jdi.BooleanValue
        • com.sun.jdi.ByteValue (also extends java.lang.Comparable<T>)
        • com.sun.jdi.CharValue (also extends java.lang.Comparable<T>)
        • com.sun.jdi.DoubleValue (also extends java.lang.Comparable<T>)
        • com.sun.jdi.FloatValue (also extends java.lang.Comparable<T>)
        • com.sun.jdi.IntegerValue (also extends java.lang.Comparable<T>)
        • com.sun.jdi.LongValue (also extends java.lang.Comparable<T>)
        • com.sun.jdi.ShortValue (also extends java.lang.Comparable<T>)
      • com.sun.jdi.VoidValue
    • com.sun.jdi.VirtualMachine
      • com.sun.jdi.PathSearchingVirtualMachine
  • com.sun.jdi.VirtualMachineManager
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


DoubleType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface DoubleType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface DoubleType
extends PrimitiveType
    在目标VM中访问的所有原始双值的类型。 致电Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    DoubleValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DoubleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface DoubleValue

  • All Superinterfaces:
    Comparable<DoubleValue> ， Mirror ， PrimitiveValue ， Value

    public interface DoubleValue
extends PrimitiveValue, Comparable<DoubleValue>
    提供对目标VM中原始值 double访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此DoubleValue进行比较以获得相等性。
      int hashCode​()
      返回此DoubleValue的哈希码值。
      double value​()
      将此DoubleValue返回为 double 。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        double value​()
        将此DoubleValue返回为 double 。
        结果
        这个对象镜像的 double 。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此DoubleValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是DoubleValue，并且如果对两个镜像的原语应用“==”，则该值为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此DoubleValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Field

  • All Superinterfaces:
    Accessible ， Comparable<Field> ， Mirror ， TypeComponent

    public interface Field
extends TypeComponent, Comparable<Field>
    目标VM中的类或实例变量。 有关Field和Method镜像的一般信息，请参阅TypeComponent 。
    从以下版本开始：
    1.3
    另请参见：
    ObjectReference ， ReferenceType

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此字段进行比较以获得相等性。
      int hashCode​()
      返回此字段的哈希码值。
      boolean isEnumConstant​()
      确定这是否是一个表示枚举常数的字段。
      boolean isTransient​()
      确定这是否是一个瞬态场。
      boolean isVolatile​()
      确定这是否是一个易失性的领域。
      Type type​()
      返回此字段的类型。
      String typeName​()
      返回此字段类型的文本表示。

      • Methods inherited from interface com.sun.jdi.Accessible

        isPackagePrivate, isPrivate, isProtected, isPublic, modifiers

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.TypeComponent

        declaringType, genericSignature, isFinal, isStatic, isSynthetic, name, signature

    • 方法详细信息

      • typeName

        String typeName​()
        返回此字段类型的文本表示。 该类型是此字段声明中指定的类型。

        即使类型尚未创建或加载，此类型名称始终可用。

        结果
        一个表示此字段类型的字符串。

      • type

        Type type​()
   throws ClassNotLoadedException
        返回此字段的类型。 该类型是此字段声明中指定的类型。

        例如，如果目标类定义：

          short s;
    Date d;
    byte[] ba;
        而JDI客户端定义了这些Field对象：
          Field sField = targetClass.fieldByName("s");
    Field dField = targetClass.fieldByName("d");
    Field baField = targetClass.fieldByName("ba");
        镜像对应的字段，然后sField.type()是ShortType ， dField.type()是ReferenceType为java.util.Date和((ArrayType)(baField.type())).componentType()为ByteType 。

        注意：如果此字段的类型是引用类型（类，接口或数组），并且尚未由声明类型的类加载器（即declaringType() .classLoader() ）创建或加载，则将抛出ClassNotLoadedException。 此外，引用类型可能已经加载但尚未准备好，在这种情况下将返回类型，但是尝试对返回类型执行某些操作（例如， fields() ）将抛出一个ClassNotPreparedException 。 使用ReferenceType.isPrepared()来确定是否准备了引用类型。

        结果
        这个领域的Type 。
        异常
        ClassNotLoadedException - 如果类型尚未通过适当的类加载器加载或创建。
        另请参见：
        Type

      • isTransient

        boolean isTransient​()
        确定这是否是一个瞬态场。
        结果
        true如果这个字段是暂时的; false否则。

      • isVolatile

        boolean isVolatile​()
        确定这是否是一个易失性的领域。
        结果
        true如果这个字段是挥发性的; 否则为false 。

      • isEnumConstant

        boolean isEnumConstant​()
        确定这是否是一个表示枚举常数的字段。
        结果
        true如果此字段表示枚举常数; false否则。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此字段进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果对象是一个字段，并且两个镜像相同的字段（在相同的类或接口中声明在同一个VM中）。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此字段的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FloatType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface FloatType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface FloatType
extends PrimitiveType
    在目标VM中访问的所有原始浮点值的类型。 调用Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    FloatValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FloatValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface FloatValue

  • All Superinterfaces:
    Comparable<FloatValue> ， Mirror ， PrimitiveValue ， Value

    public interface FloatValue
extends PrimitiveValue, Comparable<FloatValue>
    提供对目标虚拟机 float语 float值的访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的对象与此FloatValue进行比较以获得相等性。
      int hashCode​()
      返回此FloatValue的哈希码值。
      float value​()
      将此FloatValue返回为浮点数。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        float value​()
        将此FloatValue返回为浮点数。
        结果
        这个对象镜像的 float 。

      • equals

        boolean equals​(Object obj)
        将指定的对象与此FloatValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 要与之比较的参考对象。
        结果
        如果Object是FloatValue，并且如果将“==”应用于两个镜像的原语，则该值将为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此FloatValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IncompatibleThreadStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class IncompatibleThreadStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.jdi.IncompatibleThreadStateException
  • All Implemented Interfaces:
    Serializable

    public class IncompatibleThreadStateException
extends 异常
    抛出以指示所请求的操作在指定线程处于当前状态时无法完成。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IncompatibleThreadStateException​()
      IncompatibleThreadStateException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IncompatibleThreadStateException

        public IncompatibleThreadStateException​()

      • IncompatibleThreadStateException

        public IncompatibleThreadStateException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InconsistentDebugInfoException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InconsistentDebugInfoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.InconsistentDebugInfoException
  • All Implemented Interfaces:
    Serializable

    public class InconsistentDebugInfoException
extends RuntimeException
    被抛出以表明目标VM提供的调试信息有不一致之处。 例如，如果目标VM报告的检索到的值的运行时类型与其声明的类型之间存在类型不匹配，则会抛出此异常。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InconsistentDebugInfoException​()
      InconsistentDebugInfoException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InconsistentDebugInfoException

        public InconsistentDebugInfoException​()

      • InconsistentDebugInfoException

        public InconsistentDebugInfoException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IntegerType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface IntegerType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface IntegerType
extends PrimitiveType
    在目标VM中访问的所有原语int值的类型。 调用Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    IntegerValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IntegerValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface IntegerValue

  • All Superinterfaces:
    Comparable<IntegerValue> ， Mirror ， PrimitiveValue ， Value

    public interface IntegerValue
extends PrimitiveValue, Comparable<IntegerValue>
    提供对目标VM中的基元 int值的访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此IntegerValue进行比较以获得相等性。
      int hashCode​()
      返回此IntegerValue的哈希码值。
      int value​()
      将此IntegerValue返回为int。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        int value​()
        将此IntegerValue返回为int。
        结果
        这个对象镜像的 int 。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此IntegerValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 用于比较的参考对象。
        结果
        如果Object是IntegerValue，并且如果对两个镜像的原语应用“==”，则该值为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此IntegerValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InterfaceType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface InterfaceType

  • All Superinterfaces:
    Accessible ， Comparable<ReferenceType> ， Mirror ， ReferenceType ， Type

    public interface InterfaceType
extends ReferenceType
    目标虚拟机中的接口的镜像。 InterfaceType是一个ReferenceType的改进，适用于定义中JLS意义上的真实接口（不是类而不是数组类型）。 接口类型永远不会由ObjectReference.referenceType()返回，但它可能在该方法返回的ClassType的已实现接口列表中。
    从以下版本开始：
    1.3
    另请参见：
    ObjectReference

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      List<ClassType> implementors​()
      获取直接实现此接口的当前准备的类。
      default Value invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      List<InterfaceType> subinterfaces​()
      获取当前准备的接口，直接扩展该接口。
      List<InterfaceType> superinterfaces​()
      获取此接口直接扩展的接口。

      • Methods inherited from interface com.sun.jdi.Accessible

        isPackagePrivate, isPrivate, isProtected, isPublic, modifiers

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ReferenceType

        allFields, allLineLocations, allLineLocations, allMethods, availableStrata, classLoader, classObject, constantPool, constantPoolCount, defaultStratum, equals, failedToInitialize, fieldByName, fields, genericSignature, getValue, getValues, hashCode, instances, isAbstract, isFinal, isInitialized, isPrepared, isStatic, isVerified, locationsOfLine, locationsOfLine, majorVersion, methods, methodsByName, methodsByName, minorVersion, module, name, nestedTypes, sourceDebugExtension, sourceName, sourceNames, sourcePaths, visibleFields, visibleMethods

      • Methods inherited from interface com.sun.jdi.Type

        signature

    • 方法详细信息

      • superinterfaces

        List<InterfaceType> superinterfaces​()
        获取此接口直接扩展的接口。 返回的列表只包含该接口声明为扩展的那些接口。
        结果
        一个InterfaceType对象的列表， 每个对象镜像由此接口扩展的接口。 如果不存在，返回零长度列表。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • subinterfaces

        List<InterfaceType> subinterfaces​()
        获取当前准备的接口，直接扩展该接口。 返回的列表仅包含在其“extends”子句中声明此接口的接口。
        结果
        一个InterfaceType对象的列表， 每个对象镜像一个扩展此接口的接口。 如果不存在，返回零长度列表。

      • implementors

        List<ClassType> implementors​()
        获取直接实现此接口的当前准备的类。 返回的列表仅包含在其“implements”子句中声明此接口的类。
        结果
        一个ClassType对象的列表，每个镜像一个实现此接口的类。 如果不存在，返回零长度列表。

      • invokeMethod

        default Value invokeMethod​(ThreadReference thread,
                           方法 method,
                           List<? extends Value> arguments,
                           int options)
                    throws InvalidTypeException,
                           ClassNotLoadedException,
                           IncompatibleThreadStateException,
                           InvocationException
        调用目标VM中指定的静态方法 。 必须在此界面中定义指定的方法。 该方法必须是静态方法，而不是静态初始化程序。

        方法调用将发生在指定的线程中。 只有指定线程已被该线程中发生的事件挂起，才能进行方法调用。 当目标VM已通过悬浮不支持方法调用VirtualMachine.suspend()时，或者当指定的线程通过挂起ThreadReference.suspend() 。

        使用指定参数列表中的参数调用指定的方法。 方法调用是同步的 该方法直到被调用的方法在目标VM中返回才返回。 如果调用的方法抛出异常，此方法将抛出一个InvocationException ，其中包含抛出异常对象的镜像。

        对象参数必须与参数类型分配兼容（这意味着参数类型必须通过封装类的加载器加载）。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 如果被调用的方法接受可变数量的参数，则最后一个参数类型是某种组件类型的数组。 可以省略匹配位置中的参数，或者可以为null，相同组件类型的数组，或组件类型的参数，后跟任意数量的相同类型的其他参数。 如果省略参数，则传递组件类型的0长度数组。 组件类型可以是原始类型。 不支持自动装箱。 有关分配兼容性的更多信息，请参见The Java™ Language Specification的 5.2节。

        默认情况下，如果先前被某个事件挂起，或者通过VirtualMachine.suspend()或ThreadReference.suspend() ，方法将被调用，则目标VM中的所有线程都将被恢复。 这样做是为了防止如果任何线程拥有调用方法需要的监视器，将会发生死锁。 但是请注意，这个隐式恢复与ThreadReference.resume()完全一致 ，所以如果线程的挂起计数大于1，那么在调用过程中它将保持暂停状态，从而仍然可能会发生死锁。 默认情况下，当调用完成时，目标VM中的所有线程都将被暂停，而不管调用之前的状态如何。 在调用期间可能会发生断点或其他事件。 这可能会导致如上所述的死锁。 如果从客户端的事件处理程序线程调用invokeMethod，它也可能导致死锁。 在这种情况下，该线程将等待invokeMethod完成，并且不会读取新事件引入的EventSet。 如果这个新的EventSet是SUSPEND_ALL，那么会发生死锁，因为没有人会恢复EventSet。 为避免这种情况，在执行invokeMethod之前，应该禁用所有EventRequests，否则不应该从客户端的事件处理程序线程中完成invokeMethod。

        在调用期间恢复其他线程可以通过在options参数中指定ClassType.INVOKE_SINGLE_THREADED位标志来防止; 然而，没有保护或恢复上述僵局，所以这个选择应该非常小心。 只有指定的线程将被恢复（如上面所有线程所述）。 完成单个线程调用后，调用线程将再次被挂起。 请注意，在调用完成时，单线程调用期间启动的任何线程都不会被挂起。

        如果目标VM在调用期间断开连接（例如，通过VirtualMachine.dispose() ），方法调用将继续。

        参数
        thread - 要调用的线程。
        method - 要调用的方法 。
        arguments - 绑定到被调用方法的Value参数的列表。 列表中的值按照它们在方法签名中显示的顺序分配给参数。
        options - 整数位标志选项。
        结果
        一个Value镜像的调用方法的返回值。
        异常
        IllegalArgumentException - 如果方法不是此接口的成员，如果参数列表的大小与方法的声明参数数不匹配，或者方法不是静态的或是静态初始化程序。
        ClassNotLoadedException - 如果任何参数类型尚未通过适当的类加载器加载。
        IncompatibleThreadStateException - 如果指定的线程没有被事件挂起。
        InvocationException - 如果方法调用导致目标VM中的异常。
        InvalidTypeException - 如果参数不符合此要求 - 对象参数必须与参数类型兼容。 这意味着参数类型必须通过封装类'类加载器加载。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InternalException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InternalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.InternalException
  • All Implemented Interfaces:
    Serializable

    public class InternalException
extends RuntimeException
    抛出，表示出现意外的内部错误。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InternalException​()
      InternalException​(int errorCode)
      InternalException​(String s)
      InternalException​(String s, int errorCode)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      int | errorCode​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InternalException

        public InternalException​()

      • InternalException

        public InternalException​(String s)

      • InternalException

        public InternalException​(int errorCode)

      • InternalException

        public InternalException​(String s,
                         int errorCode)

    • 方法详细信息

      • errorCode

        public int errorCode​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidCodeIndexException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InvalidCodeIndexException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.InvalidCodeIndexException
  • All Implemented Interfaces:
    Serializable
    已过时。
    不再抛出此异常

    @Deprecated
public class InvalidCodeIndexException
extends RuntimeException
    抛出以指示所请求的操作无法完成，因为指定的代码索引无效。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidCodeIndexException​()
      已过时。
      InvalidCodeIndexException​(String s)
      已过时。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidCodeIndexException

        public InvalidCodeIndexException​()
        已过时。

      • InvalidCodeIndexException

        public InvalidCodeIndexException​(String s)
        已过时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidLineNumberException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InvalidLineNumberException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.InvalidLineNumberException
  • All Implemented Interfaces:
    Serializable
    已过时。
    不再抛出此异常

    @Deprecated
public class InvalidLineNumberException
extends RuntimeException
    抛出以指示所请求的操作无法完成，因为指定的行号无效。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidLineNumberException​()
      已过时。
      InvalidLineNumberException​(String s)
      已过时。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidLineNumberException

        public InvalidLineNumberException​()
        已过时。

      • InvalidLineNumberException

        public InvalidLineNumberException​(String s)
        已过时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidModuleException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InvalidModuleException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.InvalidModuleException
  • All Implemented Interfaces:
    Serializable

    public class InvalidModuleException
extends RuntimeException
    抛出以表明所请求的模块在卸载模块后无效或无效。

    从以下版本开始：
    9
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidModuleException​()
      构造一个没有详细消息的 InvalidModuleException 。
      InvalidModuleException​(String msg)
      构造具有给定详细消息的 InvalidModuleException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidModuleException

        public InvalidModuleException​()
        构造一个 InvalidModuleException ，没有详细信息。

      • InvalidModuleException

        public InvalidModuleException​(String msg)
        构造具有给定详细信息的 InvalidModuleException 。
        参数
        msg - 详细信息; 可以是null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidStackFrameException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InvalidStackFrameException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.InvalidStackFrameException
  • All Implemented Interfaces:
    Serializable

    public class InvalidStackFrameException
extends RuntimeException
    抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidStackFrameException​()
      InvalidStackFrameException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidStackFrameException

        public InvalidStackFrameException​()

      • InvalidStackFrameException

        public InvalidStackFrameException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InvalidTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.jdi.InvalidTypeException
  • All Implemented Interfaces:
    Serializable

    public class InvalidTypeException
extends 异常
    抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidTypeException​()
      InvalidTypeException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidTypeException

        public InvalidTypeException​()

      • InvalidTypeException

        public InvalidTypeException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvocationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class InvocationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.jdi.InvocationException
  • All Implemented Interfaces:
    Serializable

    public class InvocationException
extends 异常
    抛出以指示目标VM中的调用方法中发生异常。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvocationException​(ObjectReference exception)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ObjectReference exception​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvocationException

        public InvocationException​(ObjectReference exception)

    • 方法详细信息

      • exception

        public ObjectReference exception​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JDIPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class JDIPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • com.sun.jdi.JDIPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class JDIPermission
extends BasicPermission
    JDIPermission类代表对VirtualMachineManager访问权限。 这是SecurityManager将在使用SecurityManager运行的代码请求访问VirtualMachineManager时检查的权限，如Java平台的Java调试接口（JDI）中所定义。

    一个JDIPermission对象包含一个名称（也称为“目标名称”），但没有动作列表; 你有指定的权限，或者你没有。

    下表提供了许可允许的简要说明，并讨论了授予代码许可的风险。

    Table shows permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission virtualMachineManager Ability to inspect and modify the JDI objects in the VirtualMachineManager This allows an attacker to control the VirtualMachineManager and cause the system to misbehave.

    程序员通常不直接创建JDIPermission对象。 相反，它们是基于阅读安全策略文件的安全策略代码创建的。

    从以下版本开始：
    1.5
    另请参见：
    Bootstrap ， BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      JDIPermission​(String name)
      JDIPermission类代表对 VirtualMachineManager访问权限
      JDIPermission​(String name, String actions)
      构造一个新的JDIPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • JDIPermission

        public JDIPermission​(String name)
        JDIPermission类代表对 VirtualMachineManager访问权限
        参数
        name - 权限名称。 必须是“virtualMachineManager”。
        异常
        IllegalArgumentException - 如果name参数无效。

      • JDIPermission

        public JDIPermission​(String name,
                     String actions)
              throws IllegalArgumentException
        构造一个新的JDIPermission对象。
        参数
        name - 权限名称。 必须是“virtualMachineManager”。
        actions - 必须为null或空字符串。
        异常
        IllegalArgumentException - if arguments are invalid.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LocalVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface LocalVariable

  • All Superinterfaces:
    Comparable<LocalVariable> ， Mirror

    public interface LocalVariable
extends Mirror, Comparable<LocalVariable>
    目标VM中的局部变量。 在一个方法内声明的每个变量都有自己的LocalVariable对象。 在不同作用域中声明的同名变量具有不同的LocalVariable对象。 LocalVariables可以单独使用来检索有关其声明的静态信息，也可以与StackFrame一起使用来设置和获取值。
    从以下版本开始：
    1.3
    另请参见：
    StackFrame ， 方法

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此LocalVariable进行比较以获得相等性。
      String genericSignature​()
      获取此变量的通用签名（如果有）。
      int hashCode​()
      返回此LocalVariable的哈希码值。
      boolean isArgument​()
      确定此变量是否为其方法的参数。
      boolean isVisible​(StackFrame frame)
      确定是否可以从给定的StackFrame访问此变量。
      String name​()
      获取局部变量的名称。
      String signature​()
      获取局部变量的JNI签名。
      Type type​()
      返回此变量的类型。
      String typeName​()
      返回此变量类型的文本表示形式。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • name

        String name​()
        获取局部变量的名称。
        结果
        一个包含该名称的字符串。

      • typeName

        String typeName​()
        返回此变量类型的文本表示形式。 其中type是在此局部变量的声明中指定的类型。

        即使类型尚未创建或加载，此类型名称始终可用。

        结果
        一个表示此局部变量类型的字符串。

      • type

        Type type​()
   throws ClassNotLoadedException
        返回此变量的类型。 其中type是在此局部变量的声明中指定的类型。

        注意：如果此变量的类型是引用类型（类，接口或数组），并且尚未由封装类的类加载器创建或加载，则将抛出ClassNotLoadedException。 此外，引用类型可能已经加载但尚未准备好，在这种情况下，类型将被返回，但是尝试对返回类型执行某些操作（例如， fields() ）将抛出一个ClassNotPreparedException 。 使用ReferenceType.isPrepared()来确定是否准备了参考类型。

        结果
        这个局部变量的Type 。
        异常
        ClassNotLoadedException - 如果类型尚未通过适当的类加载器加载。
        另请参见：
        Type ， Field.type() - for usage examples

      • signature

        String signature​()
        获取局部变量的JNI签名。
        结果
        一个包含签名的字符串。
        另请参见：
        Type Signatures

      • genericSignature

        String genericSignature​()
        获取此变量的通用签名（如果有）。 通用签名在The Java™ Virtual Machine Specification中有描述。
        结果
        一个包含通用签名的字符串，如果没有通用签名， null 。
        从以下版本开始：
        1.5

      • isVisible

        boolean isVisible​(StackFrame frame)
        确定是否可以从给定的StackFrame访问此变量。 有关此接口中的完整描述变量可见性，请参阅StackFrame.visibleVariables() 。
        参数
        frame - StackFrame查询可见性
        结果
        true如果这个变量是可见的; 否则为false 。
        异常
        IllegalArgumentException - 如果堆栈框的方法与此变量的方法不匹配。

      • isArgument

        boolean isArgument​()
        确定此变量是否为其方法的参数。
        结果
        true如果这个变量是一个参数; false否则。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此LocalVariable进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果对象是LocalVariable，则为true，如果两个LocalVariables都包含在相同的方法中（由 Method.equals(java.lang.Object)确定），并且两个LocalVariable都在该方法中镜像同一声明
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此LocalVariable的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Locatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Locatable

  • All Known Subinterfaces:
    AccessWatchpointEvent ， BreakpointEvent ， BreakpointRequest ， ExceptionEvent ， LocatableEvent ， 方法 ， MethodEntryEvent ， MethodExitEvent ， ModificationWatchpointEvent ， MonitorContendedEnteredEvent ， MonitorContendedEnterEvent ， MonitorWaitedEvent ， MonitorWaitEvent ， StackFrame ， StepEvent ， WatchpointEvent

    public interface Locatable
    一个镜子有一个Location 。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Location location​()
      返回此镜像的Location ，如果有可执行代码与之相关联。

    • 方法详细信息

      • location

        Location location​()
        返回此镜像的Location ，如果有可执行代码与之相关联。 请注意，Java编程语言方法和本机方法均具有可执行代码。 对抽象方法返回null，因为抽象方法没有可执行代码。
        结果
        这个镜像的Location ，如果没有与之相关联的可执行代码，则为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Location (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Location

  • All Superinterfaces:
    Comparable<Location> ， Mirror

    public interface Location
extends Mirror, Comparable<Location>
    目标VM的执行代码中的一个点。 位置用于标识挂起线程的当前位置（类似于本机程序中的指令指针或程序计数器寄存器）。 它们也用于识别设置断点的位置。

    位置的行号的可用性将取决于目标VM可用的调试信息的级别。

    几个镜像接口有位置。 每个这样的镜像扩展了一个Locatable接口。

    Strata

    位置的源信息取决于所使用的层 。 层次是翻译序列中的源代码级别。 例如，说baz程序是用编程语言“Foo”编写的，然后翻译成“Bar”语言，最后转化为Java编程语言。 Java编程语言层次被命名为"Java" ，我们假设其他层被命名为“Foo”和“Bar”。 一个给定的位置（如由观察sourceName()种lineNumber()方法）可能是在“baz.foo”的线14 "Foo"在“baz.bar”的阶层，第23行"Bar"地层和的线71 "Java"地层。 请注意，虽然Java编程语言可能只有一个源文件作为引用类型，但此限制不适用于其他层 - 因此应查阅每个位置以确定其源路径。 不指定层（查询sourceName() ， sourcePath()和lineNumber() ）使用虚拟机的默认层（ VirtualMachine.getDefaultStratum() ）。 如果指定层（无论是作为虚拟机的默认方法参数或隐显式指定）为null或不可用的声明类型，声明类型的默认阶层使用（ declaringType() 。 defaultStratum() ）。 请注意，在正常情况下，源自Java编程语言源的代码将只有一个层（ "Java" ），并将作为默认值返回。 确定可用地层使用ReferenceType.availableStrata() 。

    从以下版本开始：
    1.3
    另请参见：
    EventRequestManager ， StackFrame ， BreakpointEvent ， ExceptionEvent ， Locatable

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long codeIndex​()
      获取此位置方法中的代码位置。
      ReferenceType declaringType​()
      获取此位置所属的类型。
      boolean equals​(Object obj)
      将指定的对象与此位置进行比较以获得相等性。
      int hashCode​()
      返回此位置的哈希码值。
      int lineNumber​()
      获取此位置的行号。
      int lineNumber​(String stratum)
      此位置的行号。
      方法 method​()
      获取包含此位置的方法。
      String sourceName​()
      获取与此位置相对应的源的标识名称。
      String sourceName​(String stratum)
      获取与此位置相对应的源的标识名称。
      String sourcePath​()
      获取与此位置相对应的源的路径。
      String sourcePath​(String stratum)
      获取与此位置相对应的源的路径。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • declaringType

        ReferenceType declaringType​()
        获取此位置所属的类型。 通常，声明类型是ClassType ，但可执行位置也可能存在于静态初始化程序中的一个InterfaceType中 。
        结果
        包含此位置的ReferenceType 。

      • method

        方法 method​()
        获取包含此位置的方法。
        结果
        位置的方法 。

      • codeIndex

        long codeIndex​()
        获取此位置方法中的代码位置。
        结果
        long表示方法中的位置，如果位置在本机方法内，则为-1。

      • sourceName

        String sourceName​()
           throws AbsentInformationException
        获取与此位置相对应的源的标识名称。

        此方法相当于sourceName(vm.getDefaultStratum()) - 有关详细信息，请参阅sourceName(String) 。

        结果
        一个指定源的字符串
        异常
        AbsentInformationException - 如果源名称不知道

      • sourceName

        String sourceName​(String stratum)
           throws AbsentInformationException
        获取与此位置相对应的源的标识名称。 该字符串的解释是源存储库机制的责任。

        返回的名称是指定的层 （有关层的描述，请参阅class comment ）。

        返回的字符串是此位置的源文件的不合格名称。 例如， java.lang.Thread将返回"Thread.java" 。

        参数
        stratum - 为声明类型的默认层次检索信息的层或 null 。
        结果
        一个指定源的字符串
        异常
        AbsentInformationException - 如果源名称不知道
        从以下版本开始：
        1.4

      • sourcePath

        String sourcePath​()
           throws AbsentInformationException
        获取与此位置相对应的源的路径。

        此方法相当于sourcePath(vm.getDefaultStratum()) - 有关详细信息，请参阅sourcePath(String) 。

        结果
        一个指定源的字符串
        异常
        AbsentInformationException - 如果源名称不知道

      • sourcePath

        String sourcePath​(String stratum)
           throws AbsentInformationException
        获取与此位置相对应的源的路径。 该字符串的解释是源存储库机制的责任。

        返回的路径用于指定的层 （有关层的描述，请参阅class comment ）。

        在参考实现中，对于没有明确指定源路径（Java编程语言stratum永远不会）的层，返回的字符串是declaringType()的包名称，转换为平台相关路径，后跟源文件的不合格名称位置（ sourceName(stratum) ）。 例如，在Windows平台上， java.lang.Thread将返回"java\lang\Thread.java" 。

        参数
        stratum - 为声明类型的默认层次检索信息或 null的层次。
        结果
        一个指定源的字符串
        异常
        AbsentInformationException - 如果源名称不知道
        从以下版本开始：
        1.4

      • lineNumber

        int lineNumber​()
        获取此位置的行号。

        此方法相当于lineNumber(vm.getDefaultStratum()) - 有关详细信息，请参阅lineNumber(String) 。

        结果
        指定源中的行的int返回-1，如果信息不可用; 具体来说，总是返回-1为本地方法。

      • lineNumber

        int lineNumber​(String stratum)
        此位置的行号。 行号相对于由sourceName(stratum)指定的来源 。

        返回的行号用于指定的层次 （有关层的描述，请参阅class comment ）。

        参数
        stratum - 从声明类型的默认层次中检索信息的层或 null 。
        结果
        指定源中的行的int返回-1，如果信息不可用; 具体来说，总是返回-1为本地方法。
        从以下版本开始：
        1.4

      • equals

        boolean equals​(Object obj)
        将指定的对象与此位置进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果对象是位置，并且它是否指向与此位置相同的VM中的同一点，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此位置的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LongType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface LongType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface LongType
extends PrimitiveType
    在目标虚拟机中访问的所有原始long类型为long 。 调用Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    LongValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LongValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface LongValue

  • All Superinterfaces:
    Comparable<LongValue> ， Mirror ， PrimitiveValue ， Value

    public interface LongValue
extends PrimitiveValue, Comparable<LongValue>
    提供对目标虚拟机中原始值 long访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此LongValue进行比较以获得相等性。
      int hashCode​()
      返回此LongValue的哈希码值。
      long value​()
      返回此LongValue为长。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        long value​()
        返回此LongValue为长。
        结果
        这个对象镜像的 long 。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此LongValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是LongValue，并且如果将“==”应用于两个镜像的原语，则该值将为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此LongValue的哈希码值。
        重写：
        hashCode Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Method (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Method

  • All Superinterfaces:
    Accessible ， Comparable<方法> ， Locatable ， Mirror ， TypeComponent

    public interface 方法
extends TypeComponent, Locatable, Comparable<方法>
    目标VM中的静态或实例方法。 有关Field和Method镜像的一般信息，请参阅TypeComponent 。
    从以下版本开始：
    1.3
    另请参见：
    ObjectReference ， ReferenceType

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      List<Location> allLineLocations​()
      在此方法中为每个可执行源行返回一个包含一个Location对象的列表。
      List<Location> allLineLocations​(String stratum, String sourceName)
      在此方法中为每个可执行源行返回一个包含Location对象的列表。
      List<LocalVariable> arguments​()
      返回一个列表，其中包含声明为此方法的参数的每个LocalVariable 。
      List<String> argumentTypeNames​()
      返回一个包含此方法的每个形式参数类型的文本表示的列表。
      List<Type> argumentTypes​()
      返回一个包含此方法的每个形式参数类型的列表。
      byte[] bytecodes​()
      返回一个包含此方法的字节码的数组。
      boolean equals​(Object obj)
      将指定的Object与此方法进行比较以实现相等。
      int hashCode​()
      返回此方法的哈希码值。
      boolean isAbstract​()
      确定这个方法是否是抽象的。
      boolean isBridge​()
      确定此方法是否为桥接方法。
      boolean isConstructor​()
      确定这个方法是否是一个构造函数。
      default boolean isDefault​()
      确定此方法是否为默认方法
      boolean isNative​()
      确定此方法是否为本机。
      boolean isObsolete​()
      确定此方法是否已过时。
      boolean isStaticInitializer​()
      确定此方法是否为静态初始化程序。
      boolean isSynchronized​()
      确定此方法是否同步。
      boolean isVarArgs​()
      确定此方法是否接受可变数量的参数。
      Location location​()
      返回此方法的Location ，如果有可执行代码与之相关联。
      Location locationOfCodeIndex​(long codeIndex)
      为给定的代码索引返回一个Location 。
      List<Location> locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号和源名称的所有Location对象的列表。
      Type returnType​()
      返回返回类型，如该方法的声明所指定。
      String returnTypeName​()
      返回返回类型的文本表示形式，如该方法的声明所指定。
      List<LocalVariable> variables​()
      返回包含此方法中声明的每个LocalVariable的列表。
      List<LocalVariable> variablesByName​(String name)
      在此方法中返回包含给定名称的每个LocalVariable的列表。

      • Methods inherited from interface com.sun.jdi.Accessible

        isPackagePrivate, isPrivate, isProtected, isPublic, modifiers

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.TypeComponent

        declaringType, genericSignature, isFinal, isStatic, isSynthetic, name, signature

    • 方法详细信息

      • returnTypeName

        String returnTypeName​()
        返回返回类型的文本表示形式，如该方法的声明所指定。

        即使类型尚未创建或加载，此类型名称始终可用。

        结果
        一个包含返回类型名称的 String 。

      • returnType

        Type returnType​()
         throws ClassNotLoadedException
        返回返回类型，如该方法的声明所指定。

        注意：如果此方法的返回类型是引用类型（类，接口或数组），并且尚未由声明类型的类加载器（即declaringType() .classLoader() ）创建或加载，则将抛出ClassNotLoadedException异常。 此外，引用类型可能已经加载但尚未准备好，在这种情况下，类型将被返回，但是尝试对返回的类型执行某些操作（例如， fields() ）将抛出一个ClassNotPreparedException 。 使用ReferenceType.isPrepared()确定是否准备了引用类型。

        结果
        该方法的返回值为Type 。
        异常
        ClassNotLoadedException - 如果类型尚未通过适当的类加载器创建或加载。
        另请参见：
        Type ， Field.type() - for usage examples

      • argumentTypeNames

        List<String> argumentTypeNames​()
        返回一个包含此方法的每个形式参数类型的文本表示的列表。

        即使类型尚未创建或加载，此列表始终可用。

        结果
        一个List的String ，这个方法的每个参数的一个List元素。 每个元素表示在编译时指定的形式参数的类型。 如果使用省略号声明了形式参数，则将其表示为省略号之前的类型的数组。

      • argumentTypes

        List<Type> argumentTypes​()
                  throws ClassNotLoadedException
        返回一个包含此方法的每个形式参数类型的列表。

        注意：如果存在类型为引用类型（类，接口或数组）的任何参数，并且尚未由声明类型的类加载器（即declaringType() .classLoader() ）创建或加载，则将抛出ClassNotLoadedException。 此外，引用类型可能已经加载但尚未准备好，在这种情况下，列表将被返回，但尝试对类型执行某些操作（例如， fields() ）将抛出一个ClassNotPreparedException 。 使用ReferenceType.isPrepared()来确定是否准备了引用类型。

        结果
        返回一个List的Type ，这个方法的每个参数的一个List元素。 每个元素表示在编译时指定的形式参数的类型。 如果使用省略号声明了形式参数，则将其表示为省略号之前的类型的数组。
        异常
        ClassNotLoadedException - 如果类型尚未通过适当的类加载器加载。
        另请参见：
        Type

      • isAbstract

        boolean isAbstract​()
        确定这个方法是否是抽象的。
        结果
        如果方法声明为abstract， true ; 否则为false 。

      • isDefault

        default boolean isDefault​()
        确定此方法是否为默认方法
        结果
        true如果方法声明为default; false否则。
        从以下版本开始：
        1.8

      • isSynchronized

        boolean isSynchronized​()
        确定此方法是否同步。
        结果
        true如果方法被声明为synchronized; false否则。

      • isNative

        boolean isNative​()
        确定此方法是否为本机。
        结果
        true如果方法被声明为native; 否则为false 。

      • isVarArgs

        boolean isVarArgs​()
        确定此方法是否接受可变数量的参数。
        结果
        true如果方法接受可变数量的参数，否则为 false 。
        从以下版本开始：
        1.5

      • isBridge

        boolean isBridge​()
        确定此方法是否为桥接方法。 桥接方法在The Java™ Language Specification中定义。
        结果
        true如果方法是桥接方法，否则为 false 。
        从以下版本开始：
        1.5

      • isConstructor

        boolean isConstructor​()
        确定这个方法是否是一个构造函数。
        结果
        true如果方法是一个构造函数; false否则。

      • isStaticInitializer

        boolean isStaticInitializer​()
        确定此方法是否为静态初始化程序。
        结果
        true如果方法是一个静态的初始化器; 否则为false 。

      • isObsolete

        boolean isObsolete​()
        确定此方法是否已过时。
        结果
        true如果此方法已被 VirtualMachine.redefineClasses(java.util.Map<? extends com.sun.jdi.ReferenceType, byte[]>)操作过时。
        从以下版本开始：
        1.4

      • allLineLocations

        List<Location> allLineLocations​()
                         throws AbsentInformationException
        在此方法中为每个可执行源行返回一个包含一个Location对象的列表。

        此方法相当于allLineLocations(vm.getDefaultStratum(),null) - 有关详细信息，请参阅allLineLocations(String,String) 。

        结果
        所有源码列表Location对象。
        异常
        AbsentInformationException - 如果没有这个（非本地的，非抽象的）方法的行号信息。

      • allLineLocations

        List<Location> allLineLocations​(String stratum,
                                String sourceName)
                         throws AbsentInformationException
        在此方法中为每个可执行源行返回一个包含Location对象的列表。

        每个位置将源行映射到一系列代码索引。 范围的开始可以通过Location.codeIndex()确定。 返回的列表按代码索引（从低到高）排序。

        如果编译器和/或VM将该行映射到两个或更多个不相交的代码索引范围，则返回的列表可能包含特定行号的多个位置。

        如果该方法是native或abstract，则返回一个空列表。

        返回的列表是指定的层次 （有关层的描述，请参阅Location ）。

        参数
        stratum - 从 null或 null检索信息的 层次
        sourceName - 仅返回此源文件中的位置或 null返回位置。
        结果
        所有源代码行列表Location对象。
        异常
        AbsentInformationException - 如果此（非本地，非抽象）方法没有行号信息。 或者，如果SOURCENAME是非null和源名信息不存在。
        从以下版本开始：
        1.4

      • locationsOfLine

        List<Location> locationsOfLine​(int lineNumber)
                        throws AbsentInformationException
        返回包含映射到给定行号的所有Location对象的列表。

        此方法相当于locationsOfLine(vm.getDefaultStratum(), null, lineNumber) - 有关详细信息，请参阅locationsOfLine(java.lang.String,java.lang.String,int) 。

        参数
        lineNumber - 行号
        结果
        一个Location对象的列表映射到给定的行号。
        异常
        AbsentInformationException - 如果此方法没有行号信息。

      • locationsOfLine

        List<Location> locationsOfLine​(String stratum,
                               String sourceName,
                               int lineNumber)
                        throws AbsentInformationException
        返回包含映射到给定行号和源名称的所有Location对象的列表。

        返回包含映射到给定行的每个Location的列表。 返回的列表将包含由编译器和/或VM分配给给定行的每个不相交的代码索引范围的位置。 每个返回的位置对应于此范围的开始。 如果指定的行号没有可执行代码，将返回一个空列表; 具体来说，本机和抽象方法将始终返回一个空列表。

        返回的列表是指定的层次 （有关层的描述，请参阅Location ）。

        参数
        stratum - 用于比较行号和源名称的层次，或使用默认层次的层次
        sourceName - 包含行号的源名称，或null以匹配所有源名称
        lineNumber - 行号
        结果
        一个Location对象的列表，映射到给定的行号。
        异常
        AbsentInformationException - 如果此方法没有行号信息。 或者，如果SOURCENAME是非null和源名信息不存在。
        从以下版本开始：
        1.4

      • locationOfCodeIndex

        Location locationOfCodeIndex​(long codeIndex)
        为给定的代码索引返回一个Location 。
        结果
        Location对应于给定的代码索引，如果指定的代码索引不是此方法的有效代码索引，则为null（本机和抽象方法将始终返回null）。

      • variables

        List<LocalVariable> variables​()
                       throws AbsentInformationException
        返回包含此方法中声明的每个LocalVariable的列表。 该列表包括在方法中任何范围内声明的任何变量。 它可能包含在不相交的范围内声明的同名的多个变量。 参数被认为是局部变量，并将返回到列表中。 如果局部变量信息不可用，方法调用的实际参数的值可以通过使用方法StackFrame.getArgumentValues()
        结果
        LocalVariable对象的列表， 该对象镜像目标VM中此方法中声明的局部变量。 如果没有局部变量，则返回零长度列表。
        异常
        AbsentInformationException - 如果此方法没有变量信息。 通常，局部变量信息不适用于本地或抽象方法（即，它们的参数名称信息不可用），因此它们将抛出该异常。

      • variablesByName

        List<LocalVariable> variablesByName​(String name)
                             throws AbsentInformationException
        在此方法中返回包含给定名称的每个LocalVariable的列表。 如果在方法中的不相交的范围内使用相同的变量名，则可以返回多个变量。
        结果
        给定名称的LocalVariable对象的列表。 如果没有匹配的局部变量，则返回零长度列表。
        异常
        AbsentInformationException - 如果此方法没有变量信息。 通常，局部变量信息不适用于本地或抽象方法（即，它们的参数名称信息不可用），因此它们将抛出该异常。

      • arguments

        List<LocalVariable> arguments​()
                       throws AbsentInformationException
        返回一个列表，其中包含声明为此方法的参数的每个LocalVariable 。 如果局部变量信息不可用，方法调用的实际参数的值可以通过使用方法StackFrame.getArgumentValues()
        结果
        列表LocalVariable参数。 如果没有参数，则返回零长度列表。
        异常
        AbsentInformationException - 如果此方法没有变量信息。 通常，局部变量信息不适用于本地或抽象方法（即，它们的参数名称信息不可用），因此它们将抛出该异常。

      • bytecodes

        byte[] bytecodes​()
        返回一个包含此方法的字节码的数组。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetBytecodes()确定是否支持该操作。

        结果
        字节码阵列; 抽象和本机方法将返回一个零长度的数组。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持检索字节码。

      • location

        Location location​()
        返回此方法的Location ，如果有可执行代码与之相关联。
        Specified by:
        location在接口 Locatable
        结果
        这个镜像的Location ，如果这是一个抽象方法，则为null; 本机方法将返回其codeIndex为-1的Location对象。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此方法进行比较以实现相等。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是一个方法，并且如果两个镜像都是相同的方法（在同一个VM中的同一个类或接口中声明），则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此方法的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码。
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Mirror (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Mirror

  • All Known Subinterfaces:
    AccessWatchpointEvent ， AccessWatchpointRequest ， ArrayReference ， ArrayType ， BooleanType ， BooleanValue ， BreakpointEvent ， BreakpointRequest ， ByteType ， ByteValue ， CharType ， CharValue ， ClassLoaderReference ， ClassObjectReference ， ClassPrepareEvent ， ClassPrepareRequest ， ClassType ， ClassUnloadEvent ， ClassUnloadRequest ， DoubleType ， DoubleValue ， Event ， EventQueue ， EventRequest ， EventRequestManager ， EventSet ， ExceptionEvent ， ExceptionRequest ， Field ， FloatType ， FloatValue ， IntegerType ， IntegerValue ， InterfaceType ， LocalVariable ， LocatableEvent ， Location ， LongType ， LongValue ， 方法 ， MethodEntryEvent ， MethodEntryRequest ， MethodExitEvent ， MethodExitRequest ， ModificationWatchpointEvent ， ModificationWatchpointRequest ， ModuleReference ， MonitorContendedEnteredEvent ， MonitorContendedEnteredRequest ， MonitorContendedEnterEvent ， MonitorContendedEnterRequest ， MonitorInfo ， MonitorWaitedEvent ， MonitorWaitedRequest ， MonitorWaitEvent ， MonitorWaitRequest MonitorWaitRequest ， ObjectReference ， PathSearchingVirtualMachine ， PrimitiveType ， PrimitiveValue ， ReferenceType ， ShortType ， ShortValue ， StackFrame ， StepEvent ， StepRequest ， StringReference ， ThreadDeathEvent ， ThreadDeathRequest ， ThreadGroupReference ， ThreadReference ， ThreadStartEvent ， ThreadStartRequest ， Type ， TypeComponent ， Value ， VirtualMachine ， VMDeathEvent ， VMDeathRequest ， VMDisconnectEvent ， VMStartEvent ， VoidType ， VoidValue ， WatchpointEvent ， WatchpointRequest

    public interface Mirror
    调试器使用的代理来检查或操纵另一个虚拟机中的某个实体。 镜像是此包的界面层次结构的根。 镜像可以是目标VM（ ObjectReference ）中的对象，原始值（例如， IntegerValue ），类型（例如， ReferenceType ），动态应用程序状态（例如， StackFrame ）以及甚至调试器特定构造（例如， ， BreakpointRequest ）。 VirtualMachine本身也被认为是镜像，表示目标VM的复合状态。

    不能保证目标虚拟机中的特定实体将映射到单个镜像实例。 实现者可以自由决定是否将单个镜像用于某些或所有镜像。 此接口的客户端应始终使用equals来比较两个镜像之间的相等性。

    Mirror上直接或间接使用Mirror作为参数的任何方法（例如，作为List的元素），如果镜像来自不同的虚拟机，则会抛出VMMismatchException 。

    从以下版本开始：
    1.3
    另请参见：
    VirtualMachine

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String toString​()
      返回描述此镜像的String
      VirtualMachine virtualMachine​()
      获取此镜像所属的VirtualMachine。

    • 方法详细信息

      • virtualMachine

        VirtualMachine virtualMachine​()
        获取此镜像所属的VirtualMachine。 镜像必须与VirtualMachine相关联才能有任何意义。
        结果
        这个镜像是代理的VirtualMachine 。

      • toString

        String toString​()
        返回描述此镜像的String
        重写：
        toString在 Object
        结果
        描述这个镜子的字符串。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ModuleReference

  • All Superinterfaces:
    Mirror ， ObjectReference ， Value

    public interface ModuleReference
extends ObjectReference
    目标虚拟机中的一个模块。

    上的任何方法ModuleReference直接或间接花费ModuleReference作为参数可能抛出VMDisconnectedException如果目标VM断开且VMDisconnectEvent已经或可用于被从读EventQueue 。

    上的任何方法ModuleReference直接或间接花费ModuleReference作为参数可能抛出VMOutOfMemoryException如果目标VM已用完的存储器。

    ModuleReference或直接或间接以ModuleReference作为参数的方法可能会抛出InvalidModuleException（如果镜像模块已卸载）。 并非所有目标虚拟机都支持此类。 使用VirtualMachine.canGetModuleInfo()确定是否支持该类。

    从以下版本开始：
    9

    • Field Summary

      • Fields inherited from interface com.sun.jdi.ObjectReference

        INVOKE_NONVIRTUAL, INVOKE_SINGLE_THREADED

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ClassLoaderReference classLoader​()
      返回此模块的ClassLoaderReference对象。
      String name​()
      返回模块名称。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ObjectReference

        disableCollection, enableCollection, entryCount, equals, getValue, getValues, hashCode, invokeMethod, isCollected, owningThread, referenceType, referringObjects, setValue, uniqueID, waitingThreads

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • name

        String name​()
        返回模块名称。 如果此模块是未命名的模块，此方法返回null 。
        结果
        该模块的名称。

      • classLoader

        ClassLoaderReference classLoader​()
        返回此模块的ClassLoaderReference对象。
        结果
        该模块的ClassLoaderReference对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface MonitorInfo

  • All Superinterfaces:
    Mirror

    public interface MonitorInfo
extends Mirror
    有关线程拥有的监视器的信息。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectReference monitor​()
      返回显示器的ObjectReference对象。
      int stackDepth​()
      返回该拥有线程获取该监视器的堆栈深度。
      ThreadReference thread​()
      为拥有该监视器的线程返回一个ThreadReference对象。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • monitor

        ObjectReference monitor​()
        返回显示器的ObjectReference对象。
        结果
        该显示器的ObjectReference对象。
        异常
        InvalidStackFrameException - 如果相关联的堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。
        从以下版本开始：
        1.6
        另请参见：
        ThreadReference.ownedMonitorsAndFrames()

      • stackDepth

        int stackDepth​()
        返回该拥有线程获取该监视器的堆栈深度。 如果实现无法确定堆栈深度（例如，由JNI MonitorEnter获取的监视器），则返回-1。
        结果
        该显示器由拥有的线程获取的堆叠深度。
        异常
        InvalidStackFrameException - 相关的堆栈帧是否变得无效。 一旦框架的线程恢复，堆栈框架将不再有效。
        另请参见：
        ThreadReference.ownedMonitorsAndFrames()

      • thread

        ThreadReference thread​()
        为拥有该监视器的线程返回一个ThreadReference对象。
        结果
        一个拥有该监视器的线程的ThreadReference对象。
        异常
        InvalidStackFrameException - 如果相关联的堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。
        另请参见：
        ThreadReference.frame(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NativeMethodException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class NativeMethodException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.NativeMethodException
  • All Implemented Interfaces:
    Serializable

    public class NativeMethodException
extends RuntimeException
    抛出表示操作无法完成，因为它对本机方法无效。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NativeMethodException​()
      NativeMethodException​(String message)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NativeMethodException

        public NativeMethodException​()

      • NativeMethodException

        public NativeMethodException​(String message)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectCollectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class ObjectCollectedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.ObjectCollectedException
  • All Implemented Interfaces:
    Serializable

    public class ObjectCollectedException
extends RuntimeException
    抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObjectCollectedException​()
      ObjectCollectedException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ObjectCollectedException

        public ObjectCollectedException​()

      • ObjectCollectedException

        public ObjectCollectedException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ObjectReference

  • All Superinterfaces:
    Mirror ， Value
    All Known Subinterfaces:
    ArrayReference ， ClassLoaderReference ， ClassObjectReference ， ModuleReference ， StringReference ， ThreadGroupReference ， ThreadReference

    public interface ObjectReference
extends Value
    当前存在于目标VM中的对象。 ObjectReference仅反映对象本身，并不属于当前分配给它的任何Field或LocalVariable 。 ObjectReference可以有来自字段和/或变量的0个或多个引用。

    上的任何方法ObjectReference其直接或间接地采用ObjectReference作为参数可能抛出VMDisconnectedException如果目标VM断开且VMDisconnectEvent已经或可用于被从读EventQueue 。

    如果目标虚拟机的内存ObjectReference ，则直接或间接以ObjectReference作为参数的任何方法可能会抛出VMOutOfMemoryException 。

    ObjectReference任何方法或直接或间接采用ObjectReference作为参数的方法可能会抛出ObjectCollectedException（如果镜像对象已被垃圾回收）。

    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int INVOKE_NONVIRTUAL
      执行非虚拟方法调用
      static int INVOKE_SINGLE_THREADED
      仅执行调用线程执行方法调用

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void disableCollection​()
      防止垃圾回收此对象。
      void enableCollection​()
      允许垃圾回收此对象。
      int entryCount​()
      返回此对象的显示器由当前拥有的线程输入的次数。
      boolean equals​(Object obj)
      将指定的Object与此ObjectReference进行比较以获得相等性。
      Value getValue​(Field sig)
      获取此对象中给定实例或静态字段的值。
      Map<Field,Value> getValues​(List<? extends Field> fields)
      获取此对象中多个实例和/或静态字段的值。
      int hashCode​()
      返回此ObjectReference的哈希码值。
      Value invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用此对象上指定的方法 。
      boolean isCollected​()
      确定此对象是否已在目标虚拟机中进行垃圾回收。
      ThreadReference owningThread​()
      返回当前拥有该对象的监视器的线程（如果有）的ThreadReference 。
      ReferenceType referenceType​()
      获取镜像该对象的类型的ReferenceType 。
      List<ObjectReference> referringObjects​(long maxReferrers)
      返回直接引用此对象的对象。
      void setValue​(Field field, Value value)
      设置此对象中给定实例或静态字段的值。
      long uniqueID​()
      返回此ObjectReference的唯一标识符。
      List<ThreadReference> waitingThreads​()
      返回一个列表，其中包含当前等待该对象的显示器的每个线程的一个ThreadReference 。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 字段详细信息

      • INVOKE_SINGLE_THREADED

        static final int INVOKE_SINGLE_THREADED
        仅执行调用线程执行方法调用
        另请参见：
        Constant Field Values

      • INVOKE_NONVIRTUAL

        static final int INVOKE_NONVIRTUAL
        执行非虚拟方法调用
        另请参见：
        Constant Field Values

    • 方法详细信息

      • referenceType

        ReferenceType referenceType​()
        获取反映该对象类型的ReferenceType 。 该类型可以是当前持有它的任何字段或变量的声明类型的子类或实现者。 例如，紧跟在下面的语句之后。

        Object obj = new String("Hello, world!");

        obj的ReferenceType将镜像java.lang.String而不是java.lang.Object。

        对象的类型永远不会更改，因此该方法将始终在镜像对象的生命周期中返回相同的ReferenceType。

        返回的ReferenceType将为ClassType或ArrayType ，从不为InterfaceType 。

        结果
        这个对象的ReferenceType 。

      • getValue

        Value getValue​(Field sig)
        获取此对象中给定实例或静态字段的值。 该字段必须对此ObjectReference有效; 也就是说，它必须来自镜像对象的类或该类的超类。
        参数
        sig - 包含请求值的字段
        结果
        实例字段的Value 。
        异常
        IllegalArgumentException - 如果该字段对该对象的类无效。

      • getValues

        Map<Field,Value> getValues​(List<? extends Field> fields)
        获取此对象中多个实例和/或静态字段的值。 字段必须对此ObjectReference有效; 也就是说，它们必须来自镜像对象的类或该类的超类。
        参数
        fields - 包含请求值的Field对象的列表。
        结果
        所需的Field对象的地图及其Value 。
        异常
        IllegalArgumentException - 如果任何字段对此对象的类无效。

      • setValue

        void setValue​(Field field,
              Value value)
       throws InvalidTypeException,
              ClassNotLoadedException
        设置此对象中给定实例或静态字段的值。 Field必须对此ObjectReference有效; 也就是说，它必须来自镜像对象的类或该类的超类。 如果是静态的，那么该字段不能是final。

        对象值必须与字段类型分配兼容（这意味着字段类型必须通过封闭类的加载器加载）。 原始值必须与字段类型兼容，或必须可转换为字段类型，而不会丢失信息。 有关分配兼容性的更多信息，请参阅The Java™ Language Specification的 5.2节。

        参数
        field - 包含请求值的字段
        value - 要分配的新值
        异常
        IllegalArgumentException - 如果该字段对该对象的类无效。
        InvalidTypeException - 如果值的类型与字段的类型不匹配。
        ClassNotLoadedException - 如果'value'不为null，并且字段类型尚未通过适当的类加载器加载。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • invokeMethod

        Value invokeMethod​(ThreadReference thread,
                   方法 method,
                   List<? extends Value> arguments,
                   int options)
            throws InvalidTypeException,
                   ClassNotLoadedException,
                   IncompatibleThreadStateException,
                   InvocationException
        在目标VM中调用此对象上指定的方法 。 指定的方法可以在此对象的类中，在该对象的类的超类中或在由该对象实现的接口中定义。 该方法可以是静态方法或实例方法，但不是静态初始化程序或构造函数。 使用ClassType.newInstance(com.sun.jdi.ThreadReference, com.sun.jdi.Method, java.util.List<? extends com.sun.jdi.Value>, int)创建一个新对象并运行其构造函数。

        方法调用将发生在指定的线程中。 只有指定线程已被该线程中发生的事件挂起，才能进行方法调用。 当目标VM已通过悬浮不支持方法调用VirtualMachine.suspend()时，或者当指定的线程通过挂起ThreadReference.suspend() 。

        使用指定参数列表中的参数调用指定的方法。 方法调用是同步的 该方法直到被调用的方法在目标VM中返回才返回。 如果调用的方法抛出异常，则此方法将抛出一个InvocationException ，其中包含抛出异常对象的镜像。

        对象参数必须与参数类型分配兼容（这意味着参数类型必须通过封闭类的加载器加载）。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 如果被调用的方法接受可变数量的参数，则最后一个参数类型是某种组件类型的数组。 可以省略匹配位置中的参数，或者可以为null，相同组件类型的数组，或组件类型的参数，后跟任意数量的相同类型的其他参数。 如果省略参数，则传递组件类型的0长度数组。 组件类型可以是原始类型。 不支持自动装箱。 有关分配兼容性的更多信息，请参阅The Java™ Language Specification的 5.2节。

        默认情况下，使用动态查找调用该方法，特别是The Java™ Language Specification的第15.12.4.4节所述， 将基于此ObjectReference镜像的对象的运行时类型进行覆盖。 可以通过在options参数中指定INVOKE_NONVIRTUAL位标志来更改此行为。 如果设置了此标志，则会调用指定的方法，无论该对象的运行时类型是否被覆盖。 在这种情况下，该方法必须具有在类或接口中的实现。 此选项对于执行方法调用非常有用，例如使用Java编程语言中的super关键字完成的方法调用。

        默认情况下，如果先前被某个事件挂起，或者通过VirtualMachine.suspend()或ThreadReference.suspend()，则在方法被调用的同时恢复目标VM中的所有线程。 这样做是为了防止如果任何线程拥有调用方法需要的监视器，将会发生死锁。 但是请注意，这个隐式恢复与ThreadReference.resume()完全一致 ，因此如果线程的挂起计数大于1，则在调用期间它将保持处于挂起状态，从而仍然可能发生死锁。 默认情况下，当调用完成时，目标VM中的所有线程都将被暂停，而不管调用之前的状态如何。 在调用期间可能会发生断点或其他事件。 这可能会导致如上所述的死锁。 如果从客户端的事件处理程序线程调用invokeMethod，它也可能导致死锁。 在这种情况下，该线程将等待invokeMethod完成，并且不会读取新事件引入的EventSet。 如果这个新的EventSet是SUSPEND_ALL，那么会发生死锁，因为没有人会恢复EventSet。 为避免这种情况，在执行invokeMethod之前，应该禁用所有EventRequests，否则不应该从客户端的事件处理程序线程中完成invokeMethod。

        通过在options参数中指定INVOKE_SINGLE_THREADED位标志可以防止在调用期间恢复其他线程; 然而，没有保护或恢复上述僵局，所以这个选择应该非常小心。 只有指定的线程将被恢复（如上面所有线程所述）。 完成单个线程调用后，调用线程将再次被挂起。 请注意，在调用完成时，单线程调用期间启动的任何线程都不会被挂起。

        如果目标VM在调用期间断开连接（例如，通过VirtualMachine.dispose() ），方法调用将继续。

        参数
        thread - 要调用的线程。
        method - 要调用的方法 。
        arguments - 绑定到调用方法的Value参数的列表。 列表中的值按照它们在方法签名中显示的顺序分配给参数。
        options - 整数位标志选项。
        结果
        一个Value镜像的调用方法的返回值。
        异常
        IllegalArgumentException - 如果方法不是此对象的类的成员，如果参数列表的大小与方法的声明参数的数量不匹配，如果该方法是构造函数或静态初始化程序，或者如果指定了 INVOKE_NONVIRTUAL ，方法是抽象的。
        ClassNotLoadedException - 如果任何参数类型尚未通过适当的类加载器加载。
        IncompatibleThreadStateException - 如果指定的线程未被事件挂起。
        InvocationException - 如果方法调用导致目标VM中的异常。
        InvalidTypeException - 如果参数不符合此要求 - 对象参数必须与参数类型兼容。 这意味着参数类型必须通过封闭类的加载器加载。 原始参数必须是与参数类型兼容的分配，或必须可转换为参数类型而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • disableCollection

        void disableCollection​()
        防止垃圾回收此对象。 默认情况下，JDI返回的所有ObjectReference值都可以在目标VM运行的任何时间收集。 调用此方法可确保不会收集对象。 enableCollection()可以再次允许收集。

        对此方法的调用将被计数。 在重新启用垃圾回收之前，每次调用此方法都需要相应调用enableCollection() 。

        请注意，当目标VM挂起时，不会发生垃圾回收，因为所有线程都被挂起。 暂停期间对变量，字段和数组的典型检查是安全的，没有明确禁用垃圾回收。

        应该谨慎使用此方法，因为它会改变目标VM中垃圾收集的模式，因此可能导致调试器下的应用程序行为与其未调试的行为不同。

        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请 参阅VirtualMachine.canBeModified() 。

      • enableCollection

        void enableCollection​()
        允许垃圾回收此对象。 默认情况下，JDI返回的所有ObjectReference值都可以在目标VM运行的任何时间收集。 仅当以disableCollection()禁用垃圾收集功能时，才需要调用此方法。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请 参阅VirtualMachine.canBeModified() 。

      • isCollected

        boolean isCollected​()
        确定此对象是否已在目标虚拟机中进行垃圾回收。
        结果
        true如果这个ObjectReference已被收集; false否则。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请 访问VirtualMachine.canBeModified() 。

      • uniqueID

        long uniqueID​()
        返回此ObjectReference的唯一标识符。 它保证在来自尚未被处理的同一VM的所有ObjectReferences中是唯一的。 只要此ObjectReference尚未处理，该保证适用。
        结果
        一个长独特的ID

      • waitingThreads

        List<ThreadReference> waitingThreads​()
                              throws IncompatibleThreadStateException
        返回一个列表，其中包含当前正在等待此对象的显示器的每个线程的ThreadReference 。 有关线程被认为正在等待监视器的信息，请参阅ThreadReference.currentContendedMonitor() 。

        并非所有目标虚拟机都支持此操作。 请参阅VirtualMachine＃canGetMonitorInfo以确定是否支持该操作。

        结果
        一个ThreadReference个对象的列表。 如果没有线程正在等待显示器，该列表的长度为零。
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        IncompatibleThreadStateException - 如果任何等待线程未暂停在目标VM中

      • owningThread

        ThreadReference owningThread​()
                      throws IncompatibleThreadStateException
        对于当前拥有该对象的监视器的线程（如果有的话）返回一个ThreadReference 。 有关所有权的定义，请参阅ThreadReference.ownedMonitors() 。

        并非所有目标虚拟机都支持此操作。 请参阅VirtualMachine＃canGetMonitorInfo以确定是否支持该操作。

        结果
        目前拥有该监视器的ThreadReference ，如果它是未知的，则为null。
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        IncompatibleThreadStateException - 如果所有线程没有挂起在目标虚拟机中

      • entryCount

        int entryCount​()
        throws IncompatibleThreadStateException
        返回此对象的显示器由当前拥有的线程输入的次数。 有关所有权的定义，请参阅ThreadReference.ownedMonitors() 。

        并非所有目标虚拟机都支持此操作。 请参阅VirtualMachine＃canGetMonitorInfo以确定是否支持该操作。

        结果
        条目数的整数计数。
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        IncompatibleThreadStateException - 如果拥有的线程没有暂停在目标VM中
        另请参见：
        owningThread()

      • referringObjects

        List<ObjectReference> referringObjects​(long maxReferrers)
        返回直接引用此对象的对象。 只有返回垃圾收集目的可达的对象。 请注意，对象也可以以其他方式引用，例如从堆栈帧中的局部变量或JNI全局引用引用。 此方法不返回此类非对象引用。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetInstanceInfo()确定是否支持该操作。

        参数
        maxReferrers - 返回的引用对象的最大数量。 必须是非负数。 如果为零，则返回所有引用对象。
        结果
        一个ObjectReference对象的列表。 如果没有引用此对象的对象，则返回零长度列表。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetInstanceInfo()
        IllegalArgumentException - 如果maxReferrers小于零。
        从以下版本开始：
        1.6
        另请参见：
        VirtualMachine.instanceCounts(List) ， ReferenceType.instances(long)

      • equals

        boolean equals​(Object obj)
        将指定的Object与此ObjectReference进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 用于比较的参考对象。
        结果
        如果Object是ObjectReference，则为true，如果ObjectReferences属于同一个VM，并且如果在该VM中的镜像对象上应用“==”运算符，则该值为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此ObjectReference的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PathSearchingVirtualMachine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface PathSearchingVirtualMachine

  • All Superinterfaces:
    Mirror ， VirtualMachine

    public interface PathSearchingVirtualMachine
extends VirtualMachine
    通过路径搜索类的虚拟机
    从以下版本开始：
    1.3

    • Field Summary

      • Fields inherited from interface com.sun.jdi.VirtualMachine

        TRACE_ALL, TRACE_EVENTS, TRACE_NONE, TRACE_OBJREFS, TRACE_RECEIVES, TRACE_REFTYPES, TRACE_SENDS

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String baseDirectory​()
      获取用于路径搜索的基本目录。
      List<String> bootClassPath​()
      获取此虚拟机的引导类路径。
      List<String> classPath​()
      获取此虚拟机的类路径。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.VirtualMachine

        allClasses, allModules, allThreads, canAddMethod, canBeModified, canForceEarlyReturn, canGetBytecodes, canGetClassFileVersion, canGetConstantPool, canGetCurrentContendedMonitor, canGetInstanceInfo, canGetMethodReturnValues, canGetModuleInfo, canGetMonitorFrameInfo, canGetMonitorInfo, canGetOwnedMonitorInfo, canGetSourceDebugExtension, canGetSyntheticAttribute, canPopFrames, canRedefineClasses, canRequestMonitorEvents, canRequestVMDeathEvent, canUnrestrictedlyRedefineClasses, canUseInstanceFilters, canUseSourceNameFilters, canWatchFieldAccess, canWatchFieldModification, classesByName, description, dispose, eventQueue, eventRequestManager, exit, getDefaultStratum, instanceCounts, mirrorOf, mirrorOf, mirrorOf, mirrorOf, mirrorOf, mirrorOf, mirrorOf, mirrorOf, mirrorOf, mirrorOfVoid, name, process, redefineClasses, resume, setDebugTraceMode, setDefaultStratum, suspend, topLevelThreadGroups, version

    • 方法详细信息

      • classPath

        List<String> classPath​()
        获取此虚拟机的类路径。
        结果
        List的类路径的组件，每个由一个String表示。

      • bootClassPath

        List<String> bootClassPath​()
        获取此虚拟机的引导类路径。
        结果
        List的引导类路径的组件，每个由一个String表示。

      • baseDirectory

        String baseDirectory​()
        获取用于路径搜索的基本目录。 类路径和引导类路径中的相对目录可以通过此目录名解析。
        结果
        的基本目录。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrimitiveType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface PrimitiveType

  • All Superinterfaces:
    Mirror ， Type
    All Known Subinterfaces:
    BooleanType ， ByteType ， CharType ， DoubleType ， FloatType ， IntegerType ， LongType ， ShortType

    public interface PrimitiveType
extends Type
    与目标VM中的非对象值相关联的类型。 对于所有PrimitiveValue对象，该接口的子接口的实例将从Value.type()返回。
    从以下版本开始：
    1.3
    另请参见：
    PrimitiveValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrimitiveValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface PrimitiveValue

  • All Superinterfaces:
    Mirror ， Value
    All Known Subinterfaces:
    BooleanValue ， ByteValue ， CharValue ， DoubleValue ， FloatValue ， IntegerValue ， LongValue ， ShortValue

    public interface PrimitiveValue
extends Value
    分配给目标VM中的原始类型的字段或变量的值。 每个基元值通过该接口的子接口访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean booleanValue​()
      将此值转换为BooleanValue，并将结果作为布尔值返回。
      byte byteValue​()
      将此值转换为ByteValue，并将结果作为字节返回。
      char charValue​()
      将此值转换为CharValue，并将结果作为char返回。
      double doubleValue​()
      将此值转换为DoubleValue，并将结果作为double返回。
      float floatValue​()
      将此值转换为FloatValue，并将结果作为浮点数返回。
      int intValue​()
      将此值转换为IntegerValue，并将结果作为int返回。
      long longValue​()
      将此值转换为LongValue，并将结果返回为长。
      short shortValue​()
      将此值转换为ShortValue，并将结果作为简写返回。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • booleanValue

        boolean booleanValue​()
        将此值转换为BooleanValue，并将结果作为布尔值返回。
        结果
        true如果这个值是非零（或true如果已经是一个BooleanValue）; 否则为假。

      • byteValue

        byte byteValue​()
        将此值转换为ByteValue，并将结果作为字节返回。 该值将根据需要变窄，并且幅度或精度信息可能会丢失（就好像原始图像已被转换为一个字节）。
        结果
        该值转换为字节

      • charValue

        char charValue​()
        将此值转换为CharValue，并将结果作为char返回。 价值将根据需要缩小或扩大，大小或精确度信息可能会丢失（就像原始图案在狭窄的情况下被转换为字符）。
        结果
        该值转换为char

      • shortValue

        short shortValue​()
        将此值转换为ShortValue，并将结果作为简写返回。 价值将根据需要缩小或扩大，大小或精确度信息可能会丢失（如果原始图则在狭窄的情况下被简化）。
        结果
        价值，转换为短

      • intValue

        int intValue​()
        将此值转换为IntegerValue，并将结果作为int返回。 价值将根据需要变窄或扩大，并且大小或精确度信息可能会丢失（就像原始数据在狭义情况下被转换为int）。
        结果
        该值转换为int

      • longValue

        long longValue​()
        将此值转换为LongValue，并将结果返回为长。 价值将根据需要缩小或扩大，并且大小或精确度的信息可能会丢失（就像原始图像在狭窄的情况下已经投入了很长时间）。
        结果
        价值，转换为长

      • floatValue

        float floatValue​()
        将此值转换为FloatValue，并将结果作为浮点数返回。 价值将根据需要缩小或扩大，大小或精确度的信息可能会丢失（就像原始图案在狭窄的情况下被转换为浮动）。
        结果
        该值转换为float

      • doubleValue

        double doubleValue​()
        将此值转换为DoubleValue，并将结果作为double返回。 该值将根据需要扩大，精度信息可能会丢失。
        结果
        该值转换为双倍
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReferenceType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ReferenceType

  • All Superinterfaces:
    Accessible ， Comparable<ReferenceType> ， Mirror ， Type
    All Known Subinterfaces:
    ArrayType ， ClassType ， InterfaceType

    public interface ReferenceType
extends Type, Comparable<ReferenceType>, Accessible
    目标虚拟机中对象的类型。 ReferenceType包含The Java™ Language Specification中定义的类，接口和数组类型。 所有ReferenceType对象都属于以下子接口之一： ClassType用于类， InterfaceType用于接口， ArrayType用于阵列。 请注意，原始类（例如Integer.TYPE的reflected type ）被表示为ClassType。 VM为所有三个创建Class对象，因此从VM的角度来看，每个ReferenceType映射到一个不同的Class对象。

    可以通过查询特定的ObjectReference的类型或通过从VirtualMachine获取所有引用类型的列表来获取引用类型。

    ReferenceType提供对静态类型信息（如方法和字段）的访问，并提供对动态类型信息的访问，例如对应的Class对象和类加载器。

    ReferenceType直接或间接采用ReferenceType作为参数的方法可能会导致VMDisconnectedException，如果目标VM断开，并且VMDisconnectEvent已经或可用于从EventQueue中读取。

    ReferenceType任何直接或间接采用ReferenceType作为参数的方法可能会导致VMOutOfMemoryException（如果目标虚拟机已经用完）。

    ReferenceType或直接或间接采用ReferenceType作为参数的方法可能会抛出ObjectCollectedException（如果镜像类型已卸载）。

    从以下版本开始：
    1.3
    另请参见：
    ObjectReference ， ObjectReference.referenceType() ， VirtualMachine ， VirtualMachine.allClasses()

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      List<Field> allFields​()
      返回包含此类型中声明的每个Field及其超类，已实现的接口和/或超级接口的列表。
      List<Location> allLineLocations​()
      在此引用类型中为每个可执行源行返回一个包含Location对象的列表。
      List<Location> allLineLocations​(String stratum, String sourceName)
      返回包含一个列表Location对该引用类型的每个可执行源极线对象。
      List<方法> allMethods​()
      返回包含此类型中声明的每个方法及其超类，实现的接口和/或超级接口的列表。
      List<String> availableStrata​()
      返回此参考类型的可用层。
      ClassLoaderReference classLoader​()
      获取加载与此类型相对应的类的类加载器对象。
      ClassObjectReference classObject​()
      返回与目标VM中此类型对应的类对象。
      byte[] constantPool​()
      以Java虚拟机规范中的类文件格式的constant_pool项的格式返回常量池的原始字节。
      int constantPoolCount​()
      返回常量池中的条目数加上一个。
      String defaultStratum​()
      返回此引用类型的默认层次。
      boolean equals​(Object obj)
      将指定的Object与此ReferenceType进行比较以获得相等性。
      boolean failedToInitialize​()
      确定此类的初始化失败。
      Field fieldByName​(String fieldName)
      使用给定的非歧义名称查找可见的Field 。
      List<Field> fields​()
      返回包含此类型中声明的每个Field的列表。
      String genericSignature​()
      获取此类型的通用签名（如果有）。
      Value getValue​(Field field)
      获取Value给定的静态Field这种类型。
      Map<Field,Value> getValues​(List<? extends Field> fields)
      返回包含给定列表中每个静态Field的Value的映射。
      int hashCode​()
      返回此ObjectReference的哈希码值。
      List<ObjectReference> instances​(long maxInstances)
      返回此ReferenceType的实例。
      boolean isAbstract​()
      确定此类型是否被声明为抽象。
      boolean isFinal​()
      确定此类型是否被声明为final。
      boolean isInitialized​()
      确定此类型是否已初始化。
      boolean isPrepared​()
      确定此类型是否已准备好。
      boolean isStatic​()
      确定此类型是否声明为静态。
      boolean isVerified​()
      确定此类型是否已被验证。
      List<Location> locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      int majorVersion​()
      返回类主要版本号，如Java虚拟机规范的类文件格式所定义。
      List<方法> methods​()
      返回一个列表，其中包含直接在此类型中声明的每个方法 。
      List<方法> methodsByName​(String name)
      返回一个列表，其中包含具有给定名称的每个可见的方法 。
      List<方法> methodsByName​(String name, String signature)
      返回包含具有给定名称和签名的每个可见的方法的列表。
      int minorVersion​()
      返回类的次要版本号，如Java虚拟机规范的类文件格式所定义。
      default ModuleReference module​()
      获取包含与此类型对应的类的模块对象。
      String name​()
      获取此类型的完全限定名称。
      List<ReferenceType> nestedTypes​()
      返回一个包含ReferenceType对象的列表， 该对象在此类型中声明并且当前加载到虚拟机中。
      String sourceDebugExtension​()
      获取此类型的源调试扩展。
      String sourceName​()
      获取与此类型的声明相对应的源的识别名称。
      List<String> sourceNames​(String stratum)
      获取与此类型的声明对应的所有源的识别名称。
      List<String> sourcePaths​(String stratum)
      获取与此类型的声明对应的源的路径。
      List<Field> visibleFields​()
      返回一个列表，其中包含这种类型的每个未隐藏和明确的Field 。
      List<方法> visibleMethods​()
      返回包含此类型声明或继承的每个方法的列表。

      • Methods inherited from interface com.sun.jdi.Accessible

        isPackagePrivate, isPrivate, isProtected, isPublic, modifiers

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        signature

    • 方法详细信息

      • name

        String name​()
        获取此类型的完全限定名称。 返回的名称格式可能会在此类型的对象的Java编程语句声明中显示。

        对于原始类，返回的名称是相应原语类型的名称; 例如，返回“int”作为由Integer.TYPE表示的类的名称。

        Specified by:
        name在接口 Type
        结果
        一个包含类型名称的字符串。

      • genericSignature

        String genericSignature​()
        获取此类型的通用签名（如果有）。 通用签名描述在The Java™ Virtual Machine Specification中 。
        结果
        一个包含通用签名的字符串，如果没有通用签名， null 。
        从以下版本开始：
        1.5

      • classLoader

        ClassLoaderReference classLoader​()
        获取加载与此类型相对应的类的类加载器对象。
        结果
        一个ClassLoaderReference镜像类加载器，如果类是通过引导类加载器加载的， null 。

      • module

        default ModuleReference module​()
        获取包含与此类型对应的类的模块对象。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetModuleInfo()来确定是否支持该操作。
        实现要求：
        默认实现会抛出 UnsupportedOperationException 。
        结果
        一个ModuleReference镜像目标VM中的模块。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        从以下版本开始：
        9

      • sourceName

        String sourceName​()
           throws AbsentInformationException
        获取与此类型的声明相对应的源的识别名称。 该字符串的解释是源存储库机制的责任。

        返回的名称取决于虚拟机的默认层次（ VirtualMachine.getDefaultStratum() ）。 在参考实现中，当使用基础层时，返回的字符串是包含此类型声明的源文件的不合格名称。 在其他层中，返回的源名称是该层的第一个源名称。 由于其他语言的参考类型可能有多个源名称，因此优选使用Location.sourceName()或sourceNames(String) 。

        对于数组（ ArrayType ）和原始类，总是抛出AbsentInformationException。

        结果
        字符串源文件名
        异常
        AbsentInformationException - 如果源名称不知道

      • sourceNames

        List<String> sourceNames​(String stratum)
                  throws AbsentInformationException
        获取与此类型的声明对应的所有源的识别名称。 这些名称的解释是源存储库机制的责任。

        返回的名称用于指定的层次（有关层的描述，请参阅Location ）。 在参考实现中，当使用Java编程语言层次时，返回的List包含一个元素：一个字符串，它是包含此类型声明的源文件的不合格名称。 在其他层中，返回的源名称都是为该层定义的源名称。

        参数
        stratum - 为声明类型的默认层次检索信息的层或 null 。
        结果
        每个表示源名称的字符串对象的列表
        异常
        AbsentInformationException - 如果源名称不知道。

        对于数组（ ArrayType ）和原始类，总是抛出AbsentInformationException。

        从以下版本开始：
        1.4

      • sourcePaths

        List<String> sourcePaths​(String stratum)
                  throws AbsentInformationException
        获取与此类型的声明对应的源的路径。 这些路径的解释是源存储库机制的责任。

        返回的路径用于指定的层（有关层的描述，请参阅Location ）。 在参考实现中，对于没有明确指定源路径（Java编程语言stratum永远不会）的层，返回的字符串是以此ReferenceType的包名称转换为平台相关路径的sourceNames(String) 。 例如，在Windows平台上， java.lang.Thread将返回一个包含一个元素的列表： "java\lang\Thread.java" 。

        参数
        stratum - 为声明类型的默认层次检索信息的层或 null 。
        结果
        每个表示源路径的字符串对象的列表
        异常
        AbsentInformationException - 如果源名称不知道。

        对于数组（ ArrayType ）和原始类，总是抛出AbsentInformationException。

        从以下版本开始：
        1.4

      • sourceDebugExtension

        String sourceDebugExtension​()
                     throws AbsentInformationException
        获取此类型的源调试扩展。

        并非所有目标虚拟机都支持此操作。 使用canGetSourceDebugExtension()来确定是否支持该操作。

        结果
        作为字符串源调试扩展属性
        异常
        AbsentInformationException - 如果未指定扩展名
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetSourceDebugExtension() ，

      • isStatic

        boolean isStatic​()
        确定此类型是否声明为静态。 只有嵌套类型可以声明为静态，因此对于任何包级别类型，数组类型或原始类， false返回false 。
        结果
        true如果这种类型是静态的; 否则为假。

      • isAbstract

        boolean isAbstract​()
        确定此类型是否被声明为抽象。

        对于数组（ ArrayType ）和原始类，返回值未定义。

        结果
        true如果这个类型是抽象的; 否则为假。

      • isFinal

        boolean isFinal​()
        确定此类型是否被声明为final。

        对于数组（ ArrayType ）和原始类，返回值始终为真。

        结果
        true如果这种类型是最终的; 否则为假。

      • isPrepared

        boolean isPrepared​()
        确定此类型是否已准备好。 有关类准备的定义，请参阅JVM规范。

        对于数组（ ArrayType ）和原始类，返回值未定义。

        结果
        true如果这种类型是准备的; 否则为假。

      • isVerified

        boolean isVerified​()
        确定此类型是否已被验证。 有关类验证的定义，请参阅JVM规范。

        对于数组（ ArrayType ）和原始类，返回值未定义。

        结果
        true如果这种类型被验证; 否则为假。

      • isInitialized

        boolean isInitialized​()
        确定此类型是否已初始化。 有关类验证的定义，请参阅JVM规范。 对于InterfaceType ，此方法总是返回与isPrepared()相同的值。

        对于数组（ ArrayType ）和原始类，返回值未定义。

        结果
        true如果此类型已初始化; 否则为假。

      • failedToInitialize

        boolean failedToInitialize​()
        确定此类的初始化失败。 有关类初始化的详细信息，请参阅JVM规范。

        对于数组（ ArrayType ）和原始类，返回值未定义。

        结果
        true如果尝试初始化并失败; 否则为假。

      • fields

        List<Field> fields​()
        返回包含此类型中声明的每个Field的列表。 不包括继承的字段。 编译器创建的任何合成字段都包含在列表中。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        结果
        一个列表Field对象; 如果没有字段存在，该列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • visibleFields

        List<Field> visibleFields​()
        返回一个列表，其中包含这种类型的每个未隐藏和明确的Field 。 包括可以从类或其实例以其简单名称访问的每个字段。 在最近继承的类中，具有相似名称的字段隐藏的字段被继承的字段或隐藏的字段不能被其简单的名称访问，并且不会包含在返回的列表中。 包括所有其他继承的字段。 有关详细信息，请参见JLS第8.3节。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        结果
        一个Field个对象的列表; 如果没有可见字段存在，该列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • allFields

        List<Field> allFields​()
        返回包含此类型中声明的每个Field及其超类，已实现的接口和/或超级接口的列表。 包括所有已声明和继承的字段，无论它们是否被隐藏或乘法继承。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        结果
        一个Field个对象的列表; 如果没有字段存在，该列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • fieldByName

        Field fieldByName​(String fieldName)
        使用给定的非歧义名称查找可见的Field 。 该方法遵循JLS（8.3.3）中指定的继承规则，以确定可见性。

        对于数组（ ArrayType ）和原始类，返回的值始终为空。

        参数
        fieldName - 一个包含所需字段名称的字符串。
        结果
        一个Field对象，它反映找到的字段，如果没有给定名称的字段或者给定的名称是不明确的，则为null。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • methods

        List<方法> methods​()
        返回一个列表，其中包含直接在此类型中声明的每个方法 。 不包括继承的方法。 构造函数，初始化方法（如果有的话）以及由编译器创建的任何合成方法都包含在列表中。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        结果
        一个列表方法个对象; 如果没有方法，列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • visibleMethods

        List<方法> visibleMethods​()
        返回包含此类型声明或继承的每个方法的列表。 不包括已被隐藏或覆盖的超类或超级界面的方法。

        请注意，尽管有这种排除，具有相同签名的多个继承方法可以存在于返回的列表中，但最多可以是ClassType的成员。 有关详细信息，请参见JLS第8.4.6节。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        结果
        一个方法个对象的列表; 如果不存在可见方法，列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个班还没准备好

      • allMethods

        List<方法> allMethods​()
        返回包含此类型中声明的每个方法及其超类，实现的接口和/或超级接口的列表。 包括所有声明和继承的方法，无论它们是隐藏还是被覆盖。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        结果
        一个方法个对象的列表; 如果没有方法，列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • methodsByName

        List<方法> methodsByName​(String name)
        返回一个列表，其中包含具有给定名称的每个可见的方法 。 这是最常用来查找重载的方法。

        不包括重写和隐藏的方法。 详见JLS（8.4.6）。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        参数
        name - 要查找的方法的名称。
        结果
        与给定名称匹配的方法对象的列表; 如果找不到匹配的方法，列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • methodsByName

        List<方法> methodsByName​(String name,
                           String signature)
        返回一个列表，其中包含具有给定名称和签名的每个可见的方法 。 签名字符串是目标方法的JNI签名：
        • ()V
        • ([Ljava/lang/String;)V
        • (IIII)Z
        该方法遵循JLS（8.4.6）中指定的继承规则，以确定可见性。

        列表中最多只有一个方法是具体的方法和组件ClassType ; 列表中的其他任何方法都是抽象的。 使用ClassType.concreteMethodByName(java.lang.String, java.lang.String)仅检索匹配的具体方法。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        参数
        name - 要查找的方法的名称。
        signature - 方法的签名查找
        结果
        符合给定名称和签名的方法对象的列表; 如果找不到匹配的方法，列表的长度为0。
        异常
        ClassNotPreparedException - 如果这个课程尚未准备好

      • nestedTypes

        List<ReferenceType> nestedTypes​()
        返回一个包含ReferenceType在此类型中声明并且当前加载到虚拟机中的对象的列表。 包括静态嵌套类型和非静态嵌套类型（即内部类型）。 本地内部类型（在此引用类型的某个代码块中声明）也包含在返回的列表中。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。

        结果
        嵌套ReferenceType对象列表; 如果没有嵌套类型，列表的长度为0。

      • getValue

        Value getValue​(Field field)
        获取Value给定的静态Field这种类型。 该字段必须对此类型有效; 也就是说，它必须在此类型中声明，超类，超级接口或已实现的接口。
        参数
        field - 包含请求值的字段
        结果
        实例字段的Value 。
        异常
        IllegalArgumentException - 如果该字段对该对象的类无效。

      • getValues

        Map<Field,Value> getValues​(List<? extends Field> fields)
        返回包含给定列表中每个静态Field的Value的地图。 字段必须对此类型有效; 也就是说，它们必须被声明为这种类型，超类，超级接口或已实现的接口。
        参数
        fields - 包含请求值的Field对象的列表。
        结果
        一个请求的Field对象与他们的Value的地图 。
        异常
        IllegalArgumentException - 如果任何字段对此对象的类无效。
        VMMismatchException - 如果一个Mirror参数和这个镜像不属于同一个VirtualMachine 。

      • classObject

        ClassObjectReference classObject​()
        返回与目标VM中此类型对应的类对象。 VM为每种类型的ReferenceType创建类对象：类，接口和数组类型。
        结果
        目标VM中的此引用类型的ClassObjectReference 。

      • allLineLocations

        List<Location> allLineLocations​()
                         throws AbsentInformationException
        返回包含一个列表Location对该引用类型的每个可执行源极线对象。

        此方法相当于allLineLocations(vm.getDefaultStratum(),null) - 有关详细信息，请参阅allLineLocations(String,String) 。

        异常
        AbsentInformationException - 如果 AbsentInformationException没有行号信息，并且此类的非本机非抽象可执行成员。
        ClassNotPreparedException - 如果这个课程尚未准备好

      • allLineLocations

        List<Location> allLineLocations​(String stratum,
                                String sourceName)
                         throws AbsentInformationException
        在此引用类型中，为每个可执行源行返回一个包含Location对象的列表。 每个位置将源行映射到一系列代码索引。 范围的开始可以通过Location.codeIndex()确定。 如果编译器和/或VM将该行映射到两个或更多个不相交的代码索引范围，则返回的列表可能包含特定行号的多个位置。 请注意，相同的源代码行可以用不同的方法表示不同的代码索引范围。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。 对于接口（ InterfaceType ），只有在接口具有类初始化中的可执行代码时，返回的列表将不为空。

        返回的列表是指定的层次 （有关层的描述，请参阅Location ）。

        参数
        stratum -该层来检索或信息 null为 defaultStratum() 。
        sourceName - 仅在此源文件或 null中返回位置以返回位置。
        结果
        所有源代码列表Location对象。
        异常
        AbsentInformationException - 如果AbsentInformationException没有行号信息，并且此类的非本机非抽象可执行成员。 或者，如果SOURCENAME是非null和源名信息不存在。
        ClassNotPreparedException - 如果这个班还没准备好
        从以下版本开始：
        1.4

      • locationsOfLine

        List<Location> locationsOfLine​(int lineNumber)
                        throws AbsentInformationException
        返回包含映射到给定行号的所有Location对象的列表。

        此方法相当于locationsOfLine(vm.getDefaultStratum(), null, lineNumber) - 有关详细信息，请参阅locationsOfLine(java.lang.String,java.lang.String,int) 。

        参数
        lineNumber - 行号
        结果
        一个映射到给定行的所有Location对象的列表。
        异常
        AbsentInformationException - 如果这个类没有行号信息。
        ClassNotPreparedException - 如果这个课程尚未准备好
        另请参见：
        VirtualMachine.getDefaultStratum()

      • locationsOfLine

        List<Location> locationsOfLine​(String stratum,
                               String sourceName,
                               int lineNumber)
                        throws AbsentInformationException
        返回包含映射到给定行号的所有Location对象的列表。

        对于数组（ ArrayType ）和原始类，返回的列表始终为空。 对于接口（ InterfaceType ），返回的列表将不会为空，只有当接口在其类初始化中具有指定行号的可执行代码时才会生效 。 如果指定的行号没有可执行代码，将返回一个空列表。

        返回的列表是指定的层次 （有关层的描述，请参阅Location ）。

        参数
        stratum - 用于比较行号和源名称的层次，或 null使用 defaultStratum() 。
        sourceName - 包含行号的源名称，或匹配所有源名称的 null
        lineNumber - 行号
        结果
        一个映射到给定行的所有Location对象的列表。
        异常
        AbsentInformationException - 如果AbsentInformationException没有行号信息。 或者，如果SOURCENAME是非null和源名信息不存在。
        ClassNotPreparedException - 如果这个课程尚未准备好
        从以下版本开始：
        1.4

      • availableStrata

        List<String> availableStrata​()
        返回此参考类型的可用层。

        有关层的描述，请参阅Location 。

        结果
        java.lang.String列表，每个代表一个层次
        从以下版本开始：
        1.4

      • defaultStratum

        String defaultStratum​()
        返回此引用类型的默认层次。 该值在类文件中指定，不能由用户设置。 如果类文件未指定默认层次，则返回基层（ "Java" ）。

        有关层的描述，请参阅Location 。

        从以下版本开始：
        1.4

      • instances

        List<ObjectReference> instances​(long maxInstances)
        返回此ReferenceType的实例。 仅返回为垃圾回收目的可达到的实例。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetInstanceInfo()确定是否支持该操作。

        参数
        maxInstances - 要返回的最大实例数。 必须是非负数。 如果为0，则返回所有实例。
        结果
        一个ObjectReference对象的列表。 如果没有此ReferenceType的实例，则返回零长度列表。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetInstanceInfo()
        IllegalArgumentException - 如果maxInstances小于零。
        从以下版本开始：
        1.6
        另请参见：
        VirtualMachine.instanceCounts(List) ， ObjectReference.referringObjects(long)

      • equals

        boolean equals​(Object obj)
        将指定的Object与此ReferenceType进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果对象是ReferenceType ，如果ReferenceTypes属于同一VM，并且它们镜像对应于该VM中的java.lang.Class的相同实例的类，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此ObjectReference的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • majorVersion

        int majorVersion​()
        返回类主要版本号，如Java虚拟机规范的类文件格式所定义。 对于数组（ ArrayType ）和原始类，返回的主版本号为零。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetClassFileVersion()来确定是否支持该操作。
        结果
        班级的主要版本号。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetClassFileVersion()
        从以下版本开始：
        1.6

      • minorVersion

        int minorVersion​()
        返回类的次要版本号，如Java虚拟机规范的类文件格式所定义。 对于数组（ ArrayType ）和原始类，返回的次版本号值为零。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetClassFileVersion()来确定是否支持该操作。
        结果
        课程的小版本号。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetClassFileVersion()
        从以下版本开始：
        1.6

      • constantPoolCount

        int constantPoolCount​()
        返回常量池中的条目数加上一个。 这对应于Java虚拟机规范中的类文件格式的constant_pool_count项。 对于数组（ ArrayType ）和原始类，返回的常量池计数值为零。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetConstantPool()确定是否支持该操作。
        结果
        一个类的常量池条目的总数加一个。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetConstantPool()
        从以下版本开始：
        1.6
        另请参见：
        constantPool()

      • constantPool

        byte[] constantPool​()
        以Java虚拟机规范中的类文件格式的constant_pool项的格式返回常量池的原始字节。 恒定池的格式可能因“文件格式”的版本而有所不同，因此，应检查次要和主要版本号是否兼容。 对于数组（ ArrayType ）和原始类，返回零长度字节数组。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetConstantPool()确定是否支持该操作。
        结果
        常量池的原始字节。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetConstantPool()
        从以下版本开始：
        1.6
        另请参见：
        constantPoolCount()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ShortType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ShortType

  • All Superinterfaces:
    Mirror ， PrimitiveType ， Type

    public interface ShortType
extends PrimitiveType
    在目标虚拟机中访问的所有原始short类型short 。 调用Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    LongValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ShortValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ShortValue

  • All Superinterfaces:
    Comparable<ShortValue> ， Mirror ， PrimitiveValue ， Value

    public interface ShortValue
extends PrimitiveValue, Comparable<ShortValue>
    提供对目标VM short语 short值的访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此ShortValue进行比较以获得相等性。
      int hashCode​()
      返回此ShortValue的哈希码值。
      short value​()
      返回此ShortValue作为一个短。

      • Methods inherited from interface java.lang.Comparable

        compareTo

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.PrimitiveValue

        booleanValue, byteValue, charValue, doubleValue, floatValue, intValue, longValue, shortValue

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        short value​()
        返回此ShortValue作为一个短。
        结果
        这个对象镜像的 short 。

      • equals

        boolean equals​(Object obj)
        将指定的Object与此ShortValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是ShortValue，并且如果将“==”应用于两个镜像的原语，则该值将为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此ShortValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        整数哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StackFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface StackFrame

  • All Superinterfaces:
    Locatable ， Mirror

    public interface StackFrame
extends Mirror, Locatable
    线程调用堆栈上的一种方法调用的状态。 当一个线程执行时，堆栈帧被调用堆栈的方式被推送并弹出，因为方法被调用然后返回。 StackFrame在其线程的执行中的某个时刻从目标VM镜像一个这样的帧。 那么调用堆栈就是一个StackFrame对象列表。 只要通过调用ThreadReference.frames()暂停线程，就可以获得调用堆栈

    StackFrames提供对方法局部变量及其当前值的访问。

    StackFrame的使用寿命非常有限。 它仅适用于挂起的线程，一旦线程被恢复，它就变得无效。

    StackFrame以StackFrame作为参数的任何方法可能会导致VMDisconnectedException如果目标VM断开，并且VMDisconnectEvent已经或可用于从EventQueue读取。

    如果目标虚拟机内存StackFrame ，则StackFrame作为参数的方法可能会抛出VMOutOfMemoryException 。

    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<Value> getArgumentValues​()
      返回此框架中所有参数的值。
      Value getValue​(LocalVariable variable)
      获取此框架中的LocalVariable的Value 。
      Map<LocalVariable,Value> getValues​(List<? extends LocalVariable> variables)
      返回此框架中多个局部变量的值。
      Location location​()
      返回帧中当前指令的Location 。
      void setValue​(LocalVariable variable, Value value)
      在这个框架中设置LocalVariable的Value 。
      ObjectReference thisObject​()
      返回当前帧的“this”值。
      ThreadReference thread​()
      返回运行此框架的方法的线程。
      LocalVariable visibleVariableByName​(String name)
      找到匹配给定名称的LocalVariable ，并在当前帧位置可见。
      List<LocalVariable> visibleVariables​()
      返回一个包含可以从此框架的位置访问的每个LocalVariable的列表。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • location

        Location location​()
        返回帧中当前指令的Location 。 创建此框架的方法也可以通过返回的位置进行访问。 对于堆栈中的顶部框架，此位置标识要执行的下一条指令。 对于所有其他帧，此位置标识导致下一帧的方法被调用的指令。 如果框架表示本地方法调用，则返回的位置指示类和方法，但代码索引将不会有效（-1）。
        Specified by:
        location在接口 Locatable
        结果
        目前的指令为Location 。
        异常
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。

      • thread

        ThreadReference thread​()
        返回运行此框架的方法的线程。
        结果
        一个ThreadReference镜像框架的线程。
        异常
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。

      • thisObject

        ObjectReference thisObject​()
        返回当前帧的“this”值。 “this”的ObjectReference仅适用于非本地实例方法。
        结果
        一个ObjectReference ，如果框架表示一个本机或静态方法，则返回null。
        异常
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。

      • visibleVariables

        List<LocalVariable> visibleVariables​()
                              throws AbsentInformationException
        返回一个列表，其中包含可以从此框架的位置访问的每个LocalVariable 。

        可见性基于此StackFrame的当前指令的代码索引。 每个变量都具有可访问的字节码索引的范围。 如果此堆栈框架的方法与此变量的方法匹配，并且如果此StackFrame的代码索引在变量的字节代码范围内，则该变量是可见的。

        变量的字节代码范围至少与该变量的范围一样大，但在特定情况下可以继续超出范围的结尾：

        • 编译器/ VM不会立即重用变量的插槽。
        • 实现编译器/ VM报告上述项目产生的扩展范围。
        扩展范围的优点是最近退出的范围的变量可能仍然可用于检查（这对循环索引尤其有用）。 如果作为上述扩展的结果，当前帧位置包含在同名的多个局部变量的范围内，则为返回的列表选择具有最高起始范围的变量。
        结果
        目前可见的LocalVariable个对象的列表; 如果没有可见变量，列表将为空; 具体来说，本机方法中的帧将始终返回零长度列表。
        异常
        AbsentInformationException - 如果此方法没有本地变量信息。
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。
        NativeMethodException - 如果当前方法是本机的。

      • visibleVariableByName

        LocalVariable visibleVariableByName​(String name)
                             throws AbsentInformationException
        找到匹配给定名称的LocalVariable ，并在当前帧位置可见。 详情请见visibleVariables() 。
        参数
        name - 要查找的变量名
        结果
        匹配LocalVariable ，如果没有给定名称的可见变量，则为null; 本机方法中的帧始终返回null。
        异常
        AbsentInformationException - 如果此方法没有本地变量信息。
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。
        NativeMethodException - 如果当前方法是本机的。

      • getValue

        Value getValue​(LocalVariable variable)
        获取此框架中的LocalVariable的Value 。 该变量必须对此框架的方法有效，并且根据visibleVariables()中描述的规则可见。
        参数
        variable - 要访问的LocalVariable
        结果
        实例字段的Value 。
        异常
        IllegalArgumentException - 如果变量对此框架的方法无效或不可见。
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。

      • getValues

        Map<LocalVariable,Value> getValues​(List<? extends LocalVariable> variables)
        返回此框架中多个局部变量的值。 每个变量必须对此框架的方法有效，并且根据visibleVariables()中描述的规则可见。
        参数
        variables - 要访问的LocalVariable对象的列表
        结果
        每个LocalVariable与其Value关联的地图
        异常
        IllegalArgumentException - 如果任何变量对此框架的方法无效或不可见。
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。

      • setValue

        void setValue​(LocalVariable variable,
              Value value)
       throws InvalidTypeException,
              ClassNotLoadedException
        在这个框架中设置LocalVariable的Value 。 该变量必须对该框架的方法有效，并且根据visibleVariables()中描述的规则可见。

        对象值必须与变量类型分配兼容（这意味着变量类型必须通过封闭类的加载器加载）。 原始值必须是与变量类型兼容的分配，或必须可转换为变量类型而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。

        参数
        variable - 包含请求值的字段
        value - 要分配的新值
        异常
        IllegalArgumentException - 如果该字段对此对象的类无效。
        InvalidTypeException - 如果值的类型与变量的类型不匹配。
        ClassNotLoadedException - 如果变量类型尚未通过适当的类加载器加载。
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • getArgumentValues

        List<Value> getArgumentValues​()
        返回此框架中所有参数的值。 即使没有局部变量信息，也返回值。
        结果
        一个列表，其中包含一个Value对象，用于该框架的每个参数，按声明的参数顺序。 如果与此框架相对应的方法没有参数，则返回空列表。
        异常
        InvalidStackFrameException - 如果此堆栈帧已经无效。 一旦框架的线程恢复，堆栈框架将不再有效。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface StringReference

  • All Superinterfaces:
    Mirror ， ObjectReference ， Value

    public interface StringReference
extends ObjectReference
    来自目标VM的字符串对象。 StringReference是一个ObjectReference，具有来自目标VM的字符串特定信息的附加访问权限。
    从以下版本开始：
    1.3

    • Field Summary

      • Fields inherited from interface com.sun.jdi.ObjectReference

        INVOKE_NONVIRTUAL, INVOKE_SINGLE_THREADED

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String value​()
      以字符串形式返回StringReference。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ObjectReference

        disableCollection, enableCollection, entryCount, equals, getValue, getValues, hashCode, invokeMethod, isCollected, owningThread, referenceType, referringObjects, setValue, uniqueID, waitingThreads

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • value

        String value​()
        以字符串形式返回StringReference。 返回的字符串与镜像字符串相当，但是客户端VM中的实体可以像任何其他字符串一样被操纵。
        结果
        字符串值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadGroupReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ThreadGroupReference

  • All Superinterfaces:
    Mirror ， ObjectReference ， Value

    public interface ThreadGroupReference
extends ObjectReference
    来自目标VM的线程组对象。 ThreadGroupReference是一个ObjectReference，具有来自目标VM的线程组特定信息的附加访问权限。
    从以下版本开始：
    1.3

    • Field Summary

      • Fields inherited from interface com.sun.jdi.ObjectReference

        INVOKE_NONVIRTUAL, INVOKE_SINGLE_THREADED

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回此线程组的名称。
      ThreadGroupReference parent​()
      返回此线程组的父级。
      void resume​()
      恢复此线程组中的所有线程。
      void suspend​()
      暂停此线程组中的所有线程。
      List<ThreadGroupReference> threadGroups​()
      返回一个包含此线程组中每个活动ThreadGroupReference的列表。
      List<ThreadReference> threads​()
      返回一个列表，该列表包含此线程组中每个活动线程的一个ThreadReference 。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ObjectReference

        disableCollection, enableCollection, entryCount, equals, getValue, getValues, hashCode, invokeMethod, isCollected, owningThread, referenceType, referringObjects, setValue, uniqueID, waitingThreads

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • name

        String name​()
        返回此线程组的名称。
        结果
        该字符串包含线程组名称。

      • parent

        ThreadGroupReference parent​()
        返回此线程组的父级。
        结果
        一个ThreadGroupReference镜像目标VM中此线程组的父级，如果这是顶级线程组，则为null。

      • suspend

        void suspend​()
        暂停此线程组中的所有线程。 该组和其所有子组中的每个线程将按照ThreadReference.suspend()所述进行挂起 。 这不能保证是原子操作; 如果在调用此方法时目标VM不中断，则可能会在线程被枚举的时间和所有已被挂起的时间之间创建新的线程。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • resume

        void resume​()
        恢复此线程组中的所有线程。 该组和其所有子组中的每个线程将按ThreadReference.resume()所述恢复。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • threads

        List<ThreadReference> threads​()
        返回一个列表，该列表包含此线程组中每个线程的一个ThreadReference 。 只返回此直接线程组（而不是其子组）中的实时线程。 如果线程已经启动并且还没有被停止，则线程是活着的。
        结果
        一个ThreadReference对象的列表， 用于从目标VM中的此线程组镜像活动线程。

      • threadGroups

        List<ThreadGroupReference> threadGroups​()
        返回一个包含此线程组中每个活动ThreadGroupReference的列表。 只返回此直接线程组（而不是其子组）中的活动线程组。 有关“活动”ThreadGroups的信息，请参阅ThreadGroup 。
        结果
        一个ThreadGroupReference对象的列表， 用于从目标VM中的此线程组镜像活动线程组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface ThreadReference

  • All Superinterfaces:
    Mirror ， ObjectReference ， Value

    public interface ThreadReference
extends ObjectReference
    来自目标VM的线程对象。 ThreadReference是一个ObjectReference ，可以额外访问来自目标VM的线程特定信息。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int THREAD_STATUS_MONITOR
      线程正在等待一个java监视器
      static int THREAD_STATUS_NOT_STARTED
      线程尚未启动
      static int THREAD_STATUS_RUNNING
      线程是可运行的
      static int THREAD_STATUS_SLEEPING
      线程正在睡眠 - Thread.sleep（）或JVM_Sleep（）被调用
      static int THREAD_STATUS_UNKNOWN
      线程状态未知
      static int THREAD_STATUS_WAIT
      线程正在等待 - Object.wait（）或JVM_MonitorWait（）被调用
      static int THREAD_STATUS_ZOMBIE
      线程已完成执行

      • Fields inherited from interface com.sun.jdi.ObjectReference

        INVOKE_NONVIRTUAL, INVOKE_SINGLE_THREADED

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectReference currentContendedMonitor​()
      返回一个ObjectReference的显示器，如果有的话，这个线程当前正在等待。
      void forceEarlyReturn​(Value value)
      强制一个方法在返回到返回语句之前返回。
      StackFrame frame​(int index)
      返回线程当前调用堆栈中给定索引的StackFrame 。
      int frameCount​()
      返回线程当前调用堆栈中的堆栈帧数。
      List<StackFrame> frames​()
      返回一个列表，其中包含线程当前调用堆栈中的每个StackFrame 。
      List<StackFrame> frames​(int start, int length)
      返回一个列表，该列表包含线程当前调用堆栈的StackFrame镜像范围。
      void interrupt​()
      中断此线程，除非线程已被调试器挂起。
      boolean isAtBreakpoint​()
      确定线程是否在断点处挂起。
      boolean isSuspended​()
      确定线程是否已被调试器挂起。
      String name​()
      返回此线程的名称。
      List<ObjectReference> ownedMonitors​()
      返回列表，该列表包含线程拥有的每个监视器的ObjectReference 。
      List<MonitorInfo> ownedMonitorsAndFrames​()
      返回一个列表，该列表包含线程拥有的每个监视器的一个MonitorInfo对象。
      void popFrames​(StackFrame frame)
      弹出框架。
      void resume​()
      恢复此线程。
      int status​()
      返回线程的状态。
      void stop​(ObjectReference throwable)
      停止此线程与异步异常。
      void suspend​()
      暂停这个线程。
      int suspendCount​()
      返回此线程的待处理挂起数。
      ThreadGroupReference threadGroup​()
      返回此线程的线程组。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.ObjectReference

        disableCollection, enableCollection, entryCount, equals, getValue, getValues, hashCode, invokeMethod, isCollected, owningThread, referenceType, referringObjects, setValue, uniqueID, waitingThreads

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 字段详细信息

      • THREAD_STATUS_UNKNOWN

        static final int THREAD_STATUS_UNKNOWN
        线程状态未知
        另请参见：
        Constant Field Values

      • THREAD_STATUS_ZOMBIE

        static final int THREAD_STATUS_ZOMBIE
        线程已完成执行
        另请参见：
        Constant Field Values

      • THREAD_STATUS_RUNNING

        static final int THREAD_STATUS_RUNNING
        线程是可运行的
        另请参见：
        Constant Field Values

      • THREAD_STATUS_SLEEPING

        static final int THREAD_STATUS_SLEEPING
        线程正在睡眠 - Thread.sleep（）或JVM_Sleep（）被调用
        另请参见：
        Constant Field Values

      • THREAD_STATUS_MONITOR

        static final int THREAD_STATUS_MONITOR
        线程正在等待一个java监视器
        另请参见：
        Constant Field Values

      • THREAD_STATUS_WAIT

        static final int THREAD_STATUS_WAIT
        线程正在等待 - Object.wait（）或JVM_MonitorWait（）被调用
        另请参见：
        Constant Field Values

      • THREAD_STATUS_NOT_STARTED

        static final int THREAD_STATUS_NOT_STARTED
        线程尚未启动
        另请参见：
        Constant Field Values

    • 方法详细信息

      • name

        String name​()
        返回此线程的名称。
        结果
        该字符串包含线程名称。

      • suspend

        void suspend​()
        暂停这个线程。 该线程可以通过恢复resume()或通过与其他线程恢复VirtualMachine.resume() 。

        与Thread.suspend()不同，虚拟机和单个线程的暂停计数。 在线程再次运行之前，它必须恢复（通过resume()或resume() ）它已被挂起的次数。

        使用此方法暂停单线程与Thread.suspend()具有相同的危险。 如果挂起的线程保持另一个正在运行的线程所需的监视器，目标VM中可能会发生死锁（至少直到再次恢复挂起的线程）。

        暂停线程保持暂停，直到通过上述JDI恢复方法恢复; 目标VM中的应用程序无法通过Thread.resume()恢复挂起的线程。

        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • resume

        void resume​()
        恢复此线程。 如果此线程以前未被暂停通过suspend()或通过VirtualMachine.suspend()或由于SUSPEND_ALL或SUSPEND_EVENT_THREAD事件，则调用此方法不起作用。 否则，此线程上的待处理挂起计数减少。 如果它递减到0，线程将继续执行。 注意：从事件相关的暂停恢复的正常方式是通过EventSet.resume() 。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 VirtualMachine.canBeModified() 。

      • suspendCount

        int suspendCount​()
        返回此线程的待处理挂起数。 有关计数暂停的说明，请参阅suspend() 。
        结果
        待处理挂起计数为整数

      • stop

        void stop​(ObjectReference throwable)
   throws InvalidTypeException
        停止此线程与异步异常。 目标VM中的调试器线程将使用给定的Throwable对象停止此线程。
        参数
        throwable - 异步异常抛出。
        异常
        InvalidTypeException - 如果 throwable不是目标VM中的java.lang.Throwable的实例。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 VirtualMachine.canBeModified() 。
        另请参见：
        Thread.stop(Throwable)

      • interrupt

        void interrupt​()
        中断此线程，除非线程已被调试器挂起。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 VirtualMachine.canBeModified() 。
        另请参见：
        Thread.interrupt()

      • status

        int status​()
        返回线程的状态。 如果线程不挂起，则返回线程的当前状态。 如果线程被暂停，则返回线程的挂起状态（如果此信息不可用，则返回THREAD_STATUS_UNKNOWN） isSuspended()可用于确定线程是否已被挂起。
        结果
        一个 THREAD_STATUS_UNKNOWN ， THREAD_STATUS_ZOMBIE ， THREAD_STATUS_RUNNING ， THREAD_STATUS_SLEEPING ， THREAD_STATUS_MONITOR ， THREAD_STATUS_WAIT ， THREAD_STATUS_NOT_STARTED ，

      • isSuspended

        boolean isSuspended​()
        确定线程是否已被调试器挂起。
        结果
        true如果线程当前暂停; 否则为false 。

      • isAtBreakpoint

        boolean isAtBreakpoint​()
        确定线程是否在断点处挂起。
        结果
        true如果线程当前在断点处停止; 否则为false 。

      • threadGroup

        ThreadGroupReference threadGroup​()
        返回此线程的线程组。
        结果
        一个ThreadGroupReference镜像该线程在目标VM中的线程组。

      • frameCount

        int frameCount​()
        throws IncompatibleThreadStateException
        返回线程当前调用堆栈中的堆栈帧数。 线程必须暂停（通常通过VM的中断）来获取此信息，并且只有线程再次恢复为止才有效。
        结果
        一个整数帧计数
        异常
        IncompatibleThreadStateException - 如果线程未暂停在目标VM中

      • frames

        List<StackFrame> frames​()
                 throws IncompatibleThreadStateException
        返回包含线程当前调用堆栈中的每个StackFrame的列表。 线程必须暂停（通常通过VM的中断）来获取此信息，并且只有线程再次恢复为止才有效。
        结果
        一个StackFrame的列表，当前帧首先跟随每个呼叫者的帧。
        异常
        IncompatibleThreadStateException - 如果线程未暂停在目标VM中

      • frame

        StackFrame frame​(int index)
          throws IncompatibleThreadStateException
        返回线程当前调用堆栈中给定索引的StackFrame 。 索引0检索当前帧; 较高的索引检索呼叫者帧。 线程必须暂停（通常通过VM的中断）来获取此信息，并且只有线程再次恢复为止才有效。
        参数
        index - 所需的帧
        结果
        请求StackFrame
        异常
        IncompatibleThreadStateException - 如果线程未暂停在目标VM中
        IndexOutOfBoundsException - 如果索引大于或等于 frameCount()或为负数。

      • frames

        List<StackFrame> frames​(int start,
                        int length)
                 throws IncompatibleThreadStateException
        返回一个列表，该列表包含线程当前调用堆栈的StackFrame镜像范围。 线程必须暂停（通常通过VM的中断）来获取此信息，并且只有线程再次恢复为止才有效。
        参数
        start - 要检索的第一帧的索引。 索引0表示当前帧。
        length - 要检索的帧数
        结果
        一个StackFrame的列表，当前帧首先跟随每个呼叫者的帧。
        异常
        IncompatibleThreadStateException - 如果线程未挂起在目标VM中
        IndexOutOfBoundsException - 如果指定的范围不在堆栈帧指标的范围内。 也就是说，如果满足以下任一条件，则抛出异常：
          start < 0
    start >= frameCount()
    length < 0
    (start+length) > frameCount()

      • ownedMonitors

        List<ObjectReference> ownedMonitors​()
                             throws IncompatibleThreadStateException
        返回一个包含线程拥有的每个监视器的一个ObjectReference的列表。 如果已经输入了监视器（通过同步语句或输入到同步方法），并且没有通过Object.wait(long)放弃监视器 。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetOwnedMonitorInfo()确定是否支持该操作。

        结果
        ObjectReference对象的列表。 如果没有监视器由此线程拥有，列表的长度为零。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        IncompatibleThreadStateException - 如果线程未挂起在目标VM中

      • ownedMonitorsAndFrames

        List<MonitorInfo> ownedMonitorsAndFrames​()
                                  throws IncompatibleThreadStateException
        返回一个包含线程所拥有的每个监视器的一个MonitorInfo对象的列表。 如果已经输入了监视器（通过同步语句或输入到同步方法），并且尚未通过Object.wait(long)放弃监视器 。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetMonitorFrameInfo()确定是否支持该操作。

        结果
        一个MonitorInfo对象的列表。 如果没有监视器由此线程拥有，列表的长度为零。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        IncompatibleThreadStateException - 如果线程未暂停在目标VM中
        从以下版本开始：
        1.6

      • currentContendedMonitor

        ObjectReference currentContendedMonitor​()
                                 throws IncompatibleThreadStateException
        返回一个ObjectReference的监视器，如果有的话，这个线程当前正在等待。 线程可以通过进入同步方法（synchronized语句）或Object.wait(long)等待监视器。 status()方法可用于区分前两种情况和第三种情况。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canGetCurrentContendedMonitor()确定是否支持该操作。

        结果
        对应于竞争监视器的ObjectReference ，如果不等待监视器，则为null。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        IncompatibleThreadStateException - 如果线程未暂停在目标VM中

      • popFrames

        void popFrames​(StackFrame frame)
        throws IncompatibleThreadStateException
        弹出框架。

        直到并包括frame所有帧都从堆栈中弹出。 参数frame之前的帧将成为当前帧。

        此操作后，此线程将暂停在创建frame的目标方法的调用指令中。 frame的方法可以重新进入指导步骤。

        操作数堆栈被还原，但是，在调用方法中发生的参数的任何更改都会保留。 例如，如果方法foo ：

          void foo(int x) {
        System.out.println("Foo: " + x);
        x = 4;
        System.out.println("pop here");
    }
        被称为foo(7)和foo弹出第二个println并恢复，它将打印： Foo: 4 。

        弹出框架获取的锁定在弹出时释放。 这适用于弹出的同步方法，以及其中的任何同步块。

        最后块不执行。

        除此线程的执行点和锁之外，状态的任何方面均受此调用的影响。 具体来说，字段的值不变，外部资源（如I / O流）也不变。 另外，目标程序可能被放置在一般程序流程中是不可能的状态; 例如，锁获取的顺序可能会受到干扰。 因此，目标程序的进行可能与用户期望的不同。

        必须暂停指定的线程。

        此线程的所有StackFrame对象都无效。

        此方法不会生成任何事件。

        通过并包括帧的呼叫者的帧的帧都不是本地的。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canPopFrames()确定是否支持该操作。

        参数
        frame - 堆栈框架弹出。 frame是在这个线程的调用堆栈。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 VirtualMachine.canPopFrames() 。
        IncompatibleThreadStateException - 如果此线程未挂起。
        IllegalArgumentException - 如果 frame不在此线程的调用堆栈上。
        NativeMethodException - 如果要弹出的其中一个 框架是本机方法的框架，或者框架之前的 框架是本机的 框架 。
        InvalidStackFrameException - 如果frame已经无效。 一旦这个线程被恢复，堆栈帧就不再有效了。 如果没有更多帧，也会抛出此异常。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 VirtualMachine.canBeModified() 。
        从以下版本开始：
        1.4

      • forceEarlyReturn

        void forceEarlyReturn​(Value value)
               throws InvalidTypeException,
                      ClassNotLoadedException,
                      IncompatibleThreadStateException
        强制一个方法在返回到返回语句之前返回。

        将早期返回的方法称为被叫方法。 被调用的方法是在调用此方法时指定线程的当前方法（由Java虚拟机规范中的“帧”部分定义）。

        线程必须暂停。 当在此线程上恢复执行Java编程语言代码时，返回。 在调用此方法和恢复线程执行之间，堆栈的状态未定义。

        在被叫方法中不执行进一步的指令。 具体来说，finally块不执行。 注意：这可能导致应用程序中的状态不一致。

        通过调用被叫方法（如果是同步方法）获取的锁和通过在被叫方法内输入同步块获取的锁定被释放。 注意：这不适用于本机锁或java.util.concurrent.locks锁。

        事件（如MethodExit）将按正常返回生成。

        被调用的方法必须是非本地Java编程语言方法。 在堆叠上只有一个框架的强制返回线程会导致线程在恢复时退出。

        value参数是方法返回的值。 如果方法的返回类型为void，则值必须为VoidValue 。 对象值必须与方法返回类型分配兼容（这意味着方法返回类型必须通过封闭类的加载器加载）。 原始值必须与方法返回类型兼容，或必须可转换为变量类型而不会丢失信息。 有关分配兼容性的更多信息，请参阅JLS第5.2节。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canForceEarlyReturn()确定操作是否受支持。

        参数
        value - 方法返回的值。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canForceEarlyReturn()
        IncompatibleThreadStateException - 如果此线程未挂起。
        NativeMethodException - 如果要返回的帧是本机方法的帧。
        InvalidStackFrameException - 如果没有帧。
        InvalidTypeException - 如果值的类型与方法的返回类型不匹配。
        ClassNotLoadedException - 如果方法的返回类型尚未通过适当的类加载器加载。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 VirtualMachine.canBeModified() 。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Type

  • All Superinterfaces:
    Mirror
    All Known Subinterfaces:
    ArrayType ， BooleanType ， ByteType ， CharType ， ClassType ， DoubleType ， FloatType ， IntegerType ， InterfaceType ， LongType ， PrimitiveType ， ReferenceType ， ShortType ， VoidType

    public interface Type
extends Mirror
    目标VM中类型的镜像。 此接口是包含原始类型和引用类型的类型层次结构的根。

    A类型可用于表示运行时类型：

    Value.type()
    或编译时类型：
    Field.type()
    Method.returnType()
    Method.argumentTypes()
    LocalVariable.type()
    ArrayType.componentType()

    下表说明了哪些类型的子接口用于镜像目标VM中的类型 -

    Maps each type declared in target to a mirrored instance of a subinterface of PrimitiveType or ReferenceType" Subinterfaces of PrimitiveType Type declared in target as Is mirrored as an instance of boolean BooleanType byte ByteType char CharType double DoubleType float FloatType int IntegerType long LongType short ShortType void VoidType Subinterfaces of ReferenceType Type declared in target as For example Is mirrored as an instance of a class Date ClassType an interface Runnable InterfaceType an array ArrayType an array int[] ArrayType whose componentType() is IntegerType an array Date[] ArrayType whose componentType() is ClassType an array Runnable[] ArrayType whose componentType() is InterfaceType
    从以下版本开始：
    1.3
    另请参见：
    Subinterface PrimitiveType ， Subinterface ReferenceType ， Value - for relationship between Type and Value ， Field.type() - for usage examples

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      String signature​()
      返回此类型的JNI样式签名。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • signature

        String signature​()
        返回此类型的JNI样式签名。

        对于原始类，返回的签名是相应原语类型的签名; 例如，作为由Integer.TYPE表示的类的签名返回“I”。

        结果
        该字符串包含类型签名。
        另请参见：
        Type Signatures

      • name

        String name​()
        结果
        这种类型的文本表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TypeComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface TypeComponent

  • All Superinterfaces:
    Accessible ， Mirror
    All Known Subinterfaces:
    Field ， 方法

    public interface TypeComponent
extends Mirror, Accessible
    在用户定义的类型（类或接口）内声明的实体。 该接口是类型组件层次结构的根，包括Field和方法 。 键入在不同类中声明的同名的组件（包括与继承有关的组件）具有不同的TypeComponent对象。 TypeComponents可以单独使用来检索有关其声明的静态信息，或者可以与ReferenceType或ObjectReference结合使用以访问值或调用（如适用）。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ReferenceType declaringType​()
      返回声明此组件的类型。
      String genericSignature​()
      获取此类型组件的通用签名（如果有）。
      boolean isFinal​()
      确定此TypeComponent是否为final。
      boolean isStatic​()
      确定此TypeComponent是否为静态。
      boolean isSynthetic​()
      确定此TypeComponent是否合成。
      String name​()
      获取此类型组件的名称。
      String signature​()
      获取此类型组件的JNI样式签名。

      • Methods inherited from interface com.sun.jdi.Accessible

        isPackagePrivate, isPrivate, isProtected, isPublic, modifiers

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • name

        String name​()
        获取此类型组件的名称。

        注意：对于字段，这是字段名称; 对于方法，这是方法名称; 对于构造函数，这是<init>; 对于静态初始化器，这是<clinit>。

        结果
        一个包含该名称的字符串。

      • signature

        String signature​()
        获取此类型组件的JNI样式签名。 签名是JNI文档中定义的编码类型信息。 它是一种方便，紧凑的格式，用于在内部操作类型信息，而不一定显示给最终用户。 请参阅Field.typeName()和Method.returnTypeName()，了解如何帮助获取更易读的类型表示。
        结果
        一个包含签名的字符串
        另请参见：
        Type Signatures

      • genericSignature

        String genericSignature​()
        获取此类型组件的通用签名（如果有）。 通用签名描述在The Java™ Virtual Machine Specification中 。
        结果
        一个包含通用签名的字符串，如果没有通用签名， null 。
        从以下版本开始：
        1.5

      • declaringType

        ReferenceType declaringType​()
        返回声明此组件的类型。 返回的ReferenceType镜像目标VM中的类或接口。
        结果
        一个ReferenceType，用于声明此类型组件的类型。

      • isStatic

        boolean isStatic​()
        确定此TypeComponent是否为静态。 对于构造函数和静态初始化器，返回值是未定义的。
        结果
        true如果此类型组件声明为静态; 否则为假。

      • isFinal

        boolean isFinal​()
        确定此TypeComponent是否为final。 对于构造函数和静态初始化器，返回值是未定义的。
        结果
        true如果此类型组件被声明为final; 否则为假。

      • isSynthetic

        boolean isSynthetic​()
        确定此TypeComponent是否合成。 合成成员由编译器生成，并且不存在于包含类的源代码中。

        并非所有目标虚拟机都支持此查询。 请参阅VirtualMachine.canGetSyntheticAttribute()以确定是否支持该操作。

        结果
        true如果这种类型的组件是合成的; 否则为false 。
        异常
        UnsupportedOperationException - 如果目标VM无法提供有关合成属性的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.jdi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.jdi

  • Packages that use com.sun.jdi
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
  • Classes in com.sun.jdi used by com.sun.jdi
    Class 描述
    AbsentInformationException
    抛出以表示行号或变量信息不可用。
    Accessible
    提供有关类型或类型组件的可访问性的信息。
    ArrayReference
    提供对目标虚拟机中数组对象及其组件的访问。
    BooleanValue
    提供对目标VM boolean语 boolean值的访问。
    ByteValue
    提供对目标虚拟机中原始值 byte值的访问。
    CharValue
    提供对目标虚拟机 char语 char值的访问。
    ClassLoaderReference
    来自目标VM的类加载器对象。
    ClassNotLoadedException
    抛出，表示请求的类尚未通过适当的类加载器加载。
    ClassObjectReference
    来自目标VM的java.lang.Class实例。
    ClassType
    目标VM中的类的镜像。
    DoubleValue
    提供对目标虚拟机中基元 double值的访问。
    Field
    目标VM中的类或实例变量。
    FloatValue
    提供对目标虚拟机 float语 float值的访问。
    IncompatibleThreadStateException
    抛出以指示所请求的操作在指定线程处于当前状态时无法完成。
    IntegerValue
    提供对目标虚拟机 int语 int值的访问。
    InterfaceType
    目标虚拟机中的接口的镜像。
    InvalidTypeException
    抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。
    InvocationException
    抛出以指示目标VM中的调用方法中发生异常。
    LocalVariable
    目标VM中的局部变量。
    Locatable
    一个镜子有一个Location 。
    Location
    目标VM的执行代码中的一个点。
    LongValue
    提供对目标VM long语 long值的访问。
    方法
    目标VM中的静态或实例方法。
    Mirror
    调试器使用的代理来检查或操纵另一个虚拟机中的某个实体。
    ModuleReference
    目标虚拟机中的一个模块。
    MonitorInfo
    有关线程拥有的监视器的信息。
    ObjectReference
    当前存在于目标VM中的对象。
    PrimitiveType
    与目标VM中的非对象值相关联的类型。
    PrimitiveValue
    分配给目标VM中的原始类型的字段或变量的值。
    ReferenceType
    目标虚拟机中对象的类型。
    ShortValue
    提供对目标虚拟机中原始值 short访问。
    StackFrame
    线程调用堆栈上的一种方法调用的状态。
    StringReference
    来自目标VM的字符串对象。
    ThreadGroupReference
    来自目标VM的线程组对象。
    ThreadReference
    来自目标VM的线程对象。
    Type
    目标VM中类型的镜像。
    TypeComponent
    在用户定义的类型（类或接口）内声明的实体。
    Value
    目标VM中的值的镜像。
    VirtualMachine
    用于调试的虚拟机。
    VirtualMachineManager
    目标虚拟机的连接经理。
    VoidValue
    提供对目标VM void语 void值的访问。
  • Classes in com.sun.jdi used by com.sun.jdi.connect
    Class 描述
    VirtualMachine
    用于调试的虚拟机。
  • Classes in com.sun.jdi used by com.sun.jdi.event
    Class 描述
    Field
    目标VM中的类或实例变量。
    Locatable
    一个镜子有一个Location 。
    Location
    目标VM的执行代码中的一个点。
    方法
    目标VM中的静态或实例方法。
    Mirror
    调试器使用的代理来检查或操纵另一个虚拟机中的某个实体。
    ObjectReference
    当前存在于目标VM中的对象。
    ReferenceType
    目标虚拟机中对象的类型。
    ThreadReference
    来自目标VM的线程对象。
    Value
    目标VM中的值的镜像。
  • Classes in com.sun.jdi used by com.sun.jdi.request
    Class 描述
    Field
    目标VM中的类或实例变量。
    Locatable
    一个镜子有一个Location 。
    Location
    目标VM的执行代码中的一个点。
    Mirror
    调试器使用的代理来检查或操纵另一个虚拟机中的某个实体。
    ObjectReference
    当前存在于目标VM中的对象。
    ReferenceType
    目标虚拟机中对象的类型。
    ThreadReference
    来自目标VM的线程对象。
  • Classes in com.sun.jdi used by jdk.jshell.execution
    Class 描述
    ReferenceType
    目标虚拟机中对象的类型。
    VirtualMachine
    用于调试的虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Value (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface Value

  • All Superinterfaces:
    Mirror
    All Known Subinterfaces:
    ArrayReference ， BooleanValue ， ByteValue ， CharValue ， ClassLoaderReference ， ClassObjectReference ， DoubleValue ， FloatValue ， IntegerValue ， LongValue ， ModuleReference ， ObjectReference ， PrimitiveValue ， ShortValue ， StringReference ， ThreadGroupReference ， ThreadReference ， VoidValue

    public interface Value
extends Mirror
    目标VM中的值的镜像。 此接口是包含原始值和对象值的值层次结构的根。

    可以访问值的一些示例：

    layout
    ObjectReference.getValue(Field) | - value of a field
    StackFrame.getValue(LocalVariable) | - value of a variable
    VirtualMachine.mirrorOf(double) | - created in the target VM by the JDI client
    ModificationWatchpointEvent.valueToBe() | - returned with an event

    下表说明了哪些子接口的值用于镜像目标VM中的值 -

    Maps each kind of value to a mirrored instance of a subinterface of Value Subinterfaces of PrimitiveValue Kind of value For example -
    expression in target Is mirrored as an
    instance of Type of value
    Value.type() a boolean true BooleanValue BooleanType a byte (byte)4 ByteValue ByteType a char 'a' CharValue CharType a double 3.1415926 DoubleValue DoubleType a float 2.5f FloatValue FloatType an int 22 IntegerValue IntegerType a long 1024L LongValue LongType a short (short)12 ShortValue ShortType a void VoidValue VoidType Subinterfaces of ObjectReference Kind of value For example -
    expression in target Is mirrored as an
    instance of Type of value
    Value.type() a class instance this ObjectReference ClassType an array new int[5] ArrayReference ArrayType a string "hello" StringReference ClassType a thread Thread.currentThread() ThreadReference ClassType a thread group Thread.currentThread()
    .getThreadGroup() ThreadGroupReference ClassType a java.lang.Class
    instance this.getClass() ClassObjectReference ClassType a class loader this.getClass()
    .getClassLoader() ClassLoaderReference ClassType Other Kind of value For example -
    expression in target Is mirrored as Type of value null null null n/a
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Type type​()
      返回此值的运行时类型。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • type

        Type type​()
        返回此值的运行时类型。
        结果
        一个Type ，它反映了目标VM中的值的类型。
        另请参见：
        Type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VirtualMachine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface VirtualMachine

  • All Superinterfaces:
    Mirror
    All Known Subinterfaces:
    PathSearchingVirtualMachine

    public interface VirtualMachine
extends Mirror
    用于调试的虚拟机。 更准确地说，代表目标VM的复合状态的mirror 。 所有其他镜像都与此接口的实例相关联。 通过此接口的实例直接或间接访问所有其他镜像。 此接口直接支持对全局VM属性的访问和VM执行的控制。

    此接口的实例由实例Connector创建。 例如， AttachingConnector附加到目标VM并返回其虚拟机镜像。 连接器通常将通过调用VirtualMachineManager的VirtualMachineManager.createVirtualMachine(Connection) createVirtualMachine（Connection）方法来创建一个VirtualMachine。

    请注意，在接收到VMStartEvent之前，由启动连接器启动的目标虚拟机不能保证稳定。

    VirtualMachine以VirtualMachine作为参数的任何方法可能会导致VMDisconnectedException如果目标VM断开连接，并且VMDisconnectEvent已经或可用于从EventQueue读取。

    VirtualMachine以VirtualMachine作为参数的任何方法如果目标虚拟机的内存已经用完，可能会抛出VMOutOfMemoryException 。

    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TRACE_ALL
      所有跟踪都启用
      static int TRACE_EVENTS
      跟踪启用内部事件处理。
      static int TRACE_NONE
      所有跟踪都被禁用。
      static int TRACE_OBJREFS
      跟踪启用对象引用的内部管理。
      static int TRACE_RECEIVES
      从目标VM接收的JDWP数据包启用跟踪。
      static int TRACE_REFTYPES
      跟踪启用了引用类型的内部管理。
      static int TRACE_SENDS
      为发送到目标VM的JDWP数据包启用跟踪。

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      List<ReferenceType> allClasses​()
      返回所有加载的类型。
      default List<ModuleReference> allModules​()
      返回所有模块。
      List<ThreadReference> allThreads​()
      返回当前正在运行的线程的列表。
      boolean canAddMethod​()
      确定目标VM是否支持在执行类重定义时添加方法。
      boolean canBeModified​()
      确定目标VM是否是只读VM。
      boolean canForceEarlyReturn​()
      确定目标VM是否支持强制早期返回的方法。
      boolean canGetBytecodes​()
      确定目标VM是否支持检索方法的字节码。
      boolean canGetClassFileVersion​()
      确定目标VM是否支持阅读类文件主要和次要版本。
      boolean canGetConstantPool​()
      确定目标VM是否支持获取类的常量池信息。
      boolean canGetCurrentContendedMonitor​()
      确定目标VM是否支持线程正在等待的监视器的检索。
      boolean canGetInstanceInfo​()
      确定目标VM是否支持访问类实例，实例计数和引用对象。
      boolean canGetMethodReturnValues​()
      确定目标VM是否支持在MethodExitEvent中包含返回值。
      default boolean canGetModuleInfo​()
      确定目标VM是否支持获取有关模块的信息。
      boolean canGetMonitorFrameInfo​()
      确定目标VM是否支持获取哪个帧已经获取了监视器。
      boolean canGetMonitorInfo​()
      确定目标VM是否支持检索对象的监视器信息。
      boolean canGetOwnedMonitorInfo​()
      确定目标VM是否支持线程拥有的监视器的检索。
      boolean canGetSourceDebugExtension​()
      确定目标VM是否支持获取源调试扩展。
      boolean canGetSyntheticAttribute​()
      确定目标VM是否支持方法或字段的合成属性的查询。
      boolean canPopFrames​()
      确定目标VM是否支持弹出线程堆栈的帧。
      boolean canRedefineClasses​()
      确定目标VM是否支持任何级别的重新定义。
      boolean canRequestMonitorEvents​()
      确定目标VM是否支持创建MonitorContendedEnterRequest s。
      boolean canRequestVMDeathEvent​()
      确定目标VM是否支持创建VMDeathRequest s。
      boolean canUnrestrictedlyRedefineClasses​()
      确定目标VM是否在执行类重新定义时支持无限制的更改。
      boolean canUseInstanceFilters​()
      确定目标VM是否支持特定实例对象的过滤事件。
      boolean canUseSourceNameFilters​()
      确定目标虚拟机是否支持通过源名称过滤类准备事件。
      boolean canWatchFieldAccess​()
      确定目标VM是否支持现场访问的观察点。
      boolean canWatchFieldModification​()
      确定目标VM是否支持现场修改的观察点。
      List<ReferenceType> classesByName​(String className)
      返回与给定名称相匹配的加载引用类型。
      String description​()
      返回目标虚拟机上的文本信息和镜像它的调试器支持。
      void dispose​()
      使此虚拟机镜像无效。
      EventQueue eventQueue​()
      返回此虚拟机的事件队列。
      EventRequestManager eventRequestManager​()
      返回此虚拟机的事件请求管理器。
      void exit​(int exitCode)
      导致镜像的VM以给定的错误代码终止。
      String getDefaultStratum​()
      返回此虚拟机的默认层。
      long[] instanceCounts​(List<? extends ReferenceType> refTypes)
      返回“refTypes”列表中每个ReferenceType的实例数。
      BooleanValue mirrorOf​(boolean value)
      为给定值创建一个BooleanValue 。
      ByteValue mirrorOf​(byte value)
      为给定值创建一个ByteValue 。
      CharValue mirrorOf​(char value)
      为给定值创建一个CharValue 。
      DoubleValue mirrorOf​(double value)
      为给定值创建一个DoubleValue 。
      FloatValue mirrorOf​(float value)
      为给定值创建一个FloatValue 。
      IntegerValue mirrorOf​(int value)
      为给定值创建一个IntegerValue 。
      LongValue mirrorOf​(long value)
      为给定值创建一个LongValue 。
      ShortValue mirrorOf​(short value)
      为给定值创建一个ShortValue 。
      StringReference mirrorOf​(String value)
      在此虚拟机中创建一个字符串。
      VoidValue mirrorOfVoid​()
      创建一个VoidValue 。
      String name​()
      返回由属性 java.vm.name报告的目标VM的名称。
      Process process​()
      如果由LaunchingConnector启动，则返回此虚拟机的Process对象
      void redefineClasses​(Map<? extends ReferenceType,byte[]> classToBytes)
      根据提供的定义重新定义所有给定的类。
      void resume​()
      继续执行在该虚拟机中运行的应用程序。
      void setDebugTraceMode​(int traceFlags)
      跟踪由com.sun.jdi实现执行的活动。
      void setDefaultStratum​(String stratum)
      设置此虚拟机的默认层次（有关层次的讨论，请参阅Location ）。
      void suspend​()
      暂停在该虚拟机中运行的应用程序的执行。
      List<ThreadGroupReference> topLevelThreadGroups​()
      返回没有父级的每个线程组。
      String version​()
      返回由属性 java.version报告的目标虚拟机中的Java运行时环境的版本。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 字段详细信息

      • TRACE_NONE

        static final int TRACE_NONE
        所有跟踪都被禁用。
        另请参见：
        Constant Field Values

      • TRACE_SENDS

        static final int TRACE_SENDS
        为发送到目标VM的JDWP数据包启用跟踪。
        另请参见：
        Constant Field Values

      • TRACE_RECEIVES

        static final int TRACE_RECEIVES
        从目标VM接收的JDWP数据包启用跟踪。
        另请参见：
        Constant Field Values

      • TRACE_EVENTS

        static final int TRACE_EVENTS
        跟踪启用内部事件处理。
        另请参见：
        Constant Field Values

      • TRACE_REFTYPES

        static final int TRACE_REFTYPES
        跟踪启用了引用类型的内部管理。
        另请参见：
        Constant Field Values

      • TRACE_OBJREFS

        static final int TRACE_OBJREFS
        跟踪启用对象引用的内部管理。
        另请参见：
        Constant Field Values

      • TRACE_ALL

        static final int TRACE_ALL
        所有跟踪都启用
        另请参见：
        Constant Field Values

    • 方法详细信息

      • allModules

        default List<ModuleReference> allModules​()
        返回所有模块。 对于目标VM中的每个模块， ModuleReference将被放置在返回的列表中。

        并非所有目标虚拟机都支持此操作。 使用canGetModuleInfo()确定是否支持该操作。

        实现要求：
        默认实现会抛出 UnsupportedOperationException 。
        结果
        一个ModuleReference个对象的列表，每个镜像目标VM中的一个模块。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        从以下版本开始：
        9

      • classesByName

        List<ReferenceType> classesByName​(String className)
        返回与给定名称相匹配的加载引用类型。 该名称必须是完全限定的（例如，java.lang.String）。 返回的列表将包含一个ReferenceType为每个类或接口找到与给定的名称。 搜索仅限于加载类; 不尝试加载给定名称的类。

        返回的列表将包括至少准备的参考类型和未定义准备的类型（如数组）。

        参数
        className - 要搜索的类/接口名称
        结果
        一个ReferenceType对象的列表，每个对象以给定的名称镜像目标VM中的类型。

      • allClasses

        List<ReferenceType> allClasses​()
        返回所有加载的类型。 对于目标VM中的每个加载类型， ReferenceType将被放置在返回的列表中。 该列表将包括镜像类，接口和数组类型的ReferenceTypes。

        返回的列表将包括至少准备的参考类型和未定义准备的类型（如数组）。

        结果
        一个ReferenceType对象的列表，每个对象在目标VM中镜像加载类型。

      • redefineClasses

        void redefineClasses​(Map<? extends ReferenceType,byte[]> classToBytes)
        根据提供的定义重新定义所有给定的类。 重新定义的类中的一个方法称为“等价”（对于旧版本的方法）if
        • 它们的字节码是相同的，除了指向恒定池，而
        • 引用的常数是相等的。
        否则，新方法称为“非等价”。 如果重新定义的方法具有活动堆栈帧，则这些活动帧将继续运行该方法的先前版本的字节码。 如果这种方法的新版本是非等效的，那么来自这些活动帧之一的方法称为“过时”，当在这些方法之一上调用时， Method.isObsolete()将返回true。 如果需要重置这样的框架，请使用ThreadReference.popFrames(StackFrame)从堆栈中弹出旧的过时的方法执行。 重新定义的方法的新调用将始终调用新版本。

        除了根据常规JVM语义发生的情况，此函数不会导致任何初始化。 换句话说，重新定义一个类并不会导致它的初始化器被运行。 预先存在的静态变量的值将保持在调用之前。 但是，完全未初始化（新）静态变量将被分配其默认值。

        如果重新定义的类具有实例，则所有这些实例将在调用完成时具有由重新定义的类定义的字段。 预先存在的字段将保留其以前的值。 任何新字段都将具有默认值; 没有运行实例初始值或构造函数。

        线程不需要暂停。

        此功能不会生成任何事件。

        重定义类中的所有断点都将被删除。

        并非所有目标虚拟机都支持此操作。 使用canRedefineClasses()确定是否支持该操作。 使用canAddMethod()来确定重新定义是否可以添加方法。 使用canUnrestrictedlyRedefineClasses()来确定重新定义是否可以更改模式，删除方法，更改类层次结构等。

        参数
        classToBytes - 从ReferenceType到字节数组的映射。 字节表示新的类定义，并且是Java虚拟机类文件格式。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        • 如果canRedefineClasses()为false，则此方法的任何调用都将抛出此异常。
        • 如果canAddMethod()是假的，尝试添加一个方法会抛出这个异常。
        • 如果canUnrestrictedlyRedefineClasses()为false，则尝试以下任何操作将抛出此异常
          • 改变模式（字段）
          • 改变层次结构（子类，接口）
          • 删除方法
          • 改变类修饰符
          • 改变方法修饰符
        NoClassDefFoundError - 如果字节不对应于引用类型（名称不匹配）。
        VerifyError - 如果“验证者”检测到一个类虽然形成良好，却包含内部不一致或安全问题。
        ClassFormatError - 如果字节不表示有效的类。
        ClassCircularityError - 如果在初始化类时检测到圆度。
        UnsupportedClassVersionError - 如果虚拟机不支持以字节为单位的主要和次要版本号。
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 canBeModified() 。
        从以下版本开始：
        1.4
        另请参见：
        Method.isObsolete() ，
ThreadReference.popFrames(com.sun.jdi.StackFrame) ，
canRedefineClasses() ，
canAddMethod() ，
canUnrestrictedlyRedefineClasses()

      • allThreads

        List<ThreadReference> allThreads​()
        返回当前正在运行的线程的列表。 对于目标VM中的每个正在运行的线程，将镜像它的ThreadReference放在列表中。 返回的列表包含通过java.lang.Thread创建的线程，通过JNI附加到目标VM的所有本机线程以及目标VM创建的系统线程。 尚未启动的线程对象（参见Thread.start() ）和完成执行的线程对象不包括在返回的列表中。
        结果
        一个ThreadReference对象的列表，一个用于镜像VM中的每个正在运行的线程。

      • suspend

        void suspend​()
        暂停在该虚拟机中运行的应用程序的执行。 当前运行的所有线程将被暂停。

        与Thread.suspend()不同，虚拟机和单个线程的暂停计数。 在线程再次运行之前，它必须恢复（通过resume()或ThreadReference.resume() ）它已被挂起的次数。

        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 canBeModified() 。

      • resume

        void resume​()
        继续执行在该虚拟机中运行的应用程序。 所有线程都将恢复，如ThreadReference.resume()所述 。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读 - 请参阅 canBeModified() 。
        另请参见：
        suspend()

      • topLevelThreadGroups

        List<ThreadGroupReference> topLevelThreadGroups​()
        返回没有父级的每个线程组。 对于每个顶级线程组， ThreadGroupReference被放置在返回的列表中。

        该命令可以用作构建现有线程组的树（或树）的第一步。

        结果
        一个ThreadGroupReference对象的列表，每个顶级线程组一个。

      • eventQueue

        EventQueue eventQueue​()
        返回此虚拟机的事件队列。 虚拟机只有一个EventQueue对象，每次调用该方法时都会返回相同的实例。
        结果
        这个虚拟机的EventQueue 。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 canBeModified() 。

      • eventRequestManager

        EventRequestManager eventRequestManager​()
        返回此虚拟机的事件请求管理器。 EventRequestManager控制用户可设置的事件，如断点。 虚拟机只有一个EventRequestManager对象，每次调用该方法时都会返回相同的实例。
        结果
        该虚拟机的EventRequestManager 。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 canBeModified() 。

      • mirrorOf

        BooleanValue mirrorOf​(boolean value)
        为给定值创建一个BooleanValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 为其创建值的布尔值
        结果
        给定的布尔值为BooleanValue 。

      • mirrorOf

        ByteValue mirrorOf​(byte value)
        为给定值创建一个ByteValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 用于创建值的字节
        结果
        给定字节的ByteValue 。

      • mirrorOf

        CharValue mirrorOf​(char value)
        为给定值创建一个CharValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 为其创建值的char
        结果
        给定的char的CharValue 。

      • mirrorOf

        ShortValue mirrorOf​(short value)
        为给定值创建一个ShortValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 创建价值的简称
        结果
        ShortValue为给定的短。

      • mirrorOf

        IntegerValue mirrorOf​(int value)
        为给定值创建一个IntegerValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 为其创建值的int
        结果
        给定的int为IntegerValue 。

      • mirrorOf

        LongValue mirrorOf​(long value)
        为给定值创建一个LongValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 一个长期为它创建的价值
        结果
        LongValue为给定的长。

      • mirrorOf

        FloatValue mirrorOf​(float value)
        为给定值创建一个FloatValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 为其创建值的浮点数
        结果
        给定浮动的FloatValue 。

      • mirrorOf

        DoubleValue mirrorOf​(double value)
        为给定值创建一个DoubleValue 。 该值可用于设置和比较从该虚拟机中的变量或字段检索的值。
        参数
        value - 创建该值的双倍
        结果
        给予双倍的DoubleValue 。

      • mirrorOf

        StringReference mirrorOf​(String value)
        在此虚拟机中创建一个字符串。 创建的字符串可用于设置和比较从该虚拟机中的变量或字段检索的字符串值。
        参数
        value - 要创建的字符串
        结果
        一个StringReference镜像目标虚拟机中新创建的字符串。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的，请参阅 canBeModified() 。

      • mirrorOfVoid

        VoidValue mirrorOfVoid​()
        创建VoidValue 。 当要退出一个void方法时，该值可以传递给ThreadReference.forceEarlyReturn(com.sun.jdi.Value) 。
        结果
        VoidValue 。

      • process

        Process process​()
        如果由LaunchingConnector启动，则返回此虚拟机的Process对象
        结果
        该虚拟机的Process对象，如果未由LaunchingConnector启动， 则为null 。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请 参阅canBeModified() 。

      • dispose

        void dispose​()
        使此虚拟机镜像无效。 目标VM的通信通道关闭，目标VM准备接受来自此调试器或其他调试器的另一个后续连接，包括以下任务：
        • 所有事件请求都被取消。
        • 由suspend()或ThreadReference.suspend()暂停的所有线程根据需要恢复运行多次。
        • 在通过ObjectReference.disableCollection()禁用的所有情况下，将重新启用垃圾收集。
        在目标虚拟机中执行的任何当前方法调用在断开连接后都会继续。 完成任何此类方法调用后，调用的线程将从最初停止的位置继续。

        源自此VirtualMachine（ObjectReferences，ReferenceTypes等）的资源将无效。

      • exit

        void exit​(int exitCode)
        导致镜像的VM以给定的错误代码终止。 与此VirtualMachine关联的所有资源都将被释放。 如果镜像的VM是远程的，那么它的通信通道将被关闭。 源自此VirtualMachine（ObjectReferences，ReferenceTypes等）的资源将无效。

        在镜像VM中运行的线程突然终止。 线程死亡异常不会被抛出，最后块不运行。

        参数
        exitCode - 目标VM的退出代码。 在某些平台上，退出代码可能会被截断，例如降低8位。
        异常
        VMCannotBeModifiedException - 如果VirtualMachine是只读的 - 请参阅 canBeModified() 。

      • canWatchFieldModification

        boolean canWatchFieldModification​()
        确定目标VM是否支持现场修改的观察点。
        结果
        true如果该功能被支持，否则为 false 。

      • canWatchFieldAccess

        boolean canWatchFieldAccess​()
        确定目标VM是否支持现场访问的观察点。
        结果
        true如果该功能被支持，否则为 false 。

      • canGetBytecodes

        boolean canGetBytecodes​()
        确定目标VM是否支持检索方法的字节码。
        结果
        true如果该功能被支持，否则为 false 。

      • canGetSyntheticAttribute

        boolean canGetSyntheticAttribute​()
        确定目标VM是否支持方法或字段的合成属性的查询。
        结果
        true如果该功能被支持，否则为 false 。

      • canGetOwnedMonitorInfo

        boolean canGetOwnedMonitorInfo​()
        确定目标VM是否支持线程拥有的监视器的检索。
        结果
        true如果特性被支持， false否则。

      • canGetCurrentContendedMonitor

        boolean canGetCurrentContendedMonitor​()
        确定目标VM是否支持线程正在等待的监视器的检索。
        结果
        true如果特性被支持， false否则。

      • canGetMonitorInfo

        boolean canGetMonitorInfo​()
        确定目标VM是否支持检索对象的监视器信息。
        结果
        true如果该功能被支持，否则为 false 。

      • canUseInstanceFilters

        boolean canUseInstanceFilters​()
        确定目标VM是否支持特定实例对象的过滤事件。 例如，请参阅BreakpointRequest.addInstanceFilter(com.sun.jdi.ObjectReference) 。
        结果
        true如果该功能被支持，否则为 false 。

      • canRedefineClasses

        boolean canRedefineClasses​()
        确定目标VM是否支持任何级别的重新定义。
        结果
        true如果特性被支持， false否则。
        从以下版本开始：
        1.4
        另请参见：
        redefineClasses(java.util.Map<? extends com.sun.jdi.ReferenceType, byte[]>)

      • canAddMethod

        boolean canAddMethod​()
        确定目标VM是否支持在执行类重定义时添加方法。
        结果
        true如果特性被支持， false否则。
        从以下版本开始：
        1.4
        另请参见：
        redefineClasses(java.util.Map<? extends com.sun.jdi.ReferenceType, byte[]>)

      • canUnrestrictedlyRedefineClasses

        boolean canUnrestrictedlyRedefineClasses​()
        确定目标VM是否在执行类重新定义时支持无限制的更改。
        结果
        true如果特性被支持， false否则。
        从以下版本开始：
        1.4
        另请参见：
        redefineClasses(java.util.Map<? extends com.sun.jdi.ReferenceType, byte[]>)

      • canPopFrames

        boolean canPopFrames​()
        确定目标VM是否支持弹出线程堆栈的帧。
        结果
        true如果该功能被支持，否则为 false 。
        从以下版本开始：
        1.4
        另请参见：
        ThreadReference.popFrames(com.sun.jdi.StackFrame)

      • canGetSourceDebugExtension

        boolean canGetSourceDebugExtension​()
        确定目标VM是否支持获取源调试扩展。
        结果
        true如果该功能被支持，否则为 false 。
        从以下版本开始：
        1.4
        另请参见：
        ReferenceType.sourceDebugExtension()

      • canRequestVMDeathEvent

        boolean canRequestVMDeathEvent​()
        确定目标VM是否支持创建VMDeathRequest s。
        结果
        true如果支持该功能，否则为 false 。
        从以下版本开始：
        1.4
        另请参见：
        EventRequestManager.createVMDeathRequest()

      • canGetMethodReturnValues

        boolean canGetMethodReturnValues​()
        确定目标VM是否支持在MethodExitEvent中包含返回值。
        结果
        true如果该功能被支持，否则为 false 。
        从以下版本开始：
        1.6
        另请参见：
        EventRequestManager.createMethodExitRequest()

      • canGetInstanceInfo

        boolean canGetInstanceInfo​()
        确定目标VM是否支持访问类实例，实例计数和引用对象。
        结果
        true如果特性被支持， false否则。
        从以下版本开始：
        1.6
        另请参见：
        instanceCounts(java.util.List<? extends com.sun.jdi.ReferenceType>) ，
ReferenceType.instances(long) ，
ObjectReference.referringObjects(long)

      • canUseSourceNameFilters

        boolean canUseSourceNameFilters​()
        确定目标虚拟机是否支持通过源名称过滤类准备事件。 见ClassPrepareRequest.addSourceNameFilter(java.lang.String) 。
        结果
        true如果支持该功能，否则为 false 。
        从以下版本开始：
        1.6

      • canForceEarlyReturn

        boolean canForceEarlyReturn​()
        确定目标VM是否支持强制早期返回的方法。
        结果
        true如果该功能被支持，否则为 false 。
        从以下版本开始：
        1.6
        另请参见：
        ThreadReference.forceEarlyReturn(Value)

      • canBeModified

        boolean canBeModified​()
        确定目标VM是否是只读VM。 如果在只读VM上调用修改VM状态的方法，则抛出VMCannotBeModifiedException 。
        结果
        true如果支持该功能，否则为 false 。
        从以下版本开始：
        1.5

      • canRequestMonitorEvents

        boolean canRequestMonitorEvents​()
        确定目标VM是否支持创建MonitorContendedEnterRequest s。 MonitorContendedEnteredRequest s。 MonitorWaitRequest s。 MonitorWaitedRequest s。
        结果
        true如果该功能被支持，否则为 false 。
        从以下版本开始：
        1.6
        另请参见：
        EventRequestManager.createMonitorContendedEnterRequest() ，
EventRequestManager.createMonitorContendedEnteredRequest() ，
EventRequestManager.createMonitorWaitRequest() ，
EventRequestManager.createMonitorWaitedRequest()

      • canGetMonitorFrameInfo

        boolean canGetMonitorFrameInfo​()
        确定目标VM是否支持获取哪个帧已经获取了监视器。
        结果
        true如果特性被支持， false否则。
        从以下版本开始：
        1.6
        另请参见：
        ThreadReference.ownedMonitorsAndFrames()

      • canGetClassFileVersion

        boolean canGetClassFileVersion​()
        确定目标VM是否支持阅读类文件主要和次要版本。
        结果
        true如果特性被支持， false否则。
        从以下版本开始：
        1.6
        另请参见：
        ReferenceType.majorVersion() ， ReferenceType.minorVersion()

      • canGetConstantPool

        boolean canGetConstantPool​()
        确定目标VM是否支持获取类的常量池信息。
        结果
        true如果该功能被支持，否则为 false 。
        从以下版本开始：
        1.6
        另请参见：
        ReferenceType.constantPoolCount() ， ReferenceType.constantPool()

      • canGetModuleInfo

        default boolean canGetModuleInfo​()
        确定目标VM是否支持获取有关模块的信息。
        实现要求：
        默认实现返回 false 。
        结果
        true如果特性被支持， false否则
        从以下版本开始：
        9
        另请参见：
        allModules() ， ReferenceType.module() ， ModuleReference

      • setDefaultStratum

        void setDefaultStratum​(String stratum)
        设置此VM的默认层次（有关层次的讨论，请参阅Location ）。 覆盖类文件中的每类默认设置。

        影响位置查询（例如， Location.sourceName() ）和单步执行中使用的行边界。

        参数
        stratum - 要设置为VM默认值的层次，或者使用默认值为null。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        从以下版本开始：
        1.4

      • getDefaultStratum

        String getDefaultStratum​()
        返回此虚拟机的默认层。
        结果
        null （意思是应该使用每类默认值 - ReferenceType.defaultStratum() ），除非默认层次已经设置为 setDefaultStratum(String) 。
        从以下版本开始：
        1.4
        另请参见：
        setDefaultStratum(String) ， ReferenceType.defaultStratum()

      • instanceCounts

        long[] instanceCounts​(List<? extends ReferenceType> refTypes)
        返回“refTypes”列表中每个ReferenceType的实例数。 只有为垃圾收集目的可达到的实例才会被计数。

        并非所有目标虚拟机都支持此操作。 使用canGetInstanceInfo()来确定是否支持该操作。

        参数
        refTypes - 要获取计数的ReferenceType对象的列表。
        结果
        一个long的数组，包含'refTypes'列表中每个元素的一个元素。 数组的元素i包含“refTypes”列表中位置i的ReferenceType的目标VM中的实例数。 如果“refTypes”列表为空，则返回零长度数组。 如果refTypes中的ReferenceType已经被垃圾回收，则返回零的实例计数。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetInstanceInfo()
        NullPointerException - 如果'refTypes'列表为空。
        从以下版本开始：
        1.6
        另请参见：
        ReferenceType.instances(long) ， ObjectReference.referringObjects(long)

      • description

        String description​()
        返回目标虚拟机上的文本信息和镜像它的调试器支持。 没有保证此信息的具体格式。 通常，此字符串包含目标VM和调试器接口的版本信息。 在VM和JDI版本更精确的信息，可通过version() ， VirtualMachineManager.majorInterfaceVersion() ，并VirtualMachineManager.minorInterfaceVersion()
        结果
        说明。

      • version

        String version​()
        返回由属性java.version报告的目标虚拟机中的Java运行时环境的版本。 要获得JDI接口版本，请使用VirtualMachineManager.majorInterfaceVersion()和VirtualMachineManager.minorInterfaceVersion()
        结果
        目标VM版本。

      • name

        String name​()
        返回由属性 java.vm.name报告的目标VM的名称。
        结果
        目标VM名称。

      • setDebugTraceMode

        void setDebugTraceMode​(int traceFlags)
        跟踪由com.sun.jdi实现执行的活动。 所有跟踪信息都输出到System.err。 给定的跟踪标志用于将输出限制为所需的信息。 给定的标志有效，相应的跟踪将继续下一次调用此方法。

        输出取决于实现，跟踪模式可能会被忽略。

        参数
        traceFlags - 识别要启用的跟踪类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VirtualMachineManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface VirtualMachineManager

  • public interface VirtualMachineManager
    目标虚拟机的连接经理。 VirtualMachineManager允许一个应用程序调试多个目标虚拟机。 （请注意，不支持相反;目标VM只能由一个调试器应用程序进行调试。）此接口包含管理与远程目标VM的连接的方法，并获取可用目标VM的VirtualMachine镜像。

    可以使用几个不同的Connector对象之一进行连接。 每个连接器封装了将调试器与目标VM连接的不同方式。

    VirtualMachineManager支持将调试器连接到虚拟机的许多不同方案。 下表列出了四个例子。 这些示例在Sun的实现中使用命令行语法。 一些Connector实现可能需要略微不同的处理，如下所示。

    Four scenarios for connecting a debugger to a virtual machine" Scenario Description Debugger launches target VM (simplest, most-common scenario) Debugger calls the LaunchingConnector.launch(java.util.Map) method of the default connector, obtained with defaultConnector(). The target VM is launched, and a connection between that VM and the debugger is established. A VirtualMachine mirror is returned.

    Or, for more control

    • Debugger selects a connector from the list returned by launchingConnectors() with desired characteristics (for example, transport type, etc.).
    • Debugger calls the LaunchingConnector.launch(java.util.Map) method of the selected connector. The target VM is launched, and a connection between that VM and the debugger is established. A VirtualMachine mirror is returned.
    Debugger attaches to previously-running VM
    • Target VM is launched using the options -agentlib:jdwp=transport=xxx,server=y
    • Target VM generates and outputs the tranport-specific address at which it will listen for a connection.
    • Debugger is launched. Debugger selects a connector in the list returned by attachingConnectors() matching the transport with the name "xxx".
    • Debugger presents the default connector parameters (obtained through Connector.defaultArguments()) to the end user, allowing the user to fill in the transport-specific address generated by the target VM.
    • Debugger calls the AttachingConnector.attach(java.util.Map) method of the selected to attach to the target VM. A VirtualMachine mirror is returned.
    Target VM attaches to previously-running debugger
    • At startup, debugger selects one or more connectors from the list returned by listeningConnectors() for one or more transports.
    • Debugger calls the ListeningConnector.startListening(java.util.Map) method for each selected connector. For each call, a transport-specific address string is generated and returned. The debugger makes the transport names and corresponding address strings available to the end user.
    • Debugger calls ListeningConnector.accept(java.util.Map) for each selected connector to wait for a target VM to connect.
    • Later, target VM is launched by end user with the options -agentlib:jdwp=transport=xxx,address=yyy where "xxx" the transport for one of the connectors selected by the the debugger and "yyy" is the address generated by ListeningConnector.accept(java.util.Map) for that transport.
    • Debugger's call to ListeningConnector.accept(java.util.Map) returns a VirtualMachine mirror.
    Target VM launches debugger (sometimes called "Just-In-Time" debugging)
    • Target VM is launched with the options -agentlib:jdwp=launch=cmdline,onuncaught=y,transport=xxx,server=y
    • Later, an uncaught exception is thrown in the target VM. The target VM generates the tranport-specific address at which it will listen for a connection.
    • Target VM launches the debugger with the following items concatenated together (separated by spaces) to form the command line:
      • The launch= value
      • The transport= value
      • The generated transport-specific address at which VM is listening for debugger connection.
    • Upon launch, debugger selects a connector in the list returned by attachingConnectors() matching the transport with the name "xxx".
    • Debugger changes the default connector parameters (obtained through Connector.defaultArguments()) to specify the transport specific address at which the VM is listenig. Optionally, other connector arguments can be presented to the user.
    • Debugger calls the AttachingConnector.attach(java.util.Map) method of the selected to attach to the target VM. A VirtualMachine mirror is returned.

    连接器在启动时创建。 也就是说，它们是在第一次调用Bootstrap.virtualMachineManager()时创建的。 可以通过调用allConnectors方法从VirtualMachineManager获取在启动时创建的所有连接器的列表。

    连接器在启动时创建，如果它们安装在平台上。 此外，由VirtualMachineManager自动创建连接器以封装平台上安装的任何TransportService实现。 这两种机制用于创建连接器。

    如果连接器安装在Connector类型的定义类加载器中可见的jar文件中，并且该jar文件包含资源目录META-INF/services名为com.sun.jdi.connect.Connector的提供程序配置文件，以及提供程序配置文件列出Connector实现的全限定类名。 连接器是实现Connector接口的类。 更适当地该类实现的特定连接器类型中的一种，即AttachingConnector ， ListeningConnector ，或LaunchingConnector 。 提供程序配置文件的格式是每行一个完全限定的类名。 每个类周围的空格和制表符字符以及空白行都被忽略。 注释字符为'#' （ 0x23 ），并且在每行上，忽略第一个注释字符之后的所有字符。 文件必须以UTF-8编码。

    在启动时，VirtualMachineManager将尝试加载和实例化（使用无参数构造函数）提供程序配置文件中列出的每个类。 加载或创建连接器时抛出的异常被捕获并被忽略。 换句话说，即使发生错误，启动过程仍然继续。

    除了安装在平台上的连接器之外，VirtualMachineManager还将创建连接器来封装平台上安装的任何TransportService实现。 如果安装在适用于TransportService类型的定义类加载器的jar文件中，则该平台上将安装TransportService ，该jar文件包含资源目录META-INF/services名为com.sun.jdi.connect.spi.TransportService的提供程序配置文件，并且提供程序配置文件列表TransportService实施的全限定类名。 TransportService是TransportService的具体子类。 提供程序配置文件的格式与“连接器”的提供程序配置文件相同，除了列出的每个类都必须是实现TransportService接口的类的完全限定类名称。

    对于安装在平台上的每个TransportService，VirtualMachineManager将创建相应的AttachingConnector和ListeningConnector 。 这些连接器被创建来封装一个Transport ，这又封装了TransportService。 Attach将根据连接字符串Attach的传输服务的名称进行命名。 例如，如果传输服务name()方法返回telepathic则telepathic将被命名为telepathicAttach 。 类似的ListeningConnector将被命名为Listen标记到传输服务名称的字符串。 AttachedConnector和ListeningConnector的description()方法将委托给基础传输服务的description()方法。 AttachedConnector和ListeningConnector都将有两个连接器Arguments 。 一个StringArgument命名为address是连接参数指定的地址过于重视，还是要听的。 甲IntegerArgument命名timeout是该连接器的参数时附接，或接受来指定超时。 根据传输服务是否支持附加超时或接受超时，超时连接器可能会被忽略。

    虚拟机管理器的初始化将失败，如果虚拟机管理器无法创建任何连接器，则将发生错误Bootstrap.virtualMachineManager() 。

    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<Connector> allConnectors​()
      返回所有已知的Connector对象的列表。
      List<AttachingConnector> attachingConnectors​()
      返回已知的AttachingConnector对象的列表。
      List<VirtualMachine> connectedVirtualMachines​()
      列出连接到调试器的所有目标虚拟机。
      VirtualMachine createVirtualMachine​(Connection connection)
      创建一个新的虚拟机。
      VirtualMachine createVirtualMachine​(Connection connection, Process process)
      为目标虚拟机创建虚拟机镜像。
      LaunchingConnector defaultConnector​()
      标识默认连接器。
      List<LaunchingConnector> launchingConnectors​()
      返回已知的LaunchingConnector对象的列表。
      List<ListeningConnector> listeningConnectors​()
      返回已知的ListeningConnector对象的列表。
      int majorInterfaceVersion​()
      返回JDI界面的主版本号。
      int minorInterfaceVersion​()
      返回JDI接口的次要版本号。

    • 方法详细信息

      • defaultConnector

        LaunchingConnector defaultConnector​()
        标识默认连接器。 当不需要选择具有特定特性的连接器时，该连接器应用作发射连接器。
        结果
        默认为LaunchingConnector

      • launchingConnectors

        List<LaunchingConnector> launchingConnectors​()
        返回已知的LaunchingConnector对象的列表。 任何返回的对象都可用于启动新的目标VM，并立即为其创建一个VirtualMachine镜像。 请注意，启动连接器启动的目标虚拟机不能保证稳定，直到接收到VMStartEvent 。
        结果
        LaunchingConnector对象的列表。

      • attachingConnectors

        List<AttachingConnector> attachingConnectors​()
        返回已知的AttachingConnector对象的列表。 任何返回的对象都可以用于附加到现有的目标VM并为其创建一个VirtualMachine镜像。
        结果
        一个AttachingConnector对象的列表。

      • listeningConnectors

        List<ListeningConnector> listeningConnectors​()
        返回已知的ListeningConnector对象的列表。 任何返回的对象都可用于侦听由目标VM发起的连接，并为其创建一个VirtualMachine镜像。
        结果
        一个ListeningConnector个对象的列表。

      • allConnectors

        List<Connector> allConnectors​()
        返回所有已知的Connector对象的列表。
        结果
        一个Connector个对象的列表。

      • connectedVirtualMachines

        List<VirtualMachine> connectedVirtualMachines​()
        列出连接到调试器的所有目标虚拟机。 该列表包括发起连接的任何目标虚拟机的VirtualMachine实例以及此管理器已启动连接的任何目标虚拟机。 目标VM将保留在此列表中，直到VM断开连接。 在将VM从列表中删除后，将将VMDisconnectEvent置于事件队列中。
        结果
        一个VirtualMachine个对象的列表，每个镜像一个目标虚拟机。

      • majorInterfaceVersion

        int majorInterfaceVersion​()
        返回JDI界面的主版本号。 请参阅VirtualMachine.version()目标VM版本和信息以及VirtualMachine.description()更多版本信息。
        结果
        整数主版本号。

      • minorInterfaceVersion

        int minorInterfaceVersion​()
        返回JDI接口的次要版本号。 请参阅VirtualMachine.version()目标VM版本和信息以及VirtualMachine.description()更多版本信息。
        结果
        整数小版本号

      • createVirtualMachine

        VirtualMachine createVirtualMachine​(Connection connection,
                                    Process process)
                             throws IOException
        为目标虚拟机创建虚拟机镜像。

        为已存在Connection的目标虚拟机创建虚拟机镜像。 当Connector建立连接并与目标VM成功握手时，将创建连接。 然后，连接器可以使用此方法创建虚拟机镜像来表示目标VM的复合状态。

        process参数指定标签虚拟机的Process对象。 可以指定为null 。 如果目标虚拟机由LaunchingConnector启动，则应指定process参数，否则，在创建的虚拟机上调用VirtualMachine.process()将返回null 。

        存在此方法，以便连接器可以在建立与目标VM的连接时创建虚拟机镜像。 只有开发新的Connector实现的开发者才需要直接使用这种方法。

        参数
        connection - 与目标虚拟机的打开连接。
        process - 如果启动， 则为目标VM的Process对象。 null如果没有启动。
        结果
        代表目标虚拟机的新虚拟机。
        异常
        IOException - 如果发生I / O错误
        IllegalStateException - 如果连接未打开
        从以下版本开始：
        1.5
        另请参见：
        Connection.isOpen() ， VirtualMachine.process()

      • createVirtualMachine

        VirtualMachine createVirtualMachine​(Connection connection)
                             throws IOException
        创建一个新的虚拟机。

        这种方便的方法就像调用createVirtualMachine(Connection, Process)方法一样，并指定null作为process参数。

        存在此方法，以便连接器可以在建立与目标VM的连接时创建虚拟机镜像。 只有开发新的Connector实现的开发者才需要直接使用这种方法。

        结果
        新的虚拟机
        异常
        IOException - 如果发生I / O错误
        IllegalStateException - 如果连接未打开
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VMCannotBeModifiedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class VMCannotBeModifiedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.UnsupportedOperationException
            • com.sun.jdi.VMCannotBeModifiedException
  • All Implemented Interfaces:
    Serializable

    public class VMCannotBeModifiedException
extends UnsupportedOperationException
    抛出以表示操作无效，因为它会修改VM，VM是只读的。 见VirtualMachine.canBeModified() 。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VMCannotBeModifiedException​()
      VMCannotBeModifiedException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • VMCannotBeModifiedException

        public VMCannotBeModifiedException​()

      • VMCannotBeModifiedException

        public VMCannotBeModifiedException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VMDisconnectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class VMDisconnectedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.VMDisconnectedException
  • All Implemented Interfaces:
    Serializable

    public class VMDisconnectedException
extends RuntimeException
    抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VMDisconnectedException​()
      VMDisconnectedException​(String message)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • VMDisconnectedException

        public VMDisconnectedException​()

      • VMDisconnectedException

        public VMDisconnectedException​(String message)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VMMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class VMMismatchException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.VMMismatchException
  • All Implemented Interfaces:
    Serializable

    public class VMMismatchException
extends RuntimeException
    抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VMMismatchException​()
      VMMismatchException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • VMMismatchException

        public VMMismatchException​()

      • VMMismatchException

        public VMMismatchException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VMOutOfMemoryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Class VMOutOfMemoryException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.VMOutOfMemoryException
  • All Implemented Interfaces:
    Serializable

    public class VMOutOfMemoryException
extends RuntimeException
    抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VMOutOfMemoryException​()
      VMOutOfMemoryException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • VMOutOfMemoryException

        public VMOutOfMemoryException​()

      • VMOutOfMemoryException

        public VMOutOfMemoryException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VoidType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface VoidType

  • All Superinterfaces:
    Mirror ， Type

    public interface VoidType
extends Type
    在目标VM中访问的所有原语void值的类型。 调用Value.type()将返回此接口的实现者。
    从以下版本开始：
    1.3
    另请参见：
    VoidValue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Type

        name, signature
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VoidValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi

Interface VoidValue

  • All Superinterfaces:
    Mirror ， Value

    public interface VoidValue
extends Value
    提供对目标虚拟机中原始数据 void访问。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将指定的Object与此VoidValue进行比较以获得相等性。
      int hashCode​()
      返回此VoidValue的哈希码值。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.Value

        type

    • 方法详细信息

      • equals

        boolean equals​(Object obj)
        将指定的Object与此VoidValue进行比较以获得相等性。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果Object是VoidValue，则为true; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此VoidValue的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.AbsentInformationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.AbsentInformationException

  • Packages that use AbsentInformationException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of AbsentInformationException in com.sun.jdi

      Methods in com.sun.jdi that throw AbsentInformationException
      Modifier and Type 方法 描述
      List<Location> Method.allLineLocations​()
      在此方法中为每个可执行源行返回一个包含一个Location对象的列表。
      List<Location> Method.allLineLocations​(String stratum, String sourceName)
      在此方法中为每个可执行源行返回一个包含一个Location对象的列表。
      List<Location> ReferenceType.allLineLocations​()
      在此引用类型中为每个可执行源行返回一个包含一个Location对象的列表。
      List<Location> ReferenceType.allLineLocations​(String stratum, String sourceName)
      返回一个包含此引用类型中每个可执行源代码行的对象的列表Location 。
      List<LocalVariable> Method.arguments​()
      返回一个列表，其中包含声明为此方法参数的每个LocalVariable 。
      List<Location> Method.locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> Method.locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号和源名称的所有Location对象的列表。
      List<Location> ReferenceType.locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> ReferenceType.locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      String ReferenceType.sourceDebugExtension​()
      获取此类型的源调试扩展。
      String Location.sourceName​()
      获取与此位置相对应的源的标识名称。
      String Location.sourceName​(String stratum)
      获取与此位置相对应的源的标识名称。
      String ReferenceType.sourceName​()
      获取与此类型的声明相对应的源的识别名称。
      List<String> ReferenceType.sourceNames​(String stratum)
      获取与此类型的声明对应的所有源的识别名称。
      String Location.sourcePath​()
      获取与此位置相对应的源的路径。
      String Location.sourcePath​(String stratum)
      获取与此位置相对应的源的路径。
      List<String> ReferenceType.sourcePaths​(String stratum)
      获取与此类型的声明对应的源的路径。
      List<LocalVariable> Method.variables​()
      返回一个包含在此方法中声明的每个LocalVariable的列表。
      List<LocalVariable> Method.variablesByName​(String name)
      在此方法中返回包含给定名称的每个LocalVariable的列表。
      LocalVariable StackFrame.visibleVariableByName​(String name)
      找到匹配给定名称的LocalVariable ，并在当前帧位置可见。
      List<LocalVariable> StackFrame.visibleVariables​()
      返回一个列表，其中包含可以从此框架的位置访问的每个LocalVariable 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.Bootstrap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.Bootstrap

No usage of com.sun.jdi.Bootstrap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.ClassNotLoadedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.ClassNotLoadedException

  • Packages that use ClassNotLoadedException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ClassNotLoadedException in com.sun.jdi

      Methods in com.sun.jdi that throw ClassNotLoadedException
      Modifier and Type 方法 描述
      List<Type> Method.argumentTypes​()
      返回一个包含此方法的每个形式参数类型的列表。
      Type ArrayType.componentType​()
      返回数组声明中指定的该数组的组件类型。
      void ThreadReference.forceEarlyReturn​(Value value)
      强制一个方法在返回到返回语句之前返回。
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标VM中调用指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标VM中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      使用目标VM中的给定构造函数方法构造此类型的新实例。
      Type Method.returnType​()
      返回返回类型，如该方法的声明所指定。
      void ArrayReference.setValue​(int index, Value value)
      用另一个值替换数组组件。
      void ClassType.setValue​(Field field, Value value)
      为静态字段分配一个值。
      void ObjectReference.setValue​(Field field, Value value)
      设置此对象中给定实例或静态字段的值。
      void StackFrame.setValue​(LocalVariable variable, Value value)
      在此框架中设置LocalVariable的Value 。
      void ArrayReference.setValues​(int index, List<? extends Value> values, int srcIndex, int length)
      用其他值替换一系列阵列组件。
      void ArrayReference.setValues​(List<? extends Value> values)
      用其他值替换所有数组组件。
      Type Field.type​()
      返回此字段的类型。
      Type LocalVariable.type​()
      返回此变量的类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.ClassNotPreparedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.ClassNotPreparedException

No usage of com.sun.jdi.ClassNotPreparedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.IncompatibleThreadStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.IncompatibleThreadStateException

  • Packages that use IncompatibleThreadStateException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of IncompatibleThreadStateException in com.sun.jdi

      Methods in com.sun.jdi that throw IncompatibleThreadStateException
      Modifier and Type 方法 描述
      ObjectReference ThreadReference.currentContendedMonitor​()
      返回一个ObjectReference的监视器，如果有的话，这个线程当前正在等待。
      int ObjectReference.entryCount​()
      返回此对象的显示器由当前拥有的线程输入的次数。
      void ThreadReference.forceEarlyReturn​(Value value)
      强制一个方法在返回到返回语句之前返回。
      StackFrame ThreadReference.frame​(int index)
      返回线程当前调用堆栈中给定索引的StackFrame 。
      int ThreadReference.frameCount​()
      返回线程当前调用堆栈中的堆栈帧数。
      List<StackFrame> ThreadReference.frames​()
      返回包含线程当前调用堆栈中的每个StackFrame的列表。
      List<StackFrame> ThreadReference.frames​(int start, int length)
      从线程的当前调用堆栈返回一个包含StackFrame个镜像范围的列表。
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      构造此类型的新实例，使用给定的构造方法目标VM。
      List<ObjectReference> ThreadReference.ownedMonitors​()
      返回一个列表，包含线程拥有的每个监视器的一个ObjectReference 。
      List<MonitorInfo> ThreadReference.ownedMonitorsAndFrames​()
      返回一个列表，包含线程拥有的每个监视器的一个MonitorInfo对象。
      ThreadReference ObjectReference.owningThread​()
      返回当前拥有该对象的监视器的线程（如果有）的ThreadReference 。
      void ThreadReference.popFrames​(StackFrame frame)
      弹出框架。
      List<ThreadReference> ObjectReference.waitingThreads​()
      返回一个列表，其中包含当前正在等待此对象的显示器的每个线程的ThreadReference 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InconsistentDebugInfoException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InconsistentDebugInfoException

No usage of com.sun.jdi.InconsistentDebugInfoException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InternalException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InternalException

No usage of com.sun.jdi.InternalException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InvalidCodeIndexException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InvalidCodeIndexException

No usage of com.sun.jdi.InvalidCodeIndexException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InvalidLineNumberException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InvalidLineNumberException

No usage of com.sun.jdi.InvalidLineNumberException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InvalidModuleException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InvalidModuleException

No usage of com.sun.jdi.InvalidModuleException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InvalidStackFrameException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InvalidStackFrameException

No usage of com.sun.jdi.InvalidStackFrameException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InvalidTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InvalidTypeException

  • Packages that use InvalidTypeException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of InvalidTypeException in com.sun.jdi

      Methods in com.sun.jdi that throw InvalidTypeException
      Modifier and Type 方法 描述
      void ThreadReference.forceEarlyReturn​(Value value)
      强制一个方法在返回到返回语句之前返回。
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      使用目标VM中的给定构造函数方法构造此类型的新实例。
      void ArrayReference.setValue​(int index, Value value)
      用另一个值替换数组组件。
      void ClassType.setValue​(Field field, Value value)
      为静态字段分配一个值。
      void ObjectReference.setValue​(Field field, Value value)
      设置此对象中给定实例或静态字段的值。
      void StackFrame.setValue​(LocalVariable variable, Value value)
      在此框架中设置LocalVariable的Value 。
      void ArrayReference.setValues​(int index, List<? extends Value> values, int srcIndex, int length)
      用其他值替换一系列阵列组件。
      void ArrayReference.setValues​(List<? extends Value> values)
      用其他值替换所有数组组件。
      void ThreadReference.stop​(ObjectReference throwable)
      Stops this thread with an asynchronous exception.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.InvocationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.InvocationException

  • Packages that use InvocationException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of InvocationException in com.sun.jdi

      Methods in com.sun.jdi that throw InvocationException
      Modifier and Type 方法 描述
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      构造此类型的新实例，使用给定的构造方法目标VM。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.JDIPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.JDIPermission

No usage of com.sun.jdi.JDIPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.NativeMethodException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.NativeMethodException

No usage of com.sun.jdi.NativeMethodException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.ObjectCollectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.ObjectCollectedException

No usage of com.sun.jdi.ObjectCollectedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.VMCannotBeModifiedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.VMCannotBeModifiedException

No usage of com.sun.jdi.VMCannotBeModifiedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.VMDisconnectedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.VMDisconnectedException

No usage of com.sun.jdi.VMDisconnectedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.VMMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.VMMismatchException

No usage of com.sun.jdi.VMMismatchException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.VMOutOfMemoryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.VMOutOfMemoryException

No usage of com.sun.jdi.VMOutOfMemoryException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Accessible (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Accessible

  • Packages that use Accessible
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of Accessible in com.sun.jdi

      Subinterfaces of Accessible in com.sun.jdi
      Modifier and Type 接口 描述
      interface  ArrayType
      提供对数组类的访问及其在目标虚拟机中的组件类型。
      interface  ClassType
      目标VM中的类的镜像。
      interface  Field
      目标VM中的类或实例变量。
      interface  InterfaceType
      目标虚拟机中的接口的镜像。
      interface  方法
      目标VM中的静态或实例方法。
      interface  ReferenceType
      目标虚拟机中对象的类型。
      interface  TypeComponent
      在用户定义的类型（类或接口）内声明的实体。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ArrayReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ArrayReference

  • Packages that use ArrayReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ArrayReference in com.sun.jdi

      Methods in com.sun.jdi that return ArrayReference
      Modifier and Type 方法 描述
      ArrayReference ArrayType.newInstance​(int length)
      在目标VM中创建此数组类的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ArrayType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ArrayType

No usage of com.sun.jdi.ArrayType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.BooleanType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.BooleanType

No usage of com.sun.jdi.BooleanType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.BooleanValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.BooleanValue

  • Packages that use BooleanValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of BooleanValue in com.sun.jdi

      Methods in com.sun.jdi that return BooleanValue
      Modifier and Type 方法 描述
      BooleanValue VirtualMachine.mirrorOf​(boolean value)
      为给定值创建一个BooleanValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ByteType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ByteType

No usage of com.sun.jdi.ByteType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ByteValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ByteValue

  • Packages that use ByteValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ByteValue in com.sun.jdi

      Methods in com.sun.jdi that return ByteValue
      Modifier and Type 方法 描述
      ByteValue VirtualMachine.mirrorOf​(byte value)
      为给定值创建一个ByteValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.CharType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.CharType

No usage of com.sun.jdi.CharType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.CharValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.CharValue

  • Packages that use CharValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of CharValue in com.sun.jdi

      Methods in com.sun.jdi that return CharValue
      Modifier and Type 方法 描述
      CharValue VirtualMachine.mirrorOf​(char value)
      为给定值创建一个CharValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ClassLoaderReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ClassLoaderReference

  • Packages that use ClassLoaderReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ClassLoaderReference in com.sun.jdi

      Methods in com.sun.jdi that return ClassLoaderReference
      Modifier and Type 方法 描述
      ClassLoaderReference ModuleReference.classLoader​()
      返回此模块的ClassLoaderReference对象。
      ClassLoaderReference ReferenceType.classLoader​()
      获取加载与此类型相对应的类的类加载器对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ClassObjectReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ClassObjectReference

  • Packages that use ClassObjectReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ClassObjectReference in com.sun.jdi

      Methods in com.sun.jdi that return ClassObjectReference
      Modifier and Type 方法 描述
      ClassObjectReference ReferenceType.classObject​()
      返回与目标VM中此类型对应的类对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ClassType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ClassType

  • Packages that use ClassType
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ClassType in com.sun.jdi

      Methods in com.sun.jdi that return ClassType
      Modifier and Type 方法 描述
      ClassType ClassType.superclass​()
      获取此类的超类。
      Methods in com.sun.jdi that return types with arguments of type ClassType
      Modifier and Type 方法 描述
      List<ClassType> InterfaceType.implementors​()
      获取直接实现此接口的当前准备的类。
      List<ClassType> ClassType.subclasses​()
      获取此类的当前加载的直接子类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.DoubleType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.DoubleType

No usage of com.sun.jdi.DoubleType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.DoubleValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.DoubleValue

  • Packages that use DoubleValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of DoubleValue in com.sun.jdi

      Methods in com.sun.jdi that return DoubleValue
      Modifier and Type 方法 描述
      DoubleValue VirtualMachine.mirrorOf​(double value)
      为给定值创建一个DoubleValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Field

  • Packages that use Field
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of Field in com.sun.jdi

      Methods in com.sun.jdi that return Field
      Modifier and Type 方法 描述
      Field ReferenceType.fieldByName​(String fieldName)
      找到具有给定非歧义名称的可见Field 。
      Methods in com.sun.jdi that return types with arguments of type Field
      Modifier and Type 方法 描述
      List<Field> ReferenceType.allFields​()
      返回包含此类型中声明的每个Field及其超类，已实现的接口和/或超级接口的列表。
      List<Field> ReferenceType.fields​()
      返回一个包含此类型声明的每个Field的列表。
      Map<Field,Value> ObjectReference.getValues​(List<? extends Field> fields)
      获取此对象中多个实例和/或静态字段的值。
      Map<Field,Value> ReferenceType.getValues​(List<? extends Field> fields)
      返回包含给定列表中每个静态Field的Value的地图。
      List<Field> ReferenceType.visibleFields​()
      返回一个列表，其中包含这种类型的每个未隐藏和明确的Field 。
      Methods in com.sun.jdi with parameters of type Field
      Modifier and Type 方法 描述
      Value ObjectReference.getValue​(Field sig)
      获取此对象中给定实例或静态字段的值。
      Value ReferenceType.getValue​(Field field)
      获取Value给定的静态Field这种类型。
      void ClassType.setValue​(Field field, Value value)
      为静态字段分配一个值。
      void ObjectReference.setValue​(Field field, Value value)
      设置此对象中给定实例或静态字段的值。
      Method parameters in com.sun.jdi with type arguments of type Field
      Modifier and Type 方法 描述
      Map<Field,Value> ObjectReference.getValues​(List<? extends Field> fields)
      获取此对象中多个实例和/或静态字段的值。
      Map<Field,Value> ReferenceType.getValues​(List<? extends Field> fields)
      返回包含给定列表中每个静态Field的Value的地图。

    • Uses of Field in com.sun.jdi.event

      Methods in com.sun.jdi.event that return Field
      Modifier and Type 方法 描述
      Field WatchpointEvent.field​()
      返回即将被访问/修改的字段。

    • Uses of Field in com.sun.jdi.request

      Methods in com.sun.jdi.request that return Field
      Modifier and Type 方法 描述
      Field WatchpointRequest.field​()
      获取该WatchpointRequest所关注的字段。
      Methods in com.sun.jdi.request with parameters of type Field
      Modifier and Type 方法 描述
      AccessWatchpointRequest EventRequestManager.createAccessWatchpointRequest​(Field field)
      创建一个新的禁用的观察点，监视对指定字段的访问。
      ModificationWatchpointRequest EventRequestManager.createModificationWatchpointRequest​(Field field)
      Creates a new disabled watchpoint which watches accesses to the specified field.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.FloatType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.FloatType

No usage of com.sun.jdi.FloatType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.FloatValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.FloatValue

  • Packages that use FloatValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of FloatValue in com.sun.jdi

      Methods in com.sun.jdi that return FloatValue
      Modifier and Type 方法 描述
      FloatValue VirtualMachine.mirrorOf​(float value)
      为给定值创建一个FloatValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.IntegerType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.IntegerType

No usage of com.sun.jdi.IntegerType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.IntegerValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.IntegerValue

  • Packages that use IntegerValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of IntegerValue in com.sun.jdi

      Methods in com.sun.jdi that return IntegerValue
      Modifier and Type 方法 描述
      IntegerValue VirtualMachine.mirrorOf​(int value)
      为给定值创建一个IntegerValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.InterfaceType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.InterfaceType

  • Packages that use InterfaceType
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of InterfaceType in com.sun.jdi

      Methods in com.sun.jdi that return types with arguments of type InterfaceType
      Modifier and Type 方法 描述
      List<InterfaceType> ClassType.allInterfaces​()
      获取由此类直接和间接实现的接口。
      List<InterfaceType> ClassType.interfaces​()
      获取由此类直接实现的接口。
      List<InterfaceType> InterfaceType.subinterfaces​()
      获取当前准备的接口，直接扩展该接口。
      List<InterfaceType> InterfaceType.superinterfaces​()
      获取此接口直接扩展的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.LocalVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.LocalVariable

  • Packages that use LocalVariable
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of LocalVariable in com.sun.jdi

      Methods in com.sun.jdi that return LocalVariable
      Modifier and Type 方法 描述
      LocalVariable StackFrame.visibleVariableByName​(String name)
      找到匹配给定名称的LocalVariable ，并在当前帧位置可见。
      Methods in com.sun.jdi that return types with arguments of type LocalVariable
      Modifier and Type 方法 描述
      List<LocalVariable> Method.arguments​()
      返回一个列表，其中包含声明为此方法参数的每个LocalVariable 。
      Map<LocalVariable,Value> StackFrame.getValues​(List<? extends LocalVariable> variables)
      返回此框架中多个局部变量的值。
      List<LocalVariable> Method.variables​()
      返回一个包含在此方法中声明的每个LocalVariable的列表。
      List<LocalVariable> Method.variablesByName​(String name)
      在此方法中返回包含给定名称的每个LocalVariable的列表。
      List<LocalVariable> StackFrame.visibleVariables​()
      返回一个包含可以从此框架的位置访问的每个LocalVariable的列表。
      Methods in com.sun.jdi with parameters of type LocalVariable
      Modifier and Type 方法 描述
      Value StackFrame.getValue​(LocalVariable variable)
      获取此框架中的LocalVariable的Value 。
      void StackFrame.setValue​(LocalVariable variable, Value value)
      在此框架中设置LocalVariable的Value 。
      Method parameters in com.sun.jdi with type arguments of type LocalVariable
      Modifier and Type 方法 描述
      Map<LocalVariable,Value> StackFrame.getValues​(List<? extends LocalVariable> variables)
      返回此框架中多个局部变量的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Locatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Locatable

  • Packages that use Locatable
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of Locatable in com.sun.jdi

      Subinterfaces of Locatable in com.sun.jdi
      Modifier and Type 接口 描述
      interface  方法
      目标VM中的静态或实例方法。
      interface  StackFrame
      线程调用堆栈上的一种方法调用的状态。

    • Uses of Locatable in com.sun.jdi.event

      Subinterfaces of Locatable in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  AccessWatchpointEvent
      通知目标VM中的现场访问。
      interface  BreakpointEvent
      通知目标VM中的断点。
      interface  ExceptionEvent
      通知目标VM中的异常。
      interface  LocatableEvent
      具有位置和线程的事件的抽象超界面。
      interface  MethodEntryEvent
      在目标虚拟机中通知方法调用。
      interface  MethodExitEvent
      在目标VM中返回方法的通知。
      interface  ModificationWatchpointEvent
      通知目标VM中的字段修改。
      interface  MonitorContendedEnteredEvent
      通知目标VM中的线程等待其他线程释放后进入监视器。
      interface  MonitorContendedEnterEvent
      通知目标虚拟机中的线程正在尝试进入已被另一个线程获取的监视器。
      interface  MonitorWaitedEvent
      通知目标VM中的线程已经完成等待监视器对象。
      interface  MonitorWaitEvent
      通知目标VM中的线程即将等待监视器对象。
      interface  StepEvent
      通知目标VM中的步骤完成。
      interface  WatchpointEvent
      通知目标VM中线程遇到的字段触发事件。

    • Uses of Locatable in com.sun.jdi.request

      Subinterfaces of Locatable in com.sun.jdi.request
      Modifier and Type 接口 描述
      interface  BreakpointRequest
      Identifies a Location in the target VM at which execution should be stopped.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Location (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Location

  • Packages that use Location
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of Location in com.sun.jdi

      Methods in com.sun.jdi that return Location
      Modifier and Type 方法 描述
      Location Locatable.location​()
      返回此镜像的Location ，如果有可执行代码与之相关联。
      Location Method.location​()
      返回此方法的Location ，如果有可执行代码与之相关联。
      Location StackFrame.location​()
      返回帧中当前指令的Location 。
      Location Method.locationOfCodeIndex​(long codeIndex)
      为给定的代码索引返回一个Location 。
      Methods in com.sun.jdi that return types with arguments of type Location
      Modifier and Type 方法 描述
      List<Location> Method.allLineLocations​()
      在此方法中，为每个可执行源行返回一个包含Location对象的列表。
      List<Location> Method.allLineLocations​(String stratum, String sourceName)
      在此方法中为每个可执行源行返回一个包含Location对象的列表。
      List<Location> ReferenceType.allLineLocations​()
      返回一个包含此参考类型中每个可执行源代码行的对象的列表，其中包含一个Location对象。
      List<Location> ReferenceType.allLineLocations​(String stratum, String sourceName)
      返回包含一个列表Location对该引用类型的每个可执行源极线对象。
      List<Location> Method.locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> Method.locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号和源名称的所有Location对象的列表。
      List<Location> ReferenceType.locationsOfLine​(int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。
      List<Location> ReferenceType.locationsOfLine​(String stratum, String sourceName, int lineNumber)
      返回包含映射到给定行号的所有Location对象的列表。

    • Uses of Location in com.sun.jdi.event

      Methods in com.sun.jdi.event that return Location
      Modifier and Type 方法 描述
      Location ExceptionEvent.catchLocation​()
      获取异常被捕获的位置。

    • Uses of Location in com.sun.jdi.request

      Methods in com.sun.jdi.request that return Location
      Modifier and Type 方法 描述
      Location BreakpointRequest.location​()
      返回请求断点的位置。
      Methods in com.sun.jdi.request with parameters of type Location
      Modifier and Type 方法 描述
      BreakpointRequest EventRequestManager.createBreakpointRequest​(Location location)
      创建一个新的禁用BreakpointRequest 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.LongType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.LongType

No usage of com.sun.jdi.LongType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.LongValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.LongValue

  • Packages that use LongValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of LongValue in com.sun.jdi

      Methods in com.sun.jdi that return LongValue
      Modifier and Type 方法 描述
      LongValue VirtualMachine.mirrorOf​(long value)
      为给定值创建一个LongValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Method (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Method

  • Packages that use 方法
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。

    • Uses of 方法 in com.sun.jdi

      Methods in com.sun.jdi that return 方法
      Modifier and Type 方法 描述
      方法 ClassType.concreteMethodByName​(String name, String signature)
      返回从该类可见的具有给定名称和签名的单个非抽象方法 。
      方法 Location.method​()
      获取包含此位置的方法。
      Methods in com.sun.jdi that return types with arguments of type 方法
      Modifier and Type 方法 描述
      List<方法> ReferenceType.allMethods​()
      返回包含此类型中声明的每个方法及其超类，已实现的接口和/或超级接口的列表。
      List<方法> ReferenceType.methods​()
      返回包含此类型直接声明的每个方法的列表。
      List<方法> ReferenceType.methodsByName​(String name)
      返回包含具有给定名称的每个可见的方法的列表。
      List<方法> ReferenceType.methodsByName​(String name, String signature)
      返回一个列表，其中包含具有给定名称和签名的每个可见的方法 。
      List<方法> ReferenceType.visibleMethods​()
      返回包含此类型声明或继承的每个方法的列表。
      Methods in com.sun.jdi with parameters of type 方法
      Modifier and Type 方法 描述
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      调用目标VM中指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      构造此类型的新实例，使用给定的构造方法目标VM。

    • Uses of 方法 in com.sun.jdi.event

      Methods in com.sun.jdi.event that return 方法
      Modifier and Type 方法 描述
      方法 MethodEntryEvent.method​()
      返回输入的方法。
      方法 MethodExitEvent.method​()
      返回退出的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Mirror (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Mirror

  • Packages that use Mirror
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of Mirror in com.sun.jdi

      Subinterfaces of Mirror in com.sun.jdi
      Modifier and Type 接口 描述
      interface  ArrayReference
      提供对目标虚拟机中数组对象及其组件的访问。
      interface  ArrayType
      提供对数组类的访问及其在目标虚拟机中的组件类型。
      interface  BooleanType
      在目标VM中访问的所有原始 boolean类型。
      interface  BooleanValue
      提供对目标VM中原始数据 boolean访问权限。
      interface  ByteType
      在目标VM中访问的所有原始字节值的类型。
      interface  ByteValue
      提供对目标虚拟机中基元 byte值的访问。
      interface  CharType
      在目标虚拟机中访问的所有原始字符值的类型。
      interface  CharValue
      提供对目标虚拟机 char语 char值的访问。
      interface  ClassLoaderReference
      来自目标VM的类加载器对象。
      interface  ClassObjectReference
      来自目标VM的java.lang.Class实例。
      interface  ClassType
      目标VM中的类的镜像。
      interface  DoubleType
      在目标VM中访问的所有原始双值的类型。
      interface  DoubleValue
      提供对目标VM double语 double值的访问。
      interface  Field
      目标VM中的类或实例变量。
      interface  FloatType
      在目标VM中访问的所有原始浮点值的类型。
      interface  FloatValue
      提供对目标VM float语 float值的访问。
      interface  IntegerType
      在目标VM中访问的所有原始 int类型。
      interface  IntegerValue
      提供对目标VM int语 int值的访问。
      interface  InterfaceType
      目标虚拟机中的接口的镜像。
      interface  LocalVariable
      目标VM中的局部变量。
      interface  Location
      目标VM的执行代码中的一个点。
      interface  LongType
      在目标虚拟机中访问的所有原始 long的类型 long 。
      interface  LongValue
      提供对目标VM long语 long值的访问。
      interface  方法
      目标VM中的静态或实例方法。
      interface  ModuleReference
      目标虚拟机中的一个模块。
      interface  MonitorInfo
      有关线程拥有的监视器的信息。
      interface  ObjectReference
      当前存在于目标VM中的对象。
      interface  PathSearchingVirtualMachine
      通过路径搜索类的虚拟机
      interface  PrimitiveType
      与目标VM中的非对象值相关联的类型。
      interface  PrimitiveValue
      分配给目标VM中的原始类型的字段或变量的值。
      interface  ReferenceType
      目标虚拟机中对象的类型。
      interface  ShortType
      在目标VM中访问的所有原语 short值的类型。
      interface  ShortValue
      提供对目标VM中原始值 short值的访问。
      interface  StackFrame
      线程调用堆栈上的一种方法调用的状态。
      interface  StringReference
      来自目标VM的字符串对象。
      interface  ThreadGroupReference
      来自目标VM的线程组对象。
      interface  ThreadReference
      来自目标VM的线程对象。
      interface  Type
      目标VM中类型的镜像。
      interface  TypeComponent
      在用户定义的类型（类或接口）内声明的实体。
      interface  Value
      目标VM中的值的镜像。
      interface  VirtualMachine
      用于调试的虚拟机。
      interface  VoidType
      在目标虚拟机中访问的所有原始 void类型。
      interface  VoidValue
      提供对目标VM void语 void值的访问。

    • Uses of Mirror in com.sun.jdi.event

      Subinterfaces of Mirror in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  AccessWatchpointEvent
      通知目标VM中的现场访问。
      interface  BreakpointEvent
      通知目标VM中的断点。
      interface  ClassPrepareEvent
      在目标虚拟机中通知类准备。
      interface  ClassUnloadEvent
      在目标VM中卸载类的通知。
      interface  Event
      调试器感兴趣的目标虚拟机中的一个事件。
      interface  EventQueue
      目标虚拟机的调试器事件管理器。
      interface  EventSet
      可以在给定时间由目标VirtualMachine创建几个Event个对象。
      interface  ExceptionEvent
      通知目标VM中的异常。
      interface  LocatableEvent
      具有位置和线程的事件的抽象超界面。
      interface  MethodEntryEvent
      在目标虚拟机中通知方法调用。
      interface  MethodExitEvent
      在目标VM中返回方法的通知。
      interface  ModificationWatchpointEvent
      通知目标VM中的字段修改。
      interface  MonitorContendedEnteredEvent
      通知目标VM中的线程等待其他线程释放后进入监视器。
      interface  MonitorContendedEnterEvent
      通知目标虚拟机中的线程正在尝试进入已被另一个线程获取的监视器。
      interface  MonitorWaitedEvent
      通知目标VM中的线程已经完成等待监视器对象。
      interface  MonitorWaitEvent
      通知目标VM中的线程即将等待监视器对象。
      interface  StepEvent
      通知目标VM中的步骤完成。
      interface  ThreadDeathEvent
      在目标虚拟机中通知已完成的线程。
      interface  ThreadStartEvent
      在目标虚拟机中通知新运行的线程。
      interface  VMDeathEvent
      目标VM终止通知。
      interface  VMDisconnectEvent
      断开目标VM的通知。
      interface  VMStartEvent
      通知初始化目标虚拟机。
      interface  WatchpointEvent
      通知目标VM中线程遇到的字段触发事件。

    • Uses of Mirror in com.sun.jdi.request

      Subinterfaces of Mirror in com.sun.jdi.request
      Modifier and Type 接口 描述
      interface  AccessWatchpointRequest
      在目标虚拟机中访问字段的内容时请求通知。
      interface  BreakpointRequest
      标识目标虚拟机中应停止执行的Location 。
      interface  ClassPrepareRequest
      在目标虚拟机中准备课程时请求通知。
      interface  ClassUnloadRequest
      在目标虚拟机中卸载类时请求通知。
      interface  EventRequest
      表示通知事件的请求。
      interface  EventRequestManager
      管理创建和删除EventRequest s。
      interface  ExceptionRequest
      在目标虚拟机发生异常时请求通知。
      interface  MethodEntryRequest
      在目标虚拟机中调用方法时请求通知。
      interface  MethodExitRequest
      当方法在目标虚拟机中返回时请求通知。
      interface  ModificationWatchpointRequest
      设置字段时请求通知。
      interface  MonitorContendedEnteredRequest
      在等待其他线程释放之后，请求目标VM中的线程通知进入监视器。
      interface  MonitorContendedEnterRequest
      请求在目标VM中尝试进入另一个线程已经获取的监视器的线程的通知。
      interface  MonitorWaitedRequest
      当目标虚拟机中的线程已经完成等待监视对象时，请求通知。
      interface  MonitorWaitRequest
      当目标虚拟机中的线程即将等待监视对象时，请求通知。
      interface  StepRequest
      在目标虚拟机中发生步骤时请求通知。
      interface  ThreadDeathRequest
      线程在目标虚拟机中终止时请求通知。
      interface  ThreadStartRequest
      线程在目标虚拟机中启动执行时请求通知。
      interface  VMDeathRequest
      当目标VM终止时请求通知。
      interface  WatchpointRequest
      标识正在观看的目标虚拟机中的Field 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ModuleReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ModuleReference

  • Packages that use ModuleReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ModuleReference in com.sun.jdi

      Methods in com.sun.jdi that return ModuleReference
      Modifier and Type 方法 描述
      default ModuleReference ReferenceType.module​()
      获取包含与此类型对应的类的模块对象。
      Methods in com.sun.jdi that return types with arguments of type ModuleReference
      Modifier and Type 方法 描述
      default List<ModuleReference> VirtualMachine.allModules​()
      返回所有模块。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.MonitorInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.MonitorInfo

  • Packages that use MonitorInfo
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of MonitorInfo in com.sun.jdi

      Methods in com.sun.jdi that return types with arguments of type MonitorInfo
      Modifier and Type 方法 描述
      List<MonitorInfo> ThreadReference.ownedMonitorsAndFrames​()
      返回一个包含线程所拥有的每个监视器的一个MonitorInfo对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ObjectReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ObjectReference

  • Packages that use ObjectReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ObjectReference in com.sun.jdi

      Subinterfaces of ObjectReference in com.sun.jdi
      Modifier and Type 接口 描述
      interface  ArrayReference
      提供对目标虚拟机中数组对象及其组件的访问。
      interface  ClassLoaderReference
      来自目标VM的类加载器对象。
      interface  ClassObjectReference
      来自目标VM的java.lang.Class实例。
      interface  ModuleReference
      目标虚拟机中的一个模块。
      interface  StringReference
      来自目标VM的字符串对象。
      interface  ThreadGroupReference
      来自目标VM的线程组对象。
      interface  ThreadReference
      来自目标VM的线程对象。
      Methods in com.sun.jdi that return ObjectReference
      Modifier and Type | 方法 | 描述
      ObjectReference ThreadReference.currentContendedMonitor​()
      返回一个ObjectReference的监视器，如果有的话，这个线程当前正在等待。
      ObjectReference | InvocationException.exception​()
      ObjectReference MonitorInfo.monitor​()
      返回显示器的ObjectReference对象。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      构造此类型的新实例，使用给定的构造方法目标VM。
      ObjectReference StackFrame.thisObject​()
      返回当前帧的“this”值。
      Methods in com.sun.jdi that return types with arguments of type ObjectReference
      Modifier and Type 方法 描述
      List<ObjectReference> ReferenceType.instances​(long maxInstances)
      返回此ReferenceType的实例。
      List<ObjectReference> ThreadReference.ownedMonitors​()
      返回一个列表，其中包含线程拥有的每个监视器的一个ObjectReference 。
      List<ObjectReference> ObjectReference.referringObjects​(long maxReferrers)
      返回直接引用此对象的对象。
      Methods in com.sun.jdi with parameters of type ObjectReference
      Modifier and Type 方法 描述
      void ThreadReference.stop​(ObjectReference throwable)
      停止此线程与异步异常。
      Constructors in com.sun.jdi with parameters of type ObjectReference
      Constructor 描述
      InvocationException​(ObjectReference exception)

    • Uses of ObjectReference in com.sun.jdi.event

      Methods in com.sun.jdi.event that return ObjectReference
      Modifier and Type 方法 描述
      ObjectReference ExceptionEvent.exception​()
      获取抛出的异常对象。
      ObjectReference MonitorContendedEnteredEvent.monitor​()
      返回输入的监视器。
      ObjectReference MonitorContendedEnterEvent.monitor​()
      返回输入的方法。
      ObjectReference MonitorWaitedEvent.monitor​()
      返回此线程等待的监视器对象。
      ObjectReference MonitorWaitEvent.monitor​()
      返回线程要等待的监视器对象。
      ObjectReference WatchpointEvent.object​()
      返回字段即将被访问/修改的对象。

    • Uses of ObjectReference in com.sun.jdi.request

      Methods in com.sun.jdi.request with parameters of type ObjectReference
      Modifier and Type 方法 描述
      void BreakpointRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例是指定对象的事件。
      void ExceptionRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void MethodEntryRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void MethodExitRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void MonitorContendedEnteredRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void MonitorContendedEnterRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void MonitorWaitedRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void MonitorWaitRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void StepRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void WatchpointRequest.addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.PathSearchingVirtualMachine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.PathSearchingVirtualMachine

No usage of com.sun.jdi.PathSearchingVirtualMachine
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.PrimitiveType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.PrimitiveType

  • Packages that use PrimitiveType
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of PrimitiveType in com.sun.jdi

      Subinterfaces of PrimitiveType in com.sun.jdi
      Modifier and Type 接口 描述
      interface  BooleanType
      在目标VM中访问的所有原语 boolean值的类型。
      interface  ByteType
      在目标VM中访问的所有原始字节值的类型。
      interface  CharType
      在目标虚拟机中访问的所有原始字符值的类型。
      interface  DoubleType
      在目标VM中访问的所有原始双值的类型。
      interface  FloatType
      在目标VM中访问的所有原始浮点值的类型。
      interface  IntegerType
      在目标VM中访问的所有原语 int值的类型。
      interface  LongType
      在目标虚拟机中访问的所有原始 long类型为 long 。
      interface  ShortType
      在目标虚拟机中访问的所有原始 short类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.PrimitiveValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.PrimitiveValue

  • Packages that use PrimitiveValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of PrimitiveValue in com.sun.jdi

      Subinterfaces of PrimitiveValue in com.sun.jdi
      Modifier and Type 接口 描述
      interface  BooleanValue
      提供对目标VM boolean语 boolean值的访问。
      interface  ByteValue
      提供对目标VM中原始值 byte值的访问。
      interface  CharValue
      提供对目标虚拟机 char语 char值的访问。
      interface  DoubleValue
      提供对目标VM double语 double值的访问。
      interface  FloatValue
      提供对目标虚拟机中原始值 float值的访问。
      interface  IntegerValue
      提供对目标VM中的基元 int值的访问。
      interface  LongValue
      提供对目标虚拟机 long语 long值的访问。
      interface  ShortValue
      提供对目标虚拟机中基元 short值的访问。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ReferenceType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ReferenceType

  • Packages that use ReferenceType
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of ReferenceType in com.sun.jdi

      Subinterfaces of ReferenceType in com.sun.jdi
      Modifier and Type 接口 描述
      interface  ArrayType
      提供对数组类的访问及其在目标虚拟机中的组件类型。
      interface  ClassType
      目标VM中的类的镜像。
      interface  InterfaceType
      目标虚拟机中的接口的镜像。
      Methods in com.sun.jdi that return ReferenceType
      Modifier and Type 方法 描述
      ReferenceType Location.declaringType​()
      获取此位置所属的类型。
      ReferenceType TypeComponent.declaringType​()
      返回声明此组件的类型。
      ReferenceType ObjectReference.referenceType​()
      获取镜像该对象的类型的ReferenceType 。
      ReferenceType ClassObjectReference.reflectedType​()
      返回与此类对象相对应的ReferenceType 。
      Methods in com.sun.jdi that return types with arguments of type ReferenceType
      Modifier and Type 方法 描述
      List<ReferenceType> VirtualMachine.allClasses​()
      返回所有加载的类型。
      List<ReferenceType> VirtualMachine.classesByName​(String className)
      返回与给定名称相匹配的加载引用类型。
      List<ReferenceType> ClassLoaderReference.definedClasses​()
      返回由此类加载器定义的所有加载类的列表。
      List<ReferenceType> ReferenceType.nestedTypes​()
      返回一个包含ReferenceType对象的列表， 该对象在此类型中被声明，并且当前被加载到虚拟机中。
      List<ReferenceType> ClassLoaderReference.visibleClasses​()
      返回此类加载器已被记录为目标VM中的启动加载程序的所有类的列表。
      Method parameters in com.sun.jdi with type arguments of type ReferenceType
      Modifier and Type 方法 描述
      long[] VirtualMachine.instanceCounts​(List<? extends ReferenceType> refTypes)
      返回“refTypes”列表中每个ReferenceType的实例数。
      void VirtualMachine.redefineClasses​(Map<? extends ReferenceType,byte[]> classToBytes)
      根据提供的定义重新定义所有给定的类。

    • Uses of ReferenceType in com.sun.jdi.event

      Methods in com.sun.jdi.event that return ReferenceType
      Modifier and Type 方法 描述
      ReferenceType ClassPrepareEvent.referenceType​()
      返回生成此事件的引用类型。

    • Uses of ReferenceType in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ReferenceType
      Modifier and Type 方法 描述
      ReferenceType ExceptionRequest.exception​()
      返回异常事件被请求的异常类型。
      Methods in com.sun.jdi.request with parameters of type ReferenceType
      Modifier and Type 方法 描述
      void ClassPrepareRequest.addClassFilter​(ReferenceType refType)
      限制此请求生成的事件，作为给定引用类型和任何子类型的准备。
      void ExceptionRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
      void MethodEntryRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void MethodExitRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void MonitorContendedEnteredRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void MonitorContendedEnterRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void MonitorWaitedRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
      void MonitorWaitRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
      void StepRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
      void WatchpointRequest.addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
      ExceptionRequest EventRequestManager.createExceptionRequest​(ReferenceType refType, boolean notifyCaught, boolean notifyUncaught)
      创建一个新的禁用ExceptionRequest 。

    • Uses of ReferenceType in jdk.jshell.execution

      Methods in jdk.jshell.execution that return ReferenceType
      Modifier and Type 方法 描述
      protected ReferenceType JdiExecutionControl.referenceType​(VirtualMachine vm, String name)
      返回对应于指定类名的JDI ReferenceType 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ShortType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ShortType

No usage of com.sun.jdi.ShortType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ShortValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ShortValue

  • Packages that use ShortValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ShortValue in com.sun.jdi

      Methods in com.sun.jdi that return ShortValue
      Modifier and Type 方法 描述
      ShortValue VirtualMachine.mirrorOf​(short value)
      为给定值创建一个ShortValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.StackFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.StackFrame

  • Packages that use StackFrame
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of StackFrame in com.sun.jdi

      Methods in com.sun.jdi that return StackFrame
      Modifier and Type 方法 描述
      StackFrame ThreadReference.frame​(int index)
      返回线程当前调用堆栈中给定索引的StackFrame 。
      Methods in com.sun.jdi that return types with arguments of type StackFrame
      Modifier and Type 方法 描述
      List<StackFrame> ThreadReference.frames​()
      返回包含线程当前调用堆栈中的每个StackFrame的列表。
      List<StackFrame> ThreadReference.frames​(int start, int length)
      从线程的当前调用堆栈返回一个包含一个范围为StackFrame个镜像的列表。
      Methods in com.sun.jdi with parameters of type StackFrame
      Modifier and Type 方法 描述
      boolean LocalVariable.isVisible​(StackFrame frame)
      确定是否可以从给定的StackFrame访问此变量。
      void ThreadReference.popFrames​(StackFrame frame)
      弹出框架。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.StringReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.StringReference

  • Packages that use StringReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of StringReference in com.sun.jdi

      Methods in com.sun.jdi that return StringReference
      Modifier and Type 方法 描述
      StringReference VirtualMachine.mirrorOf​(String value)
      在此虚拟机中创建一个字符串。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ThreadGroupReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ThreadGroupReference

  • Packages that use ThreadGroupReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ThreadGroupReference in com.sun.jdi

      Methods in com.sun.jdi that return ThreadGroupReference
      Modifier and Type 方法 描述
      ThreadGroupReference ThreadGroupReference.parent​()
      返回此线程组的父级。
      ThreadGroupReference ThreadReference.threadGroup​()
      返回此线程的线程组。
      Methods in com.sun.jdi that return types with arguments of type ThreadGroupReference
      Modifier and Type 方法 描述
      List<ThreadGroupReference> ThreadGroupReference.threadGroups​()
      返回一个包含此线程组中每个活动ThreadGroupReference的列表。
      List<ThreadGroupReference> VirtualMachine.topLevelThreadGroups​()
      返回没有父级的每个线程组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.ThreadReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.ThreadReference

  • Packages that use ThreadReference
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ThreadReference in com.sun.jdi

      Methods in com.sun.jdi that return ThreadReference
      Modifier and Type 方法 描述
      ThreadReference ObjectReference.owningThread​()
      返回一个ThreadReference的线程，如果有的话，它当前拥有该对象的显示器。
      ThreadReference MonitorInfo.thread​()
      为拥有该监视器的线程返回一个ThreadReference对象。
      ThreadReference StackFrame.thread​()
      返回运行此框架的方法的线程。
      Methods in com.sun.jdi that return types with arguments of type ThreadReference
      Modifier and Type 方法 描述
      List<ThreadReference> VirtualMachine.allThreads​()
      返回当前正在运行的线程的列表。
      List<ThreadReference> ThreadGroupReference.threads​()
      返回一个列表，该列表包含此线程组中每个活动线程的一个ThreadReference 。
      List<ThreadReference> ObjectReference.waitingThreads​()
      返回一个列表，其中包含当前正在等待此对象的显示器的每个线程的一个ThreadReference 。
      Methods in com.sun.jdi with parameters of type ThreadReference
      Modifier and Type 方法 描述
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      构造此类型的新实例，使用给定的构造方法目标VM。

    • Uses of ThreadReference in com.sun.jdi.event

      Methods in com.sun.jdi.event that return ThreadReference
      Modifier and Type 方法 描述
      ThreadReference ClassPrepareEvent.thread​()
      返回发生此事件的线程。
      ThreadReference LocatableEvent.thread​()
      返回发生此事件的线程。
      ThreadReference MonitorContendedEnteredEvent.thread​()
      返回发生此事件的线程。
      ThreadReference MonitorContendedEnterEvent.thread​()
      返回发生此事件的线程。
      ThreadReference MonitorWaitedEvent.thread​()
      返回发生此事件的线程。
      ThreadReference MonitorWaitEvent.thread​()
      返回发生监视等待事件的线程。
      ThreadReference ThreadDeathEvent.thread​()
      返回正在终止的线程。
      ThreadReference ThreadStartEvent.thread​()
      返回已经启动的线程。
      ThreadReference VMStartEvent.thread​()
      返回已启动的VM的初始线程。

    • Uses of ThreadReference in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ThreadReference
      Modifier and Type | 方法 | 描述
      ThreadReference | StepRequest.thread​()
      Methods in com.sun.jdi.request with parameters of type ThreadReference
      Modifier and Type 方法 描述
      void BreakpointRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void ExceptionRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void MethodEntryRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void MethodExitRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void MonitorContendedEnteredRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void MonitorContendedEnterRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void MonitorWaitedRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void MonitorWaitRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void ThreadDeathRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void ThreadStartRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      void WatchpointRequest.addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      StepRequest EventRequestManager.createStepRequest​(ThreadReference thread, int size, int depth)
      创建一个新的残疾人StepRequest 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Type

  • Packages that use Type
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of Type in com.sun.jdi

      Subinterfaces of Type in com.sun.jdi
      Modifier and Type 接口 描述
      interface  ArrayType
      提供对数组类的访问及其在目标虚拟机中的组件类型。
      interface  BooleanType
      在目标VM中访问的所有原始 boolean类型。
      interface  ByteType
      在目标VM中访问的所有原始字节值的类型。
      interface  CharType
      在目标虚拟机中访问的所有原始字符值的类型。
      interface  ClassType
      目标VM中的类的镜像。
      interface  DoubleType
      在目标VM中访问的所有原始双值的类型。
      interface  FloatType
      在目标VM中访问的所有原始浮点值的类型。
      interface  IntegerType
      在目标虚拟机中访问的所有原始 int类型。
      interface  InterfaceType
      目标虚拟机中的接口的镜像。
      interface  LongType
      在目标VM中访问的所有原语 long值的类型。
      interface  PrimitiveType
      与目标VM中的非对象值相关联的类型。
      interface  ReferenceType
      目标虚拟机中对象的类型。
      interface  ShortType
      在目标VM中访问的所有原始 short类型。
      interface  VoidType
      在目标虚拟机中访问的所有原始 void类型为 void 。
      Methods in com.sun.jdi that return Type
      Modifier and Type 方法 描述
      Type ArrayType.componentType​()
      返回数组声明中指定的该数组的组件类型。
      Type Method.returnType​()
      返回返回类型，如该方法的声明所指定。
      Type Field.type​()
      返回此字段的类型。
      Type LocalVariable.type​()
      返回此变量的类型。
      Type Value.type​()
      返回此值的运行时类型。
      Methods in com.sun.jdi that return types with arguments of type Type
      Modifier and Type 方法 描述
      List<Type> Method.argumentTypes​()
      返回一个包含此方法的每个形式参数类型的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.TypeComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.TypeComponent

  • Packages that use TypeComponent
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of TypeComponent in com.sun.jdi

      Subinterfaces of TypeComponent in com.sun.jdi
      Modifier and Type 接口 描述
      interface  Field
      目标VM中的类或实例变量。
      interface  方法
      目标VM中的静态或实例方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.Value (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.Value

  • Packages that use Value
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。

    • Uses of Value in com.sun.jdi

      Subinterfaces of Value in com.sun.jdi
      Modifier and Type 接口 描述
      interface  ArrayReference
      提供对目标虚拟机中数组对象及其组件的访问。
      interface  BooleanValue
      提供对目标VM boolean语 boolean值的访问。
      interface  ByteValue
      提供对目标虚拟机 byte语 byte值的访问。
      interface  CharValue
      提供对目标虚拟机 char语 char值的访问。
      interface  ClassLoaderReference
      来自目标VM的类加载器对象。
      interface  ClassObjectReference
      来自目标VM的java.lang.Class实例。
      interface  DoubleValue
      提供对目标VM中原始值 double访问。
      interface  FloatValue
      提供对目标虚拟机 float语 float值的访问。
      interface  IntegerValue
      提供对目标VM int语 int值的访问。
      interface  LongValue
      提供对目标VM long语 long值的访问。
      interface  ModuleReference
      目标虚拟机中的一个模块。
      interface  ObjectReference
      当前存在于目标VM中的对象。
      interface  PrimitiveValue
      分配给目标VM中的原始类型的字段或变量的值。
      interface  ShortValue
      提供对目标虚拟机 short语 short值的访问。
      interface  StringReference
      来自目标VM的字符串对象。
      interface  ThreadGroupReference
      来自目标VM的线程组对象。
      interface  ThreadReference
      来自目标VM的线程对象。
      interface  VoidValue
      提供对目标VM中原始值 void值的访问。
      Methods in com.sun.jdi that return Value
      Modifier and Type 方法 描述
      Value ArrayReference.getValue​(int index)
      返回数组组件值。
      Value ObjectReference.getValue​(Field sig)
      获取此对象中给定实例或静态字段的值。
      Value ReferenceType.getValue​(Field field)
      获取Value给定的静态Field这种类型。
      Value StackFrame.getValue​(LocalVariable variable)
      获取此框架中的LocalVariable的Value 。
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标VM中调用指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标VM中调用此对象上指定的方法 。
      Methods in com.sun.jdi that return types with arguments of type Value
      Modifier and Type 方法 描述
      List<Value> StackFrame.getArgumentValues​()
      返回此框架中所有参数的值。
      List<Value> ArrayReference.getValues​()
      返回此数组中的所有组件。
      List<Value> ArrayReference.getValues​(int index, int length)
      返回一系列数组组件。
      Map<Field,Value> ObjectReference.getValues​(List<? extends Field> fields)
      获取此对象中多个实例和/或静态字段的值。
      Map<Field,Value> ReferenceType.getValues​(List<? extends Field> fields)
      返回包含给定列表中每个静态Field的Value的地图。
      Map<LocalVariable,Value> StackFrame.getValues​(List<? extends LocalVariable> variables)
      返回此框架中多个局部变量的值。
      Methods in com.sun.jdi with parameters of type Value
      Modifier and Type 方法 描述
      void ThreadReference.forceEarlyReturn​(Value value)
      强制一个方法在返回到返回语句之前返回。
      void ArrayReference.setValue​(int index, Value value)
      用另一个值替换数组组件。
      void ClassType.setValue​(Field field, Value value)
      为静态字段分配一个值。
      void ObjectReference.setValue​(Field field, Value value)
      设置此对象中给定实例或静态字段的值。
      void StackFrame.setValue​(LocalVariable variable, Value value)
      在此框架中设置270444408692165的270444408692955 。
      Method parameters in com.sun.jdi with type arguments of type Value
      Modifier and Type 方法 描述
      Value ClassType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      default Value InterfaceType.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标虚拟机中调用指定的静态方法 。
      Value ObjectReference.invokeMethod​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      在目标VM中调用此对象上指定的方法 。
      ObjectReference ClassType.newInstance​(ThreadReference thread, 方法 method, List<? extends Value> arguments, int options)
      构造此类型的新实例，使用给定的构造方法目标VM。
      void ArrayReference.setValues​(int index, List<? extends Value> values, int srcIndex, int length)
      用其他值替换一系列阵列组件。
      void ArrayReference.setValues​(List<? extends Value> values)
      用其他值替换所有数组组件。

    • Uses of Value in com.sun.jdi.event

      Methods in com.sun.jdi.event that return Value
      Modifier and Type 方法 描述
      Value MethodExitEvent.returnValue​()
      返回该方法将返回的值。
      Value WatchpointEvent.valueCurrent​()
      现场值。
      Value ModificationWatchpointEvent.valueToBe​()
      当指令完成时将分配给该字段的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.VirtualMachine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.VirtualMachine

  • Packages that use VirtualMachine
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of VirtualMachine in com.sun.jdi

      Subinterfaces of VirtualMachine in com.sun.jdi
      Modifier and Type 接口 描述
      interface  PathSearchingVirtualMachine
      通过路径搜索类的虚拟机
      Methods in com.sun.jdi that return VirtualMachine
      Modifier and Type 方法 描述
      VirtualMachine VirtualMachineManager.createVirtualMachine​(Connection connection)
      创建一个新的虚拟机。
      VirtualMachine VirtualMachineManager.createVirtualMachine​(Connection connection, Process process)
      为目标虚拟机创建虚拟机镜像。
      VirtualMachine Mirror.virtualMachine​()
      获取此镜像所属的VirtualMachine。
      Methods in com.sun.jdi that return types with arguments of type VirtualMachine
      Modifier and Type 方法 描述
      List<VirtualMachine> VirtualMachineManager.connectedVirtualMachines​()
      列出连接到调试器的所有目标虚拟机。

    • Uses of VirtualMachine in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that return VirtualMachine
      Modifier and Type 方法 描述
      VirtualMachine ListeningConnector.accept​(Map<String,? extends Connector.Argument> arguments)
      等待目标VM附加到此连接器。
      VirtualMachine AttachingConnector.attach​(Map<String,? extends Connector.Argument> arguments)
      附加到正在运行的应用程序并返回其虚拟机的镜像。
      VirtualMachine LaunchingConnector.launch​(Map<String,? extends Connector.Argument> arguments)
      启动应用程序并连接到其VM。

    • Uses of VirtualMachine in jdk.jshell.execution

      Methods in jdk.jshell.execution that return VirtualMachine
      Modifier and Type | 方法 | 描述
      protected VirtualMachine | JdiDefaultExecutionControl.vm​()
      protected abstract VirtualMachine JdiExecutionControl.vm​()
      返回JDI VirtualMachine实例。
      VirtualMachine JdiInitiator.vm​()
      返回产生的 VirtualMachine实例。
      Methods in jdk.jshell.execution with parameters of type VirtualMachine
      Modifier and Type 方法 描述
      static void Util.detectJdiExitEvent​(VirtualMachine vm, Consumer<String> unbiddenExitHandler)
      监控JDI事件流VMDeathEvent和VMDisconnectEvent 。
      protected ReferenceType JdiExecutionControl.referenceType​(VirtualMachine vm, String name)
      返回对应于指定类名的JDI ReferenceType 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.VirtualMachineManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.VirtualMachineManager

  • Packages that use VirtualMachineManager
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of VirtualMachineManager in com.sun.jdi

      Methods in com.sun.jdi that return VirtualMachineManager
      Modifier and Type 方法 描述
      static VirtualMachineManager Bootstrap.virtualMachineManager​()
      返回虚拟机管理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.VoidType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.VoidType

No usage of com.sun.jdi.VoidType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.VoidValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.VoidValue

  • Packages that use VoidValue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of VoidValue in com.sun.jdi

      Methods in com.sun.jdi that return VoidValue
      Modifier and Type 方法 描述
      VoidValue VirtualMachine.mirrorOfVoid​()
      创建一个VoidValue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AttachingConnector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface AttachingConnector

  • All Superinterfaces:
    Connector

    public interface AttachingConnector
extends Connector
    连接到以前运行的目标VM的连接器。
    从以下版本开始：
    1.3

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.jdi.connect.Connector

        Connector.Argument, Connector.BooleanArgument, Connector.IntegerArgument, Connector.SelectedArgument, Connector.StringArgument

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      VirtualMachine attach​(Map<String,? extends Connector.Argument> arguments)
      附加到正在运行的应用程序并返回其虚拟机的镜像。

      • Methods inherited from interface com.sun.jdi.connect.Connector

        defaultArguments, description, name, transport

    • 方法详细信息

      • attach

        VirtualMachine attach​(Map<String,? extends Connector.Argument> arguments)
               throws IOException,
                      IllegalConnectorArgumentsException
        附加到正在运行的应用程序并返回其虚拟机的镜像。

        连接器在附加应用程序时使用给定的参数映射。 这些参数将包括识别VM的寻址信息。 参数映射将参数名称字符串与Connector.Argument的实例相关联。 连接器的默认参数图可以通过Connector.defaultArguments()获得。 可以更改参数映射值，但不应添加或删除映射条目。

        参数
        arguments - 用于启动VM的参数映射。
        结果
        目标虚拟机的VirtualMachine镜像。
        异常
        TransportTimeoutException - 当连接器封装在附加时支持超时的传输时，在参数映射中设置了表示超时的Connector.Argument ，并且尝试附加到目标VM时发生超时。
        IOException - 何时无法附加。 具体的异常取决于使用中的Connector实现。
        IllegalConnectorArgumentsException - 其中一个连接器参数无效时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.jdi.connect (Java SE 9 & JDK 9 )

com.sun.jdi.connect

Interfaces

  • AttachingConnector
  • Connector
  • Connector.Argument
  • Connector.BooleanArgument
  • Connector.IntegerArgument
  • Connector.SelectedArgument
  • Connector.StringArgument
  • LaunchingConnector
  • ListeningConnector
  • Transport

Exceptions

  • IllegalConnectorArgumentsException
  • TransportTimeoutException
  • VMStartException


com.sun.jdi.connect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.jdi

Package com.sun.jdi.connect

该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。 与VirtualMachineManager协调一致是启动，附加等目标虚拟机的机制。

方法可能会在以后的版本中添加到JDI包中的接口。 如果JDI成为标准扩展名，则可能会重命名现有的包。

  • 接口摘要
    接口 描述
    AttachingConnector
    连接到以前运行的目标VM的连接器。
    Connector
    调试器和目标VM之间的连接方法。
    Connector.Argument
    Connector参数的规范和值。
    Connector.BooleanArgument
    Connector参数的规范和值，其值为布尔值。
    Connector.IntegerArgument
    Connector参数的规格和值，其值为整数。
    Connector.SelectedArgument
    Connector参数的规范和值，其值是从选择列表中选择的String。
    Connector.StringArgument
    Connector参数的规范和值，其值为String。
    LaunchingConnector
    连接前可以启动目标虚拟机的连接器。
    ListeningConnector
    侦听由目标虚拟机启动的连接的连接器。
    Transport
    调试器和目标VM之间的通信方法。
  • 异常摘要
    异常 描述
    IllegalConnectorArgumentsException
    抛出表示无效的参数或不一致传递给Connector 。
    TransportTimeoutException
    当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。
    VMStartException
    目标VM已成功启动，但在建立连接之前会发生错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.jdi.connect Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.jdi.connect

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • com.sun.jdi.connect.IllegalConnectorArgumentsException
        • java.io.IOException
          • com.sun.jdi.connect.TransportTimeoutException
        • com.sun.jdi.connect.VMStartException

Interface Hierarchy

  • com.sun.jdi.connect.Connector
    • com.sun.jdi.connect.AttachingConnector
    • com.sun.jdi.connect.LaunchingConnector
    • com.sun.jdi.connect.ListeningConnector
  • java.io.Serializable
    • com.sun.jdi.connect.Connector.Argument
      • com.sun.jdi.connect.Connector.BooleanArgument
      • com.sun.jdi.connect.Connector.IntegerArgument
      • com.sun.jdi.connect.Connector.SelectedArgument
      • com.sun.jdi.connect.Connector.StringArgument
  • com.sun.jdi.connect.Transport
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Connector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface Connector

  • All Known Subinterfaces:
    AttachingConnector ， LaunchingConnector ， ListeningConnector

    public interface Connector
    调试器和目标VM之间的连接方法。 一个连接器只封装一个Transport 。 用于建立连接。 每个连接器都有一组控制其操作的参数。 参数存储为一个由字符串键入的地图。 每个实现定义它接受的字符串参数键。
    从以下版本开始：
    1.3
    另请参见：
    LaunchingConnector ， AttachingConnector ， ListeningConnector ， Connector.Argument

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  Connector.Argument
      Connector参数的规范和值。
      static interface  Connector.BooleanArgument
      Connector参数的规范和值，其值为布尔值。
      static interface  Connector.IntegerArgument
      Connector参数的规格和值，其值为整数。
      static interface  Connector.SelectedArgument
      Connector参数的规范和值，其值是从选择列表中选择的String。
      static interface  Connector.StringArgument
      Connector参数的规范和值，其值为String。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Map<String,Connector.Argument> defaultArguments​()
      返回此连接器接受的参数及其默认值。
      String description​()
      返回此连接器的可读描述及其目的。
      String name​()
      返回连接器的短标识符。
      Transport transport​()
      返回此连接器用于建立与目标VM的连接的传输机制。

    • 方法详细信息

      • name

        String name​()
        返回连接器的短标识符。 连接器实现者应遵循与包一起使用的类似的命名约定，以避免名称冲突。 例如，Sun连接器实现的名称前缀为“com.sun.jdi”。 不适合接触最终用户。
        结果
        该连接器的名称。

      • description

        String description​()
        返回此连接器的可读描述及其目的。
        结果
        该连接器的描述

      • transport

        Transport transport​()
        返回此连接器用于建立与目标VM的连接的传输机制。
        结果
        该连接器使用的Transport 。

      • defaultArguments

        Map<String,Connector.Argument> defaultArguments​()
        返回此连接器接受的参数及其默认值。 返回地图的键是字符串参数名称。 值为Connector.Argument，其中包含有关参数及其默认值的信息。
        结果
        映射将参数名称与参数信息和默认值相关联。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Connector.Argument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface Connector.Argument

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    Connector.BooleanArgument ， Connector.IntegerArgument ， Connector.SelectedArgument ， Connector.StringArgument
    Enclosing interface:
    Connector

    public static interface Connector.Argument
extends Serializable
    Connector参数的规范和值。 将始终贯彻参数的子接口： Connector.StringArgument ， Connector.BooleanArgument ， Connector.IntegerArgument ，或Connector.SelectedArgument 。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String description​()
      返回该参数及其目的的可读描述。
      boolean isValid​(String value)
      对参数进行基本的理性检查。
      String label​()
      为此参数返回一个简短的可读标签。
      boolean mustSpecify​()
      指示是否必须指定参数。
      String name​()
      返回参数的简短唯一标识符。
      void setValue​(String value)
      设置参数的值。
      String value​()
      返回参数的当前值。

    • 方法详细信息

      • name

        String name​()
        返回参数的简短唯一标识符。 不适合接触最终用户。
        结果
        这个参数的名字。

      • label

        String label​()
        为此参数返回一个简短的可读标签。
        结果
        这个参数的标签

      • description

        String description​()
        返回该参数及其目的的可读描述。
        结果
        这个论点的描述

      • value

        String value​()
        返回参数的当前值。 最初，返回默认值。 如果当前未指定该值，则返回null。
        结果
        参数的当前值。

      • setValue

        void setValue​(String value)
        设置参数的值。 该值应在设置前用isValid(String)进行检查; 连接建立时，无效值会引发异常 - 例如LaunchingConnector.launch(java.util.Map<java.lang.String, ? extends com.sun.jdi.connect.Connector.Argument>)

      • isValid

        boolean isValid​(String value)
        对参数进行基本的理性检查。
        结果
        true如果该值在 setValue(String)中有效

      • mustSpecify

        boolean mustSpecify​()
        指示是否必须指定参数。 如果为true， 则在建立连接之前使用此参数，必须使用setValue(java.lang.String)设置非空值。
        结果
        true如果必须指定参数; false否则。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Connector.BooleanArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface Connector.BooleanArgument

  • All Superinterfaces:
    Connector.Argument ， Serializable
    Enclosing interface:
    Connector

    public static interface Connector.BooleanArgument
extends Connector.Argument
    Connector参数的规范和值，其值为布尔值。 布尔值由字符串“true”和“false”的本地化版本表示。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean booleanValue​()
      将参数的值作为布尔值返回。
      boolean isValid​(String value)
      对参数进行基本的理性检查。
      void setValue​(boolean value)
      设置参数的值。
      String stringValueOf​(boolean value)
      返回 value参数的字符串表示形式。

      • Methods inherited from interface com.sun.jdi.connect.Connector.Argument

        description, label, mustSpecify, name, setValue, value

    • 方法详细信息

      • setValue

        void setValue​(boolean value)
        设置参数的值。

      • isValid

        boolean isValid​(String value)
        对参数进行基本的理性检查。
        Specified by:
        isValid在接口 Connector.Argument
        结果
        true如果value是布尔值的字符串表示形式。
        另请参见：
        stringValueOf(boolean)

      • stringValueOf

        String stringValueOf​(boolean value)
        返回value参数的字符串表示形式。 不设置或检查当前值this实例。
        结果
        布尔值的本地化的String表示形式。

      • booleanValue

        boolean booleanValue​()
        将参数的值作为布尔值返回。 由于参数可能未设置或可能具有无效值isValid(String)应在Connector.Argument.value()上调用以检查其有效性。 如果无效，则此方法返回的布尔值是未定义的。
        结果
        参数的值为布尔值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Connector.IntegerArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface Connector.IntegerArgument

  • All Superinterfaces:
    Connector.Argument ， Serializable
    Enclosing interface:
    Connector

    public static interface Connector.IntegerArgument
extends Connector.Argument
    Connector参数的规格和值，其值为整数。 整数值由其相应的字符串表示。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int intValue​()
      将参数的值作为int返回。
      boolean isValid​(int value)
      对参数进行基本的理性检查。
      boolean isValid​(String value)
      对参数进行基本的理性检查。
      int max​()
      值的上限。
      int min​()
      价值的下限。
      void setValue​(int value)
      设置参数的值。
      String stringValueOf​(int value)
      返回 value参数的字符串表示形式。

      • Methods inherited from interface com.sun.jdi.connect.Connector.Argument

        description, label, mustSpecify, name, setValue, value

    • 方法详细信息

      • setValue

        void setValue​(int value)
        设置参数的值。 该值应在设置前用isValid(int)进行检查; 建立连接时，无效值会引发异常 - 例如，在LaunchingConnector.launch(java.util.Map<java.lang.String, ? extends com.sun.jdi.connect.Connector.Argument>)

      • isValid

        boolean isValid​(String value)
        对参数进行基本的理性检查。
        Specified by:
        isValid在接口 Connector.Argument
        结果
        true如果值表示一个int为 min() <= value <= max()

      • isValid

        boolean isValid​(int value)
        对参数进行基本的理性检查。
        结果
        true如果是 min() <= value <= max()

      • stringValueOf

        String stringValueOf​(int value)
        返回value参数的字符串表示形式。 不设置或检查当前值为this实例。
        结果
        int值的String表示形式。

      • intValue

        int intValue​()
        将参数的值作为int返回。 由于参数可能未设置或可能具有无效值isValid(String)应在Connector.Argument.value()上调用以检查其有效性。 如果无效，则此方法返回的int是未定义的。
        结果
        参数的值为int。

      • max

        int max​()
        值的上限。
        结果
        此参数的最大允许值。

      • min

        int min​()
        价值的下限。
        结果
        该参数的最小允许值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Connector.SelectedArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface Connector.SelectedArgument

  • All Superinterfaces:
    Connector.Argument ， Serializable
    Enclosing interface:
    Connector

    public static interface Connector.SelectedArgument
extends Connector.Argument
    Connector参数的规范和值，其值是从选择列表中选择的String。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<String> choices​()
      返回参数的可能值
      boolean isValid​(String value)
      对参数进行基本的理性检查。

      • Methods inherited from interface com.sun.jdi.connect.Connector.Argument

        description, label, mustSpecify, name, setValue, value

    • 方法详细信息

      • choices

        List<String> choices​()
        返回参数的可能值
        结果
        List ，共String

      • isValid

        boolean isValid​(String value)
        对参数进行基本的理性检查。
        Specified by:
        isValid在接口 Connector.Argument
        结果
        true如果值是 choices()之一 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Connector.StringArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface Connector.StringArgument

  • All Superinterfaces:
    Connector.Argument ， Serializable
    Enclosing interface:
    Connector

    public static interface Connector.StringArgument
extends Connector.Argument
    Connector参数的规范和值，其值为String。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean isValid​(String value)
      对参数进行基本的理性检查。

      • Methods inherited from interface com.sun.jdi.connect.Connector.Argument

        description, label, mustSpecify, name, setValue, value

    • 方法详细信息

      • isValid

        boolean isValid​(String value)
        对参数进行基本的理性检查。
        Specified by:
        isValid在接口 Connector.Argument
        结果
        true always
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalConnectorArgumentsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Class IllegalConnectorArgumentsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.jdi.connect.IllegalConnectorArgumentsException
  • All Implemented Interfaces:
    Serializable

    public class IllegalConnectorArgumentsException
extends 异常
    抛出表示无效的参数或不一致传递给Connector 。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalConnectorArgumentsException​(String s, String name)
      构造具有指定的详细消息的 IllegalConnectorArgumentsException和无效或不一致的参数的名称。
      IllegalConnectorArgumentsException​(String s, List<String> names)
      构建 IllegalConnectorArgumentsException带指定详细消息和 List的参数，其是无效的或不一致的名字。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      List<String> argumentNames​()
      返回一个包含无效或不一致参数的名称的 List 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalConnectorArgumentsException

        public IllegalConnectorArgumentsException​(String s,
                                          String name)
        构造一个具有指定的详细消息的 IllegalConnectorArgumentsException和无效或不一致的参数的名称。
        参数
        s - 详细信息。
        name - 无效或不一致参数的名称。

      • IllegalConnectorArgumentsException

        public IllegalConnectorArgumentsException​(String s,
                                          List<String> names)
        构建 IllegalConnectorArgumentsException带指定详细消息和 List的参数，其是无效的或不一致的名字。
        参数
        s - 详细信息。
        names - 一个包含无效或不一致参数名称的 List 。

    • 方法详细信息

      • argumentNames

        public List<String> argumentNames​()
        返回一个包含无效或不一致参数的名称的 List 。
        结果
        一个参数名称为 List 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LaunchingConnector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface LaunchingConnector

  • All Superinterfaces:
    Connector

    public interface LaunchingConnector
extends Connector
    连接前可以启动目标虚拟机的连接器。
    从以下版本开始：
    1.3

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.jdi.connect.Connector

        Connector.Argument, Connector.BooleanArgument, Connector.IntegerArgument, Connector.SelectedArgument, Connector.StringArgument

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      VirtualMachine launch​(Map<String,? extends Connector.Argument> arguments)
      启动应用程序并连接到其VM。

      • Methods inherited from interface com.sun.jdi.connect.Connector

        defaultArguments, description, name, transport

    • 方法详细信息

      • launch

        VirtualMachine launch​(Map<String,? extends Connector.Argument> arguments)
               throws IOException,
                      IllegalConnectorArgumentsException,
                      VMStartException
        启动应用程序并连接到其VM。 启动的属性（可能包括选项，主类和参数）在arguments中指定。 参数映射将参数名称字符串与Connector.Argument的实例相关联。 连接器的默认参数图可以通过Connector.defaultArguments()获取 。 可以更改参数映射值，但不应添加或删除映射条目。

        在接收到VMStartEvent之前，由启动连接器启动的目标虚拟机不能保证稳定。

        重要提示：如果通过此功能启动目标虚拟机，则其输出和错误流必须在执行时读取。 这些流可通过VirtualMachine.process()返回的Process对象获得 。 如果流未定期读取，则当这些流的缓冲区被填满时，目标VM将停止执行。

        参数
        arguments - 用于启动VM的参数映射。
        结果
        目标VM的VirtualMachine镜像。
        异常
        IOException - 无法启动时。 具体的异常取决于使用中的Connector实现。
        IllegalConnectorArgumentsException - 其中一个连接器参数无效时。
        VMStartException - 当VM成功启动时，但在连接建立之前终止错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ListeningConnector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface ListeningConnector

  • All Superinterfaces:
    Connector

    public interface ListeningConnector
extends Connector
    侦听由目标虚拟机启动的连接的连接器。
    从以下版本开始：
    1.3

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.jdi.connect.Connector

        Connector.Argument, Connector.BooleanArgument, Connector.IntegerArgument, Connector.SelectedArgument, Connector.StringArgument

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      VirtualMachine accept​(Map<String,? extends Connector.Argument> arguments)
      等待目标VM附加到此连接器。
      String startListening​(Map<String,? extends Connector.Argument> arguments)
      侦听由目标虚拟机发起的一个或多个连接。
      void stopListening​(Map<String,? extends Connector.Argument> arguments)
      取消侦听连接。
      boolean supportsMultipleConnections​()
      指示此侦听连接器是否支持单个参数映射的多个连接。

      • Methods inherited from interface com.sun.jdi.connect.Connector

        defaultArguments, description, name, transport

    • 方法详细信息

      • supportsMultipleConnections

        boolean supportsMultipleConnections​()
        指示此侦听连接器是否支持单个参数映射的多个连接。 如果是这样，对startListening(java.util.Map<java.lang.String, ? extends com.sun.jdi.connect.Connector.Argument>)的调用可能允许多个目标VM连接。
        结果
        true如果支持多个连接; false否则。

      • startListening

        String startListening​(Map<String,? extends Connector.Argument> arguments)
               throws IOException,
                      IllegalConnectorArgumentsException
        侦听由目标虚拟机发起的一个或多个连接。 连接器使用给定的参数映射来确定要侦听的地址，否则会生成适当的侦听地址。 在任何一种情况下，从该方法返回地址字符串，该地址字符串可用于启动目标虚拟机以识别此连接器。 地址字符串的格式是连接器，传输和可能依赖于平台。

        参数映射将参数名称字符串与Connector.Argument的实例相关联。 连接器的默认参数图可以通过Connector.defaultArguments()获得。 可以更改参数映射值，但不应添加或删除映射条目。

        此方法不返回VirtualMachine ，并且通常在任何目标VM发起连接之前返回。 连接的目标是通过accept(java.util.Map<java.lang.String, ? extends com.sun.jdi.connect.Connector.Argument>)获得的（使用与传递给该方法相同的参数映射）。

        如果arguments包含寻址信息。 并且只接受一个连接，可以立即调用accept方法而不调用此方法。

        结果
        连接器正在侦听连接的地址。
        异常
        IOException - 当无法开始听时。 具体的异常取决于使用中的Connector实现。
        IllegalConnectorArgumentsException - 其中一个连接器参数无效时。

      • stopListening

        void stopListening​(Map<String,? extends Connector.Argument> arguments)
            throws IOException,
                   IllegalConnectorArgumentsException
        取消侦听连接。 给定的参数映射应该与先前的startListening(java.util.Map<java.lang.String, ? extends com.sun.jdi.connect.Connector.Argument>)调用给出的参数映射匹配。
        异常
        IOException - 当不能停止听。 具体的异常取决于使用中的Connector实现。
        IllegalConnectorArgumentsException - 当其中一个连接器参数无效时。

      • accept

        VirtualMachine accept​(Map<String,? extends Connector.Argument> arguments)
               throws IOException,
                      IllegalConnectorArgumentsException
        等待目标VM附加到此连接器。
        异常
        TransportTimeoutException - 当连接器封装在接受时支持超时的传输时，在参数映射中设置了表示超时的Connector.Argument ，并在等待目标虚拟机连接时发生超时。
        IOException - 当不能接受。 具体的异常取决于使用中的Connector实现。
        IllegalConnectorArgumentsException - 当其中一个连接器参数无效时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Transport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Interface Transport

  • public interface Transport
    调试器和目标VM之间的通信方法。

    传输代表Connector用于建立与目标虚拟机的连接的传输机制。 它由一个通过调用name()方法获得的名称组成。 此外，传输封装了一个TransportService ，它是用于建立连接的基础服务，并与目标VM交换Java Debug Wire Protocol（JDWP）数据包。

    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回传输的简短标识符。

    • 方法详细信息

      • name

        String name​()
        返回传输的简短标识符。
        结果
        这个运输的名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TransportTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Class TransportTimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • com.sun.jdi.connect.TransportTimeoutException
  • All Implemented Interfaces:
    Serializable

    public class TransportTimeoutException
extends IOException
    当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。

    当连接到目标虚拟机时，使用attach，如果连接器支持超时connector argument，则可能会抛出此异常。 类似地，当等待接受来自目标虚拟机的连接时，如果连接器在接受时支持超时连接器参数，则使用accept可能会抛出此异常。

    此外，开发人员创建TransportService个实现这个异常被抛出时attach次建立到目标VM，或者连接时出accept个超时等待目标VM连接。

    从以下版本开始：
    1.5
    另请参见：
    AttachingConnector.attach(java.util.Map<java.lang.String, ? extends com.sun.jdi.connect.Connector.Argument>) ，
ListeningConnector.accept(java.util.Map<java.lang.String, ? extends com.sun.jdi.connect.Connector.Argument>) ，
TransportService.attach(java.lang.String, long, long) ，
TransportService.accept(com.sun.jdi.connect.spi.TransportService.ListenKey, long, long) ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      TransportTimeoutException​()
      构造一个没有详细消息的 TransportTimeoutException 。
      TransportTimeoutException​(String message)
      构造具有指定详细消息的 TransportTimeoutException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • TransportTimeoutException

        public TransportTimeoutException​()
        构造一个 TransportTimeoutException ，没有详细消息。

      • TransportTimeoutException

        public TransportTimeoutException​(String message)
        构造具有指定详细消息的 TransportTimeoutException 。
        参数
        message - 有关此异常的详细消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.jdi.connect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.jdi.connect

  • Packages that use com.sun.jdi.connect
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
  • Classes in com.sun.jdi.connect used by com.sun.jdi
    Class 描述
    AttachingConnector
    连接到以前运行的目标VM的连接器。
    Connector
    调试器和目标VM之间的连接方法。
    LaunchingConnector
    连接前可以启动目标虚拟机的连接器。
    ListeningConnector
    侦听由目标虚拟机启动的连接的连接器。
  • Classes in com.sun.jdi.connect used by com.sun.jdi.connect
    Class 描述
    Connector
    调试器和目标VM之间的连接方法。
    Connector.Argument
    Connector参数的规范和值。
    IllegalConnectorArgumentsException
    抛出表示无效参数或不一致传递给Connector 。
    Transport
    调试器和目标VM之间的通信方法。
    VMStartException
    目标VM已成功启动，但在建立连接之前会发生错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VMStartException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect

Class VMStartException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.jdi.connect.VMStartException
  • All Implemented Interfaces:
    Serializable

    public class VMStartException
extends 异常
    目标VM已成功启动，但在建立连接之前会发生错误。 此异常为启动的目标提供了Process对象，以帮助诊断问题。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VMStartException​(Process process)
      VMStartException​(String message, Process process)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Process process​()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • VMStartException

        public VMStartException​(Process process)

      • VMStartException

        public VMStartException​(String message,
                        Process process)

    • 方法详细信息

      • process

        public Process process​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.IllegalConnectorArgumentsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.IllegalConnectorArgumentsException

  • Packages that use IllegalConnectorArgumentsException
    软件包 描述
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

    • Uses of IllegalConnectorArgumentsException in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that throw IllegalConnectorArgumentsException
      Modifier and Type 方法 描述
      VirtualMachine ListeningConnector.accept​(Map<String,? extends Connector.Argument> arguments)
      等待目标VM附加到此连接器。
      VirtualMachine AttachingConnector.attach​(Map<String,? extends Connector.Argument> arguments)
      附加到正在运行的应用程序并返回其虚拟机的镜像。
      VirtualMachine LaunchingConnector.launch​(Map<String,? extends Connector.Argument> arguments)
      启动应用程序并连接到其VM。
      String ListeningConnector.startListening​(Map<String,? extends Connector.Argument> arguments)
      侦听由目标虚拟机发起的一个或多个连接。
      void ListeningConnector.stopListening​(Map<String,? extends Connector.Argument> arguments)
      取消侦听连接。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.TransportTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.TransportTimeoutException

No usage of com.sun.jdi.connect.TransportTimeoutException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.VMStartException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.VMStartException

  • Packages that use VMStartException
    软件包 描述
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

    • Uses of VMStartException in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that throw VMStartException
      Modifier and Type 方法 描述
      VirtualMachine LaunchingConnector.launch​(Map<String,? extends Connector.Argument> arguments)
      启动应用程序并连接到其VM。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.AttachingConnector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.AttachingConnector

  • Packages that use AttachingConnector
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of AttachingConnector in com.sun.jdi

      Methods in com.sun.jdi that return types with arguments of type AttachingConnector
      Modifier and Type 方法 描述
      List<AttachingConnector> VirtualMachineManager.attachingConnectors​()
      返回已知的AttachingConnector对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.Connector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.Connector

  • Packages that use Connector
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

    • Uses of Connector in com.sun.jdi

      Methods in com.sun.jdi that return types with arguments of type Connector
      Modifier and Type 方法 描述
      List<Connector> VirtualMachineManager.allConnectors​()
      返回所有已知的Connector对象的列表。

    • Uses of Connector in com.sun.jdi.connect

      Subinterfaces of Connector in com.sun.jdi.connect
      Modifier and Type 接口 描述
      interface  AttachingConnector
      连接到以前运行的目标VM的连接器。
      interface  LaunchingConnector
      连接前可以启动目标虚拟机的连接器。
      interface  ListeningConnector
      侦听由目标虚拟机启动的连接的连接器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.Connector.Argument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.Connector.Argument

  • Packages that use Connector.Argument
    软件包 描述
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

    • Uses of Connector.Argument in com.sun.jdi.connect

      Subinterfaces of Connector.Argument in com.sun.jdi.connect
      Modifier and Type 接口 描述
      static interface  Connector.BooleanArgument
      Connector参数的规范和值，其值为布尔值。
      static interface  Connector.IntegerArgument
      Connector参数的规格和值，其值为整数。
      static interface  Connector.SelectedArgument
      Connector参数的规范和值，其值是从选择列表中选择的String。
      static interface  Connector.StringArgument
      Connector参数的规范和值，其值为String。
      Methods in com.sun.jdi.connect that return types with arguments of type Connector.Argument
      Modifier and Type 方法 描述
      Map<String,Connector.Argument> Connector.defaultArguments​()
      返回此连接器接受的参数及其默认值。
      Method parameters in com.sun.jdi.connect with type arguments of type Connector.Argument
      Modifier and Type 方法 描述
      VirtualMachine ListeningConnector.accept​(Map<String,? extends Connector.Argument> arguments)
      等待目标VM附加到此连接器。
      VirtualMachine AttachingConnector.attach​(Map<String,? extends Connector.Argument> arguments)
      附加到正在运行的应用程序并返回其虚拟机的镜像。
      VirtualMachine LaunchingConnector.launch​(Map<String,? extends Connector.Argument> arguments)
      启动应用程序并连接到其VM。
      String ListeningConnector.startListening​(Map<String,? extends Connector.Argument> arguments)
      侦听由目标虚拟机发起的一个或多个连接。
      void ListeningConnector.stopListening​(Map<String,? extends Connector.Argument> arguments)
      取消侦听连接。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.Connector.BooleanArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.Connector.BooleanArgument

No usage of com.sun.jdi.connect.Connector.BooleanArgument
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.Connector.IntegerArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.Connector.IntegerArgument

No usage of com.sun.jdi.connect.Connector.IntegerArgument
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.Connector.SelectedArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.Connector.SelectedArgument

No usage of com.sun.jdi.connect.Connector.SelectedArgument
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.Connector.StringArgument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.Connector.StringArgument

No usage of com.sun.jdi.connect.Connector.StringArgument
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.LaunchingConnector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.LaunchingConnector

  • Packages that use LaunchingConnector
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of LaunchingConnector in com.sun.jdi

      Methods in com.sun.jdi that return LaunchingConnector
      Modifier and Type 方法 描述
      LaunchingConnector VirtualMachineManager.defaultConnector​()
      标识默认连接器。
      Methods in com.sun.jdi that return types with arguments of type LaunchingConnector
      Modifier and Type 方法 描述
      List<LaunchingConnector> VirtualMachineManager.launchingConnectors​()
      返回已知的LaunchingConnector对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.ListeningConnector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.ListeningConnector

  • Packages that use ListeningConnector
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of ListeningConnector in com.sun.jdi

      Methods in com.sun.jdi that return types with arguments of type ListeningConnector
      Modifier and Type 方法 描述
      List<ListeningConnector> VirtualMachineManager.listeningConnectors​()
      返回已知的ListeningConnector对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.connect.Transport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.connect.Transport

  • Packages that use Transport
    软件包 描述
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

    • Uses of Transport in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that return Transport
      Modifier and Type 方法 描述
      Transport Connector.transport​()
      返回此连接器用于建立与目标VM的连接的传输机制。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ClosedConnectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect.spi

Class ClosedConnectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • com.sun.jdi.connect.spi.ClosedConnectionException
  • All Implemented Interfaces:
    Serializable

    public class ClosedConnectionException
extends IOException
    由于在进行I / O操作时异步关闭Connection ，因此可能会抛出此异常。

    当一个线程在readPacket中等待来自目标虚拟机的数据包时， Connection可能被另一个线程调用close方法异步关闭。 当出现这种情况时，readPacket中的线程将抛出此异常。 在Connection.writePacket(byte[])中 ，当线程被阻塞时，连线可能会被关闭。 当这种情况发生时，writePacket中的线程将抛出此异常。

    从以下版本开始：
    1.5
    另请参见：
    Connection.readPacket() ， Connection.writePacket(byte[]) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClosedConnectionException​()
      构造一个 ClosedConnectionException ，没有详细消息。
      ClosedConnectionException​(String message)
      构造具有指定详细消息的 ClosedConnectionException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClosedConnectionException

        public ClosedConnectionException​()
        构造一个 ClosedConnectionException ，没有详细消息。

      • ClosedConnectionException

        public ClosedConnectionException​(String message)
        构造具有指定详细消息的 ClosedConnectionException 。
        参数
        message - 有关此异常的详细消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.jdi.connect.spi (Java SE 9 & JDK 9 )

com.sun.jdi.connect.spi

Classes

  • Connection
  • TransportService
  • TransportService.Capabilities
  • TransportService.ListenKey

Exceptions

  • ClosedConnectionException


com.sun.jdi.connect.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.jdi

Package com.sun.jdi.connect.spi

这个包包括用于开发新的TransportService实现的接口和类。
  • 类摘要
    Class 描述
    Connection
    调试器和调试器之间的连接。
    TransportService
    用于调试器和目标VM之间连接的传输服务。
    TransportService.Capabilities
    运输服务能力。
    TransportService.ListenKey
    听密钥 。
  • 异常摘要
    异常 描述
    ClosedConnectionException
    由于在进行I / O操作时异步关闭Connection可能会抛出此异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.jdi.connect.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.jdi.connect.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.jdi.connect.spi.Connection
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • com.sun.jdi.connect.spi.ClosedConnectionException
    • com.sun.jdi.connect.spi.TransportService
    • com.sun.jdi.connect.spi.TransportService.Capabilities
    • com.sun.jdi.connect.spi.TransportService.ListenKey
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Connection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect.spi

Class Connection

  • java.lang.Object
    • com.sun.jdi.connect.spi.Connection

  • public abstract class Connection
extends Object
    调试器和调试器之间的连接。

    连接表示调试器和目标VM之间的双向通信通道。 当TransportService建立连接并与目标VM成功握手时，将创建连接。 TransportService实现提供可靠的JDWP数据包传输服务，因此Connection在调试器和目标VM之间提供可靠的JDWP数据包流。 连接是面向流的，也就是说，写入连接的JDWP数据包按目标虚拟机按写入顺序读取。 类似地，由目标VM写入连接的数据包将按调试器按写入顺序读取。

    连接是打开的还是关闭的。 它在创作时开放，并保持打开状态，直到关闭。 一旦关闭，它保持关闭，并且任何尝试调用I / O操作将导致抛出ClosedConnectionException 。 可以通过调用isOpen方法来测试连接。

    连接可以安全地访问多个并发线程，尽管最多一个线程可能正在读取，并且最多一个线程可能在任何给定时间写入。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      Connection​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void close​()
      关闭此连接。
      abstract boolean isOpen​()
      告诉这个连接是否打开。
      abstract byte[] readPacket​()
      从目标虚拟机读取数据包。
      abstract void writePacket​(byte[] pkt)
      将数据包写入目标虚拟机。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Connection

        public Connection​()

    • 方法详细信息

      • readPacket

        public abstract byte[] readPacket​()
                           throws IOException
        从目标虚拟机读取数据包。

        尝试从目标VM读取JDWP数据包。 读取操作可以无限期地阻止，并且仅在读取分组的所有字节时返回，或者在基于面向流的通信协议的传输服务的情况下，遇到流的结束。

        读取数据包除了检查数据包的长度（由length字段的值，数据包的前四个字节表示）的长度为11个或更多个字节之外，不对数据包进行任何完整性检查。 如果length值小于11，则抛出IOException 。

        返回长度等于接收到的数据包的长度的字节数组，或遇到流结束时的长度为0的字节数组。 如果在数据包的一些但不是全部字节之后遇到流结尾，则会被视为I / O错误，并抛出一个IOException 。 数据包的第一个字节存储在字节数组的元素1 ，第二个字节存储在元素0中，依此类推。 字节数组中的字节按照JDWP specification进行布局 。 也就是说，根据JDWP规范，数据包中的所有字段都是大端序。

        可以随时调用此方法。 如果另一个线程已经在此连接上启动了一个readPacket ，则该方法的调用将阻塞，直到第一个操作完成。

        结果
        该分组从目标VM读取
        异常
        ClosedConnectionException - 如果连接已关闭，或者另一个线程在readPacket正在进行时关闭连接。
        IOException - 如果分组的长度（由前4个字节表示）小于11个字节，或发生I / O错误。

      • writePacket

        public abstract void writePacket​(byte[] pkt)
                          throws IOException
        将数据包写入目标虚拟机。

        尝试将JDWP数据包写入或发送到目标VM。 写入操作仅在将整个数据包写入目标VM后才返回。 编写整个数据包并不意味着整个数据包已经传输到目标虚拟机，而是所有字节都已写入传输服务。 基于TCP / IP连接的传输服务可以例如在网络上传输之前缓冲一些或全部分组。

        提供给此方法的字节数组应按JDWP specification进行布局 。 也就是说，数据包中的所有字段都是大排序的。 第一个字节，即元素pkt[0] ，是length字段的第一个字节。 pkt[1]是length字段的第二个字节，等等。

        除了检查数据包长度之外，写入数据包不会对数据包进行任何完整性检查。 检查数据包长度需要检查length字段的值（由数据包的前四个字节表示）为11或更大。 因此，提供给此方法的字节数组的长度，即pkt.length必须为11或更大，并且必须等于或大于length字段的值。 如果字节数组的长度大于length字段的值，则元素pkt[length]以后的所有字节将被忽略。 换句话说，跟随字节数组中的数据包的任何附加字节将被忽略，不会传输到目标虚拟机。

        写操作可能会阻止或可能立即完成。 操作块的具体情况取决于运输服务。 在与目标VM的TCP / IP连接的情况下，如果存在网络拥塞或者没有足够的空间来缓冲底层网络系统中的分组，则writePacket方法可能会阻塞。

        可以随时调用此方法。 如果另一个线程已经在此连接上启动了写入操作，则此方法的后续调用将阻塞，直到第一个操作完成。

        参数
        pkt - 要写入目标虚拟机的数据包。
        异常
        ClosedConnectionException - 如果连接已关闭，或者另一个线程在写入操作进行时关闭连接。
        IOException - 如果发生I / O错误。
        IllegalArgumentException - 如果 length字段的值无效或字节数组的长度不足。

      • close

        public abstract void close​()
                    throws IOException
        关闭此连接。

        如果连接已经关闭，则调用此方法不起作用。 连接关闭后，任何进一步的尝试调用readPacket或writePacket将抛出一个ClosedConnectionException 。

        任何当前在I / O操作中被阻止的线程（ readPacket或writePacket ）将抛出一个ClosedConnectionException ）。

        可以随时调用此方法。 然而，如果一些其他线程已经调用了它，那么另一个调用将阻塞，直到第一次调用完成，之后它将不起作用。

        异常
        IOException - 如果发生I / O错误

      • isOpen

        public abstract boolean isOpen​()
        告诉这个连接是否打开。
        结果
        true if and only if this connection is open
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TransportService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect.spi

Class TransportService

  • java.lang.Object
    • com.sun.jdi.connect.spi.TransportService

  • public abstract class TransportService
extends Object
    用于调试器和目标VM之间连接的传输服务。

    传输服务是这个类的具体子类，它具有零参数的构造函数，并实现下面指定的抽象方法。 Transport用于调试器和目标VM之间的连接的底层服务。

    传输服务用于在调试器和目标VM之间建立连接，并通过底层通信协议传输Java Debug Wire Protocol（JDWP）数据包。 实质上，传输服务实现将JDWP（如JDWP specification中所指定）绑定到底层通信协议。 传输服务实现提供可靠的JDWP分组传输服务。 JDWP数据包被发送到目标VM并从目标VM发送，而不会重复或数据丢失。 传输服务实现可以基于可靠或不可靠的底层通信协议。 如果底层通信协议是可靠的，则传输服务实现可以相对简单，并且可能仅需要将JDWP分组作为底层通信协议的有效载荷进行传输。 在不可靠的通信协议的情况下，传输服务实现可以包括额外的协议支持，以便确保分组不被重复并且没有数据丢失。 这些协议的细节特定于实现，但是可以涉及诸如传输控制协议（TCP）（见RFC 793 ）的协议中使用的重传技术的肯定确认等技术。

    传输服务可用于启动与目标虚拟机的连接。 这是通过调用attach(java.lang.String, long, long)方法来完成的。 或者，传输服务可以监听和接受由目标VM发起的连接。 这是通过调用startListening(String)方法来完成的，使传输进入监听模式。 然后， accept(com.sun.jdi.connect.spi.TransportService.ListenKey, long, long)方法用于接受目标VM发起的连接。

    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TransportService.Capabilities
      运输服务能力。
      static class  TransportService.ListenKey
      听密钥 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TransportService​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Connection accept​(TransportService.ListenKey listenKey, long acceptTimeout, long handshakeTimeout)
      接受来自目标虚拟机的连接。
      abstract Connection attach​(String address, long attachTimeout, long handshakeTimeout)
      附加到指定的地址。
      abstract TransportService.Capabilities capabilities​()
      返回传输服务的功能。
      abstract String description​()
      返回传输服务的描述。
      abstract String name​()
      返回一个名称以识别传输服务。
      abstract TransportService.ListenKey startListening​()
      侦听由运输服务选择的地址。
      abstract TransportService.ListenKey startListening​(String address)
      侦听入站连接的指定地址。
      abstract void stopListening​(TransportService.ListenKey listenKey)
      停止监听入站连接。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TransportService

        public TransportService​()

    • 方法详细信息

      • name

        public abstract String name​()
        返回一个名称以识别传输服务。
        结果
        运输服务的名称

      • description

        public abstract String description​()
        返回传输服务的描述。
        结果
        运输服务的描述

      • capabilities

        public abstract TransportService.Capabilities capabilities​()
        返回传输服务的功能。
        结果
        运输服务能力

      • attach

        public abstract Connection attach​(String address,
                                  long attachTimeout,
                                  long handshakeTimeout)
                           throws IOException
        附加到指定的地址。

        附加到指定的地址，并将表示双向通信信道的连接返回给目标VM。

        连接到目标VM涉及两个步骤：首先，连接建立到指定的地址。 之后进行握手，以确保连接到目标VM。 握手涉及交换Java Debug Wire Protocol规范中指定的字符串JDWP- 握手 。

        参数
        address - 目标虚拟机的地址。
        attachTimeout - 如果此传输服务支持附加超时，并且如果attachTimeout为正，则指定在附加到目标VM时使用的超时（以毫秒为单位）（多或少）。 如果传输服务不支持附加超时，或者如果指定为attachTimeout为零，则不附加任何超时。
        handshakeTimeout - 如果此传输服务支持握手超时，并且如果handshakeTimeout为正，则指定在与目标虚拟机握手时使用的超时（以毫秒为单位）（多或少）。 超时的确切用法特定于传输服务。 传输服务例如可以使用握手超时作为字符间超时，同时等待来自目标VM的JDWP握手消息。 或者，传输服务可以例如在握手交换的持续时间内使用handshakeTimeout作为超时。 如果传输服务不支持握手超时，或者如果指定了handshakeTimeout为零，则如果目标VM没有响应，则握手不会超时。
        结果
        该连接表示到目标VM的双向通信信道。
        异常
        TransportTimeoutException - 如果在建立连接时发生超时。
        IOException - 如果发生I / O错误（包括握手超时）。
        IllegalArgumentException - 如果地址无效或附加超时或握手超时的值为负。
        另请参见：
        TransportService.Capabilities.supportsAttachTimeout()

      • startListening

        public abstract TransportService.ListenKey startListening​(String address)
                                                   throws IOException
        侦听入站连接的指定地址。

        此方法启动传输服务监听指定的地址，以便随后可以接受入站连接。 它不等到入站连接建立。

        参数
        address - 开始侦听连接的地址，或 null监听由传输服务选择的地址。
        结果
        在随后的呼叫中使用的听密钥为 accept或 stopListening方法。
        异常
        IOException - 如果发生I / O错误。
        IllegalArgumentException - 如果具体地址无效

      • startListening

        public abstract TransportService.ListenKey startListening​()
                                                   throws IOException
        侦听由运输服务选择的地址。

        这个方便的方法就像调用startListening(null)一样 。

        结果
        在随后的呼叫中使用的监听密钥为 accept或 stopListening方法。
        异常
        IOException - 如果发生I / O错误。

      • stopListening

        public abstract void stopListening​(TransportService.ListenKey listenKey)
                            throws IOException
        停止监听入站连接。

        在另一个线程在accept中调用此方法时，使用相同的listen键，等待接受连接将导致该线程抛出IOException。 如果在accept中阻塞的线程已经接受来自目标VM的连接，并且正在与目标VM进行握手，则调用此方法不会导致线程抛出异常。

        参数
        listenKey - 从以前的电话获得的听力密码为 startListening(String)或 startListening() 。
        异常
        IllegalArgumentException - 如果 IllegalArgumentException键无效
        IOException - 如果发生I / O错误。

      • accept

        public abstract Connection accept​(TransportService.ListenKey listenKey,
                                  long acceptTimeout,
                                  long handshakeTimeout)
                           throws IOException
        接受来自目标虚拟机的连接。

        等待（无限期或超时）接受来自目标虚拟机的连接。 返回表示目标VM的双向通信通道的连接。

        从目标VM接受连接涉及两个步骤。 首先，传输服务等待接受来自目标VM的连接。 建立连接后，执行握手以确保连接确实与目标VM。 握手涉及交换Java Debug Wire Protocol规范中指定的字符串JDWP- 握手 。

        参数
        listenKey - 从以前的电话获得的听力密码为 startListening(String)或 startListening() 。
        acceptTimeout - 如果此传输服务支持接受超时，并且如果acceptTimeout为正，则等待目标虚拟机连接时，阻塞最多可达acceptTimeout毫秒，或多或少。 如果传输服务不支持接受超时，或者如果acceptTimeout为零，则无限期地阻止目标VM连接。
        handshakeTimeout - 如果此传输服务支持握手超时，并且如果handshakeTimeout为正，则指定与目标VM进行握手时使用的超时（以毫秒（或多或少）为单位）。 超时的确切用法特定于传输服务。 传输服务例如可以使用握手超时作为字符间超时，同时等待来自目标VM的JDWP握手消息。 或者，传输服务可以例如使用超时作为握手交换的持续时间的超时。 如果传输服务不支持握手超时，如果指定为handshakeTimeout为零，则如果目标VM没有响应，则握手不会超时。
        结果
        该连接表示到目标VM的双向通信信道。
        异常
        TransportTimeoutException - 如果在等待目标虚拟机连接时发生超时。
        IOException - 如果发生I / O错误（包括握手超时）。
        IllegalArgumentException - 如果acceptTimeout参数或handshakeTimeout的值为负值或提供无效的listen键。
        IllegalStateException - 如果已经使用此listen键调用了 stopListening ，并且传输服务不再监听入站连接。
        另请参见：
        TransportService.Capabilities.supportsAcceptTimeout()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TransportService.Capabilities (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect.spi

Class TransportService.Capabilities

  • java.lang.Object
    • com.sun.jdi.connect.spi.TransportService.Capabilities
  • Enclosing class:
    TransportService

    public abstract static class TransportService.Capabilities
extends Object
    运输服务能力。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Capabilities​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract boolean supportsAcceptTimeout​()
      在等待目标虚拟机连接时，告知此传输服务是否支持超时。
      abstract boolean supportsAttachTimeout​()
      在连接到目标虚拟机时，请告知此传输服务是否支持超时。
      abstract boolean supportsHandshakeTimeout​()
      告知当与目标虚拟机进行握手时，此传输服务是否支持超时。
      abstract boolean supportsMultipleConnections​()
      告诉这个传输服务是否可以支持与正在监听的单个地址的多个并发连接。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Capabilities

        public Capabilities​()

    • 方法详细信息

      • supportsMultipleConnections

        public abstract boolean supportsMultipleConnections​()
        告诉这个传输服务是否可以支持与正在监听的单个地址的多个并发连接。
        结果
        true如果并且只有这个传输服务支持多个连接。

      • supportsAttachTimeout

        public abstract boolean supportsAttachTimeout​()
        在连接到目标虚拟机时，请告知此传输服务是否支持超时。
        结果
        true如果且仅当此传输服务支持附加超时时。
        另请参见：
        TransportService.attach(String,long,long)

      • supportsAcceptTimeout

        public abstract boolean supportsAcceptTimeout​()
        在等待目标虚拟机连接时，告知此传输服务是否支持超时。
        结果
        true如果且仅当此传输服务在等待目标虚拟机连接时支持超时。
        另请参见：
        TransportService.accept(TransportService.ListenKey,long,long)

      • supportsHandshakeTimeout

        public abstract boolean supportsHandshakeTimeout​()
        告知当与目标虚拟机进行握手时，此传输服务是否支持超时。
        结果
        true如果，并且只有当此传输服务在与目标VM握手时支持超时。
        另请参见：
        TransportService.attach(String,long,long) ， TransportService.accept(TransportService.ListenKey,long,long)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TransportService.ListenKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.connect.spi

Class TransportService.ListenKey

  • java.lang.Object
    • com.sun.jdi.connect.spi.TransportService.ListenKey
  • Enclosing class:
    TransportService

    public abstract static class TransportService.ListenKey
extends Object
    听密钥 。

    A TransportService可以在多个但又不同的地址同时收听。 唯一标识每个listener一听关键是每一个时间创建startListening被调用。 listen键用于调用accept方法以接受与该侦听器的入站连接。 listen键是有效的，直到它被用作stopListening的参数来停止传输服务侦听地址。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ListenKey​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract String address​()
      返回listen键的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ListenKey

        public ListenKey​()

    • 方法详细信息

      • address

        public abstract String address​()
        返回listen键的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.jdi.connect.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.jdi.connect.spi

  • Packages that use com.sun.jdi.connect.spi
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect.spi
    该包包含用于开发新的TransportService实现的接口和类。
  • Classes in com.sun.jdi.connect.spi used by com.sun.jdi
    Class 描述
    Connection
    调试器和调试器之间的连接。
  • Classes in com.sun.jdi.connect.spi used by com.sun.jdi.connect.spi
    Class 描述
    Connection
    调试器和调试器之间的连接。
    TransportService.Capabilities
    运输服务能力。
    TransportService.ListenKey
    听密钥 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.spi.ClosedConnectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.spi.ClosedConnectionException

No usage of com.sun.jdi.connect.spi.ClosedConnectionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.spi.Connection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.spi.Connection

  • Packages that use Connection
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect.spi
    该包包括用于开发新的TransportService实现的接口和类。

    • Uses of Connection in com.sun.jdi

      Methods in com.sun.jdi with parameters of type Connection
      Modifier and Type 方法 描述
      VirtualMachine VirtualMachineManager.createVirtualMachine​(Connection connection)
      创建一个新的虚拟机。
      VirtualMachine VirtualMachineManager.createVirtualMachine​(Connection connection, Process process)
      为目标虚拟机创建虚拟机镜像。

    • Uses of Connection in com.sun.jdi.connect.spi

      Methods in com.sun.jdi.connect.spi that return Connection
      Modifier and Type 方法 描述
      abstract Connection TransportService.accept​(TransportService.ListenKey listenKey, long acceptTimeout, long handshakeTimeout)
      接受来自目标虚拟机的连接。
      abstract Connection TransportService.attach​(String address, long attachTimeout, long handshakeTimeout)
      附加到指定的地址。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.spi.TransportService (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.spi.TransportService

No usage of com.sun.jdi.connect.spi.TransportService
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.spi.TransportService.Capabilities (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.spi.TransportService.Capabilities

  • Packages that use TransportService.Capabilities
    软件包 描述
    com.sun.jdi.connect.spi
    该包包含用于开发新的TransportService实现的接口和类。

    • Uses of TransportService.Capabilities in com.sun.jdi.connect.spi

      Methods in com.sun.jdi.connect.spi that return TransportService.Capabilities
      Modifier and Type 方法 描述
      abstract TransportService.Capabilities TransportService.capabilities​()
      返回传输服务的功能。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.connect.spi.TransportService.ListenKey (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.connect.spi.TransportService.ListenKey

  • Packages that use TransportService.ListenKey
    软件包 描述
    com.sun.jdi.connect.spi
    该包包含用于开发新的TransportService实现的接口和类。

    • Uses of TransportService.ListenKey in com.sun.jdi.connect.spi

      Methods in com.sun.jdi.connect.spi that return TransportService.ListenKey
      Modifier and Type 方法 描述
      abstract TransportService.ListenKey TransportService.startListening​()
      侦听由运输服务选择的地址。
      abstract TransportService.ListenKey TransportService.startListening​(String address)
      侦听入站连接的指定地址。
      Methods in com.sun.jdi.connect.spi with parameters of type TransportService.ListenKey
      Modifier and Type 方法 描述
      abstract Connection TransportService.accept​(TransportService.ListenKey listenKey, long acceptTimeout, long handshakeTimeout)
      接受来自目标虚拟机的连接。
      abstract void TransportService.stopListening​(TransportService.ListenKey listenKey)
      停止监听入站连接。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


JDI Type Signatures
Type Signature | Java Type
Z | boolean
B | byte
C | char
S | short
I | int
J | long
F | float
D | double
L fully-qualified-class ; | fully-qualified-class
[ type | type[]
( arg-types ) ret-type | method type (including constructors)

For example, the Java method:

    long f (int n, String s, int[] arr);
has the following type signature:
    (ILjava/lang/String;[I)J


AccessWatchpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface AccessWatchpointEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror ， WatchpointEvent

    public interface AccessWatchpointEvent
extends WatchpointEvent
    通知目标VM中的现场访问。 字段修改不被视为字段访问。
    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.event.WatchpointEvent

        field, object, valueCurrent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BreakpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface BreakpointEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface BreakpointEvent
extends LocatableEvent
    通知目标VM中的断点。 断点事件在执行其位置的代码之前生成。 当达到满足当前已启用的breakpoint request的位置时 ，将包含此类的实例的event set将添加到VM的事件队列中。
    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine ， BreakpointRequest

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassPrepareEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface ClassPrepareEvent

  • All Superinterfaces:
    Event ， Mirror

    public interface ClassPrepareEvent
extends Event
    在目标虚拟机中通知类准备。 有关类准备的定义，请参阅JVM规范。 不为原始类生成类准备事件（例如，java.lang.Integer.TYPE）。
    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ReferenceType referenceType​()
      返回生成此事件的引用类型。
      ThreadReference thread​()
      返回发生此事件的线程。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回发生此事件的线程。

        在极少数情况下，此事件可能发生在目标VM中的调试器系统线程中。 调试器线程采取预防措施来防止这些事件，但在某些情况下无法避免这些事件，特别是对于Error的某些子类。 如果事件由调试器系统线程生成，则此方法返回的值为null，并且如果事件的请求挂起策略为EventRequest.SUSPEND_EVENT_THREAD ，则将暂停所有线程，而EventSet.suspendPolicy()将反映此更改。

        请注意，上述讨论不适用于目标VM在其正常（非调试）操作期间创建的系统线程。

        结果
        一个ThreadReference镜像事件在目标VM中的线程，或者在上述罕见情况下为null。

      • referenceType

        ReferenceType referenceType​()
        返回生成此事件的引用类型。
        结果
        一个ReferenceType镜像已经链接的类，接口或数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassUnloadEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface ClassUnloadEvent

  • All Superinterfaces:
    Event ， Mirror

    public interface ClassUnloadEvent
extends Event
    在目标VM中卸载类的通知。

    在垃圾收集期间调试器后端有严重的限制，因此卸载信息受到很大限制。

    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String className​()
      返回已卸载的类的名称。
      String classSignature​()
      返回已卸载的类的JNI样式签名。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • className

        String className​()
        返回已卸载的类的名称。

      • classSignature

        String classSignature​()
        返回已卸载的类的JNI样式签名。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.jdi.event (Java SE 9 & JDK 9 )

com.sun.jdi.event

Interfaces

  • AccessWatchpointEvent
  • BreakpointEvent
  • ClassPrepareEvent
  • ClassUnloadEvent
  • Event
  • EventIterator
  • EventQueue
  • EventSet
  • ExceptionEvent
  • LocatableEvent
  • MethodEntryEvent
  • MethodExitEvent
  • ModificationWatchpointEvent
  • MonitorContendedEnteredEvent
  • MonitorContendedEnterEvent
  • MonitorWaitedEvent
  • MonitorWaitEvent
  • StepEvent
  • ThreadDeathEvent
  • ThreadStartEvent
  • VMDeathEvent
  • VMDisconnectEvent
  • VMStartEvent
  • WatchpointEvent


com.sun.jdi.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.jdi

Package com.sun.jdi.event

该包定义了JDI事件和事件处理。 一个Event始终是一个成员EventSet ，从所检索的EventQueue 。 事件的例子包括"breakpoints events" ， "thread creation events"和"virtual machine death event" 。 除终止事件外，所有收到的事件都必须通过"EventRequest"进行请求。 com.sun.jdi.request包定义事件请求和事件请求管理。

方法可能会在以后的版本中添加到JDI包中的接口。 如果JDI成为标准扩展名，则可能会重命名现有的包。

  • 接口摘要
    接口 描述
    AccessWatchpointEvent
    通知目标VM中的现场访问。
    BreakpointEvent
    通知目标VM中的断点。
    ClassPrepareEvent
    在目标虚拟机中通知类准备。
    ClassUnloadEvent
    在目标VM中卸载类的通知。
    Event
    调试器感兴趣的目标虚拟机中的一个事件。
    EventIterator
    EventIterators是不可修改的。
    EventQueue
    目标虚拟机的调试器事件管理器。
    EventSet
    可以在给定时间由目标VirtualMachine创建几个Event对象。
    ExceptionEvent
    通知目标VM中的异常。
    LocatableEvent
    具有位置和线程的事件的抽象超界面。
    MethodEntryEvent
    在目标虚拟机中通知方法调用。
    MethodExitEvent
    在目标VM中返回方法的通知。
    ModificationWatchpointEvent
    通知目标VM中的字段修改。
    MonitorContendedEnteredEvent
    通知目标VM中的线程等待其他线程释放后进入监视器。
    MonitorContendedEnterEvent
    通知目标虚拟机中的线程正在尝试进入已被另一个线程获取的监视器。
    MonitorWaitedEvent
    通知目标VM中的线程已经完成等待监视器对象。
    MonitorWaitEvent
    通知目标VM中的线程即将等待监视器对象。
    StepEvent
    通知目标VM中的步骤完成。
    ThreadDeathEvent
    在目标虚拟机中通知已完成的线程。
    ThreadStartEvent
    在目标虚拟机中通知新运行的线程。
    VMDeathEvent
    目标VM终止通知。
    VMDisconnectEvent
    断开目标VM的通知。
    VMStartEvent
    通知初始化目标虚拟机。
    WatchpointEvent
    Notification of a field triggered event encountered by a thread in the target VM.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.jdi.event Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.jdi.event

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.Set<E>
        • com.sun.jdi.event.EventSet (also extends com.sun.jdi.Mirror)
  • java.util.Iterator<E>
    • com.sun.jdi.event.EventIterator
  • com.sun.jdi.Locatable
    • com.sun.jdi.event.LocatableEvent (also extends com.sun.jdi.event.Event)
      • com.sun.jdi.event.BreakpointEvent
      • com.sun.jdi.event.ExceptionEvent
      • com.sun.jdi.event.MethodEntryEvent
      • com.sun.jdi.event.MethodExitEvent
      • com.sun.jdi.event.MonitorContendedEnteredEvent
      • com.sun.jdi.event.MonitorContendedEnterEvent
      • com.sun.jdi.event.MonitorWaitedEvent
      • com.sun.jdi.event.MonitorWaitEvent
      • com.sun.jdi.event.StepEvent
      • com.sun.jdi.event.WatchpointEvent
        • com.sun.jdi.event.AccessWatchpointEvent
        • com.sun.jdi.event.ModificationWatchpointEvent
  • com.sun.jdi.Mirror
    • com.sun.jdi.event.Event
      • com.sun.jdi.event.ClassPrepareEvent
      • com.sun.jdi.event.ClassUnloadEvent
      • com.sun.jdi.event.LocatableEvent (also extends com.sun.jdi.Locatable)
        • com.sun.jdi.event.BreakpointEvent
        • com.sun.jdi.event.ExceptionEvent
        • com.sun.jdi.event.MethodEntryEvent
        • com.sun.jdi.event.MethodExitEvent
        • com.sun.jdi.event.MonitorContendedEnteredEvent
        • com.sun.jdi.event.MonitorContendedEnterEvent
        • com.sun.jdi.event.MonitorWaitedEvent
        • com.sun.jdi.event.MonitorWaitEvent
        • com.sun.jdi.event.StepEvent
        • com.sun.jdi.event.WatchpointEvent
          • com.sun.jdi.event.AccessWatchpointEvent
          • com.sun.jdi.event.ModificationWatchpointEvent
      • com.sun.jdi.event.ThreadDeathEvent
      • com.sun.jdi.event.ThreadStartEvent
      • com.sun.jdi.event.VMDeathEvent
      • com.sun.jdi.event.VMDisconnectEvent
      • com.sun.jdi.event.VMStartEvent
    • com.sun.jdi.event.EventQueue
    • com.sun.jdi.event.EventSet (also extends java.util.Set<E>)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface Event

  • All Superinterfaces:
    Mirror
    All Known Subinterfaces:
    AccessWatchpointEvent ， BreakpointEvent ， ClassPrepareEvent ， ClassUnloadEvent ， ExceptionEvent ， LocatableEvent ， MethodEntryEvent ， MethodExitEvent ， ModificationWatchpointEvent ， MonitorContendedEnteredEvent ， MonitorContendedEnterEvent ， MonitorWaitedEvent ， MonitorWaitEvent ， StepEvent ， ThreadDeathEvent ， ThreadStartEvent ， VMDeathEvent ， VMDisconnectEvent ， VMStartEvent ， WatchpointEvent

    public interface Event
extends Mirror
    调试器感兴趣的目标虚拟机中的一个事件。 事件是所有事件的公共高级（例子包括BreakpointEvent ， ExceptionEvent ， ClassPrepareEvent ）。 当事件发生时，作为一个组件活动的实例EventSet中排入所述VirtualMachine的EventQueue 。
    从以下版本开始：
    1.3
    另请参见：
    EventSet ， EventQueue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      EventRequest request​()

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • request

        EventRequest request​()
        结果
        EventRequest要求这个事件。 某些事件（例如VMDeathEvent ）可能没有相应的请求，因此将返回null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface EventIterator

  • All Superinterfaces:
    Iterator<Event>

    public interface EventIterator
extends Iterator<Event>
    EventIterators是不可修改的。
    从以下版本开始：
    1.3
    另请参见：
    Event ， EventSet ， Set.iterator()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Event nextEvent​()

      • Methods inherited from interface java.util.Iterator

        forEachRemaining, hasNext, next, remove

    • 方法详细信息

      • nextEvent

        Event nextEvent​()
        结果
        下一个Event在一个EventSet 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface EventQueue

  • All Superinterfaces:
    Mirror

    public interface EventQueue
extends Mirror
    目标虚拟机的调试器事件管理器。 事件总是分组在EventSet s。 调试器后端生成的EventSet可以在这里读取。 EventQueue有一个实例分配给一个特定的VirtualMachine 。

    有些事件会导致目标虚拟机的悬挂-事件请求（ com.sun.jdi.request ）与suspend policy的SUSPEND_ALL或者SUSPEND_EVENT_THREAD ，有时VMStartEvent 。 如果这些悬架未恢复，目标VM将挂起。 因此，从事件队列直到包含VMDisconnectEvent的EventSet为止读取每个EventSet，总是很好的策略为remove() 。 除非resume以另一种方式处理，否则每个EventSet应调用EventSet.resume() 。

    从以下版本开始：
    1.3
    另请参见：
    EventSet ， VirtualMachine

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      EventSet remove​()
      等待下一个可用的事件永远。
      EventSet remove​(long timeout)
      等待下一个可用事件的指定时间。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • remove

        EventSet remove​()
         throws InterruptedException
        等待下一个可用的事件永远。
        结果
        下一个EventSet 。
        异常
        InterruptedException - 如果任何线程中断了此线程。
        VMDisconnectedException - 如果与目标虚拟机的连接不再可用。 注意，这将永远在一个VMDisconnectEvent之前。

      • remove

        EventSet remove​(long timeout)
         throws InterruptedException
        等待下一个可用事件的指定时间。
        参数
        timeout - 等待下一个事件的时间（毫秒）
        结果
        下一个EventSet ，如果有超时则为 null。
        异常
        InterruptedException - 如果任何线程中断了此线程。
        VMDisconnectedException - 如果与目标虚拟机的连接不再可用。 注意，这将始终是一个VMDisconnectEvent 。
        IllegalArgumentException - 如果timeout参数包含非法值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface EventSet

  • All Superinterfaces:
    Collection<Event> ， Iterable<Event> ， Mirror ， Set<Event>

    public interface EventSet
extends Mirror, Set<Event>
    可以在给定时间由目标VirtualMachine创建几个Event对象。 例如，给定的Location可能有多个BreakpointRequest ，或者您可能单步到与BreakpointRequest相同的位置。 这些Event对象作为EventSet一起传递。 为了均匀性，EventSet始终用于传送Event个对象。 EventSet由EventQueue提供 。 EventSet是不可修改的。

    与发布事件集相关联，目标VM中可能发生暂停。 这些悬挂对应于suspend policy 。 为了确保匹配恢复发生，建议在可能的情况下完成对EventSet.resume()设置的事件的处理。

    分组在事件集中的事件受以下限制：

    • 总是单身套装
      • VMStartEvent
      • VMDisconnectEvent
    • 只有与其他VMDeathEvents：
      • VMDeathEvent
    • 只有与其他ThreadStartEvents相同的线程：
      • ThreadStartEvent
    • 只有与其他ThreadDeathEvent相同的线程：
      • ThreadDeathEvent
    • 只有同一个类的其他ClassPrepareEvents：
      • ClassPrepareEvent
    • 只有与同一类的其他ClassUnloadEvents：
      • ClassUnloadEvent
    • 只有与其他AccessWatchpointEvent相同的字段访问：
      • AccessWatchpointEvent
    • 只有与其他ModificationWatchpointEvent相同的字段修改：
      • ModificationWatchpointEvent
    • 只有与其他异常事件相同的异常发生：
      • ExceptionEvent
    • 只有与其他MethodExitEvent相同的方法退出：
      • MethodExitEvent
    • 只有与其他监视器竞争为相同的监视器对象输入事件：
      • 监控进入事件
    • 只有与其他监视器竞争输入的事件相同的监视器对象：
      • 监控进入的事件
    • 只有与其他显示器等待事件相同的监视器对象：
      • 监视等待事件
    • 只有与其他监视器等待事件相同的监视器对象：
      • 监视等待事件
    • 只有与这个组的其他成员，在相同的位置和在同一个线程：
      • BreakpointEvent
      • StepEvent
      • MethodEntryEvent
    从以下版本开始：
    1.3
    另请参见：
    Event ， EventQueue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      EventIterator eventIterator​()
      返回特定于Event对象的迭代器。
      void resume​()
      恢复此事件集挂起的线程。
      int suspendPolicy​()
      返回用于挂起该事件集的目标虚拟机中的线程的策略。

      • Methods inherited from interface java.util.Collection

        parallelStream, removeIf, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface java.util.Set

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, of, of, of, of, of, of, of, of, of, of, of, of, remove, removeAll, retainAll, size, spliterator, toArray, toArray

    • 方法详细信息

      • suspendPolicy

        int suspendPolicy​()
        返回用于挂起该事件集的目标虚拟机中的线程的策略。 该政策是从每个事件的请求的暂停政策中选择的; 目标虚拟机选择挂起最多线程的策略。 目标虚拟机根据该策略挂起线程，此处返回该策略。 有关可能的策略值，请参阅EventRequest 。

        在极少数情况下，如果在调试器系统线程中发生了ClassPrepareEvent ，则暂停策略可能与请求的值不同。 详见ClassPrepareEvent.thread() 。

        结果
        所述suspendPolicy其是 SUSPEND_ALL ， SUSPEND_EVENT_THREAD或 SUSPEND_NONE 。

      • eventIterator

        EventIterator eventIterator​()
        返回特定于Event个对象的迭代器。

      • resume

        void resume​()
        恢复此事件集挂起的线程。 如果suspendPolicy()为EventRequest.SUSPEND_ALL ，则此方法的调用相当于VirtualMachine.resume() 。 如果挂起策略是EventRequest.SUSPEND_EVENT_THREAD ，则调用此方法相当于事件线程的ThreadReference.resume() 。 否则，对此方法的调用是无效的。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExceptionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface ExceptionEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface ExceptionEvent
extends LocatableEvent
    通知目标VM中的异常。 当抛出一个满足当前已启用的exception request的异常时 ，将包含此类的实例的event set添加到VM的事件队列中。 如果从非本机方法抛出异常，则会在抛出异常的位置生成异常事件。 如果从本机方法抛出异常，则异常事件将在抛出异常后到达的第一个非本机位置生成。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Location catchLocation​()
      获取异常被捕获的位置。
      ObjectReference exception​()
      获取抛出的异常对象。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • exception

        ObjectReference exception​()
        获取抛出的异常对象。 异常对象是Throwable的实例或目标VM中的子类。
        结果
        一个ObjectReference镜像目标VM中抛出的对象。

      • catchLocation

        Location catchLocation​()
        获取异常被捕获的位置。 如果在抛出点处将当前位置动态地包含在处理异常的try语句中，则会被捕获异常。 （有关详细信息，请参阅JVM规范）。 如果有这样的try语句，catch位置是适当的catch子句的第一个代码索引。

        如果在异常时调用堆栈中存在本机方法，则有关返回的捕获位置的重要限制。 在这种情况下，无法预测一个异常是否会被调用堆栈上的一些本机方法处理。 因此，这里可能考虑未被考虑的异常实际上将由本机方法处理，而不会导致目标VM的终止。 此外，不能假定这里返回的捕获位置将由投掷线程达到。 如果当前位置和捕获位置之间存在本机帧，则可能会以该本机方法处理和清除该异常。

        请注意，编译器可能会在源代码中不显式的情况下生成try-catch块; 例如，为synchronized和finally块生成的代码可以包含隐式的try-catch块。 如果在抛出时在调用堆栈中存在这样一个隐式生成的try-catch，即使看起来没有考虑到源代码，异常也被认为被捕获。

        结果
        Location其中异常将被捕获，如果异常未被捕获，则为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LocatableEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface LocatableEvent

  • All Superinterfaces:
    Event ， Locatable ， Mirror
    All Known Subinterfaces:
    AccessWatchpointEvent ， BreakpointEvent ， ExceptionEvent ， MethodEntryEvent ， MethodExitEvent ， ModificationWatchpointEvent ， MonitorContendedEnteredEvent ， MonitorContendedEnterEvent ， MonitorWaitedEvent ， MonitorWaitEvent ， StepEvent ， WatchpointEvent

    public interface LocatableEvent
extends Event, Locatable
    具有位置和线程的事件的抽象超界面。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ThreadReference thread​()
      返回发生此事件的线程。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回发生此事件的线程。
        结果
        a ThreadReference which mirrors the event's thread in the target VM.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodEntryEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface MethodEntryEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface MethodEntryEvent
extends LocatableEvent
    在目标虚拟机中通知方法调用。 此事件发生在进入调用方法之后以及任何代码执行之前。 为本机和非本机方法生成方法入口事件。

    在一些虚拟机中，如果方法被调用为线程的初始化的一部分，则在其发生ThreadStartEvent之前，特定线程可能会发生方法入口事件。

    从以下版本开始：
    1.3
    另请参见：
    EventQueue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      方法 method​()
      返回输入的方法。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • method

        方法 method​()
        返回输入的方法。
        结果
        a 方法 which mirrors the method that was entered.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodExitEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface MethodExitEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface MethodExitEvent
extends LocatableEvent
    在目标VM中返回方法的通知。 该事件在方法中的所有代码都已执行后生成，但此事件的位置是方法中最后执行的位置。 为本机和非本机方法生成方法退出事件。 如果方法以抛出的异常终止，则不会生成方法退出事件。
    从以下版本开始：
    1.3
    另请参见：
    EventQueue

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      方法 method​()
      返回退出的方法。
      Value returnValue​()
      返回该方法将返回的值。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • method

        方法 method​()
        返回退出的方法。
        结果
        一个方法镜像退出的方法。
        异常
        ObjectCollectedException - 如果类被垃圾回收，可能会抛出。

      • returnValue

        Value returnValue​()
        返回该方法将返回的值。 并非所有目标虚拟机都支持此操作。 使用canGetMethodReturnValues()来确定是否支持此操作。
        结果
        一个Value镜像要返回的值。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作 - 请参阅 canGetMethodReturnValues()
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModificationWatchpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface ModificationWatchpointEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror ， WatchpointEvent

    public interface ModificationWatchpointEvent
extends WatchpointEvent
    通知目标VM中的字段修改。
    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine ， ModificationWatchpointRequest

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Value valueToBe​()
      当指令完成时将分配给该字段的值。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.event.WatchpointEvent

        field, object, valueCurrent

    • 方法详细信息

      • valueToBe

        Value valueToBe​()
        当指令完成时将分配给该字段的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorContendedEnteredEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface MonitorContendedEnteredEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface MonitorContendedEnteredEvent
extends LocatableEvent
    通知目标VM中的线程等待其他线程释放后进入监视器。
    从以下版本开始：
    1.6
    另请参见：
    EventQueue ， MonitorContendedEnterEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectReference monitor​()
      返回输入的监视器。
      ThreadReference thread​()
      返回发生此事件的线程。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回发生此事件的线程。
        Specified by:
        thread接口 LocatableEvent
        结果
        一个ThreadReference ，它反映了目标VM中事件的线程。

      • monitor

        ObjectReference monitor​()
        返回输入的监视器。
        结果
        一个ObjectReference的显示器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorContendedEnterEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface MonitorContendedEnterEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface MonitorContendedEnterEvent
extends LocatableEvent
    通知目标虚拟机中的线程正在尝试进入已被另一个线程获取的监视器。
    从以下版本开始：
    1.6
    另请参见：
    EventQueue ， MonitorContendedEnteredEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectReference monitor​()
      返回输入的方法。
      ThreadReference thread​()
      返回发生此事件的线程。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回发生此事件的线程。
        Specified by:
        thread在接口 LocatableEvent
        结果
        一个ThreadReference它反映了目标虚拟机中事件的线程。

      • monitor

        ObjectReference monitor​()
        返回输入的方法。
        结果
        一个ObjectReference的显示器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorWaitedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface MonitorWaitedEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface MonitorWaitedEvent
extends LocatableEvent
    通知目标VM中的线程已经完成等待监视器对象。
    从以下版本开始：
    1.6
    另请参见：
    EventQueue ， MonitorWaitEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectReference monitor​()
      返回此线程等待的监视器对象。
      ThreadReference thread​()
      返回发生此事件的线程。
      boolean timedout​()
      返回等待是否超时或中断。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回发生此事件的线程。
        Specified by:
        thread在接口 LocatableEvent
        结果
        一个ThreadReference镜像事件在目标VM中的线程。

      • monitor

        ObjectReference monitor​()
        返回此线程等待的监视器对象。
        结果
        一个ObjectReference的显示器。

      • timedout

        boolean timedout​()
        返回等待是否超时或中断。
        结果
        true如果等待超时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorWaitEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface MonitorWaitEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface MonitorWaitEvent
extends LocatableEvent
    通知目标VM中的线程即将等待监视器对象。
    从以下版本开始：
    1.6
    另请参见：
    EventQueue ， MonitorWaitedEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectReference monitor​()
      返回线程要等待的监视器对象。
      ThreadReference thread​()
      返回发生监视等待事件的线程。
      long timeout​()
      返回线程等待的毫秒数。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回发生监视等待事件的线程。
        Specified by:
        thread在接口 LocatableEvent
        结果
        一个ThreadReference镜像事件在目标VM中的线程。

      • monitor

        ObjectReference monitor​()
        返回线程要等待的监视器对象。
        结果
        一个ObjectReference的显示器。

      • timeout

        long timeout​()
        返回线程等待的毫秒数。
        结果
        一个 jlong包含监视器等待时间（以毫秒为单位）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StepEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface StepEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror

    public interface StepEvent
extends LocatableEvent
    通知目标VM中的步骤完成。 步骤事件在执行其位置的代码之前立即生成; 因此，如果步骤正在输入新的方法（可能发生在StepRequest.STEP_INTO ），则该事件的位置是该方法的第一条指令。 当一个步骤离开一个方法时，事件的位置将是在调用方法中调用之后的第一个指令; 请注意，即使使用了StepRequest.STEP_LINE ，该位置可能不在行边界。
    从以下版本开始：
    1.3
    另请参见：
    StepRequest ， EventQueue

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadDeathEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface ThreadDeathEvent

  • All Superinterfaces:
    Event ， Mirror

    public interface ThreadDeathEvent
extends Event
    在目标虚拟机中通知已完成的线程。 通知由死亡线程在终止之前生成。 由于这个时机， VirtualMachine.allThreads()可以在收到此事件后返回此线程。

    请注意，此事件不提供有关线程对象的生命周期的信息。 根据目标VM中存在的参考，它可能会或可能不会很快收集。

    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine ， ThreadReference

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ThreadReference thread​()
      返回正在终止的线程。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回正在终止的线程。
        结果
        a ThreadReference which mirrors the event's thread in the target VM.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadStartEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface ThreadStartEvent

  • All Superinterfaces:
    Event ， Mirror

    public interface ThreadStartEvent
extends Event
    在目标虚拟机中通知新运行的线程。 新线程可能是调用Thread.start()的结果，或者通过JNI将新线程附加到VM的结果。 该通知在新线程在执行开始之前一段时间生成。 由于这个时机，在接收到该事件之前可以接收线程的其他事件。 （值得注意的是，在线程初始化期间可能会发生MethodEntryEvent s和MethodExitEvent ）。在接收到此事件之前， VirtualMachine.allThreads()也可能返回一个新的启动线程。

    请注意，此事件不提供关于可能发生得更早的线程对象的创建的信息，具体取决于正在调试的VM。

    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine ， ThreadReference

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ThreadReference thread​()
      返回已经启动的线程。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回已经启动的线程。
        结果
        a ThreadReference which mirrors the event's thread in the target VM.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.jdi.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.jdi.event

  • Packages that use com.sun.jdi.event
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
  • Classes in com.sun.jdi.event used by com.sun.jdi
    Class 描述
    EventQueue
    目标虚拟机的调试器事件管理器。
  • Classes in com.sun.jdi.event used by com.sun.jdi.event
    Class 描述
    Event
    调试器感兴趣的目标虚拟机中的一个事件。
    EventIterator
    EventIterators是不可修改的。
    EventSet
    可以在给定时间由目标VirtualMachine创建几个Event对象。
    LocatableEvent
    具有位置和线程的事件的抽象超界面。
    WatchpointEvent
    通知目标VM中线程遇到的字段触发事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VMDeathEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface VMDeathEvent

  • All Superinterfaces:
    Event ， Mirror

    public interface VMDeathEvent
extends Event
    目标VM终止通知。 如果目标VM在VM断开连接之前终止，则会发生此事件（ VMDisconnectEvent ）。 因此，如果外部力量终止连接（例如崩溃）或如果连接故意终止，则不会发生此事件VirtualMachine.dispose()

    在VM终止时，一个未经请求的VMDeathEvent将始终与SUSPEND_NONE的suspend policy一起发送。 如果使用VMDeathRequest请求，附加的VMDeathEvent将在同一事件集中发送。

    VM仍然完整，可以在此事件启动时立即进行查询，但之后立即不会被视为完整的，无法查询。 注意：如果封闭EventSet具有suspend policy以外SUSPEND_ALL发起点可能早已过去。

    所有的VMDeathEvents都将在一个单独的EventSet中 ，不会在其他事件中设置事件。 在执行暂停的任何事件集之后，必须执行恢复以继续执行 - 在这种情况下允许正常关闭。

    从以下版本开始：
    1.3
    另请参见：
    VMDisconnectEvent ， EventRequestManager.createVMDeathRequest() ， VMDeathRequest ， EventQueue ， VirtualMachine

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VMDisconnectEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface VMDisconnectEvent

  • All Superinterfaces:
    Event ， Mirror

    public interface VMDisconnectEvent
extends Event
    断开目标VM的通知。 可能是由于VM的正常终止，通过未捕获的异常或其他错误的VM终止，调试器操作（ VirtualMachine.dispose()或VirtualMachine.exit(int) ）或外部事件（例如，操作系统的目标进程终止，传输终止等）引起的。

    如果目标VM在断开连接之前终止，则此事件之前将有一个VMDeathEvent 。

    此事件始终发送。 没有相应的EventRequest 。 封闭的单身人士EventSet总是有暂停政策EventRequest.SUSPEND_NONE 。

    从以下版本开始：
    1.3
    另请参见：
    VMDeathEvent ， EventQueue ， VirtualMachine

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VMStartEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface VMStartEvent

  • All Superinterfaces:
    Event ， Mirror

    public interface VMStartEvent
extends Event
    通知初始化目标虚拟机。 在主线程启动之前以及执行任何应用程序代码之前接收到此事件。 在此事件发生之前，大量的系统代码已经执行，并且已经加载了多个系统类。 此事件始终由目标VM生成，即使未明确请求。
    从以下版本开始：
    1.3
    另请参见：
    VMDeathEvent ， EventQueue ， VirtualMachine

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ThreadReference thread​()
      返回已启动的VM的初始线程。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • thread

        ThreadReference thread​()
        返回已启动的VM的初始线程。
        结果
        a ThreadReference which mirrors the event's thread in the target VM.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WatchpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.event

Interface WatchpointEvent

  • All Superinterfaces:
    Event ， Locatable ， LocatableEvent ， Mirror
    All Known Subinterfaces:
    AccessWatchpointEvent ， ModificationWatchpointEvent

    public interface WatchpointEvent
extends LocatableEvent
    通知目标VM中线程遇到的字段触发事件。
    从以下版本开始：
    1.3
    另请参见：
    EventQueue ， VirtualMachine

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Field field​()
      返回即将被访问/修改的字段。
      ObjectReference object​()
      返回字段即将被访问/修改的对象。
      Value valueCurrent​()
      现场值。

      • Methods inherited from interface com.sun.jdi.event.Event

        request

      • Methods inherited from interface com.sun.jdi.Locatable

        location

      • Methods inherited from interface com.sun.jdi.event.LocatableEvent

        thread

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • field

        Field field​()
        返回即将被访问/修改的字段。
        结果
        一个Field镜像目标VM中的字段。
        异常
        ObjectCollectedException - 如果类被垃圾回收，可能会抛出。

      • object

        ObjectReference object​()
        返回字段即将被访问/修改的对象。 返回null是访问是静态字段。
        结果
        一个ObjectReference它反映了目标VM中事件的对象。

      • valueCurrent

        Value valueCurrent​()
        现场值。
        异常
        ObjectCollectedException - 如果对象或类已被垃圾回收。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.AccessWatchpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.AccessWatchpointEvent

No usage of com.sun.jdi.event.AccessWatchpointEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.BreakpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.BreakpointEvent

No usage of com.sun.jdi.event.BreakpointEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.ClassPrepareEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.ClassPrepareEvent

No usage of com.sun.jdi.event.ClassPrepareEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.ClassUnloadEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.ClassUnloadEvent

No usage of com.sun.jdi.event.ClassUnloadEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.Event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.Event

  • Packages that use Event
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。

    • Uses of Event in com.sun.jdi.event

      Subinterfaces of Event in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  AccessWatchpointEvent
      通知目标VM中的现场访问。
      interface  BreakpointEvent
      通知目标VM中的断点。
      interface  ClassPrepareEvent
      在目标虚拟机中通知类准备。
      interface  ClassUnloadEvent
      在目标VM中卸载类的通知。
      interface  ExceptionEvent
      通知目标VM中的异常。
      interface  LocatableEvent
      具有位置和线程的事件的抽象超界面。
      interface  MethodEntryEvent
      在目标虚拟机中通知方法调用。
      interface  MethodExitEvent
      在目标VM中返回方法的通知。
      interface  ModificationWatchpointEvent
      通知目标VM中的字段修改。
      interface  MonitorContendedEnteredEvent
      通知目标VM中的线程等待其他线程释放后进入监视器。
      interface  MonitorContendedEnterEvent
      通知目标虚拟机中的线程正在尝试进入已被另一个线程获取的监视器。
      interface  MonitorWaitedEvent
      通知目标VM中的线程已经完成等待监视器对象。
      interface  MonitorWaitEvent
      通知目标VM中的线程即将等待监视器对象。
      interface  StepEvent
      通知目标VM中的步骤完成。
      interface  ThreadDeathEvent
      在目标虚拟机中通知已完成的线程。
      interface  ThreadStartEvent
      在目标虚拟机中通知新运行的线程。
      interface  VMDeathEvent
      目标VM终止通知。
      interface  VMDisconnectEvent
      断开目标VM的通知。
      interface  VMStartEvent
      通知初始化目标虚拟机。
      interface  WatchpointEvent
      通知目标VM中线程遇到的字段触发事件。
      Methods in com.sun.jdi.event that return Event
      Modifier and Type | 方法 | 描述
      Event | EventIterator.nextEvent​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.EventIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.EventIterator

  • Packages that use EventIterator
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。

    • Uses of EventIterator in com.sun.jdi.event

      Methods in com.sun.jdi.event that return EventIterator
      Modifier and Type 方法 描述
      EventIterator EventSet.eventIterator​()
      返回特定于Event对象的迭代器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.EventQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.EventQueue

  • Packages that use EventQueue
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of EventQueue in com.sun.jdi

      Methods in com.sun.jdi that return EventQueue
      Modifier and Type 方法 描述
      EventQueue VirtualMachine.eventQueue​()
      返回此虚拟机的事件队列。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.EventSet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.EventSet

  • Packages that use EventSet
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。

    • Uses of EventSet in com.sun.jdi.event

      Methods in com.sun.jdi.event that return EventSet
      Modifier and Type 方法 描述
      EventSet EventQueue.remove​()
      等待下一个可用的事件永远。
      EventSet EventQueue.remove​(long timeout)
      等待下一个可用事件的指定时间。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.ExceptionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.ExceptionEvent

No usage of com.sun.jdi.event.ExceptionEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.LocatableEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.LocatableEvent

  • Packages that use LocatableEvent
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。

    • Uses of LocatableEvent in com.sun.jdi.event

      Subinterfaces of LocatableEvent in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  AccessWatchpointEvent
      通知目标VM中的现场访问。
      interface  BreakpointEvent
      通知目标VM中的断点。
      interface  ExceptionEvent
      通知目标VM中的异常。
      interface  MethodEntryEvent
      在目标虚拟机中通知方法调用。
      interface  MethodExitEvent
      在目标VM中返回方法的通知。
      interface  ModificationWatchpointEvent
      通知目标VM中的字段修改。
      interface  MonitorContendedEnteredEvent
      通知目标VM中的线程等待其他线程释放后进入监视器。
      interface  MonitorContendedEnterEvent
      通知目标虚拟机中的线程正在尝试进入已被另一个线程获取的监视器。
      interface  MonitorWaitedEvent
      通知目标VM中的线程已经完成等待监视器对象。
      interface  MonitorWaitEvent
      通知目标VM中的线程即将等待监视器对象。
      interface  StepEvent
      通知目标VM中的步骤完成。
      interface  WatchpointEvent
      Notification of a field triggered event encountered by a thread in the target VM.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.MethodEntryEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.MethodEntryEvent

No usage of com.sun.jdi.event.MethodEntryEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.MethodExitEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.MethodExitEvent

No usage of com.sun.jdi.event.MethodExitEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.ModificationWatchpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.ModificationWatchpointEvent

No usage of com.sun.jdi.event.ModificationWatchpointEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.MonitorContendedEnteredEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.MonitorContendedEnteredEvent

No usage of com.sun.jdi.event.MonitorContendedEnteredEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.MonitorContendedEnterEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.MonitorContendedEnterEvent

No usage of com.sun.jdi.event.MonitorContendedEnterEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.MonitorWaitedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.MonitorWaitedEvent

No usage of com.sun.jdi.event.MonitorWaitedEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.MonitorWaitEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.MonitorWaitEvent

No usage of com.sun.jdi.event.MonitorWaitEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.StepEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.StepEvent

No usage of com.sun.jdi.event.StepEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.ThreadDeathEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.ThreadDeathEvent

No usage of com.sun.jdi.event.ThreadDeathEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.ThreadStartEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.ThreadStartEvent

No usage of com.sun.jdi.event.ThreadStartEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.VMDeathEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.VMDeathEvent

No usage of com.sun.jdi.event.VMDeathEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.VMDisconnectEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.VMDisconnectEvent

No usage of com.sun.jdi.event.VMDisconnectEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.VMStartEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.VMStartEvent

No usage of com.sun.jdi.event.VMStartEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.event.WatchpointEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.event.WatchpointEvent

  • Packages that use WatchpointEvent
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。

    • Uses of WatchpointEvent in com.sun.jdi.event

      Subinterfaces of WatchpointEvent in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  AccessWatchpointEvent
      通知目标VM中的现场访问。
      interface  ModificationWatchpointEvent
      通知目标VM中的字段修改。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AccessWatchpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface AccessWatchpointRequest

  • All Superinterfaces:
    EventRequest ， Mirror ， WatchpointRequest

    public interface AccessWatchpointRequest
extends WatchpointRequest
    在目标虚拟机中访问字段的内容时请求通知。 当Java编程语言代码或Java Native Interface（JNI）获取函数（ Get<Type>Field, GetStatic<Type>Field ）访问指定的字段时，将触发此事件。 JDI的访问不会触发此事件。 当开启了AccessWatchpointRequest被满足，一个event set含有AccessWatchpointEvent将被放置在EventQueue 。 现有ExceptionRequests的收集是由管理EventRequestManager现有观察点的集合是由管理EventRequestManager 。

    请注意，字段的修改不被视为访问。

    从以下版本开始：
    1.3
    另请参见：
    ModificationWatchpointRequest ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.request.WatchpointRequest

        addClassExclusionFilter, addClassFilter, addClassFilter, addInstanceFilter, addThreadFilter, field
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BreakpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface BreakpointRequest

  • All Superinterfaces:
    EventRequest ， Locatable ， Mirror

    public interface BreakpointRequest
extends EventRequest, Locatable
    标识目标虚拟机中应停止执行的Location 。 当开启了BreakpointRequest被满足，一个event set含有BreakpointEvent将被放置在EventQueue和应用被中断。 现有断点的收集由EventRequestManager管理
    从以下版本开始：
    1.3
    另请参见：
    Location ， BreakpointEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      Location location​()
      返回请求断点的位置。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • location

        Location location​()
        返回请求断点的位置。
        Specified by:
        location在接口 Locatable
        结果
        这个断点已经设定在Location 。

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()确定是否支持该操作。

        参数
        instance - 为了通过此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassPrepareRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface ClassPrepareRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface ClassPrepareRequest
extends EventRequest
    在目标虚拟机中准备课程时请求通知。 当启用了ClassPrepareRequest时，包含ClassPrepareEvent的event set将被放置在EventQueue上 。 现有ClassPrepareRequests的收集是由管理EventRequestManager

    Java虚拟机规范中定义了类准备。

    从以下版本开始：
    1.3
    另请参见：
    ClassPrepareEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将此请求生成的事件限制为编写名称与此受限正则表达式 不匹配的引用类型。
      void addClassFilter​(ReferenceType refType)
      限制此请求生成的事件，作为给定引用类型和任何子类型的准备。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制为编写名称与此受限正则表达式匹配的引用类型。
      void addSourceNameFilter​(String sourceNamePattern)
      将此请求生成的事件限制为准备引用类型，受限正则表达式“sourceNamePattern”与正在准备的引用类型的“sourceNames”匹配。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        限制此请求生成的事件，作为给定引用类型和任何子类型的准备。 将为任何可以安全地转换为给定参考类型的准备参考类型生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制为编写名称与此受限正则表达式匹配的引用类型。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制为编写名称与此受限正则表达式不匹配的引用类型。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已删除。 过滤器只能添加到禁用的请求中。

      • addSourceNameFilter

        void addSourceNameFilter​(String sourceNamePattern)
        将此请求生成的事件限制为准备引用类型，受限正则表达式“sourceNamePattern”与正在准备的引用类型的“sourceNames”匹配。 也就是说，如果refType是准备好的ReferenceType，那么至少存在一个层次，在refType.availableStrata（）返回的列表上调用'someStratum'; 以便refType.sourceNames（someStratam）返回的列表上的名称匹配'sourceNamePattern'。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseSourceNameFilters()来确定是否支持该操作。

        参数
        sourceNamePattern - 要过滤的模式字符串。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassUnloadRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface ClassUnloadRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface ClassUnloadRequest
extends EventRequest
    在目标虚拟机中卸载类时请求通知。 当开启了ClassUnloadRequest被满足时，一个event set含有ClassUnloadEvent将被放置在EventQueue 。 现有ClassUnloadRequests的收集是由管理EventRequestManager

    有关类卸载的更多信息，请参阅Java虚拟机规范。

    从以下版本开始：
    1.3
    另请参见：
    ClassUnloadEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将此请求生成的事件限制为卸载其名称与受限正则表达式 不匹配的引用类型。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制为卸载其名称与受限正则表达式匹配的引用类型。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制为卸载其名称与受限正则表达式匹配的引用类型。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制为卸载其名称与受限正则表达式不匹配的引用类型。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.jdi.request (Java SE 9 & JDK 9 )

com.sun.jdi.request

Interfaces

  • AccessWatchpointRequest
  • BreakpointRequest
  • ClassPrepareRequest
  • ClassUnloadRequest
  • EventRequest
  • EventRequestManager
  • ExceptionRequest
  • MethodEntryRequest
  • MethodExitRequest
  • ModificationWatchpointRequest
  • MonitorContendedEnteredRequest
  • MonitorContendedEnterRequest
  • MonitorWaitedRequest
  • MonitorWaitRequest
  • StepRequest
  • ThreadDeathRequest
  • ThreadStartRequest
  • VMDeathRequest
  • WatchpointRequest

Exceptions

  • DuplicateRequestException
  • InvalidRequestStateException


com.sun.jdi.request (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.jdi

Package com.sun.jdi.request

该包用于请求在指定条件下发送JDI事件。 除了始终发送的终止事件之外 ，每种Event都有一种EventRequest - 例如， BreakpointRequest用于请求BreakpointEvent 。 事件请求由EventRequestManager创建。 事件和事件处理在com.sun.jdi.event包中定义。

方法可能会在以后的版本中添加到JDI包中的接口。 如果JDI成为标准扩展名，则可能会重命名现有的包。

  • 接口摘要
    接口 描述
    AccessWatchpointRequest
    在目标虚拟机中访问字段的内容时请求通知。
    BreakpointRequest
    标识目标虚拟机中应停止执行的Location 。
    ClassPrepareRequest
    在目标虚拟机中准备课程时请求通知。
    ClassUnloadRequest
    在目标虚拟机中卸载类时请求通知。
    EventRequest
    表示通知事件的请求。
    EventRequestManager
    管理创建和删除EventRequest s。
    ExceptionRequest
    在目标虚拟机发生异常时请求通知。
    MethodEntryRequest
    在目标虚拟机中调用方法时请求通知。
    MethodExitRequest
    当方法在目标虚拟机中返回时请求通知。
    ModificationWatchpointRequest
    设置字段时请求通知。
    MonitorContendedEnteredRequest
    在等待其他线程释放之后，请求目标VM中的线程通知进入监视器。
    MonitorContendedEnterRequest
    请求在目标VM中尝试进入另一个线程已经获取的监视器的线程的通知。
    MonitorWaitedRequest
    当目标虚拟机中的线程已经完成等待监视对象时，请求通知。
    MonitorWaitRequest
    当目标虚拟机中的线程即将等待监视对象时，请求通知。
    StepRequest
    在目标虚拟机中发生步骤时请求通知。
    ThreadDeathRequest
    线程在目标虚拟机中终止时请求通知。
    ThreadStartRequest
    线程在目标虚拟机中启动执行时请求通知。
    VMDeathRequest
    当目标VM终止时请求通知。
    WatchpointRequest
    标识正在观看的目标虚拟机中的Field 。
  • 异常摘要
    异常 描述
    DuplicateRequestException
    抛出以表示重复的事件请求。
    InvalidRequestStateException
    抛出以表示所请求的事件由于启用而无法修改。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.jdi.request Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.jdi.request

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • com.sun.jdi.request.DuplicateRequestException
          • com.sun.jdi.request.InvalidRequestStateException

Interface Hierarchy

  • com.sun.jdi.Locatable
    • com.sun.jdi.request.BreakpointRequest (also extends com.sun.jdi.request.EventRequest)
  • com.sun.jdi.Mirror
    • com.sun.jdi.request.EventRequest
      • com.sun.jdi.request.BreakpointRequest (also extends com.sun.jdi.Locatable)
      • com.sun.jdi.request.ClassPrepareRequest
      • com.sun.jdi.request.ClassUnloadRequest
      • com.sun.jdi.request.ExceptionRequest
      • com.sun.jdi.request.MethodEntryRequest
      • com.sun.jdi.request.MethodExitRequest
      • com.sun.jdi.request.MonitorContendedEnteredRequest
      • com.sun.jdi.request.MonitorContendedEnterRequest
      • com.sun.jdi.request.MonitorWaitedRequest
      • com.sun.jdi.request.MonitorWaitRequest
      • com.sun.jdi.request.StepRequest
      • com.sun.jdi.request.ThreadDeathRequest
      • com.sun.jdi.request.ThreadStartRequest
      • com.sun.jdi.request.VMDeathRequest
      • com.sun.jdi.request.WatchpointRequest
        • com.sun.jdi.request.AccessWatchpointRequest
        • com.sun.jdi.request.ModificationWatchpointRequest
    • com.sun.jdi.request.EventRequestManager
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


DuplicateRequestException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Class DuplicateRequestException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.request.DuplicateRequestException
  • All Implemented Interfaces:
    Serializable

    public class DuplicateRequestException
extends RuntimeException
    抛出以表示重复的事件请求。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DuplicateRequestException​()
      DuplicateRequestException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • DuplicateRequestException

        public DuplicateRequestException​()

      • DuplicateRequestException

        public DuplicateRequestException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface EventRequest

  • All Superinterfaces:
    Mirror
    All Known Subinterfaces:
    AccessWatchpointRequest ， BreakpointRequest ， ClassPrepareRequest ， ClassUnloadRequest ， ExceptionRequest ， MethodEntryRequest ， MethodExitRequest ， ModificationWatchpointRequest ， MonitorContendedEnteredRequest ， MonitorContendedEnterRequest ， MonitorWaitedRequest ， MonitorWaitRequest ， StepRequest ， ThreadDeathRequest ， ThreadStartRequest ， VMDeathRequest ， WatchpointRequest

    public interface EventRequest
extends Mirror
    表示通知事件的请求。 示例包括BreakpointRequest和ExceptionRequest 。 当发生启用请求的事件发生时， EventSet将被放置在EventQueue上 。 现有事件请求的收集由EventRequestManager管理。

    可以通过过滤器控制为事件请求生成的事件数。 过滤器提供事件在事件队列放置之前必须满足的附加约束。 可以通过多次调用过滤添加方法（如ExceptionRequest.addClassFilter(java.lang.String classPattern)）来使用多个过滤器。 只有当事件被禁用时，过滤器才会一次添加到事件中。 使用CUT-OFF AND应用多个过滤器，按照它们被添加到请求的顺序。 只有满足所有过滤器的事件才会放在事件队列中。

    一组可用的过滤器取决于事件请求，一些过滤器的示例是：

    • 线程过滤器允许控制生成事件的线程。
    • 类过滤器允许控制事件发生的类。
    • 实例过滤器允许控制事件发生的实例。
    • 计数过滤器可以控制事件报告的次数。
    过滤器可以通过减少从目标虚拟机发送到调试器VM的事件流量大大提高调试器性能。

    EventRequest以EventRequest作为参数的任何方法可能会导致VMDisconnectedException如果目标VM断开连接，并且VMDisconnectEvent已经或可以从EventQueue读取。

    如果目标虚拟机的内存EventRequest ，则EventRequest作为参数的方法可能会抛出VMOutOfMemoryException 。

    从以下版本开始：
    1.3
    另请参见：
    BreakpointEvent ， EventQueue ， EventRequestManager

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int SUSPEND_ALL
      发生事件时暂停所有线程
      static int SUSPEND_EVENT_THREAD
      当事件发生时，只挂起生成事件的线程
      static int SUSPEND_NONE
      事件发生时暂停线程

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addCountFilter​(int count)
      在给定数量的事件发生后，限制所要求的事件最多报告一次。
      void disable​()
      与 setEnabled(false)相同。
      void enable​()
      与 setEnabled(true)相同。
      Object getProperty​(Object key)
      使用指定的键返回属性的值。
      boolean isEnabled​()
      确定此事件请求当前是否已启用。
      void putProperty​(Object key, Object value)
      向此请求添加任意键/值“属性”。
      void setEnabled​(boolean val)
      启用或禁用此事件请求。
      void setSuspendPolicy​(int policy)
      确定在目标VM中发生请求的事件时挂起的线程。
      int suspendPolicy​()
      返回一个值，该值描述在目标VM中发生请求的事件时挂起的线程。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 字段详细信息

      • SUSPEND_NONE

        static final int SUSPEND_NONE
        事件发生时暂停线程
        另请参见：
        Constant Field Values

      • SUSPEND_EVENT_THREAD

        static final int SUSPEND_EVENT_THREAD
        当事件发生时，只挂起生成事件的线程
        另请参见：
        Constant Field Values

      • SUSPEND_ALL

        static final int SUSPEND_ALL
        发生事件时暂停所有线程
        另请参见：
        Constant Field Values

    • 方法详细信息

      • isEnabled

        boolean isEnabled​()
        确定此事件请求当前是否已启用。
        结果
        true如果启用; 否则为false 。

      • setEnabled

        void setEnabled​(boolean val)
        启用或禁用此事件请求。 当此事件请求被禁用时，事件请求将被忽略，并且如果其任何线程到达事件请求，目标VM将不会被停止。 已禁用的事件请求仍然存在，并包含在事件请求列表中，如EventRequestManager.breakpointRequests() 。
        参数
        val - true如果要启用事件请求; false否则。
        异常
        InvalidRequestStateException - 如果此请求已被删除。
        IllegalThreadStateException - 如果这是一个StepRequest， val是 true ，并且请求中命名的线程已经死亡或尚未启动。

      • enable

        void enable​()
        与 setEnabled(true)相同。
        异常
        InvalidRequestStateException - 如果此请求已被删除。
        IllegalThreadStateException - 如果这是一个StepRequest，请求中命名的线程已经死机或尚未启动。

      • disable

        void disable​()
        与 setEnabled(false)相同。
        异常
        InvalidRequestStateException - 如果此请求已被删除。

      • addCountFilter

        void addCountFilter​(int count)
        在给定数量的事件发生后，限制所要求的事件最多报告一次。 该事件未报告此过滤器的第一个count - 1次。 要请求一次性事件，请调用此方法计数1。

        计数达到0后，将应用此请求中的任何后续过滤器。 如果没有这些过滤器导致事件被抑制，则会报告事件。 否则，不报告事件。 在这两种情况下，从未报告此请求的后续事件。

        参数
        count - 生成事件之前的次数。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        IllegalArgumentException - 如果 count小于1。

      • setSuspendPolicy

        void setSuspendPolicy​(int policy)
        确定在目标VM中发生请求的事件时挂起的线程。 使用SUSPEND_ALL挂起目标虚拟机中的所有线程（默认值）。 使用SUSPEND_EVENT_THREAD只挂起生成事件的线程。 使用SUSPEND_NONE暂停线程。

        通过事件进行的线程暂停具有与明确请求的暂停相同的功能 详见ThreadReference.suspend()和VirtualMachine.suspend() 。

        参数
        policy - 选定的挂起政策。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 暂停策略只能在禁用请求中设置。
        IllegalArgumentException - 如果policy参数包含非法值。

      • suspendPolicy

        int suspendPolicy​()
        返回一个值，该值描述在目标VM中发生请求的事件时挂起的线程。 返回的值是SUSPEND_ALL ， SUSPEND_EVENT_THREAD ，或SUSPEND_NONE 。
        结果
        当前挂起模式的请求

      • putProperty

        void putProperty​(Object key,
                 Object value)
        向此请求添加任意键/值“属性”。 该属性可由JDI的客户端使用，将应用程序信息与请求相关联; JDI内部不使用这些客户端集属性。

        get/putProperty方法提供对每个实例地图的访问。 这不能与Properties混淆。

        如果值为null，则此方法将删除该属性。

        另请参见：
        getProperty(java.lang.Object)

      • getProperty

        Object getProperty​(Object key)
        使用指定的键返回属性的值。 只有使用putProperty(java.lang.Object, java.lang.Object)添加的属性将返回非空值。
        结果
        该属性的值或null
        另请参见：
        putProperty(java.lang.Object, java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventRequestManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface EventRequestManager

  • All Superinterfaces:
    Mirror

    public interface EventRequestManager
extends Mirror
    管理创建和删除EventRequest s。 该接口的单个实现者存在于特定VM中，并通过VirtualMachine.eventRequestManager()进行访问
    从以下版本开始：
    1.3
    另请参见：
    EventRequest ， Event ， BreakpointRequest ， BreakpointEvent ， VirtualMachine

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<AccessWatchpointRequest> accessWatchpointRequests​()
      返回启用和禁用的访问观察点请求的不可修改的列表。
      List<BreakpointRequest> breakpointRequests​()
      返回启用和禁用的断点请求的不可修改的列表。
      List<ClassPrepareRequest> classPrepareRequests​()
      返回启用和禁用的类准备请求的不可修改的列表。
      List<ClassUnloadRequest> classUnloadRequests​()
      返回启用和禁用的类卸载请求的不可修改的列表。
      AccessWatchpointRequest createAccessWatchpointRequest​(Field field)
      创建一个新的禁用的观察点，监视对指定字段的访问。
      BreakpointRequest createBreakpointRequest​(Location location)
      创建一个新的禁用BreakpointRequest 。
      ClassPrepareRequest createClassPrepareRequest​()
      创建一个新的禁用ClassPrepareRequest 。
      ClassUnloadRequest createClassUnloadRequest​()
      创建一个新的禁用ClassUnloadRequest 。
      ExceptionRequest createExceptionRequest​(ReferenceType refType, boolean notifyCaught, boolean notifyUncaught)
      创建一个新的禁用ExceptionRequest 。
      MethodEntryRequest createMethodEntryRequest​()
      创建一个新的禁用MethodEntryRequest 。
      MethodExitRequest createMethodExitRequest​()
      创建一个新的禁用MethodExitRequest 。
      ModificationWatchpointRequest createModificationWatchpointRequest​(Field field)
      创建一个新的禁用的观察点，监视对指定字段的访问。
      MonitorContendedEnteredRequest createMonitorContendedEnteredRequest​()
      创建一个新的禁用MonitorContendedEnteredRequest 。
      MonitorContendedEnterRequest createMonitorContendedEnterRequest​()
      创建一个新的禁用MonitorContendedEnterRequest 。
      MonitorWaitedRequest createMonitorWaitedRequest​()
      创建一个新的禁用MonitorWaitedRequest 。
      MonitorWaitRequest createMonitorWaitRequest​()
      创建一个新的禁用MonitorWaitRequest 。
      StepRequest createStepRequest​(ThreadReference thread, int size, int depth)
      创建一个新的禁用StepRequest 。
      ThreadDeathRequest createThreadDeathRequest​()
      创建一个新的禁用ThreadDeathRequest 。
      ThreadStartRequest createThreadStartRequest​()
      创建一个新的禁用ThreadStartRequest 。
      VMDeathRequest createVMDeathRequest​()
      创建一个新的禁用VMDeathRequest 。
      void deleteAllBreakpoints​()
      删除此EventRequestManager管理的所有断点。
      void deleteEventRequest​(EventRequest eventRequest)
      删除eventRequest。
      void deleteEventRequests​(List<? extends EventRequest> eventRequests)
      删除EventRequest的列表。
      List<ExceptionRequest> exceptionRequests​()
      返回启用和禁用的异常请求的不可修改的列表。
      List<MethodEntryRequest> methodEntryRequests​()
      返回启用和禁用的方法条目请求的不可修改列表。
      List<MethodExitRequest> methodExitRequests​()
      返回启用和禁用的方法退出请求的不可修改的列表。
      List<ModificationWatchpointRequest> modificationWatchpointRequests​()
      返回启用和禁用的修改观察点请求的不可修改的列表。
      List<MonitorContendedEnteredRequest> monitorContendedEnteredRequests​()
      返回已启用和禁用的已监视输入请求的不可修改的列表。
      List<MonitorContendedEnterRequest> monitorContendedEnterRequests​()
      返回启用和禁用的监视器竞争的输入请求的不可修改的列表。
      List<MonitorWaitedRequest> monitorWaitedRequests​()
      返回启用和禁用的监视器等待请求的不可修改的列表。
      List<MonitorWaitRequest> monitorWaitRequests​()
      返回启用和禁用的监视器等待请求的不可修改的列表。
      List<StepRequest> stepRequests​()
      返回启用和禁用的步骤请求的不可修改的列表。
      List<ThreadDeathRequest> threadDeathRequests​()
      返回启用和禁用的线程死亡请求的不可修改的列表。
      List<ThreadStartRequest> threadStartRequests​()
      返回启用和禁用的线程启动请求的不可修改的列表。
      List<VMDeathRequest> vmDeathRequests​()
      返回启用和禁用的VM死亡请求的不可修改的列表。

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • createClassPrepareRequest

        ClassPrepareRequest createClassPrepareRequest​()
        创建一个新的禁用ClassPrepareRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。
        结果
        创建的ClassPrepareRequest

      • createClassUnloadRequest

        ClassUnloadRequest createClassUnloadRequest​()
        创建一个新的禁用ClassUnloadRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。
        结果
        创建的ClassUnloadRequest

      • createThreadStartRequest

        ThreadStartRequest createThreadStartRequest​()
        创建一个新的禁用ThreadStartRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。
        结果
        创建的ThreadStartRequest

      • createThreadDeathRequest

        ThreadDeathRequest createThreadDeathRequest​()
        创建一个新的禁用ThreadDeathRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。
        结果
        创建的ThreadDeathRequest

      • createExceptionRequest

        ExceptionRequest createExceptionRequest​(ReferenceType refType,
                                        boolean notifyCaught,
                                        boolean notifyUncaught)
        创建一个新的禁用ExceptionRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。

        可以为异常事件选择特定的异常类型及其子类。 可以选择捕获异常，未捕获的异常或两者。 但是请注意，在抛出异常的时候，并不总是能够确定它是否被真正的捕获。 详见ExceptionEvent.catchLocation() 。

        参数
        refType - 如果非空，则指定将引用作为refType实例的异常。 注意：这将包括子类型的实例。 如果为null，则将报告所有实例
        notifyCaught - 如果为true，将捕获异常。
        notifyUncaught - 如果为真，将报告未捕获的异常。
        结果
        创建的ExceptionRequest

      • createMethodEntryRequest

        MethodEntryRequest createMethodEntryRequest​()
        创建一个新的禁用MethodEntryRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。
        结果
        创建的MethodEntryRequest

      • createMethodExitRequest

        MethodExitRequest createMethodExitRequest​()
        创建一个新的禁用MethodExitRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。
        结果
        创建的MethodExitRequest

      • createMonitorContendedEnterRequest

        MonitorContendedEnterRequest createMonitorContendedEnterRequest​()
        创建一个新的禁用MonitorContendedEnterRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canRequestMonitorEvents()确定是否支持该操作。
        结果
        创建的MonitorContendedEnterRequest
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        从以下版本开始：
        1.6

      • createMonitorContendedEnteredRequest

        MonitorContendedEnteredRequest createMonitorContendedEnteredRequest​()
        创建一个新的禁用MonitorContendedEnteredRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canRequestMonitorEvents()来确定是否支持该操作。
        结果
        创建的MonitorContendedEnteredRequest
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        从以下版本开始：
        1.6

      • createMonitorWaitRequest

        MonitorWaitRequest createMonitorWaitRequest​()
        创建一个新的禁用MonitorWaitRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canRequestMonitorEvents()来确定是否支持该操作。
        结果
        创建的MonitorWaitRequest
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        从以下版本开始：
        1.6

      • createMonitorWaitedRequest

        MonitorWaitedRequest createMonitorWaitedRequest​()
        创建一个新的禁用MonitorWaitedRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。 并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canRequestMonitorEvents()来确定是否支持该操作。
        结果
        创建的MonitorWaitedRequest
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        从以下版本开始：
        1.6

      • createStepRequest

        StepRequest createStepRequest​(ThreadReference thread,
                              int size,
                              int depth)
        创建一个新的禁用StepRequest 。 新事件请求被添加到由此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。

        返回的请求将仅在指定的thread控制步进; 所有其他线程将不受影响。 size值StepRequest.STEP_MIN将在每次代码索引更改时生成步骤事件。 它表示可用的最小步长，通常映射到指令级别。 甲size的值StepRequest.STEP_LINE将生成步骤事件每次源极线的变化，除非行号信息不可用，在这种情况下STEP_MIN将被代替完成。 例如，在通过VirtualMachine.redefineClasses(java.util.Map<? extends com.sun.jdi.ReferenceType, byte[]>)操作已被废弃的方法的执行期间，没有行号信息可用。 depth值为StepRequest.STEP_INTO将在任何调用的方法中生成步骤事件。 depth值为StepRequest.STEP_OVER将步骤事件限制为当前帧或呼叫帧。 depth值为StepRequest.STEP_OUT仅将步骤事件限制到呼叫者帧。 在步骤发生之前，所有深度限制都相对于调用堆栈。

        每个线程只允许一个待处理的步骤请求。

        请注意，在检测到第一步后，典型的调试器将要取消步进。 因此，下一行方法将执行以下操作：

           EventRequestManager mgr = myVM.{@link VirtualMachine#eventRequestManager eventRequestManager}(); StepRequest request = mgr.createStepRequest(myThread, StepRequest.{@link StepRequest#STEP_LINE STEP_LINE}, StepRequest.{@link StepRequest#STEP_OVER STEP_OVER}); request.{@link EventRequest#addCountFilter addCountFilter}(1); // next step only request.enable(); myVM.{@link VirtualMachine#resume resume}();
        参数
        thread - 要步进的线程
        depth - 阶梯深度
        size - 步长
        结果
        创建的StepRequest
        异常
        DuplicateRequestException - 如果已经有指定线程的待处理步骤请求。
        IllegalArgumentException - 如果size或depth参数包含非法值。

      • createBreakpointRequest

        BreakpointRequest createBreakpointRequest​(Location location)
        创建一个新的禁用BreakpointRequest 。 给定的Location必须具有有效（即非负）代码索引。 新的断点被添加到由此EventRequestManager管理的列表中。 允许在同一位置的多个断点。 使用EventRequest.enable()激活此事件请求。
        参数
        location - 新断点的位置。
        结果
        创建的BreakpointRequest
        异常
        NativeMethodException - 如果位置在本机方法之内。

      • createAccessWatchpointRequest

        AccessWatchpointRequest createAccessWatchpointRequest​(Field field)
        创建一个新的禁用的观察点，监视对指定字段的访问。 新的观察点被添加到由此EventRequestManager管理的列表中。 允许同一领域的多个观察点。 使用EventRequest.enable()激活此事件请求。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canWatchFieldAccess()来确定是否支持该操作。

        参数
        field - 要观看的字段
        结果
        创建的观察点
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。

      • createModificationWatchpointRequest

        ModificationWatchpointRequest createModificationWatchpointRequest​(Field field)
        创建一个新的禁用的观察点，监视对指定字段的访问。 新的观察点被添加到由此EventRequestManager管理的列表中。 允许同一领域的多个观察点。 使用EventRequest.enable()激活此事件请求。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canWatchFieldModification()来确定是否支持该操作。

        参数
        field - 要观看的字段
        结果
        创建的观察点
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。

      • createVMDeathRequest

        VMDeathRequest createVMDeathRequest​()
        创建一个新的禁用VMDeathRequest 。 新请求将添加到此EventRequestManager管理的列表中。 使用EventRequest.enable()激活此事件请求。

        该请求（如果启用）将导致目标VM终止时发送VMDeathEvent 。

        VMDeathRequest的暂停策略为SUSPEND_ALL可用于确保在VM死亡之前处理进入的SUSPEND_NONE或SUSPEND_EVENT_THREAD事件。 如果所有的事件处理是在同一个线程正在做作为正在读取事件集，使该请求是所有需要，因为VM将被挂起，直到EventSet含有VMDeathEvent被恢复。

        并非所有目标虚拟机都支持此操作。 使用VirtualMachine.canRequestVMDeathEvent()确定是否支持该操作。

        结果
        创建的请求
        异常
        UnsupportedOperationException - 如果目标VM不支持此操作。
        从以下版本开始：
        1.4

      • deleteEventRequest

        void deleteEventRequest​(EventRequest eventRequest)
        删除eventRequest。 eventRequest被禁用，并从该EventRequestManager管理的请求中删除。 一旦eventRequest被删除，则不允许任何操作（例如， EventRequest.setEnabled(boolean) ） - 尝试这样做通常会导致一个InvalidRequestStateException 。 没有其他事件请求生效。

        因为此方法会更改事件请求的底层列表，而是尝试从请求访问器返回的列表中直接删除（例如下面）：

          Iterator iter = requestManager.stepRequests().iterator();
   while (iter.hasNext()) {
      requestManager.deleteEventRequest(iter.next());
  }
        可能会造成一个ConcurrentModificationException 。 而是使用deleteEventRequests(List)或复制列表。
        参数
        eventRequest - 要删除的eventRequest

      • deleteEventRequests

        void deleteEventRequests​(List<? extends EventRequest> eventRequests)
        删除EventRequest的列表。
        参数
        eventRequests - 要删除的eventRequests的列表
        另请参见：
        deleteEventRequest(EventRequest)

      • deleteAllBreakpoints

        void deleteAllBreakpoints​()
        删除此EventRequestManager管理的所有断点。
        另请参见：
        deleteEventRequest(EventRequest)

      • stepRequests

        List<StepRequest> stepRequests​()
        返回启用和禁用的步骤请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部StepRequest对象。

      • classPrepareRequests

        List<ClassPrepareRequest> classPrepareRequests​()
        返回启用和禁用的类准备请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部ClassPrepareRequest个对象。

      • classUnloadRequests

        List<ClassUnloadRequest> classUnloadRequests​()
        返回启用和禁用的类卸载请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部ClassUnloadRequest对象。

      • threadStartRequests

        List<ThreadStartRequest> threadStartRequests​()
        返回启用和禁用的线程启动请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部ThreadStartRequest对象。

      • threadDeathRequests

        List<ThreadDeathRequest> threadDeathRequests​()
        返回启用和禁用的线程死亡请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部ThreadDeathRequest对象。

      • exceptionRequests

        List<ExceptionRequest> exceptionRequests​()
        返回启用和禁用的异常请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部为ExceptionRequest对象。

      • breakpointRequests

        List<BreakpointRequest> breakpointRequests​()
        返回启用和禁用的断点请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        所有BreakpointRequest对象的列表。

      • accessWatchpointRequests

        List<AccessWatchpointRequest> accessWatchpointRequests​()
        返回启用和禁用的访问观察点请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部为AccessWatchpointRequest对象。

      • modificationWatchpointRequests

        List<ModificationWatchpointRequest> modificationWatchpointRequests​()
        返回启用和禁用的修改观察点请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        全部ModificationWatchpointRequest个对象。

      • methodEntryRequests

        List<MethodEntryRequest> methodEntryRequests​()
        返回启用和禁用的方法条目请求的不可修改列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        所有MethodEntryRequest对象的列表。

      • methodExitRequests

        List<MethodExitRequest> methodExitRequests​()
        返回启用和禁用的方法退出请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        所有MethodExitRequest对象的列表。

      • monitorContendedEnterRequests

        List<MonitorContendedEnterRequest> monitorContendedEnterRequests​()
        返回启用和禁用的监视器竞争的输入请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        所有MonitorContendedEnterRequest对象的列表。
        从以下版本开始：
        1.6

      • monitorContendedEnteredRequests

        List<MonitorContendedEnteredRequest> monitorContendedEnteredRequests​()
        返回已启用和禁用的已监视输入请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        所有MonitorContendedEnteredRequest对象的列表。
        从以下版本开始：
        1.6

      • monitorWaitRequests

        List<MonitorWaitRequest> monitorWaitRequests​()
        返回启用和禁用的监视器等待请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        所有MonitorWaitRequest对象的列表。
        从以下版本开始：
        1.6

      • monitorWaitedRequests

        List<MonitorWaitedRequest> monitorWaitedRequests​()
        返回启用和禁用的监视器等待请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。
        结果
        所有MonitorWaitedRequest对象的列表。
        从以下版本开始：
        1.6

      • vmDeathRequests

        List<VMDeathRequest> vmDeathRequests​()
        返回启用和禁用的VM死亡请求的不可修改的列表。 此列表是这些请求的实时视图，因此在添加和删除请求时进行更改。 注意：未经请求的VMDeathEvent没有相应的请求。
        结果
        所有VMDeathRequest对象的列表。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExceptionRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface ExceptionRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface ExceptionRequest
extends EventRequest
    在目标虚拟机发生异常时请求通知。 当开启了ExceptionRequest被满足，一个event set含有ExceptionEvent将被放置在EventQueue 。 现有的ExceptionRequest的收集由EventRequestManager管理
    从以下版本开始：
    1.3
    另请参见：
    ExceptionEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      限制通过该请求到那些位置是在类名 不匹配的受限的正则表达式生成的事件。
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      ReferenceType exception​()
      返回异常事件被请求的异常类型。
      boolean notifyCaught​()
      返回所请求类型的捕获异常是否会在抛出异常时生成事件。
      boolean notifyUncaught​()
      返回所请求类型的未捕获异常是否在抛出时生成事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • exception

        ReferenceType exception​()
        返回异常事件被请求的异常类型。
        结果
        异常（及其子类）使用 EventRequestManager.createExceptionRequest(com.sun.jdi.ReferenceType, boolean, boolean)请求，或者如果默认情况下请求所有异常， 则为 null。

      • notifyCaught

        boolean notifyCaught​()
        返回所请求类型的捕获异常是否会在抛出异常时生成事件。

        请注意，在抛出异常时，并不总是可以确定它是否被真正捕获。 详见ExceptionEvent.catchLocation() 。

        结果
        boolean如果捕获的异常将被报告为true，否则为false。

      • notifyUncaught

        boolean notifyUncaught​()
        返回所请求类型的未捕获异常是否在抛出时生成事件。

        请注意，在抛出异常的时候，并不总是能够确定它是否真的没有被捕获。 详见ExceptionEvent.catchLocation() 。

        结果
        boolean如果捕获的异常将被报告为true，否则为false。

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。 将为可以安全地转换为给定参考类型的引用类型中的任何位置生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        限制通过该请求到那些位置是在类名不匹配的受限的正则表达式生成的事件。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidRequestStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Class InvalidRequestStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.sun.jdi.request.InvalidRequestStateException
  • All Implemented Interfaces:
    Serializable

    public class InvalidRequestStateException
extends RuntimeException
    抛出以表示所请求的事件由于启用而无法修改。 过滤器只能添加到已禁用的事件请求中。 如果尝试对已删除的请求进行操作，也会抛出。 见EventRequestManager.deleteEventRequest(EventRequest)
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidRequestStateException​()
      InvalidRequestStateException​(String s)

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidRequestStateException

        public InvalidRequestStateException​()

      • InvalidRequestStateException

        public InvalidRequestStateException​(String s)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodEntryRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface MethodEntryRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface MethodEntryRequest
extends EventRequest
    在目标虚拟机中调用方法时请求通知。 当开启了MethodEntryRequest被满足，一个event set含有MethodEntryEvent将被放置在EventQueue 。 现有MethodEntryRequests的收集是由管理EventRequestManager
    从以下版本开始：
    1.3
    另请参见：
    MethodEntryEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 线程过滤。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。 将为可以安全地转换为给定参考类型的引用类型中的任何位置生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法，例如“java。*”或“* .Foo”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()确定是否支持该操作。

        参数
        instance - 为了通过此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodExitRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface MethodExitRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface MethodExitRequest
extends EventRequest
    当方法在目标虚拟机中返回时请求通知。 当开启了MethodExitRequest被命中，一个event set含有MethodExitEvent将被放置在EventQueue 。 现有MethodExitRequests的集合由EventRequestManager管理
    从以下版本开始：
    1.3
    另请参见：
    MethodExitEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法。
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制在其名称与受限正则表达式匹配的类中的方法。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。 将为可以安全地转换为给定参考类型的引用类型中的任何位置生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制在其名称与受限正则表达式匹配的类中的方法。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式不匹配的类中的方法。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModificationWatchpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface ModificationWatchpointRequest

  • All Superinterfaces:
    EventRequest ， Mirror ， WatchpointRequest

    public interface ModificationWatchpointRequest
extends WatchpointRequest
    设置字段时请求通知。 当使用Java编程语言语句（赋值，增量等）或Java Native Interface（JNI）集合函数（ Set<Type>Field, SetStatic<Type>Field ）将值分配给指定的字段时，将触发此事件。 将字段设置为与先前值相同的值仍将触发此事件。 JDI修改不会触发此事件。 当开启了ModificationWatchpointRequest被满足，一个event set含有ModificationWatchpointEvent将被放置在EventQueue 。 现有观察点的收集由EventRequestManager管理。
    从以下版本开始：
    1.3
    另请参见：
    ModificationWatchpointEvent ， AccessWatchpointRequest ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

      • Methods inherited from interface com.sun.jdi.request.WatchpointRequest

        addClassExclusionFilter, addClassFilter, addClassFilter, addInstanceFilter, addThreadFilter, field
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorContendedEnteredRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface MonitorContendedEnteredRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface MonitorContendedEnteredRequest
extends EventRequest
    在等待其他线程释放之后，请求目标VM中的线程通知进入监视器。 当启用了MonitorContededEnteredRequest时，包含MonitorContendedEnteredEvent的event set将被放置在EventQueue上 。 现有MonitorContendedEnteredEvents的收集是由管理EventRequestManager
    从以下版本开始：
    1.6
    另请参见：
    MonitorContendedEnteredEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。 将为可以安全地转换为给定参考类型的引用类型中的任何位置生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法，例如“java。*”或“* .Foo”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()来确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - if this request is currently enabled or has been deleted. Filters may be added only to disabled requests.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorContendedEnterRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface MonitorContendedEnterRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface MonitorContendedEnterRequest
extends EventRequest
    请求在目标VM中尝试进入另一个线程已经获取的监视器的线程的通知。 当启用了MonitorContededEnterRequest时，包含MonitorContendedEnterEvent的270449787196897将被放置在EventQueue上 。 现有MonitorContendedEnterEvents的收集是由管理EventRequestManager
    从以下版本开始：
    1.6
    另请参见：
    MonitorContendedEnterEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。 将为可以安全地转换为给定参考类型的引用类型中的任何位置生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法，例如“java。*”或“* .Foo”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - if this request is currently enabled or has been deleted. Filters may be added only to disabled requests.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorWaitedRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface MonitorWaitedRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface MonitorWaitedRequest
extends EventRequest
    当目标虚拟机中的线程已经完成等待监视对象时，请求通知。 也就是说，一个线程正在离开Object.wait（）。 “当启用MonitorWaitedRequest满足，一个event set含有MonitorWaitedEvent将被放置在EventQueue 。现有MonitorWaitedEvents的收集是由管理EventRequestManager
    从以下版本开始：
    1.6
    另请参见：
    MonitorWaitedEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将由此请求生成的事件限制于监视对象的类名与此受限正则表达式 不匹配的事件，例如
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制为监视对象的类名与此受限正则表达式 不匹配的事件，例如“java。*”或“* .Foo”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()来确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - if this request is currently enabled or has been deleted. Filters may be added only to disabled requests.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorWaitRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface MonitorWaitRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface MonitorWaitRequest
extends EventRequest
    当目标虚拟机中的线程即将等待监视对象时，请求通知。 也就是说，一个线程正在进入Object.wait（）。 当开启了MonitorWaitRequest被满足，一个event set含有MonitorWaitEvent将被放置在EventQueue 。 现有MonitorWaitEvents的收集是由管理EventRequestManager
    从以下版本开始：
    1.6
    另请参见：
    MonitorWaitEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将由此请求生成的事件限制于监视对象的类名与此受限正则表达式 不匹配的事件，例如
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 过滤线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制为监视对象的类名与此受限正则表达式 不匹配的事件，例如“java。*”或“* .Foo”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()来确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - if this request is currently enabled or has been deleted. Filters may be added only to disabled requests.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StepRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface StepRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface StepRequest
extends EventRequest
    在目标虚拟机中发生步骤时请求通知。 当启用了一个启用的StepRequest时，包含StepEvent的event set将被放置在EventQueue上 。 现有StepRequests的收集是由管理EventRequestManager
    从以下版本开始：
    1.3
    另请参见：
    StepEvent ， EventQueue ， EventRequestManager

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int STEP_INTO
      进入任何新推的帧
      static int STEP_LINE
      一步到另一行的下一个位置
      static int STEP_MIN
      步骤到下一个可用的位置
      static int STEP_OUT
      走出当前框架
      static int STEP_OVER
      跨越任何新推的帧

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type | 方法 | 描述
      void addClassExclusionFilter​(String classPattern)
      限制通过该请求到那些位置是在类名 不匹配的受限的正则表达式生成的事件。
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      int | depth​()
      int | size​()
      ThreadReference thread​()

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 字段详细信息

      • STEP_INTO

        static final int STEP_INTO
        进入任何新推的帧
        另请参见：
        Constant Field Values

      • STEP_OVER

        static final int STEP_OVER
        跨越任何新推的帧
        另请参见：
        Constant Field Values

      • STEP_OUT

        static final int STEP_OUT
        走出当前框架
        另请参见：
        Constant Field Values

      • STEP_MIN

        static final int STEP_MIN
        步骤到下一个可用的位置
        另请参见：
        Constant Field Values

      • STEP_LINE

        static final int STEP_LINE
        一步到另一行的下一个位置
        另请参见：
        Constant Field Values

    • 方法详细信息

      • thread

        ThreadReference thread​()
        结果
        正在请求步骤事件的线程。

      • size

        int size​()
        结果
        步长

      • depth

        int depth​()
        结果
        阶梯深度

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。 将为可以安全地转换为给定参考类型的引用类型中的任何位置生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        限制通过该请求到那些位置是在类名不匹配的受限的正则表达式生成的事件。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadDeathRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface ThreadDeathRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface ThreadDeathRequest
extends EventRequest
    线程在目标虚拟机中终止时请求通知。 当启用了ThreadDeathRequest时，包含ThreadDeathEvent的ThreadDeathEvent将被放置在EventQueue上 。 现有ThreadDeathRequests的集合由EventRequestManager管理
    从以下版本开始：
    1.3
    另请参见：
    ThreadDeathEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadStartRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface ThreadStartRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface ThreadStartRequest
extends EventRequest
    线程在目标虚拟机中启动执行时请求通知。 当开启了ThreadStartRequest被命中，一个event set含有ThreadStartEvent将被放置在EventQueue 。 现有的ThreadStartRequest的集合由EventRequestManager管理
    从以下版本开始：
    1.3
    另请参见：
    ThreadStartEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.jdi.request (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.jdi.request

  • Packages that use com.sun.jdi.request
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
  • Classes in com.sun.jdi.request used by com.sun.jdi
    Class 描述
    EventRequestManager
    管理创建和删除EventRequest s。
  • Classes in com.sun.jdi.request used by com.sun.jdi.event
    Class 描述
    EventRequest
    表示通知事件的请求。
  • Classes in com.sun.jdi.request used by com.sun.jdi.request
    Class 描述
    AccessWatchpointRequest
    在目标虚拟机中访问字段的内容时请求通知。
    BreakpointRequest
    标识目标虚拟机中应停止执行的Location 。
    ClassPrepareRequest
    在目标虚拟机中准备课程时请求通知。
    ClassUnloadRequest
    在目标虚拟机中卸载类时请求通知。
    EventRequest
    表示通知事件的请求。
    ExceptionRequest
    在目标虚拟机发生异常时请求通知。
    MethodEntryRequest
    在目标虚拟机中调用方法时请求通知。
    MethodExitRequest
    当方法在目标虚拟机中返回时请求通知。
    ModificationWatchpointRequest
    设置字段时请求通知。
    MonitorContendedEnteredRequest
    在等待其他线程释放之后，请求目标VM中的线程通知进入监视器。
    MonitorContendedEnterRequest
    请求在目标VM中尝试进入另一个线程已经获取的监视器的线程的通知。
    MonitorWaitedRequest
    当目标虚拟机中的线程已经完成等待监视对象时，请求通知。
    MonitorWaitRequest
    当目标虚拟机中的线程即将等待监视对象时，请求通知。
    StepRequest
    在目标虚拟机中发生步骤时请求通知。
    ThreadDeathRequest
    线程在目标虚拟机中终止时请求通知。
    ThreadStartRequest
    线程在目标虚拟机中启动执行时请求通知。
    VMDeathRequest
    当目标VM终止时请求通知。
    WatchpointRequest
    标识正在观看的目标虚拟机中的Field 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VMDeathRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface VMDeathRequest

  • All Superinterfaces:
    EventRequest ， Mirror

    public interface VMDeathRequest
extends EventRequest
    当目标VM终止时请求通知。 当开启了VMDeathRequest被满足，一个event set含有VMDeathEvent将被放置在EventQueue 。 现有VMDeathRequests的收集是由管理EventRequestManager

    即使没有创建VMDeathRequest，一个未经请求的VMDeathEvent将发送suspend policy的SUSPEND_NONE 。 通常会创建此请求， 以便将发送具有暂停策略SUSPEND_ALL的VMDeathEvent 。 该事件可用于确保任何需要VM活动的处理（例如事件处理）的完成。 注意：未经请求的VMDeathEvent仍将被发送。

    从以下版本开始：
    1.4
    另请参见：
    VMDeathEvent ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WatchpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jdi
软件包 com.sun.jdi.request

Interface WatchpointRequest

  • All Superinterfaces:
    EventRequest ， Mirror
    All Known Subinterfaces:
    AccessWatchpointRequest ， ModificationWatchpointRequest

    public interface WatchpointRequest
extends EventRequest
    标识正在观看的目标虚拟机中的Field 。
    从以下版本开始：
    1.3
    另请参见：
    AccessWatchpointRequest ， ModificationWatchpointRequest ， EventQueue ， EventRequestManager

    • Field Summary

      • Fields inherited from interface com.sun.jdi.request.EventRequest

        SUSPEND_ALL, SUSPEND_EVENT_THREAD, SUSPEND_NONE

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addClassExclusionFilter​(String classPattern)
      将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的位置。
      void addClassFilter​(ReferenceType refType)
      将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
      void addClassFilter​(String classPattern)
      将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。
      void addInstanceFilter​(ObjectReference instance)
      将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
      void addThreadFilter​(ThreadReference thread)
      将此请求生成的事件限制在给定线程中的事件。
      Field field​()
      获取该WatchpointRequest所关注的字段。

      • Methods inherited from interface com.sun.jdi.request.EventRequest

        addCountFilter, disable, enable, getProperty, isEnabled, putProperty, setEnabled, setSuspendPolicy, suspendPolicy

      • Methods inherited from interface com.sun.jdi.Mirror

        toString, virtualMachine

    • 方法详细信息

      • field

        Field field​()
        获取该WatchpointRequest所关注的字段。
        结果
        这个Watchpoint正在监控Field 。

      • addThreadFilter

        void addThreadFilter​(ThreadReference thread)
        将此请求生成的事件限制在给定线程中的事件。
        参数
        thread - 要过滤的线程。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(ReferenceType refType)
        将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。 将为可以安全地转换为给定参考类型的引用类型中的任何位置生成一个事件。
        参数
        refType - 要过滤的参考类型。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassFilter

        void addClassFilter​(String classPattern)
        将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addClassExclusionFilter

        void addClassExclusionFilter​(String classPattern)
        将此请求生成的事件限制在其名称与此受限正则表达式不匹配的类中的位置。 正则表达式仅限于以“*”开头或以“*”结尾的精确匹配和模式; 例如“* .Foo”或“java。*”。
        参数
        classPattern - 要过滤的模式字符串。
        异常
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。

      • addInstanceFilter

        void addInstanceFilter​(ObjectReference instance)
        将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。

        并非所有目标都支持此操作。 使用VirtualMachine.canUseInstanceFilters()确定是否支持该操作。

        参数
        instance - 为了传递此过滤器必须是当前实例的对象。
        异常
        UnsupportedOperationException - 如果目标虚拟机不支持此操作。
        InvalidRequestStateException - 如果此请求当前已启用或已被删除。 过滤器只能添加到禁用的请求中。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.request.DuplicateRequestException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.request.DuplicateRequestException

No usage of com.sun.jdi.request.DuplicateRequestException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.jdi.request.InvalidRequestStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.jdi.request.InvalidRequestStateException

No usage of com.sun.jdi.request.InvalidRequestStateException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.AccessWatchpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.AccessWatchpointRequest

  • Packages that use AccessWatchpointRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of AccessWatchpointRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return AccessWatchpointRequest
      Modifier and Type 方法 描述
      AccessWatchpointRequest EventRequestManager.createAccessWatchpointRequest​(Field field)
      创建一个新的禁用的观察点，监视对指定字段的访问。
      Methods in com.sun.jdi.request that return types with arguments of type AccessWatchpointRequest
      Modifier and Type 方法 描述
      List<AccessWatchpointRequest> EventRequestManager.accessWatchpointRequests​()
      返回启用和禁用的访问观察点请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.BreakpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.BreakpointRequest

  • Packages that use BreakpointRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of BreakpointRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return BreakpointRequest
      Modifier and Type 方法 描述
      BreakpointRequest EventRequestManager.createBreakpointRequest​(Location location)
      创建一个新的禁用BreakpointRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type BreakpointRequest
      Modifier and Type 方法 描述
      List<BreakpointRequest> EventRequestManager.breakpointRequests​()
      返回启用和禁用的断点请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.ClassPrepareRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.ClassPrepareRequest

  • Packages that use ClassPrepareRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ClassPrepareRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ClassPrepareRequest
      Modifier and Type 方法 描述
      ClassPrepareRequest EventRequestManager.createClassPrepareRequest​()
      创建一个新的禁用ClassPrepareRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type ClassPrepareRequest
      Modifier and Type 方法 描述
      List<ClassPrepareRequest> EventRequestManager.classPrepareRequests​()
      返回启用和禁用的类准备请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.ClassUnloadRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.ClassUnloadRequest

  • Packages that use ClassUnloadRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ClassUnloadRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ClassUnloadRequest
      Modifier and Type 方法 描述
      ClassUnloadRequest EventRequestManager.createClassUnloadRequest​()
      创建一个新的禁用ClassUnloadRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type ClassUnloadRequest
      Modifier and Type 方法 描述
      List<ClassUnloadRequest> EventRequestManager.classUnloadRequests​()
      返回启用和禁用的类卸载请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.EventRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.EventRequest

  • Packages that use EventRequest
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of EventRequest in com.sun.jdi.event

      Methods in com.sun.jdi.event that return EventRequest
      Modifier and Type | 方法 | 描述
      EventRequest | Event.request​()

    • Uses of EventRequest in com.sun.jdi.request

      Subinterfaces of EventRequest in com.sun.jdi.request
      Modifier and Type 接口 描述
      interface  AccessWatchpointRequest
      在目标虚拟机中访问字段的内容时请求通知。
      interface  BreakpointRequest
      标识目标VM中应停止执行的Location 。
      interface  ClassPrepareRequest
      在目标虚拟机中准备课程时请求通知。
      interface  ClassUnloadRequest
      在目标虚拟机中卸载类时请求通知。
      interface  ExceptionRequest
      在目标虚拟机发生异常时请求通知。
      interface  MethodEntryRequest
      在目标虚拟机中调用方法时请求通知。
      interface  MethodExitRequest
      当方法在目标虚拟机中返回时请求通知。
      interface  ModificationWatchpointRequest
      设置字段时请求通知。
      interface  MonitorContendedEnteredRequest
      在等待其他线程释放之后，请求目标VM中的线程通知进入监视器。
      interface  MonitorContendedEnterRequest
      请求在目标VM中尝试进入另一个线程已经获取的监视器的线程的通知。
      interface  MonitorWaitedRequest
      当目标虚拟机中的线程已经完成等待监视对象时，请求通知。
      interface  MonitorWaitRequest
      当目标虚拟机中的线程即将等待监视对象时，请求通知。
      interface  StepRequest
      在目标虚拟机中发生步骤时请求通知。
      interface  ThreadDeathRequest
      线程在目标虚拟机中终止时请求通知。
      interface  ThreadStartRequest
      线程在目标虚拟机中启动执行时请求通知。
      interface  VMDeathRequest
      当目标VM终止时请求通知。
      interface  WatchpointRequest
      标识正在观看的目标虚拟机中的Field 。
      Methods in com.sun.jdi.request with parameters of type EventRequest
      Modifier and Type 方法 描述
      void EventRequestManager.deleteEventRequest​(EventRequest eventRequest)
      删除eventRequest。
      Method parameters in com.sun.jdi.request with type arguments of type EventRequest
      Modifier and Type 方法 描述
      void EventRequestManager.deleteEventRequests​(List<? extends EventRequest> eventRequests)
      删除EventRequest的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.EventRequestManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.EventRequestManager

  • Packages that use EventRequestManager
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

    • Uses of EventRequestManager in com.sun.jdi

      Methods in com.sun.jdi that return EventRequestManager
      Modifier and Type 方法 描述
      EventRequestManager VirtualMachine.eventRequestManager​()
      返回此虚拟机的事件请求管理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.ExceptionRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.ExceptionRequest

  • Packages that use ExceptionRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ExceptionRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ExceptionRequest
      Modifier and Type 方法 描述
      ExceptionRequest EventRequestManager.createExceptionRequest​(ReferenceType refType, boolean notifyCaught, boolean notifyUncaught)
      创建一个新的禁用ExceptionRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type ExceptionRequest
      Modifier and Type 方法 描述
      List<ExceptionRequest> EventRequestManager.exceptionRequests​()
      返回启用和禁用的异常请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.MethodEntryRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.MethodEntryRequest

  • Packages that use MethodEntryRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of MethodEntryRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return MethodEntryRequest
      Modifier and Type 方法 描述
      MethodEntryRequest EventRequestManager.createMethodEntryRequest​()
      创建一个新的禁用MethodEntryRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type MethodEntryRequest
      Modifier and Type 方法 描述
      List<MethodEntryRequest> EventRequestManager.methodEntryRequests​()
      返回启用和禁用的方法条目请求的不可修改列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.MethodExitRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.MethodExitRequest

  • Packages that use MethodExitRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of MethodExitRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return MethodExitRequest
      Modifier and Type 方法 描述
      MethodExitRequest EventRequestManager.createMethodExitRequest​()
      创建一个新的禁用MethodExitRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type MethodExitRequest
      Modifier and Type 方法 描述
      List<MethodExitRequest> EventRequestManager.methodExitRequests​()
      返回启用和禁用的方法退出请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.ModificationWatchpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.ModificationWatchpointRequest

  • Packages that use ModificationWatchpointRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ModificationWatchpointRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ModificationWatchpointRequest
      Modifier and Type 方法 描述
      ModificationWatchpointRequest EventRequestManager.createModificationWatchpointRequest​(Field field)
      创建一个新的禁用的观察点，监视对指定字段的访问。
      Methods in com.sun.jdi.request that return types with arguments of type ModificationWatchpointRequest
      Modifier and Type 方法 描述
      List<ModificationWatchpointRequest> EventRequestManager.modificationWatchpointRequests​()
      返回启用和禁用的修改观察点请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.MonitorContendedEnteredRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.MonitorContendedEnteredRequest

  • Packages that use MonitorContendedEnteredRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of MonitorContendedEnteredRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return MonitorContendedEnteredRequest
      Modifier and Type 方法 描述
      MonitorContendedEnteredRequest EventRequestManager.createMonitorContendedEnteredRequest​()
      创建一个新的禁用MonitorContendedEnteredRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type MonitorContendedEnteredRequest
      Modifier and Type 方法 描述
      List<MonitorContendedEnteredRequest> EventRequestManager.monitorContendedEnteredRequests​()
      返回已启用和禁用的已监视输入请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.MonitorContendedEnterRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.MonitorContendedEnterRequest

  • Packages that use MonitorContendedEnterRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of MonitorContendedEnterRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return MonitorContendedEnterRequest
      Modifier and Type 方法 描述
      MonitorContendedEnterRequest EventRequestManager.createMonitorContendedEnterRequest​()
      创建一个新的禁用MonitorContendedEnterRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type MonitorContendedEnterRequest
      Modifier and Type 方法 描述
      List<MonitorContendedEnterRequest> EventRequestManager.monitorContendedEnterRequests​()
      返回启用和禁用的监视器竞争的输入请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.MonitorWaitedRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.MonitorWaitedRequest

  • Packages that use MonitorWaitedRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of MonitorWaitedRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return MonitorWaitedRequest
      Modifier and Type 方法 描述
      MonitorWaitedRequest EventRequestManager.createMonitorWaitedRequest​()
      创建一个新的禁用MonitorWaitedRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type MonitorWaitedRequest
      Modifier and Type 方法 描述
      List<MonitorWaitedRequest> EventRequestManager.monitorWaitedRequests​()
      返回启用和禁用的监视器等待请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.MonitorWaitRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.MonitorWaitRequest

  • Packages that use MonitorWaitRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of MonitorWaitRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return MonitorWaitRequest
      Modifier and Type 方法 描述
      MonitorWaitRequest EventRequestManager.createMonitorWaitRequest​()
      创建一个新的禁用MonitorWaitRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type MonitorWaitRequest
      Modifier and Type 方法 描述
      List<MonitorWaitRequest> EventRequestManager.monitorWaitRequests​()
      返回启用和禁用的监视器等待请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.StepRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.StepRequest

  • Packages that use StepRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of StepRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return StepRequest
      Modifier and Type 方法 描述
      StepRequest EventRequestManager.createStepRequest​(ThreadReference thread, int size, int depth)
      创建一个新的禁用StepRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type StepRequest
      Modifier and Type 方法 描述
      List<StepRequest> EventRequestManager.stepRequests​()
      返回启用和禁用的步骤请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.ThreadDeathRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.ThreadDeathRequest

  • Packages that use ThreadDeathRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ThreadDeathRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ThreadDeathRequest
      Modifier and Type 方法 描述
      ThreadDeathRequest EventRequestManager.createThreadDeathRequest​()
      创建一个新的禁用ThreadDeathRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type ThreadDeathRequest
      Modifier and Type 方法 描述
      List<ThreadDeathRequest> EventRequestManager.threadDeathRequests​()
      返回启用和禁用的线程死亡请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.ThreadStartRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.ThreadStartRequest

  • Packages that use ThreadStartRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of ThreadStartRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ThreadStartRequest
      Modifier and Type 方法 描述
      ThreadStartRequest EventRequestManager.createThreadStartRequest​()
      创建一个新的禁用ThreadStartRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type ThreadStartRequest
      Modifier and Type 方法 描述
      List<ThreadStartRequest> EventRequestManager.threadStartRequests​()
      返回启用和禁用的线程启动请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.VMDeathRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.VMDeathRequest

  • Packages that use VMDeathRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of VMDeathRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return VMDeathRequest
      Modifier and Type 方法 描述
      VMDeathRequest EventRequestManager.createVMDeathRequest​()
      创建一个新的禁用VMDeathRequest 。
      Methods in com.sun.jdi.request that return types with arguments of type VMDeathRequest
      Modifier and Type 方法 描述
      List<VMDeathRequest> EventRequestManager.vmDeathRequests​()
      返回启用和禁用的VM死亡请求的不可修改的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.jdi.request.WatchpointRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.jdi.request.WatchpointRequest

  • Packages that use WatchpointRequest
    软件包 描述
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。

    • Uses of WatchpointRequest in com.sun.jdi.request

      Subinterfaces of WatchpointRequest in com.sun.jdi.request
      Modifier and Type 接口 描述
      interface  AccessWatchpointRequest
      在目标虚拟机中访问字段的内容时请求通知。
      interface  ModificationWatchpointRequest
      设置字段时请求通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.management (Java SE 9 & JDK 9 )

com.sun.management

Interfaces

  • DiagnosticCommandMBean
  • GarbageCollectorMXBean
  • HotSpotDiagnosticMXBean
  • OperatingSystemMXBean
  • ThreadMXBean
  • UnixOperatingSystemMXBean

Classes

  • GarbageCollectionNotificationInfo
  • GcInfo
  • VMOption

Enums

  • VMOption.Origin


com.sun.management (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.management

Package com.sun.management

该软件包包含JDK对java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

所有平台MBean都在平台MBeanServer中注册，可以通过ManagementFactory.getPlatformMBeanServer()获取

从以下版本开始：
1.5
  • 接口摘要
    接口 描述
    DiagnosticCommandMBean
    HotSpot Virtual Machine诊断命令的管理界面。
    GarbageCollectorMXBean
    用于垃圾收集器的特定于平台的管理界面，用于循环执行集合。
    HotSpotDiagnosticMXBean
    HotSpot虚拟机的诊断管理界面。
    OperatingSystemMXBean
    运行Java虚拟机的操作系统的平台特定管理界面。
    ThreadMXBean
    针对Java虚拟机线程系统的平台特定管理界面。
    UnixOperatingSystemMXBean
    适用于运行Java虚拟机的Unix操作系统的平台特定管理界面。
  • 类摘要
    Class 描述
    GarbageCollectionNotificationInfo
    有关垃圾收集的信息
    GcInfo
    垃圾收集信息。
    VMOption
    有关VM选项的信息，包括其值，值来自哪里被称为其origin 。
  • 枚举摘要
    Enum 描述
    VMOption.Origin
    VM选项的值的起源。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.management Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.management

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.management.GarbageCollectionNotificationInfo (implements javax.management.openmbean.CompositeDataView)
    • com.sun.management.GcInfo (implements javax.management.openmbean.CompositeData, javax.management.openmbean.CompositeDataView)
    • com.sun.management.VMOption

Interface Hierarchy

  • javax.management.DynamicMBean
    • com.sun.management.DiagnosticCommandMBean
  • java.lang.management.PlatformManagedObject
    • com.sun.management.HotSpotDiagnosticMXBean
    • java.lang.management.MemoryManagerMXBean
      • java.lang.management.GarbageCollectorMXBean
        • com.sun.management.GarbageCollectorMXBean
    • java.lang.management.OperatingSystemMXBean
      • com.sun.management.OperatingSystemMXBean
        • com.sun.management.UnixOperatingSystemMXBean
    • java.lang.management.ThreadMXBean
      • com.sun.management.ThreadMXBean

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.management.VMOption.Origin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


DiagnosticCommandMBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Interface DiagnosticCommandMBean

  • All Superinterfaces:
    DynamicMBean

    public interface DiagnosticCommandMBean
extends DynamicMBean
    HotSpot Virtual Machine诊断命令的管理界面。

    该DiagnosticCommandMBean注册到platform MBeanServer为其他平台的MBean。

    用于唯一标识MBeanServer中诊断MBean的ObjectName是：

    com.sun.management:type=DiagnosticCommand

    这个MBean是一个DynamicMBean ，也是一个NotificationEmitter 。 DiagnosticCommandMBean在运行时生成，并在Java虚拟机的生命周期内进行修改。 诊断命令表示为DiagnosticCommandMBean接口的操作。 每个诊断命令有：

    • 诊断命令名称，它是HotSpot虚拟机中引用的名称
    • MBean操作名称是为诊断命令操作调用生成的name 。 MBean操作名称取决于实现
    将诊断命令名称转换为MBean操作名称的推荐方法如下：
    • 从第一个到第一个点的所有字符都被设置为小写字符
    • 删除每个点或下划线字符，并将以下字符设置为大写字符
    • 所有其他字符被复制而不进行修改

    诊断命令名称始终提供有关名称为dcmd.name （见下文）的字段中操作的元数据。

    诊断命令可能支持或不支持选项或参数。 所有操作都返回String ，对于不支持任何选项或参数的操作，不要使用任何参数，或者对支持至少一个选项或参数的操作采用String[]参数。 每个选项或参数必须存储在单个String中。 不支持跨多个String实例分割的选项或参数。

    选项和参数之间的区别：选项由选项名称标识，而参数由其在命令行中的位置标识。 选项和参数按照传递给调用方法的数组的顺序进行处理。

    像动态MBean的任何操作一样，这些操作都由MBeanOperationInfo实例描述。 以下是此对象返回的值：

    • getName()返回从诊断命令名称生成的操作名称
    • getDescription()返回诊断命令描述（与“help”命令中的一个返回相同）
    • getImpact()返回ACTION_INFO
    • getReturnType()返回java.lang.String
    • getDescriptor()返回描述符实例（见下文）

    Descriptor是包含JMX元素的其他元数据的字段的集合。 字段是名称和关联值。 下表列出了与诊断命令相关联的操作提供的附加元数据：

    description Name Type Description dcmd.name String The original diagnostic command name (not the operation name) dcmd.description String The diagnostic command description dcmd.help String The full help message for this diagnostic command (same output as the one produced by the 'help' command) dcmd.vmImpact String The impact of the diagnostic command, this value is the same as the one printed in the 'impact' section of the help message of the diagnostic command, and it is different from the getImpact() of the MBeanOperationInfo dcmd.enabled boolean True if the diagnostic command is enabled, false otherwise dcmd.permissionClass String Some diagnostic command might require a specific permission to be executed, in addition to the MBeanPermission to invoke their associated MBean operation. This field returns the fully qualified name of the permission class or null if no permission is required dcmd.permissionName String The fist argument of the permission required to execute this diagnostic command or null if no permission is required dcmd.permissionAction String The second argument of the permission required to execute this diagnostic command or null if the permission constructor has only one argument (like the ManagementPermission) or if no permission is required dcmd.arguments Descriptor A Descriptor instance containing the descriptions of options and arguments supported by the diagnostic command (see below)

    诊断命令的参数（选项或参数）的描述在Descriptor实例中提供。 在此描述符中，每个字段名称都是一个参数名称，每个字段值本身就是一个描述符实例。 下表中描述了第二个描述符实例中提供的字段：

    description Name Type Description dcmd.arg.name String The name of the parameter dcmd.arg.type String The type of the parameter. The returned String is the name of a type recognized by the diagnostic command parser. These types are not Java types and are implementation dependent. dcmd.arg.description String The parameter description dcmd.arg.isMandatory boolean True if the parameter is mandatory, false otherwise dcmd.arg.isOption boolean True if the parameter is an option, false if it is an argument dcmd.arg.isMultiple boolean True if the parameter can be specified several times, false otherwise

    当目前的Java虚拟机所支持的一套诊断命令的修改，该DiagnosticCommandMBean发出Notification具有type的"jmx.mbean.info.changed"和userData那就是新MBeanInfo 。

    从以下版本开始：
    1.8

    • 方法摘要

      • Methods inherited from interface javax.management.DynamicMBean

        getAttribute, getAttributes, getMBeanInfo, invoke, setAttribute, setAttributes
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GarbageCollectionNotificationInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Class GarbageCollectionNotificationInfo

  • java.lang.Object
    • com.sun.management.GarbageCollectionNotificationInfo
  • All Implemented Interfaces:
    CompositeDataView

    public class GarbageCollectionNotificationInfo
extends Object
implements CompositeDataView
    有关垃圾收集的信息

    当Java虚拟机完成垃圾回收操作时， GarbageCollectorMXBean发出垃圾收集通知发出的通知将包含有关内存状态的垃圾回收通知信息：

    • 用于执行收集的垃圾收集器的名称。
    • 垃圾收集器执行的动作。
    • 垃圾收集行为的原因。
    • 一个GcInfo对象，包含有关GC循环（开始时间，结束时间）和GC循环前后的内存使用情况的一些统计信息。

    甲CompositeData表示GarbageCollectionNotificationInfo对象被存储在userdata一个的notification 。 提供from方法将其从CompositeData转换为GarbageCollectionNotificationInfo对象。 例如：

          Notification notif;

      // receive the notification emitted by a GarbageCollectorMXBean and set to notif
      ...

      String notifType = notif.getType();
      if (notifType.equals(GarbageCollectionNotificationInfo.GARBAGE_COLLECTION_NOTIFICATION)) {
          // retrieve the garbage collection notification information
          CompositeData cd = (CompositeData) notif.getUserData();
          GarbageCollectionNotificationInfo info = GarbageCollectionNotificationInfo.from(cd);
          ....
      }

    由GarbageCollectorMXBean发出的通知的类型是：

    • A garbage collection notification 。
      由垃圾收集器发出的每个通知使用，有关通知的详细信息，请参见action字符串

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String GARBAGE_COLLECTION_NOTIFICATION
      通知类型表示Java虚拟机已完成垃圾回收循环。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GarbageCollectionNotificationInfo​(String gcName, String gcAction, String gcCause, GcInfo gcInfo)
      构造一个 GarbageCollectionNotificationInfo对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static GarbageCollectionNotificationInfo from​(CompositeData cd)
      返回由给定的 CompositeData表示的 GarbageCollectionNotificationInfo对象。
      String getGcAction​()
      返回垃圾收集器执行的操作
      String getGcCause​()
      返回垃圾收集的原因
      GcInfo getGcInfo​()
      返回与最后垃圾收集相关的GC信息
      String getGcName​()
      返回用于执行集合的垃圾收集器的名称
      CompositeData toCompositeData​(CompositeType ct)
      返回对应于此对象中的值的 CompositeData 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • GARBAGE_COLLECTION_NOTIFICATION

        public static final String GARBAGE_COLLECTION_NOTIFICATION
        通知类型表示Java虚拟机已完成垃圾回收循环。 此通知由GarbageCollectorMXBean发出。 此通知类型的值为com.sun.management.gc.notification 。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GarbageCollectionNotificationInfo

        public GarbageCollectionNotificationInfo​(String gcName,
                                         String gcAction,
                                         String gcCause,
                                         GcInfo gcInfo)
        构造一个 GarbageCollectionNotificationInfo对象。
        参数
        gcName - 用于执行收集的垃圾收集器的名称
        gcAction - 垃圾回收器执行的操作的名称
        gcCause - 垃圾回收行为的原因
        gcInfo - 提供有关GC循环统计信息的GcInfo对象

    • 方法详细信息

      • getGcName

        public String getGcName​()
        返回用于执行集合的垃圾收集器的名称
        结果
        用于执行收集的垃圾收集器的名称

      • getGcAction

        public String getGcAction​()
        返回垃圾收集器执行的操作
        结果
        由垃圾收集器执行的动作

      • getGcCause

        public String getGcCause​()
        返回垃圾收集的原因
        结果
        垃圾收集的原因

      • getGcInfo

        public GcInfo getGcInfo​()
        返回与最后垃圾收集相关的GC信息
        结果
        与最后垃圾收集相关的GC信息

      • from

        public static GarbageCollectionNotificationInfo from​(CompositeData cd)
        返回由给定的CompositeData表示的GarbageCollectionNotificationInfo对象。 给定的CompositeData必须包含以下属性：
        description
        Attribute Name | Type
        gcName | java.lang.String
        gcAction | java.lang.String
        gcCause | java.lang.String
        gcInfo | javax.management.openmbean.CompositeData
        参数
        cd - CompositeData代表 GarbageCollectionNotificationInfo
        结果
        一个GarbageCollectionNotificationInfo通过表示对象cd如果cd不是null ; 否则为null 。
        异常
        IllegalArgumentException - 如果 cd不表示 GarbaageCollectionNotificationInfo对象。

      • toCompositeData

        public CompositeData toCompositeData​(CompositeType ct)
        描述从接口CompositeDataView复制

        返回对应于此对象中的值的CompositeData 。 返回的值通常应为CompositeDataSupport的实例，或通过writeReplace方法序列化为CompositeDataSupport的类。 否则，接收对象的远程客户端可能无法重构。

        Specified by:
        toCompositeData在接口 CompositeDataView
        参数
        ct - 预期的CompositeType的返回值。 如果返回值是cd ，然后cd.getCompositeType().equals(ct)应该是真实的。 通常这将是因为cd是一个CompositeDataSupport构建ct作为其CompositeType 。
        结果
        CompositeData 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GarbageCollectorMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Interface GarbageCollectorMXBean

  • All Superinterfaces:
    GarbageCollectorMXBean ， MemoryManagerMXBean ， PlatformManagedObject

    public interface GarbageCollectorMXBean
extends GarbageCollectorMXBean
    用于垃圾收集器的特定于平台的管理界面，用于循环执行集合。

    此平台扩展仅适用于支持此扩展的垃圾收集实现。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      GcInfo getLastGcInfo​()
      返回有关最新GC的GC信息。

      • Methods inherited from interface java.lang.management.GarbageCollectorMXBean

        getCollectionCount, getCollectionTime

      • Methods inherited from interface java.lang.management.MemoryManagerMXBean

        getMemoryPoolNames, getName, isValid

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getLastGcInfo

        GcInfo getLastGcInfo​()
        返回有关最新GC的GC信息。 此方法返回一个GcInfo 。 如果没有GC信息可用，则返回null 。 如果有的话，可以通过CompositeData界面获取收集器特定的属性。

        MBeanServer访问： GcInfo的映射类型为CompositeData ，其属性在GcInfo中指定。

        结果
        代表GC信息最多的GcInfo对象; 或者如果没有可用的GC信息， null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GcInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Class GcInfo

  • java.lang.Object
    • com.sun.management.GcInfo
  • All Implemented Interfaces:
    CompositeData ， CompositeDataView

    public class GcInfo
extends Object
implements CompositeData, CompositeDataView
    垃圾收集信息。 它包含一个垃圾收集以及GC特定属性的以下信息：
    • Start time
    • End time
    • Duration
    • Memory usage before the collection starts
    • Memory usage after the collection ends

    GcInfo是一个CompositeData可以通过CompositeData接口获得GC特定的属性。 这是一个历史文物，其他的类也不应该复制这种模式。 改用CompositeDataView 。

    MXBean映射

    GcInfo被映射到CompositeData作为指定具有属性from方法。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean containsKey​(String key)
      返回 true当且仅当此 CompositeData实例包含名称是项目 key 。
      boolean containsValue​(Object value)
      返回 true当且仅当此 CompositeData实例包含其值是一个项目 value 。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      static GcInfo from​(CompositeData cd)
      返回由给定的 CompositeData表示的 GcInfo对象。
      Object get​(String key)
      返回名称为 key的项目的值。
      Object[] getAll​(String[] keys)
      返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。
      CompositeType getCompositeType​()
      返回此 复合数据实例的 复合类型 。
      long getDuration​()
      返回此GC的已用时间（以毫秒为单位）。
      long getEndTime​()
      从Java虚拟机启动后返回此GC的结束时间（以毫秒为单位）。
      long getId​()
      返回此垃圾收集的标识符，该收集器是收集器完成的集合数。
      Map<String,MemoryUsage> getMemoryUsageAfterGc​()
      返回此GC结尾处的所有内存池的内存使用情况。
      Map<String,MemoryUsage> getMemoryUsageBeforeGc​()
      返回此GC开头的所有内存池的内存使用情况。
      long getStartTime​()
      从Java虚拟机启动后返回此GC的开始时间（以毫秒为单位）。
      int hashCode​()
      返回对象的哈希码值。
      CompositeData toCompositeData​(CompositeType ct)
      返回 CompositeData如此表示 GcInfo ，包括任何具体的GC-属性。
      String toString​()
      返回对象的字符串表示形式。
      Collection<?> values​()
      返回此 CompositeData实例中包含的项目值的不可修改的集合视图。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getId

        public long getId​()
        返回此垃圾收集的标识符，该收集器是收集器完成的集合数。
        结果
        这个垃圾收集的标识符是收集器完成的集合数。

      • getStartTime

        public long getStartTime​()
        从Java虚拟机启动后返回此GC的开始时间（以毫秒为单位）。
        结果
        该GC的开始时间。

      • getEndTime

        public long getEndTime​()
        从Java虚拟机启动后返回此GC的结束时间（以毫秒为单位）。
        结果
        这个GC的结束时间。

      • getDuration

        public long getDuration​()
        返回此GC的已用时间（以毫秒为单位）。
        结果
        该GC的经过时间（以毫秒为单位）。

      • getMemoryUsageBeforeGc

        public Map<String,MemoryUsage> getMemoryUsageBeforeGc​()
        返回此GC开头的所有内存池的内存使用情况。 此方法将返回一个内存池名称的Map与GC启动前相应内存池的内存使用情况。
        结果
        一个 Map的内存池名称与GC启动前的内存池的内存使用情况。

      • getMemoryUsageAfterGc

        public Map<String,MemoryUsage> getMemoryUsageAfterGc​()
        返回此GC结尾处的所有内存池的内存使用情况。 当GC完成时，此方法返回一个内存池名称的Map到相应内存池的内存使用情况。
        结果
        一个 Map的内存池名称，当GC完成时，内存池的内存使用量。

      • from

        public static GcInfo from​(CompositeData cd)
        返回由给定的CompositeData表示的GcInfo对象。 给定的CompositeData必须包含以下所有属性：
        description
        Attribute Name | Type
        index | java.lang.Long
        startTime | java.lang.Long
        endTime | java.lang.Long
        memoryUsageBeforeGc | javax.management.openmbean.TabularData
        memoryUsageAfterGc | javax.management.openmbean.TabularData
        结果
        一个GcInfo通过表示对象cd如果cd不是null ; 否则为null 。
        异常
        IllegalArgumentException - 如果 cd不表示具有上述属性的 GcInfo对象。

      • containsKey

        public boolean containsKey​(String key)
        描述从接口CompositeData复制
        返回true当且仅当此CompositeData实例包含名称是项目key 。 如果key是空或空字符串，则此方法只返回false。
        Specified by:
        containsKey在接口 CompositeData
        参数
        key - 要测试的关键。
        结果
        如果这个 CompositeData包含密钥， CompositeData true。

      • containsValue

        public boolean containsValue​(Object value)
        描述从接口CompositeData复制
        返回 true当且仅当此 CompositeData实例包含其值是一个项目 value 。
        Specified by:
        containsValue在接口 CompositeData
        参数
        value - 要测试的值。
        结果
        如果此 CompositeData true。

      • equals

        public boolean equals​(Object obj)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 一致 ：对于任何非空引用值x和y ，多重调用x.equals(y)始终返回true或始终返回false ，前提是在equals对对象进行比较的信息进行修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        Specified by:
        equals在接口 CompositeData
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果该对象与obj参数相同， true ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • get

        public Object get​(String key)
        描述从接口CompositeData复制
        返回名称为 key的项目的值。
        Specified by:
        get在接口 CompositeData
        参数
        key - 项目的名称。
        结果
        与该键相关联的值。

      • getAll

        public Object[] getAll​(String[] keys)
        说明从接口CompositeData复制
        返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。
        Specified by:
        getAll在接口 CompositeData
        参数
        keys - 项目的名称。
        结果
        与键对应的值。

      • getCompositeType

        public CompositeType getCompositeType​()
        说明从接口CompositeData复制
        返回此 复合数据实例的 复合类型 。
        Specified by:
        getCompositeType在接口 CompositeData
        结果
        这个CompositeData的类型。

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap所提供的那样 。

        hashCode的一般合同是：

        • 只要在执行Java应用程序时多次在同一个对象上调用该函数，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        Specified by:
        hashCode在接口 CompositeData
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        Specified by:
        toString在接口 CompositeData
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • values

        public Collection<?> values​()
        描述从接口CompositeData复制
        返回此CompositeData实例中包含的项目值的不可修改的集合视图。 返回的集合的迭代器将以相应项目名称的升序字典顺序返回值。
        Specified by:
        values在接口 CompositeData
        结果
        价值。

      • toCompositeData

        public CompositeData toCompositeData​(CompositeType ct)
        返回CompositeData如此表示GcInfo ，包括任何具体的GC-属性。 返回的值将至少具有from方法中描述的所有属性，以及可选的其他属性。
        Specified by:
        toCompositeData在接口 CompositeDataView
        参数
        ct - 呼叫者期望的CompositeType 。 此参数被忽略，可以为null。
        结果
        the CompositeData representation.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HotSpotDiagnosticMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Interface HotSpotDiagnosticMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface HotSpotDiagnosticMXBean
extends PlatformManagedObject
    HotSpot虚拟机的诊断管理界面。

    诊断MBean与其他平台MBean一样注册到平台MBeanServer。

    用于在MBeanServer中唯一标识诊断MXBean的ObjectName是：

    com.sun.management:type=HotSpotDiagnostic
    *可以通过调用PlatformManagedObject.getObjectName()方法获得。 如果任何输入参数是null除非另有说明，所有方法都会抛出一个NullPointerException 。
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dumpHeap​(String outputFile, boolean live)
      以与hprof堆转储相同的格式将堆转储到 outputFile文件。
      List<VMOption> getDiagnosticOptions​()
      返回所有诊断选项的 VMOption对象列表。
      VMOption getVMOption​(String name)
      返回给定名称的VM选项的 VMOption对象。
      void setVMOption​(String name, String value)
      将给定名称的VM选项设置为指定的值。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • dumpHeap

        void dumpHeap​(String outputFile,
              boolean live)
       throws IOException
        以与hprof堆转储相同的格式将堆转储到outputFile文件。

        如果从另一个进程远程调用此方法，则堆转储输出将写入运行目标VM的计算机上名为outputFile的文件。 如果outputFile是相对路径，则它与目标VM启动的工作目录相对。

        参数
        outputFile - 与系统相关的文件名
        live - 如果 true转储只有 活的对象，即可以从别人访问的对象
        异常
        IOException - 如果无法创建，打开或写入 outputFile 。
        UnsupportedOperationException - 如果不支持此操作。
        NullPointerException - 如果 outputFile是 null 。
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对命名文件的写访问，或者调用者不具有ManagmentPermission（“control”）。

      • getDiagnosticOptions

        List<VMOption> getDiagnosticOptions​()
        返回所有诊断选项的VMOption对象的列表。 诊断选项是一个writeable VM选项，可以动态设置，主要用于故障排除和诊断。
        结果
        所有诊断选项的 VMOption对象的列表。

      • getVMOption

        VMOption getVMOption​(String name)
        为给定名称的VM选项返回一个 VMOption对象。
        结果
        一个给定名称的VM选项的 VMOption对象。
        异常
        NullPointerException - 如果名字是 null 。
        IllegalArgumentException - 如果给定名称的VM选项不存在。

      • setVMOption

        void setVMOption​(String name,
                 String value)
        将给定名称的VM选项设置为指定的值。 新值将反映在getVMOption(java.lang.String)方法或getDiagnosticOptions()方法返回的新的VMOption对象中。 此方法不会更改此VMOption对象的值。
        参数
        name - VM选项的名称
        value - 要设置的VM选项的新值
        异常
        IllegalArgumentException - 如果给定名称的VM选项不存在。
        IllegalArgumentException - 如果新值无效。
        IllegalArgumentException - 如果VM选项不可写。
        NullPointerException - 如果名称或值是 null 。
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OperatingSystemMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Interface OperatingSystemMXBean

  • All Superinterfaces:
    OperatingSystemMXBean ， PlatformManagedObject
    All Known Subinterfaces:
    UnixOperatingSystemMXBean

    public interface OperatingSystemMXBean
extends OperatingSystemMXBean
    运行Java虚拟机的操作系统的平台特定管理界面。

    所述OperatingSystemMXBean通过返回对象ManagementFactory.getOperatingSystemMXBean()是实现类这个接口或的一个实例UnixOperatingSystemMXBean接口取决于其底层操作系统上。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getCommittedVirtualMemorySize​()
      返回运行进程保证可用的虚拟内存量（以字节为单位），如果不支持此操作，则 -1 。
      long getFreePhysicalMemorySize​()
      返回以字节为单位的空闲物理内存量。
      long getFreeSwapSpaceSize​()
      返回以字节为单位的空闲交换空间量。
      double getProcessCpuLoad​()
      返回Java虚拟机进程的“最近的cpu用法”。
      long getProcessCpuTime​()
      返回Java虚拟机运行的进程以纳秒为单位的CPU时间。
      double getSystemCpuLoad​()
      返回整个系统的“最近的cpu用法”。
      long getTotalPhysicalMemorySize​()
      以字节为单位返回物理内存总量。
      long getTotalSwapSpaceSize​()
      返回交换空间的总数（以字节为单位）。

      • Methods inherited from interface java.lang.management.OperatingSystemMXBean

        getArch, getAvailableProcessors, getName, getSystemLoadAverage, getVersion

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getCommittedVirtualMemorySize

        long getCommittedVirtualMemorySize​()
        返回运行进程保证可用的虚拟内存量（以字节为单位），如果不支持此操作，则 -1 。
        结果
        运行过程中保证可用的虚拟内存量（以字节为单位），如果不支持此操作， -1 。

      • getTotalSwapSpaceSize

        long getTotalSwapSpaceSize​()
        返回交换空间的总数（以字节为单位）。
        结果
        交换空间总量（以字节为单位）。

      • getFreeSwapSpaceSize

        long getFreeSwapSpaceSize​()
        返回以字节为单位的空闲交换空间量。
        结果
        空闲交换空间量（以字节为单位）。

      • getProcessCpuTime

        long getProcessCpuTime​()
        返回Java虚拟机运行的进程以纳秒为单位的CPU时间。 返回的值为纳秒精度，但不一定是纳秒精度。 如果平台不支持此操作，此方法返回-1 。
        结果
        该进程以 -1使用的CPU时间，如果不支持此操作， -1 。

      • getFreePhysicalMemorySize

        long getFreePhysicalMemorySize​()
        返回以字节为单位的空闲物理内存量。
        结果
        空闲的物理内存量（以字节为单位）。

      • getTotalPhysicalMemorySize

        long getTotalPhysicalMemorySize​()
        以字节为单位返回物理内存总量。
        结果
        物理内存的总量，以字节为单位。

      • getSystemCpuLoad

        double getSystemCpuLoad​()
        返回整个系统的“最近的cpu用法”。 该值在[0.0,1.0]间隔中为双倍。 值0.0表示所有CPU在最近观察到的时间段内都处于空闲状态，而值为1.0表示所有CPU在最近一段时间内正在100％的时间内正在运行。 根据系统中进行的活动，0.0和1.0之间的所有值都是可能的。 如果系统最近的cpu用法不可用，则该方法返回一个负值。
        结果
        整个系统的“最近cpu使用”; 如果不可用，为负值。
        从以下版本开始：
        1.7

      • getProcessCpuLoad

        double getProcessCpuLoad​()
        返回Java虚拟机进程的“最近的cpu用法”。 该值在[0.0,1.0]间隔中为双倍。 值为0.0意味着在最近观察到的时间段内没有一个CPU正在从JVM进程运行线程，而值为1.0意味着所有CPU在最近一段时间内100％的时间内积极地从JVM运行线程被观察。 来自JVM的线程包括应用程序线程以及JVM内部线程。 根据JVM进程和整个系统中的活动，0.0和1.0之间的所有值都是可能的。 如果Java虚拟机最近的CPU使用率不可用，该方法将返回一个负值。
        结果
        Java虚拟机进程的“最近的cpu用法” 如果不可用，为负值。
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Interface ThreadMXBean

  • All Superinterfaces:
    PlatformManagedObject ， ThreadMXBean

    public interface ThreadMXBean
extends ThreadMXBean
    针对Java虚拟机线程系统的平台特定管理界面。

    此平台扩展仅适用于支持此扩展的线程实现。

    从以下版本开始：
    6u25

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getThreadAllocatedBytes​(long id)
      返回指定ID的线程在堆内存中分配的内存总量（以字节为单位）的近似值。
      long[] getThreadAllocatedBytes​(long[] ids)
      返回在ID为输入数组 ids每个线程的堆内存中分配的内存总量（以字节为单位）的 ids 。
      long[] getThreadCpuTime​(long[] ids)
      返回ID为输入数组 ids每个线程的总CPU时间， ids为纳秒。
      long[] getThreadUserTime​(long[] ids)
      返回输入阵列中的ID为 ids每个线程的CPU时间以纳秒的速度在用户模式下执行。
      boolean isThreadAllocatedMemoryEnabled​()
      测试是否启用了线程内存分配测量。
      boolean isThreadAllocatedMemorySupported​()
      测试Java虚拟机实现是否支持线程内存分配测量。
      void setThreadAllocatedMemoryEnabled​(boolean enable)
      启用或禁用线程内存分配测量。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

      • Methods inherited from interface java.lang.management.ThreadMXBean

        dumpAllThreads, findDeadlockedThreads, findMonitorDeadlockedThreads, getAllThreadIds, getCurrentThreadCpuTime, getCurrentThreadUserTime, getDaemonThreadCount, getPeakThreadCount, getThreadCount, getThreadCpuTime, getThreadInfo, getThreadInfo, getThreadInfo, getThreadInfo, getThreadInfo, getThreadUserTime, getTotalStartedThreadCount, isCurrentThreadCpuTimeSupported, isObjectMonitorUsageSupported, isSynchronizerUsageSupported, isThreadContentionMonitoringEnabled, isThreadContentionMonitoringSupported, isThreadCpuTimeEnabled, isThreadCpuTimeSupported, resetPeakThreadCount, setThreadContentionMonitoringEnabled, setThreadCpuTimeEnabled

    • 方法详细信息

      • getThreadCpuTime

        long[] getThreadCpuTime​(long[] ids)
        返回ID为输入数组ids每个线程的总CPU时间， ids为纳秒。 返回的值为纳秒精度，但不一定是纳秒精度。

        该方法相当于为输入数组ids中的每个线程ID调用ThreadMXBean.getThreadCpuTime(long)方法，并在返回的数组的相应元素中设置返回值。

        参数
        ids - 一个线程ID数组。
        结果
        长数值的数组，每个都是ID的输入数组的对应元素中所使用的线程的CPU时间量，如果指定的ID的线程存在，线程是活的，CPU时间测量启用; 否则为-1 。
        异常
        NullPointerException - 如果 ids是 null
        IllegalArgumentException - 如果输入阵列 ids中的任何元素是 <= 0 。
        UnsupportedOperationException - 如果Java虚拟机实现不支持CPU时间测量。
        另请参见：
        ThreadMXBean.getThreadCpuTime(long) ，
getThreadUserTime(long[]) ，
ThreadMXBean.isThreadCpuTimeSupported() ，
ThreadMXBean.isThreadCpuTimeEnabled() ，
ThreadMXBean.setThreadCpuTimeEnabled(boolean)

      • getThreadUserTime

        long[] getThreadUserTime​(long[] ids)
        返回输入阵列中的ID为ids每个线程的CPU时间，以纳秒为单位在用户模式下执行。 返回的值为纳秒精度，但不一定是纳秒精度。

        该方法相当于为输入数组ids中的每个线程ID调用ThreadMXBean.getThreadUserTime(long)方法，并在返回的数组的相应元素中设置返回的值。

        参数
        ids - 一个线程ID数组。
        结果
        长数值的数组，其中每一个是用户模式CPU时间，其ID在ID的输入数组的相应元素中所使用的线程，如果指定的ID的线程存在，该线程是活的，并且启用CPU时间测量; -1否则。
        异常
        NullPointerException - 如果 ids是 null
        IllegalArgumentException - 如果输入数组 ids中的任何元素是 <= 0 。
        UnsupportedOperationException - 如果Java虚拟机实现不支持CPU时间测量。
        另请参见：
        ThreadMXBean.getThreadUserTime(long) ，
getThreadCpuTime(long[]) ，
ThreadMXBean.isThreadCpuTimeSupported() ，
ThreadMXBean.isThreadCpuTimeEnabled() ，
ThreadMXBean.setThreadCpuTimeEnabled(boolean)

      • getThreadAllocatedBytes

        long getThreadAllocatedBytes​(long id)
        返回指定ID的线程在堆内存中分配的内存总量（以字节为单位）的近似值。 返回的值是近似值，因为一些Java虚拟机实现可能使用对象分配机制，导致在分配对象的时间与其大小记录的时间之间的延迟。

        如果指定ID的线程不存在或不存在，则此方法返回-1 。 如果线程内存分配测量被禁用，此方法返回-1 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        如果在线程启动后启用线程内存分配测量，则Java虚拟机实现可以选择任何时间，直到并包括启用该功能的时间为线程内存分配测量开始的时间。

        参数
        id - 线程的线程ID
        结果
        如果指定的ID的线程存在，该线程存在，并且线程存储器分配测量被使能，则对于指定ID的线程的堆内存中的分配的总内存的总内存的近似值（以字节为单位） 否则为-1 。
        异常
        IllegalArgumentException - 如果是 id <= 0 。
        UnsupportedOperationException - 如果Java虚拟机实现不支持线程内存分配测量。
        另请参见：
        isThreadAllocatedMemorySupported() ，
isThreadAllocatedMemoryEnabled() ，
setThreadAllocatedMemoryEnabled(boolean)

      • getThreadAllocatedBytes

        long[] getThreadAllocatedBytes​(long[] ids)
        返回在ID为输入数组ids每个线程的堆内存中分配的内存总量（以字节为单位）的ids 。 返回的值是近似值，因为一些Java虚拟机实现可能使用对象分配机制，导致在分配对象的时间与其大小记录的时间之间的延迟。

        该方法相当于为输入数组ids中的每个线程ID调用getThreadAllocatedBytes(long)方法，并在返回的数组的相应元素中设置返回值。

        参数
        ids - 一个线程ID数组。
        结果
        长数值的数组，其中的每一个都是对于ID在ID的输入数组的相应元素中的线程的堆存储器中分配的总内存（以字节为单位）的近似值。
        异常
        NullPointerException - 如果 ids是 null
        IllegalArgumentException - 如果输入阵列中的任何元素 ids是 <= 0 。
        UnsupportedOperationException - 如果Java虚拟机实现不支持线程内存分配测量。
        另请参见：
        getThreadAllocatedBytes(long) ，
isThreadAllocatedMemorySupported() ，
isThreadAllocatedMemoryEnabled() ，
setThreadAllocatedMemoryEnabled(boolean)

      • isThreadAllocatedMemorySupported

        boolean isThreadAllocatedMemorySupported​()
        测试Java虚拟机实现是否支持线程内存分配测量。
        结果
        true如果Java虚拟机实现支持线程内存分配测量; false否则。

      • isThreadAllocatedMemoryEnabled

        boolean isThreadAllocatedMemoryEnabled​()
        测试是否启用了线程内存分配测量。
        结果
        true如果线程内存分配测量被使能; 否则为false 。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持线程内存分配测量。
        另请参见：
        isThreadAllocatedMemorySupported()

      • setThreadAllocatedMemoryEnabled

        void setThreadAllocatedMemoryEnabled​(boolean enable)
        启用或禁用线程内存分配测量。 默认值取决于平台。
        参数
        enable - true启用; false禁用。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持线程内存分配测量。
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。
        另请参见：
        isThreadAllocatedMemorySupported()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnixOperatingSystemMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Interface UnixOperatingSystemMXBean

  • All Superinterfaces:
    OperatingSystemMXBean ， OperatingSystemMXBean ， PlatformManagedObject

    public interface UnixOperatingSystemMXBean
extends OperatingSystemMXBean
    适用于运行Java虚拟机的Unix操作系统的平台特定管理界面。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getMaxFileDescriptorCount​()
      返回文件描述符的最大数量。
      long getOpenFileDescriptorCount​()
      返回打开文件描述符的数量。

      • Methods inherited from interface com.sun.management.OperatingSystemMXBean

        getCommittedVirtualMemorySize, getFreePhysicalMemorySize, getFreeSwapSpaceSize, getProcessCpuLoad, getProcessCpuTime, getSystemCpuLoad, getTotalPhysicalMemorySize, getTotalSwapSpaceSize

      • Methods inherited from interface java.lang.management.OperatingSystemMXBean

        getArch, getAvailableProcessors, getName, getSystemLoadAverage, getVersion

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getOpenFileDescriptorCount

        long getOpenFileDescriptorCount​()
        返回打开文件描述符的数量。
        结果
        打开文件描述符的数量。

      • getMaxFileDescriptorCount

        long getMaxFileDescriptorCount​()
        返回文件描述符的最大数量。
        结果
        文件描述符的最大数量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.management (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.management

  • Packages that use com.sun.management
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
  • Classes in com.sun.management used by com.sun.management
    Class 描述
    GarbageCollectionNotificationInfo
    有关垃圾收集的信息
    GcInfo
    垃圾收集信息。
    OperatingSystemMXBean
    运行Java虚拟机的操作系统的平台特定管理界面。
    VMOption
    关于VM选项的信息，包括其价值以及值来自哪里被称为其origin 。
    VMOption.Origin
    VM选项的值的起源。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VMOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.management
软件包 com.sun.management

Class VMOption

  • java.lang.Object
    • com.sun.management.VMOption

  • public class VMOption
extends Object
    有关VM选项的信息，包括其值，值来自哪里被称为其origin 。

    每个VM选项都有一个默认值。 可以在虚拟机创建时通常将虚拟机选项设置为启动器的命令行参数或传递给使用JNI调用接口创建的虚拟机的参数。 此外，可以通过环境变量或配置文件设置VM选项。 虚拟机启动后，还可以通过管理界面动态设置VM选项。 A VMOption包含VM选项的值，以及构建此VMOption对象时该值的原点。 在构建VMOption对象后，VM选项的值可能会更改，

    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  VMOption.Origin
      VM选项的值的起源。

    • 构造方法摘要

      构造方法
      Constructor 描述
      VMOption​(String name, String value, boolean writeable, VMOption.Origin origin)
      构造一个 VMOption 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static VMOption from​(CompositeData cd)
      返回由给定的 CompositeData表示的 VMOption对象。
      String getName​()
      返回此VM选项的名称。
      VMOption.Origin getOrigin​()
      返回此VM选项的值的起始位置。
      String getValue​()
      在创建此 VMOption时返回此VM选项的值。
      boolean isWriteable​()
      测试此VM选项是否可写。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • VMOption

        public VMOption​(String name,
                String value,
                boolean writeable,
                VMOption.Origin origin)
        构造一个 VMOption 。
        参数
        name - VM选项的名称。
        value - VM选项的值。
        writeable - true如果VM选项可以动态设置，否则为 false 。
        origin - VM选项的值来自哪里。
        异常
        NullPointerException - 如果名称或值是 null

    • 方法详细信息

      • getName

        public String getName​()
        返回此VM选项的名称。
        结果
        该VM选项的名称。

      • getValue

        public String getValue​()
        在创建此VMOption时返回此VM选项的值。 该值可能已更改。
        结果
        创建此 VMOption时VM选项的值。

      • getOrigin

        public VMOption.Origin getOrigin​()
        返回此VM选项的值的起始位置。 也就是说，此VM选项的值来自哪里。
        结果
        该VM选项的值来自哪里。

      • isWriteable

        public boolean isWriteable​()
        测试此VM选项是否可写。 如果该VM选项是可写的，则可以通过HotSpotDiagnosticMXBean.setVMOption方法进行设置。
        结果
        true如果这个VM选项是可写的; false否则。

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • from

        public static VMOption from​(CompositeData cd)
        返回由给定的CompositeData表示的VMOption对象。 给定的CompositeData必须包含以下属性：
        description
        Attribute Name | Type
        name | java.lang.String
        value | java.lang.String
        origin | java.lang.String
        writeable | java.lang.Boolean
        参数
        cd - CompositeData代表 VMOption
        结果
        一个VMOption通过表示对象cd如果cd不是null ; null否则。
        异常
        IllegalArgumentException - 如果 cd不代表具有上述属性的 VMOption 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VMOption.Origin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.management
软件包 com.sun.management

Enum VMOption.Origin

  • java.lang.Object
    • java.lang.Enum<VMOption.Origin>
      • com.sun.management.VMOption.Origin
  • All Implemented Interfaces:
    Serializable ， Comparable<VMOption.Origin>
    Enclosing class:
    VMOption

    public static enum VMOption.Origin
extends Enum<VMOption.Origin>
    VM选项的值的起源。 它告诉VM选项的值来自哪里。
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ATTACH_ON_DEMAND
      VM选项是使用attach框架设置的。
      CONFIG_FILE
      VM选项通过配置文件设置。
      DEFAULT
      VM选项尚未设置，其值为默认值。
      ENVIRON_VAR
      VM选项通过环境变量设置。
      ERGONOMIC
      VM选项通过VM人机工程学支持设置。
      MANAGEMENT
      虚拟机启动后，通过管理界面设置VM选项。
      OTHER
      VM选项是通过其他机制设置的。
      VM_CREATION
      VM选项设置为VM创建时间，通常作为启动器的命令行参数或传递给使用JNI调用接口创建的VM的参数。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static VMOption.Origin valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VMOption.Origin[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DEFAULT

        public static final VMOption.Origin DEFAULT
        VM选项尚未设置，其值为默认值。

      • VM_CREATION

        public static final VMOption.Origin VM_CREATION
        VM选项设置为VM创建时间，通常作为启动器的命令行参数或传递给使用JNI调用接口创建的VM的参数。

      • ENVIRON_VAR

        public static final VMOption.Origin ENVIRON_VAR
        VM选项通过环境变量设置。

      • CONFIG_FILE

        public static final VMOption.Origin CONFIG_FILE
        VM选项通过配置文件设置。

      • MANAGEMENT

        public static final VMOption.Origin MANAGEMENT
        虚拟机启动后，通过管理界面设置VM选项。

      • ERGONOMIC

        public static final VMOption.Origin ERGONOMIC
        VM选项通过VM人机工程学支持设置。

      • ATTACH_ON_DEMAND

        public static final VMOption.Origin ATTACH_ON_DEMAND
        VM选项是使用attach框架设置的。
        从以下版本开始：
        9

      • OTHER

        public static final VMOption.Origin OTHER
        VM选项是通过其他机制设置的。

    • 方法详细信息

      • values

        public static VMOption.Origin[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (VMOption.Origin c : VMOption.Origin.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static VMOption.Origin valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.management.GarbageCollectionNotificationInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.management.GarbageCollectionNotificationInfo

  • Packages that use GarbageCollectionNotificationInfo
    软件包 描述
    com.sun.management
    此软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

    • Uses of GarbageCollectionNotificationInfo in com.sun.management

      Methods in com.sun.management that return GarbageCollectionNotificationInfo
      Modifier and Type 方法 描述
      static GarbageCollectionNotificationInfo GarbageCollectionNotificationInfo.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 GarbageCollectionNotificationInfo对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.management.GcInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.management.GcInfo

  • Packages that use GcInfo
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

    • Uses of GcInfo in com.sun.management

      Methods in com.sun.management that return GcInfo
      Modifier and Type 方法 描述
      static GcInfo GcInfo.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 GcInfo对象。
      GcInfo GarbageCollectionNotificationInfo.getGcInfo​()
      返回与最后垃圾收集相关的GC信息
      GcInfo GarbageCollectorMXBean.getLastGcInfo​()
      返回有关最新GC的GC信息。
      Constructors in com.sun.management with parameters of type GcInfo
      Constructor 描述
      GarbageCollectionNotificationInfo​(String gcName, String gcAction, String gcCause, GcInfo gcInfo)
      构造一个 GarbageCollectionNotificationInfo对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.management.VMOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.management.VMOption

  • Packages that use VMOption
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

    • Uses of VMOption in com.sun.management

      Methods in com.sun.management that return VMOption
      Modifier and Type 方法 描述
      static VMOption VMOption.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 VMOption对象。
      VMOption HotSpotDiagnosticMXBean.getVMOption​(String name)
      为给定名称的VM选项返回一个 VMOption对象。
      Methods in com.sun.management that return types with arguments of type VMOption
      Modifier and Type 方法 描述
      List<VMOption> HotSpotDiagnosticMXBean.getDiagnosticOptions​()
      返回所有诊断选项的 VMOption对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.management.VMOption.Origin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.management.VMOption.Origin

  • Packages that use VMOption.Origin
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

    • Uses of VMOption.Origin in com.sun.management

      Methods in com.sun.management that return VMOption.Origin
      Modifier and Type 方法 描述
      VMOption.Origin VMOption.getOrigin​()
      返回此VM选项的值的起始位置。
      static VMOption.Origin VMOption.Origin.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VMOption.Origin[] VMOption.Origin.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in com.sun.management with parameters of type VMOption.Origin
      Constructor 描述
      VMOption​(String name, String value, boolean writeable, VMOption.Origin origin)
      构造一个 VMOption 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.management.DiagnosticCommandMBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.management.DiagnosticCommandMBean

No usage of com.sun.management.DiagnosticCommandMBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.management.GarbageCollectorMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.management.GarbageCollectorMXBean

No usage of com.sun.management.GarbageCollectorMXBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.management.HotSpotDiagnosticMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.management.HotSpotDiagnosticMXBean

No usage of com.sun.management.HotSpotDiagnosticMXBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.management.OperatingSystemMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.management.OperatingSystemMXBean

  • Packages that use OperatingSystemMXBean
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

    • Uses of OperatingSystemMXBean in com.sun.management

      Subinterfaces of OperatingSystemMXBean in com.sun.management
      Modifier and Type 接口 描述
      interface  UnixOperatingSystemMXBean
      适用于运行Java虚拟机的Unix操作系统的平台特定管理界面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.management.ThreadMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.management.ThreadMXBean

No usage of com.sun.management.ThreadMXBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.management.UnixOperatingSystemMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.management.UnixOperatingSystemMXBean

No usage of com.sun.management.UnixOperatingSystemMXBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Authenticator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Authenticator

  • java.lang.Object
    • com.sun.net.httpserver.Authenticator
  • 已知直接子类：
    BasicAuthenticator

    public abstract class Authenticator
extends Object
    认证者表示HTTP认证机制的实现。 子类提供特定机制的实现，例如Digest或Basic auth。 调用实例来提供在所有传入请求中提供的认证信息的验证。 注意。 这意味着任何缓存凭据或其他身份验证信息都必须在此类之外完成。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Authenticator.Failure
      表示认证失败。
      static class  Authenticator.Result
      来自authenticate（）方法的返回类型的基类
      static class  Authenticator.Retry
      表示验证必须重试。
      static class  Authenticator.Success
      表示认证成功，通过调用getPrincipal（）可以获取已认证的用户主体。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Authenticator​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Authenticator.Result authenticate​(HttpExchange exch)
      被要求验证每个传入的请求。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Authenticator

        public Authenticator​()

    • 方法详细信息

      • authenticate

        public abstract Authenticator.Result authenticate​(HttpExchange exch)
        被要求验证每个传入的请求。 实施必须返回失败，成功或重试对象： -

        失败意味着认证已经完成，但由于凭证无效而失败。

        Sucess意味着认证成功，并且可以通过调用Sucess.getPrincipal（）来检索表示用户的Principal对象。

        重试意味着需要另一个HTTP交换。 在给定的HttpExchange中设置需要发送回客户端的任何响应头。 必须在Retry对象中提供要返回的响应代码。 重试可能会发生多次。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Authenticator.Failure (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Authenticator.Failure

  • java.lang.Object
    • com.sun.net.httpserver.Authenticator.Result
      • com.sun.net.httpserver.Authenticator.Failure
  • Enclosing class:
    Authenticator

    public static class Authenticator.Failure
extends Authenticator.Result
    表示认证失败。 身份验证尝试已完成。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Failure​(int responseCode)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getResponseCode​()
      返回发送给客户端的响应代码

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Failure

        public Failure​(int responseCode)

    • 方法详细信息

      • getResponseCode

        public int getResponseCode​()
        返回发送给客户端的响应代码
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Authenticator.Result (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Authenticator.Result

  • java.lang.Object
    • com.sun.net.httpserver.Authenticator.Result
  • 已知直接子类：
    Authenticator.Failure ， Authenticator.Retry ， Authenticator.Success
    Enclosing class:
    Authenticator

    public abstract static class Authenticator.Result
extends Object
    来自authenticate（）方法的返回类型的基类

    • 构造方法摘要

      构造方法
      Constructor 描述
      Result​()

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Result

        public Result​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Authenticator.Retry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Authenticator.Retry

  • java.lang.Object
    • com.sun.net.httpserver.Authenticator.Result
      • com.sun.net.httpserver.Authenticator.Retry
  • Enclosing class:
    Authenticator

    public static class Authenticator.Retry
extends Authenticator.Result
    表示验证必须重试。 要发回的响应代码是从getResponseCode（）返回的。 在返回此Retry对象之前，Authenticator还必须在给定的HttpExchange中设置任何必需的响应头。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Retry​(int responseCode)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getResponseCode​()
      返回发送给客户端的响应代码

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Retry

        public Retry​(int responseCode)

    • 方法详细信息

      • getResponseCode

        public int getResponseCode​()
        返回发送给客户端的响应代码
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Authenticator.Success (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Authenticator.Success

  • java.lang.Object
    • com.sun.net.httpserver.Authenticator.Result
      • com.sun.net.httpserver.Authenticator.Success
  • Enclosing class:
    Authenticator

    public static class Authenticator.Success
extends Authenticator.Result
    表示认证成功，通过调用getPrincipal（）可以获取已认证的用户主体。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Success​(HttpPrincipal p)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      HttpPrincipal getPrincipal​()
      返回经过身份验证的用户主体

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Success

        public Success​(HttpPrincipal p)

    • 方法详细信息

      • getPrincipal

        public HttpPrincipal getPrincipal​()
        返回经过身份验证的用户主体
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BasicAuthenticator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class BasicAuthenticator

  • java.lang.Object
    • com.sun.net.httpserver.Authenticator
      • com.sun.net.httpserver.BasicAuthenticator

  • public abstract class BasicAuthenticator
extends Authenticator
    BasicAuthenticator提供HTTP Basic认证的实现。 它是一个抽象类，必须扩展以提供一个checkCredentials(String,String)的实现，该实现被调用来验证每个传入的请求。

    • Nested Class Summary

      • Nested classes/interfaces inherited from class com.sun.net.httpserver.Authenticator

        Authenticator.Failure, Authenticator.Result, Authenticator.Retry, Authenticator.Success

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      protected String | realm

    • 构造方法摘要

      构造方法
      Constructor 描述
      BasicAuthenticator​(String realm)
      为给定的HTTP领域创建BasicAuthenticator

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Authenticator.Result authenticate​(HttpExchange t)
      被要求验证每个传入的请求。
      abstract boolean checkCredentials​(String username, String password)
      要求每个传入请求在此Authenticator的领域的上下文中验证给定的名称和密码。
      String getRealm​()
      返回此BasicAuthenticator创建的领域

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • realm

        protected String realm

    • 构造方法详细信息

      • BasicAuthenticator

        public BasicAuthenticator​(String realm)
        为给定的HTTP领域创建BasicAuthenticator
        参数
        realm - HTTP基本认证领域
        异常
        NullPointerException - 如果领域是空字符串

    • 方法详细信息

      • getRealm

        public String getRealm​()
        返回此BasicAuthenticator创建的领域
        结果
        验证者的领域字符串。

      • authenticate

        public Authenticator.Result authenticate​(HttpExchange t)
        描述从类复制： Authenticator
        被要求验证每个传入的请求。 实施必须返回失败，成功或重试对象： -

        失败意味着验证已完成，但由于凭据无效而失败。

        Sucess意味着认证成功，并且可以通过调用Sucess.getPrincipal（）来检索表示用户的Principal对象。

        重试意味着需要另一个HTTP交换。 在给定的HttpExchange中设置需要发送回客户端的任何响应头。 必须在Retry对象中提供要返回的响应代码。 重试可能会发生多次。

        Specified by:
        authenticate在 Authenticator

      • checkCredentials

        public abstract boolean checkCredentials​(String username,
                                         String password)
        要求每个传入请求在此Authenticator的领域的上下文中验证给定的名称和密码。 凭证的任何缓存必须通过执行此方法来完成
        参数
        username - 请求中的用户名
        password - 请求中的密码
        结果
        true如果凭据有效， false否则。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.net.httpserver (Java SE 9 & JDK 9 )

com.sun.net.httpserver

Interfaces

  • HttpHandler

Classes

  • Authenticator
  • Authenticator.Failure
  • Authenticator.Result
  • Authenticator.Retry
  • Authenticator.Success
  • BasicAuthenticator
  • Filter
  • Filter.Chain
  • Headers
  • HttpContext
  • HttpExchange
  • HttpPrincipal
  • HttpsConfigurator
  • HttpServer
  • HttpsExchange
  • HttpsParameters
  • HttpsServer


com.sun.net.httpserver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.httpserver

Package com.sun.net.httpserver

提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。 支持“http”和“https”。 API提供了RFC 2616 （HTTP 1.1）和RFC 2818 （HTTP over TLS）的部分实现。 API提供的任何HTTP功能都可以通过使用API的应用程序代码实现。

程序员必须实现HttpHandler接口。 该接口提供了一个回调函数，用于处理来自客户端的传入请求。 HTTP请求及其响应称为交换。 HTTP交换由HttpExchange类表示。 HttpServer类用于侦听传入的TCP连接，并将这些连接上的请求调度到已经在服务器上注册的处理程序。

一个最小的Http服务器示例如下所示：

   class MyHandler implements HttpHandler {
       public void handle(HttpExchange t) throws IOException {
           InputStream is = t.getRequestBody();
           read(is); // .. read the request body
           String response = "This is the response";
           t.sendResponseHeaders(200, response.length());
           OutputStream os = t.getResponseBody();
           os.write(response.getBytes());
           os.close();
       }
   }
   ...

   HttpServer server = HttpServer.create(new InetSocketAddress(8000), 0);
   server.createContext("/applications/myapp", new MyHandler());
   server.setExecutor(null); // creates a default executor
   server.start();

上面的示例创建了一个简单的HttpServer，它使用调用应用程序线程调用针对到端口8000的传入http请求的handle（）方法以及路径/ application / myapp /。

HttpExchange类封装了应用程序处理传入请求所需的所有内容，并生成适当的响应。

使用HttpServer注册处理程序会创建一个HttpContext对象，并且可以将Filter对象添加到返回的上下文中。 过滤器用于在交换机传递到交换处理程序之前执行自动的前处理和后处理。

对于敏感信息，可以使用HttpsServer来处理由SSL或TLS协议保护的“https”请求。 必须向HttpsServer提供一个HttpsConfigurator对象，其中包含初始化的SSLContext 。 HttpsConfigurator可用于配置密码套件和其他SSL操作参数。 可以创建一个简单的例子SSLContext如下：

   char[] passphrase = "passphrase".toCharArray();
   KeyStore ks = KeyStore.getInstance("JKS");
   ks.load(new FileInputStream("testkeys"), passphrase);

   KeyManagerFactory kmf = KeyManagerFactory.getInstance("SunX509");
   kmf.init(ks, passphrase);

   TrustManagerFactory tmf = TrustManagerFactory.getInstance("SunX509");
   tmf.init(ks);

   SSLContext ssl = SSLContext.getInstance("TLS");
   ssl.init(kmf.getKeyManagers(), tmf.getTrustManagers(), null);

在上面的示例中，使用keytool实用程序创建的名为“testkeys”的keystore文件用作客户端和服务器证书的证书存储。 以下代码显示了如何在HttpsConfigurator中使用SSLContext，以及SSLContext和HttpsConfigurator如何链接到HttpsServer。

    server.setHttpsConfigurator (new HttpsConfigurator(sslContext) {
        public void configure (HttpsParameters params) {

        // get the remote address if needed
        InetSocketAddress remote = params.getClientAddress();

        SSLContext c = getSSLContext();

        // get the default parameters
        SSLParameters sslparams = c.getDefaultSSLParameters();
        if (remote.equals (...) ) {
            // modify the default set for client x
        }

        params.setSSLParameters(sslparams);
        // statement above could throw IAE if any params invalid.
        // eg. if app has a UI and parameters supplied by a user.

        }
    });
从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    HttpHandler
    被调用以处理HTTP交换的处理程序。
  • 类摘要
    Class 描述
    Authenticator
    认证者表示HTTP认证机制的实现。
    Authenticator.Failure
    表示认证失败。
    Authenticator.Result
    来自authenticate（）方法的返回类型的基类
    Authenticator.Retry
    表示验证必须重试。
    Authenticator.Success
    表示认证成功，通过调用getPrincipal（）可以获取已认证的用户主体。
    BasicAuthenticator
    BasicAuthenticator提供HTTP Basic认证的实现。
    Filter
    用于预处理和后处理传入请求的过滤器。
    Filter.Chain
    与HttpServer关联的一连串过滤器。
    Headers
    HTTP请求和响应头通过此类，它实现接口表示Map < String ， List < String >>。
    HttpContext
    HttpContext表示应用程序的根URI路径与HttpHandler之间的映射，该对象被调用以处理在相关联的HttpServer或HttpsServer上发往该路径的请求。
    HttpExchange
    此类封装了收到的HTTP请求和在一个交换中生成的响应。
    HttpPrincipal
    表示通过HTTP Basic或Digest身份验证身份验证的用户。
    HttpsConfigurator
    此类用于配置HttpsServer上每个传入https连接的https参数。
    HttpServer
    这个类实现了一个简单的HTTP服务器。
    HttpsExchange
    此类封装了收到的HTTPS请求和在一个交换中生成的响应，并定义了特定于HTTPS协议的HttpExchange扩展。
    HttpsParameters
    表示与客户端协商的每个https连接的参数集。
    HttpsServer
    This class is an extension of HttpServer which provides support for HTTPS.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.net.httpserver Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.net.httpserver

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.net.httpserver.Authenticator
      • com.sun.net.httpserver.BasicAuthenticator
    • com.sun.net.httpserver.Authenticator.Result
      • com.sun.net.httpserver.Authenticator.Failure
      • com.sun.net.httpserver.Authenticator.Retry
      • com.sun.net.httpserver.Authenticator.Success
    • com.sun.net.httpserver.Filter
    • com.sun.net.httpserver.Filter.Chain
    • com.sun.net.httpserver.Headers (implements java.util.Map<K,V>)
    • com.sun.net.httpserver.HttpContext
    • com.sun.net.httpserver.HttpExchange
      • com.sun.net.httpserver.HttpsExchange
    • com.sun.net.httpserver.HttpPrincipal (implements java.security.Principal)
    • com.sun.net.httpserver.HttpsConfigurator
    • com.sun.net.httpserver.HttpServer
      • com.sun.net.httpserver.HttpsServer
    • com.sun.net.httpserver.HttpsParameters

Interface Hierarchy

  • com.sun.net.httpserver.HttpHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Filter

  • java.lang.Object
    • com.sun.net.httpserver.Filter

  • public abstract class Filter
extends Object
    用于预处理和后处理传入请求的过滤器。 预处理发生在应用程序的交换处理程序被调用之前，后处理在交换处理程序返回后发生。 过滤器以链式组织，并与HttpContext实例相关联。

    链中的每个过滤器调用自己的doFilter（）实现中的下一个过滤器。 链中的最终过滤器调用应用程序交换处理程序。

    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Filter.Chain
      与HttpServer关联的一连串过滤器。

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | Filter​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract String description​()
      返回此过滤器的简短说明
      abstract void doFilter​(HttpExchange exchange, Filter.Chain chain)
      要求此过滤器预先/后处理给定的交换。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Filter

        protected Filter​()

    • 方法详细信息

      • doFilter

        public abstract void doFilter​(HttpExchange exchange,
                              Filter.Chain chain)
                       throws IOException
        要求此过滤器预先/后处理给定的交换。 过滤器可以：
        • 检查或修改请求头
        • 通过创建适当的过滤器流并调用HttpExchange.setStreams(InputStream,OutputStream)来过滤请求体或响应体
        • 在交换中设置属性对象，哪些其他过滤器或交换处理程序可以访问。
        • 决定要么
          1. 调用链接中的下一个过滤器，通过调用Filter.Chain.doFilter(HttpExchange)
          2. 终止调用链， 不调用Filter.Chain.doFilter(HttpExchange)
        • 如果选择了上述选项1.那么当doFilter（）返回链中的所有随后的过滤器被调用时，可以检查或修改响应头。
        • 如果选择上述选项2.则此Filter必须使用HttpExchange发回适当的响应
        参数
        exchange - 要过滤的 HttpExchange 。
        chain - 允许调用下一个过滤器的链。
        异常
        IOException - 可能被任何过滤器模块抛出，如果被捕获，则必须再次被重新抛出。
        NullPointerException - 如果任何一个交易所或链都是 null

      • description

        public abstract String description​()
        返回此过滤器的简短说明
        结果
        描述过滤器的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Filter.Chain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Filter.Chain

  • java.lang.Object
    • com.sun.net.httpserver.Filter.Chain
  • Enclosing class:
    Filter

    public static class Filter.Chain
extends Object
    与HttpServer关联的一连串过滤器。 链中的每个过滤器都被赋予其中的一个，因此它可以调用链中的下一个过滤器

    • 构造方法摘要

      构造方法
      Constructor 描述
      Chain​(List<Filter> filters, HttpHandler handler)

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void doFilter​(HttpExchange exchange)
      调用链中的下一个过滤器，否则用户交换处理程序，如果这是链中的最终过滤器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Chain

        public Chain​(List<Filter> filters,
             HttpHandler handler)

    • 方法详细信息

      • doFilter

        public void doFilter​(HttpExchange exchange)
              throws IOException
        调用链中的下一个过滤器，否则用户交换处理程序，如果这是链中的最终过滤器。 过滤器可能决定终止链，不要调用此方法。 在这种情况下，过滤器必须将响应发送到请求，因为应用程序的交换处理程序将不被调用。
        参数
        exchange - HttpExchange
        异常
        IOException - 让异常传递给堆栈
        NullPointerException - if exchange is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Headers (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class Headers

  • java.lang.Object
    • com.sun.net.httpserver.Headers
  • All Implemented Interfaces:
    Map<String,List<String>>

    public class Headers
extends Object
implements Map<String,List<String>>
    HTTP请求和响应头通过此类，它实现接口表示Map < String ， List < String >>。 密钥是不区分大小写的，表示标题名称和与每个密钥相关联的值的字符串是List < String >，在请求或响应中每个出现标题名称都有一个元素。

    例如，如果响应头实例包含一个具有两个值“value1和value2”的键“HeaderName”，则该对象将作为两个标题行输出：

     HeaderName: value1
 HeaderName: value2

    提供所有正常的Map方法，但最有可能使用以下其他方便方法：

    • getFirst(String)返回单值头或多值头的第一个值。
    • add(String,String)将给定的头值添加到给定键的列表中
    • set(String,String)将给定的头字段设置为覆盖值列表中任何现有值的单个值。

    此类中的所有方法都接受键值和值的null值。 但是，空值键永远不会出现在HTTP请求头中，不会在响应头中输出/发送。 空值可以表示为密钥的空条目（即列表为空）或密钥具有列表，但列表的值中的一个（或多个）为空。 空值作为包含密钥但不包含关联值的标题行输出。

    从以下版本开始：
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      构造方法
      Constructor 描述
      Headers​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(String key, String value)
      将给定的值添加到给定键的标题列表中。
      void clear​()
      从该地图中删除所有的映射（可选操作）。
      boolean containsKey​(Object key)
      如果此映射包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此映射将一个或多个键映射到指定的值，则返回 true 。
      Set<Map.Entry<String,List<String>>> entrySet​()
      返回此地图中包含的映射的Set视图。
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      List<String> get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      String getFirst​(String key)
      从给定键的String列表中返回第一个值（如果至少存在一个）。
      int hashCode​()
      返回对象的哈希码值。
      boolean isEmpty​()
      如果此映射不包含键值映射，则返回 true 。
      Set<String> keySet​()
      返回此地图中包含的键的Set视图。
      List<String> put​(String key, List<String> value)
      将指定的值与该映射中的指定键相关联（可选操作）。
      void putAll​(Map<? extends String,? extends List<String>> t)
      将指定地图的所有映射复制到此映射（可选操作）。
      List<String> remove​(Object key)
      如果存在（从可选的操作），从该地图中删除一个键的映射。
      void set​(String key, String value)
      将给定值设置为给定键的唯一标题值。
      int size​()
      返回此地图中键值映射的数量。
      Collection<List<String>> values​()
      返回此地图中包含的值的Collection视图。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, forEach, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Headers

        public Headers​()

    • 方法详细信息

      • size

        public int size​()
        描述从接口Map复制
        返回此地图中键值映射的数量。 如果地图包含Integer.MAX_VALUE元素，返回Integer.MAX_VALUE 。
        Specified by:
        size在接口 Map<String,List<String>>
        结果
        该地图中键值映射的数量

      • isEmpty

        public boolean isEmpty​()
        说明从界面Map复制
        如果此映射不包含键值映射，则返回 true 。
        Specified by:
        isEmpty在接口 Map<String,List<String>>
        结果
        true如果此映射不包含键值映射

      • containsKey

        public boolean containsKey​(Object key)
        描述从接口Map复制
        如果此映射包含指定键的映射，则返回true 。 更正式地说，返回true当且仅当此映射包含一个键的映射关系k这样Objects.equals(key, k) 。 （最多可以有一个这样的映射。）
        Specified by:
        containsKey在接口 Map<String,List<String>>
        参数
        key - 在此地图中存在的密钥要进行测试
        结果
        true如果此映射包含指定键的映射

      • containsValue

        public boolean containsValue​(Object value)
        描述从接口Map复制
        如果此映射将一个或多个键映射到指定的值，则返回true 。 更正式地，返回true当且仅当此映射包含至少一个映射到值v ，使得Objects.equals(value, v) 。 对于Map接口的大多数实现，此操作可能需要在地图大小的时间线性。
        Specified by:
        containsValue在接口 Map<String,List<String>>
        参数
        value - 要在此地图中存在的值要进行测试
        结果
        true如果该地图将一个或多个键映射到指定的值

      • get

        public List<String> get​(Object key)
        描述从接口Map复制
        返回指定键映射到的值，如果此映射不包含该键的映射，则返回null 。

        更正式地，如果此映射包含从密钥映射k到值v使得Objects.equals(key, k) ，则此方法返回v ; 否则返回null 。 （最多可以有一个这样的映射。）

        如果此映射允许空值，则返回值为null并不一定表示映射不包含关键字的映射; 地图也可能将密钥明确地映射到null 。 可以使用containsKey操作来区分这两种情况。

        Specified by:
        get在接口 Map<String,List<String>>
        参数
        key - 要返回其关联值的键
        结果
        指定键映射到的值，如果此映射不包含键的映射， null

      • getFirst

        public String getFirst​(String key)
        从给定键的String列表中返回第一个值（如果至少存在一个）。
        参数
        key - 搜索的关键
        结果
        与键相关联的第一个字符串值

      • put

        public List<String> put​(String key,
                        List<String> value)
        描述从接口Map复制
        将指定的值与该映射中的指定键相关联（可选操作）。 如果映射先前包含了密钥的映射，则旧值将被指定的值替换。 （映射m被称为包含关键字k的映射，当且仅当m.containsKey(k)将返回true 。）
        Specified by:
        put在接口 Map<String,List<String>>
        参数
        key - 要与指定值相关联的键
        value - 与指定键相关联的值
        结果
        先前的值相关联key ，或null如果没有映射key 。 （A null返回也可以表示该地图以前关联的null与key ，如果实现支持null值）

      • add

        public void add​(String key,
                String value)
        将给定的值添加到给定键的标题列表中。 如果映射不存在，则创建它
        参数
        key - 标题名称
        value - 要添加到标题的标题值

      • set

        public void set​(String key,
                String value)
        将给定值设置为给定键的唯一标题值。 如果映射不存在，则创建它
        参数
        key - 标题名称
        value - 要设置的头值。

      • remove

        public List<String> remove​(Object key)
        说明从接口Map复制
        如果存在（从可选的操作），从该地图中删除一个键的映射。 更正式地，如果该映射包含从键k到值v的映射，使得Objects.equals(key, k) ，该映射被去除。 （地图最多可以包含一个这样的映射。）

        返回此映射先前关联该键的值，如果该映射不包含该键的映射，则返回null 。

        如果此映射允许空值，则返回值为null并不一定表示该映射不包含该键的映射; 地图也可能将密钥显式映射到null 。

        一旦呼叫返回，该映射将不包含指定键的映射。

        Specified by:
        remove在接口 Map<String,List<String>>
        参数
        key - 要从地图中删除其映射的密钥
        结果
        先前的值相关联 key ，或 null如果没有映射 key 。

      • putAll

        public void putAll​(Map<? extends String,? extends List<String>> t)
        说明从接口Map复制
        将指定地图的所有映射复制到此映射（可选操作）。 此呼叫的效果等同于在此地图上调用put(k, v)一次，从按键k到指定地图中的值为v每个映射。 如果在操作进行中修改了指定的地图，则此操作的行为是未定义的。
        Specified by:
        putAll在接口 Map<String,List<String>>
        参数
        t - 要存储在此地图中的映射

      • clear

        public void clear​()
        描述从接口Map复制
        从该地图中删除所有的映射（可选操作）。 此呼叫返回后，地图将为空。
        Specified by:
        clear在接口 Map<String,List<String>>

      • keySet

        public Set<String> keySet​()
        说明从接口Map复制
        返回此地图中包含的键的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行中修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<String,List<String>>
        结果
        该地图中包含的键的集合视图

      • values

        public Collection<List<String>> values​()
        说明从接口Map复制
        返回此地图中包含的值的Collection视图。 集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时修改映射（除了通过迭代器自己的remove操作），迭代的结果是未定义的。 该collection支持元素移除，即从映射中相应的映射，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<String,List<String>>
        结果
        该地图中包含的值的集合视图

      • entrySet

        public Set<Map.Entry<String,List<String>>> entrySet​()
        说明从界面Map复制
        返回此地图中包含的映射的Set视图。 该集合由地图支持，因此对地图的更改将反映在集合中，反之亦然。 如果在集合中的迭代正在进行时（除了通过迭代器自己的remove操作，或者通过迭代器返回的映射条目上的setValue操作），映射被修改，则迭代的结果是未定义的。 该组支持元件移除，即从映射中相应的映射，经由Iterator.remove ， Set.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        entrySet在接口 Map<String,List<String>>
        结果
        该地图中包含的映射的集合视图

      • equals

        public boolean equals​(Object o)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖该方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        Specified by:
        equals在接口 Map<String,List<String>>
        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那些 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是在对象上的equals比较中没有使用任何信息进行修改。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        Specified by:
        hashCode在接口 Map<String,List<String>>
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpContext

  • java.lang.Object
    • com.sun.net.httpserver.HttpContext

  • public abstract class HttpContext
extends Object
    HttpContext表示应用程序的根URI路径与被调用以处理在相关联的HttpServer或HttpsServer上发往该路径的请求的HttpHandler之间的映射。

    HttpContext实例由HttpServer和HttpsServer中的create方法创建

    可以将一个Filter个对象的链接添加到HttpContext。 由上下文处理的所有交易所可以由链中的每个过滤器进行预处理和后处理。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | HttpContext​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Map<String,Object> getAttributes​()
      返回一个可变的Map，可以将配置和其他数据传递给Filter模块和上下文的交换处理程序。
      abstract Authenticator getAuthenticator​()
      返回当前设置的身份验证器（如果存在）。
      abstract List<Filter> getFilters​()
      返回此上下文的过滤器列表。
      abstract HttpHandler getHandler​()
      返回此上下文的处理程序
      abstract String getPath​()
      返回此上下文创建的路径
      abstract HttpServer getServer​()
      返回创建该上下文的服务器
      abstract Authenticator setAuthenticator​(Authenticator auth)
      设置此HttpContext的Authenticator。
      abstract void setHandler​(HttpHandler h)
      设置此上下文的处理程序（如果尚未设置）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpContext

        protected HttpContext​()

    • 方法详细信息

      • getHandler

        public abstract HttpHandler getHandler​()
        返回此上下文的处理程序
        结果
        这个上下文的HttpHandler

      • setHandler

        public abstract void setHandler​(HttpHandler h)
        设置此上下文的处理程序（如果尚未设置）。
        参数
        h - 为此上下文设置的处理程序
        异常
        IllegalArgumentException - 如果此上下文的处理程序已设置。
        NullPointerException - 如果处理程序是 null

      • getPath

        public abstract String getPath​()
        返回此上下文创建的路径
        结果
        这个上下文的路径

      • getServer

        public abstract HttpServer getServer​()
        返回创建该上下文的服务器
        结果
        这个上下文的服务器

      • getAttributes

        public abstract Map<String,Object> getAttributes​()
        返回一个可变的Map，可以将配置和其他数据传递给Filter模块和上下文的交换处理程序。

        存储在此Map中的每个属性将对此上下文处理的每个HttpExchange都可见

      • getFilters

        public abstract List<Filter> getFilters​()
        返回此上下文的过滤器列表。 这是服务器在发送请求时使用的实际列表，因此对此列表的修改会立即影响交换机的处理。

      • setAuthenticator

        public abstract Authenticator setAuthenticator​(Authenticator auth)
        设置此HttpContext的Authenticator。 一旦在上下文中建立了验证器，所有客户机请求都必须被认证，并且将调用给定的对象来验证每个请求。 每次调用此方法将替换任何先前的值集。
        参数
        auth - 验证器设置。 如果null则删除任何先前设置的认证器，并且不再需要客户端认证。
        结果
        以前的Authenticator（如果有的话），否则为 null 。

      • getAuthenticator

        public abstract Authenticator getAuthenticator​()
        返回当前设置的身份验证器（如果存在）。
        结果
        这个HttpContext的Authenticator，或者如果没有设置， null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpExchange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpExchange

  • java.lang.Object
    • com.sun.net.httpserver.HttpExchange
  • 已知直接子类：
    HttpsExchange

    public abstract class HttpExchange
extends Object
    此类封装了收到的HTTP请求和在一个交换中生成的响应。 它提供了从客户端检查请求以及构建和发送响应的方法。

    HttpExchange的典型生命周期如下所示。

    1. getRequestMethod()来确定命令
    2. getRequestHeaders()检查请求标头（如果需要）
    3. getRequestBody()返回InputStream读取请求体。 读取请求正文后，流即将关闭。
    4. getResponseHeaders()设置任何响应头，除了content-length
    5. sendResponseHeaders(int,long)发送响应头。 必须在下一步之前调用。
    6. getResponseBody()得到一个OutputStream发送响应体。 当响应体被写入时，流必须关闭才能终止交换。
    终止交流
    当请求InputStream和响应OutputStream都关闭时，交换终止。 关闭OutputStream，隐式关闭InputStream（如果尚未关闭）。 但是，建议您在关闭之前从InputStream中使用所有数据。 便利方法close()执行所有这些任务。 关闭交换而不占用所有请求主体不是错误，但可能使基础TCP连接不可用于以下交换。 未能终止交换的效果未定义，但通常会导致资源无法被释放/重用。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | HttpExchange​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void close​()
      通过按顺序执行以下操作来结束此交换：关闭请求InputStream（如果尚未关闭） 关闭OutputStream的响应，如果尚未关闭。
      abstract Object getAttribute​(String name)
      过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。
      abstract HttpContext getHttpContext​()
      获取此交换的HttpContext
      abstract InetSocketAddress getLocalAddress​()
      返回接收请求的本地地址
      abstract HttpPrincipal getPrincipal​()
      如果认证被设置在拥有这种交换的HttpContext，则此方法将返回HttpPrincipal ，表示此HttpExchange身份验证的用户。
      abstract String getProtocol​()
      从请求中以 协议/ majorVersion.minorVersion的形式返回协议串。
      abstract InetSocketAddress getRemoteAddress​()
      返回调用此请求的远程实体的地址
      abstract InputStream getRequestBody​()
      返回可以从中读取请求主体的流。
      abstract Headers getRequestHeaders​()
      返回包含此请求中包含的HTTP标头的不可变地图。
      abstract String getRequestMethod​()
      获取请求方法
      abstract URI getRequestURI​()
      获取请求URI
      abstract OutputStream getResponseBody​()
      返回响应主体必须写入的流。
      abstract int getResponseCode​()
      返回响应代码（如果已经设置）
      abstract Headers getResponseHeaders​()
      返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。
      abstract void sendResponseHeaders​(int rCode, long responseLength)
      开始使用本方法中指定的当前响应头和数字响应代码将响应发送回客户端。
      abstract void setAttribute​(String name, Object value)
      过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。
      abstract void setStreams​(InputStream i, OutputStream o)
      过滤器使用该包交换器的InputStream和OutputStream（或两者）与给定的过滤流，以便后续调用getRequestBody()将返回给定的InputStream ，并且调用getResponseBody()将返回给定的OutputStream 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpExchange

        protected HttpExchange​()

    • 方法详细信息

      • getRequestHeaders

        public abstract Headers getRequestHeaders​()
        返回包含此请求中包含的HTTP标头的不可变地图。 该地图中的键将是标题名称，而这些值将是包含每个包含的值的字符串列表（对于多次列出的标题，或者是接受逗号分隔的值列表）单线）。 在这两种情况下，标题名称的值将按照请求中包含的顺序进行显示。

        地图中的键不区分大小写。

        结果
        一个可以用来访问请求头的只读地图

      • getResponseHeaders

        public abstract Headers getResponseHeaders​()
        返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。 地图中的键将是标题名称，而这些值必须是包含应包含多次（按照它们应包含的顺序）的每个值的字符串列表。

        地图中的键不区分大小写。

        结果
        可写地图，可用于设置响应头。

      • getRequestURI

        public abstract URI getRequestURI​()
        获取请求URI
        结果
        请求URI

      • getRequestMethod

        public abstract String getRequestMethod​()
        获取请求方法
        结果
        请求方式

      • getHttpContext

        public abstract HttpContext getHttpContext​()
        获取此交换的HttpContext
        结果
        HttpContext

      • close

        public abstract void close​()
        按顺序完成此交换：
        1. 关闭请求InputStream，如果尚未关闭;
        2. 关闭OutputStream的响应，如果尚未关闭。

      • getRequestBody

        public abstract InputStream getRequestBody​()
        返回可以从中读取请求主体的流。 对此方法的多次调用将返回相同的流。 建议应用程序在关闭之前消耗（读取）此流中的所有数据。 如果在所有数据被读取之前关闭流，则close（）调用将读取并丢弃剩余的数据（达到一个实现特定的字节数）。
        结果
        可以从中读取请求主体的流。

      • getResponseBody

        public abstract OutputStream getResponseBody​()
        返回响应主体必须写入的流。 sendResponseHeaders(int,long) ）必须在调用此方法之前调用。 对此方法的多次调用（对于相同的交换）将返回相同的流。 为了正确地终止每个交换，输出流必须关闭，即使没有发送响应正文。

        关闭此流隐式关闭从getRequestBody()返回的InputStream（如果尚未关闭）。

        如果对sendResponseHeaders（）的调用指定了一个固定的响应体长度，则该调用中指定的确切字节数必须写入此流。 如果写入太多字节，那么write（）将抛出一个IOException。 如果写入太少的字节，则流close（）将抛出IOException。 在这两种情况下，交换中断，底层TCP连接关闭。

        结果
        响应主体被写入的流

      • sendResponseHeaders

        public abstract void sendResponseHeaders​(int rCode,
                                         long responseLength)
                                  throws IOException
        开始使用本方法中指定的当前响应头和数字响应代码将响应发送回客户端。 响应体长度也如下所述。 如果响应长度参数大于零，则指定要发送的确切字节数，并且应用程序必须发送确切的数据量。 如果响应长度参数是zero ，则使用分块传输编码，并且可以发送任意数量的数据。 应用程序通过关闭OutputStream来终止响应体。 如果响应长度值为-1则不会发送响应正文。

        如果内容长度响应头尚未设置，则根据响应长度参数将其设置为适当的值。

        在调用getResponseBody()之前必须调用此方法。

        参数
        rCode - 要发送的响应代码
        responseLength - 如果> 0，则指定固定的响应体长度，并且必须将精确的字节数写入从getResponseBody（）获取的流中，否则如果等于0，则使用分块编码，并且任意数量的字节可能被写 如果<= -1，则没有指定响应体长度，并且不能写入响应体。
        异常
        IOException
        另请参见：
        getResponseBody()

      • getRemoteAddress

        public abstract InetSocketAddress getRemoteAddress​()
        返回调用此请求的远程实体的地址
        结果
        调用者的InetSocketAddress

      • getResponseCode

        public abstract int getResponseCode​()
        返回响应代码（如果已经设置）
        结果
        响应代码（如果有）。 -1如果还没有。

      • getLocalAddress

        public abstract InetSocketAddress getLocalAddress​()
        返回接收请求的本地地址
        结果
        本地接口的InetSocketAddress

      • getProtocol

        public abstract String getProtocol​()
        从请求中以协议/ majorVersion.minorVersion的形式返回协议串。 例如，“HTTP / 1.1”
        结果
        来自请求的协议串

      • getAttribute

        public abstract Object getAttribute​(String name)
        过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。 其他过滤器或交换处理程序可能会访问这些对象。

        每个Filter类都将记录它们可用的属性。

        参数
        name - 要检索的属性的名称
        结果
        属性对象，如果不存在，则为null
        异常
        NullPointerException - 如果名字是 null

      • setAttribute

        public abstract void setAttribute​(String name,
                                  Object value)
        过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。 其他过滤器或交换处理程序可能会访问这些对象。

        每个Filter类都将记录它们可用的属性。

        参数
        name - 与属性值关联的名称
        value - 存储为属性值的对象。 null值为null 。
        异常
        NullPointerException - 如果名字是 null

      • setStreams

        public abstract void setStreams​(InputStream i,
                                OutputStream o)
        过滤器使用该交换的InputStream和OutputStream（或两者）与给定的过滤流，以便后续调用getRequestBody()将返回给定的InputStream ，并且调用getResponseBody()将返回给定的OutputStream 。 提供给此呼叫的流必须包装原始流，并且可能是（但不是必须的） FilterInputStream和FilterOutputStream的子类。
        参数
        i - 被过滤的输入流设置为此对象的输入流，如果没有更改， null 。
        o - 过滤后的输出流设置为此对象的输出流，如果没有更改 null 。

      • getPrincipal

        public abstract HttpPrincipal getPrincipal​()
        如果认证被设置在拥有这种交换的HttpContext，则此方法将返回HttpPrincipal ，表示此HttpExchange身份验证的用户。
        结果
        the HttpPrincipal, or null if no authenticator is set.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Interface HttpHandler

  • public interface HttpHandler
    被调用以处理HTTP交换的处理程序。 每个HTTP交换都由其中一个处理程序来处理。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void handle​(HttpExchange exchange)
      处理给定的请求并产生适当的响应。

    • 方法详细信息

      • handle

        void handle​(HttpExchange exchange)
     throws IOException
        处理给定的请求并产生适当的响应。 有关处理交易所涉及的步骤的说明，请参阅HttpExchange 。
        参数
        exchange - 交换包含来自客户端的请求并用于发送响应
        异常
        NullPointerException - 如果交易是 null
        IOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpPrincipal

  • java.lang.Object
    • com.sun.net.httpserver.HttpPrincipal
  • All Implemented Interfaces:
    Principal

    public class HttpPrincipal
extends Object
implements Principal
    表示通过HTTP Basic或Digest身份验证身份验证的用户。

    • 构造方法摘要

      构造方法
      Constructor 描述
      HttpPrincipal​(String username, String realm)
      从给定的用户名和领域创建一个HttpPrincipal

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object another)
      比较两个HttpPrincipal。
      String getName​()
      以 realm：username格式返回此主体的内容
      String getRealm​()
      返回此对象创建的领域。
      String getUsername​()
      返回此对象创建的用户名。
      int hashCode​()
      返回此HttpPrincipal的哈希码。
      String toString​()
      返回与getName（）相同的字符串

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • HttpPrincipal

        public HttpPrincipal​(String username,
                     String realm)
        从给定的用户名和领域创建一个HttpPrincipal
        参数
        username - 领域内用户的名称
        realm - 领域。
        异常
        NullPointerException - 如果用户名或领域都为空

    • 方法详细信息

      • equals

        public boolean equals​(Object another)
        比较两个HttpPrincipal。 如果另一个是true的实例，则返回true ，其用户名和领域等于该对象的用户名和领域。 否则返回false 。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        another - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • getName

        public String getName​()
        以 realm：username格式返回此主体的内容
        Specified by:
        getName在接口 Principal
        结果
        这个委托人的名字。

      • getUsername

        public String getUsername​()
        返回此对象创建的用户名。

      • getRealm

        public String getRealm​()
        返回此对象创建的领域。

      • hashCode

        public int hashCode​()
        返回此HttpPrincipal的哈希码。 这是计算为(getUsername()+getRealm().hashCode()
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回与getName（）相同的字符串
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpsConfigurator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpsConfigurator

  • java.lang.Object
    • com.sun.net.httpserver.HttpsConfigurator

  • public class HttpsConfigurator
extends Object
    此类用于配置HttpsServer上每个传入https连接的https参数。 为了更改默认配置，应用程序需要覆盖configure(HttpsParameters)方法。

    以下example显示了如何做到这一点：

     SSLContext sslContext = SSLContext.getInstance (....);
 HttpsServer server = HttpsServer.create();

 server.setHttpsConfigurator (new HttpsConfigurator(sslContext) {
     public void configure (HttpsParameters params) {

         // get the remote address if needed
         InetSocketAddress remote = params.getClientAddress();

         SSLContext c = getSSLContext();

         // get the default parameters
         SSLParameters sslparams = c.getDefaultSSLParameters();
         if (remote.equals (...) ) {
             // modify the default set for client x
         }

         params.setSSLParameters(sslparams);
     }
 });
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      HttpsConfigurator​(SSLContext context)
      使用给定的SSLContext创建一个Https配置。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void configure​(HttpsParameters params)
      由HttpsServer调用以配置当前正在建立的https连接的参数。
      SSLContext getSSLContext​()
      返回此HttpsConfigurator的SSLContext。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpsConfigurator

        public HttpsConfigurator​(SSLContext context)
        使用给定的SSLContext创建一个Https配置。
        参数
        context - 用于此配置器的SSLContext
        异常
        NullPointerException - 如果没有提供SSLContext

    • 方法详细信息

      • getSSLContext

        public SSLContext getSSLContext​()
        返回此HttpsConfigurator的SSLContext。
        结果
        SSLContext

      • configure

        public void configure​(HttpsParameters params)
        由HttpsServer调用以配置当前正在建立的https连接的参数。 为了设置连接的SSL参数，configure（）的实现必须调用HttpsParameters.setSSLParameters(SSLParameters) 。

        此方法的默认实现使用从中返回的SSLParameters

        getSSLContext().getDefaultSSLParameters()

        为了修改此行为，configure（）可能会被覆盖。 见，例如above 。

        参数
        params - 要配置的HttpsParameters。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpServer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpServer

  • java.lang.Object
    • com.sun.net.httpserver.HttpServer
  • 已知直接子类：
    HttpsServer

    public abstract class HttpServer
extends Object
    这个类实现了一个简单的HTTP服务器。 HttpServer绑定到一个IP地址和端口号，并侦听从该地址的客户端传入的TCP连接。 子类HttpsServer实现一个处理HTTPS请求的服务器。

    一个或多个HttpHandler对象必须与服务器相关联才能处理请求。 每个这样的HttpHandler都注册了一个根URI路径，该路径代表该服务器上应用程序或服务的位置。 处理程序到HttpServer的映射由一个HttpContext对象封装。 HttpContexts是通过调用createContext(String,HttpHandler)创建的。 任何无法找到任何处理程序的请求都将被拒绝。 线程的管理可以通过提供一个Executor对象在该对象的外部进行。 如果没有提供默认实现。

    将 请求URI映射到HttpContext路径

    当接收到HTTP请求时，通过查找路径是请求URI路径的最长匹配前缀的上下文来定位适当的HttpContext（和处理程序）。 路径是字面上匹配的，这意味着字符串将被敏感地进行比较，并且没有转换到或来自任何编码形式。 例如。 给出配置了以下HttpContexts的HttpServer。

    description Context Context path ctx1 "/" ctx2 "/apps/" ctx3 "/apps/foo/"

    下表显示了一些请求URI，以及哪些上下文匹配。

    description Request URI Matches context "http://foo.com/apps/foo/bar" ctx3 "http://foo.com/apps/Foo/bar" no match, wrong case "http://foo.com/apps/app1" ctx2 "http://foo.com/foo" ctx1

    关于套接字积压的注意事项

    当绑定到地址和端口号时，应用程序也可以指定一个整数backlog参数。 这表示系统将内部队列的传入TCP连接的最大数量。 连接在等待HttpServer接受时排队等待。 达到极限时，底层TCP实现可能会拒绝进一步的连接（或可能被忽略）。 设置正确的积压值是TCP层中有效资源使用（不要设置太高）并允许输入请求的足够吞吐量（不要将其设置得太低）之间的妥协。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | HttpServer​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void bind​(InetSocketAddress addr, int backlog)
      将当前未绑定的HttpServer绑定到给定的地址和端口号。
      static HttpServer create​()
      创建一个最初没有绑定到任何本地地址/端口的HttpServer实例。
      static HttpServer create​(InetSocketAddress addr, int backlog)
      创建将绑定到指定的InetSocketAddress （IP地址和端口号）的HttpServer实例也可以指定最大的积压。
      abstract HttpContext createContext​(String path)
      创建一个HttpContext，而不会最初指定一个处理程序。
      abstract HttpContext createContext​(String path, HttpHandler handler)
      创建一个HttpContext。
      abstract InetSocketAddress getAddress​()
      返回服务器正在侦听的地址
      abstract Executor getExecutor​()
      如果指定了 setExecutor(Executor) ，则返回此服务器的Executor对象，如果未指定，则 返回 null 。
      abstract void removeContext​(HttpContext context)
      从服务器中删除给定的上下文。
      abstract void removeContext​(String path)
      从服务器中删除由给定路径标识的上下文。
      abstract void setExecutor​(Executor executor)
      设置此服务器的Executor对象。
      abstract void start​()
      在新的后台线程中启动此服务器。
      abstract void stop​(int delay)
      通过关闭监听套接字来停止此服务器，并禁止任何新的交换机被处理。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpServer

        protected HttpServer​()

    • 方法详细信息

      • create

        public static HttpServer create​()
                         throws IOException
        创建一个最初没有绑定到任何本地地址/端口的HttpServer实例。 HttpServer从当前安装的HttpServerProvider获取服务器必须使用bind(InetSocketAddress,int)绑定才能使用。
        异常
        IOException

      • create

        public static HttpServer create​(InetSocketAddress addr,
                                int backlog)
                         throws IOException
        创建一个HttpServer实例，它将绑定到指定的InetSocketAddress （IP地址和端口号）也可以指定最大的积压。 这是在侦听套接字上允许的排队入站连接的最大数量。 超过此限制的排队TCP连接可能被TCP实现拒绝。 HttpServer从当前安装的HttpServerProvider获取
        参数
        addr - 要监听的地址，如果是 null那么bind（）必须调用来设置地址
        backlog - 套接字积压。 如果该值小于或等于零，则使用系统默认值。
        异常
        BindException - 如果服务器无法绑定到请求的地址，或者服务器已经绑定。
        IOException

      • bind

        public abstract void bind​(InetSocketAddress addr,
                          int backlog)
                   throws IOException
        将当前未绑定的HttpServer绑定到给定的地址和端口号。 也可以指定最大积压。 这是在侦听套接字上允许的排队入站连接的最大数量。 超过此限制的排队TCP连接可能被TCP实现拒绝。
        参数
        addr - 要收听的地址
        backlog - 套接字积压。 如果该值小于或等于零，则使用系统默认值。
        异常
        BindException - 如果服务器无法绑定到请求的地址或服务器已绑定。
        NullPointerException - 如果addr是 null
        IOException

      • start

        public abstract void start​()
        在新的后台线程中启动此服务器。 后台线程继承了调用者的优先级，线程组和上下文类加载器。

      • setExecutor

        public abstract void setExecutor​(Executor executor)
        设置此服务器的Executor对象。 执行人必须在start()被调用之前建立。 所有HTTP请求都是在给予执行者的任务中处理的。 如果没有调用此方法（在start（）之前）或使用null执行程序调用该null ，则使用默认实现，该实现使用由start()方法创建的线程。
        参数
        executor - 执行者设置，或 null作为默认实现
        异常
        IllegalStateException - 如果服务器已经启动

      • getExecutor

        public abstract Executor getExecutor​()
        如果指定了 setExecutor(Executor) ，则返回此服务器的Executor对象，如果没有指定，则 返回 null 。
        结果
        执行人员为此服务器建立或 null如果未设置。

      • stop

        public abstract void stop​(int delay)
        通过关闭监听套接字来停止此服务器，并禁止任何新的交换机被处理。 然后，该方法将阻塞，直到所有当前的交换处理程序已经完成，或者大约延迟秒数过去（取决于哪个更早发生）。 然后，所有打开的TCP连接都关闭，由start（）创建的后台线程退出，方法返回。 一旦停止，HttpServer将无法重新使用。
        参数
        delay - 等待交易完成的最长时间（秒）。
        异常
        IllegalArgumentException - 如果延迟小于零。

      • createContext

        public abstract HttpContext createContext​(String path,
                                          HttpHandler handler)
        创建一个HttpContext。 HttpContext表示从这个HttpServer的URI路径到交换处理程序的映射。 一旦创建，服务器为路径接收的所有请求将通过调用给定的处理程序对象来处理。 上下文由路径标识，稍后可以使用removeContext(String)方法从服务器中删除。

        该路径指定此上下文的根URI路径。 路径的第一个字符必须是'/'。

        类概述描述了HttpContext实例的传入请求URI如何为mapped 。

        参数
        path - 将上下文关联的根URI路径
        handler - 调用传入请求的处理程序。
        异常
        IllegalArgumentException - 如果路径无效，或者如果此路径已存在上下文
        NullPointerException - 如果任一路径或处理程序是 null

      • createContext

        public abstract HttpContext createContext​(String path)
        创建一个HttpContext，而不会最初指定一个处理程序。 稍后必须使用HttpContext.setHandler(HttpHandler)指定处理程序。 HttpContext表示从这个HttpServer的URI路径到交换处理程序的映射。 一旦创建，并且当处理程序被设置时，服务器为路径接收到的所有请求将通过调用处理程序对象来处理。 上下文由路径标识，稍后可以使用removeContext(String)方法从服务器中删除。

        该路径指定此上下文的根URI路径。 路径的第一个字符必须是'/'。

        类概述描述了HttpContext实例的传入请求URI如何为mapped 。

        参数
        path - 将上下文关联的根URI路径
        异常
        IllegalArgumentException - 如果路径无效，或者该路径的上下文已存在
        NullPointerException - 如果路径是 null

      • removeContext

        public abstract void removeContext​(String path)
                            throws IllegalArgumentException
        从服务器中删除由给定路径标识的上下文。 删除上下文不会影响当前正在处理的交换，但会阻止新的上下文被接受。
        参数
        path - 要删除的处理程序的路径
        异常
        IllegalArgumentException - 如果没有与此路径对应的处理程序存在。
        NullPointerException - 如果路径是 null

      • removeContext

        public abstract void removeContext​(HttpContext context)
        从服务器中删除给定的上下文。 删除上下文不会影响当前正在处理的交换，但会阻止新的上下文被接受。
        参数
        context - 要删除的上下文
        异常
        NullPointerException - 如果上下文是 null

      • getAddress

        public abstract InetSocketAddress getAddress​()
        返回服务器正在侦听的地址
        结果
        the address/port number the server is listening on
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpsExchange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpsExchange

  • java.lang.Object
    • com.sun.net.httpserver.HttpExchange
      • com.sun.net.httpserver.HttpsExchange

  • public abstract class HttpsExchange
extends HttpExchange
    此类封装了收到的HTTPS请求和在一个交换中生成的响应，并定义了特定于HTTPS协议的HttpExchange扩展。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | HttpsExchange​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract SSLSession getSSLSession​()
      获得SSLSession用于此交换。

      • Methods inherited from class com.sun.net.httpserver.HttpExchange

        close, getAttribute, getHttpContext, getLocalAddress, getPrincipal, getProtocol, getRemoteAddress, getRequestBody, getRequestHeaders, getRequestMethod, getRequestURI, getResponseBody, getResponseCode, getResponseHeaders, sendResponseHeaders, setAttribute, setStreams

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpsExchange

        protected HttpsExchange​()

    • 方法详细信息

      • getSSLSession

        public abstract SSLSession getSSLSession​()
        获得SSLSession用于此交换。
        结果
        SSLSession
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpsParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpsParameters

  • java.lang.Object
    • com.sun.net.httpserver.HttpsParameters

  • public abstract class HttpsParameters
extends Object
    表示与客户端协商的每个https连接的参数集。 其中一个被创建并传递给每个传入的https连接的HttpsConfigurator.configure(HttpsParameters) ，以确定要使用的参数。

    底层SSL参数可以通过此类的set / get方法建立，也可以通过SSLParameters对象建立。 SSLParameters是首选方法，因为将来可能会向该类添加其他配置功能，并且使用SSLParameters更容易地确定支持的参数集及其默认值。 另外，如果通过setSSLParameters(SSLParameters)提供了一个SSLParameters对象，那么将使用这些参数设置，并忽略在此对象中进行的任何设置。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | HttpsParameters​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      String[] getCipherSuites​()
      返回密码数组的副本，如果没有设置则返回null。
      abstract InetSocketAddress getClientAddress​()
      返回启动连接的远程客户端的地址。
      abstract HttpsConfigurator getHttpsConfigurator​()
      返回此HttpsParameters的HttpsConfigurator。
      boolean getNeedClientAuth​()
      返回是否需要客户端身份验证。
      String[] getProtocols​()
      返回协议数组的副本，如果没有设置，则返回null。
      boolean getWantClientAuth​()
      返回是否应请求客户端身份验证。
      void setCipherSuites​(String[] cipherSuites)
      设置密码组数组。
      void setNeedClientAuth​(boolean needClientAuth)
      设置是否需要客户端认证。
      void setProtocols​(String[] protocols)
      设置协议数组。
      abstract void setSSLParameters​(SSLParameters params)
      设置用于此HttpsParameters的SSLParameters。
      void setWantClientAuth​(boolean wantClientAuth)
      设置是否请求客户端身份验证。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpsParameters

        protected HttpsParameters​()

    • 方法详细信息

      • getHttpsConfigurator

        public abstract HttpsConfigurator getHttpsConfigurator​()
        返回此HttpsParameters的HttpsConfigurator。

      • getClientAddress

        public abstract InetSocketAddress getClientAddress​()
        返回启动连接的远程客户端的地址。

      • setSSLParameters

        public abstract void setSSLParameters​(SSLParameters params)
        设置用于此HttpsParameters的SSLParameters。 参数必须由与此HttpsParameters关联的HttpsConfigurator所包含的SSLContext支持。 如果没有设置参数，则默认行为是使用相关联的SSLContext中的默认参数。
        参数
        params - 要设置的SSLParameters。 如果是null则现有参数（如果有）保持不变。
        异常
        IllegalArgumentException - 如果任何参数无效或不受支持。

      • getCipherSuites

        public String[] getCipherSuites​()
        返回密码数组的副本，如果没有设置则返回null。
        结果
        密码组数组的副本，如果没有设置则为null。

      • setCipherSuites

        public void setCipherSuites​(String[] cipherSuites)
        设置密码组数组。
        参数
        cipherSuites - 密码队列（或null）

      • getProtocols

        public String[] getProtocols​()
        返回协议数组的副本，如果没有设置，则返回null。
        结果
        协议数组的副本，如果没有设置，则为null。

      • setProtocols

        public void setProtocols​(String[] protocols)
        设置协议数组。
        参数
        protocols - 协议数组（或null）

      • getWantClientAuth

        public boolean getWantClientAuth​()
        返回是否应请求客户端身份验证。
        结果
        是否应请求客户端身份验证。

      • setWantClientAuth

        public void setWantClientAuth​(boolean wantClientAuth)
        设置是否请求客户端身份验证。 调用此方法可清除needClientAuth标志。
        参数
        wantClientAuth - 是否应请求客户端认证

      • getNeedClientAuth

        public boolean getNeedClientAuth​()
        返回是否需要客户端身份验证。
        结果
        是否需要客户端认证。

      • setNeedClientAuth

        public void setNeedClientAuth​(boolean needClientAuth)
        设置是否需要客户端认证。 调用此方法可清除wantClientAuth标志。
        参数
        needClientAuth - 是否需要客户端认证
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpsServer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver

Class HttpsServer

  • java.lang.Object
    • com.sun.net.httpserver.HttpServer
      • com.sun.net.httpserver.HttpsServer

  • public abstract class HttpsServer
extends HttpServer
    此类是HttpServer的扩展，它为HTTPS提供支持。

    HttpsServer必须具有关联的HttpsConfigurator对象，用于为SSL连接建立SSL配置。

    所有其他配置与HttpServer相同。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | HttpsServer​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static HttpsServer create​()
      创建一个最初没有绑定到任何本地地址/端口的HttpsServer实例。
      static HttpsServer create​(InetSocketAddress addr, int backlog)
      创建一个HttpsServer实例，该实例将绑定到指定的InetSocketAddress （IP地址和端口号）也可以指定最大的积压。
      abstract HttpsConfigurator getHttpsConfigurator​()
      获取此服务器的HttpsConfigurator对象，如果已设置。
      abstract void setHttpsConfigurator​(HttpsConfigurator config)
      设置此服务器的HttpsConfigurator对象。

      • Methods inherited from class com.sun.net.httpserver.HttpServer

        bind, createContext, createContext, getAddress, getExecutor, removeContext, removeContext, setExecutor, start, stop

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpsServer

        protected HttpsServer​()

    • 方法详细信息

      • create

        public static HttpsServer create​()
                          throws IOException
        创建一个最初没有绑定到任何本地地址/端口的HttpsServer实例。 HttpsServer从当前安装的HttpServerProvider获取服务器必须使用HttpServer.bind(InetSocketAddress,int)绑定才能使用。 该服务器还必须有一个HttpsConfigurator建立与setHttpsConfigurator(HttpsConfigurator)
        异常
        IOException

      • create

        public static HttpsServer create​(InetSocketAddress addr,
                                 int backlog)
                          throws IOException
        创建一个将绑定到指定的InetSocketAddress （IP地址和端口号）的HttpsServer实例也可以指定最大的积压。 这是在侦听套接字上允许的排队入站连接的最大数量。 超过此限制的排队TCP连接可能被TCP实现拒绝。 HttpsServer是从当前安装的HttpServerProvider获取的 。服务器必须有一个HttpsConfigurator建立与setHttpsConfigurator(HttpsConfigurator)
        参数
        addr - 要监听的地址，如果是 null那么bind（）必须调用来设置地址
        backlog - 套接字积压。 如果该值小于或等于零，则使用系统默认值。
        异常
        BindException - 如果服务器无法绑定到请求的地址，或者服务器是否已绑定。
        IOException

      • setHttpsConfigurator

        public abstract void setHttpsConfigurator​(HttpsConfigurator config)
        设置此服务器的HttpsConfigurator对象。
        参数
        config - 设置HttpsConfigurator
        异常
        NullPointerException - 如果config为空。

      • getHttpsConfigurator

        public abstract HttpsConfigurator getHttpsConfigurator​()
        获取此服务器的HttpsConfigurator对象（如果已设置）。
        结果
        该服务器的 null如果没有设置， null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.net.httpserver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.net.httpserver

  • Packages that use com.sun.net.httpserver
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
  • Classes in com.sun.net.httpserver used by com.sun.net.httpserver
    Class 描述
    Authenticator
    认证者表示HTTP认证机制的实现。
    Authenticator.Result
    来自authenticate（）方法的返回类型的基类
    Filter
    用于预处理和后处理传入请求的过滤器。
    Filter.Chain
    与HttpServer关联的一连串过滤器。
    Headers
    HTTP请求和响应头通过此类，它实现接口表示Map < String ， List < String >>。
    HttpContext
    HttpContext表示应用程序的根URI路径与一个HttpHandler之间的映射，该对象被调用来处理在相关联的HttpServer或HttpsServer上发往该路径的请求。
    HttpExchange
    此类封装了收到的HTTP请求和在一个交换中生成的响应。
    HttpHandler
    被调用以处理HTTP交换的处理程序。
    HttpPrincipal
    表示通过HTTP Basic或Digest身份验证身份验证的用户。
    HttpsConfigurator
    此类用于配置HttpsServer上每个传入https连接的https参数。
    HttpServer
    这个类实现了一个简单的HTTP服务器。
    HttpsParameters
    表示与客户端协商的每个https连接的参数集。
    HttpsServer
    此类是HttpServer的扩展，它为HTTPS提供支持。
  • Classes in com.sun.net.httpserver used by com.sun.net.httpserver.spi
    Class 描述
    HttpServer
    这个类实现了一个简单的HTTP服务器。
    HttpsServer
    此类是HttpServer的扩展，它为HTTPS提供支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Authenticator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Authenticator

  • Packages that use Authenticator
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of Authenticator in com.sun.net.httpserver

      Subclasses of Authenticator in com.sun.net.httpserver
      Modifier and Type Class 描述
      class  BasicAuthenticator
      BasicAuthenticator提供HTTP Basic认证的实现。
      Methods in com.sun.net.httpserver that return Authenticator
      Modifier and Type 方法 描述
      abstract Authenticator HttpContext.getAuthenticator​()
      返回当前设置的身份验证器（如果存在）。
      abstract Authenticator HttpContext.setAuthenticator​(Authenticator auth)
      设置此HttpContext的Authenticator。
      Methods in com.sun.net.httpserver with parameters of type Authenticator
      Modifier and Type 方法 描述
      abstract Authenticator HttpContext.setAuthenticator​(Authenticator auth)
      设置此HttpContext的Authenticator。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Authenticator.Failure (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Authenticator.Failure

No usage of com.sun.net.httpserver.Authenticator.Failure
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Authenticator.Result (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Authenticator.Result

  • Packages that use Authenticator.Result
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of Authenticator.Result in com.sun.net.httpserver

      Subclasses of Authenticator.Result in com.sun.net.httpserver
      Modifier and Type Class 描述
      static class  Authenticator.Failure
      表示认证失败。
      static class  Authenticator.Retry
      表示验证必须重试。
      static class  Authenticator.Success
      表示认证成功，通过调用getPrincipal（）可以获取已认证的用户主体。
      Methods in com.sun.net.httpserver that return Authenticator.Result
      Modifier and Type | 方法 | 描述
      abstract Authenticator.Result Authenticator.authenticate​(HttpExchange exch)
      被要求验证每个传入的请求。
      Authenticator.Result | BasicAuthenticator.authenticate​(HttpExchange t)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Authenticator.Retry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Authenticator.Retry

No usage of com.sun.net.httpserver.Authenticator.Retry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Authenticator.Success (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Authenticator.Success

No usage of com.sun.net.httpserver.Authenticator.Success
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.BasicAuthenticator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.BasicAuthenticator

No usage of com.sun.net.httpserver.BasicAuthenticator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Filter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Filter

  • Packages that use Filter
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of Filter in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return types with arguments of type Filter
      Modifier and Type 方法 描述
      abstract List<Filter> HttpContext.getFilters​()
      返回此上下文的过滤器列表。
      Constructor parameters in com.sun.net.httpserver with type arguments of type Filter
      Constructor 描述
      Chain​(List<Filter> filters, HttpHandler handler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Filter.Chain (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Filter.Chain

  • Packages that use Filter.Chain
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of Filter.Chain in com.sun.net.httpserver

      Methods in com.sun.net.httpserver with parameters of type Filter.Chain
      Modifier and Type 方法 描述
      abstract void Filter.doFilter​(HttpExchange exchange, Filter.Chain chain)
      要求此过滤器预先/后处理给定的交换。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.Headers (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.Headers

  • Packages that use Headers
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of Headers in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return Headers
      Modifier and Type 方法 描述
      abstract Headers HttpExchange.getRequestHeaders​()
      返回包含此请求中包含的HTTP标头的不可变地图。
      abstract Headers HttpExchange.getResponseHeaders​()
      返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpContext

  • Packages that use HttpContext
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of HttpContext in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpContext
      Modifier and Type 方法 描述
      abstract HttpContext HttpServer.createContext​(String path)
      创建一个HttpContext，而不会最初指定一个处理程序。
      abstract HttpContext HttpServer.createContext​(String path, HttpHandler handler)
      创建一个HttpContext。
      abstract HttpContext HttpExchange.getHttpContext​()
      获取此交换的HttpContext
      Methods in com.sun.net.httpserver with parameters of type HttpContext
      Modifier and Type 方法 描述
      abstract void HttpServer.removeContext​(HttpContext context)
      从服务器中删除给定的上下文。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpExchange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpExchange

  • Packages that use HttpExchange
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of HttpExchange in com.sun.net.httpserver

      Subclasses of HttpExchange in com.sun.net.httpserver
      Modifier and Type Class 描述
      class  HttpsExchange
      此类封装了收到的HTTPS请求和在一个交换中生成的响应，并定义了特定于HTTPS协议的HttpExchange扩展。
      Methods in com.sun.net.httpserver with parameters of type HttpExchange
      Modifier and Type | 方法 | 描述
      abstract Authenticator.Result Authenticator.authenticate​(HttpExchange exch)
      被要求验证每个传入的请求。
      Authenticator.Result | BasicAuthenticator.authenticate​(HttpExchange t)
      void Filter.Chain.doFilter​(HttpExchange exchange)
      调用链中的下一个过滤器，否则用户交换处理程序，如果这是链中的最终过滤器。
      abstract void Filter.doFilter​(HttpExchange exchange, Filter.Chain chain)
      要求此过滤器预先/后处理给定的交换。
      void HttpHandler.handle​(HttpExchange exchange)
      处理给定的请求并产生适当的响应。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpPrincipal

  • Packages that use HttpPrincipal
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of HttpPrincipal in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpPrincipal
      Modifier and Type 方法 描述
      HttpPrincipal Authenticator.Success.getPrincipal​()
      返回经过身份验证的用户主体
      abstract HttpPrincipal HttpExchange.getPrincipal​()
      如果认证被设置在拥有这种交换的HttpContext，则此方法将返回HttpPrincipal ，表示此HttpExchange身份验证的用户。
      Constructors in com.sun.net.httpserver with parameters of type HttpPrincipal
      Constructor 描述
      Success​(HttpPrincipal p)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpsConfigurator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpsConfigurator

  • Packages that use HttpsConfigurator
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of HttpsConfigurator in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpsConfigurator
      Modifier and Type 方法 描述
      abstract HttpsConfigurator HttpsParameters.getHttpsConfigurator​()
      返回此HttpsParameters的HttpsConfigurator。
      abstract HttpsConfigurator HttpsServer.getHttpsConfigurator​()
      获取此服务器的HttpsConfigurator对象，如果已设置。
      Methods in com.sun.net.httpserver with parameters of type HttpsConfigurator
      Modifier and Type 方法 描述
      abstract void HttpsServer.setHttpsConfigurator​(HttpsConfigurator config)
      设置此服务器的HttpsConfigurator对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpServer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpServer

  • Packages that use HttpServer
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。

    • Uses of HttpServer in com.sun.net.httpserver

      Subclasses of HttpServer in com.sun.net.httpserver
      Modifier and Type Class 描述
      class  HttpsServer
      此类是HttpServer的扩展，它为HTTPS提供支持。
      Methods in com.sun.net.httpserver that return HttpServer
      Modifier and Type 方法 描述
      static HttpServer HttpServer.create​()
      创建一个最初没有绑定到任何本地地址/端口的HttpServer实例。
      static HttpServer HttpServer.create​(InetSocketAddress addr, int backlog)
      创建将绑定到指定的InetSocketAddress （IP地址和端口号）的HttpServer实例也可以指定最大积压。
      abstract HttpServer HttpContext.getServer​()
      返回创建该上下文的服务器

    • Uses of HttpServer in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi that return HttpServer
      Modifier and Type 方法 描述
      abstract HttpServer HttpServerProvider.createHttpServer​(InetSocketAddress addr, int backlog)
      creates a HttpServer from this provider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpsExchange (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpsExchange

No usage of com.sun.net.httpserver.HttpsExchange
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpsParameters (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpsParameters

  • Packages that use HttpsParameters
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of HttpsParameters in com.sun.net.httpserver

      Methods in com.sun.net.httpserver with parameters of type HttpsParameters
      Modifier and Type 方法 描述
      void HttpsConfigurator.configure​(HttpsParameters params)
      由HttpsServer调用以配置当前正在建立的https连接的参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.HttpsServer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.HttpsServer

  • Packages that use HttpsServer
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。

    • Uses of HttpsServer in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpsServer
      Modifier and Type 方法 描述
      static HttpsServer HttpsServer.create​()
      创建一个最初没有绑定到任何本地地址/端口的HttpsServer实例。
      static HttpsServer HttpsServer.create​(InetSocketAddress addr, int backlog)
      创建将绑定到指定的InetSocketAddress （IP地址和端口号）的HttpsServer实例也可以指定最大积压。

    • Uses of HttpsServer in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi that return HttpsServer
      Modifier and Type 方法 描述
      abstract HttpsServer HttpServerProvider.createHttpsServer​(InetSocketAddress addr, int backlog)
      从此提供程序创建一个HttpsServer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.net.httpserver.HttpHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.net.httpserver.HttpHandler

  • Packages that use HttpHandler
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

    • Uses of HttpHandler in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpHandler
      Modifier and Type 方法 描述
      abstract HttpHandler HttpContext.getHandler​()
      返回此上下文的处理程序
      Methods in com.sun.net.httpserver with parameters of type HttpHandler
      Modifier and Type 方法 描述
      abstract HttpContext HttpServer.createContext​(String path, HttpHandler handler)
      创建一个HttpContext。
      abstract void HttpContext.setHandler​(HttpHandler h)
      设置此上下文的处理程序（如果尚未设置）。
      Constructors in com.sun.net.httpserver with parameters of type HttpHandler
      Constructor 描述
      Chain​(List<Filter> filters, HttpHandler handler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.net.httpserver.spi (Java SE 9 & JDK 9 )

com.sun.net.httpserver.spi

Classes

  • HttpServerProvider


com.sun.net.httpserver.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.httpserver

Package com.sun.net.httpserver.spi

提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
  • 类摘要
    Class 描述
    HttpServerProvider
    HttpServer的服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.net.httpserver.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.net.httpserver.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.net.httpserver.spi.HttpServerProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


HttpServerProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.httpserver
软件包 com.sun.net.httpserver.spi

Class HttpServerProvider

  • java.lang.Object
    • com.sun.net.httpserver.spi.HttpServerProvider

  • public abstract class HttpServerProvider
extends Object
    HttpServer的服务提供者类。 HttpServerProvider的子类提供了一个HttpServer和相关类的实现。 应用程序通常不会使用此类。 有关如何查找和加载提供程序，请参阅provider() 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected HttpServerProvider​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract HttpServer createHttpServer​(InetSocketAddress addr, int backlog)
      从此提供程序创建一个HttpServer
      abstract HttpsServer createHttpsServer​(InetSocketAddress addr, int backlog)
      从此提供程序创建一个HttpsServer
      static HttpServerProvider provider​()
      返回用于Java虚拟机的此调用的系统范围默认的HttpServerProvider。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpServerProvider

        protected HttpServerProvider​()
        初始化此类的新实例。
        异常
        SecurityException - 如果安全管理员已经安装并且它拒绝RuntimePermission ("httpServerProvider")

    • 方法详细信息

      • createHttpServer

        public abstract HttpServer createHttpServer​(InetSocketAddress addr,
                                            int backlog)
                                     throws IOException
        从此提供程序创建一个HttpServer
        参数
        addr - 要绑定的地址。 可能是null
        backlog - 套接字积压。 值为zero表示系统默认值
        异常
        IOException

      • createHttpsServer

        public abstract HttpsServer createHttpsServer​(InetSocketAddress addr,
                                              int backlog)
                                       throws IOException
        从此提供程序创建一个HttpsServer
        参数
        addr - 要绑定的地址。 可能是null
        backlog - 套接字积压。 值为zero表示系统默认值
        异常
        IOException

      • provider

        public static HttpServerProvider provider​()
        返回用于Java虚拟机的此调用的系统范围默认的HttpServerProvider。

        此方法的第一次调用将定位默认提供程序对象，如下所示：

        1. 如果定义了系统属性com.sun.net.httpserver.HttpServerProvider ，则将其视为具体提供程序类的完全限定名称。 该类被加载和实例化; 如果此过程失败，则抛出未指定的未检查的错误或异常。

        2. 如果提供程序类已安装在系统类加载器可见的jar文件中，并且该jar文件在资源目录META-INF/services包含名为com.sun.net.httpserver.HttpServerProvider的提供程序配置文件，则将在该文件中指定第一个类名。 该类被加载和实例化; 如果此过程失败，则抛出未指定的未检查的错误或异常。

        3. 最后，如果没有通过上述任何一种方式指定提供程序，那么系统默认提供程序类将被实例化，并返回结果。

        此方法的后续调用返回由第一次调用返回的提供程序。

        结果
        系统默认的HttpServerProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.net.httpserver.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.net.httpserver.spi

  • Packages that use com.sun.net.httpserver.spi
    软件包 描述
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
  • Classes in com.sun.net.httpserver.spi used by com.sun.net.httpserver.spi
    Class 描述
    HttpServerProvider
    HttpServer的服务提供者类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.net.httpserver.spi.HttpServerProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.net.httpserver.spi.HttpServerProvider

  • Packages that use HttpServerProvider
    软件包 描述
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。

    • Uses of HttpServerProvider in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi that return HttpServerProvider
      Modifier and Type 方法 描述
      static HttpServerProvider HttpServerProvider.provider​()
      返回用于Java虚拟机的此调用的系统范围默认的HttpServerProvider。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AbstractNotificationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class AbstractNotificationHandler<T>

  • java.lang.Object
    • com.sun.nio.sctp.AbstractNotificationHandler<T>
  • All Implemented Interfaces:
    NotificationHandler<T>

    public class AbstractNotificationHandler<T>
extends Object
implements NotificationHandler<T>
    消耗通知并继续的骨架处理程序。

    该类handleNotification实现handleNotification方法以返回CONTINUE，以便消耗所有通知，并且通道继续尝试并接收消息。

    它还提供的重载版本handleNotification方法，一种为每个所需的支持通知类型， AssociationChangeNotification ， PeerAddressChangeNotification ， SendFailedNotification ，和ShutdownNotification 。 收到通知后，将调用适当的方法。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AbstractNotificationHandler​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      HandlerResult handleNotification​(AssociationChangeNotification notification, T attachment)
      当从SCTP堆栈接收到AssociationChangeNotification时调用。
      HandlerResult handleNotification​(Notification notification, T attachment)
      当从SCTP堆栈接收到实现特定通知时调用。
      HandlerResult handleNotification​(PeerAddressChangeNotification notification, T attachment)
      当从SCTP堆栈接收到PeerAddressChangeNotification时调用。
      HandlerResult handleNotification​(SendFailedNotification notification, T attachment)
      从SCTP堆栈接收到SendFailedNotification时调用。
      HandlerResult handleNotification​(ShutdownNotification notification, T attachment)
      从SCTP堆栈接收到ShutdownNotification时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractNotificationHandler

        protected AbstractNotificationHandler​()
        初始化此类的新实例。

    • 方法详细信息

      • handleNotification

        public HandlerResult handleNotification​(Notification notification,
                                        T attachment)
        当从SCTP堆栈接收到实现特定通知时调用。
        Specified by:
        handleNotification在接口 NotificationHandler<T>
        参数
        notification - 通知
        attachment - 启动时附加到 receive操作的对象。
        结果
        处理程序结果

      • handleNotification

        public HandlerResult handleNotification​(AssociationChangeNotification notification,
                                        T attachment)
        当从SCTP堆栈接收到AssociationChangeNotification时调用。
        参数
        notification - 通知
        attachment - 启动时附加到 receive操作的对象。
        结果
        处理程序结果

      • handleNotification

        public HandlerResult handleNotification​(PeerAddressChangeNotification notification,
                                        T attachment)
        从SCTP堆栈接收到PeerAddressChangeNotification时调用。
        参数
        notification - 通知
        attachment - 启动时附加到 receive操作的对象。
        结果
        处理程序结果

      • handleNotification

        public HandlerResult handleNotification​(SendFailedNotification notification,
                                        T attachment)
        当从SCTP堆栈接收到SendFailedNotification时调用。
        参数
        notification - 通知
        attachment - 在启动时附加到 receive操作的对象。
        结果
        处理程序结果

      • handleNotification

        public HandlerResult handleNotification​(ShutdownNotification notification,
                                        T attachment)
        当从SCTP堆栈接收到ShutdownNotification时调用。
        参数
        notification - 通知
        attachment - 启动时附加到 receive操作的对象。
        结果
        The handler result
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Association (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class Association

  • java.lang.Object
    • com.sun.nio.sctp.Association

  • public class Association
extends Object
    表示SCTP关联的类。

    两个SCTP端点之间存在关联。 每个端点由传输地址列表表示，通过该列表可以到达该端点，并从中发起SCTP消息。 该关联跨越可能从每个端点的地址列表生成的所有可能的源/目的地组合。

    协会通过其关联ID进行标识。 协会ID在协会的生命周期中保证是唯一的。 关联ID可以在关联关闭后重新使用。 关联ID在多个SCTP通道中不是唯一的。 如果SCTP实现支持动态地址重新配置所界定的关联的本地和远程地址可能会改变RFC5061 ，看到bindAddress种unbindAddress的方法SctpChannel ， SctpServerChannel ，并SctpMultiChannel 。

    从SctpChannel或Association返回一个Association ，并将其作为NotificationHandler方法的参数。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Association​(int associationID, int maxInStreams, int maxOutStreams)
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int associationID​()
      返回关联ID。
      int maxInboundStreams​()
      返回此关联支持的入站流的最大数量。
      int maxOutboundStreams​()
      返回此关联支持的最大出站流数。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Association

        protected Association​(int associationID,
                      int maxInStreams,
                      int maxOutStreams)
        初始化此类的新实例。
        参数
        associationID - 关联ID
        maxInStreams - 入站流的最大数量
        maxOutStreams - 出站流的最大数量

    • 方法详细信息

      • associationID

        public final int associationID​()
        返回关联ID。
        结果
        关联ID

      • maxInboundStreams

        public final int maxInboundStreams​()
        返回此关联支持的入站流的最大数量。

        在此关联中收到的数据将在流数s ，其中0 <= s < maxInboundStreams() 。

        结果
        入站流的最大数量

      • maxOutboundStreams

        public final int maxOutboundStreams​()
        返回此关联支持的最大出站流数。

        在此关联上发送的数据必须在流数s ，其中0 <= s < maxOutboundStreams() 。

        结果
        出站流的最大数量
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AssociationChangeNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class AssociationChangeNotification

  • java.lang.Object
    • com.sun.nio.sctp.AssociationChangeNotification
  • All Implemented Interfaces:
    Notification

    public abstract class AssociationChangeNotification
extends Object
implements Notification
    关联已打开或关闭时发出的通知。
    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  AssociationChangeNotification.AssocChangeEvent
      定义关联发生的变更事件的类型。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AssociationChangeNotification​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Association association​()
      返回此通知适用的关联。
      abstract AssociationChangeNotification.AssocChangeEvent event​()
      返回更改事件的类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AssociationChangeNotification

        protected AssociationChangeNotification​()
        初始化此类的新实例。

    • 方法详细信息

      • association

        public abstract Association association​()
        返回此通知适用的关联。
        Specified by:
        association在接口 Notification
        结果
        该协会，其状态已经改变，或者 null如果没有关联，这是 CANT_START

      • event

        public abstract AssociationChangeNotification.AssocChangeEvent event​()
        返回更改事件的类型。
        结果
        The event
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AssociationChangeNotification.AssocChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Enum AssociationChangeNotification.AssocChangeEvent

  • java.lang.Object
    • java.lang.Enum<AssociationChangeNotification.AssocChangeEvent>
      • com.sun.nio.sctp.AssociationChangeNotification.AssocChangeEvent
  • All Implemented Interfaces:
    Serializable ， Comparable<AssociationChangeNotification.AssocChangeEvent>
    Enclosing class:
    AssociationChangeNotification

    public static enum AssociationChangeNotification.AssocChangeEvent
extends Enum<AssociationChangeNotification.AssocChangeEvent>
    定义关联发生的变更事件的类型。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CANT_START
      协会无法设置。
      COMM_LOST
      协会失败了。
      COMM_UP
      一个新的关联现在已经准备就绪，数据可以与该对等体进行交换。
      RESTART
      SCTP检测到对等体重新启动。
      SHUTDOWN
      该协会已优雅关闭。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AssociationChangeNotification.AssocChangeEvent valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AssociationChangeNotification.AssocChangeEvent[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COMM_UP

        public static final AssociationChangeNotification.AssocChangeEvent COMM_UP
        一个新的关联现在已经准备就绪，数据可以与该对等体进行交换。

      • COMM_LOST

        public static final AssociationChangeNotification.AssocChangeEvent COMM_LOST
        协会失败了。 一系列SCTP发送失败通知将遵循此通知，每个未完成的消息一个。

      • RESTART

        public static final AssociationChangeNotification.AssocChangeEvent RESTART
        SCTP检测到对等体重新启动。

      • SHUTDOWN

        public static final AssociationChangeNotification.AssocChangeEvent SHUTDOWN
        该协会已优雅关闭。

      • CANT_START

        public static final AssociationChangeNotification.AssocChangeEvent CANT_START
        协会无法设置。 如果在非阻塞模式下发送了SctpMultiChannel的消息，则SCTP发送失败的通知将按照该通知发送未完成的消息。

    • 方法详细信息

      • values

        public static AssociationChangeNotification.AssocChangeEvent[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AssociationChangeNotification.AssocChangeEvent c : AssociationChangeNotification.AssocChangeEvent.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AssociationChangeNotification.AssocChangeEvent valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


com.sun.nio.sctp (Java SE 9 & JDK 9 )

com.sun.nio.sctp

Interfaces

  • Notification
  • NotificationHandler
  • SctpSocketOption

Classes

  • AbstractNotificationHandler
  • Association
  • AssociationChangeNotification
  • MessageInfo
  • PeerAddressChangeNotification
  • SctpChannel
  • SctpMultiChannel
  • SctpServerChannel
  • SctpStandardSocketOptions
  • SctpStandardSocketOptions.InitMaxStreams
  • SendFailedNotification
  • ShutdownNotification

Enums

  • AssociationChangeNotification.AssocChangeEvent
  • HandlerResult
  • PeerAddressChangeNotification.AddressChangeEvent

Exceptions

  • IllegalReceiveException
  • IllegalUnbindException
  • InvalidStreamException


com.sun.nio.sctp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.sctp

Package com.sun.nio.sctp

用于流控制传输协议的Java API。

流控制传输协议（SCTP）是与UDP（用户数据报协议）和TCP（传输控制协议）等价地存在的可靠的面向消息的传输协议。 SCTP是面向会话的，并且必须在发送任何数据之前建立端点之间的关联。

SCTP直接支持多归属，比端点可以表示多于一个地址，每个地址可用于发送和接收数据，从而提供网络冗余。 两个端点之间的连接被称为这些端点之间的关联。 端点可以在关联设置期间交换地址列表。 一个地址被指定为主地址，这是对端将用于发送数据的默认地址。 在特定会话的端点的整个地址列表中使用单个端口号。

SCTP是基于消息的。 I / O操作对消息进行操作，并保留消息边界。 每个关联可以支持多个独立逻辑流。 每个流表示单个关联中的消息序列，并且流彼此独立，这意味着流标识符和序列号被包括在数据分组中以允许每个流的消息排序。

该包提供了两种编程模型样式。 SctpChannel和SctpServerChannel支持的一对一样式，以及由SctpMultiChannel支持的一对多样式。 一对一风格界面的语义与TCP非常相似。 一个SctpChannel只能控制一个SCTP关联。 一对多样式界面的语义与UDP非常相似。 一个SctpMutliChannel可以控制多个SCTP关联。

应用程序可以通过MessageInfo发送和接收每消息的辅助信息。 例如，要发送或接收的消息的流号。 SCTP堆栈是事件驱动的，应用程序可以通过调用适当的notification handler的SCTP通道的receive方法来接收某些SCTP事件的通知。

SCTP协议由RFC4960定义， 动态地址重配置的可选扩展由RFC5061定义。

从以下版本开始：
1.7
  • 接口摘要
    接口 描述
    Notification
    来自SCTP堆栈的通知。
    NotificationHandler<T>
    用于从SCTP堆栈中消费通知的处理程序。
    SctpSocketOption<T>
    与SCTP通道相关联的插座选项。
  • 类摘要
    Class 描述
    AbstractNotificationHandler<T>
    消耗通知并继续的骨架处理程序。
    Association
    表示SCTP关联的类。
    AssociationChangeNotification
    关联已打开或关闭时发出的通知。
    MessageInfo
    MessageInfo课程提供了有关消息的其他辅助信息。
    PeerAddressChangeNotification
    多宿主对等体上的目标地址发生更改时发出的通知。
    SctpChannel
    用于面向消息的连接SCTP套接字的可选通道。
    SctpMultiChannel
    用于面向消息的SCTP套接字的可选通道。
    SctpServerChannel
    用于面向消息的侦听SCTP插座的可选通道。
    SctpStandardSocketOptions
    SCTP通道支持此类定义的套接字选项（以及特定通道类中列出的套接字选项），并且可以支持额外的实现特定套接字选项。
    SctpStandardSocketOptions.InitMaxStreams
    此类用于设置关联初始化期间本地端点使用的入站/出站流的最大数量。
    SendFailedNotification
    收到发送失败通知时发出的通知。
    ShutdownNotification
    当对等体关闭关联时发出的通知。
  • 枚举摘要
    Enum 描述
    AssociationChangeNotification.AssocChangeEvent
    定义关联发生的变更事件的类型。
    HandlerResult
    定义通知处理程序结果。
    PeerAddressChangeNotification.AddressChangeEvent
    定义在多宿主对等体遇到更改接口详细信息时发生到目标地址的地址更改事件的类型。
  • 异常摘要
    异常 描述
    IllegalReceiveException
    当试图调用未经检查的异常receive的方法SctpChannel或SctpMultiChannel从通知处理程序。
    IllegalUnbindException
    尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。
    InvalidStreamException
    尝试将消息发送到无效流时抛出未检查的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.nio.sctp Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.nio.sctp

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
          • com.sun.nio.sctp.SctpChannel
          • com.sun.nio.sctp.SctpMultiChannel
          • com.sun.nio.sctp.SctpServerChannel
    • com.sun.nio.sctp.AbstractNotificationHandler<T> (implements com.sun.nio.sctp.NotificationHandler<T>)
    • com.sun.nio.sctp.Association
    • com.sun.nio.sctp.AssociationChangeNotification (implements com.sun.nio.sctp.Notification)
    • com.sun.nio.sctp.MessageInfo
    • com.sun.nio.sctp.PeerAddressChangeNotification (implements com.sun.nio.sctp.Notification)
    • com.sun.nio.sctp.SctpStandardSocketOptions
    • com.sun.nio.sctp.SctpStandardSocketOptions.InitMaxStreams
    • com.sun.nio.sctp.SendFailedNotification (implements com.sun.nio.sctp.Notification)
    • com.sun.nio.sctp.ShutdownNotification (implements com.sun.nio.sctp.Notification)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • com.sun.nio.sctp.InvalidStreamException
          • java.lang.IllegalStateException
            • com.sun.nio.sctp.IllegalReceiveException
            • com.sun.nio.sctp.IllegalUnbindException

Interface Hierarchy

  • com.sun.nio.sctp.Notification
  • com.sun.nio.sctp.NotificationHandler<T>
  • java.net.SocketOption<T>
    • com.sun.nio.sctp.SctpSocketOption<T>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.nio.sctp.AssociationChangeNotification.AssocChangeEvent
      • com.sun.nio.sctp.HandlerResult
      • com.sun.nio.sctp.PeerAddressChangeNotification.AddressChangeEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


HandlerResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Enum HandlerResult

  • java.lang.Object
    • java.lang.Enum<HandlerResult>
      • com.sun.nio.sctp.HandlerResult
  • All Implemented Interfaces:
    Serializable ， Comparable<HandlerResult>

    public enum HandlerResult
extends Enum<HandlerResult>
    定义通知处理程序结果。

    HandlerResult用于在处理来自SCTP堆栈的通知后确定通道的行为。 本质上它的值决定了频道是否应该在返回之前尝试接收另一个通知或消息。

    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONTINUE
      尝试接收另一个消息或通知。
      RETURN
      返回而不尝试再接收任何数据。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static HandlerResult valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HandlerResult[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONTINUE

        public static final HandlerResult CONTINUE
        尝试接收另一个消息或通知。

      • RETURN

        public static final HandlerResult RETURN
        返回而不尝试再接收任何数据。

    • 方法详细信息

      • values

        public static HandlerResult[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (HandlerResult c : HandlerResult.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static HandlerResult valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


IllegalReceiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class IllegalReceiveException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • com.sun.nio.sctp.IllegalReceiveException
  • All Implemented Interfaces:
    Serializable

    public class IllegalReceiveException
extends IllegalStateException
    尝试从通知处理程序调用SctpChannel或SctpMultiChannel的receive方法时抛出未经检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalReceiveException​()
      构造这个类的一个实例。
      IllegalReceiveException​(String msg)
      使用指定的消息构造此类的实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalReceiveException

        public IllegalReceiveException​()
        构造这个类的一个实例。

      • IllegalReceiveException

        public IllegalReceiveException​(String msg)
        使用指定的消息构造此类的实例。
        参数
        msg - 包含详细消息的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalUnbindException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class IllegalUnbindException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • com.sun.nio.sctp.IllegalUnbindException
  • All Implemented Interfaces:
    Serializable

    public class IllegalUnbindException
extends IllegalStateException
    尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalUnbindException​()
      构造这个类的一个实例。
      IllegalUnbindException​(String msg)
      使用指定的详细消息构造此类的实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalUnbindException

        public IllegalUnbindException​()
        构造这个类的一个实例。

      • IllegalUnbindException

        public IllegalUnbindException​(String msg)
        使用指定的详细消息构造此类的实例。
        参数
        msg - 包含详细消息的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidStreamException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class InvalidStreamException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • com.sun.nio.sctp.InvalidStreamException
  • All Implemented Interfaces:
    Serializable

    public class InvalidStreamException
extends IllegalArgumentException
    尝试将消息发送到无效流时抛出未检查的异常。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidStreamException​()
      构造这个类的一个实例。
      InvalidStreamException​(String msg)
      使用指定的详细消息构造此类的实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidStreamException

        public InvalidStreamException​()
        构造这个类的一个实例。

      • InvalidStreamException

        public InvalidStreamException​(String msg)
        使用指定的详细消息构造此类的实例。
        参数
        msg - 包含详细消息的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MessageInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class MessageInfo

  • java.lang.Object
    • com.sun.nio.sctp.MessageInfo

  • public abstract class MessageInfo
extends Object
    MessageInfo类提供有关消息的附加辅助信息。

    收到由SctpChannel.receive和SctpMultiChannel.receive返回的SCTP消息，返回一个可以查询的MessageInfo实例，以确定有关接收到的消息的辅助信息。 消息发送应使用的一个createOutgoing种方法来为所述消息提供辅助数据被发送，并且可以使用适当的设置方法来覆盖所规定的默认值unordered ， timeToLive ， complete和payloadProtocolID ，在发送消息之前。

    对于外出消息， timeToLive参数是发送端SCTP堆栈如果尚未发送，则可能会过期消息的时间段。 该时间段是堆栈的指示，在时间段到期之后不再需要发送消息。 它不是硬超时，可能会受到关联支持部分可靠性扩展的影响， RFC 3758 。

    MessageInfo实例不能安全使用多个并发线程。 如果MessageInfo要由多个线程使用，则应通过适当的同步来控制对MessageInfo的访问。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected MessageInfo​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract SocketAddress address​()
      如果接收到消息，则返回源套接字地址，否则将发送消息的首选目标。
      abstract Association association​()
      返回消息被接收的关联，如果已经接收到消息，否则将发送该消息的关联。
      abstract int bytes​()
      返回接收到的消息读取的字节数。
      abstract MessageInfo complete​(boolean complete)
      设置消息是否完成。
      static MessageInfo createOutgoing​(Association association, SocketAddress address, int streamNumber)
      创建一个适用于向给定关联发送消息时使用的 MessageInfo实例。
      static MessageInfo createOutgoing​(SocketAddress address, int streamNumber)
      创建一个适合在发送消息时使用的 MessageInfo实例。
      abstract boolean isComplete​()
      告知邮件是否完整。
      abstract boolean isUnordered​()
      告知邮件是否无序。
      abstract int payloadProtocolID​()
      返回有效负载协议标识符。
      abstract MessageInfo payloadProtocolID​(int ppid)
      设置有效载荷协议标识符。
      abstract int streamNumber​()
      如果已经接收到消息，则返回接收到消息的流号，否则返回该消息要发送的流号。
      abstract MessageInfo streamNumber​(int streamNumber)
      设置要发送消息的流号。
      abstract long timeToLive​()
      如果尚未发送消息，发送端可能会过期的时间段，或 0表示不会发生超时的时间段。
      abstract MessageInfo timeToLive​(long millis)
      设置发送方如果尚未发送消息的时间段。
      abstract MessageInfo unordered​(boolean unordered)
      设置消息是否无序。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MessageInfo

        protected MessageInfo​()
        初始化此类的新实例。

    • 方法详细信息

      • createOutgoing

        public static MessageInfo createOutgoing​(SocketAddress address,
                                         int streamNumber)
        创建一个适合在发送消息时使用的MessageInfo实例。

        返回的实例将其unordered值设置为false ，其timeToLive设置为0 ，其complete值设置为true ，其payloadProtocolID设置为0 。 如果需要，可以在发送消息之前通过适当的setter方法设置这些值。

        参数
        address - 对于连接的SctpChannel ，地址是发送消息的关联的首选对等体地址，或null使用对等主地址。 对于SctpMultiChannel该地址用于确定关联，或者如果该地址的对等体没有关联，则设置一个。
        streamNumber - 要发送消息的流号
        结果
        传出的消息信息
        异常
        IllegalArgumentException - 如果streamNumber为负数或大于 65536

      • createOutgoing

        public static MessageInfo createOutgoing​(Association association,
                                         SocketAddress address,
                                         int streamNumber)
        创建一个适用于向给定关联发送消息时使用的MessageInfo实例。 通常用于SctpMultiChannel当一个关联已经被设置。

        返回的实例将其unordered设置为false ，其timeToLive设置为0 ，其complete设置为true ，其payloadProtocolID值设置为0 。 如果需要，可以在发送消息之前通过适当的setter方法设置这些值。

        参数
        association - 发送消息的关联
        address - 发送消息的关联的首选对等体地址，或 null使用对等主地址
        streamNumber - 要发送消息的流号。
        结果
        传出的消息信息
        异常
        IllegalArgumentException - 如果 association为 null ，或streamNumber为负数或大于 65536

      • address

        public abstract SocketAddress address​()
        如果接收到消息，则返回源套接字地址，否则将发送消息的首选目标。
        结果
        套接字地址，或 null如果此实例用于发送消息，并且已经被构造而没有指定首选目的地址

      • association

        public abstract Association association​()
        返回消息被接收的关联，如果已经接收到消息，否则将发送该消息的关联。
        结果
        该关联，或 null如果此实例用于发送消息，并已使用 createOutgoing(SocketAddress,int)静态工厂方法

      • bytes

        public abstract int bytes​()
        返回接收到的消息读取的字节数。

        这种方法只适用于接收到的消息，对发送消息没有意义。

        结果
        的字节数读， -1 ，如果信道是SctpChannel已经到达结束流，否则0

      • isComplete

        public abstract boolean isComplete​()
        告知邮件是否完整。

        对于接收到的消息， true表示消息已被完全接收。 对于消息发送true指示该消息是完整的， false表示该消息是不完整的。 发送通道如何解释此值取决于其SCTP_EXPLICIT_COMPLETE套接字选项的值。

        结果
        true如果，且仅当消息完成

      • complete

        public abstract MessageInfo complete​(boolean complete)
        设置消息是否完成。

        对于消息发送true指示该消息是完整的， false表示该消息是不完整的。 发送通道如何解释此值取决于其SCTP_EXPLICIT_COMPLETE套接字选项的值。

        参数
        complete - true如果且仅当该消息完成
        结果
        这个MessageInfo
        另请参见：
        isComplete()

      • isUnordered

        public abstract boolean isUnordered​()
        告知邮件是否无序。 对于接收到的消息， true指示消息true发送。 对于正在发送的消息， true请求消息的无序传送， false表示消息已订购。
        结果
        true如果邮件无序，否则为 false

      • unordered

        public abstract MessageInfo unordered​(boolean unordered)
        设置消息是否无序。
        参数
        unordered - true请求消息的无序传送， false表示消息已订购。
        结果
        这个MessageInfo
        另请参见：
        isUnordered()

      • payloadProtocolID

        public abstract int payloadProtocolID​()
        返回有效负载协议标识符。

        指示正在发送/接收的有效载荷协议数据的类型的值。 该值作为不透明数据由SCTP传递。 0指示未指定的有效载荷协议标识符。

        结果
        有效载荷协议标识符

      • payloadProtocolID

        public abstract MessageInfo payloadProtocolID​(int ppid)
        设置有效载荷协议标识符。

        指示正在发送的有效载荷协议数据的类型的值。 该值作为不透明数据由SCTP传递。

        参数
        ppid - 有效负载协议标识符，或 0表示未指定的有效负载协议标识符。
        结果
        这个MessageInfo
        另请参见：
        payloadProtocolID()

      • streamNumber

        public abstract int streamNumber​()
        如果已经接收到消息，则返回接收到消息的流号，否则返回该消息要发送的流号。
        结果
        流号码

      • streamNumber

        public abstract MessageInfo streamNumber​(int streamNumber)
        设置要发送消息的流号。
        参数
        streamNumber - 流号码
        结果
        这个MessageInfo
        异常
        IllegalArgumentException - 如果streamNumber为负数或大于 65536

      • timeToLive

        public abstract long timeToLive​()
        如果尚未发送消息，发送方可能会过期的时间段，或0表示不会发生超时。 该值仅适用于正在发送的消息，对接收到的消息没有意义。
        结果
        时间段（以毫秒为单位），或 0

      • timeToLive

        public abstract MessageInfo timeToLive​(long millis)
        设置发送方如果尚未发送消息的时间段。
        参数
        millis - 以毫秒为单位的时间段，或 0表示不应发生超时的时间段
        结果
        这个MessageInfo
        另请参见：
        timeToLive()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Notification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Interface Notification

  • 所有已知实现类：
    AssociationChangeNotification ， PeerAddressChangeNotification ， SendFailedNotification ， ShutdownNotification

    public interface Notification
    来自SCTP堆栈的通知。

    当收到通知时，此类型的对象将传递给NotificationHandler 。

    的SCTP通道支持下列通知： AssociationChangeNotification ， PeerAddressChangeNotification ， SendFailedNotification ， ShutdownNotification ，并且可以支持额外的实施特定的通知。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Association association​()
      返回此通知适用的关联。

    • 方法详细信息

      • association

        Association association​()
        返回此通知适用的关联。
        结果
        该协会
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NotificationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Interface NotificationHandler<T>

  • 所有已知实现类：
    AbstractNotificationHandler

    public interface NotificationHandler<T>
    用于从SCTP堆栈中消费通知的处理程序。

    此包中定义的SCTP通道允许指定通知处理程序以消耗来自SCTP堆栈的通知。 当收到通知时，调用处理程序的handleNotification方法来处理该通知。

    另外，附件对象可以附加到receive操作，以便在消费通知时提供上下文。 对于无状态 NotificationHandler用于消耗许多receive操作的结果的情况，附件很重要。

    鼓励处理程序实现扩展实现此接口的AbstractNotificationHandler类，并提供通知具体方法。 然而，API通常应该使用这个处理程序接口作为参数，返回类型等的类型，而不是抽象类。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      HandlerResult handleNotification​(Notification notification, T attachment)
      从SCTP堆栈收到通知时调用。

    • 方法详细信息

      • handleNotification

        HandlerResult handleNotification​(Notification notification,
                                 T attachment)
        从SCTP堆栈收到通知时调用。
        参数
        notification - 通知
        attachment - 启动时附加到接收操作的对象。
        结果
        处理程序结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PeerAddressChangeNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class PeerAddressChangeNotification

  • java.lang.Object
    • com.sun.nio.sctp.PeerAddressChangeNotification
  • All Implemented Interfaces:
    Notification

    public abstract class PeerAddressChangeNotification
extends Object
implements Notification
    多宿主对等体上的目标地址发生更改时发出的通知。
    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PeerAddressChangeNotification.AddressChangeEvent
      定义在多宿主对等体遇到更改接口详细信息时发生到目标地址的地址更改事件的类型。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected PeerAddressChangeNotification​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract SocketAddress address​()
      返回对等地址。
      abstract Association association​()
      返回此通知适用的关联。
      abstract PeerAddressChangeNotification.AddressChangeEvent event​()
      返回更改事件的类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PeerAddressChangeNotification

        protected PeerAddressChangeNotification​()
        初始化此类的新实例。

    • 方法详细信息

      • address

        public abstract SocketAddress address​()
        返回对等地址。
        结果
        对等地址

      • association

        public abstract Association association​()
        返回此通知适用的关联。
        Specified by:
        association在接口 Notification
        结果
        对方地址改变的关联

      • event

        public abstract PeerAddressChangeNotification.AddressChangeEvent event​()
        返回更改事件的类型。
        结果
        事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PeerAddressChangeNotification.AddressChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Enum PeerAddressChangeNotification.AddressChangeEvent

  • java.lang.Object
    • java.lang.Enum<PeerAddressChangeNotification.AddressChangeEvent>
      • com.sun.nio.sctp.PeerAddressChangeNotification.AddressChangeEvent
  • All Implemented Interfaces:
    Serializable ， Comparable<PeerAddressChangeNotification.AddressChangeEvent>
    Enclosing class:
    PeerAddressChangeNotification

    public static enum PeerAddressChangeNotification.AddressChangeEvent
extends Enum<PeerAddressChangeNotification.AddressChangeEvent>
    定义在多宿主对等体遇到更改接口详细信息时发生到目标地址的地址更改事件的类型。

    这些事件类型才会产生的关联时支持动态地址重新配置，比如SCTP_ADDR_ADDED ， SCTP_ADDR_REMOVED ，等等。

    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ADDR_ADDED
      该地址现在是协会的一部分。
      ADDR_AVAILABLE
      此地址现在可达。
      ADDR_CONFIRMED
      此地址现已确认为有效地址。
      ADDR_MADE_PRIMARY
      这个地址现在已经成为主要的目的地址。
      ADDR_REMOVED
      地址不再是协会的一部分。
      ADDR_UNREACHABLE
      指定的地址无法再达到。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PeerAddressChangeNotification.AddressChangeEvent valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PeerAddressChangeNotification.AddressChangeEvent[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ADDR_AVAILABLE

        public static final PeerAddressChangeNotification.AddressChangeEvent ADDR_AVAILABLE
        此地址现在可达。

      • ADDR_UNREACHABLE

        public static final PeerAddressChangeNotification.AddressChangeEvent ADDR_UNREACHABLE
        指定的地址无法再达到。 发送到该地址的任何数据将被重新路由到备用地址，直到该地址可达。

      • ADDR_REMOVED

        public static final PeerAddressChangeNotification.AddressChangeEvent ADDR_REMOVED
        地址不再是协会的一部分。

      • ADDR_ADDED

        public static final PeerAddressChangeNotification.AddressChangeEvent ADDR_ADDED
        该地址现在是协会的一部分。

      • ADDR_MADE_PRIMARY

        public static final PeerAddressChangeNotification.AddressChangeEvent ADDR_MADE_PRIMARY
        这个地址现在已经成为主要的目的地址。

      • ADDR_CONFIRMED

        public static final PeerAddressChangeNotification.AddressChangeEvent ADDR_CONFIRMED
        此地址现已确认为有效地址。

    • 方法详细信息

      • values

        public static PeerAddressChangeNotification.AddressChangeEvent[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (PeerAddressChangeNotification.AddressChangeEvent c : PeerAddressChangeNotification.AddressChangeEvent.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static PeerAddressChangeNotification.AddressChangeEvent valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


SctpChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class SctpChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • com.sun.nio.sctp.SctpChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel

    public abstract class SctpChannel
extends AbstractSelectableChannel
    用于面向消息的连接SCTP套接字的可选通道。

    SCTP通道只能控制一个SCTP关联。 一个SCTPChannel被调用的一个创造open种这个类的方法。 新创建的通道已打开但尚未连接，即与远程对等体没有关联设置。 尝试在未连接的通道上调用I / O操作将导致抛出NotYetConnectedException 。 可以通过使用其connect方法之一连接通道来设置关联。 一旦连接，通道保持连接，直到它被关闭。 通道是否连接可以通过调用getRemoteAddresses来确定。

    SCTP通道支持非阻塞连接：可以创建一个通道，并且可以通过connect方法启动建立到远程套接字的链接的过程，以便稍后通过finishConnect方法完成。 可以通过调用isConnectionPending方法来确定连接操作是否正在进行。

    套接字选项使用setOption方法进行配置。 SCTP通道支持以下选项：

    Socket options
    Option Name | 描述
    SCTP_DISABLE_FRAGMENTS | Enables or disables message fragmentation
    SCTP_EXPLICIT_COMPLETE | Enables or disables explicit message completion
    SCTP_FRAGMENT_INTERLEAVE | Controls how the presentation of messages occur for the message receiver
    SCTP_INIT_MAXSTREAMS | The maximum number of streams requested by the local endpoint during association initialization
    SCTP_NODELAY | Enables or disable a Nagle-like algorithm
    SCTP_PRIMARY_ADDR | Requests that the local SCTP stack use the given peer address as the association primary
    SCTP_SET_PEER_PRIMARY_ADDR | Requests that the peer mark the enclosed address as the association primary
    SO_SNDBUF | The size of the socket send buffer
    SO_RCVBUF | The size of the socket receive buffer
    SO_LINGER | Linger on close if data is present (when configured in blocking mode only)
    还可以支持附加（实现特定）选项。 支持的选项列表是通过调用supportedOptions方法获得的。

    SCTP通道可以安全使用多个并发线程。 他们支持并发阅读和写作，尽管最多只有一个线程可能正在读取，并且最多一个线程可能在任何给定的时间写入。 connect和finishConnect方法彼此相互同步，并且在调用这些方法之一的过程中尝试发起发送或接收操作将阻塞直到该调用完成。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SctpChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Association association​()
      返回此通道的套接字上的关联。
      abstract SctpChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      abstract SctpChannel bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract boolean connect​(SocketAddress remote)
      连接此通道的插座。
      abstract boolean connect​(SocketAddress remote, int maxOutStreams, int maxInStreams)
      连接此通道的插座。
      abstract boolean finishConnect​()
      完成连接SCTP通道的过程。
      abstract Set<SocketAddress> getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract <T> T getOption​(SctpSocketOption<T> name)
      返回套接字选项的值。
      abstract Set<SocketAddress> getRemoteAddresses​()
      返回此通道的套接字所连接的所有远程地址。
      abstract boolean isConnectionPending​()
      告知此频道是否正在进行连接操作。
      static SctpChannel open​()
      打开SCTP通道。
      static SctpChannel open​(SocketAddress remote, int maxOutStreams, int maxInStreams)
      打开SCTP通道并将其连接到远程地址。
      abstract <T> MessageInfo receive​(ByteBuffer dst, T attachment, NotificationHandler<T> handler)
      在给定的缓冲区中接收消息和/或处理通知。
      abstract int send​(ByteBuffer src, MessageInfo messageInfo)
      通过此频道发送消息。
      abstract <T> SctpChannel setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
      abstract SctpChannel shutdown​()
      关闭连接而不关闭通道。
      abstract Set<SctpSocketOption<?>> supportedOptions​()
      返回此通道支持的一组套接字选项。
      abstract SctpChannel unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
      int validOps​()
      返回确定此频道支持的操作的操作集。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

    • 构造方法详细信息

      • SctpChannel

        protected SctpChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 此通道的选择器提供程序

    • 方法详细信息

      • open

        public static SctpChannel open​()
                        throws IOException
        打开SCTP通道。

        新渠道未绑定和未连接。

        结果
        一个新的SCTP通道
        异常
        UnsupportedOperationException - 如果不支持SCTP协议
        IOException - 如果发生I / O错误

      • open

        public static SctpChannel open​(SocketAddress remote,
                               int maxOutStreams,
                               int maxInStreams)
                        throws IOException
        打开SCTP通道并将其连接到远程地址。

        这是一个方便的方法，等效于评估以下表达式：

         open().connect(remote, maxOutStreams, maxInStreams);
        参数
        remote - 要连接新通道的远程地址
        maxOutStreams - 应用程序希望能够发送的流数。 必须是非负数，不得大于65536 。 0使用端点的默认值。
        maxInStreams - 应用程序准备支持的入站流的最大数量。 必须是非负数，不得大于65536 。 0使用端点的默认值。
        结果
        连接到给定地址的新SCTP通道
        异常
        AsynchronousCloseException - 如果另一个线程在连接操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作进行过程中中断当前线程，从而关闭通道并设置当前线程的中断状态
        UnresolvedAddressException - 如果给定的远程地址未完全解析
        UnsupportedAddressTypeException - 如果不支持给定远程地址的类型
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程对等体
        UnsupportedOperationException - 如果不支持SCTP协议
        IOException - 如果发生其他I / O错误

      • association

        public abstract Association association​()
                                 throws IOException
        返回此通道的套接字上的关联。
        结果
        该关联，或 null如果通道的插座未连接。
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生其他I / O错误

      • bind

        public abstract SctpChannel bind​(SocketAddress local)
                          throws IOException
        将通道的套接字绑定到本地地址。

        该方法用于建立套接字和本地地址之间的关系。 一旦建立关系，则套接字保持绑定，直到通道关闭。 这种关系可能不是local的地址local因为它可能会被unbindAddress删除，但一旦调用该方法成功完成，总是会至少有一个本地地址绑定到通道的套接字。

        一旦频道的套接字已成功绑定到特定地址，则不会自动分配，可能会使用bindAddress绑定更多地址，或使用unbindAddress删除。

        参数
        local - 绑定套接字的本地地址，或 null将套接字绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        AlreadyConnectedException - 如果此频道已连接
        ClosedChannelException - 如果此通道关闭
        ConnectionPendingException - 如果此通道上已经在进行非阻塞连接操作
        AlreadyBoundException - 如果此频道已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        IOException - 如果发生其他I / O错误
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作

      • bindAddress

        public abstract SctpChannel bindAddress​(InetAddress address)
                                 throws IOException
        将给定地址添加到通道插座的绑定地址。

        给定的地址不能是wildcard地址。 在调用此方法之前，必须首先使用bind绑定通道，否则抛出NotYetBoundException 。 bind方法采用SocketAddress作为参数，通常包含端口号和地址。 使用此方法子地绑定的地址只是地址，因为SCTP端口号在通道的生存期内保持不变。

        向连接的关联添加地址是可选功能。 如果端点支持动态地址重新配置，那么它可以向对等体发送适当的消息来改变对等体地址列表。

        参数
        address - 要添加到套接字的绑定地址的地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        ConnectionPendingException - 如果此通道上已经在进行非阻塞连接操作
        NotYetBoundException - 如果此频道尚未绑定
        AlreadyBoundException - 如果此频道已经绑定到给定的地址
        IllegalArgumentException - 如果地址是 null或 wildcard地址
        IOException - 如果发生其他I / O错误

      • unbindAddress

        public abstract SctpChannel unbindAddress​(InetAddress address)
                                   throws IOException
        从通道的套接字的绑定地址中删除给定的地址。

        给定的地址不能是wildcard地址。 在调用此方法之前，必须首先使用bind绑定通道，否则抛出NotYetBoundException 。 如果在不具有address作为其绑定地址或仅具有一个本地地址的通道上调用此方法，则该方法将抛出IllegalUnbindException 。 通道的套接字使用bind绑定的初始地址可能会从通道套接字的绑定地址中删除。

        从连接的关联中删除地址是可选功能。 如果端点支持动态地址重新配置，那么它可以向对等体发送适当的消息来改变对等体地址列表。

        参数
        address - 从套接字的绑定地址中删除的地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此频道已关闭
        ConnectionPendingException - 如果此通道上已经在进行非阻塞连接操作
        NotYetBoundException - 如果此频道尚未绑定
        IllegalArgumentException - 如果地址是 null或 wildcard地址
        IllegalUnbindException - 如果address未绑定到通道的插座。 或者通道只有一个地址被绑定
        IOException - 如果发生其他I / O错误

      • connect

        public abstract boolean connect​(SocketAddress remote)
                         throws IOException
        连接此通道的插座。

        如果此通道处于非阻塞模式，则此方法的调用将启动非阻塞连接操作。 如果立即建立连接，就像本地连接一样，该方法返回true 。 否则，此方法返回false ，后来可以通过调用finishConnect方法完成连接操作。

        如果此通道处于阻塞模式，则该方法的调用将阻塞，直到建立连接或发生I / O错误。

        如果安装了一个安全管理器，则该方法验证其checkConnect方法是否允许连接给定远程对等体的地址和端口号。

        可以随时调用此方法。 如果在调用此方法时正在调用此频道上的send或receive操作，则该操作将首先阻止，直到此调用完成。 如果连接尝试启动但失败，也就是说，如果此方法的调用抛出已检查的异常，则该通道将被关闭。

        参数
        remote - 要连接此通道的远程对等体
        结果
        true如果建立了连接，则 false如果此通道处于非阻塞模式并且连接操作正在进行中
        异常
        AlreadyConnectedException - 如果此通道已连接
        ConnectionPendingException - 如果此通道上已经进行了非阻塞连接操作
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在连接操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作进行过程中中断当前线程，则关闭通道并设置当前线程的中断状态
        UnresolvedAddressException - 如果给定的远程地址未完全解析
        UnsupportedAddressTypeException - 如果不支持给定远程地址的类型
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程对等体
        IOException - 如果发生其他I / O错误

      • connect

        public abstract boolean connect​(SocketAddress remote,
                                int maxOutStreams,
                                int maxInStreams)
                         throws IOException
        连接此通道的插座。

        这是一个convience方法，相当于评估以下表达式：

         setOption(SctpStandardSocketOptions.SCTP_INIT_MAXSTREAMS, SctpStandardSocketOption.InitMaxStreams.create(maxInStreams, maxOutStreams))
  .connect(remote);

        maxOutStreams和maxInStreams参数表示应用程序希望能够发送和接收的最大流数。 它们与远程对等体协商，并且可能受到操作系统的限制。

        参数
        remote - 要连接此通道的远程对等体
        maxOutStreams - 必须是非负数，不得大于65536 。 0使用端点的默认值。
        maxInStreams - 必须是非负数，不得大于65536 。 0使用端点的默认值。
        结果
        true如果连接建立，则 false如果此通道处于非阻塞模式并且连接操作正在进行中
        异常
        AlreadyConnectedException - 如果此频道已连接
        ConnectionPendingException - 如果此通道上已经在进行非阻塞连接操作
        ClosedChannelException - 如果此频道关闭
        AsynchronousCloseException - 如果另一个线程在连接操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        UnresolvedAddressException - 如果给定的远程地址未完全解析
        UnsupportedAddressTypeException - 如果不支持给定的远程地址的类型
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程对等体
        IOException - 如果发生其他I / O错误

      • isConnectionPending

        public abstract boolean isConnectionPending​()
        告知此频道是否正在进行连接操作。
        结果
        true如果并且只有在此通道上启动了连接操作但尚未通过调用 finishConnect()方法完成

      • finishConnect

        public abstract boolean finishConnect​()
                               throws IOException
        完成连接SCTP通道的过程。

        通过将套接字通道置于非阻塞模式，然后调用其中一个connect方法来启动非阻塞连接操作。 一旦建立连接，或尝试失败，通道将变为可连接，并且可以调用该方法来完成连接顺序。 如果连接操作失败，则调用此方法将导致抛出适当的IOException 。

        如果此通道已连接，则此方法将不会阻止并立即返回true 。 如果此通道处于非阻塞模式，则如果连接进程尚未完成，则此方法将返回false 。 如果此通道处于阻塞模式，则该方法将阻塞，直到连接完成或失败，并且将始终返回true或抛出描述失败的已检查异常。

        可以随时调用此方法。 如果在调用此方法时正在调用此通道上的send或receive操作，则该操作将首先阻止，直到此调用完成。 如果连接尝试失败，也就是说，如果此方法的调用引发已检查的异常，那么该通道将被关闭。

        结果
        true如果，且仅当此通道的套接字现在已连接
        异常
        NoConnectionPendingException - 如果该通道未连接，并且没有启动连接操作
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在连接操作进行过程中关闭此通道
        ClosedByInterruptException - 如果另一个线程在连接操作进行过程中中断当前线程，从而关闭通道并设置当前线程的中断状态
        IOException - 如果发生其他I / O错误

      • getAllLocalAddresses

        public abstract Set<SocketAddress> getAllLocalAddresses​()
                                                 throws IOException
        返回此通道的套接字所绑定的所有套接字地址。
        结果
        该通道的套接字所绑定的所有套接字地址，如果通道的套接字未绑定， Set空 Set
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误

      • getRemoteAddresses

        public abstract Set<SocketAddress> getRemoteAddresses​()
                                               throws IOException
        返回此通道的套接字所连接的所有远程地址。

        如果通道连接到绑定到多个地址的远程对等体，则这些地址是通道的插座连接的。

        结果
        所有与此通道的插座连接的远程地址，如果通道的插座未连接， Set空 Set
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误

      • shutdown

        public abstract SctpChannel shutdown​()
                              throws IOException
        关闭连接而不关闭通道。

        向远程对等体发送shutdown命令，有效防止任何对等体将任何新数据写入套接字。 进一步发送将抛出ClosedChannelException 。 通道保持打开状态，以允许在接收到关闭命令之前接收对方可能发送的任何数据（和通知）。 如果通道已经关闭，则调用此方法没有任何作用。

        结果
        这个频道
        异常
        NotYetConnectedException - 如果此通道尚未连接
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生其他I / O错误

      • getOption

        public abstract <T> T getOption​(SctpSocketOption<T> name)
                         throws IOException
        返回套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        套接字选项的值。 值为null可能是某些套接字选项的有效值。
        异常
        UnsupportedOperationException - 如果该通道不支持套接字选项
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        SctpStandardSocketOptions

      • setOption

        public abstract <T> SctpChannel setOption​(SctpSocketOption<T> name,
                                          T value)
                                   throws IOException
        设置套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        SctpStandardSocketOptions

      • supportedOptions

        public abstract Set<SctpSocketOption<?>> supportedOptions​()
        返回此通道支持的一组套接字选项。

        即使通道关闭后，此方法仍将继续返回该选项。

        结果
        此通道支持的一组套接字选项

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        SCTP通道支持连接，读取和写入，所以此方法返回( SelectionKey.OP_CONNECT | SelectionKey.OP_READ | SelectionKey.OP_WRITE ) 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集

      • receive

        public abstract <T> MessageInfo receive​(ByteBuffer dst,
                                        T attachment,
                                        NotificationHandler<T> handler)
                                 throws IOException
        在给定的缓冲区中接收消息和/或处理通知。

        如果消息或通知立即可用，或者如果此通道处于阻塞模式，并且最终变为可用，则分别返回或处理消息或通知。 如果此通道处于非阻塞模式，并且消息或通知不能立即可用，则此方法将立即返回null 。

        如果此方法接收到消息，则将其复制到给定的字节缓冲区。 该消息从其当前位置开始传送到给定的字节缓冲区，并且缓冲区位置以读取的字节数增加。 如果缓冲区中剩余的字节少于保存消息所需的字节数，或者底层输入缓冲区不包含完整消息，那么在返回的MessageInfo上调用MessageInfo将返回false ，此方法的更多调用将为有必要完全消费这个messgae。 一次只能有一条讯息在任何流中部分传送。 套接字选项SCTP_FRAGMENT_INTERLEAVE控制消息发生交织的各个方面。

        如果此方法接收到通知，则调用给定处理程序的适当方法（如果有）。 如果处理程序返回CONTINUE，则此方法将尝试接收另一个消息/通知，否则，如果返回RETURN，则此方法将返回null 。 如果处理程序抛出未捕获的异常，它将通过此方法传播到堆栈中。

        可以随时调用此方法。 如果另一个线程已经在该通道上启动了接收操作，则该方法的调用将阻塞，直到第一个操作完成。 调用给定的处理程序而不用任何用于执行上述同步策略的锁，这样处理程序不会阻止其他线程接收。 处理程序不应该调用此通道的receive方法，如果它将抛出IllegalReceiveException 。

        参数类型
        T
        参数
        dst - 要传输消息字节的缓冲区
        attachment - 要附加到接收操作的对象; 可以是null
        handler - 处理来自SCTP堆栈的通知的处理程序，或 null忽略任何通知。
        结果
        的 MessageInfo ， null如果此通道处于非阻塞模式和没有消息可立即或通知处理程序返回 RETURN处理的通知后
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        NotYetConnectedException - 如果此频道尚未连接
        IllegalReceiveException - 如果给定的处理程序调用此通道的 receive方法
        IOException - 如果发生其他I / O错误

      • send

        public abstract int send​(ByteBuffer src,
                         MessageInfo messageInfo)
                  throws IOException
        通过此频道发送消息。

        如果该通道处于非阻塞模式，并且底层输出缓冲区中有足够的空间，或者如果该通道处于阻塞模式并且有足够的空间可用，则给定字节缓冲区中的剩余字节作为单个消息传输。 发送消息是原子的，除非在此通道的套接字上启用显式消息完成SCTP_EXPLICIT_COMPLETE套接字选项。

        消息从字节缓冲区传送，就像通过常规的write操作一样。

        字节将被写入streamNumber在给定的messageInfo指定的流号。

        可以随时调用此方法。 如果另一个线程已经在该通道上发起了一个发送操作，那么这个方法的调用将被阻塞，直到第一个操作完成。

        参数
        src - 包含要发送的消息的缓冲区
        messageInfo - 有关要发送的消息的辅助数据
        结果
        发送的字节数，当调用此方法时将是消息缓冲区中剩余的字节数，或者如果此通道不阻塞，则可能为0，如果底层消息的空间不足输出缓冲区
        异常
        InvalidStreamException - 如果 streamNumner为负数或大于或等于输出流的最大数量
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        NotYetConnectedException - 如果此通道尚未连接
        IOException - 如果发生其他I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SctpMultiChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class SctpMultiChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • com.sun.nio.sctp.SctpMultiChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel

    public abstract class SctpMultiChannel
extends AbstractSelectableChannel
    用于面向消息的SCTP套接字的可选通道。

    SCTP多通道支持单个插座上的许多关联。 通过调用此类的open方法创建一个SctpMultiChannel 。 新创建的频道是开放但尚未绑定的。 尝试调用未绑定通道的receive方法将导致抛出NotYetBoundException 。 尝试调用未绑定通道的send方法将导致它首先调用bind方法。 通过调用getAllLocalAddresses可以检索通道的套接字所绑定的地址 。

    可以发送和接收消息，而不显式地建立与远程对等体的关联。 只要发送或接收来自远程对等体的消息，如果没有与该对等体的关联，则该信道将隐式地建立新的关联。 关联设置成功后，将向SCTP堆栈发送association changed通知，其event参数设置为COMM_UP 。 该通知可以通过调用receive接收。

    套接字选项使用setOption方法进行配置。 一个SctpMultiChannel支持以下选项：

    Socket options
    Option Name | 描述
    SCTP_DISABLE_FRAGMENTS | Enables or disables message fragmentation
    SCTP_EXPLICIT_COMPLETE | Enables or disables explicit message completion
    SCTP_FRAGMENT_INTERLEAVE | Controls how the presentation of messages occur for the message receiver
    SCTP_INIT_MAXSTREAMS | The maximum number of streams requested by the local endpoint during association initialization
    SCTP_NODELAY | Enables or disable a Nagle-like algorithm
    SCTP_PRIMARY_ADDR | Requests that the local SCTP stack use the given peer address as the association primary
    SCTP_SET_PEER_PRIMARY_ADDR | Requests that the peer mark the enclosed address as the association primary
    SO_SNDBUF | The size of the socket send buffer
    SO_RCVBUF | The size of the socket receive buffer
    SO_LINGER | Linger on close if data is present (when configured in blocking mode only)
    还可以支持附加（实现特定）选项。 支持的选项列表是通过调用supportedOptions方法获得的。

    SCTP多通道可以安全使用多个并发线程。 它们支持并发发送和接收，尽管最多只有一个线程可能发送，并且在任何给定的时间最多有一个线程可能正在接收。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SctpMultiChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Set<Association> associations​()
      返回此通道的套接字上的打开关联。
      SctpMultiChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SctpMultiChannel bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SctpMultiChannel bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpChannel branch​(Association association)
      分支协会。
      abstract Set<SocketAddress> getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract <T> T getOption​(SctpSocketOption<T> name, Association association)
      返回套接字选项的值。
      abstract Set<SocketAddress> getRemoteAddresses​(Association association)
      返回此通道的套接字连接给定关联的所有远程地址。
      static SctpMultiChannel open​()
      打开SCTP多通道。
      abstract <T> MessageInfo receive​(ByteBuffer buffer, T attachment, NotificationHandler<T> handler)
      接收消息和/或通过此频道处理通知。
      abstract int send​(ByteBuffer buffer, MessageInfo messageInfo)
      通过此频道发送消息。
      abstract <T> SctpMultiChannel setOption​(SctpSocketOption<T> name, T value, Association association)
      设置套接字选项的值。
      abstract SctpMultiChannel shutdown​(Association association)
      关闭关联而不关闭通道。
      abstract Set<SctpSocketOption<?>> supportedOptions​()
      返回此通道支持的一组套接字选项。
      abstract SctpMultiChannel unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
      int validOps​()
      返回确定此频道支持的操作的操作集。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

    • 构造方法详细信息

      • SctpMultiChannel

        protected SctpMultiChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 此通道的选择器提供程序

    • 方法详细信息

      • open

        public static SctpMultiChannel open​()
                             throws IOException
        打开SCTP多通道。

        新渠道未绑定。

        结果
        一个新的SCTP多频道
        异常
        UnsupportedOperationException - 如果不支持SCTP协议
        IOException - 如果发生I / O错误

      • associations

        public abstract Set<Association> associations​()
                                       throws IOException
        返回此通道的套接字上的打开关联。

        只有已经收到COMM_UP关联变更事件的关联才包含在返回的关联集中。 已经收到COMM_LOST或SHUTDOWN关联更改事件的关联从该组关联中移除。

        返回的关联集是在调用此方法时打开的关联的快照。

        结果
        A Set包含打开的关联，如果没有， Set空 Set 。
        异常
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生其他I / O错误

      • bind

        public abstract SctpMultiChannel bind​(SocketAddress local,
                                      int backlog)
                               throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以监听连接。

        该方法用于建立套接字和本地地址之间的关系。 一旦建立关系，则套接字保持绑定，直到通道关闭。 这种关系可能不是local的地址local因为它可能会被unbindAddress删除，但是一旦调用此方法成功完成，将始终至少有一个本地地址绑定到通道的套接字。

        一旦通道的套接字已成功绑定到特定地址，则不会自动分配，可能会使用bindAddress绑定更多地址，或使用unbindAddress删除。

        backlog参数是套接字上挂起连接的最大数量。 其确切语义是实现具体的。 实现可以强制实现特定的最大长度，或者可以选择忽略该参数。 如果backlog参数的值为0或负值，则使用实现特定的默认值。

        参数
        local - 绑定套接字的本地地址，或 null将套接字绑定到自动分配的套接字地址
        backlog - 挂起连接的最大数量
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        AlreadyBoundException - 如果此频道已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        IOException - 如果发生其他I / O错误

      • bind

        public final SctpMultiChannel bind​(SocketAddress local)
                            throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以监听连接。

        这个方法的工作原理就像调用它相当于评估表达式：

         bind(local, 0);
        参数
        local - 绑定套接字的本地地址，或 null将套接字绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        AlreadyBoundException - 如果此频道已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        IOException - 如果发生其他I / O错误

      • bindAddress

        public abstract SctpMultiChannel bindAddress​(InetAddress address)
                                      throws IOException
        将给定地址添加到通道插座的绑定地址。

        给定的地址不能是wildcard地址。 在调用此方法之前，必须首先使用bind绑定通道，否则抛出NotYetBoundException 。 bind方法需要一个SocketAddress作为其参数，通常包含端口号和地址。 使用此方法子地绑定的地址只是地址，因为SCTP端口号在通道的生存期内保持不变。

        此方法成功完成后，新建关联设置将与给定地址关联。 向现有关联添加地址是可选功能。 如果端点支持动态地址重新配置，那么它可以向对等体发送适当的消息来改变对等体地址列表。

        参数
        address - 要添加到套接字绑定地址的地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此频道关闭
        NotYetBoundException - 如果此频道尚未绑定
        AlreadyBoundException - 如果此频道已经绑定到给定的地址
        IllegalArgumentException - 如果地址是 null或 wildcard地址
        IOException - 如果发生其他I / O错误

      • unbindAddress

        public abstract SctpMultiChannel unbindAddress​(InetAddress address)
                                        throws IOException
        从通道的套接字的绑定地址中删除给定的地址。

        给定的地址不能是wildcard地址。 在调用此方法之前，必须先使用bind绑定通道，否则抛出NotYetBoundException 。

        如果在没有address作为其绑定地址之一或只有一个本地地址绑定的通道上调用此方法，则该方法将抛出IllegalUnbindException 。

        通道的套接字使用bind绑定的初始地址可能会从通道插座的绑定地址中删除。

        此方法成功完成后，新的关联设置将不会与给定的地址相关联。 从现有关联中删除地址是可选功能。 如果端点支持动态地址重新配置，那么它可以向对等体发送适当的消息来改变对等体地址列表。

        参数
        address - 从套接字的绑定地址中删除的地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        NotYetBoundException - 如果此频道尚未绑定
        IllegalUnbindException - address未绑定到通道的套接字，或者通道只有一个地址与其绑定
        IllegalArgumentException - 如果地址是 null或 wildcard地址
        IOException - 如果发生其他I / O错误

      • getAllLocalAddresses

        public abstract Set<SocketAddress> getAllLocalAddresses​()
                                                 throws IOException
        返回此通道的套接字所绑定的所有套接字地址。
        结果
        该通道的套接字所绑定的所有套接字地址，如果通道的套接字未绑定， Set空 Set
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误

      • getRemoteAddresses

        public abstract Set<SocketAddress> getRemoteAddresses​(Association association)
                                               throws IOException
        返回此通道的套接字连接给定关联的所有远程地址。
        参数
        association - 协会
        结果
        给定关联的所有远程地址，如果关联已关闭， Set空 Set
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误

      • shutdown

        public abstract SctpMultiChannel shutdown​(Association association)
                                   throws IOException
        关闭关联而不关闭通道。
        参数
        association - 关联关联
        结果
        这个频道
        异常
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生其他I / O错误

      • getOption

        public abstract <T> T getOption​(SctpSocketOption<T> name,
                                Association association)
                         throws IOException
        返回套接字选项的值。

        请注意，某些选项在通道的套接字上检索，因此association参数不适用，如果给出将被忽略。 但是，如果选项是关联特定的，则必须给出关联。

        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        association - 应该检索其选项的关联，如果该选项应在通道的套接字级别检索， null 。
        结果
        套接字选项的值。 值为null可能是某些套接字选项的有效值。
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生I / O错误
        另请参见：
        SctpStandardSocketOptions

      • setOption

        public abstract <T> SctpMultiChannel setOption​(SctpSocketOption<T> name,
                                               T value,
                                               Association association)
                                        throws IOException
        设置套接字选项的值。

        请注意，某些选项在通道的套接字上检索，因此association参数不适用，如果给出将被忽略。 但是，如果选项是关联特定的，则必须给出关联。

        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        association - 应该设置选项的关联，如果该选项应设置在通道的套接字级别， null 。
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        SctpStandardSocketOptions

      • supportedOptions

        public abstract Set<SctpSocketOption<?>> supportedOptions​()
        返回此通道支持的一组套接字选项。

        即使通道关闭后，此方法仍将继续返回该选项。

        结果
        此通道支持的一组套接字选项

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        SCTP多通道支持阅读和写作，所以这种方法返回( SelectionKey.OP_READ | SelectionKey.OP_WRITE ) 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集

      • receive

        public abstract <T> MessageInfo receive​(ByteBuffer buffer,
                                        T attachment,
                                        NotificationHandler<T> handler)
                                 throws IOException
        接收消息和/或通过此频道处理通知。

        如果消息或通知立即可用，或者如果此通道处于阻塞模式，并且最终变为可用，则分别返回或处理消息或通知。 如果此通道处于非阻塞模式，并且消息或通知不能立即可用，则此方法将立即返回null 。

        如果此方法接收到一条消息，则将其复制到给定的字节缓冲区中，并返回一个MessageInfo 。 该消息从其当前位置开始传送到给定的字节缓冲区，并且缓冲区位置以读取的字节数增加。 如果缓冲区中剩余的字节少于保存消息所需的字节数，或者底层输入缓冲区不包含完整消息，那么在返回的MessageInfo上调用MessageInfo将返回false ，并且此方法的更多调用将为有必要完全消费这个messgae。 一次只能有一条讯息在任何流中部分传送。 套接字选项SCTP_FRAGMENT_INTERLEAVE控制发生消息隔行扫描的各个方面。

        如果此方法接收到通知，则调用给定处理程序的适当方法（如果有）。 如果处理程序返回CONTINUE，则此方法将尝试接收另一条消息/通知，否则，如果返回RETURN，则此方法将返回null 。 如果处理程序抛出未捕获的异常，它将通过此方法传播到堆栈中。

        如果已经安装了一个安全管理器，那么对于每个新的关联设置，该方法验证安全管理器的checkAccept方法允许关联源地址和端口号。

        可以随时调用此方法。 如果另一个线程已经在该通道上启动了接收操作，则该方法的调用将阻塞，直到第一个操作完成。 调用给定的处理程序而不用任何用于执行上述同步策略的锁，这样处理程序不会阻止其他线程接收。 处理程序不应该调用此通道的receive方法，如果它将抛出IllegalReceiveException 。

        参数类型
        T - 附件的类型
        参数
        buffer - 要传输字节的缓冲区
        attachment - 附加到接收操作的对象; 可以是null
        handler - 处理来自SCTP堆栈的通知的处理程序，或 null忽略任何通知。
        结果
        的 MessageInfo ， null如果此通道处于非阻塞模式和没有消息可立即或通知处理程序返回 RETURN处理的通知后
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行中断当前线程，从而关闭通道并设置当前线程的中断状态
        NotYetBoundException - 如果此频道尚未绑定
        IllegalReceiveException - 如果给定的处理程序调用此通道的 receive方法
        SecurityException - 如果已安装安全管理员，并且不允许从邮件的发件人接受新的关联
        IOException - 如果发生其他I / O错误

      • send

        public abstract int send​(ByteBuffer buffer,
                         MessageInfo messageInfo)
                  throws IOException
        通过此频道发送消息。

        如果此通道未绑定，则此方法将在发送任何数据之前调用bind(null, 0) 。

        如果该通道的套接字和预定接收方之间没有关联，由给定messageInfo中的地址标识，那么将自动设置为预期的接收者。 这被认为是隐式关联设置。 关联设置成功后，将向SCTP堆栈发送association changed通知，其event参数设置为COMM_UP 。 该通知可以通过调用receive接收。

        如果此通道处于阻塞模式，底层输出缓冲区中有足够的空间，则给定字节缓冲区中的剩余字节作为单个消息传输。 发送消息是原子的，除非在此通道的套接字上启用显式消息完成SCTP_EXPLICIT_COMPLETE套接字选项。

        如果该通道处于非阻塞模式，则底层输出缓冲区中有足够的空间，并且需要隐式关联设置，则给定字节缓冲区中的剩余字节将作为单个消息传输，但须遵守SCTP_EXPLICIT_COMPLETE 。 如果由于任何原因，无法传送该消息， 则将其event参数设置为CANT_START ，将SCTP堆栈上的通知置于association changed 。

        消息从字节缓冲区传输，就像通过常规的write操作一样。

        如果已经安装了安全管理器，那么对于每个新的关联设置，该方法验证安全管理器的checkConnect方法允许给定的远程对等体地址和端口号。

        可以随时调用此方法。 如果另一个线程已经在该通道上发起了一个发送操作，那么这个方法的调用将被阻塞，直到第一个操作完成。

        参数
        buffer - 包含要发送的消息的缓冲区
        messageInfo - 有关要发送的消息的辅助数据
        结果
        发送的字节数，当调用此方法时将是消息缓冲区中剩余的字节数，或者如果此通道不阻塞，则可能为0，如果底层消息的空间不足输出缓冲区
        异常
        InvalidStreamException - 如果 streamNumber为负，或者如果关联已经存在，并且 streamNumber大于输出流的最大数量
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在读取操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在读取操作正在进行时中断当前线程，从而关闭通道并设置当前线程的中断状态
        SecurityException - 如果已安装安全管理员，并且不允许使用邮件地址设置新的关联
        IOException - 如果发生其他I / O错误

      • branch

        public abstract SctpChannel branch​(Association association)
                            throws IOException
        分支协会。

        应用程序可以调用此方法将关联分支到单独的通道中。 将为该协会创建新的绑定和连接的SctpChannel 。 分支关联将不再是此渠道的一部分。

        当例如应用程序希望有许多零星的消息发送者/接收者保留在原始SCTP多信道之下，但是将携带高容量数据业务的关联分支到它们自己的单独的SCTP信道中时，这是特别有用的。

        参数
        association - 关联分支
        结果
        SctpChannel
        异常
        ClosedChannelException - 如果此频道关闭
        IOException - 如果发生其他I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SctpServerChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class SctpServerChannel

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel
      • java.nio.channels.SelectableChannel
        • java.nio.channels.spi.AbstractSelectableChannel
          • com.sun.nio.sctp.SctpServerChannel
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Channel ， InterruptibleChannel

    public abstract class SctpServerChannel
extends AbstractSelectableChannel
    用于面向消息的侦听SCTP插座的可选通道。

    通过调用此类的open方法创建一个SCTPServerChannel 。 新创建的SCTP服务器通道已打开但尚未绑定。 尝试调用未绑定通道的accept方法将导致抛出NotYetBoundException 。 可以通过调用此类定义的一个bind方法来绑定SCTP服务器通道。

    套接字选项使用setOption方法进行配置。 SCTP服务器插槽通道支持以下选项：

    Socket options
    Option Name | 描述
    SCTP_INIT_MAXSTREAMS | The maximum number of streams requested by the local endpoint during association initialization
    还可以支持附加（实现特定）选项。 支持的选项列表是通过调用supportedOptions方法获得的。

    SCTP服务器通道可以安全使用多个并发线程。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SctpServerChannel​(SelectorProvider provider)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract SctpChannel accept​()
      在此频道的套接字上接受关联。
      SctpServerChannel bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract SctpServerChannel bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract SctpServerChannel bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract Set<SocketAddress> getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract <T> T getOption​(SctpSocketOption<T> name)
      返回套接字选项的值。
      static SctpServerChannel open​()
      打开SCTP服务器通道。
      abstract <T> SctpServerChannel setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
      abstract Set<SctpSocketOption<?>> supportedOptions​()
      返回此通道支持的一组套接字选项。
      abstract SctpServerChannel unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
      int validOps​()
      返回确定此频道支持的操作的操作集。

      • Methods inherited from class java.nio.channels.spi.AbstractInterruptibleChannel

        begin, close, end, isOpen

      • Methods inherited from class java.nio.channels.spi.AbstractSelectableChannel

        blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register

      • Methods inherited from interface java.nio.channels.Channel

        close, isOpen

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.nio.channels.SelectableChannel

        register

    • 构造方法详细信息

      • SctpServerChannel

        protected SctpServerChannel​(SelectorProvider provider)
        初始化此类的新实例。
        参数
        provider - 此通道的选择器提供程序

    • 方法详细信息

      • open

        public static SctpServerChannel open​()
                              throws IOException
        打开SCTP服务器通道。

        新频道的套接字最初未绑定; 它必须通过其套接字的bind方法绑定到特定地址，才能接受关联。

        结果
        一个新的SCTP服务器通道
        异常
        UnsupportedOperationException - 如果不支持SCTP协议
        IOException - 如果发生I / O错误

      • accept

        public abstract SctpChannel accept​()
                            throws IOException
        在此频道的套接字上接受关联。

        如果此通道处于非阻塞模式，则如果没有未挂起的关联，则此方法将立即返回null 。 否则，它将无限期地阻塞，直到有一个新的关联可用或发生I / O错误。

        无论此通道的阻塞模式如何，通过此方法返回的SCTPChannel （如果有）将处于阻塞模式。

        如果已经安装了一个安全管理器，那么对于每个新关联，该方法将通过安全管理器的checkAccept方法来验证协议的远程对等体的地址和端口号是否被允许。

        结果
        新关联的SCTP通道，或 null如果该通道处于非阻塞模式，并且没有关联可用于接受
        异常
        ClosedChannelException - 如果此通道关闭
        AsynchronousCloseException - 如果另一个线程在接受操作正在进行时关闭此通道
        ClosedByInterruptException - 如果另一个线程在接受操作进行过程中中断当前线程，从而关闭通道并设置当前线程的中断状态
        NotYetBoundException - 如果此通道的套接字尚未绑定
        SecurityException - 如果已安装安全管理员，并且不允许访问新关联的远程对等体
        IOException - 如果发生其他I / O错误

      • bind

        public final SctpServerChannel bind​(SocketAddress local)
                             throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以侦听关联。

        这个方法的工作原理就像调用它相当于评估表达式：

         bind(local, 0);
        参数
        local - 绑定套接字的本地地址，或 null将套接字绑定到自动分配的套接字地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        AlreadyBoundException - 如果此频道已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        IOException - 如果发生其他I / O错误

      • bind

        public abstract SctpServerChannel bind​(SocketAddress local,
                                       int backlog)
                                throws IOException
        将通道的套接字绑定到本地地址，并配置套接字以侦听关联。

        该方法用于建立套接字和本地地址之间的关系。 一旦建立关系，则套接字保持绑定，直到通道关闭。 这种关系可能local地与地址local一样，因为它可能被unbindAddress删除，但一旦调用此方法成功完成，总是会至少有一个本地地址绑定到通道的套接字。

        一旦频道的套接字已成功绑定到特定地址，则不会自动分配，可能会使用bindAddress绑定更多地址，或使用unbindAddress删除。

        backlog参数是套接字上的挂起关联的最大数量。 其确切语义是实现具体的。 实现可以强制实现特定的最大长度，或者可以选择忽略该参数。 如果backlog参数的值为0或负值，则使用实现特定的默认值。

        参数
        local - 绑定套接字的本地地址，或 null将套接字绑定到自动分配的套接字地址
        backlog - 待处理关联的最大数量
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        AlreadyBoundException - 如果此频道已经绑定
        UnsupportedAddressTypeException - 如果不支持给定地址的类型
        SecurityException - 如果已安装安全管理员，并且其 checkListen方法拒绝操作
        IOException - 如果发生其他I / O错误

      • bindAddress

        public abstract SctpServerChannel bindAddress​(InetAddress address)
                                       throws IOException
        将给定地址添加到通道插座的绑定地址。

        给定的地址不能是wildcard地址。 在调用此方法之前，必须先使用bind绑定通道，否则抛出NotYetBoundException 。 bind方法采用SocketAddress作为其参数，通常包含端口号和地址。 使用此方法子地绑定的地址只是地址，因为SCTP端口号在通道的生存期内保持不变。

        此方法成功完成后接受的新关联将与给定地址相关联。

        参数
        address - 添加到套接字的绑定地址的地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        NotYetBoundException - 如果此频道尚未绑定
        AlreadyBoundException - 如果此频道已经绑定到给定的地址
        IllegalArgumentException - 如果地址是 null或 wildcard地址
        IOException - 如果发生其他I / O错误

      • unbindAddress

        public abstract SctpServerChannel unbindAddress​(InetAddress address)
                                         throws IOException
        从通道的套接字的绑定地址中删除给定的地址。

        给定的地址不能是wildcard地址。 在调用此方法之前，必须首先使用bind绑定通道，否则抛出NotYetBoundException 。 如果在没有address作为其绑定地址之一或只有一个本地地址绑定的通道上调用此方法，则该方法将抛出IllegalUnbindException 。 通道的套接字使用bind绑定的初始地址可能会从通道套接字的绑定地址中删除。

        此方法成功完成后接受的新关联将不与给定地址相关联。

        参数
        address - 从套接字的绑定地址中删除的地址
        结果
        这个频道
        异常
        ClosedChannelException - 如果此通道关闭
        NotYetBoundException - 如果此频道尚未绑定
        IllegalArgumentException - 如果地址是 null或 wildcard地址
        IllegalUnbindException - 如果实现不支持从侦听套接字中删除地址，则 address未绑定到通道的套接字，或者该通道只有一个地址与其绑定
        IOException - 如果发生其他I / O错误

      • getAllLocalAddresses

        public abstract Set<SocketAddress> getAllLocalAddresses​()
                                                 throws IOException
        返回此通道的套接字所绑定的所有套接字地址。
        结果
        该通道的套接字所绑定的所有套接字地址，如果通道的套接字未绑定， Set空 Set
        异常
        ClosedChannelException - 如果通道关闭
        IOException - 如果发生I / O错误

      • getOption

        public abstract <T> T getOption​(SctpSocketOption<T> name)
                         throws IOException
        返回套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        套接字选项的值。 值为null可能是某些套接字选项的有效值。
        异常
        UnsupportedOperationException - 如果此通道不支持套接字选项
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        SctpStandardSocketOptions

      • setOption

        public abstract <T> SctpServerChannel setOption​(SctpSocketOption<T> name,
                                                T value)
                                         throws IOException
        设置套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能是某些套接字选项的有效值。
        结果
        这个频道
        异常
        UnsupportedOperationException - 如果该通道不支持套接字选项
        IllegalArgumentException - 如果该值不是此套接字选项的有效值
        ClosedChannelException - 如果此通道关闭
        IOException - 如果发生I / O错误
        另请参见：
        SctpStandardSocketOptions

      • supportedOptions

        public abstract Set<SctpSocketOption<?>> supportedOptions​()
        返回此通道支持的一组套接字选项。

        即使通道关闭后，此方法仍将继续返回该选项。

        结果
        此通道支持的一组套接字选项

      • validOps

        public final int validOps​()
        返回确定此频道支持的操作的操作集。

        SCTP服务器通道只支持接受新的关联，所以这个方法返回SelectionKey.OP_ACCEPT 。

        Specified by:
        validOps在 SelectableChannel
        结果
        有效操作集
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SctpSocketOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Interface SctpSocketOption<T>

  • 参数类型
    T - 套接字选项值的类型。
    All Superinterfaces:
    SocketOption<T>

    public interface SctpSocketOption<T>
extends SocketOption<T>
    与SCTP通道相关联的插座选项。
    从以下版本开始：
    1.7
    另请参见：
    SctpStandardSocketOptions

    • 方法摘要

      • Methods inherited from interface java.net.SocketOption

        name, type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SctpStandardSocketOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class SctpStandardSocketOptions

  • java.lang.Object
    • com.sun.nio.sctp.SctpStandardSocketOptions

  • public class SctpStandardSocketOptions
extends Object
    SCTP通道支持此类定义的套接字选项（以及特定通道类中列出的套接字选项），并且可以支持额外的实现特定套接字选项。
    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  SctpStandardSocketOptions.InitMaxStreams
      此类用于设置关联初始化期间本地端点使用的入站/出站流的最大数量。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static SctpSocketOption<Boolean> SCTP_DISABLE_FRAGMENTS
      启用或禁用消息碎片。
      static SctpSocketOption<Boolean> SCTP_EXPLICIT_COMPLETE
      启用或禁用显式消息完成。
      static SctpSocketOption<Integer> SCTP_FRAGMENT_INTERLEAVE
      分段交错控制消息接收器的消息呈现方式。
      static SctpSocketOption<SctpStandardSocketOptions.InitMaxStreams> SCTP_INIT_MAXSTREAMS
      关联初始化期间本地端点请求的最大流数。
      static SctpSocketOption<Boolean> SCTP_NODELAY
      启用或禁用类似Nagle的算法。
      static SctpSocketOption<SocketAddress> SCTP_PRIMARY_ADDR
      请求本地SCTP堆栈使用给定对等体地址作为关联主节点。
      static SctpSocketOption<SocketAddress> SCTP_SET_PEER_PRIMARY_ADDR
      请求对等方将附带的地址标记为关联主。
      static SctpSocketOption<Integer> SO_LINGER
      如果数据存在，则关闭。
      static SctpSocketOption<Integer> SO_RCVBUF
      套接字的大小接收缓冲区。
      static SctpSocketOption<Integer> SO_SNDBUF
      套接字发送缓冲区的大小。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • SCTP_DISABLE_FRAGMENTS

        public static final SctpSocketOption<Boolean> SCTP_DISABLE_FRAGMENTS
        启用或禁用消息碎片。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 如果启用，则不会执行SCTP消息碎片。 相反，如果发送的消息超过当前的PMTU大小，则不会发送消息，并向用户显示错误。

        是否支持此选项。

      • SCTP_EXPLICIT_COMPLETE

        public static final SctpSocketOption<Boolean> SCTP_EXPLICIT_COMPLETE
        启用或禁用显式消息完成。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 启用此选项时，可以将send方法多次调用到发送消息。 该isComplete的参数MessageInfo只能设置为true的最后发送，以表明该消息是完整的。 如果禁用此选项，则每个单独的send调用被认为是完整的。

        该选项的默认值为false表示该选项被禁用。 是否支持此选项。

      • SCTP_FRAGMENT_INTERLEAVE

        public static final SctpSocketOption<Integer> SCTP_FRAGMENT_INTERLEAVE
        分段交错控制消息接收器的消息呈现方式。 有三个级别的片段交错定义。 其中两个水平影响SctpChannel ，而SctpMultiChannel则由三个层次影响。

        此选项将获得Integer值。 它可以被设置为值0 ， 1或者2 。

        设置三个级别提供以下接收器交互：

        level 0 - 防止任何消息的交织。 这意味着当部分传递开始时，除了部分传递消息之外，不会收到其他消息。 如果另一个消息到达可以传递的不同流（或关联），则会被阻塞等待用户读取所有部分传递的消息。

        level 1 - 允许来自不同关联的消息的交织。 对于SctpChannel ，级别0和级别1具有相同的含义，因为SctpChannel总是从相同的关联接收消息。 请注意，将SctpMultiChannel设置为此级别可能会导致来自不同关联的多个部分传递，但对于任何给定的关联，只有一个消息将被传递，直到消息的所有部分都被传递。 这意味着，以“X”的关联标识读取的一个大消息将阻止来自关联“X”的其他消息被传递。

        level 2 - 允许完全交错消息。 该级别要求发件人不仅仔细观察对等体Association而且还要注意流数。 启用此选项后，可能开始为“X”流“Y”传送部分传递的消息，下一个后续接收可能返回关联“X”流“Z”的消息。 请注意，直到所有流“Y”的部分传递消息被读取为止，才会传送关联“X”流“Y”的其他消息。 请注意，此选项会影响两种通道类型。 另请注意，对于SctpMultiChannel不仅可以从下一次接收传送来自相同关联的另一个流消息，一些其他关联消息可以在下次接收时传送。

        是否支持此选项。

      • SCTP_INIT_MAXSTREAMS

        public static final SctpSocketOption<SctpStandardSocketOptions.InitMaxStreams> SCTP_INIT_MAXSTREAMS
        关联初始化期间本地端点请求的最大流数。

        此套接字选项的值为InitMaxStreams ，表示通道上的关联准备支持的入站和出站流的最大数量。

        对于SctpChannel，此选项只能用于在连接之前更改入站/出站流的数量。

        对于SctpMultiChannel，此选项确定入站/出站流的最大数量，通道上的新关联设置将准备支持。

        对于SctpServerChannel，此选项确定接受套接字与其连接对等体协商的最大入站/出站流数。

        在所有情况下，此选项设置的值用于在通道的套接字上设置新关联的协商中，并且可以从适当的Association检索与对等体协商的实际最大入站/出站流数 。 Association可以从属于该关联的COMM_UP AssociationChangeNotification检索。

        该值受实际实现的限制。 换句话说，用户可能能够支持比操作系统更多的流。 在这种情况下，操作系统限制可能会覆盖用户请求的值。 默认值为0表示使用端点的默认值。

      • SCTP_NODELAY

        public static final SctpSocketOption<Boolean> SCTP_NODELAY
        启用或禁用类似Nagle的算法。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 SCTP使用像Nagle算法这样的算法聚合短片段并提高网络效率。

      • SCTP_PRIMARY_ADDR

        public static final SctpSocketOption<SocketAddress> SCTP_PRIMARY_ADDR
        请求本地SCTP堆栈使用给定对等体地址作为关联主节点。

        此套接字选项的值为SocketAddress ，表示本地SCTP堆栈用作关联主节点的对等地址。 地址必须是关联对等体的地址之一。

        一个SctpMultiChannel可以控制多个关联，在设置或检索此选项时，必须给出关联参数。

        由于SctpChannel仅控制一个关联，因此不需要关联参数，并且可以直接设置或查询该选项。

      • SCTP_SET_PEER_PRIMARY_ADDR

        public static final SctpSocketOption<SocketAddress> SCTP_SET_PEER_PRIMARY_ADDR
        请求对等方将附带的地址标记为关联主。

        此套接字选项的值为SocketAddress ，表示对端应用作其主地址的本地地址。 给定的地址必须是关联的本地绑定地址之一。

        一个SctpMultiChannel可以控制多个关联，在设置或检索此选项时，必须给出关联参数。

        由于SctpChannel仅控制一个关联，因此不需要关联参数，并且可以直接查询此选项。

        注意，这是一个集合的选项，不能通过getOption检索。 是否支持此选项。

      • SO_SNDBUF

        public static final SctpSocketOption<Integer> SO_SNDBUF
        套接字发送缓冲区的大小。

        此套接字选项的值是一个Integer ，即套接字发送缓冲区的大小（以字节为单位）。 套接字发送缓冲区是由网络实现使用的输出缓冲区。 可能需要增加大容量连接。 套接字选项的值是实现缓冲区大小的一个暗示 ，实际大小可能不同。 可以查询套接字选项来检索实际大小。

        对于SctpChannel ，它控制SCTP堆栈在内部缓冲区中可能发送的数据量。 因此，此选项限制了在单个发送呼叫中可以发送的数据的最大大小。

        对于SctpMultiChannel ，效果与SctpChannel相同，但适用于所有关联。 该选项分别适用于每个关联的窗口大小。

        一个实现允许在套接字绑定或连接之前设置此套接字选项。 一个实现是否允许在套接字绑定后更改套接字发送缓冲区是系统依赖的。

      • SO_RCVBUF

        public static final SctpSocketOption<Integer> SO_RCVBUF
        套接字的大小接收缓冲区。

        此套接字选项的值为Integer ，即套接字接收缓冲区的大小（以字节为单位）。 套接字接收缓冲区是由网络实现使用的输入缓冲区。 对于大容量连接可能需要增加或减少以限制可能积压的输入数据。 套接字选项的值是实现缓冲区大小的一个暗示 ，实际大小可能不同。

        对于SctpChannel ，它控制接收器窗口大小。

        对于SctpMultiChannel ，意思是依赖于实现。 它可以控制绑定到套接字描述符的每个关联的接收缓冲区，或者它可以控制整个套接字的接收缓冲区。

        一个实现允许在套接字绑定或连接之前设置此套接字选项。 一个实现是否允许在套接字绑定之后更改套接字接收缓冲区是系统依赖的。

      • SO_LINGER

        public static final SctpSocketOption<Integer> SO_LINGER
        如果数据存在，则关闭。

        此套接字选项的值是一个Integer ，用于控制未发送数据在套接字上排队时所采取的操作，并调用关闭套接字的方法。 如果套接字选项的值为零或更大，则表示超时值（以秒为单位），称为间隔时间间隔 。 close间隔是close方法在操作系统尝试发送未发送数据或者决定无法发送数据时阻止的超时。 如果套接字选项的值小于零，则禁用该选项。 在这种情况下， close方法不等待发送未发送的数据; 如果可能，操作系统将在连接关闭之前传输任何未发送的数据。

        此套接字选项仅适用于仅在blocking模式下配置的套接字。 close在非阻塞套接字上启用此选项时， close方法的行为。

        此套接字选项的初始值为负值，表示该选项被禁用。 该选项可以在任何时间被启用，或延迟间隔更改。 滞后间隔的最大值取决于系统。 将逗留间隔设置为大于其最大值的值会导致延迟间隔被设置为其最大值。

Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SctpStandardSocketOptions.InitMaxStreams (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class SctpStandardSocketOptions.InitMaxStreams

  • java.lang.Object
    • com.sun.nio.sctp.SctpStandardSocketOptions.InitMaxStreams
  • Enclosing class:
    SctpStandardSocketOptions

    public static class SctpStandardSocketOptions.InitMaxStreams
extends Object
    此类用于设置关联初始化期间本地端点使用的入站/出站流的最大数量。 该类的一个实例用于设置SCTP_INIT_MAXSTREAMS套接字选项。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static SctpStandardSocketOptions.InitMaxStreams create​(int maxInStreams, int maxOutStreams)
      创建一个InitMaxStreams实例。
      boolean equals​(Object obj)
      如果指定的对象是另一个 InitMaxStreams具有相同数量的输入和输出绑定流的实例，则返回true。
      int hashCode​()
      返回此init数据流的哈希码值。
      int maxInStreams​()
      返回入站流的最大数量。
      int maxOutStreams​()
      返回出站流的最大数量。
      String toString​()
      返回此init最大流的字符串表示形式，包括最大输入和输出绑定流。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • create

        public static SctpStandardSocketOptions.InitMaxStreams create​(int maxInStreams,
                                                              int maxOutStreams)
        创建一个InitMaxStreams实例。
        参数
        maxInStreams - 入站流的最大数目，其中 0 <= maxInStreams <= 65536
        maxOutStreams - 出站流的最大数量，其中 0 <= maxOutStreams <= 65536
        结果
        一个 InitMaxStreams实例
        异常
        IllegalArgumentException - 如果参数超出指定范围

      • maxInStreams

        public int maxInStreams​()
        返回入站流的最大数量。
        结果
        最大入站流

      • maxOutStreams

        public int maxOutStreams​()
        返回出站流的最大数量。
        结果
        最大出站流

      • toString

        public String toString​()
        返回此init最大流的字符串表示形式，包括最大输入和输出绑定流。
        重写：
        toString在 Object
        结果
        这个init最大流的字符串表示形式

      • equals

        public boolean equals​(Object obj)
        如果指定的对象是另一个 InitMaxStreams具有相同数量的输入和输出绑定流的实例，则返回true。
        重写：
        equals在 Object
        参数
        obj - 要与此init max比较的对象
        结果
        如果指定的对象是具有相同数量的进出流绑定流的另一个 InitMaxStreams实例， InitMaxStreams true
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此init数据流的哈希码值。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SendFailedNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class SendFailedNotification

  • java.lang.Object
    • com.sun.nio.sctp.SendFailedNotification
  • All Implemented Interfaces:
    Notification

    public abstract class SendFailedNotification
extends Object
implements Notification
    收到发送失败通知时发出的通知。

    发送失败通知表示无法发送消息。 典型地，这是因为关联已关闭与插座输出缓冲器的未发送的数据，或在一个的情况下SctpMultiChannel的关联未能设置。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SendFailedNotification​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract SocketAddress address​()
      返回地址。
      abstract Association association​()
      返回此通知适用的关联。
      abstract ByteBuffer buffer​()
      返回要发送的数据。
      abstract int errorCode​()
      返回错误代码。
      abstract int streamNumber​()
      返回消息传送的流号。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SendFailedNotification

        protected SendFailedNotification​()
        初始化此类的新实例。

    • 方法详细信息

      • association

        public abstract Association association​()
        返回此通知适用的关联。
        Specified by:
        association在接口 Notification
        结果
        失败的关联发送或 null如果没有关联，也就是通知遵循 AssociationChangeNotification.AssocChangeEvent.CANT_START

      • address

        public abstract SocketAddress address​()
        返回地址。
        结果
        关联的对等主地址或消息发送到的地址

      • buffer

        public abstract ByteBuffer buffer​()
        返回要发送的数据。
        结果
        用户数据。 缓冲区位置将为0 ，其限制将设置为数据的末尾。

      • errorCode

        public abstract int errorCode​()
        返回错误代码。

        errorCode给出了发送失败的原因，如果设置，将是RFC2960第3.3.10节中定义的SCTP协议错误代码

        结果
        错误代码

      • streamNumber

        public abstract int streamNumber​()
        返回消息传送的流号。
        结果
        流号码
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ShutdownNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.sctp
软件包 com.sun.nio.sctp

Class ShutdownNotification

  • java.lang.Object
    • com.sun.nio.sctp.ShutdownNotification
  • All Implemented Interfaces:
    Notification

    public abstract class ShutdownNotification
extends Object
implements Notification
    当对等体关闭关联时发出的通知。

    当对等体发送SHUTDOWN时 ，SCTP堆栈传递此通知，通知应用程序应停止发送数据。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ShutdownNotification​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract Association association​()
      返回此通知适用的关联。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ShutdownNotification

        protected ShutdownNotification​()
        初始化此类的新实例。

    • 方法详细信息

      • association

        public abstract Association association​()
        返回此通知适用的关联。
        Specified by:
        association在接口 Notification
        结果
        关闭的关联
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.nio.sctp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.nio.sctp

  • Packages that use com.sun.nio.sctp
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
  • Classes in com.sun.nio.sctp used by com.sun.nio.sctp
    Class 描述
    Association
    表示SCTP关联的类。
    AssociationChangeNotification
    关联已打开或关闭时发出的通知。
    AssociationChangeNotification.AssocChangeEvent
    定义关联发生的变更事件的类型。
    HandlerResult
    定义通知处理程序结果。
    MessageInfo
    MessageInfo类提供了有关消息的附加辅助信息。
    Notification
    来自SCTP堆栈的通知。
    NotificationHandler
    用于从SCTP堆栈中消费通知的处理程序。
    PeerAddressChangeNotification
    多宿主对等体上的目标地址发生更改时发出的通知。
    PeerAddressChangeNotification.AddressChangeEvent
    定义在多宿主对等体遇到更改接口详细信息时发生到目标地址的地址更改事件的类型。
    SctpChannel
    用于面向消息的连接SCTP套接字的可选通道。
    SctpMultiChannel
    用于面向消息的SCTP套接字的可选通道。
    SctpServerChannel
    用于面向消息的侦听SCTP插座的可选通道。
    SctpSocketOption
    与SCTP通道相关联的插座选项。
    SctpStandardSocketOptions.InitMaxStreams
    此类用于设置关联初始化期间本地端点使用的入站/出站流的最大数量。
    SendFailedNotification
    收到发送失败通知时发出的通知。
    ShutdownNotification
    当对等体关闭关联时发出的通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.AbstractNotificationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.AbstractNotificationHandler

No usage of com.sun.nio.sctp.AbstractNotificationHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.Association (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.Association

  • Packages that use Association
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of Association in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return Association
      Modifier and Type 方法 描述
      abstract Association AssociationChangeNotification.association​()
      返回此通知适用的关联。
      abstract Association MessageInfo.association​()
      返回消息被接收的关联，如果已经接收到消息，否则将发送该消息的关联。
      Association Notification.association​()
      返回此通知适用的关联。
      abstract Association PeerAddressChangeNotification.association​()
      返回此通知适用的关联。
      abstract Association SctpChannel.association​()
      返回此通道的套接字上的关联。
      abstract Association SendFailedNotification.association​()
      返回此通知适用的关联。
      abstract Association ShutdownNotification.association​()
      返回此通知适用的关联。
      Methods in com.sun.nio.sctp that return types with arguments of type Association
      Modifier and Type 方法 描述
      abstract Set<Association> SctpMultiChannel.associations​()
      返回此通道的套接字上的打开关联。
      Methods in com.sun.nio.sctp with parameters of type Association
      Modifier and Type 方法 描述
      abstract SctpChannel SctpMultiChannel.branch​(Association association)
      分支协会。
      static MessageInfo MessageInfo.createOutgoing​(Association association, SocketAddress address, int streamNumber)
      创建一个适用于向给定关联发送消息时使用的 MessageInfo实例。
      abstract <T> T SctpMultiChannel.getOption​(SctpSocketOption<T> name, Association association)
      返回套接字选项的值。
      abstract Set<SocketAddress> SctpMultiChannel.getRemoteAddresses​(Association association)
      返回此通道的套接字连接给定关联的所有远程地址。
      abstract <T> SctpMultiChannel SctpMultiChannel.setOption​(SctpSocketOption<T> name, T value, Association association)
      设置套接字选项的值。
      abstract SctpMultiChannel SctpMultiChannel.shutdown​(Association association)
      关闭关联而不关闭通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.AssociationChangeNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.AssociationChangeNotification

  • Packages that use AssociationChangeNotification
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of AssociationChangeNotification in com.sun.nio.sctp

      Methods in com.sun.nio.sctp with parameters of type AssociationChangeNotification
      Modifier and Type 方法 描述
      HandlerResult AbstractNotificationHandler.handleNotification​(AssociationChangeNotification notification, T attachment)
      当从SCTP堆栈接收到AssociationChangeNotification时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.AssociationChangeNotification.AssocChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.AssociationChangeNotification.AssocChangeEvent

  • Packages that use AssociationChangeNotification.AssocChangeEvent
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of AssociationChangeNotification.AssocChangeEvent in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return AssociationChangeNotification.AssocChangeEvent
      Modifier and Type 方法 描述
      abstract AssociationChangeNotification.AssocChangeEvent AssociationChangeNotification.event​()
      返回更改事件的类型。
      static AssociationChangeNotification.AssocChangeEvent AssociationChangeNotification.AssocChangeEvent.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AssociationChangeNotification.AssocChangeEvent[] AssociationChangeNotification.AssocChangeEvent.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.HandlerResult (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.HandlerResult

  • Packages that use HandlerResult
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of HandlerResult in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return HandlerResult
      Modifier and Type 方法 描述
      HandlerResult AbstractNotificationHandler.handleNotification​(AssociationChangeNotification notification, T attachment)
      当从SCTP堆栈接收到AssociationChangeNotification时调用。
      HandlerResult AbstractNotificationHandler.handleNotification​(Notification notification, T attachment)
      当从SCTP堆栈接收到实现特定通知时调用。
      HandlerResult AbstractNotificationHandler.handleNotification​(PeerAddressChangeNotification notification, T attachment)
      当从SCTP堆栈接收到PeerAddressChangeNotification时调用。
      HandlerResult AbstractNotificationHandler.handleNotification​(SendFailedNotification notification, T attachment)
      当从SCTP堆栈接收到SendFailedNotification时调用。
      HandlerResult AbstractNotificationHandler.handleNotification​(ShutdownNotification notification, T attachment)
      当从SCTP堆栈接收到ShutdownNotification时调用。
      HandlerResult NotificationHandler.handleNotification​(Notification notification, T attachment)
      从SCTP堆栈收到通知时调用。
      static HandlerResult HandlerResult.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static HandlerResult[] HandlerResult.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.IllegalReceiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.IllegalReceiveException

No usage of com.sun.nio.sctp.IllegalReceiveException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.IllegalUnbindException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.IllegalUnbindException

No usage of com.sun.nio.sctp.IllegalUnbindException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.InvalidStreamException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.InvalidStreamException

No usage of com.sun.nio.sctp.InvalidStreamException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.MessageInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.MessageInfo

  • Packages that use MessageInfo
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of MessageInfo in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return MessageInfo
      Modifier and Type 方法 描述
      abstract MessageInfo MessageInfo.complete​(boolean complete)
      设置消息是否完成。
      static MessageInfo MessageInfo.createOutgoing​(Association association, SocketAddress address, int streamNumber)
      创建一个 MessageInfo实例，适用于向给定关联发送消息时使用。
      static MessageInfo MessageInfo.createOutgoing​(SocketAddress address, int streamNumber)
      创建一个适合在发送消息时使用的 MessageInfo实例。
      abstract MessageInfo MessageInfo.payloadProtocolID​(int ppid)
      设置有效载荷协议标识符。
      abstract <T> MessageInfo SctpChannel.receive​(ByteBuffer dst, T attachment, NotificationHandler<T> handler)
      在给定的缓冲区中接收消息和/或处理通知。
      abstract <T> MessageInfo SctpMultiChannel.receive​(ByteBuffer buffer, T attachment, NotificationHandler<T> handler)
      接收消息和/或通过此频道处理通知。
      abstract MessageInfo MessageInfo.streamNumber​(int streamNumber)
      设置要发送消息的流号。
      abstract MessageInfo MessageInfo.timeToLive​(long millis)
      设置发送方如果尚未发送消息的时间段。
      abstract MessageInfo MessageInfo.unordered​(boolean unordered)
      设置消息是否无序。
      Methods in com.sun.nio.sctp with parameters of type MessageInfo
      Modifier and Type 方法 描述
      abstract int SctpChannel.send​(ByteBuffer src, MessageInfo messageInfo)
      通过此频道发送消息。
      abstract int SctpMultiChannel.send​(ByteBuffer buffer, MessageInfo messageInfo)
      通过此频道发送消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.PeerAddressChangeNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.PeerAddressChangeNotification

  • Packages that use PeerAddressChangeNotification
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of PeerAddressChangeNotification in com.sun.nio.sctp

      Methods in com.sun.nio.sctp with parameters of type PeerAddressChangeNotification
      Modifier and Type 方法 描述
      HandlerResult AbstractNotificationHandler.handleNotification​(PeerAddressChangeNotification notification, T attachment)
      当从SCTP堆栈接收到PeerAddressChangeNotification时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.PeerAddressChangeNotification.AddressChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.PeerAddressChangeNotification.AddressChangeEvent

  • Packages that use PeerAddressChangeNotification.AddressChangeEvent
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of PeerAddressChangeNotification.AddressChangeEvent in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return PeerAddressChangeNotification.AddressChangeEvent
      Modifier and Type 方法 描述
      abstract PeerAddressChangeNotification.AddressChangeEvent PeerAddressChangeNotification.event​()
      返回更改事件的类型。
      static PeerAddressChangeNotification.AddressChangeEvent PeerAddressChangeNotification.AddressChangeEvent.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static PeerAddressChangeNotification.AddressChangeEvent[] PeerAddressChangeNotification.AddressChangeEvent.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.SctpChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.SctpChannel

  • Packages that use SctpChannel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of SctpChannel in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return SctpChannel
      Modifier and Type 方法 描述
      abstract SctpChannel SctpServerChannel.accept​()
      在此频道的套接字上接受关联。
      abstract SctpChannel SctpChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      abstract SctpChannel SctpChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpChannel SctpMultiChannel.branch​(Association association)
      分支协会。
      static SctpChannel SctpChannel.open​()
      打开SCTP通道。
      static SctpChannel SctpChannel.open​(SocketAddress remote, int maxOutStreams, int maxInStreams)
      打开SCTP通道并将其连接到远程地址。
      abstract <T> SctpChannel SctpChannel.setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
      abstract SctpChannel SctpChannel.shutdown​()
      关闭连接而不关闭通道。
      abstract SctpChannel SctpChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.SctpMultiChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.SctpMultiChannel

  • Packages that use SctpMultiChannel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of SctpMultiChannel in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return SctpMultiChannel
      Modifier and Type 方法 描述
      SctpMultiChannel SctpMultiChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SctpMultiChannel SctpMultiChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SctpMultiChannel SctpMultiChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      static SctpMultiChannel SctpMultiChannel.open​()
      打开SCTP多通道。
      abstract <T> SctpMultiChannel SctpMultiChannel.setOption​(SctpSocketOption<T> name, T value, Association association)
      设置套接字选项的值。
      abstract SctpMultiChannel SctpMultiChannel.shutdown​(Association association)
      关闭关联而不关闭通道。
      abstract SctpMultiChannel SctpMultiChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.SctpServerChannel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.SctpServerChannel

  • Packages that use SctpServerChannel
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of SctpServerChannel in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return SctpServerChannel
      Modifier and Type 方法 描述
      SctpServerChannel SctpServerChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract SctpServerChannel SctpServerChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract SctpServerChannel SctpServerChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      static SctpServerChannel SctpServerChannel.open​()
      打开SCTP服务器通道。
      abstract <T> SctpServerChannel SctpServerChannel.setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
      abstract SctpServerChannel SctpServerChannel.unbindAddress​(InetAddress address)
      Removes the given address from the bound addresses for the channel's socket.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.SctpStandardSocketOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.SctpStandardSocketOptions

No usage of com.sun.nio.sctp.SctpStandardSocketOptions
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.SctpStandardSocketOptions.InitMaxStreams (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.SctpStandardSocketOptions.InitMaxStreams

  • Packages that use SctpStandardSocketOptions.InitMaxStreams
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of SctpStandardSocketOptions.InitMaxStreams in com.sun.nio.sctp

      Fields in com.sun.nio.sctp with type parameters of type SctpStandardSocketOptions.InitMaxStreams
      Modifier and Type Field 描述
      static SctpSocketOption<SctpStandardSocketOptions.InitMaxStreams> SctpStandardSocketOptions.SCTP_INIT_MAXSTREAMS
      关联初始化期间本地端点请求的最大流数。
      Methods in com.sun.nio.sctp that return SctpStandardSocketOptions.InitMaxStreams
      Modifier and Type 方法 描述
      static SctpStandardSocketOptions.InitMaxStreams SctpStandardSocketOptions.InitMaxStreams.create​(int maxInStreams, int maxOutStreams)
      创建一个InitMaxStreams实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.SendFailedNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.SendFailedNotification

  • Packages that use SendFailedNotification
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of SendFailedNotification in com.sun.nio.sctp

      Methods in com.sun.nio.sctp with parameters of type SendFailedNotification
      Modifier and Type 方法 描述
      HandlerResult AbstractNotificationHandler.handleNotification​(SendFailedNotification notification, T attachment)
      从SCTP堆栈接收到SendFailedNotification时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.nio.sctp.ShutdownNotification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.nio.sctp.ShutdownNotification

  • Packages that use ShutdownNotification
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of ShutdownNotification in com.sun.nio.sctp

      Methods in com.sun.nio.sctp with parameters of type ShutdownNotification
      Modifier and Type 方法 描述
      HandlerResult AbstractNotificationHandler.handleNotification​(ShutdownNotification notification, T attachment)
      当从SCTP堆栈接收到ShutdownNotification时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.nio.sctp.Notification (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.nio.sctp.Notification

  • Packages that use Notification
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of Notification in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement Notification
      Modifier and Type Class 描述
      class  AssociationChangeNotification
      关联已打开或关闭时发出的通知。
      class  PeerAddressChangeNotification
      多宿主对等体上的目标地址发生更改时发出的通知。
      class  SendFailedNotification
      收到发送失败通知时发出的通知。
      class  ShutdownNotification
      当对等体关闭关联时发出的通知。
      Methods in com.sun.nio.sctp with parameters of type Notification
      Modifier and Type 方法 描述
      HandlerResult AbstractNotificationHandler.handleNotification​(Notification notification, T attachment)
      当从SCTP堆栈接收到实现特定通知时调用。
      HandlerResult NotificationHandler.handleNotification​(Notification notification, T attachment)
      Invoked when a notification is received from the SCTP stack.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.nio.sctp.NotificationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.nio.sctp.NotificationHandler

  • Packages that use NotificationHandler
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of NotificationHandler in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement NotificationHandler
      Modifier and Type Class 描述
      class  AbstractNotificationHandler<T>
      消耗通知并继续的骨架处理程序。
      Methods in com.sun.nio.sctp with parameters of type NotificationHandler
      Modifier and Type 方法 描述
      abstract <T> MessageInfo SctpChannel.receive​(ByteBuffer dst, T attachment, NotificationHandler<T> handler)
      在给定的缓冲区中接收消息和/或处理通知。
      abstract <T> MessageInfo SctpMultiChannel.receive​(ByteBuffer buffer, T attachment, NotificationHandler<T> handler)
      接收消息和/或通过此频道处理通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.nio.sctp.SctpSocketOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.nio.sctp.SctpSocketOption

  • Packages that use SctpSocketOption
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。

    • Uses of SctpSocketOption in com.sun.nio.sctp

      Fields in com.sun.nio.sctp declared as SctpSocketOption
      Modifier and Type Field 描述
      static SctpSocketOption<Boolean> SctpStandardSocketOptions.SCTP_DISABLE_FRAGMENTS
      启用或禁用消息碎片。
      static SctpSocketOption<Boolean> SctpStandardSocketOptions.SCTP_EXPLICIT_COMPLETE
      启用或禁用显式消息完成。
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SCTP_FRAGMENT_INTERLEAVE
      分段交错控制消息接收器的消息呈现方式。
      static SctpSocketOption<SctpStandardSocketOptions.InitMaxStreams> SctpStandardSocketOptions.SCTP_INIT_MAXSTREAMS
      关联初始化期间本地端点请求的最大流数。
      static SctpSocketOption<Boolean> SctpStandardSocketOptions.SCTP_NODELAY
      启用或禁用类似Nagle的算法。
      static SctpSocketOption<SocketAddress> SctpStandardSocketOptions.SCTP_PRIMARY_ADDR
      请求本地SCTP堆栈使用给定对等体地址作为关联主节点。
      static SctpSocketOption<SocketAddress> SctpStandardSocketOptions.SCTP_SET_PEER_PRIMARY_ADDR
      请求对等方将附带的地址标记为关联主。
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SO_LINGER
      如果数据存在，则关闭。
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SO_RCVBUF
      套接字的大小接收缓冲区。
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SO_SNDBUF
      套接字发送缓冲区的大小。
      Methods in com.sun.nio.sctp that return types with arguments of type SctpSocketOption
      Modifier and Type 方法 描述
      abstract Set<SctpSocketOption<?>> SctpChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。
      abstract Set<SctpSocketOption<?>> SctpMultiChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。
      abstract Set<SctpSocketOption<?>> SctpServerChannel.supportedOptions​()
      返回此通道支持的一组套接字选项。
      Methods in com.sun.nio.sctp with parameters of type SctpSocketOption
      Modifier and Type 方法 描述
      abstract <T> T SctpChannel.getOption​(SctpSocketOption<T> name)
      返回套接字选项的值。
      abstract <T> T SctpMultiChannel.getOption​(SctpSocketOption<T> name, Association association)
      返回套接字选项的值。
      abstract <T> T SctpServerChannel.getOption​(SctpSocketOption<T> name)
      返回套接字选项的值。
      abstract <T> SctpChannel SctpChannel.setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
      abstract <T> SctpMultiChannel SctpMultiChannel.setOption​(SctpSocketOption<T> name, T value, Association association)
      设置套接字选项的值。
      abstract <T> SctpServerChannel SctpServerChannel.setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.auth (Java SE 9 & JDK 9 )

com.sun.security.auth

Interfaces

  • PrincipalComparator

Classes

  • LdapPrincipal
  • NTDomainPrincipal
  • NTNumericCredential
  • NTSid
  • NTSidDomainPrincipal
  • NTSidGroupPrincipal
  • NTSidPrimaryGroupPrincipal
  • NTSidUserPrincipal
  • NTUserPrincipal
  • PolicyFile
  • SolarisNumericGroupPrincipal
  • SolarisNumericUserPrincipal
  • SolarisPrincipal
  • UnixNumericGroupPrincipal
  • UnixNumericUserPrincipal
  • UnixPrincipal
  • UserPrincipal
  • X500Principal


com.sun.security.auth (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.security.auth

Package com.sun.security.auth

提供Principal的实现。
从以下版本开始：
1.4
  • 接口摘要
    接口 描述
    PrincipalComparator
    实现 java.security.Principal接口的对象通常还实现了该接口，以提供将该对象与指定的 Subject进行比较的 Subject 。
  • 类摘要
    Class 描述
    LdapPrincipal
    由 RFC 2253指定的专有名称确定的 主体 。
    NTDomainPrincipal
    该类实现了 Principal接口，并表示用户认证的Windows NT域的名称。
    NTNumericCredential
    该类抽象出一个NT安全性令牌，并提供了一种进行相同进程安全模拟的机制。
    NTSid
    该类实现了 Principal接口，并表示有关Windows NT用户，组或领域的信息。
    NTSidDomainPrincipal
    此类扩展为 NTSid ，表示Windows NT用户的域SID。
    NTSidGroupPrincipal
    此类扩展了 NTSid并表示Windows NT用户所属的组之一。
    NTSidPrimaryGroupPrincipal
    此类扩展为 NTSid ，表示Windows NT用户的主组SID。
    NTSidUserPrincipal
    该类扩展了 NTSid ，代表了Windows NT用户的SID。
    NTUserPrincipal
    该类实现了 Principal接口，代表了Windows NT用户。
    PolicyFile Deprecated, for removal: This API element is subject to removal in a future version.
    截至JDK 1.4，由sun.security.provider.PolicyFile取代。
    SolarisNumericGroupPrincipal Deprecated, for removal: This API element is subject to removal in a future version.
    截至JDK 1.4，由UnixNumericGroupPrincipal替代。
    SolarisNumericUserPrincipal Deprecated, for removal: This API element is subject to removal in a future version.
    截至JDK 1.4，由UnixNumericUserPrincipal取代。
    SolarisPrincipal Deprecated, for removal: This API element is subject to removal in a future version.
    截至JDK 1.4，由UnixPrincipal取代。
    UnixNumericGroupPrincipal
    该类实现了 Principal接口，代表用户的Unix组标识号（GID）。
    UnixNumericUserPrincipal
    该类实现了 Principal接口，代表用户的Unix标识号（UID）。
    UnixPrincipal
    该类实现了 Principal接口，代表了Unix用户。
    UserPrincipal
    由用户名或帐户名称标识的用户主体。
    X500Principal Deprecated, for removal: This API element is subject to removal in a future version.
    Java平台中提供了一个新的X500Principal类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.auth Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.security.auth

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.security.auth.LdapPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.NTDomainPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.NTNumericCredential
    • com.sun.security.auth.NTSid (implements java.security.Principal, java.io.Serializable)
      • com.sun.security.auth.NTSidDomainPrincipal
      • com.sun.security.auth.NTSidGroupPrincipal
      • com.sun.security.auth.NTSidPrimaryGroupPrincipal
      • com.sun.security.auth.NTSidUserPrincipal
    • com.sun.security.auth.NTUserPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.Policy
      • com.sun.security.auth.PolicyFile
    • com.sun.security.auth.SolarisNumericGroupPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.SolarisNumericUserPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.SolarisPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.UnixNumericGroupPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.UnixNumericUserPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.UnixPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.UserPrincipal (implements java.security.Principal, java.io.Serializable)
    • com.sun.security.auth.X500Principal (implements java.security.Principal, java.io.Serializable)

Interface Hierarchy

  • com.sun.security.auth.PrincipalComparator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


LdapPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class LdapPrincipal

  • java.lang.Object
    • com.sun.security.auth.LdapPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public final class LdapPrincipal
extends Object
implements Principal, Serializable
    由RFC 2253指定的专有名称确定的主体 。

    在成功认证之后，用户Principal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 授权决定可以基于与Principal相关联的Subject 。

    这个类是不可变的。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LdapPrincipal​(String name)
      创建一个LDAP主体。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object object)
      将此主体与指定对象进行比较。
      String getName​()
      返回最初用于创建此主体的名称。
      int hashCode​()
      计算此主体的哈希码。
      String toString​()
      以 RFC 2253定义的格式创建此主体名称的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • LdapPrincipal

        public LdapPrincipal​(String name)
              throws InvalidNameException
        创建一个LDAP主体。
        参数
        name - 校长的字符串识别名称。
        异常
        InvalidNameException - 如果检测到语法违规。
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • equals

        public boolean equals​(Object object)
        将此主体与指定对象进行比较。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        object - 将此主体与之对比的对象。
        结果
        如果他们是平等的话; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此主体的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        校长的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getName

        public String getName​()
        返回最初用于创建此主体的名称。
        Specified by:
        getName在接口 Principal
        结果
        校长的字符串名称。

      • toString

        public String toString​()
        以RFC 2253定义的格式创建此主体名称的字符串表示形式。 如果名称具有零个组件，则返回一个空字符串。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        The principal's string name.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTDomainPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTDomainPrincipal

  • java.lang.Object
    • com.sun.security.auth.NTDomainPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class NTDomainPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，并表示用户认证的Windows NT域的名称。 如果用户登录到Windows NT域，如果用户登录到工作组中，则为工作组名称，如果用户登录到独立配置，则为域名。

    诸如这个NTDomainPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTDomainPrincipal​(String name)
      创建一个具有Windows NT域名的 NTDomainPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTDomainPrincipal进行比较以获得相等性。
      String getName​()
      返回这个 NTDomainPrincipal的Windows NT域名。
      int hashCode​()
      返回这个 NTDomainPrincipal的哈希码。
      String toString​()
      返回这个 NTDomainPrincipal的字符串表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • NTDomainPrincipal

        public NTDomainPrincipal​(String name)
        使用Windows NT域名创建一个 NTDomainPrincipal 。
        参数
        name - 该用户的Windows NT域名。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • getName

        public String getName​()
        返回这个 NTDomainPrincipal的Windows NT域名。
        Specified by:
        getName在接口 Principal
        结果
        Windows NT域名为这个 NTDomainPrincipal

      • toString

        public String toString​()
        返回此 NTDomainPrincipal的字符串表示 NTDomainPrincipal 。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 NTDomainPrincipal的字符串表示 NTDomainPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTDomainPrincipal进行比较以获得相等性。 如果给定的对象也是一个NTDomainPrincipal ，并且两个NTDomainPrincipals具有相同的名称，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 与此 NTDomainPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于这个 NTDomainPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个 NTDomainPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 NTDomainPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTNumericCredential (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTNumericCredential

  • java.lang.Object
    • com.sun.security.auth.NTNumericCredential

  • public class NTNumericCredential
extends Object
    该类抽象出一个NT安全性令牌，并提供了一种进行相同进程安全模拟的机制。

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTNumericCredential​(long token)
      创建一个具有整数值的 NTNumericCredential 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTNumericCredential进行比较以获得相等性。
      long getToken​()
      返回此 NTNumericCredential的整数表示。
      int hashCode​()
      返回这个 NTNumericCredential的哈希码。
      String toString​()
      返回这个 NTNumericCredential的字符串表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NTNumericCredential

        public NTNumericCredential​(long token)
        创建一个具有整数值的 NTNumericCredential 。
        参数
        token - 此用户的Windows NT安全令牌。

    • 方法详细信息

      • getToken

        public long getToken​()
        返回此 NTNumericCredential的整数表示。
        结果
        这个 NTNumericCredential的整数表示 NTNumericCredential 。

      • toString

        public String toString​()
        返回此 NTNumericCredential的字符串表示 NTNumericCredential 。
        重写：
        toString在 Object
        结果
        这个 NTNumericCredential的字符串表示 NTNumericCredential 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTNumericCredential进行比较以获得相等性。 如果给定对象也是一个NTNumericCredential ，并且两个NTNumericCredentials表示相同的NT安全令牌，则返回true。
        重写：
        equals Object
        参数
        o - 要与此 NTNumericCredential进行平等比较的对象。
        结果
        如果指定的对象等于此 NTNumericCredential 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个 NTNumericCredential的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 NTNumericCredential的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTSid (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTSid

  • java.lang.Object
    • com.sun.security.auth.NTSid
  • All Implemented Interfaces:
    Serializable ， Principal
    已知直接子类：
    NTSidDomainPrincipal ， NTSidGroupPrincipal ， NTSidPrimaryGroupPrincipal ， NTSidUserPrincipal

    public class NTSid
extends Object
implements Principal, Serializable
    该类实现了Principal接口，并表示有关Windows NT用户，组或领域的信息。

    Windows NT选择表示用户，组和领域（或域），不仅具有通用名称，而且还包含相对唯一的数字。 这些数字称为安全标识符（SID）。 Windows NT还提供将这些SID呈现为字符串形式的服务。 这个类代表这些字符串形式。

    诸如这个NTSid可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTSid​(String stringSid)
      使用Windows NT SID创建一个 NTSid 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTSid进行比较以获得相等性。
      String getName​()
      返回这个 NTSid的字符串版本。
      int hashCode​()
      返回这个 NTSid的哈希码。
      String toString​()
      返回此 NTSid的字符串表示 NTSid 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • NTSid

        public NTSid​(String stringSid)
        使用Windows NT SID创建一个 NTSid 。
        参数
        stringSid - Windows NT SID。
        异常
        NullPointerException - 如果 String是 null 。
        IllegalArgumentException - 如果 String长度为零。

    • 方法详细信息

      • getName

        public String getName​()
        返回这个 NTSid的字符串版本。
        Specified by:
        getName在接口 Principal
        结果
        一个字符串版本的这个 NTSid

      • toString

        public String toString​()
        返回此 NTSid的字符串表示 NTSid 。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 NTSid的字符串表示 NTSid 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTSid进行比较以获得相等性。 如果给定的对象也是一个NTSid ，并且两个NTSids具有相同的String表示NTSid ，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 与此 NTSid进行平等比较的对象。
        结果
        如果指定的对象等于此， NTSid 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个 NTSid的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 NTSid的哈希码。
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTSidDomainPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTSidDomainPrincipal

  • java.lang.Object
    • com.sun.security.auth.NTSid
      • com.sun.security.auth.NTSidDomainPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class NTSidDomainPrincipal
extends NTSid
    该类扩展了NTSid ，代表Windows NT用户的域SID。

    如果NT用户实际上登录到NT域，则只有一个域SID。 如果用户登录到一个工作组或只是一个独立的配置，他们将不会有域SID。

    诸如这个NTSidDomainPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTSidDomainPrincipal​(String name)
      使用Windows NT SID创建一个 NTSidDomainPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTSidDomainPrincipal进行比较以获得相等性。
      String toString​()
      返回这个 NTSidDomainPrincipal的字符串表示。

      • Methods inherited from class com.sun.security.auth.NTSid

        getName, hashCode

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • NTSidDomainPrincipal

        public NTSidDomainPrincipal​(String name)
        使用Windows NT SID创建一个 NTSidDomainPrincipal 。
        参数
        name - 此用户域的Windows NT SID的字符串版本。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • toString

        public String toString​()
        返回此 NTSidDomainPrincipal的字符串表示 NTSidDomainPrincipal 。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 NTSid
        结果
        这个 NTSidDomainPrincipal的字符串表示 NTSidDomainPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTSidDomainPrincipal进行比较以获得相等性。 如果给定的对象也是一个NTSidDomainPrincipal ，并且两个NTSidDomainPrincipals具有相同的SID，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 NTSid
        参数
        o - 与 NTSidDomainPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于此 NTSidDomainPrincipal 。
        另请参见：
        Object.hashCode(), HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTSidGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTSidGroupPrincipal

  • java.lang.Object
    • com.sun.security.auth.NTSid
      • com.sun.security.auth.NTSidGroupPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class NTSidGroupPrincipal
extends NTSid
    此类扩展为NTSid ，代表Windows NT用户所属的组之一。

    诸如这个NTSidGroupPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， NTSid ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTSidGroupPrincipal​(String name)
      创建一个具有Windows NT组名称的 NTSidGroupPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTSidGroupPrincipal进行比较以获得相等性。
      String toString​()
      返回这个 NTSidGroupPrincipal的字符串表示。

      • Methods inherited from class com.sun.security.auth.NTSid

        getName, hashCode

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • NTSidGroupPrincipal

        public NTSidGroupPrincipal​(String name)
        创建一个具有Windows NT组名称的 NTSidGroupPrincipal 。
        参数
        name - 该用户的Windows NT组SID。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • toString

        public String toString​()
        返回这个 NTSidGroupPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 NTSid
        结果
        这个 NTSidGroupPrincipal的字符串表示 NTSidGroupPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTSidGroupPrincipal进行比较以获得相等性。 如果给定的对象也是一个NTSidGroupPrincipal ，并且两个NTSidGroupPrincipals具有相同的SID，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 NTSid
        参数
        o - 要与此 NTSidGroupPrincipal相等的对象。
        结果
        如果指定的对象等于此 NTSidGroupPrincipal 。
        另请参见：
        Object.hashCode(), HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTSidPrimaryGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTSidPrimaryGroupPrincipal

  • java.lang.Object
    • com.sun.security.auth.NTSid
      • com.sun.security.auth.NTSidPrimaryGroupPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class NTSidPrimaryGroupPrincipal
extends NTSid
    此类扩展为NTSid ，表示Windows NT用户的主组SID。

    诸如这个NTSidPrimaryGroupPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTSidPrimaryGroupPrincipal​(String name)
      使用Windows NT组SID创建一个 NTSidPrimaryGroupPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTSidPrimaryGroupPrincipal进行比较以获得相等性。
      String toString​()
      返回这个 NTSidPrimaryGroupPrincipal的字符串表示。

      • Methods inherited from class com.sun.security.auth.NTSid

        getName, hashCode

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • NTSidPrimaryGroupPrincipal

        public NTSidPrimaryGroupPrincipal​(String name)
        使用Windows NT组SID创建一个 NTSidPrimaryGroupPrincipal 。
        参数
        name - 此用户的主Windows NT组SID。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • toString

        public String toString​()
        返回这个 NTSidPrimaryGroupPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 NTSid
        结果
        这个 NTSidPrimaryGroupPrincipal的字符串表示 NTSidPrimaryGroupPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTSidPrimaryGroupPrincipal进行比较以获得相等性。 如果给定的对象也是一个NTSidPrimaryGroupPrincipal ，并且两个NTSidPrimaryGroupPrincipals具有相同的SID，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在类 NTSid
        参数
        o - 与此 NTSidPrimaryGroupPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于此 NTSidPrimaryGroupPrincipal 。
        另请参见：
        Object.hashCode(), HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTSidUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTSidUserPrincipal

  • java.lang.Object
    • com.sun.security.auth.NTSid
      • com.sun.security.auth.NTSidUserPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class NTSidUserPrincipal
extends NTSid
    此类扩展为NTSid ，表示Windows NT用户的SID。

    诸如这个NTSidUserPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTSidUserPrincipal​(String name)
      使用Windows NT SID创建一个 NTSidUserPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTSidUserPrincipal进行比较以获得相等性。
      String toString​()
      返回此 NTSidUserPrincipal的字符串表示 NTSidUserPrincipal 。

      • Methods inherited from class com.sun.security.auth.NTSid

        getName, hashCode

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • NTSidUserPrincipal

        public NTSidUserPrincipal​(String name)
        使用Windows NT SID创建一个 NTSidUserPrincipal 。
        参数
        name - 此用户的Windows NT SID的字符串版本。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • toString

        public String toString​()
        返回这个 NTSidUserPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在类 NTSid
        结果
        这个 NTSidUserPrincipal的字符串表示 NTSidUserPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTSidUserPrincipal进行比较以获得相等性。 如果给定对象也是一个NTSidUserPrincipal ，并且两个NTSidUserPrincipals具有相同的SID，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 NTSid
        参数
        o - 要与此 NTSidUserPrincipal进行比较的对象。
        结果
        如果指定的对象等于这个 NTSidUserPrincipal 。
        另请参见：
        Object.hashCode(), HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class NTUserPrincipal

  • java.lang.Object
    • com.sun.security.auth.NTUserPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class NTUserPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，代表了Windows NT用户。

    诸如这个NTUserPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTUserPrincipal​(String name)
      创建一个具有Windows NT用户名的 NTUserPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 NTUserPrincipal进行比较以获得相等性。
      String getName​()
      返回这个 NTPrincipal的Windows NT用户名。
      int hashCode​()
      返回这个 NTUserPrincipal的哈希码。
      String toString​()
      返回这个 NTPrincipal的字符串表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • NTUserPrincipal

        public NTUserPrincipal​(String name)
        使用Windows NT用户名创建一个 NTUserPrincipal 。
        参数
        name - 此用户的Windows NT用户名。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • getName

        public String getName​()
        返回这个 NTPrincipal的Windows NT用户名。
        Specified by:
        getName在接口 Principal
        结果
        Windows NT用户名为这个 NTPrincipal

      • toString

        public String toString​()
        返回这个 NTPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 NTPrincipal的字符串表示 NTPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此NTUserPrincipal进行比较以获得相等性。 如果给定对象也是一个NTUserPrincipal ，并且两个NTUserPrincipals具有相同的名称，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 要与此 NTPrincipal相等的对象。
        结果
        如果指定的对象等于这个 NTPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个 NTUserPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 NTUserPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PolicyFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class PolicyFile

  • java.lang.Object
    • javax.security.auth.Policy
      • com.sun.security.auth.PolicyFile
  • 不推荐用于删除：此API元素将在以后的版本中被删除。
    截至JDK 1.4，由sun.security.provider.PolicyFile替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="1.4",
            forRemoval=true)
public class PolicyFile
extends Policy
    此类代表javax.security.auth.Policy的默认实现。

    此对象存储整个Java运行时的策略，并且是驻留在文件中的多个静态策略配置的合并。 用于定位策略文件并将其信息读入此Policy对象的算法是：

    1. 循环安全属性auth.policy.url.1 ， auth.policy.url.2 ，...， auth.policy.url.X “。每个属性值指定一个URL指向要加载的策略文件。读入并加载每个策略。
    2. java.lang.System属性java.security.auth.policy也可以设置为指向另一个策略文件（在用户在运行时使用-D开关的情况下）的URL 。 如果定义了此属性，并且安全属性文件（Security属性policy.allowSystemProperty设置为true ）允许其使用，则还会加载该策略。
    3. 如果使用“==”（而不是“=”）定义了java.security.auth.policy属性，则忽略所有其他指定的策略，并且仅加载此策略。
    每个策略文件由一个或多个授权条目组成，每个条目由许多权限条目组成。
      grant signedBy "alias", codeBase "URL",
         principal principalClass "principalName",
         principal principalClass "principalName",
         ... {

     permission Type "name "action",
         signedBy "alias";
     permission Type "name "action",
         signedBy "alias";
     ....
   };
    以上所有非粗体项目必须按原样显示（尽管情况并不重要，有些则是可选的，如下所述）。 斜体表示变量值。

    授权条目必须以字母grant 。 signedBy和codeBase名称/值对是可选的。 如果它们不存在，则任何签名者（包括未签名的代码）将匹配，并且任何codeBase将匹配。 请注意， principal名称/值对不是可选的。 这个Policy实现只允许基于主体的授权条目。 请注意， principalClass可以设置为通配符值*，它允许它匹配任何Principal类。 此外， principalName也可以设置为通配符值*，允许它匹配任何Principal名称。 当将principalName设置为*时，不要用引号括住*。

    许可条目必须以字母permission 。 上述模板中的字Type是一个特定的权限类型，如java.io.FilePermission或java.lang.RuntimePermission 。

    对于许多许可类型，例如java.io.FilePermission （其中指定允许的文件访问类型）是必需的“ 动作 ”。 对于不需要的类别， java.lang.RuntimePermission ，您必须具有“ name ”值以下类型名称指定的权限，否则您不需要。

    权限条目的signedBy名称/值对是可选的。 如果存在，表示已签署的许可。 也就是说，许可类本身必须由给定的别名签名才能被授予。 例如，假设您有以下授权条目：

      grant principal foo.com.Principal "Duke" {
     permission Foo "foobar", signedBy "FooSoft";
   }

    那么如果“FooSoft”别名已经签署了Foo.class权限，或者如果Foo.class是系统类（即在CLASSPATH上找到），则授予类型为Foo的此权限。

    出现在条目中的项目必须以指定的顺序（ permission ， 类型 ，“ 名称 ”和“ 操作 ”）显示。 条目以分号终止。

    案例是不重要的标识符（ permission ， signedBy ， codeBase ，等等），但显著的类型或传递中作为一个值的字符串。

    策略配置文件中的两个条目的示例是

      // if the code is comes from "foo.com" and is running as "Duke",
   // grant it read/write to all files in /tmp.

   grant codeBase "foo.com", principal foo.com.Principal "Duke" {
              permission java.io.FilePermission "/tmp/*", "read,write";
   };

   // grant any code running as "Duke" permission to read
   // the "java.vendor" Property.

   grant principal foo.com.Principal "Duke" {
         permission java.util.PropertyPermission "java.vendor";

    这个Policy实现支持Policy特殊处理。 如果授权条目配置了PrivateCredentialPermission ，以及“主体类/主体名称”为PrivateCredentialPermission的“自我”，则该条目授予指定Subject权限来访问自己的私有证书。 例如，以下授权Subject “公爵”访问自己的abCredential。

      grant principal foo.com.Principal "Duke" {
      permission javax.security.auth.PrivateCredentialPermission
              "a.b.Credential self",
              "read";
    };
    以下授予Subject “Duke”访问所有自己的私人凭证：
      grant principal foo.com.Principal "Duke" {
      permission javax.security.auth.PrivateCredentialPermission
              "* self",
              "read";
    };
    以下授权所有被认证为SolarisPrincipal （无论其各自的名称）的主体是否允许访问自己的私有凭据：
      grant principal com.sun.security.auth.SolarisPrincipal * {
      permission javax.security.auth.PrivateCredentialPermission
              "* self",
              "read";
    };
    以下授权所有Subjects权限访问自己的私有凭据：
      grant principal * * {
      permission javax.security.auth.PrivateCredentialPermission
              "* self",
              "read";
    };
    另请参见：
    CodeSource ， Permissions ， ProtectionDomain ， security properties

    • 构造方法摘要

      构造方法
      Constructor 描述
      PolicyFile​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      初始化Policy对象，并将默认策略配置文件读入Policy对象。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      PermissionCollection getPermissions​(Subject subject, CodeSource codesource)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      检查此 Policy并返回授予给指定的 Subject和 CodeSource的权限。
      void refresh​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      通过重新读取所有策略文件来刷新策略对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class javax.security.auth.Policy

        getPolicy, setPolicy

    • 构造方法详细信息

      • PolicyFile

        public PolicyFile​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        初始化Policy对象，并将默认策略配置文件读入Policy对象。

    • 方法详细信息

      • refresh

        public void refresh​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        通过重新读取所有策略文件来刷新策略对象。
        Specified by:
        refresh在类 Policy
        异常
        SecurityException - 如果来电者没有权限刷新 Policy 。

      • getPermissions

        public PermissionCollection getPermissions​(Subject subject,
                                           CodeSource codesource)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        检查此Policy并返回授予给指定的Subject和CodeSource的权限。

        对于特定的授权条目权限返回如果CodeSource利用在条目中指定的基本代码和signedby值构建implies的CodeSource提供给这个方法，并且如果Subject提供给该方法包含了所有在条目中指定的主体。

        提供给此方法的Subject包含条目中指定的所有主体，如果对于每个Principal ，在授予条目中指定的“P1”满足以下两个条件之一：

        1. Subject有一个Principal “P2”，其中P2.getClass().getName()等于P1的类名，其中P2.getName()等于P1的名字。
        2. P1实现com.sun.security.auth.PrincipalComparator ，和P1.implies提供的Subject 。

        请注意，这个Policy实现对PrivateCredentialPermissions有特殊处理。 当这种方法遇到一个PrivateCredentialPermission ，其中指定“self”作为Principal类和名称，它不会将Permission添加到返回的PermissionCollection 。 相反，它建立了一个新的PrivateCredentialPermission每个Principal与所提供的相关Subject 。 每个新的PrivateCredentialPermission包含与最初授予的权限中指定的相同的凭证类，以及相应的Principal的类和名称。

        Specified by:
        getPermissions在 Policy
        参数
        subject - 返回授予此 Subject的权限和附加提供的 CodeSource 。
        codesource - 返回授予 CodeSource和附加提供的 Subject的权限。
        结果
        授予 Subject CodeSource的权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrincipalComparator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Interface PrincipalComparator

  • public interface PrincipalComparator
    实现java.security.Principal接口的对象通常还实现了该接口，以提供将该对象与指定的Subject进行比较的手段。

    比较通过implies方法实现。 执行implies方法确定此对象是否“暗示”指定的Subject 。 该方法的一个示例应用可以是“组”对象意味着特定的Subject如果该Subject属于该组。 此方法的另一个示例应用将是“角色”对象暗示特定的Subject如果该Subject当前正在扮演的角色。

    虽然实现此接口的类通常也会实现java.security.Principal接口，但不是必需的。 换句话说，类可以实现java.security.Principal本身的界面， PrincipalComparator本身，或者两者同时接口。

    另请参见：
    Principal ， Subject

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean implies​(Subject subject)
      检查该对象是否暗示了指定的 Subject 。

    • 方法详细信息

      • implies

        boolean implies​(Subject subject)
        检查该对象是否暗示了指定的 Subject 。
        结果
        如果指定的 Subject被该对象隐含， Subject true，否则为false。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SolarisNumericGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class SolarisNumericGroupPrincipal

  • java.lang.Object
    • com.sun.security.auth.SolarisNumericGroupPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal
    不推荐用于删除：此API元素将在以后的版本中被删除。
    截至JDK 1.4，由UnixNumericGroupPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="1.4",
            forRemoval=true)
public class SolarisNumericGroupPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，代表用户的Solaris组标识号（GID）。

    诸如这个SolarisNumericGroupPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject类。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SolarisNumericGroupPrincipal​(long name, boolean primaryGroup)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      使用用户组标识号（GID）的长表示法创建 SolarisNumericGroupPrincipal 。
      SolarisNumericGroupPrincipal​(String name, boolean primaryGroup)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      使用 String表示用户组标识号（GID）创建一个 SolarisNumericGroupPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      将指定的对象与此 SolarisNumericGroupPrincipal进行比较以获得相等性。
      String getName​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回此 SolarisNumericGroupPrincipal的用户组标识号（GID）。
      int hashCode​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisNumericGroupPrincipal的哈希码。
      boolean isPrimaryGroup​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回此组标识号（GID）是否表示此用户所属的主组。
      long longValue​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisNumericGroupPrincipal的用户组标识号（GID）长。
      String toString​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisNumericGroupPrincipal的字符串表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • SolarisNumericGroupPrincipal

        public SolarisNumericGroupPrincipal​(String name,
                                    boolean primaryGroup)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        使用 String表示用户组标识号（GID）创建一个 SolarisNumericGroupPrincipal 。
        参数
        name - 该用户的用户组标识号（GID）。
        primaryGroup - 如果指定的GID表示此用户所属的主组， primaryGroup true。
        异常
        NullPointerException - 如果 name是 null 。

      • SolarisNumericGroupPrincipal

        public SolarisNumericGroupPrincipal​(long name,
                                    boolean primaryGroup)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        使用用户组标识号（GID）的长表示创建 SolarisNumericGroupPrincipal 。
        参数
        name - 该用户的用户组标识号（GID）表示为长。
        primaryGroup - 如果指定的GID表示此用户所属的主组， primaryGroup true。

    • 方法详细信息

      • getName

        public String getName​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回此 SolarisNumericGroupPrincipal的用户组标识号（GID）。
        Specified by:
        getName在接口 Principal
        结果
        该用户的组标识号（GID）为 SolarisNumericGroupPrincipal

      • longValue

        public long longValue​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisNumericGroupPrincipal的用户组标识号（GID）长。
        结果
        该用户的组标识号（GID）为 SolarisNumericGroupPrincipal为长。

      • isPrimaryGroup

        public boolean isPrimaryGroup​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回此组标识号（GID）是否表示此用户所属的主组。
        结果
        如果此组标识号（GID）表示此用户所属的主组，则为true，否则为false。

      • toString

        public String toString​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisNumericGroupPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 SolarisNumericGroupPrincipal的字符串表示 SolarisNumericGroupPrincipal 。

      • equals

        public boolean equals​(Object o)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        将指定的对象与此SolarisNumericGroupPrincipal进行比较以获得相等性。 如果给定的对象也是一个SolarisNumericGroupPrincipal ，并且两个SolarisNumericGroupPrincipals具有相同的组标识号（GID），则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 要与此 SolarisNumericGroupPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于此 SolarisNumericGroupPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisNumericGroupPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 SolarisNumericGroupPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SolarisNumericUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class SolarisNumericUserPrincipal

  • java.lang.Object
    • com.sun.security.auth.SolarisNumericUserPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal
    不推荐用于删除：此API元素将在以后的版本中被删除。
    截至JDK 1.4，由UnixNumericUserPrincipal替换。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="1.4",
            forRemoval=true)
public class SolarisNumericUserPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，代表用户的Solaris标识号（UID）。

    诸如这个SolarisNumericUserPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SolarisNumericUserPrincipal​(long name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      使用用户标识号（UID）的长表示形式创建 SolarisNumericUserPrincipal 。
      SolarisNumericUserPrincipal​(String name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      使用用户标识号（UID）的 String表示创建一个 SolarisNumericUserPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      将指定的对象与此 SolarisNumericUserPrincipal进行比较以获得相等性。
      String getName​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回此 SolarisNumericUserPrincipal的用户标识号（UID）。
      int hashCode​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisNumericUserPrincipal的哈希码。
      long longValue​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisNumericUserPrincipal的用户标识号（UID）长。
      String toString​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisNumericUserPrincipal的字符串表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • SolarisNumericUserPrincipal

        public SolarisNumericUserPrincipal​(String name)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        使用用户标识号（UID）的 String表示创建 SolarisNumericUserPrincipal 。
        参数
        name - 此用户的用户标识号（UID）。
        异常
        NullPointerException - 如果 name是 null 。

      • SolarisNumericUserPrincipal

        public SolarisNumericUserPrincipal​(long name)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        使用用户标识号（UID）的长表示法创建 SolarisNumericUserPrincipal 。
        参数
        name - 此用户的用户标识号（UID）表示为长。

    • 方法详细信息

      • getName

        public String getName​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回此 SolarisNumericUserPrincipal的用户标识号（UID）。
        Specified by:
        getName在接口 Principal
        结果
        该用户识别码（UID）为 SolarisNumericUserPrincipal

      • longValue

        public long longValue​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisNumericUserPrincipal的用户标识号（UID）长。
        结果
        用户标识号（UID）为这个 SolarisNumericUserPrincipal为长。

      • toString

        public String toString​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisNumericUserPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 SolarisNumericUserPrincipal的字符串表示 SolarisNumericUserPrincipal 。

      • equals

        public boolean equals​(Object o)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        将指定的对象与此SolarisNumericUserPrincipal进行比较以获得相等性。 如果给定对象也是一个SolarisNumericUserPrincipal ，并且两个SolarisNumericUserPrincipals具有相同的用户标识号（UID），则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在类 Object
        参数
        o - 要与此 SolarisNumericUserPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于这个 SolarisNumericUserPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisNumericUserPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 SolarisNumericUserPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SolarisPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class SolarisPrincipal

  • java.lang.Object
    • com.sun.security.auth.SolarisPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal
    不推荐用于删除：此API元素将在以后的版本中被删除。
    截至JDK 1.4，由UnixPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="1.4",
            forRemoval=true)
public class SolarisPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，代表了Solaris用户。

    诸如这个SolarisPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SolarisPrincipal​(String name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      使用Solaris用户名创建SolarisPrincipal。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      将指定的对象与此 SolarisPrincipal进行比较以获得相等性。
      String getName​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回此 SolarisPrincipal的Unix用户名。
      int hashCode​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisPrincipal的哈希码。
      String toString​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 SolarisPrincipal的字符串表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • SolarisPrincipal

        public SolarisPrincipal​(String name)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        使用Solaris用户名创建SolarisPrincipal。
        参数
        name - 该用户的Unix用户名。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • getName

        public String getName​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回此 SolarisPrincipal的Unix用户名。
        Specified by:
        getName在接口 Principal
        结果
        Unix用户名为 SolarisPrincipal

      • toString

        public String toString​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 SolarisPrincipal的字符串表示 SolarisPrincipal 。

      • equals

        public boolean equals​(Object o)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        将指定的对象与此SolarisPrincipal进行比较以获得相等性。 如果给定对象也是一个SolarisPrincipal ，并且两个SolarisPrincipals具有相同的用户名，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 与 SolarisPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于这个 SolarisPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 SolarisPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 SolarisPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnixNumericGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class UnixNumericGroupPrincipal

  • java.lang.Object
    • com.sun.security.auth.UnixNumericGroupPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class UnixNumericGroupPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，代表用户的Unix组标识号（GID）。

    诸如这个UnixNumericGroupPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnixNumericGroupPrincipal​(long name, boolean primaryGroup)
      使用用户组标识号（GID）的长表示形式创建 UnixNumericGroupPrincipal 。
      UnixNumericGroupPrincipal​(String name, boolean primaryGroup)
      使用 String表示用户组标识号（GID）创建一个 UnixNumericGroupPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 UnixNumericGroupPrincipal进行比较以获得相等性。
      String getName​()
      返回此 UnixNumericGroupPrincipal的用户组标识号（GID）。
      int hashCode​()
      返回这个 UnixNumericGroupPrincipal的哈希码。
      boolean isPrimaryGroup​()
      返回此组标识号（GID）是否表示此用户所属的主组。
      long longValue​()
      返回这个 UnixNumericGroupPrincipal的用户组标识号（GID）长。
      String toString​()
      返回此 UnixNumericGroupPrincipal的字符串表示 UnixNumericGroupPrincipal 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • UnixNumericGroupPrincipal

        public UnixNumericGroupPrincipal​(String name,
                                 boolean primaryGroup)
        使用 String表示用户的组标识号（GID）创建一个 UnixNumericGroupPrincipal 。
        参数
        name - 该用户的用户组标识号（GID）。
        primaryGroup - 如果指定的GID表示此用户所属的主组， primaryGroup true。
        异常
        NullPointerException - 如果 name是 null 。

      • UnixNumericGroupPrincipal

        public UnixNumericGroupPrincipal​(long name,
                                 boolean primaryGroup)
        使用用户组标识号（GID）的长表示形式创建 UnixNumericGroupPrincipal 。
        参数
        name - 该用户的用户组标识号（GID）表示为长。
        primaryGroup - 如果指定的GID表示此用户所属的主组， primaryGroup true。

    • 方法详细信息

      • getName

        public String getName​()
        返回此 UnixNumericGroupPrincipal的用户组标识号（GID）。
        Specified by:
        getName在接口 Principal
        结果
        该用户的组标识号（GID）为 UnixNumericGroupPrincipal

      • longValue

        public long longValue​()
        返回这个 UnixNumericGroupPrincipal的用户组标识号（GID）长。
        结果
        该用户的组识别号（GID）为 UnixNumericGroupPrincipal为长。

      • isPrimaryGroup

        public boolean isPrimaryGroup​()
        返回此组标识号（GID）是否表示此用户所属的主组。
        结果
        如果此组标识号（GID）表示此用户所属的主组，则为true，否则为false。

      • toString

        public String toString​()
        返回这个 UnixNumericGroupPrincipal的字符串表示。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 UnixNumericGroupPrincipal的字符串表示 UnixNumericGroupPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此UnixNumericGroupPrincipal进行比较以获得相等性。 如果给定的对象也是一个UnixNumericGroupPrincipal ，并且两个UnixNumericGroupPrincipals具有相同的组标识号（GID），则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 要与此 UnixNumericGroupPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于此， UnixNumericGroupPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个 UnixNumericGroupPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 UnixNumericGroupPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnixNumericUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class UnixNumericUserPrincipal

  • java.lang.Object
    • com.sun.security.auth.UnixNumericUserPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class UnixNumericUserPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，代表用户的Unix标识号（UID）。

    诸如这个UnixNumericUserPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnixNumericUserPrincipal​(long name)
      使用用户标识号（UID）的长表示形成 UnixNumericUserPrincipal 。
      UnixNumericUserPrincipal​(String name)
      使用用户标识号（UID）的 String表示创建 UnixNumericUserPrincipal 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 UnixNumericUserPrincipal进行比较以获得相等性。
      String getName​()
      返回此 UnixNumericUserPrincipal的用户标识号（UID）。
      int hashCode​()
      返回这个 UnixNumericUserPrincipal的哈希码。
      long longValue​()
      返回这个 UnixNumericUserPrincipal的用户标识号（UID）长。
      String toString​()
      返回此 UnixNumericUserPrincipal的字符串表示 UnixNumericUserPrincipal 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • UnixNumericUserPrincipal

        public UnixNumericUserPrincipal​(String name)
        使用用户标识号（UID）的 String表示创建 UnixNumericUserPrincipal 。
        参数
        name - 此用户的用户标识号（UID）。
        异常
        NullPointerException - 如果 name是 null 。

      • UnixNumericUserPrincipal

        public UnixNumericUserPrincipal​(long name)
        使用用户标识号（UID）的长表示形成 UnixNumericUserPrincipal 。
        参数
        name - 该用户的用户标识号（UID）表示为长。

    • 方法详细信息

      • getName

        public String getName​()
        返回此 UnixNumericUserPrincipal的用户标识号（UID）。
        Specified by:
        getName在接口 Principal
        结果
        该用户识别码（UID）为 UnixNumericUserPrincipal

      • longValue

        public long longValue​()
        返回这个 UnixNumericUserPrincipal的用户标识号（UID）长。
        结果
        用户识别号码（UID）为 UnixNumericUserPrincipal为长。

      • toString

        public String toString​()
        返回此 UnixNumericUserPrincipal的字符串表示 UnixNumericUserPrincipal 。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 UnixNumericUserPrincipal的字符串表示 UnixNumericUserPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此UnixNumericUserPrincipal进行比较以获得相等性。 如果给定对象也是一个UnixNumericUserPrincipal ，并且两个UnixNumericUserPrincipals具有相同的用户标识号（UID），则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 要与此 UnixNumericUserPrincipal相等的对象。
        结果
        如果指定的对象等于此 UnixNumericUserPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个 UnixNumericUserPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 UnixNumericUserPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnixPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class UnixPrincipal

  • java.lang.Object
    • com.sun.security.auth.UnixPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public class UnixPrincipal
extends Object
implements Principal, Serializable
    该类实现了Principal接口，代表了Unix用户。

    诸如此UnixPrincipal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnixPrincipal​(String name)
      用Unix用户名创建一个UnixPrincipal。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      将指定的对象与此 UnixPrincipal进行比较以获得相等性。
      String getName​()
      返回此 UnixPrincipal的Unix用户名。
      int hashCode​()
      返回这个 UnixPrincipal的哈希码。
      String toString​()
      返回此 UnixPrincipal的字符串表示 UnixPrincipal 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • UnixPrincipal

        public UnixPrincipal​(String name)
        用Unix用户名创建一个UnixPrincipal。
        参数
        name - 该用户的Unix用户名。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • getName

        public String getName​()
        返回此 UnixPrincipal的Unix用户名。
        Specified by:
        getName在接口 Principal
        结果
        这个 UnixPrincipal的Unix用户名

      • toString

        public String toString​()
        返回此 UnixPrincipal的字符串表示 UnixPrincipal 。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 UnixPrincipal的字符串表示 UnixPrincipal 。

      • equals

        public boolean equals​(Object o)
        将指定的对象与此UnixPrincipal进行比较以获得相等性。 如果给定对象也是一个UnixPrincipal ，并且两个UnixPrincipals具有相同的用户名，则返回true。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 与此 UnixPrincipal进行平等比较的对象。
        结果
        如果指定的对象等于此 UnixPrincipal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个 UnixPrincipal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 UnixPrincipal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class UserPrincipal

  • java.lang.Object
    • com.sun.security.auth.UserPrincipal
  • All Implemented Interfaces:
    Serializable ， Principal

    public final class UserPrincipal
extends Object
implements Principal, Serializable
    由用户名或帐户名称标识的用户主体。

    在成功认证之后，用户Principal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 授权决定可以基于与Principal相关联的Subject 。

    这个类是不可变的。

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UserPrincipal​(String name)
      创建校长

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object object)
      将此主体与指定对象进行比较。
      String getName​()
      返回此主体的名称。
      int hashCode​()
      返回此主体的哈希码。
      String toString​()
      返回此主体的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • UserPrincipal

        public UserPrincipal​(String name)
        创建校长
        参数
        name - 校长的字符串名称。
        异常
        NullPointerException - 如果 name是 null 。

    • 方法详细信息

      • equals

        public boolean equals​(Object object)
        将此主体与指定对象进行比较。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        object - 比较此主体的对象。
        结果
        如果他们是平等的话; 否则为假。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此主体的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        校长的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getName

        public String getName​()
        返回此主体的名称。
        Specified by:
        getName在接口 Principal
        结果
        校长的名字。

      • toString

        public String toString​()
        返回此主体的字符串表示形式。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        校长的名字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.security.auth (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.security.auth

  • Packages that use com.sun.security.auth
    软件包 描述
    com.sun.security.auth
    提供Principal的实现。
  • Classes in com.sun.security.auth used by com.sun.security.auth
    Class 描述
    NTSid
    此类实现 Principal接口，并表示有关Windows NT用户，组或领域的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


X500Principal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth

Class X500Principal

  • java.lang.Object
    • com.sun.security.auth.X500Principal
  • All Implemented Interfaces:
    Serializable ， Principal
    不推荐用于删除：此API元素将在以后的版本中被删除。
    Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="1.4",
            forRemoval=true)
public class X500Principal
extends Object
implements Principal, Serializable
    这个类代表X.500 Principal 。 X500Principals具有诸如“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”（RFC 1779样式）的名称。

    诸如这个X500Principal可以与特定的Subject相关联，以增加具有附加身份的Subject 。 有关如何实现这一点的更多信息，请参阅Subject课程。 授权决定可以基于与Subject相关联的Subject 。

    另请参见：
    Principal ， Subject ， X500Principal ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      X500Principal​(String name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      使用X.500名称创建X500Principal，例如“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”（RFC 1779样式）。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      将指定的对象与此 X500Principal进行比较以获得相等性。
      String getName​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 X500Principal的Unix用户名。
      int hashCode​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回这个 X500Principal的哈希码。
      String toString​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      返回此 X500Principal的字符串表示 X500Principal 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.security.Principal

        implies

    • 构造方法详细信息

      • X500Principal

        public X500Principal​(String name)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        使用X.500名称创建X500Principal，例如“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”（RFC 1779样式）。
        参数
        name - X.500名称
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name未正确指定。

    • 方法详细信息

      • getName

        public String getName​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 X500Principal的Unix用户名。
        Specified by:
        getName在接口 Principal
        结果
        这个 X500Principal的Unix用户名

      • toString

        public String toString​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回此 X500Principal的字符串表示 X500Principal 。
        Specified by:
        toString在接口 Principal
        重写：
        toString在 Object
        结果
        这个 X500Principal的字符串表示。

      • equals

        public boolean equals​(Object o)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        将指定的对象与此 X500Principal进行比较以获得相等性。
        Specified by:
        equals在接口 Principal
        重写：
        equals在 Object
        参数
        o - 要与此 X500Principal进行平等比较的对象。
        结果
        如果指定的对象等于此， X500Principal 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        返回这个 X500Principal的哈希码。
        Specified by:
        hashCode在接口 Principal
        重写：
        hashCode在 Object
        结果
        这个 X500Principal的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.security.auth.callback (Java SE 9 & JDK 9 )

com.sun.security.auth.callback

Classes

  • TextCallbackHandler


com.sun.security.auth.callback (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.security.auth

Package com.sun.security.auth.callback

提供CallbackHandler的实现。
从以下版本开始：
1.4
  • 类摘要
    Class 描述
    TextCallbackHandler
    从命令行提示并读取认证问题的答案。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.auth.callback Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.security.auth.callback

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.security.auth.callback.TextCallbackHandler (implements javax.security.auth.callback.CallbackHandler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


TextCallbackHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.callback

Class TextCallbackHandler

  • java.lang.Object
    • com.sun.security.auth.callback.TextCallbackHandler
  • All Implemented Interfaces:
    CallbackHandler

    public class TextCallbackHandler
extends Object
implements CallbackHandler

    从命令行提示并读取认证问题的答案。 这可以由JAAS应用程序用来实例化一个CallbackHandler

    另请参见：
    javax.security.auth.callback

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextCallbackHandler​()
      创建一个回调处理程序，它提示并从命令行读取认证问题的答案。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void handle​(Callback[] callbacks)
      处理指定的一组回调。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TextCallbackHandler

        public TextCallbackHandler​()

        创建一个回调处理程序，它提示并从命令行读取认证问题的答案。 这可以由JAAS应用程序用来实例化一个CallbackHandler。

    • 方法详细信息

      • handle

        public void handle​(Callback[] callbacks)
            throws IOException,
                   UnsupportedCallbackException
        处理指定的一组回调。
        Specified by:
        handle在接口 CallbackHandler
        参数
        callbacks - 要处理的回调
        异常
        IOException - 如果发生输入或输出错误。
        UnsupportedCallbackException - 如果回调不是NameCallback或PasswordCallback的实例
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.security.auth.callback (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.security.auth.callback

No usage of com.sun.security.auth.callback
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.callback.TextCallbackHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.callback.TextCallbackHandler

No usage of com.sun.security.auth.callback.TextCallbackHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.LdapPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.LdapPrincipal

No usage of com.sun.security.auth.LdapPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTDomainPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTDomainPrincipal

No usage of com.sun.security.auth.NTDomainPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTNumericCredential (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTNumericCredential

No usage of com.sun.security.auth.NTNumericCredential
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTSid (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTSid

  • Packages that use NTSid
    软件包 描述
    com.sun.security.auth
    提供Principal的实现。

    • Uses of NTSid in com.sun.security.auth

      Subclasses of NTSid in com.sun.security.auth
      Modifier and Type Class 描述
      class  NTSidDomainPrincipal
      这个类扩展了 NTSid ，代表了Windows NT用户的域SID。
      class  NTSidGroupPrincipal
      此类扩展为 NTSid ，代表Windows NT用户所属的组之一。
      class  NTSidPrimaryGroupPrincipal
      此类扩展为 NTSid ，表示Windows NT用户的主组SID。
      class  NTSidUserPrincipal
      此类扩展为 NTSid ，代表Windows NT用户的SID。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTSidDomainPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTSidDomainPrincipal

No usage of com.sun.security.auth.NTSidDomainPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTSidGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTSidGroupPrincipal

No usage of com.sun.security.auth.NTSidGroupPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTSidPrimaryGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTSidPrimaryGroupPrincipal

No usage of com.sun.security.auth.NTSidPrimaryGroupPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTSidUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTSidUserPrincipal

No usage of com.sun.security.auth.NTSidUserPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.NTUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.NTUserPrincipal

No usage of com.sun.security.auth.NTUserPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.PolicyFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.PolicyFile

No usage of com.sun.security.auth.PolicyFile
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.SolarisNumericGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.SolarisNumericGroupPrincipal

No usage of com.sun.security.auth.SolarisNumericGroupPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.SolarisNumericUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.SolarisNumericUserPrincipal

No usage of com.sun.security.auth.SolarisNumericUserPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.SolarisPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.SolarisPrincipal

No usage of com.sun.security.auth.SolarisPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.UnixNumericGroupPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.UnixNumericGroupPrincipal

No usage of com.sun.security.auth.UnixNumericGroupPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.UnixNumericUserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.UnixNumericUserPrincipal

No usage of com.sun.security.auth.UnixNumericUserPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.UnixPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.UnixPrincipal

No usage of com.sun.security.auth.UnixPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.UserPrincipal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.UserPrincipal

No usage of com.sun.security.auth.UserPrincipal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.X500Principal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.X500Principal

No usage of com.sun.security.auth.X500Principal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.security.auth.PrincipalComparator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.security.auth.PrincipalComparator

No usage of com.sun.security.auth.PrincipalComparator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.auth.login (Java SE 9 & JDK 9 )

com.sun.security.auth.login

Classes

  • ConfigFile


com.sun.security.auth.login (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.security.auth

Package com.sun.security.auth.login

提供Configuration的实现。
从以下版本开始：
1.4
  • 类摘要
    Class 描述
    ConfigFile
    此类表示 javax.security.auth.login.Configuration的默认实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.auth.login Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.security.auth.login

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.login.Configuration
      • com.sun.security.auth.login.ConfigFile
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ConfigFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.login

Class ConfigFile

  • java.lang.Object
    • javax.security.auth.login.Configuration
      • com.sun.security.auth.login.ConfigFile

  • public class ConfigFile
extends Configuration
    此类表示javax.security.auth.login.Configuration的默认实现。

    此对象存储运行时登录配置表示，并且是驻留在文件中的多个静态登录配置的合并。 用于定位登录配置文件并将其信息读入此Configuration对象的算法是：

    1. 循环安全属性， login.config.url.1 ， login.config.url.2 ，...， login.config.url.X 。 每个属性值指定一个URL指向要加载的登录配置文件。 读入并加载每个配置。
    2. java.lang.System属性java.security.auth.login.config也可以设置为指向另一个登录配置文件（在运行时用户使用-D开关的情况下）的URL 。 如果定义了此属性，并且安全属性文件（Security属性policy.allowSystemProperty设置为true ）允许其使用，则还会加载该登录配置。
    3. 如果使用“==”（而不是“=”）定义了java.security.auth.login.config属性，则忽略所有其他指定的登录配置，并且仅加载此配置。
    4. 如果没有设置系统或安全属性，请尝试从文件$ {user.home} /。java.login.config中读取，其中$ {user.home}是由“user.home”系统属性表示的值。

    此实现支持的配置语法正是javax.security.auth.login.Configuration类中指定的语法。

    另请参见：
    LoginContext ， security properties

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.security.auth.login.Configuration

        Configuration.Parameters

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConfigFile​()
      创建一个新的 Configuration对象。
      ConfigFile​(URI uri)
      从指定的 URI创建一个新的 Configuration对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AppConfigurationEntry[] getAppConfigurationEntry​(String applicationName)
      使用应用程序名称作为索引从 Configuration检索条目。
      void refresh​()
      通过重新读取所有登录配置刷新并重新加载 Configuration 。

      • Methods inherited from class javax.security.auth.login.Configuration

        getConfiguration, getInstance, getInstance, getInstance, getParameters, getProvider, getType, setConfiguration

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ConfigFile

        public ConfigFile​()
        创建一个新的 Configuration对象。
        异常
        SecurityException - 如果 Configuration无法初始化

      • ConfigFile

        public ConfigFile​(URI uri)
        从指定的 URI创建一个新的 Configuration对象。
        参数
        uri - URI
        异常
        SecurityException - 如果 Configuration无法初始化
        NullPointerException - 如果 uri为空

    • 方法详细信息

      • getAppConfigurationEntry

        public AppConfigurationEntry[] getAppConfigurationEntry​(String applicationName)
        使用应用程序名称作为索引从 Configuration检索条目。
        Specified by:
        getAppConfigurationEntry在 Configuration
        参数
        applicationName - 用于索引 Configuration的名称
        结果
        一个 AppConfigurationEntry阵列，对应于此应用程序的 LoginModule的堆叠配置，如果此应用程序没有配置 LoginModule s， LoginModule null。

      • refresh

        public void refresh​()
        刷新并重新加载 Configuration ，重新读取所有登录配置。
        重写：
        refresh在 Configuration
        异常
        SecurityException - if the caller does not have permission to refresh the Configuration
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.security.auth.login (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.security.auth.login

No usage of com.sun.security.auth.login
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.login.ConfigFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.login.ConfigFile

No usage of com.sun.security.auth.login.ConfigFile
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.auth.module (Java SE 9 & JDK 9 )

com.sun.security.auth.module

Classes

  • JndiLoginModule
  • KeyStoreLoginModule
  • Krb5LoginModule
  • LdapLoginModule
  • NTLoginModule
  • NTSystem
  • SolarisLoginModule
  • SolarisSystem
  • UnixLoginModule
  • UnixSystem


com.sun.security.auth.module (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.security.auth

Package com.sun.security.auth.module

提供LoginModule的实现。
从以下版本开始：
1.4
  • 类摘要
    Class 描述
    JndiLoginModule
    模块提示输入用户名和密码，然后根据存储在JNDI下配置的目录服务中的密码验证密码。
    KeyStoreLoginModule
    提供一个JAAS登录模块，提示密钥存储别名，并使用别名的主体和凭据填充主题。
    Krb5LoginModule
    此 LoginModule使用Kerberos协议对用户进行身份验证。
    LdapLoginModule
    此LoginModule执行基于LDAP的身份验证。
    NTLoginModule
    这个 LoginModule将用户的NT安全信息呈现为 Principal的一些数字， Principal其与 Subject相关联。
    NTSystem
    此类实现检索并为当前用户提供可用的NT安全信息。
    SolarisLoginModule Deprecated, for removal: This API element is subject to removal in a future version.
    截至JDK1.4，由com.sun.security.auth.module.UnixLoginModule取代。
    SolarisSystem Deprecated, for removal: This API element is subject to removal in a future version.
    取代UnixSystem 。
    UnixLoginModule
    这 LoginModule导入用户的Unix Principal信息（ UnixPrincipal ， UnixNumericUserPrincipal ，并 UnixNumericGroupPrincipal ），并与当前的关联 Subject 。
    UnixSystem
    此类实现检索并提供当前用户的Unix UID / GID /组信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.auth.module Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.security.auth.module

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.security.auth.module.JndiLoginModule (implements javax.security.auth.spi.LoginModule)
    • com.sun.security.auth.module.KeyStoreLoginModule (implements javax.security.auth.spi.LoginModule)
    • com.sun.security.auth.module.Krb5LoginModule (implements javax.security.auth.spi.LoginModule)
    • com.sun.security.auth.module.LdapLoginModule (implements javax.security.auth.spi.LoginModule)
    • com.sun.security.auth.module.NTLoginModule (implements javax.security.auth.spi.LoginModule)
    • com.sun.security.auth.module.NTSystem
    • com.sun.security.auth.module.SolarisLoginModule (implements javax.security.auth.spi.LoginModule)
    • com.sun.security.auth.module.SolarisSystem
    • com.sun.security.auth.module.UnixLoginModule (implements javax.security.auth.spi.LoginModule)
    • com.sun.security.auth.module.UnixSystem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


JndiLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class JndiLoginModule

  • java.lang.Object
    • com.sun.security.auth.module.JndiLoginModule
  • All Implemented Interfaces:
    LoginModule

    public class JndiLoginModule
extends Object
implements LoginModule
    模块提示输入用户名和密码，然后根据存储在JNDI下配置的目录服务中的密码验证密码。

    该LoginModule与任何一致的JNDI服务提供商进行互操作。 为了指导这个LoginModule使用特定的JNDI服务提供商，有两个选项必须在登录指定Configuration这个LoginModule 。

      user.provider.url=name_service_url
      group.provider.url=name_service_url
    name_service_url指定此LoginModule可以访问相关用户和组信息的目录服务和路径。 由于LoginModule仅执行一级搜索以查找相关用户信息，因此URL必须指向目录服务中存储用户和组信息的一级以上的目录。 例如，要指示此LoginModule联系NIS服务器，必须指定以下URL：
      user.provider.url="nis://NISServerHostName/NISDomain/user"
    group.provider.url="nis://NISServerHostName/NISDomain/system/group"
    NISServerHostName指定NIS服务器的服务器主机名（例如， ， NISDomain指定该NIS服务器的域）（例如， jaas.sun.com 。要联系LDAP服务器，以下URL必须为规定：
      user.provider.url="ldap://LDAPServerHostName/LDAPName"
    group.provider.url="ldap://LDAPServerHostName/LDAPName"
    LDAPServerHostName指定LDAP服务器，其可包括一个端口号（例如的服务器的主机名，并且LDAPName在LDAP目录指定条目名称（例如，OU =人，O = Sun，c = US ， ou = Groups，o = Sun，c = US分别为用户和组信息）。

    用户信息必须存储在目录服务中的格式在RFC 2307中指定。具体来说，该LoginModule将使用用户的uid属性（其中uid = username）搜索目录服务中的用户条目。 如果搜索成功，该LoginModule将使用userPassword属性从检索到的条目获取用户的加密密码。 这个LoginModule假设密码存储为字节数组，当转换为String ，具有以下格式：

      "{crypt}encrypted_password"
    必须将LDAP目录服务器配置为允许对userPassword属性的读取访问。 如果用户输入有效的用户名和密码，这LoginModule相关联的UnixPrincipal ， UnixNumericUserPrincipal ，并与相关UnixNumericGroupPrincipals Subject 。

    此LoginModule还会识别以下Configuration选项：

      debug          if, true, debug messages are output to System.out.

    useFirstPass   if, true, this LoginModule retrieves the
                   username and password from the module's shared state,
                   using "javax.security.auth.login.name" and
                   "javax.security.auth.login.password" as the respective
                   keys.  The retrieved values are used for authentication.
                   If authentication fails, no attempt for a retry is made,
                   and the failure is reported back to the calling
                   application.

    tryFirstPass   if, true, this LoginModule retrieves the
                   the username and password from the module's shared state,
                   using "javax.security.auth.login.name" and
                   "javax.security.auth.login.password" as the respective
                   keys.  The retrieved values are used for authentication.
                   If authentication fails, the module uses the
                   CallbackHandler to retrieve a new username and password,
                   and another attempt to authenticate is made.
                   If the authentication fails, the failure is reported
                   back to the calling application.

    storePass      if, true, this LoginModule stores the username and password
                   obtained from the CallbackHandler in the module's
                   shared state, using "javax.security.auth.login.name" and
                   "javax.security.auth.login.password" as the respective
                   keys.  This is not performed if existing values already
                   exist for the username and password in the shared state,
                   or if authentication fails.

    clearPass     if, true, this LoginModule clears the
                  username and password stored in the module's shared state
                  after both phases of authentication (login and commit)
                  have completed.

    • Field Summary

      Fields
      Modifier and Type Field 描述
      String GROUP_PROVIDER
      String USER_PROVIDER
      JNDI提供商

    • 构造方法摘要

      构造方法
      Constructor 描述
      JndiLoginModule​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean abort​()
      如果LoginContext的整体身份验证失败，则调用此方法。
      boolean commit​()
      提交认证过程的抽象方法（阶段2）。
      void initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      boolean login​()
      提示用户名和密码。
      boolean logout​()
      注销用户。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • USER_PROVIDER

        public final String USER_PROVIDER
        JNDI提供商
        另请参见：
        Constant Field Values

      • GROUP_PROVIDER

        public final String GROUP_PROVIDER
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JndiLoginModule

        public JndiLoginModule​()

    • 方法详细信息

      • initialize

        public void initialize​(Subject subject,
                       CallbackHandler callbackHandler,
                       Map<String,?> sharedState,
                       Map<String,?> options)
        初始化 LoginModule 。
        Specified by:
        initialize在接口 LoginModule
        参数
        subject - 要验证的 Subject 。
        callbackHandler - 用于与最终用户通信的 CallbackHandler （例如提示用户名和密码）。
        sharedState - 共享 LoginModule状态。
        options - 在特定 LoginModule的登录 Configuration指定的选项。

      • login

        public boolean login​()
              throws LoginException
        提示用户名和密码。 根据相关名称服务验证密码。
        Specified by:
        login在接口 LoginModule
        结果
        真的永远，因为这 LoginModule不应该被忽视。
        异常
        FailedLoginException - 如果认证失败。
        LoginException - 如果这个 LoginModule无法执行认证。

      • commit

        public boolean commit​()
               throws LoginException
        提交认证过程的抽象方法（阶段2）。

        如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

        如果此LoginModule自己的身份验证尝试成功（通过检索通过login方法保存的私有状态进行检查），则此方法将UnixPrincipal与位于Subject中的LoginModule相关联。 如果此LoginModule自身的身份验证尝试失败，则此方法将删除原始保存的任何状态。

        Specified by:
        commit在接口 LoginModule
        结果
        如果此LoginModule自己的登录和提交尝试成功，则为true，否则为false。
        异常
        LoginException - 如果提交失败

      • abort

        public boolean abort​()
              throws LoginException
        如果LoginContext的整体身份验证失败，则调用此方法。 （相关要求，必要，有效和可选的LoginModules没有成功）。

        如果此LoginModule自己的身份验证尝试成功（通过检索由login和commit方法保存的私有状态进行检查），则此方法将清除最初保存的任何状态。

        Specified by:
        abort在接口 LoginModule
        结果
        如果此LoginModule自己的登录和/或提交尝试失败，则为false，否则为true。
        异常
        LoginException - 如果中止失败。

      • logout

        public boolean logout​()
               throws LoginException
        注销用户。

        此方法将删除由commit方法添加的commit 。

        Specified by:
        logout在接口 LoginModule
        结果
        在所有情况下都是这样，因为这个 LoginModule不应该被忽略。
        异常
        LoginException - 如果注销失败。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


KeyStoreLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class KeyStoreLoginModule

  • java.lang.Object
    • com.sun.security.auth.module.KeyStoreLoginModule
  • All Implemented Interfaces:
    LoginModule

    public class KeyStoreLoginModule
extends Object
implements LoginModule
    提供一个JAAS登录模块，提示密钥存储别名，并使用别名的主体和凭据填充主题。 在主题的主体中的别名凭据中存储第一个X500Principal的主体可分辨名称的X500Principal ，该对象的公共凭证中的别名的证书路径，以及一个X500PrivateCredential其证书是别名的证书路径中的第一个证书，其私钥为该主题私人凭据中的别名的私钥。

    识别配置文件中的以下选项：

    keyStoreURL
    指定密钥库的位置的URL。 默认为指向由user.home系统属性指定的目录中的.keystore文件的URL。 来自此URL的输入流将传递给KeyStore.load方法。 如果null流必须传递到KeyStore.load方法，则可以指定“NONE”。 例如，如果KeyStore驻留在硬体令牌设备上，则应指定“NONE”。
    keyStoreType
    钥匙店类型。 如果未指定，则默认为调用KeyStore.getDefaultType()的结果。 如果类型为“PKCS11”，则keyStoreURL必须为“NONE”，并且不能指定privateKeyPasswordURL。
    keyStoreProvider
    关键商店提供商。 如果未指定，请使用标准搜索顺序查找提供程序。
    keyStoreAlias
    密码商店中的别名登录为。 不提供回调处理程序时需要。 没有默认值。
    keyStorePasswordURL
    指定密钥存储区密码位置的URL。 当没有提供回调处理程序并且protected为假时需要。 没有默认值。
    privateKeyPasswordURL
    一个URL，用于指定访问此别名私钥所需的特定私钥密码的位置。 如果需要并且未指定该值，则使用密钥库密码。
    protected
    如果KeyStore具有单独的受保护的身份验证路径（例如，连接到智能卡的专用PIN焊盘），则该值应设置为“true”。 默认为“false”。 如果“true”keyStorePasswordURL和privateKeyPasswordURL不能被指定。

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyStoreLoginModule​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean abort​()
      如果LoginContext的整体身份验证失败，则调用此方法。
      boolean commit​()
      提交认证过程的抽象方法（阶段2）。
      void initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化这个 LoginModule 。
      boolean login​()
      验证用户。
      boolean logout​()
      注销用户。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyStoreLoginModule

        public KeyStoreLoginModule​()

    • 方法详细信息

      • initialize

        public void initialize​(Subject subject,
                       CallbackHandler callbackHandler,
                       Map<String,?> sharedState,
                       Map<String,?> options)
        初始化这个 LoginModule 。
        Specified by:
        initialize在接口 LoginModule
        参数
        subject - 要验证的 Subject 。
        callbackHandler - 用于与最终用户通信的 CallbackHandler （例如提示用户名和密码），其可以是 null 。
        sharedState - 共享 LoginModule状态。
        options - 在特定 LoginModule的登录 Configuration指定的选项。

      • login

        public boolean login​()
              throws LoginException
        验证用户。

        获取密钥库别名和相关密码。 从密钥库检索别名的主体和凭据。

        Specified by:
        login在接口 LoginModule
        结果
        在所有情况下都是这样（这个 LoginModule不应该被忽略）。
        异常
        FailedLoginException - 如果身份验证失败。
        LoginException - 如果身份验证失败

      • commit

        public boolean commit​()
               throws LoginException
        提交认证过程的抽象方法（阶段2）。

        如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

        如果此LoginModule自己的身份验证尝试成功（通过检索通过login方法保存的私有状态进行检查），则该方法将关联主题主体中别名凭据中第一个证书的主体标识名称的X500Principal ，该别名的证书路径该主体的公共凭证，以及一个X500PrivateCredential其证书是别名证书路径中的第一个证书，其私钥是主题私有凭据中别名的私钥。 如果此LoginModule自身的身份验证尝试失败，则此方法将删除原始保存的任何状态。

        Specified by:
        commit在接口 LoginModule
        结果
        如果此LoginModule自己的登录和提交尝试成功，则为true，否则为false。
        异常
        LoginException - 如果提交失败

      • abort

        public boolean abort​()
              throws LoginException
        如果LoginContext的整体身份验证失败，则调用此方法。 （相关要求，必要，有效和可选的LoginModules没有成功）。

        如果此LoginModule自己的身份验证尝试成功（通过检索由login和commit方法保存的私有状态进行检查），则此方法将清除最初保存的任何状态。

        如果加载的KeyStore的提供商扩展了java.security.AuthProvider ，则调用提供程序的logout方法。

        Specified by:
        abort在接口 LoginModule
        结果
        如果此LoginModule自己的登录和/或提交尝试失败，则为false，否则为true。
        异常
        LoginException - 如果中止失败。

      • logout

        public boolean logout​()
               throws LoginException
        注销用户。

        此方法将删除由commit方法添加的Principal，公用凭证和私有凭据。

        如果加载的KeyStore的提供商扩展了java.security.AuthProvider ，则调用提供程序的logout方法。

        Specified by:
        logout在接口 LoginModule
        结果
        在所有情况下都是这样，因为这个 LoginModule不应该被忽略。
        异常
        LoginException - if the logout fails.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Krb5LoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class Krb5LoginModule

  • java.lang.Object
    • com.sun.security.auth.module.Krb5LoginModule
  • All Implemented Interfaces:
    LoginModule

    public class Krb5LoginModule
extends Object
implements LoginModule
    此LoginModule使用Kerberos协议对用户进行身份验证。

    Krb5LoginModule的配置条目有几个选项可以控制身份验证过程，并添加到Subject的私有凭据集。 不考虑这些选项， Subject的主体集和私有凭证集仅在commit时更新。 当commit ， KerberosPrincipal被添加到Subject的主体集合（除非principal被指定为“*”）。 如果isInitiator是真的，那么KerberosTicket被添加到Subject的私有凭据。

    如果KerberosLoginModule的配置条目的选项为storeKey设置为true，那么KerberosKey或KeyTab也将添加到主体的私有凭据。 KerberosKey ，校长的密钥将来自用户的密码，而KeyTab是useKeyTab设置为true时使用的密钥表。 KeyTab对象被限制为由指定的主体使用，除非主体值为“*”。

    此LoginModule识别doNotPrompt选项。 如果设置为true，则不会提示用户输入密码。

    用户可以使用配置条目中的选项ticketCache来指定ticketCache单缓存的位置。

    用户可以使用配置条目中的选项keyTab指定密钥表位置。

    可以使用选项principal在配置条目中指定主体名称。 主体名称可以是简单的用户名，服务名称，如host/mission.eng.sun.com或“*”。 sun.security.krb5.principal也可以使用系统属性sun.security.krb5.principal进行设置。 此登录过程中检查此属性。 如果未设置此属性，则使用配置中的主体名称。 在未设置主体属性并且主体条目也不存在的情况下，将提示用户输入名称。 当此条目的属性设置为useTicketCache ，仅使用属于此主体的TGT。

    以下是Krb5LoginModule支持的配置选项列表：

    refreshKrb5Config:
    Set this to true, if you want the configuration to be refreshed before the login method is called.
    useTicketCache:
    Set this to true, if you want the TGT to be obtained from the ticket cache. Set this option to false if you do not want this module to use the ticket cache. (Default is False). This module will search for the ticket cache in the following locations: On Solaris and Linux it will look for the ticket cache in /tmp/krb5cc_ uid where the uid is numeric user identifier. If the ticket cache is not available in the above location, or if we are on a Windows platform, it will look for the cache as {user.home}{file.separator}krb5cc_{user.name}. You can override the ticket cache location by using ticketCache. For Windows, if a ticket cannot be retrieved from the file ticket cache, it will use Local Security Authority (LSA) API to get the TGT.
    ticketCache:
    Set this to the name of the ticket cache that contains user's TGT. If this is set, useTicketCache must also be set to true; Otherwise a configuration error will be returned.
    renewTGT:
    Set this to true, if you want to renew the TGT when it's more than half-way expired (the time until expiration is less than the time since start time). If this is set, useTicketCache must also be set to true; otherwise a configuration error will be returned.
    doNotPrompt:
    Set this to true if you do not want to be prompted for the password if credentials can not be obtained from the cache, the keytab, or through shared state.(Default is false) If set to true, credential must be obtained through cache, keytab, or shared state. Otherwise, authentication will fail.
    useKeyTab:
    Set this to true if you want the module to get the principal's key from the the keytab.(default value is False) If keytab is not set then the module will locate the keytab from the Kerberos configuration file. If it is not specified in the Kerberos configuration file then it will look for the file {user.home}{file.separator}krb5.keytab.
    keyTab:
    Set this to the file name of the keytab to get principal's secret key.
    storeKey:
    Set this to true to if you want the keytab or the principal's key to be stored in the Subject's private credentials. For isInitiator being false, if principal is "*", the KeyTab stored can be used by anyone, otherwise, it's restricted to be used by the specified principal only.
    principal:
    The name of the principal that should be used. The principal can be a simple username such as " testuser" or a service name such as " host/testhost.eng.sun.com". You can use the principal option to set the principal when there are credentials for multiple principals in the keyTab or when you want a specific ticket cache only. The principal can also be set using the system property sun.security.krb5.principal. In addition, if this system property is defined, then it will be used. If this property is not set, then the principal name from the configuration will be used. The principal name can be set to "*" when isInitiator is false. In this case, the acceptor is not bound to a single principal. It can act as any principal an initiator requests if keys for that principal can be found. When isInitiator is true, the principal name cannot be set to "*".
    isInitiator:
    Set this to true, if initiator. Set this to false, if acceptor only. (Default is true). Note: Do not set this value to false for initiators.

    此LoginModule还可以识别以下额外的Configuration选项，使您能够在不同的身份验证模块之间共享用户名和密码：

    useFirstPass:
    if, true, this LoginModule retrieves the username and password from the module's shared state, using "javax.security.auth.login.name" and "javax.security.auth.login.password" as the respective keys. The retrieved values are used for authentication. If authentication fails, no attempt for a retry is made, and the failure is reported back to the calling application.
    tryFirstPass:
    if, true, this LoginModule retrieves the the username and password from the module's shared state using "javax.security.auth.login.name" and "javax.security.auth.login.password" as the respective keys. The retrieved values are used for authentication. If authentication fails, the module uses the CallbackHandler to retrieve a new username and password, and another attempt to authenticate is made. If the authentication fails, the failure is reported back to the calling application
    storePass:
    if, true, this LoginModule stores the username and password obtained from the CallbackHandler in the modules shared state, using "javax.security.auth.login.name" and "javax.security.auth.login.password" as the respective keys. This is not performed if existing values already exist for the username and password in the shared state, or if authentication fails.
    clearPass:
    if, true, this LoginModule clears the username and password stored in the module's shared state after both phases of authentication (login and commit) have completed.

    如果已经提供了主体系统属性或键，共享状态中的“javax.security.auth.login.name”值将被忽略。

    当提供多个检索机票或密钥的机制时，优先级顺序为：

    1. 票缓存
    2. 密钥表
    3. 共享状态
    4. 用户提示

    请注意，如果任何步骤失败，它将回退到下一步。 只有一个例外，如果共享状态步骤失败，并且useFirstPass = true没有用户提示。

    在JAAS配置文件中Krb5LoginModule的某些配置值的示例，其结果如下：

 doNotPrompt = true
    This is an illegal combination since none of useTicketCache, useKeyTab, useFirstPass and tryFirstPass is set and the user can not be prompted for the password.

 ticketCache = <filename>
    This is an illegal combination since useTicketCache is not set to true and the ticketCache is set. A configuration error will occur.

 renewTGT = true
    This is an illegal combination since useTicketCache is not set to true and renewTGT is set. A configuration error will occur.

 storeKey = true  useTicketCache = true  doNotPrompt = true
    This is an illegal combination since storeKey is set to true but the key can not be obtained either by prompting the user or from the keytab, or from the shared state. A configuration error will occur.

 keyTab = <filename>  doNotPrompt = true
    This is an illegal combination since useKeyTab is not set to true and the keyTab is set. A configuration error will occur.

 debug = true
    Prompt the user for the principal name and the password. Use the authentication exchange to get TGT from the KDC and populate the Subject with the principal and TGT. Output debug messages.

 useTicketCache = true  doNotPrompt = true
    Check the default cache for TGT and populate the Subject with the principal and TGT. If the TGT is not available, do not prompt the user, instead fail the authentication.

 principal = <name>  useTicketCache = true  doNotPrompt = true
    Get the TGT from the default cache for the principal and populate the Subject's principal and private creds set. If ticket cache is not available or does not contain the principal's TGT authentication will fail.

 useTicketCache = true
 ticketCache = <file name>
 useKeyTab = true
 keyTab = <keytab filename>
 principal = <principal name>
 doNotPrompt = true
    Search the cache for the principal's TGT. If it is not available use the key in the keytab to perform authentication exchange with the KDC and acquire the TGT. The Subject will be populated with the principal and the TGT. If the key is not available or valid then authentication will fail.

 useTicketCache = true  ticketCache = <filename>
    The TGT will be obtained from the cache specified. The Kerberos principal name used will be the principal name in the Ticket cache. If the TGT is not available in the ticket cache the user will be prompted for the principal name and the password. The TGT will be obtained using the authentication exchange with the KDC. The Subject will be populated with the TGT.

 useKeyTab = true  keyTab=<keytab filename>  principal = <principal name>  storeKey = true
    The key for the principal will be retrieved from the keytab. If the key is not available in the keytab the user will be prompted for the principal's password. The Subject will be populated with the principal's key either from the keytab or derived from the password entered.

 useKeyTab = true  keyTab = <keytabname>  storeKey = true  doNotPrompt = false
    The user will be prompted for the service principal name. If the principal's longterm key is available in the keytab , it will be added to the Subject's private credentials. An authentication exchange will be attempted with the principal name and the key from the Keytab. If successful the TGT will be added to the Subject's private credentials set. Otherwise the authentication will fail.

 isInitiator = false  useKeyTab = true  keyTab = <keytabname>  storeKey = true  principal = *
    The acceptor will be an unbound acceptor and it can act as any principal as long that principal has keys in the keytab.

 useTicketCache = true
 ticketCache = <file name>
 useKeyTab = true
 keyTab = <file name>
 storeKey = true
 principal = <principal name>
    The client's TGT will be retrieved from the ticket cache and added to the Subject's private credentials. If the TGT is not available in the ticket cache, or the TGT's client name does not match the principal name, Java will use a secret key to obtain the TGT using the authentication exchange and added to the Subject's private credentials. This secret key will be first retrieved from the keytab. If the key is not available, the user will be prompted for the password. In either case, the key derived from the password will be added to the Subject's private credentials set.

 isInitiator = false
    Configured to act as acceptor only, credentials are not acquired via AS exchange. For acceptors only, set this value to false. For initiators, do not set this value to false.

 isInitiator = true
    Configured to act as initiator, credentials are acquired via AS exchange. For initiators, set this value to true, or leave this option unset, in which case default value (true) will be used.

    • 构造方法摘要

      构造方法
      Constructor 描述
      Krb5LoginModule​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean abort​()
      如果LoginContext的整体身份验证失败，则调用此方法。
      boolean commit​()
      如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。
      void initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      boolean login​()
      验证用户
      boolean logout​()
      注销用户。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Krb5LoginModule

        public Krb5LoginModule​()

    • 方法详细信息

      • initialize

        public void initialize​(Subject subject,
                       CallbackHandler callbackHandler,
                       Map<String,?> sharedState,
                       Map<String,?> options)
        初始化这个 LoginModule 。
        Specified by:
        initialize在接口 LoginModule
        参数
        subject - 要验证的 Subject 。
        callbackHandler - 用于与最终用户通信的 CallbackHandler （例如提示用户名和密码）。
        sharedState - 共享 LoginModule状态。
        options - 在特定 LoginModule的登录 Configuration指定的选项。

      • login

        public boolean login​()
              throws LoginException
        验证用户
        Specified by:
        login在接口 LoginModule
        结果
        在所有情况下都是真实的，因为这个 LoginModule不应该被忽略。
        异常
        FailedLoginException - 如果认证失败。
        LoginException - 如果这个 LoginModule无法执行认证。

      • commit

        public boolean commit​()
               throws LoginException
        如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

        如果此LoginModule自己的身份验证尝试成功（通过检索由login方法保存的私有状态进行检查），则此方法将Krb5Principal与位于Subject中的LoginModule相关联。 它将Kerberos凭据添加到主体的私有凭据集中。 如果此LoginModule自身的身份验证尝试失败，则此方法将删除原始保存的任何状态。

        Specified by:
        commit在接口 LoginModule
        结果
        如果此LoginModule自己的登录和提交尝试成功，则为true，否则为false。
        异常
        LoginException - 如果提交失败。

      • abort

        public boolean abort​()
              throws LoginException
        如果LoginContext的整体身份验证失败，则调用此方法。 （相关要求，必要，有效和可选的LoginModules没有成功）。

        如果此LoginModule自己的身份验证尝试成功（通过检索由login和commit方法保存的私有状态检查），则此方法将清除最初保存的任何状态。

        Specified by:
        abort在接口 LoginModule
        结果
        如果此LoginModule自己的登录和/或提交尝试失败，则为false，否则为true。
        异常
        LoginException - 如果中止失败。

      • logout

        public boolean logout​()
               throws LoginException
        注销用户。

        这种方法消除了Krb5Principal ，是由加入的commit方法。

        Specified by:
        logout在接口 LoginModule
        结果
        在所有情况下都是这样，因为这个 LoginModule不应该被忽略。
        异常
        LoginException - 如果注销失败。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LdapLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class LdapLoginModule

  • java.lang.Object
    • com.sun.security.auth.module.LdapLoginModule
  • All Implemented Interfaces:
    LoginModule

    public class LdapLoginModule
extends Object
implements LoginModule
    此LoginModule执行基于LDAP的身份验证。 根据存储在LDAP目录中的相应用户凭据验证用户名和密码。 本模块需要提供的CallbackHandler支持NameCallback和PasswordCallback 。 如果认证成功，则新LdapPrincipal使用用户的专有名称创建一个新UserPrincipal使用用户的用户名创建并且两者都与当前相关Subject 。

    该模块以以下三种模式之一运行： 首先搜索，首先 验证或仅认证 。 通过指定一组特定的选项来选择一种模式。

    在搜索优先模式下，搜索LDAP目录以确定用户的可分辨名称，然后尝试进行身份验证。 使用提供的用户名与指定的搜索过滤器一起执行（匿名）搜索。 如果成功，则尝试使用用户的可分辨名称和提供的密码进行身份验证。 要启用此模式，请设置userFilter选项，并省略authIdentity选项。 当用户的可分辨名称未提前知道时，请使用搜索优先模式。

    在认证第一模式下，尝试使用提供的用户名和密码进行认证，然后搜索LDAP目录。 如果认证成功，则使用提供的用户名与指定的搜索过滤器进行搜索。 要启用此模式，请设置authIdentity和userFilter选项。 访问已配置为禁止匿名搜索的LDAP目录时，请使用验证优先模式。

    在仅认证模式下，尝试使用提供的用户名和密码进行身份验证。 由于用户的可分辨名称已知，因此不会搜索LDAP目录。 要启用此模式，请将authIdentity选项设置为有效的可分辨名称，并省略userFilter选项。 当用户的专有名称提前知道时，使用仅认证模式。

    以下选项是必需的，必须在此模块的登录中指定Configuration ：

    userProvider=ldap_urls
    此选项标识存储用户条目的LDAP目录。 ldap_urls是标识要使用的LDAP服务器的空格分隔的LDAP URL（ RFC 2255 ）的列表，以及用户条目所在目录树中的位置。 当指定了几个LDAP URL时，会尝试依次进行第一个成功的连接建立。 必须使用百分比字符（' % '）的标准机制（后跟两个十六进制数字）转义URL的可分辨名称组件中的空格（请参阅URI ）。 还必须从URL中省略查询组件。

    支持通过DNS（ RFC 2782 ）自动发现LDAP服务器（一旦DNS配置为支持此类服务）。 通过从LDAP URL中省略主机名和端口号组件来启用它。

    此模块还可识别以下可选的Configuration选项：

    userFilter=ldap_filter
    此选项指定用于在LDAP目录中查找用户条目的搜索过滤器。 它用于确定用户的可分辨名称。 ldap_filter是一个LDAP过滤器字符串（ RFC 2254 ）。 如果它包含特殊令牌“ {USERNAME} ”，那么该标记将被替换为提供的用户名值，然后使用该过滤器来搜索该目录。
    authIdentity=auth_id
    此选项指定将用户认证到LDAP目录时要使用的身份。 auth_id可能是LDAP可分辨名称字符串（ RFC 2253 ）或其他一些字符串名称。 它必须包含特殊令牌“ {USERNAME} ”，将在使用该名称进行身份验证之前，将其替换为提供的用户名值。 请注意，如果此选项不包含可分辨名称，则还必须指定userFilter选项。
    authzIdentity=authz_id
    此选项指定用户的授权标识。 authz_id是任何字符串名称。 如果它包含带有花括号的单个特殊令牌，则该令牌将被视为属性名称，并将从用户的LDAP条目中替换为该属性的单个值。 如果无法找到属性，则该选项将被忽略。 当提供此选项并且用户已成功认证时，将使用授权标识创建一个附加的UserPrincipal，并与当前的Subject相关联。
    useSSL
    如果是false ，则在尝试身份验证之前，此模块不会建立到LDAP服务器的SSL连接。 SSL用于保护用户密码的隐私，因为它是透过LDAP传输的。 默认情况下，此模块使用SSL。
    useFirstPass
    如果是true ，则该模块将使用“javax.security.auth.login.name”和“javax.security.auth.login.password”作为相应的键从模块的共享状态检索用户名和密码。 检索到的值用于认证。 如果身份验证失败，则不会尝试重试，并将故障报告给呼叫应用程序。
    tryFirstPass
    如果是true ，该模块将使用“javax.security.auth.login.name”和“javax.security.auth.login.password”作为相应的键从模块的共享状态检索用户名和密码。 检索到的值用于认证。 如果身份验证失败，该模块将使用CallbackHandler检索新的用户名和密码，并进行另一次验证尝试。 如果身份验证失败，则会将该失败报告给调用应用程序。
    storePass
    如果是true ，则该模块将从CallbackHandler获取的用户名和密码存储在模块的共享状态中，使用“javax.security.auth.login.name”和“javax.security.auth.login.password”作为相应的键。 如果共享状态中的用户名和密码已存在现有值，或验证失败，则不执行此操作。
    clearPass
    如果是true ，则在完成认证（登录和提交）两个阶段后，此模块将清除存储在模块共享状态中的用户名和密码。
    debug
    如果true ，则在标准输出流上显示调试消息。

    任意"JNDI properties"也可以在Configuration中指定。 它们被添加到环境中并传递给LDAP提供者。 请注意，以下四个JNDI属性由此模块直接设置，如果配置中也存在，则将被忽略：

    • java.naming.provider.url
    • java.naming.security.principal
    • java.naming.security.credentials
    • java.naming.security.protocol

    三个样品Configurations如下所示。 第一个激活搜索优先模式。 它标识LDAP服务器，并指定用户的条目由其uid和objectClass属性定位。 它还指定应创建基于用户的employeeNumber属性的身份。 第二个激活认证优先模式。 它要求LDAP服务器动态定位，使用提供的用户名直接执行认证，但不保护SSL，用户的条目由三个命名属性及其objectClass属性之一定位。 第三个激活仅认证模式。 它识别替代的LDAP服务器，它指定用于身份验证的可分辨名称和用于授权的固定身份。 不执行目录搜索。

      ExampleApplication {
         com.sun.security.auth.module.LdapLoginModule REQUIRED
              userProvider="ldap://ldap-svr/ou=people,dc=example,dc=com"
              userFilter="(&(uid={USERNAME})(objectClass=inetOrgPerson))"
              authzIdentity="{EMPLOYEENUMBER}"
              debug=true;
     };

     ExampleApplication {
         com.sun.security.auth.module.LdapLoginModule REQUIRED
             userProvider="ldap:///cn=users,dc=example,dc=com"
             authIdentity="{USERNAME}"
             userFilter="(&(|(samAccountName={USERNAME})(userPrincipalName={USERNAME})(cn={USERNAME}))(objectClass=user))"
             useSSL=false
             debug=true;
     };

     ExampleApplication {
         com.sun.security.auth.module.LdapLoginModule REQUIRED
             userProvider="ldap://ldap-svr1 ldap://ldap-svr2"
             authIdentity="cn={USERNAME},ou=people,dc=example,dc=com"
             authzIdentity="staff"
             debug=true;
     };
    注意：
    当一个SecurityManager处于活动状态时，创建LoginContext并使用LoginModule的应用程序必须被授予某些权限。

    如果应用程序使用安装的 Configuration创建登录上下文，那么应用程序必须被授予AuthPermission以创建登录上下文。 例如，以下安全策略允许用户当前目录中的应用程序实例化任何登录上下文：

      grant codebase "file:${user.dir}/" {
         permission javax.security.auth.AuthPermission "createLoginContext.*";
     };
    或者，如果应用程序使用调用者指定的 Configuration创建登录上下文，那么应用程序必须被授予LoginModule所需的权限。 此模块需要以下两个权限：
    • SocketPermission连接到LDAP服务器。
    • AuthPermission修改一组Principal s相关联的一个Subject 。

    例如，以下安全策略在用户当前目录中授予应用程序该模块所需的所有权限：

      grant codebase "file:${user.dir}/" {
         permission java.net.SocketPermission "*:389", "connect";
         permission java.net.SocketPermission "*:636", "connect";
         permission javax.security.auth.AuthPermission "modifyPrincipals";
     };
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      LdapLoginModule​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean abort​()
      中止用户身份验证。
      boolean commit​()
      完成用户认证。
      void initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化这个 LoginModule 。
      boolean login​()
      开始用户认证。
      boolean logout​()
      注销用户。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LdapLoginModule

        public LdapLoginModule​()

    • 方法详细信息

      • initialize

        public void initialize​(Subject subject,
                       CallbackHandler callbackHandler,
                       Map<String,?> sharedState,
                       Map<String,?> options)
        初始化 LoginModule 。
        Specified by:
        initialize在接口 LoginModule
        参数
        subject - 要验证的 Subject 。
        callbackHandler - 一个 CallbackHandler获取用户名和密码。
        sharedState - 共享 LoginModule状态。
        options - 在特定 LoginModule的登录 Configuration指定的选项。

      • login

        public boolean login​()
              throws LoginException
        开始用户认证。

        获取用户的凭据并根据指定的LDAP目录进行验证。

        Specified by:
        login在接口 LoginModule
        结果
        真的永远，因为这个 LoginModule不应该被忽视。
        异常
        FailedLoginException - 如果身份验证失败。
        LoginException - 如果这个 LoginModule无法执行认证。

      • commit

        public boolean commit​()
               throws LoginException
        完成用户认证。

        如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

        如果此LoginModule自己的身份验证尝试成功（通过检索通过login方法保存的私有状态进行检查），则此方法将LdapPrincipal和一个或多个UserPrincipal与Subject中的LoginModule 。 如果此LoginModule自身的身份验证尝试失败，则此方法将删除原始保存的任何状态。

        Specified by:
        commit在接口 LoginModule
        结果
        如果此LoginModule自己的登录和提交尝试成功，则为true，否则为false。
        异常
        LoginException - 如果提交失败

      • abort

        public boolean abort​()
              throws LoginException
        中止用户身份验证。

        如果整体认证失败，则调用此方法。 （相关要求，必要，有效和可选的LoginModules没有成功）。

        如果此LoginModule自己的身份验证尝试成功（通过检索由login和commit方法保存的私有状态进行检查），则此方法将清除最初保存的任何状态。

        Specified by:
        abort在接口 LoginModule
        结果
        如果此LoginModule自己的登录和/或提交尝试失败，则为false，否则为true。
        异常
        LoginException - 如果中止失败。

      • logout

        public boolean logout​()
               throws LoginException
        注销用户。

        此方法将删除由commit方法添加的commit 。

        Specified by:
        logout在接口 LoginModule
        结果
        在所有情况下都是真实的，因为这个 LoginModule不应该被忽略。
        异常
        LoginException - 如果注销失败。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class NTLoginModule

  • java.lang.Object
    • com.sun.security.auth.module.NTLoginModule
  • All Implemented Interfaces:
    LoginModule

    public class NTLoginModule
extends Object
implements LoginModule
    该LoginModule将用户的NT安全信息呈现为Principal的一些数字， Principal其与Subject相关联。

    该LoginModule识别调试选项。 如果在登录配置中设置为true，则调试消息将被输出到输出流System.out。

    该LoginModule还可以识别debugNative选项。 如果在登录配置中设置为true，则将从模块的本机组件调试消息将输出到输出流System.out。

    另请参见：
    LoginModule

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTLoginModule​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean abort​()
      如果LoginContext的整体身份验证失败，则调用此方法。
      boolean commit​()
      如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。
      void initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化这个 LoginModule 。
      boolean login​()
      导入底层NT系统身份信息。
      boolean logout​()
      注销用户。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NTLoginModule

        public NTLoginModule​()

    • 方法详细信息

      • initialize

        public void initialize​(Subject subject,
                       CallbackHandler callbackHandler,
                       Map<String,?> sharedState,
                       Map<String,?> options)
        初始化这个 LoginModule 。
        Specified by:
        initialize在接口 LoginModule
        参数
        subject - 要认证的 Subject 。
        callbackHandler - 用于与最终用户进行通信的CallbackHandler （例如，提示用户名和密码）。 这个特定的LoginModule只提取底层的NT系统信息，所以这个参数被忽略。
        sharedState - 共享 LoginModule状态。
        options - 在特定 LoginModule的登录 Configuration指定的选项。

      • login

        public boolean login​()
              throws LoginException
        导入底层NT系统身份信息。
        Specified by:
        login在接口 LoginModule
        结果
        在所有情况下都是这样，因为这个 LoginModule不应该被忽略。
        异常
        FailedLoginException - 如果身份验证失败。
        LoginException - 如果这个 LoginModule无法执行认证。

      • commit

        public boolean commit​()
               throws LoginException
        如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

        如果此LoginModule自己的身份验证尝试成功（通过检索通过login方法保存的私有状态进行检查），则此方法将一些数量Principal与位于Subject中的LoginModuleContext 。 如果此LoginModule自身的身份验证尝试失败，则此方法将删除原始保存的任何状态。

        Specified by:
        commit在接口 LoginModule
        结果
        如果此LoginModule自己的登录和提交尝试成功，则为true，否则为false。
        异常
        LoginException - 如果提交失败。

      • abort

        public boolean abort​()
              throws LoginException
        如果LoginContext的整体身份验证失败，则调用此方法。 （相关要求，必要，有效和可选的LoginModules没有成功）。

        如果此LoginModule自己的身份验证尝试成功（通过检索由login和commit方法保存的私有状态检查），则此方法将清除最初保存的任何状态。

        Specified by:
        abort在接口 LoginModule
        结果
        如果此LoginModule自己的登录和/或提交尝试失败，则为false，否则为true。
        异常
        LoginException - 如果中止失败。

      • logout

        public boolean logout​()
               throws LoginException
        注销用户。

        这种方法消除了NTUserPrincipal ， NTDomainPrincipal ， NTSidUserPrincipal ， NTSidDomainPrincipal ， NTSidGroupPrincipal s和NTSidPrimaryGroupPrincipal可能已通过加入commit方法。

        Specified by:
        logout在接口 LoginModule
        结果
        在所有情况下都是这样，因为这个 LoginModule不应该被忽略。
        异常
        LoginException - if the logout fails.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NTSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class NTSystem

  • java.lang.Object
    • com.sun.security.auth.module.NTSystem

  • public class NTSystem
extends Object
    此类实现检索并为当前用户提供可用的NT安全信息。

    • 构造方法摘要

      构造方法
      Constructor 描述
      NTSystem​()
      实例化一个 NTSystem并加载本机库以访问底层系统信息。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getDomain​()
      获取当前NT用户的域。
      String getDomainSID​()
      获取当前NT用户域的可打印SID。
      String[] getGroupIDs​()
      获取当前NT用户的可打印组SID。
      long getImpersonationToken​()
      获取当前NT用户的模拟令牌。
      String getName​()
      获取当前NT用户的用户名。
      String getPrimaryGroupID​()
      获取当前NT用户的可打印主组SID。
      String getUserSID​()
      获取当前NT用户的可打印SID。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NTSystem

        public NTSystem​()
        实例化一个 NTSystem并加载本机库以访问底层系统信息。

    • 方法详细信息

      • getName

        public String getName​()
        获取当前NT用户的用户名。
        结果
        当前NT用户的用户名。

      • getDomain

        public String getDomain​()
        获取当前NT用户的域。
        结果
        当前NT用户的域。

      • getDomainSID

        public String getDomainSID​()
        获取当前NT用户域的可打印SID。
        结果
        当前NT用户域的可打印SID。

      • getUserSID

        public String getUserSID​()
        获取当前NT用户的可打印SID。
        结果
        当前NT用户可打印的SID。

      • getPrimaryGroupID

        public String getPrimaryGroupID​()
        获取当前NT用户的可打印主组SID。
        结果
        当前NT用户的主组SID。

      • getGroupIDs

        public String[] getGroupIDs​()
        获取当前NT用户的可打印组SID。
        结果
        当前NT用户的组SID。

      • getImpersonationToken

        public long getImpersonationToken​()
        获取当前NT用户的模拟令牌。
        结果
        当前NT用户的模拟令牌。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SolarisLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class SolarisLoginModule

  • java.lang.Object
    • com.sun.security.auth.module.SolarisLoginModule
  • All Implemented Interfaces:
    LoginModule
    不推荐用于删除：此API元素将在以后的版本中被删除。
    截至JDK1.4，由com.sun.security.auth.module.UnixLoginModule取代。 这个LoginModule已经完全被废弃了，这里允许平滑过渡到新的UnixLoginModule。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="1.4",
            forRemoval=true)
public class SolarisLoginModule
extends Object
implements LoginModule
    这LoginModule导入用户的Solaris Principal信息（ SolarisPrincipal ， SolarisNumericUserPrincipal ，并SolarisNumericGroupPrincipal ），并与当前的关联Subject 。

    该LoginModule识别调试选项。 如果在登录配置中设置为true，则调试消息将被输出到输出流System.out。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SolarisLoginModule​()
      不推荐用于删除：此API元素将在以后的版本中被删除。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean abort​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      中止身份验证（第二阶段）。
      boolean commit​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      提交认证（第二阶段）。
      void initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      初始化 LoginModule 。
      boolean login​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      验证用户（第一阶段）。
      boolean logout​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      注销用户

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SolarisLoginModule

        public SolarisLoginModule​()
        不推荐用于删除：此API元素将在以后的版本中被删除。

    • 方法详细信息

      • initialize

        public void initialize​(Subject subject,
                       CallbackHandler callbackHandler,
                       Map<String,?> sharedState,
                       Map<String,?> options)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        初始化 LoginModule 。
        Specified by:
        initialize在接口 LoginModule
        参数
        subject - 要认证的 Subject 。
        callbackHandler - 用于与最终用户通信的 CallbackHandler （例如，提示用户名和密码）。
        sharedState - 共享 LoginModule状态。
        options - 在特定 LoginModule的登录 Configuration指定的选项。

      • login

        public boolean login​()
              throws LoginException
        不推荐用于删除：此API元素将在以后的版本中被删除。
        验证用户（第一阶段）。

        此方法的实现尝试通过本机Solaris系统调用来检索用户的Solaris Subject信息。

        Specified by:
        login在接口 LoginModule
        结果
        在所有情况下都是这样（这个 LoginModule不应该被忽略）。
        异常
        FailedLoginException - 如果尝试检索底层系统信息失败。
        LoginException - 如果身份验证失败

      • commit

        public boolean commit​()
               throws LoginException
        不推荐用于删除：此API元素将在以后的版本中被删除。
        提交认证（第二阶段）。

        如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

        如果此LoginModule自身的身份验证尝试成功（导入Solaris验证信息成功），则此方法将Solaris主体与当前与Subject绑定的LoginModule 。 如果此LoginModule的身份验证尝试失败，则此方法将删除最初保存的任何状态。

        Specified by:
        commit在接口 LoginModule
        结果
        如果此LoginModule自己的登录和提交尝试成功，则为true，否则为false。
        异常
        LoginException - 如果提交失败

      • abort

        public boolean abort​()
              throws LoginException
        不推荐用于删除：此API元素将在以后的版本中被删除。
        中止身份验证（第二阶段）。

        如果LoginContext的整体身份验证失败，则调用此方法。 （相关要求，必要，有效和可选的LoginModules没有成功）。

        此方法可以从login和commit方法中清除原来作为身份验证尝试一部分保存的状态。

        Specified by:
        abort在接口 LoginModule
        结果
        如果此LoginModule自己的登录和/或提交尝试失败，则为false，否则为true。
        异常
        LoginException - 如果中止失败

      • logout

        public boolean logout​()
               throws LoginException
        不推荐用于删除：此API元素将在以后的版本中被删除。
        注销用户

        此方法将删除与Subject相关联的Subject 。

        Specified by:
        logout在接口 LoginModule
        结果
        在所有情况下都是这样（这个 LoginModule不应该被忽略）。
        异常
        LoginException - 如果注销失败
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SolarisSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class SolarisSystem

  • java.lang.Object
    • com.sun.security.auth.module.SolarisSystem
  • 不推荐用于删除：此API元素将在以后的版本中被删除。
    取代UnixSystem 。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="1.4",
            forRemoval=true)
public class SolarisSystem
extends Object
    此类实现检索并提供当前用户的Solaris UID / GID /组信息。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected long gid
      不推荐用于删除：此API元素将在以后的版本中被删除。
      protected long[] groups
      不推荐用于删除：此API元素将在以后的版本中被删除。
      protected long uid
      不推荐用于删除：此API元素将在以后的版本中被删除。
      protected String username
      不推荐用于删除：此API元素将在以后的版本中被删除。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SolarisSystem​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      实例化一个 SolarisSystem并加载本机库以访问底层系统信息。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      long getGid​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      获取当前Solaris用户的GID。
      long[] getGroups​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      获取当前Solaris用户的补充组。
      long getUid​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      获取当前Solaris用户的UID。
      String getUsername​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      获取当前Solaris用户的用户名。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • username

        protected String username
        不推荐用于删除：此API元素将在以后的版本中被删除。

      • uid

        protected long uid
        不推荐用于删除：此API元素将在以后的版本中被删除。

      • gid

        protected long gid
        不推荐用于删除：此API元素将在以后的版本中被删除。

      • groups

        protected long[] groups
        不推荐用于删除：此API元素将在以后的版本中被删除。

    • 构造方法详细信息

      • SolarisSystem

        public SolarisSystem​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        实例化一个 SolarisSystem并加载本机库以访问底层系统信息。

    • 方法详细信息

      • getUsername

        public String getUsername​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        获取当前Solaris用户的用户名。
        结果
        当前Solaris用户的用户名。

      • getUid

        public long getUid​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        获取当前Solaris用户的UID。
        结果
        当前Solaris用户的UID。

      • getGid

        public long getGid​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        获取当前Solaris用户的GID。
        结果
        当前Solaris用户的GID。

      • getGroups

        public long[] getGroups​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        获取当前Solaris用户的补充组。
        结果
        当前Solaris用户的补充组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnixLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class UnixLoginModule

  • java.lang.Object
    • com.sun.security.auth.module.UnixLoginModule
  • All Implemented Interfaces:
    LoginModule

    public class UnixLoginModule
extends Object
implements LoginModule
    这LoginModule导入用户的Unix Principal信息（ UnixPrincipal ， UnixNumericUserPrincipal ，并UnixNumericGroupPrincipal ），并与当前的关联Subject 。

    该LoginModule识别调试选项。 如果在登录配置中设置为true，则调试消息将被输出到输出流System.out。

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnixLoginModule​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean abort​()
      中止身份验证（第二阶段）。
      boolean commit​()
      提交认证（第二阶段）。
      void initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      boolean login​()
      验证用户（第一阶段）。
      boolean logout​()
      注销用户

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UnixLoginModule

        public UnixLoginModule​()

    • 方法详细信息

      • initialize

        public void initialize​(Subject subject,
                       CallbackHandler callbackHandler,
                       Map<String,?> sharedState,
                       Map<String,?> options)
        初始化 LoginModule 。
        Specified by:
        initialize在接口 LoginModule
        参数
        subject - 要验证的 Subject 。
        callbackHandler - 用于与最终用户通信的 CallbackHandler （例如，提示用户名和密码）。
        sharedState - 共享 LoginModule状态。
        options - 在这个特定的 LoginModule的登录 Configuration指定的选项。

      • login

        public boolean login​()
              throws LoginException
        验证用户（第一阶段）。

        该方法的实现尝试通过本机Unix系统调用来检索用户的Unix Subject信息。

        Specified by:
        login在接口 LoginModule
        结果
        在所有情况下都是这样（这个 LoginModule不应该被忽略）。
        异常
        FailedLoginException - 如果检索底层系统信息的尝试失败。
        LoginException - 如果身份验证失败

      • commit

        public boolean commit​()
               throws LoginException
        提交认证（第二阶段）。

        如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

        如果此LoginModule自身的身份验证尝试成功（导入Unix认证信息成功），则该方法将Unix主体与当前与Subject绑定的LoginModule 。 如果此LoginModule的身份验证尝试失败，则此方法将删除最初保存的任何状态。

        Specified by:
        commit在接口 LoginModule
        结果
        如果此LoginModule自己的登录和提交尝试成功，则为true，否则为false。
        异常
        LoginException - 如果提交失败

      • abort

        public boolean abort​()
              throws LoginException
        中止身份验证（第二阶段）。

        如果LoginContext的整体身份验证失败，则调用此方法。 （相关要求，必要，有效和可选的LoginModules没有成功）。

        该方法可以清除login和commit方法最初保存为认证尝试的一部分的状态。

        Specified by:
        abort在接口 LoginModule
        结果
        如果此LoginModule自己的登录和/或提交尝试失败，则为false，否则为true。
        异常
        LoginException - 如果中止失败

      • logout

        public boolean logout​()
               throws LoginException
        注销用户

        此方法将删除与Subject相关联的Subject 。

        Specified by:
        logout在接口 LoginModule
        结果
        在所有情况下都是这样（这个 LoginModule不应该被忽略）。
        异常
        LoginException - 如果注销失败
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnixSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.security.auth
软件包 com.sun.security.auth.module

Class UnixSystem

  • java.lang.Object
    • com.sun.security.auth.module.UnixSystem

  • public class UnixSystem
extends Object
    此类实现检索并提供当前用户的Unix UID / GID /组信息。

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      protected long | gid
      protected long[] | groups
      protected long | uid
      protected String | username

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnixSystem​()
      实例化一个 UnixSystem并加载本机库以访问底层系统信息。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      long getGid​()
      获取当前Unix用户的GID。
      long[] getGroups​()
      获取当前Unix用户的补充组。
      long getUid​()
      获取当前Unix用户的UID。
      String getUsername​()
      获取当前Unix用户的用户名。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • username

        protected String username

      • uid

        protected long uid

      • gid

        protected long gid

      • groups

        protected long[] groups

    • 构造方法详细信息

      • UnixSystem

        public UnixSystem​()
        实例化一个 UnixSystem并加载本机库以访问底层系统信息。

    • 方法详细信息

      • getUsername

        public String getUsername​()
        获取当前Unix用户的用户名。
        结果
        当前Unix用户的用户名。

      • getUid

        public long getUid​()
        获取当前Unix用户的UID。
        结果
        当前Unix用户的UID。

      • getGid

        public long getGid​()
        获取当前Unix用户的GID。
        结果
        当前Unix用户的GID。

      • getGroups

        public long[] getGroups​()
        获取当前Unix用户的补充组。
        结果
        当前Unix用户的补充组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.security.auth.module (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.security.auth.module

No usage of com.sun.security.auth.module
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.JndiLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.JndiLoginModule

No usage of com.sun.security.auth.module.JndiLoginModule
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.KeyStoreLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.KeyStoreLoginModule

No usage of com.sun.security.auth.module.KeyStoreLoginModule
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.Krb5LoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.Krb5LoginModule

No usage of com.sun.security.auth.module.Krb5LoginModule
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.LdapLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.LdapLoginModule

No usage of com.sun.security.auth.module.LdapLoginModule
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.NTLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.NTLoginModule

No usage of com.sun.security.auth.module.NTLoginModule
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.NTSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.NTSystem

No usage of com.sun.security.auth.module.NTSystem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.SolarisLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.SolarisLoginModule

No usage of com.sun.security.auth.module.SolarisLoginModule
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.SolarisSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.SolarisSystem

No usage of com.sun.security.auth.module.SolarisSystem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.UnixLoginModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.UnixLoginModule

No usage of com.sun.security.auth.module.UnixLoginModule
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.auth.module.UnixSystem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.auth.module.UnixSystem

No usage of com.sun.security.auth.module.UnixSystem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AuthorizationDataEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.jgss
软件包 com.sun.security.jgss

Class AuthorizationDataEntry

  • java.lang.Object
    • com.sun.security.jgss.AuthorizationDataEntry

  • public final class AuthorizationDataEntry
extends Object
    Kerberos 5 AuthorizationData条目。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AuthorizationDataEntry​(int type, byte[] data)
      创建AuthorizationDataEntry对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[] getData​()
      获取广告数据字段的副本。
      int getType​()
      获取广告类型字段。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AuthorizationDataEntry

        public AuthorizationDataEntry​(int type,
                              byte[] data)
        创建AuthorizationDataEntry对象。
        参数
        type - 广告类型
        data - ad数据，数据副本将保存在对象内。

    • 方法详细信息

      • getType

        public int getType​()
        获取广告类型字段。
        结果
        广告类型

      • getData

        public byte[] getData​()
        获取广告数据字段的副本。
        结果
        广告数据

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.security.jgss (Java SE 9 & JDK 9 )

com.sun.security.jgss

Interfaces

  • ExtendedGSSContext
  • ExtendedGSSCredential

Classes

  • AuthorizationDataEntry
  • GSSUtil
  • InquireSecContextPermission

Enums

  • InquireType


com.sun.security.jgss (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.security.jgss

Package com.sun.security.jgss

  • 接口摘要
    接口 描述
    ExtendedGSSContext
    扩展的GSSContext接口，用于支持未由 org.ietf.jgss.GSSContext定义的其他功能，例如查询上下文特定的属性。
    ExtendedGSSCredential
    扩展的GSSCredential接口，用于支持未由 org.ietf.jgss.GSSCredential定义的附加功能。
  • 类摘要
    Class 描述
    AuthorizationDataEntry
    Kerberos 5 AuthorizationData条目。
    GSSUtil
    GSS-API实用程序与Sun Microsystem的Java GSS-API实现结合使用。
    InquireSecContextPermission
    该类用于保护可以使用 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立的GSS安全上下文的各种属性。
  • 枚举摘要
    Enum 描述
    InquireType
    可以指定为 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)的参数的属性类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.security.jgss Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.security.jgss

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.security.jgss.AuthorizationDataEntry
    • com.sun.security.jgss.GSSUtil
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • com.sun.security.jgss.InquireSecContextPermission

Interface Hierarchy

  • java.lang.Cloneable
    • org.ietf.jgss.GSSCredential
      • com.sun.security.jgss.ExtendedGSSCredential
  • org.ietf.jgss.GSSContext
    • com.sun.security.jgss.ExtendedGSSContext

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.security.jgss.InquireType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ExtendedGSSContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.jgss
软件包 com.sun.security.jgss

Interface ExtendedGSSContext

  • All Superinterfaces:
    GSSContext

    public interface ExtendedGSSContext
extends GSSContext
    扩展的GSSContext接口，用于支持未由 org.ietf.jgss.GSSContext定义的其他功能，例如查询上下文相关属性。

    • Field Summary

      • Fields inherited from interface org.ietf.jgss.GSSContext

        DEFAULT_LIFETIME, INDEFINITE_LIFETIME

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean getDelegPolicyState​()
      返回委派策略响应。
      Object inquireSecContext​(InquireType type)
      返回与 type相关联的机制特定属性。
      void requestDelegPolicy​(boolean state)
      要求尊重授权政策。

      • Methods inherited from interface org.ietf.jgss.GSSContext

        acceptSecContext, acceptSecContext, dispose, export, getAnonymityState, getConfState, getCredDelegState, getDelegCred, getIntegState, getLifetime, getMech, getMIC, getMIC, getMutualAuthState, getReplayDetState, getSequenceDetState, getSrcName, getTargName, getWrapSizeLimit, initSecContext, initSecContext, isEstablished, isInitiator, isProtReady, isTransferable, requestAnonymity, requestConf, requestCredDeleg, requestInteg, requestLifetime, requestMutualAuth, requestReplayDet, requestSequenceDet, setChannelBinding, unwrap, unwrap, verifyMIC, verifyMIC, wrap, wrap

    • 方法详细信息

      • inquireSecContext

        Object inquireSecContext​(InquireType type)
                  throws GSSException
        返回与type相关联的机制特定属性。

        如果有安全管理器，一个InquireSecContextPermission名称为type.mech必须被授予。 否则，这可能会导致一个SecurityException 。

        例：

          GSSContext ctxt = m.createContext(...)
      // Establishing the context
      if (ctxt instanceof ExtendedGSSContext) {
          ExtendedGSSContext ex = (ExtendedGSSContext)ctxt;
          try {
              Key key = (key)ex.inquireSecContext(
                      InquireType.KRB5_GET_SESSION_KEY);
              // read key info
          } catch (GSSException gsse) {
              // deal with exception
          }
      }
        参数
        type - 请求的属性的类型
        结果
        属性，请参阅方法文档了解详细信息。
        异常
        GSSException - 包含以下主要错误代码： GSSException.BAD_MECH如果机制不支持此方法， GSSException.UNAVAILABLE如果指定的类型不受支持，则 GSSException.NO_CONTEXT如果安全上下文无效，则 GSSException.FAILURE用于其他未指定的故障。
        SecurityException - 如果存在安全管理员，并且没有授予正确的InquireSecContextPermission 。
        另请参见：
        InquireSecContextPermission ， InquireType

      • requestDelegPolicy

        void requestDelegPolicy​(boolean state)
                 throws GSSException
        要求尊重授权政策。 当请求真值时，底层环境将使用环境定义的委派策略作为提示来确定是否应执行凭据委派。 该请求只能在上下文发起方进行，并且必须在首次调用initSecContext之前完成。

        当这个标志为false时，授权只有在credentials delegation flag为真时才会被尝试。

        当这个标志是真的，但是credentials delegation flag是假的，代表团将只有在授权委托的情况下才会审判。

        当这个标志和credentials delegation flag都是真实的，授权将始终被尝试。 但是，如果委托政策不允许授权，即使委托成功， getDelegPolicyState()的值也是假的。

        无论如何，如果委托不成功，由GSSContext.getCredDelegState()返回的值为 false，并且返回的值为getDelegPolicyState()也是假的。

        并非所有机制都支持委托政策。 因此，应用程序应检查该请求是否符合getDelegPolicyState方法。 当不支持委托策略时， requestDelegPolicy应该默认返回，而不会抛出异常。

        注意：对于Kerberos 5机制，委托策略通过服务故障单中的OK-AS-DELEGATE标志来表示。 当它是真的，KDC允许委派到目标服务器。 在跨域环境中，为了允许委派，认证路径上的所有跨域TGT也必须设置OK-AS-DELAGATE标志。

        参数
        state - 如果政策得到尊重， state真
        异常
        GSSException - 包含以下主要错误代码： GSSException.FAILURE

      • getDelegPolicyState

        boolean getDelegPolicyState​()
        返回委派策略响应。 在建立安全上下文后调用。 这个方法只能在启动器的一边调用。 见requestDelegPolicy(boolean) 。
        结果
        代表团的政策回应
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExtendedGSSCredential (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.jgss
软件包 com.sun.security.jgss

Interface ExtendedGSSCredential

  • All Superinterfaces:
    Cloneable ， GSSCredential

    public interface ExtendedGSSCredential
extends GSSCredential
    扩展的GSSCredential接口，用于支持未定义的附加功能 org.ietf.jgss.GSSCredential 。
    从以下版本开始：
    1.8

    • Field Summary

      • Fields inherited from interface org.ietf.jgss.GSSCredential

        ACCEPT_ONLY, DEFAULT_LIFETIME, INDEFINITE_LIFETIME, INITIATE_AND_ACCEPT, INITIATE_ONLY

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      GSSCredential impersonate​(GSSName name)
      假冒一名校长

      • Methods inherited from interface org.ietf.jgss.GSSCredential

        add, dispose, equals, getMechs, getName, getName, getRemainingAcceptLifetime, getRemainingInitLifetime, getRemainingLifetime, getUsage, getUsage, hashCode

    • 方法详细信息

      • impersonate

        GSSCredential impersonate​(GSSName name)
                   throws GSSException
        假冒一名校长 在Kerberos中，可以使用Microsoft S4U2self扩展来实现。

        如果模拟失败，将抛出A GSSException.NO_CRED 。 如果此凭证对象不可用模拟方法，则会抛出GSSException.FAILURE 。

        参数
        name - 假冒的校长的姓名
        结果
        该委托人的凭证
        异常
        GSSException - 包含以下主要错误代码： GSSException.NO_CRED GSSException.FAILURE
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GSSUtil (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.jgss
软件包 com.sun.security.jgss

Class GSSUtil

  • java.lang.Object
    • com.sun.security.jgss.GSSUtil

  • public class GSSUtil
extends Object
    GSS-API实用程序与Sun Microsystem的Java GSS-API实现结合使用。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GSSUtil​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Subject createSubject​(GSSName principals, GSSCredential credentials)
      使用此方法将GSSName和GSSCredential转换为主题。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GSSUtil

        public GSSUtil​()

    • 方法详细信息

      • createSubject

        public static Subject createSubject​(GSSName principals,
                                    GSSCredential credentials)
        使用此方法将GSSName和GSSCredential转换为主题。 通常，这将由想要通过在当前访问控制上下文中设置客户端主题在Java级别模拟客户端线程的服务器来完成。 如果服务器仅在其本地JVM中使用基于主体的策略感兴趣，那么它只需要提供客户端的GSSName。 来自GSSName的元素将放置在此主题的主体集合中，GSSCredential的元素将放置在Subject的私有凭据集中。 添加到主题的任何Kerberos特定元素都将是javax.security.auth.kerberos中定义的标准Kerberos实现类的实例。
        参数
        principals - 包含同一实体的一个或多个机制特定表示的GSSName。 这些机制特定的表示将被填充在返回的主题的主体集中。
        credentials - 包含同一实体的一个或多个机制特定凭据的GSSCredential。 这些机制的特定凭据将被填充在返回的主题的私人凭据集中。 传递值为null将意味着私人凭据集应该为空。
        结果
        一个主题，其中包含来自给定GSSName和GSSCredential的元素的条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InquireSecContextPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.security.jgss
软件包 com.sun.security.jgss

Class InquireSecContextPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • com.sun.security.jgss.InquireSecContextPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class InquireSecContextPermission
extends BasicPermission
    该类用于保护可以使用ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立GSS安全上下文的各种属性。

    目标名称是允许的InquireType 。

    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InquireSecContextPermission​(String name)
      构造具有指定名称的新的 InquireSecContextPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • InquireSecContextPermission

        public InquireSecContextPermission​(String name)
        构造具有指定名称的新的InquireSecContextPermission对象。 该名称是允许的InquireType的符号名称。
        参数
        name - 本许可允许的InquireType 。 “*”表示全部允许InquireType 。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InquireType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.security.jgss
软件包 com.sun.security.jgss

Enum InquireType

  • java.lang.Object
    • java.lang.Enum<InquireType>
      • com.sun.security.jgss.InquireType
  • All Implemented Interfaces:
    Serializable ， Comparable<InquireType>

    public enum InquireType
extends Enum<InquireType>
    可以指定为 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)的参数的属性类型

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      KRB5_GET_AUTHTIME
      用于检索已建立的Kerberos 5安全上下文的服务票证中的authtime的属性类型。
      KRB5_GET_AUTHZ_DATA
      用于检索已建立的Kerberos 5安全上下文的服务票证中的授权数据的属性类型。
      KRB5_GET_KRB_CRED
      用于检索启动器即将发送给接受者的KRB_CRED消息的属性类型。
      KRB5_GET_SESSION_KEY
      已过时。
      作为图9中，由替换KRB5_GET_SESSION_KEY_EX返回的实例EncryptionKey一个实现SecretKey接口并具有类似的方法KerberosKey 。
      KRB5_GET_SESSION_KEY_EX
      用于检索已建立的Kerberos 5安全上下文的会话密钥的属性类型。
      KRB5_GET_TKT_FLAGS
      用于检索已建立的Kerberos 5安全上下文的服务票证标志的属性类型。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static InquireType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static InquireType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • KRB5_GET_SESSION_KEY

        @Deprecated
public static final InquireType KRB5_GET_SESSION_KEY
        已过时。 截至9，替换为KRB5_GET_SESSION_KEY_EX ，其返回实现SecretKey接口的EncryptionKey的实例，并具有与KerberosKey类似的方法。
        用于检索已建立的Kerberos 5安全上下文的会话密钥的属性类型。 返回的对象是一个Key的实例，具有以下属性：
        • 算法：enctype作为字符串，其中enctype在RFC 3961第8节中定义。
        • 格式：“RAW”
        • 编码形式：原始密钥字节，不在任何ASN.1编码

      • KRB5_GET_SESSION_KEY_EX

        public static final InquireType KRB5_GET_SESSION_KEY_EX
        用于检索已建立的Kerberos 5安全上下文的会话密钥的属性类型。 返回值为EncryptionKey的一个实例。
        从以下版本开始：
        9

      • KRB5_GET_TKT_FLAGS

        public static final InquireType KRB5_GET_TKT_FLAGS
        用于检索已建立的Kerberos 5安全上下文的服务票证标志的属性类型。 返回的对象是服务票据标志的布尔数组，其长度足以包含所有真实位。 这意味着如果用户想要获取第n位，但是返回的数组的长度小于n ，则被认为是假的。

      • KRB5_GET_AUTHZ_DATA

        public static final InquireType KRB5_GET_AUTHZ_DATA
        用于检索已建立的Kerberos 5安全上下文的服务票证中的授权数据的属性类型。 只在受体方支持。

      • KRB5_GET_AUTHTIME

        public static final InquireType KRB5_GET_AUTHTIME
        用于检索已建立的Kerberos 5安全上下文的服务票证中的authtime的属性类型。 返回的对象是RFC 4120第5.2.3节中定义的标准KerberosTime格式的String对象。

      • KRB5_GET_KRB_CRED

        public static final InquireType KRB5_GET_KRB_CRED
        用于检索启动器即将发送给接受者的KRB_CRED消息的属性类型。 返回类型是KerberosCredMessage的一个实例。
        从以下版本开始：
        9

    • 方法详细信息

      • values

        public static InquireType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (InquireType c : InquireType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static InquireType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.security.jgss (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.security.jgss

  • Packages that use com.sun.security.jgss
    软件包 描述
    com.sun.security.jgss
  • Classes in com.sun.security.jgss used by com.sun.security.jgss
    Class 描述
    InquireType
    Attribute types that can be specified as an argument of ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.jgss.AuthorizationDataEntry (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.jgss.AuthorizationDataEntry

No usage of com.sun.security.jgss.AuthorizationDataEntry
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.jgss.GSSUtil (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.jgss.GSSUtil

No usage of com.sun.security.jgss.GSSUtil
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.jgss.InquireSecContextPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.jgss.InquireSecContextPermission

No usage of com.sun.security.jgss.InquireSecContextPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.security.jgss.InquireType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.security.jgss.InquireType

  • Packages that use InquireType
    软件包 描述
    com.sun.security.jgss

    • Uses of InquireType in com.sun.security.jgss

      Methods in com.sun.security.jgss that return InquireType
      Modifier and Type 方法 描述
      static InquireType InquireType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static InquireType[] InquireType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in com.sun.security.jgss with parameters of type InquireType
      Modifier and Type 方法 描述
      Object ExtendedGSSContext.inquireSecContext​(InquireType type)
      返回与 type关联的机制特定属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.security.jgss.ExtendedGSSContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.security.jgss.ExtendedGSSContext

No usage of com.sun.security.jgss.ExtendedGSSContext
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.security.jgss.ExtendedGSSCredential (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.security.jgss.ExtendedGSSCredential

No usage of com.sun.security.jgss.ExtendedGSSCredential
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AttributeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface AttributeTree

  • All Superinterfaces:
    DocTree

    public interface AttributeTree
extends DocTree
    HTML元素中属性的树节点。
    从以下版本开始：
    1.8

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  AttributeTree.ValueKind
      属性值的种类。

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getName​()
      返回属性的名称。
      List<? extends DocTree> getValue​()
      返回属性的值，如果该类型为EMPTY，则返回 null 。
      AttributeTree.ValueKind getValueKind​()
      返回属性的种类。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getName

        Name getName​()
        返回属性的名称。
        结果
        属性的名称

      • getValueKind

        AttributeTree.ValueKind getValueKind​()
        返回属性的种类。
        结果
        属性的种类。

      • getValue

        List<? extends DocTree> getValue​()
        返回属性的值，如果该类型为EMPTY，则返回 null 。
        结果
        the value of the attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AttributeTree.ValueKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Enum AttributeTree.ValueKind

  • java.lang.Object
    • java.lang.Enum<AttributeTree.ValueKind>
      • com.sun.source.doctree.AttributeTree.ValueKind
  • All Implemented Interfaces:
    Serializable ， Comparable<AttributeTree.ValueKind>
    Enclosing interface:
    AttributeTree

    public static enum AttributeTree.ValueKind
extends Enum<AttributeTree.ValueKind>
    属性值的种类。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DOUBLE
      属性值用双引号括起来。
      EMPTY
      属性值为空。
      SINGLE
      属性值用单引号括起来。
      UNQUOTED
      属性值不包含在引号中。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static AttributeTree.ValueKind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AttributeTree.ValueKind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • EMPTY

        public static final AttributeTree.ValueKind EMPTY
        属性值为空。

      • UNQUOTED

        public static final AttributeTree.ValueKind UNQUOTED
        属性值不包含在引号中。

      • SINGLE

        public static final AttributeTree.ValueKind SINGLE
        属性值用单引号括起来。

      • DOUBLE

        public static final AttributeTree.ValueKind DOUBLE
        属性值用双引号括起来。

    • 方法详细信息

      • values

        public static AttributeTree.ValueKind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (AttributeTree.ValueKind c : AttributeTree.ValueKind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static AttributeTree.ValueKind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


AuthorTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface AuthorTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface AuthorTree
extends BlockTagTree
    @author块标记的树形节点。

    @author名称 - 文本。

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getName​()
      返回作者的名称。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getName

        List<? extends DocTree> getName​()
        返回作者的名称。
        结果
        名字
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BlockTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface BlockTagTree

  • All Superinterfaces:
    DocTree
    All Known Subinterfaces:
    AuthorTree ， DeprecatedTree ， HiddenTree ， ParamTree ， ProvidesTree ， ReturnTree ， SeeTree ， SerialDataTree ， SerialFieldTree ， SerialTree ， SinceTree ， ThrowsTree ， UnknownBlockTagTree ， UsesTree ， VersionTree

    public interface BlockTagTree
extends DocTree
    一个树节点用作不同类型的块标签的基类。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getTagName​()
      返回标签的名称。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getTagName

        String getTagName​()
        返回标签的名称。
        结果
        the name of the tag
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.source.doctree (Java SE 9 & JDK 9 )

com.sun.source.doctree

Interfaces

  • AttributeTree
  • AuthorTree
  • BlockTagTree
  • CommentTree
  • DeprecatedTree
  • DocCommentTree
  • DocRootTree
  • DocTree
  • DocTreeVisitor
  • EndElementTree
  • EntityTree
  • ErroneousTree
  • HiddenTree
  • IdentifierTree
  • IndexTree
  • InheritDocTree
  • InlineTagTree
  • LinkTree
  • LiteralTree
  • ParamTree
  • ProvidesTree
  • ReferenceTree
  • ReturnTree
  • SeeTree
  • SerialDataTree
  • SerialFieldTree
  • SerialTree
  • SinceTree
  • StartElementTree
  • TextTree
  • ThrowsTree
  • UnknownBlockTagTree
  • UnknownInlineTagTree
  • UsesTree
  • ValueTree
  • VersionTree

Enums

  • AttributeTree.ValueKind
  • DocTree.Kind


com.sun.source.doctree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.compiler

Package com.sun.source.doctree

提供用于将文档注释表示为抽象语法树（AST）的接口。
从以下版本开始：
1.8
另请参见：
Documentation Comment Specification for the Standard Doclet
  • 接口摘要
    接口 描述
    AttributeTree
    HTML元素中属性的树节点。
    AuthorTree
    @author块标记的树形节点。
    BlockTagTree
    一个树节点用作不同类型的块标签的基类。
    CommentTree
    嵌入式HTML注释。
    DeprecatedTree
    @deprecated块标记的树节点。
    DocCommentTree
    文档评论的顶级代表。
    DocRootTree
    @docroot内联标记的树形节点。
    DocTree
    文档语法树中所有节点的公共接口。
    DocTreeVisitor<R,P>
    树木的访客，以访客设计模式的风格。
    EndElementTree
    用于HTML元素结尾的树节点。
    EntityTree
    HTML实体的树节点。
    ErroneousTree
    一个树状节点，用于生成格式不正确的文本
    HiddenTree
    @hidden块标记的树节点。
    IdentifierTree
    文档注释中的标识符。
    IndexTree
    @index或@index内联标记的树形节点。
    InheritDocTree
    @inheritDoc内联标记的树形节点。
    InlineTagTree
    一个树节点用作不同类型的内联标签的基类。
    LinkTree
    @link或@linkplain内联标记的树形节点。
    LiteralTree
    @literal或@code内联标记的树状结点。
    ParamTree
    @param块标记的树节点。
    ProvidesTree
    @provides块标记的树节点。
    ReferenceTree
    用于引用Java语言元素的树节点。
    ReturnTree
    一个@return块标记的树节点。
    SeeTree
    @see块标记的树节点。
    SerialDataTree
    @serialData块标记的树节点。
    SerialFieldTree
    @serialData块标记的树节点。
    SerialTree
    @serial块标记的树节点。
    SinceTree
    @since块标记的树节点。
    StartElementTree
    用于开始HTML元素的树节点。
    TextTree
    纯文本的树节点。
    ThrowsTree
    @exception或@throws块标记的树节点。
    UnknownBlockTagTree
    用于无法识别的内联标签的树节点。
    UnknownInlineTagTree
    用于无法识别的内联标签的树节点。
    UsesTree
    用于@uses块标记的树节点。
    ValueTree
    @value内联标记的树形节点。
    VersionTree
    用于@version块标记的树节点。
  • 枚举摘要
    Enum 描述
    AttributeTree.ValueKind
    属性值的种类。
    DocTree.Kind
    列举各种树木。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.source.doctree Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.source.doctree

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • com.sun.source.doctree.DocTree
    • com.sun.source.doctree.AttributeTree
    • com.sun.source.doctree.BlockTagTree
      • com.sun.source.doctree.AuthorTree
      • com.sun.source.doctree.DeprecatedTree
      • com.sun.source.doctree.HiddenTree
      • com.sun.source.doctree.ParamTree
      • com.sun.source.doctree.ProvidesTree
      • com.sun.source.doctree.ReturnTree
      • com.sun.source.doctree.SeeTree
      • com.sun.source.doctree.SerialDataTree
      • com.sun.source.doctree.SerialFieldTree
      • com.sun.source.doctree.SerialTree
      • com.sun.source.doctree.SinceTree
      • com.sun.source.doctree.ThrowsTree
      • com.sun.source.doctree.UnknownBlockTagTree
      • com.sun.source.doctree.UsesTree
      • com.sun.source.doctree.VersionTree
    • com.sun.source.doctree.CommentTree
    • com.sun.source.doctree.DocCommentTree
    • com.sun.source.doctree.EndElementTree
    • com.sun.source.doctree.EntityTree
    • com.sun.source.doctree.IdentifierTree
    • com.sun.source.doctree.InlineTagTree
      • com.sun.source.doctree.DocRootTree
      • com.sun.source.doctree.IndexTree
      • com.sun.source.doctree.InheritDocTree
      • com.sun.source.doctree.LinkTree
      • com.sun.source.doctree.LiteralTree
      • com.sun.source.doctree.UnknownInlineTagTree
      • com.sun.source.doctree.ValueTree
    • com.sun.source.doctree.ReferenceTree
    • com.sun.source.doctree.StartElementTree
    • com.sun.source.doctree.TextTree
      • com.sun.source.doctree.ErroneousTree
  • com.sun.source.doctree.DocTreeVisitor<R,P>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.source.doctree.AttributeTree.ValueKind
      • com.sun.source.doctree.DocTree.Kind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


CommentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface CommentTree

  • All Superinterfaces:
    DocTree

    public interface CommentTree
extends DocTree
    嵌入式HTML注释。

    <！ - text - >

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getBody​()
      返回注释的文本。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getBody

        String getBody​()
        返回注释的文本。
        结果
        评论文字
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DeprecatedTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface DeprecatedTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface DeprecatedTree
extends BlockTagTree
    @deprecated块标记的树节点。

    @deprecated已弃用的文字。

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getBody​()
      返回解释为什么不推荐使用某项的描述。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getBody

        List<? extends DocTree> getBody​()
        返回解释为什么不推荐使用某项的描述。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocCommentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface DocCommentTree

  • All Superinterfaces:
    DocTree

    public interface DocCommentTree
extends DocTree
    文档评论的顶级代表。

    第一句身体块标签

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      List<? extends DocTree> getBlockTags​()
      返回文档注释的块标签。
      List<? extends DocTree> getBody​()
      返回文档注释的正文，出现在第一个句子之后，并返回任何块标记之前。
      List<? extends DocTree> getFirstSentence​()
      返回文档注释的第一个句子。
      default List<? extends DocTree> getFullBody​()
      返回文档注释的整个正文，出现在任何块标记之前，包括第一个句子。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getFirstSentence

        List<? extends DocTree> getFirstSentence​()
        返回文档注释的第一个句子。
        结果
        文件评论的第一句话

      • getFullBody

        default List<? extends DocTree> getFullBody​()
        返回文档注释的整个正文，出现在任何块标记之前，包括第一个句子。
        结果
        身份的文件评论第一句话包括在内
        从以下版本开始：
        9

      • getBody

        List<? extends DocTree> getBody​()
        返回文档注释的正文，出现在第一个句子之后，并返回任何块标记之前。
        结果
        身体的文件评论

      • getBlockTags

        List<? extends DocTree> getBlockTags​()
        返回文档注释的块标签。
        结果
        文档注释的块标签
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocRootTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface DocRootTree

  • All Superinterfaces:
    DocTree ， InlineTagTree

    public interface DocRootTree
extends InlineTagTree
    @docroot内联标记的树形节点。

    {} @docroot

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.InlineTagTree

        getTagName
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface DocTree

  • All Known Subinterfaces:
    AttributeTree ， AuthorTree ， BlockTagTree ， CommentTree ， DeprecatedTree ， DocCommentTree ， DocRootTree ， EndElementTree ， EntityTree ， ErroneousTree ， HiddenTree ， IdentifierTree ， IndexTree ， InheritDocTree ， InlineTagTree ， LinkTree ， LiteralTree ， ParamTree ， ProvidesTree ， ReferenceTree ， ReturnTree ， SeeTree ， SerialDataTree ， SerialFieldTree ， SerialTree ， SinceTree ， StartElementTree ， TextTree ， ThrowsTree ， UnknownBlockTagTree ， UnknownInlineTagTree ， UsesTree ， ValueTree ， VersionTree

    public interface DocTree
    文档语法树中所有节点的公共接口。
    从以下版本开始：
    1.8

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  DocTree.Kind
      列举各种树木。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      <R,D> R accept​(DocTreeVisitor<R,D> visitor, D data)
      用于实现访问者模式的接受方法。
      DocTree.Kind getKind​()
      返回此树的种类。

    • 方法详细信息

      • getKind

        DocTree.Kind getKind​()
        返回此树的种类。
        结果
        这种树的种类。

      • accept

        <R,D> R accept​(DocTreeVisitor<R,D> visitor,
               D data)
        用于实现访问者模式的接受方法。 访问者模式用于对树进行操作。
        参数类型
        R - 此操作的结果类型。
        D - 附加数据类型。
        参数
        visitor - 被叫的访客
        data - 要传递给访问者方法的参数值
        结果
        从访问者方法返回的值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocTree.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • Field |
  • 方法
  • 详细信息：
  • Enum Constants |
  • Field |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Enum DocTree.Kind

  • java.lang.Object
    • java.lang.Enum<DocTree.Kind>
      • com.sun.source.doctree.DocTree.Kind
  • All Implemented Interfaces:
    Serializable ， Comparable<DocTree.Kind>
    Enclosing interface:
    DocTree

    public static enum DocTree.Kind
extends Enum<DocTree.Kind>
    列举各种树木。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ATTRIBUTE
      用于表示HTML属性的AttributeTree的实例。
      AUTHOR
      用于表示@author标签的AuthorTree的实例。
      CODE
      用于表示@code标签的LiteralTree的实例。
      COMMENT
      用于表示HTML注释的CommentTree的实例。
      DEPRECATED
      用于实例DeprecatedTree表示@deprecated标记。
      DOC_COMMENT
      用于表示完整文档注释的DocCommentTree的实例。
      DOC_ROOT
      用于实例DocRootTree表示@docRoot标签。
      END_ELEMENT
      用于表示HTML元素结尾的EndElementTree的实例。
      ENTITY
      用于表示HTML实体的EntityTree的实例。
      ERRONEOUS
      用于表示一些无效文本的ErroneousTree的实例。
      EXCEPTION
      用于表示@exception标签的ThrowsTree的实例。
      HIDDEN
      用于实例HiddenTree表示@hidden标签。
      IDENTIFIER
      用于表示标识符的IdentifierTree的实例。
      INDEX
      用于表示搜索项的IndexTree的实例。
      INHERIT_DOC
      用于实例InheritDocTree表示@inheritDoc标签。
      LINK
      用于表示@link标签的LinkTree的实例。
      LINK_PLAIN
      用于实例LinkTree表示@linkplain标签。
      LITERAL
      用于实例LiteralTree表示@literal标签。
      OTHER
      实现保留节点。
      PARAM
      用于表示@param标签的ParamTree的实例。
      PROVIDES
      用于表示@provides标记的ProvidesTree的实例。
      REFERENCE
      用于表示对Java编程语言中的元素的引用的ReferenceTree的实例。
      RETURN
      用于代表一个@return标签的ReturnTree的实例。
      SEE
      用于表示@see标签的SeeTree的实例。
      SERIAL
      用于实例SerialTree表示@serial标签。
      SERIAL_DATA
      用于实例SerialDataTree表示@serialData标签。
      SERIAL_FIELD
      用于表示@serialField标记的SerialFieldTree的实例。
      SINCE
      用于实例SinceTree表示@Since标签。
      START_ELEMENT
      用于表示HTML元素开始的EndElementTree的实例。
      TEXT
      用于表示一些文档文本的TextTree的实例。
      THROWS
      用于表示@throws标签的ThrowsTree的实例。
      UNKNOWN_BLOCK_TAG
      用于表示未知块标签的UnknownBlockTagTree的实例。
      UNKNOWN_INLINE_TAG
      用于表示未知内联标签的UnknownInlineTagTree的实例。
      USES
      用于实例UsesTree表示@uses标签。
      VALUE
      用于表示@value标签的ValueTree的实例。
      VERSION
      用于表示一个@version标签的VersionTree的实例。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      String tagName
      与此类节点相关联的标记名称（如果有）。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static DocTree.Kind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DocTree.Kind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ATTRIBUTE

        public static final DocTree.Kind ATTRIBUTE
        用于表示HTML属性的AttributeTree的实例。

      • AUTHOR

        public static final DocTree.Kind AUTHOR
        用于表示@author标签的AuthorTree的实例。

      • CODE

        public static final DocTree.Kind CODE
        用于表示@code标签的LiteralTree的实例。

      • COMMENT

        public static final DocTree.Kind COMMENT
        用于表示HTML注释的CommentTree的实例。

      • DEPRECATED

        public static final DocTree.Kind DEPRECATED
        用于实例DeprecatedTree表示@deprecated标记。

      • DOC_COMMENT

        public static final DocTree.Kind DOC_COMMENT
        用于表示完整文档注释的DocCommentTree的实例。

      • DOC_ROOT

        public static final DocTree.Kind DOC_ROOT
        用于实例DocRootTree表示@docRoot标签。

      • END_ELEMENT

        public static final DocTree.Kind END_ELEMENT
        用于表示HTML元素结尾的EndElementTree的实例。

      • ENTITY

        public static final DocTree.Kind ENTITY
        用于表示HTML实体的EntityTree的实例。

      • ERRONEOUS

        public static final DocTree.Kind ERRONEOUS
        用于表示一些无效文本的ErroneousTree的实例。

      • EXCEPTION

        public static final DocTree.Kind EXCEPTION
        用于表示@exception标签的ThrowsTree的实例。

      • HIDDEN

        public static final DocTree.Kind HIDDEN
        用于实例HiddenTree表示@hidden标签。

      • IDENTIFIER

        public static final DocTree.Kind IDENTIFIER
        用于表示标识符的IdentifierTree的实例。

      • INDEX

        public static final DocTree.Kind INDEX
        用于表示搜索项的IndexTree的实例。

      • INHERIT_DOC

        public static final DocTree.Kind INHERIT_DOC
        用于实例InheritDocTree表示@inheritDoc标签。

      • LINK

        public static final DocTree.Kind LINK
        用于表示@link标签的LinkTree的实例。

      • LINK_PLAIN

        public static final DocTree.Kind LINK_PLAIN
        用于实例LinkTree表示@linkplain标签。

      • LITERAL

        public static final DocTree.Kind LITERAL
        用于实例LiteralTree表示@literal标签。

      • PARAM

        public static final DocTree.Kind PARAM
        用于表示@param标签的ParamTree的实例。

      • PROVIDES

        public static final DocTree.Kind PROVIDES
        用于表示@provides标记的ProvidesTree的实例。

      • REFERENCE

        public static final DocTree.Kind REFERENCE
        用于表示对Java编程语言中的元素的引用的ReferenceTree的实例。

      • RETURN

        public static final DocTree.Kind RETURN
        用于代表一个@return标签的ReturnTree的实例。

      • SEE

        public static final DocTree.Kind SEE
        用于表示@see标签的SeeTree的实例。

      • SERIAL

        public static final DocTree.Kind SERIAL
        用于实例SerialTree表示@serial标签。

      • SERIAL_DATA

        public static final DocTree.Kind SERIAL_DATA
        用于实例SerialDataTree表示@serialData标签。

      • SERIAL_FIELD

        public static final DocTree.Kind SERIAL_FIELD
        用于表示@serialField标记的SerialFieldTree的实例。

      • SINCE

        public static final DocTree.Kind SINCE
        用于实例SinceTree表示@Since标签。

      • START_ELEMENT

        public static final DocTree.Kind START_ELEMENT
        用于表示HTML元素开始的EndElementTree的实例。

      • TEXT

        public static final DocTree.Kind TEXT
        用于表示一些文档文本的TextTree的实例。

      • THROWS

        public static final DocTree.Kind THROWS
        用于表示@throws标签的ThrowsTree的实例。

      • UNKNOWN_BLOCK_TAG

        public static final DocTree.Kind UNKNOWN_BLOCK_TAG
        用于表示未知块标签的UnknownBlockTagTree的实例。

      • UNKNOWN_INLINE_TAG

        public static final DocTree.Kind UNKNOWN_INLINE_TAG
        用于表示未知内联标签的UnknownInlineTagTree的实例。

      • USES

        public static final DocTree.Kind USES
        用于实例UsesTree表示@uses标签。

      • VALUE

        public static final DocTree.Kind VALUE
        用于表示@value标签的ValueTree的实例。

      • VERSION

        public static final DocTree.Kind VERSION
        用于代表一个@version标签的VersionTree的实例。

      • OTHER

        public static final DocTree.Kind OTHER
        实现保留节点。 这不是您要查找的节点。

    • 字段详细信息

      • tagName

        public final String tagName
        与此类节点相关联的标记名称（如果有）。

    • 方法详细信息

      • values

        public static DocTree.Kind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (DocTree.Kind c : DocTree.Kind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static DocTree.Kind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • Field |
  • 方法
  • 详细信息：
  • Enum Constants |
  • Field |
  • 方法

Report a bug or suggest an enhancement


DocTreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface DocTreeVisitor<R,P>

  • 参数类型
    R - 这个访问者的方法的返回类型。 对不需要返回结果的访问者使用Void 。
    P - 访问者的方法的附加参数的类型。 对不需要其他参数的访问者使用Void 。
    所有已知实现类：
    DocTreePathScanner ， DocTreeScanner ， SimpleDocTreeVisitor

    public interface DocTreeVisitor<R,P>
    树木的访客，以访客设计模式的风格。 当编译时树的种类未知时，实现此接口的类用于在树上操作。 当访问者传递给树的accept方法时，将调用最适用于该树的visitXyz方法。

    实现此界面的类可以或可以不抛出NullPointerException如果附加参数p是null ; 有关详细信息，请参阅实施类的文档。

    警告：可能的方法将添加到此界面，以适应未来版本的Java编程语言中添加的新的，当前未知的文档注释结构。 因此，直接实现此接口的访问者类可能与未来的平台版本不兼容。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      R visitAttribute​(AttributeTree node, P p)
      访问AttributeTree节点。
      R visitAuthor​(AuthorTree node, P p)
      访问AuthorTree节点。
      R visitComment​(CommentTree node, P p)
      访问CommentTree节点。
      R visitDeprecated​(DeprecatedTree node, P p)
      访问DeprecatedTree节点。
      R visitDocComment​(DocCommentTree node, P p)
      访问DocCommentTree节点。
      R visitDocRoot​(DocRootTree node, P p)
      访问DocRootTree节点。
      R visitEndElement​(EndElementTree node, P p)
      访问EndElementTree节点。
      R visitEntity​(EntityTree node, P p)
      访问EntityTree节点。
      R visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
      R visitHidden​(HiddenTree node, P p)
      访问HiddenTree节点。
      R visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R visitIndex​(IndexTree node, P p)
      访问IndexTree节点。
      R visitInheritDoc​(InheritDocTree node, P p)
      访问InheritDocTree节点。
      R visitLink​(LinkTree node, P p)
      访问LinkTree节点。
      R visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R visitOther​(DocTree node, P p)
      访问未知类型的DocTree节点。
      R visitParam​(ParamTree node, P p)
      访问ParamTree节点。
      R visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
      R visitReference​(ReferenceTree node, P p)
      访问一个ReferenceTree节点。
      R visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R visitSee​(SeeTree node, P p)
      访问SeeTree节点。
      R visitSerial​(SerialTree node, P p)
      访问SerialTree节点。
      R visitSerialData​(SerialDataTree node, P p)
      访问一个SerialDataTree节点。
      R visitSerialField​(SerialFieldTree node, P p)
      访问SerialFieldTree节点。
      R visitSince​(SinceTree node, P p)
      访问SinceTree节点。
      R visitStartElement​(StartElementTree node, P p)
      访问StartElementTree节点。
      R visitText​(TextTree node, P p)
      访问TextTree节点。
      R visitThrows​(ThrowsTree node, P p)
      访问ThrowsTree节点。
      R visitUnknownBlockTag​(UnknownBlockTagTree node, P p)
      访问UnknownBlockTagTree节点。
      R visitUnknownInlineTag​(UnknownInlineTagTree node, P p)
      访问UnknownInlineTagTree节点。
      R visitUses​(UsesTree node, P p)
      访问UsesTree节点。
      R visitValue​(ValueTree node, P p)
      访问ValueTree节点。
      R visitVersion​(VersionTree node, P p)
      访问VersionTreeTree节点。

    • 方法详细信息

      • visitAttribute

        R visitAttribute​(AttributeTree node,
                 P p)
        访问AttributeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitAuthor

        R visitAuthor​(AuthorTree node,
              P p)
        访问AuthorTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitComment

        R visitComment​(CommentTree node,
               P p)
        访问CommentTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitDeprecated

        R visitDeprecated​(DeprecatedTree node,
                  P p)
        访问DeprecatedTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitDocComment

        R visitDocComment​(DocCommentTree node,
                  P p)
        访问DocCommentTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitDocRoot

        R visitDocRoot​(DocRootTree node,
               P p)
        访问DocRootTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitEndElement

        R visitEndElement​(EndElementTree node,
                  P p)
        访问EndElementTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitEntity

        R visitEntity​(EntityTree node,
              P p)
        访问EntityTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitErroneous

        R visitErroneous​(ErroneousTree node,
                 P p)
        访问ErroneousTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitHidden

        R visitHidden​(HiddenTree node,
              P p)
        访问HiddenTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitIdentifier

        R visitIdentifier​(IdentifierTree node,
                  P p)
        访问IdentifierTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitIndex

        R visitIndex​(IndexTree node,
             P p)
        访问IndexTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitInheritDoc

        R visitInheritDoc​(InheritDocTree node,
                  P p)
        访问InheritDocTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitLink

        R visitLink​(LinkTree node,
            P p)
        访问LinkTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitLiteral

        R visitLiteral​(LiteralTree node,
               P p)
        访问LiteralTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitParam

        R visitParam​(ParamTree node,
             P p)
        访问ParamTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitProvides

        R visitProvides​(ProvidesTree node,
                P p)
        访问ProvideTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitReference

        R visitReference​(ReferenceTree node,
                 P p)
        访问一个ReferenceTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitReturn

        R visitReturn​(ReturnTree node,
              P p)
        访问ReturnTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitSee

        R visitSee​(SeeTree node,
           P p)
        访问SeeTree节点。
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果值

      • visitSerial

        R visitSerial​(SerialTree node,
              P p)
        访问SerialTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitSerialData

        R visitSerialData​(SerialDataTree node,
                  P p)
        访问一个SerialDataTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitSerialField

        R visitSerialField​(SerialFieldTree node,
                   P p)
        访问SerialFieldTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitSince

        R visitSince​(SinceTree node,
             P p)
        访问SinceTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitStartElement

        R visitStartElement​(StartElementTree node,
                    P p)
        访问StartElementTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitText

        R visitText​(TextTree node,
            P p)
        访问TextTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitThrows

        R visitThrows​(ThrowsTree node,
              P p)
        访问ThrowsTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitUnknownBlockTag

        R visitUnknownBlockTag​(UnknownBlockTagTree node,
                       P p)
        访问UnknownBlockTagTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitUnknownInlineTag

        R visitUnknownInlineTag​(UnknownInlineTagTree node,
                        P p)
        访问UnknownInlineTagTree节点。
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果值

      • visitUses

        R visitUses​(UsesTree node,
            P p)
        访问UsesTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitValue

        R visitValue​(ValueTree node,
             P p)
        访问ValueTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitVersion

        R visitVersion​(VersionTree node,
               P p)
        访问VersionTreeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitOther

        R visitOther​(DocTree node,
             P p)
        访问未知类型的DocTree节点。 如果标签集合发生变化并将新类型的节点添加到DocTree层次结构中，则可能会发生这种情况。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EndElementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface EndElementTree

  • All Superinterfaces:
    DocTree

    public interface EndElementTree
extends DocTree
    用于HTML元素结尾的树节点。

    </ name>

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getName​()
      返回此元素的名称。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getName

        Name getName​()
        返回此元素的名称。
        结果
        名字
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EntityTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface EntityTree

  • All Superinterfaces:
    DocTree

    public interface EntityTree
extends DocTree
    HTML实体的树节点。

    ＆ 名称 ;
    ＆＃digits;
    ＆#X十六进制数字;

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getName​()
      返回实体的名称或值。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getName

        Name getName​()
        返回实体的名称或值。
        结果
        实体的名称或价值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ErroneousTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface ErroneousTree

  • All Superinterfaces:
    DocTree ， TextTree

    public interface ErroneousTree
extends TextTree
    一个树状节点，用于生成格式不正确的文本
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Diagnostic<JavaFileObject> getDiagnostic​()
      返回诊断对象，提供有关正文文本错误的原因的详细信息。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.TextTree

        getBody

    • 方法详细信息

      • getDiagnostic

        Diagnostic<JavaFileObject> getDiagnostic​()
        返回诊断对象，提供有关正文文本错误的原因的详细信息。
        结果
        诊断
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HiddenTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface HiddenTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface HiddenTree
extends BlockTagTree
    @hidden块标记的树节点。

    @隐

    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getBody​()
      返回说明为什么隐藏项目的描述。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getBody

        List<? extends DocTree> getBody​()
        返回说明为什么隐藏项目的描述。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IdentifierTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface IdentifierTree

  • All Superinterfaces:
    DocTree

    public interface IdentifierTree
extends DocTree
    文档注释中的标识符。

    名称

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getName​()
      返回标识符的名称。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getName

        Name getName​()
        返回标识符的名称。
        结果
        名字
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IndexTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface IndexTree

  • All Superinterfaces:
    DocTree ， InlineTagTree

    public interface IndexTree
extends InlineTagTree
    @index或@index内联标记的树形节点。

    {@index关键字可选描述}

    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回描述，如果有的话。
      DocTree getSearchTerm​()
      返回指定的搜索项。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.InlineTagTree

        getTagName

    • 方法详细信息

      • getSearchTerm

        DocTree getSearchTerm​()
        返回指定的搜索项。
        结果
        搜索词

      • getDescription

        List<? extends DocTree> getDescription​()
        返回描述，如果有的话。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InheritDocTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface InheritDocTree

  • All Superinterfaces:
    DocTree ， InlineTagTree

    public interface InheritDocTree
extends InlineTagTree
    @inheritDoc内联标记的树形节点。

    {} @inheritDoc

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.InlineTagTree

        getTagName
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InlineTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface InlineTagTree

  • All Superinterfaces:
    DocTree
    All Known Subinterfaces:
    DocRootTree ， IndexTree ， InheritDocTree ， LinkTree ， LiteralTree ， UnknownInlineTagTree ， ValueTree

    public interface InlineTagTree
extends DocTree
    一个树节点用作不同类型的内联标签的基类。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getTagName​()
      返回标签的名称。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getTagName

        String getTagName​()
        返回标签的名称。
        结果
        the name of the tag
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LinkTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface LinkTree

  • All Superinterfaces:
    DocTree ， InlineTagTree

    public interface LinkTree
extends InlineTagTree
    @link或@linkplain内联标记的树形节点。

    {@link参考标签}
    {@linkplain reference label}

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getLabel​()
      返回链接的标签（如果有）。
      ReferenceTree getReference​()
      返回链接的引用。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.InlineTagTree

        getTagName

    • 方法详细信息

      • getReference

        ReferenceTree getReference​()
        返回链接的引用。
        结果
        参考

      • getLabel

        List<? extends DocTree> getLabel​()
        返回链接的标签（如果有）。
        结果
        标签
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LiteralTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface LiteralTree

  • All Superinterfaces:
    DocTree ， InlineTagTree

    public interface LiteralTree
extends InlineTagTree
    @literal或@code内联标记的树状结点。

    {@literal text}

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      TextTree getBody​()
      返回 @code或 @literal标签。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.InlineTagTree

        getTagName

    • 方法详细信息

      • getBody

        TextTree getBody​()
        返回 @code或 @literal标签的 @code 。
        结果
        标签的正文
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ParamTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface ParamTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface ParamTree
extends BlockTagTree
    @param块标记的树节点。

    @param参数名称描述

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回参数的描述。
      IdentifierTree getName​()
      返回参数的名称。
      boolean isTypeParameter​()
      如果这是记录类型参数，则返回true。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • isTypeParameter

        boolean isTypeParameter​()
        如果这是记录类型参数，则返回true。
        结果
        如果这是记录类型参数，则为true

      • getName

        IdentifierTree getName​()
        返回参数的名称。
        结果
        参数的名称

      • getDescription

        List<? extends DocTree> getDescription​()
        返回参数的描述。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProvidesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface ProvidesTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface ProvidesTree
extends BlockTagTree
    @provides块标记的树节点。

    @提供服务类型描述

    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回由模块提供的服务类型的描述。
      ReferenceTree getServiceType​()
      返回正在记录的服务类型的名称。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getServiceType

        ReferenceTree getServiceType​()
        返回正在记录的服务类型的名称。
        结果
        服务类型的名称

      • getDescription

        List<? extends DocTree> getDescription​()
        返回由模块提供的服务类型的描述。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReferenceTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface ReferenceTree

  • All Superinterfaces:
    DocTree

    public interface ReferenceTree
extends DocTree
    用于引用Java语言元素的树节点。

    package.class＃field package.class＃method（ arg-types ）

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getSignature​()
      返回被引用的Java语言元素的签名，如 @see和类似的节点所示。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getSignature

        String getSignature​()
        返回被引用的Java语言元素的签名，如 @see和类似的节点所示。
        结果
        签名。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReturnTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface ReturnTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface ReturnTree
extends BlockTagTree
    一个@return块标记的树节点。

    @返回描述

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回方法返回值的描述。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getDescription

        List<? extends DocTree> getDescription​()
        返回方法返回值的描述。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SeeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface SeeTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface SeeTree
extends BlockTagTree
    @see块标记的树节点。

    @see“string”
    @参阅<a href="URL#value">标签</a>
    @参考

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getReference​()
      返回引用。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getReference

        List<? extends DocTree> getReference​()
        返回引用。
        结果
        参考
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SerialDataTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface SerialDataTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface SerialDataTree
extends BlockTagTree
    @serialData块标记的树节点。

    @serialData数据描述

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回串行数据的描述。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getDescription

        List<? extends DocTree> getDescription​()
        返回串行数据的描述。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SerialFieldTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface SerialFieldTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface SerialFieldTree
extends BlockTagTree
    @serialData块标记的树节点。

    @serialField字段名称字段类型字段描述

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回串行字段的描述。
      IdentifierTree getName​()
      返回串行字段的名称。
      ReferenceTree getType​()
      返回串行字段的类型。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getName

        IdentifierTree getName​()
        返回串行字段的名称。
        结果
        串行字段的名称

      • getType

        ReferenceTree getType​()
        返回串行字段的类型。
        结果
        串行字段的类型

      • getDescription

        List<? extends DocTree> getDescription​()
        返回串行字段的描述。
        结果
        串行字段的描述
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SerialTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface SerialTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface SerialTree
extends BlockTagTree
    @serial块标记的树节点。

    @serial field-description | 包括| 排除

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回字段的描述，或返回“包含”或“排除”一词。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getDescription

        List<? extends DocTree> getDescription​()
        返回字段的描述，或返回“包含”或“排除”一词。
        结果
        该领域的描述
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SinceTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface SinceTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface SinceTree
extends BlockTagTree
    @since块标记的树节点。

    @since自文本

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getBody​()
      返回说明正在记录的项目的可用性的文本。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getBody

        List<? extends DocTree> getBody​()
        返回说明正在记录的项目的可用性的文本。
        结果
        文本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StartElementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface StartElementTree

  • All Superinterfaces:
    DocTree

    public interface StartElementTree
extends DocTree
    用于开始HTML元素的树节点。

    <name [attributes] [/]>

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getAttributes​()
      返回此元素定义的任何属性。
      Name getName​()
      返回元素的名称。
      boolean isSelfClosing​()
      如果这是一个自动关闭元素，则返回true，如关闭“>”之前的“/”所示。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getName

        Name getName​()
        返回元素的名称。
        结果
        名字

      • getAttributes

        List<? extends DocTree> getAttributes​()
        返回此元素定义的任何属性。
        结果
        属性

      • isSelfClosing

        boolean isSelfClosing​()
        如果这是一个自动关闭元素，则返回true，如关闭“>”之前的“/”所示。
        结果
        如果这是一个自我关闭元素，则为true
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface TextTree

  • All Superinterfaces:
    DocTree
    All Known Subinterfaces:
    ErroneousTree

    public interface TextTree
extends DocTree
    纯文本的树节点。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getBody​()
      返回文本。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getBody

        String getBody​()
        返回文本。
        结果
        the text
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThrowsTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface ThrowsTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface ThrowsTree
extends BlockTagTree
    @exception或@throws块标记的树节点。 @exception是@throws的同义词。

    @exception class-name描述
    @throws class-name description

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回说明可能抛出异常的原因。
      ReferenceTree getExceptionName​()
      返回正在记录的异常的名称。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getExceptionName

        ReferenceTree getExceptionName​()
        返回正在记录的异常的名称。
        结果
        异常的名称

      • getDescription

        List<? extends DocTree> getDescription​()
        返回说明可能抛出异常的原因。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnknownBlockTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface UnknownBlockTagTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface UnknownBlockTagTree
extends BlockTagTree
    用于无法识别的内联标签的树节点。

    @name内容

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getContent​()
      返回无法识别的块标签的内容。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getContent

        List<? extends DocTree> getContent​()
        返回无法识别的块标签的内容。
        结果
        内容
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnknownInlineTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface UnknownInlineTagTree

  • All Superinterfaces:
    DocTree ， InlineTagTree

    public interface UnknownInlineTagTree
extends InlineTagTree
    用于无法识别的内联标签的树节点。

    {@name content}

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getContent​()
      返回无法识别的内联代码的内容。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.InlineTagTree

        getTagName

    • 方法详细信息

      • getContent

        List<? extends DocTree> getContent​()
        返回无法识别的内联代码的内容。
        结果
        内容
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.source.doctree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.source.doctree

  • Packages that use com.sun.source.doctree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
  • Classes in com.sun.source.doctree used by com.sun.source.doctree
    Class 描述
    AttributeTree
    HTML元素中属性的树节点。
    AttributeTree.ValueKind
    属性值的种类。
    AuthorTree
    @author块标记的树形节点。
    BlockTagTree
    一个树节点用作不同类型的块标签的基类。
    CommentTree
    嵌入式HTML注释。
    DeprecatedTree
    @deprecated块标记的树节点。
    DocCommentTree
    文档评论的顶级代表。
    DocRootTree
    @docroot内联标记的树形节点。
    DocTree
    文档语法树中所有节点的公共接口。
    DocTree.Kind
    列举各种树木。
    DocTreeVisitor
    树木的访客，以访客设计模式的风格。
    EndElementTree
    用于HTML元素结尾的树节点。
    EntityTree
    HTML实体的树节点。
    ErroneousTree
    一个树状节点，用于生成格式不正确的文本
    HiddenTree
    @hidden块标记的树节点。
    IdentifierTree
    文档注释中的标识符。
    IndexTree
    @index或@index内联标记的树形节点。
    InheritDocTree
    @inheritDoc内联标记的树形节点。
    InlineTagTree
    一个树节点用作不同类型的内联标签的基类。
    LinkTree
    @link或@linkplain内联标记的树形节点。
    LiteralTree
    @literal或@code内联标记的树状结点。
    ParamTree
    @param块标记的树节点。
    ProvidesTree
    @provides块标记的树节点。
    ReferenceTree
    用于引用Java语言元素的树节点。
    ReturnTree
    一个@return块标记的树节点。
    SeeTree
    @see块标记的树节点。
    SerialDataTree
    @serialData块标记的树节点。
    SerialFieldTree
    @serialData块标记的树节点。
    SerialTree
    @serial块标记的树节点。
    SinceTree
    @since块标记的树节点。
    StartElementTree
    用于开始HTML元素的树节点。
    TextTree
    纯文本的树节点。
    ThrowsTree
    @exception或@throws块标记的树节点。
    UnknownBlockTagTree
    用于无法识别的内联标签的树节点。
    UnknownInlineTagTree
    用于无法识别的内联标签的树节点。
    UsesTree
    用于@uses块标记的树节点。
    ValueTree
    @value内联标记的树形节点。
    VersionTree
    用于@version块标记的树节点。
  • Classes in com.sun.source.doctree used by com.sun.source.util
    Class 描述
    AttributeTree
    HTML元素中属性的树节点。
    AttributeTree.ValueKind
    属性值的种类。
    AuthorTree
    @author块标记的树形节点。
    CommentTree
    嵌入式HTML注释。
    DeprecatedTree
    @deprecated块标记的树节点。
    DocCommentTree
    文档评论的顶级代表。
    DocRootTree
    @docroot内联标记的树形节点。
    DocTree
    文档语法树中所有节点的公共接口。
    DocTreeVisitor
    树木的访客，以访客设计模式的风格。
    EndElementTree
    用于HTML元素结尾的树节点。
    EntityTree
    HTML实体的树节点。
    ErroneousTree
    一个树状节点，用于生成格式不正确的文本
    HiddenTree
    @hidden块标记的树节点。
    IdentifierTree
    文档注释中的标识符。
    IndexTree
    @index或@index内联标记的树形节点。
    InheritDocTree
    @inheritDoc内联标记的树形节点。
    LinkTree
    @link或@linkplain内联标记的树形节点。
    LiteralTree
    @literal或@code内联标记的树状结点。
    ParamTree
    @param块标记的树节点。
    ProvidesTree
    @provides块标记的树节点。
    ReferenceTree
    用于引用Java语言元素的树节点。
    ReturnTree
    一个@return块标记的树节点。
    SeeTree
    @see块标记的树节点。
    SerialDataTree
    @serialData块标记的树节点。
    SerialFieldTree
    @serialData块标记的树节点。
    SerialTree
    @serial块标记的树节点。
    SinceTree
    @since块标记的树节点。
    StartElementTree
    用于开始HTML元素的树节点。
    TextTree
    纯文本的树节点。
    ThrowsTree
    @exception或@throws块标记的树节点。
    UnknownBlockTagTree
    用于无法识别的内联标签的树节点。
    UnknownInlineTagTree
    用于无法识别的内联标签的树节点。
    UsesTree
    用于@uses块标记的树节点。
    ValueTree
    @value内联标记的树形节点。
    VersionTree
    用于@version块标记的树节点。
  • Classes in com.sun.source.doctree used by jdk.javadoc.doclet
    Class 描述
    DocTree
    文档语法树中所有节点的公共接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


UsesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface UsesTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface UsesTree
extends BlockTagTree
    用于@uses块标记的树节点。

    @uses服务类型描述

    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getDescription​()
      返回在模块中使用服务类型的描述。
      ReferenceTree getServiceType​()
      返回正在记录的服务类型的名称。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getServiceType

        ReferenceTree getServiceType​()
        返回正在记录的服务类型的名称。
        结果
        服务类型的名称

      • getDescription

        List<? extends DocTree> getDescription​()
        返回在模块中使用服务类型的描述。
        结果
        说明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ValueTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface ValueTree

  • All Superinterfaces:
    DocTree ， InlineTagTree

    public interface ValueTree
extends InlineTagTree
    @value内联标记的树形节点。

    {@value reference}

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ReferenceTree getReference​()
      返回对该值的引用。

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

      • Methods inherited from interface com.sun.source.doctree.InlineTagTree

        getTagName

    • 方法详细信息

      • getReference

        ReferenceTree getReference​()
        返回对该值的引用。
        结果
        参考
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VersionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.doctree

Interface VersionTree

  • All Superinterfaces:
    BlockTagTree ， DocTree

    public interface VersionTree
extends BlockTagTree
    用于@version块标记的树节点。

    @version版本文本

    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.doctree.DocTree

        DocTree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends DocTree> getBody​()
      返回标签的正文。

      • Methods inherited from interface com.sun.source.doctree.BlockTagTree

        getTagName

      • Methods inherited from interface com.sun.source.doctree.DocTree

        accept, getKind

    • 方法详细信息

      • getBody

        List<? extends DocTree> getBody​()
        返回标签的正文。
        结果
        身体
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.source.doctree.AttributeTree.ValueKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.doctree.AttributeTree.ValueKind

  • Packages that use AttributeTree.ValueKind
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of AttributeTree.ValueKind in com.sun.source.doctree

      Methods in com.sun.source.doctree that return AttributeTree.ValueKind
      Modifier and Type 方法 描述
      AttributeTree.ValueKind AttributeTree.getValueKind​()
      返回属性的种类。
      static AttributeTree.ValueKind AttributeTree.ValueKind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static AttributeTree.ValueKind[] AttributeTree.ValueKind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of AttributeTree.ValueKind in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AttributeTree.ValueKind
      Modifier and Type 方法 描述
      AttributeTree DocTreeFactory.newAttributeTree​(Name name, AttributeTree.ValueKind vkind, List<? extends DocTree> value)
      创建一个新的 AttributeTree对象，以表示HTML标签中的HTML属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.doctree.DocTree.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.doctree.DocTree.Kind

  • Packages that use DocTree.Kind
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。

    • Uses of DocTree.Kind in com.sun.source.doctree

      Methods in com.sun.source.doctree that return DocTree.Kind
      Modifier and Type 方法 描述
      DocTree.Kind DocTree.getKind​()
      返回此树的种类。
      static DocTree.Kind DocTree.Kind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static DocTree.Kind[] DocTree.Kind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.AttributeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.AttributeTree

  • Packages that use AttributeTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of AttributeTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type AttributeTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitAttribute​(AttributeTree node, P p)
      访问AttributeTree节点。

    • Uses of AttributeTree in com.sun.source.util

      Methods in com.sun.source.util that return AttributeTree
      Modifier and Type 方法 描述
      AttributeTree DocTreeFactory.newAttributeTree​(Name name, AttributeTree.ValueKind vkind, List<? extends DocTree> value)
      创建一个新的 AttributeTree对象，以在HTML标签中表示HTML属性。
      Methods in com.sun.source.util with parameters of type AttributeTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitAttribute​(AttributeTree node, P p)
      访问AttributeTree节点。
      R SimpleDocTreeVisitor.visitAttribute​(AttributeTree node, P p)
      访问AttributeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.AuthorTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.AuthorTree

  • Packages that use AuthorTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of AuthorTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type AuthorTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitAuthor​(AuthorTree node, P p)
      访问AuthorTree节点。

    • Uses of AuthorTree in com.sun.source.util

      Methods in com.sun.source.util that return AuthorTree
      Modifier and Type 方法 描述
      AuthorTree DocTreeFactory.newAuthorTree​(List<? extends DocTree> name)
      创建一个新的 AuthorTree对象，以表示一个 {@author }标签。
      Methods in com.sun.source.util with parameters of type AuthorTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitAuthor​(AuthorTree node, P p)
      访问AuthorTree节点。
      R SimpleDocTreeVisitor.visitAuthor​(AuthorTree node, P p)
      访问AuthorTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.BlockTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.BlockTagTree

  • Packages that use BlockTagTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。

    • Uses of BlockTagTree in com.sun.source.doctree

      Subinterfaces of BlockTagTree in com.sun.source.doctree
      Modifier and Type 接口 描述
      interface  AuthorTree
      @author块标记的树形节点。
      interface  DeprecatedTree
      @deprecated块标记的树节点。
      interface  HiddenTree
      @hidden块标记的树节点。
      interface  ParamTree
      @param块标记的树节点。
      interface  ProvidesTree
      @provides块标记的树节点。
      interface  ReturnTree
      一个@return块标记的树节点。
      interface  SeeTree
      @see块标记的树节点。
      interface  SerialDataTree
      @serialData块标记的树节点。
      interface  SerialFieldTree
      @serialData块标记的树节点。
      interface  SerialTree
      @serial块标记的树节点。
      interface  SinceTree
      @since块标记的树节点。
      interface  ThrowsTree
      @exception或@throws块标记的树节点。
      interface  UnknownBlockTagTree
      用于无法识别的内联标签的树节点。
      interface  UsesTree
      用于@uses块标记的树节点。
      interface  VersionTree
      用于@version块标记的树节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.CommentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.CommentTree

  • Packages that use CommentTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of CommentTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type CommentTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitComment​(CommentTree node, P p)
      访问CommentTree节点。

    • Uses of CommentTree in com.sun.source.util

      Methods in com.sun.source.util that return CommentTree
      Modifier and Type 方法 描述
      CommentTree DocTreeFactory.newCommentTree​(String text)
      创建一个新的 CommentTree ，以表示HTML注释。
      Methods in com.sun.source.util with parameters of type CommentTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitComment​(CommentTree node, P p)
      访问CommentTree节点。
      R SimpleDocTreeVisitor.visitComment​(CommentTree node, P p)
      访问CommentTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.DeprecatedTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.DeprecatedTree

  • Packages that use DeprecatedTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DeprecatedTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DeprecatedTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitDeprecated​(DeprecatedTree node, P p)
      访问DeprecatedTree节点。

    • Uses of DeprecatedTree in com.sun.source.util

      Methods in com.sun.source.util that return DeprecatedTree
      Modifier and Type 方法 描述
      DeprecatedTree DocTreeFactory.newDeprecatedTree​(List<? extends DocTree> text)
      创建一个新的 DeprecatedTree对象，以表示一个 {@deprecated }标签。
      Methods in com.sun.source.util with parameters of type DeprecatedTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitDeprecated​(DeprecatedTree node, P p)
      访问DeprecatedTree节点。
      R SimpleDocTreeVisitor.visitDeprecated​(DeprecatedTree node, P p)
      访问DeprecatedTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.DocCommentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.DocCommentTree

  • Packages that use DocCommentTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DocCommentTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DocCommentTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitDocComment​(DocCommentTree node, P p)
      访问DocCommentTree节点。

    • Uses of DocCommentTree in com.sun.source.util

      Methods in com.sun.source.util that return DocCommentTree
      Modifier and Type 方法 描述
      DocCommentTree DocTreePath.getDocComment​()
      返回与此路径相关联的DocCommentTree。
      abstract DocCommentTree DocTrees.getDocCommentTree​(TreePath path)
      返回由给定TreePath标识的Tree节点的doc注释树（如果有）。
      abstract DocCommentTree DocTrees.getDocCommentTree​(Element e)
      返回给定元素的文档注释树。
      abstract DocCommentTree DocTrees.getDocCommentTree​(Element e, String relativePath)
      返回相对于给定元素指定路径的给定文件的doc注释树。
      abstract DocCommentTree DocTrees.getDocCommentTree​(FileObject fileObject)
      返回给定文件的文档注释树。
      DocCommentTree DocTreeFactory.newDocCommentTree​(List<? extends DocTree> fullBody, List<? extends DocTree> tags)
      创建一个新的 DocCommentTree对象，以表示完整的文档注释。
      Methods in com.sun.source.util with parameters of type DocCommentTree
      Modifier and Type 方法 描述
      long DocSourcePositions.getEndPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件中注释中树的结束位置。
      static DocTreePath DocTreePath.getPath​(TreePath treePath, DocCommentTree doc, DocTree target)
      返回编译单元中树节点的文档树路径，如果未找到该节点，则 null 。
      long DocSourcePositions.getStartPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件内注释中树的起始位置。
      abstract void DocTrees.printMessage​(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息
      R DocTreeScanner.visitDocComment​(DocCommentTree node, P p)
      访问DocCommentTree节点。
      R SimpleDocTreeVisitor.visitDocComment​(DocCommentTree node, P p)
      访问DocCommentTree节点。
      Constructors in com.sun.source.util with parameters of type DocCommentTree
      Constructor 描述
      DocTreePath​(TreePath treePath, DocCommentTree t)
      为根节点创建DocTreePath。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.DocRootTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.DocRootTree

  • Packages that use DocRootTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DocRootTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DocRootTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitDocRoot​(DocRootTree node, P p)
      访问DocRootTree节点。

    • Uses of DocRootTree in com.sun.source.util

      Methods in com.sun.source.util that return DocRootTree
      Modifier and Type 方法 描述
      DocRootTree DocTreeFactory.newDocRootTree​()
      创建一个新的 DocRootTree对象，以表示一个 {@docroot}标签。
      Methods in com.sun.source.util with parameters of type DocRootTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitDocRoot​(DocRootTree node, P p)
      访问DocRootTree节点。
      R SimpleDocTreeVisitor.visitDocRoot​(DocRootTree node, P p)
      访问DocRootTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.DocTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.DocTree

  • Packages that use DocTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

    • Uses of DocTree in com.sun.source.doctree

      Subinterfaces of DocTree in com.sun.source.doctree
      Modifier and Type 接口 描述
      interface  AttributeTree
      HTML元素中属性的树节点。
      interface  AuthorTree
      @author块标记的树形节点。
      interface  BlockTagTree
      一个树节点用作不同类型的块标签的基类。
      interface  CommentTree
      嵌入式HTML注释。
      interface  DeprecatedTree
      @deprecated块标记的树节点。
      interface  DocCommentTree
      文档评论的顶级代表。
      interface  DocRootTree
      @docroot内联标记的树形节点。
      interface  EndElementTree
      用于HTML元素结尾的树节点。
      interface  EntityTree
      HTML实体的树节点。
      interface  ErroneousTree
      一个树状节点，用于生成格式不正确的文本
      interface  HiddenTree
      @hidden块标记的树节点。
      interface  IdentifierTree
      文档注释中的标识符。
      interface  IndexTree
      @index或@index内联标记的树形节点。
      interface  InheritDocTree
      @inheritDoc内联标记的树形节点。
      interface  InlineTagTree
      一个树节点用作不同类型的内联标签的基类。
      interface  LinkTree
      @link或@linkplain内联标记的树形节点。
      interface  LiteralTree
      @literal或@code内联标记的树状结点。
      interface  ParamTree
      @param块标记的树节点。
      interface  ProvidesTree
      @provides块标记的树节点。
      interface  ReferenceTree
      用于引用Java语言元素的树节点。
      interface  ReturnTree
      一个@return块标记的树节点。
      interface  SeeTree
      @see块标记的树节点。
      interface  SerialDataTree
      @serialData块标记的树节点。
      interface  SerialFieldTree
      @serialData块标记的树节点。
      interface  SerialTree
      @serial块标记的树节点。
      interface  SinceTree
      @since块标记的树节点。
      interface  StartElementTree
      用于开始HTML元素的树节点。
      interface  TextTree
      纯文本的树节点。
      interface  ThrowsTree
      @exception或@throws块标记的树节点。
      interface  UnknownBlockTagTree
      用于无法识别的内联标签的树节点。
      interface  UnknownInlineTagTree
      用于无法识别的内联标签的树节点。
      interface  UsesTree
      用于@uses块标记的树节点。
      interface  ValueTree
      @value内联标记的树形节点。
      interface  VersionTree
      用于@version块标记的树节点。
      Methods in com.sun.source.doctree that return DocTree
      Modifier and Type 方法 描述
      DocTree IndexTree.getSearchTerm​()
      返回指定的搜索项。
      Methods in com.sun.source.doctree that return types with arguments of type DocTree
      Modifier and Type 方法 描述
      List<? extends DocTree> StartElementTree.getAttributes​()
      返回此元素定义的任何属性。
      List<? extends DocTree> DocCommentTree.getBlockTags​()
      返回文档注释的块标签。
      List<? extends DocTree> DeprecatedTree.getBody​()
      返回解释为什么不推荐使用某项的描述。
      List<? extends DocTree> DocCommentTree.getBody​()
      返回文档注释的正文，出现在第一个句子之后，并返回任何块标记之前。
      List<? extends DocTree> HiddenTree.getBody​()
      返回说明为什么隐藏项目的描述。
      List<? extends DocTree> SinceTree.getBody​()
      返回说明正在记录的项目的可用性的文本。
      List<? extends DocTree> VersionTree.getBody​()
      返回标签的正文。
      List<? extends DocTree> UnknownBlockTagTree.getContent​()
      返回无法识别的块标签的内容。
      List<? extends DocTree> UnknownInlineTagTree.getContent​()
      返回无法识别的内联代码的内容。
      List<? extends DocTree> IndexTree.getDescription​()
      返回描述，如果有的话。
      List<? extends DocTree> ParamTree.getDescription​()
      返回参数的描述。
      List<? extends DocTree> ProvidesTree.getDescription​()
      返回由模块提供的服务类型的描述。
      List<? extends DocTree> ReturnTree.getDescription​()
      返回方法返回值的描述。
      List<? extends DocTree> SerialDataTree.getDescription​()
      返回串行数据的描述。
      List<? extends DocTree> SerialFieldTree.getDescription​()
      返回串行字段的描述。
      List<? extends DocTree> SerialTree.getDescription​()
      返回字段的描述，或返回“包含”或“排除”一词。
      List<? extends DocTree> ThrowsTree.getDescription​()
      返回说明可能抛出异常的原因。
      List<? extends DocTree> UsesTree.getDescription​()
      返回在模块中使用服务类型的描述。
      List<? extends DocTree> DocCommentTree.getFirstSentence​()
      返回文档注释的第一个句子。
      default List<? extends DocTree> DocCommentTree.getFullBody​()
      返回文档注释的整个正文，出现在任何块标记之前，包括第一个句子。
      List<? extends DocTree> LinkTree.getLabel​()
      返回链接的标签（如果有）。
      List<? extends DocTree> AuthorTree.getName​()
      返回作者的名称。
      List<? extends DocTree> SeeTree.getReference​()
      返回引用。
      List<? extends DocTree> AttributeTree.getValue​()
      返回属性的值，如果该类型为EMPTY，则返回 null 。
      Methods in com.sun.source.doctree with parameters of type DocTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitOther​(DocTree node, P p)
      访问未知类型的DocTree节点。

    • Uses of DocTree in com.sun.source.util

      Methods in com.sun.source.util that return DocTree
      Modifier and Type 方法 描述
      DocTree DocTreePath.getLeaf​()
      返回此路径的叶节点。
      Methods in com.sun.source.util that return types with arguments of type DocTree
      Modifier and Type | 方法 | 描述
      List<DocTree> DocTreeFactory.getFirstSentence​(List<? extends DocTree> list)
      获取内容列表中的第一个句子。
      abstract List<DocTree> DocTrees.getFirstSentence​(List<? extends DocTree> list)
      返回表示评论第一句的DocTree的列表。
      Iterator<DocTree> | DocTreePath.iterator​()
      Methods in com.sun.source.util with parameters of type DocTree
      Modifier and Type 方法 描述
      protected R SimpleDocTreeVisitor.defaultAction​(DocTree node, P p)
      所有访问方法使用的默认操作不被覆盖。
      long DocSourcePositions.getEndPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件中注释中树的结束位置。
      static DocTreePath DocTreePath.getPath​(DocTreePath path, DocTree target)
      返回由DocTreePath对象标识的子树内的树节点的文档树路径，如果未找到该节点，则 null 。
      static DocTreePath DocTreePath.getPath​(TreePath treePath, DocCommentTree doc, DocTree target)
      返回编译单元中树节点的文档树路径，如果未找到该节点，则 null 。
      long DocSourcePositions.getStartPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件内注释中树的起始位置。
      IndexTree DocTreeFactory.newIndexTree​(DocTree term, List<? extends DocTree> description)
      创建一个新的 IndexTree对象，以表示一个 {@index }标签。
      abstract void DocTrees.printMessage​(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息
      R DocTreePathScanner.scan​(DocTree tree, P p)
      扫描单个节点。
      R DocTreeScanner.scan​(DocTree node, P p)
      扫描单个节点。
      R SimpleDocTreeVisitor.visit​(DocTree node, P p)
      调用特定于节点类型的适当访问方式。
      R DocTreeScanner.visitOther​(DocTree node, P p)
      访问未知类型的DocTree节点。
      R SimpleDocTreeVisitor.visitOther​(DocTree node, P p)
      访问未知类型的DocTree节点。
      Method parameters in com.sun.source.util with type arguments of type DocTree
      Modifier and Type 方法 描述
      List<DocTree> DocTreeFactory.getFirstSentence​(List<? extends DocTree> list)
      获取内容列表中的第一个句子。
      abstract List<DocTree> DocTrees.getFirstSentence​(List<? extends DocTree> list)
      返回表示评论第一句的DocTree的列表。
      AttributeTree DocTreeFactory.newAttributeTree​(Name name, AttributeTree.ValueKind vkind, List<? extends DocTree> value)
      创建一个新的 AttributeTree对象，以表示HTML标签中的HTML属性。
      AuthorTree DocTreeFactory.newAuthorTree​(List<? extends DocTree> name)
      创建一个新的 AuthorTree对象，以表示一个 {@author }标签。
      DeprecatedTree DocTreeFactory.newDeprecatedTree​(List<? extends DocTree> text)
      创建一个新的 DeprecatedTree对象，以表示一个 {@deprecated }标签。
      DocCommentTree DocTreeFactory.newDocCommentTree​(List<? extends DocTree> fullBody, List<? extends DocTree> tags)
      创建一个新的 DocCommentTree对象，以表示完整的文档注释。
      ThrowsTree DocTreeFactory.newExceptionTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ExceptionTree对象，以表示一个 @exception标签。
      HiddenTree DocTreeFactory.newHiddenTree​(List<? extends DocTree> text)
      创建一个新的 HiddenTree对象，以表示一个 {@hidden }标签。
      IndexTree DocTreeFactory.newIndexTree​(DocTree term, List<? extends DocTree> description)
      创建一个新的 IndexTree对象，以表示一个 {@index }标签。
      LinkTree DocTreeFactory.newLinkPlainTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkPlainTree对象，以表示一个 {@linkplain }标签。
      LinkTree DocTreeFactory.newLinkTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkTree对象，以表示一个 {@link }标签。
      ParamTree DocTreeFactory.newParamTree​(boolean isTypeParameter, IdentifierTree name, List<? extends DocTree> description)
      创建一个新的 ParamTree对象，以表示一个 @param标签。
      ProvidesTree DocTreeFactory.newProvidesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ProvidesTree对象，以表示一个 @provides标签。
      ReturnTree DocTreeFactory.newReturnTree​(List<? extends DocTree> description)
      创建一个新的 ReturnTree对象，以表示一个 @return标签。
      SeeTree DocTreeFactory.newSeeTree​(List<? extends DocTree> reference)
      创建一个新的 SeeTree对象，以表示一个 @see标签。
      SerialDataTree DocTreeFactory.newSerialDataTree​(List<? extends DocTree> description)
      创建一个新的 SerialDataTree对象，代表一个 @serialData标签。
      SerialFieldTree DocTreeFactory.newSerialFieldTree​(IdentifierTree name, ReferenceTree type, List<? extends DocTree> description)
      创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
      SerialTree DocTreeFactory.newSerialTree​(List<? extends DocTree> description)
      创建一个新的 SerialTree对象，以表示一个 @serial标签。
      SinceTree DocTreeFactory.newSinceTree​(List<? extends DocTree> text)
      创建一个新的 SinceTree对象，以表示一个 @since标签。
      StartElementTree DocTreeFactory.newStartElementTree​(Name name, List<? extends DocTree> attrs, boolean selfClosing)
      创建一个新的 StartElementTree对象，以表示HTML元素的开始。
      ThrowsTree DocTreeFactory.newThrowsTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ThrowsTree对象，以表示一个 @throws标签。
      UnknownBlockTagTree DocTreeFactory.newUnknownBlockTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownBlockTagTree对象，以表示一个无法识别的块标签。
      UnknownInlineTagTree DocTreeFactory.newUnknownInlineTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownInlineTagTree对象，以表示无法识别的内联标签。
      UsesTree DocTreeFactory.newUsesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 UsesTree对象，代表一个 @uses标签。
      VersionTree DocTreeFactory.newVersionTree​(List<? extends DocTree> text)
      创建一个新的 VersionTree对象，以表示一个 {@version }标签。
      R DocTreeScanner.scan​(Iterable<? extends DocTree> nodes, P p)
      扫描一系列节点。
      R SimpleDocTreeVisitor.visit​(Iterable<? extends DocTree> nodes, P p)
      在每个节点序列上调用适当的访问方法。
      Constructors in com.sun.source.util with parameters of type DocTree
      Constructor 描述
      DocTreePath​(DocTreePath p, DocTree t)
      为子节点创建DocTreePath。

    • Uses of DocTree in jdk.javadoc.doclet

      Method parameters in jdk.javadoc.doclet with type arguments of type DocTree
      Modifier and Type 方法 描述
      String Taglet.toString​(List<? extends DocTree> tags, Element element)
      返回要包含在生成的输出中的该标签的一系列实例的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.DocTreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.DocTreeVisitor

  • Packages that use DocTreeVisitor
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DocTreeVisitor in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DocTreeVisitor
      Modifier and Type 方法 描述
      <R,D> R DocTree.accept​(DocTreeVisitor<R,D> visitor, D data)
      用于实现访问者模式的接受方法。

    • Uses of DocTreeVisitor in com.sun.source.util

      Classes in com.sun.source.util that implement DocTreeVisitor
      Modifier and Type Class 描述
      class  DocTreePathScanner<R,P>
      访问所有子树节点的DocTreeVisitor，并为维护父节点的路径提供支持。
      class  DocTreeScanner<R,P>
      访问所有子树节点的TreeVisitor。
      class  SimpleDocTreeVisitor<R,P>
      树节点的简单访问者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.EndElementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.EndElementTree

  • Packages that use EndElementTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of EndElementTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type EndElementTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitEndElement​(EndElementTree node, P p)
      访问EndElementTree节点。

    • Uses of EndElementTree in com.sun.source.util

      Methods in com.sun.source.util that return EndElementTree
      Modifier and Type 方法 描述
      EndElementTree DocTreeFactory.newEndElementTree​(Name name)
      创建一个新的 EndElement对象，以表示HTML元素的结尾。
      Methods in com.sun.source.util with parameters of type EndElementTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitEndElement​(EndElementTree node, P p)
      访问EndElementTree节点。
      R SimpleDocTreeVisitor.visitEndElement​(EndElementTree node, P p)
      访问EndElementTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.EntityTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.EntityTree

  • Packages that use EntityTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of EntityTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type EntityTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitEntity​(EntityTree node, P p)
      访问EntityTree节点。

    • Uses of EntityTree in com.sun.source.util

      Methods in com.sun.source.util that return EntityTree
      Modifier and Type 方法 描述
      EntityTree DocTreeFactory.newEntityTree​(Name name)
      创建一个新的 EntityTree对象，以表示一个HTML实体。
      Methods in com.sun.source.util with parameters of type EntityTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitEntity​(EntityTree node, P p)
      访问EntityTree节点。
      R SimpleDocTreeVisitor.visitEntity​(EntityTree node, P p)
      访问EntityTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.ErroneousTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.ErroneousTree

  • Packages that use ErroneousTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ErroneousTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type ErroneousTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。

    • Uses of ErroneousTree in com.sun.source.util

      Methods in com.sun.source.util that return ErroneousTree
      Modifier and Type 方法 描述
      ErroneousTree DocTreeFactory.newErroneousTree​(String text, Diagnostic<JavaFileObject> diag)
      创建一个新的 ErroneousTree对象，以表示一些不可 ErroneousTree输入。
      Methods in com.sun.source.util with parameters of type ErroneousTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
      R SimpleDocTreeVisitor.visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.HiddenTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.HiddenTree

  • Packages that use HiddenTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of HiddenTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type HiddenTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitHidden​(HiddenTree node, P p)
      访问HiddenTree节点。

    • Uses of HiddenTree in com.sun.source.util

      Methods in com.sun.source.util that return HiddenTree
      Modifier and Type 方法 描述
      HiddenTree DocTreeFactory.newHiddenTree​(List<? extends DocTree> text)
      创建一个新的 HiddenTree对象，以表示一个 {@hidden }标签。
      Methods in com.sun.source.util with parameters of type HiddenTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitHidden​(HiddenTree node, P p)
      访问HiddenTree节点。
      R SimpleDocTreeVisitor.visitHidden​(HiddenTree node, P p)
      访问HiddenTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.IdentifierTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.IdentifierTree

  • Packages that use IdentifierTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of IdentifierTree in com.sun.source.doctree

      Methods in com.sun.source.doctree that return IdentifierTree
      Modifier and Type 方法 描述
      IdentifierTree ParamTree.getName​()
      返回参数的名称。
      IdentifierTree SerialFieldTree.getName​()
      返回串行字段的名称。
      Methods in com.sun.source.doctree with parameters of type IdentifierTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。

    • Uses of IdentifierTree in com.sun.source.util

      Methods in com.sun.source.util that return IdentifierTree
      Modifier and Type 方法 描述
      IdentifierTree DocTreeFactory.newIdentifierTree​(Name name)
      创建一个新的 IdentifierTree对象，以表示一个标识符，如 @param标签。
      Methods in com.sun.source.util with parameters of type IdentifierTree
      Modifier and Type 方法 描述
      ParamTree DocTreeFactory.newParamTree​(boolean isTypeParameter, IdentifierTree name, List<? extends DocTree> description)
      创建一个新的 ParamTree对象，以表示一个 @param标签。
      SerialFieldTree DocTreeFactory.newSerialFieldTree​(IdentifierTree name, ReferenceTree type, List<? extends DocTree> description)
      创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
      R DocTreeScanner.visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R SimpleDocTreeVisitor.visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.IndexTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.IndexTree

  • Packages that use IndexTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of IndexTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type IndexTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitIndex​(IndexTree node, P p)
      访问IndexTree节点。

    • Uses of IndexTree in com.sun.source.util

      Methods in com.sun.source.util that return IndexTree
      Modifier and Type 方法 描述
      IndexTree DocTreeFactory.newIndexTree​(DocTree term, List<? extends DocTree> description)
      创建一个新的 IndexTree对象，以表示一个 {@index }标签。
      Methods in com.sun.source.util with parameters of type IndexTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitIndex​(IndexTree node, P p)
      访问IndexTree节点。
      R SimpleDocTreeVisitor.visitIndex​(IndexTree node, P p)
      访问IndexTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.InheritDocTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.InheritDocTree

  • Packages that use InheritDocTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of InheritDocTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type InheritDocTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitInheritDoc​(InheritDocTree node, P p)
      访问InheritDocTree节点。

    • Uses of InheritDocTree in com.sun.source.util

      Methods in com.sun.source.util that return InheritDocTree
      Modifier and Type 方法 描述
      InheritDocTree DocTreeFactory.newInheritDocTree​()
      创建一个新的 InheritDocTree对象，以表示一个 {@inheritDoc}标签。
      Methods in com.sun.source.util with parameters of type InheritDocTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitInheritDoc​(InheritDocTree node, P p)
      访问InheritDocTree节点。
      R SimpleDocTreeVisitor.visitInheritDoc​(InheritDocTree node, P p)
      访问InheritDocTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.InlineTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.InlineTagTree

  • Packages that use InlineTagTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。

    • Uses of InlineTagTree in com.sun.source.doctree

      Subinterfaces of InlineTagTree in com.sun.source.doctree
      Modifier and Type 接口 描述
      interface  DocRootTree
      @docroot内联标记的树形节点。
      interface  IndexTree
      @index或@index内联标记的树形节点。
      interface  InheritDocTree
      @inheritDoc内联标记的树形节点。
      interface  LinkTree
      @link或@linkplain内联标记的树形节点。
      interface  LiteralTree
      @literal或@code内联标记的树状结点。
      interface  UnknownInlineTagTree
      用于无法识别的内联标签的树节点。
      interface  ValueTree
      @value内联标记的树形节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.LinkTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.LinkTree

  • Packages that use LinkTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of LinkTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type LinkTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitLink​(LinkTree node, P p)
      访问LinkTree节点。

    • Uses of LinkTree in com.sun.source.util

      Methods in com.sun.source.util that return LinkTree
      Modifier and Type 方法 描述
      LinkTree DocTreeFactory.newLinkPlainTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkPlainTree对象，以表示一个 {@linkplain }标签。
      LinkTree DocTreeFactory.newLinkTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkTree对象，以表示一个 {@link }标签。
      Methods in com.sun.source.util with parameters of type LinkTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitLink​(LinkTree node, P p)
      访问LinkTree节点。
      R SimpleDocTreeVisitor.visitLink​(LinkTree node, P p)
      Visits a LinkTree node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.LiteralTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.LiteralTree

  • Packages that use LiteralTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of LiteralTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type LiteralTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。

    • Uses of LiteralTree in com.sun.source.util

      Methods in com.sun.source.util that return LiteralTree
      Modifier and Type 方法 描述
      LiteralTree DocTreeFactory.newCodeTree​(TextTree text)
      创建一个新的 CodeTree对象，以表示一个 {@code }标签。
      LiteralTree DocTreeFactory.newLiteralTree​(TextTree text)
      创建一个新的 LiteralTree对象，以表示一个 {@literal }标签。
      Methods in com.sun.source.util with parameters of type LiteralTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R SimpleDocTreeVisitor.visitLiteral​(LiteralTree node, P p)
      Visits an LiteralTree node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.ParamTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.ParamTree

  • Packages that use ParamTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ParamTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type ParamTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitParam​(ParamTree node, P p)
      访问ParamTree节点。

    • Uses of ParamTree in com.sun.source.util

      Methods in com.sun.source.util that return ParamTree
      Modifier and Type 方法 描述
      ParamTree DocTreeFactory.newParamTree​(boolean isTypeParameter, IdentifierTree name, List<? extends DocTree> description)
      创建一个新的 ParamTree对象，以表示一个 @param标签。
      Methods in com.sun.source.util with parameters of type ParamTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitParam​(ParamTree node, P p)
      访问ParamTree节点。
      R SimpleDocTreeVisitor.visitParam​(ParamTree node, P p)
      访问ParamTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.ProvidesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.ProvidesTree

  • Packages that use ProvidesTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ProvidesTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type ProvidesTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。

    • Uses of ProvidesTree in com.sun.source.util

      Methods in com.sun.source.util that return ProvidesTree
      Modifier and Type 方法 描述
      ProvidesTree DocTreeFactory.newProvidesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ProvidesTree对象，以表示一个 @provides标签。
      Methods in com.sun.source.util with parameters of type ProvidesTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
      R SimpleDocTreeVisitor.visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.ReferenceTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.ReferenceTree

  • Packages that use ReferenceTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ReferenceTree in com.sun.source.doctree

      Methods in com.sun.source.doctree that return ReferenceTree
      Modifier and Type 方法 描述
      ReferenceTree ThrowsTree.getExceptionName​()
      返回正在记录的异常的名称。
      ReferenceTree LinkTree.getReference​()
      返回链接的引用。
      ReferenceTree ValueTree.getReference​()
      返回对该值的引用。
      ReferenceTree ProvidesTree.getServiceType​()
      返回正在记录的服务类型的名称。
      ReferenceTree UsesTree.getServiceType​()
      返回正在记录的服务类型的名称。
      ReferenceTree SerialFieldTree.getType​()
      返回串行字段的类型。
      Methods in com.sun.source.doctree with parameters of type ReferenceTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitReference​(ReferenceTree node, P p)
      访问一个ReferenceTree节点。

    • Uses of ReferenceTree in com.sun.source.util

      Methods in com.sun.source.util that return ReferenceTree
      Modifier and Type 方法 描述
      ReferenceTree DocTreeFactory.newReferenceTree​(String signature)
      创建一个新的 ReferenceTree对象，以表示对API元素的引用。
      Methods in com.sun.source.util with parameters of type ReferenceTree
      Modifier and Type 方法 描述
      ThrowsTree DocTreeFactory.newExceptionTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ExceptionTree对象，以表示一个 @exception标签。
      LinkTree DocTreeFactory.newLinkPlainTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkPlainTree对象，以表示一个 {@linkplain }标签。
      LinkTree DocTreeFactory.newLinkTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkTree对象，以表示一个 {@link }标签。
      ProvidesTree DocTreeFactory.newProvidesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ProvidesTree对象，以表示一个 @provides标签。
      SerialFieldTree DocTreeFactory.newSerialFieldTree​(IdentifierTree name, ReferenceTree type, List<? extends DocTree> description)
      创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
      ThrowsTree DocTreeFactory.newThrowsTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ThrowsTree对象，以表示一个 @throws标签。
      UsesTree DocTreeFactory.newUsesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 UsesTree对象，代表一个 @uses标签。
      ValueTree DocTreeFactory.newValueTree​(ReferenceTree ref)
      创建一个新的 ValueTree对象，以表示一个 {@value }标签。
      R DocTreeScanner.visitReference​(ReferenceTree node, P p)
      访问一个ReferenceTree节点。
      R SimpleDocTreeVisitor.visitReference​(ReferenceTree node, P p)
      访问一个ReferenceTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.ReturnTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.ReturnTree

  • Packages that use ReturnTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ReturnTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type ReturnTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。

    • Uses of ReturnTree in com.sun.source.util

      Methods in com.sun.source.util that return ReturnTree
      Modifier and Type 方法 描述
      ReturnTree DocTreeFactory.newReturnTree​(List<? extends DocTree> description)
      创建一个新的 ReturnTree对象，以表示一个 @return标签。
      Methods in com.sun.source.util with parameters of type ReturnTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R SimpleDocTreeVisitor.visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.SeeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.SeeTree

  • Packages that use SeeTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SeeTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type SeeTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitSee​(SeeTree node, P p)
      访问SeeTree节点。

    • Uses of SeeTree in com.sun.source.util

      Methods in com.sun.source.util that return SeeTree
      Modifier and Type 方法 描述
      SeeTree DocTreeFactory.newSeeTree​(List<? extends DocTree> reference)
      创建一个新的 SeeTree对象，以表示一个 @see标签。
      Methods in com.sun.source.util with parameters of type SeeTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitSee​(SeeTree node, P p)
      访问SeeTree节点。
      R SimpleDocTreeVisitor.visitSee​(SeeTree node, P p)
      访问SeeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.SerialDataTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.SerialDataTree

  • Packages that use SerialDataTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SerialDataTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type SerialDataTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitSerialData​(SerialDataTree node, P p)
      访问一个SerialDataTree节点。

    • Uses of SerialDataTree in com.sun.source.util

      Methods in com.sun.source.util that return SerialDataTree
      Modifier and Type 方法 描述
      SerialDataTree DocTreeFactory.newSerialDataTree​(List<? extends DocTree> description)
      创建一个新的 SerialDataTree对象，以表示一个 @serialData标签。
      Methods in com.sun.source.util with parameters of type SerialDataTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitSerialData​(SerialDataTree node, P p)
      访问一个SerialDataTree节点。
      R SimpleDocTreeVisitor.visitSerialData​(SerialDataTree node, P p)
      访问一个SerialDataTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.SerialFieldTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.SerialFieldTree

  • Packages that use SerialFieldTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SerialFieldTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type SerialFieldTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitSerialField​(SerialFieldTree node, P p)
      访问SerialFieldTree节点。

    • Uses of SerialFieldTree in com.sun.source.util

      Methods in com.sun.source.util that return SerialFieldTree
      Modifier and Type 方法 描述
      SerialFieldTree DocTreeFactory.newSerialFieldTree​(IdentifierTree name, ReferenceTree type, List<? extends DocTree> description)
      创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
      Methods in com.sun.source.util with parameters of type SerialFieldTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitSerialField​(SerialFieldTree node, P p)
      访问SerialFieldTree节点。
      R SimpleDocTreeVisitor.visitSerialField​(SerialFieldTree node, P p)
      访问SerialFieldTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.SerialTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.SerialTree

  • Packages that use SerialTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SerialTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type SerialTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitSerial​(SerialTree node, P p)
      访问SerialTree节点。

    • Uses of SerialTree in com.sun.source.util

      Methods in com.sun.source.util that return SerialTree
      Modifier and Type 方法 描述
      SerialTree DocTreeFactory.newSerialTree​(List<? extends DocTree> description)
      创建一个新的 SerialTree对象，以表示一个 @serial标签。
      Methods in com.sun.source.util with parameters of type SerialTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitSerial​(SerialTree node, P p)
      访问SerialTree节点。
      R SimpleDocTreeVisitor.visitSerial​(SerialTree node, P p)
      访问SerialTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.SinceTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.SinceTree

  • Packages that use SinceTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SinceTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type SinceTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitSince​(SinceTree node, P p)
      访问SinceTree节点。

    • Uses of SinceTree in com.sun.source.util

      Methods in com.sun.source.util that return SinceTree
      Modifier and Type 方法 描述
      SinceTree DocTreeFactory.newSinceTree​(List<? extends DocTree> text)
      创建一个新的 SinceTree对象，以表示一个 @since标签。
      Methods in com.sun.source.util with parameters of type SinceTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitSince​(SinceTree node, P p)
      访问SinceTree节点。
      R SimpleDocTreeVisitor.visitSince​(SinceTree node, P p)
      访问SinceTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.StartElementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.StartElementTree

  • Packages that use StartElementTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of StartElementTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type StartElementTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitStartElement​(StartElementTree node, P p)
      访问StartElementTree节点。

    • Uses of StartElementTree in com.sun.source.util

      Methods in com.sun.source.util that return StartElementTree
      Modifier and Type 方法 描述
      StartElementTree DocTreeFactory.newStartElementTree​(Name name, List<? extends DocTree> attrs, boolean selfClosing)
      创建一个新的 StartElementTree对象，以表示HTML元素的开始。
      Methods in com.sun.source.util with parameters of type StartElementTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitStartElement​(StartElementTree node, P p)
      访问StartElementTree节点。
      R SimpleDocTreeVisitor.visitStartElement​(StartElementTree node, P p)
      访问StartElementTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.TextTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.TextTree

  • Packages that use TextTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TextTree in com.sun.source.doctree

      Subinterfaces of TextTree in com.sun.source.doctree
      Modifier and Type 接口 描述
      interface  ErroneousTree
      一个树状节点，用于生成格式不正确的文本
      Methods in com.sun.source.doctree that return TextTree
      Modifier and Type 方法 描述
      TextTree LiteralTree.getBody​()
      返回 @code或 @literal标签的 @code 。
      Methods in com.sun.source.doctree with parameters of type TextTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitText​(TextTree node, P p)
      访问TextTree节点。

    • Uses of TextTree in com.sun.source.util

      Methods in com.sun.source.util that return TextTree
      Modifier and Type 方法 描述
      TextTree DocTreeFactory.newTextTree​(String text)
      创建一个新的 TextTree对象，来表示一些纯文本。
      Methods in com.sun.source.util with parameters of type TextTree
      Modifier and Type 方法 描述
      LiteralTree DocTreeFactory.newCodeTree​(TextTree text)
      创建一个新的 CodeTree对象，以表示一个 {@code }标签。
      LiteralTree DocTreeFactory.newLiteralTree​(TextTree text)
      创建一个新的 LiteralTree对象，以表示一个 {@literal }标签。
      R DocTreeScanner.visitText​(TextTree node, P p)
      访问TextTree节点。
      R SimpleDocTreeVisitor.visitText​(TextTree node, P p)
      访问TextTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.ThrowsTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.ThrowsTree

  • Packages that use ThrowsTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ThrowsTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type ThrowsTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitThrows​(ThrowsTree node, P p)
      访问ThrowsTree节点。

    • Uses of ThrowsTree in com.sun.source.util

      Methods in com.sun.source.util that return ThrowsTree
      Modifier and Type 方法 描述
      ThrowsTree DocTreeFactory.newExceptionTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ExceptionTree对象，以表示一个 @exception标签。
      ThrowsTree DocTreeFactory.newThrowsTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ThrowsTree对象，以表示一个 @throws标签。
      Methods in com.sun.source.util with parameters of type ThrowsTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitThrows​(ThrowsTree node, P p)
      访问ThrowsTree节点。
      R SimpleDocTreeVisitor.visitThrows​(ThrowsTree node, P p)
      Visits a ThrowsTree node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.UnknownBlockTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.UnknownBlockTagTree

  • Packages that use UnknownBlockTagTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of UnknownBlockTagTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type UnknownBlockTagTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitUnknownBlockTag​(UnknownBlockTagTree node, P p)
      访问UnknownBlockTagTree节点。

    • Uses of UnknownBlockTagTree in com.sun.source.util

      Methods in com.sun.source.util that return UnknownBlockTagTree
      Modifier and Type 方法 描述
      UnknownBlockTagTree DocTreeFactory.newUnknownBlockTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownBlockTagTree对象，以表示一个无法识别的块标签。
      Methods in com.sun.source.util with parameters of type UnknownBlockTagTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitUnknownBlockTag​(UnknownBlockTagTree node, P p)
      访问UnknownBlockTagTree节点。
      R SimpleDocTreeVisitor.visitUnknownBlockTag​(UnknownBlockTagTree node, P p)
      访问UnknownBlockTagTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.UnknownInlineTagTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.UnknownInlineTagTree

  • Packages that use UnknownInlineTagTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of UnknownInlineTagTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type UnknownInlineTagTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitUnknownInlineTag​(UnknownInlineTagTree node, P p)
      访问UnknownInlineTagTree节点。

    • Uses of UnknownInlineTagTree in com.sun.source.util

      Methods in com.sun.source.util that return UnknownInlineTagTree
      Modifier and Type 方法 描述
      UnknownInlineTagTree DocTreeFactory.newUnknownInlineTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownInlineTagTree对象，以表示无法识别的内联标签。
      Methods in com.sun.source.util with parameters of type UnknownInlineTagTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitUnknownInlineTag​(UnknownInlineTagTree node, P p)
      访问UnknownInlineTagTree节点。
      R SimpleDocTreeVisitor.visitUnknownInlineTag​(UnknownInlineTagTree node, P p)
      访问UnknownInlineTagTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.UsesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.UsesTree

  • Packages that use UsesTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of UsesTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type UsesTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitUses​(UsesTree node, P p)
      访问UsesTree节点。

    • Uses of UsesTree in com.sun.source.util

      Methods in com.sun.source.util that return UsesTree
      Modifier and Type 方法 描述
      UsesTree DocTreeFactory.newUsesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 UsesTree对象，以表示一个 @uses标签。
      Methods in com.sun.source.util with parameters of type UsesTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitUses​(UsesTree node, P p)
      访问UsesTree节点。
      R SimpleDocTreeVisitor.visitUses​(UsesTree node, P p)
      访问UsesTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.ValueTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.ValueTree

  • Packages that use ValueTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ValueTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type ValueTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitValue​(ValueTree node, P p)
      访问ValueTree节点。

    • Uses of ValueTree in com.sun.source.util

      Methods in com.sun.source.util that return ValueTree
      Modifier and Type 方法 描述
      ValueTree DocTreeFactory.newValueTree​(ReferenceTree ref)
      创建一个新的 ValueTree对象，以表示一个 {@value }标签。
      Methods in com.sun.source.util with parameters of type ValueTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitValue​(ValueTree node, P p)
      访问ValueTree节点。
      R SimpleDocTreeVisitor.visitValue​(ValueTree node, P p)
      访问ValueTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.doctree.VersionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.doctree.VersionTree

  • Packages that use VersionTree
    软件包 描述
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of VersionTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type VersionTree
      Modifier and Type 方法 描述
      R DocTreeVisitor.visitVersion​(VersionTree node, P p)
      访问VersionTreeTree节点。

    • Uses of VersionTree in com.sun.source.util

      Methods in com.sun.source.util that return VersionTree
      Modifier and Type 方法 描述
      VersionTree DocTreeFactory.newVersionTree​(List<? extends DocTree> text)
      创建一个新的 VersionTree对象，以表示一个 {@version }标签。
      Methods in com.sun.source.util with parameters of type VersionTree
      Modifier and Type 方法 描述
      R DocTreeScanner.visitVersion​(VersionTree node, P p)
      访问VersionTreeTree节点。
      R SimpleDocTreeVisitor.visitVersion​(VersionTree node, P p)
      访问VersionTreeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AnnotatedTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface AnnotatedTypeTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface AnnotatedTypeTree
extends ExpressionTree
    用于注释类型的树节点。 例如：
      @annotationType String
    @annotationType ( arguments ) Date
    从以下版本开始：
    1.8
    另请参见：
    “JSR 308：Java类型注释”

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> getAnnotations​()
      返回与此类型表达式关联的注释。
      ExpressionTree getUnderlyingType​()
      返回与注释关联的底层类型。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getAnnotations

        List<? extends AnnotationTree> getAnnotations​()
        返回与此类型表达式关联的注释。
        结果
        注释

      • getUnderlyingType

        ExpressionTree getUnderlyingType​()
        返回与注释关联的底层类型。
        结果
        底层类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface AnnotationTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface AnnotationTree
extends ExpressionTree
    用于注释的树节点。 例如：
      @annotationType
    @annotationType ( arguments )
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第9.7节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      树 getAnnotationType​()
      返回注释类型。
      List<? extends ExpressionTree> getArguments​()
      返回注释的参数（如果有）。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getAnnotationType

        树 getAnnotationType​()
        返回注释类型。
        结果
        注释类型

      • getArguments

        List<? extends ExpressionTree> getArguments​()
        返回注释的参数（如果有）。
        结果
        注释类型的参数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ArrayAccessTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ArrayAccessTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface ArrayAccessTree
extends ExpressionTree
    数组访问表达式的树节点。 例如：
      expression [ index ]
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.13条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回正在访问的数组的表达式。
      ExpressionTree getIndex​()
      返回索引的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回正在访问的数组的表达式。
        结果
        阵列

      • getIndex

        ExpressionTree getIndex​()
        返回索引的表达式。
        结果
        指数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ArrayTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ArrayTypeTree

  • All Superinterfaces:
    树

    public interface ArrayTypeTree
extends 树
    数组类型的树节点。 例如：
      type []
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第10.1节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      树 getType​()
      返回此数组类型的元素类型。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getType

        树 getType​()
        返回此数组类型的元素类型。
        结果
        the element type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AssertTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface AssertTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface AssertTree
extends StatementTree
    一个用于assert语句的树节点。 例如：
      assert condition ;

   assert condition : detail ;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.10节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getCondition​()
      返回被声明的条件。
      ExpressionTree getDetail​()
      返回详细表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getCondition

        ExpressionTree getCondition​()
        返回被声明的条件。
        结果
        条件

      • getDetail

        ExpressionTree getDetail​()
        返回详细表达式。
        结果
        细节表达
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AssignmentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface AssignmentTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface AssignmentTree
extends ExpressionTree
    赋值表达式的树节点。 例如：
      variable = expression
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.26.1节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回分配给变量的表达式。
      ExpressionTree getVariable​()
      返回被分配给的变量。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getVariable

        ExpressionTree getVariable​()
        返回被分配给的变量。
        结果
        变量

      • getExpression

        ExpressionTree getExpression​()
        返回分配给变量的表达式。
        结果
        表达方式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BinaryTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface BinaryTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface BinaryTree
extends ExpressionTree
    二进制表达式的树节点。 使用getKind来确定运算符的种类。 例如：
      leftOperand operator rightOperand
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.17至15.24条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getLeftOperand​()
      返回表达式的左（第一）操作数。
      ExpressionTree getRightOperand​()
      返回表达式的右（第二）操作数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getLeftOperand

        ExpressionTree getLeftOperand​()
        返回表达式的左（第一）操作数。
        结果
        左操作数

      • getRightOperand

        ExpressionTree getRightOperand​()
        返回表达式的右（第二）操作数。
        结果
        正确的操作数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BlockTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface BlockTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface BlockTree
extends StatementTree
    语句块的树节点。 例如：
      { }

   { statements }

   static { statements }
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.2节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends StatementTree> getStatements​()
      返回包含此块的语句。
      boolean isStatic​()
      当且仅当这是静态的初始化程序块时才返回true。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • isStatic

        boolean isStatic​()
        当且仅当这是静态的初始化程序块时才返回true。
        结果
        如果这是静态初始化程序块，则为true

      • getStatements

        List<? extends StatementTree> getStatements​()
        返回包含此块的语句。
        结果
        声明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BreakTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface BreakTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface BreakTree
extends StatementTree
    一个用于break语句的树节点。 例如：
      break;

   break label ;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.15条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getLabel​()
      返回此 break语句的标签。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getLabel

        Name getLabel​()
        返回此 break语句的标签。
        结果
        the label
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CaseTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface CaseTree

  • All Superinterfaces:
    树

    public interface CaseTree
extends 树
    一个case在switch语句中的树节点。 例如：
      case expression :
       statements

   default :
       statements
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.11条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回case的表达式，如果这是默认情况，则返回 null 。
      List<? extends StatementTree> getStatements​()
      返回由案例标注的语句。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回case的表达式，如果这是默认情况，则返回 null 。
        结果
        案例的表达式，或null

      • getStatements

        List<? extends StatementTree> getStatements​()
        返回由案例标注的语句。
        结果
        情况标示的声明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CatchTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface CatchTree

  • All Superinterfaces:
    树

    public interface CatchTree
extends 树
    一个catch块的树节点在try语句中。 例如：
      catch ( parameter )
       block
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.20节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BlockTree getBlock​()
      返回catch块。
      VariableTree getParameter​()
      返回catch变量。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getParameter

        VariableTree getParameter​()
        返回catch变量。 一个多catch变量将有一个UnionTypeTree作为变量的类型。
        结果
        catch变量

      • getBlock

        BlockTree getBlock​()
        返回catch块。
        结果
        抓块
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ClassTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface ClassTree
extends StatementTree
    用于类，接口，枚举或注释类型声明的树节点。 例如：
      modifiers class simpleName typeParameters
       extends extendsClause
       implements implementsClause
   {
       members
   }
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第8.1,8.9,9.1和9.6节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      树 getExtendsClause​()
      返回此类型声明的超类型，如果没有提供，则返回 null 。
      List<? extends 树> getImplementsClause​()
      返回由此类型声明实现的接口。
      List<? extends 树> getMembers​()
      返回在此类型声明中声明的成员。
      ModifiersTree getModifiers​()
      返回此类型声明的修饰符，包括任何注释。
      Name getSimpleName​()
      返回此类型声明的简单名称。
      List<? extends TypeParameterTree> getTypeParameters​()
      返回此类型声明的任何类型参数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getModifiers

        ModifiersTree getModifiers​()
        返回此类型声明的修饰符，包括任何注释。
        结果
        修饰符

      • getSimpleName

        Name getSimpleName​()
        返回此类型声明的简单名称。
        结果
        简单的名字

      • getTypeParameters

        List<? extends TypeParameterTree> getTypeParameters​()
        返回此类型声明的任何类型参数。
        结果
        类型参数

      • getExtendsClause

        树 getExtendsClause​()
        返回此类型声明的超类型，如果没有提供，则返回 null 。
        结果
        超类型

      • getImplementsClause

        List<? extends 树> getImplementsClause​()
        返回由此类型声明实现的接口。
        结果
        界面

      • getMembers

        List<? extends 树> getMembers​()
        返回在此类型声明中声明的成员。
        结果
        成员
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.source.tree (Java SE 9 & JDK 9 )

com.sun.source.tree

Interfaces

  • AnnotatedTypeTree
  • AnnotationTree
  • ArrayAccessTree
  • ArrayTypeTree
  • AssertTree
  • AssignmentTree
  • BinaryTree
  • BlockTree
  • BreakTree
  • CaseTree
  • CatchTree
  • ClassTree
  • CompilationUnitTree
  • CompoundAssignmentTree
  • ConditionalExpressionTree
  • ContinueTree
  • DirectiveTree
  • DoWhileLoopTree
  • EmptyStatementTree
  • EnhancedForLoopTree
  • ErroneousTree
  • ExportsTree
  • ExpressionStatementTree
  • ExpressionTree
  • ForLoopTree
  • IdentifierTree
  • IfTree
  • ImportTree
  • InstanceOfTree
  • IntersectionTypeTree
  • LabeledStatementTree
  • LambdaExpressionTree
  • LineMap
  • LiteralTree
  • MemberReferenceTree
  • MemberSelectTree
  • MethodInvocationTree
  • MethodTree
  • ModifiersTree
  • ModuleTree
  • NewArrayTree
  • NewClassTree
  • OpensTree
  • PackageTree
  • ParameterizedTypeTree
  • ParenthesizedTree
  • PrimitiveTypeTree
  • ProvidesTree
  • RequiresTree
  • ReturnTree
  • Scope
  • StatementTree
  • SwitchTree
  • SynchronizedTree
  • ThrowTree
  • 树
  • TreeVisitor
  • TryTree
  • TypeCastTree
  • TypeParameterTree
  • UnaryTree
  • UnionTypeTree
  • UsesTree
  • VariableTree
  • WhileLoopTree
  • WildcardTree

Enums

  • LambdaExpressionTree.BodyKind
  • MemberReferenceTree.ReferenceMode
  • ModuleTree.ModuleKind
  • Tree.Kind


com.sun.source.tree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.compiler

Package com.sun.source.tree

提供用于将源代码表示为抽象语法树（AST）的接口。
从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    AnnotatedTypeTree
    用于注释类型的树节点。
    AnnotationTree
    用于注释的树节点。
    ArrayAccessTree
    数组访问表达式的树节点。
    ArrayTypeTree
    数组类型的树节点。
    AssertTree
    一个树结点为 assert语句。
    AssignmentTree
    赋值表达式的树节点。
    BinaryTree
    二进制表达式的树节点。
    BlockTree
    语句块的树节点。
    BreakTree
    一个用于 break语句的树节点。
    CaseTree
    一个 case树节点在 switch语句中。
    CatchTree
    一个 catch块中的一个树节点，在 try语句中。
    ClassTree
    用于类，接口，枚举或注释类型声明的树节点。
    CompilationUnitTree
    表示编译单元（源文件）和程序包声明（package-info.java）的抽象语法树。
    CompoundAssignmentTree
    复合赋值运算符的树节点。
    ConditionalExpressionTree
    条件运算符的树节点？
    ContinueTree
    一个用于 continue语句的树节点。
    DirectiveTree
    对于ModuleTree中的所有指令的超类型。
    DoWhileLoopTree
    一个用于 do语句的树节点。
    EmptyStatementTree
    一个空（跳过）语句的树节点。
    EnhancedForLoopTree
    一个树状节点用于“增强”的 for循环语句。
    ErroneousTree
    一个树形节点，用于支撑格式不正确的表达式。
    ExportsTree
    模块声明中的“exports”指令的树节点。
    ExpressionStatementTree
    表达式语句的树节点。
    ExpressionTree
    用作不同类型表达式的基类的树节点。
    ForLoopTree
    一个树节点，用于基本的 for循环语句。
    IdentifierTree
    标识符表达式的树节点。
    IfTree
    一个用于 if语句的树节点。
    ImportTree
    导入声明的树节点。
    InstanceOfTree
    一个 instanceof表达式的树节点。
    IntersectionTypeTree
    转换表达式中交叉路口类型的树节点。
    LabeledStatementTree
    标记语句的树节点。
    LambdaExpressionTree
    lambda表达式的树节点。
    LineMap
    提供在编译单元的字符位置和行号之间进行转换的方法。
    LiteralTree
    一个文字表达式的树结点。
    MemberReferenceTree
    成员引用表达式的树节点。
    MemberSelectTree
    成员访问表达式的树节点。
    MethodInvocationTree
    方法调用表达式的树节点。
    MethodTree
    用于方法或注释类型元素声明的树节点。
    ModifiersTree
    用于声明的修饰符的树节点（包括注释）。
    ModuleTree
    模块声明的树节点。
    NewArrayTree
    用于创建数组的新实例的表达式的树节点。
    NewClassTree
    一个树节点来声明一个类的新实例。
    OpensTree
    模块声明中的“打开”指令的树节点。
    PackageTree
    表示包声明。
    ParameterizedTypeTree
    涉及类型参数的类型表达式的树节点。
    ParenthesizedTree
    括号表达式的树节点。
    PrimitiveTypeTree
    一个原始类型的树节点。
    ProvidesTree
    模块声明中“提供”指令的树节点。
    RequiresTree
    模块声明中“require”指令的树结点。
    ReturnTree
    一个树节点为一个 return语句。
    Scope
    用于确定本地可用的程序元素的接口，如局部变量和导入。
    StatementTree
    用作不同类型语句的基类的树节点。
    SwitchTree
    一个用于 switch语句的树节点。
    SynchronizedTree
    一个用于 synchronized语句的树节点。
    ThrowTree
    一个树节点为一个 throw语句。
    树
    抽象语法树中所有节点的公共接口。
    TreeVisitor<R,P>
    树木的访客，以访客设计模式的风格。
    TryTree
    一个用于 try语句的树节点。
    TypeCastTree
    类型转换表达式的树节点。
    TypeParameterTree
    类型参数的树节点。
    UnaryTree
    用于后缀和一元表达式的树节点。
    UnionTypeTree
    多重变量声明中的联合类型表达式的树节点。
    UsesTree
    模块声明中的'uses'指令的树节点。
    VariableTree
    用于变量声明的树节点。
    WhileLoopTree
    一个用于 while循环语句的树节点。
    WildcardTree
    用于通配符类型参数的树节点。
  • 枚举摘要
    Enum 描述
    LambdaExpressionTree.BodyKind
    Lambda表达式有两种形式：表达式lambdas，其主体是表达式，语句lambdas，其主体是块
    MemberReferenceTree.ReferenceMode
    有两种成员引用：（i）方法引用和（ii）构造函数引用
    ModuleTree.ModuleKind
    模块的种类。
    Tree.Kind
    列举各种树木。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.source.tree Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.source.tree

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • com.sun.source.tree.LineMap
  • com.sun.source.tree.Scope
  • com.sun.source.tree.树
    • com.sun.source.tree.ArrayTypeTree
    • com.sun.source.tree.CaseTree
    • com.sun.source.tree.CatchTree
    • com.sun.source.tree.CompilationUnitTree
    • com.sun.source.tree.DirectiveTree
      • com.sun.source.tree.ExportsTree
      • com.sun.source.tree.OpensTree
      • com.sun.source.tree.ProvidesTree
      • com.sun.source.tree.RequiresTree
      • com.sun.source.tree.UsesTree
    • com.sun.source.tree.ExpressionTree
      • com.sun.source.tree.AnnotatedTypeTree
      • com.sun.source.tree.AnnotationTree
      • com.sun.source.tree.ArrayAccessTree
      • com.sun.source.tree.AssignmentTree
      • com.sun.source.tree.BinaryTree
      • com.sun.source.tree.CompoundAssignmentTree
      • com.sun.source.tree.ConditionalExpressionTree
      • com.sun.source.tree.ErroneousTree
      • com.sun.source.tree.IdentifierTree
      • com.sun.source.tree.InstanceOfTree
      • com.sun.source.tree.LambdaExpressionTree
      • com.sun.source.tree.LiteralTree
      • com.sun.source.tree.MemberReferenceTree
      • com.sun.source.tree.MemberSelectTree
      • com.sun.source.tree.MethodInvocationTree
      • com.sun.source.tree.NewArrayTree
      • com.sun.source.tree.NewClassTree
      • com.sun.source.tree.ParenthesizedTree
      • com.sun.source.tree.TypeCastTree
      • com.sun.source.tree.UnaryTree
    • com.sun.source.tree.ImportTree
    • com.sun.source.tree.IntersectionTypeTree
    • com.sun.source.tree.MethodTree
    • com.sun.source.tree.ModifiersTree
    • com.sun.source.tree.ModuleTree
    • com.sun.source.tree.PackageTree
    • com.sun.source.tree.ParameterizedTypeTree
    • com.sun.source.tree.PrimitiveTypeTree
    • com.sun.source.tree.StatementTree
      • com.sun.source.tree.AssertTree
      • com.sun.source.tree.BlockTree
      • com.sun.source.tree.BreakTree
      • com.sun.source.tree.ClassTree
      • com.sun.source.tree.ContinueTree
      • com.sun.source.tree.DoWhileLoopTree
      • com.sun.source.tree.EmptyStatementTree
      • com.sun.source.tree.EnhancedForLoopTree
      • com.sun.source.tree.ExpressionStatementTree
      • com.sun.source.tree.ForLoopTree
      • com.sun.source.tree.IfTree
      • com.sun.source.tree.LabeledStatementTree
      • com.sun.source.tree.ReturnTree
      • com.sun.source.tree.SwitchTree
      • com.sun.source.tree.SynchronizedTree
      • com.sun.source.tree.ThrowTree
      • com.sun.source.tree.TryTree
      • com.sun.source.tree.VariableTree
      • com.sun.source.tree.WhileLoopTree
    • com.sun.source.tree.TypeParameterTree
    • com.sun.source.tree.UnionTypeTree
    • com.sun.source.tree.WildcardTree
  • com.sun.source.tree.TreeVisitor<R,P>

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.source.tree.LambdaExpressionTree.BodyKind
      • com.sun.source.tree.MemberReferenceTree.ReferenceMode
      • com.sun.source.tree.ModuleTree.ModuleKind
      • com.sun.source.tree.Tree.Kind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


CompilationUnitTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface CompilationUnitTree

  • All Superinterfaces:
    树

    public interface CompilationUnitTree
extends 树
    表示编译单元（源文件）和程序包声明（package-info.java）的抽象语法树。
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    7.3和7.4节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends ImportTree> getImports​()
      返回此编译单元中出现的导入声明。
      LineMap getLineMap​()
      返回此编译单元的行图（如果可用）。
      PackageTree getPackage​()
      返回与此编译单元关联的包树，或者如果没有包声明，则返回 null 。
      List<? extends AnnotationTree> getPackageAnnotations​()
      返回在编译单元头部的任何包装声明上列出的注释，如果没有包装声明，则 null 。
      ExpressionTree getPackageName​()
      返回此编译单元头部的任何包装声明中包含的名称，如果没有包装声明，则 null 。
      JavaFileObject getSourceFile​()
      返回包含此编译单元的源的文件对象。
      List<? extends 树> getTypeDecls​()
      返回此编译单元中出现的类型声明。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getPackageAnnotations

        List<? extends AnnotationTree> getPackageAnnotations​()
        返回在编译单元头部的任何包装声明中列出的注释，如果没有包声明，则 null 。
        结果
        包注释

      • getPackageName

        ExpressionTree getPackageName​()
        返回此编译单元头部的任何包装声明中包含的名称，如果没有包装声明，则 null 。
        结果
        包名称

      • getPackage

        PackageTree getPackage​()
        返回与此编译单元关联的包树，或者如果没有包声明，则返回 null 。
        结果
        包树
        从以下版本开始：
        9

      • getImports

        List<? extends ImportTree> getImports​()
        返回此编译单元中出现的导入声明。
        结果
        进口报关单

      • getTypeDecls

        List<? extends 树> getTypeDecls​()
        返回此编译单元中出现的类型声明。 该列表还可能包括由外部分号产生的空语句。
        结果
        类型声明

      • getSourceFile

        JavaFileObject getSourceFile​()
        返回包含此编译单元的源的文件对象。
        结果
        文件对象

      • getLineMap

        LineMap getLineMap​()
        返回此编译单元的行图（如果可用）。 如果线图不可用，则返回null 。
        结果
        该编辑单位的线图
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CompoundAssignmentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface CompoundAssignmentTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface CompoundAssignmentTree
extends ExpressionTree
    复合赋值运算符的树节点。 使用getKind来确定运算符的种类。 例如：
      variable operator expression
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.26.2条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回复合赋值右侧的表达式。
      ExpressionTree getVariable​()
      返回复合赋值左侧的变量。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getVariable

        ExpressionTree getVariable​()
        返回复合赋值左侧的变量。
        结果
        变量

      • getExpression

        ExpressionTree getExpression​()
        返回复合赋值右侧的表达式。
        结果
        表达方式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ConditionalExpressionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ConditionalExpressionTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface ConditionalExpressionTree
extends ExpressionTree
    条件运算符的树节点？ ：。 例如：
      condition ? trueExpression : falseExpression
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.25条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getCondition​()
      返回条件。
      ExpressionTree getFalseExpression​()
      如果条件为false，则返回要评估的表达式。
      ExpressionTree getTrueExpression​()
      如果条件为真，返回要评估的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getCondition

        ExpressionTree getCondition​()
        返回条件。
        结果
        条件

      • getTrueExpression

        ExpressionTree getTrueExpression​()
        如果条件为真，返回要评估的表达式。
        结果
        如果条件为真，则要评估的表达式

      • getFalseExpression

        ExpressionTree getFalseExpression​()
        如果条件为false，则返回要评估的表达式。
        结果
        the expression to be evaluated if the condition is false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContinueTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ContinueTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface ContinueTree
extends StatementTree
    一个用于continue语句的树节点。 例如：
      continue;
   continue label ;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.16条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getLabel​()
      返回此 continue语句的标签。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getLabel

        Name getLabel​()
        返回此 continue语句的标签。
        结果
        the label
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DirectiveTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface DirectiveTree

  • All Superinterfaces:
    树
    All Known Subinterfaces:
    ExportsTree ， OpensTree ， ProvidesTree ， RequiresTree ， UsesTree

    public interface DirectiveTree
extends 树
    对于ModuleTree中的所有指令的超类型。

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DoWhileLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface DoWhileLoopTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface DoWhileLoopTree
extends StatementTree
    一个用于do语句的树节点。 例如：
      do
       statement
   while ( expression );
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.13条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getCondition​()
      返回循环的条件。
      StatementTree getStatement​()
      返回循环的正文。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getCondition

        ExpressionTree getCondition​()
        返回循环的条件。
        结果
        条件

      • getStatement

        StatementTree getStatement​()
        返回循环的正文。
        结果
        循环的身体
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EmptyStatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface EmptyStatementTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface EmptyStatementTree
extends StatementTree
    一个空（跳过）语句的树节点。 例如：
      ;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.6节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EnhancedForLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface EnhancedForLoopTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface EnhancedForLoopTree
extends StatementTree
    一个树状节点用于“增强”的for循环语句。 例如：
      for ( variable : expression )
       statement
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.14.2条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回产生控制变量值的表达式。
      StatementTree getStatement​()
      返回循环的正文。
      VariableTree getVariable​()
      返回循环的控制变量。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getVariable

        VariableTree getVariable​()
        返回循环的控制变量。
        结果
        控制变量

      • getExpression

        ExpressionTree getExpression​()
        返回产生控制变量值的表达式。
        结果
        表达方式

      • getStatement

        StatementTree getStatement​()
        返回循环的正文。
        结果
        the body of the loop
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ErroneousTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ErroneousTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface ErroneousTree
extends ExpressionTree
    一个树形节点，用于支撑格式不正确的表达式。
    从以下版本开始：
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends 树> getErrorTrees​()
      返回保存在此节点中的任何树。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getErrorTrees

        List<? extends 树> getErrorTrees​()
        返回保存在此节点中的任何树。
        结果
        树
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExportsTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ExportsTree

  • All Superinterfaces:
    DirectiveTree ， 树

    public interface ExportsTree
extends DirectiveTree
    模块声明中的“exports”指令的树节点。 例如：
      exports package-name;
    exports package-name to module-name;
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends ExpressionTree> getModuleNames​()
      返回包导出到的模块的名称，如果软件包导出到所有模块，则返回null。
      ExpressionTree getPackageName​()
      返回要导出的包的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getPackageName

        ExpressionTree getPackageName​()
        返回要导出的包的名称。
        结果
        要导出的包的名称

      • getModuleNames

        List<? extends ExpressionTree> getModuleNames​()
        返回包导出到的模块的名称，如果软件包导出到所有模块，则返回null。
        结果
        导出包的模块的名称，或者为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExpressionStatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ExpressionStatementTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface ExpressionStatementTree
extends StatementTree
    表达式语句的树节点。 例如：
      expression ;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.8节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回构成该语句的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回构成该语句的表达式。
        结果
        the expression
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExpressionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ExpressionTree

  • All Superinterfaces:
    树
    All Known Subinterfaces:
    AnnotatedTypeTree ， AnnotationTree ， ArrayAccessTree ， AssignmentTree ， BinaryTree ， CompoundAssignmentTree ， ConditionalExpressionTree ， ErroneousTree ， IdentifierTree ， InstanceOfTree ， LambdaExpressionTree ， LiteralTree ， MemberReferenceTree ， MemberSelectTree ， MethodInvocationTree ， NewArrayTree ， NewClassTree ， ParenthesizedTree ， TypeCastTree ， UnaryTree

    public interface ExpressionTree
extends 树
    用作不同类型表达式的基类的树节点。
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15章

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ForLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ForLoopTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface ForLoopTree
extends StatementTree
    一个树节点，用于基本的for循环语句。 例如：
      for ( initializer ; condition ; update )
       statement
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.14.1条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getCondition​()
      返回 for语句的条件。
      List<? extends StatementTree> getInitializer​()
      返回 for语句的任何初始值。
      StatementTree getStatement​()
      返回 for语句的 for 。
      List<? extends ExpressionStatementTree> getUpdate​()
      返回 for语句的更新表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getInitializer

        List<? extends StatementTree> getInitializer​()
        返回for语句的任何初始值。 如果没有初始化程序，结果将是一个空列表
        结果
        初始化器

      • getCondition

        ExpressionTree getCondition​()
        返回for语句的条件。 如果没有条件，可能是null 。
        结果
        条件

      • getUpdate

        List<? extends ExpressionStatementTree> getUpdate​()
        返回 for语句的更新表达式。
        结果
        更新表达式

      • getStatement

        StatementTree getStatement​()
        返回 for语句的 for 。
        结果
        身体
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IdentifierTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface IdentifierTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface IdentifierTree
extends ExpressionTree
    标识符表达式的树节点。 例如：
      name
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第6.5.6.1节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getName​()
      返回标识符的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getName

        Name getName​()
        返回标识符的名称。
        结果
        the name
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IfTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface IfTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface IfTree
extends StatementTree
    一个用于if语句的树节点。 例如：
      if ( condition )
      thenStatement

   if ( condition )
       thenStatement
   else
       elseStatement
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.9节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getCondition​()
      返回if语句的条件。
      StatementTree getElseStatement​()
      如果条件为false，则返回要执行的语句，如果没有这样的语句，则返回 null 。
      StatementTree getThenStatement​()
      如果条件为真，则返回要执行的语句

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getCondition

        ExpressionTree getCondition​()
        返回if语句的条件。
        结果
        条件

      • getThenStatement

        StatementTree getThenStatement​()
        如果条件为真，则返回要执行的语句
        结果
        条件为真时执行的语句

      • getElseStatement

        StatementTree getElseStatement​()
        如果条件为false，则返回要执行的语句，如果没有这样的语句，则返回 null 。
        结果
        the statement to be executed if the condition is false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImportTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ImportTree

  • All Superinterfaces:
    树

    public interface ImportTree
extends 树
    导入声明的树节点。 例如：
      import qualifiedIdentifier ;

   static import qualifiedIdentifier ;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第7.5节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      树 getQualifiedIdentifier​()
      返回要导入的声明的合格标识符。
      boolean isStatic​()
      如果这是静态导入声明，则返回true。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • isStatic

        boolean isStatic​()
        如果这是静态导入声明，则返回true。
        结果
        如果这是静态导入，则为true

      • getQualifiedIdentifier

        树 getQualifiedIdentifier​()
        返回要导入的声明的合格标识符。 如果这是一个按需导入的声明，合格的标识符将以“*”结尾。
        结果
        合格的标识符，当且仅当这是按需导入时才以“*”结尾
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InstanceOfTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface InstanceOfTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface InstanceOfTree
extends ExpressionTree
    一个instanceof表达式的树节点。 例如：
      expression instanceof type
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.20.2节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回要测试的表达式。
      树 getType​()
      返回要检查的类型。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回要测试的表达式。
        结果
        表达方式

      • getType

        树 getType​()
        返回要检查的类型。
        结果
        方式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IntersectionTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface IntersectionTypeTree

  • All Superinterfaces:
    树

    public interface IntersectionTypeTree
extends 树
    转换表达式中交叉路口类型的树节点。
    从以下版本开始：
    1.8

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends 树> getBounds​()
      返回类型的边界。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getBounds

        List<? extends 树> getBounds​()
        返回类型的边界。
        结果
        界限
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LabeledStatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface LabeledStatementTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface LabeledStatementTree
extends StatementTree
    标记语句的树节点。 例如：
      label : statement
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.7节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Name getLabel​()
      返回标签。
      StatementTree getStatement​()
      返回标记的语句。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getLabel

        Name getLabel​()
        返回标签。
        结果
        标签

      • getStatement

        StatementTree getStatement​()
        返回标记的语句。
        结果
        该声明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LambdaExpressionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface LambdaExpressionTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface LambdaExpressionTree
extends ExpressionTree
    lambda表达式的树节点。 例如：
       ()->{} (List<String> ls)->ls.size() (x,y)-> { return x + y; }

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  LambdaExpressionTree.BodyKind
      Lambda表达式有两种形式：表达式lambdas，其主体是表达式，语句lambdas，其主体是块

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      树 getBody​()
      返回lambda表达式的正文。
      LambdaExpressionTree.BodyKind getBodyKind​()
      返回lambda表达式的主体的种类。
      List<? extends VariableTree> getParameters​()
      返回此lambda表达式的参数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getParameters

        List<? extends VariableTree> getParameters​()
        返回此lambda表达式的参数。
        结果
        参数

      • getBody

        树 getBody​()
        返回lambda表达式的正文。
        结果
        身体

      • getBodyKind

        LambdaExpressionTree.BodyKind getBodyKind​()
        返回lambda表达式的主体的种类。
        结果
        身体的种类
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LambdaExpressionTree.BodyKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Enum LambdaExpressionTree.BodyKind

  • java.lang.Object
    • java.lang.Enum<LambdaExpressionTree.BodyKind>
      • com.sun.source.tree.LambdaExpressionTree.BodyKind
  • All Implemented Interfaces:
    Serializable ， Comparable<LambdaExpressionTree.BodyKind>
    Enclosing interface:
    LambdaExpressionTree

    public static enum LambdaExpressionTree.BodyKind
extends Enum<LambdaExpressionTree.BodyKind>
    Lambda表达式有两种形式：
    • 表达羔羊，身体是一种表达，
    • 陈述羔羊，身体是一块

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      EXPRESSION
      枚举常数表达兰布
      STATEMENT
      枚举常数用于语句lambdas

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static LambdaExpressionTree.BodyKind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static LambdaExpressionTree.BodyKind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • EXPRESSION

        public static final LambdaExpressionTree.BodyKind EXPRESSION
        枚举常数表达兰布

      • STATEMENT

        public static final LambdaExpressionTree.BodyKind STATEMENT
        枚举常数用于语句lambdas

    • 方法详细信息

      • values

        public static LambdaExpressionTree.BodyKind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (LambdaExpressionTree.BodyKind c : LambdaExpressionTree.BodyKind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static LambdaExpressionTree.BodyKind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


LineMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface LineMap

  • public interface LineMap
    提供在编译单元的字符位置和行号之间进行转换的方法。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getColumnNumber​(long pos)
      查找字符位置的列。
      long getLineNumber​(long pos)
      找到包含位置的行; 线终止字符在其终止的行上。
      long getPosition​(long line, long column)
      找到对应于（行，列）的位置。
      long getStartPosition​(long line)
      找到一行的起始位置。

    • 方法详细信息

      • getStartPosition

        long getStartPosition​(long line)
        找到一行的起始位置。
        参数
        line - 行号（从1开始）
        结果
        第一个字符的位置在一行
        异常
        IndexOutOfBoundsException - 如果是 lineNumber < 1如果是 lineNumber > no. of lines

      • getPosition

        long getPosition​(long line,
                 long column)
        找到对应于（行，列）的位置。
        参数
        line - 行号（从1开始）
        column - 标签扩展列号（开始1）
        结果
        性格位置
        异常
        IndexOutOfBoundsException - 如果是 line < 1如果是 line > no. of lines

      • getLineNumber

        long getLineNumber​(long pos)
        找到包含位置的行; 线终止字符在其终止的行上。
        参数
        pos - 位置的字符偏移
        结果
        pos的行数（第一行为1）

      • getColumnNumber

        long getColumnNumber​(long pos)
        查找字符位置的列。 在计算列号的同时，位置之前的标签字符将被扩展。
        参数
        pos - 位置的字符偏移
        结果
        标签展开的pos列数（第一列为1）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LiteralTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface LiteralTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface LiteralTree
extends ExpressionTree
    一个文字表达式的树结点。 使用getKind来确定文字的种类。 例如：
      value
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.28条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object getValue​()
      返回文字表达式的值。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getValue

        Object getValue​()
        返回文字表达式的值。 该值将是一个盒装原始值，一个字符串，或null 。
        结果
        the value
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemberReferenceTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface MemberReferenceTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface MemberReferenceTree
extends ExpressionTree
    成员引用表达式的树节点。 例如：
      expression # [ identifier | new ]
    从以下版本开始：
    1.8

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  MemberReferenceTree.ReferenceMode
      有两种成员引用：（i）方法引用和（ii）构造函数引用

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      MemberReferenceTree.ReferenceMode getMode​()
      返回引用的模式。
      Name getName​()
      返回引用的名称。
      ExpressionTree getQualifierExpression​()
      返回参考的限定符表达式。
      List<? extends ExpressionTree> getTypeArguments​()
      返回引用的类型参数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getMode

        MemberReferenceTree.ReferenceMode getMode​()
        返回引用的模式。
        结果
        的模式

      • getQualifierExpression

        ExpressionTree getQualifierExpression​()
        返回参考的限定符表达式。
        结果
        限定词表达

      • getName

        Name getName​()
        返回引用的名称。
        结果
        名字

      • getTypeArguments

        List<? extends ExpressionTree> getTypeArguments​()
        返回引用的类型参数。
        结果
        类型参数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemberReferenceTree.ReferenceMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Enum MemberReferenceTree.ReferenceMode

  • java.lang.Object
    • java.lang.Enum<MemberReferenceTree.ReferenceMode>
      • com.sun.source.tree.MemberReferenceTree.ReferenceMode
  • All Implemented Interfaces:
    Serializable ， Comparable<MemberReferenceTree.ReferenceMode>
    Enclosing interface:
    MemberReferenceTree

    public static enum MemberReferenceTree.ReferenceMode
extends Enum<MemberReferenceTree.ReferenceMode>
    有两种成员引用：（i）方法引用和（ii）构造函数引用

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      INVOKE
      枚举常数用于方法引用。
      NEW
      枚举常数用于构造函数引用。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static MemberReferenceTree.ReferenceMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MemberReferenceTree.ReferenceMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • INVOKE

        public static final MemberReferenceTree.ReferenceMode INVOKE
        枚举常数用于方法引用。

      • NEW

        public static final MemberReferenceTree.ReferenceMode NEW
        枚举常数用于构造函数引用。

    • 方法详细信息

      • values

        public static MemberReferenceTree.ReferenceMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MemberReferenceTree.ReferenceMode c : MemberReferenceTree.ReferenceMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MemberReferenceTree.ReferenceMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


MemberSelectTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface MemberSelectTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface MemberSelectTree
extends ExpressionTree
    成员访问表达式的树节点。 例如：
      expression . identifier
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第6.5,15.11和15.12节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回要为其选择成员的表达式。
      Name getIdentifier​()
      返回要选择的成员的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回要为其选择成员的表达式。
        结果
        表达方式。

      • getIdentifier

        Name getIdentifier​()
        返回要选择的成员的名称。
        结果
        会员
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodInvocationTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface MethodInvocationTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface MethodInvocationTree
extends ExpressionTree
    方法调用表达式的树节点。 例如：
      identifier ( arguments )

   this . typeArguments identifier ( arguments )
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.12节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends ExpressionTree> getArguments​()
      返回方法调用的参数。
      ExpressionTree getMethodSelect​()
      返回标识要调用的方法的表达式。
      List<? extends 树> getTypeArguments​()
      返回此方法调用的类型参数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getTypeArguments

        List<? extends 树> getTypeArguments​()
        返回此方法调用的类型参数。
        结果
        类型参数

      • getMethodSelect

        ExpressionTree getMethodSelect​()
        返回标识要调用的方法的表达式。
        结果
        方法选择表达式

      • getArguments

        List<? extends ExpressionTree> getArguments​()
        返回方法调用的参数。
        结果
        the arguments
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface MethodTree

  • All Superinterfaces:
    树

    public interface MethodTree
extends 树
    用于方法或注释类型元素声明的树节点。 例如：
      modifiers typeParameters type name
      ( parameters )
      body

   modifiers type name () default defaultValue
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第8.4,8.6,8.7,9.4和9.6段

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BlockTree getBody​()
      返回方法体，如果这是抽象或本机方法，则返回 null 。
      树 getDefaultValue​()
      返回默认值，如果这是注释类型声明中的元素。
      ModifiersTree getModifiers​()
      返回修饰符，包括声明方法的任何注释。
      Name getName​()
      返回正在声明的方法的名称。
      List<? extends VariableTree> getParameters​()
      返回正在声明的方法的参数。
      VariableTree getReceiverParameter​()
      返回一个显式的接收器参数（“this”参数），如果没有，则 null 。
      树 getReturnType​()
      返回正在声明的方法的返回类型。
      List<? extends ExpressionTree> getThrows​()
      返回此方法抛出的异常。
      List<? extends TypeParameterTree> getTypeParameters​()
      返回正在声明的方法的类型参数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getModifiers

        ModifiersTree getModifiers​()
        返回修饰符，包括声明方法的任何注释。
        结果
        修饰符

      • getName

        Name getName​()
        返回正在声明的方法的名称。
        结果
        名字

      • getReturnType

        树 getReturnType​()
        返回正在声明的方法的返回类型。 为构造函数返回null 。
        结果
        返回类型

      • getTypeParameters

        List<? extends TypeParameterTree> getTypeParameters​()
        返回正在声明的方法的类型参数。
        结果
        类型参数

      • getParameters

        List<? extends VariableTree> getParameters​()
        返回正在声明的方法的参数。
        结果
        参数

      • getReceiverParameter

        VariableTree getReceiverParameter​()
        返回一个显式的接收器参数（“this”参数），如果没有，则 null 。
        结果
        显式接收器参数（“this”参数）
        从以下版本开始：
        1.8

      • getThrows

        List<? extends ExpressionTree> getThrows​()
        返回此方法抛出的异常。
        结果
        例外

      • getBody

        BlockTree getBody​()
        返回方法体，如果这是抽象或本机方法，则返回 null 。
        结果
        方法体

      • getDefaultValue

        树 getDefaultValue​()
        返回默认值，如果这是注释类型声明中的元素。 返回null否则。
        结果
        默认值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModifiersTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ModifiersTree

  • All Superinterfaces:
    树

    public interface ModifiersTree
extends 树
    用于声明的修饰符的树节点（包括注释）。 例如：
      flags

   flags annotations
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第8.1.1,8.3.1,8.4.3,8.5.1,8.3.3,9.1.1和9.7段

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> getAnnotations​()
      返回此修饰符树中的注释。
      Set<Modifier> getFlags​()
      返回此修饰符树中的标志。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getFlags

        Set<Modifier> getFlags​()
        返回此修饰符树中的标志。
        结果
        旗帜

      • getAnnotations

        List<? extends AnnotationTree> getAnnotations​()
        返回此修饰符树中的注释。
        结果
        注释
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ModuleTree

  • All Superinterfaces:
    树

    public interface ModuleTree
extends 树
    模块声明的树节点。 例如：
      annotations
    [open] module module-name {
        directives
    }
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  ModuleTree.ModuleKind
      模块的种类。

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> getAnnotations​()
      返回与此模块声明关联的注释。
      List<? extends DirectiveTree> getDirectives​()
      返回模块声明中的指令。
      ModuleTree.ModuleKind getModuleType​()
      返回此模块的类型。
      ExpressionTree getName​()
      返回模块的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getAnnotations

        List<? extends AnnotationTree> getAnnotations​()
        返回与此模块声明关联的注释。
        结果
        注释

      • getModuleType

        ModuleTree.ModuleKind getModuleType​()
        返回此模块的类型。
        结果
        该模块的类型

      • getName

        ExpressionTree getName​()
        返回模块的名称。
        结果
        模块的名称

      • getDirectives

        List<? extends DirectiveTree> getDirectives​()
        返回模块声明中的指令。
        结果
        模块声明中的指令
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleTree.ModuleKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Enum ModuleTree.ModuleKind

  • java.lang.Object
    • java.lang.Enum<ModuleTree.ModuleKind>
      • com.sun.source.tree.ModuleTree.ModuleKind
  • All Implemented Interfaces:
    Serializable ， Comparable<ModuleTree.ModuleKind>
    Enclosing interface:
    ModuleTree

    public static enum ModuleTree.ModuleKind
extends Enum<ModuleTree.ModuleKind>
    模块的种类。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      OPEN
      开模块
      STRONG
      强大的模块

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ModuleTree.ModuleKind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleTree.ModuleKind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • OPEN

        public static final ModuleTree.ModuleKind OPEN
        开模块

      • STRONG

        public static final ModuleTree.ModuleKind STRONG
        强大的模块

    • 方法详细信息

      • values

        public static ModuleTree.ModuleKind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ModuleTree.ModuleKind c : ModuleTree.ModuleKind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ModuleTree.ModuleKind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


NewArrayTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface NewArrayTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface NewArrayTree
extends ExpressionTree
    用于创建数组的新实例的表达式的树节点。 例如：
      new type dimensions initializers

   new type dimensions [ ] initializers
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.10节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> getAnnotations​()
      返回基本类型的注释。
      List<? extends List<? extends AnnotationTree>> getDimAnnotations​()
      返回每个维度表达式上的注释。
      List<? extends ExpressionTree> getDimensions​()
      返回类型的维度表达式。
      List<? extends ExpressionTree> getInitializers​()
      返回初始化器表达式。
      树 getType​()
      返回表达式的基本类型。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getType

        树 getType​()
        返回表达式的基本类型。 阵列初始化器表达式可能为null 。
        结果
        基础类型

      • getDimensions

        List<? extends ExpressionTree> getDimensions​()
        返回类型的维度表达式。
        结果
        维度表达式

      • getInitializers

        List<? extends ExpressionTree> getInitializers​()
        返回初始化器表达式。
        结果
        初始化器表达式

      • getAnnotations

        List<? extends AnnotationTree> getAnnotations​()
        返回基本类型的注释。
        结果
        注释

      • getDimAnnotations

        List<? extends List<? extends AnnotationTree>> getDimAnnotations​()
        返回每个维度表达式上的注释。
        结果
        the annotations on the dimensions expressions
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NewClassTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface NewClassTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface NewClassTree
extends ExpressionTree
    一个树节点来声明一个类的新实例。 例如：
      new identifier ( )

   new identifier ( arguments )

   new typeArguments identifier ( arguments )
       classBody

   enclosingExpression.new identifier ( arguments )
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.9节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends ExpressionTree> getArguments​()
      返回要调用的构造函数的参数。
      ClassTree getClassBody​()
      如果正在实例化一个匿名类，返回类体，否则返回 null 。
      ExpressionTree getEnclosingExpression​()
      返回包含的表达式，如果没有，则返回 null 。
      ExpressionTree getIdentifier​()
      返回要实例化的类的名称。
      List<? extends 树> getTypeArguments​()
      返回正在创建的对象的类型参数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getEnclosingExpression

        ExpressionTree getEnclosingExpression​()
        返回包含的表达式，如果没有，则返回 null 。
        结果
        封闭的表达式

      • getTypeArguments

        List<? extends 树> getTypeArguments​()
        返回正在创建的对象的类型参数。
        结果
        类型参数

      • getIdentifier

        ExpressionTree getIdentifier​()
        返回要实例化的类的名称。
        结果
        名字

      • getArguments

        List<? extends ExpressionTree> getArguments​()
        返回要调用的构造函数的参数。
        结果
        论点

      • getClassBody

        ClassTree getClassBody​()
        如果正在实例化一个匿名类，返回类体，否则返回 null 。
        结果
        the class body
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OpensTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface OpensTree

  • All Superinterfaces:
    DirectiveTree ， 树

    public interface OpensTree
extends DirectiveTree
    模块声明中的“打开”指令的树节点。 例如：
      opens   package-name;
    opens   package-name to module-name;
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends ExpressionTree> getModuleNames​()
      返回包打开的模块的名称，如果打包到所有模块，则返回null。
      ExpressionTree getPackageName​()
      返回要打开的包的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getPackageName

        ExpressionTree getPackageName​()
        返回要打开的包的名称。
        结果
        要打开的包的名称

      • getModuleNames

        List<? extends ExpressionTree> getModuleNames​()
        返回包打开的模块的名称，如果打包到所有模块，则返回null。
        结果
        包打开的模块的名称，或空值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PackageTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface PackageTree

  • All Superinterfaces:
    树

    public interface PackageTree
extends 树
    表示包声明。
    从以下版本开始：
    9
    See The Java™ Language Specification:
    7.3和7.4节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> getAnnotations​()
      返回与此包声明关联的注释。
      ExpressionTree getPackageName​()
      返回正在声明的包的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getAnnotations

        List<? extends AnnotationTree> getAnnotations​()
        返回与此包声明关联的注释。
        结果
        注释

      • getPackageName

        ExpressionTree getPackageName​()
        返回正在声明的包的名称。
        结果
        名字
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ParameterizedTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ParameterizedTypeTree

  • All Superinterfaces:
    树

    public interface ParameterizedTypeTree
extends 树
    涉及类型参数的类型表达式的树节点。 例如：
      type < typeArguments >
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第4.5.1节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      树 getType​()
      返回基本类型。
      List<? extends 树> getTypeArguments​()
      返回类型参数。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getType

        树 getType​()
        返回基本类型。
        结果
        基础类型

      • getTypeArguments

        List<? extends 树> getTypeArguments​()
        返回类型参数。
        结果
        类型参数
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ParenthesizedTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ParenthesizedTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface ParenthesizedTree
extends ExpressionTree
    括号表达式的树节点。 注意：解析器不保留括号。 例如：
      ( expression )
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.8.5节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回括号内的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回括号内的表达式。
        结果
        the expression
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrimitiveTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface PrimitiveTypeTree

  • All Superinterfaces:
    树

    public interface PrimitiveTypeTree
extends 树
    一个原始类型的树节点。 例如：
      primitiveTypeKind
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第4.2节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      TypeKind getPrimitiveTypeKind​()
      返回此类型的原始类型。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getPrimitiveTypeKind

        TypeKind getPrimitiveTypeKind​()
        返回此类型的原始类型。
        结果
        the kind of the type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProvidesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ProvidesTree

  • All Superinterfaces:
    DirectiveTree ， 树

    public interface ProvidesTree
extends DirectiveTree
    模块声明中“提供”指令的树节点。 例如：
      provides service-name with implementation-name;
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends ExpressionTree> getImplementationNames​()
      返回正在提供的实现类型的名称。
      ExpressionTree getServiceName​()
      返回正在提供的服务类型的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getServiceName

        ExpressionTree getServiceName​()
        返回正在提供的服务类型的名称。
        结果
        提供的服务类型的名称

      • getImplementationNames

        List<? extends ExpressionTree> getImplementationNames​()
        返回正在提供的实现类型的名称。
        结果
        提供的实现类型的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RequiresTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface RequiresTree

  • All Superinterfaces:
    DirectiveTree ， 树

    public interface RequiresTree
extends DirectiveTree
    模块声明中“require”指令的树结点。 例如：
      requires module-name;
    requires static module-name;
    requires transitive module-name;
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getModuleName​()
      返回所需模块的名称。
      boolean isStatic​()
      如果这是一个“require static”指令，则返回true。
      boolean isTransitive​()
      如果这是一个“需要传递”的指令，则返回true。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • isStatic

        boolean isStatic​()
        如果这是一个“require static”指令，则返回true。
        结果
        如果这是一个“需要静态”指令，则为true

      • isTransitive

        boolean isTransitive​()
        如果这是一个“需要传递”的指令，则返回true。
        结果
        如果这是一个“需要传递性”指令，则为真

      • getModuleName

        ExpressionTree getModuleName​()
        返回所需模块的名称。
        结果
        所需模块的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReturnTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ReturnTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface ReturnTree
extends StatementTree
    一个用于return语句的树节点。 例如：
      return;
   return expression;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.17条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回要返回的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回要返回的表达式。
        结果
        the expression
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Scope (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface Scope

  • public interface Scope
    用于确定本地可用的程序元素的接口，如局部变量和导入。 创建时，范围与给定的程序位置相关联; 例如，一个tree node 。 该位置可以用于推断包围方法和/或类。

    范围本身不包含与包含其位置的方法和类的参数，方法和字段相对应的元素的细节。 然而，这些元件可以从封闭元件确定。

    范围可能包含在封闭的范围内。 最外层的范围包含通过“星形导入”声明可用的元素; 其范围包含编译单元的顶级元素，包括任何命名的导入。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      TypeElement getEnclosingClass​()
      返回包含此作用域位置的最内部类型元素。
      ExecutableElement getEnclosingMethod​()
      返回包含此范围位置的最内层可执行元素。
      Scope getEnclosingScope​()
      返回包围范围。
      Iterable<? extends Element> getLocalElements​()
      返回此范围中直接包含的元素。

    • 方法详细信息

      • getEnclosingScope

        Scope getEnclosingScope​()
        返回包围范围。
        结果
        封闭的范围

      • getEnclosingClass

        TypeElement getEnclosingClass​()
        返回包含此作用域位置的最内部类型元素。
        结果
        最内围的包围类型元素

      • getEnclosingMethod

        ExecutableElement getEnclosingMethod​()
        返回包含此范围位置的最内层可执行元素。
        结果
        最内围的方法声明

      • getLocalElements

        Iterable<? extends Element> getLocalElements​()
        返回此范围中直接包含的元素。
        结果
        该范围中包含的元素
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface StatementTree

  • All Superinterfaces:
    树
    All Known Subinterfaces:
    AssertTree ， BlockTree ， BreakTree ， ClassTree ， ContinueTree ， DoWhileLoopTree ， EmptyStatementTree ， EnhancedForLoopTree ， ExpressionStatementTree ， ForLoopTree ， IfTree ， LabeledStatementTree ， ReturnTree ， SwitchTree ， SynchronizedTree ， ThrowTree ， TryTree ， VariableTree ， WhileLoopTree

    public interface StatementTree
extends 树
    用作不同类型语句的基类的树节点。
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14章

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SwitchTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface SwitchTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface SwitchTree
extends StatementTree
    一个树结点的一个switch语句。 例如：
      switch ( expression ) {
     cases
   }
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.11条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends CaseTree> getCases​()
      返回 switch语句的情况。
      ExpressionTree getExpression​()
      返回 switch语句的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回 switch语句的表达式。
        结果
        表达方式

      • getCases

        List<? extends CaseTree> getCases​()
        返回 switch语句的 switch 。
        结果
        案件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SynchronizedTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface SynchronizedTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface SynchronizedTree
extends StatementTree
    一个用于synchronized语句的树节点。 例如：
      synchronized ( expression )
       block
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.19条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BlockTree getBlock​()
      返回 synchronized语句的块。
      ExpressionTree getExpression​()
      返回要同步的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回要同步的表达式。
        结果
        表达方式

      • getBlock

        BlockTree getBlock​()
        返回 synchronized语句的块。
        结果
        块
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThrowTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface ThrowTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface ThrowTree
extends StatementTree
    一个用于throw语句的树节点。 例如：
      throw expression;
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.18条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回要抛出的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回要抛出的表达式。
        结果
        the expression
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Tree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface Tree

  • All Known Subinterfaces:
    AnnotatedTypeTree ， AnnotationTree ， ArrayAccessTree ， ArrayTypeTree ， AssertTree ， AssignmentTree ， BinaryTree ， BlockTree ， BreakTree ， CaseTree ， CatchTree ， ClassTree ， CompilationUnitTree ， CompoundAssignmentTree ， ConditionalExpressionTree ， ContinueTree ， DirectiveTree ， DoWhileLoopTree ， EmptyStatementTree ， EnhancedForLoopTree ， ErroneousTree ， ExportsTree ， ExpressionStatementTree ， ExpressionTree ， ForLoopTree ， IdentifierTree ， IfTree ， ImportTree ， InstanceOfTree ， IntersectionTypeTree ， LabeledStatementTree ， LambdaExpressionTree ， LiteralTree ， MemberReferenceTree ， MemberSelectTree ， MethodInvocationTree ， MethodTree ， ModifiersTree ， ModuleTree ， NewArrayTree ， NewClassTree ， OpensTree ， PackageTree ， ParameterizedTypeTree ， ParenthesizedTree ， PrimitiveTypeTree ， ProvidesTree ， RequiresTree ， ReturnTree ， StatementTree ， SwitchTree ， SynchronizedTree ， ThrowTree ， TryTree ， TypeCastTree ， TypeParameterTree TypeParameterTree ， UnaryTree ， UnionTypeTree ， UsesTree ， VariableTree ， WhileLoopTree ， WildcardTree

    public interface 树
    抽象语法树中所有节点的公共接口。

    警告：随着Java编程语言的发展，此接口及其子接口可能会发生更改。 这些接口由JDK Java编译器（javac）实现，不应由其他应用程序直接或间接实现。

    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  Tree.Kind
      列举各种树木。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      <R,D> R accept​(TreeVisitor<R,D> visitor, D data)
      用于实现访问者模式的接受方法。
      Tree.Kind getKind​()
      返回此树的种类。

    • 方法详细信息

      • getKind

        Tree.Kind getKind​()
        返回此树的种类。
        结果
        这种树的种类。

      • accept

        <R,D> R accept​(TreeVisitor<R,D> visitor,
               D data)
        用于实现访问者模式的接受方法。 访问者模式用于对树进行操作。
        参数类型
        R - 此操作的结果类型。
        D - 附加数据类型。
        参数
        visitor - 被叫的访客
        data - 要传递给访问者的值
        结果
        调用访问者返回结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Tree.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Enum Tree.Kind

  • java.lang.Object
    • java.lang.Enum<Tree.Kind>
      • com.sun.source.tree.Tree.Kind
  • All Implemented Interfaces:
    Serializable ， Comparable<Tree.Kind>
    Enclosing interface:
    树

    public static enum Tree.Kind
extends Enum<Tree.Kind>
    列举各种树木。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      AND
      用于实例BinaryTree代表按位和逻辑“和” & 。
      AND_ASSIGNMENT
      用于实例CompoundAssignmentTree代表按位和逻辑“和”分配&= 。
      ANNOTATED_TYPE
      用于表示注释类型的AnnotatedTypeTree的实例。
      ANNOTATION
      用于表示声明注释的AnnotationTree的实例。
      ANNOTATION_TYPE
      用于表示注释类型的ClassTree的实例。
      ARRAY_ACCESS
      用于ArrayAccessTree的实例。
      ARRAY_TYPE
      用于ArrayTypeTree的实例。
      ASSERT
      用于AssertTree的实例。
      ASSIGNMENT
      用于AssignmentTree的实例。
      BITWISE_COMPLEMENT
      用于实例UnaryTree代表按位补运算符~ 。
      BLOCK
      用于BlockTree的实例。
      BOOLEAN_LITERAL
      用于表示boolean类型的布尔文字表达式的boolean 。
      BREAK
      用于BreakTree的实例。
      CASE
      用于CaseTree的实例。
      CATCH
      用于CatchTree的实例。
      CHAR_LITERAL
      用于实例LiteralTree表示类型的字符文字表达char 。
      CLASS
      用于表示类的ClassTree的实例。
      COMPILATION_UNIT
      用于CompilationUnitTree的实例。
      CONDITIONAL_AND
      用于实例BinaryTree代表条件和&& 。
      CONDITIONAL_EXPRESSION
      用于ConditionalExpressionTree的实例。
      CONDITIONAL_OR
      用于实例BinaryTree表示有条件或|| 。
      CONTINUE
      用于ContinueTree的实例。
      DIVIDE
      用于表示/的BinaryTree的实例。
      DIVIDE_ASSIGNMENT
      用于代表划分/=的CompoundAssignmentTree的实例。
      DO_WHILE_LOOP
      用于DoWhileLoopTree的实例。
      DOUBLE_LITERAL
      用于表示double类型的浮点文字表达式的double 。
      EMPTY_STATEMENT
      用于EmptyStatementTree的实例。
      ENHANCED_FOR_LOOP
      用于EnhancedForLoopTree的实例。
      ENUM
      用于表示枚举的ClassTree的实例。
      EQUAL_TO
      用于实例BinaryTree代表等于至== 。
      ERRONEOUS
      用于ErroneousTree的实例。
      EXPORTS
      用于表示模块声明中的导出指令的ExportsTree的实例。
      EXPRESSION_STATEMENT
      用于ExpressionStatementTree的实例。
      EXTENDS_WILDCARD
      用于表示扩展有界通配符类型参数的WildcardTree的实例。
      FLOAT_LITERAL
      用于表示float类型的浮点数字表达式的float 。
      FOR_LOOP
      用于ForLoopTree的实例。
      GREATER_THAN
      用于实例BinaryTree代表大于> 。
      GREATER_THAN_EQUAL
      用于实例BinaryTree代表大于平等>= 。
      IDENTIFIER
      用于IdentifierTree的实例。
      IF
      用于IfTree的实例。
      IMPORT
      用于ImportTree的实例。
      INSTANCE_OF
      用于InstanceOfTree的实例。
      INT_LITERAL
      用于表示int类型的整数文字表达式的int 。
      INTERFACE
      用于表示接口的ClassTree的实例。
      INTERSECTION_TYPE
      用于IntersectionTypeTree的实例。
      LABELED_STATEMENT
      用于LabeledStatementTree的实例。
      LAMBDA_EXPRESSION
      用于LambdaExpressionTree的实例。
      LEFT_SHIFT
      用于实例BinaryTree代表左移<< 。
      LEFT_SHIFT_ASSIGNMENT
      用于实例CompoundAssignmentTree代表左移分配<<= 。
      LESS_THAN
      用于实例BinaryTree代表小于号< 。
      LESS_THAN_EQUAL
      用于BinaryTree代表小于等于<= 。
      LOGICAL_COMPLEMENT
      用于实例UnaryTree代表逻辑补运算符! 。
      LONG_LITERAL
      用于表示long类型的整数文字表达式的long 。
      MEMBER_REFERENCE
      用于MemberReferenceTree的实例。
      MEMBER_SELECT
      用于MemberSelectTree的实例。
      METHOD
      用于MethodTree的实例。
      METHOD_INVOCATION
      用于MethodInvocationTree的实例。
      MINUS
      用于表示减法-的BinaryTree的实例。
      MINUS_ASSIGNMENT
      用于表示减法分配-=的CompoundAssignmentTree的实例。
      MODIFIERS
      用于ModifiersTree的实例。
      MODULE
      用于表示模块声明的ModuleTree的实例。
      MULTIPLY
      用于BinaryTree代表乘法*实例。
      MULTIPLY_ASSIGNMENT
      用于表示乘法赋值*=的CompoundAssignmentTree的实例。
      NEW_ARRAY
      用于NewArrayTree的实例。
      NEW_CLASS
      用于NewClassTree的实例。
      NOT_EQUAL_TO
      用于实例BinaryTree代表不等于对!= 。
      NULL_LITERAL
      用于实例LiteralTree代表使用的null 。
      OPENS
      用于表示模块声明中打开指令的ExportsTree的实例。
      OR
      用于实例BinaryTree代表按位和逻辑“或” | 。
      OR_ASSIGNMENT
      用于实例CompoundAssignmentTree代表按位和逻辑“或”分配|= 。
      OTHER
      实现保留节点。
      PACKAGE
      用于PackageTree的实例。
      PARAMETERIZED_TYPE
      用于ParameterizedTypeTree的实例。
      PARENTHESIZED
      用于ParenthesizedTree的实例。
      PLUS
      用于表示BinaryTree表示加法或字符串连接+ 。
      PLUS_ASSIGNMENT
      用于实例CompoundAssignmentTree代表加法或字符串连接分配+= 。
      POSTFIX_DECREMENT
      用于实例UnaryTree代表后缀减量操作-- 。
      POSTFIX_INCREMENT
      用于实例UnaryTree代表后缀增量运算++ 。
      PREFIX_DECREMENT
      用于实例UnaryTree代表前缀减量操作-- 。
      PREFIX_INCREMENT
      用于实例UnaryTree代表前缀增量运算++ 。
      PRIMITIVE_TYPE
      用于PrimitiveTypeTree的实例。
      PROVIDES
      用于表示在模块声明中提供指令的ProvidesTree的实例。
      REMAINDER
      用于代表%的BinaryTree的实例。
      REMAINDER_ASSIGNMENT
      用于表示剩余分配%=的CompoundAssignmentTree的实例。
      REQUIRES
      用于表示需要在模块声明中指令的RequiresTree的实例。
      RETURN
      用于ReturnTree的实例。
      RIGHT_SHIFT
      用于实例BinaryTree表示右移>> 。
      RIGHT_SHIFT_ASSIGNMENT
      用于实例CompoundAssignmentTree表示右移分配>>= 。
      STRING_LITERAL
      用于实例LiteralTree表示类型的字符串文字表达String 。
      SUPER_WILDCARD
      用于表示超级有界通配符类型参数的WildcardTree的实例。
      SWITCH
      用于SwitchTree的实例。
      SYNCHRONIZED
      用于SynchronizedTree的实例。
      THROW
      用于ThrowTree的实例。
      TRY
      用于TryTree的实例。
      TYPE_ANNOTATION
      用于表示类型注释的AnnotationTree的实例。
      TYPE_CAST
      用于TypeCastTree的实例。
      TYPE_PARAMETER
      用于TypeParameterTree的实例。
      UNARY_MINUS
      用于实例UnaryTree代表元减运算符- 。
      UNARY_PLUS
      用于实例UnaryTree代表一元加号+ 。
      UNBOUNDED_WILDCARD
      用于表示无界通配符类型参数的WildcardTree的实例。
      UNION_TYPE
      用于UnionTypeTree的实例。
      UNSIGNED_RIGHT_SHIFT
      用于实例BinaryTree表示无符号右移>>> 。
      UNSIGNED_RIGHT_SHIFT_ASSIGNMENT
      用于实例CompoundAssignmentTree表示无符号右移分配>>>= 。
      USES
      用于表示在模块声明中使用指令的UsesTree的实例。
      VARIABLE
      用于VariableTree的实例。
      WHILE_LOOP
      用于WhileLoopTree的实例。
      XOR
      用于实例BinaryTree代表按位和逻辑“异或” ^ 。
      XOR_ASSIGNMENT
      用于实例CompoundAssignmentTree代表按位和逻辑“异或”分配^= 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<? extends 树> asInterface​()
      返回使用这种类型的关联接口类型。
      static Tree.Kind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Tree.Kind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ANNOTATED_TYPE

        public static final Tree.Kind ANNOTATED_TYPE
        用于表示注释类型的AnnotatedTypeTree的实例。

      • ANNOTATION

        public static final Tree.Kind ANNOTATION
        用于表示声明注释的AnnotationTree的实例。

      • TYPE_ANNOTATION

        public static final Tree.Kind TYPE_ANNOTATION
        用于表示类型注释的AnnotationTree的实例。

      • ARRAY_ACCESS

        public static final Tree.Kind ARRAY_ACCESS
        用于ArrayAccessTree的实例。

      • ARRAY_TYPE

        public static final Tree.Kind ARRAY_TYPE
        用于ArrayTypeTree的实例。

      • ASSERT

        public static final Tree.Kind ASSERT
        用于AssertTree的实例。

      • ASSIGNMENT

        public static final Tree.Kind ASSIGNMENT
        用于AssignmentTree的实例。

      • BLOCK

        public static final Tree.Kind BLOCK
        用于BlockTree的实例。

      • BREAK

        public static final Tree.Kind BREAK
        用于BreakTree的实例。

      • CASE

        public static final Tree.Kind CASE
        用于CaseTree的实例。

      • CATCH

        public static final Tree.Kind CATCH
        用于CatchTree的实例。

      • CLASS

        public static final Tree.Kind CLASS
        用于表示类的ClassTree的实例。

      • COMPILATION_UNIT

        public static final Tree.Kind COMPILATION_UNIT
        用于CompilationUnitTree的实例。

      • CONDITIONAL_EXPRESSION

        public static final Tree.Kind CONDITIONAL_EXPRESSION
        用于ConditionalExpressionTree的实例。

      • CONTINUE

        public static final Tree.Kind CONTINUE
        用于ContinueTree的实例。

      • DO_WHILE_LOOP

        public static final Tree.Kind DO_WHILE_LOOP
        用于DoWhileLoopTree的实例。

      • ENHANCED_FOR_LOOP

        public static final Tree.Kind ENHANCED_FOR_LOOP
        用于EnhancedForLoopTree的实例。

      • EXPRESSION_STATEMENT

        public static final Tree.Kind EXPRESSION_STATEMENT
        用于ExpressionStatementTree的实例。

      • MEMBER_SELECT

        public static final Tree.Kind MEMBER_SELECT
        用于MemberSelectTree的实例。

      • MEMBER_REFERENCE

        public static final Tree.Kind MEMBER_REFERENCE
        用于MemberReferenceTree的实例。

      • FOR_LOOP

        public static final Tree.Kind FOR_LOOP
        用于ForLoopTree的实例。

      • IDENTIFIER

        public static final Tree.Kind IDENTIFIER
        用于IdentifierTree的实例。

      • IF

        public static final Tree.Kind IF
        用于IfTree的实例。

      • IMPORT

        public static final Tree.Kind IMPORT
        用于ImportTree的实例。

      • INSTANCE_OF

        public static final Tree.Kind INSTANCE_OF
        用于InstanceOfTree的实例。

      • LABELED_STATEMENT

        public static final Tree.Kind LABELED_STATEMENT
        用于LabeledStatementTree的实例。

      • METHOD

        public static final Tree.Kind METHOD
        用于MethodTree的实例。

      • METHOD_INVOCATION

        public static final Tree.Kind METHOD_INVOCATION
        用于MethodInvocationTree的实例。

      • MODIFIERS

        public static final Tree.Kind MODIFIERS
        用于ModifiersTree的实例。

      • NEW_ARRAY

        public static final Tree.Kind NEW_ARRAY
        用于NewArrayTree的实例。

      • NEW_CLASS

        public static final Tree.Kind NEW_CLASS
        用于NewClassTree的实例。

      • LAMBDA_EXPRESSION

        public static final Tree.Kind LAMBDA_EXPRESSION
        用于LambdaExpressionTree的实例。

      • PACKAGE

        public static final Tree.Kind PACKAGE
        用于PackageTree的实例。
        从以下版本开始：
        9

      • PARENTHESIZED

        public static final Tree.Kind PARENTHESIZED
        用于ParenthesizedTree的实例。

      • PRIMITIVE_TYPE

        public static final Tree.Kind PRIMITIVE_TYPE
        用于PrimitiveTypeTree的实例。

      • RETURN

        public static final Tree.Kind RETURN
        用于ReturnTree的实例。

      • EMPTY_STATEMENT

        public static final Tree.Kind EMPTY_STATEMENT
        用于EmptyStatementTree的实例。

      • SWITCH

        public static final Tree.Kind SWITCH
        用于SwitchTree的实例。

      • SYNCHRONIZED

        public static final Tree.Kind SYNCHRONIZED
        用于SynchronizedTree的实例。

      • THROW

        public static final Tree.Kind THROW
        用于ThrowTree的实例。

      • TRY

        public static final Tree.Kind TRY
        用于TryTree的实例。

      • PARAMETERIZED_TYPE

        public static final Tree.Kind PARAMETERIZED_TYPE
        用于ParameterizedTypeTree的实例。

      • UNION_TYPE

        public static final Tree.Kind UNION_TYPE
        用于UnionTypeTree的实例。

      • INTERSECTION_TYPE

        public static final Tree.Kind INTERSECTION_TYPE
        用于IntersectionTypeTree的实例。

      • TYPE_CAST

        public static final Tree.Kind TYPE_CAST
        用于TypeCastTree的实例。

      • TYPE_PARAMETER

        public static final Tree.Kind TYPE_PARAMETER
        用于TypeParameterTree的实例。

      • VARIABLE

        public static final Tree.Kind VARIABLE
        用于VariableTree的实例。

      • WHILE_LOOP

        public static final Tree.Kind WHILE_LOOP
        用于WhileLoopTree的实例。

      • POSTFIX_INCREMENT

        public static final Tree.Kind POSTFIX_INCREMENT
        用于实例UnaryTree代表后缀增量运算++ 。

      • POSTFIX_DECREMENT

        public static final Tree.Kind POSTFIX_DECREMENT
        用于实例UnaryTree代表后缀减量操作-- 。

      • PREFIX_INCREMENT

        public static final Tree.Kind PREFIX_INCREMENT
        用于实例UnaryTree代表前缀增量运算++ 。

      • PREFIX_DECREMENT

        public static final Tree.Kind PREFIX_DECREMENT
        用于实例UnaryTree代表前缀减量操作-- 。

      • UNARY_PLUS

        public static final Tree.Kind UNARY_PLUS
        用于实例UnaryTree代表一元加号+ 。

      • UNARY_MINUS

        public static final Tree.Kind UNARY_MINUS
        用于实例UnaryTree代表元减运算符- 。

      • BITWISE_COMPLEMENT

        public static final Tree.Kind BITWISE_COMPLEMENT
        用于实例UnaryTree代表按位补运算符~ 。

      • LOGICAL_COMPLEMENT

        public static final Tree.Kind LOGICAL_COMPLEMENT
        用于实例UnaryTree代表逻辑补运算符! 。

      • MULTIPLY

        public static final Tree.Kind MULTIPLY
        用于表示乘法*的BinaryTree的实例。

      • DIVIDE

        public static final Tree.Kind DIVIDE
        用于实例BinaryTree代表师/ 。

      • REMAINDER

        public static final Tree.Kind REMAINDER
        用于代表%的BinaryTree的实例。

      • PLUS

        public static final Tree.Kind PLUS
        用于表示BinaryTree表示加法或字符串连接的+ 。

      • MINUS

        public static final Tree.Kind MINUS
        用于表示减法-的BinaryTree的实例。

      • LEFT_SHIFT

        public static final Tree.Kind LEFT_SHIFT
        用于实例BinaryTree代表左移<< 。

      • RIGHT_SHIFT

        public static final Tree.Kind RIGHT_SHIFT
        用于实例BinaryTree表示右移>> 。

      • UNSIGNED_RIGHT_SHIFT

        public static final Tree.Kind UNSIGNED_RIGHT_SHIFT
        用于实例BinaryTree表示无符号右移>>> 。

      • LESS_THAN

        public static final Tree.Kind LESS_THAN
        用于实例BinaryTree代表小于号< 。

      • GREATER_THAN

        public static final Tree.Kind GREATER_THAN
        用于实例BinaryTree代表大于> 。

      • LESS_THAN_EQUAL

        public static final Tree.Kind LESS_THAN_EQUAL
        用于实例BinaryTree较低于等于<= 。

      • GREATER_THAN_EQUAL

        public static final Tree.Kind GREATER_THAN_EQUAL
        用于实例BinaryTree代表大于平等>= 。

      • EQUAL_TO

        public static final Tree.Kind EQUAL_TO
        用于实例BinaryTree代表等于至== 。

      • NOT_EQUAL_TO

        public static final Tree.Kind NOT_EQUAL_TO
        用于实例BinaryTree代表不等于对!= 。

      • AND

        public static final Tree.Kind AND
        用于BinaryTree表示按位和逻辑“ & ”的& 。

      • XOR

        public static final Tree.Kind XOR
        用于实例BinaryTree代表按位和逻辑“异或” ^ 。

      • OR

        public static final Tree.Kind OR
        用于实例BinaryTree代表按位和逻辑“或” | 。

      • CONDITIONAL_AND

        public static final Tree.Kind CONDITIONAL_AND
        用于实例BinaryTree代表条件和&& 。

      • CONDITIONAL_OR

        public static final Tree.Kind CONDITIONAL_OR
        用于实例BinaryTree表示有条件或|| 。

      • MULTIPLY_ASSIGNMENT

        public static final Tree.Kind MULTIPLY_ASSIGNMENT
        用于表示乘法赋值*=的CompoundAssignmentTree的实例。

      • DIVIDE_ASSIGNMENT

        public static final Tree.Kind DIVIDE_ASSIGNMENT
        用于代表划分/=的CompoundAssignmentTree的实例。

      • REMAINDER_ASSIGNMENT

        public static final Tree.Kind REMAINDER_ASSIGNMENT
        用于表示剩余分配%=的CompoundAssignmentTree的实例。

      • PLUS_ASSIGNMENT

        public static final Tree.Kind PLUS_ASSIGNMENT
        用于实例CompoundAssignmentTree代表加法或字符串连接分配+= 。

      • MINUS_ASSIGNMENT

        public static final Tree.Kind MINUS_ASSIGNMENT
        用于表示减法分配-=的CompoundAssignmentTree的实例。

      • LEFT_SHIFT_ASSIGNMENT

        public static final Tree.Kind LEFT_SHIFT_ASSIGNMENT
        用于实例CompoundAssignmentTree代表左移分配<<= 。

      • RIGHT_SHIFT_ASSIGNMENT

        public static final Tree.Kind RIGHT_SHIFT_ASSIGNMENT
        用于实例CompoundAssignmentTree表示右移分配>>= 。

      • UNSIGNED_RIGHT_SHIFT_ASSIGNMENT

        public static final Tree.Kind UNSIGNED_RIGHT_SHIFT_ASSIGNMENT
        用于实例CompoundAssignmentTree表示无符号右移分配>>>= 。

      • AND_ASSIGNMENT

        public static final Tree.Kind AND_ASSIGNMENT
        用于实例CompoundAssignmentTree代表按位和逻辑“和”分配&= 。

      • XOR_ASSIGNMENT

        public static final Tree.Kind XOR_ASSIGNMENT
        用于实例CompoundAssignmentTree代表按位和逻辑“异或”分配^= 。

      • OR_ASSIGNMENT

        public static final Tree.Kind OR_ASSIGNMENT
        用于实例CompoundAssignmentTree代表按位和逻辑“或”分配|= 。

      • INT_LITERAL

        public static final Tree.Kind INT_LITERAL
        用于表示int类型的整数文字表达式的int 。

      • LONG_LITERAL

        public static final Tree.Kind LONG_LITERAL
        用于表示long类型的整数文字表达式的long 。

      • FLOAT_LITERAL

        public static final Tree.Kind FLOAT_LITERAL
        用于表示float类型的浮点文字表达式的float 。

      • DOUBLE_LITERAL

        public static final Tree.Kind DOUBLE_LITERAL
        用于实例LiteralTree代表类型的浮点文字表达double 。

      • BOOLEAN_LITERAL

        public static final Tree.Kind BOOLEAN_LITERAL
        用于表示boolean类型的布尔文字表达式的boolean 。

      • CHAR_LITERAL

        public static final Tree.Kind CHAR_LITERAL
        用于表示char类型的字符文字表达式的char 。

      • STRING_LITERAL

        public static final Tree.Kind STRING_LITERAL
        用于表示String类型的字符串文字表达式的LiteralTree的实例 。

      • NULL_LITERAL

        public static final Tree.Kind NULL_LITERAL
        用于实例LiteralTree代表使用的null 。

      • UNBOUNDED_WILDCARD

        public static final Tree.Kind UNBOUNDED_WILDCARD
        用于表示无界通配符类型参数的WildcardTree的实例。

      • EXTENDS_WILDCARD

        public static final Tree.Kind EXTENDS_WILDCARD
        用于表示扩展有界通配符类型参数的WildcardTree的实例。

      • SUPER_WILDCARD

        public static final Tree.Kind SUPER_WILDCARD
        用于表示超级有界通配符类型参数的WildcardTree的实例。

      • ERRONEOUS

        public static final Tree.Kind ERRONEOUS
        用于ErroneousTree的实例。

      • INTERFACE

        public static final Tree.Kind INTERFACE
        用于表示接口的ClassTree的实例。

      • ENUM

        public static final Tree.Kind ENUM
        用于表示枚举的ClassTree的实例。

      • ANNOTATION_TYPE

        public static final Tree.Kind ANNOTATION_TYPE
        用于表示注释类型的ClassTree的实例。

      • MODULE

        public static final Tree.Kind MODULE
        用于表示模块声明的ModuleTree的实例。

      • EXPORTS

        public static final Tree.Kind EXPORTS
        用于表示模块声明中的导出指令的ExportsTree的实例。

      • OPENS

        public static final Tree.Kind OPENS
        用于表示模块声明中打开指令的ExportsTree的实例。

      • PROVIDES

        public static final Tree.Kind PROVIDES
        用于表示在模块声明中提供指令的ProvidesTree的实例。

      • REQUIRES

        public static final Tree.Kind REQUIRES
        用于表示需要在模块声明中指令的RequiresTree的实例。

      • USES

        public static final Tree.Kind USES
        用于表示在模块声明中使用指令的UsesTree的实例。

      • OTHER

        public static final Tree.Kind OTHER
        实现保留节点。 这不是您要查找的节点。

    • 方法详细信息

      • values

        public static Tree.Kind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Tree.Kind c : Tree.Kind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Tree.Kind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • asInterface

        public Class<? extends 树> asInterface​()
        返回使用这种类型的关联接口类型。
        结果
        相关界面
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


TreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface TreeVisitor<R,P>

  • 参数类型
    R - 这个访问者的方法的返回类型。 对不需要返回结果的访问者使用Void 。
    P - 此访问者方法的附加参数类型。 对不需要其他参数的访问者使用Void 。
    所有已知实现类：
    SimpleTreeVisitor ， TreePathScanner ， TreeScanner

    public interface TreeVisitor<R,P>
    树木的访客，以访客设计模式的风格。 当编译时树的种类未知时，实现此接口的类用于在树上操作。 当访问者传递给树的accept方法时，将调用最适用于该树的visitXyz方法。

    实现此界面的类可以或可以不抛出NullPointerException如果附加参数p是null ; 有关详细信息，请参阅实施类的文档。

    警告：可能的方法将添加到此界面以适应未来版本的Java编程语言中添加的新的，当前未知的语言结构。 因此，直接实现此接口的访问者类可能与未来的平台版本不兼容。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      R visitAnnotatedType​(AnnotatedTypeTree node, P p)
      访问AnnotatedTypeTree节点。
      R visitAnnotation​(AnnotationTree node, P p)
      访问AnnotatedTree节点。
      R visitArrayAccess​(ArrayAccessTree node, P p)
      访问ArrayAccessTree节点。
      R visitArrayType​(ArrayTypeTree node, P p)
      访问ArrayTypeTree节点。
      R visitAssert​(AssertTree node, P p)
      访问AssertTree节点。
      R visitAssignment​(AssignmentTree node, P p)
      访问AssignmentTree节点。
      R visitBinary​(BinaryTree node, P p)
      访问二进制流节点。
      R visitBlock​(BlockTree node, P p)
      访问BlockTree节点。
      R visitBreak​(BreakTree node, P p)
      访问BreakTree节点。
      R visitCase​(CaseTree node, P p)
      访问CaseTree节点。
      R visitCatch​(CatchTree node, P p)
      访问CatchTree节点。
      R visitClass​(ClassTree node, P p)
      访问ClassTree节点。
      R visitCompilationUnit​(CompilationUnitTree node, P p)
      访问CompilationUnitTree节点。
      R visitCompoundAssignment​(CompoundAssignmentTree node, P p)
      访问一个CompoundAssignmentTree节点。
      R visitConditionalExpression​(ConditionalExpressionTree node, P p)
      访问一个ConditionalExpressionTree节点。
      R visitContinue​(ContinueTree node, P p)
      访问ContinueTree节点。
      R visitDoWhileLoop​(DoWhileLoopTree node, P p)
      访问DoWhileTree节点。
      R visitEmptyStatement​(EmptyStatementTree node, P p)
      访问一个EmptyStatementTree节点。
      R visitEnhancedForLoop​(EnhancedForLoopTree node, P p)
      访问EnhancedForLoopTree节点。
      R visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
      R visitExports​(ExportsTree node, P p)
      访问ExportsTree节点。
      R visitExpressionStatement​(ExpressionStatementTree node, P p)
      访问ExpressionStatementTree节点。
      R visitForLoop​(ForLoopTree node, P p)
      访问ForLoopTree节点。
      R visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R visitIf​(IfTree node, P p)
      访问IfTree节点。
      R visitImport​(ImportTree node, P p)
      访问ImportTree节点。
      R visitInstanceOf​(InstanceOfTree node, P p)
      访问InstanceOfTree节点。
      R visitIntersectionType​(IntersectionTypeTree node, P p)
      访问一个IntersectionTypeTree节点。
      R visitLabeledStatement​(LabeledStatementTree node, P p)
      访问LabeledStatementTree节点。
      R visitLambdaExpression​(LambdaExpressionTree node, P p)
      访问LambdaExpressionTree节点。
      R visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R visitMemberReference​(MemberReferenceTree node, P p)
      访问MemberReferenceTree节点。
      R visitMemberSelect​(MemberSelectTree node, P p)
      访问MemberSelectTree节点。
      R visitMethod​(MethodTree node, P p)
      访问MethodTree节点。
      R visitMethodInvocation​(MethodInvocationTree node, P p)
      访问MethodInvocationTree节点。
      R visitModifiers​(ModifiersTree node, P p)
      访问修饰符Tree节点。
      R visitModule​(ModuleTree node, P p)
      访问ModuleTree节点。
      R visitNewArray​(NewArrayTree node, P p)
      访问NewArrayTree节点。
      R visitNewClass​(NewClassTree node, P p)
      访问NewClassTree节点。
      R visitOpens​(OpensTree node, P p)
      访问OpensTree节点。
      R visitOther​(树 node, P p)
      访问未知类型的树节点。
      R visitPackage​(PackageTree node, P p)
      访问PackageTree节点。
      R visitParameterizedType​(ParameterizedTypeTree node, P p)
      访问ParameterizedTypeTree节点。
      R visitParenthesized​(ParenthesizedTree node, P p)
      访问ParenthesizedTree节点。
      R visitPrimitiveType​(PrimitiveTypeTree node, P p)
      访问PrimitiveTypeTree节点。
      R visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
      R visitRequires​(RequiresTree node, P p)
      访问RequiresTree节点。
      R visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R visitSwitch​(SwitchTree node, P p)
      访问SwitchTree节点。
      R visitSynchronized​(SynchronizedTree node, P p)
      访问SynchronizedTree节点。
      R visitThrow​(ThrowTree node, P p)
      访问ThrowTree节点
      R visitTry​(TryTree node, P p)
      访问TryTree节点。
      R visitTypeCast​(TypeCastTree node, P p)
      访问TypeCastTree节点。
      R visitTypeParameter​(TypeParameterTree node, P p)
      访问TypeParameterTree节点。
      R visitUnary​(UnaryTree node, P p)
      访问UnaryTree节点。
      R visitUnionType​(UnionTypeTree node, P p)
      访问UnionTypeTree节点。
      R visitUses​(UsesTree node, P p)
      访问UsesTree节点。
      R visitVariable​(VariableTree node, P p)
      访问VariableTree节点。
      R visitWhileLoop​(WhileLoopTree node, P p)
      访问WhileLoopTree节点。
      R visitWildcard​(WildcardTree node, P p)
      访问WildcardTypeTree节点。

    • 方法详细信息

      • visitAnnotatedType

        R visitAnnotatedType​(AnnotatedTypeTree node,
                     P p)
        访问AnnotatedTypeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitAnnotation

        R visitAnnotation​(AnnotationTree node,
                  P p)
        访问AnnotatedTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitMethodInvocation

        R visitMethodInvocation​(MethodInvocationTree node,
                        P p)
        访问MethodInvocationTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitAssert

        R visitAssert​(AssertTree node,
              P p)
        访问AssertTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitAssignment

        R visitAssignment​(AssignmentTree node,
                  P p)
        访问AssignmentTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitCompoundAssignment

        R visitCompoundAssignment​(CompoundAssignmentTree node,
                          P p)
        访问一个CompoundAssignmentTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitBinary

        R visitBinary​(BinaryTree node,
              P p)
        访问二进制流节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitBlock

        R visitBlock​(BlockTree node,
             P p)
        访问BlockTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitBreak

        R visitBreak​(BreakTree node,
             P p)
        访问BreakTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitCase

        R visitCase​(CaseTree node,
            P p)
        访问CaseTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitCatch

        R visitCatch​(CatchTree node,
             P p)
        访问CatchTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitClass

        R visitClass​(ClassTree node,
             P p)
        访问ClassTree节点。
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果值

      • visitConditionalExpression

        R visitConditionalExpression​(ConditionalExpressionTree node,
                             P p)
        访问一个ConditionalExpressionTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitContinue

        R visitContinue​(ContinueTree node,
                P p)
        访问ContinueTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitDoWhileLoop

        R visitDoWhileLoop​(DoWhileLoopTree node,
                   P p)
        访问DoWhileTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitErroneous

        R visitErroneous​(ErroneousTree node,
                 P p)
        访问ErroneousTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitExpressionStatement

        R visitExpressionStatement​(ExpressionStatementTree node,
                           P p)
        访问ExpressionStatementTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitEnhancedForLoop

        R visitEnhancedForLoop​(EnhancedForLoopTree node,
                       P p)
        访问EnhancedForLoopTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitForLoop

        R visitForLoop​(ForLoopTree node,
               P p)
        访问ForLoopTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitIdentifier

        R visitIdentifier​(IdentifierTree node,
                  P p)
        访问IdentifierTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitIf

        R visitIf​(IfTree node,
          P p)
        访问IfTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitImport

        R visitImport​(ImportTree node,
              P p)
        访问ImportTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitArrayAccess

        R visitArrayAccess​(ArrayAccessTree node,
                   P p)
        访问ArrayAccessTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitLabeledStatement

        R visitLabeledStatement​(LabeledStatementTree node,
                        P p)
        访问LabeledStatementTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitLiteral

        R visitLiteral​(LiteralTree node,
               P p)
        访问LiteralTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitMethod

        R visitMethod​(MethodTree node,
              P p)
        访问MethodTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitModifiers

        R visitModifiers​(ModifiersTree node,
                 P p)
        访问修饰符Tree节点。
        参数
        node - 正在访问的节点
        p - 参数值
        结果
        结果值

      • visitNewArray

        R visitNewArray​(NewArrayTree node,
                P p)
        访问NewArrayTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitNewClass

        R visitNewClass​(NewClassTree node,
                P p)
        访问NewClassTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitLambdaExpression

        R visitLambdaExpression​(LambdaExpressionTree node,
                        P p)
        访问LambdaExpressionTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitPackage

        R visitPackage​(PackageTree node,
               P p)
        访问PackageTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitParenthesized

        R visitParenthesized​(ParenthesizedTree node,
                     P p)
        访问ParenthesizedTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitReturn

        R visitReturn​(ReturnTree node,
              P p)
        访问ReturnTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitMemberSelect

        R visitMemberSelect​(MemberSelectTree node,
                    P p)
        访问MemberSelectTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitMemberReference

        R visitMemberReference​(MemberReferenceTree node,
                       P p)
        访问MemberReferenceTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitEmptyStatement

        R visitEmptyStatement​(EmptyStatementTree node,
                      P p)
        访问一个EmptyStatementTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitSwitch

        R visitSwitch​(SwitchTree node,
              P p)
        访问SwitchTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitSynchronized

        R visitSynchronized​(SynchronizedTree node,
                    P p)
        访问SynchronizedTree节点。
        参数
        node - 正在访问的节点
        p - 参数值
        结果
        结果值

      • visitThrow

        R visitThrow​(ThrowTree node,
             P p)
        访问ThrowTree节点
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitCompilationUnit

        R visitCompilationUnit​(CompilationUnitTree node,
                       P p)
        访问CompilationUnitTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitTry

        R visitTry​(TryTree node,
           P p)
        访问TryTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitParameterizedType

        R visitParameterizedType​(ParameterizedTypeTree node,
                         P p)
        访问ParameterizedTypeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitUnionType

        R visitUnionType​(UnionTypeTree node,
                 P p)
        访问UnionTypeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitIntersectionType

        R visitIntersectionType​(IntersectionTypeTree node,
                        P p)
        访问一个IntersectionTypeTree节点。
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果值

      • visitArrayType

        R visitArrayType​(ArrayTypeTree node,
                 P p)
        访问ArrayTypeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitTypeCast

        R visitTypeCast​(TypeCastTree node,
                P p)
        访问TypeCastTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitPrimitiveType

        R visitPrimitiveType​(PrimitiveTypeTree node,
                     P p)
        访问PrimitiveTypeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitTypeParameter

        R visitTypeParameter​(TypeParameterTree node,
                     P p)
        访问TypeParameterTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitInstanceOf

        R visitInstanceOf​(InstanceOfTree node,
                  P p)
        访问InstanceOfTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitUnary

        R visitUnary​(UnaryTree node,
             P p)
        访问UnaryTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitVariable

        R visitVariable​(VariableTree node,
                P p)
        访问VariableTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitWhileLoop

        R visitWhileLoop​(WhileLoopTree node,
                 P p)
        访问WhileLoopTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitWildcard

        R visitWildcard​(WildcardTree node,
                P p)
        访问WildcardTypeTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitModule

        R visitModule​(ModuleTree node,
              P p)
        访问ModuleTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitExports

        R visitExports​(ExportsTree node,
               P p)
        访问ExportsTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitOpens

        R visitOpens​(OpensTree node,
             P p)
        访问OpensTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitProvides

        R visitProvides​(ProvidesTree node,
                P p)
        访问ProvideTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitRequires

        R visitRequires​(RequiresTree node,
                P p)
        访问RequiresTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitUses

        R visitUses​(UsesTree node,
            P p)
        访问UsesTree节点。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitOther

        R visitOther​(树 node,
             P p)
        访问未知类型的树节点。 如果语言发展并且将新类型的节点添加到树层次结构中，则可能会发生这种情况。
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TryTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface TryTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface TryTree
extends StatementTree
    一个树节点为一个try语句。 例如：
      try
       block
   catches
   finally
       finallyBlock
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.20节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BlockTree getBlock​()
      返回 try语句的块。
      List<? extends CatchTree> getCatches​()
      返回 try语句中提供的任何catch块。
      BlockTree getFinallyBlock​()
      返回 try语句中提供的finally块，如果没有则返回 null 。
      List<? extends 树> getResources​()
      返回 try语句中提供的任何资源声明。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getBlock

        BlockTree getBlock​()
        返回 try语句的块。
        结果
        块

      • getCatches

        List<? extends CatchTree> getCatches​()
        返回try语句中提供的任何catch块。 如果没有catch块，结果将是一个空列表。
        结果
        抓住块

      • getFinallyBlock

        BlockTree getFinallyBlock​()
        返回 try语句中提供的finally块，如果没有，则返回 null 。
        结果
        最后的块

      • getResources

        List<? extends 树> getResources​()
        返回try语句中提供的任何资源声明。 如果没有资源声明，结果将是一个空列表。
        结果
        资源声明
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TypeCastTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface TypeCastTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface TypeCastTree
extends ExpressionTree
    类型转换表达式的树节点。 例如：
      ( type ) expression
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.16条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回正在转换的表达式。
      树 getType​()
      返回转换的目标类型。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getType

        树 getType​()
        返回转换的目标类型。
        结果
        演员

      • getExpression

        ExpressionTree getExpression​()
        返回正在转换的表达式。
        结果
        表达方式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TypeParameterTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface TypeParameterTree

  • All Superinterfaces:
    树

    public interface TypeParameterTree
extends 树
    类型参数的树节点。 例如：
      name

   name extends bounds

   annotations name
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第4.4节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> getAnnotations​()
      返回类型参数声明的注释。
      List<? extends 树> getBounds​()
      返回type参数的边界。
      Name getName​()
      返回type参数的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getName

        Name getName​()
        返回type参数的名称。
        结果
        名字

      • getBounds

        List<? extends 树> getBounds​()
        返回type参数的边界。
        结果
        界限

      • getAnnotations

        List<? extends AnnotationTree> getAnnotations​()
        返回类型参数声明的注释。 注释需要ElementType.TYPE_PARAMETER或ElementType.TYPE_USE的目标元注释才能显示在此位置。
        结果
        类型参数声明的注释
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnaryTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface UnaryTree

  • All Superinterfaces:
    ExpressionTree ， 树

    public interface UnaryTree
extends ExpressionTree
    用于后缀和一元表达式的树节点。 使用getKind来确定运算符的种类。 例如：
      operator expression

   expression operator
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第15.14条和第15.15条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getExpression​()
      返回一元运算符的操作数的表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getExpression

        ExpressionTree getExpression​()
        返回一元运算符的操作数的表达式。
        结果
        the expression
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnionTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface UnionTypeTree

  • All Superinterfaces:
    树

    public interface UnionTypeTree
extends 树
    多重变量声明中的联合类型表达式的树节点。
    从以下版本开始：
    1.7

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<? extends 树> getTypeAlternatives​()
      返回替代类型表达式。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getTypeAlternatives

        List<? extends 树> getTypeAlternatives​()
        返回替代类型表达式。
        结果
        替代类型表达式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.source.tree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.source.tree

  • Packages that use com.sun.source.tree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
  • Classes in com.sun.source.tree used by com.sun.source.tree
    Class 描述
    AnnotatedTypeTree
    用于注释类型的树节点。
    AnnotationTree
    用于注释的树节点。
    ArrayAccessTree
    数组访问表达式的树节点。
    ArrayTypeTree
    数组类型的树节点。
    AssertTree
    一个用于 assert语句的树节点。
    AssignmentTree
    赋值表达式的树节点。
    BinaryTree
    二进制表达式的树节点。
    BlockTree
    语句块的树节点。
    BreakTree
    一个用于 break语句的树节点。
    CaseTree
    一个 case树节点在一个 switch语句中。
    CatchTree
    一个 catch块的树节点在一个 try语句中。
    ClassTree
    用于类，接口，枚举或注释类型声明的树节点。
    CompilationUnitTree
    表示编译单元（源文件）和程序包声明（package-info.java）的抽象语法树。
    CompoundAssignmentTree
    复合赋值运算符的树节点。
    ConditionalExpressionTree
    条件运算符的树节点？
    ContinueTree
    一个用于 continue语句的树节点。
    DirectiveTree
    对于ModuleTree中的所有指令的超类型。
    DoWhileLoopTree
    一个用于 do语句的树节点。
    EmptyStatementTree
    一个空（跳过）语句的树节点。
    EnhancedForLoopTree
    一个树状节点，用于“增强”的 for循环语句。
    ErroneousTree
    一个树形节点，用于支撑格式不正确的表达式。
    ExportsTree
    模块声明中的“exports”指令的树节点。
    ExpressionStatementTree
    表达式语句的树节点。
    ExpressionTree
    用作不同类型表达式的基类的树节点。
    ForLoopTree
    一个树状节点，用于基本的 for循环语句。
    IdentifierTree
    标识符表达式的树节点。
    IfTree
    一个用于 if语句的树节点。
    ImportTree
    导入声明的树节点。
    InstanceOfTree
    一个 instanceof表达式的树节点。
    IntersectionTypeTree
    转换表达式中交叉路口类型的树节点。
    LabeledStatementTree
    标记语句的树节点。
    LambdaExpressionTree
    lambda表达式的树节点。
    LambdaExpressionTree.BodyKind
    Lambda表达式有两种形式：表达式lambdas，其主体是表达式，语句lambdas，其主体是块
    LineMap
    提供在编译单元的字符位置和行号之间进行转换的方法。
    LiteralTree
    一个文字表达式的树结点。
    MemberReferenceTree
    成员引用表达式的树节点。
    MemberReferenceTree.ReferenceMode
    有两种成员引用：（i）方法引用和（ii）构造函数引用
    MemberSelectTree
    成员访问表达式的树节点。
    MethodInvocationTree
    方法调用表达式的树节点。
    MethodTree
    用于方法或注释类型元素声明的树节点。
    ModifiersTree
    用于声明的修饰符的树节点（包括注释）。
    ModuleTree
    模块声明的树节点。
    ModuleTree.ModuleKind
    模块的种类。
    NewArrayTree
    用于创建数组的新实例的表达式的树节点。
    NewClassTree
    一个树节点来声明一个类的新实例。
    OpensTree
    模块声明中的“打开”指令的树节点。
    PackageTree
    表示包声明。
    ParameterizedTypeTree
    涉及类型参数的类型表达式的树节点。
    ParenthesizedTree
    括号表达式的树节点。
    PrimitiveTypeTree
    一个原始类型的树节点。
    ProvidesTree
    模块声明中“提供”指令的树节点。
    RequiresTree
    模块声明中“require”指令的树结点。
    ReturnTree
    一个用于 return语句的树节点。
    Scope
    用于确定本地可用的程序元素的接口，如局部变量和导入。
    StatementTree
    用作不同类型语句的基类的树节点。
    SwitchTree
    一个树节点为一个 switch语句。
    SynchronizedTree
    一个树结点的一个 synchronized语句。
    ThrowTree
    一个用于 throw语句的树节点。
    树
    抽象语法树中所有节点的公共接口。
    Tree.Kind
    列举各种树木。
    TreeVisitor
    树木的访客，以访客设计模式的风格。
    TryTree
    一个用于 try语句的树节点。
    TypeCastTree
    类型转换表达式的树节点。
    TypeParameterTree
    类型参数的树节点。
    UnaryTree
    用于后缀和一元表达式的树节点。
    UnionTypeTree
    多重变量声明中的联合类型表达式的树节点。
    UsesTree
    模块声明中的'uses'指令的树节点。
    VariableTree
    用于变量声明的树节点。
    WhileLoopTree
    一个用于 while循环语句的树节点。
    WildcardTree
    用于通配符类型参数的树节点。
  • Classes in com.sun.source.tree used by com.sun.source.util
    Class 描述
    AnnotatedTypeTree
    用于注释类型的树节点。
    AnnotationTree
    用于注释的树节点。
    ArrayAccessTree
    数组访问表达式的树节点。
    ArrayTypeTree
    数组类型的树节点。
    AssertTree
    一个树结点的一个 assert语句。
    AssignmentTree
    赋值表达式的树节点。
    BinaryTree
    二进制表达式的树节点。
    BlockTree
    语句块的树节点。
    BreakTree
    一个用于 break语句的树节点。
    CaseTree
    一个 case一个树节点在一个 switch语句中。
    CatchTree
    一个 catch块中的一个树节点在一个 try语句中。
    ClassTree
    用于类，接口，枚举或注释类型声明的树节点。
    CompilationUnitTree
    表示编译单元（源文件）和程序包声明（package-info.java）的抽象语法树。
    CompoundAssignmentTree
    复合赋值运算符的树节点。
    ConditionalExpressionTree
    条件运算符的树节点？
    ContinueTree
    一个用于 continue语句的树节点。
    DoWhileLoopTree
    一个用于 do语句的树节点。
    EmptyStatementTree
    一个空（跳过）语句的树节点。
    EnhancedForLoopTree
    一个树状节点用于“增强”的 for循环语句。
    ErroneousTree
    一个树形节点，用于支撑格式不正确的表达式。
    ExportsTree
    模块声明中的“exports”指令的树节点。
    ExpressionStatementTree
    表达式语句的树节点。
    ForLoopTree
    一个树状节点，用于基本的 for循环语句。
    IdentifierTree
    标识符表达式的树节点。
    IfTree
    一个用于 if语句的树节点。
    ImportTree
    导入声明的树节点。
    InstanceOfTree
    一个 instanceof表达式的树节点。
    IntersectionTypeTree
    转换表达式中交叉路口类型的树节点。
    LabeledStatementTree
    标记语句的树节点。
    LambdaExpressionTree
    lambda表达式的树节点。
    LiteralTree
    一个文字表达式的树结点。
    MemberReferenceTree
    成员引用表达式的树节点。
    MemberSelectTree
    成员访问表达式的树节点。
    MethodInvocationTree
    方法调用表达式的树节点。
    MethodTree
    用于方法或注释类型元素声明的树节点。
    ModifiersTree
    用于声明的修饰符的树节点（包括注释）。
    ModuleTree
    模块声明的树节点。
    NewArrayTree
    用于创建数组的新实例的表达式的树节点。
    NewClassTree
    一个树节点来声明一个类的新实例。
    OpensTree
    模块声明中的“打开”指令的树节点。
    PackageTree
    表示包声明。
    ParameterizedTypeTree
    涉及类型参数的类型表达式的树节点。
    ParenthesizedTree
    括号表达式的树节点。
    PrimitiveTypeTree
    一个原始类型的树节点。
    ProvidesTree
    模块声明中“提供”指令的树节点。
    RequiresTree
    模块声明中“require”指令的树结点。
    ReturnTree
    一个用于 return语句的树节点。
    Scope
    用于确定本地可用的程序元素的接口，如局部变量和导入。
    SwitchTree
    一个用于 switch语句的树节点。
    SynchronizedTree
    一个树节点为一个 synchronized语句。
    ThrowTree
    一个用于 throw语句的树节点。
    树
    抽象语法树中所有节点的公共接口。
    TreeVisitor
    树木的访客，以访客设计模式的风格。
    TryTree
    一个用于 try语句的树节点。
    TypeCastTree
    类型转换表达式的树节点。
    TypeParameterTree
    类型参数的树节点。
    UnaryTree
    用于后缀和一元表达式的树节点。
    UnionTypeTree
    多重变量声明中的联合类型表达式的树节点。
    UsesTree
    模块声明中的'uses'指令的树节点。
    VariableTree
    用于变量声明的树节点。
    WhileLoopTree
    一个用于 while循环语句的树节点。
    WildcardTree
    用于通配符类型参数的树节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


UsesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface UsesTree

  • All Superinterfaces:
    DirectiveTree ， 树

    public interface UsesTree
extends DirectiveTree
    模块声明中的'uses'指令的树节点。 例如：
      uses service-name;
    从以下版本开始：
    9

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getServiceName​()
      返回服务类型的名称。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getServiceName

        ExpressionTree getServiceName​()
        返回服务类型的名称。
        结果
        服务类型的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VariableTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface VariableTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface VariableTree
extends StatementTree
    用于变量声明的树节点。 例如：
      modifiers type name initializer ;
   modifiers type qualified-name.this
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第8.3及14.4条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getInitializer​()
      返回变量的初始化器，如果没有，则返回 null 。
      ModifiersTree getModifiers​()
      在声明中返回修饰符，包括任何注释。
      Name getName​()
      返回正在声明的变量的名称。
      ExpressionTree getNameExpression​()
      返回名称为“声明”的合格标识符。
      树 getType​()
      返回正在声明的变量的类型。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getModifiers

        ModifiersTree getModifiers​()
        在声明中返回修饰符，包括任何注释。
        结果
        修饰符

      • getName

        Name getName​()
        返回正在声明的变量的名称。
        结果
        名字

      • getNameExpression

        ExpressionTree getNameExpression​()
        返回名称为“声明”的合格标识符。 这仅在某些情况下用于方法声明的接收者。 在所有其他情况下返回null 。
        结果
        接收者声明的合格标识符

      • getType

        树 getType​()
        返回正在声明的变量的类型。
        结果
        方式

      • getInitializer

        ExpressionTree getInitializer​()
        返回变量的初始化器，如果没有，则返回 null 。
        结果
        the initializer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WhileLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface WhileLoopTree

  • All Superinterfaces:
    StatementTree ， 树

    public interface WhileLoopTree
extends StatementTree
    一个用于while循环语句的树节点。 例如：
      while ( condition )
     statement
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第14.12条

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ExpressionTree getCondition​()
      返回循环的条件。
      StatementTree getStatement​()
      返回循环的正文。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getCondition

        ExpressionTree getCondition​()
        返回循环的条件。
        结果
        条件

      • getStatement

        StatementTree getStatement​()
        返回循环的正文。
        结果
        循环的身体
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WildcardTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.tree

Interface WildcardTree

  • All Superinterfaces:
    树

    public interface WildcardTree
extends 树
    用于通配符类型参数的树节点。 使用getKind确定绑定的种类。 例如：
      ?

   ? extends bound

   ? super bound
    从以下版本开始：
    1.6
    See The Java™ Language Specification:
    第4.5.1节

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface com.sun.source.tree.树

        Tree.Kind

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      树 getBound​()
      返回通配符的边界。

      • Methods inherited from interface com.sun.source.tree.树

        accept, getKind

    • 方法详细信息

      • getBound

        树 getBound​()
        返回通配符的边界。
        结果
        the bound
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.source.tree.LambdaExpressionTree.BodyKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.tree.LambdaExpressionTree.BodyKind

  • Packages that use LambdaExpressionTree.BodyKind
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of LambdaExpressionTree.BodyKind in com.sun.source.tree

      Methods in com.sun.source.tree that return LambdaExpressionTree.BodyKind
      Modifier and Type 方法 描述
      LambdaExpressionTree.BodyKind LambdaExpressionTree.getBodyKind​()
      返回lambda表达式的主体的种类。
      static LambdaExpressionTree.BodyKind LambdaExpressionTree.BodyKind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static LambdaExpressionTree.BodyKind[] LambdaExpressionTree.BodyKind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.tree.MemberReferenceTree.ReferenceMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.tree.MemberReferenceTree.ReferenceMode

  • Packages that use MemberReferenceTree.ReferenceMode
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of MemberReferenceTree.ReferenceMode in com.sun.source.tree

      Methods in com.sun.source.tree that return MemberReferenceTree.ReferenceMode
      Modifier and Type 方法 描述
      MemberReferenceTree.ReferenceMode MemberReferenceTree.getMode​()
      返回引用的模式。
      static MemberReferenceTree.ReferenceMode MemberReferenceTree.ReferenceMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MemberReferenceTree.ReferenceMode[] MemberReferenceTree.ReferenceMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.tree.ModuleTree.ModuleKind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.tree.ModuleTree.ModuleKind

  • Packages that use ModuleTree.ModuleKind
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of ModuleTree.ModuleKind in com.sun.source.tree

      Methods in com.sun.source.tree that return ModuleTree.ModuleKind
      Modifier and Type 方法 描述
      ModuleTree.ModuleKind ModuleTree.getModuleType​()
      返回此模块的类型。
      static ModuleTree.ModuleKind ModuleTree.ModuleKind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleTree.ModuleKind[] ModuleTree.ModuleKind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.tree.Tree.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.tree.Tree.Kind

  • Packages that use Tree.Kind
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of Tree.Kind in com.sun.source.tree

      Methods in com.sun.source.tree that return Tree.Kind
      Modifier and Type 方法 描述
      Tree.Kind Tree.getKind​()
      返回此树的种类。
      static Tree.Kind Tree.Kind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Tree.Kind[] Tree.Kind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.AnnotatedTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.AnnotatedTypeTree

  • Packages that use AnnotatedTypeTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of AnnotatedTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type AnnotatedTypeTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitAnnotatedType​(AnnotatedTypeTree node, P p)
      访问AnnotatedTypeTree节点。

    • Uses of AnnotatedTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AnnotatedTypeTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitAnnotatedType​(AnnotatedTypeTree node, P p)
      访问AnnotatedTypeTree节点。
      R TreeScanner.visitAnnotatedType​(AnnotatedTypeTree node, P p)
      访问AnnotatedTypeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.AnnotationTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.AnnotationTree

  • Packages that use AnnotationTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of AnnotationTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type AnnotationTree
      Modifier and Type 方法 描述
      List<? extends AnnotationTree> AnnotatedTypeTree.getAnnotations​()
      返回与此类型表达式关联的注释。
      List<? extends AnnotationTree> ModifiersTree.getAnnotations​()
      返回此修饰符树中的注释。
      List<? extends AnnotationTree> ModuleTree.getAnnotations​()
      返回与此模块声明关联的注释。
      List<? extends AnnotationTree> NewArrayTree.getAnnotations​()
      返回基本类型的注释。
      List<? extends AnnotationTree> PackageTree.getAnnotations​()
      返回与此包声明关联的注释。
      List<? extends AnnotationTree> TypeParameterTree.getAnnotations​()
      返回类型参数声明的注释。
      List<? extends List<? extends AnnotationTree>> NewArrayTree.getDimAnnotations​()
      返回每个维度表达式上的注释。
      List<? extends AnnotationTree> CompilationUnitTree.getPackageAnnotations​()
      返回在编译单元头部的任何包装声明中列出的注释，如果没有包声明，则 null 。
      Methods in com.sun.source.tree with parameters of type AnnotationTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitAnnotation​(AnnotationTree node, P p)
      访问AnnotatedTree节点。

    • Uses of AnnotationTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AnnotationTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitAnnotation​(AnnotationTree node, P p)
      访问AnnotatedTree节点。
      R TreeScanner.visitAnnotation​(AnnotationTree node, P p)
      Visits an AnnotatedTree node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ArrayAccessTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ArrayAccessTree

  • Packages that use ArrayAccessTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ArrayAccessTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ArrayAccessTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitArrayAccess​(ArrayAccessTree node, P p)
      访问ArrayAccessTree节点。

    • Uses of ArrayAccessTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ArrayAccessTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitArrayAccess​(ArrayAccessTree node, P p)
      访问ArrayAccessTree节点。
      R TreeScanner.visitArrayAccess​(ArrayAccessTree node, P p)
      访问ArrayAccessTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ArrayTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ArrayTypeTree

  • Packages that use ArrayTypeTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ArrayTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ArrayTypeTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitArrayType​(ArrayTypeTree node, P p)
      访问ArrayTypeTree节点。

    • Uses of ArrayTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ArrayTypeTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitArrayType​(ArrayTypeTree node, P p)
      访问ArrayTypeTree节点。
      R TreeScanner.visitArrayType​(ArrayTypeTree node, P p)
      访问ArrayTypeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.AssertTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.AssertTree

  • Packages that use AssertTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of AssertTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type AssertTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitAssert​(AssertTree node, P p)
      访问AssertTree节点。

    • Uses of AssertTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AssertTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitAssert​(AssertTree node, P p)
      访问AssertTree节点。
      R TreeScanner.visitAssert​(AssertTree node, P p)
      访问AssertTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.AssignmentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.AssignmentTree

  • Packages that use AssignmentTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of AssignmentTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type AssignmentTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitAssignment​(AssignmentTree node, P p)
      访问AssignmentTree节点。

    • Uses of AssignmentTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AssignmentTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitAssignment​(AssignmentTree node, P p)
      访问AssignmentTree节点。
      R TreeScanner.visitAssignment​(AssignmentTree node, P p)
      访问AssignmentTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.BinaryTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.BinaryTree

  • Packages that use BinaryTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of BinaryTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type BinaryTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitBinary​(BinaryTree node, P p)
      访问二进制流节点。

    • Uses of BinaryTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type BinaryTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitBinary​(BinaryTree node, P p)
      访问二进制流节点。
      R TreeScanner.visitBinary​(BinaryTree node, P p)
      访问二进制流节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.BlockTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.BlockTree

  • Packages that use BlockTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of BlockTree in com.sun.source.tree

      Methods in com.sun.source.tree that return BlockTree
      Modifier and Type 方法 描述
      BlockTree CatchTree.getBlock​()
      返回catch块。
      BlockTree SynchronizedTree.getBlock​()
      返回 synchronized语句的块。
      BlockTree TryTree.getBlock​()
      返回 try语句的块。
      BlockTree MethodTree.getBody​()
      返回方法体，如果这是一个抽象或本机方法，则返回 null 。
      BlockTree TryTree.getFinallyBlock​()
      返回 try语句中提供的finally块，如果没有，则返回 null 。
      Methods in com.sun.source.tree with parameters of type BlockTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitBlock​(BlockTree node, P p)
      访问BlockTree节点。

    • Uses of BlockTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type BlockTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitBlock​(BlockTree node, P p)
      访问BlockTree节点。
      R TreeScanner.visitBlock​(BlockTree node, P p)
      访问BlockTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.BreakTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.BreakTree

  • Packages that use BreakTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of BreakTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type BreakTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitBreak​(BreakTree node, P p)
      访问BreakTree节点。

    • Uses of BreakTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type BreakTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitBreak​(BreakTree node, P p)
      访问BreakTree节点。
      R TreeScanner.visitBreak​(BreakTree node, P p)
      访问BreakTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.CaseTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.CaseTree

  • Packages that use CaseTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of CaseTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type CaseTree
      Modifier and Type 方法 描述
      List<? extends CaseTree> SwitchTree.getCases​()
      返回 switch语句的情况。
      Methods in com.sun.source.tree with parameters of type CaseTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitCase​(CaseTree node, P p)
      访问CaseTree节点。

    • Uses of CaseTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CaseTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitCase​(CaseTree node, P p)
      访问CaseTree节点。
      R TreeScanner.visitCase​(CaseTree node, P p)
      访问CaseTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.CatchTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.CatchTree

  • Packages that use CatchTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of CatchTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type CatchTree
      Modifier and Type 方法 描述
      List<? extends CatchTree> TryTree.getCatches​()
      返回 try语句中提供的任何catch块。
      Methods in com.sun.source.tree with parameters of type CatchTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitCatch​(CatchTree node, P p)
      访问CatchTree节点。

    • Uses of CatchTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CatchTree
      Modifier and Type 方法 描述
      abstract TypeMirror Trees.getLub​(CatchTree tree)
      返回在catch子句中声明的异常参数的lub。
      R SimpleTreeVisitor.visitCatch​(CatchTree node, P p)
      访问CatchTree节点。
      R TreeScanner.visitCatch​(CatchTree node, P p)
      Visits a CatchTree node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ClassTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ClassTree

  • Packages that use ClassTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ClassTree in com.sun.source.tree

      Methods in com.sun.source.tree that return ClassTree
      Modifier and Type 方法 描述
      ClassTree NewClassTree.getClassBody​()
      如果正在实例化一个匿名类，返回类体，否则返回 null 。
      Methods in com.sun.source.tree with parameters of type ClassTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitClass​(ClassTree node, P p)
      访问ClassTree节点。

    • Uses of ClassTree in com.sun.source.util

      Methods in com.sun.source.util that return ClassTree
      Modifier and Type 方法 描述
      abstract ClassTree Trees.getTree​(TypeElement element)
      返回给定TypeElement的ClassTree节点。
      Methods in com.sun.source.util with parameters of type ClassTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitClass​(ClassTree node, P p)
      访问ClassTree节点。
      R TreeScanner.visitClass​(ClassTree node, P p)
      Visits a ClassTree node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.CompilationUnitTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.CompilationUnitTree

  • Packages that use CompilationUnitTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of CompilationUnitTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type CompilationUnitTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitCompilationUnit​(CompilationUnitTree node, P p)
      访问CompilationUnitTree节点。

    • Uses of CompilationUnitTree in com.sun.source.util

      Methods in com.sun.source.util that return CompilationUnitTree
      Modifier and Type 方法 描述
      CompilationUnitTree TaskEvent.getCompilationUnit​()
      返回此事件的编译单位。
      CompilationUnitTree TreePath.getCompilationUnit​()
      返回与此路径关联的编译单元。
      Methods in com.sun.source.util that return types with arguments of type CompilationUnitTree
      Modifier and Type 方法 描述
      abstract Iterable<? extends CompilationUnitTree> JavacTask.parse​()
      解析指定的文件，返回抽象语法树列表。
      Methods in com.sun.source.util with parameters of type CompilationUnitTree
      Modifier and Type 方法 描述
      long DocSourcePositions.getEndPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件中注释中树的结束位置。
      long SourcePositions.getEndPosition​(CompilationUnitTree file, 树 tree)
      返回文件中树的结束位置。
      static TreePath TreePath.getPath​(CompilationUnitTree unit, 树 target)
      返回编译单元中树节点的树路径，如果未找到节点，则 null 。
      abstract TreePath Trees.getPath​(CompilationUnitTree unit, 树 node)
      返回指定编译单元中树节点的路径。
      long DocSourcePositions.getStartPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件内注释中树的起始位置。
      long SourcePositions.getStartPosition​(CompilationUnitTree file, 树 tree)
      返回文件中树的起始位置。
      abstract void DocTrees.printMessage​(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息
      abstract void Trees.printMessage​(Diagnostic.Kind kind, CharSequence msg, 树 t, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息
      R SimpleTreeVisitor.visitCompilationUnit​(CompilationUnitTree node, P p)
      访问CompilationUnitTree节点。
      R TreeScanner.visitCompilationUnit​(CompilationUnitTree node, P p)
      访问CompilationUnitTree节点。
      Constructors in com.sun.source.util with parameters of type CompilationUnitTree
      Constructor 描述
      TaskEvent​(TaskEvent.Kind kind, CompilationUnitTree unit)
      为给定类型和编译单元创建任务事件。
      TaskEvent​(TaskEvent.Kind kind, CompilationUnitTree unit, TypeElement clazz)
      为给定类型，编译单位和类型元素创建任务事件。
      TreePath​(CompilationUnitTree node)
      Creates a TreePath for a root node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.CompoundAssignmentTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.CompoundAssignmentTree

  • Packages that use CompoundAssignmentTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of CompoundAssignmentTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type CompoundAssignmentTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitCompoundAssignment​(CompoundAssignmentTree node, P p)
      访问一个CompoundAssignmentTree节点。

    • Uses of CompoundAssignmentTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CompoundAssignmentTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitCompoundAssignment​(CompoundAssignmentTree node, P p)
      访问一个CompoundAssignmentTree节点。
      R TreeScanner.visitCompoundAssignment​(CompoundAssignmentTree node, P p)
      访问一个CompoundAssignmentTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ConditionalExpressionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ConditionalExpressionTree

  • Packages that use ConditionalExpressionTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ConditionalExpressionTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ConditionalExpressionTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitConditionalExpression​(ConditionalExpressionTree node, P p)
      访问一个ConditionalExpressionTree节点。

    • Uses of ConditionalExpressionTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ConditionalExpressionTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitConditionalExpression​(ConditionalExpressionTree node, P p)
      访问一个ConditionalExpressionTree节点。
      R TreeScanner.visitConditionalExpression​(ConditionalExpressionTree node, P p)
      访问一个ConditionalExpressionTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ContinueTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ContinueTree

  • Packages that use ContinueTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ContinueTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ContinueTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitContinue​(ContinueTree node, P p)
      访问ContinueTree节点。

    • Uses of ContinueTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ContinueTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitContinue​(ContinueTree node, P p)
      访问ContinueTree节点。
      R TreeScanner.visitContinue​(ContinueTree node, P p)
      访问ContinueTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.DirectiveTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.DirectiveTree

  • Packages that use DirectiveTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of DirectiveTree in com.sun.source.tree

      Subinterfaces of DirectiveTree in com.sun.source.tree
      Modifier and Type 接口 描述
      interface  ExportsTree
      模块声明中的“exports”指令的树节点。
      interface  OpensTree
      模块声明中的“打开”指令的树节点。
      interface  ProvidesTree
      模块声明中“提供”指令的树节点。
      interface  RequiresTree
      模块声明中“require”指令的树结点。
      interface  UsesTree
      模块声明中的'uses'指令的树节点。
      Methods in com.sun.source.tree that return types with arguments of type DirectiveTree
      Modifier and Type 方法 描述
      List<? extends DirectiveTree> ModuleTree.getDirectives​()
      Returns the directives in the module declaration.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.DoWhileLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.DoWhileLoopTree

  • Packages that use DoWhileLoopTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DoWhileLoopTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type DoWhileLoopTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitDoWhileLoop​(DoWhileLoopTree node, P p)
      访问DoWhileTree节点。

    • Uses of DoWhileLoopTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type DoWhileLoopTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitDoWhileLoop​(DoWhileLoopTree node, P p)
      访问DoWhileTree节点。
      R TreeScanner.visitDoWhileLoop​(DoWhileLoopTree node, P p)
      访问DoWhileTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.EmptyStatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.EmptyStatementTree

  • Packages that use EmptyStatementTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of EmptyStatementTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type EmptyStatementTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitEmptyStatement​(EmptyStatementTree node, P p)
      访问一个EmptyStatementTree节点。

    • Uses of EmptyStatementTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type EmptyStatementTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitEmptyStatement​(EmptyStatementTree node, P p)
      访问一个EmptyStatementTree节点。
      R TreeScanner.visitEmptyStatement​(EmptyStatementTree node, P p)
      访问一个EmptyStatementTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.EnhancedForLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.EnhancedForLoopTree

  • Packages that use EnhancedForLoopTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of EnhancedForLoopTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type EnhancedForLoopTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitEnhancedForLoop​(EnhancedForLoopTree node, P p)
      访问EnhancedForLoopTree节点。

    • Uses of EnhancedForLoopTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type EnhancedForLoopTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitEnhancedForLoop​(EnhancedForLoopTree node, P p)
      访问EnhancedForLoopTree节点。
      R TreeScanner.visitEnhancedForLoop​(EnhancedForLoopTree node, P p)
      访问EnhancedForLoopTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ErroneousTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ErroneousTree

  • Packages that use ErroneousTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ErroneousTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ErroneousTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。

    • Uses of ErroneousTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ErroneousTree
      Modifier and Type | 方法 | 描述
      R | SimpleTreeVisitor.visitErroneous​(ErroneousTree node, P p)
      R TreeScanner.visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ExportsTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ExportsTree

  • Packages that use ExportsTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ExportsTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ExportsTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitExports​(ExportsTree node, P p)
      访问ExportsTree节点。

    • Uses of ExportsTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ExportsTree
      Modifier and Type | 方法 | 描述
      R | SimpleTreeVisitor.visitExports​(ExportsTree node, P p)
      R | TreeScanner.visitExports​(ExportsTree node, P p)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ExpressionStatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ExpressionStatementTree

  • Packages that use ExpressionStatementTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ExpressionStatementTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type ExpressionStatementTree
      Modifier and Type 方法 描述
      List<? extends ExpressionStatementTree> ForLoopTree.getUpdate​()
      返回 for语句的更新表达式。
      Methods in com.sun.source.tree with parameters of type ExpressionStatementTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitExpressionStatement​(ExpressionStatementTree node, P p)
      访问ExpressionStatementTree节点。

    • Uses of ExpressionStatementTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ExpressionStatementTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitExpressionStatement​(ExpressionStatementTree node, P p)
      访问ExpressionStatementTree节点。
      R TreeScanner.visitExpressionStatement​(ExpressionStatementTree node, P p)
      访问ExpressionStatementTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ExpressionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ExpressionTree

  • Packages that use ExpressionTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of ExpressionTree in com.sun.source.tree

      Subinterfaces of ExpressionTree in com.sun.source.tree
      Modifier and Type 接口 描述
      interface  AnnotatedTypeTree
      用于注释类型的树节点。
      interface  AnnotationTree
      用于注释的树节点。
      interface  ArrayAccessTree
      数组访问表达式的树节点。
      interface  AssignmentTree
      赋值表达式的树节点。
      interface  BinaryTree
      二进制表达式的树节点。
      interface  CompoundAssignmentTree
      复合赋值运算符的树节点。
      interface  ConditionalExpressionTree
      条件运算符的树节点？
      interface  ErroneousTree
      一个树形节点，用于支撑格式不正确的表达式。
      interface  IdentifierTree
      标识符表达式的树节点。
      interface  InstanceOfTree
      一个 instanceof表达式的树节点。
      interface  LambdaExpressionTree
      lambda表达式的树节点。
      interface  LiteralTree
      一个文字表达式的树结点。
      interface  MemberReferenceTree
      成员引用表达式的树节点。
      interface  MemberSelectTree
      成员访问表达式的树节点。
      interface  MethodInvocationTree
      方法调用表达式的树节点。
      interface  NewArrayTree
      用于创建数组的新实例的表达式的树节点。
      interface  NewClassTree
      一个树节点来声明一个类的新实例。
      interface  ParenthesizedTree
      括号表达式的树节点。
      interface  TypeCastTree
      类型转换表达式的树节点。
      interface  UnaryTree
      用于后缀和一元表达式的树节点。
      Methods in com.sun.source.tree that return ExpressionTree
      Modifier and Type 方法 描述
      ExpressionTree AssertTree.getCondition​()
      返回被声明的条件。
      ExpressionTree ConditionalExpressionTree.getCondition​()
      返回条件。
      ExpressionTree DoWhileLoopTree.getCondition​()
      返回循环的条件。
      ExpressionTree ForLoopTree.getCondition​()
      返回 for语句的条件。
      ExpressionTree IfTree.getCondition​()
      返回if语句的条件。
      ExpressionTree WhileLoopTree.getCondition​()
      返回循环的条件。
      ExpressionTree AssertTree.getDetail​()
      返回详细表达式。
      ExpressionTree NewClassTree.getEnclosingExpression​()
      返回包含的表达式，如果没有，则返回 null 。
      ExpressionTree ArrayAccessTree.getExpression​()
      返回正在访问的数组的表达式。
      ExpressionTree AssignmentTree.getExpression​()
      返回分配给变量的表达式。
      ExpressionTree CaseTree.getExpression​()
      返回case的表达式，如果这是默认情况，则返回 null 。
      ExpressionTree CompoundAssignmentTree.getExpression​()
      返回复合赋值右侧的表达式。
      ExpressionTree EnhancedForLoopTree.getExpression​()
      返回产生控制变量值的表达式。
      ExpressionTree ExpressionStatementTree.getExpression​()
      返回构成该语句的表达式。
      ExpressionTree InstanceOfTree.getExpression​()
      返回要测试的表达式。
      ExpressionTree MemberSelectTree.getExpression​()
      返回要为其选择成员的表达式。
      ExpressionTree ParenthesizedTree.getExpression​()
      返回括号内的表达式。
      ExpressionTree ReturnTree.getExpression​()
      返回要返回的表达式。
      ExpressionTree SwitchTree.getExpression​()
      返回 switch语句的表达式。
      ExpressionTree SynchronizedTree.getExpression​()
      返回要同步的表达式。
      ExpressionTree ThrowTree.getExpression​()
      返回要抛出的表达式。
      ExpressionTree TypeCastTree.getExpression​()
      返回正在转换的表达式。
      ExpressionTree UnaryTree.getExpression​()
      返回一元运算符的操作数的表达式。
      ExpressionTree ConditionalExpressionTree.getFalseExpression​()
      如果条件为false，则返回要评估的表达式。
      ExpressionTree NewClassTree.getIdentifier​()
      返回要实例化的类的名称。
      ExpressionTree ArrayAccessTree.getIndex​()
      返回索引的表达式。
      ExpressionTree VariableTree.getInitializer​()
      返回变量的初始化器，如果没有，则返回 null 。
      ExpressionTree BinaryTree.getLeftOperand​()
      返回表达式的左（第一）操作数。
      ExpressionTree MethodInvocationTree.getMethodSelect​()
      返回标识要调用的方法的表达式。
      ExpressionTree RequiresTree.getModuleName​()
      返回所需模块的名称。
      ExpressionTree ModuleTree.getName​()
      返回模块的名称。
      ExpressionTree VariableTree.getNameExpression​()
      返回名称为“声明”的合格标识符。
      ExpressionTree CompilationUnitTree.getPackageName​()
      返回此编译单元头部的任何包装声明中包含的名称，如果没有包装声明，则 null 。
      ExpressionTree ExportsTree.getPackageName​()
      返回要导出的包的名称。
      ExpressionTree OpensTree.getPackageName​()
      返回要打开的包的名称。
      ExpressionTree PackageTree.getPackageName​()
      返回正在声明的包的名称。
      ExpressionTree MemberReferenceTree.getQualifierExpression​()
      返回参考的限定符表达式。
      ExpressionTree BinaryTree.getRightOperand​()
      返回表达式的右（第二）操作数。
      ExpressionTree ProvidesTree.getServiceName​()
      返回正在提供的服务类型的名称。
      ExpressionTree UsesTree.getServiceName​()
      返回服务类型的名称。
      ExpressionTree ConditionalExpressionTree.getTrueExpression​()
      如果条件为真，返回要评估的表达式。
      ExpressionTree AnnotatedTypeTree.getUnderlyingType​()
      返回与注释关联的底层类型。
      ExpressionTree AssignmentTree.getVariable​()
      返回被分配给的变量。
      ExpressionTree CompoundAssignmentTree.getVariable​()
      返回复合赋值左侧的变量。
      Methods in com.sun.source.tree that return types with arguments of type ExpressionTree
      Modifier and Type 方法 描述
      List<? extends ExpressionTree> AnnotationTree.getArguments​()
      返回注释的参数（如果有）。
      List<? extends ExpressionTree> MethodInvocationTree.getArguments​()
      返回方法调用的参数。
      List<? extends ExpressionTree> NewClassTree.getArguments​()
      返回要调用的构造函数的参数。
      List<? extends ExpressionTree> NewArrayTree.getDimensions​()
      返回类型的维度表达式。
      List<? extends ExpressionTree> ProvidesTree.getImplementationNames​()
      返回正在提供的实现类型的名称。
      List<? extends ExpressionTree> NewArrayTree.getInitializers​()
      返回初始化器表达式。
      List<? extends ExpressionTree> ExportsTree.getModuleNames​()
      返回包导出到的模块的名称，如果软件包导出到所有模块，则返回null。
      List<? extends ExpressionTree> OpensTree.getModuleNames​()
      返回包打开的模块的名称，如果打包到所有模块，则返回null。
      List<? extends ExpressionTree> MethodTree.getThrows​()
      返回此方法抛出的异常。
      List<? extends ExpressionTree> MemberReferenceTree.getTypeArguments​()
      返回引用的类型参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ForLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ForLoopTree

  • Packages that use ForLoopTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ForLoopTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ForLoopTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitForLoop​(ForLoopTree node, P p)
      访问ForLoopTree节点。

    • Uses of ForLoopTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ForLoopTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitForLoop​(ForLoopTree node, P p)
      访问ForLoopTree节点。
      R TreeScanner.visitForLoop​(ForLoopTree node, P p)
      访问ForLoopTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.IdentifierTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.IdentifierTree

  • Packages that use IdentifierTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of IdentifierTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type IdentifierTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。

    • Uses of IdentifierTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type IdentifierTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R TreeScanner.visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.IfTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.IfTree

  • Packages that use IfTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of IfTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type IfTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitIf​(IfTree node, P p)
      访问IfTree节点。

    • Uses of IfTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type IfTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitIf​(IfTree node, P p)
      访问IfTree节点。
      R TreeScanner.visitIf​(IfTree node, P p)
      访问IfTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ImportTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ImportTree

  • Packages that use ImportTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ImportTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type ImportTree
      Modifier and Type 方法 描述
      List<? extends ImportTree> CompilationUnitTree.getImports​()
      返回此编译单元中出现的导入声明。
      Methods in com.sun.source.tree with parameters of type ImportTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitImport​(ImportTree node, P p)
      访问ImportTree节点。

    • Uses of ImportTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ImportTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitImport​(ImportTree node, P p)
      访问ImportTree节点。
      R TreeScanner.visitImport​(ImportTree node, P p)
      访问ImportTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.InstanceOfTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.InstanceOfTree

  • Packages that use InstanceOfTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of InstanceOfTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type InstanceOfTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitInstanceOf​(InstanceOfTree node, P p)
      访问InstanceOfTree节点。

    • Uses of InstanceOfTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type InstanceOfTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitInstanceOf​(InstanceOfTree node, P p)
      访问InstanceOfTree节点。
      R TreeScanner.visitInstanceOf​(InstanceOfTree node, P p)
      访问InstanceOfTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.IntersectionTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.IntersectionTypeTree

  • Packages that use IntersectionTypeTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of IntersectionTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type IntersectionTypeTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitIntersectionType​(IntersectionTypeTree node, P p)
      访问一个IntersectionTypeTree节点。

    • Uses of IntersectionTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type IntersectionTypeTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitIntersectionType​(IntersectionTypeTree node, P p)
      访问一个IntersectionTypeTree节点。
      R TreeScanner.visitIntersectionType​(IntersectionTypeTree node, P p)
      访问一个IntersectionTypeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.LabeledStatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.LabeledStatementTree

  • Packages that use LabeledStatementTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of LabeledStatementTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type LabeledStatementTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitLabeledStatement​(LabeledStatementTree node, P p)
      访问LabeledStatementTree节点。

    • Uses of LabeledStatementTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type LabeledStatementTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitLabeledStatement​(LabeledStatementTree node, P p)
      访问LabeledStatementTree节点。
      R TreeScanner.visitLabeledStatement​(LabeledStatementTree node, P p)
      访问LabeledStatementTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.LambdaExpressionTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.LambdaExpressionTree

  • Packages that use LambdaExpressionTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of LambdaExpressionTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type LambdaExpressionTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitLambdaExpression​(LambdaExpressionTree node, P p)
      访问LambdaExpressionTree节点。

    • Uses of LambdaExpressionTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type LambdaExpressionTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitLambdaExpression​(LambdaExpressionTree node, P p)
      访问LambdaExpressionTree节点。
      R TreeScanner.visitLambdaExpression​(LambdaExpressionTree node, P p)
      访问LambdaExpressionTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.LineMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.LineMap

  • Packages that use LineMap
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of LineMap in com.sun.source.tree

      Methods in com.sun.source.tree that return LineMap
      Modifier and Type 方法 描述
      LineMap CompilationUnitTree.getLineMap​()
      返回此编译单元的行图（如果可用）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.LiteralTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.LiteralTree

  • Packages that use LiteralTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of LiteralTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type LiteralTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。

    • Uses of LiteralTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type LiteralTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R TreeScanner.visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.MemberReferenceTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.MemberReferenceTree

  • Packages that use MemberReferenceTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of MemberReferenceTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type MemberReferenceTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitMemberReference​(MemberReferenceTree node, P p)
      访问MemberReferenceTree节点。

    • Uses of MemberReferenceTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type MemberReferenceTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitMemberReference​(MemberReferenceTree node, P p)
      访问MemberReferenceTree节点。
      R TreeScanner.visitMemberReference​(MemberReferenceTree node, P p)
      访问MemberReferenceTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.MemberSelectTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.MemberSelectTree

  • Packages that use MemberSelectTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of MemberSelectTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type MemberSelectTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitMemberSelect​(MemberSelectTree node, P p)
      访问MemberSelectTree节点。

    • Uses of MemberSelectTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type MemberSelectTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitMemberSelect​(MemberSelectTree node, P p)
      访问MemberSelectTree节点。
      R TreeScanner.visitMemberSelect​(MemberSelectTree node, P p)
      访问MemberSelectTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.MethodInvocationTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.MethodInvocationTree

  • Packages that use MethodInvocationTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of MethodInvocationTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type MethodInvocationTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitMethodInvocation​(MethodInvocationTree node, P p)
      访问MethodInvocationTree节点。

    • Uses of MethodInvocationTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type MethodInvocationTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitMethodInvocation​(MethodInvocationTree node, P p)
      访问MethodInvocationTree节点。
      R TreeScanner.visitMethodInvocation​(MethodInvocationTree node, P p)
      访问MethodInvocationTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.MethodTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.MethodTree

  • Packages that use MethodTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of MethodTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type MethodTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitMethod​(MethodTree node, P p)
      访问MethodTree节点。

    • Uses of MethodTree in com.sun.source.util

      Methods in com.sun.source.util that return MethodTree
      Modifier and Type 方法 描述
      abstract MethodTree Trees.getTree​(ExecutableElement method)
      返回给定ExecutableElement的MethodTree节点。
      Methods in com.sun.source.util with parameters of type MethodTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitMethod​(MethodTree node, P p)
      访问MethodTree节点。
      R TreeScanner.visitMethod​(MethodTree node, P p)
      访问MethodTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ModifiersTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ModifiersTree

  • Packages that use ModifiersTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ModifiersTree in com.sun.source.tree

      Methods in com.sun.source.tree that return ModifiersTree
      Modifier and Type 方法 描述
      ModifiersTree ClassTree.getModifiers​()
      返回此类型声明的修饰符，包括任何注释。
      ModifiersTree MethodTree.getModifiers​()
      返回修饰符，包括声明方法的任何注释。
      ModifiersTree VariableTree.getModifiers​()
      在声明中返回修饰符，包括任何注释。
      Methods in com.sun.source.tree with parameters of type ModifiersTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitModifiers​(ModifiersTree node, P p)
      访问修饰符Tree节点。

    • Uses of ModifiersTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ModifiersTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitModifiers​(ModifiersTree node, P p)
      访问修饰符Tree节点。
      R TreeScanner.visitModifiers​(ModifiersTree node, P p)
      访问修饰符Tree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ModuleTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ModuleTree

  • Packages that use ModuleTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ModuleTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ModuleTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitModule​(ModuleTree node, P p)
      访问ModuleTree节点。

    • Uses of ModuleTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ModuleTree
      Modifier and Type | 方法 | 描述
      R | SimpleTreeVisitor.visitModule​(ModuleTree node, P p)
      R | TreeScanner.visitModule​(ModuleTree node, P p)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.NewArrayTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.NewArrayTree

  • Packages that use NewArrayTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of NewArrayTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type NewArrayTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitNewArray​(NewArrayTree node, P p)
      访问NewArrayTree节点。

    • Uses of NewArrayTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type NewArrayTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitNewArray​(NewArrayTree node, P p)
      访问NewArrayTree节点。
      R TreeScanner.visitNewArray​(NewArrayTree node, P p)
      访问NewArrayTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.NewClassTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.NewClassTree

  • Packages that use NewClassTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of NewClassTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type NewClassTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitNewClass​(NewClassTree node, P p)
      访问NewClassTree节点。

    • Uses of NewClassTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type NewClassTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitNewClass​(NewClassTree node, P p)
      访问NewClassTree节点。
      R TreeScanner.visitNewClass​(NewClassTree node, P p)
      访问NewClassTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.OpensTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.OpensTree

  • Packages that use OpensTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of OpensTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type OpensTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitOpens​(OpensTree node, P p)
      访问OpensTree节点。

    • Uses of OpensTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type OpensTree
      Modifier and Type | 方法 | 描述
      R | SimpleTreeVisitor.visitOpens​(OpensTree node, P p)
      R | TreeScanner.visitOpens​(OpensTree node, P p)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.PackageTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.PackageTree

  • Packages that use PackageTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of PackageTree in com.sun.source.tree

      Methods in com.sun.source.tree that return PackageTree
      Modifier and Type 方法 描述
      PackageTree CompilationUnitTree.getPackage​()
      返回与此编译单元关联的包树，或者如果没有包声明，则返回 null 。
      Methods in com.sun.source.tree with parameters of type PackageTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitPackage​(PackageTree node, P p)
      访问PackageTree节点。

    • Uses of PackageTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type PackageTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitPackage​(PackageTree node, P p)
      访问PackageTree节点。
      R TreeScanner.visitPackage​(PackageTree node, P p)
      访问PackageTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ParameterizedTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ParameterizedTypeTree

  • Packages that use ParameterizedTypeTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ParameterizedTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ParameterizedTypeTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitParameterizedType​(ParameterizedTypeTree node, P p)
      访问ParameterizedTypeTree节点。

    • Uses of ParameterizedTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ParameterizedTypeTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitParameterizedType​(ParameterizedTypeTree node, P p)
      访问ParameterizedTypeTree节点。
      R TreeScanner.visitParameterizedType​(ParameterizedTypeTree node, P p)
      访问ParameterizedTypeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ParenthesizedTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ParenthesizedTree

  • Packages that use ParenthesizedTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ParenthesizedTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ParenthesizedTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitParenthesized​(ParenthesizedTree node, P p)
      访问ParenthesizedTree节点。

    • Uses of ParenthesizedTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ParenthesizedTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitParenthesized​(ParenthesizedTree node, P p)
      访问ParenthesizedTree节点。
      R TreeScanner.visitParenthesized​(ParenthesizedTree node, P p)
      访问ParenthesizedTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.PrimitiveTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.PrimitiveTypeTree

  • Packages that use PrimitiveTypeTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of PrimitiveTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type PrimitiveTypeTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitPrimitiveType​(PrimitiveTypeTree node, P p)
      访问PrimitiveTypeTree节点。

    • Uses of PrimitiveTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type PrimitiveTypeTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitPrimitiveType​(PrimitiveTypeTree node, P p)
      访问PrimitiveTypeTree节点。
      R TreeScanner.visitPrimitiveType​(PrimitiveTypeTree node, P p)
      访问PrimitiveTypeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ProvidesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ProvidesTree

  • Packages that use ProvidesTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ProvidesTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ProvidesTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。

    • Uses of ProvidesTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ProvidesTree
      Modifier and Type | 方法 | 描述
      R | SimpleTreeVisitor.visitProvides​(ProvidesTree node, P p)
      R | TreeScanner.visitProvides​(ProvidesTree node, P p)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.RequiresTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.RequiresTree

  • Packages that use RequiresTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of RequiresTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type RequiresTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitRequires​(RequiresTree node, P p)
      访问RequiresTree节点。

    • Uses of RequiresTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type RequiresTree
      Modifier and Type | 方法 | 描述
      R | SimpleTreeVisitor.visitRequires​(RequiresTree node, P p)
      R | TreeScanner.visitRequires​(RequiresTree node, P p)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ReturnTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ReturnTree

  • Packages that use ReturnTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ReturnTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ReturnTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。

    • Uses of ReturnTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ReturnTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R TreeScanner.visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.Scope (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.Scope

  • Packages that use Scope
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of Scope in com.sun.source.tree

      Methods in com.sun.source.tree that return Scope
      Modifier and Type 方法 描述
      Scope Scope.getEnclosingScope​()
      返回包围范围。

    • Uses of Scope in com.sun.source.util

      Methods in com.sun.source.util that return Scope
      Modifier and Type 方法 描述
      abstract Scope Trees.getScope​(TreePath path)
      返回给定TreePath标识的Tree节点的范围。
      Methods in com.sun.source.util with parameters of type Scope
      Modifier and Type 方法 描述
      abstract boolean Trees.isAccessible​(Scope scope, Element member, DeclaredType type)
      检查给定元素是否可以作为给定范围内给定类型的成员访问。
      abstract boolean Trees.isAccessible​(Scope scope, TypeElement type)
      检查给定范围内是否可访问给定类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.StatementTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.StatementTree

  • Packages that use StatementTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。

    • Uses of StatementTree in com.sun.source.tree

      Subinterfaces of StatementTree in com.sun.source.tree
      Modifier and Type 接口 描述
      interface  AssertTree
      一个用于 assert语句的树节点。
      interface  BlockTree
      语句块的树节点。
      interface  BreakTree
      一个用于 break语句的树节点。
      interface  ClassTree
      用于类，接口，枚举或注释类型声明的树节点。
      interface  ContinueTree
      一个用于 continue语句的树节点。
      interface  DoWhileLoopTree
      一个用于 do语句的树节点。
      interface  EmptyStatementTree
      一个空（跳过）语句的树节点。
      interface  EnhancedForLoopTree
      一个树状节点，用于“增强”的 for循环语句。
      interface  ExpressionStatementTree
      表达式语句的树节点。
      interface  ForLoopTree
      一个树状节点，用于基本的 for循环语句。
      interface  IfTree
      一个用于 if语句的树节点。
      interface  LabeledStatementTree
      标记语句的树节点。
      interface  ReturnTree
      一个用于 return语句的树节点。
      interface  SwitchTree
      一个用于 switch语句的树节点。
      interface  SynchronizedTree
      一个用于 synchronized语句的树节点。
      interface  ThrowTree
      一个用于 throw语句的树节点。
      interface  TryTree
      一个用于 try语句的树节点。
      interface  VariableTree
      用于变量声明的树节点。
      interface  WhileLoopTree
      一个用于 while循环语句的树节点。
      Methods in com.sun.source.tree that return StatementTree
      Modifier and Type 方法 描述
      StatementTree IfTree.getElseStatement​()
      如果条件为false，则返回要执行的语句，如果没有此语句，则返回 null 。
      StatementTree DoWhileLoopTree.getStatement​()
      返回循环的正文。
      StatementTree EnhancedForLoopTree.getStatement​()
      返回循环的正文。
      StatementTree ForLoopTree.getStatement​()
      返回 for语句的 for 。
      StatementTree LabeledStatementTree.getStatement​()
      返回标记的语句。
      StatementTree WhileLoopTree.getStatement​()
      返回循环的正文。
      StatementTree IfTree.getThenStatement​()
      如果条件为真，则返回要执行的语句
      Methods in com.sun.source.tree that return types with arguments of type StatementTree
      Modifier and Type 方法 描述
      List<? extends StatementTree> ForLoopTree.getInitializer​()
      返回 for语句的任何初始值。
      List<? extends StatementTree> BlockTree.getStatements​()
      返回包含此块的语句。
      List<? extends StatementTree> CaseTree.getStatements​()
      返回由案例标注的语句。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.SwitchTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.SwitchTree

  • Packages that use SwitchTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SwitchTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type SwitchTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitSwitch​(SwitchTree node, P p)
      访问SwitchTree节点。

    • Uses of SwitchTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type SwitchTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitSwitch​(SwitchTree node, P p)
      访问SwitchTree节点。
      R TreeScanner.visitSwitch​(SwitchTree node, P p)
      访问SwitchTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.SynchronizedTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.SynchronizedTree

  • Packages that use SynchronizedTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SynchronizedTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type SynchronizedTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitSynchronized​(SynchronizedTree node, P p)
      访问SynchronizedTree节点。

    • Uses of SynchronizedTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type SynchronizedTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitSynchronized​(SynchronizedTree node, P p)
      访问SynchronizedTree节点。
      R TreeScanner.visitSynchronized​(SynchronizedTree node, P p)
      访问SynchronizedTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.ThrowTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.ThrowTree

  • Packages that use ThrowTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of ThrowTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ThrowTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitThrow​(ThrowTree node, P p)
      访问ThrowTree节点

    • Uses of ThrowTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ThrowTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitThrow​(ThrowTree node, P p)
      访问ThrowTree节点
      R TreeScanner.visitThrow​(ThrowTree node, P p)
      访问ThrowTree节点
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.Tree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.Tree

  • Packages that use 树
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of 树 in com.sun.source.tree

      Subinterfaces of 树 in com.sun.source.tree
      Modifier and Type 接口 描述
      interface  AnnotatedTypeTree
      用于注释类型的树节点。
      interface  AnnotationTree
      用于注释的树节点。
      interface  ArrayAccessTree
      数组访问表达式的树节点。
      interface  ArrayTypeTree
      数组类型的树节点。
      interface  AssertTree
      一个用于 assert语句的树节点。
      interface  AssignmentTree
      赋值表达式的树节点。
      interface  BinaryTree
      二进制表达式的树节点。
      interface  BlockTree
      语句块的树节点。
      interface  BreakTree
      一个用于 break语句的树节点。
      interface  CaseTree
      一个 case树节点在一个 switch语句中。
      interface  CatchTree
      一个 catch块的树节点在一个 try语句中。
      interface  ClassTree
      用于类，接口，枚举或注释类型声明的树节点。
      interface  CompilationUnitTree
      表示编译单元（源文件）和程序包声明（package-info.java）的抽象语法树。
      interface  CompoundAssignmentTree
      复合赋值运算符的树节点。
      interface  ConditionalExpressionTree
      条件运算符的树节点？
      interface  ContinueTree
      一个 continue语句的树节点。
      interface  DirectiveTree
      对于ModuleTree中的所有指令的超类型。
      interface  DoWhileLoopTree
      一个用于 do语句的树节点。
      interface  EmptyStatementTree
      一个空（跳过）语句的树节点。
      interface  EnhancedForLoopTree
      一个树状节点用于“增强”的 for循环语句。
      interface  ErroneousTree
      一个树形节点，用于支撑格式不正确的表达式。
      interface  ExportsTree
      模块声明中的“exports”指令的树节点。
      interface  ExpressionStatementTree
      表达式语句的树节点。
      interface  ExpressionTree
      用作不同类型表达式的基类的树节点。
      interface  ForLoopTree
      一个树节点，用于基本的 for循环语句。
      interface  IdentifierTree
      标识符表达式的树节点。
      interface  IfTree
      一个用于 if语句的树节点。
      interface  ImportTree
      导入声明的树节点。
      interface  InstanceOfTree
      一个 instanceof表达式的树节点。
      interface  IntersectionTypeTree
      转换表达式中交叉路口类型的树节点。
      interface  LabeledStatementTree
      标记语句的树节点。
      interface  LambdaExpressionTree
      lambda表达式的树节点。
      interface  LiteralTree
      一个文字表达式的树结点。
      interface  MemberReferenceTree
      成员引用表达式的树节点。
      interface  MemberSelectTree
      成员访问表达式的树节点。
      interface  MethodInvocationTree
      方法调用表达式的树节点。
      interface  MethodTree
      用于方法或注释类型元素声明的树节点。
      interface  ModifiersTree
      用于声明的修饰符的树节点（包括注释）。
      interface  ModuleTree
      模块声明的树节点。
      interface  NewArrayTree
      用于创建数组的新实例的表达式的树节点。
      interface  NewClassTree
      一个树节点来声明一个类的新实例。
      interface  OpensTree
      模块声明中的“打开”指令的树节点。
      interface  PackageTree
      表示包声明。
      interface  ParameterizedTypeTree
      涉及类型参数的类型表达式的树节点。
      interface  ParenthesizedTree
      括号表达式的树节点。
      interface  PrimitiveTypeTree
      一个原始类型的树节点。
      interface  ProvidesTree
      模块声明中“提供”指令的树节点。
      interface  RequiresTree
      模块声明中“require”指令的树结点。
      interface  ReturnTree
      一个用于 return语句的树节点。
      interface  StatementTree
      用作不同类型语句的基类的树节点。
      interface  SwitchTree
      一个用于 switch语句的树节点。
      interface  SynchronizedTree
      一个用于 synchronized语句的树节点。
      interface  ThrowTree
      一个树结点为 throw语句。
      interface  TryTree
      一个用于 try语句的树节点。
      interface  TypeCastTree
      类型转换表达式的树节点。
      interface  TypeParameterTree
      类型参数的树节点。
      interface  UnaryTree
      用于后缀和一元表达式的树节点。
      interface  UnionTypeTree
      多重变量声明中的联合类型表达式的树节点。
      interface  UsesTree
      模块声明中的'uses'指令的树节点。
      interface  VariableTree
      用于变量声明的树节点。
      interface  WhileLoopTree
      一个用于 while循环语句的树节点。
      interface  WildcardTree
      用于通配符类型参数的树节点。
      Methods in com.sun.source.tree that return 树
      Modifier and Type 方法 描述
      树 AnnotationTree.getAnnotationType​()
      返回注释类型。
      树 LambdaExpressionTree.getBody​()
      返回lambda表达式的正文。
      树 WildcardTree.getBound​()
      返回通配符的边界。
      树 MethodTree.getDefaultValue​()
      返回默认值，如果这是注释类型声明中的元素。
      树 ClassTree.getExtendsClause​()
      返回此类型声明的超类型，如果没有提供，则返回 null 。
      树 ImportTree.getQualifiedIdentifier​()
      返回要导入的声明的合格标识符。
      树 MethodTree.getReturnType​()
      返回正在声明的方法的返回类型。
      树 ArrayTypeTree.getType​()
      返回此数组类型的元素类型。
      树 InstanceOfTree.getType​()
      返回要检查的类型。
      树 NewArrayTree.getType​()
      返回表达式的基本类型。
      树 ParameterizedTypeTree.getType​()
      返回基本类型。
      树 TypeCastTree.getType​()
      返回转换的目标类型。
      树 VariableTree.getType​()
      返回正在声明的变量的类型。
      Methods in com.sun.source.tree that return types with arguments of type 树
      Modifier and Type 方法 描述
      Class<? extends 树> Tree.Kind.asInterface​()
      返回使用这种类型的关联接口类型。
      List<? extends 树> IntersectionTypeTree.getBounds​()
      返回类型的边界。
      List<? extends 树> TypeParameterTree.getBounds​()
      返回type参数的边界。
      List<? extends 树> ErroneousTree.getErrorTrees​()
      返回保存在此节点中的任何树。
      List<? extends 树> ClassTree.getImplementsClause​()
      返回由此类型声明实现的接口。
      List<? extends 树> ClassTree.getMembers​()
      返回在此类型声明中声明的成员。
      List<? extends 树> TryTree.getResources​()
      返回 try语句中提供的任何资源声明。
      List<? extends 树> UnionTypeTree.getTypeAlternatives​()
      返回替代类型表达式。
      List<? extends 树> MethodInvocationTree.getTypeArguments​()
      返回此方法调用的类型参数。
      List<? extends 树> NewClassTree.getTypeArguments​()
      返回正在创建的对象的类型参数。
      List<? extends 树> ParameterizedTypeTree.getTypeArguments​()
      返回类型参数。
      List<? extends 树> CompilationUnitTree.getTypeDecls​()
      返回此编译单元中出现的类型声明。
      Methods in com.sun.source.tree with parameters of type 树
      Modifier and Type 方法 描述
      R TreeVisitor.visitOther​(树 node, P p)
      访问未知类型的树节点。

    • Uses of 树 in com.sun.source.util

      Methods in com.sun.source.util that return 树
      Modifier and Type 方法 描述
      树 TreePath.getLeaf​()
      返回此路径的叶节点。
      abstract 树 Trees.getTree​(Element element)
      返回给定元素的Tree节点。
      abstract 树 Trees.getTree​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的Tree节点。
      abstract 树 Trees.getTree​(Element e, AnnotationMirror a, AnnotationValue v)
      返回给定元素上AnnotationMirror的AnnotationValue的Tree节点。
      Methods in com.sun.source.util that return types with arguments of type 树
      Modifier and Type 方法 描述
      Iterator<树> TreePath.iterator​()
      从叶到叶重迭。
      Methods in com.sun.source.util with parameters of type 树
      Modifier and Type 方法 描述
      protected R SimpleTreeVisitor.defaultAction​(树 node, P p)
      所有访问方法使用的默认操作不被覆盖。
      long SourcePositions.getEndPosition​(CompilationUnitTree file, 树 tree)
      返回文件中树的结束位置。
      static TreePath TreePath.getPath​(CompilationUnitTree unit, 树 target)
      返回编译单元中树节点的树路径，如果未找到节点，则 null 。
      static TreePath TreePath.getPath​(TreePath path, 树 target)
      返回由TreePath对象标识的子树内的树节点的树路径。
      abstract TreePath Trees.getPath​(CompilationUnitTree unit, 树 node)
      返回指定编译单元中树节点的路径。
      long SourcePositions.getStartPosition​(CompilationUnitTree file, 树 tree)
      返回文件中树的起始位置。
      abstract void Trees.printMessage​(Diagnostic.Kind kind, CharSequence msg, 树 t, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息
      R TreePathScanner.scan​(树 tree, P p)
      扫描单个节点。
      R TreeScanner.scan​(树 tree, P p)
      扫描单个节点。
      R SimpleTreeVisitor.visit​(树 node, P p)
      调用特定于节点类型的适当访问方式。
      R SimpleTreeVisitor.visitOther​(树 node, P p)
      访问未知类型的树节点。
      R TreeScanner.visitOther​(树 node, P p)
      访问未知类型的树节点。
      Method parameters in com.sun.source.util with type arguments of type 树
      Modifier and Type 方法 描述
      abstract TypeMirror JavacTask.getTypeMirror​(Iterable<? extends 树> path)
      返回由指定路径确定的树节点的类型镜像。
      R TreeScanner.scan​(Iterable<? extends 树> nodes, P p)
      扫描一系列节点。
      R SimpleTreeVisitor.visit​(Iterable<? extends 树> nodes, P p)
      在每个节点序列上调用适当的访问方法。
      Constructors in com.sun.source.util with parameters of type 树
      Constructor 描述
      TreePath​(TreePath path, 树 tree)
      为子节点创建一个TreePath。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.TreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.TreeVisitor

  • Packages that use TreeVisitor
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TreeVisitor in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type TreeVisitor
      Modifier and Type 方法 描述
      <R,D> R Tree.accept​(TreeVisitor<R,D> visitor, D data)
      用于实现访问者模式的接受方法。

    • Uses of TreeVisitor in com.sun.source.util

      Classes in com.sun.source.util that implement TreeVisitor
      Modifier and Type Class 描述
      class  SimpleTreeVisitor<R,P>
      树节点的简单访问者。
      class  TreePathScanner<R,P>
      一个访问所有子树节点的TreeVisitor，并为维护父节点的路径提供支持。
      class  TreeScanner<R,P>
      访问所有子树节点的TreeVisitor。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.TryTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.TryTree

  • Packages that use TryTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TryTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type TryTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitTry​(TryTree node, P p)
      访问TryTree节点。

    • Uses of TryTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type TryTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitTry​(TryTree node, P p)
      访问TryTree节点。
      R TreeScanner.visitTry​(TryTree node, P p)
      访问TryTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.TypeCastTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.TypeCastTree

  • Packages that use TypeCastTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TypeCastTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type TypeCastTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitTypeCast​(TypeCastTree node, P p)
      访问TypeCastTree节点。

    • Uses of TypeCastTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type TypeCastTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitTypeCast​(TypeCastTree node, P p)
      访问TypeCastTree节点。
      R TreeScanner.visitTypeCast​(TypeCastTree node, P p)
      访问TypeCastTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.TypeParameterTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.TypeParameterTree

  • Packages that use TypeParameterTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TypeParameterTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type TypeParameterTree
      Modifier and Type 方法 描述
      List<? extends TypeParameterTree> ClassTree.getTypeParameters​()
      返回此类型声明的任何类型参数。
      List<? extends TypeParameterTree> MethodTree.getTypeParameters​()
      返回正在声明的方法的类型参数。
      Methods in com.sun.source.tree with parameters of type TypeParameterTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitTypeParameter​(TypeParameterTree node, P p)
      访问TypeParameterTree节点。

    • Uses of TypeParameterTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type TypeParameterTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitTypeParameter​(TypeParameterTree node, P p)
      访问TypeParameterTree节点。
      R TreeScanner.visitTypeParameter​(TypeParameterTree node, P p)
      Visits a TypeParameterTree node.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.UnaryTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.UnaryTree

  • Packages that use UnaryTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of UnaryTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type UnaryTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitUnary​(UnaryTree node, P p)
      访问UnaryTree节点。

    • Uses of UnaryTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type UnaryTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitUnary​(UnaryTree node, P p)
      访问UnaryTree节点。
      R TreeScanner.visitUnary​(UnaryTree node, P p)
      访问UnaryTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.UnionTypeTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.UnionTypeTree

  • Packages that use UnionTypeTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of UnionTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type UnionTypeTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitUnionType​(UnionTypeTree node, P p)
      访问UnionTypeTree节点。

    • Uses of UnionTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type UnionTypeTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitUnionType​(UnionTypeTree node, P p)
      访问UnionTypeTree节点。
      R TreeScanner.visitUnionType​(UnionTypeTree node, P p)
      访问UnionTypeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.UsesTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.UsesTree

  • Packages that use UsesTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of UsesTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type UsesTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitUses​(UsesTree node, P p)
      访问UsesTree节点。

    • Uses of UsesTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type UsesTree
      Modifier and Type | 方法 | 描述
      R | SimpleTreeVisitor.visitUses​(UsesTree node, P p)
      R | TreeScanner.visitUses​(UsesTree node, P p)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.VariableTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.VariableTree

  • Packages that use VariableTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of VariableTree in com.sun.source.tree

      Methods in com.sun.source.tree that return VariableTree
      Modifier and Type 方法 描述
      VariableTree CatchTree.getParameter​()
      返回catch变量。
      VariableTree MethodTree.getReceiverParameter​()
      返回一个显式的接收器参数（“this”参数），如果没有，则 null 。
      VariableTree EnhancedForLoopTree.getVariable​()
      返回循环的控制变量。
      Methods in com.sun.source.tree that return types with arguments of type VariableTree
      Modifier and Type 方法 描述
      List<? extends VariableTree> LambdaExpressionTree.getParameters​()
      返回此lambda表达式的参数。
      List<? extends VariableTree> MethodTree.getParameters​()
      返回正在声明的方法的参数。
      Methods in com.sun.source.tree with parameters of type VariableTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitVariable​(VariableTree node, P p)
      访问VariableTree节点。

    • Uses of VariableTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type VariableTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitVariable​(VariableTree node, P p)
      访问VariableTree节点。
      R TreeScanner.visitVariable​(VariableTree node, P p)
      访问VariableTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.WhileLoopTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.WhileLoopTree

  • Packages that use WhileLoopTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of WhileLoopTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type WhileLoopTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitWhileLoop​(WhileLoopTree node, P p)
      访问WhileLoopTree节点。

    • Uses of WhileLoopTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type WhileLoopTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitWhileLoop​(WhileLoopTree node, P p)
      访问WhileLoopTree节点。
      R TreeScanner.visitWhileLoop​(WhileLoopTree node, P p)
      访问WhileLoopTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.tree.WildcardTree (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.tree.WildcardTree

  • Packages that use WildcardTree
    软件包 描述
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of WildcardTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type WildcardTree
      Modifier and Type 方法 描述
      R TreeVisitor.visitWildcard​(WildcardTree node, P p)
      访问WildcardTypeTree节点。

    • Uses of WildcardTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type WildcardTree
      Modifier and Type 方法 描述
      R SimpleTreeVisitor.visitWildcard​(WildcardTree node, P p)
      访问WildcardTypeTree节点。
      R TreeScanner.visitWildcard​(WildcardTree node, P p)
      访问WildcardTypeTree节点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.source.util (Java SE 9 & JDK 9 )

com.sun.source.util

Interfaces

  • DocSourcePositions
  • DocTreeFactory
  • Plugin
  • SourcePositions
  • TaskListener

Classes

  • DocTreePath
  • DocTreePathScanner
  • DocTrees
  • DocTreeScanner
  • JavacTask
  • SimpleDocTreeVisitor
  • SimpleTreeVisitor
  • TaskEvent
  • TreePath
  • TreePathScanner
  • Trees
  • TreeScanner

Enums

  • TaskEvent.Kind


com.sun.source.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.compiler

Package com.sun.source.util

为抽象语法树（AST）的操作提供实用程序。
从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    DocSourcePositions
    提供在javadoc注释中获取DocTree的位置的方法。
    DocTreeFactory
    创建 DocTree节点的工厂。
    Plugin
    javac插件的接口。
    SourcePositions
    提供在CompilationUnit中获取树的位置的方法。
    TaskListener
    提供监听器来监视JDK Java编译器javac的活动。
  • 类摘要
    Class 描述
    DocTreePath
    树节点的路径，通常用于表示直到顶层DocCommentTree节点的树节点的祖先节点序列。
    DocTreePathScanner<R,P>
    访问所有子树节点的DocTreeVisitor，并为维护父节点的路径提供支持。
    DocTrees
    提供对文档注释的语法树的访问。
    DocTreeScanner<R,P>
    访问所有子树节点的TreeVisitor。
    JavacTask
    提供对JDK Java编译器javac特有的功能的访问。
    SimpleDocTreeVisitor<R,P>
    树节点的简单访问者。
    SimpleTreeVisitor<R,P>
    树节点的简单访问者。
    TaskEvent
    提供有关JDK Java Compiler（javac）完成的工作的详细信息。
    TreePath
    树节点的路径，通常用于表示树节点的祖先节点的序列，直到顶层的CompilationUnitTree节点。
    TreePathScanner<R,P>
    一个访问所有子树节点的TreeVisitor，并为维护父节点的路径提供支持。
    Trees
    Bridges JSR 199，JSR 269和Tree API。
    TreeScanner<R,P>
    访问所有子树节点的TreeVisitor。
  • 枚举摘要
    Enum 描述
    TaskEvent.Kind
    Kind of task event.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.source.util Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.source.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.source.util.DocTreePath (implements java.lang.Iterable<T>)
    • com.sun.source.util.DocTreeScanner<R,P> (implements com.sun.source.doctree.DocTreeVisitor<R,P>)
      • com.sun.source.util.DocTreePathScanner<R,P>
    • com.sun.source.util.JavacTask (implements javax.tools.JavaCompiler.CompilationTask)
    • com.sun.source.util.SimpleDocTreeVisitor<R,P> (implements com.sun.source.doctree.DocTreeVisitor<R,P>)
    • com.sun.source.util.SimpleTreeVisitor<R,P> (implements com.sun.source.tree.TreeVisitor<R,P>)
    • com.sun.source.util.TaskEvent
    • com.sun.source.util.TreePath (implements java.lang.Iterable<T>)
    • com.sun.source.util.Trees
      • com.sun.source.util.DocTrees
    • com.sun.source.util.TreeScanner<R,P> (implements com.sun.source.tree.TreeVisitor<R,P>)
      • com.sun.source.util.TreePathScanner<R,P>

Interface Hierarchy

  • com.sun.source.util.DocTreeFactory
  • com.sun.source.util.Plugin
  • com.sun.source.util.SourcePositions
    • com.sun.source.util.DocSourcePositions
  • com.sun.source.util.TaskListener

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.source.util.TaskEvent.Kind
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


DocSourcePositions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Interface DocSourcePositions

  • All Superinterfaces:
    SourcePositions

    public interface DocSourcePositions
extends SourcePositions
    提供在javadoc注释中获取DocTree的位置的方法。 一个位置被定义为从CompilationUnit开始的简单字符偏移量，其中第一个字符处于偏移量0。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getEndPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件中注释中树的结束位置。
      long getStartPosition​(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      返回文件内注释中树的起始位置。

      • Methods inherited from interface com.sun.source.util.SourcePositions

        getEndPosition, getStartPosition

    • 方法详细信息

      • getStartPosition

        long getStartPosition​(CompilationUnitTree file,
                      DocCommentTree comment,
                      DocTree tree)
        返回文件内注释中树的起始位置。 如果在文件中找不到树，或者如果起始位置不可用，请返回Diagnostic.NOPOS 。 给定的树应该在给定的注释树下，给定的文档注释树应该从给定文件下的树的DocTrees.getDocCommentTree(com.sun.source.util.TreePath)返回。 返回的位置必须在此树的屈服开始处，即对于此树的任何子树，以下必须成立：

        tree.getStartPosition() <= subtree.getStartPosition()或
        tree.getStartPosition() == NOPOS或
        subtree.getStartPosition() == NOPOS

        参数
        file - 在其中找到树的CompilationUnit。
        comment - 封闭正在寻找职位的树的注释树
        tree - 寻找职位的树。
        结果
        树的起始位置。

      • getEndPosition

        long getEndPosition​(CompilationUnitTree file,
                    DocCommentTree comment,
                    DocTree tree)
        返回文件中注释中树的结束位置。 如果在文件中找不到树，或者如果结束位置不可用，请返回Diagnostic.NOPOS 。 给定的树应该在给定的注释树下，给定的文档注释树应该从给定文件下的树中的DocTrees.getDocCommentTree(com.sun.source.util.TreePath)返回。 返回的位置必须在此树的结束处，即对于此树的任何子树，以下必须成立：

        tree.getEndPosition() >= subtree.getEndPosition()或
        tree.getEndPosition() == NOPOS或
        subtree.getEndPosition() == NOPOS

        另外，以下必须保持：

        tree.getStartPosition() <= tree.getEndPosition()或
        tree.getStartPosition() == NOPOS或
        tree.getEndPosition() == NOPOS

        参数
        file - 在其中查找树的CompilationUnit。
        comment - 封闭正在寻找职位的树的注释树
        tree - 寻找职位的树。
        结果
        树的起始位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocTreeFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Interface DocTreeFactory

  • public interface DocTreeFactory
    创建 DocTree节点的工厂。
    Implementation Note:
    该接口的实现中的方法只能接受由同一实现创建的 DocTree节点。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DocTreeFactory at​(int pos)
      设置要在此工厂创建的后续树节点中记录的位置。
      List<DocTree> getFirstSentence​(List<? extends DocTree> list)
      获取内容列表中的第一个句子。
      AttributeTree newAttributeTree​(Name name, AttributeTree.ValueKind vkind, List<? extends DocTree> value)
      创建一个新的 AttributeTree对象，以在HTML标签中表示HTML属性。
      AuthorTree newAuthorTree​(List<? extends DocTree> name)
      创建一个新的 AuthorTree对象，以表示一个 {@author }标签。
      LiteralTree newCodeTree​(TextTree text)
      创建一个新的 CodeTree对象，以表示一个 {@code }标签。
      CommentTree newCommentTree​(String text)
      创建一个新的 CommentTree ，以表示HTML注释。
      DeprecatedTree newDeprecatedTree​(List<? extends DocTree> text)
      创建一个新的 DeprecatedTree对象，以表示一个 {@deprecated }标签。
      DocCommentTree newDocCommentTree​(List<? extends DocTree> fullBody, List<? extends DocTree> tags)
      创建一个新的 DocCommentTree对象，以表示完整的文档注释。
      DocRootTree newDocRootTree​()
      创建一个新的 DocRootTree对象，以表示一个 {@docroot}标签。
      EndElementTree newEndElementTree​(Name name)
      创建一个新的 EndElement对象，以表示HTML元素的结尾。
      EntityTree newEntityTree​(Name name)
      创建一个新的 EntityTree对象，以表示一个HTML实体。
      ErroneousTree newErroneousTree​(String text, Diagnostic<JavaFileObject> diag)
      创建一个新的 ErroneousTree对象，来表示一些不可 ErroneousTree输入。
      ThrowsTree newExceptionTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ExceptionTree对象，以表示一个 @exception标签。
      HiddenTree newHiddenTree​(List<? extends DocTree> text)
      创建一个新的 HiddenTree对象，以表示一个 {@hidden }标签。
      IdentifierTree newIdentifierTree​(Name name)
      创建一个新的 IdentifierTree对象，以表示一个标识符，如 @param标签。
      IndexTree newIndexTree​(DocTree term, List<? extends DocTree> description)
      创建一个新的 IndexTree对象，以表示一个 {@index }标签。
      InheritDocTree newInheritDocTree​()
      创建一个新的 InheritDocTree对象，以表示一个 {@inheritDoc}标签。
      LinkTree newLinkPlainTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkPlainTree对象，以表示一个 {@linkplain }标签。
      LinkTree newLinkTree​(ReferenceTree ref, List<? extends DocTree> label)
      创建一个新的 LinkTree对象，以表示一个 {@link }标签。
      LiteralTree newLiteralTree​(TextTree text)
      创建一个新的 LiteralTree对象，以表示一个 {@literal }标签。
      ParamTree newParamTree​(boolean isTypeParameter, IdentifierTree name, List<? extends DocTree> description)
      创建一个新的 ParamTree对象，以表示一个 @param标签。
      ProvidesTree newProvidesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ProvidesTree对象，以表示一个 @provides标签。
      ReferenceTree newReferenceTree​(String signature)
      创建一个新的 ReferenceTree对象，以表示对API元素的引用。
      ReturnTree newReturnTree​(List<? extends DocTree> description)
      创建一个新的 ReturnTree对象，以表示一个 @return标签。
      SeeTree newSeeTree​(List<? extends DocTree> reference)
      创建一个新的 SeeTree对象，以表示一个 @see标签。
      SerialDataTree newSerialDataTree​(List<? extends DocTree> description)
      创建一个新的 SerialDataTree对象，以表示一个 @serialData标签。
      SerialFieldTree newSerialFieldTree​(IdentifierTree name, ReferenceTree type, List<? extends DocTree> description)
      创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
      SerialTree newSerialTree​(List<? extends DocTree> description)
      创建一个新的 SerialTree对象，以表示一个 @serial标签。
      SinceTree newSinceTree​(List<? extends DocTree> text)
      创建一个新的 SinceTree对象，以表示一个 @since标签。
      StartElementTree newStartElementTree​(Name name, List<? extends DocTree> attrs, boolean selfClosing)
      创建一个新的 StartElementTree对象，以表示HTML元素的开始。
      TextTree newTextTree​(String text)
      创建一个新的 TextTree对象，来表示一些纯文本。
      ThrowsTree newThrowsTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 ThrowsTree对象，以表示一个 @throws标签。
      UnknownBlockTagTree newUnknownBlockTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownBlockTagTree对象，以表示一个无法识别的块标签。
      UnknownInlineTagTree newUnknownInlineTagTree​(Name name, List<? extends DocTree> content)
      创建一个新的 UnknownInlineTagTree对象，以表示无法识别的内联标签。
      UsesTree newUsesTree​(ReferenceTree name, List<? extends DocTree> description)
      创建一个新的 UsesTree对象，以表示一个 @uses标签。
      ValueTree newValueTree​(ReferenceTree ref)
      创建一个新的 ValueTree对象，以表示一个 {@value }标签。
      VersionTree newVersionTree​(List<? extends DocTree> text)
      创建一个新的 VersionTree对象，以表示一个 {@version }标签。

    • 方法详细信息

      • newAttributeTree

        AttributeTree newAttributeTree​(Name name,
                               AttributeTree.ValueKind vkind,
                               List<? extends DocTree> value)
        创建一个新的 AttributeTree对象，以在HTML标签中表示HTML属性。
        参数
        name - 属性的名称
        vkind - 属性值的种类
        value - 属性的值（如果有）
        结果
        一个 AttributeTree对象

      • newAuthorTree

        AuthorTree newAuthorTree​(List<? extends DocTree> name)
        创建一个新的 AuthorTree对象，以表示一个 {@author }标签。
        参数
        name - 作者的名字
        结果
        一个 AuthorTree对象

      • newCodeTree

        LiteralTree newCodeTree​(TextTree text)
        创建一个新的 CodeTree对象，以表示一个 {@code }标签。
        参数
        text - 标签的内容
        结果
        一个 CodeTree对象

      • newCommentTree

        CommentTree newCommentTree​(String text)
        创建一个新的 CommentTree ，以表示HTML注释。
        参数
        text - 评论的内容
        结果
        一个 CommentTree对象

      • newDeprecatedTree

        DeprecatedTree newDeprecatedTree​(List<? extends DocTree> text)
        创建一个新的 DeprecatedTree对象，以表示一个 {@deprecated }标签。
        参数
        text - 标签的内容
        结果
        一个 DeprecatedTree对象

      • newDocCommentTree

        DocCommentTree newDocCommentTree​(List<? extends DocTree> fullBody,
                                 List<? extends DocTree> tags)
        创建一个新的 DocCommentTree对象，以表示完整的文档注释。
        参数
        fullBody - 整个身体的文档评论
        tags - 文档注释中的块标记
        结果
        一个 DocCommentTree对象

      • newDocRootTree

        DocRootTree newDocRootTree​()
        创建一个新的 DocRootTree对象，以表示一个 {@docroot}标签。
        结果
        一个 DocRootTree对象

      • newEndElementTree

        EndElementTree newEndElementTree​(Name name)
        创建一个新的 EndElement对象，以表示HTML元素的结尾。
        参数
        name - HTML元素的名称
        结果
        一个 EndElementTree对象

      • newEntityTree

        EntityTree newEntityTree​(Name name)
        创建一个新的 EntityTree对象，以表示一个HTML实体。
        参数
        name - 实体的名称，代表'<'和'之间的字符;' 在HTML文档中表示实体
        结果
        一个 EntityTree对象

      • newErroneousTree

        ErroneousTree newErroneousTree​(String text,
                               Diagnostic<JavaFileObject> diag)
        创建一个新的 ErroneousTree对象，以表示一些不可 ErroneousTree输入。
        参数
        text - 不可 text的文字
        diag - 与不可 diag文本关联的诊断，或null
        结果
        一个 ErroneousTree对象

      • newExceptionTree

        ThrowsTree newExceptionTree​(ReferenceTree name,
                            List<? extends DocTree> description)
        创建一个新的 ExceptionTree对象，以表示一个 @exception标签。
        参数
        name - 异常的名称
        description - 说明为什么可能抛出异常
        结果
        一个 ExceptionTree对象

      • newHiddenTree

        HiddenTree newHiddenTree​(List<? extends DocTree> text)
        创建一个新的 HiddenTree对象，以表示一个 {@hidden }标签。
        参数
        text - 标签的内容
        结果
        一个 HiddenTree对象

      • newIdentifierTree

        IdentifierTree newIdentifierTree​(Name name)
        创建一个新的 IdentifierTree对象，以表示一个标识符，如 @param标签。
        参数
        name - 标识符的名称
        结果
        一个 IdentifierTree对象

      • newIndexTree

        IndexTree newIndexTree​(DocTree term,
                       List<? extends DocTree> description)
        创建一个新的 IndexTree对象，以表示一个 {@index }标签。
        参数
        term - 搜索词
        description - 搜索项的可选描述
        结果
        一个 IndexTree对象

      • newInheritDocTree

        InheritDocTree newInheritDocTree​()
        创建一个新的 InheritDocTree对象，以表示一个 {@inheritDoc}标签。
        结果
        一个 InheritDocTree对象

      • newLinkTree

        LinkTree newLinkTree​(ReferenceTree ref,
                     List<? extends DocTree> label)
        创建一个新的 LinkTree对象，以表示一个 {@link }标签。
        参数
        ref - 引用的API元素
        label - 链接的可选标签
        结果
        一个 LinkTree对象

      • newLinkPlainTree

        LinkTree newLinkPlainTree​(ReferenceTree ref,
                          List<? extends DocTree> label)
        创建一个新的 LinkPlainTree对象，以表示一个 {@linkplain }标签。
        参数
        ref - 引用的API元素
        label - 链接的可选标签
        结果
        一个 LinkPlainTree对象

      • newLiteralTree

        LiteralTree newLiteralTree​(TextTree text)
        创建一个新的 LiteralTree对象，以表示一个 {@literal }标签。
        参数
        text - 标签的内容
        结果
        LiteralTree

      • newParamTree

        ParamTree newParamTree​(boolean isTypeParameter,
                       IdentifierTree name,
                       List<? extends DocTree> description)
        创建一个新的 ParamTree对象，以表示一个 @param标签。
        参数
        isTypeParameter - 如果这是一个类型参数， isTypeParameter true，否则为false
        name - 正在描述的参数
        description - 参数说明
        结果
        一个 ParamTree对象

      • newProvidesTree

        ProvidesTree newProvidesTree​(ReferenceTree name,
                             List<? extends DocTree> description)
        创建一个新的 ProvidesTree对象，以表示一个 @provides标签。
        参数
        name - 服务类型的名称
        description - 正在提供的服务的描述
        结果
        一个 ProvidesTree对象

      • newReferenceTree

        ReferenceTree newReferenceTree​(String signature)
        创建一个新的 ReferenceTree对象，以表示对API元素的引用。
        参数
        signature - 参考的文档注释签名
        结果
        一个 ReferenceTree对象

      • newReturnTree

        ReturnTree newReturnTree​(List<? extends DocTree> description)
        创建一个新的 ReturnTree对象，以表示一个 @return标签。
        参数
        description - 方法的返回值的描述
        结果
        一个 ReturnTree对象

      • newSeeTree

        SeeTree newSeeTree​(List<? extends DocTree> reference)
        创建一个新的 SeeTree对象，以表示一个 @see标签。
        参数
        reference - 参考
        结果
        一个 SeeTree对象

      • newSerialTree

        SerialTree newSerialTree​(List<? extends DocTree> description)
        创建一个新的 SerialTree对象，以表示一个 @serial标签。
        参数
        description - 标签的描述
        结果
        一个 SerialTree对象

      • newSerialDataTree

        SerialDataTree newSerialDataTree​(List<? extends DocTree> description)
        创建一个新的 SerialDataTree对象，以表示一个 @serialData标签。
        参数
        description - 标签的描述
        结果
        一个 SerialDataTree对象

      • newSerialFieldTree

        SerialFieldTree newSerialFieldTree​(IdentifierTree name,
                                   ReferenceTree type,
                                   List<? extends DocTree> description)
        创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
        参数
        name - 字段的名称
        type - 字段的类型
        description - 该字段的描述
        结果
        一个 SerialFieldTree对象

      • newSinceTree

        SinceTree newSinceTree​(List<? extends DocTree> text)
        创建一个新的 SinceTree对象，以表示一个 @since标签。
        参数
        text - 标签的内容
        结果
        一个 SinceTree对象

      • newStartElementTree

        StartElementTree newStartElementTree​(Name name,
                                     List<? extends DocTree> attrs,
                                     boolean selfClosing)
        创建一个新的 StartElementTree对象，以表示HTML元素的开始。
        参数
        name - HTML元素的名称
        attrs - 属性
        selfClosing - 如果start元素被标记为自动关闭， selfClosing true; 否则为虚假
        结果
        一个 StartElementTree对象

      • newTextTree

        TextTree newTextTree​(String text)
        创建一个新的 TextTree对象，来表示一些纯文本。
        参数
        text - 文字
        结果
        一个 TextTree对象

      • newThrowsTree

        ThrowsTree newThrowsTree​(ReferenceTree name,
                         List<? extends DocTree> description)
        创建一个新的 ThrowsTree对象，以表示一个 @throws标签。
        参数
        name - 异常的名称
        description - 为什么可能抛出异常的描述
        结果
        一个 ThrowsTree对象

      • newUnknownBlockTagTree

        UnknownBlockTagTree newUnknownBlockTagTree​(Name name,
                                           List<? extends DocTree> content)
        创建一个新的 UnknownBlockTagTree对象，以表示无法识别的块标签。
        参数
        name - 块标签的名称
        content - 内容
        结果
        一个 UnknownBlockTagTree对象

      • newUnknownInlineTagTree

        UnknownInlineTagTree newUnknownInlineTagTree​(Name name,
                                             List<? extends DocTree> content)
        创建一个新的 UnknownInlineTagTree对象，以表示无法识别的内联标签。
        参数
        name - 内联标签的名称
        content - 内容
        结果
        一个 UnknownInlineTagTree对象

      • newUsesTree

        UsesTree newUsesTree​(ReferenceTree name,
                     List<? extends DocTree> description)
        创建一个新的 UsesTree对象，以表示一个 @uses标签。
        参数
        name - 服务类型的名称
        description - 如何使用服务的说明
        结果
        一个 UsesTree对象

      • newValueTree

        ValueTree newValueTree​(ReferenceTree ref)
        创建一个新的 ValueTree对象，以表示一个 {@value }标签。
        参数
        ref - 对该值的引用
        结果
        一个 ValueTree对象

      • newVersionTree

        VersionTree newVersionTree​(List<? extends DocTree> text)
        创建一个新的 VersionTree对象，以表示一个 {@version }标签。
        参数
        text - 标签的内容
        结果
        一个 VersionTree对象

      • at

        DocTreeFactory at​(int pos)
        设置要在此工厂创建的后续树节点中记录的位置。 位置应该是相对于源文件开头的字符偏移量，或NOPOS 。
        参数
        pos - 的位置
        结果
        这个对象，方便链接方便

      • getFirstSentence

        List<DocTree> getFirstSentence​(List<? extends DocTree> list)
        获取内容列表中的第一个句子。 第一句的确定是具体的实现，可能涉及使用特定于区域的BreakIterator等启发式。 结果列表可以与输入列表共享一组共同的初始项目。
        参数
        list - 列表
        结果
        包含列表第一句的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocTreePath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class DocTreePath

  • java.lang.Object
    • com.sun.source.util.DocTreePath
  • All Implemented Interfaces:
    Iterable<DocTree>

    public class DocTreePath
extends Object
implements Iterable<DocTree>
    树节点的路径，通常用于表示直到顶层DocCommentTree节点的树节点的祖先节点序列。
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      DocTreePath​(DocTreePath p, DocTree t)
      为子节点创建DocTreePath。
      DocTreePath​(TreePath treePath, DocCommentTree t)
      为根节点创建DocTreePath。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DocCommentTree getDocComment​()
      返回与此路径相关联的DocCommentTree。
      DocTree getLeaf​()
      返回此路径的叶节点。
      DocTreePath getParentPath​()
      返回包围节点的路径，如果没有包围节点，则返回 null 。
      static DocTreePath getPath​(DocTreePath path, DocTree target)
      返回由DocTreePath对象标识的子树内的树节点的文档树路径，如果未找到该节点，则 null 。
      static DocTreePath getPath​(TreePath treePath, DocCommentTree doc, DocTree target)
      返回编译单元中树节点的文档树路径，如果未找到该节点，则 null 。
      TreePath getTreePath​()
      返回与此路径相关联的TreePath。
      Iterator<DocTree> iterator​()
      返回类型为 T元素的迭代器。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocTreePath

        public DocTreePath​(TreePath treePath,
                   DocCommentTree t)
        为根节点创建DocTreePath。
        参数
        treePath - 创建根节点的TreePath。
        t - DocCommentTree创建路径。

      • DocTreePath

        public DocTreePath​(DocTreePath p,
                   DocTree t)
        为子节点创建DocTreePath。
        参数
        p - 父节点
        t - 子节点

    • 方法详细信息

      • getPath

        public static DocTreePath getPath​(TreePath treePath,
                                  DocCommentTree doc,
                                  DocTree target)
        返回编译单元中树节点的文档树路径，如果未找到该节点，则 null 。
        参数
        treePath - 与该文档注释相关联的节点的路径
        doc - 与节点相关联的文档注释
        target - doc注释中的一个节点
        结果
        确定树中目标的路径

      • getPath

        public static DocTreePath getPath​(DocTreePath path,
                                  DocTree target)
        返回由DocTreePath对象标识的子树内的树节点的文档树路径，如果未找到节点，则 null 。
        参数
        path - 标识doc注释树中节点的路径
        target - 要位于给定节点内的节点
        结果
        标识目标节点的路径

      • getTreePath

        public TreePath getTreePath​()
        返回与此路径相关联的TreePath。
        结果
        该DocTreePath的TreePath

      • getDocComment

        public DocCommentTree getDocComment​()
        返回与此路径相关联的DocCommentTree。
        结果
        DocTreePath的DocCommentTree

      • getLeaf

        public DocTree getLeaf​()
        返回此路径的叶节点。
        结果
        该DocTreePath的DocTree

      • getParentPath

        public DocTreePath getParentPath​()
        返回包围节点的路径，如果没有包围节点，则返回 null 。
        结果
        父文件的DocTreePath

      • iterator

        public Iterator<DocTree> iterator​()
        说明从界面Iterable复制
        返回类型为 T元素的迭代器。
        Specified by:
        iterator在接口 Iterable<DocTree>
        结果
        一个迭代器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocTreePathScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class DocTreePathScanner<R,P>

  • java.lang.Object
    • com.sun.source.util.DocTreeScanner<R,P>
      • com.sun.source.util.DocTreePathScanner<R,P>
  • All Implemented Interfaces:
    DocTreeVisitor<R,P>

    public class DocTreePathScanner<R,P>
extends DocTreeScanner<R,P>
    访问所有子树节点的DocTreeVisitor，并为维护父节点的路径提供支持。 要访问特定类型的节点，只需覆盖相应的visitorXYZ方法即可。 在你的方法中，调用super.visitXYZ来访问后代节点。
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      DocTreePathScanner​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DocTreePath getCurrentPath​()
      返回由当前激活的一组扫描调用构建的节点的当前路径。
      R scan​(DocTree tree, P p)
      扫描单个节点。
      R scan​(DocTreePath path, P p)
      从树路径识别的位置扫描树。

      • Methods inherited from class com.sun.source.util.DocTreeScanner

        reduce, scan, visitAttribute, visitAuthor, visitComment, visitDeprecated, visitDocComment, visitDocRoot, visitEndElement, visitEntity, visitErroneous, visitHidden, visitIdentifier, visitIndex, visitInheritDoc, visitLink, visitLiteral, visitOther, visitParam, visitProvides, visitReference, visitReturn, visitSee, visitSerial, visitSerialData, visitSerialField, visitSince, visitStartElement, visitText, visitThrows, visitUnknownBlockTag, visitUnknownInlineTag, visitUses, visitValue, visitVersion

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocTreePathScanner

        public DocTreePathScanner​()

    • 方法详细信息

      • scan

        public R scan​(DocTreePath path,
              P p)
        从树路径识别的位置扫描树。
        参数
        path - 路径
        p - 要传递给访问者方法的值
        结果
        结果返回主访客方法

      • scan

        public R scan​(DocTree tree,
              P p)
        扫描单个节点。 在扫描的持续时间内更新当前路径。
        重写：
        scan在 DocTreeScanner<R,P>
        参数
        tree - 要扫描的树
        p - 要传递给访问者方法的值
        结果
        结果返回主访客方法

      • getCurrentPath

        public DocTreePath getCurrentPath​()
        返回由当前激活的一组扫描调用构建的节点的当前路径。
        结果
        当前路径
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocTrees (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class DocTrees

  • java.lang.Object
    • com.sun.source.util.Trees
      • com.sun.source.util.DocTrees

  • public abstract class DocTrees
extends Trees
    提供对文档注释的语法树的访问。
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      DocTrees​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract BreakIterator getBreakIterator​()
      返回用于计算文档注释第一句的break迭代器。
      abstract DocCommentTree getDocCommentTree​(TreePath path)
      返回由给定TreePath标识的Tree节点的doc注释树（如果有）。
      abstract DocCommentTree getDocCommentTree​(Element e)
      返回给定元素的文档注释树。
      abstract DocCommentTree getDocCommentTree​(Element e, String relativePath)
      返回相对于给定元素指定路径的给定文件的doc注释树。
      abstract DocCommentTree getDocCommentTree​(FileObject fileObject)
      返回给定文件的文档注释树。
      abstract DocTreeFactory getDocTreeFactory​()
      返回一个用于创建 DocTree对象的实用程序对象。
      abstract DocTreePath getDocTreePath​(FileObject fileObject, PackageElement packageElement)
      返回包含给定文件的文档注释树的文档树路径。
      abstract Element getElement​(DocTreePath path)
      返回给定的DocTreePath的叶节点引用的语言模型元素，如果未知的话null 。
      abstract List<DocTree> getFirstSentence​(List<? extends DocTree> list)
      返回表示评论第一句的DocTree的列表。
      abstract DocSourcePositions getSourcePositions​()
      返回用于访问文档树节点的源位置的实用程序对象。
      static DocTrees instance​(ProcessingEnvironment env)
      返回给定的ProcessingEnvironment的DocTrees对象。
      static DocTrees instance​(JavaCompiler.CompilationTask task)
      返回给定CompilationTask的DocTrees对象。
      abstract void printMessage​(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息
      abstract void setBreakIterator​(BreakIterator breakiterator)
      设置break迭代器来计算文档注释的第一个句子。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class com.sun.source.util.Trees

        getDocComment, getElement, getLub, getOriginalType, getPath, getPath, getPath, getPath, getScope, getTree, getTree, getTree, getTree, getTree, getTypeMirror, isAccessible, isAccessible, printMessage

    • 构造方法详细信息

      • DocTrees

        public DocTrees​()

    • 方法详细信息

      • instance

        public static DocTrees instance​(JavaCompiler.CompilationTask task)
        返回给定CompilationTask的DocTrees对象。
        参数
        task - 获取Trees对象的编译任务
        结果
        DocTrees对象
        异常
        IllegalArgumentException - 如果任务不支持Trees API。

      • instance

        public static DocTrees instance​(ProcessingEnvironment env)
        返回给定的ProcessingEnvironment的DocTrees对象。
        参数
        env - 为其获取Trees对象的处理环境
        结果
        DocTrees对象
        异常
        IllegalArgumentException - 如果env不支持Trees API。

      • getBreakIterator

        public abstract BreakIterator getBreakIterator​()
        返回用于计算文档注释第一句的break迭代器。 如果没有指定，则返回null 。
        结果
        中断迭代器
        从以下版本开始：
        9

      • getDocCommentTree

        public abstract DocCommentTree getDocCommentTree​(TreePath path)
        返回由给定TreePath标识的Tree节点的doc注释树（如果有）。 如果没有找到文档评论，则返回null 。
        参数
        path - 树节点的路径
        结果
        文档注释树

      • getDocCommentTree

        public abstract DocCommentTree getDocCommentTree​(Element e)
        返回给定元素的文档注释树。 如果没有找到文档评论，则返回null 。
        参数
        e - 需要文档的元素
        结果
        文档注释树
        从以下版本开始：
        9

      • getDocCommentTree

        public abstract DocCommentTree getDocCommentTree​(FileObject fileObject)
        返回给定文件的文档注释树。 文件必须是HTML文件，在这种情况下，文档注释树表示<body>标签的内容，任何封闭标签都将被忽略。 如果没有找到文档评论，则返回null 。 未来版本可能支持其他文件类型。
        参数
        fileObject - 内容容器
        结果
        文档注释树
        从以下版本开始：
        9

      • getDocCommentTree

        public abstract DocCommentTree getDocCommentTree​(Element e,
                                                 String relativePath)
                                          throws IOException
        返回相对于给定元素指定路径的给定文件的doc注释树。 文件必须是HTML文件，在这种情况下，文档注释树表示<body>标签的内容，任何封闭标签都将被忽略。 如果没有找到文档评论，则返回null 。 未来版本可能支持其他文件类型。
        参数
        e - 其路径用作参考的元素
        relativePath - 从元素的相对路径
        结果
        文档注释树
        异常
        IOException - 如果发生异常
        从以下版本开始：
        9

      • getDocTreePath

        public abstract DocTreePath getDocTreePath​(FileObject fileObject,
                                           PackageElement packageElement)
        返回包含给定文件的文档注释树的文档树路径。 该文件必须是HTML文件，在这种情况下，文档注释树表示<body>标记的内容，任何封闭标签都将被忽略。 任何对doc注释树中@see和{@link}标签中包含的源代码元素的引用将在给定的包元素的上下文中进行评估。 如果没有找到文档评论，则返回null 。
        参数
        fileObject - 封装HTML内容的文件对象
        packageElement - 与表示遗留package.html的给定文件对象关联的包元素，否则为空
        结果
        包含从给定文件解析的文档注释的文档树路径
        异常
        IllegalArgumentException - 如果fileObject不是HTML文件
        从以下版本开始：
        9

      • getElement

        public abstract Element getElement​(DocTreePath path)
        返回给定的DocTreePath的叶节点引用的语言模型元素，如果未知的话null 。
        参数
        path - 树节点的路径
        结果
        元素

      • getFirstSentence

        public abstract List<DocTree> getFirstSentence​(List<? extends DocTree> list)
        返回表示评论第一句的DocTree的列表。
        参数
        list - 要查询的DocTree列表
        结果
        第一句话
        从以下版本开始：
        9

      • getSourcePositions

        public abstract DocSourcePositions getSourcePositions​()
        返回用于访问文档树节点的源位置的实用程序对象。
        Specified by:
        getSourcePositions在 Trees
        结果
        实用程序对象

      • printMessage

        public abstract void printMessage​(Diagnostic.Kind kind,
                                  CharSequence msg,
                                  DocTree t,
                                  DocCommentTree c,
                                  CompilationUnitTree root)
        在提供的编译单元中的树的位置打印指定类型的消息
        参数
        kind - 消息的种类
        msg - 消息，或空字符串（如果没有）
        t - 树用作位置提示
        c - 用作位置提示的文档注释树
        root - 包含树的编译单元

      • setBreakIterator

        public abstract void setBreakIterator​(BreakIterator breakiterator)
        设置break迭代器来计算文档注释的第一个句子。
        参数
        breakiterator - 一个中断迭代器或者 null来指定默认的断句
        从以下版本开始：
        9

      • getDocTreeFactory

        public abstract DocTreeFactory getDocTreeFactory​()
        返回一个用于创建 DocTree对象的实用程序对象。
        结果
        一个用于创建 DocTree对象的实用程序对象
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DocTreeScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class DocTreeScanner<R,P>

  • java.lang.Object
    • com.sun.source.util.DocTreeScanner<R,P>
  • All Implemented Interfaces:
    DocTreeVisitor<R,P>
    已知直接子类：
    DocTreePathScanner

    public class DocTreeScanner<R,P>
extends Object
implements DocTreeVisitor<R,P>
    访问所有子树节点的TreeVisitor。 要访问特定类型的节点，只需覆盖相应的visitXYZ方法即可。 在你的方法中，调用super.visitXYZ来访问后代节点。

    visitXYZ方法的默认实现将确定如下的结果：

    • 如果被访问的节点没有子节点，结果将为null 。
    • 如果被访问的节点有一个孩子，结果将是该小孩的scan调用的结果。 孩子可能是一个简单的节点或本身的节点列表。
    • 如果所访问的节点有多个子节点，则通过依次调用每个子scan来确定结果，然后将第一次扫描的结果与迄今为止的累积结果相结合，由reduce(R, R)方法确定。 每个孩子可以是节点列表的简单节点。 reduce方法的默认行为是访问reduce方法的结果将是最后一个子扫描的结果。

    以下是一个示例来计算树中错误节点的数量：

      class CountErrors extends DocTreeScanner<Integer,Void> {
      @Override
      public Integer visitErroneous(ErroneousTree node, Void p) {
          return 1;
      }
      @Override
      public Integer reduce(Integer r1, Integer r2) {
          return (r1 == null ? 0 : r1) + (r2 == null ? 0 : r2);
      }
   }
    从以下版本开始：
    1.8

    • 构造方法摘要

      构造方法
      Constructor 描述
      DocTreeScanner​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      R reduce​(R r1, R r2)
      将两个结果减少为一个组合的结果。
      R scan​(DocTree node, P p)
      扫描单个节点。
      R scan​(Iterable<? extends DocTree> nodes, P p)
      扫描一系列节点。
      R visitAttribute​(AttributeTree node, P p)
      访问AttributeTree节点。
      R visitAuthor​(AuthorTree node, P p)
      访问AuthorTree节点。
      R visitComment​(CommentTree node, P p)
      访问CommentTree节点。
      R visitDeprecated​(DeprecatedTree node, P p)
      访问DeprecatedTree节点。
      R visitDocComment​(DocCommentTree node, P p)
      访问DocCommentTree节点。
      R visitDocRoot​(DocRootTree node, P p)
      访问DocRootTree节点。
      R visitEndElement​(EndElementTree node, P p)
      访问EndElementTree节点。
      R visitEntity​(EntityTree node, P p)
      访问EntityTree节点。
      R visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
      R visitHidden​(HiddenTree node, P p)
      访问HiddenTree节点。
      R visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R visitIndex​(IndexTree node, P p)
      访问IndexTree节点。
      R visitInheritDoc​(InheritDocTree node, P p)
      访问InheritDocTree节点。
      R visitLink​(LinkTree node, P p)
      访问LinkTree节点。
      R visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R visitOther​(DocTree node, P p)
      访问未知类型的DocTree节点。
      R visitParam​(ParamTree node, P p)
      访问ParamTree节点。
      R visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
      R visitReference​(ReferenceTree node, P p)
      访问一个ReferenceTree节点。
      R visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R visitSee​(SeeTree node, P p)
      访问SeeTree节点。
      R visitSerial​(SerialTree node, P p)
      访问SerialTree节点。
      R visitSerialData​(SerialDataTree node, P p)
      访问一个SerialDataTree节点。
      R visitSerialField​(SerialFieldTree node, P p)
      访问SerialFieldTree节点。
      R visitSince​(SinceTree node, P p)
      访问SinceTree节点。
      R visitStartElement​(StartElementTree node, P p)
      访问StartElementTree节点。
      R visitText​(TextTree node, P p)
      访问TextTree节点。
      R visitThrows​(ThrowsTree node, P p)
      访问ThrowsTree节点。
      R visitUnknownBlockTag​(UnknownBlockTagTree node, P p)
      访问UnknownBlockTagTree节点。
      R visitUnknownInlineTag​(UnknownInlineTagTree node, P p)
      访问UnknownInlineTagTree节点。
      R visitUses​(UsesTree node, P p)
      访问UsesTree节点。
      R visitValue​(ValueTree node, P p)
      访问ValueTree节点。
      R visitVersion​(VersionTree node, P p)
      访问VersionTreeTree节点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocTreeScanner

        public DocTreeScanner​()

    • 方法详细信息

      • scan

        public R scan​(DocTree node,
              P p)
        扫描单个节点。
        参数
        node - 要扫描的节点
        p - 传递给访问方法的参数值
        结果
        访问方式的结果值

      • scan

        public R scan​(Iterable<? extends DocTree> nodes,
              P p)
        扫描一系列节点。
        参数
        nodes - 要扫描的节点
        p - 要传递给每个节点的访问方法的参数值
        结果
        访问方法的组合返回值。 这些值使用reduce方法组合。

      • reduce

        public R reduce​(R r1,
                R r2)
        将两个结果减少为一个组合的结果。 默认的实现是返回第一个参数。 该方法的一般合同是它可以采取任何行动。
        参数
        r1 - 要组合的第一个值
        r2 - 要组合的第二个值
        结果
        结合两个参数的结果

      • visitAttribute

        public R visitAttribute​(AttributeTree node,
                        P p)
        访问AttributeTree节点。 此实现返回null 。
        Specified by:
        visitAttribute在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitAuthor

        public R visitAuthor​(AuthorTree node,
                     P p)
        访问AuthorTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitAuthor在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitComment

        public R visitComment​(CommentTree node,
                      P p)
        访问CommentTree节点。 此实现返回null 。
        Specified by:
        visitComment在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitDeprecated

        public R visitDeprecated​(DeprecatedTree node,
                         P p)
        访问DeprecatedTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitDeprecated在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitDocComment

        public R visitDocComment​(DocCommentTree node,
                         P p)
        访问DocCommentTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitDocComment在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitDocRoot

        public R visitDocRoot​(DocRootTree node,
                      P p)
        访问DocRootTree节点。 此实现返回null 。
        Specified by:
        visitDocRoot在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitEndElement

        public R visitEndElement​(EndElementTree node,
                         P p)
        访问EndElementTree节点。 此实现返回null 。
        Specified by:
        visitEndElement在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitEntity

        public R visitEntity​(EntityTree node,
                     P p)
        访问EntityTree节点。 此实现返回null 。
        Specified by:
        visitEntity在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitErroneous

        public R visitErroneous​(ErroneousTree node,
                        P p)
        访问ErroneousTree节点。 此实现返回null 。
        Specified by:
        visitErroneous接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitHidden

        public R visitHidden​(HiddenTree node,
                     P p)
        访问HiddenTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitHidden在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitIdentifier

        public R visitIdentifier​(IdentifierTree node,
                         P p)
        访问IdentifierTree节点。 此实现返回null 。
        Specified by:
        visitIdentifier在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitIndex

        public R visitIndex​(IndexTree node,
                    P p)
        访问IndexTree节点。 此实现返回null 。
        Specified by:
        visitIndex在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitInheritDoc

        public R visitInheritDoc​(InheritDocTree node,
                         P p)
        访问InheritDocTree节点。 此实现返回null 。
        Specified by:
        visitInheritDoc在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitLink

        public R visitLink​(LinkTree node,
                   P p)
        访问LinkTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitLink在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitLiteral

        public R visitLiteral​(LiteralTree node,
                      P p)
        访问LiteralTree节点。 此实现返回null 。
        Specified by:
        visitLiteral在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitParam

        public R visitParam​(ParamTree node,
                    P p)
        访问ParamTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitParam在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitProvides

        public R visitProvides​(ProvidesTree node,
                       P p)
        访问ProvideTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitProvides在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitReference

        public R visitReference​(ReferenceTree node,
                        P p)
        访问一个ReferenceTree节点。 此实现返回null 。
        Specified by:
        visitReference在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitReturn

        public R visitReturn​(ReturnTree node,
                     P p)
        访问ReturnTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitReturn在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitSee

        public R visitSee​(SeeTree node,
                  P p)
        访问SeeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitSee在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitSerial

        public R visitSerial​(SerialTree node,
                     P p)
        访问SerialTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitSerial在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p ：
        结果
        扫描的结果

      • visitSerialData

        public R visitSerialData​(SerialDataTree node,
                         P p)
        访问一个SerialDataTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitSerialData在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitSerialField

        public R visitSerialField​(SerialFieldTree node,
                          P p)
        访问SerialFieldTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitSerialField在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitSince

        public R visitSince​(SinceTree node,
                    P p)
        访问SinceTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitSince在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitStartElement

        public R visitStartElement​(StartElementTree node,
                           P p)
        访问StartElementTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitStartElement在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitText

        public R visitText​(TextTree node,
                   P p)
        访问TextTree节点。 此实现返回null 。
        Specified by:
        visitText在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitThrows

        public R visitThrows​(ThrowsTree node,
                     P p)
        访问ThrowsTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitThrows在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitUnknownBlockTag

        public R visitUnknownBlockTag​(UnknownBlockTagTree node,
                              P p)
        访问UnknownBlockTagTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitUnknownBlockTag在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitUnknownInlineTag

        public R visitUnknownInlineTag​(UnknownInlineTagTree node,
                               P p)
        访问UnknownInlineTagTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitUnknownInlineTag在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitUses

        public R visitUses​(UsesTree node,
                   P p)
        访问UsesTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitUses在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitValue

        public R visitValue​(ValueTree node,
                    P p)
        访问ValueTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitValue在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitVersion

        public R visitVersion​(VersionTree node,
                      P p)
        访问VersionTreeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitVersion在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitOther

        public R visitOther​(DocTree node,
                    P p)
        访问未知类型的DocTree节点。 如果标签集发生变化并将新类型的节点添加到DocTree层次结构中，则可能会发生这种情况。 此实现返回null 。
        Specified by:
        visitOther在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        the result of scanning
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JavacTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class JavacTask

  • java.lang.Object
    • com.sun.source.util.JavacTask
  • All Implemented Interfaces:
    Callable<Boolean> ， JavaCompiler.CompilationTask

    public abstract class JavacTask
extends Object
implements JavaCompiler.CompilationTask
    提供对JDK Java编译器javac特有的功能的访问。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      JavacTask​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void addTaskListener​(TaskListener taskListener)
      添加指定的侦听器，以便它接收到描述此编译任务进度的事件的通知。
      abstract Iterable<? extends Element> analyze​()
      完成所有分析。
      abstract Iterable<? extends JavaFileObject> generate​()
      生成代码。
      abstract Elements getElements​()
      返回用于处理程序元素的实用程序对象。
      abstract TypeMirror getTypeMirror​(Iterable<? extends 树> path)
      返回由指定路径确定的树节点的类型镜像。
      abstract Types getTypes​()
      返回用于处理类型镜像的实用程序对象。
      static JavacTask instance​(ProcessingEnvironment processingEnvironment)
      返回 JavacTask为 ProcessingEnvironment 。
      abstract Iterable<? extends CompilationUnitTree> parse​()
      解析指定的文件，返回抽象语法树列表。
      abstract void removeTaskListener​(TaskListener taskListener)
      删除指定的侦听器，使其不再收到描述此编译任务进度的事件的通知。
      abstract void setTaskListener​(TaskListener taskListener)
      设置指定的侦听器以接收描述此编译任务进度的事件的通知。

      • Methods inherited from interface javax.tools.JavaCompiler.CompilationTask

        addModules, call, setLocale, setProcessors

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JavacTask

        public JavacTask​()

    • 方法详细信息

      • instance

        public static JavacTask instance​(ProcessingEnvironment processingEnvironment)
        返回JavacTask为ProcessingEnvironment 。 如果使用CompilationTask调用编译器，那么该任务将被返回。
        参数
        processingEnvironment - 处理环境
        结果
        JavacTask为 ProcessingEnvironment
        从以下版本开始：
        1.8

      • parse

        public abstract Iterable<? extends CompilationUnitTree> parse​()
                                                       throws IOException
        解析指定的文件，返回抽象语法树列表。
        结果
        抽象语法树的列表
        异常
        IOException - 如果编译器中发生未处理的I / O错误。
        IllegalStateException - 如果此时无法执行操作。

      • analyze

        public abstract Iterable<? extends Element> analyze​()
                                             throws IOException
        完成所有分析。
        结果
        分析的元素列表
        异常
        IOException - 如果编译器中发生未处理的I / O错误。
        IllegalStateException - 如果此时无法执行操作。

      • generate

        public abstract Iterable<? extends JavaFileObject> generate​()
                                                     throws IOException
        生成代码。
        结果
        生成的文件列表
        异常
        IOException - 如果编译器中发生未处理的I / O错误。
        IllegalStateException - 如果此时无法执行操作。

      • setTaskListener

        public abstract void setTaskListener​(TaskListener taskListener)
        设置指定的侦听器以接收描述此编译任务进度的事件的通知。 如果另一个侦听器因此先前调用此方法而收到通知，则该侦听器将不再接收通知。 非正式地，此方法相当于为以前设置的任何侦听器调用removeTaskListener ，其次是新的侦听器的addTaskListener 。
        参数
        taskListener - 任务侦听器
        异常
        IllegalStateException - 如果指定的侦听器已经被添加。

      • addTaskListener

        public abstract void addTaskListener​(TaskListener taskListener)
        添加指定的侦听器，以便它接收到描述此编译任务进度的事件的通知。 可以在编译之前或期间的任何时间调用此方法。
        参数
        taskListener - 任务侦听器
        异常
        IllegalStateException - 如果指定的侦听器已经被添加。
        从以下版本开始：
        1.8

      • removeTaskListener

        public abstract void removeTaskListener​(TaskListener taskListener)
        删除指定的侦听器，使其不再收到描述此编译任务进度的事件的通知。 可以在编译之前或期间的任何时间调用此方法。
        参数
        taskListener - 任务侦听器
        从以下版本开始：
        1.8

      • getTypeMirror

        public abstract TypeMirror getTypeMirror​(Iterable<? extends 树> path)
        返回由指定路径确定的树节点的类型镜像。 该方法已被Trees的方法取代。
        参数
        path - 路径
        结果
        类型镜
        另请参见：
        Trees.getTypeMirror(com.sun.source.util.TreePath)

      • getElements

        public abstract Elements getElements​()
        返回用于处理程序元素的实用程序对象。
        结果
        用于处理程序元素的实用程序对象

      • getTypes

        public abstract Types getTypes​()
        返回用于处理类型镜像的实用程序对象。
        结果
        用于处理类型镜的实用程序对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Plugin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Interface Plugin

  • public interface Plugin
    javac插件的接口。

    javac插件机制允许用户在javac命令行上指定一个或多个插件，以便在编译开始后即刻启动。 插件由用户友好的名称标识。 启动的每个插件将被传递一个字符串数组，可以用来为插件提供任何所需选项或其他参数的值。

    插件通过ServiceLoader定位 ，使用与注释处理器相同的类路径（即ANNOTATION_PROCESSOR_PATH或-processorpath ）。

    预期典型的插件将简单地注册一个TaskListener ，以便在执行编译期间通知事件，其余的工作将由任务侦听器完成。

    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getName​()
      返回此插件的用户友好名称。
      void init​(JavacTask task, String... args)
      初始化给定编译任务的插件。

    • 方法详细信息

      • getName

        String getName​()
        返回此插件的用户友好名称。
        结果
        用户友好的插件名称

      • init

        void init​(JavacTask task,
          String... args)
        初始化给定编译任务的插件。
        参数
        task - 刚刚开始的编译任务
        args - 插件的参数（如果有）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SimpleDocTreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class SimpleDocTreeVisitor<R,P>

  • java.lang.Object
    • com.sun.source.util.SimpleDocTreeVisitor<R,P>
  • 参数类型
    R - 这个访问者的方法的返回类型。 对不需要返回结果的访问者使用Void 。
    P - 访问者的方法的附加参数的类型。 对不需要附加参数的访问者使用Void 。
    All Implemented Interfaces:
    DocTreeVisitor<R,P>

    public class SimpleDocTreeVisitor<R,P>
extends Object
implements DocTreeVisitor<R,P>
    树节点的简单访问者。
    从以下版本开始：
    1.8

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected R DEFAULT_VALUE
      默认值由 default action返回。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SimpleDocTreeVisitor​()
      创建访问者，DEFAULT_VALUE为 null 。
      protected SimpleDocTreeVisitor​(R defaultValue)
      创建一个具有指定DEFAULT_VALUE的访问者。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected R defaultAction​(DocTree node, P p)
      所有访问方法使用的默认操作不被覆盖。
      R visit​(DocTree node, P p)
      调用特定于节点类型的适当访问方式。
      R visit​(Iterable<? extends DocTree> nodes, P p)
      在每个节点序列上调用适当的访问方法。
      R visitAttribute​(AttributeTree node, P p)
      访问AttributeTree节点。
      R visitAuthor​(AuthorTree node, P p)
      访问AuthorTree节点。
      R visitComment​(CommentTree node, P p)
      访问CommentTree节点。
      R visitDeprecated​(DeprecatedTree node, P p)
      访问DeprecatedTree节点。
      R visitDocComment​(DocCommentTree node, P p)
      访问DocCommentTree节点。
      R visitDocRoot​(DocRootTree node, P p)
      访问DocRootTree节点。
      R visitEndElement​(EndElementTree node, P p)
      访问EndElementTree节点。
      R visitEntity​(EntityTree node, P p)
      访问EntityTree节点。
      R visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
      R visitHidden​(HiddenTree node, P p)
      访问HiddenTree节点。
      R visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R visitIndex​(IndexTree node, P p)
      访问IndexTree节点。
      R visitInheritDoc​(InheritDocTree node, P p)
      访问InheritDocTree节点。
      R visitLink​(LinkTree node, P p)
      访问LinkTree节点。
      R visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R visitOther​(DocTree node, P p)
      访问未知类型的DocTree节点。
      R visitParam​(ParamTree node, P p)
      访问ParamTree节点。
      R visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
      R visitReference​(ReferenceTree node, P p)
      访问一个ReferenceTree节点。
      R visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R visitSee​(SeeTree node, P p)
      访问SeeTree节点。
      R visitSerial​(SerialTree node, P p)
      访问SerialTree节点。
      R visitSerialData​(SerialDataTree node, P p)
      访问一个SerialDataTree节点。
      R visitSerialField​(SerialFieldTree node, P p)
      访问SerialFieldTree节点。
      R visitSince​(SinceTree node, P p)
      访问SinceTree节点。
      R visitStartElement​(StartElementTree node, P p)
      访问StartElementTree节点。
      R visitText​(TextTree node, P p)
      访问TextTree节点。
      R visitThrows​(ThrowsTree node, P p)
      访问ThrowsTree节点。
      R visitUnknownBlockTag​(UnknownBlockTagTree node, P p)
      访问UnknownBlockTagTree节点。
      R visitUnknownInlineTag​(UnknownInlineTagTree node, P p)
      访问UnknownInlineTagTree节点。
      R visitUses​(UsesTree node, P p)
      访问UsesTree节点。
      R visitValue​(ValueTree node, P p)
      访问ValueTree节点。
      R visitVersion​(VersionTree node, P p)
      访问VersionTreeTree节点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT_VALUE

        protected final R DEFAULT_VALUE
        默认值，由 default action返回。

    • 构造方法详细信息

      • SimpleDocTreeVisitor

        protected SimpleDocTreeVisitor​()
        创建访问者，DEFAULT_VALUE为 null 。

      • SimpleDocTreeVisitor

        protected SimpleDocTreeVisitor​(R defaultValue)
        创建一个具有指定DEFAULT_VALUE的访问者。
        参数
        defaultValue - 默认值返回的默认值。

    • 方法详细信息

      • defaultAction

        protected R defaultAction​(DocTree node,
                          P p)
        所有访问方法使用的默认操作不被覆盖。
        参数
        node - 被访问的节点
        p - 传递给访问方法的参数值
        结果
        从访问方法返回的结果值

      • visit

        public final R visit​(DocTree node,
                     P p)
        调用特定于节点类型的适当访问方式。
        参数
        node - 要发送的节点
        p - 要传递给相应访问方法的参数
        结果
        该值从适当的访问方法返回

      • visit

        public final R visit​(Iterable<? extends DocTree> nodes,
                     P p)
        在每个节点序列上调用适当的访问方法。
        参数
        nodes - 要发送的节点
        p - 要传递给每个适当的访问方法的参数值
        结果
        从最后访问方法返回的值，如果没有调用，则返回null。

      • visitAttribute

        public R visitAttribute​(AttributeTree node,
                        P p)
        访问AttributeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitAttribute在接口 DocTreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitAuthor

        public R visitAuthor​(AuthorTree node,
                     P p)
        访问AuthorTree节点。 此实现调用defaultAction 。
        Specified by:
        visitAuthor在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitComment

        public R visitComment​(CommentTree node,
                      P p)
        访问CommentTree节点。 此实现调用defaultAction 。
        Specified by:
        visitComment在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitDeprecated

        public R visitDeprecated​(DeprecatedTree node,
                         P p)
        访问DeprecatedTree节点。 此实现调用defaultAction 。
        Specified by:
        visitDeprecated在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitDocComment

        public R visitDocComment​(DocCommentTree node,
                         P p)
        访问DocCommentTree节点。 此实现调用defaultAction 。
        Specified by:
        visitDocComment在接口 DocTreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitDocRoot

        public R visitDocRoot​(DocRootTree node,
                      P p)
        访问DocRootTree节点。 此实现调用defaultAction 。
        Specified by:
        visitDocRoot在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitEndElement

        public R visitEndElement​(EndElementTree node,
                         P p)
        访问EndElementTree节点。 此实现调用defaultAction 。
        Specified by:
        visitEndElement在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitEntity

        public R visitEntity​(EntityTree node,
                     P p)
        访问EntityTree节点。 此实现调用defaultAction 。
        Specified by:
        visitEntity在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitErroneous

        public R visitErroneous​(ErroneousTree node,
                        P p)
        访问ErroneousTree节点。 此实现调用defaultAction 。
        Specified by:
        visitErroneous在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitHidden

        public R visitHidden​(HiddenTree node,
                     P p)
        访问HiddenTree节点。 此实现调用defaultAction 。
        Specified by:
        visitHidden接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitIdentifier

        public R visitIdentifier​(IdentifierTree node,
                         P p)
        访问IdentifierTree节点。 此实现调用defaultAction 。
        Specified by:
        visitIdentifier在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitIndex

        public R visitIndex​(IndexTree node,
                    P p)
        访问IndexTree节点。 此实现调用defaultAction 。
        Specified by:
        visitIndex在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitInheritDoc

        public R visitInheritDoc​(InheritDocTree node,
                         P p)
        访问InheritDocTree节点。 此实现调用defaultAction 。
        Specified by:
        visitInheritDoc在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitLink

        public R visitLink​(LinkTree node,
                   P p)
        访问LinkTree节点。 此实现调用defaultAction 。
        Specified by:
        visitLink在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitLiteral

        public R visitLiteral​(LiteralTree node,
                      P p)
        访问LiteralTree节点。 此实现调用defaultAction 。
        Specified by:
        visitLiteral在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitParam

        public R visitParam​(ParamTree node,
                    P p)
        访问ParamTree节点。 此实现调用defaultAction 。
        Specified by:
        visitParam在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitProvides

        public R visitProvides​(ProvidesTree node,
                       P p)
        访问ProvideTree节点。 此实现调用defaultAction 。
        Specified by:
        visitProvides在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitReference

        public R visitReference​(ReferenceTree node,
                        P p)
        访问一个ReferenceTree节点。 此实现调用defaultAction 。
        Specified by:
        visitReference在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitReturn

        public R visitReturn​(ReturnTree node,
                     P p)
        访问ReturnTree节点。 此实现调用defaultAction 。
        Specified by:
        visitReturn在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitSee

        public R visitSee​(SeeTree node,
                  P p)
        访问SeeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitSee在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitSerial

        public R visitSerial​(SerialTree node,
                     P p)
        访问SerialTree节点。 此实现调用defaultAction 。
        Specified by:
        visitSerial接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitSerialData

        public R visitSerialData​(SerialDataTree node,
                         P p)
        访问一个SerialDataTree节点。 此实现调用defaultAction 。
        Specified by:
        visitSerialData在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitSerialField

        public R visitSerialField​(SerialFieldTree node,
                          P p)
        访问SerialFieldTree节点。 此实现调用defaultAction 。
        Specified by:
        visitSerialField接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitSince

        public R visitSince​(SinceTree node,
                    P p)
        访问SinceTree节点。 此实现调用defaultAction 。
        Specified by:
        visitSince在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitStartElement

        public R visitStartElement​(StartElementTree node,
                           P p)
        访问StartElementTree节点。 此实现调用defaultAction 。
        Specified by:
        visitStartElement在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitText

        public R visitText​(TextTree node,
                   P p)
        访问TextTree节点。 此实现调用defaultAction 。
        Specified by:
        visitText在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitThrows

        public R visitThrows​(ThrowsTree node,
                     P p)
        访问ThrowsTree节点。 此实现调用defaultAction 。
        Specified by:
        visitThrows接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitUnknownBlockTag

        public R visitUnknownBlockTag​(UnknownBlockTagTree node,
                              P p)
        访问UnknownBlockTagTree节点。 此实现调用defaultAction 。
        Specified by:
        visitUnknownBlockTag在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitUnknownInlineTag

        public R visitUnknownInlineTag​(UnknownInlineTagTree node,
                               P p)
        访问UnknownInlineTagTree节点。 此实现调用defaultAction 。
        Specified by:
        visitUnknownInlineTag在接口 DocTreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitUses

        public R visitUses​(UsesTree node,
                   P p)
        访问UsesTree节点。 此实现调用defaultAction 。
        Specified by:
        visitUses在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitValue

        public R visitValue​(ValueTree node,
                    P p)
        访问ValueTree节点。 此实现调用defaultAction 。
        Specified by:
        visitValue在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitVersion

        public R visitVersion​(VersionTree node,
                      P p)
        访问VersionTreeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitVersion在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitOther

        public R visitOther​(DocTree node,
                    P p)
        访问未知类型的DocTree节点。 如果标签集发生变化并将新类型的节点添加到DocTree层次结构中，则可能会发生这种情况。 此实现调用defaultAction 。
        Specified by:
        visitOther在接口 DocTreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SimpleTreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class SimpleTreeVisitor<R,P>

  • java.lang.Object
    • com.sun.source.util.SimpleTreeVisitor<R,P>
  • 参数类型
    R - 这个访问者的方法的返回类型。 对不需要返回结果的访问者使用Void 。
    P - 此访问者方法的附加参数类型。 对不需要附加参数的访问者使用Void 。
    All Implemented Interfaces:
    TreeVisitor<R,P>

    public class SimpleTreeVisitor<R,P>
extends Object
implements TreeVisitor<R,P>
    树节点的简单访问者。
    从以下版本开始：
    1.6

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected R DEFAULT_VALUE
      默认值，由 default action返回。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected SimpleTreeVisitor​()
      创建访问者，DEFAULT_VALUE为 null 。
      protected SimpleTreeVisitor​(R defaultValue)
      创建一个具有指定DEFAULT_VALUE的访问者。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected R defaultAction​(树 node, P p)
      所有访问方法使用的默认操作不被覆盖。
      R visit​(树 node, P p)
      调用特定于节点类型的适当访问方式。
      R visit​(Iterable<? extends 树> nodes, P p)
      在每个节点序列上调用适当的访问方法。
      R visitAnnotatedType​(AnnotatedTypeTree node, P p)
      访问AnnotatedTypeTree节点。
      R visitAnnotation​(AnnotationTree node, P p)
      访问AnnotatedTree节点。
      R visitArrayAccess​(ArrayAccessTree node, P p)
      访问ArrayAccessTree节点。
      R visitArrayType​(ArrayTypeTree node, P p)
      访问ArrayTypeTree节点。
      R visitAssert​(AssertTree node, P p)
      访问AssertTree节点。
      R visitAssignment​(AssignmentTree node, P p)
      访问AssignmentTree节点。
      R visitBinary​(BinaryTree node, P p)
      访问二进制流节点。
      R visitBlock​(BlockTree node, P p)
      访问BlockTree节点。
      R visitBreak​(BreakTree node, P p)
      访问BreakTree节点。
      R visitCase​(CaseTree node, P p)
      访问CaseTree节点。
      R visitCatch​(CatchTree node, P p)
      访问CatchTree节点。
      R visitClass​(ClassTree node, P p)
      访问ClassTree节点。
      R visitCompilationUnit​(CompilationUnitTree node, P p)
      访问CompilationUnitTree节点。
      R visitCompoundAssignment​(CompoundAssignmentTree node, P p)
      访问一个CompoundAssignmentTree节点。
      R visitConditionalExpression​(ConditionalExpressionTree node, P p)
      访问一个ConditionalExpressionTree节点。
      R visitContinue​(ContinueTree node, P p)
      访问ContinueTree节点。
      R visitDoWhileLoop​(DoWhileLoopTree node, P p)
      访问DoWhileTree节点。
      R visitEmptyStatement​(EmptyStatementTree node, P p)
      访问一个EmptyStatementTree节点。
      R visitEnhancedForLoop​(EnhancedForLoopTree node, P p)
      访问EnhancedForLoopTree节点。
      R visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
      R visitExports​(ExportsTree node, P p)
      访问ExportsTree节点。
      R visitExpressionStatement​(ExpressionStatementTree node, P p)
      访问ExpressionStatementTree节点。
      R visitForLoop​(ForLoopTree node, P p)
      访问ForLoopTree节点。
      R visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R visitIf​(IfTree node, P p)
      访问IfTree节点。
      R visitImport​(ImportTree node, P p)
      访问ImportTree节点。
      R visitInstanceOf​(InstanceOfTree node, P p)
      访问InstanceOfTree节点。
      R visitIntersectionType​(IntersectionTypeTree node, P p)
      访问一个IntersectionTypeTree节点。
      R visitLabeledStatement​(LabeledStatementTree node, P p)
      访问LabeledStatementTree节点。
      R visitLambdaExpression​(LambdaExpressionTree node, P p)
      访问LambdaExpressionTree节点。
      R visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R visitMemberReference​(MemberReferenceTree node, P p)
      访问MemberReferenceTree节点。
      R visitMemberSelect​(MemberSelectTree node, P p)
      访问MemberSelectTree节点。
      R visitMethod​(MethodTree node, P p)
      访问MethodTree节点。
      R visitMethodInvocation​(MethodInvocationTree node, P p)
      访问MethodInvocationTree节点。
      R visitModifiers​(ModifiersTree node, P p)
      访问修饰符Tree节点。
      R visitModule​(ModuleTree node, P p)
      访问ModuleTree节点。
      R visitNewArray​(NewArrayTree node, P p)
      访问NewArrayTree节点。
      R visitNewClass​(NewClassTree node, P p)
      访问NewClassTree节点。
      R visitOpens​(OpensTree node, P p)
      访问OpensTree节点。
      R visitOther​(树 node, P p)
      访问未知类型的树节点。
      R visitPackage​(PackageTree node, P p)
      访问PackageTree节点。
      R visitParameterizedType​(ParameterizedTypeTree node, P p)
      访问ParameterizedTypeTree节点。
      R visitParenthesized​(ParenthesizedTree node, P p)
      访问ParenthesizedTree节点。
      R visitPrimitiveType​(PrimitiveTypeTree node, P p)
      访问PrimitiveTypeTree节点。
      R visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
      R visitRequires​(RequiresTree node, P p)
      访问RequiresTree节点。
      R visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R visitSwitch​(SwitchTree node, P p)
      访问SwitchTree节点。
      R visitSynchronized​(SynchronizedTree node, P p)
      访问SynchronizedTree节点。
      R visitThrow​(ThrowTree node, P p)
      访问ThrowTree节点
      R visitTry​(TryTree node, P p)
      访问TryTree节点。
      R visitTypeCast​(TypeCastTree node, P p)
      访问TypeCastTree节点。
      R visitTypeParameter​(TypeParameterTree node, P p)
      访问TypeParameterTree节点。
      R visitUnary​(UnaryTree node, P p)
      访问UnaryTree节点。
      R visitUnionType​(UnionTypeTree node, P p)
      访问UnionTypeTree节点。
      R visitUses​(UsesTree node, P p)
      访问UsesTree节点。
      R visitVariable​(VariableTree node, P p)
      访问VariableTree节点。
      R visitWhileLoop​(WhileLoopTree node, P p)
      访问WhileLoopTree节点。
      R visitWildcard​(WildcardTree node, P p)
      访问WildcardTypeTree节点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT_VALUE

        protected final R DEFAULT_VALUE
        默认值，由 default action返回。

    • 构造方法详细信息

      • SimpleTreeVisitor

        protected SimpleTreeVisitor​()
        创建访问者，DEFAULT_VALUE为 null 。

      • SimpleTreeVisitor

        protected SimpleTreeVisitor​(R defaultValue)
        创建一个具有指定DEFAULT_VALUE的访问者。
        参数
        defaultValue - 默认值返回的默认值。

    • 方法详细信息

      • defaultAction

        protected R defaultAction​(树 node,
                          P p)
        所有访问方法使用的默认操作不被覆盖。
        参数
        node - 被访问的节点
        p - 传递给访问方法的参数值
        结果
        从访问方法返回的结果值

      • visit

        public final R visit​(树 node,
                     P p)
        调用特定于节点类型的适当访问方式。
        参数
        node - 要发送的节点
        p - 要传递给相应访问方法的参数
        结果
        该值从适当的访问方法返回

      • visit

        public final R visit​(Iterable<? extends 树> nodes,
                     P p)
        在每个节点序列上调用适当的访问方法。
        参数
        nodes - 要发送的节点
        p - 要传递给每个适当的访问方法的参数值
        结果
        从最后访问方法返回的值，如果没有调用，则返回null。

      • visitCompilationUnit

        public R visitCompilationUnit​(CompilationUnitTree node,
                              P p)
        访问CompilationUnitTree节点。 此实现调用defaultAction 。
        Specified by:
        visitCompilationUnit在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitPackage

        public R visitPackage​(PackageTree node,
                      P p)
        访问PackageTree节点。 此实现调用defaultAction 。
        Specified by:
        visitPackage在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitImport

        public R visitImport​(ImportTree node,
                     P p)
        访问ImportTree节点。 此实现调用defaultAction 。
        Specified by:
        visitImport在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitClass

        public R visitClass​(ClassTree node,
                    P p)
        访问ClassTree节点。 此实现调用defaultAction 。
        Specified by:
        visitClass在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitMethod

        public R visitMethod​(MethodTree node,
                     P p)
        访问MethodTree节点。 此实现调用defaultAction 。
        Specified by:
        visitMethod在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitVariable

        public R visitVariable​(VariableTree node,
                       P p)
        访问VariableTree节点。 此实现调用defaultAction 。
        Specified by:
        visitVariable在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitEmptyStatement

        public R visitEmptyStatement​(EmptyStatementTree node,
                             P p)
        访问一个EmptyStatementTree节点。 此实现调用defaultAction 。
        Specified by:
        visitEmptyStatement在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitBlock

        public R visitBlock​(BlockTree node,
                    P p)
        访问BlockTree节点。 此实现调用defaultAction 。
        Specified by:
        visitBlock在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitDoWhileLoop

        public R visitDoWhileLoop​(DoWhileLoopTree node,
                          P p)
        访问DoWhileTree节点。 此实现调用defaultAction 。
        Specified by:
        visitDoWhileLoop在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitWhileLoop

        public R visitWhileLoop​(WhileLoopTree node,
                        P p)
        访问WhileLoopTree节点。 此实现调用defaultAction 。
        Specified by:
        visitWhileLoop在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitForLoop

        public R visitForLoop​(ForLoopTree node,
                      P p)
        访问ForLoopTree节点。 此实现调用defaultAction 。
        Specified by:
        visitForLoop在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitEnhancedForLoop

        public R visitEnhancedForLoop​(EnhancedForLoopTree node,
                              P p)
        访问EnhancedForLoopTree节点。 此实现调用defaultAction 。
        Specified by:
        visitEnhancedForLoop在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitLabeledStatement

        public R visitLabeledStatement​(LabeledStatementTree node,
                               P p)
        访问LabeledStatementTree节点。 此实现调用defaultAction 。
        Specified by:
        visitLabeledStatement在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitSwitch

        public R visitSwitch​(SwitchTree node,
                     P p)
        访问SwitchTree节点。 此实现调用defaultAction 。
        Specified by:
        visitSwitch在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitCase

        public R visitCase​(CaseTree node,
                   P p)
        访问CaseTree节点。 此实现调用defaultAction 。
        Specified by:
        visitCase在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitSynchronized

        public R visitSynchronized​(SynchronizedTree node,
                           P p)
        访问SynchronizedTree节点。 此实现调用defaultAction 。
        Specified by:
        visitSynchronized在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitTry

        public R visitTry​(TryTree node,
                  P p)
        访问TryTree节点。 此实现调用defaultAction 。
        Specified by:
        visitTry在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitCatch

        public R visitCatch​(CatchTree node,
                    P p)
        访问CatchTree节点。 此实现调用defaultAction 。
        Specified by:
        visitCatch在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitConditionalExpression

        public R visitConditionalExpression​(ConditionalExpressionTree node,
                                    P p)
        访问一个ConditionalExpressionTree节点。 此实现调用defaultAction 。
        Specified by:
        visitConditionalExpression在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitIf

        public R visitIf​(IfTree node,
                 P p)
        访问IfTree节点。 此实现调用defaultAction 。
        Specified by:
        visitIf在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitExpressionStatement

        public R visitExpressionStatement​(ExpressionStatementTree node,
                                  P p)
        访问ExpressionStatementTree节点。 此实现调用defaultAction 。
        Specified by:
        visitExpressionStatement在接口 TreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitBreak

        public R visitBreak​(BreakTree node,
                    P p)
        访问BreakTree节点。 此实现调用defaultAction 。
        Specified by:
        visitBreak在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitContinue

        public R visitContinue​(ContinueTree node,
                       P p)
        访问ContinueTree节点。 此实现调用defaultAction 。
        Specified by:
        visitContinue在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitReturn

        public R visitReturn​(ReturnTree node,
                     P p)
        访问ReturnTree节点。 此实现调用defaultAction 。
        Specified by:
        visitReturn在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitThrow

        public R visitThrow​(ThrowTree node,
                    P p)
        访问ThrowTree节点 此实现调用defaultAction 。
        Specified by:
        visitThrow在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitAssert

        public R visitAssert​(AssertTree node,
                     P p)
        访问AssertTree节点。 此实现调用defaultAction 。
        Specified by:
        visitAssert在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitMethodInvocation

        public R visitMethodInvocation​(MethodInvocationTree node,
                               P p)
        访问MethodInvocationTree节点。 此实现调用defaultAction 。
        Specified by:
        visitMethodInvocation在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitNewClass

        public R visitNewClass​(NewClassTree node,
                       P p)
        访问NewClassTree节点。 此实现调用defaultAction 。
        Specified by:
        visitNewClass在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitNewArray

        public R visitNewArray​(NewArrayTree node,
                       P p)
        访问NewArrayTree节点。 此实现调用defaultAction 。
        Specified by:
        visitNewArray在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitLambdaExpression

        public R visitLambdaExpression​(LambdaExpressionTree node,
                               P p)
        访问LambdaExpressionTree节点。 此实现调用defaultAction 。
        Specified by:
        visitLambdaExpression在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitParenthesized

        public R visitParenthesized​(ParenthesizedTree node,
                            P p)
        访问ParenthesizedTree节点。 此实现调用defaultAction 。
        Specified by:
        visitParenthesized在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitAssignment

        public R visitAssignment​(AssignmentTree node,
                         P p)
        访问AssignmentTree节点。 此实现调用defaultAction 。
        Specified by:
        visitAssignment在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitCompoundAssignment

        public R visitCompoundAssignment​(CompoundAssignmentTree node,
                                 P p)
        访问一个CompoundAssignmentTree节点。 此实现调用defaultAction 。
        Specified by:
        visitCompoundAssignment在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitUnary

        public R visitUnary​(UnaryTree node,
                    P p)
        访问UnaryTree节点。 此实现调用defaultAction 。
        Specified by:
        visitUnary在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitBinary

        public R visitBinary​(BinaryTree node,
                     P p)
        访问二进制流节点。 此实现调用defaultAction 。
        Specified by:
        visitBinary在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitTypeCast

        public R visitTypeCast​(TypeCastTree node,
                       P p)
        访问TypeCastTree节点。 此实现调用defaultAction 。
        Specified by:
        visitTypeCast在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitInstanceOf

        public R visitInstanceOf​(InstanceOfTree node,
                         P p)
        访问InstanceOfTree节点。 此实现调用defaultAction 。
        Specified by:
        visitInstanceOf在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitArrayAccess

        public R visitArrayAccess​(ArrayAccessTree node,
                          P p)
        访问ArrayAccessTree节点。 此实现调用defaultAction 。
        Specified by:
        visitArrayAccess在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitMemberSelect

        public R visitMemberSelect​(MemberSelectTree node,
                           P p)
        访问MemberSelectTree节点。 此实现调用defaultAction 。
        Specified by:
        visitMemberSelect在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitMemberReference

        public R visitMemberReference​(MemberReferenceTree node,
                              P p)
        访问MemberReferenceTree节点。 此实现调用defaultAction 。
        Specified by:
        visitMemberReference在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitIdentifier

        public R visitIdentifier​(IdentifierTree node,
                         P p)
        访问IdentifierTree节点。 此实现调用defaultAction 。
        Specified by:
        visitIdentifier在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitLiteral

        public R visitLiteral​(LiteralTree node,
                      P p)
        访问LiteralTree节点。 此实现调用defaultAction 。
        Specified by:
        visitLiteral在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitPrimitiveType

        public R visitPrimitiveType​(PrimitiveTypeTree node,
                            P p)
        访问PrimitiveTypeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitPrimitiveType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitArrayType

        public R visitArrayType​(ArrayTypeTree node,
                        P p)
        访问ArrayTypeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitArrayType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitParameterizedType

        public R visitParameterizedType​(ParameterizedTypeTree node,
                                P p)
        访问ParameterizedTypeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitParameterizedType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitUnionType

        public R visitUnionType​(UnionTypeTree node,
                        P p)
        访问UnionTypeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitUnionType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        结果为 defaultAction

      • visitIntersectionType

        public R visitIntersectionType​(IntersectionTypeTree node,
                               P p)
        访问一个IntersectionTypeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitIntersectionType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitTypeParameter

        public R visitTypeParameter​(TypeParameterTree node,
                            P p)
        访问TypeParameterTree节点。 此实现调用defaultAction 。
        Specified by:
        visitTypeParameter在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitWildcard

        public R visitWildcard​(WildcardTree node,
                       P p)
        访问WildcardTypeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitWildcard在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitModifiers

        public R visitModifiers​(ModifiersTree node,
                        P p)
        访问修饰符Tree节点。 此实现调用defaultAction 。
        Specified by:
        visitModifiers在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitAnnotation

        public R visitAnnotation​(AnnotationTree node,
                         P p)
        访问AnnotatedTree节点。 此实现调用defaultAction 。
        Specified by:
        visitAnnotation在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitAnnotatedType

        public R visitAnnotatedType​(AnnotatedTypeTree node,
                            P p)
        访问AnnotatedTypeTree节点。 此实现调用defaultAction 。
        Specified by:
        visitAnnotatedType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction

      • visitModule

        public R visitModule​(ModuleTree node,
                     P p)
        描述从接口TreeVisitor复制
        访问ModuleTree节点。
        Specified by:
        visitModule在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitExports

        public R visitExports​(ExportsTree node,
                      P p)
        描述从接口TreeVisitor复制
        访问ExportsTree节点。
        Specified by:
        visitExports在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitOpens

        public R visitOpens​(OpensTree node,
                    P p)
        描述从接口TreeVisitor复制
        访问OpensTree节点。
        Specified by:
        visitOpens在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitProvides

        public R visitProvides​(ProvidesTree node,
                       P p)
        描述从接口TreeVisitor复制
        访问ProvideTree节点。
        Specified by:
        visitProvides在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitRequires

        public R visitRequires​(RequiresTree node,
                       P p)
        描述从接口TreeVisitor复制
        访问RequiresTree节点。
        Specified by:
        visitRequires在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitUses

        public R visitUses​(UsesTree node,
                   P p)
        描述从接口TreeVisitor复制
        访问UsesTree节点。
        Specified by:
        visitUses在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitErroneous

        public R visitErroneous​(ErroneousTree node,
                        P p)
        说明从接口TreeVisitor复制
        访问ErroneousTree节点。
        Specified by:
        visitErroneous在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitOther

        public R visitOther​(树 node,
                    P p)
        访问未知类型的树节点。 如果语言发展并且将新类型的节点添加到树层次结构中，则可能会发生这种情况。 此实现调用defaultAction 。
        Specified by:
        visitOther在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果为 defaultAction
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SourcePositions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Interface SourcePositions

  • All Known Subinterfaces:
    DocSourcePositions

    public interface SourcePositions
    提供在CompilationUnit中获取树的位置的方法。 一个位置被定义为从CompilationUnit开始的简单字符偏移量，其中第一个字符处于偏移量0。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getEndPosition​(CompilationUnitTree file, 树 tree)
      返回文件中树的结束位置。
      long getStartPosition​(CompilationUnitTree file, 树 tree)
      返回文件中树的起始位置。

    • 方法详细信息

      • getStartPosition

        long getStartPosition​(CompilationUnitTree file,
                      树 tree)
        返回文件中树的起始位置。 如果在文件中找不到树，或者如果起始位置不可用，请返回Diagnostic.NOPOS 。 返回的位置必须在此树的屈服开始处，即对于此树的任何子树，以下必须成立：

        tree.getStartPosition() <= subtree.getStartPosition()或
        tree.getStartPosition() == NOPOS或
        subtree.getStartPosition() == NOPOS

        参数
        file - 在其中找到树的CompilationUnit。
        tree - 寻找职位的树。
        结果
        树的起始位置。

      • getEndPosition

        long getEndPosition​(CompilationUnitTree file,
                    树 tree)
        返回文件中树的结束位置。 如果文件中没有找到树，或者如果结束位置不可用，请返回Diagnostic.NOPOS 。 返回的位置必须在此树的结束处，即对于此树的任何子树，以下必须成立：

        tree.getEndPosition() >= subtree.getEndPosition()或
        tree.getEndPosition() == NOPOS或
        subtree.getEndPosition() == NOPOS

        另外，以下必须保持：

        tree.getStartPosition() <= tree.getEndPosition()或
        tree.getStartPosition() == NOPOS或
        tree.getEndPosition() == NOPOS

        参数
        file - 在其中查找树的CompilationUnit。
        tree - 寻找职位的树。
        结果
        the end position of tree.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TaskEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class TaskEvent

  • java.lang.Object
    • com.sun.source.util.TaskEvent

  • public final class TaskEvent
extends Object
    提供有关JDK Java Compiler（javac）完成的工作的详细信息。
    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TaskEvent.Kind
      种类的任务事件。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TaskEvent​(TaskEvent.Kind kind)
      为特定类型创建任务事件。
      TaskEvent​(TaskEvent.Kind kind, CompilationUnitTree unit)
      为给定类型和编译单元创建任务事件。
      TaskEvent​(TaskEvent.Kind kind, CompilationUnitTree unit, TypeElement clazz)
      为给定类型，编译单位和类型元素创建任务事件。
      TaskEvent​(TaskEvent.Kind kind, JavaFileObject sourceFile)
      为给定种类和源文件创建任务事件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CompilationUnitTree getCompilationUnit​()
      返回此事件的编译单位。
      TaskEvent.Kind getKind​()
      返回此事件的种类。
      JavaFileObject getSourceFile​()
      返回此事件的源文件。
      TypeElement getTypeElement​()
      返回此事件的type元素。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TaskEvent

        public TaskEvent​(TaskEvent.Kind kind)
        为特定类型创建任务事件。 源文件，编译单元和类型元素都设置为null 。
        参数
        kind - 事件的种类

      • TaskEvent

        public TaskEvent​(TaskEvent.Kind kind,
                 JavaFileObject sourceFile)
        为给定种类和源文件创建任务事件。 编译单元和类型元素都设置为null 。
        参数
        kind - 事件的种类
        sourceFile - 源文件

      • TaskEvent

        public TaskEvent​(TaskEvent.Kind kind,
                 CompilationUnitTree unit)
        为给定类型和编译单元创建任务事件。 源文件从编译单元设置，type元素设置为null 。
        参数
        kind - 事件的种类
        unit - 编译单元

      • TaskEvent

        public TaskEvent​(TaskEvent.Kind kind,
                 CompilationUnitTree unit,
                 TypeElement clazz)
        为给定类型，编译单位和类型元素创建任务事件。 源文件是从编译单元设置的。
        参数
        kind - 事件的种类
        unit - 编译单元
        clazz - 类型元素

    • 方法详细信息

      • getKind

        public TaskEvent.Kind getKind​()
        返回此事件的种类。
        结果
        那种

      • getSourceFile

        public JavaFileObject getSourceFile​()
        返回此事件的源文件。 可能是null 。
        结果
        源文件

      • getCompilationUnit

        public CompilationUnitTree getCompilationUnit​()
        返回此事件的编译单位。 可能是null 。
        结果
        汇编单位

      • getTypeElement

        public TypeElement getTypeElement​()
        返回此事件的type元素。 可能是null 。
        结果
        类型元素

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TaskEvent.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Enum TaskEvent.Kind

  • java.lang.Object
    • java.lang.Enum<TaskEvent.Kind>
      • com.sun.source.util.TaskEvent.Kind
  • All Implemented Interfaces:
    Serializable ， Comparable<TaskEvent.Kind>
    Enclosing class:
    TaskEvent

    public static enum TaskEvent.Kind
extends Enum<TaskEvent.Kind>
    种类的任务事件。
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ANALYZE
      关于被分析错误的元素的事件。
      ANNOTATION_PROCESSING
      关于整体注解处理的事件。
      ANNOTATION_PROCESSING_ROUND
      关于个别注解处理轮次的事件。
      COMPILATION
      在解析第一个源文件之前发送，并在写入最后一个输出文件之后发送。
      ENTER
      关于进入元素的事件。
      GENERATE
      对于正在生成类文件的事件。
      PARSE
      对于与解析文件有关的事件。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TaskEvent.Kind valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TaskEvent.Kind[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PARSE

        public static final TaskEvent.Kind PARSE
        对于与解析文件有关的事件。

      • ENTER

        public static final TaskEvent.Kind ENTER
        关于进入元素的事件。

      • ANALYZE

        public static final TaskEvent.Kind ANALYZE
        关于被分析错误的元素的事件。

      • GENERATE

        public static final TaskEvent.Kind GENERATE
        对于正在生成类文件的事件。

      • ANNOTATION_PROCESSING

        public static final TaskEvent.Kind ANNOTATION_PROCESSING
        关于整体注解处理的事件。

      • ANNOTATION_PROCESSING_ROUND

        public static final TaskEvent.Kind ANNOTATION_PROCESSING_ROUND
        关于个别注解处理轮次的事件。

      • COMPILATION

        public static final TaskEvent.Kind COMPILATION
        在解析第一个源文件之前发送，并在写入最后一个输出文件之后发送。 使用时，不发送此事件JavacTask.parse() ， JavacTask.analyze()或者JavacTask.generate() 。
        从以下版本开始：
        9

    • 方法详细信息

      • values

        public static TaskEvent.Kind[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TaskEvent.Kind c : TaskEvent.Kind.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TaskEvent.Kind valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


TaskListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Interface TaskListener

  • public interface TaskListener
    提供监听器来监视JDK Java编译器javac的活动。
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 Default Methods
      Modifier and Type 方法 描述
      default void finished​(TaskEvent e)
      事件完成后调用。
      default void started​(TaskEvent e)
      事件开始时调用。

    • 方法详细信息

      • started

        default void started​(TaskEvent e)
        事件开始时调用。
        实现要求：
        这种方法的默认实现什么都不做。
        参数
        e - 事件

      • finished

        default void finished​(TaskEvent e)
        事件完成后调用。
        实现要求：
        这种方法的默认实现什么都不做。
        参数
        e - 事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TreePath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class TreePath

  • java.lang.Object
    • com.sun.source.util.TreePath
  • All Implemented Interfaces:
    Iterable<树>

    public class TreePath
extends Object
implements Iterable<树>
    树节点的路径，通常用于表示树节点的祖先节点的序列，直到顶层的CompilationUnitTree节点。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreePath​(CompilationUnitTree node)
      为根节点创建一个TreePath。
      TreePath​(TreePath path, 树 tree)
      为子节点创建一个TreePath。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CompilationUnitTree getCompilationUnit​()
      返回与此路径关联的编译单元。
      树 getLeaf​()
      返回此路径的叶节点。
      TreePath getParentPath​()
      返回包围节点的路径，如果没有包围节点，则返回 null 。
      static TreePath getPath​(CompilationUnitTree unit, 树 target)
      返回编译单元中树节点的树路径，如果未找到该节点，则 null 。
      static TreePath getPath​(TreePath path, 树 target)
      返回由TreePath对象标识的子树内的树节点的树路径。
      Iterator<树> iterator​()
      从叶到叶重迭。

      • Methods inherited from interface java.lang.Iterable

        forEach, spliterator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TreePath

        public TreePath​(CompilationUnitTree node)
        为根节点创建一个TreePath。
        参数
        node - 根节点

      • TreePath

        public TreePath​(TreePath path,
                树 tree)
        为子节点创建一个TreePath。
        参数
        path - 父路径
        tree - 子节点

    • 方法详细信息

      • getPath

        public static TreePath getPath​(CompilationUnitTree unit,
                               树 target)
        返回编译单元中树节点的树路径，如果未找到该节点，则 null 。
        参数
        unit - 要搜索的编译单元
        target - 要定位的节点
        结果
        树路径

      • getPath

        public static TreePath getPath​(TreePath path,
                               树 target)
        返回由TreePath对象标识的子树内的树节点的树路径。 如果找不到节点，则返回null 。
        参数
        path - 要搜索的路径
        target - 要查找的节点
        结果
        目标节点的树路径

      • getCompilationUnit

        public CompilationUnitTree getCompilationUnit​()
        返回与此路径关联的编译单元。
        结果
        汇编单位

      • getLeaf

        public 树 getLeaf​()
        返回此路径的叶节点。
        结果
        叶节点

      • getParentPath

        public TreePath getParentPath​()
        返回包围节点的路径，如果没有包围节点，则返回 null 。
        结果
        封闭节点的路径

      • iterator

        public Iterator<树> iterator​()
        从叶到叶重迭。
        Specified by:
        iterator在接口 Iterable<树>
        结果
        一个迭代器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TreePathScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class TreePathScanner<R,P>

  • java.lang.Object
    • com.sun.source.util.TreeScanner<R,P>
      • com.sun.source.util.TreePathScanner<R,P>
  • All Implemented Interfaces:
    TreeVisitor<R,P>

    public class TreePathScanner<R,P>
extends TreeScanner<R,P>
    一个访问所有子树节点的TreeVisitor，并为维护父节点的路径提供支持。 要访问特定类型的节点，只需覆盖相应的visitorXYZ方法即可。 在你的方法中，调用super.visitXYZ来访问后代节点。
    API Note:
    为了初始化“当前路径”，扫描必须通过调用 scan方法之一来启动。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreePathScanner​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TreePath getCurrentPath​()
      返回由当前激活的一组扫描调用构建的节点的当前路径。
      R scan​(树 tree, P p)
      扫描单个节点。
      R scan​(TreePath path, P p)
      从树路径识别的位置扫描树。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class com.sun.source.util.TreeScanner

        reduce, scan, visitAnnotatedType, visitAnnotation, visitArrayAccess, visitArrayType, visitAssert, visitAssignment, visitBinary, visitBlock, visitBreak, visitCase, visitCatch, visitClass, visitCompilationUnit, visitCompoundAssignment, visitConditionalExpression, visitContinue, visitDoWhileLoop, visitEmptyStatement, visitEnhancedForLoop, visitErroneous, visitExports, visitExpressionStatement, visitForLoop, visitIdentifier, visitIf, visitImport, visitInstanceOf, visitIntersectionType, visitLabeledStatement, visitLambdaExpression, visitLiteral, visitMemberReference, visitMemberSelect, visitMethod, visitMethodInvocation, visitModifiers, visitModule, visitNewArray, visitNewClass, visitOpens, visitOther, visitPackage, visitParameterizedType, visitParenthesized, visitPrimitiveType, visitProvides, visitRequires, visitReturn, visitSwitch, visitSynchronized, visitThrow, visitTry, visitTypeCast, visitTypeParameter, visitUnary, visitUnionType, visitUses, visitVariable, visitWhileLoop, visitWildcard

    • 构造方法详细信息

      • TreePathScanner

        public TreePathScanner​()

    • 方法详细信息

      • scan

        public R scan​(TreePath path,
              P p)
        从树路径识别的位置扫描树。
        参数
        path - 标识要扫描的节点的路径
        p - 传递给访问方法的参数值
        结果
        访问方式的结果值

      • scan

        public R scan​(树 tree,
              P p)
        扫描单个节点。 在扫描的持续时间内更新当前路径。
        重写：
        scan在 TreeScanner<R,P>
        API Note:
        这种方法通常只能由扫描仪的visit方法调用，作为由scan(TreePath, P)发起的正在进行的扫描的一部分 。 一个例外是也可以调用它来启动CompilationUnitTree的全面扫描。
        参数
        tree - 要扫描的节点
        p - 传递给访问方法的参数值
        结果
        访问方式的结果值

      • getCurrentPath

        public TreePath getCurrentPath​()
        返回由当前激活的一组扫描调用构建的节点的当前路径。
        结果
        the current path
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Trees (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class Trees

  • java.lang.Object
    • com.sun.source.util.Trees
  • 已知直接子类：
    DocTrees

    public abstract class Trees
extends Object
    Bridges JSR 199，JSR 269和Tree API。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Trees​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract String getDocComment​(TreePath path)
      返回给定TreePath标识的Tree节点的doc注释（如果有）。
      abstract Element getElement​(TreePath path)
      返回给定TreePath标识的Tree节点的元素。
      abstract TypeMirror getLub​(CatchTree tree)
      返回在catch子句中声明的异常参数的lub。
      abstract TypeMirror getOriginalType​(ErrorType errorType)
      从ErrorType对象返回原始类型。
      abstract TreePath getPath​(CompilationUnitTree unit, 树 node)
      返回指定编译单元中树节点的路径。
      abstract TreePath getPath​(Element e)
      返回给定元素的TreePath节点。
      abstract TreePath getPath​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的TreePath节点。
      abstract TreePath getPath​(Element e, AnnotationMirror a, AnnotationValue v)
      返回指定元素上AnnotationMirror的AnnotationValue的TreePath节点。
      abstract Scope getScope​(TreePath path)
      返回给定TreePath标识的Tree节点的范围。
      abstract SourcePositions getSourcePositions​()
      返回用于获取源位置的实用程序对象。
      abstract 树 getTree​(Element element)
      返回给定元素的Tree节点。
      abstract 树 getTree​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的Tree节点。
      abstract 树 getTree​(Element e, AnnotationMirror a, AnnotationValue v)
      返回给定元素上AnnotationMirror的AnnotationValue的Tree节点。
      abstract MethodTree getTree​(ExecutableElement method)
      返回给定ExecutableElement的MethodTree节点。
      abstract ClassTree getTree​(TypeElement element)
      返回给定TypeElement的ClassTree节点。
      abstract TypeMirror getTypeMirror​(TreePath path)
      返回给定TreePath标识的Tree节点的TypeMirror。
      static Trees instance​(ProcessingEnvironment env)
      返回给定ProcessingEnvironment的Trees对象。
      static Trees instance​(JavaCompiler.CompilationTask task)
      返回给定CompilationTask的Trees对象。
      abstract boolean isAccessible​(Scope scope, Element member, DeclaredType type)
      检查给定元素是否可以作为给定范围内给定类型的成员访问。
      abstract boolean isAccessible​(Scope scope, TypeElement type)
      检查给定范围内是否可访问给定类型。
      abstract void printMessage​(Diagnostic.Kind kind, CharSequence msg, 树 t, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Trees

        public Trees​()

    • 方法详细信息

      • instance

        public static Trees instance​(JavaCompiler.CompilationTask task)
        返回给定CompilationTask的Trees对象。
        参数
        task - 获取Trees对象的编译任务
        结果
        树对象
        异常
        IllegalArgumentException - 如果任务不支持Trees API。

      • instance

        public static Trees instance​(ProcessingEnvironment env)
        返回给定ProcessingEnvironment的Trees对象。
        参数
        env - 获取“树”对象的处理环境
        结果
        树对象
        异常
        IllegalArgumentException - 如果env不支持Trees API。

      • getSourcePositions

        public abstract SourcePositions getSourcePositions​()
        返回用于获取源位置的实用程序对象。
        结果
        用于获取源位置的实用程序对象

      • getTree

        public abstract 树 getTree​(Element element)
        返回给定元素的Tree节点。 如果无法找到节点，则返回null 。
        参数
        element - 元素
        结果
        树节点

      • getTree

        public abstract ClassTree getTree​(TypeElement element)
        返回给定TypeElement的ClassTree节点。 如果无法找到节点，则返回null 。
        参数
        element - 元素
        结果
        类树节点

      • getTree

        public abstract MethodTree getTree​(ExecutableElement method)
        返回给定ExecutableElement的MethodTree节点。 如果无法找到节点，则返回null 。
        参数
        method - 可执行元素
        结果
        方法树节点

      • getTree

        public abstract 树 getTree​(Element e,
                             AnnotationMirror a)
        返回给定元素上的AnnotationMirror的Tree节点。 如果无法找到节点，则返回null 。
        参数
        e - 元素
        a - 注解镜
        结果
        树节点

      • getTree

        public abstract 树 getTree​(Element e,
                             AnnotationMirror a,
                             AnnotationValue v)
        返回给定元素上AnnotationMirror的AnnotationValue的Tree节点。 如果无法找到节点，则返回null 。
        参数
        e - 元素
        a - 注解镜
        v - 注释值
        结果
        树节点

      • getPath

        public abstract TreePath getPath​(CompilationUnitTree unit,
                                 树 node)
        返回指定编译单元中树节点的路径。
        参数
        unit - 编译单元
        node - 树节点
        结果
        树路径

      • getPath

        public abstract TreePath getPath​(Element e)
        返回给定元素的TreePath节点。 如果无法找到节点，则返回null 。
        参数
        e - 元素
        结果
        树路径

      • getPath

        public abstract TreePath getPath​(Element e,
                                 AnnotationMirror a)
        返回给定元素上的AnnotationMirror的TreePath节点。 如果无法找到该节点，则返回null 。
        参数
        e - 元素
        a - 注释镜
        结果
        树路径

      • getPath

        public abstract TreePath getPath​(Element e,
                                 AnnotationMirror a,
                                 AnnotationValue v)
        返回指定元素上AnnotationMirror的AnnotationValue的TreePath节点。 如果无法找到节点，则返回null 。
        参数
        e - 元素
        a - 注解镜
        v - 注释值
        结果
        树路径

      • getElement

        public abstract Element getElement​(TreePath path)
        返回给定TreePath标识的Tree节点的元素。 如果元素不可用，则返回null 。
        参数
        path - 树路径
        结果
        元素
        异常
        IllegalArgumentException - TreePath不能识别可能具有关联元素的Tree节点。

      • getTypeMirror

        public abstract TypeMirror getTypeMirror​(TreePath path)
        返回给定TreePath标识的Tree节点的TypeMirror。 如果TypeMirror不可用，则返回null 。
        参数
        path - 树路径
        结果
        类型镜
        异常
        IllegalArgumentException - TreePath不能识别可能具有关联的TypeMirror的Tree节点。

      • getScope

        public abstract Scope getScope​(TreePath path)
        返回给定TreePath标识的Tree节点的范围。 如果范围不可用，则返回null 。
        参数
        path - 树路径
        结果
        范围

      • getDocComment

        public abstract String getDocComment​(TreePath path)
        返回给定TreePath标识的Tree节点的doc注释（如果有）。 如果没有找到文档评论，则返回null 。
        参数
        path - 树路径
        结果
        文档评论
        另请参见：
        DocTrees.getDocCommentTree(TreePath)

      • isAccessible

        public abstract boolean isAccessible​(Scope scope,
                                     TypeElement type)
        检查给定范围内是否可访问给定类型。
        参数
        scope - 要检查的范围
        type - 要检查的类型
        结果
        如果可以访问 type则为true

      • isAccessible

        public abstract boolean isAccessible​(Scope scope,
                                     Element member,
                                     DeclaredType type)
        检查给定元素是否可以作为给定范围内给定类型的成员访问。
        参数
        scope - 要检查的范围
        member - 要检查的会员
        type - 检查该成员是否可访问的类型
        结果
        如果在 member可访问 type ， type

      • getOriginalType

        public abstract TypeMirror getOriginalType​(ErrorType errorType)
        从ErrorType对象返回原始类型。
        参数
        errorType - 我们要获取原始类型的errorType。
        结果
        javax.lang.model.type.TypeMirror对应于原始类型，由ErrorType替换。

      • printMessage

        public abstract void printMessage​(Diagnostic.Kind kind,
                                  CharSequence msg,
                                  树 t,
                                  CompilationUnitTree root)
        在提供的编译单元中的树的位置打印指定类型的消息
        参数
        kind - 那种消息
        msg - 消息，或空字符串（如果没有）
        t - 用作位置提示的树
        root - 包含树的编译单元

      • getLub

        public abstract TypeMirror getLub​(CatchTree tree)
        返回在catch子句中声明的异常参数的lub。
        参数
        tree - catch子句的树
        结果
        异常参数的lub
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TreeScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.source.util

Class TreeScanner<R,P>

  • java.lang.Object
    • com.sun.source.util.TreeScanner<R,P>
  • 参数类型
    R - 这个访问者的方法的返回类型。 对不需要返回结果的访问者使用Void 。
    P - 访问者方法的附加参数的类型。 对不需要附加参数的访问者使用Void 。
    All Implemented Interfaces:
    TreeVisitor<R,P>
    已知直接子类：
    TreePathScanner

    public class TreeScanner<R,P>
extends Object
implements TreeVisitor<R,P>
    访问所有子树节点的TreeVisitor。 要访问特定类型的节点，只需覆盖相应的visitXYZ方法即可。 在你的方法中，调用super.visitXYZ来访问后代节点。

    visitXYZ方法的默认实现将确定如下的结果：

    • 如果正在访问的节点没有子节点，结果将为null 。
    • 如果正在访问的节点有一个孩子，结果将是该小孩的scan调用的结果。 孩子可能是一个简单的节点或本身的节点列表。
    • 如果所访问的节点有多个子节点，则通过依次调用每个子scan来确定结果，然后将第一次扫描的结果与迄今为止的累积结果相结合，由reduce(R, R)方法确定。 每个孩子可以是节点列表的简单节点。 reduce方法的默认行为是访问reduce方法的结果将是最后一个子扫描的结果。

    以下是一个树中标识符节点数量的示例：

      class CountIdentifiers extends TreeScanner<Integer,Void> {
      @Override
      public Integer visitIdentifier(IdentifierTree node, Void p) {
          return 1;
      }
      @Override
      public Integer reduce(Integer r1, Integer r2) {
          return (r1 == null ? 0 : r1) + (r2 == null ? 0 : r2);
      }
   }
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      TreeScanner​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      R reduce​(R r1, R r2)
      将两个结果减少为一个组合的结果。
      R scan​(树 tree, P p)
      扫描单个节点。
      R scan​(Iterable<? extends 树> nodes, P p)
      扫描一系列节点。
      R visitAnnotatedType​(AnnotatedTypeTree node, P p)
      访问AnnotatedTypeTree节点。
      R visitAnnotation​(AnnotationTree node, P p)
      访问AnnotatedTree节点。
      R visitArrayAccess​(ArrayAccessTree node, P p)
      访问ArrayAccessTree节点。
      R visitArrayType​(ArrayTypeTree node, P p)
      访问ArrayTypeTree节点。
      R visitAssert​(AssertTree node, P p)
      访问AssertTree节点。
      R visitAssignment​(AssignmentTree node, P p)
      访问AssignmentTree节点。
      R visitBinary​(BinaryTree node, P p)
      访问二进制流节点。
      R visitBlock​(BlockTree node, P p)
      访问BlockTree节点。
      R visitBreak​(BreakTree node, P p)
      访问BreakTree节点。
      R visitCase​(CaseTree node, P p)
      访问CaseTree节点。
      R visitCatch​(CatchTree node, P p)
      访问CatchTree节点。
      R visitClass​(ClassTree node, P p)
      访问ClassTree节点。
      R visitCompilationUnit​(CompilationUnitTree node, P p)
      访问CompilationUnitTree节点。
      R visitCompoundAssignment​(CompoundAssignmentTree node, P p)
      访问一个CompoundAssignmentTree节点。
      R visitConditionalExpression​(ConditionalExpressionTree node, P p)
      访问一个ConditionalExpressionTree节点。
      R visitContinue​(ContinueTree node, P p)
      访问ContinueTree节点。
      R visitDoWhileLoop​(DoWhileLoopTree node, P p)
      访问DoWhileTree节点。
      R visitEmptyStatement​(EmptyStatementTree node, P p)
      访问一个EmptyStatementTree节点。
      R visitEnhancedForLoop​(EnhancedForLoopTree node, P p)
      访问EnhancedForLoopTree节点。
      R visitErroneous​(ErroneousTree node, P p)
      访问ErroneousTree节点。
      R visitExports​(ExportsTree node, P p)
      访问ExportsTree节点。
      R visitExpressionStatement​(ExpressionStatementTree node, P p)
      访问ExpressionStatementTree节点。
      R visitForLoop​(ForLoopTree node, P p)
      访问ForLoopTree节点。
      R visitIdentifier​(IdentifierTree node, P p)
      访问IdentifierTree节点。
      R visitIf​(IfTree node, P p)
      访问IfTree节点。
      R visitImport​(ImportTree node, P p)
      访问ImportTree节点。
      R visitInstanceOf​(InstanceOfTree node, P p)
      访问InstanceOfTree节点。
      R visitIntersectionType​(IntersectionTypeTree node, P p)
      访问一个IntersectionTypeTree节点。
      R visitLabeledStatement​(LabeledStatementTree node, P p)
      访问LabeledStatementTree节点。
      R visitLambdaExpression​(LambdaExpressionTree node, P p)
      访问LambdaExpressionTree节点。
      R visitLiteral​(LiteralTree node, P p)
      访问LiteralTree节点。
      R visitMemberReference​(MemberReferenceTree node, P p)
      访问MemberReferenceTree节点。
      R visitMemberSelect​(MemberSelectTree node, P p)
      访问MemberSelectTree节点。
      R visitMethod​(MethodTree node, P p)
      访问MethodTree节点。
      R visitMethodInvocation​(MethodInvocationTree node, P p)
      访问MethodInvocationTree节点。
      R visitModifiers​(ModifiersTree node, P p)
      访问修饰符Tree节点。
      R visitModule​(ModuleTree node, P p)
      访问ModuleTree节点。
      R visitNewArray​(NewArrayTree node, P p)
      访问NewArrayTree节点。
      R visitNewClass​(NewClassTree node, P p)
      访问NewClassTree节点。
      R visitOpens​(OpensTree node, P p)
      访问OpensTree节点。
      R visitOther​(树 node, P p)
      访问未知类型的树节点。
      R visitPackage​(PackageTree node, P p)
      访问PackageTree节点。
      R visitParameterizedType​(ParameterizedTypeTree node, P p)
      访问ParameterizedTypeTree节点。
      R visitParenthesized​(ParenthesizedTree node, P p)
      访问ParenthesizedTree节点。
      R visitPrimitiveType​(PrimitiveTypeTree node, P p)
      访问PrimitiveTypeTree节点。
      R visitProvides​(ProvidesTree node, P p)
      访问ProvideTree节点。
      R visitRequires​(RequiresTree node, P p)
      访问RequiresTree节点。
      R visitReturn​(ReturnTree node, P p)
      访问ReturnTree节点。
      R visitSwitch​(SwitchTree node, P p)
      访问SwitchTree节点。
      R visitSynchronized​(SynchronizedTree node, P p)
      访问SynchronizedTree节点。
      R visitThrow​(ThrowTree node, P p)
      访问ThrowTree节点
      R visitTry​(TryTree node, P p)
      访问TryTree节点。
      R visitTypeCast​(TypeCastTree node, P p)
      访问TypeCastTree节点。
      R visitTypeParameter​(TypeParameterTree node, P p)
      访问TypeParameterTree节点。
      R visitUnary​(UnaryTree node, P p)
      访问UnaryTree节点。
      R visitUnionType​(UnionTypeTree node, P p)
      访问UnionTypeTree节点。
      R visitUses​(UsesTree node, P p)
      访问UsesTree节点。
      R visitVariable​(VariableTree node, P p)
      访问VariableTree节点。
      R visitWhileLoop​(WhileLoopTree node, P p)
      访问WhileLoopTree节点。
      R visitWildcard​(WildcardTree node, P p)
      访问WildcardTypeTree节点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TreeScanner

        public TreeScanner​()

    • 方法详细信息

      • scan

        public R scan​(树 tree,
              P p)
        扫描单个节点。
        参数
        tree - 要扫描的节点
        p - 传递给访问方法的参数值
        结果
        访问方式的结果值

      • scan

        public R scan​(Iterable<? extends 树> nodes,
              P p)
        扫描一系列节点。
        参数
        nodes - 要扫描的节点
        p - 要传递给每个节点的访问方法的参数值
        结果
        访问方法的组合返回值。 这些值使用reduce方法组合。

      • reduce

        public R reduce​(R r1,
                R r2)
        将两个结果减少为一个组合的结果。 默认的实现是返回第一个参数。 该方法的一般合同是它可以采取任何行动。
        参数
        r1 - 要组合的第一个值
        r2 - 要组合的第二个值
        结果
        结合两个参数的结果

      • visitCompilationUnit

        public R visitCompilationUnit​(CompilationUnitTree node,
                              P p)
        访问CompilationUnitTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitCompilationUnit在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitPackage

        public R visitPackage​(PackageTree node,
                      P p)
        访问PackageTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitPackage在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitImport

        public R visitImport​(ImportTree node,
                     P p)
        访问ImportTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitImport在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitClass

        public R visitClass​(ClassTree node,
                    P p)
        访问ClassTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitClass在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitMethod

        public R visitMethod​(MethodTree node,
                     P p)
        访问MethodTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitMethod在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitVariable

        public R visitVariable​(VariableTree node,
                       P p)
        访问VariableTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitVariable接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitEmptyStatement

        public R visitEmptyStatement​(EmptyStatementTree node,
                             P p)
        访问一个EmptyStatementTree节点。 此实现返回null 。
        Specified by:
        visitEmptyStatement在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitBlock

        public R visitBlock​(BlockTree node,
                    P p)
        访问BlockTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitBlock在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitDoWhileLoop

        public R visitDoWhileLoop​(DoWhileLoopTree node,
                          P p)
        访问DoWhileTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitDoWhileLoop在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitWhileLoop

        public R visitWhileLoop​(WhileLoopTree node,
                        P p)
        访问WhileLoopTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitWhileLoop在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitForLoop

        public R visitForLoop​(ForLoopTree node,
                      P p)
        访问ForLoopTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitForLoop在接口 TreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitEnhancedForLoop

        public R visitEnhancedForLoop​(EnhancedForLoopTree node,
                              P p)
        访问EnhancedForLoopTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitEnhancedForLoop在接口 TreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitLabeledStatement

        public R visitLabeledStatement​(LabeledStatementTree node,
                               P p)
        访问LabeledStatementTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitLabeledStatement接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitSwitch

        public R visitSwitch​(SwitchTree node,
                     P p)
        访问SwitchTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitSwitch在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitCase

        public R visitCase​(CaseTree node,
                   P p)
        访问CaseTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitCase在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitSynchronized

        public R visitSynchronized​(SynchronizedTree node,
                           P p)
        访问SynchronizedTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitSynchronized在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitTry

        public R visitTry​(TryTree node,
                  P p)
        访问TryTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitTry在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitCatch

        public R visitCatch​(CatchTree node,
                    P p)
        访问CatchTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitCatch在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitConditionalExpression

        public R visitConditionalExpression​(ConditionalExpressionTree node,
                                    P p)
        访问一个ConditionalExpressionTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitConditionalExpression在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitIf

        public R visitIf​(IfTree node,
                 P p)
        访问IfTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitIf在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitExpressionStatement

        public R visitExpressionStatement​(ExpressionStatementTree node,
                                  P p)
        访问ExpressionStatementTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitExpressionStatement在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitBreak

        public R visitBreak​(BreakTree node,
                    P p)
        访问BreakTree节点。 此实现返回null 。
        Specified by:
        visitBreak在接口 TreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitContinue

        public R visitContinue​(ContinueTree node,
                       P p)
        访问ContinueTree节点。 此实现返回null 。
        Specified by:
        visitContinue在接口 TreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitReturn

        public R visitReturn​(ReturnTree node,
                     P p)
        访问ReturnTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitReturn在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitThrow

        public R visitThrow​(ThrowTree node,
                    P p)
        访问ThrowTree节点 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitThrow在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitAssert

        public R visitAssert​(AssertTree node,
                     P p)
        访问AssertTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitAssert在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitMethodInvocation

        public R visitMethodInvocation​(MethodInvocationTree node,
                               P p)
        访问MethodInvocationTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitMethodInvocation在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitNewClass

        public R visitNewClass​(NewClassTree node,
                       P p)
        访问NewClassTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitNewClass在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitNewArray

        public R visitNewArray​(NewArrayTree node,
                       P p)
        访问NewArrayTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitNewArray在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitLambdaExpression

        public R visitLambdaExpression​(LambdaExpressionTree node,
                               P p)
        访问LambdaExpressionTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitLambdaExpression在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitParenthesized

        public R visitParenthesized​(ParenthesizedTree node,
                            P p)
        访问ParenthesizedTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitParenthesized在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitAssignment

        public R visitAssignment​(AssignmentTree node,
                         P p)
        访问AssignmentTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitAssignment在接口 TreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitCompoundAssignment

        public R visitCompoundAssignment​(CompoundAssignmentTree node,
                                 P p)
        访问一个CompoundAssignmentTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitCompoundAssignment在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitUnary

        public R visitUnary​(UnaryTree node,
                    P p)
        访问UnaryTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitUnary在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitBinary

        public R visitBinary​(BinaryTree node,
                     P p)
        访问二进制流节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitBinary在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitTypeCast

        public R visitTypeCast​(TypeCastTree node,
                       P p)
        访问TypeCastTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitTypeCast在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitInstanceOf

        public R visitInstanceOf​(InstanceOfTree node,
                         P p)
        访问InstanceOfTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitInstanceOf在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitArrayAccess

        public R visitArrayAccess​(ArrayAccessTree node,
                          P p)
        访问ArrayAccessTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitArrayAccess在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitMemberSelect

        public R visitMemberSelect​(MemberSelectTree node,
                           P p)
        访问MemberSelectTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitMemberSelect在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitMemberReference

        public R visitMemberReference​(MemberReferenceTree node,
                              P p)
        访问MemberReferenceTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitMemberReference在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitIdentifier

        public R visitIdentifier​(IdentifierTree node,
                         P p)
        访问IdentifierTree节点。 此实现返回null 。
        Specified by:
        visitIdentifier在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitLiteral

        public R visitLiteral​(LiteralTree node,
                      P p)
        访问LiteralTree节点。 此实现返回null 。
        Specified by:
        visitLiteral在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitPrimitiveType

        public R visitPrimitiveType​(PrimitiveTypeTree node,
                            P p)
        访问PrimitiveTypeTree节点。 此实现返回null 。
        Specified by:
        visitPrimitiveType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitArrayType

        public R visitArrayType​(ArrayTypeTree node,
                        P p)
        访问ArrayTypeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitArrayType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitParameterizedType

        public R visitParameterizedType​(ParameterizedTypeTree node,
                                P p)
        访问ParameterizedTypeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitParameterizedType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitUnionType

        public R visitUnionType​(UnionTypeTree node,
                        P p)
        访问UnionTypeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitUnionType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitIntersectionType

        public R visitIntersectionType​(IntersectionTypeTree node,
                               P p)
        访问一个IntersectionTypeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitIntersectionType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitTypeParameter

        public R visitTypeParameter​(TypeParameterTree node,
                            P p)
        访问TypeParameterTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitTypeParameter在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitWildcard

        public R visitWildcard​(WildcardTree node,
                       P p)
        访问WildcardTypeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitWildcard在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitModifiers

        public R visitModifiers​(ModifiersTree node,
                        P p)
        访问修饰符Tree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitModifiers在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitAnnotation

        public R visitAnnotation​(AnnotationTree node,
                         P p)
        访问AnnotatedTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitAnnotation在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 一个参数值
        结果
        扫描的结果

      • visitAnnotatedType

        public R visitAnnotatedType​(AnnotatedTypeTree node,
                            P p)
        访问AnnotatedTypeTree节点。 这个实现以从左到右的顺序扫描孩子。
        Specified by:
        visitAnnotatedType在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitModule

        public R visitModule​(ModuleTree node,
                     P p)
        描述从接口TreeVisitor复制
        访问ModuleTree节点。
        Specified by:
        visitModule在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitExports

        public R visitExports​(ExportsTree node,
                      P p)
        说明从接口TreeVisitor复制
        访问ExportsTree节点。
        Specified by:
        visitExports在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitOpens

        public R visitOpens​(OpensTree node,
                    P p)
        说明从接口TreeVisitor复制
        访问OpensTree节点。
        Specified by:
        visitOpens在接口 TreeVisitor<R,P>
        参数
        node - 正在被访问的节点
        p - 参数值
        结果
        结果值

      • visitProvides

        public R visitProvides​(ProvidesTree node,
                       P p)
        描述从接口TreeVisitor复制
        访问ProvideTree节点。
        Specified by:
        visitProvides在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitRequires

        public R visitRequires​(RequiresTree node,
                       P p)
        描述从接口TreeVisitor复制
        访问RequiresTree节点。
        Specified by:
        visitRequires在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitUses

        public R visitUses​(UsesTree node,
                   P p)
        描述从接口TreeVisitor复制
        访问UsesTree节点。
        Specified by:
        visitUses在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        结果值

      • visitOther

        public R visitOther​(树 node,
                    P p)
        访问未知类型的树节点。 如果语言演变，并且将新类型的节点添加到树层次结构中，则可能会发生这种情况。 此实现返回null 。
        Specified by:
        visitOther在接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果

      • visitErroneous

        public R visitErroneous​(ErroneousTree node,
                        P p)
        访问ErroneousTree节点。 此实现返回null 。
        Specified by:
        visitErroneous接口 TreeVisitor<R,P>
        参数
        node - 被访问的节点
        p - 参数值
        结果
        扫描的结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.source.util (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.source.util

  • Packages that use com.sun.source.util
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
  • Classes in com.sun.source.util used by com.sun.source.util
    Class 描述
    DocSourcePositions
    提供在javadoc注释中获取DocTree的位置的方法。
    DocTreeFactory
    工厂创建 DocTree节点。
    DocTreePath
    树节点的路径，通常用于表示直到顶层DocCommentTree节点的树节点的祖先节点序列。
    DocTrees
    提供对文档注释的语法树的访问。
    DocTreeScanner
    访问所有子树节点的TreeVisitor。
    JavacTask
    提供对JDK Java编译器javac特有的功能的访问。
    SourcePositions
    提供在CompilationUnit中获取树的位置的方法。
    TaskEvent
    提供有关JDK Java Compiler（javac）完成的工作的详细信息。
    TaskEvent.Kind
    种类的任务事件。
    TaskListener
    提供监听器来监视JDK Java编译器javac的活动。
    TreePath
    树节点的路径，通常用于表示树节点的祖先节点的序列，直到顶层的CompilationUnitTree节点。
    Trees
    Bridges JSR 199，JSR 269和Tree API。
    TreeScanner
    访问所有子树节点的TreeVisitor。
  • Classes in com.sun.source.util used by jdk.javadoc.doclet
    Class 描述
    DocTreePath
    树节点的路径，通常用于表示直到顶层DocCommentTree节点的树节点的祖先节点序列。
    DocTrees
    提供对文档注释的语法树的访问。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.DocTreePath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.DocTreePath

  • Packages that use DocTreePath
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

    • Uses of DocTreePath in com.sun.source.util

      Methods in com.sun.source.util that return DocTreePath
      Modifier and Type 方法 描述
      DocTreePath DocTreePathScanner.getCurrentPath​()
      返回由当前激活的一组扫描调用构建的节点的当前路径。
      abstract DocTreePath DocTrees.getDocTreePath​(FileObject fileObject, PackageElement packageElement)
      返回包含给定文件的文档注释树的文档树路径。
      DocTreePath DocTreePath.getParentPath​()
      返回包围节点的路径，如果没有包围节点，则返回 null 。
      static DocTreePath DocTreePath.getPath​(DocTreePath path, DocTree target)
      返回由DocTreePath对象标识的子树内的树节点的文档树路径，如果未找到该节点，则 null 。
      static DocTreePath DocTreePath.getPath​(TreePath treePath, DocCommentTree doc, DocTree target)
      返回编译单元中树节点的文档树路径，如果未找到节点，则 null 。
      Methods in com.sun.source.util with parameters of type DocTreePath
      Modifier and Type 方法 描述
      abstract Element DocTrees.getElement​(DocTreePath path)
      返回给定的DocTreePath的叶节点引用的语言模型元素，如果未知的话null 。
      static DocTreePath DocTreePath.getPath​(DocTreePath path, DocTree target)
      返回由DocTreePath对象标识的子树内的树节点的文档树路径，如果未找到该节点，则 null 。
      R DocTreePathScanner.scan​(DocTreePath path, P p)
      从树路径识别的位置扫描树。
      Constructors in com.sun.source.util with parameters of type DocTreePath
      Constructor 描述
      DocTreePath​(DocTreePath p, DocTree t)
      为子节点创建DocTreePath。

    • Uses of DocTreePath in jdk.javadoc.doclet

      Methods in jdk.javadoc.doclet with parameters of type DocTreePath
      Modifier and Type 方法 描述
      void Reporter.print​(Diagnostic.Kind kind, DocTreePath path, String msg)
      打印错误消息并增加错误计数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.DocTreePathScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.DocTreePathScanner

No usage of com.sun.source.util.DocTreePathScanner
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.DocTrees (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.DocTrees

  • Packages that use DocTrees
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

    • Uses of DocTrees in com.sun.source.util

      Methods in com.sun.source.util that return DocTrees
      Modifier and Type 方法 描述
      static DocTrees DocTrees.instance​(ProcessingEnvironment env)
      返回给定的ProcessingEnvironment的DocTrees对象。
      static DocTrees DocTrees.instance​(JavaCompiler.CompilationTask task)
      返回给定CompilationTask的DocTrees对象。

    • Uses of DocTrees in jdk.javadoc.doclet

      Methods in jdk.javadoc.doclet that return DocTrees
      Modifier and Type 方法 描述
      DocTrees DocletEnvironment.getDocTrees​()
      返回 DocTrees实用程序类的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.DocTreeScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.DocTreeScanner

  • Packages that use DocTreeScanner
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DocTreeScanner in com.sun.source.util

      Subclasses of DocTreeScanner in com.sun.source.util
      Modifier and Type Class 描述
      class  DocTreePathScanner<R,P>
      访问所有子树节点的DocTreeVisitor，并为维护父节点的路径提供支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.JavacTask (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.JavacTask

  • Packages that use JavacTask
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of JavacTask in com.sun.source.util

      Methods in com.sun.source.util that return JavacTask
      Modifier and Type 方法 描述
      static JavacTask JavacTask.instance​(ProcessingEnvironment processingEnvironment)
      返回 JavacTask为 ProcessingEnvironment 。
      Methods in com.sun.source.util with parameters of type JavacTask
      Modifier and Type 方法 描述
      void Plugin.init​(JavacTask task, String... args)
      初始化给定编译任务的插件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.SimpleDocTreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.SimpleDocTreeVisitor

No usage of com.sun.source.util.SimpleDocTreeVisitor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.SimpleTreeVisitor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.SimpleTreeVisitor

No usage of com.sun.source.util.SimpleTreeVisitor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.TaskEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.TaskEvent

  • Packages that use TaskEvent
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TaskEvent in com.sun.source.util

      Methods in com.sun.source.util with parameters of type TaskEvent
      Modifier and Type 方法 描述
      default void TaskListener.finished​(TaskEvent e)
      事件完成后调用。
      default void TaskListener.started​(TaskEvent e)
      事件开始时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.TaskEvent.Kind (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.TaskEvent.Kind

  • Packages that use TaskEvent.Kind
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TaskEvent.Kind in com.sun.source.util

      Methods in com.sun.source.util that return TaskEvent.Kind
      Modifier and Type 方法 描述
      TaskEvent.Kind TaskEvent.getKind​()
      返回此事件的种类。
      static TaskEvent.Kind TaskEvent.Kind.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TaskEvent.Kind[] TaskEvent.Kind.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in com.sun.source.util with parameters of type TaskEvent.Kind
      Constructor 描述
      TaskEvent​(TaskEvent.Kind kind)
      为特定类型创建任务事件。
      TaskEvent​(TaskEvent.Kind kind, CompilationUnitTree unit)
      为给定类型和编译单元创建任务事件。
      TaskEvent​(TaskEvent.Kind kind, CompilationUnitTree unit, TypeElement clazz)
      为给定类型，编译单位和类型元素创建任务事件。
      TaskEvent​(TaskEvent.Kind kind, JavaFileObject sourceFile)
      为给定种类和源文件创建任务事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.TreePath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.TreePath

  • Packages that use TreePath
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TreePath in com.sun.source.util

      Methods in com.sun.source.util that return TreePath
      Modifier and Type 方法 描述
      TreePath TreePathScanner.getCurrentPath​()
      返回由当前激活的一组扫描调用构建的节点的当前路径。
      TreePath TreePath.getParentPath​()
      返回包围节点的路径，如果没有包围节点，则返回 null 。
      static TreePath TreePath.getPath​(CompilationUnitTree unit, 树 target)
      返回编译单元中树节点的树路径，如果未找到该节点，则 null 。
      static TreePath TreePath.getPath​(TreePath path, 树 target)
      返回由TreePath对象标识的子树内的树节点的树路径。
      abstract TreePath Trees.getPath​(CompilationUnitTree unit, 树 node)
      返回指定编译单元中树节点的路径。
      abstract TreePath Trees.getPath​(Element e)
      返回给定元素的TreePath节点。
      abstract TreePath Trees.getPath​(Element e, AnnotationMirror a)
      返回给定元素上的AnnotationMirror的TreePath节点。
      abstract TreePath Trees.getPath​(Element e, AnnotationMirror a, AnnotationValue v)
      返回指定元素上AnnotationMirror的AnnotationValue的TreePath节点。
      TreePath DocTreePath.getTreePath​()
      返回与此路径相关联的TreePath。
      Methods in com.sun.source.util with parameters of type TreePath
      Modifier and Type 方法 描述
      abstract String Trees.getDocComment​(TreePath path)
      返回给定TreePath标识的Tree节点的doc注释（如果有）。
      abstract DocCommentTree DocTrees.getDocCommentTree​(TreePath path)
      返回由给定TreePath标识的Tree节点的doc注释树（如果有）。
      abstract Element Trees.getElement​(TreePath path)
      返回给定TreePath标识的Tree节点的元素。
      static DocTreePath DocTreePath.getPath​(TreePath treePath, DocCommentTree doc, DocTree target)
      返回编译单元中树节点的文档树路径，如果未找到节点，则 null 。
      static TreePath TreePath.getPath​(TreePath path, 树 target)
      返回由TreePath对象标识的子树内的树节点的树路径。
      abstract Scope Trees.getScope​(TreePath path)
      返回给定TreePath标识的Tree节点的范围。
      abstract TypeMirror Trees.getTypeMirror​(TreePath path)
      返回给定TreePath标识的Tree节点的TypeMirror。
      R TreePathScanner.scan​(TreePath path, P p)
      从树路径识别的位置扫描树。
      Constructors in com.sun.source.util with parameters of type TreePath
      Constructor 描述
      DocTreePath​(TreePath treePath, DocCommentTree t)
      为根节点创建DocTreePath。
      TreePath​(TreePath path, 树 tree)
      为子节点创建一个TreePath。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.TreePathScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.TreePathScanner

No usage of com.sun.source.util.TreePathScanner
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.Trees (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.Trees

  • Packages that use Trees
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of Trees in com.sun.source.util

      Subclasses of Trees in com.sun.source.util
      Modifier and Type Class 描述
      class  DocTrees
      提供对文档注释的语法树的访问。
      Methods in com.sun.source.util that return Trees
      Modifier and Type 方法 描述
      static Trees Trees.instance​(ProcessingEnvironment env)
      返回给定ProcessingEnvironment的Trees对象。
      static Trees Trees.instance​(JavaCompiler.CompilationTask task)
      返回给定CompilationTask的Trees对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.source.util.TreeScanner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.source.util.TreeScanner

  • Packages that use TreeScanner
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TreeScanner in com.sun.source.util

      Subclasses of TreeScanner in com.sun.source.util
      Modifier and Type Class 描述
      class  TreePathScanner<R,P>
      一个访问所有子树节点的TreeVisitor，并为维护父节点的路径提供支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.util.DocSourcePositions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.util.DocSourcePositions

  • Packages that use DocSourcePositions
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DocSourcePositions in com.sun.source.util

      Methods in com.sun.source.util that return DocSourcePositions
      Modifier and Type 方法 描述
      abstract DocSourcePositions DocTrees.getSourcePositions​()
      返回用于访问文档树节点的源位置的实用程序对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.util.DocTreeFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.util.DocTreeFactory

  • Packages that use DocTreeFactory
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of DocTreeFactory in com.sun.source.util

      Methods in com.sun.source.util that return DocTreeFactory
      Modifier and Type 方法 描述
      DocTreeFactory DocTreeFactory.at​(int pos)
      设置要在此工厂创建的后续树节点中记录的位置。
      abstract DocTreeFactory DocTrees.getDocTreeFactory​()
      返回一个用于创建 DocTree对象的实用程序对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.util.Plugin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.util.Plugin

No usage of com.sun.source.util.Plugin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.util.SourcePositions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.util.SourcePositions

  • Packages that use SourcePositions
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of SourcePositions in com.sun.source.util

      Subinterfaces of SourcePositions in com.sun.source.util
      Modifier and Type 接口 描述
      interface  DocSourcePositions
      提供在javadoc注释中获取DocTree的位置的方法。
      Methods in com.sun.source.util that return SourcePositions
      Modifier and Type 方法 描述
      abstract SourcePositions Trees.getSourcePositions​()
      返回用于获取源位置的实用程序对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.source.util.TaskListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.source.util.TaskListener

  • Packages that use TaskListener
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。

    • Uses of TaskListener in com.sun.source.util

      Methods in com.sun.source.util with parameters of type TaskListener
      Modifier and Type 方法 描述
      abstract void JavacTask.addTaskListener​(TaskListener taskListener)
      添加指定的侦听器，以便它接收到描述此编译任务进度的事件的通知。
      abstract void JavacTask.removeTaskListener​(TaskListener taskListener)
      删除指定的侦听器，使其不再收到描述此编译任务进度的事件的通知。
      abstract void JavacTask.setTaskListener​(TaskListener taskListener)
      设置指定的侦听器以接收描述此编译任务进度的事件的通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AgentInitializationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach

Class AgentInitializationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.tools.attach.AgentInitializationException
  • All Implemented Interfaces:
    Serializable

    public class AgentInitializationException
extends 异常
    当代理程序无法在目标Java虚拟机中初始化时抛出异常。

    此异常抛出VirtualMachine.loadAgent ， VirtualMachine.loadAgentLibrary ， VirtualMachine.loadAgentPath种方法，如果代理人或代理库，不能被初始化。 当抛出VirtualMachine.loadAgentLibrary或VirtualMachine.loadAgentPath ，异常封装了代理的Agent_OnAttach函数返回的错误。 可以通过调用returnValue方法获得此错误代码。

    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AgentInitializationException​()
      构造一个 AgentInitializationException ，没有详细信息。
      AgentInitializationException​(String s)
      构造具有指定详细消息的 AgentInitializationException 。
      AgentInitializationException​(String s, int returnValue)
      构造一个 AgentInitializationException带指定详细消息，并从代理的执行的返回值 Agent_OnAttach功能。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int returnValue​()
      如果使用代理 Agent_OnAttach函数的返回值创建异常，则返回该值，否则返回 0 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AgentInitializationException

        public AgentInitializationException​()
        构造一个 AgentInitializationException ，没有详细信息。

      • AgentInitializationException

        public AgentInitializationException​(String s)
        构造具有指定详细消息的 AgentInitializationException 。
        参数
        s - 详细信息。

      • AgentInitializationException

        public AgentInitializationException​(String s,
                                    int returnValue)
        构造一个 AgentInitializationException带指定详细消息，并从代理的执行的返回值 Agent_OnAttach功能。
        参数
        s - 详细信息。
        returnValue - 返回值

    • 方法详细信息

      • returnValue

        public int returnValue​()
        如果使用代理程序 Agent_OnAttach函数的返回值创建异常，则返回该值，否则返回 0 。
        结果
        返回值
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AgentLoadException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach

Class AgentLoadException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.tools.attach.AgentLoadException
  • All Implemented Interfaces:
    Serializable

    public class AgentLoadException
extends 异常
    代理无法加载到目标Java虚拟机时抛出的异常。

    此异常抛出VirtualMachine.loadAgent或者VirtualMachine.loadAgentLibrary ， loadAgentPath种方法，如果代理人或代理库，无法加载。

    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AgentLoadException​()
      构造一个 AgentLoadException ，没有详细消息。
      AgentLoadException​(String s)
      构造具有指定详细消息的 AgentLoadException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AgentLoadException

        public AgentLoadException​()
        构造一个没有详细消息的 AgentLoadException 。

      • AgentLoadException

        public AgentLoadException​(String s)
        构造具有指定详细消息的 AgentLoadException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AttachNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach

Class AttachNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • com.sun.tools.attach.AttachNotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class AttachNotSupportedException
extends 异常
    当尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。 它是由也扔AttachProvider.attachVirtualMachine如果提供程序试图连接到与它没有comptatible Java虚拟机。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AttachNotSupportedException​()
      构造一个没有详细消息的 AttachNotSupportedException 。
      AttachNotSupportedException​(String s)
      构造具有指定详细消息的 AttachNotSupportedException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AttachNotSupportedException

        public AttachNotSupportedException​()
        构造一个没有详细消息的 AttachNotSupportedException 。

      • AttachNotSupportedException

        public AttachNotSupportedException​(String s)
        构造具有指定详细消息的 AttachNotSupportedException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AttachOperationFailedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach

Class AttachOperationFailedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • com.sun.tools.attach.AttachOperationFailedException
  • All Implemented Interfaces:
    Serializable

    public class AttachOperationFailedException
extends IOException
    异常类型表示目标虚拟机中附着操作失败。

    当目标虚拟机中的操作失败时，可以通过VirtualMachine的各种操作抛出此异常。 如果有通信错误，将抛出常规IOException。

    从以下版本开始：
    9
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AttachOperationFailedException​(String message)
      构造具有指定详细消息的 AttachOperationFailedException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AttachOperationFailedException

        public AttachOperationFailedException​(String message)
        构造具有指定详细消息的 AttachOperationFailedException 。
        参数
        message - the detail message.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AttachPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach

Class AttachPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • com.sun.tools.attach.AttachPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class AttachPermission
extends BasicPermission
    当一个SecurityManager集合，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。 创建AttachProvider时也会检查此权限。

    一个AttachPermission对象包含一个名称（也称为“目标名称”），但没有动作列表; 你有指定的权限，或者你没有。 下表提供了许可允许的简要说明，并讨论了授予代码许可的风险。

    Table shows permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission attachVirtualMachine Ability to attach to another Java virtual machine and load agents into that VM. This allows an attacker to control the target VM which can potentially cause it to misbehave. createAttachProvider Ability to create an AttachProvider instance. This allows an attacker to create an AttachProvider which can potentially be used to attach to other Java virtual machines.

    程序员通常不会直接创建AttachPermission对象。 相反，它们是基于阅读安全策略文件的安全策略代码创建的。

    另请参见：
    VirtualMachine ， AttachProvider ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AttachPermission​(String name)
      构造一个新的AttachPermission对象。
      AttachPermission​(String name, String actions)
      构造一个新的AttachPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • AttachPermission

        public AttachPermission​(String name)
        构造一个新的AttachPermission对象。
        参数
        name - 权限名称。 必须是“attachVirtualMachine”或“createAttachProvider”。
        异常
        NullPointerException - 如果名字是 null 。
        IllegalArgumentException - 如果名称无效。

      • AttachPermission

        public AttachPermission​(String name,
                        String actions)
        构造一个新的AttachPermission对象。
        参数
        name - 权限名称。 必须是“attachVirtualMachine”或“createAttachProvider”。
        actions - 未使用，应为 null ，或空字符串。
        异常
        NullPointerException - 如果名字是 null 。
        IllegalArgumentException - 如果参数无效。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.tools.attach (Java SE 9 & JDK 9 )

com.sun.tools.attach

Classes

  • AttachPermission
  • VirtualMachine
  • VirtualMachineDescriptor

Exceptions

  • AgentInitializationException
  • AgentLoadException
  • AttachNotSupportedException
  • AttachOperationFailedException


com.sun.tools.attach (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.attach

Package com.sun.tools.attach

提供API附加到Java的虚拟机。

以Java语言编写的工具使用此API附加到目标虚拟机（VM）并将其工具代理程序加载到目标VM中。 例如，管理控制台可能具有管理代理，它用于从Java虚拟机中的已检测对象获取管理信息。 如果需要管理控制台来管理在不包含管理代理的虚拟机中运行的应用程序，则可以使用该API附加到目标虚拟机并加载代理。

从以下版本开始：
1.6
  • 类摘要
    Class 描述
    AttachPermission
    当一个SecurityManager集合，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。
    VirtualMachine
    Java虚拟机。
    VirtualMachineDescriptor
    描述一个Java虚拟机。
  • 异常摘要
    异常 描述
    AgentInitializationException
    当代理程序无法在目标Java虚拟机中初始化时抛出异常。
    AgentLoadException
    代理无法加载到目标Java虚拟机时抛出的异常。
    AttachNotSupportedException
    当尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。
    AttachOperationFailedException
    异常类型表示目标虚拟机中附着操作失败。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.attach Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.tools.attach

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • com.sun.tools.attach.AttachPermission
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • com.sun.tools.attach.AgentInitializationException
        • com.sun.tools.attach.AgentLoadException
        • com.sun.tools.attach.AttachNotSupportedException
        • java.io.IOException
          • com.sun.tools.attach.AttachOperationFailedException
    • com.sun.tools.attach.VirtualMachine
    • com.sun.tools.attach.VirtualMachineDescriptor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Package com.sun.tools.attach (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.tools.attach

  • Packages that use com.sun.tools.attach
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。
  • Classes in com.sun.tools.attach used by com.sun.tools.attach
    Class 描述
    AgentInitializationException
    当代理程序无法在目标Java虚拟机中初始化时抛出异常。
    AgentLoadException
    代理无法加载到目标Java虚拟机时抛出的异常。
    AttachNotSupportedException
    在尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。
    VirtualMachine
    Java虚拟机。
    VirtualMachineDescriptor
    描述一个Java虚拟机。
  • Classes in com.sun.tools.attach used by com.sun.tools.attach.spi
    Class 描述
    AttachNotSupportedException
    在尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。
    VirtualMachine
    Java虚拟机。
    VirtualMachineDescriptor
    描述一个Java虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VirtualMachine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach

Class VirtualMachine

  • java.lang.Object
    • com.sun.tools.attach.VirtualMachine

  • public abstract class VirtualMachine
extends Object
    Java虚拟机。

    A VirtualMachine表示此Java虚拟机已附加到的Java虚拟机。 它所连接的Java虚拟机有时称为目标虚拟机或目标虚拟机 。 应用程序（通常是一个诸如managemet控制台或分析器之类的工具）使用VirtualMachine将代理加载到目标VM中。 例如，用Java语言编写的概要分析工具可能会附加到正在运行的应用程序，并加载其分析器代理程序来配置正在运行的应用程序。

    通过使用标识目标虚拟机的标识符调用attach方法获得VirtualMachine。 标识符是依赖于实现的，但通常是每个Java虚拟机在其自己的操作系统进程中运行的环境中的进程标识符（或pid）。 可替代地，一个VirtualMachine实例是通过调用得到attach方法与VirtualMachineDescriptor从由返回的虚拟机描述符列表得到list方法。 一旦获得对虚拟机的引用 ，就使用loadAgent,loadAgentLibrary和loadAgentPath方法将代理加载到目标虚拟机中。 loadAgent方法用于加载以Java语言编写并部署在JAR file中的代理 。 （有关这些代理如何加载和启动的详细说明，请参阅java.lang.instrument ）。 loadAgentLibrary和loadAgentPath方法用于加载部署在动态库中或静态链接到VM中的代理 ，并使用JVM Tools Interface 。

    除了加载代理之外，VirtualMachine还提供对目标VM中的system properties的读取访问。 这可以在如属性一些环境中是有用的java.home ， os.name ，或os.arch被用于构建将被装载到目标虚拟机的路径剂。

    以下示例演示如何使用VirtualMachine：

      // attach to target VM
      VirtualMachine vm = VirtualMachine.attach("2177");

      // start management agent
      Properties props = new Properties();
      props.put("com.sun.management.jmxremote.port", "5000");
      vm.startManagementAgent(props);

      // detach
      vm.detach();

    在此示例中，我们附加到由进程标识符2177标识的Java虚拟机。 然后使用提供的参数在目标进程中启动JMX管理代理。 最后，客户端从目标VM分离。

    VirtualMachine可以安全地被多个并发线程使用。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected VirtualMachine​(AttachProvider provider, String id)
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static VirtualMachine attach​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      static VirtualMachine attach​(String id)
      附加到Java虚拟机。
      abstract void detach​()
      脱离虚拟机。
      boolean equals​(Object ob)
      测试此VirtualMachine与另一个对象的相等性。
      abstract Properties getAgentProperties​()
      返回目标虚拟机中的当前 代理属性 。
      abstract Properties getSystemProperties​()
      返回目标虚拟机中的当前系统属性。
      int hashCode​()
      返回此VirtualMachine的哈希码值。
      String id​()
      返回此Java虚拟机的标识符。
      static List<VirtualMachineDescriptor> list​()
      返回Java虚拟机的列表。
      void loadAgent​(String agent)
      加载代理
      abstract void loadAgent​(String agent, String options)
      加载代理
      void loadAgentLibrary​(String agentLibrary)
      加载代理库。
      abstract void loadAgentLibrary​(String agentLibrary, String options)
      加载代理库。
      void loadAgentPath​(String agentPath)
      以完整路径名加载本地代理库。
      abstract void loadAgentPath​(String agentPath, String options)
      以完整路径名加载本地代理库。
      AttachProvider provider​()
      返回创建此虚拟机的提供程序。
      abstract String startLocalManagementAgent​()
      启动目标虚拟机中的本地JMX管理代理。
      abstract void startManagementAgent​(Properties agentProperties)
      启动目标虚拟机中的JMX管理代理。
      String toString​()
      返回 VirtualMachine的字符串表示 VirtualMachine 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • VirtualMachine

        protected VirtualMachine​(AttachProvider provider,
                         String id)
        初始化此类的新实例。
        参数
        provider - 创建此类的附加提供者。
        id - 标识Java虚拟机的抽象标识符。
        异常
        NullPointerException - 如果 provider或 id是 null 。

    • 方法详细信息

      • list

        public static List<VirtualMachineDescriptor> list​()
        返回Java虚拟机的列表。

        此方法返回一个Java VirtualMachineDescriptor元素的列表。 该列表是通过调用所有安装的listVirtualMachines方法获得的虚拟机描述符列表的聚合attach providers 。 如果任何提供者都没有知道Java虚拟机，则返回一个空列表。

        结果
        虚拟机描述符列表。

      • attach

        public static VirtualMachine attach​(String id)
                             throws AttachNotSupportedException,
                                    IOException
        附加到Java虚拟机。

        该方法通过调用AttachProvider.providers()方法获取附加提供者的列表。 然后它重复列表，并依次调用每个提供者的attachVirtualMachine方法。 如果提供程序成功附加，则迭代终止，并且由此方法返回由成功附加的提供程序创建的VirtualMachine。 如果所有提供商的attachVirtualMachine方法都抛出AttachNotSupportedException，那么这个方法也会抛出AttachNotSupportedException 。 这意味着当提供给此方法的标识符无效时，抛出AttachNotSupportedException ，或者标识符对应于不存在的Java虚拟机，或者任何提供程序都不能附加到该虚拟机。 如果AttachProvider.providers()返回一个空列表，也会抛出此异常。

        参数
        id - 标识Java虚拟机的抽象标识符。
        结果
        表示目标VM的VirtualMachine。
        异常
        SecurityException - 如果已安装安全管理员，并且拒绝AttachPermission ("attachVirtualMachine")或实施所需的其他权限。
        AttachNotSupportedException - 如果所有已安装的提供商的 attachVirtualmachine方法抛出 AttachNotSupportedException ，或者没有安装任何提供程序。
        IOException - 如果发生I / O错误
        NullPointerException - 如果 id是 null 。

      • attach

        public static VirtualMachine attach​(VirtualMachineDescriptor vmd)
                             throws AttachNotSupportedException,
                                    IOException
        附加到Java虚拟机。

        该方法首先调用给定虚拟机描述符的provider()方法来获取附加提供程序。 然后，它调用附加提供程序的attachVirtualMachine以附加到目标VM。

        参数
        vmd - 虚拟机描述符。
        结果
        表示目标VM的VirtualMachine。
        异常
        SecurityException - 如果安全管理器已经安装，并且它拒绝AttachPermission ("attachVirtualMachine")或实施所需的其他权限。
        AttachNotSupportedException - 如果附加提供商的 attachVirtualmachine抛出 AttachNotSupportedException 。
        IOException - 如果发生I / O错误
        NullPointerException - 如果 vmd是 null 。

      • detach

        public abstract void detach​()
                     throws IOException
        脱离虚拟机。

        从虚拟机分离后，任何进一步尝试调用该虚拟机的操作将导致抛出IOException 。 如果在调用此方法时正在进行操作（例如loadAgent ），那么行为是依赖于实现的。 换句话说，如果操作完成或抛出IOException ，则它是实现特定的。

        如果已经从虚拟机分离，则调用此方法将不起作用。

        异常
        IOException - 如果发生I / O错误

      • provider

        public final AttachProvider provider​()
        返回创建此虚拟机的提供程序。
        结果
        创建此虚拟机的提供程序。

      • id

        public final String id​()
        返回此Java虚拟机的标识符。
        结果
        此Java虚拟机的标识符。

      • loadAgentLibrary

        public abstract void loadAgentLibrary​(String agentLibrary,
                                      String options)
                               throws AgentLoadException,
                                      AgentInitializationException,
                                      IOException
        加载代理库。

        A JVM TI客户端称为代理 。 它是用母语开发的。 JVM TI代理以平台特定的方式部署，但通常是与动态库相当的平台。 或者，它可以静态链接到VM中。 此方法将使给定的代理库加载到目标VM（如果尚未加载或未静态链接到VM中）。 然后它使目标VM调用Agent_OnAttach函数，或者对于名为“L”的静态链接代理， Agent_OnAttach_L函数，如JVM Tools Interface规范中所指定。 请注意，即使在调用此方法之前加载了代理程序库，也会调用Agent_OnAttach[_L]函数。

        提供的代理库是代理程序库的名称。 它在目标虚拟机中以实现相关的方式进行解释。 通常，实现将库名称扩展为操作系统特定的文件名。 例如，在UNIX系统上，可以将名称L扩展为libL.so ，并使用由LD_LIBRARY_PATH环境变量指定的搜索路径LD_LIBRARY_PATH 。 如果名为'L'的代理程序静态链接到VM中，则VM必须导出名为Agent_OnAttach_L的函数。

        如果代理程序库中的Agent_OnAttach[_L]函数返回错误，则抛出AgentInitializationException 。 然后可以通过调用returnValue方法获取Agent_OnAttach[_L]的返回值。

        参数
        agentLibrary - 代理程序库的名称。
        options - 提供给 Agent_OnAttach[_L]功能的选项（可以是 null ）。
        异常
        AgentLoadException - 如果代理程序库不存在，则代理程序库不会与VM静态链接，或者由于另一个原因不能加载代理程序库。
        AgentInitializationException - 如果 Agent_OnAttach[_L]函数返回错误。
        IOException - 如果发生I / O错误
        NullPointerException - 如果 agentLibrary是 null 。
        另请参见：
        AgentInitializationException.returnValue()

      • loadAgentLibrary

        public void loadAgentLibrary​(String agentLibrary)
                      throws AgentLoadException,
                             AgentInitializationException,
                             IOException
        加载代理库。

        这种方便的方法就像调用：

        loadAgentLibrary(agentLibrary, null);
        参数
        agentLibrary - 代理程序库的名称。
        异常
        AgentLoadException - 如果代理程序库不存在，则代理程序库不会与VM静态链接，或者由于另一个原因无法加载代理程序库。
        AgentInitializationException - 如果 Agent_OnAttach[_L]函数返回错误。
        IOException - 如果发生I / O错误
        NullPointerException - 如果 agentLibrary是 null 。

      • loadAgentPath

        public abstract void loadAgentPath​(String agentPath,
                                   String options)
                            throws AgentLoadException,
                                   AgentInitializationException,
                                   IOException
        以完整路径名加载本地代理库。

        A JVM TI客户端称为代理 。 它是用母语开发的。 JVM TI代理以平台特定的方式部署，但通常是与动态库相当的平台。 或者，由agentPath参数指定的本地库可能与VM静态链接。 将agentPath参数解析为静态链接库名称是以平台特定的方式在VM中完成的。 例如，在UNIX中，agentPath参数为/a/b/libL.so将命名库“L”。 有关更多详细信息，请参阅JVM TI规范。 此方法将使给定的代理库加载到目标VM（如果尚未加载或未静态链接到VM中）。 然后，它使目标VM调用Agent_OnAttach函数，或者对于名为“L”的静态链接代理， 270456492219728规范中指定的Agent_OnAttach_L函数。 请注意，即使在调用此方法之前加载了代理程序库，也会调用Agent_OnAttach[_L]函数。

        提供的代理程序库是加载代理库的绝对路径。 与loadAgentLibrary不同，库名称不会在目标虚拟机中展开。

        如果代理程序库中的Agent_OnAttach[_L]函数返回错误，则抛出一个AgentInitializationException 。 然后可以通过调用returnValue方法获取Agent_OnAttach[_L]的返回值。

        参数
        agentPath - 代理库的完整路径。
        options - 提供给 Agent_OnAttach[_L]功能的选项（可以是 null ）。
        异常
        AgentLoadException - 如果代理程序库不存在，则代理程序库不会与VM静态链接，或者由于另一个原因无法加载代理程序库。
        AgentInitializationException - 如果 Agent_OnAttach[_L]函数返回错误。
        IOException - 如果发生I / O错误
        NullPointerException - 如果 agentPath是 null 。
        另请参见：
        AgentInitializationException.returnValue()

      • loadAgentPath

        public void loadAgentPath​(String agentPath)
                   throws AgentLoadException,
                          AgentInitializationException,
                          IOException
        以完整路径名加载本地代理库。

        这种方便的方法就像调用：

        loadAgentPath(agentLibrary, null);
        参数
        agentPath - 代理程序库的完整路径。
        异常
        AgentLoadException - 如果代理程序库不存在，则代理程序库不会与VM静态链接，或者由于另一个原因不能加载代理程序库。
        AgentInitializationException - 如果 Agent_OnAttach[_L]函数返回错误。
        IOException - 如果发生I / O错误
        NullPointerException - 如果 agentPath是 null 。

      • loadAgent

        public abstract void loadAgent​(String agent,
                               String options)
                        throws AgentLoadException,
                               AgentInitializationException,
                               IOException
        加载代理

        提供给此方法的代理是目标虚拟机的文件系统上的JAR文件的路径名。 该路径被传递到目标虚拟机，在此被解释。 目标虚拟机将按照java.lang.instrument规范的规定尝试启动代理。 也就是说，指定的JAR文件被添加到目标虚拟机的系统类路径中，并且调用由JAR清单中的Agent-Class属性指定的代理类的agentmain方法。 当agentmain方法完成时， agentmain方法完成。

        参数
        agent - 包含代理的JAR文件的路径。
        options - 提供给代理人的 agentmain方法的选项（可以是 null ）。
        异常
        AgentLoadException - 如果代理不存在，或者不能以 java.lang.instrument规范中指定的方式启动。
        AgentInitializationException - 如果 agentmain抛出异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果 agent是 null 。

      • loadAgent

        public void loadAgent​(String agent)
               throws AgentLoadException,
                      AgentInitializationException,
                      IOException
        加载代理

        这种方便的方法就像调用：

        loadAgent(agent, null);
        参数
        agent - 包含代理的JAR文件的路径。
        异常
        AgentLoadException - 如果代理不存在或不能按照 java.lang.instrument规范中指定的方式启动。
        AgentInitializationException - 如果 agentmain抛出异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果 agent是 null 。

      • getSystemProperties

        public abstract Properties getSystemProperties​()
                                        throws IOException
        返回目标虚拟机中的当前系统属性。

        此方法返回目标虚拟机中的系统属性。 键或值不是String被省略。 该方法大致等同于目标虚拟机中方法System.getProperties的调用，但不包括具有不是String的键或值的属性。

        该方法通常用于决定使用loadAgent或loadAgentLibrary加载到目标虚拟机中的代理 。 例如， java.home或user.dir属性可能用于创建代理库或JAR文件的路径。

        结果
        系统属性
        异常
        AttachOperationFailedException - 如果目标虚拟机无法完成附加操作。 更具体的错误信息将由Throwable.getMessage()给出。
        IOException - 如果发生I / O错误，例如，通信错误，无法标识为错误，以指示目标VM中的操作失败。
        另请参见：
        System.getProperties() ，
loadAgentLibrary(java.lang.String, java.lang.String) ，
loadAgent(java.lang.String, java.lang.String)

      • getAgentProperties

        public abstract Properties getAgentProperties​()
                                       throws IOException
        返回目标虚拟机中的当前代理属性 。

        目标虚拟机可以代理代理维护属性列表。 这样做的方式，属性的名称和允许的值的类型是具体的实现。 代理属性通常用于存储通信端点和其他代理配置详细信息。 例如，调试器代理可能为其传输地址创建代理属性。

        此方法返回代码属性，其键值为String 。 键或值不是String被省略。 如果目标虚拟机中没有维护代理属性，则返回空属性列表。

        结果
        代理属性
        异常
        AttachOperationFailedException - 如果目标虚拟机无法完成附加操作。 更具体的错误信息将由Throwable.getMessage()给出。
        IOException - 如果发生I / O错误，则会发生通信错误，例如无法将其识别为错误，以指示目标VM中的操作失败。

      • startManagementAgent

        public abstract void startManagementAgent​(Properties agentProperties)
                                   throws IOException
        启动目标虚拟机中的JMX管理代理。

        配置属性与启动JMX管理代理时在命令行中指定的属性相同。 以与命令行相同的方式，您至少需要指定com.sun.management.jmxremote.port属性。

        有关详细信息，请参阅Monitoring and Management Using JMX Technology的在线文档。

        参数
        agentProperties - 包含代理配置属性的Properties对象。
        异常
        AttachOperationFailedException - 如果目标虚拟机无法完成附加操作。 更具体的错误信息将由Throwable.getMessage()给出。
        IOException - 如果发生I / O错误，例如，无法识别为指示操作在目标VM中失败的错误的通信错误。
        IllegalArgumentException - 如果agentProperties中的键或值无效。
        NullPointerException - 如果agentProperties为null。
        从以下版本开始：
        1.8

      • startLocalManagementAgent

        public abstract String startLocalManagementAgent​()
                                          throws IOException
        启动目标虚拟机中的本地JMX管理代理。

        有关详细信息，请参阅Monitoring and Management Using JMX Technology的在线文档。

        结果
        本地连接器服务地址的字符串表示形式。 该值可以由JMXServiceURL(String)构造函数解析。
        异常
        AttachOperationFailedException - 如果目标虚拟机无法完成附加操作。 更具体的错误信息将由Throwable.getMessage()给出。
        IOException - 如果发生I / O错误，例如通信错误，无法识别为错误，以指示目标VM中的操作失败。
        从以下版本开始：
        1.8

      • hashCode

        public int hashCode​()
        返回此VirtualMachine的哈希码值。 哈希码是基于VirtualMachine的组件，并且符合Object.hashCode方法的总体合同。
        重写：
        hashCode在 Object
        结果
        该虚拟机的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        测试此VirtualMachine与另一个对象的相等性。

        如果给定的对象不是VirtualMachine，那么此方法返回false 。 对于两个被认为是相等的VirtualMachines要求他们都引用同一个提供者，而他们的identifiers是相等的。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果，并且仅当给定的对象是等于该VirtualMachine的VirtualMachine。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回 VirtualMachine的字符串表示 VirtualMachine 。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VirtualMachineDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach

Class VirtualMachineDescriptor

  • java.lang.Object
    • com.sun.tools.attach.VirtualMachineDescriptor

  • public class VirtualMachineDescriptor
extends Object
    描述一个Java虚拟机。

    A VirtualMachineDescriptor是用于描述Java虚拟机的容器类。 它封装了标识目标虚拟机的标识符，以及对尝试附加到虚拟机时应使用的AttachProvider的引用。 标识符是依赖于实现的，但通常是每个Java虚拟机在其自己的操作系统进程中运行的进程标识符（或pid）环境。

    A VirtualMachineDescriptor也有一个displayName 。 显示名称通常是工具可能向用户显示的可读字符串。 例如，显示系统上运行的Java虚拟机列表的工具可能会使用显示名称而不是标识符。 可以创建A VirtualMachineDescriptor而不显示名称 。 在这种情况下，标识符用作显示名称 。

    通常通过调用VirtualMachine.list()方法创建VirtualMachineDescriptor实例。 这将返回描述符的完整列表，以描述所有安装的已知的Java虚拟机attach providers 。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      VirtualMachineDescriptor​(AttachProvider provider, String id)
      从给定的组件创建一个虚拟机描述符。
      VirtualMachineDescriptor​(AttachProvider provider, String id, String displayName)
      从给定的组件创建一个虚拟机描述符。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String displayName​()
      返回此描述符的 显示名称组件。
      boolean equals​(Object ob)
      测试此VirtualMachineDescriptor与其他对象的相等性。
      int hashCode​()
      返回此VirtualMachineDescriptor的哈希码值。
      String id​()
      返回此描述符的标识符组件。
      AttachProvider provider​()
      返回这个描述符引用的 AttachProvider 。
      String toString​()
      返回 VirtualMachineDescriptor的字符串表示 VirtualMachineDescriptor 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • VirtualMachineDescriptor

        public VirtualMachineDescriptor​(AttachProvider provider,
                                String id,
                                String displayName)
        从给定的组件创建一个虚拟机描述符。
        参数
        provider - 附加到Java虚拟机的AttachProvider。
        id - 虚拟机标识符。
        displayName - 显示名称。
        异常
        NullPointerException - 如果任何参数是 null

      • VirtualMachineDescriptor

        public VirtualMachineDescriptor​(AttachProvider provider,
                                String id)
        从给定的组件创建一个虚拟机描述符。

        这个方便的构造函数就像调用三参数构造函数一样工作，如下所示：

        new VirtualMachineDescriptor(provider,  id,  id);

        也就是说，它创建一个虚拟机描述符，使得显示名称与虚拟机标识符相同。

        参数
        provider - 附加到Java虚拟机的AttachProvider。
        id - 虚拟机标识符。
        异常
        NullPointerException - 如果 provider或 id是 null 。

    • 方法详细信息

      • provider

        public AttachProvider provider​()
        返回此描述符引用的 AttachProvider 。
        结果
        这个描述符引用的 AttachProvider 。

      • id

        public String id​()
        返回此描述符的标识符组件。
        结果
        该描述符的标识符组件。

      • displayName

        public String displayName​()
        返回此描述符的 显示名称组件。
        结果
        该描述符的显示名称组件。

      • hashCode

        public int hashCode​()
        返回此VirtualMachineDescriptor的哈希码值。 哈希码基于描述符的组件，并且符合Object.hashCode方法的总体合同。
        重写：
        hashCode在 Object
        结果
        该描述符的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        测试此VirtualMachineDescriptor与其他对象的相等性。

        如果给定对象不是VirtualMachineDescriptor，那么此方法返回false 。 对于两个被认为是相等的VirtualMachineDescriptors要求它们都引用同一个提供者，而他们的identifiers是相等的。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果并且只有给定的对象是等于该VirtualMachineDescriptor的VirtualMachineDescriptor。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回 VirtualMachineDescriptor的字符串表示 VirtualMachineDescriptor 。
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.AgentInitializationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.AgentInitializationException

  • Packages that use AgentInitializationException
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。

    • Uses of AgentInitializationException in com.sun.tools.attach

      Methods in com.sun.tools.attach that throw AgentInitializationException
      Modifier and Type 方法 描述
      void VirtualMachine.loadAgent​(String agent)
      加载代理
      abstract void VirtualMachine.loadAgent​(String agent, String options)
      加载代理
      void VirtualMachine.loadAgentLibrary​(String agentLibrary)
      加载代理库。
      abstract void VirtualMachine.loadAgentLibrary​(String agentLibrary, String options)
      加载代理库。
      void VirtualMachine.loadAgentPath​(String agentPath)
      以完整路径名加载本地代理库。
      abstract void VirtualMachine.loadAgentPath​(String agentPath, String options)
      Load a native agent library by full pathname.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.AgentLoadException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.AgentLoadException

  • Packages that use AgentLoadException
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。

    • Uses of AgentLoadException in com.sun.tools.attach

      Methods in com.sun.tools.attach that throw AgentLoadException
      Modifier and Type 方法 描述
      void VirtualMachine.loadAgent​(String agent)
      加载代理
      abstract void VirtualMachine.loadAgent​(String agent, String options)
      加载代理
      void VirtualMachine.loadAgentLibrary​(String agentLibrary)
      加载代理库。
      abstract void VirtualMachine.loadAgentLibrary​(String agentLibrary, String options)
      加载代理库。
      void VirtualMachine.loadAgentPath​(String agentPath)
      以完整路径名加载本地代理库。
      abstract void VirtualMachine.loadAgentPath​(String agentPath, String options)
      Load a native agent library by full pathname.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.AttachNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.AttachNotSupportedException

  • Packages that use AttachNotSupportedException
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。

    • Uses of AttachNotSupportedException in com.sun.tools.attach

      Methods in com.sun.tools.attach that throw AttachNotSupportedException
      Modifier and Type 方法 描述
      static VirtualMachine VirtualMachine.attach​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      static VirtualMachine VirtualMachine.attach​(String id)
      附加到Java虚拟机。

    • Uses of AttachNotSupportedException in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that throw AttachNotSupportedException
      Modifier and Type 方法 描述
      VirtualMachine AttachProvider.attachVirtualMachine​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      abstract VirtualMachine AttachProvider.attachVirtualMachine​(String id)
      附加到Java虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.AttachOperationFailedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.AttachOperationFailedException

No usage of com.sun.tools.attach.AttachOperationFailedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.AttachPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.AttachPermission

No usage of com.sun.tools.attach.AttachPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.VirtualMachine (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.VirtualMachine

  • Packages that use VirtualMachine
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。

    • Uses of VirtualMachine in com.sun.tools.attach

      Methods in com.sun.tools.attach that return VirtualMachine
      Modifier and Type 方法 描述
      static VirtualMachine VirtualMachine.attach​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      static VirtualMachine VirtualMachine.attach​(String id)
      附加到Java虚拟机。

    • Uses of VirtualMachine in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that return VirtualMachine
      Modifier and Type 方法 描述
      VirtualMachine AttachProvider.attachVirtualMachine​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      abstract VirtualMachine AttachProvider.attachVirtualMachine​(String id)
      附加到Java虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.VirtualMachineDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.VirtualMachineDescriptor

  • Packages that use VirtualMachineDescriptor
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。

    • Uses of VirtualMachineDescriptor in com.sun.tools.attach

      Methods in com.sun.tools.attach that return types with arguments of type VirtualMachineDescriptor
      Modifier and Type 方法 描述
      static List<VirtualMachineDescriptor> VirtualMachine.list​()
      返回Java虚拟机的列表。
      Methods in com.sun.tools.attach with parameters of type VirtualMachineDescriptor
      Modifier and Type 方法 描述
      static VirtualMachine VirtualMachine.attach​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。

    • Uses of VirtualMachineDescriptor in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that return types with arguments of type VirtualMachineDescriptor
      Modifier and Type 方法 描述
      abstract List<VirtualMachineDescriptor> AttachProvider.listVirtualMachines​()
      列出此提供程序已知的Java虚拟机。
      Methods in com.sun.tools.attach.spi with parameters of type VirtualMachineDescriptor
      Modifier and Type 方法 描述
      VirtualMachine AttachProvider.attachVirtualMachine​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AttachProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.attach
软件包 com.sun.tools.attach.spi

Class AttachProvider

  • java.lang.Object
    • com.sun.tools.attach.spi.AttachProvider

  • public abstract class AttachProvider
extends Object
    附加提供程序类以附加到Java虚拟机。

    附加提供者是这个类的具体子类，它具有零参数的构造函数，并实现下面指定的抽象方法。

    附加提供商实现通常与Java虚拟机实现，版本或甚至操作模式相关联。 也就是说，特定的提供者实现通常只能附加到特定的Java虚拟机实现或版本。 例如，Sun的JDK实现随附提供者实现，只能附加到Sun的HotSpot虚拟机。 一般来说，如果环境由不同版本的Java虚拟机和不同的供应商组成，那么每个实现或版本系列都将有一个附加提供程序实现。

    附件提供商由其name和type标识 。 该名称通常是但不是必须是与VM供应商对应的名称。 例如，Sun JDK实现附带使用名称为“sun”的附加提供程序。 该类型通常对应于附接机制。 例如，使用门进程间通信机制的实现可能使用类型“门” 。 名称和类型的目的是在安装了多个提供程序的环境中识别提供程序。

    在第一次调用providers方法时，AttachProvider实现被加载和实例化。 此方法尝试加载安装在平台上的所有提供程序实现。

    此类中的所有方法都可以安全地被多个并发线程使用。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AttachProvider​()
      初始化此类的新实例。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      VirtualMachine attachVirtualMachine​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      abstract VirtualMachine attachVirtualMachine​(String id)
      附加到Java虚拟机。
      abstract List<VirtualMachineDescriptor> listVirtualMachines​()
      列出此提供程序已知的Java虚拟机。
      abstract String name​()
      返回此提供商的名称。
      static List<AttachProvider> providers​()
      返回已安装附件提供商的列表。
      abstract String type​()
      返回此提供商的类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AttachProvider

        protected AttachProvider​()
        初始化此类的新实例。
        异常
        SecurityException - 如果安全管理器已安装，并且它拒绝AttachPermission （“ createAttachProvider ”）

    • 方法详细信息

      • name

        public abstract String name​()
        返回此提供商的名称。
        结果
        这个提供者的名字

      • type

        public abstract String type​()
        返回此提供商的类型。
        结果
        这个提供者的类型

      • attachVirtualMachine

        public abstract VirtualMachine attachVirtualMachine​(String id)
                                             throws AttachNotSupportedException,
                                                    IOException
        附加到Java虚拟机。

        Java虚拟机由抽象标识符标识。 此标识符的性质取决于平台，但在许多情况下，它将是进程标识符（或pid）的字符串表示形式。

        该方法解析标识符并将标识符映射到Java虚拟机（以实现方式依赖的方式）。 如果标识符不能由提供商解析，则抛出一个AttachNotSupportedException 。 一旦解析，此方法将尝试附加到Java虚拟机。 如果提供程序检测到标识符对应于不存在的Java虚拟机，或者对应于不支持此提供程序实现的附加机制的Java虚拟机，或者它检测到Java虚拟机是一个版本这个提供者不能附加，那么抛出一个AttachNotSupportedException 。

        参数
        id - 标识Java虚拟机的抽象标识符。
        结果
        VirtualMachine表示目标虚拟机。
        异常
        SecurityException - 如果已安装安全管理员，并且拒绝了AttachPermission （“ attachVirtualMachine ”）或实施所需的其他权限。
        AttachNotSupportedException - 如果标识符无法解析，或者对应于不存在的Java虚拟机，或者对应于此提供程序无法附加的Java虚拟机。
        IOException - 如果发生其他I / O错误
        NullPointerException - 如果 id是 null

      • attachVirtualMachine

        public VirtualMachine attachVirtualMachine​(VirtualMachineDescriptor vmd)
                                    throws AttachNotSupportedException,
                                           IOException
        附加到Java虚拟机。

        可以使用VirtualMachineDescriptor描述Java虚拟机。 此方法调用描述符的provider()方法来检查它是否等于此提供程序。 然后它尝试附加到Java虚拟机。

        参数
        vmd - 虚拟机描述符
        结果
        VirtualMachine表示目标虚拟机。
        异常
        SecurityException - 如果已安装安全管理员，并且拒绝了AttachPermission （“ attachVirtualMachine ”）或实施所需的其他权限。
        AttachNotSupportedException - 如果描述符的 provider()方法返回不是此提供程序的提供程序，或者它不对应于此提供程序可以附加的Java虚拟机。
        IOException - 如果发生其他I / O错误
        NullPointerException - 如果 vmd是 null

      • listVirtualMachines

        public abstract List<VirtualMachineDescriptor> listVirtualMachines​()
        列出此提供程序已知的Java虚拟机。

        此方法返回VirtualMachineDescriptor元素的列表。 每个VirtualMachineDescriptor描述了该提供程序可能附加到的Java虚拟机。 没有任何保证在列表中的每个描述符上调用attachVirtualMachine将成功。

        结果
        描述此提供程序已知的Java虚拟机的虚拟机描述符列表（可能为空）。

      • providers

        public static List<AttachProvider> providers​()
        返回已安装附件提供商的列表。

        如果以下情况，则在Platform平台上安装AttachProvider：

        • 它被安装在一个JAR文件是将AttachProvider类型的定义类装载程序可见的（通常，但不是必需的， system class loader ）。
        • JAR文件包含资源目录META-INF/services名为com.sun.tools.attach.spi.AttachProvider的提供程序配置。
        • 提供者配置文件列出了AttachProvider实现的全限定类名。

        提供程序配置文件的格式是每行一个完全限定的类名。 围绕每个类名称的空格和制表符字符以及空白行都将被忽略。 注释字符为'#' （ 0x23 ），并且在每行上，忽略第一个注释字符后面的所有字符。 文件必须以UTF-8编码。

        在首次调用此方法时，AttachProvider实现将被加载和实例化（使用零参数构造函数）。 第一次调用此方法返回的列表是提供程序列表。 此方法的后续调用返回相同提供程序的列表。 该列表是不可修改的。

        结果
        已安装附件提供商的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


com.sun.tools.attach.spi (Java SE 9 & JDK 9 )

com.sun.tools.attach.spi

Classes

  • AttachProvider


com.sun.tools.attach.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.attach

Package com.sun.tools.attach.spi

只有定义新附加提供商的开发者才需要直接使用这个包。
从以下版本开始：
1.6
  • 类摘要
    Class 描述
    AttachProvider
    附加提供程序类以附加到Java虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.attach.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.tools.attach.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.tools.attach.spi.AttachProvider
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Package com.sun.tools.attach.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.tools.attach.spi

  • Packages that use com.sun.tools.attach.spi
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。
  • Classes in com.sun.tools.attach.spi used by com.sun.tools.attach
    Class 描述
    AttachProvider
    附加提供程序类以附加到Java虚拟机。
  • Classes in com.sun.tools.attach.spi used by com.sun.tools.attach.spi
    Class 描述
    AttachProvider
    附加提供程序类以附加到Java虚拟机。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.attach.spi.AttachProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.attach.spi.AttachProvider

  • Packages that use AttachProvider
    软件包 描述
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。

    • Uses of AttachProvider in com.sun.tools.attach

      Methods in com.sun.tools.attach that return AttachProvider
      Modifier and Type 方法 描述
      AttachProvider VirtualMachine.provider​()
      返回创建此虚拟机的提供程序。
      AttachProvider VirtualMachineDescriptor.provider​()
      返回这个描述符引用的 AttachProvider 。
      Constructors in com.sun.tools.attach with parameters of type AttachProvider
      Constructor 描述
      VirtualMachine​(AttachProvider provider, String id)
      初始化此类的新实例。
      VirtualMachineDescriptor​(AttachProvider provider, String id)
      从给定的组件创建一个虚拟机描述符。
      VirtualMachineDescriptor​(AttachProvider provider, String id, String displayName)
      从给定的组件创建一个虚拟机描述符。

    • Uses of AttachProvider in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that return types with arguments of type AttachProvider
      Modifier and Type 方法 描述
      static List<AttachProvider> AttachProvider.providers​()
      返回已安装附件提供商的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.doclets (Java SE 9 & JDK 9 )

com.sun.tools.doclets

Interfaces

  • Taglet


com.sun.tools.doclets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.javadoc

Package com.sun.tools.doclets

注意：此包中的声明已被新包jdk.javadoc.doclet中的声明所取代。

  • 接口摘要
    接口 描述
    Taglet Deprecated.
    该接口已被替换， Taglet取代。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.doclets Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.tools.doclets

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • com.sun.tools.doclets.Taglet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Taglet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.tools.doclets

Interface Taglet

  • 已过时。
    该接口已被替换， Taglet取代。

    @Deprecated
public interface Taglet
    Doclets使用的自定义标签的界面。 自定义标签必须实现此接口。

    注意：此接口已被替换， Taglet替代。

    要在运行时由doclet加载和使用，taglet必须具有一个名为register的静态方法，该方法接受Map作为具有以下签名的参数：
      public void register(Map map)
    该方法应该将自定义taglet的实例添加到地图中，其中taglet的名称作为关键字。 如果覆盖一个taglet，为了避免名称冲突，必须先从地图中删除被覆盖的taglet，然后再将新taglet的实例添加到地图中。

    建议taglet在注册失败时引发异常。 它抛出的异常取决于用户。

    以下是两个示例标签：

    • ToDoTaglet.java - 独立标签
    • UnderlineTaglet.java - 内联标签

    有关如何创建自己的Taglets的更多信息，请参阅Taglet Overview 。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      String getName​()
      已过时。
      返回此自定义标签的名称。
      boolean inConstructor​()
      已过时。
      如果在构造函数文档中使用了这个 Taglet则返回true。
      boolean inField​()
      已过时。
      如果在现场文档中使用 Taglet则返回true。
      boolean inMethod​()
      已过时。
      如果在方法文档中使用了 Taglet则返回true。
      boolean inOverview​()
      已过时。
      如果在概述文档中使用了 Taglet则返回true。
      boolean inPackage​()
      已过时。
      如果在包文档中使用了 Taglet则返回true。
      boolean inType​()
      已过时。
      如果在类型文档（类或接口）中使用了 Taglet则返回true。
      boolean isInlineTag​()
      已过时。
      如果这个 Taglet是内联标签，则返回true。
      String toString​(Tag tag)
      已过时。
      给定此自定义标签的 Tag表示形式，返回其字符串表示形式，将其输出到生成的页面。
      String toString​(Tag[] tags)
      已过时。
      给定一个表示此自定义标签的数组 Tag s，返回其字符串表示，将其输出到生成的页面。

    • 方法详细信息

      • inField

        boolean inField​()
        已过时。
        如果在现场文档中使用了Taglet则返回true。 为内联标签设置为false。
        结果
        如果在现场文档中使用了 Taglet则为true，否则为false。

      • inConstructor

        boolean inConstructor​()
        已过时。
        如果在构造函数文档中使用了这个Taglet则返回true。 为内联标签设置为false。
        结果
        如果在构造函数文档中使用了 Taglet则为true，否则为false。

      • inMethod

        boolean inMethod​()
        已过时。
        如果在方法文档中使用了这个Taglet则返回true。 为内联标签设置为false。
        结果
        如果在方法文档中使用此 Taglet则为true，否则为false。

      • inOverview

        boolean inOverview​()
        已过时。
        如果在概述文档中使用了Taglet则返回true。 为内联标签设置为false。
        结果
        如果在方法文档中使用了 Taglet则为true，否则为false。

      • inPackage

        boolean inPackage​()
        已过时。
        如果在包文档中使用了Taglet则返回true。 为内联标签设置为false。
        结果
        如果在包文档中使用了 Taglet则为true，否则为false。

      • inType

        boolean inType​()
        已过时。
        如果在类型文档（类或接口）中使用了Taglet则返回true。 为内联标签设置为false。
        结果
        如果在类型文档中使用了 Taglet则为true，否则为false。

      • isInlineTag

        boolean isInlineTag​()
        已过时。
        如果这是Taglet是一个内联标签，返回true。 否则返回false。
        结果
        如果这是 Taglet是一个内联标签， Taglet true，否则为false。

      • getName

        String getName​()
        已过时。
        返回此自定义标签的名称。
        结果
        这个自定义标签的名称。

      • toString

        String toString​(Tag tag)
        已过时。
        给定此自定义标签的 Tag表示形式，返回其字符串表示形式，将其输出到生成的页面。
        参数
        tag - 这个自定义标签的 Tag表示。
        结果
        该字符串表示为 Tag 。

      • toString

        String toString​(Tag[] tags)
        已过时。
        给定一个表示此自定义标签的数组Tag s，返回其字符串表示形式，将其输出到生成的页面。 如果此taglet表示内联标记，则此方法应返回null。
        参数
        tags - 表示此自定义标签的 Tag s的数组。
        结果
        该字符串表示为 Tag 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.tools.doclets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.tools.doclets

No usage of com.sun.tools.doclets
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.tools.doclets.Taglet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.tools.doclets.Taglet

No usage of com.sun.tools.doclets.Taglet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.doclets.standard (Java SE 9 & JDK 9 )

com.sun.tools.doclets.standard

Classes

  • Standard


com.sun.tools.doclets.standard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.javadoc

Package com.sun.tools.doclets.standard

注意：此包中的声明已被新包jdk.javadoc.doclet中的声明所取代。

  • 类摘要
    Class 描述
    Standard Deprecated, for removal: This API element is subject to removal in a future version.
    该文件已经被替换， StandardDoclet取代。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.doclets.standard Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.tools.doclets.standard

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.tools.doclets.standard.Standard
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Standard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.tools.doclets.standard

Class Standard

  • java.lang.Object
    • com.sun.tools.doclets.standard.Standard
  • 不推荐用于删除：此API元素将在以后的版本中被删除。
    该文件夹已被替换， StandardDoclet取代。

    @Deprecated(forRemoval=true,
            since="9")
public class Standard
extends Object
    该doclet为指定的包和类型生成HTML格式的文档。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Standard​()
      不推荐用于删除：此API元素将在以后的版本中被删除。

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static LanguageVersion languageVersion​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      static int optionLength​(String option)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      static boolean start​(RootDoc root)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      static boolean validOptions​(String[][] options, DocErrorReporter reporter)
      不推荐用于删除：此API元素将在以后的版本中被删除。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Standard

        public Standard​()
        不推荐用于删除：此API元素将在以后的版本中被删除。

    • 方法详细信息

      • optionLength

        public static int optionLength​(String option)
        不推荐用于删除：此API元素将在以后的版本中被删除。

      • start

        public static boolean start​(RootDoc root)
        不推荐用于删除：此API元素将在以后的版本中被删除。

      • validOptions

        public static boolean validOptions​(String[][] options,
                                   DocErrorReporter reporter)
        不推荐用于删除：此API元素将在以后的版本中被删除。

      • languageVersion

        public static LanguageVersion languageVersion​()
        Deprecated, for removal: This API element is subject to removal in a future version.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.tools.doclets.standard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.tools.doclets.standard

No usage of com.sun.tools.doclets.standard
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.doclets.standard.Standard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.doclets.standard.Standard

No usage of com.sun.tools.doclets.standard.Standard
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.javac (Java SE 9 & JDK 9 )

com.sun.tools.javac

Classes

  • Main


com.sun.tools.javac (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.compiler

Package com.sun.tools.javac

该包提供了javac工具的传统入口点。 有关替换API的详细信息，请参阅jdk.compiler模块。
  • 类摘要
    Class 描述
    Main
    Java编程语言编译器javac的遗留编程接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.javac Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.tools.javac

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.tools.javac.Main
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Main (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.compiler
软件包 com.sun.tools.javac

Class Main

  • java.lang.Object
    • com.sun.tools.javac.Main

  • public class Main
extends Object
    Java编程语言编译器javac的遗留编程接口。 有关替换API的详细信息，请参阅jdk.compiler模块。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Main​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static int compile​(String[] args)
      Java编程语言编程器的编程接口javac。
      static int compile​(String[] args, PrintWriter out)
      Java编程语言编程器的编程接口javac。
      static void main​(String[] args)
      发射器的主入口点。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Main

        public Main​()

    • 方法详细信息

      • main

        public static void main​(String[] args)
                 throws 异常
        发射器的主入口点。 注意：此方法调用System.exit。
        参数
        args - 命令行参数
        异常
        异常

      • compile

        public static int compile​(String[] args)
        Java编程语言编程器的编程接口javac。
        参数
        args - 通常按照手册页中所述将命令行参数传递给javac程序。
        结果
        一个整数等价于调用javac的退出值，有关详细信息，请参阅手册页。

      • compile

        public static int compile​(String[] args,
                          PrintWriter out)
        Java编程语言编程器的编程接口javac。
        参数
        args - 通常按照手册页中所述传递给javac程序的命令行参数。
        out - 编译器的诊断输出所针对的PrintWriter。
        结果
        一个整数等价于调用javac的退出值，有关详细信息，请参阅手册页。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.tools.javac (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.tools.javac

No usage of com.sun.tools.javac
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.javac.Main (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.javac.Main

No usage of com.sun.tools.javac.Main
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.javadoc (Java SE 9 & JDK 9 )

com.sun.tools.javadoc

Classes

  • Main


com.sun.tools.javadoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.javadoc

Package com.sun.tools.javadoc

此软件包及其内容已被弃用，可能会在将来的版本中删除。 有关替换功能，请参阅javax.tools.ToolProvider.getSystemDocumentationTool和javax.tools.DocumentationTool 。
  • 类摘要
    Class 描述
    Main Deprecated.
    此类现在已被弃用，可能会在将来的版本中删除。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.javadoc Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.tools.javadoc

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.tools.javadoc.Main
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Main (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.javadoc
软件包 com.sun.tools.javadoc

Class Main

  • java.lang.Object
    • com.sun.tools.javadoc.Main
  • 已过时。
    此类现在已被弃用，可能会在将来的版本中删除。 有关替换功能，请参阅javax.tools.ToolProvider::getSystemDocumentationTool和javax.tools.DocumentationTool 。

    @Deprecated
public class Main
extends Object
    为javadoc程序提供外部入口点（工具和编程）。

    这不是任何支持的API的一部分。 如果您编写依赖于此的代码，则您自行承担风险。 此代码及其内部接口可能会更改或删除，恕不另行通知。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static int execute​(ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int execute​(String... args)
      已过时。
      程式化界面。
      static int execute​(String programName, PrintWriter errWriter, PrintWriter warnWriter, PrintWriter noticeWriter, String defaultDocletClassName, ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int execute​(String programName, PrintWriter errWriter, PrintWriter warnWriter, PrintWriter noticeWriter, String defaultDocletClassName, String... args)
      已过时。
      程式化界面。
      static int execute​(String programName, ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int execute​(String programName, String... args)
      已过时。
      程式化界面。
      static int execute​(String programName, String defaultDocletClassName, ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int execute​(String programName, String defaultDocletClassName, String... args)
      已过时。
      程式化界面。
      static void main​(String... args)
      已过时。
      命令行界面。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • main

        public static void main​(String... args)
        已过时。
        命令行界面。
        参数
        args - 命令行参数。

      • execute

        public static int execute​(String... args)
        已过时。
        程式化界面。
        参数
        args - 命令行参数。
        结果
        返回码。

      • execute

        public static int execute​(ClassLoader docletParentClassLoader,
                          String... args)
        已过时。
        程式化界面。
        参数
        args - 命令行参数。
        docletParentClassLoader - 创建doclet类加载器时使用的父类加载器。 如果为空，则将创建用于实例化doclet的类加载器，而不指定父类加载器。
        结果
        返回码。
        从以下版本开始：
        1.7

      • execute

        public static int execute​(String programName,
                          String... args)
        已过时。
        程式化界面。
        参数
        programName - 程序名称（用于错误消息）。
        args - 命令行参数。
        结果
        返回码。

      • execute

        public static int execute​(String programName,
                          ClassLoader docletParentClassLoader,
                          String... args)
        已过时。
        程式化界面。
        参数
        programName - 程序名称（用于错误消息）。
        args - 命令行参数。
        docletParentClassLoader - 创建doclet类加载器时使用的父类加载器。 如果为空，则将创建用于实例化doclet的类加载器，而不指定父类加载器。
        结果
        返回码。
        从以下版本开始：
        1.7

      • execute

        public static int execute​(String programName,
                          String defaultDocletClassName,
                          String... args)
        已过时。
        程式化界面。
        参数
        programName - 程序名称（用于错误消息）。
        defaultDocletClassName - 完全合格的类名。
        args - 命令行参数。
        结果
        返回码。

      • execute

        public static int execute​(String programName,
                          String defaultDocletClassName,
                          ClassLoader docletParentClassLoader,
                          String... args)
        已过时。
        程式化界面。
        参数
        programName - 程序名称（用于错误消息）。
        defaultDocletClassName - 完全合格的类名。
        docletParentClassLoader - 创建doclet类加载器时使用的父类加载器。 如果为空，则将创建用于实例化doclet的类加载器，而不指定父类加载器。
        args - 命令行参数。
        结果
        返回码。
        从以下版本开始：
        1.7

      • execute

        public static int execute​(String programName,
                          PrintWriter errWriter,
                          PrintWriter warnWriter,
                          PrintWriter noticeWriter,
                          String defaultDocletClassName,
                          String... args)
        已过时。
        程式化界面。
        参数
        programName - 程序名称（用于错误消息）。
        errWriter - PrintWriter接收错误消息。
        warnWriter - PrintWriter接收错误消息。
        noticeWriter - PrintWriter接收错误消息。
        defaultDocletClassName - 完全限定类名。
        args - 命令行参数。
        结果
        返回码。

      • execute

        public static int execute​(String programName,
                          PrintWriter errWriter,
                          PrintWriter warnWriter,
                          PrintWriter noticeWriter,
                          String defaultDocletClassName,
                          ClassLoader docletParentClassLoader,
                          String... args)
        已过时。
        程式化界面。
        参数
        programName - 程序名称（用于错误消息）。
        errWriter - PrintWriter接收错误消息。
        warnWriter - PrintWriter接收错误消息。
        noticeWriter - PrintWriter接收错误消息。
        defaultDocletClassName - 完全合格的类名。
        docletParentClassLoader - 创建doclet类加载器时使用的父类加载器。 如果为空，则将创建用于实例化doclet的类加载器，而不指定父类加载器。
        args - 命令行参数。
        结果
        返回码。
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.tools.javadoc (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.tools.javadoc

No usage of com.sun.tools.javadoc
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.javadoc.Main (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.javadoc.Main

No usage of com.sun.tools.javadoc.Main
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.jconsole (Java SE 9 & JDK 9 )

com.sun.tools.jconsole

Interfaces

  • JConsoleContext

Classes

  • JConsolePlugin

Enums

  • JConsoleContext.ConnectionState


com.sun.tools.jconsole (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module jdk.jconsole

Package com.sun.tools.jconsole

此程序包包含JConsole API。
从以下版本开始：
1.6
  • 接口摘要
    接口 描述
    JConsoleContext
    JConsoleContext表示与目标应用程序的JConsole连接。
  • 类摘要
    Class 描述
    JConsolePlugin
    一个JConsole插件类。
  • 枚举摘要
    Enum 描述
    JConsoleContext.ConnectionState
    值为ConnectionState绑定属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


com.sun.tools.jconsole Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package com.sun.tools.jconsole

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sun.tools.jconsole.JConsolePlugin

Interface Hierarchy

  • com.sun.tools.jconsole.JConsoleContext

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.sun.tools.jconsole.JConsoleContext.ConnectionState
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


JConsoleContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module jdk.jconsole
软件包 com.sun.tools.jconsole

Interface JConsoleContext

  • public interface JConsoleContext
    JConsoleContext表示与目标应用程序的JConsole连接。

    JConsoleContext通知任何PropertyChangeListeners有关ConnectionState属性更改为CONNECTED和DISCONNECTED 。 JConsoleContext实例将是任何生成的事件的源。

    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  JConsoleContext.ConnectionState
      ConnectionState绑定属性的值。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String CONNECTION_STATE_PROPERTY
      ConnectionState绑定属性名称。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(PropertyChangeListener listener)
      添加PropertyChangeListener到侦听器列表。
      JConsoleContext.ConnectionState getConnectionState​()
      返回当前的连接状态。
      MBeanServerConnection getMBeanServerConnection​()
      返回与应用程序的连接的MBeanServerConnection 。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除PropertyChangeListener 。

    • 字段详细信息

      • CONNECTION_STATE_PROPERTY

        static final String CONNECTION_STATE_PROPERTY
        ConnectionState绑定属性名称。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getMBeanServerConnection

        MBeanServerConnection getMBeanServerConnection​()
        返回与应用程序的连接的MBeanServerConnection 。 当连接状态更改为DISCONNECTED状态时，返回的MBeanServerConnection对象将变为无效。
        结果
        MBeanServerConnection用于连接到应用程序。

      • getConnectionState

        JConsoleContext.ConnectionState getConnectionState​()
        返回当前的连接状态。
        结果
        当前连接状态。

      • addPropertyChangeListener

        void addPropertyChangeListener​(PropertyChangeListener listener)
        添加PropertyChangeListener到监听器列表。 所有属性都注册了监听器。 同一个侦听器对象可以被多次添加，并且将被调用多次，因为它被添加。 如果listener为null ，则不会引发任何异常，也不会采取任何行动。
        参数
        listener - 要添加的 PropertyChangeListener

      • removePropertyChangeListener

        void removePropertyChangeListener​(PropertyChangeListener listener)
        从侦听器列表中删除PropertyChangeListener 。 这将删除所有属性注册的PropertyChangeListener 。 如果listener添加到同一个事件源，则被删除后会被通知一次。 如果listener是null ，或者从未添加，则不会抛出异常，也不会采取任何操作。
        参数
        listener - 要删除的 PropertyChangeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JConsoleContext.ConnectionState (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module jdk.jconsole
软件包 com.sun.tools.jconsole

Enum JConsoleContext.ConnectionState

  • java.lang.Object
    • java.lang.Enum<JConsoleContext.ConnectionState>
      • com.sun.tools.jconsole.JConsoleContext.ConnectionState
  • All Implemented Interfaces:
    Serializable ， Comparable<JConsoleContext.ConnectionState>
    Enclosing interface:
    JConsoleContext

    public static enum JConsoleContext.ConnectionState
extends Enum<JConsoleContext.ConnectionState>
    ConnectionState绑定属性的值。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONNECTED
      连接已成功建立。
      CONNECTING
      正在尝试连接。
      DISCONNECTED
      没有连接。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static JConsoleContext.ConnectionState valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static JConsoleContext.ConnectionState[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONNECTED

        public static final JConsoleContext.ConnectionState CONNECTED
        连接已成功建立。

      • DISCONNECTED

        public static final JConsoleContext.ConnectionState DISCONNECTED
        没有连接。

      • CONNECTING

        public static final JConsoleContext.ConnectionState CONNECTING
        正在尝试连接。

    • 方法详细信息

      • values

        public static JConsoleContext.ConnectionState[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (JConsoleContext.ConnectionState c : JConsoleContext.ConnectionState.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static JConsoleContext.ConnectionState valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


JConsolePlugin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module jdk.jconsole
软件包 com.sun.tools.jconsole

Class JConsolePlugin

  • java.lang.Object
    • com.sun.tools.jconsole.JConsolePlugin

  • public abstract class JConsolePlugin
extends Object
    一个JConsole插件类。 JConsole使用service provider机制来搜索JConsole插件。 用户可以将JConsole插件提供到包含名为文件的jar文件中
     META-INF/services/com.sun.tools.jconsole.JConsolePlugin

    该文件包含每个插件的一行，例如，

     com.sun.example.JTop

    这是执行JConsolePlugin的类的完全限定类名称。

    要在JConsole中加载JConsole插件，请运行：

     jconsole -pluginpath <plugin-path>

    其中<plugin-path>指定JConsole插件的路径来查找哪个可以是目录或jar文件。 多个路径由平台的路径分隔符分隔。

    为连接创建新的JConsole窗口时，将创建每个JConsolePlugin的实例。 JConsoleContext对象在其施工时间不可用。 创建插件对象后，JConsole将为插件设置JConsoleContext对象。 然后，它将调用其getTabs方法，并将返回的选项卡添加到JConsole窗口。

    从以下版本开始：
    1.6
    另请参见：
    ServiceLoader

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected JConsolePlugin​()
      构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addContextPropertyChangeListener​(PropertyChangeListener listener)
      在此插件的JConsoleContext对象中添加一个PropertyChangeListener 。
      void dispose​()
      处理这个插件。
      JConsoleContext getContext​()
      返回表示与应用程序的连接的JConsoleContext对象。
      abstract Map<String,JPanel> getTabs​()
      返回要在JConsole窗口中添加的选项卡。
      abstract SwingWorker<?,?> newSwingWorker​()
      返回SwingWorker以与JConsole更新GUI相同的间隔执行此插件的GUI更新。
      void removeContextPropertyChangeListener​(PropertyChangeListener listener)
      从此插件的JConsoleContext对象的侦听器列表中删除PropertyChangeListener 。
      void setContext​(JConsoleContext context)
      设置表示与应用程序的连接的JConsoleContext对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JConsolePlugin

        protected JConsolePlugin​()
        构造函数。

    • 方法详细信息

      • setContext

        public final void setContext​(JConsoleContext context)
        设置表示与应用程序的连接的JConsoleContext对象。 在创建插件后，调用getTabs()之前，此方法将仅被调用一次。 给定的context可以在任何connection state当这个方法被调用。
        参数
        context - 一个 JConsoleContext对象

      • getContext

        public final JConsoleContext getContext​()
        返回表示与应用程序的连接的JConsoleContext对象。 如果在初始化context之前调用该方法，则此方法可能会返回null 。
        结果
        表示与应用程序的连接的JConsoleContext对象。

      • getTabs

        public abstract Map<String,JPanel> getTabs​()
        返回要在JConsole窗口中添加的选项卡。

        返回的映射包含要在JConsole窗口的标签窗格中添加的每个选项卡的一个条目，其中选项卡名称作为键，而JPanel对象作为值。 如果此插件没有添加标签，此方法返回一个空的地图。 在新的连接时间，将从事件调度线程一次调用此方法。

        结果
        表示要在JConsole窗口中添加的选项卡的选项卡名称和JPanel对象的映射; 或空地图。

      • newSwingWorker

        public abstract SwingWorker<?,?> newSwingWorker​()
        返回SwingWorker以与JConsole更新GUI相同的间隔执行此插件的GUI更新。

        JConsole以为连接指定的间隔调度GUI更新。 每个更新都会调用此方法，以获取每个插件的SwingWorker 。

        JConsole将调用execute()方法来计划返回的SwingWorker执行：

        • SwingWorker对象尚未执行（即SwingWorker.getState()方法返回PENDING状态）; 和
        • 上一次更新中返回的SwingWorker对象已完成任务，如果不是null （即SwingWorker.isDone方法返回true ）。

        否则， SwingWorker对象不会被安排工作。

        插件可以安排自己的GUI更新，此方法将返回null 。

        结果
        一个SwingWorker执行GUI更新; 或null 。

      • dispose

        public void dispose​()
        处理这个插件。 此方法由JConsole调用，以通知该插件将被丢弃，并且它应该释放其分配的任何资源。 当这个方法被调用时， JConsoleContext可以在任何connection state中 。

      • addContextPropertyChangeListener

        public final void addContextPropertyChangeListener​(PropertyChangeListener listener)
        为这个插件的JConsoleContext对象添加一个PropertyChangeListener 。 当JConsoleContext对象可能或可能不可用时，此方法是该插件注册侦听器的方便方法。

        例如，一个插件构造函数可以调用这个方法来注册监听器来监听connectionState的属性更改，并且当它可用时，监听器将被添加到JConsoleContext对象中。

        参数
        listener - 要添加的 PropertyChangeListener
        异常
        NullPointerException - 如果 listener是 null 。

      • removeContextPropertyChangeListener

        public final void removeContextPropertyChangeListener​(PropertyChangeListener listener)
        从此插件的JConsoleContext对象的侦听器列表中删除PropertyChangeListener 。 如果没有添加listener则不会抛出异常并且不采取任何操作。
        参数
        listener - 要删除的 PropertyChangeListener
        异常
        NullPointerException - 如果 listener是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package com.sun.tools.jconsole (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
com.sun.tools.jconsole

  • Packages that use com.sun.tools.jconsole
    软件包 描述
    com.sun.tools.jconsole
    此程序包包含JConsole API。
  • Classes in com.sun.tools.jconsole used by com.sun.tools.jconsole
    Class 描述
    JConsoleContext
    JConsoleContext表示与目标应用程序的JConsole连接。
    JConsoleContext.ConnectionState
    值为ConnectionState绑定属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.jconsole.JConsoleContext.ConnectionState (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.jconsole.JConsoleContext.ConnectionState

  • Packages that use JConsoleContext.ConnectionState
    软件包 描述
    com.sun.tools.jconsole
    此程序包包含JConsole API。

    • Uses of JConsoleContext.ConnectionState in com.sun.tools.jconsole

      Methods in com.sun.tools.jconsole that return JConsoleContext.ConnectionState
      Modifier and Type 方法 描述
      JConsoleContext.ConnectionState JConsoleContext.getConnectionState​()
      返回当前的连接状态。
      static JConsoleContext.ConnectionState JConsoleContext.ConnectionState.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static JConsoleContext.ConnectionState[] JConsoleContext.ConnectionState.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class com.sun.tools.jconsole.JConsolePlugin (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
com.sun.tools.jconsole.JConsolePlugin

No usage of com.sun.tools.jconsole.JConsolePlugin
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface com.sun.tools.jconsole.JConsoleContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
com.sun.tools.jconsole.JConsoleContext

  • Packages that use JConsoleContext
    软件包 描述
    com.sun.tools.jconsole
    此程序包包含JConsole API。

    • Uses of JConsoleContext in com.sun.tools.jconsole

      Methods in com.sun.tools.jconsole that return JConsoleContext
      Modifier and Type 方法 描述
      JConsoleContext JConsolePlugin.getContext​()
      返回表示与应用程序的连接的JConsoleContext对象。
      Methods in com.sun.tools.jconsole with parameters of type JConsoleContext
      Modifier and Type 方法 描述
      void JConsolePlugin.setContext​(JConsoleContext context)
      设置表示与应用程序的连接的JConsoleContext对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


A-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

A

a - Variable in class java.awt. AWTEventMulticaster
事件链中的变量（listener-a）
A - javafx.scene.input. KeyCode
常数为 A键。
A - Static variable in class java.awt. PageAttributes.MediaType
Engineering A的MediaType实例，8 1/2 x 11 in。
A - Static variable in class javax.print.attribute.standard. MediaSize.Engineering
指定工程A尺寸，8.5英寸×11英寸。
A - Static variable in class javax.print.attribute.standard. MediaSizeName
大小。
A - Static variable in class javax.swing.text.html. HTML.Tag
标记<a>
A0 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A0的别名。
A0 - Static variable in class javafx.print. Paper
指定ISO A0尺寸，841 mm×1189 mm。
A0 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A0尺寸，841 mm×1189 mm。
A1 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A1的别名。
A1 - Static variable in class javafx.print. Paper
指定ISO A1尺寸，594 mm×841 mm。
A1 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A1尺寸，594 mm×841 mm。
A10 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A10的别名。
A10 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A10尺寸，26 mm x 37 mm。
A2 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A2的别名。
A2 - Static variable in class javafx.print. Paper
指定ISO A2尺寸，420 mm×594 mm。
A2 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A2尺寸，420 mm×594 mm。
A3 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A3的别名。
A3 - Static variable in class javafx.print. Paper
指定ISO A3尺寸，297 mm x 420 mm。
A3 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A3尺寸，297 mm x 420 mm。
A4 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A4的别名。
A4 - Static variable in class javafx.print. Paper
指定ISO A4尺寸，210 mm×297 mm。
A4 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A4尺寸，210 mm×297 mm。
A5 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A5的别名。
A5 - Static variable in class javafx.print. Paper
指定ISO A5尺寸，148 mm×210 mm。
A5 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A5尺寸，148 mm×210 mm。
A6 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A6的别名。
A6 - Static variable in class javafx.print. Paper
指定ISO A6尺寸，105 mm×148 mm。
A6 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A6尺寸，105 mm×148 mm。
A7 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A7的别名。
A7 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A7尺寸，74 mm x 105 mm。
A8 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A8的别名。
A8 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A8尺寸，52 mm x 74 mm。
A9 - Static variable in class java.awt. PageAttributes.MediaType
ISO_A9的别名。
A9 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO A9尺寸，37 mm×52 mm。
AA_COMPROMISE - java.security.cert. CRLReason
这个原因表明已知或怀疑证书对象的私钥已经被泄密。
abort() - Method in class com.sun.security.auth.module. JndiLoginModule
如果LoginContext的整体身份验证失败，则调用此方法。
abort() - Method in class com.sun.security.auth.module. KeyStoreLoginModule
如果LoginContext的整体身份验证失败，则调用此方法。
abort() - Method in class com.sun.security.auth.module. Krb5LoginModule
如果LoginContext的整体身份验证失败，则调用此方法。
abort() - Method in class com.sun.security.auth.module. LdapLoginModule
中止用户身份验证。
abort() - Method in class com.sun.security.auth.module. NTLoginModule
如果LoginContext的整体身份验证失败，则调用此方法。
abort() - Method in class com.sun.security.auth.module. SolarisLoginModule
已过时。
中止身份验证（第二阶段）。
abort() - Method in class com.sun.security.auth.module. UnixLoginModule
中止身份验证（第二阶段）。
abort() - Method in class java.net. CacheRequest
中止缓存响应的尝试。
abort() - Method in class javax.imageio. ImageReader
请求中止任何当前的读取操作。
abort() - Method in class javax.imageio. ImageWriter
请求中止任何当前的写入操作。
abort() - Method in interface javax.security.auth.spi. LoginModule
中止认证过程的方法（阶段2）。
abort() - Method in interface jdk.incubator.http. WebSocket
突然关闭 WebSocket 。
abort() - Method in interface org.w3c.dom.ls. LSParser
中止加载由 LSParser当前正在加载的 LSParser 。
abort(Executor) - Method in interface java.sql. Connection
终止打开的连接。
ABORT - Static variable in interface java.awt.image. ImageObserver
imageUpdate的infoflags参数中的此标志表示在生成完成之前异步跟踪的图像已中止。
ABORTED - Static variable in class java.awt. MediaTracker
表示媒体的下载中止了。
ABORTED - Static variable in class javax.print.attribute.standard. JobState
该作业已被系统中止（通常在作业处于PROCESSING或PROCESSING_STOPPED状态时），打印机已完成中止作业，并且所有作业状态属性已达到作业的最终值。
ABORTED_BY_SYSTEM - Static variable in class javax.print.attribute.standard. JobStateReason
该作业被系统中止。
abortGrabbing() - Method in class java.awt.image. PixelGrabber
请求PixelGrabber中止图像提取。
AbortPolicy() - Constructor for class java.util.concurrent. ThreadPoolExecutor.AbortPolicy
创建一个 AbortPolicy 。
abortRequested() - Method in class javax.imageio. ImageReader
返回 true是否已经做出了中止当前读取操作的请求，因为读者被实例化或 clearAbortRequest被调用。
abortRequested() - Method in class javax.imageio. ImageWriter
返回 true是否已经作出中止当前写入操作的请求自从writer被实例化或 clearAbortRequest被调用。
ABOUT_UIROLE - Static variable in class javax.print. ServiceUIFactory
表示执行信息丰富的“关于”角色的UI。
AboutEvent - Class in java.awt.desktop
当应用程序被要求打开窗口时发送事件。
AboutEvent() - Constructor for class java.awt.desktop. AboutEvent
构造一个 AboutEvent
AboutHandler - Interface in java.awt.desktop
当应用程序被要求显示对话框时，实现者会收到通知。
ABOVE_BASELINE - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
ABOVE_BASELINE_LEADING - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
ABOVE_BASELINE_TRAILING - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
ABOVE_BOTTOM - Static variable in class javax.swing.border. TitledBorder
将标题放在边框底部的底部。
ABOVE_TOP - Static variable in class javax.swing.border. TitledBorder
将标题放在边框顶部的上方。
abs() - Method in class java.math. BigDecimal
返回一个 BigDecimal其值为此 BigDecimal的绝对值，其比例为 this.scale() 。
abs() - Method in class java.math. BigInteger
返回一个BigInteger，它的值是此BigInteger的绝对值。
abs() - Method in class java.time. Duration
以正长度返回此持续时间的副本。
abs(double) - Static method in class java.lang. Math
返回值为 double绝对值。
abs(double) - Static method in class java.lang. StrictMath
返回值为 double绝对值。
abs(float) - Static method in class java.lang. Math
返回值为 float绝对值。
abs(float) - Static method in class java.lang. StrictMath
返回值为 float绝对值。
abs(int) - Static method in class java.lang. Math
返回值为 int绝对值。
abs(int) - Static method in class java.lang. StrictMath
返回值为 int绝对值。
abs(long) - Static method in class java.lang. Math
返回值为 long绝对值。
abs(long) - Static method in class java.lang. StrictMath
返回值为 long绝对值。
abs(MathContext) - Method in class java.math. BigDecimal
返回一个 BigDecimal其值为此 BigDecimal的绝对值，根据上下文设置进行舍入。
AbsentInformationException - Exception in com.sun.jdi
抛出以表示行号或变量信息不可用。
AbsentInformationException() - Constructor for exception com.sun.jdi. AbsentInformationException
AbsentInformationException(String) - Constructor for exception com.sun.jdi. AbsentInformationException
absolute(int) - Method in interface java.sql. ResultSet
将光标移动到此 ResultSet对象中的给定行号。
absolutePath() - Method in class java.util.prefs. AbstractPreferences
实现 absolutePath方法按照在本说明书中 Preferences.absolutePath() 。
absolutePath() - Method in class java.util.prefs. Preferences
返回此首选项节点的绝对路径名。
absoluteProperty() - Method in class javafx.scene.shape. PathElement
指示路径坐标是绝对还是相对的标志。
ABSTRACT - javax.lang.model.element. Modifier
修改者 abstract
ABSTRACT - Static variable in class java.lang.reflect. Modifier
代表 abstract修改 int值。
AbstractAction - Class in javax.swing
该类提供了JFC Action接口的默认实现。
AbstractAction() - Constructor for class javax.swing. AbstractAction
创建一个 Action 。
AbstractAction(String) - Constructor for class javax.swing. AbstractAction
创建一个具有指定名称的 Action 。
AbstractAction(String, Icon) - Constructor for class javax.swing. AbstractAction
创建一个具有指定名称和小图标的 Action 。
AbstractAnnotationValueVisitor6< R, P> - Class in javax.lang.model.util
注释值的骨架访问者，默认行为适用于 RELEASE_6源版本。
AbstractAnnotationValueVisitor6() - Constructor for class javax.lang.model.util. AbstractAnnotationValueVisitor6
已过时。
第6版已经过时了 更新到访问者较新的版本级别。
AbstractAnnotationValueVisitor7< R, P> - Class in javax.lang.model.util
注释值的骨架访问者，默认行为适用于 RELEASE_7源版本。
AbstractAnnotationValueVisitor7() - Constructor for class javax.lang.model.util. AbstractAnnotationValueVisitor7
具体子类调用的构造方法。
AbstractAnnotationValueVisitor8< R, P> - Class in javax.lang.model.util
注释值的骨架访问者，默认行为适用于 RELEASE_8源版本。
AbstractAnnotationValueVisitor8() - Constructor for class javax.lang.model.util. AbstractAnnotationValueVisitor8
具体子类调用的构造方法。
AbstractAnnotationValueVisitor9< R, P> - Class in javax.lang.model.util
注释值的骨架访问者，默认行为适合 RELEASE_9源版本。
AbstractAnnotationValueVisitor9() - Constructor for class javax.lang.model.util. AbstractAnnotationValueVisitor9
具体子类调用的构造方法。
AbstractBorder - Class in javax.swing.border
实现无大小空白边框的类。
AbstractBorder() - Constructor for class javax.swing.border. AbstractBorder
AbstractButton - Class in javax.swing
定义按钮和菜单项的常见行为。
AbstractButton() - Constructor for class javax.swing. AbstractButton
AbstractButton.AccessibleAbstractButton - Class in javax.swing
该类为 AbstractButton类实现可访问性支持。
AbstractButton.ButtonChangeListener - Class in javax.swing
扩展 ChangeListener可串行化。
AbstractCellEditor - Class in javax.swing
CellEditors的基类，为 CellEditor接口中的方法提供默认实现，除了 getCellEditorValue() 。
AbstractCellEditor() - Constructor for class javax.swing. AbstractCellEditor
AbstractChronology - Class in java.time.chrono
用于组织和识别日期的日历系统的抽象实现。
AbstractChronology() - Constructor for class java.time.chrono. AbstractChronology
创建一个实例。
AbstractCollection< E> - Class in java.util
此类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
AbstractCollection() - Constructor for class java.util. AbstractCollection
唯一的构造函数。
AbstractColorChooserPanel - Class in javax.swing.colorchooser
这是颜色选择器的抽象超类。
AbstractColorChooserPanel() - Constructor for class javax.swing.colorchooser. AbstractColorChooserPanel
AbstractDocument - Class in javax.swing.text
实现文档界面，作为实施各种文件的基础。
AbstractDocument(AbstractDocument.Content) - Constructor for class javax.swing.text. AbstractDocument
构造一个新的 AbstractDocument ，包裹了一些指定的内容存储机制。
AbstractDocument(AbstractDocument.Content, AbstractDocument.AttributeContext) - Constructor for class javax.swing.text. AbstractDocument
构造一个新的 AbstractDocument ，包含一些指定的内容存储机制。
AbstractDocument.AbstractElement - Class in javax.swing.text
实现元素的抽象部分。
AbstractDocument.AttributeContext - Interface in javax.swing.text
一个可用于允许MutableAttributeSet实现使用可插拔属性压缩技术的接口。
AbstractDocument.BranchElement - Class in javax.swing.text
实现一个包含其他元素的复合元素。
AbstractDocument.Content - Interface in javax.swing.text
用于描述可编辑的字符内容序列的界面。
AbstractDocument.DefaultDocumentEvent - Class in javax.swing.text
正在修改文档时存储文档更改。
AbstractDocument.ElementEdit - Class in javax.swing.text
可以添加到文档事件中的ElementChange的实现。
AbstractDocument.LeafElement - Class in javax.swing.text
实现直接表示某种内容的元素。
AbstractDoubleSpliterator(long, int) - Constructor for class java.util. Spliterators.AbstractDoubleSpliterator
创建一个报告给定估计大小和特征的分配器。
AbstractElement(Element, AttributeSet) - Constructor for class javax.swing.text. AbstractDocument.AbstractElement
创建一个新的AbstractElement。
AbstractElementVisitor6< R, P> - Class in javax.lang.model.util
程序元素的骨架访问者，默认行为适用于 RELEASE_6源版本。
AbstractElementVisitor6() - Constructor for class javax.lang.model.util. AbstractElementVisitor6
已过时。
第6版已经过时了 更新到访问者较新的版本级别。
AbstractElementVisitor7< R, P> - Class in javax.lang.model.util
程序元素的骨架访问者，默认行为适合于 RELEASE_7源版本。
AbstractElementVisitor7() - Constructor for class javax.lang.model.util. AbstractElementVisitor7
具体子类调用的构造方法。
AbstractElementVisitor8< R, P> - Class in javax.lang.model.util
具有适用于 RELEASE_8源版本的默认行为的程序元素的骨架访问者。
AbstractElementVisitor8() - Constructor for class javax.lang.model.util. AbstractElementVisitor8
具体子类调用的构造方法。
AbstractElementVisitor9< R, P> - Class in javax.lang.model.util
具有适用于 RELEASE_9源版本的默认行为的程序元素的骨架访问者。
AbstractElementVisitor9() - Constructor for class javax.lang.model.util. AbstractElementVisitor9
具体子类调用的构造方法。
AbstractExecutorService - Class in java.util.concurrent
提供ExecutorService执行方法的默认实现。
AbstractExecutorService() - Constructor for class java.util.concurrent. AbstractExecutorService
AbstractFormatter() - Constructor for class javax.swing. JFormattedTextField.AbstractFormatter
AbstractFormatterFactory() - Constructor for class javax.swing. JFormattedTextField.AbstractFormatterFactory
AbstractInterruptibleChannel - Class in java.nio.channels.spi
可中断通道的基本实现类。
AbstractInterruptibleChannel() - Constructor for class java.nio.channels.spi. AbstractInterruptibleChannel
初始化此类的新实例。
AbstractIntSpliterator(long, int) - Constructor for class java.util. Spliterators.AbstractIntSpliterator
创建一个报告给定估计大小和特征的分配器。
AbstractJSObject - Class in jdk.nashorn.api.scripting
这是nashorn ScriptObjectMirror类的基类。
AbstractJSObject() - Constructor for class jdk.nashorn.api.scripting. AbstractJSObject
默认构造函数。
AbstractLayoutCache - Class in javax.swing.tree
警告：此类的序列化对象与将来的Swing版本不兼容。
AbstractLayoutCache() - Constructor for class javax.swing.tree. AbstractLayoutCache
AbstractLayoutCache.NodeDimensions - Class in javax.swing.tree
由 AbstractLayoutCache用于确定特定节点的大小和x起点。
AbstractList< E> - Class in java.util
该类提供了List接口的骨架实现，以最大限度地减少实现由“随机存取”数据存储（如数组）支持的接口所需的工作量。
AbstractList() - Constructor for class java.util. AbstractList
唯一的构造函数。
AbstractListModel< E> - Class in javax.swing
数据模型的抽象定义，为其提供了一个 List的内容。
AbstractListModel() - Constructor for class javax.swing. AbstractListModel
AbstractLongSpliterator(long, int) - Constructor for class java.util. Spliterators.AbstractLongSpliterator
创建一个报告给定估计大小和特征的分配器。
AbstractMap< K, V> - Class in java.util
该类提供了 Map接口的骨架实现，以尽量减少实现此接口所需的工作量。
AbstractMap() - Constructor for class java.util. AbstractMap
唯一的构造函数。
AbstractMap.SimpleEntry< K, V> - Class in java.util
保存密钥和值的条目。
AbstractMap.SimpleImmutableEntry< K, V> - Class in java.util
保持一个不变的钥匙和价值的条目。
AbstractMarshallerImpl - Class in javax.xml.bind.helpers
部分默认 Marshaller实现。
AbstractMarshallerImpl() - Constructor for class javax.xml.bind.helpers. AbstractMarshallerImpl
AbstractMethodError - Error in java.lang
当应用程序尝试调用抽象方法时抛出。
AbstractMethodError() - Constructor for error java.lang. AbstractMethodError
构造一个 AbstractMethodError没有详细消息。
AbstractMethodError(String) - Constructor for error java.lang. AbstractMethodError
构造具有指定详细消息的 AbstractMethodError 。
AbstractMultiResolutionImage - Class in java.awt.image
该类为要实现 MultiResolutionImage接口的类提供了几个 Image方法的默认实现。
AbstractMultiResolutionImage() - Constructor for class java.awt.image. AbstractMultiResolutionImage
AbstractNotificationHandler< T> - Class in com.sun.nio.sctp
消耗通知并继续的骨架处理程序。
AbstractNotificationHandler() - Constructor for class com.sun.nio.sctp. AbstractNotificationHandler
初始化此类的新实例。
AbstractOwnableSynchronizer - Class in java.util.concurrent.locks
可以由线程专有的同步器。
AbstractOwnableSynchronizer() - Constructor for class java.util.concurrent.locks. AbstractOwnableSynchronizer
空构造器供子类使用。
AbstractPreferences - Class in java.util.prefs
这个类提供了一个Preferences类的骨架实现，大大简化了实现它的任务。
AbstractPreferences(AbstractPreferences, String) - Constructor for class java.util.prefs. AbstractPreferences
创建具有指定父项和相对于其父对象的指定名称的首选项节点。
AbstractProcessor - Class in javax.annotation.processing
一个抽象的注释处理器，被设计为大多数具体注解处理器的一个方便的超类。
AbstractProcessor() - Constructor for class javax.annotation.processing. AbstractProcessor
调用子类的构造方法。
AbstractQueue< E> - Class in java.util
这个类提供了一些Queue操作的骨架实现。
AbstractQueue() - Constructor for class java.util. AbstractQueue
子类使用的构造方法。
AbstractQueuedLongSynchronizer - Class in java.util.concurrent.locks
AbstractQueuedSynchronizer的版本，其中同步状态维持为long 。
AbstractQueuedLongSynchronizer() - Constructor for class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
创建一个初始同步状态为零的新的 AbstractQueuedLongSynchronizer实例。
AbstractQueuedLongSynchronizer.ConditionObject - Class in java.util.concurrent.locks
条件实施AbstractQueuedLongSynchronizer作为Lock实施的基础。
AbstractQueuedSynchronizer - Class in java.util.concurrent.locks
提供一个框架，用于实现依赖先进先出（FIFO）等待队列的阻塞锁和相关同步器（信号量，事件等）。
AbstractQueuedSynchronizer() - Constructor for class java.util.concurrent.locks. AbstractQueuedSynchronizer
创建一个新的 AbstractQueuedSynchronizer实例，初始同步状态为零。
AbstractQueuedSynchronizer.ConditionObject - Class in java.util.concurrent.locks
条件实施AbstractQueuedSynchronizer作为Lock实施的基础。
AbstractRegionPainter - Class in javax.swing.plaf.nimbus
方便的基类，用于定义Painter实例，用于渲染Nimbus中的区域或组件。
AbstractRegionPainter() - Constructor for class javax.swing.plaf.nimbus. AbstractRegionPainter
创建一个新的AbstractRegionPainter
AbstractRegionPainter.PaintContext - Class in javax.swing.plaf.nimbus
一个类封装状态在绘画时有用。
AbstractRegionPainter.PaintContext.CacheMode - Enum in javax.swing.plaf.nimbus
缓存模式。
AbstractRelinkableCallSite - Class in jdk.dynalink.support
基本实现RelinkableCallSite作为MutableCallSite 。
AbstractRelinkableCallSite(CallSiteDescriptor) - Constructor for class jdk.dynalink.support. AbstractRelinkableCallSite
创建一个新的抽象可重新链接的呼叫站点。
AbstractResourceBundleProvider - Class in java.util.spi
AbstractResourceBundleProvider是一个抽象类，为ResourceBundleProvider的提供程序实现类提供基本支持。
AbstractResourceBundleProvider() - Constructor for class java.util.spi. AbstractResourceBundleProvider
构造一个具有“java.properties”格式的 AbstractResourceBundleProvider 。
AbstractResourceBundleProvider(String...) - Constructor for class java.util.spi. AbstractResourceBundleProvider
构造一个 AbstractResourceBundleProvider与指定的 formats 。
AbstractScriptEngine - Class in javax.script
为 eval方法的几个变体提供标准实现。
AbstractScriptEngine() - Constructor for class javax.script. AbstractScriptEngine
使用 SimpleScriptContext作为其默认的 ScriptContext创建一个新的AbstractScriptEngine实例。
AbstractScriptEngine(Bindings) - Constructor for class javax.script. AbstractScriptEngine
使用指定的一个新的实例 Bindings为 ENGINE_SCOPE Bindings在保护 context领域。
AbstractSelectableChannel - Class in java.nio.channels.spi
可选通道的基本实现类。
AbstractSelectableChannel(SelectorProvider) - Constructor for class java.nio.channels.spi. AbstractSelectableChannel
初始化此类的新实例。
AbstractSelectionKey - Class in java.nio.channels.spi
选择键的基本实现类。
AbstractSelectionKey() - Constructor for class java.nio.channels.spi. AbstractSelectionKey
初始化此类的新实例。
AbstractSelector - Class in java.nio.channels.spi
选择器的基本实现类。
AbstractSelector(SelectorProvider) - Constructor for class java.nio.channels.spi. AbstractSelector
初始化此类的新实例。
AbstractSequentialList< E> - Class in java.util
该类提供了 List接口的骨架实现，以最小化实现由“顺序访问”数据存储（如链表）支持的此接口所需的工作量。
AbstractSequentialList() - Constructor for class java.util. AbstractSequentialList
唯一的构造函数。
AbstractSet< E> - Class in java.util
此类提供了 Set接口的骨架实现，以尽量减少实现此接口所需的工作量。
AbstractSet() - Constructor for class java.util. AbstractSet
唯一的构造函数。
AbstractSpinnerModel - Class in javax.swing
此类提供了SpinnerModel接口的ChangeListener部分，该接口应适用于大多数具体的SpinnerModel实现。
AbstractSpinnerModel() - Constructor for class javax.swing. AbstractSpinnerModel
AbstractSpliterator(long, int) - Constructor for class java.util. Spliterators.AbstractSpliterator
创建一个报告给定估计大小和附加特征的分配器。
AbstractTableModel - Class in javax.swing.table
这个抽象类为 TableModel界面中的大多数方法提供了默认实现。
AbstractTableModel() - Constructor for class javax.swing.table. AbstractTableModel
AbstractTypeVisitor6< R, P> - Class in javax.lang.model.util
具有适用于 RELEASE_6源版本的默认行为类型的骨骼访问者。
AbstractTypeVisitor6() - Constructor for class javax.lang.model.util. AbstractTypeVisitor6
已过时。
第6版已经过时了 更新到访问者较新的版本级别。
AbstractTypeVisitor7< R, P> - Class in javax.lang.model.util
类型的骨骼访问者，具有适合 RELEASE_7源版本的默认行为。
AbstractTypeVisitor7() - Constructor for class javax.lang.model.util. AbstractTypeVisitor7
具体子类调用的构造方法。
AbstractTypeVisitor8< R, P> - Class in javax.lang.model.util
具有默认行为类型的骨骼访问者适用于 RELEASE_8源版本。
AbstractTypeVisitor8() - Constructor for class javax.lang.model.util. AbstractTypeVisitor8
具体子类调用的构造方法。
AbstractTypeVisitor9< R, P> - Class in javax.lang.model.util
具有适用于 RELEASE_9源版本的默认行为类型的骨骼访问者。
AbstractTypeVisitor9() - Constructor for class javax.lang.model.util. AbstractTypeVisitor9
具体子类调用的构造方法。
AbstractUndoableEdit - Class in javax.swing.undo
UndoableEdit的抽象实现，实现对该接口中所有布尔方法的简单响应。
AbstractUndoableEdit() - Constructor for class javax.swing.undo. AbstractUndoableEdit
创建一个 AbstractUndoableEdit ，默认为 hasBeenDone和 alive至 true 。
AbstractUnmarshallerImpl - Class in javax.xml.bind.helpers
部分默认 Unmarshaller实现。
AbstractUnmarshallerImpl() - Constructor for class javax.xml.bind.helpers. AbstractUnmarshallerImpl
AbstractView - Interface in org.w3c.dom.views
所有视图都将源自的基本界面。
AbstractWriter - Class in javax.swing.text
AbstractWriter是一个抽象类，它实际上完成了包含属性的元素树的写入工作。
AbstractWriter(Writer, Document) - Constructor for class javax.swing.text. AbstractWriter
创建一个新的AbstractWriter。
AbstractWriter(Writer, Document, int, int) - Constructor for class javax.swing.text. AbstractWriter
创建一个新的AbstractWriter。
AbstractWriter(Writer, Element) - Constructor for class javax.swing.text. AbstractWriter
创建一个新的AbstractWriter。
AbstractWriter(Writer, Element, int, int) - Constructor for class javax.swing.text. AbstractWriter
创建一个新的AbstractWriter。
accelerationPriority - Variable in class java.awt. Image
优先加速此图像。
ACCELERATOR - javafx.scene. AccessibleAttribute
返回节点的加速器。
ACCELERATOR_KEY - Static variable in interface javax.swing. Action
用于存储 KeyStroke的密钥用作操作的加速器。
acceleratorDelimiter - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
加速器分隔符字符串，如 '+'在 'Ctrl+C' 。
acceleratorFont - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
加速器字体。
acceleratorForeground - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
加速器前景的颜色。
acceleratorProperty() - Method in class javafx.scene.control. MenuItem
加速器属性使得能够在一个击键中访问关联的动作。
acceleratorSelectionForeground - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
加速器选择的颜色。
accept() - Method in class com.sun.nio.sctp. SctpServerChannel
在此频道的套接字上接受关联。
accept() - Method in class java.net. ServerSocket
侦听要连接到此套接字并接受它。
accept() - Method in class java.nio.channels. AsynchronousServerSocketChannel
接受连接。
accept() - Method in class java.nio.channels. ServerSocketChannel
接受与此频道套接字的连接。
accept(double) - Method in class java.util. DoubleSummaryStatistics
在摘要信息中记录另一个值。
accept(double) - Method in interface java.util.function. DoubleConsumer
对给定的参数执行此操作。
accept(double) - Method in interface java.util.stream. DoubleStream.Builder
向要构建的流添加元素。
accept(int) - Method in interface java.util.function. IntConsumer
对给定的参数执行此操作。
accept(int) - Method in class java.util. IntSummaryStatistics
在摘要信息中记录一个新值
accept(int) - Method in class java.util. LongSummaryStatistics
记录新的 int值的摘要信息。
accept(int) - Method in interface java.util.stream. IntStream.Builder
向要构建的流添加元素。
accept(long) - Method in interface java.util.function. LongConsumer
对给定的参数执行此操作。
accept(long) - Method in class java.util. LongSummaryStatistics
记录一个新的 long值的摘要信息。
accept(long) - Method in interface java.util.stream. LongStream.Builder
向要构建的流添加元素。
accept(A, CompletionHandler<AsynchronousSocketChannel, ? super A>) - Method in class java.nio.channels. AsynchronousServerSocketChannel
接受连接。
accept(TransportService.ListenKey, long, long) - Method in class com.sun.jdi.connect.spi. TransportService
接受来自目标虚拟机的连接。
accept(DocTreeVisitor<R, D>, D) - Method in interface com.sun.source.doctree. DocTree
用于实现访问者模式的接受方法。
accept(TreeVisitor<R, D>, D) - Method in interface com.sun.source.tree. 树
用于实现访问者模式的接受方法。
accept(Component) - Method in class java.awt. ContainerOrderFocusTraversalPolicy
确定组件是否是新焦点所有者的可接受选择。
accept(Component) - Method in class java.awt. DefaultFocusTraversalPolicy
确定组件是否是新焦点所有者的可接受选择。
accept(Component) - Method in class javax.swing. LayoutFocusTraversalPolicy
确定指定的 Component是否是新的焦点所有者的可接受的选择。
accept(Component) - Method in class javax.swing. SortingFocusTraversalPolicy
确定组件是否是新焦点所有者的可接受选择。
accept(File) - Method in interface java.io. FileFilter
测试指定的抽象路径名是否应包含在路径名列表中。
accept(File) - Method in class javax.swing.filechooser. FileFilter
该过滤器是否接受给定的文件。
accept(File) - Method in class javax.swing.filechooser. FileNameExtensionFilter
测试指定的文件，如果文件被接受则返回true，否则返回false。
accept(File) - Method in class javax.swing. JFileChooser
如果文件应该显示，则返回true。
accept(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.AcceptAllFileFilter
返回true。
accept(File, String) - Method in interface java.io. FilenameFilter
测试指定文件是否应包含在文件列表中。
accept(Object) - Method in interface javax.swing. Action
确定是否应该使用指定的发件人对象执行操作。
accept(SocketImpl) - Method in class java.net. SocketImpl
接受连接。
accept(Map<String, ? extends Connector.Argument>) - Method in interface com.sun.jdi.connect. ListeningConnector
等待目标VM附加到此连接器。
accept(AnnotationValueVisitor<R, P>, P) - Method in interface javax.lang.model.element. AnnotationValue
将访问者应用于此值。
accept(ElementVisitor<R, P>, P) - Method in interface javax.lang.model.element. Element
将访问者应用于此元素。
accept(ModuleElement.DirectiveVisitor<R, P>, P) - Method in interface javax.lang.model.element. ModuleElement.Directive
将访问者应用于此指令。
accept(TypeVisitor<R, P>, P) - Method in interface javax.lang.model.type. TypeMirror
将访问者应用于此类型。
accept(XMLEvent) - Method in interface javax.xml.stream. EventFilter
测试此事件是否是此流的一部分。
accept(XMLStreamReader) - Method in interface javax.xml.stream. StreamFilter
测试当前状态是否是此流的一部分。
accept(TreeVisitor<R, D>, D) - Method in interface jdk.nashorn.api.tree. 树
用于实现访问者模式的接受方法。
accept(T) - Method in interface java.nio.file. DirectoryStream.Filter
决定是否接受或过滤给定的目录条目。
accept(T) - Method in interface java.util.function. Consumer
对给定的参数执行此操作。
accept(T) - Method in interface java.util.stream. Stream.Builder
向要构建的流添加元素。
accept(T, double) - Method in interface java.util.function. ObjDoubleConsumer
对给定的参数执行此操作。
accept(T, int) - Method in interface java.util.function. ObjIntConsumer
对给定的参数执行此操作。
accept(T, long) - Method in interface java.util.function. ObjLongConsumer
对给定的参数执行此操作。
accept(T, U) - Method in interface java.util.function. BiConsumer
对给定的参数执行此操作。
ACCEPT - javafx.scene.input. KeyCode
接受或提交功能键的常数。
ACCEPT_ALL - Static variable in interface java.net. CookiePolicy
一个预定义的政策接受所有的cookies。
ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
标识是否使用AcceptAllFileFilter。
ACCEPT_NONE - Static variable in interface java.net. CookiePolicy
一个预先定义的政策，不接受Cookie。
ACCEPT_ONLY - Static variable in interface org.ietf.jgss. GSSCredential
凭证使用标志，要求仅可用于上下文接受。
ACCEPT_ORIGINAL_SERVER - Static variable in interface java.net. CookiePolicy
一个预先定义的政策，只接受来自原始服务器的Cookie。
AcceptAllFileFilter() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.AcceptAllFileFilter
构造一个 AcceptAllFileFilter 。
acceptChanges() - Method in interface javax.sql.rowset. CachedRowSet
传播行更新，插入和删除对此 CachedRowSet对象所做的更改对底层数据源。
acceptChanges(Connection) - Method in interface javax.sql.rowset. CachedRowSet
将所有行更新，插入和删除备份此更改数据源 CachedRowSet使用指定的对象 Connection对象建立到数据源的连接。
acceptDrag(int) - Method in class java.awt.dnd. DropTargetContext
接受拖动。
acceptDrag(int) - Method in class java.awt.dnd. DropTargetDragEvent
接受拖动
acceptDrop(int) - Method in class java.awt.dnd. DropTargetContext
称为使用指定的操作可以接受下降。
acceptDrop(int) - Method in class java.awt.dnd. DropTargetDropEvent
使用指定的操作接受下拉。
acceptEither(CompletionStage<? extends T>, Consumer<? super T>) - Method in class java.util.concurrent. CompletableFuture
acceptEither(CompletionStage<? extends T>, Consumer<? super T>) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>) - Method in class java.util.concurrent. CompletableFuture
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>, Executor) - Method in class java.util.concurrent. CompletableFuture
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>, Executor) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
ACCEPTING_JOBS - Static variable in class javax.print.attribute.standard. PrinterIsAcceptingJobs
打印机正在接收作业。
acceptNode(Node) - Method in interface org.w3c.dom.ls. LSParserFilter
在完成每个节点的解析时，该方法将被解析器调用。
acceptNode(Node) - Method in interface org.w3c.dom.traversal. NodeFilter
在 TreeWalker或 NodeIterator的逻辑视图中测试指定的节点是否可见。
AcceptPendingException - Exception in java.nio.channels
尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
AcceptPendingException() - Constructor for exception java.nio.channels. AcceptPendingException
构造这个类的一个实例。
acceptSecContext(byte[], int, int) - Method in interface org.ietf.jgss. GSSContext
在从对等体接收到令牌时，由上下文接受者调用。
acceptSecContext(InputStream, OutputStream) - Method in interface org.ietf.jgss. GSSContext
由上下文接收方调用，使用流处理来自对等体的令牌。
acceptsURL(String) - Method in interface java.sql. Driver
检索驱动程序是否认为可以打开与给定URL的连接。
acceptTransferModes(TransferMode...) - Method in class javafx.scene.input. DragEvent
接受这个 DragEvent ，选择下拉操作的传输模式。
access - Variable in class org.omg.CORBA. ValueMember
ValueMember对象描述的 value成员的访问类型（公共，私有）。
ACCESS_EXTERNAL_DTD - Static variable in class javax.xml. XMLConstants
属性：accessExternalDTD
ACCESS_EXTERNAL_SCHEMA - Static variable in class javax.xml. XMLConstants
属性：accessExternalSchema
ACCESS_EXTERNAL_STYLESHEET - Static variable in class javax.xml. XMLConstants
属性：accessExternalStylesheet
accessClass(Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
确定是否可以从此 Lookup对象定义的查找上下文中访问类。
AccessControlContext - Class in java.security
AccessControlContext用于根据其封装的上下文来进行系统资源访问决策。
AccessControlContext(AccessControlContext, DomainCombiner) - Constructor for class java.security. AccessControlContext
创建一个新的 AccessControlContext与给定的 AccessControlContext和 DomainCombiner 。
AccessControlContext(ProtectionDomain[]) - Constructor for class java.security. AccessControlContext
使用给定的ProtectionDomains数组创建一个AccessControlContext。
AccessControlException - Exception in java.security
AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
AccessControlException(String) - Constructor for exception java.security. AccessControlException
构造一个具有指定的详细消息的 AccessControlException 。
AccessControlException(String, Permission) - Constructor for exception java.security. AccessControlException
构造一个具有指定的详细消息的 AccessControlException以及引起异常的请求权限。
AccessController - Class in java.security
AccessController类用于访问控制操作和决策。
AccessDeniedException - Exception in java.nio.file
文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。
AccessDeniedException(String) - Constructor for exception java.nio.file. AccessDeniedException
构造这个类的一个实例。
AccessDeniedException(String, String, String) - Constructor for exception java.nio.file. AccessDeniedException
构造这个类的一个实例。
AccessException - Exception in java.rmi
一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
AccessException(String) - Constructor for exception java.rmi. AccessException
构造具有指定详细消息的 AccessException 。
AccessException(String, Exception) - Constructor for exception java.rmi. AccessException
构造具有指定的详细消息和嵌套异常的 AccessException 。
accessibilityActiveProperty() - Static method in class javafx.application. Platform
指示辅助功能是否处于活动状态。
AccessibilityEventMonitor - Class in com.sun.java.accessibility.util
AccessibilityEventMonitor在实现Java虚拟机中的接口 Accessible每个UI对象上实现PropertyChange监听器。
AccessibilityEventMonitor() - Constructor for class com.sun.java.accessibility.util. AccessibilityEventMonitor
AccessibilityListenerList - Class in com.sun.java.accessibility.util
AccessibilityListenerList是Swing EventListerList类的副本。
AccessibilityListenerList() - Constructor for class com.sun.java.accessibility.util. AccessibilityListenerList
AccessibilityProvider - Class in javax.accessibility
用于辅助技术的服务提供商接口（SPI）。
AccessibilityProvider() - Constructor for class javax.accessibility. AccessibilityProvider
初始化新的辅助功能提供程序。
Accessible - Interface in com.sun.jdi
提供有关类型或类型组件的可访问性的信息。
Accessible - Interface in javax.accessibility
接口 Accessible是可访问性包的主要接口。
ACCESSIBLE_ACTION_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于指示受支持的操作集已更改。
ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
用于确定组件的活动后代何时已更改的常数。
ACCESSIBLE_CARET_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于确定 accessibleText插入符号何时发生变化。
ACCESSIBLE_CHILD_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于确定何时 Accessible子组件被添加/从对象中删除。
ACCESSIBLE_COMPONENT_BOUNDS_CHANGED - Static variable in class javax.accessibility. AccessibleContext
PropertyChangeEvent这表明组件边界发生了变化。
ACCESSIBLE_DESCRIPTION_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于确定 AccessibleContext.accessibleDescription属性何时更改。
ACCESSIBLE_HYPERTEXT_OFFSET - Static variable in class javax.accessibility. AccessibleContext
用于指示超文本元素已经接收焦点的常数。
ACCESSIBLE_INVALIDATE_CHILDREN - Static variable in class javax.accessibility. AccessibleContext
PropertyChangeEvent这表明一个组件的孩子，如树或文本发生了重大变化。
ACCESSIBLE_NAME_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于确定 AccessibleContext.accessibleName属性何时发生变化。
ACCESSIBLE_SELECTION_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于确定 accessibleSelection发生变化。
ACCESSIBLE_STATE_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于确定 accessibleStateSet属性何时发生变化。
ACCESSIBLE_TABLE_CAPTION_CHANGED - Static variable in class javax.accessibility. AccessibleContext
常数用于表示表格已更改。
ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED - Static variable in class javax.accessibility. AccessibleContext
常数用于指示列描述已更改。
ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED - Static variable in class javax.accessibility. AccessibleContext
常量用于指示列标题已更改。
ACCESSIBLE_TABLE_MODEL_CHANGED - Static variable in class javax.accessibility. AccessibleContext
用于表示表数据已更改的常数。
ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED - Static variable in class javax.accessibility. AccessibleContext
常数用于指示行描述已更改。
ACCESSIBLE_TABLE_ROW_HEADER_CHANGED - Static variable in class javax.accessibility. AccessibleContext
用于指示行标题已更改的常量。
ACCESSIBLE_TABLE_SUMMARY_CHANGED - Static variable in class javax.accessibility. AccessibleContext
常数用于表示表格摘要已更改。
ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED - Static variable in class javax.accessibility. AccessibleContext
PropertyChangeEvent ，表示文本属性已更改。
ACCESSIBLE_TEXT_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
PropertyChangeEvent ，表示文字已更改。
ACCESSIBLE_VALUE_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
常数用于确定 accessibleValue属性何时发生变化。
ACCESSIBLE_VISIBLE_DATA_PROPERTY - Static variable in class javax.accessibility. AccessibleContext
用于确定对象的视觉外观何时改变的常数。
AccessibleAbstractButton() - Constructor for class javax.swing. AbstractButton.AccessibleAbstractButton
AccessibleAction - Enum in javafx.scene
该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。
AccessibleAction - Interface in javax.accessibility
任何可以执行一个或多个操作的对象都应该支持 AccessibleAction接口。
AccessibleApplet() - Constructor for class java.applet. Applet.AccessibleApplet
已过时。
AccessibleAttribute - Enum in javafx.scene
该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
AccessibleAttributeSequence - Class in javax.accessibility
该类将共享相同连续属性集的文本的跨度以及该组属性一起收集。
AccessibleAttributeSequence(int, int, AttributeSet) - Constructor for class javax.accessibility. AccessibleAttributeSequence
构造具有给定参数的 AccessibleAttributeSequence 。
AccessibleAWTButton() - Constructor for class java.awt. Button.AccessibleAWTButton
AccessibleAWTCanvas() - Constructor for class java.awt. Canvas.AccessibleAWTCanvas
AccessibleAWTCheckbox() - Constructor for class java.awt. Checkbox.AccessibleAWTCheckbox
构造函数为 AccessibleAWTCheckbox
AccessibleAWTCheckboxMenuItem() - Constructor for class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
AccessibleAWTChoice() - Constructor for class java.awt. Choice.AccessibleAWTChoice
构造函数为 AccessibleAWTChoice
AccessibleAWTComponent() - Constructor for class java.awt. Component.AccessibleAWTComponent
虽然这个类是抽象的，但这应该由所有子类调用。
accessibleAWTComponentHandler - Variable in class java.awt. Component.AccessibleAWTComponent
组件侦听器，用于跟踪show / hide / resize事件并将其转换为PropertyChange事件。
AccessibleAWTComponentHandler() - Constructor for class java.awt. Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
AccessibleAWTContainer() - Constructor for class java.awt. Container.AccessibleAWTContainer
AccessibleAWTDialog() - Constructor for class java.awt. Dialog.AccessibleAWTDialog
accessibleAWTFocusHandler - Variable in class java.awt. Component.AccessibleAWTComponent
监听焦点事件并将其转换为PropertyChange事件的侦听器。
AccessibleAWTFocusHandler() - Constructor for class java.awt. Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
AccessibleAWTFrame() - Constructor for class java.awt. Frame.AccessibleAWTFrame
AccessibleAWTLabel() - Constructor for class java.awt. Label.AccessibleAWTLabel
可访问标签的构造方法。
AccessibleAWTList() - Constructor for class java.awt. List.AccessibleAWTList
构造新的 AccessibleAWTList
AccessibleAWTListChild(List, int) - Constructor for class java.awt. List.AccessibleAWTList.AccessibleAWTListChild
构造新的 AccessibleAWTListChild与给定的父母 List和基于0的父对象的索引。
AccessibleAWTMenu() - Constructor for class java.awt. Menu.AccessibleAWTMenu
AccessibleAWTMenuBar() - Constructor for class java.awt. MenuBar.AccessibleAWTMenuBar
AccessibleAWTMenuComponent() - Constructor for class java.awt. MenuComponent.AccessibleAWTMenuComponent
虽然这个类是抽象的，但这应该被所有子类调用。
AccessibleAWTMenuItem() - Constructor for class java.awt. MenuItem.AccessibleAWTMenuItem
AccessibleAWTPanel() - Constructor for class java.awt. Panel.AccessibleAWTPanel
AccessibleAWTPopupMenu() - Constructor for class java.awt. PopupMenu.AccessibleAWTPopupMenu
AccessibleAWTScrollBar() - Constructor for class java.awt. Scrollbar.AccessibleAWTScrollBar
AccessibleAWTScrollPane() - Constructor for class java.awt. ScrollPane.AccessibleAWTScrollPane
AccessibleAWTTextArea() - Constructor for class java.awt. TextArea.AccessibleAWTTextArea
AccessibleAWTTextComponent() - Constructor for class java.awt. TextComponent.AccessibleAWTTextComponent
构造一个AccessibleAWTTextComponent。
AccessibleAWTTextField() - Constructor for class java.awt. TextField.AccessibleAWTTextField
AccessibleAWTWindow() - Constructor for class java.awt. Window.AccessibleAWTWindow
AccessibleBox() - Constructor for class javax.swing. Box.AccessibleBox
AccessibleBoxFiller() - Constructor for class javax.swing. Box.Filler.AccessibleBoxFiller
AccessibleBundle - Class in javax.accessibility
用于维护强类型枚举的基类。
AccessibleBundle() - Constructor for class javax.accessibility. AccessibleBundle
构造一个 AccessibleBundle 。
AccessibleCellRendererPane() - Constructor for class javax.swing. CellRendererPane.AccessibleCellRendererPane
AccessibleComponent - Interface in javax.accessibility
应该在屏幕上呈现的任何对象支持 AccessibleComponent界面。
accessibleContainerHandler - Variable in class java.awt. Container.AccessibleAWTContainer
当孩子被添加或删除时，处理程序将触发 PropertyChange
AccessibleContainerHandler() - Constructor for class java.awt. Container.AccessibleAWTContainer.AccessibleContainerHandler
AccessibleContainerHandler() - Constructor for class javax.swing. JComponent.AccessibleJComponent.AccessibleContainerHandler
accessibleContext - Variable in class java.awt. Component
AccessibleContext与此 Component相关联。
accessibleContext - Variable in class javax.swing. CellRendererPane
AccessibleContext与此 CellRendererPan相关联
accessibleContext - Variable in class javax.swing. JApplet
已过时。
AccessibleContext与此 JApplet相关联
accessibleContext - Variable in class javax.swing. JColorChooser
可访问的上下文。
accessibleContext - Variable in class javax.swing. JDialog
AccessibleContext与此 JDialog相关联
accessibleContext - Variable in class javax.swing. JFileChooser
AccessibleContext与此 JFileChooser相关联
accessibleContext - Variable in class javax.swing. JFrame
可访问的上下文属性。
accessibleContext - Variable in class javax.swing. JWindow
可访问的上下文属性。
accessibleContext - Variable in class javax.swing. ProgressMonitor
AccessibleContext为 ProgressMonitor
AccessibleContext - Class in javax.accessibility
AccessibleContext表示所有可访问对象返回的最小信息。
AccessibleContext() - Constructor for class javax.accessibility. AccessibleContext
accessibleDescription - Variable in class javax.accessibility. AccessibleContext
包含对象描述的本地化字符串。
AccessibleEditableText - Interface in javax.accessibility
AccessibleEditableText接口应该由显示器上显示可编辑文本信息的所有类实现。
AccessibleExtendedComponent - Interface in javax.accessibility
AccessibleExtendedComponent界面应由屏幕上呈现的任何对象支持。
AccessibleExtendedTable - Interface in javax.accessibility
AccessibleExtendedTable类提供了以二维表格格式显示数据的用户界面组件的扩展信息。
AccessibleExtendedText - Interface in javax.accessibility
该 AccessibleExtendedText接口包含不被提供的其他方法 AccessibleText接口。
accessibleFocusHandler - Variable in class javax.swing. JComponent.AccessibleJComponent
已过时。
AccessibleFocusHandler() - Constructor for class javax.swing. JComponent.AccessibleJComponent.AccessibleFocusHandler
已过时。
accessibleHelpProperty() - Method in class javafx.scene. Node
该 Node的可访问的帮助文本。
AccessibleHyperlink - Class in javax.accessibility
在超文本文件中封装链接或一组链接（例如客户端图像映射）
AccessibleHyperlink() - Constructor for class javax.accessibility. AccessibleHyperlink
AccessibleHypertext - Interface in javax.accessibility
AccessibleHypertext类是在显示器上显示超文本信息的所有类的基类。
AccessibleIcon - Interface in javax.accessibility
任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon界面。
AccessibleImageIcon() - Constructor for class javax.swing. ImageIcon.AccessibleImageIcon
AccessibleJApplet() - Constructor for class javax.swing. JApplet.AccessibleJApplet
已过时。
AccessibleJButton() - Constructor for class javax.swing. JButton.AccessibleJButton
AccessibleJCheckBox() - Constructor for class javax.swing. JCheckBox.AccessibleJCheckBox
AccessibleJCheckBoxMenuItem() - Constructor for class javax.swing. JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
AccessibleJColorChooser() - Constructor for class javax.swing. JColorChooser.AccessibleJColorChooser
AccessibleJComboBox() - Constructor for class javax.swing. JComboBox.AccessibleJComboBox
返回AccessibleJComboBox实例
AccessibleJComponent() - Constructor for class javax.swing. JComponent.AccessibleJComponent
虽然这个类是抽象的，但这应该由所有子类调用。
AccessibleJDesktopIcon() - Constructor for class javax.swing. JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
AccessibleJDesktopPane() - Constructor for class javax.swing. JDesktopPane.AccessibleJDesktopPane
AccessibleJDialog() - Constructor for class javax.swing. JDialog.AccessibleJDialog
AccessibleJEditorPane() - Constructor for class javax.swing. JEditorPane.AccessibleJEditorPane
AccessibleJEditorPaneHTML() - Constructor for class javax.swing. JEditorPane.AccessibleJEditorPaneHTML
构造一个 AccessibleJEditorPaneHTML 。
AccessibleJFileChooser() - Constructor for class javax.swing. JFileChooser.AccessibleJFileChooser
AccessibleJFrame() - Constructor for class javax.swing. JFrame.AccessibleJFrame
AccessibleJInternalFrame() - Constructor for class javax.swing. JInternalFrame.AccessibleJInternalFrame
AccessibleJLabel() - Constructor for class javax.swing. JLabel.AccessibleJLabel
AccessibleJLayeredPane() - Constructor for class javax.swing. JLayeredPane.AccessibleJLayeredPane
AccessibleJList() - Constructor for class javax.swing. JList.AccessibleJList
构造一个 AccessibleJList 。
AccessibleJListChild(JList<E>, int) - Constructor for class javax.swing. JList.AccessibleJList.AccessibleJListChild
构造一个 AccessibleJListChild 。
AccessibleJMenu() - Constructor for class javax.swing. JMenu.AccessibleJMenu
AccessibleJMenuBar() - Constructor for class javax.swing. JMenuBar.AccessibleJMenuBar
AccessibleJOptionPane() - Constructor for class javax.swing. JOptionPane.AccessibleJOptionPane
AccessibleJPanel() - Constructor for class javax.swing. JPanel.AccessibleJPanel
AccessibleJPasswordField() - Constructor for class javax.swing. JPasswordField.AccessibleJPasswordField
AccessibleJPopupMenu() - Constructor for class javax.swing. JPopupMenu.AccessibleJPopupMenu
AccessibleJPopupMenu构造函数
AccessibleJProgressBar() - Constructor for class javax.swing. JProgressBar.AccessibleJProgressBar
AccessibleJRadioButton() - Constructor for class javax.swing. JRadioButton.AccessibleJRadioButton
AccessibleJRadioButtonMenuItem() - Constructor for class javax.swing. JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
AccessibleJRootPane() - Constructor for class javax.swing. JRootPane.AccessibleJRootPane
AccessibleJScrollBar() - Constructor for class javax.swing. JScrollBar.AccessibleJScrollBar
AccessibleJScrollPane() - Constructor for class javax.swing. JScrollPane.AccessibleJScrollPane
AccessibleJScrollPane构造函数
AccessibleJSeparator() - Constructor for class javax.swing. JSeparator.AccessibleJSeparator
AccessibleJSlider() - Constructor for class javax.swing. JSlider.AccessibleJSlider
AccessibleJSpinner() - Constructor for class javax.swing. JSpinner.AccessibleJSpinner
AccessibleJSpinner构造函数
AccessibleJSplitPane() - Constructor for class javax.swing. JSplitPane.AccessibleJSplitPane
AccessibleJTabbedPane() - Constructor for class javax.swing. JTabbedPane.AccessibleJTabbedPane
构建一个AccessibleJTabbedPane
AccessibleJTable() - Constructor for class javax.swing. JTable.AccessibleJTable
AccessibleJTable构造函数
AccessibleJTableCell(JTable, int, int, int) - Constructor for class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell
构造一个 AccessibleJTableHeaderEntry 。
AccessibleJTableHeader() - Constructor for class javax.swing.table. JTableHeader.AccessibleJTableHeader
AccessibleJTableHeaderEntry(int, JTableHeader, JTable) - Constructor for class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
X-4545454545 X-454545 X-454545 X-454545 X-4545 X-
AccessibleJTableModelChange(int, int, int, int, int) - Constructor for class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange
构造一个 AccessibleJTableModelChange 。
AccessibleJTextArea() - Constructor for class javax.swing. JTextArea.AccessibleJTextArea
AccessibleJTextComponent() - Constructor for class javax.swing.text. JTextComponent.AccessibleJTextComponent
构造AccessibleJTextComponent。
AccessibleJTextField() - Constructor for class javax.swing. JTextField.AccessibleJTextField
AccessibleJToggleButton() - Constructor for class javax.swing. JToggleButton.AccessibleJToggleButton
构造 AccessibleJToggleButton
AccessibleJToolBar() - Constructor for class javax.swing. JToolBar.AccessibleJToolBar
AccessibleJToolTip() - Constructor for class javax.swing. JToolTip.AccessibleJToolTip
AccessibleJTree() - Constructor for class javax.swing. JTree.AccessibleJTree
构造 AccessibleJTree
AccessibleJTreeNode(JTree, TreePath, Accessible) - Constructor for class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
构造一个AccessibleJTreeNode
AccessibleJViewport() - Constructor for class javax.swing. JViewport.AccessibleJViewport
AccessibleJWindow() - Constructor for class javax.swing. JWindow.AccessibleJWindow
AccessibleKeyBinding - Interface in javax.accessibility
任何具有键盘绑定（如键盘助记符和/或键盘快捷键）的对象都可以支持 AccessibleKeyBinding界面，可用于选择对象。
accessibleName - Variable in class javax.accessibility. AccessibleContext
包含对象名称的本地化字符串。
AccessibleObject - Class in java.lang.reflect
所述 AccessibleObject类是基础类 Field ， 方法 ，和 Constructor对象（被称为 反射的对象 ）。
AccessibleObject() - Constructor for class java.lang.reflect. AccessibleObject
构造函数：仅由Java虚拟机使用。
accessibleParent - Variable in class javax.accessibility. AccessibleContext
该对象的可访问父级。
AccessibleProgressMonitor() - Constructor for class javax.swing. ProgressMonitor.AccessibleProgressMonitor
AccessibleProgressMonitor构造函数
AccessibleRelation - Class in javax.accessibility
类 AccessibleRelation描述了实现 AccessibleRelation的对象与一个或多个其他对象之间的关系。
AccessibleRelation(String) - Constructor for class javax.accessibility. AccessibleRelation
使用给定的区域设置独立键创建一个新的 AccessibleRelation 。
AccessibleRelation(String, Object) - Constructor for class javax.accessibility. AccessibleRelation
使用给定的区域设置独立键创建一个新的 AccessibleRelation 。
AccessibleRelation(String, Object[]) - Constructor for class javax.accessibility. AccessibleRelation
使用给定的区域设置独立键创建一个新的 AccessibleRelation 。
AccessibleRelationSet - Class in javax.accessibility
AccessibleRelationSet类确定组件的关系集。
AccessibleRelationSet() - Constructor for class javax.accessibility. AccessibleRelationSet
创建一个新的空关系集。
AccessibleRelationSet(AccessibleRelation[]) - Constructor for class javax.accessibility. AccessibleRelationSet
与传递的关系数组中包含的初始关系创建一个新的关系。
AccessibleResourceBundle - Class in javax.accessibility
已过时。
从Java平台1.3版开始，此类已被弃用
AccessibleResourceBundle() - Constructor for class javax.accessibility. AccessibleResourceBundle
已过时。
AccessibleRole - Class in javax.accessibility
AccessibleRole类确定组件的作用。
AccessibleRole - Enum in javafx.scene
这个枚举描述了一个Node的可访问角色。
AccessibleRole(String) - Constructor for class javax.accessibility. AccessibleRole
使用给定的区域设置独立键创建一个新的 AccessibleRole 。
accessibleRoleDescriptionProperty() - Method in class javafx.scene. Node
这个角色描述这个 Node 。
accessibleRoleProperty() - Method in class javafx.scene. Node
这个 Node的可访问角色。
AccessibleSelection - Interface in javax.accessibility
这个 AccessibleSelection接口提供了辅助技术的标准机制，以确定当前所选择的孩子是什么，以及修改选择集。
AccessibleState - Class in javax.accessibility
AccessibleState类描述了组件的特定状态。
AccessibleState(String) - Constructor for class javax.accessibility. AccessibleState
使用给定的区域设置独立键创建一个新的 AccessibleState 。
AccessibleStateSet - Class in javax.accessibility
AccessibleStateSet类确定组件的状态集。
AccessibleStateSet() - Constructor for class javax.accessibility. AccessibleStateSet
创建一个新的空状态集。
AccessibleStateSet(AccessibleState[]) - Constructor for class javax.accessibility. AccessibleStateSet
创建一个新状态，其中包含在状态数组中的初始状态集合。
AccessibleStreamable - Interface in javax.accessibility
AccessibleStreamable接口应由任何组件的 AccessibleContext实现，该组件在显示屏幕上呈现组件后面的原始流。
AccessibleTable - Interface in javax.accessibility
AccessibleTable类描述了以二维表格形式显示数据的用户界面组件。
AccessibleTableModelChange - Interface in javax.accessibility
AccessibleTableModelChange接口描述了对表模型的更改。
AccessibleText - Interface in javax.accessibility
AccessibleText界面应由所有显示文本信息的类实现。
accessibleTextProperty() - Method in class javafx.scene. Node
这个 Node的可访问文本。
AccessibleTextSequence - Class in javax.accessibility
这个类收集了文本跨度的关键细节。
AccessibleTextSequence(int, int, String) - Constructor for class javax.accessibility. AccessibleTextSequence
构造具有给定参数的 AccessibleTextSequence 。
AccessibleValue - Interface in javax.accessibility
任何支持数值的对象都支持 AccessibleValue界面（例如滚动条）。
AccessMode - Enum in java.nio.file
定义用于测试文件可访问性的访问模式。
accessModeType(VarHandle.AccessMode) - Method in class java.lang.invoke. VarHandle
获取此VarHandle和给定访问模式的访问模式类型。
ACCESSORY_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
说使用不同的附件组件（例如，预览文件）。
AccessWatchpointEvent - Interface in com.sun.jdi.event
通知目标VM中的现场访问。
AccessWatchpointRequest - Interface in com.sun.jdi.request
在目标虚拟机中访问字段的内容时请求通知。
accessWatchpointRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的访问观察点请求的不可修改的列表。
Accordion - Class in javafx.scene.control
手风琴是一组TitlePanes 。
Accordion() - Constructor for class javafx.scene.control. Accordion
创建一个没有TitledPanes的新手风琴。
Accordion(TitledPane...) - Constructor for class javafx.scene.control. Accordion
创建一个新的手风琴与给定的TitledPanes在其中显示。
AccordionSkin - Class in javafx.scene.control.skin
默认皮肤实现为Accordion控件。
AccordionSkin(Accordion) - Constructor for class javafx.scene.control.skin. AccordionSkin
创建一个新的AccordionSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
AccountException - Exception in javax.security.auth.login
通用帐户异常。
AccountException() - Constructor for exception javax.security.auth.login. AccountException
构造一个没有详细消息的AccountException。
AccountException(String) - Constructor for exception javax.security.auth.login. AccountException
构造具有指定详细消息的AccountException。
AccountExpiredException - Exception in javax.security.auth.login
表示用户帐户已过期。
AccountExpiredException() - Constructor for exception javax.security.auth.login. AccountExpiredException
构造一个没有详细消息的AccountExpiredException。
AccountExpiredException(String) - Constructor for exception javax.security.auth.login. AccountExpiredException
构造具有指定详细消息的AccountExpiredException。
AccountLockedException - Exception in javax.security.auth.login
指示帐户被锁定。
AccountLockedException() - Constructor for exception javax.security.auth.login. AccountLockedException
构造一个没有详细消息的AccountLockedException。
AccountLockedException(String) - Constructor for exception javax.security.auth.login. AccountLockedException
构造具有指定详细消息的AccountLockedException。
AccountNotFoundException - Exception in javax.security.auth.login
表示找不到帐户。
AccountNotFoundException() - Constructor for exception javax.security.auth.login. AccountNotFoundException
构造一个没有详细消息的AccountNotFoundException。
AccountNotFoundException(String) - Constructor for exception javax.security.auth.login. AccountNotFoundException
构造具有指定详细消息的AccountNotFoundException。
accumulate(double) - Method in class java.util.concurrent.atomic. DoubleAccumulator
具有给定值的更新。
accumulate(long) - Method in class java.util.concurrent.atomic. LongAccumulator
具有给定值的更新。
accumulateAndGet(int, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
将索引号为 i的元素原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定函数应用于当前值和给定值，返回更新后的值。
accumulateAndGet(int, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongArray
原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回更新后的值。
accumulateAndGet(int, E, BinaryOperator<E>) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回更新后的值。
accumulateAndGet(int, IntBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicInteger
将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效应），返回更新后的值。
accumulateAndGet(long, LongBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicLong
将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回更新后的值。
accumulateAndGet(T, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
accumulateAndGet(T, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater
原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
accumulateAndGet(T, V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater
原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回更新后的值。
accumulateAndGet(V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReference
将当前值与给定函数应用于当前值和给定值的原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回更新的值。
accumulator() - Method in interface java.util.stream. Collector
将值折叠成可变结果容器的函数。
Acl - Interface in java.security.acl
已过时。
1.2包以后，这个包已经被java.security.Policy和相关类替代了。
AclEntry - Class in java.nio.file.attribute
访问控制列表（ACL）中的条目。
AclEntry - Interface in java.security.acl
已过时。
自1.2版起，该软件包已被java.security.Policy及相关课程所取代。
AclEntry.Builder - Class in java.nio.file.attribute
一个AclEntry个对象的构建器。
AclEntryFlag - Enum in java.nio.file.attribute
定义ACL entry的标志组件使用的标志。
AclEntryPermission - Enum in java.nio.file.attribute
定义与ACL entry的权限组件一起使用的权限。
AclEntryType - Enum in java.nio.file.attribute
访问控制条目类型的类型安全枚举。
AclFileAttributeView - Interface in java.nio.file.attribute
支持读取或更新文件的访问控制列表（ACL）或文件所有者属性的文件属性视图。
AclNotFoundException - Exception in java.security.acl
已过时。
1.2包以后，这个包已经被java.security.Policy和相关类替代了。
AclNotFoundException() - Constructor for exception java.security.acl. AclNotFoundException
已过时。
构造一个AclNotFoundException。
acos(double) - Static method in class java.lang. Math
返回值的反余弦值; 返回的角度在0.0到pi的范围内。
acos(double) - Static method in class java.lang. StrictMath
返回值的反余弦值; 返回的角度在0.0到pi的范围内。
acquire() - Method in class java.util.concurrent. Semaphore
从此信号量获取许可证，阻止直到可用，否则线程为 interrupted 。
acquire(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
以独占模式获取，忽略中断。
acquire(int) - Method in class java.util.concurrent. Semaphore
从该信号量获取给定数量的许可证，阻止直到所有可用，或线程为 interrupted 。
acquire(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
以独占模式获取，忽略中断。
acquiredBy() - Method in class java.nio.channels. FileLock
返回获取此锁的文件的通道。
acquireFence() - Static method in class java.lang.invoke. VarHandle
确保栅栏之前的载荷在栅栏后不会被装载和存储重新排序。
acquireInterruptibly(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
以独占方式获得，如果中断，中止。
acquireInterruptibly(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
以独占方式获得，如果中断，中止。
acquireShared(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
以共享模式获取，忽略中断。
acquireShared(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
以共享模式获取，忽略中断。
acquireSharedInterruptibly(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
以共享方式获取，如果中断，中止。
acquireSharedInterruptibly(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
以共享方式获取，如果中断，中止。
acquireUninterruptibly() - Method in class java.util.concurrent. Semaphore
从这个信号灯获取许可证，阻止一个可用的。
acquireUninterruptibly(int) - Method in class java.util.concurrent. Semaphore
从该信号量获取给定数量的许可证，阻止直到所有可用。
action(Event, Object) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，应该在组件上注册此组件作为ActionListener，该组件将触发动作事件。
Action - Interface in javax.swing
所述 Action接口提供了一个有用的扩展到 ActionListener在箱子接口，其中相同的功能可以由若干控件访问。
Action - Annotation Type in javax.xml.ws
所述 Action注释允许一个WS寻址的显式关联 Action与消息寻址属性 input ， output和 fault映射WSDL操作的消息。
ACTION - Static variable in class com.sun.java.accessibility.util. EventID
映射到AWT Action支持（即ActionListener和ActionEvent）
ACTION - Static variable in class javafx.event. ActionEvent
ActionEvent唯一有效的EventType。
ACTION - Static variable in class javax.management. MBeanOperationInfo
表示操作是类似的：它具有效果，但不返回MBean中的任何信息。
ACTION - Static variable in class javax.swing.text.html. HTML.Attribute
属性“动作”
ACTION_APPEND_AS_CHILDREN - Static variable in interface org.w3c.dom.ls. LSParser
将解析操作的结果附加到上下文节点的子节点。
ACTION_COMMAND_KEY - Static variable in interface javax.swing. Action
用于确定该命令的键 String为 ActionEvent将当被创建 Action将被通知作为驻留在的结果 Keymap与相关联 JComponent 。
ACTION_COPY - Static variable in class java.awt.dnd. DnDConstants
代表“复制”动作的 int 。
ACTION_COPY_OR_MOVE - Static variable in class java.awt.dnd. DnDConstants
代表“复制”或“移动”动作的 int 。
ACTION_EVENT - Static variable in class java.awt. Event
已过时。
此事件表示用户希望发生某些操作。
ACTION_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择动作事件的事件掩码。
ACTION_FIRST - Static variable in class java.awt.event. ActionEvent
用于动作事件的ids范围中的第一个数字。
ACTION_INFO - Static variable in class javax.management. MBeanOperationInfo
表示操作既是类似读写的，也有类似的操作：它具有效果，并且还从MBean返回信息。
ACTION_INSERT_AFTER - Static variable in interface org.w3c.dom.ls. LSParser
将解析操作的结果作为上下文节点的紧跟同步插入。
ACTION_INSERT_BEFORE - Static variable in interface org.w3c.dom.ls. LSParser
将解析操作的结果作为前一个上下文节点的同级插入。
ACTION_LAST - Static variable in class java.awt.event. ActionEvent
用于操作事件的ID的范围中的最后一个数字。
ACTION_LINK - Static variable in class java.awt.dnd. DnDConstants
代表“链接”动作的 int 。
ACTION_MOVE - Static variable in class java.awt.dnd. DnDConstants
一个 int代表一个“移动”动作。
ACTION_NONE - Static variable in class java.awt.dnd. DnDConstants
一个 int表示没有动作。
ACTION_PERFORMED - Static variable in class java.awt.event. ActionEvent
此事件ID表示发生了有意义的操作。
ACTION_REFERENCE - Static variable in class java.awt.dnd. DnDConstants
一个 int代表“参考”动作（ACTION_LINK的同义词）。
ACTION_REPLACE - Static variable in interface org.w3c.dom.ls. LSParser
用解析操作的结果替换上下文节点。
ACTION_REPLACE_CHILDREN - Static variable in interface org.w3c.dom.ls. LSParser
用解析操作的结果替换上下文节点的所有子节点。
actionCommand - Variable in class javax.swing. DefaultButtonModel
按钮触发的动作命令字符串。
actionCommand - Variable in class javax.swing. JComboBox
此保护字段是实现特定的。
ActionEvent - Class in java.awt.event
指示组件定义的动作发生的语义事件。
ActionEvent - Class in javafx.event
一个Event代表某种类型的动作。
ActionEvent() - Constructor for class javafx.event. ActionEvent
创建一个新的 ActionEvent ，事件类型为 ACTION 。
ActionEvent(Object, int, String) - Constructor for class java.awt.event. ActionEvent
构造一个 ActionEvent对象。
ActionEvent(Object, int, String, int) - Constructor for class java.awt.event. ActionEvent
使用修饰键构造一个 ActionEvent对象。
ActionEvent(Object, int, String, long, int) - Constructor for class java.awt.event. ActionEvent
使用指定的修饰符键和时间戳构造一个 ActionEvent对象。
ActionEvent(Object, EventTarget) - Constructor for class javafx.event. ActionEvent
构造一个新的 ActionEvent与指定的事件源和目标。
actionListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor
不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。
actionListener - Variable in class javax.swing. AbstractButton
按钮型号 ActionListener 。
ActionListener - Interface in java.awt.event
用于接收动作事件的侦听器界面。
ActionMap - Class in javax.swing
ActionMap提供从 Object s（称为 密钥或 Action名称 ）到 Action 。
ActionMap() - Constructor for class javax.swing. ActionMap
创建一个 ActionMap ，没有父级和没有映射。
ActionMapUIResource - Class in javax.swing.plaf
实现UIResource的javax.swing.ActionMap的子类。
ActionMapUIResource() - Constructor for class javax.swing.plaf. ActionMapUIResource
构造一个 ActionMapUIResource 。
actionName - Variable in class javax.swing.text. JTextComponent.KeyBinding
键的动作名称。
actionPerformed(ActionEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的actionPerformed方法来处理actionPerformed事件。
actionPerformed(ActionEvent) - Method in class java.awt.dnd. DropTarget.DropTargetAutoScroller
导致自动滚屏发生
actionPerformed(ActionEvent) - Method in interface java.awt.event. ActionListener
发生动作时调用。
actionPerformed(ActionEvent) - Method in class java.awt. List.AccessibleAWTList
actionPerformed(ActionEvent) - Method in class javax.swing. DefaultCellEditor.EditorDelegate
执行动作时，编辑结束。
actionPerformed(ActionEvent) - Method in class javax.swing. JComboBox
这种方法是公共的，作为实现的副作用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.CloseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.MaximizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.MinimizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.NavigateAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.OpenAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.ApproveSelectionAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.CancelSelectionAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.ChangeToParentDirectoryAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.GoHomeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.NewFolderAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.UpdateAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.CloseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.IconifyAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.MaximizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.MoveAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.RestoreAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.SizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonActionListener
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.ScrollListener
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.ActionScroller
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.ScrollListener
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardDownRightHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardEndHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardHomeHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardResizeToggleHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardUpLeftHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.ComponentHandler
由于计时器而公开。
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeCancelEditingAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeHomeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeIncrementAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreePageAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeToggleAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeTraverseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxAction
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.BeepAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.CopyAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.CutAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.DefaultKeyTypedAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.InsertBreakAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.InsertContentAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.InsertTabAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text. DefaultEditorKit.PasteAction
触发此操作时执行的操作。
actionPerformed(ActionEvent) - Method in class javax.swing.text.html. FormView
负责处理ActionEvent。
actionPerformed(ActionEvent) - Method in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction
将HTML插入到文档中。
actionPerformed(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.AlignmentAction
设置对齐。
actionPerformed(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.BoldAction
切换粗体属性。
actionPerformed(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.FontFamilyAction
设置字体系列。
actionPerformed(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.FontSizeAction
设置字体大小。
actionPerformed(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.ForegroundAction
设置前景色。
actionPerformed(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.ItalicAction
切换斜体属性。
actionPerformed(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.UnderlineAction
切换下划线属性。
actionPerformed(ActionEvent) - Method in class javax.swing. ToolTipManager.insideTimerAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing. ToolTipManager.outsideTimerAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing. ToolTipManager.stillInsideTimerAction
发生动作时调用。
actionPerformed(ActionEvent) - Method in class javax.swing.tree. DefaultTreeCellEditor
在定时器触发时消息传送，这将开始编辑会话。
actionPropertyChanged(Action, String) - Method in class javax.swing. AbstractButton
响应关联操作中的属性更改更新按钮的状态。
actionPropertyChanged(Action, String) - Method in class javax.swing. JComboBox
响应关联操作中的属性更改更新组合框的状态。
actionPropertyChanged(Action, String) - Method in class javax.swing. JMenuItem
响应关联操作中的属性更改更新按钮的状态。
actionPropertyChanged(Action, String) - Method in class javax.swing. JTextField
响应相关操作中的属性更改更新文本框的状态。
ActionScroller(JSlider, int, boolean) - Constructor for class javax.swing.plaf.basic. BasicSliderUI.ActionScroller
构造一个 ActionScroller 。
Activatable - Class in java.rmi.activation
Activatable类为需要持续访问的远程对象提供支持，并且可以由系统激活。
Activatable(String, MarshalledObject<?>, boolean, int) - Constructor for class java.rmi.activation. Activatable
通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并使用指定的端口导出对象。
Activatable(String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.activation. Activatable
通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。
Activatable(ActivationID, int) - Constructor for class java.rmi.activation. Activatable
用于在指定端口上激活/导出对象的构造方法。
Activatable(ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.activation. Activatable
用于在指定端口上激活/导出对象的构造方法。
activate() - Method in interface java.awt.im.spi. InputMethod
激活立即输入处理的输入法。
activate() - Method in class javax.accessibility. AccessibilityProvider
激活此服务提供商提供的支持。
activate() - Method in interface org.omg.PortableServer. POAManagerOperations
此操作将POA管理器的状态更改为活动状态，导致相关联的POA开始处理请求。
activate(boolean) - Method in class java.rmi.activation. ActivationID
激活该ID的对象。
activate(Applet) - Method in interface java.beans. AppletInitializer
已过时。
激活，和/或标记Applet活动。
activate(ActivationID, boolean) - Method in interface java.rmi.activation. Activator
激活与激活标识符相关联的对象， id 。
activate(IIOParam) - Method in interface javax.imageio. IIOParamController
激活控制器。
activate(IIOMetadata) - Method in interface javax.imageio.metadata. IIOMetadataController
激活控制器。
activate_object(Servant) - Method in interface org.omg.PortableServer. POAOperations
此操作生成对象标识，并在活动对象映射中输入对象标识和指定的仆人。
activate_object_with_id(byte[], Servant) - Method in interface org.omg.PortableServer. POAOperations
此操作将在“活动对象映射”中输入指定的对象标识和指定服务器之间的关联。
activateController() - Method in class javax.imageio. IIOParam
激活此 IIOParam对象的已安装的 IIOParamController并返回结果值。
activateController() - Method in class javax.imageio.metadata. IIOMetadata
激活此 IIOMetadata对象的已安装的 IIOMetadataController ，并返回结果值。
ACTIVATED - Static variable in class javax.swing.event. HyperlinkEvent.EventType
激活类型。
activatedProperty() - Method in class javafx.scene.control. Tooltip
通常，当鼠标移动到控件上时，工具提示被“激活”。
ActivateFailedException - Exception in java.rmi.activation
在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。
ActivateFailedException(String) - Constructor for exception java.rmi.activation. ActivateFailedException
构造具有指定详细消息的 ActivateFailedException 。
ActivateFailedException(String, Exception) - Constructor for exception java.rmi.activation. ActivateFailedException
构造一个具有指定的详细消息和嵌套异常的 ActivateFailedException 。
activateFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
这将激活 f将其移动到前面。
activateFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager
一般来说，表示这个框架有焦点。
activateFrame(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
当框架被选中时调用此方法。
activateLink(int, JEditorPane) - Method in class javax.swing.text.html. HTMLEditorKit.LinkController
如果给定的位置表示链接，则在相关联的JEditorPane上调用linkActivated。
ACTIVATION - java.awt.event. FocusEvent.Cause
激活一个tople窗口。
ActivationDataFlavor - Class in javax.activation
ActivationDataFlavor类是 java.awt.datatransfer.DataFlavor的特殊子类。
ActivationDataFlavor(Class, String) - Constructor for class javax.activation. ActivationDataFlavor
构造一个表示MimeType的DataFlavor。
ActivationDataFlavor(Class, String, String) - Constructor for class javax.activation. ActivationDataFlavor
构造一个表示任意Java对象的DataFlavor。
ActivationDataFlavor(String, String) - Constructor for class javax.activation. ActivationDataFlavor
构造一个表示MimeType的DataFlavor。
ActivationDesc - Class in java.rmi.activation
激活描述符包含激活对象所需的信息：对象的组标识符，对象的全限定类名，对象的代码位置（类的位置），代码库URL路径，对象的重新启动“模式”，以及，一个可以包含对象特定初始化数据的“编组”对象。
ActivationDesc(String, String, MarshalledObject<?>) - Constructor for class java.rmi.activation. ActivationDesc
为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
ActivationDesc(String, String, MarshalledObject<?>, boolean) - Constructor for class java.rmi.activation. ActivationDesc
为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>) - Constructor for class java.rmi.activation. ActivationDesc
为类名为 className的对象构造一个对象描述符，该对象描述符可以从代码 location加载，其初始化信息为 data 。
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>, boolean) - Constructor for class java.rmi.activation. ActivationDesc
为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。
ActivationException - Exception in java.rmi.activation
激活界面使用的常规异常。
ActivationException() - Constructor for exception java.rmi.activation. ActivationException
构造一个 ActivationException 。
ActivationException(String) - Constructor for exception java.rmi.activation. ActivationException
构造具有指定详细消息的 ActivationException 。
ActivationException(String, Throwable) - Constructor for exception java.rmi.activation. ActivationException
构造一个具有指定的详细信息和原因的 ActivationException 。
ActivationGroup - Class in java.rmi.activation
一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor何时：其对象变为活动或非活动，或组作为整体变为不活动。
ActivationGroup(ActivationGroupID) - Constructor for class java.rmi.activation. ActivationGroup
构造具有给定激活组标识符的激活组。
ActivationGroup_Stub - Class in java.rmi.activation
ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup子类的存根类。
ActivationGroup_Stub(RemoteRef) - Constructor for class java.rmi.activation. ActivationGroup_Stub
为 ActivationGroup类构造一个存根。
ActivationGroupDesc - Class in java.rmi.activation
激活组描述符包含创建/重新创建激活对象的激活组所需的信息。
ActivationGroupDesc(String, String, MarshalledObject<?>, Properties, ActivationGroupDesc.CommandEnvironment) - Constructor for class java.rmi.activation. ActivationGroupDesc
指定要用于组的备用组实现和执行环境。
ActivationGroupDesc(Properties, ActivationGroupDesc.CommandEnvironment) - Constructor for class java.rmi.activation. ActivationGroupDesc
构造一个使用系统默认值进行组实现和代码位置的组描述符。
ActivationGroupDesc.CommandEnvironment - Class in java.rmi.activation
ActivationGroup实现的启动选项。
ActivationGroupID - Class in java.rmi.activation
注册激活组的标识符有几个目的：在激活系统中唯一标识组，并包含对组的激活系统的引用，以便组可以在必要时联系其激活系统。
ActivationGroupID(ActivationSystem) - Constructor for class java.rmi.activation. ActivationGroupID
构造一个唯一的组ID。
ActivationID - Class in java.rmi.activation
激活使用特殊标识符来表示可以随时间激活的远程对象。
ActivationID(Activator) - Constructor for class java.rmi.activation. ActivationID
ActivationID的构造函数使用一个参数，即激活器，它指定了激活与此标识符相关联的对象的激活程序的远程引用。
ActivationInstantiator - Interface in java.rmi.activation
一个 ActivationInstantiator负责创建“可激活”对象的实例。
ActivationMonitor - Interface in java.rmi.activation
一个 ActivationMonitor是专门针对一个 ActivationGroup ，当一个组通过调用 ActivationSystem.activeGroup （这是内部完成）被报告为活动时获得。
ActivationSystem - Interface in java.rmi.activation
ActivationSystem提供了一种注册组和“可激活”对象在这些组内被激活的方法。
Activator - Interface in java.rmi.activation
Activator有助于远程对象激活。
ACTIVATOR_ID - Static variable in class java.rmi.server. ObjID
对象号为着名的 ObjID的激活剂。
active - Variable in class javax.sound.midi. VoiceStatus
指示语音是否正在处理MIDI音符。
ACTIVE - Interface in org.omg.PortableInterceptor
org / omg / PortableInterceptor / ACTIVE.java。
ACTIVE - Static variable in class javax.accessibility. AccessibleState
表示窗口当前是活动窗口。
ACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage. State
ACTIVE_CAPTION - Static variable in class java.awt. SystemColor
SystemColor.activeCaption系统颜色的数组索引。
ACTIVE_CAPTION_BORDER - Static variable in class java.awt. SystemColor
阵列索引为 SystemColor.activeCaptionBorder系统颜色。
ACTIVE_CAPTION_TEXT - Static variable in class java.awt. SystemColor
阵列索引为 SystemColor.activeCaptionText系统颜色。
ACTIVE_SENSING - Static variable in class javax.sound.midi. ShortMessage
Active Sensing消息的状态字节（0xFE或254）。
activeCaption - Static variable in class java.awt. SystemColor
为当前活动窗口的窗口标题背景呈现的颜色。
activeCaptionBorder - Static variable in class java.awt. SystemColor
为当前活动窗口周围的边框渲染的颜色。
activeCaptionText - Static variable in class java.awt. SystemColor
为当前活动窗口的窗口标题文本呈现的颜色。
activeCount() - Static method in class java.lang. Thread
返回当前线程的thread group及其子组中活动线程数的估计。
activeCount() - Method in class java.lang. ThreadGroup
返回此线程组及其子组中活动线程数的估计。
ActiveEvent - Interface in java.awt
一个知道如何发送自己的事件的界面。
activeGroup(ActivationGroupID, ActivationInstantiator, long) - Method in interface java.rmi.activation. ActivationSystem
回调通知激活系统该组现在处于活动状态。
activeGroupCount() - Method in class java.lang. ThreadGroup
返回此线程组及其子组中活动组数的估计。
activeObject(ActivationID, MarshalledObject<? extends Remote>) - Method in class java.rmi.activation. ActivationGroup
这个受保护的方法对于子类来说使得 activeObject回调到组的监视器是必要的。
activeObject(ActivationID, MarshalledObject<? extends Remote>) - Method in interface java.rmi.activation. ActivationMonitor
通知对象现在处于活动状态。
activeObject(ActivationID, Remote) - Method in class java.rmi.activation. ActivationGroup
当对象被导出（由 Activatable对象构造或显式调用到 Activatable.exportObject时，将调用该组的 activeObject方法。
ACTIVITY_COMPLETED - Exception in org.omg.CORBA
可以在任何访问Activity上下文的方法上引发 ACTIVITY_COMPLETED系统异常。
ACTIVITY_COMPLETED() - Constructor for exception org.omg.CORBA. ACTIVITY_COMPLETED
构造一个 ACTIVITY_COMPLETED异常，次要代码设置为0，CompletionStatus设置为COMPLETED_NO。
ACTIVITY_COMPLETED(int, CompletionStatus) - Constructor for exception org.omg.CORBA. ACTIVITY_COMPLETED
构造具有指定的次要代码和完成状态的 ACTIVITY_COMPLETED异常。
ACTIVITY_COMPLETED(String) - Constructor for exception org.omg.CORBA. ACTIVITY_COMPLETED
使用指定的消息构造一个 ACTIVITY_COMPLETED异常。
ACTIVITY_COMPLETED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. ACTIVITY_COMPLETED
构造具有指定消息，次要代码和完成状态的 ACTIVITY_COMPLETED异常。
ACTIVITY_REQUIRED - Exception in org.omg.CORBA
可能会在需要Activity上下文的任何方法上引发 ACTIVITY_REQUIRED系统异常。
ACTIVITY_REQUIRED() - Constructor for exception org.omg.CORBA. ACTIVITY_REQUIRED
构造一个 ACTIVITY_REQUIRED异常，次要代码设置为0，CompletionStatus设置为COMPLETED_NO。
ACTIVITY_REQUIRED(int, CompletionStatus) - Constructor for exception org.omg.CORBA. ACTIVITY_REQUIRED
构造具有指定的次要代码和完成状态的 ACTIVITY_REQUIRED异常。
ACTIVITY_REQUIRED(String) - Constructor for exception org.omg.CORBA. ACTIVITY_REQUIRED
使用指定的消息构造一个 ACTIVITY_REQUIRED异常。
ACTIVITY_REQUIRED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. ACTIVITY_REQUIRED
构造具有指定消息，次要代码和完成状态的 ACTIVITY_REQUIRED异常。
ActivityCompletedException - Exception in javax.activity
可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。
ActivityCompletedException() - Constructor for exception javax.activity. ActivityCompletedException
构造一个具有null作为其详细消息的新实例。
ActivityCompletedException(String) - Constructor for exception javax.activity. ActivityCompletedException
构造具有指定详细消息的新实例。
ActivityCompletedException(String, Throwable) - Constructor for exception javax.activity. ActivityCompletedException
构造一个新的可抛出指定的详细信息和原因。
ActivityCompletedException(Throwable) - Constructor for exception javax.activity. ActivityCompletedException
构造具有指定原因的新的throwable。
ActivityRequiredException - Exception in javax.activity
如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。
ActivityRequiredException() - Constructor for exception javax.activity. ActivityRequiredException
构造一个具有null作为其详细消息的新实例。
ActivityRequiredException(String) - Constructor for exception javax.activity. ActivityRequiredException
构造具有指定详细消息的新实例。
ActivityRequiredException(String, Throwable) - Constructor for exception javax.activity. ActivityRequiredException
构造一个新的可抛出指定的详细信息和原因。
ActivityRequiredException(Throwable) - Constructor for exception javax.activity. ActivityRequiredException
构造具有指定原因的新的throwable。
AD - Static variable in class java.util. GregorianCalendar
价值 ERA字段表示共同的时代（Anno Domini），也被称为CE。
adapt(Runnable) - Static method in class java.util.concurrent. ForkJoinTask
返回一个新的 ForkJoinTask ，它执行给定的 Runnable的 run方法作为其操作，并返回一个null结果，在 ForkJoinTask.join() 。
adapt(Runnable, T) - Static method in class java.util.concurrent. ForkJoinTask
返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其动作的 run方法，并将给定的结果返回给 ForkJoinTask.join() 。
adapt(Callable<? extends T>) - Static method in class java.util.concurrent. ForkJoinTask
返回一个新的 ForkJoinTask ，它执行给定的 Callable作为其操作的 call方法，并将其结果返回到 ForkJoinTask.join() ，将任何检查的异常转换为 RuntimeException 。
adapter_id() - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations
返回对象适配器的不透明标识符。
adapter_manager_state_changed(int, short) - Method in interface org.omg.PortableInterceptor. IORInterceptor_3_0Operations
每当适配器管理器的状态发生变化时调用。
adapter_name() - Method in interface org.omg.PortableInterceptor. ObjectReferenceTemplate
adapter_name() - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations
返回标识正在处理此请求的对象适配器实例的字符串序列。
adapter_state_changed(ObjectReferenceTemplate[], short) - Method in interface org.omg.PortableInterceptor. IORInterceptor_3_0Operations
当对象适配器的状态发生变化并且状态更改不是由适配器管理器引起时调用。
adapter_template() - Method in interface org.omg.PortableInterceptor. IORInfoOperations
返回刚创建的对象适配器的对象引用模板，并运行IOR拦截器。
AdapterActivator - Interface in org.omg.PortableServer
适配器激活器为POA提供了根据需要创建儿童POA的能力，作为接收命名儿童POA（或其一个孩子）的请求的副作用，或者当使用activate参数值为TRUE时调用find_POA时。
AdapterActivatorOperations - Interface in org.omg.PortableServer
适配器激活器为POA提供了根据需要创建儿童POA的能力，作为接收命名儿童POA（或其一个孩子）的请求的副作用，或者当使用activate参数值为TRUE时调用find_POA时。
AdapterAlreadyExists - Exception in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / AdapterAlreadyExists.java。
AdapterAlreadyExists() - Constructor for exception org.omg.PortableServer.POAPackage. AdapterAlreadyExists
AdapterAlreadyExists(String) - Constructor for exception org.omg.PortableServer.POAPackage. AdapterAlreadyExists
AdapterAlreadyExistsHelper - Class in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / AdapterAlreadyExistsHelper.java。
AdapterAlreadyExistsHelper() - Constructor for class org.omg.PortableServer.POAPackage. AdapterAlreadyExistsHelper
AdapterInactive - Exception in org.omg.PortableServer.POAManagerPackage
org / omg / PortableServer / POAManagerPackage / AdapterInactive.java。
AdapterInactive() - Constructor for exception org.omg.PortableServer.POAManagerPackage. AdapterInactive
AdapterInactive(String) - Constructor for exception org.omg.PortableServer.POAManagerPackage. AdapterInactive
AdapterInactiveHelper - Class in org.omg.PortableServer.POAManagerPackage
org / omg / PortableServer / POAManagerPackage / AdapterInactiveHelper.java。
AdapterInactiveHelper() - Constructor for class org.omg.PortableServer.POAManagerPackage. AdapterInactiveHelper
AdapterManagerIdHelper - Class in org.omg.PortableInterceptor
适配器管理标识符
AdapterManagerIdHelper() - Constructor for class org.omg.PortableInterceptor. AdapterManagerIdHelper
AdapterNameHelper - Class in org.omg.PortableInterceptor
对象适配器的名称。
AdapterNameHelper() - Constructor for class org.omg.PortableInterceptor. AdapterNameHelper
AdapterNonExistent - Exception in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / AdapterNonExistent.java。
AdapterNonExistent() - Constructor for exception org.omg.PortableServer.POAPackage. AdapterNonExistent
AdapterNonExistent(String) - Constructor for exception org.omg.PortableServer.POAPackage. AdapterNonExistent
AdapterNonExistentHelper - Class in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / AdapterNonExistentHelper.java。
AdapterNonExistentHelper() - Constructor for class org.omg.PortableServer.POAPackage. AdapterNonExistentHelper
AdapterStateHelper - Class in org.omg.PortableInterceptor
对象适配器状态的类型。
AdapterStateHelper() - Constructor for class org.omg.PortableInterceptor. AdapterStateHelper
add(byte) - Method in class java.awt.image.renderable. ParameterBlock
将一个字节添加到参数列表中。
add(char) - Method in class java.awt.image.renderable. ParameterBlock
在参数列表中添加一个字符。
add(double) - Method in class java.awt.image.renderable. ParameterBlock
向参数列表中添加一个Double。
add(double) - Method in class java.util.concurrent.atomic. DoubleAdder
添加给定值。
add(double) - Method in interface java.util.stream. DoubleStream.Builder
向要构建的流添加元素。
add(double) - Method in class javafx.beans.binding. DoubleExpression
add(double) - Method in class javafx.beans.binding. FloatExpression
add(double) - Method in class javafx.beans.binding. IntegerExpression
add(double) - Method in class javafx.beans.binding. LongExpression
add(double) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
add(double, double) - Method in class java.awt.geom. Rectangle2D
将由双精度参数 newx和 newy指定的点添加到此 Rectangle2D 。
add(double, double) - Method in class javafx.geometry. Point2D
返回具有指定坐标的点添加到此点的坐标。
add(double, double, double) - Method in class javafx.geometry. Point3D
返回具有指定坐标的点添加到此点的坐标。
add(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
add(float) - Method in class java.awt.image.renderable. ParameterBlock
将浮点数添加到参数列表中。
add(float) - Method in class javafx.beans.binding. DoubleExpression
add(float) - Method in class javafx.beans.binding. FloatExpression
add(float) - Method in class javafx.beans.binding. IntegerExpression
add(float) - Method in class javafx.beans.binding. LongExpression
add(float) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
add(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
add(int) - Method in class java.awt.image.renderable. ParameterBlock
将一个整数添加到参数列表中。
add(int) - Method in interface java.util.stream. IntStream.Builder
向要构建的流添加元素。
add(int) - Method in class javafx.beans.binding. DoubleExpression
add(int) - Method in class javafx.beans.binding. FloatExpression
add(int) - Method in class javafx.beans.binding. IntegerExpression
add(int) - Method in class javafx.beans.binding. LongExpression
add(int) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算这个NumberExpression的总和和一个常量值。
add(int) - Method in class org.omg.CORBA. NVList
创建一个新的 NamedValue对象，并使用给定的标志进行初始化，并将其添加到该 NVList对象的末尾。
add(int, int) - Method in class java.awt. Rectangle
增加了一个点，由整数参数指定 newx,newy到此的边界 Rectangle 。
add(int, int) - Method in class java.util. Calendar
根据日历的规则，将指定的时间量添加或减去给定的日历字段。
add(int, int) - Method in class java.util. GregorianCalendar
根据日历的规则，将指定的（已签名的）时间添加到给定的日历字段。
add(int, E) - Method in class java.util. AbstractList
将指定的元素插入此列表中的指定位置（可选操作）。
add(int, E) - Method in class java.util. AbstractSequentialList
将指定的元素插入此列表中的指定位置（可选操作）。
add(int, E) - Method in class java.util. ArrayList
在此列表中的指定位置插入指定的元素。
add(int, E) - Method in class java.util.concurrent. CopyOnWriteArrayList
在此列表中的指定位置插入指定的元素。
add(int, E) - Method in class java.util. LinkedList
在此列表中的指定位置插入指定的元素。
add(int, E) - Method in interface java.util. List
将指定的元素插入此列表中的指定位置（可选操作）。
add(int, E) - Method in class java.util. Vector
在此Vector中的指定位置插入指定的元素。
add(int, E) - Method in class javafx.beans.binding. ListExpression
add(int, E) - Method in class javafx.collections. ModifiableObservableListBase
add(int, E) - Method in class javax.swing. DefaultListModel
在此列表中的指定位置插入指定的元素。
add(int, Object) - Method in class javax.management. AttributeList
在此列表中的指定位置插入指定的元素。
add(int, Object) - Method in class javax.management.relation. RoleList
add(int, Object) - Method in class javax.management.relation. RoleUnresolvedList
add(int, Object) - Method in interface javax.naming.directory. Attribute
向属性值的有序列表添加属性值。
add(int, Object) - Method in class javax.naming.directory. BasicAttribute
add(int, String) - Method in class javax.naming. CompositeName
在此复合名称中的指定位置添加单个组件。
add(int, String) - Method in class javax.naming. CompoundName
在此化合物名称中的指定位置添加单个组件。
add(int, String) - Method in class javax.naming.ldap. LdapName
在此LDAP名称中的指定位置添加单个组件。
add(int, String) - Method in interface javax.naming. Name
在此名称中的指定位置添加单个组件。
add(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
add(int, Attribute) - Method in class javax.management. AttributeList
在指定的位置插入指定为元素的属性。
add(int, Role) - Method in class javax.management.relation. RoleList
在指定的位置插入指定为元素的角色。
add(int, RoleUnresolved) - Method in class javax.management.relation. RoleUnresolvedList
在指定的位置插入指定为元素的未解决角色。
add(int, Rdn) - Method in class javax.naming.ldap. LdapName
在此LDAP名称中的指定位置添加单个RDN。
add(int, RefAddr) - Method in class javax.naming. Reference
将地址添加到索引posn的地址列表中。
add(long) - Method in class java.awt.image.renderable. ParameterBlock
在参数列表中添加一个Long。
add(long) - Method in class java.util.concurrent.atomic. LongAdder
添加给定值。
add(long) - Method in interface java.util.stream. LongStream.Builder
向要构建的流添加元素。
add(long) - Method in class javafx.beans.binding. DoubleExpression
add(long) - Method in class javafx.beans.binding. FloatExpression
add(long) - Method in class javafx.beans.binding. IntegerExpression
add(long) - Method in class javafx.beans.binding. LongExpression
add(long) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值的总和。
add(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值和一个恒定值的总和。
add(short) - Method in class java.awt.image.renderable. ParameterBlock
在参数列表中添加一个Short。
add(E) - Method in class java.util. AbstractCollection
确保此集合包含指定的元素（可选操作）。
add(E) - Method in class java.util. AbstractList
将指定的元素追加到此列表的末尾（可选操作）。
add(E) - Method in class java.util. AbstractQueue
将指定的元素插入到此队列中，如果可以立即执行此操作而不违反容量限制， true成功返回 true ，如果当前没有可用的空间，则抛出 IllegalStateException 。
add(E) - Method in class java.util. ArrayDeque
在此deque的末尾插入指定的元素。
add(E) - Method in class java.util. ArrayList
将指定的元素追加到此列表的末尾。
add(E) - Method in interface java.util. Collection
确保此集合包含指定的元素（可选操作）。
add(E) - Method in class java.util.concurrent. ArrayBlockingQueue
如果可以在不超过队列的容量的情况下立即将其指定的元素插入到该队列的尾部，则在成功后返回 true ，如果该队列已满，则抛出 IllegalStateException 。
add(E) - Method in interface java.util.concurrent. BlockingDeque
将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），如果可以立即执行此操作而不违反容量限制， true成功返回 true ，如果当前没有可用空间，则抛出 IllegalStateException 。
add(E) - Method in interface java.util.concurrent. BlockingQueue
将指定的元素插入到此队列中，如果可以立即执行此操作而不违反容量限制，成功后返回 true ，如果当前没有可用空间，则抛出 IllegalStateException 。
add(E) - Method in class java.util.concurrent. ConcurrentLinkedDeque
在此deque的尾部插入指定的元素。
add(E) - Method in class java.util.concurrent. ConcurrentLinkedQueue
在该队列的尾部插入指定的元素。
add(E) - Method in class java.util.concurrent. ConcurrentSkipListSet
将指定的元素添加到此集合（如果尚未存在）。
add(E) - Method in class java.util.concurrent. CopyOnWriteArrayList
将指定的元素追加到此列表的末尾。
add(E) - Method in class java.util.concurrent. CopyOnWriteArraySet
将指定的元素添加到此集合（如果尚未存在）。
add(E) - Method in class java.util.concurrent. DelayQueue
将指定的元素插入到此延迟队列中。
add(E) - Method in class java.util.concurrent. LinkedBlockingDeque
在此deque的末尾插入指定的元素，除非它会违反容量限制。
add(E) - Method in class java.util.concurrent. LinkedTransferQueue
在该队列的尾部插入指定的元素。
add(E) - Method in class java.util.concurrent. PriorityBlockingQueue
将指定的元素插入到此优先级队列中。
add(E) - Method in interface java.util. Deque
将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），如果可以立即执行，而不违反容量限制， true成功返回 true ，如果当前没有可用空间，则抛出 IllegalStateException 。
add(E) - Method in class java.util. HashSet
将指定的元素添加到此集合（如果尚未存在）。
add(E) - Method in class java.util. LinkedList
将指定的元素追加到此列表的末尾。
add(E) - Method in interface java.util. List
将指定的元素追加到此列表的末尾（可选操作）。
add(E) - Method in interface java.util. ListIterator
将指定的元素插入列表（可选操作）。
add(E) - Method in class java.util. PriorityQueue
将指定的元素插入到此优先级队列中。
add(E) - Method in interface java.util. Queue
将指定的元素插入到此队列中，如果可以立即执行此操作而不违反容量限制， true成功返回 true ，如果当前没有可用的空间，则抛出 IllegalStateException 。
add(E) - Method in interface java.util. Set
如果指定的元素不存在，则将其指定的元素添加（可选操作）。
add(E) - Method in class java.util. TreeSet
将指定的元素添加到此集合（如果尚未存在）。
add(E) - Method in class java.util. Vector
将指定的元素追加到此Vector的末尾。
add(E) - Method in class javafx.beans.binding. ListExpression
add(E) - Method in class javafx.beans.binding. SetExpression
add(Component) - Method in class java.awt. Container
将指定的组件附加到此容器的末尾。
add(Component) - Method in class javax.swing. JMenu
将一个组件附加到此菜单的末尾。
add(Component) - Method in class javax.swing. JTabbedPane
添加一个 component与选项卡标题默认为组件的名称，这是调用 component.getName的结果。
add(Component, int) - Method in class java.awt. Container
在给定的位置将指定的组件添加到此容器。
add(Component, int) - Method in class javax.swing. JMenu
在给定的位置将指定的组件添加到此容器。
add(Component, int) - Method in class javax.swing. JTabbedPane
在指定的选项卡索引中添加一个 component ，其中的选项卡标题默认为组件的名称。
add(Component, Object) - Method in class java.awt. Container
将指定的组件添加到此容器的末尾。
add(Component, Object) - Method in class javax.swing. JTabbedPane
在标签窗格中添加一个 component 。
add(Component, Object, int) - Method in class java.awt. Container
将指定的组件添加到指定索引处的指定约束的容器中。
add(Component, Object, int) - Method in class javax.swing. JTabbedPane
在指定的选项卡索引中添加一个 component 。
add(ActionListener, ActionListener) - Static method in class java.awt. AWTEventMulticaster
添加action-listener-a与action-listener-b，并返回生成的组播侦听器。
add(AdjustmentListener, AdjustmentListener) - Static method in class java.awt. AWTEventMulticaster
使用adjust-listener-b添加调整监听器a，并返回生成的组播侦听器。
add(ComponentListener, ComponentListener) - Static method in class java.awt. AWTEventMulticaster
将component-listener-a与component-listener-b相加，并返回生成的组播侦听器。
add(ContainerListener, ContainerListener) - Static method in class java.awt. AWTEventMulticaster
将container-listener-a与container-listener-b相加，并返回生成的组播侦听器。
add(FocusListener, FocusListener) - Static method in class java.awt. AWTEventMulticaster
将focus-listener-a与focus-listener-b相加，并返回生成的组播侦听器。
add(HierarchyBoundsListener, HierarchyBoundsListener) - Static method in class java.awt. AWTEventMulticaster
将hierarchy-bounds-listener-a与hierarchy-bounds-listener-b相加，并返回生成的组播监听器。
add(HierarchyListener, HierarchyListener) - Static method in class java.awt. AWTEventMulticaster
添加具有hierarchy-listener-b的hierarchy-listener-a并返回生成的组播侦听器。
add(InputMethodListener, InputMethodListener) - Static method in class java.awt. AWTEventMulticaster
将input-method-listener-a与input-method-listener-b相加，并返回生成的组播侦听器。
add(ItemListener, ItemListener) - Static method in class java.awt. AWTEventMulticaster
将item-listener-a与item-listener-b相加，并返回生成的组播监听器。
add(KeyListener, KeyListener) - Static method in class java.awt. AWTEventMulticaster
将key-listener-a与key-listener-b相加，并返回生成的组播侦听器。
add(MouseListener, MouseListener) - Static method in class java.awt. AWTEventMulticaster
添加mouse-listener-a与mouse-listener-b并返回结果组播监听器。
add(MouseMotionListener, MouseMotionListener) - Static method in class java.awt. AWTEventMulticaster
添加mouse-motion-listener-a与mouse-motion-listener-b并返回生成的组播侦听器。
add(MouseWheelListener, MouseWheelListener) - Static method in class java.awt. AWTEventMulticaster
添加鼠标滚轮监听器a和鼠标滚轮监听器b并返回结果组播侦听器。
add(TextListener, TextListener) - Static method in class java.awt. AWTEventMulticaster
将text-listener-a与text-listener-b相加，并返回生成的多播侦听器。
add(WindowFocusListener, WindowFocusListener) - Static method in class java.awt. AWTEventMulticaster
使用window-focus-listener-b添加window-focus-listener-a，并返回生成的多播侦听器。
add(WindowListener, WindowListener) - Static method in class java.awt. AWTEventMulticaster
添加window-listener-a与window-listener-b并返回结果组播侦听器。
add(WindowStateListener, WindowStateListener) - Static method in class java.awt. AWTEventMulticaster
将window-state-listener-a与window-state-listener-b相加，并返回结果组播监听器。
add(Area) - Method in class java.awt.geom. Area
添加指定的形状 Area这种形状 Area 。
add(Point2D) - Method in class java.awt.geom. Rectangle2D
将 Point2D对象 pt添加到此 Rectangle2D 。
add(Rectangle2D) - Method in class java.awt.geom. Rectangle2D
在这个 Rectangle2D添加一个 Rectangle2D对象。
add(Menu) - Method in class java.awt. MenuBar
将指定的菜单添加到菜单栏。
add(MenuItem) - Method in class java.awt. Menu
将指定的菜单项添加到此菜单。
add(Point) - Method in class java.awt. Rectangle
添加指定 Point本的界限 Rectangle 。
add(PopupMenu) - Method in class java.awt. Component
将指定的弹出菜单添加到组件。
add(Rectangle) - Method in class java.awt. Rectangle
添加一个 Rectangle这个 Rectangle 。
add(RenderingHints) - Method in class java.awt. RenderingHints
将所有键和对应的值从指定的 RenderingHints对象添加到此 RenderingHints对象。
add(TrayIcon) - Method in class java.awt. SystemTray
添加 TrayIcon到 SystemTray 。
add(CharSequence) - Method in class java.util. StringJoiner
将给定的副本 CharSequence值作为下一个元素 StringJoiner值。
add(Class<? extends EventListener>, EventListener) - Method in class com.sun.java.accessibility.util. AccessibilityListenerList
将侦听器添加为指定类型的侦听器。
add(Class<T>, T) - Method in class javax.swing.event. EventListenerList
将侦听器添加为指定类型的侦听器。
add(Object) - Method in class java.awt.image.renderable. ParameterBlock
将对象添加到参数列表中。
add(Object) - Method in class java.beans.beancontext. BeanContextSupport
在这个 BeanContext内添加/嵌套一个孩子。
add(Object) - Method in class javax.management. AttributeList
将指定的元素追加到此列表的末尾。
add(Object) - Method in class javax.management.relation. RoleList
add(Object) - Method in class javax.management.relation. RoleUnresolvedList
add(Object) - Method in interface javax.naming.directory. Attribute
向属性添加一个新值。
add(Object) - Method in class javax.naming.directory. BasicAttribute
向此属性添加一个新值。
add(String) - Method in class java.awt. Choice
在 Choice菜单中添加一个项目。
add(String) - Method in class java.awt. List
将指定的项目添加到滚动列表的末尾。
add(String) - Method in class java.awt. Menu
将具有指定标签的项目添加到此菜单。
add(String) - Method in class javax.naming. CompositeName
将单个组件添加到此组合名称的末尾。
add(String) - Method in class javax.naming. CompoundName
将单个组件添加到此化合物名称的末尾。
add(String) - Method in class javax.naming.ldap. LdapName
将单个组件添加到此LDAP名称的末尾。
add(String) - Method in interface javax.naming. Name
将单个组件添加到此名称的末尾。
add(String) - Method in class javax.swing. JMenu
创建一个带有指定文本的新菜单项，并将其附加到此菜单的末尾。
add(String) - Method in class javax.swing. JPopupMenu
创建一个带有指定文本的新菜单项，并将其附加到此菜单的末尾。
add(String) - Method in class org.omg.CORBA. ContextList
将 String对象添加到此 ContextList对象。
add(String, int) - Method in class java.awt. List
在指定的位置将指定的项目添加到滚动列表。
add(String, Component) - Method in class java.awt. Container
将指定的组件添加到此容器。
add(String, Component) - Method in class javax.swing. JTabbedPane
添加一个 component与指定的选项卡标题。
add(String, String) - Method in class com.sun.net.httpserver. Headers
将给定的值添加到给定键的标题列表中。
add(BigDecimal) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this + augend) ，其标为 max(this.scale(), augend.scale()) 。
add(BigDecimal, MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this + augend) ，根据上下文设置进行舍入。
add(BigInteger) - Method in class java.math. BigInteger
返回值为 (this + val)的BigInteger。
add(URI, HttpCookie) - Method in interface java.net. CookieStore
向商店添加一个HTTP cookie。
add(Permission) - Method in class java.security. PermissionCollection
将权限对象添加到当前权限对象集合。
add(Permission) - Method in class java.security. Permissions
将权限对象添加到权限所属的类的PermissionCollection。
add(ObservableNumberValue) - Method in class javafx.beans.binding. DoubleExpression
add(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的总和。
add(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase
add(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
add(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值和一个恒定值的总和。
add(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算一个ObservableNumberValue的值和一个恒定值的总和。
add(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，用于计算的值的总和ObservableNumberValue和恒定值。
add(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding计算的两个实例的值的总和ObservableNumberValue 。
add(Point2D) - Method in class javafx.geometry. Point2D
返回一个点，其中指定点的坐标添加到此点的坐标。
add(Point3D) - Method in class javafx.geometry. Point3D
返回一个点，其中指定点的坐标添加到此点的坐标。
add(Node, int, int) - Method in class javafx.scene.layout. GridPane
在指定的列，行位置向子窗格添加一个小孩。
add(Node, int, int, int, int) - Method in class javafx.scene.layout. GridPane
在指定的列，行位置和跨度向窗格中添加一个小孩。
add(Duration) - Method in class javafx.util. Duration
添加此实例和另一个Duration实例以返回一个新的Duration实例。
add(AccessibleRelation) - Method in class javax.accessibility. AccessibleRelationSet
添加与当前关系集的新关系。
add(AccessibleState) - Method in class javax.accessibility. AccessibleStateSet
如果当前状态集不存在，则添加一个新状态。
add(Attribute) - Method in class javax.management. AttributeList
添加指定为列表的最后一个元素的 Attribute 。
add(Role) - Method in class javax.management.relation. RoleList
将指定的角色添加为列表的最后一个元素。
add(RoleUnresolved) - Method in class javax.management.relation. RoleUnresolvedList
将指定的RoleUnresolved作为列表的最后一个元素添加。
add(Rdn) - Method in class javax.naming.ldap. LdapName
将单个RDN添加到此LDAP名称的末尾。
add(RefAddr) - Method in class javax.naming. Reference
将地址添加到地址列表的末尾。
add(Attribute) - Method in interface javax.print.attribute. AttributeSet
如果指定的属性不存在，请将指定的属性添加到此属性集中，首先删除与指定的属性值相同的属性类别中的任何现有值。
add(Attribute) - Method in interface javax.print.attribute. DocAttributeSet
如果指定的属性值不存在，请将指定的属性值添加到该属性集中，首先删除与指定的属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - Method in class javax.print.attribute. HashAttributeSet
如果指定的属性不存在，请将指定的属性添加到该属性集中，首先删除与指定的属性值相同的属性类别中的任何现有属性。
add(Attribute) - Method in interface javax.print.attribute. PrintJobAttributeSet
如果指定的属性值不存在，请将指定的属性值添加到该属性集中，首先删除与指定的属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - Method in interface javax.print.attribute. PrintRequestAttributeSet
如果指定的属性值不存在，请将指定的属性值添加到该属性集中，首先删除与指定的属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - Method in interface javax.print.attribute. PrintServiceAttributeSet
如果指定的属性值不存在，请将指定的属性值添加到该属性集中，首先删除与指定的属性值相同的属性类别中的任何现有值（可选操作）。
add(JobStateReason) - Method in class javax.print.attribute.standard. JobStateReasons
如果指定的元素不存在，则将此指定元素添加到此作业状态reason属性。
add(MidiEvent) - Method in class javax.sound.midi. Track
向轨道添加新事件。
add(AbstractButton) - Method in class javax.swing. ButtonGroup
将按钮添加到组。
add(Action) - Method in class javax.swing. JMenu
创建附加到指定的 Action对象的新菜单项，并将其附加到此菜单的末尾。
add(Action) - Method in class javax.swing. JPopupMenu
在菜单的末尾附加一个新的菜单项，该菜单将调度指定的 Action对象。
add(Action) - Method in class javax.swing. JToolBar
添加一个新的 JButton调度该操作。
add(JMenu) - Method in class javax.swing. JMenuBar
将指定的菜单附加到菜单栏的末尾。
add(JMenuItem) - Method in class javax.swing. JMenu
将菜单项添加到此菜单的末尾。
add(JMenuItem) - Method in class javax.swing. JPopupMenu
将指定的菜单项追加到此菜单的末尾。
add(MutableTreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode
从其父代中删除 newChild ，并将其添加到该节点的子数组的末尾，使其成为该节点的子节点。
add(Duration) - Method in class javax.xml.datatype. Duration
计算值为 this+rhs的新持续时间。
add(Duration) - Method in class javax.xml.datatype. XMLGregorianCalendar
添加 duration到这个实例。
add(XMLEvent) - Method in interface javax.xml.stream.util. XMLEventConsumer
此方法会向消费者添加一个事件。
add(XMLEvent) - Method in interface javax.xml.stream. XMLEventWriter
将事件添加到输出流添加START_ELEMENT将打开一个新的命名空间范围，当对应的END_ELEMENT被写入时，它将被关闭。
add(XMLEventReader) - Method in interface javax.xml.stream. XMLEventWriter
将一个整个流添加到输出流，在inputStream参数上调用next（），直到hasNext（）返回false这应被视为一种方便的方法，它将对事件读取器中的所有事件执行以下循环，并在每个事件中调用add事件。
add(K) - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView
通过将键映射到背景映射中的默认映射值（如果已定义），将指定的键添加到此设置视图。
add(GSSName, int, int, Oid, int) - Method in interface org.ietf.jgss. GSSCredential
将机制特定凭据元素添加到现有凭据。
add(TypeCode) - Method in class org.omg.CORBA. ExceptionList
添加描述 TypeCode对象的异常的 ExceptionList对象。
add(HTMLElement, HTMLElement) - Method in interface org.w3c.dom.html. HTMLSelectElement
为这个 SELECT的 OPTION元素的集合添加一个新元素。
add(T) - Method in interface java.util.stream. Stream.Builder
向要构建的流添加元素。
ADD - javafx.scene.effect. BlendMode
来自顶部输入的颜色和alpha分量被添加到从底部输入的颜色和alpha分量。
ADD - javafx.scene.input. KeyCode
常数为 Add键。
ADD_ATTRIBUTE - Static variable in interface javax.naming.directory. DirContext
此常数指定添加具有指定值的属性。
add_client_request_interceptor(ClientRequestInterceptor) - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
用于将客户端请求Interceptor添加到客户端请求拦截器列表中。
ADD_FILE - Static variable in enum java.nio.file.attribute. AclEntryPermission
将新文件添加到目录的权限（等于 AclEntryPermission.WRITE_DATA ）
add_in_arg() - Method in class org.omg.CORBA. Request
创建一个输入参数并将其添加到此 Request对象。
add_inout_arg() - Method in class org.omg.CORBA. Request
向此 Request对象添加一个输入/输出参数。
add_ior_component(TaggedComponent) - Method in interface org.omg.PortableInterceptor. IORInfoOperations
便携式ORB服务实现从其实施 establish_components调用 add_ior_component ，以在构造IOR时将包含的组中添加标记组件。
add_ior_component_to_profile(TaggedComponent, int) - Method in interface org.omg.PortableInterceptor. IORInfoOperations
可移植ORB服务实现调用 add_ior_component_to_profile从实施 establish_components到标记的组件添加到构造IOR时要包括的设置。
add_ior_interceptor(IORInterceptor) - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
用于将IOR Interceptor添加到IOR拦截器列表中。
add_item(String, int) - Method in class org.omg.CORBA. NVList
创建一个新的 NamedValue对象，使用给定的名称和标志进行初始化，并将其添加到此 NVList对象的末尾。
add_named_in_arg(String) - Method in class org.omg.CORBA. Request
创建一个给定名称的输入参数，并将其添加到此 Request对象。
add_named_inout_arg(String) - Method in class org.omg.CORBA. Request
将给定名称的输入/输出参数添加到此 Request对象。
add_named_out_arg(String) - Method in class org.omg.CORBA. Request
将给定名称的输出参数添加到此 Request对象。
add_out_arg() - Method in class org.omg.CORBA. Request
向此 Request对象添加输出参数。
ADD_OVERRIDE - Static variable in class org.omg.CORBA. SetOverrideType
SetOverrideType常量为枚举值ADD_OVERRIDE。
add_reply_service_context(ServiceContext, boolean) - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations
允许拦截器向请求添加服务上下文。
add_request_service_context(ServiceContext, boolean) - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations
允许拦截器向请求添加服务上下文。
add_server_request_interceptor(ServerRequestInterceptor) - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
用于将服务器端请求拦截器添加到服务器端请求拦截器列表中。
ADD_SUBDIRECTORY - Static variable in enum java.nio.file.attribute. AclEntryPermission
创建目录的子目录的权限（等于 AclEntryPermission.APPEND_DATA ）
add_value(String, Any, int) - Method in class org.omg.CORBA. NVList
创建一个新的 NamedValue对象，该对象使用给定的名称，值和标志初始化，并将其添加到此 NVList对象的末尾。
addAccessibleSelection(int) - Method in class java.awt. List.AccessibleAWTList
将对象中指定的选定项目添加到对象的选择中。
addAccessibleSelection(int) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent
将对象的指定的 Accessible子对象添加到对象的选择中。
addAccessibleSelection(int) - Method in interface javax.accessibility. AccessibleSelection
将对象的指定的 Accessible子对象添加到对象的选择中。
addAccessibleSelection(int) - Method in class javax.swing. JComboBox.AccessibleJComboBox
将对象的指定Accessible子对象添加到对象的选择中。
addAccessibleSelection(int) - Method in class javax.swing. JList.AccessibleJList
将对象中指定的选定项目添加到对象的选择中。
addAccessibleSelection(int) - Method in class javax.swing. JMenu.AccessibleJMenu
在菜单中选择 i菜单。
addAccessibleSelection(int) - Method in class javax.swing. JMenuBar.AccessibleJMenuBar
选择菜单栏中的第n个菜单，强制弹出。
addAccessibleSelection(int) - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane
addAccessibleSelection(int) - Method in class javax.swing. JTable.AccessibleJTable
将对象的指定的 Accessible子对象添加到对象的选择中。
addAccessibleSelection(int) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
将对象中指定的选定项目添加到对象的选择中。
addAccessibleSelection(int) - Method in class javax.swing. JTree.AccessibleJTree
将对象中指定的选定项目添加到对象的选择中。
addActionForKeyStroke(KeyStroke, Action) - Method in interface javax.swing.text. Keymap
添加绑定到键盘映射。
addActionListener(ActionListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ACTION事件。
addActionListener(ActionListener) - Method in class java.awt. Button
添加指定的动作侦听器以从此按钮接收动作事件。
addActionListener(ActionListener) - Method in class java.awt. List
添加指定的动作侦听器以从此列表接收动作事件。
addActionListener(ActionListener) - Method in class java.awt. MenuItem
添加指定的动作侦听器以从该菜单项接收动作事件。
addActionListener(ActionListener) - Method in class java.awt. TextField
添加指定的动作侦听器以从此文本字段接收动作事件。
addActionListener(ActionListener) - Method in class java.awt. TrayIcon
添加指定的动作侦听器以从此 TrayIcon接收 ActionEvent s。
addActionListener(ActionListener) - Method in class javax.swing. AbstractButton
添加一个 ActionListener到按钮。
addActionListener(ActionListener) - Method in interface javax.swing. ButtonModel
在模型中添加一个 ActionListener 。
addActionListener(ActionListener) - Method in interface javax.swing. ComboBoxEditor
添加一个ActionListener。
addActionListener(ActionListener) - Method in class javax.swing. DefaultButtonModel
在模型中添加一个 ActionListener 。
addActionListener(ActionListener) - Method in class javax.swing. JComboBox
添加 ActionListener 。
addActionListener(ActionListener) - Method in class javax.swing. JFileChooser
添加一个 ActionListener到文件选择器。
addActionListener(ActionListener) - Method in class javax.swing. JTextField
添加指定的动作侦听器以从此文本字段接收动作事件。
addActionListener(ActionListener) - Method in class javax.swing.plaf.basic. BasicComboBoxEditor
addActionListener(ActionListener) - Method in class javax.swing. Timer
添加一个动作侦听器到 Timer 。
addAdjustmentListener(AdjustmentListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ADJUSTMENT事件。
addAdjustmentListener(AdjustmentListener) - Method in interface java.awt. Adjustable
添加一个监听器，以便在可调整对象的值更改时接收调整事件。
addAdjustmentListener(AdjustmentListener) - Method in class java.awt. Scrollbar
添加指定的调整监听器以从此滚动条接收 AdjustmentEvent实例。
addAdjustmentListener(AdjustmentListener) - Method in class java.awt. ScrollPaneAdjustable
添加指定的调整监听器以接收来自此 ScrollPaneAdjustable调整事件。
addAdjustmentListener(AdjustmentListener) - Method in class javax.swing. JScrollBar
添加一个AdjustmentListener。
addAll(float...) - Method in interface javafx.collections. ObservableFloatArray
附加给这个数组的结尾的 elements 。
addAll(float[], int, int) - Method in interface javafx.collections. ObservableFloatArray
将给定数组的一部分附加到该数组的末尾。
addAll(int...) - Method in interface javafx.collections. ObservableIntegerArray
追加给这个数组的最后的 elements 。
addAll(int[], int, int) - Method in interface javafx.collections. ObservableIntegerArray
将给定数组的一部分附加到该数组的末尾。
addAll(int, Collection<?>) - Method in class javax.management. AttributeList
将指定集合中的所有元素插入到此列表中，从指定的位置开始。
addAll(int, Collection<?>) - Method in class javax.management.relation. RoleList
addAll(int, Collection<?>) - Method in class javax.management.relation. RoleUnresolvedList
addAll(int, Collection<? extends E>) - Method in class java.util. AbstractList
将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
addAll(int, Collection<? extends E>) - Method in class java.util. AbstractSequentialList
将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
addAll(int, Collection<? extends E>) - Method in class java.util. ArrayList
将指定集合中的所有元素插入到此列表中，从指定的位置开始。
addAll(int, Collection<? extends E>) - Method in class java.util.concurrent. CopyOnWriteArrayList
将指定集合中的所有元素插入到此列表中，从指定的位置开始。
addAll(int, Collection<? extends E>) - Method in class java.util. LinkedList
将指定集合中的所有元素插入到此列表中，从指定的位置开始。
addAll(int, Collection<? extends E>) - Method in interface java.util. List
将指定集合中的所有元素插入到此列表中的指定位置（可选操作）。
addAll(int, Collection<? extends E>) - Method in class java.util. Vector
将指定集合中的所有元素插入到此向量中的指定位置。
addAll(int, Collection<? extends E>) - Method in class javafx.beans.binding. ListExpression
addAll(int, Collection<? extends E>) - Method in class javafx.collections. ModifiableObservableListBase
addAll(int, List<Rdn>) - Method in class javax.naming.ldap. LdapName
在名称中的指定位置添加名称的RDN。
addAll(int, AttributeList) - Method in class javax.management. AttributeList
将指定的 AttributeList中的所有元素插入到此列表中，从指定位置开始，按照指定的 AttributeList的迭代器返回它们的顺序。
addAll(int, RoleList) - Method in class javax.management.relation. RoleList
从指定的位置开始，按照指定的RoleList的迭代器返回的顺序，将指定的RoleList中的所有元素插入到此列表中。
addAll(int, RoleUnresolvedList) - Method in class javax.management.relation. RoleUnresolvedList
将指定的RoleUnresolvedList中的所有元素从指定的位置开始，按照指定的RoleUnresolvedList的迭代器返回的顺序。
addAll(int, Name) - Method in class javax.naming. CompositeName
在组合名称中的指定位置添加复合名称的组件。
addAll(int, Name) - Method in class javax.naming. CompoundName
在此复合名称中的指定位置添加化合物名称的组成部分。
addAll(int, Name) - Method in class javax.naming.ldap. LdapName
在名称中的指定位置添加名称的组件。
addAll(int, Name) - Method in interface javax.naming. Name
在名称中的指定位置添加名称的组件。
addAll(E...) - Method in class javafx.beans.binding. ListExpression
addAll(E...) - Method in interface javafx.collections. ObservableList
用于var-arg添加元素的方便方法。
addAll(E...) - Method in class javafx.collections. ObservableListBase
addAll(Collection) - Method in class java.beans.beancontext. BeanContextSupport
将集合添加到子集（不支持）的集合实现必须在层次结构锁和“children”保护字段上同步
addAll(Collection<?>) - Method in class javax.management. AttributeList
按指定集合的Iterator返回的顺序将指定集合中的所有元素追加到此列表的末尾。
addAll(Collection<?>) - Method in class javax.management.relation. RoleList
addAll(Collection<?>) - Method in class javax.management.relation. RoleUnresolvedList
addAll(Collection<? extends E>) - Method in class java.util. AbstractCollection
将指定集合中的所有元素添加到此集合（可选操作）。
addAll(Collection<? extends E>) - Method in class java.util. AbstractQueue
将指定集合中的所有元素添加到此队列中。
addAll(Collection<? extends E>) - Method in class java.util. ArrayDeque
在指定集合的末尾添加指定集合中的所有元素，如同通过按照集合的迭代器返回的顺序调用每个 元素ArrayDeque.addLast(E) 。
addAll(Collection<? extends E>) - Method in class java.util. ArrayList
按指定集合的Iterator返回的顺序将指定集合中的所有元素追加到此列表的末尾。
addAll(Collection<? extends E>) - Method in interface java.util. Collection
将指定集合中的所有元素添加到此集合（可选操作）。
addAll(Collection<? extends E>) - Method in class java.util.concurrent. ConcurrentLinkedDeque
按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。
addAll(Collection<? extends E>) - Method in class java.util.concurrent. ConcurrentLinkedQueue
按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该队列的末尾。
addAll(Collection<? extends E>) - Method in class java.util.concurrent. CopyOnWriteArrayList
按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。
addAll(Collection<? extends E>) - Method in class java.util.concurrent. CopyOnWriteArraySet
将指定集合中的所有元素添加到此集合（如果它们尚未存在）。
addAll(Collection<? extends E>) - Method in class java.util.concurrent. LinkedBlockingDeque
按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到该deque的末尾。
addAll(Collection<? extends E>) - Method in interface java.util. Deque
在指定集合的末尾添加指定集合中的所有元素，如同通过按照集合的迭代器返回的顺序调用每个 元素Deque.addLast(E)一样 。
addAll(Collection<? extends E>) - Method in class java.util. LinkedList
按照指定集合的迭代器返回的顺序将指定集合中的所有元素追加到此列表的末尾。
addAll(Collection<? extends E>) - Method in interface java.util. List
按指定集合的迭代器（可选操作）返回的顺序将指定集合中的所有元素附加到此列表的末尾。
addAll(Collection<? extends E>) - Method in interface java.util. Set
将指定集合中的所有元素添加到此集合（如果尚未存在）（可选操作）。
addAll(Collection<? extends E>) - Method in class java.util. TreeSet
将指定集合中的所有元素添加到此集合中。
addAll(Collection<? extends E>) - Method in class java.util. Vector
将指定集合中的所有元素追加到该向量的末尾，按照它们由指定集合的迭代器返回的顺序。
addAll(Collection<? extends E>) - Method in class javafx.beans.binding. ListExpression
addAll(Collection<? extends E>) - Method in class javafx.beans.binding. SetExpression
addAll(Collection<? extends E>) - Method in class javafx.collections. ModifiableObservableListBase
addAll(Collection<? extends K>) - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView
将指定集合中的所有元素添加到此集合中，就像在每个 元素上调用 ConcurrentHashMap.KeySetView.add(K)一样 。
addAll(Collection<? super T>, T...) - Static method in class java.util. Collections
将所有指定的元素添加到指定的集合。
addAll(List<Rdn>) - Method in class javax.naming.ldap. LdapName
将名称的RDN添加到该名称的末尾。
addAll(ObservableFloatArray) - Method in interface javafx.collections. ObservableFloatArray
将给定的可观察数组的内容附加到此数组的末尾。
addAll(ObservableFloatArray, int, int) - Method in interface javafx.collections. ObservableFloatArray
将给定的可观察数组的一部分附加到该数组的末尾。
addAll(ObservableIntegerArray) - Method in interface javafx.collections. ObservableIntegerArray
将给定的可观察数组的内容附加到此数组的末尾。
addAll(ObservableIntegerArray, int, int) - Method in interface javafx.collections. ObservableIntegerArray
将给定的可观察数组的一部分附加到该数组的末尾。
addAll(AccessibleRelation[]) - Method in class javax.accessibility. AccessibleRelationSet
将所有关系添加到现有关系集中。
addAll(AccessibleState[]) - Method in class javax.accessibility. AccessibleStateSet
将所有状态添加到现有状态集。
addAll(AttributeList) - Method in class javax.management. AttributeList
将 AttributeList指定的所有元素追加到列表的末尾， AttributeList指定的 AttributeList的迭代器返回的 AttributeList 。
addAll(RoleList) - Method in class javax.management.relation. RoleList
将所指定的RoleList中的所有元素按指定的RoleList的迭代器返回的顺序附加到列表的末尾。
addAll(RoleUnresolvedList) - Method in class javax.management.relation. RoleUnresolvedList
按照指定的RoleUnresolvedList的迭代器返回的顺序，将指定的RoleUnresolvedList中的所有元素附加到列表的末尾。
addAll(Name) - Method in class javax.naming. CompositeName
将组合名称的组件按顺序添加到此组合名称的末尾。
addAll(Name) - Method in class javax.naming. CompoundName
将复合名称的组件按顺序添加到该化合物名称的末尾。
addAll(Name) - Method in class javax.naming.ldap. LdapName
将名称的组件按顺序添加到该名称的末尾。
addAll(Name) - Method in interface javax.naming. Name
将名称的组件按顺序添加到该名称的末尾。
addAll(AttributeSet) - Method in interface javax.print.attribute. AttributeSet
将指定集合中的所有元素添加到此属性。
addAll(AttributeSet) - Method in interface javax.print.attribute. DocAttributeSet
将指定集合中的所有元素添加到此属性。
addAll(AttributeSet) - Method in class javax.print.attribute. HashAttributeSet
将指定集合中的所有元素添加到此属性。
addAll(AttributeSet) - Method in interface javax.print.attribute. PrintJobAttributeSet
将指定集合中的所有元素添加到此属性。
addAll(AttributeSet) - Method in interface javax.print.attribute. PrintRequestAttributeSet
将指定集合中的所有元素添加到此属性。
addAll(AttributeSet) - Method in interface javax.print.attribute. PrintServiceAttributeSet
将指定集合中的所有元素添加到此属性。
addAllAbsent(Collection<? extends E>) - Method in class java.util.concurrent. CopyOnWriteArrayList
将指定集合中尚未包含在此列表中的所有元素按指定集合的迭代器返回的顺序附加到此列表的末尾。
addAllowedTagSet(TIFFTagSet) - Method in class javax.imageio.plugins.tiff. TIFFImageReadParam
将 TIFFTagSet对象添加到允许的标签集列表中。
addAllToPile() - Method in class javafx.scene.control.skin. VirtualFlow
此方法将从VirtualFlow中删除所有单元格，并将其删除，将其添加到“堆”（即，稍后可以使用单元格的位置）。
addAncestorListener(AncestorListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 ANCESTOR事件。
addAncestorListener(AncestorListener) - Method in class javax.swing. JComponent
注册 listener以便它或它的任何祖先移动或使其可见或不可见时将接收 AncestorEvents 。
addAndGet(int) - Method in class java.util.concurrent.atomic. AtomicInteger
将给定的值原子地添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
addAndGet(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的记忆效应。
addAndGet(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray
原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
addAndGet(long) - Method in class java.util.concurrent.atomic. AtomicLong
将给定的值原子地添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
addAndGet(T, int) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
addAndGet(T, long) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater
将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。
addAppEventListener(SystemEventListener) - Method in class java.awt. Desktop
添加SystemEventListener的子类型以侦听本机系统的通知。
addAttachmentPart(AttachmentPart) - Method in class javax.xml.soap. SOAPMessage
将给定的 AttachmentPart对象添加到此 SOAPMessage对象。
addAttribute(Object, Object) - Method in class javax.swing.text. AbstractDocument.AbstractElement
向元素添加一个属性。
addAttribute(Object, Object) - Method in interface javax.swing.text. MutableAttributeSet
创建与此类似的新属性集，除了它包含具有给定名称和值的属性。
addAttribute(Object, Object) - Method in class javax.swing.text. SimpleAttributeSet
向列表中添加一个属性。
addAttribute(Object, Object) - Method in class javax.swing.text. StyleContext.NamedStyle
添加一个属性。
addAttribute(String, String, int, boolean, int, int) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
将新属性添加到由值列表定义的先前定义的元素中。
addAttribute(String, String, int, boolean, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
将新属性添加到可以设置为任意值的先前定义的元素。
addAttribute(String, String, int, boolean, String, String, String, boolean, boolean) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
向先前定义的元素添加一个新属性，该元素将由一系列值定义。
addAttribute(String, String, int, boolean, String, List<String>) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
向先前定义的元素添加一个新属性，该元素将由一组枚举值定义。
addAttribute(String, String, String) - Method in class org.xml.sax.helpers. AttributeListImpl
已过时。
将属性添加到属性列表。
addAttribute(String, String, String, String, String) - Method in class org.xml.sax.ext. Attributes2Impl
将属性添加到列表的末尾，将其“指定”标志设置为true。
addAttribute(String, String, String, String, String) - Method in class org.xml.sax.helpers. AttributesImpl
将属性添加到列表的末尾。
addAttribute(AttributedCharacterIterator.Attribute, Object) - Method in class java.text. AttributedString
在整个字符串中添加一个属性。
addAttribute(AttributedCharacterIterator.Attribute, Object, int, int) - Method in class java.text. AttributedString
将一个属性添加到字符串的子范围。
addAttribute(AttributeSet, Object, Object) - Method in interface javax.swing.text. AbstractDocument.AttributeContext
向给定集添加属性，并返回新的代表集。
addAttribute(AttributeSet, Object, Object) - Method in class javax.swing.text.html. StyleSheet
向给定集添加属性，并返回新的代表集。
addAttribute(AttributeSet, Object, Object) - Method in class javax.swing.text. StyleContext
向给定集添加属性，并返回新的代表集。
addAttribute(QName, String) - Method in interface javax.xml.soap. SOAPElement
将具有指定名称和值的属性添加到此 SOAPElement对象。
addAttribute(Name, String) - Method in interface javax.xml.soap. SOAPElement
将具有指定名称和值的属性添加到此 SOAPElement对象。
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in interface javax.management.modelmbean. ModelMBeanNotificationBroadcaster
注册一个实现NotificationListener接口的对象作为监听器。
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in class javax.management.modelmbean. RequiredModelMBean
addAttributes(Map<? extends AttributedCharacterIterator.Attribute, ?>, int, int) - Method in class java.text. AttributedString
将一组属性添加到字符串的子范围。
addAttributes(AttributeSet) - Method in class javax.swing.text. AbstractDocument.AbstractElement
向元素添加一组属性。
addAttributes(AttributeSet) - Method in interface javax.swing.text. MutableAttributeSet
创建与此类似的新属性集，除了它包含给定的属性和值。
addAttributes(AttributeSet) - Method in class javax.swing.text. SimpleAttributeSet
向列表中添加一组属性。
addAttributes(AttributeSet) - Method in class javax.swing.text. StyleContext.NamedStyle
向元素添加一组属性。
addAttributes(AttributeSet, AttributeSet) - Method in interface javax.swing.text. AbstractDocument.AttributeContext
向元素添加一组属性。
addAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.html. StyleSheet
向元素添加一组属性。
addAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text. StyleContext
向元素添加一组属性。
addAuxiliaryLookAndFeel(LookAndFeel) - Static method in class javax.swing. UIManager
添加一个 LookAndFeel的辅助外观和感觉列表。
addAWTEventListener(AWTEventListener, long) - Method in class java.awt. Toolkit
添加一个AWTEventListener来接收系统范围内符合给定的 eventMask所有AWTEvent。
addBatch() - Method in interface java.sql. PreparedStatement
向这个 PreparedStatement对象的一批命令添加一组参数。
addBatch(String) - Method in interface java.sql. Statement
将给定的SQL命令添加到此 Statement对象的当前命令列表中。
addBeanContextMembershipListener(BeanContextMembershipListener) - Method in interface java.beans.beancontext. BeanContext
添加指定 BeanContextMembershipListener接收 BeanContextMembershipEvents从这个 BeanContext无论何时添加或删除孩子 Component （S）。
addBeanContextMembershipListener(BeanContextMembershipListener) - Method in class java.beans.beancontext. BeanContextSupport
添加一个BeanContextMembershipListener
addBeanContextServicesListener(BeanContextServicesListener) - Method in interface java.beans.beancontext. BeanContextServices
在此BeanContext中添加一个 BeanContextServicesListener
addBeanContextServicesListener(BeanContextServicesListener) - Method in class java.beans.beancontext. BeanContextServicesSupport
添加一个BeanContextServicesListener
addBody() - Method in interface javax.xml.soap. SOAPEnvelope
创建一个 SOAPBody对象，并将其设置为该 SOAPBody对象的 SOAPEnvelope对象。
addBodyElement(QName) - Method in interface javax.xml.soap. SOAPBody
使用指定的QName创建一个新的 SOAPBodyElement对象，并将其添加到此 SOAPBody对象。
addBodyElement(Name) - Method in interface javax.xml.soap. SOAPBody
创建一个具有指定名称的新的 SOAPBodyElement对象，并将其添加到此 SOAPBody对象。
addBooleanAttribute(String, String, boolean, boolean) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
向先前定义的元素添加一个新属性，该元素将由枚举值 TRUE和 FALSE ，数据类型为 DATATYPE_BOOLEAN 。
addButtonComponents(Container, Object[], int) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
创建适当的对象以表示 buttons每个对象，并将其添加到 container 。
addCaretListener(CaretListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 CARET事件。
addCaretListener(CaretListener) - Method in class javax.swing.text. JTextComponent
添加插入符号侦听器以通知插入符的任何更改。
addCellEditorListener(CellEditorListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 CELLEDITOR事件。
addCellEditorListener(CellEditorListener) - Method in class javax.swing. AbstractCellEditor
添加一个 CellEditorListener到监听器列表。
addCellEditorListener(CellEditorListener) - Method in interface javax.swing. CellEditor
将一个监听器添加到编辑器停止时通知的列表，或者取消编辑。
addCellEditorListener(CellEditorListener) - Method in class javax.swing.tree. DefaultTreeCellEditor
添加 CellEditorListener 。
addCertificate(Certificate) - Method in class java.security. Identity
已过时。
为此身份添加证书。
addCertPathChecker(PKIXCertPathChecker) - Method in class java.security.cert. PKIXParameters
在认证路径检查列表中添加一个 PKIXCertPathChecker 。
addCertStore(CertStore) - Method in class java.security.cert. PKIXParameters
在查找证书和CRL中使用的 CertStore列表末尾添加一个 CertStore 。
addChangeListener(ChangeListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 CHANGE事件。
addChangeListener(ChangeListener) - Method in class javax.swing. AbstractButton
添加一个 ChangeListener到按钮。
addChangeListener(ChangeListener) - Method in class javax.swing. AbstractSpinnerModel
添加一个ChangeListener到模型的监听器列表。
addChangeListener(ChangeListener) - Method in interface javax.swing. BoundedRangeModel
添加一个ChangeListener到模型的监听器列表。
addChangeListener(ChangeListener) - Method in interface javax.swing. ButtonModel
在模型中添加一个 ChangeListener 。
addChangeListener(ChangeListener) - Method in interface javax.swing.colorchooser. ColorSelectionModel
作为监听器添加 listener以更改模型。
addChangeListener(ChangeListener) - Method in class javax.swing.colorchooser. DefaultColorSelectionModel
在模型中添加一个 ChangeListener 。
addChangeListener(ChangeListener) - Method in class javax.swing. DefaultBoundedRangeModel
添加一个 ChangeListener 。
addChangeListener(ChangeListener) - Method in class javax.swing. DefaultButtonModel
添加一个 ChangeListener模型。
addChangeListener(ChangeListener) - Method in class javax.swing. DefaultSingleSelectionModel
添加一个 ChangeListener到按钮。
addChangeListener(ChangeListener) - Method in class javax.swing. JProgressBar
将指定的 ChangeListener添加到进度条。
addChangeListener(ChangeListener) - Method in class javax.swing. JSlider
向滑块添加一个ChangeListener。
addChangeListener(ChangeListener) - Method in class javax.swing. JSpinner
将侦听器添加到每次发生模型更改时通知的列表。
addChangeListener(ChangeListener) - Method in class javax.swing. JTabbedPane
在此 ChangeListener添加一个 ChangeListener 。
addChangeListener(ChangeListener) - Method in class javax.swing. JViewport
每次视图的大小，位置或视口的范围大小更改时，都会将 ChangeListener添加到列表中。
addChangeListener(ChangeListener) - Method in class javax.swing. MenuSelectionManager
添加一个ChangeListener到按钮。
addChangeListener(ChangeListener) - Method in interface javax.swing. SingleSelectionModel
将 侦听器添加为模型中的更改的侦听器。
addChangeListener(ChangeListener) - Method in interface javax.swing. SpinnerModel
添加一个 ChangeListener到模型的监听器列表。
addChangeListener(ChangeListener) - Method in interface javax.swing.text. Caret
添加一个侦听器，以便每当插入位置被更改时跟踪。
addChangeListener(ChangeListener) - Method in class javax.swing.text. DefaultCaret
添加一个侦听器，以便每当插入位置被更改时跟踪。
addChangeListener(ChangeListener) - Method in interface javax.swing.text. Style
添加一个监听器，以便在属性被更改时跟踪。
addChangeListener(ChangeListener) - Method in class javax.swing.text. StyleContext
添加一个侦听器来跟踪何时添加或删除样式。
addChangeListener(ChangeListener) - Method in class javax.swing.text. StyleContext.NamedStyle
添加更改侦听器。
addChildElement(String) - Method in interface javax.xml.soap. SOAPElement
创建使用指定的本地名称初始化的新的 SOAPElement对象，并将新元素添加到此 SOAPElement对象。
addChildElement(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
将一个现有元素添加到给定父节点类型的合法子节点列表中。
addChildElement(String, String) - Method in interface javax.xml.soap. SOAPElement
创建一个新的 SOAPElement对象，使用指定的本地名称和前缀进行初始化，并将新元素添加到此 SOAPElement对象。
addChildElement(String, String, String) - Method in interface javax.xml.soap. SOAPElement
创建使用指定的本地名称，前缀和URI初始化的新的 SOAPElement对象，并将新元素添加到此 SOAPElement对象。
addChildElement(QName) - Method in interface javax.xml.soap. SOAPElement
创建使用给定的 SOAPElement对象初始化的新的 QName对象，并将新元素添加到此 SOAPElement对象。
addChildElement(Name) - Method in interface javax.xml.soap. SOAPElement
创建使用给定的 SOAPElement对象初始化的新的 Name对象，并将新元素添加到此 SOAPElement对象。
addChildElement(SOAPElement) - Method in interface javax.xml.soap. SOAPElement
添加一个 SOAPElement作为这个 SOAPElement实例的孩子。
addChoosableFileFilter(FileFilter) - Method in class javax.swing. JFileChooser
将一个过滤器添加到用户可选择的文件过滤器列表中。
addChooserPanel(AbstractColorChooserPanel) - Method in class javax.swing. JColorChooser
在颜色选择器中添加一个颜色选择器面板。
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. ClassPrepareRequest
将此请求生成的事件限制为编写名称与此受限正则表达式 不匹配的引用类型。
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. ClassUnloadRequest
将此请求生成的事件限制为卸载其名称与受限正则表达式 不匹配的引用类型。
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. ExceptionRequest
限制通过该请求到那些位置是在类名 不匹配的受限的正则表达式生成的事件。
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. MethodEntryRequest
将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. MethodExitRequest
将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法。
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. MonitorContendedEnteredRequest
将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. MonitorContendedEnterRequest
将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. MonitorWaitedRequest
将由此请求生成的事件限制于监视对象的类名与此受限正则表达式 不匹配的事件，例如
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. MonitorWaitRequest
将由此请求生成的事件限制于监视对象的类名与此受限正则表达式 不匹配的事件，例如
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. StepRequest
限制通过该请求到那些位置是在类名 不匹配的受限的正则表达式生成的事件。
addClassExclusionFilter(String) - Method in interface com.sun.jdi.request. WatchpointRequest
将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的位置。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. ClassPrepareRequest
限制此请求生成的事件，作为给定引用类型和任何子类型的准备。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. ExceptionRequest
将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. MethodEntryRequest
将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. MethodExitRequest
将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. MonitorContendedEnteredRequest
将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. MonitorContendedEnterRequest
将此请求生成的事件限制在给定引用类型或其任何子类型的方法中。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. MonitorWaitedRequest
将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. MonitorWaitRequest
将此请求生成的事件限制在监视对象为给定引用类型或其任何子类型的对象。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. StepRequest
将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
addClassFilter(ReferenceType) - Method in interface com.sun.jdi.request. WatchpointRequest
将此请求生成的事件限制在位置在给定引用类型或其任何子类型中的那些事件。
addClassFilter(String) - Method in interface com.sun.jdi.request. ClassPrepareRequest
将此请求生成的事件限制为编写名称与此受限正则表达式匹配的引用类型。
addClassFilter(String) - Method in interface com.sun.jdi.request. ClassUnloadRequest
将此请求生成的事件限制为卸载其名称与受限正则表达式匹配的引用类型。
addClassFilter(String) - Method in interface com.sun.jdi.request. ExceptionRequest
将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。
addClassFilter(String) - Method in interface com.sun.jdi.request. MethodEntryRequest
将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。
addClassFilter(String) - Method in interface com.sun.jdi.request. MethodExitRequest
将此请求生成的事件限制在其名称与受限正则表达式匹配的类中的方法。
addClassFilter(String) - Method in interface com.sun.jdi.request. MonitorContendedEnteredRequest
将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。
addClassFilter(String) - Method in interface com.sun.jdi.request. MonitorContendedEnterRequest
将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。
addClassFilter(String) - Method in interface com.sun.jdi.request. MonitorWaitedRequest
将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。
addClassFilter(String) - Method in interface com.sun.jdi.request. MonitorWaitRequest
将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。
addClassFilter(String) - Method in interface com.sun.jdi.request. StepRequest
将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。
addClassFilter(String) - Method in interface com.sun.jdi.request. WatchpointRequest
将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。
addColumn(int, Node...) - Method in class javafx.scene.layout. GridPane
将指定节点顺序放置在网格的给定列中的便利方法。
addColumn(Object) - Method in class javax.swing.table. DefaultTableModel
向模型添加一列。
addColumn(Object, Object[]) - Method in class javax.swing.table. DefaultTableModel
向模型添加一列。
addColumn(Object, Vector<?>) - Method in class javax.swing.table. DefaultTableModel
向模型添加一列。
addColumn(TableColumn) - Method in class javax.swing. JTable
将 aColumn追加到 JTable的列模型所持有的列数组的末尾。
addColumn(TableColumn) - Method in class javax.swing.table. DefaultTableColumnModel
在 tableColumns数组的末尾追加 aColumn 。
addColumn(TableColumn) - Method in interface javax.swing.table. TableColumnModel
附加 aColumn到的末尾 tableColumns阵列。
addColumnModelListener(TableColumnModelListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有 COLUMNMODEL事件。
addColumnModelListener(TableColumnModelListener) - Method in class javax.swing.table. DefaultTableColumnModel
为表格列模型事件添加一个侦听器。
addColumnModelListener(TableColumnModelListener) - Method in interface javax.swing.table. TableColumnModel
为表格列模型事件添加一个侦听器。
addColumnSelectionInterval(int, int) - Method in class javax.swing. JTable
将列从 index0添加到 index1 ，包括当前选择。
addComponent(boolean, Component) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个 Component这个 Group 。
addComponent(boolean, Component, int, int, int) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个 Component到这个 Group与指定的大小。
addComponent(Component) - Method in class javax.swing. GroupLayout.Group
添加一个 Component这个 Group 。
addComponent(Component) - Method in class javax.swing. GroupLayout.ParallelGroup
添加一个 Component到这个 Group 。
addComponent(Component) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个 Component到这个 Group 。
addComponent(Component, int, int, int) - Method in class javax.swing. GroupLayout.Group
添加一个 Component到这个 Group与指定的大小。
addComponent(Component, int, int, int) - Method in class javax.swing. GroupLayout.ParallelGroup
添加一个 Component到这个 Group与指定的大小。
addComponent(Component, int, int, int) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个 Component到这个 Group与指定的大小。
addComponent(Component, GroupLayout.Alignment) - Method in class javax.swing. GroupLayout.ParallelGroup
添加一个 Component到这个 ParallelGroup与指定的对齐。
addComponent(Component, GroupLayout.Alignment, int, int, int) - Method in class javax.swing. GroupLayout.ParallelGroup
添加一个 Component到这个 ParallelGroup与指定的对齐和大小。
addComponentListener(ComponentListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 COMPONENT事件。
addComponentListener(ComponentListener) - Method in class java.awt. Component
添加指定的组件侦听器以从该组件接收组件事件。
addConfigurationListener(Runnable) - Method in class java.util.logging. LogManager
添加每次读取日志配置时调用的配置监听器。
addConnectionEventListener(ConnectionEventListener) - Method in interface javax.sql. PooledConnection
注册给定的事件侦听器，以便在 PooledConnection对象发生事件时通知它。
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.remote. JMXConnector
添加一个监听器以通知连接状态的变化。
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.remote.rmi. RMIConnector
addConsumer(ImageConsumer) - Method in class java.awt.image. FilteredImageSource
将指定的 ImageConsumer添加到对过滤图像的数据感兴趣的消费者列表中。
addConsumer(ImageConsumer) - Method in interface java.awt.image. ImageProducer
注册一个 ImageConsumer与 ImageProducer所述的稍后重建期间用于访问图像数据 Image 。
addConsumer(ImageConsumer) - Method in class java.awt.image. MemoryImageSource
将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
addConsumer(ImageConsumer) - Method in class java.awt.image.renderable. RenderableImageProducer
将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
addContainerGap() - Method in class javax.swing. GroupLayout.SequentialGroup
添加表示容器边缘与触摸容器边界的组件之间的优选间距的元素。
addContainerGap(int, int) - Method in class javax.swing. GroupLayout.SequentialGroup
添加表示容器的一个边缘与指定尺寸的下一个或前一个 Component之间的优选间隙的元素。
addContainerListener(ContainerListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 CONTAINER事件。
addContainerListener(ContainerListener) - Method in class java.awt. Container
添加指定的容器侦听器以从此容器接收容器事件。
addContent(char[], int, int) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
添加一些带有当前字符属性的文本。
addContent(char[], int, int, boolean) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
添加一些带有当前字符属性的文本。
addContextPropertyChangeListener(PropertyChangeListener) - Method in class com.sun.tools.jconsole. JConsolePlugin
为这个插件的JConsoleContext对象添加一个PropertyChangeListener 。
addControlButtons() - Method in class javax.swing.plaf.metal. MetalFileChooserUI
将控制按钮添加到底部面板。
addControllerEventListener(ControllerEventListener, int[]) - Method in interface javax.sound.midi. Sequencer
注册一个控制器事件侦听器，只要顺序程序处理所请求的类型或类型的控制更改事件，就会收到通知。
addCountFilter(int) - Method in interface com.sun.jdi.request. EventRequest
在给定数量的事件发生后，限制所要求的事件最多报告一次。
addCSSAttribute(MutableAttributeSet, CSS.Attribute, String) - Method in class javax.swing.text.html. StyleSheet
将CSS属性添加到给定的集合。
addCSSAttributeFromHTML(MutableAttributeSet, CSS.Attribute, String) - Method in class javax.swing.text.html. StyleSheet
将CSS属性添加到给定的集合。
addCustomEntriesToTable(UIDefaults) - Method in class javax.swing.plaf.metal. MetalTheme
将此主题特有的值添加到默认表。
addCustomEntriesToTable(UIDefaults) - Method in class javax.swing.plaf.metal. OceanTheme
将此主题的自定义条目添加到默认表。
addDetail() - Method in interface javax.xml.soap. SOAPFault
创建一个可选的 Detail对象，并将其设置为 Detail对象的 SOAPFault对象。
addDetailEntry(QName) - Method in interface javax.xml.soap. Detail
使用给定的QName创建一个新的 DetailEntry对象，并将其添加到此 Detail对象。
addDetailEntry(Name) - Method in interface javax.xml.soap. Detail
使用给定的名称创建一个新的 DetailEntry对象，并将其添加到此 Detail对象。
addDirtyRegion(Applet, int, int, int, int) - Method in class javax.swing. RepaintManager
已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
addDirtyRegion(Window, int, int, int, int) - Method in class javax.swing. RepaintManager
将 window添加到需要重新绘制的 Component的列表中。
addDirtyRegion(JComponent, int, int, int, int) - Method in class javax.swing. RepaintManager
在要刷新的组件列表中添加一个组件。
addDocument(Document) - Method in interface javax.xml.soap. SOAPBody
将DOM Document的根节点添加到此SOAPBody对象。
addDocumentListener(DocumentListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 DOCUMENT事件。
addDocumentListener(DocumentListener) - Method in class javax.swing.text. AbstractDocument
添加文档侦听器以通知任何更改。
addDocumentListener(DocumentListener) - Method in class javax.swing.text. DefaultStyledDocument
添加文档侦听器以通知任何更改。
addDocumentListener(DocumentListener) - Method in interface javax.swing.text. Document
注册给定的观察者，以便在对文档进行更改时开始接收通知。
addDragGestureListener(DragGestureListener) - Method in class java.awt.dnd. DragGestureRecognizer
注册新的 DragGestureListener 。
addDragSourceListener(DragSourceListener) - Method in class java.awt.dnd. DragSource
添加指定 DragSourceListener这个 DragSource期间与由此引发的拖动操作接收拖动源事件 DragSource 。
addDragSourceListener(DragSourceListener) - Method in class java.awt.dnd. DragSourceContext
添加 DragSourceListener这个 DragSourceContext如果一个尚未加入。
addDragSourceMotionListener(DragSourceMotionListener) - Method in class java.awt.dnd. DragSource
添加指定 DragSourceMotionListener这个 DragSource期间与由此引发的拖动操作接收的拖动移动事件 DragSource 。
addDropTargetListener(DropTargetListener) - Method in class java.awt.dnd. DropTarget
添加一个新的 DropTargetListener （UNICAST SOURCE）。
addEdit(UndoableEdit) - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent
添加文档编辑。
addEdit(UndoableEdit) - Method in class javax.swing.undo. AbstractUndoableEdit
此默认实现返回false。
addEdit(UndoableEdit) - Method in class javax.swing.undo. CompoundEdit
如果此编辑是 inProgress ，请接受 anEdit并返回true。
addEdit(UndoableEdit) - Method in interface javax.swing.undo. UndoableEdit
添加一个 UndoableEdit到这个 UndoableEdit 。
addEdit(UndoableEdit) - Method in class javax.swing.undo. UndoManager
添加一个 UndoableEdit到这个 UndoManager ，如果可能的话。
addEditor() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
这种公共方法是实现具体的，应该是私有的。
addElement(E) - Method in class java.util. Vector
将指定的组件添加到此向量的末尾，将其大小增加1。
addElement(E) - Method in class javax.swing. DefaultComboBoxModel
addElement(E) - Method in class javax.swing. DefaultListModel
将指定的组件添加到此列表的末尾。
addElement(E) - Method in interface javax.swing. MutableComboBoxModel
在模型的末尾添加一个项目。
addElement(String, String, int) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
使用非 CHILD_POLICY_REPEAT以外的子策略向此元数据文档格式添加新元素类型。
addElement(String, String, int, int) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
将新元素类型添加到此元数据文档格式，子策略为 CHILD_POLICY_REPEAT 。
addEntry(Principal, AclEntry) - Method in interface java.security.acl. Acl
已过时。
向此ACL添加ACL条目。
addEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Service
将事件过滤器注册到此任务。
addEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Task
将事件过滤器注册到此任务。
addEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Node
向此节点注册事件过滤器。
addEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Scene
注册一个事件过滤器到这个场景。
addEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene.transform. Transform
为此转换注册事件过滤器。
addEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.stage. Window
向此节点注册事件过滤器。
addEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. Menu
在此MenuItem中注册一个事件处理程序。
addEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. MenuItem
在此MenuItem中注册一个事件处理程序。
addEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. TableColumnBase
在此表列中注册一个事件处理程序。
addEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. TreeItem
将一个事件处理程序注册到此TreeItem。
addEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Service
注册一个事件处理程序到这个任务。
addEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Task
注册一个事件处理程序到这个任务。
addEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Node
向此节点注册事件处理程序。
addEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Scene
注册一个事件处理程序到这个场景。
addEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene.transform. Transform
注册一个事件处理程序到这个变换。
addEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.stage. Window
向此节点注册事件处理程序。
addEventListener(String, EventListener, boolean) - Method in interface org.w3c.dom.events. EventTarget
该方法允许在事件目标上注册事件侦听器。
addExact(int, int) - Static method in class java.lang. Math
返回其参数的总和，如果结果溢出 int ，则抛出异常。
addExact(int, int) - Static method in class java.lang. StrictMath
返回其参数的总和，如果结果溢出一个 int ，则抛出异常。
addExact(long, long) - Static method in class java.lang. Math
返回其参数的总和，如果结果溢出 long ，则抛出异常。
addExact(long, long) - Static method in class java.lang. StrictMath
返回其参数的总和，如果结果溢出一个 long ，则抛出异常。
addExports(Module, String, Module) - Method in class java.lang. ModuleLayer.Controller
更新模块 source在图层中导出一个包到模块 target 。
addExports(String, Module) - Method in class java.lang. Module
如果调用者的模块是此模块，则更新此模块以将给定的包导出到给定的模块。
addFault() - Method in interface javax.xml.soap. SOAPBody
创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。
addFault(QName, String) - Method in interface javax.xml.soap. SOAPBody
创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。
addFault(QName, String, Locale) - Method in interface javax.xml.soap. SOAPBody
创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。
addFault(Name, String) - Method in interface javax.xml.soap. SOAPBody
创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。
addFault(Name, String, Locale) - Method in interface javax.xml.soap. SOAPBody
创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。
addFaultReasonText(String, Locale) - Method in interface javax.xml.soap. SOAPFault
追加或替换包含指定短信的原因文本项目和从 locale派生的 xml：lang 。
addFirst(E) - Method in class java.util. ArrayDeque
在此deque前面插入指定的元素。
addFirst(E) - Method in interface java.util.concurrent. BlockingDeque
如果可以在不违反容量限制的情况下立即将其指定的元素插入到此deque的前面，如果当前没有可用空间，则抛出一个 IllegalStateException 。
addFirst(E) - Method in class java.util.concurrent. ConcurrentLinkedDeque
在此deque前面插入指定的元素。
addFirst(E) - Method in class java.util.concurrent. LinkedBlockingDeque
addFirst(E) - Method in interface java.util. Deque
如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的前面，如果当前没有可用空间，则抛出一个 IllegalStateException 。
addFirst(E) - Method in class java.util. LinkedList
在该列表开头插入指定的元素。
addFlavorForUnencodedNative(String, DataFlavor) - Method in class java.awt.datatransfer. SystemFlavorMap
添加一个从一个 String本机到一个 DataFlavor 。
addFlavorListener(FlavorListener) - Method in class java.awt.datatransfer. Clipboard
注册指定的 FlavorListener从此剪贴板接收 FlavorEvent s。
addFocusListener(FocusListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 FOCUS个事件。
addFocusListener(FocusListener) - Method in class com.sun.java.accessibility.util. Translator
添加指定的 FocusListener以从该组件接收焦点事件。
addFocusListener(FocusListener) - Method in class java.awt. Component.AccessibleAWTComponent
新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
addFocusListener(FocusListener) - Method in class java.awt. Component
当该组件获得输入焦点时，添加指定的焦点侦听器以从该组件接收焦点事件。
addFocusListener(FocusListener) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild
新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
addFocusListener(FocusListener) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent
新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
addFocusListener(FocusListener) - Method in interface javax.accessibility. AccessibleComponent
新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
addFocusListener(FocusListener) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild
addFocusListener(FocusListener) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell
addFocusListener(FocusListener) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
addFocusListener(FocusListener) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
addGap(int) - Method in class javax.swing. GroupLayout.Group
为这个 Group增加了一个刚性的差距。
addGap(int) - Method in class javax.swing. GroupLayout.ParallelGroup
给这个 Group增加了一个刚性的差距。
addGap(int) - Method in class javax.swing. GroupLayout.SequentialGroup
给这个 Group增加了一个刚性的差距。
addGap(int, int, int) - Method in class javax.swing. GroupLayout.Group
添加一个与此 Group指定大小的差距。
addGap(int, int, int) - Method in class javax.swing. GroupLayout.ParallelGroup
添加一个与此 Group指定大小的差距。
addGap(int, int, int) - Method in class javax.swing. GroupLayout.SequentialGroup
与此 Group添加一个与指定大小的差距。
addGroup(boolean, GroupLayout.Group) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个 Group到这个 Group 。
addGroup(GroupLayout.Alignment, GroupLayout.Group) - Method in class javax.swing. GroupLayout.ParallelGroup
添加一个 Group到这个 ParallelGroup与指定的对齐。
addGroup(GroupLayout.Group) - Method in class javax.swing. GroupLayout.Group
添加一个 Group到这个 Group 。
addGroup(GroupLayout.Group) - Method in class javax.swing. GroupLayout.ParallelGroup
添加一个 Group这个 Group 。
addGroup(GroupLayout.Group) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个 Group这个 Group 。
addGUIInitializedListener(GUIInitializedListener) - Static method in class com.sun.java.accessibility.util. EventQueueMonitor
添加指定的监听器，以在GUI子系统初始化时通知。
addHandler(Handler) - Method in class java.util.logging. Logger
添加日志处理程序以接收日志消息。
addHandshakeCompletedListener(HandshakeCompletedListener) - Method in class javax.net.ssl. SSLSocket
注册事件侦听器以接收SSL握手在此连接上已完成的通知。
addHeader() - Method in interface javax.xml.soap. SOAPEnvelope
创建一个 SOAPHeader对象，并将其设置为 SOAPHeader对象的 SOAPEnvelope对象。
addHeader(String, String) - Method in class javax.xml.soap. MimeHeaders
添加一个 MimeHeader具有指定名称和值的这个对象 MimeHeaders头的对象的列表。
addHeaderElement(QName) - Method in interface javax.xml.soap. SOAPHeader
创建一个新的 SOAPHeaderElement对象，使用指定的qname初始化并将其添加到此 SOAPHeader对象。
addHeaderElement(Name) - Method in interface javax.xml.soap. SOAPHeader
创建一个新的 SOAPHeaderElement对象，使用指定的名称初始化，并将其添加到此 SOAPHeader对象。
addHierarchyBoundsListener(HierarchyBoundsListener) - Method in class java.awt. Component
添加指定的层次结构边界侦听器以在此容器所属的层次结构更改时从此组件接收层次结构边界事件。
addHierarchyListener(HierarchyListener) - Method in class java.awt. Component
添加指定的层次监听器，以便在此容器所属的层次结构更改时从此组件接收层次结构更改的事件。
addHighlight(int, int, Highlighter.HighlightPainter) - Method in class javax.swing.text. DefaultHighlighter
在视图中添加高亮。
addHighlight(int, int, Highlighter.HighlightPainter) - Method in interface javax.swing.text. Highlighter
在视图中添加高亮。
addHighlight(List<? extends Node>, int) - Method in class javafx.scene.control.skin. TextAreaSkin
从输入法添加组合文本的高亮。
addHighlight(List<? extends Node>, int) - Method in class javafx.scene.control.skin. TextFieldSkin
从输入法添加组合文本的高亮。
addHighlight(List<? extends Node>, int) - Method in class javafx.scene.control.skin. TextInputControlSkin
从输入法添加组合文本的高亮。
addHyperlinkListener(HyperlinkListener) - Method in class javax.swing. JEditorPane
添加超链接侦听器以通知任何更改，例如选择并输入链接时。
addIcon(Container) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
创建并添加一个表示从 getIcon返回的图标到 top 。
addIdentity(Identity) - Method in class java.security. IdentityScope
已过时。
向此身份范围添加身份。
addIfAbsent(E) - Method in class java.util.concurrent. CopyOnWriteArrayList
附加元素，如果不存在。
addIIOReadProgressListener(IIOReadProgressListener) - Method in class javax.imageio. ImageReader
在注册进度监听器列表中添加一个 IIOReadProgressListener 。
addIIOReadUpdateListener(IIOReadUpdateListener) - Method in class javax.imageio. ImageReader
在注册的更新监听器列表中添加一个 IIOReadUpdateListener 。
addIIOReadWarningListener(IIOReadWarningListener) - Method in class javax.imageio. ImageReader
将 IIOReadWarningListener添加到已注册的警告监听器列表中。
addIIOWriteProgressListener(IIOWriteProgressListener) - Method in class javax.imageio. ImageWriter
在注册进度侦听器列表中添加一个 IIOWriteProgressListener 。
addIIOWriteWarningListener(IIOWriteWarningListener) - Method in class javax.imageio. ImageWriter
将 IIOWriteWarningListener添加到已注册的警告侦听器列表中。
addImage(Image, int) - Method in class java.awt. MediaTracker
将图像添加到此媒体跟踪器跟踪的图像列表中。
addImage(Image, int, int, int) - Method in class java.awt. MediaTracker
将缩放图像添加到此媒体跟踪器跟踪的图像列表中。
addImpl(Component, Object, int) - Method in class java.awt. Container
在指定的索引处将指定的组件添加到此容器。
addImpl(Component, Object, int) - Method in class java.awt. ScrollPane
将指定的组件添加到此滚动窗格容器。
addImpl(Component, Object, int) - Method in class javax.swing. AbstractButton
将指定的组件添加到指定索引的此容器中，有关此方法的完整说明，请参阅 Container.addImpl(Component, Object, int) 。
addImpl(Component, Object, int) - Method in class javax.swing. CellRendererPane
如果指定的组件已经是一个小孩，那么我们不用担心任何事情 - 堆栈顺序对于单元格渲染器组件并不重要（CellRendererPane不会绘制）。
addImpl(Component, Object, int) - Method in class javax.swing. JApplet
已过时。
添加指定的小孩 Component 。
addImpl(Component, Object, int) - Method in class javax.swing. JDesktopPane
在指定的索引处将指定的组件添加到此容器。
addImpl(Component, Object, int) - Method in class javax.swing. JDialog
添加指定的小孩 Component 。
addImpl(Component, Object, int) - Method in class javax.swing. JFrame
添加指定的小孩 Component 。
addImpl(Component, Object, int) - Method in class javax.swing. JInternalFrame
添加指定的小孩 Component 。
addImpl(Component, Object, int) - Method in class javax.swing. JLayer
JLayer不支持此方法，并始终抛出 UnsupportedOperationException
addImpl(Component, Object, int) - Method in class javax.swing. JLayeredPane
addImpl(Component, Object, int) - Method in class javax.swing. JRootPane
覆盖以执行玻璃部件的位置作为零子。
addImpl(Component, Object, int) - Method in class javax.swing. JSplitPane
将指定的组件添加到此拆分窗格。
addImpl(Component, Object, int) - Method in class javax.swing. JToolBar
如果添加了一个 JButton ，它最初被设置为禁用。
addImpl(Component, Object, int) - Method in class javax.swing. JViewport
设置 JViewport的一个轻量级的孩子，可以是 null 。
addImpl(Component, Object, int) - Method in class javax.swing. JWindow
添加指定的小孩 Component 。
addInputMethodListener(InputMethodListener) - Method in class java.awt. Component
添加指定的输入法侦听器以从该组件接收输入法事件。
addInputMethodListener(InputMethodListener) - Method in class javax.swing.text. JTextComponent
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. BreakpointRequest
将由此请求生成的事件限制为当前正在执行的实例是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. ExceptionRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. MethodEntryRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. MethodExitRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. MonitorContendedEnteredRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. MonitorContendedEnterRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. MonitorWaitedRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. MonitorWaitRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. StepRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInstanceFilter(ObjectReference) - Method in interface com.sun.jdi.request. WatchpointRequest
将由此请求生成的事件限制为当前正在执行的实例（“this”）是指定对象的事件。
addInternal(EventListener, EventListener) - Static method in class java.awt. AWTEventMulticaster
通过将listener-a和listener-b添加到一起返回生成的多播监听器。
addInternalFrameListener(InternalFrameListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 INTERNALFRAME事件。
addInternalFrameListener(InternalFrameListener) - Method in class javax.swing. JInternalFrame
添加指定的侦听器以从该内部帧接收内部帧事件。
addInvalidComponent(JComponent) - Method in class javax.swing. RepaintManager
将组件标记为需要布局，并为事件分派线程队列运行，该线程将首先验证组件isValidateRoot（）祖先。
addIssuer(X500Principal) - Method in class java.security.cert. X509CRLSelector
向issuerNames条件添加一个名称。
addIssuerName(byte[]) - Method in class java.security.cert. X509CRLSelector
向issuerNames条件添加一个名称。
addIssuerName(String) - Method in class java.security.cert. X509CRLSelector
诋毁 ，使用 X509CRLSelector.addIssuer(X500Principal)或者 X509CRLSelector.addIssuerName(byte[])代替。
addItem(E) - Method in class javax.swing. JComboBox
将项目添加到项目列表。
addItem(String) - Method in class java.awt. Choice
作为Java 2平台v1.1的过时。
addItem(String) - Method in class java.awt. List
已过时。
替换为add(String) 。
addItem(String, int) - Method in class java.awt. List
已过时。
替换为add(String, int) 。
addItemListener(ItemListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ITEM事件。
addItemListener(ItemListener) - Method in class java.awt. Checkbox
添加指定的项目侦听器以从此复选框接收项目事件。
addItemListener(ItemListener) - Method in class java.awt. CheckboxMenuItem
添加指定的项目侦听器以从此复选框菜单项接收项目事件。
addItemListener(ItemListener) - Method in class java.awt. Choice
添加指定的项目监听器以从此 Choice菜单接收项目事件。
addItemListener(ItemListener) - Method in interface java.awt. ItemSelectable
当用户更改项目的状态时，添加监听器以接收项目事件。
addItemListener(ItemListener) - Method in class java.awt. List
添加指定的项目侦听器以从该列表接收项目事件。
addItemListener(ItemListener) - Method in class javax.swing. AbstractButton
添加 ItemListener到 checkbox 。
addItemListener(ItemListener) - Method in interface javax.swing. ButtonModel
在模型中添加一个 ItemListener 。
addItemListener(ItemListener) - Method in class javax.swing. DefaultButtonModel
在模型中添加一个 ItemListener 。
addItemListener(ItemListener) - Method in class javax.swing. JComboBox
添加一个 ItemListener 。
ADDITION - Static variable in interface org.w3c.dom.events. MutationEvent
Attr刚刚添加。
AdditionalComments - Static variable in class javax.swing.text.html. HTMLDocument
文档属性键值。
addKeyEventDispatcher(KeyEventDispatcher) - Method in class java.awt. KeyboardFocusManager
将KeyEventDispatcher添加到此KeyboardFocusManager的调度程序链中。
addKeyEventPostProcessor(KeyEventPostProcessor) - Method in class java.awt. KeyboardFocusManager
将KeyEventPostProcessor添加到此KeyboardFocusManager的后处理器链。
addKeyListener(KeyListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器，以便在Java虚拟机发生时的每个组件实例上接收所有 KEY个事件。
addKeyListener(KeyListener) - Method in class java.awt. Component
添加指定的密钥侦听器以从该组件接收密钥事件。
addKeymap(String, Keymap) - Static method in class javax.swing.text. JTextComponent
在键盘层次结构中添加一个新的键盘映射。
addLast(E) - Method in class java.util. ArrayDeque
在此deque的末尾插入指定的元素。
addLast(E) - Method in interface java.util.concurrent. BlockingDeque
如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，则抛出一个 IllegalStateException如果当前没有空格）。
addLast(E) - Method in class java.util.concurrent. ConcurrentLinkedDeque
在此deque的末尾插入指定的元素。
addLast(E) - Method in class java.util.concurrent. LinkedBlockingDeque
addLast(E) - Method in interface java.util. Deque
如果可以立即在不违反容量限制的情况下将指定的元素插入到此deque的末尾，如果当前没有可用的空间，则抛出一个 IllegalStateException 。
addLast(E) - Method in class java.util. LinkedList
将指定的元素追加到此列表的末尾。
addLayoutComponent(Component, Object) - Method in class java.awt. BorderLayout
使用指定的约束对象将指定的组件添加到布局。
addLayoutComponent(Component, Object) - Method in class java.awt. CardLayout
将指定的组件添加到此卡布局的内部名称表中。
addLayoutComponent(Component, Object) - Method in class java.awt. GridBagLayout
使用指定的 constraints对象将指定的组件添加到布局。
addLayoutComponent(Component, Object) - Method in interface java.awt. LayoutManager2
使用指定的约束对象将指定的组件添加到布局。
addLayoutComponent(Component, Object) - Method in class javax.swing. BoxLayout
本课不使用
addLayoutComponent(Component, Object) - Method in class javax.swing. GroupLayout
通知已将 Component添加到父容器。
addLayoutComponent(Component, Object) - Method in class javax.swing. JRootPane.RootLayout
addLayoutComponent(Component, Object) - Method in class javax.swing. OverlayLayout
使用指定的约束对象将指定的组件添加到布局。
addLayoutComponent(Component, Object) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
使用指定的约束对象将指定的组件添加到布局。
addLayoutComponent(Component, Object) - Method in class javax.swing. SpringLayout
如果 constraints是 constraints的实例， SpringLayout.Constraints约束与指定的组件关联。
addLayoutComponent(String, Component) - Method in class java.awt. BorderLayout
已过时。
替换为addLayoutComponent(Component, Object) 。
addLayoutComponent(String, Component) - Method in class java.awt. CardLayout
已过时。
替换为addLayoutComponent(Component, Object) 。
addLayoutComponent(String, Component) - Method in class java.awt. FlowLayout
将指定的组件添加到布局。
addLayoutComponent(String, Component) - Method in class java.awt. GridBagLayout
没有效果，因为此布局管理器不使用每个组件字符串。
addLayoutComponent(String, Component) - Method in class java.awt. GridLayout
将具有指定名称的指定组件添加到布局。
addLayoutComponent(String, Component) - Method in interface java.awt. LayoutManager
如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与由 name指定的字符串相关联。
addLayoutComponent(String, Component) - Method in class javax.swing. BoxLayout
本课不使用
addLayoutComponent(String, Component) - Method in class javax.swing. GroupLayout
通知已将 Component添加到父容器。
addLayoutComponent(String, Component) - Method in class javax.swing. JRootPane.RootLayout
addLayoutComponent(String, Component) - Method in class javax.swing. JSpinner.DefaultEditor
这个 LayoutManager方法什么都不做。
addLayoutComponent(String, Component) - Method in class javax.swing. OverlayLayout
将指定的组件添加到布局。
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ComboBoxLayoutManager
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.TitlePaneLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFrameLayout
如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与 name指定的字符串相关联。
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DividerLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
将组件添加到位置。
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
addLayoutComponent(String, Component) - Method in class javax.swing. ScrollPaneLayout
将指定的组件添加到布局。
addLayoutComponent(String, Component) - Method in class javax.swing. SpringLayout
没有效果，因为此布局管理器不使用每个组件字符串。
addLayoutComponent(String, Component) - Method in class javax.swing. ViewportLayout
将指定的组件添加到布局。
addLineListener(LineListener) - Method in interface javax.sound.sampled. Line
在此行添加一个侦听器。
addListDataListener(ListDataListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 LISTDATA事件。
addListDataListener(ListDataListener) - Method in class javax.swing. AbstractListModel
将一个监听器添加到每次发生数据模型更改时通知的列表。
addListDataListener(ListDataListener) - Method in interface javax.swing. ListModel
将一个监听器添加到每次发生数据模型更改时通知的列表。
addListener(InvalidationListener) - Method in class javafx.beans.binding. BooleanBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. DoubleBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. FloatBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. IntegerBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. ListBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. LongBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. MapBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. ObjectBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. SetBinding
addListener(InvalidationListener) - Method in class javafx.beans.binding. StringBinding
addListener(InvalidationListener) - Method in interface javafx.beans. Observable
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
添加一个InvalidationListener ，当Observable变得无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.beans.property. BooleanPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. DoublePropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. FloatPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. IntegerPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ListPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. LongPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. MapPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ObjectPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyBooleanPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyDoublePropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyFloatPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyIntegerPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyListPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyLongPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyObjectPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlySetPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyStringPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. SetPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.property. StringPropertyBase
addListener(InvalidationListener) - Method in class javafx.beans.value. ObservableValueBase
添加一个InvalidationListener ，当Observable无效时，它将被通知。
addListener(InvalidationListener) - Method in class javafx.collections. ObservableArrayBase
addListener(InvalidationListener) - Method in class javafx.collections. ObservableListBase
addListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.binding. BooleanBinding
addListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
addListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.property. BooleanPropertyBase
addListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.property. ReadOnlyBooleanPropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. DoubleBinding
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. FloatBinding
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. IntegerBinding
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. LongBinding
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. DoublePropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. FloatPropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. IntegerPropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. LongPropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyDoublePropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyFloatPropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyIntegerPropertyBase
addListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyLongPropertyBase
addListener(ChangeListener<? super String>) - Method in class javafx.beans.binding. StringBinding
addListener(ChangeListener<? super String>) - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
addListener(ChangeListener<? super String>) - Method in class javafx.beans.property. ReadOnlyStringPropertyBase
addListener(ChangeListener<? super String>) - Method in class javafx.beans.property. StringPropertyBase
addListener(ChangeListener<? super ObservableList<E>>) - Method in class javafx.beans.binding. ListBinding
addListener(ChangeListener<? super ObservableList<E>>) - Method in class javafx.beans.property. ListPropertyBase
addListener(ChangeListener<? super ObservableList<E>>) - Method in class javafx.beans.property. ReadOnlyListPropertyBase
addListener(ChangeListener<? super ObservableMap<K, V>>) - Method in class javafx.beans.binding. MapBinding
addListener(ChangeListener<? super ObservableMap<K, V>>) - Method in class javafx.beans.property. MapPropertyBase
addListener(ChangeListener<? super ObservableMap<K, V>>) - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
addListener(ChangeListener<? super ObservableSet<E>>) - Method in class javafx.beans.binding. SetBinding
addListener(ChangeListener<? super ObservableSet<E>>) - Method in class javafx.beans.property. ReadOnlySetPropertyBase
addListener(ChangeListener<? super ObservableSet<E>>) - Method in class javafx.beans.property. SetPropertyBase
addListener(ChangeListener<? super T>) - Method in class javafx.beans.binding. ObjectBinding
addListener(ChangeListener<? super T>) - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
addListener(ChangeListener<? super T>) - Method in class javafx.beans.property. ObjectPropertyBase
addListener(ChangeListener<? super T>) - Method in class javafx.beans.property. ReadOnlyObjectPropertyBase
addListener(ChangeListener<? super T>) - Method in interface javafx.beans.value. ObservableValue
添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
addListener(ChangeListener<? super T>) - Method in class javafx.beans.value. ObservableValueBase
添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
addListener(ArrayChangeListener<T>) - Method in interface javafx.collections. ObservableArray
添加一个监听器到这个可观察的数组。
addListener(ArrayChangeListener<T>) - Method in class javafx.collections. ObservableArrayBase
addListener(ListChangeListener<? super E>) - Method in class javafx.beans.binding. ListBinding
addListener(ListChangeListener<? super E>) - Method in class javafx.beans.property. ListPropertyBase
addListener(ListChangeListener<? super E>) - Method in class javafx.beans.property. ReadOnlyListPropertyBase
addListener(ListChangeListener<? super E>) - Method in interface javafx.collections. ObservableList
将侦听器添加到此可观察列表中。
addListener(ListChangeListener<? super E>) - Method in class javafx.collections. ObservableListBase
addListener(MapChangeListener<? super K, ? super V>) - Method in class javafx.beans.binding. MapBinding
addListener(MapChangeListener<? super K, ? super V>) - Method in class javafx.beans.property. MapPropertyBase
addListener(MapChangeListener<? super K, ? super V>) - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
addListener(MapChangeListener<? super K, ? super V>) - Method in interface javafx.collections. ObservableMap
添加一个监听器到这个可观察的地图。
addListener(SetChangeListener<? super E>) - Method in class javafx.beans.binding. SetBinding
addListener(SetChangeListener<? super E>) - Method in class javafx.beans.property. ReadOnlySetPropertyBase
addListener(SetChangeListener<? super E>) - Method in class javafx.beans.property. SetPropertyBase
addListener(SetChangeListener<? super E>) - Method in interface javafx.collections. ObservableSet
添加一个监听器到这个可观察的集合。
addListSelectionListener(ListSelectionListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 LISTSELECTION事件。
addListSelectionListener(ListSelectionListener) - Method in class javax.swing. DefaultListSelectionModel
将侦听器添加到每次发生更改选择时通知的列表。
addListSelectionListener(ListSelectionListener) - Method in class javax.swing. JList
将一个监听器添加到列表中，每次发生更改时都会被通知; 倾听选择状态变化的首选方式。
addListSelectionListener(ListSelectionListener) - Method in interface javax.swing. ListSelectionModel
将侦听器添加到每次发生更改选择时通知的列表。
addLogger(Logger) - Method in class java.util.logging. LogManager
添加一个命名记录器。
addMailcap(String) - Method in class javax.activation. MailcapCommandMap
将条目添加到注册表。
addMember(Principal) - Method in interface java.security.acl. Group
已过时。
将指定的成员添加到组中。
addMenuDragMouseListener(MenuDragMouseListener) - Method in class javax.swing. JMenuItem
在菜单项中添加一个 MenuDragMouseListener 。
addMenuKeyListener(MenuKeyListener) - Method in class javax.swing. JMenuItem
在菜单项中添加一个 MenuKeyListener 。
addMenuKeyListener(MenuKeyListener) - Method in class javax.swing. JPopupMenu
在弹出菜单中添加一个 MenuKeyListener 。
addMenuListener(MenuListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 MENU事件。
addMenuListener(MenuListener) - Method in class javax.swing. JMenu
为菜单事件添加一个侦听器。
addMessageComponents(Container, GridBagConstraints, Object, int, boolean) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
创建适当的对象来表示 msg并将其放入 container 。
addMetaEventListener(MetaEventListener) - Method in interface javax.sound.midi. Sequencer
注册元事件监听器，以便在序列中遇到元事件并由序列器处理时接收通知。
addMimeHeader(String, String) - Method in class javax.xml.soap. AttachmentPart
将具有指定名称和值的MIME标头添加到此 AttachmentPart对象。
addMimeHeader(String, String) - Method in class javax.xml.soap. SOAPPart
创建 MimeHeader具有指定名称和值对象，并将其添加到这个 SOAPPart对象。
addMimeTypes(String) - Method in class javax.activation. MimetypesFileTypeMap
将MIME类型值添加到注册表。
addMnemonic(Mnemonic) - Method in class javafx.scene. Scene
注册指定的助记符。
addModules(Iterable<String>) - Method in interface javax.tools. DocumentationTool.DocumentationTask
在模块解析期间添加要考虑的根模块。
addModules(Iterable<String>) - Method in interface javax.tools. JavaCompiler.CompilationTask
在模块解析期间添加要考虑的根模块。
addMouseListener(MouseListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 MOUSE事件。
addMouseListener(MouseListener) - Method in class java.awt. Component
添加指定的鼠标监听器以从该组件接收鼠标事件。
addMouseListener(MouseListener) - Method in class java.awt. TrayIcon
添加指定的鼠标监听器以从该 TrayIcon接收鼠标事件。
addMouseMotionListener(MouseMotionListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有鼠标 MOTION事件。
addMouseMotionListener(MouseMotionListener) - Method in class java.awt. Component
添加指定的鼠标移动侦听器以从该组件接收鼠标移动事件。
addMouseMotionListener(MouseMotionListener) - Method in class java.awt. TrayIcon
添加指定的鼠标监听器以从此 TrayIcon接收鼠标移动事件。
addMouseWheelListener(MouseWheelListener) - Method in class java.awt. Component
添加指定的鼠标滚轮侦听器以从该组件接收鼠标滚轮事件。
addMtomAttachment(byte[], int, int, String, String, String) - Method in class javax.xml.bind.attachment. AttachmentMarshaller
考虑二进制 data作为附件的优化二进制存储。
addMtomAttachment(DataHandler, String, String) - Method in class javax.xml.bind.attachment. AttachmentMarshaller
考虑MIME内容 data作为附件的优化二进制存储。
addNamespaceDeclaration(String, String) - Method in interface javax.xml.soap. SOAPElement
向此 SOAPElement对象添加具有指定前缀和URI的命名空间声明。
addNamingListener(String, int, NamingListener) - Method in interface javax.naming.event. EventContext
添加一个侦听器，用于接收由字符串目标名称和范围指定的对象更改时触发的命名事件。
addNamingListener(String, String, Object[], SearchControls, NamingListener) - Method in interface javax.naming.event. EventDirContext
添加一个侦听器，用于接收由搜索过滤器标识的对象 filter和由字符串目标名称命名的对象的过滤器参数被触发的命名事件。
addNamingListener(String, String, SearchControls, NamingListener) - Method in interface javax.naming.event. EventDirContext
添加一个侦听器，用于接收在由字符串目标名称命名的对象由搜索过滤器 filter标识的对象时触发的命名事件。
addNamingListener(Name, int, NamingListener) - Method in interface javax.naming.event. EventContext
添加一个侦听器，用于接收由目标和范围标识的对象更改时触发的命名事件。
addNamingListener(Name, String, Object[], SearchControls, NamingListener) - Method in interface javax.naming.event. EventDirContext
添加一个侦听器，用于接收由搜索过滤器标识的对象 filter和目标命名的对象的过滤器参数被触发的命名事件。
addNamingListener(Name, String, SearchControls, NamingListener) - Method in interface javax.naming.event. EventDirContext
添加一个侦听器，用于接收由目标命名的对象由搜索过滤器 filter标识的对象时触发的命名事件。
addNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs. AbstractPreferences
addNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs. Preferences
注册指定的侦听器以接收该节点的 节点更改事件 。
addNotification(String, String, Object, Date) - Method in class javax.management.timer. Timer
创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
addNotification(String, String, Object, Date) - Method in interface javax.management.timer. TimerMBean
创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
addNotification(String, String, Object, Date, long) - Method in class javax.management.timer. Timer
创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
addNotification(String, String, Object, Date, long) - Method in interface javax.management.timer. TimerMBean
创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
addNotification(String, String, Object, Date, long, long) - Method in class javax.management.timer. Timer
创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
addNotification(String, String, Object, Date, long, long) - Method in interface javax.management.timer. TimerMBean
创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
addNotification(String, String, Object, Date, long, long, boolean) - Method in class javax.management.timer. Timer
创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
addNotification(String, String, Object, Date, long, long, boolean) - Method in interface javax.management.timer. TimerMBean
创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management. MBeanServerDelegate
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.modelmbean. RequiredModelMBean
注册一个实现NotificationListener接口的对象作为监听器。
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management. NotificationBroadcaster
添加一个监听器到这个MBean。
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management. NotificationBroadcasterSupport
添加一个监听器。
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management. StandardEmitterMBean
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management. MBeanServer
将一个监听器添加到注册的MBean。
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management. MBeanServerConnection
将一个监听器添加到注册的MBean。
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi. RMIConnection
处理方法 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 。
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management. MBeanServer
将一个监听器添加到注册的MBean。
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management. MBeanServerConnection
将一个监听器添加到注册的MBean。
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in interface javax.management.remote.rmi. RMIConnection
处理方法 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 。
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in class javax.management.remote.rmi. RMIConnectionImpl
addNotify() - Method in class java.awt. Button
创建按钮的对等体。
addNotify() - Method in class java.awt. Canvas
创建画布的对等体。
addNotify() - Method in class java.awt. Checkbox
创建复选框的对等体。
addNotify() - Method in class java.awt. CheckboxMenuItem
创建复选框项目的对等体。
addNotify() - Method in class java.awt. Choice
创造 Choice的同行。
addNotify() - Method in class java.awt. Component
将此 Component连接到本机屏幕资源可显示。
addNotify() - Method in class java.awt. Container
通过将此容器连接到本机屏幕资源来使此容器显示。
addNotify() - Method in class java.awt. Dialog
将此对话框通过将其连接到本机屏幕资源来显示。
addNotify() - Method in class java.awt.dnd. DropTarget
通知与组件关联的DropTarget此方法通常从与此DropTarget关联的组件的java.awt.Component.addNotify（）中调用，以通知DropTarget ComponentPeer已与该组件相关联。
addNotify() - Method in class java.awt. FileDialog
创建文件对话框的对等体。
addNotify() - Method in class java.awt. Frame
通过将此框架连接到本机屏幕资源来使此框架可以显示。
addNotify() - Method in class java.awt. Label
创建此标签的对等体。
addNotify() - Method in class java.awt. List
创建列表的对等体。
addNotify() - Method in class java.awt. Menu
创建菜单的对等体。
addNotify() - Method in class java.awt. MenuBar
创建菜单栏的对等体。
addNotify() - Method in class java.awt. MenuItem
创建菜单项的对等体。
addNotify() - Method in class java.awt. Panel
创建小组的同行。
addNotify() - Method in class java.awt. PopupMenu
创建弹出菜单的对等体。
addNotify() - Method in class java.awt. Scrollbar
创建 Scrollbar的同行。
addNotify() - Method in class java.awt. ScrollPane
创建滚动窗格的对等体。
addNotify() - Method in class java.awt. TextArea
创建 TextArea的同伴。
addNotify() - Method in class java.awt. TextComponent
通过将此组件连接到本机屏幕资源来使此组件可以显示。
addNotify() - Method in class java.awt. TextField
创建TextField的对等体。
addNotify() - Method in class java.awt. Window
通过创建与其本机屏幕资源的连接，使此窗口可显示。
addNotify() - Method in class javafx.embed.swing. JFXPanel
通知此组件它现在有一个父组件。
addNotify() - Method in class javax.swing. JComponent
通知此组件它现在有一个父组件。
addNotify() - Method in class javax.swing. JLayer
通知此组件它现在有一个父组件。
addNotify() - Method in class javax.swing. JMenuBar
覆盖 JComponent.addNotify以使用当前的键盘管理器注册该菜单栏。
addNotify() - Method in class javax.swing. JRootPane
通知此组件它现在有一个父组件。
addNotify() - Method in class javax.swing. JTable
调用 configureEnclosingScrollPane方法。
addNotify() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
addNotUnderstoodHeaderElement(QName) - Method in interface javax.xml.soap. SOAPHeader
创建一个新的NotUnderstood SOAPHeaderElement对象，并使用指定的名称进行初始化，并将其添加到此 SOAPHeader对象。
addObjectValue(String, Class<?>, int, int) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
允许给定类类型的 Object引用存储在实现命名元素的节点中。
addObjectValue(String, Class<T>, boolean, T) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
允许给定类类型的 Object引用存储在实现命名元素的节点中。
addObjectValue(String, Class<T>, boolean, T, List<? extends T>) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
允许给定类类型的 Object引用存储在实现命名元素的节点中。
addObjectValue(String, Class<T>, T, Comparable<? super T>, Comparable<? super T>, boolean, boolean) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
允许 Object定类类型的 Object引用存储在实现命名元素的节点中。
addObservedObject(ObjectName) - Method in class javax.management.monitor. Monitor
如果该对象不存在，则将指定的对象添加到观察到的MBean集合中。
addObservedObject(ObjectName) - Method in interface javax.management.monitor. MonitorMBean
将指定的对象添加到观察到的MBean集合中。
addObserver(Observer) - Method in class java.util. Observable
已过时。
将一个观察者添加到该对象的观察者组中，前提是它与集合中已有的一些观察者不一样。
addOpens(Module, String, Module) - Method in class java.lang. ModuleLayer.Controller
更新模块 source在图层中打开一个包到模块 target 。
addOpens(String, Module) - Method in class java.lang. Module
如果该模块已经至少 打开了一个包到调用者模块，然后更新该模块以将包打开到给定的模块。
addOwner(Principal, Principal) - Method in interface java.security.acl. Owner
已过时。
添加所有者。
addPathToName(int, byte[]) - Method in class java.security.cert. X509CertSelector
在pathToNames条件中添加一个名称。
addPathToName(int, String) - Method in class java.security.cert. X509CertSelector
在pathToNames条件中添加一个名称。
addPermission(Permission) - Method in interface java.security.acl. AclEntry
已过时。
将指定的权限添加到此ACL条目。
addPoint(int, int) - Method in class java.awt. Polygon
将指定的坐标附加到此 Polygon 。
addPopupMenuListener(PopupMenuListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有 POPUPMENU事件。
addPopupMenuListener(PopupMenuListener) - Method in class javax.swing. JComboBox
添加一个 PopupMenu监听器，它将从组合框的弹出窗口中收听通知消息。
addPopupMenuListener(PopupMenuListener) - Method in class javax.swing. JPopupMenu
添加一个 PopupMenu监听器。
addPort(QName, String, String) - Method in class javax.xml.ws. Service
为服务创建一个新的端口。
addPort(QName, String, String) - Method in class javax.xml.ws.spi. ServiceDelegate
为服务创建一个新的端口。
addPostLayoutPulseListener(Runnable) - Method in class javafx.scene. Scene
在这个场景中添加一个新的场景布局脉冲侦听器。
addPreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs. AbstractPreferences
addPreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs. Preferences
注册指定的侦听器以接收此首选项节点的 优先级更改事件 。
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement) - Method in class javax.swing. GroupLayout.SequentialGroup
添加表示两个组件之间的优选间隙的元素。
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, int) - Method in class javax.swing. GroupLayout.SequentialGroup
添加表示两个组件之间的优选间隙的元素。
addPreferredGap(LayoutStyle.ComponentPlacement) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个表示最近组件之间的优选间距的元素。
addPreferredGap(LayoutStyle.ComponentPlacement, int, int) - Method in class javax.swing. GroupLayout.SequentialGroup
添加一个表示最近组件之间的优选间距的元素。
addPreLayoutPulseListener(Runnable) - Method in class javafx.scene. Scene
在这个场景中添加一个新的场景预布置脉冲监听器。
addPrintJobAttributeListener(PrintJobAttributeListener, PrintJobAttributeSet) - Method in interface javax.print. DocPrintJob
注册侦听器以指定属性的更改。
addPrintJobListener(PrintJobListener) - Method in interface javax.print. DocPrintJob
为此打印作业期间发生的事件注册一个侦听器。
addPrintServiceAttributeListener(PrintServiceAttributeListener) - Method in interface javax.print. PrintService
在此PrintService上为事件注册一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - Static method in class com.sun.java.accessibility.util. AccessibilityEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个UI对象实例上接收所有PropertyChange事件。
addPropertyChangeListener(PropertyChangeListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器，以便在Java虚拟机发生时在每个组件实例上接收所有 PROPERTYCHANGE事件。
addPropertyChangeListener(PropertyChangeListener) - Method in class com.sun.java.accessibility.util. Translator
添加一个 PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in interface com.sun.tools.jconsole. JConsoleContext
添加PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Component.AccessibleAWTComponent
添加 PropertyChangeListener到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Component
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Container.AccessibleAWTContainer
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Container
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt. KeyboardFocusManager
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Window
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.beans. Customizer
注册PropertyChange事件的侦听器。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.beans. PropertyChangeSupport
将一个PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.beans. PropertyEditor
为值更改添加一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - Method in class java.beans. PropertyEditorSupport
为值更改添加一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.accessibility. AccessibleContext
添加 PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. AbstractAction
添加 PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing. Action
添加一个 PropertyChange监听器。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JComponent.AccessibleJComponent
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell
添加一个 PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
将一个PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JTree.EmptySelectionModel
这样做是无效的 EmptySelectionModel不允许选择。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.basic. BasicDirectoryModel
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf. LayerUI
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. SwingWorker
添加 PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table. TableColumn
添加 PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.tree. DefaultTreeSelectionModel
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.tree. TreeSelectionModel
将PropertyChangeListener添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. UIDefaults
添加一个 PropertyChangeListener到监听器列表。
addPropertyChangeListener(PropertyChangeListener) - Static method in class javax.swing. UIManager
添加 PropertyChangeListener到监听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. Component
将PropertyChangeListener添加到特定属性的侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. Container
将PropertyChangeListener添加到特定属性的侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. KeyboardFocusManager
将PropertyChangeListener添加到特定属性的侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. SystemTray
将 PropertyChangeListener添加到特定属性的侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. Toolkit
为指定的桌面属性添加指定的属性更改侦听器。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. Window
将PropertyChangeListener添加到特定属性的侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - Method in interface java.beans.beancontext. BeanContextChild
为此 BeanContextChild添加一个 PropertyChangeListener ，以便在指定的属性更改时接收 PropertyChangeEvent 。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.beancontext. BeanContextChildSupport
为特定属性添加PropertyChangeListener。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans. PropertyChangeSupport
为特定属性添加PropertyChangeListener。
addPropertyChangeListener(String, PropertyChangeListener) - Method in class javax.swing.plaf. LayerUI
将PropertyChangeListener添加到特定属性的侦听器列表中。
addProvider(Provider) - Static method in class java.security. Security
将供应商添加到下一个可用位置。
addProviderAtEnd(Provider, Oid) - Method in class org.ietf.jgss. GSSManager
该方法用于向GSSManager指示，如果没有找到支持给定机制的其他提供程序，应用程序将希望使用特定的提供程序。
addProviderAtFront(Provider, Oid) - Method in class org.ietf.jgss. GSSManager
该方法用于向GSSManager指示当给定机制需要支持时，应用程序希望在所有其他提供程序之前使用特定的提供程序。
ADDR_ADDED - com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
该地址现在是协会的一部分。
ADDR_AVAILABLE - com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
此地址现在可达。
ADDR_CONFIRMED - com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
此地址现已确认为有效地址。
ADDR_MADE_PRIMARY - com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
这个地址现在已经成为主要的目的地址。
ADDR_REMOVED - com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
地址不再是协会的一部分。
ADDR_UNREACHABLE - com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
指定的地址无法再达到。
addReads(Module) - Method in class java.lang. Module
如果调用者的模块是该模块，则更新该模块以读取给定的模块。
addReads(Module, Module) - Method in class java.lang. ModuleLayer.Controller
更新模块 source在图层读取模块 target 。
addRelation(ObjectName) - Method in class javax.management.relation. RelationService
将由用户创建的一个MBean（并由他注册在MBean服务器中）添加为关系服务中的关系。
addRelation(ObjectName) - Method in interface javax.management.relation. RelationServiceMBean
将由用户创建的一个MBean（并由他注册在MBean服务器中）添加为关系服务中的关系。
addRelationType(RelationType) - Method in class javax.management.relation. RelationService
将给定对象添加为关系类型。
addRelationType(RelationType) - Method in interface javax.management.relation. RelationServiceMBean
将给定对象添加为关系类型。
addRenderingHints(Map<?, ?>) - Method in class java.awt. Graphics2D
为渲染算法设置任意数量的首选项的值。
addRequestProperty(String, String) - Method in class java.net. URLConnection
添加由键值对指定的一般请求属性。
addResourceBundle(String) - Method in class javax.swing. UIDefaults
将资源包添加到搜索本地化值的资源束列表中。
addResponseHeader(String, String) - Method in class javax.xml.ws.spi.http. HttpExchange
添加具有给定名称和值的响应头。
address - Variable in class java.net. SocketImpl
该套接字远端的IP地址。
address() - Method in class com.sun.jdi.connect.spi. TransportService.ListenKey
返回listen键的字符串表示形式。
address() - Method in class com.sun.nio.sctp. MessageInfo
如果接收到消息，则返回源套接字地址，否则将发送消息的首选目标。
address() - Method in class com.sun.nio.sctp. PeerAddressChangeNotification
返回对等地址。
address() - Method in class com.sun.nio.sctp. SendFailedNotification
返回地址。
address() - Method in class java.net. Proxy
返回代理的套接字地址，如果它是直接连接，则返回 null 。
address(String) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
设置 address至 W3CEndpointReference实例的 wsa:Address 。
ADDRESS - Static variable in class javax.swing.text.html. HTML.Tag
标签<地址>
AddressHelper - Class in org.omg.CosNaming.NamingContextExtPackage
地址是以字符串表示的主机和端口信息。
AddressHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage. AddressHelper
Addressing - Annotation Type in javax.xml.ws.soap
此注释表示使用SOAP 1.1 / HTTP或SOAP 1.2 / HTTP绑定的WS-Addressing。
AddressingFeature - Class in javax.xml.ws.soap
AddressingFeature表示使用SOAP 1.1 / HTTP或SOAP 1.2 / HTTP绑定的WS-Addressing。
AddressingFeature() - Constructor for class javax.xml.ws.soap. AddressingFeature
使用寻址要求创建和配置一个 AddressingFeature 。
AddressingFeature(boolean) - Constructor for class javax.xml.ws.soap. AddressingFeature
使用寻址要求创建和配置一个 AddressingFeature 。
AddressingFeature(boolean, boolean) - Constructor for class javax.xml.ws.soap. AddressingFeature
使用寻址要求创建和配置一个 AddressingFeature 。
AddressingFeature(boolean, boolean, AddressingFeature.Responses) - Constructor for class javax.xml.ws.soap. AddressingFeature
使用寻址要求创建并配置 AddressingFeature 。
AddressingFeature.Responses - Enum in javax.xml.ws.soap
如果启用寻址，则此属性确定端点是否仅需要使用匿名响应，或仅使用非匿名响应或全部。
addRoleInfo(RoleInfo) - Method in class javax.management.relation. RelationTypeSupport
添加角色信息。
addRow(int, Node...) - Method in class javafx.scene.layout. GridPane
将指定节点顺序放置在网格的给定行中的便利方法。
addRow(Object[]) - Method in class javax.swing.table. DefaultTableModel
在模型的末尾添加一行。
addRow(Vector<?>) - Method in class javax.swing.table. DefaultTableModel
在模型的末尾添加一行。
addRowSelectionInterval(int, int) - Method in class javax.swing. JTable
将行从 index0添加到 index1 （包括）到当前选择。
addRowSet(Joinable) - Method in interface javax.sql.rowset. JoinRowSet
将给定的 RowSet对象添加到此 JoinRowSet对象。
addRowSet(RowSet[], int[]) - Method in interface javax.sql.rowset. JoinRowSet
将一个或多个 RowSet包含的给定阵列中的对象 RowSet对象此 JoinRowSet对象，并为每一个的匹配列 RowSet对象列索引的给定阵列中的匹配列。
addRowSet(RowSet[], String[]) - Method in interface javax.sql.rowset. JoinRowSet
将一个或多个 RowSet包含的给定阵列中的对象 RowSet对象此 JoinRowSet对象，并为每一个的匹配列 RowSet对象列名的给定阵列中的匹配列。
addRowSet(RowSet, int) - Method in interface javax.sql.rowset. JoinRowSet
将给定的 RowSet对象添加到此 JoinRowSet对象，并将指定的列设置为 RowSet对象的匹配列。
addRowSet(RowSet, String) - Method in interface javax.sql.rowset. JoinRowSet
将 rowset添加到此 JoinRowSet对象，并将指定的列设置为匹配列。
addRowSetListener(RowSetListener) - Method in interface javax.sql. RowSet
注册给定的监听器，以便它将被通知在这个 RowSet对象上发生的事件。
addRowSetListener(RowSetListener) - Method in class javax.sql.rowset. BaseRowSet
当这个 RowSet对象发生事件时，监听器将被通知。
addRowSorterListener(RowSorterListener) - Method in class javax.swing. RowSorter
添加 RowSorterListener以接收有关此 RowSorter通知。
addrs - Variable in class javax.naming. Reference
包含本参考文献中包含的地址。
addrType - Variable in class javax.naming. RefAddr
包含此地址的类型。
addRule(String) - Method in class javax.swing.text.html. StyleSheet
在工作表中添加一组规则。
addSelectionInterval(int, int) - Method in class javax.swing. DefaultListSelectionModel
将选择更改为当前选择的 index0并且包含 index0和 index1之间的索引。
addSelectionInterval(int, int) - Method in class javax.swing. JList
将选择设置为指定间隔与当前选择的并集。
addSelectionInterval(int, int) - Method in class javax.swing. JTree
将指定的行（包括）添加到选择。
addSelectionInterval(int, int) - Method in interface javax.swing. ListSelectionModel
将选择更改为当前选择的集合，以及 index0和 index1之间的索引。
addSelectionPath(TreePath) - Method in class javax.swing. JTree
将由指定的 TreePath标识的节点添加到当前选择。
addSelectionPath(TreePath) - Method in class javax.swing.tree. DefaultTreeSelectionModel
添加当前选择的路径。
addSelectionPath(TreePath) - Method in interface javax.swing.tree. TreeSelectionModel
添加当前选择的路径。
addSelectionPaths(TreePath[]) - Method in class javax.swing. JTree
将路径数组中的每个路径添加到当前选择。
addSelectionPaths(TreePath[]) - Method in class javax.swing. JTree.EmptySelectionModel
这样做是无效的 EmptySelectionModel不允许选择。
addSelectionPaths(TreePath[]) - Method in class javax.swing.tree. DefaultTreeSelectionModel
将路径添加到当前选择。
addSelectionPaths(TreePath[]) - Method in interface javax.swing.tree. TreeSelectionModel
将路径添加到当前选择。
addSelectionRow(int) - Method in class javax.swing. JTree
将指定行的路径添加到当前选择。
addSelectionRows(int[]) - Method in class javax.swing. JTree
将每个指定行的路径添加到当前选择。
addSeparator() - Method in class java.awt. Menu
在当前位置的菜单中添加分隔线或连字符。
addSeparator() - Method in class javax.swing. JMenu
在菜单末尾附加一个新的分隔符。
addSeparator() - Method in class javax.swing. JPopupMenu
在菜单末尾附加一个新的分隔符。
addSeparator() - Method in class javax.swing. JToolBar
将默认大小的分隔符附加到工具栏的末尾。
addSeparator(Dimension) - Method in class javax.swing. JToolBar
将指定大小的分隔符追加到工具栏的末尾。
addService(Class<?>, BeanContextServiceProvider) - Method in interface java.beans.beancontext. BeanContextServices
向这个BeanContext添加一个服务。
addService(Class<?>, BeanContextServiceProvider) - Method in class java.beans.beancontext. BeanContextServicesSupport
添加服务
addService(Class<?>, BeanContextServiceProvider, boolean) - Method in class java.beans.beancontext. BeanContextServicesSupport
添加服务
addShutdownHook(Thread) - Method in class java.lang. Runtime
注册一个新的虚拟机关机挂钩。
addSingleInstanceListener(SingleInstanceListener) - Method in interface javax.jnlp. SingleInstanceService
添加指定的SingleInstanceListener来处理应用程序/小应用程序在调用相同应用程序/ applet的另一个实例时的行为方式。
addSingletonComponent(Component, Component) - Method in class javax.swing. ScrollPaneLayout
删除现有组件。
addSource(Object) - Method in class java.awt.image.renderable. ParameterBlock
将图像添加到源列表的末尾。
addSource(DOMImplementationSource) - Method in class org.w3c.dom.bootstrap. DOMImplementationRegistry
注册一个实现。
addSourceNameFilter(String) - Method in interface com.sun.jdi.request. ClassPrepareRequest
将此请求生成的事件限制为准备引用类型，受限正则表达式“sourceNamePattern”与正在准备的引用类型的“sourceNames”匹配。
addSpecialElement(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
添加基本上完全在属性集中指定的内容。
addStatementEventListener(StatementEventListener) - Method in interface javax.sql. PooledConnection
注册 StatementEventListener与此 PooledConnection对象。
addString(String) - Method in class javafx.css. StyleConverter.StringStore
addStyle(String, Style) - Method in class javax.swing. JTextPane
在逻辑样式层次结构中添加新样式。
addStyle(String, Style) - Method in class javax.swing.text. DefaultStyledDocument
在逻辑样式层次结构中添加新样式。
addStyle(String, Style) - Method in class javax.swing.text. StyleContext
在样式层次结构中添加新样式。
addStyle(String, Style) - Method in interface javax.swing.text. StyledDocument
在逻辑样式层次结构中添加新样式。
addStyleSheet(StyleSheet) - Method in class javax.swing.text.html. StyleSheet
将规范从StyleSheet ss添加到接收器的规则。
addSubComponents() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
添加子组件。
addSubComponents() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
覆盖父方法避免创建菜单栏。
addSubjectAlternativeName(int, byte[]) - Method in class java.security.cert. X509CertSelector
在subjectAlternativeNames条件中添加一个名称。
addSubjectAlternativeName(int, String) - Method in class java.security.cert. X509CertSelector
在subjectAlternativeNames条件中添加一个名称。
addSuppressed(Throwable) - Method in class java.lang. Throwable
将指定的异常附加到为了传递此异常而被抑制的异常。
addSwaRefAttachment(DataHandler) - Method in class javax.xml.bind.attachment. AttachmentMarshaller
添加MIME data作为附件，并返回附件的content-id，cid。
addSwitchPoint(SwitchPoint) - Method in class jdk.dynalink.linker. GuardedInvocation
使用添加的切换点创建新的守卫调用。
addSystemMenuItems(JMenu) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
将系统菜单项添加到 systemMenu 。
addSystemMenuItems(JMenu) - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
覆盖父方法，不做任何操作。
addTab(String, Component) - Method in class javax.swing. JTabbedPane
添加一个由 component表示的 title ，没有图标。
addTab(String, Icon, Component) - Method in class javax.swing. JTabbedPane
添加由 title和/或 component表示的 icon ，其中任何一个可以是 null 。
addTab(String, Icon, Component, String) - Method in class javax.swing. JTabbedPane
增加了一个 component和 tip由a表示 title和/或 icon ，其中任一个可以是 null 。
addTableModelListener(TableModelListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 TABLEMODEL事件。
addTableModelListener(TableModelListener) - Method in class javax.swing.table. AbstractTableModel
将一个监听器添加到每次发生数据模型更改时通知的列表。
addTableModelListener(TableModelListener) - Method in interface javax.swing.table. TableModel
将一个监听器添加到每次发生数据模型更改时通知的列表。
addTag - Variable in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction
HTML中的标签开始添加标签。
addTagSet(TIFFTagSet) - Method in class javax.imageio.plugins.tiff. TIFFDirectory
将一个元素添加到该目录知道的TIFFTagSet的组中。
addTask(Runnable) - Method in class javax.swing.text. LayoutQueue
添加一个不需要立即执行的任务，因为结果不被认为是可见的。
addTaskListener(TaskListener) - Method in class com.sun.source.util. JavacTask
添加指定的侦听器，以便它接收到描述此编译任务进度的事件的通知。
addTextListener(TextListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 TEXT事件。
addTextListener(TextListener) - Method in class java.awt. TextComponent
添加指定的文本事件侦听器以从此文本组件接收文本事件。
addTextNode(String) - Method in interface javax.xml.soap. SOAPElement
创建一个新的 Text对象，使用给定的 String初始化并将其添加到此 SOAPElement对象。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. BreakpointRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. ExceptionRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. MethodEntryRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. MethodExitRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. MonitorContendedEnteredRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. MonitorContendedEnterRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. MonitorWaitedRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. MonitorWaitRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. ThreadDeathRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. ThreadStartRequest
将此请求生成的事件限制在给定线程中的事件。
addThreadFilter(ThreadReference) - Method in interface com.sun.jdi.request. WatchpointRequest
将此请求生成的事件限制在给定线程中的事件。
addTIFFField(TIFFField) - Method in class javax.imageio.plugins.tiff. TIFFDirectory
将TIFF字段添加到目录。
addTileObserver(TileObserver) - Method in class java.awt.image. BufferedImage
添加瓦片观察器。
addTileObserver(TileObserver) - Method in interface java.awt.image. WritableRenderedImage
添加观察者
addTo(Temporal) - Method in interface java.time.chrono. ChronoPeriod
将此时段添加到指定的时间对象。
addTo(Temporal) - Method in class java.time. Duration
将此持续时间添加到指定的时间对象。
addTo(Temporal) - Method in class java.time. Period
将此时段添加到指定的时间对象。
addTo(Temporal) - Method in interface java.time.temporal. TemporalAmount
添加到指定的时间对象。
addTo(Calendar) - Method in class javax.xml.datatype. Duration
将此持续时间添加到Calendar对象。
addTo(Date) - Method in class javax.xml.datatype. Duration
将此持续时间添加到Date对象。
addTo(R, long) - Method in enum java.time.temporal. ChronoUnit
addTo(R, long) - Method in interface java.time.temporal. TemporalUnit
返回添加指定句点的指定时间对象的副本。
addToClasspath(String) - Method in class jdk.jshell.execution. DirectExecutionControl
addToClasspath(String) - Method in interface jdk.jshell.execution. LoaderDelegate
将路径添加到执行类路径。
addToClasspath(String) - Method in class jdk.jshell.execution. StreamingExecutionControl
addToClasspath(String) - Method in class jdk.jshell. JShell
指定的路径被添加到eval（）中使用的类路径的末尾。
addToClasspath(String) - Method in interface jdk.jshell.spi. ExecutionControl
将路径添加到执行类路径。
addToEnvironment(String, Object) - Method in interface javax.naming. Context
在此上下文的环境中添加一个新的环境属性。
addToEnvironment(String, Object) - Method in class javax.naming. InitialContext
addToPendingCount(int) - Method in class java.util.concurrent. CountedCompleter
将给定值添加（原子地）给挂起的计数。
addTopLevelWindowListener(TopLevelWindowListener) - Static method in class com.sun.java.accessibility.util. EventQueueMonitor
添加当创建或销毁顶级窗口时通知的指定侦听器。
addTransformer(ClassFileTransformer) - Method in interface java.lang.instrument. Instrumentation
注册提供的变压器。
addTransformer(ClassFileTransformer, boolean) - Method in interface java.lang.instrument. Instrumentation
注册提供的变压器。
addTreeExpansionListener(TreeExpansionListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 TREEEXPANSION事件。
addTreeExpansionListener(TreeExpansionListener) - Method in class javax.swing. JTree
为 TreeExpansion事件添加一个侦听 TreeExpansion 。
addTreeModelListener(TreeModelListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 TREEMODEL事件。
addTreeModelListener(TreeModelListener) - Method in class javax.swing.tree. DefaultTreeModel
添加树树更改后发布的TreeModelEvent的侦听器。
addTreeModelListener(TreeModelListener) - Method in interface javax.swing.tree. TreeModel
添加一个监听器为 TreeModelEvent发布树后更改。
addTreeSelectionListener(TreeSelectionListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 TREESELECTION事件。
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing. JTree
为 TreeSelection事件添加一个侦听 TreeSelection 。
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing. JTree.EmptySelectionModel
这样做是无效的 EmptySelectionModel不允许进行选择。
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.tree. DefaultTreeSelectionModel
将x添加到每次选定的TreePath集合更改时通知的侦听器列表。
addTreeSelectionListener(TreeSelectionListener) - Method in interface javax.swing.tree. TreeSelectionModel
将x添加到每次选定的TreePath集合更改时通知的侦听器列表。
addTreeWillExpandListener(TreeWillExpandListener) - Method in class javax.swing. JTree
为 TreeWillExpand事件添加一个侦听 TreeWillExpand 。
addUndoableEditListener(UndoableEditListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 UNDOABLEEDIT事件。
addUndoableEditListener(UndoableEditListener) - Method in class javax.swing.text. AbstractDocument
添加撤消侦听器以通知任何更改。
addUndoableEditListener(UndoableEditListener) - Method in interface javax.swing.text. Document
注册给定的观察者，以便在对文档进行撤消修改时开始接收通知。
addUndoableEditListener(UndoableEditListener) - Method in class javax.swing.undo. UndoableEditSupport
注册 UndoableEditListener 。
addUnencodedNativeForFlavor(DataFlavor, String) - Method in class java.awt.datatransfer. SystemFlavorMap
将指定的 DataFlavor （和所有 DataFlavor s等于指定的 DataFlavor ）的映射添加到指定的 String本机。
addUnicodeLocaleAttribute(String) - Method in class java.util. Locale.Builder
添加unicode区域设置属性（如果尚未存在），否则不起作用。
addUpgradeHeaderElement(String) - Method in interface javax.xml.soap. SOAPHeader
创建一个新的升级 SOAPHeaderElement对象，并使用指定的支持的SOAP URI进行初始化，并将其添加到此 SOAPHeader对象。
addUpgradeHeaderElement(String[]) - Method in interface javax.xml.soap. SOAPHeader
创建一个新的升级 SOAPHeaderElement对象，并使用指定的受支持的SOAP URI数组进行初始化，并将其添加到此 SOAPHeader对象。
addUpgradeHeaderElement(Iterator<String>) - Method in interface javax.xml.soap. SOAPHeader
创建一个新的升级 SOAPHeaderElement对象，并使用指定的支持SOAP URI的String Iterator进行初始化，并将其添加到此 SOAPHeader对象。
addURL(String) - Method in class javax.management.loading. MLet
将指定的URL附加到URL列表中以搜索类和资源。
addURL(String) - Method in interface javax.management.loading. MLetMBean
将指定的URL附加到URL列表中以搜索类和资源。
addURL(URL) - Method in class java.net. URLClassLoader
将指定的URL附加到URL列表中以搜索类和资源。
addURL(URL) - Method in class javax.management.loading. MLet
将指定的URL附加到URL列表中以搜索类和资源。
addURL(URL) - Method in interface javax.management.loading. MLetMBean
将指定的URL附加到URL列表中以搜索类和资源。
addUses(Class<?>) - Method in class java.lang. Module
如果调用者模块是此模块，则更新此模块以添加对给定服务类型的服务依赖。
addValueName(int, String) - Method in class javax.imageio.plugins.tiff. TIFFTag
为此标签的数据可能需要的特定值添加一个助记符名称。
addVetoableChangeListener(VetoableChangeListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 VETOABLECHANGE事件。
addVetoableChangeListener(VetoableChangeListener) - Method in class java.awt. KeyboardFocusManager
将VetoableChangeListener添加到侦听器列表。
addVetoableChangeListener(VetoableChangeListener) - Method in class java.beans. VetoableChangeSupport
将VetoableChangeListener添加到侦听器列表。
addVetoableChangeListener(VetoableChangeListener) - Method in class javax.swing. JComponent
添加 VetoableChangeListener到侦听器列表。
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.awt. KeyboardFocusManager
将VetoableChangeListener添加到特定属性的侦听器列表中。
addVetoableChangeListener(String, VetoableChangeListener) - Method in interface java.beans.beancontext. BeanContextChild
在此 BeanContextChild添加一个 VetoableChangeListener ，以便在指定的属性更改时接收事件。
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.beancontext. BeanContextChildSupport
为特定属性添加VetoableChangeListener。
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans. VetoableChangeSupport
为特定属性添加VetoableChangeListener。
addWindowFocusListener(WindowFocusListener) - Method in class java.awt. Window
添加指定的窗口焦点侦听器以从此窗口接收窗口事件。
addWindowListener(WindowListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 WINDOW事件。
addWindowListener(WindowListener) - Method in class java.awt. Window
添加指定的窗口侦听器以从此窗口接收窗口事件。
addWindowStateListener(WindowStateListener) - Method in class java.awt. Window
添加指定的窗口状态侦听器以从此窗口接收窗口事件。
Adjustable - Interface in java.awt
具有可调整数值的对象的界面包含在有限范围内的值。
adjustAllocation(Shape) - Method in class javax.swing.text. FieldView
调整给予视图的分配是文本字段的合适分配。
adjustForGravity(GridBagConstraints, Rectangle) - Method in class java.awt. GridBagLayout
根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
AdjustForGravity(GridBagConstraints, Rectangle) - Method in class java.awt. GridBagLayout
根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
adjustInto(Temporal) - Method in interface java.time.chrono. ChronoLocalDate
调整指定的时间对象与此对象的日期相同。
adjustInto(Temporal) - Method in interface java.time.chrono. ChronoLocalDateTime
调整指定的时间对象与此对象具有相同的日期和时间。
adjustInto(Temporal) - Method in interface java.time.chrono. Era
调整指定的时间对象与此对象具有相同的时代。
adjustInto(Temporal) - Method in enum java.time. DayOfWeek
将指定的时间对象调整为具有这一天的日期。
adjustInto(Temporal) - Method in class java.time. Instant
调整指定的时间对象具有这个瞬间。
adjustInto(Temporal) - Method in class java.time. LocalDate
调整指定的时间对象与此对象的日期相同。
adjustInto(Temporal) - Method in class java.time. LocalDateTime
调整指定的时间对象与此对象具有相同的日期和时间。
adjustInto(Temporal) - Method in class java.time. LocalTime
调整指定的时间对象与此对象具有相同的时间。
adjustInto(Temporal) - Method in enum java.time. Month
将指定的时间对象调整为具有这个月的年份。
adjustInto(Temporal) - Method in class java.time. MonthDay
将指定的时间对象调整为具有这个月日。
adjustInto(Temporal) - Method in class java.time. OffsetDateTime
调整指定的时间对象与此对象具有相同的偏移量，日期和时间。
adjustInto(Temporal) - Method in class java.time. OffsetTime
调整指定的时间对象与此对象具有相同的偏移量和时间。
adjustInto(Temporal) - Method in interface java.time.temporal. TemporalAdjuster
调整指定的时间对象。
adjustInto(Temporal) - Method in class java.time. Year
调整指定的时间对象到今年。
adjustInto(Temporal) - Method in class java.time. YearMonth
将指定的时间对象调整为今年。
adjustInto(Temporal) - Method in class java.time. ZoneOffset
调整指定的时间对象与此对象的偏移量相同。
adjustInto(R, long) - Method in enum java.time.temporal. ChronoField
adjustInto(R, long) - Method in interface java.time.temporal. TemporalField
返回指定时间对象的副本，并设置该字段的值。
ADJUSTMENT - Static variable in class com.sun.java.accessibility.util. EventID
映射到AWT调整支持（即AdjustmentListener和AdjustmentEvent）
ADJUSTMENT_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择调整事件的事件掩码。
ADJUSTMENT_FIRST - Static variable in class java.awt.event. AdjustmentEvent
标记调整事件ID范围的第一个整数ID。
ADJUSTMENT_LAST - Static variable in class java.awt.event. AdjustmentEvent
标记调整事件ID的范围的最后整数ID。
ADJUSTMENT_VALUE_CHANGED - Static variable in class java.awt.event. AdjustmentEvent
调整值改变事件。
AdjustmentEvent - Class in java.awt.event
可调整对象发出的调整事件，如Scrollbar和ScrollPane 。
AdjustmentEvent(Adjustable, int, int, int) - Constructor for class java.awt.event. AdjustmentEvent
构造具有指定的 Adjustable源，事件类型，调整类型和值的 AdjustmentEvent对象。
AdjustmentEvent(Adjustable, int, int, int, boolean) - Constructor for class java.awt.event. AdjustmentEvent
构造具有指定的可调源，事件类型，调整类型和值的 AdjustmentEvent对象。
adjustmentListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor
不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。
AdjustmentListener - Interface in java.awt.event
用于接收调整事件的侦听器接口。
adjustmentValueChanged(AdjustmentEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的adjustValueChanged方法来处理adjustValueChanged事件。
adjustmentValueChanged(AdjustmentEvent) - Method in interface java.awt.event. AdjustmentListener
当可调整的值已更改时调用。
adjustRow(FlowView, int, int, int) - Method in class javax.swing.text. FlowView.FlowStrategy
如果可能，调整给定行以适应布局范围。
adjustSizes(int, SizeRequirements[]) - Static method in class javax.swing. SizeRequirements
将指定的大小数组调整一定量。
adjustValue(double) - Method in class javafx.scene.control. ScrollBar
调整 value属性 blockIncrement 。
adjustValue(double) - Method in class javafx.scene.control. Slider
调整 value匹配 newValue 。
adjustVisibility(Rectangle) - Method in class javax.swing.text. DefaultCaret
滚动关联视图（如有必要）使插入符可见。
Adler32 - Class in java.util.zip
可用于计算数据流的Adler-32校验和的类。
Adler32() - Constructor for class java.util.zip. Adler32
创建一个新的Adler32对象。
ADMIN_UIROLE - Static variable in class javax.print. ServiceUIFactory
表示执行管理角色的UI。
adoptNode(Node) - Method in interface org.w3c.dom. Document
尝试从另一个文档中采用节点到本文档。
AEADBadTagException - Exception in javax.crypto
当以AEAD模式运行的Cipher （例如GCM / CCM）无法验证提供的认证标签时，会抛出此异常。
AEADBadTagException() - Constructor for exception javax.crypto. AEADBadTagException
构造一个没有详细消息的AEADBadTagException。
AEADBadTagException(String) - Constructor for exception javax.crypto. AEADBadTagException
构造具有指定详细消息的AEADBadTagException。
AEGEAN_NUMBERS - Static variable in class java.lang. Character.UnicodeBlock
“爱琴海数字”Unicode字符块的常数。
AFFILIATION_CHANGED - java.security.cert. CRLReason
这个原因表明主题的名称或其他信息已经改变。
affine(double, double, double, double, double, double) - Static method in class javafx.scene.transform. Transform
从12个数字值返回新的 Affine对象，表示3x4仿射变换矩阵的6个可指定条目。
affine(double, double, double, double, double, double, double, double, double, double, double, double) - Static method in class javafx.scene.transform. Transform
从12个数字值返回新的 Affine对象，表示3x4仿射变换矩阵的12个可指定条目。
Affine - Class in javafx.scene.transform
Affine类代表一般的仿射变换。
Affine() - Constructor for class javafx.scene.transform. Affine
创建包含身份转换的新实例 Affine 。
Affine(double[], MatrixType, int) - Constructor for class javafx.scene.transform. Affine
使用由数组指定的转换矩阵创建一个新的 Affine实例。
Affine(double, double, double, double, double, double) - Constructor for class javafx.scene.transform. Affine
用元素值指定的2D变换创建一个新的 Affine实例。
Affine(double, double, double, double, double, double, double, double, double, double, double, double) - Constructor for class javafx.scene.transform. Affine
用元素值指定的变换创建一个新的 Affine实例。
Affine(Transform) - Constructor for class javafx.scene.transform. Affine
创建一个填充了指定变换值的新实例 Affine 。
AffineTransform - Class in java.awt.geom
AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“直线度”和“平行度”。
AffineTransform() - Constructor for class java.awt.geom. AffineTransform
构造一个新的 AffineTransform代表身份转换。
AffineTransform(double[]) - Constructor for class java.awt.geom. AffineTransform
从表示3x3转换矩阵的4个非转换条目或6个可指定条目的双精度值数组构造新的 AffineTransform 。
AffineTransform(double, double, double, double, double, double) - Constructor for class java.awt.geom. AffineTransform
从6个双精度值构造新的 AffineTransform ，表示3x3转换矩阵的6个可指定条目。
AffineTransform(float[]) - Constructor for class java.awt.geom. AffineTransform
从表示3x3转换矩阵的4个非转换条目或6个可指定条目的浮点值数组构造新的 AffineTransform 。
AffineTransform(float, float, float, float, float, float) - Constructor for class java.awt.geom. AffineTransform
从6个浮点值构造新的 AffineTransform ，表示3x3转换矩阵的6个可指定条目。
AffineTransform(AffineTransform) - Constructor for class java.awt.geom. AffineTransform
构造一个新的 AffineTransform ，它是一个指定的 AffineTransform对象的副本。
AffineTransformOp - Class in java.awt.image
该类使用仿射变换来执行从源图像中的2D坐标或目标图像中的 Raster到2D坐标的线性映射或 Raster 。
AffineTransformOp(AffineTransform, int) - Constructor for class java.awt.image. AffineTransformOp
构造一个 AffineTransformOp给出仿射变换和插值类型。
AffineTransformOp(AffineTransform, RenderingHints) - Constructor for class java.awt.image. AffineTransformOp
构造一个 AffineTransformOp给出一个仿射变换。
after(Object) - Method in class java.util. Calendar
返回这个 Calendar是否表示由指定的 Object表示的时间之后的时间。
after(Timestamp) - Method in class java.sql. Timestamp
指示此 Timestamp对象是否晚于给定的 Timestamp对象。
after(Date) - Method in class java.util. Date
测试此日期是否在指定日期之后。
AFTER - javax.swing. RowFilter.ComparisonType
表示应包含提供值后面的值的条目。
AFTER_LAST_LINE - Static variable in class java.awt. BorderLayout
PAGE_END的同义词。
AFTER_LINE_ENDS - Static variable in class java.awt. BorderLayout
LINE_END的同义词。
afterExecute(Runnable, Throwable) - Method in class java.util.concurrent. ThreadPoolExecutor
完成指定Runnable的执行后调用方法。
afterLast() - Method in interface java.sql. ResultSet
将光标移动到此 ResultSet对象的最后一行。
afterMarshal(Object) - Method in class javax.xml.bind. Marshaller.Listener
在将 source编组为XML后调用回调方法。
afterOffset(int) - Static method in class java.awt.font. TextHitInfo
以指定的偏移量创建 TextHitInfo ，与偏移后的字符相关联。
afterUnmarshal(Object, Object) - Method in class javax.xml.bind. Unmarshaller.Listener
将 target XML数据解 target到 target后调用回调方法。
AGAIN - javafx.scene.input. KeyCode
常数为 Again键。
AgentInitializationException - Exception in com.sun.tools.attach
当代理程序无法在目标Java虚拟机中初始化时抛出异常。
AgentInitializationException() - Constructor for exception com.sun.tools.attach. AgentInitializationException
构造一个 AgentInitializationException ，没有详细信息。
AgentInitializationException(String) - Constructor for exception com.sun.tools.attach. AgentInitializationException
构造具有指定详细消息的 AgentInitializationException 。
AgentInitializationException(String, int) - Constructor for exception com.sun.tools.attach. AgentInitializationException
构造一个 AgentInitializationException带指定详细消息，并从代理的执行的返回值 Agent_OnAttach功能。
AgentLoadException - Exception in com.sun.tools.attach
代理无法加载到目标Java虚拟机时抛出的异常。
AgentLoadException() - Constructor for exception com.sun.tools.attach. AgentLoadException
构造一个没有详细消息的 AgentLoadException 。
AgentLoadException(String) - Constructor for exception com.sun.tools.attach. AgentLoadException
构造具有指定详细消息的 AgentLoadException 。
AH - java.time.chrono. HijrahEra
当代时代的单身实例“Anno Hegirae”，其数值为1。
AHOM - java.lang. Character.UnicodeScript
Unicode脚本“Ahom”。
AHOM - Static variable in class java.lang. Character.UnicodeBlock
“Ahom”Unicode字符块的常数。
AIFC - Static variable in class javax.sound.sampled. AudioFileFormat.Type
指定AIFF-C文件。
AIFF - Static variable in class javax.sound.sampled. AudioFileFormat.Type
指定AIFF文件。
ALARM - java.nio.file.attribute. AclEntryType
以系统依赖的方式生成在ACL条目的权限组件中指定的访问的警报。
ALAW - Static variable in class javax.sound.sampled. AudioFormat.Encoding
指定a律编码数据。
ALCHEMICAL_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
常数为“Alchemical Symbols”Unicode字符块。
Alert - Class in javafx.scene.control
Alert类对Dialog类进行子类化，并提供对许多预构建的对话框类型的支持，可以轻松向用户显示提示响应。
Alert(Alert.AlertType) - Constructor for class javafx.scene.control. Alert
使用给定的AlertType创建警报（参考Alert.AlertType文档了解哪一个是最合适的）。
Alert(Alert.AlertType, String, ButtonType...) - Constructor for class javafx.scene.control. Alert
使用给定的contentText，ButtonTypes和AlertType创建警报（参考Alert.AlertType文档了解哪一个是最合适的）。
ALERT - Static variable in class javafx.scene.web. WebEvent
当脚本调用JavaScript alert函数时，会发生此事件。
ALERT - Static variable in class javax.accessibility. AccessibleRole
对象用于提醒用户有关某些内容。
Alert.AlertType - Enum in javafx.scene.control
包含Alert类可用于预先填充各种属性的可用的预构建警报类型的枚举 。
alertTypeProperty() - Method in class javafx.scene.control. Alert
创建Alert实例时，用户必须传入一个Alert.AlertType枚举值。
ALGORITHM_CONSTRAINED - java.security.cert. CertPathValidatorException.BasicReason
公钥或签名算法已被约束。
AlgorithmConstraints - Interface in java.security
该接口指定加密算法，密钥（密钥大小）和其他算法参数的约束。
AlgorithmMethod - Interface in javax.xml.crypto
在XML安全规范中定义的算法的抽象表示。
AlgorithmParameterGenerator - Class in java.security
AlgorithmParameterGenerator类用于生成一组要用于某种算法的参数。
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi, Provider, String) - Constructor for class java.security. AlgorithmParameterGenerator
创建一个AlgorithmParameterGenerator对象。
AlgorithmParameterGeneratorSpi - Class in java.security
该类定义了 AlgorithmParameterGenerator类的 （ SPI ），用于生成一组要与特定算法一起使用的参数。
AlgorithmParameterGeneratorSpi() - Constructor for class java.security. AlgorithmParameterGeneratorSpi
AlgorithmParameters - Class in java.security
此类用作加密参数的不透明表示。
AlgorithmParameters(AlgorithmParametersSpi, Provider, String) - Constructor for class java.security. AlgorithmParameters
创建一个AlgorithmParameters对象。
AlgorithmParameterSpec - Interface in java.security.spec
密码参数的（透明）规范。
AlgorithmParametersSpi - Class in java.security
该类为 AlgorithmParameters类定义了 （ SPI ），用于管理算法参数。
AlgorithmParametersSpi() - Constructor for class java.security. AlgorithmParametersSpi
aliases() - Method in class java.nio.charset. Charset
返回一个包含此字符集的别名的集合。
aliases() - Method in class java.security. KeyStore
列出此密钥库的所有别名。
ALICEBLUE - Static variable in class javafx.scene.paint. Color
颜色为蓝绿色，RGB值为＃F0F8FF
ALIGN - Static variable in class javax.swing.text.html. HTML.Attribute
属性“对齐”
ALIGN_BAR - Static variable in class javax.swing.text. TabStop
对齐吧
ALIGN_CENTER - javafx.scene.web. HTMLEditorSkin.Command
ALIGN_CENTER - Static variable in class javax.swing.text. StyleConstants
段落对齐的可能值。
ALIGN_CENTER - Static variable in class javax.swing.text. TabStop
以下选项卡中的字符将被放置，以便下一个选项卡/换行符的所有后续字符都围绕选项卡位置居中。
ALIGN_DECIMAL - Static variable in class javax.swing.text. TabStop
字符以下选项卡对齐，以便下一个十进制/标签/换行符在选项卡位置，非常类似于RIGHT_TAB，只包含十进制作为要查找的附加字符。
ALIGN_JUSTIFIED - Static variable in class javax.swing.text. StyleConstants
段落对齐的可能值。
ALIGN_JUSTIFY - javafx.scene.web. HTMLEditorSkin.Command
ALIGN_LEFT - javafx.scene.web. HTMLEditorSkin.Command
ALIGN_LEFT - Static variable in class javax.swing.text. StyleConstants
段落对齐的可能值。
ALIGN_LEFT - Static variable in class javax.swing.text. TabStop
字符以下选项卡位于位置。
ALIGN_RIGHT - javafx.scene.web. HTMLEditorSkin.Command
ALIGN_RIGHT - Static variable in class javax.swing.text. StyleConstants
段落对齐的可能值。
ALIGN_RIGHT - Static variable in class javax.swing.text. TabStop
以下选项卡中的字符将被定位，使得所有后续字符直到下一个选项卡/换行符在位置结束。
ALIGNED_DAY_OF_WEEK_IN_MONTH - java.time.temporal. ChronoField
一个月内排列的星期几。
ALIGNED_DAY_OF_WEEK_IN_YEAR - java.time.temporal. ChronoField
一年内排列的星期几。
ALIGNED_WEEK_OF_MONTH - java.time.temporal. ChronoField
一个月内的对齐周。
ALIGNED_WEEK_OF_YEAR - java.time.temporal. ChronoField
一年内对齐的一周。
alignedSlice(int) - Method in class java.nio. ByteBuffer
创建一个新的字节缓冲区，其内容是此缓冲区内容的共享和对齐子序列。
alignment - Variable in class javax.swing. SizeRequirements
对齐方式，指定为0.0和1.0之间的值，包括0和1.0。
Alignment - Static variable in class javax.swing.text. StyleConstants
段落的对齐。
AlignmentAction(String, int) - Constructor for class javax.swing.text. StyledEditorKit.AlignmentAction
创建一个新的AlignmentAction。
alignmentOffset(int, int) - Method in class java.nio. ByteBuffer
返回内存地址，指向给定索引处的字节，模拟给定的单位大小。
alignmentProperty() - Method in class javafx.scene.control. Labeled
指定Labeled内的空格时如何对齐Labeled中的文本和图形。
alignmentProperty() - Method in class javafx.scene.control. TextField
指定当TextField中有空格时如何对齐文本。
alignmentProperty() - Method in class javafx.scene.layout. FlowPane
Flowpane的内容在其宽度和高度之间的整体对齐。
alignmentProperty() - Method in class javafx.scene.layout. GridPane
格栅在格栅宽度和高度内的对齐方式。
alignmentProperty() - Method in class javafx.scene.layout. HBox
孩子们在hbox的宽度和高度之间的整体对齐。
alignmentProperty() - Method in class javafx.scene.layout. StackPane
在stackpane的宽度和高度内的子项的默认对齐方式。
alignmentProperty() - Method in class javafx.scene.layout. TilePane
瓦楞纸板内容在其宽度和高度之间的整体对齐。
alignmentProperty() - Method in class javafx.scene.layout. VBox
孩子们在vbox的宽度和高度之间的整体对齐。
ALINK - Static variable in class javax.swing.text.html. HTML.Attribute
属性“alink”
ALL - java.lang. System.Logger.Level
指示所有级别都启用的标记。
ALL - javax.smartcardio. CardTerminals.State
所有卡终端
ALL - javax.xml.ws.soap. AddressingFeature.Responses
支持所有的响应类型，这是默认值
ALL - jdk.javadoc.doclet. DocletEnvironment.ModuleMode
说明需要详细的文件
ALL - Static variable in class java.awt. JobAttributes.DefaultSelectionType
用于指定应打印作业的所有页面的 DefaultSelectionType实例。
ALL - Static variable in class java.util.logging. Level
ALL表示所有消息都应该被记录。
ALL - Static variable in interface javax.jnlp. DownloadService2
匹配所有资源 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
ALL_CANDIDATES - javafx.scene.input. KeyCode
所有候选人的常数功能键。
ALL_COLUMNS - Static variable in class javax.swing.event. TableModelEvent
指定一行或多行中的所有列。
ALL_DESCENDANTS - javafx.scene.control. TreeSortMode
默认; 排序所有节点。
ALL_RANGES - Static variable in class java.awt.font. NumericShaper
识别所有范围，用于完整的上下文整形。
ALL_STYLES - Static variable in class java.util. Calendar
一个表示 getDisplayNames的样式说明符，表示所有样式的名称，如“1月”和“1月”。
ALL_TABS - javafx.scene.control. TabPane.TabClosingPolicy
所有选项卡都可以选择关闭。
ALLBITS - Static variable in interface java.awt.image. ImageObserver
imageUpdate的infoflags参数中的此标志表示以前绘制的静态图像现在已完成，可以以其最终形式再次绘制。
allClasses() - Method in interface com.sun.javadoc. PackageDoc
已过时。
在包中获取所有 included类和接口。
allClasses() - Method in interface com.sun.jdi. VirtualMachine
返回所有加载的类型。
allClasses(boolean) - Method in interface com.sun.javadoc. PackageDoc
已过时。
获取包中的所有类和接口，过滤到指定的 access modifier option 。
allConnectors() - Method in interface com.sun.jdi. VirtualMachineManager
返回所有已知的Connector对象的列表。
allFields() - Method in interface com.sun.jdi. ReferenceType
返回包含此类型中声明的每个Field及其超类，已实现的接口和/或超级接口的列表。
allHtmlFlavor - Static variable in class java.awt.datatransfer. DataFlavor
代表一个HTML标记。
allInterfaces() - Method in interface com.sun.jdi. ClassType
获取由此类直接和间接实现的接口。
allKeys() - Method in class javax.swing. ActionMap
返回此 ActionMap及其父代码中定义的键的数组。
allKeys() - Method in class javax.swing. InputMap
返回此 InputMap及其父级中定义的 KeyStroke的数组。
allLineLocations() - Method in interface com.sun.jdi. 方法
在此方法中，为每个可执行源行返回一个包含Location对象的列表。
allLineLocations() - Method in interface com.sun.jdi. ReferenceType
在此引用类型中，为每个可执行源行返回一个包含Location对象的列表。
allLineLocations(String, String) - Method in interface com.sun.jdi. 方法
在此方法中为每个可执行源行返回一个包含Location对象的列表。
allLineLocations(String, String) - Method in interface com.sun.jdi. ReferenceType
返回包含一个列表Location对该引用类型的每个可执行源极线对象。
allMatch(DoublePredicate) - Method in interface java.util.stream. DoubleStream
返回此流的所有元素是否与提供的谓词匹配。
allMatch(IntPredicate) - Method in interface java.util.stream. IntStream
返回此流的所有元素是否与提供的谓词匹配。
allMatch(LongPredicate) - Method in interface java.util.stream. LongStream
返回此流的所有元素是否与提供的谓词匹配。
allMatch(Predicate<? super T>) - Method in interface java.util.stream. Stream
返回此流的所有元素是否与提供的谓词匹配。
allMethods() - Method in interface com.sun.jdi. ReferenceType
返回包含此类型中声明的每个方法及其超类，已实现的接口和/或超级接口的列表。
allModules() - Method in interface com.sun.jdi. VirtualMachine
返回所有模块。
allNotesOff() - Method in interface javax.sound.midi. MidiChannel
关闭当前在此频道上播放的所有音符。
allocate(int) - Static method in class java.nio. ByteBuffer
分配一个新的字节缓冲区。
allocate(int) - Static method in class java.nio. CharBuffer
分配一个新的char缓冲区。
allocate(int) - Static method in class java.nio. DoubleBuffer
分配一个新的双缓冲区。
allocate(int) - Static method in class java.nio. FloatBuffer
分配一个新的浮动缓冲区。
allocate(int) - Static method in class java.nio. IntBuffer
分配一个新的int缓冲区。
allocate(int) - Static method in class java.nio. LongBuffer
分配一个新的长缓冲区。
allocate(int) - Static method in class java.nio. ShortBuffer
分配一个新的缓冲区。
allocate(XMLStreamReader) - Method in interface javax.xml.stream.util. XMLEventAllocator
该方法分配给定XMLStreamReader的当前状态的事件。
allocate(XMLStreamReader, XMLEventConsumer) - Method in interface javax.xml.stream.util. XMLEventAllocator
该方法分配给定XMLStreamReader的当前状态的事件或事件集，并将事件或事件集添加到传入的消费者。
allocate_slot_id() - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
呼叫在 PortableInterceptor.Current分配一个插槽。
allocateArray(int) - Method in class javax.swing.text. GapContent
分配一个数组以存储适当类型的项目（由子类确定）。
allocateDirect(int) - Static method in class java.nio. ByteBuffer
分配一个新的直接字节缓冲区。
ALLOCATOR - Static variable in class javax.xml.stream. XMLInputFactory
该属性用于设置/获取分配器的实现
allOf(Class<E>) - Static method in class java.util. EnumSet
创建一个包含指定元素类型中所有元素的枚举集。
allOf(CompletableFuture<?>...) - Static method in class java.util.concurrent. CompletableFuture
返回一个新的CompletableFuture，当所有给定的CompletableFutures完成时，完成。
ALLOW - java.nio.file.attribute. AclEntryType
明确授予对文件或目录的访问权限。
ALLOW_UNASSIGNED - Static variable in class java.net. IDN
标志允许处理未分配的代码点
allowCoreThreadTimeOut(boolean) - Method in class java.util.concurrent. ThreadPoolExecutor
设置策略是否核心线程可能会超时，如果任务没有在活着的时间内到达，则在新任务到达时被替换。
ALLOWED - java.io. ObjectInputFilter.Status
状态是允许的。
ALLOWED_CLASSNAMES - Static variable in class javax.management.openmbean. OpenType
已过时。
改用ALLOWED_CLASSNAMES_LIST 。
ALLOWED_CLASSNAMES_LIST - Static variable in class javax.management.openmbean. OpenType
列出允许开放数据值的Java类的完全限定名称。
allowIndeterminateProperty() - Method in class javafx.scene.control. CheckBox
确定用户是否切换复选框应该循环遍历所有三个状态：已 选中 ， 未选中和 未定义 。
allowMultipleSelections() - Method in class javax.security.auth.callback. ChoiceCallback
获取布尔确定是否允许从 choices列表中选择多个选项。
allowsChildren - Variable in class javax.swing.tree. DefaultMutableTreeNode
如果节点能够拥有子节点，则为true
allowsCoreThreadTimeOut() - Method in class java.util.concurrent. ThreadPoolExecutor
如果此池允许核心线程超时并终止，如果没有任务在keepAlive时间内到达，则返回true，如果新任务到达时需要更换。
allowsMultipleSelections() - Method in class java.awt. List
已过时。
自JDK 1.1版起，由isMultipleMode()替代。
allowThreadSuspension(boolean) - Method in class java.lang. ThreadGroup
已过时。
此呼叫的定义取决于ThreadGroup.suspend() ，已被弃用。 此外，从未指定此调用的行为。
allowUserInteraction - Variable in class java.net. URLConnection
如果是 true ，这个 URL正在上下文中进行检查，其中允许用户交互（例如弹出认证对话）是有意义的。
AllPermission - Class in java.security
AllPermission是一个隐含所有其他权限的权限。
AllPermission() - Constructor for class java.security. AllPermission
创建一个新的AllPermission对象。
AllPermission(String, String) - Constructor for class java.security. AllPermission
创建一个新的AllPermission对象。
allProceduresAreCallable() - Method in interface java.sql. DatabaseMetaData
检索当前用户是否可以调用方法返回的所有过程 getProcedures 。
allProcesses() - Static method in interface java.lang. ProcessHandle
返回当前进程可见的所有进程的快照。
allRowsChanged() - Method in class javax.swing. DefaultRowSorter
当底层模型的内容完全改变时调用。
allRowsChanged() - Method in class javax.swing. RowSorter
当底层模型的内容完全改变时调用。
allSoundOff() - Method in interface javax.sound.midi. MidiChannel
立即关闭此通道上的所有声音，忽略保持踏板的状态和当前 Instrument的内部衰减速率。
allTablesAreSelectable() - Method in interface java.sql. DatabaseMetaData
检索当前用户是否可以使用 SELECT语句中方法 getTables返回的所有表。
allThreads() - Method in interface com.sun.jdi. VirtualMachine
返回当前正在运行的线程的列表。
allValues(String) - Method in interface jdk.incubator.http. HttpHeaders
返回给定的命名头的所有值的不可修改的列表。
ALPHABETIC_PRESENTATION_FORMS - Static variable in class java.lang. Character.UnicodeBlock
“字母表示形式”Unicode字符块的常量。
ALPHABETICAL - javax.xml.bind.annotation. XmlAccessOrder
类中的字段和属性的排序按照java.lang.String.compareTo（String anotherString）方法确定的字母顺序。
AlphaComposite - Class in java.awt
AlphaComposite类实现了基本的alpha合成规则，用于组合源和目标颜色，以实现图形和图像的混合和透明效果。
ALPHANUMERIC - javafx.scene.input. KeyCode
字母数字功能键的常数。
ALREADY_CREATED - jdk.net. SocketFlow.Status
具有相同属性的流已经存在。
AlreadyBound - Exception in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / AlreadyBound.java。
AlreadyBound() - Constructor for exception org.omg.CosNaming.NamingContextPackage. AlreadyBound
AlreadyBound(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage. AlreadyBound
AlreadyBoundException - Exception in java.nio.channels
尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
AlreadyBoundException - Exception in java.rmi
如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出一个 AlreadyBoundException 。
AlreadyBoundException() - Constructor for exception java.nio.channels. AlreadyBoundException
构造这个类的一个实例。
AlreadyBoundException() - Constructor for exception java.rmi. AlreadyBoundException
构造一个没有指定详细信息的 AlreadyBoundException 。
AlreadyBoundException(String) - Constructor for exception java.rmi. AlreadyBoundException
构造具有指定详细消息的 AlreadyBoundException 。
AlreadyBoundHelper - Class in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / AlreadyBoundHelper.java。
AlreadyBoundHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHelper
AlreadyBoundHolder - Class in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / AlreadyBoundHolder.java。
AlreadyBoundHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHolder
AlreadyBoundHolder(AlreadyBound) - Constructor for class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHolder
AlreadyConnectedException - Exception in java.nio.channels
尝试连接已连接的SocketChannel时 ，会引发未检查的异常。
AlreadyConnectedException() - Constructor for exception java.nio.channels. AlreadyConnectedException
构造这个类的一个实例。
alreadyNotified - Variable in class javax.management.monitor. Monitor
已过时。
相当于Monitor.alreadyNotifieds [0]。
alreadyNotifieds - Variable in class javax.management.monitor. Monitor
所选监视器错误已被通知。
ALT - javafx.scene.input. KeyCode
常数为 Alt键。
ALT - Static variable in class javax.swing.text.html. HTML.Attribute
属性“alt”
ALT_ANY - Static variable in class javafx.scene.input. KeyCombination
修饰符指定 alt键可以是向上还是向下。
ALT_DOWN - Static variable in class javafx.scene.input. KeyCombination
修饰符指定 alt键必须关闭。
ALT_DOWN_MASK - Static variable in class java.awt.event. InputEvent
Alt键扩展修饰符常数。
ALT_GRAPH - javafx.scene.input. KeyCode
AltGraph功能键的常数。
ALT_GRAPH_DOWN_MASK - Static variable in class java.awt.event. InputEvent
AltGraph键扩展修饰符常数。
ALT_GRAPH_MASK - Static variable in class java.awt.event. InputEvent
已过时。
建议使用ALT_GRAPH_DOWN_MASK和InputEvent.getModifiersEx()
ALT_MASK - Static variable in class java.awt.event. ActionEvent
alt修饰符。
ALT_MASK - Static variable in class java.awt. Event
已过时。
该标志表示事件发生时Alt键已关闭。
ALT_MASK - Static variable in class java.awt.event. InputEvent
已过时。
建议使用ALT_DOWN_MASK和InputEvent.getModifiersEx()
ALTERNATE - Static variable in class java.util. FormattableFlags
需要输出使用替代形式。
alternateAddTag - Variable in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction
HTML中的替代标签开始添加标签，如果没有找到parentTag，并找到alternateParentTag。
alternateParentTag - Variable in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction
如果没有找到parentTag，则在文档中检查的备用标签。
alternativeColumnFillVisibleProperty() - Method in class javafx.scene.chart. XYChart
如果为真，则替代垂直列将填充
alternativeRowFillVisibleProperty() - Method in class javafx.scene.chart. XYChart
如果为真，则替代的水平行将填充
ALTITUDE_REF_SEA_LEVEL - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSAltitudeRef”标签一起使用的值。
ALTITUDE_REF_SEA_LEVEL_REFERENCE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSAltitudeRef”标签一起使用的值。
altMetafactory(MethodHandles.Lookup, String, MethodType, Object...) - Static method in class java.lang.invoke. LambdaMetafactory
在适当的类型适配和参数的部分评估后，便于创建简单的“功能对象”，通过委派给所提供的MethodHandle来实现一个或多个接口。
altName - Variable in exception javax.naming. CannotProceedException
包含解析对象的名称，相对于上下文 altNameCtx 。
altNameCtx - Variable in exception javax.naming. CannotProceedException
包含指定 altName的上下文。
ALWAYS - java.time.format. SignStyle
样式总是输出符号，其中零将输出'+'。
ALWAYS - javafx.scene.control. ScrollPane.ScrollBarPolicy
表示应始终显示滚动条。
ALWAYS - javafx.scene.layout. Priority
布局区域将始终尝试增长（或缩小），与其他布局面积（或缩小）为一致的空间共享增加（或减小）。
ALWAYS - jdk.incubator.http. HttpClient.Redirect
总是重定向
ALWAYS_UPDATE - Static variable in class javax.swing.text. DefaultCaret
表示无论文档更新是否在事件分派主题上执行，插入符位置将 始终随文档更改相应更新。
alwaysOnTopProperty() - Method in class javafx.stage. Stage
定义这个 Stage是否保持在其他窗口的顶部。
AM - Static variable in class java.util. Calendar
Calendar.AM_PM字段的值表示从午夜到中午之前的一天中的一段时间。
AM_PM - Static variable in class java.text. DateFormat.Field
常数识别时间指示符（例如
AM_PM - Static variable in class java.util. Calendar
对于现场数 get和 set指示是否 HOUR是前或中午之后。
AM_PM_FIELD - Static variable in class java.text. DateFormat
AM_PM字段对齐的常用常数。
AmbientLight - Class in javafx.scene
定义环境光源对象。
AmbientLight() - Constructor for class javafx.scene. AmbientLight
使用默认的Color.WHITE光源创建一个新的 AmbientLight类的实例。
AmbientLight(Color) - Constructor for class javafx.scene. AmbientLight
使用指定的颜色创建一个新的 AmbientLight类的实例。
amountToStepByProperty() - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory
设置每步增加或减少的量。
amountToStepByProperty() - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory
设置每步增加或减少的量。
AMPERSAND - javafx.scene.input. KeyCode
常数为 Ampersand键。
AMPM_OF_DAY - java.time.temporal. ChronoField
今天下午。
analyze() - Method in class com.sun.source.util. JavacTask
完成所有分析。
ANALYZE - com.sun.source.util. TaskEvent.Kind
关于被分析错误的元素的事件。
analyzeCompletion(String) - Method in class jdk.jshell. SourceCodeAnalysis
给定一个输入字符串，找到第一个代码片段（一个语句，定义，导入或表达式），并评估它是否完整。
analyzeType(String, int) - Method in class jdk.jshell. SourceCodeAnalysis
推断给定表达式的类型。
ANATOLIAN_HIEROGLYPHS - java.lang. Character.UnicodeScript
Unicode脚本“安纳托利亚象形文字”。
ANATOLIAN_HIEROGLYPHS - Static variable in class java.lang. Character.UnicodeBlock
“安纳托利亚象形文字”Unicode字符块的常数。
ANCESTOR - Static variable in class com.sun.java.accessibility.util. EventID
映射到Swing Ancestor支持（即AncestorListener和AncestorEvent）
ANCESTOR_ADDED - Static variable in class javax.swing.event. AncestorEvent
祖先组件被添加到可见对象的层次结构（可见）中，并且正在显示。
ANCESTOR_MOVED - Static variable in class java.awt.event. HierarchyEvent
指示一个祖先的容器ID被移动了。
ANCESTOR_MOVED - Static variable in class javax.swing.event. AncestorEvent
祖先组件更改了屏幕上的位置。
ANCESTOR_REMOVED - Static variable in class javax.swing.event. AncestorEvent
祖先组件从可见对象（隐藏）的层次结构中删除，不再显示。
ANCESTOR_RESIZED - Static variable in class java.awt.event. HierarchyEvent
指示祖先的事件ID容器被调整大小。
ancestorAdded(AncestorEvent) - Method in interface javax.swing.event. AncestorListener
当源或其祖先被调用setVisible（true）或被添加到组件层次结构中时，被调用。
AncestorEvent - Class in javax.swing.event
向组件层级中的祖先发送的子组件的事件。
AncestorEvent(JComponent, int, Container, Container) - Constructor for class javax.swing.event. AncestorEvent
构造一个AncestorEvent对象，以识别祖先组件的显示状态的变化。
AncestorListener - Interface in javax.swing.event
AncestorListener接口，用于在JComponent或其祖先之一发生更改时支持通知。
ancestorMoved(HierarchyEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用ancestorMoved方法来处理ancestorMoved事件。
ancestorMoved(HierarchyEvent) - Method in class java.awt.event. HierarchyBoundsAdapter
当源的祖先移动时调用。
ancestorMoved(HierarchyEvent) - Method in interface java.awt.event. HierarchyBoundsListener
当源的祖先移动时调用。
ancestorMoved(AncestorEvent) - Method in interface javax.swing.event. AncestorListener
当源或其祖先被移动时调用。
ancestorRemoved(AncestorEvent) - Method in interface javax.swing.event. AncestorListener
当源或其祖先被调用setVisible（false）或被从组件层次结构中移除时，被调用。
ancestorResized(HierarchyEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的ancestorResized方法来处理ancestorResized事件。
ancestorResized(HierarchyEvent) - Method in class java.awt.event. HierarchyBoundsAdapter
调用源的祖先调整大小时。
ancestorResized(HierarchyEvent) - Method in interface java.awt.event. HierarchyBoundsListener
调用源的祖先调整大小时。
anchor - Variable in class java.awt. GridBagConstraints
当该组件小于其显示区域时使用该字段。
ANCHOR_SELECTION_PATH_PROPERTY - Static variable in class javax.swing. JTree
锚点选择路径的绑定属性名称。
anchorLocationProperty() - Method in class javafx.stage. PopupWindow
指定弹出式定位中使用的弹出式锚点。
AnchorPane - Class in javafx.scene.layout
AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。
AnchorPane() - Constructor for class javafx.scene.layout. AnchorPane
创建AnchorPane布局。
AnchorPane(Node...) - Constructor for class javafx.scene.layout. AnchorPane
与给定的孩子创建AnchorPane布局。
anchorProperty() - Method in class javafx.scene.control. TextInputControl
anchor的文字选择。
anchorXProperty() - Method in class javafx.stage. PopupWindow
指定屏幕上弹出锚点的x坐标。
anchorYProperty() - Method in class javafx.stage. PopupWindow
指定屏幕上弹出锚点的y坐标。
ANCIENT_GREEK_MUSICAL_NOTATION - Static variable in class java.lang. Character.UnicodeBlock
常规为“古希腊音乐符号”Unicode字符块。
ANCIENT_GREEK_NUMBERS - Static variable in class java.lang. Character.UnicodeBlock
常数为“古希腊数字”Unicode字符块。
ANCIENT_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
“古代符号”Unicode字符块的常数。
and(BigInteger) - Method in class java.math. BigInteger
返回值为 (this & val)的BigInteger。
and(BitSet) - Method in class java.util. BitSet
执行此参数位置位的此目标位设置的逻辑 AND 。
and(BiPredicate<? super T, ? super U>) - Method in interface java.util.function. BiPredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
and(DoublePredicate) - Method in interface java.util.function. DoublePredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
and(IntPredicate) - Method in interface java.util.function. IntPredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
and(LongPredicate) - Method in interface java.util.function. LongPredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
and(Predicate<? super T>) - Method in interface java.util.function. Predicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑AND。
and(ObservableBooleanValue) - Method in class javafx.beans.binding. BooleanExpression
创建一个新的BooleanExpression ，在这个BooleanExpression和ObservableBooleanValue执行条件AND操作。
and(ObservableBooleanValue, ObservableBooleanValue) - Static method in class javafx.beans.binding. Bindings
创建一个BooleanBinding ，它计算两个实例值为ObservableBooleanValue的条件AND操作。
and(QueryExp, QueryExp) - Static method in class javax.management. Query
返回一个查询表达式，它是两个其他查询表达式的连接。
AND - com.sun.source.tree. Tree.Kind
用于BinaryTree表示按位和逻辑“ & ”的& 。
AND - jdk.nashorn.api.tree. Tree.Kind
用于BinaryTree表示按位和逻辑“ & ”的& 。
AND_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于实例CompoundAssignmentTree代表按位和逻辑“和”分配&= 。
AND_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例CompoundAssignmentTree代表按位和逻辑“和”分配&= 。
andFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - Static method in class javax.swing. RowFilter
如果所有提供的过滤器都包含该条目，则返回一个 RowFilter ，其中包含条目。
andNot(BigInteger) - Method in class java.math. BigInteger
返回值为 (this & ~val)的BigInteger。
andNot(BitSet) - Method in class java.util. BitSet
清除此 BitSet其相应位在指定的 BitSet设置的所有位。
andThen(BiConsumer<? super T, ? super U>) - Method in interface java.util.function. BiConsumer
返回一个组合的 BiConsumer ，依次执行此操作，然后执行 after操作。
andThen(Consumer<? super T>) - Method in interface java.util.function. Consumer
返回一个组合的 Consumer ，按顺序执行此操作，然后执行 after操作。
andThen(DoubleConsumer) - Method in interface java.util.function. DoubleConsumer
返回一个组合的 DoubleConsumer ，依次执行此操作，然后执行 after操作。
andThen(DoubleUnaryOperator) - Method in interface java.util.function. DoubleUnaryOperator
返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
andThen(Function<? super R, ? extends V>) - Method in interface java.util.function. BiFunction
返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。
andThen(Function<? super R, ? extends V>) - Method in interface java.util.function. Function
返回一个组合函数，首先将该函数应用于其输入，然后将 after函数应用于结果。
andThen(IntConsumer) - Method in interface java.util.function. IntConsumer
返回一个组合的 IntConsumer ，依次执行此操作，然后执行 after操作。
andThen(IntUnaryOperator) - Method in interface java.util.function. IntUnaryOperator
返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
andThen(LongConsumer) - Method in interface java.util.function. LongConsumer
返回一个组合的 LongConsumer ，依次执行此操作，然后执行 after操作。
andThen(LongUnaryOperator) - Method in interface java.util.function. LongUnaryOperator
返回一个组合运算符，首先将该运算符应用于其输入，然后将 after运算符应用于结果。
angle(double, double) - Method in class javafx.geometry. Point2D
计算由该点表示的矢量与指定矢量之间的角度（以度为单位）。
angle(double, double, double) - Method in class javafx.geometry. Point3D
计算由该点表示的矢量与指定矢量之间的角度（以度为单位）。
angle(Point2D) - Method in class javafx.geometry. Point2D
计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
angle(Point2D, Point2D) - Method in class javafx.geometry. Point2D
计算三点之间的角度（以度为单位），此点作为顶点。
angle(Point3D) - Method in class javafx.geometry. Point3D
计算由该点表示的向量与由指定点表示的向量之间的角度（以度为单位）。
angle(Point3D, Point3D) - Method in class javafx.geometry. Point3D
计算三点之间的角度（以度为单位），此点作为顶点。
angleProperty() - Method in class javafx.scene.effect. MotionBlur
运动效果的角度，以度为单位。
angleProperty() - Method in class javafx.scene.transform. Rotate
定义以度为单位的旋转角度。
animate(Animation) - Method in class javafx.scene.chart. Chart
在动画完成后，在图形的每一帧上播放给定的动画图表。
animatedProperty() - Method in class javafx.scene.chart. Axis
当真实时，轴和其范围的任何更改将被动画化。
animatedProperty() - Method in class javafx.scene.chart. Chart
当真的任何数据变化将被动画。
animatedProperty() - Method in class javafx.scene.control. TitledPane
TitledPane的动画状态。
Animation - Class in javafx.animation
类 Animation提供了JavaFX运行时中使用的所有动画的核心功能。
Animation() - Constructor for class javafx.animation. Animation
构造函数为 Animation 。
Animation(double) - Constructor for class javafx.animation. Animation
构造函数为 Animation 。
Animation.Status - Enum in javafx.animation
可能状态为 status 。
AnimationTimer - Class in javafx.animation
AnimationTimer类允许创建一个定时器，它在每个帧处于活动状态时被调用。
AnimationTimer() - Constructor for class javafx.animation. AnimationTimer
创建一个新的计时器。
annotateClass(Class<?>) - Method in class java.io. ObjectOutputStream
子类可以实现此方法，以允许类数据存储在流中。
ANNOTATED_TYPE - com.sun.source.tree. Tree.Kind
用于表示注释类型的AnnotatedTypeTree的实例。
AnnotatedArrayType - Interface in java.lang.reflect
AnnotatedArrayType表示数组类型的潜在注释使用，其组件类型本身可以表示类型的注释使用。
AnnotatedConstruct - Interface in javax.lang.model
表示可以注释的构造。
AnnotatedElement - Interface in java.lang.reflect
表示当前在此VM中运行的程序的注释元素。
AnnotatedParameterizedType - Interface in java.lang.reflect
AnnotatedParameterizedType表示参数化类型的潜在注释使用，其类型参数本身可以表示类型的注释使用。
AnnotatedType - Interface in com.sun.javadoc
已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
AnnotatedType - Interface in java.lang.reflect
AnnotatedType表示当前在此VM中运行的程序中可能注释的类型的使用。
AnnotatedTypeTree - Interface in com.sun.source.tree
用于注释类型的树节点。
AnnotatedTypeVariable - Interface in java.lang.reflect
AnnotatedTypeVariable表示类型变量的潜在注释使用，其声明可能具有其自身表示注释类型使用的界限。
AnnotatedWildcardType - Interface in java.lang.reflect
AnnotatedWildcardType表示通配符类型参数的潜在注释使用，其上限或下限本身可以表示类型的注释使用。
annotateProxyClass(Class<?>) - Method in class java.io. ObjectOutputStream
子类可以实现这种方法来存储流中的自定义数据以及动态代理类的描述符。
Annotation - Class in java.text
如果属性具有注释特征，则Annotation对象用作文本属性值的包装器。
Annotation - Interface in java.lang.annotation
所有注释类型扩展的公共接口。
Annotation(Object) - Constructor for class java.text. Annotation
构造具有给定值的注释记录，可以为null。
ANNOTATION - com.sun.source.tree. Tree.Kind
用于表示声明注释的AnnotationTree的实例。
ANNOTATION_PROCESSING - com.sun.source.util. TaskEvent.Kind
关于整体注解处理的事件。
ANNOTATION_PROCESSING_ROUND - com.sun.source.util. TaskEvent.Kind
关于个别注解处理轮次的事件。
ANNOTATION_PROCESSOR_MODULE_PATH - javax.tools. StandardLocation
搜索包含注解处理器的模块的位置。
ANNOTATION_PROCESSOR_PATH - javax.tools. StandardLocation
搜索注释处理器的位置。
ANNOTATION_TYPE - com.sun.source.tree. Tree.Kind
用于表示注释类型的ClassTree的实例。
ANNOTATION_TYPE - java.lang.annotation. ElementType
注解类型声明
ANNOTATION_TYPE - javax.lang.model.element. ElementKind
注释类型。
ANNOTATION_TYPE_SUBKIND - jdk.jshell. Snippet.SubKind
注释接口声明。
AnnotationDesc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
AnnotationDesc.ElementValuePair - Interface in com.sun.javadoc
已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
AnnotationFormatError - Error in java.lang.annotation
当注释解析器尝试从类文件读取注释并确定注释格式错误时抛出。
AnnotationFormatError(String) - Constructor for error java.lang.annotation. AnnotationFormatError
构造一个新的 AnnotationFormatError具有指定的详细信息。
AnnotationFormatError(String, Throwable) - Constructor for error java.lang.annotation. AnnotationFormatError
构造一个新的 AnnotationFormatError具有指定的详细信息和原因。
AnnotationFormatError(Throwable) - Constructor for error java.lang.annotation. AnnotationFormatError
构造具有指定原因的新的 AnnotationFormatError和详细消息 (cause == null ? null : cause.toString()) （通常包含类和详细消息为 cause ）。
AnnotationMirror - Interface in javax.lang.model.element
表示注释。
annotations() - Method in interface com.sun.javadoc. AnnotatedType
已过时。
返回与此类型相关联的注释。
annotations() - Method in interface com.sun.javadoc. PackageDoc
已过时。
获取此包的注释。
annotations() - Method in interface com.sun.javadoc. Parameter
已过时。
获取此参数的注释。
annotations() - Method in interface com.sun.javadoc. ProgramElementDoc
已过时。
获取此程序元素的注释。
annotations() - Method in interface com.sun.javadoc. TypeVariable
已过时。
获取此程序元素的注释。
AnnotationTree - Interface in com.sun.source.tree
用于注释的树节点。
annotationType() - Method in interface com.sun.javadoc. AnnotationDesc
已过时。
返回此注释的注释类型。
annotationType() - Method in interface java.lang.annotation. Annotation
返回此注释的注释类型。
annotationType() - Method in exception java.lang.annotation. IncompleteAnnotationException
返回缺少元素的注释类型的Class对象。
AnnotationTypeDoc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
AnnotationTypeElementDoc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
AnnotationTypeMismatchException - Exception in java.lang.annotation
抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。
AnnotationTypeMismatchException(Method, String) - Constructor for exception java.lang.annotation. AnnotationTypeMismatchException
为指定的注释类型元素构造AnnotationTypeMismatchException，并找到数据类型。
annotationTypes() - Method in interface com.sun.javadoc. PackageDoc
已过时。
在此包中获取包含的注释类型。
AnnotationValue - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
AnnotationValue - Interface in javax.lang.model.element
表示注释类型元素的值。
AnnotationValueVisitor< R, P> - Interface in javax.lang.model.element
注释类型元素的值的访问者，使用访问者设计模式的变体。
ANONYMOUS - javax.lang.model.element. NestingKind
没有名字的类型
ANONYMOUS - javax.xml.ws.soap. AddressingFeature.Responses
指定仅使用匿名响应。
ANTIQUEWHITE - Static variable in class javafx.scene.paint. Color
颜色古色古香的白色，RGB值为＃FAEBD7
Any - Class in org.omg.CORBA
作为可以在IDL或任何IDL原语类型中描述的任何数据的容器。
Any() - Constructor for class org.omg.CORBA. Any
ANY - javafx.scene.input. KeyCombination.ModifierValue
常数，表示修饰键可以是向上还是向下。
ANY - javax.xml.xpath. XPathEvaluationResult.XPathResultType
任何类型，代表下面列出的其他5种类型中的任何一种。
ANY - Static variable in class javafx.concurrent. WorkerStateEvent
所有工作状态事件类型的常用超类型。
ANY - Static variable in class javafx.event. ActionEvent
所有动作事件类型的公共超类型。
ANY - Static variable in class javafx.event. Event
所有事件类型的公共超类型。
ANY - Static variable in class javafx.scene.control. CheckBoxTreeItem.TreeModificationEvent
所有树修改事件类型的常用超类型。
ANY - Static variable in class javafx.scene.control. DialogEvent
所有对话事件类型的常用超类型。
ANY - Static variable in class javafx.scene.control. ListView.EditEvent
所有编辑事件类型的公共超类型。
ANY - Static variable in class javafx.scene.control. ScrollToEvent
所有滚动到事件类型的常用超类型。
ANY - Static variable in class javafx.scene.control. SortEvent
所有排序事件类型的常用超类型。
ANY - Static variable in class javafx.scene.control. TableColumn.CellEditEvent
所有单元格编辑事件类型的公共超类型。
ANY - Static variable in class javafx.scene.control. TreeItem.TreeModificationEvent
所有树修改事件类型的常用超类型。
ANY - Static variable in class javafx.scene.control. TreeTableColumn.CellEditEvent
所有单元格编辑事件类型的公共超类型。
ANY - Static variable in class javafx.scene.control. TreeTableView.EditEvent
所有编辑事件类型的公共超类型。
ANY - Static variable in class javafx.scene.control. TreeView.EditEvent
所有编辑事件类型的公共超类型。
ANY - Static variable in class javafx.scene.input. ContextMenuEvent
所有上下文菜单事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. DragEvent
所有拖动事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. GestureEvent
所有手势的常用超类型。
ANY - Static variable in class javafx.scene.input. InputEvent
所有输入事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. InputMethodEvent
所有输入法事件类型的公共超类型。
ANY - Static variable in class javafx.scene.input. KeyEvent
所有关键事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. MouseDragEvent
所有鼠标事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. MouseEvent
所有鼠标事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. RotateEvent
所有旋转事件类型的公共超类型。
ANY - Static variable in class javafx.scene.input. ScrollEvent
所有滚动事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. SwipeEvent
所有滑动事件类型的常用超类型。
ANY - Static variable in class javafx.scene.input. TouchEvent
所有触摸事件类型的常用超类型。
ANY - Static variable in enum javafx.scene.input. TransferMode
数组包含所有传输模式。
ANY - Static variable in class javafx.scene.input. ZoomEvent
所有缩放事件类型的常用超类型。
ANY - Static variable in class javafx.scene.transform. TransformChangedEvent
所有变换事件类型的公共超类型。
ANY - Static variable in class javafx.scene.web. WebErrorEvent
所有 WebErrorEvent类型的常用超类型。
ANY - Static variable in class javafx.scene.web. WebEvent
所有Web事件类型的常用超类型。
ANY - Static variable in class javafx.stage. WindowEvent
所有窗口事件类型的常用超类型。
ANY - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于任何
ANY_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
此代码不代表特定类型。
ANY_UNORDERED_NODE_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是由单个节点定义并将被访问的节点集，如果节点集为空，则可以为 null 。
AnyHolder - Class in org.omg.CORBA
持有人 Any 。
AnyHolder() - Constructor for class org.omg.CORBA. AnyHolder
构造一个新的 AnyHolder对象，其 value字段初始化为 null 。
AnyHolder(Any) - Constructor for class org.omg.CORBA. AnyHolder
构造一个新 AnyHolder给定对象 Any对象。
anyMatch(DoublePredicate) - Method in interface java.util.stream. DoubleStream
返回此流的任何元素是否与提供的谓词匹配。
anyMatch(IntPredicate) - Method in interface java.util.stream. IntStream
返回此流的任何元素是否与提供的谓词匹配。
anyMatch(LongPredicate) - Method in interface java.util.stream. LongStream
返回此流的任何元素是否与提供的谓词匹配。
anyMatch(Predicate<? super T>) - Method in interface java.util.stream. Stream
返回此流的任何元素是否与提供的谓词匹配。
anyOf(CompletableFuture<?>...) - Static method in class java.util.concurrent. CompletableFuture
返回一个新的CompletableFuture，当任何一个给定的CompletableFutures完成时，完成相同的结果。
AnySeqHelper - Class in org.omg.CORBA
助手 AnySeq 。
AnySeqHelper - Class in org.omg.DynamicAny
org / omg / DynamicAny / AnySeqHelper.java。
AnySeqHelper() - Constructor for class org.omg.CORBA. AnySeqHelper
AnySeqHelper() - Constructor for class org.omg.DynamicAny. AnySeqHelper
AnySeqHolder - Class in org.omg.CORBA
持有人 AnySeq 。
AnySeqHolder() - Constructor for class org.omg.CORBA. AnySeqHolder
AnySeqHolder(Any[]) - Constructor for class org.omg.CORBA. AnySeqHolder
anySubString(AttributeValueExp, StringValueExp) - Static method in class javax.management. Query
返回一个表示字符串参数匹配约束的查询表达式。
API - jdk.javadoc.doclet. DocletEnvironment.ModuleMode
需要指示API级别的文档
APP_ABOUT - java.awt. Desktop.Action
代表一个AboutHandler
APP_EVENT_FOREGROUND - java.awt. Desktop.Action
表示AppForegroundListener
APP_EVENT_HIDDEN - java.awt. Desktop.Action
表示AppHiddenListener
APP_EVENT_REOPENED - java.awt. Desktop.Action
表示AppReopenedListener
APP_EVENT_SCREEN_SLEEP - java.awt. Desktop.Action
表示ScreenSleepListener
APP_EVENT_SYSTEM_SLEEP - java.awt. Desktop.Action
表示SystemSleepListener
APP_EVENT_USER_SESSION - java.awt. Desktop.Action
表示一个UserSessionListener
APP_HELP_VIEWER - java.awt. Desktop.Action
代表一个HelpViewer
APP_MENU_BAR - java.awt. Desktop.Action
表示菜单栏
APP_OPEN_FILE - java.awt. Desktop.Action
表示OpenFilesHandler
APP_OPEN_URI - java.awt. Desktop.Action
代表OpenURIHandler
APP_PREFERENCES - java.awt. Desktop.Action
表示PreferencesHandler
APP_PRINT_FILE - java.awt. Desktop.Action
表示PrintFilesHandler
APP_QUIT_HANDLER - java.awt. Desktop.Action
代表一个QuitHandler
APP_QUIT_STRATEGY - java.awt. Desktop.Action
代表一个QuitStrategy
APP_REQUEST_FOREGROUND - java.awt. Desktop.Action
表示requestForeground
APP_SUDDEN_TERMINATION - java.awt. Desktop.Action
代表突发事件
AppConfigurationEntry - Class in javax.security.auth.login
此类表示为 Configuration类中的 getAppConfigurationEntry(String appName)方法中指定的应用程序配置的单个 LoginModule条目。
AppConfigurationEntry(String, AppConfigurationEntry.LoginModuleControlFlag, Map<String, ?>) - Constructor for class javax.security.auth.login. AppConfigurationEntry
此类的默认构造函数。
AppConfigurationEntry.LoginModuleControlFlag - Class in javax.security.auth.login
此类表示 LoginModule是否需要，必要，有效或可选。
append(boolean) - Method in class java.lang. StringBuffer
append(boolean) - Method in class java.lang. StringBuilder
append(char) - Method in class java.io. CharArrayWriter
将指定的字符附加到此作者。
append(char) - Method in class java.io. PrintStream
将指定的字符附加到此输出流。
append(char) - Method in class java.io. PrintWriter
将指定的字符附加到此作者。
append(char) - Method in class java.io. StringWriter
将指定的字符附加到此作者。
append(char) - Method in class java.io. Writer
将指定的字符附加到此作者。
append(char) - Method in interface java.lang. Appendable
将指定的字符追加到此 Appendable 。
append(char) - Method in class java.lang. StringBuffer
append(char) - Method in class java.lang. StringBuilder
append(char) - Method in class java.nio. CharBuffer
将指定的字符追加到此缓冲区 （可选操作） 。
append(char[]) - Method in class java.lang. StringBuffer
append(char[]) - Method in class java.lang. StringBuilder
append(char[], int, int) - Method in class java.lang. StringBuffer
append(char[], int, int) - Method in class java.lang. StringBuilder
append(double) - Method in class java.lang. StringBuffer
append(double) - Method in class java.lang. StringBuilder
append(double[], MatrixType, int) - Method in class javafx.scene.transform. Affine
将数组指定的变换追加到此实例。
append(double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
将元素值指定的2D变换附加到此实例。
append(double, double, double, double, double, double, double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
将由元素值指定的变换附加到此实例。
append(float) - Method in class java.lang. StringBuffer
append(float) - Method in class java.lang. StringBuilder
append(int) - Method in class java.lang. StringBuffer
append(int) - Method in class java.lang. StringBuilder
append(long) - Method in class java.lang. StringBuffer
append(long) - Method in class java.lang. StringBuilder
append(PathIterator, boolean) - Method in class java.awt.geom. Path2D
将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
append(PathIterator, boolean) - Method in class java.awt.geom. Path2D.Double
将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
append(PathIterator, boolean) - Method in class java.awt.geom. Path2D.Float
将指定的PathIterator对象的几何图形附加到路径，可能将新几何体连接到具有线段的现有路径段。
append(Printable, PageFormat) - Method in class java.awt.print. Book
在这个 Book的末尾添加一个页面。
append(Printable, PageFormat, int) - Method in class java.awt.print. Book
追加 numPages页本月底 Book 。
append(Shape, boolean) - Method in class java.awt.geom. Path2D
将指定的 Shape对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
append(CharSequence) - Method in class java.io. CharArrayWriter
将指定的字符序列附加到此作者。
append(CharSequence) - Method in class java.io. OutputStreamWriter
append(CharSequence) - Method in class java.io. PrintStream
将指定的字符序列附加到此输出流。
append(CharSequence) - Method in class java.io. PrintWriter
将指定的字符序列附加到此作者。
append(CharSequence) - Method in class java.io. StringWriter
将指定的字符序列附加到此作者。
append(CharSequence) - Method in class java.io. Writer
将指定的字符序列附加到此作者。
append(CharSequence) - Method in interface java.lang. Appendable
将指定的字符序列追加到此 Appendable 。
append(CharSequence) - Method in class java.lang. StringBuffer
追加指定的 CharSequence到这个序列。
append(CharSequence) - Method in class java.lang. StringBuilder
append(CharSequence) - Method in class java.nio. CharBuffer
将指定的字符序列追加到此缓冲区 （可选操作） 。
append(CharSequence, int, int) - Method in class java.io. CharArrayWriter
将指定字符序列的子序列附加到此作者。
append(CharSequence, int, int) - Method in class java.io. OutputStreamWriter
append(CharSequence, int, int) - Method in class java.io. PrintStream
将指定字符序列的子序列附加到此输出流。
append(CharSequence, int, int) - Method in class java.io. PrintWriter
将指定字符序列的子序列附加到此作者。
append(CharSequence, int, int) - Method in class java.io. StringWriter
将指定字符序列的子序列附加到此作者。
append(CharSequence, int, int) - Method in class java.io. Writer
将指定字符序列的子序列附加到此作者。
append(CharSequence, int, int) - Method in interface java.lang. Appendable
将指定字符序列的子序列追加到此 Appendable 。
append(CharSequence, int, int) - Method in class java.lang. StringBuffer
append(CharSequence, int, int) - Method in class java.lang. StringBuilder
append(CharSequence, int, int) - Method in class java.nio. CharBuffer
将指定字符序列的子序列附加到此缓冲区 （可选操作） 。
append(Object) - Method in class java.lang. StringBuffer
append(Object) - Method in class java.lang. StringBuilder
append(String) - Method in class java.awt. TextArea
将给定的文本附加到文本区域的当前文本。
append(String) - Method in class java.lang. StringBuffer
append(String) - Method in class java.lang. StringBuilder
append(String) - Method in class javax.swing. JTextArea
将给定的文本附加到文档的末尾。
append(StringBuffer) - Method in class java.lang. StringBuffer
追加指定的 StringBuffer到这个序列。
append(StringBuffer) - Method in class java.lang. StringBuilder
追加指定的 StringBuffer到这个序列。
append(DateTimeFormatter) - Method in class java.time.format. DateTimeFormatterBuilder
将格式化程序的所有元素附加到构建器。
append(EventDispatcher) - Method in interface javafx.event. EventDispatchChain
将指定的 EventDispatcher追加到此链。
append(Transform) - Method in class javafx.scene.transform. Affine
将指定的变换附加到此实例。
append(View) - Method in class javax.swing.text. View
附加单个子视图。
APPEND - java.lang. ProcessBuilder.Redirect.Type
从 Redirect.appendTo(File)返回的重定向类型。
APPEND - java.nio.file. StandardOpenOption
如果文件打开 StandardOpenOption.WRITE访问，则字节将写入文件的末尾而不是开头。
APPEND_DATA - java.nio.file.attribute. AclEntryPermission
将数据附加到文件的权限。
Appendable - Interface in java.lang
可附加 char序列和值的对象。
appendChild(Node) - Method in class javax.imageio.metadata. IIOMetadataNode
将节点 newChild添加到此节点的子节点列表的末尾。
appendChild(Node) - Method in interface org.w3c.dom. Node
将节点 newChild添加到此节点的子节点列表的末尾。
appendChronologyId() - Method in class java.time.format. DateTimeFormatterBuilder
将时间序列ID（如“ISO”或“ThaiBuddhist”）附加到格式化程序。
appendChronologyText(TextStyle) - Method in class java.time.format. DateTimeFormatterBuilder
将年表名称附加到格式化程序。
appendCodePoint(int) - Method in class java.lang. StringBuffer
appendCodePoint(int) - Method in class java.lang. StringBuilder
appendData(String) - Method in interface org.w3c.dom. CharacterData
将字符串附加到节点的字符数据的末尾。
appendEvent(InputEvent) - Method in class java.awt.dnd. DragGestureRecognizer
通过此识别器在组件上注册的侦听器应记录被识别为通过该API组成拖放启动手势的一系列事件的一部分的所有事件。
appendFaultSubcode(QName) - Method in interface javax.xml.soap. SOAPFault
将子代码添加到此SOAPFault包含的子代码序列的 SOAPFault 。
appendFraction(TemporalField, int, int, boolean) - Method in class java.time.format. DateTimeFormatterBuilder
将日期时间字段的小数值附加到格式化程序。
appendGenericZoneText(TextStyle) - Method in class java.time.format. DateTimeFormatterBuilder
将泛型时区名称（如“太平洋时间”）附加到格式化程序。
appendGenericZoneText(TextStyle, Set<ZoneId>) - Method in class java.time.format. DateTimeFormatterBuilder
将泛型时区名称（如“太平洋时间”）附加到格式化程序。
appendInstant() - Method in class java.time.format. DateTimeFormatterBuilder
使用ISO-8601即时添加格式化程序，以三组格式化小数位数。
appendInstant(int) - Method in class java.time.format. DateTimeFormatterBuilder
使用ISO-8601即时使用格式化程序，可以控制小数位数。
appendLiteral(char) - Method in class java.time.format. DateTimeFormatterBuilder
在格式化程序中附加一个字符文字。
appendLiteral(String) - Method in class java.time.format. DateTimeFormatterBuilder
将一个字符串字面值附加到格式化程序。
appendLocalized(FormatStyle, FormatStyle) - Method in class java.time.format. DateTimeFormatterBuilder
将本地化的日期时间模式附加到格式化程序。
appendLocalizedOffset(TextStyle) - Method in class java.time.format. DateTimeFormatterBuilder
将本地化区域偏移量（如“GMT + 01：00”）附加到格式化程序。
appendMedium(String) - Method in interface org.w3c.dom.stylesheets. MediaList
添加介质 newMedium到列表的末尾。
appendOffset(String, String) - Method in class java.time.format. DateTimeFormatterBuilder
将区域偏移（如“+01：00”）附加到格式化程序。
appendOffsetId() - Method in class java.time.format. DateTimeFormatterBuilder
将区域偏移（如“+01：00”）附加到格式化程序。
appendOptional(DateTimeFormatter) - Method in class java.time.format. DateTimeFormatterBuilder
将一个格式化程序附加到构建器，该构建器可以格式化/解析。
appendParameterTypes(Class<?>...) - Method in class java.lang.invoke. MethodType
查找或创建具有其他参数类型的方法类型。
appendParameterTypes(List<Class<?>>) - Method in class java.lang.invoke. MethodType
查找或创建具有其他参数类型的方法类型。
appendPattern(String) - Method in class java.time.format. DateTimeFormatterBuilder
将指定模式定义的元素附加到构建器。
appendRemainingComponent(String) - Method in exception javax.naming. NamingException
将名称添加为剩余名称中的最后一个组件。
appendRemainingComponent(String) - Method in class javax.naming.spi. ResolveResult
将单个组件添加到剩余名称的末尾。
appendRemainingName(Name) - Method in exception javax.naming. NamingException
从“name”添加组件作为剩余名称中的最后一个组件。
appendRemainingName(Name) - Method in class javax.naming.spi. ResolveResult
将组件添加到剩余名称的末尾。
appendReplacement(StringBuffer, String) - Method in class java.util.regex. Matcher
实施非终端附加和替换步骤。
appendReplacement(StringBuilder, String) - Method in class java.util.regex. Matcher
实施非终端附加和替换步骤。
appendRotation(double) - Method in class javafx.scene.transform. Affine
将2D旋转追加到此实例。
appendRotation(double, double, double) - Method in class javafx.scene.transform. Affine
使用枢轴将2D旋转附加到此实例。
appendRotation(double, double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
将旋转追加到此实例。
appendRotation(double, double, double, double, Point3D) - Method in class javafx.scene.transform. Affine
将旋转追加到此实例。
appendRotation(double, Point2D) - Method in class javafx.scene.transform. Affine
使用枢轴将2D旋转附加到此实例。
appendRotation(double, Point3D, Point3D) - Method in class javafx.scene.transform. Affine
将旋转追加到此实例。
appendScale(double, double) - Method in class javafx.scene.transform. Affine
将2D刻度追加到此实例。
appendScale(double, double, double) - Method in class javafx.scene.transform. Affine
追加比例到这个实例。
appendScale(double, double, double, double) - Method in class javafx.scene.transform. Affine
将具有枢轴的2D刻度附加到此实例。
appendScale(double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
使用pivot附加到此实例的缩放。
appendScale(double, double, double, Point3D) - Method in class javafx.scene.transform. Affine
使用pivot附加到此实例的缩放。
appendScale(double, double, Point2D) - Method in class javafx.scene.transform. Affine
将具有枢轴的2D刻度附加到此实例。
appendShear(double, double) - Method in class javafx.scene.transform. Affine
附加剪切到这个实例。
appendShear(double, double, double, double) - Method in class javafx.scene.transform. Affine
用枢轴附加剪切到这个实例。
appendShear(double, double, Point2D) - Method in class javafx.scene.transform. Affine
用枢轴附加剪切到这个实例。
appendSVGPath(String) - Method in class javafx.scene.canvas. GraphicsContext
将SVG路径字符串附加到当前路径。
appendTail(StringBuffer) - Method in class java.util.regex. Matcher
实施终端附加和替换步骤。
appendTail(StringBuilder) - Method in class java.util.regex. Matcher
实施终端附加和替换步骤。
appendText(String) - Method in class java.awt. TextArea
已过时。
从JDK 1.1版开始，由append(String)替代。
appendText(String) - Method in class javafx.scene.control. TextInputControl
向内容追加一串字符。
appendText(TemporalField) - Method in class java.time.format. DateTimeFormatterBuilder
使用全文样式将日期时间字段的文本附加到格式化程序。
appendText(TemporalField, TextStyle) - Method in class java.time.format. DateTimeFormatterBuilder
将日期时间字段的文本附加到格式化程序。
appendText(TemporalField, Map<Long, String>) - Method in class java.time.format. DateTimeFormatterBuilder
使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。
appendTo(File) - Static method in class java.lang. ProcessBuilder.Redirect
返回重定向以附加到指定的文件。
appendToBootstrapClassLoaderSearch(JarFile) - Method in interface java.lang.instrument. Instrumentation
指定具有由引导类加载器定义的检测类的JAR文件。
appendToSystemClassLoaderSearch(JarFile) - Method in interface java.lang.instrument. Instrumentation
指定具有由系统类加载器定义的检测类的JAR文件。
appendTranslation(double, double) - Method in class javafx.scene.transform. Affine
将2D翻译附加到此实例。
appendTranslation(double, double, double) - Method in class javafx.scene.transform. Affine
将翻译附加到此实例。
appendValue(TemporalField) - Method in class java.time.format. DateTimeFormatterBuilder
使用正常输出样式将日期时间字段的值附加到格式化程序。
appendValue(TemporalField, int) - Method in class java.time.format. DateTimeFormatterBuilder
使用固定宽度零填充方法将日期时间字段的值附加到格式化程序。
appendValue(TemporalField, int, int, SignStyle) - Method in class java.time.format. DateTimeFormatterBuilder
将日期时间字段的值追加到格式化程序，以提供对格式化的完全控制。
appendValueReduced(TemporalField, int, int, int) - Method in class java.time.format. DateTimeFormatterBuilder
将日期时间字段的减小值附加到格式化程序。
appendValueReduced(TemporalField, int, int, ChronoLocalDate) - Method in class java.time.format. DateTimeFormatterBuilder
将日期时间字段的减小值附加到格式化程序。
appendZoneId() - Method in class java.time.format. DateTimeFormatterBuilder
将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。
appendZoneOrOffsetId() - Method in class java.time.format. DateTimeFormatterBuilder
使用最佳可用区域ID将时区ID（例如“欧洲/巴黎”或“+02：00”）附加到格式化程序。
appendZoneRegionId() - Method in class java.time.format. DateTimeFormatterBuilder
将时区区域ID（如“Europe / Paris”）附加到格式化程序，如果是 ZoneOffset ，则拒绝该区域ID。
appendZoneText(TextStyle) - Method in class java.time.format. DateTimeFormatterBuilder
将时区名称（如“英国夏令时”）附加到格式化程序。
appendZoneText(TextStyle, Set<ZoneId>) - Method in class java.time.format. DateTimeFormatterBuilder
将时区名称（如“英国夏令时”）附加到格式化程序。
AppEvent - Class in java.awt.desktop
AppEvent被发送到安装在Desktop上的监听器和处理程序。
AppForegroundEvent - Class in java.awt.desktop
当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。
AppForegroundEvent() - Constructor for class java.awt.desktop. AppForegroundEvent
构造一个 AppForegroundEvent
AppForegroundListener - Interface in java.awt.desktop
当应用程序成为前台应用程序，何时不再是前台应用程序，实施者会收到通知。
appHidden(AppHiddenEvent) - Method in interface java.awt.desktop. AppHiddenListener
被称为应用程序被隐藏。
AppHiddenEvent - Class in java.awt.desktop
应用程序隐藏或显示时发送的事件。
AppHiddenEvent() - Constructor for class java.awt.desktop. AppHiddenEvent
构造一个 AppHiddenEvent
AppHiddenListener - Interface in java.awt.desktop
当应用程序被用户隐藏或显示时，将通知实施者。
applet - Variable in class javax.swing.text.html.parser. DTD
与applet对应的元素。
Applet - Class in java.applet
已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
Applet() - Constructor for class java.applet. Applet
已过时。
构建一个新的Applet。
APPLET - Static variable in interface javax.jnlp. DownloadService2
匹配applets在 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
APPLET - Static variable in interface javax.naming. Context
已过时。
在构建初始上下文时，将忽略具有此名称的环境属性。 此常量最初用作属性名称，以在创建初始上下文时指定Applet以从中检索参数。 目前需要传递给初始上下文的任何applet属性都应该复制到环境哈希表中：
   Hashtable env = new Hashtable(); env.put(Context.INITIAL_CONTEXT_FACTORY, ((Applet) this).getParameter(Context.INITIAL_CONTEXT_FACTORY)); env.put(Context.PROVIDER_URL, ((Applet) this).getParameter(Context.PROVIDER_URL)); // ... other properties ... Context ctx = new InitialContext(env);
APPLET - Static variable in class javax.swing.text.html. HTML.Tag
标记<applet>
Applet.AccessibleApplet - Class in java.applet
已过时。
该类实现对 Applet类的可访问性支持。
AppletContext - Interface in java.applet
已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
AppletInitializer - Interface in java.beans
已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
appletResize(int, int) - Method in interface java.applet. AppletStub
已过时。
当applet想要调整大小时调用。
AppletStub - Interface in java.applet
已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
Application - Class in javafx.application
JavaFX应用程序扩展的应用程序类。
Application() - Constructor for class javafx.application. Application
构造一个新的 Application实例。
APPLICATION - javax.annotation. Resource.AuthenticationType
APPLICATION - javax.xml.ws.handler. MessageContext.Scope
应用可见性
APPLICATION - Static variable in interface javax.jnlp. DownloadService2
匹配应用程序在 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
APPLICATION_EXCLUDE - java.awt. Dialog.ModalExclusionType
APPLICATION_EXCLUDE表示顶级窗口不会被任何应用程序模式对话框阻止。
APPLICATION_MODAL - java.awt. Dialog.ModalityType
一个 APPLICATION_MODAL对话框阻止来自同一个Java应用程序的所有顶级窗口，除了它们自己的子层次结构。
APPLICATION_MODAL - javafx.stage. Modality
定义阻止事件传递到任何其他应用程序窗口的模态窗口。
Application.Parameters - Class in javafx.application
封装一组应用程序的参数。
ApplicationException - Exception in org.omg.CORBA.portable
此类用于报告ORB和存根之间的应用程序级异常。
ApplicationException(String, InputStream) - Constructor for exception org.omg.CORBA.portable. ApplicationException
从异常的CORBA存储库ID中构造一个ApplicationException，以及可以读取异常数据作为参数的输入流。
applies(Styleable) - Method in class javafx.css. CompoundSelector
applies(Styleable) - Method in class javafx.css. Selector
applies(Styleable) - Method in class javafx.css. SimpleSelector
applies(Styleable, Set<PseudoClass>[], int) - Method in class javafx.css. CompoundSelector
applies(Styleable, Set<PseudoClass>[], int) - Method in class javafx.css. Selector
applies(Styleable, Set<PseudoClass>[], int) - Method in class javafx.css. SimpleSelector
apply(double) - Method in interface java.util.function. DoubleFunction
将此函数应用于给定的参数。
apply(int) - Method in interface java.util.function. IntFunction
将此函数应用于给定的参数。
apply(int, HttpHeaders) - Method in interface jdk.incubator.http. HttpResponse.BodyHandler
考虑到给定的响应状态代码和标题，返回一个BodyProcessor 。
apply(long) - Method in interface java.util.function. LongFunction
将此函数应用于给定的参数。
apply(ObjectName) - Method in class javax.management. AttributeValueExp
将 AttributeValueExp应用于MBean。
apply(ObjectName) - Method in class javax.management. ObjectName
测试这个ObjectName（可能是一个模式）是否匹配另一个ObjectName。
apply(ObjectName) - Method in interface javax.management. QueryExp
在MBean上应用QueryExp。
apply(ObjectName) - Method in class javax.management. StringValueExp
在MBean上应用ValueExp。
apply(ObjectName) - Method in interface javax.management. ValueExp
在MBean上应用ValueExp。
apply(T) - Method in interface java.util.function. Function
将此函数应用于给定的参数。
apply(T, U) - Method in interface java.util.function. BiFunction
将此函数应用于给定的参数。
APPLY - javafx.scene.control. ButtonBar.ButtonData
“应用”按钮的标签。
APPLY - Static variable in class javafx.scene.control. ButtonType
预先定义的ButtonType显示“应用”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.APPLY 。
APPLY_REVERB - Static variable in class javax.sound.sampled. BooleanControl.Type
表示是否将混响应用于线路的控件。
applyAsDouble(double) - Method in interface java.util.function. DoubleUnaryOperator
将此运算符应用于给定的操作数。
applyAsDouble(double, double) - Method in interface java.util.function. DoubleBinaryOperator
将此运算符应用于给定的操作数。
applyAsDouble(int) - Method in interface java.util.function. IntToDoubleFunction
将此函数应用于给定的参数。
applyAsDouble(long) - Method in interface java.util.function. LongToDoubleFunction
将此函数应用于给定的参数。
applyAsDouble(T) - Method in interface java.util.function. ToDoubleFunction
将此函数应用于给定的参数。
applyAsDouble(T, U) - Method in interface java.util.function. ToDoubleBiFunction
将此函数应用于给定的参数。
applyAsInt(double) - Method in interface java.util.function. DoubleToIntFunction
将此函数应用于给定的参数。
applyAsInt(int) - Method in interface java.util.function. IntUnaryOperator
将此运算符应用于给定的操作数。
applyAsInt(int, int) - Method in interface java.util.function. IntBinaryOperator
将此运算符应用于给定的操作数。
applyAsInt(long) - Method in interface java.util.function. LongToIntFunction
将此函数应用于给定的参数。
applyAsInt(T) - Method in interface java.util.function. ToIntFunction
将此函数应用于给定的参数。
applyAsInt(T, U) - Method in interface java.util.function. ToIntBiFunction
将此函数应用于给定的参数。
applyAsLong(double) - Method in interface java.util.function. DoubleToLongFunction
将此函数应用于给定的参数。
applyAsLong(int) - Method in interface java.util.function. IntToLongFunction
将此函数应用于给定的参数。
applyAsLong(long) - Method in interface java.util.function. LongUnaryOperator
将此运算符应用于给定的操作数。
applyAsLong(long, long) - Method in interface java.util.function. LongBinaryOperator
将此运算符应用于给定的操作数。
applyAsLong(T) - Method in interface java.util.function. ToLongFunction
将此函数应用于给定的参数。
applyAsLong(T, U) - Method in interface java.util.function. ToLongBiFunction
将此函数应用于给定的参数。
applyComponentOrientation(ComponentOrientation) - Method in class java.awt. Component
设置此组件的 ComponentOrientation属性及其中包含的所有组件。
applyComponentOrientation(ComponentOrientation) - Method in class java.awt. Container
设置此容器的 ComponentOrientation属性及其中包含的所有组件。
applyComponentOrientation(ComponentOrientation) - Method in class javax.swing. JMenu
设置此菜单的 ComponentOrientation属性及其中包含的所有组件。
applyCss() - Method in class javafx.scene. Node
如果需要，将样式应用于此节点及其子节点（如果有）。
applyEffect(Effect) - Method in class javafx.scene.canvas. GraphicsContext
将给定的效果应用于画布的整个边界，并将结果存储回同一个画布。
applyLocalizedPattern(String) - Method in class java.text. DecimalFormat
将给定的模式应用于此Format对象。
applyLocalizedPattern(String) - Method in class java.text. SimpleDateFormat
将给定的本地化模式字符串应用于此日期格式。
applyPattern(String) - Method in class java.text. ChoiceFormat
设置模式。
applyPattern(String) - Method in class java.text. DecimalFormat
将给定的模式应用于此Format对象。
applyPattern(String) - Method in class java.text. MessageFormat
设置此消息格式使用的模式。
applyPattern(String) - Method in class java.text. SimpleDateFormat
将给定的模式字符串应用于此日期格式。
applyPropertyChange(PropertyChangeEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
通知 LayerUI当它的任何一个属性被更改，并允许更新每 JLayer这个 LayerUI实例被设置为。
applyResourceBundle(String) - Method in class java.awt. Window
已过时。
截至J2SE 1.4，由Component.applyComponentOrientation替代。
applyResourceBundle(ResourceBundle) - Method in class java.awt. Window
已过时。
截至J2SE 1.4，由Component.applyComponentOrientation替代。
applyStyle(StyleOrigin, Boolean) - Method in class javafx.css. StyleableBooleanProperty
这个方法从CSS代码调用来设置属性的值。
applyStyle(StyleOrigin, Number) - Method in class javafx.css. StyleableDoubleProperty
这个方法从CSS代码调用来设置属性的值。
applyStyle(StyleOrigin, Number) - Method in class javafx.css. StyleableFloatProperty
这个方法从CSS代码调用来设置属性的值。
applyStyle(StyleOrigin, Number) - Method in class javafx.css. StyleableIntegerProperty
这个方法从CSS代码调用来设置属性的值。
applyStyle(StyleOrigin, Number) - Method in class javafx.css. StyleableLongProperty
这个方法从CSS代码调用来设置属性的值。
applyStyle(StyleOrigin, String) - Method in class javafx.css. StyleableStringProperty
这个方法从CSS代码调用来设置属性的值。
applyStyle(StyleOrigin, T) - Method in class javafx.css. StyleableObjectProperty
这个方法从CSS代码调用来设置属性的值。
applyStyle(StyleOrigin, T) - Method in interface javafx.css. StyleableProperty
这个方法从CSS代码调用来设置属性的值。
applyToEither(CompletionStage<? extends T>, Function<? super T, U>) - Method in class java.util.concurrent. CompletableFuture
applyToEither(CompletionStage<? extends T>, Function<? super T, U>) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的函数的参数。
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>) - Method in class java.util.concurrent. CompletableFuture
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供函数的参数。
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>, Executor) - Method in class java.util.concurrent. CompletableFuture
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>, Executor) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用提供的执行器执行，其中相应的结果作为参数提供给函数。
appMovedToBackground(AppForegroundEvent) - Method in interface java.awt.desktop. AppForegroundListener
当应用程序成为后台应用程序并且另一个应用程序成为前台应用程序时调用。
appRaisedToForeground(AppForegroundEvent) - Method in interface java.awt.desktop. AppForegroundListener
当应用程序成为前台应用程序时调用。
appRandom - Variable in class java.security. SignatureSpi
应用指定的随机源。
appReopened(AppReopenedEvent) - Method in interface java.awt.desktop. AppReopenedListener
当应用程序重新打开时调用
AppReopenedEvent - Class in java.awt.desktop
当应用程序被要求重新打开时发送事件。
AppReopenedEvent() - Constructor for class java.awt.desktop. AppReopenedEvent
构造一个 AppReopenedEvent
AppReopenedListener - Interface in java.awt.desktop
当应用程序被要求再次打开时，实施者会收到通知。
APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
识别助记符的更改（yes，ok）按钮。
APPROVE_BUTTON_TEXT_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
标识批准文本的更改（是，确定）按钮。
APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
标识批准（是，确定）按钮的工具提示文本中的更改。
APPROVE_OPTION - Static variable in class javax.swing. JFileChooser
如果批准（yes，ok），则返回值。
APPROVE_SELECTION - Static variable in class javax.swing. JFileChooser
批准当前选择的指令（与按yes或ok相同）。
approveSelection() - Method in class javax.swing. JFileChooser
当用户点击“批准”按钮（默认情况下标记为“打开”或“保存”）时，由用户名称调用。
ApproveSelectionAction() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.ApproveSelectionAction
构造一个 ApproveSelectionAction 。
appUnhidden(AppHiddenEvent) - Method in interface java.awt.desktop. AppHiddenListener
当隐藏的应用程序再次显示（但不一定被带到前台）时调用。
APRIL - java.time. Month
4月份的单身实例，30天。
APRIL - Static variable in class java.util. Calendar
Calendar.MONTH字段的价值表示今年第四个月在公历和朱利安日历。
APRIL - Static variable in class javax.xml.datatype. DatatypeConstants
一年的第四个月的价值。
AQUA - Static variable in class javafx.scene.paint. Color
颜色水彩，RGB值为＃00FFFF
AQUAMARINE - Static variable in class javafx.scene.paint. Color
RGB值为＃7FFFD4的彩色海蓝宝石
ARABIC - java.awt.font. NumericShaper.Range
阿拉伯语范围与阿拉伯语 - 印度数字。
ARABIC - java.lang. Character.UnicodeScript
Unicode脚本“阿拉伯语”。
ARABIC - Static variable in class java.awt.font. NumericShaper
标识ARABIC范围和十进制基数。
ARABIC - Static variable in class java.lang. Character.UnicodeBlock
“阿拉伯语”Unicode字符块的常量。
ARABIC_EXTENDED_A - Static variable in class java.lang. Character.UnicodeBlock
“阿拉伯语扩展A”Unicode字符块的常量。
ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
常数为“阿拉伯数学字母符号”Unicode字符块。
ARABIC_PRESENTATION_FORMS_A - Static variable in class java.lang. Character.UnicodeBlock
“阿拉伯文表达式A”Unicode字符块的常量。
ARABIC_PRESENTATION_FORMS_B - Static variable in class java.lang. Character.UnicodeBlock
“阿拉伯语表达式B”Unicode字符块的常量。
ARABIC_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“阿拉伯语补充”Unicode字符块的常量。
arc(double, double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
将路径元素添加到当前路径以创建使用欧几里德度数的弧。
Arc - Class in javafx.scene.shape
所述 Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND ）。
Arc() - Constructor for class javafx.scene.shape. Arc
创建一个空的实例Arc。
Arc(double, double, double, double, double, double) - Constructor for class javafx.scene.shape. Arc
创建一个新的Arc实例。
Arc2D - Class in java.awt.geom
Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或 PIE ）。
Arc2D() - Constructor for class java.awt.geom. Arc2D
这是一个无法直接实例化的抽象类。
Arc2D(int) - Constructor for class java.awt.geom. Arc2D
这是一个无法直接实例化的抽象类。
Arc2D.Double - Class in java.awt.geom
该类定义了 double精度中指定的弧。
Arc2D.Float - Class in java.awt.geom
此类定义了 float精度中指定的弧。
archeight - Variable in class java.awt.geom. RoundRectangle2D.Double
从角落圆弧的高度。
archeight - Variable in class java.awt.geom. RoundRectangle2D.Float
从角落圆弧的高度。
arcHeightProperty() - Method in class javafx.scene.shape. Rectangle
定义矩形四角的圆弧的垂直直径。
ARCHIVE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“档案”
arcTo(double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
将段添加到当前路径以创建弧。
ArcTo - Class in javafx.scene.shape
一个路径元素，它使用指定的半径从前一个坐标到指定的x和y坐标形成弧。
ArcTo() - Constructor for class javafx.scene.shape. ArcTo
创建一个空的ArcTo实例。
ArcTo(double, double, double, double, double, boolean, boolean) - Constructor for class javafx.scene.shape. ArcTo
创建一个新的ArcTo实例。
ArcType - Enum in javafx.scene.shape
ArcType指定Arc对象的关闭类型。
arcwidth - Variable in class java.awt.geom. RoundRectangle2D.Double
从角落圆弧的宽度。
arcwidth - Variable in class java.awt.geom. RoundRectangle2D.Float
从角落圆弧的宽度。
arcWidthProperty() - Method in class javafx.scene.shape. Rectangle
定义矩形四角的圆弧的水平直径。
Area - Class in java.awt.geom
一个 Area对象存储和操纵二维空间的封闭区域的与分辨率无关的描述。
Area() - Constructor for class java.awt.geom. Area
创建空区域的默认构造函数。
Area(Shape) - Constructor for class java.awt.geom. Area
Area类从指定的Shape对象创建一个区域几何。
AREA - Static variable in class javax.swing.text.html. HTML.Tag
标签<area>
AreaAveragingScaleFilter - Class in java.awt.image
一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。
AreaAveragingScaleFilter(int, int) - Constructor for class java.awt.image. AreaAveragingScaleFilter
构造一个AreaAveragingScaleFilter，可以根据width和height参数指定的其源图像的像素进行缩放。
AreaChart< X, Y> - Class in javafx.scene.chart
AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。
AreaChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. AreaChart
用给定轴构建新的区域图
AreaChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>) - Constructor for class javafx.scene.chart. AreaChart
使用给定的轴和数据构建新的区域图
areExtraMouseButtonsEnabled() - Method in class java.awt. Toolkit
报告是否允许来自额外的鼠标按钮的事件被处理并发布到 EventQueue 。
areFieldsSet - Variable in class java.util. Calendar
如果 fields[]与当前设置的时间同步， fields[]真。
areFocusTraversalKeysSet(int) - Method in class java.awt. Component
返回是否为此组件显式定义了给定焦点遍历操作的聚焦遍历键集。
areFocusTraversalKeysSet(int) - Method in class java.awt. Container
返回是否为此容器显式定义了给定焦点遍历操作的聚焦遍历键集。
areNew - Variable in class javax.swing.event. TreeSelectionEvent
对于每个路径，标识该路径实际上是新的。
arePathsContiguous(TreePath[]) - Method in class javax.swing.tree. DefaultTreeSelectionModel
如果路径是连续的，或者该对象没有RowMapper，则返回true。
areTablesSet() - Method in class javax.imageio.plugins.jpeg. JPEGImageReadParam
如果表当前设置，则返回 true 。
areTablesSet() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam
如果表当前设置，则返回 true 。
arg - Variable in class java.awt. Event
已过时。
事件的任意论证。
ARG_IN - Interface in org.omg.CORBA
表示调用的“input”参数，这意味着参数正在从客户机传递到服务器。
ARG_INOUT - Interface in org.omg.CORBA
在调用中表示用于输入和输出的参数，这意味着该参数是从客户端传递到服务器，然后从服务器传回到客户端。
ARG_OUT - Interface in org.omg.CORBA
一个常量，表示一个调用的“输出”参数，意味着该参数正在从服务器传递给客户端。
argument - Variable in class org.omg.Dynamic. Parameter
ARGUMENT - Static variable in class java.text. MessageFormat.Field
常量标识从传入 formatToCharacterIterator的参数生成的消息的一部分。
argumentNames() - Method in exception com.sun.jdi.connect. IllegalConnectorArgumentsException
返回一个包含无效或不一致参数的名称的 List 。
arguments() - Method in interface com.sun.jdi. 方法
返回一个列表，其中包含声明为此方法参数的每个LocalVariable 。
arguments() - Method in interface java.lang. ProcessHandle.Info
返回进程参数的Strings数组。
arguments() - Method in class org.omg.CORBA. Request
检索包含要调用方法的参数的 NVList对象。
arguments() - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
返回传递给 ORB.init的参数。
arguments() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
返回一个 Parameter对象的数组，其中包含要调用的操作的参数。
arguments(NVList) - Method in class org.omg.CORBA. ServerRequest
指定方法参数类型并检索“in”和“inout”参数值。
argumentTypeNames() - Method in interface com.sun.jdi. 方法
返回一个包含此方法的每个形式参数类型的文本表示的列表。
argumentTypes() - Method in interface com.sun.jdi. 方法
返回一个包含此方法的每个形式参数类型的列表。
ARGV - Static variable in interface javax.script. ScriptEngine
用于将位置参数数组传递给脚本的命名值的保留键。
ArithmeticException - Exception in java.lang
抛出异常算术条件时抛出。
ArithmeticException() - Constructor for exception java.lang. ArithmeticException
构造一个没有详细消息的 ArithmeticException 。
ArithmeticException(String) - Constructor for exception java.lang. ArithmeticException
构造具有指定详细消息的 ArithmeticException 。
arm() - Method in class javafx.scene.control. ButtonBase
按下按钮。
arm() - Method in class javafx.scene.control. ComboBoxBase
武装ComboBox。
ARMED - Static variable in class javax.accessibility. AccessibleState
表示对象已布防。
ARMED - Static variable in class javax.swing. DefaultButtonModel
标识位掩码中的“布防”位，这表示部分承诺选择/触发按钮。
armedProperty() - Method in class javafx.scene.control. ButtonBase
表示该按钮已被“布防”，使得鼠标释放将导致按钮的动作被调用。
armedProperty() - Method in class javafx.scene.control. ComboBoxBase
表示ComboBox已被“布防”，使得鼠标释放将导致ComboBox ComboBoxBase.show()方法被调用。
ARMENIAN - java.lang. Character.UnicodeScript
Unicode脚本“亚美尼亚”。
ARMENIAN - Static variable in class java.lang. Character.UnicodeBlock
“亚美尼亚”Unicode字符块的常数。
arrangeGrid(Container) - Method in class java.awt. GridBagLayout
排出电网。
ArrangeGrid(Container) - Method in class java.awt. GridBagLayout
此方法已过时，仅供后向兼容; 新代码应该调用arrangeGrid 。
array - Variable in class javax.swing.text. Segment
这是包含感兴趣的文本的数组。
array() - Method in class java.nio. Buffer
返回支持此缓冲区的数组 （可选操作） 。
array() - Method in class java.nio. ByteBuffer
返回支持此缓冲区的字节数组 （可选操作） 。
array() - Method in class java.nio. CharBuffer
返回支持此缓冲区的char数组 （可选操作） 。
array() - Method in class java.nio. DoubleBuffer
返回支持此缓冲区的双数组 （可选操作） 。
array() - Method in class java.nio. FloatBuffer
返回支持此缓冲区的float数组 （可选操作） 。
array() - Method in class java.nio. IntBuffer
返回支持此缓冲区的int数组 （可选操作） 。
array() - Method in class java.nio. LongBuffer
返回支持此缓冲区的长数组 （可选操作） 。
array() - Method in class java.nio. ShortBuffer
返回支持此缓冲区的短数组 （可选操作） 。
Array - Class in java.lang.reflect
Array类提供静态方法来动态创建和访问Java数组。
Array - Interface in java.sql
在Java编程语言中的映射为SQL类型 ARRAY 。
ARRAY - java.sql. JDBCType
标识通用SQL类型 ARRAY 。
ARRAY - javax.lang.model.type. TypeKind
数组类型。
ARRAY - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 ARRAY 。
ARRAY_ACCESS - com.sun.source.tree. Tree.Kind
用于ArrayAccessTree的实例。
ARRAY_ACCESS - jdk.nashorn.api.tree. Tree.Kind
用于ArrayAccessTree的实例。
ARRAY_COMPONENT_DELIMITER - Static variable in class javafx.fxml. FXMLLoader
数组的分隔符作为值。
ARRAY_LITERAL - jdk.nashorn.api.tree. Tree.Kind
用于ArrayLiteralTree的实例。
ARRAY_TYPE - com.sun.source.tree. Tree.Kind
用于ArrayTypeTree的实例。
ArrayAccessTree - Interface in com.sun.source.tree
数组访问表达式的树节点。
ArrayAccessTree - Interface in jdk.nashorn.api.tree
数组访问表达式的树节点。
ArrayBlockingQueue< E> - Class in java.util.concurrent
一个有限的blocking queue由数组支持。
ArrayBlockingQueue(int) - Constructor for class java.util.concurrent. ArrayBlockingQueue
创建具有给定（固定）容量和默认访问策略的 ArrayBlockingQueue 。
ArrayBlockingQueue(int, boolean) - Constructor for class java.util.concurrent. ArrayBlockingQueue
创建具有给定（固定）容量和指定访问策略的 ArrayBlockingQueue 。
ArrayBlockingQueue(int, boolean, Collection<? extends E>) - Constructor for class java.util.concurrent. ArrayBlockingQueue
创建具有给定（固定）容量的 ArrayBlockingQueue ，指定的访问策略，最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
ArrayChangeListener< T extends ObservableArray< T>> - Interface in javafx.collections
接收ObservableArray更改通知的接口。
arrayConstructor(Class<?>) - Static method in class java.lang.invoke. MethodHandles
生成构造所需类型的数组的方法句柄。
arraycopy(Object, int, Object, int, int) - Static method in class java.lang. System
将指定源数组中的数组从指定位置复制到目标数组的指定位置。
ArrayDeque< E> - Class in java.util
Deque接口的可调整大小的数组实现。
ArrayDeque() - Constructor for class java.util. ArrayDeque
构造一个空数组deque，初始容量足以容纳16个元素。
ArrayDeque(int) - Constructor for class java.util. ArrayDeque
构造一个空数组deque，初始容量足以容纳指定数量的元素。
ArrayDeque(Collection<? extends E>) - Constructor for class java.util. ArrayDeque
构造一个包含指定集合的元素的deque，按照它们由集合的迭代器返回的顺序。
arrayElementGetter(Class<?>) - Static method in class java.lang.invoke. MethodHandles
产生方法句柄，提供对数组元素的读取访问。
arrayElementSetter(Class<?>) - Static method in class java.lang.invoke. MethodHandles
生成方法句柄，为数组的元素提供写访问权限。
arrayElementVarHandle(Class<?>) - Static method in class java.lang.invoke. MethodHandles
产生一个VarHandle，可以访问arrayClass类型的数组的 arrayClass 。
ArrayIndexOutOfBoundsException - Exception in java.lang
抛出以表示使用非法索引访问数组。
ArrayIndexOutOfBoundsException() - Constructor for exception java.lang. ArrayIndexOutOfBoundsException
构造一个没有详细消息的 ArrayIndexOutOfBoundsException 。
ArrayIndexOutOfBoundsException(int) - Constructor for exception java.lang. ArrayIndexOutOfBoundsException
构造一个新的 ArrayIndexOutOfBoundsException类，其中包含指示非法索引的参数。
ArrayIndexOutOfBoundsException(String) - Constructor for exception java.lang. ArrayIndexOutOfBoundsException
构造具有指定详细消息的 ArrayIndexOutOfBoundsException类。
arrayLength() - Method in interface java.io. ObjectInputFilter.FilterInfo
反序列化类的数组时的数组元素数。
arrayLength(Class<?>) - Static method in class java.lang.invoke. MethodHandles
产生返回数组长度的方法句柄。
ArrayList< E> - Class in java.util
List接口的可调整大小的数组实现。
ArrayList() - Constructor for class java.util. ArrayList
构造一个初始容量为十的空列表。
ArrayList(int) - Constructor for class java.util. ArrayList
构造具有指定初始容量的空列表。
ArrayList(Collection<? extends E>) - Constructor for class java.util. ArrayList
构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。
ArrayLiteralTree - Interface in jdk.nashorn.api.tree
表示ECMAScript数组文字表达式。
arrayOffset() - Method in class java.nio. Buffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
arrayOffset() - Method in class java.nio. ByteBuffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
arrayOffset() - Method in class java.nio. CharBuffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
arrayOffset() - Method in class java.nio. DoubleBuffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
arrayOffset() - Method in class java.nio. FloatBuffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
arrayOffset() - Method in class java.nio. IntBuffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
arrayOffset() - Method in class java.nio. LongBuffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
arrayOffset() - Method in class java.nio. ShortBuffer
返回该缓冲区的缓冲区的第一个元素的背衬数组中的偏移量 （可选操作） 。
ArrayReference - Interface in com.sun.jdi
提供对目标虚拟机中数组对象及其组件的访问。
Arrays - Class in java.util
该类包含用于操作数组的各种方法（如排序和搜索）。
ArrayStoreException - Exception in java.lang
抛出以表示尝试将错误类型的对象存储到对象数组中。
ArrayStoreException() - Constructor for exception java.lang. ArrayStoreException
构造一个 ArrayStoreException ，没有详细的消息。
ArrayStoreException(String) - Constructor for exception java.lang. ArrayStoreException
构造一个具有指定详细消息的 ArrayStoreException 。
ArrayType< T> - Class in javax.management.openmbean
所述 ArrayType类是 开放类型类，其实例描述了作为 开放数据值的n维阵列所有 打开的 数据值。
ArrayType - Interface in com.sun.jdi
提供对数组类的访问及其在目标虚拟机中的组件类型。
ArrayType - Interface in javax.lang.model.type
表示数组类型。
ArrayType(int, OpenType<?>) - Constructor for class javax.management.openmbean. ArrayType
构造一个描述 开放数据值的 ArrayType实例，它是具有 开放类型为 elementType的元素的维度 维度的数组。
ArrayType(SimpleType<?>, boolean) - Constructor for class javax.management.openmbean. ArrayType
为所提供的 SimpleType构造一维 ArrayType实例。
ArrayTypeTree - Interface in com.sun.source.tree
数组类型的树节点。
arrive() - Method in class java.util.concurrent. Phaser
抵达这个移相器，而不用等待别人到达。
arriveAndAwaitAdvance() - Method in class java.util.concurrent. Phaser
到达这个移相器，等待其他人。
arriveAndDeregister() - Method in class java.util.concurrent. Phaser
到达这个移相器并从其中注销，而无需等待别人到达。
ARROW_BUTTON - Static variable in class javax.swing.plaf.synth. Region
ArrowButton是特殊类型的按钮，它们还呈现方向指示器，通常是箭头。
arrowButton - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
调用弹出窗口的箭头按钮。
ArrowButtonListener() - Constructor for class javax.swing.plaf.basic. BasicScrollBarUI.ArrowButtonListener
arrowIcon - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
箭头图标。
ARROWS - Static variable in class java.lang. Character.UnicodeBlock
常量为“箭头”Unicode字符块。
AS_NEEDED - javafx.scene.control. ScrollPane.ScrollBarPolicy
表示需要时显示滚动条。
asAnnotatedType() - Method in interface com.sun.javadoc. Type
已过时。
如果它表示一个注释类型，则返回此类型为 AnnotatedType 。
asAnnotationTypeDoc() - Method in interface com.sun.javadoc. Type
已过时。
如果它表示注释类型，则返回此类型为 AnnotationTypeDoc 。
asByteArray() - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回一个BodyHandler<byte[]> ，返回一个从BodyProcessor.asByteArray()获得的BodyProcessor < byte[] >。
asByteArray() - Static method in interface jdk.incubator.http. HttpResponse.BodyProcessor
返回一个 BodyProcessor ，它将响应体存储为字节数组。
asByteArrayConsumer(Consumer<Optional<byte[]>>) - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回一个BodyHandler<Void> ，返回一个从 <Void>获得的BodyProcessor <Void> 。
asByteArrayConsumer(Consumer<Optional<byte[]>>) - Static method in interface jdk.incubator.http. HttpResponse.BodyProcessor
返回一个 BodyProcessor ，它将传入的身体数据提供给所提供的消费者 Optional<byte[]> 。
ASCENDING - javafx.scene.control. TableColumn.SortType
列将按升序排序。
ASCENDING - javafx.scene.control. TreeTableColumn.SortType
列将按升序排序。
ASCENDING - javax.swing. SortOrder
指示项目的枚举值按照增加的顺序进行排序。
asCharacters() - Method in interface javax.xml.stream.events. XMLEvent
将此事件作为Characters返回，如果此事件不是Characters，可能会导致类转换异常。
asCharBuffer() - Method in class java.nio. ByteBuffer
创建一个字节缓冲区作为char缓冲区的视图。
ASCII_STREAM_PARAM - Static variable in class javax.sql.rowset. BaseRowSet
一个常量，指示一个给定参数是ASCII流的一个 RowSetReaderImpl对象。
asciiStream - Variable in class javax.sql.rowset. BaseRowSet
InputStream对象将由方法 getAsciiStream返回，在 ResultSet界面中指定。
asClassDoc() - Method in interface com.sun.javadoc. ParameterizedType
已过时。
返回声明此类型的泛型类或接口。
asClassDoc() - Method in interface com.sun.javadoc. Type
已过时。
如果表示类或接口，则返回此类型为 ClassDoc 。
asCollector(int, Class<?>, int) - Method in class java.lang.invoke. MethodHandle
创建一个 数组收集方法句柄，它接收从给定位置开始的给定数量的位置参数，并将它们收集到数组参数中。
asCollector(Class<?>, int) - Method in class java.lang.invoke. MethodHandle
使 数组收集方法句柄接受给定数量的尾随位置参数并将其收集到数组参数中。
asDoubleBuffer() - Method in class java.nio. ByteBuffer
将此字节缓冲区的视图创建为双缓冲区。
asDoubleStream() - Method in interface java.util.stream. IntStream
返回一个由此流的元素组成的 DoubleStream ，转换为 double 。
asDoubleStream() - Method in interface java.util.stream. LongStream
返回一个 DoubleStream由该流的元素组成，转换为 double 。
asElement() - Method in interface javax.lang.model.type. DeclaredType
返回与此类型对应的元素。
asElement() - Method in interface javax.lang.model.type. TypeVariable
返回与此类型变量相对应的元素。
asElement(TypeMirror) - Method in interface javax.lang.model.util. Types
返回与类型相对应的元素。
asEndElement() - Method in interface javax.xml.stream.events. XMLEvent
将此事件作为结束元素事件返回，如果此事件不是结束元素，则可能会导致类转换异常。
asFile(Path) - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回一个BodyHandler<Path> ，返回一个从 <Path>获得的BodyProcessor <Path> 。
asFile(Path) - Static method in interface jdk.incubator.http. HttpResponse.BodyProcessor
返回一个 BodyProcessor ，它将响应正文放在使用给定名称打开的文件中。
asFile(Path, OpenOption...) - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回BodyHandler<Path>返回一个BodyProcessor <Path>从获得BodyProcessor.asFile(Path,OpenOption...) 。
asFile(Path, OpenOption...) - Static method in interface jdk.incubator.http. HttpResponse.BodyProcessor
返回一个 BodyProcessor ，它将响应体存储在使用给定选项和名称打开的文件中。
asFileAttribute(Set<PosixFilePermission>) - Static method in class java.nio.file.attribute. PosixFilePermissions
创建一个FileAttribute ，封装给定文件权限的副本，适合传递给createFile或createDirectory方法。
asFileDownload(Path, OpenOption...) - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回一个BodyHandler<Path> ，返回一个BodyProcessor < Path >其中指定了下载目录，但文件名是从Content-Disposition响应头获取的。
asFixedArity() - Method in class java.lang.invoke. MethodHandle
创建一个 固定的arity方法句柄，否则相当于当前的方法句柄。
asFloatBuffer() - Method in class java.nio. ByteBuffer
将此字节缓冲区的视图创建为浮动缓冲区。
asin(double) - Static method in class java.lang. Math
返回值的正弦值; 返回角度在pi / 2到pi / 2的范围内。
asin(double) - Static method in class java.lang. StrictMath
返回值的正弦值; 返回角度在pi / 2到pi / 2的范围内。
asIntBuffer() - Method in class java.nio. ByteBuffer
将此字节缓冲区的视图创建为int缓冲区。
asInterface() - Method in enum com.sun.source.tree. Tree.Kind
返回使用这种类型的关联接口类型。
asInterface() - Method in enum jdk.nashorn.api.tree. Tree.Kind
返回使用这种类型的关联接口类型。
asInterfaceInstance(Class<T>, MethodHandle) - Static method in class java.lang.invoke. MethodHandleProxies
生成给定的单一方法接口的实例，将其调用重定向到给定的方法句柄。
asIterator() - Method in interface java.util. Enumeration
返回一个Iterator ，它遍历此枚举覆盖的其余元素。
asksAllowsChildren - Variable in class javax.swing.tree. DefaultTreeModel
确定 isLeaf方法如果节点是叶节点，则 isLeaf 。
asksAllowsChildren() - Method in class javax.swing.tree. DefaultTreeModel
告诉叶节点如何确定。
asLifoQueue(Deque<T>) - Static method in class java.util. Collections
返回Deque作为先入先出（ Lifo ） Queue的视图 。
asList() - Method in class javax.management. AttributeList
将此列表的视图作为 List<Attribute> 。
asList() - Method in class javax.management.relation. RoleList
将此列表的视图作为 List<Role> 。
asList() - Method in class javax.management.relation. RoleUnresolvedList
将此列表的视图作为 List<RoleUnresolved> 。
asList(T...) - Static method in class java.util. Arrays
返回由指定数组支持的固定大小的列表。
asLongBuffer() - Method in class java.nio. ByteBuffer
将此字节缓冲区的视图创建为长缓冲区。
asLongStream() - Method in interface java.util.stream. IntStream
返回一个由此流的元素组成的 LongStream ，转换为 long 。
asMap(Function<HttpRequest, Optional<HttpResponse.BodyHandler<V>>>) - Static method in interface jdk.incubator.http. HttpResponse.MultiProcessor
返回多个响应的通用处理程序。
asMap(Function<HttpRequest, Optional<HttpResponse.BodyHandler<V>>>, boolean) - Static method in interface jdk.incubator.http. HttpResponse.MultiProcessor
返回多个响应的通用处理程序。
asMemberOf(DeclaredType, Element) - Method in interface javax.lang.model.util. Types
返回当该元素被视为给定类型的成员或以其他方式直接包含的元素的类型。
asNormal() - Method in enum java.time.format. TextStyle
返回具有相同大小的普通样式。
asObject() - Method in class javafx.beans.binding. BooleanExpression
创建一个ObjectExpression ，其值为BooleanExpression 。
asObject() - Method in class javafx.beans.binding. DoubleExpression
创建一个ObjectExpression ，其值为DoubleExpression 。
asObject() - Method in class javafx.beans.binding. FloatExpression
创建一个持有FloatExpression的值的FloatExpression 。
asObject() - Method in class javafx.beans.binding. IntegerExpression
创建一个ObjectExpression ，其值为IntegerExpression 。
asObject() - Method in class javafx.beans.binding. LongExpression
创建一个ObjectExpression ，其值为LongExpression 。
asObject() - Method in class javafx.beans.property. BooleanProperty
创建一个ObjectProperty ，其值为BooleanProperty 。
asObject() - Method in class javafx.beans.property. DoubleProperty
创建一个ObjectProperty双向绑定到这个DoubleProperty 。
asObject() - Method in class javafx.beans.property. FloatProperty
创建一个ObjectProperty双向绑定到这个FloatProperty 。
asObject() - Method in class javafx.beans.property. IntegerProperty
创建一个ObjectProperty双向绑定到这个IntegerProperty 。
asObject() - Method in class javafx.beans.property. LongProperty
创建一个ObjectProperty双向绑定到这个LongProperty 。
asObject() - Method in class javafx.beans.property. ReadOnlyBooleanProperty
创建一个ReadOnlyObjectProperty ，其值为ReadOnlyBooleanProperty 。
asObject() - Method in class javafx.beans.property. ReadOnlyDoubleProperty
创建一个ReadOnlyObjectProperty ，其值为ReadOnlyDoubleProperty 。
asObject() - Method in class javafx.beans.property. ReadOnlyFloatProperty
创建一个ReadOnlyObjectProperty ，其值为ReadOnlyFloatProperty 。
asObject() - Method in class javafx.beans.property. ReadOnlyIntegerProperty
创建一个ReadOnlyObjectProperty ，其值为ReadOnlyIntegerProperty 。
asObject() - Method in class javafx.beans.property. ReadOnlyLongProperty
创建一个ReadOnlyObjectProperty ，其值为ReadOnlyLongProperty 。
asParameterizedType() - Method in interface com.sun.javadoc. Type
已过时。
如果它代表泛型类或接口的调用，则返回此类型为 ParameterizedType 。
asPath(FileObject) - Method in interface javax.tools. StandardJavaFileManager
返回此文件对象下的路径（如果有）（可选操作）。
asPredicate() - Method in class java.util.regex. Pattern
创建可用于匹配字符串的谓词。
asReadLock() - Method in class java.util.concurrent.locks. StampedLock
返回此StampedLock的一个普通的Lock视图，其中Lock.lock()方法映射到StampedLock.readLock() ，其他方法也是如此。
asReadOnlyBuffer() - Method in class java.nio. ByteBuffer
创建一个新的只读字节缓冲区，共享此缓冲区的内容。
asReadOnlyBuffer() - Method in class java.nio. CharBuffer
创建一个新的只读char缓冲区，共享此缓冲区的内容。
asReadOnlyBuffer() - Method in class java.nio. DoubleBuffer
创建一个新的只读双缓冲区，共享此缓冲区的内容。
asReadOnlyBuffer() - Method in class java.nio. FloatBuffer
创建一个新的只读浮动缓冲区，共享此缓冲区的内容。
asReadOnlyBuffer() - Method in class java.nio. IntBuffer
创建一个新的只读int缓冲区，共享此缓冲区的内容。
asReadOnlyBuffer() - Method in class java.nio. LongBuffer
创建一个新的只读长缓冲区，共享此缓冲区的内容。
asReadOnlyBuffer() - Method in class java.nio. ShortBuffer
创建一个新的只读缓冲区，共享此缓冲区的内容。
asReadWriteLock() - Method in class java.util.concurrent.locks. StampedLock
返回此StampedLock的ReadWriteLock视图，其中ReadWriteLock.readLock()方法映射到StampedLock.asReadLock() ，而ReadWriteLock.writeLock()映射到StampedLock.asWriteLock() 。
assembleSystemMenu() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
组装系统菜单。
assembleSystemMenu() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
覆盖父方法，不做任何操作。
ASSERT - com.sun.source.tree. Tree.Kind
用于AssertTree的实例。
AssertionError - Error in java.lang
抛出以表明断言失败。
AssertionError() - Constructor for error java.lang. AssertionError
构造一个没有详细消息的AssertionError。
AssertionError(boolean) - Constructor for error java.lang. AssertionError
构造具有从指定其详细消息派生一个AssertionError boolean ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
AssertionError(char) - Constructor for error java.lang. AssertionError
构造具有从指定其详细消息派生一个AssertionError char ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
AssertionError(double) - Constructor for error java.lang. AssertionError
构造具有从指定其详细消息派生一个AssertionError double ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
AssertionError(float) - Constructor for error java.lang. AssertionError
构造具有从指定其详细消息派生一个AssertionError float ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
AssertionError(int) - Constructor for error java.lang. AssertionError
构造具有从指定其详细消息派生一个AssertionError int ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
AssertionError(long) - Constructor for error java.lang. AssertionError
构造具有从指定其详细消息派生一个AssertionError long ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
AssertionError(Object) - Constructor for error java.lang. AssertionError
构造具有从指定的对象派生其详细消息，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串一个AssertionError。
AssertionError(String, Throwable) - Constructor for error java.lang. AssertionError
构造一个新的 AssertionError与指定的详细信息和原因。
AssertTree - Interface in com.sun.source.tree
一个 assert语句的树节点。
asShortBuffer() - Method in class java.nio. ByteBuffer
将此字节缓冲区的视图创建为短缓冲区。
assign(DynAny) - Method in interface org.omg.CORBA. DynAny
已过时。
将内容从一个动态任务复制到另一个。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynAnyStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynArrayStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynEnumStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynFixedStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynSequenceStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynStructStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynUnionStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in class org.omg.DynamicAny. _DynValueStub
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
assign(DynAny) - Method in interface org.omg.DynamicAny. DynAnyOperations
使用与另一个DynAny对象关联的值初始化与DynAny对象关联的值。
ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于AssignmentTree的实例。
ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于AssignmentTree的实例。
ASSIGNMENT_SUBKIND - jdk.jshell. Snippet.SubKind
赋值表达式。
AssignmentTree - Interface in com.sun.source.tree
赋值表达式的树节点。
AssignmentTree - Interface in jdk.nashorn.api.tree
赋值表达式的树节点。
association() - Method in class com.sun.nio.sctp. AssociationChangeNotification
返回此通知适用的关联。
association() - Method in class com.sun.nio.sctp. MessageInfo
返回消息被接收的关联，如果已经接收到消息，否则将发送该消息的关联。
association() - Method in interface com.sun.nio.sctp. Notification
返回此通知适用的关联。
association() - Method in class com.sun.nio.sctp. PeerAddressChangeNotification
返回此通知适用的关联。
association() - Method in class com.sun.nio.sctp. SctpChannel
返回此通道的套接字上的关联。
association() - Method in class com.sun.nio.sctp. SendFailedNotification
返回此通知适用的关联。
association() - Method in class com.sun.nio.sctp. ShutdownNotification
返回此通知适用的关联。
Association - Class in com.sun.nio.sctp
表示SCTP关联的类。
Association(int, int, int) - Constructor for class com.sun.nio.sctp. Association
初始化此类的新实例。
AssociationChangeNotification - Class in com.sun.nio.sctp
关联已打开或关闭时发出的通知。
AssociationChangeNotification() - Constructor for class com.sun.nio.sctp. AssociationChangeNotification
初始化此类的新实例。
AssociationChangeNotification.AssocChangeEvent - Enum in com.sun.nio.sctp
定义关联发生的变更事件的类型。
associationID() - Method in class com.sun.nio.sctp. Association
返回关联ID。
associations() - Method in class com.sun.nio.sctp. SctpMultiChannel
返回此通道的套接字上的打开关联。
asSpreader(int, Class<?>, int) - Method in class java.lang.invoke. MethodHandle
创建一个 数组扩展方法句柄，它可以在给定的位置接受一个数组参数，并将其元素作为位置参数扩展代替数组。
asSpreader(Class<?>, int) - Method in class java.lang.invoke. MethodHandle
创建一个 数组扩展方法句柄，它接受一个尾随数组参数，并将其元素作为位置参数传播。
asStandalone() - Method in enum java.time.format. TextStyle
返回具有相同大小的独立样式。
asStartElement() - Method in interface javax.xml.stream.events. XMLEvent
将此事件作为起始元素事件返回，如果此事件不是起始元素，则可能会导致类转换异常。
asString() - Method in class javafx.beans.binding. BooleanExpression
创建一个StringBinding ，保持该值BooleanExpression变成String 。
asString() - Method in class javafx.beans.binding. ListExpression
创建一个StringBinding持有的价值ListExpression变成了String 。
asString() - Method in class javafx.beans.binding. MapExpression
创建一个StringBinding持有的价值MapExpression变成了String 。
asString() - Method in interface javafx.beans.binding. NumberExpression
创建一个StringBinding持有的价值NumberExpression变成了String 。
asString() - Method in class javafx.beans.binding. NumberExpressionBase
asString() - Method in class javafx.beans.binding. ObjectExpression
创建一个StringBinding ，将该值ObjectExpression变成String 。
asString() - Method in class javafx.beans.binding. SetExpression
创建一个StringBinding持有的价值SetExpression变成了String 。
asString() - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回一个BodyHandler<String> ，返回一个从 <String>获得的BodyProcessor <String> 。
asString(String) - Method in interface javafx.beans.binding. NumberExpression
创建一个StringBinding持有的价值NumberExpression变成了String 。
asString(String) - Method in class javafx.beans.binding. NumberExpressionBase
asString(String) - Method in class javafx.beans.binding. ObjectExpression
创建一个StringBinding持有的价值ObjectExpression变成了String 。
asString(Charset) - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回一个BodyHandler<String> ，返回一个BodyProcessor <String> ，从BodyProcessor.asString(Charset)获得。
asString(Charset) - Static method in interface jdk.incubator.http. HttpResponse.BodyProcessor
返回一个主体处理器，其存储响应主体作为 String使用给定的转换 Charset 。
asString(Locale, String) - Method in interface javafx.beans.binding. NumberExpression
创建一个StringBinding持有的价值NumberExpression变成了String 。
asString(Locale, String) - Method in class javafx.beans.binding. NumberExpressionBase
asString(Locale, String) - Method in class javafx.beans.binding. ObjectExpression
创建一个StringBinding持有的价值NumberExpression变成了String 。
asSubclass(Class<U>) - Method in class java.lang. Class
Class这个 Class对象来表示由指定的类对象表示的类的子类。
assureRectsCreated(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
确保矩形被创建。
ASTERISK - javafx.scene.input. KeyCode
常数为 Asterisk键。
asType() - Method in interface javax.lang.model.element. Element
返回此元素定义的类型。
asType(MethodHandle, MethodType) - Method in interface jdk.dynalink.linker. LinkerServices
类似于MethodHandle.asType(MethodType)，除了它也钩在由所有可用的GuardingTypeConverterFactory实现产生的方法句柄中，提供参数的语言特定类型的强制。
asType(MethodHandle, MethodType) - Method in interface jdk.dynalink.linker. MethodTypeConversionStrategy
将方法句柄转换为新类型。
asType(MethodHandle, MethodType) - Static method in class jdk.dynalink.linker.support. Guards
使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
asType(MethodType) - Method in class java.lang.invoke. MethodHandle
生成一个适配器方法句柄，该句柄将当前方法句柄的类型适配为新类型。
asType(MethodType) - Method in class jdk.dynalink.linker. GuardedInvocation
更改调用的类型，就好像应用了它的调用的 MethodHandle.asType(MethodType)及其保护，如果它有一个（返回类型更改为布尔值，并且参数计数可能被截断为保护）。
asType(CallSiteDescriptor) - Method in class jdk.dynalink.linker. GuardedInvocation
更改调用的类型，如果它已被应用于其调用及其保护（如果它有一个（返回类型更改为布尔 值守 ））。
asType(LinkerServices, MethodHandle, MethodType) - Static method in class jdk.dynalink.linker.support. Guards
使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
asType(LinkerServices, MethodType) - Method in class jdk.dynalink.linker. GuardedInvocation
改变调用的类型，仿佛 LinkerServices.asType(MethodHandle, MethodType)施加到它的调用和它的后卫，如果它有一个（具有变更为布尔返回类型和参数计数潜在截断，挡板）。
asTypeLosslessReturn(MethodHandle, MethodType) - Method in interface jdk.dynalink.linker. LinkerServices
类似于 LinkerServices.asType(MethodHandle, MethodType)，除了它特别处理返回值类型转换。
asTypeSafeReturn(LinkerServices, MethodType) - Method in class jdk.dynalink.linker. GuardedInvocation
改变调用的类型，仿佛 LinkerServices.asTypeLosslessReturn(MethodHandle, MethodType)施加到它的调用和 LinkerServices.asType(MethodHandle, MethodType)施加到其后卫，如果它有一个（与返回类型更改为布尔型，和参数计数潜在截断，挡板）。
asTypeVariable() - Method in interface com.sun.javadoc. Type
已过时。
如果它代表一个类型变量，则返回此类型为 TypeVariable 。
asVarargsCollector(Class<?>) - Method in class java.lang.invoke. MethodHandle
创建一个 可变的arity适配器，它可以接受任意数量的尾随位置参数并将其收集到数组参数中。
asWildcardType() - Method in interface com.sun.javadoc. Type
已过时。
如果表示通配符类型，则返回此类型为 WildcardType 。
asWriteLock() - Method in class java.util.concurrent.locks. StampedLock
返回此冲压锁的Lock视图，其中Lock.lock()方法映射到StampedLock.writeLock() ，其他方法也相似。
AsyncBoxView - Class in javax.swing.text
一个异步执行布局的框。
AsyncBoxView(Element, int) - Constructor for class javax.swing.text. AsyncBoxView
构造一个执行异步布局的框视图。
AsyncBoxView.ChildLocator - Class in javax.swing.text
在本地化区域内进行变更时，可以管理子视图在局部区域中的有效位置。
AsyncBoxView.ChildState - Class in javax.swing.text
表示子视图的布局状态的记录。
AsyncHandler< T> - Interface in javax.xml.ws
AsyncHandler接口由希望接收异步调用的服务端点操作完成的回调通知的客户端实现。
AsynchronousByteChannel - Interface in java.nio.channels
一个可以读写字节的异步通道。
AsynchronousChannel - Interface in java.nio.channels
支持异步I / O操作的通道。
AsynchronousChannelGroup - Class in java.nio.channels
用于资源共享的一组异步通道。
AsynchronousChannelGroup(AsynchronousChannelProvider) - Constructor for class java.nio.channels. AsynchronousChannelGroup
初始化此类的新实例。
AsynchronousChannelProvider - Class in java.nio.channels.spi
用于异步通道的服务提供程序类。
AsynchronousChannelProvider() - Constructor for class java.nio.channels.spi. AsynchronousChannelProvider
初始化此类的新实例。
AsynchronousCloseException - Exception in java.nio.channels
当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
AsynchronousCloseException() - Constructor for exception java.nio.channels. AsynchronousCloseException
构造这个类的一个实例。
AsynchronousFileChannel - Class in java.nio.channels
用于读取，写入和操作文件的异步通道。
AsynchronousFileChannel() - Constructor for class java.nio.channels. AsynchronousFileChannel
初始化此类的新实例。
AsynchronousServerSocketChannel - Class in java.nio.channels
用于面向流的侦听套接字的异步通道。
AsynchronousServerSocketChannel(AsynchronousChannelProvider) - Constructor for class java.nio.channels. AsynchronousServerSocketChannel
初始化此类的新实例。
AsynchronousSocketChannel - Class in java.nio.channels
用于面向流的连接插座的异步通道。
AsynchronousSocketChannel(AsynchronousChannelProvider) - Constructor for class java.nio.channels. AsynchronousSocketChannel
初始化此类的新实例。
at(int) - Method in interface com.sun.source.util. DocTreeFactory
设置要在此工厂创建的后续树节点中记录的位置。
AT - javafx.scene.input. KeyCode
“@”键的常数。
AT_TARGET - Static variable in interface org.w3c.dom.events. Event
目前正在对目标进行评估 EventTarget 。
atan(double) - Static method in class java.lang. Math
返回值的反正切值; 返回角度在pi / 2到pi / 2的范围内。
atan(double) - Static method in class java.lang. StrictMath
返回值的反正切值; 返回角度在pi / 2到pi / 2的范围内。
atan2(double, double) - Static method in class java.lang. Math
返回从直角坐标（转换角度 theta x ， y ）为极坐标 （R，θ-）。
atan2(double, double) - Static method in class java.lang. StrictMath
返回从直角坐标（转换角度 theta x ， y ）为极坐标 （R，θ-）。
atDate(LocalDate) - Method in class java.time. LocalTime
结合这个时间与一个日期创建一个 LocalDateTime 。
atDate(LocalDate) - Method in class java.time. OffsetTime
结合这个时间与一个日期来创建一个 OffsetDateTime 。
atDay(int) - Method in class java.time. Year
今年与今年的合并创造了 LocalDate 。
atDay(int) - Method in class java.time. YearMonth
结合今年的月份，创造一个 LocalDate 。
atEndOfMonth() - Method in class java.time. YearMonth
在月底返回 LocalDate 。
atMonth(int) - Method in class java.time. Year
今年结合一个月创造一个 YearMonth 。
atMonth(Month) - Method in class java.time. Year
今年结合一个月创造 YearMonth 。
atMonthDay(MonthDay) - Method in class java.time. Year
结合今年与一个月的日子，创造一个 LocalDate 。
atOffset(ZoneOffset) - Method in class java.time. Instant
将此瞬间与偏移量组合起来创建一个 OffsetDateTime 。
atOffset(ZoneOffset) - Method in class java.time. LocalDateTime
将此日期时间与偏移量相结合，创建一个 OffsetDateTime 。
atOffset(ZoneOffset) - Method in class java.time. LocalTime
结合这个时间与偏移创建一个 OffsetTime 。
ATOMIC_MOVE - java.nio.file. StandardCopyOption
将文件作为原子文件系统操作移动。
AtomicBoolean - Class in java.util.concurrent.atomic
A boolean可能原子更新的值。
AtomicBoolean() - Constructor for class java.util.concurrent.atomic. AtomicBoolean
创建一个新的 AtomicBoolean ，初始值为 false 。
AtomicBoolean(boolean) - Constructor for class java.util.concurrent.atomic. AtomicBoolean
创建一个新的 AtomicBoolean与给定的初始值。
AtomicInteger - Class in java.util.concurrent.atomic
可能原子更新的 int值。
AtomicInteger() - Constructor for class java.util.concurrent.atomic. AtomicInteger
创建一个新的AtomicInteger，初始值为 0 。
AtomicInteger(int) - Constructor for class java.util.concurrent.atomic. AtomicInteger
用给定的初始值创建一个新的AtomicInteger。
AtomicIntegerArray - Class in java.util.concurrent.atomic
一个 int数组，其中元素可以原子更新。
AtomicIntegerArray(int) - Constructor for class java.util.concurrent.atomic. AtomicIntegerArray
创建给定长度的新AtomicIntegerArray，所有元素最初为零。
AtomicIntegerArray(int[]) - Constructor for class java.util.concurrent.atomic. AtomicIntegerArray
创建一个新的AtomicIntegerArray，其长度与从给定数组复制的所有元素相同。
AtomicIntegerFieldUpdater< T> - Class in java.util.concurrent.atomic
基于反射的实用程序，可以对指定类的指定的 volatile int字段进行原子更新。
AtomicIntegerFieldUpdater() - Constructor for class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
受保护的do-nothing构造函数供子类使用。
AtomicLong - Class in java.util.concurrent.atomic
可以原子更新的 long值。
AtomicLong() - Constructor for class java.util.concurrent.atomic. AtomicLong
创建一个新的AtomicLong，初始值为 0 。
AtomicLong(long) - Constructor for class java.util.concurrent.atomic. AtomicLong
用给定的初始值创建一个新的AtomicLong。
AtomicLongArray - Class in java.util.concurrent.atomic
一个 long数组，其中元素可以原子更新。
AtomicLongArray(int) - Constructor for class java.util.concurrent.atomic. AtomicLongArray
创建给定长度的新AtomicLongArray，所有元素最初为零。
AtomicLongArray(long[]) - Constructor for class java.util.concurrent.atomic. AtomicLongArray
创建一个与原始数组相同长度的新的AtomicLongArray，并复制所有元素。
AtomicLongFieldUpdater< T> - Class in java.util.concurrent.atomic
基于反射的实用程序，可以对指定类的指定的 volatile long字段进行原子更新。
AtomicLongFieldUpdater() - Constructor for class java.util.concurrent.atomic. AtomicLongFieldUpdater
受保护的do-nothing构造函数供子类使用。
AtomicMarkableReference< V> - Class in java.util.concurrent.atomic
一个 AtomicMarkableReference维护对象引用以及可以原子更新的标记位。
AtomicMarkableReference(V, boolean) - Constructor for class java.util.concurrent.atomic. AtomicMarkableReference
创建一个新的 AtomicMarkableReference与给定的初始值。
AtomicMoveNotSupportedException - Exception in java.nio.file
当文件不能作为原子文件系统操作移动时，检查的异常抛出。
AtomicMoveNotSupportedException(String, String, String) - Constructor for exception java.nio.file. AtomicMoveNotSupportedException
构造这个类的一个实例。
AtomicReference< V> - Class in java.util.concurrent.atomic
可以原子更新的对象引用。
AtomicReference() - Constructor for class java.util.concurrent.atomic. AtomicReference
使用null初始值创建新的AtomicReference。
AtomicReference(V) - Constructor for class java.util.concurrent.atomic. AtomicReference
用给定的初始值创建一个新的AtomicReference。
AtomicReferenceArray< E> - Class in java.util.concurrent.atomic
可以以原子方式更新元素的对象引用数组。
AtomicReferenceArray(int) - Constructor for class java.util.concurrent.atomic. AtomicReferenceArray
创建给定长度的新AtomicReferenceArray，所有元素最初为null。
AtomicReferenceArray(E[]) - Constructor for class java.util.concurrent.atomic. AtomicReferenceArray
创建一个与原始数组相同的长度和所有元素的AtomicReferenceArray。
AtomicReferenceFieldUpdater< T, V> - Class in java.util.concurrent.atomic
基于反射的实用程序，可以对指定类的指定的 volatile参考字段进行原子更新。
AtomicReferenceFieldUpdater() - Constructor for class java.util.concurrent.atomic. AtomicReferenceFieldUpdater
受保护的do-nothing构造函数供子类使用。
AtomicStampedReference< V> - Class in java.util.concurrent.atomic
一个 AtomicStampedReference维护一个对象引用以及整数“印记”，可以原子更新。
AtomicStampedReference(V, int) - Constructor for class java.util.concurrent.atomic. AtomicStampedReference
创建一个新的 AtomicStampedReference与给定的初始值。
ATR - Class in javax.smartcardio
智能卡的应答复位字节。
ATR(byte[]) - Constructor for class javax.smartcardio. ATR
从字节数组构造ATR。
atStartOfDay() - Method in class java.time. LocalDate
将此日期与午夜时间结合，以便在此日期开始时创建一个 LocalDateTime 。
atStartOfDay(ZoneId) - Method in class java.time. LocalDate
根据时区中的规则，在最早的有效时间内从此日期返回划分的日期时间。
attach(VirtualMachineDescriptor) - Static method in class com.sun.tools.attach. VirtualMachine
附加到Java虚拟机。
attach(Object) - Method in class java.nio.channels. SelectionKey
将给定对象附加到此键。
attach(String) - Static method in class com.sun.tools.attach. VirtualMachine
附加到Java虚拟机。
attach(String, long, long) - Method in class com.sun.jdi.connect.spi. TransportService
附加到指定的地址。
attach(Map<String, ? extends Connector.Argument>) - Method in interface com.sun.jdi.connect. AttachingConnector
附加到正在运行的应用程序并返回其虚拟机的镜像。
ATTACH_ON_DEMAND - com.sun.management. VMOption.Origin
VM选项是使用attach框架设置的。
AttachingConnector - Interface in com.sun.jdi.connect
连接到以前运行的目标VM的连接器。
attachingConnectors() - Method in interface com.sun.jdi. VirtualMachineManager
返回已知的AttachingConnector对象的列表。
attachment() - Method in class java.nio.channels. SelectionKey
检索当前附件。
AttachmentMarshaller - Class in javax.xml.bind.attachment
启用JAXB编组以优化二进制数据的存储。
AttachmentMarshaller() - Constructor for class javax.xml.bind.attachment. AttachmentMarshaller
AttachmentPart - Class in javax.xml.soap
对 SOAPMessage对象的单个附件。
AttachmentPart() - Constructor for class javax.xml.soap. AttachmentPart
AttachmentUnmarshaller - Class in javax.xml.bind.attachment
使JAXB解组合包含优化的二进制数据格式的根文档。
AttachmentUnmarshaller() - Constructor for class javax.xml.bind.attachment. AttachmentUnmarshaller
AttachNotSupportedException - Exception in com.sun.tools.attach
当尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。
AttachNotSupportedException() - Constructor for exception com.sun.tools.attach. AttachNotSupportedException
构造一个 AttachNotSupportedException ，没有详细消息。
AttachNotSupportedException(String) - Constructor for exception com.sun.tools.attach. AttachNotSupportedException
构造具有指定详细消息的 AttachNotSupportedException 。
AttachOperationFailedException - Exception in com.sun.tools.attach
异常类型表示目标虚拟机中附着操作失败。
AttachOperationFailedException(String) - Constructor for exception com.sun.tools.attach. AttachOperationFailedException
构造具有指定详细消息的 AttachOperationFailedException 。
AttachPermission - Class in com.sun.tools.attach
当一个SecurityManager集合，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。
AttachPermission(String) - Constructor for class com.sun.tools.attach. AttachPermission
构造一个新的AttachPermission对象。
AttachPermission(String, String) - Constructor for class com.sun.tools.attach. AttachPermission
构造一个新的AttachPermission对象。
AttachProvider - Class in com.sun.tools.attach.spi
附加提供程序类以附加到Java虚拟机。
AttachProvider() - Constructor for class com.sun.tools.attach.spi. AttachProvider
初始化此类的新实例。
attachVirtualMachine(VirtualMachineDescriptor) - Method in class com.sun.tools.attach.spi. AttachProvider
附加到Java虚拟机。
attachVirtualMachine(String) - Method in class com.sun.tools.attach.spi. AttachProvider
附加到Java虚拟机。
ATTEMPTED - Static variable in class javax.print.attribute.standard. PDLOverrideSupported
打印机尝试使外部作业属性值优先于文档打印数据中的嵌入式指令，但不能保证。
attemptMark(V, boolean) - Method in class java.util.concurrent.atomic. AtomicMarkableReference
如果当前引用为期望引用的 == ，则将标记的值原子设置为给定的更新值。
attemptStamp(V, int) - Method in class java.util.concurrent.atomic. AtomicStampedReference
如果当前引用为预期引用的 == ，则原子地将戳的值设置为给定的更新值。
atTime(int, int) - Method in class java.time. LocalDate
结合此日期与时间创建一个 LocalDateTime 。
atTime(int, int, int) - Method in class java.time. LocalDate
结合此日期与时间创建一个 LocalDateTime 。
atTime(int, int, int, int) - Method in class java.time. LocalDate
结合此日期与时间创建一个 LocalDateTime 。
atTime(LocalTime) - Method in interface java.time.chrono. ChronoLocalDate
结合此日期与时间创建一个 ChronoLocalDateTime 。
atTime(LocalTime) - Method in class java.time.chrono. HijrahDate
atTime(LocalTime) - Method in class java.time.chrono. JapaneseDate
atTime(LocalTime) - Method in class java.time.chrono. MinguoDate
atTime(LocalTime) - Method in class java.time.chrono. ThaiBuddhistDate
atTime(LocalTime) - Method in class java.time. LocalDate
结合此日期与时间创建一个 LocalDateTime 。
atTime(OffsetTime) - Method in class java.time. LocalDate
将此日期与偏移时间相结合以创建 OffsetDateTime 。
attr(String) - Static method in class javax.management. Query
返回一个新的属性表达式。
attr(String, String) - Static method in class javax.management. Query
返回一个新的限定属性表达式。
Attr - Interface in org.w3c.dom
Attr接口表示 Element对象中的属性。
attribute(QName, String) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
将扩展属性添加到 W3CEndpointReference实例的 wsa:EndpointReference元素。
Attribute - Class in javax.management
通过将其名称与其值相关联来表示MBean属性。
Attribute - Interface in javax.naming.directory
此接口表示与命名对象关联的属性。
Attribute - Interface in javax.print.attribute
接口属性是由任何和每个打印属性类实现的基本接口，以指示该类表示打印属性。
Attribute - Interface in javax.xml.stream.events
包含属性信息的界面。
Attribute(String) - Constructor for class java.text. AttributedCharacterIterator.Attribute
构造具有给定名称的 Attribute 。
Attribute(String, Object) - Constructor for class javax.management. Attribute
构造一个将给定属性名称与给定值相关联的属性对象。
ATTRIBUTE - com.sun.source.doctree. DocTree.Kind
用于表示HTML属性的AttributeTree的实例。
ATTRIBUTE - Static variable in interface javax.xml.stream. XMLStreamConstants
表示事件是属性
ATTRIBUTE_CHANGE - Static variable in class javax.management. AttributeChangeNotification
指示观察到的MBean属性值已更改的通知类型。
ATTRIBUTE_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 Attr 。
ATTRIBUTE_RUN - Static variable in interface javax.accessibility. AccessibleExtendedText
常数用于表示应检索的文本部分是具有相同文本属性的连续文本。
AttributeChangeNotification - Class in javax.management
提供MBean发送的属性更改通知的定义。
AttributeChangeNotification(Object, long, long, String, String, String, Object, Object) - Constructor for class javax.management. AttributeChangeNotification
构造属性更改通知对象。
AttributeChangeNotificationFilter - Class in javax.management
这个类实现了NotificationFilter接口的attribute change notification 。
AttributeChangeNotificationFilter() - Constructor for class javax.management. AttributeChangeNotificationFilter
AttributedCharacterIterator - Interface in java.text
一个 AttributedCharacterIterator允许通过文本和相关的属性信息进行迭代。
AttributedCharacterIterator.Attribute - Class in java.text
定义用于标识文本属性的属性键。
attributeDecl(String, String, String, String, String) - Method in interface org.xml.sax.ext. DeclHandler
报告属性类型声明。
attributeDecl(String, String, String, String, String) - Method in class org.xml.sax.ext. DefaultHandler2
AttributedString - Class in java.text
AttributedString保存文本和相关属性信息。
AttributedString(String) - Constructor for class java.text. AttributedString
使用给定的文本构造一个AttributedString实例。
AttributedString(String, Map<? extends AttributedCharacterIterator.Attribute, ?>) - Constructor for class java.text. AttributedString
使用给定的文本和属性构造一个AttributedString实例。
AttributedString(AttributedCharacterIterator) - Constructor for class java.text. AttributedString
使用AttributedCharacterIterator表示的给定归因文本构造一个AttributedString实例。
AttributedString(AttributedCharacterIterator, int, int) - Constructor for class java.text. AttributedString
使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。
AttributedString(AttributedCharacterIterator, int, int, AttributedCharacterIterator.Attribute[]) - Constructor for class java.text. AttributedString
使用AttributedCharacterIterator表示的给定归因文本的子范围构造一个AttributedString实例。
AttributeException - Interface in javax.print
Interface AttributeException是一个mixin接口，它可以实现PrintException的子类来报告一个特定Print Service实例不支持的一个或多个打印属性的错误条件。
AttributeInUseException - Exception in javax.naming.directory
当操作尝试添加已经存在的属性时，抛出此异常。
AttributeInUseException() - Constructor for exception javax.naming.directory. AttributeInUseException
构造一个新的AttributeInUseException实例。
AttributeInUseException(String) - Constructor for exception javax.naming.directory. AttributeInUseException
构造一个新的AttributeInUseException实例，并带有解释。
AttributeList - Class in javax.management
表示MBean属性值的列表。
AttributeList - Class in javax.swing.text.html.parser
该类使用ATTLIST构造在DTD中描述了SGML元素的属性。
AttributeList - Interface in org.xml.sax
已过时。
该接口已被SAX2 Attributes接口所取代，其中包括命名空间支持。
AttributeList() - Constructor for class javax.management. AttributeList
构造一个空的 AttributeList 。
AttributeList(int) - Constructor for class javax.management. AttributeList
构造一个空的 AttributeList ，其中指定了初始容量。
AttributeList(String) - Constructor for class javax.swing.text.html.parser. AttributeList
创建属性列表元素。
AttributeList(String, int, int, String, Vector<?>, AttributeList) - Constructor for class javax.swing.text.html.parser. AttributeList
创建属性列表元素。
AttributeList(List<Attribute>) - Constructor for class javax.management. AttributeList
构造一个 AttributeList其中包含 AttributeList的元素，按 List的迭代器返回的 List 。
AttributeList(AttributeList) - Constructor for class javax.management. AttributeList
构造一个 AttributeList其中包含 AttributeList的元素，按 AttributeList的迭代器返回的 AttributeList 。
AttributeListImpl - Class in org.xml.sax.helpers
已过时。
这个类实现了一个不推荐的接口， AttributeList ; 该接口已被替换为Attributes ，它是在AttributesImpl帮助类中实现的。
AttributeListImpl() - Constructor for class org.xml.sax.helpers. AttributeListImpl
已过时。
创建一个空属性列表。
AttributeListImpl(AttributeList) - Constructor for class org.xml.sax.helpers. AttributeListImpl
已过时。
构造一个现有属性列表的永久性副本。
AttributeModificationException - Exception in javax.naming.directory
当尝试添加，删除或修改与属性（模式）定义或属性状态相冲突的属性，其标识符或其值时，将抛出此异常。
AttributeModificationException() - Constructor for exception javax.naming.directory. AttributeModificationException
构造一个新的AttributeModificationException实例。
AttributeModificationException(String) - Constructor for exception javax.naming.directory. AttributeModificationException
使用说明构造一个新的AttributeModificationException实例。
attributeNames() - Method in class java.beans. FeatureDescriptor
获取此功能的与区域设置无关的名称的枚举。
attributeNoNulls - Static variable in interface java.sql. DatabaseMetaData
表示可能不允许有 NULL值。
AttributeNotFoundException - Exception in javax.management
指定的属性不存在或无法检索。
AttributeNotFoundException() - Constructor for exception javax.management. AttributeNotFoundException
默认构造函数。
AttributeNotFoundException(String) - Constructor for exception javax.management. AttributeNotFoundException
允许指定特定错误消息的构造方法。
attributeNullable - Static variable in interface java.sql. DatabaseMetaData
表示绝对允许 NULL值。
attributeNullableUnknown - Static variable in interface java.sql. DatabaseMetaData
表示是否允许 NULL值是未知的。
attributes - Variable in class javax.accessibility. AccessibleAttributeSequence
文本属性。
Attributes - Class in java.util.jar
属性类将Manifest属性名称映射到关联的字符串值。
Attributes - Interface in javax.naming.directory
此接口表示属性的集合。
Attributes - Interface in org.xml.sax
XML属性列表的接口。
Attributes() - Constructor for class java.util.jar. Attributes
构造一个具有默认大小的新的空的Attributes对象。
Attributes(int) - Constructor for class java.util.jar. Attributes
构造具有指定的初始大小的新的空的Attributes对象。
Attributes(Attributes) - Constructor for class java.util.jar. Attributes
构造具有与指定属性中相同的属性名称 - 值映射的新Attributes对象。
Attributes.Name - Class in java.util.jar
Attributes.Name类表示存储在此Map中的属性名称。
Attributes2 - Interface in org.xml.sax.ext
SAX2扩展以增加Attributes提供的每个属性信息。
Attributes2Impl - Class in org.xml.sax.ext
SAX2扩展助手附加属性信息，实现Attributes2界面。
Attributes2Impl() - Constructor for class org.xml.sax.ext. Attributes2Impl
构造一个新的，空的Attributes2Impl对象。
Attributes2Impl(Attributes) - Constructor for class org.xml.sax.ext. Attributes2Impl
复制现有的Attributes或Attributes2对象。
AttributeSet - Interface in javax.print.attribute
Interface AttributeSet指定一组打印属性的接口。
AttributeSet - Interface in javax.swing.text
一组独特的属性。
AttributeSet.CharacterAttribute - Interface in javax.swing.text
该接口是预期在有助于字符级呈现的任何属性键上存在的类型签名。
AttributeSet.ColorAttribute - Interface in javax.swing.text
该接口是期望存在于有助于呈现颜色的任何属性键上的类型签名。
AttributeSet.FontAttribute - Interface in javax.swing.text
此接口是预期存在于任何有助于确定用于呈现某些文本的字体的任何属性键上的类型签名。
AttributeSet.ParagraphAttribute - Interface in javax.swing.text
该接口是预期存在于对段落级别呈现有贡献的任何属性键上的类型签名。
AttributeSetUtilities - Class in javax.print.attribute
Class AttributeSetUtilities提供用于操作AttributeSets的静态方法。
AttributesImpl - Class in org.xml.sax.helpers
属性界面的默认实现。
AttributesImpl() - Constructor for class org.xml.sax.helpers. AttributesImpl
构造一个新的空的AttributesImpl对象。
AttributesImpl(Attributes) - Constructor for class org.xml.sax.helpers. AttributesImpl
复制现有的Attributes对象。
AttributeTree - Interface in com.sun.source.doctree
HTML元素中属性的树节点。
AttributeTree.ValueKind - Enum in com.sun.source.doctree
属性值的种类。
AttributeUndoableEdit(Element, AttributeSet, boolean) - Constructor for class javax.swing.text. DefaultStyledDocument.AttributeUndoableEdit
构造一个 AttributeUndoableEdit 。
attributeUpdate(PrintJobAttributeEvent) - Method in interface javax.print.event. PrintJobAttributeListener
通知侦听器某些打印作业属性的更改。
attributeUpdate(PrintServiceAttributeEvent) - Method in interface javax.print.event. PrintServiceAttributeListener
被要求在打印服务中通知侦听器事件。
AttributeValueExp - Class in javax.management
表示用作关系约束的参数的属性。
AttributeValueExp() - Constructor for class javax.management. AttributeValueExp
已过时。
使用此构造函数创建的实例不能在查询中使用。
AttributeValueExp(String) - Constructor for class javax.management. AttributeValueExp
创建一个新的 AttributeValueExp表示指定的对象属性，名为attr。
AttributeView - Interface in java.nio.file.attribute
提供与文件系统中的对象相关联的非不透明值的只读或可更新 视图的对象。
attrID - Variable in class javax.naming.directory. BasicAttribute
保留属性的ID。
atts - Variable in class javax.swing.text.html.parser. Element
属性
atYear(int) - Method in class java.time. MonthDay
结合本月与一年创造 LocalDate 。
atZone(ZoneId) - Method in interface java.time.chrono. ChronoLocalDateTime
将此时间与时区相结合，创建一个 ChronoZonedDateTime 。
atZone(ZoneId) - Method in class java.time. Instant
将此瞬间与时区相结合，创建一个 ZonedDateTime 。
atZone(ZoneId) - Method in class java.time. LocalDateTime
将此日期时间与时区组合，以创建一个 ZonedDateTime 。
atZoneSameInstant(ZoneId) - Method in class java.time. OffsetDateTime
将此日期时间与时区组合，以创建一个 ZonedDateTime ，以确保结果具有相同的时间。
atZoneSimilarLocal(ZoneId) - Method in class java.time. OffsetDateTime
将此日期时间与时区相结合，以创建一个 ZonedDateTime试图保持相同的本地日期和时间。
AU - Static variable in class javax.sound.sampled. AudioFileFormat.Type
指定AU文件。
AudioClip - Class in javafx.scene.media
AudioClip表示可以以最小延迟播放的音频段。
AudioClip - Interface in java.applet
已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
AudioClip(String) - Constructor for class javafx.scene.media. AudioClip
从提供的源URL创建一个 AudioClip 。
AudioEqualizer - Class in javafx.scene.media
AudioEqualizer课程为媒体播放器提供音频均衡控制。
AudioFileFormat - Class in javax.sound.sampled
AudioFileFormat类的实例描述了音频文件，包括文件类型，文件的长度（以字节为单位），文件中包含的音频数据的采样帧长度以及音频数据的格式。
AudioFileFormat(AudioFileFormat.Type, int, AudioFormat, int) - Constructor for class javax.sound.sampled. AudioFileFormat
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int) - Constructor for class javax.sound.sampled. AudioFileFormat
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int, Map<String, Object>) - Constructor for class javax.sound.sampled. AudioFileFormat
使用一组定义的属性构建音频文件格式对象。
AudioFileFormat.Type - Class in javax.sound.sampled
Type类的一个实例代表音频文件的标准类型之一。
AudioFileReader - Class in javax.sound.sampled.spi
音频文件阅读服务提供商。
AudioFileReader() - Constructor for class javax.sound.sampled.spi. AudioFileReader
AudioFileWriter - Class in javax.sound.sampled.spi
音频文件写入服务提供商。
AudioFileWriter() - Constructor for class javax.sound.sampled.spi. AudioFileWriter
AudioFormat - Class in javax.sound.sampled
AudioFormat是指定声音流中数据的特定排列的类。
AudioFormat(float, int, int, boolean, boolean) - Constructor for class javax.sound.sampled. AudioFormat
构造一个具有线性PCM编码的 AudioFormat和给定的参数。
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean) - Constructor for class javax.sound.sampled. AudioFormat
构造具有给定参数的 AudioFormat 。
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean, Map<String, Object>) - Constructor for class javax.sound.sampled. AudioFormat
构造一个具有给定参数的 AudioFormat 。
AudioFormat.Encoding - Class in javax.sound.sampled
Encoding类命名用于音频流的特定数据表示类型。
AudioInputStream - Class in javax.sound.sampled
音频输入流是具有指定音频格式和长度的输入流。
AudioInputStream(InputStream, AudioFormat, long) - Constructor for class javax.sound.sampled. AudioInputStream
使用来自指定输入流的音频数据构建音频输入流，该音频输入流在采样帧中具有请求的格式和长度。
AudioInputStream(TargetDataLine) - Constructor for class javax.sound.sampled. AudioInputStream
构建从所指示的目标数据线读取其数据的音频输入流。
AudioPermission - Class in javax.sound.sampled
AudioPermission类代表对音频系统资源的访问权限。
AudioPermission(String) - Constructor for class javax.sound.sampled. AudioPermission
创建具有指定符号名称的新的 AudioPermission对象，例如“播放”或“记录”。
AudioPermission(String, String) - Constructor for class javax.sound.sampled. AudioPermission
创建具有指定符号名称的新的 AudioPermission对象，例如“播放”或“记录”。
audioSpectrumIntervalProperty() - Method in class javafx.scene.media. MediaPlayer
频谱更新之间的间隔（秒）。
AudioSpectrumListener - Interface in javafx.scene.media
音频频谱回调接口。
audioSpectrumListenerProperty() - Method in class javafx.scene.media. MediaPlayer
用于音频频谱更新的监听器。
audioSpectrumNumBandsProperty() - Method in class javafx.scene.media. MediaPlayer
音频频谱中的频带数。
audioSpectrumThresholdProperty() - Method in class javafx.scene.media. MediaPlayer
灵敏度阈值以分贝为单位; 必须是非积极的。
AudioSystem - Class in javax.sound.sampled
AudioSystem类作为采样音频系统资源的入口点。
AudioTrack - Class in javafx.scene.media
描述音轨的Track 。
AUDIT - java.nio.file.attribute. AclEntryType
以系统依赖的方式记录ACL条目的权限组件中指定的访问。
augmentList(Action[], Action[]) - Static method in class javax.swing.text. TextAction
获取一个命令列表，并用另一个命令列表来增加它。
AUGUST - java.time. Month
8月份的单身人士31天。
AUGUST - Static variable in class java.util. Calendar
Calendar.MONTH领域的价值指示了公历和朱利安日历中的第八个月。
AUGUST - Static variable in class javax.xml.datatype. DatatypeConstants
一年八月的价值
authenticate(HttpExchange) - Method in class com.sun.net.httpserver. Authenticator
被要求验证每个传入的请求。
authenticate(HttpExchange) - Method in class com.sun.net.httpserver. BasicAuthenticator
authenticate(Object) - Method in interface javax.management.remote. JMXAuthenticator
使用给定的客户端凭据验证 MBeanServerConnection客户端。
AuthenticationException - Exception in javax.naming
访问命名或目录服务时发生身份验证错误时抛出此异常。
AuthenticationException - Exception in javax.security.sasl
由SASL机制实现引发此异常，以指示SASL交换机由于与认证有关的原因（例如无效的身份，密码或密钥）而失败。
AuthenticationException() - Constructor for exception javax.naming. AuthenticationException
构造一个新的AuthenticationException实例。
AuthenticationException() - Constructor for exception javax.security.sasl. AuthenticationException
构造一个新的实例 AuthenticationException 。
AuthenticationException(String) - Constructor for exception javax.naming. AuthenticationException
使用提供的说明构造一个新的AuthenticationException实例。
AuthenticationException(String) - Constructor for exception javax.security.sasl. AuthenticationException
构造一个新的实例 AuthenticationException与详细的消息。
AuthenticationException(String, Throwable) - Constructor for exception javax.security.sasl. AuthenticationException
构造一个新的 AuthenticationException实例， AuthenticationException包含详细的消息和根异常。
AuthenticationNotSupportedException - Exception in javax.naming
当不支持所请求的身份验证的特定风格时，会抛出此异常。
AuthenticationNotSupportedException() - Constructor for exception javax.naming. AuthenticationNotSupportedException
构造一个具有所有名称解析字段的AuthenticationNotSupportedException的新实例，并将说明初始化为null。
AuthenticationNotSupportedException(String) - Constructor for exception javax.naming. AuthenticationNotSupportedException
使用说明构造一个新的AuthenticationNotSupportedException实例。
authenticator() - Method in class jdk.incubator.http. HttpClient
返回一个Optional其中包含此客户端上设置的Authenticator 。
authenticator(Authenticator) - Method in class jdk.incubator.http. HttpClient.Builder
设置用于HTTP身份验证的身份验证器。
Authenticator - Class in com.sun.net.httpserver
认证者表示HTTP认证机制的实现。
Authenticator - Class in java.net
Authenticator类代表一个知道如何获取网络连接认证的对象。
Authenticator() - Constructor for class com.sun.net.httpserver. Authenticator
Authenticator() - Constructor for class java.net. Authenticator
AUTHENTICATOR - Static variable in class javax.management.remote. JMXConnectorServer
指定连接器服务器的认证器的属性的名称。
Authenticator.Failure - Class in com.sun.net.httpserver
表示认证失败。
Authenticator.RequestorType - Enum in java.net
请求认证的实体的类型。
Authenticator.Result - Class in com.sun.net.httpserver
来自authenticate（）方法的返回类型的基类
Authenticator.Retry - Class in com.sun.net.httpserver
表示验证必须重试。
Authenticator.Success - Class in com.sun.net.httpserver
表示认证成功，通过调用getPrincipal（）可以获取已认证的用户主体。
AUTHOR - com.sun.source.doctree. DocTree.Kind
用于表示@author标签的AuthorTree的实例。
AUTHOR - javafx.css. StyleOrigin
样式表是一个外部文件
AUTHORITATIVE - Static variable in interface javax.naming. Context
用于指定所请求的服务的权威性的环境属性的名称的常量。
AuthorizationDataEntry - Class in com.sun.security.jgss
Kerberos 5 AuthorizationData条目。
AuthorizationDataEntry(int, byte[]) - Constructor for class com.sun.security.jgss. AuthorizationDataEntry
创建AuthorizationDataEntry对象。
AuthorizeCallback - Class in javax.security.sasl
该回调由 SaslServer用于确定一个实体（通过认证的身份验证身份标识）是否可以代表另一个实体（由授权标识符标识）。
AuthorizeCallback(String, String) - Constructor for class javax.security.sasl. AuthorizeCallback
构造一个 AuthorizeCallback的实例。
AuthorTree - Interface in com.sun.source.doctree
@author块标记的树形节点。
AuthPermission - Class in javax.security.auth
此类用于验证权限。
AuthPermission(String) - Constructor for class javax.security.auth. AuthPermission
创建一个具有指定名称的新AuthPermission。
AuthPermission(String, String) - Constructor for class javax.security.auth. AuthPermission
创建一个具有指定名称的新AuthPermission对象。
AuthProvider - Class in java.security
此类为提供程序定义登录和注销方法。
AuthProvider(String, double, String) - Constructor for class java.security. AuthProvider
已过时。
改用AuthProvider(String, String, String) 。
AuthProvider(String, String, String) - Constructor for class java.security. AuthProvider
构造具有指定名称，版本字符串和信息的提供程序。
AUTO - Static variable in class javafx.scene.layout. BackgroundSize
从CSS规范中：通过使用图像的内在比例和其他维度的大小，或使用图像的本征大小，或者将图像的本征大小视为100％，可以解析一个维度的“自动”值。
AUTO - Static variable in class javafx.scene.layout. BorderWidths
当BorderStroke使用时，AUTO的值被解释为对应的 BorderStroke.MEDIUM的值。
AUTO_RESIZE_ALL_COLUMNS - Static variable in class javax.swing. JTable
在所有调整大小操作期间，按比例调整所有列的大小。
AUTO_RESIZE_LAST_COLUMN - Static variable in class javax.swing. JTable
在所有调整大小操作期间，仅对最后一列应用调整。
AUTO_RESIZE_NEXT_COLUMN - Static variable in class javax.swing. JTable
在UI中调整列时，以相反的方式调整下一列。
AUTO_RESIZE_OFF - Static variable in class javax.swing. JTable
不要自动调整色谱柱宽度; 使用水平滚动条代替。
AUTO_RESIZE_SUBSEQUENT_COLUMNS - Static variable in class javax.swing. JTable
在UI调整期间，更改后续列以保留总宽度; 这是默认行为。
AutoCloseable - Interface in java.lang
可以保存资源的对象（如文件或套接字句柄），直到它关闭。
autoCommitFailureClosesAllResultSets() - Method in interface java.sql. DatabaseMetaData
检索一个 SQLException而autoCommit是 true表示所有打开的ResultSet都是关闭的，即使是可保存的。
autoCreateColumnsFromModel - Variable in class javax.swing. JTable
如果这是真的，表将查询 TableModel以构建默认列。
autoFixProperty() - Method in class javafx.stage. PopupWindow
这个便利变量指示当显示弹出窗口时，是否应自动更正其位置，使其不会最终定位在屏幕外。
autoHideProperty() - Method in class javafx.stage. PopupWindow
指定弹出窗口是否应该自动隐藏。
AUTOLOAD_PERMISSION_NAME - Static variable in class jdk.dynalink.linker. GuardingDynamicLinkerExporter
创建此类实例的运行时权限的名称。
AUTOMATIC - java.lang.module. ModuleDescriptor.Modifier
自动模块
AUTOMATIC - Static variable in class javafx.print. PaperSource
指定自动选择纸盘。
autoPlayProperty() - Method in class javafx.scene.media. MediaPlayer
是否应尽快开始播放。
autoRange(double) - Method in class javafx.scene.chart. Axis
这将根据提供给invalidateRange（）方法的数据计算上限和下限。
autoRange(double) - Method in class javafx.scene.chart. CategoryAxis
这将根据提供给invalidateRange（）方法的数据计算类别。
autoRange(double) - Method in class javafx.scene.chart. ValueAxis
这将根据提供给invalidateRange（）方法的数据计算上限和下限。
autoRange(double, double, double, double) - Method in class javafx.scene.chart. NumberAxis
被要求设置上限和下限以及需要自动调整的任何其他内容。
autoRange(double, double, double, double) - Method in class javafx.scene.chart. ValueAxis
被要求设置上限和下限以及需要自动调整的任何其他内容。
autoRangingProperty() - Method in class javafx.scene.chart. Axis
当轴自动从数据中确定其范围时，这一点是正确的
autoResizeMode - Variable in class javax.swing. JTable
确定表是否自动调整表的列的宽度，以占用表的整个宽度，以及如何调整大小。
autoReverseProperty() - Method in class javafx.animation. Animation
定义 Animation是否在交替循环中反转方向。
autoscroll(Point) - Method in interface java.awt.dnd. Autoscroll
通知 Component自动滚屏
Autoscroll - Interface in java.awt.dnd
在DnD操作期间，用户可能希望将操作的主题放在用户当前不可见的可滚动GUI控件的区域上。
autoScrollDown() - Method in class javax.swing.plaf.basic. BasicComboPopup
此受保护方法是实现特定的，应该是私有的。
autoscrollTimer - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
autoScrollUp() - Method in class javax.swing.plaf.basic. BasicComboPopup
此受保护方法是实现特定的，应该是私有的。
AUTOSELECT_FILTERING - java.util. Locale.FilteringMode
指定基于由语言范围组成的给定语言优先级列表的自动过滤模式。
AUTOSENSE - Static variable in class javax.print. DocFlavor.BYTE_ARRAY
Doc风格与MIME类型= "application/octet-stream" ，打印数据表示类名= "[B" （字节数组）。
AUTOSENSE - Static variable in class javax.print. DocFlavor.INPUT_STREAM
具有MIME类型的文档风格= "application/octet-stream" ，打印数据表示类名= "java.io.InputStream" （字节流）。
AUTOSENSE - Static variable in class javax.print. DocFlavor.URL
具有MIME类型的文档风味= "application/octet-stream" ，打印数据表示类名= "java.net.URL" 。
autosize() - Method in class javafx.scene. Node
如果节点可调整大小，则将其布局边界设置为当前优选的宽度和高度。
autoSizeChildrenProperty() - Method in class javafx.scene. Group
控制 Group是否会在布局过程中自动将任何受管理的可调整大小的儿童调整为首选大小。
AUX_RETURN - Static variable in class javax.sound.sampled. FloatControl.Type
表示一条线上辅助回波增益的控制。
AUX_SEND - Static variable in class javax.sound.sampled. FloatControl.Type
表示一条线上辅助发送增益的控制。
available() - Method in class java.io. BufferedInputStream
从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
available() - Method in class java.io. ByteArrayInputStream
返回可从此输入流读取（或跳过）的剩余字节数。
available() - Method in class java.io. FileInputStream
返回从此输入流中可以读取（或跳过）的剩余字节数的估计值，而不会被下一次调用此输入流的方法阻塞。
available() - Method in class java.io. FilterInputStream
返回从该输入流中可以读取（或跳过）的字节数的估计，而不会被下一个调用者阻塞该输入流的方法。
available() - Method in class java.io. InputStream
从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
available() - Method in class java.io. LineNumberInputStream
已过时。
返回可以从该输入流读取而不阻塞的字节数。
available() - Method in interface java.io. ObjectInput
返回可以读取而不阻塞的字节数。
available() - Method in class java.io. ObjectInputStream
返回可以读取而不阻塞的字节数。
available() - Method in class java.io. PipedInputStream
返回可以从该输入流读取而不阻塞的字节数。
available() - Method in class java.io. PushbackInputStream
从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
available() - Method in class java.io. SequenceInputStream
返回当前底层输入流可以读取（或跳过）的字节数，而不会被下一次调用当前底层输入流的方法阻塞。
available() - Method in class java.io. StringBufferInputStream
已过时。
返回无阻塞地从输入流中读取的字节数。
available() - Method in class java.net. SocketImpl
返回可从该套接字读取而不阻塞的字节数。
available() - Method in class java.util.zip. DeflaterInputStream
到达EOF后返回0，否则总是返回1。
available() - Method in class java.util.zip. InflaterInputStream
到达EOF后返回0，否则总是返回1。
available() - Method in class java.util.zip. ZipInputStream
EOF到达当前条目数据后返回0，否则返回1。
available() - Method in class javax.crypto. CipherInputStream
返回可以从该输入流读取而不阻塞的字节数。
available() - Method in class javax.sound.sampled. AudioInputStream
返回从该音频输入流中可以读取（或跳过）的最大字节数，而不会阻塞。
available() - Method in interface javax.sound.sampled. DataLine
获取应用程序当前可用于数据线内部缓冲区中处理数据的字节数。
availableCharsets() - Static method in class java.nio.charset. Charset
构造从规范字符集名称到字符集对象的排序映射。
availableLocales - Variable in class javax.imageio. ImageReader
可用于本地化警告消息的 Locale的阵列，如果不支持本地化， null 。
availableLocales - Variable in class javax.imageio. ImageWriter
可用于定位警告消息和压缩设置值的 Locale s阵列，如果不支持本地化， null 。
availablePermits() - Method in class java.util.concurrent. Semaphore
返回此信号量中当前可用的许可数。
availableProcessors() - Method in class java.lang. Runtime
返回可用于Java虚拟机的处理器数量。
availableStrata() - Method in interface com.sun.jdi. ReferenceType
返回此参考类型的可用层。
average() - Method in interface java.util.stream. DoubleStream
返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
average() - Method in interface java.util.stream. IntStream
返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回一个空的可选项。
average() - Method in interface java.util.stream. LongStream
返回描述此流的元素的算术平均值的 OptionalDouble ，如果此流为空，则返回空的可选项。
averageBytesPerChar() - Method in class java.nio.charset. CharsetEncoder
返回为每个输入字符产生的平均字节数。
averageCharsPerByte() - Method in class java.nio.charset. CharsetDecoder
返回每个字节输入的平均字符数。
averagingDouble(ToDoubleFunction<? super T>) - Static method in class java.util.stream. Collectors
返回一个产生应用于输入元素的双值函数的算术平均值的 Collector 。
averagingInt(ToIntFunction<? super T>) - Static method in class java.util.stream. Collectors
返回一个产生应用于输入元素的整数值函数的算术平均值的 Collector 。
averagingLong(ToLongFunction<? super T>) - Static method in class java.util.stream. Collectors
返回一个产生应用于输入元素的长值函数的算术平均值的 Collector 。
AVESTAN - java.lang. Character.UnicodeScript
Unicode脚本“Avestan”。
AVESTAN - Static variable in class java.lang. Character.UnicodeBlock
“Avestan”Unicode字符块的常数。
avoidingGui() - Method in class java.beans.beancontext. BeanContextSupport
用于确定 BeanContext孩子是否避免使用其GUI。
avoidingGui() - Method in interface java.beans. Visibility
确定这个bean是否避免使用GUI。
await() - Method in class java.util.concurrent. CountDownLatch
导致当前线程等到锁存器向下计数为零，除非线程为 interrupted 。
await() - Method in class java.util.concurrent. CyclicBarrier
等待，直到所有 parties已经在这个障碍上调用了 await 。
await() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject
实现可中断条件等待。
await() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject
实现可中断条件等待。
await() - Method in interface java.util.concurrent.locks. Condition
导致当前线程等到它发出信号或 interrupted 。
await(long, TimeUnit) - Method in class java.util.concurrent. CountDownLatch
使当前线程等待直到锁存器计数到零为止，除非线程为 interrupted ，否则指定的等待时间过去。
await(long, TimeUnit) - Method in class java.util.concurrent. CyclicBarrier
等待，直到所有 parties已经在此屏障上调用了 await ，或者指定的等待时间 await 。
await(long, TimeUnit) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject
实现定时状态等待。
await(long, TimeUnit) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject
实现定时状态等待。
await(long, TimeUnit) - Method in interface java.util.concurrent.locks. Condition
使当前线程等待直到发出信号或中断，或指定的等待时间过去。
awaitAdvance(int) - Method in class java.util.concurrent. Phaser
等待该相位器的相位从给定相位值前进，如果当前相位不等于给定相位值，则立即返回，或者该相位器被终止。
awaitAdvanceInterruptibly(int) - Method in class java.util.concurrent. Phaser
等待相移器的相位从给定的相位值推进，抛出 InterruptedException如果在等待时中断，或者如果当前相位不等于给定相位值，则立即返回，或者该相位器被终止。
awaitAdvanceInterruptibly(int, long, TimeUnit) - Method in class java.util.concurrent. Phaser
等待该移相器的阶段从给定的相位值或给定的超时时间 InterruptedException到等待，如果当前相位不等于给定的相位值，则抛出 InterruptedException或立即返回，或者该相位器被终止。
awaitNanos(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject
实现定时状态等待。
awaitNanos(long) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject
实现定时状态等待。
awaitNanos(long) - Method in interface java.util.concurrent.locks. Condition
使当前线程等待直到发出信号或中断，或指定的等待时间过去。
awaitQuiescence(long, TimeUnit) - Method in class java.util.concurrent. ForkJoinPool
如果在此池中操作的ForkJoinTask调用，则相当于 ForkJoinTask.helpQuiesce() 。
awaitTermination(long, TimeUnit) - Method in class java.nio.channels. AsynchronousChannelGroup
等待该组终止。
awaitTermination(long, TimeUnit) - Method in interface java.util.concurrent. ExecutorService
阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
awaitTermination(long, TimeUnit) - Method in class java.util.concurrent. ForkJoinPool
阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
awaitTermination(long, TimeUnit) - Method in class java.util.concurrent. ThreadPoolExecutor
awaitUninterruptibly() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject
实现不间断状态等待。
awaitUninterruptibly() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject
实现不间断状态等待。
awaitUninterruptibly() - Method in interface java.util.concurrent.locks. Condition
使当前线程等待直到发出信号。
awaitUntil(Date) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject
实现绝对定时条件等待。
awaitUntil(Date) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject
实现绝对定时条件等待。
awaitUntil(Date) - Method in interface java.util.concurrent.locks. Condition
使当前线程等待直到发出信号或中断，或者指定的最后期限过去。
AWT_COMPONENT - Static variable in class javax.accessibility. AccessibleRole
一个AWT组件，但没有其他的知道它。
AWTError - Error in java.awt
当出现严重的抽象窗口工具包错误时抛出。
AWTError(String) - Constructor for error java.awt. AWTError
构造具有指定详细消息的 AWTError实例。
AWTEvent - Class in java.awt
所有AWT事件的根事件类。
AWTEvent(Event) - Constructor for class java.awt. AWTEvent
已过时。
建议使用AWTEvent(Object, int)
AWTEvent(Object, int) - Constructor for class java.awt. AWTEvent
构造具有指定源对象和类型的AWTEvent对象。
AWTEventListener - Interface in java.awt.event
用于接收分派到作为Component或MenuComponent或其子类的实例的对象的事件的侦听器接口。
AWTEventListenerProxy - Class in java.awt.event
一个扩展 EventListenerProxy专门用于为特定事件掩码添加一个 AWTEventListener的类。
AWTEventListenerProxy(long, AWTEventListener) - Constructor for class java.awt.event. AWTEventListenerProxy
将 AWTEventListener绑定到特定事件掩码的构造方法。
AWTEventMonitor - Class in com.sun.java.accessibility.util
AWTEventMonitor实现了一组有条件地安装在Java虚拟机中的每个AWT组件实例上的监听器。
AWTEventMonitor() - Constructor for class com.sun.java.accessibility.util. AWTEventMonitor
AWTEventMulticaster - Class in java.awt
AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
AWTEventMulticaster(EventListener, EventListener) - Constructor for class java.awt. AWTEventMulticaster
创建一个事件多重实例，它将listener-a与listener-b链接起来。
AWTException - Exception in java.awt
表示发生抽象窗口工具包异常。
AWTException(String) - Constructor for exception java.awt. AWTException
构造具有指定详细消息的 AWTException实例。
AWTKeyStroke - Class in java.awt
AWTKeyStroke表示键盘或等效输入设备上的关键操作。
AWTKeyStroke() - Constructor for class java.awt. AWTKeyStroke
构造具有默认值的 AWTKeyStroke 。
AWTKeyStroke(char, int, int, boolean) - Constructor for class java.awt. AWTKeyStroke
构造具有指定值的 AWTKeyStroke 。
AWTPermission - Class in java.awt
此类用于AWT权限。
AWTPermission(String) - Constructor for class java.awt. AWTPermission
创建一个新的指定名称的 AWTPermission 。
AWTPermission(String, String) - Constructor for class java.awt. AWTPermission
使用指定的名称创建一个新的 AWTPermission对象。
Axis< T> - Class in javafx.scene.chart
JavaFX中所有轴的基类，表示在图表区域上绘制的轴。
Axis() - Constructor for class javafx.scene.chart. Axis
创建并初始化Axis类的新实例。
Axis.TickMark< T> - Class in javafx.scene.chart
TickMark代表标签文本，它与Axis的每个刻度相关联的属性。
axisProperty() - Method in class javafx.animation. RotateTransition
指定 RotateTransition的旋转轴。
axisProperty() - Method in class javafx.scene.transform. Rotate
定义枢轴点的旋转轴。
axisSortingPolicyProperty() - Method in class javafx.scene.chart. LineChart
指示传递给LineChart的数据是否应按其中一个轴的自然顺序进行排序。
azimuthProperty() - Method in class javafx.scene.effect. Light.Distant
光的方位角。
AZURE - Static variable in class javafx.scene.paint. Color
RGB值为＃F0FFFF的颜色天蓝色
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


B-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

B

b - Variable in class java.awt. AWTEventMulticaster
事件链中的一个变量（listener-b）
B - javafx.scene.input. KeyCode
常数为 B键。
B - Static variable in class java.awt. PageAttributes.MediaType
Engineering B的MediaType实例，11 x 17 in。
B - Static variable in class javax.print.attribute.standard. MediaSize.Engineering
指定工程B尺寸，11英寸×17英寸。
B - Static variable in class javax.print.attribute.standard. MediaSizeName
B尺寸。
B - Static variable in class javax.swing.text.html. HTML.Tag
标记<b>
B0 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B0的别名。
B0 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B0尺寸，1000 mm×1414 mm。
B0 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B0尺寸，1030mm×1456mm。
B1 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B1的别名。
B1 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B1尺寸，707 mm×1000 mm。
B1 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B1尺寸，728mm×1030mm。
B10 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B10的别名。
B10 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B10尺寸，31 mm x 44 mm。
B10 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B10尺寸，32mm×45mm。
B2 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B2的别名。
B2 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B2尺寸，500 mm×707 mm。
B2 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B2尺寸，515mm×728mm。
B3 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B3的别名。
B3 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B3尺寸，353 mm×500 mm。
B3 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B3尺寸，364 mm×515 mm。
B4 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B4的别名。
B4 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B4尺寸，250 mm×353 mm。
B4 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B4尺寸，257 mm×364 mm。
B5 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B5的别名。
B5 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B5尺寸，176 mm×250 mm。
B5 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B5尺寸，182 mm×257 mm。
B6 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B6的别名。
B6 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B6尺寸，125 mm×176 mm。
B6 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B6尺寸，128 mm×182 mm。
B7 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B7的别名。
B7 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B7尺寸，88 mm x 125 mm。
B7 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B7尺寸，91mm×128mm。
B8 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B8的别名。
B8 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B8尺寸，62 mm×88 mm。
B8 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B8尺寸，64mm×91mm。
B9 - Static variable in class java.awt. PageAttributes.MediaType
ISO_B9的别名。
B9 - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO B9尺寸，44 mm x 62 mm。
B9 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS B9尺寸，45mm×64mm。
BACK - javafx.scene.shape. CullFace
剔除所有背面的多边形。
BACK_PREVIOUS - javafx.scene.control. ButtonBar.ButtonData
“back”或“previous”按钮的标签。
BACK_QUOTE - javafx.scene.input. KeyCode
常数为 Back Quote键。
BACK_SLASH - javafx.scene.input. KeyCode
常数为斜杠，“\”
BACK_SPACE - javafx.scene.input. KeyCode
常数为 Backspace键。
BACK_SPACE - Static variable in class java.awt. Event
已过时。
BackSpace键。
backBuffers - Variable in class java.awt. Component.BltBufferStrategy
后缓冲
Background - Class in javafx.scene.layout
背景Region 。
Background - Static variable in class javax.swing.text. StyleConstants
背景颜色属性的名称。
Background(List<BackgroundFill>, List<BackgroundImage>) - Constructor for class javafx.scene.layout. Background
创建一个新的背景提供两个列表，一个用于背景填充，一个用于背景图像。
Background(BackgroundFill...) - Constructor for class javafx.scene.layout. Background
通过提供一个BackgroundFill数组创建一个新的背景。
Background(BackgroundFill[], BackgroundImage[]) - Constructor for class javafx.scene.layout. Background
通过提供两个阵列创建一个新的背景，一个用于背景填充，另一个用于背景图像。
Background(BackgroundImage...) - Constructor for class javafx.scene.layout. Background
通过提供一个BackgroundImages数组创建一个新的背景。
BACKGROUND - Static variable in class java.awt. BufferCapabilities.FlipContents
当翻转内容为 BACKGROUND ，翻转后背景缓冲区的内容将被清除。
BACKGROUND - Static variable in class java.awt.font. TextAttribute
用于渲染文本背景的绘画的属性键。
BACKGROUND - Static variable in class javax.swing.plaf.synth. ColorType
ColorType为区域的背景。
BACKGROUND - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“background”。
BACKGROUND - Static variable in class javax.swing.text.html. HTML.Attribute
属性“背景”
BACKGROUND_ATTACHMENT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“background-attachment”。
BACKGROUND_COLOR - javafx.scene.web. HTMLEditorSkin.Command
BACKGROUND_COLOR - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“background-color”。
BACKGROUND_IMAGE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“background-image”。
BACKGROUND_POSITION - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“background-position”。
BACKGROUND_REPEAT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“background-repeat”。
BackgroundFill - Class in javafx.scene.layout
填充和相关属性指示如何填充Region的背景。
BackgroundFill(Paint, CornerRadii, Insets) - Constructor for class javafx.scene.layout. BackgroundFill
使用指定的填充，半径和插入创建一个新的BackgroundFill。
BackgroundImage - Class in javafx.scene.layout
定义描述如何将图像渲染为Region的背景的属性 。
BackgroundImage(Image, BackgroundRepeat, BackgroundRepeat, BackgroundPosition, BackgroundSize) - Constructor for class javafx.scene.layout. BackgroundImage
创建一个新的BackgroundImage。
backgroundNonSelectionColor - Variable in class javax.swing.tree. DefaultTreeCellRenderer
未选择节点时用于背景的颜色。
BackgroundPosition - Class in javafx.scene.layout
表示的位置BackgroundImage的内Region的绘图区域。
BackgroundPosition(Side, double, boolean, Side, double, boolean) - Constructor for class javafx.scene.layout. BackgroundPosition
创建一个新的BackgroundPosition。
backgroundProperty() - Method in class javafx.scene.layout. Region
该区域的背景由零个或多个BackgroundFill组成，以及零个或多个BackgroundImages。
BackgroundRepeat - Enum in javafx.scene.layout
枚举在背景中重复图像的选项
backgroundSelectionColor - Variable in class javax.swing.tree. DefaultTreeCellRenderer
选择节点时用于背景的颜色。
BackgroundSize - Class in javafx.scene.layout
定义BackgroundImage应该填充的区域的大小相对于其样式的Region。
BackgroundSize(double, double, boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.layout. BackgroundSize
创建一个新的BackgroundSize。
backingStore - Variable in class javax.swing. JViewport
已过时。
从Java 2平台v1.3开始
BACKINGSTORE_SCROLL_MODE - Static variable in class javax.swing. JViewport
将视口内容绘制到屏幕外的图像中。
BackingStoreException - Exception in java.util.prefs
抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。
BackingStoreException(String) - Constructor for exception java.util.prefs. BackingStoreException
构造具有指定详细消息的BackingStoreException。
BackingStoreException(Throwable) - Constructor for exception java.util.prefs. BackingStoreException
构造具有指定原因的BackingStoreException。
backingStoreImage - Variable in class javax.swing. JViewport
用于后台存储的视图图像。
backoffStrategyProperty() - Method in class javafx.concurrent. ScheduledService
计算在每次故障时添加到期间的时间量。
backward() - Method in class javafx.scene.control. TextInputControl
向后移动插入符号位置。
Backward - Static variable in class javax.swing.text. Position.Bias
表示对模型中前一个字符的偏见。
BACKWARD_TRAVERSAL_KEYS - Static variable in class java.awt. KeyboardFocusManager
后向聚焦遍历键的标识符。
backwardAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号逻辑地向后移动一个位置的Action的名称。
BAD_BINDINGS - Static variable in exception org.ietf.jgss. GSSException
频道绑定不匹配。
BAD_BOUNDARYPOINTS_ERR - Static variable in exception org.w3c.dom.ranges. RangeException
如果范围的边界点不符合特定要求。
BAD_CONTEXT - Exception in org.omg.CORBA
当客户端调用操作时抛出异常，但传递的上下文不包含操作所需的上下文值。
BAD_CONTEXT() - Constructor for exception org.omg.CORBA. BAD_CONTEXT
构造一个 BAD_CONTEXT异常，默认次要代码为0，完成状态为COMPLETED_NO。
BAD_CONTEXT(int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_CONTEXT
构造具有指定的次要代码和完成状态的 BAD_CONTEXT异常。
BAD_CONTEXT(String) - Constructor for exception org.omg.CORBA. BAD_CONTEXT
构造一个 BAD_CONTEXT异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。
BAD_CONTEXT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_CONTEXT
构造具有指定的详细信息，次要代码和完成状态的 BAD_CONTEXT异常。
BAD_INV_ORDER - Exception in org.omg.CORBA
这个异常表示调用者以错误的顺序调用了操作。
BAD_INV_ORDER() - Constructor for exception org.omg.CORBA. BAD_INV_ORDER
构造一个 BAD_INV_ORDER异常，默认次要代码为0，完成状态为COMPLETED_NO。
BAD_INV_ORDER(int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_INV_ORDER
构造具有指定的次要代码和完成状态的 BAD_INV_ORDER异常 BAD_INV_ORDER 。
BAD_INV_ORDER(String) - Constructor for exception org.omg.CORBA. BAD_INV_ORDER
构造一个 BAD_INV_ORDER异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。
BAD_INV_ORDER(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_INV_ORDER
构造具有指定的详细消息，次要代码和完成状态的 BAD_INV_ORDER异常。
BAD_LOCATION - Static variable in class javax.swing.text. AbstractDocument
错误信息表示错误的位置。
BAD_MECH - Static variable in exception org.ietf.jgss. GSSException
请求不受支持的机制。
BAD_MIC - Static variable in exception org.ietf.jgss. GSSException
令牌无效的完整性检查。
BAD_NAME - Static variable in exception org.ietf.jgss. GSSException
提供的名称无效。
BAD_NAMETYPE - Static variable in exception org.ietf.jgss. GSSException
提供的不支持类型的名称。
BAD_OPERATION - Exception in org.omg.CORBA
当对象引用表示现有对象但该对象不支持被调用的操作时抛出异常。
BAD_OPERATION() - Constructor for exception org.omg.CORBA. BAD_OPERATION
构造一个 BAD_OPERATION异常，默认次要代码为0，完成状态为COMPLETED_NO。
BAD_OPERATION(int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_OPERATION
构造具有指定的次要代码和完成状态的 BAD_OPERATION异常。
BAD_OPERATION(String) - Constructor for exception org.omg.CORBA. BAD_OPERATION
构造一个 BAD_OPERATION异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。
BAD_OPERATION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_OPERATION
构造一个 BAD_OPERATION异常，其中包含指定的详细消息，次要代码和完成状态。
BAD_PARAM - Exception in org.omg.CORBA
传递给调用的参数超出范围或以其他方式被视为非法时引发的异常。
BAD_PARAM() - Constructor for exception org.omg.CORBA. BAD_PARAM
构造一个 BAD_PARAM异常，默认次要代码为0，完成状态为COMPLETED_NO。
BAD_PARAM(int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_PARAM
构造具有指定的次要代码和完成状态的 BAD_PARAM异常。
BAD_PARAM(String) - Constructor for exception org.omg.CORBA. BAD_PARAM
构造一个 BAD_PARAM异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。
BAD_PARAM(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_PARAM
构造具有指定的详细消息，次要代码和完成状态的 BAD_PARAM异常。
BAD_POLICY - Interface in org.omg.CORBA
A PolicyErrorCode将填写 PolicyError例外。
BAD_POLICY_TYPE - Interface in org.omg.CORBA
A PolicyErrorCode将填写 PolicyError例外。
BAD_POLICY_VALUE - Interface in org.omg.CORBA
包含用于指示对ORB类中定义的 create_policy方法的调用中有效策略类型不正确的策略值的值。
BAD_QOP - Static variable in exception org.ietf.jgss. GSSException
不支持的QOP值。
BAD_QOS - Exception in org.omg.CORBA
当对象不能支持具有与其相关联的服务质量语义的调用参数所需的服务质量时，引发 BAD_QOS异常。
BAD_QOS() - Constructor for exception org.omg.CORBA. BAD_QOS
构造一个 BAD_QOS异常，次要代码设置为0，CompletionStatus设置为COMPLETED_NO。
BAD_QOS(int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_QOS
构造具有指定的次要代码和完成状态的 BAD_QOS异常。
BAD_QOS(String) - Constructor for exception org.omg.CORBA. BAD_QOS
使用指定的消息构造一个 BAD_QOS异常。
BAD_QOS(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_QOS
构造具有指定消息，次要代码和完成状态的 BAD_QOS异常。
BAD_STATUS - Static variable in exception org.ietf.jgss. GSSException
状态码无效
BAD_TYPECODE - Exception in org.omg.CORBA
当ORB遇到格式错误的代码（例如， TCKind无效的类型代码）时抛出异常。
BAD_TYPECODE() - Constructor for exception org.omg.CORBA. BAD_TYPECODE
构造一个 BAD_TYPECODE异常，默认次要代码为0，完成状态为COMPLETED_NO。
BAD_TYPECODE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_TYPECODE
构造具有指定的次要代码和完成状态的 BAD_TYPECODE异常。
BAD_TYPECODE(String) - Constructor for exception org.omg.CORBA. BAD_TYPECODE
构造一个 BAD_TYPECODE异常，指定的细节，次要代码为0，完成状态为COMPLETED_NO。
BAD_TYPECODE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. BAD_TYPECODE
构造一个 BAD_TYPECODE异常，指定的详细消息，次要代码和完成状态。
BadAttributeValueExpException - Exception in javax.management
当无效的MBean属性传递给查询构造方法时抛出。
BadAttributeValueExpException(Object) - Constructor for exception javax.management. BadAttributeValueExpException
使用指定的Object构造一个BadAttributeValueExpException来创建toString（）值。
BadBinaryOpValueExpException - Exception in javax.management
当无效表达式传递给构造查询的方法时抛出。
BadBinaryOpValueExpException(ValueExp) - Constructor for exception javax.management. BadBinaryOpValueExpException
构造一个 BadBinaryOpValueExpException与指定的 ValueExp 。
BadBreakWeight - Static variable in class javax.swing.text. View
表示视图的重量是格式化的一个坏的机会。
BadKind - Exception in org.omg.CORBA.TypeCodePackage
当对 TypeCode对象调用不正确的操作时，抛出异常 BadKind 。
BadKind() - Constructor for exception org.omg.CORBA.TypeCodePackage. BadKind
构造一个 BadKind异常，没有原因信息。
BadKind(String) - Constructor for exception org.omg.CORBA.TypeCodePackage. BadKind
构造具有指定原因消息的 BadKind异常。
BadKindHelper - Class in org.omg.CORBA.TypeCodePackage
这个Helper类用于方便编组 TypeCodePackage/BadKind 。
BadKindHelper() - Constructor for class org.omg.CORBA.TypeCodePackage. BadKindHelper
BadLocationException - Exception in javax.swing.text
此异常是报告文档模型中的不良位置（即尝试引用不存在的位置）。
BadLocationException(String, int) - Constructor for exception javax.swing.text. BadLocationException
创建一个新的BadLocationException对象。
BadPaddingException - Exception in javax.crypto
当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
BadPaddingException() - Constructor for exception javax.crypto. BadPaddingException
构造一个没有详细消息的BadPaddingException。
BadPaddingException(String) - Constructor for exception javax.crypto. BadPaddingException
构造具有指定详细消息的BadPaddingException。
BadStringOperationException - Exception in javax.management
当无效的字符串操作传递给构造查询的方法时抛出。
BadStringOperationException(String) - Constructor for exception javax.management. BadStringOperationException
构造具有指定详细消息的 BadStringOperationException 。
BALANCE - Static variable in class javax.sound.sampled. FloatControl.Type
表示两个立体声扬声器之间立体声信号相对平衡的控制。
BALANCED - Static variable in class javafx.scene. SceneAntialiasing
实现抗锯齿优化，实现质量和性能的平衡
balanceProperty() - Method in class javafx.scene.media. AudioClip
剪辑的相对左右音量级别。
balanceProperty() - Method in class javafx.scene.media. MediaPlayer
音频输出的平衡或左右设置。
BALINESE - java.awt.font. NumericShaper.Range
巴厘岛系列与巴厘岛数字。
BALINESE - java.lang. Character.UnicodeScript
Unicode脚本“巴厘岛”。
BALINESE - Static variable in class java.lang. Character.UnicodeBlock
“巴厘岛”Unicode字符块的常数。
BAMUM - java.lang. Character.UnicodeScript
Unicode脚本“Bamum”。
BAMUM - Static variable in class java.lang. Character.UnicodeBlock
“Bamum”Unicode字符块的常量。
BAMUM_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“Bamum Supplement”Unicode字符块的常量。
BandCombineOp - Class in java.awt.image
该类使用指定的矩阵在 Raster中执行频带的任意线性组合。
BandCombineOp(float[][], RenderingHints) - Constructor for class java.awt.image. BandCombineOp
构造具有指定矩阵的 BandCombineOp 。
BandedSampleModel - Class in java.awt.image
该类表示以频带交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
BandedSampleModel(int, int, int, int) - Constructor for class java.awt.image. BandedSampleModel
构造带指定参数的BandedSampleModel。
BandedSampleModel(int, int, int, int, int[], int[]) - Constructor for class java.awt.image. BandedSampleModel
构造带指定参数的BandedSampleModel。
bandOffsets - Variable in class java.awt.image. ComponentSampleModel
数据数组元素中所有频带的偏移量。
bandwidth() - Method in class jdk.net. SocketFlow
返回此SocketFlow的带宽。
bandwidth(long) - Method in class jdk.net. SocketFlow
设置这个SocketFlow的带宽。
bandwidthProperty() - Method in class javafx.scene.media. EqualizerBand
带的带宽以赫兹为单位。
bank - Variable in class javax.sound.midi. VoiceStatus
该声音当前正在使用的乐器的银行号码。
bankIndices - Variable in class java.awt.image. ComponentSampleModel
每个存储一个图像数据带的存储体的索引。
banks - Variable in class java.awt.image. DataBuffer
此DataBuffer中的存储区数。
BarChart< X, Y> - Class in javafx.scene.chart
绘制一个指示类别数据值的条形图。
BarChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. BarChart
用给定的轴构建一个新的BarChart。
BarChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>) - Constructor for class javafx.scene.chart. BarChart
用给定的轴和数据构造一个新的BarChart。
BarChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>, double) - Constructor for class javafx.scene.chart. BarChart
用给定的轴和数据构造一个新的BarChart。
BARE - javax.jws.soap. SOAPBinding.ParameterStyle
barGapProperty() - Method in class javafx.scene.chart. BarChart
在同一类别的酒吧之间留下的差距
base - Variable in class javax.swing.text.html.parser. DTD
元素对应于基数。
BASE - Static variable in class javax.swing.text.html. HTML.Tag
标签<base>
Base64 - Class in java.util
该类仅由用于获得Base64编码方案的编码器和解码器的静态方法组成。
BASE64 - Static variable in interface javax.xml.crypto.dsig. Transform
Base64转换算法URI。
Base64.Decoder - Class in java.util
该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于解码字节数据的解码器。
Base64.Encoder - Class in java.util
该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于编码字节数据的编码器。
baseDirectory() - Method in interface com.sun.jdi. PathSearchingVirtualMachine
获取用于路径搜索的基本目录。
BASEFONT - Static variable in class javax.swing.text.html. HTML.Tag
标签<basefont>
baseIsLeftToRight() - Method in class java.text. Bidi
如果基本方向是从左到右，则返回true。
BASELINE - javafx.geometry. VPos
表示基线垂直位置。
BASELINE - javax.swing. GroupLayout.Alignment
表示元素应沿其基线对齐。
BASELINE - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
BASELINE - Static variable in class javax.swing. SpringLayout
指定组件的基线。
BASELINE_CENTER - javafx.geometry. Pos
在垂直方向和中心水平方向上表示基线的位置。
BASELINE_LEADING - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
BASELINE_LEFT - javafx.geometry. Pos
表示垂直方向和左侧水平位置。
BASELINE_OFFSET_SAME_AS_HEIGHT - Static variable in class javafx.scene. Node
这是 Node.getBaselineOffset()可能返回的特殊值。
BASELINE_RIGHT - javafx.geometry. Pos
在垂直方向和右侧的水平位置表示基线的位置。
BASELINE_TRAILING - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
baselineLayout(int, int, int[], int[]) - Method in class javax.swing.text. BoxView
计算 BoxView的每个子视图的位置和范围，这是 targetSpan ，它是我们必须使用的区域的宽度（或高度）。
baselineOffsetProperty() - Method in class javafx.scene.text. Text
“文字”（或罗马）基线偏离了文本节点的layoutBounds.minY位置。
baselineRequirements(int, SizeRequirements) - Method in class javax.swing.text. BoxView
通过检查每个子视图的大小来计算此 BoxView的大小要求。
BaselineTIFFTagSet - Class in javax.imageio.plugins.tiff
表示在基准TIFF规范中找到的一组标签的类以及一些常见的附加标签。
BaseMultiResolutionImage - Class in java.awt.image
这个类是基于数组的 AbstractMultiResolutionImage类的实现。
BaseMultiResolutionImage(int, Image...) - Constructor for class java.awt.image. BaseMultiResolutionImage
使用给定的基本图像索引和分辨率变体创建多分辨率图像。
BaseMultiResolutionImage(Image...) - Constructor for class java.awt.image. BaseMultiResolutionImage
使用给定的分辨率变体创建多分辨率图像。
BaseRowSet - Class in javax.sql.rowset
一个抽象类，提供一个 RowSet对象及其基本功能。
BaseRowSet() - Constructor for class javax.sql.rowset. BaseRowSet
构造一个新的 BaseRowSet对象，其初始化为其 listeners字段的默认 Vector对象。
BaseStream< T, S extends BaseStream< T, S>> - Interface in java.util.stream
流的基本界面，它们是支持顺序和并行聚合操作的元素序列。
baseVersion() - Static method in class java.util.jar. JarFile
返回表示多版本jar文件的未版本化配置的版本。
baseWireHandle - Static variable in interface java.io. ObjectStreamConstants
要分配的第一根钢丝柄。
BASIC_ISO_DATE - Static variable in class java.time.format. DateTimeFormatter
格式化或解析没有偏移量的日期的ISO日期格式化程序，例如“20111203”。
BASIC_LATIN - Static variable in class java.lang. Character.UnicodeBlock
Unicode基本字符块的常数。
BasicArrowButton - Class in javax.swing.plaf.basic
JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
BasicArrowButton(int) - Constructor for class javax.swing.plaf.basic. BasicArrowButton
创建一个 BasicArrowButton其箭头在指定的方向绘制。
BasicArrowButton(int, Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic. BasicArrowButton
创建一个 BasicArrowButton其箭头以指定的方向绘制并具有指定的颜色。
BasicAttribute - Class in javax.naming.directory
这个类提供了 Attribute接口的基本实现。
BasicAttribute(String) - Constructor for class javax.naming.directory. BasicAttribute
构造无值的无序属性的新实例。
BasicAttribute(String, boolean) - Constructor for class javax.naming.directory. BasicAttribute
构造一个没有值的可能有序属性的新实例。
BasicAttribute(String, Object) - Constructor for class javax.naming.directory. BasicAttribute
使用单个值构造无序属性的新实例。
BasicAttribute(String, Object, boolean) - Constructor for class javax.naming.directory. BasicAttribute
构造具有单个值的可能有序属性的新实例。
BasicAttributes - Class in javax.naming.directory
该类提供了Attributes界面的基本实现。
BasicAttributes() - Constructor for class javax.naming.directory. BasicAttributes
构造一个新的属性实例。
BasicAttributes(boolean) - Constructor for class javax.naming.directory. BasicAttributes
构造一个新的属性实例。
BasicAttributes(String, Object) - Constructor for class javax.naming.directory. BasicAttributes
使用一个属性构造一个新的属性实例。
BasicAttributes(String, Object, boolean) - Constructor for class javax.naming.directory. BasicAttributes
使用一个属性构造一个新的属性实例。
BasicAuthenticator - Class in com.sun.net.httpserver
BasicAuthenticator提供HTTP Basic认证的实现。
BasicAuthenticator(String) - Constructor for class com.sun.net.httpserver. BasicAuthenticator
为给定的HTTP领域创建BasicAuthenticator
BasicBorders - Class in javax.swing.plaf.basic
工厂对象可以出售适用于基本L＆F的边界
BasicBorders() - Constructor for class javax.swing.plaf.basic. BasicBorders
BasicBorders.ButtonBorder - Class in javax.swing.plaf.basic
画一个按钮周围的边框。
BasicBorders.FieldBorder - Class in javax.swing.plaf.basic
绘制一个字段周围的边框。
BasicBorders.MarginBorder - Class in javax.swing.plaf.basic
围绕支持边距的组件绘制边框。
BasicBorders.MenuBarBorder - Class in javax.swing.plaf.basic
绘制菜单栏周围的边框。
BasicBorders.RadioButtonBorder - Class in javax.swing.plaf.basic
绘制单选按钮周围的边框。
BasicBorders.RolloverButtonBorder - Class in javax.swing.plaf.basic
特殊的细边框，用于翻转工具栏按钮。
BasicBorders.SplitPaneBorder - Class in javax.swing.plaf.basic
画出裂缝周围的边界。
BasicBorders.ToggleButtonBorder - Class in javax.swing.plaf.basic
绘制切换按钮周围的边框。
BasicButtonListener - Class in javax.swing.plaf.basic
按钮监听器
BasicButtonListener(AbstractButton) - Constructor for class javax.swing.plaf.basic. BasicButtonListener
构造一个新的实例 BasicButtonListener 。
BasicButtonUI - Class in javax.swing.plaf.basic
BasicButton实现
BasicButtonUI() - Constructor for class javax.swing.plaf.basic. BasicButtonUI
BasicCaret() - Constructor for class javax.swing.plaf.basic. BasicTextUI.BasicCaret
BasicCheckBoxMenuItemUI - Class in javax.swing.plaf.basic
BasicCheckboxMenuItem实现
BasicCheckBoxMenuItemUI() - Constructor for class javax.swing.plaf.basic. BasicCheckBoxMenuItemUI
BasicCheckBoxUI - Class in javax.swing.plaf.basic
BasicCheckboxUI的CheckboxUI实现
BasicCheckBoxUI() - Constructor for class javax.swing.plaf.basic. BasicCheckBoxUI
BasicColorChooserUI - Class in javax.swing.plaf.basic
为JColorChooser提供基本的外观和感觉。
BasicColorChooserUI() - Constructor for class javax.swing.plaf.basic. BasicColorChooserUI
BasicColorChooserUI.PropertyHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicComboBoxEditor - Class in javax.swing.plaf.basic
可编辑组合框的默认编辑器。
BasicComboBoxEditor() - Constructor for class javax.swing.plaf.basic. BasicComboBoxEditor
构造一个新的实例 BasicComboBoxEditor 。
BasicComboBoxEditor.UIResource - Class in javax.swing.plaf.basic
BasicComboBoxEditor的子类实现UIResource。
BasicComboBoxRenderer - Class in javax.swing.plaf.basic
ComboBox渲染器
BasicComboBoxRenderer() - Constructor for class javax.swing.plaf.basic. BasicComboBoxRenderer
构造一个新的实例 BasicComboBoxRenderer 。
BasicComboBoxRenderer.UIResource - Class in javax.swing.plaf.basic
BasicComboBoxRenderer的子类实现UIResource。
BasicComboBoxUI - Class in javax.swing.plaf.basic
JComboBox的基本UI实现。
BasicComboBoxUI() - Constructor for class javax.swing.plaf.basic. BasicComboBoxUI
BasicComboBoxUI.ComboBoxLayoutManager - Class in javax.swing.plaf.basic
该布局管理器处理组合框的“标准”布局。
BasicComboBoxUI.FocusHandler - Class in javax.swing.plaf.basic
当焦点丢失时，此侦听器隐藏弹出窗口。
BasicComboBoxUI.ItemHandler - Class in javax.swing.plaf.basic
此监听器监视组合框中对选择的更改。
BasicComboBoxUI.KeyHandler - Class in javax.swing.plaf.basic
该侦听器检查键事件是否不是导航键。
BasicComboBoxUI.ListDataHandler - Class in javax.swing.plaf.basic
这位听众观看 ComboBoxModel变化。
BasicComboBoxUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
该监听器监视组合框中已更改的绑定属性。
BasicComboPopup - Class in javax.swing.plaf.basic
这是 ComboPopup界面的基本实现。
BasicComboPopup(JComboBox<Object>) - Constructor for class javax.swing.plaf.basic. BasicComboPopup
构造一个新的实例 BasicComboPopup 。
BasicComboPopup.InvocationKeyHandler - Class in javax.swing.plaf.basic
从Java 2平台v 1.4开始，此类现在已经过时，仅用于向后兼容API。
BasicComboPopup.InvocationMouseHandler - Class in javax.swing.plaf.basic
在组合框（ 而不是其弹出菜单）上注册的侦听器来处理影响弹出菜单状态的鼠标事件。
BasicComboPopup.InvocationMouseMotionHandler - Class in javax.swing.plaf.basic
如果拖动列表，该监听器将监视拖动并更新列表中的当前选择。
BasicComboPopup.ItemHandler - Class in javax.swing.plaf.basic
此监听器监视组合框中对选择的更改。
BasicComboPopup.ListDataHandler - Class in javax.swing.plaf.basic
从1.4开始，这个类现在已经过时了，不做任何事情，只能包含用于向后兼容的API。
BasicComboPopup.ListMouseHandler - Class in javax.swing.plaf.basic
当列表中释放鼠标时，此侦听器会隐藏弹出窗口。
BasicComboPopup.ListMouseMotionHandler - Class in javax.swing.plaf.basic
当您将鼠标移动到列表上时，此侦听器将更改所选项。
BasicComboPopup.ListSelectionHandler - Class in javax.swing.plaf.basic
从Java 2平台v 1.4开始，这个类现在已经过时了，不做任何事情，只包含在后端的API兼容性中。
BasicComboPopup.PropertyChangeHandler - Class in javax.swing.plaf.basic
该监听器监视组合框中已更改的绑定属性。
BasicControl - Class in javax.naming.ldap
该类提供了 Control接口的基本实现。
BasicControl(String) - Constructor for class javax.naming.ldap. BasicControl
构建非关键控件。
BasicControl(String, boolean, byte[]) - Constructor for class javax.naming.ldap. BasicControl
使用提供的参数构造一个控件。
BasicDesktopIconUI - Class in javax.swing.plaf.basic
桌面上最小化窗口的基本L＆F。
BasicDesktopIconUI() - Constructor for class javax.swing.plaf.basic. BasicDesktopIconUI
构造一个新的实例 BasicDesktopIconUI 。
BasicDesktopIconUI.MouseInputHandler - Class in javax.swing.plaf.basic
监听鼠标移动并对其进行操作。
BasicDesktopPaneUI - Class in javax.swing.plaf.basic
台式机的基本L＆F。
BasicDesktopPaneUI() - Constructor for class javax.swing.plaf.basic. BasicDesktopPaneUI
构造一个新的实例 BasicDesktopPaneUI 。
BasicDesktopPaneUI.CloseAction - Class in javax.swing.plaf.basic
处理关闭内部框架。
BasicDesktopPaneUI.MaximizeAction - Class in javax.swing.plaf.basic
处理最大化内部框架。
BasicDesktopPaneUI.MinimizeAction - Class in javax.swing.plaf.basic
处理最小化内部框架。
BasicDesktopPaneUI.NavigateAction - Class in javax.swing.plaf.basic
处理导航到下一个内部框架。
BasicDesktopPaneUI.OpenAction - Class in javax.swing.plaf.basic
处理恢复最小化或最大化的内部框架。
BasicDirectoryModel - Class in javax.swing.plaf.basic
文件列表的基本实现。
BasicDirectoryModel(JFileChooser) - Constructor for class javax.swing.plaf.basic. BasicDirectoryModel
构造一个新的实例 BasicDirectoryModel 。
BasicEditorPaneUI - Class in javax.swing.plaf.basic
为JEditorPane提供外观和感觉。
BasicEditorPaneUI() - Constructor for class javax.swing.plaf.basic. BasicEditorPaneUI
创建一个新的BasicEditorPaneUI。
BasicFileAttributes - Interface in java.nio.file.attribute
与文件系统中的文件相关联的基本属性。
BasicFileAttributeView - Interface in java.nio.file.attribute
文件属性视图，提供许多文件系统通用的 基本文件属性 集的视图。
BasicFileChooserUI - Class in javax.swing.plaf.basic
FileChooser的基本L＆F实现。
BasicFileChooserUI(JFileChooser) - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI
构造一个 BasicFileChooserUI 。
BasicFileChooserUI.AcceptAllFileFilter - Class in javax.swing.plaf.basic
接受所有文件过滤器。
BasicFileChooserUI.ApproveSelectionAction - Class in javax.swing.plaf.basic
响应打开或保存请求
BasicFileChooserUI.BasicFileView - Class in javax.swing.plaf.basic
一个基本的文件视图。
BasicFileChooserUI.CancelSelectionAction - Class in javax.swing.plaf.basic
回复取消请求。
BasicFileChooserUI.ChangeToParentDirectoryAction - Class in javax.swing.plaf.basic
更改为父目录操作。
BasicFileChooserUI.DoubleClickListener - Class in javax.swing.plaf.basic
双击监听器。
BasicFileChooserUI.GoHomeAction - Class in javax.swing.plaf.basic
在“家”键事件或等效事件上行事。
BasicFileChooserUI.NewFolderAction - Class in javax.swing.plaf.basic
创建一个新文件夹。
BasicFileChooserUI.SelectionListener - Class in javax.swing.plaf.basic
选择听众。
BasicFileChooserUI.UpdateAction - Class in javax.swing.plaf.basic
重新扫描当前目录中的文件
BasicFileView() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView
构造一个 BasicFileView 。
BasicFormattedTextFieldUI - Class in javax.swing.plaf.basic
为 JFormattedTextField提供外观实现。
BasicFormattedTextFieldUI() - Constructor for class javax.swing.plaf.basic. BasicFormattedTextFieldUI
BasicGraphicsUtils - Class in javax.swing.plaf.basic
方便的util类。
BasicGraphicsUtils() - Constructor for class javax.swing.plaf.basic. BasicGraphicsUtils
BasicHighlighter() - Constructor for class javax.swing.plaf.basic. BasicTextUI.BasicHighlighter
BasicHTML - Class in javax.swing.plaf.basic
支持为swing组件提供html视图。
BasicHTML() - Constructor for class javax.swing.plaf.basic. BasicHTML
BasicIconFactory - Class in javax.swing.plaf.basic
工厂对象可以将图标适用于基本的L＆F
BasicIconFactory() - Constructor for class javax.swing.plaf.basic. BasicIconFactory
BasicInternalFrameListener() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener
BasicInternalFrameTitlePane - Class in javax.swing.plaf.basic
管理基本标题栏的类
BasicInternalFrameTitlePane(JInternalFrame) - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane
构造一个新的实例 BasicInternalFrameTitlePane 。
BasicInternalFrameTitlePane.CloseAction - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.IconifyAction - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.MaximizeAction - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.MoveAction - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.PropertyChangeHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.RestoreAction - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.SizeAction - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.SystemMenuBar - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameTitlePane.TitlePaneLayout - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicInternalFrameUI - Class in javax.swing.plaf.basic
JInternalFrame的基本L＆F实现。
BasicInternalFrameUI(JInternalFrame) - Constructor for class javax.swing.plaf.basic. BasicInternalFrameUI
构造一个 BasicInternalFrameUI 。
BasicInternalFrameUI.BasicInternalFrameListener - Class in javax.swing.plaf.basic
基本内部框架监听器。
BasicInternalFrameUI.BorderListener - Class in javax.swing.plaf.basic
倾听边界调整。
BasicInternalFrameUI.ComponentHandler - Class in javax.swing.plaf.basic
组件处理程序
BasicInternalFrameUI.GlassPaneDispatcher - Class in javax.swing.plaf.basic
玻璃窗格调度器。
BasicInternalFrameUI.InternalFrameLayout - Class in javax.swing.plaf.basic
内部框架布局。
BasicInternalFrameUI.InternalFramePropertyChangeListener - Class in javax.swing.plaf.basic
内部框架属性更改侦听器。
BasicLabelUI - Class in javax.swing.plaf.basic
LabelUI的Windows L＆F实现。
BasicLabelUI() - Constructor for class javax.swing.plaf.basic. BasicLabelUI
BasicListUI - Class in javax.swing.plaf.basic
可扩展的实现 ListUI 。
BasicListUI() - Constructor for class javax.swing.plaf.basic. BasicListUI
BasicListUI.FocusHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicListUI.ListDataHandler - Class in javax.swing.plaf.basic
该 ListDataListener被添加到 JLists型号在 installUI time ，并且每当JList.model属性更改。
BasicListUI.ListSelectionHandler - Class in javax.swing.plaf.basic
在installUI时添加到JLists选择模型的ListSelectionListener，以及JList.selectionModel属性更改时。
BasicListUI.MouseInputHandler - Class in javax.swing.plaf.basic
鼠标输入和JList的焦点处理。
BasicListUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
在InstallUI时添加到JList的PropertyChangeListener。
BasicLookAndFeel - Class in javax.swing.plaf.basic
用于创建Swing的外观的基础类。
BasicLookAndFeel() - Constructor for class javax.swing.plaf.basic. BasicLookAndFeel
BasicMenuBarUI - Class in javax.swing.plaf.basic
MenuBarUI的默认L＆F实现。
BasicMenuBarUI() - Constructor for class javax.swing.plaf.basic. BasicMenuBarUI
BasicMenuItemUI - Class in javax.swing.plaf.basic
BasicMenuItem实现
BasicMenuItemUI() - Constructor for class javax.swing.plaf.basic. BasicMenuItemUI
BasicMenuItemUI.MouseInputHandler - Class in javax.swing.plaf.basic
鼠标输入处理程序
BasicMenuUI - Class in javax.swing.plaf.basic
MenuUI的默认L＆F实现。
BasicMenuUI() - Constructor for class javax.swing.plaf.basic. BasicMenuUI
BasicMenuUI.ChangeHandler - Class in javax.swing.plaf.basic
从Java 2平台1.4开始，这个以前没有记录的类现在已经过时了。
BasicMenuUI.MouseInputHandler - Class in javax.swing.plaf.basic
由菜单项实例化和使用，以处理鼠标事件当前的菜单选择。
BasicOptionPaneUI - Class in javax.swing.plaf.basic
提供 JOptionPane的基本外观和感觉。
BasicOptionPaneUI() - Constructor for class javax.swing.plaf.basic. BasicOptionPaneUI
BasicOptionPaneUI.ButtonActionListener - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicOptionPaneUI.ButtonAreaLayout - Class in javax.swing.plaf.basic
ButtonAreaLayout行为方式与 FlowLayout相似。
BasicOptionPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicPanelUI - Class in javax.swing.plaf.basic
BasicPanel实现
BasicPanelUI() - Constructor for class javax.swing.plaf.basic. BasicPanelUI
BasicPasswordFieldUI - Class in javax.swing.plaf.basic
提供Windows外观和密码字段。
BasicPasswordFieldUI() - Constructor for class javax.swing.plaf.basic. BasicPasswordFieldUI
BasicPermission - Class in java.security
BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
BasicPermission(String) - Constructor for class java.security. BasicPermission
用指定的名称创建一个新的BasicPermission。
BasicPermission(String, String) - Constructor for class java.security. BasicPermission
创建一个具有指定名称的新BasicPermission对象。
BasicPopupMenuSeparatorUI - Class in javax.swing.plaf.basic
PopupMenuSeparatorUI的基本L＆F实现。
BasicPopupMenuSeparatorUI() - Constructor for class javax.swing.plaf.basic. BasicPopupMenuSeparatorUI
BasicPopupMenuUI - Class in javax.swing.plaf.basic
一个Windows L＆F实现的PopupMenuUI。
BasicPopupMenuUI() - Constructor for class javax.swing.plaf.basic. BasicPopupMenuUI
构造一个新的实例 BasicPopupMenuUI 。
BasicProgressBarUI - Class in javax.swing.plaf.basic
ProgressBarUI的基本L＆F实现。
BasicProgressBarUI() - Constructor for class javax.swing.plaf.basic. BasicProgressBarUI
BasicProgressBarUI.ChangeHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicRadioButtonMenuItemUI - Class in javax.swing.plaf.basic
BasicRadioButtonMenuItem实现
BasicRadioButtonMenuItemUI() - Constructor for class javax.swing.plaf.basic. BasicRadioButtonMenuItemUI
BasicRadioButtonUI - Class in javax.swing.plaf.basic
BasicRadioButtonUI的RadioButtonUI实现
BasicRadioButtonUI() - Constructor for class javax.swing.plaf.basic. BasicRadioButtonUI
BasicRootPaneUI - Class in javax.swing.plaf.basic
RootPaneUI的基本实现，所有JRootPane实例之间共享一个。
BasicRootPaneUI() - Constructor for class javax.swing.plaf.basic. BasicRootPaneUI
BasicScrollBarUI - Class in javax.swing.plaf.basic
实现ScrollBarUI的基本外观和感觉
BasicScrollBarUI() - Constructor for class javax.swing.plaf.basic. BasicScrollBarUI
BasicScrollBarUI.ArrowButtonListener - Class in javax.swing.plaf.basic
光标键侦听器。
BasicScrollBarUI.ModelListener - Class in javax.swing.plaf.basic
监听模式更改的监听器。
BasicScrollBarUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
属性更改处理程序
BasicScrollBarUI.ScrollListener - Class in javax.swing.plaf.basic
在 ScrollPane发起的滚动事件侦听器。
BasicScrollBarUI.TrackListener - Class in javax.swing.plaf.basic
跟踪鼠标拖动。
BasicScrollPaneUI - Class in javax.swing.plaf.basic
ScrollPaneUI的默认L＆F实现。
BasicScrollPaneUI() - Constructor for class javax.swing.plaf.basic. BasicScrollPaneUI
BasicScrollPaneUI.HSBChangeListener - Class in javax.swing.plaf.basic
水平滚动条监听器。
BasicScrollPaneUI.MouseWheelHandler - Class in javax.swing.plaf.basic
MouseWheelHandler是一个实现MouseWheelListener接口的内部类。
BasicScrollPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
属性更改处理程序
BasicScrollPaneUI.ViewportChangeHandler - Class in javax.swing.plaf.basic
监听器用于视口事件。
BasicScrollPaneUI.VSBChangeListener - Class in javax.swing.plaf.basic
垂直卷轴侦听器。
BasicSeparatorUI - Class in javax.swing.plaf.basic
SeparatorUI的基本L＆F实现。
BasicSeparatorUI() - Constructor for class javax.swing.plaf.basic. BasicSeparatorUI
BasicService - Interface in javax.jnlp
BasicService接口可以访问应用程序的代码库，如果应用程序以离线模式运行，以及在给定平台上与本机浏览器的简单交互。
BasicSliderUI - Class in javax.swing.plaf.basic
SliderUI的基本L＆F实现。
BasicSliderUI(JSlider) - Constructor for class javax.swing.plaf.basic. BasicSliderUI
构造一个 BasicSliderUI 。
BasicSliderUI.ActionScroller - Class in javax.swing.plaf.basic
从Java 2平台v1.3开始，这个未记录的类就不再使用了。
BasicSliderUI.ChangeHandler - Class in javax.swing.plaf.basic
数据模型侦听器
BasicSliderUI.ComponentHandler - Class in javax.swing.plaf.basic
调整事件大小的侦听器。
BasicSliderUI.FocusHandler - Class in javax.swing.plaf.basic
聚焦改变听众
BasicSliderUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
属性更改处理程序。
BasicSliderUI.ScrollListener - Class in javax.swing.plaf.basic
滚动事件侦听器。
BasicSliderUI.TrackListener - Class in javax.swing.plaf.basic
跟踪鼠标移动。
BasicSpinnerUI - Class in javax.swing.plaf.basic
默认的Spinner UI委托。
BasicSpinnerUI() - Constructor for class javax.swing.plaf.basic. BasicSpinnerUI
BasicSplitPaneDivider - Class in javax.swing.plaf.basic
BasicSplitPaneUI使用的分隔符。
BasicSplitPaneDivider(BasicSplitPaneUI) - Constructor for class javax.swing.plaf.basic. BasicSplitPaneDivider
创建一个 BasicSplitPaneDivider的实例。
BasicSplitPaneDivider.DividerLayout - Class in javax.swing.plaf.basic
用于布局一个 BasicSplitPaneDivider 。
BasicSplitPaneDivider.DragController - Class in javax.swing.plaf.basic
在针对HORIZONTAL_SPLIT的拆分窗格的拖动会话期间处理事件。
BasicSplitPaneDivider.MouseHandler - Class in javax.swing.plaf.basic
MouseHandler负责将鼠标事件（释放，拖动...）转换为适当的DragController方法。
BasicSplitPaneDivider.VerticalDragController - Class in javax.swing.plaf.basic
在VERTICAL_SPLIT面向拆分窗格的拖动会话期间处理事件。
BasicSplitPaneUI - Class in javax.swing.plaf.basic
SplitPaneUI的基本L＆F实现。
BasicSplitPaneUI() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI
BasicSplitPaneUI.BasicHorizontalLayoutManager - Class in javax.swing.plaf.basic
具有方向为HORIZONTAL_SPLIT的JSplitPanes的LayoutManager。
BasicSplitPaneUI.BasicVerticalLayoutManager - Class in javax.swing.plaf.basic
LayoutManager用于JSplitPanes，方向为VERTICAL_SPLIT。
BasicSplitPaneUI.FocusHandler - Class in javax.swing.plaf.basic
JSplitPane UI使用的FocusListener的实现。
BasicSplitPaneUI.KeyboardDownRightHandler - Class in javax.swing.plaf.basic
JSplitPane UI用于处理特定按键的ActionListener的实现。
BasicSplitPaneUI.KeyboardEndHandler - Class in javax.swing.plaf.basic
JSplitPane UI用于处理特定按键的ActionListener的实现。
BasicSplitPaneUI.KeyboardHomeHandler - Class in javax.swing.plaf.basic
JSplitPane UI用于处理特定按键的ActionListener的实现。
BasicSplitPaneUI.KeyboardResizeToggleHandler - Class in javax.swing.plaf.basic
JSplitPane UI用于处理特定按键的ActionListener的实现。
BasicSplitPaneUI.KeyboardUpLeftHandler - Class in javax.swing.plaf.basic
JSplitPane UI用于处理特定按键的ActionListener的实现。
BasicSplitPaneUI.PropertyHandler - Class in javax.swing.plaf.basic
实现JSplitPane UI使用的PropertyChangeListener。
BasicStroke - Class in java.awt
BasicStroke类为图形基元的轮廓定义了一组基本的渲染属性，这些属性使用一个将其Stroke属性设置为BasicStroke的Graphics2D对象呈现。
BasicStroke() - Constructor for class java.awt. BasicStroke
构造一个新的 BasicStroke ，默认为所有属性。
BasicStroke(float) - Constructor for class java.awt. BasicStroke
构造一个固定的 BasicStroke具有指定的行宽，并使用上限和连接样式的默认值。
BasicStroke(float, int, int) - Constructor for class java.awt. BasicStroke
构造具有指定属性的实体 BasicStroke 。
BasicStroke(float, int, int, float) - Constructor for class java.awt. BasicStroke
构造具有指定属性的实体 BasicStroke 。
BasicStroke(float, int, int, float, float[], float) - Constructor for class java.awt. BasicStroke
构造具有指定属性的新的 BasicStroke 。
BasicTabbedPaneUI - Class in javax.swing.plaf.basic
TabbedPaneUI的基本L＆F实现。
BasicTabbedPaneUI() - Constructor for class javax.swing.plaf.basic. BasicTabbedPaneUI
BasicTabbedPaneUI.FocusHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTabbedPaneUI.MouseHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTabbedPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTabbedPaneUI.TabbedPaneLayout - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTabbedPaneUI.TabSelectionHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTableHeaderUI - Class in javax.swing.plaf.basic
BasicTableHeaderUI实现
BasicTableHeaderUI() - Constructor for class javax.swing.plaf.basic. BasicTableHeaderUI
BasicTableHeaderUI.MouseInputHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTableUI - Class in javax.swing.plaf.basic
BasicTableUI实现
BasicTableUI() - Constructor for class javax.swing.plaf.basic. BasicTableUI
BasicTableUI.FocusHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTableUI.KeyHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTableUI.MouseInputHandler - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicTextAreaUI - Class in javax.swing.plaf.basic
提供纯文本编辑器的外观和感觉。
BasicTextAreaUI() - Constructor for class javax.swing.plaf.basic. BasicTextAreaUI
构造一个新的BasicTextAreaUI对象。
BasicTextFieldUI - Class in javax.swing.plaf.basic
JTextField的外观和感觉的基础。
BasicTextFieldUI() - Constructor for class javax.swing.plaf.basic. BasicTextFieldUI
创建一个新的BasicTextFieldUI。
BasicTextPaneUI - Class in javax.swing.plaf.basic
为风格的文本编辑器提供外观和感觉。
BasicTextPaneUI() - Constructor for class javax.swing.plaf.basic. BasicTextPaneUI
创建一个新的BasicTextPaneUI。
BasicTextUI - Class in javax.swing.plaf.basic
文本元素的外观和感觉的基础。
BasicTextUI() - Constructor for class javax.swing.plaf.basic. BasicTextUI
创建一个新的UI。
BasicTextUI.BasicCaret - Class in javax.swing.plaf.basic
默认实现接口 Caret 。
BasicTextUI.BasicHighlighter - Class in javax.swing.plaf.basic
默认实现接口 Highlighter 。
BasicToggleButtonUI - Class in javax.swing.plaf.basic
BasicToggleButton实现
BasicToggleButtonUI() - Constructor for class javax.swing.plaf.basic. BasicToggleButtonUI
BasicToolBarSeparatorUI - Class in javax.swing.plaf.basic
ToolBarSeparatorUI的基本L＆F实现。
BasicToolBarSeparatorUI() - Constructor for class javax.swing.plaf.basic. BasicToolBarSeparatorUI
BasicToolBarUI - Class in javax.swing.plaf.basic
ToolBarUI的基本L＆F实现。
BasicToolBarUI() - Constructor for class javax.swing.plaf.basic. BasicToolBarUI
BasicToolBarUI.DockingListener - Class in javax.swing.plaf.basic
这个类应该被视为一个“受保护”的内部类。
BasicToolBarUI.DragWindow - Class in javax.swing.plaf.basic
在拖动 JToolBar期间出现的窗口。
BasicToolBarUI.FrameListener - Class in javax.swing.plaf.basic
该类监听窗口事件。
BasicToolBarUI.PropertyListener - Class in javax.swing.plaf.basic
该类监听属性更改的事件。
BasicToolBarUI.ToolBarContListener - Class in javax.swing.plaf.basic
该类侦听组件事件。
BasicToolBarUI.ToolBarFocusListener - Class in javax.swing.plaf.basic
班级聆听焦点事件。
BasicToolTipUI - Class in javax.swing.plaf.basic
标准刀尖L＆F。
BasicToolTipUI() - Constructor for class javax.swing.plaf.basic. BasicToolTipUI
构造一个新的实例 BasicToolTipUI 。
BasicTreeUI - Class in javax.swing.plaf.basic
分层数据结构的基本L＆F。
BasicTreeUI() - Constructor for class javax.swing.plaf.basic. BasicTreeUI
构造一个新的实例 BasicTreeUI 。
BasicTreeUI.CellEditorHandler - Class in javax.swing.plaf.basic
监听器负责获取单元格编辑事件并相应地更新树。
BasicTreeUI.ComponentHandler - Class in javax.swing.plaf.basic
更新滚动时的首选大小（如有必要）。
BasicTreeUI.FocusHandler - Class in javax.swing.plaf.basic
当重点丢失/获得时，重新排列主导选择行。
BasicTreeUI.KeyHandler - Class in javax.swing.plaf.basic
这用于获取多个关键事件以适当地生成事件。
BasicTreeUI.MouseHandler - Class in javax.swing.plaf.basic
TreeMouseListener负责根据鼠标事件更新选择。
BasicTreeUI.MouseInputHandler - Class in javax.swing.plaf.basic
MouseInputHandler处理所有鼠标事件，包括鼠标移动事件，直到鼠标释放到它构造的目的地。
BasicTreeUI.NodeDimensionsHandler - Class in javax.swing.plaf.basic
负责获取节点大小的类，方法转发到BasicTreeUI方法。
BasicTreeUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
PropertyChangeListener为树。
BasicTreeUI.SelectionModelPropertyChangeHandler - Class in javax.swing.plaf.basic
在TreeSelectionModel上的侦听器，如果模型的任何属性更改，则重置行选择。
BasicTreeUI.TreeCancelEditingAction - Class in javax.swing.plaf.basic
ActionListener在执行操作时调用cancelEditing。
BasicTreeUI.TreeExpansionHandler - Class in javax.swing.plaf.basic
响应节点扩展/折叠更新TreeState。
BasicTreeUI.TreeHomeAction - Class in javax.swing.plaf.basic
TreeHomeAction用于处理结束/ home操作。
BasicTreeUI.TreeIncrementAction - Class in javax.swing.plaf.basic
TreeIncrementAction用于处理上/下动作。
BasicTreeUI.TreeModelHandler - Class in javax.swing.plaf.basic
将所有TreeModel事件转发给TreeState。
BasicTreeUI.TreePageAction - Class in javax.swing.plaf.basic
TreePageAction处理页面向上和向下翻页事件。
BasicTreeUI.TreeSelectionHandler - Class in javax.swing.plaf.basic
监听选择模型中的更改，并相应地更新显示。
BasicTreeUI.TreeToggleAction - Class in javax.swing.plaf.basic
对于第一个选定的行展开将被切换。
BasicTreeUI.TreeTraverseAction - Class in javax.swing.plaf.basic
TreeTraverseAction是用于左/右键的动作。
BasicVerticalLayoutManager() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.BasicVerticalLayoutManager
构造一个新的实例 BasicVerticalLayoutManager 。
BasicViewportUI - Class in javax.swing.plaf.basic
BasicViewport实现
BasicViewportUI() - Constructor for class javax.swing.plaf.basic. BasicViewportUI
BASSA_VAH - java.lang. Character.UnicodeScript
Unicode脚本“Bassa Vah”。
BASSA_VAH - Static variable in class java.lang. Character.UnicodeBlock
常数为“Bassa Vah”Unicode字符块。
BATAK - java.lang. Character.UnicodeScript
Unicode脚本“Batak”。
BATAK - Static variable in class java.lang. Character.UnicodeBlock
“Batak”Unicode字符块的常量。
BATCHSIZE - Static variable in interface javax.naming. Context
包含用于指定通过服务协议返回数据时使用的批量大小的环境属性名称的常量。
BatchUpdateException - Exception in java.sql
在批量更新操作期间发生错误时，抛出SQLException的子类。
BatchUpdateException() - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException对象。
BatchUpdateException(int[]) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException对象，初始化为给定的 updateCounts 。
BatchUpdateException(int[], Throwable) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException对象，初始化为给定的 cause和 updateCounts 。
BatchUpdateException(String, int[]) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException对象，初始化为给定的 reason和 updateCounts 。
BatchUpdateException(String, int[], Throwable) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException与给定的初始化的对象 reason ， cause和 updateCounts 。
BatchUpdateException(String, String, int[]) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState和 updateCounts 。
BatchUpdateException(String, String, int[], Throwable) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， cause ，和 updateCounts 。
BatchUpdateException(String, String, int, int[]) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode和 updateCounts 。
BatchUpdateException(String, String, int, int[], Throwable) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。
BatchUpdateException(String, String, int, long[], Throwable) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。
BatchUpdateException(Throwable) - Constructor for exception java.sql. BatchUpdateException
构造一个 BatchUpdateException对象，使用给定的 cause初始化。
BC - Static variable in class java.util. GregorianCalendar
表示 ERA字段的价值，表示在共同时代之前（在基督之前），也称为公民时代之前的时期。
BCE - java.time.chrono. IsoEra
在当前时代之前的“当前时代之前”的单例实例，其数值为0。
bcmListeners - Variable in class java.beans.beancontext. BeanContextSupport
对 protected ArrayList bcmListeners字段的所有访问应在该对象上同步。
bcsChildren() - Method in class java.beans.beancontext. BeanContextSupport
返回此 BeanContext的所有子代的迭代器。
bcsListeners - Variable in class java.beans.beancontext. BeanContextServicesSupport
BeanContextServicesListener对象列表。
bcsPreDeserializationHook(ObjectInputStream) - Method in class java.beans.beancontext. BeanContextServicesSupport
从BeanContextSupport readObject中调用它反序列化子对象...
bcsPreDeserializationHook(ObjectInputStream) - Method in class java.beans.beancontext. BeanContextSupport
通过readObject在defaultReadObject（）之后调用，但在任何孩子反序列化之前。
bcsPreSerializationHook(ObjectOutputStream) - Method in class java.beans.beancontext. BeanContextServicesSupport
从BeanContextSupport中调用writeObject，然后序列化子对象...
bcsPreSerializationHook(ObjectOutputStream) - Method in class java.beans.beancontext. BeanContextSupport
在writeWriteObject（）之后但在序列化当前可序列化的孩子之前调用writeObject。
BE - java.time.chrono. ThaiBuddhistEra
当代时代的单身实例“佛教时代”，其数值为1。
bean(Object) - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder
设置适配器应该连接的Java Bean实例
bean(Object) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder
设置适配器应该连接的Java Bean实例
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder
设置要在其中搜索getter和setter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder
设置要在其中搜索getter和setter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder
设置要在其中搜索getter和setter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder
设置要在其中搜索getter和setter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder
设置要在其中搜索getter和setter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder
设置要在其中搜索getter和setter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder
设置要在其中搜索getter和setter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder
设置要在其中搜索getter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder
设置要在其中搜索getter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder
设置要在其中搜索getter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder
设置要在其中搜索getter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder
设置要在其中搜索getter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder
设置要在其中搜索getter的Java Bean类。
beanClass(Class<?>) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder
设置要在其中搜索getter的Java Bean类。
beanContext - Variable in class java.beans.beancontext. BeanContextChildSupport
bean上下文。
BeanContext - Interface in java.beans.beancontext
BeanContext对JavaBeans起着逻辑分层容器的作用。
BeanContextChild - Interface in java.beans.beancontext
希望嵌套在JavaBeans中，并且获得对它们的执行环境的引用，或者由BeanContext子接口定义的上下文将实现该接口。
BeanContextChildComponentProxy - Interface in java.beans.beancontext
该接口由 BeanContextChildren实现，它们具有与它们相关联的AWT Component 。
beanContextChildPeer - Variable in class java.beans.beancontext. BeanContextChildSupport
其中 BeanContext其中 BeanContextChild是嵌套的。
BeanContextChildSupport - Class in java.beans.beancontext
这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
BeanContextChildSupport() - Constructor for class java.beans.beancontext. BeanContextChildSupport
构造一个BeanContextChildSupport，此类已经被子类化，以便实现JavaBean组件本身。
BeanContextChildSupport(BeanContextChild) - Constructor for class java.beans.beancontext. BeanContextChildSupport
构造一个BeanContextChildSupport，其中JavaBean组件自身实现BeanContextChild，并封装了这个，将该接口委派给此实现
BeanContextContainerProxy - Interface in java.beans.beancontext
该接口由BeanContexts实现，它们具有与它们相关联的AWT容器。
BeanContextEvent - Class in java.beans.beancontext
BeanContextEvent是用于从发射的所有事件的抽象根事件类，和有关的语义，一个 BeanContext 。
BeanContextEvent(BeanContext) - Constructor for class java.beans.beancontext. BeanContextEvent
Contruct一个BeanContextEvent
BeanContextMembershipEvent - Class in java.beans.beancontext
A BeanContextMembershipEvent封装了添加到特定 BeanContext的成员资格或从其中删除的子项列表。
BeanContextMembershipEvent(BeanContext, Object[]) - Constructor for class java.beans.beancontext. BeanContextMembershipEvent
引发BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext, Collection) - Constructor for class java.beans.beancontext. BeanContextMembershipEvent
引发BeanContextMembershipEvent
BeanContextMembershipListener - Interface in java.beans.beancontext
BeanContext的成员状态发生变化时，BeanContexts会在此界面上触发事件。
BeanContextProxy - Interface in java.beans.beancontext
该接口由不直接具有与之关联的BeanContext（Child）的JavaBean实现（通过实现该接口或其子接口），但具有从其委托的公共BeanContext（Child）。
BeanContextServiceAvailableEvent - Class in java.beans.beancontext
BeanContextServicesListener使用此事件类型来识别正在注册的服务。
BeanContextServiceAvailableEvent(BeanContextServices, Class<?>) - Constructor for class java.beans.beancontext. BeanContextServiceAvailableEvent
构造一个 BeanContextAvailableServiceEvent 。
BeanContextServiceProvider - Interface in java.beans.beancontext
BeanContext的主要功能之一就是作为JavaBeans和BeanContextServiceProviders之间的会合。
BeanContextServiceProviderBeanInfo - Interface in java.beans.beancontext
一个BeanContextServiceProvider实现者希望提供关于他们的bean可能提供的服务的显式信息，应该实现一个实现这个BeanInfo子接口的BeanInfo类，并提供有关其服务的方法，属性，事件等的显式信息。
BeanContextServiceRevokedEvent - Class in java.beans.beancontext
该事件类型由 BeanContextServiceRevokedListener用于识别正在撤销的服务。
BeanContextServiceRevokedEvent(BeanContextServices, Class<?>, boolean) - Constructor for class java.beans.beancontext. BeanContextServiceRevokedEvent
构建一个 BeanContextServiceEvent 。
BeanContextServiceRevokedListener - Interface in java.beans.beancontext
用于接收 BeanContextServiceRevokedEvent对象的侦听器接口。
BeanContextServices - Interface in java.beans.beancontext
BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
BeanContextServicesListener - Interface in java.beans.beancontext
用于接收 BeanContextServiceAvailableEvent对象的侦听器接口。
BeanContextServicesSupport - Class in java.beans.beancontext
这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
BeanContextServicesSupport() - Constructor for class java.beans.beancontext. BeanContextServicesSupport
创建一个不是另一个对象的委托的实例
BeanContextServicesSupport(BeanContextServices) - Constructor for class java.beans.beancontext. BeanContextServicesSupport
与对等体创建一个实例
BeanContextServicesSupport(BeanContextServices, Locale) - Constructor for class java.beans.beancontext. BeanContextServicesSupport
使用指定的区域设置创建一个实例
BeanContextServicesSupport(BeanContextServices, Locale, boolean) - Constructor for class java.beans.beancontext. BeanContextServicesSupport
使用指定的区域设置和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices, Locale, boolean, boolean) - Constructor for class java.beans.beancontext. BeanContextServicesSupport
构造一个BeanContextServicesSupport实例
BeanContextServicesSupport.BCSSChild - Class in java.beans.beancontext
BeanContextServicesSupport.BCSSProxyServiceProvider - Class in java.beans.beancontext
BeanContextServicesSupport.BCSSServiceProvider - Class in java.beans.beancontext
子类可以将此嵌套类子类化为每个BeanContextServicesProvider添加行为。
BeanContextSupport - Class in java.beans.beancontext
这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
BeanContextSupport() - Constructor for class java.beans.beancontext. BeanContextSupport
创建一个不是另一个对象的委托的实例
BeanContextSupport(BeanContext) - Constructor for class java.beans.beancontext. BeanContextSupport
新新200新200新新新新新旗新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新
BeanContextSupport(BeanContext, Locale) - Constructor for class java.beans.beancontext. BeanContextSupport
使用指定的区域设置创建一个实例
BeanContextSupport(BeanContext, Locale, boolean) - Constructor for class java.beans.beancontext. BeanContextSupport
使用指定的区域设置和设计模式创建一个实例。
BeanContextSupport(BeanContext, Locale, boolean, boolean) - Constructor for class java.beans.beancontext. BeanContextSupport
200新新新新200新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗200新新旗新新200新
BeanContextSupport.BCSChild - Class in java.beans.beancontext
BeanContextSupport.BCSIterator - Class in java.beans.beancontext
受保护的final子类封装了一个迭代器，但实现了一个noop remove（）方法。
BeanDescriptor - Class in java.beans
BeanDescriptor提供有关“bean”的全局信息，包括其Java类，其displayName等。
BeanDescriptor(Class<?>) - Constructor for class java.beans. BeanDescriptor
为没有自定义程序的bean创建BeanDescriptor。
BeanDescriptor(Class<?>, Class<?>) - Constructor for class java.beans. BeanDescriptor
为具有自定义程序的bean创建BeanDescriptor。
BeanInfo - Interface in java.beans
使用 BeanInfo接口创建一个 BeanInfo类，并提供关于bean的方法，属性，事件和其他功能的显式信息。
BeanProperty - Annotation Type in java.beans
一个注释用于指定自动生成的BeanInfo类的一些属性相关信息。
Beans - Class in java.beans
这个类提供了一些通用的bean控制方法。
Beans() - Constructor for class java.beans. Beans
BeansLinker - Class in jdk.dynalink.beans
用于普通Java对象的链接器。
BeansLinker() - Constructor for class jdk.dynalink.beans. BeansLinker
创建一个新的bean连接器。
BeansLinker(MissingMemberHandlerFactory) - Constructor for class jdk.dynalink.beans. BeansLinker
使用指定的工厂创建一个新的bean连接器来创建缺少的成员处理程序。
beep() - Method in class java.awt. Toolkit
根据本地系统设置和硬件功能发出音频蜂鸣声。
beepAction - Static variable in class javax.swing.text. DefaultEditorKit
创建哔声的动作名称。
BeepAction() - Constructor for class javax.swing.text. DefaultEditorKit.BeepAction
使用相应的标识符创建此对象。
before(Object) - Method in class java.util. Calendar
返回 Calendar是否表示在指定的时间之前的时间 Object 。
before(Timestamp) - Method in class java.sql. Timestamp
指示此 Timestamp对象是否早于给定的 Timestamp对象。
before(Date) - Method in class java.util. Date
测试此日期是否在指定日期之前。
BEFORE - javax.swing. RowFilter.ComparisonType
表示应包含提供值之前的值的条目。
BEFORE_BE - java.time.chrono. ThaiBuddhistEra
在当前时代之前的“以前的佛教时代”，其数值为0的单例实例。
BEFORE_FIRST_LINE - Static variable in class java.awt. BorderLayout
PAGE_START的同义词。
BEFORE_INIT - javafx.application. Preloader.StateChangeNotification.Type
表示应用程序的init方法即将被调用。
BEFORE_LINE_BEGINS - Static variable in class java.awt. BorderLayout
LINE_START的同义词。
BEFORE_LOAD - javafx.application. Preloader.StateChangeNotification.Type
表示应用程序类即将被加载和构造。
BEFORE_ROC - java.time.chrono. MinguoEra
在当前时代之前的“中华民国时代之前”的单例，其数值为0。
BEFORE_START - javafx.application. Preloader.StateChangeNotification.Type
表示应用程序的start方法即将被调用。
beforeExecute(Thread, Runnable) - Method in class java.util.concurrent. ThreadPoolExecutor
在给定的线程中执行给定的Runnable之前调用方法。
beforeFirst() - Method in interface java.sql. ResultSet
将光标移动到此 ResultSet对象的正面，就在第一行之前。
beforeMarshal(Object) - Method in class javax.xml.bind. Marshaller.Listener
从 source编组到XML之前调用的回调方法。
beforeOffset(int) - Static method in class java.awt.font. TextHitInfo
以指定的偏移量创建 TextHitInfo ，与偏移量之前的字符相关联。
beforeUnmarshal(Object, Object) - Method in class javax.xml.bind. Unmarshaller.Listener
在解 target之前调用回调方法到 target 。
begin() - Method in class java.nio.channels.spi. AbstractInterruptibleChannel
标记可能无限期阻止的I / O操作的开始。
begin() - Method in class java.nio.channels.spi. AbstractSelector
标记可能无限期阻止的I / O操作的开始。
BEGIN - javafx.scene.input. KeyCode
常数为开始键。
beginAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号移动到文档开头的 Action名称。
beginChange() - Method in class javafx.collections. ObservableListBase
开始改变块
beginCopyElement() - Method in interface javafx.fxml. LoadListener
当加载程序开始读取复制元素时调用。
beginDefineElement() - Method in interface javafx.fxml. LoadListener
当加载程序已经开始阅读define元素时被调用。
beginDragDividerLocation - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
拖动会话开始时分隔线的位置。
beginDraggingFrame(JComponent) - Method in class javax.swing. DefaultDesktopManager
beginDraggingFrame(JComponent) - Method in interface javax.swing. DesktopManager
通常当用户指示它们将开始拖动组件时调用此方法。
beginExclusive() - Method in class javax.smartcardio. Card
请求独占访问此卡。
beginHandshake() - Method in class javax.net.ssl. SSLEngine
在这个SSLEngine上启动握手（初始或重新协商）。
beginIncludeElement() - Method in interface javafx.fxml. LoadListener
当加载程序开始读取包含元素时调用。
beginInstanceDeclarationElement(Class<?>) - Method in interface javafx.fxml. LoadListener
当加载程序开始读取实例声明元素时调用。
beginLineAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号移动到行的开头的 Action名称。
BEGINNING - javafx.scene.control.skin. TextInputControlSkin.Direction
beginParagraphAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号移动到段落开头的 Action名称。
beginPath() - Method in class javafx.scene.canvas. GraphicsContext
将当前路径重置为空。
beginPropertyElement(String, Class<?>) - Method in interface javafx.fxml. LoadListener
当加载程序开始读取属性元素时调用。
beginReferenceElement() - Method in interface javafx.fxml. LoadListener
当加载程序开始读取参考元素时调用。
beginRequest() - Method in interface java.sql. Connection
向司机提示，一个请求，一个独立的工作单位，正在开始这个连接。
beginResizingFrame(JComponent, int) - Method in class javax.swing. DefaultDesktopManager
beginResizingFrame(JComponent, int) - Method in interface javax.swing. DesktopManager
当用户指示它们将开始调整框架大小时，通常会调用此方法。
beginRootElement() - Method in interface javafx.fxml. LoadListener
当加载程序开始读取根元素时调用。
beginScriptElement() - Method in interface javafx.fxml. LoadListener
当加载程序开始读取脚本元素时调用。
beginUnknownStaticPropertyElement(String) - Method in interface javafx.fxml. LoadListener
当加载程序开始读取由未知类型定义的静态属性元素时调用。
beginUnknownTypeElement(String) - Method in interface javafx.fxml. LoadListener
当加载程序已经开始读取未知类型的实例声明元素时调用。
beginUpdate() - Method in class javax.swing.undo. UndoableEditSupport
beginWordAction - Static variable in class javax.swing.text. DefaultEditorKit
Action名称，用于将插入符号移动到单词的开头。
BEIGE - Static variable in class javafx.scene.paint. Color
颜色米色，RGB值为＃F5F5DC
belongsTo(EventTarget) - Method in class javafx.scene.input. TouchPoint
区分目标在给定节点或其某些孩子的触摸点之间的接触点，指向其他地方。
BELOW_BASELINE - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
BELOW_BASELINE_LEADING - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
BELOW_BASELINE_TRAILING - Static variable in class java.awt. GridBagConstraints
可能的值为 anchor字段。
BELOW_BOTTOM - Static variable in class javax.swing.border. TitledBorder
将标题放在边框底部的下方。
BELOW_TOP - Static variable in class javax.swing.border. TitledBorder
将标题放在边框顶部的下方。
BENGALI - java.awt.font. NumericShaper.Range
孟加拉语范围与孟加拉语数字。
BENGALI - java.lang. Character.UnicodeScript
Unicode脚本“孟加拉语”。
BENGALI - Static variable in class java.awt.font. NumericShaper
标识BENGALI范围和十进制基数。
BENGALI - Static variable in class java.lang. Character.UnicodeBlock
“孟加拉语”Unicode字符块的常数。
BEST_COMPRESSION - Static variable in class java.util.zip. Deflater
最佳压缩压缩级别。
BEST_SPEED - Static variable in class java.util.zip. Deflater
压缩级别最快的压缩。
bestRowNotPseudo - Static variable in interface java.sql. DatabaseMetaData
表示最佳行标识符不是伪列。
bestRowPseudo - Static variable in interface java.sql. DatabaseMetaData
表示最佳行标识符是伪列。
bestRowSession - Static variable in interface java.sql. DatabaseMetaData
表示最佳行标识符的范围是当前会话的剩余部分。
bestRowTemporary - Static variable in interface java.sql. DatabaseMetaData
表示最佳行标识符的范围是非常临时的，只在该行被使用时持久。
bestRowTransaction - Static variable in interface java.sql. DatabaseMetaData
表示最佳行标识符的范围是当前事务的剩余部分。
bestRowUnknown - Static variable in interface java.sql. DatabaseMetaData
表示最佳行标识符可能是伪列，也可能不是伪列。
between(ChronoLocalDate, ChronoLocalDate) - Static method in interface java.time.chrono. ChronoPeriod
获得一个 ChronoPeriod包括两个日期之间的时间量。
between(LocalDate, LocalDate) - Static method in class java.time. Period
获得一个 Period包括两个日期之间的年数，月份和日期。
between(Temporal, Temporal) - Static method in class java.time. Duration
获取 Duration表示两个时间对象之间的持续时间。
between(Temporal, Temporal) - Method in enum java.time.temporal. ChronoUnit
between(Temporal, Temporal) - Method in interface java.time.temporal. TemporalUnit
计算两个时间对象之间的时间量。
between(ValueExp, ValueExp, ValueExp) - Static method in class javax.management. Query
返回一个表示一个值位于两个其他值之间的约束的查询表达式。
BEVEL - javafx.scene.shape. StrokeLineJoin
通过连接其广泛轮廓的外角与直线段来连接路段。
BevelBorder - Class in javax.swing.border
一个实现一个简单的两行斜角边框的类。
BevelBorder(int) - Constructor for class javax.swing.border. BevelBorder
创建具有指定类型的斜角边框，其颜色将从传递到paintBorder方法的组件的背景颜色派生。
BevelBorder(int, Color, Color) - Constructor for class javax.swing.border. BevelBorder
创建具有指定类型，高亮和阴影颜色的斜角边框。
BevelBorder(int, Color, Color, Color, Color) - Constructor for class javax.swing.border. BevelBorder
创建具有指定类型，高亮和阴影颜色的斜角边框。
BevelBorderUIResource(int) - Constructor for class javax.swing.plaf. BorderUIResource.BevelBorderUIResource
构造一个 BevelBorderUIResource 。
BevelBorderUIResource(int, Color, Color) - Constructor for class javax.swing.plaf. BorderUIResource.BevelBorderUIResource
构造一个 BevelBorderUIResource 。
BevelBorderUIResource(int, Color, Color, Color, Color) - Constructor for class javax.swing.plaf. BorderUIResource.BevelBorderUIResource
构造一个 BevelBorderUIResource 。
bevelType - Variable in class javax.swing.border. BevelBorder
斜面类型。
bezierCurveTo(double, double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
将段添加到当前路径以生成立方贝塞尔曲线。
BGCOLOR - Static variable in class javax.swing.text.html. HTML.Attribute
属性“bgcolor”
BI_DIRECTIONAL_BINDING_PREFIX - Static variable in class javafx.fxml. FXMLLoader
前缀用于双向绑定表达式解析。
BI_DIRECTIONAL_BINDING_SUFFIX - Static variable in class javafx.fxml. FXMLLoader
双向绑定表达式解析的后缀。
BiConsumer< T, U> - Interface in java.util.function
表示接受两个输入参数并且不返回结果的操作。
Bidi - Class in java.text
该类实现了Unicode双向算法。
Bidi(char[], int, byte[], int, int, int) - Constructor for class java.text. Bidi
从给定的文本，嵌入和方向信息创建Bidi。
Bidi(String, int) - Constructor for class java.text. Bidi
从文本和基本方向的给定段落创建Bidi。
Bidi(AttributedCharacterIterator) - Constructor for class java.text. Bidi
从文本的给定段落创建Bidi。
BIDI_EMBEDDING - Static variable in class java.awt.font. TextAttribute
文本嵌入级别的属性键。
BidiElementName - Static variable in class javax.swing.text. AbstractDocument
用于保持单向运行的元素的名称
BidiLevel - Static variable in class javax.swing.text. StyleConstants
由Unicode bidi算法分配的字符的双向级别。
BiFunction< T, U, R> - Interface in java.util.function
表示接受两个参数并产生结果的函数。
BIG - Static variable in class javax.swing.text.html. HTML.Tag
标签<大>
BIG_ENDIAN - Static variable in class java.nio. ByteOrder
常量表示大字节顺序。
BIG_GAP - javafx.scene.control. ButtonBar.ButtonData
胶水推动间隙将占用尽可能多的空间，至少有一个“无关”的差距。
BigDecimal - Class in java.math
不变的，任意精度的带符号的十进制数字。
BigDecimal(char[]) - Constructor for class java.math. BigDecimal
将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列。
BigDecimal(char[], int, int) - Constructor for class java.math. BigDecimal
将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，同时允许指定子数组。
BigDecimal(char[], int, int, MathContext) - Constructor for class java.math. BigDecimal
将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，同时允许指定子数组并根据上下文设置进行舍入。
BigDecimal(char[], MathContext) - Constructor for class java.math. BigDecimal
将 BigDecimal的字符阵列表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，并根据上下文设置进行舍入。
BigDecimal(double) - Constructor for class java.math. BigDecimal
将 double转换为 BigDecimal ，它是 double的二进制浮点值的精确十进制表示。
BigDecimal(double, MathContext) - Constructor for class java.math. BigDecimal
将 double转换为 BigDecimal ，根据上下文设置进行舍入。
BigDecimal(int) - Constructor for class java.math. BigDecimal
将 int翻译成 BigDecimal 。
BigDecimal(int, MathContext) - Constructor for class java.math. BigDecimal
将 int转换为 BigDecimal ，根据上下文设置进行舍入。
BigDecimal(long) - Constructor for class java.math. BigDecimal
将 long翻译成 BigDecimal 。
BigDecimal(long, MathContext) - Constructor for class java.math. BigDecimal
将 long转换为 BigDecimal ，根据上下文设置进行舍入。
BigDecimal(String) - Constructor for class java.math. BigDecimal
将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal 。
BigDecimal(String, MathContext) - Constructor for class java.math. BigDecimal
将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符串，根据上下文设置进行舍入。
BigDecimal(BigInteger) - Constructor for class java.math. BigDecimal
将 BigInteger翻译成 BigDecimal 。
BigDecimal(BigInteger, int) - Constructor for class java.math. BigDecimal
将 BigInteger值和 int比例转换为 BigDecimal 。
BigDecimal(BigInteger, int, MathContext) - Constructor for class java.math. BigDecimal
将 BigInteger标度值和 int标度转换为 BigDecimal ，根据上下文设置进行舍入。
BigDecimal(BigInteger, MathContext) - Constructor for class java.math. BigDecimal
根据上下文设置将 BigInteger转换为 BigDecimal舍入。
BIGDECIMAL - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.math.BigDecimal值的 SimpleType实例。
BigDecimalStringConverter - Class in javafx.util.converter
StringConverter实现BigDecimal值。
BigDecimalStringConverter() - Constructor for class javafx.util.converter. BigDecimalStringConverter
bigEndian - Variable in class javax.sound.sampled. AudioFormat
指示音频数据是以big-endian还是小端序存储。
BIGINT - java.sql. JDBCType
标识通用SQL类型 BIGINT 。
BIGINT - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BIGINT 。
BigInteger - Class in java.math
不可变的任意精度整数。
BigInteger(byte[]) - Constructor for class java.math. BigInteger
将包含BigInteger的二进制补码二进制表达式的字节数组转换为BigInteger。
BigInteger(byte[], int, int) - Constructor for class java.math. BigInteger
将包含BigInteger的二进制补码二进制表示的字节子数组转换为BigInteger。
BigInteger(int, byte[]) - Constructor for class java.math. BigInteger
将BigInteger的符号大小表示形式转换为BigInteger。
BigInteger(int, byte[], int, int) - Constructor for class java.math. BigInteger
将BigInteger的符号大小表示形式转换为BigInteger。
BigInteger(int, int, Random) - Constructor for class java.math. BigInteger
构造一个随机生成的正BigInteger，它可能是素数，具有指定的bitLength。
BigInteger(int, Random) - Constructor for class java.math. BigInteger
构造一个随机生成的BigInteger，均匀分布在0到（2 numBits - 1）的范围内。
BigInteger(String) - Constructor for class java.math. BigInteger
将BigInteger的十进制字符串表示形式转换为BigInteger。
BigInteger(String, int) - Constructor for class java.math. BigInteger
将指定基数中的BigInteger的String表示形式转换为BigInteger。
BIGINTEGER - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.math.BigInteger值的 SimpleType实例。
BigIntegerStringConverter - Class in javafx.util.converter
StringConverter实现BigInteger值。
BigIntegerStringConverter() - Constructor for class javafx.util.converter. BigIntegerStringConverter
BINARY - java.sql. JDBCType
标识通用SQL类型 BINARY 。
BINARY - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BINARY 。
BINARY_STREAM_PARAM - Static variable in class javax.sql.rowset. BaseRowSet
RowSetReaderImpl给定参数是二进制流的 RowSetReaderImpl对象的常量。
BinaryOperator< T> - Interface in java.util.function
表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
BinaryRefAddr - Class in javax.naming
该类表示通信端点的地址的二进制形式。
BinaryRefAddr(String, byte[]) - Constructor for class javax.naming. BinaryRefAddr
使用其地址类型和内容的字节数组构造一个新的BinaryRefAddr实例。
BinaryRefAddr(String, byte[], int, int) - Constructor for class javax.naming. BinaryRefAddr
使用其地址类型构建一个新的BinaryRefAddr实例，并为内容构造一个字节数组的区域。
binarySearch(byte[], byte) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定值的指定字节数组。
binarySearch(byte[], int, int, byte) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定值的指定字节数组的范围。
binarySearch(char[], char) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定数组的指定值。
binarySearch(char[], int, int, char) - Static method in class java.util. Arrays
使用二分搜索算法搜索指定值的指定数组的范围。
binarySearch(double[], double) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定值的指定数组的双精度值。
binarySearch(double[], int, int, double) - Static method in class java.util. Arrays
使用二分搜索算法搜索指定值的指定数组的双精度范围。
binarySearch(float[], float) - Static method in class java.util. Arrays
使用二叉搜索算法搜索指定数组的浮点数。
binarySearch(float[], int, int, float) - Static method in class java.util. Arrays
使用二分搜索算法搜索指定数组的浮点数范围。
binarySearch(int[], int) - Static method in class java.util. Arrays
使用二叉搜索算法搜索指定的int数组的指定值。
binarySearch(int[], int, int, int) - Static method in class java.util. Arrays
使用二叉搜索算法搜索指定值的指定数组的范围。
binarySearch(long[], int, int, long) - Static method in class java.util. Arrays
使用二分搜索算法搜索指定值的指定数组的范围。
binarySearch(long[], long) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定数组的指定数组。
binarySearch(short[], int, int, short) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定值的指定数组的短整型范围。
binarySearch(short[], short) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定值的指定数组的指定值。
binarySearch(Object[], int, int, Object) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定对象的指定数组的范围。
binarySearch(Object[], Object) - Static method in class java.util. Arrays
使用二叉搜索算法搜索指定对象的指定数组。
binarySearch(List<? extends Comparable<? super T>>, T) - Static method in class java.util. Collections
使用二叉搜索算法搜索指定对象的指定列表。
binarySearch(List<? extends T>, T, Comparator<? super T>) - Static method in class java.util. Collections
使用二叉搜索算法搜索指定对象的指定列表。
binarySearch(T[], int, int, T, Comparator<? super T>) - Static method in class java.util. Arrays
使用二进制搜索算法搜索指定对象的指定数组的范围。
binarySearch(T[], T, Comparator<? super T>) - Static method in class java.util. Arrays
使用二叉搜索算法搜索指定对象的指定数组。
binaryStream - Variable in class javax.sql.rowset. BaseRowSet
将通过方法 getBinaryStream返回的 InputStream对象，该对象在 ResultSet接口中指定。
BinaryTree - Interface in com.sun.source.tree
二进制表达式的树节点。
BinaryTree - Interface in jdk.nashorn.api.tree
二进制表达式的树节点。
bind(int, InetAddress) - Method in class java.net. DatagramSocketImpl
将数据报套接字绑定到本地端口和地址。
bind(Object, String, MethodType) - Method in class java.lang.invoke. MethodHandles.Lookup
为非静态方法生成早期绑定的方法句柄。
bind(String, Object) - Method in interface javax.naming. Context
将名称绑定到对象。
bind(String, Object) - Method in class javax.naming. InitialContext
bind(String, Object, Attributes) - Method in interface javax.naming.directory. DirContext
将名称绑定到对象，以及关联的属性。
bind(String, Object, Attributes) - Method in class javax.naming.directory. InitialDirContext
bind(String, Remote) - Static method in class java.rmi. Naming
将指定的 name绑定到远程对象。
bind(String, Remote) - Method in interface java.rmi.registry. Registry
绑定到此注册表中指定的 name的远程引用。
bind(InetAddress, int) - Method in class java.net. SocketImpl
将此套接字绑定到指定的本地IP地址和端口号。
bind(InetSocketAddress, int) - Method in class com.sun.net.httpserver. HttpServer
将当前未绑定的HttpServer绑定到给定的地址和端口号。
bind(SocketAddress) - Method in class com.sun.nio.sctp. SctpChannel
将通道的套接字绑定到本地地址。
bind(SocketAddress) - Method in class com.sun.nio.sctp. SctpMultiChannel
将通道的套接字绑定到本地地址，并配置套接字以监听连接。
bind(SocketAddress) - Method in class com.sun.nio.sctp. SctpServerChannel
将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
bind(SocketAddress) - Method in class java.net. DatagramSocket
将此DatagramSocket绑定到特定的地址和端口。
bind(SocketAddress) - Method in class java.net. ServerSocket
将 ServerSocket绑定到特定地址（IP地址和端口号）。
bind(SocketAddress) - Method in class java.net. Socket
将套接字绑定到本地地址。
bind(SocketAddress) - Method in class java.nio.channels. AsynchronousServerSocketChannel
将通道的套接字绑定到本地地址，并配置套接字以监听连接。
bind(SocketAddress) - Method in class java.nio.channels. AsynchronousSocketChannel
bind(SocketAddress) - Method in class java.nio.channels. DatagramChannel
bind(SocketAddress) - Method in interface java.nio.channels. NetworkChannel
将通道的套接字绑定到本地地址。
bind(SocketAddress) - Method in class java.nio.channels. ServerSocketChannel
将通道的套接字绑定到本地地址，并配置套接字以监听连接。
bind(SocketAddress) - Method in class java.nio.channels. SocketChannel
bind(SocketAddress, int) - Method in class com.sun.nio.sctp. SctpMultiChannel
将通道的套接字绑定到本地地址，并配置套接字以监听连接。
bind(SocketAddress, int) - Method in class com.sun.nio.sctp. SctpServerChannel
将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
bind(SocketAddress, int) - Method in class java.net. ServerSocket
将 ServerSocket绑定到特定地址（IP地址和端口号）。
bind(SocketAddress, int) - Method in class java.nio.channels. AsynchronousServerSocketChannel
将通道的套接字绑定到本地地址，并配置套接字以监听连接。
bind(SocketAddress, int) - Method in class java.nio.channels. ServerSocketChannel
将通道的套接字绑定到本地地址，并配置套接字以监听连接。
bind(Observable...) - Method in class javafx.beans.binding. BooleanBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. DoubleBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. FloatBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. IntegerBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. ListBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. LongBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. MapBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. ObjectBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. SetBinding
开始观察更改的依赖关系。
bind(Observable...) - Method in class javafx.beans.binding. StringBinding
开始观察更改的依赖关系。
bind(ObservableValue<? extends Boolean>) - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Boolean>) - Method in class javafx.beans.property. BooleanPropertyBase
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Boolean>) - Method in class javafx.css. StyleableBooleanProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
为此创建一个单向绑定 Property 。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property. DoublePropertyBase
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property. FloatPropertyBase
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property. IntegerPropertyBase
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.beans.property. LongPropertyBase
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.css. StyleableDoubleProperty
为此创建一个单向绑定 Property 。
bind(ObservableValue<? extends Number>) - Method in class javafx.css. StyleableFloatProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.css. StyleableIntegerProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends Number>) - Method in class javafx.css. StyleableLongProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends String>) - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends String>) - Method in class javafx.beans.property. StringPropertyBase
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends String>) - Method in class javafx.css. StyleableStringProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends ObservableList<E>>) - Method in class javafx.beans.property. ListPropertyBase
bind(ObservableValue<? extends ObservableMap<K, V>>) - Method in class javafx.beans.property. MapPropertyBase
bind(ObservableValue<? extends ObservableSet<E>>) - Method in class javafx.beans.property. SetPropertyBase
bind(ObservableValue<? extends T>) - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends T>) - Method in class javafx.beans.property. ObjectPropertyBase
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends T>) - Method in interface javafx.beans.property. Property
为此 Property创建一个单向绑定。
bind(ObservableValue<? extends T>) - Method in class javafx.css. StyleableObjectProperty
为此 Property创建一个单向绑定。
bind(Name, Object) - Method in interface javax.naming. Context
将名称绑定到对象。
bind(Name, Object) - Method in class javax.naming. InitialContext
bind(Name, Object, Attributes) - Method in interface javax.naming.directory. DirContext
将名称绑定到对象，以及关联的属性。
bind(Name, Object, Attributes) - Method in class javax.naming.directory. InitialDirContext
bind(NameComponent[], Object) - Method in class org.omg.CosNaming. _NamingContextExtStub
在命名上下文中创建名称和对象的绑定。
bind(NameComponent[], Object) - Method in class org.omg.CosNaming. _NamingContextStub
在命名上下文中创建名称和对象的绑定。
bind(NameComponent[], Object) - Method in interface org.omg.CosNaming. NamingContextOperations
在命名上下文中创建名称和对象的绑定。
BIND - Static variable in class javax.print.attribute.standard. Finishings
该值表示绑定将应用于文档; 绑定的类型和位置是站点定义的。
bind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming. _NamingContextExtStub
命名一个命名上下文的对象。
bind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming. _NamingContextStub
命名一个命名上下文的对象。
bind_context(NameComponent[], NamingContext) - Method in interface org.omg.CosNaming. NamingContextOperations
命名一个命名上下文的对象。
bind_new_context(NameComponent[]) - Method in class org.omg.CosNaming. _NamingContextExtStub
此操作创建一个新的上下文并将其绑定到作为参数提供的名称。
bind_new_context(NameComponent[]) - Method in class org.omg.CosNaming. _NamingContextStub
此操作创建一个新的上下文并将其绑定到作为参数提供的名称。
bind_new_context(NameComponent[]) - Method in interface org.omg.CosNaming. NamingContextOperations
此操作创建一个新的上下文并将其绑定到作为参数提供的名称。
bindAddress(InetAddress) - Method in class com.sun.nio.sctp. SctpChannel
将给定地址添加到通道插座的绑定地址。
bindAddress(InetAddress) - Method in class com.sun.nio.sctp. SctpMultiChannel
将给定地址添加到通道插座的绑定地址。
bindAddress(InetAddress) - Method in class com.sun.nio.sctp. SctpServerChannel
将给定地址添加到通道插座的绑定地址。
bindBidirectional(Property<?>, Format) - Method in class javafx.beans.property. StringProperty
在这个 StringProperty和另一个任意属性之间创建双向绑定。
bindBidirectional(Property<Boolean>) - Method in class javafx.beans.property. BooleanProperty
在这个 Property和另一个之间创建双向绑定。
bindBidirectional(Property<Number>) - Method in class javafx.beans.property. DoubleProperty
在这个 Property之间创建一个双向绑定。
bindBidirectional(Property<Number>) - Method in class javafx.beans.property. FloatProperty
在这个 Property之间创建一个双向绑定。
bindBidirectional(Property<Number>) - Method in class javafx.beans.property. IntegerProperty
在这个 Property和另一个之间创建双向绑定。
bindBidirectional(Property<Number>) - Method in class javafx.beans.property. LongProperty
在这个 Property之间创建一个双向绑定。
bindBidirectional(Property<String>) - Method in class javafx.beans.property. StringProperty
在这个 Property和另一个之间创建双向绑定。
bindBidirectional(Property<String>, Property<?>, Format) - Static method in class javafx.beans.binding. Bindings
在String - Property和另一个Property使用指定的Format生成双向绑定（或“反向绑定”）进行转换。
bindBidirectional(Property<String>, Property<T>, StringConverter<T>) - Static method in class javafx.beans.binding. Bindings
在String - Property和另一个Property使用指定的StringConverter生成双向绑定（或“反向绑定”）进行转换。
bindBidirectional(Property<ObservableList<E>>) - Method in class javafx.beans.property. ListProperty
在这个 Property和另一个之间创建双向绑定。
bindBidirectional(Property<ObservableMap<K, V>>) - Method in class javafx.beans.property. MapProperty
在这个 Property和另一个之间创建双向绑定。
bindBidirectional(Property<ObservableSet<E>>) - Method in class javafx.beans.property. SetProperty
在这个 Property之间创建一个双向绑定。
bindBidirectional(Property<T>) - Method in class javafx.beans.property. ObjectProperty
在这个 Property之间创建一个双向绑定。
bindBidirectional(Property<T>) - Method in interface javafx.beans.property. Property
在这个 Property和另一个之间创建双向绑定。
bindBidirectional(Property<T>, Property<T>) - Static method in class javafx.beans.binding. Bindings
在Property的两个实例之间生成双向绑定（或“反向绑定”）。
bindBidirectional(Property<T>, StringConverter<T>) - Method in class javafx.beans.property. StringProperty
在这个 StringProperty和另一个任意属性之间创建双向绑定。
bindContent(List<E>, ObservableList<? extends E>) - Static method in class javafx.beans.binding. Bindings
生成ObservableList和List之间的内容绑定。
bindContent(Map<K, V>, ObservableMap<? extends K, ? extends V>) - Static method in class javafx.beans.binding. Bindings
生成ObservableMap和Map之间的内容绑定。
bindContent(Set<E>, ObservableSet<? extends E>) - Static method in class javafx.beans.binding. Bindings
生成ObservableSet和Set之间的内容绑定。
bindContent(ObservableList<E>) - Method in class javafx.beans.property. ReadOnlyListProperty
创建ObservableList之间的内容绑定，即包装在这个ReadOnlyListProperty ，另一个是ObservableList 。
bindContent(ObservableMap<K, V>) - Method in class javafx.beans.property. ReadOnlyMapProperty
创建ObservableMap之间的内容绑定，即包含在这个ReadOnlyMapProperty和另一个ObservableMap 。
bindContent(ObservableSet<E>) - Method in class javafx.beans.property. ReadOnlySetProperty
创建ObservableSet之间的内容绑定，即包装在这个ReadOnlySetProperty和另一个ObservableSet 。
bindContentBidirectional(ObservableList<E>) - Method in class javafx.beans.property. ReadOnlyListProperty
创建ObservableList的双向内容绑定，即包装在这个ReadOnlyListProperty ，另一个是ObservableList 。
bindContentBidirectional(ObservableList<E>, ObservableList<E>) - Static method in class javafx.beans.binding. Bindings
在ObservableList的两个实例之间生成双向绑定（或“反向绑定”）。
bindContentBidirectional(ObservableMap<K, V>) - Method in class javafx.beans.property. ReadOnlyMapProperty
创建一个双向内容绑定的ObservableMap ，即包装在这个ReadOnlyMapProperty ，另外ObservableMap 。
bindContentBidirectional(ObservableMap<K, V>, ObservableMap<K, V>) - Static method in class javafx.beans.binding. Bindings
在ObservableMap的两个实例之间生成双向绑定（或“绑定反向”）。
bindContentBidirectional(ObservableSet<E>) - Method in class javafx.beans.property. ReadOnlySetProperty
创建一个双向内容绑定的ObservableSet ，即包装在这个ReadOnlySetProperty和另一个ObservableSet 。
bindContentBidirectional(ObservableSet<E>, ObservableSet<E>) - Static method in class javafx.beans.binding. Bindings
在ObservableSet的两个实例之间生成双向绑定（或“绑定”）。
Binder< XmlNode> - Class in javax.xml.bind
启用表示相同XML文档的XML信息集节点和JAXB对象之间的同步。
Binder() - Constructor for class javax.xml.bind. Binder
BindException - Exception in java.net
指示尝试将套接字绑定到本地地址和端口时发生错误。
BindException() - Constructor for exception java.net. BindException
构造一个新的BindException，没有详细的消息。
BindException(String) - Constructor for exception java.net. BindException
构造一个新的BindException与指定的详细信息为什么绑定错误发生。
Binding - Class in javax.naming
此类表示在上下文中找到的名称对对象绑定。
Binding - Class in org.omg.CosNaming
org / omg / CosNaming / Binding.java。
Binding< T> - Interface in javafx.beans.binding
A Binding计算取决于一个或多个来源的值。
Binding - Interface in javax.xml.ws
Binding接口是JAX-WS协议绑定的基本接口。
Binding() - Constructor for class org.omg.CosNaming. Binding
Binding(String, Object) - Constructor for class javax.naming. Binding
构造一个绑定的实例给它的名称和对象。
Binding(String, Object, boolean) - Constructor for class javax.naming. Binding
构造绑定的实例给它的名称，对象以及名称是否相对。
Binding(String, String, Object) - Constructor for class javax.naming. Binding
构造一个绑定的实例给它的名称，类名和对象。
Binding(String, String, Object, boolean) - Constructor for class javax.naming. Binding
构造绑定的实例给它的名称，类名，对象以及名称是否相对。
Binding(NameComponent[], BindingType) - Constructor for class org.omg.CosNaming. Binding
BINDING_EXPRESSION_PREFIX - Static variable in class javafx.fxml. FXMLLoader
用于表达式解析的前缀。
BINDING_EXPRESSION_SUFFIX - Static variable in class javafx.fxml. FXMLLoader
绑定表达式分辨率的后缀
binding_name - Variable in class org.omg.CosNaming. Binding
binding_type - Variable in class org.omg.CosNaming. Binding
BindingHelper - Class in org.omg.CosNaming
org / omg / CosNaming / BindingHelper.java。
BindingHelper() - Constructor for class org.omg.CosNaming. BindingHelper
BindingHolder - Class in org.omg.CosNaming
org / omg / CosNaming / BindingHolder.java。
BindingHolder() - Constructor for class org.omg.CosNaming. BindingHolder
BindingHolder(Binding) - Constructor for class org.omg.CosNaming. BindingHolder
BindingIterator - Interface in org.omg.CosNaming
BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
BindingIteratorHelper - Class in org.omg.CosNaming
BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
BindingIteratorHelper() - Constructor for class org.omg.CosNaming. BindingIteratorHelper
BindingIteratorHolder - Class in org.omg.CosNaming
BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
BindingIteratorHolder() - Constructor for class org.omg.CosNaming. BindingIteratorHolder
BindingIteratorHolder(BindingIterator) - Constructor for class org.omg.CosNaming. BindingIteratorHolder
BindingIteratorOperations - Interface in org.omg.CosNaming
BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
BindingIteratorPOA - Class in org.omg.CosNaming
BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
BindingIteratorPOA() - Constructor for class org.omg.CosNaming. BindingIteratorPOA
BindingListHelper - Class in org.omg.CosNaming
绑定清单。
BindingListHelper() - Constructor for class org.omg.CosNaming. BindingListHelper
BindingListHolder - Class in org.omg.CosNaming
绑定清单。
BindingListHolder() - Constructor for class org.omg.CosNaming. BindingListHolder
BindingListHolder(Binding[]) - Constructor for class org.omg.CosNaming. BindingListHolder
BindingProvider - Interface in javax.xml.ws
BindingProvider接口提供对协议绑定和相关联的上下文对象的访问以用于请求和响应消息处理。
Bindings - Class in javafx.beans.binding
绑定是一个帮助类，具有很多实用功能来创建简单的绑定。
Bindings - Interface in javax.script
键/值对的映射，所有键的键均为 Strings 。
BindingType - Class in org.omg.CosNaming
指定给定的绑定是针对对象（不是命名上下文）还是用于命名上下文。
BindingType - Annotation Type in javax.xml.ws
BindingType注释用于指定用于Web服务端点实现类的绑定。
BindingType(int) - Constructor for class org.omg.CosNaming. BindingType
BindingTypeHelper - Class in org.omg.CosNaming
指定给定的绑定是针对对象（不是命名上下文）还是用于命名上下文。
BindingTypeHelper() - Constructor for class org.omg.CosNaming. BindingTypeHelper
BindingTypeHolder - Class in org.omg.CosNaming
指定给定的绑定是针对对象（不是命名上下文）还是用于命名上下文。
BindingTypeHolder() - Constructor for class org.omg.CosNaming. BindingTypeHolder
BindingTypeHolder(BindingType) - Constructor for class org.omg.CosNaming. BindingTypeHolder
bindTo(Object) - Method in class java.lang.invoke. MethodHandle
将值 x绑定到方法句柄的第一个参数，而不调用它。
BiPredicate< T, U> - Interface in java.util.function
表示两个参数的谓词（布尔值函数）。
BISQUE - Static variable in class javafx.scene.paint. Color
RGB值为＃FFE4C4的彩色色差
BIT - java.sql. JDBCType
标识通用SQL类型 BIT 。
BIT - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BIT 。
BIT_DEPTH_MULTI - Static variable in class java.awt. DisplayMode
在该显示模式下支持多个位深度时，位深度的值。
bitCount() - Method in class java.math. BigInteger
返回与其符号位不同的BigInteger的二进制补码表示中的位数。
bitCount(int) - Static method in class java.lang. Integer
返回指定的 int值的二进制补码二进制表示中的 int 。
bitCount(long) - Static method in class java.lang. Long
返回指定的 long值的二进制补码二进制表示中的 long 。
bitLength() - Method in class java.math. BigInteger
返回此BigInteger的最小二进制补码表示中的位数， 不包括符号位。
BITMASK - Static variable in interface java.awt. Transparency
表示保证为完全不透明，Alpha值为1.0或完全透明，Alpha值为0.0的图像数据。
bitOffset - Variable in class javax.imageio.stream. ImageInputStreamImpl
流内的当前位偏移。
BitSet - Class in java.util
该类实现了根据需要增长的位向量。
BitSet() - Constructor for class java.util. BitSet
创建一个新的位集。
BitSet(int) - Constructor for class java.util. BitSet
创建一个位集，其初始大小足够大以显式表示索引为 0到 nbits-1 。
BITWISE_COMPLEMENT - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表按位补运算符~ 。
BITWISE_COMPLEMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表按位补运算符~ 。
black - Static variable in class java.awt. Color
颜色黑色。
BLACK - javafx.scene.text. FontWeight
代表黑色字体重量（900）。
BLACK - Static variable in class java.awt. Color
颜色黑色。
BLACK - Static variable in class javafx.scene.paint. Color
颜色为黑色，RGB值为＃000000
BLANCHEDALMOND - Static variable in class javafx.scene.paint. Color
颜色变白的杏仁，RGB值为#FFEBCD
Blend - Class in javafx.scene.effect
使用预定义的BlendMode之一将两个输入组合在一起的效果。
Blend() - Constructor for class javafx.scene.effect. Blend
使用默认参数创建Blend的新实例。
Blend(BlendMode) - Constructor for class javafx.scene.effect. Blend
使用指定的模式创建Blend的新实例。
Blend(BlendMode, Effect, Effect) - Constructor for class javafx.scene.effect. Blend
使用指定的模式和底部和顶部输入创建Blend的新实例。
BlendMode - Enum in javafx.scene.effect
混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
blendModeProperty() - Method in class javafx.scene. Node
BlendMode用于将这个单独的节点混合到其后面的场景中。
BLIT_SCROLL_MODE - Static variable in class javax.swing. JViewport
使用 graphics.copyArea实现滚动。
Blob - Interface in java.sql
表示（映射）在Java编程语言中的一个SQL BLOB值。
BLOB - java.sql. JDBCType
标识通用SQL类型 BLOB 。
BLOB - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BLOB 。
block() - Method in interface java.util.concurrent. ForkJoinPool.ManagedBlocker
可能阻止当前线程，例如等待锁或条件。
block(InetAddress) - Method in class java.nio.channels. MembershipKey
阻止来自给定源地址的组播数据报。
BLOCK - com.sun.source.tree. Tree.Kind
用于BlockTree的实例。
BLOCK - jdk.nashorn.api.tree. Tree.Kind
用于BlockTree的实例。
BLOCK_CIPHER - java.security. CryptoPrimitive
对称原语：块密码
BLOCK_DECREMENT - javafx.scene. AccessibleAction
请求节点递减一个较大的值。
BLOCK_DECREMENT - Static variable in class java.awt.event. AdjustmentEvent
块减量调整类型。
BLOCK_ELEMENTS - Static variable in class java.lang. Character.UnicodeBlock
常量为“块元素”Unicode字符块。
BLOCK_INCREMENT - javafx.scene. AccessibleAction
请求节点递增一个较大的值。
BLOCK_INCREMENT - Static variable in class java.awt.event. AdjustmentEvent
块增量调整类型。
BlockAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.BlockAction
blockClose(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
向解析缓冲区添加指令以关闭给定类型的块元素。
BLOCKED - java.lang. Thread.State
一个线程的线程状态阻塞等待监视器锁定。
BlockElement(Element, AttributeSet) - Constructor for class javax.swing.text.html. HTMLDocument.BlockElement
构造最初不包含子项的复合元素。
blockIncrement - Variable in class javax.swing. JScrollBar
blockIncrementProperty() - Method in class javafx.scene.control. ScrollBar
如果点击栏的轨道，调整滚动条的量。
blockIncrementProperty() - Method in class javafx.scene.control. Slider
如果点击滑块的轨道，则调整滑块的量。
BlockingDeque< E> - Interface in java.util.concurrent
A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并在存储元素时等待空格变为可用于deque。
blockingLock() - Method in class java.nio.channels. SelectableChannel
检索 configureBlocking和 register方法同步的对象。
blockingLock() - Method in class java.nio.channels.spi. AbstractSelectableChannel
BlockingQueue< E> - Interface in java.util.concurrent
A Queue另外支持在检索元素时等待队列变为非空的操作，并在存储元素时等待队列中的空间变得可用。
blockOpen(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
向解析缓冲区添加指令以创建具有给定属性的块元素。
BLOCKQUOTE - Static variable in class javax.swing.text.html. HTML.Tag
标签<blockquote>
BlockTagTree - Interface in com.sun.source.doctree
一个树节点用作不同类型的块标签的基类。
BlockTree - Interface in com.sun.source.tree
语句块的树节点。
BlockTree - Interface in jdk.nashorn.api.tree
语句块的树节点。
BlockView - Class in javax.swing.text.html
使用CSS规范显示块（作为框）的视图实现。
BlockView(Element, int) - Constructor for class javax.swing.text.html. BlockView
创建一个代表html框的新视图。
Bloom - Class in javafx.scene.effect
基于可配置的阈值，使得输入图像的较亮部分看起来发亮的高级效果。
Bloom() - Constructor for class javafx.scene.effect. Bloom
用默认参数创建一个新的Bloom实例。
Bloom(double) - Constructor for class javafx.scene.effect. Bloom
以指定的阈值创建一个Bloom实例。
BltBufferStrategy(int, BufferCapabilities) - Constructor for class java.awt. Component.BltBufferStrategy
围绕组件创建一个新的blt缓冲策略
blue - Static variable in class java.awt. Color
颜色蓝色。
BLUE - javafx.scene.effect. BlendMode
底部输入的蓝色分量被顶部输入的蓝色分量替换; 其他颜色成分不受影响。
BLUE - Static variable in class java.awt. Color
颜色蓝色。
BLUE - Static variable in class javafx.scene.paint. Color
颜色蓝色，RGB值为＃0000FF
BLUECOMPONENT - Static variable in class java.awt.color. ICC_ProfileRGB
用于获取蓝色分量的伽马值或TRC。
BLUEVIOLET - Static variable in class javafx.scene.paint. Color
RGB值为＃8A2BE2的蓝色紫色
blur() - Method in interface org.w3c.dom.html. HTMLAnchorElement
从此元素中移除键盘焦点。
blur() - Method in interface org.w3c.dom.html. HTMLInputElement
从此元素中移除键盘焦点。
blur() - Method in interface org.w3c.dom.html. HTMLSelectElement
从此元素中移除键盘焦点。
blur() - Method in interface org.w3c.dom.html. HTMLTextAreaElement
从此元素中移除键盘焦点。
BlurType - Enum in javafx.scene.effect
表示用于软化 Shadow效果的模糊算法的类型。
blurTypeProperty() - Method in class javafx.scene.effect. DropShadow
用于模糊阴影的算法。
blurTypeProperty() - Method in class javafx.scene.effect. InnerShadow
用于模糊阴影的算法。
blurTypeProperty() - Method in class javafx.scene.effect. Shadow
用于模糊阴影的算法。
BMPImageWriteParam - Class in javax.imageio.plugins.bmp
用于编码BMP格式的图像的 ImageWriteParam的子类。
BMPImageWriteParam() - Constructor for class javax.imageio.plugins.bmp. BMPImageWriteParam
构造一个 BMPImageWriteParam对象，具有所有参数的默认值，以及一个 null Locale 。
BMPImageWriteParam(Locale) - Constructor for class javax.imageio.plugins.bmp. BMPImageWriteParam
构造一个 BMPImageWriteParam设置，使用给定的 Locale和所有参数的默认值。
body - Variable in class javax.swing.text.html.parser. DTD
元素对应于身体。
body() - Method in class jdk.incubator.http. HttpResponse
返回身体。
BODY - Static variable in class javax.swing.text.html. HTML.Tag
标签<body>
bodyProcessor() - Method in class jdk.incubator.http. HttpRequest
返回一个Optional其中包含这个请求的HttpRequest.BodyProcessor集。
Bold - Static variable in class javax.swing.text. StyleConstants
粗体属性的名称。
BOLD - javafx.scene.text. FontWeight
代表粗体字体重（700）。
BOLD - javafx.scene.web. HTMLEditorSkin.Command
BOLD - Static variable in class java.awt. Font
大胆的风格常数。
BOLD_ACTION - Static variable in class javax.swing.text.html. HTMLEditorKit
粗体动作标识符
BoldAction() - Constructor for class javax.swing.text. StyledEditorKit.BoldAction
构建新的BoldAction。
Book - Class in java.awt.print
Book课程提供了一个文档的表示，其中页面可能具有不同的页面格式和页面绘画。
Book() - Constructor for class java.awt.print. Book
创建一个新的，空的 Book 。
Boolean - Class in java.lang
布尔类将对象中的基元类型为 boolean 。
Boolean(boolean) - Constructor for class java.lang. Boolean
已过时。
很少使用这个构造函数。 静态工厂Boolean.valueOf(boolean)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。 如果可能，还要考虑使用最终的字段Boolean.TRUE和Boolean.FALSE 。
Boolean(String) - Constructor for class java.lang. Boolean
已过时。
很少使用这个构造函数。 使用Boolean.parseBoolean(String)将字符串转换为boolean原语，或使用Boolean.valueOf(String)将字符串转换为Boolean对象。
BOOLEAN - java.sql. JDBCType
标识通用SQL类型 BOOLEAN 。
BOOLEAN - javax.lang.model.type. TypeKind
原始类型 boolean 。
BOOLEAN - javax.xml.xpath. XPathEvaluationResult.XPathResultType
XPath 1.0布尔数据类型。
BOOLEAN - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 BOOLEAN 。
BOOLEAN - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.lang.Boolean值的 SimpleType实例。
BOOLEAN - Static variable in class javax.xml.xpath. XPathConstants
XPath 1.0布尔数据类型。
BOOLEAN_LITERAL - com.sun.source.tree. Tree.Kind
用于表示boolean类型的布尔文字表达式的boolean 。
BOOLEAN_LITERAL - jdk.nashorn.api.tree. Tree.Kind
用于表示boolean类型的布尔文字表达式的boolean 。
BOOLEAN_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是一个布尔值。
BooleanBinding - Class in javafx.beans.binding
提供实现boolean值Binding所需的大部分功能的基类。
BooleanBinding() - Constructor for class javafx.beans.binding. BooleanBinding
唯一的构造函数
BooleanControl - Class in javax.sound.sampled
A BooleanControl提供了在影响线路音频的两种可能设置之间切换的功能。
BooleanControl(BooleanControl.Type, boolean) - Constructor for class javax.sound.sampled. BooleanControl
使用给定的参数构造一个新的布尔控件对象。
BooleanControl(BooleanControl.Type, boolean, String, String) - Constructor for class javax.sound.sampled. BooleanControl
使用给定的参数构造一个新的布尔控件对象。
BooleanControl.Type - Class in javax.sound.sampled
BooleanControl.Type类的一个实例标识一种布尔控件。
BooleanConverter - Class in javafx.css.converter
booleanExpression(ObservableBooleanValue) - Static method in class javafx.beans.binding. BooleanExpression
返回一个BooleanExpression的BooleanExpression 。
booleanExpression(ObservableValue<Boolean>) - Static method in class javafx.beans.binding. BooleanExpression
返回一个BooleanExpression ，其中包含一个ObservableValue 。
BooleanExpression - Class in javafx.beans.binding
BooleanExpression是一个ObservableBooleanValue，另外还有一个方便的方法来生成流畅的绑定。
BooleanExpression() - Constructor for class javafx.beans.binding. BooleanExpression
唯一的构造函数
BooleanHolder - Class in org.omg.CORBA
持有人 Boolean 。
BooleanHolder() - Constructor for class org.omg.CORBA. BooleanHolder
构造一个新的 BooleanHolder对象，其 value字段初始化为 false 。
BooleanHolder(boolean) - Constructor for class org.omg.CORBA. BooleanHolder
构造一个新的 BooleanHolder对象，其 value字段使用给定的 boolean初始化。
booleanProperty(Property<Boolean>) - Static method in class javafx.beans.property. BooleanProperty
返回一个BooleanProperty ，其中包含一个Property 。
BooleanProperty - Class in javafx.beans.property
这个类提供了一个包含 boolean值的Property的完整实现。
BooleanProperty() - Constructor for class javafx.beans.property. BooleanProperty
唯一的构造函数
BooleanPropertyBase - Class in javafx.beans.property
类 BooleanPropertyBase是包含 boolean值的属性的基类。
BooleanPropertyBase() - Constructor for class javafx.beans.property. BooleanPropertyBase
BooleanPropertyBase的构造 BooleanPropertyBase 。
BooleanPropertyBase(boolean) - Constructor for class javafx.beans.property. BooleanPropertyBase
的构造函数 BooleanPropertyBase 。
BooleanSeqHelper - Class in org.omg.CORBA
助手 BooleanSeq 。
BooleanSeqHelper() - Constructor for class org.omg.CORBA. BooleanSeqHelper
BooleanSeqHolder - Class in org.omg.CORBA
持有人 BooleanSeq 。
BooleanSeqHolder() - Constructor for class org.omg.CORBA. BooleanSeqHolder
BooleanSeqHolder(boolean[]) - Constructor for class org.omg.CORBA. BooleanSeqHolder
BooleanStringConverter - Class in javafx.util.converter
StringConverter实现Boolean （和布尔基元）值。
BooleanStringConverter() - Constructor for class javafx.util.converter. BooleanStringConverter
BooleanSupplier - Interface in java.util.function
代表 boolean结果。
BooleanType - Interface in com.sun.jdi
在目标虚拟机中访问的所有原始 boolean类型 boolean 。
booleanValue() - Method in interface com.sun.jdi.connect. Connector.BooleanArgument
将参数的值作为布尔值返回。
booleanValue() - Method in interface com.sun.jdi. PrimitiveValue
将此值转换为BooleanValue，并将结果作为布尔值返回。
booleanValue() - Method in class java.lang. Boolean
将此 Boolean对象的值作为 Boolean元返回。
BooleanValue - Interface in com.sun.jdi
提供对目标虚拟机 boolean语 boolean值的访问。
booleanValueAt(ObservableList<Boolean>, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，其中包含ObservableList在指定位置的元素。
booleanValueAt(ObservableList<Boolean>, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。
booleanValueAt(ObservableList<Boolean>, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，其中包含指定位置的ObservableList的元素。
booleanValueAt(ObservableMap<K, Boolean>, ObservableValue<? extends K>) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
booleanValueAt(ObservableMap<K, Boolean>, K) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
boot() - Static method in class java.lang. ModuleLayer
返回引导层。
bootClassPath() - Method in interface com.sun.jdi. PathSearchingVirtualMachine
获取此虚拟机的引导类路径。
Bootstrap - Class in com.sun.jdi
提供对JDI接口的默认实现的初始类。
Bootstrap() - Constructor for class com.sun.jdi. Bootstrap
BootstrapMethodError - Error in java.lang
抛出以表示invokedynamic指令未能找到其引导方法，或者引导方法未能提供call site的target为正确的method type 。
BootstrapMethodError() - Constructor for error java.lang. BootstrapMethodError
构造一个 BootstrapMethodError ，没有详细信息。
BootstrapMethodError(String) - Constructor for error java.lang. BootstrapMethodError
构造具有指定详细消息的 BootstrapMethodError 。
BootstrapMethodError(String, Throwable) - Constructor for error java.lang. BootstrapMethodError
构造一个具有指定的详细信息和原因的 BootstrapMethodError 。
BootstrapMethodError(Throwable) - Constructor for error java.lang. BootstrapMethodError
构造具有指定原因的 BootstrapMethodError 。
BOPOMOFO - java.lang. Character.UnicodeScript
Unicode脚本“Bopomofo”。
BOPOMOFO - Static variable in class java.lang. Character.UnicodeBlock
“Bopomofo”Unicode字符块的常量。
BOPOMOFO_EXTENDED - Static variable in class java.lang. Character.UnicodeBlock
“Bopomofo Extended”Unicode字符块的常量。
border - Variable in class javax.swing.border. TitledBorder
边界。
border - Variable in class javax.swing.tree. DefaultTreeCellEditor.DefaultTextField
边框使用。
Border - Class in javafx.scene.layout
边界一个Region 。
Border - Interface in javax.swing.border
描述能够渲染围绕摆动组件边缘的边框的对象的界面。
Border(List<BorderStroke>, List<BorderImage>) - Constructor for class javafx.scene.layout. Border
通过提供BorderStrokes和BorderImages列表创建一个新的边框。
Border(BorderImage...) - Constructor for class javafx.scene.layout. Border
通过提供一个BorderImages数组创建一个新的边框。
Border(BorderStroke...) - Constructor for class javafx.scene.layout. Border
通过提供一个BorderStrokes数组创建一个新的边框。
Border(BorderStroke[], BorderImage[]) - Constructor for class javafx.scene.layout. Border
通过提供一系列BorderStrokes和BorderImages创建一个新的边框。
BORDER - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border”。
BORDER - Static variable in class javax.swing.text.html. HTML.Attribute
属性“边界”
BORDER_BOTTOM - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-bottom”。
BORDER_BOTTOM_COLOR - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-bottom-color”。
BORDER_BOTTOM_STYLE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-bottom-style”。
BORDER_BOTTOM_WIDTH - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-bottom-width”。
BORDER_COLOR - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-color”。
BORDER_LEFT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-left”。
BORDER_LEFT_COLOR - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“margin-right”。
BORDER_LEFT_STYLE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-left-style”。
BORDER_LEFT_WIDTH - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-left-width”。
BORDER_PAINTED_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识绘制边框或不绘制边框的更改。
BORDER_PAINTED_FLAT_CHANGED_PROPERTY - Static variable in class javax.swing. JCheckBox
标识对平面属性的更改。
BORDER_RIGHT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-right”。
BORDER_RIGHT_COLOR - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-right-color”。
BORDER_RIGHT_STYLE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-right-style”。
BORDER_RIGHT_WIDTH - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-right-width”。
BORDER_STYLE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-style”。
BORDER_TOP - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-top”。
BORDER_TOP_COLOR - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-top-color”。
BORDER_TOP_STYLE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-top-style”。
BORDER_TOP_WIDTH - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-top-width”。
BORDER_WIDTH - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“border-width”。
BorderFactory - Class in javax.swing
出厂标准为 Border对象。
BorderImage - Class in javafx.scene.layout
定义描述如何将图像呈现为某个区域的边框的属性。
BorderImage(Image, BorderWidths, Insets, BorderWidths, boolean, BorderRepeat, BorderRepeat) - Constructor for class javafx.scene.layout. BorderImage
创建一个新的BorderImage。
borderInsets - Static variable in class javax.swing.plaf.metal. MetalBorders.ButtonBorder
边界插入。
borderInsets - Static variable in class javax.swing.plaf.metal. MetalBorders.MenuBarBorder
边界插入。
borderInsets - Static variable in class javax.swing.plaf.metal. MetalBorders.MenuItemBorder
边界插入。
borderInsets - Static variable in class javax.swing.plaf.metal. MetalBorders.PopupMenuBorder
边界插入。
BorderLayout - Class in java.awt
边界布局设置了一个容器，安排和调整其组件，以适应五个区域：北，南，东，西和中心。
BorderLayout() - Constructor for class java.awt. BorderLayout
构建新的边框布局，组件间没有间隙。
BorderLayout(int, int) - Constructor for class java.awt. BorderLayout
构造具有组件之间指定间隙的边框布局。
borderListener - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI
边界听众
BorderListener() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
BorderPane - Class in javafx.scene.layout
BorderPane在上，左，右，底部和中间位置摆放孩子。
BorderPane() - Constructor for class javafx.scene.layout. BorderPane
创建BorderPane布局。
BorderPane(Node) - Constructor for class javafx.scene.layout. BorderPane
创建一个BorderPane布局，给定的Node作为BorderPane的中心。
BorderPane(Node, Node, Node, Node, Node) - Constructor for class javafx.scene.layout. BorderPane
创建BorderPane布局，其中给定的节点用于边框中每个主要布局区域。
borderProperty() - Method in class javafx.scene.layout. Region
该区域的边界由零个或多个BorderStrokes组成，零个或多个BorderImages。
BorderRepeat - Enum in javafx.scene.layout
枚举指示边框图像的重复规则。
borderSelectionColor - Variable in class javax.swing.tree. DefaultTreeCellEditor
如果绘制边框选择颜色，则为真。
borderSelectionColor - Variable in class javax.swing.tree. DefaultTreeCellRenderer
当节点具有焦点时，用于聚焦指示符的颜色。
BorderStroke - Class in javafx.scene.layout
定义用于对区域进行样式设置的边框上使用的笔画。
BorderStroke(Paint, BorderStrokeStyle, CornerRadii, BorderWidths) - Constructor for class javafx.scene.layout. BorderStroke
创建一个新的BorderStroke。
BorderStroke(Paint, BorderStrokeStyle, CornerRadii, BorderWidths, Insets) - Constructor for class javafx.scene.layout. BorderStroke
创建一个新的BorderStroke。
BorderStroke(Paint, Paint, Paint, Paint, BorderStrokeStyle, BorderStrokeStyle, BorderStrokeStyle, BorderStrokeStyle, CornerRadii, BorderWidths, Insets) - Constructor for class javafx.scene.layout. BorderStroke
创建一个新的BorderStroke，指定所有构造参数。
BorderStrokeStyle - Class in javafx.scene.layout
定义在BorderStroke的一边使用的笔触风格。
BorderStrokeStyle(StrokeType, StrokeLineJoin, StrokeLineCap, double, double, List<Double>) - Constructor for class javafx.scene.layout. BorderStrokeStyle
创建一个新的BorderStrokeStyle。
BorderUIResource - Class in javax.swing.plaf
实现UIResource的边界包装类。
BorderUIResource(Border) - Constructor for class javax.swing.plaf. BorderUIResource
创建一个包含现有Border实例的UIResource边框对象。
BorderUIResource.BevelBorderUIResource - Class in javax.swing.plaf
斜角边界UI资源。
BorderUIResource.CompoundBorderUIResource - Class in javax.swing.plaf
复合边界UI资源。
BorderUIResource.EmptyBorderUIResource - Class in javax.swing.plaf
一个空的边界UI资源。
BorderUIResource.EtchedBorderUIResource - Class in javax.swing.plaf
蚀刻的边界UI资源。
BorderUIResource.LineBorderUIResource - Class in javax.swing.plaf
线边界UI资源。
BorderUIResource.MatteBorderUIResource - Class in javax.swing.plaf
无边界的UI资源。
BorderUIResource.TitledBorderUIResource - Class in javax.swing.plaf
标题边界UI资源。
BorderWidths - Class in javafx.scene.layout
定义四个组件（顶部，右侧，底部和左侧）的宽度。
BorderWidths(double) - Constructor for class javafx.scene.layout. BorderWidths
使用所有四个边框的给定宽度创建一个新的BorderWidth，并将此宽度视为文字值，而不是百分比。
BorderWidths(double, double, double, double) - Constructor for class javafx.scene.layout. BorderWidths
创建一个新的BorderWidths，具有指定的顶部，右侧，底部和左侧的宽度。
BorderWidths(double, double, double, double, boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.layout. BorderWidths
创建一个新的BorderWidths。
BOTH - Static variable in class java.awt. GridBagConstraints
水平和垂直调整组件的大小。
bottom - Variable in class java.awt. Insets
从底部的插图。
bottom - Variable in class javax.swing.border. EmptyBorder
边框的底部插图。
BOTTOM - javafx.geometry. Side
表示矩形的底部。
BOTTOM - javafx.geometry. VPos
表示底部垂直位置。
BOTTOM - javafx.scene.control. ContentDisplay
内容将被放置在标签的底部。
BOTTOM - Static variable in class javafx.print. PaperSource
指定选择底部托盘。
BOTTOM - Static variable in class javax.print.attribute.standard. MediaTray
打印机底部进纸盘。
BOTTOM - Static variable in class javax.swing.border. TitledBorder
将标题放在边框底部的中间。
BOTTOM - Static variable in class javax.swing. JSplitPane
用来添加 Component其他下方 Component 。
BOTTOM - Static variable in interface javax.swing. SwingConstants
用于指定框底部的方框常数。
BOTTOM_ALIGNMENT - Static variable in class java.awt. Component
易于使用的常数为 getAlignmentY 。
BOTTOM_ALIGNMENT - Static variable in class java.awt.font. GraphicAttribute
将图形底部对齐到底部。
BOTTOM_CENTER - javafx.geometry. Pos
水平定位在垂直方向和中心位置。
BOTTOM_LEFT - javafx.geometry. Pos
表示垂直和左侧水平位置。
BOTTOM_RIGHT - javafx.geometry. Pos
在垂直方向和右侧水平定位。
bottomInputProperty() - Method in class javafx.scene.effect. Blend
这个 Blend操作的底部输入。
bottomOpacityProperty() - Method in class javafx.scene.effect. Reflection
底部的不透明度值，它是底部极端反射的不透明度。
bottomProperty() - Method in class javafx.scene.layout. BorderPane
节点放置在此边框的底部边缘。
BOUND_SERVER_NAME - Static variable in class javax.security.sasl. Sasl
指定未绑定服务器的绑定服务器名称的属性的名称。
BoundedRangeModel - Interface in javax.swing
定义 Slider和 ProgressBar等组件使用的数据模型。
BoundingBox - Class in javafx.geometry
一个矩形边框，用于描述节点或其他场景图对象的界限。
BoundingBox(double, double, double, double) - Constructor for class javafx.geometry. BoundingBox
创建一个新的2D BoundingBox实例。
BoundingBox(double, double, double, double, double, double) - Constructor for class javafx.geometry. BoundingBox
创建一个新的3D实例 BoundingBox 。
bounds - Variable in class java.awt. Polygon
这个边界 Polygon 。
bounds() - Method in interface com.sun.javadoc. TypeVariable
已过时。
返回此类型变量的边界。
bounds() - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由getBounds()替代。
Bounds - Class in javafx.geometry
用于描述节点或其他场景图形对象边界的对象的基类。
Bounds - Exception in org.omg.CORBA
当参数不在方法尝试访问的对象的合法范围内时抛出用户异常。
Bounds - Exception in org.omg.CORBA.TypeCodePackage
提供 TypeCode操作 member_name() ， member_type() ，并 member_label 。
Bounds() - Constructor for exception org.omg.CORBA. Bounds
构造一个没有指定详细消息的 Bounds 。
Bounds() - Constructor for exception org.omg.CORBA.TypeCodePackage. Bounds
构造一个没有原因消息的 Bounds异常。
Bounds(double, double, double, double, double, double) - Constructor for class javafx.geometry. Bounds
创建一个新的 Bounds类的实例。
Bounds(String) - Constructor for exception org.omg.CORBA. Bounds
构造具有指定详细消息的 Bounds 。
Bounds(String) - Constructor for exception org.omg.CORBA.TypeCodePackage. Bounds
构造具有指定原因消息的 Bounds异常。
BOUNDS - javafx.scene. AccessibleAttribute
返回节点的边界。
BOUNDS_FOR_RANGE - javafx.scene. AccessibleAttribute
返回给定字符范围的边界矩形数组。
BoundsHelper - Class in org.omg.CORBA
这个Helper类用于方便编组 Bounds 。
BoundsHelper - Class in org.omg.CORBA.TypeCodePackage
这个Helper类用于方便编组 TypeCodePackage/Bounds 。
BoundsHelper() - Constructor for class org.omg.CORBA. BoundsHelper
BoundsHelper() - Constructor for class org.omg.CORBA.TypeCodePackage. BoundsHelper
boundsInLocalProperty() - Method in class javafx.scene. Node
该 Node的矩形边界在节点未转换的局部坐标空间中。
boundsInParentProperty() - Method in class javafx.scene. Node
这个 Node的矩形边界包括它的变换。
boundsTypeProperty() - Method in class javafx.scene.text. Text
确定如何计算文本节点的边界。
Box - Class in javafx.scene.shape
Box类定义了具有指定大小的3维框。
Box - Class in javax.swing
一个使用BoxLayout对象作为其布局管理器的轻量级容器。
Box() - Constructor for class javafx.scene.shape. Box
Box(double, double, double) - Constructor for class javafx.scene.shape. Box
按深度创建尺寸宽度为 Box的新实例。
Box(int) - Constructor for class javax.swing. Box
创建一个 Box ，它沿着指定的轴显示其组件。
BOX_DRAWING - Static variable in class java.lang. Character.UnicodeBlock
常量为“框图”Unicode字符块。
Box.AccessibleBox - Class in javax.swing
这个类实现 Box类的可访问性支持。
Box.Filler - Class in javax.swing
参与布局但没有视图的轻量级组件的实现。
Box.Filler.AccessibleBoxFiller - Class in javax.swing
这个类实现 Box.Filler类的可访问性支持。
BoxBlur - Class in javafx.scene.effect
使用简单的盒式过滤器内核的模糊效果，在两个维度上都有单独配置的大小，以及控制所产生的模糊质量的迭代参数。
BoxBlur() - Constructor for class javafx.scene.effect. BoxBlur
使用默认参数创建一个新的BoxBlur实例。
BoxBlur(double, double, int) - Constructor for class javafx.scene.effect. BoxBlur
创建一个新的具有指定宽度，高度和迭代的BoxBlur实例。
boxed() - Method in interface java.util.stream. DoubleStream
返回一个 Stream ，由此流的元素组成，装箱至 Double 。
boxed() - Method in interface java.util.stream. IntStream
返回一个由这个流的元素组成的 Stream ，每个包装成一个 Integer 。
boxed() - Method in interface java.util.stream. LongStream
返回一个 Stream组成的这个流的元素，每个盒装到一个 Long 。
boxedClass(PrimitiveType) - Method in interface javax.lang.model.util. Types
返回给定基元类型的盒装值的类。
BoxedValueHelper - Interface in org.omg.CORBA.portable
BoxLayout - Class in javax.swing
一个布局管理器，可以将多个组件垂直或水平放置。
BoxLayout(Container, int) - Constructor for class javax.swing. BoxLayout
创建一个布局管理器，它将沿着给定的轴布局组件。
boxRect - Variable in class javax.swing.plaf.basic. BasicProgressBarUI
用于保存弹出框（由getBox返回）的位置和大小以进行绘制。
BoxView - Class in javax.swing.text
通过沿着一条轴平铺儿童，将孩子们排列成盒子形状的观点。
BoxView(Element, int) - Constructor for class javax.swing.text. BoxView
构造一个 BoxView 。
BR - Static variable in class javax.swing.text.html. HTML.Tag
标签<br>
BRACELEFT - javafx.scene.input. KeyCode
常数为 Left Brace键。
BRACERIGHT - javafx.scene.input. KeyCode
常数为 Right Brace键。
BRAHMI - java.lang. Character.UnicodeScript
Unicode脚本“Brahmi”。
BRAHMI - Static variable in class java.lang. Character.UnicodeBlock
“Brahmi”Unicode字符块的常量。
BRAILLE - java.lang. Character.UnicodeScript
Unicode脚本“盲文”。
BRAILLE_PATTERNS - Static variable in class java.lang. Character.UnicodeBlock
“盲文图案”Unicode字符块的常数。
branch(Association) - Method in class com.sun.nio.sctp. SctpMultiChannel
分支协会。
branchCollapsedEvent() - Static method in class javafx.scene.control. TreeItem
当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于折叠状态。
BranchElement(Element, AttributeSet) - Constructor for class javax.swing.text. AbstractDocument.BranchElement
构造最初不包含子项的复合元素。
branchExpandedEvent() - Static method in class javafx.scene.control. TreeItem
当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于展开状态。
breadthFirstEnumeration() - Method in class javax.swing.tree. DefaultMutableTreeNode
创建并返回以宽度优先顺序遍历以此节点为根的子树的枚举。
BREAK - com.sun.source.tree. Tree.Kind
用于BreakTree的实例。
BREAK - jdk.nashorn.api.tree. Tree.Kind
用于BreakTree的实例。
BreakIterator - Class in java.text
BreakIterator类实现了在文本中查找边界位置的方法。
BreakIterator() - Constructor for class java.text. BreakIterator
构造函数。
BreakIteratorProvider - Class in java.text.spi
提供BreakIterator类的具体实现的服务提供者的抽象类。
BreakIteratorProvider() - Constructor for class java.text.spi. BreakIteratorProvider
唯一的构造函数。
BreakpointEvent - Interface in com.sun.jdi.event
通知目标VM中的断点。
BreakpointRequest - Interface in com.sun.jdi.request
标识目标VM中应停止执行的Location 。
breakpointRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的断点请求的不可修改的列表。
breaksFlow() - Method in class javax.swing.text.html. HTML.Tag
返回 true如果此标签导致数据流的换行，否则返回 false 。
breaksFlow() - Method in class javax.swing.text.html.parser. TagElement
返回 true如果此标签导致数据流的换行，否则返回 false 。
BreakTree - Interface in com.sun.source.tree
一个 break语句的树节点。
BreakTree - Interface in jdk.nashorn.api.tree
“休息”语句的树节点。
breakView(int, float, Shape) - Method in class javax.swing.text. ParagraphView
以给定长度在给定轴上打破此视图。
breakView(int, int, float, float) - Method in class javax.swing.text. GlyphView
以给定长度在给定轴上打破此视图。
breakView(int, int, float, float) - Method in class javax.swing.text.html. InlineView
试图在给定的轴上打破这个视图。
breakView(int, int, float, float) - Method in class javax.swing.text. View
试图在给定的轴上打破这个视图。
bridge - Variable in class javafx.scene.control. PopupControl
我们需要一个特殊的根节点，除了我们不能替代PopupControl中的特殊根节点。
BRIEF - Static variable in class java.rmi.server. LogStream
已过时。
日志级别常量（简短日志记录）。
brighter() - Method in class java.awt. Color
创建一个新 Color ，它是此的一个亮的 Color 。
brighter() - Method in class javafx.scene.paint. Color
创建一个这种颜色更亮的新颜色。
brightnessProperty() - Method in class javafx.scene.effect. ColorAdjust
亮度调节值。
BrokenBarrierException - Exception in java.util.concurrent
当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。
BrokenBarrierException() - Constructor for exception java.util.concurrent. BrokenBarrierException
构造一个没有指定详细消息的 BrokenBarrierException 。
BrokenBarrierException(String) - Constructor for exception java.util.concurrent. BrokenBarrierException
构造具有指定详细消息的 BrokenBarrierException 。
BROWN - Static variable in class javafx.scene.paint. Color
颜色棕色，RGB值为＃A52A2A
browse(URI) - Method in class java.awt. Desktop
启动默认浏览器以显示 URI 。
BROWSE - java.awt. Desktop.Action
代表“浏览”动作。
BROWSE_FILE_DIR - java.awt. Desktop.Action
表示浏览文件目录
browseFileDirectory(File) - Method in class java.awt. Desktop
打开包含 file的文件夹，并在默认的系统文件管理器中选择它。
BubbleChart< X, Y> - Class in javafx.scene.chart
为一系列数据点绘制气泡的图表类型。
BubbleChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. BubbleChart
使用给定的轴构建一个新的BubbleChart。
BubbleChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>) - Constructor for class javafx.scene.chart. BubbleChart
使用给定的轴和数据构建新的BubbleChart。
BUBBLING_PHASE - Static variable in interface org.w3c.dom.events. Event
当前事件阶段是冒泡阶段。
buf - Variable in class java.io. BufferedInputStream
存储数据的内部缓冲区数组。
buf - Variable in class java.io. BufferedOutputStream
存储数据的内部缓冲区。
buf - Variable in class java.io. ByteArrayInputStream
由数据流的创建者提供的字节数组。
buf - Variable in class java.io. ByteArrayOutputStream
存储数据的缓冲区。
buf - Variable in class java.io. CharArrayReader
字符缓冲区。
buf - Variable in class java.io. CharArrayWriter
存储数据的缓冲区。
buf - Variable in class java.io. PushbackInputStream
推回缓冲区。
buf - Variable in class java.util.zip. DeflaterInputStream
用于读取压缩数据的输入缓冲区
buf - Variable in class java.util.zip. DeflaterOutputStream
用于写入压缩数据的输出缓冲区
buf - Variable in class java.util.zip. InflaterInputStream
用于解压缩的输入缓冲区。
buf - Variable in class java.util.zip. InflaterOutputStream
用于写入未压缩数据的输出缓冲区。
buffer - Variable in class java.io. PipedInputStream
传入数据的循环缓冲区。
buffer - Variable in class java.io. StringBufferInputStream
已过时。
读取字节的字符串。
buffer - Variable in class javax.swing.text. DefaultStyledDocument
元素缓冲区。
buffer() - Method in class com.sun.nio.sctp. SendFailedNotification
返回要发送的数据。
Buffer - Class in java.nio
用于特定原始类型的数据的容器。
BUFFER_OVERFLOW - javax.net.ssl. SSLEngineResult.Status
SSLEngine无法处理操作，因为目标缓冲区中没有足够的可用字节来保存结果。
BUFFER_SIZE_DEFAULT - Static variable in class javax.swing.text. DefaultStyledDocument
初始内容缓冲区的默认大小。
BUFFER_UNDERFLOW - javax.net.ssl. SSLEngineResult.Status
SSLEngine无法解开传入的数据，因为没有足够的源字节可用来创建完整的数据包。
BufferCapabilities - Class in java.awt
缓冲区的功能和属性。
BufferCapabilities(ImageCapabilities, ImageCapabilities, BufferCapabilities.FlipContents) - Constructor for class java.awt. BufferCapabilities
创建一个用于指定缓冲功能的新对象
BufferCapabilities.FlipContents - Class in java.awt
页面翻转后可能的反向缓冲区内容的类型安全枚举
BUFFERED_OPTION - Static variable in class javax.swing. DebugGraphics
在单独的 Frame显示缓冲操作。
BufferedImage - Class in java.awt.image
BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
BufferedImage(int, int, int) - Constructor for class java.awt.image. BufferedImage
构造其中一个预定义图像类型的 BufferedImage 。
BufferedImage(int, int, int, IndexColorModel) - Constructor for class java.awt.image. BufferedImage
构造一个预定义的图像类型的一个 BufferedImage ：TYPE_BYTE_BINARY或TYPE_BYTE_INDEXED。
BufferedImage(ColorModel, WritableRaster, boolean, Hashtable<?, ?>) - Constructor for class java.awt.image. BufferedImage
构造一个新的 BufferedImage与指定的 ColorModel和 Raster 。
BufferedImageFilter - Class in java.awt.image
所述BufferedImageFilter类的子类的ImageFilter是提供一种使用单一源/单一目标图像操作符（的简单方法BufferedImageOp ）以过滤BufferedImage在图像生产者/消费者/观察员范例。
BufferedImageFilter(BufferedImageOp) - Constructor for class java.awt.image. BufferedImageFilter
构造具有指定的单源/单目的地址操作符的 BufferedImageFilter 。
BufferedImageOp - Interface in java.awt.image
该接口描述了对 BufferedImage对象执行的单输入/单输出操作。
BufferedInputStream - Class in java.io
A BufferedInputStream将功能添加到另一个输入流 - 即缓冲输入并支持 mark和 reset方法的功能。
BufferedInputStream(InputStream) - Constructor for class java.io. BufferedInputStream
创建一个 BufferedInputStream并保存其参数，输入流 in供以后使用。
BufferedInputStream(InputStream, int) - Constructor for class java.io. BufferedInputStream
创建一个具有指定缓冲区大小的 BufferedInputStream ，并保存其参数，输入流 in供以后使用。
BufferedOutputStream - Class in java.io
该类实现缓冲输出流。
BufferedOutputStream(OutputStream) - Constructor for class java.io. BufferedOutputStream
创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
BufferedOutputStream(OutputStream, int) - Constructor for class java.io. BufferedOutputStream
创建一个新的缓冲输出流，以便以指定的缓冲区大小将数据写入指定的底层输出流。
BufferedReader - Class in java.io
从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
BufferedReader(Reader) - Constructor for class java.io. BufferedReader
创建使用默认大小的输入缓冲区的缓冲字符输入流。
BufferedReader(Reader, int) - Constructor for class java.io. BufferedReader
创建使用指定大小的输入缓冲区的缓冲字符输入流。
BufferedWriter - Class in java.io
将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
BufferedWriter(Writer) - Constructor for class java.io. BufferedWriter
创建使用默认大小的输出缓冲区的缓冲字符输出流。
BufferedWriter(Writer, int) - Constructor for class java.io. BufferedWriter
创建一个新的缓冲字符输出流，使用给定大小的输出缓冲区。
BufferOverflowException - Exception in java.nio
相对 放置操作达到目标缓冲区限制时抛出的未检查异常。
BufferOverflowException() - Constructor for exception java.nio. BufferOverflowException
构造这个类的一个实例。
BufferPoolMXBean - Interface in java.lang.management
缓冲池的管理界面，例如direct或mapped缓冲区的池。
bufferProgressTimeProperty() - Method in class javafx.scene.media. MediaPlayer
当前的缓冲位置指示可以播放多少媒体，而不会停止 MediaPlayer 。
BufferStrategy - Class in java.awt.image
BufferStrategy类表示在特定的 Canvas或 Window上组织复杂内存的机制。
BufferStrategy() - Constructor for class java.awt.image. BufferStrategy
BufferUnderflowException - Exception in java.nio
当相对 get操作达到源缓冲区的限制时抛出未检查的异常。
BufferUnderflowException() - Constructor for exception java.nio. BufferUnderflowException
构造这个类的一个实例。
BUGINESE - java.lang. Character.UnicodeScript
Unicode脚本“Buginese”。
BUGINESE - Static variable in class java.lang. Character.UnicodeBlock
“Buginese”Unicode字符块的常数。
BUHID - java.lang. Character.UnicodeScript
Unicode脚本“Buhid”。
BUHID - Static variable in class java.lang. Character.UnicodeBlock
“Buhid”Unicode字符块的常量。
build() - Method in class java.lang.module. ModuleDescriptor.Builder
构建并从其组件返回一个 ModuleDescriptor 。
build() - Method in class java.lang. Runtime.Version
返回 build number 。
build() - Method in class java.nio.file.attribute. AclEntry.Builder
从此构建器的组件构造一个AclEntry 。
build() - Method in interface java.sql. ConnectionBuilder
返回由此构建器定义的对象的实例。
build() - Method in interface java.sql. ShardingKeyBuilder
返回由此构建器定义的对象的实例。
build() - Method in class java.util. Calendar.Builder
返回一个由setter方法设置的参数构建的 Calendar 。
build() - Method in class java.util. Locale.Builder
返回从此构建器上设置的字段创建的实例 Locale 。
build() - Method in interface java.util.stream. DoubleStream.Builder
构建流，将此构建器转换为内置状态。
build() - Method in interface java.util.stream. IntStream.Builder
构建流，将此构建器转换为内置状态。
build() - Method in interface java.util.stream. LongStream.Builder
构建流，将此构建器转换为内置状态。
build() - Method in interface java.util.stream. Stream.Builder
构建流，将此构建器转换为内置状态。
build() - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder
使用当前设置生成新的JavaBeanBooleanProperty 。
build() - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder
使用当前设置生成新的JavaBeanDoubleProperty 。
build() - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder
使用当前设置生成新的JavaBeanFloatProperty 。
build() - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder
使用当前设置生成新的JavaBeanIntegerProperty 。
build() - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder
使用当前设置生成新的JavaBeanLongProperty 。
build() - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder
使用当前设置生成新的JavaBeanObjectProperty 。
build() - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder
使用当前设置生成新的JavaBeanStringProperty 。
build() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder
使用当前设置生成新的ReadOnlyJavaBeanBooleanProperty 。
build() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder
使用当前设置生成新的ReadOnlyJavaBeanDoubleProperty 。
build() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder
使用当前设置生成新的ReadOnlyJavaBeanFloatProperty 。
build() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder
使用当前设置生成新的ReadOnlyJavaBeanIntegerProperty 。
build() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder
使用当前设置生成新的ReadOnlyJavaBeanLongProperty 。
build() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder
使用当前设置生成新的ReadOnlyJavaBeanObjectProperty 。
build() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder
使用当前设置生成新的ReadOnlyJavaBeanStringProperty 。
build() - Method in interface javafx.util. Builder
构建并返回对象。
build() - Method in interface javax.sql. PooledConnectionBuilder
返回由此构建器定义的对象的实例。
build() - Method in interface javax.sql. XAConnectionBuilder
返回由此构建器定义的对象的实例。
build() - Method in class javax.xml.catalog. CatalogFeatures.Builder
返回此构建器构建的CatalogFeatures对象。
build() - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
根据此 W3CEndpointReferenceBuilder实例中设置的累积属性构建一个 W3CEndpointReference 。
build() - Method in class jdk.incubator.http. HttpClient.Builder
返回从此构建器的当前状态构建的HttpClient 。
build() - Method in class jdk.incubator.http. HttpRequest.Builder
构建并返回一个HttpRequest 。
build() - Method in class jdk.jshell. JShell.Builder
构建一个JShell状态引擎。
build() - Method in class jdk.security.jarsigner. JarSigner.Builder
根据setter方法设置的参数构建一个 JarSigner对象。
build(CertPathParameters) - Method in class java.security.cert. CertPathBuilder
尝试使用指定的算法参数集构建认证路径。
buildAsync() - Method in interface jdk.incubator.http. WebSocket.Builder
构建一个 WebSocket 。
buildChooser() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel
建立一个新的选择面板。
builder() - Static method in interface java.util.stream. DoubleStream
返回一个 DoubleStream生成器。
builder() - Static method in interface java.util.stream. IntStream
返回一个 IntStream生成器。
builder() - Static method in interface java.util.stream. LongStream
返回一个 LongStream生成器。
builder() - Static method in interface java.util.stream. Stream
返回一个 Stream生成器。
builder() - Static method in class javax.xml.catalog. CatalogFeatures
返回用于创建CatalogFeatures对象的构建器的实例。
builder() - Static method in class jdk.jshell. JShell
JShell.Builder工厂方法，反过来，用于创建 JShell实例。
builder() - Static method in interface jdk.jshell.tool. JavaShellToolBuilder
创建一个用于启动JDK jshell工具的构建器。
Builder< T> - Interface in javafx.util
代表构建器的界面。
Builder() - Constructor for class java.security. KeyStore.Builder
构建新的Builder。
Builder() - Constructor for class java.util. Calendar.Builder
构造一个 Calendar.Builder 。
Builder() - Constructor for class java.util. Locale.Builder
构造一个空的构建器。
Builder() - Constructor for class jdk.incubator.http. HttpClient.Builder
Builder() - Constructor for class jdk.incubator.http. HttpRequest.Builder
创建一个生成器。
Builder(KeyStore.PrivateKeyEntry) - Constructor for class jdk.security.jarsigner. JarSigner.Builder
使用JarSigner.Builder对象创建一个JarSigner.Builder对象。
Builder(PrivateKey, CertPath) - Constructor for class jdk.security.jarsigner. JarSigner.Builder
使用私钥和认证路径创建一个 JarSigner.Builder对象。
BuilderFactory - Interface in javafx.util
界面代表建筑工厂。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.concurrent. Service
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.concurrent. Task
buildEventDispatchChain(EventDispatchChain) - Method in interface javafx.event. EventTarget
为此目标构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene.control. Dialog
为此目标构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene.control. Menu
为此目标构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene.control. MenuItem
为此目标构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene.control. Tab
为此目标构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene.control. TableColumnBase
为此目标构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene.control. TreeItem
为此目标构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene. Node
为此节点构造事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene. Scene
为此场景构建事件调度链。
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.scene.transform. Transform
buildEventDispatchChain(EventDispatchChain) - Method in class javafx.stage. Window
为此窗口构建事件调度链。
bulkRegister(int) - Method in class java.util.concurrent. Phaser
增加给定数量的新的有争议的派对到这个移相器。
BULLETS - javafx.scene.web. HTMLEditorSkin.Command
bumpInputProperty() - Method in class javafx.scene.effect. Lighting
可选的凹凸贴图输入。
bumpMapProperty() - Method in class javafx.scene.paint. PhongMaterial
这个PhongMaterial的凹凸贴图，这是一个正常的地图，存储为RGB Image 。
BURLYWOOD - Static variable in class javafx.scene.paint. Color
颜色粗糙的木材，RGB值为＃DEB887
burstStringInto(Container, String, int) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
递归创建新的 JLabel实例来表示 d 。
BUSY - Static variable in class javax.accessibility. AccessibleState
表示当前对象正在忙。
BUTT - javafx.scene.shape. StrokeLineCap
结束未封闭的子路径和划线段，没有添加装饰。
Button - Class in java.awt
这个类创建一个标记的按钮。
Button - Class in javafx.scene.control
一个简单的按钮控件。
Button() - Constructor for class java.awt. Button
构造一个带有标签的空字符串的按钮。
Button() - Constructor for class javafx.scene.control. Button
为其标签创建一个空字符串的按钮。
Button(String) - Constructor for class java.awt. Button
构造具有指定标签的按钮。
Button(String) - Constructor for class javafx.scene.control. Button
创建具有指定文本的按钮作为其标签。
Button(String, Node) - Constructor for class javafx.scene.control. Button
创建一个带有指定文本和图标的按钮。
BUTTON - javafx.scene. AccessibleRole
按钮角色。
BUTTON - Static variable in class javax.swing.plaf.synth. Region
按钮区域。
BUTTON_ORDER_LINUX - Static variable in class javafx.scene.control. ButtonBar
Linux上的默认按钮排序（特别是GNOME）。
BUTTON_ORDER_MAC_OS - Static variable in class javafx.scene.control. ButtonBar
Mac OS上的默认按钮排序。
BUTTON_ORDER_NONE - Static variable in class javafx.scene.control. ButtonBar
一个按钮排序字符串，指定没有按钮排序。
BUTTON_ORDER_WINDOWS - Static variable in class javafx.scene.control. ButtonBar
Windows上的默认按钮排序。
Button.AccessibleAWTButton - Class in java.awt
该类实现对 Button类的可访问性支持。
BUTTON1 - Static variable in class java.awt.event. MouseEvent
表示鼠标按钮＃1; 由MouseEvent.getButton()使用 。
BUTTON1_DOWN_MASK - Static variable in class java.awt.event. InputEvent
鼠标Button1扩展修饰符常数。
BUTTON1_MASK - Static variable in class java.awt.event. InputEvent
已过时。
建议使用BUTTON1_DOWN_MASK和InputEvent.getModifiersEx()
BUTTON2 - Static variable in class java.awt.event. MouseEvent
表示鼠标按钮＃2; 由MouseEvent.getButton()使用 。
BUTTON2_DOWN_MASK - Static variable in class java.awt.event. InputEvent
鼠标Button2扩展修饰符常数。
BUTTON2_MASK - Static variable in class java.awt.event. InputEvent
已过时。
建议使用BUTTON2_DOWN_MASK和InputEvent.getModifiersEx() 。 请注意，BUTTON2_MASK的值与ALT_MASK相同。
BUTTON3 - Static variable in class java.awt.event. MouseEvent
表示鼠标按钮＃3; 由MouseEvent.getButton()使用 。
BUTTON3_DOWN_MASK - Static variable in class java.awt.event. InputEvent
鼠标Button3扩展修饰符常数。
BUTTON3_MASK - Static variable in class java.awt.event. InputEvent
已过时。
建议使用BUTTON3_DOWN_MASK和InputEvent.getModifiersEx() 。 请注意，BUTTON3_MASK与META_MASK具有相同的值。
ButtonActionListener(int) - Constructor for class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonActionListener
构造一个新的实例 ButtonActionListener 。
ButtonAreaLayout(boolean, int) - Constructor for class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout
构造一个新的实例 ButtonAreaLayout 。
ButtonBar - Class in javafx.scene.control
ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。
ButtonBar() - Constructor for class javafx.scene.control. ButtonBar
使用用户操作系统的默认属性创建默认的ButtonBar实例。
ButtonBar(String) - Constructor for class javafx.scene.control. ButtonBar
使用给定的按钮顺序创建ButtonBar（有关详细信息，请参阅 ButtonBar.buttonOrderProperty() ）。
ButtonBar.ButtonData - Enum in javafx.scene.control
枚举所有可用的按钮数据注释。
ButtonBarSkin - Class in javafx.scene.control.skin
默认皮肤实现为ButtonBar控件。
ButtonBarSkin(ButtonBar) - Constructor for class javafx.scene.control.skin. ButtonBarSkin
创建一个新的ButtonBarSkin实例，将必需的子节点安装到控件 children列表中。
ButtonBase - Class in javafx.scene.control
按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。
ButtonBase() - Constructor for class javafx.scene.control. ButtonBase
创建一个带有空文本的默认ButtonBase。
ButtonBase(String) - Constructor for class javafx.scene.control. ButtonBase
创建一个带有给定文本的ButtonBase。
ButtonBase(String, Node) - Constructor for class javafx.scene.control. ButtonBase
创建一个带有给定文本和图形的ButtonBase。
ButtonBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.ButtonBorder
ButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic. BasicBorders.ButtonBorder
构造一个新的实例 ButtonBorder 。
buttonCellProperty() - Method in class javafx.scene.control. ComboBox
按钮单元格用于渲染ComboBox“按钮”区域中显示的内容。
ButtonGroup - Class in javax.swing
此类用于为一组按钮创建多重排除范围。
ButtonGroup() - Constructor for class javax.swing. ButtonGroup
创建一个新的 ButtonGroup 。
buttonIndex - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonActionListener
按钮的索引。
buttonListener - Variable in class javax.swing.plaf.basic. BasicScrollBarUI
按钮监听器
buttonMinWidthProperty() - Method in class javafx.scene.control. ButtonBar
指定放置在此按钮栏中的所有按钮的最小宽度。
ButtonModel - Interface in javax.swing
按钮的状态模型。
buttonOrderProperty() - Method in class javafx.scene.control. ButtonBar
标准按钮栏中典型按钮的顺序。
buttons - Variable in class javax.swing. ButtonGroup
参与此组的按钮列表。
ButtonSkin - Class in javafx.scene.control.skin
默认皮肤实现为Button控件。
ButtonSkin(Button) - Constructor for class javafx.scene.control.skin. ButtonSkin
创建一个新的ButtonSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。
ButtonType - Class in javafx.scene.control
ButtonType类用作JavaFX Dialog API（更具体地说， DialogPane API）的一部分，用于指定在对话框中向用户显示哪些按钮。
ButtonType(String) - Constructor for class javafx.scene.control. ButtonType
创建一个带有给定文本的ButtonType实例，并将ButtonData设置为 ButtonBar.ButtonData.OTHER 。
ButtonType(String, ButtonBar.ButtonData) - Constructor for class javafx.scene.control. ButtonType
创建一个带有给定文本的ButtonType实例，并按指定的方式设置ButtonData。
ButtonUI - Class in javax.swing.plaf
JButton可插拔的外观和界面。
ButtonUI() - Constructor for class javax.swing.plaf. ButtonUI
byAngleProperty() - Method in class javafx.animation. RotateTransition
指定从这个 RotateTransition开始的递增停止角度值。
Byte - Class in java.lang
Byte类在一个对象中包含一个原始类型 byte的值。
Byte(byte) - Constructor for class java.lang. Byte
已过时。
很少使用这个构造函数。 静态工厂Byte.valueOf(byte)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
Byte(String) - Constructor for class java.lang. Byte
已过时。
很少使用这个构造函数。 使用Byte.parseByte(String)将字符串转换为byte原语，或使用Byte.valueOf(String)将字符串转换为Byte对象。
BYTE - javax.lang.model.type. TypeKind
原始类型 byte 。
BYTE - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.lang.Byte值的 SimpleType实例。
BYTE_ARRAY(String) - Constructor for class javax.print. DocFlavor.BYTE_ARRAY
使用给定的MIME类型和打印数据表示类名称为 "[B" （字节数组）构造新的doc风格。
BYTE_BGRA - javafx.scene.image. PixelFormat.Type
像素被存储在相邻的字节中，非预乘数组件以增加的索引顺序存储：蓝色，绿色，红色，α。
BYTE_BGRA_PRE - javafx.scene.image. PixelFormat.Type
像素被存储在相邻的字节中，其中预乘数分量按照增加的索引的顺序存储：蓝色，绿色，红色，α。
BYTE_INDEXED - javafx.scene.image. PixelFormat.Type
像素颜色由存储在像素阵列中的字节索引引用，将字节解释为由 PixelFormat对象提供的颜色列表中的无符号索引。
BYTE_RGB - javafx.scene.image. PixelFormat.Type
不透明像素存储在相邻字节中，颜色分量按照增加的索引顺序存储：红，绿，蓝。
ByteArrayInputStream - Class in java.io
A ByteArrayInputStream包含一个内部缓冲区，其中包含可以从流中读取的字节。
ByteArrayInputStream(byte[]) - Constructor for class java.io. ByteArrayInputStream
创建一个 ByteArrayInputStream ，使其使用 buf作为其缓冲区数组。
ByteArrayInputStream(byte[], int, int) - Constructor for class java.io. ByteArrayInputStream
创建 ByteArrayInputStream ，使用 buf作为其缓冲区数组。
ByteArrayOutputStream - Class in java.io
该类实现了将数据写入字节数组的输出流。
ByteArrayOutputStream() - Constructor for class java.io. ByteArrayOutputStream
创建一个新的字节数组输出流。
ByteArrayOutputStream(int) - Constructor for class java.io. ByteArrayOutputStream
创建一个新的字节数组输出流，具有指定大小的缓冲区容量（以字节为单位）。
byteArrayViewVarHandle(Class<?>, ByteOrder) - Static method in class java.lang.invoke. MethodHandles
产生一个VarHandle，可以访问 byte[]阵列的元素，如同它是不同的基本数组类型，如 int[]或 long[] 。
ByteBuffer - Class in java.nio
一个字节缓冲区。
byteBufferViewVarHandle(Class<?>, ByteOrder) - Static method in class java.lang.invoke. MethodHandles
产生VarHandle给予访问的元素 ByteBuffer视为好像它是一个不同的基本组件类型到的元件的阵列 byte ，如 int[]或 long[] 。
ByteChannel - Interface in java.nio.channels
一个可以读写字节的通道。
bytecodes() - Method in interface com.sun.jdi. 方法
返回一个包含此方法的字节码的数组。
bytecodes() - Method in class jdk.jshell.spi. ExecutionControl.ClassBytecodes
该类的字节码。
ByteHolder - Class in org.omg.CORBA
持有人 Byte 。
ByteHolder() - Constructor for class org.omg.CORBA. ByteHolder
构造一个新的 ByteHolder对象，其 value字段初始化为0。
ByteHolder(byte) - Constructor for class org.omg.CORBA. ByteHolder
为给定的 byte构造一个新的 ByteHolder对象。
byteLength - Variable in class javax.sound.midi. MidiFileFormat
MIDI文件的长度（以字节为单位）。
ByteLookupTable - Class in java.awt.image
这个类定义了一个查找表对象。
ByteLookupTable(int, byte[]) - Constructor for class java.awt.image. ByteLookupTable
从表示要应用于所有频带的查找表的字节数组构造一个ByteLookupTable对象。
ByteLookupTable(int, byte[][]) - Constructor for class java.awt.image. ByteLookupTable
从表示每个频带的查找表的字节数组的数组构造一个ByteLookupTable对象。
byteOrder - Variable in class javax.imageio.stream. ImageInputStreamImpl
作为枚举类别 java.nio.ByteOrder的实例的流的字节顺序，其中 ByteOrder.BIG_ENDIAN指示网络字节顺序和 ByteOrder.LITTLE_ENDIAN指示相反的顺序。
ByteOrder - Class in java.nio
字节顺序的类型安全枚举。
bytes() - Method in class com.sun.nio.sctp. MessageInfo
返回接收到的消息读取的字节数。
BYTES - Static variable in class java.lang. Byte
用于表示二进制补码二进制形式的 byte值的字节数。
BYTES - Static variable in class java.lang. Character
用于以无符号二进制形式表示 char值的字节数。
BYTES - Static variable in class java.lang. Double
用于表示 double值的字节数。
BYTES - Static variable in class java.lang. Float
用于表示 float值的字节数。
BYTES - Static variable in class java.lang. Integer
用于表示二进制补码二进制形式的 int值的字节数。
BYTES - Static variable in class java.lang. Long
用于表示二进制补码二进制形式的 long值的字节数。
BYTES - Static variable in class java.lang. Short
用于表示二进制补码二进制形式的 short值的字节数。
bytesConsumed() - Method in class javax.net.ssl. SSLEngineResult
返回从输入缓冲区消耗的字节数。
bytesProduced() - Method in class javax.net.ssl. SSLEngineResult
返回写入输出缓冲区的字节数。
bytesTransferred - Variable in exception java.io. InterruptedIOException
报告中断之前作为I / O操作的一部分传输了多少个字节。
ByteStringConverter - Class in javafx.util.converter
StringConverter实现Byte （和字节基元）值。
ByteStringConverter() - Constructor for class javafx.util.converter. ByteStringConverter
bytesWidth(byte[], int, int) - Method in class java.awt. FontMetrics
返回此 Font显示指定字节数组的总进位宽度。
ByteType - Interface in com.sun.jdi
在目标VM中访问的所有原始字节值的类型。
byteValue() - Method in interface com.sun.jdi. PrimitiveValue
将此值转换为ByteValue，并将结果作为字节返回。
byteValue() - Method in class java.lang. Byte
返回 Byte的值作为 byte 。
byteValue() - Method in class java.lang. Double
返回此值 Double为 byte的基本收缩转换后。
byteValue() - Method in class java.lang. Float
返回此值 Float为 byte的基本收缩转换后。
byteValue() - Method in class java.lang. Integer
返回此值 Integer为 byte的基本收缩转换后。
byteValue() - Method in class java.lang. Long
返回此值 Long为 byte的基本收缩转换后。
byteValue() - Method in class java.lang. Number
返回指定数字的值作为 byte 。
byteValue() - Method in class java.lang. Short
返回此值 Short为 byte的基本收缩转换后。
ByteValue - Interface in com.sun.jdi
提供对目标虚拟机 byte语 byte值的访问。
byteValueExact() - Method in class java.math. BigDecimal
将此 BigDecimal转换为 byte ，检查丢失的信息。
byteValueExact() - Method in class java.math. BigInteger
将此 BigInteger转换为 byte ，检查丢失的信息。
byValueProperty() - Method in class javafx.animation. FadeTransition
指定从这个 FadeTransition开始的递增停止不透明度值。
byXProperty() - Method in class javafx.animation. ScaleTransition
指定从这个 ScaleTransition开始的递增的停止X比例值。
byXProperty() - Method in class javafx.animation. TranslateTransition
指定从这个 TranslateTransition开始的递增的停止X坐标值。
byYProperty() - Method in class javafx.animation. ScaleTransition
指定从这个 ScaleTransition开始的递增的停止Y比例值。
byYProperty() - Method in class javafx.animation. TranslateTransition
指定从这个 TranslateTransition开始的递增的停止Y坐标值。
BYZANTINE_MUSICAL_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
常数为“拜占庭式音乐符号”Unicode字符块。
byZProperty() - Method in class javafx.animation. ScaleTransition
指定从这个 ScaleTransition开始的递增的停止Z比例值。
byZProperty() - Method in class javafx.animation. TranslateTransition
指定从这个 TranslateTransition开始的递增的停止Z坐标值。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


C-Index (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

SEARCH:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
C

C - javafx.scene.input. KeyCode

常数为 C键。

C - Static variable in class java.awt. PageAttributes.MediaType

Engineering C的MediaType实例，17 x 22 in。

C - Static variable in class javafx.print. Paper

指定工程C尺寸，17英寸×22英寸。

C - Static variable in class javax.print.attribute.standard. MediaSize.Engineering

指定工程C尺寸，17英寸×22英寸。

C - Static variable in class javax.print.attribute.standard. MediaSizeName

C尺寸。

C0 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C0的别名。

C1 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C1的别名。

C10 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C10的别名。

C14NMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec

一个CanonicalizationMethod算法的算法参数说明 。

C2 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C2的别名。

C3 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C3的别名。

C3 - Static variable in class javax.print.attribute.standard. MediaSize.ISO

指定ISO C3尺寸，324 mm×458 mm。

C4 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C4的别名。

C4 - Static variable in class javax.print.attribute.standard. MediaSize.ISO

指定ISO C4尺寸，229 mm×324 mm。

C5 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C5的别名。

C5 - Static variable in class javax.print.attribute.standard. MediaSize.ISO

指定ISO C5尺寸，162 mm×229 mm。

C6 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C6的别名。

C6 - Static variable in class javax.print.attribute.standard. MediaSize.ISO

指定ISO C6尺寸，114 mm x 162 mm。

C7 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C7的别名。

C8 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C8的别名。

C9 - Static variable in class java.awt. PageAttributes.MediaType

ISO_C9的别名。

CA_COMPROMISE - java.security.cert. CRLReason

这个原因表明已知或怀疑证书对象的私钥已经被泄密。

CACHED - Static variable in interface javax.jnlp. PersistenceService

cachedChildren() - Method in class java.util.prefs. AbstractPreferences

返回此节点的所有已知未被删除的子节点。

cachedMinimumSize - Variable in class javax.swing.plaf.basic. BasicComboBoxUI

缓存的最小首选大小。

CachedRowSet - Interface in javax.sql.rowset

CachedRowSet所有标准实现必须实现的接口。

CacheHint - Enum in javafx.scene

缓存提示用于 Node.cacheHint

cacheHintProperty() - Method in class javafx.scene. Node

控制位图缓存的其他提示。

cacheIcon(File, Icon) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

缓存文件的图标。

cacheMBeanInfo(MBeanInfo) - Method in class javax.management. StandardMBean

自定义钩子：缓存为此对象构建的MBeanInfo。

cacheProperty() - Method in class javafx.scene. Node

系统的性能提示表明这个 Node应该被缓存为一个位图。

CacheRequest - Class in java.net

表示在ResponseCache中存储资源的通道。

CacheRequest() - Constructor for class java.net. CacheRequest

CacheResponse - Class in java.net

代表从ResponseCache中检索资源的通道。

CacheResponse() - Constructor for class java.net. CacheResponse

cacheShapeProperty() - Method in class javafx.scene.layout. Region

定义对系统的提示，指出用于定义区域背景的Shape是稳定的，可以从缓存中受益。

cacheValue(ParsedValue, Object) - Method in class javafx.css. StyleConverter

缓存指定键的值。

CADETBLUE - Static variable in class javafx.scene.paint. Color

颜色学员蓝色，RGB值为＃5F9EA0

calcRect - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

用于一般布局计算的矩形，以避免构建许多新的矩形。

calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - Static method in class javax.swing. SizeRequirements

创建一堆偏移/跨度对，指定如何使用指定的对齐方式布置一组组件。

calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - Static method in class javax.swing. SizeRequirements

创建一组偏移/跨度对，指定如何使用指定的对齐方式布置一组组件。

calculateBreakPosition(int, int) - Method in class javax.swing.text. WrappedPlainView

这被嵌套的包装线视图调用来确定断点位置。

calculateContentRect() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算内容矩形。

calculateFocusRect() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算焦点矩形。

calculateGeometry() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算几何。

calculateGeometry() - Method in class javax.swing.plaf.synth. SynthSliderUI

计算几何。

calculateIndex(CompositeData) - Method in interface javax.management.openmbean. TabularData

计算将在此 TabularData实例中使用的索引，以引用指定的复合数据 值参数（如果将其添加到此实例）。

calculateIndex(CompositeData) - Method in class javax.management.openmbean. TabularDataSupport

计算将在此 TabularData实例中使用的索引，以引用指定的复合数据 值参数（如果已添加到此实例）。

calculateInnerArea(JComponent, Rectangle) - Static method in class javax.swing. SwingUtilities

存储 r指定组件的 r区域的位置和大小，并返回 r 。

calculateLabelRect() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算标签矩形。

calculateLayoutInfo() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout

计算布局信息。

calculateMajorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text. BoxView

计算长轴 axis的尺寸要求。

calculateMajorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html. BlockView

沿着长轴计算块的要求（即轴与其一起的瓦片）。

calculateMajorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text. TableView.TableRow

calculateMaxTabHeight(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

计算最大标签高度。

calculateMaxTabHeight(int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

calculateMaxTabHeight(int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

计算最大标签高度。

calculateMaxTabWidth(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

计算最大标签宽度。

calculateMaxTabWidth(int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

计算最大标签宽度。

calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text. BoxView

计算短轴 axis的尺寸要求。

calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text. FlowView

计算沿短轴的要求。

calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html. BlockView

计算沿着短轴的块的要求（即，与轴一起垂直于轴的轴以及瓦片）。

calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html. ParagraphView

计算沿着短轴的段落的需要。

calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text. ParagraphView

计算沿着短轴的段落的需要。

calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text. TableView

计算短轴的要求。

calculateMinorTickMarks() - Method in class javafx.scene.chart. NumberAxis

计算每个小刻度线的数据值列表

calculateMinorTickMarks() - Method in class javafx.scene.chart. ValueAxis

计算每个小刻度线的数据值列表

calculateNewScale(double, double, double) - Method in class javafx.scene.chart. ValueAxis

计算此轴的新刻度。

calculateSize(boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout

返回计算的大小。

calculateTabAreaHeight(int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

计算标签区域高度。

calculateTabAreaWidth(int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

计算标签区域宽度。

calculateTabHeight(int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

计算标签高度。

calculateTabRects(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout

计算标签矩形。

calculateTabWidth(int, int, FontMetrics) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

计算标签宽度。

calculateTabWidth(int, int, FontMetrics) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

计算标签宽度。

calculateThumbLocation() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算拇指位置。

calculateThumbLocation() - Method in class javax.swing.plaf.synth. SynthSliderUI

计算拇指位置。

calculateThumbSize() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算拇指大小矩形。

calculateTickRect() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算刻度矩形。

calculateTickValues(double, Object) - Method in class javafx.scene.chart. Axis

计算范围内每个刻度线的所有数据值的列表

calculateTickValues(double, Object) - Method in class javafx.scene.chart. CategoryAxis

计算范围内每个刻度线的所有数据值的列表

calculateTickValues(double, Object) - Method in class javafx.scene.chart. NumberAxis

计算范围内每个刻度线的所有数据值的列表

calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - Static method in class javax.swing. SizeRequirements

创建一组偏移/跨度对，这些偏移/跨度对代表端到端布局一组组件。

calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - Static method in class javax.swing. SizeRequirements

创建一组偏移/跨度对，这些偏移/跨度对代表端到端布局一组组件。

calculateTrackBuffer() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算轨道缓冲区。

calculateTrackRect() - Method in class javax.swing.plaf.basic. BasicSliderUI

计算轨道矩形。

calendar - Variable in class java.text. DateFormat

用于计算日期时间字段的Calendar实例和时间。

Calendar - Class in java.util

所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。

Calendar() - Constructor for class java.util. Calendar

构造具有默认时区和默认的 FORMAT区域设置的日历。

Calendar(TimeZone, Locale) - Constructor for class java.util. Calendar

构造具有指定时区和区域设置的日历。

Calendar.Builder - Class in java.util

Calendar.Builder用于从各种日期时间参数创建 Calendar 。

CalendarDataProvider - Class in java.util.spi

服务提供者的抽象类，它提供了与区域相关的Calendar参数。

CalendarDataProvider() - Constructor for class java.util.spi. CalendarDataProvider

唯一的构造函数。

CalendarNameProvider - Class in java.util.spi

提供 Calendar字段值的本地化字符串表示（显示名称）的服务提供者的抽象类。

CalendarNameProvider() - Constructor for class java.util.spi. CalendarNameProvider

唯一的构造函数。

call() - Method in interface java.util.concurrent. Callable

计算一个结果，如果不能这样做，就会抛出一个异常。

call() - Method in class javafx.concurrent. Task

在执行任务时调用，调用方法必须被子类覆盖并实现。

call() - Method in interface javax.tools. DocumentationTool.DocumentationTask

执行此文档任务。

call() - Method in interface javax.tools. JavaCompiler.CompilationTask

执行此编译任务。

call(Object, Object...) - Method in class jdk.nashorn.api.scripting. AbstractJSObject

call(Object, Object...) - Method in interface jdk.nashorn.api.scripting. JSObject

将此对象称为JavaScript函数。

call(Object, Object...) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

call(String, Object...) - Method in class netscape.javascript. JSObject

调用JavaScript方法。

call(TableColumn.CellDataFeatures<Map, T>) - Method in class javafx.scene.control.cell. MapValueFactory

call(TableColumn.CellDataFeatures<S, T>) - Method in class javafx.scene.control.cell. PropertyValueFactory

当需要时调用 call方法，并且给出一个类型为P的单个参数，并要求返回类型为R的对象。

call(TreeTableColumn.CellDataFeatures<S, T>) - Method in class javafx.scene.control.cell. TreeItemPropertyValueFactory

call方法在需要时被调用，并且被赋予类型为P的单个参数，要求返回类型为R的对象。

call(SOAPMessage, Object) - Method in class javax.xml.soap. SOAPConnection

将给定的消息发送到指定的端点并阻塞，直到它返回响应。

call(P) - Method in interface javafx.util. Callback

call方法在需要时被调用，并且被赋予类型为P的单个参数，要求返回类型为R的对象。

CALL - jdk.dynalink. StandardOperation

调用可调用对象。

callable(Runnable) - Static method in class java.util.concurrent. Executors

返回一个Callable对象，当被调用时，它运行给定的任务并返回null 。

callable(Runnable, T) - Static method in class java.util.concurrent. Executors

返回一个Callable对象，当被调用时，它运行给定的任务并返回给定的结果。

callable(PrivilegedAction<?>) - Static method in class java.util.concurrent. Executors

返回一个Callable对象，该对象在被调用时运行给定的特权操作并返回其结果。

callable(PrivilegedExceptionAction<?>) - Static method in class java.util.concurrent. Executors

返回一个Callable对象，该对象在被调用时运行给定的特权异常操作并返回其结果。

Callable< V> - Interface in java.util.concurrent

返回结果并可能引发异常的任务。

CallableStatement - Interface in java.sql

用于执行SQL存储过程的界面。

Callback< P, R> - Interface in javafx.util

回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。

Callback - Interface in javax.security.auth.callback

该接口的实现被传递到 CallbackHandler ，允许底层安全服务与呼叫应用程序交互以检索用户名和密码等特定认证数据或显示某些信息（例如错误和警告消息）的能力。

CallbackHandler - Interface in javax.security.auth.callback

应用程序实现 CallbackHandler并将其传递给基础安全服务，以便它们可以与应用程序交互以检索特定的身份验证数据，例如用户名和密码，或显示某些信息，例如错误和警告消息。

CallbackHandlerProtection(CallbackHandler) - Constructor for class java.security. KeyStore.CallbackHandlerProtection

从CallbackHandler构造一个新的CallbackHandlerProtection。

CallerRunsPolicy() - Constructor for class java.util.concurrent. ThreadPoolExecutor.CallerRunsPolicy

创建一个 CallerRunsPolicy 。

callMember(String, Object...) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

调用成员函数

CallSite - Class in java.lang.invoke

A CallSite是变量MethodHandle的持有人，称为其target 。

CallSiteDescriptor - Class in jdk.dynalink

呼叫站点描述符包含链接呼叫站点所需的所有信息。

CallSiteDescriptor(MethodHandles.Lookup, Operation, MethodType) - Constructor for class jdk.dynalink. CallSiteDescriptor

创建一个新的呼叫站点描述符。

Camera - Class in javafx.scene

用于渲染场景的相机的基类。

Camera() - Constructor for class javafx.scene. Camera

cameraProperty() - Method in class javafx.scene. Scene

指定用于渲染 Scene的相机使用类型。

cameraProperty() - Method in class javafx.scene. SubScene

指定用于渲染 SubScene的相机使用类型。

canAccess(Object) - Method in class java.lang.reflect. AccessibleObject

测试调用者是否可以访问此反射对象。

CANADA - Static variable in class java.util. Locale

对国家有用的常数。

CANADA_FRENCH - Static variable in class java.util. Locale

对国家有用的常数。

canAddMethod() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持在执行类重定义时添加方法。

CANADIAN_ABORIGINAL - java.lang. Character.UnicodeScript

Unicode脚本“Canadian_Aboriginal”。

canBeModified() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否是只读VM。

cancel() - Method in class java.awt.print. PrinterJob

取消正在进行的打印作业。

cancel() - Method in class java.nio.channels. SelectionKey

要求取消该密钥的通道与其选择器的注册。

cancel() - Method in class java.nio.channels.spi. AbstractSelectionKey

取消此键。

cancel() - Method in interface java.nio.file. WatchKey

取消对手表服务的注册。

cancel() - Method in interface java.sql. Statement

如果DBMS和驱动程序都支持中止SQL语句，则取消此 Statement对象。

cancel() - Method in interface java.util.concurrent. Flow.Subscription

使订阅者（最终）停止接收消息。

cancel() - Method in class java.util. Timer

终止此计时器，丢弃任何当前计划的任务。

cancel() - Method in class java.util. TimerTask

取消此计时器任务。

cancel() - Method in class javafx.concurrent. ScheduledService

取消任何当前正在运行的任务并停止此计划的服务，这样就不会发生额外的迭代。

cancel() - Method in class javafx.concurrent. Service

取消任何当前正在运行的任务（如果有）。

cancel() - Method in class javafx.concurrent. Task

cancel() - Method in interface javafx.concurrent. Worker

终止执行这个工人。

cancel() - Method in class javafx.scene.image. Image

取消此图像的后台加载。

cancel() - Method in interface javax.print. CancelablePrintJob

停止打印作业的进一步处理。

cancel(boolean) - Method in class java.util.concurrent. CompletableFuture

如果尚未完成，请使用CancellationException完成此CompletableFuture。

cancel(boolean) - Method in class java.util.concurrent. ForkJoinTask

尝试取消执行此任务。

cancel(boolean) - Method in interface java.util.concurrent. Future

尝试取消执行此任务。

cancel(boolean) - Method in class java.util.concurrent. FutureTask

cancel(boolean) - Method in class javafx.concurrent. Task

cancel(boolean) - Method in class javax.swing. SwingWorker

尝试取消执行此任务。

CANCEL - javafx.scene.input. KeyCode

常数为 Cancel键。

CANCEL - Static variable in class javafx.scene.control. ButtonType

预先定义的ButtonType显示“取消”，并具有ButtonBar.ButtonData ButtonBar.ButtonData.CANCEL_CLOSE 。

CANCEL - Static variable in class javax.security.auth.callback. ConfirmationCallback

CANCEL选项。

CANCEL_CLOSE - javafx.scene.control. ButtonBar.ButtonData

“取消”或“关闭”按钮的标签。

CANCEL_OPTION - Static variable in class javax.swing. JFileChooser

如果选择了取消，则返回值。

CANCEL_OPTION - Static variable in class javax.swing. JOptionPane

如果选择CANCEL，则从类方法返回值。

CANCEL_SELECTION - Static variable in class javax.swing. JFileChooser

取消当前选择的指令。

CancelablePrintJob - Interface in javax.print

此接口由打印应用程序用于取消打印作业。

cancelButtonMnemonic - Variable in class javax.swing.plaf.basic. BasicFileChooserUI

取消按钮助记符

cancelButtonProperty() - Method in class javafx.scene.control. Button

取消按钮是接收键盘VK_ESC的按钮，如果场景中没有其他节点消耗它。

cancelButtonText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI

取消按钮文字

cancelButtonToolTipText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI

取消按钮工具提示文本

cancelCellEditing() - Method in class javax.swing. AbstractCellEditor

致电 fireEditingCanceled 。

cancelCellEditing() - Method in interface javax.swing. CellEditor

告诉编辑器取消编辑，不接受任何部分编辑的值。

cancelCellEditing() - Method in class javax.swing. DefaultCellEditor

将消息从 CellEditor转发到 delegate 。

cancelCellEditing() - Method in class javax.swing. DefaultCellEditor.EditorDelegate

取消编辑。

cancelCellEditing() - Method in class javax.swing.tree. DefaultTreeCellEditor

消息 cancelCellEditing到 realEditor并将其从此实例中删除。

CANCELED - javafx.print. PrinterJob.JobStatus

该作业已被应用程序取消。

CANCELED - Static variable in class javax.print.attribute.standard. JobState

这个工作已被一些人力机构取消，打印机已经完成了取消工作，所有工作状态属性都达到了最终的工作价值。

cancelEdit() - Method in class javafx.scene.control. Cell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ChoiceBoxListCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ChoiceBoxTableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ChoiceBoxTreeCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ComboBoxListCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ComboBoxTableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ComboBoxTreeCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. TextFieldListCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. TextFieldTableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. TextFieldTreeCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control.cell. TextFieldTreeTableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control. ComboBox

如果ComboBox是 editable ，调用此方法将尝试用最后提交的 value替换编辑器文本。

cancelEdit() - Method in class javafx.scene.control. ListCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control. Spinner

如果Spinner是 editable ，调用此方法将尝试用最后提交的 value替换编辑器文本。

cancelEdit() - Method in class javafx.scene.control. TableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control. TextInputControl

如果该字段当前正在被编辑，该调用将把文本设置为最后一个被提交的值。

cancelEdit() - Method in class javafx.scene.control. TreeCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control. TreeTableCell

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEdit() - Method in class javafx.scene.control. TreeTableRow

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

cancelEditing() - Method in class javax.swing. JTree

取消当前编辑会话。

cancelEditing(JTree) - Method in class javax.swing.plaf.basic. BasicTreeUI

取消当前编辑会话。

cancelEditing(JTree) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 cancelEditing方法。

cancelEditing(JTree) - Method in class javax.swing.plaf. TreeUI

取消当前编辑会话。

cancelJob() - Method in class javafx.print. PrinterJob

最早取消底层打印作业。

cancelLatestCommittedText() - Method in interface javafx.scene.input. InputMethodRequests

从文本编辑节点获取最新提交的文本，并将其从节点的文本正文中删除。

cancelLatestCommittedText(AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im. InputMethodRequests

从文本编辑组件获取最新提交的文本，并将其从组件的文本正文中删除。

CancellationException - Exception in java.util.concurrent

异常表示由于任务被取消，无法检索值生成任务的结果，如FutureTask 。

CancellationException() - Constructor for exception java.util.concurrent. CancellationException

构造一个 CancellationException ，没有详细信息。

CancellationException(String) - Constructor for exception java.util.concurrent. CancellationException

构造具有指定详细消息的 CancellationException 。

cancelled() - Method in class javafx.concurrent. Service

对于子类的受保护的便利方法，只要服务状态已经转换到CANCELED状态就调用。

cancelled() - Method in class javafx.concurrent. Task

每当任务的状态已经转换到CANCELED状态时，调用子类的受保护的便利方法。

CANCELLED - javafx.concurrent. Worker.State

表示此工人已通过 Worker.cancel()方法取消。

CancelledKeyException - Exception in java.nio.channels

当试图使用不再有效的选择键时抛出未检查的异常。

CancelledKeyException() - Constructor for exception java.nio.channels. CancelledKeyException

构造这个类的一个实例。

cancelledKeys() - Method in class java.nio.channels.spi. AbstractSelector

检索此选择器的已取消键集。

cancelQuit() - Method in interface java.awt.desktop. QuitResponse

通知外部退出请求者用户已明确取消挂起的退出，并使应用程序运行。

cancelRowUpdates() - Method in interface java.sql. ResultSet

取消对此 ResultSet对象中当前行所做的更新。

cancelSelection() - Method in class javax.swing. JFileChooser

当用户选择“取消”按钮时，由UI调用。

CancelSelectionAction() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.CancelSelectionAction

canConvert(Class<?>, Class<?>) - Method in interface jdk.dynalink.linker. LinkerServices

如果可能存在请求的类型（自动JVM转换或任何可用的GuardingTypeConverterFactory提供的转换）之间的转换，则返回true;如果在请求的类型之间绝对不存在转换，则返回false。

canDecodeInput(Object) - Method in class javax.imageio.spi. ImageReaderSpi

如果提供的源对象看起来是由本读者支持的格式，则返回 true 。

canDisplay(char) - Method in class java.awt. Font

检查此 Font是否具有指定字符的字形。

canDisplay(int) - Method in class java.awt. Font

检查这个 Font是否具有指定字符的字形。

canDisplayUpTo(char[], int, int) - Method in class java.awt. Font

指示此是否 Font可以显示在指定的字符 text在起始 start和在结束 limit 。

canDisplayUpTo(String) - Method in class java.awt. Font

指示 Font是否可以显示指定的 String 。

canDisplayUpTo(CharacterIterator, int, int) - Method in class java.awt. Font

指示 Font是否可以显示由 iter开始并以 start结尾的 limit指定的文本。

canDock(Component, Point) - Method in class javax.swing.plaf.basic. BasicToolBarUI

如果 JToolBar可以 JToolBar在给定的位置，则返回 true 。

canEdit - Variable in class javax.swing.tree. DefaultTreeCellEditor

从Java 2平台v1.4开始，此字段不再被使用。

canEditImmediately(EventObject) - Method in class javax.swing.tree. DefaultTreeCellEditor

如果返回true event为 null ，或者它是一个 MouseEvent与点击计数> 2 inHitRegion返回true。

canEncode() - Method in class java.nio.charset. Charset

告诉这个字符集是否支持编码。

canEncode(char) - Method in class java.nio.charset. CharsetEncoder

告知编码器是否可以对给定的字符进行编码。

canEncode(CharSequence) - Method in class java.nio.charset. CharsetEncoder

告知编码器是否可以对给定的字符序列进行编码。

canEncodeImage(RenderedImage) - Method in class javax.imageio.spi. ImageWriterSpi

返回 true如果 ImageWriter与此服务提供者关联实现能够编码给定的 RenderedImage实例。

canEncodeImage(ImageTypeSpecifier) - Method in class javax.imageio.spi. ImageWriterSpi

如果与此服务提供商相关联的 ImageWriter实现能够对具有给定布局的图像进行编码，则返回 true 。

canExecute() - Method in class java.io. File

测试应用程序是否可以执行此抽象路径名表示的文件。

canFilterIndexColorModel - Variable in class java.awt.image. RGBImageFilter

该布尔值指示是否可以将filterRGB方法的颜色过滤应用于IndexColorModel对象的颜色表条目，以代替逐像素过滤。

canForceEarlyReturn() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持强制早期返回的方法。

canGetBytecodes() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持检索方法的字节码。

canGetClassFileVersion() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持阅读类文件主要和次要版本。

canGetConstantPool() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持获取类的常量池信息。

canGetCurrentContendedMonitor() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持线程正在等待的监视器的检索。

canGetInstanceInfo() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持访问类实例，实例计数和引用对象。

canGetMethodReturnValues() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持在MethodExitEvent中包含返回值。

canGetModuleInfo() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持获取有关模块的信息。

canGetMonitorFrameInfo() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持获取哪个帧已经获取了监视器。

canGetMonitorInfo() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持检索对象的监视器信息。

canGetOwnedMonitorInfo() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持线程拥有的监视器的检索。

canGetSourceDebugExtension() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持获取源调试扩展。

canGetSyntheticAttribute() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持方法或字段的合成属性的查询。

canImport(JComponent, DataFlavor[]) - Method in class javax.swing. TransferHandler

指示组件是否将在实际尝试导入之前接受给定的一组数据风格的导入。

canImport(TransferHandler.TransferSupport) - Method in class javax.swing. TransferHandler

这种方法在拖放操作期间重复调用，以允许开发人员配置属性并返回传输的可接受性; 返回值为true ，表示由给定的TransferSupport （其中包含转移的所有细节）表示的转移在当前时间是可接受的，并且值为false拒绝转移。

canInsertEmpty(int) - Method in class javax.imageio. ImageWriter

如果作者支持在给定索引处插入新的空图像，则返回 true 。

canInsertImage(int) - Method in class javax.imageio. ImageWriter

如果作者支持在给定索引处插入新图像，则返回 true 。

canLinkType(Class<?>) - Method in class jdk.dynalink.linker.support. CompositeTypeBasedGuardingDynamicLinker

如果至少有一个复合链接器为该类型从 TypeBasedGuardingDynamicLinker.canLinkType(Class)返回true， 则返回true。

canLinkType(Class<?>) - Method in interface jdk.dynalink.linker. TypeBasedGuardingDynamicLinker

如果链接器可以链接第一个参数（接收者）是指定类型的调用，则返回true。

canNodeAppear(String, ImageTypeSpecifier) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回 true如果元素（及其下面的子树）被允许出现在由 ImageTypeSpecifier定义的给定类型的图像的元数据文档中。

canNodeAppear(String, ImageTypeSpecifier) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

CannotProceed - Exception in org.omg.CosNaming.NamingContextPackage

org / omg / CosNaming / NamingContextPackage / CannotProceed.java。

CannotProceed() - Constructor for exception org.omg.CosNaming.NamingContextPackage. CannotProceed

CannotProceed(String, NamingContext, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage. CannotProceed

CannotProceed(NamingContext, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage. CannotProceed

CannotProceedException - Exception in javax.naming

抛出此异常以指示操作达到操作无法继续进行的名称中的一个点。

CannotProceedException() - Constructor for exception javax.naming. CannotProceedException

构造一个新的CannotProceedException实例。

CannotProceedException(String) - Constructor for exception javax.naming. CannotProceedException

使用说明构造一个新的CannotProceedException实例。

CannotProceedHelper - Class in org.omg.CosNaming.NamingContextPackage

org / omg / CosNaming / NamingContextPackage / CannotProceedHelper.java。

CannotProceedHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage. CannotProceedHelper

CannotProceedHolder - Class in org.omg.CosNaming.NamingContextPackage

org / omg / CosNaming / NamingContextPackage / CannotProceedHolder.java。

CannotProceedHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage. CannotProceedHolder

CannotProceedHolder(CannotProceed) - Constructor for class org.omg.CosNaming.NamingContextPackage. CannotProceedHolder

CannotRedoException - Exception in javax.swing.undo

抛出一个UndoableEdit被告知 redo()并且不能。

CannotRedoException() - Constructor for exception javax.swing.undo. CannotRedoException

CannotUndoException - Exception in javax.swing.undo

抛出一个UndoableEdit被告知 undo()而不能。

CannotUndoException() - Constructor for exception javax.swing.undo. CannotUndoException

canOffsetTiles - Variable in class javax.imageio. ImageWriteParam

A boolean是 true如果这个 ImageWriteParam允许设置平铺网格偏移参数。

canOffsetTiles() - Method in class javax.imageio. ImageWriteParam

如果作者在写入时可以执行非零网格偏移的平铺，则返回 true 。

CANON_EQ - Static variable in class java.util.regex. Pattern

实现规范等价。

CANONICAL - Static variable in class javax.security.auth.x500. X500Principal

可分辨名称的规范字符串格式。

CANONICAL_DECOMPOSITION - Static variable in class java.text. Collator

分解模式值。

CanonicalizationMethod - Interface in javax.xml.crypto.dsig

在 CanonicalizationMethod中定义的XML CanonicalizationMethod元素的 表示 。

canonicalize(Oid) - Method in interface org.ietf.jgss. GSSName

创建一个为某种机制规范化的名称。

canPathsBeAdded(TreePath[]) - Method in class javax.swing.tree. DefaultTreeSelectionModel

用于测试是否可以添加特定的一组 TreePath 。

canPathsBeRemoved(TreePath[]) - Method in class javax.swing.tree. DefaultTreeSelectionModel

如果可以删除路径而不会破坏模型的连续性，则返回true。

canPopFrames() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持弹出线程堆栈的帧。

canRead() - Method in class java.io. File

测试应用程序是否可以读取由此抽象路径名表示的文件。

canRead() - Method in interface javax.jnlp. FileContents

返回是否可以读取文件。

canRead(Module) - Method in class java.lang. Module

指示此模块是否读取给定的模块。

canReadRaster() - Method in class javax.imageio. ImageReader

如果此插件支持只读取Raster像素数据，则返回true 。

canRedefineClasses() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持任何级别的重新定义。

canRedo() - Method in class javax.swing.undo. AbstractUndoableEdit

返回 true如果此编辑为 alive和 hasBeenDone为 false 。

canRedo() - Method in class javax.swing.undo. CompoundEdit

如果 isInProgress返回false，或者超级返回false。

canRedo() - Method in interface javax.swing.undo. UndoableEdit

如果可以重做此修改，则返回true。

canRedo() - Method in class javax.swing.undo. UndoManager

如果编辑可能会重做，则返回true。

canRemoveImage(int) - Method in class javax.imageio. ImageWriter

如果作者支持在给定索引处删除现有图像，则返回 true 。

canReplaceImageMetadata(int) - Method in class javax.imageio. ImageWriter

返回 true ，如果它是可以替换与现有的图像与索引相关联的图像元数据 imageIndex 。

canReplacePixels(int) - Method in class javax.imageio. ImageWriter

如果作者允许使用 replacePixels方法替换给定图像的像素，则返回 true 。

canReplaceStreamMetadata() - Method in class javax.imageio. ImageWriter

如果可以替换已经存在于输出中的流元数据，则返回 true 。

canRequestMonitorEvents() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持创建MonitorContendedEnterRequest s。

canRequestVMDeathEvent() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持创建VMDeathRequest s。

canSetParameter(String, Object) - Method in interface org.w3c.dom. DOMConfiguration

检查是否将参数设置为特定值。

canSetSourceRenderSize - Variable in class javax.imageio. ImageReadParam

true如果这个 ImageReadParam允许设置源渲染维度。

canSetSourceRenderSize() - Method in class javax.imageio. ImageReadParam

返回 true如果该读取器允许源图像以任意大小作为解码过程的一部分，通过 setSourceRenderSize方法。

CANT_START - com.sun.nio.sctp. AssociationChangeNotification.AssocChangeEvent

协会无法设置。

canUndo() - Method in class javax.swing.undo. AbstractUndoableEdit

如果此编辑是 alive而 hasBeenDone是 true则返回true。

canUndo() - Method in class javax.swing.undo. CompoundEdit

如果 isInProgress返回false，或者超级返回false。

canUndo() - Method in interface javax.swing.undo. UndoableEdit

如果该编辑可能被撤销，则返回true。

canUndo() - Method in class javax.swing.undo. UndoManager

如果编辑可能被撤销，则返回true。

canUndoOrRedo() - Method in class javax.swing.undo. UndoManager

如果可以调用 undo或 redo ，则返回true。

canUnrestrictedlyRedefineClasses() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否在执行类重新定义时支持无限制的更改。

canUse(Class<?>) - Method in class java.lang. Module

指示此模块是否具有对给定服务类型的服务依赖性。

canUseCacheFile() - Method in class javax.imageio.spi. ImageInputStreamSpi

返回 true如果 ImageInputStream与此服务提供者关联实现可选择使用了改进的性能和/或内存占用一个缓存文件。

canUseCacheFile() - Method in class javax.imageio.spi. ImageOutputStreamSpi

返回 true如果 ImageOutputStream与此服务提供者关联实现可选择使用缓存 File ，以提高性能和/或内存占用。

canUseInstanceFilters() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持特定实例对象的过滤事件。

canUseSourceNameFilters() - Method in interface com.sun.jdi. VirtualMachine

确定目标虚拟机是否支持通过源名称过滤类准备事件。

Canvas - Class in java.awt

Canvas组件表示应用程序可以在其上绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。

Canvas - Class in javafx.scene.canvas

Canvas是可以使用GraphicsContext提供的一组图形命令绘制的图像。

Canvas() - Constructor for class java.awt. Canvas

构造一个新的画布。

Canvas() - Constructor for class javafx.scene.canvas. Canvas

创建一个空的Canvas实例。

Canvas(double, double) - Constructor for class javafx.scene.canvas. Canvas

以给定的大小创建一个新的Canvas实例。

Canvas(GraphicsConfiguration) - Constructor for class java.awt. Canvas

给一个GraphicsConfiguration对象构造一个新的Canvas。

CANVAS - Static variable in class javax.accessibility. AccessibleRole

可以被绘制并用于捕获事件的对象。

Canvas.AccessibleAWTCanvas - Class in java.awt

这个类实现 Canvas类的可访问性支持。

canWatchFieldAccess() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持现场访问的观察点。

canWatchFieldModification() - Method in interface com.sun.jdi. VirtualMachine

确定目标VM是否支持现场修改的观察点。

canWrite() - Method in class java.io. File

测试应用程序是否可以修改由此抽象路径名表示的文件。

canWrite() - Method in interface javax.jnlp. FileContents

返回是否可以写入文件。

canWriteCompressed - Variable in class javax.imageio. ImageWriteParam

A boolean是 true如果这个作者可以使用压缩编写图像。

canWriteCompressed() - Method in class javax.imageio. ImageWriteParam

如果此作者支持压缩，则返回 true 。

canWriteEmpty() - Method in class javax.imageio. ImageWriter

如果作者支持写入一个包含未定义像素值的单个图像和相关元数据和缩略图的完整图像流，则返回 true 。

canWriteProgressive - Variable in class javax.imageio. ImageWriteParam

A boolean是 true如果这个 ImageWriteParam允许图像被写入逐渐增加的质量通行序列。

canWriteProgressive() - Method in class javax.imageio. ImageWriteParam

返回 true如果作者可以将图像作为逐渐增加的质量的一系列通行证。

canWriteRasters() - Method in class javax.imageio. ImageWriter

返回 true如果采取方法 IIOImage参数能够与处理的 Raster （相对于 RenderedImage ）源图像。

canWriteSequence() - Method in class javax.imageio. ImageWriter

如果作者能够将图像附加到已经包含标题信息和可能的先前图像的图像流中，则返回 true 。

canWriteTiles - Variable in class javax.imageio. ImageWriteParam

A boolean是 true如果这个 ImageWriteParam允许设置tile width和tile height参数。

canWriteTiles() - Method in class javax.imageio. ImageWriteParam

如果作家在写作时可以执行 true则返回 true 。

CAP_BUTT - Static variable in class java.awt. BasicStroke

结束未封闭的子路径和划线段，没有添加装饰。

CAP_ROUND - Static variable in class java.awt. BasicStroke

用圆形装饰结束未封闭的子路径和划线段，半圆形的半径等于笔宽的一半。

CAP_SQUARE - Static variable in class java.awt. BasicStroke

结束未封闭的子路径和划线段，其中方块投影延伸超出段的末端至等于线宽一半的距离。

capabilities() - Method in class com.sun.jdi.connect.spi. TransportService

返回传输服务的功能。

Capabilities() - Constructor for class com.sun.jdi.connect.spi. TransportService.Capabilities

capacity() - Method in class java.lang. StringBuffer

capacity() - Method in class java.nio. Buffer

返回此缓冲区的容量。

capacity() - Method in class java.util. Vector

返回此向量的当前容量。

capacity() - Method in class javax.swing. DefaultListModel

返回此列表的当前容量。

capacityIncrement - Variable in class java.util. Vector

当矢量的大小大于其容量时，矢量的容量自动增加的量。

capacityIncrement - Static variable in class javax.management.monitor. Monitor

当显示器阵列的容量大于其容量时，显示器阵列的容量会自动增加。

caps - Variable in class java.awt. Component.BltBufferStrategy

缓冲功能

caps - Variable in class java.awt. Component.FlipBufferStrategy

缓冲功能

CAPS - javafx.scene.input. KeyCode

常数为 Caps Lock键。

CAPS_LOCK - Static variable in class java.awt. Event

已过时。

大写锁定键，非ASCII操作键。

CAPTION - Static variable in class javax.swing.text.html. HTML.Tag

标签<caption>

capture(TypeMirror) - Method in interface javax.lang.model.util. Types

将捕获转换应用于类型。

CAPTURING_PHASE - Static variable in interface org.w3c.dom.events. Event

当前的事件阶段是捕获阶段。

Card - Class in javax.smartcardio

与其建立连接的智能卡。

Card() - Constructor for class javax.smartcardio. Card

构造一个新的Card对象。

CARD_ABSENT - javax.smartcardio. CardTerminals.State

卡终端，其中不存在卡。

CARD_INSERTION - javax.smartcardio. CardTerminals.State

在最近一次通话期间检测到卡插入的卡终端，号码为 waitForChange() 。

CARD_PRESENT - javax.smartcardio. CardTerminals.State

卡存在卡的终端。

CARD_REMOVAL - javax.smartcardio. CardTerminals.State

CardTerminals在最近一次通话期间检测到卡片删除被发送到 waitForChange()电话。

CardChannel - Class in javax.smartcardio

与智能卡的逻辑通道连接。

CardChannel() - Constructor for class javax.smartcardio. CardChannel

构造一个新的CardChannel对象。

CardException - Exception in javax.smartcardio

在与智能卡堆栈或卡本身通信期间发生的错误异常。

CardException(String) - Constructor for exception javax.smartcardio. CardException

构造一个带有指定详细信息的新CardException。

CardException(String, Throwable) - Constructor for exception javax.smartcardio. CardException

构造一个具有指定的详细信息和原因的新CardException。

CardException(Throwable) - Constructor for exception javax.smartcardio. CardException

构造一个新的CardException具有指定的原因和详细信息 (cause==null ?

cardinality() - Method in class java.util. BitSet

返回此 BitSet设置为 true的 BitSet 。

CardLayout - Class in java.awt

A CardLayout对象是容器的布局管理器。

CardLayout() - Constructor for class java.awt. CardLayout

创建一个新的卡片布局，其大小为零。

CardLayout(int, int) - Constructor for class java.awt. CardLayout

创建具有指定的水平和垂直间隙的新卡布局。

CardNotPresentException - Exception in javax.smartcardio

当应用程序尝试与没有存在卡的终端建立连接时抛出异常。

CardNotPresentException(String) - Constructor for exception javax.smartcardio. CardNotPresentException

构造一个新的具有指定详细消息的CardNotPresentException。

CardNotPresentException(String, Throwable) - Constructor for exception javax.smartcardio. CardNotPresentException

构造一个新的具有指定的详细信息和原因的CardNotPresentException。

CardNotPresentException(Throwable) - Constructor for exception javax.smartcardio. CardNotPresentException

构造一个新的CardNotPresentException具有指定的原因和详细信息为 (cause==null ?

CardPermission - Class in javax.smartcardio

智能卡操作的许可。

CardPermission(String, String) - Constructor for class javax.smartcardio. CardPermission

构造一个具有指定操作的新CardPermission。

CardTerminal - Class in javax.smartcardio

智能卡终端，有时称为智能卡读卡器。

CardTerminal() - Constructor for class javax.smartcardio. CardTerminal

构造一个新的CardTerminal对象。

CardTerminals - Class in javax.smartcardio

TerminalFactory支持的一组终端。

CardTerminals() - Constructor for class javax.smartcardio. CardTerminals

构造一个新的CardTerminals对象。

CardTerminals.State - Enum in javax.smartcardio

枚举CardTerminal的属性。

Caret - Interface in javax.swing.text

文档视图中的一个位置，表示可以将东西插入到文档模型中。

CARET - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing Text Caret支持（即CaretListener和CaretEvent）

CARET_OFFSET - javafx.scene. AccessibleAttribute

返回节点的插入偏移。

CARET_POSITION_CHANGED - Static variable in class java.awt.event. InputMethodEvent

指示输入法文本中更改的插入点的事件类型。

caretBiasProperty() - Method in class javafx.scene.text. Text

CaretEvent - Class in javax.swing.event

CaretEvent用于通知有关方面事件源文本插入符已更改。

CaretEvent(Object) - Constructor for class javax.swing.event. CaretEvent

创建一个新的CaretEvent对象。

CaretListener - Interface in javax.swing.event

侦听器，用于更改文本组件的插入位置。

CaretPolicy() - Constructor for class java.awt.font. TextLayout.CaretPolicy

构造一个 CaretPolicy 。

caretPositionChanged(InputMethodEvent) - Method in class java.awt. AWTEventMulticaster

通过在listener-a和listener-b上调用caretPositionChanged方法处理caretPositionChanged事件。

caretPositionChanged(InputMethodEvent) - Method in interface java.awt.event. InputMethodListener

当合成文本内的插入符已更改时调用。

caretPositionProperty() - Method in class javafx.scene.control. TextInputControl

文本中插入符号的当前位置。

caretPositionProperty() - Method in class javafx.scene.text. Text

caretShape(int, boolean) - Method in class javafx.scene.text. Text

在给定的索引和偏倚上返回插入符号的形状。

caretShape(int, boolean) - Method in class javafx.scene.text. TextFlow

以局部坐标返回插入符号的形状。

caretShapeProperty() - Method in class javafx.scene.text. Text

caretUpdate(CaretEvent) - Method in interface javax.swing.event. CaretListener

当插入位置更新时调用。

caretUpdate(CaretEvent) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

处理插入符更新（触发适当的属性更改事件，它们是AccessibleContext.ACCESSIBLE_CARET_PROPERTY和AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY）。

CARIAN - java.lang. Character.UnicodeScript

Unicode脚本“Carian”。

CARIAN - Static variable in class java.lang. Character.UnicodeBlock

“Carian”Unicode字符块的常量。

CASE - com.sun.source.tree. Tree.Kind

用于CaseTree的实例。

CASE - jdk.nashorn.api.tree. Tree.Kind

用于CaseTree的实例。

CASE_INSENSITIVE - Static variable in class java.util.regex. Pattern

启用不区分大小写的匹配。

CASE_INSENSITIVE_ORDER - Static variable in class java.lang. String

一个比较器，可以按 compareToIgnoreCase命令 String对象。

CaseTree - Interface in com.sun.source.tree

树节点为 case的 switch声明。

CaseTree - Interface in jdk.nashorn.api.tree

“switch”语句中的“case”的树节点。

cast(Object) - Method in class java.lang. Class

将对象转换为由此 Class对象表示的类或接口。

catalog(CatalogFeatures, URI...) - Static method in class javax.xml.catalog. CatalogManager

使用指定的功能设置和uri创建一个 Catalog对象到一个或多个目录文件。

Catalog - Interface in javax.xml.catalog

目录类代表由 XML Catalogs, OASIS Standard V1.1, 7 October 2005定义的实体目录。

CatalogException - Exception in javax.xml.catalog

异常类处理在处理或使用目录时可能发生的错误。

CatalogException(String) - Constructor for exception javax.xml.catalog. CatalogException

使用指定的详细消息构造新的CatalogException。

CatalogException(String, Throwable) - Constructor for exception javax.xml.catalog. CatalogException

构造一个具有指定的详细信息和原因的新的CatalogException。

CatalogFeatures - Class in javax.xml.catalog

CatalogFeatures拥有功能和属性的集合。

CatalogFeatures.Builder - Class in javax.xml.catalog

用于构建CatalogFeatures对象的Builder类。

CatalogFeatures.Feature - Enum in javax.xml.catalog

Catalog Features table中定义的要素类型。

CatalogManager - Class in javax.xml.catalog

目录管理器管理XML目录和目录解析器的创建。

catalogResolver(Catalog) - Static method in class javax.xml.catalog. CatalogManager

使用指定的目录创建一个 CatalogResolver的实例。

catalogResolver(CatalogFeatures, URI...) - Static method in class javax.xml.catalog. CatalogManager

使用指定的功能设置和uri（s）创建一个 CatalogResolver的实例到一个或多个目录文件。

CatalogResolver - Interface in javax.xml.catalog

实现SAX EntityResolver ，Schema Validation使用的StAX XMLResolver ，DOM LS LSResourceResolver以及转换URIResolver的Catalog Resolver ，并使用目录解析外部引用。

catalogs() - Method in interface javax.xml.catalog. Catalog

返回使用指定的替代目录顺序流nextCatalog在当前目录条目，作为不包括当前目录的目录文件的输入（即，在输入列表中的第一个），当由所述创建的目录对象CatalogManager 。

CATCH - com.sun.source.tree. Tree.Kind

用于CatchTree的实例。

CATCH - jdk.nashorn.api.tree. Tree.Kind

用于CatchTree的实例。

catchException(MethodHandle, Class<? extends Throwable>, MethodHandle) - Static method in class java.lang.invoke. MethodHandles

通过在异常处理程序中运行它来创建适应目标方法句柄的方法句柄。

catchExceptions - Variable in class java.awt.event. InvocationEvent

如果dispatch（）捕获Throwable并将其存储在异常实例变量中，则设置为true。

catchLocation() - Method in interface com.sun.jdi.event. ExceptionEvent

获取异常被捕获的位置。

CatchTree - Interface in com.sun.source.tree

在 try语句中的一个 catch块的树节点。

CatchTree - Interface in jdk.nashorn.api.tree

“try”语句中的“catch”块的树结点。

CategoryAxis - Class in javafx.scene.chart

一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。

CategoryAxis() - Constructor for class javafx.scene.chart. CategoryAxis

创建一个具有空列表类别的自动范围类别轴。

CategoryAxis(ObservableList<String>) - Constructor for class javafx.scene.chart. CategoryAxis

创建具有给定类别的类别轴。

categoryGapProperty() - Method in class javafx.scene.chart. BarChart

在不同类别的酒吧之间留下的差距

categoryGapProperty() - Method in class javafx.scene.chart. StackedBarChart

在不同类别的酒吧之间留下的差距

categorySpacingProperty() - Method in class javafx.scene.chart. CategoryAxis

这是沿着这个轴线的一个类别和下一个类别之间的差距

CAUCASIAN_ALBANIAN - java.lang. Character.UnicodeScript

Unicode脚本“白种人阿尔巴尼亚人”。

CAUCASIAN_ALBANIAN - Static variable in class java.lang. Character.UnicodeBlock

“阿尔巴尼亚白人”Unicode字符块的常数。

causeExceptionClass() - Method in exception jdk.jshell.spi. ExecutionControl.UserException

返回用户异常的类。

causeSnippet() - Method in class jdk.jshell. SnippetEvent

或者是其更改导致此更新的代码段，或 null 。

cbrt(double) - Static method in class java.lang. Math

返回 double值的多维数据集根。

cbrt(double) - Static method in class java.lang. StrictMath

返回 double值的多维数据集根。

CDATA - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于CDATA

CDATA - Static variable in interface javax.xml.stream. XMLStreamConstants

表示事件是CDATA部分

CDATA_SECTION_ELEMENTS - Static variable in class javax.xml.transform. OutputKeys

cdata-section-elements = 扩展名 。

CDATA_SECTION_NODE - Static variable in interface org.w3c.dom. Node

该节点是一个 CDATASection 。

CDATASection - Interface in org.w3c.dom

CDATA部分用于转义包含否则将被视为标记的字符的文本块。

CE - java.time.chrono. IsoEra

当前时代的单身实例“当前时代”，其数值为1。

ceil(double) - Static method in class java.lang. Math

返回大于或等于参数的最小（最接近负无穷大）的 double值，并且等于数学整数。

ceil(double) - Static method in class java.lang. StrictMath

返回大于或等于参数的最小（最接近负无穷大）的 double值，并且等于一个数学整数。

ceiling(E) - Method in class java.util.concurrent. ConcurrentSkipListSet

ceiling(E) - Method in interface java.util. NavigableSet

返回此集合中最小元素大于或等于给定元素，如果没有此元素，则 null 。

ceiling(E) - Method in class java.util. TreeSet

CEILING - java.math. RoundingMode

圆形模式向正无穷大转弯。

ceilingEntry(K) - Method in class java.util.concurrent. ConcurrentSkipListMap

返回与大于或等于给定键的最小键相关联的键值映射，如果没有 null则 null 。

ceilingEntry(K) - Method in interface java.util. NavigableMap

返回与大于或等于给定键的最小键相关联的键值映射，如果没有此键，则 null 。

ceilingEntry(K) - Method in class java.util. TreeMap

ceilingKey(K) - Method in class java.util.concurrent. ConcurrentSkipListMap

ceilingKey(K) - Method in interface java.util. NavigableMap

返回大于或等于给定键的 null键，如果没有此键，则 null 。

ceilingKey(K) - Method in class java.util. TreeMap

Cell< T> - Class in javafx.scene.control

细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。

Cell() - Constructor for class javafx.scene.control. Cell

创建默认样式类为“单元格”的默认单元格。

CELL_AT_ROW_COLUMN - javafx.scene. AccessibleAttribute

返回给定行和列索引处的单元格。

CELL_EDITOR_PROPERTY - Static variable in class javax.swing. JTree

绑定属性名称为 cellEditor 。

CELL_RENDERER_PROPERTY - Static variable in class javax.swing. JTree

绑定属性名称为 cellRenderer 。

CELL_RENDERER_PROPERTY - Static variable in class javax.swing.table. TableColumn

作为Java 2平台v1.3的过时。

cellCountProperty() - Method in class javafx.scene.control.skin. VirtualFlow

表示流中应该有的单元格数。

CellDataFeatures(TableView<S>, TableColumn<S, T>, S) - Constructor for class javafx.scene.control. TableColumn.CellDataFeatures

实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。

CellDataFeatures(TreeTableView<S>, TreeTableColumn<S, T>, TreeItem<S>) - Constructor for class javafx.scene.control. TreeTableColumn.CellDataFeatures

实例化具有设置为此实例的只读值的给定属性的CellDataFeatures实例。

CellEditEvent(TableView<S>, TablePosition<S, T>, EventType<TableColumn.CellEditEvent<S, T>>, T) - Constructor for class javafx.scene.control. TableColumn.CellEditEvent

创建一个可以随后向相关听众触发的新事件。

CellEditEvent(TreeTableView<S>, TreeTablePosition<S, T>, EventType<TreeTableColumn.CellEditEvent<S, T>>, T) - Constructor for class javafx.scene.control. TreeTableColumn.CellEditEvent

创建一个可以随后向相关听众触发的新事件。

cellEditor - Variable in class javax.swing. JTable

活动单元编辑器对象覆盖当前单元占用的屏幕空间，并允许用户改变其内容。

cellEditor - Variable in class javax.swing. JTree

编辑条目。

cellEditor - Variable in class javax.swing.plaf.basic. BasicTreeUI

树的编辑。

cellEditor - Variable in class javax.swing.table. TableColumn

编辑器用于编辑列的数据单元格。

CellEditor - Interface in javax.swing

该界面定义了一般编辑器应该能够实现的方法。

CELLEDITOR - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing CellEditor支持（即CellEditorListener和CellEditorEvent）

CellEditorHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.CellEditorHandler

CellEditorListener - Interface in javax.swing.event

CellEditorListener定义了一个监听CellEditor中更改的对象的接口

cellFactoryProperty() - Method in class javafx.scene.control. ComboBox

提供自定义单元格工厂可以完全自定义ComboBox中项目的呈现。

cellFactoryProperty() - Method in class javafx.scene.control. ListView

设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。

cellFactoryProperty() - Method in class javafx.scene.control.skin. VirtualFlow

设置自定义单元格工厂具有推迟所有单元格创建的效果，允许对单元格进行全面定制。

cellFactoryProperty() - Method in class javafx.scene.control. TableColumn

该列中所有单元格的单元格工厂。

cellFactoryProperty() - Method in class javafx.scene.control. TreeTableColumn

该列中所有单元格的单元格工厂。

cellFactoryProperty() - Method in class javafx.scene.control. TreeView

表示将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。

cellHeight - Variable in class javax.swing.plaf.basic. BasicListUI

细胞的高度

cellHeights - Variable in class javax.swing.plaf.basic. BasicListUI

单元格的高度

CELLPADDING - Static variable in class javax.swing.text.html. HTML.Attribute

属性“cellpadding”

cellRenderer - Variable in class javax.swing. JTree

用于绘制节点的单元格。

cellRenderer - Variable in class javax.swing.table. TableColumn

渲染器用于绘制列的数据单元格。

cellRendererChanged - Static variable in class javax.swing.plaf.basic. BasicListUI

该位涉及到单元格渲染器更改的属性。

CellRendererPane - Class in javax.swing

此类插入到单元格渲染器和使用它们的组件之间。

CellRendererPane() - Constructor for class javax.swing. CellRendererPane

构造一个CellRendererPane对象。

CellRendererPane.AccessibleCellRendererPane - Class in javax.swing

该类实现对 CellRendererPane类的可访问性支持。

cellSelectionEnabled - Variable in class javax.swing. JTable

作为Java 2平台v1.3的过时。

cellSelectionEnabledProperty() - Method in class javafx.scene.control. TableSelectionModel

一个布尔属性，用于表示表是行还是单元格选择模式。

cellSizeProperty() - Method in class javafx.scene.control.skin. CellSkinBase

默认单元格大小。

CellSkinBase< C extends Cell> - Class in javafx.scene.control.skin

默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。

CellSkinBase(C) - Constructor for class javafx.scene.control.skin. CellSkinBase

创建一个新的CellSkinBase实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

CELLSPACING - Static variable in class javax.swing.text.html. HTML.Attribute

属性“cellspacing”

cellValueFactoryProperty() - Method in class javafx.scene.control. TableColumn

单元格值工厂需要设置为指定如何填充单个TableColumn中的所有单元格。

cellValueFactoryProperty() - Method in class javafx.scene.control. TreeTableColumn

单元格值工厂需要设置为指定如何填充单个TreeTableColumn中的所有单元格。

cellWidth - Variable in class javax.swing.plaf.basic. BasicListUI

电池的宽度。

CENTER - javafx.geometry. HPos

表示居中的水平位置。

CENTER - javafx.geometry. Pos

在垂直和水平方向上表示中心的定位。

CENTER - javafx.geometry. VPos

表示居中垂直位置。

CENTER - javafx.scene.control. ContentDisplay

内容将被放置在标签的中心。

CENTER - javafx.scene.text. TextAlignment

表示居中的文本对齐方式（左侧和右侧）。

CENTER - javax.swing. GroupLayout.Alignment

表示元素应该在该区域居中。

CENTER - Static variable in class java.awt. BorderLayout

中心布局约束（容器中间）。

CENTER - Static variable in class java.awt. FlowLayout

该值表示每行的组件应该居中。

CENTER - Static variable in class java.awt. GridBagConstraints

将组件放在其显示区域的中央。

CENTER - Static variable in class java.awt. Label

表示标签应该居中。

CENTER - Static variable in class javafx.scene.layout. BackgroundPosition

一个将背景图像中心的BackgroundPosition。

CENTER - Static variable in class javax.swing.border. TitledBorder

将标题文本置于边界线的中心。

CENTER - Static variable in interface javax.swing. SwingConstants

在一个地区的中心位置。

CENTER - Static variable in class javax.swing.text.html. HTML.Tag

标签<center>

CENTER_ALIGNMENT - Static variable in class java.awt. Component

易于使用的常数为 getAlignmentY和 getAlignmentX 。

CENTER_BASELINE - Static variable in class java.awt. Font

中文，日文，韩文等表意文字的基线。

CENTER_BASELINE - Static variable in class java.awt.font. GraphicAttribute

将图形的起点与线的中心基线对齐。

CENTER_ELLIPSIS - javafx.scene.control. OverrunStyle

修剪正在显示的字符串的中心，并用“...”替换中间的三个字符。

CENTER_LEFT - javafx.geometry. Pos

表示垂直方向和左侧水平位置。

CENTER_OFFSET - java.awt. Component.BaselineResizeBehavior

表示基线保持与组件中心的固定距离。

CENTER_RIGHT - javafx.geometry. Pos

垂直方向和水平位置在中心位置。

CENTER_WORD_ELLIPSIS - javafx.scene.control. OverrunStyle

与CENTER_ELLIPSIS相同，但确保“...”发生在完整的单词之间。

CENTERED - javafx.scene.shape. StrokeType

行程由加厚的边界施加Shape通过的一半的距离节点strokeWidth在边界的任一侧上。

centerFrequencyProperty() - Method in class javafx.scene.media. EqualizerBand

乐队的中心频率为赫兹。

centerOnScreen() - Method in class javafx.stage. Window

在此窗口中设置x和y属性，以便它在curent屏幕上居中。

centerProperty() - Method in class javafx.scene.layout. BorderPane

节点放置在此边框窗格的中心。

centersChildren - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

如果是真的，孩子们会在父母身上聚集在一起。

centerShapeProperty() - Method in class javafx.scene.layout. Region

定义形状是否位于区域的宽度或高度内。

centerXProperty() - Method in class javafx.scene.shape. Arc

定义圆弧中心点的X坐标。

centerXProperty() - Method in class javafx.scene.shape. Circle

以像素为单位定义圆心的水平位置。

centerXProperty() - Method in class javafx.scene.shape. Ellipse

定义椭圆中心的水平位置（以像素为单位）。

centerYProperty() - Method in class javafx.scene.shape. Arc

定义圆弧中心点的Y坐标。

centerYProperty() - Method in class javafx.scene.shape. Circle

定义圆心的垂直位置，以像素为单位。

centerYProperty() - Method in class javafx.scene.shape. Ellipse

定义椭圆中心的垂直位置（以像素为单位）。

CENTURIES - java.time.temporal. ChronoUnit

代表一个世纪概念的单位。

Certificate - Class in java.security.cert

用于管理各种身份证件的抽象类。

Certificate - Class in javax.security.cert

已过时。
使用java.security.cert的类。

Certificate - Interface in java.security

已过时。
Java平台中创建了一个新的证书处理包。 此证书界面已完全弃用，并在此允许平滑过渡到新软件包。

Certificate() - Constructor for class javax.security.cert. Certificate

已过时。

Certificate(String) - Constructor for class java.security.cert. Certificate

创建指定类型的证书。

CERTIFICATE_HOLD - java.security.cert. CRLReason

这个原因表明证书已被搁置。

Certificate.CertificateRep - Class in java.security.cert

用于序列化的替代证书类。

CertificateEncodingException - Exception in java.security.cert

证书编码异常。

CertificateEncodingException - Exception in javax.security.cert

已过时。
使用java.security.cert的类。

CertificateEncodingException() - Constructor for exception java.security.cert. CertificateEncodingException

构造一个没有详细消息的CertificateEncodingException。

CertificateEncodingException() - Constructor for exception javax.security.cert. CertificateEncodingException

已过时。

构造一个没有详细消息的CertificateEncodingException。

CertificateEncodingException(String) - Constructor for exception java.security.cert. CertificateEncodingException

构造具有指定详细消息的CertificateEncodingException。

CertificateEncodingException(String) - Constructor for exception javax.security.cert. CertificateEncodingException

已过时。

构造具有指定详细消息的CertificateEncodingException。

CertificateEncodingException(String, Throwable) - Constructor for exception java.security.cert. CertificateEncodingException

创建一个具有指定的详细信息和原因的 CertificateEncodingException 。

CertificateEncodingException(Throwable) - Constructor for exception java.security.cert. CertificateEncodingException

创建 CertificateEncodingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

CertificateException - Exception in java.security.cert

此异常表示各种证书问题之一。

CertificateException - Exception in javax.security.cert

已过时。
使用java.security.cert的类。

CertificateException() - Constructor for exception java.security.cert. CertificateException

构造一个没有详细消息的证书异常。

CertificateException() - Constructor for exception javax.security.cert. CertificateException

已过时。

构造一个没有详细消息的证书异常。

CertificateException(String) - Constructor for exception java.security.cert. CertificateException

使用给定的详细消息构造证书异常。

CertificateException(String) - Constructor for exception javax.security.cert. CertificateException

已过时。

使用给定的详细消息构造证书异常。

CertificateException(String, Throwable) - Constructor for exception java.security.cert. CertificateException

创建一个具有指定的详细消息和原因的 CertificateException 。

CertificateException(Throwable) - Constructor for exception java.security.cert. CertificateException

创建 CertificateException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

CertificateExpiredException - Exception in java.security.cert

证书过期例外

CertificateExpiredException - Exception in javax.security.cert

已过时。
使用java.security.cert的类。

CertificateExpiredException() - Constructor for exception java.security.cert. CertificateExpiredException

构造一个没有详细消息的CertificateExpiredException。

CertificateExpiredException() - Constructor for exception javax.security.cert. CertificateExpiredException

已过时。

构造一个没有详细消息的CertificateExpiredException。

CertificateExpiredException(String) - Constructor for exception java.security.cert. CertificateExpiredException

构造具有指定详细消息的CertificateExpiredException。

CertificateExpiredException(String) - Constructor for exception javax.security.cert. CertificateExpiredException

已过时。

构造具有指定详细消息的CertificateExpiredException。

CertificateFactory - Class in java.security.cert

该类定义了证书工厂的功能，用于从其编码生成证书，认证路径（ CertPath ）和证书吊销列表（CRL）对象。

CertificateFactory(CertificateFactorySpi, Provider, String) - Constructor for class java.security.cert. CertificateFactory

创建给定类型的CertificateFactory对象，并将给定的提供者实现（SPI对象）封装在其中。

CertificateFactorySpi - Class in java.security.cert

该类定义了 CertificateFactory类的 （ SPI ）。

CertificateFactorySpi() - Constructor for class java.security.cert. CertificateFactorySpi

CertificateNotYetValidException - Exception in java.security.cert

证书还没有有效的例外。

CertificateNotYetValidException - Exception in javax.security.cert

已过时。
使用java.security.cert的类。

CertificateNotYetValidException() - Constructor for exception java.security.cert. CertificateNotYetValidException

构造一个没有详细消息的CertificateNotYetValidException。

CertificateNotYetValidException() - Constructor for exception javax.security.cert. CertificateNotYetValidException

已过时。

构造一个没有详细消息的CertificateNotYetValidException。

CertificateNotYetValidException(String) - Constructor for exception java.security.cert. CertificateNotYetValidException

构造具有指定详细消息的CertificateNotYetValidException。

CertificateNotYetValidException(String) - Constructor for exception javax.security.cert. CertificateNotYetValidException

已过时。

构造具有指定详细消息的CertificateNotYetValidException。

CertificateParsingException - Exception in java.security.cert

证书解析异常。

CertificateParsingException - Exception in javax.security.cert

已过时。
使用java.security.cert的类。

CertificateParsingException() - Constructor for exception java.security.cert. CertificateParsingException

构造一个没有详细消息的CertificateParsingException。

CertificateParsingException() - Constructor for exception javax.security.cert. CertificateParsingException

已过时。

构造一个没有详细消息的CertificateParsingException。

CertificateParsingException(String) - Constructor for exception java.security.cert. CertificateParsingException

构造具有指定详细消息的CertificateParsingException。

CertificateParsingException(String) - Constructor for exception javax.security.cert. CertificateParsingException

已过时。

构造具有指定详细消息的CertificateParsingException。

CertificateParsingException(String, Throwable) - Constructor for exception java.security.cert. CertificateParsingException

创建一个 CertificateParsingException与指定的详细信息和原因。

CertificateParsingException(Throwable) - Constructor for exception java.security.cert. CertificateParsingException

创建 CertificateParsingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

CertificateRep(String, byte[]) - Constructor for class java.security.cert. Certificate.CertificateRep

使用证书类型和证书编码字节构造备用证书类。

CertificateRevokedException - Exception in java.security.cert

表示X.509证书的异常被撤销。

CertificateRevokedException(Date, CRLReason, X500Principal, Map<String, Extension>) - Constructor for exception java.security.cert. CertificateRevokedException

构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。

certificates() - Method in class java.security. Identity

已过时。

返回此身份的所有证书的副本。

CertPath - Class in java.security.cert

证书的不可变序列（认证路径）。

CertPath(String) - Constructor for class java.security.cert. CertPath

创建一个指定类型的 CertPath 。

CertPath.CertPathRep - Class in java.security.cert

候补 CertPath类用于序列化。

CertPathBuilder - Class in java.security.cert

建立认证路径（也称为证书链）的课程。

CertPathBuilder(CertPathBuilderSpi, Provider, String) - Constructor for class java.security.cert. CertPathBuilder

创建给定算法的 CertPathBuilder对象，并将给定的提供者实现（SPI对象）封装在其中。

CertPathBuilderException - Exception in java.security.cert

一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。

CertPathBuilderException() - Constructor for exception java.security.cert. CertPathBuilderException

创建一个 CertPathBuilderException与 null作为其详细信息。

CertPathBuilderException(String) - Constructor for exception java.security.cert. CertPathBuilderException

使用给定的详细信息创建一个 CertPathBuilderException 。

CertPathBuilderException(String, Throwable) - Constructor for exception java.security.cert. CertPathBuilderException

创建一个 CertPathBuilderException与指定的详细信息和原因。

CertPathBuilderException(Throwable) - Constructor for exception java.security.cert. CertPathBuilderException

创建一个 CertPathBuilderException包裹指定的throwable。

CertPathBuilderResult - Interface in java.security.cert

认证路径构建器算法的结果的规范。

CertPathBuilderSpi - Class in java.security.cert

CertPathBuilder类的 （ SPI ）。

CertPathBuilderSpi() - Constructor for class java.security.cert. CertPathBuilderSpi

默认构造函数。

CertPathChecker - Interface in java.security.cert

对每个的一个或多个检查 Certificate一个的 CertPath 。

CertPathParameters - Interface in java.security.cert

认证路径算法参数的规范。

CertPathRep(String, byte[]) - Constructor for class java.security.cert. CertPath.CertPathRep

创建具有指定类型和认证路径的编码形式的 CertPathRep 。

CertPathTrustManagerParameters - Class in javax.net.ssl

CertPathParameters的包装器。

CertPathTrustManagerParameters(CertPathParameters) - Constructor for class javax.net.ssl. CertPathTrustManagerParameters

从指定的参数构造新的CertPathTrustManagerParameters。

CertPathValidator - Class in java.security.cert

用于验证认证路径（也称为证书链）的类。

CertPathValidator(CertPathValidatorSpi, Provider, String) - Constructor for class java.security.cert. CertPathValidator

创建给定算法的 CertPathValidator对象，并将给定的提供者实现（SPI对象）封装在其中。

CertPathValidatorException - Exception in java.security.cert

表示验证认证路径时遇到的各种问题之一的异常。

CertPathValidatorException() - Constructor for exception java.security.cert. CertPathValidatorException

创建一个 CertPathValidatorException没有详细信息。

CertPathValidatorException(String) - Constructor for exception java.security.cert. CertPathValidatorException

使用给定的详细信息创建一个 CertPathValidatorException 。

CertPathValidatorException(String, Throwable) - Constructor for exception java.security.cert. CertPathValidatorException

创建一个 CertPathValidatorException与指定的详细信息和原因。

CertPathValidatorException(String, Throwable, CertPath, int) - Constructor for exception java.security.cert. CertPathValidatorException

创建具有指定的详细消息，原因，认证路径和索引的 CertPathValidatorException 。

CertPathValidatorException(String, Throwable, CertPath, int, CertPathValidatorException.Reason) - Constructor for exception java.security.cert. CertPathValidatorException

创建一个具有指定的详细消息，原因，认证路径，索引和原因的 CertPathValidatorException 。

CertPathValidatorException(Throwable) - Constructor for exception java.security.cert. CertPathValidatorException

创建一个 CertPathValidatorException ，它包装指定的throwable。

CertPathValidatorException.BasicReason - Enum in java.security.cert

BasicReason列举了任何类型的认证路径可能无效的潜在原因。

CertPathValidatorException.Reason - Interface in java.security.cert

验证算法失败的原因。

CertPathValidatorResult - Interface in java.security.cert

认证路径验证器算法的结果的规范。

CertPathValidatorSpi - Class in java.security.cert

CertPathValidator类的 （ SPI ）。

CertPathValidatorSpi() - Constructor for class java.security.cert. CertPathValidatorSpi

默认构造函数。

CertSelector - Interface in java.security.cert

一个选择器，定义了一组选择 Certificate的标准。

CertStore - Class in java.security.cert

从存储库检索 Certificate s和 CRL s的类。

CertStore(CertStoreSpi, Provider, String, CertStoreParameters) - Constructor for class java.security.cert. CertStore

创建给定类型的 CertStore对象，并将给定的提供者实现（SPI对象）封装在其中。

CertStoreException - Exception in java.security.cert

一个例外，指出从 CertStore检索证书和CRL的各种问题。

CertStoreException() - Constructor for exception java.security.cert. CertStoreException

创建一个 CertStoreException与 null作为其详细信息。

CertStoreException(String) - Constructor for exception java.security.cert. CertStoreException

创建一个 CertStoreException与给定的详细消息。

CertStoreException(String, Throwable) - Constructor for exception java.security.cert. CertStoreException

创建一个具有指定的详细信息和原因的 CertStoreException 。

CertStoreException(Throwable) - Constructor for exception java.security.cert. CertStoreException

创建一个 CertStoreException ，它包装指定的throwable。

CertStoreParameters - Interface in java.security.cert

规格为 CertStore参数。

CertStoreSpi - Class in java.security.cert

（ SPI ）为CertStore类。

CertStoreSpi(CertStoreParameters) - Constructor for class java.security.cert. CertStoreSpi

唯一的建设者。

CESSATION_OF_OPERATION - java.security.cert. CRLReason

这个原因表明证书不再需要了。

Chain(List<Filter>, HttpHandler) - Constructor for class com.sun.net.httpserver. Filter.Chain

ChainedCallSite - Class in jdk.dynalink.support

实现多态内联缓存策略的可重新链接的调用站点。

ChainedCallSite(CallSiteDescriptor) - Constructor for class jdk.dynalink.support. ChainedCallSite

创建一个新的链接呼叫站点。

CHAKMA - java.lang. Character.UnicodeScript

Unicode脚本“Chakma”。

CHAKMA - Static variable in class java.lang. Character.UnicodeBlock

“Chakma”Unicode字符块的常量。

CHAM - java.awt.font. NumericShaper.Range

Cham系列与Cham数字。

CHAM - java.lang. Character.UnicodeScript

Unicode脚本“Cham”。

CHAM - Static variable in class java.lang. Character.UnicodeBlock

“Cham”Unicode字符块的常量。

change(int, int, AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer

更改内容

Change(ObservableList<E>) - Constructor for class javafx.collections. ListChangeListener.Change

构造一个新的列表更改。

Change(ObservableMap<K, V>) - Constructor for class javafx.collections. MapChangeListener.Change

构造与地图关联的更改。

Change(ObservableSet<E>) - Constructor for class javafx.collections. SetChangeListener.Change

构造与集相关联的更改。

CHANGE - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing Change支持（即ChangeListener和ChangeEvent）

CHANGE - Static variable in class javax.swing.event. DocumentEvent.EventType

更改类型。

CHANGE_EVENT_HANDLER_SUFFIX - Static variable in class javafx.fxml. FXMLLoader

财产更改/无效处理程序的后缀。

changed(ObservableValue<? extends T>, T, T) - Method in interface javafx.beans.value. ChangeListener

该方法需要通过 ChangeListener的实现来提供。

changed(ObservableValue<? extends T>, T, T) - Method in class javafx.beans.value. WeakChangeListener

该方法需要通过 ChangeListener的实现来提供。

CHANGED - Static variable in class java.awt.dnd. DragSourceContext

一个 int由updateCurrentCursor（使用）的指示用户操作已经改变。

ChangedCharSetException - Exception in javax.swing.text

ChangedCharSetException作为名称指示是在更改字符集时抛出的异常。

ChangedCharSetException(String, boolean) - Constructor for exception javax.swing.text. ChangedCharSetException

构造一个 ChangedCharSetException 。

changedUpdate(DocumentEvent) - Method in interface javax.swing.event. DocumentListener

发出属性或属性集的更改通知。

changedUpdate(DocumentEvent) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

处理文档删除（触发适当的属性更改事件，即AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. FlowView

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. GlyphView

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html. BlockView

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html. ImageView

当Elements属性更改时调用。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html. InlineView

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. LabelView

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. ParagraphView

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. PlainView

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. View

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. WrappedPlainView

在该视图负责的位置向文档发出属性更改的通知。

changedUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text. FlowView.FlowStrategy

在该视图负责的位置向文档发出属性更改的通知。

changeEvent - Variable in class javax.swing. AbstractButton

每个按钮实例只需要一个 ChangeEvent因为事件的唯一状态是源属性。

changeEvent - Variable in class javax.swing. AbstractCellEditor

变更事件。

changeEvent - Variable in class javax.swing.colorchooser. DefaultColorSelectionModel

由于事件的唯一（只读）状态是源属性，因此每个模型实例只需要一个 ChangeEvent 。

changeEvent - Variable in class javax.swing. DefaultBoundedRangeModel

由于事件的唯一（只读）状态是源属性，因此每个模型实例只需要一个 ChangeEvent 。

changeEvent - Variable in class javax.swing. DefaultButtonModel

每个按钮模型实例只需要一个 ChangeEvent因为事件的唯一状态是源属性。

changeEvent - Variable in class javax.swing. DefaultSingleSelectionModel

由于事件的唯一（只读）状态是源属性，因此每个模型实例只需要一个ModelChangeEvent。

changeEvent - Variable in class javax.swing. JProgressBar

每个实例只需要一个 ChangeEvent因为事件唯一有趣的属性是不可变的源，它是进度条。

changeEvent - Variable in class javax.swing. JSlider

由于事件的唯一（只读）状态是源属性，因此每个滑块实例只需要一个 ChangeEvent 。

changeEvent - Variable in class javax.swing. JTabbedPane

每个 TabPane实例只需要一个 ChangeEvent因为事件的唯一（只读）状态是源属性。

changeEvent - Variable in class javax.swing. MenuSelectionManager

每个按钮模型实例只需要一个ChangeEvent，因为事件的唯一状态是源属性。

changeEvent - Variable in class javax.swing.table. DefaultTableColumnModel

更改事件（只需一个）

changeEvent - Variable in class javax.swing.text. DefaultCaret

模型的变化事件。

changeEvent - Variable in class javax.swing.text. StyleContext.NamedStyle

由于事件的唯一（只读）状态是源属性，因此每个模型实例只需要一个ChangeEvent。

ChangeEvent - Class in javax.swing.event

ChangeEvent用于通知有关方面事件来源状态已更改。

ChangeEvent(Object) - Constructor for class javax.swing.event. ChangeEvent

构造一个ChangeEvent对象。

ChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicProgressBarUI.ChangeHandler

ChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicSliderUI.ChangeHandler

ChangeHandler(JMenu, BasicMenuUI) - Constructor for class javax.swing.plaf.basic. BasicMenuUI.ChangeHandler

构造一个新的实例 ChangeHandler 。

changeHighlight(Object, int, int) - Method in class javax.swing.text. DefaultHighlighter

改变亮点

changeHighlight(Object, int, int) - Method in interface javax.swing.text. Highlighter

更改给定的突出显示以覆盖文档的不同部分。

changeInfo - Variable in class javax.naming.event. NamingEvent

包含有关生成此事件的更改的信息。

changeListener - Variable in class javax.swing. AbstractButton

按钮型号 changeListener 。

changeListener - Variable in class javax.swing. JProgressBar

监听进度条模型发送的更改事件，将其重新分配到此进度条上注册的更改事件侦听器。

changeListener - Variable in class javax.swing. JSlider

changeListener（无后缀）是我们添加到滑块模型的侦听器。

changeListener - Variable in class javax.swing. JTabbedPane

changeListener是我们添加到模型的监听器。

changeListener - Variable in class javax.swing.plaf.basic. BasicMenuBarUI

实例 ChangeListener 。

changeListener - Variable in class javax.swing.plaf.basic. BasicMenuUI

实例 ChangeListener 。

changeListener - Variable in class javax.swing.plaf.basic. BasicProgressBarUI

实例 ChangeListener 。

changeListener - Variable in class javax.swing.plaf.basic. BasicSliderUI

改变听众

ChangeListener< T> - Interface in javafx.beans.value

甲ChangeListener通知每当的值ObservableValue种变化。

ChangeListener - Interface in javax.swing.event

定义一个监听ChangeEvents的对象。

changeMethodType(MethodType) - Method in class jdk.dynalink. CallSiteDescriptor

查找或创建仅在其描述符的方法类型中不同的调用站点描述符。

changeMethodTypeInternal(MethodType) - Method in class jdk.dynalink. CallSiteDescriptor

查找或创建仅在其描述符的方法类型中不同的调用站点描述符。

changeName(String) - Method in class jdk.dynalink. NamedOperation

查找或创建与名称不同的命名操作。

changeOperation(Operation) - Method in class jdk.dynalink. CallSiteDescriptor

查找或创建一个调用站点描述符，其操作与此描述符不同。

changeOperationInternal(Operation) - Method in class jdk.dynalink. CallSiteDescriptor

查找或创建一个调用站点描述符，其操作与此描述符不同。

changeParameterType(int, Class<?>) - Method in class java.lang.invoke. MethodType

查找或创建具有单个不同参数类型的方法类型。

changeReturnType(Class<?>) - Method in class java.lang.invoke. MethodType

查找或创建具有不同返回类型的方法类型。

changeSelection(int, int, boolean, boolean) - Method in class javax.swing. JTable

根据两个标志的状态更新表的选择模型： toggle和 extend 。

changeShape(Dimension, Dimension, Dimension) - Method in class javax.swing. Box.Filler

更改此形状的大小请求。

changeSupport - Variable in class javax.swing. AbstractAction

如果有任何 PropertyChangeListeners已被注册，那么 changeSupport字段描述它们。

changeSupport - Variable in class javax.swing.tree. DefaultTreeSelectionModel

用于发送已注册的听众。

changeToParentDirectory() - Method in class javax.swing. JFileChooser

将要设置的目录更改为当前目录的父级。

ChangeToParentDirectoryAction() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.ChangeToParentDirectoryAction

构造一个 ChangeToParentDirectoryAction 。

changeUpdate() - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer

更新元素结构以响应文档中的更改。

channel - Variable in class javax.sound.midi. VoiceStatus

此声音播放的MIDI通道。

channel() - Method in class java.nio.channels. FileLock

返回获取此锁的文件通道。

channel() - Method in class java.nio.channels. MembershipKey

返回创建此成员资格密钥的通道。

channel() - Method in class java.nio.channels. SelectionKey

返回创建此键的通道。

Channel - Interface in java.nio.channels

I / O操作的联系。

CHANNEL_DOWN - javafx.scene.input. KeyCode

常数为 Channel Down键。

CHANNEL_PRESSURE - Static variable in class javax.sound.midi. ShortMessage

通道压力（触发）消息（0xD0或208）的命令值。

CHANNEL_UP - javafx.scene.input. KeyCode

常数为 Channel Up键。

ChannelBinding - Class in org.ietf.jgss

该类封装了主叫方提供的通道绑定信息的概念。

ChannelBinding(byte[]) - Constructor for class org.ietf.jgss. ChannelBinding

创建一个没有任何寻址信息的ChannelBinding对象。

ChannelBinding(InetAddress, InetAddress, byte[]) - Constructor for class org.ietf.jgss. ChannelBinding

使用用户提供的地址信息和数据创建ChannelBinding对象。

channels - Variable in class javax.sound.sampled. AudioFormat

这种格式的音频通道的数量（1为mono，2为立体声）。

Channels - Class in java.nio.channels

通道和流的实用方法。

CHAR - java.sql. JDBCType

标识通用SQL类型 CHAR 。

CHAR - javax.lang.model.type. TypeKind

原始类型 char 。

CHAR - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 CHAR 。

CHAR_ARRAY(String) - Constructor for class javax.print. DocFlavor.CHAR_ARRAY

使用给定的MIME类型和打印数据表示类名称为 "[C" （字符数组）构造新的文档风格。

CHAR_LITERAL - com.sun.source.tree. Tree.Kind

用于表示char类型的字符文字表达式的char 。

CHAR_REPLACEMENT - Static variable in class java.awt.font. TextAttribute

用于用户定义的字形显示的属性键代替字符的字体标准字形。

CHAR_UNDEFINED - Static variable in class java.awt.event. KeyEvent

KEY_PRESSED和KEY_RELEASED事件不映射到一个有效的Unicode字符使用它作为keyChar值。

CHAR_UNDEFINED - Static variable in class javafx.scene.input. KeyEvent

KEY_PRESSED和KEY_RELEASED事件不映射到一个有效的Unicode字符使用它作为keyChar值。

Character - Class in java.lang

Character类包装一个对象中的基元类型 char的值。

Character(char) - Constructor for class java.lang. Character

已过时。
很少使用这个构造函数。 静态工厂Character.valueOf(char)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。

CHARACTER - javafx.scene.control.skin. TextInputControlSkin.TextUnit

CHARACTER - Static variable in interface javax.accessibility. AccessibleText

常数用于表示应检索的文本部分是一个字符。

CHARACTER - Static variable in class javax.management.openmbean. SimpleType

描述Java类名称为 java.lang.Character值的 SimpleType实例。

CHARACTER_SET_ENCODING - Static variable in class javax.xml.soap. SOAPMessage

指定SOAP消息的字符类型编码。

Character.Subset - Class in java.lang

该类的实例表示Unicode字符集的特定子集。

Character.UnicodeBlock - Class in java.lang

一系列字符子集，表示Unicode规范中的字符块。

Character.UnicodeScript - Enum in java.lang

一系列字符子集，表示 Unicode Standard Annex #24: Script Names中定义的字符脚本。

CharacterAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.CharacterAction

CharacterCodingException - Exception in java.nio.charset

发生字符编码或解码错误时抛出的检查异常。

CharacterCodingException() - Constructor for exception java.nio.charset. CharacterCodingException

构造这个类的一个实例。

CharacterData - Interface in org.w3c.dom

CharacterData接口使用一组用于访问DOM中的字符数据的属性和方法来扩展Node。

characteristics() - Method in interface java.util. Spliterator

返回此Spliterator及其元素的一组特征。

characteristics() - Method in class java.util. Spliterators.AbstractDoubleSpliterator

返回此Spliterator及其元素的一组特征。

characteristics() - Method in class java.util. Spliterators.AbstractIntSpliterator

返回此Spliterator及其元素的一组特征。

characteristics() - Method in class java.util. Spliterators.AbstractLongSpliterator

返回此Spliterator及其元素的一组特征。

characteristics() - Method in class java.util. Spliterators.AbstractSpliterator

返回此Spliterator及其元素的一组特征。

characteristics() - Method in interface java.util.stream. Collector

返回 Set的 Collector.Characteristics表明该收藏家的特征。

CharacterIterator - Interface in java.text

该接口定义了一种用于文本双向迭代的协议。

characters(char[], int, int) - Method in interface org.xml.sax. ContentHandler

接收字符数据通知。

characters(char[], int, int) - Method in interface org.xml.sax. DocumentHandler

已过时。

接收字符数据通知。

characters(char[], int, int) - Method in class org.xml.sax. HandlerBase

已过时。

接收元素内的字符数据通知。

characters(char[], int, int) - Method in class org.xml.sax.helpers. DefaultHandler

接收元素内的字符数据通知。

characters(char[], int, int) - Method in class org.xml.sax.helpers. ParserAdapter

适配器实现方法; 不要打电话。

characters(char[], int, int) - Method in class org.xml.sax.helpers. XMLFilterImpl

过滤字符数据事件。

characters(char[], int, int) - Method in class org.xml.sax.helpers. XMLReaderAdapter

调整SAX2字符事件。

Characters - Interface in javax.xml.stream.events

这描述了与Characters事件的接口。

CHARACTERS - javafx.scene.input. ScrollEvent.HorizontalTextScrollUnits

水平文本滚动量是要滚动的字符数。

CHARACTERS - Static variable in interface javax.xml.stream. XMLStreamConstants

表示事件是字符

CharacterStringConverter - Class in javafx.util.converter

StringConverter实现为Character （和char基元）值。

CharacterStringConverter() - Constructor for class javafx.util.converter. CharacterStringConverter

CharArrayReader - Class in java.io

该类实现了一个字符缓冲区，可以用作字符输入流。

CharArrayReader(char[]) - Constructor for class java.io. CharArrayReader

从指定的字符数组中创建CharArrayReader。

CharArrayReader(char[], int, int) - Constructor for class java.io. CharArrayReader

从指定的字符数组中创建CharArrayReader。

CharArrayWriter - Class in java.io

该类实现了可以用作Writer的字符缓冲区。

CharArrayWriter() - Constructor for class java.io. CharArrayWriter

创建一个新的CharArrayWriter。

CharArrayWriter(int) - Constructor for class java.io. CharArrayWriter

用指定的初始大小创建一个新的CharArrayWriter。

charAt(int) - Method in interface java.lang. CharSequence

返回指定索引处的 char值。

charAt(int) - Method in class java.lang. String

返回指定索引处的 char值。

charAt(int) - Method in class java.lang. StringBuffer

charAt(int) - Method in class java.nio. CharBuffer

以相对于当前位置的给定索引读取字符。

charAt(int) - Method in class javax.swing.text. Segment

返回指定索引处的 char值。

charAttr - Variable in class javax.swing.text.html. HTMLDocument.HTMLReader

当前字符属性集。

CharBuffer - Class in java.nio

一个char缓冲区。

CharConversionException - Exception in java.io

字符转换异常的基类。

CharConversionException() - Constructor for exception java.io. CharConversionException

这不提供详细的信息。

CharConversionException(String) - Constructor for exception java.io. CharConversionException

这提供了详细的信息。

charCount(int) - Static method in class java.lang. Character

确定表示指定字符（Unicode代码点）所需的 char值的数量。

CharHolder - Class in org.omg.CORBA

持有人 Char 。

CharHolder() - Constructor for class org.omg.CORBA. CharHolder

构造一个新的 CharHolder对象，其 value字段初始化为 0 。

CharHolder(char) - Constructor for class org.omg.CORBA. CharHolder

为给定的 char构造一个新的 CharHolder对象。

chars() - Method in interface java.lang. CharSequence

返回一个 int的数据流，从这个序列中扩展 char值。

chars() - Method in class java.lang. String

返回一个 int的数据流，从这个序列中扩展 char值。

chars() - Method in class java.nio. CharBuffer

CharSeqHelper - Class in org.omg.CORBA

助手 CharSeq 。

CharSeqHelper() - Constructor for class org.omg.CORBA. CharSeqHelper

CharSeqHolder - Class in org.omg.CORBA

持有人 CharSeq 。

CharSeqHolder() - Constructor for class org.omg.CORBA. CharSeqHolder

CharSeqHolder(char[]) - Constructor for class org.omg.CORBA. CharSeqHolder

CharSequence - Interface in java.lang

A CharSequence是 char值的可读序列。

charset() - Method in class java.nio.charset. CharsetDecoder

返回创建此解码器的字符集。

charset() - Method in class java.nio.charset. CharsetEncoder

返回创建此编码器的字符集。

Charset - Class in java.nio.charset

16位Unicode code units和字节序列的序列之间的命名映射。

Charset(String, String[]) - Constructor for class java.nio.charset. Charset

使用给定的规范名称和别名集初始化新的字符集。

CHARSET_RULE - Static variable in interface org.w3c.dom.css. CSSRule

规则是 CSSCharsetRule 。

CharsetDecoder - Class in java.nio.charset

可以将特定字符集中的字节序列转换为十六位Unicode字符序列的引擎。

CharsetDecoder(Charset, float, float) - Constructor for class java.nio.charset. CharsetDecoder

初始化一个新的解码器。

CharsetEncoder - Class in java.nio.charset

一种引擎，可以将一系列十六位Unicode字符转换为特定字符集中的字节序列。

CharsetEncoder(Charset, float, float) - Constructor for class java.nio.charset. CharsetEncoder

初始化新的编码器。

CharsetEncoder(Charset, float, float, byte[]) - Constructor for class java.nio.charset. CharsetEncoder

初始化新的编码器。

charsetForName(String) - Method in class java.nio.charset.spi. CharsetProvider

检索给定字符集名称的字符集。

CharsetProvider - Class in java.nio.charset.spi

字符集服务提供者类。

CharsetProvider() - Constructor for class java.nio.charset.spi. CharsetProvider

初始化一个新的字符集提供程序。

charsets() - Method in class java.nio.charset.spi. CharsetProvider

创建一个迭代器来迭代此提供程序支持的字符集。

charStream - Variable in class javax.sql.rowset. BaseRowSet

Reader对象将通过方法 getCharacterStream返回，这是在 ResultSet接口中指定的。

charsWidth(char[], int, int) - Method in class java.awt. FontMetrics

返回在此 Font显示指定字符数组的总进位宽度。

Chart - Class in javafx.scene.chart

所有图表的基础类。

Chart() - Constructor for class javafx.scene.chart. Chart

创建一个新的默认图表实例。

chartProperty() - Method in class javafx.scene.chart. PieChart.Data

该数据所属的图表。

chartProperty() - Method in class javafx.scene.chart. XYChart.Series

参考本系列所属的图表

CHARTREUSE - Static variable in class javafx.scene.paint. Color

RGB值为＃7FFF00的颜色表格

CharType - Interface in com.sun.jdi

在目标虚拟机中访问的所有原始字符值的类型。

charValue() - Method in interface com.sun.jdi. PrimitiveValue

将此值转换为CharValue，并将结果作为char返回。

charValue() - Method in class java.lang. Character

返回此 Character对象的值。

CharValue - Interface in com.sun.jdi

提供对目标虚拟机 char语 char值的访问。

charWidth(char) - Method in class java.awt. FontMetrics

返回此 Font指定字符的前进宽度。

charWidth(int) - Method in class java.awt. FontMetrics

返回此 Font指定字符的前进宽度。

check(String, URL, String, MLetContent) - Method in class javax.management.loading. MLet

当扩展此服务以支持缓存和版本控制时，此方法将被覆盖。

check(Certificate) - Method in interface java.security.cert. CertPathChecker

使用其内部状态对指定的证书执行检查。

check(Certificate) - Method in class java.security.cert. PKIXCertPathChecker

使用其内部状态对指定的证书执行检查。

check(Certificate, Collection<String>) - Method in class java.security.cert. PKIXCertPathChecker

使用其内部状态对指定证书执行检查，并从指定的OID字符串集合中删除其处理的任何关键扩展，这些扩展代表未解决的关键扩展。

CHECK_BOX - javafx.scene. AccessibleRole

复选框角色。

CHECK_BOX - Static variable in class javax.accessibility. AccessibleRole

可以选中或取消选中的选项，并为当前状态提供单独的指示符。

CHECK_BOX - Static variable in class javax.swing.plaf.synth. Region

复选框区域。

CHECK_BOX_MENU_ITEM - Static variable in class javax.swing.plaf.synth. Region

CheckBoxMenuItem区域。

CHECK_MENU_ITEM - javafx.scene. AccessibleRole

检查菜单项角色。

checkAccept(String, int) - Method in class java.lang. SecurityManager

如果调用线程不允许从指定的主机和端口号接受套接字连接，则抛出一个 SecurityException 。

checkAccess() - Method in class java.lang. Thread

确定当前正在运行的线程是否有权限修改此线程。

checkAccess() - Method in class java.lang. ThreadGroup

确定当前运行的线程是否有权限修改此线程组。

checkAccess() - Method in class java.util.logging. LogManager

检查当前上下文是否受信任以修改日志记录配置。

checkAccess(Thread) - Method in class java.lang. SecurityManager

如果调用线程不允许修改线程参数，则抛出一个 SecurityException 。

checkAccess(ThreadGroup) - Method in class java.lang. SecurityManager

如果调用线程不允许修改线程组参数，则抛出一个 SecurityException 。

checkAccess(Path, AccessMode...) - Method in class java.nio.file.spi. FileSystemProvider

检查文件的存在，以及可选的可访问性。

checkAll() - Method in class java.awt. MediaTracker

检查此媒体跟踪器跟踪的所有图像是否已完成加载。

checkAll(boolean) - Method in class java.awt. MediaTracker

检查此媒体跟踪器跟踪的所有图像是否已完成加载。

checkAwtEventQueueAccess() - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
此方法最初用于检查调用线程是否可以访问AWT事件队列。 该方法已经过时，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessEventQueue") 。 此方法在将来的Java SE版本中可能会被删除。

Checkbox - Class in java.awt

复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。

Checkbox() - Constructor for class java.awt. Checkbox

为其标签创建一个带有空字符串的复选框。

Checkbox(String) - Constructor for class java.awt. Checkbox

创建一个带有指定标签的复选框。

Checkbox(String, boolean) - Constructor for class java.awt. Checkbox

创建一个带有指定标签的复选框，并设置指定的状态。

Checkbox(String, boolean, CheckboxGroup) - Constructor for class java.awt. Checkbox

构造具有指定标签的复选框，设置为指定的状态，并在指定的复选框组中。

Checkbox(String, CheckboxGroup, boolean) - Constructor for class java.awt. Checkbox

在指定的复选框组中创建带有指定标签的复选框，并设置为指定的状态。

CheckBox - Class in javafx.scene.control

三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。

CheckBox() - Constructor for class javafx.scene.control. CheckBox

为其标签创建一个带有空字符串的复选框。

CheckBox(String) - Constructor for class javafx.scene.control. CheckBox

创建一个带有指定文本的复选框作为其标签。

Checkbox.AccessibleAWTCheckbox - Class in java.awt

这个类实现 Checkbox类的可访问性支持。

CheckboxGroup - Class in java.awt

CheckboxGroup类用于组合一组 Checkbox按钮。

CheckboxGroup() - Constructor for class java.awt. CheckboxGroup

创建一个新的实例 CheckboxGroup 。

CheckBoxListCell< T> - Class in javafx.scene.control.cell

一个包含一个ListCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。

CheckBoxListCell() - Constructor for class javafx.scene.control.cell. CheckBoxListCell

创建一个默认的CheckBoxListCell。

CheckBoxListCell(Callback<T, ObservableValue<Boolean>>) - Constructor for class javafx.scene.control.cell. CheckBoxListCell

创建一个默认的CheckBoxListCell。

CheckBoxListCell(Callback<T, ObservableValue<Boolean>>, StringConverter<T>) - Constructor for class javafx.scene.control.cell. CheckBoxListCell

用自定义字符串转换器创建一个CheckBoxListCell。

CheckboxMenuItem - Class in java.awt

此类表示可以包含在菜单中的复选框。

CheckboxMenuItem() - Constructor for class java.awt. CheckboxMenuItem

创建一个带有空标签的复选框菜单项。

CheckboxMenuItem(String) - Constructor for class java.awt. CheckboxMenuItem

创建带有指定标签的复选框菜单项。

CheckboxMenuItem(String, boolean) - Constructor for class java.awt. CheckboxMenuItem

创建带有指定标签和状态的复选框菜单项。

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem - Class in java.awt

用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。

checkBoxSelectionChangedEvent() - Static method in class javafx.scene.control. CheckBoxTreeItem

当CheckBoxTreeItem选择/不确定状态改变时使用的EventType。

CheckBoxSkin - Class in javafx.scene.control.skin

默认皮肤实现为三态CheckBox控件。

CheckBoxSkin(CheckBox) - Constructor for class javafx.scene.control.skin. CheckBoxSkin

创建一个新的CheckBoxSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

CheckBoxTableCell< S, T> - Class in javafx.scene.control.cell

一个包含TableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。

CheckBoxTableCell() - Constructor for class javafx.scene.control.cell. CheckBoxTableCell

创建一个默认的CheckBoxTableCell。

CheckBoxTableCell(Callback<Integer, ObservableValue<Boolean>>) - Constructor for class javafx.scene.control.cell. CheckBoxTableCell

创建一个默认的CheckBoxTableCell，使用自定义的Callback检索给定单元格索引的ObservableValue。

CheckBoxTableCell(Callback<Integer, ObservableValue<Boolean>>, StringConverter<T>) - Constructor for class javafx.scene.control.cell. CheckBoxTableCell

创建一个带有自定义字符串转换器的CheckBoxTableCell。

CheckBoxTreeCell< T> - Class in javafx.scene.control.cell

一个包含一个TreeCell实现的类，它在单元格中绘制一个CheckBox节点，同时支持常见的交互（ 稍后更详细地讨论）。

CheckBoxTreeCell() - Constructor for class javafx.scene.control.cell. CheckBoxTreeCell

创建一个默认的CheckBoxTreeCell ，它假定TreeView是用CheckBoxTreeItem实例构建的，而不是默认的TreeItem 。

CheckBoxTreeCell(Callback<TreeItem<T>, ObservableValue<Boolean>>) - Constructor for class javafx.scene.control.cell. CheckBoxTreeCell

创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。

CheckBoxTreeCell(Callback<TreeItem<T>, ObservableValue<Boolean>>, StringConverter<TreeItem<T>>) - Constructor for class javafx.scene.control.cell. CheckBoxTreeCell

创建一个CheckBoxTreeCell用于通过单元格工厂的TreeView控件。

CheckBoxTreeItem< T> - Class in javafx.scene.control

TreeItem子类增加了在选定的，未选择的和不确定的状态中的支持。

CheckBoxTreeItem() - Constructor for class javafx.scene.control. CheckBoxTreeItem

创建一个空的CheckBoxTreeItem。

CheckBoxTreeItem(T) - Constructor for class javafx.scene.control. CheckBoxTreeItem

创建一个CheckBoxTreeItem，其value属性设置为提供的对象。

CheckBoxTreeItem(T, Node) - Constructor for class javafx.scene.control. CheckBoxTreeItem

创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的节点。

CheckBoxTreeItem(T, Node, boolean) - Constructor for class javafx.scene.control. CheckBoxTreeItem

创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的Node，并将 CheckBoxTreeItem.selectedProperty()的初始状态设置为提供的布尔值。

CheckBoxTreeItem(T, Node, boolean, boolean) - Constructor for class javafx.scene.control. CheckBoxTreeItem

创建一个CheckBoxTreeItem，其value属性设置为提供的对象，图形设置为提供的Node， CheckBoxTreeItem.selectedProperty()的初始状态设置为提供的布尔值，以及 27045958634928属性的初始状态为提供的布尔值。

CheckBoxTreeItem.TreeModificationEvent< T> - Class in javafx.scene.control

一个TreeModificationEvent类，与类似于TreeItem.TreeModificationEvent类的工作类似，因为这个事件会引发 CheckBoxTreeItem层次结构，直到父节点为空。

CheckBoxTreeTableCell< S, T> - Class in javafx.scene.control.cell

一个包含一个TreeTableCell实现的类，在该单元格中绘制一个CheckBox节点，可选地带有一个标签，表示复选框代表什么。

CheckBoxTreeTableCell() - Constructor for class javafx.scene.control.cell. CheckBoxTreeTableCell

创建一个默认的CheckBoxTreeTableCell。

CheckBoxTreeTableCell(Callback<Integer, ObservableValue<Boolean>>) - Constructor for class javafx.scene.control.cell. CheckBoxTreeTableCell

创建一个默认的CheckBoxTreeTableCell与自定义Callback检索给定单元格索引的ObservableValue。

CheckBoxTreeTableCell(Callback<Integer, ObservableValue<Boolean>>, StringConverter<T>) - Constructor for class javafx.scene.control.cell. CheckBoxTreeTableCell

用自定义字符串转换器创建一个CheckBoxTreeTableCell。

checkClientTrusted(X509Certificate[], String) - Method in interface javax.net.ssl. X509TrustManager

给定由对等体提供的部分或完整的证书链，构建证书路径到受信任的根，并返回，如果它可以被验证，并且基于认证类型对客户端SSL认证信任。

checkClientTrusted(X509Certificate[], String, Socket) - Method in class javax.net.ssl. X509ExtendedTrustManager

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

checkClientTrusted(X509Certificate[], String, SSLEngine) - Method in class javax.net.ssl. X509ExtendedTrustManager

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

checkClosed() - Method in class javax.imageio.stream. ImageInputStreamImpl

如果流已关闭，则抛出一个 IOException 。

checkConnect(String, int) - Method in class java.lang. SecurityManager

如果调用线程不允许打开与指定的主机和端口号的套接字连接，则抛出一个 SecurityException 。

checkConnect(String, int, Object) - Method in class java.lang. SecurityManager

如果指定的安全上下文不允许打开到指定主机和端口号的套接字连接，则抛出一个 SecurityException 。

checkCreateClassLoader() - Method in class java.lang. SecurityManager

如果调用线程不允许创建新的类加载器，则抛出一个 SecurityException 。

checkCredentials(String, String) - Method in class com.sun.net.httpserver. BasicAuthenticator

要求每个传入请求在此Authenticator的领域的上下文中验证给定的名称和密码。

checkDelete(String) - Method in class java.lang. SecurityManager

如果调用线程不允许删除指定的文件，则抛出一个 SecurityException 。

CHECKED - Static variable in class javax.accessibility. AccessibleState

表示此对象当前已被选中。

CHECKED - Static variable in class javax.swing.text.html. HTML.Attribute

属性“已检查”

checkedCollection(Collection<E>, Class<E>) - Static method in class java.util. Collections

返回指定集合的动态类型安全视图。

CheckedInputStream - Class in java.util.zip

也保持正在读取的数据的校验和的输入流。

CheckedInputStream(InputStream, Checksum) - Constructor for class java.util.zip. CheckedInputStream

使用指定的校验和创建输入流。

checkedList(List<E>, Class<E>) - Static method in class java.util. Collections

返回指定列表的动态类型安全视图。

checkedMap(Map<K, V>, Class<K>, Class<V>) - Static method in class java.util. Collections

返回指定地图的动态类型安全视图。

checkedNavigableMap(NavigableMap<K, V>, Class<K>, Class<V>) - Static method in class java.util. Collections

返回指定可导航地图的动态类型安全视图。

checkedNavigableSet(NavigableSet<E>, Class<E>) - Static method in class java.util. Collections

返回指定的可导航集的动态类型安全视图。

checkedObservableList(ObservableList<E>, Class<E>) - Static method in class javafx.collections. FXCollections

在提供的可观察列表之上创建并返回一个类型安全的包装器。

checkedObservableMap(ObservableMap<K, V>, Class<K>, Class<V>) - Static method in class javafx.collections. FXCollections

在提供的可观察地图的顶部创建并返回类型安全的包装器。

checkedObservableSet(ObservableSet<E>, Class<E>) - Static method in class javafx.collections. FXCollections

在提供的可观察集之上创建并返回一个类型安全的包装器。

CheckedOutputStream - Class in java.util.zip

一个输出流，它还维护正在写入的数据的校验和。

CheckedOutputStream(OutputStream, Checksum) - Constructor for class java.util.zip. CheckedOutputStream

使用指定的校验和创建输出流。

checkedQueue(Queue<E>, Class<E>) - Static method in class java.util. Collections

返回指定队列的动态类型安全视图。

checkedSet(Set<E>, Class<E>) - Static method in class java.util. Collections

返回指定集合的动态类型安全视图。

checkedSortedMap(SortedMap<K, V>, Class<K>, Class<V>) - Static method in class java.util. Collections

返回指定排序映射的动态类型安全视图。

checkedSortedSet(SortedSet<E>, Class<E>) - Static method in class java.util. Collections

返回指定排序集的动态类型安全视图。

checkError() - Method in class java.io. PrintStream

刷新流并检查其错误状态。

checkError() - Method in class java.io. PrintWriter

如果流未关闭，请刷新流并检查其错误状态。

checkExec(String) - Method in class java.lang. SecurityManager

如果调用线程不允许创建子进程，则抛出一个 SecurityException 。

checkExit(int) - Method in class java.lang. SecurityManager

如果不允许调用线程使Java虚拟机停止指定的状态代码，则抛出一个 SecurityException 。

checkForClickInExpandControl(TreePath, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI

如果 mouseX和 mouseY都在的展开/折叠区域 row ，这将切换行。

checkFromIndexSize(int, int, int) - Static method in class java.util. Objects

检查是否在子范围从 fromIndex （含）至 fromIndex + size （不包括）是范围界限内 0 （包括）到 length （不包括）。

checkFromToIndex(int, int, int) - Static method in class java.util. Objects

检查是否在子范围从 fromIndex （含）至 toIndex （不包括）是范围界限内 0 （包括）到 length （不包括）。

checkGuard(Object) - Method in interface java.security. Guard

确定是否允许访问被保护对象 object 。

checkGuard(Object) - Method in class java.security. Permission

实施保护接口以获得许可。

checkHorizontalKey(int, String) - Method in class javax.swing. AbstractButton

验证 key参数是否为 horizontalAlignment和 horizontalTextPosition属性的合法值。

checkHorizontalKey(int, String) - Method in class javax.swing. JLabel

验证该键是horizontalAlignment属性的合法值。

checkIcon - Variable in class javax.swing.plaf.basic. BasicMenuItemUI

检查图标。

checkID(int) - Method in class java.awt. MediaTracker

检查由该媒体跟踪器跟踪的所有标记有指定标识符的图像是否已完成加载。

checkID(int, boolean) - Method in class java.awt. MediaTracker

检查由该媒体跟踪器跟踪的所有标记有指定标识符的图像是否已完成加载。

checkImage(Image, int, int, ImageObserver) - Method in class java.awt. Component

返回构造指定图像的屏幕表示的状态。

checkImage(Image, int, int, ImageObserver) - Method in class java.awt. Toolkit

表示准备显示的指定图像的构造状态。

checkImage(Image, ImageObserver) - Method in class java.awt. Component

返回构造指定图像的屏幕表示的状态。

checkIndex(int, int) - Static method in class java.util. Objects

检查 index是否在从 0 （含）的范围内到 length （排他）的范围内。

checkInput(ObjectInputFilter.FilterInfo) - Method in interface java.io. ObjectInputFilter

检查类，数组长度，对象引用数，深度，流大小和其他可用过滤信息。

checkLink(String) - Method in class java.lang. SecurityManager

如果调用线程不允许动态链接由字符串参数文件指定的库代码，则抛出一个 SecurityException 。

checkListen(int) - Method in class java.lang. SecurityManager

如果调用线程不允许在指定的本地端口号上等待连接请求，则抛出一个 SecurityException 。

checkMaxDegree(int) - Method in class javax.management.relation. RoleInfo

如果 value参数低于或等于预期的最大度数，则返回true，否则返回false。

checkMemberAccess(Class<?>, int) - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
该方法依赖于调用者的堆栈深度为4，容易出错，并且不能由运行时执行。 该方法的用户应直接调用SecurityManager.checkPermission(java.security.Permission) 。 此方法在将来的Java SE版本中可能会被删除。

CheckMenuItem - Class in javafx.scene.control

A MenuItem可以在选定状态和未选择状态之间切换。

CheckMenuItem() - Constructor for class javafx.scene.control. CheckMenuItem

*构造函数* *

CheckMenuItem(String) - Constructor for class javafx.scene.control. CheckMenuItem

构造一个CheckMenuItem并设置具有指定文本的显示文本。

CheckMenuItem(String, Node) - Constructor for class javafx.scene.control. CheckMenuItem

构造一个CheckMenuItem，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。

checkMinDegree(int) - Method in class javax.management.relation. RoleInfo

如果 value参数大于或等于预期的最小度，则返回true，否则返回false。

checkMulticast(InetAddress) - Method in class java.lang. SecurityManager

如果调用线程不允许使用（加入/离开/发送/接收）IP组播，则抛出一个 SecurityException 。

checkMulticast(InetAddress, byte) - Method in class java.lang. SecurityManager

已过时。
请改用#checkPermission（java.security.Permission）

checkOpacity(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonListener

检查 AbstractButton的不透明度。

checkPackageAccess(String) - Method in class java.lang. SecurityManager

如果调用线程不允许访问指定的包，则抛出一个 SecurityException 。

checkPackageDefinition(String) - Method in class java.lang. SecurityManager

如果调用线程不允许在指定的包中定义类，则抛出一个 SecurityException 。

checkPainter() - Method in class javax.swing.text. GlyphView

检查是否存在字形画家。

checkPermission(Permission) - Method in interface java.security.acl. AclEntry

已过时。

检查指定的权限是否是此条目中权限集的一部分。

checkPermission(Permission) - Method in class java.lang. SecurityManager

如果根据当前有效的安全策略不允许由给定权限指定的请求访问，则抛出一个 SecurityException 。

checkPermission(Permission) - Method in class java.security. AccessControlContext

根据当前有效的安全策略以及此对象中的上下文确定是否允许或拒绝由指定权限指定的访问请求。

checkPermission(Permission) - Static method in class java.security. AccessController

根据当前的AccessControlContext和安全策略确定是否允许或拒绝由指定的权限指定的访问请求。

checkPermission(Permission, Object) - Method in class java.lang. SecurityManager

如果指定的安全上下文被拒绝访问指定权限指定的资源，则抛出一个 SecurityException 。

checkPermission(Principal, Permission) - Method in interface java.security.acl. Acl

已过时。

检查指定的委托人是否具有指定的权限。

checkPrintJobAccess() - Method in class java.lang. SecurityManager

如果调用线程不允许启动打印作业请求，则抛出一个 SecurityException 。

checkPropertiesAccess() - Method in class java.lang. SecurityManager

如果调用线程不允许访问或修改系统属性，则抛出一个 SecurityException 。

checkPropertyAccess(String) - Method in class java.lang. SecurityManager

如果调用线程不允许访问具有指定的 key名称的系统属性，则抛出一个 SecurityException 。

checkRead(FileDescriptor) - Method in class java.lang. SecurityManager

如果调用线程不允许从指定的文件描述符读取，则抛出一个 SecurityException 。

checkRead(String) - Method in class java.lang. SecurityManager

如果调用线程不允许读取由字符串参数指定的文件，则抛出一个 SecurityException 。

checkRead(String, Object) - Method in class java.lang. SecurityManager

如果指定的安全上下文不允许读取由字符串参数指定的文件，则抛出一个 SecurityException 。

checkReadParamBandSettings(ImageReadParam, int, int) - Static method in class javax.imageio. ImageReader

读者可以使用一种实用方法来测试 ImageReadParam的源和目标频带设置的 ImageReadParam 。

checkRoleReading(String, String) - Method in class javax.management.relation. RelationService

检查给定角色是否可以以给定类型的关系读取。

checkRoleReading(String, String) - Method in interface javax.management.relation. RelationServiceMBean

检查给定角色是否可以以给定类型的关系读取。

checkRoleWriting(Role, String, Boolean) - Method in class javax.management.relation. RelationService

检查给定的角色是否可以按给定类型的关系进行设置。

checkRoleWriting(Role, String, Boolean) - Method in interface javax.management.relation. RelationServiceMBean

检查给定的角色是否可以按给定类型的关系进行设置。

checkSecurityAccess(String) - Method in class java.lang. SecurityManager

确定是否应授予或拒绝具有指定权限目标名称的权限。

checkServerTrusted(X509Certificate[], String) - Method in interface javax.net.ssl. X509TrustManager

给定对等体提供的部分或完整的证书链，构建一个证书路径到一个受信任的根，并返回，如果它可以被验证，并且信任基于认证类型的服务器SSL认证。

checkServerTrusted(X509Certificate[], String, Socket) - Method in class javax.net.ssl. X509ExtendedTrustManager

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

checkServerTrusted(X509Certificate[], String, SSLEngine) - Method in class javax.net.ssl. X509ExtendedTrustManager

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

checkSetFactory() - Method in class java.lang. SecurityManager

抛出 SecurityException如果调用线程不允许设置由使用的套接字工厂 ServerSocket或者 Socket ，或使用的流处理程序工厂 URL 。

Checksum - Interface in java.util.zip

表示数据校验和的接口。

checkSystemClipboardAccess() - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
该方法最初用于检查调用线程是否可以访问系统剪贴板。 该方法已被废弃，代码应使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessClipboard") 。 此方法在将来的Java SE版本中可能会被删除。

checkTopLevelWindow(Object) - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
该方法最初用于检查调用线程是否被信任以启动顶级窗口。 该方法已被废弃，代码应使用SecurityManager.checkPermission(java.security.Permission)查询AWTPermission("showWindowWithoutWarningBanner") 。 此方法在将来的Java SE版本中可能会被删除。

checkValidIntValue(long) - Method in enum java.time.temporal. ChronoField

检查指定的值是否有效并适合 int 。

checkValidIntValue(long, TemporalField) - Method in class java.time.temporal. ValueRange

检查指定的值是否有效，并符合 int 。

checkValidity() - Method in class java.security.cert. X509Certificate

检查证书当前是否有效。

checkValidity() - Method in class javax.security.cert. X509Certificate

已过时。

检查证书当前是否有效。

checkValidity(Date) - Method in class java.security.cert. X509Certificate

检查给定日期是否在证书的有效期内。

checkValidity(Date) - Method in class javax.security.cert. X509Certificate

已过时。

检查指定的日期是否在证书的有效期内。

checkValidValue(long) - Method in enum java.time.temporal. ChronoField

检查该字段指定的值是否有效。

checkValidValue(long, TemporalField) - Method in class java.time.temporal. ValueRange

检查指定的值是否有效。

checkVerticalKey(int, String) - Method in class javax.swing. AbstractButton

验证 key参数是垂直属性的合法值。

checkVerticalKey(int, String) - Method in class javax.swing. JLabel

验证该键是verticalAlignment或verticalTextPosition属性的合法值。

checkWrite(FileDescriptor) - Method in class java.lang. SecurityManager

如果调用线程不允许写入指定的 SecurityException则抛出一个 SecurityException 。

checkWrite(String) - Method in class java.lang. SecurityManager

如果调用线程不允许写入由string参数指定的文件，则抛出一个 SecurityException 。

CHEROKEE - java.lang. Character.UnicodeScript

Unicode脚本“切诺基”。

CHEROKEE - Static variable in class java.lang. Character.UnicodeBlock

常数为“切诺基”Unicode字符块。

CHEROKEE_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock

常数为“切诺基补充”Unicode字符块。

CHILD_NODE_OF - Static variable in class javax.accessibility. AccessibleRelation

表示对象是一个或多个对象的子节点。

CHILD_NODE_OF_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation

表示两个或多个对象之间的 CHILD_NODE_OF关系已更改。

CHILD_POLICY_ALL - Static variable in interface javax.imageio.metadata. IIOMetadataFormat

一个由 getChildPolicy返回的 getChildPolicy以表示元素必须具有每个其合法子元素的单个实例。

CHILD_POLICY_CHOICE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat

由 getChildPolicy返回的 getChildPolicy表示元素必须有零个或一个小孩，从其合法的子元素中选择。

CHILD_POLICY_EMPTY - Static variable in interface javax.imageio.metadata. IIOMetadataFormat

一个由 getChildPolicy返回的 getChildPolicy ，表示某个元素可能没有任何子项。

CHILD_POLICY_MAX - Static variable in interface javax.imageio.metadata. IIOMetadataFormat

最大有效 CHILD_POLICY_*常数，用于范围检查。

CHILD_POLICY_REPEAT - Static variable in interface javax.imageio.metadata. IIOMetadataFormat

一个由 getChildPolicy返回的 getChildPolicy ，表示一个元素必须有零个或多个独特的合法子元素的实例。

CHILD_POLICY_SEQUENCE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat

由 getChildPolicy返回的 getChildPolicy表示元素必须具有其任何法定子元素的实例序列。

CHILD_POLICY_SOME - Static variable in interface javax.imageio.metadata. IIOMetadataFormat

一个由 getChildPolicy返回的常数，以表示元素必须具有每个其合法子元素的零个或一个实例。

childAdded(NodeChangeEvent) - Method in interface java.util.prefs. NodeChangeListener

添加子节点时调用此方法。

childAlloc - Variable in class javax.swing.text. AsyncBoxView.ChildLocator

用于子分配的形状，以避免产生大量的垃圾。

childAllocation(int, Rectangle) - Method in class javax.swing.text. BoxView

为子视图分配一个区域。

childAllocation(int, Rectangle) - Method in class javax.swing.text. CompositeView

返回给定子项的分配。

childChanged(AsyncBoxView.ChildState) - Method in class javax.swing.text. AsyncBoxView.ChildLocator

通知孩子改变了。

childDeserializedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext. BeanContextSupport

由readObject与新反序列化的小孩和BCSChild调用。

childIndices - Variable in class javax.swing.event. TreeModelEvent

确定孩子的位置的指标。

childJustAddedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext. BeanContextSupport

子类可以覆盖此方法，以便在添加子项之后和事件通知发生之前简单地扩展add（）语义。

childJustRemovedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext. BeanContextServicesSupport

在孩子被成功删除之后从超类儿童删除操作中调用。 调用与子同步。

childJustRemovedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext. BeanContextSupport

子类可以覆盖此方法，以便在子进程已被删除之后和事件通知发生之前简单地扩展remove（）语义。

ChildLocator() - Constructor for class javax.swing.text. AsyncBoxView.ChildLocator

构建一个子定位器。

childRemoved(NodeChangeEvent) - Method in interface java.util.prefs. NodeChangeListener

删除子节点时调用此方法。

children - Variable in class java.beans.beancontext. BeanContextMembershipEvent

受此事件通知影响的小孩列表。

children - Variable in class java.beans.beancontext. BeanContextSupport

对 protected HashMap children字段的所有访问应在该对象上同步。

children - Variable in class javax.swing.event. TreeModelEvent

被删除的孩子

children - Variable in class javax.swing.tree. DefaultMutableTreeNode

如果此节点没有子节点，则可能为null

children() - Method in class java.lang. Process

返回进程的直接子节点的快照。

children() - Method in interface java.lang. ProcessHandle

返回进程当前直接子节点的快照。

children() - Method in class javax.swing. JTree.DynamicUtilTreeNode

子类加载孩子，如有必要。

children() - Method in class javax.swing.text. AbstractDocument.AbstractElement

以 Enumeration返回接收者的 Enumeration 。

children() - Method in class javax.swing.text. AbstractDocument.BranchElement

以 Enumeration返回接收者的 Enumeration 。

children() - Method in class javax.swing.text. AbstractDocument.LeafElement

以 Enumeration返回接收者的 Enumeration 。

children() - Method in class javax.swing.tree. DefaultMutableTreeNode

创建并返回该节点的子节点的前向枚举。

children() - Method in interface javax.swing.tree. TreeNode

以 Enumeration返回接收者的 Enumeration 。

CHILDREN - javafx.scene. AccessibleAttribute

返回节点的子节点。

childrenAdded(BeanContextMembershipEvent) - Method in interface java.beans.beancontext. BeanContextMembershipListener

当一个孩子或儿童列表被添加到这个监听者注册的 BeanContext时调用。

childrenModificationEvent() - Static method in class javafx.scene.control. TreeItem

当TreeItem接收到对其子列表的直接修改时使用的EventType。

childrenNames() - Method in class java.util.prefs. AbstractPreferences

实现 children方法按照在本说明书中 Preferences.childrenNames() 。

childrenNames() - Method in class java.util.prefs. Preferences

返回此首选项节点的子节点相对于此节点的名称。

childrenNamesSpi() - Method in class java.util.prefs. AbstractPreferences

返回此首选项节点的子节点的名称。

childrenRemoved(BeanContextMembershipEvent) - Method in interface java.beans.beancontext. BeanContextMembershipListener

当从这个监听者注册的 BeanContext中删除一个孩子或孩子列表时调用。

childSpi(String) - Method in class java.util.prefs. AbstractPreferences

返回此首选项节点的命名子节点，如果它不存在则创建它。

ChildState(View) - Constructor for class javax.swing.text. AsyncBoxView.ChildState

构建小孩状态。

childValue - Variable in class javax.swing. JTree.DynamicUtilTreeNode

创造孩子的价值。

childValue(T) - Method in class java.lang. InheritableThreadLocal

在子线程创建时，根据父值的值计算该可继承线程局部变量的子级初始值。

CHINA - Static variable in class java.util. Locale

对国家有用的常数。

CHINESE - Static variable in class java.util. Locale

有用的语言常数

CHOCOLATE - Static variable in class javafx.scene.paint. Color

颜色巧克力，RGB值为＃D2691E

Choice - Class in java.awt

Choice课程提供了一个弹出菜单的选择。

Choice() - Constructor for class java.awt. Choice

创建一个新的选择菜单。

Choice.AccessibleAWTChoice - Class in java.awt

这个类实现 Choice类的辅助功能支持。

ChoiceBox< T> - Class in javafx.scene.control

ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。

ChoiceBox() - Constructor for class javafx.scene.control. ChoiceBox

创建一个新的ChoiceBox，它有一个空的项目列表。

ChoiceBox(ObservableList<T>) - Constructor for class javafx.scene.control. ChoiceBox

使用给定的项目创建一个新的ChoiceBox。

ChoiceBoxListCell< T> - Class in javafx.scene.control.cell

一个包含ListCell实现的类，在单元格内绘制一个ChoiceBox节点。

ChoiceBoxListCell() - Constructor for class javafx.scene.control.cell. ChoiceBoxListCell

创建一个带有空项目列表的默认ChoiceBoxListCell。

ChoiceBoxListCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxListCell

创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxListCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxListCell

创建一个ChoiceBoxListCell实例，给定的项目用于在显示时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxListCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxListCell

创建一个ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxListCell(T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxListCell

创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为ChoiceBox控件。

ChoiceBoxSkin(ChoiceBox<T>) - Constructor for class javafx.scene.control.skin. ChoiceBoxSkin

创建一个新的ChoiceBoxSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

ChoiceBoxTableCell< S, T> - Class in javafx.scene.control.cell

一个包含TableCell实现的类，在该单元格内绘制一个ChoiceBox节点。

ChoiceBoxTableCell() - Constructor for class javafx.scene.control.cell. ChoiceBoxTableCell

创建一个带有空项目列表的默认ChoiceBoxTableCell。

ChoiceBoxTableCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxTableCell

创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxTableCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxTableCell

创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTableCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxTableCell

创建一个ChoiceBoxTableCell实例，给定的项目用于在显示时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTableCell(T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxTableCell

创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxTreeCell< T> - Class in javafx.scene.control.cell

一个包含一个ListCell实现的类，在该单元格内绘制一个ChoiceBox节点。

ChoiceBoxTreeCell() - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeCell

创建一个带有空项目列表的默认ChoiceBoxTreeCell。

ChoiceBoxTreeCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeCell

创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxTreeCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeCell

创建一个ChoiceBoxTreeCell实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTreeCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeCell

创建一个ChoiceBoxTreeCell实例，给定的项目用于在显示时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTreeCell(T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeCell

创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxTreeTableCell< S, T> - Class in javafx.scene.control.cell

一个包含TreeTableCell实现的类，在该单元格内绘制一个ChoiceBox节点。

ChoiceBoxTreeTableCell() - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeTableCell

创建一个带有空项目列表的默认ChoiceBoxTreeTableCell。

ChoiceBoxTreeTableCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeTableCell

创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxTreeTableCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeTableCell

创建一个ChoiceBoxTreeTableCell实例，给定的项目用于在显示时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTreeTableCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeTableCell

创建一个ChoiceBoxTreeTableCell实例，给定的项目用于在显示时填充ChoiceBox ，而StringConverter用于将项目转换为用户可读的表单。

ChoiceBoxTreeTableCell(T...) - Constructor for class javafx.scene.control.cell. ChoiceBoxTreeTableCell

创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充它。

ChoiceCallback - Class in javax.security.auth.callback

基础安全服务实例，并通过一个 ChoiceCallback至 handle一个方法 CallbackHandler ，以显示选项列表并获取选中的选项（S）。

ChoiceCallback(String, String[], int, boolean) - Constructor for class javax.security.auth.callback. ChoiceCallback

使用提示符，选项列表，默认选项和布尔值构造 ChoiceCallback ，指定是否允许从选项列表中选择多个选项。

ChoiceDialog< T> - Class in javafx.scene.control

一个对话框，向用户显示选择列表，最多可以从中选择一个项目。

ChoiceDialog() - Constructor for class javafx.scene.control. ChoiceDialog

创建一个DefaultDialog的默认空的实例，没有设置项和空默认选项。

ChoiceDialog(T, Collection<T>) - Constructor for class javafx.scene.control. ChoiceDialog

创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选择，第二个参数指定用户的所有可用选项的集合。

ChoiceDialog(T, T...) - Constructor for class javafx.scene.control. ChoiceDialog

创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选项，并且所有以下参数都被视为用户所有可用选项的varargs数组。

ChoiceFormat - Class in java.text

A ChoiceFormat允许您将格式附加到数字范围。

ChoiceFormat(double[], String[]) - Constructor for class java.text. ChoiceFormat

具有限制和相应格式的构造。

ChoiceFormat(String) - Constructor for class java.text. ChoiceFormat

基于模式的限制和相应格式的构造。

choices - Variable in class java.sql. DriverPropertyInfo

如果可以从特定值的值中选择字段值DriverPropertyInfo.value ，则可能值的数组; 否则为空。

choices() - Method in interface com.sun.jdi.connect. Connector.SelectedArgument

返回参数的可能值

chokeProperty() - Method in class javafx.scene.effect. InnerShadow

阴影的cho子。

CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser

标识用户可以选择的预定义文件过滤器列表中的更改。

chooseBestCursor(Image[], double, double) - Static method in class javafx.scene. ImageCursor

从指定的图像之一创建自定义图像光标。

chooseClientAlias(String[], Principal[], Socket) - Method in interface javax.net.ssl. X509KeyManager

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，来认证安全套接字的客户端。

chooseEngineClientAlias(String[], Principal[], SSLEngine) - Method in class javax.net.ssl. X509ExtendedKeyManager

选择别名到的客户端进行身份验证 SSLEngine给出公钥类型和同位体（如果有的话）认可证书发行机构的列表连接。

chooseEngineServerAlias(String, Principal[], SSLEngine) - Method in class javax.net.ssl. X509ExtendedKeyManager

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，鉴定 SSLEngine连接的服务器端。

chooser - Variable in class javax.swing.plaf.basic. BasicColorChooserUI

JColorChooser安装了BasicColorChooserUI。

CHOOSER_PANELS_PROPERTY - Static variable in class javax.swing. JColorChooser

chooserPanel数组属性名称。

chooseServerAlias(String, Principal[], Socket) - Method in interface javax.net.ssl. X509KeyManager

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，对安全套接字的服务器端进行身份验证。

CHORD - javafx.scene.shape. ArcType

通过从弧段开始绘制直线段到弧段的末端，关闭电弧的闭合类型。

CHORD - Static variable in class java.awt.geom. Arc2D

通过从弧段开始绘制直线段到弧段的末端，关闭电弧的闭合类型。

CHOU_1 - Static variable in class javax.print.attribute.standard. MediaSize.JIS

指定JIS Chou（“long”）＃1信封尺寸，142 mm×332 mm。

CHOU_2 - Static variable in class javax.print.attribute.standard. MediaSize.JIS

指定JIS Chou（“long”）＃2信封尺寸，119 mm×277 mm。

CHOU_3 - Static variable in class javax.print.attribute.standard. MediaSize.JIS

指定JIS Chou（“long”）＃3信封尺寸，120 mm×235 mm。

CHOU_30 - Static variable in class javax.print.attribute.standard. MediaSize.JIS

指定JIS Chou（“long”）＃30信封尺寸，92 mm×235 mm。

CHOU_4 - Static variable in class javax.print.attribute.standard. MediaSize.JIS

指定JIS Chou（“long”）＃4信封尺寸，90 mm×205 mm。

CHOU_40 - Static variable in class javax.print.attribute.standard. MediaSize.JIS

指定JIS Chou（“long”）＃40信封尺寸，90 mm×225 mm。

Chromaticity - Class in javax.print.attribute.standard

Class Chromaticity是一个打印属性类，一个枚举，用于指定单色或彩色打印。

Chromaticity(int) - Constructor for class javax.print.attribute.standard. Chromaticity

用给定的整数值构造一个新的色度枚举值。

ChronoField - Enum in java.time.temporal

一套标准的字段。

ChronoLocalDate - Interface in java.time.chrono

一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。

ChronoLocalDateTime< D extends ChronoLocalDate> - Interface in java.time.chrono

在任意年代没有时区的日期时间，用于高级全球化用例。

chronology() - Static method in class java.time.temporal. TemporalQueries

查询 Chronology 。

Chronology - Interface in java.time.chrono

用于组织和识别日期的日历系统。

chronologyProperty() - Method in class javafx.scene.control. DatePicker

用于在DatePicker控件中解析，显示和选择日期的日历系统。

ChronoPeriod - Interface in java.time.chrono

基于日期的时间，例如任意年代的“3年，4个月和5天”，旨在用于高级全球化用例。

ChronoUnit - Enum in java.time.temporal

一组标准的日期单位。

ChronoZonedDateTime< D extends ChronoLocalDate> - Interface in java.time.chrono

具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。

chunkLength - Variable in class java.net. HttpURLConnection

使用分块编码流模式进行输出时的块长度。

Cipher - Class in javax.crypto

该类提供加密和解密的加密密码的功能。

Cipher(CipherSpi, Provider, String) - Constructor for class javax.crypto. Cipher

创建一个Cipher对象。

CipherInputStream - Class in javax.crypto

CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。

CipherInputStream(InputStream) - Constructor for class javax.crypto. CipherInputStream

从InputStream构造CipherInputStream，而不指定密码。

CipherInputStream(InputStream, Cipher) - Constructor for class javax.crypto. CipherInputStream

从InputStream和Cipher构造一个CipherInputStream。

CipherOutputStream - Class in javax.crypto

CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。

CipherOutputStream(OutputStream) - Constructor for class javax.crypto. CipherOutputStream

在不指定密码的情况下，从OutputStream构造CipherOutputStream。

CipherOutputStream(OutputStream, Cipher) - Constructor for class javax.crypto. CipherOutputStream

从OutputStream和Cipher构造一个CipherOutputStream。

CipherSpi - Class in javax.crypto

该类定义了 Cipher类的 （ SPI ）。

CipherSpi() - Constructor for class javax.crypto. CipherSpi

Circle - Class in javafx.scene.shape

Circle类创建一个具有指定半径和中心位置的新圆圈，以像素为单位。

Circle() - Constructor for class javafx.scene.shape. Circle

创建一个空的Circle实例。

Circle(double) - Constructor for class javafx.scene.shape. Circle

用指定的半径创建一个新的Circle实例。

Circle(double, double, double) - Constructor for class javafx.scene.shape. Circle

用指定的位置和半径创建一个新的Circle实例。

Circle(double, double, double, Paint) - Constructor for class javafx.scene.shape. Circle

创建一个新的具有指定位置，半径和填充的Circle实例。

Circle(double, Paint) - Constructor for class javafx.scene.shape. Circle

创建一个新的具有指定半径的Circle实例并填充。

CIRCUMFLEX - javafx.scene.input. KeyCode

常数为“^”键。

CITE - Static variable in class javax.swing.text.html. HTML.Tag

标签<cite>

CJK_COMPATIBILITY - Static variable in class java.lang. Character.UnicodeBlock

常量为“CJK兼容性”Unicode字符块。

CJK_COMPATIBILITY_FORMS - Static variable in class java.lang. Character.UnicodeBlock

“CJK兼容性表单”Unicode字符块的常量。

CJK_COMPATIBILITY_IDEOGRAPHS - Static variable in class java.lang. Character.UnicodeBlock

“CJK兼容性表意符号”Unicode字符块的常量。

CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock

“CJK兼容性表意文字补充”Unicode字符块的常数。

CJK_RADICALS_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock

常数为“CJK Radicals Supplement”Unicode字符块。

CJK_STROKES - Static variable in class java.lang. Character.UnicodeBlock

常量为“CJK笔画”Unicode字符块。

CJK_SYMBOLS_AND_PUNCTUATION - Static variable in class java.lang. Character.UnicodeBlock

常量为“CJK符号和标点符号”Unicode字符块。

CJK_UNIFIED_IDEOGRAPHS - Static variable in class java.lang. Character.UnicodeBlock

“CJK统一表意符号”Unicode字符块的常数。

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A - Static variable in class java.lang. Character.UnicodeBlock

“CJK统一表意扩展A”Unicode字符块的常数。

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B - Static variable in class java.lang. Character.UnicodeBlock

“CJK统一表意扩展B”Unicode字符块的常数。

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C - Static variable in class java.lang. Character.UnicodeBlock

“CJK统一表意扩展C”Unicode字符块的常数。

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D - Static variable in class java.lang. Character.UnicodeBlock

“CJK统一表意扩展D”Unicode字符块的常数。

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_E - Static variable in class java.lang. Character.UnicodeBlock

“CJK统一表意扩展E”Unicode字符块的常数。

Class< T> - Class in java.lang

Class类的实例表示正在运行的Java应用程序中的类和接口。

CLASS - com.sun.source.tree. Tree.Kind

用于表示类的ClassTree的实例。

CLASS - java.lang.annotation. RetentionPolicy

注释将由编译器记录在类文件中，但VM不需要在运行时保留。

CLASS - javax.lang.model.element. ElementKind

一个没有更具体种类描述的课（如 ENUM ）。

CLASS - javax.tools. JavaFileObject.Kind

Java虚拟机的类文件。

CLASS - jdk.nashorn.api.tree. Tree.Kind

用于ClassDeclarationTree的实例。

CLASS - Static variable in interface javax.jnlp. DownloadService2

匹配类文件 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。

CLASS - Static variable in class javax.swing.text.html. HTML.Attribute

属性“类”

CLASS_ABSTRACT - Static variable in class java.awt.color. ICC_Profile

简档类是抽象的。

CLASS_ATTRIBUTE_PFX - Static variable in interface java.util.jar. Pack200.Packer

当与类属性名称连接时，使用JSR 200规范中指定的布局语言来指示该属性的格式。

CLASS_COLORSPACECONVERSION - Static variable in class java.awt.color. ICC_Profile

Profile类是颜色空间的转换。

CLASS_DEVICELINK - Static variable in class java.awt.color. ICC_Profile

配置文件类是设备链接。

CLASS_DISPLAY - Static variable in class java.awt.color. ICC_Profile

Profile类是显示。

CLASS_EXPRESSION - jdk.nashorn.api.tree. Tree.Kind

用于ClassExpressionTree的实例。

CLASS_INPUT - Static variable in class java.awt.color. ICC_Profile

配置文件类是输入。

CLASS_LOADING_MXBEAN_NAME - Static variable in class java.lang.management. ManagementFactory

字符串表示的ObjectName为ClassLoadingMXBean 。

CLASS_NAMEDCOLOR - Static variable in class java.awt.color. ICC_Profile

配置文件类命名为颜色。

CLASS_OUTPUT - javax.tools. StandardLocation

新类文件的位置

CLASS_OUTPUT - Static variable in class java.awt.color. ICC_Profile

配置文件类被输出。

CLASS_PATH - javax.tools. StandardLocation

搜索用户类文件的位置。

CLASS_PATH - Static variable in class java.util.jar. Attributes.Name

Name对象为 Class-Path清单属性。

CLASS_SUBKIND - jdk.jshell. Snippet.SubKind

课堂宣言

classattr() - Static method in class javax.management. Query

返回一个新的类属性表达式，可以在期望使用ValueExp的任何Query调用中使用。

ClassBytecodes(String, byte[]) - Constructor for class jdk.jshell.spi. ExecutionControl.ClassBytecodes

创建一个名称/字节码对。

ClassCastException - Exception in java.lang

抛出表示代码尝试将对象转换为不属于实例的子类。

ClassCastException() - Constructor for exception java.lang. ClassCastException

构造一个 ClassCastException ，没有详细消息。

ClassCastException(String) - Constructor for exception java.lang. ClassCastException

构造具有指定详细消息的 ClassCastException 。

ClassCircularityError - Error in java.lang

当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。

ClassCircularityError() - Constructor for error java.lang. ClassCircularityError

构造一个没有详细消息的 ClassCircularityError 。

ClassCircularityError(String) - Constructor for error java.lang. ClassCircularityError

构造具有指定详细消息的 ClassCircularityError 。

ClassDeclarationTree - Interface in jdk.nashorn.api.tree

一个代表一个 class declaration的树节点。

ClassDefinition - Class in java.lang.instrument

该类作为 Instrumentation.redefineClasses方法的参数块。

ClassDefinition(Class<?>, byte[]) - Constructor for class java.lang.instrument. ClassDefinition

使用提供的类和类文件字节创建一个新的 ClassDefinition绑定。

classDepth(String) - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。

ClassDesc - Class in javax.rmi.CORBA

此类用于通过IIOP来组织java.lang.Class对象。

ClassDesc() - Constructor for class javax.rmi.CORBA. ClassDesc

ClassDoc - Interface in com.sun.javadoc

已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

classEquals(Class<?>, Class<?>) - Static method in class java.beans.beancontext. BeanContextSupport

测试两个类对象或其名称是否相等。

classes() - Method in interface com.sun.javadoc. RootDoc

已过时。

返回所有包中的 included类和接口。

classesByName(String) - Method in interface com.sun.jdi. VirtualMachine

返回与给定名称相匹配的加载引用类型。

classesRedefined(ExecutionControl.ClassBytecodes[]) - Method in class jdk.jshell.execution. DirectExecutionControl

通知类已被重新定义。

classesRedefined(ExecutionControl.ClassBytecodes[]) - Method in interface jdk.jshell.execution. LoaderDelegate

通知类已被重新定义。

ClassExpressionTree - Interface in jdk.nashorn.api.tree

一个代表 class expression的树节点。

classFactory - Variable in class javax.naming. Reference

包含用于创建此引用引用的对象的实例的工厂类的名称。

classFactoryLocation - Variable in class javax.naming. Reference

包含工厂类的位置。

ClassFileTransformer - Interface in java.lang.instrument

类文件的变压器。

ClassFilter - Interface in jdk.nashorn.api.scripting

类别过滤器（可选）由nashorn脚本引擎使用。

ClassFormatError - Error in java.lang

当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。

ClassFormatError() - Constructor for error java.lang. ClassFormatError

构造一个 ClassFormatError ，没有详细消息。

ClassFormatError(String) - Constructor for error java.lang. ClassFormatError

构造具有指定详细消息的 ClassFormatError 。

CLASSID - Static variable in class javax.swing.text.html. HTML.Attribute

属性“classid”

ClassInstallException(String, boolean[]) - Constructor for exception jdk.jshell.spi. ExecutionControl.ClassInstallException

classLoader() - Method in interface com.sun.jdi. ModuleReference

返回此模块的ClassLoaderReference对象。

classLoader() - Method in interface com.sun.jdi. ReferenceType

获取加载与此类型相对应的类的类加载器对象。

ClassLoader - Class in java.lang

类加载器是负责加载类的对象。

ClassLoader() - Constructor for class java.lang. ClassLoader

创建使用一个新的类加载器 ClassLoader该方法返回 getSystemClassLoader()作为父类加载器。

ClassLoader(ClassLoader) - Constructor for class java.lang. ClassLoader

使用指定的父类加载器创建一个新的类加载器进行委派。

ClassLoader(String, ClassLoader) - Constructor for class java.lang. ClassLoader

创建指定名称的新类加载器，并使用指定的父类加载器进行委派。

classLoaderDepth() - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。

ClassLoaderReference - Interface in com.sun.jdi

来自目标VM的类加载器对象。

ClassLoaderRepository - Interface in javax.management.loading

此接口的实例用于保留在MBean服务器中注册的ClassLoaders列表。

ClassLoadingMXBean - Interface in java.lang.management

Java虚拟机的类加载系统的管理界面。

classModifiers() - Static method in class java.lang.reflect. Modifier

返回一个 int值将OR-ing组合在一起可以应用于类的源语言修饰符。

classname - Variable in exception java.io. InvalidClassException

无效类的名称

className - Variable in class javax.naming. Reference

包含此引用引用的对象的类的完全限定名称。

className() - Method in exception com.sun.jdi. ClassNotLoadedException

className() - Method in interface com.sun.jdi.event. ClassUnloadEvent

返回已卸载的类的名称。

classNamed(String) - Method in interface com.sun.javadoc. RootDoc

已过时。

为指定的类或接口名返回ClassDoc。

ClassNotFoundException - Exception in java.lang

的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。

ClassNotFoundException() - Constructor for exception java.lang. ClassNotFoundException

构造一个 ClassNotFoundException ，没有详细消息。

ClassNotFoundException(String) - Constructor for exception java.lang. ClassNotFoundException

构造具有指定详细消息的 ClassNotFoundException 。

ClassNotFoundException(String, Throwable) - Constructor for exception java.lang. ClassNotFoundException

构造一个 ClassNotFoundException其中包含指定的详细消息和加载类时引发的可选异常。

ClassNotLoadedException - Exception in com.sun.jdi

抛出，表示请求的类尚未通过适当的类加载器加载。

ClassNotLoadedException(String) - Constructor for exception com.sun.jdi. ClassNotLoadedException

ClassNotLoadedException(String, String) - Constructor for exception com.sun.jdi. ClassNotLoadedException

ClassNotPreparedException - Exception in com.sun.jdi

抛出以指示由于指定的类尚未准备而请求的操作无法完成。

ClassNotPreparedException() - Constructor for exception com.sun.jdi. ClassNotPreparedException

ClassNotPreparedException(String) - Constructor for exception com.sun.jdi. ClassNotPreparedException

classObject() - Method in interface com.sun.jdi. ReferenceType

返回与目标VM中此类型对应的类对象。

ClassObjectReference - Interface in com.sun.jdi

来自目标VM的java.lang.Class实例。

classPath() - Method in interface com.sun.jdi. PathSearchingVirtualMachine

获取此虚拟机的类路径。

ClassPrepareEvent - Interface in com.sun.jdi.event

在目标虚拟机中通知类准备。

ClassPrepareRequest - Interface in com.sun.jdi.request

在目标虚拟机中准备课程时请求通知。

classPrepareRequests() - Method in interface com.sun.jdi.request. EventRequestManager

返回启用和禁用的类准备请求的不可修改的列表。

classSignature() - Method in interface com.sun.jdi.event. ClassUnloadEvent

返回已卸载的类的JNI样式签名。

ClassTree - Interface in com.sun.source.tree

用于类，接口，枚举或注释类型声明的树节点。

ClassType - Interface in com.sun.jdi

目标VM中的类的镜像。

ClassUnloadEvent - Interface in com.sun.jdi.event

在目标VM中卸载类的通知。

ClassUnloadRequest - Interface in com.sun.jdi.request

在目标虚拟机中卸载类时请求通知。

classUnloadRequests() - Method in interface com.sun.jdi.request. EventRequestManager

返回启用和禁用的类卸载请求的不可修改的列表。

ClassValue< T> - Class in java.lang

将计算的值与（潜在地）每种类型相关联。

ClassValue() - Constructor for class java.lang. ClassValue

唯一的构造函数。

clean() - Method in interface java.lang.ref. Cleaner.Cleanable

取消注册可清洁并调用清洁操作。

clean(ObjID[], long, VMID, boolean) - Method in interface java.rmi.dgc. DGC

干净的呼叫从'id'中指示的每个远程对象的引用列表中删除'vmid'。

CLEAN_FAX_DATA_ERRORS_CORRECTED - Static variable in class javax.imageio.plugins.tiff. FaxTIFFTagSet

与“CleanFaxData”标签一起使用的值。

CLEAN_FAX_DATA_ERRORS_UNCORRECTED - Static variable in class javax.imageio.plugins.tiff. FaxTIFFTagSet

与“CleanFaxData”标签一起使用的值。

CLEAN_FAX_DATA_NO_ERRORS - Static variable in class javax.imageio.plugins.tiff. FaxTIFFTagSet

与“CleanFaxData”标签一起使用的值。

Cleaner - Class in java.lang.ref

Cleaner管理一组对象引用和相应的清理动作。

Cleaner.Cleanable - Interface in java.lang.ref

Cleanable表示在 Cleaner登记的对象和清理动作。

clear() - Method in class com.sun.net.httpserver. Headers

clear() - Method in class java.awt. List

已过时。
从JDK 1.1版开始，由removeAll()替代。

clear() - Method in class java.awt. RenderingHints

清除所有键/值对的这个 RenderingHints对象。

clear() - Method in class java.beans.beancontext. BeanContextSupport

清除子层（不支持）实现必须在层次结构锁和“children”保护字段上同步

clear() - Method in class java.lang.ref. Reference

清除此参考对象。

clear() - Method in class java.nio. Buffer

清除此缓冲区。

clear() - Method in class java.nio. ByteBuffer

清除此缓冲区。

clear() - Method in class java.nio. CharBuffer

清除此缓冲区。

clear() - Method in class java.nio. DoubleBuffer

清除此缓冲区。

clear() - Method in class java.nio. FloatBuffer

清除此缓冲区。

clear() - Method in class java.nio. IntBuffer

清除此缓冲区。

clear() - Method in class java.nio. LongBuffer

清除此缓冲区。

clear() - Method in class java.nio. MappedByteBuffer

清除此缓冲区。

clear() - Method in class java.nio. ShortBuffer

清除此缓冲区。

clear() - Method in class java.security. Provider

清除此提供程序，使其不再包含用于查找由提供程序实施的设施的属性。

clear() - Method in class java.util. AbstractCollection

从此集合中删除所有元素（可选操作）。

clear() - Method in class java.util. AbstractList

从此列表中删除所有元素（可选操作）。

clear() - Method in class java.util. AbstractMap

从该地图中删除所有的映射（可选操作）。

clear() - Method in class java.util. AbstractQueue

从此队列中删除所有元素。

clear() - Method in class java.util. ArrayDeque

从这个deque中删除所有的元素。

clear() - Method in class java.util. ArrayList

从列表中删除所有元素。

clear() - Method in class java.util. BitSet

将该BitSet中的所有位设置为 false 。

clear() - Method in class java.util. Calendar

将所有的日历字段值和时间值（毫秒从偏移 Epoch如此） Calendar不确定。

clear() - Method in interface java.util. Collection

从此集合中删除所有元素（可选操作）。

clear() - Method in class java.util.concurrent. ArrayBlockingQueue

从这个队列中原子地删除所有的元素。

clear() - Method in class java.util.concurrent. ConcurrentHashMap

从这张地图中删除所有的映射。

clear() - Method in class java.util.concurrent. ConcurrentLinkedDeque

从这个deque中删除所有的元素。

clear() - Method in class java.util.concurrent. ConcurrentLinkedQueue

clear() - Method in class java.util.concurrent. ConcurrentSkipListMap

从这张地图中删除所有的映射。

clear() - Method in class java.util.concurrent. ConcurrentSkipListSet

从此集合中删除所有元素。

clear() - Method in class java.util.concurrent. CopyOnWriteArrayList

从列表中删除所有元素。

clear() - Method in class java.util.concurrent. CopyOnWriteArraySet

从此集合中删除所有元素。

clear() - Method in class java.util.concurrent. DelayQueue

从此延迟队列中原子地删除所有元素。

clear() - Method in class java.util.concurrent. LinkedBlockingDeque

从这个deque原子地删除所有的元素。

clear() - Method in class java.util.concurrent. LinkedBlockingQueue

从这个队列中原子地删除所有的元素。

clear() - Method in class java.util.concurrent. LinkedTransferQueue

clear() - Method in class java.util.concurrent. PriorityBlockingQueue

从这个队列中原子地删除所有的元素。

clear() - Method in class java.util.concurrent. SynchronousQueue

什么也没做。

clear() - Method in class java.util. EnumMap

从此地图中删除所有的映射。

clear() - Method in class java.util. HashMap

从这张地图中删除所有的映射。

clear() - Method in class java.util. HashSet

从此集合中删除所有元素。

clear() - Method in class java.util. Hashtable

清除此散列表，使其不包含键。

clear() - Method in class java.util. IdentityHashMap

从这张地图中删除所有的映射。

clear() - Method in class java.util.jar. Attributes

从此地图中删除所有属性。

clear() - Method in class java.util.jar. Manifest

清除主要属性以及此清单中的条目。

clear() - Method in class java.util. LinkedHashMap

从这张地图中删除所有的映射。

clear() - Method in class java.util. LinkedList

从列表中删除所有元素。

clear() - Method in interface java.util. List

从此列表中删除所有元素（可选操作）。

clear() - Method in class java.util. Locale.Builder

将构建器重置为初始状态。

clear() - Method in interface java.util. Map

从该地图中删除所有的映射（可选操作）。

clear() - Method in class java.util.prefs. AbstractPreferences

实现 clear方法按照在本说明书中 Preferences.clear() 。

clear() - Method in class java.util.prefs. Preferences

删除此首选项节点中的所有首选项（键值关联）。

clear() - Method in class java.util. PriorityQueue

从此优先级队列中删除所有元素。

clear() - Method in class java.util. Properties

clear() - Method in interface java.util. Set

从此集合中删除所有元素（可选操作）。

clear() - Method in class java.util. TreeMap

从这张地图中删除所有的映射。

clear() - Method in class java.util. TreeSet

从此集合中删除所有元素。

clear() - Method in class java.util. Vector

从此Vector中删除所有元素。

clear() - Method in class java.util. WeakHashMap

从这张地图中删除所有的映射。

clear() - Method in class javafx.beans.binding. ListExpression

clear() - Method in class javafx.beans.binding. MapExpression

clear() - Method in class javafx.beans.binding. SetExpression

clear() - Method in interface javafx.collections. ObservableArray

通过将其调整为0来清空数组。

clear() - Method in class javafx.scene.control. TextInputControl

清除文本。

clear() - Method in class javafx.scene.input. Clipboard

清除任何和所有内容的剪贴板。

clear() - Method in class javax.accessibility. AccessibleRelationSet

从当前关系集中删除所有关系。

clear() - Method in class javax.accessibility. AccessibleStateSet

从当前状态集中删除所有状态。

clear() - Method in interface javax.management.openmbean. TabularData

从此 TabularData实例中删除所有 CompositeData值（即行）。

clear() - Method in class javax.management.openmbean. TabularDataSupport

从此 TabularDataSupport实例中删除所有行。

clear() - Method in interface javax.naming.directory. Attribute

从此属性中删除所有值。

clear() - Method in class javax.naming.directory. BasicAttribute

clear() - Method in class javax.naming. Reference

从此引用中删除所有地址。

clear() - Method in interface javax.print.attribute. AttributeSet

从该属性集中删除所有属性。

clear() - Method in class javax.print.attribute. HashAttributeSet

从该属性集中删除所有属性。

clear() - Method in class javax.script. SimpleBindings

从该地图中删除所有的映射（可选操作）。

clear() - Method in class javax.swing. ActionMap

从这个 ActionMap删除所有的映射。

clear() - Method in class javax.swing. ComponentInputMap

从此对象中删除所有映射。

clear() - Method in class javax.swing. DefaultListModel

从列表中删除所有元素。

clear() - Method in class javax.swing. InputMap

从这个 InputMap删除所有的映射。

clear() - Method in class javax.xml.datatype. XMLGregorianCalendar

取消设置所有字段为undefined。

clear() - Method in class jdk.incubator.http. MultiMapResult

clear() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

clear() - Method in class org.omg.CORBA. Environment

清除此 Environment异常的对象。

clear() - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

清除属性列表。

clear() - Method in class org.xml.sax.helpers. AttributesImpl

清除属性列表以供重用。

clear(int) - Method in class java.util. BitSet

将索引指定的位设置为 false 。

clear(int) - Method in class java.util. Calendar

设置给定日历字段值和时间值（毫秒从偏移 Epoch如此） Calendar不确定。

clear(int, int) - Method in class java.util. BitSet

将指定的 fromIndex （含）的位设置为 toIndex （排他）到 false 。

Clear - Static variable in class java.awt. AlphaComposite

AlphaComposite对象实现不透明的CLEAR规则，其alpha为1.0f。

CLEAR - javafx.scene.input. KeyCode

常数为 Clear键。

CLEAR - Static variable in class java.awt. AlphaComposite

目的地的颜色和alpha都被清除（Porter-Duff Clear规则）。

CLEAR - Static variable in class javax.swing.text.html. CSS.Attribute

CSS属性“清除”。

CLEAR - Static variable in class javax.swing.text.html. HTML.Attribute

属性“清除”

CLEAR_GLOBAL_FOCUS_OWNER - java.awt.event. FocusEvent.Cause

清理全球焦点所有者。

clearAbortRequest() - Method in class javax.imageio. ImageReader

清除任何先前的中止请求。

clearAbortRequest() - Method in class javax.imageio. ImageWriter

清除任何先前的中止请求。

clearAccessibleSelection() - Method in class java.awt. List.AccessibleAWTList

清除对象中的选择，以便选择对象中的任何内容。

clearAccessibleSelection() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

清除对象中的选择，以使对象中没有子对象被选中。

clearAccessibleSelection() - Method in interface javax.accessibility. AccessibleSelection

清除对象中的选择，以使对象中没有子对象被选中。

clearAccessibleSelection() - Method in class javax.swing. JComboBox.AccessibleJComboBox

清除对象中的选择，以使对象中没有子对象被选中。

clearAccessibleSelection() - Method in class javax.swing. JList.AccessibleJList

清除对象中的选择，以便选择对象中的任何内容。

clearAccessibleSelection() - Method in class javax.swing. JMenu.AccessibleJMenu

清除对象中的选择，以便选择对象中的任何内容。

clearAccessibleSelection() - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

清除对象中的选择，以便选择对象中的任何内容。

clearAccessibleSelection() - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

clearAccessibleSelection() - Method in class javax.swing. JTable.AccessibleJTable

清除对象中的选择，以使对象中没有子对象被选中。

clearAccessibleSelection() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

清除对象中的选择，以便选择对象中的任何内容。

clearAccessibleSelection() - Method in class javax.swing. JTree.AccessibleJTree

清除对象中的选择，以便选择对象中的任何内容。

clearAndSelect(int) - Method in class javafx.scene.control. SelectionModel

在将选择设置为给定索引之前清除任何选择的方法。

clearAndSelect(int) - Method in class javafx.scene.control. SingleSelectionModel

在SingleSelectionModel中，此方法在功能上等同于调用 select(index) ，因为一次只允许一个选择。

clearAndSelect(int, TableColumn<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

清除所有选择，然后选择给定行/列交点处的单元格。

clearAndSelect(int, TableColumnBase<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

清除所有选择，然后选择给定行/列交点处的单元格。

clearAndSelect(int, TableColumnBase<T, ?>) - Method in class javafx.scene.control. TableSelectionModel

清除所有选择，然后选择给定行/列交点处的单元格。

clearAssertionStatus() - Method in class java.lang. ClassLoader

将此类加载器的默认断言状态设置为 false并丢弃与类加载器相关联的任何包默认值或类断言状态设置。

clearAutoscroll() - Method in class java.awt.dnd. DropTarget

清除自动滚动

clearBatch() - Method in interface java.sql. Statement

清空此 Statement对象的当前SQL命令列表。

clearBit(int) - Method in class java.math. BigInteger

返回一个BigInteger，其值等于此BigInteger，指定的位被清零。

clearCache() - Static method in class java.util. ResourceBundle

从缓存中删除已由调用者模块加载的所有资源束。

clearCache() - Static method in class javafx.css.converter. EffectConverter

clearCache() - Static method in class javafx.css.converter. ShapeConverter

clearCache() - Static method in class javafx.css. StyleConverter

清除缓存。

clearCache(ClassLoader) - Static method in class java.util. ResourceBundle

从缓存中删除由给定的类加载器加载的所有资源束。

clearChanged() - Method in class java.util. Observable

已过时。

表示此对象已不再更改，或已经通知其所有观察者其最近更改，因此 hasChanged方法现在将返回 false 。

clearConstraints(Node) - Static method in class javafx.scene.layout. AnchorPane

从子节点中删除所有锚窗格约束。

clearConstraints(Node) - Static method in class javafx.scene.layout. BorderPane

从子节点中删除所有边框窗格约束。

clearConstraints(Node) - Static method in class javafx.scene.layout. FlowPane

从子节点中删除所有flowpane约束。

clearConstraints(Node) - Static method in class javafx.scene.layout. GridPane

从子节点中删除所有网格框约束。

clearConstraints(Node) - Static method in class javafx.scene.layout. HBox

从子节点中删除所有hbox约束。

clearConstraints(Node) - Static method in class javafx.scene.layout. StackPane

从子节点中删除所有stackpane约束。

clearConstraints(Node) - Static method in class javafx.scene.layout. TilePane

从子节点中删除所有瓦楞纸板约束。

clearConstraints(Node) - Static method in class javafx.scene.layout. VBox

从子节点中删除所有vbox约束。

clearContent() - Method in class javax.xml.soap. AttachmentPart

清除此 AttachmentPart对象的内容。

clearError() - Method in class java.io. PrintStream

清除此流的内部错误状态。

clearError() - Method in class java.io. PrintWriter

清除此流的错误状态。

clearExtensions() - Method in class java.util. Locale.Builder

将扩展名重置为初始，空状态。

clearFocusOwner() - Method in class java.awt. KeyboardFocusManager

如果焦点所有者存在并驻留在与调用线程相同的上下文中，则清除Java和本机级别的焦点所有者，否则该方法将静默返回。

clearGlobalFocusOwner() - Method in class java.awt. KeyboardFocusManager

在Java和本机级别清除全局焦点所有者。

clearIconCache() - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

清除图标缓存。

clearIconCache() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

清除图标缓存。

clearParameters() - Method in interface java.sql. PreparedStatement

立即清除当前参数值。

clearParameters() - Method in class javax.sql.rowset. BaseRowSet

清除此 RowSet对象在执行此 RowSet对象的命令时要设置的参数的内部表示形式中的所有当前参数值。

clearParameters() - Method in interface javax.sql. RowSet

清除为此 RowSet对象的命令设置的参数。

clearParameters() - Method in class javax.xml.transform. Transformer

清除所有使用setParameter设置的参数。

clearPassword() - Method in class javax.crypto.spec. PBEKeySpec

清除密码的内部副本。

clearPassword() - Method in class javax.security.auth.callback. PasswordCallback

清除检索到的密码。

clearProperty(String) - Static method in class java.lang. System

删除指定键指定的系统属性。

clearRect(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

用透明颜色值清除画布的一部分。

clearRect(int, int, int, int) - Method in class java.awt. Graphics

通过填充当前图形表面的背景颜色来清除指定的矩形。

clearRect(int, int, int, int) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.clearRect 。

clearSelectedPath() - Method in class javax.swing. MenuSelectionManager

告诉菜单选择关闭并取消选择所有菜单组件。

clearSelection() - Method in class javafx.scene.control. SelectionModel

清除所有选定索引的选择模型。

clearSelection() - Method in class javafx.scene.control. SingleSelectionModel

清除所有选定索引的选择模型。

clearSelection() - Method in class javax.swing. ButtonGroup

清除选择，使得不选择 ButtonGroup中的任何按钮。

clearSelection() - Method in class javax.swing. DefaultListSelectionModel

将选择更改为空集。

clearSelection() - Method in class javax.swing. DefaultSingleSelectionModel

清除选择（至-1）。

clearSelection() - Method in class javax.swing. JList

清除选择; 调用此方法后， isSelectionEmpty将返回true 。

clearSelection() - Method in class javax.swing. JTable

取消选择所有选定的列和行。

clearSelection() - Method in class javax.swing. JTree

清除选择。

clearSelection() - Method in interface javax.swing. ListSelectionModel

将选择更改为空集。

clearSelection() - Method in interface javax.swing. SingleSelectionModel

清除选择（至-1）。

clearSelection() - Method in class javax.swing.tree. DefaultTreeSelectionModel

清空当前的选择。

clearSelection() - Method in interface javax.swing.tree. TreeSelectionModel

清空当前的选择。

clearSelection(int) - Method in class javafx.scene.control. SelectionModel

该方法将清除给定索引中项目的选择。

clearSelection(int) - Method in class javafx.scene.control. SingleSelectionModel

清除给定索引的选择，如果它当前被选中。

clearSelection(int, TableColumn<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

从指定的行/列位置（视图索引）中移除选择。

clearSelection(int, TableColumnBase<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

从指定的行/列位置（视图索引）中移除选择。

clearSelection(int, TableColumnBase<T, ?>) - Method in class javafx.scene.control. TableSelectionModel

从指定的行/列位置（视图索引）中移除选择。

clearTextShiftOffset() - Method in class javax.swing.plaf.basic. BasicButtonUI

清除文本的偏移量。

clearToggledPaths() - Method in class javax.swing. JTree

清除切换树路径的缓存。

clearWarnings() - Method in interface java.sql. Connection

清除为此 Connection对象报告的所有警告。

clearWarnings() - Method in interface java.sql. ResultSet

清除此 ResultSet对象上报告的所有警告。

clearWarnings() - Method in interface java.sql. Statement

清除所有在此 Statement对象上报告的警告。

click() - Method in interface org.w3c.dom.html. HTMLInputElement

模拟鼠标点击。

CLICK - Static variable in interface javax.accessibility. AccessibleAction

使组件执行其默认操作的操作。

clickCount - Variable in class java.awt. Event

已过时。

对于 MOUSE_DOWN事件，此字段指示连续点击次数。

clickCountToStart - Variable in class javax.swing. DefaultCellEditor

一个整数，指定开始编辑所需的点击次数。

clientClosed(RMIConnection) - Method in class javax.management.remote.rmi. RMIServerImpl

当由 makeClient创建的客户端连接关闭时调用的方法。

clientCodeEnter() - Method in class jdk.jshell.execution. DirectExecutionControl

标记输入用户代码。

clientCodeEnter() - Method in class jdk.jshell.execution. LocalExecutionControl

clientCodeEnter() - Method in class jdk.jshell.execution. RemoteExecutionControl

clientCodeLeave() - Method in class jdk.jshell.execution. DirectExecutionControl

标记离开用户代码。

clientCodeLeave() - Method in class jdk.jshell.execution. LocalExecutionControl

clientCodeLeave() - Method in class jdk.jshell.execution. RemoteExecutionControl

ClientInfoStatus - Enum in java.sql

通过拨打 Connection.setClientInfo无法设置属性的状态的枚举

ClientRequestInfo - Interface in org.omg.PortableInterceptor

请求信息，客户端请求拦截器可访问。

ClientRequestInfoOperations - Interface in org.omg.PortableInterceptor

请求信息，客户端请求拦截器可访问。

ClientRequestInterceptor - Interface in org.omg.PortableInterceptor

客户端请求拦截器。

ClientRequestInterceptorOperations - Interface in org.omg.PortableInterceptor

客户端请求拦截器。

clip() - Method in class javafx.scene.canvas. GraphicsContext

使用当前路径相交当前的剪辑并将其作为抗锯齿掩码应用到后续渲染操作。

clip(Shape) - Method in class java.awt. Graphics2D

将当前的 Clip与内部指定的 Shape ，并将 Clip设置为 Clip的交点。

Clip - Interface in javax.sound.sampled

Clip接口表示一种特殊类型的数据线，其音频数据可以在播放之前加载，而不是实时流式传输。

CLIP - javafx.scene.control. OverrunStyle

任何超过标签范围的文本都将被剪切。

Clipboard - Class in java.awt.datatransfer

实现使用剪切/复制/粘贴操作传输数据的机制的类。

Clipboard - Class in javafx.scene.input

表示操作系统剪贴板，数据可能在例如剪切，复制和粘贴操作期间放置。

Clipboard(String) - Constructor for class java.awt.datatransfer. Clipboard

创建剪贴板对象。

ClipboardContent - Class in javafx.scene.input

数据容器Clipboard数据。

ClipboardContent() - Constructor for class javafx.scene.input. ClipboardContent

ClipboardOwner - Interface in java.awt.datatransfer

定义将向剪贴板提供数据的类的接口。

ClipboardService - Interface in javax.jnlp

ClipboardService提供了访问共享系统范围的剪贴板的方法，即使是在不受信任的执行环境中运行的应用程序。

clipProperty() - Method in class javafx.scene. Node

指定一个 Node用于定义此节点的剪切形状。

clipRect(int, int, int, int) - Method in class java.awt. Graphics

用指定的矩形相交当前的剪辑。

clipRect(int, int, int, int) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.clipRect 。

Clob - Interface in java.sql

在Java的编程语言中映射为SQL CLOB类型。

CLOB - java.sql. JDBCType

标识通用SQL类型 CLOB 。

CLOB - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 CLOB 。

Clock - Class in java.time

使用时区提供对当前即时，日期和时间的访问的时钟。

Clock() - Constructor for class java.time. Clock

子类可访问的构造方法。

CLOCK_HOUR_OF_AMPM - java.time.temporal. ChronoField

上午的时钟小时。

CLOCK_HOUR_OF_DAY - java.time.temporal. ChronoField

时钟的一天。

clockSequence() - Method in class java.util. UUID

与该UUID相关联的时钟序列值。

clockwiseProperty() - Method in class javafx.scene.chart. PieChart

如果真的，我们从startAngle开始顺时针放置切片

clone() - Method in class java.awt. BufferCapabilities

clone() - Method in class java.awt.datatransfer. DataFlavor

返回此 DataFlavor的克隆。

clone() - Method in class java.awt.font. TextLayout

创建一个这个 TextLayout的副本。

clone() - Method in class java.awt.font. TextMeasurer

clone() - Method in class java.awt.geom. AffineTransform

返回此 AffineTransform对象的副本。

clone() - Method in class java.awt.geom. Area

返回此 Area对象的精确副本。

clone() - Method in class java.awt.geom. CubicCurve2D

创建与此对象相同类的新对象。

clone() - Method in class java.awt.geom. Dimension2D

创建与此对象相同类的新对象。

clone() - Method in class java.awt.geom. Line2D

创建与此对象相同类的新对象。

clone() - Method in class java.awt.geom. Path2D

创建与此对象相同类的新对象。

clone() - Method in class java.awt.geom. Path2D.Double

创建与此对象相同类的新对象。

clone() - Method in class java.awt.geom. Path2D.Float

创建与此对象相同类的新对象。

clone() - Method in class java.awt.geom. Point2D

创建与该对象相同的类和新内容相同的新对象。

clone() - Method in class java.awt.geom. QuadCurve2D

创建与该对象相同的类和新内容相同的新对象。

clone() - Method in class java.awt.geom. RectangularShape

创建与该对象相同的类和新内容相同的新对象。

clone() - Method in class java.awt. GridBagConstraints

创建此网格包约束的副本。

clone() - Method in class java.awt.image. ImageFilter

克隆这个对象。

clone() - Method in class java.awt.image. Kernel

克隆这个对象。

clone() - Method in class java.awt.image.renderable. ParameterBlock

创建一个 ParameterBlock的副本。

clone() - Method in class java.awt.image.renderable. RenderContext

制作RenderContext的副本。

clone() - Method in class java.awt. ImageCapabilities

clone() - Method in class java.awt. Insets

创建此对象的副本。

clone() - Method in class java.awt. JobAttributes

创建并返回此 JobAttributes的副本。

clone() - Method in class java.awt. PageAttributes

创建并返回此PageAttributes的副本。

clone() - Method in class java.awt.print. PageFormat

制作 PageFormat的副本，内容与此 PageFormat相同。

clone() - Method in class java.awt.print. Paper

创建一个 Paper的副本，内容与这个 Paper相同。

clone() - Method in class java.awt. RenderingHints

创建此的克隆 RenderingHints具有相同的内容，因为这对象 RenderingHints对象。

clone() - Method in class java.lang. Enum

抛出CloneNotSupportedException。

clone() - Method in class java.lang. Object

创建并返回此对象的副本。

clone() - Method in class java.lang. Thread

将CloneNotSupportedException作为线程抛出无法有意义地克隆。

clone() - Method in class java.net. HttpCookie

创建并返回此对象的副本。

clone() - Method in class java.rmi.server. UnicastRemoteObject

返回与原始对象不同的远程对象的克隆。

clone() - Method in interface java.security.acl. AclEntry

已过时。

克隆此ACL条目。

clone() - Method in interface java.security.cert. CertPathBuilderResult

复制一份这个 CertPathBuilderResult 。

clone() - Method in interface java.security.cert. CertPathParameters

复制一份这个 CertPathParameters 。

clone() - Method in interface java.security.cert. CertPathValidatorResult

复制一份这个 CertPathValidatorResult 。

clone() - Method in interface java.security.cert. CertSelector

做一个这个 CertSelector的副本。

clone() - Method in interface java.security.cert. CertStoreParameters

复制一份这个 CertStoreParameters 。

clone() - Method in class java.security.cert. CollectionCertStoreParameters

返回此对象的副本。

clone() - Method in interface java.security.cert. CRLSelector

复制这份 CRLSelector 。

clone() - Method in class java.security.cert. LDAPCertStoreParameters

返回此对象的副本。

clone() - Method in class java.security.cert. PKIXCertPathChecker

返回此对象的克隆。

clone() - Method in class java.security.cert. PKIXCertPathValidatorResult

返回此对象的副本。

clone() - Method in class java.security.cert. PKIXParameters

PKIXParameters这个 PKIXParameters对象。

clone() - Method in class java.security.cert. PKIXRevocationChecker

clone() - Method in class java.security.cert. URICertStoreParameters

返回此对象的副本。

clone() - Method in class java.security.cert. X509CertSelector

返回此对象的副本。

clone() - Method in class java.security.cert. X509CRLSelector

返回此对象的副本。

clone() - Method in class java.security. MessageDigest

如果实现是可克隆的，则返回克隆。

clone() - Method in class java.security. MessageDigestSpi

如果实现是可克隆的，则返回克隆。

clone() - Method in class java.security. Signature

如果实现是可克隆的，则返回克隆。

clone() - Method in class java.security. SignatureSpi

如果实现是可克隆的，则返回克隆。

clone() - Method in class java.text. BreakIterator

创建一个这个迭代器的副本

clone() - Method in interface java.text. CharacterIterator

创建一个这个迭代器的副本

clone() - Method in class java.text. ChoiceFormat

覆盖可克隆

clone() - Method in class java.text. Collator

覆盖可克隆

clone() - Method in class java.text. DateFormat

覆盖可克隆

clone() - Method in class java.text. DateFormatSymbols

覆盖可克隆

clone() - Method in class java.text. DecimalFormat

标准覆盖 语义不变。

clone() - Method in class java.text. DecimalFormatSymbols

标准覆盖。

clone() - Method in class java.text. Format

创建并返回此对象的副本。

clone() - Method in class java.text. MessageFormat

创建并返回此对象的副本。

clone() - Method in class java.text. NumberFormat

覆盖可克隆。

clone() - Method in class java.text. RuleBasedCollator

标准覆盖 语义不变。

clone() - Method in class java.text. SimpleDateFormat

创建一个这个 SimpleDateFormat的副本。

clone() - Method in class java.text. StringCharacterIterator

创建此迭代器的副本。

clone() - Method in class java.util. AbstractMap

返回此 AbstractMap实例的浅拷贝：键和值本身不被克隆。

clone() - Method in class java.util. ArrayDeque

返回此deque的副本。

clone() - Method in class java.util. ArrayList

返回此 ArrayList实例的浅层副本。

clone() - Method in class java.util. BitSet

克隆 BitSet产生一个新的 BitSet等于它。

clone() - Method in class java.util. Calendar

创建并返回此对象的副本。

clone() - Method in class java.util.concurrent. ConcurrentSkipListMap

返回此 ConcurrentSkipListMap实例的浅拷贝。

clone() - Method in class java.util.concurrent. ConcurrentSkipListSet

返回此 ConcurrentSkipListSet实例的浅拷贝。

clone() - Method in class java.util.concurrent. CopyOnWriteArrayList

返回此列表的浅层副本。

clone() - Method in class java.util. Date

返回此对象的副本。

clone() - Method in class java.util. EnumMap

返回此枚举映射的浅拷贝。

clone() - Method in class java.util. EnumSet

返回此集合的副本。

clone() - Method in class java.util. GregorianCalendar

clone() - Method in class java.util. HashMap

返回此 HashMap实例的浅拷贝：键和值本身不被克隆。

clone() - Method in class java.util. HashSet

返回此 HashSet实例的浅拷贝：元素本身不被克隆。

clone() - Method in class java.util. Hashtable

创建这个散列表的浅拷贝。

clone() - Method in class java.util. IdentityHashMap

返回此标识哈希映射的浅拷贝：键和值本身不被克隆。

clone() - Method in class java.util.jar. Attributes

返回属性的副本，实现如下：

clone() - Method in class java.util.jar. Manifest

返回此清单的浅层副本。

clone() - Method in class java.util. LinkedList

返回此 LinkedList的浅拷贝。

clone() - Method in class java.util. Locale

覆盖可克隆。

clone() - Method in class java.util. Properties

clone() - Method in class java.util. SimpleTimeZone

返回此 SimpleTimeZone实例的克隆。

clone() - Method in class java.util. TimeZone

创建一个这个 TimeZone的副本。

clone() - Method in class java.util. TreeMap

返回此 TreeMap实例的浅拷贝。

clone() - Method in class java.util. TreeSet

返回此 TreeSet实例的浅拷贝。

clone() - Method in class java.util. Vector

返回此向量的克隆。

clone() - Method in class java.util.zip. ZipEntry

返回此条目的副本。

clone() - Method in class javafx.event. Event

创建并返回此 Event的副本。

clone() - Method in class javafx.scene.control. TextFormatter.Change

clone() - Method in class javafx.scene.transform. Affine

clone() - Method in class javafx.scene.transform. Rotate

clone() - Method in class javafx.scene.transform. Scale

clone() - Method in class javafx.scene.transform. Shear

clone() - Method in class javafx.scene.transform. Transform

返回此转换的深层副本。

clone() - Method in class javafx.scene.transform. Translate

clone() - Method in class javax.crypto. Mac

如果提供程序实现是可克隆的，则返回克隆。

clone() - Method in class javax.crypto. MacSpi

如果实现是可克隆的，则返回克隆。

clone() - Method in class javax.imageio.plugins.tiff. TIFFDirectory

克隆目录及其中包含的所有字段。

clone() - Method in class javax.imageio.plugins.tiff. TIFFField

克隆该字段及其中包含的所有信息。

clone() - Method in interface javax.management. Descriptor

返回一个等于该描述符的描述符。

clone() - Method in class javax.management. ImmutableDescriptor

返回一个等于该描述符的描述符。

clone() - Method in class javax.management. MBeanAttributeInfo

返回此实例的浅克隆。

clone() - Method in class javax.management. MBeanConstructorInfo

返回此实例的浅克隆。

clone() - Method in class javax.management. MBeanInfo

返回此实例的浅克隆。

clone() - Method in class javax.management. MBeanNotificationInfo

返回此实例的浅克隆。

clone() - Method in class javax.management. MBeanOperationInfo

返回此实例的浅克隆。

clone() - Method in class javax.management. MBeanParameterInfo

返回此实例的浅克隆。

clone() - Method in class javax.management.modelmbean. DescriptorSupport

返回与描述符重复的新描述符。

clone() - Method in class javax.management.modelmbean. ModelMBeanAttributeInfo

创建并返回一个新的ModelMBeanAttributeInfo，它与此ModelMBeanAttributeInfo重复。

clone() - Method in class javax.management.modelmbean. ModelMBeanConstructorInfo

创建并返回一个新的ModelMBeanConstructorInfo，它与此ModelBeanConstructorInfo重复。

clone() - Method in interface javax.management.modelmbean. ModelMBeanInfo

创建并返回此对象的副本。

clone() - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

返回此实例的浅克隆。

clone() - Method in class javax.management.modelmbean. ModelMBeanNotificationInfo

创建并返回一个新的ModelMBeanNotificationInfo，它与此ModelMBeanNotificationInfo重复。

clone() - Method in class javax.management.modelmbean. ModelMBeanOperationInfo

创建并返回一个与此ModelMBeanOperationInfo重复的新ModelMBeanOperationInfo。

clone() - Method in class javax.management.openmbean. TabularDataSupport

返回此 TabularDataSupport实例的克隆：通过调用 super.clone()获取克隆，然后克隆基础映射。

clone() - Method in class javax.management.relation. Role

克隆角色对象。

clone() - Method in class javax.management.relation. RoleUnresolved

克隆这个对象。

clone() - Method in class javax.naming. CompositeName

生成此复合名称的副本。

clone() - Method in class javax.naming. CompoundName

创建此复合名称的副本。

clone() - Method in interface javax.naming.directory. Attribute

制作属性的副本。

clone() - Method in interface javax.naming.directory. Attributes

创建属性集的副本。

clone() - Method in class javax.naming.directory. BasicAttribute

clone() - Method in class javax.naming.directory. BasicAttributes

clone() - Method in class javax.naming.ldap. LdapName

生成一个这个名字的新副本。

clone() - Method in interface javax.naming. Name

生成一个这个名字的新副本。

clone() - Method in class javax.naming. Reference

使用其类别名称列表的地址，类工厂名称和类工厂位置创建此引用的副本。

clone() - Method in class javax.print.attribute. EnumSyntax

返回此枚举值的克隆，其中保留枚举值的语义是与此枚举值相同的对象。

clone() - Method in class javax.sound.midi. MetaMessage

创建与该对象相同的类和新内容相同的新对象。

clone() - Method in class javax.sound.midi. MidiMessage

创建与该对象相同的类和新内容相同的新对象。

clone() - Method in class javax.sound.midi. ShortMessage

创建与该对象相同的类和新内容相同的新对象。

clone() - Method in class javax.sound.midi. SysexMessage

创建与该对象相同的类和新内容相同的新对象。

clone() - Method in class javax.sql.rowset.serial. SerialArray

返回此 SerialArray的克隆。

clone() - Method in class javax.sql.rowset.serial. SerialBlob

返回此 SerialBlob的克隆。

clone() - Method in class javax.sql.rowset.serial. SerialClob

返回此 SerialClob的克隆。

clone() - Method in class javax.sql.rowset.serial. SerialDatalink

返回此 SerialDatalink的克隆。

clone() - Method in class javax.sql.rowset.serial. SerialJavaObject

返回此 SerialJavaObject的克隆。

clone() - Method in class javax.sql.rowset.serial. SerialRef

返回此 SerialRef的克隆。

clone() - Method in class javax.sql.rowset.serial. SerialStruct

返回此 SerialStruct的克隆。

clone() - Method in class javax.swing. AbstractAction

克隆抽象动作。

clone() - Method in class javax.swing. DefaultListSelectionModel

返回具有相同选择的此选择模型的克隆。

clone() - Method in class javax.swing. JFormattedTextField.AbstractFormatter

克隆 AbstractFormatter 。

clone() - Method in class javax.swing.text. DefaultFormatter

创建DefaultFormatter的副本。

clone() - Method in class javax.swing.text. EditorKit

创建一个编辑工具包的副本。

clone() - Method in class javax.swing.text. ElementIterator

克隆ElementIterator。

clone() - Method in class javax.swing.text. GlyphView

创建一个浅的副本。

clone() - Method in class javax.swing.text.html. HTMLEditorKit

创建一个编辑工具包的副本。

clone() - Method in class javax.swing.text. InternationalFormatter

创建DefaultFormatter的副本。

clone() - Method in class javax.swing.text. Segment

创建一个浅的副本。

clone() - Method in class javax.swing.text. SimpleAttributeSet

克隆一组属性。

clone() - Method in class javax.swing.text. StyleContext.SmallAttributeSet

克隆一组属性。

clone() - Method in class javax.swing.text. StyledEditorKit

创建一个编辑工具包的副本。

clone() - Method in class javax.swing.tree. DefaultMutableTreeNode

覆盖使克隆公开。

clone() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回具有相同选择的此对象的克隆。

clone() - Method in class javax.xml.datatype. XMLGregorianCalendar

创建并返回此对象的副本。

clone(Element, Element) - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer

使用不同的父项创建此元素的副本。

Cloneable - Interface in java.lang

一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段对字段的复制是合法的。

cloneContents() - Method in interface org.w3c.dom.ranges. Range

复制范围的内容

cloneNode(boolean) - Method in class javax.imageio.metadata. IIOMetadataNode

返回此节点的副本。

cloneNode(boolean) - Method in interface org.w3c.dom. Node

返回此节点的副本，即，作为节点的通用拷贝构造函数。

CloneNotSupportedException - Exception in java.lang

抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。

CloneNotSupportedException() - Constructor for exception java.lang. CloneNotSupportedException

构造一个 CloneNotSupportedException ，没有详细信息。

CloneNotSupportedException(String) - Constructor for exception java.lang. CloneNotSupportedException

构造具有指定详细消息的 CloneNotSupportedException 。

cloneRange() - Method in interface org.w3c.dom.ranges. Range

产生一个新的范围，其边界点等于Range的边界点。

cloneWithSource(Object) - Method in class javax.swing.event. TreeSelectionEvent

返回接收者的副本，但源代码是newSource。

closable - Variable in class javax.swing. JInternalFrame

框架可以关闭。

closableProperty() - Method in class javafx.scene.control. Tab

此选项卡的可关闭状态。

close() - Method in class com.sun.jdi.connect.spi. Connection

关闭此连接。

close() - Method in class com.sun.net.httpserver. HttpExchange

通过按顺序执行以下操作来结束此交换：关闭请求InputStream（如果尚未关闭） 关闭OutputStream的响应，如果尚未关闭。

close() - Method in class java.awt. SplashScreen

隐藏启动屏幕，关闭窗口，并释放所有关联的资源。

close() - Method in class java.beans. XMLDecoder

此方法关闭与此流相关联的输入流。

close() - Method in class java.beans. XMLEncoder

该方法调用 flush ，写入关闭后缀，然后关闭与此流相关联的输出流。

close() - Method in class java.io. BufferedInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.io. BufferedReader

close() - Method in class java.io. BufferedWriter

close() - Method in class java.io. ByteArrayInputStream

关闭 ByteArrayInputStream没有任何效果。

close() - Method in class java.io. ByteArrayOutputStream

关闭 ByteArrayOutputStream没有任何效果。

close() - Method in class java.io. CharArrayReader

关闭流并释放与之相关联的任何系统资源。

close() - Method in class java.io. CharArrayWriter

关闭流。

close() - Method in interface java.io. Closeable

关闭此流并释放与之相关联的任何系统资源。

close() - Method in class java.io. FileInputStream

关闭此文件输入流并释放与流相关联的任何系统资源。

close() - Method in class java.io. FileOutputStream

关闭此文件输出流并释放与此流相关联的任何系统资源。

close() - Method in class java.io. FilterInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.io. FilterOutputStream

关闭此输出流并释放与流相关联的任何系统资源。

close() - Method in class java.io. FilterReader

close() - Method in class java.io. FilterWriter

close() - Method in class java.io. InputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.io. InputStreamReader

close() - Method in interface java.io. ObjectInput

关闭输入流。

close() - Method in class java.io. ObjectInputStream

关闭输入流。

close() - Method in interface java.io. ObjectOutput

关闭流。

close() - Method in class java.io. ObjectOutputStream

关闭流。

close() - Method in class java.io. OutputStream

关闭此输出流并释放与此流相关联的任何系统资源。

close() - Method in class java.io. OutputStreamWriter

close() - Method in class java.io. PipedInputStream

关闭此管道输入流，并释放与流相关联的任何系统资源。

close() - Method in class java.io. PipedOutputStream

关闭此管道输出流，并释放与此流相关联的任何系统资源。

close() - Method in class java.io. PipedReader

关闭此管道流，并释放与流相关联的任何系统资源。

close() - Method in class java.io. PipedWriter

关闭此管道输出流，并释放与此流相关联的任何系统资源。

close() - Method in class java.io. PrintStream

关闭流。

close() - Method in class java.io. PrintWriter

关闭流并释放与之相关联的任何系统资源。

close() - Method in class java.io. PushbackInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.io. PushbackReader

关闭流并释放与之相关联的任何系统资源。

close() - Method in class java.io. RandomAccessFile

关闭此随机访问文件流并释放与流相关联的任何系统资源。

close() - Method in class java.io. Reader

关闭流并释放与之相关联的任何系统资源。

close() - Method in class java.io. SequenceInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.io. StringReader

关闭流并释放与之相关联的任何系统资源。

close() - Method in class java.io. StringWriter

关闭 StringWriter没有任何效果。

close() - Method in class java.io. Writer

关闭流，先刷新。

close() - Method in interface java.lang. AutoCloseable

关闭此资源，放弃任何基础资源。

close() - Method in interface java.lang.module. ModuleReader

关闭模块阅读器。

close() - Method in class java.net. DatagramSocket

关闭此数据报套接字。

close() - Method in class java.net. DatagramSocketImpl

关闭插座。

close() - Method in class java.net. ServerSocket

关闭此套接字。

close() - Method in class java.net. Socket

关闭此套接字。

close() - Method in class java.net. SocketImpl

关闭此套接字。

close() - Method in class java.net. URLClassLoader

关闭此URLClassLoader，以使其不能再用于加载由此加载程序定义的新类或资源。

close() - Method in interface java.nio.channels. AsynchronousChannel

关闭此频道。

close() - Method in interface java.nio.channels. Channel

关闭此频道。

close() - Method in class java.nio.channels. FileLock

此方法调用 FileLock.release()方法。

close() - Method in interface java.nio.channels. InterruptibleChannel

关闭此频道。

close() - Method in interface java.nio.channels. MulticastChannel

关闭此频道。

close() - Method in class java.nio.channels. Selector

关闭此选择器。

close() - Method in class java.nio.channels.spi. AbstractInterruptibleChannel

关闭此频道。

close() - Method in class java.nio.channels.spi. AbstractSelector

关闭此选择器。

close() - Method in class java.nio.file. FileSystem

关闭此文件系统。

close() - Method in interface java.nio.file. WatchService

关闭这个手表服务。

close() - Method in interface java.sql. Connection

立即释放此 Connection对象的数据库和JDBC资源，而不是等待它们自动释放。

close() - Method in interface java.sql. ResultSet

立即释放此 ResultSet对象的数据库和JDBC资源，而不是等待其自动关闭时发生。

close() - Method in interface java.sql. Statement

立即释放此 Statement对象的数据库和JDBC资源，而不是等待其自动关闭时发生。

close() - Method in class java.util.concurrent. SubmissionPublisher

除非已经关闭，否则问题 onComplete向当前用户发出信号，并且不允许随后的尝试发布。

close() - Method in class java.util. Formatter

关闭此格式化程序。

close() - Method in class java.util.logging. ConsoleHandler

覆盖 StreamHandler.close做一个flush但不关闭输出流。

close() - Method in class java.util.logging. FileHandler

关闭所有文件。

close() - Method in class java.util.logging. Handler

关闭 Handler并释放所有相关资源。

close() - Method in class java.util.logging. MemoryHandler

关闭 Handler并释放所有相关资源。

close() - Method in class java.util.logging. SocketHandler

关闭此输出流。

close() - Method in class java.util.logging. StreamHandler

关闭当前的输出流。

close() - Method in class java.util. Scanner

关闭此扫描仪。

close() - Method in interface java.util.stream. BaseStream

关闭此流，导致此流管道的所有关闭处理程序被调用。

close() - Method in class java.util.zip. DeflaterInputStream

关闭此输入流及其底层输入流，丢弃任何待处理的未压缩数据。

close() - Method in class java.util.zip. DeflaterOutputStream

将剩余的压缩数据写入输出流并关闭底层流。

close() - Method in class java.util.zip. GZIPInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.util.zip. InflaterInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.util.zip. InflaterOutputStream

将任何剩余的未压缩数据写入输出流并关闭底层输出流。

close() - Method in class java.util.zip. ZipFile

关闭ZIP文件。

close() - Method in class java.util.zip. ZipInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class java.util.zip. ZipOutputStream

关闭ZIP输出流以及正在过滤的流。

close() - Method in class javafx.scene.control. Dialog

关闭此 Dialog 。

close() - Method in class javafx.stage. Stage

关闭此 Stage 。

close() - Method in class javax.crypto. CipherInputStream

关闭此输入流并释放与流相关联的任何系统资源。

close() - Method in class javax.crypto. CipherOutputStream

关闭此输出流并释放与此流相关联的任何系统资源。

close() - Method in class javax.imageio.stream. FileCacheImageInputStream

关闭此 FileCacheImageInputStream ，关闭并删除缓存文件。

close() - Method in class javax.imageio.stream. FileCacheImageOutputStream

关闭此 FileCacheImageOutputStream 。

close() - Method in class javax.imageio.stream. FileImageInputStream

close() - Method in class javax.imageio.stream. FileImageOutputStream

close() - Method in interface javax.imageio.stream. ImageInputStream

关闭流。

close() - Method in class javax.imageio.stream. ImageInputStreamImpl

close() - Method in class javax.imageio.stream. MemoryCacheImageInputStream

关闭这个 MemoryCacheImageInputStream ，释放缓存。

close() - Method in class javax.imageio.stream. MemoryCacheImageOutputStream

关闭此 MemoryCacheImageOutputStream 。

close() - Method in interface javax.jnlp. JNLPRandomAccessFile

关闭此随机访问文件流并释放与流相关联的任何系统资源。

close() - Method in interface javax.management.remote. JMXConnector

关闭与其服务器的客户端连接。

close() - Method in interface javax.management.remote.rmi. RMIConnection

关闭此连接。

close() - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

close() - Method in class javax.management.remote.rmi. RMIConnectionImpl

close() - Method in class javax.management.remote.rmi. RMIConnector

close() - Method in class javax.management.remote.rmi. RMIServerImpl

关闭此连接服务器。

close() - Method in interface javax.naming. Context

关闭这个上下文。

close() - Method in class javax.naming. InitialContext

close() - Method in class javax.naming.ldap. StartTlsResponse

妥善地关闭TLS连接并恢复到底层连接。

close() - Method in interface javax.naming. NamingEnumeration

关闭此枚举。

close() - Method in class javax.smartcardio. CardChannel

关闭这个CardChannel。

close() - Method in interface javax.sound.midi. MidiDevice

关闭设备，指示设备现在应该释放它正在使用的任何系统资源。

close() - Method in interface javax.sound.midi. Receiver

表示应用程序已完成使用接收器，并且其所需的有限资源可能会被释放或提供。

close() - Method in interface javax.sound.midi. Transmitter

表示应用程序已完成使用发射机，并且其所需的有限资源可能会被释放或提供。

close() - Method in class javax.sound.sampled. AudioInputStream

关闭此音频输入流并释放与流相关联的任何系统资源。

close() - Method in interface javax.sound.sampled. Line

关闭该行，表示可以释放该行所使用的任何系统资源。

close() - Method in interface javax.sql. PooledConnection

关闭此 PooledConnection对象所代表的物理连接。

close() - Method in class javax.swing. ProgressMonitor

表示操作完成。

close() - Method in class javax.swing. ProgressMonitorInputStream

覆盖 FilterInputStream.close以关闭进度监视器以及流。

close() - Method in class javax.tools. ForwardingJavaFileManager

close() - Method in interface javax.tools. JavaFileManager

释放此文件管理器直接或间接打开的任何资源。

close() - Method in class javax.xml.soap. SOAPConnection

关闭此 SOAPConnection对象。

close() - Method in class javax.xml.stream.util. EventReaderDelegate

close() - Method in class javax.xml.stream.util. StreamReaderDelegate

close() - Method in interface javax.xml.stream. XMLEventReader

释放与此Reader相关联的任何资源。

close() - Method in interface javax.xml.stream. XMLEventWriter

释放与此流相关联的任何资源

close() - Method in interface javax.xml.stream. XMLStreamReader

释放与此Reader相关联的任何资源。

close() - Method in interface javax.xml.stream. XMLStreamWriter

关闭此作者并释放与作者相关的任何资源。

close() - Method in class javax.xml.ws.spi.http. HttpExchange

必须调用这个结束交换。

close() - Method in class jdk.jshell.execution. DirectExecutionControl

close() - Method in class jdk.jshell.execution. JdiDefaultExecutionControl

close() - Method in class jdk.jshell.execution. StreamingExecutionControl

关闭执行引擎。

close() - Method in class jdk.jshell. JShell

关闭这个状态引擎。

close() - Method in interface jdk.jshell.spi. ExecutionControl

关闭这个执行引擎。

close() - Method in class jdk.nashorn.api.scripting. URLReader

close() - Method in interface org.w3c.dom.html. HTMLDocument

关闭由 open()打开的文档流，并强制呈现。

close(MessageContext) - Method in interface javax.xml.ws.handler. Handler

在JAX-WS运行时间发送消息，故障或异常之前，在消息交换模式的结束时调用。

CLOSE - Static variable in class javafx.scene.control. ButtonType

预先定义的ButtonType显示“关闭”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.CANCEL_CLOSE 。

CLOSE - Static variable in class javax.sound.sampled. LineEvent.Type

线路关闭时发送的事件类型，释放打开时获取的系统资源。

CLOSE_ALL_RESULTS - Static variable in interface java.sql. Statement

该常量表明，当调用 getMoreResults时，所有先前已保持打开的 ResultSet对象都应关闭。

CLOSE_ALL_WINDOWS - java.awt.desktop. QuitStrategy

通过从后到左关闭每个窗口来关闭应用程序。

CLOSE_BRACKET - javafx.scene.input. KeyCode

关闭括号键的常数，“]”

CLOSE_CMD - Static variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

关闭按钮文本属性。

CLOSE_CURRENT_RESULT - Static variable in interface java.sql. Statement

该常量指示当调用 getMoreResults时，当前的 ResultSet对象应关闭。

CLOSE_CURSORS_AT_COMMIT - Static variable in interface java.sql. ResultSet

指示当前事务提交时，表示具有此 ResultSet对象的常量将被关闭。

CLOSE_FAILURE - Static variable in class java.util.logging. ErrorManager

当关闭输出流失败时使用CLOSE_FAILURE。

Closeable - Interface in java.io

A Closeable是可以关闭的数据的源或目的地。

closeAction - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

一个 CloseAction 。

CloseAction() - Constructor for class javax.swing.plaf.basic. BasicDesktopPaneUI.CloseAction

CloseAction() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.CloseAction

构造一个新的实例 CloseAction 。

closeButton - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

关闭按钮。

closeClient(RMIConnection) - Method in class javax.management.remote.rmi. RMIIIOPServerImpl

已过时。

closeClient(RMIConnection) - Method in class javax.management.remote.rmi. RMIJRMPServerImpl

closeClient(RMIConnection) - Method in class javax.management.remote.rmi. RMIServerImpl

关闭由 makeClient制造的客户端连接。

CLOSED - javax.net.ssl. SSLEngineResult.Status

操作刚刚关闭了这边 SSLEngine ，或者操作无法完成，因为它已经关闭了。

CLOSED - Static variable in class javax.management.remote. JMXConnectionNotification

连接关闭通知的通知类型字符串。

CLOSED_EVENT - Static variable in class javafx.scene.control. Tab

当用户关闭此选项卡时调用。

CLOSED_HAND - Static variable in class javafx.scene. Cursor

用手关闭的光标，通常在“抓取”时使用，例如，当平移时。

CLOSED_OPTION - Static variable in class javax.swing. JOptionPane

如果用户关闭窗口而不选择任何东西，则从类方法返回值，这可能会被视为 CANCEL_OPTION或 NO_OPTION 。

ClosedByInterruptException - Exception in java.nio.channels

另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。

ClosedByInterruptException() - Constructor for exception java.nio.channels. ClosedByInterruptException

构造这个类的一个实例。

ClosedChannelException - Exception in java.nio.channels

当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。

ClosedChannelException() - Constructor for exception java.nio.channels. ClosedChannelException

构造这个类的一个实例。

ClosedConnectionException - Exception in com.sun.jdi.connect.spi

由于在进行I / O操作时异步关闭Connection ，可能会抛出此异常。

ClosedConnectionException() - Constructor for exception com.sun.jdi.connect.spi. ClosedConnectionException

构造一个 ClosedConnectionException ，没有详细信息。

ClosedConnectionException(String) - Constructor for exception com.sun.jdi.connect.spi. ClosedConnectionException

构造具有指定详细消息的 ClosedConnectionException 。

ClosedDirectoryStreamException - Exception in java.nio.file

尝试在关闭的目录流上调用操作时抛出未检查的异常。

ClosedDirectoryStreamException() - Constructor for exception java.nio.file. ClosedDirectoryStreamException

构造这个类的一个实例。

ClosedFileSystemException - Exception in java.nio.file

尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。

ClosedFileSystemException() - Constructor for exception java.nio.file. ClosedFileSystemException

构造这个类的一个实例。

closedIcon - Variable in class javax.swing.tree. DefaultTreeCellRenderer

用于显示未展开的非叶节点的图标。

closeDown() - Method in interface jdk.jshell.spi. ExecutionEnv

报告执行引擎已关闭。

ClosedSelectorException - Exception in java.nio.channels

尝试在闭合选择器上调用I / O操作时抛出未检查的异常。

ClosedSelectorException() - Constructor for exception java.nio.channels. ClosedSelectorException

构造这个类的一个实例。

ClosedWatchServiceException - Exception in java.nio.file

尝试在关闭的手表服务上调用操作时抛出未检查的异常。

ClosedWatchServiceException() - Constructor for exception java.nio.file. ClosedWatchServiceException

构造这个类的一个实例。

closeEntry() - Method in class java.util.zip. ZipInputStream

关闭当前的ZIP条目，并定位流以读取下一个条目。

closeEntry() - Method in class java.util.zip. ZipOutputStream

关闭当前的ZIP条目，并定位流以写入下一个条目。

closeExceptionally(Throwable) - Method in class java.util.concurrent. SubmissionPublisher

除非已经关闭，否则问题 onError向给定的错误的当前用户发出信号，并且不允许随后的尝试发布。

closeFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager

从其父母移除框架，如有必要，可以 desktopIcon 。

closeFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager

一般来说，此调用应从其父级中删除该框架。

closeFrame(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

当用户想要关闭框架时调用此方法。

closeIcon - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

关闭图标。

closeInbound() - Method in class javax.net.ssl. SSLEngine

表示没有更多的入站网络数据将发送到此 SSLEngine 。

closeKey - Variable in class javax.swing.plaf.basic. BasicDesktopPaneUI

已过时。
截至1.3。

closeOnCompletion() - Method in interface java.sql. Statement

指定当其所有相关结果集都关闭时，此 Statement将关闭。

closeOutbound() - Method in class javax.net.ssl. SSLEngine

表示在此 SSLEngine不会再发送外发应用程序数据。

closeOutUnwantedEmbeddedTags(AttributeSet) - Method in class javax.swing.text.html. HTMLWriter

搜索属性集和存储在标签向量中的每个标签。

closePath() - Method in class java.awt.geom. Path2D

通过将直线绘制回最后一个 moveTo的坐标来关闭当前子路径。

closePath() - Method in class javafx.scene.canvas. GraphicsContext

关闭路径。

ClosePath - Class in javafx.scene.shape

关闭当前路径的路径元素。

ClosePath() - Constructor for class javafx.scene.shape. ClosePath

创建一个空的ClosePath实例。

closeServer() - Method in class javax.management.remote.rmi. RMIIIOPServerImpl

已过时。

closeServer() - Method in class javax.management.remote.rmi. RMIJRMPServerImpl

由 RMIServerImpl.close()调用，通过 取消导出该对象来关闭连接器服务器。

closeServer() - Method in class javax.management.remote.rmi. RMIServerImpl

调用 RMIServerImpl.close()关闭连接器服务器。

CM - javafx.css. SizeUnits

CMMException - Exception in java.awt.color

如果本机CMM返回错误，则抛出此异常。

CMMException(String) - Constructor for exception java.awt.color. CMMException

构造具有指定详细消息的CMMException。

coalesceEvents(AWTEvent, AWTEvent) - Method in class java.awt. Component

潜在地合并现有事件发布的事件。

code - Variable in exception org.w3c.dom. DOMException

code - Variable in exception org.w3c.dom.events. EventException

code - Variable in exception org.w3c.dom.ls. LSException

code - Variable in exception org.w3c.dom.ranges. RangeException

code - Variable in exception org.w3c.dom.xpath. XPathException

CODE - com.sun.source.doctree. DocTree.Kind

用于表示@code标签的LiteralTree的实例。

CODE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“代码”

CODE - Static variable in class javax.swing.text.html. HTML.Tag

标签<code>

CODE_ATTRIBUTE_PFX - Static variable in interface java.util.jar. Pack200.Packer

当与代码属性名称连接时，表示该属性的格式。

CODE_INPUT - javafx.scene.input. KeyCode

代码输入功能键的常数。

CODEBASE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“codebase”

Codec - Interface in org.omg.IOP

ORB服务使用的IOR组件和服务上下文数据的格式通常定义为编码IDL定义数据类型实例的CDR封装。

codec_factory() - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations

返回 IOP.CodecFactory 。

CodecFactory - Interface in org.omg.IOP

Codecs是从 CodecFactory获得的。

CodecFactoryHelper - Class in org.omg.IOP

Codecs是从 CodecFactory获得的。

CodecFactoryHelper() - Constructor for class org.omg.IOP. CodecFactoryHelper

CodecFactoryOperations - Interface in org.omg.IOP

Codecs是从 CodecFactory获得的。

CodecOperations - Interface in org.omg.IOP

ORB服务使用的IOR组件和服务上下文数据的格式通常定义为编码IDL定义数据类型实例的CDR封装。

codeIndex() - Method in interface com.sun.jdi. Location

获取此位置方法中的代码位置。

codePointAt(char[], int) - Static method in class java.lang. Character

返回 char数组的给定索引处的代码点。

codePointAt(char[], int, int) - Static method in class java.lang. Character

返回 char数组的给定索引处的代码点，其中只能使用 index小于 limit数组元素。

codePointAt(int) - Method in class java.lang. String

返回指定索引处的字符（Unicode代码点）。

codePointAt(int) - Method in class java.lang. StringBuffer

codePointAt(CharSequence, int) - Static method in class java.lang. Character

返回 CharSequence给定索引处的代码点。

codePointBefore(char[], int) - Static method in class java.lang. Character

返回 char数组的给定索引之前的代码点。

codePointBefore(char[], int, int) - Static method in class java.lang. Character

返回 char数组的给定索引之前的代码点，其中只能使用 index大于或等于 start数组元素。

codePointBefore(int) - Method in class java.lang. String

返回指定索引之前的字符（Unicode代码点）。

codePointBefore(int) - Method in class java.lang. StringBuffer

codePointBefore(CharSequence, int) - Static method in class java.lang. Character

返回 CharSequence给定索引之前的代码点。

codePointCount(char[], int, int) - Static method in class java.lang. Character

返回 char数组参数的子阵列中的Unicode代码点数。

codePointCount(int, int) - Method in class java.lang. String

返回此 String指定文本范围内的Unicode代码点数。

codePointCount(int, int) - Method in class java.lang. StringBuffer

codePointCount(CharSequence, int, int) - Static method in class java.lang. Character

返回指定字符序列的文本范围内的Unicode代码点数。

codePointOf(String) - Static method in class java.lang. Character

返回由给定的Unicode字符名称指定的Unicode字符的代码点值。

codePoints() - Method in interface java.lang. CharSequence

从此序列返回码流值。

codePoints() - Method in class java.lang. String

从此序列返回码流值。

CoderMalfunctionError - Error in java.nio.charset

错误抛出当decodeLoop方法的CharsetDecoder ，或encodeLoop一个的方法CharsetEncoder ，抛出意外的异常。

CoderMalfunctionError(Exception) - Constructor for error java.nio.charset. CoderMalfunctionError

初始化此类的实例。

CoderResult - Class in java.nio.charset

编码器的结果状态的描述。

CODESET_INCOMPATIBLE - Exception in org.omg.CORBA

无论客户端和服务器本机代码集之间无法进行有意义的通信，都会引发此异常。

CODESET_INCOMPATIBLE() - Constructor for exception org.omg.CORBA. CODESET_INCOMPATIBLE

构造一个 CODESET_INCOMPATIBLE异常，次要代码设置为0，而CompletionStatus设置为COMPLETED_NO。

CODESET_INCOMPATIBLE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. CODESET_INCOMPATIBLE

构造具有指定的次要代码和完成状态的 CODESET_INCOMPATIBLE异常。

CODESET_INCOMPATIBLE(String) - Constructor for exception org.omg.CORBA. CODESET_INCOMPATIBLE

使用指定的消息构造一个 CODESET_INCOMPATIBLE异常。

CODESET_INCOMPATIBLE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. CODESET_INCOMPATIBLE

构造具有指定消息，次要代码和完成状态的 CODESET_INCOMPATIBLE异常。

CodeSets - Interface in org.omg.IOP

org / omg / IOP / CodeSets.java。

CodeSigner - Class in java.security

该类封装了有关代码签名者的信息。

CodeSigner(CertPath, Timestamp) - Constructor for class java.security. CodeSigner

构造一个CodeSigner对象。

CodeSource - Class in java.security

该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。

CodeSource(URL, Certificate[]) - Constructor for class java.security. CodeSource

构造一个CodeSource并将其与指定的位置和证书集合相关联。

CodeSource(URL, CodeSigner[]) - Constructor for class java.security. CodeSource

构造CodeSource并将其与指定的位置和代码签名者集合相关联。

CODETYPE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“codetype”

CodingErrorAction - Class in java.nio.charset

用于编码错误操作的类型安全枚举。

coerceData(boolean) - Method in class java.awt.image. BufferedImage

强制数据匹配 isAlphaPremultiplied变量中指定的状态。

coerceData(WritableRaster, boolean) - Method in class java.awt.image. ColorModel

强制栅格数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设此 ColorModel目前正确描述了数据。

coerceData(WritableRaster, boolean) - Method in class java.awt.image. ComponentColorModel

强制栅格数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设此 ColorModel目前正确描述了数据。

coerceData(WritableRaster, boolean) - Method in class java.awt.image. DirectColorModel

强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设此 ColorModel当前正确描述了数据。

colHead - Variable in class javax.swing. ScrollPaneLayout

列标题子。

collapse(boolean) - Method in interface org.w3c.dom.ranges. Range

将范围折叠到其边界点之一

COLLAPSE - javafx.scene. AccessibleAction

请求节点应该折叠。

COLLAPSED - Static variable in class javax.accessibility. AccessibleState

表示此对象已折叠。

collapsedIcon - Variable in class javax.swing.plaf.basic. BasicTreeUI

折叠图标。

CollapsedStringAdapter - Class in javax.xml.bind.annotation.adapters

内置XmlAdapter处理xs:token及其派生类型。

CollapsedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters. CollapsedStringAdapter

collapsePath(TreePath) - Method in class javax.swing. JTree

确保由指定路径标识的节点被折叠和可视。

collapseRow(int) - Method in class javax.swing. JTree

确保指定行中的节点已折叠。

collapsibleProperty() - Method in class javafx.scene.control. TitledPane

TitledPane的可折叠状态。

COLLATED - javafx.print. Collation

文档的每个副本都打印在一起。

COLLATED - Static variable in class javax.print.attribute.standard. SheetCollate

当打印多份副本时，文档中的表单按整理顺序显示。

Collation - Enum in javafx.print

排序规则指定作业中打印文档的每个副本的介质页是否是顺序的。

CollationElementIterator - Class in java.text

CollationElementIterator类用作遍历国际字符串的每个字符的迭代器。

CollationKey - Class in java.text

A CollationKey表示一个 String的规则下的一个特定的 Collator对象。

CollationKey(String) - Constructor for class java.text. CollationKey

CollationKey构造函数。

collationProperty() - Method in class javafx.print. JobSettings

属性代表 Collation一个实例。

Collator - Class in java.text

Collator类执行区域设置敏感的 String比较。

Collator() - Constructor for class java.text. Collator

默认构造函数。

CollatorProvider - Class in java.text.spi

提供Collator类的具体实现的服务提供者的抽象类。

CollatorProvider() - Constructor for class java.text.spi. CollatorProvider

唯一的构造函数。

collect(Supplier<R>, BiConsumer<R, ? super T>, BiConsumer<R, R>) - Method in interface java.util.stream. Stream

对此流的元素执行 mutable reduction操作。

collect(Supplier<R>, ObjDoubleConsumer<R>, BiConsumer<R, R>) - Method in interface java.util.stream. DoubleStream

对此流的元素执行 mutable reduction操作。

collect(Supplier<R>, ObjIntConsumer<R>, BiConsumer<R, R>) - Method in interface java.util.stream. IntStream

对此流的元素执行 mutable reduction操作。

collect(Supplier<R>, ObjLongConsumer<R>, BiConsumer<R, R>) - Method in interface java.util.stream. LongStream

对此流的元素执行 mutable reduction操作。

collect(Collector<? super T, A, R>) - Method in interface java.util.stream. Stream

使用 Collector对此流的元素执行 mutable reduction操作。

collectArguments(MethodHandle, int, MethodHandle) - Static method in class java.lang.invoke. MethodHandles

通过使用过滤器（另一种方法句柄）预处理其参数的子序列来适应目标方法句柄。

collectingAndThen(Collector<T, A, R>, Function<R, RR>) - Static method in class java.util.stream. Collectors

适应 Collector进行额外的整理转换。

Collection< E> - Interface in java.util

集合层次结构中的根界面。

CollectionCertStoreParameters - Class in java.security.cert

参数用作集合 CertStore算法的输入。

CollectionCertStoreParameters() - Constructor for class java.security.cert. CollectionCertStoreParameters

使用默认参数值创建一个 CollectionCertStoreParameters的实例（一个空 Collection ）。

CollectionCertStoreParameters(Collection<?>) - Constructor for class java.security.cert. CollectionCertStoreParameters

创建一个 CollectionCertStoreParameters的实例，这将允许从指定的 Collection检索证书和CRL。

Collections - Class in java.util

此类仅由静态方法组合或返回集合。

Collector< T, A, R> - Interface in java.util.stream

A mutable reduction operation将输入元素累加到可变结果容器中，可选地在所有输入元素被处理之后将累加结果转换成最终表示。

Collector.Characteristics - Enum in java.util.stream

指示 Collector属性的特性，可用于优化还原实现。

Collectors - Class in java.util.stream

实现各种有用的还原操作的Collector ，例如将元素累积到集合中，根据各种标准汇总元素等。

COLON - javafx.scene.input. KeyCode

“：”键的常数。

color - Variable in class javax.swing.border. MatteBorder

为边界呈现的颜色。

color(double, double, double) - Static method in class javafx.scene.paint. Color

使用指定的红色，绿色和蓝色值创建不透明的sRGB颜色，范围为 0.0-1.0 。

color(double, double, double, double) - Static method in class javafx.scene.paint. Color

使用指定的红色，绿色和蓝色值创建sRGB颜色，范围为 0.0-1.0 ，以及给定的不透明度。

Color - Class in java.awt

Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。

Color - Class in javafx.scene.paint

Color类用于将颜色封装在默认的sRGB颜色空间中。

Color(double, double, double, double) - Constructor for class javafx.scene.paint. Color

创建一个新的颜色实例

Color(float, float, float) - Constructor for class java.awt. Color

使用范围（0.0 - 1.0）中指定的红色，绿色和蓝色值创建不透明的sRGB颜色。

Color(float, float, float, float) - Constructor for class java.awt. Color

用范围（0.0 - 1.0）中指定的红，绿，蓝和阿尔法值创建sRGB颜色。

Color(int) - Constructor for class java.awt. Color

创建一个不透明的sRGB颜色，其中指定的组合RGB值包括位16-23中的红色分量，位8-15中的绿色分量和位0-7中的蓝色分量。

Color(int, boolean) - Constructor for class java.awt. Color

使用指定的组合RGBA值创建sRGB颜色，RGBA值由位24-31中的alpha分量，位16-23中的红色分量，位8-15中的绿色分量和位0-7中的蓝色分量组成。

Color(int, int, int) - Constructor for class java.awt. Color

用范围（0 - 255）范围内的指定的红色，绿色和蓝色值创建不透明的sRGB颜色。

Color(int, int, int, int) - Constructor for class java.awt. Color

在范围（0 - 255）范围内创建指定的红，绿，蓝和阿尔法值的sRGB颜色。

Color(ColorSpace, float[], float) - Constructor for class java.awt. Color

使用 float数组中指定的颜色组件和指定的alpha创建指定的 ColorSpace中的颜色。

COLOR - javafx.print. PrintColor

指定彩色打印。

COLOR - Static variable in class java.awt. PageAttributes.ColorType

用于指定彩色打印的ColorType实例。

COLOR - Static variable in class javax.print.attribute.standard. Chromaticity

彩色印刷。

COLOR - Static variable in class javax.swing.text.html. CSS.Attribute

CSS属性“颜色”。

COLOR - Static variable in class javax.swing.text.html. HTML.Attribute

属性“颜色”

COLOR_ACTION - Static variable in class javax.swing.text.html. HTMLEditorKit

颜色选择动作标识符颜色作为参数传递

COLOR_BURN - javafx.scene.effect. BlendMode

底部输入颜色分量的倒数除以顶部输入颜色分量，然后将其全部反转以产生所得颜色。

COLOR_CHOOSER - Static variable in class javax.accessibility. AccessibleRole

允许用户选择颜色的专用窗格。

COLOR_CHOOSER - Static variable in class javax.swing.plaf.synth. Region

ColorChooser地区。

COLOR_CHOOSER_DIALOG - Static variable in class javax.swing. JRootPane

用于windowDecorationStyle属性的常量。

COLOR_DODGE - javafx.scene.effect. BlendMode

底部输入颜色分量被顶部输入颜色分量的倒数除以产生所得到的颜色。

COLOR_SPACE_SRGB - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“ColorSpace”标签一起使用的值。

COLOR_SPACE_UNCALIBRATED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“ColorSpace”标签一起使用的值。

ColorAdjust - Class in javafx.scene.effect

允许每个像素调整色调，饱和度，亮度和对比度的效果。

ColorAdjust() - Constructor for class javafx.scene.effect. ColorAdjust

使用默认参数创建一个新的ColorAdjust实例。

ColorAdjust(double, double, double, double) - Constructor for class javafx.scene.effect. ColorAdjust

以指定的色调，饱和度，亮度和对比度创建ColorAdjust的新实例。

ColorChooserComponentFactory - Class in javax.swing.colorchooser

一个设计用于生产预配置的“附件”对象以插入到颜色选择器中的类。

ColorChooserUI - Class in javax.swing.plaf

JColorChooser可插拔的外观和界面。

ColorChooserUI() - Constructor for class javax.swing.plaf. ColorChooserUI

ColorConverter - Class in javafx.css.converter

ColorConvertOp - Class in java.awt.image

该类对源图像中的数据执行逐像素颜色转换。

ColorConvertOp(ColorSpace, ColorSpace, RenderingHints) - Constructor for class java.awt.image. ColorConvertOp

从两个ColorSpace对象构造一个新的ColorConvertOp。

ColorConvertOp(ColorSpace, RenderingHints) - Constructor for class java.awt.image. ColorConvertOp

从ColorSpace对象构造一个新的ColorConvertOp。

ColorConvertOp(ICC_Profile[], RenderingHints) - Constructor for class java.awt.image. ColorConvertOp

从ICC_Profiles数组构造一个新的ColorConvertOp。

ColorConvertOp(RenderingHints) - Constructor for class java.awt.image. ColorConvertOp

构造一个新的ColorConvertOp，它将从源颜色空间转换为目标色彩空间。

COLORED_KEY_0 - javafx.scene.input. KeyCode

常数为 Colored Key 0键。

COLORED_KEY_1 - javafx.scene.input. KeyCode

常数为 Colored Key 1键。

COLORED_KEY_2 - javafx.scene.input. KeyCode

常数为 Colored Key 2键。

COLORED_KEY_3 - javafx.scene.input. KeyCode

常数为 Colored Key 3键。

ColorInput - Class in javafx.scene.effect

使用给定的 Paint填充（“淹没”）的矩形区域的效果。

ColorInput() - Constructor for class javafx.scene.effect. ColorInput

使用默认参数创建一个新的ColorInput实例。

ColorInput(double, double, double, double, Paint) - Constructor for class javafx.scene.effect. ColorInput

使用指定的x，y，width，height和paint创建一个ColorInput的新实例。

colorModel - Variable in class javax.imageio. ImageTypeSpecifier

将 ColorModel作为原型使用。

ColorModel - Class in java.awt.image

ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和Alpha分量的方法。

ColorModel(int) - Constructor for class java.awt.image. ColorModel

构造一个 ColorModel ，它将指定位数的像素转换为彩色/ alpha分量。

ColorModel(int, int[], ColorSpace, boolean, boolean, int, int) - Constructor for class java.awt.image. ColorModel

构造一个 ColorModel ，将像素值转换为彩色/ alpha分量。

ColorPicker - Class in javafx.scene.control

ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。

ColorPicker() - Constructor for class javafx.scene.control. ColorPicker

创建默认的ColorPicker实例，将所选颜色设置为白色。

ColorPicker(Color) - Constructor for class javafx.scene.control. ColorPicker

创建一个ColorPicker实例，并将所选颜色设置为给定的颜色。

ColorPickerSkin - Class in javafx.scene.control.skin

默认皮肤实现为ColorPicker控件。

ColorPickerSkin(ColorPicker) - Constructor for class javafx.scene.control.skin. ColorPickerSkin

创建一个新的ColorPickerSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

colorProperty() - Method in class javafx.scene.effect. DropShadow

阴影 Color 。

colorProperty() - Method in class javafx.scene.effect. InnerShadow

阴影 Color 。

colorProperty() - Method in class javafx.scene.effect. Light

光源的颜色。

colorProperty() - Method in class javafx.scene.effect. Shadow

阴影 Color 。

colorProperty() - Method in class javafx.scene. LightBase

指定光源的颜色。

ColorSelectionModel - Interface in javax.swing.colorchooser

支持选择一个 Color模型。

ColorSpace - Class in java.awt.color

该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。

ColorSpace(int, int) - Constructor for class java.awt.color. ColorSpace

给定一个ColorSpace对象，给出一个颜色空间类型和组件数量。

ColorSupported - Class in javax.print.attribute.standard

ColorSupported类是一个打印属性类，一个枚举，用于标识设备是否能够进行任何类型的彩色打印，包括突出显示颜色以及全过程颜色。

ColorSupported(int) - Constructor for class javax.print.attribute.standard. ColorSupported

使用给定的整数值构造支持新颜色的枚举值。

ColorType - Class in javax.swing.plaf.synth

一种可以从风格中获取的颜色的类型安全枚举。

ColorType(String) - Constructor for class javax.swing.plaf.synth. ColorType

创建一个带有指定说明的新ColorType。

ColorUIResource - Class in javax.swing.plaf

实现UIResource的Color子类。

ColorUIResource(float, float, float) - Constructor for class javax.swing.plaf. ColorUIResource

构造一个 ColorUIResource 。

ColorUIResource(int) - Constructor for class javax.swing.plaf. ColorUIResource

构造一个 ColorUIResource 。

ColorUIResource(int, int, int) - Constructor for class javax.swing.plaf. ColorUIResource

构造一个 ColorUIResource 。

ColorUIResource(Color) - Constructor for class javax.swing.plaf. ColorUIResource

构造一个 ColorUIResource 。

COLS - Static variable in class javax.swing.text.html. HTML.Attribute

属性“cols”

COLSPAN - Static variable in class javax.swing.text.html. HTML.Attribute

属性“colspan”

column - Variable in class javax.swing.event. TableModelEvent

事件列。

column() - Method in interface com.sun.javadoc. SourcePosition

已过时。

源文件中的列。

column(MatrixType, int) - Method in class javafx.scene.transform. Transform

返回一个包含转换矩阵列的数组。

column(MatrixType, int, double[]) - Method in class javafx.scene.transform. Transform

返回一个包含转换矩阵列的数组。

COLUMN_AT_INDEX - javafx.scene. AccessibleAttribute

返回给定索引处的列。

COLUMN_COUNT - javafx.scene. AccessibleAttribute

返回节点的列计数。

COLUMN_HEADER - Static variable in class javax.accessibility. AccessibleRole

数据列的标题。

COLUMN_HEADER - Static variable in interface javax.swing. ScrollPaneConstants

标识左上角和右上角之间的视口顶部的区域。

COLUMN_INDEX - javafx.scene. AccessibleAttribute

返回节点的列索引。

COLUMN_WIDTH_PROPERTY - Static variable in class javax.swing.table. TableColumn

作为Java 2平台v1.3的过时。

columnAdded(TableColumnModelEvent) - Method in interface javax.swing.event. TableColumnModelListener

告诉听众列已添加到模型中。

columnAdded(TableColumnModelEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪表内容的更改（列插入）

columnAdded(TableColumnModelEvent) - Method in class javax.swing. JTable

当列添加到表列模型时调用。

columnAdded(TableColumnModelEvent) - Method in class javax.swing.table. JTableHeader

当列添加到表列模型时调用。

columnAtPoint(Point) - Method in class javax.swing. JTable

返回 point所在列的索引，如果结果不在[ getColumnCount() -1]范围内，则 getColumnCount() -1。

columnAtPoint(Point) - Method in class javax.swing.table. JTableHeader

返回 point所在列的索引，如果它位于边界之外，则返回-1。

ColumnConstraints - Class in javafx.scene.layout

为GridPane中的列定义可选布局约束。

ColumnConstraints() - Constructor for class javafx.scene.layout. ColumnConstraints

创建一个没有设置属性的列约束对象。

ColumnConstraints(double) - Constructor for class javafx.scene.layout. ColumnConstraints

创建具有固定宽度的列约束对象。

ColumnConstraints(double, double, double) - Constructor for class javafx.scene.layout. ColumnConstraints

创建具有固定大小范围的列约束对象。

ColumnConstraints(double, double, double, Priority, HPos, boolean) - Constructor for class javafx.scene.layout. ColumnConstraints

创建具有固定大小范围，水平增长优先级，水平对齐和水平填充行为的列约束对象。

columnHalignmentProperty() - Method in class javafx.scene.layout. FlowPane

垂直花式板的每列内的节点的水平对齐。

columnHeader - Variable in class javax.swing. JScrollPane

列标题子。

columnIdentifiers - Variable in class javax.swing.table. DefaultTableModel

列标识符为 Vector 。

columnMargin - Variable in class javax.swing.table. DefaultTableColumnModel

每列之间的宽度

columnMarginChanged(ChangeEvent) - Method in interface javax.swing.event. TableColumnModelListener

告诉听众列由于边距变化而被移动。

columnMarginChanged(ChangeEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪由于边际变化而移动的列的变化。

columnMarginChanged(ChangeEvent) - Method in class javax.swing. JTable

当列由于边距更改而移动时调用。

columnMarginChanged(ChangeEvent) - Method in class javax.swing.table. JTableHeader

当列由于边距更改而移动时调用。

columnModel - Variable in class javax.swing. JTable

表中的 TableColumnModel 。

columnModel - Variable in class javax.swing.table. JTableHeader

表头的 TableColumnModel 。

COLUMNMODEL - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing TableColumnModel支持（即TableColumnModelListener和TableColumnModelEvent）

columnMoved(TableColumnModelEvent) - Method in interface javax.swing.event. TableColumnModelListener

告诉收听者列重新定位。

columnMoved(TableColumnModelEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪列重新定位的更改。

columnMoved(TableColumnModelEvent) - Method in class javax.swing. JTable

当列重新定位时调用。

columnMoved(TableColumnModelEvent) - Method in class javax.swing.table. JTableHeader

当列重新定位时调用。

columnNoNulls - Static variable in interface java.sql. DatabaseMetaData

表示该列可能不允许 NULL值。

columnNoNulls - Static variable in interface java.sql. ResultSetMetaData

该常量指示一列不允许 NULL值。

columnNullable - Static variable in interface java.sql. DatabaseMetaData

表示该列绝对允许 NULL值。

columnNullable - Static variable in interface java.sql. ResultSetMetaData

常数表示列允许 NULL 。

columnNullableUnknown - Static variable in interface java.sql. DatabaseMetaData

表示列的无效性是未知的。

columnNullableUnknown - Static variable in interface java.sql. ResultSetMetaData

常数表示列的值的可空性是未知的。

columnRemoved(TableColumnModelEvent) - Method in interface javax.swing.event. TableColumnModelListener

告诉听众列从模型中删除。

columnRemoved(TableColumnModelEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪表内容的更改（列删除）

columnRemoved(TableColumnModelEvent) - Method in class javax.swing. JTable

从列列模型中删除列时调用。

columnRemoved(TableColumnModelEvent) - Method in class javax.swing.table. JTableHeader

从列列模型中删除列时调用。

columnResizePolicyProperty() - Method in class javafx.scene.control. TableView

这是当用户完成列大小调整操作时调用的函数。

columnResizePolicyProperty() - Method in class javafx.scene.control. TreeTableView

这是当用户完成列大小调整操作时调用的函数。

columns() - Method in enum javafx.scene.transform. MatrixType

返回此类型矩阵中的列数。

columnSelectionAllowed - Variable in class javax.swing.table. DefaultTableColumnModel

此列模型允许列选择

columnSelectionChanged(ListSelectionEvent) - Method in interface javax.swing.event. TableColumnModelListener

告诉听众表TableColumnModel的选择模型已更改。

columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪TableColumnModel的选择模型更改。

columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing. JTable

当 TableColumnModel的选择模型更改时调用。

columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.table. JTableHeader

当更改 TableColumnModel的选择模型时调用。

columnUpdated(int) - Method in interface javax.sql.rowset. CachedRowSet

指示此 CachedRowSet对象当前行中的指定列是否已更新。

columnUpdated(String) - Method in interface javax.sql.rowset. CachedRowSet

指示此 CachedRowSet对象当前行中的指定列是否已更新。

columnWeights - Variable in class java.awt. GridBagLayout

此字段保留对列权重的覆盖。

columnWidths - Variable in class java.awt. GridBagLayout

此字段将覆盖列的最小宽度。

com.sun.jarsigner - package com.sun.jarsigner

该包包含用于定义 jarsigner工具使用的签名机制的接口和类。

com.sun.java.accessibility.util - package com.sun.java.accessibility.util

提供组成Java辅助功能实用程序的接口和类的集合。

com.sun.javadoc - package com.sun.javadoc

注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

com.sun.jdi - package com.sun.jdi

这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

com.sun.jdi.connect - package com.sun.jdi.connect

该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

com.sun.jdi.connect.spi - package com.sun.jdi.connect.spi

该包包含用于开发新的TransportService实现的接口和类。

com.sun.jdi.event - package com.sun.jdi.event

该包定义了JDI事件和事件处理。

com.sun.jdi.request - package com.sun.jdi.request

该包用于请求在指定条件下发送JDI事件。

com.sun.management - package com.sun.management

该包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

com.sun.net.httpserver - package com.sun.net.httpserver

提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

com.sun.net.httpserver.spi - package com.sun.net.httpserver.spi

提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。

com.sun.nio.sctp - package com.sun.nio.sctp

用于流控制传输协议的Java API。

com.sun.security.auth - package com.sun.security.auth

提供Principal的实现。

com.sun.security.auth.callback - package com.sun.security.auth.callback

提供CallbackHandler的实现。

com.sun.security.auth.login - package com.sun.security.auth.login

提供Configuration的实现。

com.sun.security.auth.module - package com.sun.security.auth.module

提供LoginModule的实现。

com.sun.security.jgss - package com.sun.security.jgss

com.sun.source.doctree - package com.sun.source.doctree

提供用于将文档注释表示为抽象语法树（AST）的接口。

com.sun.source.tree - package com.sun.source.tree

提供用于将源代码表示为抽象语法树（AST）的接口。

com.sun.source.util - package com.sun.source.util

为抽象语法树（AST）的操作提供实用程序。

com.sun.tools.attach - package com.sun.tools.attach

提供API附加到Java的虚拟机。

com.sun.tools.attach.spi - package com.sun.tools.attach.spi

只有定义新附加提供商的开发者才需要直接使用这个包。

com.sun.tools.doclets - package com.sun.tools.doclets

注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

com.sun.tools.doclets.standard - package com.sun.tools.doclets.standard

注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

com.sun.tools.javac - package com.sun.tools.javac

该包提供了 javac工具的传统入口点。

com.sun.tools.javadoc - package com.sun.tools.javadoc

此软件包及其内容已被弃用，可能会在将来的版本中删除。

com.sun.tools.jconsole - package com.sun.tools.jconsole

此程序包包含JConsole API。

combine(ProtectionDomain[], ProtectionDomain[]) - Method in interface java.security. DomainCombiner

修改或更新提供的ProtectionDomains。

combine(ProtectionDomain[], ProtectionDomain[]) - Method in class javax.security.auth. SubjectDomainCombiner

更新从校长有关的ProtectionDomains Subject与此相关 SubjectDomainCombiner 。

combine(DoubleSummaryStatistics) - Method in class java.util. DoubleSummaryStatistics

将另一个 DoubleSummaryStatistics的状态合并到这一个中。

combine(IntSummaryStatistics) - Method in class java.util. IntSummaryStatistics

将另一个 IntSummaryStatistics的状态合并到一个。

combine(LongSummaryStatistics) - Method in class java.util. LongSummaryStatistics

将另一个 LongSummaryStatistics的状态合并到这一个中。

combiner() - Method in interface java.util.stream. Collector

一个接受两个部分结果并将其合并的函数。

COMBINING - Static variable in class java.awt.font. GlyphMetrics

表示表示组合字符的字形，例如变音符号。

COMBINING_DIACRITICAL_MARKS - Static variable in class java.lang. Character.UnicodeBlock

“组合变音符号”Unicode字符块的常数。

COMBINING_DIACRITICAL_MARKS_EXTENDED - Static variable in class java.lang. Character.UnicodeBlock

Unicode字符块的“组合变音符号扩展”的常数。

COMBINING_DIACRITICAL_MARKS_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock

Unicode字符块的“组合变音符号补充”的常数。

COMBINING_HALF_MARKS - Static variable in class java.lang. Character.UnicodeBlock

Unicode字符块的“组合半标记”的常量。

COMBINING_MARKS_FOR_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock

Unicode字符块的“组合符号变音符号”的常量。

COMBINING_SPACING_MARK - Static variable in class java.lang. Character

Unicode规范中的一般类别“Mc”。

COMBO_BOX - javafx.scene. AccessibleRole

组合框角色。

COMBO_BOX - Static variable in class javax.accessibility. AccessibleRole

用户可以选择的选项列表。

COMBO_BOX - Static variable in class javax.swing.plaf.synth. Region

ComboBox区域。

comboBox - Variable in class javax.swing.plaf.basic. BasicComboBoxUI

实例 JComboBox 。

comboBox - Variable in class javax.swing.plaf.basic. BasicComboPopup

实例 JComboBox 。

comboBox - Variable in class javax.swing.plaf.metal. MetalComboBoxButton

实例 JComboBox 。

ComboBox< T> - Class in javafx.scene.control

针对最常见形式的ComboBox的ComboBoxBase抽象类的实现，其中向用户提供弹出列表，以提供他们可以选择的选项。

ComboBox() - Constructor for class javafx.scene.control. ComboBox

创建一个默认的ComboBox实例，其中包含一个空的 items列表，默认为 selection model 。

ComboBox(ObservableList<T>) - Constructor for class javafx.scene.control. ComboBox

使用提供的项目列表创建默认的ComboBox实例，默认为 selection model 。

ComboBoxBase< T> - Class in javafx.scene.control

ComboBox类控件的抽象基类。

ComboBoxBase() - Constructor for class javafx.scene.control. ComboBoxBase

创建默认的ComboBoxBase实例。

ComboBoxBaseSkin< T> - Class in javafx.scene.control.skin

一个抽象类，旨在用作基于ComboBoxBase的 ComboBox类控件的基础外观 。

ComboBoxBaseSkin(ComboBoxBase<T>) - Constructor for class javafx.scene.control.skin. ComboBoxBaseSkin

创建一个新的ComboBoxBaseSkin实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。

comboBoxEditableProperty() - Method in class javafx.scene.control.cell. ComboBoxListCell

表示ComboBox在向用户显示时是否可编辑的属性。

comboBoxEditableProperty() - Method in class javafx.scene.control.cell. ComboBoxTableCell

表示ComboBox在向用户显示时是否可编辑的属性。

comboBoxEditableProperty() - Method in class javafx.scene.control.cell. ComboBoxTreeCell

表示ComboBox在向用户显示时是否可编辑的属性。

comboBoxEditableProperty() - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

表示ComboBox在向用户显示时是否可编辑的属性。

ComboBoxEditor - Interface in javax.swing

用于JComboBox组件的编辑器组件。

ComboBoxLayoutManager() - Constructor for class javax.swing.plaf.basic. BasicComboBoxUI.ComboBoxLayoutManager

ComboBoxListCell< T> - Class in javafx.scene.control.cell

一个包含一个ListCell实现的类，它在单元格内绘制一个ComboBox节点。

ComboBoxListCell() - Constructor for class javafx.scene.control.cell. ComboBoxListCell

创建一个带有空项目列表的默认ComboBoxListCell。

ComboBoxListCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxListCell

创建默认的ComboBoxListCell实例，给定的项目用于填充ComboBox 。

ComboBoxListCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxListCell

创建一个ComboBoxListCell实例，给定的项目用于在显示时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。

ComboBoxListCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ComboBoxListCell

创建一个ComboBoxListCell实例，其中给定的项目用于在显示时填充ComboBox ，并且StringConverter用于将项目转换为用户可读的形式。

ComboBoxListCell(T...) - Constructor for class javafx.scene.control.cell. ComboBoxListCell

创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxListViewSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为ComboBox控件。

ComboBoxListViewSkin(ComboBox<T>) - Constructor for class javafx.scene.control.skin. ComboBoxListViewSkin

创建一个新的ComboBoxListViewSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

ComboBoxModel< E> - Interface in javax.swing

组合框的数据模型。

ComboBoxPopupControl< T> - Class in javafx.scene.control.skin

一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。

ComboBoxPopupControl(ComboBoxBase<T>) - Constructor for class javafx.scene.control.skin. ComboBoxPopupControl

创建一个新的ComboBoxPopupControl实例，虽然注意到这个实例没有处理任何行为/输入映射 - 这需要被子类适当地处理。

ComboBoxTableCell< S, T> - Class in javafx.scene.control.cell

一个包含TableCell实现的类，在该单元格内绘制一个ComboBox节点。

ComboBoxTableCell() - Constructor for class javafx.scene.control.cell. ComboBoxTableCell

创建一个带有空项目列表的默认ComboBoxTableCell。

ComboBoxTableCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxTableCell

创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxTableCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxTableCell

创建一个ComboBoxTableCell实例，其中给定的项目用于在显示时填充ComboBox ，并且StringConverter用于将项目转换为用户可读的形式。

ComboBoxTableCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ComboBoxTableCell

创建一个ComboBoxTableCell实例，给定的项目用于在显示时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。

ComboBoxTableCell(T...) - Constructor for class javafx.scene.control.cell. ComboBoxTableCell

创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxTreeCell< T> - Class in javafx.scene.control.cell

一个包含TreeCell实现的类，在该单元格内绘制一个ComboBox节点。

ComboBoxTreeCell() - Constructor for class javafx.scene.control.cell. ComboBoxTreeCell

创建一个带有空项目列表的默认ComboBoxTreeCell。

ComboBoxTreeCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxTreeCell

创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxTreeCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxTreeCell

创建一个ComboBoxTreeCell实例，给定的项目用于在显示时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。

ComboBoxTreeCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ComboBoxTreeCell

创建一个ComboBoxTreeCell实例，给定的项目用于填充ComboBox，当它被显示时， StringConverter用于将项目转换为用户可读的形式。

ComboBoxTreeCell(T...) - Constructor for class javafx.scene.control.cell. ComboBoxTreeCell

创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxTreeTableCell< S, T> - Class in javafx.scene.control.cell

一个包含TreeTableCell实现的类，在该单元格内绘制一个ComboBox节点。

ComboBoxTreeTableCell() - Constructor for class javafx.scene.control.cell. ComboBoxTreeTableCell

创建一个带有空项目列表的默认ComboBoxTreeTableCell。

ComboBoxTreeTableCell(ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxTreeTableCell

创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxTreeTableCell(StringConverter<T>, ObservableList<T>) - Constructor for class javafx.scene.control.cell. ComboBoxTreeTableCell

创建一个ComboBoxTreeTableCell实例，给定的项目用于在显示时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。

ComboBoxTreeTableCell(StringConverter<T>, T...) - Constructor for class javafx.scene.control.cell. ComboBoxTreeTableCell

创建一个ComboBoxTreeTableCell实例，给定的项目用于在显示时填充ComboBox ，而StringConverter用于将项目转换为用户可读的表单。

ComboBoxTreeTableCell(T...) - Constructor for class javafx.scene.control.cell. ComboBoxTreeTableCell

创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxUI - Class in javax.swing.plaf

JComboBox可插拔的外观和界面。

ComboBoxUI() - Constructor for class javax.swing.plaf. ComboBoxUI

comboIcon - Variable in class javax.swing.plaf.metal. MetalComboBoxButton

图标。

ComboPopup - Interface in javax.swing.plaf.basic

定义实现组合框的弹出部分所需的方法的界面。

COMM_FAILURE - Exception in org.omg.CORBA

在客户端发送请求后，服务器的回复已经返回到客户端之前，在进行中的通信丢失时发生异常。

COMM_FAILURE() - Constructor for exception org.omg.CORBA. COMM_FAILURE

构造一个 COMM_FAILURE异常，默认次要代码为0，完成状态为COMPLETED_NO。

COMM_FAILURE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. COMM_FAILURE

构造具有指定的次要代码和完成状态的 COMM_FAILURE异常。

COMM_FAILURE(String) - Constructor for exception org.omg.CORBA. COMM_FAILURE

构造一个 COMM_FAILURE异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

COMM_FAILURE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. COMM_FAILURE

构造一个 COMM_FAILURE异常，其中包含指定的详细消息，次要代码和完成状态。

COMM_LOST - com.sun.nio.sctp. AssociationChangeNotification.AssocChangeEvent

协会失败了。

COMM_UP - com.sun.nio.sctp. AssociationChangeNotification.AssocChangeEvent

一个新的关联现在已经准备就绪，数据可以与该对等体进行交换。

COMMA - javafx.scene.input. KeyCode

常数为逗号键“，”

COMMA - jdk.nashorn.api.tree. Tree.Kind

用于表示逗号,的BinaryTree的实例。

command() - Method in class java.lang. ProcessBuilder

返回此流程构建器的操作系统程序和参数。

command() - Method in interface java.lang. ProcessHandle.Info

返回进程的可执行路径名。

command(Object) - Static method in class java.lang. Compiler

已过时。

检查参数类型及其字段并执行一些文档化操作。

command(String...) - Method in class java.lang. ProcessBuilder

设置此流程构建器的操作系统程序和参数。

command(List<String>) - Method in class java.lang. ProcessBuilder

设置此流程构建器的操作系统程序和参数。

COMMAND - javafx.scene.input. KeyCode

常数为苹果 Command键。

CommandAPDU - Class in javax.smartcardio

遵循ISO / IEC 7816-4中定义的结构的命令APDU。

CommandAPDU(byte[]) - Constructor for class javax.smartcardio. CommandAPDU

从包含完整的APDU内容（标题和正文）的字节数组构造一个CommandAPDU。

CommandAPDU(byte[], int, int) - Constructor for class javax.smartcardio. CommandAPDU

从包含完整的APDU内容（标题和正文）的字节数组构造一个CommandAPDU。

CommandAPDU(int, int, int, int) - Constructor for class javax.smartcardio. CommandAPDU

从四个头字节构造一个CommandAPDU。

CommandAPDU(int, int, int, int, byte[]) - Constructor for class javax.smartcardio. CommandAPDU

从四个头字节和命令数据构造一个CommandAPDU。

CommandAPDU(int, int, int, int, byte[], int) - Constructor for class javax.smartcardio. CommandAPDU

从四个头字节，命令数据和预期的响应数据长度构造一个CommandAPDU。

CommandAPDU(int, int, int, int, byte[], int, int) - Constructor for class javax.smartcardio. CommandAPDU

从四个头字节和命令数据构造一个CommandAPDU。

CommandAPDU(int, int, int, int, byte[], int, int, int) - Constructor for class javax.smartcardio. CommandAPDU

从四个头字节，命令数据和预期的响应数据长度构造一个CommandAPDU。

CommandAPDU(int, int, int, int, int) - Constructor for class javax.smartcardio. CommandAPDU

从四个头字节和预期的响应数据长度构造一个CommandAPDU。

CommandAPDU(ByteBuffer) - Constructor for class javax.smartcardio. CommandAPDU

从包含完整的APDU内容（标题和正文）的ByteBuffer创建一个CommandAPDU。

CommandEnvironment(String, String[]) - Constructor for class java.rmi.activation. ActivationGroupDesc.CommandEnvironment

创建一个具有所有必要信息的CommandEnvironment。

CommandInfo - Class in javax.activation

CommandMap实现使用CommandInfo类来描述命令请求的结果。

CommandInfo(String, String) - Constructor for class javax.activation. CommandInfo

CommandInfo的构造方法。

commandLine() - Method in interface java.lang. ProcessHandle.Info

返回进程的命令行。

CommandMap - Class in javax.activation

CommandMap类为系统中可用的命令对象的注册表提供了一个接口。

CommandMap() - Constructor for class javax.activation. CommandMap

CommandObject - Interface in javax.activation

Activation Framework感知的JavaBeans组件实现此接口，以找出要求执行的命令动词，并获取表示他们应该操作的数据的DataHandler。

comment(char[], int, int) - Method in class org.xml.sax.ext. DefaultHandler2

comment(char[], int, int) - Method in interface org.xml.sax.ext. LexicalHandler

在文档的任何位置报告XML注释。

comment(Element) - Method in class javax.swing.text.html. HTMLWriter

写出评论。

Comment - Interface in javax.xml.stream.events

用于评论事件的界面

Comment - Interface in org.w3c.dom

该接口继承自 CharacterData并表示注释的内容，即所有字符之间的起始' <!

COMMENT - com.sun.source.doctree. DocTree.Kind

用于表示HTML注释的CommentTree的实例。

COMMENT - Static variable in class javax.swing.text.html. HTML.Attribute

属性“评论”

COMMENT - Static variable in class javax.swing.text.html. HTML.Tag

所有评论均标有此标签。

COMMENT - Static variable in interface javax.xml.stream. XMLStreamConstants

表示事件是注释

COMMENT_NODE - Static variable in interface org.w3c.dom. Node

该节点是一个 Comment 。

commentChar(int) - Method in class java.io. StreamTokenizer

指定字符参数启动单行注释。

COMMENTS - Static variable in class java.util.regex. Pattern

允许空格和注释格式。

commentText() - Method in interface com.sun.javadoc. Doc

已过时。

返回此文档项目的注释文本。

CommentTree - Interface in com.sun.source.doctree

嵌入式HTML注释。

commit() - Method in class com.sun.security.auth.module. JndiLoginModule

提交认证过程的抽象方法（阶段2）。

commit() - Method in class com.sun.security.auth.module. KeyStoreLoginModule

提交认证过程的抽象方法（阶段2）。

commit() - Method in class com.sun.security.auth.module. Krb5LoginModule

如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

commit() - Method in class com.sun.security.auth.module. LdapLoginModule

完成用户认证。

commit() - Method in class com.sun.security.auth.module. NTLoginModule

如果LoginContext的整体身份验证成功（相关的请求，REQUISITE，SUPPICIENT和可选LoginModules成功），则调用此方法。

commit() - Method in class com.sun.security.auth.module. SolarisLoginModule

已过时。

提交认证（第二阶段）。

commit() - Method in class com.sun.security.auth.module. UnixLoginModule

提交认证（第二阶段）。

commit() - Method in interface java.sql. Connection

使之前进行的所有更改都是永久性的，并释放此 Connection对象当前持有的任何数据库锁。

commit() - Method in interface javax.security.auth.spi. LoginModule

提交认证过程的方法（阶段2）。

commit() - Method in interface javax.sql.rowset. CachedRowSet

每个 CachedRowSet对象的 SyncProvider包含一个 Connection对象，从 ResultSet或JDBC属性传递给它的构造函数。

commit() - Method in interface javax.sql.rowset. JdbcRowSet

每个 JdbcRowSet包含一个 Connection对象，从 ResultSet或JDBC属性传递给它的构造函数。

commit() - Method in interface javax.sql.rowset.spi. TransactionalWriter

自从最后一次调用 commit或 rollback方法以来，永久性地进行了所有由 acceptChanges方法执行的更改。

commit(Xid, boolean) - Method in interface javax.transaction.xa. XAResource

提交由xid指定的全局事务。

COMMIT - Static variable in class javax.swing. JFormattedTextField

常量识别当焦点丢失时，应调用 commitEdit 。

COMMIT_ON_ACCEPT_CHANGES - Static variable in interface javax.sql.rowset. CachedRowSet

已过时。
因为这个字段是final（它是接口的一部分），所以它的值不能被改变。

COMMIT_OR_REVERT - Static variable in class javax.swing. JFormattedTextField

常数确定当焦点丢失时，应该调用 commitEdit 。

commitEdit() - Method in class javax.swing. JFormattedTextField

强制从 AbstractFormatter的当前值并设置为当前值。

commitEdit() - Method in class javax.swing. JSpinner

将当前编辑的值提交到 SpinnerModel 。

commitEdit() - Method in class javax.swing. JSpinner.DefaultEditor

将当前编辑的值推送到 SpinnerModel 。

commitEdit(T) - Method in class javafx.scene.control. Cell

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

commitEdit(T) - Method in class javafx.scene.control. ListCell

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

commitEdit(T) - Method in class javafx.scene.control. TableCell

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

commitEdit(T) - Method in class javafx.scene.control. TreeCell

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

commitEdit(T) - Method in class javafx.scene.control. TreeTableCell

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

commitEdit(T) - Method in class javafx.scene.control. TreeTableRow

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

commitValue() - Method in class javafx.scene.control. ComboBox

如果ComboBox是 editable ，调用此方法将尝试提交当前文本并将其转换为 value 。

commitValue() - Method in class javafx.scene.control. Spinner

如果微调器是 editable ，调用此方法将尝试提交当前文本并将其转换为 value 。

commitValue() - Method in class javafx.scene.control. TextInputControl

提交当前文本并将其转换为值。

COMMON - java.lang. Character.UnicodeScript

Unicode脚本“常用”。

COMMON - Static variable in class java.awt. JobAttributes.DialogType

用于指定跨平台，纯Java打印对话框的 DialogType实例。

COMMON - Static variable in class javax.print.attribute.standard. DialogTypeSelection

COMMON_INDIC_NUMBER_FORMS - Static variable in class java.lang. Character.UnicodeBlock

“常用印数字”表示Unicode字符块的常数。

CommonDataSource - Interface in javax.sql

接口，定义它们之间的共同的方法 DataSource ， XADataSource和 ConnectionPoolDataSource 。

commonPool() - Static method in class java.util.concurrent. ForkJoinPool

返回公共池实例。

CommunicationException - Exception in javax.naming

当客户端无法与目录或命名服务通信时，抛出此异常。

CommunicationException() - Constructor for exception javax.naming. CommunicationException

构造一个新的CommunicationException实例。

CommunicationException(String) - Constructor for exception javax.naming. CommunicationException

使用提供的参数构造一个新的CommunicationException实例。

compact() - Method in class java.nio. ByteBuffer

压缩此缓冲区 （可选操作） 。

compact() - Method in class java.nio. CharBuffer

压缩此缓冲区 （可选操作） 。

compact() - Method in class java.nio. DoubleBuffer

压缩此缓冲区 （可选操作） 。

compact() - Method in class java.nio. FloatBuffer

压缩此缓冲区 （可选操作） 。

compact() - Method in class java.nio. IntBuffer

压缩此缓冲区 （可选操作） 。

compact() - Method in class java.nio. LongBuffer

压缩此缓冲区 （可选操作） 。

compact() - Method in class java.nio. ShortBuffer

压缩此缓冲区 （可选操作） 。

COMPACT - Static variable in class javax.swing.text.html. HTML.Attribute

属性“紧凑”

COMPACT_DISC - Static variable in class javax.sound.sampled. Port.Info

一种从CD-ROM驱动器获取音频的端口。

Comparable< T> - Interface in java.lang

该接口对实现它的每个类的对象强加一个整体排序。

comparator() - Method in class java.util.concurrent. ConcurrentSkipListMap

comparator() - Method in class java.util.concurrent. ConcurrentSkipListSet

comparator() - Method in class java.util.concurrent. PriorityBlockingQueue

返回用于为了在这个队列中的元素，或比较null如果此队列使用natural ordering的元素。

comparator() - Method in class java.util. PriorityQueue

返回用于为了在这个队列中的元素，或比较null如果此队列根据所述排序natural ordering的元素。

comparator() - Method in interface java.util. SortedMap

返回用于为了在这个映射中的键，或比较null如果此映射使用natural ordering它的键。

comparator() - Method in interface java.util. SortedSet

返回用于为了在这个组中的元素，或比较null如果这个集使用natural ordering的元素。

comparator() - Method in class java.util. TreeMap

comparator() - Method in class java.util. TreeSet

Comparator< T> - Interface in java.util

比较功能，对一些对象的集合施加了一个 整体排序 。

comparatorProperty() - Method in class javafx.collections.transformation. SortedList

比较器，表示此SortedList的顺序。

comparatorProperty() - Method in class javafx.scene.control. TableColumnBase

排序此表列时使用的比较器功能。

comparatorProperty() - Method in class javafx.scene.control. TableView

比较器属性是一个只读属性，代表 sort order列表的当前状态。

comparatorProperty() - Method in class javafx.scene.control. TreeTableView

比较器属性是一个只读属性，代表 sort order列表的当前状态。

compare(boolean[], boolean[]) - Static method in class java.util. Arrays

boolean字典顺序比较两个 boolean阵列。

compare(boolean[], int, int, boolean[], int, int) - Static method in class java.util. Arrays

比较两个 boolean阵列在 boolean指定的范围。

compare(boolean, boolean) - Static method in class java.lang. Boolean

比较两个 boolean值。

compare(byte[], byte[]) - Static method in class java.util. Arrays

比较两个 byte阵列的字典。

compare(byte[], int, int, byte[], int, int) - Static method in class java.util. Arrays

比较两个 byte阵列在 byte指定的范围。

compare(byte, byte) - Static method in class java.lang. Byte

数值比较两个 byte 。

compare(char[], char[]) - Static method in class java.util. Arrays

char字典顺序比较两个 char阵列。

compare(char[], int, int, char[], int, int) - Static method in class java.util. Arrays

比较两个 char阵列在 char指定的范围。

compare(char, char) - Static method in class java.lang. Character

数值比较两个 char数值。

compare(double[], double[]) - Static method in class java.util. Arrays

以字典顺序比较两个 double阵列。

compare(double[], int, int, double[], int, int) - Static method in class java.util. Arrays

比较两个 double阵列的字典顺序在指定范围内。

compare(double, double) - Static method in class java.lang. Double

比较两个指定的 double值。

compare(float[], float[]) - Static method in class java.util. Arrays

float字典顺序比较两个 float阵列。

compare(float[], int, int, float[], int, int) - Static method in class java.util. Arrays

比较两个 float阵列在指定范围内的字典。

compare(float, float) - Static method in class java.lang. Float

比较两个指定的 float值。

compare(int[], int[]) - Static method in class java.util. Arrays

int字典顺序比较两个 int阵列。

compare(int[], int, int, int[], int, int) - Static method in class java.util. Arrays

比较两个 int阵列在字典上超过指定的范围。

compare(int, int) - Static method in class java.lang. Integer

数值比较两个 int数值。

compare(long[], int, int, long[], int, int) - Static method in class java.util. Arrays

比较两个 long阵列在指定范围内的字典。

compare(long[], long[]) - Static method in class java.util. Arrays

long字典顺序比较两个 long阵列。

compare(long, long) - Static method in class java.lang. Long

数值比较两个 long数值。

compare(short[], int, int, short[], int, int) - Static method in class java.util. Arrays

比较两个 short阵列在 short指定的范围。

compare(short[], short[]) - Static method in class java.util. Arrays

short字典顺序比较两个 short阵列。

compare(short, short) - Static method in class java.lang. Short

数值比较两个 short数值。

compare(Object, Object) - Method in class java.text. Collator

比较其两个参数的顺序。

compare(String, String) - Method in class java.text. Collator

根据此Collator的排序规则将源字符串与目标字符串进行比较。

compare(String, String) - Method in class java.text. RuleBasedCollator

基于归类规则比较存储在两个不同字符串中的字符数据。

compare(Duration) - Method in class javax.xml.datatype. Duration

与这个 Duration实例的部分顺序关系比较。

compare(XMLGregorianCalendar) - Method in class javax.xml.datatype. XMLGregorianCalendar

根据 W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime中定义的部分顺序关系，比较W3C XML Schema 1 . 0日期/时间数据类型的两个实例。

compare(T[], int, int, T[], int, int) - Static method in class java.util. Arrays

比较两个 Object阵列在字典上超过指定的范围。

compare(T[], int, int, T[], int, int, Comparator<? super T>) - Static method in class java.util. Arrays

比较两个 Object阵列在 Object指定的范围。

compare(T[], T[]) - Static method in class java.util. Arrays

比较两个 Object阵列，可比较的元素，按字典顺序。

compare(T[], T[], Comparator<? super T>) - Static method in class java.util. Arrays

比较两个 Object阵列，使用指定的比较器进行字典比对。

compare(T, T) - Method in interface java.util. Comparator

比较其两个参数的顺序。

compare(T, T, Comparator<? super T>) - Static method in class java.util. Objects

如果参数相同，则返回0，否则返回 c.compare(a, b) 。

COMPARE_AND_EXCHANGE - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.compareAndExchange指定

COMPARE_AND_EXCHANGE_ACQUIRE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.compareAndExchangeAcquire指定

COMPARE_AND_EXCHANGE_RELEASE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.compareAndExchangeRelease指定

COMPARE_AND_SET - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.compareAndSet指定

compareAndExchange(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。

compareAndExchange(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。

compareAndExchange(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

如果元素的当前值（称为 见证值 == expectedValue ）具有 == expectedValue所指定的内存效果， == expectedValue索引 i为 newValue的元素原子设置为 i 。

compareAndExchange(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

以原子方式设置在索引元件 i到 newValue如果该元素的当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。

compareAndExchange(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

以原子方式设置在索引元件 i到 newValue如果该元素的当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。

compareAndExchange(long, long) - Method in class java.util.concurrent.atomic. AtomicLong

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。

compareAndExchange(Object...) - Method in class java.lang.invoke. VarHandle

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getVolatile(java.lang.Object...) 。

compareAndExchange(V, V) - Method in class java.util.concurrent.atomic. AtomicReference

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchange(java.lang.Object...) 。

compareAndExchangeAcquire(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。

compareAndExchangeAcquire(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。

compareAndExchangeAcquire(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeAcquire(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 2704596345941888 。

compareAndExchangeAcquire(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeAcquire(java.lang.Object...)指定的内存效果， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。

compareAndExchangeAcquire(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

以原子方式设置在索引元件 i到 newValue如果该元素的当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。

compareAndExchangeAcquire(long, long) - Method in class java.util.concurrent.atomic. AtomicLong

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。

compareAndExchangeAcquire(Object...) - Method in class java.lang.invoke. VarHandle

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getAcquire(java.lang.Object...) 。

compareAndExchangeAcquire(V, V) - Method in class java.util.concurrent.atomic. AtomicReference

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeAcquire(java.lang.Object...) 。

compareAndExchangeRelease(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。

compareAndExchangeRelease(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。

compareAndExchangeRelease(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的内存效果， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。

compareAndExchangeRelease(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

如果元素的当前值（称为 见证值 == expectedValue ）具有由 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的内存效果， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。

compareAndExchangeRelease(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

如果元素的当前值（称为 见证值 == expectedValue ）具有 VarHandle.compareAndExchangeRelease(java.lang.Object...)指定的记忆效应， == expectedValue索引 i为 newValue的元素原子设置为 newValue 。

compareAndExchangeRelease(long, long) - Method in class java.util.concurrent.atomic. AtomicLong

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。

compareAndExchangeRelease(Object...) - Method in class java.lang.invoke. VarHandle

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.setRelease(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.get(java.lang.Object...) 。

compareAndExchangeRelease(V, V) - Method in class java.util.concurrent.atomic. AtomicReference

原子将值设置为 newValue如果当前值，被称为 证人值 ， == expectedValue如通过指定，记忆效应 VarHandle.compareAndExchangeRelease(java.lang.Object...) 。

compareAndSet(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

如果当前值为 == expectedValue ，将其值设为 newValue ，具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果。

compareAndSet(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger

原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。

compareAndSet(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

如果元素的当前值为 == expectedValue ，具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果，则原子将索引 i为 newValue的元素设置为 newValue 。

compareAndSet(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

如果元素的当前值 == expectedValue具有 == expectedValue所指定的内存效果，则将索引 i为 newValue的元素原子设置为 newValue 。

compareAndSet(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。

compareAndSet(long, long) - Method in class java.util.concurrent.atomic. AtomicLong

原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。

compareAndSet(Object...) - Method in class java.lang.invoke. VarHandle

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getVolatile(java.lang.Object...) 。

compareAndSet(T, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

如果当前值为 == ，则将此更新程序管理的给定对象的字段设置为给定的更新值。

compareAndSet(T, long, long) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

如果当前值为 == ，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。

compareAndSet(T, V, V) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater

如果当前值为 == ，则将由此更新程序管理的给定对象的字段设置为给定的更新值。

compareAndSet(V, V) - Method in class java.util.concurrent.atomic. AtomicReference

原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.compareAndSet(java.lang.Object...) 。

compareAndSet(V, V, boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicMarkableReference

如果当前引用为预期引用的 == ，并且当前标记等于预期标记，则将引用和标记的值原子设置为给定更新值。

compareAndSet(V, V, int, int) - Method in class java.util.concurrent.atomic. AtomicStampedReference

如果当前引用为预期引用的 == ，并且当前印记等于预期的印记，则将引用和印记两者的值原子设置为给定的更新值。

compareAndSetForkJoinTaskTag(short, short) - Method in class java.util.concurrent. ForkJoinTask

以原子方式有条件地设置此任务的标签值。

compareAndSetPendingCount(int, int) - Method in class java.util.concurrent. CountedCompleter

只有当当前持有给定的预期值时，将挂起的计数设置为（原子地）给定计数。

compareAndSetState(int, int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

如果当前状态值等于期望值，则将同步状态原子设置为给定的更新值。

compareAndSetState(long, long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

如果当前状态值等于期望值，则将同步状态原子设置为给定的更新值。

compareBoundaryPoints(short, Range) - Method in interface org.w3c.dom.ranges. Range

比较文档中两个范围的边界点。

compareConversion(Class<?>, Class<?>, Class<?>) - Method in interface jdk.dynalink.linker. ConversionComparator

从源类型确定两种目标类型中的哪一种是首选转换目标。

compareConversion(Class<?>, Class<?>, Class<?>) - Method in interface jdk.dynalink.linker. LinkerServices

确定从源类型到两种目标类型的两种类型转换中的哪一种是首选。

compareDocumentPosition(Node) - Method in class javax.imageio.metadata. IIOMetadataNode

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

compareDocumentPosition(Node) - Method in interface org.w3c.dom. Node

将参考节点，即将被调用此方法的节点与文档中的位置相关联的节点（即作为参数传递的节点）进行比较。

compareTabOrder(Component, Component) - Method in class javax.swing. DefaultFocusManager

通过焦点遍历循环顺序对组件进行比较。

compareTo(E) - Method in class java.lang. Enum

将此枚举与指定的对象进行比较以进行订购。

compareTo(File) - Method in class java.io. File

比较两个抽象的路径名字典。

compareTo(Boolean) - Method in class java.lang. Boolean

将此 Boolean实例与另一个实例进行比较。

compareTo(Byte) - Method in class java.lang. Byte

以数字形式比较两个 Byte对象。

compareTo(Character) - Method in class java.lang. Character

以数字方式比较两个 Character对象。

compareTo(Double) - Method in class java.lang. Double

以数字方式比较两个 Double对象。

compareTo(Float) - Method in class java.lang. Float

以数字方式比较两个 Float对象。

compareTo(Integer) - Method in class java.lang. Integer

以数字比较两个 Integer对象。

compareTo(Long) - Method in class java.lang. Long

以数字形式比较两个 Long对象。

compareTo(ModuleDescriptor) - Method in class java.lang.module. ModuleDescriptor

将此模块描述符与其他描述符进行比较

compareTo(ModuleDescriptor.Exports) - Method in class java.lang.module. ModuleDescriptor.Exports

将此模块导出与另一个进行比较。

compareTo(ModuleDescriptor.Opens) - Method in class java.lang.module. ModuleDescriptor.Opens

比较这个模块打开另一个。

compareTo(ModuleDescriptor.Provides) - Method in class java.lang.module. ModuleDescriptor.Provides

比较这提供给另一个。

compareTo(ModuleDescriptor.Requires) - Method in class java.lang.module. ModuleDescriptor.Requires

将此模块的依赖性与另一个模型相比较

compareTo(ModuleDescriptor.Version) - Method in class java.lang.module. ModuleDescriptor.Version

将此模块版本与其他模块版本进行比较。

compareTo(Object) - Method in interface com.sun.javadoc. Doc

已过时。

将此doc对象与指定的对象进行比较以进行排序。

compareTo(Object) - Method in interface com.sun.javadoc. SerialFieldTag

已过时。

将此对象与指定的对象进行比较。

compareTo(Object) - Method in class java.io. ObjectStreamField

将此字段与另一个 ObjectStreamField进行比较。

compareTo(Object) - Method in class javax.naming. CompositeName

将此CompositeName与指定的对象进行比较。

compareTo(Object) - Method in class javax.naming. CompoundName

将此CompoundName与指定的对象进行比较以进行订购。

compareTo(Object) - Method in class javax.naming.ldap. LdapName

将此LdapName与指定的对象进行比较。

compareTo(Object) - Method in class javax.naming.ldap. Rdn

将此Rdn与指定的对象进行比较以进行订购。

compareTo(Object) - Method in interface javax.naming. Name

将此名称与其他名称进行比较以进行订购。

compareTo(ProcessHandle) - Method in interface java.lang. ProcessHandle

将此ProcessHandle与指定的ProcessHandle进行比较。

compareTo(Runtime.Version) - Method in class java.lang. Runtime.Version

将此版本与另一版本进行比较。

compareTo(Short) - Method in class java.lang. Short

以数字比较两个 Short对象。

compareTo(String) - Method in class java.lang. String

按字典顺序比较两个字符串。

compareTo(BigDecimal) - Method in class java.math. BigDecimal

将此 BigDecimal与指定的 BigDecimal 。

compareTo(BigInteger) - Method in class java.math. BigInteger

将此BigInteger与指定的BigInteger进行比较。

compareTo(URI) - Method in class java.net. URI

将此URI与另一个对象进行比较，该对象必须是URI。

compareTo(ByteBuffer) - Method in class java.nio. ByteBuffer

将此缓冲区与另一个缓冲区进

compareTo(CharBuffer) - Method in class java.nio. CharBuffer

将此缓冲区与另一个缓冲区进

compareTo(Charset) - Method in class java.nio.charset. Charset

将此字符串与另一个字符集进行比较

compareTo(DoubleBuffer) - Method in class java.nio. DoubleBuffer

将此缓冲区与另一个缓冲区进

compareTo(FileTime) - Method in class java.nio.file.attribute. FileTime

比较两个 FileTime对象的价值。

compareTo(Path) - Method in interface java.nio.file. Path

比较两个抽象的路径词典。

compareTo(FloatBuffer) - Method in class java.nio. FloatBuffer

将此缓冲区与另一个缓冲区进

compareTo(IntBuffer) - Method in class java.nio. IntBuffer

将此缓冲区与另一个缓冲区进

compareTo(LongBuffer) - Method in class java.nio. LongBuffer

将此缓冲区与另一个缓冲区进

compareTo(ShortBuffer) - Method in class java.nio. ShortBuffer

将此缓冲区与另一个缓冲区进

compareTo(Timestamp) - Method in class java.sql. Timestamp

将此 Timestamp对象与给定的 Timestamp对象进行比较。

compareTo(CollationKey) - Method in class java.text. CollationKey

将此CollationKey与目标CollationKey进行比较。

compareTo(ChronoLocalDate) - Method in interface java.time.chrono. ChronoLocalDate

将此日期与其他日期进行比较，包括年表。

compareTo(ChronoLocalDate) - Method in class java.time. LocalDate

将此日期与另一个日期进行比较。

compareTo(ChronoLocalDateTime<?>) - Method in interface java.time.chrono. ChronoLocalDateTime

将此日期时间与其他日期时间进行比较，包括年表。

compareTo(ChronoLocalDateTime<?>) - Method in class java.time. LocalDateTime

将此日期时间与其他日期时间进行比较。

compareTo(Chronology) - Method in class java.time.chrono. AbstractChronology

将这个年表与另一个年表进行比较。

compareTo(Chronology) - Method in interface java.time.chrono. Chronology

将这个年表与另一个年表进行比较。

compareTo(ChronoZonedDateTime<?>) - Method in interface java.time.chrono. ChronoZonedDateTime

将此日期时间与其他日期时间进行比较，包括年表。

compareTo(Duration) - Method in class java.time. Duration

将此持续时间与指定的 Duration 。

compareTo(Instant) - Method in class java.time. Instant

将此瞬间与指定的时刻进行比较。

compareTo(LocalTime) - Method in class java.time. LocalTime

比较这个时间到另一个时间。

compareTo(MonthDay) - Method in class java.time. MonthDay

比较这个月份到另一个月的日子。

compareTo(OffsetDateTime) - Method in class java.time. OffsetDateTime

将此日期时间与其他日期时间进行比较。

compareTo(OffsetTime) - Method in class java.time. OffsetTime

比较这个 OffsetTime到另一个时间。

compareTo(Year) - Method in class java.time. Year

今年再比较一年。

compareTo(YearMonth) - Method in class java.time. YearMonth

比较今年至另一个月。

compareTo(ZoneOffsetTransition) - Method in class java.time.zone. ZoneOffsetTransition

根据转换时刻将此转换与另一个进行比较。

compareTo(ZoneOffset) - Method in class java.time. ZoneOffset

将此偏移量与其他偏移量按降序进行比较。

compareTo(Calendar) - Method in class java.util. Calendar

比较由两个 Calendar对象表示的时间值（ Epoch的毫秒偏移量）。

compareTo(Date) - Method in class java.sql. Timestamp

将此 Timestamp对象与给定的 Date对象进行比较。

compareTo(Date) - Method in class java.util. Date

比较两个日期进行订购。

compareTo(UUID) - Method in class java.util. UUID

将此UUID与指定的UUID进行比较。

compareTo(Match) - Method in class javafx.css. Match

compareTo(Duration) - Method in class javafx.util. Duration

比较由此对象和指定对象表示的持续时间。

compareTo(ObjectName) - Method in class javax.management. ObjectName

比较两个ObjectName实例。

compareTo(T) - Method in interface java.lang. Comparable

将此对象与指定的对象进行比较以进行排序。

compareToIgnoreCase(String) - Method in class java.lang. String

按字典顺序比较两个字符串，忽略病例差异。

compareToIgnoreOptional(Runtime.Version) - Method in class java.lang. Runtime.Version

将此版本与其他版本进行比较，忽略可选构建信息。

compareUnsigned(byte[], byte[]) - Static method in class java.util. Arrays

比较两个 byte阵列的 byte ，数字处理元素为无符号。

compareUnsigned(byte[], int, int, byte[], int, int) - Static method in class java.util. Arrays

将两个 byte数组按照指定的范围进行 byte比较，将元素数字化处理为无符号。

compareUnsigned(byte, byte) - Static method in class java.lang. Byte

比较两个 byte值以数字方式将值视为无符号。

compareUnsigned(int[], int[]) - Static method in class java.util. Arrays

比较两个 int阵列在 int ，数字处理元素为无符号。

compareUnsigned(int[], int, int, int[], int, int) - Static method in class java.util. Arrays

将两个 int数组按照 int顺序比较在指定范围内，将元素数字化处理为无符号。

compareUnsigned(int, int) - Static method in class java.lang. Integer

比较两个 int值以数字方式将值视为无符号。

compareUnsigned(long[], int, int, long[], int, int) - Static method in class java.util. Arrays

比较两个 long阵列在指定范围内的数字化处理，以无符号的形式处理元素。

compareUnsigned(long[], long[]) - Static method in class java.util. Arrays

比较两个 long数组的字典，数字处理元素为无符号。

compareUnsigned(long, long) - Static method in class java.lang. Long

比较两个 long值以数字方式将值视为无符号。

compareUnsigned(short[], int, int, short[], int, int) - Static method in class java.util. Arrays

比较两个 short阵列在指定的范围内，以数字方式处理元素为无符号。

compareUnsigned(short[], short[]) - Static method in class java.util. Arrays

比较两个 short阵列的字典，数字处理元素为无符号。

compareUnsigned(short, short) - Static method in class java.lang. Short

比较两个 short值以数字方式将值视为无符号。

comparing(Function<? super T, ? extends U>) - Static method in interface java.util. Comparator

接受从类型T中提取Comparable排序键的T ，并返回一个Comparator<T> ，该排序键与该排序键进行比较。

comparing(Function<? super T, ? extends U>, Comparator<? super U>) - Static method in interface java.util. Comparator

接受从类型T中提取排序键的T ，并返回一个Comparator<T> ，该类别使用指定的Comparator进行比较。

comparingByKey() - Static method in interface java.util. Map.Entry

返回一个比较器， 按键的自然顺序比较Map.Entry 。

comparingByKey(Comparator<? super K>) - Static method in interface java.util. Map.Entry

返回一个比较器，比较Map.Entry按键使用给定的Comparator 。

comparingByValue() - Static method in interface java.util. Map.Entry

返回一个比较器， 它以自然顺序比较Map.Entry的值。

comparingByValue(Comparator<? super V>) - Static method in interface java.util. Map.Entry

返回一个比较器，使用给定的Comparator比较Map.Entry的值。

comparingDouble(ToDoubleFunction<? super T>) - Static method in interface java.util. Comparator

接受从类型 T中提取 double排序键的功能，并返回一个按该排序键进行比较的 Comparator<T> 。

comparingInt(ToIntFunction<? super T>) - Static method in interface java.util. Comparator

接受从类型 T中提取 int排序键的 T ，并返回一个按该排序键进行比较的 Comparator<T> 。

comparingLong(ToLongFunction<? super T>) - Static method in interface java.util. Comparator

接受从类型 T中提取 long排序键的 T ，并返回与该排序键进行比较的 Comparator<T> 。

Compilable - Interface in javax.script

ScriptEngines实现的可选接口，其方法将脚本编译为可重复执行的表单，而无需重新编译。

COMPILATION - com.sun.source.util. TaskEvent.Kind

在解析第一个源文件之前发送，并在写入最后一个输出文件之后发送。

COMPILATION_MXBEAN_NAME - Static variable in class java.lang.management. ManagementFactory

字符串表示的ObjectName为CompilationMXBean 。

COMPILATION_UNIT - com.sun.source.tree. Tree.Kind

用于CompilationUnitTree的实例。

COMPILATION_UNIT - jdk.nashorn.api.tree. Tree.Kind

用于CompilationUnitTree的实例。

CompilationMXBean - Interface in java.lang.management

Java虚拟机编译系统的管理界面。

CompilationUnitTree - Interface in com.sun.source.tree

表示编译单元（源文件）和程序包声明（package-info.java）的抽象语法树。

CompilationUnitTree - Interface in jdk.nashorn.api.tree

表示编译单元（源文件）的抽象语法树

compile(Reader) - Method in interface javax.script. Compilable

编译脚本（源码为 Reader ）供以后执行。

compile(Reader) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

compile(String) - Static method in class java.util.regex. Pattern

将给定的正则表达式编译为模式。

compile(String) - Method in interface javax.script. Compilable

编译脚本（源代码为 String ）供以后执行。

compile(String) - Method in interface javax.xml.xpath. XPath

编译XPath表达式供以后评估。

compile(String) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

compile(String[]) - Static method in class com.sun.tools.javac. Main

Java编程语言编程器的编程接口javac。

compile(String[], PrintWriter) - Static method in class com.sun.tools.javac. Main

Java编程语言编程器的编程接口javac。

compile(String, int) - Static method in class java.util.regex. Pattern

将给定的正则表达式编译为带有给定标志的模式。

compileClass(Class<?>) - Static method in class java.lang. Compiler

已过时。

编译指定的类。

compileClasses(String) - Static method in class java.lang. Compiler

已过时。

编译名称与指定字符串匹配的所有类。

CompiledScript - Class in javax.script

由存储编译结果的类扩展。

CompiledScript() - Constructor for class javax.script. CompiledScript

compiledVersion() - Method in class java.lang.module. ModuleDescriptor.Requires

如果在编译时记录，则返回模块的版本。

Compiler - Class in java.lang

不推荐用于删除：此API元素将在以后的版本中被删除。
JIT编译器及其技术变化太大，可以通过标准化界面有效地进行控制。 因此，许多JIT编译器实现忽略此接口，而是由特定于实现的机制（如命令行选项）控制。 此类可能在将来的Java SE版本中被删除。

compilerOptions(String...) - Method in class jdk.jshell. JShell.Builder

添加编译器选项。

complementOf(EnumSet<E>) - Static method in class java.util. EnumSet

创建与指定枚举集具有相同元素类型的枚举集，最初包含此类型的所有元素，该元素 不包含在指定的集合中。

CompletableFuture< T> - Class in java.util.concurrent

A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持在完成后触发的依赖功能和操作。

CompletableFuture() - Constructor for class java.util.concurrent. CompletableFuture

创建一个新的不完整的CompletableFuture。

CompletableFuture.AsynchronousCompletionTask - Interface in java.util.concurrent

标识接口，用于标识由 async方法生成的异步任务。

complete() - Method in class java.util. Calendar

填写日历字段中的任何未设置的字段。

complete(boolean) - Method in class com.sun.nio.sctp. MessageInfo

设置消息是否完成。

complete(T) - Method in class java.util.concurrent. CompletableFuture

如果尚未完成，请将返回的值设置为 CompletableFuture.get()，并将相关方法设置为给定值。

complete(T) - Method in class java.util.concurrent. CountedCompleter

无论挂起的数量如何，调用 CountedCompleter.onCompletion(CountedCompleter) ，将此任务标记为完成，并进一步触发 CountedCompleter.tryComplete()对此任务的完成（如果存在）。

complete(V) - Method in class java.util.concurrent. ForkJoinTask

完成此任务，如果尚未中止或取消，则返回给定值作为以后调用的结果 join和相关操作。

COMPLETE - jdk.jshell. SourceCodeAnalysis.Completeness

输入是一个完整的源代码段（声明或语句）。

COMPLETE - Static variable in class java.awt. MediaTracker

表示媒体下载成功的标志。

COMPLETE_WITH_SEMI - jdk.jshell. SourceCodeAnalysis.Completeness

通过添加分号，输入是完整的源代码段。

completeAsync(Supplier<? extends T>) - Method in class java.util.concurrent. CompletableFuture

使用默认执行程序从异步任务调用给定的供应商函数的结果，完成此CompletableFuture。

completeAsync(Supplier<? extends T>, Executor) - Method in class java.util.concurrent. CompletableFuture

使用给定的执行器从异步任务调用给定的供应商函数的结果来完成此CompletableFuture。

completed - Variable in exception org.omg.CORBA. SystemException

抛出此异常的操作状态。

completed(V, A) - Method in interface java.nio.channels. CompletionHandler

操作完成后调用。

COMPLETED - Static variable in class javax.print.attribute.standard. JobState

作业已成功完成或处理完毕后出现警告或错误，所有作业介质单已经成功堆放在相应的输出仓中，并且所有作业状态属性已达到作业的最终值。

COMPLETED_MAYBE - Static variable in class org.omg.CORBA. CompletionStatus

一个 CompletionStatus实例用常量 _COMPLETED_MAYBE初始化。

COMPLETED_NO - Static variable in class org.omg.CORBA. CompletionStatus

一个 CompletionStatus的实例用常量 _COMPLETED_NO初始化。

COMPLETED_YES - Static variable in class org.omg.CORBA. CompletionStatus

一个实例 CompletionStatus用常量 _COMPLETED_YES初始化。

completedFuture(U) - Static method in class java.util.concurrent. CompletableFuture

返回已经使用给定值完成的新的CompletableFuture。

completeDrag(int, int) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController

消息finishDraggingTo与鼠标事件的新位置。

completeDrag(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController

消息finishDraggingTo与鼠标事件的新位置。

completedStage(U) - Static method in class java.util.concurrent. CompletableFuture

返回已经使用给定值完成的新CompletionStage，并仅支持接口CompletionStage中的那些方法。

completeEditing() - Method in class javax.swing.plaf.basic. BasicTreeUI

消息停止编辑会话。

completeEditing(boolean, boolean, boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI

停止编辑会话。

completeExceptionally(Throwable) - Method in class java.util.concurrent. CompletableFuture

如果还没有完成，会导致调用 CompletableFuture.get()和相关方法来抛出给定的异常。

completeExceptionally(Throwable) - Method in class java.util.concurrent. ForkJoinTask

完成此任务异常，如果尚未中止或取消，将导致给予异常 join和相关操作。

completeness() - Method in interface jdk.jshell. SourceCodeAnalysis.CompletionInfo

分析输入的完整性。

completeOnTimeout(T, long, TimeUnit) - Method in class java.util.concurrent. CompletableFuture

如果在给定的超时之前未完成，则使用给定值完成此CompletableFuture。

COMPLETESCANLINES - Static variable in interface java.awt.image. ImageConsumer

像素将以完整的扫描线一次传输（倍数）。

completeUIInstall() - Method in class javax.swing.plaf.basic. BasicTreeUI

在安装了所有默认值/监听器之后从installUI调用。

completeUIUninstall() - Method in class javax.swing.plaf.basic. BasicTreeUI

卸载UI

completion(CompletableFuture<Void>, CompletableFuture<Void>) - Method in interface jdk.incubator.http. HttpResponse.MultiProcessor

当聚合结果对象本身可用时，返回一个CompletableFuture <U> 。

Completion - Interface in javax.annotation.processing

A建议 completion用于注释。

CompletionException - Exception in java.util.concurrent

在完成结果或任务的过程中遇到错误或其他异常时抛出异常。

CompletionException() - Constructor for exception java.util.concurrent. CompletionException

构造一个 CompletionException ，没有详细消息。

CompletionException(String) - Constructor for exception java.util.concurrent. CompletionException

构造具有指定详细消息的 CompletionException 。

CompletionException(String, Throwable) - Constructor for exception java.util.concurrent. CompletionException

构造一个具有指定的详细信息和原因的 CompletionException 。

CompletionException(Throwable) - Constructor for exception java.util.concurrent. CompletionException

构造具有指定原因的 CompletionException 。

CompletionHandler< V, A> - Interface in java.nio.channels

用于消除异步I / O操作结果的处理程序。

Completions - Class in javax.annotation.processing

组装Completion对象的实用类。

CompletionService< V> - Interface in java.util.concurrent

一种将新异步任务的生产与已完成任务的结果消耗相分离的服务。

CompletionStage< T> - Interface in java.util.concurrent

可能的异步计算的阶段，当另一个完成时间完成时，执行一个动作或计算一个值。

CompletionStatus - Class in org.omg.CORBA

指示当抛出 SystemException时方法是否已完成运行的对象。

CompletionStatusHelper - Class in org.omg.CORBA

助手 CompletionStatus 。

CompletionStatusHelper() - Constructor for class org.omg.CORBA. CompletionStatusHelper

completionSuggestions(String, int, int[]) - Method in class jdk.jshell. SourceCodeAnalysis

计算给定输入的可能跟踪。

component - Variable in class java.awt.dnd. DragGestureRecognizer

该 Component与此 DragGestureRecognizer相关联。

component - Static variable in class javax.swing. ImageIcon

已过时。
自1.8

Component - Class in java.awt

组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。

Component() - Constructor for class java.awt. Component

构造一个新的组件。

COMPONENT - Static variable in class com.sun.java.accessibility.util. EventID

映射到AWT组件支持（即ComponentListener和ComponentEvent）

COMPONENT - Static variable in class java.awt.font. GlyphMetrics

表示后备存储中没有相应字符的字形。

COMPONENT_ADDED - Static variable in class java.awt.event. ContainerEvent

此事件表示组件已添加到容器中。

component_count() - Method in class org.omg.DynamicAny. _DynAnyStub

返回DynAny的组件数。

component_count() - Method in class org.omg.DynamicAny. _DynArrayStub

返回DynAny的组件数。

component_count() - Method in class org.omg.DynamicAny. _DynEnumStub

返回DynAny的组件数。

component_count() - Method in class org.omg.DynamicAny. _DynFixedStub

返回DynAny的组件数。

component_count() - Method in class org.omg.DynamicAny. _DynSequenceStub

返回DynAny的组件数。

component_count() - Method in class org.omg.DynamicAny. _DynStructStub

返回DynAny的组件数。

component_count() - Method in class org.omg.DynamicAny. _DynUnionStub

返回DynAny的组件数。

component_count() - Method in class org.omg.DynamicAny. _DynValueStub

返回DynAny的组件数。

component_count() - Method in interface org.omg.DynamicAny. DynAnyOperations

返回DynAny的组件数。

component_data - Variable in class org.omg.IOP. TaggedComponent

组件数据与组件ID相关联。

COMPONENT_EVENT_MASK - Static variable in class java.awt. AWTEvent

用于选择组件事件的事件掩码。

COMPONENT_FIRST - Static variable in class java.awt.event. ComponentEvent

用于组件事件的ids范围中的第一个数字。

COMPONENT_HIDDEN - Static variable in class java.awt.event. ComponentEvent

此事件表示该组件被呈现为不可见。

COMPONENT_LAST - Static variable in class java.awt.event. ComponentEvent

用于组件事件的ID的范围中的最后一个数字。

COMPONENT_MOVED - Static variable in class java.awt.event. ComponentEvent

此事件表示组件的位置已更改。

COMPONENT_REMOVED - Static variable in class java.awt.event. ContainerEvent

此事件表示组件已从容器中删除。

COMPONENT_RESIZED - Static variable in class java.awt.event. ComponentEvent

此事件表示组件的大小已更改。

COMPONENT_SHOWN - Static variable in class java.awt.event. ComponentEvent

此事件表示组件已显示。

Component.AccessibleAWTComponent - Class in java.awt

组件的内部类用于为辅助功能提供默认支持。

Component.AccessibleAWTComponent.AccessibleAWTComponentHandler - Class in java.awt

Fire PropertyChange监听器，如果已注册，显示/隐藏..

Component.AccessibleAWTComponent.AccessibleAWTFocusHandler - Class in java.awt

Fire PropertyChange监听器，如果有注册，焦点事件发生时

Component.BaselineResizeBehavior - Enum in java.awt

枚举组件的基准线随着大小变化而改变的常见方式。

Component.BltBufferStrategy - Class in java.awt

内部类别将屏幕外表面喷涂到组件上。

Component.FlipBufferStrategy - Class in java.awt

内部类用于在组件上翻转缓冲区。

ComponentAdapter - Class in java.awt.event

用于接收组件事件的抽象适配器类。

ComponentAdapter() - Constructor for class java.awt.event. ComponentAdapter

componentAdded(ContainerEvent) - Method in class java.awt. AWTEventMulticaster

通过调用listener-a和listener-b上的componentAdded方法来处理componentAdded容器事件。

componentAdded(ContainerEvent) - Method in class java.awt. Container.AccessibleAWTContainer.AccessibleContainerHandler

componentAdded(ContainerEvent) - Method in class java.awt.event. ContainerAdapter

当组件已添加到容器时调用。

componentAdded(ContainerEvent) - Method in interface java.awt.event. ContainerListener

当组件已添加到容器时调用。

componentAdded(ContainerEvent) - Method in class javax.swing. JComponent.AccessibleJComponent.AccessibleContainerHandler

componentAdded(ContainerEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.ToolBarContListener

ComponentAttribute - Static variable in class javax.swing.text. StyleConstants

组件属性的名称。

ComponentColorModel - Class in java.awt.image

一个 ColorModel类，用于将颜色和alpha信息表示为单独样本的像素值，并将每个样本存储在单独的数据元素中。

ComponentColorModel(ColorSpace, boolean, boolean, int, int) - Constructor for class java.awt.image. ComponentColorModel

从指定的参数构造一个 ComponentColorModel 。

ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) - Constructor for class java.awt.image. ComponentColorModel

从指定的参数构造一个 ComponentColorModel 。

ComponentElementName - Static variable in class javax.swing.text. StyleConstants

用于表示组件的元素的名称。

ComponentEvent - Class in java.awt.event

指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。

ComponentEvent(Component, int) - Constructor for class java.awt.event. ComponentEvent

构造一个 ComponentEvent对象。

componentForPoint(Component, Point) - Method in class javax.swing. MenuSelectionManager

返回当前所选路径中包含sourcePoint的组件。

ComponentHandler() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameUI.ComponentHandler

ComponentHandler() - Constructor for class javax.swing.plaf.basic. BasicSliderUI.ComponentHandler

ComponentHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.ComponentHandler

componentHidden(ComponentEvent) - Method in class java.awt. AWTEventMulticaster

通过在listener-a和listener-b上调用componentHidden方法来处理componentHidden事件。

componentHidden(ComponentEvent) - Method in class java.awt. Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

componentHidden(ComponentEvent) - Method in class java.awt.event. ComponentAdapter

当该组件不可见时调用。

componentHidden(ComponentEvent) - Method in interface java.awt.event. ComponentListener

当该组件不可见时调用。

componentHidden(ComponentEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.ComponentHandler

当该组件不可见时调用。

ComponentIdHelper - Class in org.omg.IOP

表示多组件配置文件的标准方式。

ComponentIdHelper() - Constructor for class org.omg.IOP. ComponentIdHelper

ComponentInputMap - Class in javax.swing

甲 ComponentInputMap是 InputMap与特定关联 JComponent 。

ComponentInputMap(JComponent) - Constructor for class javax.swing. ComponentInputMap

创建与指定组件关联的 ComponentInputMap 。

ComponentInputMapUIResource - Class in javax.swing.plaf

实现UIResource的javax.swing.ComponentInputMap的子类。

ComponentInputMapUIResource(JComponent) - Constructor for class javax.swing.plaf. ComponentInputMapUIResource

构造一个 ComponentInputMapUIResource 。

componentListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor

不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。

componentListener - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI

组件侦听器

componentListener - Variable in class javax.swing.plaf.basic. BasicSliderUI

组件侦听器

ComponentListener - Interface in java.awt.event

用于接收组件事件的侦听器接口。

componentMoved(ComponentEvent) - Method in class java.awt. AWTEventMulticaster

通过调用listener-a和listener-b上的componentMoved方法来处理componentMoved事件。

componentMoved(ComponentEvent) - Method in class java.awt. Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

componentMoved(ComponentEvent) - Method in class java.awt.event. ComponentAdapter

当组件的位置更改时调用。

componentMoved(ComponentEvent) - Method in interface java.awt.event. ComponentListener

当组件的位置更改时调用。

componentMoved(ComponentEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.ComponentHandler

当组件的位置更改时调用。

componentMoved(ComponentEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.ComponentHandler

ComponentOrientation - Class in java.awt

ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。

componentRemoved(ContainerEvent) - Method in class java.awt. AWTEventMulticaster

通过调用listener-a和listener-b上的componentRemoved方法来处理componentRemoved容器事件。

componentRemoved(ContainerEvent) - Method in class java.awt. Container.AccessibleAWTContainer.AccessibleContainerHandler

componentRemoved(ContainerEvent) - Method in class java.awt.event. ContainerAdapter

当组件从容器中删除时调用。

componentRemoved(ContainerEvent) - Method in interface java.awt.event. ContainerListener

当组件从容器中删除时调用。

componentRemoved(ContainerEvent) - Method in class javax.swing. JComponent.AccessibleJComponent.AccessibleContainerHandler

componentRemoved(ContainerEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.ToolBarContListener

componentResized(ComponentEvent) - Method in class java.awt. AWTEventMulticaster

通过调用listener-a和listener-b上的componentResized方法来处理componentResized事件。

componentResized(ComponentEvent) - Method in class java.awt. Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

componentResized(ComponentEvent) - Method in class java.awt.event. ComponentAdapter

当组件的大小更改时调用。

componentResized(ComponentEvent) - Method in interface java.awt.event. ComponentListener

当组件的大小更改时调用。

componentResized(ComponentEvent) - Method in class javax.swing. JViewport.ViewListener

componentResized(ComponentEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.ComponentHandler

当JInternalFrame的父级大小更改时调用。

componentResized(ComponentEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.ComponentHandler

components - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

组件。

COMPONENTS_CONFIGURATION_B - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“ComponentsConfiguration”标签一起使用的值。

COMPONENTS_CONFIGURATION_CB - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“ComponentsConfiguration”标签一起使用的值。

COMPONENTS_CONFIGURATION_CR - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“ComponentsConfiguration”标签一起使用的值。

COMPONENTS_CONFIGURATION_DOES_NOT_EXIST - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“ComponentsConfiguration”标签一起使用的值。

COMPONENTS_CONFIGURATION_G - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“ComponentsConfiguration”标签一起使用的值。

COMPONENTS_CONFIGURATION_R - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“ComponentsConfiguration”标签一起使用的值。

COMPONENTS_CONFIGURATION_Y - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“ComponentsConfiguration”标签一起使用的值。

components_established(IORInfo) - Method in interface org.omg.PortableInterceptor. IORInterceptor_3_0Operations

在所有注册的IORInterceptor实例上调用了Estab_components之后，在所有已注册的IORInterceptor_3_0实例上调用了components_established方法。

ComponentSampleModel - Class in java.awt.image

该类表示存储的图像数据，使得像素的每个样本占据DataBuffer的一个数据元素。

ComponentSampleModel(int, int, int, int, int, int[]) - Constructor for class java.awt.image. ComponentSampleModel

使用指定的参数构造一个ComponentSampleModel。

ComponentSampleModel(int, int, int, int, int, int[], int[]) - Constructor for class java.awt.image. ComponentSampleModel

使用指定的参数构造一个ComponentSampleModel。

componentShown(ComponentEvent) - Method in class java.awt. AWTEventMulticaster

通过调用listener-a和listener-b上的componentShown方法来处理componentShown事件。

componentShown(ComponentEvent) - Method in class java.awt. Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

componentShown(ComponentEvent) - Method in class java.awt.event. ComponentAdapter

当组件可见时调用。

componentShown(ComponentEvent) - Method in interface java.awt.event. ComponentListener

当组件可见时调用。

componentShown(ComponentEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.ComponentHandler

当组件可见时调用。

componentSignature() - Method in interface com.sun.jdi. ArrayType

获取该数组类的组件的JNI签名。

componentType() - Method in interface com.sun.jdi. ArrayType

返回数组声明中指定的该数组的组件类型。

componentTypeName() - Method in interface com.sun.jdi. ArrayType

返回此数组的组件类型的文本表示形式。

ComponentUI - Class in javax.swing.plaf

所有UI委托对象的基类在Swing可插拔外观和体系结构中。

ComponentUI() - Constructor for class javax.swing.plaf. ComponentUI

唯一的构造函数。

ComponentView - Class in javax.swing.text

实现视图界面的组件装饰器。

ComponentView(Element) - Constructor for class javax.swing.text. ComponentView

创建一个新的ComponentView对象。

componentWithFocus - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor

不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用; 使用getComponentWithFocus方法获取焦点的组件。

compose(Raster, Raster, WritableRaster) - Method in interface java.awt. CompositeContext

组合两个源Raster对象，并将结果放在目标WritableRaster中 。

compose(MethodHandle) - Method in class jdk.dynalink.linker. GuardedInvocation

将调用，保护，切换点和异常组合到复合方法句柄中，该句柄知道当保护失败或调用无效时如何退回。

compose(MethodHandle, MethodHandle, MethodHandle) - Method in class jdk.dynalink.linker. GuardedInvocation

将调用，保护，切换点和异常组合到复合方法句柄中，该句柄知道当保护失败或调用无效时如何退回。

compose(ModuleFinder...) - Static method in interface java.lang.module. ModuleFinder

返回由零个或多个模块查找器的序列组成的模块查找器。

compose(DoubleUnaryOperator) - Method in interface java.util.function. DoubleUnaryOperator

返回一个组合运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。

compose(Function<? super V, ? extends T>) - Method in interface java.util.function. Function

返回一个组合函数，首先将 before函数应用于其输入，然后将此函数应用于结果。

compose(IntUnaryOperator) - Method in interface java.util.function. IntUnaryOperator

返回一个组合运算符，首先将 before运算符应用于其输入，然后将该运算符应用于结果。

compose(LongUnaryOperator) - Method in interface java.util.function. LongUnaryOperator

返回一个 before运算符，首先将其 before符应用于其输入，然后将该运算符应用于结果。

COMPOSE - javafx.scene.input. KeyCode

输入法/常规键的常数。

ComposedTextAttribute - Static variable in class javax.swing.text. StyleConstants

输入法的名称组合文本属性。

composeName(String, String) - Method in interface javax.naming. Context

使用相对于该上下文的名称组合此上下文的名称。

composeName(String, String) - Method in class javax.naming. InitialContext

使用相对于该上下文的名称组合此上下文的名称。

composeName(Name, Name) - Method in interface javax.naming. Context

使用相对于该上下文的名称组合此上下文的名称。

composeName(Name, Name) - Method in class javax.naming. InitialContext

使用相对于该上下文的名称组合此上下文的名称。

Composite - Interface in java.awt

Composite界面，以及CompositeContext ，定义了组合绘图基元与底层图形区域的方法。

CompositeContext - Interface in java.awt

CompositeContext接口定义了合成操作的封装和优化环境。

CompositeData - Interface in javax.management.openmbean

CompositeData接口指定了表示 复合数据结构的特定类型的复杂 开放数据对象的行为。

CompositeDataInvocationHandler - Class in javax.management.openmbean

一个InvocationHandler ，将getter方法转发到一个CompositeData 。

CompositeDataInvocationHandler(CompositeData) - Constructor for class javax.management.openmbean. CompositeDataInvocationHandler

构造由给定的 CompositeData支持的处理程序。

CompositeDataSupport - Class in javax.management.openmbean

CompositeDataSupport类是实现 CompositeData接口的 开放数据类。

CompositeDataSupport(CompositeType, String[], Object[]) - Constructor for class javax.management.openmbean. CompositeDataSupport

构造一个 CompositeDataSupport实例与指定 compositeType ，其项值由指定 itemValues[] ，以相同的顺序为 itemNames[] 。

CompositeDataSupport(CompositeType, Map<String, ?>) - Constructor for class javax.management.openmbean. CompositeDataSupport

构造具有指定的 compositeType的 CompositeDataSupport实例，其项目名称和对应的值由映射 items中的映射 items 。

CompositeDataView - Interface in javax.management.openmbean

Java类可以实现此接口，以指示如何通过MXBean框架将其转换为 CompositeData 。

CompositeGuardingDynamicLinker - Class in jdk.dynalink.linker.support

A GuardingDynamicLinker在其CompositeGuardingDynamicLinker.getGuardedInvocation(LinkRequest, LinkerServices)中顺序地委派给其他守护动态链接器的列表 。

CompositeGuardingDynamicLinker(Iterable<? extends GuardingDynamicLinker>) - Constructor for class jdk.dynalink.linker.support. CompositeGuardingDynamicLinker

创建一个新的复合链接器。

CompositeName - Class in javax.naming

此类表示组合名称 - 跨多个命名空间的组件名称序列。

CompositeName() - Constructor for class javax.naming. CompositeName

构造一个新的空复合名称。

CompositeName(String) - Constructor for class javax.naming. CompositeName

通过使用复合名称语法（从左到右，斜杠分隔）解析字符串n来构造新的复合名称实例。

CompositeName(Enumeration<String>) - Constructor for class javax.naming. CompositeName

使用“comps”指定的组件构造新的组合名称实例。

CompositeType - Class in javax.management.openmbean

CompositeType类是其实例描述的类型为CompositeData的开放式类。

CompositeType(String, String, String[], String[], OpenType<?>[]) - Constructor for class javax.management.openmbean. CompositeType

构造一个 CompositeType实例，检查给定参数的有效性。

CompositeTypeBasedGuardingDynamicLinker - Class in jdk.dynalink.linker.support

一种基于复合类型的保护动态链接器。

CompositeTypeBasedGuardingDynamicLinker(Iterable<? extends TypeBasedGuardingDynamicLinker>) - Constructor for class jdk.dynalink.linker.support. CompositeTypeBasedGuardingDynamicLinker

创建一个新的基于复合类型的链接器。

CompositeView - Class in javax.swing.text

CompositeView是一个抽象的 View实现，它管理一个或多个子视图。

CompositeView(Element) - Constructor for class javax.swing.text. CompositeView

为给定元素构造一个 CompositeView 。

CompoundAssignmentTree - Interface in com.sun.source.tree

复合赋值运算符的树节点。

CompoundAssignmentTree - Interface in jdk.nashorn.api.tree

复合赋值运算符的树节点。

CompoundBorder - Class in javax.swing.border

一个复合的Border类，用于通过在Border对象的外部嵌套内嵌一个Border对象来将两个Border对象组合成一个单一的边框。

CompoundBorder() - Constructor for class javax.swing.border. CompoundBorder

在边框外部和内部创建一个复合边框。

CompoundBorder(Border, Border) - Constructor for class javax.swing.border. CompoundBorder

用指定的外部和内部边框创建复合边框。

CompoundBorderUIResource(Border, Border) - Constructor for class javax.swing.plaf. BorderUIResource.CompoundBorderUIResource

构造一个 CompoundBorderUIResource 。

CompoundControl - Class in javax.sound.sampled

A CompoundControl （例如图形均衡器）提供对两个或多个相关属性的控制，每个属性本身表示为 Control 。

CompoundControl(CompoundControl.Type, Control[]) - Constructor for class javax.sound.sampled. CompoundControl

使用给定的参数构造一个新的复合控件对象。

CompoundControl.Type - Class in javax.sound.sampled

CompoundControl.Type内部类的实例标识一种复合控件。

compoundEdit - Variable in class javax.swing.undo. UndoableEditSupport

复合编辑。

CompoundEdit - Class in javax.swing.undo

AbstractUndoableEdit的一个具体子类，用于将小的UndoableEdits组合成大型的。

CompoundEdit() - Constructor for class javax.swing.undo. CompoundEdit

构造一个 CompoundEdit 。

CompoundName - Class in javax.naming

该类表示复合名称 - 来自分层名称空间的名称。

CompoundName(String, Properties) - Constructor for class javax.naming. CompoundName

通过使用提供的语法属性指定的语法解析字符串n来构造新的化合物名称实例。

CompoundName(Enumeration<String>, Properties) - Constructor for class javax.naming. CompoundName

使用comps和syntax中指定的组件构造一个新的复合名称实例。

CompoundSelector - Class in javafx.css

根据CSS标准行事的复合选择器。

COMPRESS - Static variable in class javax.print.attribute.standard. Compression

UNIX压缩技术。

Compression - Class in javax.print.attribute.standard

类压缩是打印属性类，枚举，用于指定打印数据的压缩方式。

Compression(int) - Constructor for class javax.print.attribute.standard. Compression

使用给定的整数值构造新的压缩枚举值。

COMPRESSION_CCITT_RLE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_CCITT_T_4 - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_CCITT_T_6 - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_DEFLATE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_ERROR - Static variable in class javax.print.attribute.standard. JobStateReason

该作业被系统中止，因为打印机在解压缩文档数据时遇到错误。

COMPRESSION_JPEG - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_LZW - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_NONE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_OLD_JPEG - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_PACKBITS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

COMPRESSION_ZLIB - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“压缩”标签一起使用的值。

compressionMode - Variable in class javax.imageio. ImageWriteParam

模式控制压缩设置，必须设置为四个 MODE_*值。

compressionQuality - Variable in class javax.imageio. ImageWriteParam

A float包含当前的压缩质量设置。

compressionType - Variable in class javax.imageio. ImageWriteParam

A String包含当前压缩类型的名称，如果没有设置， null 。

compressionTypes - Variable in class javax.imageio. ImageWriteParam

包含可用压缩类型名称的 String的数组。

comptable - Variable in class java.awt. GridBagLayout

这个散列表维护了一个组件与其gridbag约束之间的关联。

compute() - Method in class java.util.concurrent. CountedCompleter

这个任务执行的主要计算。

compute() - Method in class java.util.concurrent. RecursiveAction

这个任务执行的主要计算。

compute() - Method in class java.util.concurrent. RecursiveTask

这个任务执行的主要计算。

compute(Object, BiFunction<? super Object, ? super Object, ?>) - Method in class java.util. Properties

compute(Object, BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security. Provider

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentHashMap

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.concurrent. ConcurrentMap

尝试计算指定键及其当前映射值的映射（如果没有当前映射，则 null ）。

compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentSkipListMap

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. HashMap

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. Hashtable

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util. Map

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

computeAreaInScreen() - Method in class javafx.scene. Node

返回以像素为单位投影到物理屏幕上的 Node的面积。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxBaseSkin

基于第一个受管理的子节点计算基线偏移量。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase

基于第一个受管理的子节点计算基线偏移量。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control.skin. ProgressBarSkin

基于第一个受管理的子节点计算基线偏移量。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin

基于第一个受管理的子节点计算基线偏移量。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control.skin. TabPaneSkin

基于第一个受管理的子节点计算基线偏移量。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control.skin. TextAreaSkin

基于第一个受管理的子节点计算基线偏移量。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control.skin. TextFieldSkin

基于第一个受管理的子节点计算基线偏移量。

computeBaselineOffset(double, double, double, double) - Method in class javafx.scene.control. SkinBase

基于第一个受管理的子节点计算基线偏移量。

computeBlit(int, int, Point, Point, Dimension, Rectangle) - Method in class javax.swing. JViewport

计算一个blit的参数，其中后备存储图像当前包含 oldLoc在左上角，我们正在滚动到 newLoc 。

computeDifference(Rectangle, Rectangle) - Static method in class javax.swing. SwingUtilities

方便返回表示 rectA中与 rectB不重叠的区域的rect数组。

computeFields() - Method in class java.util. Calendar

当前毫秒时间值转换为 Calendar.time的日历字段值 fields[] 。

computeFields() - Method in class java.util. GregorianCalendar

将时间值（从 Epoch的毫秒偏移）转换为日历字段值。

computeIfAbsent(Object, Function<? super Object, ?>) - Method in class java.util. Properties

computeIfAbsent(Object, Function<? super Object, ? extends Object>) - Method in class java.security. Provider

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util.concurrent. ConcurrentHashMap

如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

computeIfAbsent(K, Function<? super K, ? extends V>) - Method in interface java.util.concurrent. ConcurrentMap

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util.concurrent. ConcurrentSkipListMap

如果指定的键尚未与值相关联，则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util. HashMap

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util. Hashtable

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

computeIfAbsent(K, Function<? super K, ? extends V>) - Method in interface java.util. Map

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

computeIfPresent(Object, BiFunction<? super Object, ? super Object, ?>) - Method in class java.util. Properties

computeIfPresent(Object, BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security. Provider

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentHashMap

如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。

computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.concurrent. ConcurrentMap

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentSkipListMap

如果存在指定键的值，则尝试计算给出键的新映射及其当前映射值。

computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. HashMap

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. Hashtable

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util. Map

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

computeIntersection(int, int, int, int, Rectangle) - Static method in class javax.swing. SwingUtilities

方便计算两个矩形的交点，而不分配一个新的矩形。

computeMaxHeight(double) - Method in class javafx.scene.control. Control

根据提供的宽度计算控制的最大允许高度。

computeMaxHeight(double) - Method in class javafx.scene.layout. Region

计算该区域的最大高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ChoiceBoxSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxBaseSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ListCellSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuBarSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuButtonSkinBase

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ProgressBarSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollBarSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SeparatorSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SliderSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TableRowSkinBase

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TextFieldSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ToolBarSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TreeCellSkin

根据提供的宽度计算皮肤的最大允许高度。

computeMaxHeight(double, double, double, double, double) - Method in class javafx.scene.control. SkinBase

根据提供的宽度计算皮肤的最大允许高度。

computeMaxWidth(double) - Method in class javafx.scene.control. Control

根据提供的高度计算控件的最大允许宽度。

computeMaxWidth(double) - Method in class javafx.scene.layout. Region

计算此区域的最大宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ChoiceBoxSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxBaseSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuButtonSkinBase

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ProgressBarSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollBarSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SeparatorSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SliderSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TitledPaneSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ToolBarSkin

根据提供的高度计算皮肤的最大允许宽度。

computeMaxWidth(double, double, double, double, double) - Method in class javafx.scene.control. SkinBase

根据提供的高度计算皮肤的最大允许宽度。

computeMinHeight(double) - Method in class javafx.scene.chart. Chart

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

computeMinHeight(double) - Method in class javafx.scene.control. Control

根据提供的宽度计算控制的最小允许高度。

computeMinHeight(double) - Method in class javafx.scene.control. DialogPane

计算该区域的最小高度。

computeMinHeight(double) - Method in class javafx.scene.control.skin. TableColumnHeader

计算该区域的最小高度。

computeMinHeight(double) - Method in class javafx.scene.control.skin. TableHeaderRow

计算该区域的最小高度。

computeMinHeight(double) - Method in class javafx.scene.layout. AnchorPane

computeMinHeight(double) - Method in class javafx.scene.layout. BorderPane

computeMinHeight(double) - Method in class javafx.scene.layout. FlowPane

computeMinHeight(double) - Method in class javafx.scene.layout. GridPane

computeMinHeight(double) - Method in class javafx.scene.layout. HBox

computeMinHeight(double) - Method in class javafx.scene.layout. Region

计算该区域的最小高度。

computeMinHeight(double) - Method in class javafx.scene.layout. StackPane

computeMinHeight(double) - Method in class javafx.scene.layout. TilePane

computeMinHeight(double) - Method in class javafx.scene.layout. VBox

computeMinHeight(double) - Method in class javafx.scene. Parent

计算这个 Parent的最小高度。

computeMinHeight(double) - Method in class javafx.scene.text. TextFlow

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. AccordionSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. CheckBoxSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ChoiceBoxSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ListCellSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuBarSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuButtonSkinBase

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. PaginationSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. RadioButtonSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollBarSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollPaneSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SeparatorSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SliderSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SplitPaneSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TableRowSkinBase

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TextFieldSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TitledPaneSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ToolBarSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TreeCellSkin

根据提供的宽度计算皮肤的最小允许高度。

computeMinHeight(double, double, double, double, double) - Method in class javafx.scene.control. SkinBase

根据提供的宽度计算皮肤的最小允许高度。

computeMinWidth(double) - Method in class javafx.scene.chart. Chart

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

computeMinWidth(double) - Method in class javafx.scene.control. Control

根据提供的高度计算控件的最小允许宽度。

computeMinWidth(double) - Method in class javafx.scene.control. DialogPane

计算该区域的最小宽度。

computeMinWidth(double) - Method in class javafx.scene.layout. AnchorPane

computeMinWidth(double) - Method in class javafx.scene.layout. BorderPane

computeMinWidth(double) - Method in class javafx.scene.layout. FlowPane

computeMinWidth(double) - Method in class javafx.scene.layout. GridPane

computeMinWidth(double) - Method in class javafx.scene.layout. HBox

computeMinWidth(double) - Method in class javafx.scene.layout. Region

计算该区域的最小宽度。

computeMinWidth(double) - Method in class javafx.scene.layout. StackPane

computeMinWidth(double) - Method in class javafx.scene.layout. TilePane

computeMinWidth(double) - Method in class javafx.scene.layout. VBox

computeMinWidth(double) - Method in class javafx.scene. Parent

计算这个 Parent的最小宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. CheckBoxSkin

计算并返回此Labeled的最小宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ChoiceBoxSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. DatePickerSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase

计算并返回此Labeled的最小宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuBarSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuButtonSkinBase

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. PaginationSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. RadioButtonSkin

计算并返回此Labeled的最小宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollBarSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollPaneSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SeparatorSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SliderSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SplitPaneSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TitledPaneSkin

计算并返回此Labeled的最小宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ToolBarSkin

根据提供的高度计算皮肤的最小允许宽度。

computeMinWidth(double, double, double, double, double) - Method in class javafx.scene.control. SkinBase

根据提供的高度计算皮肤的最小允许宽度。

computePopupBounds(int, int, int, int) - Method in class javax.swing.plaf.basic. BasicComboPopup

基于组合框位置和封闭屏幕边界，计算组合框的弹出部分的位置和大小。

computePrefHeight(double) - Method in class javafx.scene.chart. Axis

计算给定宽度的该轴的首选高度。

computePrefHeight(double) - Method in class javafx.scene.chart. Chart

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

computePrefHeight(double) - Method in class javafx.scene.control. Control

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

computePrefHeight(double) - Method in class javafx.scene.control. DialogPane

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

computePrefHeight(double) - Method in class javafx.scene.control.skin. NestedTableColumnHeader

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

computePrefHeight(double) - Method in class javafx.scene.control.skin. TableColumnHeader

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

computePrefHeight(double) - Method in class javafx.scene.control.skin. TableHeaderRow

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

computePrefHeight(double) - Method in class javafx.scene.control.skin. VirtualFlow

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

computePrefHeight(double) - Method in class javafx.scene.layout. AnchorPane

computePrefHeight(double) - Method in class javafx.scene.layout. BorderPane

computePrefHeight(double) - Method in class javafx.scene.layout. FlowPane

computePrefHeight(double) - Method in class javafx.scene.layout. GridPane

computePrefHeight(double) - Method in class javafx.scene.layout. HBox

computePrefHeight(double) - Method in class javafx.scene.layout. Region

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

computePrefHeight(double) - Method in class javafx.scene.layout. StackPane

computePrefHeight(double) - Method in class javafx.scene.layout. TilePane

computePrefHeight(double) - Method in class javafx.scene.layout. VBox

computePrefHeight(double) - Method in class javafx.scene. Parent

计算这个 Parent的首选高度。

computePrefHeight(double) - Method in class javafx.scene.text. TextFlow

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. AccordionSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. CheckBoxSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ChoiceBoxSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxBaseSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. DateCellSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ListCellSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ListViewSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuBarSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuButtonSkinBase

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. PaginationSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ProgressBarSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. RadioButtonSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollBarSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollPaneSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SeparatorSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SliderSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. SplitPaneSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TableRowSkinBase

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TableViewSkinBase

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TabPaneSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TextFieldSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TitledPaneSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. ToolBarSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TreeCellSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control.skin. TreeViewSkin

计算这个 SkinBase的首选高度。

computePrefHeight(double, double, double, double, double) - Method in class javafx.scene.control. SkinBase

计算这个 SkinBase的首选高度。

computePrefWidth(double) - Method in class javafx.scene.chart. Axis

计算给定高度的该轴的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.chart. Chart

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

computePrefWidth(double) - Method in class javafx.scene.control. Control

计算给定高度的该区域的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.control. DialogPane

计算给定高度的该区域的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.control.skin. NestedTableColumnHeader

计算给定高度的该区域的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.control.skin. TableColumnHeader

计算给定高度的该区域的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.control.skin. TableHeaderRow

计算给定高度的该区域的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.control.skin. VirtualFlow

计算给定高度的该区域的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.layout. AnchorPane

computePrefWidth(double) - Method in class javafx.scene.layout. BorderPane

computePrefWidth(double) - Method in class javafx.scene.layout. FlowPane

computePrefWidth(double) - Method in class javafx.scene.layout. GridPane

computePrefWidth(double) - Method in class javafx.scene.layout. HBox

computePrefWidth(double) - Method in class javafx.scene.layout. Region

计算给定高度的该区域的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.layout. StackPane

computePrefWidth(double) - Method in class javafx.scene.layout. TilePane

computePrefWidth(double) - Method in class javafx.scene.layout. VBox

computePrefWidth(double) - Method in class javafx.scene. Parent

计算这个 Parent的首选宽度。

computePrefWidth(double) - Method in class javafx.scene.text. TextFlow

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. CheckBoxSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ChoiceBoxSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ColorPickerSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxBaseSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. DateCellSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ListCellSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ListViewSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuBarSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. MenuButtonSkinBase

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. PaginationSkin

计算 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ProgressBarSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. RadioButtonSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollBarSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ScrollPaneSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SeparatorSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SliderSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. SplitPaneSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TableCellSkinBase

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TableRowSkinBase

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TableViewSkinBase

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TabPaneSkin

计算 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TextFieldSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TitledPaneSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. ToolBarSkin

计算此 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TreeCellSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control.skin. TreeViewSkin

计算这个 SkinBase的首选宽度。

computePrefWidth(double, double, double, double, double) - Method in class javafx.scene.control. SkinBase

计算这个 SkinBase的首选宽度。

computeRegions(ImageReadParam, int, int, BufferedImage, Rectangle, Rectangle) - Static method in class javax.imageio. ImageReader

计算感兴趣的源区域和目标区域，将源图像的宽度和高度，可选的目标图像和可选的 ImageReadParam考虑在内。

computerIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI

电脑图标

computeStringWidth(FontMetrics, String) - Static method in class javax.swing. SwingUtilities

使用指定的“metrics”（大小）的字体计算字符串的宽度。

computeStringWidth(SynthContext, Font, FontMetrics, String) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils

返回传入的字符串的大小。

computeTime() - Method in class java.util. Calendar

将 fields[]中的当前日历字段值 转换为毫秒时间值 Calendar.time 。

computeTime() - Method in class java.util. GregorianCalendar

将日历字段值转换为时间值（与 Epoch的毫秒偏移量）。

computeUnion(int, int, int, int, Rectangle) - Static method in class javax.swing. SwingUtilities

计算两个矩形的并集而不分配新矩形的便捷方法。

computeValue() - Method in class javafx.beans.binding. BooleanBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. DoubleBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. FloatBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. IntegerBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. ListBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. LongBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. MapBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. ObjectBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. SetBinding

计算此绑定的当前值。

computeValue() - Method in class javafx.beans.binding. StringBinding

计算此绑定的当前值。

computeValue(Class<?>) - Method in class java.lang. ClassValue

计算给定类的派生值为 ClassValue 。

computeVisibleRect(Rectangle) - Method in class javax.swing. JComponent

返回 Component的“可见矩形矩形” - 该组件的可见矩形与其所有祖先的交集。

concat(Object) - Method in class javafx.beans.binding. StringExpression

返回一个 StringExpression ，该值保持 StringExpression与另一个 Object连接的值。

concat(Object...) - Static method in class javafx.beans.binding. Bindings

返回一个StringExpression ，它保持多个并置值Objects 。

concat(String) - Method in class java.lang. String

将指定的字符串连接到该字符串的末尾。

concat(DoubleStream, DoubleStream) - Static method in interface java.util.stream. DoubleStream

创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。

concat(IntStream, IntStream) - Static method in interface java.util.stream. IntStream

创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。

concat(LongStream, LongStream) - Static method in interface java.util.stream. LongStream

创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。

concat(Stream<? extends T>, Stream<? extends T>) - Static method in interface java.util.stream. Stream

创建一个懒惰连接的流，其元素是第一个流的所有元素，后跟第二个流的所有元素。

concat(ObservableList<E>...) - Static method in class javafx.collections. FXCollections

将更多可观察的列表连接成一个。

concatenate(AffineTransform) - Method in class java.awt.geom. AffineTransform

将 AffineTransform Tx连接到此 AffineTransform Cx中，以最常用的方式提供映射到前一个用户空间的新用户空间 Tx 。

concatenateTransform(AffineTransform) - Method in class java.awt.image.renderable. RenderContext

通过附加另一个转换来修改当前的用户到设备的转换。

concetenateTransform(AffineTransform) - Method in class java.awt.image.renderable. RenderContext

已过时。
替换为concatenateTransform(AffineTransform) 。

concrete_base_type() - Method in class org.omg.CORBA. TypeCode

返回描述 TypeCode对象描述的值类型的具体基类型的 TypeCode对象。

concreteMethodByName(String, String) - Method in interface com.sun.jdi. ClassType

返回从该类可见的具有给定名称和签名的单个非抽象方法 。

CONCUR_READ_ONLY - Static variable in interface java.sql. ResultSet

该常量指示可能不会更新的 ResultSet对象的并发模式。

CONCUR_UPDATABLE - Static variable in interface java.sql. ResultSet

该常量指示可能更新的 ResultSet对象的并发模式。

CONCURRENT - java.util.stream. Collector.Characteristics

表示此收集器是 并发的 ，这意味着结果容器可以支持与多个线程相同的结果容器同时调用的累加器函数。

CONCURRENT - Static variable in interface java.util. Spliterator

特征值表示可以通过多个线程安全同时修改元素源（允许添加，替换和/或删除），而无需外部同步。

ConcurrentHashMap< K, V> - Class in java.util.concurrent

支持检索的完全并发性和更新的高预期并发性的哈希表。

ConcurrentHashMap() - Constructor for class java.util.concurrent. ConcurrentHashMap

创建一个新的，空的地图与默认的初始表大小（16）。

ConcurrentHashMap(int) - Constructor for class java.util.concurrent. ConcurrentHashMap

创建一个新的空的地图，其初始表格大小适应指定数量的元素，而不需要动态调整大小。

ConcurrentHashMap(int, float) - Constructor for class java.util.concurrent. ConcurrentHashMap

根据给定的元素数量（ initialCapacity ）和初始表格密度（ loadFactor ）创建一个新的，空的地图，初始的表格大小。

ConcurrentHashMap(int, float, int) - Constructor for class java.util.concurrent. ConcurrentHashMap

创建具有基于给定数量的元件（初始表大小的新的空映射 initialCapacity ），表密度（ loadFactor ），并同时更新线程（数 concurrencyLevel ）。

ConcurrentHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.concurrent. ConcurrentHashMap

创建与给定地图相同的映射的新地图。

ConcurrentHashMap.KeySetView< K, V> - Class in java.util.concurrent

ConcurrentHashMap视图为一个Set的密钥，其中可以通过映射到公共值来选择添加。

ConcurrentLinkedDeque< E> - Class in java.util.concurrent

基于链接节点的无界并发deque 。

ConcurrentLinkedDeque() - Constructor for class java.util.concurrent. ConcurrentLinkedDeque

构造一个空的德克。

ConcurrentLinkedDeque(Collection<? extends E>) - Constructor for class java.util.concurrent. ConcurrentLinkedDeque

构造最初包含给定集合的元素的deque，以集合的迭代器的遍历顺序添加。

ConcurrentLinkedQueue< E> - Class in java.util.concurrent

基于链接节点的无界线程安全queue 。

ConcurrentLinkedQueue() - Constructor for class java.util.concurrent. ConcurrentLinkedQueue

创建一个最初为空的 ConcurrentLinkedQueue 。

ConcurrentLinkedQueue(Collection<? extends E>) - Constructor for class java.util.concurrent. ConcurrentLinkedQueue

创建一个 ConcurrentLinkedQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。

ConcurrentMap< K, V> - Interface in java.util.concurrent

A Map提供线程安全和原子性保证。

ConcurrentModificationException - Exception in java.util

当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。

ConcurrentModificationException() - Constructor for exception java.util. ConcurrentModificationException

构造一个没有详细消息的ConcurrentModificationException。

ConcurrentModificationException(String) - Constructor for exception java.util. ConcurrentModificationException

构造具有指定详细消息的 ConcurrentModificationException 。

ConcurrentModificationException(String, Throwable) - Constructor for exception java.util. ConcurrentModificationException

构造一个新的异常与指定的详细信息和原因。

ConcurrentModificationException(Throwable) - Constructor for exception java.util. ConcurrentModificationException

构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause 。

ConcurrentNavigableMap< K, V> - Interface in java.util.concurrent

A ConcurrentMap支持NavigableMap操作，并且对其可导航子地图进行递归。

ConcurrentSkipListMap< K, V> - Class in java.util.concurrent

一个可扩展并发的ConcurrentNavigableMap实现。

ConcurrentSkipListMap() - Constructor for class java.util.concurrent. ConcurrentSkipListMap

构造一个新的，空的地图，按照natural ordering的按键进行排序。

ConcurrentSkipListMap(Comparator<? super K>) - Constructor for class java.util.concurrent. ConcurrentSkipListMap

构造一个新的，空的地图，根据指定的比较器进行排序。

ConcurrentSkipListMap(Map<? extends K, ? extends V>) - Constructor for class java.util.concurrent. ConcurrentSkipListMap

构造一个新映射，其中包含与给定映射相同的映射，根据密钥的natural ordering进行排序。

ConcurrentSkipListMap(SortedMap<K, ? extends V>) - Constructor for class java.util.concurrent. ConcurrentSkipListMap

构造一个包含相同映射并使用与指定排序映射相同顺序的新映射。

ConcurrentSkipListSet< E> - Class in java.util.concurrent

可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。

ConcurrentSkipListSet() - Constructor for class java.util.concurrent. ConcurrentSkipListSet

构造一个新的，空的集合，根据它们的natural ordering命令其元素。

ConcurrentSkipListSet(Collection<? extends E>) - Constructor for class java.util.concurrent. ConcurrentSkipListSet

构造一个包含指定集合中的元素的新集合，根据它们的natural ordering对其元素进行排序 。

ConcurrentSkipListSet(Comparator<? super E>) - Constructor for class java.util.concurrent. ConcurrentSkipListSet

构造一个新的空集合，根据指定的比较器对其元素进行排序。

ConcurrentSkipListSet(SortedSet<E>) - Constructor for class java.util.concurrent. ConcurrentSkipListSet

构造一个包含相同元素并使用与指定排序集相同顺序的新集合。

Condition - Interface in java.util.concurrent.locks

Condition因素出Object监视器方法（ wait ， notify和notifyAll ）成不同的对象，以得到具有多个等待集的每个对象，通过将它们与使用任意的组合的效果Lock个实现。

CONDITIONAL_AND - com.sun.source.tree. Tree.Kind

用于实例BinaryTree代表条件和&& 。

CONDITIONAL_AND - jdk.nashorn.api.tree. Tree.Kind

用于实例BinaryTree代表条件和&& 。

CONDITIONAL_EXPRESSION - com.sun.source.tree. Tree.Kind

用于ConditionalExpressionTree的实例。

CONDITIONAL_EXPRESSION - jdk.nashorn.api.tree. Tree.Kind

用于ConditionalExpressionTree的实例。

CONDITIONAL_OR - com.sun.source.tree. Tree.Kind

用于实例BinaryTree表示有条件或|| 。

CONDITIONAL_OR - jdk.nashorn.api.tree. Tree.Kind

用于实例BinaryTree表示有条件或|| 。

ConditionalExpressionTree - Interface in com.sun.source.tree

条件运算符的树节点？

ConditionalExpressionTree - Interface in jdk.nashorn.api.tree

条件运算符的树节点？

ConditionalFeature - Enum in javafx.application

定义一组条件（可选）功能。

ConditionalLoopTree - Interface in jdk.nashorn.api.tree

一个混合条件的“循环”语句。

ConditionObject() - Constructor for class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject

创建一个新的 ConditionObject实例。

ConditionObject() - Constructor for class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject

创建一个新的 ConditionObject实例。

config(String) - Method in class java.util.logging. Logger

记录CONFIG消息。

config(Supplier<String>) - Method in class java.util.logging. Logger

记录一个CONFIG消息，只有在记录级别实际上记录该消息时，才能构建一个CONFIG消息。

CONFIG - Static variable in class java.util.logging. Level

CONFIG是静态配置消息的消息级别。

CONFIG_FILE - com.sun.management. VMOption.Origin

VM选项通过配置文件设置。

ConfigFile - Class in com.sun.security.auth.login

此类表示 javax.security.auth.login.Configuration的默认实现。

ConfigFile() - Constructor for class com.sun.security.auth.login. ConfigFile

创建一个新的 Configuration对象。

ConfigFile(URI) - Constructor for class com.sun.security.auth.login. ConfigFile

从指定的 URI创建一个新的 Configuration对象。

configuration() - Method in class java.lang.module. ResolvedModule

返回此已解析模块所在的配置。

configuration() - Method in class java.lang. ModuleLayer

返回此图层的配置。

Configuration - Class in java.lang.module

的构造的结果是 resolution或分辨率 service binding 。

Configuration - Class in javax.security.auth.login

一个配置对象负责指定哪一个LoginModule应该用于一个特定的应用程序，以及以什么顺序调用LoginModule。

Configuration() - Constructor for class javax.security.auth.login. Configuration

唯一的构造函数。

Configuration.Parameters - Interface in javax.security.auth.login

这表示配置参数的标记界面。

ConfigurationException - Exception in javax.naming

出现配置问题时抛出此异常。

ConfigurationException() - Constructor for exception javax.naming. ConfigurationException

构造一个具有所有名称解析字段的ConfigurationException的新实例，并将说明初始化为null。

ConfigurationException(String) - Constructor for exception javax.naming. ConfigurationException

使用解释构造一个新的ConfigurationException实例。

ConfigurationSpi - Class in javax.security.auth.login

该类定义了 Configuration类的 （ SPI ）。

ConfigurationSpi() - Constructor for class javax.security.auth.login. ConfigurationSpi

configure(HttpsParameters) - Method in class com.sun.net.httpserver. HttpsConfigurator

由HttpsServer调用以配置当前正在建立的https连接的参数。

configure(String) - Method in class java.security. Provider

将提供的配置参数应用于此提供程序实例并返回配置的提供程序。

configureArrowButton() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

这种公共方法是实现具体的，应该是私有的。

configureBlocking(boolean) - Method in class java.nio.channels. SelectableChannel

调整此频道的屏蔽模式。

configureBlocking(boolean) - Method in class java.nio.channels.spi. AbstractSelectableChannel

调整此频道的屏蔽模式。

configureEditor() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

此受保护方法是实现特定的，应该是私有的。

configureEditor() - Method in class javax.swing.plaf.metal. MetalComboBoxUI

configureEditor(ComboBoxEditor, Object) - Method in class javax.swing. JComboBox

用指定的项目初始化编辑器。

configureEnclosingScrollPane() - Method in class javax.swing. JTable

如果这 JTable是 viewportView的封闭 JScrollPane （通常情况下），配置此 ScrollPane的，除其他事项外，安装表的 tableHeader为 columnHeaderView滚动窗格。

configureGraphics(Graphics2D) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter

配置给定的Graphics2D。

configureLayoutCache() - Method in class javax.swing.plaf.basic. BasicTreeUI

根据我们提供的外观和感觉树重新设置TreeState实例。

configureList() - Method in class javax.swing.plaf.basic. BasicComboPopup

配置用于在弹出窗口中保存组合框项目的列表。

configurePopup() - Method in class javax.swing.plaf.basic. BasicComboPopup

配置组合框的弹出部分。

configurePropertiesFromAction(Action) - Method in class javax.swing. AbstractButton

设置此按钮上的属性，以匹配指定的 Action中的 Action 。

configurePropertiesFromAction(Action) - Method in class javax.swing. JComboBox

设置此组合框上的属性，以匹配指定的 Action中的 Action 。

configurePropertiesFromAction(Action) - Method in class javax.swing. JMenuItem

设置此按钮上的属性与指定的 Action的属性相匹配。

configurePropertiesFromAction(Action) - Method in class javax.swing. JTextField

设置此文本字段上的属性以匹配指定的 Action中的 Action 。

configureScrollBarColors() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

配置滚动条颜色。

configureScrollBarColors() - Method in class javax.swing.plaf.metal. MetalScrollBarUI

configureScrollBarColors() - Method in class javax.swing.plaf.synth. SynthScrollBarUI

配置滚动条颜色。

configureScroller() - Method in class javax.swing.plaf.basic. BasicComboPopup

配置在组合框弹出窗口中保存列表的可滚动部分。

CONFIRMATION - javafx.scene.control. Alert.AlertType

CONFIRMATION警报类型配置警报对话框，以提示对话框的内容正在寻求用户确认的方式显示。

ConfirmationCallback - Class in javax.security.auth.callback

基础安全服务实例，并通过一个 ConfirmationCallback至 handle一个方法 CallbackHandler ，以请求YES / NO，确定/取消，YES / NO / CANCEL或其他类似的确认。

ConfirmationCallback(int, int, int) - Constructor for class javax.security.auth.callback. ConfirmationCallback

使用消息类型，选项类型和默认选项构造 ConfirmationCallback 。

ConfirmationCallback(int, String[], int) - Constructor for class javax.security.auth.callback. ConfirmationCallback

使用消息类型，选项列表和默认选项构造 ConfirmationCallback 。

ConfirmationCallback(String, int, int, int) - Constructor for class javax.security.auth.callback. ConfirmationCallback

使用提示符，消息类型，选项类型和默认选项构造 ConfirmationCallback 。

ConfirmationCallback(String, int, String[], int) - Constructor for class javax.security.auth.callback. ConfirmationCallback

使用提示，消息类型，选项列表和默认选项构建 ConfirmationCallback 。

confirmHandlerProperty() - Method in class javafx.scene.web. WebEngine

JavaScript confirm处理程序属性。

connect() - Method in class java.net. URLConnection

打开与此URL引用的资源的通信链接，如果此类连接尚未建立。

connect() - Method in interface javax.management.remote. JMXConnector

建立与连接器服务器的连接。

connect() - Method in class javax.management.remote.rmi. RMIConnector

connect(PipedInputStream) - Method in class java.io. PipedOutputStream

将此管道输出流连接到接收器。

connect(PipedOutputStream) - Method in class java.io. PipedInputStream

使此管道输入流连接到管道输出流 src 。

connect(PipedReader) - Method in class java.io. PipedWriter

将此管道写入器连接到接收器。

connect(PipedWriter) - Method in class java.io. PipedReader

使这个管道读取器连接到管道写入器 src 。

connect(String) - Method in class javax.smartcardio. CardTerminal

建立与卡的连接。

connect(String, int) - Method in class java.net. SocketImpl

将此套接字连接到指定主机上的指定端口。

connect(String, Properties) - Method in interface java.sql. Driver

尝试使数据库连接到给定的URL。

connect(InetAddress, int) - Method in class java.net. DatagramSocket

将套接字连接到此套接字的远程地址。

connect(InetAddress, int) - Method in class java.net. DatagramSocketImpl

将数据报套接字连接到远程目标。

connect(InetAddress, int) - Method in class java.net. SocketImpl

将此套接字连接到指定主机上的指定端口号。

connect(SocketAddress) - Method in class com.sun.nio.sctp. SctpChannel

连接此通道的插座。

connect(SocketAddress) - Method in class java.net. DatagramSocket

将此套接字连接到远程套接字地址（IP地址+端口号）。

connect(SocketAddress) - Method in class java.net. Socket

将此套接字连接到服务器。

connect(SocketAddress) - Method in class java.nio.channels. AsynchronousSocketChannel

连接此频道。

connect(SocketAddress) - Method in class java.nio.channels. DatagramChannel

连接此通道的插座。

connect(SocketAddress) - Method in class java.nio.channels. SocketChannel

连接此通道的插座。

connect(SocketAddress, int) - Method in class java.net. Socket

将此套接字连接到具有指定超时值的服务器。

connect(SocketAddress, int) - Method in class java.net. SocketImpl

将此套接字连接到指定主机上的指定端口号。

connect(SocketAddress, int, int) - Method in class com.sun.nio.sctp. SctpChannel

连接此通道的插座。

connect(SocketAddress, A, CompletionHandler<Void, ? super A>) - Method in class java.nio.channels. AsynchronousSocketChannel

连接此频道。

connect(Remote, Remote) - Method in interface javax.rmi.CORBA. PortableRemoteObjectDelegate

代表团要求 PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 。

connect(Remote, Remote) - Static method in class javax.rmi. PortableRemoteObject

使远程对象准备好进行远程通信。

connect(Map<String, ?>) - Method in interface javax.management.remote. JMXConnector

建立与连接器服务器的连接。

connect(Map<String, ?>) - Method in class javax.management.remote.rmi. RMIConnector

connect(JMXServiceURL) - Static method in class javax.management.remote. JMXConnectorFactory

创建与给定地址的连接器服务器的连接。

connect(JMXServiceURL, Map<String, ?>) - Static method in class javax.management.remote. JMXConnectorFactory

创建与给定地址的连接器服务器的连接。

connect(Stub, ORB) - Method in interface javax.rmi.CORBA. StubDelegate

代表团要求 Stub.connect(org.omg.CORBA.ORB) 。

connect(Object) - Method in class org.omg.CORBA. ORB

将给定的服务对象（作为服务器实现类的实例的Java对象）连接到ORB。

connect(ORB) - Method in class javax.rmi.CORBA. Stub

将此存根连接到ORB。

connected - Variable in class java.net. URLConnection

如果 false ，此连接对象尚未创建指定URL的通信链接。

CONNECTED - com.sun.tools.jconsole. JConsoleContext.ConnectionState

连接已成功建立。

connectedVirtualMachines() - Method in interface com.sun.jdi. VirtualMachineManager

列出连接到调试器的所有目标虚拟机。

ConnectException - Exception in java.net

指示尝试将套接字连接到远程地址和端口时发生错误。

ConnectException - Exception in java.rmi

如果连接被拒绝到远程主机进行远程方法调用，则抛出 ConnectException 。

ConnectException() - Constructor for exception java.net. ConnectException

构造一个没有详细消息的新ConnectException。

ConnectException(String) - Constructor for exception java.net. ConnectException

构造一个新的ConnectException与指定的详细信息，为什么连接错误发生。

ConnectException(String) - Constructor for exception java.rmi. ConnectException

构造具有指定详细消息的 ConnectException 。

ConnectException(String, Exception) - Constructor for exception java.rmi. ConnectException

构造具有指定的详细消息和嵌套异常的 ConnectException 。

connectFailed(URI, SocketAddress, IOException) - Method in class java.net. ProxySelector

被称为表示连接不能建立到代理/袜子服务器。

CONNECTING - com.sun.tools.jconsole. JConsoleContext.ConnectionState

正在尝试连接。

CONNECTING_TO_DEVICE - Static variable in class javax.print.attribute.standard. PrinterStateReason

打印机已经在输出设备上安排了一个作业，并且正在连接到共享网络输出设备（并且可能无法实际开始打印作业任意长时间，具体取决于其他设备的使用情况）网络上的服务器）。

ConnectIOException - Exception in java.rmi

如果在与远程主机进行远程方法调用的连接时发生 ConnectIOException则抛出 IOException 。

ConnectIOException(String) - Constructor for exception java.rmi. ConnectIOException

构造具有指定详细消息的 ConnectIOException 。

ConnectIOException(String, Exception) - Constructor for exception java.rmi. ConnectIOException

构造具有指定的详细消息和嵌套异常的 ConnectIOException 。

Connection - Class in com.sun.jdi.connect.spi

调试器和调试器之间的连接。

Connection - Interface in java.sql

与特定数据库的连接（会话）。

Connection() - Constructor for class com.sun.jdi.connect.spi. Connection

CONNECTION_STATE_PROPERTY - Static variable in interface com.sun.tools.jconsole. JConsoleContext

ConnectionState绑定属性名称。

ConnectionBuilder - Interface in java.sql

从 DataSource对象创建的构建器，用于建立与 data source对象所表示的数据库的连接。

connectionClosed(String, String, Object) - Method in class javax.management.remote. JMXConnectorServer

当客户端连接正常关闭时，由子类调用。

connectionClosed(String, String, Object) - Method in class javax.management.remote.rmi. RMIConnectorServer

connectionClosed(ConnectionEvent) - Method in interface javax.sql. ConnectionEventListener

通知这个 ConnectionEventListener该应用程序已经调用了方法 close对其合并连接的表示。

connectionErrorOccurred(ConnectionEvent) - Method in interface javax.sql. ConnectionEventListener

通知此 ConnectionEventListener发生了致命错误，并且无法再使用合并的连接。

ConnectionEvent - Class in javax.sql

一个 Event对象，提供有关连接相关事件源的信息。

ConnectionEvent(PooledConnection) - Constructor for class javax.sql. ConnectionEvent

构造一个用给定的 ConnectionEvent对象初始化的 PooledConnection对象。

ConnectionEvent(PooledConnection, SQLException) - Constructor for class javax.sql. ConnectionEvent

构造一个 ConnectionEvent对象，该对象使用给定的 PooledConnection对象和 SQLException对象进行初始化。

ConnectionEventListener - Interface in javax.sql

注册要通知由 PooledConnection对象生成的事件的对象。

connectionFailed(String, String, Object) - Method in class javax.management.remote. JMXConnectorServer

当客户端连接失败时由子类调用。

connectionFailed(String, String, Object) - Method in class javax.management.remote.rmi. RMIConnectorServer

connectionOpened(String, String, Object) - Method in class javax.management.remote. JMXConnectorServer

当新的客户端连接打开时由子类调用。

connectionOpened(String, String, Object) - Method in class javax.management.remote.rmi. RMIConnectorServer

ConnectionPendingException - Exception in java.nio.channels

当尝试连接已经在进行非阻塞连接操作的SocketChannel时抛出未检查的异常。

ConnectionPendingException() - Constructor for exception java.nio.channels. ConnectionPendingException

构造这个类的一个实例。

ConnectionPoolDataSource - Interface in javax.sql

一个工厂为 PooledConnection对象。

Connector - Interface in com.sun.jdi.connect

调试器和目标VM之间的连接方法。

CONNECTOR_PUNCTUATION - Static variable in class java.lang. Character

Unicode规范中的通用类别“Pc”。

Connector.Argument - Interface in com.sun.jdi.connect

Connector参数的规范和值。

Connector.BooleanArgument - Interface in com.sun.jdi.connect

Connector参数的规范和值，其值为布尔值。

Connector.IntegerArgument - Interface in com.sun.jdi.connect

Connector参数的规格和值，其值为整数。

Connector.SelectedArgument - Interface in com.sun.jdi.connect

Connector参数的规范和值，其值是从选择列表中选择的String。

Connector.StringArgument - Interface in com.sun.jdi.connect

Connector参数的规范和值，其值为String。

connectTimeout(Duration) - Method in interface jdk.incubator.http. WebSocket.Builder

设置开启握手的超时。

CONREF - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于CONREF

CONSIDERED_INCOMPLETE - jdk.jshell. SourceCodeAnalysis.Completeness

具有尾随（非终止）空语句的语句。

console() - Static method in class java.lang. System

返回与当前Java虚拟机关联的唯一的Console对象（如果有）。

Console - Class in java.io

访问与当前Java虚拟机关联的基于字符的控制台设备（如果有的话）的方法。

CONSOLE - java.awt.desktop. UserSessionEvent.Reason

会话已连接/断开连接到控制台终端。

ConsoleHandler - Class in java.util.logging

这个 Handler将日志记录发布到 System.err 。

ConsoleHandler() - Constructor for class java.util.logging. ConsoleHandler

创建 ConsoleHandler为 System.err 。

constant(int) - Static method in class javax.swing. Spring

返回一个支柱 - 一个弹簧，其 最小值 ， 优选值和 最大值都具有值 pref 。

constant(int, int, int) - Static method in class javax.swing. Spring

返回弹簧，其 最小 ， 优选的 ，并且 最大值具有以下值： min ， pref ，和 max分别。

constant(Class<?>, Object) - Static method in class java.lang.invoke. MethodHandles

生成请求的返回类型的方法句柄，每次调用时返回给定的常量值。

CONSTANT_ASCENT - java.awt. Component.BaselineResizeBehavior

表示基线相对于y-origin保持固定。

CONSTANT_DESCENT - java.awt. Component.BaselineResizeBehavior

表示基线相对于高度保持固定，并且不随宽度变化而改变。

ConstantCallSite - Class in java.lang.invoke

A ConstantCallSite是一个CallSite，其目标是永久性的，永远不能更改。

ConstantCallSite(MethodHandle) - Constructor for class java.lang.invoke. ConstantCallSite

创建一个具有永久目标的呼叫站点。

ConstantCallSite(MethodType, MethodHandle) - Constructor for class java.lang.invoke. ConstantCallSite

创建具有永久目标的呼叫站点，可能绑定到呼叫站点本身。

constantName() - Method in exception java.lang. EnumConstantNotPresentException

返回缺少的枚举常量的名称。

constantPool() - Method in interface com.sun.jdi. ReferenceType

以Java虚拟机规范中的类文件格式的constant_pool项的格式返回常量池的原始字节。

constantPoolCount() - Method in interface com.sun.jdi. ReferenceType

返回常量池中的条目数加上一个。

constantValue() - Method in interface com.sun.javadoc. FieldDoc

已过时。

获取常量字段的值。

constantValueExpression() - Method in interface com.sun.javadoc. FieldDoc

已过时。

获取常量字段的值。

CONSTRAIN_TO_PREF - Static variable in class javafx.scene.layout. ConstraintsBase

如果设置为最大值，则表示pref值应该用作最大值。

CONSTRAINED_RESIZE_POLICY - Static variable in class javafx.scene.control. TableView

确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。

CONSTRAINED_RESIZE_POLICY - Static variable in class javafx.scene.control. TreeTableView

确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。

constraintBeforeFloating - Variable in class javax.swing.plaf.basic. BasicToolBarUI

浮动前的布局。

Constraints() - Constructor for class javax.swing. SpringLayout.Constraints

创建一个空的 Constraints对象。

Constraints(Component) - Constructor for class javax.swing. SpringLayout.Constraints

创建 Constraints与合适的物体 x ， y ， width和 height弹簧用于组分， c 。

Constraints(Spring, Spring) - Constructor for class javax.swing. SpringLayout.Constraints

为其 x和 y属性创建指定值的 Constraints对象。

Constraints(Spring, Spring, Spring, Spring) - Constructor for class javax.swing. SpringLayout.Constraints

创建 Constraints具有用于其指定的值对象 x ， y ， width ，和 height性质。

ConstraintsBase - Class in javafx.scene.layout

用于定义节点特定布局约束的基类。

Constructor< T> - Class in java.lang.reflect

Constructor提供了一个类的单个构造函数的信息和访问权限。

CONSTRUCTOR - java.lang.annotation. ElementType

构造函数声明

CONSTRUCTOR - javax.lang.model.element. ElementKind

一个构造函数。

CONSTRUCTOR - jdk.javadoc.doclet. Taglet.Location

在构造函数的文档中。

ConstructorDoc - Interface in com.sun.javadoc

已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

constructorModifiers() - Static method in class java.lang.reflect. Modifier

返回一个 int值将可以应用于构造函数的源语言修饰符OR组合在一起。

ConstructorParameters - Annotation Type in javax.management

一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。

ConstructorProperties - Annotation Type in java.beans

一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。

constructors() - Method in interface com.sun.javadoc. ClassDoc

已过时。

在此类中返回 included构造函数。

constructors(boolean) - Method in interface com.sun.javadoc. ClassDoc

已过时。

在此类中返回构造函数，过滤到指定的 access modifier option 。

constructorsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter

返回 elements中的构造函数列表。

constructorsIn(Set<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter

在 elements返回一组构造 elements 。

consume() - Method in class java.awt. AWTEvent

消耗这个事件，如果这个事件可以消耗。

consume() - Method in class java.awt.event. InputEvent

消耗此事件，使其不会以源自源的默认方式处理。

consume() - Method in class java.awt.event. InputMethodEvent

消耗此事件，使其不会以源自源的默认方式处理。

consume() - Method in class javafx.event. Event

标记为 Event消耗。

consume(Consumer<? super T>) - Method in class java.util.concurrent. SubmissionPublisher

使用给定的Consumer功能处理所有已发布的项目。

consumeAutoHidingEventsProperty() - Method in class javafx.stage. PopupWindow

指定是否应该使用引起Popup隐藏的事件。

consumed - Variable in class java.awt. AWTEvent

控制一旦源处理它，事件是否被发回到对等体 - false意味着它被发送到对等体; 真的意味着它不是。

consumed - Variable in class javafx.event. Event

此事件是否已被任何过滤器或处理程序使用。

consumeMouseEvents(boolean) - Method in class javafx.scene.control. SkinBase

确定是否应自动消耗所有鼠标事件。

consumer - Variable in class java.awt.image. ImageFilter

ImageFilter的此实例正在过滤数据的特定图像数据流的消费者。

Consumer< T> - Interface in java.util.function

表示接受单个输入参数并且不返回结果的操作。

containedIn(Oid[]) - Method in class org.ietf.jgss. Oid

测试此Oid值是否包含在提供的Oid数组中的实用方法。

Container - Class in java.awt

通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。

Container() - Constructor for class java.awt. Container

构造一个新的容器。

CONTAINER - javax.annotation. Resource.AuthenticationType

CONTAINER - Static variable in class com.sun.java.accessibility.util. EventID

映射到AWT容器支持（即ContainerListener和ContainerEvent）

CONTAINER_EVENT_MASK - Static variable in class java.awt. AWTEvent

用于选择容器事件的事件掩码。

CONTAINER_FIRST - Static variable in class java.awt.event. ContainerEvent

用于容器事件的ids范围中的第一个数字。

CONTAINER_LAST - Static variable in class java.awt.event. ContainerEvent

用于容器事件的ids范围中的最后一个数字。

Container.AccessibleAWTContainer - Class in java.awt

Container的内部类用于为辅助功能提供默认支持。

Container.AccessibleAWTContainer.AccessibleContainerHandler - Class in java.awt

火 PropertyChange听众，如果一个人注册，当孩子被添加或删除。

ContainerAdapter - Class in java.awt.event

用于接收容器事件的抽象适配器类。

ContainerAdapter() - Constructor for class java.awt.event. ContainerAdapter

containerAlignmentProperty() - Method in class javafx.scene.control.skin. MenuBarSkin

指定MenuBar中菜单按钮的对齐方式（默认为Pos.TOP_LEFT）。

ContainerEvent - Class in java.awt.event

低级别事件，表示容器的内容因添加或删除组件而发生更改。

ContainerEvent(Component, int, Component) - Constructor for class java.awt.event. ContainerEvent

构造一个 ContainerEvent对象。

containerListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor

不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。

containerListener - Variable in class javax.swing.plaf.basic. BasicMenuBarUI

实例 ContainerListener 。

ContainerListener - Interface in java.awt.event

用于接收容器事件的侦听器接口。

ContainerOrderFocusTraversalPolicy - Class in java.awt

FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。

ContainerOrderFocusTraversalPolicy() - Constructor for class java.awt. ContainerOrderFocusTraversalPolicy

containingClass() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

获取该程序元素的包含类或接口。

containingPackage() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

获取包含该程序元素的包。

containingType() - Method in interface com.sun.javadoc. ParameterizedType

已过时。

将包含此类型的类型作为成员返回。

contains(double, double) - Method in class java.awt.geom. Arc2D

确定指定点是否在弧的边界内。

contains(double, double) - Method in class java.awt.geom. Area

测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class java.awt.geom. CubicCurve2D

测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class java.awt.geom. Ellipse2D

测试指定坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class java.awt.geom. Line2D

测试指定的坐标是否在此 Line2D的边界内。

contains(double, double) - Method in class java.awt.geom. Path2D

测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class java.awt.geom. QuadCurve2D

测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class java.awt.geom. Rectangle2D

测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class java.awt.geom. RoundRectangle2D

测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class java.awt. Polygon

测试指定坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in interface java.awt. Shape

测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。

contains(double, double) - Method in class javafx.geometry. BoundingBox

测试指定的 (x, y)坐标是否在 Bounds的边界内。

contains(double, double) - Method in class javafx.geometry. Bounds

测试指定的 (x, y)坐标是否在 Bounds的边界内。

contains(double, double) - Method in class javafx.geometry. Rectangle2D

测试指定的 (x, y)坐标是否在 Rectangle2D的边界内。

contains(double, double) - Method in class javafx.scene. Node

返回 true如果给定的点（指定在局部坐标的此空间 Node ）包含在此的形状内 Node 。

contains(double, double, double) - Method in class javafx.geometry. BoundingBox

测试指定的 (x, y, z)坐标是否在 Bounds的边界内。

contains(double, double, double) - Method in class javafx.geometry. Bounds

测试 (x, y, z)坐标是否在 Bounds的边界内。

contains(double, double, double, double) - Method in class java.awt.geom. Arc2D

确定圆弧的内部是否完全包含指定的矩形。

contains(double, double, double, double) - Method in class java.awt.geom. Area

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class java.awt.geom. CubicCurve2D

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class java.awt.geom. Ellipse2D

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class java.awt.geom. Line2D

测试这个 Line2D的内部 Line2D完全包含指定的一组直角坐标。

contains(double, double, double, double) - Method in class java.awt.geom. Path2D

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class java.awt.geom. QuadCurve2D

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class java.awt.geom. Rectangle2D

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class java.awt.geom. RoundRectangle2D

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class java.awt. Polygon

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in interface java.awt. Shape

测试 Shape的内部 Shape完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class javafx.geometry. BoundingBox

测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class javafx.geometry. Bounds

测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。

contains(double, double, double, double) - Method in class javafx.geometry. Rectangle2D

测试这个 Rectangle2D的内部 Rectangle2D完全包含指定的矩形区域。

contains(double, double, double, double, double, double) - Method in class javafx.geometry. BoundingBox

测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。

contains(double, double, double, double, double, double) - Method in class javafx.geometry. Bounds

测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。

contains(int) - Method in class javax.print.attribute. SetOfIntegerSyntax

确定此整数整数属性是否包含给定值。

contains(int, int) - Method in class java.awt. Component

检查此组件是否“包含”指定点，其中 x和 y被定义为相对于该组件的坐标系。

contains(int, int) - Method in class java.awt. Polygon

确定指定的坐标是否在此 Polygon 。

contains(int, int) - Method in class java.awt. Rectangle

检查此 Rectangle是否包含指定位置的点 (x,y) 。

contains(int, int) - Method in class javax.swing. JComponent

为UI代理提供一个机会，以便为鼠标处理定义该组件的精确形状。

contains(int, int, int, int) - Method in class java.awt. Rectangle

检查该 Rectangle是否完全包含 Rectangle在指定位置 (X,Y)具有指定的尺寸 (W,H) 。

contains(PathIterator, double, double) - Static method in class java.awt.geom. Path2D

测试指定的坐标是否在指定的PathIterator的封闭边界内。

contains(PathIterator, double, double, double, double) - Static method in class java.awt.geom. Path2D

测试指定的矩形区域是否完全在指定的PathIterator的封闭边界内。

contains(PathIterator, Point2D) - Static method in class java.awt.geom. Path2D

测试指定Point2D是指定的封闭边界内PathIterator 。

contains(PathIterator, Rectangle2D) - Static method in class java.awt.geom. Path2D

测试指定Rectangle2D是完全指定的封闭边界内PathIterator 。

contains(Point2D) - Method in class java.awt.geom. Area

测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。

contains(Point2D) - Method in class java.awt.geom. CubicCurve2D

测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。

contains(Point2D) - Method in class java.awt.geom. Line2D

测试一个给定的 Point2D是否在这个 Line2D的边界内。

contains(Point2D) - Method in class java.awt.geom. Path2D

测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。

contains(Point2D) - Method in class java.awt.geom. QuadCurve2D

测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。

contains(Point2D) - Method in class java.awt.geom. RectangularShape

测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。

contains(Point2D) - Method in class java.awt. Polygon

测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。

contains(Point2D) - Method in interface java.awt. Shape

测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。

contains(Rectangle2D) - Method in class java.awt.geom. Arc2D

确定圆弧的内部是否完全包含指定的矩形。

contains(Rectangle2D) - Method in class java.awt.geom. Area

测试 Shape的内部 Shape完全包含指定的 Rectangle2D 。

contains(Rectangle2D) - Method in class java.awt.geom. CubicCurve2D

测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。

contains(Rectangle2D) - Method in class java.awt.geom. Line2D

测试这个 Line2D的内部 Line2D完全包含指定的 Rectangle2D 。

contains(Rectangle2D) - Method in class java.awt.geom. Path2D

测试 Shape的内部 Shape完全包含指定的 Rectangle2D 。

contains(Rectangle2D) - Method in class java.awt.geom. QuadCurve2D

测试 Shape的内部 Shape完全包含指定的 Rectangle2D 。

contains(Rectangle2D) - Method in class java.awt.geom. RectangularShape

测试 Shape的内部 Shape完全包含指定的 Rectangle2D 。

contains(Rectangle2D) - Method in class java.awt. Polygon

测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。

contains(Rectangle2D) - Method in interface java.awt. Shape

测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。

contains(Point) - Method in class com.sun.java.accessibility.util. Translator

检查指定的 Point是否在此对象的边界内，其中 Point是相对于对象的坐标系。

contains(Point) - Method in class java.awt. Component.AccessibleAWTComponent

检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。

contains(Point) - Method in class java.awt. Component

检查此组件是否“包含”指定点，其中点的 x和 y坐标被定义为相对于该组件的坐标系。

contains(Point) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。

contains(Point) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。

contains(Point) - Method in class java.awt. Polygon

确定指定的Point是否在此Polygon 。

contains(Point) - Method in class java.awt. Rectangle

检查此 Rectangle是否包含指定的 Point 。

contains(Point) - Method in interface javax.accessibility. AccessibleComponent

检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。

contains(Point) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

contains(Point) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。

contains(Point) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

contains(Point) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

contains(Rectangle) - Method in class java.awt. Rectangle

检查这个 Rectangle是否完全包含指定的 Rectangle 。

contains(CharSequence) - Method in class java.lang. String

当且仅当此字符串包含指定的char值序列时才返回true。

contains(Object) - Method in class java.beans.beancontext. BeanContextMembershipEvent

孩子指定是否受到事件的影响？

contains(Object) - Method in class java.beans.beancontext. BeanContextSupport

确定指定的对象当前是否为此 BeanContext的子 BeanContext 。

contains(Object) - Method in class java.util. AbstractCollection

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. ArrayDeque

如果此deque包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. ArrayList

如果此列表包含指定的元素，则返回 true 。

contains(Object) - Method in interface java.util. Collection

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. ArrayBlockingQueue

如果此队列包含指定的元素，则返回 true 。

contains(Object) - Method in interface java.util.concurrent. BlockingDeque

如果此deque包含指定的元素，则返回 true 。

contains(Object) - Method in interface java.util.concurrent. BlockingQueue

如果此队列包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. ConcurrentHashMap

测试一些键映射到此表中的指定值。

contains(Object) - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. ConcurrentLinkedDeque

如果此deque包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. ConcurrentLinkedQueue

如果此队列包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. ConcurrentSkipListSet

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. CopyOnWriteArrayList

如果此列表包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. CopyOnWriteArraySet

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. LinkedBlockingDeque

如果此deque包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. LinkedBlockingQueue

如果此队列包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. LinkedTransferQueue

如果此队列包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. PriorityBlockingQueue

如果此队列包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util.concurrent. SynchronousQueue

始终返回 false 。

contains(Object) - Method in interface java.util. Deque

如果此deque包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. HashSet

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. Hashtable

测试一些键映射到这个哈希表中的指定值。

contains(Object) - Method in class java.util. LinkedList

如果此列表包含指定的元素，则返回 true 。

contains(Object) - Method in interface java.util. List

如果此列表包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. PriorityQueue

如果此队列包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. Properties

contains(Object) - Method in interface java.util. Set

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. TreeSet

如果此集合包含指定的元素，则返回 true 。

contains(Object) - Method in class java.util. Vector

如果此向量包含指定的元素，则返回 true 。

contains(Object) - Method in class javafx.beans.binding. ListExpression

contains(Object) - Method in class javafx.beans.binding. SetExpression

contains(Object) - Method in class javax.imageio.spi. ServiceRegistry

返回 true如果 provider当前注册。

contains(Object) - Method in interface javax.naming.directory. Attribute

确定值是否在属性中。

contains(Object) - Method in class javax.naming.directory. BasicAttribute

确定值是否在此属性中。

contains(Object) - Method in class javax.swing. DefaultListModel

测试指定的对象是否是此列表中的组件。

contains(Object) - Method in class javax.swing.plaf.basic. BasicDirectoryModel

返回 true如果一个元素 o是在文件缓存，否则，返回 false 。

contains(String) - Method in class javax.accessibility. AccessibleRelationSet

返回关系集是否包含与指定键匹配的关系。

contains(String) - Method in interface org.w3c.dom. DOMStringList

测试一个字符串是否是这个 DOMStringList一部分。

contains(String) - Method in interface org.w3c.dom. NameList

测试一个名字是否是这个 NameList一部分。

contains(Charset) - Method in class java.nio.charset. Charset

告知这个字符集是否包含给定的字符集。

contains(Bounds) - Method in class javafx.geometry. BoundingBox

测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。

contains(Bounds) - Method in class javafx.geometry. Bounds

测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。

contains(Point2D) - Method in class javafx.geometry. BoundingBox

测试指定点是否在 Bounds的边界内。

contains(Point2D) - Method in class javafx.geometry. Bounds

测试指定点是否在 Bounds的边界内。

contains(Point2D) - Method in class javafx.geometry. Rectangle2D

测试指定点是否在 Rectangle2D的边界内。

contains(Point2D) - Method in class javafx.scene. Node

返回 true如果给定的点（指定在局部坐标的此空间 Node ）包含在此的形状内 Node 。

contains(Point3D) - Method in class javafx.geometry. BoundingBox

测试指定点是否在 Bounds的边界内。

contains(Point3D) - Method in class javafx.geometry. Bounds

测试指定点是否在 Bounds的边界内。

contains(Rectangle2D) - Method in class javafx.geometry. Rectangle2D

测试这个 Rectangle2D的内部 Rectangle2D完全包含指定的Rectangle2D， r 。

contains(AccessibleState) - Method in class javax.accessibility. AccessibleStateSet

检查当前状态是否处于状态集。

contains(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util. Types

测试一个类型参数是否 包含另一个参数。

contains(IntegerSyntax) - Method in class javax.print.attribute. SetOfIntegerSyntax

确定此整数整数属性是否包含给定的整数属性的值。

contains(JComponent, int, int) - Method in class javax.swing.plaf. ComponentUI

如果指定的 x，y位置包含在指定组件的外观定义的形状内 ，则返回 true 。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiButtonUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiColorChooserUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiLabelUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiMenuBarUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiMenuItemUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiPanelUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiProgressBarUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiRootPaneUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiScrollBarUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiSeparatorUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiSliderUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiSpinnerUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiTableUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiToolBarUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiToolTipUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 contains方法。

contains(JComponent, int, int) - Method in class javax.swing.plaf.multi. MultiViewportUI

在此对象处理的每个UI上调用 contains方法。

contains(JavaFileManager.Location, FileObject) - Method in class javax.tools. ForwardingJavaFileManager

contains(JavaFileManager.Location, FileObject) - Method in interface javax.tools. JavaFileManager

确定给定的文件对象是否“包含在”指定的位置。

contains(Namespace) - Method in class jdk.dynalink. NamespaceOperation

如果此命名空间操作包含等于指定命名空间的命名空间，则返回true。

contains(Operation, Operation, Namespace) - Static method in class jdk.dynalink. NamespaceOperation

如果指定的操作是NamespaceOperation，并且其基本操作等于指定的操作，并且它包含指定的命名空间，则返回true。

containsAlias(String) - Method in class java.security. KeyStore

检查此密钥库中是否存在给定的别名。

containsAll(Collection) - Method in class java.beans.beancontext. BeanContextSupport

测试以查看指定的 Collection中的所有对象是否为 Collection的子 BeanContext 。

containsAll(Collection<?>) - Method in class java.util. AbstractCollection

如果此集合包含指定集合中的所有元素，则返回 true 。

containsAll(Collection<?>) - Method in interface java.util. Collection

如果此集合包含指定集合中的所有元素，则返回 true 。

containsAll(Collection<?>) - Method in class java.util.concurrent. CopyOnWriteArrayList

如果此列表包含指定集合的所有元素，则返回 true 。

containsAll(Collection<?>) - Method in class java.util.concurrent. CopyOnWriteArraySet

如果此集合包含指定集合的所有元素，则返回 true 。

containsAll(Collection<?>) - Method in class java.util.concurrent. SynchronousQueue

返回 false除非给定的集合为空。

containsAll(Collection<?>) - Method in interface java.util. List

如果此列表包含指定集合的所有元素，则返回 true 。

containsAll(Collection<?>) - Method in interface java.util. Set

如果此集合包含指定集合的所有元素，则返回 true 。

containsAll(Collection<?>) - Method in class java.util. Vector

如果此向量包含指定集合中的所有元素，则返回true。

containsAll(Collection<?>) - Method in class javafx.beans.binding. ListExpression

containsAll(Collection<?>) - Method in class javafx.beans.binding. SetExpression

containsAngle(double) - Method in class java.awt.geom. Arc2D

确定指定角度是否在弧的角度范围内。

containsAttribute(Object, Object) - Method in class javax.swing.text. AbstractDocument.AbstractElement

检查是否定义了一个给定的属性名称/值。

containsAttribute(Object, Object) - Method in interface javax.swing.text. AttributeSet

如果此集合定义了具有相同名称和相等值的属性，则返回 true 。

containsAttribute(Object, Object) - Method in class javax.swing.text. SimpleAttributeSet

检查属性列表是否包含指定的属性名称/值对。

containsAttribute(Object, Object) - Method in class javax.swing.text. StyleContext.NamedStyle

检查是否定义了一个给定的属性名称/值。

containsAttribute(Object, Object) - Method in class javax.swing.text. StyleContext.SmallAttributeSet

检查是否定义了一个给定的属性名称/值。

containsAttributes(AttributeSet) - Method in class javax.swing.text. AbstractDocument.AbstractElement

检查元素是否包含所有属性。

containsAttributes(AttributeSet) - Method in interface javax.swing.text. AttributeSet

返回 true如果此集合定义了具有相等值的给定集合中的所有属性。

containsAttributes(AttributeSet) - Method in class javax.swing.text. SimpleAttributeSet

检查属性列表是否包含所有指定的名称/值对。

containsAttributes(AttributeSet) - Method in class javax.swing.text. StyleContext.NamedStyle

检查元素是否包含所有属性。

containsAttributes(AttributeSet) - Method in class javax.swing.text. StyleContext.SmallAttributeSet

检查属性集是否包含所有给定的属性。

containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

如果在最后一次调用validateComponent消息或按钮包含Component的子类时返回true。

containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 containsCustomComponents方法。

containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf. OptionPaneUI

如果用户为选项或消息提供了Component的实例，则返回true。

containsKey(Class<?>) - Method in interface javax.print.attribute. AttributeSet

如果此属性集包含指定类别的属性，则返回 true 。

containsKey(Class<?>) - Method in class javax.print.attribute. HashAttributeSet

如果此属性集包含指定类别的属性，则返回 true 。

containsKey(Object) - Method in class com.sun.net.httpserver. Headers

containsKey(Object) - Method in class java.awt. RenderingHints

如果此 RenderingHints包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class java.beans.beancontext. BeanContextSupport

确定指定的对象当前是否为此 BeanContext的子 BeanContext 。

containsKey(Object) - Method in class java.util. AbstractMap

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class java.util.concurrent. ConcurrentHashMap

测试此表中的指定对象是否为键。

containsKey(Object) - Method in class java.util.concurrent. ConcurrentSkipListMap

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class java.util. EnumMap

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class java.util. HashMap

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class java.util. Hashtable

测试指定的对象是否在此哈希表中的键。

containsKey(Object) - Method in class java.util. IdentityHashMap

测试此标识哈希映射中指定的对象引用是否为密钥。

containsKey(Object) - Method in class java.util.jar. Attributes

如果此Map包含指定的属性名称（key），则返回true。

containsKey(Object) - Method in interface java.util. Map

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class java.util. Properties

containsKey(Object) - Method in class java.util. TreeMap

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class java.util. WeakHashMap

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class javafx.beans.binding. MapExpression

containsKey(Object) - Method in class javax.management.openmbean. TabularDataSupport

返回 true当且仅当此 TabularData实例包含索引为指定 键的 CompositeData值（即一行）时。

containsKey(Object) - Method in interface javax.script. Bindings

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class javax.script. SimpleBindings

如果此映射包含指定键的映射，则返回 true 。

containsKey(Object) - Method in class jdk.incubator.http. MultiMapResult

containsKey(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

containsKey(Object[]) - Method in interface javax.management.openmbean. TabularData

返回 true当且仅当此 TabularData实例包含索引为指定 键的 CompositeData值（即一行）时。

containsKey(Object[]) - Method in class javax.management.openmbean. TabularDataSupport

返回 true当且仅当该 TabularData实例包含索引为指定 键的 CompositeData值（即一行）时。

containsKey(String) - Method in class com.sun.management. GcInfo

containsKey(String) - Method in class java.util. ResourceBundle

确定给定的 key是否包含在此 ResourceBundle或其父包中。

containsKey(String) - Method in interface javax.management.openmbean. CompositeData

返回 true当且仅当此 CompositeData实例包含名称是项目 key 。

containsKey(String) - Method in class javax.management.openmbean. CompositeDataSupport

返回 true当且仅当该 CompositeData实例包含名称为 key的项目时。

containsKey(String) - Method in class javax.management.openmbean. CompositeType

如果此 CompositeType实例定义了名称为 itemName的项目，则返回 true 。

containsNS(String, String) - Method in interface org.w3c.dom. NameList

测试该对namespaceURI / name是否为 NameList一部分。

containsObservedObject(ObjectName) - Method in class javax.management.monitor. Monitor

测试指定的对象是否在所观察的MBean集合中。

containsObservedObject(ObjectName) - Method in interface javax.management.monitor. MonitorMBean

测试指定的对象是否在所观察的MBean集合中。

containsTIFFField(int) - Method in class javax.imageio.plugins.tiff. TIFFDirectory

确定具有给定标签号的TIFF字段是否包含在此目录中。

containsValue(Object) - Method in class com.sun.management. GcInfo

containsValue(Object) - Method in class com.sun.net.httpserver. Headers

containsValue(Object) - Method in class java.awt. RenderingHints

如果此RenderingHints将一个或多个键映射到指定的值，则返回true。

containsValue(Object) - Method in class java.util. AbstractMap

如果此映射将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class java.util.concurrent. ConcurrentHashMap

如果此地图将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class java.util.concurrent. ConcurrentSkipListMap

如果此地图将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class java.util. EnumMap

如果此映射将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class java.util. HashMap

如果此地图将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class java.util. Hashtable

如果此哈希表将一个或多个键映射到此值，则返回true。

containsValue(Object) - Method in class java.util. IdentityHashMap

测试指定的对象引用是否是此标识哈希映射中的值。

containsValue(Object) - Method in class java.util.jar. Attributes

如果此Map将一个或多个属性名称（键）映射到指定的值，则返回true。

containsValue(Object) - Method in class java.util. LinkedHashMap

如果此映射将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in interface java.util. Map

如果此映射将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class java.util. Properties

containsValue(Object) - Method in class java.util. TreeMap

如果此映射将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class java.util. WeakHashMap

如果此地图将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class javafx.beans.binding. MapExpression

containsValue(Object) - Method in interface javax.management.openmbean. CompositeData

返回 true当且仅当此 CompositeData实例包含值为 value的项目时。

containsValue(Object) - Method in class javax.management.openmbean. CompositeDataSupport

返回 true当且仅当此 CompositeData实例包含其值是一个项目 value 。

containsValue(Object) - Method in class javax.management.openmbean. TabularDataSupport

当且仅当此 TabularData实例包含指定值时，返回 true 。

containsValue(Object) - Method in class javax.script. SimpleBindings

如果此地图将一个或多个键映射到指定的值，则返回 true 。

containsValue(Object) - Method in class jdk.incubator.http. MultiMapResult

containsValue(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

containsValue(CompositeData) - Method in interface javax.management.openmbean. TabularData

返回 true当且仅当此 TabularData实例包含指定的 CompositeData值时。

containsValue(CompositeData) - Method in class javax.management.openmbean. TabularDataSupport

如果且仅当此 TabularData实例包含指定的 CompositeData值时，则返回 true 。

containsValue(Attribute) - Method in interface javax.print.attribute. AttributeSet

如果此属性集包含给定的属性值，则返回 true 。

containsValue(Attribute) - Method in class javax.print.attribute. HashAttributeSet

如果此属性集包含给定属性，则返回 true 。

content - Variable in class javax.swing.text.html.parser. ContentModel

内容。

content - Variable in class javax.swing.text.html.parser. Element

内容模型

CONTENT - Static variable in class javax.swing.text.html. HTML.Attribute

属性“内容”

CONTENT - Static variable in class javax.swing.text.html. HTML.Tag

所有文字内容均标有此标签。

CONTENT_AREA_FILLED_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton

标识使按钮绘制内容区域的更改。

CONTENT_BOTTOM_LEFT - javafx.stage. PopupWindow.AnchorLocation

代表左下角的内容。

CONTENT_BOTTOM_RIGHT - javafx.stage. PopupWindow.AnchorLocation

代表最右下角的内容。

CONTENT_PANE_PROPERTY - Static variable in class javax.swing. JInternalFrame

绑定属性名称。

CONTENT_TOP_LEFT - javafx.stage. PopupWindow.AnchorLocation

代表左上角的角落。

CONTENT_TOP_RIGHT - javafx.stage. PopupWindow.AnchorLocation

代表右上角的内容。

content_type() - Method in class org.omg.CORBA. TypeCode

返回 TypeCode表示IDL类型用于通过此所描述的对象的成员对象 TypeCode对象。

CONTENT_TYPE - Static variable in class java.util.jar. Attributes.Name

Name对象为 Content-Type清单属性。

contentBorderInsets - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

内容边框插图

ContentDisplay - Enum in javafx.scene.control

将内容放置在标签内的位置。

contentDisplayProperty() - Method in class javafx.scene.control. Labeled

指定图形相对于文本的位置。

contentDisplayProperty() - Method in class javafx.scene.control. Tooltip

指定图形相对于文本的位置。

ContentElementName - Static variable in class javax.swing.text. AbstractDocument

用于表示内容的元素的名称

contentEquals(CharSequence) - Method in class java.lang. String

将此字符串与指定的 CharSequence 。

contentEquals(CharSequence) - Method in interface javax.lang.model.element. Name

将此名称与指定的 CharSequence 。

contentEquals(StringBuffer) - Method in class java.lang. String

将此字符串与指定的 StringBuffer 。

ContentHandler - Class in java.net

抽象类 ContentHandler是从 URLConnection读取 Object的所有类的超类。

ContentHandler - Interface in org.xml.sax

接收文档逻辑内容的通知。

ContentHandler() - Constructor for class java.net. ContentHandler

ContentHandlerFactory - Interface in java.net

该界面为内容处理程序定义了一个工厂。

contentInputProperty() - Method in class javafx.scene.effect. Lighting

内容输入为 Effect 。

contentLength() - Method in interface jdk.incubator.http. HttpRequest.BodyProcessor

返回此请求正文的内容长度。

ContentModel - Class in javax.swing.text.html.parser

内容模型的表示。

ContentModel() - Constructor for class javax.swing.text.html.parser. ContentModel

创建 ContentModel

ContentModel(int, Object, ContentModel) - Constructor for class javax.swing.text.html.parser. ContentModel

创建特定类型的内容模型。

ContentModel(int, ContentModel) - Constructor for class javax.swing.text.html.parser. ContentModel

创建特定类型的内容模型。

ContentModel(Element) - Constructor for class javax.swing.text.html.parser. ContentModel

为元素创建内容模型。

contentPane - Variable in class javax.swing. JRootPane

内容窗格。

contentProperty() - Method in class javafx.scene.control. CustomMenuItem

在此CustomMenuItem中显示的节点。

contentProperty() - Method in class javafx.scene.control. DialogPane

表示对话框的内容区域的属性。

contentProperty() - Method in class javafx.scene.control. ScrollPane

该节点用作此ScrollPane的内容。

contentProperty() - Method in class javafx.scene.control. Tab

与标签相关的内容。

contentProperty() - Method in class javafx.scene.control. TitledPane

TitledPane的内容。

contentProperty() - Method in class javafx.scene.shape. SVGPath

定义SVG路径编码字符串，如以下指定： http://www.w3.org/TR/SVG/paths.html 。

contentRect - Variable in class javax.swing.plaf.basic. BasicSliderUI

内容矩形

contents - Variable in class java.awt.datatransfer. Clipboard

剪贴板的内容。

CONTENTS - javafx.scene. AccessibleAttribute

返回节点的内容。

CONTENTS_CHANGED - Static variable in class javax.swing.event. ListDataEvent

标识列表内容中的一个或多个更改。

contentsChanged(ListDataEvent) - Method in interface javax.swing.event. ListDataListener

当列表的内容发生变化的方式太复杂以表征以前的方法时发送。

contentsChanged(ListDataEvent) - Method in class javax.swing. JComboBox

这种方法是公共的，作为实现的副作用。

contentsChanged(ListDataEvent) - Method in class javax.swing. JList.AccessibleJList

列表数据监听器内容改变了方法。

contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ListDataHandler

contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ListDataHandler

contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicListUI.ListDataHandler

ContentSigner - Class in com.sun.jarsigner

已过时。
此类已被弃用。

ContentSigner() - Constructor for class com.sun.jarsigner. ContentSigner

已过时。

ContentSignerParameters - Interface in com.sun.jarsigner

已过时。
此类已被弃用。

contentsLost() - Method in class java.awt. Component.BltBufferStrategy

contentsLost() - Method in class java.awt. Component.FlipBufferStrategy

contentsLost() - Method in class java.awt.image. BufferStrategy

返回自上次调用 getDrawGraphics以来绘图缓冲区是否丢失。

contentsLost() - Method in class java.awt.image. VolatileImage

如果自上一次 validate调用以来，如果渲染数据丢失，则返回 true 。

contentsRestored() - Method in class java.awt. Component.BltBufferStrategy

contentsRestored() - Method in class java.awt. Component.FlipBufferStrategy

contentsRestored() - Method in class java.awt.image. BufferStrategy

返回绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）。

contentTextProperty() - Method in class javafx.scene.control. Dialog

表示对话窗格的内容文本的属性。

contentTextProperty() - Method in class javafx.scene.control. DialogPane

表示对话窗格的内容文本的属性。

ContentType - Static variable in class javax.swing.text. DefaultStyledDocument.ElementSpec

getType的可能值。

context - Variable in class java.awt.dnd. DropTargetEvent

该 DropTargetContext与此 DropTargetEvent相关联。

context - Variable in class javax.script. AbstractScriptEngine

该 ScriptContext的默认 ScriptContext AbstractScriptEngine 。

context() - Method in interface java.nio.file. WatchEvent

返回事件的上下文。

Context - Class in org.omg.CORBA

在 Request操作中使用的对象，用于指定上下文对象，在上下文对象中，上下文字符串必须在与请求调用一起发送之前解决。

Context - Interface in javax.naming

该接口表示一个命名上下文，它由一组名称对对象绑定组成。

Context() - Constructor for class org.omg.CORBA. Context

context_data - Variable in class org.omg.IOP. ServiceContext

与此服务上下文相关的数据

CONTEXT_EXPIRED - Static variable in exception org.ietf.jgss. GSSException

安全上下文过期

context_id - Variable in class org.omg.IOP. ServiceContext

服务上下文id

CONTEXT_MENU - javafx.scene. AccessibleRole

上下文菜单角色。

CONTEXT_MENU - javafx.scene.input. KeyCode

Microsoft Windows上下文菜单键的常数。

CONTEXT_MENU_REQUESTED - Static variable in class javafx.scene.input. ContextMenuEvent

当请求上下文菜单时，会发生此事件。

context_name() - Method in class org.omg.CORBA. Context

检索此 Context对象的名称。

ContextList - Class in org.omg.CORBA

包含表示属性名称的 String对象的可修改列表的对象。

ContextList() - Constructor for class org.omg.CORBA. ContextList

ContextMenu - Class in javafx.scene.control

一个包含菜单项的ObservableList的弹出控件。

ContextMenu() - Constructor for class javafx.scene.control. ContextMenu

创建一个新的ContextMenu

ContextMenu(MenuItem...) - Constructor for class javafx.scene.control. ContextMenu

创建一个使用给定项目初始化的新的ContextMenu

contextMenuEnabledProperty() - Method in class javafx.scene.web. WebView

指定是否启用了上下文菜单。

ContextMenuEvent - Class in javafx.scene.input

当用户请求上下文菜单时，会发生此事件。

ContextMenuEvent(Object, EventTarget, EventType<ContextMenuEvent>, double, double, double, double, boolean, PickResult) - Constructor for class javafx.scene.input. ContextMenuEvent

构造新的ContextMenu事件。

ContextMenuEvent(EventType<ContextMenuEvent>, double, double, double, double, boolean, PickResult) - Constructor for class javafx.scene.input. ContextMenuEvent

构造具有空源和目标的新ContextMenu事件。

contextMenuProperty() - Method in class javafx.scene.control. Control

为此控件显示的ContextMenu。

contextMenuProperty() - Method in class javafx.scene.control. Tab

与选项卡关联的上下文菜单。

contextMenuProperty() - Method in class javafx.scene.control. TableColumnBase

当用户右键单击此TableColumnBase的标题区域时，将显示此菜单。

ContextMenuSkin - Class in javafx.scene.control.skin

ContextMenu的默认皮肤实现。

ContextMenuSkin(ContextMenu) - Constructor for class javafx.scene.control.skin. ContextMenuSkin

创建一个新的ContextMenuSkin实例。

ContextNotEmptyException - Exception in javax.naming

尝试销毁不为空的上下文时抛出此异常。

ContextNotEmptyException() - Constructor for exception javax.naming. ContextNotEmptyException

构造一个具有所有名称解析字段的ContextNotEmptyException的新实例，并将说明初始化为null。

ContextNotEmptyException(String) - Constructor for exception javax.naming. ContextNotEmptyException

使用解释构造一个新的ContextNotEmptyException实例。

contexts() - Method in class org.omg.CORBA. Request

检索此请求的 ContextList对象。

contexts() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations

返回描述可以在此操作调用中传递的上下文的 String对象的数组。

ContextualRenderedImageFactory - Interface in java.awt.image.renderable

ContextualRenderedImageFactory为RenderableImageOp的实例之间的功能提供了一个接口。

CONTIGUOUS_TREE_SELECTION - Static variable in interface javax.swing.tree. TreeSelectionModel

选择只能是连续的。

continuation() - Method in interface jdk.jshell. SourceCodeAnalysis.Suggestion

候选人延续给定用户的输入。

CONTINUE - com.sun.nio.sctp. HandlerResult

尝试接收另一个消息或通知。

CONTINUE - com.sun.source.tree. Tree.Kind

用于ContinueTree的实例。

CONTINUE - java.nio.file. FileVisitResult

继续。

CONTINUE - jdk.nashorn.api.tree. Tree.Kind

用于ContinueTree的实例。

CONTINUE - Static variable in class javax.sound.midi. ShortMessage

继续消息的状态字节（0xFB或251）。

continueDrag(int, int) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController

消息dragDividerTo与鼠标事件的新位置。

continueDrag(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController

消息dragDividerTo与鼠标事件的新位置。

ContinueTree - Interface in com.sun.source.tree

一个树结点的一个 continue语句。

ContinueTree - Interface in jdk.nashorn.api.tree

“continue”语句的树结点。

CONTINUOUS_LAYOUT_PROPERTY - Static variable in class javax.swing. JSplitPane

continuousLayout的绑定属性名称。

continuousLayout - Variable in class javax.swing. JSplitPane

在调整大小时是否不断重新显示视图。

contListener - Variable in class javax.swing.plaf.metal. MetalToolBarUI

此保护字段是实现特定的。

CONTRAST_HARD - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“对比度”标签一起使用的值。

CONTRAST_NORMAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“对比度”标签一起使用的值。

CONTRAST_SOFT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“对比度”标签一起使用的值。

contrastProperty() - Method in class javafx.scene.effect. ColorAdjust

对比度调整值。

control - Static variable in class java.awt. SystemColor

为控制面板和控制对象（如按钮）的背景渲染的颜色。

Control - Class in javafx.scene.control

所有用户界面控件的基类。

Control - Class in javax.sound.sampled

Lines经常有一组控制，如增益和平移，影响通过线路的音频信号。

Control - Interface in javax.naming.ldap

此接口表示 RFC 2251中定义的LDAPv3控件。

Control() - Constructor for class java.util. ResourceBundle.Control

唯一的构造函数。

Control() - Constructor for class javafx.scene.control. Control

创建一个新的控件。

Control(Control.Type) - Constructor for class javax.sound.sampled. Control

构造具有指定类型的控件。

CONTROL - javafx.scene.input. KeyCode

常数为 Ctrl键。

CONTROL - Static variable in class java.awt. SystemColor

SystemColor.control系统颜色的数组索引。

CONTROL - Static variable in class java.lang. Character

Unicode规范中的一般类别“Cc”。

CONTROL_ANY - Static variable in class javafx.scene.input. KeyCombination

指定 control键的 control可以是向上还是向下。

CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser

指示显示控制按钮。

CONTROL_CHANGE - Static variable in class javax.sound.midi. ShortMessage

控制更改消息（0xB0或176）的命令值。

CONTROL_DK_SHADOW - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.controlDkShadow系统颜色。

CONTROL_DOWN - Static variable in class javafx.scene.input. KeyCombination

指定 control键的 control必须关闭。

CONTROL_FACTORIES - Static variable in interface javax.naming.ldap. LdapContext

用于指定要使用的控制工厂列表的环境属性的名称的常量。

CONTROL_HIGHLIGHT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.controlHighlight系统颜色。

CONTROL_LT_HIGHLIGHT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.controlLtHighlight系统颜色。

CONTROL_PICTURES - Static variable in class java.lang. Character.UnicodeBlock

“控制图片”Unicode字符块的常量。

CONTROL_SHADOW - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.controlShadow系统颜色。

CONTROL_TEXT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.controlText系统颜色。

Control.Type - Class in javax.sound.sampled

Type类的一个实例表示控件的类型。

controlChange(int, int) - Method in interface javax.sound.midi. MidiChannel

反映指定控制器价值的变化。

controlChange(ShortMessage) - Method in interface javax.sound.midi. ControllerEventListener

当Sequencer遇到并处理此侦听器感兴趣的控制更改事件时调用。

controlDkShadow - Static variable in class java.awt. SystemColor

在3D控件对象（如按钮）上为暗影区域呈现的颜色。

controlDown() - Method in class java.awt. Event

已过时。

注意： Event类已过时，仅适用于向后兼容性。

ControlFactory - Class in javax.naming.ldap

这个抽象类代表一个用于创建LDAPv3控件的工厂。

ControlFactory() - Constructor for class javax.naming.ldap. ControlFactory

创建控制工厂的新实例。

controlHighlight - Static variable in class java.awt. SystemColor

为3D控制对象（如按钮）的亮区渲染颜色。

CONTROLLED_BY - Static variable in class javax.accessibility. AccessibleRelation

表示对象由一个或多个目标对象控制。

CONTROLLED_BY_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation

标识正在进行控制的目标对象已更改。

controller - Variable in class javax.imageio. IIOParam

该 IIOParamController将用于提供此设置 IIOParam对象时 activateController方法被调用。

controller - Variable in class javax.imageio.metadata. IIOMetadata

该 IIOMetadataController将用于提供此设置 IIOMetadata对象时 activateController方法被调用。

CONTROLLER_FOR - Static variable in class javax.accessibility. AccessibleRelation

表示对象是一个或多个目标对象的控制器。

CONTROLLER_FOR_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation

标识目标对象的控制器已更改。

CONTROLLER_KEYWORD - Static variable in class javafx.fxml. FXMLLoader

控制器在命名空间映射中的关键。

CONTROLLER_METHOD_PREFIX - Static variable in class javafx.fxml. FXMLLoader

控制器方法分辨率前缀。

CONTROLLER_SUFFIX - Static variable in class javafx.fxml. FXMLLoader

包含fxml文件的控制器的后缀。

ControllerEventListener - Interface in javax.sound.midi

ControllerEventListener接口应当由Sequencer处理请求类型的MIDI控制更改事件时需要通知实例的类实现。

controlLtHighlight - Static variable in class java.awt. SystemColor

为3D控件对象的高亮区域（如按钮）渲染颜色。

CONTROLS - javafx.application. ConditionalFeature

表示在此平台上提供了提供UI控件的JavaFX类。

controlShadow - Static variable in class java.awt. SystemColor

为3D控件对象（如按钮）的阴影区域呈现的颜色。

controlText - Static variable in class java.awt. SystemColor

为控制面板和控制对象（如按钮）的文本呈现的颜色。

controlX1Property() - Method in class javafx.scene.shape. CubicCurve

定义三次曲线段的第一个控制点的X坐标。

controlX1Property() - Method in class javafx.scene.shape. CubicCurveTo

定义第一个Bézier控制点的X坐标。

controlX2Property() - Method in class javafx.scene.shape. CubicCurve

定义三次曲线段的第二个控制点的X坐标。

controlX2Property() - Method in class javafx.scene.shape. CubicCurveTo

定义第二个Bézier控制点的X坐标。

controlXProperty() - Method in class javafx.scene.shape. QuadCurve

定义二次曲线段的控制点的X坐标。

controlXProperty() - Method in class javafx.scene.shape. QuadCurveTo

定义二次控制点的X坐标。

controlY1Property() - Method in class javafx.scene.shape. CubicCurve

定义三次曲线段的第一个控制点的Y坐标。

controlY1Property() - Method in class javafx.scene.shape. CubicCurveTo

定义第一个Bézier控制点的Y坐标。

controlY2Property() - Method in class javafx.scene.shape. CubicCurve

定义三次曲线段的第二个控制点的Y坐标。

controlY2Property() - Method in class javafx.scene.shape. CubicCurveTo

定义第二个Bézier控制点的Y坐标。

controlYProperty() - Method in class javafx.scene.shape. QuadCurve

定义二次曲线段控制点的Y坐标。

controlYProperty() - Method in class javafx.scene.shape. QuadCurveTo

定义二次控制点的Y坐标。

ConversionComparator - Interface in jdk.dynalink.linker

可选接口由GuardingTypeConverterFactory实现。

ConversionComparator.Comparison - Enum in jdk.dynalink.linker

列举将一个转换与另一个转换进行比较的可能结果。

convert(long, TimeUnit) - Method in enum java.util.concurrent. TimeUnit

将给定单位的给定持续时间转换为本机。

convert(Object, Object) - Static method in class jdk.nashorn.api.scripting. ScriptUtils

将给定对象转换为给定类型。

convert(Map<CssMetaData<? extends Styleable, ?>, Object>) - Method in class javafx.css.converter. FontConverter

convert(Map<CssMetaData<? extends Styleable, ?>, Object>) - Method in class javafx.css. StyleConverter

从成分值转换为目标属性类型。

convert(ObservableValue<?>) - Static method in class javafx.beans.binding. Bindings

返回一个StringExpression ，其中包含一个ObservableValue 。

convert(ParsedValue<F, T>, Font) - Method in class javafx.css. StyleConverter

从解析的CSS值转换为目标属性类型。

convert(ParsedValue<String, E>, Font) - Method in class javafx.css.converter. EnumConverter

convert(ParsedValue<String, Boolean>, Font) - Method in class javafx.css.converter. BooleanConverter

convert(ParsedValue<String, String>, Font) - Method in class javafx.css.converter. StringConverter

convert(ParsedValue<String, Cursor>, Font) - Method in class javafx.css.converter. CursorConverter

convert(ParsedValue<String, Color>, Font) - Method in class javafx.css.converter. ColorConverter

convert(ParsedValue<String, Shape>, Font) - Method in class javafx.css.converter. ShapeConverter

convert(ParsedValue<String, FontPosture>, Font) - Method in class javafx.css.converter. FontConverter.FontStyleConverter

convert(ParsedValue<String, FontWeight>, Font) - Method in class javafx.css.converter. FontConverter.FontWeightConverter

convert(ParsedValue<ParsedValue[], Number[]>, Font) - Method in class javafx.css.converter. SizeConverter.SequenceConverter

convert(ParsedValue<ParsedValue[], String>, Font) - Method in class javafx.css.converter. URLConverter

convert(ParsedValue<ParsedValue[], Insets>, Font) - Method in class javafx.css.converter. InsetsConverter

convert(ParsedValue<ParsedValue[], Effect>, Font) - Method in class javafx.css.converter. EffectConverter

convert(ParsedValue<ParsedValue[], Effect>, Font) - Method in class javafx.css.converter. EffectConverter.DropShadowConverter

convert(ParsedValue<ParsedValue[], Effect>, Font) - Method in class javafx.css.converter. EffectConverter.InnerShadowConverter

convert(ParsedValue<ParsedValue[], Color>, Font) - Method in class javafx.css.converter. DeriveColorConverter

convert(ParsedValue<ParsedValue[], Color>, Font) - Method in class javafx.css.converter. LadderConverter

convert(ParsedValue<ParsedValue[], Paint>, Font) - Method in class javafx.css.converter. PaintConverter.ImagePatternConverter

convert(ParsedValue<ParsedValue[], Paint>, Font) - Method in class javafx.css.converter. PaintConverter.LinearGradientConverter

convert(ParsedValue<ParsedValue[], Paint>, Font) - Method in class javafx.css.converter. PaintConverter.RadialGradientConverter

convert(ParsedValue<ParsedValue[], Paint>, Font) - Method in class javafx.css.converter. PaintConverter.RepeatingImagePatternConverter

convert(ParsedValue<ParsedValue[], Stop>, Font) - Method in class javafx.css.converter. StopConverter

convert(ParsedValue<ParsedValue[], Font>, Font) - Method in class javafx.css.converter. FontConverter

convert(ParsedValue<ParsedValue<?, Size>, Number>, Font) - Method in class javafx.css.converter. FontConverter.FontSizeConverter

convert(ParsedValue<ParsedValue<?, Size>, Number>, Font) - Method in class javafx.css.converter. SizeConverter

convert(ParsedValue<ParsedValue<?, Size>, Duration>, Font) - Method in class javafx.css.converter. DurationConverter

convert(ParsedValue<ParsedValue<?, Paint>, Paint>, Font) - Method in class javafx.css.converter. PaintConverter

convert(ParsedValue<ParsedValue<?, Paint>[], Paint[]>, Font) - Method in class javafx.css.converter. PaintConverter.SequenceConverter

convert(ParsedValue<ParsedValue<String, String>[], String[]>, Font) - Method in class javafx.css.converter. StringConverter.SequenceConverter

convert(ParsedValue<ParsedValue<ParsedValue[], String>[], String[]>, Font) - Method in class javafx.css.converter. URLConverter.SequenceConverter

convert(ParsedValue<ParsedValue<ParsedValue[], Insets>[], Insets[]>, Font) - Method in class javafx.css.converter. InsetsConverter.SequenceConverter

convert(ParsedValue<ParsedValue<Size, Size>[], Size>, Font) - Method in class javafx.css.converter. DeriveSizeConverter

convert(Font) - Method in class javafx.css. ParsedValue

方便的方式拨打 convert这个 ParsedValue 。

CONVERT - javafx.scene.input. KeyCode

转换功能键的常数。

convertColumnIndexToModel(int) - Method in class javax.swing. JTable

将视图中的列索引为 viewColumnIndex到表模型中的列的索引。

convertColumnIndexToView(int) - Method in class javax.swing. JTable

将表模型中的列索引为 modelColumnIndex到视图中列的索引。

CONVERTED_TEXT - Static variable in class java.awt.im. InputMethodHighlight

转换文本状态的常数。

converter - Variable in class javafx.css. ParsedValue

所述StyleConverter其中被分析的值转换为的类型StyleableProperty 。

converterProperty() - Method in class javafx.scene.control.cell. CheckBoxListCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. CheckBoxTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. CheckBoxTreeCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. CheckBoxTreeTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. ChoiceBoxListCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. ChoiceBoxTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. ChoiceBoxTreeCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. ComboBoxListCell

StringConverter的财产。

converterProperty() - Method in class javafx.scene.control.cell. ComboBoxTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. ComboBoxTreeCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. TextFieldListCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. TextFieldTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. TextFieldTreeCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control.cell. TextFieldTreeTableCell

StringConverter属性。

converterProperty() - Method in class javafx.scene.control. ChoiceBox

允许一种方式来指定如何表示项目列表中的对象。

converterProperty() - Method in class javafx.scene.control. ComboBox

将用户输入的输入（当ComboBox为 editable ）转换为类型T的对象时，可以通过 value属性检索输入。

converterProperty() - Method in class javafx.scene.control. DatePicker

将输入文本转换为类型为LocalDate的对象，反之亦然。

converterProperty() - Method in class javafx.scene.control. SpinnerValueFactory

将用户输入的输入（当微调器为 editable ）转换为T型对象时，可以通过 value属性检索输入。

convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - Method in interface javax.imageio. ImageTranscoder

返回可用于编码的 IIOMetadata对象，并可以使用其文档接口或特定于将用于编码的writer插件的其他接口进行修改。

convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - Method in class javax.imageio. ImageWriter

convertMouseEvent(Component, MouseEvent, Component) - Static method in class javax.swing. SwingUtilities

返回类似于 sourceEvent的MouseEvent，但其x和y成员已转换为 destination的坐标系。

convertMouseEvent(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup

转换鼠标事件。

convertPoint(Component, int, int, Component) - Static method in class javax.swing. SwingUtilities

转换点 (x,y)在 source坐标系 destination坐标系。

convertPoint(Component, Point, Component) - Static method in class javax.swing. SwingUtilities

转换为 aPoint在 source坐标系 destination坐标系。

convertPointFromScreen(Point, Component) - Static method in class javax.swing. SwingUtilities

将一个点从屏幕坐标转换为组件的坐标系

convertPointToScreen(Point, Component) - Static method in class javax.swing. SwingUtilities

将点从组件的坐标系转换为屏幕坐标。

convertPreviousRowIndexToModel(int) - Method in class javax.swing.event. RowSorterEvent

根据排序前的模型返回 index的位置。

convertRectangle(Component, Rectangle, Component) - Static method in class javax.swing. SwingUtilities

将 source坐标系中的矩形 aRectangle转换为 destination坐标系。

convertRowIndexToModel(int) - Method in class javax.swing. DefaultRowSorter

根据底层模型返回 index的位置。

convertRowIndexToModel(int) - Method in class javax.swing. JTable

将行的索引映射到底层 TableModel 。

convertRowIndexToModel(int) - Method in class javax.swing. RowSorter

根据底层模型返回 index的位置。

convertRowIndexToView(int) - Method in class javax.swing. DefaultRowSorter

在视图中返回 index的位置。

convertRowIndexToView(int) - Method in class javax.swing. JTable

根据视图的 TableModel映射行的索引。

convertRowIndexToView(int) - Method in class javax.swing. RowSorter

在视图方面返回 index的位置。

convertRowToY(int) - Method in class javax.swing.plaf.basic. BasicListUI

返回指定行的原点的 JList相对Y坐标，如果行无效则返回-1。

convertStreamMetadata(IIOMetadata, ImageWriteParam) - Method in interface javax.imageio. ImageTranscoder

返回可用于编码的 IIOMetadata对象，并可使用文档接口或特定于编写器插件的其他接口进行修改，该接口将用于编码。

convertStreamMetadata(IIOMetadata, ImageWriteParam) - Method in class javax.imageio. ImageWriter

convertToBinary(File, File) - Static method in class javafx.css. Stylesheet

将urlIn引用的.css文件转换为二进制格式并写入urlOut。

convertToIntDiscrete(Raster, boolean) - Method in class java.awt.image. IndexColorModel

返回一个新 BufferedImage TYPE_INT_ARGB或TYPE_INT_RGB的具有 Raster通过展开源的索引来计算的与像素数据 Raster使用此的颜色/ alpha分量数组 ColorModel 。

convertToType(Class<?>, Class<?>, Supplier<MethodHandles.Lookup>) - Method in interface jdk.dynalink.linker. GuardingTypeConverterFactory

返回受保护的类型转换，它接收指定的源类型的值，并返回转换为指定的目标类型的值。

convertToVector(Object[]) - Static method in class javax.swing.table. DefaultTableModel

返回一个包含与数组相同的对象的向量。

convertToVector(Object[][]) - Static method in class javax.swing.table. DefaultTableModel

返回包含与数组相同对象的向量向量。

convertValueToText(Object, boolean, boolean, boolean, int, boolean) - Method in class javax.swing. JTree

由渲染器调用，将指定的值转换为文本。

convertYToRow(int) - Method in class javax.swing.plaf.basic. BasicListUI

基于当前布局，将 JList相对坐标转换为包含该坐标的行。

ConvolveOp - Class in java.awt.image

该类实现从源到目的地的卷积。

ConvolveOp(Kernel) - Constructor for class java.awt.image. ConvolveOp

构造一个给定内核的ConvolveOp。

ConvolveOp(Kernel, int, RenderingHints) - Constructor for class java.awt.image. ConvolveOp

构造一个给定内核，边缘条件和RenderingHints对象（可能为null）的ConvolveOp。

CookieHandler - Class in java.net

CookieHandler对象提供一个回调机制，将HTTP状态管理策略实现连接到HTTP协议处理程序中。

CookieHandler() - Constructor for class java.net. CookieHandler

CookieHolder - Class in org.omg.PortableServer.ServantLocatorPackage

PortableServer :: ServantLocator :: Cookie的本机类型映射到java.lang.Object。

CookieHolder() - Constructor for class org.omg.PortableServer.ServantLocatorPackage. CookieHolder

CookieHolder(Object) - Constructor for class org.omg.PortableServer.ServantLocatorPackage. CookieHolder

cookieManager() - Method in class jdk.incubator.http. HttpClient

返回一个Optional ，其中包含该客户端的CookieManager 。

cookieManager(CookieManager) - Method in class jdk.incubator.http. HttpClient.Builder

设置一个cookie管理器。

CookieManager - Class in java.net

CookieManager提供了一个CookieHandler的具体实现， 它将 cookie的存储与接受和拒绝Cookie的策略分开。

CookieManager() - Constructor for class java.net. CookieManager

创建一个新的cookie管理器。

CookieManager(CookieStore, CookiePolicy) - Constructor for class java.net. CookieManager

使用指定的Cookie存储和Cookie策略创建一个新的cookie管理器。

CookiePolicy - Interface in java.net

CookiePolicy实现决定哪些Cookie应该被接受，哪些应该被拒绝。

CookieStore - Interface in java.net

CookieStore对象表示Cookie的存储。

coordinateTypes() - Method in class java.lang.invoke. VarHandle

返回此VarHandle的坐标类型。

COORDS - Static variable in class javax.swing.text.html. HTML.Attribute

属性“协调”

COPIED - Static variable in class java.awt. BufferCapabilities.FlipContents

当翻转内容为 COPIED ，翻转时将后台缓冲区的内容复制到前台缓冲区。

Copies - Class in javax.print.attribute.standard

Class Copies是一个整数值的打印属性类，它指定要打印的份数。

Copies(int) - Constructor for class javax.print.attribute.standard. Copies

使用给定的整数值构造新的副本属性。

copiesProperty() - Method in class javafx.print. JobSettings

IntegerProperty表示要打印的作业的份数。

CopiesSupported - Class in javax.print.attribute.standard

Class CopiesSupported是一个打印属性类，一组整数，它为Copies属性提供支持的值。

CopiesSupported(int) - Constructor for class javax.print.attribute.standard. CopiesSupported

构造包含单个整数的新的副本支持属性。

CopiesSupported(int, int) - Constructor for class javax.print.attribute.standard. CopiesSupported

构造一个包含单个整数范围的支持新的副本属性。

COPTIC - java.lang. Character.UnicodeScript

Unicode脚本“科普特”。

COPTIC - Static variable in class java.lang. Character.UnicodeBlock

“科普特”Unicode字符块的常数。

COPTIC_EPACT_NUMBERS - Static variable in class java.lang. Character.UnicodeBlock

常规为“科普特数字”Unicode字符块。

copy - Variable in class javax.swing.text. DefaultStyledDocument.AttributeUndoableEdit

AttributeSet的副本包含元素。

copy() - Method in class java.util.concurrent. CompletableFuture

返回一个新的CompletableFuture，它在正常完成时正常完成，具有与此CompletableFuture相同的值。

copy() - Method in class javafx.scene.control. PasswordField

PasswordField什么也不做。

copy() - Method in class javafx.scene.control. TextInputControl

将文本中当前选定的范围传输到剪贴板，留下当前的选择。

copy() - Method in class javax.swing. JPasswordField

调用 provideErrorFeedback当前的外观和感觉，通常会发出一个错误提示音。

copy() - Method in class javax.swing.text. JTextComponent

将相关文本模型中的当前选定范围传输到系统剪贴板，将文本模型中的内容留下。

copy() - Method in class jdk.incubator.http. HttpRequest.Builder

根据当前状态返回此 Builder的精确副本。

copy() - Method in class org.omg.CORBA. _PolicyStub

复制策略对象。

copy() - Method in interface org.omg.CORBA. DynAny

已过时。

克隆这个 DynAny对象。

copy() - Method in interface org.omg.CORBA. PolicyOperations

返回 Policy对象的副本。

copy() - Method in class org.omg.DynamicAny. _DynAnyStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in class org.omg.DynamicAny. _DynArrayStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in class org.omg.DynamicAny. _DynEnumStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in class org.omg.DynamicAny. _DynFixedStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in class org.omg.DynamicAny. _DynSequenceStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in class org.omg.DynamicAny. _DynStructStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in class org.omg.DynamicAny. _DynUnionStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in class org.omg.DynamicAny. _DynValueStub

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy() - Method in interface org.omg.DynamicAny. DynAnyOperations

创建一个新的DynAny对象，该对象的值是调用它的DynAny的深层副本。

copy(InputStream, Path, CopyOption...) - Static method in class java.nio.file. Files

将输入流中的所有字节复制到文件。

copy(Path, OutputStream) - Static method in class java.nio.file. Files

将文件中的所有字节复制到输出流。

copy(Path, Path, CopyOption...) - Static method in class java.nio.file. Files

将文件复制到目标文件。

copy(Path, Path, CopyOption...) - Method in class java.nio.file.spi. FileSystemProvider

将文件复制到目标文件。

copy(List<? super T>, List<? extends T>) - Static method in class java.util. Collections

将所有元素从一个列表复制到另一个列表中。

copy(ObservableList<? super T>, List<? extends T>) - Static method in class javafx.collections. FXCollections

将元素从src复制到dest。

COPY - javafx.scene.input. KeyCode

常数为 Copy键。

COPY - javafx.scene.input. TransferMode

表示支持或打算复制数据。

COPY - javafx.scene.web. HTMLEditorSkin.Command

COPY - Static variable in class javax.swing. TransferHandler

代表“复制”转让行动的 int 。

COPY_ATTRIBUTES - java.nio.file. StandardCopyOption

将属性复制到新文件。

COPY_OR_MOVE - Static variable in enum javafx.scene.input. TransferMode

包含传输模式的数组COPY和MOVE。

COPY_OR_MOVE - Static variable in class javax.swing. TransferHandler

代表“复制”或“移动”的源操作能力的 int 。

COPY_SOURCE_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader

<fx：copy>'source'属性。

COPY_TAG - Static variable in class javafx.fxml. FXMLLoader

标签名称为<fx：copy>。

copyAction - Static variable in class javax.swing.text. DefaultEditorKit

复制所选区域的操作名称，并将内容放入系统剪贴板。

CopyAction() - Constructor for class javax.swing.text. DefaultEditorKit.CopyAction

使用相应的标识符创建此对象。

copyArea(int, int, int, int, int, int) - Method in class java.awt. Graphics

将组件的一个区域复制 dx和 dy指定的距离。

copyArea(int, int, int, int, int, int) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.copyArea 。

copyAttributes() - Method in class javax.swing.text. AbstractDocument.AbstractElement

复制一组属性。

copyAttributes() - Method in interface javax.swing.text. AttributeSet

返回一个保证不会随时间变化的属性集。

copyAttributes() - Method in class javax.swing.text. SimpleAttributeSet

复制属性。

copyAttributes() - Method in class javax.swing.text. StyleContext.NamedStyle

复制一组属性。

copyAttributes() - Method in class javax.swing.text. StyleContext.SmallAttributeSet

复制一组属性。

copyChildren() - Method in class java.beans.beancontext. BeanContextSupport

获取这个BeanContext的孩子的副本。

copyData(WritableRaster) - Method in class java.awt.image. BufferedImage

计算 BufferedImage的任意矩形区域，并将其复制到指定的 WritableRaster 。

copyData(WritableRaster) - Method in interface java.awt.image. RenderedImage

计算RenderedImage的任意矩形区域，并将其复制到调用者提供的WritableRaster中。

copyFor(Object, EventTarget) - Method in class javafx.event. ActionEvent

copyFor(Object, EventTarget) - Method in class javafx.event. Event

使用指定的事件源和目标创建并返回此事件的副本。

copyFor(Object, EventTarget) - Method in class javafx.scene.control. DialogEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. ContextMenuEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. DragEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. GestureEvent

使用指定的事件源和目标创建并返回此事件的副本。

copyFor(Object, EventTarget) - Method in class javafx.scene.input. InputMethodEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. KeyEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. MouseDragEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. MouseEvent

将此事件复制到不同的来源和目标。

copyFor(Object, EventTarget) - Method in class javafx.scene.input. RotateEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. ScrollEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. SwipeEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.input. TouchEvent

使用指定的事件源和目标创建并返回此事件的副本。

copyFor(Object, EventTarget) - Method in class javafx.scene.input. ZoomEvent

copyFor(Object, EventTarget) - Method in class javafx.scene.media. MediaErrorEvent

copyFor(Object, EventTarget) - Method in class javafx.stage. WindowEvent

copyFor(Object, EventTarget, Object, Object, EventType<DragEvent>) - Method in class javafx.scene.input. DragEvent

创建给定字段替换的给定拖动事件的副本。

copyFor(Object, EventTarget, EventType<? extends MouseEvent>) - Method in class javafx.scene.input. MouseDragEvent

copyFor(Object, EventTarget, EventType<? extends MouseEvent>) - Method in class javafx.scene.input. MouseEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<DialogEvent>) - Method in class javafx.scene.control. DialogEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<DragEvent>) - Method in class javafx.scene.input. DragEvent

创建给定字段替换的给定拖动事件的副本。

copyFor(Object, EventTarget, EventType<KeyEvent>) - Method in class javafx.scene.input. KeyEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<RotateEvent>) - Method in class javafx.scene.input. RotateEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<ScrollEvent>) - Method in class javafx.scene.input. ScrollEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<SwipeEvent>) - Method in class javafx.scene.input. SwipeEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<TouchEvent>) - Method in class javafx.scene.input. TouchEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<ZoomEvent>) - Method in class javafx.scene.input. ZoomEvent

用给定的字段替换给定事件的副本。

copyFor(Object, EventTarget, EventType<WindowEvent>) - Method in class javafx.stage. WindowEvent

用给定的字段替换给定事件的副本。

copyForMouseDragEvent(MouseEvent, Object, EventTarget, EventType<MouseDragEvent>, Object, PickResult) - Static method in class javafx.scene.input. MouseEvent

创建MouseDragEvent类型的鼠标事件的副本

copyInto(Object[]) - Method in class java.util. Vector

将此向量的组件复制到指定的数组中。

copyInto(Object[]) - Method in class javax.swing. DefaultListModel

将此列表的组件复制到指定的数组中。

copyObject(Object, ORB) - Static method in class javax.rmi.CORBA. Util

复制或连接对象。

copyObject(Object, ORB) - Method in interface javax.rmi.CORBA. UtilDelegate

代表团要求 Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 。

copyObjects(Object[], ORB) - Static method in class javax.rmi.CORBA. Util

复制或连接对象数组。

copyObjects(Object[], ORB) - Method in interface javax.rmi.CORBA. UtilDelegate

代表团要求 Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 。

copyOf(boolean[], int) - Static method in class java.util. Arrays

复制指定的数组，截断或填充 false （如有必要），以使副本具有指定的长度。

copyOf(byte[], int) - Static method in class java.util. Arrays

复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。

copyOf(char[], int) - Static method in class java.util. Arrays

复制指定的数组，截断或填充空字符（如有必要），以便复制具有指定的长度。

copyOf(double[], int) - Static method in class java.util. Arrays

复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。

copyOf(float[], int) - Static method in class java.util. Arrays

复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。

copyOf(int[], int) - Static method in class java.util. Arrays

复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。

copyOf(long[], int) - Static method in class java.util. Arrays

复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。

copyOf(short[], int) - Static method in class java.util. Arrays

复制指定的数组，使用零截断或填充（如有必要），以使副本具有指定的长度。

copyOf(Collection<E>) - Static method in class java.util. EnumSet

创建从指定集合初始化的枚举集。

copyOf(EnumSet<E>) - Static method in class java.util. EnumSet

创建与指定的枚举集相同的元素类型的枚举集，最初包含相同的元素（如果有）。

copyOf(T[], int) - Static method in class java.util. Arrays

复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。

copyOf(U[], int, Class<? extends T[]>) - Static method in class java.util. Arrays

复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。

copyOfRange(boolean[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(byte[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(char[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(double[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(float[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(int[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(long[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(short[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(T[], int, int) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

copyOfRange(U[], int, int, Class<? extends T[]>) - Static method in class java.util. Arrays

将指定数组的指定范围复制到新数组中。

CopyOnWriteArrayList< E> - Class in java.util.concurrent

的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。

CopyOnWriteArrayList() - Constructor for class java.util.concurrent. CopyOnWriteArrayList

创建一个空列表。

CopyOnWriteArrayList(E[]) - Constructor for class java.util.concurrent. CopyOnWriteArrayList

创建一个包含给定数组的副本的列表。

CopyOnWriteArrayList(Collection<? extends E>) - Constructor for class java.util.concurrent. CopyOnWriteArrayList

按照集合的迭代器返回的顺序创建一个包含指定集合元素的列表。

CopyOnWriteArraySet< E> - Class in java.util.concurrent

A Set在其所有操作中使用内部CopyOnWriteArrayList 。

CopyOnWriteArraySet() - Constructor for class java.util.concurrent. CopyOnWriteArraySet

创建一个空集。

CopyOnWriteArraySet(Collection<? extends E>) - Constructor for class java.util.concurrent. CopyOnWriteArraySet

创建一个包含指定集合的所有元素的集合。

CopyOption - Interface in java.nio.file

配置如何复制或移动文件的对象。

copySign(double, double) - Static method in class java.lang. Math

使用第二个浮点参数的符号返回第一个浮点参数。

copySign(double, double) - Static method in class java.lang. StrictMath

使用第二个浮点参数的符号返回第一个浮点参数。

copySign(float, float) - Static method in class java.lang. Math

使用第二个浮点参数的符号返回第一个浮点参数。

copySign(float, float) - Static method in class java.lang. StrictMath

使用第二个浮点参数的符号返回第一个浮点参数。

copyTo(int, float[], int, int) - Method in interface javafx.collections. ObservableFloatArray

将数组的指定部分复制到 dest数组中。

copyTo(int, int[], int, int) - Method in interface javafx.collections. ObservableIntegerArray

将数组的指定部分复制到 dest数组中。

copyTo(int, ObservableFloatArray, int, int) - Method in interface javafx.collections. ObservableFloatArray

将数组的指定部分复制到可观察数组 dest 。

copyTo(int, ObservableIntegerArray, int, int) - Method in interface javafx.collections. ObservableIntegerArray

将数组的指定部分复制到可观察数组 dest 。

copyValueOf(char[]) - Static method in class java.lang. String

相当于 String.valueOf(char[]) 。

copyValueOf(char[], int, int) - Static method in class java.lang. String

相当于 String.valueOf(char[], int, int) 。

CORAL - Static variable in class javafx.scene.paint. Color

颜色珊瑚，RGB值为＃FF7F50

CornerRadii - Class in javafx.scene.layout

定义BorderStroke的四个角中的每一个的半径。

CornerRadii(double) - Constructor for class javafx.scene.layout. CornerRadii

为所有角落的所有组件创建一个具有单个均匀半径值的新CornerRadii。

CornerRadii(double, boolean) - Constructor for class javafx.scene.layout. CornerRadii

为每个角创建一个具有给定半径的新CornerRadii。

CornerRadii(double, double, double, double, boolean) - Constructor for class javafx.scene.layout. CornerRadii

为每个角落创建一个均匀而独立的半径的新CornerRadii。

CornerRadii(double, double, double, double, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.layout. CornerRadii

创建一个新的CornerRadii，允许指定每个角半径的每个组件，以及每个组件是否应被视为一个值或百分比。

CORNFLOWERBLUE - Static variable in class javafx.scene.paint. Color

颜色矢车菊蓝色，RGB值为＃6495ED

CORNSILK - Static variable in class javafx.scene.paint. Color

具有RGB值为＃FFF8DC的颜色cornsilk

cos(double) - Static method in class java.lang. Math

返回角度的三角余弦。

cos(double) - Static method in class java.lang. StrictMath

返回角度的三角余弦。

cosh(double) - Static method in class java.lang. Math

返回 double值的双曲余弦值。

cosh(double) - Static method in class java.lang. StrictMath

返回 double值的双曲余弦值。

count - Variable in class java.io. BufferedInputStream

索引一大于缓冲区中最后一个有效字节的索引。

count - Variable in class java.io. BufferedOutputStream

缓冲区中有效字节的数量。

count - Variable in class java.io. ByteArrayInputStream

索引一大于输入流缓冲区中的最后一个有效字符。

count - Variable in class java.io. ByteArrayOutputStream

缓冲区中有效字节的数量。

count - Variable in class java.io. CharArrayReader

这个缓冲区结束的索引。

count - Variable in class java.io. CharArrayWriter

缓冲区中的字符数。

count - Variable in class java.io. StringBufferInputStream

已过时。

输入流缓冲区中有效字符的数量。

count - Variable in class javax.swing.text. Segment

这是组成感兴趣文本的数组元素的数量。

count() - Method in interface java.nio.file. WatchEvent

返回事件计数。

count() - Method in interface java.util.stream. DoubleStream

返回此流中的元素数。

count() - Method in interface java.util.stream. IntStream

返回此流中的元素数。

count() - Method in interface java.util.stream. LongStream

返回此流中的元素数。

count() - Method in interface java.util.stream. Stream

返回此流中的元素数。

count() - Method in class org.omg.CORBA. ContextList

返回此 String对象中的 ContextList对象的数量。

count() - Method in class org.omg.CORBA. ExceptionList

检索此 TypeCode对象中的 ExceptionList对象数。

count() - Method in class org.omg.CORBA. NVList

返回的数量 NamedValue已经加入到这一对象 NVList对象。

countAttachments() - Method in class javax.xml.soap. SOAPMessage

获取此消息中附件数量的计数。

countComponents() - Method in class java.awt. Container

已过时。
从JDK 1.1版开始，由getComponentCount（）替换。

countDown() - Method in class java.util.concurrent. CountDownLatch

减少锁存器的计数，如果计数达到零，释放所有等待的线程。

CountDownLatch - Class in java.util.concurrent

允许一个或多个线程等待直到在其他线程中执行的一组操作完成的同步辅助。

CountDownLatch(int) - Constructor for class java.util.concurrent. CountDownLatch

构造一个以给定计数初始化的 CountDownLatch 。

CountedCompleter< T> - Class in java.util.concurrent

A ForkJoinTask ，当触发时执行完成操作，并且没有剩余的待处理操作。

CountedCompleter() - Constructor for class java.util.concurrent. CountedCompleter

创建一个新的CountedCompleter，没有完成，初始挂起计数为零。

CountedCompleter(CountedCompleter<?>) - Constructor for class java.util.concurrent. CountedCompleter

创建一个新的CountedCompleter与给定的完成者和初始挂起计数为零。

CountedCompleter(CountedCompleter<?>, int) - Constructor for class java.util.concurrent. CountedCompleter

创建一个新的CountedCompleter与给定的完成和初始挂起计数。

countedLoop(MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles

构造一个运行给定次数迭代的循环。

countedLoop(MethodHandle, MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles

构造一个计数一系列数字的循环。

Counter - Interface in org.w3c.dom.css

Counter接口用于表示任何计数器或计数器的功能值。

CounterMonitor - Class in javax.management.monitor

定义监视器MBean，用于观察计数器属性的值。

CounterMonitor() - Constructor for class javax.management.monitor. CounterMonitor

默认构造函数。

CounterMonitorMBean - Interface in javax.management.monitor

暴露计数器监视器MBean的远程管理界面。

counting() - Static method in class java.util.stream. Collectors

返回 Collector接收元素，类型为 T ，它计算输入元素的数量。

COUNTING_ROD_NUMERALS - Static variable in class java.lang. Character.UnicodeBlock

常数为“计数杆号”Unicode字符块。

countItems() - Method in class java.awt. Choice

已过时。
从JDK 1.1版开始，由getItemCount()替代。

countItems() - Method in class java.awt. List

已过时。
从JDK 1.1版开始，由getItemCount()替代。

countItems() - Method in class java.awt. Menu

已过时。
从JDK 1.1版开始，由getItemCount()替代。

countMenus() - Method in class java.awt. MenuBar

已过时。
从JDK 1.1版开始，由getMenuCount()替代。

countObservers() - Method in class java.util. Observable

已过时。

返回此 Observable对象的观察者数。

countStackFrames() - Method in class java.lang. Thread

不推荐用于删除：此API元素将在以后的版本中被删除。
此呼叫的定义取决于Thread.suspend() ，已被弃用。 此外，此呼叫的结果从未明确。 此方法在将来的Java SE版本中可能会被删除。

countTokens() - Method in class java.util. StringTokenizer

计算此生成异常之前可以调用此tokenizer的 nextToken方法的次数。

COVER - Static variable in class javax.print.attribute.standard. Finishings

当需要为文档选择未打印（或预先打印的）封面时，指定该值。

COVER_OPEN - Static variable in class javax.print.attribute.standard. PrinterStateReason

设备上的一个或多个封面是开放的。

CPE - Static variable in class javax.naming.spi. NamingManager

持有 getContinuationContext()存储其 CannotProceedException参数值的环境属性名称的常量。

crc - Variable in class java.util.zip. GZIPInputStream

CRC-32用于未压缩数据。

crc - Variable in class java.util.zip. GZIPOutputStream

未压缩数据的CRC-32。

CRC32 - Class in java.util.zip

可用于计算数据流的CRC-32的类。

CRC32() - Constructor for class java.util.zip. CRC32

创建一个新的CRC32对象。

CRC32C - Class in java.util.zip

可用于计算数据流的CRC-32C的类。

CRC32C() - Constructor for class java.util.zip. CRC32C

创建一个新的CRC32C对象。

create() - Static method in class com.sun.net.httpserver. HttpServer

创建一个最初没有绑定到任何本地地址/端口的HttpServer实例。

create() - Static method in class com.sun.net.httpserver. HttpsServer

创建一个最初没有绑定到任何本地地址/端口的HttpsServer实例。

create() - Method in class java.awt. Graphics

创建一个新的 Graphics对象，该对象是此 Graphics对象的副本。

create() - Static method in class java.lang.ref. Cleaner

返回一个新的 Cleaner 。

create() - Method in class java.net. DatagramSocketImpl

创建数据报套接字。

create() - Static method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder

创建一个新的实例 JavaBeanBooleanPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder

创建一个新的实例 JavaBeanDoublePropertyBuilder

create() - Static method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder

创建一个新的实例 JavaBeanFloatPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder

创建一个新的实例 JavaBeanIntegerPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder

创建一个新的实例 JavaBeanLongPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder

创建一个新的实例 JavaBeanObjectPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder

创建一个新的实例 JavaBeanStringPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder

创建一个新的实例 ReadOnlyJavaBeanBooleanPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder

创建一个新的实例 ReadOnlyJavaBeanDoublePropertyBuilder

create() - Static method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder

创建一个新的实例 ReadOnlyJavaBeanFloatPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder

创建一个新的实例 ReadOnlyJavaBeanIntegerPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder

创建一个新的实例 ReadOnlyJavaBeanLongPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder

创建一个新的实例 ReadOnlyJavaBeanObjectPropertyBuilder

create() - Static method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder

创建一个新的实例 ReadOnlyJavaBeanStringPropertyBuilder

create() - Method in class javax.swing. DebugGraphics

覆盖 Graphics.create以返回一个DebugGraphics对象。

create() - Static method in class jdk.jshell. JShell

创建一个新的JShell状态引擎。

create() - Static method in class jdk.net. SocketFlow

创建一个新的SocketFlow，可用于设置SO_FLOW_SLA套接字选项并创建套接字流。

create(boolean) - Method in class java.net. SocketImpl

创建流或数据报套接字。

create(int, int) - Static method in class com.sun.nio.sctp. SctpStandardSocketOptions.InitMaxStreams

创建一个InitMaxStreams实例。

create(int, int, int, int) - Method in class java.awt. Graphics

基于这个 Graphics对象创建一个新的 Graphics对象，但使用了一个新的翻译和剪辑区域。

create(int, int, int, int) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.create以返回一个DebugGraphics对象。

create(ParameterBlock, RenderingHints) - Method in interface java.awt.image.renderable. RenderedImageFactory

创建表示给定ParameterBlock和RenderingHints的成像操作（或操作链）的结果的RenderedImage。

create(RenderContext, ParameterBlock) - Method in interface java.awt.image.renderable. ContextualRenderedImageFactory

给定一个渲染，给定一个RenderContext和一个ParameterBlock，其中包含操作的源和参数。

create(Class<T>, Object, String) - Static method in class java.beans. EventHandler

创建一个 listenerInterface的实现，其中监听器界面中的 所有方法将处理程序的 action应用于 target 。

create(Class<T>, Object, String, String) - Static method in class java.beans. EventHandler

/ **创建 listenerInterface的实现，其中 所有方法将事件表达式 eventPropertyName的值传递给应用于 action的语句中的最终方法 target 。

create(Class<T>, Object, String, String, String) - Static method in class java.beans. EventHandler

创建的实施 listenerInterface其中命名方法 listenerMethodName传递事件表达，的值 eventPropertyName ，在语句中的最终方法， action ，其被施加到 target 。

create(Object) - Static method in class javax.xml.ws. Endpoint

创建具有指定的实现对象的端点。

create(Object, WebServiceFeature...) - Static method in class javax.xml.ws. Endpoint

创建具有指定的实现者对象和Web服务功能的端点。

create(String) - Static method in class java.net. URI

通过解析给定的字符串创建一个URI。

create(String) - Method in class javax.xml.soap. SOAPElementFactory

已过时。
改用javax.xml.soap.SOAPFactory.createElement（String localName）

create(String...) - Static method in interface jdk.nashorn.api.tree. Parser

Factory方法创建一个新的Parser实例。

create(String, Object) - Static method in class javax.xml.ws. Endpoint

创建具有指定绑定类型和实现方对象的端点。

create(String, Object, WebServiceFeature...) - Static method in class javax.xml.ws. Endpoint

创建具有指定绑定类型，实现方对象和Web服务功能的端点。

create(String, String, String) - Method in class javax.xml.soap. SOAPElementFactory

已过时。
改用javax.xml.soap.SOAPFactory.createElement（String localName，String prefix，String uri）

create(InetSocketAddress, int) - Static method in class com.sun.net.httpserver. HttpServer

创建一个HttpServer实例，它将绑定到指定的InetSocketAddress （IP地址和端口号）也可以指定最大的积压。

create(InetSocketAddress, int) - Static method in class com.sun.net.httpserver. HttpsServer

创建将绑定到指定的InetSocketAddress （IP地址和端口号）的HttpsServer实例也可以指定最大积压。

create(URL, long) - Method in interface javax.jnlp. PersistenceService

在客户端创建一个以给定的URL命名的永久存储条目。

create(URL, QName) - Static method in class javax.xml.ws. Service

创建一个 Service实例。

create(URL, QName, WebServiceFeature...) - Static method in class javax.xml.ws. Service

创建一个 Service实例。

create(ThreadFactory) - Static method in class java.lang.ref. Cleaner

返回一个新 Cleaner使用 Thread从 ThreadFactory 。

create(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text. DefaultStyledDocument

初始化文档以反映给定的元素结构（即 getDefaultRootElement方法报告的结构）。

create(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.html. HTMLDocument

用给定的元素规格替换文档的内容。

create(Element) - Method in class javax.swing.plaf.basic. BasicPasswordFieldUI

为元素创建一个视图（PasswordView）。

create(Element) - Method in class javax.swing.plaf.basic. BasicTextAreaUI

创建元素的视图。

create(Element) - Method in class javax.swing.plaf.basic. BasicTextFieldUI

根据元素创建视图（FieldView）。

create(Element) - Method in class javax.swing.plaf.basic. BasicTextUI

创建元素的视图。

create(Element) - Method in class javax.swing.plaf.synth. SynthPasswordFieldUI

为元素创建一个视图（PasswordView）。

create(Element) - Method in class javax.swing.text.html. HTMLEditorKit.HTMLFactory

从元素创建视图。

create(Element) - Method in interface javax.swing.text. ViewFactory

从文档的给定结构元素创建视图。

create(Element, int, int) - Method in class javax.swing.plaf.basic. BasicTextUI

创建元素的视图。

create(QName) - Static method in class javax.xml.ws. Service

创建一个 Service实例。

create(QName, WebServiceFeature...) - Static method in class javax.xml.ws. Service

创建一个 Service实例。

create(Name) - Method in class javax.xml.soap. SOAPElementFactory

已过时。
改用javax.xml.soap.SOAPFactory.createElement（javax.xml.soap.Name）

CREATE - java.nio.file. StandardOpenOption

创建一个新文件（如果不存在）。

create_abstract_interface_tc(String, String) - Method in class org.omg.CORBA. ORB

为IDL抽象接口创建一个 TypeCode对象。

create_alias_tc(String, String, TypeCode) - Method in class org.omg.CORBA. ORB

创建一个表示IDL alias （ typedef ）的 TypeCode对象。

create_any() - Method in class org.omg.CORBA. ORB

创建一个IDL Any对象，初始化为 Typecode对象，其对象的 kind字段设置为 TCKind.tc_null 。

create_array_tc(int, TypeCode) - Method in class org.omg.CORBA. ORB

创建一个表示IDL array的 TypeCode对象。

create_basic_dyn_any(TypeCode) - Method in class org.omg.CORBA. ORB

已过时。
使用新的DynAnyFactory API

create_child(String) - Method in class org.omg.CORBA. Context

创建一个 Context对象，其中给定的字符串作为其名称，并将此 Context对象设置为其父对象。

create_codec(Encoding) - Method in interface org.omg.IOP. CodecFactoryOperations

创建给定编码的 Codec 。

create_context_list() - Method in class org.omg.CORBA. ORB

创建一个空的 ContextList对象。

create_dyn_any(Any) - Method in class org.omg.CORBA. ORB

已过时。
使用新的DynAnyFactory API

create_dyn_any(Any) - Method in class org.omg.DynamicAny. _DynAnyFactoryStub

从任何值创建一个新的DynAny对象。

create_dyn_any(Any) - Method in interface org.omg.DynamicAny. DynAnyFactoryOperations

从任何值创建一个新的DynAny对象。

create_dyn_any_from_type_code(TypeCode) - Method in class org.omg.DynamicAny. _DynAnyFactoryStub

从TypeCode创建DynAny。

create_dyn_any_from_type_code(TypeCode) - Method in interface org.omg.DynamicAny. DynAnyFactoryOperations

从TypeCode创建DynAny。

create_dyn_array(TypeCode) - Method in class org.omg.CORBA. ORB

已过时。
使用新的DynAnyFactory API

create_dyn_enum(TypeCode) - Method in class org.omg.CORBA. ORB

已过时。
使用新的DynAnyFactory API

create_dyn_sequence(TypeCode) - Method in class org.omg.CORBA. ORB

已过时。
使用新的DynAnyFactory API

create_dyn_struct(TypeCode) - Method in class org.omg.CORBA. ORB

已过时。
使用新的DynAnyFactory API

create_dyn_union(TypeCode) - Method in class org.omg.CORBA. ORB

已过时。
使用新的DynAnyFactory API

create_enum_tc(String, String, String[]) - Method in class org.omg.CORBA. ORB

创建一个表示IDL 枚举的 TypeCode对象。

create_environment() - Method in class org.omg.CORBA. ORB

创建一个 Environment对象。

create_exception_list() - Method in class org.omg.CORBA. ORB

创建一个空的 ExceptionList对象。

create_exception_tc(String, String, StructMember[]) - Method in class org.omg.CORBA. ORB

创建一个表示IDL exception的 TypeCode对象。

create_fixed_tc(short, short) - Method in class org.omg.CORBA. ORB

为IDL固定类型创建一个 TypeCode对象。

create_id_assignment_policy(IdAssignmentPolicyValue) - Method in interface org.omg.PortableServer. POAOperations

这些操作都返回具有指定值的策略对象的引用。

create_id_uniqueness_policy(IdUniquenessPolicyValue) - Method in interface org.omg.PortableServer. POAOperations

这些操作都返回具有指定值的策略对象的引用。

create_implicit_activation_policy(ImplicitActivationPolicyValue) - Method in interface org.omg.PortableServer. POAOperations

这些操作都返回具有指定值的策略对象的引用。

create_input_stream() - Method in class org.omg.CORBA. Any

创建一个输入流，从中可以 Any此 Any对象的值。

create_input_stream() - Method in class org.omg.CORBA.portable. OutputStream

返回具有相同缓冲区的输入流。

create_interface_tc(String, String) - Method in class org.omg.CORBA. ORB

创建一个表示IDL interface的 TypeCode对象。

create_lifespan_policy(LifespanPolicyValue) - Method in interface org.omg.PortableServer. POAOperations

这些操作都返回具有指定值的策略对象的引用。

create_list(int) - Method in class org.omg.CORBA. ORB

分配一个 NVList （可能）足够的空间用于指定数量的 NamedValue对象。

create_named_value(String, Any, int) - Method in class org.omg.CORBA. ORB

使用给定的名称，值和参数模式标志创建一个 NamedValue对象。

create_native_tc(String, String) - Method in class org.omg.CORBA. ORB

为IDL本机类型创建一个 TypeCode对象。

CREATE_NEW - java.nio.file. StandardOpenOption

创建一个新的文件，如果该文件已经存在失败。

create_operation_list(Object) - Method in class org.omg.CORBA. ORB

创建一个 NVList初始化的参数描述，在给定的 OperationDef对象中描述的操作。

create_output_stream() - Method in class org.omg.CORBA. Any

创建一个可以编组 Any对象的值的输出流。

create_output_stream() - Method in class org.omg.CORBA. ORB

创建一个新的 org.omg.CORBA.portable.OutputStream ，可以在方法调用期间 org.omg.CORBA.portable.OutputStream IDL方法参数。

create_POA(String, POAManager, Policy[]) - Method in interface org.omg.PortableServer. POAOperations

此操作将创建一个新的POA作为目标POA的子代。

create_policy(int, Any) - Method in class org.omg.CORBA. ORB

可以调用以创建具有指定初始状态的特定类型的策略对象的新实例。

create_policy(int, Any) - Method in interface org.omg.PortableInterceptor. PolicyFactoryOperations

返回从 CORBA.Policy派生的适当接口的实例，其值对应于指定的任何值。

create_recursive_sequence_tc(int, int) - Method in class org.omg.CORBA. ORB

已过时。
使用create_recursive_tc和create_sequence_tc的组合

create_recursive_tc(String) - Method in class org.omg.CORBA. ORB

创建一个递归的 TypeCode对象，该对象在创建包含递归的TypeCode的过程中充当具体的TypeCode的占位符。

create_reference(String) - Method in interface org.omg.PortableServer. POAOperations

此操作创建一个对象引用，该引用封装了POA生成的对象标识值和指定的接口存储库标识。

create_reference_with_id(byte[], String) - Method in interface org.omg.PortableServer. POAOperations

此操作创建一个对象引用，该引用封装了指定的对象标识和接口存储库标识值。

create_request(Object, Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.portable. Delegate

创建一个要在动态调用接口中使用的请求实例。

create_request(Object, Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.portable. Delegate

创建一个要在动态调用接口中使用的请求实例。

create_request_processing_policy(RequestProcessingPolicyValue) - Method in interface org.omg.PortableServer. POAOperations

这些操作都返回具有指定值的策略对象的引用。

create_sequence_tc(int, TypeCode) - Method in class org.omg.CORBA. ORB

创建一个表示IDL sequence的 TypeCode对象。

create_servant_retention_policy(ServantRetentionPolicyValue) - Method in interface org.omg.PortableServer. POAOperations

这些操作都返回具有指定值的策略对象的引用。

create_string_tc(int) - Method in class org.omg.CORBA. ORB

创建一个表示有界IDL string的 TypeCode对象。

create_struct_tc(String, String, StructMember[]) - Method in class org.omg.CORBA. ORB

创建 TypeCode表示IDL对象 struct 。

create_thread_policy(ThreadPolicyValue) - Method in interface org.omg.PortableServer. POAOperations

这些操作都返回具有指定值的策略对象的引用。

create_union_tc(String, String, TypeCode, UnionMember[]) - Method in class org.omg.CORBA. ORB

创建 TypeCode表示IDL对象 union 。

create_value_box_tc(String, String, TypeCode) - Method in class org.omg.CORBA. ORB

为IDL值框创建一个 TypeCode对象。

create_value_tc(String, String, short, TypeCode, ValueMember[]) - Method in class org.omg.CORBA. ORB

为IDL值类型创建一个 TypeCode对象。

create_wstring_tc(int) - Method in class org.omg.CORBA. ORB

表示一个 TypeCode对象，表示一个有界的IDL wstring （宽字符串）。

createAccessWatchpointRequest(Field) - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用的观察点，监视对指定字段的访问。

createActionChangeListener(JButton) - Method in class javax.swing. JToolBar

返回一个正确配置的 PropertyChangeListener ，其更新控件作为 Action发生的更改，或 null如果需要该控件的默认属性更改侦听器）。

createActionChangeListener(JMenuItem) - Method in class javax.swing. JMenu

返回正确配置的 PropertyChangeListener ，更新控件，因为发生 Action更改。

createActionChangeListener(JMenuItem) - Method in class javax.swing. JPopupMenu

返回正确配置的 PropertyChangeListener ，更新控件，因为发生 Action更改。

createActionComponent(Action) - Method in class javax.swing. JMenu

工厂方法创建 JMenuItem为 Action添加到 JMenu 。

createActionComponent(Action) - Method in class javax.swing. JPopupMenu

工厂方法创建 JMenuItem为 Actions添加到 JPopupMenu 。

createActionComponent(Action) - Method in class javax.swing. JToolBar

工厂方法为 Action创建 JButton添加到 JToolBar 。

createActionListener() - Method in class javax.swing. AbstractButton

返回添加到模型的 ActionListener 。

createActionMap() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

构造一个 ActionMap的实例。

createActionPropertyChangeListener(Action) - Method in class javax.swing. AbstractButton

创建并返回一个 PropertyChangeListener ，负责监听从指定的 Action进行的更改并更新相应的属性。

createActionPropertyChangeListener(Action) - Method in class javax.swing. JComboBox

创建并返回一个 PropertyChangeListener ，负责监听从指定的 Action进行的更改并更新相应的属性。

createActionPropertyChangeListener(Action) - Method in class javax.swing. JTextField

创建并返回一个 PropertyChangeListener ，负责监听从指定的 Action进行的更改并更新相应的属性。

createActions() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

创建动作。

createAndPublishEndpoint(String, Object) - Method in class javax.xml.ws.spi. Provider

创建并发布具有指定地址和实现对象的端点对象。

createAndPublishEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi. Provider

创建并发布具有指定地址，实现对象和Web服务功能的端点对象。

createArrayForType(int, int) - Static method in class javax.imageio.plugins.tiff. TIFFField

创建一个适合指定数据类型的数组。

createArrayOf(String, Object[]) - Method in interface java.sql. Connection

用于创建Array对象的Factory方法。

createArrowButton() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建一个按钮，该按钮将用作控件来显示或隐藏组合框的弹出窗口部分。

createArrowButton() - Method in class javax.swing.plaf.metal. MetalComboBoxUI

createArrowButton() - Method in class javax.swing.plaf.synth. SynthComboBoxUI

创建一个按钮，该按钮将用作控件来显示或隐藏组合框的弹出窗口部分。

createArrowButtonListener() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

创建一个箭头按钮侦听器。

createAttachmentPart() - Method in class javax.xml.soap. SOAPMessage

创建一个新的空的 AttachmentPart对象。

createAttachmentPart(Object, String) - Method in class javax.xml.soap. SOAPMessage

创建一个 AttachmentPart对象，并使用指定的内容类型的指定数据进行填充。

createAttachmentPart(DataHandler) - Method in class javax.xml.soap. SOAPMessage

创建一个 AttachmentPart对象，并使用给定的 DataHandler对象进行填充。

createAttribute(String) - Method in interface org.w3c.dom. Document

创建给定名称的 Attr 。

createAttribute(String, String) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的属性

createAttribute(String, String, String, String) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的属性

createAttribute(QName, String) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的属性

createAttributeNS(String, String) - Method in interface org.w3c.dom. Document

创建给定的限定名称和命名空间URI的属性。

createAudioAction(Object) - Method in class javax.swing.plaf.basic. BasicLookAndFeel

创建并返回一个 Action用于播放声音。

createBackBuffers(int) - Method in class java.awt. Component.BltBufferStrategy

创建后台缓冲区

createBanded(ColorSpace, int[], int[], int, boolean, boolean) - Static method in class javax.imageio. ImageTypeSpecifier

返回带状图像格式的说明符，将使用 ComponentColorModel和 BandedSampleModel将每个通道存储在单独的数组中。

createBandedRaster(int, int, int, int, int[], int[], Point) - Static method in class java.awt.image. Raster

基于具有指定数据类型，宽度，高度，扫描线步长，银行索引和带偏移的BandedSampleModel创建光栅。

createBandedRaster(int, int, int, int, Point) - Static method in class java.awt.image. Raster

根据具有指定数据类型，宽度，高度和频带数的BandedSampleModel创建栅格。

createBandedRaster(DataBuffer, int, int, int, int[], int[], Point) - Static method in class java.awt.image. Raster

根据指定的DataBuffer，width，height，scanline stride，bank index和band offsets创建一个基于BandedSampleModel的光栅。

createBaselineGroup(boolean, boolean) - Method in class javax.swing. GroupLayout

创建并返回一个 ParallelGroup ，使其沿着基线的元素对齐。

createBCSChild(Object, Object) - Method in class java.beans.beancontext. BeanContextServicesSupport

子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。

createBCSChild(Object, Object) - Method in class java.beans.beancontext. BeanContextSupport

子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。

createBCSSServiceProvider(Class<?>, BeanContextServiceProvider) - Method in class java.beans.beancontext. BeanContextServicesSupport

子类可以覆盖此方法来创建BCSSServiceProvider的新子类，而不必重写addService（）以便实例化。

createBevelBorder(int) - Static method in class javax.swing. BorderFactory

创建指定类型的斜角边框，使用组件的当前背景颜色的较亮的阴影突出显示，阴影的阴影更暗。

createBevelBorder(int, Color, Color) - Static method in class javax.swing. BorderFactory

使用指定的高亮和阴影创建指定类型的斜角边框。

createBevelBorder(int, Color, Color, Color, Color) - Static method in class javax.swing. BorderFactory

创建指定类型的斜角边框，使用指定的颜色进行内部和外部高亮和阴影区域。

createBinder() - Method in class javax.xml.bind. JAXBContext

为W3C DOM创建一个 Binder 。

createBinder(Class<T>) - Method in class javax.xml.bind. JAXBContext

创建可用于关联/就地解组/编组的 Binder对象。

createBindings() - Method in interface javax.script. ScriptEngine

返回未初始化的 Bindings 。

createBindings() - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

createBlackLineBorder() - Static method in class javax.swing.border. LineBorder

获取Color.black LineBorder厚度为1的便捷方法。

createBlob() - Method in interface java.sql. Connection

构造一个实现 Blob接口的对象。

createBooleanBinding(Callable<Boolean>, Observable...) - Static method in class javafx.beans.binding. Bindings

助手功能创建自定义BooleanBinding 。

createBooleanCssMetaData(String, Function<S, StyleableProperty<Boolean>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。

createBooleanCssMetaData(String, Function<S, StyleableProperty<Boolean>>, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。

createBooleanCssMetaData(String, Function<S, StyleableProperty<Boolean>>, boolean, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Boolean>，并继承标志。

createBorderListener(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建边框侦听器。

createBorderListener(JInternalFrame) - Method in class javax.swing.plaf.metal. MetalInternalFrameUI

返回 MouseInputAdapter ，将在TitlePane安装。

createBranchElement(Element, AttributeSet) - Method in class javax.swing.text. AbstractDocument

创建一个可以包含其他元素的文档分支元素。

createBranchElement(Element, AttributeSet) - Method in class javax.swing.text.html. HTMLDocument

创建一个可以包含其他元素的文档分支元素。

createBreakpointRequest(Location) - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用BreakpointRequest 。

createBufferedImage(int, int) - Method in class javax.imageio. ImageTypeSpecifier

根据此对象中体现的规范，创建一个给定宽度和高度的 BufferedImage 。

createBuffers(int, BufferCapabilities) - Method in class java.awt. Component.FlipBufferStrategy

使用给定的功能创建一个或多个复杂的翻转缓冲区。

createBufferStrategy(int) - Method in class java.awt. Canvas

为此组件创建一个新的多缓冲策略。

createBufferStrategy(int) - Method in class java.awt. Window

为此组件创建一个新的多缓冲策略。

createBufferStrategy(int, BufferCapabilities) - Method in class java.awt. Canvas

在此组件上创建一个新策略，以实现所需的缓冲功能。

createBufferStrategy(int, BufferCapabilities) - Method in class java.awt. Window

在此组件上创建一个新策略，以实现所需的缓冲功能。

createButton(ButtonType) - Method in class javafx.scene.control. DialogPane

子类可以覆盖此方法来创建一个随后插入DialogPane按钮区域的自定义按钮（通过DialogPane.createButtonBar()方法创建，但通常它是ButtonBar的一个实例）。

createButtonActionListener(int) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

构造一个新的 ButtonActionListener实例。

createButtonArea() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

创建并返回包含按钮的 Container 。

createButtonBar() - Method in class javafx.scene.control. DialogPane

这个方法可以被子类覆盖以提供按钮栏。

createButtonListener(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI

返回一个新的实例 BasicButtonListener 。

createButtonListener(AbstractButton) - Method in class javax.swing.plaf.metal. MetalButtonUI

createButtons() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

创建按钮。

createButtons() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane

createByteIndexedInstance(int[]) - Static method in class javafx.scene.image. PixelFormat

创建描述像素布局的 PixelFormat实例，其中像素存储为单字节，表示索引到 INT_ARGB格式的 非预乘颜色值的指定查找表中。

createByteIndexedPremultipliedInstance(int[]) - Static method in class javafx.scene.image. PixelFormat

创建描述像素布局的 PixelFormat实例，其中像素存储为单个字节，表示索引到 INT_ARGB_PRE格式的 预乘颜色值的指定查找表中。

createCachedRowSet() - Method in interface javax.sql.rowset. RowSetFactory

创建一个新的CachedRowSet实例。

createCaption() - Method in interface org.w3c.dom.html. HTMLTableElement

创建一个新的表标题对象或返回一个现有的。

createCaret() - Method in class javax.swing.plaf.basic. BasicTextUI

创建用于插入符号的对象。

createCaret() - Method in class javax.swing.text. DefaultEditorKit

获取可以浏览由相关ViewFactory生成的视图的插入符号。

createCaret() - Method in class javax.swing.text. EditorKit

获取可以浏览由相关ViewFactory生成的视图的插入符号。

createCData(String) - Method in class javax.xml.stream. XMLEventFactory

创建一个Charata事件，CData标志设置为true

createCDATASection(String) - Method in interface org.w3c.dom. Document

创建一个值为指定字符串的 CDATASection节点。

createCell(TableColumnBase) - Method in class javafx.scene.control.skin. TableRowSkin

创建适用于表示给定表列实例的新单元实例。

createCell(TableColumnBase) - Method in class javafx.scene.control.skin. TreeTableRowSkin

创建适用于表示给定表列实例的新单元实例。

createCell(TableColumnBase<T, ?>) - Method in class javafx.scene.control.skin. TableRowSkinBase

创建适用于表示给定表列实例的新单元实例。

createCellEditorListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建一个监听器来处理来自当前编辑器的事件。

createCellRendererPane() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回渲染器组件所在的渲染器窗格。

createChangeListener() - Method in class javax.swing. AbstractButton

想要处理 ChangeEvents子类可以覆盖此值，以返回另一个 ChangeListener实现。

createChangeListener() - Method in class javax.swing. JProgressBar

希望以不同方式处理来自模型的更改事件的子类可以覆盖此返回自定义 ChangeListener实现的实例。

createChangeListener() - Method in class javax.swing. JSlider

想要从模型处理 ChangeEvent s的子 ChangeEvent可以覆盖这一点，以返回自定义的 ChangeListener实现的实例。

createChangeListener() - Method in class javax.swing. JTabbedPane

想要处理 ChangeEvents的子类可以覆盖此值，以返回一个 ModelListener或另一个 ChangeListener实现的子类。

createChangeListener() - Method in class javax.swing.plaf.basic. BasicMenuBarUI

返回一个 ChangeListener的实例。

createChangeListener() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

创建一个更改侦听器。

createChangeListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuUI

返回一个 ChangeListener的实例。

createChangeListener(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

创建一个更改侦听器。

createCharacters(String) - Method in class javax.xml.stream. XMLEventFactory

创建一个Characters事件，此方法不检查内容是否为空白。

createChild(int, int, int, int, int, int, int[]) - Method in class java.awt.image. Raster

返回一个新的Raster，它共享此Raster DataBuffer的全部或部分。

createChildren(DefaultMutableTreeNode, Object) - Static method in class javax.swing. JTree.DynamicUtilTreeNode

添加到父母所有的孩子在 children 。

createChildState(View) - Method in class javax.swing.text. AsyncBoxView

通过此方法创建新的ChildState记录，以允许子类将ChildState记录扩展为更多。

createClassFile(CharSequence, Element...) - Method in interface javax.annotation.processing. Filer

创建一个新的类文件，并返回一个对象以允许写入它。

createClassPrepareRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用ClassPrepareRequest 。

createClassUnloadRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用ClassUnloadRequest 。

createClob() - Method in interface java.sql. Connection

构造一个实现 Clob接口的对象。

createColorCssMetaData(String, Function<S, StyleableProperty<Color>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。

createColorCssMetaData(String, Function<S, StyleableProperty<Color>>, Color) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。

createColorCssMetaData(String, Function<S, StyleableProperty<Color>>, Color, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Color>并继承标志。

createComment(String) - Method in class javax.xml.stream. XMLEventFactory

创建评论

createComment(String) - Method in interface org.w3c.dom. Document

为指定的字符串创建一个 Comment节点。

createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image. AffineTransformOp

创建具有正确大小和频带数的归零目标图像。

createCompatibleDestImage(BufferedImage, ColorModel) - Method in interface java.awt.image. BufferedImageOp

创建具有正确大小和频带数的归零目标图像。

createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image. ColorConvertOp

给出这个来源，创建具有正确大小和频带数的归零目标图像。

createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image. ConvolveOp

创建具有正确大小和频带数的归零目标图像。

createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image. LookupOp

创建具有正确大小和频带数的归零目标图像。

createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image. RescaleOp

创建具有正确大小和频带数的归零目标图像。

createCompatibleDestRaster(Raster) - Method in class java.awt.image. AffineTransformOp

创建带有正确大小和频带数的零目的地 Raster 。

createCompatibleDestRaster(Raster) - Method in class java.awt.image. BandCombineOp

创建一个归零目的地 Raster具有正确的大小和数量的频带。

createCompatibleDestRaster(Raster) - Method in class java.awt.image. ColorConvertOp

给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。

createCompatibleDestRaster(Raster) - Method in class java.awt.image. ConvolveOp

给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。

createCompatibleDestRaster(Raster) - Method in class java.awt.image. LookupOp

创建一个零目的地 Raster具有正确的大小和数量的带，给定这个来源。

createCompatibleDestRaster(Raster) - Method in interface java.awt.image. RasterOp

创建具有正确大小和频带数的归零目标光栅。

createCompatibleDestRaster(Raster) - Method in class java.awt.image. RescaleOp

创建一个零目的地 Raster具有正确的大小和数量的频带，给定这个来源。

createCompatibleImage(int, int) - Method in class java.awt. GraphicsConfiguration

返回一个BufferedImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。

createCompatibleImage(int, int, int) - Method in class java.awt. GraphicsConfiguration

返回支持指定透明度的 BufferedImage ，并具有与此 GraphicsConfiguration兼容的数据布局和颜色模型。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. BandedSampleModel

创建一个带有指定宽度和高度的新的BandedSampleModel。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. ColorModel

创建一个 SampleModel ，具有与此 ColorModel兼容的数据布局的指定宽度和高度。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. ComponentColorModel

创建一个具有指定宽度和高度的 SampleModel ，它具有与此 ColorModel兼容的数据布局。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. ComponentSampleModel

创建一个新的 ComponentSampleModel具有指定的宽度和高度。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. IndexColorModel

创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. MultiPixelPackedSampleModel

创建一个新的 MultiPixelPackedSampleModel具有指定的宽度和高度。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. PackedColorModel

创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. PixelInterleavedSampleModel

创建一个具有指定宽度和高度的新PixelInterleavedSampleModel。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. SampleModel

创建一个SampleModel，它描述了SampleModel格式的数据，但是具有不同的宽度和高度。

createCompatibleSampleModel(int, int) - Method in class java.awt.image. SinglePixelPackedSampleModel

创建一个具有指定宽度和高度的新SinglePixelPackedSampleModel。

createCompatibleVolatileImage(int, int) - Method in class java.awt. GraphicsConfiguration

返回一个VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。

createCompatibleVolatileImage(int, int, int) - Method in class java.awt. GraphicsConfiguration

返回一个VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。

createCompatibleVolatileImage(int, int, ImageCapabilities) - Method in class java.awt. GraphicsConfiguration

使用指定的图像功能返回一个VolatileImage，其中包含与此GraphicsConfiguration兼容的数据布局和颜色模型。

createCompatibleVolatileImage(int, int, ImageCapabilities, int) - Method in class java.awt. GraphicsConfiguration

使用指定的图像功能和透明度值返回VolatileImage，其中包含与此GraphicsConfiguration兼容的数据布局和颜色模型。

createCompatibleWritableRaster() - Method in class java.awt.image. Raster

创建与此Raster相同大小的兼容WritableRaster，具有相同的SampleModel和新的已初始化的DataBuffer。

createCompatibleWritableRaster(int, int) - Method in class java.awt.image. ColorModel

创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。

createCompatibleWritableRaster(int, int) - Method in class java.awt.image. ComponentColorModel

创建一个具有指定宽度和高度的 WritableRaster ，具有与此 ColorModel兼容的数据布局（ SampleModel ）。

createCompatibleWritableRaster(int, int) - Method in class java.awt.image. DirectColorModel

创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。

createCompatibleWritableRaster(int, int) - Method in class java.awt.image. IndexColorModel

创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。

createCompatibleWritableRaster(int, int) - Method in class java.awt.image. Raster

创建一个具有指定大小的兼容WritableRaster，一个新的SampleModel和一个新的初始化DataBuffer。

createCompatibleWritableRaster(int, int, int, int) - Method in class java.awt.image. Raster

创建一个兼容的WritableRaster，具有指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。

createCompatibleWritableRaster(Rectangle) - Method in class java.awt.image. Raster

创建一个兼容的WritableRaster，它具有由rect指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。

createComponent() - Method in class javax.swing.text. ComponentView

创建与此视图关联的组件。

createComponent() - Method in class javax.swing.text.html. FormView

创建组件。

createComponent() - Method in class javax.swing.text.html. ObjectView

创建组件。

createComponentListener() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建组件侦听器。

createComponentListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建并返回一个新的ComponentHandler。

createComponentListener() - Method in class javax.swing.plaf.synth. SynthInternalFrameUI

创建组件侦听器。

createComponentListener(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

创建一个复合侦听器。

createCompoundBorder() - Static method in class javax.swing. BorderFactory

创建一个 null内边缘和 null外边缘的复合边框。

createCompoundBorder(Border, Border) - Static method in class javax.swing. BorderFactory

创建一个复合边框，指定要用于外边和内边的边框对象。

createCompoundEdit() - Method in class javax.swing.undo. UndoableEditSupport

仅限于 beginUpdate 。

createConcatenation(Transform) - Method in class javafx.scene.transform. Affine

createConcatenation(Transform) - Method in class javafx.scene.transform. Rotate

createConcatenation(Transform) - Method in class javafx.scene.transform. Scale

createConcatenation(Transform) - Method in class javafx.scene.transform. Shear

createConcatenation(Transform) - Method in class javafx.scene.transform. Transform

返回此变换和指定变换的并置。

createConcatenation(Transform) - Method in class javafx.scene.transform. Translate

createConnection() - Method in class javax.xml.soap. SOAPConnectionFactory

创建一个新的 SOAPConnection 。

createConnectionBuilder() - Method in interface javax.sql. DataSource

创建一个新的 ConnectionBuilder实例

createContainer() - Method in class javax.swing.tree. DefaultTreeCellEditor

创建容器管理 editingComponent位置。

createContainerListener() - Method in class javax.swing.plaf.basic. BasicMenuBarUI

返回一个 ContainerListener的实例。

createContainerListener() - Method in class javax.swing.plaf.metal. MetalToolBarUI

创建一个将添加到JToolBar的容器监听器。

createContentHandler(String) - Method in interface java.net. ContentHandlerFactory

创建一个新的 ContentHandler从 URLStreamHandler读取一个对象。

createContentPane() - Method in class javax.swing. JRootPane

由构造函数调用方法创建默认的 contentPane 。

createContext(byte[]) - Method in class org.ietf.jgss. GSSManager

用于创建先前导出的上下文的工厂方法。

createContext(ColorModel, ColorModel, RenderingHints) - Method in class java.awt. AlphaComposite

创建合成操作的上下文。

createContext(ColorModel, ColorModel, RenderingHints) - Method in interface java.awt. Composite

创建用于执行合成操作的上下文包含状态。

createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt. Color

创建并返回一个用于生成纯色字段模式的PaintContext 。

createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt. GradientPaint

创建并返回一个用于生成线性颜色渐变模式的PaintContext 。

createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt. LinearGradientPaint

创建并返回一个用于生成线性颜色渐变模式的PaintContext 。

createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in interface java.awt. Paint

创建并返回一个用于生成颜色模式的PaintContext 。

createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt. RadialGradientPaint

创建并返回一个用于生成圆形径向颜色渐变图案的PaintContext 。

createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt. TexturePaint

创建并返回一个用于生成平铺图像模式的PaintContext 。

createContext(Class<?>[], Map<String, ?>) - Method in interface javax.xml.bind. JAXBContextFactory

创建一个新的 JAXBContext类的实例。

createContext(String) - Method in class com.sun.net.httpserver. HttpServer

创建一个HttpContext，而不会最初指定一个处理程序。

createContext(String, HttpHandler) - Method in class com.sun.net.httpserver. HttpServer

创建一个HttpContext。

createContext(String, ClassLoader, Map<String, ?>) - Method in interface javax.xml.bind. JAXBContextFactory

创建一个新的 JAXBContext类的实例。

createContext(GSSCredential) - Method in class org.ietf.jgss. GSSManager

用于在受体侧创建上下文的工厂方法。

createContext(GSSName, Oid, GSSCredential, int) - Method in class org.ietf.jgss. GSSManager

用于在启动者侧创建上下文的工厂方法。

createCopy() - Method in interface javax.sql.rowset. CachedRowSet

创建一个 RowSet对象，该对象是此 CachedRowSet对象中的数据的深层副本。

createCopyNoConstraints() - Method in interface javax.sql.rowset. CachedRowSet

创建一个 CachedRowSet对象，该对象是此 CachedRowSet对象数据的深层副本，但 CachedRowSet无关。

createCopySchema() - Method in interface javax.sql.rowset. CachedRowSet

创建一个 CachedRowSet对象，该对象是此 CachedRowSet对象的空白副本。

createCredential(int) - Method in class org.ietf.jgss. GSSManager

用于获取默认凭据的工厂方法。

createCredential(GSSName, int, Oid[], int) - Method in class org.ietf.jgss. GSSManager

用于通过一组机制获取凭据的工厂方法。

createCredential(GSSName, int, Oid, int) - Method in class org.ietf.jgss. GSSManager

用于获取单一机制凭证的工厂方法。

createCSSStyleSheet(String, String) - Method in interface org.w3c.dom.css. DOMImplementationCSS

创建一个新的 CSSStyleSheet 。

createCustomCursor(Image, Point, String) - Method in class java.awt. Toolkit

创建一个新的自定义光标对象。

createDashedBorder(Paint) - Static method in class javax.swing. BorderFactory

创建指定的 paint的虚线边框。

createDashedBorder(Paint, float, float) - Static method in class javax.swing. BorderFactory

创建指定的 paint ，相对 length和相对 spacing的虚线边框。

createDashedBorder(Paint, float, float, float, boolean) - Static method in class javax.swing. BorderFactory

创建指定的 paint ， thickness ，相对 length和相对 spacing的虚线边框。

createDataBuffer() - Method in class java.awt.image. BandedSampleModel

创建对应于此BandedSampleModel的DataBuffer，DataBuffer的数据类型，数量和大小将与此BandedSampleModel一致。

createDataBuffer() - Method in class java.awt.image. ComponentSampleModel

创建一个 DataBuffer对应于这个 ComponentSampleModel 。

createDataBuffer() - Method in class java.awt.image. MultiPixelPackedSampleModel

创建一个 DataBuffer对应于这个 MultiPixelPackedSampleModel 。

createDataBuffer() - Method in class java.awt.image. SampleModel

创建与此SampleModel对应的DataBuffer。

createDataBuffer() - Method in class java.awt.image. SinglePixelPackedSampleModel

创建与此SinglePixelPackedSampleModel对应的DataBuffer。

createDataContentHandler(String) - Method in class javax.activation. CommandMap

找到与MIME类型相对应的DataContentHandler。

createDataContentHandler(String) - Method in interface javax.activation. DataContentHandlerFactory

为MIME类型创建一个新的DataContentHandler对象。

createDataContentHandler(String) - Method in class javax.activation. MailcapCommandMap

返回指定MIME类型的DataContentHandler。

createDataContentHandler(String, DataSource) - Method in class javax.activation. CommandMap

找到与MIME类型相对应的DataContentHandler。

createDatagramSocketImpl() - Method in interface java.net. DatagramSocketImplFactory

创建一个新的 DatagramSocketImpl实例。

createDateTime(LocalDateTime, ZoneOffset, ZoneOffset) - Method in enum java.time.zone. ZoneOffsetTransitionRule.TimeDefinition

将指定的本地日期时间转换为挂钟上实际看到的本地日期时间。

createdCellEditor - Variable in class javax.swing.plaf.basic. BasicTreeUI

如果当前在树中的编辑器是由此实例创建的，则设置为true。

createDecreaseButton(int) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

创建减少按钮。

createDecreaseButton(int) - Method in class javax.swing.plaf.metal. MetalScrollBarUI

返回表示减少视图的视图。

createDecreaseButton(int) - Method in class javax.swing.plaf.synth. SynthScrollBarUI

创建减少按钮。

createDefaultCellEditor() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建默认单元格编辑器。

createDefaultCellEditor() - Method in class javax.swing.plaf.synth. SynthTreeUI

创建默认单元格编辑器。

createDefaultCellRenderer() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回用于执行每个节点冲压的默认单元格渲染器。

createDefaultCellRenderer() - Method in class javax.swing.plaf.synth. SynthTreeUI

返回用于执行每个节点冲压的默认单元格渲染器。

createDefaultChoosers() - Method in class javax.swing.plaf.basic. BasicColorChooserUI

返回一组默认颜色选择器。

createDefaultChoosers() - Method in class javax.swing.plaf.synth. SynthColorChooserUI

返回一组默认颜色选择器。

createDefaultColumnModel() - Method in class javax.swing. JTable

返回默认列模型对象，它是一个 DefaultTableColumnModel 。

createDefaultColumnModel() - Method in class javax.swing.table. JTableHeader

返回默认列模型对象，它是一个 DefaultTableColumnModel 。

createDefaultColumnsFromModel() - Method in class javax.swing. JTable

使用 TableModel界面中定义的 getColumnCount方法从数据模型创建表的默认列。

createDefaultDataModel() - Method in class javax.swing. JTable

返回默认表模型对象，它是一个 DefaultTableModel 。

createDefaultDivider() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

创建默认分隔符。

createDefaultDivider() - Method in class javax.swing.plaf.metal. MetalSplitPaneUI

创建默认分隔符。

createDefaultDivider() - Method in class javax.swing.plaf.synth. SynthSplitPaneUI

创建默认分隔符。

createDefaultDocument() - Method in class javax.swing.text. DefaultEditorKit

创建适用于此类型编辑器的未初始化文本存储模型（PlainDocument）。

createDefaultDocument() - Method in class javax.swing.text. EditorKit

创建适用于此类型编辑器的未初始化文本存储模型。

createDefaultDocument() - Method in class javax.swing.text.html. HTMLEditorKit

创建适用于此类型编辑器的未初始化文本存储模型。

createDefaultDocument() - Method in class javax.swing.text. StyledEditorKit

创建适用于此类型编辑器的未初始化文本存储模型。

createDefaultDragGestureRecognizer(Component, int, DragGestureListener) - Method in class java.awt.dnd. DragSource

创建一个新的 DragGestureRecognizer实现的默认抽象子类 DragGestureRecognizer这个 DragSource ，并设置指定 Component和 DragGestureListener新创建的对象上。

createDefaultEditorKit() - Method in class javax.swing. JEditorPane

创建组件首次创建时的默认编辑器工具包（ PlainEditorKit ）。

createDefaultEditorKit() - Method in class javax.swing. JTextPane

创建默认使用的 EditorKit 。

createDefaultEditors() - Method in class javax.swing. JTable

为对象，数字和布尔值创建默认单元格编辑器。

createDefaultHeaderRenderer() - Method in class javax.swing.table. TableColumn

从Java 2平台v1.3开始，这种方法不是由 TableColumn构造函数调用的。

createDefaultKeySelectionManager() - Method in class javax.swing. JComboBox

返回默认密钥选择管理器的一个实例。

createDefaultModel() - Method in class javax.swing. JTextArea

如果没有明确给出，则创建要在构建中使用的模型的默认实现。

createDefaultModel() - Method in class javax.swing. JTextField

如果没有明确给出，则创建要在构建中使用的模型的默认实现。

createDefaultNonContinuousLayoutDivider() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回默认的非连续布局分隔符，这是一个 Canvas的实例，用灰色填充背景。

createDefaultNonContinuousLayoutDivider() - Method in class javax.swing.plaf.synth. SynthSplitPaneUI

返回默认的非连续布局分隔符，这是一个 Canvas的实例，用灰色填充背景。

createDefaultRenderer() - Method in class javax.swing.table. JTableHeader

返回在 TableColumn未定义标题渲染器时使用的默认渲染器。

createDefaultRenderers() - Method in class javax.swing. JTable

为对象，数字，双精度，日期，布尔值和图标创建默认单元格渲染器。

createDefaultRendering() - Method in interface java.awt.image.renderable. RenderableImage

返回此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。

createDefaultRendering() - Method in class java.awt.image.renderable. RenderableImageOp

获取此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。

createDefaultRoot() - Method in class javax.swing.text. DefaultStyledDocument

创建用于表示默认文档结构的根元素。

createDefaultRoot() - Method in class javax.swing.text.html. HTMLDocument

创建用于表示默认文档结构的根元素。

createDefaultRoot() - Method in class javax.swing.text. PlainDocument

创建用于表示默认文档结构的根元素。

createDefaultSelectionModel() - Method in class javax.swing. JTable

返回默认选择模型对象，它是一个 DefaultListSelectionModel 。

createDefaultSkin() - Method in class javafx.scene.control. Accordion

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Button

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ButtonBar

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. CheckBox

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ChoiceBox

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ColorPicker

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ComboBox

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ContextMenu

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Control

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. DateCell

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. DatePicker

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Hyperlink

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Label

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ListCell

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ListView

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. MenuBar

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. MenuButton

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Pagination

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. PopupControl

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ProgressBar

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ProgressIndicator

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. RadioButton

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ScrollBar

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ScrollPane

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Separator

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Slider

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Spinner

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. SplitMenuButton

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. SplitPane

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TableCell

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TableRow

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TableView

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TabPane

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TextArea

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TextField

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TitledPane

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ToggleButton

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. ToolBar

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. Tooltip

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TreeCell

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TreeTableCell

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TreeTableRow

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TreeTableView

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.control. TreeView

为此控件创建一个新的默认皮肤实例。

createDefaultSkin() - Method in class javafx.scene.web. HTMLEditor

createDefaultTableHeader() - Method in class javax.swing. JTable

返回默认的表头对象，它是一个 JTableHeader 。

createDefaultTheme() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

确保目前的 MetalTheme是 non-null 。

createDesktopManager() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建桌面管理器。

createDetail() - Method in class javax.xml.soap. SOAPFactory

创建一个新的 Detail对象，作为 DetailEntry对象的容器。

createDetailsButton() - Method in class javafx.scene.control. DialogPane

子类可以覆盖此方法来创建自定义详细信息按钮。

createDetailsView(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

构造细节视图。

createDialog(Component) - Method in class javax.swing. JFileChooser

创建并返回一个新的 JDialog包装 this居中于 parent在 parent的帧。

createDialog(Component, String) - Method in class javax.swing. JOptionPane

创建并返回一个新的 JDialog包装 this居中于 parentComponent在 parentComponent的帧。

createDialog(Component, String, boolean, JColorChooser, ActionListener, ActionListener) - Static method in class javax.swing. JColorChooser

创建并返回包含指定的 ColorChooser窗格的新对话框以及“确定”，“取消”和“重置”按钮。

createDialog(String) - Method in class javax.swing. JOptionPane

创建并返回具有指定标题的新的无父母 JDialog 。

createDirectories(Path, FileAttribute<?>...) - Static method in class java.nio.file. Files

首先创建所有不存在的父目录来创建目录。

createDirectory(Path, FileAttribute<?>...) - Static method in class java.nio.file. Files

创建一个新的目录。

createDirectory(Path, FileAttribute<?>...) - Method in class java.nio.file.spi. FileSystemProvider

创建一个新的目录。

createDirectoryComboBoxModel(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

构造的新实例 DataModel为 DirectoryComboBox 。

createDisabledImage(Image) - Static method in class javax.swing. GrayFilter

创建禁用的图像

createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws. Service

创建一个 Dispatch实例，供客户选择的对象使用。

createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.spi. ServiceDelegate

创建一个 Dispatch实例，供用户选择的对象使用。

createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws. Service

创建一个 Dispatch实例，供客户选择的对象使用。

createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi. ServiceDelegate

创建一个 Dispatch实例，供用户选择的对象使用。

createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws. Service

创建一个用于JAXB生成的对象的 Dispatch实例。

createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.spi. ServiceDelegate

创建一个用于JAXB生成的对象的 Dispatch实例。

createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws. Service

创建一个用于JAXB生成的对象的 Dispatch实例。

createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi. ServiceDelegate

创建一个用于JAXB生成的对象的 Dispatch实例。

createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws. Service

创建一个 Dispatch实例，供客户选择的对象使用。

createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi. ServiceDelegate

创建一个 Dispatch实例，供用户选择的对象使用。

createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws. Service

创建一个用于JAXB生成的对象的 Dispatch实例。

createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi. ServiceDelegate

创建一个用于JAXB生成的对象的 Dispatch实例。

createDockingListener() - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回一个 MouseInputListener的实例。

createDockingListener() - Method in class javax.swing.plaf.metal. MetalToolBarUI

createDocument(String, String, DocumentType) - Method in interface org.w3c.dom. DOMImplementation

使用其文档元素创建指定类型的DOM文档对象。

createDocumentFragment() - Method in interface org.w3c.dom. Document

创建一个空的 DocumentFragment对象。

createDocumentType(String, String, String) - Method in interface org.w3c.dom. DOMImplementation

创建一个空的 DocumentType节点。

createDoubleBinding(Callable<Double>, Observable...) - Static method in class javafx.beans.binding. Bindings

助手功能创建自定义DoubleBinding 。

createDoubleClickListener(JFileChooser, JList<?>) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

创建一个双击监听器。

createDragGestureRecognizer(Class<T>, Component, int, DragGestureListener) - Method in class java.awt.dnd. DragSource

创建一个新的 DragGestureRecognizer ，实现指定的抽象子类 DragGestureRecognizer ，并在新创建的对象上设置指定的 Component和 DragGestureListener 。

createDragGestureRecognizer(Class<T>, DragSource, Component, int, DragGestureListener) - Method in class java.awt. Toolkit

创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。

createDragSourceContext(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Method in class java.awt.dnd. DragSource

创建 DragSourceContext以处理当前的拖动操作。

createDragWindow(JToolBar) - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回一个 DragWindow的实例。

createdRenderer - Variable in class javax.swing.plaf.basic. BasicTreeUI

如果当前在树中的渲染器是由此实例创建的，请设置为true。

createDropTargetAutoScroller(Component, Point) - Method in class java.awt.dnd. DropTarget

创建一个嵌入式自动推送器

createDropTargetContext() - Method in class java.awt.dnd. DropTarget

创建与此DropTarget关联的DropTargetContext。

createDTD(String) - Method in class javax.xml.stream. XMLEventFactory

创建文档类型定义事件此字符串包含与XML 1.0规范中的doctypedecl匹配的整个文档类型声明

createDTD(DTD, String) - Static method in class javax.swing.text.html.parser. ParserDelegator

使用指定的 name从归档格式重新创建DTD。

createDurationCssMetaData(String, Function<S, StyleableProperty<Duration>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。

createDurationCssMetaData(String, Function<S, StyleableProperty<Duration>>, Duration) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。

createDurationCssMetaData(String, Function<S, StyleableProperty<Duration>>, Duration, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Duration>并继承标志。

createEastPane(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建东面板。

createEditor() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建将在可编辑组合框中使用的默认编辑器。

createEditor() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

该方法由installUI调用以获取 JSpinner的编辑器组件。

createEditor() - Method in class javax.swing.plaf.metal. MetalComboBoxUI

createEditor() - Method in class javax.swing.plaf.synth. SynthComboBoxUI

创建将在可编辑组合框中使用的默认编辑器。

createEditor() - Method in class javax.swing.plaf.synth. SynthSpinnerUI

该方法由installUI调用以获取 JSpinner的编辑器组件。

createEditor(SpinnerModel) - Method in class javax.swing. JSpinner

该方法由构造函数调用来创建显示序列的当前值的 JComponent 。

createEditorComponent() - Method in class javax.swing.plaf.basic. BasicComboBoxEditor

创建内部编辑器组件。

createEditorKitForContentType(String) - Static method in class javax.swing. JEditorPane

从编辑器工具箱的默认注册表创建给定类型的处理程序。

createEffectCssMetaData(String, Function<S, StyleableProperty<E>>) - Method in class javafx.css. StyleablePropertyFactory

创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。

createEffectCssMetaData(String, Function<S, StyleableProperty<E>>, E) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。

createEffectCssMetaData(String, Function<S, StyleableProperty<E>>, E, boolean) - Method in class javafx.css. StyleablePropertyFactory

用初始值创建一个CssMetaData <S，Effect>并继承标志。

createElement(String) - Method in class javax.xml.soap. SOAPFactory

创建使用给定的本地名称初始化的 SOAPElement对象。

createElement(String) - Method in interface org.w3c.dom. Document

创建指定类型的元素。

createElement(String, String, String) - Method in class javax.xml.soap. SOAPFactory

使用给定的本地名称，前缀和uri创建一个新的 SOAPElement对象。

createElement(QName) - Method in class javax.xml.soap. SOAPFactory

创建使用给定的 SOAPElement对象初始化的 QName对象。

createElement(Name) - Method in class javax.xml.soap. SOAPFactory

创建 SOAPElement给定初始化的对象 Name对象。

createElement(Element) - Method in class javax.xml.soap. SOAPFactory

从现有的DOM Element创建一个 SOAPElement对象。

createElementNS(String, String) - Method in interface org.w3c.dom. Document

创建给定限定名称和命名空间URI的元素。

createEmptyBorder() - Static method in class javax.swing. BorderFactory

创建一个不占用空间的空白边框。

createEmptyBorder(int, int, int, int) - Static method in class javax.swing. BorderFactory

创建一个占用空间的空白边框，但没有绘制，指定顶部，左侧，底部和右侧的宽度。

createEmptyFrameIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回空框图标。

createEndDocument() - Method in class javax.xml.stream. XMLEventFactory

创建一个EndDocument事件的新实例

createEndElement(String, String, String) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的EndElement

createEndElement(String, String, String, Iterator<? extends Namespace>) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的EndElement

createEndElement(QName, Iterator<? extends Namespace>) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的EndElement

createEndpoint(String, Class<?>, Invoker, WebServiceFeature...) - Method in class javax.xml.ws.spi. Provider

使用提供的绑定，实现类，调用者和Web服务功能创建端点对象。

createEndpoint(String, Object) - Method in class javax.xml.ws.spi. Provider

使用提供的绑定和实现对象创建端点对象。

createEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi. Provider

使用提供的绑定，实现对象和Web服务功能创建端点对象。

createEntityReference(String) - Method in interface org.w3c.dom. Document

创建一个 EntityReference对象。

createEntityReference(String, EntityDeclaration) - Method in class javax.xml.stream. XMLEventFactory

创建EntityReference事件的新实例

createEnumCssMetaData(Class<? extends Enum>, String, Function<S, StyleableProperty<E>>) - Method in class javafx.css. StyleablePropertyFactory

创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。

createEnumCssMetaData(Class<? extends Enum>, String, Function<S, StyleableProperty<E>>, E) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。

createEnumCssMetaData(Class<? extends Enum>, String, Function<S, StyleableProperty<E>>, E, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，枚举>，并继承标志。

createEtchedBorder() - Static method in class javax.swing. BorderFactory

使用组件的当前背景颜色创建具有“蚀刻”外观的边框，以突出显示和着色。

createEtchedBorder(int) - Static method in class javax.swing. BorderFactory

使用组件的当前背景颜色创建具有“蚀刻”外观的边框，以突出显示和着色。

createEtchedBorder(int, Color, Color) - Static method in class javax.swing. BorderFactory

使用指定的高亮和阴影颜色创建一个“蚀刻”外观的边框。

createEtchedBorder(Color, Color) - Static method in class javax.swing. BorderFactory

使用指定的高亮和阴影颜色创建一个“蚀刻”外观的边框。

createEvent(String) - Method in interface org.w3c.dom.events. DocumentEvent

createExceptionReply() - Method in interface org.omg.CORBA.portable. ResponseHandler

在方法调用期间由servant调用。

createExceptionRequest(ReferenceType, boolean, boolean) - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用ExceptionRequest 。

createExpression(String, XPathNSResolver) - Method in interface org.w3c.dom.xpath. XPathEvaluator

使用解析的命名空间创建一个已解析的XPath表达式。

createExtendedResponse(String, byte[], int, int) - Method in interface javax.naming.ldap. ExtendedRequest

创建与此请求对应的响应对象。

createExtendedResponse(String, byte[], int, int) - Method in class javax.naming.ldap. StartTlsRequest

创建对应于LDAP StartTLS扩展请求的扩展响应对象。

createFault() - Method in class javax.xml.soap. SOAPFactory

创建一个新的默认值 SOAPFault对象

createFault(String, QName) - Method in class javax.xml.soap. SOAPFactory

创建一个新的 SOAPFault对象，初始化为给定的 reasonText和 faultCode

createFile(Path, FileAttribute<?>...) - Static method in class java.nio.file. Files

创建一个新的和空的文件，如果该文件已存在失败。

createFileObject(File, String) - Method in class javax.swing.filechooser. FileSystemView

返回从给定文件名在dir中构造的File对象。

createFileObject(String) - Method in class javax.swing.filechooser. FileSystemView

返回从给定的路径字符串构造的File对象。

createFileSystemRoot(File) - Method in class javax.swing.filechooser. FileSystemView

为 f创建一个新的 File对象，具有文件系统根目录的正确行为。

createFilter(String) - Static method in class java.io. ObjectInputFilter.Config

从一个模式字符串返回一个ObjectInputFilter。

createFilterComboBoxModel() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

构造一个 DataModel的类型 ComboBox 。

createFilterComboBoxRenderer() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

构造一个 Renderer的类型 ComboBox 。

createFilteredReader(XMLEventReader, EventFilter) - Method in class javax.xml.stream. XMLInputFactory

创建一个过滤的事件读取器，将过滤器包裹在事件读取器周围

createFilteredReader(XMLStreamReader, StreamFilter) - Method in class javax.xml.stream. XMLInputFactory

创建一个过滤的阅读器，将过滤器包裹在阅读器周围

createFilteredRowSet() - Method in interface javax.sql.rowset. RowSetFactory

创建一个新的FilteredRowSet实例。

createFloatBinding(Callable<Float>, Observable...) - Static method in class javafx.beans.binding. Bindings

助手功能创建自定义FloatBinding 。

createFloatingFrame(JToolBar) - Method in class javax.swing.plaf.basic. BasicToolBarUI

不再使用，使用BasicToolBarUI.createFloatingWindow（JToolBar）

createFloatingWindow(JToolBar) - Method in class javax.swing.plaf.basic. BasicToolBarUI

在从其容器中拖出工具栏后，创建一个包含工具栏的窗口

createFocusListener() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建一个 FocusListener ，它将被添加到组合框中。

createFocusListener() - Method in class javax.swing.plaf.basic. BasicListUI

返回一个 FocusListener的实例。

createFocusListener() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

为 JSplitPane UI创建一个 FocusListener 。

createFocusListener() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

创建焦点侦听器。

createFocusListener() - Method in class javax.swing.plaf.basic. BasicTableUI

在 JTable创建处理键盘导航的焦点侦听 JTable 。

createFocusListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建一个监听器，负责在焦点丢失/获取时更新显示。

createFocusListener(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

创建焦点侦听器。

createFont(int, File) - Static method in class java.awt. Font

使用指定的字体类型和指定的字体文件返回一个新的 Font 。

createFont(int, InputStream) - Static method in class java.awt. Font

使用指定的字体类型和输入数据返回一个新的 Font 。

createFontCssMetaData(String, Function<S, StyleableProperty<Font>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个CssMetaData <S，Font>，初始值为 Font.getDefault() ，并将标志默认为true。

createFontCssMetaData(String, Function<S, StyleableProperty<Font>>, Font) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。

createFontCssMetaData(String, Function<S, StyleableProperty<Font>>, Font, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的CssMetaData <S，Font>并继承标志。

createFonts(File) - Static method in class java.awt. Font

返回从指定文件解码的新数组 Font 。

createFonts(InputStream) - Static method in class java.awt. Font

返回从指定的流解码的新数组 Font 。

createFragment(int, int) - Method in class javax.swing.text. GlyphView

创建一个表示元素的一部分的视图。

createFragment(int, int) - Method in class javax.swing.text. View

创建一个表示元素的一部分的视图。

createFrameListener() - Method in class javax.swing.plaf.basic. BasicToolBarUI

构造一个新的实例 WindowListener 。

createFromBufferedImageType(int) - Static method in class javax.imageio. ImageTypeSpecifier

返回一个 ImageTypeSpecifier ，编码一个标准的 BufferedImage类型（ TYPE_CUSTOM ）。

createFromMetadata(IIOMetadata) - Static method in class javax.imageio.plugins.tiff. TIFFDirectory

从图像元数据对象的内容创建一个 TIFFDirectory实例。

createFromMetadataNode(TIFFTagSet, Node) - Static method in class javax.imageio.plugins.tiff. TIFFField

从TIFF本机图像元数据节点创建 TIFFField 。

createFromRenderedImage(RenderedImage) - Static method in class javax.imageio. ImageTypeSpecifier

返回一个 ImageTypeSpecifier ，编码 RenderedImage （可能是 BufferedImage ）的布局。

createGlassPane() - Method in class javax.swing. JLayer

由构造函数调用方法创建一个默认的 glassPane 。

createGlassPane() - Method in class javax.swing. JRootPane

由构造函数调用方法创建默认的 glassPane 。

createGlassPaneDispatcher() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建一个 GlassPaneDispatcher 。

createGlue() - Static method in class javax.swing. Box

创建一个不可见的“胶水”组件，可在Box中使用，其可见组件具有最大宽度（对于水平框）或高度（对于垂直框）。

createGlyphVector(FontRenderContext, char[]) - Method in class java.awt. Font

通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。

createGlyphVector(FontRenderContext, int[]) - Method in class java.awt. Font

通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。

createGlyphVector(FontRenderContext, String) - Method in class java.awt. Font

通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。

createGlyphVector(FontRenderContext, CharacterIterator) - Method in class java.awt. Font

通过在Font中基于Unicode cmap将指定的字符映射到字形，创建一个Font 。

createGraphics() - Method in class java.awt.image. BufferedImage

创建一个 Graphics2D ，可以用来绘制这个 BufferedImage 。

createGraphics() - Method in class java.awt.image. VolatileImage

创建一个 Graphics2D ，可以用来绘制这个 VolatileImage 。

createGraphics() - Method in class java.awt. SplashScreen

为启动屏幕叠加图像创建图形上下文（作为Graphics2D对象），允许您绘制闪屏。

createGraphics(BufferedImage) - Method in class java.awt. GraphicsEnvironment

返回一个Graphics2D对象，用于渲染到指定的BufferedImage 。

createGrayLineBorder() - Static method in class javax.swing.border. LineBorder

获得Color.gray LineBorder厚度为1的便捷方法。

createGrayscale(int, int, boolean) - Static method in class javax.imageio. ImageTypeSpecifier

返回一个灰度图像格式的说明符，该格式将将给定位深度的像素包装为指定数据类型的数组元素。

createGrayscale(int, int, boolean, boolean) - Static method in class javax.imageio. ImageTypeSpecifier

返回一个用于灰度加Alpha图像格式的说明符，它将给定位深度的像素包装为指定数据类型的数组元素。

createGroup(ActivationGroupID, ActivationGroupDesc, long) - Static method in class java.rmi.activation. ActivationGroup

创建并设置当前虚拟机的激活组。

createHandler(Object, ExceptionListener, ClassLoader) - Static method in class java.beans. XMLDecoder

为SAX解析器创建一个新的处理程序，可用于解析由 XMLEncoder类创建的嵌入式XML存档。

createHighlighter() - Method in class javax.swing.plaf.basic. BasicTextUI

创建用于添加高光的对象。

createHorizontalBox() - Static method in class javax.swing. Box

创建一个 Box显示其组件的 Box 。

createHorizontalGlue() - Static method in class javax.swing. Box

创建水平胶水组件。

createHorizontalScrollBar() - Method in class javax.swing. JScrollPane

默认情况下返回 JScrollPane.ScrollBar 。

createHorizontalStrut(int) - Static method in class javax.swing. Box

创建一个看不见的，固定宽度的组件。

createHSBChangeListener() - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

返回水平滚动条 ChangeListener的实例。

createHTMLDocument(String) - Method in interface org.w3c.dom.html. HTMLDOMImplementation

创建一个 HTMLDocument与由以下元素的最小树对象： HTML ， HEAD ， TITLE ，和 BODY 。

createHTMLView(JComponent, String) - Static method in class javax.swing.plaf.basic. BasicHTML

为给定的组件和html的字符串创建一个html渲染器。

createHttpServer(InetSocketAddress, int) - Method in class com.sun.net.httpserver.spi. HttpServerProvider

从此提供程序创建一个HttpServer

createHttpsServer(InetSocketAddress, int) - Method in class com.sun.net.httpserver.spi. HttpServerProvider

从此提供程序创建一个HttpsServer

createIgnorableSpace(String) - Method in class javax.xml.stream. XMLEventFactory

创建一个可忽略的空间

createImage(byte[]) - Method in class java.awt. Toolkit

创建解码存储在指定字节数组中的图像的图像。

createImage(byte[], int, int) - Method in class java.awt. Toolkit

创建一个图像，解码存储在指定字节数组中的图像，并以指定的偏移量和长度。

createImage(int, int) - Method in class java.awt. Component

创建一个用于双缓冲的屏幕外可绘图像。

createImage(ImageProducer) - Method in class java.awt. Component

从指定的图像制作者创建图像。

createImage(ImageProducer) - Method in class java.awt. Toolkit

使用指定的图像生成器创建图像。

createImage(String) - Method in class java.awt. Toolkit

返回从指定文件获取像素数据的图像。

createImage(URL) - Method in class java.awt. Toolkit

返回从指定的URL获取像素数据的图像。

createImageInputStream(Object) - Static method in class javax.imageio. ImageIO

返回一个 ImageInputStream ，它将从给定的 Object获取其输入。

createImageOutputStream(Object) - Static method in class javax.imageio. ImageIO

返回一个 ImageOutputStream ，将其输出发送给给定的 Object 。

createIncreaseButton(int) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

创建一个增加按钮。

createIncreaseButton(int) - Method in class javax.swing.plaf.metal. MetalScrollBarUI

返回表示增加视图的视图。

createIncreaseButton(int) - Method in class javax.swing.plaf.synth. SynthScrollBarUI

创建一个增加按钮。

createIndexed(byte[], byte[], byte[], byte[], int, int) - Static method in class javax.imageio. ImageTypeSpecifier

返回索引颜色图像格式的说明符，该格式将给定位深度的索引值包装为指定数据类型的数组元素。

createInitialContextFactory(Hashtable<?, ?>) - Method in interface javax.naming.spi. InitialContextFactoryBuilder

使用指定的环境创建一个初始上下文工厂。

createInputAttributes(Element, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLEditorKit

将 element的AttributeSet中的键/值复制到 set 。

createInputAttributes(Element, MutableAttributeSet) - Method in class javax.swing.text. StyledEditorKit

将 element的AttributeSet中的键/值复制到 set 。

createInputMethod() - Method in interface java.awt.im.spi. InputMethodDescriptor

创建相应输入法的新实例。

createInputMethodJFrame(String, boolean) - Method in interface java.awt.im.spi. InputMethodContext

创建一个顶级的Swing JFrame以供输入法使用。

createInputMethodWindow(String, boolean) - Method in interface java.awt.im.spi. InputMethodContext

创建一个顶级窗口，供输入法使用。

createInputStreamInstance(Object) - Method in class javax.imageio.spi. ImageInputStreamSpi

返回与此服务提供商关联的 ImageInputStream实现的实例。

createInputStreamInstance(Object, boolean, File) - Method in class javax.imageio.spi. ImageInputStreamSpi

返回与此服务提供商关联的 ImageInputStream实现的实例。

createInsetsCssMetaData(String, Function<S, StyleableProperty<Insets>>) - Method in class javafx.css. StyleablePropertyFactory

创建CssMetaData <S，Insets>，初始值为 Insets.EMPTY ，并将标志默认为false。

createInsetsCssMetaData(String, Function<S, StyleableProperty<Insets>>, Insets) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。

createInsetsCssMetaData(String, Function<S, StyleableProperty<Insets>>, Insets, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Insets>并继承标志。

createIntegerBinding(Callable<Integer>, Observable...) - Static method in class javafx.beans.binding. Bindings

助手功能创建一个自定义的IntegerBinding 。

createInterleaved(ColorSpace, int[], int, boolean, boolean) - Static method in class javax.imageio. ImageTypeSpecifier

返回一个交织图像格式的说明符，将使用 ComponentColorModel和 PixelInterleavedSampleModel将每个像素组件存储在单独的字节，短或int中。

createInterleavedRaster(int, int, int, int, int, int[], Point) - Static method in class java.awt.image. Raster

基于具有指定数据类型，宽度，高度，扫描线步长，像素步长和带偏移的PixelInterleavedSampleModel创建光栅。

createInterleavedRaster(int, int, int, int, Point) - Static method in class java.awt.image. Raster

基于具有指定数据类型，宽度，高度和频带数的PixelInterleavedSampleModel创建光栅。

createInterleavedRaster(DataBuffer, int, int, int, int, int[], Point) - Static method in class java.awt.image. Raster

基于具有指定DataBuffer，宽度，高度，扫描线步长，像素步幅和带偏移的PixelInterleavedSampleModel创建光栅。

createInternalFrame(Component, String) - Method in class javax.swing. JOptionPane

创建并返回一个 JInternalFrame的实例。

createInternalFrameListener() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建内部框架监听器。

createIntersection(Rectangle2D) - Method in class java.awt.geom. Rectangle2D

返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。

createIntersection(Rectangle2D) - Method in class java.awt.geom. Rectangle2D.Double

返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。

createIntersection(Rectangle2D) - Method in class java.awt.geom. Rectangle2D.Float

返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。

createIntersection(Rectangle2D) - Method in class java.awt. Rectangle

返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。

createInverse() - Method in class java.awt.geom. AffineTransform

返回表示逆变换的 AffineTransform对象。

createInverse() - Method in class javafx.scene.transform. Affine

createInverse() - Method in class javafx.scene.transform. Rotate

createInverse() - Method in class javafx.scene.transform. Scale

createInverse() - Method in class javafx.scene.transform. Shear

createInverse() - Method in class javafx.scene.transform. Transform

返回此变换的逆变换。

createInverse() - Method in class javafx.scene.transform. Translate

createItemListener() - Method in class javax.swing. AbstractButton

返回添加到模型中的 ItemListener 。

createItemListener() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建一个 ItemListener ，它将被添加到组合框中。

createItemListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建一个 ItemListener将被添加到组合框。

createJAXBIntrospector() - Method in class javax.xml.bind. JAXBContext

创建一个可用于内省JAXB对象的 JAXBIntrospector对象。

createJdbcRowSet() - Method in interface javax.sql.rowset. RowSetFactory

创建一个新的JdbcRowSet实例。

createJoinRowSet() - Method in interface javax.sql.rowset. RowSetFactory

创建一个JoinRowSet的新实例。

createKeyboardDownRightListener() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

已过时。
从Java 2平台v1.3开始。

createKeyboardEndListener() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

已过时。
从Java 2平台v1.3开始。

createKeyboardHomeListener() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

已过时。
从Java 2平台v1.3开始。

createKeyboardResizeToggleListener() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

已过时。
从Java 2平台v1.3开始。

createKeyboardUpLeftListener() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

已过时。
从Java 2平台v1.3开始。

createKeyListener() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建一个 KeyListener将被添加到组合框。

createKeyListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建将添加到组合框的关键侦听器。

createKeyListener() - Method in class javax.swing.plaf.basic. BasicTableUI

在 JTable创建处理键盘导航的按键侦听 JTable 。

createKeyListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建负责从树中获取关键事件的监听器。

createKeymap() - Method in class javax.swing.plaf.basic. BasicTextUI

创建要用于文本组件的键盘映射，并在其中安装任何必需的绑定。

createLargeAttributeSet(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

创建一个大的属性集，应该与时间交换空间。

createLargeAttributeSet(AttributeSet) - Method in class javax.swing.text. StyleContext

创建一个大的属性集，应该与时间交换空间。

createLayeredPane() - Method in class javax.swing. JRootPane

由构造函数调用方法创建默认的 layeredPane 。

createLayout() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

返回布局管理器。

createLayout() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

创建一个 LayoutManager管理的 editor ， nextButton ，并 previousButton的JSpinner的儿童。

createLayout() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane

createLayout() - Method in class javax.swing.plaf.synth. SynthSpinnerUI

创建一个 LayoutManager管理的 editor ， nextButton ，并 previousButton的JSpinner的儿童。

createLayout() - Method in class javax.swing.plaf.synth. SynthToolBarUI

创建一个 LayoutManager以使用工具栏。

createLayoutCache() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建负责管理扩展内容的对象以及节点的大小。

createLayoutManager() - Method in class javax.swing. JViewport

子类可以覆盖此构造器中的不同布局管理器（或 null ）。

createLayoutManager() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建一个布局管理器来管理构成组合框的组件。

createLayoutManager() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建布局管理器。

createLayoutManager() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回布局管理器。

createLayoutManager() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

调用 installUI创建一个布局管理器对象来管理 JTabbedPane 。

createLayoutManager() - Method in class javax.swing.plaf.metal. MetalComboBoxUI

createLayoutManager() - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

createLayoutManager() - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

调用 installUI创建一个布局管理器对象来管理 JTabbedPane 。

createLeafElement(Element, AttributeSet, int, int) - Method in class javax.swing.text. AbstractDocument

创建文档叶元素。

createLeafElement(Element, AttributeSet, int, int) - Method in class javax.swing.text.html. HTMLDocument

创建直接表示文本（没有任何子代）的文档叶元素。

createLeftOneTouchButton() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

创建并返回可用于折叠拆分窗格中左侧组件的 JButton实例。

createLineBidi(int, int) - Method in class java.text. Bidi

创建一个Bidi对象，该对象表示由当前Bidi表示的段落内的一行文本上的双目标信息。

createLineBorder(Color) - Static method in class javax.swing. BorderFactory

创建具有指定颜色的线边框。

createLineBorder(Color, int) - Static method in class javax.swing. BorderFactory

创建具有指定颜色和宽度的线边框。

createLineBorder(Color, int, boolean) - Static method in class javax.swing. BorderFactory

创建具有指定颜色，粗细和拐角形状的线条边框。

createLink(Path, Path) - Static method in class java.nio.file. Files

为现有文件创建新的链接（目录条目） （可选操作） 。

createLink(Path, Path) - Method in class java.nio.file.spi. FileSystemProvider

为现有文件创建一个新的链接（目录条目）。

createLinker() - Method in class jdk.dynalink. DynamicLinkerFactory

根据当前配置创建一个新的动态链接器。

createList() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建弹出窗口中使用的JList，以显示组合框模型中的项目。

createList(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

构造细节视图。

createListDataListener() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建一个列表数据监听器，它将被添加到 ComboBoxModel 。

createListDataListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建将添加到 ComboBoxModel的列表数据监听 ComboBoxModel 。

createListDataListener() - Method in class javax.swing.plaf.basic. BasicListUI

创建一个 ListDataListener的实例，根据需要添加到 JLists 。

createListMouseListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建一个鼠标监听器，在弹出的列表中监视鼠标事件。

createListMouseMotionListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建一个鼠标移动侦听器，在弹出的列表中监视鼠标移动事件。

createListSelectionListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建一个列表选择监听器，用于在弹出列表中监视选择更改。

createListSelectionListener() - Method in class javax.swing.plaf.basic. BasicListUI

创建一个 ListSelectionHandler的实例，通过selectionModel根据需要添加到 JLists 。

createListSelectionListener(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

创建列表选择侦听器。

createListSelectionListener(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

为文件和目录列表创建选择侦听器。

createLongBinding(Callable<Long>, Observable...) - Static method in class javafx.beans.binding. Bindings

助手功能创建自定义LongBinding 。

createLookAndFeel(String) - Static method in class javax.swing. UIManager

创建由给定的 L&F name名称指定的受支持的内置Java LookAndFeel 。

createLoweredBevelBorder() - Static method in class javax.swing. BorderFactory

使用降低的斜边创建边框，使用组件当前背景颜色的更亮的阴影突出显示，阴影阴影更暗。

createLoweredSoftBevelBorder() - Static method in class javax.swing. BorderFactory

创建一个具有下降边缘和软化角的斜边框，使用组件当前背景颜色的更亮的阴影突出显示，阴影阴影更暗。

createLSInput() - Method in interface org.w3c.dom.ls. DOMImplementationLS

创建一个新的空输入源对象，其中 LSInput.characterStream ， LSInput.byteStream ， LSInput.stringData LSInput.systemId ， LSInput.publicId ， LSInput.baseURI ，并 LSInput.encoding为空，且 LSInput.certifiedText是假的。

createLSOutput() - Method in interface org.w3c.dom.ls. DOMImplementationLS

创建一个新的空输出目标对象，其中 LSOutput.characterStream ， LSOutput.byteStream ， LSOutput.systemId ， LSOutput.encoding为空。

createLSParser(short, String) - Method in interface org.w3c.dom.ls. DOMImplementationLS

创建一个新的 LSParser 。

createLSSerializer() - Method in interface org.w3c.dom.ls. DOMImplementationLS

创建一个新的 LSSerializer对象。

createMarshaller() - Method in class javax.xml.bind. JAXBContext

创建可用于将java内容树转换为XML数据的 Marshaller对象。

createMatch() - Method in class javafx.css. CompoundSelector

createMatch() - Method in class javafx.css. Selector

createMatch() - Method in class javafx.css. SimpleSelector

createMatteBorder(int, int, int, int, Color) - Static method in class javax.swing. BorderFactory

使用纯色创建无光泽的边框。

createMatteBorder(int, int, int, int, Icon) - Static method in class javax.swing. BorderFactory

创建由指定图标的多个图块组成的无光泽边框。

createMBean(String, ObjectName) - Method in interface javax.management. MBeanServer

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName) - Method in interface javax.management. MBeanServerConnection

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management. MBeanServer

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management. MBeanServerConnection

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 。

createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

createMBean(String, ObjectName, ObjectName) - Method in interface javax.management. MBeanServer

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName, ObjectName) - Method in interface javax.management. MBeanServerConnection

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management. MBeanServer

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management. MBeanServerConnection

在MBean服务器中实例化并注册一个MBean。

createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 。

createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

createMBean(String, ObjectName, ObjectName, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 。

createMBean(String, ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

createMBean(String, ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

createMBean(String, ObjectName, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.createMBean(String, ObjectName) 。

createMBean(String, ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

createMBean(String, ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

createMBeanServer() - Static method in class javax.management. MBeanServerFactory

返回实现具有标准默认域名的MBeanServer接口的新对象。

createMBeanServer(String) - Static method in class javax.management. MBeanServerFactory

使用指定的默认域名返回实现MBeanServer接口的新对象。

createMenuDragMouseListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

返回一个 MenuDragMouseListener的实例。

createMenuDragMouseListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuUI

createMenuKeyListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

返回一个 MenuKeyListener的实例。

createMenuKeyListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuUI

createMenuListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuUI

返回一个 MenuListener的实例。

createMessage() - Method in class javax.xml.soap. MessageFactory

创建一个新 SOAPMessage用默认对象 SOAPPart ， SOAPEnvelope ， SOAPBody ，并 SOAPHeader对象。

createMessage(MimeHeaders, InputStream) - Method in class javax.xml.soap. MessageFactory

将给定的 InputStream对象的内容内化为一个新的 SOAPMessage对象，并返回 SOAPMessage对象。

createMessageArea() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

消息从 installComponents创建一个 Container包含消息的正文。

createMessageArea() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI

调用从 SynthOptionPaneUI.installComponents()创建一个包含消息正文的 Container 。

createMethodEntryRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用MethodEntryRequest 。

createMethodExitRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用MethodExitRequest 。

createMissingMemberHandler(LinkRequest, LinkerServices) - Method in interface jdk.dynalink.beans. MissingMemberHandlerFactory

返回适用于为特定链接请求实现丢失成员行为的方法句柄。

createModel() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

创建模型。

createModelListener() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

创建一个模型侦听器。

createModificationWatchpointRequest(Field) - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用的观察点，监视对指定字段的访问。

createMonitorContendedEnteredRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用MonitorContendedEnteredRequest 。

createMonitorContendedEnterRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用MonitorContendedEnterRequest 。

createMonitorWaitedRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用MonitorWaitedRequest 。

createMonitorWaitRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用MonitorWaitRequest 。

createMouseInputListener() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

返回一个新的实例 MouseInputListener 。

createMouseInputListener() - Method in class javax.swing.plaf.basic. BasicListUI

创建一个实现 MouseInputListener 。

createMouseInputListener() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

为 JTableHeader创建鼠标监听 JTableHeader 。

createMouseInputListener() - Method in class javax.swing.plaf.basic. BasicTableUI

为 JTable创建鼠标监听 JTable 。

createMouseInputListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

返回一个 MouseInputListener的实例。

createMouseInputListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuUI

createMouseListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建一个监听器，它将在组合框上观察鼠标按键和释放事件。

createMouseListener() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

创建一个鼠标监听器。

createMouseListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建负责更新基于鼠标事件的选择的监听器。

createMouseListener() - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

创建一个鼠标监听器。

createMouseMotionListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建将添加到组合框的鼠标移动侦听器。

createMouseWheelListener() - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

创建一个MouseWheelListener的实例，该实例由installUI（）添加到JScrollPane中。

createMultiDocPrintJob() - Method in interface javax.print. MultiDocPrintService

创建一个可以打印multiDoc的作业。

createMultiResolutionScreenCapture(Rectangle) - Method in class java.awt. Robot

创建包含从屏幕读取的像素的图像。

createName(byte[], Oid) - Method in class org.ietf.jgss. GSSManager

将包含名称的字节数组从指定的命名空间转换为GSSName对象的Factory方法。

createName(byte[], Oid, Oid) - Method in class org.ietf.jgss. GSSManager

将包含名称的字节数组从指定的命名空间转换为GSSName对象的Factory方法，并同时为机制进行规范化。

createName(String) - Method in interface javax.xml.soap. SOAPEnvelope

创建使用给定的本地名称初始化的新的 Name对象。

createName(String) - Method in class javax.xml.soap. SOAPFactory

创建使用给定的本地名称初始化的新的 Name对象。

createName(String, String, String) - Method in interface javax.xml.soap. SOAPEnvelope

创建使用给定的本地名称，命名空间前缀和命名空间URI初始化的新的 Name对象。

createName(String, String, String) - Method in class javax.xml.soap. SOAPFactory

创建使用给定的本地名称，命名空间前缀和命名空间URI初始化的新的 Name对象。

createName(String, Oid) - Method in class org.ietf.jgss. GSSManager

将字符串名称从指定的命名空间转换为GSSName对象的Factory方法。

createName(String, Oid, Oid) - Method in class org.ietf.jgss. GSSManager

将字符串名称从指定的命名空间转换为GSSName对象并将其同时用于机制进行规范化的Factory方法。

createNamespace(String) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的默认命名空间

createNamespace(String, String) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的命名空间

createNClob() - Method in interface java.sql. Connection

构造一个实现 NClob接口的对象。

createNewFile() - Method in class java.io. File

当且仅当具有该名称的文件尚不存在时，原子地创建一个由该抽象路径名命名的新的空文件。

createNewFolder(File) - Method in class javax.swing.filechooser. FileSystemView

创建一个具有默认文件夹名称的新文件夹。

createNextButton() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

创建一个增量按钮，即用 spinner.getNextValue返回的对象替换微调 spinner.getNextValue值的 spinner.getNextValue 。

createNextButton() - Method in class javax.swing.plaf.synth. SynthSpinnerUI

创建增量按钮，即用 spinner.getNextValue返回的对象替换微调 spinner.getNextValue值的 spinner.getNextValue 。

createNodeDimensions() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建能够确定树中给定节点的大小的 NodeDimensions的实例。

createNodeIterator(Node, int, NodeFilter, boolean) - Method in interface org.w3c.dom.traversal. DocumentTraversal

在指定节点上生成的子 NodeIterator创建一个新的 NodeIterator 。

createNonRolloverBorder() - Method in class javax.swing.plaf.basic. BasicToolBarUI

创建工具栏组件的非滚动边框。

createNonRolloverBorder() - Method in class javax.swing.plaf.metal. MetalToolBarUI

createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建北面的窗格。

createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.metal. MetalInternalFrameUI

createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.synth. SynthInternalFrameUI

创建北面的窗格。

createNSResolver(Node) - Method in interface org.w3c.dom.xpath. XPathEvaluator

适应任何DOM节点来解析命名空间，以便相对于文档中出现的节点的上下文，可以轻松地评估XPath表达式。

createObjectBinding(Callable<T>, Observable...) - Static method in class javafx.beans.binding. Bindings

助手功能创建自定义ObjectBinding 。

createObjectFactory(Object, Hashtable<?, ?>) - Method in interface javax.naming.spi. ObjectFactoryBuilder

使用提供的环境创建一个新的对象工厂。

createOutgoing(Association, SocketAddress, int) - Static method in class com.sun.nio.sctp. MessageInfo

创建一个 MessageInfo实例，适用于向给定关联发送消息时使用。

createOutgoing(SocketAddress, int) - Static method in class com.sun.nio.sctp. MessageInfo

创建一个适合在发送消息时使用的 MessageInfo实例。

createOutput(String, String) - Method in class javax.xml.bind. SchemaOutputResolver

决定将写入模式文件（给定的命名空间URI）的位置，并将其作为Result对象返回。

createOutputStreamInstance(Object) - Method in class javax.imageio.spi. ImageOutputStreamSpi

返回与该服务提供商相关联的 ImageOutputStream实现的实例。

createOutputStreamInstance(Object, boolean, File) - Method in class javax.imageio.spi. ImageOutputStreamSpi

返回与此服务提供商相关联的 ImageOutputStream实现的实例。

createPacked(ColorSpace, int, int, int, int, int, boolean) - Static method in class javax.imageio. ImageTypeSpecifier

返回一个打包图像格式的说明符，它将使用 DirectColorModel和一个打包的 SampleModel来存储单个字节，短或整数的每个像素。

createPackedRaster(int, int, int, int[], Point) - Static method in class java.awt.image. Raster

基于具有指定数据类型，宽度，高度和带屏蔽的SinglePixelPackedSampleModel创建光栅。

createPackedRaster(int, int, int, int, int, Point) - Static method in class java.awt.image. Raster

根据指定的数据类型，宽度，高度，频带数和每个频段的位数，打包SampleModel创建光栅。

createPackedRaster(DataBuffer, int, int, int, int[], Point) - Static method in class java.awt.image. Raster

基于具有指定DataBuffer，宽度，高度，扫描线步长和带屏蔽的SinglePixelPackedSampleModel创建光栅。

createPackedRaster(DataBuffer, int, int, int, Point) - Static method in class java.awt.image. Raster

基于具有指定DataBuffer，宽度，高度和每像素位数的MultiPixelPackedSampleModel创建光栅。

createPageLayout(Paper, PageOrientation, double, double, double, double) - Method in class javafx.print. Printer

使用指定的参数获取此打印机的新PageLayout。

createPageLayout(Paper, PageOrientation, Printer.MarginType) - Method in class javafx.print. Printer

使用指定的参数获取此打印机的新PageLayout实例。

createPaintCssMetaData(String, Function<S, StyleableProperty<Paint>>) - Method in class javafx.css. StyleablePropertyFactory

使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。

createPaintCssMetaData(String, Function<S, StyleableProperty<Paint>>, Paint) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。

createPaintCssMetaData(String, Function<S, StyleableProperty<Paint>>, Paint, boolean) - Method in class javafx.css. StyleablePropertyFactory

用初始值创建一个CssMetaData <S，Paint>并继承标志。

createParallelGroup() - Method in class javax.swing. GroupLayout

创建并返回 ParallelGroup ，对齐方式为 Alignment.LEADING 。

createParallelGroup(GroupLayout.Alignment) - Method in class javax.swing. GroupLayout

创建并返回具有指定对齐的 ParallelGroup 。

createParallelGroup(GroupLayout.Alignment, boolean) - Method in class javax.swing. GroupLayout

创建并返回具有指定对齐和调整大小行为的 ParallelGroup 。

createPooledConnectionBuilder() - Method in interface javax.sql. ConnectionPoolDataSource

创建一个新的 PooledConnectionBuilder实例

createPopup() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建组合框的弹出窗口部分。

createPopup() - Method in class javax.swing.plaf.metal. MetalComboBoxUI

createPopup() - Method in class javax.swing.plaf.synth. SynthComboBoxUI

创建组合框的弹出窗口部分。

createPopupHandlerProperty() - Method in class javafx.scene.web. WebEngine

JavaScript弹出窗口处理程序属性。

createPosition(int) - Method in interface javax.swing.text. AbstractDocument.Content

在内容中创建一个位置，该内容将随内容突变而跟踪更改。

createPosition(int) - Method in class javax.swing.text. AbstractDocument

返回在文档更改时跟踪更改的位置。

createPosition(int) - Method in interface javax.swing.text. Document

该方法允许应用程序在字符内容序列中标记一个地方。

createPosition(int) - Method in class javax.swing.text. GapContent

在内容中创建一个位置，该内容将随内容突变而跟踪更改。

createPosition(int) - Method in class javax.swing.text. StringContent

在内容中创建一个位置，该内容将随内容突变而跟踪更改。

createPreviousButton() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

创建一个减量按钮，即用 spinner.getPreviousValue返回的对象替换微调 spinner.getPreviousValue值的 spinner.getPreviousValue 。

createPreviousButton() - Method in class javax.swing.plaf.synth. SynthSpinnerUI

创建一个减量按钮，即用 spinner.getPreviousValue返回的对象替换微调值的 spinner.getPreviousValue 。

createPrinterJob() - Static method in class javafx.print. PrinterJob

创建工作的工厂方法。

createPrinterJob(Printer) - Static method in class javafx.print. PrinterJob

为指定的打印机创建作业的工厂方法。

createPrintJob() - Method in interface javax.print. PrintService

创建并返回一个能够处理任何受支持文档风格的数据的PrintJob。

createProcessingInstruction(String, String) - Method in class javax.xml.stream. XMLEventFactory

创建处理指令

createProcessingInstruction(String, String) - Method in interface org.w3c.dom. Document

创建给定指定名称和数据字符串的 ProcessingInstruction节点。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicColorChooserUI

返回一个 PropertyChangeListener的实例。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建一个 PropertyChangeListener ，它将被添加到组合框中。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建一个 PropertyChangeListener ，它将被添加到组合框中。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

返回 PropertyChangeListener安装在 JDesktopPane 。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

返回一个 PropertyChangeListener的实例。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建属性更改侦听器。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicListUI

创建的实例 PropertyChangeHandler了加在 JList由 installUI() 。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回一个 PropertyChangeListener的实例。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

创建属性更改侦听器。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

创建一个 PropertyChangeListener的实例，被添加到 JScrollPane由 installUI() 。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

创建一个可以添加到JSpinner本身的 PropertyChangeListener 。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

创建 PropertyChangeListener为 JSplitPane UI。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

创建属性更改侦听器。

createPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建一个监听器，负责根据树的更改更新UI。

createPropertyChangeListener() - Method in class javax.swing.plaf.metal. MetalComboBoxUI

createPropertyChangeListener() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane

createPropertyChangeListener() - Method in class javax.swing.plaf.metal. MetalScrollBarUI

createPropertyChangeListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

创建一个 PropertyChangeListener ，将添加到菜单项。

createPropertyChangeListener(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuUI

createPropertyChangeListener(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

创建属性更改侦听器。

createPropertyChangeListener(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

createPropertyChangeListener(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

创建属性更改侦听器。

createPropertyChangeListener(JSlider) - Method in class javax.swing.plaf.metal. MetalSliderUI

构造 MetalPropertyListener 。

createPropertyEditor(Object) - Method in class java.beans. PropertyDescriptor

使用当前的属性编辑器类构造一个属性编辑器的实例。

createPropertyListener() - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回一个 PropertyChangeListener的实例。

createQName(String, String) - Method in interface javax.xml.soap. SOAPElement

在这个 SOAPElement的上下文中创建一个 QName其名称空间URI是与参数 prefix相关联的URI。

createRaisedBevelBorder() - Static method in class javax.swing. BorderFactory

使用凸起的斜边创建边框，使用组件当前背景颜色的较亮的阴影突出显示，阴影阴影更暗。

createRaisedSoftBevelBorder() - Static method in class javax.swing. BorderFactory

使用凸起的边缘和软化的角落创建斜面边框，使用组件当前背景颜色的更亮的阴影突出显示，阴影阴影更暗。

createRange() - Method in interface org.w3c.dom.ranges. DocumentRange

该接口可以从实现 Document接口的对象获得，使用绑定特定的浇注方法。

createRaster(SampleModel, DataBuffer, Point) - Static method in class java.awt.image. Raster

使用指定的SampleModel和DataBuffer创建光栅。

createReaderInstance() - Method in class javax.imageio.spi. ImageReaderSpi

返回与此服务提供商关联的 ImageReader实现的实例。

createReaderInstance(Object) - Method in class javax.imageio.spi. ImageReaderSpi

返回与此服务提供商相关联的 ImageReader实现的实例。

createRegistry(int) - Static method in class java.rmi.registry. LocateRegistry

在本地主机上创建并导出 Registry实例，该实例接受指定的 port请求。

createRegistry(int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.registry. LocateRegistry

在本地主机上创建并导出 Registry实例，该实例使用自定义套接字工厂进行与该实例的通信。

createRelation(String, String, RoleList) - Method in class javax.management.relation. RelationService

创建给定关系类型的简单关系（由RelationSupport对象表示），并将其添加到关系服务中。

createRelation(String, String, RoleList) - Method in interface javax.management.relation. RelationServiceMBean

创建给定关系类型的简单关系（由RelationSupport对象表示），并将其添加到关系服务中。

createRelationType(String, RoleInfo[]) - Method in class javax.management.relation. RelationService

使用给定的角色信息（由RoleInfo对象提供）创建关系类型（RelationTypeSupport对象），并将其添加到关系服务中。

createRelationType(String, RoleInfo[]) - Method in interface javax.management.relation. RelationServiceMBean

使用给定的角色信息（由RoleInfo对象提供）创建关系类型（RelationTypeSupport对象），并将其添加到关系服务中。

createRenderer() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建将在不可编辑的组合框中使用的默认渲染器。

createRenderer() - Method in class javax.swing.plaf.synth. SynthComboBoxUI

创建将在不可编辑的组合框中使用的默认渲染器。

createRendering(RenderContext) - Method in interface java.awt.image.renderable. RenderableImage

创建一个RenderedImage，表示使用给定的RenderContext渲染此图像。

createRendering(RenderContext) - Method in class java.awt.image.renderable. RenderableImageOp

创建一个RenderedImage，它表示根据给定的RenderContext呈现的RenderableImageOp（包括其Renderable源）。

createReply() - Method in interface org.omg.CORBA.portable. ResponseHandler

在方法调用期间由servant调用。

createResource(JavaFileManager.Location, CharSequence, CharSequence, Element...) - Method in interface javax.annotation.processing. Filer

创建一个新的辅助资源文件进行写入并返回一个文件对象。

createRightOneTouchButton() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

创建并返回可用于折叠拆分窗格中正确组件的 JButton实例。

createRigidArea(Dimension) - Static method in class javax.swing. Box

创建一个总是指定大小的不可见组件。

createRolloverBorder() - Method in class javax.swing.plaf.basic. BasicToolBarUI

为工具栏组件创建滚动边框。

createRolloverBorder() - Method in class javax.swing.plaf.metal. MetalToolBarUI

createRolloverListener() - Method in class javax.swing.plaf.metal. MetalToolBarUI

创建一个将添加到JToolBar的属性更改侦听器。

createRootHeader() - Method in class javafx.scene.control.skin. TableHeaderRow

创建一个新的NestedTableColumnHeader实例。

createRootLayout() - Method in class javax.swing. JRootPane

由构造函数调用方法创建默认的 layoutManager 。

createRootPane() - Method in class javax.swing. JApplet

已过时。

由构造函数调用方法创建默认的rootPane。

createRootPane() - Method in class javax.swing. JDialog

由构造函数调用方法创建默认的 rootPane 。

createRootPane() - Method in class javax.swing. JFrame

由构造函数调用方法创建默认的 rootPane 。

createRootPane() - Method in class javax.swing. JInternalFrame

由构造函数调用设置 JRootPane 。

createRootPane() - Method in class javax.swing. JWindow

由构造函数调用方法创建默认的 rootPane 。

createRow() - Method in class javax.swing.text. FlowView

创建一个应用于在一个流中保存一行值得孩子的视图。

createRow() - Method in class javax.swing.text. ParagraphView

创建一个 View ，应该用来持有一行的孩子流。

createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - Static method in class javax.security.sasl. Sasl

使用提供的参数创建一个 SaslClient 。

createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - Method in interface javax.security.sasl. SaslClientFactory

使用提供的参数创建SaslClient。

createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - Static method in class javax.security.sasl. Sasl

为指定的机制创建一个 SaslServer 。

createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - Method in interface javax.security.sasl. SaslServerFactory

使用提供的参数创建一个 SaslServer 。

createScaledRendering(int, int, RenderingHints) - Method in interface java.awt.image.renderable. RenderableImage

以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。

createScaledRendering(int, int, RenderingHints) - Method in class java.awt.image.renderable. RenderableImageOp

以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。

createScreenCapture(Rectangle) - Method in class java.awt. Robot

创建包含从屏幕读取的像素的图像。

createScrollBarSwapListener() - Method in class javax.swing.plaf.metal. MetalScrollPaneUI

为滚动条交换事件返回一个新的 PropertyChangeListener 。

createScrollButton(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

创建并返回一个JButton，它将向用户提供一种在特定方向滚动选项卡的方法。

createScrollButton(int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

创建并返回一个JButton，它将向用户提供一种在特定方向滚动选项卡的方法。

createScroller() - Method in class javax.swing.plaf.basic. BasicComboPopup

创建容纳可滚动列表的滚动窗格。

createScrollListener() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

创建一个滚动侦听器。

createScrollListener(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

创建一个滚动侦听器。

createScrollPaneForTable(JTable) - Static method in class javax.swing. JTable

已过时。
截至Swing 1.0.2版，由new JScrollPane(aTable)替代。

createSecondaryLoop() - Method in class java.awt. EventQueue

创建与此事件队列相关联的新的 secondary loop 。

createSelectionModel() - Method in class javax.swing. JList

返回一个DefaultListSelectionModel的实例; 在建设期间呼吁初始化列表的选择模型属性。

createSelectionModel() - Method in class javax.swing.table. DefaultTableColumnModel

创建一个新的默认列表选择模型。

createSelectionModelPropertyChangeListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建负责从选择模型获取属性更改事件的监听器。

createSelector(String) - Static method in class javafx.css. Selector

createSeparator() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回一个分隔符。

createSeparator() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI

返回一个分隔符。

createSequentialGroup() - Method in class javax.swing. GroupLayout

创建并返回一个 SequentialGroup 。

createServerSocket() - Method in class javax.net. ServerSocketFactory

返回未绑定的服务器套接字。

createServerSocket(int) - Method in interface java.rmi.server. RMIServerSocketFactory

在指定端口上创建服务器套接字（端口0表示匿名端口）。

createServerSocket(int) - Method in class java.rmi.server. RMISocketFactory

在指定端口上创建服务器套接字（端口0表示匿名端口）。

createServerSocket(int) - Method in class javax.net. ServerSocketFactory

返回绑定到指定端口的服务器套接字。

createServerSocket(int) - Method in class javax.rmi.ssl. SslRMIServerSocketFactory

创建一个服务器套接字，接受根据本工厂的SSL套接字配置参数配置的SSL连接。

createServerSocket(int, int) - Method in class javax.net. ServerSocketFactory

返回绑定到指定端口的服务器套接字，并使用指定的连接积压。

createServerSocket(int, int, InetAddress) - Method in class javax.net. ServerSocketFactory

返回绑定到指定端口的服务器套接字，具有指定的listen backlog和本地IP。

createServiceDelegate(URL, QName, Class<? extends Service>) - Method in class javax.xml.ws.spi. Provider

创建服务委托对象。

createServiceDelegate(URL, QName, Class<? extends Service>, WebServiceFeature...) - Method in class javax.xml.ws.spi. Provider

创建服务委托对象。

createShardingKeyBuilder() - Method in interface javax.sql. CommonDataSource

创建一个新的 ShardingKeyBuilder实例

createShared() - Method in interface javax.sql.rowset. CachedRowSet

返回一个新 RowSet由相同的数据与此的支持对象 CachedRowSet对象。

createSizeCssMetaData(String, Function<S, StyleableProperty<Number>>) - Method in class javafx.css. StyleablePropertyFactory

创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。

createSizeCssMetaData(String, Function<S, StyleableProperty<Number>>, Number) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。

createSizeCssMetaData(String, Function<S, StyleableProperty<Number>>, Number, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，Number>，并继承标志。

createSmallAttributeSet(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

创建可以共享的一组紧凑的属性。

createSmallAttributeSet(AttributeSet) - Method in class javax.swing.text. StyleContext

创建可以共享的一组紧凑的属性。

createSNIMatcher(String) - Static method in class javax.net.ssl. SNIHostName

为SNIHostName创建一个SNIMatcher对象。

createSocket() - Method in class javax.net. SocketFactory

创建一个未连接的套接字。

createSocket(String, int) - Method in interface java.rmi.server. RMIClientSocketFactory

创建连接到指定主机和端口的客户端套接字。

createSocket(String, int) - Method in class java.rmi.server. RMISocketFactory

创建连接到指定主机和端口的客户端套接字。

createSocket(String, int) - Method in class javax.net. SocketFactory

创建套接字并将其连接到指定的远程端口上的指定远程主机。

createSocket(String, int) - Method in class javax.rmi.ssl. SslRMIClientSocketFactory

创建一个SSL套接字。

createSocket(String, int, InetAddress, int) - Method in class javax.net. SocketFactory

创建套接字并将其连接到指定远程端口上的指定远程主机。

createSocket(InetAddress, int) - Method in class javax.net. SocketFactory

创建套接字并将其连接到指定地址处的指定端口号。

createSocket(InetAddress, int, InetAddress, int) - Method in class javax.net. SocketFactory

创建套接字并将其连接到指定远程端口上指定的远程地址。

createSocket(Socket, InputStream, boolean) - Method in class javax.net.ssl. SSLSocketFactory

创建服务器模式Socket在现有连接的套接字上分层，并且能够读取已从Socket的底层InputStream中消耗/删除的数据 。

createSocket(Socket, String, int, boolean) - Method in class javax.net.ssl. SSLSocketFactory

返回在给定端口上分层连接到指定主机的现有套接字上的套接字。

createSocketImpl() - Method in interface java.net. SocketImplFactory

创建一个新的 SocketImpl实例。

createSoftBevelBorder(int) - Static method in class javax.swing. BorderFactory

创建具有软化角的指定类型的斜切边框，使用组件当前背景颜色的更亮的阴影突出显示，阴影阴影更暗。

createSoftBevelBorder(int, Color, Color) - Static method in class javax.swing. BorderFactory

使用指定的高亮和阴影创建具有软化角的指定类型的斜切边框。

createSoftBevelBorder(int, Color, Color, Color, Color) - Static method in class javax.swing. BorderFactory

创建具有软化角的指定类型的斜切边框，使用指定的颜色用于突出显示的内边缘和外边缘以及阴影区域。

createSourceFile(CharSequence, Element...) - Method in interface javax.annotation.processing. Filer

创建一个新的源文件并返回一个对象以允许写入它。

createSouthPane(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建北面的窗格。

createSpace(String) - Method in class javax.xml.stream. XMLEventFactory

创建一个字符事件，将isSpace标志设置为true

createSQLXML() - Method in interface java.sql. Connection

构造实现 SQLXML接口的对象。

createSSLEngine() - Method in class javax.net.ssl. SSLContext

使用此上下文创建一个新的 SSLEngine 。

createSSLEngine(String, int) - Method in class javax.net.ssl. SSLContext

使用咨询对等体信息使用此上下文创建一个新的 SSLEngine 。

createStandardLabels(int) - Method in class javax.swing. JSlider

创建一个 Hashtable的数字文本标签，从最小滑块开始，并使用指定的增量。

createStandardLabels(int, int) - Method in class javax.swing. JSlider

创建一个 Hashtable的数字文本标签，从指定的起始点开始，并使用指定的增量。

createStartDocument() - Method in class javax.xml.stream. XMLEventFactory

创建一个StartDocument事件的新实例

createStartDocument(String) - Method in class javax.xml.stream. XMLEventFactory

创建一个StartDocument事件的新实例

createStartDocument(String, String) - Method in class javax.xml.stream. XMLEventFactory

创建一个StartDocument事件的新实例

createStartDocument(String, String, boolean) - Method in class javax.xml.stream. XMLEventFactory

创建一个StartDocument事件的新实例

createStartElement(String, String, String) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的StartElement。

createStartElement(String, String, String, Iterator<? extends Attribute>, Iterator<? extends Namespace>) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的StartElement。

createStartElement(String, String, String, Iterator<? extends Attribute>, Iterator<? extends Namespace>, NamespaceContext) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的StartElement。

createStartElement(QName, Iterator<? extends Attribute>, Iterator<? extends Namespace>) - Method in class javax.xml.stream. XMLEventFactory

创建一个新的StartElement。

createStatement() - Method in interface java.sql. Connection

创建一个 Statement对象，用于将SQL语句发送到数据库。

createStatement(int, int) - Method in interface java.sql. Connection

创建一个 Statement对象，它将生成具有给定类型和并发性的 ResultSet对象。

createStatement(int, int, int) - Method in interface java.sql. Connection

创建一个 Statement对象，该对象将生成具有给定类型，并发和可 ResultSet对象。

createStepRequest(ThreadReference, int, int) - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用StepRequest 。

createStringBinding(Callable<String>, Observable...) - Static method in class javafx.beans.binding. Bindings

助手功能创建自定义StringBinding 。

createStringCssMetaData(String, Function<S, StyleableProperty<String>>) - Method in class javafx.css. StyleablePropertyFactory

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

createStringCssMetaData(String, Function<S, StyleableProperty<String>>, String) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

createStringCssMetaData(String, Function<S, StyleableProperty<String>>, String, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，String>并继承标志。

createStrokeBorder(BasicStroke) - Static method in class javax.swing. BorderFactory

创建指定的边框 stroke 。

createStrokeBorder(BasicStroke, Paint) - Static method in class javax.swing. BorderFactory

创建指定的 stroke和 paint 。

createStrokedShape(Shape) - Method in class java.awt. BasicStroke

返回一个 Shape其内部定义了指定的 Shape轮廓。

createStrokedShape(Shape) - Method in interface java.awt. Stroke

返回一个轮廓 Shape ，其中包含根据由实现 Stroke接口的对象定义的规则来描绘 Shape时应绘制的区域。

createStruct(String, Object[]) - Method in interface java.sql. Connection

用于创建Struct对象的工厂方法。

createStyleableBooleanProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Boolean>。

createStyleableBooleanProperty(S, String, String, Function<S, StyleableProperty<Boolean>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Boolean>。

createStyleableBooleanProperty(S, String, String, Function<S, StyleableProperty<Boolean>>, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Boolean>。

createStyleableBooleanProperty(S, String, String, Function<S, StyleableProperty<Boolean>>, boolean, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Boolean>并继承标志。

createStyleableColorProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Color>。

createStyleableColorProperty(S, String, String, Function<S, StyleableProperty<Color>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Color>。

createStyleableColorProperty(S, String, String, Function<S, StyleableProperty<Color>>, Color) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Color>。

createStyleableColorProperty(S, String, String, Function<S, StyleableProperty<Color>>, Color, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Color>并继承标志。

createStyleableDurationProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用之前创建的给定的 cssProperty创建一个StyleableProperty <Duration>。

createStyleableDurationProperty(S, String, String, Function<S, StyleableProperty<Duration>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Duration>。

createStyleableDurationProperty(S, String, String, Function<S, StyleableProperty<Duration>>, Duration) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Duration>。

createStyleableDurationProperty(S, String, String, Function<S, StyleableProperty<Duration>>, Duration, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Duration>并继承标志。

createStyleableEffectProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Effect>。

createStyleableEffectProperty(S, String, String, Class<E>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <E使用以前创建的CssMetaData为给定的 cssProperty扩展枚举<E >>。

createStyleableEffectProperty(S, String, String, Function<S, StyleableProperty<E>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Effect>。

createStyleableEffectProperty(S, String, String, Function<S, StyleableProperty<E>>, E) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Effect>。

createStyleableEffectProperty(S, String, String, Function<S, StyleableProperty<E>>, E, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Effect>并继承标志。

createStyleableEnumProperty(S, String, String, Function<S, StyleableProperty<E>>, Class<E>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <E extends Enum <E >>。

createStyleableEnumProperty(S, String, String, Function<S, StyleableProperty<E>>, Class<E>, E) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <E使用初始值扩展Enum <E >>。

createStyleableEnumProperty(S, String, String, Function<S, StyleableProperty<E>>, Class<E>, E, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。

createStyleableFontProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Font>。

createStyleableFontProperty(S, String, String, Function<S, StyleableProperty<Font>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Font>。

createStyleableFontProperty(S, String, String, Function<S, StyleableProperty<Font>>, Font) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Font>。

createStyleableFontProperty(S, String, String, Function<S, StyleableProperty<Font>>, Font, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Font>并继承标志。

createStyleableInsetsProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Insets>使用以前创建的CssMetaData为给定的 cssProperty 。

createStyleableInsetsProperty(S, String, String, Function<S, StyleableProperty<Insets>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Inset>。

createStyleableInsetsProperty(S, String, String, Function<S, StyleableProperty<Insets>>, Insets) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Inset>。

createStyleableInsetsProperty(S, String, String, Function<S, StyleableProperty<Insets>>, Insets, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Inset>并继承标志。

createStyleableNumberProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用之前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Number>。

createStyleableNumberProperty(S, String, String, Function<S, StyleableProperty<Number>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Number>。

createStyleableNumberProperty(S, String, String, Function<S, StyleableProperty<Number>>, Number) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Number>。

createStyleableNumberProperty(S, String, String, Function<S, StyleableProperty<Number>>, Number, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Number>并继承标志。

createStyleablePaintProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Paint>。

createStyleablePaintProperty(S, String, String, Function<S, StyleableProperty<Paint>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <Paint>。

createStyleablePaintProperty(S, String, String, Function<S, StyleableProperty<Paint>>, Paint) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Paint>。

createStyleablePaintProperty(S, String, String, Function<S, StyleableProperty<Paint>>, Paint, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <Paint>并继承标志。

createStyleableStringProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。

createStyleableStringProperty(S, String, String, Function<S, StyleableProperty<String>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个StyleableProperty <String>。

createStyleableStringProperty(S, String, String, Function<S, StyleableProperty<String>>, String) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <String>。

createStyleableStringProperty(S, String, String, Function<S, StyleableProperty<String>>, String, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <String>并继承标志。

createStyleableUrlProperty(S, String, String) - Method in class javafx.css. StyleablePropertyFactory

使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。

createStyleableUrlProperty(S, String, String, Function<S, StyleableProperty<String>>) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <String>。

createStyleableUrlProperty(S, String, String, Function<S, StyleableProperty<String>>, String) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <String>。

createStyleableUrlProperty(S, String, String, Function<S, StyleableProperty<String>>, String, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建一个具有初始值的StyleableProperty <String>并继承标志。

createSubcontext(String) - Method in interface javax.naming. Context

创建并绑定新的上下文。

createSubcontext(String) - Method in class javax.naming. InitialContext

createSubcontext(String, Attributes) - Method in interface javax.naming.directory. DirContext

创建和绑定新的上下文以及关联的属性。

createSubcontext(String, Attributes) - Method in class javax.naming.directory. InitialDirContext

createSubcontext(Name) - Method in interface javax.naming. Context

创建并绑定新的上下文。

createSubcontext(Name) - Method in class javax.naming. InitialContext

createSubcontext(Name, Attributes) - Method in interface javax.naming.directory. DirContext

创建和绑定新的上下文以及关联的属性。

createSubcontext(Name, Attributes) - Method in class javax.naming.directory. InitialDirContext

createSubject(GSSName, GSSCredential) - Static method in class com.sun.security.jgss. GSSUtil

使用此方法将GSSName和GSSCredential转换为主题。

createSubsetSampleModel(int[]) - Method in class java.awt.image. BandedSampleModel

创建一个带有BandedSampleModel的带子集的新BandedSampleModel。

createSubsetSampleModel(int[]) - Method in class java.awt.image. ComponentSampleModel

使用此ComponentSampleModel的带子集创建新的ComponentSampleModel。

createSubsetSampleModel(int[]) - Method in class java.awt.image. MultiPixelPackedSampleModel

创建一个新的 MultiPixelPackedSampleModel与这个 MultiPixelPackedSampleModel的带的子集。

createSubsetSampleModel(int[]) - Method in class java.awt.image. PixelInterleavedSampleModel

创建一个新的PixelInterleavedSampleModel与PixelInterleavedSampleModel的带子集。

createSubsetSampleModel(int[]) - Method in class java.awt.image. SampleModel

使用此SampleModel的一个子带子创建一个新的SampleModel。

createSubsetSampleModel(int[]) - Method in class java.awt.image. SinglePixelPackedSampleModel

这将创建一个新的SinglePixelPackedSampleModel与该SinglePixelPackedSampleModel的频带的子集。

createSymbolicLink(Path, Path, FileAttribute<?>...) - Static method in class java.nio.file. Files

创建到目标的符号链接 （可选操作） 。

createSymbolicLink(Path, Path, FileAttribute<?>...) - Method in class java.nio.file.spi. FileSystemProvider

创建一个到目标的符号链接。

createSymbolsProperty() - Method in class javafx.scene.chart. AreaChart

当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。

createSymbolsProperty() - Method in class javafx.scene.chart. LineChart

当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。

createSymbolsProperty() - Method in class javafx.scene.chart. StackedAreaChart

当为true时，将为未指定符号节点的任何数据项创建CSS样式符号。

createSystemMenu() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

返回一个新的实例 JMenu 。

createSystemMenuBar() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

返回一个新的实例 JMenuBar 。

createTableCell(Element) - Method in class javax.swing.text. TableView

已过时。
表格单元现在可以是任意的View实现，应该由ViewFactory而不是表生成。

createTableColumnHeader(TableColumnBase) - Method in class javafx.scene.control.skin. NestedTableColumnHeader

为给定的TableColumnBase实例创建一个新的TableColumnHeader实例。

createTableHeaderRow() - Method in class javafx.scene.control.skin. TableViewSkinBase

创建一个新的TableHeaderRow实例。

createTableRow(Element) - Method in class javax.swing.text. TableView

创建一个新的表行。

createTask() - Method in class javafx.concurrent. Service

在JavaFX应用程序主题上启动服务后调用。

createTempDirectory(String, FileAttribute<?>...) - Static method in class java.nio.file. Files

在默认临时文件目录中创建一个新目录，使用给定的前缀生成其名称。

createTempDirectory(Path, String, FileAttribute<?>...) - Static method in class java.nio.file. Files

在指定的目录中创建一个新目录，使用给定的前缀生成其名称。

createTempFile(String, String) - Static method in class java.io. File

在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。

createTempFile(String, String, File) - Static method in class java.io. File

在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。

createTempFile(String, String, FileAttribute<?>...) - Static method in class java.nio.file. Files

在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。

createTempFile(Path, String, String, FileAttribute<?>...) - Static method in class java.nio.file. Files

在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。

createTextNode(String) - Method in interface org.w3c.dom. Document

创建给定指定字符串的 Text节点。

createTFoot() - Method in interface org.w3c.dom.html. HTMLTableElement

创建一个表页脚行或返回一个现有的页脚。

createTHead() - Method in interface org.w3c.dom.html. HTMLTableElement

创建一个表头行或返回一个现有的行。

createThreadDeathRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用ThreadDeathRequest 。

createThreadStartRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用ThreadStartRequest 。

createTitledBorder(String) - Static method in class javax.swing. BorderFactory

创建一个带有指定标题的新标题边框，默认边框类型（由当前外观确定），默认文本位置（由当前外观确定），默认对齐（前导）和默认字体，文字颜色（由目前的外观所决定）。

createTitledBorder(Border) - Static method in class javax.swing. BorderFactory

创建一个新的标题边框，一个空的标题，指定的边框对象，默认的文本位置（由当前的外观和感觉确定），默认对齐（前导）和默认的字体和文本颜色（由当前的外观和感觉）。

createTitledBorder(Border, String) - Static method in class javax.swing. BorderFactory

将标题添加到现有边框，默认定位（由当前外观确定），默认对齐（前导）和默认字体和文字颜色（由当前外观确定）。

createTitledBorder(Border, String, int, int) - Static method in class javax.swing. BorderFactory

将标题添加到现有边框中，并使用指定的定位，并使用默认的字体和文字颜色（由当前外观确定）。

createTitledBorder(Border, String, int, int, Font) - Static method in class javax.swing. BorderFactory

使用指定的定位和字体，使用默认文本颜色（由当前外观确定）将标题添加到现有边框。

createTitledBorder(Border, String, int, int, Font, Color) - Static method in class javax.swing. BorderFactory

使用指定的定位，字体和颜色将标题添加到现有边框。

createToolBarContListener() - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回一个 ContainerListener的实例。

createToolBarFocusListener() - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回一个 FocusListener的实例。

createToolTip() - Method in class javax.swing. JComponent

返回应用于显示工具提示的 JToolTip的实例。

createTrack() - Method in class javax.sound.midi. Sequence

创建一个新的，最初的空轨，作为这个序列的一部分。

createTrackListener() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

创建一个轨道监听器。

createTrackListener(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

创建一个轨道监听器。

createTrackListener(JSlider) - Method in class javax.swing.plaf.synth. SynthSliderUI

创建一个轨道监听器。

createTranscoderInstance() - Method in class javax.imageio.spi. ImageTranscoderSpi

返回与此服务提供商关联的 ImageTranscoder实现的实例。

createTransferable(JComponent) - Method in class javax.swing. TransferHandler

创建一个 Transferable作为数据传输的来源。

createTransferableProxy(Transferable, boolean) - Method in class java.awt.dnd. DropTargetContext

创建一个TransferableProxy代理指定的Transferable。

createTransformedArea(AffineTransform) - Method in class java.awt.geom. Area

创建一个新的 Area对象，该对象包含与指定的 AffineTransform转换的 Area相同的几何。

createTransformedShape(AffineTransform) - Method in class java.awt.geom. Path2D

返回一个新的 Shape代表这个 Path2D的转换版本。

createTransformedShape(Shape) - Method in class java.awt.geom. AffineTransform

返回一个新Shape由指定的几何定义的对象Shape已通过此变换之后。

createTransition(int) - Method in class java.time.zone. ZoneOffsetTransitionRule

创建指定年份的转换实例。

createTranslatedChild(int, int) - Method in class java.awt.image. Raster

创建一个具有相同大小的光栅，SampleModel和DataBuffer，但是具有不同的位置。

createTreeCellEditor() - Method in class javax.swing.tree. DefaultTreeCellEditor

如果构造函数中没有提供 TreeCellEditor则调用此方法。

createTreeExpansionListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

当节点扩展状态更改时，创建并返回负责更新treestate的对象。

createTreeModel(Object) - Static method in class javax.swing. JTree

返回一个包裹指定对象的 TreeModel 。

createTreeModelListener() - Method in class javax.swing. JTree

创建并返回一个 TreeModelHandler的实例。

createTreeModelListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回在模型更改时可以更新树的侦听器。

createTreeSelectionListener() - Method in class javax.swing.plaf.basic. BasicTreeUI

创建基于选择更改方法更新显示的侦听器。

createTreeWalker(Node, int, NodeFilter, boolean) - Method in interface org.w3c.dom.traversal. DocumentTraversal

在指定节点上生成的子 TreeWalker创建一个新的 TreeWalker 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicButtonUI

返回一个 BasicButtonUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicCheckBoxMenuItemUI

构造一个新的实例 BasicCheckBoxMenuItemUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicCheckBoxUI

返回一个 BasicCheckBoxUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicColorChooserUI

返回一个新的实例 BasicColorChooserUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicComboBoxUI

构造一个新的实例 BasicComboBoxUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicDesktopIconUI

构造一个新的实例 BasicDesktopIconUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicDesktopPaneUI

构造一个新的实例 BasicDesktopPaneUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicEditorPaneUI

为JTextPane创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicFileChooserUI

为指定的组件创建一个 BasicFileChooserUI实现。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicFormattedTextFieldUI

为JFormattedTextField创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回组件UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicLabelUI

返回一个 BasicLabelUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicListUI

返回一个新的实例 BasicListUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicMenuBarUI

返回一个新的实例 BasicMenuBarUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicMenuItemUI

返回一个新的实例 BasicMenuItemUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicMenuUI

构造一个新的实例 BasicMenuUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicOptionPaneUI

创建一个新的 BasicOptionPaneUI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicPanelUI

返回一个 BasicPanelUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicPasswordFieldUI

为JPasswordField创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicPopupMenuSeparatorUI

返回一个新的实例 BasicPopupMenuSeparatorUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicPopupMenuUI

构造一个新的实例 BasicPopupMenuUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicProgressBarUI

返回一个新的实例 BasicProgressBarUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicRadioButtonMenuItemUI

返回一个新的实例 BasicRadioButtonMenuItemUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicRadioButtonUI

返回一个 BasicRadioButtonUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicRootPaneUI

返回一个新的实例 BasicRootPaneUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicScrollBarUI

创建UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicScrollPaneUI

返回一个新的实例 BasicScrollPaneUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicSeparatorUI

返回一个新的实例 BasicSeparatorUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicSliderUI

创建一个UI

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicSpinnerUI

返回一个新的BasicSpinnerUI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicSplitPaneUI

创建一个新的实例 BasicSplitPaneUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicTabbedPaneUI

创建一个UI

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicTableHeaderUI

返回一个新的实例 BasicTableHeaderUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicTableUI

返回一个新的实例 BasicTableUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicTextAreaUI

为JTextArea创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicTextFieldUI

为JTextField创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicTextPaneUI

为JTextPane创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicToggleButtonUI

返回一个 BasicToggleButtonUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicToolBarSeparatorUI

返回一个新的实例 BasicToolBarSeparatorUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicToolBarUI

构造一个新的实例 BasicToolBarUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicToolTipUI

返回 BasicToolTipUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicTreeUI

构造一个新的实例 BasicTreeUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.basic. BasicViewportUI

返回一个 BasicViewportUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf. ComponentUI

返回指定组件的UI委托的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalButtonUI

返回一个 MetalButtonUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalCheckBoxUI

返回一个 MetalCheckBoxUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalComboBoxUI

构造一个 MetalComboBoxUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalDesktopIconUI

构造一个新的实例 MetalDesktopIconUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalFileChooserUI

构造一个新的实例 MetalFileChooserUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalInternalFrameUI

构造一个新的 MetalInternalFrameUI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalLabelUI

返回一个 MetalLabelUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalMenuBarUI

为传入的组件创建 ComponentUI实现。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalPopupMenuSeparatorUI

构造一个新的 MetalPopupMenuSeparatorUI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalProgressBarUI

构造一个 MetalProgressBarUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalRadioButtonUI

返回一个 MetalRadioButtonUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalRootPaneUI

创建一个 JRootPane的UI。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalScrollBarUI

构造一个新的 MetalScrollBarUI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalScrollPaneUI

构造新的 MetalScrollPaneUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalSeparatorUI

构造一个新的 MetalSeparatorUI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalSliderUI

构造一个 MetalSliderUI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalSplitPaneUI

创建一个新的 MetalSplitPaneUI实例

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalTabbedPaneUI

构造 MetalTabbedPaneUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalTextFieldUI

构造 MetalTextFieldUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalToggleButtonUI

构造 MetalToogleButtonUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalToolBarUI

构造一个 MetalToolBarUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalToolTipUI

返回一个 MetalToolTipUI的实例。

createUI(JComponent) - Static method in class javax.swing.plaf.metal. MetalTreeUI

构造 MetalTreeUI 。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiButtonUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiColorChooserUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiComboBoxUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiDesktopIconUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiDesktopPaneUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiFileChooserUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiInternalFrameUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiLabelUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiListUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiMenuBarUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiMenuItemUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiOptionPaneUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiPanelUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiPopupMenuUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiProgressBarUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiRootPaneUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiScrollBarUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiScrollPaneUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiSeparatorUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiSliderUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiSpinnerUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiSplitPaneUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiTabbedPaneUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiTableHeaderUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiTableUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiTextUI

如果任何辅助 LookAndFeel支持此UI，则返回复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiToolBarUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiToolTipUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiTreeUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.multi. MultiViewportUI

如果任何辅助 LookAndFeel支持此UI，则返回多路复用UI实例。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthButtonUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthCheckBoxMenuItemUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthCheckBoxUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthColorChooserUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthComboBoxUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthDesktopIconUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthDesktopPaneUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthEditorPaneUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthFormattedTextFieldUI

为JFormattedTextField创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthInternalFrameUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthLabelUI

返回用于皮肤外观的LabelUI实现。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthListUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthLookAndFeel

创建Synth的外观和感觉 ComponentUI为通过在 JComponent 。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthMenuBarUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthMenuItemUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthMenuUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthOptionPaneUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthPanelUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthPasswordFieldUI

为JPasswordField创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthPopupMenuUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthProgressBarUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthRadioButtonMenuItemUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthRadioButtonUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthRootPaneUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthScrollBarUI

返回一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthScrollPaneUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthSeparatorUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthSliderUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthSpinnerUI

返回SynthSpinnerUI的新实例。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthSplitPaneUI

创建一个新的SynthSplitPaneUI实例

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthTabbedPaneUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthTableHeaderUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthTableUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthTextAreaUI

为JTextArea创建一个UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthTextFieldUI

为JTextField创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthTextPaneUI

为JTextPane创建一个UI。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthToggleButtonUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthToolBarUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthToolTipUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthTreeUI

为给定的组件创建一个新的UI对象。

createUI(JComponent) - Static method in class javax.swing.plaf.synth. SynthViewportUI

为给定的组件创建一个新的UI对象。

createUIs(ComponentUI, Vector<ComponentUI>, JComponent) - Static method in class javax.swing.plaf.multi. MultiLookAndFeel

创建 ComponentUI对象，以显示 target组件，将对象放在 uis向量中，并返回最能代表组件UI的 ComponentUI对象。

createUnion(Rectangle2D) - Method in class java.awt.geom. Rectangle2D

返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。

createUnion(Rectangle2D) - Method in class java.awt.geom. Rectangle2D.Double

返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。

createUnion(Rectangle2D) - Method in class java.awt.geom. Rectangle2D.Float

返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。

createUnion(Rectangle2D) - Method in class java.awt. Rectangle

返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。

createUnmarshalException(SAXException) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

从SAXException创建一个UnmarshalException。

createUnmarshaller() - Method in class javax.xml.bind. JAXBContext

创建可以将XML数据转换为java内容树的 Unmarshaller对象。

createUnmarshaller(ValidationEventHandler) - Method in interface javax.xml.bind.annotation. DomHandler

当JAXB提供者需要将文档的一部分解组成信息集表示时，它首先调用此方法来创建一个Result对象。

createUnmarshaller(ValidationEventHandler) - Method in class javax.xml.bind.annotation. W3CDomHandler

createUnresolved(String, int) - Static method in class java.net. InetSocketAddress

从主机名和端口号创建未解析的套接字地址。

createUrlCssMetaData(String, Function<S, StyleableProperty<String>>) - Method in class javafx.css. StyleablePropertyFactory

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

createUrlCssMetaData(String, Function<S, StyleableProperty<String>>, String) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

createUrlCssMetaData(String, Function<S, StyleableProperty<String>>, String, boolean) - Method in class javafx.css. StyleablePropertyFactory

创建具有初始值的CssMetaData <S，String>并继承标志。

createURLStreamHandler(String) - Method in interface java.net. URLStreamHandlerFactory

使用指定的协议创建一个新的 URLStreamHandler实例。

createValidator() - Method in class javax.xml.bind. JAXBContext

已过时。
自JAXB2.0起

createValue(UIDefaults) - Method in interface javax.swing. UIDefaults.ActiveValue

创建从 UIDefaults表中检索的值。

createValue(UIDefaults) - Method in class javax.swing. UIDefaults.LazyInputMap

创建一个 InputMap与传入的绑定。

createValue(UIDefaults) - Method in interface javax.swing. UIDefaults.LazyValue

创建从 UIDefaults表中检索的实际值。

createValue(UIDefaults) - Method in class javax.swing. UIDefaults.ProxyLazyValue

创建从 UIDefaults表中检索的值。

createValueHandler() - Static method in class javax.rmi.CORBA. Util

返回实现ValueHandler接口的类的单例实例。

createValueHandler() - Method in interface javax.rmi.CORBA. UtilDelegate

代表团要求 Util.createValueHandler() 。

createVerticalBox() - Static method in class javax.swing. Box

创建一个 Box显示其组件的 Box 。

createVerticalGlue() - Static method in class javax.swing. Box

创建垂直胶水组件。

createVerticalScrollBar() - Method in class javax.swing. JScrollPane

默认情况下返回 JScrollPane.ScrollBar 。

createVerticalStrut(int) - Static method in class javax.swing. Box

创建一个看不见的，固定高度的组件。

createView(FlowView, int, int, int) - Method in class javax.swing.text. FlowView.FlowStrategy

创建一个可用于表示当前流的视图。

createViewListener() - Method in class javax.swing. JViewport

为视图创建一个侦听器。

createViewport() - Method in class javax.swing. JScrollPane

默认情况下返回一个新的 JViewport 。

createViewportChangeListener() - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

返回视口 ChangeListener的实例。

createVirtualMachine(Connection) - Method in interface com.sun.jdi. VirtualMachineManager

创建一个新的虚拟机。

createVirtualMachine(Connection, Process) - Method in interface com.sun.jdi. VirtualMachineManager

为目标虚拟机创建虚拟机镜像。

createVMDeathRequest() - Method in interface com.sun.jdi.request. EventRequestManager

创建一个新的禁用VMDeathRequest 。

createVolatileImage(int, int) - Method in class java.awt. Component

创建一个用于双缓冲的易失性的屏幕外可绘图像。

createVolatileImage(int, int, ImageCapabilities) - Method in class java.awt. Component

使用给定的功能创建一个易失的屏幕外可绘制图像。

createVSBChangeListener() - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

返回垂直滚动条 ChangeListener一个实例。

createW3CEndpointReference(String, QName, QName, List<Element>, String, List<Element>) - Method in class javax.xml.ws.spi. Provider

工厂方法创建一个 W3CEndpointReference 。

createW3CEndpointReference(String, QName, QName, QName, List<Element>, String, List<Element>, List<Element>, Map<QName, String>) - Method in class javax.xml.ws.spi. Provider

工厂方法创建一个 W3CEndpointReference 。

createWebRowSet() - Method in interface javax.sql.rowset. RowSetFactory

创建一个WebRowSet的新实例。

createWestPane(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

创建西窗格。

createWinListener(JPopupMenu) - Method in class javax.swing. JMenu

为弹出窗口创建一个关闭窗口的侦听器。

createWritableChild(int, int, int, int, int, int, int[]) - Method in class java.awt.image. WritableRaster

返回一个新的WritableRaster，它分享这个WritableRaster的DataBuffer的全部或部分。

createWritableRaster(SampleModel, DataBuffer, Point) - Static method in class java.awt.image. Raster

使用指定的SampleModel和DataBuffer创建WritableRaster。

createWritableRaster(SampleModel, Point) - Static method in class java.awt.image. Raster

使用指定的SampleModel创建WritableRaster。

createWritableTranslatedChild(int, int) - Method in class java.awt.image. WritableRaster

创建一个具有相同大小的WritableRaster，SampleModel和DataBuffer，但是具有不同的位置。

createWriterInstance() - Method in class javax.imageio.spi. ImageWriterSpi

返回与此服务提供商关联的 ImageWriter实现的实例。

createWriterInstance(Object) - Method in class javax.imageio.spi. ImageWriterSpi

返回与此服务提供商相关联的 ImageWriter实现的实例。

createXAConnectionBuilder() - Method in interface javax.sql. XADataSource

创建一个新的 XAConnectionBuilder实例

createXMLEventReader(InputStream) - Method in class javax.xml.stream. XMLInputFactory

从java.io.InputStream创建一个新的XMLEventReader

createXMLEventReader(InputStream, String) - Method in class javax.xml.stream. XMLInputFactory

从java.io.InputStream创建一个新的XMLEventReader

createXMLEventReader(Reader) - Method in class javax.xml.stream. XMLInputFactory

从阅读器创建一个新的XMLEventReader

createXMLEventReader(String, InputStream) - Method in class javax.xml.stream. XMLInputFactory

从java.io.InputStream创建一个新的XMLEventReader

createXMLEventReader(String, Reader) - Method in class javax.xml.stream. XMLInputFactory

从阅读器创建一个新的XMLEventReader

createXMLEventReader(XMLStreamReader) - Method in class javax.xml.stream. XMLInputFactory

从XMLStreamReader创建一个新的XMLEventReader。

createXMLEventReader(Source) - Method in class javax.xml.stream. XMLInputFactory

从JAXP源创建一个新的XMLEventReader。

createXMLEventWriter(OutputStream) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入流的新XMLEventWriter

createXMLEventWriter(OutputStream, String) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入流的新XMLEventWriter

createXMLEventWriter(Writer) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入作者的新的XMLEventWriter

createXMLEventWriter(Result) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入JAXP结果的新的XMLEventWriter。

createXMLReader() - Static method in class org.xml.sax.helpers. XMLReaderFactory

已过时。

获得一个新的实例XMLReader 。

createXMLReader(String) - Static method in class org.xml.sax.helpers. XMLReaderFactory

已过时。

尝试从类名创建XML阅读器。

createXMLStreamReader(InputStream) - Method in class javax.xml.stream. XMLInputFactory

从java.io.InputStream创建一个新的XMLStreamReader

createXMLStreamReader(InputStream, String) - Method in class javax.xml.stream. XMLInputFactory

从java.io.InputStream创建一个新的XMLStreamReader

createXMLStreamReader(Reader) - Method in class javax.xml.stream. XMLInputFactory

从阅读器创建一个新的XMLStreamReader

createXMLStreamReader(String, InputStream) - Method in class javax.xml.stream. XMLInputFactory

从java.io.InputStream创建一个新的XMLStreamReader

createXMLStreamReader(String, Reader) - Method in class javax.xml.stream. XMLInputFactory

从java.io.InputStream创建一个新的XMLStreamReader

createXMLStreamReader(Source) - Method in class javax.xml.stream. XMLInputFactory

从JAXP源创建一个新的XMLStreamReader。

createXMLStreamWriter(OutputStream) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入流的新XMLStreamWriter

createXMLStreamWriter(OutputStream, String) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入流的新XMLStreamWriter

createXMLStreamWriter(Writer) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入作者的新XMLStreamWriter

createXMLStreamWriter(Result) - Method in class javax.xml.stream. XMLOutputFactory

创建一个写入JAXP结果的新XMLStreamWriter。

createZipEntry(String) - Method in class java.util.jar. JarInputStream

为指定的JAR文件条目名称创建一个新的 JarEntry （ ZipEntry ）。

createZipEntry(String) - Method in class java.util.zip. ZipInputStream

为指定的条目名称创建一个新的 ZipEntry对象。

createZone(int, int) - Method in class javax.swing.text. ZoneView

创建一个视图来表示模型中给定范围的区域（应该在该对象的责任范围内）。

creationTime() - Method in interface java.nio.file.attribute. BasicFileAttributes

返回创建时间。

CREDENTIAL_TYPES - Static variable in class javax.management.remote.rmi. RMIConnectorServer

指定可接受作为 RMIServer.newClient()远程方法调用的参数的类名列表的属性的名称。

CredentialException - Exception in javax.security.auth.login

通用凭证异常。

CredentialException() - Constructor for exception javax.security.auth.login. CredentialException

构造一个没有详细消息的CredentialException。

CredentialException(String) - Constructor for exception javax.security.auth.login. CredentialException

构造具有指定详细消息的CredentialException。

CredentialExpiredException - Exception in javax.security.auth.login

表示 Credential已过期。

CredentialExpiredException() - Constructor for exception javax.security.auth.login. CredentialExpiredException

构造一个没有详细消息的CredentialExpiredException。

CredentialExpiredException(String) - Constructor for exception javax.security.auth.login. CredentialExpiredException

构造具有指定详细消息的CredentialExpiredException。

CredentialNotFoundException - Exception in javax.security.auth.login

表示没有找到凭据。

CredentialNotFoundException() - Constructor for exception javax.security.auth.login. CredentialNotFoundException

构造一个没有详细消息的CredentialNotFoundException。

CredentialNotFoundException(String) - Constructor for exception javax.security.auth.login. CredentialNotFoundException

构造具有指定详细消息的CredentialNotFoundException。

CREDENTIALS - Static variable in interface javax.management.remote. JMXConnector

指定在连接期间发送到连接器服务器的凭据的属性的名称。

CREDENTIALS - Static variable in class javax.security.sasl. Sasl

指定要使用的凭据的属性的名称。

CREDENTIALS_EXPIRED - Static variable in exception org.ietf.jgss. GSSException

过期凭证

CRIMSON - Static variable in class javafx.scene.paint. Color

颜色深红色，RGB值为＃DC143C

CRITICAL - Static variable in interface javax.naming.ldap. Control

表示关键控制。

criticality - Variable in class javax.naming.ldap. BasicControl

控制的关键性。

CRL - Class in java.security.cert

该类是具有不同格式但重要常见用途的证书吊销列表（CRL）的抽象。

CRL(String) - Constructor for class java.security.cert. CRL

创建指定类型的CRL。

CRLException - Exception in java.security.cert

CRL（证书撤销列表）异常。

CRLException() - Constructor for exception java.security.cert. CRLException

构造一个没有详细消息的CRLException。

CRLException(String) - Constructor for exception java.security.cert. CRLException

构造具有指定详细消息的CRLException。

CRLException(String, Throwable) - Constructor for exception java.security.cert. CRLException

创建一个具有指定的详细信息和原因的 CRLException 。

CRLException(Throwable) - Constructor for exception java.security.cert. CRLException

创建 CRLException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

CRLReason - Enum in java.security.cert

CRLReason枚举指定了撤销证书的原因，如 RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile中所定义。

CRLSelector - Interface in java.security.cert

一个选择器，用于定义一组选择 CRL的标准。

CropImageFilter - Class in java.awt.image

用于裁剪图像的ImageFilter类。

CropImageFilter(int, int, int, int) - Constructor for class java.awt.image. CropImageFilter

构造一个CropImageFilter，它从x，y，w和h参数指定的源图像中提取像素的绝对矩形区域。

CROSS_JOIN - Static variable in interface javax.sql.rowset. JoinRowSet

ANSI-style JOIN提供两个表的交叉产品

CROSSHAIR - Static variable in class javafx.scene. Cursor

十字准线游标类型。

CROSSHAIR_CURSOR - Static variable in class java.awt. Cursor

十字准线游标类型。

CROSSHAIR_CURSOR - Static variable in class java.awt. Frame

已过时。
替换为Cursor.CROSSHAIR_CURSOR 。

crossProduct(double, double) - Method in class javafx.geometry. Point2D

计算由该实例表示的向量与指定向量的交叉乘积。

crossProduct(double, double, double) - Method in class javafx.geometry. Point3D

计算由该实例表示的向量与指定向量的交叉乘积。

crossProduct(Point2D) - Method in class javafx.geometry. Point2D

计算由该实例表示的向量与指定向量的交叉乘积。

crossProduct(Point3D) - Method in class javafx.geometry. Point3D

计算由该实例表示的向量与指定向量的交叉乘积。

CryptoPrimitive - Enum in java.security

加密原语的枚举。

CS_CIEXYZ - Static variable in class java.awt.color. ColorSpace

上面定义的CIEXYZ转换颜色空间。

CS_GRAY - Static variable in class java.awt.color. ColorSpace

内置线性灰度色彩空间。

CS_LINEAR_RGB - Static variable in class java.awt.color. ColorSpace

内置线性RGB色彩空间。

CS_PYCC - Static variable in class java.awt.color. ColorSpace

照片YCC转换颜色空间。

CS_sRGB - Static variable in class java.awt.color. ColorSpace

sRGB颜色空间定义在 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html 。

CSS - Class in javax.swing.text.html

将一组 CSS attributes定义为类型安全枚举。

CSS() - Constructor for class javax.swing.text.html. CSS

构造一个CSS对象。

CSS_ATTR - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是属性函数。

CSS_CM - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为长度（cm）。

CSS_COUNTER - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是计数器或计数器功能。

CSS_CUSTOM - Static variable in interface org.w3c.dom.css. CSSValue

该值是一个自定义值。

CSS_DEG - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个角度（度）。

CSS_DIMENSION - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是具有未知维度的数字。

CSS_EMS - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

值是一个长度（ems）。

CSS_EXS - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个长度（exs）。

CSS_GRAD - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个角度（grad）。

CSS_HZ - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为频率（Hz）。

CSS_IDENT - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个标识符。

CSS_IN - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个长度（英寸）。

CSS_INHERIT - Static variable in interface org.w3c.dom.css. CSSValue

该值是继承的，而 cssText包含“继承”。

CSS_KHZ - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为频率（kHz）。

CSS_MM - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

值为长度（mm）。

CSS_MS - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个时间（ms）。

CSS_NUMBER - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个简单的数字。

CSS_PC - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个长度（pc）。

CSS_PERCENTAGE - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个百分比。

CSS_PRIMITIVE_VALUE - Static variable in interface org.w3c.dom.css. CSSValue

的值是原始值和所述的实例 CSSPrimitiveValue可以通过使用在此实例结合特异性铸造方法获得接口 CSSValue接口。

CSS_PT - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为长度（pt）。

CSS_PX - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为长度（px）。

CSS_RAD - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为角度（rad）。

CSS_RECT - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个rect函数。

CSS_RGBCOLOR - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为RGB颜色。

CSS_S - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个时间。

CSS_STRING - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值为STRING。

CSS_UNKNOWN - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值不是公认的CSS2值。

CSS_URI - Static variable in interface org.w3c.dom.css. CSSPrimitiveValue

该值是一个URI。

CSS_VALUE_LIST - Static variable in interface org.w3c.dom.css. CSSValue

该值是一个 CSSValue列表和实例 CSSValueList可以通过使用在此实例结合特异性铸造方法获得接口 CSSValue接口。

CSS.Attribute - Class in javax.swing.text.html

定义用作可能包含CSS属性的AttributeSet的键。

CSS2Properties - Interface in org.w3c.dom.css

所述 CSS2Properties接口表示用于检索和一内定型特性的便利机制 CSSStyleDeclaration 。

CSSBridge() - Constructor for class javafx.scene.control. PopupControl.CSSBridge

CSSCharsetRule - Interface in org.w3c.dom.css

CSSCharsetRule接口代表CSS样式表中的@charset规则。

CSSFontFaceRule - Interface in org.w3c.dom.css

CSSFontFaceRule接口代表CSS样式表中的@ font-face规则。

CSSImportRule - Interface in org.w3c.dom.css

CSSImportRule接口表示CSS样式表中的@import规则。

CSSMediaRule - Interface in org.w3c.dom.css

CSSMediaRule接口表示CSS样式表中的@media规则。

CssMetaData< S extends Styleable, V> - Class in javafx.css

CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。

CssMetaData(String, StyleConverter<?, V>) - Constructor for class javafx.css. CssMetaData

使用给定的参数构造一个CssMetaData，initialValue为null，inherit设置为false，没有子属性。

CssMetaData(String, StyleConverter<?, V>, V) - Constructor for class javafx.css. CssMetaData

使用给定的参数构造一个CssMetaData，继承设置为false并且没有子属性。

CssMetaData(String, StyleConverter<?, V>, V, boolean) - Constructor for class javafx.css. CssMetaData

用给定的参数构造一个CssMetaData，没有子属性。

CssMetaData(String, StyleConverter<?, V>, V, boolean, List<CssMetaData<? extends Styleable, ?>>) - Constructor for class javafx.css. CssMetaData

用给定的参数构造一个CssMetaData，没有子属性。

CSSPageRule - Interface in org.w3c.dom.css

CSSPageRule接口表示CSS样式表中的@page规则。

CssParser - Class in javafx.css

CssParser() - Constructor for class javafx.css. CssParser

CssParser.ParseError - Class in javafx.css

封装关于解析CSS或将样式应用于节点时遇到的错误的来源和性质的信息。

CssParser.ParseError.InlineStyleParsingError - Class in javafx.css

封装从节点样式属性解析引起的错误

CssParser.ParseError.PropertySetError - Class in javafx.css

封装将风格应用于节点所产生的错误。

CssParser.ParseError.StringParsingError - Class in javafx.css

当样式不是内联样式时，也不会从样式表中选择样式，从而解析解析时出现的错误。

CssParser.ParseError.StylesheetParsingError - Class in javafx.css

封装解析样式表文件时产生的错误

CSSPrimitiveValue - Interface in org.w3c.dom.css

CSSPrimitiveValue接口表示单个CSS值。

CSSRule - Interface in org.w3c.dom.css

CSSRule接口是任何类型的CSS语句的抽象基础接口。

CSSRuleList - Interface in org.w3c.dom.css

CSSRuleList接口提供了CSS规则的有序集合的抽象。

CSSStyleDeclaration - Interface in org.w3c.dom.css

CSSStyleDeclaration接口代表一个单一的CSS声明块。

CSSStyleRule - Interface in org.w3c.dom.css

CSSStyleRule接口表示CSS样式表中的单个规则集。

CSSStyleSheet - Interface in org.w3c.dom.css

CSSStyleSheet界面是用于表示CSS样式表的具体界面，即其内容类型为“text / css”的样式表。

CSSUnknownRule - Interface in org.w3c.dom.css

CSSUnknownRule接口表示此用户代理不支持的规则。

CSSValue - Interface in org.w3c.dom.css

CSSValue接口代表一个简单或复杂的值。

CSSValueList - Interface in org.w3c.dom.css

CSSValueList接口提供了CSS值的有序集合的抽象。

CTRL_DOWN_MASK - Static variable in class java.awt.event. InputEvent

控制键扩展修改常数。

CTRL_MASK - Static variable in class java.awt.event. ActionEvent

控制修饰符。

CTRL_MASK - Static variable in class java.awt. Event

已过时。

该标志表示事件发生时控制键已关闭。

CTRL_MASK - Static variable in class java.awt.event. InputEvent

已过时。
建议使用CTRL_DOWN_MASK和InputEvent.getModifiersEx()

ctrlx - Variable in class java.awt.geom. QuadCurve2D.Double

二次曲线段控制点的X坐标。

ctrlx - Variable in class java.awt.geom. QuadCurve2D.Float

二次曲线段控制点的X坐标。

ctrlx1 - Variable in class java.awt.geom. CubicCurve2D.Double

三次曲线段的第一个控制点的X坐标。

ctrlx1 - Variable in class java.awt.geom. CubicCurve2D.Float

三次曲线段的第一个控制点的X坐标。

ctrlx2 - Variable in class java.awt.geom. CubicCurve2D.Double

三次曲线段的第二个控制点的X坐标。

ctrlx2 - Variable in class java.awt.geom. CubicCurve2D.Float

三次曲线段的第二个控制点的X坐标。

ctrly - Variable in class java.awt.geom. QuadCurve2D.Double

二次曲线段控制点的Y坐标。

ctrly - Variable in class java.awt.geom. QuadCurve2D.Float

二次曲线段控制点的Y坐标。

ctrly1 - Variable in class java.awt.geom. CubicCurve2D.Double

三次曲线段的第一个控制点的Y坐标。

ctrly1 - Variable in class java.awt.geom. CubicCurve2D.Float

三次曲线段的第一个控制点的Y坐标。

ctrly2 - Variable in class java.awt.geom. CubicCurve2D.Double

三次曲线段的第二个控制点的Y坐标。

ctrly2 - Variable in class java.awt.geom. CubicCurve2D.Float

三次曲线段的第二个控制点的Y坐标。

ctx() - Method in class org.omg.CORBA. Request

检索此请求的 Context对象。

ctx() - Method in class org.omg.CORBA. ServerRequest

当操作不是属性访问并且操作的IDL定义包含上下文表达式时，返回IDL中为操作指定的上下文信息; 否则返回Context参考。

ctx(Context) - Method in class org.omg.CORBA. Request

将此请求的 Context对象设置为给定的对象。

CTX_RESTRICT_SCOPE - Interface in org.omg.CORBA

一个标志，可以用作方法 Context.get_values的第二个参数来限制搜索范围。

CubicCurve - Class in javafx.scene.shape

CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。

CubicCurve() - Constructor for class javafx.scene.shape. CubicCurve

创建一个空的CubicCurve实例。

CubicCurve(double, double, double, double, double, double, double, double) - Constructor for class javafx.scene.shape. CubicCurve

创建一个新的CubicCurve实例。

CubicCurve2D - Class in java.awt.geom

CubicCurve2D类定义了 (x,y)坐标空间中的三次参数曲线段。

CubicCurve2D() - Constructor for class java.awt.geom. CubicCurve2D

这是一个无法直接实例化的抽象类。

CubicCurve2D.Double - Class in java.awt.geom

用 double坐标指定的三次参数曲线段。

CubicCurve2D.Float - Class in java.awt.geom

用 float指定的三次参数曲线段。

CubicCurveTo - Class in javafx.scene.shape

通过使用指定点 (controlX1,controlY1)和 (controlX2,controlY2)作为BÃzier控制点 (controlX1,controlY1)与当前坐标和指定坐标 (x,y)相交的立方Bier曲线，创建由三个新点定义的曲线路径元素。

CubicCurveTo() - Constructor for class javafx.scene.shape. CubicCurveTo

创建一个空的CubicCurveTo实例。

CubicCurveTo(double, double, double, double, double, double) - Constructor for class javafx.scene.shape. CubicCurveTo

创建一个新的CubicCurveTo实例。

CullFace - Enum in javafx.scene.shape

面部剔除设置，用于 Shape3D.cullFace

cullFaceProperty() - Method in class javafx.scene.shape. Shape3D

定义cullFace这 Shape3D 。

cumulativePeriodProperty() - Method in class javafx.concurrent. ScheduledService

迭代之间使用的当前累积周期。

CUNEIFORM - java.lang. Character.UnicodeScript

Unicode脚本“楔形文字”。

CUNEIFORM - Static variable in class java.lang. Character.UnicodeBlock

“Cuneiform”Unicode字符块的常数。

CUNEIFORM_NUMBERS_AND_PUNCTUATION - Static variable in class java.lang. Character.UnicodeBlock

“Cuneiform数字和标点符号”Unicode字符块的常数。

Currency - Class in java.util

代表货币。

CURRENCY - Static variable in class java.text. NumberFormat.Field

不断识别货币字段。

CURRENCY_SYMBOL - Static variable in class java.lang. Character

Unicode规范中的一般类别“Sc”。

CURRENCY_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock

Unicode字符块的“货币符号”的常量。

CurrencyNameProvider - Class in java.util.spi

为Currency类提供本地化货币符号和显示名称的服务提供商的抽象类。

CurrencyNameProvider() - Constructor for class java.util.spi. CurrencyNameProvider

唯一的构造函数。

CurrencyStringConverter - Class in javafx.util.converter

StringConverter代表货币的Number值的实现。

CurrencyStringConverter() - Constructor for class javafx.util.converter. CurrencyStringConverter

CurrencyStringConverter(String) - Constructor for class javafx.util.converter. CurrencyStringConverter

CurrencyStringConverter(NumberFormat) - Constructor for class javafx.util.converter. CurrencyStringConverter

CurrencyStringConverter(Locale) - Constructor for class javafx.util.converter. CurrencyStringConverter

CurrencyStringConverter(Locale, String) - Constructor for class javafx.util.converter. CurrencyStringConverter

current() - Static method in interface java.lang. ProcessHandle

返回当前进程的ProcessHandle。

current() - Method in class java.text. BreakIterator

返回最近由next（），next（int），previous（），first（），last（），following（int）或previous（int）返回的文本边界的字符索引。

current() - Method in interface java.text. CharacterIterator

获取当前位置的字符（由getIndex（）返回）。

current() - Method in class java.text. StringCharacterIterator

为String执行CharacterIterator.current（）。

current() - Static method in class java.util.concurrent. ThreadLocalRandom

返回当前线程的 ThreadLocalRandom 。

current() - Method in class javax.swing.text. ElementIterator

获取当前元素。

current() - Method in class javax.swing.text. Segment

获取当前位置的字符（由getIndex（）返回）。

Current - Interface in org.omg.CORBA

从 Current接口派生的接口使得ORB和CORBA服务能够访问与运行线程相关联的信息（上下文）。

Current - Interface in org.omg.PortableInterceptor

便携式拦截器当前（也称为 PICurrent ）仅仅是一个时隙表，每个服务的时隙表都用于在其上下文和请求或应答的服务上下文之间传送其上下文数据。

Current - Interface in org.omg.PortableServer

从CORBA :: Current派生的PortableServer :: Current接口提供了访问方法被调用的对象的身份的方法实现。

CURRENT - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于CURRENT

current_component() - Method in interface org.omg.CORBA. DynAny

已过时。

返回一个 DynAny对象引用，可用于获取/设置当前访问的组件的值。

current_component() - Method in class org.omg.DynamicAny. _DynAnyStub

返回当前位置的组件的DynAny。

current_component() - Method in class org.omg.DynamicAny. _DynArrayStub

返回当前位置的组件的DynAny。

current_component() - Method in class org.omg.DynamicAny. _DynEnumStub

返回当前位置的组件的DynAny。

current_component() - Method in class org.omg.DynamicAny. _DynFixedStub

返回当前位置的组件的DynAny。

current_component() - Method in class org.omg.DynamicAny. _DynSequenceStub

返回当前位置的组件的DynAny。

current_component() - Method in class org.omg.DynamicAny. _DynStructStub

返回当前位置的组件的DynAny。

current_component() - Method in class org.omg.DynamicAny. _DynUnionStub

返回当前位置的组件的DynAny。

current_component() - Method in class org.omg.DynamicAny. _DynValueStub

返回当前位置的组件的DynAny。

current_component() - Method in interface org.omg.DynamicAny. DynAnyOperations

返回当前位置的组件的DynAny。

current_factory() - Method in interface org.omg.PortableInterceptor. IORInfoOperations

读取时，返回当前工厂，该工厂将用于为刚创建的对象适配器创建对象引用，并正在运行IOR拦截器。

current_factory(ObjectReferenceFactory) - Method in interface org.omg.PortableInterceptor. IORInfoOperations

读取时，返回当前工厂，该工厂将用于为刚创建的对象适配器创建对象引用，并正在运行IOR拦截器。

current_member_kind() - Method in interface org.omg.CORBA. DynStruct

已过时。

返回描述当前成员种类的 TCKind对象。

current_member_kind() - Method in interface org.omg.CORBA. DynValue

已过时。

返回描述当前成员的 TCKind对象。

current_member_kind() - Method in class org.omg.DynamicAny. _DynStructStub

返回与当前位置的成员关联的TCKind。

current_member_kind() - Method in class org.omg.DynamicAny. _DynValueStub

返回与当前位置的成员关联的TCKind。

current_member_kind() - Method in interface org.omg.DynamicAny. DynStructOperations

返回与当前位置的成员关联的TCKind。

current_member_kind() - Method in interface org.omg.DynamicAny. DynValueOperations

返回与当前位置的成员关联的TCKind。

current_member_name() - Method in interface org.omg.CORBA. DynStruct

已过时。

在遍历期间，返回当前成员的名称。

current_member_name() - Method in interface org.omg.CORBA. DynValue

已过时。

在遍历表示Value对象的 DynAny对象时返回当前成员的名称。

current_member_name() - Method in class org.omg.DynamicAny. _DynStructStub

返回当前位置的成员名称。

current_member_name() - Method in class org.omg.DynamicAny. _DynValueStub

返回当前位置的成员名称。

current_member_name() - Method in interface org.omg.DynamicAny. DynStructOperations

返回当前位置的成员名称。

current_member_name() - Method in interface org.omg.DynamicAny. DynValueOperations

返回当前位置的成员名称。

currentCellRenderer - Variable in class javax.swing.plaf.basic. BasicTreeUI

正在使用的渲染器进行实际的单元格绘图。

currentClassLoader() - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。

currentContendedMonitor() - Method in interface com.sun.jdi. ThreadReference

返回一个ObjectReference的显示器，如果有的话，这个线程当前正在等待。

currentCountProperty() - Method in class javafx.scene.media. MediaPlayer

完成播放周期的次数。

currentDisplayedExtraValueProperty(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart

当前显示的额外值属性。

currentDisplayedXValueProperty(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart

在X轴上绘制的当前显示的数据值属性。

currentDisplayedYValueProperty(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart

在Y轴上绘制的当前显示的数据值属性。

currentFailureCountProperty() - Method in class javafx.concurrent. ScheduledService

当前ScheduledService失败的次数。

currentGroupID() - Static method in class java.rmi.activation. ActivationGroup

返回当前激活组的标识符。

CurrentHelper - Class in org.omg.CORBA

助手 Current 。

CurrentHelper - Class in org.omg.PortableInterceptor

便携式拦截器当前（也称为 PICurrent ）仅仅是一个时隙表，每个服务的时隙表都用于在其上下文和请求或应答的服务上下文之间传送其上下文数据。

CurrentHelper - Class in org.omg.PortableServer

从CORBA :: Current派生的PortableServer :: Current接口提供了访问方法被调用的对象的身份的方法实现。

CurrentHelper() - Constructor for class org.omg.CORBA. CurrentHelper

CurrentHelper() - Constructor for class org.omg.PortableInterceptor. CurrentHelper

CurrentHelper() - Constructor for class org.omg.PortableServer. CurrentHelper

CurrentHolder - Class in org.omg.CORBA

持有人 Current 。

CurrentHolder() - Constructor for class org.omg.CORBA. CurrentHolder

CurrentHolder(Current) - Constructor for class org.omg.CORBA. CurrentHolder

currentIndexProperty() - Method in class javafx.scene.web. WebHistory

定义历史上当前 Entry的指数。

currentLoadedClass() - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission呼叫。 此方法在将来的Java SE版本中可能会被删除。

currentLowerBound - Variable in class javafx.scene.chart. ValueAxis

该轴的lowerBound的当前值（最小值）。

currentManager(Component) - Static method in class javax.swing. RepaintManager

返回给定组件的调用线程的RepaintManager。

currentManager(JComponent) - Static method in class javax.swing. RepaintManager

返回给指定JComponent的调用线程的RepaintManager。

currentMouseX - Variable in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener

当前的鼠标x位置

currentMouseX - Variable in class javax.swing.plaf.basic. BasicSliderUI.TrackListener

当前鼠标x。

currentMouseY - Variable in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener

当前鼠标y位置

currentMouseY - Variable in class javax.swing.plaf.basic. BasicSliderUI.TrackListener

当前鼠标y。

CurrentOperations - Interface in org.omg.CORBA

界面为 Current 。

CurrentOperations - Interface in org.omg.PortableInterceptor

便携式拦截器当前（也称为 PICurrent ）仅仅是一个时隙表，每个服务的时隙表都用于在其上下文和请求或应答的服务上下文之间传送其上下文数据。

CurrentOperations - Interface in org.omg.PortableServer

从CORBA :: Current派生的PortableServer :: Current接口提供了访问方法被调用的对象的身份的方法实现。

currentPageIndexProperty() - Method in class javafx.scene.control. Pagination

要为此分页控件显示的当前页面索引。

currentRateProperty() - Method in class javafx.animation. Animation

只读变量来指示正在播放 Animation当前方向/速度。

currentRateProperty() - Method in class javafx.scene.media. MediaPlayer

当前的播放速度，无论设置如何。

currentSegment(double[]) - Method in class java.awt.geom. FlatteningPathIterator

返回迭代中当前路径段的坐标和类型。

currentSegment(double[]) - Method in interface java.awt.geom. PathIterator

返回迭代中当前路径段的坐标和类型。

currentSegment(float[]) - Method in class java.awt.geom. FlatteningPathIterator

返回迭代中当前路径段的坐标和类型。

currentSegment(float[]) - Method in interface java.awt.geom. PathIterator

返回迭代中当前路径段的坐标和类型。

currentThread() - Static method in class java.lang. Thread

返回对当前正在执行的线程对象的引用。

currentTimeMillis() - Static method in class java.lang. System

返回当前时间（以毫秒为单位）。

currentTimeProperty() - Method in class javafx.animation. Animation

定义 Animation的播放位置。

currentTimeProperty() - Method in class javafx.scene.media. MediaPlayer

当前媒体播放时间。

currentValuePane - Variable in class javax.swing.plaf.basic. BasicComboBoxUI

用于在组合框中呈现当前选定的项目。

cursor(String) - Static method in class javafx.scene. Cursor

返回指定标识符的游标。

Cursor - Class in java.awt

封装鼠标光标位图表示的类。

Cursor - Class in javafx.scene

封装鼠标光标位图表示的类。

Cursor(int) - Constructor for class java.awt. Cursor

创建一个指定类型的新的游标对象。

Cursor(String) - Constructor for class java.awt. Cursor

使用指定的名称创建一个新的自定义游标对象。

CursorConverter - Class in javafx.css.converter

cursorMoved(RowSetEvent) - Method in interface javax.sql. RowSetListener

通知已注册的听众 RowSet对象的光标已移动。

cursorProperty() - Method in class javafx.scene. Node

为此 Node和子节点定义鼠标光标。

cursorProperty() - Method in class javafx.scene. Scene

为此 Scene定义鼠标光标。

curve(double) - Method in class javafx.animation. Interpolator

从[0.0..1.0]映射到本身。

curveTo(double, double, double, double, double, double) - Method in class java.awt.geom. Path2D

通过绘制与当前坐标和指定坐标 (x3,y3)相交的BÃ©zier曲线，使用指定点 (x1,y1)和 (x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。

curveTo(double, double, double, double, double, double) - Method in class java.awt.geom. Path2D.Double

通过绘制与当前坐标和指定坐标 (x3,y3)相交的Bézier曲线，使用指定点 (x1,y1)和 (x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。

curveTo(double, double, double, double, double, double) - Method in class java.awt.geom. Path2D.Float

通过绘制与当前坐标和指定坐标 (x3,y3)相交的Bézier曲线，使用指定点 (x1,y1)和 (x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。

curveTo(float, float, float, float, float, float) - Method in class java.awt.geom. Path2D.Float

通过使用指定点 (x1,y1)和 (x2,y2)作为BÃzier控制点 (x1,y1)与当前坐标和指定坐标 (x3,y3)相交的Bézier曲线，将一个由三个新点定义的曲线段添加到路径。

CUSTOM_CURSOR - Static variable in class java.awt. Cursor

与所有自定义光标相关联的类型。

CUSTOM_DIALOG - Static variable in class javax.swing. JFileChooser

键入值，表示 JFileChooser支持开发人员指定的文件操作。

CUSTOM_RENDERED_CUSTOM - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“CustomRendered”标签一起使用的值。

CUSTOM_RENDERED_NORMAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“CustomRendered”标签一起使用的值。

Customizer - Interface in java.beans

定制器类提供了一个完整的自定义GUI来定制目标Java Bean。

CustomMarshal - Interface in org.omg.CORBA

意图由ORB使用的抽象值类型，而不是用户。

CustomMenuItem - Class in javafx.scene.control

A MenuItem允许通过为content属性分配一个Node来嵌入其中的任意节点。

CustomMenuItem() - Constructor for class javafx.scene.control. CustomMenuItem

创建默认的CustomMenuItem实例。

CustomMenuItem(Node) - Constructor for class javafx.scene.control. CustomMenuItem

构造一个CustomMenuItem并使用指定的节点初始化其内容。

CustomMenuItem(Node, boolean) - Constructor for class javafx.scene.control. CustomMenuItem

构造一个CustomMenuItem并将内容设置为指定的节点。

CustomValue - Interface in org.omg.CORBA.portable

由自定义值类型实现的扩展名为 ValueBase 。

cut() - Method in class javafx.scene.control. PasswordField

PasswordField什么也不做。

cut() - Method in class javafx.scene.control. TextInputControl

将文本中当前选定的范围传输到剪贴板，删除当前选择。

cut() - Method in class javax.swing. JPasswordField

对当前的外观和感觉调用 provideErrorFeedback ，通常会发出一个错误提示音。

cut() - Method in class javax.swing.text. JTextComponent

将相关文本模型中当前选定的范围传输到系统剪贴板，从模型中删除内容。

cut(int, int) - Method in interface javax.accessibility. AccessibleEditableText

将两个索引之间的文本剪切到系统剪贴板中。

cut(int, int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

将两个索引之间的文本剪切到系统剪贴板中。

cut(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

将两个索引之间的文本剪切到系统剪贴板中。

CUT - javafx.scene.input. KeyCode

常数为 Cut键。

CUT - javafx.scene.web. HTMLEditorSkin.Command

cutAction - Static variable in class javax.swing.text. DefaultEditorKit

要剪切所选区域并将内容放入系统剪贴板的操作名称。

CutAction() - Constructor for class javax.swing.text. DefaultEditorKit.CutAction

使用相应的标识符创建此对象。

cxt - Variable in exception org.omg.CosNaming.NamingContextPackage. CannotProceed

cyan - Static variable in class java.awt. Color

颜色青色。

CYAN - Static variable in class java.awt. Color

颜色青色。

CYAN - Static variable in class javafx.scene.paint. Color

颜色青色，RGB值为＃00FFFF

cycleCountProperty() - Method in class javafx.animation. Animation

定义此动画中的循环次数。

cycleCountProperty() - Method in class javafx.scene.media. AudioClip

调用 AudioClip.play()时播放剪辑的次数。

cycleCountProperty() - Method in class javafx.scene.media. MediaPlayer

媒体播放的次数。

cycleDurationProperty() - Method in class javafx.animation. Animation

用于指示 Animation的一个周期持续时间的只读变量：从时间0到动画结束所需的时间（默认为 rate为1.0）。

cycleDurationProperty() - Method in class javafx.scene.media. MediaPlayer

这个玩家的 startTime和 stopTime之间的时间量。

CycleMethod - Enum in javafx.scene.paint

该枚举定义了以下方法梯度边界之外绘制时使用的一个： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。

CyclicBarrier - Class in java.util.concurrent

允许一组线程全部等待彼此达到共同屏障点的同步辅助。

CyclicBarrier(int) - Constructor for class java.util.concurrent. CyclicBarrier

创建一个新的 CyclicBarrier ，当给定数量的党（线程）等待它时，它将跳闸，并且当屏障跳闸时不执行预定义的动作。

CyclicBarrier(int, Runnable) - Constructor for class java.util.concurrent. CyclicBarrier

创建一个新的 CyclicBarrier ，当给定数量的线程（线程）等待时，它将跳闸，当屏障跳闸时执行给定的屏障动作，由最后一个线程进入屏障执行。

Cylinder - Class in javafx.scene.shape

Cylinder类定义了具有指定大小的三维圆柱体。

Cylinder() - Constructor for class javafx.scene.shape. Cylinder

创建半径为1.0的高度为2.0的新实例 Cylinder 。

Cylinder(double, double) - Constructor for class javafx.scene.shape. Cylinder

创建给定半径和高度的新实例 Cylinder 。

Cylinder(double, double, int) - Constructor for class javafx.scene.shape. Cylinder

创建给定半径，高度和分割的新实例 Cylinder 。

CYPRIOT - java.lang. Character.UnicodeScript

Unicode脚本“塞浦路斯”。

CYPRIOT_SYLLABARY - Static variable in class java.lang. Character.UnicodeBlock

“塞浦路字母”Unicode字符块的常数。

CYRILLIC - java.lang. Character.UnicodeScript

Unicode脚本“西里尔文”。

CYRILLIC - Static variable in class java.lang. Character.UnicodeBlock

“西里尔”Unicode字符块的常数。

CYRILLIC_EXTENDED_A - Static variable in class java.lang. Character.UnicodeBlock

“西里尔扩展A”Unicode字符块的常量。

CYRILLIC_EXTENDED_B - Static variable in class java.lang. Character.UnicodeBlock

“西里尔扩展B”Unicode字符块的常量。

CYRILLIC_SUPPLEMENTARY - Static variable in class java.lang. Character.UnicodeBlock

“西里尔语补充”Unicode字符块的常数。

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

Report a bug or suggest an enhancement


D-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

D

D - javafx.scene.input. KeyCode
常数为 D键。
D - Static variable in class java.awt. PageAttributes.MediaType
Engineering D的MediaType实例，22 x 34 in。
D - Static variable in class javax.print.attribute.standard. MediaSize.Engineering
指定工程D尺寸，22英寸×34英寸。
D - Static variable in class javax.print.attribute.standard. MediaSizeName
D尺寸。
damage(Rectangle) - Method in class javax.swing.text. DefaultCaret
损坏插入符号周围的区域，使其在新的位置重画。
damageLineRange(int, int, Shape, Component) - Method in class javax.swing.text. PlainView
重复给定行范围。
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.basic. BasicTextUI
导致部分视图对模型的给定部分负责。
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.multi. MultiTextUI
在此对象处理的每个UI上调用 damageRange方法。
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf. TextUI
导致部分视图对模型的给定部分负责。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.basic. BasicTextUI
导致部分视图对模型的给定部分负责。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.multi. MultiTextUI
在此对象处理的每个UI上调用 damageRange方法。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf. TextUI
导致部分视图对模型的给定部分负责。
DARK - Static variable in class javax.swing.plaf.metal. MetalIconFactory
DARK用于财产 Tree.expandedIcon 。
DARK_GRAY - Static variable in class java.awt. Color
颜色深灰色。
DARKBLUE - Static variable in class javafx.scene.paint. Color
颜色深蓝色，RGB值为＃00008B
DARKCYAN - Static variable in class javafx.scene.paint. Color
颜色深蓝色，RGB值为＃008B8B
DARKEN - javafx.scene.effect. BlendMode
选择来自两个输入的颜色分量较暗以产生所得颜色。
darker() - Method in class java.awt. Color
创建一个新的 Color这是一个较深的版本的这个 Color 。
darker() - Method in class javafx.scene.paint. Color
创建一个这种颜色较暗版本的新颜色。
DARKGOLDENROD - Static variable in class javafx.scene.paint. Color
颜色深黄色，RGB值为＃B8860B
darkGray - Static variable in class java.awt. Color
颜色深灰色。
DARKGRAY - Static variable in class javafx.scene.paint. Color
颜色深灰色，RGB值为＃A9A9A9
DARKGREEN - Static variable in class javafx.scene.paint. Color
颜色深绿色，RGB值为＃006400
DARKGREY - Static variable in class javafx.scene.paint. Color
颜色深灰色，RGB值为＃A9A9A9
DARKKHAKI - Static variable in class javafx.scene.paint. Color
颜色深色卡其色，RGB值为＃BDB76B
DARKMAGENTA - Static variable in class javafx.scene.paint. Color
RGB值为＃8B008B的深色洋红色
DARKOLIVEGREEN - Static variable in class javafx.scene.paint. Color
颜色深绿橄榄绿，RGB值为＃556B2F
DARKORANGE - Static variable in class javafx.scene.paint. Color
颜色深橙色，RGB值为＃FF8C00
DARKORCHID - Static variable in class javafx.scene.paint. Color
颜色深蓝色，RGB值为＃9932CC
DARKRED - Static variable in class javafx.scene.paint. Color
颜色深红色，RGB值为＃8B0000
DARKSALMON - Static variable in class javafx.scene.paint. Color
颜色深色鲑鱼，RGB值为＃E9967A
DARKSEAGREEN - Static variable in class javafx.scene.paint. Color
颜色深绿色，RGB值为＃8FBC8F
darkShadow - Variable in class javax.swing.plaf.basic. BasicBorders.ButtonBorder
阴影的颜色。
darkShadow - Variable in class javax.swing.plaf.basic. BasicBorders.FieldBorder
阴影的颜色。
darkShadow - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
暗影色
darkShadowColor - Static variable in class javax.swing.plaf.metal. MetalSliderUI
阴影的颜色。
DARKSLATEBLUE - Static variable in class javafx.scene.paint. Color
颜色深蓝色，RGB值为＃483D8B
DARKSLATEGRAY - Static variable in class javafx.scene.paint. Color
颜色深灰色，RGB值为＃2F4F4F
DARKSLATEGREY - Static variable in class javafx.scene.paint. Color
颜色深灰色，RGB值为＃2F4F4F
DARKTURQUOISE - Static variable in class javafx.scene.paint. Color
颜色深蓝绿色，RGB值为＃00CED1
DARKVIOLET - Static variable in class javafx.scene.paint. Color
颜色深紫色，RGB值为＃9400D3
DASH_PUNCTUATION - Static variable in class java.lang. Character
Unicode规范中的一般类别“Pd”。
DASHED - Static variable in class javafx.scene.layout. BorderStrokeStyle
用于抚摸的预定义虚线图案
data - Variable in class javax.sound.midi. MidiMessage
MIDI信息数据。
data - Variable in class javax.swing.text.html.parser. Element
用于存储用户数据的字段。
data - Variable in class javax.swing.text.html.parser. Entity
char数组的数组。
Data - Interface in javax.xml.crypto
取消引用URIReference或后续Transform的输入/输出的结果的抽象表示。
Data() - Constructor for class javafx.scene.chart. XYChart.Data
创建一个空XYChart.Data对象。
Data(String, double) - Constructor for class javafx.scene.chart. PieChart.Data
构造具有给定名称和值的PieChart.Data对象。
Data(X, Y) - Constructor for class javafx.scene.chart. XYChart.Data
创建一个XYChart.Data对象的实例，并初始化X，Y数据值。
Data(X, Y, Object) - Constructor for class javafx.scene.chart. XYChart.Data
创建XYChart.Data对象的实例，并初始化X，Y数据值和extraValue。
DATA - Static variable in class javax.swing.text.html. HTML.Attribute
属性“数据”
DATA_CONVERSION - Exception in org.omg.CORBA
如果ORB无法将封送的数据的表示形式转换为其本机表示形式，反之亦然，则会引发此异常。
DATA_CONVERSION() - Constructor for exception org.omg.CORBA. DATA_CONVERSION
构造一个 DATA_CONVERSION异常，默认次要代码为0，完成状态为COMPLETED_NO。
DATA_CONVERSION(int, CompletionStatus) - Constructor for exception org.omg.CORBA. DATA_CONVERSION
构造具有指定的次要代码和完成状态的 DATA_CONVERSION异常。
DATA_CONVERSION(String) - Constructor for exception org.omg.CORBA. DATA_CONVERSION
构造具有指定详细信息的 DATA_CONVERSION异常。
DATA_CONVERSION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. DATA_CONVERSION
构造具有指定的详细信息，次要代码和完成状态的 DATA_CONVERSION异常。
DATA_TRANSFER_COMPLETE - Static variable in class javax.print.event. PrintJobEvent
该作业不一定要打印出来，但数据已经从客户端成功转移到打印服务。
DatabaseMetaData - Interface in java.sql
关于整个数据库的综合信息。
DataBindingException - Exception in javax.xml.bind
表示JAXB操作失败的异常。
DataBindingException(String, Throwable) - Constructor for exception javax.xml.bind. DataBindingException
DataBindingException(Throwable) - Constructor for exception javax.xml.bind. DataBindingException
dataBuffer - Variable in class java.awt.image. Raster
DataBuffer存储图像数据。
DataBuffer - Class in java.awt.image
此类存在用于包装一个或多个数据数组。
DataBuffer(int, int) - Constructor for class java.awt.image. DataBuffer
构造一个包含指定数据类型和大小的一行的DataBuffer。
DataBuffer(int, int, int) - Constructor for class java.awt.image. DataBuffer
构造一个包含指定数量的存储区的DataBuffer。
DataBuffer(int, int, int, int) - Constructor for class java.awt.image. DataBuffer
构造包含指定数量的存储区的DataBuffer。
DataBuffer(int, int, int, int[]) - Constructor for class java.awt.image. DataBuffer
构造一个包含指定数量的存储区的DataBuffer。
DataBufferByte - Class in java.awt.image
该类扩展了 DataBuffer并将数据内部存储为字节。
DataBufferByte(byte[][], int) - Constructor for class java.awt.image. DataBufferByte
使用指定的数组构造一个基于字节的 DataBuffer 。
DataBufferByte(byte[][], int, int[]) - Constructor for class java.awt.image. DataBufferByte
使用指定的数组，大小和偏移构造一个基于字节的 DataBuffer 。
DataBufferByte(byte[], int) - Constructor for class java.awt.image. DataBufferByte
使用指定的数组构造一个基于字节的 DataBuffer与一个单独的库。
DataBufferByte(byte[], int, int) - Constructor for class java.awt.image. DataBufferByte
使用指定的数组，大小和偏移构造一个基于字节的 DataBuffer与单个库。
DataBufferByte(int) - Constructor for class java.awt.image. DataBufferByte
构造一个基于字节的 DataBuffer与单个银行和指定的大小。
DataBufferByte(int, int) - Constructor for class java.awt.image. DataBufferByte
构造一个基于字节的 DataBuffer ，其中指定数量的库都是指定的大小。
DataBufferDouble - Class in java.awt.image
该类扩展了 DataBuffer并在 double内部存储数据。
DataBufferDouble(double[][], int) - Constructor for class java.awt.image. DataBufferDouble
构造一个基于 double的 DataBuffer与指定的数据数组。
DataBufferDouble(double[][], int, int[]) - Constructor for class java.awt.image. DataBufferDouble
构造一个基于 double的 DataBuffer其中包含指定的数据数组，大小和每个组的偏移量。
DataBufferDouble(double[], int) - Constructor for class java.awt.image. DataBufferDouble
使用指定的数据数组构造一个基于 double的 DataBuffer 。
DataBufferDouble(double[], int, int) - Constructor for class java.awt.image. DataBufferDouble
使用指定的数据数组构造一个基于 double的 DataBuffer 。
DataBufferDouble(int) - Constructor for class java.awt.image. DataBufferDouble
构造一个 double的 DataBuffer ，具有指定的大小。
DataBufferDouble(int, int) - Constructor for class java.awt.image. DataBufferDouble
构建一个基于 double的 DataBuffer ，其中指定数量的银行都是指定的大小。
DataBufferFloat - Class in java.awt.image
该类扩展了 DataBuffer并以 float形式存储数据。
DataBufferFloat(float[][], int) - Constructor for class java.awt.image. DataBufferFloat
构造一个基于 float的 DataBuffer与指定的数据数组。
DataBufferFloat(float[][], int, int[]) - Constructor for class java.awt.image. DataBufferFloat
构造一个基于 float的 DataBuffer其中包含指定的数据数组，大小和每个库的偏移量。
DataBufferFloat(float[], int) - Constructor for class java.awt.image. DataBufferFloat
构造一个基于 float的 DataBuffer与指定的数据数组。
DataBufferFloat(float[], int, int) - Constructor for class java.awt.image. DataBufferFloat
构造一个基于 float的 DataBuffer与指定的数据数组。
DataBufferFloat(int) - Constructor for class java.awt.image. DataBufferFloat
构造具有指定大小的 float基于 DataBuffer 。
DataBufferFloat(int, int) - Constructor for class java.awt.image. DataBufferFloat
构建一个基于 float的 DataBuffer ，其中指定数量的银行都是指定的大小。
DataBufferInt - Class in java.awt.image
该类扩展了 DataBuffer并将数据内部存储为整数。
DataBufferInt(int) - Constructor for class java.awt.image. DataBufferInt
构造一个基于整数的 DataBuffer与单个银行和指定的大小。
DataBufferInt(int[][], int) - Constructor for class java.awt.image. DataBufferInt
使用指定的数组构造一个基于整数的 DataBuffer 。
DataBufferInt(int[][], int, int[]) - Constructor for class java.awt.image. DataBufferInt
使用指定的数组，大小和偏移量构造一个基于整数的 DataBuffer 。
DataBufferInt(int[], int) - Constructor for class java.awt.image. DataBufferInt
使用指定的数组构造一个基于整数的 DataBuffer与单个银行。
DataBufferInt(int[], int, int) - Constructor for class java.awt.image. DataBufferInt
使用指定的数组，大小和偏移量，使用单个库构造一个基于整数的 DataBuffer 。
DataBufferInt(int, int) - Constructor for class java.awt.image. DataBufferInt
构造一个基于整数的 DataBuffer ，其中指定的银行数量，都是指定的大小。
DataBufferShort - Class in java.awt.image
该类扩展了 DataBuffer并将数据内部存储为 DataBuffer 。
DataBufferShort(int) - Constructor for class java.awt.image. DataBufferShort
构建一个基于短期的 DataBuffer与单个银行和指定的大小。
DataBufferShort(int, int) - Constructor for class java.awt.image. DataBufferShort
构造一个基于短期的 DataBuffer ，其中指定数量的银行都是指定的大小。
DataBufferShort(short[][], int) - Constructor for class java.awt.image. DataBufferShort
使用指定的数组构造一个基于短基的 DataBuffer 。
DataBufferShort(short[][], int, int[]) - Constructor for class java.awt.image. DataBufferShort
构造一个基于指定的数组，大小和偏移量的基于短基的 DataBuffer 。
DataBufferShort(short[], int) - Constructor for class java.awt.image. DataBufferShort
使用指定的数组构建一个基于短基的 DataBuffer与单个银行。
DataBufferShort(short[], int, int) - Constructor for class java.awt.image. DataBufferShort
使用指定的数组，大小和偏移量，使用单个库构建基于短基的 DataBuffer 。
DataBufferUShort - Class in java.awt.image
此类扩展了 DataBuffer并将数据内部存储为短裤。
DataBufferUShort(int) - Constructor for class java.awt.image. DataBufferUShort
构造一个无符号短基于 DataBuffer与单个银行和指定的大小。
DataBufferUShort(int, int) - Constructor for class java.awt.image. DataBufferUShort
构造一个无符号短基于 DataBuffer与指定数量的银行，所有这些都是指定的大小。
DataBufferUShort(short[][], int) - Constructor for class java.awt.image. DataBufferUShort
使用指定的数组构造一个无符号短基的 DataBuffer 。
DataBufferUShort(short[][], int, int[]) - Constructor for class java.awt.image. DataBufferUShort
构造具有指定数组，大小和偏移量的无符号短基于 DataBuffer 。
DataBufferUShort(short[], int) - Constructor for class java.awt.image. DataBufferUShort
构造一个无符号短基于 DataBuffer与单个银行使用指定的数组。
DataBufferUShort(short[], int, int) - Constructor for class java.awt.image. DataBufferUShort
使用指定的数组，大小和偏移量构建一个无符号短基于 DataBuffer的单个存储区。
DataContentHandler - Interface in javax.activation
DataContentHandler接口由可用于扩展DataHandler实现可传输接口的功能的对象实现。
DataContentHandlerFactory - Interface in javax.activation
此接口为 DataContentHandlers定义了一个工厂。
dataDefinitionCausesTransactionCommit() - Method in interface java.sql. DatabaseMetaData
检索事务中的数据定义语句是否强制事务提交。
dataDefinitionIgnoredInTransactions() - Method in interface java.sql. DatabaseMetaData
检索此数据库是否忽略事务中的数据定义语句。
DataFlavor - Class in java.awt.datatransfer
A DataFlavor提供有关数据的元信息。
DataFlavor() - Constructor for class java.awt.datatransfer. DataFlavor
构造新的 DataFlavor 。
DataFlavor(Class<?>, String) - Constructor for class java.awt.datatransfer. DataFlavor
构造一个表示Java类的 DataFlavor 。
DataFlavor(String) - Constructor for class java.awt.datatransfer. DataFlavor
从 mimeType字符串构造一个 DataFlavor 。
DataFlavor(String, String) - Constructor for class java.awt.datatransfer. DataFlavor
构造一个 DataFlavor代表一个 MimeType 。
DataFlavor(String, String, ClassLoader) - Constructor for class java.awt.datatransfer. DataFlavor
构造一个 DataFlavor ，代表一个 MimeType 。
DataFormat - Class in javafx.scene.input
数据格式标识符用作识别存储在剪贴板/拖板上的数据的手段。
DataFormat(String...) - Constructor for class javafx.scene.input. DataFormat
创建一个新的DataFormat，指定与此数据格式相关联的ids集。
DataFormatException - Exception in java.util.zip
发出数据格式错误的信号。
DataFormatException() - Constructor for exception java.util.zip. DataFormatException
构造一个没有详细消息的DataFormatException。
DataFormatException(String) - Constructor for exception java.util.zip. DataFormatException
构造具有指定详细消息的DataFormatException。
DatagramChannel - Class in java.nio.channels
面向数据报的套接字的可选通道。
DatagramChannel(SelectorProvider) - Constructor for class java.nio.channels. DatagramChannel
初始化此类的新实例。
DatagramPacket - Class in java.net
该类表示数据报包。
DatagramPacket(byte[], int) - Constructor for class java.net. DatagramPacket
构造一个 DatagramPacket用于接收长度为 length数据包。
DatagramPacket(byte[], int, int) - Constructor for class java.net. DatagramPacket
构造一个 DatagramPacket用于接收长度为 length数据包，指定缓冲区中的偏移量。
DatagramPacket(byte[], int, int, InetAddress, int) - Constructor for class java.net. DatagramPacket
构造一个数据报包，用于发送长度为 length的数据包，偏移量为 ioffset到指定主机上的指定端口号。
DatagramPacket(byte[], int, int, SocketAddress) - Constructor for class java.net. DatagramPacket
构造一个数据报包，用于发送长度为 length的数据包，偏移量为 ioffset到指定主机上的指定端口号。
DatagramPacket(byte[], int, InetAddress, int) - Constructor for class java.net. DatagramPacket
构建数据报包，将数据包长度为 length ，发送到指定主机上的指定端口号。
DatagramPacket(byte[], int, SocketAddress) - Constructor for class java.net. DatagramPacket
构造一个数据报包，用于发送指定主机上指定端口号的长度为 length的数据包。
DatagramSocket - Class in java.net
此类表示用于发送和接收数据报数据包的套接字。
DatagramSocket() - Constructor for class java.net. DatagramSocket
构造数据报套接字并将其绑定到本地主机上的任何可用端口。
DatagramSocket(int) - Constructor for class java.net. DatagramSocket
构造数据报套接字并将其绑定到本地主机上的指定端口。
DatagramSocket(int, InetAddress) - Constructor for class java.net. DatagramSocket
创建一个数据报套接字，绑定到指定的本地地址。
DatagramSocket(DatagramSocketImpl) - Constructor for class java.net. DatagramSocket
使用指定的DatagramSocketImpl创建一个未绑定的数据报套接字。
DatagramSocket(SocketAddress) - Constructor for class java.net. DatagramSocket
创建一个数据报套接字，绑定到指定的本地套接字地址。
DatagramSocketImpl - Class in java.net
抽象数据报和组播套接字实现基类。
DatagramSocketImpl() - Constructor for class java.net. DatagramSocketImpl
DatagramSocketImplFactory - Interface in java.net
该接口为数据报套接字实现定义了一个工厂。
DataHandler - Class in javax.activation
DataHandler类为许多不同来源和格式的数据提供了一致的界面。
DataHandler(Object, String) - Constructor for class javax.activation. DataHandler
创建一个表示此MIME类型对象的 DataHandler实例。
DataHandler(URL) - Constructor for class javax.activation. DataHandler
创建引用URL的 DataHandler实例。
DataHandler(DataSource) - Constructor for class javax.activation. DataHandler
创建引用指定的DataSource的 DataHandler实例。
DataInput - Interface in java.io
DataInput接口提供从二进制流读取字节并从其中重建任何Java原语类型的数据。
DataInputStream - Class in java.io
数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
DataInputStream - Interface in org.omg.CORBA
定义用于从输入流读取原始数据类型的方法，以解除对自定义值类型的调整。
DataInputStream(InputStream) - Constructor for class java.io. DataInputStream
创建使用指定的底层InputStream的DataInputStream。
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. AreaChart
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. BarChart
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. BubbleChart
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. LineChart
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. ScatterChart
将数据项添加到系列时调用。
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. StackedAreaChart
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. StackedBarChart
dataItemAdded(XYChart.Series<X, Y>, int, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart
将数据项添加到系列时调用。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. AreaChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. BarChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. BubbleChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. LineChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. ScatterChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. StackedAreaChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. StackedBarChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemChanged(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart
数据项已更改时调用，即其xValue，yValue或extraValue已更改。
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. AreaChart
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. BarChart
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. BubbleChart
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. LineChart
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. ScatterChart
当数据项已从数据模型中删除但在图表上仍然可见时调用。
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. StackedAreaChart
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. StackedBarChart
dataItemRemoved(XYChart.Data<X, Y>, XYChart.Series<X, Y>) - Method in class javafx.scene.chart. XYChart
当数据项已从数据模型中删除但在图表上仍然可见时调用。
DataLine - Interface in javax.sound.sampled
DataLine添加媒体相关功能， Line 。
DataLine.Info - Class in javax.sound.sampled
除了从其超类继承的类信息， DataLine.Info还提供了特定于数据行的附加信息。
DATALINK - java.sql. JDBCType
标识通用SQL类型 DATALINK 。
DATALINK - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DATALINK 。
dataModel - Variable in class javax.swing. JComboBox
此保护字段是实现特定的。
dataModel - Variable in class javax.swing. JTable
表中的 TableModel 。
DataOutput - Interface in java.io
DataOutput接口提供将数据从任何Java基本类型转换为一系列字节，并将这些字节写入二进制流。
DataOutputStream - Class in java.io
数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
DataOutputStream - Interface in org.omg.CORBA
定义用于将原始数据类型写入到编组自定义值类型的输出流中的方法。
DataOutputStream(OutputStream) - Constructor for class java.io. DataOutputStream
创建一个新的数据输出流，以将数据写入指定的底层输出流。
dataProperty() - Method in class javafx.scene.chart. PieChart
PieCharts数据
dataProperty() - Method in class javafx.scene.chart. XYChart
XYCharts数据
dataProperty() - Method in class javafx.scene.chart. XYChart.Series
ObservableList组成本系列的数据项
DataSource - Interface in javax.activation
DataSource接口为JavaBean激活框架提供了任意数据集合的抽象。
DataSource - Interface in javax.sql
连接到 DataSource对象所代表的物理数据源的工厂。
DATASOURCE_DB_LOCK - Static variable in class javax.sql.rowset.spi. SyncProvider
表示在作为使用此 SyncProvider对象的 RowSet对象的数据源的整个数据源上放置锁定。
DATASOURCE_NO_LOCK - Static variable in class javax.sql.rowset.spi. SyncProvider
表示始发数据源上没有锁。
DATASOURCE_ROW_LOCK - Static variable in class javax.sql.rowset.spi. SyncProvider
表示锁定位于用于填充正在使用此 SyncProvider对象的 RowSet对象的原始SQL语句所触及的行上。
DATASOURCE_TABLE_LOCK - Static variable in class javax.sql.rowset.spi. SyncProvider
表示在用于填充正在使用此 SyncProvider对象的 RowSet对象的原始SQL语句所触及的所有表上都会放置一个锁。
DataTruncation - Exception in java.sql
由于其超出 MaxFieldSize原因导致数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取）。
DataTruncation(int, boolean, boolean, int, int) - Constructor for exception java.sql. DataTruncation
创建一个 DataTruncation对象，其中SQLState初始化为01004，当 read设置为 true ，22001当 read设置为 false ，原因设置为“数据截断”，供应商代码设置为0，其他字段设置为给定值。
DataTruncation(int, boolean, boolean, int, int, Throwable) - Constructor for exception java.sql. DataTruncation
创建 DataTruncation与初始化为01004时的SQLState对象 read设定为 true时和22001 read设定为 false ，设置为“数据截断”，供应商代码设置为0的原因，而其他字段被设置为给定值。
dataType - Variable in class java.awt.image. DataBuffer
DataBuffer的数据类型。
dataType - Variable in class java.awt.image. SampleModel
存储像素数据的DataBuffer的数据类型。
DATATYPE_BOOLEAN - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getAttributeDataType返回的 getAttributeDataType表示属性的值是布尔值“true”或“false”之一。
DATATYPE_DOUBLE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getAttributeDataType返回的 getAttributeDataType表示属性的值是双精度十进制浮点数的字符串表示形式。
DATATYPE_FLOAT - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getAttributeDataType返回的 getAttributeDataType表示属性的值是十进制浮点数的字符串表示形式。
DATATYPE_INTEGER - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
由 getAttributeDataType返回的 getAttributeDataType指示属性的值是整数的字符串表示形式。
DATATYPE_STRING - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getAttributeDataType返回的 getAttributeDataType表示属性的值是一般的Unicode字符串。
DatatypeConfigurationException - Exception in javax.xml.datatype
表示严重的配置错误。
DatatypeConfigurationException() - Constructor for exception javax.xml.datatype. DatatypeConfigurationException
创建一个新的 DatatypeConfigurationException ，没有指定的详细信息和原因。
DatatypeConfigurationException(String) - Constructor for exception javax.xml.datatype. DatatypeConfigurationException
使用指定的详细消息创建一个新的 DatatypeConfigurationException 。
DatatypeConfigurationException(String, Throwable) - Constructor for exception javax.xml.datatype. DatatypeConfigurationException
创建一个新的 DatatypeConfigurationException具有指定的详细信息和原因。
DatatypeConfigurationException(Throwable) - Constructor for exception javax.xml.datatype. DatatypeConfigurationException
创建一个新的 DatatypeConfigurationException与指定的原因。
DatatypeConstants - Class in javax.xml.datatype
包含基本数据类型值作为常量的实用程序类。
DatatypeConstants.Field - Class in javax.xml.datatype
类型安全的枚举类，表示Duration类的六个字段。
DatatypeConverter - Class in javax.xml.bind
可以使用javaType绑定声明来自定义XML模式数据类型与Java数据类型的绑定。
DatatypeConverterInterface - Interface in javax.xml.bind
DatatypeConverterInterface仅供JAXB提供者使用。
DatatypeFactory - Class in javax.xml.datatype
创建新的 javax.xml.datatype Object的工厂，将XML映射到/从Java Object s。
DatatypeFactory() - Constructor for class javax.xml.datatype. DatatypeFactory
受保护的构造函数以防止程序包外的实例化。
DATATYPEFACTORY_IMPLEMENTATION_CLASS - Static variable in class javax.xml.datatype. DatatypeFactory
JSR 206中定义的默认实现类名称 ：用于XML处理的Java（TM）API（JAXP）1.3 。
DATATYPEFACTORY_PROPERTY - Static variable in class javax.xml.datatype. DatatypeFactory
JSR 206中定义的默认属性名称：用于XML处理的Java（TM）API（JAXP）1.3。
dataVector - Variable in class javax.swing.table. DefaultTableModel
Vector Vectors的 Object值。
date(int, int, int) - Method in interface java.time.chrono. Chronology
从年龄，月份和月份月份获取本年度的年表。
date(int, int, int) - Method in class java.time.chrono. HijrahChronology
在Hijrah日历系统中，从幼稚年份，月份和月份月份获取当地日期。
date(int, int, int) - Method in class java.time.chrono. IsoChronology
从月度，月份和月份月份获取ISO本地日期。
date(int, int, int) - Method in class java.time.chrono. JapaneseChronology
从日光年，月 - 日和日月份获取日本日历系统的当地日期。
date(int, int, int) - Method in class java.time.chrono. MinguoChronology
从月光年，月和月的月份中获取Minguo日历系统中的当地日期。
date(int, int, int) - Method in class java.time.chrono. ThaiBuddhistChronology
在泰国佛教日历系统中，从幼稚年份，月份和月份月份获取当地日期。
date(Era, int, int, int) - Method in interface java.time.chrono. Chronology
从这个时代，年龄，月份和月份的时代获得这个年表的当地日期。
date(Era, int, int, int) - Method in class java.time.chrono. HijrahChronology
从Hijrah日历系统的时代，年龄，月份和月份月份获取当地的日期。
date(Era, int, int, int) - Method in class java.time.chrono. IsoChronology
从时代，年龄，月份和月份的时代获得ISO本地日期。
date(Era, int, int, int) - Method in class java.time.chrono. JapaneseChronology
从日期，时代，月份和月份的时代，获取日本日历系统中的当地日期。
date(Era, int, int, int) - Method in class java.time.chrono. MinguoChronology
从时代，年龄，月份和月份的时代，获得Minguo日历系统中的当地日期。
date(Era, int, int, int) - Method in class java.time.chrono. ThaiBuddhistChronology
从时代，年龄，月份和月份的时代，获得泰国佛教日历系统的当地日期。
date(TemporalAccessor) - Method in interface java.time.chrono. Chronology
从另一个时间对象获取本年龄的本地日期。
date(TemporalAccessor) - Method in class java.time.chrono. HijrahChronology
date(TemporalAccessor) - Method in class java.time.chrono. IsoChronology
从另一个日期时间对象获取ISO本地日期。
date(TemporalAccessor) - Method in class java.time.chrono. JapaneseChronology
date(TemporalAccessor) - Method in class java.time.chrono. MinguoChronology
date(TemporalAccessor) - Method in class java.time.chrono. ThaiBuddhistChronology
Date - Class in java.sql
一个薄的包装器，大约有一个毫秒值，允许JDBC将其标识为SQL DATE值。
Date - Class in java.util
Date类代表一个特定的时间，具有毫秒精度。
Date() - Constructor for class java.util. Date
分配一个 Date对象，并初始化它，以便它表示分配的时间，测量到最近的毫秒。
Date(int, int, int) - Constructor for class java.sql. Date
已过时。
而是使用构造函数Date(long date)
Date(int, int, int) - Constructor for class java.util. Date
已过时。
从JDK 1.1版开始，由Calendar.set(year + 1900, month, date)或GregorianCalendar(year + 1900, month, date) 。
Date(int, int, int, int, int) - Constructor for class java.util. Date
已过时。
从JDK 1.1版开始，替换为Calendar.set(year + 1900, month, date, hrs, min)或GregorianCalendar(year + 1900, month, date, hrs, min) 。
Date(int, int, int, int, int, int) - Constructor for class java.util. Date
已过时。
从JDK 1.1版开始，替换为Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec) 。
Date(long) - Constructor for class java.sql. Date
使用给定的毫秒时间值构造一个 Date对象。
Date(long) - Constructor for class java.util. Date
分配一个 Date对象，并将其初始化为表示从标准基准时间（称为“时代”）即1970年1月1日00:00:00 GMT起的指定毫秒数。
Date(String) - Constructor for class java.util. Date
已过时。
从JDK 1.1版开始，由DateFormat.parse(String s)替代。
DATE - java.sql. JDBCType
标识通用SQL类型 DATE 。
DATE - javafx.scene. AccessibleAttribute
返回节点的本地日期。
DATE - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DATE 。
DATE - Static variable in class java.util. Calendar
get字段编号和 set表示本月的日期。
DATE - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.util.Date值的 SimpleType实例。
DATE - Static variable in class javax.xml.datatype. DatatypeConstants
W3C XML Schema 1.0数据类型 date完全限定名称。
DATE_EDITOR - Static variable in class javax.accessibility. AccessibleRole
A DATE_EDITOR是允许用户编辑 java.util.Date和 java.util.Time对象的组件。
DATE_FIELD - Static variable in class java.text. DateFormat
DATE字段对齐的常用常数。
DATE_PICKER - javafx.scene. AccessibleRole
日期选择器角色。
DateCell - Class in javafx.scene.control
DateCell由DatePicker用于在日历月中呈现单个网格单元格。
DateCell() - Constructor for class javafx.scene.control. DateCell
DateCellSkin - Class in javafx.scene.control.skin
默认皮肤实现为DateCell控件。
DateCellSkin(DateCell) - Constructor for class javafx.scene.control.skin. DateCellSkin
创建一个新的DateCellSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
DateEditor(JSpinner) - Constructor for class javax.swing. JSpinner.DateEditor
构造一个 JSpinner编辑器，支持显示和编辑一个 SpinnerDateModel的值，一个 JFormattedTextField 。
DateEditor(JSpinner, String) - Constructor for class javax.swing. JSpinner.DateEditor
构造一个 JSpinner编辑器，支持显示和编辑的价值 SpinnerDateModel用 JFormattedTextField 。
dateEpochDay(long) - Method in interface java.time.chrono. Chronology
从这个时代的时代获得当地的日期。
dateEpochDay(long) - Method in class java.time.chrono. HijrahChronology
从Hijrah日历系统中获取当地的日期。
dateEpochDay(long) - Method in class java.time.chrono. IsoChronology
从时代获取ISO本地日期。
dateEpochDay(long) - Method in class java.time.chrono. JapaneseChronology
在日历日历系统中从当天获取本地日期。
dateEpochDay(long) - Method in class java.time.chrono. MinguoChronology
从时代到日本的Minguo日历系统获取本地日期。
dateEpochDay(long) - Method in class java.time.chrono. ThaiBuddhistChronology
从泰国佛教日历系统中获取当地的日期。
dateFilter(RowFilter.ComparisonType, Date, int...) - Static method in class javax.swing. RowFilter
返回一个 RowFilter ，其中包含符合指定条件的值至少有一个 Date条目。
dateFormat - Variable in class javafx.util.converter. DateTimeStringConverter
DateFormat - Class in java.text
DateFormat是一种用于日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
DateFormat() - Constructor for class java.text. DateFormat
创建一个新的日期格式。
DateFormat.Field - Class in java.text
定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
DateFormatProvider - Class in java.text.spi
提供DateFormat类的具体实现的服务提供者的抽象类。
DateFormatProvider() - Constructor for class java.text.spi. DateFormatProvider
唯一的构造函数。
DateFormatSymbols - Class in java.text
DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，星期几的名称和时区数据。
DateFormatSymbols() - Constructor for class java.text. DateFormatSymbols
通过从默认的 FORMAT区域设置的资源中加载格式数据构造一个DateFormatSymbols对象。
DateFormatSymbols(Locale) - Constructor for class java.text. DateFormatSymbols
通过从给定语言环境的资源加载格式数据构造DateFormatSymbols对象。
DateFormatSymbolsProvider - Class in java.text.spi
提供DateFormatSymbols类的实例的服务提供者的抽象类。
DateFormatSymbolsProvider() - Constructor for class java.text.spi. DateFormatSymbolsProvider
唯一的构造函数。
DateFormatter - Class in javax.swing.text
DateFormatter是一个 InternationalFormatter ，它通过 java.text.DateFormat的实例进行 java.text.DateFormat 。
DateFormatter() - Constructor for class javax.swing.text. DateFormatter
这是 new DateFormatter(DateFormat.getDateInstance())简写。
DateFormatter(DateFormat) - Constructor for class javax.swing.text. DateFormatter
返回使用指定的 Format实例配置的DateFormatter。
dateNow() - Method in interface java.time.chrono. Chronology
从默认时区的系统时钟获取此时间顺序中的当前本地日期。
dateNow() - Method in class java.time.chrono. HijrahChronology
dateNow() - Method in class java.time.chrono. IsoChronology
从默认时区的系统时钟获取当前的ISO本地日期。
dateNow() - Method in class java.time.chrono. JapaneseChronology
dateNow() - Method in class java.time.chrono. MinguoChronology
dateNow() - Method in class java.time.chrono. ThaiBuddhistChronology
dateNow(Clock) - Method in interface java.time.chrono. Chronology
从指定的时钟获取本年龄的当前本地日期。
dateNow(Clock) - Method in class java.time.chrono. HijrahChronology
dateNow(Clock) - Method in class java.time.chrono. IsoChronology
从指定的时钟获取当前的ISO本地日期。
dateNow(Clock) - Method in class java.time.chrono. JapaneseChronology
dateNow(Clock) - Method in class java.time.chrono. MinguoChronology
dateNow(Clock) - Method in class java.time.chrono. ThaiBuddhistChronology
dateNow(ZoneId) - Method in interface java.time.chrono. Chronology
从指定时区的系统时钟获取此时间顺序中的当前本地日期。
dateNow(ZoneId) - Method in class java.time.chrono. HijrahChronology
dateNow(ZoneId) - Method in class java.time.chrono. IsoChronology
从指定时区的系统时钟获取当前的ISO本地日期。
dateNow(ZoneId) - Method in class java.time.chrono. JapaneseChronology
dateNow(ZoneId) - Method in class java.time.chrono. MinguoChronology
dateNow(ZoneId) - Method in class java.time.chrono. ThaiBuddhistChronology
DatePicker - Class in javafx.scene.control
DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。
DatePicker() - Constructor for class javafx.scene.control. DatePicker
创建一个默认的DatePicker实例，其日期值为 null 。
DatePicker(LocalDate) - Constructor for class javafx.scene.control. DatePicker
创建一个DatePicker实例，并将 value设置为给定日期。
DatePickerSkin - Class in javafx.scene.control.skin
默认皮肤实现为DatePicker控件。
DatePickerSkin(DatePicker) - Constructor for class javafx.scene.control.skin. DatePickerSkin
创建一个新的DatePickerSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
DateStringConverter - Class in javafx.util.converter
StringConverter实现Date值。
DateStringConverter() - Constructor for class javafx.util.converter. DateStringConverter
使用DateFormat.DEFAULT日期风格创建Date的StringConverter值。
DateStringConverter(int) - Constructor for class javafx.util.converter. DateStringConverter
创建一个StringConverter的Date值，使用指定的DateFormat日期样式。
DateStringConverter(String) - Constructor for class javafx.util.converter. DateStringConverter
使用指定的模式为Date值创建StringConverter 。
DateStringConverter(DateFormat) - Constructor for class javafx.util.converter. DateStringConverter
使用指定的DateFormat格式化程序为Date创建一个StringConverter 。
DateStringConverter(Locale) - Constructor for class javafx.util.converter. DateStringConverter
使用指定的区域设置和DateFormat.DEFAULT日期样式为Date创建一个StringConverter值。
DateStringConverter(Locale, int) - Constructor for class javafx.util.converter. DateStringConverter
使用指定的区域设置和DateFormat日期样式为Date创建一个StringConverter值。
DateStringConverter(Locale, String) - Constructor for class javafx.util.converter. DateStringConverter
使用指定的区域设置和模式为Date值创建一个StringConverter 。
dateStyle - Variable in class javafx.util.converter. DateTimeStringConverter
datesUntil(LocalDate) - Method in class java.time. LocalDate
返回顺序排列的日期流。
datesUntil(LocalDate, Period) - Method in class java.time. LocalDate
通过给定的增量步骤返回日期的顺序排序流。
DATETIME - Static variable in class javax.xml.datatype. DatatypeConstants
W3C XML Schema 1.0数据类型 dateTime完全限定名称。
DateTimeAtCompleted - Class in javax.print.attribute.standard
类DateTimeAtCompleted是打印属性类，日期时间属性，指示打印作业完成（或被取消或中止）的日期和时间。
DateTimeAtCompleted(Date) - Constructor for class javax.print.attribute.standard. DateTimeAtCompleted
使用给定的Date值在完成的属性中构建新的日期时间。
DateTimeAtCreation - Class in javax.print.attribute.standard
类DateTimeAtCreation是一个打印属性类，一个日期时间属性，表示创建打印作业的日期和时间。
DateTimeAtCreation(Date) - Constructor for class javax.print.attribute.standard. DateTimeAtCreation
使用给定的Date值创建一个新的创建日期时间属性。
DateTimeAtProcessing - Class in javax.print.attribute.standard
类DateTimeAtProcessing是打印属性类，日期时间属性，表示打印作业首次开始处理的日期和时间。
DateTimeAtProcessing(Date) - Constructor for class javax.print.attribute.standard. DateTimeAtProcessing
在给定的Date值处理属性时构造一个新的日期时间。
DateTimeException - Exception in java.time
用于在计算日期时间时指示问题的异常。
DateTimeException(String) - Constructor for exception java.time. DateTimeException
使用指定的消息构造新的日期时间异常。
DateTimeException(String, Throwable) - Constructor for exception java.time. DateTimeException
构造一个新的日期时间异常与指定的消息和原因。
DateTimeFormatter - Class in java.time.format
格式化器用于打印和解析日期时间对象。
DateTimeFormatterBuilder - Class in java.time.format
Builder创建日期格式化程序。
DateTimeFormatterBuilder() - Constructor for class java.time.format. DateTimeFormatterBuilder
构建构建器的新实例。
DateTimeParseException - Exception in java.time.format
解析期间发生错误时抛出异常。
DateTimeParseException(String, CharSequence, int) - Constructor for exception java.time.format. DateTimeParseException
使用指定的消息构造新的异常。
DateTimeParseException(String, CharSequence, int, Throwable) - Constructor for exception java.time.format. DateTimeParseException
构造一个新的异常与指定的消息和原因。
DateTimeStringConverter - Class in javafx.util.converter
StringConverter代表日期和时间的Date值的实现。
DateTimeStringConverter() - Constructor for class javafx.util.converter. DateTimeStringConverter
为Date创建一个StringConverter值，使用DateFormat.DEFAULT样式进行日期和时间。
DateTimeStringConverter(int, int) - Constructor for class javafx.util.converter. DateTimeStringConverter
为Date创建一个StringConverter值，使用指定的DateFormat样式进行日期和时间。
DateTimeStringConverter(String) - Constructor for class javafx.util.converter. DateTimeStringConverter
使用指定的模式为Date创建一个StringConverter值。
DateTimeStringConverter(DateFormat) - Constructor for class javafx.util.converter. DateTimeStringConverter
使用DateFormat格式化程序为Date创建一个StringConverter值。
DateTimeStringConverter(Locale) - Constructor for class javafx.util.converter. DateTimeStringConverter
创建StringConverter的Date值，使用指定的区域设置和DateFormat.DEFAULT样式的日期和时间。
DateTimeStringConverter(Locale, int, int) - Constructor for class javafx.util.converter. DateTimeStringConverter
为Date创建一个Date值，使用指定的区域设置和日期和时间的DateFormat样式。
DateTimeStringConverter(Locale, String) - Constructor for class javafx.util.converter. DateTimeStringConverter
使用指定的区域设置和模式为Date值创建一个StringConverter 。
DateTimeSyntax - Class in javax.print.attribute
类DateTimeSyntax是一个抽象基类，提供值为日期和时间的所有属性的常见实现。
DateTimeSyntax(Date) - Constructor for class javax.print.attribute. DateTimeSyntax
使用给定的 java.util.Date值构造新的日期时间属性。
dateYearDay(int, int) - Method in interface java.time.chrono. Chronology
在这个年龄和年龄段的年龄中获得当地的日期。
dateYearDay(int, int) - Method in class java.time.chrono. HijrahChronology
从日光年和日间字段获取Hijrah日历系统中的当地日期。
dateYearDay(int, int) - Method in class java.time.chrono. IsoChronology
从幼稚年份和日期字段获取ISO本地日期。
dateYearDay(int, int) - Method in class java.time.chrono. JapaneseChronology
从日光年和日期字段获取日语日历系统中的当地日期。
dateYearDay(int, int) - Method in class java.time.chrono. MinguoChronology
从日光年和日期字段获取Minguo日历系统中的当地日期。
dateYearDay(int, int) - Method in class java.time.chrono. ThaiBuddhistChronology
在泰国佛教日历系统中，从幼稚年份和日期领域获得当地日期。
dateYearDay(Era, int, int) - Method in interface java.time.chrono. Chronology
从这个时代，年龄和时代的年代领域获得这个年表的当地日期。
dateYearDay(Era, int, int) - Method in class java.time.chrono. HijrahChronology
从Hijrah日历系统的时代，年龄和日期领域获得当地的日期。
dateYearDay(Era, int, int) - Method in class java.time.chrono. IsoChronology
从时代，年龄和日期的领域获得ISO本地日期。
dateYearDay(Era, int, int) - Method in class java.time.chrono. JapaneseChronology
从时代，年龄和日期领域获取日本日历系统中的当地日期。
dateYearDay(Era, int, int) - Method in class java.time.chrono. MinguoChronology
从时代，年龄和日期领域获得Minguo日历系统中的当地日期。
dateYearDay(Era, int, int) - Method in class java.time.chrono. ThaiBuddhistChronology
在泰国佛教日历系统中，从时代，年龄和日期领域获得当地日期。
DAY_OF_MONTH - java.time.temporal. ChronoField
月日。
DAY_OF_MONTH - Static variable in class java.text. DateFormat.Field
不断识别月的字段。
DAY_OF_MONTH - Static variable in class java.util. Calendar
get字段编号和 set表示该月的日期。
DAY_OF_QUARTER - Static variable in class java.time.temporal. IsoFields
代表季度的领域。
DAY_OF_WEEK - java.time.temporal. ChronoField
星期二，例如星期二。
DAY_OF_WEEK - Static variable in class java.text. DateFormat.Field
不断识别星期几的字段。
DAY_OF_WEEK - Static variable in class java.util. Calendar
字段编号为 get和 set表示星期几。
DAY_OF_WEEK_FIELD - Static variable in class java.text. DateFormat
DAY_OF_WEEK字段对齐的常用常数。
DAY_OF_WEEK_IN_MONTH - Static variable in class java.text. DateFormat.Field
不断识别星期几的字段。
DAY_OF_WEEK_IN_MONTH - Static variable in class java.util. Calendar
get字段编号和 set表示当月的星期几的序号。
DAY_OF_WEEK_IN_MONTH_FIELD - Static variable in class java.text. DateFormat
DAY_OF_WEEK_IN_MONTH字段对齐的常用常数。
DAY_OF_YEAR - java.time.temporal. ChronoField
一年的一天。
DAY_OF_YEAR - Static variable in class java.text. DateFormat.Field
常年识别日期字段。
DAY_OF_YEAR - Static variable in class java.util. Calendar
get字段编号和 set表示 set的日数。
DAY_OF_YEAR_FIELD - Static variable in class java.text. DateFormat
DAY_OF_YEAR字段对齐的常用常数。
dayCellFactoryProperty() - Method in class javafx.scene.control. DatePicker
可以提供自定义单元格工厂来自定义DatePicker弹出窗口中的单个日期单元格。
dayOfWeek() - Method in class java.time.temporal. WeekFields
根据这个 WeekFields返回一个字段来访问星期 WeekFields 。
DayOfWeek - Enum in java.time
星期几，如“星期二”。
dayOfWeekInMonth(int, DayOfWeek) - Static method in class java.time.temporal. TemporalAdjusters
返回月份调整器中的星期几，该日期将根据月份返回具有序数星期的新日期。
DAYS - java.time.temporal. ChronoUnit
代表一天概念的单位。
DAYS - java.util.concurrent. TimeUnit
时间单位代表二十四小时。
DAYS - Static variable in class javax.xml.datatype. DatatypeConstants
一个表示日期字段的常数。
dbgTag - Variable in class javax.management.monitor. Monitor
已过时。
没有替换
DD - Static variable in class javax.swing.text.html. HTML.Tag
标签<dd>
deactivate() - Method in interface javax.rmi.CORBA. Tie
取消这个领带所代表的目标对象。
deactivate(boolean) - Method in interface java.awt.im.spi. InputMethod
禁用输入法。
deactivate(boolean, boolean) - Method in interface org.omg.PortableServer. POAManagerOperations
此操作将POA管理器的状态更改为非活动状态，导致相关联的POA拒绝尚未开始执行的请求以及任何新请求。
deactivate_object(byte[]) - Method in interface org.omg.PortableServer. POAOperations
此操作会导致在oid参数中指定的ObjectId被禁用。
deactivateFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
deactivateFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager
一般来说，表明这个框架已经失焦了。
deactivateFrame(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
当不再选择帧时调用此方法。
DEAD_ABOVEDOT - javafx.scene.input. KeyCode
常数为 Dead Abovedot键。
DEAD_ABOVERING - javafx.scene.input. KeyCode
常数为 Dead Abovering键。
DEAD_ACUTE - javafx.scene.input. KeyCode
常数为 Dead Acute键。
DEAD_BREVE - javafx.scene.input. KeyCode
常数为 Dead Breve键。
DEAD_CARON - javafx.scene.input. KeyCode
常数为 Dead Caron键。
DEAD_CEDILLA - javafx.scene.input. KeyCode
常数为 Dead Cedilla键。
DEAD_CIRCUMFLEX - javafx.scene.input. KeyCode
常数为 Dead Circumflex键。
DEAD_DIAERESIS - javafx.scene.input. KeyCode
常数为 Dead Diaeresis键。
DEAD_DOUBLEACUTE - javafx.scene.input. KeyCode
常数为 Dead Doubleacute键。
DEAD_GRAVE - javafx.scene.input. KeyCode
常数为 Dead Grave键。
DEAD_IOTA - javafx.scene.input. KeyCode
常数为 Dead Iota键。
DEAD_MACRON - javafx.scene.input. KeyCode
常数为 Dead Macron键。
DEAD_OGONEK - javafx.scene.input. KeyCode
常数为 Dead Ogonek键。
DEAD_SEMIVOICED_SOUND - javafx.scene.input. KeyCode
常数为 Dead Semivoiced Sound键。
DEAD_TILDE - javafx.scene.input. KeyCode
常数为 Dead Tilde键。
DEAD_VOICED_SOUND - javafx.scene.input. KeyCode
常数为 Dead Voiced Sound键。
DEBUG - java.lang. System.Logger.Level
DEBUG级别：通常用于记录调试信息跟踪。
DEBUGGER - jdk.nashorn.api.tree. Tree.Kind
用于DebuggerTree的实例。
DebuggerTree - Interface in jdk.nashorn.api.tree
“调试器”语句的树节点。
DebugGraphics - Class in javax.swing
图形子类支持图形调试。
DebugGraphics() - Constructor for class javax.swing. DebugGraphics
构造一个支持减速绘图的新的调试图形上下文。
DebugGraphics(Graphics) - Constructor for class javax.swing. DebugGraphics
构建一个调试图形上下文从现有的图形上下文，支持减慢绘图。
DebugGraphics(Graphics, JComponent) - Constructor for class javax.swing. DebugGraphics
从现有的图形上下文中构建调试图形上下文，从而减缓指定组件的绘图。
DECADES - java.time.temporal. ChronoUnit
代表十年概念的单位。
decapitalize(String) - Static method in class java.beans. Introspector
实用方法来取一个字符串并将其转换为正常的Java变量名称大小写。
DECEMBER - java.time. Month
12月份的单身人士31天。
DECEMBER - Static variable in class java.util. Calendar
Calendar.MONTH字段的值表示公历和朱利安日历中的第十二个月。
DECEMBER - Static variable in class javax.xml.datatype. DatatypeConstants
一年十二个月的价值
DECIMAL - java.sql. JDBCType
标识通用SQL类型 DECIMAL 。
DECIMAL - javafx.scene.input. KeyCode
常数为 Decimal键。
DECIMAL - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DECIMAL 。
DECIMAL_DIGIT_NUMBER - Static variable in class java.lang. Character
Unicode规范中的一般类别“Nd”。
DECIMAL_FLOAT - java.util. Formatter.BigDecimalLayoutForm
将 BigDecimal格式化为十进制数。
DECIMAL_SEPARATOR - Static variable in class java.text. NumberFormat.Field
常数标识小数分隔符字段。
DECIMAL128 - Static variable in class java.math. MathContext
A MathContext对象，其精度设置与IEEE 754R Decimal128格式，34位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。
DECIMAL32 - Static variable in class java.math. MathContext
A MathContext对象，其精度设置与IEEE 754R Decimal32格式，7位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。
DECIMAL64 - Static variable in class java.math. MathContext
A MathContext对象，其精度设置与IEEE 754R Decimal64格式，16位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。
DecimalFormat - Class in java.text
DecimalFormat是格式为十进制数的 NumberFormat的具体子类。
DecimalFormat() - Constructor for class java.text. DecimalFormat
使用默认模式和默认的 FORMAT区域设置的符号创建一个DecimalFormat。
DecimalFormat(String) - Constructor for class java.text. DecimalFormat
使用给定的模式和默认的 FORMAT区域设置的符号创建一个DecimalFormat。
DecimalFormat(String, DecimalFormatSymbols) - Constructor for class java.text. DecimalFormat
使用给定的模式和符号创建一个DecimalFormat。
DecimalFormatSymbols - Class in java.text
此类表示 DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。
DecimalFormatSymbols() - Constructor for class java.text. DecimalFormatSymbols
为默认的 FORMAT语言环境创建一个DecimalFormatSymbols对象。
DecimalFormatSymbols(Locale) - Constructor for class java.text. DecimalFormatSymbols
为给定的区域设置创建一个DecimalFormatSymbols对象。
DecimalFormatSymbolsProvider - Class in java.text.spi
提供DecimalFormatSymbols类的实例的服务提供者的抽象类。
DecimalFormatSymbolsProvider() - Constructor for class java.text.spi. DecimalFormatSymbolsProvider
唯一的构造函数。
DecimalStyle - Class in java.time.format
在日期和时间格式中使用的本地化十进制格式。
Declaration - Class in javafx.css
DeclarationSnippet - Class in jdk.jshell
分组所有声明片段：变量声明（ VarSnippet ），方法声明（ MethodSnippet ）和类型声明（ TypeDeclSnippet ）。
DECLARE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“声明”
DECLARED - javax.lang.model.type. TypeKind
类或接口类型。
DECLARED - Static variable in interface java.lang.reflect. Member
标识类或接口的已声明成员集。
declaredType - Variable in class javax.xml.bind. JAXBElement
Java数据类型绑定xml元素声明的类型。
DeclaredType - Interface in javax.lang.model.type
表示声明的类型，类类型或接口类型。
declarePrefix(String, String) - Method in class org.xml.sax.helpers. NamespaceSupport
声明一个命名空间前缀。
declaringType() - Method in interface com.sun.jdi. Location
获取此位置所属的类型。
declaringType() - Method in interface com.sun.jdi. TypeComponent
返回声明此组件的类型。
DeclHandler - Interface in org.xml.sax.ext
用于DTD声明事件的SAX2扩展处理程序。
decode(byte[]) - Method in class java.util. Base64.Decoder
使用Base64编码方案从输入字节数组中解码所有字节，将结果写入新分配的输出字节数组。
decode(byte[]) - Method in interface org.omg.IOP. CodecOperations
基于对此 Codec有效的编码格式，将给定的字节数组解码为 Codec 。
decode(byte[], byte[]) - Method in class java.util. Base64.Decoder
使用Base64编码方案从输入字节数组中解码所有字节，将结果写入给定的输出字节数组，从偏移0开始。
decode(InputStream) - Method in interface java.security. Certificate
已过时。
从输入流解码证书。
decode(String) - Static method in class java.awt. Color
将 String转换为整数，并返回指定的不透明度 Color 。
decode(String) - Static method in class java.awt. Font
返回 Font ，该 str参数描述。
decode(String) - Static method in class java.lang. Byte
将 String解码成 Byte 。
decode(String) - Static method in class java.lang. Integer
将 String解码成 Integer 。
decode(String) - Static method in class java.lang. Long
将 String解码为 Long 。
decode(String) - Static method in class java.lang. Short
将 String解码成 Short 。
decode(String) - Static method in class java.net. URLDecoder
已过时。
结果字符串可能会因平台的默认编码而异。 而是使用decode（String，String）方法来指定编码。
decode(String) - Method in class java.util. Base64.Decoder
使用Base64编码方案将Base64编码的字符串解码为新分配的字节数组。
decode(String, String) - Static method in class java.net. URLDecoder
使用特定的编码方案解码 application/x-www-form-urlencoded字符串。
decode(ByteBuffer) - Method in class java.nio.charset. Charset
便利方法，将此字符集中的字节解码为Unicode字符。
decode(ByteBuffer) - Method in class java.nio.charset. CharsetDecoder
将单个输入字节缓冲器的剩余内容解码为新分配的字符缓冲区的方便方法。
decode(ByteBuffer) - Method in class java.util. Base64.Decoder
使用Base64编码方案从输入字节缓冲区中解码所有字节，将结果写入新分配的ByteBuffer。
decode(ByteBuffer, CharBuffer, boolean) - Method in class java.nio.charset. CharsetDecoder
从给定的输入缓冲区解码尽可能多的字节，将结果写入给定的输出缓冲区。
decode_value(byte[], TypeCode) - Method in interface org.omg.IOP. CodecOperations
根据给定的 TypeCode和对此 Codec有效的编码格式，将给定的字节数组解码为 Codec 。
decodeAnchorX(float, float) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
解码并返回给定控制点的编码X值的锚定点的实际像素位置的浮点值，以及从该控制点到锚点的偏移距离。
decodeAnchorY(float, float) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
解码并返回一个浮点值，表示给定控制点的编码Y值的锚点的实际像素位置，以及从该控制点到锚点的偏移距离。
decodeColor(Color, Color, float) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
解码并返回从两个其他颜色之间的偏移导出的颜色。
decodeColor(String, float, float, float, int) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
解码并返回从UI默认值中的基色导出的颜色。
decodeDataFlavor(String) - Static method in class java.awt.datatransfer. SystemFlavorMap
解码 String本机，用作 DataFlavor 。
decodeGradient(float, float, float, float, float[], Color[]) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
给定用于创建LinearGradientPaint的参数，此方法将创建并返回一个线性渐变画线。
decodeJavaMIMEType(String) - Static method in class java.awt.datatransfer. SystemFlavorMap
解码一个 String本机以用作Java MIME类型。
decodeLineStyle(Object) - Method in class javax.swing.plaf.metal. MetalTreeUI
传递给客户端属性的字符串和内部表示（当前和int）之间的转换
decodeLoop(ByteBuffer, CharBuffer) - Method in class java.nio.charset. CharsetDecoder
将一个或多个字节解码为一个或多个字符。
decodeRadialGradient(float, float, float, float[], Color[]) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
给定用于创建RadialGradientPaint的参数，此方法将创建并返回径向渐变画。
decodeX(float) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
解码并返回表示给定编码X值的实际像素位置的浮点值。
decodeY(float) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
解码并返回表示给定编码的y值的实际像素位置的浮点值。
DECORATED - javafx.stage. StageStyle
定义一个正常的 Stage风格与一个坚实的白色背景和平台装饰。
decorateTask(Runnable, RunnableScheduledFuture<V>) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor
修改或替换用于执行runnable的任务。
decorateTask(Callable<V>, RunnableScheduledFuture<V>) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor
修改或替换用于执行可调用的任务。
decrButton - Variable in class javax.swing.plaf.basic. BasicScrollBarUI
递减按钮
DECREASE_HIGHLIGHT - Static variable in class javax.swing.plaf.basic. BasicScrollBarUI
降低亮点
decreaseButton - Variable in class javax.swing.plaf.metal. MetalScrollBarUI
减少按钮。
decrement() - Method in class java.util.concurrent.atomic. LongAdder
相当于 add(-1) 。
decrement() - Method in class javafx.scene.control. ScrollBar
减少 ScrollBar的价值 unitIncrement
decrement() - Method in class javafx.scene.control. Slider
将值减少 blockIncrement ，以最大值
decrement() - Method in class javafx.scene.control. Spinner
尝试将 value factory减一步，通过调用一个参数的 SpinnerValueFactory.decrement(int)方法。
decrement(int) - Method in class javafx.scene.control. Spinner
尝试通过调用 SpinnerValueFactory.decrement(int)方法并将步骤参数转发给给定数量的步骤来减少 value factory 。
decrement(int) - Method in class javafx.scene.control. SpinnerValueFactory
尝试按照给定的步数减少 value 。
decrement(int) - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory
尝试按照给定的步数减少 value 。
decrement(int) - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory
尝试按照给定的步数减少 value 。
decrement(int) - Method in class javafx.scene.control. SpinnerValueFactory.ListSpinnerValueFactory
尝试按照给定的步数减少 value 。
DECREMENT - javafx.scene. AccessibleAction
请求节点递减一个小的值。
DECREMENT - Static variable in interface javax.accessibility. AccessibleAction
减少值的动作。
DECREMENT_BUTTON - javafx.scene. AccessibleRole
递减按钮角色。
decrementAndGet() - Method in class java.util.concurrent.atomic. AtomicInteger
按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子递减当前值。
decrementAndGet() - Method in class java.util.concurrent.atomic. AtomicLong
按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果， 原来递减当前值。
decrementAndGet(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
按索引 i原子地递减元素的值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
decrementAndGet(int) - Method in class java.util.concurrent.atomic. AtomicLongArray
按索引 i原子地递减元素的值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。
decrementAndGet(T) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
由该更新程序管理的给定对象的字段的当前值原子减1。
decrementAndGet(T) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater
由该更新程序管理的给定对象的字段的当前值原子减1。
decrementExact(int) - Static method in class java.lang. Math
返回一个递减1的参数，如果结果溢出一个 int ，则抛出异常。
decrementExact(long) - Static method in class java.lang. Math
返回一个减1的参数，如果结果溢出一个 long ，则抛出一个异常。
decrementPendingCountUnlessZero() - Method in class java.util.concurrent. CountedCompleter
如果挂起的计数非零，（原子地）减少它。
decrGap - Variable in class javax.swing.plaf.basic. BasicScrollBarUI
减量按钮和轨道之间的距离。
decrIndent() - Method in class javax.swing.text. AbstractWriter
减少缩进级别。
DECRYPT - Static variable in class javax.xml.crypto. KeySelector.Purpose
解密的关键。
DECRYPT_MODE - Static variable in class javax.crypto. Cipher
常数用于将密码初始化为解密模式。
deepEquals(Object[], Object[]) - Static method in class java.util. Arrays
如果两个指定的数组彼此 深度相等 ，则返回 true 。
deepEquals(Object, Object) - Static method in class java.util. Objects
返回 true如果参数是深层相等，彼此 false否则。
deepHashCode(Object[]) - Static method in class java.util. Arrays
根据指定数组的“深度内容”返回哈希码。
DEEPPINK - Static variable in class javafx.scene.paint. Color
颜色深粉红色，RGB值为＃FF1493
DEEPSKYBLUE - Static variable in class javafx.scene.paint. Color
颜色深蓝色，RGB值为＃00BFFF
deepToString(Object[]) - Static method in class java.util. Arrays
返回指定数组的“深度内容”的字符串表示形式。
def - Variable in class java.util.zip. DeflaterInputStream
此流的压缩器。
def - Variable in class java.util.zip. DeflaterOutputStream
此流的压缩器。
def_kind() - Method in class org.omg.CORBA. _IDLTypeStub
def_kind() - Method in interface org.omg.CORBA. IRObjectOperations
返回对应于此Interface Repository对象的 DefinitionKind 。
defAttributeList(String, int, int, String, String, AttributeList) - Method in class javax.swing.text.html.parser. DTD
创建并返回一个 AttributeList响应一个新属性。
DEFAULT - com.sun.management. VMOption.Origin
VM选项尚未设置，其值为默认值。
DEFAULT - javafx.print. Printer.MarginType
这要求所有方面的默认0.75英寸的边距。
DEFAULT - javafx.scene. CacheHint
没有额外的提示。
DEFAULT - javax.lang.model.element. Modifier
修饰词 default
DEFAULT - Static variable in class java.awt.dnd. DragSourceContext
一个 int由updateCurrentCursor（）使用，表示 Cursor应该更改为默认值（不下降） Cursor 。
DEFAULT - Static variable in class java.security.spec. PSSParameterSpec
PSS参数设置为所有默认值。
DEFAULT - Static variable in class java.text. DateFormat
常数为默认样式模式。
DEFAULT - Static variable in class javafx.scene. Cursor
默认游标类型（如果未定义游标，则设置）。
DEFAULT - Static variable in class javafx.scene.layout. BackgroundPosition
任何BackgroundImage的默认BackgroundPosition。
DEFAULT - Static variable in class javafx.scene.layout. BackgroundSize
当未定义显式大小时，BackgroundImages使用的默认BackgroundSize。
DEFAULT - Static variable in class javafx.scene.layout. BorderWidths
指定null时由BorderImage使用的默认BorderWidth。
DEFAULT - Static variable in class javax.crypto.spec. OAEPParameterSpec
OAEP参数设置为所有默认值。
DEFAULT - Static variable in class javax.crypto.spec. PSource.PSpecified
编码输入P的值等于byte [0]。
DEFAULT - Static variable in interface javax.swing. Action
目前不使用
DEFAULT - Static variable in interface javax.swing.plaf.synth. SynthConstants
表示该区域是默认值。
DEFAULT - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于DEFAULT
DEFAULT - Static variable in class javax.xml.crypto.dsig.spec. ExcC14NParameterSpec
表示默认命名空间（“#default”）。
DEFAULT() - Constructor for class javax.xml.bind.annotation.adapters. XmlJavaTypeAdapter.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation. XmlElement.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation. XmlElementRef.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation. XmlSchemaType.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation. XmlType.DEFAULT
DEFAULT_CARET_POLICY - Static variable in class java.awt.font. TextLayout
当客户端未指定策略时，将使用此 CaretPolicy 。
DEFAULT_CELL_FACTORY - Static variable in class javafx.scene.control. TableColumn
如果在TableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
DEFAULT_CELL_FACTORY - Static variable in class javafx.scene.control. TreeTableColumn
如果在TreeTableColumn实例上未指定cellFactory，则默认情况下将使用该实例。
DEFAULT_CHARSET_NAME - Static variable in class javafx.fxml. FXMLLoader
字符集未被明确指定时使用的字符集。
DEFAULT_CLASS_LOADER - Static variable in class javax.management.remote. JMXConnectorFactory
指定默认类加载器的属性的名称。
DEFAULT_CLASS_LOADER - Static variable in class javax.management.remote. JMXConnectorServerFactory
指定默认类加载器的属性的名称。
DEFAULT_CLASS_LOADER_NAME - Static variable in class javax.management.remote. JMXConnectorServerFactory
指定默认类加载器MBean名称的属性的名称。
DEFAULT_COMPARATOR - Static variable in class javafx.scene.control. TableColumnBase
默认情况下，所有列将使用此比较器执行排序。
DEFAULT_COMPRESSION - Static variable in class java.util.zip. Deflater
默认压缩级别。
DEFAULT_CSS - Static variable in class javax.swing.text.html. HTMLEditorKit
默认级联样式表文件，用于设置标签视图。
DEFAULT_CURSOR - Static variable in class java.awt. Cursor
默认游标类型（如果未定义游标，则设置）。
DEFAULT_CURSOR - Static variable in class java.awt. Frame
已过时。
替换为Cursor.DEFAULT_CURSOR 。
default_index() - Method in class org.omg.CORBA. TypeCode
返回默认成员的索引，如果没有默认成员则返回-1。
DEFAULT_JUSTIFICATION - Static variable in class javax.swing.border. TitledBorder
使用标题文本的默认对齐方式。
DEFAULT_KEYMAP - Static variable in class javax.swing.text. JTextComponent
默认键盘映射将被所有 JTextComponent实例共享，除非它们具有不同的键映射集。
DEFAULT_LAYER - Static variable in class javax.swing. JLayeredPane
定义默认图层的便利对象。
DEFAULT_LIFETIME - Static variable in interface org.ietf.jgss. GSSContext
表示默认上下文生存期的生命周期常数。
DEFAULT_LIFETIME - Static variable in interface org.ietf.jgss. GSSCredential
表示默认凭证生命周期的生命周期常数。
DEFAULT_MODALITY_TYPE - Static variable in class java.awt. Dialog
模态对话框的默认模式类型。
DEFAULT_NS_PREFIX - Static variable in class javax.xml. XMLConstants
用于表示默认XML命名空间的前缀。
DEFAULT_OBJECT_MODEL_URI - Static variable in class javax.xml.xpath. XPathFactory
默认对象模型URI。
DEFAULT_OPTION - Static variable in class javax.swing. JOptionPane
类型含义Look and Feel不应提供任何选项 - 只能使用 JOptionPane的选项。
default_POA(Servant) - Method in interface org.omg.PortableServer.portable. Delegate
此函数的默认行为是从与仆人关联的ORB实例返回根POA。
DEFAULT_POSITION - Static variable in class javax.swing.border. TitledBorder
使用标题文本的默认垂直方向。
DEFAULT_PREF_COLUMN_COUNT - Static variable in class javafx.scene.control. TextArea
默认值为 TextArea.prefColumnCount 。
DEFAULT_PREF_COLUMN_COUNT - Static variable in class javafx.scene.control. TextField
默认值为 TextField.prefColumnCount 。
DEFAULT_PREF_ROW_COUNT - Static variable in class javafx.scene.control. TextArea
默认值为 TextArea.prefRowCount 。
DEFAULT_PROPERTY_NAME - Static variable in class javax.xml.xpath. XPathFactory
根据JAXP规范的默认属性名称。
DEFAULT_SIZE - Static variable in class javafx.scene.shape. Box
创建一个尺寸为2×2的新实例 Box 。
DEFAULT_SIZE - Static variable in class javax.swing. GroupLayout
表示组件或间隙的尺寸应用于特定范围值。
DEFAULT_SOAP_PROTOCOL - Static variable in interface javax.xml.soap. SOAPConstants
默认协议：SOAP 1.1，用于向后兼容。
DEFAULT_SORT_POLICY - Static variable in class javafx.scene.control. TableView
如果没有指定其他策略，则此TableView将使用默认值 sort policy 。
DEFAULT_SORT_POLICY - Static variable in class javafx.scene.control. TreeTableView
如果没有指定其他策略，则该TreeTableView将使用默认值 sort policy 。
DEFAULT_STRATEGY - Static variable in class java.util.zip. Deflater
默认压缩策略。
DEFAULT_STYLE - Static variable in class javax.swing.text. StyleContext
名称附加到段落的默认逻辑风格。
DEFAULT_VALUE - Variable in class com.sun.source.util. SimpleDocTreeVisitor
默认值由 default action返回。
DEFAULT_VALUE - Variable in class com.sun.source.util. SimpleTreeVisitor
默认值由 default action返回。
DEFAULT_VALUE - Variable in class javax.lang.model.util. ElementScanner6
指定的默认值。
DEFAULT_VALUE - Variable in class javax.lang.model.util. SimpleAnnotationValueVisitor6
要返回的默认值; defaultAction返回此值，除非该方法被覆盖。
DEFAULT_VALUE - Variable in class javax.lang.model.util. SimpleElementVisitor6
要返回的默认值; defaultAction返回此值，除非该方法被覆盖。
DEFAULT_VALUE - Variable in class javax.lang.model.util. SimpleTypeVisitor6
要返回的默认值; defaultAction返回此值，除非该方法被覆盖。
DEFAULT_VALUE_FIELD - Static variable in class javax.management. JMX
名称为 defaultValue字段。
DEFAULT_WIDTHS - Static variable in class javafx.scene.layout. BorderStroke
默认Insets与BorderStroke一起使用，否则不定义任何内容。
defaultAction(DocTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
所有访问方法使用的默认操作不被覆盖。
defaultAction(Tree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
所有访问方法使用的默认操作不被覆盖。
defaultAction(Object, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问方法的默认操作。
defaultAction(Element, P) - Method in class javax.lang.model.util. SimpleElementVisitor6
访问方法的默认操作。
defaultAction(TypeMirror, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问方法的默认操作。
defaultArguments() - Method in interface com.sun.jdi.connect. Connector
返回此连接器接受的参数及其默认值。
DefaultBoundedRangeModel - Class in javax.swing
BoundedRangeModel的一般实现。
DefaultBoundedRangeModel() - Constructor for class javax.swing. DefaultBoundedRangeModel
使用默认值初始化所有属性。
DefaultBoundedRangeModel(int, int, int, int) - Constructor for class javax.swing. DefaultBoundedRangeModel
初始化值，范围，最小值和最大值。
defaultBufferSize() - Static method in class java.util.concurrent. Flow
返回发布者或订阅者缓冲的默认值，可以在没有其他约束的情况下使用。
defaultButton - Variable in class javax.swing. JRootPane
当窗格具有焦点并且出现特定于UI的操作（如按 Enter键）时，该按钮将被激活。
DefaultButtonModel - Class in javax.swing
默认实现的一个 Button组件的数据模型。
DefaultButtonModel() - Constructor for class javax.swing. DefaultButtonModel
构造一个 DefaultButtonModel 。
defaultButtonProperty() - Method in class javafx.scene.control. Button
默认按钮是接收键盘VK_ENTER的按钮，如果场景中没有其他节点消耗它。
DefaultCaret - Class in javax.swing.text
默认的Caret实现。
DefaultCaret() - Constructor for class javax.swing.text. DefaultCaret
构造默认插入符号。
DefaultCellEditor - Class in javax.swing
表和树单元格的默认编辑器。
DefaultCellEditor(JCheckBox) - Constructor for class javax.swing. DefaultCellEditor
构造一个使用复选框的 DefaultCellEditor对象。
DefaultCellEditor(JComboBox<?>) - Constructor for class javax.swing. DefaultCellEditor
构造一个使用组合框的 DefaultCellEditor对象。
DefaultCellEditor(JTextField) - Constructor for class javax.swing. DefaultCellEditor
构造一个使用文本字段的 DefaultCellEditor 。
DefaultCellEditor.EditorDelegate - Class in javax.swing
受保护的 EditorDelegate类。
defaultCharset() - Static method in class java.nio.charset. Charset
返回此Java虚拟机的默认字符集。
defaultChoosers - Variable in class javax.swing.plaf.basic. BasicColorChooserUI
默认颜色选择器的数组。
DefaultColorSelectionModel - Class in javax.swing.colorchooser
通用实现 ColorSelectionModel 。
DefaultColorSelectionModel() - Constructor for class javax.swing.colorchooser. DefaultColorSelectionModel
创建一个 DefaultColorSelectionModel ，当前颜色设置为 Color.white 。
DefaultColorSelectionModel(Color) - Constructor for class javax.swing.colorchooser. DefaultColorSelectionModel
创建一个 DefaultColorSelectionModel ，当前的颜色设置为 color ，它应该是非 null 。
DefaultComboBoxModel< E> - Class in javax.swing
组合框的默认模型。
DefaultComboBoxModel() - Constructor for class javax.swing. DefaultComboBoxModel
构造一个空的DefaultComboBoxModel对象。
DefaultComboBoxModel(E[]) - Constructor for class javax.swing. DefaultComboBoxModel
构造一个使用对象数组初始化的DefaultComboBoxModel对象。
DefaultComboBoxModel(Vector<E>) - Constructor for class javax.swing. DefaultComboBoxModel
构造一个使用向量初始化的DefaultComboBoxModel对象。
defaultConnector() - Method in interface com.sun.jdi. VirtualMachineManager
标识默认连接器。
defaultConstraints - Variable in class java.awt. GridBagLayout
该字段包含包含默认值的网格包约束实例，因此如果组件没有与其相关联的网格包约束，则将为该组件分配 defaultConstraints的副本。
defaultController - Variable in class javax.imageio. IIOParam
当调用 activateController方法时，默认的 IIOParamController将用于为此 IIOParam对象提供设置。
defaultController - Variable in class javax.imageio.metadata. IIOMetadata
一个 IIOMetadataController被建议用作控制器此 IIOMetadata对象。
DefaultCopyDrop - Static variable in class java.awt.dnd. DragSource
默认的 Cursor用于复制操作，指示当前允许丢弃。
DefaultCopyNoDrop - Static variable in class java.awt.dnd. DragSource
默认的 Cursor用于复制操作，指示当前不允许丢弃。
DefaultDesktopManager - Class in javax.swing
这是一个 DesktopManager的实现。
DefaultDesktopManager() - Constructor for class javax.swing. DefaultDesktopManager
DefaultDocumentEvent(int, int, DocumentEvent.EventType) - Constructor for class javax.swing.text. AbstractDocument.DefaultDocumentEvent
构建变更记录。
defaulted(String) - Method in class java.io. ObjectInputStream.GetField
如果命名字段是默认值，并且此流中没有值，则返回true。
DefaultEditor(JSpinner) - Constructor for class javax.swing. JSpinner.DefaultEditor
构造指定的编辑器组件 JSpinner 。
DefaultEditorKit - Class in javax.swing.text
这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。
DefaultEditorKit() - Constructor for class javax.swing.text. DefaultEditorKit
DefaultEditorKit的默认构造函数
DefaultEditorKit.BeepAction - Class in javax.swing.text
发出哔声
DefaultEditorKit.CopyAction - Class in javax.swing.text
复制所选区域并将其内容放入系统剪贴板。
DefaultEditorKit.CutAction - Class in javax.swing.text
剪切所选区域并将其内容放入系统剪贴板。
DefaultEditorKit.DefaultKeyTypedAction - Class in javax.swing.text
如果接收到 键入类型的事件并且没有键映射条目，则默认执行的操作。
DefaultEditorKit.InsertBreakAction - Class in javax.swing.text
在文档中放置一个行/段落。
DefaultEditorKit.InsertContentAction - Class in javax.swing.text
将内容放入相关的文档。
DefaultEditorKit.InsertTabAction - Class in javax.swing.text
将标签字符放在文档中。
DefaultEditorKit.PasteAction - Class in javax.swing.text
将系统剪贴板的内容粘贴到所选区域中，或者如果没有选择任何内容，则将其插入插入符号之前。
defaultEditorsByColumnClass - Variable in class javax.swing. JTable
显示和编辑单元格内容的对象表，由 TableModel接口中的 getColumnClass中声明的类索引。
defaultExecutor() - Method in class java.util.concurrent. CompletableFuture
返回用于不指定Executor的异步方法的默认Executor。
DefaultFocusManager - Class in javax.swing
这个类已被1.4焦点API过时了。
DefaultFocusManager() - Constructor for class javax.swing. DefaultFocusManager
构造一个 DefaultFocusManager 。
DefaultFocusTraversalPolicy - Class in java.awt
FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
DefaultFocusTraversalPolicy() - Constructor for class java.awt. DefaultFocusTraversalPolicy
defaultForkJoinWorkerThreadFactory - Static variable in class java.util.concurrent. ForkJoinPool
创建一个新的ForkJoinWorkerThread。
DefaultFormatter - Class in javax.swing.text
DefaultFormatter格式化任意对象。
DefaultFormatter() - Constructor for class javax.swing.text. DefaultFormatter
创建一个DefaultFormatter。
DefaultFormatter(NumberAxis) - Constructor for class javafx.scene.chart. NumberAxis.DefaultFormatter
为给定的NumberAxis构造一个DefaultFormatter
DefaultFormatter(NumberAxis, String, String) - Constructor for class javafx.scene.chart. NumberAxis.DefaultFormatter
为给定的NumberAxis构造一个带有前缀和/或后缀的DefaultFormatter。
DefaultFormatterFactory - Class in javax.swing.text
执行 JFormattedTextField.AbstractFormatterFactory 。
DefaultFormatterFactory() - Constructor for class javax.swing.text. DefaultFormatterFactory
构造一个 DefaultFormatterFactory 。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text. DefaultFormatterFactory
创建一个 DefaultFormatterFactory与指定的 JFormattedTextField.AbstractFormatter 。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text. DefaultFormatterFactory
创建一个 DefaultFormatterFactory与指定的 JFormattedTextField.AbstractFormatter s。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text. DefaultFormatterFactory
用指定的JFormattedTextField.AbstractFormatter创建一个DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text. DefaultFormatterFactory
用指定的JFormattedTextField.AbstractFormatter创建一个DefaultFormatterFactory。
DefaultHandler - Class in org.xml.sax.helpers
SAX2事件处理程序的默认基类。
DefaultHandler() - Constructor for class org.xml.sax.helpers. DefaultHandler
DefaultHandler2 - Class in org.xml.sax.ext
此类扩展SAX2基本处理程序类，以支持SAX2 LexicalHandler ， DeclHandler ，并EntityResolver2扩展。
DefaultHandler2() - Constructor for class org.xml.sax.ext. DefaultHandler2
构造一个忽略所有解析事件的处理程序。
DefaultHighlighter - Class in javax.swing.text
实现荧光笔界面。
DefaultHighlighter() - Constructor for class javax.swing.text. DefaultHighlighter
创建一个新的DefaultHighlighther对象。
DefaultHighlighter.DefaultHighlightPainter - Class in javax.swing.text
简单的高亮画家，用纯色填充突出显示的区域。
DefaultHighlightPainter(Color) - Constructor for class javax.swing.text. DefaultHighlighter.DefaultHighlightPainter
构建一个新的亮点画家。
defaultInitCtx - Variable in class javax.naming. InitialContext
保留调用NamingManager.getInitialContext（）的结果的字段。
DefaultInternalObjectFilter - Class in jdk.dynalink.linker.support
一个 DynamicLinkerFactory.setInternalObjectsFilter(MethodHandleTransformer)的默认实现，委托一对过滤方法句柄。
DefaultInternalObjectFilter(MethodHandle, MethodHandle) - Constructor for class jdk.dynalink.linker.support. DefaultInternalObjectFilter
创建一个新的过滤器。
DefaultKeyboardFocusManager - Class in java.awt
用于AWT应用程序的默认KeyboardFocusManager。
DefaultKeyboardFocusManager() - Constructor for class java.awt. DefaultKeyboardFocusManager
defaultKeyTypedAction - Static variable in class javax.swing.text. DefaultEditorKit
默认情况下，如果接收到 键类型事件并且没有键映射条目，则执行的操作的名称。
DefaultKeyTypedAction() - Constructor for class javax.swing.text. DefaultEditorKit.DefaultKeyTypedAction
使用相应的标识符创建此对象。
DefaultLinkDrop - Static variable in class java.awt.dnd. DragSource
默认的 Cursor与链接操作一起使用，指示当前允许丢弃。
DefaultLinkNoDrop - Static variable in class java.awt.dnd. DragSource
默认的 Cursor用于链接操作，指示当前不允许丢弃。
DefaultListCellRenderer - Class in javax.swing
渲染列表中的项目。
DefaultListCellRenderer() - Constructor for class javax.swing. DefaultListCellRenderer
为列表中的项构造一个默认渲染器对象。
DefaultListCellRenderer.UIResource - Class in javax.swing
实现UIResource的DefaultListCellRenderer的子类。
DefaultListModel< E> - Class in javax.swing
该类松散地实现了 java.util.Vector API，因为它实现了1.1.x版本的 java.util.Vector ，没有收集类支持，并且在发生更改时通知 ListDataListener 。
DefaultListModel() - Constructor for class javax.swing. DefaultListModel
DefaultListSelectionModel - Class in javax.swing
列表选择的默认数据模型。
DefaultListSelectionModel() - Constructor for class javax.swing. DefaultListSelectionModel
DefaultLoaderRepository - Class in javax.management
已过时。
改用MBeanServer.getClassLoaderRepository() 。
DefaultLoaderRepository - Class in javax.management.loading
已过时。
改用MBeanServer.getClassLoaderRepository() 。
DefaultLoaderRepository() - Constructor for class javax.management. DefaultLoaderRepository
已过时。
DefaultLoaderRepository() - Constructor for class javax.management.loading. DefaultLoaderRepository
已过时。
defaultManager() - Static method in class javax.swing. MenuSelectionManager
返回默认菜单选择管理器。
DefaultMenuLayout - Class in javax.swing.plaf.basic
弹出菜单和菜单栏的默认布局管理器。
DefaultMenuLayout(Container, int) - Constructor for class javax.swing.plaf.basic. DefaultMenuLayout
构造一个新的实例 DefaultMenuLayout 。
DefaultMetalTheme - Class in javax.swing.plaf.metal
具体实现了 MetalTheme提供了Java Look and Feel的原始外观，代号为“Steel”。
DefaultMetalTheme() - Constructor for class javax.swing.plaf.metal. DefaultMetalTheme
创建并返回一个 DefaultMetalTheme的实例。
DefaultMoveDrop - Static variable in class java.awt.dnd. DragSource
使用默认值 Cursor进行移动操作，指示当前允许丢弃。
DefaultMoveNoDrop - Static variable in class java.awt.dnd. DragSource
默认的 Cursor与移动操作一起使用，指示当前不允许丢弃。
DefaultMutableTreeNode - Class in javax.swing.tree
A DefaultMutableTreeNode是树状数据结构中的通用节点。
DefaultMutableTreeNode() - Constructor for class javax.swing.tree. DefaultMutableTreeNode
创建一个树节点，没有父节点，没有子节点，但它允许子节点。
DefaultMutableTreeNode(Object) - Constructor for class javax.swing.tree. DefaultMutableTreeNode
创建一个没有父进程，没有子节点，但允许子节点的树节点，并用指定的用户对象初始化它。
DefaultMutableTreeNode(Object, boolean) - Constructor for class javax.swing.tree. DefaultMutableTreeNode
创建一个没有父进程的树节点，没有子节点，用指定的用户对象进行初始化，只有在指定的时候才允许子节点。
defaultPage() - Method in class java.awt.print. PrinterJob
创建一个新的 PageFormat实例，并将其设置为默认大小和方向。
defaultPage(PageFormat) - Method in class java.awt.print. PrinterJob
克隆 PageFormat参数，并更改克隆来描述默认页面大小和方向。
DefaultPainter - Static variable in class javax.swing.text. DefaultHighlighter
LayeredHighlighter.LayerPainter的默认实现，可用于绘制亮点。
defaultParameters() - Method in class jdk.jshell.execution. FailOverExecutionControlProvider
创建并返回此 ExecutionControlProvider的默认参数图。
defaultParameters() - Method in class jdk.jshell.execution. JdiExecutionControlProvider
创建并返回此 ExecutionControlProvider的默认参数图。
defaultParameters() - Method in class jdk.jshell.execution. LocalExecutionControlProvider
创建并返回 LocalExecutionControlProvider的默认参数图。
defaultParameters() - Method in interface jdk.jshell.spi. ExecutionControlProvider
创建并返回此 ExecutionControlProvider的默认参数图。
DefaultPersistenceDelegate - Class in java.beans
DefaultPersistenceDelegate是一个抽象的 PersistenceDelegate类的具体实现，是默认情况下用于没有信息可用的类的委托。
DefaultPersistenceDelegate() - Constructor for class java.beans. DefaultPersistenceDelegate
为具有无效构造函数的类创建持久性委托。
DefaultPersistenceDelegate(String[]) - Constructor for class java.beans. DefaultPersistenceDelegate
为具有构造函数的类创建默认持久性委托，该构造函数的参数是由 constructorPropertyNames指定的属性名称的值。
defaultPrinterProperty() - Static method in class javafx.print. Printer
表示当前默认打印机的只读对象属性。
DefaultProperty - Annotation Type in javafx.beans
指定未指定显式属性时将添加或设置子元素的属性。
defaultReadObject() - Method in class java.io. ObjectInputStream
从此流读取当前类的非静态和非瞬态字段。
defaultRenderersByColumnClass - Variable in class javax.swing. JTable
一个显示单元格内容的对象表，由 TableModel接口中的 getColumnClass中声明的类索引。
DefaultRowSorter< M, I> - Class in javax.swing
实现 RowSorter ，它围绕网格数据模型提供排序和过滤。
DefaultRowSorter() - Constructor for class javax.swing. DefaultRowSorter
创建一个空的 DefaultRowSorter 。
DefaultRowSorter.ModelWrapper< M, I> - Class in javax.swing
DefaultRowSorter.ModelWrapper负责提供按 DefaultRowSorter排序的数据。
defaults - Variable in class java.util. Properties
属性列表，其中包含此属性列表中未找到的任何键的默认值。
defaults() - Static method in class javax.xml.catalog. CatalogFeatures
返回具有默认设置的CatalogFeatures实例。
DefaultSingleSelectionModel - Class in javax.swing
SingleSelectionModel的一般实现。
DefaultSingleSelectionModel() - Constructor for class javax.swing. DefaultSingleSelectionModel
defaultStratum() - Method in interface com.sun.jdi. ReferenceType
返回此引用类型的默认层次。
DefaultStringConverter - Class in javafx.util.converter
StringConverter实现String值。
DefaultStringConverter() - Constructor for class javafx.util.converter. DefaultStringConverter
DefaultStyledDocument - Class in javax.swing.text
可以以与RTF格式相似的方式标记字符和段落样式的文档。
DefaultStyledDocument() - Constructor for class javax.swing.text. DefaultStyledDocument
构造默认样式文档。
DefaultStyledDocument(AbstractDocument.Content, StyleContext) - Constructor for class javax.swing.text. DefaultStyledDocument
构造一个风格的文档。
DefaultStyledDocument(StyleContext) - Constructor for class javax.swing.text. DefaultStyledDocument
构造具有默认内容存储实现和共享样式集的样式文档。
DefaultStyledDocument.AttributeUndoableEdit - Class in javax.swing.text
一个UndoableEdit用于记住对元素的AttributeSet更改。
DefaultStyledDocument.ElementBuffer - Class in javax.swing.text
用于管理元素层次结构更改的类。
DefaultStyledDocument.ElementSpec - Class in javax.swing.text
建筑元素规范。
DefaultStyledDocument.SectionElement - Class in javax.swing.text
文档的默认根元素...映射包含的段落/行。
DefaultTableCellRenderer - Class in javax.swing.table
用于在 JTable渲染（显示）单个单元格的标准类。
DefaultTableCellRenderer() - Constructor for class javax.swing.table. DefaultTableCellRenderer
创建一个默认的表单元格渲染器。
DefaultTableCellRenderer.UIResource - Class in javax.swing.table
DefaultTableCellRenderer的子类实现 UIResource 。
DefaultTableColumnModel - Class in javax.swing.table
JTable的标准列处理程序。
DefaultTableColumnModel() - Constructor for class javax.swing.table. DefaultTableColumnModel
创建默认表列模型。
DefaultTableModel - Class in javax.swing.table
这是一个 TableModel的实现，它使用 Vector的 Vectors来存储单元格值对象。
DefaultTableModel() - Constructor for class javax.swing.table. DefaultTableModel
构造默认的 DefaultTableModel ，它是零列和零行的表。
DefaultTableModel(int, int) - Constructor for class javax.swing.table. DefaultTableModel
构造 DefaultTableModel与 rowCount和 columnCount的 null对象值。
DefaultTableModel(Object[][], Object[]) - Constructor for class javax.swing.table. DefaultTableModel
构造一个 DefaultTableModel并通过将 data和 columnNames传递给 setDataVector方法来初始化该表。
DefaultTableModel(Object[], int) - Constructor for class javax.swing.table. DefaultTableModel
构造一个 DefaultTableModel与尽可能多的列有在元件 columnNames和 rowCount的 null对象值。
DefaultTableModel(Vector<?>, int) - Constructor for class javax.swing.table. DefaultTableModel
构造一个 DefaultTableModel与尽可能多的列有在元件 columnNames和 rowCount的 null对象值。
DefaultTableModel(Vector<? extends Vector>, Vector<?>) - Constructor for class javax.swing.table. DefaultTableModel
构造一个 DefaultTableModel并通过将 data和 columnNames通过 setDataVector方法初始化表。
DefaultTextField(Border) - Constructor for class javax.swing.tree. DefaultTreeCellEditor.DefaultTextField
构造一个 DefaultTreeCellEditor.DefaultTextField对象。
defaultTextIconGap - Variable in class javax.swing.plaf.basic. BasicButtonUI
文本和图标之间的默认差距。
defaultTextIconGap - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
文字与图示之间的差距。
defaultTextShiftOffset - Variable in class javax.swing.plaf.basic. BasicButtonUI
文本的默认偏移量。
DefaultTextUI - Class in javax.swing.text
已过时。
DefaultTextUI() - Constructor for class javax.swing.text. DefaultTextUI
已过时。
defaultThreadFactory() - Static method in class java.util.concurrent. Executors
返回用于创建新线程的默认线程工厂。
DefaultTreeCellEditor - Class in javax.swing.tree
A TreeCellEditor 。
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer) - Constructor for class javax.swing.tree. DefaultTreeCellEditor
使用指定的渲染器和默认编辑器为JTree构造一个 DefaultTreeCellEditor对象。
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer, TreeCellEditor) - Constructor for class javax.swing.tree. DefaultTreeCellEditor
使用指定的渲染器和指定的编辑器为 JTree构造一个 DefaultTreeCellEditor对象。
DefaultTreeCellEditor.DefaultTextField - Class in javax.swing.tree
TextField不提供编辑器时使用。
DefaultTreeCellEditor.EditorContainer - Class in javax.swing.tree
集装箱负责放置 editingComponent 。
DefaultTreeCellRenderer - Class in javax.swing.tree
在树中显示一个条目。
DefaultTreeCellRenderer() - Constructor for class javax.swing.tree. DefaultTreeCellRenderer
创建一个 DefaultTreeCellRenderer 。
DefaultTreeModel - Class in javax.swing.tree
一个使用TreeNodes的简单树数据模型。
DefaultTreeModel(TreeNode) - Constructor for class javax.swing.tree. DefaultTreeModel
创建一个树，其中任何节点可以拥有子节点。
DefaultTreeModel(TreeNode, boolean) - Constructor for class javax.swing.tree. DefaultTreeModel
创建一个树，指定任何节点是否可以有子节点，或者只有某些节点可以有子节点。
DefaultTreeSelectionModel - Class in javax.swing.tree
TreeSelectionModel的默认实现。
DefaultTreeSelectionModel() - Constructor for class javax.swing.tree. DefaultTreeSelectionModel
创建一个新的DefaultTreeSelectionModel实例，该实例为空，选择模式为DISCONTIGUOUS_TREE_SELECTION。
DefaultValidationEventHandler - Class in javax.xml.bind.helpers
JAXB 1.0只有默认的验证事件处理程序。
DefaultValidationEventHandler() - Constructor for class javax.xml.bind.helpers. DefaultValidationEventHandler
defaultValue() - Method in interface com.sun.javadoc. AnnotationTypeElementDoc
已过时。
返回此元素的默认值。
defaultValue() - Method in enum javax.xml.catalog. CatalogFeatures.Feature
返回属性的默认值。
defaultWriteObject() - Method in class java.io. ObjectOutputStream
将当前类的非静态和非瞬态字段写入此流。
defContentModel(int, Object, ContentModel) - Method in class javax.swing.text.html.parser. DTD
创建并返回新的内容模型。
DEFECTIVE_CREDENTIAL - Static variable in exception org.ietf.jgss. GSSException
凭证不足
DEFECTIVE_TOKEN - Static variable in exception org.ietf.jgss. GSSException
有缺陷的令牌
defElement(String, int, boolean, boolean, ContentModel, String[], String[], AttributeList) - Method in class javax.swing.text.html.parser. DTD
创建并返回一个 Element 。
defEntity(String, int, int) - Method in class javax.swing.text.html.parser. DTD
创建并返回一个字符 Entity 。
defEntity(String, int, String) - Method in class javax.swing.text.html.parser. DTD
创建并返回一个 Entity 。
DEFER - javax.xml.catalog. CatalogFeatures.Feature
目录功能表中 javax.xml.catalog.defer属性，如 DEFER所述。
DEFINE_TAG - Static variable in class javafx.fxml. FXMLLoader
标签名称为<fx：define>。
defineAttributes(String, AttributeList) - Method in class javax.swing.text.html.parser. DTD
定义 Element属性。
defineClass(byte[]) - Method in class java.lang.invoke. MethodHandles.Lookup
定义一个类到相同的类加载器和相同的运行时包和protection domain作为这个查找的lookup class 。
defineClass(byte[], int, int) - Method in class java.lang. ClassLoader
已过时。
替换为defineClass(String, byte[], int, int)
defineClass(String, byte[], int, int) - Method in class java.lang. ClassLoader
将字节数组转换为类别 Class的实例。
defineClass(String, byte[], int, int, CodeSource) - Method in class java.security. SecureClassLoader
将字节数组转换为类Class的实例，并具有可选的CodeSource。
defineClass(String, byte[], int, int, ProtectionDomain) - Method in class java.lang. ClassLoader
将一个字节数组转换为类别 Class的实例，给定的是 ProtectionDomain 。
defineClass(String, ByteBuffer, CodeSource) - Method in class java.security. SecureClassLoader
一个转换ByteBuffer成类的实例Class ，使用可选的CodeSource。
defineClass(String, ByteBuffer, ProtectionDomain) - Method in class java.lang. ClassLoader
一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。
defined_in - Variable in class org.omg.CORBA. ValueMember
该成员定义的 value的存储库ID。
definedClasses() - Method in interface com.sun.jdi. ClassLoaderReference
返回由此类加载器定义的所有加载类的列表。
defineElement(String, int, boolean, boolean, ContentModel, BitSet, BitSet, AttributeList) - Method in class javax.swing.text.html.parser. DTD
返回匹配指定参数的 Element 。
defineEntity(String, int, char[]) - Method in class javax.swing.text.html.parser. DTD
定义一个实体。
defineModules(Configuration, Function<String, ClassLoader>) - Method in class java.lang. ModuleLayer
通过在Java虚拟机给定的 Configuration定义模块，创建一个新的模块层，将该层作为其父层。
defineModules(Configuration, List<ModuleLayer>, Function<String, ClassLoader>) - Static method in class java.lang. ModuleLayer
通过在Java虚拟机给定的 Configuration定义模块来创建新的模块层。
defineModulesWithManyLoaders(Configuration, ClassLoader) - Method in class java.lang. ModuleLayer
通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
defineModulesWithManyLoaders(Configuration, List<ModuleLayer>, ClassLoader) - Static method in class java.lang. ModuleLayer
通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
defineModulesWithOneLoader(Configuration, ClassLoader) - Method in class java.lang. ModuleLayer
通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
defineModulesWithOneLoader(Configuration, List<ModuleLayer>, ClassLoader) - Static method in class java.lang. ModuleLayer
通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
definePackage(String, String, String, String, String, String, String, URL) - Method in class java.lang. ClassLoader
通过定义一个包 name在这个 ClassLoader 。
definePackage(String, Manifest, URL) - Method in class java.net. URLClassLoader
在这个 URLClassLoader按名称定义一个新的包。
definesSerializableFields() - Method in interface com.sun.javadoc. ClassDoc
已过时。
如果使用特殊类成员 serialPersistentFields明确定义可序列化字段，则返回true。
DEFINITELY_INCOMPLETE - jdk.jshell. SourceCodeAnalysis.Completeness
必须有更多的来源超出给定的输入，以使其完整。
DefinitionKind - Class in org.omg.CORBA
提供用于标识Interface Repository对象类型的常量的类。
DefinitionKind(int) - Constructor for class org.omg.CORBA. DefinitionKind
构造一个 DefinitionKind对象，其 _value字段使用给定值进行初始化。
DefinitionKindHelper - Class in org.omg.CORBA
助手 DefinitionKind 。
DefinitionKindHelper() - Constructor for class org.omg.CORBA. DefinitionKindHelper
deflate() - Method in class java.util.zip. DeflaterOutputStream
将下一个压缩数据块写入输出流。
deflate(byte[]) - Method in class java.util.zip. Deflater
压缩输入数据，并用压缩数据填充指定的缓冲区。
deflate(byte[], int, int) - Method in class java.util.zip. Deflater
压缩输入数据，并用压缩数据填充指定的缓冲区。
deflate(byte[], int, int, int) - Method in class java.util.zip. Deflater
压缩输入数据，并用压缩数据填充指定的缓冲区。
DEFLATE - Static variable in class javax.print.attribute.standard. Compression
ZIP公共领域充气/放气压缩技术。
DEFLATE_HINT - Static variable in interface java.util.jar. Pack200.Packer
如果此属性设置为 Pack200.Packer.TRUE或 Pack200.Packer.FALSE ，则 打包程序将在输出归档中相应设置 通知提示，并且不会传送归档元素的各个通配提示。
DEFLATE_HINT - Static variable in interface java.util.jar. Pack200.Unpacker
表示解包器应忽略DEFLATE_HINT的所有传输值，替换为给定值 Pack200.Unpacker.TRUE或 Pack200.Unpacker.FALSE 。
DEFLATED - Static variable in class java.util.zip. Deflater
减压算法的压缩方法（目前唯一支持的）。
DEFLATED - Static variable in class java.util.zip. ZipEntry
压缩（缩小）条目的压缩方法。
DEFLATED - Static variable in class java.util.zip. ZipOutputStream
压缩（DEFLATED）条目的压缩方法。
Deflater - Class in java.util.zip
该类支持通用压缩使用流行的ZLIB压缩库。
Deflater() - Constructor for class java.util.zip. Deflater
创建一个具有默认压缩级别的新压缩器。
Deflater(int) - Constructor for class java.util.zip. Deflater
使用指定的压缩级别创建新的压缩器。
Deflater(int, boolean) - Constructor for class java.util.zip. Deflater
使用指定的压缩级别创建新的压缩器。
DeflaterInputStream - Class in java.util.zip
实现用于压缩“放气”压缩格式的数据的输入流过滤器。
DeflaterInputStream(InputStream) - Constructor for class java.util.zip. DeflaterInputStream
创建一个具有默认压缩器和缓冲区大小的新输入流。
DeflaterInputStream(InputStream, Deflater) - Constructor for class java.util.zip. DeflaterInputStream
使用指定的压缩器和默认缓冲区大小创建新的输入流。
DeflaterInputStream(InputStream, Deflater, int) - Constructor for class java.util.zip. DeflaterInputStream
创建具有指定压缩器和缓冲区大小的新输入流。
DeflaterOutputStream - Class in java.util.zip
该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
DeflaterOutputStream(OutputStream) - Constructor for class java.util.zip. DeflaterOutputStream
创建具有默认压缩器和缓冲区大小的新输出流。
DeflaterOutputStream(OutputStream, boolean) - Constructor for class java.util.zip. DeflaterOutputStream
使用默认压缩器，默认缓冲区大小和指定的刷新模式创建新的输出流。
DeflaterOutputStream(OutputStream, Deflater) - Constructor for class java.util.zip. DeflaterOutputStream
使用指定的压缩器和默认缓冲区大小创建新的输出流。
DeflaterOutputStream(OutputStream, Deflater, boolean) - Constructor for class java.util.zip. DeflaterOutputStream
使用指定的压缩器，刷新模式和默认缓冲区大小创建新的输出流。
DeflaterOutputStream(OutputStream, Deflater, int) - Constructor for class java.util.zip. DeflaterOutputStream
创建具有指定压缩器和缓冲区大小的新输出流。
DeflaterOutputStream(OutputStream, Deflater, int, boolean) - Constructor for class java.util.zip. DeflaterOutputStream
创建具有指定压缩器，缓冲区大小和冲洗模式的新输出流。
DEG - javafx.css. SizeUnits
deiconifyFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
从其父项中删除desktopIcon，并将其框架添加到父级。
deiconifyFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager
一般来说，删除现有的任何标志性表示，并将框架恢复为原始大小和位置。
deiconifyFrame(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
当用户想要对该帧进行解码时，会调用此方法。
deiconize() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI
取消图标化内部框架。
deinstall(JEditorPane) - Method in class javax.swing.text. EditorKit
当该套件从JEditorPane中删除时调用。
deinstall(JEditorPane) - Method in class javax.swing.text.html. HTMLEditorKit
当该套件从JEditorPane中删除时调用。
deinstall(JEditorPane) - Method in class javax.swing.text. StyledEditorKit
当该套件从JEditorPane中删除时调用。
deinstall(JTextComponent) - Method in interface javax.swing.text. Caret
当UI从JTextComponent的界面中删除时调用。
deinstall(JTextComponent) - Method in class javax.swing.text. DefaultCaret
当UI从JTextComponent的界面中删除时调用。
deinstall(JTextComponent) - Method in class javax.swing.text. DefaultHighlighter
当UI从JTextComponent的界面中删除时调用。
deinstall(JTextComponent) - Method in interface javax.swing.text. Highlighter
当UI从JTextComponent的界面中删除时调用。
deinstallMouseHandlers(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
卸载鼠标处理程序。
delay(int) - Method in class java.awt. Robot
睡在指定的时间。
Delayed - Interface in java.util.concurrent
一个混合样式界面，用于标记在给定延迟后应该执行的对象。
delayedExecutor(long, TimeUnit) - Static method in class java.util.concurrent. CompletableFuture
返回一个新的执行程序，它在给定的延迟之后将任务提交给默认的执行程序（或者如果不为正，则不会延迟）。
delayedExecutor(long, TimeUnit, Executor) - Static method in class java.util.concurrent. CompletableFuture
返回一个新的Executor，它在给定的延迟之后向给定的基本执行器提交一个任务（或者如果非正的则不会延迟）。
delayProperty() - Method in class javafx.animation. Animation
延迟动画的开始。
delayProperty() - Method in class javafx.concurrent. ScheduledService
首次启动ScheduledService之间的初始延迟，以及何时开始运行。
DelayQueue< E extends Delayed> - Class in java.util.concurrent
一个无限制的blocking queue的Delayed元素，其中元素只能在其延迟到期时被采用。
DelayQueue() - Constructor for class java.util.concurrent. DelayQueue
创建一个最初为空的新的 DelayQueue 。
DelayQueue(Collection<? extends E>) - Constructor for class java.util.concurrent. DelayQueue
创建一个DelayQueue最初包含给定集合的元素Delayed实例。
delegate - Variable in class javax.swing. DefaultCellEditor
处理从 CellEditor发送的所有方法的 CellEditor 。
Delegate - Class in org.omg.CORBA_2_3.portable
代理类提供ORB供应商具体实现CORBA对象。
Delegate - Class in org.omg.CORBA.portable
指定用于ORB特定于org.omg.CORBA.Object方法的ORB特定于实现的便携式API。
Delegate - Interface in org.omg.PortableServer.portable
可移植性包包含为ORB实现者设计和使用的接口和类。
Delegate() - Constructor for class org.omg.CORBA_2_3.portable. Delegate
Delegate() - Constructor for class org.omg.CORBA.portable. Delegate
DELEGATE_NAME - Static variable in class javax.management. MBeanServerDelegate
定义MBeanServerDelegate的默认ObjectName。
delegateFocus(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup
这是一种实用方法，可帮助事件处理程序在弹出弹出窗口时找出发送焦点的位置。
delegateFocus(MouseEvent) - Method in class javax.swing.plaf.metal. MetalComboBoxUI.MetalComboPopup
已过时。
DelegationPermission - Class in javax.security.auth.kerberos
此类用于限制Kerberos授权模型的使用，即：可转发和可预售的机票。
DelegationPermission(String) - Constructor for class javax.security.auth.kerberos. DelegationPermission
创建一个新的 DelegationPermission与指定的下属和目标主体。
DelegationPermission(String, String) - Constructor for class javax.security.auth.kerberos. DelegationPermission
创建一个新的 DelegationPermission与指定的下属和目标主体。
delete() - Method in class java.io. File
删除由此抽象路径名表示的文件或目录。
delete() - Method in interface javax.tools. FileObject
删除此文件对象。
delete() - Method in class javax.tools. ForwardingFileObject
delete() - Method in class javax.tools. SimpleJavaFileObject
这个实现什么都不做。
delete(int, int) - Method in class java.lang. StringBuffer
delete(int, int) - Method in class java.lang. StringBuilder
delete(int, int) - Method in interface javax.accessibility. AccessibleEditableText
删除两个索引之间的文本。
delete(int, int) - Method in class javax.swing. JSpinner.AccessibleJSpinner
删除两个索引之间的文本
delete(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent
删除两个索引之间的文本
delete(int, int, boolean) - Method in interface javafx.scene.control. TextInputControl.Content
从内容中删除一串字符。
delete(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
从此对象中删除属性。
delete(String) - Method in interface java.nio.file.attribute. UserDefinedFileAttributeView
删除用户定义的属性。
delete(URL) - Method in interface javax.jnlp. PersistenceService
从客户端日期持久性存储中删除与给定URL相关联的流。
delete(Path) - Static method in class java.nio.file. Files
删除文件。
delete(Path) - Method in class java.nio.file.spi. FileSystemProvider
删除文件。
DELETE - java.nio.file.attribute. AclEntryPermission
允许删除文件。
DELETE - javafx.scene.input. KeyCode
常数为 Delete键。
DELETE - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表逻辑delete运算符delete 。
DELETE - Static variable in class java.awt. Event
已过时。
删除键。
DELETE - Static variable in interface javax.accessibility. AccessibleTableModelChange
标识行和/或列的删除。
DELETE - Static variable in class javax.swing.event. TableModelEvent
标识删除行或列。
DELETE(HttpRequest.BodyProcessor) - Method in class jdk.incubator.http. HttpRequest.Builder
将此构建器的请求方法设置为DELETE，并将其请求体处理器设置为给定值。
DELETE_CHILD - java.nio.file.attribute. AclEntryPermission
删除目录中的文件或目录的权限。
DELETE_ON_CLOSE - java.nio.file. StandardOpenOption
关闭时删除。
DELETE_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi. SyncResolver
表示 RowSet对象尝试删除数据源中的行时发生冲突。
delete_values(String) - Method in class org.omg.CORBA. Context
从此 Context对象中删除 NamedValue对象（其中的 name字段与给定的属性名称匹配）。
deleteAllBreakpoints() - Method in interface com.sun.jdi.request. EventRequestManager
删除此EventRequestManager管理的所有断点。
deleteCaption() - Method in interface org.w3c.dom.html. HTMLTableElement
删除表格标题（如果存在）。
deleteCell(int) - Method in interface org.w3c.dom.html. HTMLTableRowElement
从当前行中删除单元格。
deleteChar(boolean) - Method in class javafx.scene.control.skin. TextFieldSkin
如果没有选择，则从文本中删除当前插入符号位置之后或之前的字符，如果有选择则删除选择。
deleteChar(AttributedCharacterIterator, int) - Method in class java.awt.font. LineBreakMeasurer
从文本中删除单个字符后更新此 LineBreakMeasurer ，并将当前位置设置为段落的开头。
deleteChar(AttributedCharacterIterator, int) - Method in class java.awt.font. TextMeasurer
更新 TextMeasurer后一个字符已经从当前由此表示的段落中删除 TextMeasurer 。
deleteCharAt(int) - Method in class java.lang. StringBuffer
deleteCharAt(int) - Method in class java.lang. StringBuilder
deleteContents() - Method in interface org.w3c.dom.ranges. Range
从包含的文档或文档片段中删除范围的内容，而不返回对删除的内容的引用。
deleteData(int, int) - Method in interface org.w3c.dom. CharacterData
从节点中删除一个16位的单位范围。
deleteDirectory(T) - Method in interface java.nio.file. SecureDirectoryStream
删除目录。
deleteEntry(String) - Method in class java.security. KeyStore
从此密钥库中删除由给定别名标识的条目。
deleteEventRequest(EventRequest) - Method in interface com.sun.jdi.request. EventRequestManager
删除eventRequest。
deleteEventRequests(List<? extends EventRequest>) - Method in interface com.sun.jdi.request. EventRequestManager
删除EventRequest的列表。
deleteFile(T) - Method in interface java.nio.file. SecureDirectoryStream
删除文件。
deleteIfExists(Path) - Static method in class java.nio.file. Files
删除文件（如果存在）。
deleteIfExists(Path) - Method in class java.nio.file.spi. FileSystemProvider
删除文件（如果存在）。
deleteMedium(String) - Method in interface org.w3c.dom.stylesheets. MediaList
从列表中删除由 oldMedium指定的媒体。
deleteNextChar() - Method in class javafx.scene.control. TextInputControl
如果没有选择，则从文本中删除当前插入符号位置后的字符，如果有选择则删除选择。
deleteNextCharAction - Static variable in class javax.swing.text. DefaultEditorKit
删除当前插入符位置后的内容的字符的操作名称。
deleteNextWordAction - Static variable in class javax.swing.text. DefaultEditorKit
删除选择开始之后的单词的动作名称。
deleteObserver(Observer) - Method in class java.util. Observable
已过时。
从该对象的观察者组中删除观察者。
deleteObservers() - Method in class java.util. Observable
已过时。
清除观察者列表，使此对象不再有任何观察者。
deleteOnExit() - Method in class java.io. File
请求在虚拟机终止时删除由此抽象路径名表示的文件或目录。
deleteOwner(Principal, Principal) - Method in interface java.security.acl. Owner
已过时。
删除所有者。
deletePrevCharAction - Static variable in class javax.swing.text. DefaultEditorKit
删除当前插入符号位置前的内容字符的操作名称。
deletePreviousChar() - Method in class javafx.scene.control. TextInputControl
如果没有选择，则从文本中删除当前插入符号位置之前的字符，如果有选择则删除选择。
deletePrevWordAction - Static variable in class javax.swing.text. DefaultEditorKit
要删除选择开始之前的单词的操作的名称。
deleteRow() - Method in interface java.sql. ResultSet
从此 ResultSet对象和底层数据库中删除当前行。
deleteRow(int) - Method in interface org.w3c.dom.html. HTMLTableElement
删除表格行。
deleteRow(int) - Method in interface org.w3c.dom.html. HTMLTableSectionElement
从此部分删除一行。
deleteRule(int) - Method in interface org.w3c.dom.css. CSSMediaRule
用于从媒体块中删除规则。
deleteRule(int) - Method in interface org.w3c.dom.css. CSSStyleSheet
用于从样式表中删除规则。
deletesAreDetected(int) - Method in interface java.sql. DatabaseMetaData
检索是否通过调用方法 ResultSet.rowDeleted检测到可见行删除。
deleteShortcut() - Method in class java.awt. MenuItem
删除与此菜单项相关联的任何 MenuShortcut对象。
deleteShortcut(MenuShortcut) - Method in class java.awt. MenuBar
删除指定的菜单快捷方式。
deleteText(int, int) - Method in class javafx.scene.control. TextInputControl
从内容中删除一系列字符。
deleteText(IndexRange) - Method in class javafx.scene.control. TextInputControl
从内容中删除一系列字符。
deleteTFoot() - Method in interface org.w3c.dom.html. HTMLTableElement
从表中删除页脚，如果存在。
deleteTHead() - Method in interface org.w3c.dom.html. HTMLTableElement
从表中删除标题（如果存在）。
deleteTrack(Track) - Method in class javax.sound.midi. Sequence
从序列中删除指定的轨迹。
delimiter() - Method in class java.util. Scanner
返回 Pattern这个 Scanner当前正在使用来匹配分隔符。
delItem(int) - Method in class java.awt. List
已过时。
替换为remove(String)和remove(int) 。
delItems(int, int) - Method in class java.awt. List
已过时。
从JDK 1.1版开始，未来不会公开使用。 这种方法只能作为一个包私有方法保留。
deliverEvent(Event) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代。
deliverEvent(Event) - Method in class java.awt. Container
已过时。
截至JDK 1.1版，由dispatchEvent(AWTEvent e)替代
deltaTransform(double[], int, double[], int, int) - Method in class java.awt.geom. AffineTransform
通过该变换来变换相对距离向量的数组。
deltaTransform(double, double) - Method in class javafx.scene.transform. Affine
deltaTransform(double, double) - Method in class javafx.scene.transform. Rotate
deltaTransform(double, double) - Method in class javafx.scene.transform. Scale
deltaTransform(double, double) - Method in class javafx.scene.transform. Shear
deltaTransform(double, double) - Method in class javafx.scene.transform. Transform
通过该变换来变换相对幅度矢量。
deltaTransform(double, double) - Method in class javafx.scene.transform. Translate
deltaTransform(double, double, double) - Method in class javafx.scene.transform. Affine
deltaTransform(double, double, double) - Method in class javafx.scene.transform. Rotate
deltaTransform(double, double, double) - Method in class javafx.scene.transform. Scale
deltaTransform(double, double, double) - Method in class javafx.scene.transform. Shear
deltaTransform(double, double, double) - Method in class javafx.scene.transform. Transform
通过该变换来变换相对幅度矢量。
deltaTransform(double, double, double) - Method in class javafx.scene.transform. Translate
deltaTransform(Point2D, Point2D) - Method in class java.awt.geom. AffineTransform
转换 ptSrc指定的相对距离向量， ptSrc结果存储在 ptDst 。
deltaTransform(Point2D) - Method in class javafx.scene.transform. Transform
通过该变换来转换由指定的 Point2D实例表示的相对幅度向量。
deltaTransform(Point2D) - Method in class javafx.scene.transform. Translate
deltaTransform(Point3D) - Method in class javafx.scene.transform. Transform
通过此变换转换由指定的 Point3D实例表示的相对幅度向量。
deltaTransform(Point3D) - Method in class javafx.scene.transform. Translate
DENY - java.nio.file.attribute. AclEntryType
显式地拒绝对文件或目录的访问。
dependents(Snippet) - Method in class jdk.jshell. SourceCodeAnalysis
返回 Snippet的集合，如果给定的 Snippet更新，则可能需要更新。
已过时的 - Annotation Type in java.lang
注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
DEPRECATED - com.sun.source.doctree. DocTree.Kind
用于实例DeprecatedTree表示@deprecated标记。
DeprecatedTree - Interface in com.sun.source.doctree
@deprecated块标记的树节点。
depth() - Method in interface com.sun.jdi.request. StepRequest
depth() - Method in interface java.io. ObjectInputFilter.FilterInfo
当前的深度。
depth() - Method in class javax.swing.text. ElementIterator
获取元素树的当前深度。
depthFirstEnumeration() - Method in class javax.swing.tree. DefaultMutableTreeNode
创建并返回以深度优先顺序遍历以此节点为根的子树的枚举。
depthOffset - Variable in class javax.swing.plaf.basic. BasicTreeUI
要适当地计算x位置应该抵消多少深度。
depthProperty() - Method in class javafx.scene.shape. Box
定义Box的深度或Z尺寸。
DepthTest - Enum in javafx.scene
该枚举定义了节点中depthTest标志的可能状态。
depthTestProperty() - Method in class javafx.scene. Node
指示在渲染此节点时是否使用深度测试。
Deque< E> - Interface in java.util
支持两端元素插入和移除的线性集合。
dequeueKeyEvents(long, Component) - Method in class java.awt. DefaultKeyboardFocusManager
释放正常调度到当前焦点所有者所有由于调用具有相同时间戳和组件的 enqueueKeyEvents KeyEvent。
dequeueKeyEvents(long, Component) - Method in class java.awt. KeyboardFocusManager
由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。
dereference(URIReference, XMLCryptoContext) - Method in interface javax.xml.crypto. URIDereferencer
取消指定的 URIReference并返回取消引用的数据。
dereference(XMLCryptoContext) - Method in interface javax.xml.crypto.dsig.keyinfo. RetrievalMethod
KeyInfo该 RetrievalMethod引用的 KeyInfo信息，并应用指定的 Transform s。
deregister() - Method in interface java.sql. DriverAction
由 DriverManager.deregisterDriver(Driver)调用的方法通知JDBC驱动程序它已被注销。
deregister(AbstractSelectionKey) - Method in class java.nio.channels.spi. AbstractSelector
从其频道的密钥集中删除给定的密钥。
deregisterAll() - Method in class javax.imageio.spi. ServiceRegistry
取消注册所有类别的所有当前注册服务提供商。
deregisterAll(Class<?>) - Method in class javax.imageio.spi. ServiceRegistry
取消注册目前在给定类别下注册的所有服务提供商对象。
deregisterDriver(Driver) - Static method in class java.sql. DriverManager
从 DriverManager的注册驱动程序列表中删除指定的驱动程序。
deregisterServiceProvider(Object) - Method in class javax.imageio.spi. ServiceRegistry
从包含它的所有类别中删除服务提供商对象。
deregisterServiceProvider(T, Class<T>) - Method in class javax.imageio.spi. ServiceRegistry
从给定的类别中删除服务提供者对象。
DERIVATION_EXTENSION - Static variable in interface org.w3c.dom. TypeInfo
如果文档的架构是XML Schema [ XML Schema Part 1 ]，则此常量表示由 extension派生 。
DERIVATION_LIST - Static variable in interface org.w3c.dom. TypeInfo
如果文档的架构是XML Schema [ XML Schema Part 1 ]，则此常量表示 list 。
DERIVATION_RESTRICTION - Static variable in interface org.w3c.dom. TypeInfo
如果文档的模式是一个XML Schema [ XML Schema Part 1 ]，这个常数代表由推导 restriction如果复杂类型参与，或 restriction ，如果简单类型的参与。
DERIVATION_UNION - Static variable in interface org.w3c.dom. TypeInfo
如果文档的架构是XML Schema [ XML Schema Part 1 ]，则该常量表示涉及简单类型的 union 。
derive(float) - Method in class java.awt. AlphaComposite
返回一个使用指定的alpha值的类似的 AlphaComposite对象。
derive(int) - Method in class java.awt. AlphaComposite
返回使用指定的合成规则的类似的 AlphaComposite对象。
deriveColor(double, double, double, double) - Method in class javafx.scene.paint. Color
基于这个 Color创建一个新的 Color ，色调，饱和度，亮度和不透明度值都改变了。
DeriveColorConverter - Class in javafx.css.converter
从颜色和亮度值导出颜色
deriveFont(float) - Method in class java.awt. Font
通过复制当前的 Font对象并应用新的大小来创建一个新的 Font对象。
deriveFont(int) - Method in class java.awt. Font
通过复制当前的 Font对象并应用新的样式来创建一个新的 Font对象。
deriveFont(int, float) - Method in class java.awt. Font
通过复制此 Font对象并应用新的样式和大小来创建新的 Font对象。
deriveFont(int, AffineTransform) - Method in class java.awt. Font
通过复制这个 Font对象并应用新的样式和变换来创建一个新的 Font对象。
deriveFont(AffineTransform) - Method in class java.awt. Font
通过复制当前的 Font对象并应用一个新的变换来创建一个新的 Font对象。
deriveFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Method in class java.awt. Font
通过复制当前的 Font对象并应用一组新的字体属性来创建一个新的 Font对象。
deriveMMFont(float[]) - Method in interface java.awt.font. MultipleMaster
根据指定数组中包含的设计轴值创建多个主字体的新实例。
deriveMMFont(float[], float, float, float, float) - Method in interface java.awt.font. MultipleMaster
基于详细的度量标准信息创建一个多个主字体的新实例。
DeriveSizeConverter - Class in javafx.css.converter
一种组合两个Size值的类型。
DES_EDE_KEY_LEN - Static variable in class javax.crypto.spec. DESedeKeySpec
定义DESede密钥长度的常数（以字节为单位）。
DES_KEY_LEN - Static variable in class javax.crypto.spec. DESKeySpec
定义DES密钥长度的常量（以字节为单位）。
desaturate() - Method in class javafx.scene.paint. Color
创建一个不太饱和的Color颜色的新颜色。
descendants() - Method in class java.lang. Process
返回进程后代的快照。
descendants() - Method in interface java.lang. ProcessHandle
返回进程后代的快照。
DESCENDING - javafx.scene.control. TableColumn.SortType
列将按降序排序。
DESCENDING - javafx.scene.control. TreeTableColumn.SortType
列将按降序排序。
DESCENDING - javax.swing. SortOrder
指示项目的枚举值按降序排序。
descendingIterator() - Method in class java.util. ArrayDeque
descendingIterator() - Method in class java.util.concurrent. ConcurrentLinkedDeque
以相反的顺序返回此deque中的元素的迭代器。
descendingIterator() - Method in class java.util.concurrent. ConcurrentSkipListSet
以降序返回该集合中的元素的迭代器。
descendingIterator() - Method in class java.util.concurrent. LinkedBlockingDeque
以相反的顺序返回此deque中的元素的迭代器。
descendingIterator() - Method in interface java.util. Deque
以相反的顺序返回此deque中的元素的迭代器。
descendingIterator() - Method in class java.util. LinkedList
descendingIterator() - Method in interface java.util. NavigableSet
以降序返回该集合中的元素的迭代器。
descendingIterator() - Method in class java.util. TreeSet
以降序返回该集合中的元素的迭代器。
descendingKeySet() - Method in interface java.util.concurrent. ConcurrentNavigableMap
返回此地图中包含的键的相反顺序NavigableSet 。
descendingKeySet() - Method in class java.util.concurrent. ConcurrentSkipListMap
descendingKeySet() - Method in interface java.util. NavigableMap
返回此地图中包含的键的相反顺序NavigableSet 。
descendingKeySet() - Method in class java.util. TreeMap
descendingMap() - Method in interface java.util.concurrent. ConcurrentNavigableMap
返回此映射中包含的映射的反向排序视图。
descendingMap() - Method in class java.util.concurrent. ConcurrentSkipListMap
descendingMap() - Method in interface java.util. NavigableMap
返回此映射中包含的映射的反向排序视图。
descendingMap() - Method in class java.util. TreeMap
descendingSet() - Method in class java.util.concurrent. ConcurrentSkipListSet
返回此集合中包含的元素的反向排序视图。
descendingSet() - Method in interface java.util. NavigableSet
返回此集合中包含的元素的反向排序视图。
descendingSet() - Method in class java.util. TreeSet
description - Variable in class java.sql. DriverPropertyInfo
属性的简要说明，可能为null。
description - Variable in class javax.management. MBeanFeatureInfo
该功能的人性化描述。
description() - Method in interface com.sun.javadoc. SerialFieldTag
已过时。
返回字段注释。
description() - Method in interface com.sun.jdi.connect. Connector.Argument
返回该参数及其目的的可读描述。
description() - Method in interface com.sun.jdi.connect. Connector
返回此连接器的可读描述及其目的。
description() - Method in class com.sun.jdi.connect.spi. TransportService
返回传输服务的描述。
description() - Method in interface com.sun.jdi. VirtualMachine
返回目标虚拟机上的文本信息和镜像它的调试器支持。
description() - Method in class com.sun.net.httpserver. Filter
返回此过滤器的简短说明
descriptor() - Method in class java.lang.module. ModuleReference
返回模块描述符。
Descriptor - Interface in javax.management
JMX元素的附加元数据。
DescriptorAccess - Interface in javax.management
该接口用于访问与JMX组件关联的描述符类的描述符，即
DescriptorKey - Annotation Type in javax.management
描述注释元素如何与Descriptor中的字段关联的元标注。
DescriptorRead - Interface in javax.management
用于读取管理界面元素（如MBeanInfo）的描述符的接口。
DescriptorSupport - Class in javax.management.modelmbean
此类表示一个ModelMBean元素的元数据集。
DescriptorSupport() - Constructor for class javax.management.modelmbean. DescriptorSupport
描述符默认构造函数。
DescriptorSupport(int) - Constructor for class javax.management.modelmbean. DescriptorSupport
描述符构造函数。
DescriptorSupport(String) - Constructor for class javax.management.modelmbean. DescriptorSupport
描述符构造函数采用XML字符串。
DescriptorSupport(String...) - Constructor for class javax.management.modelmbean. DescriptorSupport
构造器采用 fieldName = fieldValue格式的字段。
DescriptorSupport(String[], Object[]) - Constructor for class javax.management.modelmbean. DescriptorSupport
构造器获取字段名称和字段值。
DescriptorSupport(DescriptorSupport) - Constructor for class javax.management.modelmbean. DescriptorSupport
描述符构造函数将描述符作为参数。
DESedeKeySpec - Class in javax.crypto.spec
该类指定DES-EDE（“triple-DES”）键。
DESedeKeySpec(byte[]) - Constructor for class javax.crypto.spec. DESedeKeySpec
创建使用前24个字节在一个DESedeKeySpec对象， key作为DES-EDE密钥的密钥材料。
DESedeKeySpec(byte[], int) - Constructor for class javax.crypto.spec. DESedeKeySpec
创建使用前24个字节在一个DESedeKeySpec对象， key ，在开始 offset以下，作为DES-EDE密钥的密钥材料。
deselect() - Method in class javafx.scene.control. TextInputControl
清除选择。
deselect(int) - Method in class java.awt. List
取消选择指定索引处的项目。
DESELECTED - Static variable in class java.awt.event. ItemEvent
该状态变化值表示已选择的项目被取消选择。
DESERET - java.lang. Character.UnicodeScript
Unicode脚本“Deseret”。
DESERET - Static variable in class java.lang. Character.UnicodeBlock
“Deseret”Unicode字符块的常量。
deserialize(ObjectInputStream, Collection) - Method in class java.beans.beancontext. BeanContextSupport
由readObject用于反序列化集合。
deserialize(String, byte[]) - Method in interface javax.management. MBeanServer
已过时。
使用MBeanServer.getClassLoaderRepository()获取类加载程序库，并将其用于反序列化。
deserialize(String, ObjectName, byte[]) - Method in interface javax.management. MBeanServer
已过时。
使用getClassLoader获取反序列化的类加载器。
deserialize(ObjectName, byte[]) - Method in interface javax.management. MBeanServer
已过时。
使用getClassLoaderFor获取适当的反序列化类加载器。
DESIGNATED_LONG - Static variable in class javafx.print. Paper
指定ISO指定长尺寸，110 mm×220 mm。
DESIGNATED_LONG - Static variable in class javax.print.attribute.standard. MediaSize.ISO
指定ISO指定长尺寸，110 mm×220 mm。
DesignMode - Interface in java.beans
该接口旨在由java.beans.beancontext.BeanContext的实例实现或委派，以便传播到java.beans.beancontext.BeanContextChild实例（当前的“designTime”）属性的嵌套层次结构。
designTime - Variable in class java.beans.beancontext. BeanContextSupport
A boolean指示该对象当前是否处于设计时间模式。
desiredAssertionStatus() - Method in class java.lang. Class
如果要在调用此方法时初始化该类，则返回将分配给此类的断言状态。
DESKeySpec - Class in javax.crypto.spec
该类指定一个DES密钥。
DESKeySpec(byte[]) - Constructor for class javax.crypto.spec. DESKeySpec
创建使用前8个字节中一个DESKeySpec对象， key作为DES密钥的密钥材料。
DESKeySpec(byte[], int) - Constructor for class javax.crypto.spec. DESKeySpec
创建使用前8个字节中一个DESKeySpec对象， key ，在开始 offset以下，作为DES密钥的密钥材料。
desktop - Static variable in class java.awt. SystemColor
渲染为桌面背景的颜色。
desktop - Variable in class javax.swing.plaf.basic. BasicDesktopPaneUI
实例 JDesktopPane 。
Desktop - Class in java.awt
Desktop类允许与各种桌面功能进行交互。
DESKTOP - Static variable in class java.awt. SystemColor
阵列索引为 SystemColor.desktop系统颜色。
DESKTOP_ICON - Static variable in class javax.accessibility. AccessibleRole
一个图标化的内部框架在一个 DESKTOP_PANE 。
DESKTOP_ICON - Static variable in class javax.swing.plaf.synth. Region
DesktopIcon区域。
DESKTOP_PANE - Static variable in class javax.accessibility. AccessibleRole
支持这些内部框架的内部框架和图标化版本的窗格。
DESKTOP_PANE - Static variable in class javax.swing.plaf.synth. Region
DesktopPane区域。
Desktop.Action - Enum in java.awt
表示动作类型。
desktopIcon - Variable in class javax.swing. JInternalFrame
当内部框架被图标化时显示的图标。
desktopIcon - Variable in class javax.swing.plaf.basic. BasicDesktopIconUI
实例 JInternalFrame.JDesktopIcon 。
DesktopIconUI - Class in javax.swing.plaf
JDesktopIcon可插拔的外观和界面。
DesktopIconUI() - Constructor for class javax.swing.plaf. DesktopIconUI
desktopManager - Variable in class javax.swing.plaf.basic. BasicDesktopPaneUI
实例 DesktopManager 。
DesktopManager - Interface in javax.swing
DesktopManager对象由JDesktopPane对象拥有。
DesktopPaneUI - Class in javax.swing.plaf
JDesktopPane可插拔外观界面。
DesktopPaneUI() - Constructor for class javax.swing.plaf. DesktopPaneUI
desktopProperties - Variable in class java.awt. Toolkit
桌面属性。
desktopPropsSupport - Variable in class java.awt. Toolkit
桌面属性更改支持。
DEST_DISTANCE_REF_KILOMETERS - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSDestDistanceRef”标签一起使用的值。
DEST_DISTANCE_REF_KNOTS - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSDestDistanceRef”标签一起使用的值。
DEST_DISTANCE_REF_MILES - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSDestDistanceRef”标签一起使用的值。
destHeight - Variable in class java.awt.image. ReplicateScaleFilter
目标高度来缩放图像。
destination - Variable in class javax.imageio. ImageReadParam
当前目的地 BufferedImage ，如果没有设置， null 。
destination - Variable in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
接收所有事件的目的地。
Destination - Class in javax.print.attribute.standard
类目标是打印属性类（URI），用于指示假脱机打印机格式化数据的备用目标。
Destination(URI) - Constructor for class javax.print.attribute.standard. Destination
使用指定的URI构造新的目标属性。
destinationBands - Variable in class javax.imageio. ImageReadParam
要使用的目标频带集合，作为 int的阵列。
destinationOffset - Variable in class javax.imageio. IIOParam
应放置左上角解码像素的目的地偏移量。
destinationType - Variable in class javax.imageio. IIOParam
一个 ImageTypeSpecifier用于在读取时生成目标图像，或者在写入时设置输出颜色类型。
destroy() - Method in class java.applet. Applet
已过时。
由浏览器或小程序查看器调用以通知此小程序它正在被回收，并且它应该销毁其分配的任何资源。
destroy() - Method in class java.lang. Process
杀死这个过程。
destroy() - Method in interface java.lang. ProcessHandle
请求进程被杀死。
destroy() - Method in class java.lang. Thread
不推荐用于删除：此API元素将在以后的版本中被删除。
这种方法最初是为了销毁这个线程而没有任何清理。 它所持有的任何监视器都将保持锁定。 但是，该方法从未实现。 如果要实施，那么它将是Thread.suspend()的方式会是死锁的倾向。 如果目标线程在销毁时保护关键系统资源的锁，则无法再次访问该资源。 如果另一个线程曾尝试锁定此资源，将导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
destroy() - Method in class java.lang. ThreadGroup
销毁此线程组及其所有子组。
destroy() - Method in class java.security. KeyStore.PasswordProtection
清除密码。
destroy() - Method in interface javax.security.auth. Destroyable
破坏这 Object 。
destroy() - Method in class javax.security.auth.kerberos. EncryptionKey
清除此键的关键材料来销毁此键。
destroy() - Method in class javax.security.auth.kerberos. KerberosCredMessage
清除该消息来销毁此对象。
destroy() - Method in class javax.security.auth.kerberos. KerberosKey
清除此密钥的密钥材料即可销毁此密钥。
destroy() - Method in class javax.security.auth.kerberos. KerberosTicket
销毁票据并销毁其中存储的任何敏感信息。
destroy() - Method in class javax.security.auth.x500. X500PrivateCredential
清除此对象中X.509证书，私钥和KeyStore别名的引用。
destroy() - Method in class org.omg.CORBA. _IDLTypeStub
destroy() - Method in class org.omg.CORBA. _PolicyStub
销毁策略对象。
destroy() - Method in interface org.omg.CORBA. DynAny
已过时。
销毁此 DynAny对象，并释放用于表示与之关联的数据值的任何资源。
destroy() - Method in interface org.omg.CORBA. IRObjectOperations
破坏这个对象。
destroy() - Method in class org.omg.CORBA. ORB
破坏ORB，以便资源可以回收。
destroy() - Method in interface org.omg.CORBA. PolicyOperations
销毁 Policy对象。
destroy() - Method in class org.omg.CosNaming. _BindingIteratorStub
此操作会破坏迭代器。
destroy() - Method in class org.omg.CosNaming. _NamingContextExtStub
破坏操作会删除命名上下文。
destroy() - Method in class org.omg.CosNaming. _NamingContextStub
破坏操作会删除命名上下文。
destroy() - Method in interface org.omg.CosNaming. BindingIteratorOperations
此操作会破坏迭代器。
destroy() - Method in interface org.omg.CosNaming. NamingContextOperations
破坏操作会删除命名上下文。
destroy() - Method in class org.omg.DynamicAny. _DynAnyStub
销毁DynAny对象。
destroy() - Method in class org.omg.DynamicAny. _DynArrayStub
销毁DynAny对象。
destroy() - Method in class org.omg.DynamicAny. _DynEnumStub
销毁DynAny对象。
destroy() - Method in class org.omg.DynamicAny. _DynFixedStub
销毁DynAny对象。
destroy() - Method in class org.omg.DynamicAny. _DynSequenceStub
销毁DynAny对象。
destroy() - Method in class org.omg.DynamicAny. _DynStructStub
销毁DynAny对象。
destroy() - Method in class org.omg.DynamicAny. _DynUnionStub
销毁DynAny对象。
destroy() - Method in class org.omg.DynamicAny. _DynValueStub
销毁DynAny对象。
destroy() - Method in interface org.omg.DynamicAny. DynAnyOperations
销毁DynAny对象。
destroy() - Method in interface org.omg.PortableInterceptor. InterceptorOperations
提供破坏此拦截器的机会。
destroy(boolean, boolean) - Method in interface org.omg.PortableServer. POAOperations
此操作会破坏POA和所有后代的POA。
Destroyable - Interface in javax.security.auth
诸如凭证的对象可以可选地实现该接口以提供破坏其内容的能力。
destroyBuffers() - Method in class java.awt. Component.FlipBufferStrategy
破坏通过此对象创建的缓冲区
DestroyFailedException - Exception in javax.security.auth
表示 destroy操作失败。
DestroyFailedException() - Constructor for exception javax.security.auth. DestroyFailedException
构造一个没有详细消息的DestroyFailedException。
DestroyFailedException(String) - Constructor for exception javax.security.auth. DestroyFailedException
构造具有指定详细消息的DestroyFailedException。
destroyForcibly() - Method in class java.lang. Process
强制杀死进程。
destroyForcibly() - Method in interface java.lang. ProcessHandle
要求进程被强行杀死。
destroySubcontext(String) - Method in interface javax.naming. Context
销毁命名上下文并将其从命名空间中删除。
destroySubcontext(String) - Method in class javax.naming. InitialContext
destroySubcontext(Name) - Method in interface javax.naming. Context
销毁命名上下文并将其从命名空间中删除。
destroySubcontext(Name) - Method in class javax.naming. InitialContext
destWidth - Variable in class java.awt.image. ReplicateScaleFilter
缩放图像的目标宽度。
detach() - Method in class com.sun.tools.attach. VirtualMachine
脱离虚拟机。
detach() - Method in interface org.w3c.dom.ranges. Range
被称为表示该范围已不再使用，并且该实现可能放弃与此Range相关联的任何资源。
detach() - Method in interface org.w3c.dom.traversal. NodeIterator
从它迭代的集合中分离出 NodeIterator ，释放任何计算资源，并将 NodeIterator置于INVALID状态。
detachNode() - Method in interface javax.xml.soap. Node
从树中删除此 Node对象。
detail - Variable in exception java.io. WriteAbortedException
写入ObjectStream时被捕获的异常。
detail - Variable in exception java.rmi.activation. ActivationException
激活异常的原因。
detail - Variable in exception java.rmi. RemoteException
远程异常的原因。
detail - Variable in exception java.rmi.server. ServerCloneException
造成异常的原因。
Detail - Interface in javax.xml.soap
一个用于 DetailEntry对象的容器。
DetailEntry - Interface in javax.xml.soap
对于内容 Detail对象，给予细节的 SOAPFault对象。
detailsViewIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
详细视图图标
detectedCharset() - Method in class java.nio.charset. CharsetDecoder
检索该解码器检测到的字符集 （可选操作） 。
detectJdiExitEvent(VirtualMachine, Consumer<String>) - Static method in class jdk.jshell.execution. Util
监控JDI事件流VMDeathEvent和VMDisconnectEvent 。
determinant() - Method in class javafx.scene.transform. Affine
determinant() - Method in class javafx.scene.transform. Transform
计算转换矩阵的行列式。
determineOffset(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.tree. DefaultTreeCellEditor
确定偏移量。
DEVANAGARI - java.awt.font. NumericShaper.Range
梵文的范围与梵文数字。
DEVANAGARI - java.lang. Character.UnicodeScript
Unicode脚本“Devanagari”。
DEVANAGARI - Static variable in class java.awt.font. NumericShaper
标识DEVANAGARI范围和十进制基数。
DEVANAGARI - Static variable in class java.lang. Character.UnicodeBlock
“Devanagari”Unicode字符块的常量。
DEVANAGARI_EXTENDED - Static variable in class java.lang. Character.UnicodeBlock
“梵文扩展”Unicode字符块的常量。
DEVELOPER_EMPTY - Static variable in class javax.print.attribute.standard. PrinterStateReason
该设备不在开发者身上。
DEVELOPER_LOW - Static variable in class javax.print.attribute.standard. PrinterStateReason
该设备的开发人员低。
DFN - Static variable in class javax.swing.text.html. HTML.Tag
标签<dfn>
DGC - Interface in java.rmi.dgc
DGC抽象用于分布式垃圾回收算法的服务器端。
DGC_ID - Static variable in class java.rmi.server. ObjID
对象编号为知名的 ObjID的分布式垃圾收集器。
DHGenParameterSpec - Class in javax.crypto.spec
此类指定用于生成Diffie-Hellman密钥协议中使用的Diffie-Hellman（系统）参数的参数集。
DHGenParameterSpec(int, int) - Constructor for class javax.crypto.spec. DHGenParameterSpec
构造用于生成Diffie-Hellman（系统）参数的参数集。
DHKey - Interface in javax.crypto.interfaces
与Diffie-Hellman密钥的接口。
DHParameterSpec - Class in javax.crypto.spec
该类指定与PKCS＃3： Diffie-Hellman密钥协商标准中指定的Diffie-Hellman算法一起使用的参数集合。
DHParameterSpec(BigInteger, BigInteger) - Constructor for class javax.crypto.spec. DHParameterSpec
使用质数模数 p和基本生成器 g构造Diffie-Hellman的参数集。
DHParameterSpec(BigInteger, BigInteger, int) - Constructor for class javax.crypto.spec. DHParameterSpec
使用随机指数（私有值）的质数 p ，基本生成器 g和位数 l的大小构造Diffie-Hellman的参数集。
DHPrivateKey - Interface in javax.crypto.interfaces
与Diffie-Hellman私钥的接口。
DHPrivateKeySpec - Class in javax.crypto.spec
该类指定具有相关参数的Diffie-Hellman私钥。
DHPrivateKeySpec(BigInteger, BigInteger, BigInteger) - Constructor for class javax.crypto.spec. DHPrivateKeySpec
私有价值 x ，质数模数 p和基本生成器 g 。
DHPublicKey - Interface in javax.crypto.interfaces
与Diffie-Hellman公钥的接口。
DHPublicKeySpec - Class in javax.crypto.spec
该类指定具有相关参数的Diffie-Hellman公钥。
DHPublicKeySpec(BigInteger, BigInteger, BigInteger) - Constructor for class javax.crypto.spec. DHPublicKeySpec
具有公开值 y ，素数模数 p和基本生成器 g 。
Diag - Class in jdk.jshell
代码段的诊断信息。
Diagnostic< S> - Interface in javax.tools
工具诊断界面。
Diagnostic - Interface in jdk.nashorn.api.tree
工具诊断界面。
Diagnostic.Kind - Enum in javax.tools
诊断的种类，例如错误或警告。
Diagnostic.Kind - Enum in jdk.nashorn.api.tree
诊断的种类，例如错误或警告。
DiagnosticCollector< S> - Class in javax.tools
提供在列表中收集诊断的简单方法。
DiagnosticCollector() - Constructor for class javax.tools. DiagnosticCollector
DiagnosticCommandMBean - Interface in com.sun.management
HotSpot Virtual Machine诊断命令的管理界面。
DiagnosticListener< S> - Interface in javax.tools
用于从工具接收诊断的接口。
DiagnosticListener - Interface in jdk.nashorn.api.tree
用于从Nashorn解析器接收诊断的接口。
diagnostics(Snippet) - Method in class jdk.jshell. JShell
返回片段最近评估的诊断。
Dialog - Class in java.awt
Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
Dialog< R> - Class in javafx.scene.control
JavaFX中的Dialog包装了一个DialogPane，并提供了必要的API来将其呈现给最终用户。
Dialog() - Constructor for class javafx.scene.control. Dialog
创建一个没有指定所有者的对话框。
Dialog(Dialog) - Constructor for class java.awt. Dialog
构造一个最初看不见的，无指定的 Dialog与指定的所有者 Dialog和一个空的标题。
Dialog(Dialog, String) - Constructor for class java.awt. Dialog
构造一个最初看不见的，无模式的 Dialog与指定的所有者 Dialog和标题。
Dialog(Dialog, String, boolean) - Constructor for class java.awt. Dialog
构造最初不可见的 Dialog与指定的所有者 Dialog ，标题和模态。
Dialog(Dialog, String, boolean, GraphicsConfiguration) - Constructor for class java.awt. Dialog
构造最初无形 Dialog与指定的所有者 Dialog ，标题，模式和 GraphicsConfiguration 。
Dialog(Frame) - Constructor for class java.awt. Dialog
构造一个最初看不见的，无指定的 Dialog与指定的所有者 Frame和一个空的标题。
Dialog(Frame, boolean) - Constructor for class java.awt. Dialog
构造最初不可见的 Dialog与指定的所有者 Frame和模态和一个空的标题。
Dialog(Frame, String) - Constructor for class java.awt. Dialog
构造一个最初看不见的，无模式的 Dialog与指定的所有者 Frame和标题。
Dialog(Frame, String, boolean) - Constructor for class java.awt. Dialog
构造一个最初看不见的 Dialog与指定的所有者 Frame ，标题和模态。
Dialog(Frame, String, boolean, GraphicsConfiguration) - Constructor for class java.awt. Dialog
构造最初无形 Dialog与指定的所有者 Frame ，标题，模态和 GraphicsConfiguration 。
Dialog(Window) - Constructor for class java.awt. Dialog
构造一个最初看不见的，无模式的 Dialog与指定的所有者 Window和一个空的标题。
Dialog(Window, Dialog.ModalityType) - Constructor for class java.awt. Dialog
构造最初不可见的 Dialog与指定的所有者 Window和模态和一个空的标题。
Dialog(Window, String) - Constructor for class java.awt. Dialog
构造一个最初看不见的，无模式的 Dialog与指定的所有者 Window和标题。
Dialog(Window, String, Dialog.ModalityType) - Constructor for class java.awt. Dialog
构造一个最初看不见的 Dialog与指定的所有者 Window ，标题和模态。
Dialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - Constructor for class java.awt. Dialog
构造最初不可见的 Dialog与指定的所有者 Window ，标题，模式和 GraphicsConfiguration 。
DIALOG - Static variable in class java.awt. Font
逻辑字体“对话框”的规范系列名称的字符串常量。
DIALOG - Static variable in class javax.accessibility. AccessibleRole
标题栏和边框的顶级窗口。
DIALOG_CLOSE_REQUEST - Static variable in class javafx.scene.control. DialogEvent
当有外部请求关闭该对话框时，此事件将传递到对话框。
DIALOG_HIDDEN - Static variable in class javafx.scene.control. DialogEvent
此事件发生在隐藏后的对话框上。
DIALOG_HIDING - Static variable in class javafx.scene.control. DialogEvent
此事件发生在隐藏之前的对话框上。
DIALOG_INPUT - Static variable in class java.awt. Font
逻辑字体“DialogInput”的规范系列名称的字符串常量。
DIALOG_SHOWING - Static variable in class javafx.scene.control. DialogEvent
此事件发生在显示之前的对话框上。
DIALOG_SHOWN - Static variable in class javafx.scene.control. DialogEvent
此事件发生在显示之后的对话框上。
DIALOG_TITLE_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
标识对话标题中的更改。
DIALOG_TYPE_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
标识显示文件类型的变化（仅文件，仅目录，或文件和目录）。
DIALOG_UI - Static variable in class javax.print. ServiceUIFactory
表示实现为AWT对话框的UI。
Dialog.AccessibleAWTDialog - Class in java.awt
该类为 Dialog类实现可访问性支持。
Dialog.ModalExclusionType - Enum in java.awt
任何顶级窗口都可以标记为不被模态对话框阻止。
Dialog.ModalityType - Enum in java.awt
模态对话框阻止某些顶级窗口的所有输入。
DialogEvent - Class in javafx.scene.control
与对话框显示/隐藏操作相关的事件。
DialogEvent(Dialog<?>, EventType<? extends Event>) - Constructor for class javafx.scene.control. DialogEvent
构造一个新的 Event与指定的事件源，目标和类型。
dialogInit() - Method in class javax.swing. JDialog
由构造函数调用，正确启动 JDialog 。
DialogPane - Class in javafx.scene.control
DialogPane应该被认为是在一个Dialog实例中显示的根节点 。
DialogPane() - Constructor for class javafx.scene.control. DialogPane
创建一个带有“dialog-pane”样式类的新DialogPane实例。
dialogPaneProperty() - Method in class javafx.scene.control. Dialog
对话框的根节点 ， DialogPane包含对话框中显示的所有视觉元素。
DialogTypeSelection - Class in javax.print.attribute.standard
DialogTypeSelection类是一个打印属性类，一个枚举，指示用于指定打印选项的用户对话框类型。
DialogTypeSelection(int) - Constructor for class javax.print.attribute.standard. DialogTypeSelection
使用给定的整数值构造新的对话框类型选择枚举值。
Dictionary< K, V> - Class in java.util
Dictionary类是任何类的抽象父类，例如 Hashtable ，它将键映射到值。
Dictionary() - Constructor for class java.util. Dictionary
唯一的构造函数。
die() - Method in class javax.swing.undo. AbstractUndoableEdit
将 alive设为false。
die() - Method in class javax.swing.undo. CompoundEdit
向每个子编辑器发送 die ，与添加的顺序相反。
die() - Method in interface javax.swing.undo. UndoableEdit
通知编辑它不应再被使用。
DIFFERENCE - javafx.scene.effect. BlendMode
从较浅的输入中减去两个输入的颜色分量较暗，以产生最终的颜色。
DIFFERENTIAL_CORRECTION_APPLIED - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSDifferential”标签一起使用的值。
DIFFERENTIAL_CORRECTION_NONE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSDifferential”标签一起使用的值。
diffuseColorProperty() - Method in class javafx.scene.paint. PhongMaterial
这个漫反射的颜色这个 PhongMaterial 。
diffuseConstantProperty() - Method in class javafx.scene.effect. Lighting
漫反射常数。
diffuseMapProperty() - Method in class javafx.scene.paint. PhongMaterial
这个漫反射图 PhongMaterial 。
digest - Variable in class java.security. DigestInputStream
与此流相关联的消息摘要。
digest - Variable in class java.security. DigestOutputStream
与此流相关联的消息摘要。
digest() - Method in class java.security. MessageDigest
通过执行最后的操作（如填充）来完成哈希计算。
digest(byte[]) - Method in class java.security. MessageDigest
使用指定的字节数组对摘要执行最终更新，然后完成摘要计算。
digest(byte[], int, int) - Method in class java.security. MessageDigest
通过执行最后的操作（如填充）来完成哈希计算。
digestAlgorithm(String) - Method in class jdk.security.jarsigner. JarSigner.Builder
设置摘要算法。
digestAlgorithm(String, Provider) - Method in class jdk.security.jarsigner. JarSigner.Builder
从指定的提供者设置摘要算法。
DigestException - Exception in java.security
这是通用的消息摘要异常。
DigestException() - Constructor for exception java.security. DigestException
构造一个没有详细消息的DigestException。
DigestException(String) - Constructor for exception java.security. DigestException
构造具有指定详细消息的DigestException。
DigestException(String, Throwable) - Constructor for exception java.security. DigestException
创建一个 DigestException与指定的详细信息和原因。
DigestException(Throwable) - Constructor for exception java.security. DigestException
创建 DigestException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
DigestInputStream - Class in java.security
透明流，使用通过流的位更新关联的消息摘要。
DigestInputStream(InputStream, MessageDigest) - Constructor for class java.security. DigestInputStream
使用指定的输入流和消息摘要创建摘要输入流。
DigestMethod - Interface in javax.xml.crypto.dsig
在 DigestMethod中定义的XML DigestMethod元素的 表示 。
DigestMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec
一个DigestMethod算法的算法参数说明 。
DigestOutputStream - Class in java.security
透明流，使用通过流的位更新关联的消息摘要。
DigestOutputStream(OutputStream, MessageDigest) - Constructor for class java.security. DigestOutputStream
使用指定的输出流和消息摘要创建摘要输出流。
digit(char, int) - Static method in class java.lang. Character
返回指定基数中的字符 ch的数值。
digit(int, int) - Static method in class java.lang. Character
返回指定基数中指定字符（Unicode代码点）的数值。
DIGIT0 - javafx.scene.input. KeyCode
常数为 0键。
DIGIT1 - javafx.scene.input. KeyCode
常数为 1键。
DIGIT2 - javafx.scene.input. KeyCode
常数为 2键。
DIGIT3 - javafx.scene.input. KeyCode
常数为 3键。
DIGIT4 - javafx.scene.input. KeyCode
常数为 4键。
DIGIT5 - javafx.scene.input. KeyCode
常数为 5键。
DIGIT6 - javafx.scene.input. KeyCode
常数为 6键。
DIGIT7 - javafx.scene.input. KeyCode
常数为 7键。
DIGIT8 - javafx.scene.input. KeyCode
常数为 8键。
DIGIT9 - javafx.scene.input. KeyCode
常数为 9键。
dimension() - Method in interface com.sun.javadoc. Type
已过时。
返回类型的维度信息，作为字符串。
Dimension - Class in java.awt
Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
Dimension() - Constructor for class java.awt. Dimension
创建一个 Dimension的实例，宽度为零，高度为零。
Dimension(int, int) - Constructor for class java.awt. Dimension
构造一个 Dimension ，并将其初始化为指定的宽度和指定的高度。
Dimension(Dimension) - Constructor for class java.awt. Dimension
创建一个 Dimension的实例，其宽度和高度与指定维度相同。
Dimension2D - Class in java.awt.geom
Dimension2D类封装了宽度和高度尺寸。
Dimension2D - Class in javafx.geometry
包含宽度和高度的2D维度对象。
Dimension2D() - Constructor for class java.awt.geom. Dimension2D
这是一个无法直接实例化的抽象类。
Dimension2D(double, double) - Constructor for class javafx.geometry. Dimension2D
构造具有指定宽度和高度的 Dimension2D 。
DimensionUIResource - Class in javax.swing.plaf
Dimension的子类实现 UIResource 。
DimensionUIResource(int, int) - Constructor for class javax.swing.plaf. DimensionUIResource
构造一个 DimensionUIResource 。
DIMGRAY - Static variable in class javafx.scene.paint. Color
颜色变暗，RGB值为＃696969
DIMGREY - Static variable in class javafx.scene.paint. Color
颜色变暗，RGB值为＃696969
DINGBATS - Static variable in class java.lang. Character.UnicodeBlock
“Dingbats”Unicode字符块的常量。
DIR - Static variable in class javax.swing.text.html. HTML.Attribute
属性“dir”
DIR - Static variable in class javax.swing.text.html. HTML.Tag
标签<dir>
DirContext - Interface in javax.naming.directory
目录服务界面，包含检查和更新与对象关联的属性以及搜索目录的方法。
DIRECT - java.net. Proxy.Type
代表一个直接连接，或代表不存在。
DirectColorModel - Class in java.awt.image
DirectColorModel类是一个 ColorModel类，可以将像素值用于表示RGB颜色和alpha信息作为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。
DirectColorModel(int, int, int, int) - Constructor for class java.awt.image. DirectColorModel
从指定的掩码构建一个 DirectColorModel ，指示 int像素表示中的哪些位包含红色，绿色和蓝色样本。
DirectColorModel(int, int, int, int, int) - Constructor for class java.awt.image. DirectColorModel
从指定的掩码构建一个 DirectColorModel ，指示 int像素表示中的哪些位包含红色，绿色和蓝色样本以及alpha样本（如果存在）。
DirectColorModel(ColorSpace, int, int, int, int, int, boolean, int) - Constructor for class java.awt.image. DirectColorModel
从指定的参数构造一个 DirectColorModel 。
DirectExecutionControl - Class in jdk.jshell.execution
一个在当前进程中运行的ExecutionControl实现。
DirectExecutionControl() - Constructor for class jdk.jshell.execution. DirectExecutionControl
使用默认的类加载创建一个实例。
DirectExecutionControl(LoaderDelegate) - Constructor for class jdk.jshell.execution. DirectExecutionControl
创建一个实例，将加载器操作委派给指定的委托。
direction - Variable in class javax.swing.plaf.basic. BasicArrowButton
方向箭头。
direction - Variable in class javax.swing.plaf.basic. BasicTreeUI.TreeHomeAction
方向。
direction - Variable in class javax.swing.plaf.basic. BasicTreeUI.TreeIncrementAction
指定调整选择的方向。
direction - Variable in class javax.swing.plaf.basic. BasicTreeUI.TreePageAction
指定调整选择的方向。
direction - Variable in class javax.swing.plaf.basic. BasicTreeUI.TreeTraverseAction
确定要移动的方向，1表示展开，-1表示折叠。
DIRECTION_DEFAULT_LEFT_TO_RIGHT - Static variable in class java.text. Bidi
常数表示基本方向取决于文本中根据Unicode双向算法的第一个强定向字符。
DIRECTION_DEFAULT_RIGHT_TO_LEFT - Static variable in class java.text. Bidi
常数表示基本方向取决于文本中根据Unicode双向算法的第一个强定向字符。
DIRECTION_LEFT_TO_RIGHT - Static variable in class java.text. Bidi
常数表示基地方向是从左到右。
DIRECTION_REF_MAGNETIC - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。
DIRECTION_REF_TRUE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。
DIRECTION_RIGHT_TO_LEFT - Static variable in class java.text. Bidi
恒定指示基准方向是从右到左。
DIRECTIONALITY_ARABIC_NUMBER - Static variable in class java.lang. Character
Unicode规范中的弱双向字符类型“AN”。
DIRECTIONALITY_BOUNDARY_NEUTRAL - Static variable in class java.lang. Character
Unicode规范中的双向字符类型“BN”弱。
DIRECTIONALITY_COMMON_NUMBER_SEPARATOR - Static variable in class java.lang. Character
Unicode规范中的双向字符类型“CS”弱。
DIRECTIONALITY_EUROPEAN_NUMBER - Static variable in class java.lang. Character
Unicode规范中的弱双向字符类型“EN”。
DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR - Static variable in class java.lang. Character
Unicode规范中的双向字符类型为“ES”较弱。
DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR - Static variable in class java.lang. Character
Unicode规范中的双向字符类型“ET”较弱。
DIRECTIONALITY_FIRST_STRONG_ISOLATE - Static variable in class java.lang. Character
Unicode规范中的弱双向字符类型“FSI”。
DIRECTIONALITY_LEFT_TO_RIGHT - Static variable in class java.lang. Character
Unicode规范中的强双向字符类型“L”。
DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING - Static variable in class java.lang. Character
Unicode规范中的强双向字符类型“LRE”。
DIRECTIONALITY_LEFT_TO_RIGHT_ISOLATE - Static variable in class java.lang. Character
Unicode规范中的双向字符类型“LRI”弱。
DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE - Static variable in class java.lang. Character
Unicode规范中的强双向字符类型“LRO”。
DIRECTIONALITY_NONSPACING_MARK - Static variable in class java.lang. Character
Unicode规范中的弱双向字符类型“NSM”。
DIRECTIONALITY_OTHER_NEUTRALS - Static variable in class java.lang. Character
Unicode规范中的中立双向字符类型“ON”。
DIRECTIONALITY_PARAGRAPH_SEPARATOR - Static variable in class java.lang. Character
Unicode规范中的中立双向字符类型“B”。
DIRECTIONALITY_POP_DIRECTIONAL_FORMAT - Static variable in class java.lang. Character
Unicode规范中的双向字符类型为“PDF”。
DIRECTIONALITY_POP_DIRECTIONAL_ISOLATE - Static variable in class java.lang. Character
Unicode规范中的双向字符类型为“PDI”。
DIRECTIONALITY_RIGHT_TO_LEFT - Static variable in class java.lang. Character
Unicode规范中的强双向字符类型“R”。
DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC - Static variable in class java.lang. Character
Unicode规范中的强双向字符类型“AL”。
DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING - Static variable in class java.lang. Character
Unicode规范中的强双向字符类型“RLE”。
DIRECTIONALITY_RIGHT_TO_LEFT_ISOLATE - Static variable in class java.lang. Character
Unicode规范中的弱双向字符类型“RLI”。
DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE - Static variable in class java.lang. Character
Unicode规范中的强双向字符类型“RLO”。
DIRECTIONALITY_SEGMENT_SEPARATOR - Static variable in class java.lang. Character
Unicode规范中的中立双向字符类型“S”。
DIRECTIONALITY_UNDEFINED - Static variable in class java.lang. Character
未定义的双向字符类型。
DIRECTIONALITY_WHITESPACE - Static variable in class java.lang. Character
Unicode规范中的中立双向字符类型“WS”。
DirectiveTree - Interface in com.sun.source.tree
对于ModuleTree中的所有指令的超类型。
DIRECTORIES_ONLY - Static variable in class javax.swing. JFileChooser
仅显示目录的指令。
directory() - Method in class java.lang. ProcessBuilder
返回此进程构建器的工作目录。
directory(File) - Method in class java.lang. ProcessBuilder
设置此进程构建器的工作目录。
DIRECTORY_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
标识用户的目录更改。
DIRECTORY_INHERIT - java.nio.file.attribute. AclEntryFlag
可以放在一个目录上，并指示ACL条目应该添加到创建的每个新目录中。
DIRECTORY_PANE - Static variable in class javax.accessibility. AccessibleRole
允许用户导航并选择目录内容的窗格。
DirectoryChooser - Class in javafx.stage
提供对标准目录选择器对话框的支持。
DirectoryChooser() - Constructor for class javafx.stage. DirectoryChooser
DirectoryComboBoxAction() - Constructor for class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxAction
构造一个新的实例 DirectoryComboBoxAction 。
DirectoryComboBoxModel() - Constructor for class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxModel
构造一个 DirectoryComboBoxModel的实例。
directoryIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
目录图标
DirectoryIteratorException - Exception in java.nio.file
如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。
DirectoryIteratorException(IOException) - Constructor for exception java.nio.file. DirectoryIteratorException
构造这个类的一个实例。
DirectoryManager - Class in javax.naming.spi
此类包含支持 DirContext实现的方法。
DirectoryNotEmptyException - Exception in java.nio.file
由于目录不为空，文件系统操作失败时抛出的检查异常。
DirectoryNotEmptyException(String) - Constructor for exception java.nio.file. DirectoryNotEmptyException
构造这个类的一个实例。
directoryOpenButtonMnemonic - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
当选择目录并且当前选择模式为FILES_ONLY时，用于批准按钮的助记键码。
directoryOpenButtonText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
当选择目录并且当前选择模式为FILES_ONLY时，批准按钮上显示的标签文本。
directoryOpenButtonToolTipText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
当选择目录并且当前选择模式为FILES_ONLY时，在批准按钮上显示的工具提示文本。
DirectoryStream< T> - Interface in java.nio.file
一个对象来迭代目录中的条目。
DirectoryStream.Filter< T> - Interface in java.nio.file
由对象执行的接口，用于确定是否应接受或过滤目录条目。
directSupertypes(TypeMirror) - Method in interface javax.lang.model.util. Types
返回类型的直接超类型。
DirObjectFactory - Interface in javax.naming.spi
该接口代表一个用于创建给定对象的对象的工厂，以及关于该对象的属性。
DirStateFactory - Interface in javax.naming.spi
该接口表示用于获取对象的状态的工厂和用于绑定的相应属性。
DirStateFactory.Result - Class in javax.naming.spi
用于返回DirStateFactory.getStateToBind（）的结果的对象/属性对。
dirty(ObjID[], long, Lease) - Method in interface java.rmi.dgc. DGC
对于与数组“ids”中包含的对象标识符相关联的远程对象引用的脏调用请求。
DIRTY - Static variable in interface javax.jnlp. PersistenceService
disable() - Method in interface com.sun.jdi.request. EventRequest
与 setEnabled(false)相同。
disable() - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由setEnabled(boolean)替代。
disable() - Method in class java.awt. MenuItem
已过时。
从JDK 1.1版开始，由setEnabled(boolean)替代。
disable() - Static method in class java.lang. Compiler
已过时。
导致编译器停止操作。
disable() - Method in class javax.swing. JComponent
已过时。
从JDK 1.1版开始，由java.awt.Component.setEnabled(boolean)替代。
DISABLE - javafx.scene. DepthTest
指定深度测试被禁用。
disableAllAttributes() - Method in class javax.management. AttributeChangeNotificationFilter
禁用所有属性名称。
disableAllObjectNames() - Method in class javax.management.relation. MBeanServerNotificationFilter
禁用任何MBeanServerNotification（取消选择所有对象名称）。
disableAllTypes() - Method in class javax.management. NotificationFilterSupport
禁用所有通知类型。
disableAttribute(String) - Method in class javax.management. AttributeChangeNotificationFilter
禁用其属性名称等于要发送给侦听器的指定属性名称的所有属性更改通知。
disableCollection() - Method in interface com.sun.jdi. ObjectReference
防止垃圾回收此对象。
DISABLED - javafx.scene. AccessibleAttribute
如果节点被禁用则返回true，否则返回false。
DISABLED - Static variable in class javafx.scene. SceneAntialiasing
禁用反锯齿
DISABLED - Static variable in interface javax.swing.plaf.synth. SynthConstants
表示该区域的主状态未启用。
DISABLED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识当按钮被禁用时使用的图标的更改。
DISABLED_SELECTED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识当按钮被禁用并选择时使用的图标的更改。
disabledForeground - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
禁用前景的颜色。
disabledProperty() - Method in class javafx.scene.control. Tab
表示是否禁用 Tab 。
disabledProperty() - Method in class javafx.scene. Node
表示是否禁用 Node 。
disabledTextColor - Variable in class javax.swing.plaf.metal. MetalButtonUI
禁用颜色的颜色。
disabledTextColor - Variable in class javax.swing.plaf.metal. MetalRadioButtonUI
禁用文字的颜色。
disabledTextColor - Variable in class javax.swing.plaf.metal. MetalToggleButtonUI
禁用文字的颜色。
disableEvents(long) - Method in class java.awt. Component
禁用由指定事件掩码参数定义的事件传递给此组件。
disableEvents(long) - Method in class java.awt. MenuItem
禁用由指定事件掩码参数定义的事件的此菜单项的事件传递。
disableObjectName(ObjectName) - Method in class javax.management.relation. MBeanServerNotificationFilter
禁用有关给定ObjectName的MBeanServerNotifications。
disableProperty() - Method in class javafx.scene.control. MenuItem
设置此MenuItem的单独禁用状态。
disableProperty() - Method in class javafx.scene.control. Tab
设置此选项卡的禁用状态。
disableProperty() - Method in class javafx.scene. Node
定义此 Node的个人禁用状态。
disableResizedPosting() - Method in class javax.swing.table. TableColumn
已过时。
从Java 2平台v1.3开始
disableSuddenTermination() - Method in class java.awt. Desktop
防止此应用程序突然终止。
disableSwingFocusManager() - Static method in class javax.swing. FocusManager
已过时。
截至1.4，由KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)代替
disableType(String) - Method in class javax.management. NotificationFilterSupport
从前缀列表中删除给定的前缀。
DISAPPEAR - Static variable in class javafx.scene. Cursor
消失的游标类型。
disarm() - Method in class javafx.scene.control. ButtonBase
取消按钮。
disarm() - Method in class javafx.scene.control. ComboBoxBase
取消ComboBox。
discard(U) - Static method in interface jdk.incubator.http. HttpResponse.BodyHandler
返回响应体处理程序，该处理程序丢弃响应正文并使用给定值作为替代。
discard(U) - Static method in interface jdk.incubator.http. HttpResponse.BodyProcessor
返回一个丢弃响应体的响应处理器。
DISCARD - Static variable in class java.lang. ProcessBuilder.Redirect
表示子进程输出将被丢弃。
discard_requests(boolean) - Method in interface org.omg.PortableServer. POAManagerOperations
此操作将POA管理器的状态更改为丢弃。
discardAllEdits() - Method in class javax.swing.undo. UndoManager
清空撤销管理器，在此过程中发送每条编辑 die消息。
DISCARDING - Interface in org.omg.PortableInterceptor
org / omg / PortableInterceptor / DISCARDING.java。
DISCARDING - Static variable in class org.omg.PortableServer.POAManagerPackage. State
discardKeyEvents(Component) - Method in class java.awt. DefaultKeyboardFocusManager
丢弃由于一次或 enqueueKeyEvents使用指定的组件或其后代调用 enqueueKeyEvents而排入队列的所有KeyEvent。
discardKeyEvents(Component) - Method in class java.awt. KeyboardFocusManager
由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。
DiscardOldestPolicy() - Constructor for class java.util.concurrent. ThreadPoolExecutor.DiscardOldestPolicy
为给定的执行者创建一个 DiscardOldestPolicy 。
DiscardPolicy() - Constructor for class java.util.concurrent. ThreadPoolExecutor.DiscardPolicy
创建一个 DiscardPolicy 。
DISCLOSURE_LEVEL - javafx.scene. AccessibleAttribute
返回披露层次结构中一行的深度。
disclosureNodeProperty() - Method in class javafx.scene.control. TreeCell
公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
disclosureNodeProperty() - Method in class javafx.scene.control. TreeTableRow
公开节点通常被视为在屏幕上旋转的三角形，以指示其旁边放置的TreeItem是否被展开或折叠。
disconnect() - Method in class java.net. DatagramSocket
断开插座。
disconnect() - Method in class java.net. DatagramSocketImpl
从其远程目标断开数据报套接字。
disconnect() - Method in class java.net. HttpURLConnection
表示在不久的将来不太可能对服务器的其他请求。
disconnect() - Method in class java.nio.channels. DatagramChannel
断开此通道的插座。
disconnect(boolean) - Method in class javax.smartcardio. Card
断开与此卡的连接。
disconnect(Object) - Method in class org.omg.CORBA. ORB
断开给定的servant对象与ORB的连接。
DISCONNECTED - com.sun.tools.jconsole. JConsoleContext.ConnectionState
没有连接。
DISCONTIGUOUS_TREE_SELECTION - Static variable in interface javax.swing.tree. TreeSelectionModel
选择可以包含任何数量的不一定连续的项目。
DISCRETE - Static variable in class javafx.animation. Interpolator
内置插值器，提供离散时间插值。
discriminator() - Method in interface org.omg.CORBA. DynUnion
已过时。
返回必须缩小到鉴别器类型的DynAny对象引用，以便插入/获取鉴别器值。
discriminator_kind() - Method in interface org.omg.CORBA. DynUnion
已过时。
返回与该联合的鉴别器相关联的TCKind对象。
discriminator_kind() - Method in class org.omg.DynamicAny. _DynUnionStub
返回识别器TypeCode的TCKind值。
discriminator_kind() - Method in interface org.omg.DynamicAny. DynUnionOperations
返回识别器TypeCode的TCKind值。
discriminator_type() - Method in class org.omg.CORBA. TypeCode
返回描述所有非默认成员标签的 TypeCode对象。
disjoint(Collection<?>, Collection<?>) - Static method in class java.util. Collections
如果两个指定的集合没有共同的元素，则返回 true 。
dismiss(JSpinner) - Method in class javax.swing. JSpinner.DefaultEditor
从指定的 JSpinner断开 this编辑器的 JSpinner 。
dispatch() - Method in interface java.awt. ActiveEvent
将事件发送到其目标，事件源的侦听器，或执行此事件应该做的任何事情。
dispatch() - Method in class java.awt.event. InvocationEvent
执行Runnable的 run()方法，并在 run()返回或引发异常时通知通知程序（如果有）。
dispatch(Remote, RemoteCall, int, long) - Method in interface java.rmi.server. Skeleton
已过时。
没有替换
dispatch(NamingListener) - Method in class javax.naming.event. NamingEvent
在此事件上调用适当的侦听器方法。
dispatch(NamingListener) - Method in class javax.naming.event. NamingExceptionEvent
使用此事件在侦听器上调用 namingExceptionThrown()方法。
dispatch(UnsolicitedNotificationListener) - Method in class javax.naming.ldap. UnsolicitedNotificationEvent
使用此事件在侦听器上调用 notificationReceived()方法。
Dispatch< T> - Interface in javax.xml.ws
Dispatch接口为动态调用服务端点操作提供支持。
dispatchEvent(AWTEvent) - Method in class java.awt. Component
将事件分派到此组件或其一个子组件。
dispatchEvent(AWTEvent) - Method in class java.awt. DefaultKeyboardFocusManager
该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。
dispatchEvent(AWTEvent) - Method in class java.awt. EventQueue
调度事件。
dispatchEvent(AWTEvent) - Method in class java.awt.im. InputContext
将事件调度为活动输入法。
dispatchEvent(AWTEvent) - Method in interface java.awt.im.spi. InputMethod
将事件调度到输入法。
dispatchEvent(AWTEvent) - Method in class java.awt. KeyboardFocusManager
该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。
dispatchEvent(AWTEvent) - Method in class java.awt. MenuComponent
将事件提供给此组件或其子组件之一。
dispatchEvent(Event) - Method in interface javafx.event. EventDispatchChain
通过此 EventDispatchChain调度指定的事件。
dispatchEvent(Event, EventDispatchChain) - Method in interface javafx.event. EventDispatcher
通过此 EventDispatcher调度指定的事件。
dispatchEvent(Event) - Method in interface org.w3c.dom.events. EventTarget
该方法允许将事件分派到实现事件模型中。
dispatchInputMethodEvent(int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Method in interface java.awt.im.spi. InputMethodContext
从给定的参数创建输入法事件并将其分派到客户端组件。
dispatchKeyEvent(KeyEvent) - Method in class java.awt. DefaultKeyboardFocusManager
如果调度程序链中没有其他的KeyEventDispatcher调度了KeyEvent，或者没有其他的KeyEventDispatchers被注册，则调用 dispatchEvent 。
dispatchKeyEvent(KeyEvent) - Method in class java.awt. KeyboardFocusManager
通常，如果调度程序链中没有其他的KeyEventDispatcher调度了KeyEvent，或者没有其他的KeyEventDispatchers被注册，这个方法将被调用 dispatchEvent 。
dispatchKeyEvent(KeyEvent) - Method in interface java.awt. KeyEventDispatcher
此方法由当前的KeyboardFocusManager调用，请求此KeyEventDispatcher代表它分派指定的事件。
DisplacementMap - Class in javafx.scene.effect
将每个像素移动由指定的FloatMap的前两个频带指定的距离的效果 。
DisplacementMap() - Constructor for class javafx.scene.effect. DisplacementMap
使用默认参数创建DisplacementMap的新实例。
DisplacementMap(FloatMap) - Constructor for class javafx.scene.effect. DisplacementMap
使用指定的mapData创建DisplacementMap的新实例。
DisplacementMap(FloatMap, double, double, double, double) - Constructor for class javafx.scene.effect. DisplacementMap
使用指定的mapData，offsetX，offsetY，scaleX和scaleY创建一个新的DisplacementMap实例。
DISPLAY - java.util. Locale.Category
用于表示用于显示用户界面的默认区域设置的类别。
DISPLAY - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“显示”。
DISPLAYABILITY_CHANGED - Static variable in class java.awt.event. HierarchyEvent
更改标志表示 HIERARCHY_CHANGED事件是由于层次可显示性的改变而生成的。
DISPLAYED_MNEMONIC_INDEX_KEY - Static variable in interface javax.swing. Action
用于存储的密钥 Integer对应于在文本（由所识别的索引 NAME属性），对于一个助记符的装饰应在被渲染。
displayMessage(String, String, TrayIcon.MessageType) - Method in class java.awt. TrayIcon
在托盘图标附近显示弹出消息。
DisplayMode - Class in java.awt
所述 DisplayMode类封装的位深度，高度，宽度，和刷新速率 GraphicsDevice 。
DisplayMode(int, int, int, int) - Constructor for class java.awt. DisplayMode
使用提供的参数创建一个新的显示模式对象。
displayName() - Method in class com.sun.tools.attach. VirtualMachineDescriptor
返回此描述符的 显示名称组件。
displayName() - Method in class java.nio.charset. Charset
返回此字符集的默认语言环境的可读名称。
displayName(Locale) - Method in class java.nio.charset. Charset
返回此字符集的给定语言环境的人类可读名称。
dispose() - Method in interface com.sun.jdi. VirtualMachine
使此虚拟机镜像无效。
dispose() - Method in class com.sun.tools.jconsole. JConsolePlugin
处理这个插件。
dispose() - Method in class java.awt. Component.BltBufferStrategy
释放此 BufferStrategy当前使用的系统资源，并将其从关联的组件中删除。
dispose() - Method in class java.awt. Component.FlipBufferStrategy
释放此 BufferStrategy当前使用的系统资源，并将其从关联的组件中删除。
dispose() - Method in interface java.awt. CompositeContext
释放为上下文分配的资源。
dispose() - Method in class java.awt. Graphics
处理此图形上下文并释放其正在使用的任何系统资源。
dispose() - Method in class java.awt.im. InputContext
释放此输入上下文使用的资源。
dispose() - Method in interface java.awt.im.spi. InputMethod
释放此输入法使用的资源。
dispose() - Method in class java.awt.image. BufferStrategy
释放此 BufferStrategy当前使用的系统资源，并将其从关联的组件中删除。
dispose() - Method in interface java.awt. PaintContext
释放为操作分配的资源。
dispose() - Method in class java.awt. Window
发布此 Window及其子组件及其所有子集所使用的所有本地屏幕资源。
dispose() - Method in interface javafx.beans.binding. Binding
信号到 Binding它不会被使用，任何引用都可以删除。
dispose() - Method in class javafx.beans.binding. BooleanBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.binding. DoubleBinding
默认实现为 dispose()为空。
dispose() - Method in class javafx.beans.binding. FloatBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.binding. IntegerBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.binding. ListBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.binding. LongBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.binding. MapBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.binding. ObjectBinding
默认实现为 dispose()为空。
dispose() - Method in class javafx.beans.binding. SetBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.binding. StringBinding
默认实现为 dispose() ，为空。
dispose() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoubleProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in interface javafx.beans.property.adapter. ReadOnlyJavaBeanProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringProperty
信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。
dispose() - Method in class javafx.scene.control.skin. AccordionSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ButtonSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. CheckBoxSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ChoiceBoxSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ColorPickerSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ComboBoxListViewSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ContextMenuSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. DateCellSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. DatePickerSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in interface javafx.scene.control. Skin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. HyperlinkSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ListCellSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ListViewSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. MenuBarSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. MenuButtonSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. MenuButtonSkinBase
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. PaginationSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ProgressIndicatorSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. RadioButtonSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ScrollBarSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ScrollPaneSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. SliderSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. SpinnerSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. SplitMenuButtonSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TableCellSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TableCellSkinBase
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TableRowSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TableViewSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TableViewSkinBase
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TabPaneSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TextAreaSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TextFieldSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TitledPaneSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ToggleButtonSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. ToolBarSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TooltipSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TreeCellSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TreeTableCellSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TreeTableRowSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TreeTableViewSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control.skin. TreeViewSkin
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.control. SkinBase
当Skinnable更换皮肤时，由Skinnable调用。
dispose() - Method in class javafx.scene.media. MediaPlayer
释放与播放器相关的所有资源。
dispose() - Method in class javax.imageio. ImageReader
允许释放此对象持有的任何资源。
dispose() - Method in class javax.imageio. ImageWriter
允许释放此对象持有的任何资源。
dispose() - Method in class javax.print. StreamPrintService
处理这个 StreamPrintService 。
dispose() - Method in interface javax.security.sasl. SaslClient
处理SaslClient可能使用的任何系统资源或安全敏感信息。
dispose() - Method in interface javax.security.sasl. SaslServer
处理SaslServer可能使用的任何系统资源或安全敏感信息。
dispose() - Method in class javax.swing. DebugGraphics
覆盖 Graphics.dispose 。
dispose() - Method in class javax.swing. JInternalFrame
使此内部框架不可见，未选择并关闭。
dispose() - Method in interface org.ietf.jgss. GSSContext
释放存储在上下文对象中的任何系统资源和加密信息，并使上下文无效。
dispose() - Method in interface org.ietf.jgss. GSSCredential
释放GSSCredential对象可能包含的任何敏感信息。
DISPOSE_ON_CLOSE - Static variable in interface javax.swing. WindowConstants
配置窗口默认窗口关闭操作。
DISPOSED - javafx.scene.media. MediaPlayer.Status
调用dispose（）方法后的播放器的状态。
disposePeer() - Method in class javafx.scene. Scene
distance(double, double) - Method in class java.awt.geom. Point2D
返回从这个 Point2D到指定点的距离。
distance(double, double) - Method in class javafx.geometry. Point2D
计算此点与点 (x1, y1)之间的距离。
distance(double, double, double) - Method in class javafx.geometry. Point3D
计算此点与点 (x1, y1, z1)之间的距离。
distance(double, double, double, double) - Static method in class java.awt.geom. Point2D
返回两点之间的距离。
distance(Point2D) - Method in class java.awt.geom. Point2D
返回从此 Point2D到指定的 Point2D的距离。
distance(Point2D) - Method in class javafx.geometry. Point2D
计算此点与指定的距离 point 。
distance(Point3D) - Method in class javafx.geometry. Point3D
计算此点与指定的 point之间的距离。
distanceSq(double, double) - Method in class java.awt.geom. Point2D
返回从该 Point2D到指定点的距离的平方。
distanceSq(double, double, double, double) - Static method in class java.awt.geom. Point2D
返回两点之间距离的平方。
distanceSq(Point2D) - Method in class java.awt.geom. Point2D
返回从该 Point2D到指定的 Point2D的距离的平方。
Distant() - Constructor for class javafx.scene.effect. Light.Distant
使用默认参数创建一个新的遥控灯实例。
Distant(double, double, Color) - Constructor for class javafx.scene.effect. Light.Distant
创建一个新的具有指定方位角，高程和颜色的远光的实例。
distinct() - Method in interface java.util.stream. DoubleStream
返回由该流的不同元素组成的流。
distinct() - Method in interface java.util.stream. IntStream
返回由该流的不同元素组成的流。
distinct() - Method in interface java.util.stream. LongStream
返回由该流的不同元素组成的流。
distinct() - Method in interface java.util.stream. Stream
返回由该流的不同元素（根据 Object.equals(Object) ）组成的流。
DISTINCT - java.sql. JDBCType
标识通用SQL类型 DISTINCT 。
DISTINCT - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DISTINCT 。
DISTINCT - Static variable in interface java.util. Spliterator
特性值这标志着，对于每对遇到的元件 x, y ， !x.equals(y) 。
div(ValueExp, ValueExp) - Static method in class javax.management. Query
返回表示两个数值的商的二进制表达式。
DIV - Static variable in class javax.management. Query
代表 Query.div(javax.management.ValueExp, javax.management.ValueExp)表达式的代码。
DIV - Static variable in class javax.swing.text.html. HTML.Tag
标签<div>
divide(double) - Method in class javafx.beans.binding. DoubleExpression
divide(double) - Method in class javafx.beans.binding. FloatExpression
divide(double) - Method in class javafx.beans.binding. IntegerExpression
divide(double) - Method in class javafx.beans.binding. LongExpression
divide(double) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算该NumberExpression和常数值。
divide(double) - Method in class javafx.util. Duration
将此实例除以一个数字以返回一个新的Duration实例。
divide(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，计算一个常数值的除法和ObservableNumberValue的值。
divide(float) - Method in class javafx.beans.binding. DoubleExpression
divide(float) - Method in class javafx.beans.binding. FloatExpression
divide(float) - Method in class javafx.beans.binding. IntegerExpression
divide(float) - Method in class javafx.beans.binding. LongExpression
divide(float) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算这个NumberExpression和一个常数值。
divide(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算一个常数值的除法和一个ObservableNumberValue的值。
divide(int) - Method in class javafx.beans.binding. DoubleExpression
divide(int) - Method in class javafx.beans.binding. FloatExpression
divide(int) - Method in class javafx.beans.binding. IntegerExpression
divide(int) - Method in class javafx.beans.binding. LongExpression
divide(int) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算该NumberExpression和常数值。
divide(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个常数值的除法和一个ObservableNumberValue的值。
divide(long) - Method in class javafx.beans.binding. DoubleExpression
divide(long) - Method in class javafx.beans.binding. FloatExpression
divide(long) - Method in class javafx.beans.binding. IntegerExpression
divide(long) - Method in class javafx.beans.binding. LongExpression
divide(long) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算此NumberExpression和常数值。
divide(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个常数值的除法和一个ObservableNumberValue的值。
divide(BigDecimal) - Method in class java.math. BigDecimal
返回一个BigDecimal ，其值是(this / divisor) ，并且其优选的比例为(this.scale() - divisor.scale()) ; 如果不能表示确切的商（因为它具有非终止的十进制扩展），则抛出一个ArithmeticException 。
divide(BigDecimal, int) - Method in class java.math. BigDecimal
已过时。
应该优先使用方法BigDecimal.divide(BigDecimal, RoundingMode) 。
divide(BigDecimal, int, int) - Method in class java.math. BigDecimal
已过时。
应该优先使用方法BigDecimal.divide(BigDecimal, int, RoundingMode) 。
divide(BigDecimal, int, RoundingMode) - Method in class java.math. BigDecimal
返回一个 BigDecimal其值为 (this / divisor) ，其比例为指定。
divide(BigDecimal, MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this / divisor) ，根据上下文设置进行舍入。
divide(BigDecimal, RoundingMode) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this / divisor) ，其标为 this.scale() 。
divide(BigInteger) - Method in class java.math. BigInteger
返回值为 (this / val)的BigInteger。
divide(ObservableNumberValue) - Method in class javafx.beans.binding. DoubleExpression
divide(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的划分 。
divide(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase
divide(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，计算ObservableNumberValue的值除以恒定值。
divide(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的除数和一个恒定值。
divide(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值除以恒定值。
divide(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值除数和常数值。
divide(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算两个实例的值除数ObservableNumberValue 。
divide(Duration) - Method in class javafx.util. Duration
已过时。
这种方法通过不考虑单位产生令人惊讶的结果。 改用Duration.divide(double) 。
DIVIDE - com.sun.source.tree. Tree.Kind
用于表示/的BinaryTree的实例。
DIVIDE - javafx.scene.input. KeyCode
常数为 Divide键。
DIVIDE - jdk.nashorn.api.tree. Tree.Kind
用于表示/的BinaryTree的实例。
DIVIDE_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于表示划分/=的CompoundAssignmentTree的实例。
DIVIDE_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于表示划分/=的CompoundAssignmentTree的实例。
divideAndRemainder(BigDecimal) - Method in class java.math. BigDecimal
返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上的两个操作数。
divideAndRemainder(BigDecimal, MathContext) - Method in class java.math. BigDecimal
返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上与根据上下文设置进行舍入计算出的两个操作数。
divideAndRemainder(BigInteger) - Method in class java.math. BigInteger
返回两个BigInteger的数组，其中包含 (this / val)后跟 (this % val) 。
dividedBy(long) - Method in class java.time. Duration
返回此持续时间的副本除以指定的值。
dividedBy(Duration) - Method in class java.time. Duration
在此持续时间内返回指定持续时间的整数倍数。
divider - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
这个JSplitPane的分隔符的实例。
Divider() - Constructor for class javafx.scene.control. SplitPane.Divider
创建一个默认的Divider实例。
DIVIDER - Static variable in class javax.swing. JSplitPane
用于添加将代表分隔符的 Component 。
DIVIDER_LOCATION_PROPERTY - Static variable in class javax.swing. JSplitPane
dividerLocation的绑定属性。
DIVIDER_SIZE_PROPERTY - Static variable in class javax.swing. JSplitPane
边界的绑定属性名称。
DividerLayout() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneDivider.DividerLayout
dividerResizeToggleKey - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
dividerSize - Variable in class javax.swing. JSplitPane
分隔线的尺寸
dividerSize - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
分隔线的尺寸
dividerSize - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
拖动会话有效时分隔符的大小。
divideToIntegralValue(BigDecimal) - Method in class java.math. BigDecimal
返回一个 BigDecimal其值是 (this / divisor)舍入的商 (this / divisor)的整数部分。
divideToIntegralValue(BigDecimal, MathContext) - Method in class java.math. BigDecimal
返回值为 BigDecimal的整数部分的 (this / divisor) 。
divideUnsigned(int, int) - Static method in class java.lang. Integer
返回将第一个参数除以秒的无符号商，其中每个参数和结果被解释为无符号值。
divideUnsigned(long, long) - Static method in class java.lang. Long
返回将第一个参数除以秒的无符号商，其中每个参数和结果被解释为无符号值。
divisionType - Variable in class javax.sound.midi. MidiFileFormat
MIDI文件的分割类型。
divisionType - Variable in class javax.sound.midi. Sequence
序列的时序分割类型。
dk_AbstractInterface - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表示Interface Repository对象表示抽象接口。
dk_Alias - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例指示Interface Repository对象是别名。
dk_all - Static variable in class org.omg.CORBA. DefinitionKind
通配符 DefinitionKind常数，适用于任何适合 DefinitionKind所有场合。
dk_Array - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个Array。
dk_Attribute - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个Attribute。
dk_Constant - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表示Interface Repository对象是一个常量。
dk_Enum - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是枚举。
dk_Exception - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表示Interface Repository对象是一个异常。
dk_Fixed - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表示Interface Repository对象是Fixed值。
dk_Interface - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个Interface。
dk_Module - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个Module。
dk_Native - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例指示Interface Repository对象是Native值。
dk_none - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象没有定义类型。
dk_Operation - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表示Interface Repository对象是一个Operation。
dk_Primitive - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个Primitive。
dk_Repository - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例指示Interface Repository对象是Repository。
dk_Sequence - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表示Interface Repository对象是一个Sequence。
dk_String - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个String。
dk_Struct - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个Struct。
dk_Typedef - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例指示Interface Repository对象是Typedef。
dk_Union - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是Union。
dk_Value - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是一个值。
dk_ValueBox - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例指示Interface Repository对象是ValueBox。
dk_ValueMember - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例指示Interface Repository对象是ValueMember。
dk_Wstring - Static variable in class org.omg.CORBA. DefinitionKind
DefinitionKind的静态实例表明Interface Repository对象是Wstring。
DL - Static variable in class javax.swing.text.html. HTML.Tag
标签<dl>
DnDConstants - Class in java.awt.dnd
此类包含表示由拖放操作执行的操作类型的常量值。
DNS_URL - Static variable in interface javax.naming. Context
持有用于指定用于JNDI URL上下文的DNS主机和域名的环境属性的名称的常量（例如“dns：//somehost/wiz.com”）。
DO_NOTHING_ON_CLOSE - Static variable in interface javax.swing. WindowConstants
不做任何默认窗口关闭操作。
DO_WHILE_LOOP - com.sun.source.tree. Tree.Kind
用于DoWhileLoopTree的实例。
DO_WHILE_LOOP - jdk.nashorn.api.tree. Tree.Kind
用于DoWhileLoopTree的实例。
doAccessibleAction(int) - Method in class java.awt. Button.AccessibleAWTButton
对对象执行指定的Action
doAccessibleAction(int) - Method in class java.awt. Checkbox.AccessibleAWTCheckbox
对对象执行指定的Action
doAccessibleAction(int) - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
对对象执行指定的Action
doAccessibleAction(int) - Method in class java.awt. Choice.AccessibleAWTChoice
对对象执行指定的Action
doAccessibleAction(int) - Method in class java.awt. MenuItem.AccessibleAWTMenuItem
对对象执行指定的Action
doAccessibleAction(int) - Method in interface javax.accessibility. AccessibleAction
对对象执行指定的操作。
doAccessibleAction(int) - Method in class javax.accessibility. AccessibleHyperlink
对对象执行指定的操作。
doAccessibleAction(int) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton
对对象执行指定的Action
doAccessibleAction(int) - Method in class javax.swing. JComboBox.AccessibleJComboBox
对对象执行指定的Action
doAccessibleAction(int) - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
对对象执行指定的Action
doAccessibleAction(int) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild
对对象执行指定的操作。
doAccessibleAction(int) - Method in class javax.swing. JSpinner.AccessibleJSpinner
对对象执行指定的Action
doAccessibleAction(int) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
在树节点上执行指定的操作。
doAccessibleAction(int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent
对对象执行指定的Action
doAdd(int, E) - Method in class javafx.collections. ModifiableObservableListBase
将 element添加到列表中，位置为 index 。
doAs(Subject, PrivilegedAction<T>) - Static method in class javax.security.auth. Subject
执行工作，特别是 Subject 。
doAs(Subject, PrivilegedExceptionAction<T>) - Static method in class javax.security.auth. Subject
执行工作作为一个特定的 Subject 。
doAsPrivileged(Subject, PrivilegedAction<T>, AccessControlContext) - Static method in class javax.security.auth. Subject
作为特定的 Subject执行特权工作。
doAsPrivileged(Subject, PrivilegedExceptionAction<T>, AccessControlContext) - Static method in class javax.security.auth. Subject
作为特定的 Subject执行特权工作。
Doc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
Doc - Interface in javax.print
Interface Doc指定为打印作业提供一张打印数据的对象的界面。
DOC_COMMENT - com.sun.source.doctree. DocTree.Kind
用于表示完整的文档注释的DocCommentTree的实例。
DOC_ROOT - com.sun.source.doctree. DocTree.Kind
用于实例DocRootTree表示@docRoot标签。
DocAttribute - Interface in javax.print.attribute
接口DocAttribute是打印属性类实现的标记接口，用于指示属性表示文档的设置。
DocAttributeSet - Interface in javax.print.attribute
接口DocAttributeSet指定一组doc属性的接口，即打印实现接口DocAttribute的属性。
DocCommentTree - Interface in com.sun.source.doctree
文档评论的顶级代表。
DocErrorReporter - Interface in com.sun.javadoc
已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
DocFlavor - Class in javax.print
DocFlavor类封装了一个对象，它将打印数据的格式指定给一个DocPrintJob 。
DocFlavor(String, String) - Constructor for class javax.print. DocFlavor
从给定的MIME类型和表示类名称构造一个新的doc flavor对象。
DocFlavor.BYTE_ARRAY - Class in javax.print
DocFlavor.BYTE_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字节数组（ byte[] ）作为打印数据表示类的doc风格。
DocFlavor.CHAR_ARRAY - Class in javax.print
DocFlavor.CHAR_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字符数组（ char[] ）作为打印数据表示类的doc风格。
DocFlavor.INPUT_STREAM - Class in javax.print
DocFlavor.INPUT_STREAM类提供了预定义的静态常量DocFlavor对象，例如使用字节流（ java.io.InputStream ）作为打印数据表示类的doc口味。
DocFlavor.READER - Class in javax.print
DocFlavor.READER类提供了预定义的静态常量DocFlavor对象，例如使用字符流（ java.io.Reader ）作为打印数据表示类的doc风格。
DocFlavor.SERVICE_FORMATTED - Class in javax.print
DocFlavor.SERVICE_FORMATTED类提供了预定义的静态常量DocFlavor对象，例如用于服务格式化打印数据的doc风格。
DocFlavor.STRING - Class in javax.print
DocFlavor.STRING类提供了预定义的静态常量DocFlavor对象，例如使用字符串（ java.lang.String ）作为打印数据表示类的doc风格。
DocFlavor.URL - Class in javax.print
DocFlavor.URL类提供了预定义的静态常量DocFlavor对象。
dockingBorderColor - Variable in class javax.swing.plaf.basic. BasicToolBarUI
对接边框的颜色。
dockingColor - Variable in class javax.swing.plaf.basic. BasicToolBarUI
对接边框的背景颜色。
dockingListener - Variable in class javax.swing.plaf.basic. BasicToolBarUI
一个 MouseInputListener的实例。
DockingListener(JToolBar) - Constructor for class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
构造一个新的实例 DockingListener 。
Doclet - Class in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
Doclet - Interface in jdk.javadoc.doclet
用户doclet必须实现此接口，如 package description中所述。
Doclet() - Constructor for class com.sun.javadoc. Doclet
已过时。
DOCLET_PATH - javax.tools. DocumentationTool.Location
搜索doclets的位置。
Doclet.Option - Interface in jdk.javadoc.doclet
Doclet使用的选项名称，别名，参数和描述的封装。
Doclet.Option.Kind - Enum in jdk.javadoc.doclet
这种选择。
DocletEnvironment - Interface in jdk.javadoc.doclet
表示单次调用doclet的操作环境。
DocletEnvironment.ModuleMode - Enum in jdk.javadoc.doclet
doClick() - Method in class javax.swing. AbstractButton
以编程方式执行“点击”。
doClick(int) - Method in class javax.swing. AbstractButton
以编程方式执行“点击”。
doClick(int) - Method in class javax.swing. JMenu
以编程方式执行“点击”。
doClick(MenuSelectionManager) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
当菜单项被激活时调用此方法。
DocPrintJob - Interface in javax.print
此接口表示可以使用一组作业属性打印指定文档的打印作业。
DocRootTree - Interface in com.sun.source.doctree
@docroot内联标记的树形节点。
DocSourcePositions - Interface in com.sun.source.util
提供在javadoc注释中获取DocTree的位置的方法。
DocTree - Interface in com.sun.source.doctree
文档语法树中所有节点的公共接口。
DocTree.Kind - Enum in com.sun.source.doctree
列举各种树木。
DocTreeFactory - Interface in com.sun.source.util
创建 DocTree节点的工厂。
DocTreePath - Class in com.sun.source.util
树节点的路径，通常用于表示直到顶层DocCommentTree节点的树节点的祖先节点序列。
DocTreePath(DocTreePath, DocTree) - Constructor for class com.sun.source.util. DocTreePath
为子节点创建DocTreePath。
DocTreePath(TreePath, DocCommentTree) - Constructor for class com.sun.source.util. DocTreePath
为根节点创建DocTreePath。
DocTreePathScanner< R, P> - Class in com.sun.source.util
访问所有子树节点的DocTreeVisitor，并为维护父节点的路径提供支持。
DocTreePathScanner() - Constructor for class com.sun.source.util. DocTreePathScanner
DocTrees - Class in com.sun.source.util
提供对文档注释的语法树的访问。
DocTrees() - Constructor for class com.sun.source.util. DocTrees
DocTreeScanner< R, P> - Class in com.sun.source.util
访问所有子树节点的TreeVisitor。
DocTreeScanner() - Constructor for class com.sun.source.util. DocTreeScanner
DocTreeVisitor< R, P> - Interface in com.sun.source.doctree
树木的访客，以访客设计模式的风格。
DOCTYPE_PUBLIC - Static variable in class javax.xml.transform. OutputKeys
doctype-public = string 。
DOCTYPE_SYSTEM - Static variable in class javax.xml.transform. OutputKeys
doctype-system = string 。
Document - Interface in javax.swing.text
Document是用于文本的容器，用作挥杆文本组件的模型。
Document - Interface in org.w3c.dom
Document接口代表整个HTML或XML文档。
DOCUMENT - javax.jws.soap. SOAPBinding.Style
DOCUMENT - Static variable in class com.sun.java.accessibility.util. EventID
映射到Swing Document支持（即DocumentListener和DocumentEvent）
DOCUMENT_ACCESS_ERROR - Static variable in class javax.print.attribute.standard. JobStateReason
打印机无法访问通过引用传递的一个或多个文档（即打印数据表示对象是一个URL）。
DOCUMENT_FORMAT_ERROR - Static variable in class javax.print.attribute.standard. JobStateReason
该作业被系统中止，因为打印机在处理文档数据时遇到错误。
DOCUMENT_FRAGMENT_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 DocumentFragment 。
DOCUMENT_MODAL - java.awt. Dialog.ModalityType
一个 DOCUMENT_MODAL对话框阻止输入到同一个文档的所有顶层窗口，而不是它们自己的子层次结构。
DOCUMENT_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 Document 。
DOCUMENT_POSITION_CONTAINED_BY - Static variable in interface org.w3c.dom. Node
节点由参考节点包含。
DOCUMENT_POSITION_CONTAINS - Static variable in interface org.w3c.dom. Node
节点包含参考节点。
DOCUMENT_POSITION_DISCONNECTED - Static variable in interface org.w3c.dom. Node
两个节点断开连接。
DOCUMENT_POSITION_FOLLOWING - Static variable in interface org.w3c.dom. Node
节点跟随参考节点。
DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC - Static variable in interface org.w3c.dom. Node
前面和后面的确定是实现特定的。
DOCUMENT_POSITION_PRECEDING - Static variable in interface org.w3c.dom. Node
第二个节点在参考节点之前。
DOCUMENT_TYPE_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 DocumentType 。
documentation(String, int, boolean) - Method in class jdk.jshell. SourceCodeAnalysis
计算给定用户输入的文档。
DOCUMENTATION_OUTPUT - javax.tools. DocumentationTool.Location
新文件的位置。
DocumentationTool - Interface in javax.tools
从程序中调用Java编程语言文档工具的接口。
DocumentationTool.DocumentationTask - Interface in javax.tools
表示文档任务的未来的接口。
DocumentationTool.Location - Enum in javax.tools
特定于DocumentationTool的地点。
documentBaseKey - Static variable in class javax.swing.plaf.basic. BasicHTML
密钥存储为客户端属性，以指示相对引用被解析的基础。
DocumentBuilder - Class in javax.xml.parsers
定义从XML文档获取DOM文档实例的API。
DocumentBuilder() - Constructor for class javax.xml.parsers. DocumentBuilder
受保护的构造函数
DocumentBuilderFactory - Class in javax.xml.parsers
定义工厂API，使应用程序能够从XML文档获取生成DOM对象树的解析器。
DocumentBuilderFactory() - Constructor for class javax.xml.parsers. DocumentBuilderFactory
受保护的构造函数以防止实例化。
DocumentCSS - Interface in org.w3c.dom.css
此接口表示具有CSS视图的文档。
Documented - Annotation Type in java.lang.annotation
如果在注释类型 A的声明上存在注释 @Documented ，则元素上的任何 @A注释将被视为元素的公共合同的一部分。
DocumentEvent - Interface in javax.swing.event
文档更改通知界面。
DocumentEvent - Interface in org.w3c.dom.events
DocumentEvent接口提供了一种机制，用户可以通过该机制创建实现支持的类型的事件。
DocumentEvent.ElementChange - Interface in javax.swing.event
描述对特定元素所做的更改。
DocumentEvent.EventType - Class in javax.swing.event
文档事件类型的枚举
DocumentFilter - Class in javax.swing.text
DocumentFilter ，顾名思义，是 Document突变方法的过滤器。
DocumentFilter() - Constructor for class javax.swing.text. DocumentFilter
DocumentFilter.FilterBypass - Class in javax.swing.text
用作一种方式来规避回调文档以更改它。
DocumentFragment - Interface in org.w3c.dom
DocumentFragment是一个“轻量级”或“最小” Document对象。
DocumentHandler - Interface in org.xml.sax
已过时。
该接口已被SAX2 ContentHandler接口所取代，其中包括命名空间支持。
DocumentListener - Interface in javax.swing.event
观察者注册接收文本文档更改通知的界面。
DocumentName - Class in javax.print.attribute.standard
DocumentName类是一个打印属性类，一个指定文档名称的文本属性。
DocumentName(String, Locale) - Constructor for class javax.print.attribute.standard. DocumentName
使用给定的文档名称和语言环境构造新的文档名称属性。
DocumentParser - Class in javax.swing.text.html.parser
HTML文档的解析器（实际上，您可以指定一个DTD，但您应该只使用html dtd的这个类）。
DocumentParser(DTD) - Constructor for class javax.swing.text.html.parser. DocumentParser
使用指定的 dtd创建文档解析器。
documentProperty() - Method in class javafx.scene.web. WebEngine
当前网页的文档对象。
DocumentRange - Interface in org.w3c.dom.ranges
另见 Document Object Model (DOM) Level 2 Traversal and Range Specification 。
DocumentStyle - Interface in org.w3c.dom.stylesheets
DocumentStyle界面提供了一种可以检索嵌入在文档中的样式表的机制。
DocumentTraversal - Interface in org.w3c.dom.traversal
DocumentTraversal包含创建 NodeIterators和 TreeWalkers以按文档顺序遍历节点及其子节点的方法（深度优先，预订遍历，等效于文档的文本表示中起始标签出现的顺序）。
DocumentType - Interface in org.w3c.dom
每个 Document具有 doctype属性，其值为 null或 DocumentType对象。
DocumentView - Interface in org.w3c.dom.views
DocumentView接口由支持DOM视图的DOM实现中的 Document对象实现。
doDefaultCloseAction() - Method in class javax.swing. JInternalFrame
触发 INTERNAL_FRAME_CLOSING事件，然后执行内部框架默认关闭操作指定的操作。
DODGERBLUE - Static variable in class javafx.scene.paint. Color
颜色闪烁蓝色，RGB值为＃1E90FF
doesMaxRowSizeIncludeBlobs() - Method in interface java.sql. DatabaseMetaData
检索方法 getMaxRowSize的返回值是否包含SQL数据类型 LONGVARCHAR和 LONGVARBINARY 。
doFilter(HttpExchange) - Method in class com.sun.net.httpserver. Filter.Chain
调用链中的下一个过滤器，否则用户交换处理程序，如果这是链中的最终过滤器。
doFilter(HttpExchange, Filter.Chain) - Method in class com.sun.net.httpserver. Filter
要求此过滤器预先/后处理给定的交换。
doFinal() - Method in class javax.crypto. Cipher
完成多部分加密或解密操作，这取决于该密码如何初始化。
doFinal() - Method in class javax.crypto. Mac
完成MAC操作。
doFinal(byte[]) - Method in class javax.crypto. Cipher
在单一部分操作中加密或解密数据，或完成多部分操作。
doFinal(byte[]) - Method in class javax.crypto. Mac
处理给定的字节数组，并完成MAC操作。
doFinal(byte[], int) - Method in class javax.crypto. Cipher
完成多部分加密或解密操作，这取决于该密码如何初始化。
doFinal(byte[], int) - Method in class javax.crypto. Mac
完成MAC操作。
doFinal(byte[], int, int) - Method in class javax.crypto. Cipher
在单一部分操作中加密或解密数据，或完成多部分操作。
doFinal(byte[], int, int, byte[]) - Method in class javax.crypto. Cipher
在单一部分操作中加密或解密数据，或完成多部分操作。
doFinal(byte[], int, int, byte[], int) - Method in class javax.crypto. Cipher
在单一部分操作中加密或解密数据，或完成多部分操作。
doFinal(ByteBuffer, ByteBuffer) - Method in class javax.crypto. Cipher
在单一部分操作中加密或解密数据，或完成多部分操作。
doInBackground() - Method in class javax.swing. SwingWorker
计算一个结果，如果不能这样做，就会抛出一个异常。
doInput - Variable in class java.net. URLConnection
此变量由 setDoInput方法设置。
doLayout() - Method in class java.awt. Component
提示布局管理器布局此组件。
doLayout() - Method in class java.awt. Container
使此容器布置其组件。
doLayout() - Method in class java.awt. ScrollPane
通过将其小孩调整为首选尺寸，将这个容器放在一起。
doLayout() - Method in class javax.swing. JLayer
将其功能委托给 LayerUI.doLayout(JLayer)方法，如果设置了 LayerUI 。
doLayout() - Method in class javax.swing. JTable
导致此表布置其行和列。
doLayout() - Method in class javax.swing.tree. DefaultTreeCellEditor.EditorContainer
出来这个 Container 。
doLayout(JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
导致传递的 JLayer实例布局其组件。
DOLLAR - javafx.scene.input. KeyCode
“$”键的常数。
doLookup(String) - Static method in class javax.naming. InitialContext
一种用于检索命名对象的静态方法。
doLookup(Name) - Static method in class javax.naming. InitialContext
一种用于检索命名对象的静态方法。
DOM_OBJECT_MODEL - Static variable in class javax.xml.xpath. XPathConstants
DOM对象模型的URI，“http://java.sun.com/jaxp/xpath/dom”。
DomainCombiner - Interface in java.security
A DomainCombiner提供了一种手段来动态更新与当前的 AccessControlContext相关联的ProtectionDomains。
DomainLoadStoreParameter - Class in java.security
指定密钥库中密钥库的配置数据。
DomainLoadStoreParameter(URI, Map<String, KeyStore.ProtectionParameter>) - Constructor for class java.security. DomainLoadStoreParameter
使用用于保护密钥库数据的参数构建密钥库域的DomainLoadStoreParameter。
DomainManager - Interface in org.omg.CORBA
提供建立和导航关系到上级和下级域以及创建和访问策略的机制。
DomainManagerOperations - Interface in org.omg.CORBA
为 DomainManager提供访问策略的方法。
domainMatches(String, String) - Static method in class java.net. HttpCookie
检查主机名是否在域中的实用方法。
DOMConfiguration - Interface in org.w3c.dom
DOMConfiguration接口表示文档的配置并维护已识别参数的表。
DOMCryptoContext - Class in javax.xml.crypto.dom
这个类提供了一个DOM特定的XMLCryptoContext接口的实现。
DOMCryptoContext() - Constructor for class javax.xml.crypto.dom. DOMCryptoContext
默认构造函数。
DOMError - Interface in org.w3c.dom
DOMError是描述错误的界面。
DOMErrorHandler - Interface in org.w3c.dom
DOMErrorHandler是在报告处理XML数据时发生的错误或进行其他处理（例如验证文档）时，DOM实现可以调用的回调接口。
DOMException - Exception in org.w3c.dom
DOM操作只会在“异常”情况下引发异常，即当操作无法执行时（出于逻辑原因，因为数据丢失，或者由于实现变得不稳定））。
DOMException(short, String) - Constructor for exception org.w3c.dom. DOMException
DomHandler< ElementT, ResultT extends Result> - Interface in javax.xml.bind.annotation
将元素（及其后代）从/转换为DOM（或类似的）表示形式。
DOMImplementation - Interface in org.w3c.dom
DOMImplementation接口提供了许多用于执行独立于文档对象模型的任何特定实例的操作的方法。
DOMImplementationCSS - Interface in org.w3c.dom.css
该界面允许DOM用户在文档的上下文之外创建一个 CSSStyleSheet 。
DOMImplementationList - Interface in org.w3c.dom
DOMImplementationList接口提供了DOM实现的有序集合的抽象，而不定义或约束如何实现此集合。
DOMImplementationLS - Interface in org.w3c.dom.ls
DOMImplementationLS包含用于创建加载和保存对象的工厂方法。
DOMImplementationRegistry - Class in org.w3c.dom.bootstrap
一个允许应用程序获取 DOMImplementation实例的 DOMImplementation 。
DOMImplementationSource - Interface in org.w3c.dom
该接口允许DOM实现者基于所要求的特征和版本来提供一个或多个实现，如 DOM Features中所规定的。
DOMINO_TILES - Static variable in class java.lang. Character.UnicodeBlock
“Domino Tiles”Unicode字符块的常量。
DOMLocator - Interface in javax.xml.transform.dom
指示源DOM中节点的位置，主要用于错误报告。
DOMLocator - Interface in org.w3c.dom
DOMLocator是描述位置的接口（例如，
DOMResult - Class in javax.xml.transform.dom
作为文档对象模型（DOM）树形式的转换结果树的持有者。
DOMResult() - Constructor for class javax.xml.transform.dom. DOMResult
零参数默认构造函数。
DOMResult(Node) - Constructor for class javax.xml.transform.dom. DOMResult
使用DOM节点创建新的输出目标。
DOMResult(Node, String) - Constructor for class javax.xml.transform.dom. DOMResult
使用DOM节点创建具有指定的系统ID的新的输出目标。
DOMResult(Node, Node) - Constructor for class javax.xml.transform.dom. DOMResult
使用DOM节点创建一个新的输出目标，指定要在其中插入结果节点的子节点。
DOMResult(Node, Node, String) - Constructor for class javax.xml.transform.dom. DOMResult
使用DOM节点创建一个新的输出目标，指定要在其中插入结果节点的子节点和指定的系统ID。
DOMSignContext - Class in javax.xml.crypto.dsig.dom
一个DOM特定的XMLSignContext 。
DOMSignContext(Key, Node) - Constructor for class javax.xml.crypto.dsig.dom. DOMSignContext
使用指定的签名密钥和父节点创建一个 DOMSignContext 。
DOMSignContext(Key, Node, Node) - Constructor for class javax.xml.crypto.dsig.dom. DOMSignContext
使用指定的签名密钥，父级和下一个兄弟节点创建一个 DOMSignContext 。
DOMSignContext(KeySelector, Node) - Constructor for class javax.xml.crypto.dsig.dom. DOMSignContext
使用指定的键选择器和父节点创建一个 DOMSignContext 。
DOMSignContext(KeySelector, Node, Node) - Constructor for class javax.xml.crypto.dsig.dom. DOMSignContext
使用指定的键选择器，父节点和下一个兄弟节点创建一个 DOMSignContext 。
DOMSource - Class in javax.xml.transform.dom
作为文档对象模型（DOM）树形式的变换源树的持有者。
DOMSource() - Constructor for class javax.xml.transform.dom. DOMSource
零参数默认构造函数。
DOMSource(Node) - Constructor for class javax.xml.transform.dom. DOMSource
使用DOM节点创建一个新的输入源。
DOMSource(Node, String) - Constructor for class javax.xml.transform.dom. DOMSource
使用DOM节点创建一个新的输入源，并且系统ID也作为基本URI传入。
DOMSTRING_SIZE_ERR - Static variable in exception org.w3c.dom. DOMException
如果指定的文本范围不符合 DOMString 。
DOMStringList - Interface in org.w3c.dom
DOMStringList接口提供 DOMString值的有序集合的抽象，而不定义或约束如何实现此集合。
DOMStructure - Class in javax.xml.crypto.dom
DOM专有XMLStructure 。
DOMStructure(Node) - Constructor for class javax.xml.crypto.dom. DOMStructure
创建一个包含指定节点的 DOMStructure 。
DOMURIReference - Interface in javax.xml.crypto.dom
一个DOM特定的URIReference 。
DOMValidateContext - Class in javax.xml.crypto.dsig.dom
DOM专有的XMLValidateContext 。
DOMValidateContext(Key, Node) - Constructor for class javax.xml.crypto.dsig.dom. DOMValidateContext
创建包含指定的键和节点的 DOMValidateContext 。
DOMValidateContext(KeySelector, Node) - Constructor for class javax.xml.crypto.dsig.dom. DOMValidateContext
创建包含指定的键选择器和节点的 DOMValidateContext 。
done() - Method in interface java.rmi.server. RemoteCall
已过时。
没有替换
done() - Method in class java.util.concurrent. FutureTask
此任务转换到状态 isDone （无论是正常还是通过取消）调用的受保护方法。
done() - Method in class javax.swing. SwingWorker
doInBackground方法完成后，在 事件发送线程上执行。
done(RemoteCall) - Method in interface java.rmi.server. RemoteRef
已过时。
1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
DONE - javafx.print. PrinterJob.JobStatus
该工作启动了打印，后来被称为endJob（），报告成功。
DONE - javax.swing. SwingWorker.StateValue
SwingWorker是 DONE后 doInBackground方法完成。
DONE - Static variable in class java.text. BreakIterator
当达到第一个或最后一个文本边界时，DONE将返回previous（），next（），next（int），previous（int）和after（int）。
DONE - Static variable in interface java.text. CharacterIterator
当迭代器到达文本的结尾或开始时返回的常量。
dontUseGui() - Method in class java.beans.beancontext. BeanContextSupport
通知此实例可能不再呈现GUI。
dontUseGui() - Method in interface java.beans. Visibility
这个方法指示bean不应该使用Gui。
DOOR_OPEN - Static variable in class javax.print.attribute.standard. PrinterStateReason
设备上的一个或多个门打开。
doOutput - Variable in class java.net. URLConnection
此变量由 setDoOutput方法设置。
doPaint(Graphics2D, JComponent, int, int, Object[]) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
实际执行绘画操作。
doPhase(Key, boolean) - Method in class javax.crypto. KeyAgreement
执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
doPrivileged(PrivilegedAction<T>) - Static method in class java.security. AccessController
执行指定的 PrivilegedAction启用特权。
doPrivileged(PrivilegedAction<T>, AccessControlContext) - Static method in class java.security. AccessController
执行指定的 PrivilegedAction ，启用和限制的指定 AccessControlContext 。
doPrivileged(PrivilegedAction<T>, AccessControlContext, Permission...) - Static method in class java.security. AccessController
执行指定的 PrivilegedAction ，启用并受限于指定的 AccessControlContext并且特权范围受指定的 Permission参数限制的权限。
doPrivileged(PrivilegedExceptionAction<T>) - Static method in class java.security. AccessController
执行指定的 PrivilegedExceptionAction启用特权。
doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext) - Static method in class java.security. AccessController
执行指定的 PrivilegedExceptionAction其中启用并受指定的 AccessControlContext限制。
doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext, Permission...) - Static method in class java.security. AccessController
执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
doPrivilegedWithCombiner(PrivilegedAction<T>) - Static method in class java.security. AccessController
执行指定的 PrivilegedAction启用特权。
doPrivilegedWithCombiner(PrivilegedAction<T>, AccessControlContext, Permission...) - Static method in class java.security. AccessController
执行指定的 PrivilegedAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
doPrivilegedWithCombiner(PrivilegedExceptionAction<T>) - Static method in class java.security. AccessController
执行指定的 PrivilegedExceptionAction启用特权。
doPrivilegedWithCombiner(PrivilegedExceptionAction<T>, AccessControlContext, Permission...) - Static method in class java.security. AccessController
执行指定的 PrivilegedExceptionAction ，该权限启用并受指定的 AccessControlContext限制，特权范围受指定的 Permission参数限制。
doRemove(int) - Method in class javafx.collections. ModifiableObservableListBase
删除 index位置的 index 。
doSet(int, E) - Method in class javafx.collections. ModifiableObservableListBase
设置 element在的位置的列表 index 。
DosFileAttributes - Interface in java.nio.file.attribute
与支持旧版“DOS”属性的文件系统中的文件相关联的文件属性。
DosFileAttributeView - Interface in java.nio.file.attribute
提供传统“DOS”文件属性视图的文件属性视图。
DOTALL - Static variable in class java.util.regex. Pattern
启用点阵模式。
dotProduct(double, double) - Method in class javafx.geometry. Point2D
计算由该实例表示的向量的点（标量）乘积和指定的向量。
dotProduct(double, double, double) - Method in class javafx.geometry. Point3D
计算由该实例表示的向量的点（标量）乘积和指定的向量。
dotProduct(Point2D) - Method in class javafx.geometry. Point2D
计算由该实例表示的向量的点（标量）乘积和指定的向量。
dotProduct(Point3D) - Method in class javafx.geometry. Point3D
计算由该实例表示的向量的点（标量）乘积和指定的向量。
DOTTED - Static variable in class javafx.scene.layout. BorderStrokeStyle
用于抚摸的预定点缀图案
Double - Class in java.lang
Double类包装一个对象中的原始类型 double的值。
Double() - Constructor for class java.awt.geom. Arc2D.Double
构造一个新的OPEN弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）。
Double() - Constructor for class java.awt.geom. CubicCurve2D.Double
构造并初始化坐标（0，0，0，0，0，0，0，0）的CubicCurve。
Double() - Constructor for class java.awt.geom. Ellipse2D.Double
构造新的 Ellipse2D ，初始化为位置（0，0）和大小（0，0）。
Double() - Constructor for class java.awt.geom. Line2D.Double
构造并初始化坐标（0，0）→（0，0）的行。
Double() - Constructor for class java.awt.geom. Path2D.Double
构造一个新的空双精度 Path2D对象，默认绕组规则为 Path2D.WIND_NON_ZERO 。
Double() - Constructor for class java.awt.geom. Point2D.Double
构造并初始化具有坐标（0，0）的 Point2D 。
Double() - Constructor for class java.awt.geom. QuadCurve2D.Double
构造并初始化 QuadCurve2D ，其坐标为（ QuadCurve2D ）。
Double() - Constructor for class java.awt.geom. Rectangle2D.Double
构造一个新的 Rectangle2D ，初始化为位置（0，0）和大小（0，0）。
Double() - Constructor for class java.awt.geom. RoundRectangle2D.Double
构造一个新的 RoundRectangle2D ，初始化为位置（ RoundRectangle2D ），大小（ RoundRectangle2D ）和半径为0.0的角弧。
Double(double) - Constructor for class java.lang. Double
已过时。
很少使用这个构造函数。 静态工厂Double.valueOf(double)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
Double(double, double) - Constructor for class java.awt.geom. Point2D.Double
构造并初始化具有指定坐标的 Point2D 。
Double(double, double, double, double) - Constructor for class java.awt.geom. Ellipse2D.Double
从指定的坐标构建和初始化一个 Ellipse2D 。
Double(double, double, double, double) - Constructor for class java.awt.geom. Line2D.Double
从指定的坐标构造并初始化 Line2D 。
Double(double, double, double, double) - Constructor for class java.awt.geom. Rectangle2D.Double
构造并初始化一个 Rectangle2D从指定 double坐标。
Double(double, double, double, double, double, double) - Constructor for class java.awt.geom. QuadCurve2D.Double
构造并初始化一个 QuadCurve2D从指定 double坐标。
Double(double, double, double, double, double, double) - Constructor for class java.awt.geom. RoundRectangle2D.Double
构造并初始化一个 RoundRectangle2D从指定 double坐标。
Double(double, double, double, double, double, double, double, double) - Constructor for class java.awt.geom. CubicCurve2D.Double
构造并初始化一个 CubicCurve2D从指定 double坐标。
Double(double, double, double, double, double, double, int) - Constructor for class java.awt.geom. Arc2D.Double
构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
Double(int) - Constructor for class java.awt.geom. Arc2D.Double
构造一个新弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）以及指定的闭合类型。
Double(int) - Constructor for class java.awt.geom. Path2D.Double
使用指定的绕组规则构造一个新的空双精度 Path2D对象，以控制需要定义路径内部的操作。
Double(int, int) - Constructor for class java.awt.geom. Path2D.Double
使用指定的绕组规则和指定的初始容量构造新的空双精度 Path2D对象以存储路径段。
Double(Point2D, Point2D) - Constructor for class java.awt.geom. Line2D.Double
构造并初始化一个 Line2D从指定 Point2D对象。
Double(Rectangle2D, double, double, int) - Constructor for class java.awt.geom. Arc2D.Double
构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
Double(Shape) - Constructor for class java.awt.geom. Path2D.Double
构造一个新的双精度Path2D从任意对象Shape对象。
Double(Shape, AffineTransform) - Constructor for class java.awt.geom. Path2D.Double
构造一个新的单精度Path2D从任意物体Shape对象，由一个转化AffineTransform对象。
Double(String) - Constructor for class java.lang. Double
已过时。
很少使用这个构造函数。 使用Double.parseDouble(String)将字符串转换为double原语，或使用Double.valueOf(String)将字符串转换为Double对象。
DOUBLE - com.sun.source.doctree. AttributeTree.ValueKind
属性值用双引号括起来。
DOUBLE - java.sql. JDBCType
标识通用SQL类型 DOUBLE 。
DOUBLE - javax.lang.model.type. TypeKind
原始类型 double 。
DOUBLE - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 DOUBLE 。
DOUBLE - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.lang.Double值的 SimpleType实例。
DOUBLE_LITERAL - com.sun.source.tree. Tree.Kind
用于表示double类型的浮点文字表达式的double 。
DoubleAccumulator - Class in java.util.concurrent.atomic
一个或多个变量一起保持正在运行的 double值，使用提供的函数进行更新。
DoubleAccumulator(DoubleBinaryOperator, double) - Constructor for class java.util.concurrent.atomic. DoubleAccumulator
使用给定的累加器函数和identity元素创建一个新的实例。
DoubleAdder - Class in java.util.concurrent.atomic
一个或多个变量一起保持初始为零 double总和。
DoubleAdder() - Constructor for class java.util.concurrent.atomic. DoubleAdder
创建一个新的加法器，初始和为零。
DoubleBinaryOperator - Interface in java.util.function
代表两个 double操作数的操作，并产生一个 double结果。
DoubleBinding - Class in javafx.beans.binding
提供实现double值Binding所需的大部分功能的基类。
DoubleBinding() - Constructor for class javafx.beans.binding. DoubleBinding
DoubleBuffer - Class in java.nio
双缓冲。
DoubleClickListener(JList<?>) - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.DoubleClickListener
一座 DoubleClickListener 。
DoubleConsumer - Interface in java.util.function
表示接受单个 double值参数的操作，不返回任何结果。
doubleExpression(ObservableDoubleValue) - Static method in class javafx.beans.binding. DoubleExpression
返回一个DoubleExpression的DoubleExpression 。
doubleExpression(ObservableValue<T>) - Static method in class javafx.beans.binding. DoubleExpression
返回一个DoubleExpression ，其中包含一个ObservableValue 。
DoubleExpression - Class in javafx.beans.binding
DoubleExpression是一个ObservableDoubleValue加上其他便利方法，以流利的方式生成绑定。
DoubleExpression() - Constructor for class javafx.beans.binding. DoubleExpression
DoubleFunction< R> - Interface in java.util.function
表示接受双值参数并产生结果的函数。
DoubleHolder - Class in org.omg.CORBA
持有人 Double 。
DoubleHolder() - Constructor for class org.omg.CORBA. DoubleHolder
构造一个新的 DoubleHolder对象，其 value字段初始化为0.0。
DoubleHolder(double) - Constructor for class org.omg.CORBA. DoubleHolder
为给定的 double构造一个新的 DoubleHolder对象。
DoublePredicate - Interface in java.util.function
表示一个 double值参数的谓词（布尔值函数）。
doubleProperty(Property<Double>) - Static method in class javafx.beans.property. DoubleProperty
返回一个DoubleProperty ，它包装一个Property ，并双向绑定到它。
DoubleProperty - Class in javafx.beans.property
这个类定义了一个Property包装double值。
DoubleProperty() - Constructor for class javafx.beans.property. DoubleProperty
DoublePropertyBase - Class in javafx.beans.property
类 DoublePropertyBase是包含 double值的属性的基类。
DoublePropertyBase() - Constructor for class javafx.beans.property. DoublePropertyBase
DoublePropertyBase的构造 DoublePropertyBase 。
DoublePropertyBase(double) - Constructor for class javafx.beans.property. DoublePropertyBase
DoublePropertyBase的构造 DoublePropertyBase 。
doubles() - Method in class java.util.concurrent. ThreadLocalRandom
返回一个有效的无限流伪随机数 double ，每个值在零（包括）和一（独占）之间。
doubles() - Method in class java.util. Random
返回一个有效的无限流伪随机数 double值，每个值在零（包括）和一（独占）之间。
doubles() - Method in class java.util. SplittableRandom
返回一个有效地无限流的伪随机数double来自该发生器和/或一个分割的值; 每个值在零（包括）和一（独占）之间。
doubles(double, double) - Method in class java.util.concurrent. ThreadLocalRandom
返回一个有效无限流的伪随机数 double值，每个符合给定的起始（包括）和绑定（排他）。
doubles(double, double) - Method in class java.util. Random
返回一个有效的无限流伪随机数 double值，每个符合给定的起始（包括）和绑定（排他）。
doubles(double, double) - Method in class java.util. SplittableRandom
返回一个有效的无限流的伪随机数double来自该发生器和/或从它的一个分裂值; 每个值符合给定的起始（包括）和绑定（排他）。
doubles(long) - Method in class java.util.concurrent. ThreadLocalRandom
返回一个流，产生给定的 streamSize伪随机数 double值，每个值在零（包括）和一（独占）之间。
doubles(long) - Method in class java.util. Random
返回产生给定的 streamSize伪随机数 double值的流，每个值在零（包括）和一（独占）之间。
doubles(long) - Method in class java.util. SplittableRandom
返回产生所述给定流streamSize数的伪随机的double从该发电机和/或从它一个分割值; 每个值在零（包括）和一（独占）之间。
doubles(long, double, double) - Method in class java.util.concurrent. ThreadLocalRandom
返回一个流，产生给定的 streamSize伪随机数 double值，每个值符合给定的起始（包括）和绑定（排他）。
doubles(long, double, double) - Method in class java.util. Random
返回一个流，产生给定的 streamSize数量的伪随机数 double值，每个值符合给定的起始（包括）和绑定（排他）。
doubles(long, double, double) - Method in class java.util. SplittableRandom
返回一个流，产生给定的streamSize数量的伪随机double从这个发生器和/或从它的一个分割; 每个值符合给定的起始（包括）和绑定（排他）。
DoubleSeqHelper - Class in org.omg.CORBA
助手 DoubleSeq 。
DoubleSeqHelper() - Constructor for class org.omg.CORBA. DoubleSeqHelper
DoubleSeqHolder - Class in org.omg.CORBA
持有人 DoubleSeq 。
DoubleSeqHolder() - Constructor for class org.omg.CORBA. DoubleSeqHolder
DoubleSeqHolder(double[]) - Constructor for class org.omg.CORBA. DoubleSeqHolder
DoubleSpinnerValueFactory(double, double) - Constructor for class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory
构造一个新的DoubleSpinnerValueFactory，将初始值设置为等于最小值，默认 amountToStepBy 。
DoubleSpinnerValueFactory(double, double, double) - Constructor for class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory
构造一个新的DoubleSpinnerValueFactory，默认 amountToStepBy 。
DoubleSpinnerValueFactory(double, double, double, double) - Constructor for class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory
构造一个新的DoubleSpinnerValueFactory。
doubleStream(Supplier<? extends Spliterator.OfDouble>, int, boolean) - Static method in class java.util.stream. StreamSupport
创建一个新的顺序或并行 DoubleStream从 Supplier的 Spliterator.OfDouble 。
doubleStream(Spliterator.OfDouble, boolean) - Static method in class java.util.stream. StreamSupport
创建一个新的串行或并行 DoubleStream从 Spliterator.OfDouble 。
DoubleStream - Interface in java.util.stream
支持顺序和并行聚合操作的原始双值元素序列。
DoubleStream.Builder - Interface in java.util.stream
一个可变的构建器为 DoubleStream 。
DoubleStringConverter - Class in javafx.util.converter
StringConverter实现Double （和双原语）值。
DoubleStringConverter() - Constructor for class javafx.util.converter. DoubleStringConverter
DoubleSummaryStatistics - Class in java.util
统计数据的收集状态，如count，min，max，sum和average。
DoubleSummaryStatistics() - Constructor for class java.util. DoubleSummaryStatistics
用零计数，零和， Double.POSITIVE_INFINITY分钟， Double.NEGATIVE_INFINITY最大和零平均值构造一个空实例。
DoubleSupplier - Interface in java.util.function
代表 double结果。
DoubleToIntFunction - Interface in java.util.function
表示接受双值参数并产生int值结果的函数。
doubleToLongBits(double) - Static method in class java.lang. Double
根据IEEE 754浮点“双格式”位布局返回指定浮点值的表示。
DoubleToLongFunction - Interface in java.util.function
表示接受双值参数并产生长期值结果的函数。
doubleToRawLongBits(double) - Static method in class java.lang. Double
根据IEEE 754浮点“双格式”位布局返回指定浮点值的表示，保留非数字（NaN）值。
DoubleType - Interface in com.sun.jdi
在目标VM中访问的所有原始双值的类型。
DoubleUnaryOperator - Interface in java.util.function
表示对单个 double值操作数的操作，产生一个 double值结果。
doubleValue() - Method in interface com.sun.jdi. PrimitiveValue
将此值转换为DoubleValue，并将结果作为double返回。
doubleValue() - Method in class java.lang. Byte
返回此值 Byte为 double一个宽元转换后。
doubleValue() - Method in class java.lang. Double
返回此 Double对象的 double值。
doubleValue() - Method in class java.lang. Float
返回此值 Float为 double一个宽元转换后。
doubleValue() - Method in class java.lang. Integer
返回此值 Integer为 double一个宽元转换后。
doubleValue() - Method in class java.lang. Long
返回此值 Long为 double一个宽元转换后。
doubleValue() - Method in class java.lang. Number
返回指定数字的值作为 double 。
doubleValue() - Method in class java.lang. Short
返回此值 Short为 double一个宽元转换后。
doubleValue() - Method in class java.math. BigDecimal
将此 BigDecimal转换为 double 。
doubleValue() - Method in class java.math. BigInteger
将此BigInteger转换为 double 。
doubleValue() - Method in class java.util.concurrent.atomic. AtomicInteger
返回此的当前值 AtomicInteger作为 double加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
doubleValue() - Method in class java.util.concurrent.atomic. AtomicLong
返回此的当前值 AtomicLong作为 double加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
doubleValue() - Method in class java.util.concurrent.atomic. DoubleAccumulator
相当于 DoubleAccumulator.get() 。
doubleValue() - Method in class java.util.concurrent.atomic. DoubleAdder
相当于 DoubleAdder.sum() 。
doubleValue() - Method in class java.util.concurrent.atomic. LongAccumulator
在扩展原始转换后，返回 current value作为 double 。
doubleValue() - Method in class java.util.concurrent.atomic. LongAdder
在扩展原始转换后，返回 LongAdder.sum()作为 double 。
doubleValue() - Method in class javafx.beans.binding. DoubleExpression
doubleValue() - Method in class javafx.beans.binding. FloatExpression
doubleValue() - Method in class javafx.beans.binding. IntegerExpression
doubleValue() - Method in class javafx.beans.binding. LongExpression
doubleValue() - Method in interface javafx.beans.value. ObservableNumberValue
返回 ObservableNumberValue的值作为 double 。
DoubleValue - Interface in com.sun.jdi
提供对目标虚拟机中原始的 double值的访问。
doubleValueAt(ObservableList<? extends Number>, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，其中包含ObservableList在指定位置的元素。
doubleValueAt(ObservableList<? extends Number>, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
doubleValueAt(ObservableList<? extends Number>, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
doubleValueAt(ObservableMap<K, ? extends Number>, ObservableValue<? extends K>) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
doubleValueAt(ObservableMap<K, ? extends Number>, K) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
doWhileLoop(MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles
从初始化器，身体和谓词构造一个 do-while循环。
DoWhileLoopTree - Interface in com.sun.source.tree
一个用于 do语句的树节点。
DoWhileLoopTree - Interface in jdk.nashorn.api.tree
“do”语句的树节点。
DOWN - java.math. RoundingMode
舍入模式向零舍入。
DOWN - javafx.geometry. VerticalDirection
向下的方向
DOWN - javafx.scene.control.skin. TextInputControlSkin.Direction
DOWN - javafx.scene.input. KeyCode
常数为非numpad 向下箭头键。
DOWN - javafx.scene.input. KeyCombination.ModifierValue
表示修饰符键必须关闭的常数。
DOWN - Static variable in class java.awt. Event
已过时。
向下箭头键，非ASCII操作键。
DOWN_CYCLE_TRAVERSAL_KEYS - Static variable in class java.awt. KeyboardFocusManager
Down Cycle的标识符聚焦遍历键。
downAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号向下移动一个位置的操作名称。
downFocusCycle() - Method in class java.awt. KeyboardFocusManager
当焦点所有者是当前焦点循环根的容器时，将焦点向下移动当前焦点所有者的一个焦点遍历循环。
downFocusCycle(Container) - Method in class java.awt. DefaultKeyboardFocusManager
将焦点向下移动一个焦点遍历周期。
downFocusCycle(Container) - Method in class java.awt. KeyboardFocusManager
将焦点向下移动一个焦点遍历周期。
downKey - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
downKey - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
已过时。
从Java 2平台v1.3开始。
downKey - Variable in class javax.swing.plaf.basic. BasicToolBarUI
已过时。
从Java 2平台v1.3开始。
downloadFailed(URL, String) - Method in interface javax.jnlp. DownloadServiceListener
如果下载失败或意外中止，JNLP客户端的 DownloadService实现应该调用此方法。
DownloadService - Interface in javax.jnlp
DownloadService服务允许应用程序控制自己的资源如何被缓存，以确定当前缓存哪些资源，强制资源被缓存，以及从高速缓存中移除资源。
DownloadService2 - Interface in javax.jnlp
为JNLP应用程序提供高速缓存查询服务。
DownloadService2.ResourceSpec - Class in javax.jnlp
指定资源查询的模式作为参数，并保留结果为 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
DownloadServiceListener - Interface in javax.jnlp
DownloadServiceListener提供了一个回调对象实现的接口，可以由一个DownloadService实现使用。
DPCM - Static variable in class javax.print.attribute. ResolutionSyntax
值表示每厘米点数（dpcm）。
DPI - Static variable in class javax.print.attribute. ResolutionSyntax
值表示每英寸点数（dpi）。
DRAFT - javafx.print. PrintQuality
指定DRAFT质量打印。
DRAFT - Static variable in class java.awt. PageAttributes.PrintQualityType
PrintQualityType实例用于指定打印质量草图。
DRAFT - Static variable in class javax.print.attribute.standard. PrintQuality
最低质量可用在打印机上。
DRAG_DETECTED - Static variable in class javafx.scene.input. MouseEvent
该事件被传递到被识别为拖动手势的源的节点。
DRAG_DONE - Static variable in class javafx.scene.input. DragEvent
数据丢弃在放置目标上之后，这种事件就发生在拖放手势源上。
DRAG_DROPPED - Static variable in class javafx.scene.input. DragEvent
当在拖放目标上拖放手势时释放鼠标按钮时，会发生此事件。
DRAG_ENTERED - Static variable in class javafx.scene.input. DragEvent
当拖动手势进入节点时，会发生此事件。
DRAG_ENTERED_TARGET - Static variable in class javafx.scene.input. DragEvent
当拖动手势进入节点时，会发生此事件。
DRAG_EXITED - Static variable in class javafx.scene.input. DragEvent
当拖动手势退出节点时，会发生此事件。
DRAG_EXITED_TARGET - Static variable in class javafx.scene.input. DragEvent
当拖动手势退出节点时，会发生此事件。
DRAG_LAYER - Static variable in class javax.swing. JLayeredPane
定义拖动图层的便利对象。
DRAG_OVER - Static variable in class javafx.scene.input. DragEvent
当拖动手势在该节点内进行时，会发生此事件。
Dragboard - Class in javafx.scene.input
拖放具体Clipboard 。
DragController(MouseEvent) - Constructor for class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController
构造一个新的实例 DragController 。
dragDividerTo(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider
消息的BasicSplitPaneUI与dragDividerTo该实例包含在。
dragDividerTo(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
在拖动会话期间将消息传递到 location 。
dragDropEnd(DragSourceDropEvent) - Method in class java.awt.dnd. DragSourceAdapter
调用此方法来表示拖放操作完成。
dragDropEnd(DragSourceDropEvent) - Method in class java.awt.dnd. DragSourceContext
致电 dragDropEnd在 DragSourceListener注册了这个 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDropEvent 。
dragDropEnd(DragSourceDropEvent) - Method in interface java.awt.dnd. DragSourceListener
调用此方法来表示拖放操作完成。
dragEnter(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceAdapter
称为光标的热点进入平台依赖的放置站点。
dragEnter(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceContext
致电 dragEnter在 DragSourceListener注册该 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
dragEnter(DragSourceDragEvent) - Method in interface java.awt.dnd. DragSourceListener
称为光标的热点进入平台依赖的放置站点。
dragEnter(DropTargetDragEvent) - Method in class java.awt.dnd. DropTarget
致电 dragEnter在注册的 DropTargetListener并通过指定的 DropTargetDragEvent 。
dragEnter(DropTargetDragEvent) - Method in class java.awt.dnd. DropTargetAdapter
当拖动操作正在进行时，当鼠标指针进入为此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
dragEnter(DropTargetDragEvent) - Method in interface java.awt.dnd. DropTargetListener
当拖动操作正在进行时，当鼠标指针进入为此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
DragEvent - Class in javafx.scene.input
拖动事件在拖放手势时替换鼠标事件。
DragEvent(Object, EventTarget, EventType<DragEvent>, Dragboard, double, double, double, double, TransferMode, Object, Object, PickResult) - Constructor for class javafx.scene.input. DragEvent
构造新的DragEvent事件。
DragEvent(EventType<DragEvent>, Dragboard, double, double, double, double, TransferMode, Object, Object, PickResult) - Constructor for class javafx.scene.input. DragEvent
构造具有空源和目标的新的DragEvent事件。
dragExit(DragSourceEvent) - Method in class java.awt.dnd. DragSourceAdapter
称为光标的热点退出平台相关的放置站点。
dragExit(DragSourceEvent) - Method in class java.awt.dnd. DragSourceContext
电话 dragExit在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceEvent 。
dragExit(DragSourceEvent) - Method in interface java.awt.dnd. DragSourceListener
称为光标的热点退出平台相关的放置站点。
dragExit(DropTargetEvent) - Method in class java.awt.dnd. DropTarget
致电 dragExit注册 DropTargetListener并通过指定的 DropTargetEvent 。
dragExit(DropTargetEvent) - Method in class java.awt.dnd. DropTargetAdapter
当拖动操作正在进行时，当鼠标指针已经退出到此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
dragExit(DropTargetEvent) - Method in interface java.awt.dnd. DropTargetListener
当拖动操作正在进行时，当鼠标指针已经退出到此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
dragFrame(JComponent, int, int) - Method in class javax.swing. DefaultDesktopManager
将被拖动的框架的可视位置移动到指定的位置。
dragFrame(JComponent, int, int) - Method in interface javax.swing. DesktopManager
用户已移动框架。
draggedColumn - Variable in class javax.swing.table. JTableHeader
正在拖动列的索引。
draggedDistance - Variable in class javax.swing.table. JTableHeader
与其原始位置的距离，列已被拖动。
dragger - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
处理鼠标拖动消息来做实际拖动。
DragGestureEvent - Class in java.awt.dnd
当特定的 DragGestureRecognizer检测到正在跟踪的 Component上发生平台相关的拖动启动手势时， DragGestureEvent将传递给 DragGestureListener的dragGestureRecognized（）方法。
DragGestureEvent(DragGestureRecognizer, int, Point, List<? extends InputEvent>) - Constructor for class java.awt.dnd. DragGestureEvent
构造一个 DragGestureEvent由给定对象 DragGestureRecognizer实例激发此事件中， act表示用户的首选操作参数，一个 ori参数指示拖动原点，和一个 List组成动作（事件 evs参数）。
dragGestureListener - Variable in class java.awt.dnd. DragGestureRecognizer
该 DragGestureListener与此 DragGestureRecognizer相关联。
DragGestureListener - Interface in java.awt.dnd
用于接收拖动手势事件的侦听器界面。
dragGestureRecognized(DragGestureEvent) - Method in interface java.awt.dnd. DragGestureListener
当 DragGestureRecognizer检测到与平台相关的拖动启动手势时，此方法由 DragGestureRecognizer调用。
DragGestureRecognizer - Class in java.awt.dnd
DragGestureRecognizer是用于规范平台相关的监听器的抽象基类，可以与特定的 Component相关联，以便识别平台相关的拖动启动手势。
DragGestureRecognizer(DragSource) - Constructor for class java.awt.dnd. DragGestureRecognizer
构造一个新的 DragGestureRecognizer给定 DragSource用于此拖放操作。
DragGestureRecognizer(DragSource, Component) - Constructor for class java.awt.dnd. DragGestureRecognizer
构造一个新的 DragGestureRecognizer给出 DragSource用于此拖放操作，而 Component这个 DragGestureRecognizer应该“观察”拖动启动手势。
DragGestureRecognizer(DragSource, Component, int) - Constructor for class java.awt.dnd. DragGestureRecognizer
构造一个新的 DragGestureRecognizer给定 DragSource用于此拖放操作， Component这 DragGestureRecognizer应该“观察”拖动启动手势，以及此拖放操作支持的操作。
DragGestureRecognizer(DragSource, Component, int, DragGestureListener) - Constructor for class java.awt.dnd. DragGestureRecognizer
构造一个新的 DragGestureRecognizer给定 DragSource用于这个拖放操作， Component这个 DragGestureRecognizer应该“观察”拖动启动手势，这个拖放操作支持的动作，以及 DragGestureListener通知一次已经检测到拖动启动手势。
draggingHW - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
如果任何一个孩子（不包括nonContinuousLayoutDivider）是重量，则在startDragging中设置为true。
dragMouseMoved(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceAdapter
在拖动操作期间鼠标移动时调用。
dragMouseMoved(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceContext
致电 dragMouseMoved在 DragSourceMotionListener注册与 DragSource相关联的这个 DragSourceContext ，他们通过了指定的 DragSourceDragEvent 。
dragMouseMoved(DragSourceDragEvent) - Method in interface java.awt.dnd. DragSourceMotionListener
在拖动操作期间鼠标移动时调用。
dragOver(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceAdapter
称为光标的热点在平台相关的放置站点上移动。
dragOver(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceContext
致电 dragOver在 DragSourceListener注册该 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
dragOver(DragSourceDragEvent) - Method in interface java.awt.dnd. DragSourceListener
称为光标的热点在平台相关的放置站点上移动。
dragOver(DropTargetDragEvent) - Method in class java.awt.dnd. DropTarget
致电 dragOver注册 DropTargetListener并通过指定的 DropTargetDragEvent 。
dragOver(DropTargetDragEvent) - Method in class java.awt.dnd. DropTargetAdapter
当拖动操作正在进行时被调用，而鼠标指针仍然在该监听 DropTarget注册的 DropTarget的放置站点的可操作部分上。
dragOver(DropTargetDragEvent) - Method in interface java.awt.dnd. DropTargetListener
当拖动操作正在进行时被调用，而鼠标指针仍然在向该监听 DropTarget注册的 DropTarget的放置站点的可操作部分上。
dragSource - Variable in class java.awt.dnd. DragGestureRecognizer
该 DragSource与此 DragGestureRecognizer相关联。
DragSource - Class in java.awt.dnd
DragSource是负责启动拖放操作的实体，可用于多种情况：该JVM的生命周期为每个JVM 1个默认实例。
DragSource() - Constructor for class java.awt.dnd. DragSource
创建一个新的 DragSource 。
DragSourceAdapter - Class in java.awt.dnd
用于接收拖动源事件的抽象适配器类。
DragSourceAdapter() - Constructor for class java.awt.dnd. DragSourceAdapter
DragSourceContext - Class in java.awt.dnd
DragSourceContext课程负责管理拖放协议的发起方。
DragSourceContext(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Constructor for class java.awt.dnd. DragSourceContext
从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。
DragSourceDragEvent - Class in java.awt.dnd
DragSourceDragEvent从 DragSourceContextPeer通过 DragSourceContext发送到 DragSourceListener注册 DragSourceContext及其相关联的 DragSource 。
DragSourceDragEvent(DragSourceContext, int, int, int) - Constructor for class java.awt.dnd. DragSourceDragEvent
构造一个 DragSourceDragEvent 。
DragSourceDragEvent(DragSourceContext, int, int, int, int, int) - Constructor for class java.awt.dnd. DragSourceDragEvent
构造一个 DragSourceDragEvent给定了指定的 DragSourceContext ，用户放置操作，目标放置操作，修饰符和坐标。
DragSourceDropEvent - Class in java.awt.dnd
所述 DragSourceDropEvent从递送 DragSourceContextPeer ，经由 DragSourceContext ，到 dragDropEnd的方法 DragSourceListener与注册小号 DragSourceContext和与其相关联的 DragSource 。
DragSourceDropEvent(DragSourceContext) - Constructor for class java.awt.dnd. DragSourceDropEvent
构造一个 DragSourceDropEvent的拖动，不会导致下降。
DragSourceDropEvent(DragSourceContext, int, boolean) - Constructor for class java.awt.dnd. DragSourceDropEvent
构建一个 DragSourceDropEvent的一个下降，给出了 DragSourceContext的下拉动作，以及一个 boolean指示下降是否成功。
DragSourceDropEvent(DragSourceContext, int, boolean, int, int) - Constructor for class java.awt.dnd. DragSourceDropEvent
构造一个 DragSourceDropEvent一个下降，给出了 DragSourceContext的下降动作，一个 boolean表示是否下降成功，并且坐标。
DragSourceEvent - Class in java.awt.dnd
这个类是 DragSourceDragEvent和 DragSourceDropEvent的基类。
DragSourceEvent(DragSourceContext) - Constructor for class java.awt.dnd. DragSourceEvent
构造一个 DragSourceEvent给定一个指定的 DragSourceContext 。
DragSourceEvent(DragSourceContext, int, int) - Constructor for class java.awt.dnd. DragSourceEvent
构造一个 DragSourceEvent给定一个指定的 DragSourceContext和光标位置的坐标。
DragSourceListener - Interface in java.awt.dnd
DragSourceListener定义了用于跟踪用户手势状态的拖放操作的发起者的事件接口，并在拖放操作中向用户提供适当的“拖拽”反馈。
DragSourceMotionListener - Interface in java.awt.dnd
用于在拖动操作期间接收鼠标运动事件的侦听器界面。
dragTo(Point, Point) - Method in class javax.swing.plaf.basic. BasicToolBarUI
该方法是用来拖动 DragWindow在 JToolBar被拖动。
dragWindow - Variable in class javax.swing.plaf.basic. BasicToolBarUI
实例 DragWindow 。
drain() - Method in class java.io. ObjectOutputStream
排除ObjectOutputStream中的缓冲数据。
drain() - Method in interface javax.sound.sampled. DataLine
通过持续的数据I / O从排队排出数据，直到数据线的内部缓冲区被清空。
drainPermits() - Method in class java.util.concurrent. Semaphore
获得并返回所有可立即获得的许可证，或者如果有可用的许可证，则可以将其释放。
drainTasksTo(Collection<? super ForkJoinTask<?>>) - Method in class java.util.concurrent. ForkJoinPool
从调度队列中删除所有可用的未执行的提交和分派任务，并将其添加到给定集合中，而不会更改其执行状态。
drainTo(Collection<? super E>) - Method in class java.util.concurrent. ArrayBlockingQueue
drainTo(Collection<? super E>) - Method in interface java.util.concurrent. BlockingQueue
从该队列中删除所有可用的元素，并将它们添加到给定的集合中。
drainTo(Collection<? super E>) - Method in class java.util.concurrent. DelayQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent. LinkedBlockingDeque
drainTo(Collection<? super E>) - Method in class java.util.concurrent. LinkedBlockingQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent. LinkedTransferQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent. PriorityBlockingQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent. SynchronousQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent. ArrayBlockingQueue
drainTo(Collection<? super E>, int) - Method in interface java.util.concurrent. BlockingQueue
最多从该队列中删除给定数量的可用元素，并将它们添加到给定的集合中。
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent. DelayQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent. LinkedBlockingDeque
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent. LinkedBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent. LinkedTransferQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent. PriorityBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent. SynchronousQueue
draw(Graphics2D, float, float) - Method in class java.awt.font. GraphicAttribute
在指定的位置渲染此 GraphicAttribute 。
draw(Graphics2D, float, float) - Method in class java.awt.font. ImageGraphicAttribute
在指定的位置渲染此 GraphicAttribute 。
draw(Graphics2D, float, float) - Method in class java.awt.font. ShapeGraphicAttribute
在指定的位置渲染此 GraphicAttribute 。
draw(Graphics2D, float, float) - Method in class java.awt.font. TextLayout
这呈现TextLayout在指定的指定位置Graphics2D上下文。
draw(Shape) - Method in class java.awt. Graphics2D
使用当前的 Graphics2D上下文的设置来 Shape的轮廓。
draw3DRect(int, int, int, int, boolean) - Method in class java.awt. Graphics
绘制指定矩形的3-D高亮轮廓。
draw3DRect(int, int, int, int, boolean) - Method in class java.awt. Graphics2D
绘制指定矩形的3-D高亮轮廓。
draw3DRect(int, int, int, int, boolean) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.draw3DRect 。
drawArc(int, int, int, int, int, int) - Method in class java.awt. Graphics
绘制覆盖指定矩形的圆形或椭圆形圆弧的轮廓。
drawArc(int, int, int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawArc 。
drawBezel(Graphics, int, int, int, int, boolean, boolean, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
画一个挡板
drawBuffer - Variable in class java.awt. Component.FlipBufferStrategy
绘图缓冲区
drawBytes(byte[], int, int, int, int) - Method in class java.awt. Graphics
绘制由指定字节数组给出的文本，使用此图形上下文的当前字体和颜色。
drawBytes(byte[], int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawBytes 。
drawCentered(Component, Graphics, Icon, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI
绘制以（x，y）为中心的 icon 。
drawCentered(Component, Graphics, Icon, int, int) - Method in class javax.swing.plaf.synth. SynthTreeUI
以（x，y）为中心绘制 icon 。
drawChars(char[], int, int, int, int) - Method in class java.awt. Graphics
绘制由指定的字符数组给出的文本，使用此图形上下文的当前字体和颜色。
drawChars(char[], int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawChars 。
drawCheck(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalCheckBoxIcon
油漆 MetalCheckBoxIcon 。
drawDashedHorizontalLine(Graphics, int, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI
画一条水平虚线。
drawDashedRect(Graphics, int, int, int, int) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
绘制虚线矩形。
drawDashedVerticalLine(Graphics, int, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI
画一条垂直虚线。
drawEchoCharacter(Graphics2D, float, float, char) - Method in class javax.swing.text. PasswordView
呈现回音字符，或者用于显示密码字符的任何图形。
drawEchoCharacter(Graphics, int, int, char) - Method in class javax.swing.text. PasswordView
已过时。
替换为PasswordView.drawEchoCharacter(Graphics2D, float, float, char)
drawEtchedRect(Graphics, int, int, int, int, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
画一个蚀刻的矩形。
drawGlyphVector(GlyphVector, float, float) - Method in class java.awt. Graphics2D
使用Graphics2D上下文的呈现属性呈现指定的GlyphVector的文本。
drawGroove(Graphics, int, int, int, int, Color, Color) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
画一个凹槽
drawImage(BufferedImage, BufferedImageOp, int, int) - Method in class java.awt. Graphics2D
呈现一个BufferedImage ，用BufferedImageOp过滤。
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class java.awt. Graphics
按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawImage 。
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class java.awt. Graphics
按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawImage 。
drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class java.awt. Graphics
绘制与已经缩放以适应指定矩形内的指定图像的大小。
drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawImage 。
drawImage(Image, int, int, int, int, ImageObserver) - Method in class java.awt. Graphics
绘制与已经缩放以适应指定矩形内的指定图像的大小。
drawImage(Image, int, int, int, int, ImageObserver) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawImage 。
drawImage(Image, int, int, Color, ImageObserver) - Method in class java.awt. Graphics
绘制当前可用的指定图像的大小。
drawImage(Image, int, int, Color, ImageObserver) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawImage 。
drawImage(Image, int, int, ImageObserver) - Method in class java.awt. Graphics
绘制当前可用的指定图像的大小。
drawImage(Image, int, int, ImageObserver) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawImage 。
drawImage(Image, AffineTransform, ImageObserver) - Method in class java.awt. Graphics2D
渲染图像，在绘制之前将图像空间的变换应用到用户空间中。
drawImage(Image, double, double) - Method in class javafx.scene.canvas. GraphicsContext
使用给定图像的宽度和高度在给定的x，y位置绘制图像。
drawImage(Image, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
将图像绘制到画布的给定目标矩形中。
drawImage(Image, double, double, double, double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
将给定图像的指定源矩形绘制到Canvas的给定目标矩形。
drawingCache - Variable in class javax.swing.plaf.basic. BasicTreeUI
用于最小化垂直线的绘图。
drawInverted() - Method in class javax.swing.plaf.basic. BasicSliderUI
画倒。
drawLine(int, int, int, int) - Method in class java.awt. Graphics
在该图形上下文的坐标系中点 (x1, y1)和 (x2, y2)之间绘制一条线，使用当前颜色。
drawLine(int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawLine 。
drawLine(int, int, Graphics2D, float, float) - Method in class javax.swing.text. WrappedPlainView
渲染一行文本，最终抑制空格并展开任何标签。
drawLine(int, int, Graphics, int, int) - Method in class javax.swing.text. WrappedPlainView
已过时。
替换为WrappedPlainView.drawLine(int, int, Graphics2D, float, float)
drawLine(int, Graphics2D, float, float) - Method in class javax.swing.text. PlainView
渲染一行文本，最终抑制空格并展开任何标签。
drawLine(int, Graphics, int, int) - Method in class javax.swing.text. PlainView
已过时。
由PlainView.drawLine(int, Graphics2D, float, float)取代
drawLine(SynthContext, Object, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils
在两个终点之间画一条线。
drawLine(SynthContext, Object, Graphics, int, int, int, int, Object) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils
在两个终点之间画一条线。
drawLoweredBezel(Graphics, int, int, int, int, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
画下一个挡板。
DrawMode - Enum in javafx.scene.shape
定义与 Shape3D.drawMode使用时如何绘制多边形
drawModeProperty() - Method in class javafx.scene.shape. Shape3D
定义用于渲染 Shape3D的绘制模式。
drawOval(int, int, int, int) - Method in class java.awt. Graphics
绘制椭圆形轮廓。
drawOval(int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawOval 。
drawPolygon(int[], int[], int) - Method in class java.awt. Graphics
绘制由 x和 y坐标数组定义的封闭多边形。
drawPolygon(int[], int[], int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawPolygon 。
drawPolygon(Polygon) - Method in class java.awt. Graphics
绘制由指定的 Polygon对象定义的多边形的轮廓。
drawPolyline(int[], int[], int) - Method in class java.awt. Graphics
绘制由 x和 y坐标数组定义的连接线序列。
drawPolyline(int[], int[], int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawPolyline 。
drawRect(int, int, int, int) - Method in class java.awt. Graphics
绘制指定矩形的轮廓。
drawRect(int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawRect 。
drawRenderableImage(RenderableImage, AffineTransform) - Method in class java.awt. Graphics2D
渲染一个RenderableImage ，在绘制之前将图像空间的变换应用到用户空间。
drawRenderedImage(RenderedImage, AffineTransform) - Method in class java.awt. Graphics2D
渲染一个RenderedImage ，在绘制之前将图像空间的变换应用到用户空间中。
drawRoundRect(int, int, int, int, int, int) - Method in class java.awt. Graphics
使用此图形上下文的当前颜色绘制一个概略的圆角矩形。
drawRoundRect(int, int, int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawRoundRect 。
drawSelectedText(Graphics2D, float, float, int, int) - Method in class javax.swing.text. PasswordView
drawSelectedText(Graphics2D, float, float, int, int) - Method in class javax.swing.text. PlainView
将模型中的给定范围渲染为所选文本。
drawSelectedText(Graphics2D, float, float, int, int) - Method in class javax.swing.text. WrappedPlainView
将模型中的给定范围渲染为所选文本。
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text. PasswordView
已过时。
替换为PasswordView.drawSelectedText(Graphics2D, float, float, int, int)
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text. PlainView
已过时。
由PlainView.drawSelectedText(Graphics2D, float, float, int, int)取代
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text. WrappedPlainView
已过时。
替换为WrappedPlainView.drawSelectedText(Graphics2D, float, float, int, int)
drawString(Graphics, String, int, int, int) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
绘制一个字符串，图形 g在位置（x，y）就像 g.drawString会。
drawString(String, float, float) - Method in class java.awt. Graphics2D
使用 Graphics2D上下文中的当前文本属性状态呈现由指定的 String指定的文本。
drawString(String, int, int) - Method in class java.awt. Graphics
使用该图形上下文的当前字体和颜色绘制由指定字符串给出的文本。
drawString(String, int, int) - Method in class java.awt. Graphics2D
使用 Graphics2D上下文中的当前文本属性状态呈现指定的 String的文本。
drawString(String, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawString 。
drawString(AttributedCharacterIterator, float, float) - Method in class java.awt. Graphics2D
根据TextAttribute类的规范，渲染指定迭代器的文本，以应用其属性。
drawString(AttributedCharacterIterator, int, int) - Method in class java.awt. Graphics
根据TextAttribute类的规范，渲染应用其属性的指定迭代器的文本。
drawString(AttributedCharacterIterator, int, int) - Method in class java.awt. Graphics2D
根据TextAttribute类的规范，渲染指定的迭代器的文本应用其属性。
drawString(AttributedCharacterIterator, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.drawString 。
drawString(JComponent, Graphics2D, String, float, float) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
使用提供的组件的文本属性和反锯齿提示在指定位置绘制给定的字符串。
drawStringUnderlineCharAt(Graphics, String, int, int, int) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
画一个字符串与图形 g在位置（ x ， y ）就像 g.drawString会。
drawStringUnderlineCharAt(JComponent, Graphics2D, String, int, float, float) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils
在指定的位置绘制给定的字符串，强调指定的字符。
drawTabbedText(Segment, float, float, Graphics2D, TabExpander, int) - Static method in class javax.swing.text. Utilities
绘制给定的文本，使用给定的选项卡扩展技术扩展包含的所有选项卡。
drawTabbedText(Segment, int, int, Graphics, TabExpander, int) - Static method in class javax.swing.text. Utilities
已过时。
替换为Utilities.drawTabbedText(Segment, float, float, Graphics2D, TabExpander, int)
drawUnselectedText(Graphics2D, float, float, int, int) - Method in class javax.swing.text. PasswordView
drawUnselectedText(Graphics2D, float, float, int, int) - Method in class javax.swing.text. PlainView
将模型中的给定范围呈现为正常未选择的文本。
drawUnselectedText(Graphics2D, float, float, int, int) - Method in class javax.swing.text. WrappedPlainView
将模型中的给定范围呈现为正常未选择的文本。
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text. PasswordView
已过时。
替换为PasswordView.drawUnselectedText(Graphics2D, float, float, int, int)
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text. PlainView
已过时。
替换为PlainView.drawUnselectedText(Graphics2D, float, float, int, int)
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text. WrappedPlainView
已过时。
替换为WrappedPlainView.drawUnselectedText(Graphics2D, float, float, int, int)
drawVBuffer - Variable in class java.awt. Component.FlipBufferStrategy
绘图缓冲区作为易失性图像
DrbgParameters - Class in java.security
该类指定DRBG（确定性随机位发生器）使用的参数。
DrbgParameters.Capability - Enum in java.security
DRBG的可重新预测和预测抵抗能力。
DrbgParameters.Instantiation - Class in java.security
用于实例化的DRBG参数。
DrbgParameters.NextBytes - Class in java.security
用于随机位生成的DRBG参数。
DrbgParameters.Reseed - Class in java.security
重新植入的DRBG参数。
Driver - Interface in java.sql
每个驱动程序类必须实现的接口。
DriverAction - Interface in java.sql
当Driver想要通知DriverManager时必须实现的接口。
DriverManager - Class in java.sql
用于管理一组JDBC驱动程序的基本服务。
DriverPropertyInfo - Class in java.sql
用于进行连接的驱动程序属性。
DriverPropertyInfo(String, String) - Constructor for class java.sql. DriverPropertyInfo
构造具有给定名称和值的 DriverPropertyInfo对象。
drivers() - Static method in class java.sql. DriverManager
使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索流。
drop() - Method in class java.nio.channels. MembershipKey
删除会员资格
drop(DropTargetDropEvent) - Method in class java.awt.dnd. DropTarget
致电 drop注册 DropTargetListener并通过指定的 DropTargetDropEvent如果这 DropTarget是活动的。
drop(DropTargetDropEvent) - Method in interface java.awt.dnd. DropTargetListener
当拖放操作已终止时，在该收听者注册的 DropTarget的投放站点的可操作部分上下降。
drop(Snippet) - Method in class jdk.jshell. JShell
从状态中移除声明。
dropActionChanged(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceAdapter
当用户修改了放置手势时调用。
dropActionChanged(DragSourceDragEvent) - Method in class java.awt.dnd. DragSourceContext
致电 dropActionChanged在 DragSourceListener注册此 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
dropActionChanged(DragSourceDragEvent) - Method in interface java.awt.dnd. DragSourceListener
当用户修改了放置手势时调用。
dropActionChanged(DropTargetDragEvent) - Method in class java.awt.dnd. DropTarget
致电 dropActionChanged注册 DropTargetListener并通过指定的 DropTargetDragEvent 。
dropActionChanged(DropTargetDragEvent) - Method in class java.awt.dnd. DropTargetAdapter
如果用户修改了当前的放置手势，则被调用。
dropActionChanged(DropTargetDragEvent) - Method in interface java.awt.dnd. DropTargetListener
如果用户修改了当前的放置手势，则被调用。
dropArguments(int, Class<?>...) - Method in class jdk.dynalink.linker. GuardedInvocation
进行调用，在调用和保护（如果存在并且至少具有 pos参数）中 pos参数，具有 MethodHandles.dropArguments(MethodHandle, int, Class...) 。
dropArguments(int, List<Class<?>>) - Method in class jdk.dynalink.linker. GuardedInvocation
在调用和保护（如果存在并且至少具有 pos参数）中使用 MethodHandles.dropArguments(MethodHandle, int, List)进行调用 。
dropArguments(MethodHandle, int, Class<?>...) - Static method in class java.lang.invoke. MethodHandles
产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
dropArguments(MethodHandle, int, List<Class<?>>) - Static method in class java.lang.invoke. MethodHandles
产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
dropArgumentsToMatch(MethodHandle, int, List<Class<?>>, int) - Static method in class java.lang.invoke. MethodHandles
适应目标方法句柄以匹配给定的参数类型列表。
dropComplete(boolean) - Method in class java.awt.dnd. DropTargetContext
该方法表明，下降完成并且成功。
dropComplete(boolean) - Method in class java.awt.dnd. DropTargetDropEvent
该方法通知 DragSource丢弃传输完成。
DropLocation(Point) - Constructor for class javax.swing. TransferHandler.DropLocation
为给定点构建一个放置位置。
dropLookupMode(int) - Method in class java.lang.invoke. MethodHandles.Lookup
在同一查找类中创建一个查找，该查找对象查找成员，但查找模式已丢失给定的查找模式。
DropMode - Enum in javax.swing
拖放模式，用于确定组件在拖放过程中跟踪并指示放置位置的方法。
dropParameterTypes(int, int) - Method in class java.lang.invoke. MethodType
查找或创建一种省略某些参数类型的方法类型。
DROPPED - jdk.jshell. Snippet.Status
由于显式调用了 JShell.drop(Snippet)，因此该片段无效。
DropShadow - Class in javafx.scene.effect
使用指定的颜色，半径和偏移量将给定内容的阴影呈现在内容后面的高级效果。
DropShadow() - Constructor for class javafx.scene.effect. DropShadow
使用默认参数创建一个新的DropShadow实例。
DropShadow(double, double, double, Color) - Constructor for class javafx.scene.effect. DropShadow
以指定的半径，offsetX，offsetY和颜色创建一个新的DropShadow实例。
DropShadow(double, Color) - Constructor for class javafx.scene.effect. DropShadow
创建一个具有指定半径和颜色的DropShadow的新实例。
DropShadow(BlurType, Color, double, double, double, double) - Constructor for class javafx.scene.effect. DropShadow
使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的DropShadow实例。
DropTarget - Class in java.awt.dnd
该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。
DropTarget() - Constructor for class java.awt.dnd. DropTarget
创建一个 DropTarget 。
DropTarget(Component, int, DropTargetListener) - Constructor for class java.awt.dnd. DropTarget
创建一个 DropTarget给出 Component与自己相关联，一个 int表示默认可接受的操作支持，一个 DropTargetListener处理事件处理。
DropTarget(Component, int, DropTargetListener, boolean) - Constructor for class java.awt.dnd. DropTarget
创建一个 DropTarget给出 Component与自己相关联，一个 int表示默认可接受的操作支持，一个 DropTargetListener处理事件处理，以及一个 boolean表示 DropTarget是否正在接受丢弃。
DropTarget(Component, int, DropTargetListener, boolean, FlavorMap) - Constructor for class java.awt.dnd. DropTarget
创建一个新的DropTarget，给定 Component以将自身关联，一个 int表示默认可接受的动作以支持，一个 DropTargetListener处理事件处理，一个 boolean指示 DropTarget是否正在接受丢弃，以及一个 FlavorMap使用（或null为默认值 FlavorMap ）。
DropTarget(Component, DropTargetListener) - Constructor for class java.awt.dnd. DropTarget
创建一个 DropTarget给出 Component与自己相关联，并且 DropTargetListener处理事件处理。
DropTarget.DropTargetAutoScroller - Class in java.awt.dnd
这个受保护的嵌套类实现自动滚动
DropTargetAdapter - Class in java.awt.dnd
用于接收丢弃目标事件的抽象适配器类。
DropTargetAdapter() - Constructor for class java.awt.dnd. DropTargetAdapter
DropTargetAutoScroller(Component, Point) - Constructor for class java.awt.dnd. DropTarget.DropTargetAutoScroller
构建一个DropTargetAutoScroller
DropTargetContext - Class in java.awt.dnd
甲 DropTargetContext每当用拖放操作相关联的逻辑光标用的可见几何一致创建 Component与相关联 DropTarget 。
DropTargetContext.TransferableProxy - Class in java.awt.dnd
TransferableProxy是一个助手内部类，实现 Transferable接口，并作为另一个 Transferable对象的代理，代表特定的拖放操作的数据传输。
DropTargetDragEvent - Class in java.awt.dnd
所述 DropTargetDragEvent被输送到 DropTargetListener经由其dragEnter事件（）和的dragover（）方法。
DropTargetDragEvent(DropTargetContext, Point, int, int) - Constructor for class java.awt.dnd. DropTargetDragEvent
构造一个 DropTargetDragEvent给出的 DropTargetContext此操作中，“拖”的位置 Cursor “在S热点 Component坐标”，用户放置动作，和源drop操作。
DropTargetDropEvent - Class in java.awt.dnd
DropTargetDropEvent是通过 DropTargetListener drop（）方法传递的。
DropTargetDropEvent(DropTargetContext, Point, int, int) - Constructor for class java.awt.dnd. DropTargetDropEvent
构造一个 DropTargetDropEvent给出的 DropTargetContext进行此操作，拖动的位置 Cursor的在热点 Component坐标，当前选择的用户放置动作，和当前的一组源支持的操作“。
DropTargetDropEvent(DropTargetContext, Point, int, int, boolean) - Constructor for class java.awt.dnd. DropTargetDropEvent
构造一个 DropTargetEvent给出了 DropTargetContext的这个操作，拖动 Cursor的热点位置在 Component的坐标，当前选择的用户放置动作，当前由源支持的一组动作，以及一个 boolean指示源是否与目标相同的JVM。
DropTargetEvent - Class in java.awt.dnd
DropTargetEvent是 DropTargetDragEvent和 DropTargetDropEvent的基础类。
DropTargetEvent(DropTargetContext) - Constructor for class java.awt.dnd. DropTargetEvent
使用指定的 DropTargetContext构造一个 DropTargetEvent对象。
DropTargetListener - Interface in java.awt.dnd
DropTargetListener接口是 DropTarget类使用的回调接口，用于提供涉及主题 DropTarget的DnD操作的通知。
dropWhile(DoublePredicate) - Method in interface java.util.stream. DoubleStream
如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
dropWhile(IntPredicate) - Method in interface java.util.stream. IntStream
如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
dropWhile(LongPredicate) - Method in interface java.util.stream. LongStream
如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
dropWhile(Predicate<? super T>) - Method in interface java.util.stream. Stream
如果此流被排序，则返回一个流，该流包含该流的剩余元素，在丢弃与给定谓词匹配的元素的最长前缀之后。
DSA_SHA1 - Static variable in interface javax.xml.crypto.dsig. SignatureMethod
DSAwithSHA1 （DSS）签名方法算法URI。
DSA_TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo. KeyValue
标识DSA KeyValue KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。
DSAGenParameterSpec - Class in java.security.spec
此不可变类指定用于生成DSA参数的参数集，如 FIPS 186-3 Digital Signature Standard (DSS)中所述 。
DSAGenParameterSpec(int, int) - Constructor for class java.security.spec. DSAGenParameterSpec
使用 primePLen和 subprimeQLen创建DSA参数生成的域参数规范。
DSAGenParameterSpec(int, int, int) - Constructor for class java.security.spec. DSAGenParameterSpec
创建用于使用DSA参数生成一个域参数规范 primePLen ， subprimeQLen ，和 seedLen 。
DSAKey - Interface in java.security.interfaces
DSA公钥或私钥的接口。
DSAKeyPairGenerator - Interface in java.security.interfaces
与能够生成DSA密钥对的对象的接口。
DSAParameterSpec - Class in java.security.spec
该类指定与DSA算法一起使用的参数集。
DSAParameterSpec(BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec. DSAParameterSpec
使用指定的参数值创建新的DSAParameterSpec。
DSAParams - Interface in java.security.interfaces
与DSA特定的关键参数集的接口，定义了DSA 密钥族 。
DSAPrivateKey - Interface in java.security.interfaces
DSA私钥的标准接口。
DSAPrivateKeySpec - Class in java.security.spec
此类指定具有相关参数的DSA私钥。
DSAPrivateKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec. DSAPrivateKeySpec
用指定的参数值创建一个新的DSAPrivateKeySpec。
DSAPublicKey - Interface in java.security.interfaces
DSA公钥的接口。
DSAPublicKeySpec - Class in java.security.spec
该类指定具有相关参数的DSA公钥。
DSAPublicKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec. DSAPublicKeySpec
用指定的参数值创建一个新的DSAPublicKeySpec。
Dst - Static variable in class java.awt. AlphaComposite
AlphaComposite对象实现不透明的DST规则，其alpha为1.0f。
DST - Static variable in class java.awt. AlphaComposite
目的地保持不变（Porter-Duff目的地规则）。
DST_ATOP - Static variable in class java.awt. AlphaComposite
位于源头的目的地的一部分在源上合成，并替换目的地（Porter-Duff Destination Atop Source规则）。
DST_IN - Static variable in class java.awt. AlphaComposite
位于源代码内的目的地部分将替换目的地（Porter-Duff Destination In Source规则）。
DST_OFFSET - Static variable in class java.util. Calendar
get字段编号和 set指示以毫秒为单位的夏令时偏移量。
DST_OUT - Static variable in class java.awt. AlphaComposite
位于源代码之外的目的地的一部分将替换目的地（Porter-Duff Destination Held Out By Source规则）。
DST_OVER - Static variable in class java.awt. AlphaComposite
目的地在源上合成，结果将替换目的地（Porter-Duff Destination Over Source规则）。
DstAtop - Static variable in class java.awt. AlphaComposite
AlphaComposite对象实现不透明的DST_ATOP规则，其alpha为1.0f。
DstIn - Static variable in class java.awt. AlphaComposite
AlphaComposite对象实现不透明的DST_IN规则，其alpha为1.0f。
DstOut - Static variable in class java.awt. AlphaComposite
AlphaComposite对象实现不透明的DST_OUT规则，alpha为1.0f。
DstOver - Static variable in class java.awt. AlphaComposite
AlphaComposite对象实现不透明的DST_OVER规则，其alpha为1.0f。
DSYNC - java.nio.file. StandardOpenOption
要求将文件内容的每次更新都与底层存储设备同步写入。
DT - Static variable in class javax.swing.text.html. HTML.Tag
标签<dt>
dtd - Variable in class javax.swing.text.html.parser. Parser
该dtd。
DTD - Class in javax.swing.text.html.parser
SGML DTD的表示。
DTD - Interface in javax.xml.stream.events
这是处理DTD的事件的顶级界面
DTD - Static variable in interface javax.xml.stream. XMLStreamConstants
表示事件是DTD
DTD(String) - Constructor for class javax.swing.text.html.parser. DTD
创建具有指定名称的新DTD。
DTDConstants - Interface in javax.swing.text.html.parser
在DTD中使用的SGML常量。
DTDHandler - Interface in org.xml.sax
接收基本DTD相关事件的通知。
DUMMY - Static variable in class javax.swing.text.html. HTML.Attribute
属性“虚拟”
dump(PrintStream) - Method in class javax.swing.text. AbstractDocument
提供诊断转储。
dump(PrintStream, int) - Method in class javax.swing.text. AbstractDocument.AbstractElement
转储元素层次结构的调试表示。
dumpAllThreads(boolean, boolean) - Method in interface java.lang.management. ThreadMXBean
使用堆栈跟踪和同步信息返回所有实时线程的线程信息。
dumpHeap(String, boolean) - Method in interface com.sun.management. HotSpotDiagnosticMXBean
以与hprof堆转储相同的格式将堆转储到 outputFile文件。
dumpStack() - Static method in class java.lang. Thread
将当前线程的堆栈跟踪打印到标准错误流。
DUPLEX - javafx.print. PrintSides
纸张的垂直边缘用于装订的双面打印，如书中。
DUPLEX - Static variable in class javax.print.attribute.standard. Sides
“双面长边”的别名（见 TWO_SIDED_LONG_EDGE ）。
duplicate() - Method in class java.nio. Buffer
创建一个共享此缓冲区内容的新缓冲区。
duplicate() - Method in class java.nio. ByteBuffer
创建一个新的字节缓冲区，共享此缓冲区的内容。
duplicate() - Method in class java.nio. CharBuffer
创建一个新的char缓冲区，共享此缓冲区的内容。
duplicate() - Method in class java.nio. DoubleBuffer
创建一个新的双缓冲区，共享此缓冲区的内容。
duplicate() - Method in class java.nio. FloatBuffer
创建一个新的浮动缓冲区，共享此缓冲区的内容。
duplicate() - Method in class java.nio. IntBuffer
创建一个共享此缓冲区内容的新int缓冲区。
duplicate() - Method in class java.nio. LongBuffer
创建一个新的长缓冲区，共享此缓冲区的内容。
duplicate() - Method in class java.nio. ShortBuffer
创建一个新的缓冲区，共享此缓冲区的内容。
duplicate(Object) - Method in class org.omg.CORBA.portable. Delegate
返回提供的对象引用的副本。
DUPLICATE_ELEMENT - Static variable in exception org.ietf.jgss. GSSException
请求的重复凭据元素。
DUPLICATE_TOKEN - Static variable in exception org.ietf.jgss. GSSException
令牌是较早的令牌的重复。
DuplicateFormatFlagsException - Exception in java.util
在格式说明符中提供重复标志时抛出未经检查的异常。
DuplicateFormatFlagsException(String) - Constructor for exception java.util. DuplicateFormatFlagsException
使用指定的标志构造此类的实例。
DuplicateName - Exception in org.omg.PortableInterceptor.ORBInitInfoPackage
org / omg / PortableInterceptor / ORBInitInfoPackage / DuplicateName.java。
DuplicateName() - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateName
DuplicateName(String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateName
DuplicateName(String, String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateName
DuplicateNameHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage
org / omg / PortableInterceptor / ORBInitInfoPackage / DuplicateNameHelper.java。
DuplicateNameHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateNameHelper
DuplicateRequestException - Exception in com.sun.jdi.request
抛出以表示重复的事件请求。
DuplicateRequestException() - Constructor for exception com.sun.jdi.request. DuplicateRequestException
DuplicateRequestException(String) - Constructor for exception com.sun.jdi.request. DuplicateRequestException
DUPLOYAN - java.lang. Character.UnicodeScript
Unicode脚本“Duployan”。
DUPLOYAN - Static variable in class java.lang. Character.UnicodeBlock
“Duployan”Unicode字符块的常量。
duration() - Method in class jdk.incubator.http. HttpRequest
返回此请求的持续时间。
Duration - Class in java.time
基于时间的时间量，如'34.5秒'。
Duration - Class in javafx.util
定义持续时间的类。
Duration - Class in javax.xml.datatype
W3C XML Schema 1.0规范中定义的时间跨度的不可变表示。
Duration() - Constructor for class javax.xml.datatype. Duration
默认的无参数构造函数。
Duration(double) - Constructor for class javafx.util. Duration
创建一个新的持续时间，具有潜在的分数毫秒分辨率。
DURATION - Static variable in class javax.xml.datatype. DatatypeConstants
W3C XML Schema数据类型 duration完全限定名称。
DURATION_DAYTIME - Static variable in class javax.xml.datatype. DatatypeConstants
XQuery 1.0和XPath 2.0数据类型的完全限定名称 dayTimeDuration 。
DURATION_YEARMONTH - Static variable in class javax.xml.datatype. DatatypeConstants
XQuery 1.0和XPath 2.0数据类型 yearMonthDuration完全限定名称。
DurationConverter - Class in javafx.css.converter
将大小转换为持续时间
durationProperty() - Method in class javafx.animation. FadeTransition
这个 FadeTransition的持续时间。
durationProperty() - Method in class javafx.animation. FillTransition
这个 FillTransition的持续时间。
durationProperty() - Method in class javafx.animation. PathTransition
这个 Transition的持续时间。
durationProperty() - Method in class javafx.animation. PauseTransition
这个 Transition的持续时间。
durationProperty() - Method in class javafx.animation. RotateTransition
这个 RotateTransition的持续时间。
durationProperty() - Method in class javafx.animation. ScaleTransition
这个 ScaleTransition的持续时间。
durationProperty() - Method in class javafx.animation. StrokeTransition
这个 StrokeTransition的持续时间。
durationProperty() - Method in class javafx.animation. TranslateTransition
这个 TranslateTransition的持续时间。
durationProperty() - Method in class javafx.scene.media. Media
源介质的持续时间（以秒为单位）。
DYNAMIC_SOAP_PROTOCOL - Static variable in interface javax.xml.soap. SOAPConstants
用于创建 MessageFactory实例，创建 SOAPMessages其具体类型基于传递给 createMessage方法的 Content-Type MIME标头。
DynamicImplementation - Class in org.omg.CORBA
已过时。
org.omg.CORBA.DynamicImplementation
DynamicImplementation - Class in org.omg.PortableServer
允许动态处理对象调用。
DynamicImplementation() - Constructor for class org.omg.CORBA. DynamicImplementation
已过时。
DynamicImplementation() - Constructor for class org.omg.PortableServer. DynamicImplementation
dynamicInvoker() - Method in class java.lang.invoke. CallSite
生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
dynamicInvoker() - Method in class java.lang.invoke. ConstantCallSite
返回此呼叫站点的永久目标。
dynamicInvoker() - Method in class java.lang.invoke. MutableCallSite
生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
dynamicInvoker() - Method in class java.lang.invoke. VolatileCallSite
生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
DynamicLinker - Class in jdk.dynalink
RelinkableCallSite对象的链接器。
DynamicLinkerFactory - Class in jdk.dynalink
创建DynamicLinker对象的工厂类。
DynamicLinkerFactory() - Constructor for class jdk.dynalink. DynamicLinkerFactory
创建一个默认配置的动态链接器工厂。
DynamicMBean - Interface in javax.management
定义应该由动态MBean（显示动态管理界面的MBean）实现的方法。
DynamicUtilTreeNode(Object, Object) - Constructor for class javax.swing. JTree.DynamicUtilTreeNode
创建具有指定对象的节点作为其值和指定的子节点。
DynAny - Interface in org.omg.CORBA
已过时。
改用新的DynAny
DynAny - Interface in org.omg.DynamicAny
任何值都可以动态解释（遍历）并通过DynAny对象构造。
DynAnyFactory - Interface in org.omg.DynamicAny
可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。
DynAnyFactoryHelper - Class in org.omg.DynamicAny
可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。
DynAnyFactoryHelper() - Constructor for class org.omg.DynamicAny. DynAnyFactoryHelper
DynAnyFactoryOperations - Interface in org.omg.DynamicAny
可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。
DynAnyHelper - Class in org.omg.DynamicAny
任何值都可以动态解释（遍历）并通过DynAny对象构造。
DynAnyHelper() - Constructor for class org.omg.DynamicAny. DynAnyHelper
DynAnyOperations - Interface in org.omg.DynamicAny
任何值都可以动态解释（遍历）并通过DynAny对象构造。
DynAnySeqHelper - Class in org.omg.DynamicAny
org / omg / DynamicAny / DynAnySeqHelper.java。
DynAnySeqHelper() - Constructor for class org.omg.DynamicAny. DynAnySeqHelper
DynArray - Interface in org.omg.CORBA
已过时。
改用新的DynArray
DynArray - Interface in org.omg.DynamicAny
DynArray对象支持IDL数组的操作。
DynArrayHelper - Class in org.omg.DynamicAny
DynArray对象支持IDL数组的操作。
DynArrayHelper() - Constructor for class org.omg.DynamicAny. DynArrayHelper
DynArrayOperations - Interface in org.omg.DynamicAny
DynArray对象支持IDL数组的操作。
DynEnum - Interface in org.omg.CORBA
已过时。
使用新的DynEnum代替
DynEnum - Interface in org.omg.DynamicAny
DynEnum对象支持对IDL枚举值的操作。
DynEnumHelper - Class in org.omg.DynamicAny
DynEnum对象支持对IDL枚举值的操作。
DynEnumHelper() - Constructor for class org.omg.DynamicAny. DynEnumHelper
DynEnumOperations - Interface in org.omg.DynamicAny
DynEnum对象支持对IDL枚举值的操作。
DynFixed - Interface in org.omg.CORBA
已过时。
改用新的DynFixed
DynFixed - Interface in org.omg.DynamicAny
DynFixed对象支持IDL固定值的操作。
DynFixedHelper - Class in org.omg.DynamicAny
DynFixed对象支持IDL固定值的操作。
DynFixedHelper() - Constructor for class org.omg.DynamicAny. DynFixedHelper
DynFixedOperations - Interface in org.omg.DynamicAny
DynFixed对象支持IDL固定值的操作。
DynSequence - Interface in org.omg.CORBA
已过时。
使用新的DynSequence代替
DynSequence - Interface in org.omg.DynamicAny
DynSequence对象支持IDL序列的操作。
DynSequenceHelper - Class in org.omg.DynamicAny
DynSequence对象支持IDL序列的操作。
DynSequenceHelper() - Constructor for class org.omg.DynamicAny. DynSequenceHelper
DynSequenceOperations - Interface in org.omg.DynamicAny
DynSequence对象支持IDL序列的操作。
DynStruct - Interface in org.omg.CORBA
已过时。
改用新的DynStruct
DynStruct - Interface in org.omg.DynamicAny
DynStruct对象支持IDL结构和异常值的操作。
DynStructHelper - Class in org.omg.DynamicAny
DynStruct对象支持IDL结构和异常值的操作。
DynStructHelper() - Constructor for class org.omg.DynamicAny. DynStructHelper
DynStructOperations - Interface in org.omg.DynamicAny
DynStruct对象支持IDL结构和异常值的操作。
DynUnion - Interface in org.omg.CORBA
已过时。
改用新的DynUnion
DynUnion - Interface in org.omg.DynamicAny
DynUnion对象支持IDL联盟的操纵。
DynUnionHelper - Class in org.omg.DynamicAny
DynUnion对象支持IDL联盟的操纵。
DynUnionHelper() - Constructor for class org.omg.DynamicAny. DynUnionHelper
DynUnionOperations - Interface in org.omg.DynamicAny
DynUnion对象支持IDL联盟的操纵。
DynValue - Interface in org.omg.CORBA
已过时。
改用新的DynValue
DynValue - Interface in org.omg.DynamicAny
DynValue对象支持IDL非盒装值类型的操作。
DynValueBox - Interface in org.omg.DynamicAny
DynValueBox对象支持IDL框值类型的操作。
DynValueBoxOperations - Interface in org.omg.DynamicAny
DynValueBox对象支持IDL框值类型的操作。
DynValueCommon - Interface in org.omg.DynamicAny
DynValueCommon提供由DynValue和DynValueBox接口支持的操作。
DynValueCommonOperations - Interface in org.omg.DynamicAny
DynValueCommon提供由DynValue和DynValueBox接口支持的操作。
DynValueHelper - Class in org.omg.DynamicAny
DynValue对象支持IDL非盒装值类型的操作。
DynValueHelper() - Constructor for class org.omg.DynamicAny. DynValueHelper
DynValueOperations - Interface in org.omg.DynamicAny
DynValue对象支持IDL非盒装值类型的操作。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


E-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

E

E - javafx.scene.input. KeyCode
常数为 E键。
E - Static variable in class java.awt. PageAttributes.MediaType
Engineering E的MediaType实例，34 x 44 in。
E - Static variable in class java.lang. Math
double价值比其他任何一个更接近 e ，自然对数的基础。
E - Static variable in class java.lang. StrictMath
double值比其他任何一个更接近 e ，自然对数的基础。
E - Static variable in class javax.print.attribute.standard. MediaSize.Engineering
指定工程E尺寸，34英寸×44英寸。
E - Static variable in class javax.print.attribute.standard. MediaSizeName
E尺寸。
E_RESIZE - Static variable in class javafx.scene. Cursor
东调整游标类型。
E_RESIZE_CURSOR - Static variable in class java.awt. Cursor
东调整游标类型。
E_RESIZE_CURSOR - Static variable in class java.awt. Frame
已过时。
替换为Cursor.E_RESIZE_CURSOR 。
EARLY_DYNASTIC_CUNEIFORM - Static variable in class java.lang. Character.UnicodeBlock
常数为“早期楔形文字”Unicode字符块。
EASE_BOTH - Static variable in class javafx.animation. Interpolator
内置插件器实例，提供简单的输入/输出行为。
EASE_IN - Static variable in class javafx.animation. Interpolator
内置插件器实例，提供行为方便。
EASE_OUT - Static variable in class javafx.animation. Interpolator
内置interpolator实例，提供轻松的行为。
EAST - Static variable in class java.awt. BorderLayout
东面布局限制（容器右侧）。
EAST - Static variable in class java.awt. GridBagConstraints
将组件放置在显示区域的右侧，垂直居中。
EAST - Static variable in class javax.swing. SpringLayout
指定组件的边界矩形的右边缘。
EAST - Static variable in interface javax.swing. SwingConstants
指南针方向东（右）。
EASTERN_ARABIC - java.awt.font. NumericShaper.Range
阿拉伯语范围与东部阿拉伯语 - 印度数字。
EASTERN_ARABIC - Static variable in class java.awt.font. NumericShaper
标识ARABIC范围和ARABIC_EXTENDED十进制基数。
eastPane - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI
东面板
ECField - Interface in java.security.spec
该接口表示椭圆曲线（EC）有限域。
ECFieldF2m - Class in java.security.spec
这个不可变类定义了椭圆曲线（EC）特征2有限域。
ECFieldF2m(int) - Constructor for class java.security.spec. ECFieldF2m
创建椭圆曲线特征2有限域，其具有正常基础的2 ^ m元素。
ECFieldF2m(int, int[]) - Constructor for class java.security.spec. ECFieldF2m
创建椭圆曲线特征2有限域，其具有多项式基础的2 ^ m元素。
ECFieldF2m(int, BigInteger) - Constructor for class java.security.spec. ECFieldF2m
创建椭圆曲线特征2有限域，其具有多项式基础的2 ^ m元素。
ECFieldFp - Class in java.security.spec
这个不可变类定义了椭圆曲线（EC）素数有限域。
ECFieldFp(BigInteger) - Constructor for class java.security.spec. ECFieldFp
创建具有指定素数的椭圆曲线初始有限域 p 。
ECGenParameterSpec - Class in java.security.spec
这个不可变类指定用于生成椭圆曲线（EC）域参数的参数集。
ECGenParameterSpec(String) - Constructor for class java.security.spec. ECGenParameterSpec
使用标准（或预定义）名称 stdName创建EC参数生成的参数规范，以生成相应的（预计算）椭圆曲线域参数。
echoCharIsSet() - Method in class java.awt. TextField
指示此文本字段是否具有用于回显的字符集。
echoCharIsSet() - Method in class javax.swing. JPasswordField
如果此 JPasswordField具有用于回显的字符集，则返回true。
ECKey - Interface in java.security.interfaces
椭圆曲线（EC）键的界面。
ECParameterSpec - Class in java.security.spec
这个不可变类指定了使用椭圆曲线加密（ECC）的一组域参数。
ECParameterSpec(EllipticCurve, ECPoint, BigInteger, int) - Constructor for class java.security.spec. ECParameterSpec
根据指定的值创建椭圆曲线域参数。
ECPoint - Class in java.security.spec
这个不可变的类表示仿射坐标中的椭圆曲线（EC）上的点。
ECPoint(BigInteger, BigInteger) - Constructor for class java.security.spec. ECPoint
从指定的仿射x坐标 x和仿射y坐标 y创建一个 y 。
ECPrivateKey - Interface in java.security.interfaces
椭圆曲线（EC）私钥的界面。
ECPrivateKeySpec - Class in java.security.spec
这个不可变类指定一个带有关联参数的椭圆曲线私钥。
ECPrivateKeySpec(BigInteger, ECParameterSpec) - Constructor for class java.security.spec. ECPrivateKeySpec
用指定的参数值创建一个新的ECPrivateKeySpec。
ECPublicKey - Interface in java.security.interfaces
椭圆曲线（EC）公钥的界面。
ECPublicKeySpec - Class in java.security.spec
这个不可变类指定了一个带有关联参数的椭圆曲线公钥。
ECPublicKeySpec(ECPoint, ECParameterSpec) - Constructor for class java.security.spec. ECPublicKeySpec
用指定的参数值创建一个新的ECPublicKeySpec。
EDGE_NO_OP - Static variable in class java.awt.image. ConvolveOp
源图像边缘的像素被复制到目的地的相应像素，而不进行修改。
EDGE_SPACING - Static variable in class javax.swing.border. TitledBorder
边界和边缘之间的空间
EDGE_STITCH - Static variable in class javax.print.attribute.standard. Finishings
沿着一个边缘用一个或多个缝钉（线缝）绑定文件。
EDGE_STITCH_BOTTOM - Static variable in class javax.print.attribute.standard. Finishings
用一个或多个订书钉（线缝）沿底边绑定文档。
EDGE_STITCH_LEFT - Static variable in class javax.print.attribute.standard. Finishings
沿着左边缘用一个或多个订书钉（线迹）绑定文档。
EDGE_STITCH_RIGHT - Static variable in class javax.print.attribute.standard. Finishings
沿着右边缘用一个或多个订书针（线迹）绑定文档。
EDGE_STITCH_TOP - Static variable in class javax.print.attribute.standard. Finishings
用一个或多个缝钉（线缝）沿着顶边绑定文档。
EDGE_ZERO_FILL - Static variable in class java.awt.image. ConvolveOp
目标图像边缘的像素设置为零。
edit(int) - Method in class javafx.scene.control. ListView
如果ListView为 editable ，则指示ListView开始编辑给定索引中的项目。
edit(int, TableColumn<S, ?>) - Method in class javafx.scene.control. TableView
导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。
edit(int, TreeTableColumn<S, ?>) - Method in class javafx.scene.control. TreeTableView
导致给定行/列视图索引处的单元格切换到其编辑状态（如果尚未存在），并且假设TableView和列也是可编辑的。
edit(File) - Method in class java.awt. Desktop
启动相关的编辑器应用程序并打开一个文件进行编辑。
edit(TreeItem<T>) - Method in class javafx.scene.control. TreeView
指示TreeView开始编辑给定的TreeItem，如果TreeView是 editable 。
EDIT - java.awt. Desktop.Action
代表“编辑”动作。
editable - Variable in class javax.swing. JTree
树可编辑吗？
EDITABLE - javafx.scene. AccessibleAttribute
如果节点是可编辑的，则返回true，否则返回false。
EDITABLE - Static variable in class javax.accessibility. AccessibleState
表示用户可以更改此对象的内容。
EDITABLE_PROPERTY - Static variable in class javax.swing. JTree
绑定属性名称为 editable 。
editableProperty() - Method in class javafx.scene.control. Cell
表示该单元是否被允许进入编辑状态的属性。
editableProperty() - Method in class javafx.scene.control. ComboBoxBase
指定ComboBox是否允许用户输入。
editableProperty() - Method in class javafx.scene.control. ListView
指定此ListView是否可编辑 - 只有当ListView和ListCells都可编辑时，ListCell才能进入编辑状态。
editableProperty() - Method in class javafx.scene.control. Spinner
可编辑属性用于指定用户输入是否能够输入到Spinner editor中 。
editableProperty() - Method in class javafx.scene.control. TableColumnBase
指定此表列是否允许编辑。
editableProperty() - Method in class javafx.scene.control. TableView
指定此TableView是否可编辑 - 只有TableView，TableColumn（如果适用）和TableCells中的TableCells都可以编辑，TableCell才能进入编辑状态。
editableProperty() - Method in class javafx.scene.control. TextInputControl
指示该TextInputControl是否可以由用户编辑。
editableProperty() - Method in class javafx.scene.control. TreeTableView
指定此TreeTableView是否可编辑 - 只有当TreeTableView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
editableProperty() - Method in class javafx.scene.control. TreeView
指定此TreeView是否可编辑 - 只有当TreeView和TreeCells都可编辑时，TreeCell才能进入编辑状态。
editablePropertyChanged(PropertyChangeEvent) - Method in class javax.swing.plaf.metal. MetalComboBoxUI
已过时。
从Java 2平台v1.4开始。
editAnyEvent() - Static method in class javafx.scene.control. ListView
指示发生一些编辑事件的EventType。
editAnyEvent() - Static method in class javafx.scene.control. TableColumn
任何TableColumn编辑事件的父事件。
editAnyEvent() - Static method in class javafx.scene.control. TreeTableColumn
任何TreeTableColumn编辑事件的父事件。
editAnyEvent() - Static method in class javafx.scene.control. TreeTableView
指示发生一些编辑事件的EventType。
editAnyEvent() - Static method in class javafx.scene.control. TreeView
指示发生一些编辑事件的EventType。
EDITBAR - Static variable in class javax.accessibility. AccessibleRole
指示对象的角色用作计算值的公式。
editCancelEvent() - Static method in class javafx.scene.control. ListView
一个EventType，用于指示在事件触发的ListView中刚刚取消了编辑事件。
editCancelEvent() - Static method in class javafx.scene.control. TableColumn
表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
editCancelEvent() - Static method in class javafx.scene.control. TreeTableColumn
表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
editCancelEvent() - Static method in class javafx.scene.control. TreeTableView
EventType用于指示事件被触发的TreeTableView中刚刚取消了编辑事件。
editCancelEvent() - Static method in class javafx.scene.control. TreeView
EventType用于指示事件被触发的TreeView中刚刚取消了编辑事件。
editCellAt(int, int) - Method in class javax.swing. JTable
如果这些索引处于有效范围，那么以编程方式开始编辑该单元格，即 row和 column ，并且这些索引处的单元格是可编辑的。
editCellAt(int, int, EventObject) - Method in class javax.swing. JTable
如果这些索引处于有效范围，并且这些索引处的单元格是可编辑的， row和 column程序开始编辑单元格。
editCommitEvent() - Static method in class javafx.scene.control. ListView
EventType用于指示已在触发事件的ListView中提交了编辑事件。
editCommitEvent() - Static method in class javafx.scene.control. TableColumn
表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
editCommitEvent() - Static method in class javafx.scene.control. TreeTableColumn
表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
editCommitEvent() - Static method in class javafx.scene.control. TreeTableView
用于指示TreeTableView中的编辑已提交的EventType。
editCommitEvent() - Static method in class javafx.scene.control. TreeView
用于指示TreeView中的编辑已提交的EventType。
EditEvent(ListView<T>, EventType<? extends ListView.EditEvent<T>>, T, int) - Constructor for class javafx.scene.control. ListView.EditEvent
创建一个新的EditEvent实例来表示编辑事件。
EditEvent(TreeTableView<S>, EventType<? extends TreeTableView.EditEvent>, TreeItem<S>, S, S) - Constructor for class javafx.scene.control. TreeTableView.EditEvent
创建一个新的EditEvent实例来表示编辑事件。
EditEvent(TreeView<T>, EventType<? extends TreeView.EditEvent>, TreeItem<T>, T, T) - Constructor for class javafx.scene.control. TreeView.EditEvent
创建一个新的EditEvent实例来表示编辑事件。
editingCanceled(ChangeEvent) - Method in interface javax.swing.event. CellEditorListener
这告诉听众编辑器已经取消了编辑
editingCanceled(ChangeEvent) - Method in class javax.swing. JTable.AccessibleJTable
编辑被取消后调用。
editingCanceled(ChangeEvent) - Method in class javax.swing. JTable
编辑被取消后调用。
editingCanceled(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.CellEditorHandler
在树中取消编辑时发生消息传递。
editingCellProperty() - Method in class javafx.scene.control. TableView
表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
editingCellProperty() - Method in class javafx.scene.control. TreeTableView
表示正在编辑的当前单元格，如果没有编辑单元格，则为空。
editingColumn - Variable in class javax.swing. JTable
标识要编辑的单元格的列。
editingComponent - Variable in class javax.swing.plaf.basic. BasicTreeUI
编辑时，这将是正在进行实际编辑的组件。
editingComponent - Variable in class javax.swing.tree. DefaultTreeCellEditor
组件用于编辑，从 editingContainer获得。
editingContainer - Variable in class javax.swing.tree. DefaultTreeCellEditor
编辑容器，将包含 editorComponent 。
editingIcon - Variable in class javax.swing.tree. DefaultTreeCellEditor
编辑时使用的图标。
editingIndexProperty() - Method in class javafx.scene.control. ListView
用于表示当前在ListView中编辑的项目的索引的属性（如果正在进行编辑），如果没有编辑任何项目，则用于表示-1。
editingItemProperty() - Method in class javafx.scene.control. TreeView
用于表示当前在TreeView中编辑的TreeItem的属性，如果正在进行编辑，或者如果没有编辑任何项目，则为null。
editingPath - Variable in class javax.swing.plaf.basic. BasicTreeUI
正在编辑的路径
editingProperty() - Method in class javafx.scene.control. Cell
表示该单元格当前处于编辑状态的属性。
editingRow - Variable in class javax.swing. JTable
标识正在编辑的单元格行。
editingRow - Variable in class javax.swing.plaf.basic. BasicTreeUI
正在编辑的行。
editingStopped(ChangeEvent) - Method in interface javax.swing.event. CellEditorListener
这告诉听众编辑器已经结束编辑
editingStopped(ChangeEvent) - Method in class javax.swing. JTable.AccessibleJTable
跟踪单元格内容的更改。
editingStopped(ChangeEvent) - Method in class javax.swing. JTable
编辑完成后调用。
editingStopped(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.CellEditorHandler
在树中停止编辑时发生消息传递。
editor - Variable in class javax.swing. JComboBox
此保护字段是实现特定的。
editor - Variable in class javax.swing.plaf.basic. BasicComboBoxEditor
一个实例 JTextField 。
editor - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
@ {code ComboBoxEditor}用于编辑的组件。
EDITOR_PANE - Static variable in class javax.swing.plaf.synth. Region
EditorPane区域。
editorBorderInsets - Variable in class javax.swing.plaf.metal. MetalBorders.TableHeaderBorder
边界插入。
editorBorderInsets - Static variable in class javax.swing.plaf.metal. MetalComboBoxEditor
默认编辑器边框 Insets 。
editorComp - Variable in class javax.swing. JTable
如果编辑， Component正在处理编辑。
editorComponent - Variable in class javax.swing. DefaultCellEditor
正在编辑的Swing组件。
EditorContainer() - Constructor for class javax.swing.tree. DefaultTreeCellEditor.EditorContainer
构造一个 EditorContainer对象。
EditorContainer() - Method in class javax.swing.tree. DefaultTreeCellEditor.EditorContainer
不使用。
EditorDelegate() - Constructor for class javax.swing. DefaultCellEditor.EditorDelegate
editorHasDifferentSize - Variable in class javax.swing.plaf.basic. BasicTreeUI
如果编辑器具有与渲染器不同的大小，则设置为true。
EditorKit - Class in javax.swing.text
将文本组件所需的一组事物建立为某种 类型的文本内容的合理功能的编辑器。
EditorKit() - Constructor for class javax.swing.text. EditorKit
构建一个EditorKit。
editorProperty() - Method in class javafx.scene.control. ComboBox
ComboBox的编辑器。
editorProperty() - Method in class javafx.scene.control. DatePicker
DatePicker的编辑器。
editorProperty() - Method in class javafx.scene.control. Spinner
Spinner控件使用的编辑器。
edits - Variable in class javax.swing.undo. CompoundEdit
由 UndoableEdit收集 UndoableEdit s撤消/重新 CompoundEdit 。
editStartEvent() - Static method in class javafx.scene.control. ListView
EventType用于指示在事件被触发的ListView中启动编辑事件。
editStartEvent() - Static method in class javafx.scene.control. TableColumn
表示用户已经执行了一些交互以启动编辑事件，或者已经调用了 TableView.edit(int, javafx.scene.control.TableColumn)方法。
editStartEvent() - Static method in class javafx.scene.control. TreeTableColumn
表示用户已经执行了一些交互以启动编辑事件，或者 TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)方法已被调用。
editStartEvent() - Static method in class javafx.scene.control. TreeTableView
EventType用于指示在触发事件的TreeTableView中启动了编辑事件。
editStartEvent() - Static method in class javafx.scene.control. TreeView
EventType用于指示在事件触发的TreeView中启动了编辑事件。
editToBeRedone() - Method in class javax.swing.undo. UndoManager
如果调用了 redo则返回下一个要重做的重要编辑。
editToBeUndone() - Method in class javax.swing.undo. UndoManager
如果调用了 undo则返回下一个要撤消的重要编辑。
Effect - Class in javafx.scene.effect
所有效果实现的抽象基类。
Effect() - Constructor for class javafx.scene.effect. Effect
创建一个新的效果。
EFFECT - javafx.application. ConditionalFeature
表示平台上可以使用过滤效果。
EffectConverter - Class in javafx.css.converter
EffectConverter() - Constructor for class javafx.css.converter. EffectConverter
EffectConverter.DropShadowConverter - Class in javafx.css.converter
EffectConverter.InnerShadowConverter - Class in javafx.css.converter
effective_profile() - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations
返回将用于发送请求的配置文件。
effective_target() - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations
返回将调用操作的实际对象。
effectiveNodeOrientationProperty() - Method in class javafx.scene. Node
节点的有效方向解决节点方向的继承，从左到右或从右到左返回。
effectiveNodeOrientationProperty() - Method in class javafx.scene. Scene
场景的有效节点方向解决节点方向的继承，从左到右或从右到左返回。
effectProperty() - Method in class javafx.scene. Node
指定要应用于此 Node的效果。
EFFORT - Static variable in interface java.util.jar. Pack200.Packer
如果此属性设置为单个十进制数字，打包程序将使用指定的压缩压缩数据量。
EGYPTIAN_HIEROGLYPHS - java.lang. Character.UnicodeScript
Unicode脚本“Egyptian_Hieroglyphs”。
EGYPTIAN_HIEROGLYPHS - Static variable in class java.lang. Character.UnicodeBlock
“埃及象形文字”Unicode字符块的常数。
EJECT_TOGGLE - javafx.scene.input. KeyCode
常数为 Eject键。
ELBASAN - java.lang. Character.UnicodeScript
Unicode脚本“Elbasan”。
ELBASAN - Static variable in class java.lang. Character.UnicodeBlock
常数为“Elbasan”Unicode字符块。
element - Variable in class javax.swing.text. DefaultStyledDocument.AttributeUndoableEdit
受影响元素
element() - Method in interface com.sun.javadoc. AnnotationDesc.ElementValuePair
已过时。
返回注释类型元素。
element() - Method in exception java.lang.annotation. AnnotationTypeMismatchException
返回错误类型元素的 方法对象。
element() - Method in class java.util. AbstractQueue
检索，但不删除，这个队列的头。
element() - Method in class java.util. ArrayDeque
检索，但不删除，由这个deque表示的队列的头。
element() - Method in interface java.util.concurrent. BlockingDeque
检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
element() - Method in class java.util.concurrent. ConcurrentLinkedDeque
element() - Method in class java.util.concurrent. LinkedBlockingDeque
检索，但不删除，由这个deque表示的队列的头。
element() - Method in interface java.util. Deque
检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
element() - Method in class java.util. LinkedList
检索但不删除此列表的头（第一个元素）。
element() - Method in interface java.util. Queue
检索，但不删除，这个队列的头。
element(Element) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
向 W3CEndpointReference实例的 wsa:EndpointReference元素添加一个扩展元素。
Element - Class in javax.swing.text.html.parser
使用ELEMENT构造在DTD中描述的元素。
Element - Interface in javax.lang.model.element
表示程序元素，如模块，包，类或方法。
Element - Interface in javax.swing.text
描述文档结构的界面。
Element - Interface in javax.xml.bind
这是一个元素标记界面。
Element - Interface in org.w3c.dom
Element接口表示HTML或XML文档中的元素。
ELEMENT - jdk.dynalink. StandardNamespace
集合对象的元素的标准命名空间。
ELEMENT_NODE - Static variable in interface org.w3c.dom. Node
节点是一个 Element 。
elementAt(int) - Method in class java.util. Vector
返回指定索引处的组件。
elementAt(int) - Method in class javax.swing. DefaultListModel
返回指定索引处的组件。
ElementBuffer(Element) - Constructor for class javax.swing.text. DefaultStyledDocument.ElementBuffer
创建一个新的ElementBuffer。
elementCount - Variable in class java.util. Vector
此 Vector对象中有效组件的数量。
elementCount - Variable in class javax.management.monitor. Monitor
观察对象向量中有效分量的数量。
elementCountToTag(HTMLDocument, int, HTML.Tag) - Method in class javax.swing.text.html. HTMLEditorKit.HTMLTextAction
返回元素数，从最深的叶开始，到达一个表示 tag的元素。
ElementCSSInlineStyle - Interface in org.w3c.dom.css
附加到元素的内联样式信息通过 style属性公开。
elementData - Variable in class java.util. Vector
存储向量的组件的阵列缓冲区。
elementDecl(String, String) - Method in interface org.xml.sax.ext. DeclHandler
报告元素类型声明。
elementDecl(String, String) - Method in class org.xml.sax.ext. DefaultHandler2
ElementEdit(Element, int, Element[], Element[]) - Constructor for class javax.swing.text. AbstractDocument.ElementEdit
构建编辑记录。
ElementFilter - Class in javax.lang.model.util
用于从元素集合中仅选择感兴趣元素的过滤器。
elementHash - Variable in class javax.swing.text.html.parser. DTD
散列表包含元素的名称和相应的元素。
ElementIterator - Class in javax.swing.text
ElementIterator，顾名思义，遍历Element树。
ElementIterator(Document) - Constructor for class javax.swing.text. ElementIterator
创建一个新的ElementIterator。
ElementIterator(Element) - Constructor for class javax.swing.text. ElementIterator
创建一个新的ElementIterator。
ElementKind - Enum in javax.lang.model.element
一个元素的 kind 。
ElementKindVisitor6< R, P> - Class in javax.lang.model.util
程序元素的访问者基于他们的kind默认行为适合RELEASE_6源版本。
ElementKindVisitor6() - Constructor for class javax.lang.model.util. ElementKindVisitor6
已过时。
第6版已经过时了 更新到访问者较新的版本级别。
ElementKindVisitor6(R) - Constructor for class javax.lang.model.util. ElementKindVisitor6
已过时。
第6版已经过时了 更新到访问者较新的版本级别。
ElementKindVisitor7< R, P> - Class in javax.lang.model.util
程序元素的访问者基于其kind的默认行为，适合于RELEASE_7源版本。
ElementKindVisitor7() - Constructor for class javax.lang.model.util. ElementKindVisitor7
具体子类的构造方法 使用null作为默认值。
ElementKindVisitor7(R) - Constructor for class javax.lang.model.util. ElementKindVisitor7
具体子类的构造方法 使用参数作为默认值。
ElementKindVisitor8< R, P> - Class in javax.lang.model.util
程序元素的访问者基于他们的kind ，默认行为适用于RELEASE_8源版本。
ElementKindVisitor8() - Constructor for class javax.lang.model.util. ElementKindVisitor8
具体子类的构造方法 使用默认值null 。
ElementKindVisitor8(R) - Constructor for class javax.lang.model.util. ElementKindVisitor8
具体子类的构造方法 使用参数作为默认值。
ElementKindVisitor9< R, P> - Class in javax.lang.model.util
基于他们的kind程序元素的访问者的默认行为适合RELEASE_9源版本。
ElementKindVisitor9() - Constructor for class javax.lang.model.util. ElementKindVisitor9
具体子类的构造方法 使用null作为默认值。
ElementKindVisitor9(R) - Constructor for class javax.lang.model.util. ElementKindVisitor9
具体子类的构造方法 使用参数作为默认值。
elementName() - Method in exception java.lang.annotation. IncompleteAnnotationException
返回缺少元素的名称。
ElementNameAttribute - Static variable in class javax.swing.text. AbstractDocument
用于指定元素名称的属性的名称。
elements - Variable in class javax.swing.text.html.parser. DTD
元素的向量
elements() - Method in interface com.sun.javadoc. AnnotationTypeDoc
已过时。
返回此注释类型的元素。
elements() - Method in class java.security. PermissionCollection
返回集合中所有Permission对象的枚举。
elements() - Method in class java.security. Permissions
返回此Permissions对象中所有PermissionCollections中所有Permission对象的枚举。
elements() - Method in class java.security. Provider
elements() - Method in class java.util.concurrent. ConcurrentHashMap
返回此表中值的枚举。
elements() - Method in class java.util. Dictionary
返回此字典中值的枚举。
elements() - Method in class java.util. Hashtable
返回此散列表中值的枚举。
elements() - Method in class java.util. Properties
elements() - Method in class java.util. Vector
返回此向量的组件的枚举。
elements() - Method in enum javafx.scene.transform. MatrixType
返回此类型的矩阵中的元素数。
elements() - Method in class javax.swing. DefaultListModel
返回此列表的组件的枚举。
Elements - Interface in javax.lang.model.util
对程序元素进行操作的实用方法。
Elements.Origin - Enum in javax.lang.model.util
元素或其他语言模型项目的 起源 。
elementsAsStream() - Method in class java.security. PermissionCollection
返回集合中所有权限对象的流。
ElementScanner6< R, P> - Class in javax.lang.model.util
具有适用于 RELEASE_6源版本的默认行为的程序元素的扫描访问者。
ElementScanner6() - Constructor for class javax.lang.model.util. ElementScanner6
已过时。
第6版已经过时了 更新到访问者较新的版本级别。
ElementScanner6(R) - Constructor for class javax.lang.model.util. ElementScanner6
已过时。
第6版已经过时了 更新到访问者较新的版本级别。
ElementScanner7< R, P> - Class in javax.lang.model.util
具有适用于 RELEASE_7源版本的默认行为的程序元素的扫描访问者。
ElementScanner7() - Constructor for class javax.lang.model.util. ElementScanner7
具体子类的构造方法 使用null作为默认值。
ElementScanner7(R) - Constructor for class javax.lang.model.util. ElementScanner7
具体子类的构造方法 使用参数作为默认值。
ElementScanner8< R, P> - Class in javax.lang.model.util
具有适用于 RELEASE_8源版本的默认行为的程序元素的扫描访问者。
ElementScanner8() - Constructor for class javax.lang.model.util. ElementScanner8
具体子类的构造方法 使用默认值null 。
ElementScanner8(R) - Constructor for class javax.lang.model.util. ElementScanner8
具体子类的构造方法 使用参数作为默认值。
ElementScanner9< R, P> - Class in javax.lang.model.util
具有默认行为的程序元素的扫描访问者适用于 RELEASE_9源版本。
ElementScanner9() - Constructor for class javax.lang.model.util. ElementScanner9
具体子类的构造方法 使用默认值null 。
ElementScanner9(R) - Constructor for class javax.lang.model.util. ElementScanner9
具体子类的构造方法 使用参数作为默认值。
ElementSpec(AttributeSet, short) - Constructor for class javax.swing.text. DefaultStyledDocument.ElementSpec
当标记不会存储在文档中时，对标记有用的构造方法。
ElementSpec(AttributeSet, short, char[], int, int) - Constructor for class javax.swing.text. DefaultStyledDocument.ElementSpec
构建器，用于外部批量输入内容和标记到文档中。
ElementSpec(AttributeSet, short, int) - Constructor for class javax.swing.text. DefaultStyledDocument.ElementSpec
当数据已被添加时，在文档内部进行解析，但需要len信息的构造方法。
ElementTraversal - Interface in org.w3c.dom
ElementTraversal接口是一组只读属性，允许作者轻松地在文档中的元素之间导航。
ElementType - Enum in java.lang.annotation
这个枚举类型的常量提供了在Java程序中可能出现注释的句法位置的简单分类。
elementValues() - Method in interface com.sun.javadoc. AnnotationDesc
已过时。
返回此注释的元素及其值。
ElementVisitor< R, P> - Interface in javax.lang.model.element
游客的程式元素，以访客设计风格为格局。
elevationProperty() - Method in class javafx.scene.effect. Light.Distant
光的高度。
Ellipse - Class in javafx.scene.shape
Ellipse类创建一个新的椭圆，具有指定的大小和位置（以像素为单位）
Ellipse() - Constructor for class javafx.scene.shape. Ellipse
创建一个空的椭圆实例。
Ellipse(double, double) - Constructor for class javafx.scene.shape. Ellipse
创建给定大小的椭圆实例。
Ellipse(double, double, double, double) - Constructor for class javafx.scene.shape. Ellipse
创建给定位置和大小的椭圆实例。
Ellipse2D - Class in java.awt.geom
Ellipse2D类描述了由框架矩形定义的椭圆。
Ellipse2D() - Constructor for class java.awt.geom. Ellipse2D
这是一个无法直接实例化的抽象类。
Ellipse2D.Double - Class in java.awt.geom
Double类定义了一个 double精度指定的椭圆。
Ellipse2D.Float - Class in java.awt.geom
Float类定义了 float精度中指定的椭圆。
ELLIPSIS - javafx.scene.control. OverrunStyle
如果标签的文字超过标签范围，则可显示的最后三个字符为“...”。
ellipsisStringProperty() - Method in class javafx.scene.control. Labeled
指定在文本被截断时为省略号显示的字符串。
EllipticCurve - Class in java.security.spec
这个不变的类保存代表椭圆曲线所需的必要值。
EllipticCurve(ECField, BigInteger, BigInteger) - Constructor for class java.security.spec. EllipticCurve
创建具有指定的椭圆场 field和系数 a和 b的椭圆曲线。
EllipticCurve(ECField, BigInteger, BigInteger, byte[]) - Constructor for class java.security.spec. EllipticCurve
创建具有指定的椭圆场 field ，系数 a和 b以及用于曲线生成的 seed的椭圆曲线。
EM - javafx.css. SizeUnits
EM - Static variable in class javax.swing.text.html. HTML.Tag
标记<em>
EMBEDDED_BY - Static variable in class javax.accessibility. AccessibleRelation
表示对象嵌入到一个或多个对象中。
EMBEDDED_BY_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
表示两个或多个对象之间的 EMBEDDED_BY关系已更改。
EMBEDS - Static variable in class javax.accessibility. AccessibleRelation
表示对象中嵌入了一个或多个对象。
EMBEDS_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
表示两个或多个对象之间的 EMBEDS关系已更改。
EMOTICONS - Static variable in class java.lang. Character.UnicodeBlock
常量为“表情符号”Unicode字符块。
empty() - Static method in class java.lang.module. Configuration
返回 空配置。
empty() - Static method in class java.lang. ModuleLayer
返回 空层。
empty() - Static method in class java.util. Optional
返回一个空的 Optional实例。
empty() - Static method in class java.util. OptionalDouble
返回一个空的 OptionalDouble实例。
empty() - Static method in class java.util. OptionalInt
返回一个空的 OptionalInt实例。
empty() - Static method in class java.util. OptionalLong
返回一个空的 OptionalLong实例。
empty() - Method in class java.util. Stack
测试此堆栈是否为空。
empty() - Static method in interface java.util.stream. DoubleStream
返回一个空的序列 DoubleStream 。
empty() - Static method in interface java.util.stream. IntStream
返回一个空的顺序 IntStream 。
empty() - Static method in interface java.util.stream. LongStream
返回一个空序列 LongStream 。
empty() - Static method in interface java.util.stream. Stream
返回一个空的顺序 Stream 。
empty() - Method in class javax.swing.text.html.parser. ContentModel
如果内容模型可以匹配一个空的输入流，返回true。
empty(MethodType) - Static method in class java.lang.invoke. MethodHandles
产生一个忽略任何参数的请求类型的方法句柄，不执行任何操作，并根据返回类型返回合适的默认值。
EMPTY - com.sun.source.doctree. AttributeTree.ValueKind
属性值为空。
EMPTY - jdk.jshell. SourceCodeAnalysis.Completeness
一个空的输入。
EMPTY - Static variable in class javafx.geometry. Insets
空插图。
EMPTY - Static variable in class javafx.geometry. Rectangle2D
一个空的 Rectangle2D实例（所有坐标等于零）。
EMPTY - Static variable in class javafx.scene.layout. Background
一个空的背景，使用而不是null。
EMPTY - Static variable in class javafx.scene.layout. Border
空的边框，使用而不是null。
EMPTY - Static variable in class javafx.scene.layout. BorderWidths
一组空的宽度，使得所有值都为0，并且是文字值。
EMPTY - Static variable in class javafx.scene.layout. CornerRadii
一个完全为空的CornerRadii，表示方角。
EMPTY - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于EMPTY
EMPTY - Static variable in class javax.swing.text. SimpleAttributeSet
一个空属性集。
EMPTY_DESCRIPTOR - Static variable in class javax.management. ImmutableDescriptor
一个空描述符。
EMPTY_ENUMERATION - Static variable in class javax.swing.tree. DefaultMutableTreeNode
一个总是空的枚举。
EMPTY_LIST - Static variable in class java.util. Collections
空列表（不可变）。
EMPTY_MAP - Static variable in class java.util. Collections
空地图（immutable）。
EMPTY_SET - Static variable in class java.util. Collections
空集（不可变）。
EMPTY_STATEMENT - com.sun.source.tree. Tree.Kind
用于EmptyStatementTree的实例。
EMPTY_STATEMENT - jdk.nashorn.api.tree. Tree.Kind
用于EmptyStatementTree的实例。
EmptyBorder - Class in javax.swing.border
一个提供一个空的透明边框的类，占用空间但不绘图。
EmptyBorder(int, int, int, int) - Constructor for class javax.swing.border. EmptyBorder
使用指定的插图创建空白边框。
EmptyBorder(Insets) - Constructor for class javax.swing.border. EmptyBorder
使用指定的插图创建空白边框。
EmptyBorderUIResource(int, int, int, int) - Constructor for class javax.swing.plaf. BorderUIResource.EmptyBorderUIResource
构造一个 EmptyBorderUIResource 。
EmptyBorderUIResource(Insets) - Constructor for class javax.swing.plaf. BorderUIResource.EmptyBorderUIResource
构造一个 EmptyBorderUIResource 。
emptyDoubleSpliterator() - Static method in class java.util. Spliterators
创建一个空的 Spliterator.OfDouble
emptyEnumeration() - Static method in class java.util. Collections
返回没有元素的枚举。
emptyIntSpliterator() - Static method in class java.util. Spliterators
创建一个空的 Spliterator.OfInt
emptyIterator() - Static method in class java.util. Collections
返回没有元素的迭代器。
emptyList() - Static method in class java.util. Collections
返回空列表（immutable）。
emptyListIterator() - Static method in class java.util. Collections
返回没有元素的列表迭代器。
emptyLongSpliterator() - Static method in class java.util. Spliterators
创建一个空的 Spliterator.OfLong
emptyMap() - Static method in class java.util. Collections
返回空的地图（不可变）。
emptyNavigableMap() - Static method in class java.util. Collections
返回空导航地图（不可变）。
emptyNavigableSet() - Static method in class java.util. Collections
返回一个空导航集（immutable）。
emptyObservableList() - Static method in class javafx.collections. FXCollections
创建和清空不可修改的可观察列表。
emptyObservableMap() - Static method in class javafx.collections. FXCollections
创建和清空不可修改的可观测地图。
emptyObservableSet() - Static method in class javafx.collections. FXCollections
创建和清空不可修改的可观察集。
emptyProperty() - Method in class javafx.beans.binding. ListBinding
emptyProperty() - Method in class javafx.beans.binding. ListExpression
一个布尔属性，如果列表为空，则为 true 。
emptyProperty() - Method in class javafx.beans.binding. MapBinding
emptyProperty() - Method in class javafx.beans.binding. MapExpression
一个布尔属性是 true ，如果地图是空的。
emptyProperty() - Method in class javafx.beans.binding. SetBinding
emptyProperty() - Method in class javafx.beans.binding. SetExpression
一个布尔值为 true属性，如果该集合是空的。
emptyProperty() - Method in class javafx.beans.property. ListPropertyBase
emptyProperty() - Method in class javafx.beans.property. MapPropertyBase
emptyProperty() - Method in class javafx.beans.property. SetPropertyBase
emptyProperty() - Method in class javafx.scene.control. Cell
用于表示单元格是否具有任何内容的属性。
EmptySelectionModel() - Constructor for class javax.swing. JTree.EmptySelectionModel
emptySet() - Static method in class java.util. Collections
返回一个空集（immutable）。
emptySortedMap() - Static method in class java.util. Collections
返回空的排序映射（immutable）。
emptySortedSet() - Static method in class java.util. Collections
返回一个空的排序集（immutable）。
emptySpliterator() - Static method in class java.util. Spliterators
创建一个空的 Spliterator
EmptyStackException - Exception in java.util
由 Stack类中的方法抛出，表示堆栈为空。
EmptyStackException() - Constructor for exception java.util. EmptyStackException
构造一个新的 EmptyStackException其中 null为错误消息字符串。
EmptyStatementTree - Interface in com.sun.source.tree
一个空（跳过）语句的树节点。
EmptyStatementTree - Interface in jdk.nashorn.api.tree
一个空（跳过）语句的树节点。
emptyTag(Element) - Method in class javax.swing.text.html. HTMLWriter
写出所有空的元素（所有没有相应的结束标签的标签）。
enable() - Method in interface com.sun.jdi.request. EventRequest
与 setEnabled(true)相同。
enable() - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由setEnabled(boolean)替代。
enable() - Method in class java.awt. MenuItem
已过时。
从JDK 1.1版开始，由setEnabled(boolean)替代。
enable() - Static method in class java.lang. Compiler
已过时。
导致编译器恢复运行。
enable() - Method in class javax.swing. JComponent
已过时。
从JDK 1.1版开始，替换为java.awt.Component.setEnabled(boolean) 。
enable(boolean) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由setEnabled(boolean)替代。
enable(boolean) - Method in class java.awt. MenuItem
已过时。
从JDK 1.1版开始，由setEnabled(boolean)替代。
ENABLE - javafx.scene. DepthTest
指定深度测试已启用。
enableActions() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
启用动作。
enableAllObjectNames() - Method in class javax.management.relation. MBeanServerNotificationFilter
X- 20045 X-454545 X-4545 CEEC X-
enableAttribute(String) - Method in class javax.management. AttributeChangeNotificationFilter
启用所有属性更改通知，其属性名称等于要发送给侦听器的指定名称。
enableClientWindowNotification(InputMethod, boolean) - Method in interface java.awt.im.spi. InputMethodContext
启用或禁用当前客户端窗口的位置和指定输入法的状态的通知。
enableCollection() - Method in interface com.sun.jdi. ObjectReference
允许垃圾回收此对象。
enabled - Variable in class javax.swing. AbstractAction
指定是否启用动作; 默认值为true。
enabled - Variable in class javax.xml.ws. WebServiceFeature
指定该功能是启用还是禁用
ENABLED - Static variable in class javax.accessibility. AccessibleState
表示此对象已启用。
ENABLED - Static variable in class javax.swing. DefaultButtonModel
标识位掩码中的“已启用”位，表示该按钮可由输入设备（如鼠标指针）选择。
ENABLED - Static variable in interface javax.swing.plaf.synth. SynthConstants
指示组件的主状态已启用。
enabledProperty() - Method in class javafx.scene.media. AudioEqualizer
启用或禁用 AudioEqualizer 。
enableEvents(long) - Method in class java.awt. Component
启用由指定的事件掩码参数定义的事件传递给此组件。
enableEvents(long) - Method in class java.awt. MenuItem
启用事件传递到此菜单项，以指定事件掩码参数定义的事件
enableInputMethodEvents(boolean) - Method in class javafx.scene. Scene
enableInputMethods(boolean) - Method in class java.awt. Component
启用或禁用此组件的输入法支持。
enableInputMethods(boolean) - Method in class java.awt. TextComponent
启用或禁用此文本组件的输入法支持。
enableObjectName(ObjectName) - Method in class javax.management.relation. MBeanServerNotificationFilter
启用有关给定ObjectName的MBeanServerNotifications。
enableReplaceObject(boolean) - Method in class java.io. ObjectOutputStream
启用流来替代写入流的对象。
enableResizedPosting() - Method in class javax.swing.table. TableColumn
已过时。
从Java 2平台v1.3开始
enableResolveObject(boolean) - Method in class java.io. ObjectInputStream
启用流来替换从流读取的对象。
enableSuddenTermination() - Method in class java.awt. Desktop
使此应用程序突然终止。
enableType(String) - Method in class javax.management. NotificationFilterSupport
启用所有类型的通知以指定的前缀开始发送到侦听器。
ENCLOSED_ALPHANUMERIC_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“封闭的字母数字补充”Unicode字符块的常量。
ENCLOSED_ALPHANUMERICS - Static variable in class java.lang. Character.UnicodeBlock
“封闭字母数字”Unicode字符块的常数。
ENCLOSED_CJK_LETTERS_AND_MONTHS - Static variable in class java.lang. Character.UnicodeBlock
“封闭的CJK字母和月”Unicode字符块的常量。
ENCLOSED_IDEOGRAPHIC_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“封闭式表意补充”Unicode字符块的常量。
ENCLOSING_MARK - Static variable in class java.lang. Character
Unicode规范中的一般类别“Me”。
encode(byte[]) - Method in class java.util. Base64.Encoder
使用Base64编码方案将指定字节数组中的所有字节编码为新分配的字节数组。
encode(byte[], byte[]) - Method in class java.util. Base64.Encoder
使用Base64编码方案对指定字节数组中的所有字节进行编码，将结果字节写入给定的输出字节数组，从偏移0开始。
encode(OutputStream) - Method in interface java.security.cert. Extension
生成扩展的DER编码，并将其写入输出流。
encode(OutputStream) - Method in interface java.security. Certificate
已过时。
将证书编码为可以通过 decode方法解码的格式的输出流。
encode(String) - Static method in class java.net. URLEncoder
已过时。
结果字符串可能会因平台的默认编码而异。 而是使用encode（String，String）方法来指定编码。
encode(String) - Method in class java.nio.charset. Charset
在此字符集中将字符串编码为字节的便捷方法。
encode(String, String) - Static method in class java.net. URLEncoder
使用特定的编码方案将字符串转换为 application/x-www-form-urlencoded格式。
encode(ByteBuffer) - Method in class java.util. Base64.Encoder
使用Base64编码方案将所有剩余字节从指定的字节缓冲区编码到新分配的ByteBuffer中。
encode(CharBuffer) - Method in class java.nio.charset. Charset
在这个字符集中将Unicode字符编码为字节的便捷方法。
encode(CharBuffer) - Method in class java.nio.charset. CharsetEncoder
便捷方法，将单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区中。
encode(CharBuffer, ByteBuffer, boolean) - Method in class java.nio.charset. CharsetEncoder
从给定的输入缓冲区编码尽可能多的字符，将结果写入给定的输出缓冲区。
encode(Any) - Method in interface org.omg.IOP. CodecOperations
基于对这个 Codec有效的编码格式，将给定的任何值转换为字节数组。
encode_value(Any) - Method in interface org.omg.IOP. CodecOperations
基于对该编解码器有效的编码格式，将给定的任何数据转换为字节数组。
ENCODED - javax.jws.soap. SOAPBinding.Use
encodeDataFlavor(DataFlavor) - Static method in class java.awt.datatransfer. SystemFlavorMap
编码 DataFlavor用作本地的 String 。
EncodedKeySpec - Class in java.security.spec
该类表示编码格式的公钥或私钥。
EncodedKeySpec(byte[]) - Constructor for class java.security.spec. EncodedKeySpec
使用给定的编码密钥创建一个新的 EncodedKeySpec 。
EncodedKeySpec(byte[], String) - Constructor for class java.security.spec. EncodedKeySpec
使用给定的编码密钥创建一个新的 EncodedKeySpec 。
encodedParams - Variable in class javax.crypto. SealedObject
密码密码使用的密码参数，以默认格式编码。
encodeJavaMIMEType(String) - Static method in class java.awt.datatransfer. SystemFlavorMap
将MIME类型编码为 String本机。
encodeLoop(CharBuffer, ByteBuffer) - Method in class java.nio.charset. CharsetEncoder
将一个或多个字符编码为一个或多个字节。
Encoder - Class in java.beans
一个 Encoder是一个类，可用于创建根据其公共API对JavaBean集合的状态进行编码的文件或流。
Encoder() - Constructor for class java.beans. Encoder
encodeToString(byte[]) - Method in class java.util. Base64.Encoder
使用Base64编码方案将指定的字节数组编码为字符串。
encoding - Variable in class javax.sound.sampled. AudioFormat
这种格式使用的音频编码技术。
Encoding - Class in org.omg.IOP
org / omg / IOP / Encoding.java。
Encoding() - Constructor for class org.omg.IOP. Encoding
Encoding(short, byte, byte) - Constructor for class org.omg.IOP. Encoding
Encoding(String) - Constructor for class javax.sound.sampled. AudioFormat.Encoding
构造新的编码。
ENCODING - Static variable in class javax.xml.transform. OutputKeys
encoding = string 。
ENCODING_CDR_ENCAPS - Interface in org.omg.IOP
org / omg / IOP / ENCODING_CDR_ENCAPS.java。
encodingSet() - Method in interface javax.xml.stream.events. StartDocument
如果在文档的编码声明中设置了CharacterEncodingScheme，则返回true
ENCRYPT - Static variable in class javax.xml.crypto. KeySelector.Purpose
加密的关键。
ENCRYPT_MODE - Static variable in class javax.crypto. Cipher
常数用于将密码初始化为加密模式。
EncryptedPrivateKeyInfo - Class in javax.crypto
该类实现了PKCS＃8中定义的 EncryptedPrivateKeyInfo类型。
EncryptedPrivateKeyInfo(byte[]) - Constructor for class javax.crypto. EncryptedPrivateKeyInfo
从其ASN.1编码构造（即解析）一个 EncryptedPrivateKeyInfo 。
EncryptedPrivateKeyInfo(String, byte[]) - Constructor for class javax.crypto. EncryptedPrivateKeyInfo
从加密算法名称和加密数据构造一个 EncryptedPrivateKeyInfo 。
EncryptedPrivateKeyInfo(AlgorithmParameters, byte[]) - Constructor for class javax.crypto. EncryptedPrivateKeyInfo
从加密算法参数和加密数据构建一个 EncryptedPrivateKeyInfo 。
EncryptionKey - Class in javax.security.auth.kerberos
此类封装了Kerberos中使用的EncryptionKey。
EncryptionKey(byte[], int) - Constructor for class javax.security.auth.kerberos. EncryptionKey
从给定的字节和键类型构造一个 EncryptionKey 。
ENCTYPE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“enctype”
end() - Method in class java.awt. PrintJob
结束打印作业，并进行任何必要的清理。
end() - Method in class java.nio.channels.spi. AbstractSelector
标记可能无限期阻止的I / O操作的结束。
end() - Method in class java.util.regex. Matcher
返回最后一个字符匹配后的偏移量。
end() - Method in interface java.util.regex. MatchResult
返回最后一个字符匹配后的偏移量。
end() - Method in class java.util.zip. Deflater
关闭压缩器并丢弃任何未处理的输入。
end() - Method in class java.util.zip. Inflater
关闭解压缩程序并丢弃任何未处理的输入。
end() - Method in class javafx.scene.control. TextInputControl
将插入符移动到文本的最后一个字符之后。
end() - Method in class javax.swing.undo. CompoundEdit
将 inProgress设为false。
end() - Method in class javax.swing.undo. StateEdit
获取StateEditable对象的后编辑状态，并结束编辑。
end() - Method in class javax.swing.undo. UndoManager
将这个 UndoManager变成一个正常的 CompoundEdit 。
end(boolean) - Method in class java.nio.channels.spi. AbstractInterruptibleChannel
标记可能无限期阻止的I / O操作的结束。
end(int) - Method in class java.util.regex. Matcher
返回在上次匹配操作期间由给定组捕获的子序列的最后一个字符之后的偏移量。
end(int) - Method in interface java.util.regex. MatchResult
返回给定组在此匹配期间捕获的子序列的最后一个字符之后的偏移量。
end(String) - Method in class java.util.regex. Matcher
返回在上一次匹配操作期间由给定的 named-capturing group捕获的子序列的最后一个字符之后的偏移量。
end(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.BlockAction
end(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.CharacterAction
end(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.FormAction
end(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.HiddenAction
end(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.ParagraphAction
end(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.PreAction
end(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.TagAction
当此动作被注册的标签类型看到结尾标签时被调用。
end(Xid, int) - Method in interface javax.transaction.xa. XAResource
结束代表交易分支执行的工作。
END - javafx.scene.control.skin. TextInputControlSkin.Direction
END - javafx.scene.input. KeyCode
常数为 End键。
END - Static variable in class java.awt. Event
已过时。
结束键，非ASCII操作键。
END_DOCUMENT - Static variable in interface javax.xml.stream. XMLStreamConstants
表示事件是最终文档
END_ELEMENT - com.sun.source.doctree. DocTree.Kind
用于表示HTML元素结尾的EndElementTree的实例。
END_ELEMENT - Static variable in interface javax.xml.stream. XMLStreamConstants
表示一个事件是一个结束元素
END_OF_EXCLUSIVE - Static variable in class javax.sound.midi. ShortMessage
系统专用消息结束（0xF7或247）的状态字节。
END_PUNCTUATION - Static variable in class java.lang. Character
Unicode规范中的一般类别“Pe”。
END_TO_END - Static variable in interface org.w3c.dom.ranges. Range
比较结束的边界点 sourceRange结束对哪个范围的边界点 compareBoundaryPoints被调用。
END_TO_START - Static variable in interface org.w3c.dom.ranges. Range
比较端点 sourceRange开始调用 compareBoundaryPoints的范围的边界点。
end_value() - Method in interface org.omg.CORBA.portable. ValueInputStream
end_value方法读取嵌套自定义值类型的结束标记（在跳过结束标记之前的任何数据之后），并递减值类型嵌套深度。
end_value() - Method in interface org.omg.CORBA.portable. ValueOutputStream
end_value方法结束任何当前打开的块，为嵌套的自定义值类型写入结束标记，并减少值类型嵌套深度。
endAction - Static variable in class javax.swing.text. DefaultEditorKit
Action名称，用于将插入符号移动到文档的末尾。
endCDATA() - Method in class org.xml.sax.ext. DefaultHandler2
endCDATA() - Method in interface org.xml.sax.ext. LexicalHandler
报告CDATA部分的结尾。
endChange() - Method in class javafx.collections. ObservableListBase
结束更改块。
endComposition() - Method in class java.awt.im. InputContext
结束本文中可能正在进行的任何输入组合。
endComposition() - Method in interface java.awt.im.spi. InputMethod
结束本文中可能正在进行的任何输入组合。
endDocument() - Method in interface org.xml.sax. ContentHandler
接收文件结束的通知。
endDocument() - Method in interface org.xml.sax. DocumentHandler
已过时。
接收文件结束的通知。
endDocument() - Method in class org.xml.sax. HandlerBase
已过时。
接收文件结尾的通知。
endDocument() - Method in class org.xml.sax.helpers. DefaultHandler
接收文件结尾的通知。
endDocument() - Method in class org.xml.sax.helpers. ParserAdapter
适配器实现方法; 不要打电话。
endDocument() - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤结束文档事件。
endDocument() - Method in class org.xml.sax.helpers. XMLReaderAdapter
结束文件事件。
EndDocument - Interface in javax.xml.stream.events
用于文档结尾的标记界面
endDraggingFrame(JComponent) - Method in class javax.swing. DefaultDesktopManager
endDraggingFrame(JComponent) - Method in interface javax.swing. DesktopManager
此方法表示拖动会话的结束。
endDTD() - Method in class org.xml.sax.ext. DefaultHandler2
endDTD() - Method in interface org.xml.sax.ext. LexicalHandler
报告DTD声明的结尾。
endElement(Object) - Method in interface javafx.fxml. LoadListener
加载程序完成读取元素后调用。
endElement(String) - Method in interface org.xml.sax. DocumentHandler
已过时。
接收元素结尾的通知。
endElement(String) - Method in class org.xml.sax. HandlerBase
已过时。
接收元素结尾的通知。
endElement(String) - Method in class org.xml.sax.helpers. ParserAdapter
适配器实现方法; 不要打电话。
endElement(String, String, String) - Method in interface org.xml.sax. ContentHandler
接收元素结尾的通知。
endElement(String, String, String) - Method in class org.xml.sax.helpers. DefaultHandler
接收元素结尾的通知。
endElement(String, String, String) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤结束元素事件。
endElement(String, String, String) - Method in class org.xml.sax.helpers. XMLReaderAdapter
修改SAX2终端元素事件。
EndElement - Interface in javax.xml.stream.events
终端元素事件的界面。
EndElementTree - Interface in com.sun.source.doctree
用于HTML元素结尾的树节点。
endEntity(String) - Method in class org.xml.sax.ext. DefaultHandler2
endEntity(String) - Method in interface org.xml.sax.ext. LexicalHandler
报告实体的结束。
endExclusive() - Method in class javax.smartcardio. Card
发布以前使用 beginExclusive建立的独家访问。
endFontTag() - Method in class javax.swing.text.html. MinimalHTMLWriter
这不再使用，而是会写出<span>。
endIndex - Variable in class javax.accessibility. AccessibleAttributeSequence
文本序列的结束索引。
endIndex - Variable in class javax.accessibility. AccessibleTextSequence
文本序列的结束索引。
endInsertEmpty() - Method in class javax.imageio. ImageWriter
完成插入一个以前调用 prepareInsertEmpty开始的新映像。
endJob() - Method in class javafx.print. PrinterJob
如果作业可以成功地假脱机到打印机队列，这将返回true。
endKey - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
endLineAction - Static variable in class javax.swing.text. DefaultEditorKit
Action名称，用于将插入符号移动到行尾。
endMarginProperty() - Method in class javafx.scene.chart. CategoryAxis
最后一个刻度线与轴端之间的余量
EndOfLineStringProperty - Static variable in class javax.swing.text. DefaultEditorKit
当遇到CRLF时读取文档时，添加具有此名称的属性，该值将为“\ r \ n”。
endOfNextWord() - Method in class javafx.scene.control. TextInputControl
将插入符移动到下一个单词的末尾。
endPageProperty() - Method in class javafx.print. PageRange
IntegerProperty表示范围的结束页码。
endParagraphAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号移动到段落末尾的 Action名称。
Endpoint - Class in javax.xml.ws
Web服务端点。
Endpoint() - Constructor for class javax.xml.ws. Endpoint
ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.ws. BindingProvider
标准属性：目标服务端点地址。
EndpointContext - Class in javax.xml.ws
EndpointContext允许应用程序中的多个端点共享任何信息。
EndpointContext() - Constructor for class javax.xml.ws. EndpointContext
endpointName(QName) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
在 wsa:Metadata元素中将 endpointName设为 wsam:ServiceName/@EndpointName 。
EndpointReference - Class in javax.xml.ws
此类表示WS-Addressing EndpointReference，它是对Web服务端点的远程引用。
EndpointReference() - Constructor for class javax.xml.ws. EndpointReference
默认构造函数。
endPrefixMapping(String) - Method in interface org.xml.sax. ContentHandler
结束前缀URI映射的范围。
endPrefixMapping(String) - Method in class org.xml.sax.helpers. DefaultHandler
接收命名空间映射结束的通知。
endPrefixMapping(String) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤结束命名空间前缀映射事件。
endPrefixMapping(String) - Method in class org.xml.sax.helpers. XMLReaderAdapter
修改SAX2结束前缀映射事件。
endReplacePixels() - Method in class javax.imageio. ImageWriter
终止一个调用序列到 replacePixels 。
endRequest() - Method in interface java.sql. Connection
向司机提示，要求，独立工作单位已经完成。
endResizingFrame(JComponent) - Method in class javax.swing. DefaultDesktopManager
endResizingFrame(JComponent) - Method in interface javax.swing. DesktopManager
此方法指示调整大小会话的结束。
endsWith(String) - Method in class java.lang. String
测试此字符串是否以指定的后缀结尾。
endsWith(String) - Method in interface java.nio.file. Path
测试此路径是否以 Path结束，通过转换给定的路径字符串，完全由 endsWith(Path)方法指定的方式 构建 。
endsWith(Path) - Method in interface java.nio.file. Path
测试此路径是否以给定的路径结束。
endsWith(List<Rdn>) - Method in class javax.naming.ldap. LdapName
确定指定的RDN序列是否形成此LDAP名称的后缀。
endsWith(Name) - Method in class javax.naming. CompositeName
确定复合名称是否是此复合名称的后缀。
endsWith(Name) - Method in class javax.naming. CompoundName
确定复合名称是否是此化合物名称的后缀。
endsWith(Name) - Method in class javax.naming.ldap. LdapName
确定此LDAP名称是否以指定的LDAP名称后缀结尾。
endsWith(Name) - Method in interface javax.naming. Name
确定此名称是否以指定的后缀结尾。
endTag(boolean) - Method in class javax.swing.text.html.parser. Parser
处理结束标签
endTag(Element) - Method in class javax.swing.text.html. HTMLWriter
写出元素的结束标签。
ENDTAG - Static variable in class javax.swing.text.html. HTML.Attribute
属性“endtag”
ENDTAG - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于ENDTAG
EndTagType - Static variable in class javax.swing.text. DefaultStyledDocument.ElementSpec
getType的可能值。
endUpdate() - Method in class javax.swing.undo. UndoableEditSupport
死锁警告：调用此方法可能会在所有侦听器中调用 undoableEditHappened 。
endWordAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符移动到单词末尾的操作名称。
endWriteEmpty() - Method in class javax.imageio. ImageWriter
完成了以前致电 prepareWriteEmpty开始的新图像的写作。
endWriteSequence() - Method in class javax.imageio. ImageWriter
完成以 prepareWriteSequence开始的一系列图像的写作。
endXProperty() - Method in class javafx.scene.shape. CubicCurve
定义三次曲线段终点的X坐标。
endXProperty() - Method in class javafx.scene.shape. Line
线段终点的X坐标。
endXProperty() - Method in class javafx.scene.shape. QuadCurve
定义二次曲线段终点的X坐标。
endYProperty() - Method in class javafx.scene.shape. CubicCurve
定义三次曲线段终点的Y坐标。
endYProperty() - Method in class javafx.scene.shape. Line
线段终点的Y坐标。
endYProperty() - Method in class javafx.scene.shape. QuadCurve
定义二次曲线段终点的Y坐标。
ENGINE - Static variable in interface javax.script. ScriptEngine
命名值的保留键为 ScriptEngine实现的名称。
ENGINE_SCOPE - Static variable in interface javax.script. ScriptContext
EngineScope属性在单个 ScriptEngine的生存期内可见，并为每个引擎维护一组属性。
ENGINE_VERSION - Static variable in interface javax.script. ScriptEngine
用于标识 ScriptEngine实现版本的命名值的保留键。
engineAliases() - Method in class java.security. KeyStoreSpi
列出此密钥库的所有别名。
engineBuild(CertPathParameters) - Method in class java.security.cert. CertPathBuilderSpi
尝试使用指定的算法参数集构建认证路径。
engineContainsAlias(String) - Method in class java.security. KeyStoreSpi
检查此密钥库中是否存在给定的别名。
engineCreateSSLEngine() - Method in class javax.net.ssl. SSLContextSpi
使用这个上下文创建一个新的 SSLEngine 。
engineCreateSSLEngine(String, int) - Method in class javax.net.ssl. SSLContextSpi
使用此上下文创建一个 SSLEngine 。
engineDeleteEntry(String) - Method in class java.security. KeyStoreSpi
从此密钥库中删除由给定别名标识的条目。
engineDigest() - Method in class java.security. MessageDigestSpi
通过执行最后的操作（如填充）来完成哈希计算。
engineDigest(byte[], int, int) - Method in class java.security. MessageDigestSpi
通过执行最后的操作（如填充）来完成哈希计算。
engineDoFinal() - Method in class javax.crypto. MacSpi
完成MAC计算并重置MAC进一步使用，维护MAC初始化的秘密密钥。
engineDoFinal(byte[], int, int) - Method in class javax.crypto. CipherSpi
在单一部分操作中加密或解密数据，或完成多部分操作。
engineDoFinal(byte[], int, int, byte[], int) - Method in class javax.crypto. CipherSpi
在单一部分操作中加密或解密数据，或完成多部分操作。
engineDoFinal(ByteBuffer, ByteBuffer) - Method in class javax.crypto. CipherSpi
在单一部分操作中加密或解密数据，或完成多部分操作。
engineDoPhase(Key, boolean) - Method in class javax.crypto. KeyAgreementSpi
执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
engineEntryInstanceOf(String, Class<? extends KeyStore.Entry>) - Method in class java.security. KeyStoreSpi
确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
engineGenerateCertificate(InputStream) - Method in class java.security.cert. CertificateFactorySpi
生成证书对象并使用从输入流 inStream读取的数据进行初始化。
engineGenerateCertificates(InputStream) - Method in class java.security.cert. CertificateFactorySpi
返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
engineGenerateCertPath(InputStream) - Method in class java.security.cert. CertificateFactorySpi
生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
engineGenerateCertPath(InputStream, String) - Method in class java.security.cert. CertificateFactorySpi
生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
engineGenerateCertPath(List<? extends Certificate>) - Method in class java.security.cert. CertificateFactorySpi
生成一个 CertPath对象，并使用 List的 Certificate初始化。
engineGenerateCRL(InputStream) - Method in class java.security.cert. CertificateFactorySpi
生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
engineGenerateCRLs(InputStream) - Method in class java.security.cert. CertificateFactorySpi
返回从给定的输入流 inStream读取的CRL的（可能为空的）集合视图。
engineGenerateKey() - Method in class javax.crypto. KeyGeneratorSpi
生成一个秘密密钥。
engineGenerateParameters() - Method in class java.security. AlgorithmParameterGeneratorSpi
生成参数。
engineGeneratePrivate(KeySpec) - Method in class java.security. KeyFactorySpi
从提供的密钥规范（密钥材料）生成私钥对象。
engineGeneratePublic(KeySpec) - Method in class java.security. KeyFactorySpi
从提供的密钥规范（密钥材料）生成公钥对象。
engineGenerateSecret() - Method in class javax.crypto. KeyAgreementSpi
生成共享密钥并将其返回到新的缓冲区。
engineGenerateSecret(byte[], int) - Method in class javax.crypto. KeyAgreementSpi
生成共享密钥，并将其放入缓冲区 sharedSecret ，从 offset开始。
engineGenerateSecret(String) - Method in class javax.crypto. KeyAgreementSpi
创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。
engineGenerateSecret(KeySpec) - Method in class javax.crypto. SecretKeyFactorySpi
从提供的密钥规范（密钥材料）生成一个 SecretKey对象。
engineGenerateSeed(int) - Method in class java.security. SecureRandomSpi
返回给定的种子字节数。
engineGenExemptionBlob() - Method in class javax.crypto. ExemptionMechanismSpi
生成豁免机制密钥blob。
engineGenExemptionBlob(byte[], int) - Method in class javax.crypto. ExemptionMechanismSpi
生成豁免机制键blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
engineGetAppConfigurationEntry(String) - Method in class javax.security.auth.login. ConfigurationSpi
检索指定的 name的AppConfigurationEntries。
engineGetBlockSize() - Method in class javax.crypto. CipherSpi
返回块大小（以字节为单位）。
engineGetCertificate(String) - Method in class java.security. KeyStoreSpi
返回与给定别名相关联的证书。
engineGetCertificateAlias(Certificate) - Method in class java.security. KeyStoreSpi
返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。
engineGetCertificateChain(String) - Method in class java.security. KeyStoreSpi
返回与给定别名关联的证书链。
engineGetCertificates(CertSelector) - Method in class java.security.cert. CertStoreSpi
返回匹配指定选择器的 Collection的 Certificate 。
engineGetCertPathEncodings() - Method in class java.security.cert. CertificateFactorySpi
返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。
engineGetClientSessionContext() - Method in class javax.net.ssl. SSLContextSpi
返回此上下文的客户端 SSLSessionContext对象。
engineGetCreationDate(String) - Method in class java.security. KeyStoreSpi
返回由给定别名标识的条目的创建日期。
engineGetCRLs(CRLSelector) - Method in class java.security.cert. CertStoreSpi
返回匹配指定选择器的 Collection的 CRL 。
engineGetDefaultSSLParameters() - Method in class javax.net.ssl. SSLContextSpi
返回指示此SSL上下文默认设置的SSLParameters的副本。
engineGetDigestLength() - Method in class java.security. MessageDigestSpi
以字节为单位返回摘要长度。
engineGetEncoded() - Method in class java.security. AlgorithmParametersSpi
返回其主要编码格式的参数。
engineGetEncoded(String) - Method in class java.security. AlgorithmParametersSpi
返回以指定格式编码的参数。
engineGetEntry(String, KeyStore.ProtectionParameter) - Method in class java.security. KeyStoreSpi
使用指定的保护参数获取指定别名的 KeyStore.Entry 。
engineGetIV() - Method in class javax.crypto. CipherSpi
返回新缓冲区中的初始化向量（IV）。
engineGetKey(String, char[]) - Method in class java.security. KeyStoreSpi
返回与给定别名相关联的密钥，使用给定的密码恢复它。
engineGetKeyManagers() - Method in class javax.net.ssl. KeyManagerFactorySpi
返回每种类型的密钥材料的一个密钥管理器。
engineGetKeySize(Key) - Method in class javax.crypto. CipherSpi
以位为单位返回给定键对象的键大小。
engineGetKeySpec(Key, Class<T>) - Method in class java.security. KeyFactorySpi
返回给定键对象的规范（关键材料）。
engineGetKeySpec(SecretKey, Class<?>) - Method in class javax.crypto. SecretKeyFactorySpi
以请求的格式返回给定键对象的规范（关键材料）。
engineGetMacLength() - Method in class javax.crypto. MacSpi
以字节为单位返回MAC的长度。
engineGetOutputSize(int) - Method in class javax.crypto. CipherSpi
给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 update或 doFinal操作的结果的字节长度。
engineGetOutputSize(int) - Method in class javax.crypto. ExemptionMechanismSpi
给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 engineGenExemptionBlob操作结果的字节长度。
engineGetParameter(String) - Method in class java.security. SignatureSpi
已过时。
engineGetParameters() - Method in class java.security. SecureRandomSpi
返回此SecureRandom实例的有效SecureRandomParameters 。
engineGetParameters() - Method in class java.security. SignatureSpi
提供者覆盖此方法以返回与此签名引擎一起使用的参数，如果此签名引擎不使用任何参数，则返回null。
engineGetParameters() - Method in class javax.crypto. CipherSpi
返回与此密码一起使用的参数。
engineGetParameterSpec(Class<T>) - Method in class java.security. AlgorithmParametersSpi
返回此参数对象的（透明）规范。
engineGetPermissions(CodeSource) - Method in class java.security. PolicySpi
返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。
engineGetPermissions(ProtectionDomain) - Method in class java.security. PolicySpi
返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。
engineGetRevocationChecker() - Method in class java.security.cert. CertPathBuilderSpi
返回此实现用于检查证书的吊销状态的 CertPathChecker 。
engineGetRevocationChecker() - Method in class java.security.cert. CertPathValidatorSpi
返回此实现用于检查证书的吊销状态的 CertPathChecker 。
engineGetServerSessionContext() - Method in class javax.net.ssl. SSLContextSpi
返回此上下文的服务器 SSLSessionContext对象。
engineGetServerSocketFactory() - Method in class javax.net.ssl. SSLContextSpi
为此上下文返回一个 ServerSocketFactory对象。
engineGetSocketFactory() - Method in class javax.net.ssl. SSLContextSpi
为此上下文返回一个 SocketFactory对象。
engineGetSupportedSSLParameters() - Method in class javax.net.ssl. SSLContextSpi
返回指示此SSL上下文支持的最大设置的SSLParameters的副本。
engineGetTrustManagers() - Method in class javax.net.ssl. TrustManagerFactorySpi
为每种类型的信任资料返回一位信托管理员。
engineImplies(ProtectionDomain, Permission) - Method in class java.security. PolicySpi
检查策略是否授予了ProtectionDomain的权限。
engineInit(byte[]) - Method in class java.security. AlgorithmParametersSpi
导入指定的参数，并根据参数的主要解码格式进行解码。
engineInit(byte[], String) - Method in class java.security. AlgorithmParametersSpi
从 params导入参数，并根据指定的解码格式进行解码。
engineInit(int, Key, AlgorithmParameters, SecureRandom) - Method in class javax.crypto. CipherSpi
使用密钥，一组算法参数和随机源初始化此密码。
engineInit(int, Key, SecureRandom) - Method in class javax.crypto. CipherSpi
用密钥和随机源初始化此密码。
engineInit(int, Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto. CipherSpi
使用密钥，一组算法参数和随机源初始化此密码。
engineInit(int, SecureRandom) - Method in class java.security. AlgorithmParameterGeneratorSpi
初始化此参数生成器以获得一定的大小和随机源。
engineInit(int, SecureRandom) - Method in class javax.crypto. KeyGeneratorSpi
使用给定的随机源初始化该密钥生成器以进行某些密钥化。
engineInit(Key) - Method in class javax.crypto. ExemptionMechanismSpi
使用密钥初始化此豁免机制。
engineInit(Key, AlgorithmParameters) - Method in class javax.crypto. ExemptionMechanismSpi
使用密钥和一组算法参数初始化此豁免机制。
engineInit(Key, SecureRandom) - Method in class javax.crypto. KeyAgreementSpi
用给定的密钥和随机源初始化这个密钥协商。
engineInit(Key, AlgorithmParameterSpec) - Method in class javax.crypto. ExemptionMechanismSpi
使用密钥和一组算法参数初始化此豁免机制。
engineInit(Key, AlgorithmParameterSpec) - Method in class javax.crypto. MacSpi
用给定（秘密）密钥和算法参数初始化MAC。
engineInit(Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto. KeyAgreementSpi
使用给定的密钥，算法参数集合和随机源初始化此密钥协议。
engineInit(KeyStore) - Method in class javax.net.ssl. TrustManagerFactorySpi
使用证书颁发机构和相关信托资料来源初始化该工厂。
engineInit(KeyStore, char[]) - Method in class javax.net.ssl. KeyManagerFactorySpi
使用关键材料来源初始化该工厂。
engineInit(SecureRandom) - Method in class javax.crypto. KeyGeneratorSpi
初始化密钥生成器。
engineInit(AlgorithmParameterSpec) - Method in class java.security. AlgorithmParametersSpi
使用 paramSpec指定的参数初始化此参数对象。
engineInit(AlgorithmParameterSpec, SecureRandom) - Method in class java.security. AlgorithmParameterGeneratorSpi
使用一组特定于算法的参数生成值初始化此参数生成器。
engineInit(AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto. KeyGeneratorSpi
使用指定的参数集和用户提供的随机源初始化密钥生成器。
engineInit(KeyManager[], TrustManager[], SecureRandom) - Method in class javax.net.ssl. SSLContextSpi
初始化此上下文。
engineInit(ManagerFactoryParameters) - Method in class javax.net.ssl. KeyManagerFactorySpi
使用关键材料来源初始化该工厂。
engineInit(ManagerFactoryParameters) - Method in class javax.net.ssl. TrustManagerFactorySpi
使用提供商特定的密钥材料来源初始化该工厂。
engineInitSign(PrivateKey) - Method in class java.security. SignatureSpi
使用指定的私钥初始化此签名对象进行签名操作。
engineInitSign(PrivateKey, SecureRandom) - Method in class java.security. SignatureSpi
使用指定的私钥和签名操作的随机源初始化此签名对象。
engineInitVerify(PublicKey) - Method in class java.security. SignatureSpi
使用指定的公钥初始化此签名对象进行验证操作。
engineIsCertificateEntry(String) - Method in class java.security. KeyStoreSpi
如果由给定别名标识的条目是通过调用 setCertificateEntry创建的，或通过调用 setEntry与 TrustedCertificateEntry创建的条目，则返回true。
engineIsKeyEntry(String) - Method in class java.security. KeyStoreSpi
如果由给定别名标识的条目是通过调用 setKeyEntry创建的，或通过调用 setEntry与 PrivateKeyEntry或 SecretKeyEntry创建的条目，则返回true。
engineLoad(InputStream, char[]) - Method in class java.security. KeyStoreSpi
从给定的输入流加载密钥库。
engineLoad(KeyStore.LoadStoreParameter) - Method in class java.security. KeyStoreSpi
使用给定的 KeyStore.LoadStoreParameter加载密钥库。
engineNextBytes(byte[]) - Method in class java.security. SecureRandomSpi
生成用户指定的随机字节数。
engineNextBytes(byte[], SecureRandomParameters) - Method in class java.security. SecureRandomSpi
使用附加参数生成用户指定的随机字节数。
engineProbe(InputStream) - Method in class java.security. KeyStoreSpi
探测指定的输入流以确定它是否包含此实现支持的密钥库。
engineRefresh() - Method in class java.security. PolicySpi
刷新/重新加载策略配置。
engineRefresh() - Method in class javax.security.auth.login. ConfigurationSpi
刷新并重新加载配置。
engineReseed(SecureRandomParameters) - Method in class java.security. SecureRandomSpi
使用附加参数从熵源读取熵输入来重新获得该随机对象。
engineReset() - Method in class java.security. MessageDigestSpi
重置摘要以供进一步使用。
engineReset() - Method in class javax.crypto. MacSpi
重置MAC进一步使用，维护MAC初始化的秘密密钥。
engineScope - Variable in class javax.script. SimpleScriptContext
这是引擎范围绑定。
engineSetCertificateEntry(String, Certificate) - Method in class java.security. KeyStoreSpi
将给定的证书分配给给定的别名。
engineSetEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - Method in class java.security. KeyStoreSpi
在指定的别名下保存一个 KeyStore.Entry 。
engineSetKeyEntry(String, byte[], Certificate[]) - Method in class java.security. KeyStoreSpi
将给定的密钥（已经被保护）分配给给定的别名。
engineSetKeyEntry(String, Key, char[], Certificate[]) - Method in class java.security. KeyStoreSpi
将给定的密钥分配给给定的别名，并使用给定的密码进行保护。
engineSetMode(String) - Method in class javax.crypto. CipherSpi
设置此密码的模式。
engineSetPadding(String) - Method in class javax.crypto. CipherSpi
设置这个密码的填充机制。
engineSetParameter(String, Object) - Method in class java.security. SignatureSpi
已过时。
替换为engineSetParameter 。
engineSetParameter(AlgorithmParameterSpec) - Method in class java.security. SignatureSpi
提供者将覆盖此方法以使用指定的参数集来初始化此签名引擎。
engineSetSeed(byte[]) - Method in class java.security. SecureRandomSpi
用给定的种子重新设定这个随机对象。
engineSign() - Method in class java.security. SignatureSpi
返回到目前为止更新的所有数据的签名字节。
engineSign(byte[], int, int) - Method in class java.security. SignatureSpi
完成此签名操作，并将生成的签名字节存储在提供的缓冲区 outbuf ，从 offset开始。
engineSize() - Method in class java.security. KeyStoreSpi
检索此密钥库中的条目数。
engineStore(OutputStream, char[]) - Method in class java.security. KeyStoreSpi
将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
engineStore(KeyStore.LoadStoreParameter) - Method in class java.security. KeyStoreSpi
使用给定的 KeyStore.LoadStoreParmeter存储此密钥库。
engineTerminals() - Method in class javax.smartcardio. TerminalFactorySpi
返回此工厂创建的CardTerminals。
EngineTerminationException(String) - Constructor for exception jdk.jshell.spi. ExecutionControl.EngineTerminationException
engineToString() - Method in class java.security. AlgorithmParametersSpi
返回描述参数的格式化字符串。
engineTranslateKey(Key) - Method in class java.security. KeyFactorySpi
将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。
engineTranslateKey(SecretKey) - Method in class javax.crypto. SecretKeyFactorySpi
将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。
engineUnwrap(byte[], String, int) - Method in class javax.crypto. CipherSpi
打开以前包装的钥匙。
engineUpdate(byte) - Method in class java.security. MessageDigestSpi
使用指定的字节更新摘要。
engineUpdate(byte) - Method in class java.security. SignatureSpi
使用指定的字节更新要签名或验证的数据。
engineUpdate(byte) - Method in class javax.crypto. MacSpi
处理给定的字节。
engineUpdate(byte[], int, int) - Method in class java.security. MessageDigestSpi
使用指定的字节数组从指定的偏移量开始更新摘要。
engineUpdate(byte[], int, int) - Method in class java.security. SignatureSpi
使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
engineUpdate(byte[], int, int) - Method in class javax.crypto. CipherSpi
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
engineUpdate(byte[], int, int) - Method in class javax.crypto. MacSpi
在 input处理第 len个字节，从 offset开始。
engineUpdate(byte[], int, int, byte[], int) - Method in class javax.crypto. CipherSpi
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
engineUpdate(ByteBuffer) - Method in class java.security. MessageDigestSpi
使用指定的ByteBuffer更新摘要。
engineUpdate(ByteBuffer) - Method in class java.security. SignatureSpi
使用指定的ByteBuffer更新要签名或验证的数据。
engineUpdate(ByteBuffer) - Method in class javax.crypto. MacSpi
处理 input.remaining()字节的ByteBuffer input ，从 input.position()开始。
engineUpdate(ByteBuffer, ByteBuffer) - Method in class javax.crypto. CipherSpi
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
engineUpdateAAD(byte[], int, int) - Method in class javax.crypto. CipherSpi
使用所提供的缓冲区的子集，继续进行附加认证数据（AAD）的多部分更新。
engineUpdateAAD(ByteBuffer) - Method in class javax.crypto. CipherSpi
继续进行附加认证数据（AAD）的多部分更新。
engineValidate(CertPath, CertPathParameters) - Method in class java.security.cert. CertPathValidatorSpi
使用指定的算法参数集验证指定的认证路径。
engineVerify(byte[]) - Method in class java.security. SignatureSpi
验证传入签名。
engineVerify(byte[], int, int) - Method in class java.security. SignatureSpi
以指定的偏移量开始，以指定的字节数组验证传入签名。
engineWrap(Key) - Method in class javax.crypto. CipherSpi
包裹钥匙
ENGLISH - Static variable in class java.util. Locale
有用的语言常数
ENHANCED_FOR_LOOP - com.sun.source.tree. Tree.Kind
用于EnhancedForLoopTree的实例。
EnhancedForLoopTree - Interface in com.sun.source.tree
一个树状节点，用于“增强”的 for循环语句。
enqueue() - Method in class java.lang.ref. Reference
清除此引用对象并将其添加到与其注册的队列（如果有）。
enqueueKeyEvents(long, Component) - Method in class java.awt. DefaultKeyboardFocusManager
延迟调度KeyEvents直到指定的Component成为焦点所有者。
enqueueKeyEvents(long, Component) - Method in class java.awt. KeyboardFocusManager
由AWT调用，通知KeyboardFocusManager它应该延迟调度KeyEvents，直到指定的Component成为焦点所有者。
enquoteIdentifier(String, boolean) - Method in interface java.sql. Statement
返回一个SQL标识符。
enquoteLiteral(String) - Method in interface java.sql. Statement
返回一个 String用单引号括起来。
enquoteNCharLiteral(String) - Method in interface java.sql. Statement
返回一个 String代表一个用单引号括起来并以大写字母N前缀的国家字符集文字。
ensureCapacity(int) - Method in class java.lang. StringBuffer
ensureCapacity(int) - Method in class java.util. ArrayList
如果需要，增加此 ArrayList实例的容量，以确保它至少能够容纳最小容量参数指定的元素数量。
ensureCapacity(int) - Method in class java.util. Vector
如果需要，增加此向量的容量，以确保它可以至少保存最小容量参数指定的组件数。
ensureCapacity(int) - Method in interface javafx.collections. ObservableArray
如果当前容量小于 capacity ，则增加该阵列的容量，如果已经超过了 capacity则 capacity 。
ensureCapacity(int) - Method in class javax.swing. DefaultListModel
如有必要，增加此列表的容量，以确保它至少能够容纳最小容量参数指定的组件数。
ensureFileIsVisible(File) - Method in class javax.swing. JFileChooser
确保指定的文件是可见的，而不是隐藏。
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
确保有问题的文件是可见的。
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf. FileChooserUI
确保有问题的文件是可见的。
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.metal. MetalFileChooserUI
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.multi. MultiFileChooserUI
在此对象处理的每个UI上调用 ensureFileIsVisible方法。
ensureIndexIsVisible(int) - Method in class javax.swing. JList
在封闭的视口中滚动列表，使指定的单元格完全可见。
ensureRowsAreVisible(int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI
确保由 beginRow至 endRow标识的行是可见的。
enter() - Method in interface java.awt. SecondaryLoop
阻止当前线程的执行，并在事件分派线程上输入新的辅助事件循环。
ENTER - com.sun.source.util. TaskEvent.Kind
关于进入元素的事件。
ENTER - javafx.scene.input. KeyCode
常数为 Enter键。
ENTER - Static variable in class java.awt.dnd. DragSourceContext
由updateCurrentCursor（）使用的一个 int ，表示 Cursor已经输入了一个 DropTarget 。
ENTER - Static variable in class java.awt. Event
已过时。
Enter键。
ENTERED - Static variable in class javax.swing.event. HyperlinkEvent.EventType
输入类型。
entering(String, String) - Method in class java.util.logging. Logger
记录方法条目。
entering(String, String, Object) - Method in class java.util.logging. Logger
使用一个参数记录方法条目。
entering(String, String, Object[]) - Method in class java.util.logging. Logger
使用参数数组记录方法条目。
enterNestedEventLoop(Object) - Static method in class javafx.application. Platform
输入嵌套事件循环并阻塞，直到相应的exitNestedEventLoop调用被创建为止。
ENTITIES - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于ENTITIES
Entity - Class in javax.swing.text.html.parser
使用ENTITY构造在DTD中描述实体。
Entity - Interface in org.w3c.dom
此接口表示XML文档中已解析或未解析的实体。
Entity(String, int, char[]) - Constructor for class javax.swing.text.html.parser. Entity
创建一个实体。
ENTITY - com.sun.source.doctree. DocTree.Kind
用于表示HTML实体的EntityTree的实例。
ENTITY - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于ENTITY
ENTITY_DECLARATION - Static variable in interface javax.xml.stream. XMLStreamConstants
表示实体声明
ENTITY_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 Entity 。
ENTITY_REFERENCE - Static variable in interface javax.xml.stream. XMLStreamConstants
表示事件是实体引用
ENTITY_REFERENCE_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 EntityReference 。
EntityDeclaration - Interface in javax.xml.stream.events
用于处理实体声明的接口此接口用于记录和报告未分类的实体声明。
entityHash - Variable in class javax.swing.text.html.parser. DTD
哈希表包含一个 Object和相应的 Entity
EntityReference - Interface in javax.xml.stream.events
用于处理实体事件的界面。
EntityReference - Interface in org.w3c.dom
EntityReference节点可用于表示树中的实体引用。
EntityResolver - Interface in org.xml.sax
解决实体的基本界面。
EntityResolver2 - Interface in org.xml.sax.ext
用于将外部实体引用映射到输入源的扩展接口，或提供缺少的外部子集。
EntityTree - Interface in com.sun.source.doctree
HTML实体的树节点。
entries() - Method in interface java.security.acl. Acl
已过时。
返回此ACL中条目的枚举。
entries() - Method in class java.util.jar. JarFile
返回枚举jar文件条目。
entries() - Method in class java.util.zip. ZipFile
返回ZIP文件条目的枚举。
entry(K, V) - Static method in interface java.util. Map
返回包含给定键和值的不可变的Map.Entry 。
Entry() - Constructor for class javax.swing. RowFilter.Entry
创建一个 Entry 。
ENTRY_CREATE - Static variable in class java.nio.file. StandardWatchEventKinds
创建目录条目。
ENTRY_DELETE - Static variable in class java.nio.file. StandardWatchEventKinds
目录条目已删除。
ENTRY_MODIFY - Static variable in class java.nio.file. StandardWatchEventKinds
目录条目修改。
entryCount() - Method in interface com.sun.jdi. ObjectReference
返回此对象的显示器由当前拥有的线程输入的次数。
entryInstanceOf(String, Class<? extends KeyStore.Entry>) - Method in class java.security. KeyStore
确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
entrySet() - Method in class com.sun.net.httpserver. Headers
entrySet() - Method in class java.awt. RenderingHints
返回此 RenderingHints包含的映射的 Set视图。
entrySet() - Method in class java.security. Provider
返回此提供程序中包含的属性条目的不可修改的Set视图。
entrySet() - Method in class java.util. AbstractMap
entrySet() - Method in class java.util.concurrent. ConcurrentHashMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util.concurrent. ConcurrentSkipListMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util. EnumMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util. HashMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util. Hashtable
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util. IdentityHashMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util.jar. Attributes
返回此Map中包含的属性名称 - 值映射的集合视图。
entrySet() - Method in class java.util. LinkedHashMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in interface java.util. Map
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util. Properties
entrySet() - Method in interface java.util. SortedMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util. TreeMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class java.util. WeakHashMap
返回此地图中包含的映射的Set视图。
entrySet() - Method in class javafx.beans.binding. MapExpression
entrySet() - Method in class javax.management.openmbean. TabularDataSupport
返回此 TabularDataSupport实例中包含的行映射索引的集合视图。
entrySet() - Method in class javax.script. SimpleBindings
返回此地图中包含的映射的Set视图。
entrySet() - Method in class jdk.incubator.http. MultiMapResult
entrySet() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
Enum< E extends Enum< E>> - Class in java.lang
这是所有Java语言枚举类型的公共基类。
Enum(String, int) - Constructor for class java.lang. Enum
唯一的构造函数。
ENUM - com.sun.source.tree. Tree.Kind
用于表示枚举的ClassTree的实例。
ENUM - javax.lang.model.element. ElementKind
枚举类型。
ENUM_CONSTANT - javax.lang.model.element. ElementKind
枚举常数。
ENUM_SUBKIND - jdk.jshell. Snippet.SubKind
枚举声明。
EnumConstantNotPresentException - Exception in java.lang
当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。
EnumConstantNotPresentException(Class<? extends Enum>, String) - Constructor for exception java.lang. EnumConstantNotPresentException
为指定的常量构造一个 EnumConstantNotPresentException 。
enumConstants() - Method in interface com.sun.javadoc. ClassDoc
已过时。
如果这是枚举类型，则返回枚举常量。
EnumControl - Class in javax.sound.sampled
一个 EnumControl提供对一组离散的可能值的控制，每个值由对象表示。
EnumControl(EnumControl.Type, Object[], Object) - Constructor for class javax.sound.sampled. EnumControl
使用给定的参数构造一个新的枚举控制对象。
EnumControl.Type - Class in javax.sound.sampled
EnumControl.Type内部类的实例标识了一种枚举控件。
EnumConverter< E extends Enum< E>> - Class in javafx.css.converter
EnumConverter(Class<E>) - Constructor for class javafx.css.converter. EnumConverter
enumerate(Thread[]) - Static method in class java.lang. Thread
将当前线程的线程组及其子组中的每个活动线程复制到指定的数组中。
enumerate(Thread[]) - Method in class java.lang. ThreadGroup
将此线程组及其子组中的每个活动线程复制到指定的数组中。
enumerate(Thread[], boolean) - Method in class java.lang. ThreadGroup
将此线程组中的每个活动线程复制到指定的数组中。
enumerate(ThreadGroup[]) - Method in class java.lang. ThreadGroup
复制到该线程组及其子组中每个活动子组的指定数组引用。
enumerate(ThreadGroup[], boolean) - Method in class java.lang. ThreadGroup
复制到该线程组中每个活动子组的指定数组引用。
enumeration(Collection<T>) - Static method in class java.util. Collections
返回指定集合的枚举。
Enumeration< E> - Interface in java.util
实现枚举接口的对象生成一系列元素，一次一个。
EnumMap< K extends Enum< K>, V> - Class in java.util
一个专门用于枚举类型键的Map实现。
EnumMap(Class<K>) - Constructor for class java.util. EnumMap
使用指定的键类型创建一个空的枚举映射。
EnumMap(EnumMap<K, ? extends V>) - Constructor for class java.util. EnumMap
创建与指定的枚举映射相同的键类型的枚举映射，最初包含相同的映射（如果有）。
EnumMap(Map<K, ? extends V>) - Constructor for class java.util. EnumMap
创建从指定地图初始化的枚举映射。
enums() - Method in interface com.sun.javadoc. PackageDoc
已过时。
在此包中获取包含的枚举类型。
EnumSet< E extends Enum< E>> - Class in java.util
一个专门用于枚举类型的Set实现。
EnumSyntax - Class in javax.print.attribute
类EnumSyntax是提供所有“类型安全枚举”对象的通用实现的抽象基类。
EnumSyntax(int) - Constructor for class javax.print.attribute. EnumSyntax
用给定的整数值构造一个新的枚举值。
enumType() - Method in exception java.lang. EnumConstantNotPresentException
返回缺少的枚举常量的类型。
env() - Method in class org.omg.CORBA. Request
检索此请求的 Environment对象。
env(Map<String, String>) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置环境变量的源。
ENV_10 - Static variable in class java.awt. PageAttributes.MediaType
NA_NUMBER_10_ENVELOPE的别名。
ENV_10X13 - Static variable in class java.awt. PageAttributes.MediaType
NA_10X13_ENVELOPE的别名。
ENV_10X14 - Static variable in class java.awt. PageAttributes.MediaType
NA_10X14_ENVELOPE的别名。
ENV_10X15 - Static variable in class java.awt. PageAttributes.MediaType
NA_10X15_ENVELOPE的别名。
ENV_11 - Static variable in class java.awt. PageAttributes.MediaType
NA_NUMBER_11_ENVELOPE的别名。
ENV_12 - Static variable in class java.awt. PageAttributes.MediaType
NA_NUMBER_12_ENVELOPE的别名。
ENV_14 - Static variable in class java.awt. PageAttributes.MediaType
NA_NUMBER_14_ENVELOPE的别名。
ENV_6X9 - Static variable in class java.awt. PageAttributes.MediaType
NA_6X9_ENVELOPE的别名。
ENV_7X9 - Static variable in class java.awt. PageAttributes.MediaType
NA_7X9_ENVELOPE的别名。
ENV_9 - Static variable in class java.awt. PageAttributes.MediaType
NA_NUMBER_9_ENVELOPE的别名。
ENV_9X11 - Static variable in class java.awt. PageAttributes.MediaType
NA_9X11_ENVELOPE的别名。
ENV_9X12 - Static variable in class java.awt. PageAttributes.MediaType
NA_9X12_ENVELOPE的别名。
ENV_INVITE - Static variable in class java.awt. PageAttributes.MediaType
INVITE_ENVELOPE的别名。
ENV_ITALY - Static variable in class java.awt. PageAttributes.MediaType
ITALY_ENVELOPE的别名。
ENV_MONARCH - Static variable in class java.awt. PageAttributes.MediaType
MONARCH_ENVELOPE的别名。
ENV_PERSONAL - Static variable in class java.awt. PageAttributes.MediaType
PERSONAL_ENVELOPE的别名。
ENVELOPE - Static variable in class javafx.print. PaperSource
指定选择ENVELOPE纸盘。
ENVELOPE - Static variable in class javax.print.attribute.standard. MediaTray
打印机中的信封进纸盒。
ENVELOPED - Static variable in interface javax.xml.crypto.dsig. Transform
Enveloped Signature转换算法URI。
ENVIRON_VAR - com.sun.management. VMOption.Origin
VM选项通过环境变量设置。
environment - Variable in exception javax.naming. CannotProceedException
包含与Context或DirContext方法无关的环境。
environment() - Method in class java.lang. ProcessBuilder
返回此流程构建器环境的字符串映射视图。
Environment - Class in org.omg.CORBA
用于异常的容器（持有者），用于在 Request操作中使异常可用于客户端。
Environment() - Constructor for class org.omg.CORBA. Environment
eof - Variable in exception java.io. OptionalDataException
如果流的缓冲部分中没有更多数据，则为真。
EOFException - Exception in java.io
表示在输入过程中意外地到达文件结束或流结束。
EOFException() - Constructor for exception java.io. EOFException
构造一个 EOFException其中包含 null作为其错误详细消息。
EOFException(String) - Constructor for exception java.io. EOFException
构造具有指定详细消息的 EOFException 。
eolIsSignificant(boolean) - Method in class java.io. StreamTokenizer
确定行尾是否被视为令牌。
eos - Variable in class java.util.zip. GZIPInputStream
表示输入流结束。
EPOCH - Static variable in class java.time. Instant
常数为1970-01-01T00：00：00Z时代瞬间。
EPOCH - Static variable in class java.time. LocalDate
时代年份 LocalDate ，'1970-01-01'。
EPOCH_DAY - java.time.temporal. ChronoField
基于1970-01-01（ISO）的Java时代的时代。
epochSecond(int, int, int, int, int, int, ZoneOffset) - Method in interface java.time.chrono. Chronology
从1970-01-01T00：00：00Z的时期获取秒数。
epochSecond(int, int, int, int, int, int, ZoneOffset) - Method in class java.time.chrono. IsoChronology
从1970-01-01T00：00：00Z的时期获取秒数。
epochSecond(Era, int, int, int, int, int, int, ZoneOffset) - Method in interface java.time.chrono. Chronology
从1970-01-01T00：00：00Z的时期获取秒数。
eq(ValueExp, ValueExp) - Static method in class javax.management. Query
返回一个表示两个值上的等式约束的查询表达式。
EQ - Static variable in class javax.management. Query
代表 Query.eq(javax.management.ValueExp, javax.management.ValueExp)查询的代码。
equal(double, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
equal(float, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保存true 。
equal(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保存true 。
equal(int, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
equal(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。
equal(long, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值（具有公差），则保留true 。
equal(Object, ObservableObjectValue<?>) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保留true 。
equal(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。
equal(ObservableBooleanValue, ObservableBooleanValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue相等。
equal(ObservableNumberValue, double, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
equal(ObservableNumberValue, float, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数（容差），则保留true 。
equal(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保存true 。
equal(ObservableNumberValue, int, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue等于恒定值（具有公差）。
equal(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个恒定值，则保留true 。
equal(ObservableNumberValue, long, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值等于一个常数值（具有公差），则保留true 。
equal(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等。
equal(ObservableNumberValue, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue相等（与公差）。
equal(ObservableObjectValue<?>, Object) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，则保存true 。
equal(ObservableObjectValue<?>, ObservableObjectValue<?>) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue相等。
equal(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保存true 。
equal(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等。
equal(Any) - Method in class org.omg.CORBA. Any
检查此 Any对象与给定的 Any对象之间是否相等。
equal(TypeCode) - Method in class org.omg.CORBA. TypeCode
将此 TypeCode对象与给定对象进行比较，测试相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynAnyStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynArrayStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynEnumStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynFixedStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynSequenceStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynStructStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynUnionStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in class org.omg.DynamicAny. _DynValueStub
比较两个DynAny值以获得相等性。
equal(DynAny) - Method in interface org.omg.DynamicAny. DynAnyOperations
比较两个DynAny值以获得相等性。
EQUAL - javafx.print. Printer.MarginType
选择最大的四个硬件边距，并将其用于所有的边距，以使边框在所有方面相等。
EQUAL - javax.swing. RowFilter.ComparisonType
表示应包含值等于提供值的条目。
EQUAL - Static variable in class javax.xml.datatype. DatatypeConstants
比较结果。
EQUAL_OPPOSITES - javafx.print. Printer.MarginType
类似于 EQUAL ，但它分别选择较大的左/右硬件边距和顶部/底部硬件边距，以使顶部和底部边距相等，左右边距相等。
EQUAL_TO - com.sun.source.tree. Tree.Kind
用于实例BinaryTree代表等于至== 。
EQUAL_TO - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree代表等于至== 。
equalIgnoreCase(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableStringValue等于恒定值忽略大小写。
equalIgnoreCase(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值忽略大小写，则保存true 。
equalIgnoreCase(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue相等忽略大小写。
EqualizerBand - Class in javafx.scene.media
所述EqualizerBand类提供了在每个频带控制AudioEqualizer 。
EqualizerBand() - Constructor for class javafx.scene.media. EqualizerBand
默认构造函数 EqualizerBand 。
EqualizerBand(double, double, double) - Constructor for class javafx.scene.media. EqualizerBand
自定义 EqualizerBand构造函数。
equals(boolean[], boolean[]) - Static method in class java.util. Arrays
如果两个指定的布尔数组彼此 相等 ，则返回 true 。
equals(boolean[], int, int, boolean[], int, int) - Static method in class java.util. Arrays
如果两个指定的布尔值数组在指定的范围内彼此 相等 ，则返回true。
equals(byte[], byte[]) - Static method in class java.util. Arrays
如果两个指定的字节数组彼此 相等 ，则返回 true 。
equals(byte[], int, int, byte[], int, int) - Static method in class java.util. Arrays
如果两个指定的字节数组（在指定范围内）彼此 相等 ，则返回true。
equals(char[], char[]) - Static method in class java.util. Arrays
如果两个指定的字符数组彼此 相等 ，则返回 true 。
equals(char[], int, int, char[], int, int) - Static method in class java.util. Arrays
如果两个指定的字符数组在指定范围内彼此 相等 ，则返回true。
equals(double[], double[]) - Static method in class java.util. Arrays
如果两个指定的双精度数组彼此 相等 ，则返回 true 。
equals(double[], int, int, double[], int, int) - Static method in class java.util. Arrays
如果指定范围内的两个指定的双精度数组彼此 相等 ，则返回true。
equals(float[], float[]) - Static method in class java.util. Arrays
如果两个指定的浮动数组彼此 相等 ，则返回 true 。
equals(float[], int, int, float[], int, int) - Static method in class java.util. Arrays
如果两个指定的浮点数在指定范围内相互 相等 ，则返回true。
equals(int[], int[]) - Static method in class java.util. Arrays
如果两个指定的int数组彼此 相等 ，则返回 true 。
equals(int[], int, int, int[], int, int) - Static method in class java.util. Arrays
如果两个指定的int数组在指定的范围内彼此 相等 ，则返回true。
equals(long[], int, int, long[], int, int) - Static method in class java.util. Arrays
如果指定范围内的两个指定的long数组彼此 相等 ，则返回true。
equals(long[], long[]) - Static method in class java.util. Arrays
如果两个指定的longs数组彼此 相等 ，则返回 true 。
equals(short[], int, int, short[], int, int) - Static method in class java.util. Arrays
如果两个指定的短整型数组在指定的范围内彼此 相等 ，则返回true。
equals(short[], short[]) - Static method in class java.util. Arrays
如果两个指定的短裤数组彼此 相等 ，则返回 true 。
equals(DataFlavor) - Method in class java.awt.datatransfer. DataFlavor
此方法与 DataFlavor.equals(Object)具有相同的行为。
equals(DataFlavor) - Method in class javax.activation. ActivationDataFlavor
将传入的DataFlavor与此DataFlavor进行比较; 调用isMimeTypeEqual方法。
equals(DisplayMode) - Method in class java.awt. DisplayMode
返回两种显示模式是否相等。
equals(FontRenderContext) - Method in class java.awt.font. FontRenderContext
如果rhs具有相同的变换，抗锯齿和小数度量值，则返回true。
equals(GlyphVector) - Method in class java.awt.font. GlyphVector
测试指定的 GlyphVector完全等于此 GlyphVector 。
equals(ImageGraphicAttribute) - Method in class java.awt.font. ImageGraphicAttribute
将此 ImageGraphicAttribute与指定的 ImageGraphicAttribute 。
equals(ShapeGraphicAttribute) - Method in class java.awt.font. ShapeGraphicAttribute
将此 ShapeGraphicAttribute与指定的 ShapeGraphicAttribute 。
equals(TextHitInfo) - Method in class java.awt.font. TextHitInfo
返回 true如果指定 TextHitInfo具有相同 charIndex和 isLeadingEdge ，因为这 TextHitInfo 。
equals(TextLayout) - Method in class java.awt.font. TextLayout
如果两个布局相等，则返回 true 。
equals(Area) - Method in class java.awt.geom. Area
测试两个 Area对象的几何是否相等。
equals(MenuShortcut) - Method in class java.awt. MenuShortcut
返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。
equals(Object) - Method in class com.sun.java.accessibility.util. Translator
如果此对象与传入的对象相同，则返回true。
equals(Object) - Method in interface com.sun.jdi. BooleanValue
将指定的Object与此BooleanValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. ByteValue
将指定的对象与此ByteValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. CharValue
将指定的对象与此CharValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. DoubleValue
将指定的Object与此DoubleValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. Field
将指定的Object与此字段进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. FloatValue
将指定的对象与此FloatValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. IntegerValue
将指定的Object与此IntegerValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. LocalVariable
将指定的Object与此LocalVariable进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. Location
将指定的对象与此位置进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. LongValue
将指定的Object与此LongValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. 方法
将指定的Object与此方法进行比较以实现相等。
equals(Object) - Method in interface com.sun.jdi. ObjectReference
将指定的Object与此ObjectReference进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. ReferenceType
将指定的Object与此ReferenceType进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. ShortValue
将指定的Object与此ShortValue进行比较以获得相等性。
equals(Object) - Method in interface com.sun.jdi. VoidValue
将指定的Object与此VoidValue进行比较以获得相等性。
equals(Object) - Method in class com.sun.management. GcInfo
equals(Object) - Method in class com.sun.net.httpserver. Headers
equals(Object) - Method in class com.sun.net.httpserver. HttpPrincipal
比较两个HttpPrincipal。
equals(Object) - Method in class com.sun.nio.sctp. SctpStandardSocketOptions.InitMaxStreams
如果指定的对象是另一个 InitMaxStreams具有相同数量的输入和输出绑定流的实例，则返回true。
equals(Object) - Method in class com.sun.security.auth. LdapPrincipal
将此主体与指定对象进行比较。
equals(Object) - Method in class com.sun.security.auth. NTDomainPrincipal
将指定的对象与此 NTDomainPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. NTNumericCredential
将指定的对象与此 NTNumericCredential进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. NTSid
将指定的对象与此 NTSid进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. NTSidDomainPrincipal
将指定的对象与此 NTSidDomainPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. NTSidGroupPrincipal
将指定的对象与此 NTSidGroupPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. NTSidPrimaryGroupPrincipal
将指定的对象与此 NTSidPrimaryGroupPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. NTSidUserPrincipal
将指定的对象与此 NTSidUserPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. NTUserPrincipal
将指定的对象与此 NTUserPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. SolarisNumericGroupPrincipal
已过时。
将指定的对象与此 SolarisNumericGroupPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. SolarisNumericUserPrincipal
已过时。
将指定的对象与此 SolarisNumericUserPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. SolarisPrincipal
已过时。
将指定的对象与此 SolarisPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. UnixNumericGroupPrincipal
将指定的对象与此 UnixNumericGroupPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. UnixNumericUserPrincipal
将指定的对象与此 UnixNumericUserPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. UnixPrincipal
将指定的对象与此 UnixPrincipal进行比较以获得相等性。
equals(Object) - Method in class com.sun.security.auth. UserPrincipal
将此主体与指定对象进行比较。
equals(Object) - Method in class com.sun.security.auth. X500Principal
已过时。
将指定的对象与此 X500Principal进行比较以获得相等性。
equals(Object) - Method in class com.sun.tools.attach. VirtualMachine
测试此VirtualMachine与另一个对象的相等性。
equals(Object) - Method in class com.sun.tools.attach. VirtualMachineDescriptor
测试此VirtualMachineDescriptor与其他对象的相等性。
equals(Object) - Method in class java.awt. AlphaComposite
确定指定的对象是否等于此 AlphaComposite 。
equals(Object) - Method in class java.awt. AWTKeyStroke
如果此对象与指定的对象相同，则返回true。
equals(Object) - Method in class java.awt. BasicStroke
测试指定的对象是否等于 BasicStroke ，首先测试是否为 BasicStroke ，然后将其宽度，连接，上限， BasicStroke限制，破折号和破折号相位属性与该 BasicStroke 。
equals(Object) - Method in class java.awt. Color
确定另一个对象是否等于此 Color 。
equals(Object) - Method in class java.awt.datatransfer. DataFlavor
指示一些其他对象是否等于此。
equals(Object) - Method in class java.awt. Dimension
检查两维对象是否具有相等的值。
equals(Object) - Method in class java.awt. DisplayMode
指示一些其他对象是否等于此。
equals(Object) - Method in class java.awt. Font
将此 Font对象与指定的 Object 。
equals(Object) - Method in class java.awt.font. FontRenderContext
如果obj是FontRenderContext的一个实例，并且具有与此相同的转换，抗锯齿和小数度量值，则返回true。
equals(Object) - Method in class java.awt.font. ImageGraphicAttribute
将此ImageGraphicAttribute与指定的Object进行比较 。
equals(Object) - Method in class java.awt.font. NumericShaper
如果指定的对象是 NumericShaper的实例，并且与这个对象的形状相同，则返回 true ，而不考虑范围表示，位掩码或枚举。
equals(Object) - Method in class java.awt.font. ShapeGraphicAttribute
将此 ShapeGraphicAttribute与指定的 Object 。
equals(Object) - Method in class java.awt.font. TextHitInfo
返回 true如果指定 Object是 TextHitInfo ，等于这个 TextHitInfo 。
equals(Object) - Method in class java.awt.font. TransformAttribute
返回 true如果rhs是一个 TransformAttribute其变换等于这个 TransformAttribute的变换。
equals(Object) - Method in class java.awt.geom. AffineTransform
返回 true如果这个 AffineTransform表示与指定参数相同的仿射坐标变换。
equals(Object) - Method in class java.awt.geom. Arc2D
确定指定的 Object是否等于此 Arc2D 。
equals(Object) - Method in class java.awt.geom. Ellipse2D
确定指定的 Object是否等于此 Ellipse2D 。
equals(Object) - Method in class java.awt.geom. Point2D
确定两点是否相等。
equals(Object) - Method in class java.awt.geom. Rectangle2D
确定指定的 Object是否等于此 Rectangle2D 。
equals(Object) - Method in class java.awt.geom. RoundRectangle2D
确定指定的 Object是否等于此 RoundRectangle2D 。
equals(Object) - Method in class java.awt.image. ColorModel
该方法简单地委托到 Object中与 ==测试相同的默认实现，因为该类不能在多个独立子类分支之间强制执行正确的等式测试的问题。
equals(Object) - Method in class java.awt.image. ComponentColorModel
测试指定 Object是一个实例 ComponentColorModel和等于这个 ComponentColorModel 。
equals(Object) - Method in class java.awt.image. ComponentSampleModel
equals(Object) - Method in class java.awt.image. IndexColorModel
如果指定的测试 Object是一个实例 IndexColorModel ，以及它是否该 IndexColorModel
equals(Object) - Method in class java.awt.image. MultiPixelPackedSampleModel
equals(Object) - Method in class java.awt.image. PackedColorModel
测试指定的 Object是否为 PackedColorModel ，等于该 PackedColorModel 。
equals(Object) - Method in class java.awt.image. SinglePixelPackedSampleModel
equals(Object) - Method in class java.awt. Insets
检查两个插入对象是否相等。
equals(Object) - Method in class java.awt. JobAttributes
确定两个JobAttributes是否相等。
equals(Object) - Method in class java.awt. MenuShortcut
返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。
equals(Object) - Method in class java.awt. PageAttributes
确定两个PageAttributes是否相等。
equals(Object) - Method in class java.awt. Point
确定两点是否相等。
equals(Object) - Method in class java.awt. Rectangle
检查两个矩形是否相等。
equals(Object) - Method in class java.awt. RenderingHints
将 Object与 RenderingHints进行比较，以获得相等性。
equals(Object) - Method in class java.awt. RenderingHints.Key
所有Key对象的equals方法将返回与等式运算符“==”相同的结果。
equals(Object) - Method in class java.beans. IndexedPropertyDescriptor
将此 PropertyDescriptor与指定对象进行比较。
equals(Object) - Method in class java.beans. PropertyDescriptor
将此 PropertyDescriptor与指定对象进行比较。
equals(Object) - Method in class java.io. File
测试此抽象路径名与给定对象的相等性。
equals(Object) - Method in class java.io. FilePermission
检查两个FilePermission对象是否相等。
equals(Object) - Method in interface java.lang.annotation. Annotation
如果指定的对象表示在逻辑上等同于该注释的注释，则返回true。
equals(Object) - Method in class java.lang. Boolean
如果且仅当参数不是 null且是表示与此对象相同的 boolean值的 Boolean对象时，则返回 true 。
equals(Object) - Method in class java.lang. Byte
将此对象与指定的对象进行比较。
equals(Object) - Method in class java.lang. Character
将此对象与指定对象进行比较。
equals(Object) - Method in class java.lang. Character.Subset
比较两个 Subset对象的相等性。
equals(Object) - Method in class java.lang. Double
将此对象与指定对象进行比较。
equals(Object) - Method in class java.lang. Enum
如果指定的对象等于此枚举常量，则返回true。
equals(Object) - Method in class java.lang. Float
将此对象与指定对象进行比较。
equals(Object) - Method in class java.lang. Integer
将此对象与指定的对象进行比较。
equals(Object) - Method in class java.lang.invoke. MethodType
将指定的对象与此类型进行比较以获得相等性。
equals(Object) - Method in class java.lang. Long
将此对象与指定的对象进行比较。
equals(Object) - Method in class java.lang.module. ModuleDescriptor
测试此模块描述符与给定对象的相等性。
equals(Object) - Method in class java.lang.module. ModuleDescriptor.Exports
测试此模块导出与给定对象的相等性。
equals(Object) - Method in class java.lang.module. ModuleDescriptor.Opens
测试此模块打开以与给定对象相等。
equals(Object) - Method in class java.lang.module. ModuleDescriptor.Provides
测试这提供了与给定对象的相等性。
equals(Object) - Method in class java.lang.module. ModuleDescriptor.Requires
测试此模块与给定对象的相等性的依赖关系。
equals(Object) - Method in class java.lang.module. ModuleDescriptor.Version
测试此模块版本与给定对象的相等性。
equals(Object) - Method in class java.lang.module. ResolvedModule
测试此已解析模块与给定对象的相等性。
equals(Object) - Method in class java.lang. Object
指示一些其他对象是否等于此。
equals(Object) - Method in class java.lang. ProcessBuilder.Redirect
将指定的对象与此 Redirect进行比较以获得相等性。
equals(Object) - Method in interface java.lang. ProcessHandle
返回true如果other对象是非空的，是相同的实现，并表示相同的系统进程; 否则返回false 。
equals(Object) - Method in class java.lang.reflect. Constructor
将此 Constructor与指定对象进行比较。
equals(Object) - Method in class java.lang.reflect. Field
将此 Field与指定对象进行比较。
equals(Object) - Method in class java.lang.reflect. 方法
将此 方法与指定对象进行比较。
equals(Object) - Method in class java.lang.reflect. Parameter
基于可执行文件和索引进行比较。
equals(Object) - Method in class java.lang. Runtime.Version
确定此 Version是否等于另一个对象。
equals(Object) - Method in class java.lang. Short
将此对象与指定的对象进行比较。
equals(Object) - Method in class java.lang. StackTraceElement
如果指定的对象是另一个表示与该实例相同的执行点的 StackTraceElement实例，则返回true。
equals(Object) - Method in class java.lang. String
将此字符串与指定对象进行比较。
equals(Object) - Method in class java.math. BigDecimal
将此 BigDecimal与指定的 Object进行比较以获得相等性。
equals(Object) - Method in class java.math. BigInteger
将此BigInteger与指定的对象进行比较以实现相等。
equals(Object) - Method in class java.math. MathContext
将此 MathContext与指定的 Object进行比较以获得相等性。
equals(Object) - Method in class java.net. HttpCookie
测试两个HTTP Cookie的相等性。
equals(Object) - Method in class java.net. Inet4Address
将此对象与指定对象进行比较。
equals(Object) - Method in class java.net. Inet6Address
将此对象与指定对象进行比较。
equals(Object) - Method in class java.net. InetAddress
将此对象与指定对象进行比较。
equals(Object) - Method in class java.net. InetSocketAddress
将此对象与指定对象进行比较。
equals(Object) - Method in class java.net. InterfaceAddress
将此对象与指定对象进行比较。
equals(Object) - Method in class java.net. NetworkInterface
将此对象与指定对象进行比较。
equals(Object) - Method in class java.net. Proxy
将此对象与指定对象进行比较。
equals(Object) - Method in class java.net. SocketPermission
检查两个SocketPermission对象是否相等。
equals(Object) - Method in class java.net. URI
测试此URI以与另一个对象相等。
equals(Object) - Method in class java.net. URL
将此URL与其他对象进行比较。
equals(Object) - Method in class java.net. URLPermission
如果this.getActions（）。equals（p.getActions（））和p的url等于这个url，则返回true。
equals(Object) - Method in class java.nio. ByteBuffer
告诉这个缓冲区是否等于另一个对象。
equals(Object) - Method in class java.nio. CharBuffer
告诉这个缓冲区是否等于另一个对象。
equals(Object) - Method in class java.nio.charset. Charset
告诉这个对象是否等于另一个。
equals(Object) - Method in class java.nio. DoubleBuffer
告诉这个缓冲区是否等于另一个对象。
equals(Object) - Method in class java.nio.file.attribute. AclEntry
将指定的对象与此ACL条目进行比较以获得相等性。
equals(Object) - Method in class java.nio.file.attribute. FileTime
测试此 FileTime与给定对象的相等性。
equals(Object) - Method in interface java.nio.file. Path
测试此路径与给定对象的相等性。
equals(Object) - Method in class java.nio. FloatBuffer
告诉这个缓冲区是否等于另一个对象。
equals(Object) - Method in class java.nio. IntBuffer
告诉这个缓冲区是否等于另一个对象。
equals(Object) - Method in class java.nio. LongBuffer
告诉这个缓冲区是否等于另一个对象。
equals(Object) - Method in class java.nio. ShortBuffer
告诉这个缓冲区是否等于另一个对象。
equals(Object) - Method in class java.rmi.activation. ActivationDesc
比较两个激活描述符的内容相等性。
equals(Object) - Method in class java.rmi.activation. ActivationGroupDesc.CommandEnvironment
比较两个命令环境的内容相等性。
equals(Object) - Method in class java.rmi.activation. ActivationGroupDesc
比较两个激活组描述符的内容相等性。
equals(Object) - Method in class java.rmi.activation. ActivationGroupID
比较两个组标识符的内容相等性。
equals(Object) - Method in class java.rmi.activation. ActivationID
比较两个激活ID用于内容相等。
equals(Object) - Method in class java.rmi.dgc. VMID
将此VMID与另一个进行比较，如果它们是相同的标识符，则返回true。
equals(Object) - Method in class java.rmi. MarshalledObject
将此 MarshalledObject与另一个对象进行比较。
equals(Object) - Method in class java.rmi.server. ObjID
将指定的对象与此 ObjID进行比较以获得相等性。
equals(Object) - Method in class java.rmi.server. RemoteObject
比较两个远程对象的相等性。
equals(Object) - Method in class java.rmi.server. UID
将指定的对象与此 UID进行比较以获得相等性。
equals(Object) - Method in class java.security. AccessControlContext
检查两个AccessControlContext对象的相等性。
equals(Object) - Method in interface java.security.acl. Permission
已过时。
如果传递的对象匹配此接口中表示的权限，则返回true。
equals(Object) - Method in class java.security. AllPermission
检查两个AllPermission对象是否相等。
equals(Object) - Method in class java.security. BasicPermission
检查两个BasicPermission对象是否相等。
equals(Object) - Method in class java.security.cert. Certificate
将此证书与指定的对象进行比较。
equals(Object) - Method in class java.security.cert. CertPath
将此认证路径与指定的对象进行比较。
equals(Object) - Method in class java.security.cert. URICertStoreParameters
将指定的对象与此参数对象进行比较以获得相等性。
equals(Object) - Method in class java.security.cert. X509CRL
将此CRL与给定对象进行比较。
equals(Object) - Method in class java.security.cert. X509CRLEntry
将此CRL条目与给定对象进行比较。
equals(Object) - Method in class java.security. CodeSigner
测试指定对象与此代码签名者之间的相等性。
equals(Object) - Method in class java.security. CodeSource
测试指定对象和此对象之间的相等性。
equals(Object) - Method in class java.security. Identity
已过时。
测试指定对象与此身份之间的相等性。
equals(Object) - Method in class java.security. Permission
检查两个Permission对象的相等性。
equals(Object) - Method in class java.security. PKCS12Attribute
比较这个 PKCS12Attribute和一个指定的对象的相等性。
equals(Object) - Method in interface java.security. Principal
将此主体与指定对象进行比较。
equals(Object) - Method in class java.security.spec. ECFieldF2m
将此有限域作为与指定对象相等的比较。
equals(Object) - Method in class java.security.spec. ECFieldFp
将此主要有限域与等同与指定对象进行比较。
equals(Object) - Method in class java.security.spec. ECPoint
将此椭圆曲线点与指定对象进行比较。
equals(Object) - Method in class java.security.spec. EllipticCurve
将此椭圆曲线与指定对象进行比较。
equals(Object) - Method in class java.security. Timestamp
测试指定对象与此时间戳之间的相等性。
equals(Object) - Method in class java.security. UnresolvedPermission
检查两个UnresolvedPermission对象是否相等。
equals(Object) - Method in interface java.sql. RowId
将此 RowId与指定对象进行比较。
equals(Object) - Method in class java.sql. Timestamp
测试这个 Timestamp对象是否等于给定的对象。
equals(Object) - Method in class java.text. AttributedCharacterIterator.Attribute
比较两个对象的平等。
equals(Object) - Method in class java.text. ChoiceFormat
两者之间的平等比较
equals(Object) - Method in class java.text. Collator
比较两个Collator的平等。
equals(Object) - Method in class java.text. DateFormat
覆盖等于
equals(Object) - Method in class java.text. DateFormatSymbols
覆盖等于
equals(Object) - Method in class java.text. DecimalFormat
覆盖等于
equals(Object) - Method in class java.text. DecimalFormatSymbols
覆盖等于。
equals(Object) - Method in class java.text. FieldPosition
覆盖等于
equals(Object) - Method in class java.text. MessageFormat
两个消息格式对象之间的平等比较
equals(Object) - Method in class java.text. NumberFormat
覆盖等于。
equals(Object) - Method in class java.text. ParsePosition
覆盖等于
equals(Object) - Method in class java.text. RuleBasedCollator
比较两个对照对象的相等性。
equals(Object) - Method in class java.text. SimpleDateFormat
将给定对象与此 SimpleDateFormat进行比较以获得相等性。
equals(Object) - Method in class java.text. StringCharacterIterator
比较两个StringCharacterIterator对象的相等性。
equals(Object) - Method in class java.time.chrono. AbstractChronology
检查这个年表是否等于另一个年表。
equals(Object) - Method in interface java.time.chrono. ChronoLocalDate
检查这个日期是否等于另一个日期，包括年表。
equals(Object) - Method in interface java.time.chrono. ChronoLocalDateTime
检查这个日期时间是否等于另一个日期时间，包括年表。
equals(Object) - Method in interface java.time.chrono. Chronology
检查这个年表是否等于另一个年表。
equals(Object) - Method in interface java.time.chrono. ChronoPeriod
检查这个时期是否等于另一个时期，包括年表。
equals(Object) - Method in interface java.time.chrono. ChronoZonedDateTime
检查此日期时间是否等于另一个日期时间。
equals(Object) - Method in class java.time.chrono. HijrahDate
将此日期与其他日期进行比较，包括年表。
equals(Object) - Method in class java.time.chrono. JapaneseDate
将此日期与其他日期进行比较，包括年表。
equals(Object) - Method in class java.time.chrono. MinguoDate
将此日期与其他日期进行比较，包括年表。
equals(Object) - Method in class java.time.chrono. ThaiBuddhistDate
将此日期与其他日期进行比较，包括年表。
equals(Object) - Method in class java.time. Clock
检查这个时钟是否等于另一个时钟。
equals(Object) - Method in class java.time. Duration
检查此持续时间是否等于指定的 Duration 。
equals(Object) - Method in class java.time.format. DecimalStyle
检查这个DecimalStyle是否等于另一个DecimalStyle。
equals(Object) - Method in class java.time. Instant
检查这个瞬间是否等于指定的时刻。
equals(Object) - Method in class java.time. LocalDate
检查这个日期是否等于另一个日期。
equals(Object) - Method in class java.time. LocalDateTime
检查此日期时间是否等于另一个日期时间。
equals(Object) - Method in class java.time. LocalTime
检查这次是否等于另一次。
equals(Object) - Method in class java.time. MonthDay
检查这个月日是否等于另一个月 - 日。
equals(Object) - Method in class java.time. OffsetDateTime
检查此日期时间是否等于另一个日期时间。
equals(Object) - Method in class java.time. OffsetTime
检查这次是否等于另一次。
equals(Object) - Method in class java.time. Period
检查此期间是否等于另一期间。
equals(Object) - Method in class java.time.temporal. ValueRange
检查此范围是否等于另一个范围。
equals(Object) - Method in class java.time.temporal. WeekFields
检查这个 WeekFields是否等于指定的对象。
equals(Object) - Method in class java.time. Year
检查今年是否等于另一年。
equals(Object) - Method in class java.time. YearMonth
检查这个年月是否等于另一个一个月。
equals(Object) - Method in class java.time.zone. ZoneOffsetTransition
检查这个对象是否等于另一个。
equals(Object) - Method in class java.time.zone. ZoneOffsetTransitionRule
检查这个对象是否等于另一个。
equals(Object) - Method in class java.time.zone. ZoneRules
检查这套规则是否等于另一个。
equals(Object) - Method in class java.time. ZonedDateTime
检查此日期时间是否等于另一个日期时间。
equals(Object) - Method in class java.time. ZoneId
检查此时区ID是否等于其他时区ID。
equals(Object) - Method in class java.time. ZoneOffset
检查这个偏移量是否等于另一个偏移量。
equals(Object) - Method in class java.util. AbstractList
将指定的对象与此列表进行比较以获得相等性。
equals(Object) - Method in class java.util. AbstractMap
将指定的对象与此映射进行比较以获得相等性。
equals(Object) - Method in class java.util. AbstractMap.SimpleEntry
将指定的对象与此条目进行比较以获得相等性。
equals(Object) - Method in class java.util. AbstractMap.SimpleImmutableEntry
将指定的对象与此条目进行比较以获得相等性。
equals(Object) - Method in class java.util. AbstractSet
将指定的对象与此集合进行比较以实现相等。
equals(Object) - Method in class java.util. BitSet
将此对象与指定对象进行比较。
equals(Object) - Method in class java.util. Calendar
将此 Calendar与指定的 Object 。
equals(Object) - Method in interface java.util. Collection
将指定的对象与此集合进行比较以获得相等性。
equals(Object) - Method in interface java.util. Comparator
指示某个其他对象是否等于此比较器。
equals(Object) - Method in class java.util.concurrent. ConcurrentHashMap
将指定的对象与此映射进行比较以获得相等性。
equals(Object) - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView
equals(Object) - Method in class java.util.concurrent. ConcurrentSkipListMap
将指定的对象与此映射进行比较以获得相等性。
equals(Object) - Method in class java.util.concurrent. ConcurrentSkipListSet
将指定的对象与此集合进行比较以实现相等。
equals(Object) - Method in class java.util.concurrent. CopyOnWriteArrayList
将指定的对象与此列表进行比较以获得相等性。
equals(Object) - Method in class java.util.concurrent. CopyOnWriteArraySet
将指定的对象与此集合进行比较以实现相等。
equals(Object) - Method in class java.util. Date
比较两个日期来平等。
equals(Object) - Method in class java.util. EnumMap
将指定的对象与此映射进行比较以获得相等性。
equals(Object) - Method in class java.util. GregorianCalendar
将此 GregorianCalendar与指定的 Object 。
equals(Object) - Method in class java.util. Hashtable
根据Map界面中的定义，将指定的对象与此Map进行比较以相等。
equals(Object) - Method in class java.util. IdentityHashMap
将指定的对象与此映射进行比较以获得相等性。
equals(Object) - Method in class java.util.jar. Attributes
将指定的Attributes对象与此Map进行比较以获得相等性。
equals(Object) - Method in class java.util.jar. Attributes.Name
将此属性名称与其他名称进行比较以获得相等性
equals(Object) - Method in class java.util.jar. Manifest
如果指定的对象也是清单并具有相同的主要属性和条目，则返回true。
equals(Object) - Method in interface java.util. List
将指定的对象与此列表进行比较以获得相等性。
equals(Object) - Method in class java.util. Locale
如果此区域设置等于另一个对象，则返回true。
equals(Object) - Method in class java.util. Locale.LanguageRange
将此对象与指定的对象进行比较。
equals(Object) - Method in class java.util.logging. Level
比较两个对象的值相等。
equals(Object) - Method in interface java.util. Map.Entry
将指定的对象与此条目进行比较以获得相等性。
equals(Object) - Method in interface java.util. Map
将指定的对象与此映射进行比较以获得相等性。
equals(Object) - Method in class java.util. Optional
指示某个其他对象是否等于此 Optional 。
equals(Object) - Method in class java.util. OptionalDouble
指示某个其他对象是否等于此 OptionalDouble 。
equals(Object) - Method in class java.util. OptionalInt
指示某个其他对象是否等于此 OptionalInt 。
equals(Object) - Method in class java.util. OptionalLong
指示一些其他对象是否等于此 OptionalLong 。
equals(Object) - Method in class java.util. Properties
equals(Object) - Method in class java.util. PropertyPermission
检查两个PropertyPermission对象是否相等。
equals(Object) - Method in interface java.util. Set
将指定的对象与此集合进行比较以实现相等。
equals(Object) - Method in class java.util. SimpleTimeZone
比较两个 SimpleTimeZone对象的相等性。
equals(Object) - Method in class java.util. UUID
将此对象与指定的对象进行比较。
equals(Object) - Method in class java.util. Vector
将指定的对象与此向量进行比较以获得相等性。
equals(Object) - Method in class javafx.animation. KeyFrame
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.animation. KeyValue
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.beans.property. ReadOnlyListProperty
equals(Object) - Method in class javafx.beans.property. ReadOnlyMapProperty
equals(Object) - Method in class javafx.beans.property. ReadOnlySetProperty
equals(Object) - Method in class javafx.css. CompoundSelector
equals(Object) - Method in class javafx.css.converter. EnumConverter
equals(Object) - Method in class javafx.css. CssMetaData
如果两个CssMetaData对象的 property值相等，则认为它们是相等的。
equals(Object) - Method in class javafx.css. Declaration
无论宣言所属的规则如何，一个宣言是相等的。
equals(Object) - Method in class javafx.css. SimpleSelector
equals(Object) - Method in class javafx.css. Size
equals(Object) - Method in class javafx.css. Style
equals(Object) - Method in class javafx.css. Stylesheet
equals(Object) - Method in class javafx.fxml. FXMLLoader
equals(Object) - Method in class javafx.geometry. BoundingBox
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.geometry. Dimension2D
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.geometry. Insets
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.geometry. Point2D
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.geometry. Point3D
返回该点的哈希码值。
equals(Object) - Method in class javafx.geometry. Rectangle2D
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.print. PageLayout
equals(Object) - Method in class javafx.print. Paper
equals(Object) - Method in class javafx.print. PrintResolution
equals(Object) - Method in class javafx.scene.control. IndexRange
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.control. TablePositionBase
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.input. DataFormat
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.input. KeyCharacterCombination
测试这个 KeyCharacterCombination是否等于指定的对象。
equals(Object) - Method in class javafx.scene.input. KeyCodeCombination
测试这个 KeyCodeCombination是否等于指定的对象。
equals(Object) - Method in class javafx.scene.input. KeyCombination
测试这个 KeyCombination是否等于指定的对象。
equals(Object) - Method in class javafx.scene.layout. Background
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BackgroundFill
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BackgroundImage
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BackgroundPosition
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BackgroundSize
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. Border
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BorderImage
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BorderStroke
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BorderStrokeStyle
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. BorderWidths
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.layout. CornerRadii
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.paint. Color
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.paint. LinearGradient
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.paint. RadialGradient
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.paint. Stop
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.scene.text. Font
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.stage. Screen
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.util. Duration
指示一些其他对象是否等于此。
equals(Object) - Method in class javafx.util. Pair
测试这个 Pair与另一个 Object平等。
equals(Object) - Method in class javax.crypto.spec. RC2ParameterSpec
测试指定对象和此对象之间的相等性。
equals(Object) - Method in class javax.crypto.spec. RC5ParameterSpec
测试指定对象和此对象之间的相等性。
equals(Object) - Method in class javax.crypto.spec. SecretKeySpec
测试指定对象和此对象之间的相等性。
equals(Object) - Method in class javax.imageio. ImageTypeSpecifier
如果给定的 Object是 ImageTypeSpecifier并且具有与该对象相同的 SampleModel和 ColorModel ，则返回 true 。
equals(Object) - Method in interface javax.lang.model.element. Element
返回 true如果参数表示相同的元件作为 this ，或 false否则。
equals(Object) - Method in interface javax.lang.model.element. Name
返回 true如果参数表示相同的名字 this和 false否则。
equals(Object) - Method in interface javax.lang.model.type. TypeMirror
遵守 Object.equals的总合同。
equals(Object) - Method in class javax.management. Attribute
将当前属性对象与另一个属性对象进行比较。
equals(Object) - Method in interface javax.management. Descriptor
将此描述符与给定对象进行比较。
equals(Object) - Method in class javax.management. ImmutableDescriptor
将此描述符与给定对象进行比较。
equals(Object) - Method in class javax.management. MBeanAttributeInfo
将此MBeanAttributeInfo与另一个进行比较。
equals(Object) - Method in class javax.management. MBeanConstructorInfo
将此MBeanConstructorInfo与另一个进行比较。
equals(Object) - Method in class javax.management. MBeanFeatureInfo
将此MBeanFeatureInfo与另一个进行比较。
equals(Object) - Method in class javax.management. MBeanInfo
将此MBeanInfo与另一个进行比较。
equals(Object) - Method in class javax.management. MBeanNotificationInfo
将此MBeanNotificationInfo与另一个进行比较。
equals(Object) - Method in class javax.management. MBeanOperationInfo
将此MBeanOperationInfo与另一个进行比较。
equals(Object) - Method in class javax.management. MBeanParameterInfo
将此MBeanParameterInfo与另一个进行比较。
equals(Object) - Method in class javax.management. MBeanPermission
检查两个MBeanPermission对象是否相等。
equals(Object) - Method in class javax.management. MBeanServerPermission
检查两个MBeanServerPermission对象是否相等。
equals(Object) - Method in class javax.management.modelmbean. DescriptorSupport
将此描述符与给定对象进行比较。
equals(Object) - Method in class javax.management. ObjectInstance
将当前对象实例与另一个对象实例进行比较。
equals(Object) - Method in class javax.management. ObjectName
将当前对象名称与另一个对象名称进行比较。
equals(Object) - Method in class javax.management.openmbean. ArrayType
将指定的 obj参数与此 ArrayType实例进行比较以获得相等性。
equals(Object) - Method in interface javax.management.openmbean. CompositeData
将指定的 obj参数与此 CompositeData实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. CompositeDataSupport
将指定的 obj参数与此 CompositeDataSupport实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. CompositeType
将指定的 obj参数与此 CompositeType实例进行比较以获得相等性。
equals(Object) - Method in interface javax.management.openmbean. OpenMBeanAttributeInfo
将指定的 obj参数与此 OpenMBeanAttributeInfo实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport
将指定的 obj参数与此 OpenMBeanAttributeInfoSupport实例相比较。
equals(Object) - Method in interface javax.management.openmbean. OpenMBeanConstructorInfo
将指定的 obj参数与此 OpenMBeanConstructorInfo实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. OpenMBeanConstructorInfoSupport
将指定的 obj参数与此 OpenMBeanConstructorInfoSupport实例进行比较以获得相等性。
equals(Object) - Method in interface javax.management.openmbean. OpenMBeanInfo
将指定的 obj参数与此 OpenMBeanInfo实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. OpenMBeanInfoSupport
将指定的 obj参数与此 OpenMBeanInfoSupport实例进行比较以获得相等性。
equals(Object) - Method in interface javax.management.openmbean. OpenMBeanOperationInfo
将指定的 obj参数与此 OpenMBeanOperationInfo实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. OpenMBeanOperationInfoSupport
将指定的 obj参数与此 OpenMBeanOperationInfoSupport实例进行比较以获得相等性。
equals(Object) - Method in interface javax.management.openmbean. OpenMBeanParameterInfo
将指定的 obj参数与此 OpenMBeanParameterInfo实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport
将指定的 obj参数与此 OpenMBeanParameterInfoSupport实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. OpenType
将指定的 obj参数与此打开类型的实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. SimpleType
将指定的 obj参数与此 SimpleType实例进行比较以获得相等性。
equals(Object) - Method in interface javax.management.openmbean. TabularData
将指定的 obj参数与此 TabularData实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. TabularDataSupport
将指定的 obj参数与此 TabularDataSupport实例进行比较以获得相等性。
equals(Object) - Method in class javax.management.openmbean. TabularType
将指定的 obj参数与此 TabularType实例相比较。
equals(Object) - Method in class javax.management.remote. JMXPrincipal
将指定的对象与此 JMXPrincipal进行比较以获得相等性。
equals(Object) - Method in class javax.management.remote. JMXServiceURL
指示一些其他对象是否等于此。
equals(Object) - Method in class javax.naming. BinaryRefAddr
确定obj是否等于此地址。
equals(Object) - Method in class javax.naming. CompositeName
确定两个复合名称是否相等。
equals(Object) - Method in class javax.naming. CompoundName
确定obj是否在语法上等于此化合物名称。
equals(Object) - Method in class javax.naming.directory. BasicAttribute
确定obj是否等于此属性。
equals(Object) - Method in class javax.naming.directory. BasicAttributes
确定此 BasicAttributes是否等于另一个 Attributes两个 Attributes如果都是 Attributes实例，则 Attributes ，以相同的方式处理属性ID的情况，并包含相同的属性。
equals(Object) - Method in class javax.naming.ldap. LdapName
确定两个LDAP名称是否相等。
equals(Object) - Method in class javax.naming.ldap. Rdn
将指定的对象与此Rdn进行比较以获得相等性。
equals(Object) - Method in class javax.naming. RefAddr
确定obj是否等于此RefAddr。
equals(Object) - Method in class javax.naming. Reference
确定obj是否是具有与该引用相同的地址（以相同的顺序）的引用。
equals(Object) - Method in class javax.net.ssl. SNIHostName
将此服务器名称与指定对象进行比较。
equals(Object) - Method in class javax.net.ssl. SNIServerName
指示某个其他对象是否等于此服务器名称。
equals(Object) - Method in interface javax.print.attribute. AttributeSet
将指定的对象与此属性集进行比较，以便相等。
equals(Object) - Method in class javax.print.attribute. DateTimeSyntax
返回此日期时间属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute. HashAttributeSet
将指定的对象与此属性集进行比较，以便相等。
equals(Object) - Method in class javax.print.attribute. IntegerSyntax
返回此整数属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute. ResolutionSyntax
返回此分辨率属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute. SetOfIntegerSyntax
返回此整数属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute. Size2DSyntax
返回此二维大小属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. Copies
返回此副本属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. CopiesSupported
返回此副本支持的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. DateTimeAtCompleted
返回完成属性中的此日期时间是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. DateTimeAtCreation
返回创建时的此date-time属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. DateTimeAtProcessing
返回处理属性中的此日期时间是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. Destination
返回此目标属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. DocumentName
返回此文档名称属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobHoldUntil
返回此作业是否保持，直到attribute等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobImpressions
返回此作业展示属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobImpressionsCompleted
返回此作业展示完成属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobImpressionsSupported
返回此作业展示支持的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobKOctets
返回此作业K octets属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobKOctetsProcessed
返回此作业K个八位字节处理的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobKOctetsSupported
返回此作业K字节支持的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobMediaSheets
返回此作业介质页属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobMediaSheetsCompleted
返回此作业介质单的完成属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobMediaSheetsSupported
返回此作业介质页支持的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobMessageFromOperator
返回来自operator属性的此作业消息是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobName
返回此作业名称属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobOriginatingUserName
返回此作业发起用户名属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobPriority
返回此作业优先级属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. JobPrioritySupported
返回此作业优先级支持的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. Media
返回此media属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. MediaPrintableArea
返回此介质边距属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. MediaSize
返回此media size属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. NumberOfDocuments
返回此数量的文档属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. NumberOfInterveningJobs
返回此数量的介入作业属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. NumberUp
返回此数字up属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. NumberUpSupported
返回此数字支持的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. OutputDeviceAssigned
返回此输出设备分配的属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PageRanges
返回此页面范围属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PagesPerMinute
返回此页面每分钟属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PagesPerMinuteColor
返回此页面每分钟的颜色属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterInfo
返回此打印机信息属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterLocation
返回此打印机位置属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterMakeAndModel
返回此打印机的make和model属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterMessageFromOperator
返回来自operator属性的此打印机消息是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterMoreInfo
返回此打印机的更多信息属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterMoreInfoManufacturer
返回此打印机更多信息制造商属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterName
返回此打印机名称属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterResolution
返回此打印机分辨率属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. PrinterURI
返回此打印机名称属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. QueuedJobCount
返回此排队的作业计数属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute.standard. RequestingUserName
返回此请求用户名属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute. TextSyntax
返回此文本属性是否等同于传入的对象。
equals(Object) - Method in class javax.print.attribute. URISyntax
返回此URI属性是否等同于传入的对象。
equals(Object) - Method in class javax.print. DocFlavor
确定此文档flavor对象是否等于给定对象。
equals(Object) - Method in interface javax.print. PrintService
确定两个服务是否指向相同的底层服务。
equals(Object) - Method in class javax.rmi.CORBA. Stub
比较两个存根的平等。
equals(Object) - Method in class javax.rmi.ssl. SslRMIClientSocketFactory
指示一些其他对象是否等于此。
equals(Object) - Method in class javax.rmi.ssl. SslRMIServerSocketFactory
指示一些其他对象是否等于此。
equals(Object) - Method in class javax.security.auth.kerberos. DelegationPermission
检查两个DelegatorPermission对象是否相等。
equals(Object) - Method in class javax.security.auth.kerberos. EncryptionKey
将指定的对象与此键进行比较以获得相等性。
equals(Object) - Method in class javax.security.auth.kerberos. KerberosCredMessage
将指定的对象与此 KerberosCredMessage进行比较以获得相等性。
equals(Object) - Method in class javax.security.auth.kerberos. KerberosKey
将指定的对象与此 KerberosKey进行比较以获得相等性。
equals(Object) - Method in class javax.security.auth.kerberos. KerberosPrincipal
将指定的对象与此主体进行比较以获得相等性。
equals(Object) - Method in class javax.security.auth.kerberos. KerberosTicket
将指定的对象与此 KerberosTicket进行比较以获得相等性。
equals(Object) - Method in class javax.security.auth.kerberos. KeyTab
将指定的对象与此 KeyTab进行比较以获得相等性。
equals(Object) - Method in class javax.security.auth.kerberos. ServicePermission
检查两个ServicePermission对象是否相等。
equals(Object) - Method in class javax.security.auth. PrivateCredentialPermission
检查两个 PrivateCredentialPermission对象的相等性。
equals(Object) - Method in class javax.security.auth. Subject
将指定的对象与此 Subject进行比较以获得相等性。
equals(Object) - Method in class javax.security.auth.x500. X500Principal
将指定的 Object与此 X500Principal进行比较以获得相等性。
equals(Object) - Method in class javax.security.cert. Certificate
已过时。
将此证书与指定的对象进行比较。
equals(Object) - Method in class javax.smartcardio. ATR
将指定的对象与此ATR进行比较以获得相等性。
equals(Object) - Method in class javax.smartcardio. CardPermission
将指定的对象与此CardPermission进行比较以获得相等性。
equals(Object) - Method in class javax.smartcardio. CommandAPDU
将指定的对象与此命令APDU相比较。
equals(Object) - Method in class javax.smartcardio. ResponseAPDU
将指定的对象与此响应APDU进行比较以获得相等性。
equals(Object) - Method in class javax.sound.midi. MidiDevice.Info
报告两个对象是否相等。
equals(Object) - Method in class javax.sound.midi. Sequencer.SyncMode
确定两个对象是否相等。
equals(Object) - Method in class javax.sound.sampled. AudioFileFormat.Type
完成equals方法。
equals(Object) - Method in class javax.sound.sampled. AudioFormat.Encoding
完成equals方法。
equals(Object) - Method in class javax.sound.sampled. Control.Type
完成equals方法。
equals(Object) - Method in class javax.sound.sampled. LineEvent.Type
指示指定的对象是否等于此事件类型，如果对象相同，则返回 true 。
equals(Object) - Method in class javax.sound.sampled. Mixer.Info
指示两个信息对象是否相等，如果它们相同，则返回 true 。
equals(Object) - Method in class javax.sound.sampled. Port.Info
完成equals方法。
equals(Object) - Method in class javax.sound.sampled. ReverbType
指示指定的对象是否等于此混响类型，如果对象相同，则返回 true 。
equals(Object) - Method in class javax.sql.rowset.serial. SerialArray
将此SerialArray与指定的对象进行比较。
equals(Object) - Method in class javax.sql.rowset.serial. SerialBlob
将此SerialBlob与指定对象进行比较。
equals(Object) - Method in class javax.sql.rowset.serial. SerialClob
将此SerialClob与指定对象进行比较。
equals(Object) - Method in class javax.sql.rowset.serial. SerialDatalink
将此 SerialDatalink与指定对象进行比较。
equals(Object) - Method in class javax.sql.rowset.serial. SerialJavaObject
将此SerialJavaObject与指定的对象进行比较。
equals(Object) - Method in class javax.sql.rowset.serial. SerialRef
将此SerialRef与指定的对象进行比较。
equals(Object) - Method in class javax.sql.rowset.serial. SerialStruct
将此SerialStruct与指定对象进行比较。
equals(Object) - Method in class javax.swing. RowSorter.SortKey
如果此对象等于指定的对象，则返回true。
equals(Object) - Method in class javax.swing.text. DefaultCaret
将此对象与指定的对象进行比较。
equals(Object) - Method in class javax.swing.text.html. HTML.UnknownTag
将此对象与指定的对象进行比较。
equals(Object) - Method in class javax.swing.text. SimpleAttributeSet
将此对象与指定的对象进行比较。
equals(Object) - Method in class javax.swing.text. StyleContext.SmallAttributeSet
将此对象与指定的对象进行比较。
equals(Object) - Method in class javax.swing.text. TabSet
指示这个 TabSet是否等于另一个。
equals(Object) - Method in class javax.swing.text. TabStop
如果选项卡相等则返回true。
equals(Object) - Method in class javax.swing.tree. TreePath
将此 TreePath与指定对象进行比较。
equals(Object) - Method in class javax.xml.datatype. Duration
检查此持续时间对象是否与另一个 Duration对象具有相同的持续时间。
equals(Object) - Method in class javax.xml.datatype. XMLGregorianCalendar
将此日历与指定的对象进行比较。
equals(Object) - Method in class javax.xml.namespace. QName
测试这个 QName与另一个 Object平等。
equals(Object) - Method in class jdk.dynalink. CallSiteDescriptor
如果此调用站点描述符等于传递的对象，则返回true。
equals(Object) - Method in class jdk.dynalink. NamedOperation
将此命名操作与另一个对象进行比较。
equals(Object) - Method in class jdk.dynalink. NamespaceOperation
如果另一个对象也是命名空间操作，并且它们的基本操作和命名空间相等，则返回true。
equals(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
equals(Object) - Method in class org.ietf.jgss. ChannelBinding
比较两个ChannelBinding实例。
equals(Object) - Method in interface org.ietf.jgss. GSSCredential
测试此GSSCredential是否与提供的对象断言相同的实体。
equals(Object) - Method in interface org.ietf.jgss. GSSName
与此相比 GSSName对象的另一个对象可能是 GSSName 。
equals(Object) - Method in class org.ietf.jgss. Oid
测试两个Oid对象是否表示相同的对象标识符值。
equals(Object) - Method in class org.omg.CORBA.portable. ObjectImpl
将此 ObjectImpl对象与给定的对象进行比较以获得相等性。
equals(Object[], int, int, Object[], int, int) - Static method in class java.util. Arrays
如果两个指定的对象数组在指定范围内彼此 相等 ，则返回true。
equals(Object[], Object[]) - Static method in class java.util. Arrays
如果两个指定的对象数组彼此 相等 ，则返回 true 。
equals(Object, Object) - Static method in class java.util. Objects
返回 true如果参数相等，彼此 false否则。
equals(String) - Method in class java.awt.datatransfer. DataFlavor
已过时。
与hashCode()合同不一致，请改用DataFlavor.isMimeTypeEqual(String) 。
equals(String, String) - Method in class java.text. Collator
基于此Collator的排序规则比较两个字符串的相等性的便利方法。
equals(URL, URL) - Method in class java.net. URLStreamHandler
提供默认的equals计算。
equals(Timestamp) - Method in class java.sql. Timestamp
测试这个 Timestamp对象是否等于给定的 Timestamp对象。
equals(Stub, Object) - Method in interface javax.rmi.CORBA. StubDelegate
代表团要求 Stub.equals(java.lang.Object) 。
equals(GSSName) - Method in interface org.ietf.jgss. GSSName
比较两个 GSSName对象，以确定它们是否引用相同的实体。
equals(Object, Object) - Method in class org.omg.CORBA.portable. Delegate
提供实现来覆盖委托CORBA对象的equals（java.lang.Object obj）方法。
equals(T[], int, int, T[], int, int, Comparator<? super T>) - Static method in class java.util. Arrays
如果两个指定的对象数组在指定范围内彼此 相等 ，则返回true。
equals(T[], T[], Comparator<? super T>) - Static method in class java.util. Arrays
如果两个指定的对象数组彼此 相等 ，则返回 true 。
EQUALS - javafx.scene.input. KeyCode
等于键的常数，“=”
equalsIgnoreCase(String) - Method in class java.lang. String
将此 String与另一个 String比较，忽略案例注意事项。
equalsIgnoreOptional(Object) - Method in class java.lang. Runtime.Version
确定此 Version是否等于另一个忽略可选构建信息。
equivalent(TypeCode) - Method in class org.omg.CORBA. TypeCode
测试看看给定的 TypeCode对象是否等同于这个 TypeCode对象。
Era - Interface in java.time.chrono
时代的时代。
ERA - java.time.temporal. ChronoField
时代。
ERA - Static variable in class java.text. DateFormat.Field
不断识别时代领域。
ERA - Static variable in class java.util. Calendar
get字段编号和 set表示时代，例如，在儒略历中的AD或BC。
ERA_FIELD - Static variable in class java.text. DateFormat
ERA场对齐的有用常数。
eraOf(int) - Method in interface java.time.chrono. Chronology
根据数值创建年代时代对象。
eraOf(int) - Method in class java.time.chrono. HijrahChronology
从数值创建HijrahEra对象。
eraOf(int) - Method in class java.time.chrono. IsoChronology
eraOf(int) - Method in class java.time.chrono. JapaneseChronology
从给定的数值返回日历系统时代对象。
eraOf(int) - Method in class java.time.chrono. MinguoChronology
eraOf(int) - Method in class java.time.chrono. ThaiBuddhistChronology
eras() - Method in interface java.time.chrono. Chronology
获取年表的时间列表。
eras() - Method in class java.time.chrono. HijrahChronology
eras() - Method in class java.time.chrono. IsoChronology
eras() - Method in class java.time.chrono. JapaneseChronology
eras() - Method in class java.time.chrono. MinguoChronology
eras() - Method in class java.time.chrono. ThaiBuddhistChronology
ERAS - java.time.temporal. ChronoUnit
代表一个时代概念的单位。
erase() - Method in class java.lang.invoke. MethodType
删除所有引用类型到 Object 。
erasure(TypeMirror) - Method in interface javax.lang.model.util. Types
返回类型的擦除。
ERGONOMIC - com.sun.management. VMOption.Origin
VM选项通过VM人机工程学支持设置。
err - Static variable in class java.io. FileDescriptor
标准错误流的句柄。
err - Static variable in class java.lang. System
“标准”错误输出流。
err(PrintStream) - Method in class jdk.jshell. JShell.Builder
设置运行评估的错误输出（它是 System.err ）。
err(PrintStream) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置错误通道。
err(PrintStream, PrintStream) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置错误通道。
ERRONEOUS - com.sun.source.doctree. DocTree.Kind
用于表示一些无效文本的ErroneousTree的实例。
ERRONEOUS - com.sun.source.tree. Tree.Kind
用于ErroneousTree的实例。
ERRONEOUS - jdk.jshell. Snippet.Kind
无法确定特定类型的语法不正确的输入。
ErroneousSnippet - Class in jdk.jshell
一段代码无效的Java编程语言代码。
ErroneousTree - Interface in com.sun.source.doctree
一个树状节点，用于生成格式不正确的文本
ErroneousTree - Interface in com.sun.source.tree
一个树形节点，用于支撑格式不正确的表达式。
ErroneousTree - Interface in jdk.nashorn.api.tree
一个树形节点，用于支撑格式不正确的表达式。
error(String) - Method in class javax.swing.text.html.parser. Parser
使用第1，第2和第3个错误消息参数“？”调用错误处理程序。
error(String, Exception, int) - Method in class java.util.logging. ErrorManager
发生处理程序失败时调用错误方法。
error(String, String) - Method in class javax.swing.text.html.parser. Parser
使用第2和第3个错误消息参数“？”调用错误处理程序。
error(String, String, String) - Method in class javax.swing.text.html.parser. Parser
使用第三个错误消息参数“？”调用错误处理程序。
error(String, String, String, String) - Method in class javax.swing.text.html.parser. Parser
调用错误处理程序。
error(TransformerException) - Method in interface javax.xml.transform. ErrorListener
接收可恢复错误的通知。
error(SAXParseException) - Method in interface org.xml.sax. ErrorHandler
接收可恢复错误的通知。
error(SAXParseException) - Method in class org.xml.sax. HandlerBase
已过时。
接收可解析解析器错误的通知。
error(SAXParseException) - Method in class org.xml.sax.helpers. DefaultHandler
接收可解析解析器错误的通知。
error(SAXParseException) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤错误事件。
Error - Error in java.lang
一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
Error() - Constructor for error java.lang. Error
构造一个新的错误 null作为其详细信息。
Error(String) - Constructor for error java.lang. Error
使用指定的详细信息构造新的错误。
Error(String, Throwable) - Constructor for error java.lang. Error
构造一个新的错误与指定的详细信息和原因。
Error(String, Throwable, boolean, boolean) - Constructor for error java.lang. Error
构造一个新的错误指定的详细信息，原因，抑制启用或禁用，可写栈跟踪启用或禁用。
Error(Throwable) - Constructor for error java.lang. Error
构造具有指定原因的新错误和详细信息 (cause==null ? null : cause.toString()) （通常包含类别和详细信息为 cause ）。
ERROR - java.awt. Taskbar.State
显示发生错误。
ERROR - java.awt. TrayIcon.MessageType
一个错误消息
ERROR - java.lang. System.Logger.Level
ERROR级别：通常用于记录错误消息。
ERROR - javafx.print. PrinterJob.JobStatus
工作遇到错误。
ERROR - javafx.scene.control. Alert.AlertType
ERROR警报类型配置警报对话框以表明出现问题的方式出现。
ERROR - javax.lang.model.type. TypeKind
无法解析的类或接口类型。
ERROR - javax.tools. Diagnostic.Kind
阻止工具正常完成的问题。
ERROR - jdk.nashorn.api.tree. Diagnostic.Kind
阻止工具正常完成的问题。
ERROR - jdk.nashorn.api.tree. Tree.Kind
用于ErroneousTree的实例。
ERROR - Static variable in interface java.awt.image. ImageObserver
imageUpdate的infoflags参数中的此标志表示正在异步跟踪的图像遇到错误。
ERROR - Static variable in interface java.util.jar. Pack200.Packer
字符串“error”是某些属性的可能值。
ERROR - Static variable in class javax.print.attribute.standard. Severity
表示PrinterStateReason是“错误”（最严重）。
ERROR - Static variable in class javax.security.auth.callback. ConfirmationCallback
错误消息类型。
ERROR - Static variable in class javax.security.auth.callback. TextOutputCallback
错误信息。
ERROR - Static variable in interface javax.xml.bind. ValidationEvent
符合W3C XML 1.0建议书第1.2节“错误”定义的条件
ERROR_DIALOG - Static variable in class javax.swing. JRootPane
用于windowDecorationStyle属性的常量。
ERROR_MESSAGE - Static variable in class javax.swing. JOptionPane
用于错误消息。
ERROR_OPTION - Static variable in class javax.swing. JFileChooser
返回值，如果发生错误。
errorCode - Variable in exception javax.transaction.xa. XAException
用于创建SystemException的错误代码。
errorCode() - Method in exception com.sun.jdi. InternalException
errorCode() - Method in class com.sun.nio.sctp. SendFailedNotification
返回错误代码。
ERRORED - Static variable in class java.awt. MediaTracker
表示媒体的下载遇到错误的标志。
ErrorHandler - Interface in org.xml.sax
SAX错误处理程序的基本界面。
ErrorListener - Interface in javax.xml.transform
要提供自定义错误处理，实现此接口并使用setErrorListener方法注册与执行的实例Transformer 。
ErrorManager - Class in java.util.logging
可以将ErrorManager对象附加到处理程序，以处理在记录期间在处理程序中发生的任何错误。
ErrorManager() - Constructor for class java.util.logging. ErrorManager
ErrorNotification(String, String, Throwable) - Constructor for class javafx.application. Preloader.ErrorNotification
构造错误通知。
errorProperty() - Method in class javafx.scene.image. Image
指示在加载图像时是否检测到错误。
errorProperty() - Method in class javafx.scene.media. Media
发生错误时将属性设置为MediaException值。
errorProperty() - Method in class javafx.scene.media. MediaPlayer
如果出现错误，Observable属性设置为 MediaException 。
errorRaised() - Method in interface javax.annotation.processing. RoundEnvironment
如果在前一轮的处理中出现错误，则返回true ; 否则返回false 。
errors() - Method in interface com.sun.javadoc. PackageDoc
已过时。
获取包含此包中的错误类。
errorsProperty() - Static method in class javafx.css. CssParser
ErrorType - Interface in javax.lang.model.type
表示无法正确建模的类或接口类型。
errorWriter - Variable in class javax.script. SimpleScriptContext
这是用于从脚本输出错误的作者。
ESCAPE - javafx.scene.input. KeyCode
常数为 Esc键。
ESCAPE - Static variable in class java.awt. Event
已过时。
退出键
ESCAPE_PREFIX - Static variable in class javafx.fxml. FXMLLoader
转义属性值内的特殊字符的转义前缀。
escapeValue(Object) - Static method in class javax.naming.ldap. Rdn
给定属性的值，根据 RFC 2253中指定的规则返回一个转义的字符串。
establish_components(IORInfo) - Method in interface org.omg.PortableInterceptor. IORInterceptorOperations
服务器端ORB在组装将包含在对象引用的配置文件或配置文件中的组件的列表时，会对所有已注册的 IORInterceptor实例调用 establish_components操作。
estimateMaximumLag() - Method in class java.util.concurrent. SubmissionPublisher
返回所有当前订阅者中生成但尚未消费的最大项目数量的估计值。
estimateMinimumDemand() - Method in class java.util.concurrent. SubmissionPublisher
在所有当前订阅者中，返回所要求的最小数量（通过 request ）但尚未生成的估计。
estimateSize() - Method in interface java.util. Spliterator
返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果为无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。
estimateSize() - Method in class java.util. Spliterators.AbstractDoubleSpliterator
返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。
estimateSize() - Method in class java.util. Spliterators.AbstractIntSpliterator
返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计，或者如果为无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。
estimateSize() - Method in class java.util. Spliterators.AbstractLongSpliterator
返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计，如果无穷大，未知数或计算成本太高，则返回 Long.MAX_VALUE 。
estimateSize() - Method in class java.util. Spliterators.AbstractSpliterator
返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。
EtchedBorder - Class in javax.swing.border
一个实现一个简单蚀刻边界的课程，可以被蚀刻或蚀刻出来。
EtchedBorder() - Constructor for class javax.swing.border. EtchedBorder
创建一个下降的蚀刻边框，其颜色将从传递到paintBorder方法的组件的背景颜色派生。
EtchedBorder(int) - Constructor for class javax.swing.border. EtchedBorder
使用指定的蚀刻类型创建蚀刻边框，其颜色将从传递到paintBorder方法的组件的背景颜色派生。
EtchedBorder(int, Color, Color) - Constructor for class javax.swing.border. EtchedBorder
使用指定的蚀刻类型，高光和阴影颜色创建蚀刻边框。
EtchedBorder(Color, Color) - Constructor for class javax.swing.border. EtchedBorder
使用指定的高光和阴影颜色创建一个降低的蚀刻边框。
EtchedBorderUIResource() - Constructor for class javax.swing.plaf. BorderUIResource.EtchedBorderUIResource
构造一个 EtchedBorderUIResource 。
EtchedBorderUIResource(int) - Constructor for class javax.swing.plaf. BorderUIResource.EtchedBorderUIResource
构造一个 EtchedBorderUIResource 。
EtchedBorderUIResource(int, Color, Color) - Constructor for class javax.swing.plaf. BorderUIResource.EtchedBorderUIResource
构造一个 EtchedBorderUIResource 。
EtchedBorderUIResource(Color, Color) - Constructor for class javax.swing.plaf. BorderUIResource.EtchedBorderUIResource
构造一个 EtchedBorderUIResource 。
etchType - Variable in class javax.swing.border. EtchedBorder
由边框绘制的蚀刻类型。
etherealize(byte[], POA, Servant, boolean, boolean) - Method in class org.omg.PortableServer. _ServantActivatorStub
假设POA具有USE_SERVANT_MANAGER和RETAIN策略，则每当某个对象的servant被停用时，都会调用此操作。
etherealize(byte[], POA, Servant, boolean, boolean) - Method in interface org.omg.PortableServer. ServantActivatorOperations
假设POA具有USE_SERVANT_MANAGER和RETAIN策略，则每当某个对象的servant被停用时，都会调用此操作。
ETHIOPIC - java.awt.font. NumericShaper.Range
埃塞俄比亚的范围与埃塞俄比亚数字。
ETHIOPIC - java.lang. Character.UnicodeScript
Unicode脚本“埃塞俄比亚”。
ETHIOPIC - Static variable in class java.awt.font. NumericShaper
标识ETHIOPIC范围和十进制基数。
ETHIOPIC - Static variable in class java.lang. Character.UnicodeBlock
“埃塞俄比亚”Unicode字符块的常数。
ETHIOPIC_EXTENDED - Static variable in class java.lang. Character.UnicodeBlock
“埃塞俄比亚扩展”Unicode字符块的常量。
ETHIOPIC_EXTENDED_A - Static variable in class java.lang. Character.UnicodeBlock
“埃塞俄比亚扩展A”Unicode字符块的常量。
ETHIOPIC_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“埃塞俄比亚补编”Unicode字符块的常数。
EURO_SIGN - javafx.scene.input. KeyCode
欧元货币符号键的常数。
EUROPEAN - java.awt.font. NumericShaper.Range
拉丁语（欧洲）范围与拉丁（ASCII）数字。
EUROPEAN - Static variable in class java.awt.font. NumericShaper
确定拉丁语1（欧洲）和扩展范围以及拉丁语1（欧洲）十进制基数。
eval() - Method in class javax.script. CompiledScript
执行存储在 CompiledScript对象中的程序。
eval(Reader) - Method in class javax.script. AbstractScriptEngine
eval(Reader)调用摘要 eval(Reader, ScriptContext)传递 context字段的值。
eval(Reader) - Method in interface javax.script. ScriptEngine
与 eval(String)相同，只是该脚本的来源以 Reader形式提供
eval(Reader, Bindings) - Method in class javax.script. AbstractScriptEngine
eval(Reader, Bindings)调用抽象的 eval(Reader, ScriptContext)方法，传递一个 ScriptContext其读取器，作者和绑定的其他 ENGINE_SCOPE与受保护的 context字段的成员相同。
eval(Reader, Bindings) - Method in interface javax.script. ScriptEngine
与 eval(String, Bindings)相同，只是该脚本的来源以 Reader形式提供。
eval(Reader, ScriptContext) - Method in interface javax.script. ScriptEngine
与 eval(String, ScriptContext)相同，其中脚本的来源从 Reader读取。
eval(Reader, ScriptContext) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine
eval(String) - Method in class javax.script. AbstractScriptEngine
与 eval(Reader)相同，但使用摘要 eval(String, ScriptContext) 。
eval(String) - Method in interface javax.script. ScriptEngine
执行指定的脚本。
eval(String) - Method in class jdk.jshell. JShell
评估输入字符串，包括定义和/或执行（如果适用）。
eval(String) - Method in class jdk.nashorn.api.scripting. AbstractJSObject
eval(String) - Method in interface jdk.nashorn.api.scripting. JSObject
评估JavaScript表达式。
eval(String) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
eval(String) - Method in class netscape.javascript. JSObject
评估JavaScript表达式。
eval(String, Bindings) - Method in class javax.script. AbstractScriptEngine
与 eval(Reader, Bindings)相同，但使用摘要 eval(String, ScriptContext) 。
eval(String, Bindings) - Method in interface javax.script. ScriptEngine
执行使用该脚本 Bindings参数为 ENGINE_SCOPE Bindings的的 ScriptEngine的脚本执行期间。
eval(String, ScriptContext) - Method in interface javax.script. ScriptEngine
导致立即执行脚本，其脚本是作为第一个参数传递的String。
eval(String, ScriptContext) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine
eval(Bindings) - Method in class javax.script. CompiledScript
在脚本执行期间，使用提供的 Bindings属性作为相关联的 ScriptEngine的 ENGINE_SCOPE执行存储在 CompiledScript对象中的程序。
eval(ScriptContext) - Method in class javax.script. CompiledScript
执行存储在此 CompiledScript对象中的程序。
EvalException - Exception in jdk.jshell
封装在远程执行客户机中抛出的异常。
evaluate(Object) - Method in interface javax.xml.xpath. XPathExpression
在指定的上下文中评估编译的XPath表达式，并将结果作为 String返回。
evaluate(Object, int) - Method in interface javax.sql.rowset. Predicate
该方法由 FilteredRowSet对象调用，以检查值是否位于使用 setFilter()方法设置的过滤标准（或存在多个约束的条件） setFilter() 。
evaluate(Object, String) - Method in interface javax.sql.rowset. Predicate
该方法由 FilteredRowSet对象调用，以检查该值是否位于使用setFilter方法设置的过滤条件之间。
evaluate(Object, QName) - Method in interface javax.xml.xpath. XPathExpression
在指定的上下文中评估编译的XPath表达式，并将结果作为指定的类型返回。
evaluate(String, Object) - Method in interface javax.xml.xpath. XPath
在指定的上下文中评估XPath表达式，并将结果作为 String返回。
evaluate(String, Object, QName) - Method in interface javax.xml.xpath. XPath
在指定的上下文中评估一个 XPath表达式，并将结果作为指定的类型返回。
evaluate(String, Node, XPathNSResolver, short, Object) - Method in interface org.w3c.dom.xpath. XPathEvaluator
评估XPath表达式字符串，如果可能，返回指定类型的结果。
evaluate(String, InputSource) - Method in interface javax.xml.xpath. XPath
在指定的 InputSource的上下文中评估XPath表达式，并将结果作为 String返回。
evaluate(String, InputSource, QName) - Method in interface javax.xml.xpath. XPath
在指定的 InputSource的上下文中评估XPath表达式，并返回结果作为指定的类型。
evaluate(List) - Method in interface javax.xml.xpath. XPathFunction
用指定的参数来评估函数。
evaluate(RowSet) - Method in interface javax.sql.rowset. Predicate
这个方法通常被称为一个 FilteredRowSet对象的内部方法（不是public），它控制着 RowSet对象的光标从一行移动到另一个。
evaluate(Node, short, Object) - Method in interface org.w3c.dom.xpath. XPathExpression
评估此XPath表达式并返回结果。
evaluate(InputSource) - Method in interface javax.xml.xpath. XPathExpression
在指定的 InputSource的上下文中评估编译的XPath表达式，并将结果作为 String返回。
evaluate(InputSource, QName) - Method in interface javax.xml.xpath. XPathExpression
在指定的 InputSource的上下文中评估编译的XPath表达式，并将结果作为指定的类型返回。
evaluateChallenge(byte[]) - Method in interface javax.security.sasl. SaslClient
评估挑战数据并产生响应。
evaluateExpression(Object) - Method in interface javax.xml.xpath. XPathExpression
在指定的上下文中评估编译的XPath表达式。
evaluateExpression(Object, Class<T>) - Method in interface javax.xml.xpath. XPathExpression
评估在指定上下文中编译的XPath表达式，并返回具有通过 class type指定的类型的结果。
evaluateExpression(String, Object) - Method in interface javax.xml.xpath. XPath
评估指定上下文中的XPath表达式。
evaluateExpression(String, Object, Class<T>) - Method in interface javax.xml.xpath. XPath
在指定的上下文中评估一个XPath表达式，并通过 class type指定的类型返回结果
evaluateExpression(String, InputSource) - Method in interface javax.xml.xpath. XPath
评估指定上下文中的XPath表达式。
evaluateExpression(String, InputSource, Class<T>) - Method in interface javax.xml.xpath. XPath
在指定的 source的上下文中评估XPath表达式，并返回指定的结果。
evaluateExpression(InputSource) - Method in interface javax.xml.xpath. XPathExpression
在指定的上下文中评估编译的XPath表达式。
evaluateExpression(InputSource, Class<T>) - Method in interface javax.xml.xpath. XPathExpression
评估在指定上下文中编译的XPath表达式，并返回结果，其类型通过 class type指定
evaluateResponse(byte[]) - Method in interface javax.security.sasl. SaslServer
评估响应数据并产生挑战。
EVEN_ODD - javafx.scene.shape. FillRule
定义用于确定路径内部的偶数填充规则。
event - Variable in exception javax.swing.tree. ExpandVetoException
创建异常的事件。
event() - Method in class com.sun.nio.sctp. AssociationChangeNotification
返回更改事件的类型。
event() - Method in class com.sun.nio.sctp. PeerAddressChangeNotification
返回更改事件的类型。
Event - Class in java.awt
已过时。
建议使用AWTEvent及其子类
Event - Class in javafx.event
FX事件的基础类。
Event - Interface in com.sun.jdi.event
调试器感兴趣的目标虚拟机中的一个事件。
Event - Interface in org.w3c.dom.events
Event接口用于向事件处理程序提供有关事件的上下文信息。
Event(Object, int, Object) - Constructor for class java.awt. Event
已过时。
注意： Event类已过时，仅适用于向后兼容性。
Event(Object, long, int, int, int, int, int) - Constructor for class java.awt. Event
已过时。
注意： Event类已过时，仅适用于向后兼容性。
Event(Object, long, int, int, int, int, int, Object) - Constructor for class java.awt. Event
已过时。
注意： Event课程已经过时，仅适用于向后兼容性。
Event(Object, EventTarget, EventType<? extends Event>) - Constructor for class javafx.event. Event
构造一个新的 Event与指定的事件源，目标和类型。
Event(EventType<? extends Event>) - Constructor for class javafx.event. Event
构造具有指定事件类型的新的 Event 。
EVENT_HANDLER_PREFIX - Static variable in class javafx.fxml. FXMLLoader
事件处理程序属性的前缀。
EVENT_KEY - Static variable in class javafx.fxml. FXMLLoader
事件处理程序脚本中Event对象的名称。
EventContext - Interface in javax.naming.event
包含用于注册/注销侦听器的方法，以通知在上下文中命名的对象发生变化时触发的事件。
EventDirContext - Interface in javax.naming.event
包含用于注册侦听器的方法，以便在目录上下文中指定的对象更改时触发的事件被通知。
EventDispatchChain - Interface in javafx.event
代表 EventDispatcher对象的链接，可以发送一个 Event 。
eventDispatched(AWTEvent) - Method in class com.sun.java.accessibility.util. EventQueueMonitor
因为在EventQueueMonitor.maybeInitialize()的EventQueue注册一个监听器来处理事件。
eventDispatched(AWTEvent) - Method in interface java.awt.event. AWTEventListener
在AWT中调度事件时调用。
eventDispatched(AWTEvent) - Method in class java.awt.event. AWTEventListenerProxy
将AWT事件转发给侦听器代理。
eventDispatched(AWTEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理 AWTEvent s为 JLayer及其 所有后代到这个 LayerUI实例。
EventDispatcher - Interface in javafx.event
一个 EventDispatcher代表一个事件调度和处理实体。
eventDispatcherProperty() - Method in class javafx.scene. Node
指定此节点的事件分派器。
eventDispatcherProperty() - Method in class javafx.scene. Scene
指定此场景的事件调度程序。
eventDispatcherProperty() - Method in class javafx.stage. Window
指定此节点的事件分派器。
EventException - Exception in org.w3c.dom.events
事件操作可能会抛出方法描述中指定的 EventException 。
EventException(short, String) - Constructor for exception org.w3c.dom.events. EventException
EventFilter - Interface in javax.xml.stream
该接口声明一个可以创建过滤XMLEventReaders的简单过滤器接口
eventHandler(BiConsumer<String, String>) - Method in class jdk.security.jarsigner. JarSigner.Builder
设置当在签名过程中添加，签名或更新JarEntry时将触发的事件处理程序。
EventHandler - Class in java.beans
EventHandler类提供对动态生成事件侦听器的支持，该侦听器的方法执行涉及传入事件对象和目标对象的简单语句。
EventHandler< T extends Event> - Interface in javafx.event
处理程序用于特定类/类型的事件。
EventHandler(Object, String, String, String) - Constructor for class java.beans. EventHandler
创建一个新的EventHandler对象; 你通常使用create方法之一，而不是直接调用这个构造函数。
EventID - Class in com.sun.java.accessibility.util
EventID包含映射到AWT和Swing中的事件支持的整型常量。
EventID() - Constructor for class com.sun.java.accessibility.util. EventID
eventIterator() - Method in interface com.sun.jdi.event. EventSet
返回特定于Event个对象的迭代器。
EventIterator - Interface in com.sun.jdi.event
EventIterators是不可修改的。
EventListener - Interface in java.util
所有事件侦听器接口必须扩展的标记接口。
EventListener - Interface in org.w3c.dom.events
EventListener接口是处理事件的主要方法。
EventListenerList - Class in javax.swing.event
一个持有EventListener列表的类。
EventListenerList() - Constructor for class javax.swing.event. EventListenerList
EventListenerProxy< T extends EventListener> - Class in java.util
一个 EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。
EventListenerProxy(T) - Constructor for class java.util. EventListenerProxy
为指定的侦听器创建代理。
EventObject - Class in java.util
所有事件状态对象应从其派生的根类。
EventObject(Object) - Constructor for class java.util. EventObject
构建一个典型的事件。
eventQueue() - Method in interface com.sun.jdi. VirtualMachine
返回此虚拟机的事件队列。
EventQueue - Class in java.awt
EventQueue是一个独立于平台的类，可以从基础对等体类和可信应用程序类排队事件。
EventQueue - Interface in com.sun.jdi.event
目标虚拟机的调试器事件管理器。
EventQueue() - Constructor for class java.awt. EventQueue
初始化一个新的实例 EventQueue 。
EventQueueMonitor - Class in com.sun.java.accessibility.util
EventQueueMonitor类为辅助技术提供了关键的核心功能（以及需要辅助技术需要的一些相同功能的其他系统级技术）。
EventQueueMonitor() - Constructor for class com.sun.java.accessibility.util. EventQueueMonitor
创建一个新的 EventQueueMonitor实例。
EventReaderDelegate - Class in javax.xml.stream.util
这是导出XMLEventReader过滤器的基类。
EventReaderDelegate() - Constructor for class javax.xml.stream.util. EventReaderDelegate
构造一个没有父进程的空过滤器。
EventReaderDelegate(XMLEventReader) - Constructor for class javax.xml.stream.util. EventReaderDelegate
使用指定的父构造一个过滤器。
EventRequest - Interface in com.sun.jdi.request
表示通知事件的请求。
eventRequestManager() - Method in interface com.sun.jdi. VirtualMachine
返回此虚拟机的事件请求管理器。
EventRequestManager - Interface in com.sun.jdi.request
管理创建和删除EventRequest s。
events - Variable in class java.awt.dnd. DragGestureRecognizer
事件列表（按顺序）， DragGestureRecognizer “识别”为触发拖动的“手势”。
EventSet - Interface in com.sun.jdi.event
可以在给定时间由目标VirtualMachine创建几个Event对象。
EventSetDescriptor - Class in java.beans
EventSetDescriptor描述给定的Java Bean触发的一组事件。
EventSetDescriptor(Class<?>, String, Class<?>, String) - Constructor for class java.beans. EventSetDescriptor
创建一个 EventSetDescriptor假设您遵循最简单的标准设计模式，其中一个命名事件“fred”（1）作为一个调用方式传递给接口FredListener的单一方法，（2）具有类型为FredEvent的单个参数和（ 3）FredListener可以通过对源组件的addFredListener方法的调用进行注册，并通过removeFredListener方法的调用进行删除。
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String) - Constructor for class java.beans. EventSetDescriptor
使用字符串名称从头创建一个 EventSetDescriptor 。
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String, String) - Constructor for class java.beans. EventSetDescriptor
该构造函数使用字符串名称从头开始创建一个EventSetDescriptor。
EventSetDescriptor(String, Class<?>, MethodDescriptor[], Method, Method) - Constructor for class java.beans. EventSetDescriptor
使用 java.lang.reflect.MethodDescriptor和 java.lang.Class对象从头创建一个 EventSetDescriptor 。
EventSetDescriptor(String, Class<?>, Method[], Method, Method) - Constructor for class java.beans. EventSetDescriptor
创建一个 EventSetDescriptor使用从无到有 java.lang.reflect.Method个 java.lang.Class对象。
EventSetDescriptor(String, Class<?>, Method[], Method, Method, Method) - Constructor for class java.beans. EventSetDescriptor
此构造函数从头开始使用java.lang.reflect.Method和java.lang.Class对象创建一个EventSetDescriptor。
EventTarget - Interface in javafx.event
表示事件目标。
EventTarget - Interface in org.w3c.dom.events
EventTarget接口由支持DOM事件模型的实现中的所有 Nodes实现。
eventType - Variable in class javafx.event. Event
事件的类型。
EventType< T extends Event> - Class in javafx.event
此类表示与 Event相关联的特定事件类型。
EventType() - Constructor for class javafx.event. EventType
已过时。
不要使用这个构造函数，因为只有一个这样的EventType可以存在
EventType(String) - Constructor for class javafx.event. EventType
构造具有指定名称的新的 EventType和作为其超类型的 EventType.ROOT 。
EventType(EventType<? super T>) - Constructor for class javafx.event. EventType
构造一个新的 EventType具有指定的超类型，名称设置为 null 。
EventType(EventType<? super T>, String) - Constructor for class javafx.event. EventType
构造具有指定的超类型和名称的新的 EventType 。
eventTypeEnabled(int) - Method in class java.awt. ScrollPane
如果启用滚动滚动，我们将为MouseWheelEvents返回true
evt - Variable in class java.awt. Event
已过时。
下一个事件。
EX - javafx.css. SizeUnits
exactInvoker(MethodType) - Static method in class java.lang.invoke. MethodHandles
生成一个特殊的 调用方法句柄 ，可以用于调用给定类型的任何方法句柄，如同通过 invokeExact一样 。
examineAllHeaderElements() - Method in interface javax.xml.soap. SOAPHeader
返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象。
examineHeaderElements(String) - Method in interface javax.xml.soap. SOAPHeader
返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象具有指定 演员 。
examineMustUnderstandHeaderElements(String) - Method in interface javax.xml.soap. SOAPHeader
返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象具有指定 演员 ，有一个mustUnderstand属性，其值等于 true 。
ExcC14NParameterSpec - Class in javax.xml.crypto.dsig.spec
W3C推荐参数： Exclusive XML Canonicalization (C14N) algorithm 。
ExcC14NParameterSpec() - Constructor for class javax.xml.crypto.dsig.spec. ExcC14NParameterSpec
创建一个空的前缀列表的 ExcC14NParameterSpec 。
ExcC14NParameterSpec(List<String>) - Constructor for class javax.xml.crypto.dsig.spec. ExcC14NParameterSpec
创建具有指定的前缀列表的 ExcC14NParameterSpec 。
EXCEEDS_PAD - java.time.format. SignStyle
如果该值超过焊盘宽度，样式总是输出符号。
ExcellentBreakWeight - Static variable in class javax.swing.text. View
指示视图的重量支持打破，这代表了一个非常有吸引力的地方打破。
except - Variable in exception org.omg.CORBA. UnknownUserException
包含由服务器抛出的实际用户异常的 Any实例。
except(Any) - Method in class org.omg.CORBA. ServerRequest
已过时。
使用set_exception（）
exception() - Method in interface com.sun.javadoc. ThrowsTag
已过时。
返回代表异常的 ClassDoc 。
exception() - Method in interface com.sun.jdi.event. ExceptionEvent
获取抛出的异常对象。
exception() - Method in exception com.sun.jdi. InvocationException
exception() - Method in interface com.sun.jdi.request. ExceptionRequest
返回异常事件被请求的异常类型。
exception() - Method in class jdk.jshell. SnippetEvent
实例UnresolvedReferenceException ，如果遇到未解决的参考，或实例EvalException如果一个异常在执行过程中抛出，否则null 。
exception() - Method in class org.omg.CORBA. Environment
检索此 Environment对象中的异常。
exception(Exception) - Method in class org.omg.CORBA. Environment
将给定的异常插入到此 Environment对象中。
异常 - Exception in java.lang
类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
Exception() - Constructor for exception java.lang. 异常
构造一个新的异常，其中 null作为其详细信息。
Exception(String) - Constructor for exception java.lang. 异常
使用指定的详细消息构造新的异常。
Exception(String, Throwable) - Constructor for exception java.lang. 异常
构造一个新的异常与指定的详细信息和原因。
Exception(String, Throwable, boolean, boolean) - Constructor for exception java.lang. 异常
构造一个新的异常，指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
Exception(Throwable) - Constructor for exception java.lang. 异常
构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
EXCEPTION - com.sun.source.doctree. DocTree.Kind
用于表示@exception标签的ThrowsTree的实例。
EXCEPTION_PARAMETER - javax.lang.model.element. ElementKind
异常处理程序的参数。
exceptionally(Function<Throwable, ? extends T>) - Method in class java.util.concurrent. CompletableFuture
返回一个新的CompletableFuture，当CompletableFuture完成时完成，结果是异常触发此CompletableFuture的完成特殊功能的给定功能; 否则，如果此CompletableFuture正常完成，则返回的CompletableFuture也会以相同的值正常完成。
exceptionally(Function<Throwable, ? extends T>) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当此阶段完成异常时，将以此阶段的异常作为提供函数的参数执行。
exceptionComment() - Method in interface com.sun.javadoc. ThrowsTag
已过时。
返回与此 ThrowsTag关联的异常注释。
ExceptionDetailMessage - Interface in org.omg.IOP
org / omg / IOP / ExceptionDetailMessage.java。
ExceptionEvent - Interface in com.sun.jdi.event
通知目标VM中的异常。
ExceptionInInitializerError - Error in java.lang
表示在静态初始化程序中发生意外异常。
ExceptionInInitializerError() - Constructor for error java.lang. ExceptionInInitializerError
构造一个 ExceptionInInitializerError其中包含 null作为其详细消息字符串，没有保存的可抛物体。
ExceptionInInitializerError(String) - Constructor for error java.lang. ExceptionInInitializerError
构造具有指定的详细消息字符串的ExceptionInInitializerError。
ExceptionInInitializerError(Throwable) - Constructor for error java.lang. ExceptionInInitializerError
构造一个新的 ExceptionInInitializerError类，保存对 Throwable对象的引用，以便稍后通过 ExceptionInInitializerError.getException()方法检索。
ExceptionList - Class in org.omg.CORBA
在 Request操作中使用的对象来描述方法可以抛出的异常。
ExceptionList() - Constructor for class org.omg.CORBA. ExceptionList
ExceptionListener - Interface in java.beans
通知内部异常的ExceptionListener。
exceptionName() - Method in interface com.sun.javadoc. ThrowsTag
已过时。
返回与此 ThrowsTag相关联的异常的名称。
exceptionProperty() - Method in class javafx.concurrent. Service
exceptionProperty() - Method in class javafx.concurrent. Task
exceptionProperty() - Method in interface javafx.concurrent. Worker
获取表示发生的任何异常的ReadOnlyObjectProperty。
exceptionProperty() - Method in class javafx.scene.image. Image
导致图像加载失败的异常。
ExceptionRequest - Interface in com.sun.jdi.request
在目标虚拟机发生异常时请求通知。
exceptionRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的异常请求的不可修改的列表。
exceptions() - Method in interface com.sun.javadoc. PackageDoc
已过时。
在此包中包含异常类。
exceptions() - Method in class org.omg.CORBA. Request
检索此请求的 ExceptionList对象。
exceptions() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
返回一个 TypeCode对象的数组，描述这个操作调用可能抛出的用户异常的 TypeCode 。
exceptionThrown(Exception) - Method in interface java.beans. ExceptionListener
当可捕获的异常被捕获时，调用此方法。
exceptionType() - Method in interface com.sun.javadoc. ThrowsTag
已过时。
返回与此 ThrowsTag相关联的异常的类型。
exchange(V) - Method in class java.util.concurrent. Exchanger
等待另一个线程到达此交换点（除非当前线程为 interrupted ），然后将给定对象传输给它，接收其对象作为回报。
exchange(V, long, TimeUnit) - Method in class java.util.concurrent. Exchanger
等待另一个线程到达此交换点（除非当前线程为 interrupted或指定的等待时间过去），然后将给定对象传输给它，接收其对象作为回报。
Exchanger< V> - Class in java.util.concurrent
线程可以在成对内配对和交换元素的同步点。
Exchanger() - Constructor for class java.util.concurrent. Exchanger
创建一个新的交换器。
EXCLAMATION_MARK - javafx.scene.input. KeyCode
常数为“！”
EXCLUSION - javafx.scene.effect. BlendMode
将两个输入的颜色分量相乘并加倍，然后从底部输入颜色分量的和中减去，以产生所得到的颜色。
exclusions - Variable in class javax.swing.text.html.parser. Element
元素中不能出现的元素集
EXCLUSIVE - Static variable in interface javax.xml.crypto.dsig. CanonicalizationMethod
Exclusive Canonical XML (without comments)规范化方法算法URI。
EXCLUSIVE_WITH_COMMENTS - Static variable in interface javax.xml.crypto.dsig. CanonicalizationMethod
Exclusive Canonical XML with comments规范化方法算法URI。
exclusiveOr(Area) - Method in class java.awt.geom. Area
将此 Area的形状设置为当前形状的组合面积和指定的 Area的形状，减去其交点。
exec() - Method in class java.util.concurrent. CountedCompleter
实现CountedCompleters的执行约定。
exec() - Method in class java.util.concurrent. ForkJoinTask
立即执行此任务的基本操作，并返回true，如果从此方法返回后，此任务将保证已正常完成。
exec() - Method in class java.util.concurrent. RecursiveAction
执行递归法的执行约定。
exec() - Method in class java.util.concurrent. RecursiveTask
实现RecursiveTask的执行约定。
exec(String) - Method in class java.lang. Runtime
在单独的进程中执行指定的字符串命令。
exec(String[]) - Method in class java.lang. Runtime
在单独的进程中执行指定的命令和参数。
exec(String[], String[]) - Method in class java.lang. Runtime
在指定环境的单独进程中执行指定的命令和参数。
exec(String[], String[], File) - Method in class java.lang. Runtime
在指定的环境和工作目录的单独进程中执行指定的命令和参数。
exec(String, String[]) - Method in class java.lang. Runtime
在具有指定环境的单独进程中执行指定的字符串命令。
exec(String, String[], File) - Method in class java.lang. Runtime
在指定的环境和工作目录的单独进程中执行指定的字符串命令。
Executable - Class in java.lang.reflect
方法和Constructor的共同功能的共享超类。
EXECUTABLE - javax.lang.model.type. TypeKind
方法，构造函数或初始化器。
ExecutableElement - Interface in javax.lang.model.element
表示类或接口的方法，构造函数或初始化器（静态或实例），包括注释类型元素。
ExecutableMemberDoc - Interface in com.sun.javadoc
已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
ExecutableType - Interface in javax.lang.model.type
表示可执行文件的类型。
execute() - Method in class java.beans. Expression
execute方法查找名称与 methodName属性相同的方法，并调用目标方法。
execute() - Method in class java.beans. Statement
execute方法查找名称与 methodName属性相同的方法，并调用目标方法。
execute() - Method in interface java.sql. PreparedStatement
执行此 PreparedStatement对象中的SQL语句，可能是任何类型的SQL语句。
execute() - Method in interface javax.sql. RowSet
使用数据填充此 RowSet对象。
execute() - Method in class javax.swing. SwingWorker
计划这个 SwingWorker在 工作线程上执行。
execute(ClassLoader, String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(Runnable) - Method in interface java.util.concurrent. Executor
在将来的某个时间执行给定的命令。
execute(Runnable) - Method in class java.util.concurrent. ForkJoinPool
execute(Runnable) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor
执行 command ，需要零延迟。
execute(Runnable) - Method in class java.util.concurrent. ThreadPoolExecutor
在将来某个时候执行给定的任务。
execute(String) - Method in interface java.sql. Statement
执行给定的SQL语句，这可能会返回多个结果。
execute(String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(String, int) - Method in interface java.sql. Statement
执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出任何自动生成的密钥应该可用于检索。
execute(String, int[]) - Method in interface java.sql. Statement
执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
execute(String, PrintWriter, PrintWriter, PrintWriter, String, ClassLoader, String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(String, PrintWriter, PrintWriter, PrintWriter, String, String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(String, ClassLoader, String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(String, String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(String, String[]) - Method in interface java.sql. Statement
执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
execute(String, String, ClassLoader, String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(String, String, String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
程式化界面。
execute(Connection) - Method in interface javax.sql.rowset. CachedRowSet
用数据填充此 CachedRowSet对象，使用给定的连接生成将从中读取数据的结果集。
execute(ForkJoinTask<?>) - Method in class java.util.concurrent. ForkJoinPool
为异步执行给定任务的排列。
EXECUTE - java.nio.file. AccessMode
测试执行访问。
EXECUTE - java.nio.file.attribute. AclEntryPermission
执行文件的权限
EXECUTE_FAILED - Static variable in interface java.sql. Statement
指示执行批处理语句时发生错误的常量。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. ButtonBase
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. ChoiceBox
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. ComboBoxBase
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. Control
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. ListCell
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. MenuButton
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. ScrollBar
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control.skin. ListViewSkin
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control.skin. TableViewSkin
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control.skin. TextInputControlSkin
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control.skin. ToolBarSkin
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control.skin. TreeTableViewSkin
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control.skin. TreeViewSkin
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. SkinBase
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. Slider
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. Spinner
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. SplitMenuButton
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. TableCell
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. TextInputControl
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. TitledPane
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. TreeCell
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. TreeTableCell
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene.control. TreeTableRow
该方法由辅助技术调用，请求执行由参数指示的动作。
executeAccessibleAction(AccessibleAction, Object...) - Method in class javafx.scene. Node
该方法由辅助技术调用，请求执行由参数指示的动作。
executeBatch() - Method in interface java.sql. Statement
将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。
executeCall() - Method in interface java.rmi.server. RemoteCall
已过时。
没有替换
executeLargeBatch() - Method in interface java.sql. Statement
将一批命令提交到数据库以执行，并且所有命令都执行成功，返回一个更新计数的数组。
executeLargeUpdate() - Method in interface java.sql. PreparedStatement
执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
executeLargeUpdate(String) - Method in interface java.sql. Statement
执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。
executeLargeUpdate(String, int) - Method in interface java.sql. Statement
执行给定的SQL语句并用给定的标志来向驱动程序发出信号，以了解该 Statement对象产生的自动生成的密钥是否应该可用于检索。
executeLargeUpdate(String, int[]) - Method in interface java.sql. Statement
执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
executeLargeUpdate(String, String[]) - Method in interface java.sql. Statement
执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
executeQuery() - Method in interface java.sql. PreparedStatement
执行此 PreparedStatement对象中的SQL查询，并返回查询生成的 ResultSet对象。
executeQuery(String) - Method in interface java.sql. Statement
执行给定的SQL语句，返回一个 ResultSet对象。
executeScript(String) - Method in class javafx.scene.web. WebEngine
在当前页面的上下文中执行脚本。
executeTask(Task<V>) - Method in class javafx.concurrent. ScheduledService
executeTask(Task<V>) - Method in class javafx.concurrent. Service
使用此服务上定义的 executor执行给定的任务。
executeUpdate() - Method in interface java.sql. PreparedStatement
执行在该SQL语句PreparedStatement对象，它必须是一个SQL数据操纵语言（DML）语句，比如INSERT ， UPDATE或DELETE ; 或不返回任何内容的SQL语句，例如DDL语句。
executeUpdate(String) - Method in interface java.sql. Statement
执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。
executeUpdate(String, int) - Method in interface java.sql. Statement
执行给定的SQL语句，并向给定的标志指示驱动程序，以了解该 Statement对象产生的自动生成的密钥是否应该可用于检索。
executeUpdate(String, int[]) - Method in interface java.sql. Statement
执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
executeUpdate(String, String[]) - Method in interface java.sql. Statement
执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。
ExecutionControl - Interface in jdk.jshell.spi
该接口指定了实现可插拔JShell执行引擎必须提供的功能。
ExecutionControl.ClassBytecodes - Class in jdk.jshell.spi
使用类字节码捆绑类名。
ExecutionControl.ClassInstallException - Exception in jdk.jshell.spi
类安装（加载或重新定义）遇到问题。
ExecutionControl.EngineTerminationException - Exception in jdk.jshell.spi
未执行引擎终止已发生。
ExecutionControl.ExecutionControlException - Exception in jdk.jshell.spi
所有 ExecutionControl例外的抽象基础。
ExecutionControl.InternalException - Exception in jdk.jshell.spi
发生内部问题。
ExecutionControl.NotImplementedException - Exception in jdk.jshell.spi
该命令未实现。
ExecutionControl.ResolutionException - Exception in jdk.jshell.spi
一个例外，指出已经遇到一个未解决的引用的一个 DeclarationSnippet 。
ExecutionControl.RunException - Exception in jdk.jshell.spi
特定于运行用户代码的异常的抽象基础。
ExecutionControl.StoppedException - Exception in jdk.jshell.spi
 表示
ExecutionControl.invoke(java.lang.String, java.lang.String) （或理论上为
ExecutionControl.varValue(java.lang.String, java.lang.String) ）已被
ExecutionControl.stop()打断的
异常 。
ExecutionControl.UserException - Exception in jdk.jshell.spi
发生“正常”用户异常。
ExecutionControlException(String) - Constructor for exception jdk.jshell.spi. ExecutionControl.ExecutionControlException
ExecutionControlProvider - Interface in jdk.jshell.spi
JShell使用的提供程序来生成评估代码段所需的执行引擎。
executionEngine(String) - Method in class jdk.jshell. JShell.Builder
设置要执行的自定义引擎。
executionEngine(ExecutionControlProvider, Map<String, String>) - Method in class jdk.jshell. JShell.Builder
设置要执行的自定义引擎。
ExecutionEnv - Interface in jdk.jshell.spi
功能可用于可插拔的JShell执行引擎。
ExecutionException - Exception in java.util.concurrent
尝试检索通过抛出异常中止的任务的结果时抛出的异常。
ExecutionException() - Constructor for exception java.util.concurrent. ExecutionException
构造一个 ExecutionException ，没有详细信息。
ExecutionException(String) - Constructor for exception java.util.concurrent. ExecutionException
构造具有指定详细消息的 ExecutionException 。
ExecutionException(String, Throwable) - Constructor for exception java.util.concurrent. ExecutionException
构造一个具有指定的详细信息和原因的 ExecutionException 。
ExecutionException(Throwable) - Constructor for exception java.util.concurrent. ExecutionException
构造具有指定原因的 ExecutionException 。
EXECUTIVE - Static variable in class java.awt. PageAttributes.MediaType
Executive的MediaType实例，7 1/4 x 10 1/2 in。
EXECUTIVE - Static variable in class javafx.print. Paper
指定行政大小，7.25英寸×10.5英寸。
EXECUTIVE - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定行政大小，7.25英寸×10.5英寸。
EXECUTIVE - Static variable in class javax.print.attribute.standard. MediaSizeName
行政大小。
executor() - Method in class jdk.incubator.http. HttpClient
返回此客户端上设置的 Executor 。
executor(Executor) - Method in class jdk.incubator.http. HttpClient.Builder
将执行器设置为用于异步任务。
Executor - Interface in java.util.concurrent
执行提交的对象Runnable任务。
ExecutorCompletionService< V> - Class in java.util.concurrent
A CompletionService使用提供的Executor执行任务。
ExecutorCompletionService(Executor) - Constructor for class java.util.concurrent. ExecutorCompletionService
使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，一个LinkedBlockingQueue作为完成队列。
ExecutorCompletionService(Executor, BlockingQueue<Future<V>>) - Constructor for class java.util.concurrent. ExecutorCompletionService
使用提供的执行程序创建一个ExecutorCompletionService，用于执行基本任务，并将提供的队列作为其完成队列。
executorProperty() - Method in class javafx.concurrent. Service
执行者用于运行此服务。
Executors - Class in java.util.concurrent
工厂和工具方法Executor ， ExecutorService ， ScheduledExecutorService ， ThreadFactory和Callable此包中定义的类。
ExecutorService - Interface in java.util.concurrent
一个Executor提供了管理终止的方法和方法，可以产生一个Future来跟踪一个或多个异步任务的进度。
ExemptionMechanism - Class in javax.crypto
这个类提供了豁免机制的功能，其中的例子是 密钥恢复 ， 密钥弱化和 密钥托管 。
ExemptionMechanism(ExemptionMechanismSpi, Provider, String) - Constructor for class javax.crypto. ExemptionMechanism
创建一个ExemptionMechanism对象。
ExemptionMechanismException - Exception in javax.crypto
这是通用的ExemptionMechanism异常。
ExemptionMechanismException() - Constructor for exception javax.crypto. ExemptionMechanismException
构造一个没有详细消息的ExemptionMechanismException。
ExemptionMechanismException(String) - Constructor for exception javax.crypto. ExemptionMechanismException
构造具有指定详细消息的ExemptionMechanismException。
ExemptionMechanismSpi - Class in javax.crypto
该类定义了 ExemptionMechanism类的 （ SPI ）。
ExemptionMechanismSpi() - Constructor for class javax.crypto. ExemptionMechanismSpi
EXIF_VERSION_2_1 - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
要与ExifVersion标签一起使用的值来表示Exif版本2.1。
EXIF_VERSION_2_2 - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
要与ExifVersion标签一起使用以指示Exif版本2.2的值。
ExifGPSTagSet - Class in javax.imageio.plugins.tiff
代表在Exif GPS Info IFD中找到的标签的类。
ExifInteroperabilityTagSet - Class in javax.imageio.plugins.tiff
代表在Exif互操作性IFD中找到的标签的类。
ExifParentTIFFTagSet - Class in javax.imageio.plugins.tiff
包含用于引用Exif和GPS IFD的TIFF标签的类。
ExifTIFFTagSet - Class in javax.imageio.plugins.tiff
代表在Exif IFD中找到的标签的类。
exists() - Method in class java.io. File
测试此抽象路径名表示的文件或目录是否存在。
exists() - Method in class javax.security.auth.kerberos. KeyTab
检查keytab文件是否存在。
exists(Path, LinkOption...) - Static method in class java.nio.file. Files
测试文件是否存在。
exit() - Method in interface java.awt. SecondaryLoop
解除阻止由 SecondaryLoop.enter()方法阻止的线程的执行，并退出次级循环。
exit() - Static method in class javafx.application. Platform
导致JavaFX应用程序终止。
exit(int) - Method in interface com.sun.jdi. VirtualMachine
导致镜像的VM以给定的错误代码终止。
exit(int) - Method in class java.lang. Runtime
通过启动其关闭序列来终止当前正在运行的Java虚拟机。
exit(int) - Static method in class java.lang. System
终止当前运行的Java虚拟机。
EXIT_ON_CLOSE - Static variable in interface javax.swing. WindowConstants
退出应用程序默认窗口关闭操作。
EXITED - Static variable in class javax.swing.event. HyperlinkEvent.EventType
退出类型。
exiting(String, String) - Method in class java.util.logging. Logger
记录方法返回。
exiting(String, String, Object) - Method in class java.util.logging. Logger
使用结果对象记录方法返回。
exitNestedEventLoop(Object, Object) - Static method in class javafx.application. Platform
退出一个嵌套事件循环并解除对应的enterNestedEventLoop的调用者的阻塞。
exitValue() - Method in class java.lang. Process
返回进程的退出值。
exp(double) - Static method in class java.lang. Math
返回欧拉的数字 e提高到 double价值。
exp(double) - Static method in class java.lang. StrictMath
返回欧拉的数字 e提高到 double价值。
EXPAND - javafx.scene. AccessibleAction
请求节点应该扩展。
EXPANDABLE - Static variable in class javax.accessibility. AccessibleState
表示此对象允许逐渐披露其子项。
expandableContentProperty() - Method in class javafx.scene.control. DialogPane
表示对话框可扩展内容区域的属性。
EXPANDED - javafx.scene. AccessibleAttribute
如果节点被展开，返回true，否则返回false。
EXPANDED - Static variable in class javax.accessibility. AccessibleState
表示此对象已展开。
expandedIcon - Variable in class javax.swing.plaf.basic. BasicTreeUI
扩展图标。
expandedItemCountChangeEvent() - Static method in class javafx.scene.control. TreeItem
当TreeItem接收到一个修改，导致孩子数目可见的更改时使用的常规EventType。
expandedItemCountProperty() - Method in class javafx.scene.control. TreeTableView
表示当前能够在TreeTableView中可见的树节点数。
expandedItemCountProperty() - Method in class javafx.scene.control. TreeView
表示当前能够在TreeView中可见的树节点数。
expandedPaneProperty() - Method in class javafx.scene.control. Accordion
手风琴中扩大的TitledPane。
expandedProperty() - Method in class javafx.scene.control. DialogPane
表示是否扩展了dialogPane。
expandedProperty() - Method in class javafx.scene.control. TitledPane
TitledPane的扩展状态。
expandedProperty() - Method in class javafx.scene.control. TreeItem
这个TreeItem的扩展状态。
expandPath(TreePath) - Method in class javax.swing. JTree
确保由指定路径标识的节点被扩展和可视。
expandRow(int) - Method in class javax.swing. JTree
确保指定行中的节点被扩展和可见。
EXPANDS_SELECTED_PATHS_PROPERTY - Static variable in class javax.swing. JTree
用于展开所选路径属性的绑定属性名称
expandTabRunsArray() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
扩展选项卡运行数组。
ExpandVetoException - Exception in javax.swing.tree
用于阻止扩展/崩溃的异常发生。
ExpandVetoException(TreeExpansionEvent) - Constructor for exception javax.swing.tree. ExpandVetoException
构造一个没有消息的ExpandVetoException对象。
ExpandVetoException(TreeExpansionEvent, String) - Constructor for exception javax.swing.tree. ExpandVetoException
构造具有指定消息的ExpandVetoException对象。
expectContinue() - Method in class jdk.incubator.http. HttpRequest
返回此请求的 expect continue 设置。
expectContinue(boolean) - Method in class jdk.incubator.http. HttpRequest.Builder
在发送请求正文之前请求服务器确认请求。
EXPIRED - java.security.cert. CertPathValidatorException.BasicReason
证书已过期。
EXPLICIT - javax.lang.model.util. Elements.Origin
描述在源代码中显式声明的构造。
explicitCastArguments(MethodHandle, MethodType) - Static method in class java.lang.invoke. MethodHandles
生成方法句柄，通过成对参数和返回类型转换将给定方法句柄的类型适配为新类型。
expm1(double) - Static method in class java.lang. Math
返回 e x -1。
expm1(double) - Static method in class java.lang. StrictMath
返回 e x -1。
EXPONENT - Static variable in class java.text. NumberFormat.Field
常数识别指数字段。
EXPONENT_SIGN - Static variable in class java.text. NumberFormat.Field
常数识别指数符号字段。
EXPONENT_SYMBOL - Static variable in class java.text. NumberFormat.Field
常数识别指数符号字段。
EXPONENTIAL_BACKOFF_STRATEGY - Static variable in class javafx.concurrent. ScheduledService
backoffStrategy属性的回调实现将在失败的情况下以指数方式 backoffStrategy重新执行之间的时间段。
export() - Method in class javax.management.remote.rmi. RMIIIOPServerImpl
已过时。
export() - Method in class javax.management.remote.rmi. RMIJRMPServerImpl
export() - Method in class javax.management.remote.rmi. RMIServerImpl
导出此RMI对象。
export() - Method in interface org.ietf.jgss. GSSContext
导出此上下文，以便另一个进程可以导入它。
export() - Method in interface org.ietf.jgss. GSSName
返回机制名称（MN）的规范连续字节表示，适用于通过授权功能直接逐字节比较。
EXPORT_ENTRY - jdk.nashorn.api.tree. Tree.Kind
用于ExportEntryTree的实例。
exportAsDrag(JComponent, InputEvent, int) - Method in class javax.swing. TransferHandler
导致启动Swing拖动支持。
exportDone(JComponent, Transferable, int) - Method in class javax.swing. TransferHandler
数据导出后调用。
ExportEntryTree - Interface in jdk.nashorn.api.tree
导出条目的树节点在 Module information 。
ExportException - Exception in java.rmi.server
一个 ExportException是 RemoteException如果导出远程对象的尝试失败抛出。
ExportException(String) - Constructor for exception java.rmi.server. ExportException
构造具有指定详细消息的 ExportException 。
ExportException(String, Exception) - Constructor for exception java.rmi.server. ExportException
构造一个具有指定的详细消息和嵌套异常的 ExportException 。
exportNode(OutputStream) - Method in class java.util.prefs. AbstractPreferences
实现 exportNode方法按照在本说明书中 Preferences.exportNode(OutputStream) 。
exportNode(OutputStream) - Method in class java.util.prefs. Preferences
在指定的输出流上发出一个XML文档，表示此节点中包含的所有首选项（而不是其后代）。
exportObject(Remote) - Static method in class java.rmi.server. UnicastRemoteObject
已过时。
此方法已被弃用，因为它仅支持静态存根。 改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
exportObject(Remote) - Method in interface javax.rmi.CORBA. PortableRemoteObjectDelegate
代表团要求 PortableRemoteObject.exportObject(java.rmi.Remote) 。
exportObject(Remote) - Static method in class javax.rmi. PortableRemoteObject
使服务器对象准备好接收远程调用。
exportObject(Remote, int) - Static method in class java.rmi.server. UnicastRemoteObject
使用特定提供的端口导出远程对象以使其可用于接收来电。
exportObject(Remote, int, ObjectInputFilter) - Static method in class java.rmi.server. UnicastRemoteObject
使用特定提供的端口和filter导出远程对象以使其可用于接收来电。
exportObject(Remote, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.server. UnicastRemoteObject
使用给定套接字工厂指定的传输导出远程对象以使其可用于接收来电。
exportObject(Remote, int, RMIClientSocketFactory, RMIServerSocketFactory, ObjectInputFilter) - Static method in class java.rmi.server. UnicastRemoteObject
使用指定的套接字工厂指定的传输和filter导出远程对象以使其可用于接收来电。
exportObject(Remote, Object) - Method in interface java.rmi.server. ServerRef
已过时。
为所提供的Remote对象创建客户端存根对象。
exportObject(Remote, String, MarshalledObject<?>, boolean, int) - Static method in class java.rmi.activation. Activatable
为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。
exportObject(Remote, String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.activation. Activatable
注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。
exportObject(Remote, ActivationID, int) - Static method in class java.rmi.activation. Activatable
将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
exportObject(Remote, ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.activation. Activatable
将可激活的远程对象导出到RMI运行时间，使对象可用于接收来电。
exports() - Method in class java.lang.module. ModuleDescriptor
返回表示导出包的 Exports对象集。
exports(ModuleDescriptor.Exports) - Method in class java.lang.module. ModuleDescriptor.Builder
添加导出的包。
exports(String) - Method in class java.lang.module. ModuleDescriptor.Builder
添加导出的包。
exports(String, Set<String>) - Method in class java.lang.module. ModuleDescriptor.Builder
添加导出的包。
exports(Set<ModuleDescriptor.Exports.Modifier>, String) - Method in class java.lang.module. ModuleDescriptor.Builder
使用给定（可能为空）的修饰符集添加导出的包。
exports(Set<ModuleDescriptor.Exports.Modifier>, String, Set<String>) - Method in class java.lang.module. ModuleDescriptor.Builder
使用给定（可能为空）的修饰符集添加导出的包。
EXPORTS - com.sun.source.tree. Tree.Kind
用于表示模块声明中的导出指令的ExportsTree实例。
EXPORTS - javax.lang.model.element. ModuleElement.DirectiveKind
“export package-name [to module-name-list]”指令。
exportsIn(Iterable<? extends ModuleElement.Directive>) - Static method in class javax.lang.model.util. ElementFilter
在 directives返回 exports指令的列表。
ExportsTree - Interface in com.sun.source.tree
模块声明中的“exports”指令的树节点。
exportSubtree(OutputStream) - Method in class java.util.prefs. AbstractPreferences
实现 exportSubtree方法按照在本说明书中 Preferences.exportSubtree(OutputStream) 。
exportSubtree(OutputStream) - Method in class java.util.prefs. Preferences
发出表示此节点及其所有后代中包含的所有首选项的XML文档。
exportToClipboard(JComponent, Clipboard, int) - Method in class javax.swing. TransferHandler
导致从给定组件转移到给定的剪贴板。
exposeToScripts(String) - Method in interface jdk.nashorn.api.scripting. ClassFilter
应该将指定名称的Java类暴露给脚本吗？
EXPOSURE_MODE_AUTO_BRACKET - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureMode”标签一起使用的值。
EXPOSURE_MODE_AUTO_EXPOSURE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureMode”标签一起使用的值。
EXPOSURE_MODE_MANUAL_EXPOSURE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureMode”标签一起使用的值。
EXPOSURE_PROGRAM_ACTION_PROGRAM - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_APERTURE_PRIORITY - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_CREATIVE_PROGRAM - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_LANDSCAPE_MODE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_MANUAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_MAX_RESERVED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_NORMAL_PROGRAM - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_NOT_DEFINED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_PORTRAIT_MODE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
EXPOSURE_PROGRAM_SHUTTER_PRIORITY - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“ExposureProgram”标签一起使用的值。
Expression - Class in java.beans
一个 Expression对象表示一个原始表达式，其中单个方法应用于目标和一组参数以返回结果 - 如 "a.getFoo()" 。
Expression(Object, Object, String, Object[]) - Constructor for class java.beans. Expression
使用指定的目标对象的指定值创建一个新的Expression对象，以调用由名称和参数数组指定的方法。
Expression(Object, String, Object[]) - Constructor for class java.beans. Expression
为指定的目标对象创建一个新的Expression对象，以调用由名称和参数数组指定的方法。
EXPRESSION - com.sun.source.tree. LambdaExpressionTree.BodyKind
枚举常数表达兰布
EXPRESSION - jdk.jshell. Snippet.Kind
表达，有或没有副作用。
EXPRESSION_PREFIX - Static variable in class javafx.fxml. FXMLLoader
（变量）表达式分辨率的前缀。
EXPRESSION_STATEMENT - com.sun.source.tree. Tree.Kind
用于ExpressionStatementTree的实例。
EXPRESSION_STATEMENT - jdk.nashorn.api.tree. Tree.Kind
用于ExpressionStatementTree的实例。
ExpressionSnippet - Class in jdk.jshell
赋值或变量值表达式的代码段。
ExpressionStatementTree - Interface in com.sun.source.tree
表达式语句的树节点。
ExpressionStatementTree - Interface in jdk.nashorn.api.tree
表达式语句的树节点。
ExpressionTree - Interface in com.sun.source.tree
用作不同类型表达式的基类的树节点。
ExpressionTree - Interface in jdk.nashorn.api.tree
用作不同类型表达式的基类的树节点。
EXTENDED - jdk.javadoc.doclet. Doclet.Option.Kind
扩展选项，例如前缀为-X的选项
EXTENDED_FILTERING - java.util. Locale.FilteringMode
指定扩展过滤。
ExtendedGSSContext - Interface in com.sun.security.jgss
扩展的GSSContext接口，用于支持未由 org.ietf.jgss.GSSContext定义的其他功能，例如查询上下文特定的属性。
ExtendedGSSCredential - Interface in com.sun.security.jgss
扩展的GSSCredential接口，用于支持未由 org.ietf.jgss.GSSCredential定义的附加功能。
extendedOperation(ExtendedRequest) - Method in class javax.naming.ldap. InitialLdapContext
extendedOperation(ExtendedRequest) - Method in interface javax.naming.ldap. LdapContext
执行扩展操作。
ExtendedRequest - Interface in javax.naming.ldap
该接口表示如 RFC 2251中定义的LDAPv3扩展操作请求。
ExtendedResponse - Interface in javax.naming.ldap
此接口表示如 RFC 2251中定义的LDAP扩展操作响应。
ExtendedService - Interface in javax.jnlp
ExtendedService提供对当前JNLP API的额外支持，允许应用程序在客户端的文件系统中打开特定的文件。
ExtendedSocketOptions - Class in jdk.net
定义扩展套接字选项，超出StandardSocketOptions中定义的。
ExtendedSSLSession - Class in javax.net.ssl
扩展 SSLSession接口以支持其他会话属性。
ExtendedSSLSession() - Constructor for class javax.net.ssl. ExtendedSSLSession
EXTENDS_WILDCARD - com.sun.source.tree. Tree.Kind
用于表示扩展有界通配符类型参数的WildcardTree的实例。
extendsBounds() - Method in interface com.sun.javadoc. WildcardType
已过时。
返回由 扩展子句给出的此通配符类型参数的上限。
extendSelection(int) - Method in class javafx.scene.control. TextInputControl
此功能将扩展选择以包括指定的位置。
extension - Variable in enum javax.tools. JavaFileObject.Kind
通常用于这种文件对象的扩展。
Extension - Interface in java.security.cert
此接口表示X.509扩展。
EXTENSION - Static variable in interface javax.jnlp. DownloadService2
匹配扩展在 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
EXTENSION_INSTALLATION - Static variable in class java.util.jar. Attributes.Name
已过时。
扩展机制不再受支持。
EXTENSION_LIST - Static variable in class java.util.jar. Attributes.Name
Name对象，用于不再支持的扩展机制的 Extension-List manifest属性。
EXTENSION_NAME - Static variable in class java.util.jar. Attributes.Name
Name对象为 Extension-Name清单属性。
extensionCommand(String, Object) - Method in class jdk.jshell.execution. DirectExecutionControl
extensionCommand(String, Object) - Method in class jdk.jshell.execution. StreamingExecutionControl
extensionCommand(String, Object) - Method in interface jdk.jshell.spi. ExecutionControl
运行非标准命令（或较新版本的标准命令）。
ExtensionFilter(String, String...) - Constructor for class javafx.stage. FileChooser.ExtensionFilter
创建一个具有指定描述和文件扩展名的 ExtensionFilter 。
ExtensionFilter(String, List<String>) - Constructor for class javafx.stage. FileChooser.ExtensionFilter
创建一个具有指定描述和文件扩展名的 ExtensionFilter 。
ExtensionInstallerService - Interface in javax.jnlp
ExtensionInstallerService由扩展安装程序用于与JNLP客户端进行通信。
extent - Variable in class java.awt.geom. Arc2D.Double
电弧的角度范围为度。
extent - Variable in class java.awt.geom. Arc2D.Float
电弧的角度范围为度。
externalEntityDecl(String, String, String) - Method in interface org.xml.sax.ext. DeclHandler
报告被解析的外部实体声明。
externalEntityDecl(String, String, String) - Method in class org.xml.sax.ext. DefaultHandler2
Externalizable - Interface in java.io
只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。
EXTRA_BOLD - javafx.scene.text. FontWeight
代表“Extra Bold”字体重量（800）。
EXTRA_LIGHT - javafx.scene.text. FontWeight
代表“Extra Light”字体重量（200）。
EXTRA_SAMPLES_ASSOCIATED_ALPHA - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“ExtraSamples”标签一起使用的值。
EXTRA_SAMPLES_UNASSOCIATED_ALPHA - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“ExtraSamples”标签一起使用的值。
EXTRA_SAMPLES_UNSPECIFIED - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“ExtraSamples”标签一起使用的值。
extract(Any) - Static method in class org.omg.CORBA. AnySeqHelper
extract(Any) - Static method in class org.omg.CORBA. BooleanSeqHelper
extract(Any) - Static method in class org.omg.CORBA. BoundsHelper
extract(Any) - Static method in class org.omg.CORBA. CharSeqHelper
extract(Any) - Static method in class org.omg.CORBA. CompletionStatusHelper
extract(Any) - Static method in class org.omg.CORBA. CurrentHelper
extract(Any) - Static method in class org.omg.CORBA. DefinitionKindHelper
extract(Any) - Static method in class org.omg.CORBA. DoubleSeqHelper
extract(Any) - Static method in class org.omg.CORBA. FieldNameHelper
extract(Any) - Static method in class org.omg.CORBA. FloatSeqHelper
extract(Any) - Static method in class org.omg.CORBA. IdentifierHelper
extract(Any) - Static method in class org.omg.CORBA. IDLTypeHelper
extract(Any) - Static method in class org.omg.CORBA. LongLongSeqHelper
extract(Any) - Static method in class org.omg.CORBA. LongSeqHelper
extract(Any) - Static method in class org.omg.CORBA. NameValuePairHelper
extract(Any) - Static method in class org.omg.CORBA. ObjectHelper
extract(Any) - Static method in class org.omg.CORBA. OctetSeqHelper
extract(Any) - Static method in class org.omg.CORBA.ORBPackage. InvalidNameHelper
extract(Any) - Static method in class org.omg.CORBA. ParameterModeHelper
extract(Any) - Static method in class org.omg.CORBA. PolicyErrorCodeHelper
extract(Any) - Static method in class org.omg.CORBA. PolicyErrorHelper
extract(Any) - Static method in class org.omg.CORBA. PolicyHelper
extract(Any) - Static method in class org.omg.CORBA. PolicyListHelper
extract(Any) - Static method in class org.omg.CORBA. PolicyTypeHelper
extract(Any) - Static method in class org.omg.CORBA. RepositoryIdHelper
extract(Any) - Static method in class org.omg.CORBA. ServiceDetailHelper
extract(Any) - Static method in class org.omg.CORBA. ServiceInformationHelper
extract(Any) - Static method in class org.omg.CORBA. SetOverrideTypeHelper
extract(Any) - Static method in class org.omg.CORBA. ShortSeqHelper
extract(Any) - Static method in class org.omg.CORBA. StringSeqHelper
extract(Any) - Static method in class org.omg.CORBA. StringValueHelper
extract(Any) - Static method in class org.omg.CORBA. StructMemberHelper
extract(Any) - Static method in class org.omg.CORBA.TypeCodePackage. BadKindHelper
extract(Any) - Static method in class org.omg.CORBA.TypeCodePackage. BoundsHelper
extract(Any) - Static method in class org.omg.CORBA. ULongLongSeqHelper
extract(Any) - Static method in class org.omg.CORBA. ULongSeqHelper
extract(Any) - Static method in class org.omg.CORBA. UnionMemberHelper
extract(Any) - Static method in class org.omg.CORBA. UnknownUserExceptionHelper
extract(Any) - Static method in class org.omg.CORBA. UShortSeqHelper
extract(Any) - Static method in class org.omg.CORBA. ValueBaseHelper
extract(Any) - Static method in class org.omg.CORBA. ValueMemberHelper
extract(Any) - Static method in class org.omg.CORBA. VersionSpecHelper
extract(Any) - Static method in class org.omg.CORBA. VisibilityHelper
extract(Any) - Static method in class org.omg.CORBA. WCharSeqHelper
extract(Any) - Static method in class org.omg.CORBA. WrongTransactionHelper
extract(Any) - Static method in class org.omg.CORBA. WStringSeqHelper
extract(Any) - Static method in class org.omg.CORBA. WStringValueHelper
extract(Any) - Static method in class org.omg.CosNaming. BindingHelper
extract(Any) - Static method in class org.omg.CosNaming. BindingIteratorHelper
extract(Any) - Static method in class org.omg.CosNaming. BindingListHelper
extract(Any) - Static method in class org.omg.CosNaming. BindingTypeHelper
extract(Any) - Static method in class org.omg.CosNaming. IstringHelper
extract(Any) - Static method in class org.omg.CosNaming. NameComponentHelper
extract(Any) - Static method in class org.omg.CosNaming. NameHelper
extract(Any) - Static method in class org.omg.CosNaming. NamingContextExtHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage. AddressHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage. StringNameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage. URLStringHelper
extract(Any) - Static method in class org.omg.CosNaming. NamingContextHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHelper
extract(Any) - Static method in class org.omg.DynamicAny. AnySeqHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCodeHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynAnyHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyPackage. InvalidValueHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyPackage. TypeMismatchHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynAnySeqHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynArrayHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynEnumHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynFixedHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynSequenceHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynStructHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynUnionHelper
extract(Any) - Static method in class org.omg.DynamicAny. DynValueHelper
extract(Any) - Static method in class org.omg.DynamicAny. FieldNameHelper
extract(Any) - Static method in class org.omg.DynamicAny. NameDynAnyPairHelper
extract(Any) - Static method in class org.omg.DynamicAny. NameDynAnyPairSeqHelper
extract(Any) - Static method in class org.omg.DynamicAny. NameValuePairHelper
extract(Any) - Static method in class org.omg.DynamicAny. NameValuePairSeqHelper
extract(Any) - Static method in class org.omg.IOP. CodecFactoryHelper
extract(Any) - Static method in class org.omg.IOP.CodecFactoryPackage. UnknownEncodingHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage. FormatMismatchHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage. InvalidTypeForEncodingHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage. TypeMismatchHelper
extract(Any) - Static method in class org.omg.IOP. ComponentIdHelper
extract(Any) - Static method in class org.omg.IOP. IORHelper
extract(Any) - Static method in class org.omg.IOP. MultipleComponentProfileHelper
extract(Any) - Static method in class org.omg.IOP. ProfileIdHelper
extract(Any) - Static method in class org.omg.IOP. ServiceContextHelper
extract(Any) - Static method in class org.omg.IOP. ServiceContextListHelper
extract(Any) - Static method in class org.omg.IOP. ServiceIdHelper
extract(Any) - Static method in class org.omg.IOP. TaggedComponentHelper
extract(Any) - Static method in class org.omg.IOP. TaggedProfileHelper
extract(Any) - Static method in class org.omg.Messaging. SyncScopeHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. AdapterManagerIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. AdapterNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. AdapterStateHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. CurrentHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. ForwardRequestHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. InvalidSlotHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper
extract(Any) - Static method in class org.omg.PortableInterceptor. ObjectIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. ORBIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. ObjectIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor. ServerIdHelper
extract(Any) - Static method in class org.omg.PortableServer. CurrentHelper
extract(Any) - Static method in class org.omg.PortableServer.CurrentPackage. NoContextHelper
extract(Any) - Static method in class org.omg.PortableServer. ForwardRequestHelper
extract(Any) - Static method in class org.omg.PortableServer. POAHelper
extract(Any) - Static method in class org.omg.PortableServer.POAManagerPackage. AdapterInactiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. AdapterAlreadyExistsHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. AdapterNonExistentHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. InvalidPolicyHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. NoServantHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. ObjectAlreadyActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. ObjectNotActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. ServantAlreadyActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. ServantNotActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. WrongAdapterHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage. WrongPolicyHelper
extract(Any) - Static method in class org.omg.PortableServer. ServantActivatorHelper
extract(Any) - Static method in class org.omg.PortableServer. ServantLocatorHelper
extract_any() - Method in class org.omg.CORBA. Any
在此 Any对象的 value字段中提取 Any对象。
extract_boolean() - Method in class org.omg.CORBA. Any
提取 boolean在此 Any对象 value场。
extract_char() - Method in class org.omg.CORBA. Any
提取 char在此 Any对象 value场。
extract_double() - Method in class org.omg.CORBA. Any
提取 double在此 Any对象 value场。
extract_fixed() - Method in class org.omg.CORBA. Any
在此 Any对象的 value字段中提取 java.math.BigDecimal对象。
extract_float() - Method in class org.omg.CORBA. Any
提取 float在此 Any对象 value场。
extract_long() - Method in class org.omg.CORBA. Any
提取 int在此 Any对象 value场。
extract_longlong() - Method in class org.omg.CORBA. Any
提取 long在此 Any对象 value场。
extract_Object() - Method in class org.omg.CORBA. Any
提取 org.omg.CORBA.Object在此 Any对象 value场。
extract_octet() - Method in class org.omg.CORBA. Any
提取 byte在此 Any对象 value场。
extract_Principal() - Method in class org.omg.CORBA. Any
已过时。
被CORBA弃用2.2。
extract_short() - Method in class org.omg.CORBA. Any
提取 short在此 Any对象 value场。
extract_Streamable() - Method in class org.omg.CORBA. Any
从此 Any对象的 value字段中提取一个 Streamable 。
extract_string() - Method in class org.omg.CORBA. Any
在 Any对象的 value字段中提取 String对象。
extract_TypeCode() - Method in class org.omg.CORBA. Any
在此 Any对象的 value字段中提取 TypeCode对象。
extract_ulong() - Method in class org.omg.CORBA. Any
提取 int在此 Any对象 value场。
extract_ulonglong() - Method in class org.omg.CORBA. Any
提取 long在此 Any对象 value场。
extract_ushort() - Method in class org.omg.CORBA. Any
提取 short在此 Any对象 value场。
extract_Value() - Method in class org.omg.CORBA. Any
在此 Any对象的 value字段中提取 java.io.Serializable对象。
extract_wchar() - Method in class org.omg.CORBA. Any
提取 char在此 Any对象 value场。
extract_wstring() - Method in class org.omg.CORBA. Any
提取 String在这个对象 Any对象 value场。
extractAllHeaderElements() - Method in interface javax.xml.soap. SOAPHeader
返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象，并从该中分离出来 SOAPHeader对象。
extractContentAsDocument() - Method in interface javax.xml.soap. SOAPBody
创建一个新的DOM Document并设置这个SOAPBody的第一个孩子作为它的文档元素。
extractContents() - Method in interface org.w3c.dom.ranges. Range
将范围的内容从包含的文档或文档片段移动到新的DocumentFragment。
extractHeaderElements(String) - Method in interface javax.xml.soap. SOAPHeader
返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象中具有指定 的actor并从此中分离出来 SOAPHeader对象。
extraImageMetadataFormatClassNames - Variable in class javax.imageio.spi. ImageReaderWriterSpi
String的数组包含该插件支持的任何其他图像元数据格式的类名，最初为 null 。
extraImageMetadataFormatNames - Variable in class javax.imageio.spi. ImageReaderWriterSpi
String的数组， String包含该插件支持的任何其他图像元数据格式的名称，最初为 null 。
extraMetadataFormatClassNames - Variable in class javax.imageio.metadata. IIOMetadata
实现 IIOMetadataFormat的类的名称数组，并表示该插件支持的标准和本机格式之外的元数据格式，初始化为 null并通过构造函数进行设置。
extraMetadataFormatNames - Variable in class javax.imageio.metadata. IIOMetadata
由该插件支持的格式（不包括标准和本机格式）的数组，初始化为 null并通过构造函数进行设置。
extraRemoteVMOptions() - Method in interface jdk.jshell.spi. ExecutionEnv
返回启动远程JVM时要使用的其他VM选项。
extraStreamMetadataFormatClassNames - Variable in class javax.imageio.spi. ImageReaderWriterSpi
String的数组包含该插件支持的任何其他流元数据格式的类名，最初为 null 。
extraStreamMetadataFormatNames - Variable in class javax.imageio.spi. ImageReaderWriterSpi
String的数组，包含该插件支持的任何其他流元数据格式的名称，最初为 null 。
extraValueProperty() - Method in class javafx.scene.chart. XYChart.Data
以图表所需的任何方式绘制的通用数据值。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


F-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

F

F - javafx.scene.input. KeyCode
常数为 F键。
F0 - Static variable in class java.security.spec. RSAKeyGenParameterSpec
公众指数值F0 = 3。
F1 - javafx.scene.input. KeyCode
常数为F1功能键。
F1 - Static variable in class java.awt. Event
已过时。
F1功能键，非ASCII动作键。
F10 - javafx.scene.input. KeyCode
常数为F10功能键。
F10 - Static variable in class java.awt. Event
已过时。
F10功能键，非ASCII动作键。
F11 - javafx.scene.input. KeyCode
常数为F11功能键。
F11 - Static variable in class java.awt. Event
已过时。
F11功能键，非ASCII操作键。
F12 - javafx.scene.input. KeyCode
F12功能键的常数。
F12 - Static variable in class java.awt. Event
已过时。
F12功能键，非ASCII动作键。
F13 - javafx.scene.input. KeyCode
F13功能键的常数。
F14 - javafx.scene.input. KeyCode
F14功能键的常数。
F15 - javafx.scene.input. KeyCode
F15功能键的常数。
F16 - javafx.scene.input. KeyCode
F16功能键的常数。
F17 - javafx.scene.input. KeyCode
F17功能键的常数。
F18 - javafx.scene.input. KeyCode
F18功能键的常数。
F19 - javafx.scene.input. KeyCode
F19功能键的常数。
F2 - javafx.scene.input. KeyCode
F2功能键的常数。
F2 - Static variable in class java.awt. Event
已过时。
F2功能键，非ASCII动作键。
F20 - javafx.scene.input. KeyCode
F20功能键的常数。
F21 - javafx.scene.input. KeyCode
F21功能键的常数。
F22 - javafx.scene.input. KeyCode
F22功能键的常数。
F23 - javafx.scene.input. KeyCode
F23功能键的常数。
F24 - javafx.scene.input. KeyCode
F24功能键的常数。
F3 - javafx.scene.input. KeyCode
F3功能键的常数。
F3 - Static variable in class java.awt. Event
已过时。
F3功能键，非ASCII动作键。
F4 - javafx.scene.input. KeyCode
F4功能键的常数。
F4 - Static variable in class java.awt. Event
已过时。
F4功能键，非ASCII动作键。
F4 - Static variable in class java.security.spec. RSAKeyGenParameterSpec
公共指数值F4 = 65537。
F5 - javafx.scene.input. KeyCode
F5功能键的常数。
F5 - Static variable in class java.awt. Event
已过时。
F5功能键，非ASCII动作键。
F6 - javafx.scene.input. KeyCode
常数为F6功能键。
F6 - Static variable in class java.awt. Event
已过时。
F6功能键，非ASCII动作键。
F7 - javafx.scene.input. KeyCode
F7功能键的常数。
F7 - Static variable in class java.awt. Event
已过时。
F7功能键，非ASCII动作键。
F8 - javafx.scene.input. KeyCode
F8功能键的常数。
F8 - Static variable in class java.awt. Event
已过时。
F8功能键，非ASCII动作键。
F9 - javafx.scene.input. KeyCode
常数为F9功能键。
F9 - Static variable in class java.awt. Event
已过时。
F9功能键，非ASCII动作键。
FACE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“脸”
FACE_UNDEFINED - Static variable in class javafx.scene.input. PickResult
一个未定义的脸。
FactoryConfigurationError - Error in javax.xml.parsers
当与Parser工厂存在配置问题时抛出。
FactoryConfigurationError - Error in javax.xml.stream
报告工厂配置错误的错误类。
FactoryConfigurationError() - Constructor for error javax.xml.parsers. FactoryConfigurationError
创建一个新的 FactoryConfigurationError没有详细消息。
FactoryConfigurationError() - Constructor for error javax.xml.stream. FactoryConfigurationError
默认构造函数
FactoryConfigurationError(Exception) - Constructor for error javax.xml.parsers. FactoryConfigurationError
创建一个新的 FactoryConfigurationError与给定的 异常基本原因的错误。
FactoryConfigurationError(Exception) - Constructor for error javax.xml.stream. FactoryConfigurationError
使用嵌套的内部异常构造异常
FactoryConfigurationError(Exception, String) - Constructor for error javax.xml.parsers. FactoryConfigurationError
创建一个新的 FactoryConfigurationError与给定的 异常基本原因和详细信息。
FactoryConfigurationError(Exception, String) - Constructor for error javax.xml.stream. FactoryConfigurationError
使用嵌套的内部异常和消息构造异常
FactoryConfigurationError(String) - Constructor for error javax.xml.parsers. FactoryConfigurationError
创建一个新的 FactoryConfigurationError ，其中 String指定为错误消息。
FactoryConfigurationError(String) - Constructor for error javax.xml.stream. FactoryConfigurationError
使用关联的消息构造异常
FactoryConfigurationError(String, Exception) - Constructor for error javax.xml.stream. FactoryConfigurationError
使用嵌套的内部异常和消息构造异常
FadeTransition - Class in javafx.animation
这个 Transition创建了一个跨越其 duration的褪色效果动画。
FadeTransition() - Constructor for class javafx.animation. FadeTransition
构造函数为 FadeTransition
FadeTransition(Duration) - Constructor for class javafx.animation. FadeTransition
构造函数为 FadeTransition
FadeTransition(Duration, Node) - Constructor for class javafx.animation. FadeTransition
构造函数为 FadeTransition
failed() - Method in class javafx.concurrent. ScheduledService
对于子类的受保护的便利方法，只要服务状态已经转换到FAILED状态。
failed() - Method in class javafx.concurrent. Service
对于子类的受保护的便利方法，只要服务状态已经转换到FAILED状态。
failed() - Method in class javafx.concurrent. Task
每当任务的状态已转换到FAILED状态时调用的子类的受保护的便利方法。
failed(Throwable, A) - Method in interface java.nio.channels. CompletionHandler
当操作失败时调用。
FAILED - javafx.concurrent. Worker.State
表示此工作人员失败，通常是由于某些意外情况发生。
FAILED - Static variable in class javax.management.remote. JMXConnectionNotification
连接失败通知的通知类型字符串。
failedFuture(Throwable) - Static method in class java.util.concurrent. CompletableFuture
返回一个已经完成的新的CompletableFuture，特别是给定的异常。
FailedLoginException - Exception in javax.security.auth.login
表示用户身份验证失败。
FailedLoginException() - Constructor for exception javax.security.auth.login. FailedLoginException
构造一个没有详细消息的FailedLoginException。
FailedLoginException(String) - Constructor for exception javax.security.auth.login. FailedLoginException
构造具有指定详细消息的FailedLoginException。
failedStage(Throwable) - Static method in class java.util.concurrent. CompletableFuture
返回一个已经完成的新的CompletionStage，特别是给定异常，并且仅支持接口CompletionStage中的那些方法。
failedToInitialize() - Method in interface com.sun.jdi. ReferenceType
确定此类的初始化失败。
FailOverExecutionControlProvider - Class in jdk.jshell.execution
一直尝试其他提供商，直到一个工作。
FailOverExecutionControlProvider() - Constructor for class jdk.jshell.execution. FailOverExecutionControlProvider
创建一个实例。
failure(Exception) - Method in interface java.rmi.server. RMIFailureHandler
当RMI运行时无法通过 RMISocketFactory创建 ServerSocket时，将调用 failure回调。
Failure(int) - Constructor for class com.sun.net.httpserver. Authenticator.Failure
FAILURE - Static variable in exception org.ietf.jgss. GSSException
一般故障，未在GSS-API级别指定。
FALSE - Static variable in class java.lang. Boolean
对应 Boolean对象的原始值为 false 。
FALSE - Static variable in interface java.util.jar. Pack200.Packer
字符串“false”是某些属性的可能值。
FALSE - Static variable in interface java.util.jar. Pack200.Unpacker
字符串“false”是某些属性的可能值。
Family - Static variable in class javax.swing.text. StyleConstants
字体系列的名称
FAMILY - Static variable in class java.awt.font. TextAttribute
字体名称的属性键。
farClipProperty() - Method in class javafx.scene. Camera
指定眼睛坐标空间中 Camera的远剪切平面眼睛的距离。
FAST_FWD - javafx.scene.input. KeyCode
常数为 Fast Forward键。
FATAL_ERROR - Static variable in interface javax.xml.bind. ValidationEvent
符合W3C XML 1.0建议书第1.2节“致命错误”定义的条件
fatalError(TransformerException) - Method in interface javax.xml.transform. ErrorListener
接收不可恢复错误的通知。
fatalError(SAXParseException) - Method in interface org.xml.sax. ErrorHandler
接收不可恢复错误的通知。
fatalError(SAXParseException) - Method in class org.xml.sax. HandlerBase
已过时。
报告致命的XML解析错误。
fatalError(SAXParseException) - Method in class org.xml.sax.helpers. DefaultHandler
报告致命的XML解析错误。
fatalError(SAXParseException) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤一个致命错误事件。
FaultAction - Annotation Type in javax.xml.ws
所述FaultAction注解用于内部Action注释以允许WS寻址的显式关联Action与消息寻址属性fault从异常类映射到的WSDL操作的消息。
FaxTIFFTagSet - Class in javax.imageio.plugins.tiff
表示在 TIFF-F （RFC 2036）文件中找到的额外标签的类。
fd - Variable in class java.net. DatagramSocketImpl
文件描述符对象。
fd - Variable in class java.net. SocketImpl
该套接字的文件描述符对象。
FEATURE - Static variable in class javax.xml.transform.dom. DOMResult
如果 TransformerFactory.getFeature(java.lang.String)通过此值作为参数返回 true ，则 Transformer支持此类型的 Result输出。
FEATURE - Static variable in class javax.xml.transform.dom. DOMSource
如果在传递此值作为参数时， TransformerFactory.getFeature(java.lang.String)返回true，则Transformer支持此类型的Source输入。
FEATURE - Static variable in class javax.xml.transform.sax. SAXResult
如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer支持此类型的Result输出。
FEATURE - Static variable in class javax.xml.transform.sax. SAXSource
如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer支持此类型的Source输入。
FEATURE - Static variable in class javax.xml.transform.sax. SAXTransformerFactory
如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则可以将从 TransformerFactory.newInstance()返回的TransformerFactory安全地转换为SAXTransformerFactory。
FEATURE - Static variable in class javax.xml.transform.stax. StAXResult
如果 TransformerFactory.getFeature(String name)将该值作为参数传递时返回true，则Transformer支持此类型的Result输出。
FEATURE - Static variable in class javax.xml.transform.stax. StAXSource
如果在传递此值作为参数时， TransformerFactory.getFeature(String name)返回true，则Transformer支持此类型的Source输入。
FEATURE - Static variable in class javax.xml.transform.stream. StreamResult
如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer将支持此类型的Result输出。
FEATURE - Static variable in class javax.xml.transform.stream. StreamSource
如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer支持此类型的Source输入。
FEATURE_SECURE_PROCESSING - Static variable in class javax.xml. XMLConstants
安全处理功能。
FEATURE_XMLFILTER - Static variable in class javax.xml.transform.sax. SAXTransformerFactory
 如果
TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则支持
SAXTransformerFactory.newXMLFilter(Source src)和
SAXTransformerFactory.newXMLFilter(Templates templates)方法。
FeatureDescriptor - Class in java.beans
FeatureDescriptor类是PropertyDescriptor，EventSetDescriptor和MethodDescriptor等的常见基类。
FeatureDescriptor() - Constructor for class java.beans. FeatureDescriptor
构造一个 FeatureDescriptor 。
FEBRUARY - java.time. Month
二月份的单身人士28天，或闰年29人。
FEBRUARY - Static variable in class java.util. Calendar
Calendar.MONTH字段的值表示今年第二个月在公历和朱利安日历。
FEBRUARY - Static variable in class javax.xml.datatype. DatatypeConstants
一年的第二个月的价值
FETCH_FORWARD - Static variable in interface java.sql. ResultSet
指示结果集中的行将在向前方向处理的常数; 第一个到最后。
FETCH_REVERSE - Static variable in interface java.sql. ResultSet
指示结果集中的行将以相反方向处理的常数; 最后到第一位。
FETCH_UNKNOWN - Static variable in interface java.sql. ResultSet
指示结果集中的行将被处理的顺序的常量是未知的。
fetchNotifications(long, int, long) - Method in interface javax.management.remote.rmi. RMIConnection
从连接器服务器检索通知。
fetchNotifications(long, int, long) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
fetchNotifications(long, int, long) - Method in class javax.management.remote.rmi. RMIConnectionImpl
fictional() - Method in class javax.swing.text.html.parser. TagElement
如果标签是虚构的，则返回 true 。
Fidelity - Class in javax.print.attribute.standard
类Fidelity是打印属性类，枚举，指示是否需要对客户端提供的打印请求属性的总保真度。
Fidelity(int) - Constructor for class javax.print.attribute.standard. Fidelity
使用给定的整数值构造新的保真枚举值。
FIDELITY_FALSE - Static variable in class javax.print.attribute.standard. Fidelity
打印机应该合理地尝试打印作业，即使它不能按照指定打印。
FIDELITY_TRUE - Static variable in class javax.print.attribute.standard. Fidelity
作业必须按照指定的方式打印。 否则被拒绝。
field() - Method in interface com.sun.jdi.event. WatchpointEvent
返回即将被访问/修改的字段。
field() - Method in interface com.sun.jdi.request. WatchpointRequest
获取该WatchpointRequest所关注的字段。
Field - Class in java.lang.reflect
A Field提供有关类或接口的单个字段的信息和动态访问。
Field - Interface in com.sun.jdi
目标VM中的类或实例变量。
Field(String) - Constructor for class java.text. Format.Field
用指定的名称创建一个字段。
Field(String) - Constructor for class java.text. MessageFormat.Field
用指定的名称创建一个字段。
Field(String) - Constructor for class java.text. NumberFormat.Field
创建具有指定名称的Field实例。
Field(String, int) - Constructor for class java.text. DateFormat.Field
创建一个 Field 。
字段 - java.lang.annotation. ElementType
字段声明（包括枚举常数）
字段 - javax.lang.model.element. ElementKind
一个不具体描述的字段（如 ENUM_CONSTANT ）。
字段 - javax.xml.bind.annotation. XmlAccessType
JAXB绑定类中的每个非静态非瞬态字段将自动绑定到XML，除非由XmlTransient注释。
字段 - jdk.javadoc.doclet. Taglet.Location
在一个字段的文档中。
FIELD_ATTRIBUTE_PFX - Static variable in interface java.util.jar. Pack200.Packer
当与字段属性名称连接时，表示该属性的格式。
FIELD_COUNT - Static variable in class java.util. Calendar
get和 set识别的不同字段的数量。
FIELD_UNDEFINED - Static variable in class javax.xml.datatype. DatatypeConstants
指定“int”字段未设置。
FieldBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic. BasicBorders.FieldBorder
构造一个新的实例 FieldBorder 。
fieldByName(String) - Method in interface com.sun.jdi. ReferenceType
找到具有给定非歧义名称的可见Field 。
FieldDoc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
fieldModifiers() - Static method in class java.lang.reflect. Modifier
返回一个 int值将可以应用于一个字段的源语言修饰符OR值组合在一起。
fieldName() - Method in interface com.sun.javadoc. SerialFieldTag
已过时。
返回可序列化的字段名称。
FieldNameHelper - Class in org.omg.CORBA
助手 FieldName 。
FieldNameHelper - Class in org.omg.DynamicAny
org / omg / DynamicAny / FieldNameHelper.java。
FieldNameHelper() - Constructor for class org.omg.CORBA. FieldNameHelper
FieldNameHelper() - Constructor for class org.omg.DynamicAny. FieldNameHelper
fieldOfViewProperty() - Method in class javafx.scene. PerspectiveCamera
指定相机投影的视野角度，以度为单位。
FieldPosition - Class in java.text
FieldPosition是由 Format及其子类使用的简单类，用于标识格式化输出中的字段。
FieldPosition(int) - Constructor for class java.text. FieldPosition
为给定字段创建一个FieldPosition对象。
FieldPosition(Format.Field) - Constructor for class java.text. FieldPosition
为给定的字段常量创建一个FieldPosition对象。
FieldPosition(Format.Field, int) - Constructor for class java.text. FieldPosition
为给定字段创建一个 FieldPosition对象。
fields - Variable in class java.util. Calendar
该日历的当前设置时间的日历字段值。
fields() - Method in interface com.sun.javadoc. ClassDoc
已过时。
返回 此类或接口中的 included字段。
fields() - Method in interface com.sun.jdi. ReferenceType
返回包含此类型中声明的每个Field的列表。
fields(boolean) - Method in interface com.sun.javadoc. ClassDoc
已过时。
返回此类或接口中的字段，过滤到指定的 access modifier option 。
fieldsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
返回 elements中的字段列表。
fieldsIn(Set<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
返回一组字段在 elements 。
fieldType() - Method in interface com.sun.javadoc. SerialFieldTag
已过时。
返回字段类型字符串。
fieldTypeDoc() - Method in interface com.sun.javadoc. SerialFieldTag
已过时。
返回ClassDoc的字段类型。
FieldView - Class in javax.swing.text
将多行纯文本视图扩展为适合单行编辑器视图。
FieldView(Element) - Constructor for class javax.swing.text. FieldView
构造一个包含在元素上的新FieldView。
file() - Method in interface com.sun.javadoc. SourcePosition
已过时。
源文件。
file() - Method in class java.lang. ProcessBuilder.Redirect
返回File源或目标与此重定向或相关null ，如果没有这样的文件。
File - Class in java.io
文件和目录路径名的抽象表示。
File(File, String) - Constructor for class java.io. File
从父抽象路径名和子路径名字符串创建一个新的 File实例。
File(String) - Constructor for class java.io. File
通过将给定的路径名字符串转换为抽象路径名来创建新的 File实例。
File(String, String) - Constructor for class java.io. File
从父路径名字符串和子路径名字符串创建新的 File实例。
File(URI) - Constructor for class java.io. File
通过将给定的 file: URI转换为抽象路径名来创建新的 File实例。
FILE - Static variable in class java.awt. JobAttributes.DestinationType
用于指定打印到文件的 DestinationType实例。
FILE - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported
主机专用文件名。
FILE_CHOOSER - Static variable in class javax.accessibility. AccessibleRole
一个专门的对话框，用于显示目录中的文件，并允许用户选择文件，浏览不同的目录或指定文件名。
FILE_CHOOSER - Static variable in class javax.swing.plaf.synth. Region
FileChooser区域。
FILE_CHOOSER_DIALOG - Static variable in class javax.swing. JRootPane
用于windowDecorationStyle属性的常量。
FILE_FILTER_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
用户更改了要显示的文件种类。
FILE_HIDING_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
标识显示隐藏文件属性的更改。
FILE_INHERIT - java.nio.file.attribute. AclEntryFlag
可以放在一个目录上，并指示ACL条目应该添加到每个新创建的非目录文件中。
FILE_SELECTION_MODE_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
识别选择类型的变化（单个，多个等）。
FILE_SOURCE_DSC - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“FileSource”标签一起使用的值。
FILE_SYSTEM_VIEW_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
说使用不同的对象来查找系统上可用的驱动器。
FILE_VERSION - Static variable in class javax.swing.text.html.parser. DTD
文件的版本
FILE_VIEW_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
说使用不同的对象来检索文件信息。
FileAlreadyExistsException - Exception in java.nio.file
尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
FileAlreadyExistsException(String) - Constructor for exception java.nio.file. FileAlreadyExistsException
构造这个类的一个实例。
FileAlreadyExistsException(String, String, String) - Constructor for exception java.nio.file. FileAlreadyExistsException
构造这个类的一个实例。
FileAttribute< T> - Interface in java.nio.file.attribute
封装了通过调用 createFile或 createDirectory方法创建新文件或目录时可以原子地设置的文件属性的值的对象。
FileAttributeView - Interface in java.nio.file.attribute
属性视图，它是与文件系统中的文件相关联的非不透明值的只读或可更新视图。
FileCacheImageInputStream - Class in javax.imageio.stream
一个 ImageInputStream的实现，从一个常规的 InputStream得到它的输入。
FileCacheImageInputStream(InputStream, File) - Constructor for class javax.imageio.stream. FileCacheImageInputStream
构造一个 FileCacheImageInputStream ，它将从给定的 InputStream读取。
FileCacheImageOutputStream - Class in javax.imageio.stream
实现 ImageOutputStream将其输出写入常规 OutputStream 。
FileCacheImageOutputStream(OutputStream, File) - Constructor for class javax.imageio.stream. FileCacheImageOutputStream
构造一个 FileCacheImageOutputStream ，它将写入给定的 outputStream 。
FileChannel - Class in java.nio.channels
用于读取，写入，映射和操作文件的通道。
FileChannel() - Constructor for class java.nio.channels. FileChannel
初始化此类的新实例。
FileChannel.MapMode - Class in java.nio.channels
文件映射模式的类型安全枚举。
FileChooser - Class in javafx.stage
提供对标准平台文件对话框的支持。
FileChooser() - Constructor for class javafx.stage. FileChooser
FileChooser.ExtensionFilter - Class in javafx.stage
定义一个扩展过滤器，用于过滤可以在FileDialog中根据文件扩展名选择哪些文件。
FileChooserUI - Class in javax.swing.plaf
可插拔的外观和界面 JFileChooser 。
FileChooserUI() - Constructor for class javax.swing.plaf. FileChooserUI
FileContents - Interface in javax.jnlp
FileContents对象封装文件的名称和内容。
FileDataSource - Class in javax.activation
FileDataSource类实现了一个封装文件的简单DataSource对象。
FileDataSource(File) - Constructor for class javax.activation. FileDataSource
从File对象创建FileDataSource。
FileDataSource(String) - Constructor for class javax.activation. FileDataSource
从指定的路径名创建一个FileDataSource。
FileDescriptor - Class in java.io
文件描述符类的实例用作表示打开文件，开放套接字或其他字节源或信宿的底层机器特定结构的不透明句柄。
FileDescriptor() - Constructor for class java.io. FileDescriptor
构造（无效）FileDescriptor对象。
FileDialog - Class in java.awt
FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
FileDialog(Dialog) - Constructor for class java.awt. FileDialog
创建一个加载文件的文件对话框。
FileDialog(Dialog, String) - Constructor for class java.awt. FileDialog
创建一个文件对话框窗口，其中包含用于加载文件的指定标题。
FileDialog(Dialog, String, int) - Constructor for class java.awt. FileDialog
创建一个带有指定标题的文件对话窗口，用于加载或保存文件。
FileDialog(Frame) - Constructor for class java.awt. FileDialog
创建一个加载文件的文件对话框。
FileDialog(Frame, String) - Constructor for class java.awt. FileDialog
创建一个文件对话框窗口，其中包含用于加载文件的指定标题。
FileDialog(Frame, String, int) - Constructor for class java.awt. FileDialog
创建一个带有指定标题的文件对话窗口，用于加载或保存文件。
FileFilter - Class in javax.swing.filechooser
FileFilter是 JFileChooser用于过滤向用户显示的文件集的抽象类。
FileFilter - Interface in java.io
抽象路径名的过滤器。
FileFilter() - Constructor for class javax.swing.filechooser. FileFilter
FileHandler - Class in java.util.logging
简单的文件记录 Handler 。
FileHandler() - Constructor for class java.util.logging. FileHandler
构造默认值 FileHandler 。
FileHandler(String) - Constructor for class java.util.logging. FileHandler
初始化 FileHandler以写入给定的文件名。
FileHandler(String, boolean) - Constructor for class java.util.logging. FileHandler
初始化一个 FileHandler以写入给定的文件名，可选附加。
FileHandler(String, int, int) - Constructor for class java.util.logging. FileHandler
初始化一个 FileHandler写入一组文件。
FileHandler(String, int, int, boolean) - Constructor for class java.util.logging. FileHandler
初始化 FileHandler以写入一组可选附件的文件。
FileHandler(String, long, int, boolean) - Constructor for class java.util.logging. FileHandler
初始化一个 FileHandler以写入一组可选的附加文件。
fileIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
文件图标
FileIcon16() - Constructor for class javax.swing.plaf.metal. MetalIconFactory.FileIcon16
FileImageInputStream - Class in javax.imageio.stream
一个 ImageInputStream的实现，从 File或 RandomAccessFile获取它的输入。
FileImageInputStream(File) - Constructor for class javax.imageio.stream. FileImageInputStream
构造一个 FileImageInputStream将从给定的读取 File 。
FileImageInputStream(RandomAccessFile) - Constructor for class javax.imageio.stream. FileImageInputStream
构造一个 FileImageInputStream ，它将从给定的 RandomAccessFile读取。
FileImageOutputStream - Class in javax.imageio.stream
实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
FileImageOutputStream(File) - Constructor for class javax.imageio.stream. FileImageOutputStream
构造一个 FileImageOutputStream ，将写入给定的 File 。
FileImageOutputStream(RandomAccessFile) - Constructor for class javax.imageio.stream. FileImageOutputStream
构造一个 FileImageOutputStream ，它将写入给定的 RandomAccessFile 。
FileInputStream - Class in java.io
A FileInputStream从文件系统中的文件获取输入字节。
FileInputStream(File) - Constructor for class java.io. FileInputStream
通过打开与实际文件的连接创建一个 FileInputStream ，该文件由文件系统中的 File对象 file命名。
FileInputStream(FileDescriptor) - Constructor for class java.io. FileInputStream
通过使用文件描述符 fdObj创建 FileInputStream ，该文件描述符表示与文件系统中的实际文件的现有连接。
FileInputStream(String) - Constructor for class java.io. FileInputStream
通过打开与实际文件的连接来创建一个 FileInputStream ，该文件由文件系统中的路径名 name命名。
fileKey() - Method in interface java.nio.file.attribute. BasicFileAttributes
返回唯一标识给定文件的对象，如果文件密钥不可用，则返回 null 。
FileLock - Class in java.nio.channels
表示文件区域上的锁的令牌。
FileLock(AsynchronousFileChannel, long, long, boolean) - Constructor for class java.nio.channels. FileLock
初始化此类的新实例。
FileLock(FileChannel, long, long, boolean) - Constructor for class java.nio.channels. FileLock
初始化此类的新实例。
FileLockInterruptionException - Exception in java.nio.channels
另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。
FileLockInterruptionException() - Constructor for exception java.nio.channels. FileLockInterruptionException
构造这个类的一个实例。
fileManager - Variable in class javax.tools. ForwardingJavaFileManager
所有方法的委托文件管理器。
fileManager(Function<StandardJavaFileManager, StandardJavaFileManager>) - Method in class jdk.jshell. JShell.Builder
配置 FileManager通过编译和源分析使用。
FILENAME - Static variable in interface javax.script. ScriptEngine
作为正在执行的文件的名称的命名值的保留键。
FileNameExtensionFilter - Class in javax.swing.filechooser
一个 FileFilter的实现过滤使用指定的一组扩展。
FileNameExtensionFilter(String, String...) - Constructor for class javax.swing.filechooser. FileNameExtensionFilter
创建一个具有指定的说明和文件扩展名的 FileNameExtensionFilter 。
FilenameFilter - Interface in java.io
用于实现此接口的类的实例用于过滤文件名。
FileNameMap - Interface in java.net
一个简单的界面，提供了一种在文件名和MIME类型字符串之间映射的机制。
FileNotFoundException - Exception in java.io
指示尝试打开由指定路径名表示的文件失败。
FileNotFoundException() - Constructor for exception java.io. FileNotFoundException
构造 FileNotFoundException其中包含 null作为其错误详细消息。
FileNotFoundException(String) - Constructor for exception java.io. FileNotFoundException
构造具有指定详细消息的 FileNotFoundException 。
fileObject - Variable in class javax.tools. ForwardingFileObject
所有方法被委派的文件对象。
FileObject - Interface in javax.tools
文件抽象的工具。
FileOpenService - Interface in javax.jnlp
FileOpenService服务允许用户从本地文件系统中选择一个文件，即使是在不受信任的执行环境中运行的应用程序。
FileOutputStream - Class in java.io
文件输出流是用于将数据写入 File或 FileDescriptor的输出流。
FileOutputStream(File) - Constructor for class java.io. FileOutputStream
创建文件输出流以写入由指定的 File对象表示的文件。
FileOutputStream(FileDescriptor) - Constructor for class java.io. FileOutputStream
创建文件输出流以写入指定的文件描述符，表示与文件系统中实际文件的现有连接。
FileOutputStream(File, boolean) - Constructor for class java.io. FileOutputStream
创建文件输出流以写入由指定的 File对象表示的文件。
FileOutputStream(String) - Constructor for class java.io. FileOutputStream
创建文件输出流以指定的名称写入文件。
FileOutputStream(String, boolean) - Constructor for class java.io. FileOutputStream
创建文件输出流以指定的名称写入文件。
FileOwnerAttributeView - Interface in java.nio.file.attribute
支持阅读或更新文件所有者的文件属性视图。
FilePermission - Class in java.io
此类表示访问文件或目录。
FilePermission(String, String) - Constructor for class java.io. FilePermission
使用指定的操作创建一个新的FilePermission对象。
Filer - Interface in javax.annotation.processing
该接口支持通过注释处理器创建新文件。
FileReader - Class in java.io
阅读字符文件的便利课。
FileReader(File) - Constructor for class java.io. FileReader
创建一个新的 FileReader ，给予 File读取。
FileReader(FileDescriptor) - Constructor for class java.io. FileReader
创建新的 FileReader ，给予 FileDescriptor读取。
FileReader(String) - Constructor for class java.io. FileReader
创建一个新的 FileReader ，给定要读取的文件的名称。
FileRenderer() - Constructor for class javax.swing.plaf.metal. MetalFileChooserUI.FileRenderer
已过时。
FilerException - Exception in javax.annotation.processing
表示Filer检测到尝试打开将违反Filer提供的保证的Filer 。
FilerException(String) - Constructor for exception javax.annotation.processing. FilerException
使用指定的详细消息构造异常。
Files - Class in java.nio.file
该类只包含对文件，目录或其他类型文件进行操作的静态方法。
FILES - javax.xml.catalog. CatalogFeatures.Feature
javax.xml.catalog.files属性，如“产品特性”表的 FILES所述。
FILES - Static variable in class javafx.scene.input. DataFormat
表示文件列表。
FILES_AND_DIRECTORIES - Static variable in class javax.swing. JFileChooser
显示文件和目录的指令。
FILES_ONLY - Static variable in class javax.swing. JFileChooser
仅显示文件的指令。
FileSaveService - Interface in javax.jnlp
FileSaveService服务允许用户将文件保存到本地文件系统，即使是在不受信任的执行环境中运行的应用程序。
FilesEvent - Class in java.awt.desktop
辅助事件包含文件列表。
FileStore - Class in java.nio.file
文件存储
FileStore() - Constructor for class java.nio.file. FileStore
初始化此类的新实例。
FileStoreAttributeView - Interface in java.nio.file.attribute
属性视图是FileStore的属性的只读或可更新视图。
FileSystem - Class in java.nio.file
提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。
FileSystem() - Constructor for class java.nio.file. FileSystem
初始化此类的新实例。
FileSystemAlreadyExistsException - Exception in java.nio.file
新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新
FileSystemAlreadyExistsException() - Constructor for exception java.nio.file. FileSystemAlreadyExistsException
构造这个类的一个实例。
FileSystemAlreadyExistsException(String) - Constructor for exception java.nio.file. FileSystemAlreadyExistsException
构造这个类的一个实例。
FileSystemException - Exception in java.nio.file
在一个或两个文件上的文件系统操作失败时抛出。
FileSystemException(String) - Constructor for exception java.nio.file. FileSystemException
构造这个类的一个实例。
FileSystemException(String, String, String) - Constructor for exception java.nio.file. FileSystemException
构造这个类的一个实例。
FileSystemLoopException - Exception in java.nio.file
当遇到文件系统循环或循环时抛出的检查异常。
FileSystemLoopException(String) - Constructor for exception java.nio.file. FileSystemLoopException
构造这个类的一个实例。
FileSystemNotFoundException - Exception in java.nio.file
无法找到文件系统时抛出的运行时异常。
FileSystemNotFoundException() - Constructor for exception java.nio.file. FileSystemNotFoundException
构造这个类的一个实例。
FileSystemNotFoundException(String) - Constructor for exception java.nio.file. FileSystemNotFoundException
构造这个类的一个实例。
FileSystemProvider - Class in java.nio.file.spi
文件系统的服务提供者类。
FileSystemProvider() - Constructor for class java.nio.file.spi. FileSystemProvider
初始化此类的新实例。
FileSystems - Class in java.nio.file
文件系统的工厂方法。
FileSystemView - Class in javax.swing.filechooser
FileSystemView是JFileChooser到文件系统的网关。
FileSystemView() - Constructor for class javax.swing.filechooser. FileSystemView
构造一个FileSystemView。
FileTime - Class in java.nio.file.attribute
表示文件时间戳属性的值。
FileTypeDetector - Class in java.nio.file.spi
用于探测文件以猜测其文件类型的文件类型检测器。
FileTypeDetector() - Constructor for class java.nio.file.spi. FileTypeDetector
初始化此类的新实例。
FileTypeMap - Class in javax.activation
FileTypeMap是一个抽象类，为文件提供数据输入界面。
FileTypeMap() - Constructor for class javax.activation. FileTypeMap
默认构造函数。
FileView - Class in javax.swing.filechooser
FileView定义了可被实现为提供有用于UI信息的文件选择一个抽象类 File 。
FileView() - Constructor for class javax.swing.filechooser. FileView
FileVisitOption - Enum in java.nio.file
定义文件树遍历选项。
FileVisitor< T> - Interface in java.nio.file
文件访问者
FileVisitResult - Enum in java.nio.file
结果类型为FileVisitor 。
FileWriter - Class in java.io
方便课写字符文件。
FileWriter(File) - Constructor for class java.io. FileWriter
给一个File对象构造一个FileWriter对象。
FileWriter(FileDescriptor) - Constructor for class java.io. FileWriter
构造与文件描述符关联的FileWriter对象。
FileWriter(File, boolean) - Constructor for class java.io. FileWriter
给一个File对象构造一个FileWriter对象。
FileWriter(String) - Constructor for class java.io. FileWriter
构造一个给定文件名的FileWriter对象。
FileWriter(String, boolean) - Constructor for class java.io. FileWriter
构造一个FileWriter对象，给出一个带有布尔值的文件名，表示是否附加写入的数据。
fill - Variable in class java.awt. GridBagConstraints
当组件的显示区域大于组件的请求大小时，将使用此字段。
fill() - Method in class java.util.zip. InflaterInputStream
填写输入缓冲区以获得更多的数据解压缩。
fill() - Method in class javafx.scene.canvas. GraphicsContext
填充当前填充油漆的路径。
fill(boolean[], boolean) - Static method in class java.util. Arrays
将指定的布尔值分配给指定的布尔数组的每个元素。
fill(boolean[], int, int, boolean) - Static method in class java.util. Arrays
将指定的布尔值分配给指定数组布尔值的指定范围的每个元素。
fill(byte[], byte) - Static method in class java.util. Arrays
将指定的字节值分配给指定字节数组的每个元素。
fill(byte[], int, int, byte) - Static method in class java.util. Arrays
将指定的字节值分配给指定字节数组的指定范围的每个元素。
fill(char[], char) - Static method in class java.util. Arrays
将指定的char值分配给指定的char数组的每个元素。
fill(char[], int, int, char) - Static method in class java.util. Arrays
将指定的char值分配给指定的char数组的指定范围的每个元素。
fill(double[], double) - Static method in class java.util. Arrays
将指定的double值分配给指定的双精度数组的每个元素。
fill(double[], int, int, double) - Static method in class java.util. Arrays
将指定的double值分配给指定的双精度数组范围的每个元素。
fill(float[], float) - Static method in class java.util. Arrays
将指定的float值分配给指定的浮点数组的每个元素。
fill(float[], int, int, float) - Static method in class java.util. Arrays
将指定的浮点值分配给指定的浮点数组的指定范围的每个元素。
fill(int[], int) - Static method in class java.util. Arrays
将指定的int值分配给指定的int数组的每个元素。
fill(int[], int, int, int) - Static method in class java.util. Arrays
将指定的int值分配给指定的int数组的指定范围的每个元素。
fill(long[], int, int, long) - Static method in class java.util. Arrays
将指定的long值分配给指定的longs数组的指定范围的每个元素。
fill(long[], long) - Static method in class java.util. Arrays
将指定的long值分配给指定的longs数组的每个元素。
fill(short[], int, int, short) - Static method in class java.util. Arrays
将指定的短值分配给指定的短裤数组的指定范围的每个元素。
fill(short[], short) - Static method in class java.util. Arrays
将指定的短值分配给指定的短裤数组的每个元素。
fill(Shape) - Method in class java.awt. Graphics2D
使用 Graphics2D上下文的设置填充 Shape的内部。
fill(Object[], int, int, Object) - Static method in class java.util. Arrays
将指定的对象引用分配给指定的对象数组的指定范围的每个元素。
fill(Object[], Object) - Static method in class java.util. Arrays
将指定的对象引用分配给指定的对象数组的每个元素。
fill(List<? super T>, T) - Static method in class java.util. Collections
用指定的元素替换指定列表的所有元素。
fill(ObservableList<? super T>, T) - Static method in class javafx.collections. FXCollections
用obj填写提供的列表。
FILL - javafx.scene.shape. DrawMode
通过填充多边形的内部渲染多边形原语。
FILL - Static variable in class java.awt.font. ShapeGraphicAttribute
一个表示形状的键应该被填充。
FILL_ORDER_LEFT_TO_RIGHT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“FillOrder”标签一起使用的值。
FILL_ORDER_RIGHT_TO_LEFT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“FillOrder”标签一起使用的值。
fill3DRect(int, int, int, int, boolean) - Method in class java.awt. Graphics
绘制一个填充有当前颜色的3-D高亮矩形。
fill3DRect(int, int, int, int, boolean) - Method in class java.awt. Graphics2D
绘制一个填充有当前颜色的3-D高亮矩形。
fill3DRect(int, int, int, int, boolean) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.fill3DRect 。
fillArc(double, double, double, double, double, double, ArcType) - Method in class javafx.scene.canvas. GraphicsContext
使用当前的填充油漆填充弧。
fillArc(int, int, int, int, int, int) - Method in class java.awt. Graphics
填写一个圆形或椭圆形的圆弧覆盖指定的矩形。
fillArc(int, int, int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.fillArc 。
filledSlider - Variable in class javax.swing.plaf.metal. MetalSliderUI
该物业的价值 JSlider.isFilled 。
Filler(Dimension, Dimension, Dimension) - Constructor for class javax.swing. Box.Filler
创建具有给定大小范围的形状的构造函数。
FILLER - Static variable in class javax.accessibility. AccessibleRole
填充用户界面空间的对象。
fillHeightProperty() - Method in class javafx.scene.layout. HBox
是否调整大小的小孩将被调整大小以填补hbox的全部高度，或者调整大小至其首选高度，并根据 alignment vpos值对齐。
fillHeightProperty() - Method in class javafx.scene.layout. RowConstraints
行的垂直填充策略。
fillInStackTrace() - Method in class java.lang. Throwable
填写执行堆栈跟踪。
fillOval(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
使用当前的填充油漆填充椭圆。
fillOval(int, int, int, int) - Method in class java.awt. Graphics
用当前颜色填充由指定矩形界定的椭圆。
fillOval(int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.fillOval 。
fillPolygon(double[], double[], int) - Method in class javafx.scene.canvas. GraphicsContext
使用当前设置的填充油漆填充具有给定点的多边形。
fillPolygon(int[], int[], int) - Method in class java.awt. Graphics
填充由 x和 y坐标数组定义的封闭多边形。
fillPolygon(int[], int[], int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.fillPolygon 。
fillPolygon(Polygon) - Method in class java.awt. Graphics
使用图形上下文的当前颜色填充由指定的多边形对象定义的多边形。
fillProperty() - Method in class javafx.scene. Scene
定义这个 Scene的背景填充。
fillProperty() - Method in class javafx.scene.shape. Shape
使用 Paint上下文的设置定义填充 Shape内部的参数。
fillProperty() - Method in class javafx.scene. SubScene
定义这个 SubScene的背景填充。
fillRect(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
使用当前的填充油漆填充矩形。
fillRect(int, int, int, int) - Method in class java.awt. Graphics
填写指定的矩形。
fillRect(int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.fillRect 。
fillRoundRect(double, double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
使用当前的填充油漆填充圆角矩形。
fillRoundRect(int, int, int, int, int, int) - Method in class java.awt. Graphics
使用当前颜色填充指定的圆角矩形。
fillRoundRect(int, int, int, int, int, int) - Method in class javax.swing. DebugGraphics
覆盖 Graphics.fillRoundRect 。
FillRule - Enum in javafx.scene.shape
用于确定路径内部的填充规则。
fillRuleProperty() - Method in class javafx.scene.shape. Path
定义用于确定路径内部的填充规则常数。
fillRuleProperty() - Method in class javafx.scene.shape. SVGPath
定义用于确定路径内部的填充规则常数。
fillText(String, double, double) - Method in class javafx.scene.canvas. GraphicsContext
使用当前的填充颜色属性填充位置x，y处的给定文本字符串。
fillText(String, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
填写文本并包含字符串的最大宽度。
FillTransition - Class in javafx.animation
这个 Transition创建了一个动画，它改变了 duration的形状填充。
FillTransition() - Constructor for class javafx.animation. FillTransition
构造函数为 FillTransition
FillTransition(Duration) - Constructor for class javafx.animation. FillTransition
构造函数为 FillTransition
FillTransition(Duration, Color, Color) - Constructor for class javafx.animation. FillTransition
构造函数为 FillTransition
FillTransition(Duration, Shape) - Constructor for class javafx.animation. FillTransition
构造函数为 FillTransition
FillTransition(Duration, Shape, Color, Color) - Constructor for class javafx.animation. FillTransition
构造函数为 FillTransition
fillWidthProperty() - Method in class javafx.scene.layout. ColumnConstraints
列的横向填充策略。
fillWidthProperty() - Method in class javafx.scene.layout. VBox
是否调整大小的小孩将被调整大小以填满vbox的全部宽度，或者调整大小至其首选宽度，并根据 alignment hpos值对齐。
filter(BufferedImage, BufferedImage) - Method in class java.awt.image. AffineTransformOp
转换源 BufferedImage并将结果存储在目标 BufferedImage 。
filter(BufferedImage, BufferedImage) - Method in interface java.awt.image. BufferedImageOp
在 BufferedImage上执行单输入/单输出操作。
filter(BufferedImage, BufferedImage) - Method in class java.awt.image. ColorConvertOp
ColorConverts源BufferedImage。
filter(BufferedImage, BufferedImage) - Method in class java.awt.image. ConvolveOp
对BufferedImages执行卷积。
filter(BufferedImage, BufferedImage) - Method in class java.awt.image. LookupOp
对 BufferedImage执行查找操作。
filter(BufferedImage, BufferedImage) - Method in class java.awt.image. RescaleOp
重新调整源BufferedImage。
filter(Raster, WritableRaster) - Method in class java.awt.image. AffineTransformOp
转换源 Raster并将结果存储在目标 Raster 。
filter(Raster, WritableRaster) - Method in class java.awt.image. BandCombineOp
使用构造函数中指定的矩阵转换 Raster 。
filter(Raster, WritableRaster) - Method in class java.awt.image. ColorConvertOp
Color转换源光栅中的图像数据。
filter(Raster, WritableRaster) - Method in class java.awt.image. ConvolveOp
对光栅进行卷积。
filter(Raster, WritableRaster) - Method in class java.awt.image. LookupOp
对 Raster执行查找操作。
filter(Raster, WritableRaster) - Method in interface java.awt.image. RasterOp
执行从源光栅到目标光栅的单输入/单输出操作。
filter(Raster, WritableRaster) - Method in class java.awt.image. RescaleOp
重新调整源光栅中的像素数据。
filter(Object) - Method in interface javax.imageio.spi. ServiceRegistry.Filter
返回 true如果给定 provider对象通过这个定义的标准匹配 Filter 。
filter(DoublePredicate) - Method in interface java.util.stream. DoubleStream
返回由与此给定谓词匹配的此流的元素组成的流。
filter(IntPredicate) - Method in interface java.util.stream. IntStream
返回由与此给定谓词匹配的此流的元素组成的流。
filter(LongPredicate) - Method in interface java.util.stream. LongStream
返回由与此给定谓词匹配的此流的元素组成的流。
filter(Predicate<? super T>) - Method in class java.util. Optional
如果存在值，并且该值与给定谓词匹配，则返回描述该值的 Optional ，否则返回一个空的 Optional 。
filter(Predicate<? super T>) - Method in interface java.util.stream. Stream
返回由与此给定谓词匹配的此流的元素组成的流。
filter(List<Locale.LanguageRange>, Collection<Locale>) - Static method in class java.util. Locale
使用RFC 4647中定义的过滤机制返回匹配的 Locale实例的列表。
filter(List<Locale.LanguageRange>, Collection<Locale>, Locale.FilteringMode) - Static method in class java.util. Locale
使用RFC 4647中定义的过滤机制返回匹配的 Locale实例列表。
filter(GuardedInvocation, LinkRequest, LinkerServices) - Method in interface jdk.dynalink.linker. GuardedInvocationTransformer
给予一个有保护的调用，返回相同或可能不同的守卫调用。
Filter - Class in com.sun.net.httpserver
用于预处理和后处理传入请求的过滤器。
Filter - Interface in java.util.logging
可以使用过滤器对超出记录级别提供的控制范围内的记录进行细粒度控制。
Filter() - Constructor for class com.sun.net.httpserver. Filter
FILTER_ACCEPT - Static variable in interface org.w3c.dom.ls. LSParserFilter
接受节点。
FILTER_ACCEPT - Static variable in interface org.w3c.dom.traversal. NodeFilter
接受节点。
FILTER_INTERRUPT - Static variable in interface org.w3c.dom.ls. LSParserFilter
中断文件的正常处理。
FILTER_REJECT - Static variable in interface org.w3c.dom.ls. LSParserFilter
拒绝节点及其子节点。
FILTER_REJECT - Static variable in interface org.w3c.dom.traversal. NodeFilter
拒绝节点。
FILTER_SKIP - Static variable in interface org.w3c.dom.ls. LSParserFilter
跳过这个单个节点。
FILTER_SKIP - Static variable in interface org.w3c.dom.traversal. NodeFilter
跳过这个单个节点。
Filter.Chain - Class in com.sun.net.httpserver
与HttpServer关联的一连串过滤器。
filterArguments(int, MethodHandle...) - Method in class jdk.dynalink.linker. GuardedInvocation
将参数过滤器应用于调用和保护（如果存在且具有至少 pos + 1参数）与 MethodHandles.filterArguments(MethodHandle, int, MethodHandle...) 。
filterArguments(MethodHandle, int, MethodHandle...) - Static method in class java.lang.invoke. MethodHandles
通过预处理其一个或多个参数来适应目标方法句柄，每个参数具有自己的一元过滤器函数，然后使用每个预处理的参数替换为相应过滤器函数的结果来调用目标。
FilterBypass() - Constructor for class javax.swing.text. DocumentFilter.FilterBypass
FilterBypass() - Constructor for class javax.swing.text. NavigationFilter.FilterBypass
FilterComboBoxModel() - Constructor for class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxModel
构造一个 FilterComboBoxModel的实例。
FilterComboBoxRenderer() - Constructor for class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxRenderer
filtered(Predicate<E>) - Method in interface javafx.collections. ObservableList
使用指定的谓词创建此列表的FilteredList包装器。
FILTERED - Static variable in class java.util.zip. Deflater
压缩策略最适用于主要由具有随机分布的小值组成的数据。
FilteredImageSource - Class in java.awt.image
这个类是ImageProducer接口的一个实现，它接收一个现有的图像和一个过滤器对象，并使用它们来生成原始图像的新过滤版本的图像数据。
FilteredImageSource(ImageProducer, ImageFilter) - Constructor for class java.awt.image. FilteredImageSource
从现有的ImageProducer和过滤器对象构造一个ImageProducer对象。
FilteredList< E> - Class in javafx.collections.transformation
包装一个ObservableList并使用提供的谓词过滤其内容。
FilteredList(ObservableList<E>) - Constructor for class javafx.collections.transformation. FilteredList
在源列表周围构造一个新的FilteredList包装器。
FilteredList(ObservableList<E>, Predicate<? super E>) - Constructor for class javafx.collections.transformation. FilteredList
在源列表周围构造一个新的FilteredList包装器。
FilteredRowSet - Interface in javax.sql.rowset
FilteredRowSet所有标准实现必须实现的标准接口。
filterIndexColorModel(IndexColorModel) - Method in class java.awt.image. RGBImageFilter
通过RGBImageFilter子类必须提供的filterRGB函数运行其颜色表中的每个条目来过滤IndexColorModel对象。
filtering(Predicate<? super T>, Collector<? super T, A, R>) - Static method in class java.util.stream. Collectors
适应一个 Collector相同类型的一个接受元件 T通过将谓词给每个输入元素并且如果所述谓词仅返回累积 true 。
FilterInputStream - Class in java.io
A FilterInputStream包含一些其他输入流，它用作其基本的数据源，可能会沿着路径转换数据或提供附加功能。
FilterInputStream(InputStream) - Constructor for class java.io. FilterInputStream
创建 FilterInputStream通过分配参数 in到外地 this.in ，以便记住它供以后使用。
filterInternalObjects(MethodHandle) - Method in interface jdk.dynalink.linker. LinkerServices
修改方法句柄，以便可以接收潜在的内部语言运行时对象的任何参数都将添加一个过滤器，以防止它们转义，可能通过包装它们。
FilterOutputStream - Class in java.io
这个类是过滤输出流的所有类的超类。
FilterOutputStream(OutputStream) - Constructor for class java.io. FilterOutputStream
创建一个基于指定底层输出流的输出流过滤器。
FilterReader - Class in java.io
用于读取过滤后的字符流的抽象类。
FilterReader(Reader) - Constructor for class java.io. FilterReader
创建一个新的过滤阅读器。
filterReturnValue(MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles
通过使用过滤器（另一种方法句柄）对其返回值（如果有的话）进行后处理来适应目标方法句柄。
filterRGB(int, int, int) - Method in class java.awt.image. RGBImageFilter
子类必须指定一种将默认RGB ColorModel中的单个输入像素转换为单个输出像素的方法。
filterRGB(int, int, int) - Method in class javax.swing. GrayFilter
覆盖 RGBImageFilter.filterRGB 。
filterRGBPixels(int, int, int, int, int[], int, int) - Method in class java.awt.image. RGBImageFilter
通过filterRGB方法逐个传递默认RGB ColorModel中的像素缓冲区。
filters - Variable in class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxModel
一组文件过滤器。
filterTags(List<Locale.LanguageRange>, Collection<String>) - Static method in class java.util. Locale
使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
filterTags(List<Locale.LanguageRange>, Collection<String>, Locale.FilteringMode) - Static method in class java.util. Locale
使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。
FilterWriter - Class in java.io
用于编写过滤后的字符流的抽象类。
FilterWriter(Writer) - Constructor for class java.io. FilterWriter
创建一个新的过滤的作者。
FINAL - javafx.scene.input. KeyCode
用于亚洲键盘的输入法支持常数。
FINAL - javax.lang.model.element. Modifier
修饰词 final
FINAL - Static variable in class java.lang.reflect. Modifier
int值代表 final修饰符。
FINAL_QUOTE_PUNCTUATION - Static variable in class java.lang. Character
Unicode规范中的一般类别“Pf”。
finalize() - Method in class java.awt.color. ICC_Profile
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.awt. Graphics
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.awt.image. ColorModel
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.awt.image. IndexColorModel
已过时。
finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.awt. PrintJob
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.io. FileInputStream
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中的描述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.io. FileOutputStream
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.lang. Enum
枚举类不能有finalize方法。
finalize() - Method in class java.lang. Object
已过时。
定稿机制本质上是有问题的。 定稿可能导致性能问题，死锁和挂起。 敲定错误可能导致资源泄漏; 如果不再需要，无法取消定稿; 并且在对不同对象的finalize方法的调用中没有指定排序。 此外，关于定稿的时间并不保证。 只有在无限期延迟之后，才能在可终止对象上调用finalize方法（如果有的话）。 其实例持有非堆资源的类应提供一种方法来实现这些资源的显式释放，如果适用，它们还应实现AutoCloseable 。 当对象变得不可达时， Cleaner和PhantomReference提供了更灵活和更有效的方式来释放资源。
finalize() - Method in class java.util.concurrent. ThreadPoolExecutor
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.util.zip. Deflater
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.util.zip. Inflater
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class java.util.zip. ZipFile
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中的描述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class javax.imageio.spi. ServiceRegistry
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class javax.imageio.stream. FileCacheImageInputStream
已过时。
finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中的描述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class javax.imageio.stream. FileImageInputStream
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class javax.imageio.stream. FileImageOutputStream
已过时。
finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class javax.imageio.stream. ImageInputStreamImpl
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalize() - Method in class javax.imageio.stream. MemoryCacheImageInputStream
已过时。
finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
finalRequest() - Method in class jdk.incubator.http. HttpResponse
返回在线上发送的最终HttpRequest进行交换（可能或可能不等于初始请求）。
finalSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management. Query
返回一个表示字符串参数匹配约束的查询表达式。
find() - Method in class java.util.regex. Matcher
尝试找到匹配模式的输入序列的下一个子序列。
find(int) - Method in class java.util.regex. Matcher
重新设置该匹配器，然后尝试从指定的索引开始找到匹配模式的输入序列的下一个子序列。
find(String) - Method in interface java.lang.module. ModuleFinder
查找给定名称的模块的引用。
find(String) - Method in interface java.lang.module. ModuleReader
查找资源，将URI返回给模块中的资源。
find(Path, int, BiPredicate<Path, BasicFileAttributes>, FileVisitOption...) - Static method in class java.nio.file. Files
返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。
FIND - javafx.scene.input. KeyCode
常数为 Find键。
find_POA(String, boolean) - Method in interface org.omg.PortableServer. POAOperations
如果目标POA是具有指定名称（相对于目标POA）的子级POA的父级，则返回该子级POA。
findAll() - Method in interface java.lang.module. ModuleFinder
返回此查找器可以找到的所有模块引用的集合。
findAll(String) - Method in class java.util. Scanner
返回与提供的模式字符串相匹配的匹配结果流。
findAll(Pattern) - Method in class java.util. Scanner
返回此扫描仪的匹配结果流。
findAny() - Method in interface java.util.stream. DoubleStream
返回OptionalDouble描述流的一些元件，或一个空OptionalDouble如果流是空的。
findAny() - Method in interface java.util.stream. IntStream
返回OptionalInt描述流的一些元件，或一个空OptionalInt如果流是空的。
findAny() - Method in interface java.util.stream. LongStream
返回OptionalLong描述流的一些元件，或一个空OptionalLong如果流是空的。
findAny() - Method in interface java.util.stream. Stream
返回Optional描述流的一些元件，或一个空Optional如果流是空的。
findAssociatedMBeans(ObjectName, String, String) - Method in class javax.management.relation. RelationService
检索与某个关系中的给定关联的MBean。
findAssociatedMBeans(ObjectName, String, String) - Method in interface javax.management.relation. RelationServiceMBean
检索与某个关系中的给定关联的MBean。
findByName(String) - Static method in enum javafx.scene.text. FontPosture
以其名称返回 FontPosture 。
findByName(String) - Static method in enum javafx.scene.text. FontWeight
以其名称返回 FontWeight 。
findByWeight(int) - Static method in enum javafx.scene.text. FontWeight
返回由CSS和OpenType规范定义的权重值最接近的 FontWeight 。
findClass(String) - Method in interface com.sun.javadoc. ClassDoc
已过时。
在该类doc的上下文中找到指定的类或接口。
findClass(String) - Method in interface com.sun.javadoc. PackageDoc
已过时。
在此包中查找类或接口。
findClass(String) - Method in class java.lang. ClassLoader
找到具有指定的 类别binary name 。
findClass(String) - Method in class java.lang.invoke. MethodHandles.Lookup
从这个 Lookup对象定义的查找上下文中按名称查找一个类。
findClass(String) - Method in class java.net. URLClassLoader
从URL搜索路径查找并加载具有指定名称的类。
findClass(String) - Method in class javax.management.loading. MLet
这是正在重新定义的类加载器的主要方法。
findClass(String) - Method in class jdk.jshell.execution. DirectExecutionControl
查找具有指定二进制名称的类。
findClass(String) - Method in interface jdk.jshell.execution. LoaderDelegate
查找具有指定二进制名称的类。
findClass(String, String) - Method in class java.lang. ClassLoader
在定义到此类加载器的模块中找到给定的类别 binary name 。
findColumn(String) - Method in interface java.sql. ResultSet
将给定的 ResultSet列标签映射到其 ResultSet列索引。
findColumn(String) - Method in class javax.swing.table. AbstractTableModel
返回一个给定其名称的列。
findComponentAt(int, int) - Method in class java.awt. Container
找到包含指定位置的可见子组件。
findComponentAt(Point) - Method in class java.awt. Container
找到包含指定点的可见子组件。
findConstructor(Class<?>, MethodType) - Method in class java.lang.invoke. MethodHandles.Lookup
使用指定类型的构造函数生成创建对象并初始化它的方法句柄。
findDeadlockedThreads() - Method in interface java.lang.management. ThreadMXBean
查找处于死锁等待获取对象监视器的线程的循环，或 ownable synchronizers 。
findEditor(Class<?>) - Static method in class java.beans. PropertyEditorManager
找到给定目标类型的值编辑器。
findElementMatchingTag(HTMLDocument, int, HTML.Tag) - Method in class javax.swing.text.html. HTMLEditorKit.HTMLTextAction
返回 offset匹配 tag最深的元素。
FindException - Exception in java.lang.module
抛出一个ModuleFinder发生错误时发现一个模块。
FindException() - Constructor for exception java.lang.module. FindException
构造一个 FindException ，没有详细信息。
FindException(String) - Constructor for exception java.lang.module. FindException
构造具有给定详细消息的 FindException 。
FindException(String, Throwable) - Constructor for exception java.lang.module. FindException
构造一个 FindException与给定的详细信息和原因。
FindException(Throwable) - Constructor for exception java.lang.module. FindException
构造一个 FindException与给定的原因。
findFirst() - Method in class java.util. ServiceLoader
加载此装载程序服务的第一个可用服务提供商。
findFirst() - Method in interface java.util.stream. DoubleStream
返回OptionalDouble描述此流的第一个元素，或空OptionalDouble如果流是空的。
findFirst() - Method in interface java.util.stream. IntStream
返回OptionalInt描述此流的第一个元素，或空OptionalInt如果流是空的。
findFirst() - Method in interface java.util.stream. LongStream
返回OptionalLong描述此流的第一个元素，或空OptionalLong如果流是空的。
findFirst() - Method in interface java.util.stream. Stream
返回Optional描述此流的第一个元素，或空Optional如果流是空的。
findFirst(String) - Static method in interface java.util.spi. ToolProvider
返回具有给定名称的ToolProvider的第一个实例，由使用系统类加载器的ServiceLoader加载。
findFirst(Operation) - Static method in enum jdk.dynalink. StandardNamespace
如果传递的操作是一个NamespaceOperation ，或者一个NamedOperation包装一个NamespaceOperation ，那么它返回它的命名空间列表中的第一个（如果有的话） StandardNamespace 。
findFocusOwner(Component) - Static method in class javax.swing. SwingUtilities
已过时。
截至1.4，由KeyboardFocusManager.getFocusOwner()代替。
findGetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
产生方法句柄，给非静态字段的读访问权限。
findGetter(Class<?>, String, Class<?>) - Method in class jdk.dynalink.linker.support. Lookup
执行MethodHandles.Lookup.findGetter(Class, String, Class) ，将任何遇到的IllegalAccessException转换成IllegalAccessError和NoSuchFieldException成NoSuchFieldError 。
findInLine(String) - Method in class java.util. Scanner
尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。
findInLine(Pattern) - Method in class java.util. Scanner
尝试找到忽略分隔符的指定模式的下一个出现。
findLibrary(String) - Method in class java.lang. ClassLoader
返回本机库的绝对路径名。
findLibrary(String) - Method in class javax.management.loading. MLet
返回本机库的绝对路径名。
findLoadedClass(String) - Method in class java.lang. ClassLoader
如果这个装载程序已被Java虚拟机记录为具有该类别的启动加载程序，则返回具有给定的 binary name的类 binary name 。
findLoader(String) - Method in class java.lang. ModuleLayer
返回具有给定名称的模块的 ClassLoader 。
findMBeanServer(String) - Static method in class javax.management. MBeanServerFactory
返回已注册MBeanServer对象的列表。
findMedia(float, float, int) - Static method in class javax.print.attribute.standard. MediaSize
指定的维度用于从所有标准MediaSize实例中定位匹配的MediaSize实例。
findModule(String) - Method in class java.lang.module. Configuration
在此配置中查找已解决的模块，或者在此配置中 找不到parent配置。
findModule(String) - Method in class java.lang. ModuleLayer
在此层中返回具有给定名称的模块，或者如果不在此层中，则 返回parent层。
findMonitorDeadlockedThreads() - Method in interface java.lang.management. ThreadMXBean
查找处于死锁等待获取对象监视器的线程的循环。
findOffsetToCharactersInString(char[], int) - Method in class javax.swing.text. ParagraphView
查找文档中的下一个字符，其中字符为 string ，从偏移 start开始。
findOwnSpecial(MethodHandles.Lookup, String, Class<?>, Class<?>...) - Static method in class jdk.dynalink.linker.support. Lookup
给定一个查找，找到使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。
findOwnSpecial(String, Class<?>, Class<?>...) - Method in class jdk.dynalink.linker.support. Lookup
查找使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。
findOwnStatic(MethodHandles.Lookup, String, Class<?>, Class<?>...) - Static method in class jdk.dynalink.linker.support. Lookup
给定一个查找，找到使用 Lookup.findStatic(Class, String, MethodType)该查找的类的方法。
findOwnStatic(String, Class<?>, Class<?>...) - Method in class jdk.dynalink.linker.support. Lookup
查找使用 Lookup.findStatic(Class, String, MethodType)该查找的类的方法。
findReferencingRelations(ObjectName, String, String) - Method in class javax.management.relation. RelationService
检索给定MBean引用的关系。
findReferencingRelations(ObjectName, String, String) - Method in interface javax.management.relation. RelationServiceMBean
检索给定MBean引用的关系。
findRelationsOfType(String) - Method in class javax.management.relation. RelationService
返回给定类型的关系的关系id。
findRelationsOfType(String) - Method in interface javax.management.relation. RelationServiceMBean
返回给定类型的关系的关系id。
findResource(String) - Method in class java.lang. ClassLoader
找到具有给定名称的资源。
findResource(String) - Method in class java.net. URLClassLoader
在URL搜索路径上查找具有指定名称的资源。
findResource(String, String) - Method in class java.lang. ClassLoader
返回一个URL定义到此类加载器的模块中的资源。
findResources(String) - Method in class java.lang. ClassLoader
返回表示具有给定名称的所有资源的URL对象的枚举。
findResources(String) - Method in class java.net. URLClassLoader
返回表示URL搜索路径上具有指定名称的所有资源的URL的枚举。
findSetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
产生一个给非静态字段写入访问权限的方法句柄。
findSpecial(Class<?>, String, MethodType) - Method in class jdk.dynalink.linker.support. Lookup
对底层查找执行 MethodHandles.Lookup.findSpecial(Class, String, MethodType, Class) 。
findSpecial(Class<?>, String, MethodType, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
为虚拟方法生成早期绑定的方法句柄。
findStatic(Class<?>, String, MethodType) - Method in class java.lang.invoke. MethodHandles.Lookup
为静态方法生成方法句柄。
findStatic(Class<?>, String, MethodType) - Method in class jdk.dynalink.linker.support. Lookup
对底层查找执行 MethodHandles.Lookup.findStatic(Class, String, MethodType) 。
findStaticGetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
产生一个给静态字段读取访问权限的方法句柄。
findStaticSetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
生成方法句柄，给静态字段写权限。
findStaticVarHandle(Class<?>, String, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
产生一个VarHandle，可以访问 name类中声明的类型为 type的静态字段 decl 。
findSystemClass(String) - Method in class java.lang. ClassLoader
查找具有指定的 类别binary name ，如果需要加载它。
findVarHandle(Class<?>, String, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
产生一个VarHandle，可以访问在 name类中声明的类型为 type的非静态字段 recv 。
findVirtual(Class<?>, String, MethodType) - Method in class java.lang.invoke. MethodHandles.Lookup
为虚拟方法生成方法句柄。
findVirtual(Class<?>, String, MethodType) - Method in class jdk.dynalink.linker.support. Lookup
对底层查找执行 MethodHandles.Lookup.findVirtual(Class, String, MethodType) 。
findWithinHorizon(String, int) - Method in class java.util. Scanner
尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。
findWithinHorizon(Pattern, int) - Method in class java.util. Scanner
尝试找到指定模式的下一个出现。
fine(String) - Method in class java.util.logging. Logger
记录一个FINE消息。
fine(Supplier<String>) - Method in class java.util.logging. Logger
记录一个FINE消息，只有在记录级别实际上记录该消息时才会被构造。
FINE - Static variable in class java.util.logging. Level
FINE是提供跟踪信息的消息级别。
finer(String) - Method in class java.util.logging. Logger
记录一个FINER消息。
finer(Supplier<String>) - Method in class java.util.logging. Logger
记录一个FINER消息，只有在记录级别实际上记录该消息时，才会构建一个FINER消息。
FINER - Static variable in class java.util.logging. Level
FINER表示相当详细的跟踪消息。
finest(String) - Method in class java.util.logging. Logger
记录一条FINEST消息。
finest(Supplier<String>) - Method in class java.util.logging. Logger
记录一个FINEST消息，只有当记录级别实际上记录消息时，才能构建FINEST消息。
FINEST - Static variable in class java.util.logging. Level
FINEST表示高度详细的跟踪消息。
finish() - Method in class java.util.zip. Deflater
当被调用时，表示压缩应以输入缓冲区的当前内容结束。
finish() - Method in class java.util.zip. DeflaterOutputStream
完成将压缩数据写入输出流，而不关闭底层流。
finish() - Method in class java.util.zip. GZIPOutputStream
完成将压缩数据写入输出流，而不关闭底层流。
finish() - Method in class java.util.zip. InflaterOutputStream
完成将未压缩数据写入输出流，而不关闭底层流。
finish() - Method in class java.util.zip. ZipOutputStream
完成编写ZIP输出流的内容，而不关闭底层流。
FINISH - javafx.scene.control. ButtonBar.ButtonData
“完成”的标签。
FINISH - Static variable in class javafx.scene.control. ButtonType
一个预先定义的ButtonType显示“完成”，并有ButtonBar.ButtonData的ButtonBar.ButtonData.FINISH 。
finishConnect() - Method in class com.sun.nio.sctp. SctpChannel
完成连接SCTP通道的过程。
finishConnect() - Method in class java.nio.channels. SocketChannel
完成连接插座通道的过程。
finishDraggingTo(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider
消息的BasicSplitPaneUI与finishDraggingTo该实例包含在。
finishDraggingTo(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
消息传递完成拖动会话。
finished() - Method in class java.util.zip. Deflater
如果达到压缩数据输出流的结尾，则返回true。
finished() - Method in class java.util.zip. Inflater
如果达到压缩数据流的结尾，则返回true。
finished(TaskEvent) - Method in interface com.sun.source.util. TaskListener
事件完成后调用。
FINISHED - javax.net.ssl. SSLEngineResult.HandshakeStatus
SSLEngine刚刚完成握手。
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
当指定的拆分窗格绘制其子项时调用。
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI
在此对象处理的每个UI上调用 finishedPaintingChildren方法。
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf. SplitPaneUI
在JSplitPane之后，接收器为其孩子提供了油漆的外观和感觉。
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
当指定的拆分窗格绘制其子项时调用。
finisher() - Method in interface java.util.stream. Collector
执行从中间累积类型 A到最终结果类型 R的最终 R 。
Finishings - Class in javax.print.attribute.standard
类完成是打印属性类，枚举，用于标识打印机是否对作业中每个打印文档的每个副本执行某种类型的装订操作。
Finishings(int) - Constructor for class javax.print.attribute.standard. Finishings
使用给定的整数值构造新的finishings绑定枚举值。
fire() - Method in class javafx.scene.control. Button
当用户手势指示应发生 ButtonBase的事件时调用。
fire() - Method in class javafx.scene.control. ButtonBase
当用户手势指示应该发生 ButtonBase的事件时调用。
fire() - Method in class javafx.scene.control. CheckBox
切换 CheckBox的状态。
fire() - Method in class javafx.scene.control. Hyperlink
实现调用ActionEvent如果定义了一个。
fire() - Method in class javafx.scene.control. MenuButton
这没有影响。
fire() - Method in class javafx.scene.control. MenuItem
触发一个新的ActionEvent。
fire() - Method in class javafx.scene.control. RadioButton
当且仅当RadioButton尚未选择或不属于ToggleGroup时，才能切换单选按钮的状态。
fire() - Method in class javafx.scene.control. SplitMenuButton
按下按钮时调用动作。
fire() - Method in class javafx.scene.control. ToggleButton
当用户手势指示应发生 ButtonBase的事件时调用。
fire() - Method in class javafx.scene.input. Mnemonic
火ActionEvent
FIRE - javafx.scene. AccessibleAction
触发该节点的主要操作。
fireActionEvent() - Method in class javax.swing. JComboBox
通知所有在此事件类型上通知有兴趣的听众。
fireActionPerformed() - Method in class javax.swing. JTextField
通知所有在此事件类型上通知有兴趣的听众。
fireActionPerformed(ActionEvent) - Method in class javax.swing. AbstractButton
通知所有在此事件类型上通知有兴趣的听众。
fireActionPerformed(ActionEvent) - Method in class javax.swing. DefaultButtonModel
通知所有在此事件类型上通知有兴趣的听众。
fireActionPerformed(ActionEvent) - Method in class javax.swing. Timer
通知所有在此事件类型上通知有兴趣的听众。
fireActionPerformed(String) - Method in class javax.swing. JFileChooser
通知所有在此事件类型上通知有兴趣的听众。
fireAdjustmentValueChanged(int, int, int) - Method in class javax.swing. JScrollBar
通知听众滚动条的模型已更改。
FIREBRICK - Static variable in class javafx.scene.paint. Color
颜色耐火砖，RGB值为＃B22222
fireCaretUpdate(CaretEvent) - Method in class javax.swing.text. JTextComponent
通知所有在此事件类型上通知有兴趣的听众。
fireChange(boolean, int, int) - Method in class javafx.collections. ObservableArrayBase
通知所有听众的变化
fireChange(ListChangeListener.Change<? extends E>) - Method in class javafx.collections. ObservableListBase
通知所有听众的变化
fireChangedUpdate(DocumentEvent) - Method in class javax.swing.text. AbstractDocument
通知所有在此事件类型上通知有兴趣的听众。
fireChangedUpdate(DocumentEvent) - Method in class javax.swing.text.html. HTMLDocument
通知所有在此事件类型上通知有兴趣的听众。
fireChildrenAdded(BeanContextMembershipEvent) - Method in class java.beans.beancontext. BeanContextSupport
在BeanContextMembershipListener接口上激活BeanContextshipEvent
fireChildrenRemoved(BeanContextMembershipEvent) - Method in class java.beans.beancontext. BeanContextSupport
在BeanContextMembershipListener接口上激活BeanContextshipEvent
fireColumnAdded(TableColumnModelEvent) - Method in class javax.swing.table. DefaultTableColumnModel
通知所有在此事件类型上通知有兴趣的听众。
fireColumnMarginChanged() - Method in class javax.swing.table. DefaultTableColumnModel
通知所有在此事件类型上通知有兴趣的听众。
fireColumnMoved(TableColumnModelEvent) - Method in class javax.swing.table. DefaultTableColumnModel
通知所有在此事件类型上通知有兴趣的听众。
fireColumnRemoved(TableColumnModelEvent) - Method in class javax.swing.table. DefaultTableColumnModel
通知所有在此事件类型上通知有兴趣的听众。
fireColumnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.table. DefaultTableColumnModel
通知所有在此事件类型上通知有兴趣的听众。
fireContentsChanged() - Method in class javax.swing.plaf.basic. BasicDirectoryModel
内容更改时调用。
fireContentsChanged(Object, int, int) - Method in class javax.swing. AbstractListModel
AbstractListModel子类必须在列表的一个或多个元素更改 后调用此方法。
fireDragGestureRecognized(int, Point) - Method in class java.awt.dnd. DragGestureRecognizer
通知DragGestureListener发生拖放启动手势。
fireEditingCanceled() - Method in class javax.swing. AbstractCellEditor
通知所有在此事件类型上通知有兴趣的听众。
fireEditingStopped() - Method in class javax.swing. AbstractCellEditor
通知所有在此事件类型上通知有兴趣的听众。
fireEvent(Event) - Method in class javafx.concurrent. Service
触发指定的事件。
fireEvent(Event) - Method in class javafx.concurrent. Task
触发指定的事件。
fireEvent(Event) - Method in class javafx.scene. Node
触发指定的事件。
fireEvent(Event) - Method in class javafx.stage. Window
触发指定的事件。
fireEvent(EventTarget, Event) - Static method in class javafx.event. Event
触发指定的事件。
fireHyperlinkUpdate(HyperlinkEvent) - Method in class javax.swing. JEditorPane
通知所有在此事件类型上通知有兴趣的听众。
fireIndexedPropertyChange(String, int, boolean, boolean) - Method in class java.beans. PropertyChangeSupport
向已注册的侦听器报告布尔绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。
fireIndexedPropertyChange(String, int, int, int) - Method in class java.beans. PropertyChangeSupport
向已注册的监听器报告整数绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。
fireIndexedPropertyChange(String, int, Object, Object) - Method in class java.beans. PropertyChangeSupport
向已注册的监听器报告绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。
fireInsertUpdate(DocumentEvent) - Method in class javax.swing.text. AbstractDocument
通知所有在此事件类型上通知有兴趣的听众。
fireInternalFrameEvent(int) - Method in class javax.swing. JInternalFrame
触发内部框架事件。
fireIntervalAdded(Object, int, int) - Method in class javax.swing. AbstractListModel
AbstractListModel子类必须 在将一个或多个元素添加到模型 后调用此方法。
fireIntervalRemoved(Object, int, int) - Method in class javax.swing. AbstractListModel
AbstractListModel子类必须 在从模型中删除一个或多个元素 后调用此方法。
fireItemStateChanged(ItemEvent) - Method in class javax.swing. AbstractButton
通知所有在此事件类型上通知有兴趣的听众。
fireItemStateChanged(ItemEvent) - Method in class javax.swing. DefaultButtonModel
通知所有在此事件类型上通知有兴趣的听众。
fireItemStateChanged(ItemEvent) - Method in class javax.swing. JComboBox
通知所有在此事件类型上通知有兴趣的听众。
fireMenuCanceled() - Method in class javax.swing. JMenu
通知所有在此事件类型上通知有兴趣的听众。
fireMenuDeselected() - Method in class javax.swing. JMenu
通知所有在此事件类型上通知有兴趣的听众。
fireMenuDragMouseDragged(MenuDragMouseEvent) - Method in class javax.swing. JMenuItem
通知所有在此事件类型上通知有兴趣的听众。
fireMenuDragMouseEntered(MenuDragMouseEvent) - Method in class javax.swing. JMenuItem
通知所有在此事件类型上通知有兴趣的听众。
fireMenuDragMouseExited(MenuDragMouseEvent) - Method in class javax.swing. JMenuItem
通知所有在此事件类型上通知有兴趣的听众。
fireMenuDragMouseReleased(MenuDragMouseEvent) - Method in class javax.swing. JMenuItem
通知所有在此事件类型上通知有兴趣的听众。
fireMenuKeyPressed(MenuKeyEvent) - Method in class javax.swing. JMenuItem
通知所有在此事件类型上通知有兴趣的听众。
fireMenuKeyReleased(MenuKeyEvent) - Method in class javax.swing. JMenuItem
通知所有在此事件类型上通知有兴趣的听众。
fireMenuKeyTyped(MenuKeyEvent) - Method in class javax.swing. JMenuItem
通知所有在此事件类型上通知有兴趣的听众。
fireMenuSelected() - Method in class javax.swing. JMenu
通知所有在此事件类型上通知有兴趣的听众。
firePopupMenuCanceled() - Method in class javax.swing. JComboBox
通知 PopupMenuListener s组合框的弹出部分已被取消。
firePopupMenuCanceled() - Method in class javax.swing. JPopupMenu
通知 PopupMenuListeners该弹出菜单被取消。
firePopupMenuCanceled() - Method in class javax.swing.plaf.basic. BasicComboPopup
firePopupMenuWillBecomeInvisible() - Method in class javax.swing. JComboBox
通知 PopupMenuListener s组合框的弹出部分已经变得不可见。
firePopupMenuWillBecomeInvisible() - Method in class javax.swing. JPopupMenu
通知 PopupMenuListener s这个弹出菜单将变得不可见。
firePopupMenuWillBecomeInvisible() - Method in class javax.swing.plaf.basic. BasicComboPopup
firePopupMenuWillBecomeVisible() - Method in class javax.swing. JComboBox
通知 PopupMenuListener s组合框的弹出部分将变得可见。
firePopupMenuWillBecomeVisible() - Method in class javax.swing. JPopupMenu
通知 PopupMenuListener这个弹出菜单将变得可见。
firePopupMenuWillBecomeVisible() - Method in class javax.swing.plaf.basic. BasicComboPopup
firePropertyChange() - Method in class java.beans. PropertyEditorSupport
报告说，我们已被修改为任何感兴趣的听众。
firePropertyChange(PropertyChangeEvent) - Method in class java.beans. PropertyChangeSupport
将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
firePropertyChange(PropertyChangeEvent) - Method in class javax.swing.event. SwingPropertyChangeSupport
将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
firePropertyChange(String, boolean, boolean) - Method in class java.awt. Component
支持报告布尔属性的绑定属性更改。
firePropertyChange(String, boolean, boolean) - Method in class java.beans. PropertyChangeSupport
向已注册的侦听器报告布尔绑定属性更新，以跟踪所有属性的更新或具有指定名称的属性。
firePropertyChange(String, boolean, boolean) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, boolean, boolean) - Method in class javax.swing. JComponent
支持报告布尔属性的绑定属性更改。
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.table. DefaultTableCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, byte, byte) - Method in class java.awt. Component
报告绑定属性更改。
firePropertyChange(String, byte, byte) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, byte, byte) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, char, char) - Method in class java.awt. Component
报告绑定属性更改。
firePropertyChange(String, char, char) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, char, char) - Method in class javax.swing. JComponent
firePropertyChange(String, char, char) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, double, double) - Method in class java.awt. Component
报告绑定属性更改。
firePropertyChange(String, double, double) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, double, double) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, float, float) - Method in class java.awt. Component
报告绑定属性更改。
firePropertyChange(String, float, float) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, float, float) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, int, int) - Method in class java.awt. Component
支持报告整数属性的绑定属性更改。
firePropertyChange(String, int, int) - Method in class java.beans. PropertyChangeSupport
向已注册的监听器报告整数绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。
firePropertyChange(String, int, int) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, int, int) - Method in class javax.swing. JComponent
支持报告整数属性的绑定属性更改。
firePropertyChange(String, int, int) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, long, long) - Method in class java.awt. Component
报告绑定属性更改。
firePropertyChange(String, long, long) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, long, long) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, short, short) - Method in class java.awt. Component
报告绑定属性更改。
firePropertyChange(String, short, short) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, short, short) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, Object, Object) - Method in class java.awt. Component
支持报告对象属性的绑定属性更改。
firePropertyChange(String, Object, Object) - Method in class java.awt. KeyboardFocusManager
触发PropertyChangeEvent以响应绑定属性的更改。
firePropertyChange(String, Object, Object) - Method in class java.beans.beancontext. BeanContextChildSupport
向任何已注册的监听器报告绑定属性更新。
firePropertyChange(String, Object, Object) - Method in class java.beans. PropertyChangeSupport
向已注册的监听器报告绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。
firePropertyChange(String, Object, Object) - Method in class javax.accessibility. AccessibleContext
支持报告绑定属性更改。
firePropertyChange(String, Object, Object) - Method in class javax.swing. AbstractAction
支持报告绑定属性更改。
firePropertyChange(String, Object, Object) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, Object, Object) - Method in class javax.swing. JViewport
通知侦听器属性更改。
firePropertyChange(String, Object, Object) - Method in class javax.swing.plaf.basic. BasicDirectoryModel
支持报告布尔属性的绑定属性更改。
firePropertyChange(String, Object, Object) - Method in class javax.swing.plaf. LayerUI
支持报告对象属性的绑定属性更改。
firePropertyChange(String, Object, Object) - Method in class javax.swing. SwingWorker
向任何已注册的监听器报告绑定属性更新。
firePropertyChange(String, Object, Object) - Method in class javax.swing.table. DefaultTableCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, Object, Object) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
firePropertyChange(String, Object, Object) - Method in class javax.swing. UIDefaults
支持报告绑定属性更改。
fireRemoveUpdate(DocumentEvent) - Method in class javax.swing.text. AbstractDocument
通知所有在此事件类型上通知有兴趣的听众。
fireRowSorterChanged(int[]) - Method in class javax.swing. RowSorter
通知侦听器映射已更改。
fireSelectionValueChanged(int, int, boolean) - Method in class javax.swing. JList
通知 ListSelectionListener s直接添加到对选择模型所做的选择更改的列表中。
fireServiceAdded(BeanContextServiceAvailableEvent) - Method in class java.beans.beancontext. BeanContextServicesSupport
触发 BeanContextServiceAvailableEvent表示新服务已经可用。
fireServiceAdded(Class<?>) - Method in class java.beans.beancontext. BeanContextServicesSupport
通知新服务 BeanContextServiceEvent 。
fireServiceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext. BeanContextServicesSupport
发出 BeanContextServiceEvent通知正在撤销的服务。
fireServiceRevoked(Class<?>, boolean) - Method in class java.beans.beancontext. BeanContextServicesSupport
触发 BeanContextServiceRevokedEvent表示特定服务不再可用。
fireSortOrderChanged() - Method in class javax.swing. RowSorter
通知侦听器排序顺序已更改。
fireStateChanged() - Method in class javax.swing. AbstractButton
通知所有在此事件类型上通知有兴趣的听众。
fireStateChanged() - Method in class javax.swing. AbstractSpinnerModel
运行每个ChangeListeners stateChanged（）方法。
fireStateChanged() - Method in class javax.swing.colorchooser. DefaultColorSelectionModel
运行每个 ChangeListener的 stateChanged方法。
fireStateChanged() - Method in class javax.swing. DefaultBoundedRangeModel
运行每个 ChangeListener的 stateChanged方法。
fireStateChanged() - Method in class javax.swing. DefaultButtonModel
通知所有在此事件类型上通知有兴趣的听众。
fireStateChanged() - Method in class javax.swing. DefaultSingleSelectionModel
通知所有在此事件类型上通知有兴趣的听众。
fireStateChanged() - Method in class javax.swing. JProgressBar
发送 ChangeEvent ，其来源是这个 JProgressBar ，所有 ChangeListener s已注册兴趣在 ChangeEvent s。
fireStateChanged() - Method in class javax.swing. JSlider
发送 ChangeEvent ，其来源是这个 JSlider ，所有 ChangeListener s已注册的兴趣在 ChangeEvent s。
fireStateChanged() - Method in class javax.swing. JSpinner
发送一个 ChangeEvent ，其来源是这个 JSpinner ，每个 ChangeListener 。
fireStateChanged() - Method in class javax.swing. JTabbedPane
发送一个 ChangeEvent ，以这个 JTabbedPane为源，给每个注册的听众。
fireStateChanged() - Method in class javax.swing. JViewport
当视图大小，位置或视口 ChangeListeners大小 ChangeListeners时，通知所有 ChangeListeners 。
fireStateChanged() - Method in class javax.swing. MenuSelectionManager
通知所有在此事件类型上通知有兴趣的听众。
fireStateChanged() - Method in class javax.swing.text. DefaultCaret
通知所有在此事件类型上通知有兴趣的听众。
fireStateChanged() - Method in class javax.swing.text. StyleContext.NamedStyle
通知所有在此事件类型上通知有兴趣的听众。
fireTableCellUpdated(int, int) - Method in class javax.swing.table. AbstractTableModel
通知所有侦听器 [row, column]的单元格值已被更新。
fireTableChanged(TableModelEvent) - Method in class javax.swing.table. AbstractTableModel
将给定的通知事件转发给所有注册为此表模型的监听器的 TableModelListeners 。
fireTableDataChanged() - Method in class javax.swing.table. AbstractTableModel
通知所有侦听器表格行中的所有单元格值可能已更改。
fireTableRowsDeleted(int, int) - Method in class javax.swing.table. AbstractTableModel
通知所有侦听器，范围为 [firstRow, lastRow] （含）的行已被删除。
fireTableRowsInserted(int, int) - Method in class javax.swing.table. AbstractTableModel
通知所有侦听器，已插入范围为 [firstRow, lastRow] （含）的行。
fireTableRowsUpdated(int, int) - Method in class javax.swing.table. AbstractTableModel
通知所有侦听器，范围为 [firstRow, lastRow] （包括）的行已更新。
fireTableStructureChanged() - Method in class javax.swing.table. AbstractTableModel
通知所有侦听器表的结构已更改。
fireTreeCollapsed(TreePath) - Method in class javax.swing. JTree
通知所有在此事件类型上通知有兴趣的听众。
fireTreeExpanded(TreePath) - Method in class javax.swing. JTree
通知所有在此事件类型上通知有兴趣的听众。
fireTreeNodesChanged(Object, Object[], int[], Object[]) - Method in class javax.swing.tree. DefaultTreeModel
通知所有在此事件类型上通知有兴趣的听众。
fireTreeNodesInserted(Object, Object[], int[], Object[]) - Method in class javax.swing.tree. DefaultTreeModel
通知所有在此事件类型上通知有兴趣的听众。
fireTreeNodesRemoved(Object, Object[], int[], Object[]) - Method in class javax.swing.tree. DefaultTreeModel
通知所有在此事件类型上通知有兴趣的听众。
fireTreeStructureChanged(Object, Object[], int[], Object[]) - Method in class javax.swing.tree. DefaultTreeModel
通知所有在此事件类型上通知有兴趣的听众。
fireTreeWillCollapse(TreePath) - Method in class javax.swing. JTree
通知所有在此事件类型上通知有兴趣的听众。
fireTreeWillExpand(TreePath) - Method in class javax.swing. JTree
通知所有在此事件类型上通知有兴趣的听众。
fireUndoableEditUpdate(UndoableEditEvent) - Method in class javax.swing.text. AbstractDocument
通知所有在此事件类型上通知有兴趣的听众。
fireUndoableEditUpdate(UndoableEditEvent) - Method in class javax.swing.text.html. HTMLDocument
通知所有在此事件类型上通知有兴趣的听众。
fireValueChanged(boolean) - Method in class javax.swing. DefaultListSelectionModel
通知听众我们已经结束了一系列调整。
fireValueChanged(int, int) - Method in class javax.swing. DefaultListSelectionModel
通知 ListSelectionListeners该选择的值，在闭区间 firstIndex ， lastIndex ，已经改变。
fireValueChanged(int, int, boolean) - Method in class javax.swing. DefaultListSelectionModel
fireValueChanged(TreeSelectionEvent) - Method in class javax.swing. JTree
通知所有在此事件类型上通知有兴趣的听众。
fireValueChanged(TreeSelectionEvent) - Method in class javax.swing.tree. DefaultTreeSelectionModel
通知所有在此对象上注册树选择事件的侦听器。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanProperty
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoubleProperty
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatProperty
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerProperty
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongProperty
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectProperty
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in interface javafx.beans.property.adapter. ReadOnlyJavaBeanProperty
如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。
fireValueChangedEvent() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringProperty
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. BooleanPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. DoublePropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. FloatPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. IntegerPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ListPropertyBase
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
fireValueChangedEvent() - Method in class javafx.beans.property. LongPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. MapPropertyBase
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
fireValueChangedEvent() - Method in class javafx.beans.property. ObjectPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyBooleanPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyBooleanWrapper
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyDoublePropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyDoubleWrapper
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyFloatPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyFloatWrapper
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyIntegerPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyIntegerWrapper
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyListPropertyBase
如果对ObservableList的引用发生变化，则需要调用此方法。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyListWrapper
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyLongPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyLongWrapper
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
如果对ObservableList的引用发生变化，则需要调用此方法。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyMapWrapper
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyObjectPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyObjectWrapper
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlySetPropertyBase
如果对ObservableSet的引用发生变化，则需要调用此方法。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlySetWrapper
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyStringPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. ReadOnlyStringWrapper
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.property. SetPropertyBase
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
fireValueChangedEvent() - Method in class javafx.beans.property. StringPropertyBase
发送所有附件的通知InvalidationListeners和ChangeListeners 。
fireValueChangedEvent() - Method in class javafx.beans.value. ObservableValueBase
通知目前注册的观察员的价值变动。
fireValueChangedEvent(ListChangeListener.Change<? extends E>) - Method in class javafx.beans.property. ListPropertyBase
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
fireValueChangedEvent(ListChangeListener.Change<? extends E>) - Method in class javafx.beans.property. ReadOnlyListPropertyBase
如果引用的内容ObservableList的内容发生变化，则需要调用此方法。
fireValueChangedEvent(ListChangeListener.Change<? extends E>) - Method in class javafx.beans.property. ReadOnlyListWrapper
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。
fireValueChangedEvent(MapChangeListener.Change<? extends K, ? extends V>) - Method in class javafx.beans.property. MapPropertyBase
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
fireValueChangedEvent(MapChangeListener.Change<? extends K, ? extends V>) - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
如果引用的内容ObservableList的内容发生变化，则需要调用此方法。
fireValueChangedEvent(MapChangeListener.Change<? extends K, ? extends V>) - Method in class javafx.beans.property. ReadOnlyMapWrapper
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。
fireValueChangedEvent(SetChangeListener.Change<? extends E>) - Method in class javafx.beans.property. ReadOnlySetPropertyBase
如果引用的内容ObservableSet发生变化，则需要调用此方法。
fireValueChangedEvent(SetChangeListener.Change<? extends E>) - Method in class javafx.beans.property. ReadOnlySetWrapper
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
fireValueChangedEvent(SetChangeListener.Change<? extends E>) - Method in class javafx.beans.property. SetPropertyBase
发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。
fireVetoableChange(PropertyChangeEvent) - Method in class java.beans. VetoableChangeSupport
将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
fireVetoableChange(String, boolean, boolean) - Method in class java.beans. VetoableChangeSupport
向已注册的监听器报告布尔约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。
fireVetoableChange(String, int, int) - Method in class java.beans. VetoableChangeSupport
向已注册的监听器报告整数约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。
fireVetoableChange(String, Object, Object) - Method in class java.awt. KeyboardFocusManager
触发PropertyChangeEvent以响应否决权属性的更改。
fireVetoableChange(String, Object, Object) - Method in class java.beans.beancontext. BeanContextChildSupport
向任何已注册的听众报告否决权属性更新。
fireVetoableChange(String, Object, Object) - Method in class java.beans. VetoableChangeSupport
向已注册的监听器报告受限属性更新，以跟踪所有属性的更新或具有指定名称的属性。
fireVetoableChange(String, Object, Object) - Method in class javax.swing. JComponent
支持报告受限的属性更改。
fireVisibleDataPropertyChange() - Method in class javax.swing. JTree.AccessibleJTree
触发可见的数据属性更改通知。
first() - Method in interface java.sql. ResultSet
将光标移动到此 ResultSet对象中的第一行。
first() - Method in class java.text. BreakIterator
返回第一个边界。
first() - Method in interface java.text. CharacterIterator
将位置设置为getBeginIndex（），并返回该位置的字符。
first() - Method in class java.text. StringCharacterIterator
为String实现CharacterIterator.first（）。
first() - Method in class java.util.concurrent. ConcurrentSkipListSet
first() - Method in interface java.util. SortedSet
返回此集合中当前的第一个（最低）元素。
first() - Method in class java.util. TreeSet
first() - Method in class javax.swing.text. ElementIterator
获取第一个元素
first() - Method in class javax.swing.text.html.parser. ContentModel
返回必须接下来的元素。
first() - Method in class javax.swing.text. Segment
将位置设置为getBeginIndex（），并返回该位置的字符。
first(Container) - Method in class java.awt. CardLayout
翻转到容器的第一张卡片。
first(Object) - Method in class javax.swing.text.html.parser. ContentModel
如果令牌可能是输入流中的第一个令牌，则返回true。
FIRST - jdk.incubator.http. WebSocket.MessagePart
序列中消息的第一部分。
FIRST_LINE_END - Static variable in class java.awt. GridBagConstraints
将组件放置在其显示区域的一角，其中页面上的第一行文本正常结束当前的 ComponentOrientation 。
FIRST_LINE_START - Static variable in class java.awt. GridBagConstraints
将组件放置在其显示区域的一角，其中页面上的第一行文本通常将为当前的 ComponentOrientation开始。
FIRST_ORDERED_NODE_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是由单个节点定义并将被访问的节点集，如果节点集为空，则可以是 null 。
firstChild() - Method in interface org.w3c.dom.traversal. TreeWalker
将 TreeWalker移动到当前节点的第一个可见子节点，并返回新节点。
firstColumn - Variable in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange
第一列
firstComplete() - Method in class java.util.concurrent. CountedCompleter
如果此任务的挂起计数为零，则返回此任务; 否则递减其待处理的计数并返回null 。
firstDayOfMonth() - Static method in class java.time.temporal. TemporalAdjusters
返回“第一个月的”调整器，它返回设置为当月的第一天的新日期。
firstDayOfNextMonth() - Static method in class java.time.temporal. TemporalAdjusters
返回“下一个月的第一天”调整器，它将新的日期设置为下个月的第一天。
firstDayOfNextYear() - Static method in class java.time.temporal. TemporalAdjusters
返回“明年的第一天”调整器，返回设置为下一年的第一天的新日期。
firstDayOfYear() - Static method in class java.time.temporal. TemporalAdjusters
返回“一年的第一天”调整器，其返回设置为当前第一天的新日期。
firstDayOfYear(boolean) - Method in enum java.time. Month
获得与本月第一天对应的日期。
firstElement() - Method in class java.util. Vector
返回此向量的第一个组件（索引号为 0的项目）。
firstElement() - Method in class javax.swing. DefaultListModel
返回此列表的第一个组件。
firstEntry() - Method in class java.util.concurrent. ConcurrentSkipListMap
返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
firstEntry() - Method in interface java.util. NavigableMap
返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
firstEntry() - Method in class java.util. TreeMap
firstInMonth(DayOfWeek) - Static method in class java.time.temporal. TemporalAdjusters
返回月初调整器，它在同一个月内返回与第一个匹配的星期几的新日期。
firstKey() - Method in class java.util.concurrent. ConcurrentSkipListMap
firstKey() - Method in interface java.util. SortedMap
返回此地图中当前的第一个（最低）键。
firstKey() - Method in class java.util. TreeMap
firstLineIndent - Variable in class javax.swing.text. ParagraphView
第一行缩进，从左边插入。
FirstLineIndent - Static variable in class javax.swing.text. StyleConstants
缩进段落第一行的空格量。
firstMonthOfQuarter() - Method in enum java.time. Month
获得与本季度第一个月相对应的月份。
firstRow - Variable in class javax.swing.event. TableModelEvent
第一行已更改。
firstRow - Variable in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange
第一行
firstSentenceTags() - Method in interface com.sun.javadoc. Doc
已过时。
将注释的第一个句子作为标签数组返回。
firstSentenceTags() - Method in interface com.sun.javadoc. Tag
已过时。
将注释的第一个句子作为标签数组返回。
firstValue(String) - Method in interface jdk.incubator.http. HttpHeaders
返回一个Optional，其中包含给定的（可能是多值）头的第一个值。
firstValueAsLong(String) - Method in interface jdk.incubator.http. HttpHeaders
返回包含命名头字段的第一个值的OptionalLong 。
FIT_WIDTH - javax.swing. JTable.PrintMode
如果需要，可以缩小输出的打印模式，以适应每个页面上的表的整个宽度（从而所有列）; 必要时，行分布在多个页面上。
fitHeightProperty() - Method in class javafx.scene.image. ImageView
根据需要调整大小的源图像的边界框的高度。
fitHeightProperty() - Method in class javafx.scene.media. MediaView
确定必要时调整大小的源介质的边界框的高度。
fitToHeightProperty() - Method in class javafx.scene.control. ScrollPane
如果为true，并且如果包含的节点是可调整大小，则节点将被保持调整大小以匹配ScrollPane视口的高度。
fitToWidthProperty() - Method in class javafx.scene.control. ScrollPane
如果为true，并且如果包含的节点是可调整大小，那么该节点将保持调整大小以匹配ScrollPane视口的宽度。
fitWidthProperty() - Method in class javafx.scene.image. ImageView
根据需要调整源图像大小的边框的宽度。
fitWidthProperty() - Method in class javafx.scene.media. MediaView
确定根据需要调整大小的源介质的边界框的宽度。
fixed(Instant, ZoneId) - Static method in class java.time. Clock
获得始终返回相同时刻的时钟。
FIXED - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于FIXED
fixed_digits() - Method in class org.omg.CORBA. TypeCode
返回此 TypeCode对象描述的固定类型中的 TypeCode 。
fixed_scale() - Method in class org.omg.CORBA. TypeCode
返回此 TypeCode对象描述的固定类型的比例。
FIXED_SIZES - javax.swing.plaf.nimbus. AbstractRegionPainter.PaintContext.CacheMode
固定尺寸
fixedCellHeightChanged - Static variable in class javax.swing.plaf.basic. BasicListUI
这个位与固定单元格高度变化的属性有关。
fixedCellSizeProperty() - Method in class javafx.scene.control. ListView
指定此控件是否具有固定高度（指定值）的单元格。
fixedCellSizeProperty() - Method in class javafx.scene.control.skin. VirtualFlow
为了优化目的，一些用例可以交换动态单元格的速度 - 如果fixedCellSize大于零，我们将使用它，而不是通过查询单元本身来确定它。
fixedCellSizeProperty() - Method in class javafx.scene.control. TableView
指定此控件是否具有固定高度（指定值）的单元格。
fixedCellSizeProperty() - Method in class javafx.scene.control. TreeTableView
指定此控件是否具有固定高度（指定值）的单元格。
fixedCellSizeProperty() - Method in class javafx.scene.control. TreeView
指定此控件是否具有固定高度（指定值）的单元格。
fixedCellWidthChanged - Static variable in class javax.swing.plaf.basic. BasicListUI
该位涉及固定单元宽度改变属性。
fixedContentLength - Variable in class java.net. HttpURLConnection
使用固定长度流式传输模式时的固定内容长度。
fixedContentLengthLong - Variable in class java.net. HttpURLConnection
使用固定长度流式传输模式时的固定内容长度。
FixedHeightLayoutCache - Class in javax.swing.tree
注意：在将来的版本中这将变得更加开放。
FixedHeightLayoutCache() - Constructor for class javax.swing.tree. FixedHeightLayoutCache
构造一个 FixedHeightLayoutCache 。
FixedHolder - Class in org.omg.CORBA
持有人 Fixed 。
FixedHolder() - Constructor for class org.omg.CORBA. FixedHolder
构造FixedHolder而不初始化包含的值。
FixedHolder(BigDecimal) - Constructor for class org.omg.CORBA. FixedHolder
构造FixedHolder并用给定的值初始化它。
FLAG_BRIDGES - Static variable in class java.lang.invoke. LambdaMetafactory
指示lambda对象的备用元素的标志需要额外的桥接方法
FLAG_COMPLEX_GLYPHS - Static variable in class java.awt.font. GlyphVector
与getLayoutFlags一起使用的标志，指示该 GlyphVector具有复杂的字形到字符映射（一个不以符合运行方向的严格升序或降序的方式将字形映射到字符一对一）。
FLAG_HAS_POSITION_ADJUSTMENTS - Static variable in class java.awt.font. GlyphVector
与getLayoutFlags一起使用的标志，表示该 GlyphVector有位置调整。
FLAG_HAS_TRANSFORMS - Static variable in class java.awt.font. GlyphVector
与getLayoutFlags一起使用的标志，表示此 GlyphVector具有每个字形转换。
FLAG_MARKERS - Static variable in class java.lang.invoke. LambdaMetafactory
指示lambda对象的替代元素的标志实现除Serializable之外的其他标记接口
FLAG_MASK - Static variable in class java.awt.font. GlyphVector
来自getLayoutFlags的支持标志的掩码。
FLAG_RUN_RTL - Static variable in class java.awt.font. GlyphVector
与getLayoutFlags一起使用的标志，表示该 GlyphVector具有从右到左的运行方向。
FLAG_SERIALIZABLE - Static variable in class java.lang.invoke. LambdaMetafactory
指示lambda对象的替代元素的标志必须是可序列化的
flags() - Method in class java.nio.file.attribute. AclEntry
返回flags组件的副本。
flags() - Method in class java.util.regex. Pattern
返回此模式的匹配标志。
flags() - Method in class org.omg.CORBA. NamedValue
检索此 NamedValue对象的参数模式标志。
FLASH_DID_NOT_FIRE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的值，表示闪光灯未触发。
FLASH_FIRED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的值，表示闪光灯闪光，但闪光灯返回状态未知。
FLASH_MASK_FIRED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
一个与“Flash”标签一起使用的面具，表示闪光灯闪光。
FLASH_MASK_FUNCTION_NOT_PRESENT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的掩码，表示不存在闪光灯功能。
FLASH_MASK_MODE_AUTO - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的掩码，表示自动模式。
FLASH_MASK_MODE_FLASH_FIRING - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的面具，表示强制闪光灯闪光模式。
FLASH_MASK_MODE_FLASH_SUPPRESSION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的掩码，表示强制闪存抑制模式。
FLASH_MASK_RED_EYE_REDUCTION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的面具，表示支持红眼。
FLASH_MASK_RETURN_DETECTED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的掩码，指示检测到闪光灯返回光。
FLASH_MASK_RETURN_NOT_DETECTED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的掩码，指示未检测到闪光灯返回光。
FLASH_OPTION - Static variable in class javax.swing. DebugGraphics
Flash图形操作。
FLASH_STROBE_RETURN_LIGHT_DETECTED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的值，表示闪光灯闪烁，并检测到闪光灯返回光。
FLASH_STROBE_RETURN_LIGHT_NOT_DETECTED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“Flash”标签一起使用的值，表示闪光灯闪光，但没有检测到闪光灯返回光。
flashColor() - Static method in class javax.swing. DebugGraphics
返回用于闪存绘图操作的颜色。
flashCount() - Static method in class javax.swing. DebugGraphics
返回绘图操作将闪烁的次数。
flashTime() - Static method in class javax.swing. DebugGraphics
返回绘图操作闪烁的时间延迟。
flatMap(DoubleFunction<? extends DoubleStream>) - Method in interface java.util.stream. DoubleStream
返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
flatMap(Function<? super T, ? extends Optional<? extends U>>) - Method in class java.util. Optional
如果存在值，则返回将给定的 Optional映射函数应用于该值的结果，否则返回一个空的 Optional 。
flatMap(Function<? super T, ? extends Stream<? extends R>>) - Method in interface java.util.stream. Stream
返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
flatMap(IntFunction<? extends IntStream>) - Method in interface java.util.stream. IntStream
返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
flatMap(LongFunction<? extends LongStream>) - Method in interface java.util.stream. LongStream
返回由通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果的流。
flatMapping(Function<? super T, ? extends Stream<? extends U>>, Collector<? super U, A, R>) - Static method in class java.util.stream. Collectors
适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累之前施加平坦映射函数应用于每个输入元件。
flatMapToDouble(Function<? super T, ? extends DoubleStream>) - Method in interface java.util.stream. Stream
返回一个 DoubleStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
flatMapToInt(Function<? super T, ? extends IntStream>) - Method in interface java.util.stream. Stream
返回一个 IntStream其中包含将该流的每个元素替换为通过将提供的映射函数应用于每个元素而产生的映射流的内容的结果。
flatMapToLong(Function<? super T, ? extends LongStream>) - Method in interface java.util.stream. Stream
返回一个 LongStream其中包含通过将提供的映射函数应用于每个元素而产生的映射流的内容来替换该流的每个元素的结果。
flatSignature() - Method in interface com.sun.javadoc. ExecutableMemberDoc
已过时。
得到平面签名。
FlatteningPathIterator - Class in java.awt.geom
FlatteningPathIterator类返回另一个PathIterator对象的扁平化视图。
FlatteningPathIterator(PathIterator, double) - Constructor for class java.awt.geom. FlatteningPathIterator
构造一个新的 FlatteningPathIterator对象，在对其进行迭代时使其 FlatteningPathIterator 。
FlatteningPathIterator(PathIterator, double, int) - Constructor for class java.awt.geom. FlatteningPathIterator
构造一个新的 FlatteningPathIterator对象，使它在遍历它时 FlatteningPathIterator一个路径。
FlavorEvent - Class in java.awt.datatransfer
FlavorEvent用于通知有关方面27046058456766在Clipboard （事件源）中有变化。
FlavorEvent(Clipboard) - Constructor for class java.awt.datatransfer. FlavorEvent
构造一个 FlavorEvent对象。
FlavorException - Interface in javax.print
Interface FlavorException是一个mixin接口，它可以实现PrintException的子类来报告涉及到一个文档风格或风格（类别DocFlavor ）的错误条件。
FlavorListener - Interface in java.awt.datatransfer
定义一个监听FlavorEvent的对象。
FlavorMap - Interface in java.awt.datatransfer
对应于平台特定数据格式的“本土”（字符串）和“风格”（DataFlavors）之间的双向映射，它们与平台无关的MIME类型相对应。
flavorsChanged(FlavorEvent) - Method in interface java.awt.datatransfer. FlavorListener
当侦听器的目标Clipboard已更改其可用的DataFlavor s时调用。
FlavorTable - Interface in java.awt.datatransfer
一个FlavorMap，放宽了地图传统的1对1限制。
flip() - Method in class java.nio. Buffer
翻转这个缓冲区。
flip() - Method in class java.nio. ByteBuffer
翻转这个缓冲区。
flip() - Method in class java.nio. CharBuffer
翻转这个缓冲区。
flip() - Method in class java.nio. DoubleBuffer
翻转这个缓冲区。
flip() - Method in class java.nio. FloatBuffer
翻转这个缓冲区。
flip() - Method in class java.nio. IntBuffer
翻转这个缓冲区。
flip() - Method in class java.nio. LongBuffer
翻转这个缓冲区。
flip() - Method in class java.nio. MappedByteBuffer
翻转这个缓冲区。
flip() - Method in class java.nio. ShortBuffer
翻转这个缓冲区。
flip(int) - Method in class java.util. BitSet
将指定索引处的位设置为其当前值的补码。
flip(int, int) - Method in class java.util. BitSet
将指定的 fromIndex （含）中的每一位设置为指定的 toIndex （排他）到其当前值的补码。
flip(BufferCapabilities.FlipContents) - Method in class java.awt. Component.FlipBufferStrategy
翻转通过复制或移动视频指针将后缓冲区的内容移动到前缓冲区。
flipBit(int) - Method in class java.math. BigInteger
返回一个BigInteger，其值等于此BigInteger，指定的位被翻转。
FlipBufferStrategy(int, BufferCapabilities) - Constructor for class java.awt. Component.FlipBufferStrategy
为此组件创建一个新的翻转缓冲区策略。
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text. BoxView
确定下一个视图放在哪个方向。
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text. CompositeView
确定下一个视图放在哪个方向。
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text. ParagraphView
确定下一个视图放在哪个方向。
Float - Class in java.lang
Float类包装一个对象中的原始类型为 float的值。
Float() - Constructor for class java.awt.geom. Arc2D.Float
构造一个新的OPEN弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）。
Float() - Constructor for class java.awt.geom. CubicCurve2D.Float
构造并初始化坐标（0，0，0，0，0，0，0，0）的CubicCurve。
Float() - Constructor for class java.awt.geom. Ellipse2D.Float
构造新的 Ellipse2D ，初始化为位置（0,0）和大小（0,0）。
Float() - Constructor for class java.awt.geom. Line2D.Float
构造并初始化坐标（0，0）→（0，0）的行。
Float() - Constructor for class java.awt.geom. Path2D.Float
构造一个新的空单精度 Path2D对象，默认卷绕规则为 Path2D.WIND_NON_ZERO 。
Float() - Constructor for class java.awt.geom. Point2D.Float
构造并初始化具有坐标（0,0）的 Point2D 。
Float() - Constructor for class java.awt.geom. QuadCurve2D.Float
构造并初始化具有坐标（ QuadCurve2D 。
Float() - Constructor for class java.awt.geom. Rectangle2D.Float
构造新的 Rectangle2D ，初始化为位置（ Rectangle2D ）和大小（ Rectangle2D ）。
Float() - Constructor for class java.awt.geom. RoundRectangle2D.Float
构造一个新的 RoundRectangle2D ，初始化为位置（ RoundRectangle2D ），大小（ RoundRectangle2D ）和半径为0.0的角弧。
Float(double) - Constructor for class java.lang. Float
已过时。
很少使用这个构造函数。 相反，使用静态工厂方法Float.valueOf(float)的方法如下： Float.valueOf((float)value) 。
Float(float) - Constructor for class java.lang. Float
已过时。
很少使用这个构造函数。 静态工厂Float.valueOf(float)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
Float(float, float) - Constructor for class java.awt.geom. Point2D.Float
构造并初始化具有指定坐标的 Point2D 。
Float(float, float, float, float) - Constructor for class java.awt.geom. Ellipse2D.Float
从指定的坐标构造并初始化 Ellipse2D 。
Float(float, float, float, float) - Constructor for class java.awt.geom. Line2D.Float
从指定的坐标构造和初始化一行。
Float(float, float, float, float) - Constructor for class java.awt.geom. Rectangle2D.Float
构造并初始化一个 Rectangle2D从指定 float坐标。
Float(float, float, float, float, float, float) - Constructor for class java.awt.geom. QuadCurve2D.Float
构造并初始化一个 QuadCurve2D从指定 float坐标。
Float(float, float, float, float, float, float) - Constructor for class java.awt.geom. RoundRectangle2D.Float
构造并初始化一个 RoundRectangle2D从指定 float坐标。
Float(float, float, float, float, float, float, float, float) - Constructor for class java.awt.geom. CubicCurve2D.Float
构造并初始化一个 CubicCurve2D从指定 float坐标。
Float(float, float, float, float, float, float, int) - Constructor for class java.awt.geom. Arc2D.Float
构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
Float(int) - Constructor for class java.awt.geom. Arc2D.Float
构造一个新弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）以及指定的闭合类型。
Float(int) - Constructor for class java.awt.geom. Path2D.Float
使用指定的绕组规则构造新的空单精度 Path2D对象，以控制需要定义路径内部的操作。
Float(int, int) - Constructor for class java.awt.geom. Path2D.Float
构造一个新的空单精度 Path2D对象，具有指定的绕组规则和指定的初始容量以存储路径段。
Float(Point2D, Point2D) - Constructor for class java.awt.geom. Line2D.Float
构造并初始化一个 Line2D从指定 Point2D对象。
Float(Rectangle2D, float, float, int) - Constructor for class java.awt.geom. Arc2D.Float
构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
Float(Shape) - Constructor for class java.awt.geom. Path2D.Float
构造一个新的单精度Path2D从任意对象Shape对象。
Float(Shape, AffineTransform) - Constructor for class java.awt.geom. Path2D.Float
构造一个新的单精度Path2D从任意物体Shape对象，由一个转化AffineTransform对象。
Float(String) - Constructor for class java.lang. Float
已过时。
很少使用这个构造函数。 使用Float.parseFloat(String)将字符串转换为float原语，或使用Float.valueOf(String)将字符串转换为Float对象。
FLOAT - java.sql. JDBCType
标识通用SQL类型 FLOAT 。
FLOAT - javax.lang.model.type. TypeKind
原始类型 float 。
FLOAT - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 FLOAT 。
FLOAT - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.lang.Float值的 SimpleType实例。
FLOAT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“float”。
FLOAT_LITERAL - com.sun.source.tree. Tree.Kind
用于表示float类型的浮点文字表达式的float 。
floatAt(Point, Point) - Method in class javax.swing.plaf.basic. BasicToolBarUI
在拖动结束时调用该方法将框架放置在其原始位置或其浮动框架中。
FloatBinding - Class in javafx.beans.binding
基类提供了实现float的float所需的大部分功能。
FloatBinding() - Constructor for class javafx.beans.binding. FloatBinding
FloatBuffer - Class in java.nio
一个浮动缓冲区。
FloatControl - Class in javax.sound.sampled
一个 FloatControl对象提供对一系列浮点值的控制。
FloatControl(FloatControl.Type, float, float, float, int, float, String) - Constructor for class javax.sound.sampled. FloatControl
使用给定的参数构造一个新的float控件对象。
FloatControl(FloatControl.Type, float, float, float, int, float, String, String, String, String) - Constructor for class javax.sound.sampled. FloatControl
使用给定的参数构造一个新的float控件对象。
FloatControl.Type - Class in javax.sound.sampled
FloatControl.Type内部类的实例标识一种浮动控件。
floatExpression(ObservableFloatValue) - Static method in class javafx.beans.binding. FloatExpression
返回一个FloatExpression的FloatExpression 。
floatExpression(ObservableValue<T>) - Static method in class javafx.beans.binding. FloatExpression
返回一个FloatExpression的FloatExpression 。
FloatExpression - Class in javafx.beans.binding
FloatExpression是一个ObservableFloatValue，另外还有一个方便的方法来生成流畅的绑定。
FloatExpression() - Constructor for class javafx.beans.binding. FloatExpression
FloatHolder - Class in org.omg.CORBA
持有人 Float 。
FloatHolder() - Constructor for class org.omg.CORBA. FloatHolder
构造一个新的 FloatHolder对象，其 value字段初始化为0.0。
FloatHolder(float) - Constructor for class org.omg.CORBA. FloatHolder
为给定的 float构造一个新的 FloatHolder对象。
floatingBorderColor - Variable in class javax.swing.plaf.basic. BasicToolBarUI
不对接边框的颜色。
floatingColor - Variable in class javax.swing.plaf.basic. BasicToolBarUI
不对接边框的背景颜色。
FloatMap - Class in javafx.scene.effect
包含浮点数据的缓冲区，用作DisplacementMap等效果参数。
FloatMap() - Constructor for class javafx.scene.effect. FloatMap
使用默认参数创建一个新的FloatMap实例。
FloatMap(int, int) - Constructor for class javafx.scene.effect. FloatMap
以指定的宽度和高度创建一个新的FloatMap实例。
floatProperty(Property<Float>) - Static method in class javafx.beans.property. FloatProperty
返回一个FloatProperty的FloatProperty并双向绑定到它。
FloatProperty - Class in javafx.beans.property
这个类定义了一个Property包裹一个float值。
FloatProperty() - Constructor for class javafx.beans.property. FloatProperty
FloatPropertyBase - Class in javafx.beans.property
FloatPropertyBase类是包含 float值的属性的基类。
FloatPropertyBase() - Constructor for class javafx.beans.property. FloatPropertyBase
的构造函数为 FloatPropertyBase 。
FloatPropertyBase(float) - Constructor for class javafx.beans.property. FloatPropertyBase
的构造函数为 FloatPropertyBase 。
FloatSeqHelper - Class in org.omg.CORBA
助手 FloatSeq 。
FloatSeqHelper() - Constructor for class org.omg.CORBA. FloatSeqHelper
FloatSeqHolder - Class in org.omg.CORBA
持有人 FloatSeq 。
FloatSeqHolder() - Constructor for class org.omg.CORBA. FloatSeqHolder
FloatSeqHolder(float[]) - Constructor for class org.omg.CORBA. FloatSeqHolder
FloatStringConverter - Class in javafx.util.converter
StringConverter实现Float （和浮动原语）值。
FloatStringConverter() - Constructor for class javafx.util.converter. FloatStringConverter
floatToIntBits(float) - Static method in class java.lang. Float
根据IEEE 754浮点“单格式”位布局返回指定浮点值的表示。
floatToRawIntBits(float) - Static method in class java.lang. Float
根据IEEE 754浮点“单格式”位布局返回指定浮点值的表示，保留非数字（NaN）值。
FloatType - Interface in com.sun.jdi
在目标VM中访问的所有原始浮点值的类型。
floatValue() - Method in interface com.sun.jdi. PrimitiveValue
将此值转换为FloatValue，并将结果作为浮点数返回。
floatValue() - Method in class java.lang. Byte
在扩展原始转换后，返回 Byte的值作为 float 。
floatValue() - Method in class java.lang. Double
在缩小原始转换后，返回 Double的值作为 float 。
floatValue() - Method in class java.lang. Float
返回此 Float对象的 float值。
floatValue() - Method in class java.lang. Integer
返回此值 Integer为 float一个宽元转换后。
floatValue() - Method in class java.lang. Long
返回此值 Long为 float一个宽元转换后。
floatValue() - Method in class java.lang. Number
返回指定数字的值作为 float 。
floatValue() - Method in class java.lang. Short
返回此值 Short为 float一个宽元转换后。
floatValue() - Method in class java.math. BigDecimal
将此 BigDecimal转换为 float 。
floatValue() - Method in class java.math. BigInteger
将此BigInteger转换为 float 。
floatValue() - Method in class java.util.concurrent.atomic. AtomicInteger
返回此的当前值 AtomicInteger作为 float加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
floatValue() - Method in class java.util.concurrent.atomic. AtomicLong
返回此的当前值 AtomicLong作为 float加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
floatValue() - Method in class java.util.concurrent.atomic. DoubleAccumulator
在缩小原始转换后返回 current value作为 float 。
floatValue() - Method in class java.util.concurrent.atomic. DoubleAdder
在缩小原始转换后，返回 DoubleAdder.sum()作为 float 。
floatValue() - Method in class java.util.concurrent.atomic. LongAccumulator
在扩展原始转换后，返回 current value作为 float 。
floatValue() - Method in class java.util.concurrent.atomic. LongAdder
在扩展原始转换后，返回 LongAdder.sum()作为 float 。
floatValue() - Method in class javafx.beans.binding. DoubleExpression
floatValue() - Method in class javafx.beans.binding. FloatExpression
floatValue() - Method in class javafx.beans.binding. IntegerExpression
floatValue() - Method in class javafx.beans.binding. LongExpression
floatValue() - Method in interface javafx.beans.value. ObservableNumberValue
返回 ObservableNumberValue的值作为 float 。
FloatValue - Interface in com.sun.jdi
提供对目标虚拟机中原始数据 float访问。
floatValueAt(ObservableFloatArray, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含ObservableArray在指定位置的元素。
floatValueAt(ObservableFloatArray, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含ObservableArray在指定位置的元素。
floatValueAt(ObservableFloatArray, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含指定位置的ObservableArray的元素。
floatValueAt(ObservableList<? extends Number>, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含ObservableList在指定位置的元素。
floatValueAt(ObservableList<? extends Number>, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含指定位置的元素ObservableList 。
floatValueAt(ObservableList<? extends Number>, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含ObservableList在指定位置的元素。
floatValueAt(ObservableMap<K, ? extends Number>, ObservableValue<? extends K>) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
floatValueAt(ObservableMap<K, ? extends Number>, K) - Static method in class javafx.beans.binding. Bindings
创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
floor(double) - Static method in class java.lang. Math
返回小于或等于参数的最大（最接近正无穷大） double值，等于数学整数。
floor(double) - Static method in class java.lang. StrictMath
返回小于或等于参数的最大（最接近正无穷大）的 double值，并且等于数学整数。
floor(E) - Method in class java.util.concurrent. ConcurrentSkipListSet
floor(E) - Method in interface java.util. NavigableSet
返回此集中最大的元素小于或等于给定元素，如果没有这样的元素，则 null 。
floor(E) - Method in class java.util. TreeSet
FLOOR - java.math. RoundingMode
舍入模式向负无穷大转弯。
floorDiv(int, int) - Static method in class java.lang. Math
返回小于或等于代数商的最大（最接近正无穷大） int值。
floorDiv(int, int) - Static method in class java.lang. StrictMath
返回小于或等于代数商的最大（最接近正无穷大） int值。
floorDiv(long, int) - Static method in class java.lang. Math
返回小于或等于代数商的最大（最接近正无穷大） long值。
floorDiv(long, int) - Static method in class java.lang. StrictMath
返回小于或等于代数商的最大（最接近正无穷大） long值。
floorDiv(long, long) - Static method in class java.lang. Math
返回小于或等于代数商的最大（最接近正无穷大） long值。
floorDiv(long, long) - Static method in class java.lang. StrictMath
返回小于或等于代数商的最大（最接近正无穷大） long值。
floorEntry(K) - Method in class java.util.concurrent. ConcurrentSkipListMap
返回与小于或等于给定键的最大键相关联的键值映射，如果没有此键，则 null 。
floorEntry(K) - Method in interface java.util. NavigableMap
返回与小于或等于给定键的最大键相关联的键值映射，如果没有此键，则 null 。
floorEntry(K) - Method in class java.util. TreeMap
floorKey(K) - Method in class java.util.concurrent. ConcurrentSkipListMap
floorKey(K) - Method in interface java.util. NavigableMap
返回小于或等于给定键的最大键，如果没有这样的键，则 null 。
floorKey(K) - Method in class java.util. TreeMap
floorMod(int, int) - Static method in class java.lang. Math
返回 int参数的底模数。
floorMod(int, int) - Static method in class java.lang. StrictMath
返回 int参数的底模数。
floorMod(long, int) - Static method in class java.lang. Math
返回 long和 int参数的底模。
floorMod(long, int) - Static method in class java.lang. StrictMath
返回 long和 int参数的底模。
floorMod(long, long) - Static method in class java.lang. Math
返回 long参数的底模数。
floorMod(long, long) - Static method in class java.lang. StrictMath
返回 long参数的底模数。
floppyDriveIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
软盘驱动器图标
FLORALWHITE - Static variable in class javafx.scene.paint. Color
颜色花白色，RGB值为＃FFFAF0
Flow - Class in java.util.concurrent
用于建立流量控制组件的相关接口和静态方法，其中Publishers生成由一个或多个Subscribers消耗的项目，每个由Subscription管理。
Flow.Processor< T, R> - Interface in java.util.concurrent
作为订阅者和发布者的组件。
Flow.Publisher< T> - Interface in java.util.concurrent
订阅者接收的项目（和相关控制消息）的生产者。
Flow.Subscriber< T> - Interface in java.util.concurrent
消息的接收者。
Flow.Subscription - Interface in java.util.concurrent
链接Flow.Publisher和Flow.Subscriber的消息控件。
FlowLayout - Class in java.awt
流程布局将组件布置在定向流中，与段落中的文本行类似。
FlowLayout() - Constructor for class java.awt. FlowLayout
构造一个新的 FlowLayout中心对齐和默认的5单位水平和垂直间隙。
FlowLayout(int) - Constructor for class java.awt. FlowLayout
构造新的 FlowLayout具有指定的对齐和默认的5单位水平和垂直间隙。
FlowLayout(int, int, int) - Constructor for class java.awt. FlowLayout
创建一个新的流程布局管理器，具有指示的对齐方式和指示的水平和垂直间距。
FlowPane - Class in javafx.scene.layout
FlowPane将其孩子摆放在流过玻璃边界的流中。
FlowPane() - Constructor for class javafx.scene.layout. FlowPane
使用hgap / vgap = 0创建一个水平FlowPane布局。
FlowPane(double, double) - Constructor for class javafx.scene.layout. FlowPane
使用指定的hgap / vgap创建一个水平FlowPane布局。
FlowPane(double, double, Node...) - Constructor for class javafx.scene.layout. FlowPane
使用指定的hgap / vgap创建一个水平FlowPane布局。
FlowPane(Orientation) - Constructor for class javafx.scene.layout. FlowPane
使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
FlowPane(Orientation, double, double) - Constructor for class javafx.scene.layout. FlowPane
使用指定的方向和hgap / vgap创建FlowPane布局。
FlowPane(Orientation, double, double, Node...) - Constructor for class javafx.scene.layout. FlowPane
使用指定的方向和hgap / vgap创建FlowPane布局。
FlowPane(Orientation, Node...) - Constructor for class javafx.scene.layout. FlowPane
使用指定的方向创建一个FlowPane布局，并创建hgap / vgap = 0。
FlowPane(Node...) - Constructor for class javafx.scene.layout. FlowPane
使用hgap / vgap = 0创建一个水平FlowPane布局。
FLOWS_FROM - Static variable in class javax.accessibility. AccessibleRelation
表示一个对象与第二个对象在逻辑上邻接，第二个对象发生在对象之前。
FLOWS_FROM_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
表示两个对象之间的 FLOWS_FROM关系发生变化。
FLOWS_TO - Static variable in class javax.accessibility. AccessibleRelation
表示对象与第二个对象在逻辑上邻接，第二个对象发生在对象之后。
FLOWS_TO_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
表示两个对象之间的 FLOWS_TO关系发生变化。
FlowStrategy() - Constructor for class javax.swing.text. FlowView.FlowStrategy
FlowView - Class in javax.swing.text
一个试图将孩子流入某些部分受限空间的视图。
FlowView(Element, int) - Constructor for class javax.swing.text. FlowView
为给定元素构造一个FlowView。
FlowView.FlowStrategy - Class in javax.swing.text
保持流动的物理形式的策略。
flush() - Method in class java.awt. Image
刷新此Image对象正在使用的所有可重建资源。
flush() - Method in class java.beans. XMLEncoder
如果尚未写入与XML编码相关联的前导码，则该方法会写出自上次调用 flush以来写入流的所有值。
flush() - Method in class java.io. BufferedOutputStream
刷新缓冲输出流。
flush() - Method in class java.io. BufferedWriter
刷新流。
flush() - Method in class java.io. CharArrayWriter
冲洗流。
flush() - Method in class java.io. Console
刷新控制台并强制任何缓冲输出立即写入。
flush() - Method in class java.io. DataOutputStream
刷新此数据输出流。
flush() - Method in class java.io. FilterOutputStream
刷新此输出流，并强制将任何缓冲的输出字节写入流。
flush() - Method in class java.io. FilterWriter
刷新流。
flush() - Method in interface java.io. Flushable
通过将任何缓冲的输出写入底层流来刷新流。
flush() - Method in interface java.io. ObjectOutput
刷新流。
flush() - Method in class java.io. ObjectOutputStream
刷新流。
flush() - Method in class java.io. OutputStream
刷新此输出流并强制任何缓冲的输出字节被写出。
flush() - Method in class java.io. OutputStreamWriter
刷新流。
flush() - Method in class java.io. PipedOutputStream
刷新此输出流并强制任何缓冲的输出字节被写出。
flush() - Method in class java.io. PipedWriter
刷新此输出流并强制任何缓冲的输出字符被写出。
flush() - Method in class java.io. PrintStream
刷新流。
flush() - Method in class java.io. PrintWriter
刷新流。
flush() - Method in class java.io. StringWriter
冲洗流。
flush() - Method in class java.io. Writer
刷新流。
flush() - Method in class java.util. Formatter
刷新格式化程序。
flush() - Method in class java.util.logging. Handler
冲洗任何缓冲输出。
flush() - Method in class java.util.logging. MemoryHandler
导致目标上的冲水 Handler 。
flush() - Method in class java.util.logging. StreamHandler
刷新任何缓冲的消息。
flush() - Method in class java.util.prefs. AbstractPreferences
实现 flush方法按照在本说明书中 Preferences.flush() 。
flush() - Method in class java.util.prefs. Preferences
强制将此首选项节点及其后代的内容更改为永久存储。
flush() - Method in class java.util.zip. DeflaterOutputStream
刷新压缩的输出流。
flush() - Method in class java.util.zip. InflaterOutputStream
刷新此输出流，强制任何待处理的缓冲输出字节被写入。
flush() - Method in class javax.crypto. CipherOutputStream
通过强制已经由封装的密码对象处理的任何缓冲的输出字节被写出来刷新输出流。
flush() - Method in interface javax.imageio.stream. ImageInputStream
在当前流位置之前丢弃流的初始位置。
flush() - Method in class javax.imageio.stream. ImageInputStreamImpl
flush() - Method in interface javax.sound.sampled. DataLine
从行刷新排队的数据。
flush() - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
最后一个方法叫读者。
flush() - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
最后一个方法叫读者。
flush() - Method in class javax.tools. ForwardingJavaFileManager
flush() - Method in interface javax.tools. JavaFileManager
刷新此文件管理器直接或间接打开输出的任何资源。
flush() - Method in interface javax.xml.stream. XMLEventWriter
将任何缓存的事件写入基础输出机制
flush() - Method in interface javax.xml.stream. XMLStreamWriter
将任何缓存的数据写入基础输出机制。
flush(ByteBuffer) - Method in class java.nio.charset. CharsetEncoder
刷新编码器。
flush(CharBuffer) - Method in class java.nio.charset. CharsetDecoder
刷新此解码器。
FLUSH_FAILURE - Static variable in class java.util.logging. ErrorManager
当输出流的刷新失败时使用FLUSH_FAILURE。
Flush3DBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.Flush3DBorder
Flushable - Interface in java.io
A Flushable是可以刷新的数据的目的地。
flushAttributes() - Method in class javax.swing.text.html.parser. Parser
删除当前属性。
flushBefore(long) - Method in class javax.imageio.stream. FileCacheImageOutputStream
flushBefore(long) - Method in interface javax.imageio.stream. ImageInputStream
在指示的位置之前丢弃流的初始部分。
flushBefore(long) - Method in class javax.imageio.stream. ImageInputStreamImpl
flushBefore(long) - Method in interface javax.imageio.stream. ImageOutputStream
将给定位置之前的所有数据刷新到基础目的地，例如 OutputStream或 File 。
flushBefore(long) - Method in class javax.imageio.stream. MemoryCacheImageInputStream
flushBefore(long) - Method in class javax.imageio.stream. MemoryCacheImageOutputStream
flushBits() - Method in class javax.imageio.stream. ImageOutputStreamImpl
如果位偏移量不为零，则强制当前字节中的剩余位为0，并将流位置提前一位。
flushCaches() - Static method in class java.beans. Introspector
冲洗所有Introspector的内部缓存。
flushedPos - Variable in class javax.imageio.stream. ImageInputStreamImpl
可以丢弃数据的位置。
flushFromCaches(Class<?>) - Static method in class java.beans. Introspector
刷新内部缓存信息给一个给定的类。
flushRequirementChanges() - Method in class javax.swing.text. AsyncBoxView
将首选项向上发布到父视图。
flushSpi() - Method in class java.util.prefs. AbstractPreferences
此方法在此节点锁定时被调用。
fma(double, double, double) - Static method in class java.lang. Math
返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的double 。
fma(double, double, double) - Static method in class java.lang. StrictMath
返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的double 。
fma(float, float, float) - Static method in class java.lang. Math
返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的float 。
fma(float, float, float) - Static method in class java.lang. StrictMath
返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的float 。
FOCAL_PLANE_RESOLUTION_UNIT_CENTIMETER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“FocalPlaneXResolution”标签一起使用的值。
FOCAL_PLANE_RESOLUTION_UNIT_INCH - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“FocalPlaneXResolution”标签一起使用的值。
FOCAL_PLANE_RESOLUTION_UNIT_NONE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
要与“FocalPlaneResolutionUnit”标签一起使用的值。
focus - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
聚焦颜色
focus() - Method in interface org.w3c.dom.html. HTMLAnchorElement
给这个元素提供键盘焦点。
focus() - Method in interface org.w3c.dom.html. HTMLInputElement
给这个元素提供键盘焦点。
focus() - Method in interface org.w3c.dom.html. HTMLSelectElement
给这个元素提供键盘焦点。
focus() - Method in interface org.w3c.dom.html. HTMLTextAreaElement
给这个元素提供键盘焦点。
focus(int) - Method in class javafx.scene.control. FocusModel
导致给定索引处的项目接收焦点。
focus(int) - Method in class javafx.scene.control. TableView.TableViewFocusModel
导致给定索引处的项目接收焦点。
focus(int) - Method in class javafx.scene.control. TableView.TableViewSelectionModel
focus(int) - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
导致给定索引处的项目接收焦点。
focus(int) - Method in class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel
focus(int, TableColumn<S, ?>) - Method in class javafx.scene.control. TableView.TableViewFocusModel
导致给定索引处的项目接收焦点。
focus(int, TreeTableColumn<S, ?>) - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
导致给定索引处的项目接收焦点。
focus(int, TC) - Method in class javafx.scene.control. TableFocusModel
导致给定索引处的项目接收焦点。
focus(TablePosition) - Method in class javafx.scene.control. TableView.TableViewFocusModel
使用TablePosition设置焦点在特定行或单元格的便利方法。
focus(TreeTablePosition<S, ?>) - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
使用TablePosition设置焦点在特定行或单元格的便利方法。
FOCUS - Static variable in class com.sun.java.accessibility.util. EventID
映射到AWT Focus支持（即FocusListener和FocusEvent）
FOCUS - Static variable in class javax.swing.plaf.synth. ColorType
ColorType为焦点。
FOCUS_ACCELERATOR_KEY - Static variable in class javax.swing.text. JTextComponent
焦点加速器的绑定属性名称。
FOCUS_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择焦点事件的事件掩码。
FOCUS_FIRST - Static variable in class java.awt.event. FocusEvent
用于焦点事件的ids范围中的第一个数字。
FOCUS_GAINED - Static variable in class java.awt.event. FocusEvent
此事件表示组件现在是焦点所有者。
FOCUS_ITEM - javafx.scene. AccessibleAttribute
返回焦点项。
FOCUS_LAST - Static variable in class java.awt.event. FocusEvent
用于焦点事件的ids范围中的最后一个数字。
FOCUS_LOST - Static variable in class java.awt.event. FocusEvent
此事件表示组件不再是焦点所有者。
FOCUS_MANAGER_CLASS_PROPERTY - Static variable in class javax.swing. FocusManager
该字段已过时，因为其规范与1.4焦点API不兼容，因此不鼓励使用该字段。
FOCUS_NODE - javafx.scene. AccessibleAttribute
返回焦点节点。
FOCUS_PAINTED_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识在聚焦时突出显示边框的更改。
FOCUSABLE - Static variable in class javax.accessibility. AccessibleState
表示此对象可以接受键盘焦点，这意味着通过在键盘上打字产生的所有事件通常会在焦点时传递给它。
focusAboveCell() - Method in class javafx.scene.control. TableFocusModel
尝试将焦点移动到当前聚焦单元格上方的单元格。
focusAboveCell() - Method in class javafx.scene.control. TableView.TableViewFocusModel
尝试将焦点移动到当前聚焦单元格上方的单元格。
focusAboveCell() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
尝试将焦点移动到当前聚焦单元格上方的单元格。
FocusAdapter - Class in java.awt.event
用于接收键盘焦点事件的抽象适配器类。
FocusAdapter() - Constructor for class java.awt.event. FocusAdapter
focusBelowCell() - Method in class javafx.scene.control. TableFocusModel
尝试将焦点移动到当前聚焦单元格下方的单元格。
focusBelowCell() - Method in class javafx.scene.control. TableView.TableViewFocusModel
尝试将焦点移动到当前聚焦单元格下方的单元格。
focusBelowCell() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
尝试将焦点移动到当前聚焦单元格下方的单元格。
focusColor - Variable in class javax.swing.plaf.metal. MetalButtonUI
聚焦按钮的颜色。
focusColor - Variable in class javax.swing.plaf.metal. MetalRadioButtonUI
聚焦单选按钮的颜色。
focusColor - Variable in class javax.swing.plaf.metal. MetalToggleButtonUI
聚焦切换按钮的颜色。
FOCUSED - javafx.scene. AccessibleAttribute
如果节点聚焦，则返回true，否则返回false。
FOCUSED - Static variable in class javax.accessibility. AccessibleState
表示此对象当前具有键盘焦点。
FOCUSED - Static variable in interface javax.swing.plaf.synth. SynthConstants
表示该地区有焦点。
focusedCellProperty() - Method in class javafx.scene.control. TableView.TableViewFocusModel
当前项目在TableView中的位置具有重点。
focusedCellProperty() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
当前项目在TableView中的位置具有重点。
focusedCompIndex - Variable in class javax.swing.plaf.basic. BasicToolBarUI
聚焦组件的索引。
focusedIndexProperty() - Method in class javafx.scene.control. FocusModel
FocusModel中具有焦点的当前项目的索引。
focusedItemProperty() - Method in class javafx.scene.control. FocusModel
FocusModel中的当前项目具有重点。
focusedProperty() - Method in class javafx.scene. Node
指示此 Node当前是否具有输入焦点。
focusedProperty() - Method in class javafx.stage. Window
这个 Window是否具有键盘或输入焦点。
FocusEvent - Class in java.awt.event
指示组件已经获得或丢失了输入焦点的低级事件。
FocusEvent(Component, int) - Constructor for class java.awt.event. FocusEvent
构造一个 FocusEvent对象，并将其标识为焦点的永久性更改。
FocusEvent(Component, int, boolean) - Constructor for class java.awt.event. FocusEvent
构造一个 FocusEvent对象，并确定更改是否是临时的。
FocusEvent(Component, int, boolean, Component) - Constructor for class java.awt.event. FocusEvent
构造一个具有指定临时状态的 FocusEvent对象，与 Component相反， Cause.UNKNOWN原因。
FocusEvent(Component, int, boolean, Component, FocusEvent.Cause) - Constructor for class java.awt.event. FocusEvent
构造一个 FocusEvent对象，具有指定的临时状态，相反的原因是 Component 。
FocusEvent.Cause - Enum in java.awt.event
这个枚举代表了一个 FocusEvent的原因 - 它发生的原因。
focusGained(FocusEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用focusGained方法来处理focusGained事件。
focusGained(FocusEvent) - Method in class java.awt. Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
focusGained(FocusEvent) - Method in class java.awt.event. FocusAdapter
当组件获得键盘焦点时调用。
focusGained(FocusEvent) - Method in interface java.awt.event. FocusListener
当组件获得键盘焦点时调用。
focusGained(FocusEvent) - Method in class javax.swing. JComponent.AccessibleJComponent.AccessibleFocusHandler
已过时。
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxEditor
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicListUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.ToolBarFocusListener
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.FocusHandler
在我们所在的树上激活焦点时调用，重绘铅笔。
focusGained(FocusEvent) - Method in class javax.swing.text. DefaultCaret
当包含插入符号的组件获取焦点时调用。
FocusHandler() - Constructor for class javax.swing.plaf.basic. BasicComboBoxUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic. BasicListUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic. BasicSliderUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic. BasicTabbedPaneUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic. BasicTableUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.FocusHandler
focusInsets - Variable in class javax.swing.plaf.basic. BasicSliderUI
焦点插图
focusLeftCell() - Method in class javafx.scene.control. TableFocusModel
尝试将焦点移动到当前聚焦单元格左侧的单元格。
focusLeftCell() - Method in class javafx.scene.control. TableView.TableViewFocusModel
尝试将焦点移动到当前聚焦单元格左侧的单元格。
focusLeftCell() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
尝试将焦点移动到当前聚焦单元格左侧的单元格。
focusListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor
不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。
focusListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
此保护字段是实现特定的。
focusListener - Variable in class javax.swing.plaf.basic. BasicListUI
FocusListener ，附于 JList 。
focusListener - Variable in class javax.swing.plaf.basic. BasicSliderUI
聚焦听众
focusListener - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
此JSplitPane的FocusListener的实例。
focusListener - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
焦点变化听众
focusListener - Variable in class javax.swing.plaf.basic. BasicTableUI
FocusListener ，附于 JTable 。
FocusListener - Interface in java.awt.event
用于在组件上接收键盘焦点事件的侦听器界面。
focusLost(FocusEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用focusLost方法来处理focusLost事件。
focusLost(FocusEvent) - Method in class java.awt. Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
focusLost(FocusEvent) - Method in class java.awt.event. FocusAdapter
当组件丢失键盘焦点时调用。
focusLost(FocusEvent) - Method in interface java.awt.event. FocusListener
当组件丢失键盘焦点时调用。
focusLost(FocusEvent) - Method in class javax.swing. JComponent.AccessibleJComponent.AccessibleFocusHandler
已过时。
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxEditor
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicListUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.ToolBarFocusListener
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.FocusHandler
在我们所在的树上激活焦点时调用，重绘铅笔。
focusLost(FocusEvent) - Method in class javax.swing.text. DefaultCaret
当包含插入符号的组件失去焦点时调用。
FocusManager - Class in javax.swing
这个类已被1.4焦点API过时了。
FocusManager() - Constructor for class javax.swing. FocusManager
FocusModel< T> - Class in javafx.scene.control
FocusModel实现的抽象基类。
FocusModel() - Constructor for class javafx.scene.control. FocusModel
创建默认的FocusModel实例。
focusModelProperty() - Method in class javafx.scene.control. ListView
FocusModel提供了API，通过它可以获得并设置ListView中单个项目的焦点。
focusModelProperty() - Method in class javafx.scene.control. TableView
代表当前安装的TableView.TableViewFocusModel for TableView。
focusModelProperty() - Method in class javafx.scene.control. TreeTableView
FocusModel提供API，通过它可以将焦点控制在零或一行TreeTableView上。
focusModelProperty() - Method in class javafx.scene.control. TreeView
FocusModel提供API，通过它可以将焦点控制在零行或一行TreeView。
focusNext() - Method in class javafx.scene.control. FocusModel
尝试将焦点放在当前焦点集中的行之后。
focusNext() - Method in class javafx.scene.control. TableView.TableViewFocusModel
尝试将焦点放在当前焦点集中的行之后。
focusNext() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
尝试将焦点放在当前焦点集中的行之后。
focusNextComponent() - Method in class java.awt. KeyboardFocusManager
在当前焦点所有者之后聚焦组件。
focusNextComponent(Component) - Method in class java.awt. DefaultKeyboardFocusManager
将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
focusNextComponent(Component) - Method in class java.awt. KeyboardFocusManager
将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
focusOwnerProperty() - Method in class javafx.scene. Scene
场景当前焦点所有者节点。
focusPrevious() - Method in class javafx.scene.control. FocusModel
尝试将重点放在目前重点集中的行之前。
focusPrevious() - Method in class javafx.scene.control. TableView.TableViewFocusModel
尝试将重点放在目前重点集中的行之前。
focusPrevious() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
尝试将重点放在目前重点集中的行之前。
focusPreviousComponent() - Method in class java.awt. KeyboardFocusManager
将组件聚焦到当前焦点所有者之前。
focusPreviousComponent(Component) - Method in class java.awt. DefaultKeyboardFocusManager
在组件之前聚焦组件，通常基于FocusTraversalPolicy。
focusPreviousComponent(Component) - Method in class java.awt. KeyboardFocusManager
在组件之前聚焦组件，通常基于FocusTraversalPolicy。
focusRect - Variable in class javax.swing.plaf.basic. BasicSliderUI
焦点矩形
focusRightCell() - Method in class javafx.scene.control. TableFocusModel
尝试将焦点移动到当前聚焦单元格右侧的单元格。
focusRightCell() - Method in class javafx.scene.control. TableView.TableViewFocusModel
尝试将焦点移动到当前聚焦单元格右侧的单元格。
focusRightCell() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel
尝试将焦点移动到当前聚焦单元格右侧的单元格。
focusTraversableProperty() - Method in class javafx.scene. Node
指定这个 Node是否应该是焦点遍历周期的一部分。
FocusTraversalPolicy - Class in java.awt
FocusTraversalPolicy定义了遍历特定焦点循环根的组件的顺序。
FocusTraversalPolicy() - Constructor for class java.awt. FocusTraversalPolicy
foldArguments(MethodHandle, int, MethodHandle) - Static method in class java.lang.invoke. MethodHandles
通过预先处理一些参数，从给定的位置开始，然后调用具有预处理结果的目标，将其插入原来的参数序列之前，使其适用于目标方法句柄。
foldArguments(MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles
通过预处理一些参数来适应目标方法句柄，然后调用具有预处理结果的目标，插入到原始的参数序列中。
FolderIcon16() - Constructor for class javax.swing.plaf.metal. MetalIconFactory.FolderIcon16
FOLIO - Static variable in class java.awt. PageAttributes.MediaType
Folio的MediaType实例，8 1/2 x 13 in。
FOLIO - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定作品大小，8.5英寸×13英寸。
FOLIO - Static variable in class javax.print.attribute.standard. MediaSizeName
对开大小。
FOLLOW_LINKS - java.nio.file. FileVisitOption
遵循符号链接。
following(int) - Method in class java.text. BreakIterator
返回指定字符偏移后的第一个边界。
followRedirects() - Method in class jdk.incubator.http. HttpClient
返回此客户端的以下重定向设置。
followRedirects(HttpClient.Redirect) - Method in class jdk.incubator.http. HttpClient.Builder
指定请求是否会自动跟踪服务器发出的重定向。
font - Variable in class java.awt. FontMetrics
创建字体指标的实际Font 。
font - Variable in class javax.swing.tree. DefaultTreeCellEditor
要绘制的字体， null表示将使用渲染器的字体。
font(double) - Static method in class javafx.scene.text. Font
根据默认的字体系列名称和给定的字体大小搜索适当的字体。
font(String) - Static method in class javafx.scene.text. Font
根据给定的字体系列名称和默认字体大小搜索适当的字体。
font(String, double) - Static method in class javafx.scene.text. Font
根据字体系列名称和大小搜索适当的字体。
font(String, FontPosture, double) - Static method in class javafx.scene.text. Font
根据字体系列名称和姿势样式，搜索适合的字体。
font(String, FontWeight, double) - Static method in class javafx.scene.text. Font
根据字体系列名称和体重样式搜索适当的字体。
font(String, FontWeight, FontPosture, double) - Static method in class javafx.scene.text. Font
根据字体系列名称，体重和姿势样式搜索适当的字体。
Font - Class in java.awt
Font类代表字体，用于以可见的方式呈现文本。
Font - Class in javafx.scene.text
Font类表示字体，用于在屏幕上呈现文本。
Font(double) - Constructor for class javafx.scene.text. Font
使用默认面“System”构造一个字体。
Font(Font) - Constructor for class java.awt. Font
创建一个新 Font从指定 font 。
Font(String, double) - Constructor for class javafx.scene.text. Font
使用指定的正面名称和大小构造字体
Font(String, int, int) - Constructor for class java.awt. Font
从指定的名称，样式和点大小创建一个新的 Font 。
Font(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Constructor for class java.awt. Font
创建一个新的 Font具有指定的属性。
FONT - javafx.scene. AccessibleAttribute
返回节点的字体。
FONT - Static variable in class java.awt.font. TextAttribute
用于提供用于呈现文本的字体的属性键。
FONT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“font”。
FONT - Static variable in class javax.swing.text.html. HTML.Tag
标签<font>
FONT_CHANGE_BIGGER - Static variable in class javax.swing.text.html. HTMLEditorKit
字体大小增加到下一个值动作标识符
FONT_CHANGE_SMALLER - Static variable in class javax.swing.text.html. HTMLEditorKit
字体大小减小到下一个值动作标识符
FONT_CHOOSER - Static variable in class javax.accessibility. AccessibleRole
A FONT_CHOOSER是一个组件，可让用户为字体选择各种属性。
FONT_FACE_RULE - Static variable in interface org.w3c.dom.css. CSSRule
规则是 CSSFontFaceRule 。
FONT_FAMILY - javafx.scene.web. HTMLEditorSkin.Command
FONT_FAMILY - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“font-family”。
FONT_SIZE - javafx.scene.web. HTMLEditorSkin.Command
FONT_SIZE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“font-size”。
FONT_STYLE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“font-style”。
FONT_VARIANT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“font-variant”。
FONT_WEIGHT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“font-weight”。
fontChanged - Static variable in class javax.swing.plaf.basic. BasicListUI
该位与字体更改属性有关。
FontConverter - Class in javafx.css.converter
FontConverter.FontSizeConverter - Class in javafx.css.converter
FontConverter.FontStyleConverter - Class in javafx.css.converter
FontConverter.FontWeightConverter - Class in javafx.css.converter
FontCssMetaData< S extends Styleable> - Class in javafx.css
CssMetaData部分实现Font属性，其中包含字体子属性：weight，style，family和size。
FontCssMetaData(String, Font) - Constructor for class javafx.css. FontCssMetaData
从指定的属性和初始字体构造一个FontCSSMetaData对象。
FontFace - Class in javafx.css
FontFace是一个来自CSS文件的@ font-face定义
FontFace() - Constructor for class javafx.css. FontFace
仅用于私有实现类的构造方法。
FontFamily - Static variable in class javax.swing.text. StyleConstants
字体系列的名称
FontFamilyAction(String, String) - Constructor for class javax.swing.text. StyledEditorKit.FontFamilyAction
创建一个新的FontFamilyAction。
FontFormatException - Exception in java.awt
在 Font类中通过方法createFont抛出，指示指定的字体不好。
FontFormatException(String) - Constructor for exception java.awt. FontFormatException
报告FontFormatException为指定的原因。
FontMetrics - Class in java.awt
FontMetrics类定义了一个字体度量对象，该对象封装了特定屏幕上特定字体渲染的信息。
FontMetrics(Font) - Constructor for class java.awt. FontMetrics
创建一个新的 FontMetrics用于找出的高度和宽度信息有关指定对象 Font在和特定字符字形的 Font 。
FontPosture - Enum in javafx.scene.text
指定字体是否为斜体
fontProperty() - Method in class javafx.scene.control. Labeled
用于标签中文本的默认字体。
fontProperty() - Method in class javafx.scene.control. TextInputControl
TextInputControl中用于文本的默认字体。
fontProperty() - Method in class javafx.scene.control. Tooltip
工具提示中用于文本的默认字体。
fontProperty() - Method in class javafx.scene.text. Text
定义文本的字体。
FontRenderContext - Class in java.awt.font
FontRenderContext类是用于正确测量文本所需信息的容器。
FontRenderContext() - Constructor for class java.awt.font. FontRenderContext
构造一个新的 FontRenderContext对象。
FontRenderContext(AffineTransform, boolean, boolean) - Constructor for class java.awt.font. FontRenderContext
从可选的AffineTransform和两个boolean值构造一个FontRenderContext对象，用于确定新构造的对象是否具有抗锯齿或小数度量。
FontRenderContext(AffineTransform, Object, Object) - Constructor for class java.awt.font. FontRenderContext
从可选的AffineTransform和两个Object值构造一个FontRenderContext对象，确定新构造的对象是否具有抗锯齿或小数度量。
fontScaleProperty() - Method in class javafx.scene.web. WebView
指定应用于字体的比例因子。
FontSize - Static variable in class javax.swing.text. StyleConstants
字体大小的名称。
FontSizeAction(String, int) - Constructor for class javax.swing.text. StyledEditorKit.FontSizeAction
创建一个新的FontSizeAction。
FontSmoothingType - Enum in javafx.scene.text
用于指定用于屏幕文本平滑字体边缘的首选机制是 FontSmoothingType枚举。
fontSmoothingTypeProperty() - Method in class javafx.scene.text. Text
指定所请求的字体平滑类型：灰色或LCD。
fontSmoothingTypeProperty() - Method in class javafx.scene.web. WebView
指定所请求的字体平滑类型：灰色或LCD。
FontUIResource - Class in javax.swing.plaf
实现UIResource的java.awt.Font的子类。
FontUIResource(Font) - Constructor for class javax.swing.plaf. FontUIResource
构造一个 FontUIResource 。
FontUIResource(String, int, int) - Constructor for class javax.swing.plaf. FontUIResource
构造一个 FontUIResource 。
FontWeight - Enum in javafx.scene.text
指定在系统上搜索字体时可以使用的不同字体权重。
FOOTER - Static variable in class javax.accessibility. AccessibleRole
文字页脚。
FOR_IN_LOOP - jdk.nashorn.api.tree. Tree.Kind
用于ForInLoopTree的实例。
FOR_LOOP - com.sun.source.tree. Tree.Kind
用于ForLoopTree的实例。
FOR_LOOP - jdk.nashorn.api.tree. Tree.Kind
用于ForLoopTree的实例。
force() - Method in class java.nio. MappedByteBuffer
强制将此缓冲区内容的任何更改写入包含映射文件的存储设备。
force(boolean) - Method in class java.nio.channels. AsynchronousFileChannel
强制将此通道文件的任何更新写入包含该通道的存储设备。
force(boolean) - Method in class java.nio.channels. FileChannel
强制将此通道文件的任何更新写入包含该通道的存储设备。
ForcedBreakWeight - Static variable in class javax.swing.text. View
指示视图的重量支持断开，并且必须打破，以便在放置在通过破坏它们来格式化其子项的视图中时正确表示。
forceEarlyReturn(Value) - Method in interface com.sun.jdi. ThreadReference
强制一个方法在返回到返回语句之前返回。
forceIntegerRenderScaleProperty() - Method in class javafx.stage. Window
当相关的输出比例有变化时，控制系统默认情况下是否设置整数渲染比例的布尔属性。
forceTermination() - Method in class java.util.concurrent. Phaser
强制此移相器进入终止状态。
forceZeroInRangeProperty() - Method in class javafx.scene.chart. NumberAxis
当真实零值始终包含在可见范围内时。
forClass() - Method in class java.io. ObjectStreamClass
返回此版本映射到的本地VM中的类。
forClass(Class<?>) - Static method in class jdk.dynalink.beans. StaticClass
检索指定类的StaticClass实例。
forDigit(int, int) - Static method in class java.lang. Character
确定指定基数中特定数字的字符表示。
forEach(long, BiConsumer<? super K, ? super V>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个（键，值）执行给定的动作。
forEach(long, BiFunction<? super K, ? super V, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个（key，value）的每个非空变换执行给定的动作。
forEach(BiConsumer<? super Object, ? super Object>) - Method in class java.security. Provider
forEach(BiConsumer<? super Object, ? super Object>) - Method in class java.util. Properties
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.concurrent. ConcurrentHashMap
forEach(BiConsumer<? super K, ? super V>) - Method in interface java.util.concurrent. ConcurrentMap
对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.concurrent. ConcurrentSkipListMap
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util. HashMap
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util. Hashtable
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util. IdentityHashMap
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util. LinkedHashMap
forEach(BiConsumer<? super K, ? super V>) - Method in interface java.util. Map
对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util. TreeMap
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util. WeakHashMap
forEach(Consumer<? super E>) - Method in class java.util. ArrayDeque
forEach(Consumer<? super E>) - Method in class java.util. ArrayList
forEach(Consumer<? super E>) - Method in class java.util.concurrent. ArrayBlockingQueue
forEach(Consumer<? super E>) - Method in class java.util.concurrent. ConcurrentLinkedDeque
forEach(Consumer<? super E>) - Method in class java.util.concurrent. ConcurrentLinkedQueue
forEach(Consumer<? super E>) - Method in class java.util.concurrent. CopyOnWriteArrayList
forEach(Consumer<? super E>) - Method in class java.util.concurrent. CopyOnWriteArraySet
forEach(Consumer<? super E>) - Method in class java.util.concurrent. LinkedBlockingDeque
forEach(Consumer<? super E>) - Method in class java.util.concurrent. LinkedBlockingQueue
forEach(Consumer<? super E>) - Method in class java.util.concurrent. LinkedTransferQueue
forEach(Consumer<? super E>) - Method in class java.util. Vector
forEach(Consumer<? super StackWalker.StackFrame>) - Method in class java.lang. StackWalker
对当前线程的 StackFrame流的每个元素执行给定的动作，从堆栈的顶部框架遍历，这是调用此 forEach方法的方法。
forEach(Consumer<? super K>) - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView
forEach(Consumer<? super T>) - Method in interface java.lang. Iterable
对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEach(Consumer<? super T>) - Method in interface java.util.stream. Stream
对此流的每个元素执行操作。
forEach(DoubleConsumer) - Method in interface java.util.stream. DoubleStream
对此流的每个元素执行操作。
forEach(IntConsumer) - Method in interface java.util.stream. IntStream
对此流的每个元素执行操作。
forEach(LongConsumer) - Method in interface java.util.stream. LongStream
对此流的每个元素执行操作。
forEachEntry(long, Consumer<? super Map.Entry<K, V>>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个条目执行给定的操作。
forEachEntry(long, Function<Map.Entry<K, V>, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个条目的每个非空变换执行给定的操作。
forEachKey(long, Consumer<? super K>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个键执行给定的动作。
forEachKey(long, Function<? super K, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个键的每个非空变换执行给定的动作。
forEachOrdered(Consumer<? super T>) - Method in interface java.util.stream. Stream
如果流具有定义的遇到顺序，则以流的遇到顺序对该流的每个元素执行操作。
forEachOrdered(DoubleConsumer) - Method in interface java.util.stream. DoubleStream
对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
forEachOrdered(IntConsumer) - Method in interface java.util.stream. IntStream
对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
forEachOrdered(LongConsumer) - Method in interface java.util.stream. LongStream
对此流的每个元素执行一个操作，保证每个元素按遇到顺序处理，以便具有定义的遇到顺序的流。
forEachRemaining(Consumer<? super E>) - Method in interface java.util. Iterator
对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(Consumer<? super Double>) - Method in interface java.util. PrimitiveIterator.OfDouble
对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(Consumer<? super Double>) - Method in interface java.util. Spliterator.OfDouble
在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(Consumer<? super Integer>) - Method in interface java.util. PrimitiveIterator.OfInt
对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(Consumer<? super Integer>) - Method in interface java.util. Spliterator.OfInt
在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(Consumer<? super Long>) - Method in interface java.util. PrimitiveIterator.OfLong
对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(Consumer<? super Long>) - Method in interface java.util. Spliterator.OfLong
在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(Consumer<? super T>) - Method in interface java.util. Spliterator
在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(DoubleConsumer) - Method in interface java.util. PrimitiveIterator.OfDouble
对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(DoubleConsumer) - Method in interface java.util. Spliterator.OfDouble
forEachRemaining(IntConsumer) - Method in interface java.util. PrimitiveIterator.OfInt
对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(IntConsumer) - Method in interface java.util. Spliterator.OfInt
forEachRemaining(LongConsumer) - Method in interface java.util. PrimitiveIterator.OfLong
对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
forEachRemaining(LongConsumer) - Method in interface java.util. Spliterator.OfLong
forEachRemaining(T_CONS) - Method in interface java.util. PrimitiveIterator
对每个剩余的元素执行给定的动作，按照迭代时发生的顺序，直到所有元素都被处理或动作引发异常。
forEachRemaining(T_CONS) - Method in interface java.util. Spliterator.OfPrimitive
在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
forEachValue(long, Consumer<? super V>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个值执行给定的操作。
forEachValue(long, Function<? super V, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent. ConcurrentHashMap
对每个值的每个非空转换执行给定的动作。
Foreground - Static variable in class javax.swing.text. StyleConstants
前景颜色属性的名称。
FOREGROUND - Static variable in class java.awt.font. TextAttribute
用于渲染文本的颜色的属性键。
FOREGROUND - Static variable in class javax.swing.plaf.synth. ColorType
ColorType为区域的前景。
FOREGROUND_COLOR - javafx.scene.web. HTMLEditorSkin.Command
ForegroundAction(String, Color) - Constructor for class javax.swing.text. StyledEditorKit.ForegroundAction
创建一个新的ForegroundAction。
FORESTGREEN - Static variable in class javafx.scene.paint. Color
颜色森林绿色，RGB值为＃228B22
FOREVER - java.time.temporal. ChronoUnit
代表永恒概念的人造单位。
forget(Xid) - Method in interface javax.transaction.xa. XAResource
告诉资源管理器忘记一个启发式完成的事务分支。
ForInLoopTree - Interface in jdk.nashorn.api.tree
for..in语句的树节点例如：
fork() - Method in class java.util.concurrent. ForkJoinTask
在当前任务正在运行的池中异步执行此任务，如果适用，或使用 ForkJoinPool.commonPool()（如果不是 ForkJoinTask.inForkJoinPool()） 。
ForkJoinPool - Class in java.util.concurrent
一个ExecutorService运行ForkJoinTask s。
ForkJoinPool() - Constructor for class java.util.concurrent. ForkJoinPool
创建一个 ForkJoinPool ，并行度等于 Runtime.availableProcessors() ，使用所有其他参数的默认值（见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
ForkJoinPool(int) - Constructor for class java.util.concurrent. ForkJoinPool
使用指定的并行级别创建一个 ForkJoinPool ，使用所有其他参数的默认值（见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
ForkJoinPool(int, ForkJoinPool.ForkJoinWorkerThreadFactory, Thread.UncaughtExceptionHandler, boolean) - Constructor for class java.util.concurrent. ForkJoinPool
使用给定的参数创建一个 ForkJoinPool （使用默认 值为其他参数 - 请参阅 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
ForkJoinPool(int, ForkJoinPool.ForkJoinWorkerThreadFactory, Thread.UncaughtExceptionHandler, boolean, int, int, int, Predicate<? super ForkJoinPool>, long, TimeUnit) - Constructor for class java.util.concurrent. ForkJoinPool
使用给定的参数创建一个 ForkJoinPool 。
ForkJoinPool.ForkJoinWorkerThreadFactory - Interface in java.util.concurrent
工厂创建新的ForkJoinWorkerThread s。
ForkJoinPool.ManagedBlocker - Interface in java.util.concurrent
用于扩展管理并行性的接口，用于运行在ForkJoinPool中的任务。
ForkJoinTask< V> - Class in java.util.concurrent
在ForkJoinPool内运行的任务的抽象基类。
ForkJoinTask() - Constructor for class java.util.concurrent. ForkJoinTask
ForkJoinWorkerThread - Class in java.util.concurrent
一个由ForkJoinPool管理的线程，执行ForkJoinTask秒。
ForkJoinWorkerThread(ForkJoinPool) - Constructor for class java.util.concurrent. ForkJoinWorkerThread
在给定的池中创建一个ForkJoinWorkerThread。
forLanguageTag(String) - Static method in class java.util. Locale
返回指定的IETF BCP 47语言标记字符串的语言环境。
forListView() - Static method in class javafx.scene.control.cell. TextFieldListCell
提供了一个TextField ，允许在双击单元格时调用单元格内容，或者调用ListView.edit(int)时。
forListView(ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxListCell
创建一个ChoiceBox单元格工厂用于ListView控件。
forListView(ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxListCell
创建一个ComboBox单元格工厂，用于ListView控件。
forListView(Callback<T, ObservableValue<Boolean>>) - Static method in class javafx.scene.control.cell. CheckBoxListCell
创建用于ListView控件的单元格工厂。
forListView(Callback<T, ObservableValue<Boolean>>, StringConverter<T>) - Static method in class javafx.scene.control.cell. CheckBoxListCell
创建用于ListView控件的单元格工厂。
forListView(StringConverter<T>) - Static method in class javafx.scene.control.cell. TextFieldListCell
提供TextField ，使单元格内容的编辑在小区双击，或者当ListView.edit(int)被调用。
forListView(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxListCell
创建一个ChoiceBox单元格工厂，用于ListView控件。
forListView(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxListCell
创建ComboBox单元格工厂用于ListView控件。
forListView(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ChoiceBoxListCell
创建一个ChoiceBox单元格工厂，用于ListView控件。
forListView(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ComboBoxListCell
创建ComboBox单元格工厂，用于ListView控件。
forListView(T...) - Static method in class javafx.scene.control.cell. ChoiceBoxListCell
创建一个ChoiceBox单元格工厂，用于ListView控件。
forListView(T...) - Static method in class javafx.scene.control.cell. ComboBoxListCell
创建ComboBox单元格工厂，用于ListView控件。
ForLoopTree - Interface in com.sun.source.tree
一个树节点，用于基本的 for循环语句。
ForLoopTree - Interface in jdk.nashorn.api.tree
循环语句的基本“for”循环语句的树节点。
FORM - Static variable in class javax.swing.text.html. HTML.Tag
标签<form>
FormAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.FormAction
format - Variable in class javax.sound.sampled. AudioInputStream
流中包含的音频数据的格式。
format - Variable in class org.omg.IOP. Encoding
编码格式。
format(double) - Method in class java.text. NumberFormat
专业化格式。
format(double, StringBuffer, FieldPosition) - Method in class java.text. ChoiceFormat
返回格式为double的模式。
format(double, StringBuffer, FieldPosition) - Method in class java.text. DecimalFormat
格式化为一个字符串。
format(double, StringBuffer, FieldPosition) - Method in class java.text. NumberFormat
专业化格式。
format(long) - Method in class java.text. NumberFormat
专业化格式。
format(long, StringBuffer, FieldPosition) - Method in class java.text. ChoiceFormat
专业化格式。
format(long, StringBuffer, FieldPosition) - Method in class java.text. DecimalFormat
格式化一个长的字符串。
format(long, StringBuffer, FieldPosition) - Method in class java.text. NumberFormat
专业化格式。
format(Object) - Method in class java.text. Format
格式化一个对象来生成一个字符串。
format(Object[], StringBuffer, FieldPosition) - Method in class java.text. MessageFormat
格式化一个对象数组，并将 MessageFormat的格式附加到格式化对象的格式元素到所提供的 StringBuffer 。
format(Object, StringBuffer, FieldPosition) - Method in class java.text. DateFormat
覆盖格式。
format(Object, StringBuffer, FieldPosition) - Method in class java.text. DecimalFormat
格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
format(Object, StringBuffer, FieldPosition) - Method in class java.text. Format
格式化对象并将生成的文本附加到给定的字符串缓冲区。
format(Object, StringBuffer, FieldPosition) - Method in class java.text. MessageFormat
格式化一组对象，并将 MessageFormat的格式附加到格式化对象的格式元素中，到所提供的 StringBuffer 。
format(Object, StringBuffer, FieldPosition) - Method in class java.text. NumberFormat
格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
format(String, Object...) - Method in class java.io. Console
使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流。
format(String, Object...) - Method in class java.io. PrintStream
使用指定的格式字符串和参数将格式化的字符串写入此输出流。
format(String, Object...) - Method in class java.io. PrintWriter
使用指定的格式字符串和参数将格式化的字符串写入此写入程序。
format(String, Object...) - Static method in class java.lang. String
使用指定的格式字符串和参数返回格式化的字符串。
format(String, Object...) - Static method in class java.text. MessageFormat
使用给定的模式创建一个MessageFormat，并使用它来格式化给定的参数。
format(String, Object...) - Method in class java.util. Formatter
使用指定的格式字符串和参数将格式化的字符串写入此对象的目标。
format(String, Object...) - Static method in class javafx.beans.binding. Bindings
创建StringExpression保持多个值Objects根据格式格式化String 。
format(String, Object[]) - Static method in class jdk.nashorn.api.scripting. ScriptUtils
将JavaScript类型转换为String.format方法（jrunscript函数sprintf）的java类型的方法。
format(DateTimeFormatter) - Method in interface java.time.chrono. ChronoLocalDate
使用指定的格式化程序格式化此日期。
format(DateTimeFormatter) - Method in interface java.time.chrono. ChronoLocalDateTime
使用指定的格式化程序格式化此日期时间。
format(DateTimeFormatter) - Method in interface java.time.chrono. ChronoZonedDateTime
使用指定的格式化程序格式化此日期时间。
format(DateTimeFormatter) - Method in class java.time. LocalDate
使用指定的格式化程序格式化此日期。
format(DateTimeFormatter) - Method in class java.time. LocalDateTime
使用指定的格式化程序格式化此日期时间。
format(DateTimeFormatter) - Method in class java.time. LocalTime
此时使用指定的格式化程序格式化。
format(DateTimeFormatter) - Method in class java.time. MonthDay
使用指定的格式化程序格式化本月。
format(DateTimeFormatter) - Method in class java.time. OffsetDateTime
使用指定的格式化程序格式化此日期时间。
format(DateTimeFormatter) - Method in class java.time. OffsetTime
此时使用指定的格式化程序格式化。
format(DateTimeFormatter) - Method in class java.time. Year
今年格式使用指定的格式化程序。
format(DateTimeFormatter) - Method in class java.time. YearMonth
使用指定的格式化程序在今年的格式。
format(DateTimeFormatter) - Method in class java.time. ZonedDateTime
使用指定的格式化程序格式化此日期时间。
format(TemporalAccessor) - Method in class java.time.format. DateTimeFormatter
使用此格式化程序格式化日期时间对象。
format(Date) - Method in class java.text. DateFormat
将日期格式化成日期/时间字符串。
format(Date, StringBuffer, FieldPosition) - Method in class java.text. DateFormat
将日期格式化成日期/时间字符串。
format(Date, StringBuffer, FieldPosition) - Method in class java.text. SimpleDateFormat
将给定的 Date成日期/时间字符串，并将结果追加到给定的 StringBuffer 。
format(Locale, String, Object...) - Method in class java.io. PrintStream
使用指定的格式字符串和参数将格式化的字符串写入此输出流。
format(Locale, String, Object...) - Method in class java.io. PrintWriter
使用指定的格式字符串和参数将格式化的字符串写入此写入程序。
format(Locale, String, Object...) - Static method in class java.lang. String
使用指定的区域设置，格式字符串和参数返回格式化的字符串。
format(Locale, String, Object...) - Method in class java.util. Formatter
使用指定的区域设置，格式字符串和参数将格式化的字符串写入此对象的目标。
format(Locale, String, Object...) - Static method in class javafx.beans.binding. Bindings
创建一个StringExpression ，其中保存按照格式String和指定的Locale格式化的多个Objects的值
format(LogRecord) - Method in class java.util.logging. Formatter
格式化给定的日志记录并返回格式化的字符串。
format(LogRecord) - Method in class java.util.logging. SimpleFormatter
格式化给定的LogRecord。
format(LogRecord) - Method in class java.util.logging. XMLFormatter
将给定的消息格式化为XML。
Format - Class in java.text
Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
Format() - Constructor for class java.text. Format
唯一的构造函数。
FORMAT - java.util. Locale.Category
用于表示格式化日期，数字和/或货币的默认区域设置的类别。
FORMAT - javafx.scene.web. HTMLEditorSkin.Command
FORMAT - Static variable in class java.lang. Character
Unicode规范中的一般类别“Cf”。
FORMAT_CLASS - Static variable in class java.util. ResourceBundle.Control
类别 List包含 "java.class" 。
FORMAT_DEFAULT - Static variable in class java.util. ResourceBundle.Control
默认格式为 List ，其中包含字符串 "java.class"和 "java.properties" ，按此顺序。
FORMAT_FAILURE - Static variable in class java.util.logging. ErrorManager
由于任何原因格式化失败时使用FORMAT_FAILURE。
FORMAT_PROPERTIES - Static variable in class java.util. ResourceBundle.Control
属性格式 List包含 "java.properties" 。
Format.Field - Class in java.text
定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。
FormatConversionProvider - Class in javax.sound.sampled.spi
格式转换提供者将一种或多种输入格式的格式转换服务提供给一种或多种输出格式。
FormatConversionProvider() - Constructor for class javax.sound.sampled.spi. FormatConversionProvider
FormatFlagsConversionMismatchException - Exception in java.util
转换和标志不兼容时抛出未经检查的异常。
FormatFlagsConversionMismatchException(String, char) - Constructor for exception java.util. FormatFlagsConversionMismatchException
使用指定的标志和转换构造此类的实例。
formatMessage(LogRecord) - Method in class java.util.logging. Formatter
从日志记录本地化和格式化消息字符串。
FormatMismatch - Exception in org.omg.IOP.CodecPackage
org / omg / IOP / CodecPackage / FormatMismatch.java。
FormatMismatch() - Constructor for exception org.omg.IOP.CodecPackage. FormatMismatch
FormatMismatch(String) - Constructor for exception org.omg.IOP.CodecPackage. FormatMismatch
FormatMismatchHelper - Class in org.omg.IOP.CodecPackage
org / omg / IOP / CodecPackage / FormatMismatchHelper.java。
FormatMismatchHelper() - Constructor for class org.omg.IOP.CodecPackage. FormatMismatchHelper
FormatStringConverter< T> - Class in javafx.util.converter
StringConverter实现可以使用Format实例。
FormatStringConverter(Format) - Constructor for class javafx.util.converter. FormatStringConverter
FormatStyle - Enum in java.time.format
枚举本地化日期，时间或日期时间格式化的风格。
Formattable - Interface in java.util
所述Formattable接口必须通过需要执行自定义使用格式化任何类来实现's'的转换指定Formatter 。
FormattableFlags - Class in java.util
FomattableFlags被传递给Formattable.formatTo()方法和修改的输出格式为Formattables 。
FORMATTED_TEXT_FIELD - Static variable in class javax.swing.plaf.synth. Region
FormattedTextField区域。
Formatter - Class in java.util
printf风格格式字符串的解释器。
Formatter - Class in java.util.logging
格式化程序提供对LogRecords进行格式化的支持。
Formatter() - Constructor for class java.util. Formatter
构造一个新的格式化程序。
Formatter() - Constructor for class java.util.logging. Formatter
构造一个新的格式化程序
Formatter(File) - Constructor for class java.util. Formatter
使用指定的文件构造一个新的格式化程序。
Formatter(File, String) - Constructor for class java.util. Formatter
使用指定的文件和字符集构造一个新的格式化程序。
Formatter(File, String, Locale) - Constructor for class java.util. Formatter
使用指定的文件，字符集和区域设置构造一个新的格式化程序。
Formatter(OutputStream) - Constructor for class java.util. Formatter
使用指定的输出流构造一个新的格式化程序。
Formatter(OutputStream, String) - Constructor for class java.util. Formatter
使用指定的输出流和字符集构造一个新的格式化程序。
Formatter(OutputStream, String, Locale) - Constructor for class java.util. Formatter
使用指定的输出流，字符集和区域设置构造一个新的格式化程序。
Formatter(PrintStream) - Constructor for class java.util. Formatter
使用指定的打印流构造新的格式化程序。
Formatter(Appendable) - Constructor for class java.util. Formatter
构造具有指定目的地的新格式化程序。
Formatter(Appendable, Locale) - Constructor for class java.util. Formatter
构造一个具有指定目的地和区域设置的新格式化程序。
Formatter(String) - Constructor for class java.util. Formatter
构造具有指定文件名的新格式化程序。
Formatter(String, String) - Constructor for class java.util. Formatter
构造具有指定文件名和字符集的新格式化程序。
Formatter(String, String, Locale) - Constructor for class java.util. Formatter
构造具有指定文件名，字符集和区域设置的新格式化程序。
Formatter(Locale) - Constructor for class java.util. Formatter
构造具有指定区域设置的新格式化程序。
Formatter.BigDecimalLayoutForm - Enum in java.util
枚举为 BigDecimal格式化。
FormatterClosedException - Exception in java.util
格式化程序已关闭时抛出未检查的异常。
FormatterClosedException() - Constructor for exception java.util. FormatterClosedException
构造这个类的一个实例。
formatTo(TemporalAccessor, Appendable) - Method in class java.time.format. DateTimeFormatter
使用此格式化程序将日期时间对象格式化为 Appendable 。
formatTo(Formatter, int, int, int) - Method in interface java.util. Formattable
使用提供的formatter格式化对象。
formatToCharacterIterator(Object) - Method in class java.text. DecimalFormat
格式化产生一个 AttributedCharacterIterator的对象。
formatToCharacterIterator(Object) - Method in class java.text. Format
格式化一个对象，生成一个 AttributedCharacterIterator 。
formatToCharacterIterator(Object) - Method in class java.text. MessageFormat
格式化一组对象，并将它们插入到 MessageFormat的模式中，产生一个 AttributedCharacterIterator 。
formatToCharacterIterator(Object) - Method in class java.text. SimpleDateFormat
格式化一个对象，生成一个 AttributedCharacterIterator 。
FormSubmitEvent - Class in javax.swing.text.html
FormSubmitEvent用于通知有关方面提交表单。
FormSubmitEvent.MethodType - Enum in javax.swing.text.html
表示HTML表单方法类型。
FormView - Class in javax.swing.text.html
组件装饰器，用于实现表单元素<input>，<textarea>和<select>的视图界面。
FormView(Element) - Constructor for class javax.swing.text.html. FormView
创建一个新的FormView对象。
FormView.MouseEventListener - Class in javax.swing.text.html
当类型等于图像的输入点击时，MouseEventListener类可以处理表单提交。
forName(Module, String) - Static method in class java.lang. Class
返回 Class给定 binary name给定的模块中。
forName(String) - Static method in class java.lang. Character.UnicodeBlock
返回具有给定名称的UnicodeBlock。
forName(String) - Static method in enum java.lang. Character.UnicodeScript
使用给定的Unicode脚本名称或脚本名称别名返回UnicodeScript常量。
forName(String) - Static method in class java.lang. Class
返回与给定字符串名称的类或接口相关联的 Class对象。
forName(String) - Static method in class java.nio.charset. Charset
返回名为charset的charset对象。
forName(String, boolean, ClassLoader) - Static method in class java.lang. Class
使用给定的类加载器返回与给定字符串名称的类或接口相关联的 Class对象。
ForOfLoopTree - Interface in jdk.nashorn.api.tree
一个树节点为 for..of statement 。
forTableColumn() - Static method in class javafx.scene.control.cell. ProgressBarTableCell
提供了一个ProgressBar ，允许从0.0到1.0的容易显示数字值。
forTableColumn() - Static method in class javafx.scene.control.cell. TextFieldTableCell
提供TextField ，允许在双击单元格时调用单元格内容，或调用TableView.edit(int, javafx.scene.control.TableColumn)时。
forTableColumn(ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxTableCell
创建一个ChoiceBox单元格工厂，用于TableColumn控件。
forTableColumn(ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxTableCell
创建ComboBox单元格工厂，用于TableColumn控件。
forTableColumn(TableColumn<S, Boolean>) - Static method in class javafx.scene.control.cell. CheckBoxTableCell
创建一个电池厂 ，用于TableColumn电池厂 。
forTableColumn(Callback<Integer, ObservableValue<Boolean>>) - Static method in class javafx.scene.control.cell. CheckBoxTableCell
创建一个电池厂 ，用于TableColumn电池厂 。
forTableColumn(Callback<Integer, ObservableValue<Boolean>>, boolean) - Static method in class javafx.scene.control.cell. CheckBoxTableCell
创建一个电池厂 ，用于TableColumn电池厂 。
forTableColumn(Callback<Integer, ObservableValue<Boolean>>, StringConverter<T>) - Static method in class javafx.scene.control.cell. CheckBoxTableCell
创建一个用于TableColumn电池厂的电池厂 。
forTableColumn(StringConverter<T>) - Static method in class javafx.scene.control.cell. TextFieldTableCell
提供TextField ，允许在单元格双击时或当调用TableView.edit(int, javafx.scene.control.TableColumn)时编辑单元格内容。
forTableColumn(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxTableCell
创建一个ChoiceBox单元格工厂，用于TableColumn控件。
forTableColumn(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxTableCell
创建ComboBox单元格工厂，用于TableColumn控件。
forTableColumn(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ChoiceBoxTableCell
创建一个ChoiceBox单元格工厂，用于TableColumn控件。
forTableColumn(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ComboBoxTableCell
创建ComboBox单元格工厂，用于TableColumn控件。
forTableColumn(T...) - Static method in class javafx.scene.control.cell. ChoiceBoxTableCell
创建一个ChoiceBox单元格工厂，用于TableColumn控件。
forTableColumn(T...) - Static method in class javafx.scene.control.cell. ComboBoxTableCell
创建ComboBox单元格工厂，用于TableColumn控件。
forTreeTableColumn() - Static method in class javafx.scene.control.cell. ProgressBarTreeTableCell
提供了一个ProgressBar ，允许从0.0到1.0轻松显示数字值。
forTreeTableColumn() - Static method in class javafx.scene.control.cell. TextFieldTreeTableCell
提供TextField ，允许双击单元格时，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时编辑单元格内容。
forTreeTableColumn(ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell
创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
forTreeTableColumn(ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxTreeTableCell
创建一个ComboBox单元格工厂，用于TreeTableColumn控件。
forTreeTableColumn(TreeTableColumn<S, Boolean>) - Static method in class javafx.scene.control.cell. CheckBoxTreeTableCell
创建一个在TreeTableColumn电池厂使用的电池厂 。
forTreeTableColumn(Callback<Integer, ObservableValue<Boolean>>) - Static method in class javafx.scene.control.cell. CheckBoxTreeTableCell
创建一个在TreeTableColumn电池厂使用的电池厂 。
forTreeTableColumn(Callback<Integer, ObservableValue<Boolean>>, boolean) - Static method in class javafx.scene.control.cell. CheckBoxTreeTableCell
创建一个电池厂 ，用于TreeTableColumn电池厂 。
forTreeTableColumn(Callback<Integer, ObservableValue<Boolean>>, StringConverter<T>) - Static method in class javafx.scene.control.cell. CheckBoxTreeTableCell
创建一个电池厂 ，用于TreeTableColumn电池厂 。
forTreeTableColumn(StringConverter<T>) - Static method in class javafx.scene.control.cell. TextFieldTreeTableCell
提供TextField ，使单元格内容的编辑在小区双击，或者当TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)被调用。
forTreeTableColumn(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell
创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
forTreeTableColumn(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxTreeTableCell
创建一个ComboBox单元格工厂用于TreeTableColumn控件。
forTreeTableColumn(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell
创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
forTreeTableColumn(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ComboBoxTreeTableCell
创建ComboBox单元格工厂用于TreeTableColumn控件。
forTreeTableColumn(T...) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell
创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
forTreeTableColumn(T...) - Static method in class javafx.scene.control.cell. ComboBoxTreeTableCell
创建一个ComboBox单元格工厂，用于TreeTableColumn控件。
forTreeView() - Static method in class javafx.scene.control.cell. CheckBoxTreeCell
创建在TreeView控件中使用的单元格工厂，尽管在TreeView中使用时有一个主要假设：此单元格工厂假定TreeView根和所有子项都是CheckBoxTreeItem的实例，而不是正常使用的默认值TreeItem 。
forTreeView() - Static method in class javafx.scene.control.cell. TextFieldTreeCell
提供TextField ，使单元格内容的编辑在小区双击，或者当TreeView.edit(javafx.scene.control.TreeItem)被调用。
forTreeView(ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeCell
创建一个ChoiceBox单元格工厂，用于TreeView控件。
forTreeView(ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxTreeCell
创建ComboBox单元格工厂，用于TreeView控件。
forTreeView(Callback<TreeItem<T>, ObservableValue<Boolean>>) - Static method in class javafx.scene.control.cell. CheckBoxTreeCell
创建一个用于TreeView控件的单元格工厂。
forTreeView(Callback<TreeItem<T>, ObservableValue<Boolean>>, StringConverter<TreeItem<T>>) - Static method in class javafx.scene.control.cell. CheckBoxTreeCell
创建一个用于TreeView控件的单元格工厂。
forTreeView(StringConverter<T>) - Static method in class javafx.scene.control.cell. TextFieldTreeCell
提供TextField ，允许双击单元格时，或调用TreeView.edit(javafx.scene.control.TreeItem)时编辑单元格内容。
forTreeView(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeCell
创建一个ChoiceBox单元格工厂，用于TreeView控件。
forTreeView(StringConverter<T>, ObservableList<T>) - Static method in class javafx.scene.control.cell. ComboBoxTreeCell
创建ComboBox单元格工厂，用于TreeView控件。
forTreeView(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeCell
创建一个ChoiceBox单元格工厂，用于TreeView控件。
forTreeView(StringConverter<T>, T...) - Static method in class javafx.scene.control.cell. ComboBoxTreeCell
创建ComboBox单元格工厂，用于TreeView控件。
forTreeView(T...) - Static method in class javafx.scene.control.cell. ChoiceBoxTreeCell
创建一个ChoiceBox单元格工厂，用于TreeView控件。
forTreeView(T...) - Static method in class javafx.scene.control.cell. ComboBoxTreeCell
创建一个ComboBox单元格工厂用于TreeView控件。
forward - Variable in exception org.omg.PortableInterceptor. ForwardRequest
将请求转发到的新对象。
forward() - Method in class javafx.scene.control. TextInputControl
向前移动插入位置。
Forward - Static variable in class javax.swing.text. Position.Bias
表示偏向模型中的下一个字符。
forward_reference - Variable in exception org.omg.PortableServer. ForwardRequest
forward_reference() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
如果 reply_status属性为 LOCATION_FORWARD ，则包含请求转发的对象。
FORWARD_TRAVERSAL_KEYS - Static variable in class java.awt. KeyboardFocusManager
正向聚焦遍历键的标识符。
forwardAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号逻辑移动一个位置的操作名称。
forwardBiasProperty() - Method in class javafx.scene.control.skin. TextInputControlSkin
插入偏倚的内容。 真正意味着对前进角色的偏见（true = leading / false = trailing）
forwardExecutionControl(ExecutionControl, ObjectInput, ObjectOutput) - Static method in class jdk.jshell.execution. Util
将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
forwardExecutionControlAndIO(ExecutionControl, InputStream, OutputStream, Map<String, Consumer<OutputStream>>, Map<String, Consumer<InputStream>>) - Static method in class jdk.jshell.execution. Util
将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
ForwardingFileObject< F extends FileObject> - Class in javax.tools
转发给定文件对象。
ForwardingFileObject(F) - Constructor for class javax.tools. ForwardingFileObject
创建一个新的ForwardingFileObject实例。
ForwardingJavaFileManager< M extends JavaFileManager> - Class in javax.tools
转发给给定的文件管理器。
ForwardingJavaFileManager(M) - Constructor for class javax.tools. ForwardingJavaFileManager
创建一个新的ForwardingJavaFileManager实例。
ForwardingJavaFileObject< F extends JavaFileObject> - Class in javax.tools
转发给定文件对象。
ForwardingJavaFileObject(F) - Constructor for class javax.tools. ForwardingJavaFileObject
创建一个新的ForwardingJavaFileObject实例。
ForwardRequest - Exception in org.omg.PortableInterceptor
org / omg / PortableInterceptor / ForwardRequest.java。
ForwardRequest - Exception in org.omg.PortableServer
org / omg / PortableServer / ForwardRequest.java。
ForwardRequest() - Constructor for exception org.omg.PortableInterceptor. ForwardRequest
ForwardRequest() - Constructor for exception org.omg.PortableServer. ForwardRequest
ForwardRequest(String, Object) - Constructor for exception org.omg.PortableInterceptor. ForwardRequest
ForwardRequest(String, Object) - Constructor for exception org.omg.PortableServer. ForwardRequest
ForwardRequest(Object) - Constructor for exception org.omg.PortableInterceptor. ForwardRequest
ForwardRequest(Object) - Constructor for exception org.omg.PortableServer. ForwardRequest
ForwardRequestHelper - Class in org.omg.PortableInterceptor
org / omg / PortableInterceptor / ForwardRequestHelper.java。
ForwardRequestHelper - Class in org.omg.PortableServer
org / omg / PortableServer / ForwardRequestHelper.java。
ForwardRequestHelper() - Constructor for class org.omg.PortableInterceptor. ForwardRequestHelper
ForwardRequestHelper() - Constructor for class org.omg.PortableServer. ForwardRequestHelper
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. BoxView
将给定的 DocumentEvent转发给需要通知模型更改的子视图。
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. TableView
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. View
向给定的 DocumentEvent转发需要通知模型更改的子视图。
forwardUpdateToView(View, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. View
向 DocumentEvent发送 DocumentEvent子视图。
foundType() - Method in exception java.lang.annotation. AnnotationTypeMismatchException
返回错误类型元素中找到的数据类型。
FRACTION - Static variable in class java.text. NumberFormat.Field
常数识别分数字段。
FRACTION_FIELD - Static variable in class java.text. NumberFormat
用于构造FieldPosition对象的字段常量。
fractionProperty() - Method in class javafx.scene.effect. Reflection
在反射中可见的输入分数。
fragmentHtmlFlavor - Static variable in class java.awt.datatransfer. DataFlavor
代表一个HTML标记。
frame - Variable in class javax.swing.plaf.basic. BasicDesktopIconUI
实例 JInternalFrame 。
frame - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
实例 JInternalFrame 。
frame - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI
帧
frame(int) - Method in interface com.sun.jdi. ThreadReference
返回线程当前调用堆栈中给定索引的StackFrame 。
Frame - Class in java.awt
A Frame是一个标题和边框的顶级窗口。
Frame() - Constructor for class java.awt. Frame
构造最初不可见的新的实例 Frame 。
Frame(GraphicsConfiguration) - Constructor for class java.awt. Frame
构造一个新的，初始看不见的 Frame与指定的 GraphicsConfiguration 。
Frame(String) - Constructor for class java.awt. Frame
构造一个新的，最初不可见的 Frame对象与指定的标题。
Frame(String, GraphicsConfiguration) - Constructor for class java.awt. Frame
构造一个新的，最初不可见的 Frame对象，具有指定的标题和一个 GraphicsConfiguration 。
FRAME - Static variable in class javax.accessibility. AccessibleRole
带有标题栏，边框，菜单栏等的顶级窗口
FRAME - Static variable in class javax.swing. JRootPane
用于windowDecorationStyle属性的常量。
FRAME - Static variable in class javax.swing.text.html. HTML.Tag
标记<frame>
FRAME_CONTENT_LAYER - Static variable in class javax.swing. JLayeredPane
定义框架内容层的便利对象。
FRAME_ICON_PROPERTY - Static variable in class javax.swing. JInternalFrame
绑定属性名称。
Frame.AccessibleAWTFrame - Class in java.awt
这个类实现 Frame类的辅助功能支持。
FRAMEBITS - Static variable in interface java.awt.image. ImageObserver
imageUpdate的infoflags参数中的此标志表示先前绘制的多帧图像的另一个完整帧现在可以再次绘制。
FRAMEBORDER - Static variable in class javax.swing.text.html. HTML.Attribute
属性“frameborder”
frameCount() - Method in interface com.sun.jdi. ThreadReference
返回线程当前调用堆栈中的堆栈帧数。
frameIcon - Variable in class javax.swing. JInternalFrame
该内部框架左上角显示的图标。
frameInit() - Method in class javax.swing. JFrame
由构造函数调用正确地初始化 JFrame 。
frameLength - Variable in class javax.sound.sampled. AudioInputStream
这个流的长度，采样帧。
FrameListener() - Constructor for class javax.swing.plaf.basic. BasicToolBarUI.FrameListener
framePos - Variable in class javax.sound.sampled. AudioInputStream
这个流中的当前位置，在采样帧中（从零开始）。
frameRate - Variable in class javax.sound.sampled. AudioFormat
每秒播放或录制的帧数，具有这种格式的声音。
frames() - Method in interface com.sun.jdi. ThreadReference
返回一个包含线程当前调用堆栈中的每个StackFrame的列表。
frames(int, int) - Method in interface com.sun.jdi. ThreadReference
从线程的当前调用堆栈返回一个包含StackFrame个镜像范围的列表。
FRAMESET - Static variable in class javax.swing.text.html. HTML.Tag
标签<frameset>
frameSize - Variable in class javax.sound.sampled. AudioFormat
具有此格式的声音每帧中的字节数。
frameSize - Variable in class javax.sound.sampled. AudioInputStream
每个帧的大小，以字节为单位。
FRANCE - Static variable in class java.util. Locale
对国家有用的常数。
free() - Method in interface java.sql. Array
此方法释放 Array对象并释放其所拥有的资源。
free() - Method in interface java.sql. Blob
该方法可以释放 Blob对象并释放其拥有的资源。
free() - Method in interface java.sql. Clob
此方法释放 Clob对象所持有的资源。
free() - Method in interface java.sql. SQLXML
此方法关闭此对象并释放其持有的资源。
free() - Method in class javax.sql.rowset.serial. SerialArray
此方法可以释放 SerialArray对象并释放其拥有的资源。
free() - Method in class javax.sql.rowset.serial. SerialBlob
此方法可以释放 SerialBlob对象并释放其拥有的资源。
free() - Method in class javax.sql.rowset.serial. SerialClob
该方法可以释放 SerialClob对象并释放它所拥有的资源。
FREE_MEM - Exception in org.omg.CORBA
ORB在尝试释放动态内存时失败，例如由于堆损坏或内存段被锁定而导致异常。
FREE_MEM() - Constructor for exception org.omg.CORBA. FREE_MEM
构造一个 FREE_MEM异常，默认次要代码为0，完成状态为COMPLETED_NO。
FREE_MEM(int, CompletionStatus) - Constructor for exception org.omg.CORBA. FREE_MEM
构造具有指定的次要代码和完成状态的 FREE_MEM异常。
FREE_MEM(String) - Constructor for exception org.omg.CORBA. FREE_MEM
构造具有指定详细消息的 FREE_MEM异常，次要代码为0和COMPLETED_NO的完成状态。
FREE_MEM(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. FREE_MEM
构造具有指定的详细消息，次要代码和完成状态的 FREE_MEM异常。
FREE_STANDING_PROP - Static variable in class javax.swing.plaf.metal. MetalScrollBarUI
物业 JScrollBar.isFreeStanding 。
freeMemory() - Method in class java.lang. Runtime
返回Java虚拟机中的可用内存量。
freeze() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
ECMA 15.2.39 - 冻结执行。
FRENCH - Static variable in class java.util. Locale
有用的语言常数
frequency(Collection<?>, Object) - Static method in class java.util. Collections
返回指定集合中与指定对象相等的元素数。
FRIDAY - java.time. DayOfWeek
星期五的单日例子。
FRIDAY - Static variable in class java.util. Calendar
价值 Calendar.DAY_OF_WEEK字段显示星期五。
from(long, TimeUnit) - Static method in class java.nio.file.attribute. FileTime
返回一个 FileTime表示给定的粒度单位的值。
from(File) - Static method in class java.lang. ProcessBuilder.Redirect
返回从指定文件读取的重定向。
from(Instant) - Static method in class java.nio.file.attribute. FileTime
返回一个 FileTime表示与所提供的 Instant对象相同的时间点值。
from(Instant) - Static method in class java.sql. Timestamp
从Instant对象获取一个Timestamp的实例。
from(Instant) - Static method in class java.util. Date
从 Instant对象获取一个 Date的实例。
from(TemporalAccessor) - Static method in interface java.time.chrono. ChronoLocalDate
从时间对象获取一个 ChronoLocalDate的实例。
from(TemporalAccessor) - Static method in interface java.time.chrono. ChronoLocalDateTime
从时间对象获取一个 ChronoLocalDateTime的实例。
from(TemporalAccessor) - Static method in interface java.time.chrono. Chronology
从时间对象获取一个 Chronology的实例。
from(TemporalAccessor) - Static method in interface java.time.chrono. ChronoZonedDateTime
从时间对象获取一个 ChronoZonedDateTime的实例。
from(TemporalAccessor) - Static method in class java.time.chrono. HijrahDate
从时间物体获得伊斯兰教Umm Al-Qura日历的 HijrahDate 。
from(TemporalAccessor) - Static method in class java.time.chrono. JapaneseDate
从时间对象获取 JapaneseDate 。
from(TemporalAccessor) - Static method in class java.time.chrono. MinguoDate
从时间对象获取 MinguoDate 。
from(TemporalAccessor) - Static method in class java.time.chrono. ThaiBuddhistDate
从时间对象获取 ThaiBuddhistDate 。
from(TemporalAccessor) - Static method in enum java.time. DayOfWeek
从时间对象获取一个 DayOfWeek的实例。
from(TemporalAccessor) - Static method in class java.time. Instant
从时间对象获取一个 Instant的实例。
from(TemporalAccessor) - Static method in class java.time. LocalDate
从时间对象获取一个 LocalDate的实例。
from(TemporalAccessor) - Static method in class java.time. LocalDateTime
从时间对象获取一个 LocalDateTime的实例。
from(TemporalAccessor) - Static method in class java.time. LocalTime
从时间对象获取一个 LocalTime的实例。
from(TemporalAccessor) - Static method in enum java.time. Month
从时间对象获取一个 Month的实例。
from(TemporalAccessor) - Static method in class java.time. MonthDay
从时间对象获取一个 MonthDay的实例。
from(TemporalAccessor) - Static method in class java.time. OffsetDateTime
从时间对象获取一个 OffsetDateTime的实例。
from(TemporalAccessor) - Static method in class java.time. OffsetTime
从时间对象获取一个 OffsetTime的实例。
from(TemporalAccessor) - Static method in class java.time. Year
从时间对象获取一个 Year的实例。
from(TemporalAccessor) - Static method in class java.time. YearMonth
从时间对象获取一个 YearMonth的实例。
from(TemporalAccessor) - Static method in class java.time. ZonedDateTime
从时间对象获取一个 ZonedDateTime的实例。
from(TemporalAccessor) - Static method in class java.time. ZoneId
从时间对象获取一个 ZoneId的实例。
from(TemporalAccessor) - Static method in class java.time. ZoneOffset
从时间对象获取一个 ZoneOffset的实例。
from(TemporalAmount) - Static method in class java.time. Duration
从时间量获取 Duration的实例。
from(TemporalAmount) - Static method in class java.time. Period
从时间量获取一个 Period的实例。
from(ZonedDateTime) - Static method in class java.util. GregorianCalendar
获取的实例 GregorianCalendar从一个默认的语言环境 ZonedDateTime对象。
from(CompositeData) - Static method in class com.sun.management. GarbageCollectionNotificationInfo
返回由给定的 CompositeData表示的 GarbageCollectionNotificationInfo对象。
from(CompositeData) - Static method in class com.sun.management. GcInfo
返回由给定的 CompositeData表示的 GcInfo对象。
from(CompositeData) - Static method in class com.sun.management. VMOption
返回由给定的 CompositeData表示的 VMOption对象。
from(CompositeData) - Static method in class java.lang.management. LockInfo
返回由给定的 CompositeData表示的 LockInfo对象。
from(CompositeData) - Static method in class java.lang.management. MemoryNotificationInfo
返回由给定的 CompositeData表示的 MemoryNotificationInfo对象。
from(CompositeData) - Static method in class java.lang.management. MemoryUsage
返回由给定的 CompositeData表示的 MemoryUsage对象。
from(CompositeData) - Static method in class java.lang.management. MonitorInfo
返回由给定的 CompositeData表示的 MonitorInfo对象。
from(CompositeData) - Static method in class java.lang.management. ThreadInfo
返回由给定的 CompositeData表示的 ThreadInfo对象。
from_any(Any) - Method in interface org.omg.CORBA. DynAny
已过时。
做一个 DynAny从对象 Any对象。
from_any(Any) - Method in class org.omg.DynamicAny. _DynAnyStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in class org.omg.DynamicAny. _DynArrayStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in class org.omg.DynamicAny. _DynEnumStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in class org.omg.DynamicAny. _DynFixedStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in class org.omg.DynamicAny. _DynSequenceStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in class org.omg.DynamicAny. _DynStructStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in class org.omg.DynamicAny. _DynUnionStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in class org.omg.DynamicAny. _DynValueStub
使用任何值中包含的值初始化与DynAny对象关联的值。
from_any(Any) - Method in interface org.omg.DynamicAny. DynAnyOperations
使用任何值中包含的值初始化与DynAny对象关联的值。
from_int(int) - Static method in class org.omg.CORBA. CompletionStatus
从给定的 int创建一个 CompletionStatus对象。
from_int(int) - Static method in class org.omg.CORBA. DefinitionKind
创建一个对应于给定代码的 DefinitionKind实例。
from_int(int) - Static method in class org.omg.CORBA. ParameterMode
from_int(int) - Static method in class org.omg.CORBA. SetOverrideType
将给定的 int转换为相应的 SetOverrideType实例。
from_int(int) - Static method in class org.omg.CORBA. TCKind
将给定的 int转换为相应的 TCKind实例。
from_int(int) - Static method in class org.omg.CosNaming. BindingType
from_int(int) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
from_int(int) - Static method in class org.omg.PortableServer. IdAssignmentPolicyValue
from_int(int) - Static method in class org.omg.PortableServer. IdUniquenessPolicyValue
from_int(int) - Static method in class org.omg.PortableServer. ImplicitActivationPolicyValue
from_int(int) - Static method in class org.omg.PortableServer. LifespanPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.POAManagerPackage. State
from_int(int) - Static method in class org.omg.PortableServer. RequestProcessingPolicyValue
from_int(int) - Static method in class org.omg.PortableServer. ServantRetentionPolicyValue
from_int(int) - Static method in class org.omg.PortableServer. ThreadPolicyValue
fromAngleProperty() - Method in class javafx.animation. RotateTransition
指定此 RotateTransition的起始角度值。
fromByteArray(byte[]) - Static method in interface jdk.incubator.http. HttpRequest.BodyProcessor
返回一个请求体处理器，其主体是给定的字节数组。
fromByteArray(byte[], int, int) - Static method in interface jdk.incubator.http. HttpRequest.BodyProcessor
返回一个请求体处理器，其身体是从指定的 offset开始的给定字节数组的内容为 length个字节。
fromByteArrays(Iterable<byte[]>) - Static method in interface jdk.incubator.http. HttpRequest.BodyProcessor
一个从 Iterable字节数组获取数据的请求体处理器。
fromCIEXYZ(float[]) - Method in class java.awt.color. ColorSpace
将CS_CIEXYZ转换颜色空间中假定的颜色值转换为此ColorSpace。
fromCIEXYZ(float[]) - Method in class java.awt.color. ICC_ColorSpace
将CS_CIEXYZ转换颜色空间中假定的颜色值转换为此ColorSpace。
fromFile(Path) - Static method in interface jdk.incubator.http. HttpRequest.BodyProcessor
从文件的内容获取数据的请求体处理器。
fromFXImage(Image, BufferedImage) - Static method in class javafx.embed.swing. SwingFXUtils
快照指定的JavaFX Image对象，并将其像素的副本存储到一个BufferedImage对象中，如果需要创建一个新对象。
fromIndex - Variable in class javax.swing.event. TableColumnModelEvent
从其移动或移除的列的索引
fromInputStream(Supplier<? extends InputStream>) - Static method in interface jdk.incubator.http. HttpRequest.BodyProcessor
一个请求体处理器，从InputStream读取其数据。
fromMethodDescriptorString(String, ClassLoader) - Static method in class java.lang.invoke. MethodType
查找或创建方法类型的实例，给定其字节码描述符的拼写。
fromMillis(long) - Static method in class java.nio.file.attribute. FileTime
返回表示给定值（以毫秒为单位）的 FileTime 。
fromRGB(float[]) - Method in class java.awt.color. ColorSpace
将假定为默认的CS_sRGB颜色空间的颜色值转换为此ColorSpace。
fromRGB(float[]) - Method in class java.awt.color. ICC_ColorSpace
将假定为默认的CS_sRGB颜色空间的颜色值转换为此ColorSpace。
fromString(String) - Static method in class java.nio.file.attribute. PosixFilePermissions
返回与给定的 String表示相对应的权限集。
fromString(String) - Static method in class java.util. UUID
创建 UUID如在所描述的字符串标准表示 UUID.toString()方法。
fromString(String) - Method in class javafx.scene.chart. NumberAxis.DefaultFormatter
将提供的字符串转换为由此转换器定义的数字。
fromString(String) - Method in class javafx.util.converter. BigDecimalStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. BigIntegerStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. BooleanStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. ByteStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. CharacterStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. DateTimeStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. DefaultStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. DoubleStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. FloatStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. FormatStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. IntegerStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. LocalDateStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. LocalDateTimeStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. LocalTimeStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. LongStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. NumberStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util.converter. ShortStringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Method in class javafx.util. StringConverter
将提供的字符串转换为由特定转换器定义的对象。
fromString(String) - Static method in interface jdk.incubator.http. HttpRequest.BodyProcessor
返回一个请求体处理器，其身体是给定的 String ，使用 UTF_8字符集进行转换。
fromString(String, Charset) - Static method in interface jdk.incubator.http. HttpRequest.BodyProcessor
返回一个请求体处理器，其身体是给定的 String ，使用给定的字符集进行转换。
fromValueProperty() - Method in class javafx.animation. FadeTransition
指定此 FadeTransition的起始不透明度值。
fromValueProperty() - Method in class javafx.animation. FillTransition
指定此 FillTransition的起始颜色值。
fromValueProperty() - Method in class javafx.animation. StrokeTransition
指定此 StrokeTransition的起始颜色值。
fromXProperty() - Method in class javafx.animation. ScaleTransition
指定此 ScaleTransition的起始X比例值。
fromXProperty() - Method in class javafx.animation. TranslateTransition
指定此 TranslateTransition的起始X坐标值。
fromYProperty() - Method in class javafx.animation. ScaleTransition
指定此 ScaleTransition的起始Y比例值。
fromYProperty() - Method in class javafx.animation. TranslateTransition
指定此 TranslateTransition的起始Y坐标值。
fromZProperty() - Method in class javafx.animation. ScaleTransition
指定此 ScaleTransition的起始Z刻度值。
fromZProperty() - Method in class javafx.animation. TranslateTransition
指定此 TranslateTransition的起始Z坐标值。
FRONT - javafx.scene.shape. CullFace
剔除所有面向前的多边形。
FTP - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported
文件传输协议（FTP）。
FUCHSIA - Static variable in class javafx.scene.paint. Color
颜色紫红色，RGB值为＃FF00FF
FULL - java.time.format. FormatStyle
全文风格，最细节。
FULL - java.time.format. TextStyle
全文，通常是完整的描述。
FULL - Static variable in class java.text. DateFormat
恒定的全风格图案。
FULL - Static variable in class javafx.scene.layout. BorderWidths
一组宽度，表示每边100％。
FULL_DECOMPOSITION - Static variable in class java.text. Collator
分解模式值。
FULL_FLUSH - Static variable in class java.util.zip. Deflater
压缩冲洗模式用于清除所有待处理输出并重置放气器。
FULL_JOIN - Static variable in interface javax.sql.rowset. JoinRowSet
ANSI-style JOIN提供完整的JOIN。
FULL_STANDALONE - java.time.format. TextStyle
全文为独立使用，通常为完整描述。
FULL_WIDTH - javafx.scene.input. KeyCode
全角字符的常量功能键。
fullClassName() - Method in interface jdk.jshell. SourceCodeAnalysis.SnippetWrapper
返回 SourceCodeAnalysis.SnippetWrapper.wrapped()类的完全限定类名。
fullFence() - Static method in class java.lang.invoke. VarHandle
确保围墙之前的装载和商店不会在围栏后面加载和存储重新排序。
fullname() - Method in class jdk.jshell. ImportSnippet
进口的合格名称。
fullScreenExitHintProperty() - Method in class javafx.stage. Stage
fullScreenExitKeyProperty() - Method in class javafx.stage. Stage
获取全屏幕退出组合键的属性。
fullScreenProperty() - Method in class javafx.stage. Stage
指定这个 Stage应该是一个全屏，未装饰的窗口。
FULLWIDTH_DIGITS - Static variable in class java.awt.im. InputSubset
Unicode宽度和全宽形式字符块中包含的全宽数字的常数。
FULLWIDTH_LATIN - Static variable in class java.awt.im. InputSubset
Unicode宽度和全宽形式字符块的全宽ASCII变体子集的常数。
Function< T, R> - Interface in java.util.function
表示接受一个参数并产生结果的函数。
FUNCTION - jdk.nashorn.api.tree. Tree.Kind
用于FunctionDeclarationTree的实例。
FUNCTION_EXPRESSION - jdk.nashorn.api.tree. Tree.Kind
用于FunctionExpressionTree的实例。
FUNCTION_INVOCATION - jdk.nashorn.api.tree. Tree.Kind
用于FunctionCallTree的实例。
FunctionalInterface - Annotation Type in java.lang
用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
FunctionCallTree - Interface in jdk.nashorn.api.tree
用于函数调用表达式的树节点。
functionColumnIn - Static variable in interface java.sql. DatabaseMetaData
表示参数或列是IN参数。
functionColumnInOut - Static variable in interface java.sql. DatabaseMetaData
表示参数或列是INOUT参数。
functionColumnOut - Static variable in interface java.sql. DatabaseMetaData
表示参数或列是OUT参数。
functionColumnResult - Static variable in interface java.sql. DatabaseMetaData
表示参数或列是结果集中的列。
functionColumnUnknown - Static variable in interface java.sql. DatabaseMetaData
表示参数或列的类型未知。
FunctionDeclarationTree - Interface in jdk.nashorn.api.tree
一个树节点为 function declaration 。
FunctionExpressionTree - Interface in jdk.nashorn.api.tree
一个树节点为 function expressions，其中包括 arrow functions 。
functionNoNulls - Static variable in interface java.sql. DatabaseMetaData
表示不允许 NULL值。
functionNoTable - Static variable in interface java.sql. DatabaseMetaData
表示该函数不返回表。
functionNullable - Static variable in interface java.sql. DatabaseMetaData
表示允许 NULL值。
functionNullableUnknown - Static variable in interface java.sql. DatabaseMetaData
表示是否允许 NULL值是未知的。
functionResultUnknown - Static variable in interface java.sql. DatabaseMetaData
表示不知道函数是返回结果还是表。
functionReturn - Static variable in interface java.sql. DatabaseMetaData
表示参数或列是返回值。
functionReturnsTable - Static variable in interface java.sql. DatabaseMetaData
表示该函数返回一个表。
FUSER_OVER_TEMP - Static variable in class javax.print.attribute.standard. PrinterStateReason
定影温度高于正常值。
FUSER_UNDER_TEMP - Static variable in class javax.print.attribute.standard. PrinterStateReason
定影器温度低于正常值。
Future< V> - Interface in java.util.concurrent
A Future表示异步计算的结果。
FutureTask< V> - Class in java.util.concurrent
可取消的异步计算。
FutureTask(Runnable, V) - Constructor for class java.util.concurrent. FutureTask
创建一个 FutureTask ，它将在运行时执行给定的 Runnable ，并且安排 get将在成功完成后返回给定的结果。
FutureTask(Callable<V>) - Constructor for class java.util.concurrent. FutureTask
创建一个 FutureTask ，它将在运行时执行给定的 Callable 。
FX_CONSTANT_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader
标签名为'fx：constant'。
FX_CONTROLLER_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader
根的fx：controller属性的名称。
FX_FACTORY_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader
“fx：factory”属性的名称。
FX_ID_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader
fx：id属性的名称。
FX_NAMESPACE_PREFIX - Static variable in class javafx.fxml. FXMLLoader
'fx'命名空间的前缀。
FX_NAMESPACE_VERSION - Static variable in class javafx.fxml. FXMLLoader
包含当前的fx namepsace版本。
FX_VALUE_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader
fx：value属性的名称。
FXCollections - Class in javafx.collections
由静态方法组成的实用程序类，它们是java.util.Collections方法的1：1。
FXML - javafx.application. ConditionalFeature
表示XML库存在于JRE中，FXML API在平台上可用。
FXML - Annotation Type in javafx.fxml
将字段或方法标记为可用于标记的注释。
FXMLLoader - Class in javafx.fxml
从XML文档加载对象层次结构。
FXMLLoader() - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXMLLoader(URL) - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXMLLoader(URL, ResourceBundle) - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXMLLoader(URL, ResourceBundle, BuilderFactory) - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXMLLoader(URL, ResourceBundle, BuilderFactory, Callback<Class<?>, Object>) - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXMLLoader(URL, ResourceBundle, BuilderFactory, Callback<Class<?>, Object>, Charset) - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXMLLoader(URL, ResourceBundle, BuilderFactory, Callback<Class<?>, Object>, Charset, LinkedList<FXMLLoader>) - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXMLLoader(Charset) - Constructor for class javafx.fxml. FXMLLoader
创建一个新的FXMLLoader实例。
FXPermission - Class in javafx.util
此类用于JavaFX权限。
FXPermission(String) - Constructor for class javafx.util. FXPermission
创建一个新的 FXPermission与指定的名称。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


G-Index (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

SEARCH:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
G

G - javafx.scene.input. KeyCode

常数为 G键。

GAIN_CONTROL_HIGH_GAIN_DOWN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“GainControl”标签一起使用的值。

GAIN_CONTROL_HIGH_GAIN_UP - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“GainControl”标签一起使用的值。

GAIN_CONTROL_LOW_GAIN_DOWN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“GainControl”标签一起使用的值。

GAIN_CONTROL_LOW_GAIN_UP - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“GainControl”标签一起使用的值。

GAIN_CONTROL_NONE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“GainControl”标签一起使用的值。

gainProperty() - Method in class javafx.scene.media. EqualizerBand

应用于该频带的频率的增益。

GAINSBORO - Static variable in class javafx.scene.paint. Color

RGB值为#DCDCDC的彩色增益

GAME_A - javafx.scene.input. KeyCode

常数为 Game A键。

GAME_B - javafx.scene.input. KeyCode

常数为 Game B键。

GAME_C - javafx.scene.input. KeyCode

常数为 Game C键。

GAME_D - javafx.scene.input. KeyCode

常数为 Game D键。

GAP_TOKEN - Static variable in exception org.ietf.jgss. GSSException

未收到预期的每消息令牌。

GapContent - Class in javax.swing.text

AbstractDocument.Content接口的实现使用与emacs使用的类似的间隙缓冲区来实现。

GapContent() - Constructor for class javax.swing.text. GapContent

创建一个新的GapContent对象。

GapContent(int) - Constructor for class javax.swing.text. GapContent

创建一个新的GapContent对象，指定初始大小。

gapStartAndEndProperty() - Method in class javafx.scene.chart. CategoryAxis

如果这是真的，那么刻度之间的一半空格留在开始和结束

GARBAGE_COLLECTION_NOTIFICATION - Static variable in class com.sun.management. GarbageCollectionNotificationInfo

通知类型表示Java虚拟机已完成垃圾回收循环。

GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE - Static variable in class java.lang.management. ManagementFactory

ObjectName的域名和类型密钥属性为GarbageCollectorMXBean 。

GarbageCollectionNotificationInfo - Class in com.sun.management

有关垃圾收集的信息

GarbageCollectionNotificationInfo(String, String, String, GcInfo) - Constructor for class com.sun.management. GarbageCollectionNotificationInfo

构造一个 GarbageCollectionNotificationInfo对象。

GarbageCollectorMXBean - Interface in com.sun.management

用于垃圾收集器的特定于平台的管理界面，用于循环执行集合。

GarbageCollectorMXBean - Interface in java.lang.management

用于Java虚拟机垃圾收集的管理界面。

GatheringByteChannel - Interface in java.nio.channels

可以从缓冲区序列中写入字节的通道。

GaugeMonitor - Class in javax.management.monitor

定义一个监视器MBean，用于观察仪表属性的值。

GaugeMonitor() - Constructor for class javax.management.monitor. GaugeMonitor

默认构造函数。

GaugeMonitorMBean - Interface in javax.management.monitor

暴露量规监视器MBean的远程管理界面。

GAUSSIAN - javafx.scene.effect. BlurType

高斯模糊内核用于以非常高的质量模糊阴影。

GaussianBlur - Class in javafx.scene.effect

使用高斯卷积核的模糊效果，具有可配置的半径。

GaussianBlur() - Constructor for class javafx.scene.effect. GaussianBlur

用默认参数创建一个新的GaussianBlur实例。

GaussianBlur(double) - Constructor for class javafx.scene.effect. GaussianBlur

用指定的半径创建一个新的GaussianBlur实例。

gc() - Method in interface java.lang.management. MemoryMXBean

运行垃圾回收器。

gc() - Method in class java.lang. Runtime

运行垃圾回收器。

gc() - Static method in class java.lang. System

运行垃圾回收器。

gcd(BigInteger) - Method in class java.math. BigInteger

返回一个BigInteger，其值是 abs(this)和 abs(val) 。

GcInfo - Class in com.sun.management

垃圾收集信息。

GCMParameterSpec - Class in javax.crypto.spec

指定使用伽罗瓦/计数器模式（GCM）模式的Cipher所需的一组参数。

GCMParameterSpec(int, byte[]) - Constructor for class javax.crypto.spec. GCMParameterSpec

使用指定的认证标签位长度和IV缓冲区构造GCMParameterSpec。

GCMParameterSpec(int, byte[], int, int) - Constructor for class javax.crypto.spec. GCMParameterSpec

使用指定的身份验证标记位长度和指定缓冲区的子集作为IV构造一个GCMParameterSpec对象。

GDAY - Static variable in class javax.xml.datatype. DatatypeConstants

W3C XML Schema 1.0数据类型 gDay完全限定名称。

GE - Static variable in class javax.management. Query

代表 Query.geq(javax.management.ValueExp, javax.management.ValueExp)查询的代码。

GENERAL - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于GENERAL

GENERAL_PUNCTUATION - Static variable in class java.lang. Character.UnicodeBlock

常规为“一般标点符号”Unicode字符块。

GeneralPath - Class in java.awt.geom

GeneralPath类代表由直线构成的几何路径，以及二次和立方（Bézier）曲线。

GeneralPath() - Constructor for class java.awt.geom. GeneralPath

构造一个新的空单精度 GeneralPath对象，其默认缠绕规则为 Path2D.WIND_NON_ZERO 。

GeneralPath(int) - Constructor for class java.awt.geom. GeneralPath

使用指定的绕组规则构造一个新的 GeneralPath对象，以控制需要定义路径内部的操作。

GeneralPath(int, int) - Constructor for class java.awt.geom. GeneralPath

构造一个新的 GeneralPath对象，其中指定的绕组规则和指定的初始容量来存储路径坐标。

GeneralPath(Shape) - Constructor for class java.awt.geom. GeneralPath

构造一个新GeneralPath从任意对象Shape对象。

GeneralSecurityException - Exception in java.security

GeneralSecurityException类是一种通用安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。

GeneralSecurityException() - Constructor for exception java.security. GeneralSecurityException

构造一个没有详细消息的GeneralSecurityException。

GeneralSecurityException(String) - Constructor for exception java.security. GeneralSecurityException

构造具有指定详细消息的GeneralSecurityException。

GeneralSecurityException(String, Throwable) - Constructor for exception java.security. GeneralSecurityException

创建一个具有指定的详细消息和原因的 GeneralSecurityException 。

GeneralSecurityException(Throwable) - Constructor for exception java.security. GeneralSecurityException

创建 GeneralSecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

generate() - Method in class com.sun.source.util. JavacTask

生成代码。

generate(DoubleSupplier) - Static method in interface java.util.stream. DoubleStream

返回无限顺序无序流，其中每个元素由提供的 DoubleSupplier生成。

generate(IntSupplier) - Static method in interface java.util.stream. IntStream

返回无限顺序无序流，其中每个元素由提供的 IntSupplier生成。

generate(LongSupplier) - Static method in interface java.util.stream. LongStream

返回无限顺序无序流，其中每个元素由提供的 LongSupplier生成。

generate(Supplier<? extends T>) - Static method in interface java.util.stream. Stream

返回无限顺序无序流，其中每个元素由提供的 Supplier生成。

generate(ExecutionEnv, String) - Static method in interface jdk.jshell.spi. ExecutionControl

搜索提供者，然后创建并返回 ExecutionControl实例。

generate(ExecutionEnv, String, Map<String, String>) - Static method in interface jdk.jshell.spi. ExecutionControl

搜索提供者，然后创建并返回 ExecutionControl实例。

generate(ExecutionEnv, Map<String, String>) - Method in class jdk.jshell.execution. FailOverExecutionControlProvider

创建并返回一个本地执行的 ExecutionControl实例。

generate(ExecutionEnv, Map<String, String>) - Method in class jdk.jshell.execution. JdiExecutionControlProvider

generate(ExecutionEnv, Map<String, String>) - Method in class jdk.jshell.execution. LocalExecutionControlProvider

创建并返回本地执行的 ExecutionControl实例。

generate(ExecutionEnv, Map<String, String>) - Method in interface jdk.jshell.spi. ExecutionControlProvider

创建并返回 ExecutionControl实例。

GENERATE - com.sun.source.util. TaskEvent.Kind

对于正在生成类文件的事件。

generateCertificate(InputStream) - Method in class java.security.cert. CertificateFactory

生成证书对象并使用从输入流 inStream读取的数据进行初始化。

generateCertificates(InputStream) - Method in class java.security.cert. CertificateFactory

返回从给定的输入流 inStream读取的证书的（可能为空的）集合视图。

generateCertPath(InputStream) - Method in class java.security.cert. CertificateFactory

生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。

generateCertPath(InputStream, String) - Method in class java.security.cert. CertificateFactory

生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。

generateCertPath(List<? extends Certificate>) - Method in class java.security.cert. CertificateFactory

生成一个 CertPath对象，并用 List的 Certificate初始化。

generateCRL(InputStream) - Method in class java.security.cert. CertificateFactory

生成证书撤销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。

generateCRLs(InputStream) - Method in class java.security.cert. CertificateFactory

返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。

Generated - Annotation Type in javax.annotation

生成的注释用于标记已生成的源代码。

Generated - Annotation Type in javax.annotation.processing

生成的注释用于标记已生成的源代码。

generatedKeyAlwaysReturned() - Method in interface java.sql. DatabaseMetaData

检索如果为自动生成的密钥列指定的列名称或索引有效并且语句成功，将始终返回生成的密钥。

generateKey() - Method in class javax.crypto. KeyGenerator

生成一个秘密密钥。

generateKeyPair() - Method in class java.security. KeyPairGenerator

生成一个密钥对。

generateKeyPair() - Method in class java.security. KeyPairGeneratorSpi

生成一个密钥对。

generateParameters() - Method in class java.security. AlgorithmParameterGenerator

生成参数。

generatePrivate(KeySpec) - Method in class java.security. KeyFactory

从提供的密钥规范（密钥材料）生成私钥对象。

generatePublic(KeySpec) - Method in class java.security. KeyFactory

从提供的密钥规范（密钥材料）生成公钥对象。

generateSchema(SchemaOutputResolver) - Method in class javax.xml.bind. JAXBContext

生成此上下文的模式文档。

generateSecret() - Method in class javax.crypto. KeyAgreement

生成共享密钥并将其返回到新的缓冲区。

generateSecret(byte[], int) - Method in class javax.crypto. KeyAgreement

生成共享密钥，并将其放入缓冲区 sharedSecret （从 offset开始）。

generateSecret(String) - Method in class javax.crypto. KeyAgreement

创建共享密钥，并将其作为指定算法的 SecretKey对象返回。

generateSecret(KeySpec) - Method in class javax.crypto. SecretKeyFactory

根据提供的密钥规范（密钥材料）生成一个 SecretKey对象。

generateSeed(int) - Method in class java.security. SecureRandom

返回给定数量的种子字节，使用该类用于种子本身的种子生成算法计算。

generateSignedData(ContentSignerParameters, boolean, boolean) - Method in class com.sun.jarsigner. ContentSigner

已过时。

生成PKCS＃7签名的数据消息。

generic() - Method in class java.lang.invoke. MethodType

将所有类型（引用和原始）转换为 Object 。

GENERIC_FAILURE - Static variable in class java.util.logging. ErrorManager

GENERIC_FAILURE用于不符合其他类别的故障。

GenericArrayType - Interface in java.lang.reflect

GenericArrayType表示组件类型是参数化类型或类型变量的数组类型。

GenericDeclaration - Interface in java.lang.reflect

声明类型变量的所有实体的通用接口。

genericMethodType(int) - Static method in class java.lang.invoke. MethodType

查找或创建一个方法类型，其组件全部为 Object 。

genericMethodType(int, boolean) - Static method in class java.lang.invoke. MethodType

查找或创建一个方法类型，其组件为 Object并具有可选的尾部 Object[]数组。

genericSignature() - Method in interface com.sun.jdi. LocalVariable

获取此变量的通用签名（如果有）。

genericSignature() - Method in interface com.sun.jdi. ReferenceType

获取此类型的通用签名（如果有）。

genericSignature() - Method in interface com.sun.jdi. TypeComponent

获取此类型组件的通用签名（如果有）。

GenericSignatureFormatError - Error in java.lang.reflect

当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。

GenericSignatureFormatError() - Constructor for error java.lang.reflect. GenericSignatureFormatError

构造新的 GenericSignatureFormatError 。

GenericSignatureFormatError(String) - Constructor for error java.lang.reflect. GenericSignatureFormatError

构造一个新的 GenericSignatureFormatError与指定的消息。

genExemptionBlob() - Method in class javax.crypto. ExemptionMechanism

生成豁免机制密钥blob。

genExemptionBlob(byte[]) - Method in class javax.crypto. ExemptionMechanism

生成豁免机制密钥blob，并将结果存储在 output缓冲区中。

genExemptionBlob(byte[], int) - Method in class javax.crypto. ExemptionMechanism

生成豁免机制键blob，并将结果存储在 output缓冲区中，从 outputOffset开始。

genKeyPair() - Method in class java.security. KeyPairGenerator

生成一个密钥对。

GEOMETRIC_SHAPES - Static variable in class java.lang. Character.UnicodeBlock

“几何形状”Unicode字符块的常量。

GEOMETRIC_SHAPES_EXTENDED - Static variable in class java.lang. Character.UnicodeBlock

“几何形状扩展”Unicode字符块的常数。

GEORGIAN - java.lang. Character.UnicodeScript

Unicode脚本“格鲁吉亚”。

GEORGIAN - Static variable in class java.lang. Character.UnicodeBlock

“格式”Unicode字符块的常数。

GEORGIAN_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock

“格鲁吉亚补编”Unicode字符块的常数。

GeoTIFFTagSet - Class in javax.imageio.plugins.tiff

代表GeoTIFF IFD中找到的标签的类。

geq(ValueExp, ValueExp) - Static method in class javax.management. Query

返回一个在两个值上表示“大于或等于”约束的查询表达式。

GERMAN - Static variable in class java.util. Locale

有用的语言常数

GERMANY - Static variable in class java.util. Locale

对国家有用的常数。

GestureEvent - Class in javafx.scene.input

表示手势输入的事件。

GestureEvent(Object, EventTarget, EventType<? extends GestureEvent>) - Constructor for class javafx.scene.input. GestureEvent

已过时。
不要使用这个构造函数。 构造空事件。

GestureEvent(Object, EventTarget, EventType<? extends GestureEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, PickResult) - Constructor for class javafx.scene.input. GestureEvent

构建新的GestureEvent事件。

GestureEvent(EventType<? extends GestureEvent>) - Constructor for class javafx.scene.input. GestureEvent

已过时。
不要使用这个构造函数。 构造空事件。

GestureEvent(EventType<? extends GestureEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, PickResult) - Constructor for class javafx.scene.input. GestureEvent

构造新的GestureEvent事件，具有空源和目标

get() - Method in class java.lang.ref. PhantomReference

返回此引用对象的指示。

get() - Method in class java.lang.ref. Reference

返回此引用对象的指示。

get() - Method in class java.lang.ref. SoftReference

返回此引用对象的指示。

get() - Method in class java.lang. ThreadLocal

返回当前线程的此线程局部变量的副本中的值。

get() - Method in class java.nio. ByteBuffer

相对 获取方法。

get() - Method in class java.nio. CharBuffer

相对 获取方法。

get() - Method in class java.nio. DoubleBuffer

相对 获取方法。

get() - Method in class java.nio. FloatBuffer

相对 获取方法。

get() - Method in class java.nio. IntBuffer

相对 获取方法。

get() - Method in class java.nio. LongBuffer

相对 获取方法。

get() - Method in class java.nio. ShortBuffer

相对 获取方法。

get() - Method in class java.rmi. MarshalledObject

返回包含的编组对象的新副本。

get() - Method in class java.util.concurrent.atomic. AtomicBoolean

返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。

get() - Method in class java.util.concurrent.atomic. AtomicInteger

返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。

get() - Method in class java.util.concurrent.atomic. AtomicLong

返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。

get() - Method in class java.util.concurrent.atomic. AtomicReference

返回当前值，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。

get() - Method in class java.util.concurrent.atomic. DoubleAccumulator

返回当前值。

get() - Method in class java.util.concurrent.atomic. LongAccumulator

返回当前值。

get() - Method in class java.util.concurrent. CompletableFuture

等待这个未来完成的必要，然后返回结果。

get() - Method in class java.util.concurrent. ForkJoinTask

等待计算完成，然后检索其结果。

get() - Method in interface java.util.concurrent. Future

等待计算完成，然后检索其结果。

get() - Method in class java.util.concurrent. FutureTask

get() - Method in interface java.util.function. Supplier

获得结果。

get() - Method in class java.util. Optional

如果存在值，返回值，否则抛出 NoSuchElementException 。

get() - Method in interface java.util. ServiceLoader.Provider

返回提供者的一个实例。

get() - Method in class javafx.beans.binding. BooleanBinding

返回 BooleanBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. DoubleBinding

返回 DoubleBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. FloatBinding

返回 FloatBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. IntegerBinding

返回 IntegerBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. ListBinding

返回结果 ListBinding.computeValue() 。

get() - Method in class javafx.beans.binding. LongBinding

返回 LongBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. MapBinding

返回 MapBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. ObjectBinding

返回 ObjectBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. SetBinding

返回 SetBinding.computeValue()的结果。

get() - Method in class javafx.beans.binding. StringBinding

返回 StringBinding.computeValue()的结果。

get() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty

获取包装的值。

get() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty

获取包装的值。

get() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty

获取包装的值。

get() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty

获取包装的值。

get() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty

获取包装的值。

get() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty

获取包装的值。

get() - Method in class javafx.beans.property.adapter. JavaBeanStringProperty

获取包装的值。

get() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanProperty

返回此 ObservableBooleanValue的当前值。

get() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoubleProperty

返回此 ObservableDoubleValue的当前值。

get() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatProperty

返回此 ObservableFloatValue的当前值。

get() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerProperty

返回此 ObservableIntegerValue的当前值。

get() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongProperty

返回此 ObservableLongValue的当前值。

get() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectProperty

返回此 ObservableObjectValue<T>的当前值。

get() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringProperty

返回此 ObservableObjectValue<T>的当前值。

get() - Method in class javafx.beans.property. BooleanPropertyBase

获取包装的值。

get() - Method in class javafx.beans.property. DoublePropertyBase

获取包装的值。

get() - Method in class javafx.beans.property. FloatPropertyBase

获取包装的值。

get() - Method in class javafx.beans.property. IntegerPropertyBase

获取包装的值。

get() - Method in class javafx.beans.property. ListPropertyBase

get() - Method in class javafx.beans.property. LongPropertyBase

获取包装的值。

get() - Method in class javafx.beans.property. MapPropertyBase

get() - Method in class javafx.beans.property. ObjectPropertyBase

获取包装的值。

get() - Method in class javafx.beans.property. SetPropertyBase

get() - Method in class javafx.beans.property. StringPropertyBase

获取包装的值。

get() - Method in interface javafx.beans.value. ObservableBooleanValue

返回此 ObservableBooleanValue的当前值。

get() - Method in interface javafx.beans.value. ObservableDoubleValue

返回此 ObservableDoubleValue的当前值。

get() - Method in interface javafx.beans.value. ObservableFloatValue

返回此 ObservableFloatValue的当前值。

get() - Method in interface javafx.beans.value. ObservableIntegerValue

返回此 ObservableIntegerValue的当前值。

get() - Method in interface javafx.beans.value. ObservableLongValue

返回此 ObservableLongValue的当前值。

get() - Method in interface javafx.beans.value. ObservableObjectValue

返回此 ObservableObjectValue<T>的当前值。

get() - Method in interface javafx.beans.value. WritableBooleanValue

获取包装的值。

get() - Method in interface javafx.beans.value. WritableDoubleValue

获取包装的值。

get() - Method in interface javafx.beans.value. WritableFloatValue

获取包装的值。

get() - Method in interface javafx.beans.value. WritableIntegerValue

获取包装的值。

get() - Method in interface javafx.beans.value. WritableLongValue

获取包装的值。

get() - Method in interface javafx.beans.value. WritableObjectValue

获取包装的值。

get() - Method in interface javax.naming.directory. Attribute

检索此属性值之一。

get() - Method in class javax.naming.directory. BasicAttribute

检索此属性值之一。

get() - Method in class javax.swing. SwingWorker

等待计算完成，然后检索其结果。

get(boolean[]) - Method in class java.util.concurrent.atomic. AtomicMarkableReference

返回引用和标记的当前值。

get(byte[]) - Method in class java.nio. ByteBuffer

相对批量 获取方法。

get(byte[], int, int) - Method in class java.nio. ByteBuffer

相对批量 获取方法。

get(char[]) - Method in class java.nio. CharBuffer

相对批量 获取方法。

get(char[], int, int) - Method in class java.nio. CharBuffer

相对批量 获取方法。

get(double[]) - Method in class java.nio. DoubleBuffer

相对批量 获取方法。

get(double[], int, int) - Method in class java.nio. DoubleBuffer

相对批量 获取方法。

get(float[]) - Method in class java.nio. FloatBuffer

相对批量 获取方法。

get(float[], int, int) - Method in class java.nio. FloatBuffer

相对批量 获取方法。

get(int) - Method in class java.nio. ByteBuffer

绝对 获取方法。

get(int) - Method in class java.nio. CharBuffer

绝对 获取方法。

get(int) - Method in class java.nio. DoubleBuffer

绝对 获取方法。

get(int) - Method in class java.nio. FloatBuffer

绝对 获取方法。

get(int) - Method in class java.nio. IntBuffer

绝对 获取方法。

get(int) - Method in class java.nio. LongBuffer

绝对 获取方法。

get(int) - Method in class java.nio. ShortBuffer

绝对 获取方法。

get(int) - Method in class java.util. AbstractList

返回此列表中指定位置的元素。

get(int) - Method in class java.util. AbstractSequentialList

返回此列表中指定位置的元素。

get(int) - Method in class java.util. ArrayList

返回此列表中指定位置的元素。

get(int) - Method in class java.util. BitSet

返回具有指定索引的位的值。

get(int) - Method in class java.util. Calendar

返回给定日历字段的值。

get(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

返回索引号为 i的元素的当前值，具有由 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。

get(int) - Method in class java.util.concurrent.atomic. AtomicLongArray

返回索引号为 i的元素的当前值，由 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。

get(int) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

返回索引号为 i的元素的当前值，具有由 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。

get(int) - Method in class java.util.concurrent. CopyOnWriteArrayList

返回此列表中指定位置的元素。

get(int) - Method in class java.util. LinkedList

返回此列表中指定位置的元素。

get(int) - Method in interface java.util. List

返回此列表中指定位置的元素。

get(int) - Method in class java.util. Vector

返回此向量中指定位置的元素。

get(int) - Method in class javafx.beans.binding. ListExpression

get(int) - Method in class javafx.collections. ModifiableObservableListBase

get(int) - Method in interface javafx.collections. ObservableFloatArray

获取数组的单个值。

get(int) - Method in interface javafx.collections. ObservableIntegerArray

获取数组的单个值。

get(int) - Method in class javafx.collections.transformation. FilteredList

返回此列表中指定位置的元素。

get(int) - Method in class javafx.collections.transformation. SortedList

返回此列表中指定位置的元素。

get(int) - Method in class javax.naming. CompositeName

检索此复合名称的组件。

get(int) - Method in class javax.naming. CompoundName

检索此化合物名称的组件。

get(int) - Method in interface javax.naming.directory. Attribute

从有序的属性值列表中检索属性值。

get(int) - Method in class javax.naming.directory. BasicAttribute

get(int) - Method in class javax.naming.ldap. LdapName

以此字符串形式检索此LDAP名称的组件。

get(int) - Method in interface javax.naming. Name

检索此名称的组件。

get(int) - Method in class javax.naming. Reference

检索索引posn上的地址。

get(int) - Method in class javax.sound.midi. Track

在指定的索引处获取事件。

get(int) - Method in class javax.swing. DefaultListModel

返回此列表中指定位置的元素。

get(int) - Method in interface javax.xml.xpath. XPathNodes

返回指定位置的节点

get(int[]) - Method in class java.nio. IntBuffer

相对批量 获取方法。

get(int[]) - Method in class java.util.concurrent.atomic. AtomicStampedReference

返回引用和戳记的当前值。

get(int[], int, int) - Method in class java.nio. IntBuffer

相对批量 获取方法。

get(int, int) - Method in class java.util. BitSet

返回一个新的 BitSet由 BitSet从 fromIndex （含）组成，由 toIndex （排他）组成。

get(int, int) - Method in interface javafx.scene.control. TextInputControl.Content

检索内容的一个子集。

get(long[]) - Method in class java.nio. LongBuffer

相对批量 获取方法。

get(long[], int, int) - Method in class java.nio. LongBuffer

相对批量 获取方法。

get(long, TimeUnit) - Method in class java.util.concurrent. CompletableFuture

如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。

get(long, TimeUnit) - Method in class java.util.concurrent. ForkJoinTask

如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。

get(long, TimeUnit) - Method in interface java.util.concurrent. Future

如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。

get(long, TimeUnit) - Method in class java.util.concurrent. FutureTask

get(long, TimeUnit) - Method in class javax.swing. SwingWorker

如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。

get(short[]) - Method in class java.nio. ShortBuffer

相对批量 获取方法。

get(short[], int, int) - Method in class java.nio. ShortBuffer

相对批量 获取方法。

get(Class<?>) - Method in class java.lang. ClassValue

返回给定类的值。

get(Class<?>) - Method in interface javax.print.attribute. AttributeSet

返回此属性集在给定属性类别中包含的属性值。

get(Class<?>) - Method in class javax.print.attribute. HashAttributeSet

返回此属性集在给定属性类别中包含的属性值。

get(Object) - Method in class com.sun.net.httpserver. Headers

get(Object) - Method in class java.awt. RenderingHints

返回指定键映射到的值。

get(Object) - Method in class java.beans. Encoder

在此流创建的环境中返回 oldInstance的临时值。

get(Object) - Method in class java.lang.reflect. Field

返回指定对象上由此 Field表示的字段的值。

get(Object) - Method in class java.security. Provider

get(Object) - Method in class java.util. AbstractMap

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

get(Object) - Method in class java.util.concurrent. ConcurrentHashMap

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

get(Object) - Method in class java.util.concurrent. ConcurrentSkipListMap

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

get(Object) - Method in class java.util. Dictionary

返回该字典中键映射到的值。

get(Object) - Method in class java.util. EnumMap

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

get(Object) - Method in class java.util. HashMap

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

get(Object) - Method in class java.util. Hashtable

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

get(Object) - Method in class java.util. IdentityHashMap

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

get(Object) - Method in class java.util.jar. Attributes

返回指定属性名的值，如果未找到属性名，则返回null。

get(Object) - Method in class java.util. LinkedHashMap

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

get(Object) - Method in interface java.util. Map

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

get(Object) - Method in class java.util. Properties

get(Object) - Method in class java.util. TreeMap

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

get(Object) - Method in class java.util. WeakHashMap

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

get(Object) - Method in class javafx.beans.binding. MapExpression

get(Object) - Method in class javax.management.openmbean. TabularDataSupport

这个方法只需调用 get((Object[]) key) 。

get(Object) - Method in interface javax.script. Bindings

返回此映射映射指定键的值。

get(Object) - Method in class javax.script. SimpleBindings

返回此映射映射指定键的值。

get(Object) - Method in class javax.swing. ActionMap

返回 key的绑定，如果绑定未在本地定义，则发送消息传递父对象 ActionMap 。

get(Object) - Method in class javax.swing. UIDefaults

返回值的值。

get(Object) - Static method in class javax.swing. UIManager

从默认值返回一个对象。

get(Object) - Method in class javax.xml.crypto.dom. DOMCryptoContext

此实现使用内部HashMap来获取指定键映射到的对象。

get(Object) - Method in interface javax.xml.crypto. XMLCryptoContext

返回此上下文映射指定键的值。

get(Object) - Method in class javax.xml.soap. SOAPConnection

从特定端点获取消息，并阻塞，直到收到，

get(Object) - Method in class jdk.incubator.http. MultiMapResult

get(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

get(Object...) - Method in class java.lang.invoke. VarHandle

返回变量的值，读取的内存语义就好像变量被声明为非 volatile 。

get(Object[]) - Method in interface javax.management.openmbean. TabularData

返回 CompositeData值，其指数是 关键 ，或 null如果没有值映射到 按键 ，在此 TabularData实例。

get(Object[]) - Method in class javax.management.openmbean. TabularDataSupport

在这个 TabularData实例中，如果没有值映射到 键 ，则返回其索引为 key的 CompositeData值，或 null 。

get(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中的索引组件的值。

get(Object, Locale) - Method in class javax.swing. UIDefaults

返回与给定语言环境相关联的键的值。

get(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回一个对象。

get(String) - Method in class com.sun.management. GcInfo

get(String) - Method in class javax.accessibility. AccessibleRelationSet

返回与指定键匹配的关系。

get(String) - Method in class javax.activation. MimeTypeParameterList

检索与给定名称相关联的值，如果没有当前关联，则返回null。

get(String) - Method in interface javax.management.openmbean. CompositeData

返回名称为 key的项目的值。

get(String) - Method in class javax.management.openmbean. CompositeDataSupport

返回名称为 key的项目的值。

get(String) - Method in interface javax.naming.directory. Attributes

使用属性集中的给定属性id检索属性。

get(String) - Method in class javax.naming.directory. BasicAttributes

get(String) - Method in class javax.naming. Reference

检索地址类型为“addrType”的第一个地址。

get(String) - Method in class javax.script. AbstractScriptEngine

获取受保护的 context字段的 ENGINE_SCOPE中指定键的值。

get(String) - Method in interface javax.script. ScriptEngine

检索在此引擎状态下设置的值。

get(String) - Method in class javax.script. ScriptEngineManager

获取全局范围中指定键的值

get(String, boolean) - Method in class java.io. ObjectInputStream.GetField

从持久化字段获取命名布尔字段的值。

get(String, byte) - Method in class java.io. ObjectInputStream.GetField

从持久化字段获取命名字节字段的值。

get(String, char) - Method in class java.io. ObjectInputStream.GetField

从持久化字段获取命名的char字段的值。

get(String, double) - Method in class java.io. ObjectInputStream.GetField

从持续字段获取命名的双字段的值。

get(String, float) - Method in class java.io. ObjectInputStream.GetField

从持久化字段获取命名的float字段的值。

get(String, int) - Method in class java.io. ObjectInputStream.GetField

从持久化字段获取命名的int字段的值。

get(String, long) - Method in class java.io. ObjectInputStream.GetField

从持久化字段获取命名的长字段的值。

get(String, short) - Method in class java.io. ObjectInputStream.GetField

从持续字段获取命名的短字段的值。

get(String, Object) - Method in class java.io. ObjectInputStream.GetField

从持久化字段获取命名的对象字段的值。

get(String, String) - Method in class java.util.prefs. AbstractPreferences

实现 get方法按照在本说明书中 Preferences.get(String,String) 。

get(String, String) - Method in class java.util.prefs. Preferences

返回与此首选项节点中指定键相关联的值。

get(String, String...) - Static method in class java.nio.file. Paths

将路径字符串或连接到路径字符串的字符串序列转换为 Path 。

get(URI) - Method in interface java.net. CookieStore

检索与给定URI相关联的Cookie，或者其域与给定的URI匹配。

get(URI) - Static method in class java.nio.file. Paths

将给定的URI转换为Path对象。

get(URI, String, Map<String, List<String>>) - Method in class java.net. ResponseCache

根据请求的uri，请求方法和请求标头检索缓存的响应。

get(URI, Map<String, List<String>>) - Method in class java.net. CookieHandler

从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。

get(URI, Map<String, List<String>>) - Method in class java.net. CookieManager

get(URL) - Method in interface javax.jnlp. PersistenceService

返回表示此文件内容的 FileContents对象。

get(TemporalField) - Method in interface java.time.chrono. ChronoZonedDateTime

get(TemporalField) - Method in interface java.time.chrono. Era

从这个时代获取指定字段的值作为 int 。

get(TemporalField) - Method in enum java.time. DayOfWeek

从这个星期几获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. Instant

从该时刻获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. LocalDate

从此日期获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. LocalDateTime

从此日期时间获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. LocalTime

从这个时间获取指定字段的值作为 int 。

get(TemporalField) - Method in enum java.time. Month

从这个月份获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. MonthDay

从这个月日获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. OffsetDateTime

从此日期时间获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. OffsetTime

从此时间获取指定字段的值为 int 。

get(TemporalField) - Method in interface java.time.temporal. TemporalAccessor

获取指定字段的 int 。

get(TemporalField) - Method in class java.time. Year

从今年获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. YearMonth

从本年度获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. ZonedDateTime

从此日期时间获取指定字段的值作为 int 。

get(TemporalField) - Method in class java.time. ZoneOffset

从该偏移量获取指定字段的值作为 int 。

get(TemporalUnit) - Method in interface java.time.chrono. ChronoPeriod

获取所请求单元的值。

get(TemporalUnit) - Method in class java.time. Duration

获取所请求单元的值。

get(TemporalUnit) - Method in class java.time. Period

获取所请求单元的值。

get(TemporalUnit) - Method in interface java.time.temporal. TemporalAmount

返回请求的单位的值。

get(KeyStroke) - Method in class javax.swing. InputMap

返回 keyStroke的绑定，如果绑定未在本地定义，则发送消息传递父对象 InputMap 。

get(SynthContext, Object) - Method in class javax.swing.plaf.nimbus. NimbusStyle

Getter为区域特定样式属性。

get(SynthContext, Object) - Method in class javax.swing.plaf.synth. SynthStyle

Getter为区域特定样式属性。

get(CatalogFeatures.Feature) - Method in class javax.xml.catalog. CatalogFeatures

返回指定要素的值。

get(T) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

返回由此更新程序管理的给定对象的字段中保留的当前值。

get(T) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

返回由此更新程序管理的给定对象的字段中保留的当前值。

get(T) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater

返回由此更新程序管理的给定对象的字段中保留的当前值。

GET - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.get指定

GET - javax.swing.text.html. FormSubmitEvent.MethodType

GET对应于GET表单方法

GET - jdk.dynalink. StandardOperation

从对象上定义的命名空间获取值。

GET() - Method in class jdk.incubator.http. HttpRequest.Builder

将此构建器的请求方法设置为GET。

GET_ACQUIRE - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.getAcquire指定

GET_AND_ADD - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndAdd指定

GET_AND_ADD_ACQUIRE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndAddAcquire指定

GET_AND_ADD_RELEASE - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.getAndAddRelease指定

GET_AND_BITWISE_AND - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.getAndBitwiseAnd指定

GET_AND_BITWISE_AND_ACQUIRE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndBitwiseAndAcquire指定

GET_AND_BITWISE_AND_RELEASE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndBitwiseAndRelease指定

GET_AND_BITWISE_OR - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndBitwiseOr指定

GET_AND_BITWISE_OR_ACQUIRE - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.getAndBitwiseOrAcquire指定

GET_AND_BITWISE_OR_RELEASE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndBitwiseOrRelease指定

GET_AND_BITWISE_XOR - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndBitwiseXor指定

GET_AND_BITWISE_XOR_ACQUIRE - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.getAndBitwiseXorAcquire指定

GET_AND_BITWISE_XOR_RELEASE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndBitwiseXorRelease指定

GET_AND_SET - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndSet指定

GET_AND_SET_ACQUIRE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndSetAcquire指定

GET_AND_SET_RELEASE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getAndSetRelease指定

get_any() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 org.omg.CORBA.Any包含在此 DynAny对象。

get_any() - Method in class org.omg.DynamicAny. _DynAnyStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in class org.omg.DynamicAny. _DynArrayStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in class org.omg.DynamicAny. _DynEnumStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in class org.omg.DynamicAny. _DynFixedStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in class org.omg.DynamicAny. _DynSequenceStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in class org.omg.DynamicAny. _DynStructStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in class org.omg.DynamicAny. _DynUnionStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in class org.omg.DynamicAny. _DynValueStub

提取由DynAny表示的Any中包含的任何值。

get_any() - Method in interface org.omg.DynamicAny. DynAnyOperations

提取由DynAny表示的Any中包含的任何值。

get_as_string() - Method in class org.omg.DynamicAny. _DynEnumStub

将DynEnum的值作为IDL标识符返回。

get_as_string() - Method in interface org.omg.DynamicAny. DynEnumOperations

将DynEnum的值作为IDL标识符返回。

get_as_ulong() - Method in class org.omg.DynamicAny. _DynEnumStub

将DynEnum的值作为枚举值的序数值返回。

get_as_ulong() - Method in interface org.omg.DynamicAny. DynEnumOperations

将DynEnum的值作为枚举值的序数值返回。

get_boolean() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 boolean包含在此 DynAny对象。

get_boolean() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取布尔值。

get_boolean() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取布尔值。

get_boolean() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取布尔值。

get_boolean() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取布尔值。

get_boolean() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取布尔值。

get_boolean() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取布尔值。

get_boolean() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取布尔值。

get_boolean() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取布尔值。

get_boolean() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取布尔值。

get_boxed_value() - Method in interface org.omg.DynamicAny. DynValueBoxOperations

返回Box的值为Any。

get_boxed_value_as_dyn_any() - Method in interface org.omg.DynamicAny. DynValueBoxOperations

返回盒装值作为DynAny。

get_char() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 char包含在此 DynAny对象。

get_char() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取字符值。

get_char() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取字符值。

get_char() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取字符值。

get_char() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取字符值。

get_char() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取字符值。

get_char() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取字符值。

get_char() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取字符值。

get_char() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取字符值。

get_char() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取字符值。

get_codebase(Object) - Method in class org.omg.CORBA_2_3.portable. Delegate

返回提供的对象引用的代码库。

get_compact_typecode() - Method in class org.omg.CORBA. TypeCode

删除所有可选的名称和成员名称字段，但保留所有别名类型代码。

get_current() - Method in class org.omg.CORBA. ORB

已过时。
使用resolve_initial_references 。

get_default_context() - Method in class org.omg.CORBA. ORB

获取默认的 Context对象。

get_discriminator() - Method in class org.omg.DynamicAny. _DynUnionStub

返回当前的鉴别器值。

get_discriminator() - Method in interface org.omg.DynamicAny. DynUnionOperations

返回当前的鉴别器值。

get_domain_managers(Object) - Method in class org.omg.CORBA.portable. Delegate

检索此对象的 DomainManagers 。

get_domain_policy(int) - Method in interface org.omg.CORBA. DomainManagerOperations

这将返回此域中对象的指定类型的策略。

get_double() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 double包含在此 DynAny对象。

get_double() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取双重值。

get_double() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取双重值。

get_double() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取双重值。

get_double() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取双重值。

get_double() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取双重值。

get_double() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取双重值。

get_double() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取双重值。

get_double() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取双重值。

get_double() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取双重值。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynAnyStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynArrayStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynEnumStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynFixedStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynSequenceStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynStructStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynUnionStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in class org.omg.DynamicAny. _DynValueStub

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_dyn_any() - Method in interface org.omg.DynamicAny. DynAnyOperations

提取由该DynAny表示的Any中包含的Any值，并将其返回包装到新的DynAny中。

get_effective_component(int) - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations

从为此请求选择的配置文件中返回具有给定ID的 IOP.TaggedComponent 。

get_effective_components(int) - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations

从为该请求选择的配置文件中返回具有给定ID的所有标记组件的数组。

get_effective_policy(int) - Method in interface org.omg.PortableInterceptor. IORInfoOperations

允许ORB服务实现来确定特定类型的服务器端策略对于正在构造的IOR有效。

get_elements() - Method in interface org.omg.CORBA. DynArray

已过时。

返回此数组的所有元素的值。

get_elements() - Method in interface org.omg.CORBA. DynSequence

已过时。

返回此序列中每个元素的值。

get_elements() - Method in class org.omg.DynamicAny. _DynArrayStub

返回DynArray的元素。

get_elements() - Method in class org.omg.DynamicAny. _DynSequenceStub

返回序列的元素。

get_elements() - Method in interface org.omg.DynamicAny. DynArrayOperations

返回DynArray的元素。

get_elements() - Method in interface org.omg.DynamicAny. DynSequenceOperations

返回序列的元素。

get_elements_as_dyn_any() - Method in class org.omg.DynamicAny. _DynArrayStub

以DynAnys返回DynArray的元素。

get_elements_as_dyn_any() - Method in class org.omg.DynamicAny. _DynSequenceStub

返回表示序列元素的DynAnys。

get_elements_as_dyn_any() - Method in interface org.omg.DynamicAny. DynArrayOperations

以DynAnys返回DynArray的元素。

get_elements_as_dyn_any() - Method in interface org.omg.DynamicAny. DynSequenceOperations

返回表示序列元素的DynAnys。

get_float() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 float包含在此 DynAny对象。

get_float() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取浮点值。

get_float() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取浮点值。

get_float() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取浮点值。

get_float() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取浮点值。

get_float() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取浮点值。

get_float() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取浮点值。

get_float() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取浮点值。

get_float() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取浮点值。

get_float() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取浮点值。

get_id() - Method in interface org.omg.CORBA.portable. BoxedValueHelper

get_id() - Method in class org.omg.CORBA. StringValueHelper

get_id() - Method in class org.omg.CORBA. WStringValueHelper

get_interface_def(Object) - Method in class org.omg.CORBA.portable. Delegate

返回提供的对象引用的InterfaceDef。

get_interface_def(Servant) - Method in interface org.omg.PortableServer.portable. Delegate

此操作返回Interface Repository中的对象，该对象提供可能对程序有用的类型信息。

get_length() - Method in class org.omg.DynamicAny. _DynSequenceStub

返回序列的当前长度。

get_length() - Method in interface org.omg.DynamicAny. DynSequenceOperations

返回序列的当前长度。

get_long() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 int包含在此 DynAny对象。

get_long() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取整数值。

get_long() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取整数值。

get_long() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取整数值。

get_long() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取整数值。

get_long() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取整数值。

get_long() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取整数值。

get_long() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取整数值。

get_long() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取整数值。

get_long() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取整数值。

get_longlong() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 long包含在此 DynAny对象。

get_longlong() - Method in class org.omg.DynamicAny. _DynAnyStub

从DynAny中提取长的值。

get_longlong() - Method in class org.omg.DynamicAny. _DynArrayStub

从DynAny中提取长的值。

get_longlong() - Method in class org.omg.DynamicAny. _DynEnumStub

从DynAny中提取长的值。

get_longlong() - Method in class org.omg.DynamicAny. _DynFixedStub

从DynAny中提取长的值。

get_longlong() - Method in class org.omg.DynamicAny. _DynSequenceStub

从DynAny中提取长的值。

get_longlong() - Method in class org.omg.DynamicAny. _DynStructStub

从DynAny中提取长的值。

get_longlong() - Method in class org.omg.DynamicAny. _DynUnionStub

从DynAny中提取长的值。

get_longlong() - Method in class org.omg.DynamicAny. _DynValueStub

从DynAny中提取长的值。

get_longlong() - Method in interface org.omg.DynamicAny. DynAnyOperations

从DynAny中提取长的值。

GET_LOOKUP_PERMISSION_NAME - Static variable in class jdk.dynalink. SecureLookupSupplier

成功调用 SecureLookupSupplier.getLookup()方法所需的运行时权限的名称。

get_members() - Method in interface org.omg.CORBA. DynStruct

已过时。

返回一个包含存储结构体的所有成员的数组。

get_members() - Method in interface org.omg.CORBA. DynValue

已过时。

返回一个包含存储在此 DynValue中的值对象的所有成员的数组。

get_members() - Method in class org.omg.DynamicAny. _DynStructStub

返回一个NameValuePairs序列，描述与DynStruct对象关联的结构中每个成员的名称和值。

get_members() - Method in class org.omg.DynamicAny. _DynValueStub

返回一个NameValuePairs序列，描述值类型中每个成员的名称和值。

get_members() - Method in interface org.omg.DynamicAny. DynStructOperations

返回一个NameValuePairs序列，描述与DynStruct对象关联的结构中每个成员的名称和值。

get_members() - Method in interface org.omg.DynamicAny. DynValueOperations

返回一个NameValuePairs序列，描述值类型中每个成员的名称和值。

get_members_as_dyn_any() - Method in class org.omg.DynamicAny. _DynStructStub

返回一个NameDynAnyPairs序列，描述与DynStruct对象关联的结构中每个成员的名称和值。

get_members_as_dyn_any() - Method in class org.omg.DynamicAny. _DynValueStub

返回一个NameDynAnyPairs序列，描述值类型中每个成员的名称和值。

get_members_as_dyn_any() - Method in interface org.omg.DynamicAny. DynStructOperations

返回一个NameDynAnyPairs序列，描述与DynStruct对象关联的结构中每个成员的名称和值。

get_members_as_dyn_any() - Method in interface org.omg.DynamicAny. DynValueOperations

返回一个NameDynAnyPairs序列，描述值类型中每个成员的名称和值。

get_next_response() - Method in class org.omg.CORBA. ORB

获取接收到响应的下一个 Request实例。

get_object_id() - Method in interface org.omg.PortableServer. CurrentOperations

返回ObjectId，标识在其上下文中被调用的对象。

get_octet() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 byte包含在此 DynAny对象。

get_octet() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取字节值。

get_octet() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取字节值。

get_octet() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取字节值。

get_octet() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取字节值。

get_octet() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取字节值。

get_octet() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取字节值。

get_octet() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取字节值。

get_octet() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取字节值。

get_octet() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取字节值。

GET_OPAQUE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getOpaque指定

get_POA() - Method in interface org.omg.PortableServer. CurrentOperations

返回对实现在其上下文中调用的对象的POA的引用。

get_policy(Object, int) - Method in class org.omg.CORBA.portable. Delegate

返回适用于此对象的指定类型的 Policy对象。

get_primitive_tc(TCKind) - Method in class org.omg.CORBA. ORB

检索表示给定的原始IDL类型的 TypeCode对象。

get_reference() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 org.omg.CORBA.Other包含在此 DynAny对象。

get_reference() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取对CORBA对象的引用。

get_reference() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取对CORBA对象的引用。

get_reply_service_context(int) - Method in interface org.omg.PortableInterceptor. RequestInfoOperations

使用与回复关联的给定ID返回服务上下文的副本。

get_request_policy(int) - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations

返回此操作生效的给定策略。

get_request_service_context(int) - Method in interface org.omg.PortableInterceptor. RequestInfoOperations

使用与请求相关联的给定ID返回服务上下文的副本。

get_response() - Method in class org.omg.CORBA. Request

允许用户使用 send_deferred方法访问先前触发的调用响应。

get_servant() - Method in interface org.omg.PortableServer. POAOperations

此操作返回与POA关联的默认servant。

get_servant_manager() - Method in interface org.omg.PortableServer. POAOperations

如果POA的ServantRetentionPolicy是RETAIN，则ServantManager参数（imgr）将支持ServantActivator接口。

get_server_policy(int) - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations

返回给定策略类型的此操作的有效策略。

get_service_information(short, ServiceInformationHolder) - Method in class org.omg.CORBA. ORB

用于获取有关该ORB支持的CORBA设施和服务的信息。

get_short() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 short包含在此 DynAny对象。

get_short() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取短值。

get_short() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取短值。

get_short() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取短值。

get_short() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取短值。

get_short() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取短值。

get_short() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取短值。

get_short() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取短值。

get_short() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取短值。

get_short() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取短值。

get_slot(int) - Method in interface org.omg.PortableInterceptor. CurrentOperations

通过 get_slot检索PICurrent中设置的应用程序的插槽数据。

get_slot(int) - Method in interface org.omg.PortableInterceptor. RequestInfoOperations

返回位于请求范围内的 PortableInterceptor.Current的给定槽中的数据。

get_state() - Method in interface org.omg.PortableServer. POAManagerOperations

此操作返回POA管理器的状态。

get_string() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 String包含在此 DynAny对象。

get_string() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取字符串值。

get_string() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取字符串值。

get_string() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取字符串值。

get_string() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取字符串值。

get_string() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取字符串值。

get_string() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取字符串值。

get_string() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取字符串值。

get_string() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取字符串值。

get_string() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取字符串值。

get_typecode() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 org.omg.CORBA.TypeCode包含在此 DynAny对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取TypeCode对象。

get_typecode() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取TypeCode对象。

get_ulong() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 int包含在此 DynAny对象。

get_ulong() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取整数值。

get_ulong() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取整数值。

get_ulong() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取整数值。

get_ulong() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取整数值。

get_ulong() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取整数值。

get_ulong() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取整数值。

get_ulong() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取整数值。

get_ulong() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取整数值。

get_ulong() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取整数值。

get_ulonglong() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 long包含在此 DynAny对象。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynAnyStub

从DynAny中提取长的值。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynArrayStub

从DynAny中提取长的值。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynEnumStub

从DynAny中提取长的值。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynFixedStub

从DynAny中提取长的值。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynSequenceStub

从DynAny中提取长的值。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynStructStub

从DynAny中提取长的值。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynUnionStub

从DynAny中提取长的值。

get_ulonglong() - Method in class org.omg.DynamicAny. _DynValueStub

从DynAny中提取长的值。

get_ulonglong() - Method in interface org.omg.DynamicAny. DynAnyOperations

从DynAny中提取长的值。

get_ushort() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 short包含在此 DynAny对象。

get_ushort() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取短值。

get_ushort() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取短值。

get_ushort() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取短值。

get_ushort() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取短值。

get_ushort() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取短值。

get_ushort() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取短值。

get_ushort() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取短值。

get_ushort() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取短值。

get_ushort() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取短值。

get_val() - Method in interface org.omg.CORBA. DynAny

已过时。

检索此 java.io.Serializable对象中包含的 DynAny对象。

get_val() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取可序列化的对象。

get_val() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取可序列化的对象。

get_val() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取可序列化的对象。

get_val() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取可序列化的对象。

get_val() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取可序列化的对象。

get_val() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取可序列化的对象。

get_val() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取可序列化的对象。

get_val() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取可序列化的对象。

get_val() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取可序列化的对象。

get_value() - Method in interface org.omg.CORBA. DynFixed

已过时。

返回此 DynFixed对象中表示的固定类型的值。

get_value() - Method in class org.omg.DynamicAny. _DynFixedStub

返回DynFixed的值。

get_value() - Method in interface org.omg.DynamicAny. DynFixedOperations

返回DynFixed的值。

get_value_def(String) - Method in class org.omg.CORBA_2_3. ORB

get_values(String, int, String) - Method in class org.omg.CORBA. Context

检索其 name字段与给定名称或名称模式匹配的 NamedValue对象。

GET_VOLATILE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.getVolatile指定

get_wchar() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 char包含在此 DynAny对象。

get_wchar() - Method in class org.omg.DynamicAny. _DynAnyStub

从DynAny中提取长的值。

get_wchar() - Method in class org.omg.DynamicAny. _DynArrayStub

从DynAny中提取长的值。

get_wchar() - Method in class org.omg.DynamicAny. _DynEnumStub

从DynAny中提取长的值。

get_wchar() - Method in class org.omg.DynamicAny. _DynFixedStub

从DynAny中提取长的值。

get_wchar() - Method in class org.omg.DynamicAny. _DynSequenceStub

从DynAny中提取长的值。

get_wchar() - Method in class org.omg.DynamicAny. _DynStructStub

从DynAny中提取长的值。

get_wchar() - Method in class org.omg.DynamicAny. _DynUnionStub

从DynAny中提取长的值。

get_wchar() - Method in class org.omg.DynamicAny. _DynValueStub

从DynAny中提取长的值。

get_wchar() - Method in interface org.omg.DynamicAny. DynAnyOperations

从DynAny中提取长的值。

get_wstring() - Method in interface org.omg.CORBA. DynAny

已过时。

检索 String包含在此 DynAny对象。

get_wstring() - Method in class org.omg.DynamicAny. _DynAnyStub

从此DynAny中提取字符串值。

get_wstring() - Method in class org.omg.DynamicAny. _DynArrayStub

从此DynAny中提取字符串值。

get_wstring() - Method in class org.omg.DynamicAny. _DynEnumStub

从此DynAny中提取字符串值。

get_wstring() - Method in class org.omg.DynamicAny. _DynFixedStub

从此DynAny中提取字符串值。

get_wstring() - Method in class org.omg.DynamicAny. _DynSequenceStub

从此DynAny中提取字符串值。

get_wstring() - Method in class org.omg.DynamicAny. _DynStructStub

从此DynAny中提取字符串值。

get_wstring() - Method in class org.omg.DynamicAny. _DynUnionStub

从此DynAny中提取字符串值。

get_wstring() - Method in class org.omg.DynamicAny. _DynValueStub

从此DynAny中提取字符串值。

get_wstring() - Method in interface org.omg.DynamicAny. DynAnyOperations

从此DynAny中提取字符串值。

get2DigitYearStart() - Method in class java.text. SimpleDateFormat

返回100年期间的开始日期，2位数年份被解释为在内。

getA() - Method in class java.security.spec. EllipticCurve

返回椭圆曲线的第一个系数 a 。

getAbbr() - Method in interface org.w3c.dom.html. HTMLTableCellElement

标题单元的缩写。

getAbsoluteFile() - Method in class java.io. File

返回此抽象路径名的绝对形式。

getAbsolutePath() - Method in class java.io. File

返回此抽象路径名的绝对路径名字符串。

getAccelerationPriority() - Method in class java.awt. Image

返回加速优先提示的当前值。

getAccelerator() - Method in class javafx.scene.control. MenuItem

获取属性加速器的值。

getAccelerator() - Method in class javax.swing. JMenuItem

返回 KeyStroke ，作为菜单项的加速器。

getAcceleratorForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的加速器前景色。

getAcceleratorForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回加速器前景色。

getAccelerators() - Method in class javafx.scene. Scene

获取此 Scene的加速器列表。

getAcceleratorSelectedForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回加速器选择的当前主题的前景色。

getAcceleratorSelectedForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回加速器选择的前景色。

getAcceleratorString() - Method in class javax.swing.plaf.metal. MetalToolTipUI

返回加速器字符串。

getAccept() - Method in interface org.w3c.dom.html. HTMLInputElement

服务器处理此表单的内容类型的逗号分隔列表将会正确处理。

getAcceptAllFileFilter() - Method in class javax.swing. JFileChooser

返回 AcceptAll文件过滤器。

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回默认值接受所有文件过滤器

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf. FileChooserUI

返回一个accept-all文件过滤器。

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getAcceptAllFileFilter方法。

getAcceptCharset() - Method in interface org.w3c.dom.html. HTMLFormElement

服务器支持的字符集列表。

getAcceptedIssuers() - Method in interface javax.net.ssl. X509TrustManager

返回一个可信任验证对等体的证书颁发机构证书数组。

getAcceptedTransferMode() - Method in class javafx.scene.input. DragEvent

获得潜在目标接受的传输模式。

getAcceptingObject() - Method in class javafx.scene.input. DragEvent

接受拖动的对象。

getAcceptorAddress() - Method in class org.ietf.jgss. ChannelBinding

获取该通道绑定的接受者地址。

getAccessible(Object) - Static method in class com.sun.java.accessibility.util. Translator

获取实现接口 Accessible的对象。

getAccessibleAction() - Method in class java.awt. Button.AccessibleAWTButton

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class java.awt. Choice.AccessibleAWTChoice

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class javax.accessibility. AccessibleContext

获取与此对象关联的 AccessibleAction ，该对象支持一个或多个操作。

getAccessibleAction() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class javax.swing. JComboBox.AccessibleJComboBox

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

获取支持一个或多个操作的此对象关联的 AccessibleAction 。

getAccessibleAction() - Method in class javax.swing. JSpinner.AccessibleJSpinner

获取与支持一个或多个操作的此对象关联的AccessibleAction。

getAccessibleAction() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取与此对象关联的 AccessibleAction如果存在）。

getAccessibleAction() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取与此对象关联的AccessibleAction。

getAccessibleAction() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleAction() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

getAccessibleActionAnchor(int) - Method in class javax.accessibility. AccessibleHyperlink

返回一个表示链接锚点的对象，适用于该链接。

getAccessibleActionAnchor(int) - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

根据该链接返回一个表示链接锚点的对象。

getAccessibleActionCount() - Method in class java.awt. Button.AccessibleAWTButton

返回此对象中可用的操作数。

getAccessibleActionCount() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

返回此对象中可用的操作数。

getAccessibleActionCount() - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

返回此对象中可用的操作数。

getAccessibleActionCount() - Method in class java.awt. Choice.AccessibleAWTChoice

返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。

getAccessibleActionCount() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

返回此对象中可用的操作数。

getAccessibleActionCount() - Method in interface javax.accessibility. AccessibleAction

返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。

getAccessibleActionCount() - Method in class javax.accessibility. AccessibleHyperlink

返回此链接中可用操作的数量如果有多个可用操作，则第一个不被视为此LINK对象的“默认”操作（例如，在HTML图像映射中）。

getAccessibleActionCount() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回此对象中可用的操作数。

getAccessibleActionCount() - Method in class javax.swing. JComboBox.AccessibleJComboBox

返回此对象中可用的操作数。

getAccessibleActionCount() - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

返回此链接中可用操作的数量如果有多个可用操作，则第一个不被视为此LINK对象的“默认”操作（例如，在HTML图像映射中）。

getAccessibleActionCount() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。

getAccessibleActionCount() - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。

getAccessibleActionCount() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回此树节点中可用的可访问操作的数量。

getAccessibleActionCount() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。

getAccessibleActionDescription(int) - Method in class java.awt. Button.AccessibleAWTButton

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class java.awt. Choice.AccessibleAWTChoice

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in interface javax.accessibility. AccessibleAction

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class javax.accessibility. AccessibleHyperlink

返回此特定链接操作的字符串描述。

getAccessibleActionDescription(int) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class javax.swing. JComboBox.AccessibleJComboBox

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

返回此特定链接操作的字符串描述。

getAccessibleActionDescription(int) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回对象的指定操作的描述。

getAccessibleActionDescription(int) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回树节点指定动作的描述。

getAccessibleActionDescription(int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回对象的指定操作的描述。

getAccessibleActionObject(int) - Method in class javax.accessibility. AccessibleHyperlink

返回表示链接操作的对象，适用于该链接。

getAccessibleActionObject(int) - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

返回一个表示链接的URL对象。

getAccessibleAt(int, int) - Method in interface javax.accessibility. AccessibleTable

返回表中指定行和列的 Accessible 。

getAccessibleAt(int, int) - Method in class javax.swing. JTable.AccessibleJTable

getAccessibleAt(Component, Point) - Static method in class javax.swing. SwingUtilities

返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。

getAccessibleAt(Point) - Static method in class com.sun.java.accessibility.util. EventQueueMonitor

在屏幕上的给定点获取Accessible对象。

getAccessibleAt(Point) - Method in class com.sun.java.accessibility.util. Translator

返回包含在本地坐标Point（如果存在）的可访问子项。

getAccessibleAt(Point) - Method in class java.awt. Component.AccessibleAWTComponent

返回 Accessible小孩（如果有的话）包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in class java.awt. Container.AccessibleAWTContainer

返回 Accessible小孩（如果存在），包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

返回 Accessible小孩（如果有的话）包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in class java.awt. List.AccessibleAWTList

返回包含在本地坐标Point（如果存在）的Accessible子项。

getAccessibleAt(Point) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回 Accessible小孩（如果存在），包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in interface javax.accessibility. AccessibleComponent

返回 Accessible小孩（如果存在），包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in class javax.swing. JEditorPane.AccessibleJEditorPaneHTML

返回Accessible小组（如果存在）包含在本地坐标Point。

getAccessibleAt(Point) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleAt(Point) - Method in class javax.swing. JList.AccessibleJList

返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。

getAccessibleAt(Point) - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

返回包含在本地坐标 Point （如果存在）的 Accessible子 Point 。

getAccessibleAt(Point) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

getAccessibleAt(Point) - Method in class javax.swing. JTable.AccessibleJTable

返回 Accessible小孩（如果存在），包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回 Accessible小孩（如果存在），包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in class javax.swing. JTree.AccessibleJTree

返回 Accessible子 Accessible （如果存在），包含在本地坐标 Point 。

getAccessibleAt(Point) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleAt(Point) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader

返回Accessible小组（如果存在）包含在本地坐标Point。

getAccessibleCaption() - Method in interface javax.accessibility. AccessibleTable

返回表的标题。

getAccessibleCaption() - Method in class javax.swing. JTable.AccessibleJTable

返回表的标题。

getAccessibleChild(int) - Method in class com.sun.java.accessibility.util. Translator

返回对象的第n个可访问的小孩。

getAccessibleChild(int) - Method in class java.awt. Component.AccessibleAWTComponent

返回对象的第n个 Accessible子对象。

getAccessibleChild(int) - Method in class java.awt. Container.AccessibleAWTContainer

返回对象的第n个 Accessible子对象。

getAccessibleChild(int) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

返回对象的指定Accessible子对象。

getAccessibleChild(int) - Method in class java.awt. List.AccessibleAWTList

返回对象的第n个可访问子对象。

getAccessibleChild(int) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回对象的第n个 Accessible子对象。

getAccessibleChild(int) - Method in class javax.accessibility. AccessibleContext

返回对象的指定的 Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. ImageIcon.AccessibleImageIcon

返回对象的第n个可访问子对象。

getAccessibleChild(int) - Method in class javax.swing. JComboBox.AccessibleJComboBox

返回对象的第n个可访问子对象。

getAccessibleChild(int) - Method in class javax.swing. JComponent.AccessibleJComponent

返回对象的第n个可访问子对象。

getAccessibleChild(int) - Method in class javax.swing. JEditorPane.AccessibleJEditorPaneHTML

返回对象的指定Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleChild(int) - Method in class javax.swing. JList.AccessibleJList

返回对象的第n个可访问子对象。

getAccessibleChild(int) - Method in class javax.swing. JMenu.AccessibleJMenu

返回对象的第n个可访问子对象。

getAccessibleChild(int) - Method in class javax.swing. JRootPane.AccessibleJRootPane

返回对象的指定Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回对象的指定Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

返回对象的指定Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

返回对象的指定的 Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. JTable.AccessibleJTable

返回对象的第n个 Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回对象的指定Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing. JTree.AccessibleJTree

返回对象的第n个可访问子对象。

getAccessibleChild(int) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回对象的指定Accessible子对象。

getAccessibleChild(int) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleChild(int) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader

返回对象的第n个可访问子对象。

getAccessibleChild(Component, int) - Static method in class javax.swing. SwingUtilities

返回对象的第n个可访问子对象。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf. ComponentUI

返回对象的 i第 Accessible个子对象。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiButtonUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiColorChooserUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiLabelUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiMenuBarUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiMenuItemUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiPanelUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiProgressBarUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiRootPaneUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiScrollBarUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiSeparatorUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiSliderUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiSpinnerUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiTableUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiToolBarUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiToolTipUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi. MultiViewportUI

在此对象处理的每个UI上调用 getAccessibleChild方法。

getAccessibleChildrenCount() - Method in class com.sun.java.accessibility.util. Translator

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class java.awt. Component.AccessibleAWTComponent

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class java.awt. Container.AccessibleAWTContainer

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

返回对象的可访问子对象的数量。

getAccessibleChildrenCount() - Method in class java.awt. List.AccessibleAWTList

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.accessibility. AccessibleContext

返回对象的可访问子对象的数量。

getAccessibleChildrenCount() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JComboBox.AccessibleJComboBox

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JComponent.AccessibleJComponent

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JEditorPane.AccessibleJEditorPaneHTML

返回对象的可访问子对象的数量。

getAccessibleChildrenCount() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleChildrenCount() - Method in class javax.swing. JList.AccessibleJList

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JMenu.AccessibleJMenu

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JRootPane.AccessibleJRootPane

返回对象的可访问子对象的数量。

getAccessibleChildrenCount() - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回对象的可访问子对象的数量。

getAccessibleChildrenCount() - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JTable.AccessibleJTable

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回对象中可访问的子项数。

getAccessibleChildrenCount() - Method in class javax.swing. JTree.AccessibleJTree

返回此JTree的顶级子节点数。

getAccessibleChildrenCount() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回对象的可访问子对象的数量。

getAccessibleChildrenCount() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleChildrenCount() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader

返回对象中可访问的子项数。

getAccessibleChildrenCount(Component) - Static method in class javax.swing. SwingUtilities

返回对象中可访问的子项数。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf. ComponentUI

返回对象中可访问的子项数。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI

在此对象处理的每个UI上调用 getAccessibleChildrenCount方法。

getAccessibleColumn(int) - Method in interface javax.accessibility. AccessibleExtendedTable

返回表中索引的列号。

getAccessibleColumn(int) - Method in class javax.swing. JTable.AccessibleJTable

返回表中索引的列号。

getAccessibleColumnAtIndex(int) - Method in class javax.swing. JTable.AccessibleJTable

将给定索引处的列返回到表中。

getAccessibleColumnCount() - Method in interface javax.accessibility. AccessibleTable

返回表中的列数。

getAccessibleColumnCount() - Method in class javax.swing. JTable.AccessibleJTable

getAccessibleColumnDescription(int) - Method in interface javax.accessibility. AccessibleTable

返回表中指定列的描述文本。

getAccessibleColumnDescription(int) - Method in class javax.swing. JTable.AccessibleJTable

返回表中指定列的描述。

getAccessibleColumnExtentAt(int, int) - Method in interface javax.accessibility. AccessibleTable

返回表中指定行和列的 Accessible占用的列数。

getAccessibleColumnExtentAt(int, int) - Method in class javax.swing. JTable.AccessibleJTable

返回给定（行，列） Accessible占用的列数。

getAccessibleColumnHeader() - Method in interface javax.accessibility. AccessibleTable

返回列标题为 AccessibleTable 。

getAccessibleColumnHeader() - Method in class javax.swing. JTable.AccessibleJTable

返回列标题为 AccessibleTable 。

getAccessibleComponent() - Method in class java.awt. Component.AccessibleAWTComponent

获取与此对象关联的 AccessibleComponent如果存在）。

getAccessibleComponent() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取与此对象关联的 AccessibleComponent如果存在）。

getAccessibleComponent() - Method in class javax.accessibility. AccessibleContext

获取与该对象关联的 AccessibleComponent ，该对象具有图形表示。

getAccessibleComponent() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

获取与此对象关联的AccessibleComponent。

getAccessibleComponent() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取与此对象关联的 AccessibleComponent如果存在）。

getAccessibleComponent() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取与此对象关联的AccessibleComponent。

getAccessibleComponent() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取与此对象关联的AccessibleComponent，该对象具有图形表示形式。

getAccessibleComponent() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

获取与此对象关联的AccessibleComponent。

getAccessibleContext() - Method in class com.sun.java.accessibility.util. Translator

返回此对象。

getAccessibleContext() - Method in class java.applet. Applet

已过时。

获取与此Applet关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. Button

获取 AccessibleContext与此 Button相关联。

getAccessibleContext() - Method in class java.awt. Canvas

获取与此Canvas关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. Checkbox

获取与此复选框相关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. CheckboxMenuItem

获取与此CheckboxMenuItem关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. Choice

获取 AccessibleContext与此 Choice相关联。

getAccessibleContext() - Method in class java.awt. Component

获取 AccessibleContext与此 Component相关联。

getAccessibleContext() - Method in class java.awt. Dialog

获取与此对话框关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. Frame

获取与此Frame相关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. Label

获取与此Label相关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的AccessibleContext。

getAccessibleContext() - Method in class java.awt. List

获取 AccessibleContext与此 List相关联。

getAccessibleContext() - Method in class java.awt. Menu

获取与此菜单关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. MenuBar

获取与此MenuBar关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. MenuComponent

获取 AccessibleContext与此 MenuComponent相关联。

getAccessibleContext() - Method in class java.awt. MenuItem

获取与此MenuItem关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. Panel

获取与此面板关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. PopupMenu

获取 AccessibleContext与此 PopupMenu相关联。

getAccessibleContext() - Method in class java.awt. Scrollbar

获取 AccessibleContext与此 Scrollbar相关联。

getAccessibleContext() - Method in class java.awt. ScrollPane

获取与此ScrollPane关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. TextArea

返回 AccessibleContext与此相关 TextArea 。

getAccessibleContext() - Method in class java.awt. TextComponent

获取与此TextComponent关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. TextField

获取与此TextField关联的AccessibleContext。

getAccessibleContext() - Method in class java.awt. Window

获取与此窗口关联的AccessibleContext。

getAccessibleContext() - Method in interface javax.accessibility. Accessible

返回与此对象关联的 AccessibleContext 。

getAccessibleContext() - Method in class javax.swing. Box.Filler

获取与此Box.Filler相关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. Box

获取与此Box关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. CellRendererPane

获取与此CellRendererPane关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. ImageIcon

获取与此ImageIcon关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JApplet

已过时。

获取与此JApplet关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JButton

获取 AccessibleContext与此 JButton相关联。

getAccessibleContext() - Method in class javax.swing. JCheckBox

获取与此JCheckBox关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JCheckBoxMenuItem

获取与此JCheckBoxMenuItem关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JColorChooser

获取与此JColorChooser关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JComboBox

获取与此JComboBox关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JDesktopPane

获取 AccessibleContext与此 JDesktopPane相关联。

getAccessibleContext() - Method in class javax.swing. JDialog

获取与此JDialog关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JEditorPane

获取与此JEditorPane关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JFileChooser

获取与此JFileChooser关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JFrame

获取与此JFrame关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JInternalFrame

获取 AccessibleContext与此 JInternalFrame相关联。

getAccessibleContext() - Method in class javax.swing. JInternalFrame.JDesktopIcon

获取与此JDesktopIcon关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JLabel

获取此对象的AccessibleContext

getAccessibleContext() - Method in class javax.swing. JLayer

获取与此 JLayer相关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JLayeredPane

获取与此JLayeredPane关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

获取此对象的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JList

获取 AccessibleContext与此 JList相关联。

getAccessibleContext() - Method in class javax.swing. JMenu

获取与此JMenu关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JMenuBar

获取与此JMenuBar关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JMenuItem

返回 AccessibleContext与此相关 JMenuItem 。

getAccessibleContext() - Method in class javax.swing. JOptionPane

返回与此JOptionPane关联的 AccessibleContext 。

getAccessibleContext() - Method in class javax.swing. JPanel

获取与此JPanel关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JPasswordField

返回 AccessibleContext与此 JPasswordField相关联。

getAccessibleContext() - Method in class javax.swing. JPopupMenu

获取与此JPopupMenu关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JProgressBar

获取 AccessibleContext与此 JProgressBar相关联。

getAccessibleContext() - Method in class javax.swing. JRadioButton

获取与此JRadioButton关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JRadioButtonMenuItem

获取与此JRadioButtonMenuItem关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JRootPane

获取 AccessibleContext与此 JRootPane相关联。

getAccessibleContext() - Method in class javax.swing. JScrollBar

获取与此JScrollBar关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JScrollPane

获取与此JScrollPane关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JSeparator

获取与此JSeparator关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JSlider

获取与此JSlider相关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JSpinner

获得 AccessibleContext的 JSpinner

getAccessibleContext() - Method in class javax.swing. JSplitPane

获取与此JSplitPane关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JTabbedPane

获取与此JTabbedPane关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取与此组件关联的 AccessibleContext 。

getAccessibleContext() - Method in class javax.swing. JTable

获取与此JTable关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JTextArea

获取与此JTextArea关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JTextField

获取 AccessibleContext与此 JTextField相关联。

getAccessibleContext() - Method in class javax.swing. JToggleButton

获取与此JToggleButton关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JToolBar

获取与此JToolBar关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JToolTip

获取与此JToolTip关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取与此树节点相关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JTree

获取与此JTree关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JViewport

获取与此JViewport关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. JWindow

获取与此JWindow关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing.plaf.basic. BasicComboPopup

获取与此BasicComboPopup关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing. ProgressMonitor

获得 AccessibleContext为 ProgressMonitor

getAccessibleContext() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

获取与此对象关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing.table. JTableHeader

获取与此JTableHeader关联的AccessibleContext。

getAccessibleContext() - Method in class javax.swing.text.html. HTMLEditorKit

返回与此编辑器工具包关联的AccessibleContext

getAccessibleContext() - Method in class javax.swing.text. JTextComponent

获取 AccessibleContext与此 JTextComponent相关联。

getAccessibleDescription() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的可访问描述。

getAccessibleDescription() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的可访问描述。

getAccessibleDescription() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的可访问描述。

getAccessibleDescription() - Method in class javax.accessibility. AccessibleContext

获取此对象的 accessibleDescription属性。

getAccessibleDescription() - Method in class javax.swing. JComponent.AccessibleJComponent

获取此对象的可访问描述。

getAccessibleDescription() - Method in class javax.swing. JEditorPane.AccessibleJEditorPane

获取此对象的accessibleDescription属性。

getAccessibleDescription() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleDescription() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的可访问描述。

getAccessibleDescription() - Method in class javax.swing. JToolTip.AccessibleJToolTip

获取此对象的可访问描述。

getAccessibleDescription() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取此对象的可访问描述。

getAccessibleDescription() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取此对象的accessibleDescription属性。

getAccessibleDescription() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleEditableText() - Method in class javax.accessibility. AccessibleContext

获取与此对象关联的 AccessibleEditableText ，该对象在显示屏上显示可编辑文本。

getAccessibleEditableText() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回此文本组件的AccessibleEditableText接口。

getAccessibleHelp() - Method in class javafx.scene. Node

获取属性accessibleHelp的值。

getAccessibleIcon() - Method in class javax.accessibility. AccessibleContext

获取与具有一个或多个关联图标的对象相关联的 AccessibleIcons 。

getAccessibleIcon() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

如果有一个或多个存在，获取与该对象相关联的AccessibleIcons。

getAccessibleIcon() - Method in class javax.swing. JLabel.AccessibleJLabel

如果有一个或多个存在，获取与该对象相关联的AccessibleIcons。

getAccessibleIcon() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

如果渲染器组件不包含图标，则返回元素渲染器的图标，作为 AccessibleIcon或 null阵列的 null数组。

getAccessibleIconDescription() - Method in interface javax.accessibility. AccessibleIcon

获取图标的描述。

getAccessibleIconDescription() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

获取图标的描述。

getAccessibleIconHeight() - Method in interface javax.accessibility. AccessibleIcon

获取图标的高度。

getAccessibleIconHeight() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

获取图标的高度。

getAccessibleIconWidth() - Method in interface javax.accessibility. AccessibleIcon

获取图标的宽度。

getAccessibleIconWidth() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

获取图标的宽度。

getAccessibleIndex(int, int) - Method in interface javax.accessibility. AccessibleExtendedTable

返回表中行和列的索引。

getAccessibleIndex(int, int) - Method in class javax.swing. JTable.AccessibleJTable

返回表中行和列的索引。

getAccessibleIndexAt(int, int) - Method in class javax.swing. JTable.AccessibleJTable

返回表中给定（行，列）的索引。

getAccessibleIndexInParent() - Method in class com.sun.java.accessibility.util. Translator

在其可访问的父项中获取此对象的索引。

getAccessibleIndexInParent() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象在其可访问父级中的索引。

getAccessibleIndexInParent() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

在其可访问的父项中获取此对象的基于0的索引。

getAccessibleIndexInParent() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象在其可访问父级中的索引。

getAccessibleIndexInParent() - Method in class javax.accessibility. AccessibleContext

在其可访问的父项中获取此对象的基于0的索引。

getAccessibleIndexInParent() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

获取此对象在其可访问父级中的索引。

getAccessibleIndexInParent() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleIndexInParent() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象在其可访问父级中的索引。

getAccessibleIndexInParent() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

在其可访问的父项中获取此对象的索引。

getAccessibleIndexInParent() - Method in class javax.swing. JTree.AccessibleJTree

在其可访问的父项中获取此对象的索引。

getAccessibleIndexInParent() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

在其可访问的父项中获取此对象的基于0的索引。

getAccessibleIndexInParent() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleIndexInParent(Component) - Static method in class javax.swing. SwingUtilities

在其可访问的父项中获取此对象的索引。

getAccessibleKeyBinding() - Method in interface javax.accessibility. AccessibleExtendedComponent

返回与此对象关联的键绑定。

getAccessibleKeyBinding() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回与此对象关联的键绑定

getAccessibleKeyBinding() - Method in class javax.swing. JComponent.AccessibleJComponent

返回与此对象关联的键绑定

getAccessibleKeyBinding() - Method in class javax.swing. JLabel.AccessibleJLabel

返回与此对象关联的键绑定

getAccessibleKeyBinding(int) - Method in interface javax.accessibility. AccessibleKeyBinding

返回此对象的键绑定。

getAccessibleKeyBindingCount() - Method in interface javax.accessibility. AccessibleKeyBinding

返回此对象的键绑定数。

getAccessibleName() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的可访问名称。

getAccessibleName() - Method in class java.awt. Button.AccessibleAWTButton

获取此对象的可访问名称。

getAccessibleName() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的可访问名称。

getAccessibleName() - Method in class java.awt. Label.AccessibleAWTLabel

获取此对象的可访问名称。

getAccessibleName() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的可访问名称。

getAccessibleName() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.accessibility. AccessibleContext

获取此对象的 accessibleName属性。

getAccessibleName() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. JComponent.AccessibleJComponent

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. JDialog.AccessibleJDialog

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. JFrame.AccessibleJFrame

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. JInternalFrame.AccessibleJInternalFrame

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. JLabel.AccessibleJLabel

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleName() - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

返回此对象的可访问名称，如果没有可访问名称，则返回 null 。

getAccessibleName() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取此对象的可访问名称。

getAccessibleName() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取此对象的accessibleName属性。

getAccessibleName() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleParent() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的可访问父级。

getAccessibleParent() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的 Accessible父项。

getAccessibleParent() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的父母 Accessible 。

getAccessibleParent() - Method in class javax.accessibility. AccessibleContext

获取此对象的 Accessible父项。

getAccessibleParent() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

获取此对象的可访问父项。

getAccessibleParent() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的 Accessible父项。

getAccessibleParent() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取此对象的Accessible父项。

getAccessibleParent() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取此对象的可访问父项。

getAccessibleRelationSet() - Method in class javax.accessibility. AccessibleContext

获取与对象关联的 AccessibleRelationSet 。

getAccessibleRelationSet() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

获取与此对象关联的AccessibleRelationSet（如果存在）。

getAccessibleRelationSet() - Method in class javax.swing. JLabel.AccessibleJLabel

获取与此对象关联的AccessibleRelationSet（如果存在）。

getAccessibleRole() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的角色。

getAccessibleRole() - Method in class java.applet. Applet.AccessibleApplet

已过时。

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Button.AccessibleAWTButton

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Canvas.AccessibleAWTCanvas

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Choice.AccessibleAWTChoice

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Component.AccessibleAWTComponent

获得此对象的作用。

getAccessibleRole() - Method in class java.awt. Dialog.AccessibleAWTDialog

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Frame.AccessibleAWTFrame

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Label.AccessibleAWTLabel

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. List.AccessibleAWTList

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Menu.AccessibleAWTMenu

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. MenuBar.AccessibleAWTMenuBar

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获得此对象的作用。

getAccessibleRole() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Panel.AccessibleAWTPanel

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. PopupMenu.AccessibleAWTPopupMenu

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. Scrollbar.AccessibleAWTScrollBar

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. ScrollPane.AccessibleAWTScrollPane

获取此对象的角色。

getAccessibleRole() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

获得此对象的作用。

getAccessibleRole() - Method in class java.awt. Window.AccessibleAWTWindow

获取此对象的角色。

getAccessibleRole() - Method in class javafx.scene. Node

获取属性accessibilityRole的值。

getAccessibleRole() - Method in class javax.accessibility. AccessibleContext

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. Box.AccessibleBox

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. Box.Filler.AccessibleBoxFiller

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. CellRendererPane.AccessibleCellRendererPane

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JButton.AccessibleJButton

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JCheckBox.AccessibleJCheckBox

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JColorChooser.AccessibleJColorChooser

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JComboBox.AccessibleJComboBox

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JComponent.AccessibleJComponent

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JDesktopPane.AccessibleJDesktopPane

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JFileChooser.AccessibleJFileChooser

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JInternalFrame.AccessibleJInternalFrame

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JLabel.AccessibleJLabel

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JLayeredPane.AccessibleJLayeredPane

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleRole() - Method in class javax.swing. JList.AccessibleJList

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JMenu.AccessibleJMenu

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JMenuItem.AccessibleJMenuItem

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JOptionPane.AccessibleJOptionPane

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JPanel.AccessibleJPanel

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JPopupMenu.AccessibleJPopupMenu

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JProgressBar.AccessibleJProgressBar

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JRadioButton.AccessibleJRadioButton

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JRootPane.AccessibleJRootPane

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JScrollBar.AccessibleJScrollBar

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JScrollPane.AccessibleJScrollPane

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JSeparator.AccessibleJSeparator

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JSlider.AccessibleJSlider

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JSpinner.AccessibleJSpinner

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JSplitPane.AccessibleJSplitPane

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JTable.AccessibleJTable

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing. JToggleButton.AccessibleJToggleButton

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JToolBar.AccessibleJToolBar

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JToolTip.AccessibleJToolTip

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JTree.AccessibleJTree

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. JViewport.AccessibleJViewport

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获得此对象的作用。

getAccessibleRole() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleRole() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader

获取此对象的角色。

getAccessibleRole() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

获得此对象的作用。

getAccessibleRoleDescription() - Method in class javafx.scene. Node

获取属性accessibilityRoleDescription的值。

getAccessibleRow(int) - Method in interface javax.accessibility. AccessibleExtendedTable

返回表中索引的行号。

getAccessibleRow(int) - Method in class javax.swing. JTable.AccessibleJTable

返回表中索引的行号。

getAccessibleRowAtIndex(int) - Method in class javax.swing. JTable.AccessibleJTable

将给定索引的行返回到表中。

getAccessibleRowCount() - Method in interface javax.accessibility. AccessibleTable

返回表中的行数。

getAccessibleRowCount() - Method in class javax.swing. JTable.AccessibleJTable

getAccessibleRowDescription(int) - Method in interface javax.accessibility. AccessibleTable

返回表中指定行的描述。

getAccessibleRowDescription(int) - Method in class javax.swing. JTable.AccessibleJTable

返回表中指定行的描述。

getAccessibleRowExtentAt(int, int) - Method in interface javax.accessibility. AccessibleTable

返回表中指定行和列的 Accessible占用的行数。

getAccessibleRowExtentAt(int, int) - Method in class javax.swing. JTable.AccessibleJTable

返回表中指定行和列的 Accessible占用的行数。

getAccessibleRowHeader() - Method in interface javax.accessibility. AccessibleTable

返回行标题为 AccessibleTable 。

getAccessibleRowHeader() - Method in class javax.swing. JTable.AccessibleJTable

返回行标题为 AccessibleTable 。

getAccessibleSelection() - Method in class java.awt. List.AccessibleAWTList

获取与此对象关联的AccessibleSelection。

getAccessibleSelection() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取与此对象关联的 AccessibleSelection ，允许其 Accessible孩子被选中。

getAccessibleSelection() - Method in class javax.accessibility. AccessibleContext

获取与此对象关联的 AccessibleSelection ，允许其 Accessible孩子被选中。

getAccessibleSelection() - Method in class javax.swing. JComboBox.AccessibleJComboBox

获取与此对象关联的AccessibleSelection。

getAccessibleSelection() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleSelection() - Method in class javax.swing. JList.AccessibleJList

获取与此对象关联的AccessibleSelection。

getAccessibleSelection() - Method in class javax.swing. JMenu.AccessibleJMenu

获取与此对象关联的AccessibleSelection。

getAccessibleSelection() - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

获取与此对象关联的AccessibleSelection。

getAccessibleSelection() - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

获取与此对象关联的 AccessibleSelection 。

getAccessibleSelection() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取与此对象关联的 AccessibleSelection如果存在）。

getAccessibleSelection() - Method in class javax.swing. JTable.AccessibleJTable

获取与此对象关联的AccessibleSelection。

getAccessibleSelection() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取与此对象关联的AccessibleSelection（如果存在）。

getAccessibleSelection() - Method in class javax.swing. JTree.AccessibleJTree

获取与此对象关联的AccessibleSelection。

getAccessibleSelection() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleSelection(int) - Method in class java.awt. List.AccessibleAWTList

返回表示对象中指定的选定项的Accessible。

getAccessibleSelection(int) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回表示对象中指定的选定子项的 Accessible 。

getAccessibleSelection(int) - Method in interface javax.accessibility. AccessibleSelection

返回表示对象的指定选定子对象的 Accessible 。

getAccessibleSelection(int) - Method in class javax.swing. JComboBox.AccessibleJComboBox

返回代表弹出窗口中指定的选定子项的Accessible。

getAccessibleSelection(int) - Method in class javax.swing. JList.AccessibleJList

返回表示对象中指定的选定项的Accessible。

getAccessibleSelection(int) - Method in class javax.swing. JMenu.AccessibleJMenu

如果选择了一个，返回当前选择的子菜单，否则为空（只能有一个选项，只能是子菜单，否则菜单项不会被选中）。

getAccessibleSelection(int) - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

如果选择了一个菜单，返回当前选择的菜单，否则返回null。

getAccessibleSelection(int) - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

getAccessibleSelection(int) - Method in class javax.swing. JTable.AccessibleJTable

返回表示对象中指定的选定子项的 Accessible 。

getAccessibleSelection(int) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回表示对象中指定的选定项的Accessible。

getAccessibleSelection(int) - Method in class javax.swing. JTree.AccessibleJTree

返回表示对象中指定的选定项的Accessible。

getAccessibleSelectionCount() - Method in class java.awt. List.AccessibleAWTList

返回当前选择的项目数。

getAccessibleSelectionCount() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回当前选择的 Accessible孩子的数量。

getAccessibleSelectionCount() - Method in interface javax.accessibility. AccessibleSelection

返回当前选择的 Accessible孩子的数量。

getAccessibleSelectionCount() - Method in class javax.swing. JComboBox.AccessibleJComboBox

返回当前选择的可访问儿童的数量。

getAccessibleSelectionCount() - Method in class javax.swing. JList.AccessibleJList

返回当前选择的项目数。

getAccessibleSelectionCount() - Method in class javax.swing. JMenu.AccessibleJMenu

如果当前在此菜单中选择了子菜单，则返回1。

getAccessibleSelectionCount() - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

如果当前在此菜单栏中选择菜单，则返回1。

getAccessibleSelectionCount() - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

getAccessibleSelectionCount() - Method in class javax.swing. JTable.AccessibleJTable

Accessible

getAccessibleSelectionCount() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回当前选择的项目数。

getAccessibleSelectionCount() - Method in class javax.swing. JTree.AccessibleJTree

返回当前选择的项目数。

getAccessibleStateSet() - Method in class com.sun.java.accessibility.util. Translator

给定一个已经填充的状态的这个对象的状态。

getAccessibleStateSet() - Method in class java.applet. Applet.AccessibleApplet

已过时。

获取此对象的状态。

getAccessibleStateSet() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

获取此对象的状态集。

getAccessibleStateSet() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的状态。

getAccessibleStateSet() - Method in class java.awt. Dialog.AccessibleAWTDialog

获取此对象的状态。

getAccessibleStateSet() - Method in class java.awt. Frame.AccessibleAWTFrame

获取此对象的状态。

getAccessibleStateSet() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的状态集。

getAccessibleStateSet() - Method in class java.awt. List.AccessibleAWTList

获取此对象的状态集。

getAccessibleStateSet() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的状态。

getAccessibleStateSet() - Method in class java.awt. Scrollbar.AccessibleAWTScrollBar

获取此对象的状态集。

getAccessibleStateSet() - Method in class java.awt. TextArea.AccessibleAWTTextArea

获取此对象的状态集。

getAccessibleStateSet() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

获取TextComponent的状态集。

getAccessibleStateSet() - Method in class java.awt. TextField.AccessibleAWTTextField

获取此对象的状态集。

getAccessibleStateSet() - Method in class java.awt. Window.AccessibleAWTWindow

获取此对象的状态。

getAccessibleStateSet() - Method in class javax.accessibility. AccessibleContext

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

获取此对象的状态。

getAccessibleStateSet() - Method in class javax.swing. JComboBox.AccessibleJComboBox

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JComponent.AccessibleJComponent

获取此对象的状态。

getAccessibleStateSet() - Method in class javax.swing. JDialog.AccessibleJDialog

获取此对象的状态。

getAccessibleStateSet() - Method in class javax.swing. JEditorPane.AccessibleJEditorPane

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JFrame.AccessibleJFrame

获取此对象的状态。

getAccessibleStateSet() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleStateSet() - Method in class javax.swing. JList.AccessibleJList

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

获取此对象的可访问状态集。

getAccessibleStateSet() - Method in class javax.swing. JProgressBar.AccessibleJProgressBar

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JScrollBar.AccessibleJScrollBar

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JSlider.AccessibleJSlider

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JSplitPane.AccessibleJSplitPane

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JTextArea.AccessibleJTextArea

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JTextField.AccessibleJTextField

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. JToolBar.AccessibleJToolBar

获取此对象的状态。

getAccessibleStateSet() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取此对象的状态集。

getAccessibleStateSet() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleStateSet() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

获取JTextComponent的状态集。

getAccessibleStateSet(Component) - Static method in class javax.swing. SwingUtilities

获取此对象的状态。

getAccessibleSummary() - Method in interface javax.accessibility. AccessibleTable

返回表的摘要说明。

getAccessibleSummary() - Method in class javax.swing. JTable.AccessibleJTable

返回表的摘要说明。

getAccessibleTable() - Method in class javax.accessibility. AccessibleContext

获取与对象关联的 AccessibleTable 。

getAccessibleTable() - Method in class javax.swing. JTable.AccessibleJTable

获取与此对象关联的 AccessibleTable 。

getAccessibleText() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

获取与此对象关联的AccessibleText。

getAccessibleText() - Method in class javafx.scene. Node

获取属性accessibleText的值。

getAccessibleText() - Method in class javax.accessibility. AccessibleContext

获取与该对象相关联的 AccessibleText在显示器上显示文本。

getAccessibleText() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

getAccessibleText() - Method in class javax.swing. JEditorPane.AccessibleJEditorPaneHTML

返回可访问的文本。

getAccessibleText() - Method in class javax.swing. JLabel.AccessibleJLabel

getAccessibleText() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleText() - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

获得 AccessibleText的 JPasswordField 。

getAccessibleText() - Method in class javax.swing. JSpinner.AccessibleJSpinner

获取与该对象相关联的AccessibleText在显示器上呈现文本。

getAccessibleText() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取与此对象关联的 AccessibleText如果存在）。

getAccessibleText() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取与此对象关联的AccessibleText（如果存在）。

getAccessibleText() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取与该对象相关联的AccessibleText在显示器上呈现文本。

getAccessibleText() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleText() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

获取与此对象关联的AccessibleText。

getAccessibleValue() - Method in class java.awt. Button.AccessibleAWTButton

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class java.awt. Scrollbar.AccessibleAWTScrollBar

获取与此对象关联的 AccessibleValue 。

getAccessibleValue() - Method in class javax.accessibility. AccessibleContext

获取与此对象关联的 AccessibleValue ，该对象支持 Numerical值。

getAccessibleValue() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class javax.swing. JInternalFrame.AccessibleJInternalFrame

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class javax.swing. JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getAccessibleValue() - Method in class javax.swing. JProgressBar.AccessibleJProgressBar

获取与此对象关联的 AccessibleValue 。

getAccessibleValue() - Method in class javax.swing. JScrollBar.AccessibleJScrollBar

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class javax.swing. JSlider.AccessibleJSlider

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class javax.swing. JSpinner.AccessibleJSpinner

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class javax.swing. JSplitPane.AccessibleJSplitPane

获取与此对象关联的AccessibleValue。

getAccessibleValue() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取与此对象关联的 AccessibleValue如果存在）。

getAccessibleValue() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取与此对象关联的AccessibleValue（如果存在）。

getAccessibleValue() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取与此对象关联的AccessibleValue，该对象支持数值。

getAccessibleValue() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessKey() - Method in interface org.w3c.dom.html. HTMLAnchorElement

单个字符访问键可以访问表单控件。

getAccessKey() - Method in interface org.w3c.dom.html. HTMLAreaElement

单个字符访问键可以访问表单控件。

getAccessKey() - Method in interface org.w3c.dom.html. HTMLButtonElement

单个字符访问键可以访问表单控件。

getAccessKey() - Method in interface org.w3c.dom.html. HTMLInputElement

单个字符访问键可以访问表单控件。

getAccessKey() - Method in interface org.w3c.dom.html. HTMLLabelElement

单个字符访问键可以访问表单控件。

getAccessKey() - Method in interface org.w3c.dom.html. HTMLLegendElement

单个字符访问键可以访问表单控件。

getAccessKey() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

单个字符访问键可以访问表单控件。

getAccessLevel() - Method in class javax.tools. ForwardingJavaFileObject

getAccessLevel() - Method in interface javax.tools. JavaFileObject

提供关于由该文件对象表示的类的访问级别的提示。

getAccessLevel() - Method in class javax.tools. SimpleJavaFileObject

此实现返回 null 。

getAccessory() - Method in class javax.swing. JFileChooser

返回附件组件。

getAccessoryPanel() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回附件面板。

getACHuffmanTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageReadParam

返回在最近调用 setDecodeTables或 null如果表当前未设置）时设置的AC Huffman表数组的副本。

getACHuffmanTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的AC Huffman表数组的副本。

getAcl() - Method in interface java.nio.file.attribute. AclFileAttributeView

读取访问控制列表。

getAcquire() - Method in class java.util.concurrent.atomic. AtomicBoolean

返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。

getAcquire() - Method in class java.util.concurrent.atomic. AtomicInteger

返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。

getAcquire() - Method in class java.util.concurrent.atomic. AtomicLong

返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。

getAcquire() - Method in class java.util.concurrent.atomic. AtomicReference

返回当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。

getAcquire(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

返回索引号为 i的元素的当前值，由 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。

getAcquire(int) - Method in class java.util.concurrent.atomic. AtomicLongArray

返回索引号为 i的元素的当前值，具有 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。

getAcquire(int) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

返回索引号为 i的元素的当前值，由 VarHandle.getAcquire(java.lang.Object...)指定的内存效果。

getAcquire(Object...) - Method in class java.lang.invoke. VarHandle

返回变量的值，并确保后续加载和存储在此访问之前未重新排序。

getAction() - Method in class java.beans. EventHandler

返回此事件处理程序将设置的目标的可写属性的名称，或此事件处理程序将在目标上调用的方法的名称。

getAction() - Method in class javax.swing. AbstractButton

返回当前设置 Action这个 ActionEvent源，或者 null如果没有 Action设置。

getAction() - Method in class javax.swing. JComboBox

返回当前设置 Action这个 ActionEvent源，或者 null如果没有 Action设置。

getAction() - Method in class javax.swing. JTextField

返回当前设置 Action这个 ActionEvent源，或者 null如果没有 Action设置。

getAction() - Method in interface org.w3c.dom.html. HTMLFormElement

服务器端表单处理程序。

getAction(KeyStroke) - Method in interface javax.swing.text. Keymap

获取适合于给定符号事件序列的动作。

getActionCommand() - Method in class java.awt. Button

返回此按钮触发的操作事件的命令名称。

getActionCommand() - Method in class java.awt.event. ActionEvent

返回与此操作相关联的命令字符串。

getActionCommand() - Method in class java.awt. MenuItem

获取此菜单项触发的操作事件的命令名称。

getActionCommand() - Method in class java.awt. TrayIcon

返回此托盘图标触发的操作事件的命令名称。

getActionCommand() - Method in class javax.swing. AbstractButton

返回此按钮的动作命令。

getActionCommand() - Method in interface javax.swing. ButtonModel

返回按钮的动作命令字符串。

getActionCommand() - Method in class javax.swing. DefaultButtonModel

返回按钮的动作命令字符串。

getActionCommand() - Method in class javax.swing. JComboBox

返回发送到动作侦听器的事件中包含的动作命令。

getActionCommand() - Method in class javax.swing. Timer

返回此定时器触发的 ActionEvent的action命令将要传递的字符串。

getActionForKeyStroke(KeyStroke) - Method in class javax.swing. JComponent

返回将执行为给定键击注册的操作的对象。

getActionListeners() - Method in class java.awt. Button

返回在此按钮上注册的所有动作侦听器的数组。

getActionListeners() - Method in class java.awt. List

返回在此列表中注册的所有动作侦听器的数组。

getActionListeners() - Method in class java.awt. MenuItem

返回在此菜单项上注册的所有动作侦听器的数组。

getActionListeners() - Method in class java.awt. TextField

返回在此文本域中注册的所有操作侦听器的数组。

getActionListeners() - Method in class java.awt. TrayIcon

返回在此 TrayIcon上注册的所有动作侦听器的数组。

getActionListeners() - Method in class javax.swing. AbstractButton

返回使用addActionListener（）添加到此AbstractButton的所有 ActionListener的数组。

getActionListeners() - Method in class javax.swing. DefaultButtonModel

返回在此 DefaultButtonModel上注册的所有动作侦听器的数组。

getActionListeners() - Method in class javax.swing. JComboBox

返回使用addActionListener（）添加到此JComboBox的所有 ActionListener的数组。

getActionListeners() - Method in class javax.swing. JFileChooser

返回在此文件选择器上注册的所有动作侦听器的数组。

getActionListeners() - Method in class javax.swing. JTextField

返回使用addActionListener（）添加到此JTextField的所有 ActionListener的数组。

getActionListeners() - Method in class javax.swing. Timer

返回在此定时器上注册的所有动作侦听器的数组。

getActionMap() - Method in class javax.swing. JComponent

返回 ActionMap用于确定什么 Action为特定的 KeyStroke绑定。

getActionMap() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

返回一个 ActionMap的实例。

getActions() - Method in class java.io. FilePermission

返回动作的“规范字符串表示”。

getActions() - Method in class java.net. SocketPermission

返回动作的规范字符串表示形式。

getActions() - Method in class java.net. URLPermission

返回标准化方法列表和请求头列表，格式如下：

getActions() - Method in class java.security. AllPermission

返回动作的规范字符串表示形式。

getActions() - Method in class java.security. BasicPermission

返回动作的规范字符串表示形式，它当前是空字符串“”，因为BasicPermission没有任何操作。

getActions() - Method in class java.security. Permission

以String形式返回操作。

getActions() - Method in class java.security. UnresolvedPermission

返回动作的规范字符串表示形式，它当前是空字符串“”，因为UnresolvedPermission没有任何操作。

getActions() - Method in class java.util. PropertyPermission

返回动作的“规范字符串表示”。

getActions() - Method in class javax.management. MBeanPermission

返回动作的“规范字符串表示”。

getActions() - Method in class javax.security.auth.kerberos. ServicePermission

返回动作的规范字符串表示形式。

getActions() - Method in class javax.security.auth. PrivateCredentialPermission

返回动作的“规范字符串表示”。

getActions() - Method in class javax.smartcardio. CardPermission

返回动作的规范字符串表示形式。

getActions() - Method in class javax.swing. JFormattedTextField.AbstractFormatter

子类和覆盖，如果你想提供一个自定义的一组 Action s。

getActions() - Method in class javax.swing. JFormattedTextField

获取编辑器的命令列表。

getActions() - Method in class javax.swing. JTextField

获取编辑器的命令列表。

getActions() - Method in class javax.swing.text. DefaultEditorKit

获取可用于使用此套件生成的模型和视图的文本组件的一组命令。

getActions() - Method in class javax.swing.text. EditorKit

获取可用于使用此套件生成的模型和视图的文本组件的一组命令。

getActions() - Method in class javax.swing.text.html. HTMLEditorKit

获取编辑器的命令列表。

getActions() - Method in class javax.swing.text. InternationalFormatter

如果 getSupportsIncrement返回true，则返回两个适用于递增/递减值的动作。

getActions() - Method in class javax.swing.text. JTextComponent

获取编辑器的命令列表。

getActions() - Method in class javax.swing.text. StyledEditorKit

获取编辑器的命令列表。

getActivationDesc(ActivationID) - Method in interface java.rmi.activation. ActivationSystem

返回激活描述符，对于具有激活标识符的对象， id 。

getActivationGroupDesc(ActivationGroupID) - Method in interface java.rmi.activation. ActivationSystem

返回激活组描述符，对于具有激活组标识符的组 id 。

getActiveCount() - Method in class java.util.concurrent. ThreadPoolExecutor

返回正在执行任务的线程的大概数量。

getActiveThreadCount() - Method in class java.util.concurrent. ForkJoinPool

返回当前正在窃取或执行任务的线程数的估计。

getActiveWindow() - Method in class java.awt. KeyboardFocusManager

如果活动窗口与调用线程处于相同的上下文中，则返回活动窗口。

getActor() - Method in interface javax.xml.soap. SOAPHeaderElement

返回此 SOAPHeaderElement的 actor属性的uri。

getActualMaximum(int) - Method in class java.util. Calendar

给定此 Calendar的时间值，返回指定日历字段可能具有的 Calendar 。

getActualMaximum(int) - Method in class java.util. GregorianCalendar

返回此日历字段可能有，考虑到给定的时间值和的当前值中的最大值 getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和 getTimeZone方法。

getActualMinimum(int) - Method in class java.util. Calendar

给定此 Calendar的时间值，返回指定日历字段可能具有的 Calendar 。

getActualMinimum(int) - Method in class java.util. GregorianCalendar

返回此日历字段可能有，考虑到给定的时间值和的当前值的最小值 getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和 getTimeZone方法。

getActualTypeArguments() - Method in interface java.lang.reflect. ParameterizedType

返回一个 Type对象的数组，表示此类型的实际类型参数。

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

getAdapter(Class<A>) - Method in interface javax.xml.bind. Marshaller

获取与指定类型相关联的适配器。

getAdapter(Class<A>) - Method in interface javax.xml.bind. Unmarshaller

获取与指定类型相关联的适配器。

getAddedChildren() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent

返回在此事件中添加到TreeItem的子项，如果未添加子项，则返回空列表。

getAddedSize() - Method in class javafx.collections. ListChangeListener.Change

添加的间隔的大小

getAddedSize() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent

返回在此事件中添加的子项目数，如果未添加子项，则返回零。

getAddedSubList() - Method in class javafx.collections. ListChangeListener.Change

要获取仅包含元素的列表的子列表视图，请使用getAddedSubList（）方法。

getAdditionalBeanInfo() - Method in interface java.beans. BeanInfo

此方法使当前的 BeanInfo对象能够返回任何其他 BeanInfo对象的集合， BeanInfo对象提供有关当前bean的附加信息。

getAdditionalBeanInfo() - Method in class java.beans. SimpleBeanInfo

声明没有其他相关的BeanInfo对象。

getAdditionalHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.FileIcon16

返回图标的附加高度。

getAdditionalHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.FolderIcon16

返回图标的附加高度。

getAdditionalHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeFolderIcon

getAdditionalHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeLeafIcon

getAdditionalInput() - Method in class java.security. DrbgParameters.NextBytes

返回请求的附加输入。

getAdditionalInput() - Method in class java.security. DrbgParameters.Reseed

返回请求的附加输入。

getAddListenerMethod() - Method in class java.beans. EventSetDescriptor

获取用于添加事件侦听器的方法。

getAddress() - Method in class com.sun.net.httpserver. HttpServer

返回服务器正在侦听的地址

getAddress() - Method in class java.net. DatagramPacket

返回该数据报发送或接收数据报的计算机的IP地址。

getAddress() - Method in class java.net. Inet4Address

返回此 InetAddress对象的原始IP地址。

getAddress() - Method in class java.net. Inet6Address

返回此 InetAddress对象的原始IP地址。

getAddress() - Method in class java.net. InetAddress

返回此 InetAddress对象的原始IP地址。

getAddress() - Method in class java.net. InetSocketAddress

获得 InetAddress 。

getAddress() - Method in class java.net. InterfaceAddress

返回此地址的 InetAddress 。

getAddress() - Method in interface javax.management.remote. JMXAddressable

这个对象的地址。

getAddress() - Method in interface javax.management.remote. JMXConnectorServerMBean

该连接器服务器的地址。

getAddress() - Method in class javax.management.remote.rmi. RMIConnector

该连接器的地址。

getAddress() - Method in class javax.management.remote.rmi. RMIConnectorServer

getAdjustable() - Method in class java.awt.event. AdjustmentEvent

返回此事件发生的 Adjustable对象。

getAdjustmentListeners() - Method in class java.awt. Scrollbar

返回在此滚动条上注册的所有调整监听器的数组。

getAdjustmentListeners() - Method in class java.awt. ScrollPaneAdjustable

返回在这个 ScrollPaneAdjustable上注册的所有调整监听器的数组。

getAdjustmentListeners() - Method in class javax.swing. JScrollBar

返回使用addAdjustmentListener（）添加到此JScrollBar的所有 AdjustmentListener的数组。

getAdjustmentType() - Method in class java.awt.event. AdjustmentEvent

返回导致值更改事件的调整类型。

getAdler() - Method in class java.util.zip. Deflater

返回未压缩数据的ADLER-32值。

getAdler() - Method in class java.util.zip. Inflater

返回未压缩数据的ADLER-32值。

getAdvance() - Method in class java.awt.font. GlyphMetrics

返回字符沿基线的前进（水平或垂直）。

getAdvance() - Method in class java.awt.font. GraphicAttribute

返回此 GraphicAttribute 。

getAdvance() - Method in class java.awt.font. ImageGraphicAttribute

返回此 ImageGraphicAttribute 。

getAdvance() - Method in class java.awt.font. ShapeGraphicAttribute

返回此 ShapeGraphicAttribute 。

getAdvance() - Method in class java.awt.font. TextLayout

返回此 TextLayout 。

getAdvanceBetween(int, int) - Method in class java.awt.font. TextMeasurer

返回从 start开始的行的图形宽度，其中包含高达 limit字符。

getAdvanceX() - Method in class java.awt.font. GlyphMetrics

返回字形前进的x分量。

getAdvanceY() - Method in class java.awt.font. GlyphMetrics

返回字形前进的y分量。

getAffineX() - Method in class java.security.spec. ECPoint

返回仿射x坐标 x 。

getAffineY() - Method in class java.security.spec. ECPoint

返回仿射y坐标 y 。

getAfterIndex(int, int) - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回给定索引后的String。

getAfterIndex(int, int) - Method in interface javax.accessibility. AccessibleText

给定索引后返回 String 。

getAfterIndex(int, int) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回给定索引后的String。

getAfterIndex(int, int) - Method in class javax.swing. JLabel.AccessibleJLabel

返回给定索引后的String。

getAfterIndex(int, int) - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

返回 String给定后 index 。

getAfterIndex(int, int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回给定索引后的String。

getAfterIndex(int, int) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回给定索引后的String。

getAfterIndex(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回给定索引后的String。

getAgentProperties() - Method in class com.sun.tools.attach. VirtualMachine

返回目标虚拟机中的当前 代理属性 。

getAlertType() - Method in class javafx.scene.control. Alert

获取属性alertType的值。

getAlgName() - Method in class javax.crypto. EncryptedPrivateKeyInfo

返回加密算法。

getAlgorithm() - Method in class java.security. AlgorithmParameterGenerator

返回此参数生成器关联的算法的标准名称。

getAlgorithm() - Method in class java.security. AlgorithmParameters

返回与此参数对象关联的算法的名称。

getAlgorithm() - Method in class java.security.cert. CertPathBuilder

返回此 CertPathBuilder算法的 CertPathBuilder 。

getAlgorithm() - Method in class java.security.cert. CertPathValidator

返回此 CertPathValidator的算法名称。

getAlgorithm() - Method in interface java.security. Key

返回此键的标准算法名称。

getAlgorithm() - Method in class java.security. KeyFactory

获取与此 KeyFactory相关联的算法的名称。

getAlgorithm() - Method in class java.security. KeyPairGenerator

返回此密钥对生成器的算法的标准名称。

getAlgorithm() - Method in class java.security. MessageDigest

返回一个标识算法的字符串，与实现细节无关。

getAlgorithm() - Method in class java.security. Provider.Service

返回此服务的算法的名称。

getAlgorithm() - Method in class java.security. SecureRandom

返回由此 SecureRandom对象实现的算法的名称。

getAlgorithm() - Method in class java.security. Signature

返回此签名对象的算法名称。

getAlgorithm() - Method in class java.security. SignedObject

检索签名算法的名称。

getAlgorithm() - Method in class java.security.spec. EncodedKeySpec

返回编码密钥算法的名称。

getAlgorithm() - Method in class javax.crypto. Cipher

返回此 Cipher对象的算法名称。

getAlgorithm() - Method in class javax.crypto. KeyAgreement

返回此 KeyAgreement对象的算法名称。

getAlgorithm() - Method in class javax.crypto. KeyGenerator

返回此 KeyGenerator对象的算法名称。

getAlgorithm() - Method in class javax.crypto. Mac

返回此 Mac对象的算法名称。

getAlgorithm() - Method in class javax.crypto. SealedObject

返回用于密封此对象的算法。

getAlgorithm() - Method in class javax.crypto. SecretKeyFactory

返回此 SecretKeyFactory对象的算法名称。

getAlgorithm() - Method in class javax.crypto.spec. PSource

返回PSource算法名称。

getAlgorithm() - Method in class javax.crypto.spec. SecretKeySpec

返回与该密钥相关联的算法的名称。

getAlgorithm() - Method in class javax.net.ssl. KeyManagerFactory

返回此 KeyManagerFactory对象的算法名称。

getAlgorithm() - Method in class javax.net.ssl. TrustManagerFactory

返回此 TrustManagerFactory对象的算法名称。

getAlgorithm() - Method in class javax.security.auth.kerberos. EncryptionKey

返回此键的标准算法名称。

getAlgorithm() - Method in class javax.security.auth.kerberos. KerberosKey

返回此键的标准算法名称。

getAlgorithm() - Method in interface javax.xml.crypto. AlgorithmMethod

返回此 AlgorithmMethod的算法URI。

getAlgorithm() - Method in class javax.xml.crypto.dsig. TransformService

返回此 TransformService支持的算法的URI。

getAlgorithmConstraints() - Method in class javax.net.ssl. SSLParameters

返回加密算法约束。

getAlgorithmProperty(String, String) - Static method in class java.security. Security

已过时。
此方法用于返回“SUN”加密服务提供程序的主文件中的专有属性的值，以确定如何解析特定于算法的参数。 AlgorithmParameters使用新的基于提供者的和算法无关的AlgorithmParameters和KeyFactory引擎类（在J2SE版本1.2平台中引入）。

getAlgorithms(String) - Static method in class java.security. Security

返回一组字符串，其中包含指定Java加密服务的所有可用算法或类型的名称（例如Signature，MessageDigest，Cipher，Mac，KeyStore）。

getAlgParameters() - Method in class javax.crypto. EncryptedPrivateKeyInfo

返回加密算法使用的算法参数。

getAlias() - Method in class javax.security.auth.x500. X500PrivateCredential

返回KeyStore别名。

getAlign() - Method in interface org.w3c.dom.html. HTMLAppletElement

将对象（垂直或水平）与其周围文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLDivElement

水平文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLHeadingElement

水平文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLHRElement

将规则对齐在页面上。

getAlign() - Method in interface org.w3c.dom.html. HTMLIFrameElement

将对象（垂直或水平）与其周围文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLImageElement

将对象（垂直或水平）与其周围文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLInputElement

将对象（垂直或水平）与其周围文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLLegendElement

文本对齐相对于 FIELDSET 。

getAlign() - Method in interface org.w3c.dom.html. HTMLObjectElement

将对象（垂直或水平）与其周围文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLParagraphElement

水平文本对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLTableCaptionElement

相对于表的字幕对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLTableCellElement

数据在单元格中的水平对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLTableColElement

列中单元格数据的水平对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLTableElement

指定表的相对于文档的其余部分的位置。

getAlign() - Method in interface org.w3c.dom.html. HTMLTableRowElement

此行的单元格内的数据的水平对齐。

getAlign() - Method in interface org.w3c.dom.html. HTMLTableSectionElement

单元格中数据的水平对齐。

getAlignedSizeRequirements(SizeRequirements[]) - Static method in class javax.swing. SizeRequirements

确定对齐一组组件所需的总空间。

getAlignment() - Method in class java.awt. FlowLayout

获取此布局的对齐方式。

getAlignment() - Method in class java.awt.font. GraphicAttribute

返回这个 GraphicAttribute的对齐方式。

getAlignment() - Method in class java.awt. Label

获取此标签的当前对齐方式。

getAlignment() - Method in class javafx.scene.control. Labeled

获取属性对齐的值。

getAlignment() - Method in class javafx.scene.control. TextField

获取属性对齐的值。

getAlignment() - Method in class javafx.scene.layout. FlowPane

获取属性对齐的值。

getAlignment() - Method in class javafx.scene.layout. GridPane

获取属性对齐的值。

getAlignment() - Method in class javafx.scene.layout. HBox

获取属性对齐的值。

getAlignment() - Method in class javafx.scene.layout. StackPane

获取属性对齐的值。

getAlignment() - Method in class javafx.scene.layout. TilePane

获取属性对齐的值。

getAlignment() - Method in class javafx.scene.layout. VBox

获取属性对齐的值。

getAlignment() - Method in class javax.swing.text. TabStop

返回该选项卡的对齐方式（以整数形式）。

getAlignment(int) - Method in class javax.swing.text. BoxView

确定沿着轴的该视图的所需对准。

getAlignment(int) - Method in class javax.swing.text. ComponentView

确定沿着轴的该视图的所需对准。

getAlignment(int) - Method in class javax.swing.text. GlyphView

确定沿着轴的该视图的所需对准。

getAlignment(int) - Method in class javax.swing.text.html. BlockView

获得对齐。

getAlignment(int) - Method in class javax.swing.text.html. ImageView

确定沿着轴的该视图的所需对准。

getAlignment(int) - Method in class javax.swing.text.html. ListView

计算列表所需的形状。

getAlignment(int) - Method in class javax.swing.text. IconView

确定沿着轴的该视图的所需对准。

getAlignment(int) - Method in class javax.swing.text. ParagraphView

确定沿着轴的该视图的所需对准。

getAlignment(int) - Method in class javax.swing.text. View

确定沿着轴的该视图的所需对准。

getAlignment(Node) - Static method in class javafx.scene.layout. BorderPane

如果设置，返回小孩的对齐约束。

getAlignment(Node) - Static method in class javafx.scene.layout. StackPane

如果设置，返回小孩的对齐约束。

getAlignment(Node) - Static method in class javafx.scene.layout. TilePane

如果设置，返回小孩的对齐约束。

getAlignment(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取对齐设置。

getAlignmentX() - Method in class java.awt. Component

返回沿x轴的对齐方式。

getAlignmentX() - Method in class java.awt. Container

返回沿x轴的对齐方式。

getAlignmentX() - Method in class javax.swing. JComponent

覆盖 Container.getAlignmentX以返回水平对齐。

getAlignmentY() - Method in class java.awt. Component

返回沿着y轴的对齐。

getAlignmentY() - Method in class java.awt. Container

返回沿着y轴的对齐。

getAlignmentY() - Method in class javax.swing. JComponent

覆盖 Container.getAlignmentY以返回垂直对齐方式。

getAlignOnBaseline() - Method in class java.awt. FlowLayout

如果组件沿其基线垂直对齐，则返回true。

getALink() - Method in interface org.w3c.dom.html. HTMLBodyElement

活动链接的颜色（鼠标按钮向下，但在鼠标左键之前）。

getAll() - Method in class javax.naming. CompositeName

检索此复合名称的组件作为字符串的枚举。

getAll() - Method in class javax.naming. CompoundName

检索此复合名称的组件作为字符串的枚举。

getAll() - Method in interface javax.naming.directory. Attribute

检索属性值的枚举。

getAll() - Method in interface javax.naming.directory. Attributes

检索属性集中属性的枚举。

getAll() - Method in class javax.naming.directory. BasicAttribute

检索此属性值的枚举。

getAll() - Method in class javax.naming.directory. BasicAttributes

getAll() - Method in class javax.naming.ldap. LdapName

检索此名称的组件作为字符串的枚举。

getAll() - Method in interface javax.naming. Name

检索此名称的组件作为字符串的枚举。

getAll() - Method in class javax.naming. Reference

检索本参考文献中地址的列举。

getAll(String[]) - Method in class com.sun.management. GcInfo

getAll(String[]) - Method in interface javax.management.openmbean. CompositeData

返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。

getAll(String[]) - Method in class javax.management.openmbean. CompositeDataSupport

返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。

getAllAnnotationMirrors(Element) - Method in interface javax.lang.model.util. Elements

返回元素上 存在的所有注释，无论是直接存在还是通过继承存在。

getAllAttributeKeys() - Method in interface java.text. AttributedCharacterIterator

返回在迭代器的文本范围上定义的所有属性的关键字。

getAllAttributeKeys() - Static method in class javax.swing.text.html. CSS

返回所有可能的CSS属性键的集合。

getAllAttributeKeys() - Static method in class javax.swing.text.html. HTML

返回识别的HTML属性集。

getAllAttributes() - Method in interface javax.xml.soap. SOAPElement

返回一个 Iterator在所有的属性 Name对象在此 SOAPElement对象。

getAllAttributesAsQNames() - Method in interface javax.xml.soap. SOAPElement

将 Iterator中的所有属性返回 SOAPElement作为 QName对象。

getAllByName(String) - Static method in class java.net. InetAddress

给定主机的名称，根据系统上配置的名称服务返回其IP地址数组。

getAllCommands() - Method in class javax.activation. DataHandler

返回此类型数据的所有命令。

getAllCommands(String) - Method in class javax.activation. CommandMap

获取此类型的所有可用命令。

getAllCommands(String) - Method in class javax.activation. MailcapCommandMap

获取此MIME类型的MailcapCommandMap的此实例已知的所有mailcap文件中的所有可用命令。

getAllCommands(String, DataSource) - Method in class javax.activation. CommandMap

获取此类型的所有可用命令。

getAllFonts() - Method in class java.awt. GraphicsEnvironment

返回一个包含此 GraphicsEnvironment可用的所有字体的一点大小实例的 GraphicsEnvironment 。

getAllFrames() - Method in class javax.swing. JDesktopPane

返回目前在桌面上显示的所有 JInternalFrames 。

getAllFramesInLayer(int) - Method in class javax.swing. JDesktopPane

返回当前显示在桌面的指定图层中的所有 JInternalFrames 。

getAllHeaders() - Method in class javax.xml.soap. MimeHeaders

返回所有 MimeHeader在这个S MimeHeaders对象。

getAllLoadedClasses() - Method in interface java.lang.instrument. Instrumentation

返回当前由JVM加载的所有类的数组。

getAllLocalAddresses() - Method in class com.sun.nio.sctp. SctpChannel

返回此通道的套接字所绑定的所有套接字地址。

getAllLocalAddresses() - Method in class com.sun.nio.sctp. SctpMultiChannel

返回此通道的套接字所绑定的所有套接字地址。

getAllLocalAddresses() - Method in class com.sun.nio.sctp. SctpServerChannel

返回此通道的套接字所绑定的所有套接字地址。

getAllMembers(TypeElement) - Method in interface javax.lang.model.util. Elements

返回类型元素的所有成员，无论是继承还是直接声明。

getAllMimeHeaders() - Method in class javax.xml.soap. AttachmentPart

检索这一切的头 AttachmentPart对象为在一个迭代 MimeHeader对象。

getAllMimeHeaders() - Method in class javax.xml.soap. SOAPPart

检索这一切的头 SOAPPart对象为在一个迭代 MimeHeader对象。

getAllModuleElements() - Method in interface javax.lang.model.util. Elements

返回当前环境中的所有模块元素。

getAllNotificationIDs() - Method in class javax.management.timer. Timer

获取注册到通知列表中的所有定时器通知标识符。

getAllNotificationIDs() - Method in interface javax.management.timer. TimerMBean

获取注册到通知列表中的所有定时器通知标识符。

getAllowedLocations() - Method in interface jdk.javadoc.doclet. Taglet

返回可以使用标签的位置集合。

getAllowedTagSets() - Method in class javax.imageio.plugins.tiff. TIFFImageReadParam

返回 List包含允许 TIFFTagSet对象。

getAllowsChildren() - Method in class javax.swing.text. AbstractDocument.AbstractElement

如果接收器允许孩子，则返回true。

getAllowsChildren() - Method in class javax.swing.text. AbstractDocument.BranchElement

如果接收器允许孩子，则返回true。

getAllowsChildren() - Method in class javax.swing.text. AbstractDocument.LeafElement

如果接收器允许孩子，则返回true。

getAllowsChildren() - Method in class javax.swing.tree. DefaultMutableTreeNode

如果该节点允许有子节点，则返回true。

getAllowsChildren() - Method in interface javax.swing.tree. TreeNode

如果接收器允许孩子，则返回true。

getAllowsInvalid() - Method in class javax.swing.text. DefaultFormatter

返回正在编辑的值是否允许在一段时间内无效。

getAllowUserInteraction() - Method in class java.net. URLConnection

返回此对象的 allowUserInteraction字段的值。

getAllPackageElements(CharSequence) - Method in interface javax.lang.model.util. Elements

返回具有给定规范名称的所有包元素。

getAllPrinters() - Static method in class javafx.print. Printer

检索已安装的打印机。

getAllRelationIds() - Method in class javax.management.relation. RelationService

返回由关系服务处理的所有关系的所有关系ID。

getAllRelationIds() - Method in interface javax.management.relation. RelationServiceMBean

返回由关系服务处理的所有关系的所有关系ID。

getAllRelationTypeNames() - Method in class javax.management.relation. RelationService

检索所有已知关系类型的名称。

getAllRelationTypeNames() - Method in interface javax.management.relation. RelationServiceMBean

检索所有已知关系类型的名称。

getAllRoles() - Method in interface javax.management.relation. Relation

返回关系中存在的所有角色。

getAllRoles() - Method in class javax.management.relation. RelationSupport

返回关系中存在的所有角色。

getAllRoles(String) - Method in class javax.management.relation. RelationService

返回关系中存在的所有角色。

getAllRoles(String) - Method in interface javax.management.relation. RelationServiceMBean

返回关系中存在的所有角色。

getAllStackTraces() - Static method in class java.lang. Thread

返回所有活动线程的堆栈跟踪图。

getAllTags() - Static method in class javax.swing.text.html. HTML

返回由默认HTML阅读器识别的一组实际的HTML标签。

getAllThreadIds() - Method in interface java.lang.management. ThreadMXBean

返回所有活动线程ID。

getAllTypeElements(CharSequence) - Method in interface javax.lang.model.util. Elements

返回具有给定规范名称的所有类型元素。

getAlpha() - Method in class java.awt. AlphaComposite

返回这个 AlphaComposite的alpha值。

getAlpha() - Method in class java.awt. Color

返回0-255范围内的alpha分量。

getAlpha(int) - Method in class java.awt.image. ColorModel

返回指定像素的alpha分量，从0到255。

getAlpha(int) - Method in class java.awt.image. ComponentColorModel

返回指定像素的alpha分量，从0到255。

getAlpha(int) - Method in class java.awt.image. DirectColorModel

返回指定像素的alpha分量，从0到255。

getAlpha(int) - Method in class java.awt.image. IndexColorModel

返回指定像素的alpha分量，从0到255。

getAlpha(Object) - Method in class java.awt.image. ColorModel

返回指定像素的alpha分量，从0到255。

getAlpha(Object) - Method in class java.awt.image. ComponentColorModel

返回指定像素的alpha分量，从0到255。

getAlpha(Object) - Method in class java.awt.image. DirectColorModel

返回指定像素的alpha分量，从0到255。

getAlphaMask() - Method in class java.awt.image. DirectColorModel

返回掩码，指示 int像素表示中的哪些位包含alpha组件。

getAlphaRaster() - Method in class java.awt.image. BufferedImage

返回一个 WritableRaster表示 BufferedImage对象的alpha通道，其中 ColorModel对象支持单独的空间alpha通道，如 ComponentColorModel和 DirectColorModel 。

getAlphaRaster(WritableRaster) - Method in class java.awt.image. ColorModel

返回 Raster表示图像的alpha通道，从输入中提取 Raster ，提供此的像素值 ColorModel表示颜色和alpha信息为独立的空间频带（例如

getAlphaRaster(WritableRaster) - Method in class java.awt.image. ComponentColorModel

返回 Raster表示图像的alpha通道，从输入中提取 Raster 。

getAlphaRaster(WritableRaster) - Method in class java.awt.image. PackedColorModel

返回WritableRaster表示图像的alpha通道，从输入中提取WritableRaster 。

getAlphas(byte[]) - Method in class java.awt.image. IndexColorModel

将Alpha透明组件数组复制到指定的数组中。

getAlt() - Method in class javafx.scene.input. KeyCombination

alt键的这个组合状态。

getAlt() - Method in interface org.w3c.dom.html. HTMLAppletElement

用户代理的替代文本不呈现此元素的正常内容。

getAlt() - Method in interface org.w3c.dom.html. HTMLAreaElement

用户代理的替代文本不呈现此元素的正常内容。

getAlt() - Method in interface org.w3c.dom.html. HTMLImageElement

用户代理的替代文本不呈现此元素的正常内容。

getAlt() - Method in interface org.w3c.dom.html. HTMLInputElement

用户代理的替代文本不呈现此元素的正常内容。

getAlternatives() - Method in interface javax.lang.model.type. UnionType

返回包含此联合类型的替代方案。

getAltKey() - Method in interface org.w3c.dom.events. MouseEvent

用于指示在事件触发期间“alt”键是否被按下。

getAltName() - Method in exception javax.naming. CannotProceedException

检索此异常的 altName字段。

getAltNameCtx() - Method in exception javax.naming. CannotProceedException

检索此异常的 altNameCtx字段。

getAltText() - Method in class javax.swing.text.html. ImageView

如果图像无法加载，返回要显示的文本。

getAmountFull(Insets, int, int) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

这将根据从模型收集的百分比确定应填充的进度条的数量。

getAmountToStepBy() - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory

获取属性amountToStepBy的值。

getAmountToStepBy() - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

获取属性amountToStepBy的值。

getAmPmStrings() - Method in class java.text. DateFormatSymbols

获取ampm字符串。

getAncestor() - Method in class javax.swing.event. AncestorEvent

返回事件实际发生的祖先。

getAncestorListeners() - Method in class javax.swing. JComponent

返回在此组件上注册的所有祖先监听器的数组。

getAncestorNamed(String, Component) - Static method in class javax.swing. SwingUtilities

以上搜索的便捷方法 comp组件层次结构中，并返回的第一对象 name它找到。

getAncestorOfClass(Class<?>, Component) - Static method in class javax.swing. SwingUtilities

在组件层次结构中搜索 comp以上的方便方法，并返回它找到的第 c类的第一个对象。

getAncestorParent() - Method in class javax.swing.event. AncestorEvent

返回事件实际发生的祖先的父级。

getAnchor() - Method in class javafx.scene.control. TextFormatter.Change

获得新的锚点。

getAnchor() - Method in class javafx.scene.control. TextInputControl

获取属性锚点的值。

getAnchorLocation() - Method in class javafx.stage. PopupWindow

获取属性anchorLocation的值。

getAnchorRect() - Method in class java.awt. TexturePaint

返回锚定矩形的副本，该矩形位置和尺寸纹理图像。

getAnchors() - Method in interface org.w3c.dom.html. HTMLDocument

所有锚点（ A ）的元素的集合，其值为 name属性。

getAnchorSelectionIndex() - Method in class javax.swing. DefaultListSelectionModel

从最近调用setSelectionInterval（），addSelectionInterval（）或removeSelectionInterval（）返回第一个索引参数。

getAnchorSelectionIndex() - Method in class javax.swing. JList

返回锚选择索引。

getAnchorSelectionIndex() - Method in interface javax.swing. ListSelectionModel

从最近调用setSelectionInterval（），addSelectionInterval（）或removeSelectionInterval（）返回第一个索引参数。

getAnchorSelectionPath() - Method in class javax.swing. JTree

返回标识为锚点的路径。

getAnchorX() - Method in class javafx.stage. PopupWindow

获取属性anchorX的值。

getAnchorY() - Method in class javafx.stage. PopupWindow

获取属性anchorY的值。

getAndAccumulate(int, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回上一个值。

getAndAccumulate(int, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongArray

原始更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素，并将给定函数应用于当前值和给定值，返回上一个值。

getAndAccumulate(int, E, BinaryOperator<E>) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

将索引号为 i的元素原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），并将给定的函数应用于当前值和给定值，返回上一个值。

getAndAccumulate(int, IntBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicInteger

将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回上一个值。

getAndAccumulate(long, LongBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicLong

将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回上一个值。

getAndAccumulate(T, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。

getAndAccumulate(T, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。

getAndAccumulate(T, V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater

原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，并将给定函数应用于当前值和给定值，返回上一个值。

getAndAccumulate(V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReference

将当前值与给定函数应用于当前值和给定值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效应），返回上一个值。

getAndAdd(int) - Method in class java.util.concurrent.atomic. AtomicInteger

原始地将给定值添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

getAndAdd(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

getAndAdd(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

原子地将给定的值添加到索引号为 i的元素，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

getAndAdd(long) - Method in class java.util.concurrent.atomic. AtomicLong

将给定的值原子地添加到当前值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

getAndAdd(Object...) - Method in class java.lang.invoke. VarHandle

以原子添加 value用的内存语义变量的当前值 VarHandle.setVolatile(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.getVolatile(java.lang.Object...) 。

getAndAdd(T, int) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。

getAndAdd(T, long) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

将给定值原子地添加到由此更新程序管理的给定对象的字段的当前值。

getAndAddAcquire(Object...) - Method in class java.lang.invoke. VarHandle

以原子添加 value用的内存语义变量的当前值 VarHandle.set(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.getAcquire(java.lang.Object...) 。

getAndAddRelease(Object...) - Method in class java.lang.invoke. VarHandle

以原子添加 value用的内存语义变量的当前值 VarHandle.setRelease(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.get(java.lang.Object...) 。

getAndBitwiseAnd(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间按位AND的结果，并返回变量的上一个值，内存语义为 VarHandle.getVolatile(java.lang.Object...) 。

getAndBitwiseAndAcquire(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值原子设置为变量当前值与 mask的内存语义的 mask之间按位AND的结果，并返回变量的上一个值，并使用内存语义为 VarHandle.getAcquire(java.lang.Object...)进行访问。

getAndBitwiseAndRelease(Object...) - Method in class java.lang.invoke. VarHandle

原子地将变量的值设置为变量当前值与 mask的内存语义的 mask之间按位AND的结果，并返回变量的先前值，如使用内存语义 VarHandle.get(java.lang.Object...)访问的。

getAndBitwiseOr(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值原子设置为变量当前值与 mask之间的按位OR的结果，内存语义为 VarHandle.setVolatile(java.lang.Object...)，并返回变量的上一个值，内存语义为 VarHandle.getVolatile(java.lang.Object...) 。

getAndBitwiseOrAcquire(Object...) - Method in class java.lang.invoke. VarHandle

原子地将变量的值设置为变量的当前值与 mask之间按位OR的结果，内存语义为 VarHandle.set(java.lang.Object...)，并返回变量的上一个值，并以内存语义为 VarHandle.getAcquire(java.lang.Object...)进行访问。

getAndBitwiseOrRelease(Object...) - Method in class java.lang.invoke. VarHandle

在变量的当前值和 mask的内存语义为 VarHandle.setRelease(java.lang.Object...)之间，将变量的值原子设置为按位OR的结果，并返回变量的上一个值，并以内存语义为 VarHandle.get(java.lang.Object...)进行访问。

getAndBitwiseXor(Object...) - Method in class java.lang.invoke. VarHandle

在变量的当前值和 mask的内存语义为 VarHandle.setVolatile(java.lang.Object...)之间，将变量的值原子地设置为按位XOR的结果，并返回变量的上一个值，内存语义为 VarHandle.getVolatile(java.lang.Object...) 。

getAndBitwiseXorAcquire(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值原子设置为变量当前值与 mask的内存语义的 mask之间的按位XOR的结果，并返回该变量的上一个值，并以内存语义为 VarHandle.getAcquire(java.lang.Object...)进行访问。

getAndBitwiseXorRelease(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值原子设置为变量当前值与 mask的内存语义的 mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为 VarHandle.get(java.lang.Object...) 。

getAndDecrement() - Method in class java.util.concurrent.atomic. AtomicInteger

按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子递减当前值。

getAndDecrement() - Method in class java.util.concurrent.atomic. AtomicLong

按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效应原则递减当前值。

getAndDecrement(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

原子地递减索引号为 i的元素的值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

getAndDecrement(int) - Method in class java.util.concurrent.atomic. AtomicLongArray

按索引 i原子地递减元素的值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

getAndDecrement(T) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

由该更新程序管理的给定对象的字段的当前值原子减1。

getAndDecrement(T) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

由该更新程序管理的给定对象的字段的当前值原子减1。

getAndIncrement() - Method in class java.util.concurrent.atomic. AtomicInteger

以 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果原子地增加当前值。

getAndIncrement() - Method in class java.util.concurrent.atomic. AtomicLong

按照 VarHandle.getAndAdd(java.lang.Object...)所规定的内存效果，原子地增加当前值。

getAndIncrement(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

按索引 i原子地增加元素的值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

getAndIncrement(int) - Method in class java.util.concurrent.atomic. AtomicLongArray

按照 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果，原子地增加索引号为 i的元素的值。

getAndIncrement(T) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

由此更新程序管理的给定对象的字段的当前值以原子方式递增1。

getAndIncrement(T) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

由此更新程序管理的给定对象的字段的当前值以原子方式递增1。

getAndSet(boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。

getAndSet(int) - Method in class java.util.concurrent.atomic. AtomicInteger

将该值原子设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。

getAndSet(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。

getAndSet(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。

getAndSet(int, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

将索引 i为 newValue的元素原子设置为 newValue并返回具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果的旧值。

getAndSet(long) - Method in class java.util.concurrent.atomic. AtomicLong

将该值原子设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。

getAndSet(Object...) - Method in class java.lang.invoke. VarHandle

原子地将变量的值设置为 newValue ，其内存语义为 VarHandle.setVolatile(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.getVolatile(java.lang.Object...)访问的。

getAndSet(T, int) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。

getAndSet(T, long) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。

getAndSet(T, V) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater

将由此更新程序管理的给定对象的字段原子设置为给定值，并返回旧值。

getAndSet(V) - Method in class java.util.concurrent.atomic. AtomicReference

将值设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。

getAndSetAcquire(Object...) - Method in class java.lang.invoke. VarHandle

原子地将变量的值设置为 newValue ，其内存语义为 VarHandle.set(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.getAcquire(java.lang.Object...)访问的。

getAndSetRelease(Object...) - Method in class java.lang.invoke. VarHandle

原子地将变量的值设置为 newValue ，其内存语义为 VarHandle.setRelease(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.get(java.lang.Object...)访问的。

getAndUpdate(int, IntUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。

getAndUpdate(int, LongUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongArray

使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。

getAndUpdate(int, UnaryOperator<E>) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。

getAndUpdate(IntUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicInteger

使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。

getAndUpdate(LongUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicLong

使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。

getAndUpdate(UnaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReference

使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回上一个值。

getAndUpdate(T, IntUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

通过应用给定函数的结果，原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，返回上一个值。

getAndUpdate(T, LongUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。

getAndUpdate(T, UnaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater

原始更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回上一个值。

getAngle() - Method in class javafx.scene.effect. MotionBlur

获取属性角度的值。

getAngle() - Method in class javafx.scene.input. RotateEvent

获取此事件的旋转角度。

getAngle() - Method in class javafx.scene.transform. Rotate

获取属性角度的值。

getAngleExtent() - Method in class java.awt.geom. Arc2D.Double

返回弧的角度范围。

getAngleExtent() - Method in class java.awt.geom. Arc2D.Float

返回弧的角度范围。

getAngleExtent() - Method in class java.awt.geom. Arc2D

返回弧的角度范围。

getAngleStart() - Method in class java.awt.geom. Arc2D.Double

返回弧的起始角度。

getAngleStart() - Method in class java.awt.geom. Arc2D.Float

返回弧的起始角度。

getAngleStart() - Method in class java.awt.geom. Arc2D

返回弧的起始角度。

getAnimated() - Method in class javafx.scene.chart. Axis

指示轴范围的更改是否将被动画化。

getAnimated() - Method in class javafx.scene.chart. Chart

指示数据更改是否将被动画化。

getAnimationIndex() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

获取当前动画帧的索引。

getAnnotatedActualTypeArguments() - Method in interface java.lang.reflect. AnnotatedParameterizedType

返回此参数化类型的可能注释的实际类型参数。

getAnnotatedBounds() - Method in interface java.lang.reflect. AnnotatedTypeVariable

返回此类型变量的可能注释的边界。

getAnnotatedBounds() - Method in interface java.lang.reflect. TypeVariable

返回一个AnnotatedType对象的数组，表示使用类型来表示此TypeVariable表示的类型参数的上限。

getAnnotatedExceptionTypes() - Method in class java.lang.reflect. Executable

返回一个 AnnotatedType对象的数组，它们表示使用类型来指定由此可执行文件表示的方法/构造函数声明的异常。

getAnnotatedGenericComponentType() - Method in interface java.lang.reflect. AnnotatedArrayType

返回此数组类型的可能注释的通用组件类型。

getAnnotatedInterfaces() - Method in class java.lang. Class

返回一个 AnnotatedType对象的数组，表示使用类型指定由该 Class对象表示的实体的 Class 。

getAnnotatedLowerBounds() - Method in interface java.lang.reflect. AnnotatedWildcardType

返回此通配符类型的潜在注释下限。

getAnnotatedOwnerType() - Method in interface java.lang.reflect. AnnotatedArrayType

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

getAnnotatedOwnerType() - Method in interface java.lang.reflect. AnnotatedParameterizedType

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

getAnnotatedOwnerType() - Method in interface java.lang.reflect. AnnotatedType

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

getAnnotatedOwnerType() - Method in interface java.lang.reflect. AnnotatedTypeVariable

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

getAnnotatedOwnerType() - Method in interface java.lang.reflect. AnnotatedWildcardType

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

getAnnotatedParameterTypes() - Method in class java.lang.reflect. Executable

返回一个 AnnotatedType对象的数组，表示使用类型来指定此可执行文件所表示的方法/构造函数的形式参数类型。

getAnnotatedReceiverType() - Method in class java.lang.reflect. Constructor

返回一个 AnnotatedType对象，表示使用类型来指定由此 Executable对象表示的方法/构造函数的接收器类型。

getAnnotatedReceiverType() - Method in class java.lang.reflect. Executable

返回一个 AnnotatedType对象，表示使用类型来指定由此 Executable对象表示的方法/构造函数的接收器类型。

getAnnotatedReturnType() - Method in class java.lang.reflect. Constructor

返回一个 AnnotatedType对象，表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。

getAnnotatedReturnType() - Method in class java.lang.reflect. Executable

返回一个 AnnotatedType对象，表示使用类型指定此可执行文件所表示的方法/构造函数的返回类型。

getAnnotatedReturnType() - Method in class java.lang.reflect. 方法

返回一个 AnnotatedType对象，表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。

getAnnotatedSuperclass() - Method in class java.lang. Class

返回一个 AnnotatedType对象，该对象表示使用类型来指定由此 Class对象表示的实体的超类。

getAnnotatedType() - Method in class java.lang.reflect. Field

返回一个AnnotatedType对象，它表示使用一个类型来指定此Field所表示的字段的声明类型。

getAnnotatedType() - Method in class java.lang.reflect. Parameter

返回一个AnnotatedType对象，它表示使用一个类型来指定此参数表示的形式参数的类型。

getAnnotatedUpperBounds() - Method in interface java.lang.reflect. AnnotatedWildcardType

返回此通配符类型的可能注释的上限。

getAnnotation(Class<A>) - Method in class java.lang. Class

getAnnotation(Class<A>) - Method in class java.lang. 软件包

getAnnotation(Class<A>) - Method in interface javax.lang.model. AnnotatedConstruct

返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。

getAnnotation(Class<A>) - Method in interface javax.lang.model.element. Element

返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。

getAnnotation(Class<T>) - Method in class java.lang. Module

返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。

getAnnotation(Class<T>) - Method in class java.lang.reflect. AccessibleObject

getAnnotation(Class<T>) - Method in interface java.lang.reflect. AnnotatedElement

返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。

getAnnotation(Class<T>) - Method in class java.lang.reflect. Constructor

返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。

getAnnotation(Class<T>) - Method in class java.lang.reflect. Executable

返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。

getAnnotation(Class<T>) - Method in class java.lang.reflect. Field

getAnnotation(Class<T>) - Method in class java.lang.reflect. 方法

返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。

getAnnotation(Class<T>) - Method in class java.lang.reflect. Parameter

返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。

getAnnotationMirrors() - Method in interface javax.lang.model. AnnotatedConstruct

返回 直接存在于此构造上的注释。

getAnnotationMirrors() - Method in interface javax.lang.model.element. Element

返回 直接存在于此构造上的注释。

getAnnotations() - Method in interface com.sun.source.tree. AnnotatedTypeTree

返回与此类型表达式关联的注释。

getAnnotations() - Method in interface com.sun.source.tree. ModifiersTree

返回此修饰符树中的注释。

getAnnotations() - Method in interface com.sun.source.tree. ModuleTree

返回与此模块声明关联的注释。

getAnnotations() - Method in interface com.sun.source.tree. NewArrayTree

返回基本类型的注释。

getAnnotations() - Method in interface com.sun.source.tree. PackageTree

返回与此包声明关联的注释。

getAnnotations() - Method in interface com.sun.source.tree. TypeParameterTree

返回类型参数声明的注释。

getAnnotations() - Method in class java.lang. Class

getAnnotations() - Method in class java.lang. Module

返回此元素上 存在的注释。

getAnnotations() - Method in class java.lang. 软件包

getAnnotations() - Method in class java.lang.reflect. AccessibleObject

getAnnotations() - Method in interface java.lang.reflect. AnnotatedElement

返回此元素上 存在的注释。

getAnnotations() - Method in class java.lang.reflect. Parameter

返回此元素上 存在的注释。

getAnnotationsByType(Class<A>) - Method in class java.lang. Class

getAnnotationsByType(Class<A>) - Method in class java.lang. 软件包

getAnnotationsByType(Class<A>) - Method in interface javax.lang.model. AnnotatedConstruct

返回与此构造 关联的注释。

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect. AccessibleObject

getAnnotationsByType(Class<T>) - Method in interface java.lang.reflect. AnnotatedElement

返回与此元素 相关联的注释。

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect. Executable

返回与此元素 相关联的注释。

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect. Field

返回与此元素 相关联的注释。

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect. Parameter

返回与此元素 相关联的注释。

getAnnotationType() - Method in interface com.sun.source.tree. AnnotationTree

返回注释类型。

getAnnotationType() - Method in interface javax.lang.model.element. AnnotationMirror

返回此注释的类型。

getAnonymityState() - Method in interface org.ietf.jgss. GSSContext

确定上下文启动器是否被上下文接受者匿名认证。

getAnonymousLogger() - Static method in class java.util.logging. Logger

创建一个匿名记录器。

getAnonymousLogger(String) - Static method in class java.util.logging. Logger

创建一个匿名记录器。

getAntiAliasing() - Method in class javafx.scene. Scene

返回定义 SceneAntialiasing这个 Scene 。

getAntiAliasing() - Method in class javafx.scene. SubScene

返回定义 SceneAntialiasing这个 SubScene 。

getAntiAliasingHint() - Method in class java.awt.font. FontRenderContext

返回此 FontRenderContext使用的文本反锯齿渲染模式提示。

getAppConfigurationEntry(String) - Method in class com.sun.security.auth.login. ConfigFile

使用应用程序名称作为索引从 Configuration检索条目。

getAppConfigurationEntry(String) - Method in class javax.security.auth.login. Configuration

从此配置中检索指定的 name的AppConfigurationEntries。

getApplet(String) - Method in interface java.applet. AppletContext

已过时。

找到并返回由该applet上下文表示的文档中的applet，该文件具有给定的名称。

getAppletContext() - Method in class java.applet. Applet

已过时。

确定这个小程序的上下文，这允许小程序查询并影响它运行的环境。

getAppletContext() - Method in interface java.applet. AppletStub

已过时。

返回小程序的上下文。

getAppletInfo() - Method in class java.applet. Applet

已过时。

返回有关此小程序的信息。

getApplets() - Method in interface java.applet. AppletContext

已过时。

查找由该applet上下文表示的文档中的所有applet。

getApplets() - Method in interface org.w3c.dom.html. HTMLDocument

所有 OBJECT元素的集合，包括文档中的小程序和 APPLET （不推荐使用）元素。

getApplication() - Method in class javafx.application. Preloader.StateChangeNotification

返回与此通知关联的应用程序实例。

getApplicationBufferSize() - Method in interface javax.net.ssl. SSLSession

获取使用此会话时预期的最大应用程序数据的当前大小。

getApplicationData() - Method in class org.ietf.jgss. ChannelBinding

获取该通道绑定的应用程序指定的数据。

getApplicationProtocol() - Method in class javax.net.ssl. SSLEngine

返回为此连接协商的最新应用程序协议值。

getApplicationProtocol() - Method in class javax.net.ssl. SSLSocket

返回为此连接协商的最新应用程序协议值。

getApplicationProtocols() - Method in class javax.net.ssl. SSLParameters

返回可通过SSL / TLS / DTLS协议协商的应用层协议名称的优先级数组。

getApproveButton(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回批准按钮。

getApproveButton(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

getApproveButtonMnemonic() - Method in class javax.swing. JFileChooser

返回批准按钮的助记符。

getApproveButtonMnemonic(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回批准按钮助记符。

getApproveButtonText() - Method in class javax.swing. JFileChooser

返回 ApproveButton中的 FileChooserUI使用的文本。

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

退回批准按钮文本。

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf. FileChooserUI

退回批准按钮文本。

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getApproveButtonText方法。

getApproveButtonToolTipText() - Method in class javax.swing. JFileChooser

返回 ApproveButton使用的工具提示文本。

getApproveButtonToolTipText(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回批准按钮工具提示。

getApproveSelectionAction() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回批准选择动作。

getArch() - Method in interface java.lang.management. OperatingSystemMXBean

返回操作系统架构。

getArcHeight() - Method in class java.awt.geom. RoundRectangle2D.Double

获取圆角圆弧的高度。

getArcHeight() - Method in class java.awt.geom. RoundRectangle2D.Float

获取圆角圆弧的高度。

getArcHeight() - Method in class java.awt.geom. RoundRectangle2D

获取圆角圆弧的高度。

getArcHeight() - Method in class javafx.scene.shape. Rectangle

获取属性arcHeight的值。

getArchive() - Method in interface org.w3c.dom.html. HTMLAppletElement

逗号分隔的档案列表。

getArchive() - Method in interface org.w3c.dom.html. HTMLObjectElement

空格分隔的档案清单。

getArcType() - Method in class java.awt.geom. Arc2D

返回弧的弧闭合类型： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。

getArcWidth() - Method in class java.awt.geom. RoundRectangle2D.Double

获取从角落舍入的圆弧的宽度。

getArcWidth() - Method in class java.awt.geom. RoundRectangle2D.Float

获取从角落舍入的圆弧的宽度。

getArcWidth() - Method in class java.awt.geom. RoundRectangle2D

获取从角落舍入的圆弧的宽度。

getArcWidth() - Method in class javafx.scene.shape. Rectangle

获取属性arcWidth的值。

getAreaOfInterest() - Method in class java.awt.image.renderable. RenderContext

获取当前包含在RenderContext中的兴趣。

getAreas() - Method in interface org.w3c.dom.html. HTMLMapElement

为图像映射定义的区域列表。

getArgb(int, int) - Method in interface javafx.scene.image. PixelReader

从表面的指定坐标读取像素颜色的32位整数表示形式。

getArgb(T, int, int, int) - Method in class javafx.scene.image. PixelFormat

从指定坐标的缓冲区读取像素数据，并将其转换为 INT_ARGB格式的颜色的32位整数表示形式。

getArgument() - Method in exception javax.lang.model.element. UnknownAnnotationValueException

返回附加参数。

getArgument() - Method in exception javax.lang.model.element. UnknownDirectiveException

返回附加参数。

getArgument() - Method in exception javax.lang.model.element. UnknownElementException

返回附加参数。

getArgument() - Method in exception javax.lang.model.type. UnknownTypeException

返回附加参数。

getArgument() - Method in exception jdk.nashorn.api.tree. UnknownTreeException

返回附加参数。

getArgumentClass() - Method in exception java.util. IllegalFormatConversionException

返回不匹配参数的类。

getArgumentCount() - Method in interface jdk.javadoc.doclet. Doclet.Option

返回参数数，该选项将消耗。

getArguments() - Method in interface com.sun.source.tree. AnnotationTree

返回注释的参数（如果有）。

getArguments() - Method in interface com.sun.source.tree. MethodInvocationTree

返回方法调用的参数。

getArguments() - Method in interface com.sun.source.tree. NewClassTree

返回要调用的构造函数的参数。

getArguments() - Method in class java.beans. Statement

返回要调用的方法的参数。

getArguments() - Method in interface jdk.dynalink.linker. LinkRequest

返回要链接的调用的参数。

getArguments() - Method in class jdk.dynalink.linker.support. SimpleLinkRequest

getArguments() - Method in interface jdk.nashorn.api.tree. FunctionCallTree

返回传递给此函数调用的参数列表。

getArgumentValues() - Method in interface com.sun.jdi. StackFrame

返回此框架中所有参数的值。

getArray() - Method in interface java.sql. Array

以Java编程语言的形式 Array由该 Array对象指定的SQL ARRAY值的内容。

getArray() - Method in class javax.sql.rowset.serial. SerialArray

返回一个新数组，该数组是该 SerialArray对象的副本。

getArray() - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

获取字符数组。

getArray(int) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定的JDBC ARRAY参数的值作为Array对象。

getArray(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 ResultSet对象的形式 Array此 ResultSet对象的当前行中指定列的值。

getArray(long, int) - Method in interface java.sql. Array

检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。

getArray(long, int) - Method in class javax.sql.rowset.serial. SerialArray

返回一个新数组，它是该 SerialArray对象的一个片段的副本，从给定索引处的元素开始，并包含给定数量的连续元素。

getArray(long, int, Map<String, Class<?>>) - Method in interface java.sql. Array

检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。

getArray(long, int, Map<String, Class<?>>) - Method in class javax.sql.rowset.serial. SerialArray

返回一个新数组，该数组是该 SerialArray对象的一个片段的副本，从给定索引处的元素开始，并包含给定数量的连续元素。

getArray(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的一个Array对象获取JDBC ARRAY参数的值。

getArray(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 Array对象获取此 ResultSet对象的当前行中指定列的值。

getArray(Map<String, Class<?>>) - Method in interface java.sql. Array

检索此 Array对象指定的SQL ARRAY值的内容。

getArray(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial. SerialArray

返回一个新数组，该数组是 SerialArray对象的副本，当元素为SQL UDT时，使用给定的类型映射来定制每个元素的映射。

getArrayLength() - Method in class javax.swing.text. GapContent

获取分配的数组的长度。

getArrayType(TypeMirror) - Method in interface javax.lang.model.util. Types

返回具有指定组件类型的数组类型。

getArrayType(OpenType<E>) - Static method in class javax.management.openmbean. ArrayType

以类型安全的方式创建一个 ArrayType实例。

getArrivedParties() - Method in class java.util.concurrent. Phaser

返回在此移相器的当前阶段到达的已注册方的数量。

getAsBoolean() - Method in interface java.util.function. BooleanSupplier

获得结果。

getAsBytes() - Method in class javax.imageio.plugins.tiff. TIFFField

将数据作为未解释的数组返回 byte s。

getAscent() - Method in class java.awt.font. GraphicAttribute

返回这个 GraphicAttribute的上升。

getAscent() - Method in class java.awt.font. ImageGraphicAttribute

返回此 ImageGraphicAttribute的上升。

getAscent() - Method in class java.awt.font. LineMetrics

返回文本的上升。

getAscent() - Method in class java.awt.font. ShapeGraphicAttribute

返回这个 ShapeGraphicAttribute的上升。

getAscent() - Method in class java.awt.font. TextLayout

返回这个 TextLayout的上升。

getAscent() - Method in class java.awt. FontMetrics

确定 FontMetrics对象描述的 Font的 字体上升 。

getAscent(GlyphView) - Method in class javax.swing.text. GlyphView.GlyphPainter

上升的回报。

getAsChars() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_SHORT数据作为 char s（无符号16位整数）的数组。

getAsciiName() - Method in class javax.net.ssl. SNIHostName

返回此 SNIHostName对象的 StandardCharsets.US_ASCII兼容主机名。

getAsciiStream() - Method in interface java.sql. Clob

检索由该 Clob对象指定的 CLOB值作为ascii流。

getAsciiStream() - Method in class javax.sql.rowset.serial. SerialClob

检索由该 SerialClob对象指定的 CLOB值作为ASCII码流。

getAsciiStream(int) - Method in interface java.sql. ResultSet

将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。

getAsciiStream(String) - Method in interface java.sql. ResultSet

将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。

getAsDouble() - Method in interface java.util.function. DoubleSupplier

获得结果。

getAsDouble() - Method in class java.util. OptionalDouble

如果值存在，则返回值，否则抛出 NoSuchElementException 。

getAsDouble(int) - Method in class javax.imageio.plugins.tiff. TIFFField

以 double格式返回任何格式的 double 。

getAsDoubles() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_DOUBLE数据作为 double s（64位浮点值）的数组。

getAsFloat(int) - Method in class javax.imageio.plugins.tiff. TIFFField

以 float格式返回任何格式的 float 。

getAsFloats() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_FLOAT数据作为 float s（32位浮点值）的数组。

getAsInt() - Method in interface java.util.function. IntSupplier

获得结果。

getAsInt() - Method in class java.util. OptionalInt

如果值存在，则返回值，否则抛出 NoSuchElementException 。

getAsInt(int) - Method in class javax.imageio.plugins.tiff. TIFFField

以 int格式返回任何格式的 int 。

getAsInts() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_SLONG数据作为 int （有符号32位整数）的数组。

getAsLong() - Method in interface java.util.function. LongSupplier

获得结果。

getAsLong() - Method in class java.util. OptionalLong

如果值存在，则返回值，否则抛出 NoSuchElementException 。

getAsLong(int) - Method in class javax.imageio.plugins.tiff. TIFFField

以 long格式返回任何格式的 long 。

getAsLongs() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_LONG或 TIFF_IFD_POINTER数据作为 long s（有符号的64位整数）的数组。

getAsMetadata() - Method in class javax.imageio.plugins.tiff. TIFFDirectory

将目录转换为元数据对象。

getAsNativeNode() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFField作为一个名为 "TIFFField"或 "TIFFIFD"的节点，如TIFF本机图像元数据规范中所述。

getAspectRatio(int) - Method in class javax.imageio. ImageReader

将给定图像的宽高比（即其宽度除以其高度）返回为 float 。

getAsRational(int) - Method in class javax.imageio.plugins.tiff. TIFFField

返回一个TIFFTag.TIFF_RATIONAL数据项作为一个双元素的int数组。

getAsRationals() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_RATIONAL数据作为2元件数组的数组 long秒。

getAsShorts() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_SSHORT数据作为阵列 short秒（带符号的16位整数）。

getAssociatedStylesheet(Source, String, String, String) - Method in class javax.xml.transform. TransformerFactory

通过符合给定条件的 xml-stylesheet processing instruction获取与XML Source文档相关联的样式表规范。

getAsSRational(int) - Method in class javax.imageio.plugins.tiff. TIFFField

将 TIFFTag.TIFF_SRATIONAL数据项作为 TIFFTag.TIFF_SRATIONAL的双元素数组 int 。

getAsSRationals() - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_SRATIONAL数据作为 int s的2元素数组的数组。

getAsString(int) - Method in class javax.imageio.plugins.tiff. TIFFField

返回 TIFFTag.TIFF_ASCII值作为 String 。

getAsText() - Method in interface java.beans. PropertyEditor

获取属性值作为文本。

getAsText() - Method in class java.beans. PropertyEditorSupport

获取属性值作为适合演示文稿的字符串进行编辑。

getAsTree(String) - Method in class javax.imageio.metadata. IIOMetadata

根据给定元数据格式定义的约定，返回表示此对象中包含的元数据树的根的XML DOM Node对象。

getAsync() - Method in interface org.w3c.dom.ls. LSParser

true如果 LSParser是异步的， false如果是同步的。

getAsynchronousLoadPriority() - Method in class javax.swing.text. AbstractDocument

获取异步加载优先级。

getAsyncMode() - Method in class java.util.concurrent. ForkJoinPool

返回 true如果此池使用本地先入先出调度模式，用于从未加入的分叉任务。

getAtIndex(int, int) - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回给定索引处的String。

getAtIndex(int, int) - Method in interface javax.accessibility. AccessibleText

返回给定索引的 String 。

getAtIndex(int, int) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回给定索引处的String。

getAtIndex(int, int) - Method in class javax.swing. JLabel.AccessibleJLabel

返回给定索引处的String。

getAtIndex(int, int) - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

返回 String在给定 index 。

getAtIndex(int, int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回给定索引处的String。

getAtIndex(int, int) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回给定索引处的String。

getAtIndex(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回给定索引处的String。

getATR() - Method in class javax.smartcardio. Card

返回此卡的ATR。

getAttachment(SOAPElement) - Method in class javax.xml.soap. SOAPMessage

返回与此 SOAPElement或 null引用的附件相关联的 AttachmentPart对象，如果不存在此类附件。

getAttachmentAsByteArray(String) - Method in class javax.xml.bind.attachment. AttachmentUnmarshaller

检索由content-id， cid标识的附件，作为 byte[] 。

getAttachmentAsDataHandler(String) - Method in class javax.xml.bind.attachment. AttachmentUnmarshaller

根据content-id查询MIME内容， cid ，并返回为DataHandler 。

getAttachmentMarshaller() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

getAttachmentMarshaller() - Method in interface javax.xml.bind. Marshaller

getAttachments() - Method in class javax.xml.soap. SOAPMessage

检索所有 AttachmentPart对象是这部分 SOAPMessage对象。

getAttachments(MimeHeaders) - Method in class javax.xml.soap. SOAPMessage

检索具有与指定标题匹配的标题条目的所有 AttachmentPart对象。

getAttachmentUnmarshaller() - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

getAttachmentUnmarshaller() - Method in interface javax.xml.bind. Unmarshaller

getAttrChange() - Method in interface org.w3c.dom.events. MutationEvent

attrChange指示触发DOMAttrModified事件的更改类型。

getAttribute() - Method in class javax.naming.directory. ModificationItem

检索与此修改项相关联的属性。

getAttribute(Class<T>) - Method in interface javax.print. PrintService

获取单个指定服务属性的值。

getAttribute(Object) - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取属性的值。

getAttribute(Object) - Method in interface javax.swing.text. AttributeSet

获取给定属性的值。

getAttribute(Object) - Method in class javax.swing.text. SimpleAttributeSet

获取属性的值。

getAttribute(Object) - Method in class javax.swing.text. StyleContext.NamedStyle

获取属性的值。

getAttribute(Object) - Method in class javax.swing.text. StyleContext.SmallAttributeSet

获取属性的值。

getAttribute(String) - Method in class com.sun.net.httpserver. HttpExchange

过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。

getAttribute(String) - Method in class java.nio.file. FileStore

读取文件存储属性的值。

getAttribute(String) - Method in class java.security. Provider.Service

返回指定属性的值，如果未为此服务设置此属性，则返回null。

getAttribute(String) - Method in class javax.imageio.metadata. IIOMetadataNode

按名称检索属性值。

getAttribute(String) - Method in interface javax.management. DynamicMBean

获取动态MBean的特定属性的值。

getAttribute(String) - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回名称请求的ModelMBeanAttributeInfo。

getAttribute(String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

getAttribute(String) - Method in class javax.management.modelmbean. RequiredModelMBean

返回为此ModelMBean定义的特定属性的值。

getAttribute(String) - Method in class javax.management. StandardMBean

getAttribute(String) - Method in interface javax.script. ScriptContext

在搜索顺序中最早出现的范围内检索具有给定名称的属性值。

getAttribute(String) - Method in class javax.script. SimpleScriptContext

在搜索顺序中最早出现的范围内检索具有给定名称的属性值。

getAttribute(String) - Static method in class javax.swing.text.html. CSS

将字符串转换为 CSS.Attribute对象。

getAttribute(String) - Method in class javax.swing.text.html.parser. Element

通过名称获取属性。

getAttribute(String) - Method in class javax.xml.parsers. DocumentBuilderFactory

允许用户检索底层实现的特定属性。

getAttribute(String) - Method in class javax.xml.transform. TransformerFactory

允许用户检索底层实现的特定属性。

getAttribute(String) - Method in class javax.xml.ws.spi.http. HttpContext

返回容器配置的属性值和jax-ws运行时可以使用的其他数据。

getAttribute(String) - Method in class javax.xml.ws.spi.http. HttpExchange

返回与此 HttpExchange关联的属性。

getAttribute(String) - Method in interface org.w3c.dom. Element

按名称检索属性值。

getAttribute(String, int) - Method in interface javax.script. ScriptContext

获取给定范围内的属性值。

getAttribute(String, int) - Method in class javax.script. SimpleScriptContext

获取给定范围内的属性值。

getAttribute(Path, String, LinkOption...) - Static method in class java.nio.file. Files

读取文件属性的值。

getAttribute(AttributedCharacterIterator.Attribute) - Method in interface java.text. AttributedCharacterIterator

返回当前字符的名称为 attribute的值。

getAttribute(ObjectName) - Method in class javax.management. AttributeValueExp

返回指定的MBean中给定属性的值。

getAttribute(ObjectName, String) - Method in interface javax.management. MBeanServer

getAttribute(ObjectName, String) - Method in interface javax.management. MBeanServerConnection

获取命名MBean的特定属性的值。

getAttribute(ObjectName, String, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.getAttribute(ObjectName, String) 。

getAttribute(ObjectName, String, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getAttribute(ObjectName, String, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

getAttributeByName(QName) - Method in interface javax.xml.stream.events. StartElement

返回此名称引用的属性

getAttributeByValue(String) - Method in class javax.swing.text.html.parser. Element

通过值获取属性。

getAttributeContext() - Method in class javax.swing.text. AbstractDocument

获取管理属性的上下文。

getAttributeCount() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取定义的属性数。

getAttributeCount() - Method in interface javax.swing.text. AttributeSet

返回此集合中本地定义的属性数。

getAttributeCount() - Method in class javax.swing.text. SimpleAttributeSet

获取属性数的计数。

getAttributeCount() - Method in class javax.swing.text. StyleContext.NamedStyle

获取定义的属性数。

getAttributeCount() - Method in class javax.swing.text. StyleContext.SmallAttributeSet

获取定义的属性数。

getAttributeCount() - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributeCount() - Method in interface javax.xml.stream. XMLStreamReader

返回此START_ELEMENT上的属性数量，此方法仅适用于START_ELEMENT或ATTRIBUTE。

getAttributeDataType(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回从 DATATYPE_开始的常量 DATATYPE_ ，指示指定元素中给定属性的值的格式和解释。

getAttributeDataType(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeDefaultValue(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

如果没有默认值可用，则返回命名属性的默认值（如果它未显式存在于命名元素中）， String ，或 null 。

getAttributeDefaultValue(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeDefinition() - Method in interface javax.naming.directory. Attribute

检索属性的模式定义。

getAttributeDefinition() - Method in class javax.naming.directory. BasicAttribute

检索此属性的模式定义。

getAttributeDescription(String, String, Locale) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回一个 String其中包含命名属性的描述，或 null 。

getAttributeDescription(String, String, Locale) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

返回 String含有指定属性，或的描述 null 。

getAttributeEnumerations(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回一个 String s的数组， String包含指定元素中给定属性的合法枚举值。

getAttributeEnumerations(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeID() - Method in class javax.naming.ldap. SortKey

检索排序键的属性ID。

getAttributeID() - Method in class javax.naming.ldap. SortResponseControl

检索导致排序失败的属性的ID。

getAttributeKey(String) - Static method in class javax.swing.text.html. HTML

获取一个众所周知的属性名称的属性常量（即集合{FACE，COMMENT，SIZE，COLOR，CLEAR，BACKGROUND，BGCOLOR，TEXT，LINK，VLINK，ALINK，WIDTH，HEIGHT，ALIGN，NAME ，HREF，REL，REV，TITLE，TARGET，SHAPE，COORDS，ISMAP，NOHREF，ALT，ID，SRC，HSPACE，VSPACE，USEMAP，LOWSRC，CODEBASE，CODE，ARCHIVE，VALUE，VALUETYPE，TYPE，CLASS，STYLE，LANG ，DIR，DECLARE，CLASSID，DATA，CODETYPE，STANDBY，BORDER，SHAPES，NOSHADE，COMPACT，START，ACTION，METHOD，ENCTYPE，CHECKED，MAXLENGTH，MULTIPLE，SELECTED，ROWS，COLS，DUMMY，CELLSPACING，CELLPADDING，VALIGN，HALIGN ，NOWRAP，ROWSPAN，COLSPAN，PROMPT，HTTPEQUIV，CONTENT，LANGUAGE，VERSION，N，FRAMEBORDER，MARGINWIDTH，MARGINHEIGHT，SCROLLING，NORESIZE，MEDIA，ENDTAG}）。

getAttributeListMaxLength(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回可用于定义此属性的列表项的最大数量。

getAttributeListMaxLength(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeListMinLength(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回可用于定义此属性的列表项的最小数量。

getAttributeListMinLength(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeLocalName(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributeLocalName(int) - Method in interface javax.xml.stream. XMLStreamReader

返回提供的索引处的属性的localName

getAttributeMaxValue(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回属性的最大合法值。

getAttributeMaxValue(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeMinValue(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回属性的最小合法值。

getAttributeMinValue(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeName() - Method in class javax.management. AttributeChangeNotification

获取已更改的属性的名称。

getAttributeName() - Method in class javax.management. AttributeValueExp

返回属性名称的字符串表示形式。

getAttributeName(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributeName(int) - Method in interface javax.xml.stream. XMLStreamReader

返回提供的索引处的属性的qname

getAttributeNames() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取所有属性的名称。

getAttributeNames() - Method in interface javax.swing.text. AttributeSet

返回在集合中本地定义的属性的名称的枚举。

getAttributeNames() - Method in class javax.swing.text. SimpleAttributeSet

获取集合中属性的名称。

getAttributeNames() - Method in class javax.swing.text. StyleContext.NamedStyle

获取所有属性的名称。

getAttributeNames() - Method in class javax.swing.text. StyleContext.SmallAttributeSet

获取所有属性的名称。

getAttributeNames() - Method in class javax.xml.ws.spi.http. HttpContext

返回容器配置的所有属性名称和jax-ws运行时可以使用的其他数据。

getAttributeNames() - Method in class javax.xml.ws.spi.http. HttpExchange

提供与此 HttpExchange相关联的所有属性名称。

getAttributeNames(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回一个 String的数组，列出可能与命名元素相关联的属性的名称。

getAttributeNames(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttributeNamespace(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributeNamespace(int) - Method in interface javax.xml.stream. XMLStreamReader

返回在提供的索引处的属性的命名空间

getAttributeNode(String) - Method in class javax.imageio.metadata. IIOMetadataNode

getAttributeNode(String) - Method in interface org.w3c.dom. Element

按名称检索属性节点。

getAttributeNodeNS(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode

相当于 getAttributeNode(localName) 。

getAttributeNodeNS(String, String) - Method in interface org.w3c.dom. Element

通过本地名称和命名空间URI检索 Attr节点。

getAttributeNS(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode

相当于 getAttribute(localName) 。

getAttributeNS(String, String) - Method in interface org.w3c.dom. Element

通过本地名称和命名空间URI检索属性值。

getAttributePrefix(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributePrefix(int) - Method in interface javax.xml.stream. XMLStreamReader

在提供的索引处返回此属性的前缀

getAttributes() - Method in class com.sun.net.httpserver. HttpContext

返回一个可变的Map，可以将配置和其他数据传递给Filter模块和上下文的交换处理程序。

getAttributes() - Method in interface com.sun.source.doctree. StartElementTree

返回此元素定义的任何属性。

getAttributes() - Method in class java.awt. Font

返回此 Font可用的字体属性的映射。

getAttributes() - Method in class java.net. JarURLConnection

如果该连接的URL指向JAR文件条目，则返回此连接的Attributes对象，否则返回null。

getAttributes() - Method in interface java.security. KeyStore.Entry

检索与条目关联的属性。

getAttributes() - Method in class java.security. KeyStore.PrivateKeyEntry

检索与条目关联的属性。

getAttributes() - Method in class java.security. KeyStore.SecretKeyEntry

检索与条目关联的属性。

getAttributes() - Method in class java.security. KeyStore.TrustedCertificateEntry

检索与条目关联的属性。

getAttributes() - Method in interface java.sql. Struct

生成此 Struct对象所代表的SQL结构化类型的属性的有序值。

getAttributes() - Method in interface java.text. AttributedCharacterIterator

返回当前字符中定义的属性的地图。

getAttributes() - Method in class java.util.jar. JarEntry

返回 Manifest Attributes此条，或 null如果没有。

getAttributes() - Method in class javax.imageio.metadata. IIOMetadataNode

返回包含此节点属性的 NamedNodeMap 。

getAttributes() - Method in class javax.management.loading. MLetContent

获取 MLET标签的属性。

getAttributes() - Method in class javax.management. MBeanInfo

返回暴露给管理的属性列表。

getAttributes() - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回暴露给管理的属性列表。

getAttributes() - Method in interface javax.management.openmbean. OpenMBeanInfo

返回一个 OpenMBeanAttributeInfo实例的数组，描述了这个 OpenMBeanInfo实例描述的开放MBean中的每个属性。

getAttributes() - Method in interface javax.management.remote. JMXConnectorServerMBean

此连接器服务器的属性。

getAttributes() - Method in class javax.management.remote.rmi. RMIConnectorServer

getAttributes() - Method in class javax.naming.directory. SearchResult

检索此搜索结果中的属性。

getAttributes() - Method in class javax.naming.spi. DirStateFactory.Result

检索要绑定的属性。

getAttributes() - Method in interface javax.print. Doc

获取此文档对象的打印属性集。

getAttributes() - Method in interface javax.print. DocPrintJob

获取此打印作业的一组打印属性。

getAttributes() - Method in class javax.print.event. PrintJobAttributeEvent

确定更改的打印属性及其新值。

getAttributes() - Method in class javax.print.event. PrintServiceAttributeEvent

确定更改的打印服务属性及其新值。

getAttributes() - Method in interface javax.print. PrintService

获取此打印服务的一组打印机描述属性，以提供此打印服务的状态。

getAttributes() - Method in class javax.print. SimpleDoc

获取此文档对象的打印属性集。

getAttributes() - Method in class javax.sql.rowset.serial. SerialStruct

检索包含 SerialStruct对象所代表的SQL结构类型的属性的 Object值的数组。

getAttributes() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取元素的属性。

getAttributes() - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

获取元素属性。

getAttributes() - Method in interface javax.swing.text. Element

获取此元素包含的属性集合。

getAttributes() - Method in class javax.swing.text.html. BlockView

获取渲染时要使用的属性。

getAttributes() - Method in class javax.swing.text.html. HTMLDocument.Iterator

返回此标签的属性。

getAttributes() - Method in class javax.swing.text.html. ImageView

获取渲染时要使用的属性。

getAttributes() - Method in class javax.swing.text.html. InlineView

获取渲染时要使用的属性。

getAttributes() - Method in class javax.swing.text.html. Option

获取与此选项关联的属性。

getAttributes() - Method in class javax.swing.text.html. ParagraphView

获取渲染时要使用的属性。

getAttributes() - Method in class javax.swing.text.html.parser. Element

获取属性。

getAttributes() - Method in class javax.swing.text.html.parser. Parser

返回当前标签的属性。

getAttributes() - Method in class javax.swing.text. View

获取渲染时要使用的属性。

getAttributes() - Method in interface javax.xml.stream.events. StartElement

返回在此START_ELEMENT上声明的非命名空间声明属性的迭代器，如果没有属性，则返回空的迭代器。

getAttributes() - Method in interface org.w3c.dom. Node

A NamedNodeMap包含此节点的属性（如果它是一个 Element ）或 null 。

getAttributes(String) - Method in class java.util.jar. Manifest

返回指定条目名称的属性。

getAttributes(String) - Method in interface javax.naming.directory. DirContext

检索与命名对象关联的所有属性。

getAttributes(String) - Method in class javax.naming.directory. InitialDirContext

getAttributes(String[]) - Method in interface javax.management. DynamicMBean

获取动态MBean的几个属性的值。

getAttributes(String[]) - Method in class javax.management.modelmbean. RequiredModelMBean

返回ModelMBean中的几个属性的值。

getAttributes(String[]) - Method in class javax.management. StandardMBean

getAttributes(String, String[]) - Method in interface javax.naming.directory. DirContext

检索与命名对象关联的所选属性。

getAttributes(String, String[]) - Method in class javax.naming.directory. InitialDirContext

getAttributes(String, String, String, String) - Method in interface java.sql. DatabaseMetaData

检索给定模式和目录中可用的用户定义类型（UDT）给定类型的给定属性的描述。

getAttributes(Map<String, Class<?>>) - Method in interface java.sql. Struct

生成此 Struct对象所代表的SQL结构化类型的属性的有序值。

getAttributes(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial. SerialStruct

检索 SerialStruct表示为 Object值的数组的SQL结构类型的属性，如果合适，则使用给定的类型映射进行自定义映射。

getAttributes(ObjectName, String[]) - Method in interface javax.management. MBeanServer

getAttributes(ObjectName, String[]) - Method in interface javax.management. MBeanServerConnection

检索命名MBean的几个属性的值。

getAttributes(ObjectName, String[], Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.getAttributes(ObjectName, String[]) 。

getAttributes(ObjectName, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getAttributes(ObjectName, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

getAttributes(Name) - Method in interface javax.naming.directory. DirContext

检索与命名对象关联的所有属性。

getAttributes(Name) - Method in class javax.naming.directory. InitialDirContext

getAttributes(Name, String[]) - Method in interface javax.naming.directory. DirContext

检索与命名对象关联的所选属性。

getAttributes(Name, String[]) - Method in class javax.naming.directory. InitialDirContext

getAttributesScope(String) - Method in interface javax.script. ScriptContext

获取定义属性的最低范围。

getAttributesScope(String) - Method in class javax.script. SimpleScriptContext

获取定义属性的最低范围。

getAttributeSyntaxDefinition() - Method in interface javax.naming.directory. Attribute

检索与属性相关联的语法定义。

getAttributeSyntaxDefinition() - Method in class javax.naming.directory. BasicAttribute

检索与此属性相关联的语法定义。

getAttributeType() - Method in class javax.management. AttributeChangeNotification

获取已更改的属性的类型。

getAttributeType(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributeType(int) - Method in interface javax.xml.stream. XMLStreamReader

返回提供的索引处的属性的XML类型

getAttributeTypeInfo(int) - Method in class javax.xml.validation. TypeInfoProvider

返回当前元素的指定属性的不可变的TypeInfo对象。

getAttributeValue(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributeValue(int) - Method in interface javax.xml.stream. XMLStreamReader

返回索引处的属性值

getAttributeValue(String, String) - Method in class javax.xml.stream.util. StreamReaderDelegate

getAttributeValue(String, String) - Method in interface javax.xml.stream. XMLStreamReader

返回具有命名空间和localName的属性的归一化属性值如果namespaceURI为空，则不会检查命名空间是否相等

getAttributeValue(QName) - Method in interface javax.xml.soap. SOAPElement

返回具有指定qname的属性值。

getAttributeValue(Name) - Method in interface javax.xml.soap. SOAPElement

返回具有指定名称的属性值。

getAttributeValueType(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回从 VALUE_开始的常量 VALUE_ ，指示指定元素中给定属性的值是否是任意的，被限制在指定范围内，被限制为一组枚举值中的一个，或是空格分隔的列表的任意值。

getAttributeValueType(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getAttrName() - Method in interface org.w3c.dom.events. MutationEvent

attrName表示DOMAttrModified事件中更改的 Attr节点的名称。

getAudioActionMap() - Method in class javax.swing.plaf.basic. BasicLookAndFeel

返回一个包含这种外观的音频动作的 ActionMap 。

getAudioClip(URL) - Method in class java.applet. Applet

已过时。

返回由 URL参数指定的 AudioClip对象。

getAudioClip(URL) - Method in interface java.applet. AppletContext

已过时。

创建音频剪辑。

getAudioClip(URL, String) - Method in class java.applet. Applet

已过时。

返回由 URL和 name参数指定的 AudioClip对象。

getAudioEqualizer() - Method in class javafx.scene.media. MediaPlayer

检索与此播放器关联的AudioEqualizer 。

getAudioFileFormat(File) - Static method in class javax.sound.sampled. AudioSystem

获取指定的 File的音频文件格式。

getAudioFileFormat(File) - Method in class javax.sound.sampled.spi. AudioFileReader

获取提供的 File的音频文件格式。

getAudioFileFormat(InputStream) - Static method in class javax.sound.sampled. AudioSystem

获取提供的输入流的音频文件格式。

getAudioFileFormat(InputStream) - Method in class javax.sound.sampled.spi. AudioFileReader

获取提供的输入流的音频文件格式。

getAudioFileFormat(URL) - Static method in class javax.sound.sampled. AudioSystem

获取指定URL的音频文件格式。

getAudioFileFormat(URL) - Method in class javax.sound.sampled.spi. AudioFileReader

获取提供的URL的音频文件格式。

getAudioFileTypes() - Static method in class javax.sound.sampled. AudioSystem

获取系统提供文件写入支持的文件类型。

getAudioFileTypes() - Method in class javax.sound.sampled.spi. AudioFileWriter

获取此音频文件写入程序提供的文件写入支持的文件类型。

getAudioFileTypes(AudioInputStream) - Static method in class javax.sound.sampled. AudioSystem

从指定的音频输入流获取系统可以写入的文件类型。

getAudioFileTypes(AudioInputStream) - Method in class javax.sound.sampled.spi. AudioFileWriter

获取音频文件写入器可以从指定的音频输入流中写入的文件类型。

getAudioInputStream(File) - Static method in class javax.sound.sampled. AudioSystem

从提供的 File获取音频输入流。

getAudioInputStream(File) - Method in class javax.sound.sampled.spi. AudioFileReader

从提供的 File获取音频输入流。

getAudioInputStream(InputStream) - Static method in class javax.sound.sampled. AudioSystem

从提供的输入流中获取音频输入流。

getAudioInputStream(InputStream) - Method in class javax.sound.sampled.spi. AudioFileReader

从提供的输入流中获取音频输入流。

getAudioInputStream(URL) - Static method in class javax.sound.sampled. AudioSystem

从提供的URL获取音频输入流。

getAudioInputStream(URL) - Method in class javax.sound.sampled.spi. AudioFileReader

从提供的URL获取音频输入流。

getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - Static method in class javax.sound.sampled. AudioSystem

通过转换所提供的音频输入流来获得所指示的编码的音频输入流。

getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - Method in class javax.sound.sampled.spi. FormatConversionProvider

从给定的音频输入流中获取具有指定编码的音频输入流。

getAudioInputStream(AudioFormat, AudioInputStream) - Static method in class javax.sound.sampled. AudioSystem

通过转换所提供的音频输入流来获得指示格式的音频输入流。

getAudioInputStream(AudioFormat, AudioInputStream) - Method in class javax.sound.sampled.spi. FormatConversionProvider

从给定的音频输入流中获取具有指定格式的音频输入流。

getAudioSpectrumInterval() - Method in class javafx.scene.media. MediaPlayer

检索音频频谱通知间隔的值，单位为秒。

getAudioSpectrumListener() - Method in class javafx.scene.media. MediaPlayer

检索音频频谱的听众。

getAudioSpectrumNumBands() - Method in class javafx.scene.media. MediaPlayer

检索音频频谱中的频带数。

getAudioSpectrumThreshold() - Method in class javafx.scene.media. MediaPlayer

以分贝取回音频频谱阈值。

getAuthenticationID() - Method in class javax.security.sasl. AuthorizeCallback

返回要检查的身份验证ID。

getAuthenticator() - Method in class com.sun.net.httpserver. HttpContext

返回当前设置的身份验证器（如果存在）。

getAuthority() - Method in class java.net. URI

返回此URI的已解码权限组件。

getAuthority() - Method in class java.net. URL

获得这个 URL的权限部分。

getAuthorityKeyIdentifier() - Method in class java.security.cert. X509CertSelector

返回authorityKeyIdentifier标准。

getAuthorityName() - Method in exception java.security.cert. CertificateRevokedException

返回签署证书撤销状态信息的权限的名称。

getAuthorizationID() - Method in class javax.security.sasl. AuthorizeCallback

返回要检查的授权ID。

getAuthorizationID() - Method in interface javax.security.sasl. SaslServer

报告此会话客户端的授权ID。

getAuthorizedID() - Method in class javax.security.sasl. AuthorizeCallback

返回授权用户的ID。

getAuthTime() - Method in class javax.security.auth.kerberos. KerberosTicket

返回客户端进行身份验证的时间。

getAutoCommit() - Method in interface java.sql. Connection

检索此 Connection对象的当前自动提交模式。

getAutoCommit() - Method in interface javax.sql.rowset. JdbcRowSet

每个 JdbcRowSet包含一个 Connection对象，从原始的 ResultSet或传递给它的JDBC属性。

getAutoCreateColumnsFromModel() - Method in class javax.swing. JTable

确定表是否将从模型中创建默认列。

getAutoCreateContainerGaps() - Method in class javax.swing. GroupLayout

返回 true如果容器和容器边界的组件之间的间隙自动创建。

getAutoCreateGaps() - Method in class javax.swing. GroupLayout

如果组件之间的间隙自动创建，则返回 true 。

getAutoCreateRowSorter() - Method in class javax.swing. JTable

返回true如果模型发生变化，应当创建一个新的RowSorter作为表的分拣机安装; 否则返回false 。

getAutoDelay() - Method in class java.awt. Robot

返回此机器人在生成事件后休眠的毫秒数。

getAutoLoadingErrors() - Method in class jdk.dynalink. DynamicLinkerFactory

返回在上次调用期间加载自动发现的链接器时遇到的ServiceConfigurationError的列表DynamicLinkerFactory.createLinker() 。

getAutoResizeMode() - Method in class javax.swing. JTable

返回表的自动调整大小模式。

getAutoscrollInsets() - Method in interface java.awt.dnd. Autoscroll

此方法返回描述自动滚动区域或边框相对于实现组件几何的 Insets 。

getAutoscrolls() - Method in class javax.swing. JComponent

获取 autoscrolls属性。

getAuxiliaryLookAndFeels() - Static method in class javax.swing. UIManager

返回辅助外观和感觉列表（可以是 null ）。

getAvailableAcceleratedMemory() - Method in class java.awt. GraphicsDevice

此方法返回此设备上加速内存中可用的字节数。

getAvailableAttributes() - Method in class java.awt. Font

返回此 Font支持的所有属性的 Font 。

getAvailableCalendarTypes() - Static method in class java.util. Calendar

返回一个不可修改 Set含支持的所有日历类型 Calendar在运行时环境。

getAvailableCell(int) - Method in class javafx.scene.control.skin. VirtualFlow

获取可以在布局中使用的单元格。

getAvailableChronologies() - Static method in interface java.time.chrono. Chronology

返回可用的年表。

getAvailableCurrencies() - Static method in class java.util. Currency

获得一组可用的货币。

getAvailableDataFlavors() - Method in class java.awt.datatransfer. Clipboard

返回一个 DataFlavor的数组，其中可以提供此剪贴板的当前内容。

getAvailableFontFamilyNames() - Method in class java.awt. GraphicsEnvironment

返回一个数组，该数组包含本地化为默认语言环境的 GraphicsEnvironment中所有字体族的名称，由 Locale.getDefault()返回。

getAvailableFontFamilyNames(Locale) - Method in class java.awt. GraphicsEnvironment

返回一个包含本地化为指定区域设置的 GraphicsEnvironment中所有字体族的名称的数组。

getAvailableIDs() - Static method in class java.util. TimeZone

获取支持的所有可用ID。

getAvailableIDs(int) - Static method in class java.util. TimeZone

根据给定的时区偏移（以毫秒为单位）获取可用ID。

getAvailableInstruments() - Method in interface javax.sound.midi. Synthesizer

获取合成器随附的仪器列表。

getAvailableLocales() - Method in interface java.awt.im.spi. InputMethodDescriptor

返回相应输入法支持的语言环境。

getAvailableLocales() - Static method in class java.text. BreakIterator

返回一个所有语言环境的数组，该类的 get*Instance方法可以返回本地化实例。

getAvailableLocales() - Static method in class java.text. Collator

返回一个所有区域的数组，为此类可以返回本地化实例的 getInstance方法。

getAvailableLocales() - Static method in class java.text. DateFormat

返回一个所有区域的数组，该类的 get*Instance方法可以返回本地化实例。

getAvailableLocales() - Static method in class java.text. DateFormatSymbols

返回一个所有区域的数组，为此类可以返回本地化实例的 getInstance方法。

getAvailableLocales() - Static method in class java.text. DecimalFormatSymbols

返回一个所有语言环境的数组，该类的 getInstance方法可以返回本地化实例。

getAvailableLocales() - Static method in class java.text. NumberFormat

返回一个所有本地化的数组，为此类可以返回本地化实例的 get*Instance方法。

getAvailableLocales() - Static method in class java.time.format. DecimalStyle

列出支持的所有语言环境。

getAvailableLocales() - Static method in class java.util. Calendar

返回一个所有语言环境的数组，该类的 getInstance方法可以返回本地化实例。

getAvailableLocales() - Static method in class java.util. Locale

返回所有已安装区域设置的数组。

getAvailableLocales() - Method in class java.util.spi. LocaleServiceProvider

返回此区域设置服务提供程序可以为其提供本地化对象或名称的所有区域设置的数组。

getAvailableLocales() - Method in class javax.imageio. ImageReader

返回可用于本地化警告侦听器和压缩设置的 Locale s的数组。

getAvailableLocales() - Method in class javax.imageio. ImageWriter

返回可用于本地化警告侦听器和压缩设置的 Locale s的数组。

getAvailableProcessors() - Method in interface java.lang.management. OperatingSystemMXBean

返回可用于Java虚拟机的处理器数量。

getAvailableSize(Dimension, Insets) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

根据容器大小和 Insets返回可用宽度。

getAvailableZoneIds() - Static method in class java.time.zone. ZoneRulesProvider

获取一组可用的区域ID。

getAvailableZoneIds() - Static method in class java.time. ZoneId

获取一组可用的区域ID。

getAverage() - Method in class java.util. DoubleSummaryStatistics

返回记录的值的算术平均值，如果没有记录值，则返回零。

getAverage() - Method in class java.util. IntSummaryStatistics

返回记录的值的算术平均值，如果没有记录值，则返回零。

getAverage() - Method in class java.util. LongSummaryStatistics

返回记录的值的算术平均值，如果没有记录值，则返回零。

getAWTEventListeners() - Method in class java.awt. Toolkit

返回在该工具包上注册的所有 AWTEventListener的数组。

getAWTEventListeners(long) - Method in class java.awt. Toolkit

返回在该工具包上注册的所有 AWTEventListener s的数组，该数组监听 eventMask参数中指定的所有事件类型。

getAWTKeyStroke(char) - Static method in class java.awt. AWTKeyStroke

返回一个 AWTKeyStroke的共享实例，表示指定字符的 KEY_TYPED事件。

getAWTKeyStroke(int, int) - Static method in class java.awt. AWTKeyStroke

返回一个 AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符。

getAWTKeyStroke(int, int, boolean) - Static method in class java.awt. AWTKeyStroke

返回一个 AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符，指定按下或释放该键是否被激活。

getAWTKeyStroke(Character, int) - Static method in class java.awt. AWTKeyStroke

返回一个 AWTKeyStroke的共享实例，该实例表示指定的Character对象的 KEY_TYPED事件和一组修饰符。

getAWTKeyStroke(String) - Static method in class java.awt. AWTKeyStroke

解析一个字符串并返回一个 AWTKeyStroke 。

getAWTKeyStrokeForEvent(KeyEvent) - Static method in class java.awt. AWTKeyStroke

返回一个 AWTKeyStroke ，表示生成给定的 KeyEvent 。

getAxis() - Method in class javafx.animation. RotateTransition

获取属性轴的值。

getAxis() - Method in class javafx.scene.transform. Rotate

获取属性轴的值。

getAxis() - Method in class javax.swing. BoxLayout

返回用于布局组件的轴。

getAxis() - Method in class javax.swing.text. BoxView

获取瓦片轴属性。

getAxis() - Method in interface org.w3c.dom.html. HTMLTableCellElement

命名相关标题组。

getAxisSortingPolicy() - Method in class javafx.scene.chart. LineChart

获取属性axisSortingPolicy的值。

getAzimuth() - Method in class javafx.scene.effect. Light.Distant

获取属性方位角的值。

getAzimuth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的方位属性定义。

getB() - Method in class java.security.spec. EllipticCurve

返回椭圆曲线的第二个系数 b 。

getBackBuffer() - Method in class java.awt. Component.FlipBufferStrategy

getBackBufferCapabilities() - Method in class java.awt. BufferCapabilities

getBackground() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的背景 Color 。

getBackground() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的背景颜色。

getBackground() - Method in class java.awt. Component

获取此组件的背景颜色。

getBackground() - Method in class java.awt. Graphics2D

返回用于清除区域的背景颜色。

getBackground() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的背景颜色。

getBackground() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的背景颜色。

getBackground() - Method in class java.awt. TextComponent

获取此文本组件的背景颜色。

getBackground() - Method in class java.awt. Window

获取此窗口的背景颜色。

getBackground() - Method in class javafx.scene.layout. Region

获取属性背景的值。

getBackground() - Method in interface javax.accessibility. AccessibleComponent

获取此对象的背景颜色。

getBackground() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getBackground() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的背景颜色。

getBackground() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取此对象的背景颜色。

getBackground() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getBackground() - Method in class javax.swing.text. GlyphView

获取用于渲染字形的背景颜色。

getBackground() - Method in class javax.swing.text. LabelView

获取用于渲染字形的背景颜色。

getBackground() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background属性定义。

getBackground() - Method in interface org.w3c.dom.html. HTMLBodyElement

背景纹理图像的URI。

getBackground(AttributeSet) - Method in class javax.swing.text. DefaultStyledDocument

从属性集获取背景颜色。

getBackground(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

获取一组属性并将其转换为背景颜色规范。

getBackground(AttributeSet) - Static method in class javax.swing.text. StyleConstants

从属性列表中获取背景颜色设置。

getBackground(AttributeSet) - Method in class javax.swing.text. StyleContext

获取一组属性并将其转换为背景颜色规范。

getBackground(AttributeSet) - Method in interface javax.swing.text. StyledDocument

获取一组属性并将其转换为背景颜色规范。

getBackgroundAt(int) - Method in class javax.swing. JTabbedPane

返回标签背景颜色为 index 。

getBackgroundAttachment() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-attachment属性定义。

getBackgroundColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-color属性定义。

getBackgroundImage() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-image属性定义。

getBackgroundNonSelectionColor() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回要用于非选定节点的背景颜色。

getBackgroundPainter(SynthContext) - Method in class javax.swing.plaf.nimbus. NimbusStyle

获取适当的背景Painter，如果有的话，给定SynthContext中指定的状态。

getBackgroundPosition() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-position属性定义。

getBackgroundRepeat() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-repeat属性定义。

getBackgroundSelectionColor() - Method in class javax.swing.tree. DefaultTreeCellRenderer

如果选择节点，则返回用于背景的颜色。

getBackoffStrategy() - Method in class javafx.concurrent. ScheduledService

获取属性backoffStrategy的值。

getBalance() - Method in class javafx.scene.media. AudioClip

获取此剪辑的默认平衡级别。

getBalance() - Method in class javafx.scene.media. MediaPlayer

检索音频平衡。

getBandOffsets() - Method in class java.awt.image. ComponentSampleModel

返回所有频段的频偏。

getBands() - Method in class javafx.scene.media. AudioEqualizer

ObservableList包含EqualizerBand元素。

getBandwidth() - Method in class javafx.scene.media. EqualizerBand

检索频带的带宽。

getBank() - Method in class javax.sound.midi. Patch

返回包含 Patch指定的位置的票据的银行编号。

getBankData() - Method in class java.awt.image. DataBufferByte

返回所有库的数据数组。

getBankData() - Method in class java.awt.image. DataBufferDouble

返回所有存储区的数据数组。

getBankData() - Method in class java.awt.image. DataBufferFloat

返回所有存储区的数据数组。

getBankData() - Method in class java.awt.image. DataBufferInt

返回所有库的数据数组。

getBankData() - Method in class java.awt.image. DataBufferShort

返回所有库的数据数组。

getBankData() - Method in class java.awt.image. DataBufferUShort

返回所有库的数据数组。

getBankIndices() - Method in class java.awt.image. ComponentSampleModel

返回所有频段的银行指数。

getBarGap() - Method in class javafx.scene.chart. BarChart

获取属性barGap的值。

getBase() - Method in class javax.swing.text.html. HTMLDocument

返回相对URL的位置。

getBase() - Method in class javax.swing.text.html. StyleSheet

返回基数。

getBase64Content() - Method in class javax.xml.soap. AttachmentPart

返回一个 InputStream ，可用于获取 AttachmentPart的内容作为Base64编码字符数据，此方法将base64编码附件的原始字节并返回。

getBaseBundleName() - Method in class java.util. ResourceBundle

如果已知，则返回此包的基本名称，如果未知，则返回 null 。

getBaseImage() - Method in class java.awt.image. AbstractMultiResolutionImage

返回表示最佳版本的图像的基本图像，以便以默认的宽度和高度渲染。

getBaseImage() - Method in class java.awt.image. BaseMultiResolutionImage

getBaseLevel() - Method in class java.text. Bidi

返回基本级别（如果从左到右为0，如果从右到左，则返回1）。

getBaseline() - Method in class java.awt.font. TextLayout

返回此 TextLayout的基准。

getBaseline(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回指定选项卡的基线。

getBaseline(int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

返回指定选项卡的基线。

getBaseline(int, int) - Method in class java.awt. Component

返回基线。

getBaseline(int, int) - Method in class javax.swing. JComponent

返回基线。

getBaseline(int, int) - Method in class javax.swing. JSpinner.DefaultEditor

返回基线。

getBaseline(Component, int, int) - Method in class javax.swing.border. AbstractBorder

返回基线。

getBaseline(Component, int, int) - Method in class javax.swing.border. TitledBorder

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicButtonUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicLabelUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicListUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicPanelUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicSliderUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicSpinnerUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicTableUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicTextAreaUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicTextFieldUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf. ComponentUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf. LayerUI

如果 JLayer的视图组件不是 null ， null调用视图的 getBaseline()方法。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.metal. MetalComboBoxUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth. SynthLabelUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth. SynthProgressBarUI

返回基线。

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth. SynthSliderUI

返回基线。

getBaselineFor(char) - Method in class java.awt. Font

返回适合显示此字符的基线。

getBaselineIndex() - Method in class java.awt.font. LineMetrics

返回文本的基准索引。

getBaselineOffset() - Method in class javafx.scene.control. Control

基于第一个受管理的子节点计算基线偏移量。

getBaselineOffset() - Method in class javafx.scene.layout. HBox

getBaselineOffset() - Method in class javafx.scene. Node

当基于与其他节点垂直对齐的节点的layoutBounds.minY位置时，“字母”（或“罗马”）基线偏移。

getBaselineOffset() - Method in class javafx.scene. Parent

基于第一个受管理的子节点计算基线偏移量。

getBaselineOffset() - Method in class javafx.scene.text. Text

获取属性baselineOffset的值。

getBaselineOffset() - Method in class javafx.scene.text. TextFlow

getBaselineOffset() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回基线偏移量。

getBaselineOffset() - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

返回基线偏移量。

getBaselineOffsets() - Method in class java.awt.font. LineMetrics

返回相对于文本基线的文本的基线偏移量。

getBaselineOffsets() - Method in class java.awt.font. TextLayout

返回用于此 TextLayout的基线的偏移数组。

getBaselineResizeBehavior() - Method in class java.awt. Component

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior() - Method in class javax.swing. JComponent

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior() - Method in class javax.swing. JSpinner.DefaultEditor

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(Component) - Method in class javax.swing.border. AbstractBorder

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(Component) - Method in class javax.swing.border. TitledBorder

返回一个枚举，指示边框的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicLabelUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicListUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicPanelUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicSliderUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicSpinnerUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicTableUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicTextAreaUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicTextFieldUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf. ComponentUI

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf. LayerUI

如果 JLayer的视图组件不是 null ，则返回视图 getBaselineResizeBehavior()方法的结果。

getBaseOperation() - Method in class jdk.dynalink. NamedOperation

返回此命名操作的基本操作。

getBaseOperation() - Method in class jdk.dynalink. NamespaceOperation

返回此命名操作的基本操作。

getBaseOperation(Operation) - Static method in class jdk.dynalink. NamedOperation

如果传递的操作是命名操作，则返回其 NamedOperation.getBaseOperation() ，否则返回操作。

getBaseOperation(Operation) - Static method in class jdk.dynalink. NamespaceOperation

如果传递的操作是命名空间操作，则返回其 NamespaceOperation.getBaseOperation() ，否则返回操作。

getBaseType() - Method in interface java.sql. Array

检索由该 Array对象指定的数组中的元素的JDBC类型。

getBaseType() - Method in class javax.activation. MimeType

返回此对象的String表示，而不包含参数列表。

getBaseType() - Method in class javax.sql.rowset.serial. SerialArray

检索此 SerialArray对象中的元素的SQL类型。

getBaseTypeName() - Method in interface java.sql. Array

检索此 Array对象指定的数组中的元素的SQL类型名称。

getBaseTypeName() - Method in interface java.sql. Ref

检索此 Ref对象引用的SQL结构类型的完全限定SQL名称。

getBaseTypeName() - Method in class javax.sql.rowset.serial. SerialArray

检索此 SerialArray对象中元素的DBMS特定类型名称。

getBaseTypeName() - Method in class javax.sql.rowset.serial. SerialRef

返回描述 Ref的基本类型名称的 Ref 。

getBaseUnit() - Method in enum java.time.temporal. ChronoField

getBaseUnit() - Method in interface java.time.temporal. TemporalField

获取测量场的单位。

getBaseURI() - Method in class javax.imageio.metadata. IIOMetadataNode

IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

getBaseURI() - Method in class javax.xml.crypto.dom. DOMCryptoContext

getBaseURI() - Method in interface javax.xml.crypto. XMLCryptoContext

返回基本URI。

getBaseURI() - Method in interface javax.xml.stream.events. EntityDeclaration

获取此引用的基本URI，如果此信息不可用，则为null

getBaseURI() - Method in interface org.w3c.dom.ls. LSInput

要使用的基本URI（参见[ IETF RFC 2396 ]中的5.1.4））将相对的 systemId解析为绝对URI。

getBaseURI() - Method in interface org.w3c.dom. Node

该节点的绝对基本URI或 null如果实现无法获取绝对URI。

getBasicChannel() - Method in class javax.smartcardio. Card

返回基本逻辑通道的CardChannel。

getBasicConstraints() - Method in class java.security.cert. X509Certificate

从关键的 BasicConstraints扩展名（OID = 2.5.29.19）获取证书约束路径长度。

getBasicConstraints() - Method in class java.security.cert. X509CertSelector

返回基本约束约束。

getBasicSplitPaneUI() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

返回接收者目前的 SplitPaneUI 。

getBean() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. JavaBeanStringProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoubleProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringProperty

返回包含此属性的 Object 。

getBean() - Method in interface javafx.beans.property. ReadOnlyProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleBooleanProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleDoubleProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleFloatProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleIntegerProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleListProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleLongProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleMapProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleObjectProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleSetProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.beans.property. SimpleStringProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.css. SimpleStyleableBooleanProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.css. SimpleStyleableDoubleProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.css. SimpleStyleableFloatProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.css. SimpleStyleableIntegerProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.css. SimpleStyleableLongProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.css. SimpleStyleableObjectProperty

返回包含此属性的 Object 。

getBean() - Method in class javafx.css. SimpleStyleableStringProperty

返回包含此属性的 Object 。

getBean(CommandInfo) - Method in class javax.activation. DataHandler

一个方便的方法，它接受CommandInfo对象并实例化相应的命令，通常是一个JavaBean组件。

getBeanClass() - Method in class java.beans. BeanDescriptor

获取bean的Class对象。

getBeanContext() - Method in interface java.beans.beancontext. BeanContextChild

获取 BeanContext与此 BeanContextChild相关联。

getBeanContext() - Method in class java.beans.beancontext. BeanContextChildSupport

获取嵌套 BeanContext这个 BeanContextChildSupport 。

getBeanContext() - Method in class java.beans.beancontext. BeanContextEvent

获取与此事件关联的 BeanContext 。

getBeanContextChildPeer() - Method in class java.beans.beancontext. BeanContextChildSupport

获取 BeanContextChild与此 BeanContextChildSupport相关联。

getBeanContextPeer() - Method in class java.beans.beancontext. BeanContextSupport

获取 BeanContext的实例，该对象正在为其提供实现。

getBeanContextProxy() - Method in interface java.beans.beancontext. BeanContextProxy

获取与此对象关联的 BeanContextChild （或子接口）。

getBeanContextServicesPeer() - Method in class java.beans.beancontext. BeanContextServicesSupport

获取 BeanContextServices与此 BeanContextServicesSupport相关联。

getBeanDescriptor() - Method in interface java.beans. BeanInfo

返回提供关于该bean的整体信息的bean描述符，例如其显示名称或其定制器。

getBeanDescriptor() - Method in class java.beans. SimpleBeanInfo

拒绝关于bean的类和定制器的知识。

getBeanInfo(Class<?>) - Static method in class java.beans. Introspector

内省Java Bean并了解其所有属性，暴露的方法和事件。

getBeanInfo(Class<?>, int) - Static method in class java.beans. Introspector

对Java bean进行内省，并了解其所有属性，公开方法和事件，并遵守一些控制标志。

getBeanInfo(Class<?>, Class<?>) - Static method in class java.beans. Introspector

内省Java bean并了解其属性，暴露的方法，低于给定的“停止”点。

getBeanInfo(Class<?>, Class<?>, int) - Static method in class java.beans. Introspector

内省Java Bean，并了解其所有属性，暴露的方法和事件，低于给定的 stopClass点，受到一些控制 flags 。

getBeanInfoSearchPath() - Static method in class java.beans. Introspector

获取将用于查找BeanInfo类的包名称列表。

getBeforeIndex(int, int) - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回给定索引之前的String。

getBeforeIndex(int, int) - Method in interface javax.accessibility. AccessibleText

返回给定索引前的 String 。

getBeforeIndex(int, int) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回给定索引之前的String。

getBeforeIndex(int, int) - Method in class javax.swing. JLabel.AccessibleJLabel

返回给定索引之前的String。

getBeforeIndex(int, int) - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

在给定的 String之前返回 index 。

getBeforeIndex(int, int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回给定索引之前的String。

getBeforeIndex(int, int) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回给定索引之前的String。

getBeforeIndex(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回给定索引之前的String。

getBeginIndex() - Method in interface java.text. CharacterIterator

返回文本的起始索引。

getBeginIndex() - Method in class java.text. FieldPosition

检索请求字段中第一个字符的索引。

getBeginIndex() - Method in class java.text. StringCharacterIterator

为String实现CharacterIterator.getBeginIndex（）。

getBeginIndex() - Method in class javax.swing.text. Segment

返回文本的起始索引。

getBestConfiguration(GraphicsConfigTemplate) - Method in class java.awt. GraphicsDevice

返回可能通过GraphicsConfigTemplate中定义的条件的“最佳”配置。

getBestConfiguration(GraphicsConfiguration[]) - Method in class java.awt. GraphicsConfigTemplate

返回可能通过 GraphicsConfigTemplate定义的条件的“最佳”配置。

getBestCursorSize(int, int) - Method in class java.awt. Toolkit

返回最接近所需大小的支持的光标维度。

getBestRowIdentifier(String, String, String, int, boolean) - Method in interface java.sql. DatabaseMetaData

检索表的唯一标识行的最佳列集描述。

getBestSize(double, double) - Static method in class javafx.scene. ImageCursor

获取最接近指定的首选大小的支持的光标大小。

getBevelType() - Method in class javax.swing.border. BevelBorder

返回斜角边框的类型。

getBgColor() - Method in interface org.w3c.dom.html. HTMLBodyElement

文件背景颜色。

getBgColor() - Method in interface org.w3c.dom.html. HTMLTableCellElement

单元格背景颜色。

getBgColor() - Method in interface org.w3c.dom.html. HTMLTableElement

单元格背景颜色。

getBgColor() - Method in interface org.w3c.dom.html. HTMLTableRowElement

行的背景颜色。

getBias() - Method in class javax.swing.text. JTextComponent.DropLocation

返回下降指数的偏差。

getBidiLevel(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取BidiLevel设置。

getBidiRootElement() - Method in class javax.swing.text. AbstractDocument

返回此文档的双向结构的根元素。

getBigDecimal(int) - Method in interface java.sql. CallableStatement

将指定的JDBC NUMERIC参数的值作为 java.math.BigDecimal对象 NUMERIC ，该对象的值包含小数点右侧的数字。

getBigDecimal(int) - Method in interface java.sql. ResultSet

以 ResultSet作为 java.math.BigDecimal该 ResultSet对象的当前行中指定列的值。

getBigDecimal(int, int) - Method in interface java.sql. CallableStatement

已过时。
使用getBigDecimal(int parameterIndex)或getBigDecimal(String parameterName)

getBigDecimal(int, int) - Method in interface java.sql. ResultSet

已过时。
使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)

getBigDecimal(String) - Method in interface java.sql. CallableStatement

检索JDBC NUMERIC参数的值作为 java.math.BigDecimal对象，其值包含小数点右侧的数字。

getBigDecimal(String) - Method in interface java.sql. ResultSet

以 ResultSet对象的当前行中的指定列的值作为 java.math.BigDecimal完全精确 java.math.BigDecimal 。

getBigDecimal(String, int) - Method in interface java.sql. ResultSet

已过时。
使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)

getBinaryName(TypeElement) - Method in interface javax.lang.model.util. Elements

返回类型元素的 二进制名称 。

getBinaryStream() - Method in interface java.sql. Blob

检索由该 Blob实例指定的 BLOB值作为流。

getBinaryStream() - Method in interface java.sql. SQLXML

检索此SQLXML实例指定的XML值作为流。

getBinaryStream() - Method in class javax.sql.rowset.serial. SerialBlob

返回此 SerialBlob对象作为输入流。

getBinaryStream(int) - Method in interface java.sql. ResultSet

将此 ResultSet对象的当前行中的指定列的值作为未解释的字节流 ResultSet 。

getBinaryStream(long, long) - Method in interface java.sql. Blob

返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为长度字节。

getBinaryStream(long, long) - Method in class javax.sql.rowset.serial. SerialBlob

返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为长度字节。

getBinaryStream(String) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值作为未解释的流 byte s。

getBinding() - Method in interface javax.xml.ws. BindingProvider

获取此绑定提供程序的绑定。

getBinding() - Method in class javax.xml.ws. Endpoint

返回此端点的绑定。

getBinding() - Method in interface jdk.nashorn.api.tree. VariableTree

返回此声明的绑定。

getBindingID() - Method in interface javax.xml.ws. Binding

获取此绑定实例的URI。

getBindingID() - Method in interface javax.xml.ws.handler. PortInfo

获取标识被访问端口使用的绑定的URI。

getBindings() - Method in class javax.script. ScriptEngineManager

getBindings返回 globalScope字段的值。

getBindings(int) - Method in class javax.script. AbstractScriptEngine

返回 Bindings与受保护的规定范围值 context场。

getBindings(int) - Method in interface javax.script. ScriptContext

获取 Bindings ，在这个给定的范围相关 ScriptContext 。

getBindings(int) - Method in interface javax.script. ScriptEngine

返回命名值的范围。

getBindings(int) - Method in class javax.script. SimpleScriptContext

如果指定的范围为 ENGINE_SCOPE则返回 engineScope字段的值。

getBitDepth() - Method in class java.awt. DisplayMode

以像素为单位返回显示的位深度。

getBitMasks() - Method in class java.awt.image. SinglePixelPackedSampleModel

返回所有频段的位掩码。

getBitOffset() - Method in interface javax.imageio.stream. ImageInputStream

返回当前的位偏移量，为0到7之间的整数，包括0和7。

getBitOffset() - Method in class javax.imageio.stream. ImageInputStreamImpl

getBitOffset(int) - Method in class java.awt.image. MultiPixelPackedSampleModel

返回以扫描线的 x像素存储的数据元素中的位数偏移量。

getBitOffsets() - Method in class java.awt.image. SinglePixelPackedSampleModel

将位偏移返回到表示所有频带的像素的数据数组元素中。

getBitRate(float) - Method in class javax.imageio. ImageWriteParam

返回 float指示在给定质量水平下每个输入图像数据位的输出数据的位数的估计。

getBitsPerBand(int) - Method in class javax.imageio. ImageTypeSpecifier

返回用于表示给定波段的样本的位数。

getBlack() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的黑色。

getBlack() - Method in class javax.swing.plaf.metal. MetalTheme

返回黑色。

getBlack() - Method in class javax.swing.plaf.metal. OceanTheme

返回黑色。

getBlackBoxBounds(int, int) - Method in class java.awt.font. TextLayout

返回指定范围内的字符的黑框边界。

getBlackLineBorderUIResource() - Static method in class javax.swing.plaf. BorderUIResource

返回黑线边框UI资源。

getBlendMode() - Method in class javafx.scene. Node

获取属性blendMode的值。

getBlinkRate() - Method in interface javax.swing.text. Caret

获取插入符号的闪烁速率。

getBlinkRate() - Method in class javax.swing.text. DefaultCaret

获得插入眨眼率。

getBlob(int) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定的JDBC BLOB参数的值作为Blob对象。

getBlob(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 ResultSet对象的形式 Blob此 ResultSet对象的当前行中指定列的值。

getBlob(String) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取 JDBC BLOB参数的值作为Blob对象。

getBlob(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 ResultSet对象的形式 Blob此 ResultSet对象的当前行中指定列的值。

getBlock() - Method in interface com.sun.source.tree. CatchTree

返回catch块。

getBlock() - Method in interface com.sun.source.tree. SynchronizedTree

返回 synchronized语句的块。

getBlock() - Method in interface com.sun.source.tree. TryTree

返回 try语句的块。

getBlock() - Method in interface jdk.nashorn.api.tree. CatchTree

返回此catch块的代码块。

getBlock() - Method in interface jdk.nashorn.api.tree. TryTree

返回'try'语句的'try'块。

getBlockedCount() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程阻止进入或重新输入监视器的总次数。

getBlockedTime() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程由于启用线程争用监控而阻止进入或重新输入监视器的大致累积已用时间（以毫秒为单位）。

getBlocker(Thread) - Static method in class java.util.concurrent.locks. LockSupport

返回提供给最近调用尚未解除阻塞的park方法的阻止程序对象，如果不阻止则返回null。

getBlockIncrement() - Method in interface java.awt. Adjustable

获取可调整对象的块值增量。

getBlockIncrement() - Method in class java.awt. Scrollbar

获取此滚动条的块增量。

getBlockIncrement() - Method in class java.awt. ScrollPaneAdjustable

getBlockIncrement() - Method in class javafx.scene.control. ScrollBar

获取属性blockIncrement的值。

getBlockIncrement() - Method in class javafx.scene.control. Slider

获取属性blockIncrement的值。

getBlockIncrement() - Method in class javax.swing. JScrollBar

为了向后兼容java.awt.Scrollbar。

getBlockIncrement(int) - Method in class javax.swing. JScrollBar

给定一个块（通常是“页”）上/下请求，返回滚动条的值的值。

getBlockIncrement(int) - Method in class javax.swing. JScrollPane.ScrollBar

如果视口的视图为 Scrollable对象，则计算滚动的块增量。

getBlockSize() - Method in class javax.crypto. Cipher

返回块大小（以字节为单位）。

getBlockTags() - Method in interface com.sun.source.doctree. DocCommentTree

返回文档注释的块标签。

getBlue() - Method in class java.awt. Color

返回默认sRGB空间中0-255范围内的蓝色分量。

getBlue() - Method in class javafx.scene.paint. Color

Color的蓝色成分，范围 0.0-1.0 。

getBlue() - Method in interface org.w3c.dom.css. RGBColor

该属性用于RGB颜色的蓝色值。

getBlue(int) - Method in class java.awt.image. ColorModel

返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。

getBlue(int) - Method in class java.awt.image. ComponentColorModel

返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。

getBlue(int) - Method in class java.awt.image. DirectColorModel

返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getBlue(int) - Method in class java.awt.image. IndexColorModel

返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。

getBlue(Object) - Method in class java.awt.image. ColorModel

返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getBlue(Object) - Method in class java.awt.image. ComponentColorModel

返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getBlue(Object) - Method in class java.awt.image. DirectColorModel

返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getBlueMask() - Method in class java.awt.image. DirectColorModel

返回掩码，指示 int像素表示中的哪些位包含蓝色分量。

getBlues(byte[]) - Method in class java.awt.image. IndexColorModel

将蓝色组件数组复制到指定的数组中。

getBlurType() - Method in class javafx.scene.effect. DropShadow

获取属性blurType的值。

getBlurType() - Method in class javafx.scene.effect. InnerShadow

获取属性blurType的值。

getBlurType() - Method in class javafx.scene.effect. Shadow

获取属性blurType的值。

getBody() - Method in interface com.sun.source.doctree. CommentTree

返回注释的文本。

getBody() - Method in interface com.sun.source.doctree. DeprecatedTree

返回解释为什么不推荐使用某项的描述。

getBody() - Method in interface com.sun.source.doctree. DocCommentTree

返回文档注释的正文，出现在第一个句子之后，并返回任何块标记之前。

getBody() - Method in interface com.sun.source.doctree. HiddenTree

返回说明为什么隐藏项目的描述。

getBody() - Method in interface com.sun.source.doctree. LiteralTree

返回 @code或 @literal标签的 @code 。

getBody() - Method in interface com.sun.source.doctree. SinceTree

返回说明正在记录的项目的可用性的文本。

getBody() - Method in interface com.sun.source.doctree. TextTree

返回文本。

getBody() - Method in interface com.sun.source.doctree. VersionTree

返回标签的正文。

getBody() - Method in interface com.sun.source.tree. LambdaExpressionTree

返回lambda表达式的正文。

getBody() - Method in interface com.sun.source.tree. MethodTree

返回方法体，如果这是抽象或本机方法，则返回 null 。

getBody() - Method in class java.net. CacheRequest

返回一个可以写入响应体的OutputStream。

getBody() - Method in class java.net. CacheResponse

将响应体作为InputStream返回。

getBody() - Method in interface javax.xml.soap. SOAPEnvelope

返回 SOAPBody与此相关联的对象 SOAPEnvelope对象。

getBody() - Method in interface jdk.incubator.http. HttpResponse.BodyProcessor

返回一个 CompletionStage ，当完成后将返回响应体对象。

getBody() - Method in interface jdk.nashorn.api.tree. FunctionDeclarationTree

返回此函数的代码正文。

getBody() - Method in interface jdk.nashorn.api.tree. FunctionExpressionTree

返回此函数的正文。

getBody() - Method in interface org.w3c.dom.html. HTMLDocument

包含文档内容的元素。

getBodyKind() - Method in interface com.sun.source.tree. LambdaExpressionTree

返回lambda表达式的主体的种类。

getBoolean(int) - Method in interface java.sql. CallableStatement

获取指定的JDBC的价值 BIT或者 BOOLEAN作为参数 boolean Java编程语言。

getBoolean(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 boolean此 ResultSet对象的当前行中指定列的值。

getBoolean(Object) - Method in class java.lang.reflect. Field

获取静态或实例的值 boolean字段。

getBoolean(Object) - Method in class javax.swing. UIDefaults

如果值为 key是布尔值，则返回布尔值，否则返回false。

getBoolean(Object) - Static method in class javax.swing. UIManager

从与键值相关联的默认值返回一个布尔值。

getBoolean(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中索引组件的值，如 boolean 。

getBoolean(Object, Locale) - Method in class javax.swing. UIDefaults

如果值 key对于给定 Locale是布尔值，则返回该boolean值，否则返回false。

getBoolean(Object, Locale) - Static method in class javax.swing. UIManager

从与键值和给定的 Locale相关联的默认值返回一个布尔值。

getBoolean(String) - Static method in class java.lang. Boolean

返回 true当且仅当由参数命名的系统属性存在且等于忽略大小写时，字符串 "true" 。

getBoolean(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 boolean JDBC BIT或 BOOLEAN参数的值。

getBoolean(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 boolean此 ResultSet对象当前行中指定列的值。

getBoolean(String, boolean) - Method in class java.util.prefs. AbstractPreferences

实现 getBoolean方法按照在本说明书中 Preferences.getBoolean(String,boolean) 。

getBoolean(String, boolean) - Method in class java.util.prefs. Preferences

返回由此首选项节点中与指定键相关联的字符串表示的布尔值。

getBoolean(SynthContext, Object, boolean) - Method in class javax.swing.plaf.synth. SynthStyle

方便的方法来获取一个特定的style属性，其值是一个布尔值。

getBooleanConverter() - Static method in class javafx.css. StyleConverter

返回一个 StyleConverter ，其将“真”或“假”到 Boolean 。

getBooleanValue() - Method in interface org.w3c.dom.xpath. XPathResult

这个布尔值的结果。

getBootClassPath() - Method in interface java.lang.management. RuntimeMXBean

返回bootstrap类加载器用于搜索类文件的引导类路径。

getBorder() - Method in class javafx.scene.layout. Region

获取属性边框的值。

getBorder() - Method in class javax.swing.border. TitledBorder

返回标题边框的边框。

getBorder() - Method in class javax.swing. JComponent

如果当前没有设置边框，则返回此组件的边框或 null 。

getBorder() - Method in class javax.swing. JLayer

将其功能委托给 getView().getBorder()方法，如果视图组件是 javax.swing.JComponent的实例，否则返回 null 。

getBorder() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

返回此组件的边框，如果当前未设置边框，则返回null。

getBorder() - Method in class javax.swing.tree. DefaultTreeCellEditor.DefaultTextField

覆盖 JComponent.getBorder以返回当前边框。

getBorder() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border属性定义。

getBorder() - Method in interface org.w3c.dom.html. HTMLImageElement

图像边框宽度。

getBorder() - Method in interface org.w3c.dom.html. HTMLObjectElement

对象边框宽度。

getBorder() - Method in interface org.w3c.dom.html. HTMLTableElement

表格边框的宽度。

getBorder(Object) - Method in class javax.swing. UIDefaults

如果 key的值是 Border返回，否则返回 null 。

getBorder(Object) - Static method in class javax.swing. UIManager

从默认值返回一个边框。

getBorder(Object, Locale) - Method in class javax.swing. UIDefaults

如果值 key对于给定 Locale是 Border返回它，否则返回 null 。

getBorder(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回一个边框。

getBorderBottom() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom属性定义。

getBorderBottomColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom-color属性定义。

getBorderBottomStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom-style属性定义。

getBorderBottomWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom-width属性定义。

getBorderCollapse() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-collapse属性定义。

getBorderColor() - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow

返回边框颜色。

getBorderColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-color属性定义。

getBorderInsets() - Method in class javax.swing.border. EmptyBorder

返回边框的插入。

getBorderInsets() - Method in class javax.swing.border. MatteBorder

返回边框的插入。

getBorderInsets(Component) - Method in class javax.swing.border. AbstractBorder

此默认实现返回一个由AbstractBorder.getBorderInsets(Component,Insets)方法初始化的新的Insets对象。

getBorderInsets(Component) - Method in interface javax.swing.border. Border

返回边框的插入。

getBorderInsets(Component) - Method in class javax.swing.plaf.basic. BasicBorders.SplitPaneBorder

getBorderInsets(Component) - Method in class javax.swing.plaf. BorderUIResource

getBorderInsets(Component, Insets) - Method in class javax.swing.border. AbstractBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. BevelBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. CompoundBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. EmptyBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. EtchedBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. LineBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. MatteBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. SoftBevelBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. StrokeBorder

使用此边框的当前插图重新初始化 insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.border. TitledBorder

使用此Border的当前Insets重新初始化insets参数。

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic. BasicBorders.ButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic. BasicBorders.FieldBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic. BasicBorders.MarginBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic. BasicBorders.MenuBarBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic. BasicBorders.RadioButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic. BasicBorders.ToggleButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.ButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.Flush3DBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.InternalFrameBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.MenuBarBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.MenuItemBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.OptionDialogBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.PaletteBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.PopupMenuBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.ScrollPaneBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.TableHeaderBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal. MetalBorders.ToolBarBorder

getBorderLeft() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left属性定义。

getBorderLeftColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left-color属性定义。

getBorderLeftStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left-style属性定义。

getBorderLeftWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left-width属性定义。

getBorderPainter(SynthContext) - Method in class javax.swing.plaf.nimbus. NimbusStyle

获取适当的边界Painter，如果有的话，给定SynthContext中指定的状态。

getBorderRight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right属性定义。

getBorderRightColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right-color属性定义。

getBorderRightStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right-style属性定义。

getBorderRightWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right-width属性定义。

getBorderSelectionColor() - Method in class javax.swing.tree. DefaultTreeCellEditor

返回绘制边框的颜色。

getBorderSelectionColor() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回绘制边框的颜色。

getBorderSpacing() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-spacing属性定义。

getBorderStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-style属性定义。

getBorderTitle(Border) - Method in class javax.swing. JComponent.AccessibleJComponent

递归搜索具有非空标题的TitledBorder的边界层次结构（如果存在）。

getBorderTop() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top属性定义。

getBorderTopColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top-color属性定义。

getBorderTopStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top-style属性定义。

getBorderTopWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top-width属性定义。

getBorderWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-width属性定义。

getBottom() - Method in class javafx.geometry. Insets

底部的插图

getBottom() - Method in class javafx.scene.layout. BorderPane

获取属性底部的值。

getBottom() - Method in class javafx.scene.layout. BorderWidths

非负值（ BorderWidths.AUTO除外 ），表示边框底部的边框厚度。

getBottom() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的底层属性定义。

getBottom() - Method in interface org.w3c.dom.css. Rect

该属性用于rect的底部。

getBottomAnchor(Node) - Static method in class javafx.scene.layout. AnchorPane

如果设置，返回小孩的底部锚约束。

getBottomComponent() - Method in class javax.swing. JSplitPane

返回下面的组件或分隔符的右侧。

getBottomInput() - Method in class javafx.scene.effect. Blend

获取属性bottomInput的值。

getBottomInset() - Method in class javax.swing.text. AsyncBoxView

获取视图边缘的底部。

getBottomInset() - Method in class javax.swing.text. CompositeView

获取底部插图。

getBottomLeftHorizontalRadius() - Method in class javafx.scene.layout. CornerRadii

左下角的水平半径的长度。

getBottomLeftVerticalRadius() - Method in class javafx.scene.layout. CornerRadii

左下角的垂直半径的长度。

getBottomMargin() - Method in class javafx.print. PageLayout

以点为单位返回页面布局的底部边距。

getBottomOpacity() - Method in class javafx.scene.effect. Reflection

获取属性bottomOpacity的值。

getBottomPanel() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

返回底部面板。

getBottomRightHorizontalRadius() - Method in class javafx.scene.layout. CornerRadii

右下角水平半径的长度。

getBottomRightVerticalRadius() - Method in class javafx.scene.layout. CornerRadii

右下角垂直半径的长度。

getBottomStroke() - Method in class javafx.scene.layout. BorderStroke

定义此边框底部的填充。

getBottomStyle() - Method in class javafx.scene.layout. BorderStroke

定义此边框底部的样式。

getBound() - Method in interface com.sun.source.tree. WildcardTree

返回通配符的边界。

getBoundActions() - Method in interface javax.swing.text. Keymap

获取此键盘映射中定义的所有操作。

getBoundedPosition(GlyphView, int, float, float) - Method in class javax.swing.text. GlyphView.GlyphPainter

确定表示适合给定跨度的最大提前的模型位置。

getBoundingBox() - Method in class java.awt. Polygon

已过时。
从JDK 1.1版开始，由getBounds()替代。

getBoundKeyStrokes() - Method in interface javax.swing.text. Keymap

获取此映射中所有与某些操作绑定的按键。

getBounds() - Method in class com.sun.java.accessibility.util. Translator

返回此对象的当前边界。

getBounds() - Method in interface com.sun.source.tree. IntersectionTypeTree

返回类型的边界。

getBounds() - Method in interface com.sun.source.tree. TypeParameterTree

返回type参数的边界。

getBounds() - Method in class java.awt. Component.AccessibleAWTComponent

以Rectangle对象的形式获取此对象的边界。

getBounds() - Method in class java.awt. Component

以 Rectangle对象的形式获取此组件的边界。

getBounds() - Method in class java.awt.font. GraphicAttribute

返回一个Rectangle2D ，它包含相对于渲染位置由此GraphicAttribute绘制的所有位。

getBounds() - Method in class java.awt.font. ImageGraphicAttribute

返回一个Rectangle2D ，它包含相对于渲染位置的由此ImageGraphicAttribute呈现的所有位。

getBounds() - Method in class java.awt.font. ShapeGraphicAttribute

返回一个Rectangle2D ，它包含了相对于渲染位置的ShapeGraphicAttribute绘制的所有位。

getBounds() - Method in class java.awt.font. TextLayout

返回这个 TextLayout的边界。

getBounds() - Method in class java.awt.geom. Area

返回边界Rectangle完全包围此Area 。

getBounds() - Method in class java.awt.geom. CubicCurve2D

返回一个整数Rectangle完全包围Shape 。

getBounds() - Method in class java.awt.geom. Line2D

返回一个整数Rectangle完全包围Shape 。

getBounds() - Method in class java.awt.geom. Path2D

返回一个整数Rectangle完全包围Shape 。

getBounds() - Method in class java.awt.geom. QuadCurve2D

返回一个整数Rectangle完全包围Shape 。

getBounds() - Method in class java.awt.geom. RectangularShape

返回一个整数Rectangle完全包围Shape 。

getBounds() - Method in class java.awt. GraphicsConfiguration

返回设备坐标中的 GraphicsConfiguration的边界。

getBounds() - Method in class java.awt.image. Raster

返回此栅格的边界矩形。

getBounds() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

以Rectangle对象的形式获取此对象的边界。

getBounds() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

以 Rectangle对象的形式获取此对象的边界。

getBounds() - Method in class java.awt. Polygon

获得这个 Polygon的边框。

getBounds() - Method in class java.awt. Rectangle

获取边界 Rectangle如此 Rectangle 。

getBounds() - Method in interface java.awt. Shape

返回一个整数Rectangle完全包围Shape 。

getBounds() - Method in class java.awt. SplashScreen

返回启动屏幕窗口的边界为Rectangle 。

getBounds() - Method in interface java.lang.reflect. TypeVariable

返回表示此类型变量的上限的 Type对象的数组。

getBounds() - Method in class javafx.stage. Screen

获得这个 Screen的界限。

getBounds() - Method in interface javax.accessibility. AccessibleComponent

以 Rectangle对象的形式获取此对象的边界。

getBounds() - Method in interface javax.lang.model.element. TypeParameterElement

返回此类型参数的边界。

getBounds() - Method in interface javax.lang.model.type. IntersectionType

返回包含此交集类型的边界。

getBounds() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getBounds() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

getBounds() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

getBounds() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getBounds(Rectangle) - Method in class java.awt. Component

将此组件的边界存储到“返回值” rv并返回 rv 。

getBounds(Rectangle) - Method in class javax.swing. JComponent

将此组件的边界存储为“返回值” rv并返回 rv 。

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree. AbstractLayoutCache

返回一个给出绘制路径所需边界的矩形。

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree. FixedHeightLayoutCache

返回一个给出绘制路径所需边界的矩形。

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree. VariableHeightLayoutCache

返回包含 Rectangle标识的项目的标签部分的 path 。

getBounds2D() - Method in class java.awt.font. GlyphMetrics

返回字形的边界。

getBounds2D() - Method in class java.awt.geom. Arc2D

返回圆弧的高精度框架矩形。

getBounds2D() - Method in class java.awt.geom. Area

返回一个高精度的边界Rectangle2D完全包围此Area 。

getBounds2D() - Method in class java.awt.geom. CubicCurve2D.Double

返回 Shape比 getBounds方法高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. CubicCurve2D.Float

返回 Shape高精度和更准确的边界框，比 getBounds方法。

getBounds2D() - Method in class java.awt.geom. Ellipse2D.Double

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. Ellipse2D.Float

返回 Shape高精度和更精确的边界框，比 getBounds方法。

getBounds2D() - Method in class java.awt.geom. Line2D.Double

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. Line2D.Float

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. Path2D.Double

返回 Shape高精度和更精确的边界框，比 getBounds方法。

getBounds2D() - Method in class java.awt.geom. Path2D.Float

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. QuadCurve2D.Double

比 getBounds方法返回 Shape高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. QuadCurve2D.Float

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. Rectangle2D.Double

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. Rectangle2D.Float

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt.geom. Rectangle2D

返回 Shape高精度和更精确的边界框，比 getBounds方法。

getBounds2D() - Method in class java.awt.geom. RoundRectangle2D.Double

返回 Shape高精度和更准确的边界框，比 getBounds方法。

getBounds2D() - Method in class java.awt.geom. RoundRectangle2D.Float

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt. Polygon

返回 Shape比 getBounds方法更高精度和更准确的边界框。

getBounds2D() - Method in class java.awt. Rectangle

比 getBounds方法返回 Shape高精度和更准确的边界框。

getBounds2D() - Method in interface java.awt. Shape

返回 Shape高精度和更精确的边界框，比 getBounds方法。

getBounds2D(BufferedImage) - Method in class java.awt.image. AffineTransformOp

返回已转换目的地的边界框。

getBounds2D(BufferedImage) - Method in interface java.awt.image. BufferedImageOp

返回已过滤的目标图像的边界框。

getBounds2D(BufferedImage) - Method in class java.awt.image. ColorConvertOp

给出这个源，返回目的地的边界框。

getBounds2D(BufferedImage) - Method in class java.awt.image. ConvolveOp

返回已过滤的目标图像的边界框。

getBounds2D(BufferedImage) - Method in class java.awt.image. LookupOp

返回已过滤的目标图像的边界框。

getBounds2D(BufferedImage) - Method in class java.awt.image. RescaleOp

返回重新缩放的目标图像的边框。

getBounds2D(Raster) - Method in class java.awt.image. AffineTransformOp

返回已转换目的地的边界框。

getBounds2D(Raster) - Method in class java.awt.image. BandCombineOp

返回已转换目的地的边界框。

getBounds2D(Raster) - Method in class java.awt.image. ColorConvertOp

给出这个源，返回目的地的边界框。

getBounds2D(Raster) - Method in class java.awt.image. ConvolveOp

返回已筛选的目标栅格的边框。

getBounds2D(Raster) - Method in class java.awt.image. LookupOp

返回已筛选的目标栅格的边框。

getBounds2D(Raster) - Method in interface java.awt.image. RasterOp

返回已筛选的目标栅格的边框。

getBounds2D(Raster) - Method in class java.awt.image. RescaleOp

返回重新缩放的目标栅格的边框。

getBounds2D(ParameterBlock) - Method in interface java.awt.image.renderable. ContextualRenderedImageFactory

在独立于渲染的空间中，返回在给定的一组源上执行的操作输出的边界框。

getBoundsAt(int) - Method in class javax.swing. JTabbedPane

返回标签边界 index 。

getBoundsForIconOf(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager

iconifyFrame()代码调用这个来确定desktopIcon的正确边界。

getBoundsInLocal() - Method in class javafx.scene. Node

获取属性boundsInLocal的值。

getBoundsInParent() - Method in class javafx.scene. Node

获取属性boundsInParent的值。

getBoundsType() - Method in class javafx.scene.text. Text

获取属性boundsType的值。

getBox(Rectangle) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

存储将在 r为当前动画索引绘制的弹跳框的位置和大小，并返回 r 。

getBox(Rectangle) - Method in class javax.swing.plaf.synth. SynthProgressBarUI

存储将在 r为当前动画索引绘制的弹跳框的位置和大小，并返回 r 。

getBoxLength(int, int) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回要画的“弹跳框”的长度。

getBoxPainter(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

获取框格式化程序用于给定的一组CSS属性。

getBranchQualifier() - Method in interface javax.transaction.xa. Xid

获取XID的事务分支标识符作为字节数组。

getBreakIterator() - Method in class com.sun.source.util. DocTrees

返回用于计算文档注释第一句的break迭代器。

getBreakLocation(Segment, FontMetrics, float, float, TabExpander, int) - Static method in class javax.swing.text. Utilities

确定在给定的范围内打破给定文本的位置。

getBreakLocation(Segment, FontMetrics, int, int, TabExpander, int) - Static method in class javax.swing.text. Utilities

已过时。
替换为Utilities.getBreakLocation(Segment, FontMetrics, float, float, TabExpander, int)

getBreakWeight(int, float) - Method in class javax.swing.text. ParagraphView

获得给定位置的重量。

getBreakWeight(int, float, float) - Method in class javax.swing.text. GlyphView

确定这种观点的休息时机有多吸引人。

getBreakWeight(int, float, float) - Method in class javax.swing.text.html. InlineView

确定这种观点的休息时机有多吸引人。

getBreakWeight(int, float, float) - Method in class javax.swing.text. View

确定这种观点的休息时机有多吸引人。

getBrightness() - Method in class javafx.scene.effect. ColorAdjust

获取属性亮度的值。

getBrightness() - Method in class javafx.scene.paint. Color

获得这个 Color的亮度分量。

getBroadcast() - Method in class java.net. DatagramSocket

测试是否启用了SO_BROADCAST。

getBroadcast() - Method in class java.net. InterfaceAddress

为此InterfaceAddress的广播地址返回 InetAddress 。

getBubbles() - Method in interface org.w3c.dom.events. Event

用于指示事件是否是冒泡事件。

getBuffer() - Method in class java.io. StringWriter

返回字符串缓冲区本身。

getBufferCapabilities() - Method in class java.awt. GraphicsConfiguration

返回此 GraphicsConfiguration的缓冲功能。

getBufferedImageOp() - Method in class java.awt.image. BufferedImageFilter

返回 BufferedImageOp 。

getBufferedImageType() - Method in class javax.imageio. ImageTypeSpecifier

返回一个int，其中包含描述 BufferedImage图像格式的枚举常数值。

getBufferProgressTime() - Method in class javafx.scene.media. MediaPlayer

检索 bufferProgressTime的价值。

getBufferSize() - Method in interface javax.sound.sampled. DataLine

获取将适合数据线内部缓冲区的最大数据字节数。

getBufferStrategy() - Method in class java.awt. Canvas

返回此组件使用的 BufferStrategy 。

getBufferStrategy() - Method in class java.awt. Window

返回此组件使用的 BufferStrategy 。

getBuilder() - Method in class javax.xml.bind.annotation. W3CDomHandler

getBuilder(Class<?>) - Method in class javafx.fxml. JavaFXBuilderFactory

返回指定类型的构建器，如果不使用构建器，则返回null。

getBuilder(Class<?>) - Method in interface javafx.util. BuilderFactory

返回适用于构造给定类型实例的构建器。

getBuilderFactory() - Method in class javafx.fxml. FXMLLoader

返回此装载器使用的构建器工厂。

getBumpInput() - Method in class javafx.scene.effect. Lighting

获取属性bumpInput的值。

getBumpMap() - Method in class javafx.scene.paint. PhongMaterial

获取属性bumpMap的值。

getBundle(String) - Static method in class java.util. ResourceBundle

使用指定的基本名称，默认语言环境和调用者的类加载器获取资源包。

getBundle(String, Module) - Static method in class java.util. ResourceBundle

使用指定的基本名称和默认语言环境代替指定的模块获取资源包。

getBundle(String, Locale) - Static method in class java.util. ResourceBundle

使用指定的基本名称和区域设置以及调用者的类加载器获取资源包。

getBundle(String, Locale) - Method in class java.util.spi. AbstractResourceBundleProvider

返回 ResourceBundle为给定 baseName和 locale 。

getBundle(String, Locale) - Method in interface java.util.spi. ResourceBundleProvider

为给定的包名称和区域设置返回一个 ResourceBundle 。

getBundle(String, Locale, ClassLoader) - Static method in class java.util. ResourceBundle

使用指定的基本名称，区域设置和类加载器获取资源包。

getBundle(String, Locale, ClassLoader, ResourceBundle.Control) - Static method in class java.util. ResourceBundle

使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。

getBundle(String, Locale, Module) - Static method in class java.util. ResourceBundle

使用指定的基本名称和区域设置代替指定的模块获取资源包。

getBundle(String, Locale, ResourceBundle.Control) - Static method in class java.util. ResourceBundle

使用指定的基本名称，目标语言环境和控件以及调用者的类加载器返回资源包。

getBundle(String, ResourceBundle.Control) - Static method in class java.util. ResourceBundle

X- 2004545 CEEC X-

getBusy() - Method in interface org.w3c.dom.ls. LSParser

true如果 LSParser正在忙于加载文件，否则为 false 。

getButton() - Method in class java.awt.event. MouseEvent

返回哪个鼠标按钮（如果有）已更改状态。

getButton() - Method in class javafx.scene.input. MouseEvent

哪个，如果有的话，鼠标按钮是负责这个事件。

getButton() - Method in interface org.w3c.dom.events. MouseEvent

在鼠标按键或鼠标按键释放引起的鼠标事件期间， button用于指示哪个鼠标按钮改变状态。

getButtonBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JButton的边框实例。

getButtonBorder() - Static method in class javax.swing.plaf.metal. MetalBorders

返回 JButton的边框实例。

getButtonCell() - Method in class javafx.scene.control. ComboBox

获取属性buttonCell的值。

getButtonCount() - Method in class javax.swing. ButtonGroup

返回组中按钮的数量。

getButtonData() - Method in class javafx.scene.control. ButtonType

返回在构造函数中为此ButtonType指定的ButtonData。

getButtonData(Node) - Static method in class javafx.scene.control. ButtonBar

返回给定按钮上先前设置的ButtonData属性。

getButtonMinWidth() - Method in class javafx.scene.control. ButtonBar

返回放置在此按钮栏中的所有按钮的最小宽度。

getButtonOrder() - Method in class javafx.scene.control. ButtonBar

返回当前的 button order 。

getButtonPanel() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

返回按钮面板。

getButtons() - Method in class javafx.scene.control. ButtonBar

在此ObservableList内放置按钮将指示ButtonBar根据它们指定的ButtonBar.ButtonData将它们相对放置 。

getButtons() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回从 JOptionPane显示的按钮，接收器提供外观和感觉。

getButtonTypes() - Method in class javafx.scene.control. Alert

返回当前在此Alert实例中设置的所有ButtonType个实例中的ObservableList 。

getButtonTypes() - Method in class javafx.scene.control. DialogPane

用于对话框按钮栏区域的按钮类型的可观察列表（通过 DialogPane.createButtonBar()方法创建）。

getButtonWidth() - Method in class javax.swing.plaf.metal. MetalScrollButton

返回按钮的宽度。

getByAddress(byte[]) - Static method in class java.net. InetAddress

给出原始IP地址的 InetAddress对象。

getByAddress(String, byte[]) - Static method in class java.net. InetAddress

根据提供的主机名和IP地址创建InetAddress。

getByAddress(String, byte[], int) - Static method in class java.net. Inet6Address

按照 InetAddress.getByAddress(String,byte[])的确切方式创建Inet6Address，但将IPv6范围 ID设置为给定的数值。

getByAddress(String, byte[], NetworkInterface) - Static method in class java.net. Inet6Address

在的确切方式创建Inet6Address， InetAddress.getByAddress(String,byte[])不同之处在于将IPv6 scope_id设置为对应于在指定的地址类型的给定接口的值 addr 。

getByAngle() - Method in class javafx.animation. RotateTransition

获取属性的值byAngle。

getByIndex(int) - Static method in class java.net. NetworkInterface

获取一个网络接口给它的索引。

getByInetAddress(InetAddress) - Static method in class java.net. NetworkInterface

搜索具有绑定到指定的Internet协议（IP）地址的网络接口的便利方法。

getByName(String) - Static method in class java.net. InetAddress

确定主机名称的IP地址。

getByName(String) - Static method in class java.net. NetworkInterface

搜索具有指定名称的网络接口。

getByte(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 byte指定的JDBC TINYINT参数的值。

getByte(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 byte此 ResultSet对象的当前行中指定列的值。

getByte(Object) - Method in class java.lang.reflect. Field

获取静态或实例的值 byte字段。

getByte(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中索引组件的值，如 byte 。

getByte(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 byte JDBC TINYINT参数的值。

getByte(String) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 byte 。

getByteArray(String, byte[]) - Method in class java.util.prefs. AbstractPreferences

实现 getByteArray方法按照在本说明书中 Preferences.getByteArray(String,byte[]) 。

getByteArray(String, byte[]) - Method in class java.util.prefs. Preferences

返回由此首选项节点中与指定键相关联的字符串表示的字节数组值。

getByteBgraInstance() - Static method in class javafx.scene.image. PixelFormat

返回一个 WritablePixelFormat实例，描述像素布局，其中存储在相邻字节中的像素，其中 非预乘数组件以增加的索引：蓝色，绿色，红色，alpha的顺序存储。

getByteBgraPreInstance() - Static method in class javafx.scene.image. PixelFormat

返回描述像素布局的 WritablePixelFormat实例，其中存储在相邻字节中的像素，其中 预乘数组件以增加的索引：蓝色，绿色，红色，alpha的顺序存储。

getByteCodeIndex() - Method in interface java.lang. StackWalker.StackFrame

返回包含由该堆栈帧表示的执行点的 Code属性的代码数组的索引。

getByteLength() - Method in class javax.sound.midi. MidiFileFormat

获取MIDI文件的长度，以8位字节表示。

getByteLength() - Method in class javax.sound.sampled. AudioFileFormat

获取整个音频文件（不仅仅是其音频数据）的字节大小。

getByteOffset() - Method in interface org.w3c.dom. DOMLocator

如果没有字节偏移可用，则该定位器指向的输入源的字节偏移量为 -1 。

getByteOrder() - Method in interface javax.imageio.stream. ImageInputStream

作为 java.nio.ByteOrder枚举的实例，返回从该流读取数据值的字节顺序。

getByteOrder() - Method in class javax.imageio.stream. ImageInputStreamImpl

getByteParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

一个方便的方法返回一个参数作为一个字节。

getByteRgbInstance() - Static method in class javafx.scene.image. PixelFormat

返回描述像素布局的 PixelFormat实例，其中存储在相邻字节中的像素的颜色分量按照增加的索引顺序存储：红色，绿色和蓝色。

getBytes() - Method in class java.lang. String

使用平台的默认字符集将此 String编码为字节序列，将结果存储到新的字节数组中。

getBytes() - Method in interface java.sql. RowId

返回一个字节数组，表示该 java.sql.RowId对象指定的SQL ROWID的值。

getBytes() - Method in class javax.smartcardio. ATR

返回此ATR中的字节的副本。

getBytes() - Method in class javax.smartcardio. CommandAPDU

返回此APDU中的字节的副本。

getBytes() - Method in class javax.smartcardio. ResponseAPDU

返回此APDU中的字节的副本。

getBytes(int) - Method in interface java.sql. CallableStatement

将指定的JDBC BINARY或 VARBINARY参数的值作为Java编程语言中的 byte值的数组 byte 。

getBytes(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 byte数组的形式，将此 ResultSet对象的当前行中的指定列的值检索。

getBytes(int, int, byte[], int) - Method in class java.lang. String

已过时。
此方法无法将字符正确转换为字节。 从JDK 1.1开始，首选的方法是通过使用平台默认字符集的String.getBytes()方法。

getBytes(long, int) - Method in interface java.sql. Blob

检索该 Blob对象所代表的全部或部分 BLOB值作为字节数组。

getBytes(long, int) - Method in class javax.sql.rowset.serial. SerialBlob

将从给定位置开始的指定数量的字节从该 SerialBlob对象 SerialBlob到另一个字节数组。

getBytes(String) - Method in class java.lang. String

使用命名的字符集将这个 String编码成一个字节序列，将结果存储到一个新的字节数组中。

getBytes(String) - Method in interface java.sql. CallableStatement

检索JDBC BINARY或 VARBINARY参数的值，作为Java编程语言中的 byte数组。

getBytes(String) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 byte数组。

getBytes(Charset) - Method in class java.lang. String

使用给定的charset将该String编码为字节序列，将结果存储到新的字节数组中。

getBytesRead() - Method in class java.util.zip. Deflater

返回到目前为止输入的未压缩字节的总数。

getBytesRead() - Method in class java.util.zip. Inflater

返回到目前为止输入的压缩字节的总数。

getByteStream() - Method in interface org.w3c.dom.ls. LSInput

表示字节流的语言和绑定依赖类型的属性。

getByteStream() - Method in interface org.w3c.dom.ls. LSOutput

表示可写入字节流的语言和绑定依赖类型的属性。

getByteStream() - Method in class org.xml.sax. InputSource

获取此输入源的字节流。

getBytesWritten() - Method in class java.util.zip. Deflater

返回到目前为止输出的压缩字节总数。

getBytesWritten() - Method in class java.util.zip. Inflater

返回到目前为止输出的未压缩字节的总数。

getByValue() - Method in class javafx.animation. FadeTransition

通过值获取属性的值。

getByX() - Method in class javafx.animation. ScaleTransition

通过X获取属性的值。

getByX() - Method in class javafx.animation. TranslateTransition

通过X获取属性的值。

getByY() - Method in class javafx.animation. ScaleTransition

通过Y获取属性的值。

getByY() - Method in class javafx.animation. TranslateTransition

通过Y获取属性的值。

getByZ() - Method in class javafx.animation. ScaleTransition

通过Z获取属性的值。

getByZ() - Method in class javafx.animation. TranslateTransition

通过Z获取属性的值。

getCA() - Method in class java.security.cert. TrustAnchor

返回最受信任的CA作为X500Principal的名称。

getCachedIcon(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

返回文件的缓存图标。

getCachedInterpolator() - Method in class javafx.animation. Transition

返回Interpolator ，当Transition启动时设置。

getCacheDirectory() - Static method in class javax.imageio. ImageIO

如果没有进行显式设置，则返回 setCacheDirectory设置的当前值，或 null 。

getCachedMBeanInfo() - Method in class javax.management. StandardMBean

自定义钩子：返回为此对象缓存的MBeanInfo。

getCachedResources(DownloadService2.ResourceSpec) - Method in interface javax.jnlp. DownloadService2

返回缓存中与指定资源规范之一匹配的所有资源。

getCachedValue(ParsedValue) - Method in class javafx.css. StyleConverter

获取指定键的缓存值。

getCacheHint() - Method in class javafx.scene. Node

获取属性cacheHint的值。

getCalculatedDigestValue() - Method in interface javax.xml.crypto.dsig. Reference

在验证操作后返回此 Reference的计算摘要值。

getCalendar() - Method in class java.text. DateFormat

获取与此日期/时间格式化程序关联的日历。

getCalendarField() - Method in class java.text. DateFormat.Field

返回与此属性相关联的 Calendar字段。

getCalendarField() - Method in class javax.swing. SpinnerDateModel

返回 Calendar字段被添加到或从由所述减去 nextValue种 previousValue方法。

getCalendarType() - Method in interface java.time.chrono. Chronology

获取日历系统的日历类型。

getCalendarType() - Method in class java.time.chrono. HijrahChronology

获取伊斯兰历法的日历类型。

getCalendarType() - Method in class java.time.chrono. IsoChronology

获取底层日历系统的日历类型 - 'iso8601'。

getCalendarType() - Method in class java.time.chrono. JapaneseChronology

获取基础日历系统的日历类型 - “日语”。

getCalendarType() - Method in class java.time.chrono. MinguoChronology

获取底层日历系统的日历类型 - “roc”。

getCalendarType() - Method in class java.time.chrono. ThaiBuddhistChronology

获取基础日历系统的日历类型 - “佛教”。

getCalendarType() - Method in class java.util. Calendar

返回此 Calendar的日历类型。

getCalendarType() - Method in class java.util. GregorianCalendar

返回 "gregory"作为日历类型。

getCallback() - Method in exception javax.security.auth.callback. UnsupportedCallbackException

获取无法识别的 Callback 。

getCallbackHandler() - Method in class java.security. KeyStore.CallbackHandlerProtection

返回CallbackHandler。

getCallerClass() - Method in class java.lang. StackWalker

获取调用者调用 getCallerClass的方法的调用者的 Class对象。

getCallSiteDescriptor() - Method in interface jdk.dynalink.linker. LinkRequest

返回被链接的呼叫站点的呼叫站点描述符。

getCallSiteDescriptor() - Method in class jdk.dynalink.linker.support. SimpleLinkRequest

getCamera() - Method in class javafx.scene. Scene

获取属性摄像机的值。

getCamera() - Method in class javafx.scene. SnapshotParameters

获取当前相机。

getCamera() - Method in class javafx.scene. SubScene

获取属性摄像机的值。

getCAName() - Method in class java.security.cert. TrustAnchor

返回RFC 2253 String格式中最受信任的CA的名称。

getCancelable() - Method in interface org.w3c.dom.events. Event

用于指示事件是否可以防止其默认动作。

getCancelSelectionAction() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回取消选择动作。

getCandidateLocales(String, Locale) - Method in class java.util. ResourceBundle.Control

返回 List的 Locale作为 baseName和 locale候选语言环境。

getCanonicalFile() - Method in class java.io. File

返回此抽象路径名的规范形式。

getCanonicalHostName() - Method in class java.net. InetAddress

获取此IP地址的完全限定域名。

getCanonicalizationMethod() - Method in interface javax.xml.crypto.dsig. SignedInfo

返回这个 SignedInfo的规范化方法。

getCanonicalizedData() - Method in interface javax.xml.crypto.dsig. SignedInfo

在签名或验证操作后返回规范化的已签名信息字节。

getCanonicalKeyPropertyListString() - Method in class javax.management. ObjectName

返回键属性列表的字符串表示形式，其中键属性按词法顺序排序。

getCanonicalName() - Method in class java.lang. Class

返回由Java语言规范定义的基础类的规范名称。

getCanonicalName() - Method in class javax.management. ObjectName

返回名称的规范形式; 也就是字符串表示，其中属性按词法顺序排序。

getCanonicalPath() - Method in class java.io. File

返回此抽象路径名的规范路径名字符串。

getCanvas() - Method in class javafx.scene.canvas. GraphicsContext

获取 Canvas的 GraphicsContext的发行平局命令。

getCanWrapLines() - Method in class javax.swing.text. AbstractWriter

返回是否可以包装线。

getCapabilities() - Method in class java.awt. Component.BltBufferStrategy

getCapabilities() - Method in class java.awt. Component.FlipBufferStrategy

getCapabilities() - Method in class java.awt.image. BufferStrategy

返回 BufferCapabilities为这个 BufferStrategy 。

getCapabilities() - Method in class java.awt.image. VolatileImage

返回一个ImageCapabilities对象，可以查询该VolatileImage的具体功能。

getCapabilities(GraphicsConfiguration) - Method in class java.awt. Image

返回一个ImageCapabilities对象，可以在指定的GraphicsConfiguration上查询该Image的功能。

getCapability() - Method in class java.security. DrbgParameters.Instantiation

返回能力。

getCaption() - Method in interface org.w3c.dom.html. HTMLTableElement

返回表的 CAPTION ，如果不存在则返回void。

getCaptionSide() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的标题侧属性定义。

getCapturedArg(int) - Method in class java.lang.invoke. SerializedLambda

获取lambda捕获站点的动态参数。

getCapturedArgCount() - Method in class java.lang.invoke. SerializedLambda

获取lambda捕获站点的动态参数计数。

getCapturingClass() - Method in class java.lang.invoke. SerializedLambda

获取捕获此lambda的类的名称。

getCAPublicKey() - Method in class java.security.cert. TrustAnchor

返回最受信任的CA的公钥。

getCard() - Method in class javax.smartcardio. CardChannel

返回此频道关联的卡。

getCaret() - Method in class java.awt.event. InputMethodEvent

得到插入符号。

getCaret() - Method in class javax.swing.text. JTextComponent

获取允许通过视图进行文本导向的插入符号。

getCaret() - Method in class javax.swing.text. NavigationFilter.FilterBypass

返回正在更改的插入符号。

getCaretBounds() - Method in class javafx.scene.control.skin. TextAreaSkin

getCaretColor() - Method in class javax.swing.text. JTextComponent

获取当前用于渲染插入符号的颜色。

getCaretInfo(TextHitInfo) - Method in class java.awt.font. TextLayout

返回与 hit对应的插入符号的信息。

getCaretInfo(TextHitInfo, Rectangle2D) - Method in class java.awt.font. TextLayout

返回与 hit对应的插入符号的信息。

getCaretListeners() - Method in class javax.swing.text. JTextComponent

返回在此文本组件上注册的所有插入符号侦听器的数组。

getCaretPosition() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回插入符号的从零开始的偏移量。

getCaretPosition() - Method in class java.awt. TextComponent

返回文本插入插入符的位置。

getCaretPosition() - Method in class javafx.scene.control. TextFormatter.Change

获得新的插入位置。

getCaretPosition() - Method in class javafx.scene.control. TextInputControl

获取属性caretPosition的值。

getCaretPosition() - Method in class javafx.scene.input. InputMethodEvent

组合文本中的输入法插入位置。

getCaretPosition() - Method in class javafx.scene.text. Text

获取属性caretPosition的值。

getCaretPosition() - Method in interface javax.accessibility. AccessibleText

返回插入符号的从零开始的偏移量。

getCaretPosition() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回插入符号的从零开始的偏移量。

getCaretPosition() - Method in class javax.swing. JLabel.AccessibleJLabel

返回插入符号的从零开始的偏移量。

getCaretPosition() - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回插入符号的从零开始的偏移量。

getCaretPosition() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回插入符号的从零开始的偏移量。

getCaretPosition() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回插入符号的从零开始的偏移量。

getCaretPosition() - Method in class javax.swing.text. JTextComponent

返回文本组件的文本插入符号的位置。

getCaretShape() - Method in class javafx.scene.text. Text

在本地坐标中插入符号的形状。

getCaretShape(TextHitInfo) - Method in class java.awt.font. TextLayout

返回一个 Shape代表在这个 TextLayout的自然界内的指定命中的插入符号。

getCaretShape(TextHitInfo, Rectangle2D) - Method in class java.awt.font. TextLayout

返回一个Shape，表示指定边界内指定点的插入符号。

getCaretShapes(int) - Method in class java.awt.font. TextLayout

返回对应于强和弱插入符号的两个路径。

getCaretShapes(int, Rectangle2D) - Method in class java.awt.font. TextLayout

返回对应于强和弱插入符号的两个路径。

getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy) - Method in class java.awt.font. TextLayout

返回对应于强和弱插入符号的两个路径。

getCases() - Method in interface com.sun.source.tree. SwitchTree

返回 switch语句的 switch 。

getCases() - Method in interface jdk.nashorn.api.tree. SwitchTree

返回'case'语句的列表。

getCatalog() - Method in interface java.sql. Connection

检索此 Connection对象的当前目录名称。

getCatalogName(int) - Method in interface java.sql. ResultSetMetaData

获取指定列的表的目录名称。

getCatalogName(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索从中导出指定列中的值的表的目录名称。

getCatalogs() - Method in interface java.sql. DatabaseMetaData

检索此数据库中可用的目录名称。

getCatalogSeparator() - Method in interface java.sql. DatabaseMetaData

检索此数据库用作目录和表名之间的分隔符的 String 。

getCatalogTerm() - Method in interface java.sql. DatabaseMetaData

检索“目录”的数据库供应商的首选项。

getCatches() - Method in interface com.sun.source.tree. TryTree

返回 try语句中提供的任何catch块。

getCatches() - Method in interface jdk.nashorn.api.tree. TryTree

返回与'try'关联的'catch'语句的列表。

getCategories() - Method in class javafx.scene.chart. CategoryAxis

返回在此轴上绘制的类别的ObservableList 。

getCategories() - Method in class javax.imageio.spi. ServiceRegistry

返回 Iterator的 Class对象，指示当前的类别集。

getCategory() - Method in interface javax.print.attribute. Attribute

当打印属性值添加到属性集中时，获取打印属性类，该属性类将用作此打印属性值的“类别”。

getCategory() - Method in class javax.print.attribute.standard. Chromaticity

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. ColorSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Compression

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Copies

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. CopiesSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. DateTimeAtCompleted

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. DateTimeAtCreation

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. DateTimeAtProcessing

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Destination

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. DialogTypeSelection

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. DocumentName

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Fidelity

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Finishings

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobHoldUntil

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobImpressions

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobImpressionsCompleted

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobImpressionsSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobKOctets

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobKOctetsProcessed

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobKOctetsSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobMediaSheets

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobMediaSheetsCompleted

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobMediaSheetsSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobMessageFromOperator

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobName

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobOriginatingUserName

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobPriority

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobPrioritySupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobSheets

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobState

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobStateReason

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. JobStateReasons

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Media

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. MediaPrintableArea

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. MediaSize

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. MultipleDocumentHandling

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. NumberOfDocuments

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. NumberOfInterveningJobs

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. NumberUp

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. NumberUpSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. OrientationRequested

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. OutputDeviceAssigned

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PageRanges

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PagesPerMinute

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PagesPerMinuteColor

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PDLOverrideSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PresentationDirection

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterInfo

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterIsAcceptingJobs

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterLocation

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterMakeAndModel

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterMessageFromOperator

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterMoreInfo

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterMoreInfoManufacturer

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterName

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterResolution

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterState

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterStateReason

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterStateReasons

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrinterURI

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. PrintQuality

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. QueuedJobCount

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. ReferenceUriSchemesSupported

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. RequestingUserName

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Severity

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. SheetCollate

获取要用作此打印属性值的“类别”的打印属性类。

getCategory() - Method in class javax.print.attribute.standard. Sides

获取要用作此打印属性值的“类别”的打印属性类。

getCategoryGap() - Method in class javafx.scene.chart. BarChart

获取属性categoryGap的值。

getCategoryGap() - Method in class javafx.scene.chart. StackedBarChart

获取属性categoryGap的值。

getCategorySpacing() - Method in class javafx.scene.chart. CategoryAxis

获取属性categorySpacing的值。

getCause() - Method in class java.awt.event. FocusEvent

返回事件原因。

getCause() - Method in exception java.awt.print. PrinterIOException

返回此异常的原因（终止打印作业的 IOException ）。

getCause() - Method in exception java.io. UncheckedIOException

返回此异常的原因。

getCause() - Method in exception java.io. WriteAbortedException

返回终止操作的异常（ 原因 ）。

getCause() - Method in exception java.lang. ClassNotFoundException

返回此异常的原因（如果在尝试加载类时发生错误，则引发异常;否则为 null ）。

getCause() - Method in error java.lang. ExceptionInInitializerError

返回此错误的原因（导致此错误创建的静态初始化期间发生的异常）。

getCause() - Method in exception java.lang.reflect. InvocationTargetException

返回此异常的原因（抛出的目标异常，可能是 null ）。

getCause() - Method in exception java.lang.reflect. UndeclaredThrowableException

返回此异常的原因（ Throwable实例包含在此 UndeclaredThrowableException ，可能为 null ）。

getCause() - Method in class java.lang. Throwable

如果原因不存在或未知，则返回此throwable的原因或 null 。

getCause() - Method in exception java.nio.file. DirectoryIteratorException

返回此异常的原因。

getCause() - Method in exception java.rmi.activation. ActivationException

返回此异常的原因。

getCause() - Method in exception java.rmi. RemoteException

返回此异常的原因。

getCause() - Method in exception java.rmi.server. ServerCloneException

返回此异常的原因。

getCause() - Method in exception java.security. PrivilegedActionException

返回此异常的原因（导致此 PrivilegedActionException的特权计算抛出的异常）。

getCause() - Method in class javafx.application. Preloader.ErrorNotification

检索与此错误通知相关联的异常或错误（如果有）。

getCause() - Method in exception javax.management. MBeanException

返回实际异常抛出。

getCause() - Method in exception javax.management. ReflectionException

返回实际抛出的异常 。

getCause() - Method in exception javax.management.remote. JMXProviderException

getCause() - Method in exception javax.management.remote. JMXServerErrorException

getCause() - Method in exception javax.management. RuntimeErrorException

返回实际抛出的Error 。

getCause() - Method in exception javax.management. RuntimeMBeanException

返回实际抛出的RuntimeException 。

getCause() - Method in exception javax.management. RuntimeOperationsException

返回实际抛出的RuntimeException 。

getCause() - Method in exception javax.naming. NamingException

返回此异常的原因。

getCause() - Method in exception javax.security.sasl. SaslException

getCause() - Method in exception javax.xml.bind. JAXBException

getCause() - Method in exception javax.xml.crypto.dsig. TransformException

如果原因不存在或未知，则返回 TransformException或 null的原因。

getCause() - Method in exception javax.xml.crypto.dsig. XMLSignatureException

如果原因不存在或未知，则返回 XMLSignatureException或 null的原因。

getCause() - Method in exception javax.xml.crypto. KeySelectorException

如果原因不存在或未知，则返回 KeySelectorException或 null的原因。

getCause() - Method in exception javax.xml.crypto. MarshalException

如果原因不存在或未知，则返回 MarshalException或 null的原因。

getCause() - Method in exception javax.xml.crypto. NoSuchMechanismException

如果原因不存在或未知，则返回 NoSuchMechanismException或 null的原因。

getCause() - Method in exception javax.xml.crypto. URIReferenceException

如果原因不存在或未知，则返回 URIReferenceException或 null的原因。

getCause() - Method in error javax.xml.parsers. FactoryConfigurationError

使用JDK1.4的异常链接机制

getCause() - Method in exception javax.xml.soap. SOAPException

返回 Throwable对象嵌入在这个 SOAPException如果有的话。

getCause() - Method in error javax.xml.stream. FactoryConfigurationError

使用JDK1.4的异常链接机制

getCause() - Method in exception javax.xml.transform. TransformerException

如果原因不存在或未知，则返回此throwable的原因或 null 。

getCause() - Method in error javax.xml.transform. TransformerFactoryConfigurationError

使用JDK1.4的异常链接机制

getCause() - Method in exception javax.xml.xpath. XPathException

得到这个XPathException的原因。

getCause() - Method in exception org.xml.sax. SAXException

返回异常的原因

getCell(int) - Method in class javafx.scene.control.skin. VirtualFlow

返回给定索引的单元格。

getCellBounds(int, int) - Method in class javafx.scene.layout. GridPane

返回指定列和行位置的单元格的边界。

getCellBounds(int, int) - Method in class javax.swing. JList

返回列表坐标系中由两个索引指定的单元格范围的边界矩形。

getCellBounds(JList<?>, int, int) - Method in class javax.swing.plaf.basic. BasicListUI

返回给定列表的坐标系中由两个索引指定的单元格范围的边界矩形。

getCellBounds(JList<?>, int, int) - Method in class javax.swing.plaf. ListUI

返回给定列表的坐标系中由两个索引指定的单元格范围的边界矩形。

getCellBounds(JList<?>, int, int) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 getCellBounds方法。

getCellCount() - Method in class javafx.scene.control.skin. VirtualFlow

获取属性cellCount的值。

getCellData(int) - Method in class javafx.scene.control. TableColumnBase

返回给定行索引（并且属于此表列）的单元格的实际值。

getCellData(S) - Method in class javafx.scene.control. TableColumnBase

从给定项返回单元格的实际值。

getCellEditor() - Method in class javax.swing. JTable

返回活动单元格编辑器，如果表当前未编辑，则为 null 。

getCellEditor() - Method in class javax.swing. JTree

返回用于编辑树中条目的编辑器。

getCellEditor() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回一个 TreeCellEditor的实例。

getCellEditor() - Method in class javax.swing.table. TableColumn

返回 TableCellEditor用于编辑此列的值的 JTable 。

getCellEditor(int, int) - Method in class javax.swing. JTable

为 row和 column指定的单元格返回适当的编辑器。

getCellEditorListeners() - Method in class javax.swing. AbstractCellEditor

返回使用addCellEditorListener（）添加到此AbstractCellEditor的所有 CellEditorListener的数组。

getCellEditorListeners() - Method in class javax.swing.tree. DefaultTreeCellEditor

返回使用addCellEditorListener（）添加到此DefaultTreeCellEditor的所有 CellEditorListener的数组。

getCellEditorValue() - Method in interface javax.swing. CellEditor

返回编辑器中包含的值。

getCellEditorValue() - Method in class javax.swing. DefaultCellEditor.EditorDelegate

返回此单元格的值。

getCellEditorValue() - Method in class javax.swing. DefaultCellEditor

将消息从 CellEditor转发到 delegate 。

getCellEditorValue() - Method in class javax.swing.tree. DefaultTreeCellEditor

返回当前正在编辑的值。

getCellFactory() - Method in class javafx.scene.control. ComboBox

获取属性cellFactory的值。

getCellFactory() - Method in class javafx.scene.control. ListView

返回当前的单元格工厂。

getCellFactory() - Method in class javafx.scene.control.skin. VirtualFlow

返回当前的单元格工厂。

getCellFactory() - Method in class javafx.scene.control. TableColumn

获取属性cellFactory的值。

getCellFactory() - Method in class javafx.scene.control. TreeTableColumn

获取属性cellFactory的值。

getCellFactory() - Method in class javafx.scene.control. TreeView

返回用于创建TreeCells的单元格工厂，用于表示TreeView中的项目，如果未设置自定义单元格工厂，则返回null。

getCellIndex() - Method in interface org.w3c.dom.html. HTMLTableCellElement

行中的这个单元格的索引，从0开始。

getCellIndex(T) - Method in class javafx.scene.control.skin. VirtualFlow

返回给定单元格的索引。

getCellLength() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回要在进度条中呈现的每个单元格/单位的宽度（如果为HORIZONTAL）或高度（如果为VERTICAL）。

getCellObservableValue(int) - Method in class javafx.scene.control. TableColumn

尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。

getCellObservableValue(int) - Method in class javafx.scene.control. TableColumnBase

尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。

getCellObservableValue(int) - Method in class javafx.scene.control. TreeTableColumn

尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。

getCellObservableValue(TreeItem<S>) - Method in class javafx.scene.control. TreeTableColumn

尝试返回给定项目（其类型为S）的ObservableValue <T>。

getCellObservableValue(S) - Method in class javafx.scene.control. TableColumn

尝试返回给定项目（其类型为S）的ObservableValue <T>。

getCellObservableValue(S) - Method in class javafx.scene.control. TableColumnBase

尝试返回给定项目（其类型为S）的ObservableValue <T>。

getCellPadding() - Method in interface org.w3c.dom.html. HTMLTableElement

指定单元格内容和单元格边框之间的水平和垂直间距。

getCellRect(int, int, boolean) - Method in class javax.swing. JTable

返回位于 row和 column交点处的单元格的矩形。

getCellRenderer() - Method in class javax.swing. JList

返回负责绘画列表项的对象。

getCellRenderer() - Method in class javax.swing. JTree

返回正在渲染每个单元格的当前 TreeCellRenderer 。

getCellRenderer() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回 currentCellRenderer ，它将是树形渲染器，或者是 defaultCellRenderer ，它永远不是空的。

getCellRenderer() - Method in class javax.swing.table. TableColumn

返回 TableCellRenderer用于绘制此列的值的 JTable 。

getCellRenderer(int, int) - Method in class javax.swing. JTable

为此行和列指定的单元格返回适当的渲染器。

getCells() - Method in interface org.w3c.dom.html. HTMLTableRowElement

这行中单元格的集合。

getCellSelectionEnabled() - Method in class javax.swing. JTable

如果列和列选择模型都启用，则返回true。

getCellSize() - Method in class javafx.scene.control.skin. CellSkinBase

获取属性cellSize的值。

getCellSpacing() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回进度条中每个单元格/单位之间的间距。

getCellSpacing() - Method in interface org.w3c.dom.html. HTMLTableElement

指定单元格之间的水平和垂直间隔。

getCellValueFactory() - Method in class javafx.scene.control. TableColumn

获取属性cellValueFactory的值。

getCellValueFactory() - Method in class javafx.scene.control. TreeTableColumn

获取属性cellValueFactory的值。

getCenter() - Method in class javafx.scene.layout. BorderPane

获取物业中心的价值。

getCenterFrequency() - Method in class javafx.scene.media. EqualizerBand

检索乐队的中心频率。

getCenterPoint() - Method in class java.awt. GraphicsEnvironment

返回Windows应该居中的点。

getCenterPoint() - Method in class java.awt. RadialGradientPaint

返回径向渐变中心点的副本。

getCentersChildren() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

返回是否应使用中心儿童。

getCenterX() - Method in class java.awt.geom. RectangularShape

以 double精度返回 Shape的框架矩形中心的X坐标。

getCenterX() - Method in class javafx.scene.paint. RadialGradient

定义定义渐变的圆的中心点的X坐标。

getCenterX() - Method in class javafx.scene.shape. Arc

获取属性centerX的值。

getCenterX() - Method in class javafx.scene.shape. Circle

获取属性centerX的值。

getCenterX() - Method in class javafx.scene.shape. Ellipse

获取属性centerX的值。

getCenterY() - Method in class java.awt.geom. RectangularShape

以 double精度 Shape double框架矩形中心的Y坐标。

getCenterY() - Method in class javafx.scene.paint. RadialGradient

定义定义渐变的圆的中心点的X坐标。

getCenterY() - Method in class javafx.scene.shape. Arc

获取属性centerY的值。

getCenterY() - Method in class javafx.scene.shape. Circle

获取属性centerY的值。

getCenterY() - Method in class javafx.scene.shape. Ellipse

获取属性centerY的值。

getCertificate() - Method in class java.security.cert. X509CertSelector

返回certificateEquals标准。

getCertificate() - Method in class java.security. KeyStore.PrivateKeyEntry

从该条目中的证书链中获取终端实体 Certificate 。

getCertificate() - Method in class javax.security.auth.x500. X500PrivateCredential

返回X.509证书。

getCertificate(String) - Method in class java.security. KeyStore

返回与给定别名相关联的证书。

getCertificateAlias(Certificate) - Method in class java.security. KeyStore

返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。

getCertificateChain() - Method in class java.security. KeyStore.PrivateKeyEntry

从此条目获取 Certificate链。

getCertificateChain(String) - Method in class java.security. KeyStore

返回与给定别名关联的证书链。

getCertificateChain(String) - Method in interface javax.net.ssl. X509KeyManager

返回与给定别名关联的证书链。

getCertificateChecking() - Method in class java.security.cert. X509CRLSelector

返回正在检查的证书。

getCertificateIssuer() - Method in class java.security.cert. X509CRLEntry

获取此条目描述的X509证书颁发者。

getCertificates() - Method in class java.net. JarURLConnection

如果它的URL指向JAR文件条目，则返回此连接的证书对象，否则返回null。

getCertificates() - Method in class java.security.cert. CertPath

返回此认证路径中的证书列表。

getCertificates() - Method in class java.security. CodeSource

返回与此CodeSource相关联的证书。

getCertificates() - Method in class java.util.jar. JarEntry

返回 Certificate对象此条，或 null如果没有。

getCertificates(CertSelector) - Method in class java.security.cert. CertStore

返回匹配指定选择器的 Collection的 Certificate 。

getCertificateValid() - Method in class java.security.cert. X509CertSelector

返回certificateValid条件。

getCertifiedText() - Method in interface org.w3c.dom.ls. LSInput

如果设置为true，则在解析[ XML 1.1 ]时，假定输入已被认证（见[ XML 1.1 ]中的2.13部分））。

getCertPath() - Method in interface java.security.cert. CertPathBuilderResult

返回建立的认证路径。

getCertPath() - Method in exception java.security.cert. CertPathValidatorException

返回在抛出异常时验证的认证路径。

getCertPath() - Method in class java.security.cert. PKIXCertPathBuilderResult

返回建立和验证的认证路径。

getCertPathCheckers() - Method in class java.security.cert. PKIXParameters

返回认证路径检查程序的 List 。

getCertPathEncodings() - Method in class java.security.cert. CertificateFactory

返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。

getCertStoreParameters() - Method in class java.security.cert. CertStore

返回用于初始化 CertStore的参数。

getCertStores() - Method in class java.security.cert. PKIXParameters

返回用于查找证书和CRL的不可变 List的 CertStore s。

getCh() - Method in interface org.w3c.dom.html. HTMLTableCellElement

列中单元格的对齐字符。

getCh() - Method in interface org.w3c.dom.html. HTMLTableColElement

列中单元格的对齐字符。

getCh() - Method in interface org.w3c.dom.html. HTMLTableRowElement

列中单元格的对齐字符。

getCh() - Method in interface org.w3c.dom.html. HTMLTableSectionElement

列中单元格的对齐字符。

getChange(Element) - Method in interface javax.swing.event. DocumentEvent

获取给定元素的更改信息。

getChange(Element) - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

获取元素的更改。

getChanged() - Method in class java.awt.event. HierarchyEvent

返回已更改的层次结构顶部的组件。

getChangedParent() - Method in class java.awt.event. HierarchyEvent

返回由 getChanged()返回的组件的父 getChanged() 。

getChangeFlags() - Method in class java.awt.event. HierarchyEvent

返回一个位掩码，指示此事件对象中表示的HIERARCHY_CHANGED事件的类型。

getChangeInfo() - Method in class javax.naming.event. NamingEvent

检索此事件的更改信息。

getChangeListeners() - Method in class javax.swing. AbstractButton

返回使用addChangeListener（）添加到此AbstractButton的所有 ChangeListener的数组。

getChangeListeners() - Method in class javax.swing. AbstractSpinnerModel

返回使用addChangeListener（）添加到此AbstractSpinnerModel的所有 ChangeListener的数组。

getChangeListeners() - Method in class javax.swing.colorchooser. DefaultColorSelectionModel

返回所有 ChangeListener的数组添加到这个 DefaultColorSelectionModel与 addChangeListener 。

getChangeListeners() - Method in class javax.swing. DefaultBoundedRangeModel

返回在这个 DefaultBoundedRangeModel上注册的所有更改监听器的数组。

getChangeListeners() - Method in class javax.swing. DefaultButtonModel

返回在此 DefaultButtonModel上注册的所有更改监听器的数组。

getChangeListeners() - Method in class javax.swing. DefaultSingleSelectionModel

返回在此 DefaultSingleSelectionModel上注册的所有更改监听器的数组。

getChangeListeners() - Method in class javax.swing. JProgressBar

返回所有的数组 ChangeListener加入到这一进度条以s addChangeListener 。

getChangeListeners() - Method in class javax.swing. JSlider

返回使用addChangeListener（）添加到此JSlider的所有 ChangeListener的数组。

getChangeListeners() - Method in class javax.swing. JSpinner

返回使用addChangeListener（）添加到此JSpinner的所有 ChangeListener的数组。

getChangeListeners() - Method in class javax.swing. JTabbedPane

返回所有 ChangeListener的数组，添加到 JTabbedPane与 addChangeListener 。

getChangeListeners() - Method in class javax.swing. JViewport

返回使用addChangeListener（）添加到此JViewport的所有 ChangeListener的数组。

getChangeListeners() - Method in class javax.swing. MenuSelectionManager

返回使用addChangeListener（）添加到此MenuSelectionManager的所有 ChangeListener的数组。

getChangeListeners() - Method in class javax.swing.text. DefaultCaret

返回在这个插入符号上注册的所有更改监听器的数组。

getChangeListeners() - Method in class javax.swing.text. StyleContext

返回使用addChangeListener（）添加到此StyleContext的所有 ChangeListener的数组。

getChangeListeners() - Method in class javax.swing.text. StyleContext.NamedStyle

返回使用addChangeListener（）添加到此NamedStyle的所有 ChangeListener的数组。

getChangeToParentDirectoryAction() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回对父目录操作的更改。

getChannel() - Method in class java.io. FileInputStream

返回与此文件输入流相关联的唯一的FileChannel对象。

getChannel() - Method in class java.io. FileOutputStream

返回与此文件输出流相关联的唯一的FileChannel对象。

getChannel() - Method in class java.io. RandomAccessFile

返回与此文件关联的唯一的FileChannel对象。

getChannel() - Method in class java.net. DatagramSocket

返回与该数据报套接字相关联的唯一的DatagramChannel对象（如果有）。

getChannel() - Method in class java.net. ServerSocket

返回与此套接字相关联的唯一的ServerSocketChannel对象（如果有）。

getChannel() - Method in class java.net. Socket

返回与此套接字相关联的唯一的SocketChannel对象（如果有）。

getChannel() - Method in class javax.sound.midi. ShortMessage

获取与此事件关联的MIDI通道。

getChannelNumber() - Method in class javax.smartcardio. CardChannel

返回此CardChannel的频道号。

getChannelPressure() - Method in interface javax.sound.midi. MidiChannel

获取频道的键盘压力。

getChannels() - Method in interface javax.sound.midi. Synthesizer

获得由该合成器控制的一组MIDI通道。

getChannels() - Method in class javax.sound.sampled. AudioFormat

获取频道数量。

getChar() - Method in class java.nio. ByteBuffer

读取char值的相对 get方法。

getChar() - Method in enum javafx.scene.input. KeyCode

返回此键代码的字符元素，这只是 KeyCode.getCode()返回的底层平台代码的 映射 。

getChar(int) - Method in class java.nio. ByteBuffer

绝对 获取方法来读取一个char值。

getChar(Object) - Method in class java.lang.reflect. Field

通过扩展转换获取类型为 char的静态或实例字段的 char或可转换为类型 char的另一个基元类型的值。

getChar(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中索引组件的值，如 char 。

getCharacter() - Method in class javafx.scene.input. KeyCharacterCombination

获取与该组合关联的关键字符。

getCharacter() - Method in class javafx.scene.input. KeyEvent

与键类型事件相关联的Unicode字符或字符序列。

getCharacterAttribute(int) - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回给定字符的AttributeSet（在给定索引处）。

getCharacterAttribute(int) - Method in interface javax.accessibility. AccessibleText

给定索引返回给定字符的 AttributeSet 。

getCharacterAttribute(int) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

在给定索引处返回给定字符的AttributeSet

getCharacterAttribute(int) - Method in class javax.swing. JLabel.AccessibleJLabel

在给定索引处返回给定字符的AttributeSet

getCharacterAttribute(int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回给定索引处给定字符的AttributeSet

getCharacterAttribute(int) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回给定索引处给定字符的AttributeSet

getCharacterAttribute(int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回给定字符的AttributeSet（在给定索引处）。

getCharacterAttributeRun() - Method in class javax.swing.text. StyledEditorKit

获取表示当前插入符号的字符属性的元素的元素。

getCharacterAttributes() - Method in class javax.swing. JTextPane

获取在插入符号的当前位置有效的字符属性，或 null 。

getCharacterBounds(int) - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

将给定索引处的字符的边框确定为字符串。

getCharacterBounds(int) - Method in class javafx.scene.control.skin. TextAreaSkin

返回给定索引处字符的边界。

getCharacterBounds(int) - Method in class javafx.scene.control.skin. TextFieldSkin

返回给定索引处字符的边界。

getCharacterBounds(int) - Method in class javafx.scene.control.skin. TextInputControlSkin

返回给定索引处字符的边界。

getCharacterBounds(int) - Method in interface javax.accessibility. AccessibleText

将给定索引处的字符的边框确定为字符串。

getCharacterBounds(int) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

将给定索引处的字符的边框确定为字符串。

getCharacterBounds(int) - Method in class javax.swing. JLabel.AccessibleJLabel

返回字符串中给定索引处字符的边界框。

getCharacterBounds(int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

将给定索引处的字符的边框确定为字符串。

getCharacterBounds(int) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

将给定索引处的字符的边框确定为字符串。

getCharacterBounds(int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

将给定索引处的字符的边框确定为字符串。

getCharacterCount() - Method in class java.awt.font. TextLayout

返回此 TextLayout表示的字符数。

getCharacterElement(int) - Method in class javax.swing.text. DefaultStyledDocument

基于位置获取字符元素。

getCharacterElement(int) - Method in interface javax.swing.text. StyledDocument

获取表示文档中给定偏移量的字符的元素。

getCharacterEncodingScheme() - Method in interface javax.xml.stream.events. StartDocument

返回XML数据的编码样式

getCharacterEncodingScheme() - Method in class javax.xml.stream.util. StreamReaderDelegate

getCharacterEncodingScheme() - Method in interface javax.xml.stream. XMLStreamReader

返回在xml声明中声明的字符编码如果没有声明，则返回null

getCharacterInstance() - Static method in class java.text. BreakIterator

返回一个新 BreakIterator例如 character breaks为 default locale 。

getCharacterInstance(Locale) - Static method in class java.text. BreakIterator

为给定的语言环境返回一个新的 BreakIterator实例 character breaks 。

getCharacterInstance(Locale) - Method in class java.text.spi. BreakIteratorProvider

为给定的语言环境返回一个新的 BreakIterator实例 character breaks 。

getCharacterLevel(int) - Method in class java.awt.font. TextLayout

返回字符的级别为 index 。

getCharacterOffset() - Method in interface javax.xml.stream. Location

将字节或字符偏移量返回到此位置指向的输入源。

getCharacters() - Method in class javafx.scene.control. TextField

返回支持文本字段内容的字符序列。

getCharacterStream() - Method in interface java.sql. Clob

检索 CLOB由该指定值 Clob对象作为 java.io.Reader对象（或作为字符流）。

getCharacterStream() - Method in interface java.sql. SQLXML

将此SQLXML实例指定的XML值作为java.io.Reader对象检索。

getCharacterStream() - Method in class javax.sql.rowset.serial. SerialClob

将此 SerialClob对象的数据作为Unicode字符流返回。

getCharacterStream() - Method in interface org.w3c.dom.ls. LSInput

一种表示16位单位流的语言和绑定依赖类型的属性。

getCharacterStream() - Method in interface org.w3c.dom.ls. LSOutput

表示可输出16位单位的可写入流的语言和绑定依赖类型的属性。

getCharacterStream() - Method in class org.xml.sax. InputSource

获取此输入源的字符流。

getCharacterStream(int) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。

getCharacterStream(int) - Method in interface java.sql. ResultSet

检索 ResultSet对象当前行中指定列的值作为 java.io.Reader对象。

getCharacterStream(long, long) - Method in interface java.sql. Clob

返回一个包含部分 Clob值的 Reader对象，以pos指定的字符开头，长度为长度字符。

getCharacterStream(long, long) - Method in class javax.sql.rowset.serial. SerialClob

返回一个包含部分 SerialClob值的 Reader对象，以pos指定的字符开头，长度为长度字符。

getCharacterStream(String) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。

getCharacterStream(String) - Method in interface java.sql. ResultSet

以 ResultSet对象的形式 java.io.Reader此 ResultSet对象的当前行中指定列的值。

getCharContent(boolean) - Method in interface javax.tools. FileObject

返回此文件对象的字符内容（如果可用）。

getCharContent(boolean) - Method in class javax.tools. ForwardingFileObject

getCharContent(boolean) - Method in class javax.tools. SimpleJavaFileObject

这个实现总是抛出UnsupportedOperationException 。

getCharCount() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回字符数（有效索引）

getCharCount() - Method in interface javax.accessibility. AccessibleText

返回字符数（有效指标）。

getCharCount() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回字符数（有效指标）

getCharCount() - Method in class javax.swing. JLabel.AccessibleJLabel

返回字符数（有效指标）

getCharCount() - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回字符数（有效指标）

getCharCount() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回字符数（有效指标）

getCharCount() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回字符数（有效索引）

getCharIndex() - Method in class java.awt.font. TextHitInfo

返回字符命中的索引。

getCharIndex() - Method in class javafx.scene.text. HitInfo

该命中信息所指的字符的索引。

getCharParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

一个方便的方法返回参数作为一个char。

getChars(int, int, char[], int) - Method in class java.lang. String

将此字符串中的字符复制到目标字符数组中。

getChars(int, int, char[], int) - Method in class java.lang. StringBuffer

getChars(int, int, Segment) - Method in interface javax.swing.text. AbstractDocument.Content

获取一系列字符并将其复制到段中。

getChars(int, int, Segment) - Method in class javax.swing.text. GapContent

检索一部分内容。

getChars(int, int, Segment) - Method in class javax.swing.text. StringContent

检索一部分内容。

getCharset() - Method in class javafx.fxml. FXMLLoader

返回此装载器使用的字符集。

getCharset() - Method in class jdk.nashorn.api.scripting. URLReader

这个读者使用的字符串

getCharset() - Method in interface org.w3c.dom.html. HTMLAnchorElement

链接资源的字符编码。

getCharset() - Method in interface org.w3c.dom.html. HTMLLinkElement

链接到的资源的字符编码。

getCharset() - Method in interface org.w3c.dom.html. HTMLScriptElement

链接资源的字符编码。

getCharsetName() - Method in exception java.nio.charset. IllegalCharsetNameException

检索非法字符集名称。

getCharsetName() - Method in exception java.nio.charset. UnsupportedCharsetException

检索不支持的字符集的名称。

getCharSetSpec() - Method in exception javax.swing.text. ChangedCharSetException

返回字符集规范。

getChart() - Method in class javafx.scene.chart. PieChart.Data

获取属性图表的值。

getChart() - Method in class javafx.scene.chart. XYChart.Series

获取属性图表的值。

getChartChildren() - Method in class javafx.scene.chart. Chart

图表中所有内容的可修改和可观察的列表。

getCheckboxGroup() - Method in class java.awt. Checkbox

确定此复选框的组。

getCheckBoxIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回复选框图标。

getCheckBoxIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回一个复选框图标。

getCheckBoxMenuItemIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回一个复选框菜单项图标。

getCheckBoxMenuItemIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 JCheckBoxMenuItem要使用的 JCheckBoxMenuItem 。

getChecked() - Method in interface org.w3c.dom.html. HTMLInputElement

当元素的 type属性具有值“Radio”或“Checkbox”时，表示在交互式用户代理中的表单控件的当前状态。

getChecksum() - Method in class java.util.zip. CheckedInputStream

返回此输入流的校验和。

getChecksum() - Method in class java.util.zip. CheckedOutputStream

返回此输出流的校验和。

getChild() - Method in class java.awt.event. ContainerEvent

返回受事件影响的组件。

getChild() - Method in class java.util.prefs. NodeChangeEvent

返回添加或删除的节点。

getChild(File, String) - Method in class javax.swing.filechooser. FileSystemView

getChild(Object, int) - Method in class javax.swing.tree. DefaultTreeModel

返回父节点的子数组中的 父索引 的索引孩子。

getChild(Object, int) - Method in interface javax.swing.tree. TreeModel

返回父子的子数组中索引 index为 parent的 index的子代。

getChild(String) - Method in class java.util.prefs. AbstractPreferences

如果命名的子项存在，则返回它，否则 null 。

getChildAfter(TreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

返回该节点的子数组中紧跟 aChild的子节点，它必须是此节点的子节点。

getChildAllocation(int) - Method in class javax.swing.text. AsyncBoxView.ChildLocator

获取用于子视图的分配。

getChildAllocation(int, Shape) - Method in class javax.swing.text. AsyncBoxView.ChildLocator

获取用于子视图的分配。

getChildAllocation(int, Shape) - Method in class javax.swing.text. AsyncBoxView

获取给定子视图的分配。

getChildAllocation(int, Shape) - Method in class javax.swing.text. BoxView

获取给定子视图的分配。

getChildAllocation(int, Shape) - Method in class javax.swing.text. CompositeView

获取给定子视图的分配。

getChildAllocation(int, Shape) - Method in class javax.swing.text. View

获取给定子视图的分配。

getChildAt(int) - Method in class javax.swing. JTree.DynamicUtilTreeNode

子类加载孩子，如有必要。

getChildAt(int) - Method in class javax.swing.text. AbstractDocument.AbstractElement

返回子 TreeNode索引 childIndex 。

getChildAt(int) - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的子数组中指定索引处的子节点。

getChildAt(int) - Method in interface javax.swing.tree. TreeNode

返回小孩 TreeNode ，索引号为 childIndex 。

getChildBeanContextChild(Object) - Static method in class java.beans.beancontext. BeanContextSupport

获取指定子节点的BeanContextChild（如果有）

getChildBeanContextMembershipListener(Object) - Static method in class java.beans.beancontext. BeanContextSupport

获取指定子节点的BeanContextMembershipListener（如果有）

getChildBeanContextServicesListener(Object) - Static method in class java.beans.beancontext. BeanContextServicesSupport

获取指定小孩的 BeanContextServicesListener （如果有）。

getChildBefore(TreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

返回该节点的子阵列中紧靠 aChild之前的子节点，它必须是此节点的子节点。

getChildCount() - Method in class javax.swing. JTree.DynamicUtilTreeNode

返回子节点的数量。

getChildCount() - Method in class javax.swing.text. AbstractDocument.AbstractElement

返回 TreeNode的接收者的数量。

getChildCount() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的子节点数。

getChildCount() - Method in interface javax.swing.tree. TreeNode

返回接收器包含的子数 TreeNode 。

getChildCount(Object) - Method in class javax.swing.tree. DefaultTreeModel

返回 父节点的子节点数。

getChildCount(Object) - Method in interface javax.swing.tree. TreeModel

返回小孩数 parent 。

getChildElementCount() - Method in interface org.w3c.dom. ElementTraversal

返回元素的当前子节点数为Element类型。

getChildElements() - Method in interface javax.xml.soap. SOAPElement

返回一个Iterator了所有直接子Node s此元素。

getChildElements(QName) - Method in interface javax.xml.soap. SOAPElement

返回一个Iterator了所有直接子Node s的指定qname的此元素。

getChildElements(Name) - Method in interface javax.xml.soap. SOAPElement

返回一个Iterator了所有直接子Node s的指定名称的此元素。

getChildIndex() - Method in class javax.swing. JTree.DropLocation

返回相对于 getPath()返回的路径应丢弃数据的索引。

getChildIndices() - Method in class javax.swing.event. TreeModelEvent

返回子索引的值。

getChildNames(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回一个 String s的数组，表示允许作为命名元素的子元素的元素的名称，按照它们应该出现的顺序。

getChildNames(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getChildNodes() - Method in class javax.imageio.metadata. IIOMetadataNode

返回包含此节点的所有子节点的 NodeList 。

getChildNodes() - Method in interface org.w3c.dom. Node

A NodeList包含此节点的所有子节点。

getChildPolicy(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回以 CHILD_POLICY_开头的常量 CHILD_POLICY_ ，指示命名元素的 CHILD_POLICY_的合法模式。

getChildPolicy(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getChildPropertyChangeListener(Object) - Static method in class java.beans.beancontext. BeanContextSupport

获取指定子对象的PropertyChangeListener（如果有）

getChildren() - Method in interface java.security.cert. PolicyNode

返回该节点的子节点的迭代器。

getChildren() - Method in class javafx.animation. ParallelTransition

将按顺序播放的Animations的列表。

getChildren() - Method in class javafx.animation. SequentialTransition

将按顺序播放Animations的列表。

getChildren() - Method in class javafx.scene.control. SkinBase

返回皮肤的孩子。

getChildren() - Method in class javafx.scene.control. TreeItem

这个TreeItem的孩子。

getChildren() - Method in class javafx.scene. Group

获取这个 Group的孩子列表。

getChildren() - Method in class javafx.scene.layout. Pane

getChildren() - Method in class javafx.scene. Parent

获取这个 Parent的孩子列表。

getChildren() - Method in class javafx.scene.web. WebView

getChildren() - Method in class javax.swing.event. TreeModelEvent

返回由标识节点的子对象 getPath在由指定的位置 getChildIndices 。

getChildrenAdded() - Method in interface javax.swing.event. DocumentEvent.ElementChange

获取添加到给定父元素的子元素。

getChildrenAdded() - Method in class javax.swing.text. AbstractDocument.ElementEdit

获取添加的子项列表。

getChildrenRemoved() - Method in interface javax.swing.event. DocumentEvent.ElementChange

获取从给定父元素中删除的子元素。

getChildrenRemoved() - Method in class javax.swing.text. AbstractDocument.ElementEdit

获取已删除的子项列表。

getChildrenUnmodifiable() - Method in class javafx.scene. Parent

获取这个 Parent的孩子列表作为只读列表。

getChildSerializable(Object) - Static method in class java.beans.beancontext. BeanContextSupport

获取与指定的Child相关联的Serializable（如果有）

getChildState(int) - Method in class javax.swing.text. AsyncBoxView

在给定索引处获取表示子节点布局状态的对象。

getChildVetoableChangeListener(Object) - Static method in class java.beans.beancontext. BeanContextSupport

获取指定子节点的VetoableChangeListener（如果有）

getChildView() - Method in class javax.swing.text. AsyncBoxView.ChildState

获取此记录代表的子视图。

getChildVisibility(Object) - Static method in class java.beans.beancontext. BeanContextSupport

获取与指定子项关联的组件（如果有）。

getChOff() - Method in interface org.w3c.dom.html. HTMLTableCellElement

对齐角色偏移

getChOff() - Method in interface org.w3c.dom.html. HTMLTableColElement

对齐角色偏移

getChOff() - Method in interface org.w3c.dom.html. HTMLTableRowElement

对齐角色偏移

getChOff() - Method in interface org.w3c.dom.html. HTMLTableSectionElement

对齐角色偏移

getChoices() - Method in class javax.security.auth.callback. ChoiceCallback

获取选择列表。

getChoke() - Method in class javafx.scene.effect. InnerShadow

获取属性阻塞的值。

getChoosableFileFilters() - Method in class javax.swing. JFileChooser

获取用户可选择的文件过滤器列表。

getChooserComboBoxFiles() - Method in class javax.swing.filechooser. FileSystemView

返回一个表示要在文件选择器选择器中默认显示的值的文件数组。

getChooserPanels() - Method in class javax.swing. JColorChooser

返回指定的颜色面板。

getChronology() - Method in interface java.time.chrono. ChronoLocalDate

获得这个日期的年表。

getChronology() - Method in interface java.time.chrono. ChronoLocalDateTime

获得这个日期时间的年表。

getChronology() - Method in interface java.time.chrono. ChronoPeriod

获取定义支持的单位意义的年表。

getChronology() - Method in interface java.time.chrono. ChronoZonedDateTime

获得这个日期时间的年表。

getChronology() - Method in class java.time.chrono. HijrahDate

获得这个日期的年表，即Hijrah日历系统。

getChronology() - Method in class java.time.chrono. JapaneseDate

获得这个日期的年表，这是日本的日历系统。

getChronology() - Method in class java.time.chrono. MinguoDate

获得这个日期的时间顺序，即Minguo日历系统。

getChronology() - Method in class java.time.chrono. ThaiBuddhistDate

获得这个日期的年表，这是泰国佛教日历系统。

getChronology() - Method in class java.time.format. DateTimeFormatter

获得在格式化期间使用的压倒一记的年表。

getChronology() - Method in class java.time. LocalDate

获取这个日期的时间顺序，即ISO日历系统。

getChronology() - Method in class java.time. Period

获得这个时期的年表，即ISO日历系统。

getChronology() - Method in class javafx.scene.control. DatePicker

获取物业年表的价值。

getCipherSuite() - Method in class java.net. SecureCacheResponse

返回在检索网络资源的原始连接上使用的加密套件。

getCipherSuite() - Method in class javax.net.ssl. HandshakeCompletedEvent

返回由握手产生的会话使用的密码套件。

getCipherSuite() - Method in class javax.net.ssl. HttpsURLConnection

返回此连接上正在使用的密码套件。

getCipherSuite() - Method in interface javax.net.ssl. SSLSession

返回用于会话中所有连接的SSL加密套件的名称。

getCipherSuites() - Method in class com.sun.net.httpserver. HttpsParameters

返回密码数组的副本，如果没有设置则返回null。

getCipherSuites() - Method in class javax.net.ssl. SSLParameters

返回密码数组的副本，如果没有设置则返回null。

getCite() - Method in interface org.w3c.dom.html. HTMLModElement

指定描述更改原因的文档的URI。

getCite() - Method in interface org.w3c.dom.html. HTMLQuoteElement

指定源文档或消息的URI。

getCLA() - Method in class javax.smartcardio. CommandAPDU

返回类字节CLA的值。

getClass() - Method in class java.lang. Object

返回此 Object的运行时类。

getClassAnnotation(Class<?>) - Static method in class java.rmi.server. RMIClassLoader

返回在编组给定类的对象时，RMI将用于注释类描述符的注释字符串（表示类定义的位置）。

getClassAnnotation(Class<?>) - Method in class java.rmi.server. RMIClassLoaderSpi

提供 RMIClassLoader.getClassAnnotation(Class)的实现。

getClassBody() - Method in interface com.sun.source.tree. NewClassTree

如果正在实例化一个匿名类，返回类体，否则返回 null 。

getClassContext() - Method in class java.lang. SecurityManager

将当前执行堆栈作为一个类的数组返回。

getClassCssMetaData() - Static method in class javafx.scene.chart. AreaChart

getClassCssMetaData() - Static method in class javafx.scene.chart. Axis

getClassCssMetaData() - Static method in class javafx.scene.chart. BarChart

getClassCssMetaData() - Static method in class javafx.scene.chart. CategoryAxis

getClassCssMetaData() - Static method in class javafx.scene.chart. Chart

getClassCssMetaData() - Static method in class javafx.scene.chart. LineChart

getClassCssMetaData() - Static method in class javafx.scene.chart. NumberAxis

getClassCssMetaData() - Static method in class javafx.scene.chart. PieChart

getClassCssMetaData() - Static method in class javafx.scene.chart. StackedAreaChart

getClassCssMetaData() - Static method in class javafx.scene.chart. StackedBarChart

getClassCssMetaData() - Static method in class javafx.scene.chart. ValueAxis

getClassCssMetaData() - Static method in class javafx.scene.chart. XYChart

getClassCssMetaData() - Static method in class javafx.scene.control. Control

getClassCssMetaData() - Static method in class javafx.scene.control. DatePicker

getClassCssMetaData() - Static method in class javafx.scene.control. DialogPane

getClassCssMetaData() - Static method in class javafx.scene.control. Labeled

getClassCssMetaData() - Static method in class javafx.scene.control. ListView

getClassCssMetaData() - Static method in class javafx.scene.control. MenuBar

getClassCssMetaData() - Static method in class javafx.scene.control. Pagination

getClassCssMetaData() - Static method in class javafx.scene.control. PopupControl

getClassCssMetaData() - Static method in class javafx.scene.control. ScrollBar

getClassCssMetaData() - Static method in class javafx.scene.control. ScrollPane

getClassCssMetaData() - Static method in class javafx.scene.control. Separator

getClassCssMetaData() - Static method in class javafx.scene.control.skin. CellSkinBase

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. ColorPickerSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. MenuBarSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. PaginationSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. ProgressBarSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. ProgressIndicatorSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. TableColumnHeader

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. TabPaneSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. TextInputControlSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. ToolBarSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. TreeCellSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control.skin. TreeTableRowSkin

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control. SkinBase

返回与此类相关联的CssMetaData，其可以包括其超类的CssMetaData。

getClassCssMetaData() - Static method in class javafx.scene.control. Slider

getClassCssMetaData() - Static method in class javafx.scene.control. SplitPane

getClassCssMetaData() - Static method in class javafx.scene.control. Tab

getClassCssMetaData() - Static method in class javafx.scene.control. TableColumn

getClassCssMetaData() - Static method in class javafx.scene.control. TableView

getClassCssMetaData() - Static method in class javafx.scene.control. TabPane

getClassCssMetaData() - Static method in class javafx.scene.control. TextArea

getClassCssMetaData() - Static method in class javafx.scene.control. TextField

getClassCssMetaData() - Static method in class javafx.scene.control. TextInputControl

getClassCssMetaData() - Static method in class javafx.scene.control. TitledPane

getClassCssMetaData() - Static method in class javafx.scene.control. ToolBar

getClassCssMetaData() - Static method in class javafx.scene.control. Tooltip

getClassCssMetaData() - Static method in class javafx.scene.control. TreeTableColumn

getClassCssMetaData() - Static method in class javafx.scene.control. TreeTableView

getClassCssMetaData() - Static method in class javafx.scene.control. TreeView

getClassCssMetaData() - Static method in class javafx.scene.image. ImageView

getClassCssMetaData() - Static method in class javafx.scene.layout. Background

getClassCssMetaData() - Static method in class javafx.scene.layout. Border

getClassCssMetaData() - Static method in class javafx.scene.layout. FlowPane

getClassCssMetaData() - Static method in class javafx.scene.layout. GridPane

getClassCssMetaData() - Static method in class javafx.scene.layout. HBox

getClassCssMetaData() - Static method in class javafx.scene.layout. Region

getClassCssMetaData() - Static method in class javafx.scene.layout. StackPane

getClassCssMetaData() - Static method in class javafx.scene.layout. TilePane

getClassCssMetaData() - Static method in class javafx.scene.layout. VBox

getClassCssMetaData() - Static method in class javafx.scene. Node

getClassCssMetaData() - Static method in class javafx.scene.shape. Rectangle

getClassCssMetaData() - Static method in class javafx.scene.shape. Shape

getClassCssMetaData() - Static method in class javafx.scene.text. Text

getClassCssMetaData() - Static method in class javafx.scene.text. TextFlow

getClassCssMetaData() - Static method in class javafx.scene.web. WebView

getClassElements() - Method in interface jdk.nashorn.api.tree. ClassDeclarationTree

获取除构造函数之外的其他属性定义。

getClassElements() - Method in interface jdk.nashorn.api.tree. ClassExpressionTree

获取除构造函数之外的其他属性定义。

getClasses() - Method in class java.lang. Class

返回一个数组，其中包含 Class对象，该对象表示由该 Class对象表示的类的成员的所有公共类和接口。

getClassGuard(Class<?>) - Static method in class jdk.dynalink.linker.support. Guards

创建一个保护方法，测试其唯一的参数是一个确切的特定类。

getClassHeritage() - Method in interface jdk.nashorn.api.tree. ClassDeclarationTree

表达的 extends条款。

getClassHeritage() - Method in interface jdk.nashorn.api.tree. ClassExpressionTree

表达式的 extends子句。

getClassLoader() - Method in class java.lang. Class

返回类的类加载器。

getClassLoader() - Method in class java.lang. Module

返回此模块的 ClassLoader 。

getClassLoader() - Method in class java.security. ProtectionDomain

返回此域的ClassLoader。

getClassLoader() - Method in class javafx.fxml. FXMLLoader

返回此加载器使用的类加载器。

getClassLoader(String) - Static method in class java.rmi.server. RMIClassLoader

返回从给定的代码库URL路径加载类的类加载器。

getClassLoader(String) - Method in class java.rmi.server. RMIClassLoaderSpi

提供 RMIClassLoader.getClassLoader(String)的实现。

getClassLoader(ObjectName) - Method in interface javax.management. MBeanServer

返回名称ClassLoader 。

getClassLoader(JavaFileManager.Location) - Method in class javax.tools. ForwardingJavaFileManager

getClassLoader(JavaFileManager.Location) - Method in interface javax.tools. JavaFileManager

返回一个类加载器，用于从给定的面向包的位置加载插件。

getClassLoaderFor(ObjectName) - Method in interface javax.management. MBeanServer

返回用于加载名为MBean的类的ClassLoader 。

getClassLoaderName() - Method in class java.lang. StackTraceElement

返回包含由此堆栈跟踪元素表示的执行点的类的类加载器的名称。

getClassLoaderRepository() - Method in interface javax.management. MBeanServer

返回此MBeanServer的ClassLoaderRepository。

getClassLoaderRepository() - Method in class javax.management.modelmbean. RequiredModelMBean

返回用于执行类加载的Class Loader Repository。

getClassLoaderRepository(MBeanServer) - Static method in class javax.management. MBeanServerFactory

返回给定MBeanServer使用的ClassLoaderRepository。

getClassLoadingLock(String) - Method in class java.lang. ClassLoader

返回类加载操作的锁定对象。

getClassLoadingMXBean() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机的类加载系统的托管bean。

getClassName() - Method in class java.lang.management. LockInfo

返回锁定对象的类的完全限定名称。

getClassName() - Method in class java.lang. StackTraceElement

返回包含由该堆栈跟踪元素表示的执行点的类的完全限定名称。

getClassName() - Method in interface java.lang. StackWalker.StackFrame

获取由此堆栈帧表示的方法的声明类的 binary name 。

getClassName() - Method in class java.rmi.activation. ActivationDesc

返回此描述符指定的对象的类名。

getClassName() - Method in class java.rmi.activation. ActivationGroupDesc

返回组的类名（可能为 null ）。

getClassName() - Method in class java.security. Provider.Service

返回实现此服务的类的名称。

getClassName() - Method in exception java.util. MissingResourceException

获取由构造函数传递的参数。

getClassName() - Method in class javax.management. MBeanInfo

返回此 MBeanInfo描述的MBean的Java类的名称。

getClassName() - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回此 MBeanInfo描述的MBean的Java类的名称。

getClassName() - Method in class javax.management. ObjectInstance

返回类部分。

getClassName() - Method in interface javax.management.openmbean. OpenMBeanInfo

返回 OpenMBeanInfo描述的开放MBean实例的完全限定Java类名。

getClassName() - Method in class javax.management.openmbean. OpenType

返回此开放类型描述的开放数据值的完全限定Java类名称。

getClassName() - Method in class javax.naming. Binding

检索绑定到此绑定名称的对象的类名。

getClassName() - Method in class javax.naming. NameClassPair

检索绑定到此绑定名称的对象的类名。

getClassName() - Method in class javax.naming. Reference

检索引用引用的对象的类名。

getClassName() - Method in class javax.swing. UIManager.LookAndFeelInfo

返回实现这种外观的类的名称。

getClassName() - Method in class jdk.nashorn.api.scripting. AbstractJSObject

getClassName() - Method in interface jdk.nashorn.api.scripting. JSObject

ECMA [[Class]]属性

getClassName() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

getClassName() - Method in interface org.w3c.dom.html. HTMLElement

元素的类属性。

getClassName(MBeanInfo) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanInfo中使用的className。

getClassPath() - Method in interface java.lang.management. RuntimeMXBean

返回系统类加载器用于搜索类文件的Java类路径。

getClear() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的清除属性定义。

getClear() - Method in interface org.w3c.dom.html. HTMLBRElement

控制浮动文字的流动。

getClickCount() - Method in class java.awt.event. MouseEvent

返回与此事件关联的鼠标点击次数。

getClickCount() - Method in class javafx.scene.input. MouseEvent

返回与此事件关联的鼠标点击数。

getClickCountToStart() - Method in class javax.swing. DefaultCellEditor

返回开始编辑所需的点击次数。

getClient() - Method in class javax.security.auth.kerberos. KerberosTicket

返回与此票证相关联的客户主体。

getClientAddress() - Method in class com.sun.net.httpserver. HttpsParameters

返回启动连接的远程客户端的地址。

getClientAddresses() - Method in class javax.security.auth.kerberos. KerberosTicket

返回可以使用票证的地址列表。

getClientAliases(String, Principal[]) - Method in interface javax.net.ssl. X509KeyManager

获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的客户端。

getClientHost() - Static method in class java.rmi.server. RemoteServer

返回在当前线程中正在处理的远程方法调用的客户端主机的字符串表示形式。

getClientHost() - Method in interface java.rmi.server. ServerRef

已过时。

返回当前客户端的主机名。

getClientInfo() - Method in interface java.sql. Connection

返回包含驱动程序支持的每个客户端信息属性的名称和当前值的列表。

getClientInfo(String) - Method in interface java.sql. Connection

返回由name指定的客户端信息属性的值。

getClientInfoProperties() - Method in interface java.sql. DatabaseMetaData

检索驱动程序支持的客户端信息属性的列表。

getClientProperty(Object) - Method in class javax.swing. JComponent

使用指定的键返回属性的值。

getClientSessionContext() - Method in class javax.net.ssl. SSLContext

返回客户端会话上下文，代表可在客户端SSL套接字握手阶段使用的SSL会话集。

getClientX() - Method in interface org.w3c.dom.events. MouseEvent

事件相对于DOM实现的客户区域发生的水平坐标。

getClientY() - Method in interface org.w3c.dom.events. MouseEvent

事件发生的垂直坐标相对于DOM实现的客户区。

getClip() - Method in class java.awt. Graphics

获取当前的裁剪区域。

getClip() - Method in class javafx.scene. Node

获取属性剪辑的值。

getClip() - Static method in class javax.sound.sampled. AudioSystem

获取可用于播放音频文件或音频流的剪辑。

getClip() - Method in class javax.swing. DebugGraphics

覆盖 Graphics.getClip 。

getClip() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的剪辑属性定义。

getClip(Mixer.Info) - Static method in class javax.sound.sampled. AudioSystem

从指定的混音器中获取可用于播放音频文件或音频流的剪辑。

getClipBounds() - Method in class java.awt. Graphics

返回当前裁剪区域的边界矩形。

getClipBounds() - Method in class javax.swing. DebugGraphics

覆盖 Graphics.getClipBounds 。

getClipBounds(Rectangle) - Method in class java.awt. Graphics

返回当前裁剪区域的边界矩形。

getClippedString(JComponent, FontMetrics, String, int) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils

将传入的字符串剪切到提供的空格。

getClipRect() - Method in class java.awt. Graphics

已过时。
从JDK 1.1版开始，由getClipBounds()代替。

getClob(int) - Method in interface java.sql. CallableStatement

以Java编程语言 java.sql.Clob指定的JDBC CLOB参数的值作为 java.sql.Clob对象。

getClob(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 Clob对象的形式，检索此 ResultSet对象的当前行中指定列的值。

getClob(String) - Method in interface java.sql. CallableStatement

以Java编程语言的形式 java.sql.Clob JDBC CLOB参数的值作为 java.sql.Clob对象。

getClob(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 ResultSet对象的形式 Clob此 ResultSet对象的当前行中指定列的值。

getClosedException() - Method in class java.util.concurrent. SubmissionPublisher

返回与 closeExceptionally相关联的异常，如果未关闭或正常关闭，则返回null。

getClosedIcon() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回用于表示未展开的非叶节点的图标。

getClosestPathForLocation(int, int) - Method in class javax.swing. JTree

返回最接近x，y的节点的路径。

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回最接近x，y的节点的路径。

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getClosestPathForLocation方法。

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf. TreeUI

返回最接近x，y的节点的路径。

getClosestPositionTo(int, Position.Bias, Shape, int, Position.Bias[], int, int) - Method in class javax.swing.text. ParagraphView

返回最接近的模型位置为 x 。

getClosestRowForLocation(int, int) - Method in class javax.swing. JTree

返回到最接近x，y的节点的行。

getCode() - Method in enum javafx.scene.input. KeyCode

返回用于表示密钥代码中的 character的底层平台代码。

getCode() - Method in class javafx.scene.input. KeyCodeCombination

获取与该组合关联的键码。

getCode() - Method in class javafx.scene.input. KeyEvent

与该键中的键相关的键代码按下或键释放事件。

getCode() - Method in class javax.management.loading. MLetContent

获取 MLET标签的 CODE属性的值。

getCode() - Method in interface javax.tools. Diagnostic

返回指示诊断类型的诊断代码。

getCode() - Method in class jdk.jshell. Diag

返回指示诊断类型的诊断代码。

getCode() - Method in interface jdk.nashorn.api.tree. Diagnostic

获取指示诊断类型的诊断代码。

getCode() - Method in interface org.w3c.dom.html. HTMLAppletElement

Applet类文件。

getCode() - Method in interface org.w3c.dom.html. HTMLObjectElement

Applet类文件。

getCodebase(Class) - Static method in class javax.rmi.CORBA. Util

返回给定类的代码库（如果有）。

getCodebase(Class) - Method in interface javax.rmi.CORBA. UtilDelegate

代表团要求 Util.getCodebase(java.lang.Class) 。

getCodeBase() - Method in class java.applet. Applet

已过时。

获取基本URL。

getCodeBase() - Method in interface java.applet. AppletStub

已过时。

获取基本URL。

getCodeBase() - Method in class javafx.application. HostServices

获取此应用程序的代码库URI。

getCodeBase() - Method in interface javax.jnlp. BasicService

返回应用程序的代码库。

getCodeBase() - Method in class javax.management.loading. MLetContent

获取代码库URL。

getCodeBase() - Method in interface org.w3c.dom.html. HTMLAppletElement

小程序的可选基本URI。

getCodeBase() - Method in interface org.w3c.dom.html. HTMLObjectElement

classid基本URI， data和 archive属性。

getCodePoint() - Method in exception java.util. IllegalFormatCodePointException

返回由 Character.isValidCodePoint(int)定义的非法代码点。

getCodeSigners() - Method in class java.security. CodeSource

返回与此CodeSource相关联的代码签名者。

getCodeSigners() - Method in class java.util.jar. JarEntry

返回 CodeSigner对象此条，或 null如果没有。

getCodeSource() - Method in class java.security. ProtectionDomain

返回此域的CodeSource。

getCodeType() - Method in interface org.w3c.dom.html. HTMLObjectElement

通过 classid属性下载的数据的内容类型。

getCofactor() - Method in class java.security.spec. ECParameterSpec

返回辅助因子。

getCollapsed() - Method in interface org.w3c.dom.ranges. Range

如果范围已折叠，则为TRUE

getCollapsedIcon() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回折叠图标。

getCollation() - Method in class javafx.print. JobSettings

排序规则确定打印文档的多个副本时如何排序纸张。

getCollationElementIterator(String) - Method in class java.text. RuleBasedCollator

返回给定String的CollationElementIterator。

getCollationElementIterator(CharacterIterator) - Method in class java.text. RuleBasedCollator

返回给定CharacterIterator的CollationElementIterator。

getCollationKey(String) - Method in class java.text. Collator

将String转换成可以与其他CollationKeys进行比较的一系列位。

getCollationKey(String) - Method in class java.text. RuleBasedCollator

将字符串转换成可以与CollationKey.compareTo进行比较的一系列字符。

getCollection() - Method in class java.security.cert. CollectionCertStoreParameters

返回 Collection ， Certificate检索 Certificate s和 CRL s。

getCollectionCount() - Method in interface java.lang.management. GarbageCollectorMXBean

返回已发生的集合总数。

getCollectionTime() - Method in interface java.lang.management. GarbageCollectorMXBean

返回以毫秒为单位的大概累积收集时间。

getCollectionUsage() - Method in interface java.lang.management. MemoryPoolMXBean

返回Java虚拟机最近花费在回收此内存池中未使用对象的努力后的内存使用情况。

getCollectionUsageThreshold() - Method in interface java.lang.management. MemoryPoolMXBean

以字节为单位返回此内存池的集合使用阈值。

getCollectionUsageThresholdCount() - Method in interface java.lang.management. MemoryPoolMXBean

返回Java虚拟机检测到内存使用量达到或超过集合使用率阈值的次数。

getColor() - Method in class java.awt. Graphics

获取此图形上下文的当前颜色。

getColor() - Method in class java.awt. PageAttributes

返回是否使用这些属性的页面将以彩色或单色呈现。

getColor() - Method in class javafx.scene.effect. DropShadow

获取属性颜色的值。

getColor() - Method in class javafx.scene.effect. InnerShadow

获取属性颜色的值。

getColor() - Method in class javafx.scene.effect. Light

获取属性颜色的值。

getColor() - Method in class javafx.scene.effect. Shadow

获取属性颜色的值。

getColor() - Method in class javafx.scene. LightBase

获取属性颜色的值。

getColor() - Method in class javafx.scene.paint. Stop

获取此偏移量的渐变颜色。

getColor() - Method in class javax.swing. DebugGraphics

返回用于文本绘图操作的颜色。

getColor() - Method in class javax.swing. JColorChooser

从颜色选择器获取当前颜色值。

getColor() - Method in class javax.swing.text. DefaultHighlighter.DefaultHighlightPainter

返回突出显示的颜色。

getColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的颜色属性定义。

getColor() - Method in interface org.w3c.dom.html. HTMLBaseFontElement

字体颜色。

getColor() - Method in interface org.w3c.dom.html. HTMLFontElement

字体颜色。

getColor(int, int) - Method in interface javafx.scene.image. PixelReader

从表面的指定坐标读取像素的颜色，并将该值作为Color对象返回。

getColor(Object) - Method in class javax.swing. UIDefaults

如果 key的值是 Color返回，否则返回 null 。

getColor(Object) - Static method in class javax.swing. UIManager

从默认值返回颜色。

getColor(Object, Locale) - Method in class javax.swing. UIDefaults

如果值 key对于给定 Locale是 Color返回它，否则返回 null 。

getColor(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回颜色。

getColor(String) - Static method in class java.awt. Color

在系统属性中查找颜色。

getColor(String, int) - Static method in class java.awt. Color

在系统属性中查找颜色。

getColor(String, Color) - Static method in class java.awt. Color

在系统属性中查找颜色。

getColor(SynthContext, ColorType) - Method in class javax.swing.plaf.synth. SynthStyle

返回指定状态的颜色。

getColor1() - Method in class java.awt. GradientPaint

返回由点P1锚定的颜色C1。

getColor2() - Method in class java.awt. GradientPaint

返回由点P2锚定的颜色C2。

getColorComponents(float[]) - Method in class java.awt. Color

返回一个 float阵列只包含的颜色分量 Color ，在 ColorSpace的的 Color 。

getColorComponents(ColorSpace, float[]) - Method in class java.awt. Color

返回一个 float包含由 cspace参数指定的 Color中的 ColorSpace的颜色分量的 float数组。

getColorConverter() - Static method in class javafx.css. StyleConverter

返回一个 StyleConverter ，将Web颜色的String表示形式转换为 Color 。

getColorForGap(int, int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

返回间隙的颜色。

getColorForState(SynthContext, ColorType) - Method in class javax.swing.plaf.nimbus. NimbusStyle

返回指定状态的颜色。

getColorForState(SynthContext, ColorType) - Method in class javax.swing.plaf.synth. SynthStyle

返回指定状态的颜色。

getColorFromModel() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

返回当前选择的颜色。

getColorModel() - Method in class java.awt. Component

获取用于在输出设备上显示组件的 ColorModel实例。

getColorModel() - Method in class java.awt. GraphicsConfiguration

返回ColorModel与此GraphicsConfiguration相关联。

getColorModel() - Method in class java.awt.image. BufferedImage

返回 ColorModel 。

getColorModel() - Method in class java.awt.image. PixelGrabber

获取存储在数组中的像素的ColorModel。

getColorModel() - Method in interface java.awt.image. RenderedImage

返回与此图像相关联的ColorModel。

getColorModel() - Method in interface java.awt. PaintContext

返回输出的 ColorModel 。

getColorModel() - Method in class java.awt. Toolkit

确定该工具包屏幕的颜色模型。

getColorModel() - Method in class javax.imageio. ImageTypeSpecifier

返回此对象指定的 ColorModel 。

getColorModel(int) - Method in class java.awt. GraphicsConfiguration

返回与支持指定透明度的 ColorModel相关联的 GraphicsConfiguration 。

getColors() - Method in class java.awt. MultipleGradientPaint

返回此梯度使用的颜色数组的副本。

getColorSelectionModel() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

返回选择器面板正在编辑的模型。

getColorSpace() - Method in class java.awt. Color

返回 ColorSpace的 Color 。

getColorSpace() - Method in class java.awt.image. ColorModel

返回 ColorSpace与此 ColorModel相关联。

getColorSpace() - Method in class java.awt. MultipleGradientPaint

返回枚举类型，它指定插值的颜色空间。

getColorSpaceType() - Method in class java.awt.color. ICC_Profile

返回颜色空间类型。

getCols() - Method in interface org.w3c.dom.html. HTMLFrameSetElement

框架集中的帧列数。

getCols() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

控制宽度（字符）。

getColSpan() - Method in interface org.w3c.dom.html. HTMLTableCellElement

单元格跨越的列数。

getColumn() - Method in class javafx.scene.control. ResizeFeaturesBase

返回发生resize的列，如果由于大小调整操作而创建了此ResizeFeatures实例，则返回null。

getColumn() - Method in class javafx.scene.control. TablePosition

Table Table在TableView中表示的列索引。

getColumn() - Method in class javafx.scene.control. TablePositionBase

Table Table在TableView中表示的列索引。

getColumn() - Method in class javafx.scene.control. TableView.ResizeFeatures

返回发生resize的列，如果由于TableView resize操作而创建了此ResizeFeatures实例，则返回null。

getColumn() - Method in class javafx.scene.control. TreeTablePosition

TreeTablePosition在TreeTableView中表示的列索引。

getColumn() - Method in class javafx.scene.control. TreeTableView.ResizeFeatures

返回发生resize的列，如果由于TreeTableView resize操作而创建了此ResizeFeatures实例，则返回null。

getColumn() - Method in class javax.swing.event. TableModelEvent

返回事件的列。

getColumn() - Method in class javax.swing. JTable.DropLocation

返回抛出的项目应放在表中的列索引。

getColumn() - Method in class javax.swing. RowSorter.SortKey

返回列的索引。

getColumn(int) - Method in class javax.swing.table. DefaultTableColumnModel

返回 TableColumn在列对象 columnIndex 。

getColumn(int) - Method in interface javax.swing.table. TableColumnModel

返回 TableColumn在列对象 columnIndex 。

getColumn(Object) - Method in class javax.swing. JTable

返回表中的列的 TableColumn对象，其标识符等于 identifier ，与 equals进行比较时。

getColumnClass(int) - Method in class javax.swing. JTable

返回列位置 column在视图中显示的列的类型。

getColumnClass(int) - Method in class javax.swing.table. AbstractTableModel

无论 Object.class如何返回 columnIndex 。

getColumnClass(int) - Method in interface javax.swing.table. TableModel

返回列中所有单元格值的最具体的超类。

getColumnClassName(int) - Method in interface java.sql. ResultSetMetaData

如果调用方法 ResultSet.getObject从列中检索值，则返回其实例生成的Java类的完全限定名称。

getColumnClassName(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

以指定列中的值映射到的Java编程语言中的类的全限定名称。

getColumnConstraints() - Method in class javafx.scene.layout. GridPane

返回列约束列表。

getColumnCount() - Method in interface java.sql. ResultSetMetaData

返回此 ResultSet对象中的列数。

getColumnCount() - Method in class javafx.scene.layout. GridPane

返回此GridPane中的列数。

getColumnCount() - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索创建此 RowSetMetaDataImpl对象的 RowSet对象中的列数。

getColumnCount() - Method in class javax.swing. DefaultRowSorter.ModelWrapper

返回模型中的列数。

getColumnCount() - Method in class javax.swing. JTable

返回列模型中的列数。

getColumnCount() - Method in class javax.swing.table. DefaultTableColumnModel

返回 tableColumns数组中的列数。

getColumnCount() - Method in class javax.swing.table. DefaultTableModel

返回此数据表中的列数。

getColumnCount() - Method in interface javax.swing.table. TableColumnModel

返回模型中的列数。

getColumnCount() - Method in interface javax.swing.table. TableModel

返回模型中的列数。

getColumnCount() - Method in class javax.swing.text. TableView.TableCell

已过时。

获取此单元格跨越的列数（例如网格宽度）。

getColumnDisplaySize(int) - Method in interface java.sql. ResultSetMetaData

指定指定列的正常最大宽度（以字符为单位）。

getColumnDisplaySize(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索指定列的字符的正常最大宽度。

getColumnHalignment() - Method in class javafx.scene.layout. FlowPane

获取属性columnHalignment的值。

getColumnHeader() - Method in class javax.swing. JScrollPane

返回列标题。

getColumnHeader() - Method in class javax.swing. ScrollPaneLayout

返回作为列标题的 JViewport对象。

getColumnHeaders() - Method in class javafx.scene.control.skin. NestedTableColumnHeader

返回一个不可修改的TableColumnHeader实例的列表，这是NestedTableColumnHeader的子项。

getColumnIndex(Object) - Method in class javax.swing.table. DefaultTableColumnModel

当使用 equals进行比较时，返回其标识符等于 identifier的 tableColumns数组中的第一列的索引。

getColumnIndex(Object) - Method in interface javax.swing.table. TableColumnModel

当使用 equals进行比较时，返回标识符等于 identifier的表中第一列的索引。

getColumnIndex(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，则返回小孩的列索引约束。

getColumnIndexAtX(int) - Method in class javax.swing.table. DefaultTableColumnModel

返回位于 x的列的索引，如果没有列覆盖此点，则返回-1。

getColumnIndexAtX(int) - Method in interface javax.swing.table. TableColumnModel

返回位于水平点的列的索引， xPosition ; 如果它位于列的边界之外，则为-1。

getColumnLabel(int) - Method in interface java.sql. ResultSetMetaData

获取指定列的建议标题用于打印输出和显示。

getColumnLabel(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索指定列的建议列标题，以用于打印输出和显示。

getColumnMargin() - Method in class javax.swing.table. DefaultTableColumnModel

返回宽度边距 TableColumn 。

getColumnMargin() - Method in interface javax.swing.table. TableColumnModel

返回每列中单元格之间的宽度。

getColumnModel() - Method in class javax.swing. JTable

返回包含此表的所有列信息的 TableColumnModel 。

getColumnModel() - Method in class javax.swing.table. JTableHeader

返回包含此表头的所有列信息的 TableColumnModel 。

getColumnModelListeners() - Method in class javax.swing.table. DefaultTableColumnModel

返回在此模型上注册的所有列模型侦听器的数组。

getColumnName(int) - Method in interface java.sql. ResultSetMetaData

获取指定列的名称。

getColumnName(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索指定列的名称。

getColumnName(int) - Method in class javax.swing. JTable

返回列位置 column在视图中出现的列的名称。

getColumnName(int) - Method in class javax.swing.table. AbstractTableModel

使用电子表格约定返回列的默认名称：A，B，C，...

getColumnName(int) - Method in class javax.swing.table. DefaultTableModel

返回列名。

getColumnName(int) - Method in interface javax.swing.table. TableModel

返回列的名称为 columnIndex 。

getColumnNumber() - Method in exception javax.script. ScriptException

获取发生错误的列号。

getColumnNumber() - Method in interface javax.tools. Diagnostic

返回由 Diagnostic.getPosition()返回的字符偏移量的列号。

getColumnNumber() - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

getColumnNumber() - Method in interface javax.xml.bind. ValidationEventLocator

返回列号（如果有）

getColumnNumber() - Method in interface javax.xml.stream. Location

返回当前事件结束的列号，如果没有可用，返回-1。

getColumnNumber() - Method in interface javax.xml.transform. SourceLocator

返回当前文档事件结束的字符位置。

getColumnNumber() - Method in exception jdk.nashorn.api.scripting. NashornException

获取此 NashornException的列

getColumnNumber() - Method in interface jdk.nashorn.api.tree. Diagnostic

获取 Diagnostic.getPosition()返回的字符偏移量的列号。

getColumnNumber() - Method in interface org.w3c.dom. DOMLocator

此定位器指向的列号，如果没有列号可用， -1 。

getColumnNumber() - Method in class org.xml.sax.helpers. LocatorImpl

返回保存的列号（1）。

getColumnNumber() - Method in interface org.xml.sax. Locator

返回当前文档事件结束的列号。

getColumnNumber() - Method in exception org.xml.sax. SAXParseException

发生异常的文本结尾的列号。

getColumnNumber(long) - Method in interface com.sun.source.tree. LineMap

查找字符位置的列。

getColumnNumber(long) - Method in interface jdk.nashorn.api.tree. LineMap

找到字符位置的列。

getColumnPrivileges(String, String, String, String) - Method in interface java.sql. DatabaseMetaData

检索表的列的访问权限的描述。

getColumnResizePolicy() - Method in class javafx.scene.control. TableView

获取属性columnResizePolicy的值。

getColumnResizePolicy() - Method in class javafx.scene.control. TreeTableView

获取属性columnResizePolicy的值。

getColumns() - Method in class java.awt. GridLayout

获取此布局中的列数。

getColumns() - Method in class java.awt. TextArea

返回此文本区域中的列数。

getColumns() - Method in class java.awt. TextField

获取此文本字段中的列数。

getColumns() - Method in class javafx.scene.control. TableColumn

这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。

getColumns() - Method in class javafx.scene.control. TableColumnBase

这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。

getColumns() - Method in class javafx.scene.control. TableView

TableColumns是TableView的一部分。

getColumns() - Method in class javafx.scene.control. TreeTableColumn

这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。

getColumns() - Method in class javafx.scene.control. TreeTableView

作为TableView的一部分的TreeTableColumns。

getColumns() - Method in class javax.swing. JTextArea

返回TextArea中的列数。

getColumns() - Method in class javax.swing. JTextField

返回此 TextField的列数。

getColumns() - Method in class javax.swing.table. DefaultTableColumnModel

返回 Enumeration中所有列的 Enumeration 。

getColumns() - Method in interface javax.swing.table. TableColumnModel

返回 Enumeration中所有列的 Enumeration 。

getColumns(String, String, String, String) - Method in interface java.sql. DatabaseMetaData

检索指定目录中可用的表列的描述。

getColumnSelectionAllowed() - Method in class javax.swing. JTable

如果可以选择列，则返回true。

getColumnSelectionAllowed() - Method in class javax.swing.table. DefaultTableColumnModel

如果允许列选择，则返回true，否则返回false。

getColumnSelectionAllowed() - Method in interface javax.swing.table. TableColumnModel

如果可以选择列，则返回true。

getColumnSpan(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，则返回小孩的列跨度约束。

getColumnType(int) - Method in interface java.sql. ResultSetMetaData

检索指定列的SQL类型。

getColumnType(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索存储在指定列中的SQL类型的类型代码（ java.sql.Types常量之一）。

getColumnTypeName(int) - Method in interface java.sql. ResultSetMetaData

检索指定列的数据库特定类型名称。

getColumnTypeName(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索存储在指定列中的值的DBMS特定类型名称。

getColumnWidth() - Method in class javax.swing. JTextArea

获取列宽。

getColumnWidth() - Method in class javax.swing. JTextField

返回列宽。

getComboBox() - Method in class javax.swing.plaf.metal. MetalComboBoxButton

返回 JComboBox 。

getComboIcon() - Method in class javax.swing.plaf.metal. MetalComboBoxButton

返回 JComboBox的图标。

getCommand() - Method in enum javafx.scene.web. HTMLEditorSkin.Command

getCommand() - Method in class javax.sound.midi. ShortMessage

获取与此事件相关联的MIDI命令。

getCommand() - Method in class javax.sql.rowset. BaseRowSet

检索作为此 RowSet对象的命令的SQL查询。

getCommand() - Method in interface javax.sql. RowSet

检索此 RowSet对象的命令属性。

getCommand(String) - Method in class javax.activation. DataHandler

获取命令 cmdName 。

getCommand(String, String) - Method in class javax.activation. CommandMap

获取与MIME类型相对应的默认命令。

getCommand(String, String) - Method in class javax.activation. MailcapCommandMap

获取对应于 cmdName的MIME类型的命令。

getCommand(String, String, DataSource) - Method in class javax.activation. CommandMap

获取与MIME类型相对应的默认命令。

getCommandClass() - Method in class javax.activation. CommandInfo

返回命令的类名。

getCommandEnvironment() - Method in class java.rmi.activation. ActivationGroupDesc

返回组的命令环境控制对象。

getCommandLine() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索传递给jarsigner工具的命令行参数。

getCommandName() - Method in class javax.activation. CommandInfo

返回命令动词。

getCommandObject(DataHandler, ClassLoader) - Method in class javax.activation. CommandInfo

返回实例化的JavaBean组件。

getCommandOptions() - Method in class java.rmi.activation. ActivationGroupDesc.CommandEnvironment

获取配置的java命令选项。

getCommandPath() - Method in class java.rmi.activation. ActivationGroupDesc.CommandEnvironment

获取配置的路径限定的java命令名称。

getComment() - Method in class java.net. HttpCookie

返回描述此cookie的目的的注释，如果cookie没有注释，则返回 null 。

getComment() - Method in class java.util.zip. ZipEntry

返回条目的注释字符串。

getComment() - Method in class java.util.zip. ZipFile

返回zip文件注释，否则返回null。

getCommentURL() - Method in class java.net. HttpCookie

返回描述此cookie的目的的注释URL，如果cookie没有注释URL，则返回 null 。

getCommitsOnValidEdit() - Method in class javax.swing.text. DefaultFormatter

当编辑发布回 JFormattedTextField时返回。

getCommitted() - Method in class java.lang.management. MemoryUsage

返回为Java虚拟机提供的内存量（以字节计）。

getCommitted() - Method in class javafx.scene.input. InputMethodEvent

作为组合的结果，获取输入法提交的文本。

getCommittedCharacterCount() - Method in class java.awt.event. InputMethodEvent

获取文本中提交的字符数。

getCommittedText(int, int, AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im. InputMethodRequests

获取一个迭代器，提供对文本编辑组件中包含的整个文本和属性的访问，除了未提交的文本。

getCommittedTextLength() - Method in interface java.awt.im. InputMethodRequests

获取文本编辑组件中包含的整个文本的长度，但未提交（组合）文本除外）。

getCommittedVirtualMemorySize() - Method in interface com.sun.management. OperatingSystemMXBean

返回运行进程保证可用的虚拟内存量（以字节为单位），如果不支持此操作，则 -1 。

getCommonAncestorContainer() - Method in interface org.w3c.dom.ranges. Range

范围两个边界点最深的共同祖先容器。

getCommonPoolParallelism() - Static method in class java.util.concurrent. ForkJoinPool

返回公共池的目标并行度级别。

getCompact() - Method in interface org.w3c.dom.html. HTMLDirectoryElement

减少列表项之间的间距。

getCompact() - Method in interface org.w3c.dom.html. HTMLDListElement

减少列表项之间的间距。

getCompact() - Method in interface org.w3c.dom.html. HTMLMenuElement

减少列表项之间的间距。

getCompact() - Method in interface org.w3c.dom.html. HTMLOListElement

减少列表项之间的间距。

getCompact() - Method in interface org.w3c.dom.html. HTMLUListElement

减少列表项之间的间距。

getComparator() - Method in interface java.util. Spliterator

如果这个Spliterator的来源是Spliterator.SORTED由Comparator ，返回Comparator 。

getComparator() - Method in class javafx.collections.transformation. SortedList

获取属性比较器的值。

getComparator() - Method in class javafx.scene.control. TableColumnBase

获取属性比较器的值。

getComparator() - Method in class javafx.scene.control. TableView

获取属性比较器的值。

getComparator() - Method in class javafx.scene.control. TreeTableView

获取属性比较器的值。

getComparator() - Method in class javax.swing. SortingFocusTraversalPolicy

返回将用于在焦点遍历循环中对“组件”进行排序的“比较器”。

getComparator(int) - Method in class javax.swing. DefaultRowSorter

返回指定列的 Comparator 。

getComparator(int) - Method in class javax.swing.table. TableRowSorter

返回指定列的 Comparator 。

getCompilationMXBean() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机编译系统的受管Bean。

getCompilationUnit() - Method in class com.sun.source.util. TaskEvent

返回此事件的编译单位。

getCompilationUnit() - Method in class com.sun.source.util. TreePath

返回与此路径关联的编译单元。

getCompletedTaskCount() - Method in class java.util.concurrent. ThreadPoolExecutor

返回完成执行的任务的大致总数。

getCompleter() - Method in class java.util.concurrent. CountedCompleter

返回在此任务的构造函数中建立的完成者，如果没有，则返回 null 。

getCompletions(Element, AnnotationMirror, ExecutableElement, String) - Method in class javax.annotation.processing. AbstractProcessor

返回一个空的可迭代的完成。

getCompletions(Element, AnnotationMirror, ExecutableElement, String) - Method in interface javax.annotation.processing. Processor

返回到工具基础结构，可以对注释的建议完成进行迭代。

getComponent() - Method in class java.awt.dnd. DragGestureEvent

返回 Component与此相关 DragGestureEvent 。

getComponent() - Method in class java.awt.dnd. DragGestureRecognizer

该方法返回 Component ，由 DragGestureRecognizer进行“观察”，用于拖动启动手势。

getComponent() - Method in class java.awt.dnd. DragSourceContext

返回 Component与此相关 DragSourceContext 。

getComponent() - Method in class java.awt.dnd. DropTarget

获取 Component与此 DropTarget相关联。

getComponent() - Method in class java.awt.dnd. DropTargetContext

此方法返回 Component与此相关 DropTargetContext 。

getComponent() - Method in class java.awt.event. ComponentEvent

返回事件的发起者。

getComponent() - Method in class java.awt.event. HierarchyEvent

返回事件的发起者。

getComponent() - Method in interface java.beans.beancontext. BeanContextChildComponentProxy

获取 java.awt.Component与此 BeanContextChild相关联。

getComponent() - Method in class javax.swing. ComponentInputMap

返回创建的组件 InputMap 。

getComponent() - Method in class javax.swing. DefaultCellEditor

返回对编辑器组件的引用。

getComponent() - Method in class javax.swing.event. AncestorEvent

返回侦听器添加到的组件。

getComponent() - Method in class javax.swing. JMenu

返回 java.awt.Component用于绘制这个 MenuElement 。

getComponent() - Method in class javax.swing. JMenuBar

实现为 MenuElement 。

getComponent() - Method in class javax.swing. JMenuItem

返回用于绘制此对象的 java.awt.Component 。

getComponent() - Method in class javax.swing. JPopupMenu

返回此 JPopupMenu组件。

getComponent() - Method in class javax.swing. JToolTip

返回工具提示应用于的组件。

getComponent() - Method in interface javax.swing. MenuElement

此方法应返回用于绘制接收元素的 java.awt.Component 。

getComponent() - Method in class javax.swing.plaf.basic. BasicTextUI

获取与此UI实现相关联的文本组件。

getComponent() - Method in class javax.swing.plaf.synth. SynthContext

返回包含区域的托管组件。

getComponent() - Method in interface javax.swing. Renderer

返回用于渲染值的组件。

getComponent() - Method in class javax.swing.text. ComponentView

获取与视图关联的组件。

getComponent() - Method in class javax.swing.text. DefaultCaret

获取此插入符所绑定的文本编辑器组件。

getComponent() - Method in class javax.swing. TransferHandler.TransferSupport

返回此传输的目标组件。

getComponent(int) - Method in class java.awt. Container

获取此容器中的第n个组件。

getComponent(AttributeSet) - Static method in class javax.swing.text. StyleConstants

从属性列表获取组件设置。

getComponentAfter(Container, Component) - Method in class java.awt. ContainerOrderFocusTraversalPolicy

返回在aComponent之后应该接收焦点的Component。

getComponentAfter(Container, Component) - Method in class java.awt. FocusTraversalPolicy

返回在aComponent之后应该接收焦点的Component。

getComponentAfter(Container, Component) - Method in class javax.swing. DefaultFocusManager

返回之后的组件。

getComponentAfter(Container, Component) - Method in class javax.swing. LayoutFocusTraversalPolicy

返回在aComponent之后应该接收焦点的Component。

getComponentAfter(Container, Component) - Method in class javax.swing. SortingFocusTraversalPolicy

返回在aComponent之后应该接收焦点的Component。

getComponentAt(int) - Method in class javax.swing. JTabbedPane

返回组件 index 。

getComponentAt(int, int) - Method in class java.awt. Component

确定此组件或其一个直接子组件是否包含（ x ， y ）位置，如果是，则返回包含的组件。

getComponentAt(int, int) - Method in class java.awt. Container

找到包含x，y位置的组件。

getComponentAt(Point) - Method in class java.awt. Component

返回包含指定点的组件或子组件。

getComponentAt(Point) - Method in class java.awt. Container

获取包含指定点的组件。

getComponentAtIndex(int) - Method in class javax.swing. JMenuBar

已过时。
替换为getComponent(int i)

getComponentAtIndex(int) - Method in class javax.swing. JPopupMenu

已过时。
替换为Container.getComponent(int)

getComponentAtIndex(int) - Method in class javax.swing. JToolBar

返回指定索引处的组件。

getComponentBefore(Container, Component) - Method in class java.awt. ContainerOrderFocusTraversalPolicy

返回应该在aComponent之前接收焦点的Component。

getComponentBefore(Container, Component) - Method in class java.awt. FocusTraversalPolicy

返回应该在aComponent之前接收焦点的Component。

getComponentBefore(Container, Component) - Method in class javax.swing. DefaultFocusManager

返回之前的组件。

getComponentBefore(Container, Component) - Method in class javax.swing. LayoutFocusTraversalPolicy

返回应该在aComponent之前接收焦点的Component。

getComponentBefore(Container, Component) - Method in class javax.swing. SortingFocusTraversalPolicy

返回应该在aComponent之前接收焦点的Component。

getComponentColor(JComponent, String, Color, float, float, int) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter

从给定的JComponent获取颜色属性。

getComponentCount() - Method in class java.awt. Container

获取此面板中的组件数量。

getComponentCountInLayer(int) - Method in class javax.swing. JLayeredPane

返回当前在指定图层中的子项数。

getComponentGraphics(Graphics) - Method in class javax.swing. JComponent

返回用于绘制该组件的图形对象。

getComponentIndex(Component) - Method in class javax.swing. JMenuBar

返回指定组件的索引。

getComponentIndex(Component) - Method in class javax.swing. JPopupMenu

返回指定组件的索引。

getComponentIndex(Component) - Method in class javax.swing. JToolBar

返回指定组件的索引。

getComponentListeners() - Method in class java.awt. Component

返回在此组件上注册的所有组件侦听器的数组。

getComponentOrientation() - Method in class java.awt. Component

检索用于对该组件中的元素或文本进行排序的语言敏感方向。

getComponentPopupMenu() - Method in class javax.swing. JComponent

返回分配给此组件的 JPopupMenu 。

getComponents() - Method in class java.awt. Container

获取此容器中的所有组件。

getComponents(float[]) - Method in class java.awt. Color

返回一个包含 float的颜色和alpha分量的 Color ，在 ColorSpace的 Color 。

getComponents(int, int[], int) - Method in class java.awt.image. ColorModel

在这个 ColorModel给出了一个像素的非规范化颜色/ alpha分量的数组。

getComponents(int, int[], int) - Method in class java.awt.image. ComponentColorModel

在这个 ColorModel给出了一个像素的非规范化颜色/ alpha分量的数组。

getComponents(int, int[], int) - Method in class java.awt.image. DirectColorModel

在这个 ColorModel给出一个像素，返回一个非规范化颜色/ alpha分量的数组。

getComponents(int, int[], int) - Method in class java.awt.image. IndexColorModel

返回 ColorModel指定像素的非标准化颜色/ alpha分量 ColorModel 。

getComponents(ColorSpace, float[]) - Method in class java.awt. Color

返回一个 float阵列包含的颜色和alpha分量 Color ，在 ColorSpace由指定 cspace参数。

getComponents(Object, int[], int) - Method in class java.awt.image. ColorModel

在这个 ColorModel给出一个像素的非归一化颜色/ alpha分量的数组。

getComponents(Object, int[], int) - Method in class java.awt.image. ComponentColorModel

在这个 ColorModel给出了一个像素的非规范化颜色/ alpha分量的数组。

getComponents(Object, int[], int) - Method in class java.awt.image. DirectColorModel

返回给这个 ColorModel一个像素的非标准化颜色/ alpha分量的数组。

getComponents(Object, int[], int) - Method in class java.awt.image. IndexColorModel

返回 ColorModel指定像素的非标准化颜色/ alpha分量 ColorModel 。

getComponentsInLayer(int) - Method in class javax.swing. JLayeredPane

返回指定图层中的组件数组。

getComponentSize() - Method in class java.awt.image. ColorModel

返回每个颜色/ alpha分量的位数的数组。

getComponentSize() - Method in class java.awt.image. IndexColorModel

返回每个颜色/ alpha分量的位数的数组。

getComponentSize(int) - Method in class java.awt.image. ColorModel

返回指定颜色/ alpha分量的位数。

getComponentState() - Method in class javax.swing.plaf.synth. SynthContext

返回小部件的状态，这是 SynthConstants定义的值的位掩码。

getComponentToLayer() - Method in class javax.swing. JLayeredPane

返回将组件映射到图层的散列表。

getComponentType() - Method in class java.lang. Class

返回表示数组的组件类型的 Class 。

getComponentType() - Method in interface javax.lang.model.type. ArrayType

返回此数组类型的组件类型。

getComponentWithFocus() - Static method in class com.sun.java.accessibility.util. AWTEventMonitor

返回当前具有键盘焦点的组件。

getComponentZOrder(Component) - Method in class java.awt. Container

返回容器内组件的z-order索引。

getComposed() - Method in class javafx.scene.input. InputMethodEvent

获取组合下的文本。

getComposite() - Method in class java.awt. Graphics2D

返回 Graphics2D上下文中的当前 Composite 。

getCompositeData() - Method in class javax.management.openmbean. CompositeDataInvocationHandler

返回提供给构造函数的 CompositeData 。

getCompositeType() - Method in class com.sun.management. GcInfo

getCompositeType() - Method in interface javax.management.openmbean. CompositeData

返回此 复合数据实例的 复合类型 。

getCompositeType() - Method in class javax.management.openmbean. CompositeDataSupport

返回此 复合数据实例的 复合类型 。

getCompressedSize() - Method in class java.util.zip. ZipEntry

返回压缩条目数据的大小。

getCompressionMode() - Method in class javax.imageio. ImageWriteParam

如果支持压缩，则返回当前压缩模式。

getCompressionQuality() - Method in class javax.imageio. ImageWriteParam

返回当前的压缩质量设置。

getCompressionQualityDescriptions() - Method in class javax.imageio. ImageWriteParam

返回 String的数组，可以与 getCompressionQualityValues一起使用，作为设置或显示压缩质量级别的用户界面的一部分。

getCompressionQualityDescriptions() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

getCompressionQualityValues() - Method in class javax.imageio. ImageWriteParam

返回 float的数组，可以与 getCompressionQualityDescriptions一起使用，作为设置或显示压缩质量级别的用户界面的一部分。

getCompressionQualityValues() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

getCompressionThreshold() - Method in class javax.swing.text. StyleContext

返回尝试压缩到唯一/不可变集合的键/值对的最大数量。

getCompressionType() - Method in class javax.imageio. ImageWriteParam

返回当前设置的压缩类型，如果没有设置，则返回 null 。

getCompressionTypes() - Method in class javax.imageio. ImageWriteParam

返回可用的压缩类型列表，如数组或 String s，或 null如果可能不使用这些接口选择压缩类型。

getComputedStyle(Element, String) - Method in interface org.w3c.dom.css. ViewCSS

该方法用于获取在[ CSS2 ]中定义的计算样式。

getConcurrency() - Method in interface java.sql. ResultSet

检索此 ResultSet对象的并发模式。

getConcurrency() - Method in class javax.sql.rowset. BaseRowSet

返回此 RowSet对象的并发性。

getCondition() - Method in interface com.sun.source.tree. AssertTree

返回被声明的条件。

getCondition() - Method in interface com.sun.source.tree. ConditionalExpressionTree

返回条件。

getCondition() - Method in interface com.sun.source.tree. DoWhileLoopTree

返回循环的条件。

getCondition() - Method in interface com.sun.source.tree. ForLoopTree

返回 for语句的条件。

getCondition() - Method in interface com.sun.source.tree. IfTree

返回if语句的条件。

getCondition() - Method in interface com.sun.source.tree. WhileLoopTree

返回循环的条件。

getCondition() - Method in interface jdk.nashorn.api.tree. CatchTree

返回可选的catch条件表达式。

getCondition() - Method in interface jdk.nashorn.api.tree. ConditionalExpressionTree

返回此三元表达式的条件表达式。

getCondition() - Method in interface jdk.nashorn.api.tree. ConditionalLoopTree

返回此“循环”语句的条件表达式。

getCondition() - Method in interface jdk.nashorn.api.tree. DoWhileLoopTree

返回此do-while语句的条件表达式。

getCondition() - Method in interface jdk.nashorn.api.tree. ForLoopTree

返回此'for'语句的条件表达式。

getCondition() - Method in interface jdk.nashorn.api.tree. IfTree

返回此'if'语句的条件表达式。

getCondition() - Method in interface jdk.nashorn.api.tree. WhileLoopTree

这个'while'语句的条件表达式。

getConditionForKeyStroke(KeyStroke) - Method in class javax.swing. JComponent

返回确定是否发生注册的操作以响应指定的击键的条件。

getConfiguration() - Method in class java.security. DomainLoadStoreParameter

获取域配置数据的标识符。

getConfiguration() - Static method in class javax.security.auth.login. Configuration

获取安装的登录配置。

getConfigurations() - Method in class java.awt. GraphicsDevice

返回与此 GraphicsDevice相关联的所有 GraphicsConfiguration对象。

getConfirmHandler() - Method in class javafx.scene.web. WebEngine

获取属性confirmHandler的值。

getConflictValue(int) - Method in interface javax.sql.rowset.spi. SyncResolver

检索此 SyncResolver对象的当前行中指定列中的值，该值是导致冲突的数据源中的值。

getConflictValue(String) - Method in interface javax.sql.rowset.spi. SyncResolver

检索此 SyncResolver对象的当前行中的指定列中的值，该值是导致冲突的数据源中的值。

getConfState() - Method in interface org.ietf.jgss. GSSContext

确定数据机密性是否可用于上下文。

getConnectControls() - Method in class javax.naming.ldap. InitialLdapContext

getConnectControls() - Method in interface javax.naming.ldap. LdapContext

检索此上下文的连接请求控件。

getConnection() - Method in interface java.sql. DatabaseMetaData

检索生成此元数据对象的连接。

getConnection() - Method in interface java.sql. Statement

检索 Connection生成此对象 Statement对象。

getConnection() - Method in interface javax.sql. DataSource

尝试建立与此 DataSource对象所代表的数据源的连接。

getConnection() - Method in interface javax.sql. PooledConnection

创建并返回一个 Connection对象，该对象是该 PooledConnection对象表示的物理连接的句柄。

getConnection() - Method in interface javax.sql. RowSetInternal

检索 Connection传递给该对象 RowSet对象。

getConnection(String) - Static method in class java.sql. DriverManager

尝试建立与给定数据库URL的连接。

getConnection(String, String) - Method in interface javax.sql. DataSource

尝试与此 DataSource对象所代表的数据源建立连接。

getConnection(String, String, String) - Static method in class java.sql. DriverManager

尝试建立与给定数据库URL的连接。

getConnection(String, Properties) - Static method in class java.sql. DriverManager

尝试建立与给定数据库URL的连接。

getConnectionId() - Method in class javax.management.remote. JMXConnectionNotification

此通知所属的连接ID。

getConnectionId() - Method in interface javax.management.remote. JMXConnector

从连接器服务器获取此连接的ID。

getConnectionId() - Method in interface javax.management.remote.rmi. RMIConnection

返回连接ID。

getConnectionId() - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getConnectionId() - Method in class javax.management.remote.rmi. RMIConnectionImpl

getConnectionId() - Method in class javax.management.remote.rmi. RMIConnector

getConnectionIds() - Method in class javax.management.remote. JMXConnectorServer

getConnectionIds() - Method in interface javax.management.remote. JMXConnectorServerMBean

此连接器服务器当前打开的连接的ID列表。

getConnectionState() - Method in interface com.sun.tools.jconsole. JConsoleContext

返回当前的连接状态。

getConnectTimeout() - Method in class java.net. URLConnection

返回连接超时的设置。

getConstantExpression(Object) - Method in interface javax.lang.model.util. Elements

返回表示原始值或字符串的 常量表达式的文本。

getConstantValue() - Method in interface javax.lang.model.element. VariableElement

如果这是一个初始化为编译 final数的 final字段，则返回此变量的值。

getConstraint(String) - Method in class javax.swing. SpringLayout.Constraints

返回指定边的值，该值可以是派生值，甚至是 null 。

getConstraint(String, Component) - Method in class javax.swing. SpringLayout

返回控制组件的指定边缘与其父级的顶部或左侧边缘之间的距离的弹簧。

getConstraints(Component) - Method in class java.awt. BorderLayout

获取指定组件的约束

getConstraints(Component) - Method in class java.awt. GridBagLayout

获取指定组件的约束。

getConstraints(Component) - Method in class javax.swing. SpringLayout

返回指定组件的约束。

getConstructor() - Method in interface jdk.nashorn.api.tree. ClassDeclarationTree

X- 20045 X- 200 X- 200 X- 200 200 X- 200 200 X-

getConstructor() - Method in interface jdk.nashorn.api.tree. ClassExpressionTree

X- 20045 X- 200 X- 200 X- 200 200 X- 200 200 X-

getConstructor(Class<?>...) - Method in class java.lang. Class

返回一个 Constructor对象，该对象反映由该 Class对象表示的类的指定公共构造函数。

getConstructor(String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

返回名称请求的ModelMBeanConstructorInfo。

getConstructorExpression() - Method in interface jdk.nashorn.api.tree. NewTree

返回此“new”表达式的构造函数表达式。

getConstructorMethod(Class<?>, String) - Static method in class jdk.dynalink.beans. BeansLinker

返回给定类的构造函数的动态方法和给定的签名。

getConstructors() - Method in class java.lang. Class

返回一个包含 Constructor对象的数组， Constructor对象反映由该 Class对象表示的类的所有公共构造函数。

getConstructors() - Method in class javax.management. MBeanInfo

返回MBean的公共构造函数的列表。

getConstructors() - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回MBean的公共构造函数的列表。

getConstructors() - Method in interface javax.management.openmbean. OpenMBeanInfo

返回的数组 OpenMBeanConstructorInfo实例描述在此描述的开放MBean中的每个构造 OpenMBeanInfo实例。

getConstructors(MBeanConstructorInfo[], Object) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanInfo中使用的MBeanConstructorInfo []。

getConsumeAutoHidingEvents() - Method in class javafx.stage. PopupWindow

获取属性consumeAutoHidingEvents的值。

getContainer() - Method in class java.awt.event. ContainerEvent

返回事件的发起者。

getContainer() - Method in interface java.beans.beancontext. BeanContextContainerProxy

获取 java.awt.Container与此 BeanContext相关联。

getContainer() - Method in class javax.swing.text. View

获取托管视图的容器。

getContainerAlignment() - Method in class javafx.scene.control.skin. MenuBarSkin

获取属性containerAlignment的值。

getContainerGap(JComponent, int, Container) - Method in class javax.swing. LayoutStyle

返回要放置在组件与其父项的指定边缘之间的空间量。

getContainerListeners() - Method in class java.awt. Container

返回在此容器上注册的所有容器侦听器的数组。

getContent() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索已签名的内容。

getContent() - Method in interface com.sun.source.doctree. UnknownBlockTagTree

返回无法识别的块标签的内容。

getContent() - Method in interface com.sun.source.doctree. UnknownInlineTagTree

返回无法识别的内联代码的内容。

getContent() - Method in class java.net. URL

获取此URL的内容。

getContent() - Method in class java.net. URLConnection

检索此URL连接的内容。

getContent() - Method in class javafx.embed.swing. SwingNode

返回附加到此 SwingNode的 JComponent实例。

getContent() - Method in class javafx.scene.control. CustomMenuItem

获取属性内容的值。

getContent() - Method in class javafx.scene.control. DialogPane

将对话框内容作为节点返回（即使使用DialogPane.setContentText(String)将其设置为字符串 - 这简单地转换为Node （最可能是Label ）。

getContent() - Method in class javafx.scene.control. ScrollPane

获取属性内容的值。

getContent() - Method in class javafx.scene.control. Tab

与标签相关的内容。

getContent() - Method in class javafx.scene.control. TextInputControl

返回文本输入的内容模型。

getContent() - Method in class javafx.scene.control. TitledPane

TitledPane的内容。

getContent() - Method in class javafx.scene.shape. SVGPath

获取属性内容的值。

getContent() - Method in class javafx.stage. Popup

Node的ObservableList将在此 Popup上呈现。

getContent() - Method in class javax.activation. DataHandler

以其首选对象形式返回数据。

getContent() - Method in class javax.naming. BinaryRefAddr

作为对象检索此地址的内容。

getContent() - Method in class javax.naming. RefAddr

检索此地址的内容。

getContent() - Method in class javax.naming. StringRefAddr

检索此地址的内容。

getContent() - Method in class javax.swing.text. AbstractDocument

获取文档的内容。

getContent() - Method in class javax.swing.text.html.parser. Element

获取内容模型

getContent() - Method in interface javax.xml.crypto.dsig.keyinfo. KeyInfo

返回包含密钥信息的 unmodifiable list 。

getContent() - Method in interface javax.xml.crypto.dsig.keyinfo. X509Data

返回这个 X509Data的内容中的 X509Data 。

getContent() - Method in interface javax.xml.crypto.dsig. SignatureProperty

返回此SignatureProperty中包含的一个或多个XMLStructure的SignatureProperty 。

getContent() - Method in interface javax.xml.crypto.dsig. XMLObject

返回此XMLObject中包含的XMLStructure的XMLObject ，它们代表任何命名空间的元素。

getContent() - Method in class javax.xml.soap. AttachmentPart

获取这个 AttachmentPart对象的内容作为Java对象。

getContent() - Method in class javax.xml.soap. SOAPPart

以JAXP Source对象的形式返回SOAPEnvelope的内容。

getContent() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的content属性定义。

getContent() - Method in interface org.w3c.dom.html. HTMLMetaElement

相关信息。

getContent(Class<?>[]) - Method in class java.net. URL

获取此URL的内容。

getContent(Class<?>[]) - Method in class java.net. URLConnection

检索此URL连接的内容。

getContent(URLConnection) - Method in class java.net. ContentHandler

给定位于对象表示开头的URL连接流，该方法读取该流并从中创建一个对象。

getContent(URLConnection, Class[]) - Method in class java.net. ContentHandler

给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。

getContent(DataFormat) - Method in class javafx.scene.input. Clipboard

返回给定类型的此剪贴板中存储的内容，如果没有此类型的内容，则返回null。

getContent(DataSource) - Method in interface javax.activation. DataContentHandler

以最优选的形式返回表示数据的对象。

getContentBias() - Method in class javafx.scene.control. Accordion

返回节点调整大小偏置的方向以进行布局。

getContentBias() - Method in class javafx.scene.control. Labeled

如果wrapText为true，则contentBias将为HORIZONTAL，否则为null。

getContentBias() - Method in class javafx.scene.control. TitledPane

getContentBias() - Method in class javafx.scene.layout. BorderPane

getContentBias() - Method in class javafx.scene.layout. FlowPane

getContentBias() - Method in class javafx.scene.layout. GridPane

getContentBias() - Method in class javafx.scene.layout. HBox

getContentBias() - Method in class javafx.scene.layout. StackPane

getContentBias() - Method in class javafx.scene.layout. TilePane

getContentBias() - Method in class javafx.scene.layout. VBox

getContentBias() - Method in class javafx.scene. Node

返回节点调整大小偏置的方向以进行布局。

getContentBias() - Method in class javafx.scene.text. TextFlow

getContentBorderInsets(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回内容边框插入。

getContentDescription() - Method in class javax.xml.soap. SOAPMessage

检索此 SOAPMessage对象内容的描述。

getContentDisplay() - Method in class javafx.scene.control. Labeled

获取属性contentDisplay的值。

getContentDisplay() - Method in class javafx.scene.control. Tooltip

获取属性contentDisplay的值。

getContentDocument() - Method in interface org.w3c.dom.html. HTMLFrameElement

这个框架包含的文件，如果有的话，它可用，否则为 null 。

getContentDocument() - Method in interface org.w3c.dom.html. HTMLIFrameElement

该框架包含的文件，如果有的话，它可用，否则为 null 。

getContentDocument() - Method in interface org.w3c.dom.html. HTMLObjectElement

这个对象包含的文档，如果有的话，可以使用，否则为 null 。

getContentEncoding() - Method in class java.net. URLConnection

返回 content-encoding头字段的值。

getContentHandler() - Method in class javax.xml.validation. ValidatorHandler

获取ContentHandler ，它接收到增强的验证结果。

getContentHandler() - Method in class org.xml.sax.helpers. ParserAdapter

返回当前内容处理程序。

getContentHandler() - Method in class org.xml.sax.helpers. XMLFilterImpl

获取内容事件处理程序。

getContentHandler() - Method in interface org.xml.sax. XMLReader

返回当前内容处理程序。

getContentId() - Method in class javax.xml.soap. AttachmentPart

获取名称为“Content-ID”的MIME标头的值。

getContentId() - Method in class javax.xml.soap. SOAPPart

检索名称为“Content-Id”的MIME标头的值。

getContentInput() - Method in class javafx.scene.effect. Lighting

获取属性contentInput的值。

getContentLength() - Method in class java.net. URLConnection

返回 content-length标题字段的值。

getContentLengthLong() - Method in class java.net. URLConnection

返回 content-length标题字段的值为long。

getContentLocation() - Method in class javax.xml.soap. AttachmentPart

获取名称为“Content-Location”的MIME标头的值。

getContentLocation() - Method in class javax.xml.soap. SOAPPart

检索名称为“Content-Location”的MIME标头的值。

getContentPane() - Method in class javax.swing. JApplet

已过时。

返回此applet的contentPane对象。

getContentPane() - Method in class javax.swing. JDialog

返回此对话框的 contentPane对象。

getContentPane() - Method in class javax.swing. JFrame

返回此帧的 contentPane对象。

getContentPane() - Method in class javax.swing. JInternalFrame

返回此内部框架的内容窗格。

getContentPane() - Method in class javax.swing. JRootPane

返回内容窗格 - 保存由根窗格父化的组件的容器。

getContentPane() - Method in class javax.swing. JWindow

返回 Container ，这是该窗口的 contentPane 。

getContentPane() - Method in interface javax.swing. RootPaneContainer

返回contentPane。

getContents() - Method in class java.util. ListResourceBundle

返回一个数组，其中每个项目是 Object数组中的一对对象。

getContents() - Method in class javax.accessibility. AccessibleResourceBundle

已过时。

返回编程键和本地化显示字符串之间的映射。

getContents() - Method in interface javax.jnlp. ClipboardService

返回表示剪贴板当前内容的 Transferable对象。

getContents(Object) - Method in class java.awt.datatransfer. Clipboard

返回表示剪贴板当前内容的可转移对象。

getContentText() - Method in class javafx.scene.control. Dialog

返回此DialogPane的当前设置的内容文本。

getContentText() - Method in class javafx.scene.control. DialogPane

返回此DialogPane的当前设置的内容文本。

getContentType() - Method in class java.net. URLConnection

返回 content-type标题字段的值。

getContentType() - Method in class javax.activation. DataHandler

返回从源对象检索的此对象的MIME类型。

getContentType() - Method in interface javax.activation. DataSource

此方法以字符串的形式返回数据的MIME类型。

getContentType() - Method in class javax.activation. FileDataSource

此方法以字符串的形式返回数据的MIME类型。

getContentType() - Method in class javax.activation. URLDataSource

返回URL内容类型头字段的值。

getContentType() - Method in class javax.swing. JEditorPane

获取此编辑器当前设置处理的内容类型。

getContentType() - Method in class javax.swing.text. DefaultEditorKit

获取此套件代表支持的数据的MIME类型。

getContentType() - Method in class javax.swing.text. EditorKit

获取此套件代表支持的数据的MIME类型。

getContentType() - Method in class javax.swing.text.html. HTMLEditorKit

获取此套件代表支持的数据的MIME类型。

getContentType() - Method in class javax.swing.text.rtf. RTFEditorKit

获取此套件代表支持的数据的MIME类型。

getContentType() - Method in class javax.xml.soap. AttachmentPart

获取名称为“Content-Type”的MIME标头的值。

getContentType(File) - Method in class javax.activation. FileTypeMap

返回文件对象的类型。

getContentType(File) - Method in class javax.activation. MimetypesFileTypeMap

返回文件对象的MIME类型。

getContentType(String) - Method in class javax.activation. FileTypeMap

返回传入的文件的类型。

getContentType(String) - Method in class javax.activation. MimetypesFileTypeMap

根据指定的文件名返回MIME类型。

getContentTypeFor(String) - Method in interface java.net. FileNameMap

获取指定文件名的MIME类型。

getContentTypes() - Method in class javafx.scene.input. Clipboard

获取此剪贴板实例上具有已在剪贴板上注册的关联数据的DataFormat类型集。

getContext() - Method in class com.sun.tools.jconsole. JConsolePlugin

返回表示与应用程序的连接的JConsoleContext对象。

getContext() - Static method in class java.security. AccessController

此方法将获取当前调用上下文的“快照”，其中包括当前Thread的继承的AccessControlContext和任何有限权限范围，并将其放置在AccessControlContext对象中。

getContext() - Method in class javax.script. AbstractScriptEngine

返回受保护的 context字段的值。

getContext() - Method in interface javax.script. ScriptEngine

返回默认 ScriptContext的的 ScriptEngine的Bindings，Reader和Writer被用于脚本执行时没有 ScriptContext指定。

getContext() - Method in interface javax.xml.ws. Response

获取包含的响应上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthColorChooserUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthComboBoxUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthDesktopIconUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthEditorPaneUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthInternalFrameUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthLabelUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthListUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthMenuBarUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthMenuItemUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthMenuUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthOptionPaneUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthPanelUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthPopupMenuUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthProgressBarUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthRootPaneUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthScrollBarUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthSliderUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthSpinnerUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthSplitPaneUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthTableHeaderUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthTableUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthTextAreaUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthTextFieldUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthToolBarUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthTreeUI

返回指定组件的上下文。

getContext(JComponent) - Method in interface javax.swing.plaf.synth. SynthUI

返回指定组件的上下文。

getContext(JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI

返回指定组件的上下文。

getContextClassLoader() - Method in class java.lang. Thread

返回此线程的上下文 ClassLoader 。

getContextMenu() - Method in class javafx.scene.control. Control

获取属性contextMenu的值。

getContextMenu() - Method in class javafx.scene.control. Tab

与选项卡关联的上下文菜单。

getContextMenu() - Method in class javafx.scene.control. TableColumnBase

获取属性contextMenu的值。

getContextPath() - Method in class javax.xml.ws.spi.http. HttpExchange

返回应用程序中所有端点的上下文路径。

getContextualShaper(int) - Static method in class java.awt.font. NumericShaper

返回提供的unicode范围的上下文整形器。

getContextualShaper(int, int) - Static method in class java.awt.font. NumericShaper

返回提供的unicode范围的上下文整形器。

getContextualShaper(Set<NumericShaper.Range>) - Static method in class java.awt.font. NumericShaper

返回提供的Unicode范围的上下文整形器。

getContextualShaper(Set<NumericShaper.Range>, NumericShaper.Range) - Static method in class java.awt.font. NumericShaper

返回提供的Unicode范围的上下文整形器。

getContinuationContext(CannotProceedException) - Static method in class javax.naming.spi. NamingManager

创建一个上下文来继续上下文操作。

getContinuationDirContext(CannotProceedException) - Static method in class javax.naming.spi. DirectoryManager

创建一个上下文，继续操作 DirContext 。

getContinueExistingPeriodicTasksAfterShutdownPolicy() - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

获取关于是否继续执行现有周期性任务的策略，即使该执行者已经是 shutdown 。

getContrast() - Method in class javafx.scene.effect. ColorAdjust

获取属性对比的值。

getControl() - Method in class javafx.scene.control. TextFormatter.Change

获取与此更改相关联的控件。

getControl() - Method in class javafx.scene.input. KeyCombination

control键的状态在这个组合键上。

getControl() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件颜色。

getControl() - Method in class javax.swing.plaf.metal. MetalTheme

返回控件颜色。

getControl(String) - Method in interface java.util.spi. ResourceBundleControlProvider

返回一个 ResourceBundle.Control实例，用于处理给定的 baseName资源束加载。

getControl(List<String>) - Static method in class java.util. ResourceBundle.Control

返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats 。

getControl(Control.Type) - Method in interface javax.sound.sampled. Line

获取指定类型的控件，如果有的话。

getControlAnchor() - Method in class javafx.scene.control. TextFormatter.Change

获取控件的当前锚定位置。

getControlButtonsAreShown() - Method in class javax.swing. JFileChooser

返回 controlButtonsAreShown属性的值。

getControlCaretPosition() - Method in class javafx.scene.control. TextFormatter.Change

获取控件的当前插入位置。

getControlCssMetaData() - Method in class javafx.scene.control. Control

getControlCssMetaData() - Method in class javafx.scene.control. DatePicker

getControlCssMetaData() - Method in class javafx.scene.control. Labeled

getControlCssMetaData() - Method in class javafx.scene.control. ListView

getControlCssMetaData() - Method in class javafx.scene.control. MenuBar

getControlCssMetaData() - Method in class javafx.scene.control. Pagination

getControlCssMetaData() - Method in class javafx.scene.control. ScrollBar

getControlCssMetaData() - Method in class javafx.scene.control. ScrollPane

getControlCssMetaData() - Method in class javafx.scene.control. Separator

getControlCssMetaData() - Method in class javafx.scene.control. Slider

getControlCssMetaData() - Method in class javafx.scene.control. SplitPane

getControlCssMetaData() - Method in class javafx.scene.control. TableView

getControlCssMetaData() - Method in class javafx.scene.control. TabPane

getControlCssMetaData() - Method in class javafx.scene.control. TextArea

getControlCssMetaData() - Method in class javafx.scene.control. TextField

getControlCssMetaData() - Method in class javafx.scene.control. TextInputControl

getControlCssMetaData() - Method in class javafx.scene.control. TitledPane

getControlCssMetaData() - Method in class javafx.scene.control. ToolBar

getControlCssMetaData() - Method in class javafx.scene.control. TreeTableView

getControlCssMetaData() - Method in class javafx.scene.control. TreeView

getControlDarkShadow() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件阴影颜色。

getControlDarkShadow() - Method in class javax.swing.plaf.metal. MetalTheme

返回控制暗影色。

getControlDisabled() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件禁用颜色。

getControlDisabled() - Method in class javax.swing.plaf.metal. MetalTheme

返回禁用的控件颜色。

getControlFlag() - Method in class javax.security.auth.login. AppConfigurationEntry

返回controlFlag（或者REQUIRED，REQUISITE，足够了，或可选）此 LoginModule 。

getControlHighlight() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件突出显示颜色。

getControlHighlight() - Method in class javax.swing.plaf.metal. MetalTheme

返回控件高亮颜色。

getControlInfo() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件信息颜色。

getControlInfo() - Method in class javax.swing.plaf.metal. MetalTheme

返回控制信息颜色。

getControlInstance(Control) - Method in class javax.naming.ldap. ControlFactory

使用该控制工厂创建控制。

getControlInstance(Control, Context, Hashtable<?, ?>) - Static method in class javax.naming.ldap. ControlFactory

使用已知的控制工厂创建控制。

getController() - Method in class javafx.fxml. FXMLLoader

返回与根对象关联的控制器。

getController() - Method in class javax.imageio. IIOParam

返回当前安装的 IIOParamController 。

getController() - Method in class javax.imageio.metadata. IIOMetadata

返回当前安装的 IIOMetadataController 。

getController(int) - Method in interface javax.sound.midi. MidiChannel

获取指定控制器的当前值。

getControllerFactory() - Method in class javafx.fxml. FXMLLoader

返回此装载器使用的控制器工厂。

getControlNewText() - Method in class javafx.scene.control. TextFormatter.Change

获取完整的新文本，将在此更改后用于控件。

getControlObject() - Method in interface java.awt.im.spi. InputMethod

从此输入法返回一个控件对象，或者返回null。

getControls() - Method in interface javax.naming.ldap. HasControls

从实现此接口的对象检索 Control的数组。

getControls() - Method in interface javax.sound.sampled. Line

获取与此行相关联的一组控件。

getControlShadow() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件阴影颜色。

getControlShadow() - Method in class javax.swing.plaf.metal. MetalTheme

返回控制阴影颜色。

getControlSize() - Method in class javax.swing.plaf.metal. MetalCheckBoxIcon

返回控件的大小。

getControlText() - Method in class javafx.scene.control. TextFormatter.Change

这是控制在更改之前的全文。

getControlTextColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件文本颜色。

getControlTextColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回控件文本颜色。

getControlTextColor() - Method in class javax.swing.plaf.metal. OceanTheme

返回控件文本颜色。

getControlTextFont() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回控件文本字体。

getControlTextFont() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的控件文本字体。

getControlTextFont() - Method in class javax.swing.plaf.metal. MetalTheme

返回控件文本字体。

getControlX() - Method in class javafx.scene.shape. QuadCurve

获取属性controlX的值。

getControlX() - Method in class javafx.scene.shape. QuadCurveTo

获取属性controlX的值。

getControlX1() - Method in class javafx.scene.shape. CubicCurve

获取属性controlX1的值。

getControlX1() - Method in class javafx.scene.shape. CubicCurveTo

获取属性controlX1的值。

getControlX2() - Method in class javafx.scene.shape. CubicCurve

获取属性controlX2的值。

getControlX2() - Method in class javafx.scene.shape. CubicCurveTo

获取属性controlX2的值。

getControlY() - Method in class javafx.scene.shape. QuadCurve

获取属性controlY的值。

getControlY() - Method in class javafx.scene.shape. QuadCurveTo

获取属性controlY的值。

getControlY1() - Method in class javafx.scene.shape. CubicCurve

获取属性controlY1的值。

getControlY1() - Method in class javafx.scene.shape. CubicCurveTo

获取属性controlY1的值。

getControlY2() - Method in class javafx.scene.shape. CubicCurve

获取属性controlY2的值。

getControlY2() - Method in class javafx.scene.shape. CubicCurveTo

获取属性controlY2的值。

getConversion() - Method in exception java.util. FormatFlagsConversionMismatchException

返回不兼容的转换。

getConversion() - Method in exception java.util. IllegalFormatConversionException

返回不适用的转换。

getConversion() - Method in exception java.util. UnknownFormatConversionException

返回未知的转换。

getConverter() - Method in class javafx.css. CssMetaData

getConverter() - Method in class javafx.css. ParsedValue

甲StyleConverter转换分析得到的值到的类型StyleableProperty 。

getConverter() - Method in class javafx.scene.control.cell. CheckBoxListCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. CheckBoxTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. CheckBoxTreeCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. CheckBoxTreeTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ChoiceBoxListCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ChoiceBoxTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ChoiceBoxTreeCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ComboBoxListCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ComboBoxTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ComboBoxTreeCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. TextFieldListCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. TextFieldTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. TextFieldTreeCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control.cell. TextFieldTreeTableCell

返回此单元格中使用的StringConverter 。

getConverter() - Method in class javafx.scene.control. ChoiceBox

获取属性转换器的值。

getConverter() - Method in class javafx.scene.control. ComboBox

获取属性转换器的值。

getConverter() - Method in class javafx.scene.control. DatePicker

获取属性转换器的值。

getConverter() - Method in class javafx.scene.control.skin. ColorPickerSkin

子类负责获取转换器。

getConverter() - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

子类负责获取转换器。

getConverter() - Method in class javafx.scene.control.skin. ComboBoxPopupControl

子类负责获取转换器。

getConverter() - Method in class javafx.scene.control.skin. DatePickerSkin

子类负责获取转换器。

getConverter() - Method in class javafx.scene.control. SpinnerValueFactory

获取属性转换器的值。

getCookie() - Method in class javax.naming.ldap. PagedResultsResponseControl

检索服务器生成的cookie。

getCookie() - Method in interface org.w3c.dom.html. HTMLDocument

与此文档相关联的Cookie。

getCookies() - Method in interface java.net. CookieStore

在Cookie商店中获取所有未过期的Cookie。

getCookieStore() - Method in class java.net. CookieManager

检索当前cookie存储。

getCoords() - Method in interface org.w3c.dom.html. HTMLAnchorElement

逗号分隔的长度列表，定义活动区域几何。

getCoords() - Method in interface org.w3c.dom.html. HTMLAreaElement

逗号分隔的长度列表，定义活动区域几何。

getCopies() - Method in class java.awt. JobAttributes

返回应用程序应使用这些属性为作业呈现的副本数。

getCopies() - Method in class java.awt.print. PrinterJob

获取要打印的份数。

getCopies() - Method in class javafx.print. JobSettings

获取要打印的份数。

getCopyAction() - Static method in class javax.swing. TransferHandler

返回执行复制操作到剪贴板的 Action 。

getCorePoolSize() - Method in class java.util.concurrent. ThreadPoolExecutor

返回核心线程数。

getCorner(String) - Method in class javax.swing. JScrollPane

返回指定角落的组件。

getCorner(String) - Method in class javax.swing. ScrollPaneLayout

返回指定角落处的 Component 。

getCount() - Method in interface java.lang.management. BufferPoolMXBean

返回池中缓冲区数量的估计值。

getCount() - Method in class java.lang.management. MemoryNotificationInfo

返回构建通知时内存使用量超过阈值的次数。

getCount() - Method in class java.util.concurrent. CountDownLatch

返回当前计数。

getCount() - Method in class java.util. DoubleSummaryStatistics

返回记录的值的计数。

getCount() - Method in class java.util. IntSummaryStatistics

返回记录的值的计数。

getCount() - Method in class java.util. LongSummaryStatistics

返回记录的值的计数。

getCount() - Method in class javax.imageio.plugins.tiff. TIFFField

返回字段中存在的数据项数。

getCount() - Method in class javax.imageio.plugins.tiff. TIFFTag

返回此标签的值计数。

getCounterIncrement() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的counter-increment属性定义。

getCounterReset() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的counter-reset属性定义。

getCounterValue() - Method in interface org.w3c.dom.css. CSSPrimitiveValue

该方法用于获取计数器值。

getCountLimit() - Method in class javax.naming.directory. SearchControls

检索由搜索结果返回的最大条目数。

getCountry() - Method in class java.util. Locale

返回此区域设置的国家/地区代码，该代码应为空字符串，大写ISO 3166 2字母代码或UN M.49 3位代码。

getCrc() - Method in class java.util.zip. ZipEntry

返回未压缩条目数据的CRC-32校验和。

getCreatePopupHandler() - Method in class javafx.scene.web. WebEngine

获取属性createPopupHandler的值。

getCreateSymbols() - Method in class javafx.scene.chart. AreaChart

指示是否创建数据点的符号。

getCreateSymbols() - Method in class javafx.scene.chart. LineChart

指示是否创建数据点的符号。

getCreateSymbols() - Method in class javafx.scene.chart. StackedAreaChart

指示是否创建数据点的符号。

getCreationDate(String) - Method in class java.security. KeyStore

返回由给定别名标识的条目的创建日期。

getCreationTime() - Method in class java.util.zip. ZipEntry

返回条目的创建时间。

getCreationTime() - Method in interface javax.net.ssl. SSLSession

返回此会话表示形式创建的时间，以1970年1月1日UTC为午夜的毫秒计。

getCredDelegState() - Method in interface org.ietf.jgss. GSSContext

确定在此上下文中是否启用凭据委派。

getCredentialClass() - Method in class javax.security.auth. PrivateCredentialPermission

返回与此 PrivateCredentialPermission相关联的凭据的类名。

getCriticalExtensionOIDs() - Method in interface java.security.cert. X509Extension

获取由实现此接口的对象管理的证书/ CRL中标记为“CRITICAL”的扩展名的OID字符串集。

getCRLs(CRLSelector) - Method in class java.security.cert. CertStore

返回匹配指定选择器的 Collection的 CRL 。

getCrossFeedResolution() - Method in class javafx.print. PrintResolution

以dpi返回分辨率。 穿过送纸方向。

getCrossFeedResolution(int) - Method in class javax.print.attribute. ResolutionSyntax

以给定单位返回此分辨率属性的交叉进给方向分辨率。

getCrossFeedResolutionDphi() - Method in class javax.print.attribute. ResolutionSyntax

以dphi为单位返回此分辨率属性的交叉进给方向分辨率。

getCrossPlatformLookAndFeelClassName() - Static method in class javax.swing. UIManager

返回实现默认跨平台外观的 LookAndFeel类的名称--Java Look and Feel（JLF）。

getCrossReference(String, String, String, String, String, String) - Method in interface java.sql. DatabaseMetaData

检索引用主键的给定外键表中的外键列的描述，或表示父表的唯一约束的列（可以是相同或不同的表）。

getCrtCoefficient() - Method in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

返回crtCoefficient。

getCrtCoefficient() - Method in interface java.security.interfaces. RSAPrivateCrtKey

返回crtCoefficient。

getCrtCoefficient() - Method in class java.security.spec. RSAMultiPrimePrivateCrtKeySpec

返回crtCoefficient。

getCrtCoefficient() - Method in class java.security.spec. RSAOtherPrimeInfo

返回素数的crtCoefficient。

getCrtCoefficient() - Method in class java.security.spec. RSAPrivateCrtKeySpec

返回crtCoefficient。

getCssFloat() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的float属性定义。

getCssMetaData() - Method in class javafx.css. SimpleStyleableBooleanProperty

反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in class javafx.css. SimpleStyleableDoubleProperty

反映对应于这个 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in class javafx.css. SimpleStyleableFloatProperty

反映了对应于这个 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in class javafx.css. SimpleStyleableIntegerProperty

反映了对应于这个 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in class javafx.css. SimpleStyleableLongProperty

反映了对应于这个 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in class javafx.css. SimpleStyleableObjectProperty

反映了对应于这个 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in class javafx.css. SimpleStyleableStringProperty

反映对应于这个 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in interface javafx.css. Styleable

这个样式的CssMetaData。

getCssMetaData() - Method in interface javafx.css. StyleableProperty

反映对应于这个 javafx.beans.property.StyleableProperty

getCssMetaData() - Method in class javafx.css. StyleablePropertyFactory

获取给定Styleable的CssMetaData。

getCssMetaData() - Method in class javafx.scene.chart. AreaChart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. Axis

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. BarChart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. CategoryAxis

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. Chart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. LineChart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. NumberAxis

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. PieChart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. StackedAreaChart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. StackedBarChart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. ValueAxis

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.chart. XYChart

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control. Control

此方法返回一个List，其中包含所有CssMetaData（用于此控件）（从Control.getControlCssMetaData()返回）及其Skin ，假设skin property为SkinBase 。

getCssMetaData() - Method in class javafx.scene.control. DialogPane

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control. MenuItem

getCssMetaData() - Method in class javafx.scene.control. PopupControl.CSSBridge

getCssMetaData() - Method in class javafx.scene.control. PopupControl

这个样式的CssMetaData。

getCssMetaData() - Method in class javafx.scene.control.skin. CellSkinBase

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. ColorPickerSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. MenuBarSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. PaginationSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. ProgressBarSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. ProgressIndicatorSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. TableColumnHeader

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. TabPaneSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. TextInputControlSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. ToolBarSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. TreeCellSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control.skin. TreeTableRowSkin

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control. SkinBase

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.control. Tab

这个样式的CssMetaData。

getCssMetaData() - Method in class javafx.scene.control. TableColumn

这个样式的CssMetaData。

getCssMetaData() - Method in class javafx.scene.control. Tooltip

这个样式的CssMetaData。

getCssMetaData() - Method in class javafx.scene.control. TreeTableColumn

这个样式的CssMetaData。

getCssMetaData() - Method in class javafx.scene.image. ImageView

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.layout. FlowPane

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.layout. GridPane

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.layout. HBox

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.layout. Region

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.layout. StackPane

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.layout. TilePane

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.layout. VBox

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene. Node

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.shape. Rectangle

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.shape. Shape

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.text. Text

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

getCssMetaData() - Method in class javafx.scene.text. TextFlow

getCssMetaData() - Method in class javafx.scene.web. WebView

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

getCssRules() - Method in interface org.w3c.dom.css. CSSMediaRule

媒体块中包含的所有CSS规则的列表。

getCssRules() - Method in interface org.w3c.dom.css. CSSStyleSheet

所有CSS规则的列表包含在样式表中。

getCssText() - Method in interface org.w3c.dom.css. CSSRule

规则的可理解的文本表示。

getCssText() - Method in interface org.w3c.dom.css. CSSStyleDeclaration

声明块的可解释文本表示（不包括周围的花括号）。

getCssText() - Method in interface org.w3c.dom.css. CSSValue

当前值的字符串表示形式。

getCssValueType() - Method in interface org.w3c.dom.css. CSSValue

定义上面定义的值的类型的代码。

getCtrlKey() - Method in interface org.w3c.dom.events. MouseEvent

用于指示在触发事件期间是否按下“ctrl”键。

getCtrlP1() - Method in class java.awt.geom. CubicCurve2D.Double

返回第一个控制点。

getCtrlP1() - Method in class java.awt.geom. CubicCurve2D.Float

返回第一个控制点。

getCtrlP1() - Method in class java.awt.geom. CubicCurve2D

返回第一个控制点。

getCtrlP2() - Method in class java.awt.geom. CubicCurve2D.Double

返回第二个控制点。

getCtrlP2() - Method in class java.awt.geom. CubicCurve2D.Float

返回第二个控制点。

getCtrlP2() - Method in class java.awt.geom. CubicCurve2D

返回第二个控制点。

getCtrlPt() - Method in class java.awt.geom. QuadCurve2D.Double

返回控制点。

getCtrlPt() - Method in class java.awt.geom. QuadCurve2D.Float

返回控制点。

getCtrlPt() - Method in class java.awt.geom. QuadCurve2D

返回控制点。

getCtrlX() - Method in class java.awt.geom. QuadCurve2D.Double

以 double精度返回控制点的X坐标。

getCtrlX() - Method in class java.awt.geom. QuadCurve2D.Float

以 double精度返回控制点的X坐标。

getCtrlX() - Method in class java.awt.geom. QuadCurve2D

以 double精度返回控制点的X坐标。

getCtrlX1() - Method in class java.awt.geom. CubicCurve2D.Double

以双精度返回第一个控制点的X坐标。

getCtrlX1() - Method in class java.awt.geom. CubicCurve2D.Float

以双精度返回第一个控制点的X坐标。

getCtrlX1() - Method in class java.awt.geom. CubicCurve2D

以双精度返回第一个控制点的X坐标。

getCtrlX2() - Method in class java.awt.geom. CubicCurve2D.Double

以双精度返回第二个控制点的X坐标。

getCtrlX2() - Method in class java.awt.geom. CubicCurve2D.Float

以双精度返回第二个控制点的X坐标。

getCtrlX2() - Method in class java.awt.geom. CubicCurve2D

以双精度返回第二个控制点的X坐标。

getCtrlY() - Method in class java.awt.geom. QuadCurve2D.Double

以 double精度返回控制点的Y坐标。

getCtrlY() - Method in class java.awt.geom. QuadCurve2D.Float

以 double精度返回控制点的Y坐标。

getCtrlY() - Method in class java.awt.geom. QuadCurve2D

以 double精度返回控制点的Y坐标。

getCtrlY1() - Method in class java.awt.geom. CubicCurve2D.Double

以双精度返回第一个控制点的Y坐标。

getCtrlY1() - Method in class java.awt.geom. CubicCurve2D.Float

以双精度返回第一个控制点的Y坐标。

getCtrlY1() - Method in class java.awt.geom. CubicCurve2D

以双精度返回第一个控制点的Y坐标。

getCtrlY2() - Method in class java.awt.geom. CubicCurve2D.Double

以双精度返回第二个控制点的Y坐标。

getCtrlY2() - Method in class java.awt.geom. CubicCurve2D.Float

以双精度返回第二个控制点的Y坐标。

getCtrlY2() - Method in class java.awt.geom. CubicCurve2D

以双精度返回第二个控制点的Y坐标。

getCue() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cue属性定义。

getCueAfter() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cue-after属性定义。

getCueBefore() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cue-before属性定义。

getCuePoints() - Method in class javafx.animation. Animation

提示点可用于标记 Animation重要位置。

getCullFace() - Method in class javafx.scene.shape. Shape3D

获取属性cullFace的值。

getCumulativePeriod() - Method in class javafx.concurrent. ScheduledService

获取属性cumulativePeriod的值。

getCurrency() - Method in class java.text. DecimalFormat

在格式化货币值时获取此十进制格式使用的货币。

getCurrency() - Method in class java.text. DecimalFormatSymbols

获取这些DecimalFormatSymbols的货币。

getCurrency() - Method in class java.text. NumberFormat

在格式化货币值时，获取此数字格式使用的货币。

getCurrencyCode() - Method in class java.util. Currency

获得此货币的ISO 4217货币代码。

getCurrencyInstance() - Static method in class java.text. NumberFormat

返回当前默认值 FORMAT区域设置的货币格式。

getCurrencyInstance(Locale) - Static method in class java.text. NumberFormat

返回指定区域设置的货币格式。

getCurrencyInstance(Locale) - Method in class java.text.spi. NumberFormatProvider

返回一个新的 NumberFormat实例，它为指定的区域设置格式化货币值。

getCurrencySymbol() - Method in class java.text. DecimalFormatSymbols

返回其区域设置中这些DecimalFormatSymbols的货币的货币符号。

getCurrent() - Method in class java.awt. CheckboxGroup

已过时。
从JDK 1.1版开始，由getSelectedCheckbox()取代。

getCurrentAccessibleContext() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取表单元格渲染器的AccessibleContext。

getCurrentAccessibleValue() - Method in class java.awt. Button.AccessibleAWTButton

将该对象的值作为数字获取。

getCurrentAccessibleValue() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

将该对象的值作为数字获取。

getCurrentAccessibleValue() - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

将该对象的值作为数字获取。

getCurrentAccessibleValue() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

将该对象的值作为数字获取。

getCurrentAccessibleValue() - Method in class java.awt. Scrollbar.AccessibleAWTScrollBar

获取此对象的可访问值。

getCurrentAccessibleValue() - Method in interface javax.accessibility. AccessibleValue

以 Number获取该对象的值。

getCurrentAccessibleValue() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

将该对象的值作为数字获取。

getCurrentAccessibleValue() - Method in class javax.swing. JInternalFrame.AccessibleJInternalFrame

将该对象的值作为数字获取。

getCurrentAccessibleValue() - Method in class javax.swing. JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

以 Number获取此对象的值。

getCurrentAccessibleValue() - Method in class javax.swing. JProgressBar.AccessibleJProgressBar

获取此对象的可访问值。

getCurrentAccessibleValue() - Method in class javax.swing. JScrollBar.AccessibleJScrollBar

获取此对象的可访问值。

getCurrentAccessibleValue() - Method in class javax.swing. JSlider.AccessibleJSlider

获取此对象的可访问值。

getCurrentAccessibleValue() - Method in class javax.swing. JSpinner.AccessibleJSpinner

将该对象的值作为数字获取。

getCurrentAccessibleValue() - Method in class javax.swing. JSplitPane.AccessibleJSplitPane

获取此对象的可访问值。

getCurrentComponent() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取表单元格渲染器组件。

getCurrentCount() - Method in class javafx.scene.media. MediaPlayer

检索当前周期的索引。

getCurrentDataFlavors() - Method in class java.awt.dnd. DropTargetContext

获取此操作的 Transferable操作数的可用DataFlavors。

getCurrentDataFlavors() - Method in class java.awt.dnd. DropTargetDragEvent

该方法返回当前 DataFlavor从S DropTargetContext 。

getCurrentDataFlavors() - Method in class java.awt.dnd. DropTargetDropEvent

此方法返回当前DataFlavors。

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd. DropTargetContext

该方法将 Transferable操作数的当前可用DataFlavors返回为 java.util.List 。

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd. DropTargetDragEvent

此方法返回当前的 DataFlavor作为 java.util.List

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd. DropTargetDropEvent

此方法返回当前可用的 DataFlavor作为 java.util.List 。

getCurrentDirectory() - Method in class javax.swing. JFileChooser

返回当前目录。

getCurrentDisplayedExtraValue(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart

当前显示的数据额外值。

getCurrentDisplayedXValue(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart

当前显示的数据值绘制在X轴上。

getCurrentDisplayedYValue(XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart

当前显示的数据值绘制在Y轴上。

getCurrentEvent() - Static method in class java.awt. EventQueue

返回与调用线程相关联的 EventQueue当前调度的事件。

getCurrentFailureCount() - Method in class javafx.concurrent. ScheduledService

获取属性currentFailureCount的值。

getCurrentFocusCycleRoot() - Method in class java.awt. KeyboardFocusManager

如果当前焦点循环根与调用线程处于相同的上下文中，则返回当前焦点循环根。

getCurrentIndex() - Method in class javafx.scene.web. WebHistory

获取属性currentIndex的值。

getCurrentKeyboardFocusManager() - Static method in class java.awt. KeyboardFocusManager

返回调用线程上下文的当前KeyboardFocusManager实例。

getCurrentLine() - Method in class javax.swing.text.html.parser. Parser

getCurrentLineLength() - Method in class javax.swing.text. AbstractWriter

返回当前行长度。

getCurrentManager() - Static method in class javax.swing. FocusManager

返回调用线程上下文的当前 KeyboardFocusManager实例。

getCurrentMousePosition() - Static method in class com.sun.java.accessibility.util. EventQueueMonitor

将鼠标的最后记录位置返回到屏幕坐标。

getCurrentNode() - Method in interface org.w3c.dom.traversal. TreeWalker

TreeWalker当前位于的节点。

getCurrentPageIndex() - Method in class javafx.scene.control. Pagination

返回当前页面索引。

getCurrentPath() - Method in class com.sun.source.util. DocTreePathScanner

返回由当前激活的一组扫描调用构建的节点的当前路径。

getCurrentPath() - Method in class com.sun.source.util. TreePathScanner

返回由当前激活的一组扫描调用构建的节点的当前路径。

getCurrentPoint() - Method in class java.awt.geom. Path2D

将最近添加到路径末尾的坐标作为Point2D对象返回。

getCurrentPos() - Method in class javax.swing.text.html.parser. Parser

返回当前位置。

getCurrentRate() - Method in class javafx.animation. Animation

获取属性currentRate的值。

getCurrentRate() - Method in class javafx.scene.media. MediaPlayer

检索当前播放速率。

getCurrentServiceClasses() - Method in interface java.beans.beancontext. BeanContextServices

获取此上下文的当前可用服务。

getCurrentServiceClasses() - Method in class java.beans.beancontext. BeanContextServicesSupport

getCurrentServiceSelectors() - Method in class java.beans.beancontext. BeanContextServiceAvailableEvent

获取服务依赖选择器的列表。

getCurrentServiceSelectors(BeanContextServices, Class<?>) - Method in interface java.beans.beancontext. BeanContextServiceProvider

该方法由 BeanContextServices调用，获取指定服务的当前服务选择器。

getCurrentServiceSelectors(BeanContextServices, Class<?>) - Method in class java.beans.beancontext. BeanContextServicesSupport.BCSSProxyServiceProvider

getCurrentServiceSelectors(Class<?>) - Method in interface java.beans.beancontext. BeanContextServices

通过调用底层BeanContextServiceProvider上的getCurrentServiceSelectors（），获取指定服务的服务相关服务参数（服务选择器）列表。

getCurrentServiceSelectors(Class<?>) - Method in class java.beans.beancontext. BeanContextServicesSupport

getCurrentTarget() - Method in interface org.w3c.dom.events. Event

用于指示 EventTarget ，其 EventListeners ，目前正在处理。

getCurrentTheme() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回 MetalLookAndFeel当前正在使用的主题。

getCurrentThreadCpuTime() - Method in interface java.lang.management. ThreadMXBean

以纳秒为单位返回当前线程的总CPU时间。

getCurrentThreadUserTime() - Method in interface java.lang.management. ThreadMXBean

返回当前线程以纳秒为单位在用户模式下执行的CPU时间。

getCurrentTime() - Method in class javafx.animation. Animation

获取属性currentTime的值。

getCurrentTime() - Method in class javafx.scene.media. MediaPlayer

检索当前媒体时间。

getCurrentWriter() - Method in class javax.swing.text. AbstractDocument

获取当前的书写线程，如果有的话。

getCursor() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的 Cursor 。

getCursor() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的 Cursor 。

getCursor() - Method in class java.awt. Component

获取组件中的光标集。

getCursor() - Method in class java.awt.dnd. DragSourceContext

返回当前自定义拖动 Cursor 。

getCursor() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的Cursor。

getCursor() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的 Cursor 。

getCursor() - Method in class javafx.scene. Node

获取属性游标的值。

getCursor() - Method in class javafx.scene. Scene

获取属性游标的值。

getCursor() - Method in interface javax.accessibility. AccessibleComponent

获取此对象的光标。

getCursor() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getCursor() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的 Cursor 。

getCursor() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

getCursor() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getCursor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cursor属性定义。

getCursorName() - Method in interface java.sql. ResultSet

检索此 ResultSet对象使用的SQL游标的名称。

getCursorType() - Method in class java.awt. Frame

已过时。
从JDK 1.1版开始，由Component.getCursor()替代。

getCurve() - Method in class java.security.spec. ECParameterSpec

返回此参数定义的椭圆曲线。

getCustomColors() - Method in class javafx.scene.control. ColorPicker

获取用户添加到调色板的自定义颜色列表。

getCustomEditor() - Method in interface java.beans. PropertyEditor

PropertyEditor可以选择提供编辑其属性值的完整自定义组件。

getCustomEditor() - Method in class java.beans. PropertyEditorSupport

PropertyEditor可以选择提供编辑其属性值的完整自定义组件。

getCustomizerClass() - Method in class java.beans. BeanDescriptor

获取bean的定制器的Class对象。

getCutAction() - Static method in class javax.swing. TransferHandler

返回一个 Action ，执行切割操作到剪贴板。

getCycleCount() - Method in class javafx.animation. Animation

获取属性cycleCount的值。

getCycleCount() - Method in class javafx.scene.media. AudioClip

获取默认循环计数。

getCycleCount() - Method in class javafx.scene.media. MediaPlayer

检索周期数。

getCycleDuration() - Method in class javafx.animation. Animation

获取属性cycleDuration的值。

getCycleDuration() - Method in class javafx.scene.media. MediaPlayer

以秒为单位检索循环持续时间。

getCycleMethod() - Method in class java.awt. MultipleGradientPaint

返回指定循环行为的枚举类型。

getCycleMethod() - Method in class javafx.scene.paint. LinearGradient

定义了下面的循环方法的被施加到 LinearGradient ： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。

getCycleMethod() - Method in class javafx.scene.paint. RadialGradient

定义应用于 RadialGradient的循环方法。

getDaemonThreadCount() - Method in interface java.lang.management. ThreadMXBean

返回当前的守护进程线程数。

getDashArray() - Method in class java.awt. BasicStroke

返回表示短划线段长度的数组。

getDashArray() - Method in class javafx.scene.layout. BorderStrokeStyle

定义表示短划线段长度的数组。

getDashOffset() - Method in class javafx.scene.layout. BorderStrokeStyle

定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。

getDashPhase() - Method in class java.awt. BasicStroke

返回当前的虚线阶段。

getData() - Method in class com.sun.security.jgss. AuthorizationDataEntry

获取广告数据字段的副本。

getData() - Method in class java.awt.color. ICC_Profile

返回与该ICC_Profile的数据对应的字节数组。

getData() - Method in class java.awt.image. BufferedImage

将图像返回为一个大图块。

getData() - Method in class java.awt.image. DataBufferByte

返回默认（第一个）字节数据数组。

getData() - Method in class java.awt.image. DataBufferDouble

返回默认（第一个） double数据数组。

getData() - Method in class java.awt.image. DataBufferFloat

返回默认（第一个） float数据数组。

getData() - Method in class java.awt.image. DataBufferInt

返回 DataBuffer中的默认（第一个）int数据数组。

getData() - Method in class java.awt.image. DataBufferShort

返回默认（第一个）字节数据数组。

getData() - Method in class java.awt.image. DataBufferUShort

返回默认（第一个）无符号短数据数组。

getData() - Method in interface java.awt.image. RenderedImage

将图像作为一个大图块返回（对于基于图块的图像，这将需要获取整个图像并复制图像数据）。

getData() - Method in class java.net. DatagramPacket

返回数据缓冲区。

getData() - Method in class java.rmi.activation. ActivationDesc

返回一个包含由该描述符指定的对象的初始化/激活数据的“编组对象”。

getData() - Method in class java.rmi.activation. ActivationGroupDesc

返回组的初始化数据。

getData() - Method in class javafx.scene.chart. PieChart

获取属性数据的值。

getData() - Method in class javafx.scene.chart. XYChart

获取属性数据的值。

getData() - Method in class javafx.scene.chart. XYChart.Series

获取属性数据的值。

getData() - Method in class javafx.scene.web. WebEvent

返回此事件携带的数据项。

getData() - Method in class javax.imageio.plugins.tiff. TIFFField

返回与该字段关联的数据对象的引用。

getData() - Method in class javax.imageio.stream. IIOByteBuffer

返回对字节数组的引用。

getData() - Method in class javax.smartcardio. CommandAPDU

返回命令体中数据字节的副本。

getData() - Method in class javax.smartcardio. ResponseAPDU

返回响应正文中数据字节的副本。

getData() - Method in class javax.sound.midi. MetaMessage

获取元消息的数据副本。

getData() - Method in class javax.sound.midi. SoundbankResource

获取存储在此 SoundbankResource的采样音频。

getData() - Method in class javax.sound.midi. SysexMessage

获取系统专用消息的数据副本。

getData() - Method in class javax.swing.text.html. FormSubmitEvent

获取表单提交数据。

getData() - Method in class javax.swing.text.html.parser. Entity

返回 data 。

getData() - Method in interface javax.xml.stream.events. Characters

获取此事件的字符数据

getData() - Method in interface javax.xml.stream.events. ProcessingInstruction

处理指令的数据部分

getData() - Method in interface org.w3c.dom. CharacterData

实现此接口的节点的字符数据。

getData() - Method in interface org.w3c.dom.html. HTMLObjectElement

指定对象数据位置的URI。

getData() - Method in interface org.w3c.dom. ProcessingInstruction

该处理指令的内容。

getData(int) - Method in class java.awt.color. ICC_Profile

从配置文件返回特定的标记数据元素作为字节数组。

getData(int) - Method in class java.awt.image. DataBufferByte

返回指定库的数据数组。

getData(int) - Method in class java.awt.image. DataBufferDouble

返回指定库的数据数组。

getData(int) - Method in class java.awt.image. DataBufferFloat

返回指定库的数据数组。

getData(int) - Method in class java.awt.image. DataBufferInt

返回指定库的数据数组。

getData(int) - Method in class java.awt.image. DataBufferShort

返回指定库的数据数组。

getData(int) - Method in class java.awt.image. DataBufferUShort

返回指定库的数据数组。

getData(DataFlavor) - Method in class java.awt.datatransfer. Clipboard

在指定的 DataFlavor返回表示此剪贴板当前内容的对象。

getData(Rectangle) - Method in class java.awt.image. BufferedImage

计算并返回 BufferedImage的任意区域。

getData(Rectangle) - Method in interface java.awt.image. RenderedImage

计算并返回RenderedImage的任意区域。

getData1() - Method in class javax.sound.midi. ShortMessage

获取消息中的第一个数据字节。

getData2() - Method in class javax.sound.midi. ShortMessage

获取消息中的第二个数据字节。

getDatabaseMajorVersion() - Method in interface java.sql. DatabaseMetaData

检索底层数据库的主版本号。

getDatabaseMinorVersion() - Method in interface java.sql. DatabaseMetaData

检索底层数据库的次要版本号。

getDatabaseProductName() - Method in interface java.sql. DatabaseMetaData

检索此数据库产品的名称。

getDatabaseProductVersion() - Method in interface java.sql. DatabaseMetaData

检索此数据库产品的版本号。

getDataBitOffset() - Method in class java.awt.image. MultiPixelPackedSampleModel

以位为单位返回数据位偏移量。

getDataBuffer() - Method in class java.awt.image. Raster

返回与此栅格相关联的DataBuffer。

getDataClass() - Method in class javax.sound.midi. SoundbankResource

获取此样本用于表示其数据的类。

getDataElement(float[], int) - Method in class java.awt.image. ColorModel

给定一个归一化的颜色/ alpha分量阵列，返回 int中 ColorModel表示的像素值。

getDataElement(float[], int) - Method in class java.awt.image. ComponentColorModel

给出一个归一化的颜色/ alpha分量数组，返回 int中 ColorModel表示的像素值。

getDataElement(int[], int) - Method in class java.awt.image. ColorModel

返回一个 int中 ColorModel表示的像素值，给出了一系列非标准化颜色/ alpha分量。

getDataElement(int[], int) - Method in class java.awt.image. ComponentColorModel

给出一个非规范化颜色/ alpha分量的数组，返回这个 ColorModel以int表示的像素值。

getDataElement(int[], int) - Method in class java.awt.image. DirectColorModel

返回一个像 int这个 ColorModel中的像素值，给出了一个非规范化的颜色/ alpha分量阵列。

getDataElement(int[], int) - Method in class java.awt.image. IndexColorModel

返回一个像这个 ColorModel的int表示的像素值，给出一个非规范化的颜色/ alpha组件数组。

getDataElements(float[], int, Object) - Method in class java.awt.image. ColorModel

给出这个 ColorModel中的像素的数据元素数组表示，给出了一组归一化的颜色/ alpha分量。

getDataElements(float[], int, Object) - Method in class java.awt.image. ComponentColorModel

给定一个标准化颜色/ alpha分量的数组，返回此 ColorModel中的像素的数据元素数组表示。

getDataElements(int[], int, Object) - Method in class java.awt.image. ColorModel

返回这个 ColorModel中的像素的数据元素数组表示，给出了一个非规范化的颜色/ alpha分量的数组。

getDataElements(int[], int, Object) - Method in class java.awt.image. ComponentColorModel

给出这个 ColorModel的一个像素的数据元素数组表示，给出一个非标准化颜色/ alpha分量的数组。

getDataElements(int[], int, Object) - Method in class java.awt.image. DirectColorModel

返回这个 ColorModel中的像素的数据元素数组表示，给出了一个非标准化颜色/ alpha分量的数组。

getDataElements(int[], int, Object) - Method in class java.awt.image. IndexColorModel

返回这个 ColorModel的一个像素的数据元素数组表示，给出一个非标准化的颜色/ alpha分量数组。

getDataElements(int, int, int, int, Object) - Method in class java.awt.image. Raster

返回TransferType类型的原始数组中指定的像素矩形的像素数据。

getDataElements(int, int, int, int, Object, DataBuffer) - Method in class java.awt.image. SampleModel

返回TransferType类型的原始数组中指定的像素矩形的像素数据。

getDataElements(int, int, Object) - Method in class java.awt.image. Raster

返回TransferType类型的原始数组中单个像素的数据。

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. BandedSampleModel

返回TransferType类型的原始数组中单个像素的数据。

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

返回类型为 TransferType的基本数组中单个像素的数据。

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. MultiPixelPackedSampleModel

返回TransferType类型的原始数组中单个像素的数据。

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. SampleModel

返回TransferType类型的原始数组中单个像素的数据。

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

返回TransferType类型的原始数组中单个像素的数据。

getDataElements(int, Object) - Method in class java.awt.image. ColorModel

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

getDataElements(int, Object) - Method in class java.awt.image. ComponentColorModel

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

getDataElements(int, Object) - Method in class java.awt.image. DirectColorModel

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

getDataElements(int, Object) - Method in class java.awt.image. IndexColorModel

返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

getDataFlavors() - Method in class javax.swing. TransferHandler.TransferSupport

返回此传输的数据风格。

getDataHandler() - Method in class javax.xml.soap. AttachmentPart

获取此 DataHandler对象的 AttachmentPart对象。

getDataLength(int) - Method in class javax.sound.midi. ShortMessage

检索与特定状态字节值相关联的数据字节数。

getDatalink() - Method in class javax.sql.rowset.serial. SerialDatalink

返回一个新的URL，它是该 SerialDatalink对象的副本。

getDataSize() - Method in exception java.sql. DataTruncation

获取应该传输的数据的字节数。

getDataSource() - Method in class javax.activation. DataHandler

返回与此DataHandler实例关联的DataSource。

getDataSourceLock() - Method in class javax.sql.rowset.spi. SyncProvider

返回此 SyncProvider实现中当前数据源锁严重级别。

getDataSourceName() - Method in class javax.sql.rowset. BaseRowSet

返回当提供给使用Java命名和目录接口（JNDI）API的命名服务时，将检索 javax.sql.DataSource对象的逻辑名称。

getDataSourceName() - Method in interface javax.sql. RowSet

检索标识该 RowSet对象的数据源的逻辑名称。

getDataType() - Method in class java.awt.image. DataBuffer

返回此DataBuffer的数据类型。

getDataType() - Method in class java.awt.image. SampleModel

返回存储像素数据的DataBuffer的数据类型。

getDataTypes() - Method in class javax.imageio.plugins.tiff. TIFFTag

返回指示可用于存储与标签相关联的数据的数据类型集的位掩码。

getDataTypeSize(int) - Static method in class java.awt.image. DataBuffer

给出数据类型标签的数据类型的大小（以位为单位）。

getDataVector() - Method in class javax.swing.table. DefaultTableModel

返回包含表的数据值的 Vector的 Vectors 。

getDate() - Method in class java.net. URLConnection

返回 date标题字段的值。

getDate() - Method in class java.security.cert. PKIXParameters

返回确定认证路径有效性的时间。

getDate() - Method in class java.sql. Time

已过时。

getDate() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_MONTH)替代。

getDate() - Method in class javax.swing. SpinnerDateModel

返回此序列中的当前元素 Date s。

getDate(int) - Method in interface java.sql. CallableStatement

以 java.sql.Date对象的形式获取指定的JDBC DATE参数的值。

getDate(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 java.sql.Date对象的形式，检索此 ResultSet对象的当前行中指定列的值。

getDate(int, Calendar) - Method in interface java.sql. CallableStatement

检索指定的JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象来构造日期。

getDate(int, Calendar) - Method in interface java.sql. ResultSet

这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Date的Java编程语言对象。

getDate(Integer) - Method in class javax.management.timer. Timer

获取与定时器通知相关联的日期的副本。

getDate(Integer) - Method in interface javax.management.timer. TimerMBean

获取与定时器通知相关联的日期的副本。

getDate(String) - Method in interface java.sql. CallableStatement

检索作为 java.sql.Date对象的JDBC DATE参数的值。

getDate(String) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Date对象。

getDate(String, Calendar) - Method in interface java.sql. CallableStatement

检索JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象来构造日期。

getDate(String, Calendar) - Method in interface java.sql. ResultSet

将该 ResultSet对象的当前行中指定列的值作为Java编程语言中的 java.sql.Date对象 java.sql.Date 。

getDateAndTime() - Method in class java.security.cert. X509CRLSelector

返回dateAndTime条件。

getDateFormat() - Method in class javafx.util.converter. DateStringConverter

返回一个DateFormat实例，用于格式化和解析StringConverter 。

getDateFormat() - Method in class javafx.util.converter. DateTimeStringConverter

返回一个DateFormat实例，用于格式化和解析StringConverter 。

getDateFormat() - Method in class javafx.util.converter. TimeStringConverter

返回一个DateFormat实例，用于在此StringConverter中进行格式化和解析。

getDateFormatSymbols() - Method in class java.text. SimpleDateFormat

获取此日期格式的日期和时间格式符号的副本。

getDateInstance() - Static method in class java.text. DateFormat

获取默认格式化样式为默认的 FORMAT区域设置的日期格式化程序。

getDateInstance(int) - Static method in class java.text. DateFormat

获取默认的 FORMAT语言环境的给定格式化样式的日期格式化程序。

getDateInstance(int, Locale) - Static method in class java.text. DateFormat

获取给定区域设置的给定格式化样式的日期格式化程序。

getDateInstance(int, Locale) - Method in class java.text.spi. DateFormatProvider

返回一个新的 DateFormat实例，其格式为指定区域设置的给定格式化样式的日期。

getDateTime() - Method in interface org.w3c.dom.html. HTMLModElement

变更的日期和时间。

getDateTimeAfter() - Method in class java.time.zone. ZoneOffsetTransition

获取本地转换日期时间，将以“after”偏移量表示。

getDateTimeBefore() - Method in class java.time.zone. ZoneOffsetTransition

获取本地转换日期时间，如“before”偏移量所表达的那样。

getDateTimeInstance() - Static method in class java.text. DateFormat

获取日期/时间格式化程序，默认的格式化样式为默认的 FORMAT区域设置。

getDateTimeInstance(int, int) - Static method in class java.text. DateFormat

使用默认的 FORMAT区域设置的给定日期和时间格式化样式获取日期/时间格式化程序。

getDateTimeInstance(int, int, Locale) - Static method in class java.text. DateFormat

获取给定区域设置的给定格式样式的日期/时间格式化程序。

getDateTimeInstance(int, int, Locale) - Method in class java.text.spi. DateFormatProvider

返回一个新的 DateFormat实例，它使用指定区域设置的给定格式化样式格式化日期和时间。

getDay() - Method in class java.sql. Time

已过时。

getDay() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_WEEK)替代。

getDay() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回月份的日期或 DatatypeConstants.FIELD_UNDEFINED 。

getDayCellFactory() - Method in class javafx.scene.control. DatePicker

获取属性dayCellFactory的值。

getDaylightSavings(Instant) - Method in class java.time.zone. ZoneRules

获取此区域中指定时间使用的夏令时数量。

getDayOfMonth() - Method in class java.time. LocalDate

获取月份字段。

getDayOfMonth() - Method in class java.time. LocalDateTime

获取月份字段。

getDayOfMonth() - Method in class java.time. MonthDay

获取月份字段。

getDayOfMonth() - Method in class java.time. OffsetDateTime

获取月份字段。

getDayOfMonth() - Method in class java.time. ZonedDateTime

获取月份字段。

getDayOfMonthIndicator() - Method in class java.time.zone. ZoneOffsetTransitionRule

获得转型月份的指标。

getDayOfWeek() - Method in class java.time. LocalDate

获取星期几字段，这是一个枚举 DayOfWeek 。

getDayOfWeek() - Method in class java.time. LocalDateTime

获取星期几字段，这是一个枚举 DayOfWeek 。

getDayOfWeek() - Method in class java.time. OffsetDateTime

获取星期几字段，这是一个枚举 DayOfWeek 。

getDayOfWeek() - Method in class java.time.zone. ZoneOffsetTransitionRule

获得过渡的星期几。

getDayOfWeek() - Method in class java.time. ZonedDateTime

获取星期几字段，这是一个枚举 DayOfWeek 。

getDayOfYear() - Method in class java.time. LocalDate

获得日期字段。

getDayOfYear() - Method in class java.time. LocalDateTime

获得日期字段。

getDayOfYear() - Method in class java.time. OffsetDateTime

获得日期字段。

getDayOfYear() - Method in class java.time. ZonedDateTime

获得日期字段。

getDays() - Method in class java.time. Period

获得此期间的天数。

getDays() - Method in class javax.xml.datatype. Duration

获取DAYS字段的值作为整数值，如果不存在则取为0。

getDCHuffmanTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageReadParam

返回在最近调用 setDecodeTables设置的DC Huffman表数组的副本，如果表当前未设置，则 null 。

getDCHuffmanTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的DC Huffman表数组的副本。

getDebugGraphicsOptions() - Method in class javax.swing. JComponent

返回图形调试状态。

getDebugOptions() - Method in class javax.swing. DebugGraphics

返回此DebugGraphics的当前调试选项。

getDecayTime() - Method in class javax.sound.sampled. ReverbType

获得衰减时间，这是晚期反射衰减到有效零点的时间量。

getDecimalFormatSymbols() - Method in class java.text. DecimalFormat

返回十进制格式符号的副本，通常程序员或用户不会更改它们。

getDecimalSeparator() - Method in class java.text. DecimalFormatSymbols

获取用于十进制符号的字符。

getDecimalSeparator() - Method in class java.time.format. DecimalStyle

获取表示小数点的字符。

getDecimalStyle() - Method in class java.time.format. DateTimeFormatter

获取在格式化期间使用的DecimalStyle。

getDeclaration() - Method in class javafx.css. Style

“宣言”是即将应用或刚刚应用的风格的来源。

getDeclaration() - Method in interface javax.xml.stream.events. EntityReference

返回该实体的声明。

getDeclaration(String) - Method in class javax.swing.text.html. StyleSheet

将CSS声明转换为表示CSS声明的AttributeSet。

getDeclarations() - Method in class javafx.css. Rule

此方法是支持可能希望从规则添加声明或从规则中删除声明的工具。

getDeclare() - Method in interface org.w3c.dom.html. HTMLObjectElement

声明（为将来参考），但不要实例化，这个对象。

getDeclaredAnnotation(Class<A>) - Method in class java.lang. Class

getDeclaredAnnotation(Class<A>) - Method in class java.lang. 软件包

getDeclaredAnnotation(Class<T>) - Method in class java.lang.reflect. AccessibleObject

getDeclaredAnnotation(Class<T>) - Method in interface java.lang.reflect. AnnotatedElement

如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。

getDeclaredAnnotation(Class<T>) - Method in class java.lang.reflect. Parameter

getDeclaredAnnotations() - Method in class java.lang. Class

getDeclaredAnnotations() - Method in class java.lang. Module

返回 直接存在于此元素上的注释。

getDeclaredAnnotations() - Method in class java.lang. 软件包

getDeclaredAnnotations() - Method in class java.lang.reflect. AccessibleObject

getDeclaredAnnotations() - Method in interface java.lang.reflect. AnnotatedElement

返回 直接存在于此元素上的注释。

getDeclaredAnnotations() - Method in class java.lang.reflect. Constructor

返回 直接存在于此元素上的注释。

getDeclaredAnnotations() - Method in class java.lang.reflect. Executable

返回 直接存在于此元素上的注释。

getDeclaredAnnotations() - Method in class java.lang.reflect. Field

返回 直接存在于此元素上的注释。

getDeclaredAnnotations() - Method in class java.lang.reflect. 方法

返回 直接存在于此元素上的注释。

getDeclaredAnnotations() - Method in class java.lang.reflect. Parameter

返回 直接存在于此元素上的注释。

getDeclaredAnnotationsByType(Class<A>) - Method in class java.lang. Class

getDeclaredAnnotationsByType(Class<A>) - Method in class java.lang. 软件包

getDeclaredAnnotationsByType(Class<T>) - Method in class java.lang.reflect. AccessibleObject

getDeclaredAnnotationsByType(Class<T>) - Method in interface java.lang.reflect. AnnotatedElement

如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。

getDeclaredAnnotationsByType(Class<T>) - Method in class java.lang.reflect. Parameter

getDeclaredClasses() - Method in class java.lang. Class

返回一个 Class对象的数组， Class对象反映了声明为由该 Class对象表示的类的成员的所有类和接口。

getDeclaredConstructor(Class<?>...) - Method in class java.lang. Class

返回一个 Constructor对象，它反映此表示的类或接口的指定构造 Class对象。

getDeclaredConstructors() - Method in class java.lang. Class

返回反映由该 Class对象表示的类声明的所有构造函数的 Constructor对象的数组。

getDeclaredField(String) - Method in class java.lang. Class

返回一个 Field对象，它反映此表示的类或接口的指定已声明字段 Class对象。

getDeclaredFields() - Method in class java.lang. Class

返回一个 Field对象的数组，反映由该 Class对象表示的类或接口声明的所有字段。

getDeclaredMethod(String, Class<?>...) - Method in class java.lang. Class

返回一个 方法对象，该对象反映由该 Class对象表示的类或接口的指定声明方法。

getDeclaredMethods() - Method in class java.lang. Class

返回一个包含 方法对象的数组， 方法对象反映了由此 Class对象表示的类或接口的所有声明方法，包括public，protected，default（package）访问和私有方法，但不包括继承方法。

getDeclaredPrefixes() - Method in class org.xml.sax.helpers. NamespaceSupport

返回在此上下文中声明的所有前缀的枚举。

getDeclaredType() - Method in class javax.xml.bind. JAXBElement

返回xml元素声明的type属性的Java绑定。

getDeclaredType(TypeElement, TypeMirror...) - Method in interface javax.lang.model.util. Types

返回与类型元素和实际类型参数相对应的类型。

getDeclaredType(DeclaredType, TypeElement, TypeMirror...) - Method in interface javax.lang.model.util. Types

返回与类型元素和实际类型参数对应的类型，给出一个 containing type它是其成员。

getDeclaringClass() - Method in class java.lang. Class

如果由此 Class对象表示的类或接口是另一个类的成员，则返回表示其声明的类的 Class对象。

getDeclaringClass() - Method in class java.lang. Enum

返回与此枚举常量的枚举类型相对应的Class对象。

getDeclaringClass() - Method in interface java.lang.invoke. MethodHandleInfo

返回定义了破解方法句柄的基础成员的类。

getDeclaringClass() - Method in class java.lang.reflect. Constructor

返回表示声明由该对象表示的构造函数的类的 Class对象。

getDeclaringClass() - Method in class java.lang.reflect. Executable

返回表示由该对象表示的可执行文件的类或接口的 Class对象。

getDeclaringClass() - Method in class java.lang.reflect. Field

返回 Class表示声明此表示的字段的类或接口对象 Field对象。

getDeclaringClass() - Method in interface java.lang.reflect. Member

返回表示声明该成员表示的成员或构造函数的类或接口的Class对象。

getDeclaringClass() - Method in class java.lang.reflect. 方法

返回表示由该对象表示的方法声明的类或接口的 Class对象。

getDeclaringClass() - Method in interface java.lang. StackWalker.StackFrame

获取由此堆栈帧表示的方法声明 Class 。

getDeclaringExecutable() - Method in class java.lang.reflect. Parameter

返回说明此参数的 Executable 。

getDecoder() - Static method in class java.util. Base64

返回Base64.Decoder解码使用Basic型base64编码方案。

getDecomposition() - Method in class java.text. Collator

获取此Collator的分解模式。

getDeepestComponentAt(Component, int, int) - Static method in class javax.swing. SwingUtilities

返回的最深可见后代组件 parent包含位置 x ， y 。

getDefault() - Static method in class java.net. Authenticator

获取默认验证器。

getDefault() - Static method in class java.net. CookieHandler

获取系统范围的Cookie处理程序。

getDefault() - Static method in class java.net. ProxySelector

获取系统范围的代理选择器。

getDefault() - Static method in class java.net. ResponseCache

获取系统范围的响应缓存。

getDefault() - Static method in class java.nio.file. FileSystems

返回默认值 FileSystem 。

getDefault() - Static method in class java.util. Locale

获取Java虚拟机的此实例的默认语言环境的当前值。

getDefault() - Static method in class java.util. TimeZone

获取Java虚拟机的默认值 TimeZone 。

getDefault() - Static method in class javafx.scene.text. Font

获取将来自“系统”系列的默认字体，通常为“常规”样式，并且具有与用户桌面环境一致的大小，至可以确定的程度。

getDefault() - Static method in class javax.net. ServerSocketFactory

返回环境默认套接字工厂的副本。

getDefault() - Static method in class javax.net. SocketFactory

返回环境默认套接字工厂的副本。

getDefault() - Static method in class javax.net.ssl. SSLContext

返回默认的SSL上下文。

getDefault() - Static method in class javax.net.ssl. SSLServerSocketFactory

返回默认的SSL服务器套接字工厂。

getDefault() - Static method in class javax.net.ssl. SSLSocketFactory

返回默认的SSL套接字工厂。

getDefault() - Static method in class javax.smartcardio. TerminalFactory

返回默认的TerminalFactory实例。

getDefault(Locale.Category) - Static method in class java.util. Locale

获取Java虚拟机的此实例的指定类别的默认语言环境的当前值。

getDefaultAction() - Method in interface javax.swing.text. Keymap

如果键入键（即接收到KEY_TYPED KeyEvent），则获取默认操作以触发，并且没有绑定。

getDefaultActions() - Method in class java.awt.dnd. DropTarget

获取一个 int表示受此支持的当前操作（一个或多个） DropTarget 。

getDefaultAlgorithm() - Static method in class javax.net.ssl. KeyManagerFactory

获取默认的KeyManagerFactory算法名称。

getDefaultAlgorithm() - Static method in class javax.net.ssl. TrustManagerFactory

获取默认的TrustManagerFactory算法名称。

getDefaultAllowUserInteraction() - Static method in class java.net. URLConnection

返回 allowUserInteraction字段的默认值。

getDefaultAttributeValue(Class<? extends Attribute>) - Method in interface javax.print. PrintService

确定此打印服务在给定类别中的默认打印属性值。

getDefaultButton() - Method in class javax.swing. JRootPane

返回 defaultButton属性的值。

getDefaultButton(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回当前 LookAndFeel默认按钮。

getDefaultButton(JFileChooser) - Method in class javax.swing.plaf. FileChooserUI

返回当前的默认按钮 LookAndFeel 。

getDefaultChecked() - Method in interface org.w3c.dom.html. HTMLInputElement

当 type具有值“Radio”或“Checkbox”时，表示元素的HTML checked属性。

getDefaultChoice() - Method in class javafx.scene.control. ChoiceDialog

返回在构造函数中指定的默认选项。

getDefaultChoice() - Method in class javax.security.auth.callback. ChoiceCallback

获取defaultChoice。

getDefaultChooserPanels() - Static method in class javax.swing.colorchooser. ColorChooserComponentFactory

返回默认选择器面板。

getDefaultCipherSuites() - Method in class javax.net.ssl. SSLServerSocketFactory

返回默认启用的密码套件列表。

getDefaultCipherSuites() - Method in class javax.net.ssl. SSLSocketFactory

返回默认启用的密码套件列表。

getDefaultClassLoader() - Static method in class javafx.fxml. FXMLLoader

返回默认的类加载器。

getDefaultClassLoader() - Method in class javax.management.remote.rmi. RMIServerImpl

获取此连接器服务器使用的默认值 ClassLoader 。

getDefaultClosedIcon() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回用于表示未展开的非叶节点的当前laf的默认图标。

getDefaultCloseOperation() - Method in class javax.swing. JDialog

返回用户在此对话框上启动“关闭”时发生的操作。

getDefaultCloseOperation() - Method in class javax.swing. JFrame

返回当用户在此框架上启动“关闭”时发生的操作。

getDefaultCloseOperation() - Method in class javax.swing. JInternalFrame

返回用户在此内部框架上启动“关闭”时发生的默认操作。

getDefaultCollation() - Method in class javafx.print. PrinterAttributes

默认的排序规则设置。

getDefaultCommandMap() - Static method in class javax.activation. CommandMap

获取默认的CommandMap。

getDefaultComponent(Container) - Method in class java.awt. ContainerOrderFocusTraversalPolicy

返回要对焦的默认组件。

getDefaultComponent(Container) - Method in class java.awt. FocusTraversalPolicy

返回要对焦的默认组件。

getDefaultComponent(Container) - Method in class javax.swing. SortingFocusTraversalPolicy

返回要对焦的默认组件。

getDefaultConfiguration() - Method in class java.awt. GraphicsDevice

返回默认 GraphicsConfiguration与此相关 GraphicsDevice 。

getDefaultController() - Method in class javax.imageio. IIOParam

返回默认的 IIOParamController ，如果有一个，不管当前安装的控制器。

getDefaultController() - Method in class javax.imageio.metadata. IIOMetadata

返回默认的 IIOMetadataController ，如果有一个，不管当前安装的控制器。

getDefaultCopies() - Method in class javafx.print. PrinterAttributes

要打印的默认份数。

getDefaultCursor() - Static method in class java.awt. Cursor

返回系统默认光标。

getDefaultCursor() - Method in class javax.swing.text.html. HTMLEditorKit

返回默认游标。

getDefaultDigestAlgorithm() - Static method in class jdk.security.jarsigner. JarSigner.Builder

获取默认摘要算法。

getDefaultDirectory() - Method in class javax.swing.filechooser. FileSystemView

返回用户的文件选择器的默认启动目录。

getDefaultDomain() - Method in interface javax.management. MBeanServer

getDefaultDomain() - Method in interface javax.management. MBeanServerConnection

返回用于命名MBean的默认域。

getDefaultDomain(Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.getDefaultDomain() 。

getDefaultDomain(Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getDefaultDomain(Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

getDefaultDragSource() - Static method in class java.awt.dnd. DragSource

获取与底层平台相关联的 DragSource对象。

getDefaultEditor(Class<?>) - Method in class javax.swing. JTable

在 TableColumn没有设置编辑器时，返回要使用的编辑器。

getDefaultEventIndex() - Method in interface java.beans. BeanInfo

一个bean可能有一个默认的事件通常应用在这个bean使用。

getDefaultEventIndex() - Method in class java.beans. SimpleBeanInfo

拒绝默认事件的知识。

getDefaultFileTypeMap() - Static method in class javax.activation. FileTypeMap

返回系统的默认FileTypeMap。

getDefaultFlavorMap() - Static method in class java.awt.datatransfer. SystemFlavorMap

返回此线程的ClassLoader的默认FlavorMap。

getDefaultFocusTraversalKeys(int) - Method in class java.awt. KeyboardFocusManager

返回给定遍历操作的一组默认焦点遍历键。

getDefaultFocusTraversalPolicy() - Method in class java.awt. KeyboardFocusManager

返回默认的FocusTraversalPolicy。

getDefaultFormatter() - Method in class javax.swing.text. DefaultFormatterFactory

返回 JFormattedTextField.AbstractFormatter作为最后手段使用，例如，如果未指定显示，编辑或空值 JFormattedTextField.AbstractFormatter 。

getDefaultFractionDigits() - Method in class java.util. Currency

获取与该货币一起使用的默认小数位数。

getDefaultHostnameVerifier() - Static method in class javax.net.ssl. HttpsURLConnection

获取 HostnameVerifier的新实例继承的默认值 HostnameVerifier 。

getDefaultIcon() - Method in class javax.swing.plaf.basic. BasicRadioButtonUI

返回默认图标。

getDefaultIcon(AbstractButton) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回默认图标。

getDefaultImageMetadata(ImageTypeSpecifier, ImageWriteParam) - Method in class javax.imageio. ImageWriter

返回一个 IIOMetadata对象，其中包含用于对给定类型的图像进行编码的默认值。

getDefaultInitCtx() - Method in class javax.naming. InitialContext

通过调用 NamingManager.getInitialContext()并将其缓存在defaultInitCtx中获取初始上下文。

getDefaultInstance() - Static method in class javax.imageio.spi. IIORegistry

返回Image I / O API使用的默认 IIORegistry实例。

getDefaultLeafIcon() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回用于表示叶节点的当前laf的默认图标。

getDefaultLightWeightPopupEnabled() - Static method in class javax.swing. JPopupMenu

获取 defaultLightWeightPopupEnabled属性，默认为 true 。

getDefaultLocale() - Static method in class javax.swing. JComponent

返回用于在创建时初始化每个JComponent的locale属性的默认区域设置。

getDefaultLocale() - Method in class javax.swing. UIDefaults

返回默认语言环境。

getDefaultName() - Method in class javax.security.auth.callback. NameCallback

获取默认名称。

getDefaultNamespacePrefix() - Method in class javax.xml.crypto.dom. DOMCryptoContext

getDefaultNamespacePrefix() - Method in interface javax.xml.crypto. XMLCryptoContext

返回默认名称空间前缀。

getDefaultOpenIcon() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回用于表示展开的非叶节点的当前laf的默认图标。

getDefaultOption() - Method in class javax.security.auth.callback. ConfirmationCallback

获取默认选项。

getDefaultPage() - Method in interface javax.jnlp. PrintService

创建一个新的PageFormat实例，并将其设置为默认的大小和方向。

getDefaultPageLayout() - Method in class javafx.print. Printer

返回此打印机的默认页面布局。

getDefaultPageOrientation() - Method in class javafx.print. PrinterAttributes

返回此打印机上纸张的默认方向。

getDefaultPaper() - Method in class javafx.print. PrinterAttributes

返回此打印机使用的默认纸张尺寸。

getDefaultPaperSource() - Method in class javafx.print. PrinterAttributes

返回默认纸张输入源/纸盘/

getDefaultPort() - Method in class java.net. URL

获取与此 URL相关联的协议的默认端口号。

getDefaultPort() - Method in class java.net. URLStreamHandler

返回此处理程序解析的URL的默认端口。

getDefaultPrintColor() - Method in class javafx.print. PrinterAttributes

获取默认颜色设置：灰度或颜色

getDefaultPrinter() - Static method in class javafx.print. Printer

检索默认打印机。

getDefaultPrintQuality() - Method in class javafx.print. PrinterAttributes

返回默认质量设置

getDefaultPrintResolution() - Method in class javafx.print. PrinterAttributes

返回此打印机上纸张的默认打印分辨率。

getDefaultPrintService() - Method in class javax.print. PrintServiceLookup

不被应用程序直接调用

getDefaultPrintSides() - Method in class javafx.print. PrinterAttributes

返回双工设置的默认值。

getDefaultProgressWindow() - Method in interface javax.jnlp. DownloadService

返回一个默认的DownloadServiceListener实现，当传递给一个load方法时，应该随着进度而弹出并更新一个进度窗口。

getDefaultPropertyIndex() - Method in interface java.beans. BeanInfo

当bean定制时，bean可能具有通常更新的默认属性。

getDefaultPropertyIndex() - Method in class java.beans. SimpleBeanInfo

拒绝默认属性的知识。

getDefaultProviderInstance() - Static method in class java.rmi.server. RMIClassLoader

返回服务提供商接口RMIClassLoaderSpi的默认提供程序的规范实例。

getDefaultQueue() - Static method in class javax.swing.text. LayoutQueue

获取默认布局队列。

getDefaultReadParam() - Method in class javax.imageio. ImageReader

返回适用于此格式的默认值 ImageReadParam对象。

getDefaultRenderer() - Method in class javax.swing.table. JTableHeader

返回当由 TableColumn定义 headerRenderer时使用的默认渲染器。

getDefaultRenderer(Class<?>) - Method in class javax.swing. JTable

返回在 TableColumn未设置渲染器时要使用的单元格渲染器。

getDefaultRepresentationClass() - Method in class java.awt.datatransfer. DataFlavor

返回默认表示类。

getDefaultRepresentationClassAsString() - Method in class java.awt.datatransfer. DataFlavor

返回默认表示类的名称。

getDefaultRequestProperty(String) - Static method in class java.net. URLConnection

已过时。
在获得适当的URLConnection实例之后，应该使用实例特定的getRequestProperty方法。

getDefaultRootElement() - Method in class javax.swing.text. AbstractDocument

返回视图应该基于的根元素，除非提供了用于将视图分配给元素结构的其他机制。

getDefaultRootElement() - Method in class javax.swing.text. DefaultStyledDocument

获取默认的根元素。

getDefaultRootElement() - Method in interface javax.swing.text. Document

返回视图应该基于的根元素，除非提供了用于将视图分配给元素结构的其他机制。

getDefaultRootElement() - Method in class javax.swing.text. PlainDocument

获取文档模型的默认根元素。

getDefaults() - Method in class javax.swing. LookAndFeel

返回外观和默认值。

getDefaults() - Method in class javax.swing.plaf.basic. BasicLookAndFeel

返回外观和默认值。

getDefaults() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

返回外观和默认值。

getDefaults() - Method in class javax.swing.plaf.multi. MultiLookAndFeel

创建，初始化和返回外观和感觉特定的默认值。

getDefaults() - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

返回此SynthLookAndFeel的默认值。

getDefaults() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回此SynthLookAndFeel的默认值。

getDefaults() - Static method in class javax.swing. UIManager

返回默认值。

getDefaultScreenDevice() - Method in class java.awt. GraphicsEnvironment

返回默认画面 GraphicsDevice 。

getDefaultSelected() - Method in interface org.w3c.dom.html. HTMLOptionElement

表示HTML所选属性的值。

getDefaultSelection() - Method in class java.awt. JobAttributes

指定对于使用这些属性的作业，应用程序是否应打印所有页面，返回值为 getPageRanges指定的范围，或当前选择。

getDefaultSignatureAlgorithm(PrivateKey) - Static method in class jdk.security.jarsigner. JarSigner.Builder

获取私钥的默认签名算法。

getDefaultSize() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

使用当前渲染器和字体返回组合框的空显示区域的默认大小。

getDefaultSize() - Method in class javax.swing.plaf.synth. SynthComboBoxUI

使用当前渲染器和字体返回组合框的空显示区域的默认大小。

getDefaultSocketFactory() - Static method in class java.rmi.server. RMISocketFactory

返回对此RMI实现使用的默认套接字工厂的引用。

getDefaultSoundbank() - Method in interface javax.sound.midi. Synthesizer

获取合成器的默认声音库（如果存在）。

getDefaultSSLParameters() - Method in class javax.net.ssl. SSLContext

返回指示此SSL上下文默认设置的SSLParameters的副本。

getDefaultSSLSocketFactory() - Static method in class javax.net.ssl. HttpsURLConnection

获取由此类的新实例继承的默认静态 SSLSocketFactory 。

getDefaultStratum() - Method in interface com.sun.jdi. VirtualMachine

返回此虚拟机的默认层。

getDefaultStream() - Static method in class java.rmi.server. LogStream

已过时。
没有替换

getDefaultStreamMetadata(ImageWriteParam) - Method in class javax.imageio. ImageWriter

返回包含用于编码图像流的默认值的 IIOMetadata对象。

getDefaultStyleContext() - Static method in class javax.swing.text. StyleContext

返回默认的AttributeContext由所有不想定义/提供自己的上下文的文档共享。

getDefaultText() - Method in class javax.security.auth.callback. TextInputCallback

获取默认文本。

getDefaultTextIconGap(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI

返回文本和图标之间的默认差距。

getDefaultToolkit() - Static method in class java.awt. Toolkit

获取默认工具包。

getDefaultTransactionIsolation() - Method in interface java.sql. DatabaseMetaData

检索此数据库的默认事务隔离级别。

getDefaultTransform() - Method in class java.awt. GraphicsConfiguration

返回默认AffineTransform这个GraphicsConfiguration 。

getDefaultTreeModel() - Static method in class javax.swing. JTree

创建并返回样品 TreeModel 。

getDefaultType() - Static method in class java.security.cert. CertPathBuilder

返回由 certpathbuilder.type安全属性指定的默认值 CertPathBuilder类型，如果不存在此属性，则返回字符串“PKIX”。

getDefaultType() - Static method in class java.security.cert. CertPathValidator

返回由 certpathvalidator.type安全属性指定的默认值 CertPathValidator ，如果不存在此属性，则返回字符串“PKIX”。

getDefaultType() - Static method in class java.security.cert. CertStore

返回由 certstore.type安全属性指定的默认值 CertStore ，如果不存在此属性，则返回字符串“LDAP”。

getDefaultType() - Static method in class java.security. KeyStore

返回由 keystore.type安全属性指定的默认密钥库类型，或者如果没有此类属性，则返回字符串“jks”（“Java密钥库”的缩写）。

getDefaultType() - Static method in class javax.smartcardio. TerminalFactory

获取默认的TerminalFactory类型。

getDefaultUncaughtExceptionHandler() - Static method in class java.lang. Thread

返回当线程由于未捕获异常突然终止而调用的默认处理程序。

getDefaultUseCaches() - Method in class java.net. URLConnection

返回默认值为 URLConnection的 useCaches标志。

getDefaultUseCaches(String) - Static method in class java.net. URLConnection

返回给定协议的 useCaches标志的默认值。

getDefaultValue() - Method in interface com.sun.source.tree. MethodTree

返回默认值，如果这是注释类型声明中的元素。

getDefaultValue() - Method in class java.lang.reflect. 方法

返回由此 方法实例表示的注释成员的默认值。

getDefaultValue() - Method in class javafx.scene.control. TextInputDialog

返回在构造函数中指定的默认值。

getDefaultValue() - Method in class javafx.scene.web. PromptData

返回此数据对象携带的默认值。

getDefaultValue() - Method in interface javax.lang.model.element. ExecutableElement

如果此可执行文件是注释类型元素，则返回默认值。

getDefaultValue() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport

返回此 OpenMBeanAttributeInfoSupport实例描述的属性（如果指定）的默认值，否则 null 。

getDefaultValue() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回此参数的默认值，如果它有一个，否则 null 。

getDefaultValue() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport

返回此 OpenMBeanParameterInfoSupport实例描述的参数的默认值（如果指定），否则 null 。

getDefaultValue() - Method in class javax.swing.text.html. CSS.Attribute

获取属性的默认值。

getDefaultValue() - Method in interface org.w3c.dom.html. HTMLInputElement

当元素的 type属性具有值“文本”，“文件”或“密码”时，表示元素的HTML值属性。

getDefaultValue() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

表示元素的内容。

getDefaultValue(Class<?>) - Method in interface jdk.nashorn.api.scripting. JSObject

根据ECMAScript 5.1第8.6.2节实现此对象的 [[DefaultValue]]方法。

getDefaultValue(Class<?>) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

getDefaultValue(JSObject, Class<?>) - Static method in class jdk.nashorn.api.scripting. AbstractJSObject

已过时。
改用JSObject.getDefaultValue(Class) 。

getDefaultView() - Method in interface org.w3c.dom.views. DocumentView

这个 Document的默认 AbstractView Document ，如果没有可用， null 。

getDefaultWriteParam() - Method in class javax.imageio. ImageWriter

返回包含默认值的此文件格式的适当类型的新的 ImageWriteParam对象，即，如果未指定 ImageWriteParam对象将使用的值将被使用。

getDefer() - Method in interface org.w3c.dom.html. HTMLScriptElement

表示用户代理可以延迟脚本的处理。

getDefinedPackage(String) - Method in class java.lang. ClassLoader

返回由此类加载器定义的给定的 软件包中的 软件包 。

getDefinedPackages() - Method in class java.lang. ClassLoader

返回此类加载器定义的所有 软件包 。

getDefinitionClass() - Method in class java.lang.instrument. ClassDefinition

返回类。

getDefinitionClassFile() - Method in class java.lang.instrument. ClassDefinition

返回包含新类文件的字节数组。

getDelay() - Method in class javafx.animation. Animation

获取属性延迟的值。

getDelay() - Method in class javafx.concurrent. ScheduledService

获取属性延迟的值。

getDelay() - Method in class javax.swing. JMenu

在子菜单弹出或关闭之前，返回建议的延迟（以毫秒为单位）。

getDelay() - Method in class javax.swing. Timer

返回动作事件触发之间的延迟（以毫秒为单位）。

getDelay(TimeUnit) - Method in interface java.util.concurrent. Delayed

在给定的时间单位中返回与此对象相关联的剩余延迟。

getDelegatedTask() - Method in class javax.net.ssl. SSLEngine

返回此 SSLEngine的委托 Runnable任务。

getDelegCred() - Method in interface org.ietf.jgss. GSSContext

获取由上下文启动器委派给上下文接收器的凭据。

getDelegPolicyState() - Method in interface com.sun.security.jgss. ExtendedGSSContext

返回委派策略响应。

getDelta() - Method in class javafx.scene.control. ResizeFeaturesBase

返回在resize操作中添加或删除的水平空间量。

getDeltaX() - Method in class javafx.scene.input. ScrollEvent

获取水平滚动量。

getDeltaY() - Method in class javafx.scene.input. ScrollEvent

获取垂直滚动量。

getDependencies() - Method in interface javafx.beans.binding. Binding

返回不可修改的绑定的依赖关系ObservableList 。

getDependencies() - Method in class javafx.beans.binding. BooleanBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. DoubleBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. FloatBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. IntegerBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. ListBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. LongBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. MapBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. ObjectBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. SetBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependencies() - Method in class javafx.beans.binding. StringBinding

getDependencies()的默认实现返回一个空的ObservableList 。

getDependency() - Method in interface javax.lang.model.element. ModuleElement.RequiresDirective

返回所需的模块

getDepth() - Method in interface java.security.cert. PolicyNode

返回此节点在有效策略树中的深度。

getDepth() - Method in class javafx.geometry. Bounds

这个深度 Bounds 。

getDepth() - Method in class javafx.scene.shape. Box

获取属性深度的值。

getDepth() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回根据此节点的树的深度 - 从该节点到叶片的最长距离。

getDepth(int) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxModel

返回深度为 i文件。

getDepthTest() - Method in class javafx.scene. Node

获取属性depthTest的值。

getDER() - Method in class org.ietf.jgss. Oid

返回此oid对象的完整ASN.1 DER编码，其中包含标签和长度。

getDereferencedData() - Method in interface javax.xml.crypto.dsig. Reference

如果启用了 reference caching ，则返回取消引用的数据。

getDerefLinkFlag() - Method in class javax.naming.directory. SearchControls

确定在搜索期间链接是否将被取消引用。

getDerivedColor(Color, Color, float) - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

解码并返回从两个其他颜色之间的偏移导出的颜色。

getDerivedColor(Color, Color, float, boolean) - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

解码并返回从两个其他颜色之间的偏移导出的颜色。

getDerivedColor(String, float, float, float, int, boolean) - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

获取派生颜色，派生颜色是共享实例，并且当其父UIDefault颜色更改时，颜色值将更改。

getDerivedGauge() - Method in class javax.management.monitor. CounterMonitor

已过时。
截至JMX 1.2，由CounterMonitor.getDerivedGauge(ObjectName)替代

getDerivedGauge() - Method in interface javax.management.monitor. CounterMonitorMBean

已过时。
截至JMX 1.2，由CounterMonitorMBean.getDerivedGauge(ObjectName)替代

getDerivedGauge() - Method in class javax.management.monitor. GaugeMonitor

已过时。
截至JMX 1.2，由GaugeMonitor.getDerivedGauge(ObjectName)替代

getDerivedGauge() - Method in interface javax.management.monitor. GaugeMonitorMBean

已过时。
截至JMX 1.2，由GaugeMonitorMBean.getDerivedGauge(ObjectName)替代

getDerivedGauge() - Method in class javax.management.monitor. MonitorNotification

获取此监视器通知的派生量规。

getDerivedGauge() - Method in class javax.management.monitor. StringMonitor

已过时。
截至JMX 1.2，由StringMonitor.getDerivedGauge(ObjectName)替代

getDerivedGauge() - Method in interface javax.management.monitor. StringMonitorMBean

已过时。
截至JMX 1.2，由StringMonitorMBean.getDerivedGauge(ObjectName)替代

getDerivedGauge(ObjectName) - Method in class javax.management.monitor. CounterMonitor

如果此对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor. CounterMonitorMBean

获取指定MBean的派生量规。

getDerivedGauge(ObjectName) - Method in class javax.management.monitor. GaugeMonitor

如果此对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor. GaugeMonitorMBean

获取指定MBean的派生量规。

getDerivedGauge(ObjectName) - Method in class javax.management.monitor. StringMonitor

如果此对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor. StringMonitorMBean

获取指定MBean的派生量规。

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor. CounterMonitor

已过时。
截至JMX 1.2，由CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)取代

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor. CounterMonitorMBean

已过时。
截至JMX 1.2，由CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)替代

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor. GaugeMonitor

已过时。
截至JMX 1.2，由GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)替代

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor. GaugeMonitorMBean

已过时。
截至JMX 1.2，由GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)替代

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor. StringMonitor

已过时。
截至JMX 1.2，由StringMonitor.getDerivedGaugeTimeStamp(ObjectName)替代

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor. StringMonitorMBean

已过时。
截至JMX 1.2，由StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)替代

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor. CounterMonitor

如果该对象包含在所观察到的MBean集合中，则获取指定对象的派生标尺时间戳，否则为 0 。

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor. CounterMonitorMBean

获取指定MBean的派生标尺时间戳。

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor. GaugeMonitor

如果该对象包含在观察到的MBean集合中，则获取指定对象的派生标尺时间戳，否则为 0 。

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor. GaugeMonitorMBean

获取指定MBean的派生标尺时间戳。

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor. StringMonitor

如果该对象包含在观察到的MBean集合中，则获取指定对象的派生量规时间戳，否则为 0 。

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor. StringMonitorMBean

获取指定MBean的派生标尺时间戳。

getDescendantToggledPaths(TreePath) - Method in class javax.swing. JTree

返回一个 Enumeration的 TreePaths已展开是后裔 parent 。

getDescent() - Method in class java.awt.font. GraphicAttribute

返回此 GraphicAttribute的下降。

getDescent() - Method in class java.awt.font. ImageGraphicAttribute

返回此 ImageGraphicAttribute的下降。

getDescent() - Method in class java.awt.font. LineMetrics

返回文本的下降。

getDescent() - Method in class java.awt.font. ShapeGraphicAttribute

返回此 ShapeGraphicAttribute的下降。

getDescent() - Method in class java.awt.font. TextLayout

返回此 TextLayout的下降。

getDescent() - Method in class java.awt. FontMetrics

确定此 FontMetrics对象描述的 Font的 字体下降 。

getDescent(GlyphView) - Method in class javax.swing.text. GlyphView.GlyphPainter

下降的回报。

getDescription() - Method in interface com.sun.source.doctree. IndexTree

返回描述，如果有的话。

getDescription() - Method in interface com.sun.source.doctree. ParamTree

返回参数的描述。

getDescription() - Method in interface com.sun.source.doctree. ProvidesTree

返回由模块提供的服务类型的描述。

getDescription() - Method in interface com.sun.source.doctree. ReturnTree

返回方法返回值的描述。

getDescription() - Method in interface com.sun.source.doctree. SerialDataTree

返回串行数据的描述。

getDescription() - Method in interface com.sun.source.doctree. SerialFieldTree

返回串行字段的描述。

getDescription() - Method in interface com.sun.source.doctree. SerialTree

返回字段的描述，或返回“包含”或“排除”一词。

getDescription() - Method in interface com.sun.source.doctree. ThrowsTree

返回说明可能抛出异常的原因。

getDescription() - Method in interface com.sun.source.doctree. UsesTree

返回在模块中使用服务类型的描述。

getDescription() - Method in exception java.util.regex. PatternSyntaxException

检索错误的描述。

getDescription() - Method in class javafx.stage. FileChooser.ExtensionFilter

获取此 ExtensionFilter的描述。

getDescription() - Method in class javax.management. MBeanFeatureInfo

返回该功能的可读描述。

getDescription() - Method in class javax.management. MBeanInfo

返回MBean的可读描述。

getDescription() - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回MBean的可读描述。

getDescription() - Method in interface javax.management.openmbean. OpenMBeanConstructorInfo

返回此 OpenMBeanConstructorInfo实例描述的构造函数的可读描述。

getDescription() - Method in interface javax.management.openmbean. OpenMBeanInfo

返回 OpenMBeanInfo描述的打开的MBean实例的类型的可读描述。

getDescription() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo

返回此 OpenMBeanOperationInfo实例描述的操作的可读描述。

getDescription() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回此 OpenMBeanParameterInfo实例描述的参数的可读描述。

getDescription() - Method in class javax.management.openmbean. OpenType

返回此 OpenType实例的文本描述。

getDescription() - Method in class javax.management.relation. RoleInfo

返回角色的说明文字。

getDescription() - Method in class javax.sound.midi. MidiDevice.Info

获取设备的描述。

getDescription() - Method in interface javax.sound.midi. Soundbank

获取声音库的文字描述，适合显示。

getDescription() - Method in class javax.sound.sampled. Mixer.Info

获取混音器的描述。

getDescription() - Method in class javax.swing.event. HyperlinkEvent

以链接形式获取链接的描述。

getDescription() - Method in class javax.swing.filechooser. FileFilter

这个过滤器的描述。

getDescription() - Method in class javax.swing.filechooser. FileNameExtensionFilter

这个过滤器的描述。

getDescription() - Method in class javax.swing. ImageIcon

获取图像的描述。

getDescription() - Method in class javax.swing. LookAndFeel

返回这个外观的一行描述实现，例如

getDescription() - Method in class javax.swing.plaf.basic. BasicFileChooserUI.AcceptAllFileFilter

这个过滤器的描述。

getDescription() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

返回这种外观的简短描述。

getDescription() - Method in class javax.swing.plaf.multi. MultiLookAndFeel

返回这种外观的一行描述。

getDescription() - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

返回此外观的文字说明。

getDescription() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回SynthLookAndFeel的文本描述。

getDescription() - Method in interface jdk.javadoc.doclet. Doclet.Option

返回该选项的描述。

getDescription(File) - Method in class javax.swing.filechooser. FileView

该文件的人类可读描述。

getDescription(File) - Method in class javax.swing. JFileChooser

返回文件描述。

getDescription(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

该文件的人类可读描述。

getDescription(String) - Method in class javax.management.openmbean. CompositeType

返回其名称为 itemName，或该项目的描述 null如果 CompositeType实例不定义其名称为 itemName的任何项目。

getDescription(Locale) - Method in class javax.imageio.spi. IIOServiceProvider

返回此服务提供商及其相关实现的简短可读的描述。

getDescription(MBeanAttributeInfo) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanAttributeInfo中使用的描述。

getDescription(MBeanConstructorInfo) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanConstructorInfo中使用的描述。

getDescription(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management. StandardMBean

自定义钩子：获取将用于MBean返回的MBeanConstructorInfo的 序列 MBeanParameterInfo的描述。

getDescription(MBeanFeatureInfo) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanFeatureInfo中使用的描述。

getDescription(MBeanInfo) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanInfo中使用的描述。

getDescription(MBeanOperationInfo) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanOperationInfo中使用的描述。

getDescription(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management. StandardMBean

自定义钩子：获取将用于MBean返回的MBeanOperationInfo的 序列 MBeanParameterInfo的描述。

getDescriptor() - Method in class java.lang. Module

返回此模块的模块描述符，如果此模块是未命名模块，则返回 null 。

getDescriptor() - Method in interface javax.management. DescriptorRead

返回描述符的副本。

getDescriptor() - Method in class javax.management. MBeanFeatureInfo

返回该特征的描述符。

getDescriptor() - Method in class javax.management. MBeanInfo

获取此MBeanInfo的描述符。

getDescriptor() - Method in class javax.management.modelmbean. ModelMBeanAttributeInfo

获取ModelMBeanAttributeInfo的关联描述符的副本。

getDescriptor() - Method in class javax.management.modelmbean. ModelMBeanConstructorInfo

返回相关描述符的副本。

getDescriptor() - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

getDescriptor() - Method in class javax.management.modelmbean. ModelMBeanNotificationInfo

返回ModelMBeanNotificationInfo的关联描述符的副本。

getDescriptor() - Method in class javax.management.modelmbean. ModelMBeanOperationInfo

返回ModelMBeanOperationInfo的关联描述符的副本。

getDescriptor() - Method in interface jdk.dynalink. RelinkableCallSite

返回此调用站点的描述符。

getDescriptor() - Method in class jdk.dynalink.support. AbstractRelinkableCallSite

getDescriptor(String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

返回名称请求的描述符。

getDescriptor(String, String) - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回由name和descriptorType请求的描述符。

getDescriptor(String, String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

getDescriptors(String) - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回一个Descriptor数组，它由TypeDelegorType类型的ModelMBeanInfo的所有描述符组成。

getDescriptors(String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

getDesignAxisDefaults() - Method in interface java.awt.font. MultipleMaster

返回每个轴的默认设计值数组。

getDesignAxisNames() - Method in interface java.awt.font. MultipleMaster

返回每个设计轴的名称。

getDesignAxisRanges() - Method in interface java.awt.font. MultipleMaster

返回一个设计限制的数组，每个轴以[从...到]的形式进行交错。

getDesktop() - Static method in class java.awt. Desktop

返回当前桌面上下文的 Desktop实例。

getDesktopColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的桌面颜色。

getDesktopColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回桌面颜色。

getDesktopColor() - Method in class javax.swing.plaf.metal. OceanTheme

返回桌面颜色。

getDesktopIcon() - Method in class javax.swing. JInternalFrame

返回 JDesktopIcon当这个 JInternalFrame被图标化时使用。

getDesktopIconBorder() - Static method in class javax.swing.plaf.metal. MetalBorders

返回桌面图标的边框实例。

getDesktopManager() - Method in class javax.swing. JDesktopPane

返回处理桌面特定UI操作的 DesktopManger 。

getDesktopManager() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回正确的DesktopManager。

getDesktopPane() - Method in class javax.swing. JInternalFrame

在祖先层级中搜索 JDesktop实例的便捷方法。

getDesktopPane() - Method in class javax.swing. JInternalFrame.JDesktopIcon

方便的方法来 Desktop它所属的 Desktop对象的图标。

getDesktopPaneForComponent(Component) - Static method in class javax.swing. JOptionPane

返回指定组件的桌面窗格。

getDesktopProperty(String) - Method in class java.awt. Toolkit

获取指定的桌面属性的值。

getDesktopPropertyValue(String, Object) - Static method in class javax.swing. LookAndFeel

通过调用 Toolkit.getDefaultToolkit().getDesktopProperty()返回指定的系统桌面属性的 Toolkit.getDefaultToolkit().getDesktopProperty() 。

getDestination() - Method in class java.awt. JobAttributes

指定输出将是打印机还是使用这些属性的作业文件。

getDestination() - Method in class javax.imageio. ImageReadParam

返回 BufferedImage目前由设置 setDestination方法，或者 null ，如果没有设置。

getDestination(ImageReadParam, Iterator<ImageTypeSpecifier>, int, int) - Static method in class javax.imageio. ImageReader

返回要写入的解码像素数据的 BufferedImage 。

getDestinationBands() - Method in class javax.imageio. ImageReadParam

返回将放置数据的频带索引集。

getDestinationOffset() - Method in class javax.imageio. IIOParam

返回目标图像中要放置像素的偏移量。

getDestinationType() - Method in class javax.imageio. IIOParam

如果通过调用 setDestination(ImageTypeSpecifier)设置，则返回读取的返回图像的类型，如 ImageTypeSpecifier 。

getDetail() - Method in interface com.sun.source.tree. AssertTree

返回详细表达式。

getDetail() - Method in interface javax.xml.soap. SOAPFault

返回此 SOAPFault对象的可选detail元素。

getDetail() - Method in interface org.w3c.dom.events. UIEvent

指定有关 Event一些详细信息，具体取决于事件的类型。

getDetailEntries() - Method in interface javax.xml.soap. Detail

在这个 Detail对象中的所有 DetailEntry获取迭代器。

getDetails() - Method in class javafx.application. Preloader.ErrorNotification

检索错误的描述。

getDeterminant() - Method in class java.awt.geom. AffineTransform

返回变换的矩阵表示的行列式。

getDevice() - Method in class java.awt. GraphicsConfiguration

返回GraphicsDevice与此相关GraphicsConfiguration 。

getDevice() - Method in class java.awt. PointerInfo

返回 GraphicsDevice这个鼠标指针是在创建这个 PointerInfo的那一刻。

getDevice(MidiDevice.Info) - Method in class javax.sound.midi.spi. MidiDeviceProvider

获取由info对象表示的设备的实例。

getDeviceConfiguration() - Method in class java.awt. Graphics2D

返回与此 Graphics2D关联的设备配置。

getDeviceInfo() - Method in interface javax.sound.midi. MidiDevice

获取有关设备的信息，包括其Java类和包含其名称，供应商和描述的 Strings 。

getDeviceInfo() - Method in class javax.sound.midi.spi. MidiDeviceProvider

获取表示 MidiDeviceProvider提供的设备或设备的信息对象集。

getDiagnostic() - Method in interface com.sun.source.doctree. ErroneousTree

返回诊断对象，提供有关正文文本错误的原因的详细信息。

getDiagnosticOptions() - Method in interface com.sun.management. HotSpotDiagnosticMXBean

返回所有诊断选项的 VMOption对象的列表。

getDiagnostics() - Method in class javax.tools. DiagnosticCollector

返回此对象收集的诊断的列表视图。

getDialog() - Method in class java.awt. JobAttributes

返回对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。

getDialogPane() - Method in class javafx.scene.control. Dialog

获取属性dialogPane的值。

getDialogTitle() - Method in class javax.swing. JFileChooser

获取 JFileChooser的标题栏中的字符串。

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回此对话框的标题

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf. FileChooserUI

返回对话框标题。

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getDialogTitle方法。

getDialogType() - Method in class javax.swing. JFileChooser

返回此对话框的类型。

getDifferenceMode() - Method in class javax.management.monitor. CounterMonitor

获取所有观察到的MBean共有的差异模式标志值。

getDifferenceMode() - Method in interface javax.management.monitor. CounterMonitorMBean

获取差分模式标志值。

getDifferenceMode() - Method in class javax.management.monitor. GaugeMonitor

获取所有观察到的MBean共有的差异模式标志值。

getDifferenceMode() - Method in interface javax.management.monitor. GaugeMonitorMBean

获取差分模式标志值。

getDiffuseColor() - Method in class javafx.scene.paint. PhongMaterial

获取属性diffuseColor的值。

getDiffuseConstant() - Method in class javafx.scene.effect. Lighting

获取属性diffuseConstant的值。

getDiffuseMap() - Method in class javafx.scene.paint. PhongMaterial

获取属性diffuseMap的值。

getDigestAlgorithm() - Method in class java.security.spec. MGF1ParameterSpec

返回掩码生成函数使用的消息摘要的算法名称。

getDigestAlgorithm() - Method in class java.security.spec. PSSParameterSpec

返回消息摘要算法名称。

getDigestAlgorithm() - Method in class javax.crypto.spec. OAEPParameterSpec

返回消息摘要算法名称。

getDigestAlgorithm() - Method in class jdk.security.jarsigner. JarSigner

返回此 JarSigner的摘要算法。

getDigestInputStream() - Method in interface javax.xml.crypto.dsig. Reference

如果启用了 reference caching ，则返回预消化的输入流。

getDigestLength() - Method in class java.security. MessageDigest

以字节为单位返回摘要的长度，如果提供程序不支持此操作，并且实现不可克隆，则返回0。

getDigestMethod() - Method in interface javax.xml.crypto.dsig. Reference

返回此 Reference的摘要方法。

getDigestValue() - Method in interface javax.xml.crypto.dsig. Reference

返回此 Reference的摘要值。

getDigit() - Method in class java.text. DecimalFormatSymbols

获取用于图案中数字的字符。

getDimAnnotations() - Method in interface com.sun.source.tree. NewArrayTree

返回每个维度表达式上的注释。

getDimension() - Method in class javax.management.openmbean. ArrayType

返回此 ArrayType实例描述的阵列的维度。

getDimension(Object) - Method in class javax.swing. UIDefaults

如果 key的值是 Dimension返回，否则返回 null 。

getDimension(Object) - Static method in class javax.swing. UIManager

从默认值返回维度。

getDimension(Object, Locale) - Method in class javax.swing. UIDefaults

如果值 key对于给定 Locale是 Dimension返回它，否则返回 null 。

getDimension(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回维度。

getDimensions() - Method in interface com.sun.source.tree. NewArrayTree

返回类型的维度表达式。

getDir() - Method in interface org.w3c.dom.html. HTMLElement

指定定向中性文本的基本方向和表的方向性。

getDirection() - Method in class javax.swing.plaf.basic. BasicArrowButton

返回箭头的方向。

getDirection() - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

获得方向。

getDirection() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的方向属性定义。

getDirectionality(char) - Static method in class java.lang. Character

返回给定字符的Unicode方向属性。

getDirectionality(int) - Static method in class java.lang. Character

返回给定字符的Unicode方向性属性（Unicode代码点）。

getDirectives() - Method in interface com.sun.source.tree. ModuleTree

返回模块声明中的指令。

getDirectives() - Method in interface javax.lang.model.element. ModuleElement

返回此模块声明中包含的伪指令。

getDirectories() - Method in class javax.swing.plaf.basic. BasicDirectoryModel

返回目录列表。

getDirectory() - Method in class java.awt. FileDialog

获取此文件对话框的目录。

getDirectory() - Method in class javax.imageio.plugins.tiff. TIFFField

返回相关联的 TIFFDirectory （如果可用）。

getDirectory() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

要记住UI中当前选择的目录的属性。

getDirectoryName() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回目录名称。

getDirectoryName() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

返回目录名称。

getDirtyRegion(JComponent) - Method in class javax.swing. RepaintManager

返回组件当前的脏区域。

getDisabled() - Method in interface org.w3c.dom.html. HTMLButtonElement

在这种情况下，控件不可用。

getDisabled() - Method in interface org.w3c.dom.html. HTMLInputElement

在这种情况下，控件不可用。

getDisabled() - Method in interface org.w3c.dom.html. HTMLLinkElement

启用/禁用链接。

getDisabled() - Method in interface org.w3c.dom.html. HTMLOptGroupElement

在这种情况下，控件不可用。

getDisabled() - Method in interface org.w3c.dom.html. HTMLOptionElement

在这种情况下，控件不可用。

getDisabled() - Method in interface org.w3c.dom.html. HTMLSelectElement

在这种情况下，控件不可用。

getDisabled() - Method in interface org.w3c.dom.html. HTMLStyleElement

启用/禁用样式表。

getDisabled() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

在这种情况下，控件不可用。

getDisabled() - Method in interface org.w3c.dom.stylesheets. StyleSheet

如果样式表应用于文档， false 。

getDisabledIcon() - Method in class javax.swing. AbstractButton

返回按钮禁用时使用的图标。

getDisabledIcon() - Method in class javax.swing. JLabel

返回标签禁用时使用的图标。

getDisabledIcon(JComponent, Icon) - Method in class javax.swing. LookAndFeel

返回一个禁用外观的 Icon 。

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.plaf.metal. MetalLookAndFeel

返回一个禁用外观的 Icon 。

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

getDisabledIconAt(int) - Method in class javax.swing. JTabbedPane

在 index返回标签禁用图标。

getDisabledObjectNames() - Method in class javax.management.relation. MBeanServerNotificationFilter

获取禁用的所有ObjectNames。

getDisabledSelectedIcon() - Method in class javax.swing. AbstractButton

返回按钮在禁用和选择时使用的图标。

getDisabledSelectedIcon(JComponent, Icon) - Method in class javax.swing. LookAndFeel

返回一个 Icon ，供被同样选择的禁用组件使用。

getDisabledSelectedIcon(JComponent, Icon) - Method in class javax.swing.plaf.metal. MetalLookAndFeel

返回一个 Icon用于还被选中的禁用组件。

getDisabledTextColor() - Method in class javax.swing.plaf.metal. MetalButtonUI

返回禁用文字的颜色。

getDisabledTextColor() - Method in class javax.swing.plaf.metal. MetalRadioButtonUI

返回禁用文字的颜色。

getDisabledTextColor() - Method in class javax.swing.plaf.metal. MetalToggleButtonUI

返回禁用文字的颜色。

getDisabledTextColor() - Method in class javax.swing.text. JTextComponent

获取用于呈现禁用的文本的当前颜色。

getDiscard() - Method in class java.net. HttpCookie

返回cookie的丢弃属性

getDisclosureNode() - Method in class javafx.scene.control. TreeCell

返回此TreeCell中设置的当前披露节点。

getDisclosureNode() - Method in class javafx.scene.control. TreeTableRow

返回此TreeTableCell中设置的当前披露节点。

getDismissDelay() - Method in class javax.swing. ToolTipManager

返回解雇延迟值。

getDisplay() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的显示属性定义。

getDisplayCountry() - Method in class java.util. Locale

返回适合显示给用户的区域设置国家/地区的名称。

getDisplayCountry(String, Locale) - Method in class java.util.spi. LocaleNameProvider

返回给定的 IETF BCP47区域代码（ISO 3166国家代码或UN M.49区域代码）的本地化名称以及适合向用户显示的给定区域设置。

getDisplayCountry(Locale) - Method in class java.util. Locale

返回适合显示给用户的区域设置国家/地区的名称。

getDisplayedDataIterator(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. XYChart

XYChart维护当前显示的所有项目的列表，其中包括所有当前数据+最近删除的正在淡出的数据项。

getDisplayedMnemonic() - Method in class javax.swing. JLabel

返回指示助记键的键码。

getDisplayedMnemonicIndex() - Method in class javax.swing. AbstractButton

返回字符，作为索引，外观和感觉应提供装饰用于表示助记符。

getDisplayedMnemonicIndex() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

提供关于 getDisplayName中视觉识别为助记符的字符索引的外观和感觉的提示。

getDisplayedMnemonicIndex() - Method in class javax.swing. JLabel

返回字符，作为索引，外观和感觉应提供装饰用于表示助记符。

getDisplayedMnemonicIndexAt(int) - Method in class javax.swing. JTabbedPane

返回字符，作为索引，外观和感觉应提供装饰用于表示助记符。

getDisplayedSeriesIterator() - Method in class javafx.scene.chart. XYChart

XYChart维护当前显示的所有系列的列表，其中包括所有当前系列+最近被删除的系列，它们正在被褪色（动画）过程中。

getDisplayFormatter() - Method in class javax.swing.text. DefaultFormatterFactory

返回 JFormattedTextField.AbstractFormatter ，如果使用 JFormattedTextField未被编辑和任一的值不是空，或该值为空和null formatter的尚未指定。

getDisplayLanguage() - Method in class java.util. Locale

返回适合显示给用户的语言环境语言的名称。

getDisplayLanguage(String, Locale) - Method in class java.util.spi. LocaleNameProvider

返回给定的 IETF BCP47语言代码和适用于向用户显示的给定语言环境的本地化名称。

getDisplayLanguage(Locale) - Method in class java.util. Locale

返回适合显示给用户的语言环境语言的名称。

getDisplayMode() - Method in class java.awt. GraphicsDevice

返回此 GraphicsDevice的当前显示模式。

getDisplayModes() - Method in class java.awt. GraphicsDevice

返回此 GraphicsDevice可用的所有显示模式。

getDisplayName() - Method in class java.beans. FeatureDescriptor

获取此功能的本地化显示名称。

getDisplayName() - Method in class java.net. NetworkInterface

获取此网络接口的显示名称。

getDisplayName() - Method in class java.util. Currency

获取适合显示默认 值为DISPLAY区域设置的货币的名称。

getDisplayName() - Method in class java.util. Locale

返回适合显示给用户的区域设置的名称。

getDisplayName() - Method in class java.util. TimeZone

返回此 TimeZone的较长标准时间名称，适合在默认语言环境中呈现给用户。

getDisplayName() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

返回一个包含面板显示名称的字符串。

getDisplayName(boolean, int) - Method in class java.util. TimeZone

返回此 TimeZone指定的 style中的名称，该名称适用于以默认语言环境向用户呈现。

getDisplayName(boolean, int, Locale) - Method in class java.util. TimeZone

返回此 TimeZone指定的 style中的一个名称，适用于在指定的 style中向用户 locale 。

getDisplayName(int, int, Locale) - Method in class java.util. Calendar

返回给定的 style和 locale中的日历 field的字符串表示 locale 。

getDisplayName(String, boolean, int, Locale) - Method in class java.util.spi. TimeZoneNameProvider

返回适合在指定语言环境中向用户呈现的给定时区ID的名称。

getDisplayName(String, int, int, int, Locale) - Method in class java.util.spi. CalendarNameProvider

返回给定的 style和 locale中的日历 field value的字符串表示（显示名称）。

getDisplayName(String, Locale) - Method in class java.util.spi. CurrencyNameProvider

返回适合显示给用户的货币名称。

getDisplayName(TextStyle, Locale) - Method in interface java.time.chrono. Chronology

获取这个年表的文本表示。

getDisplayName(TextStyle, Locale) - Method in interface java.time.chrono. Era

获得这个时代的文字表现。

getDisplayName(TextStyle, Locale) - Method in class java.time.chrono. JapaneseEra

获得这个时代的文字表现。

getDisplayName(TextStyle, Locale) - Method in enum java.time. DayOfWeek

获取文本表示，如“星期一”或“星期五”。

getDisplayName(TextStyle, Locale) - Method in enum java.time. Month

获取文本表示，如“1月”或“12月”。

getDisplayName(TextStyle, Locale) - Method in class java.time. ZoneId

获取区域的文字表示，例如“英国时间”或“+02：00”。

getDisplayName(Locale) - Method in enum java.time.temporal. ChronoField

getDisplayName(Locale) - Method in interface java.time.temporal. TemporalField

获取所请求语言环境中字段的显示名称。

getDisplayName(Locale) - Method in class java.util. Currency

获取适用于显示指定区域设置的货币的名称。

getDisplayName(Locale) - Method in class java.util. Locale

返回适合显示给用户的区域设置的名称。

getDisplayName(Locale) - Method in class java.util. TimeZone

返回此 TimeZone的较长标准时间名称，适用于在指定的 locale向用户 locale 。

getDisplayNames(int, int, Locale) - Method in class java.util. Calendar

返回一个 Map其中包含给定的 style和 locale中的日历 field所有名称及其对应的字段值。

getDisplayNames(String, int, int, Locale) - Method in class java.util.spi. CalendarNameProvider

返回 Map包含的所有字符串表示（显示名称） Calendar field给定 style和 locale及其相应的字段值。

getDisplayNode() - Method in class javafx.scene.control.skin. ColorPickerSkin

该方法应该返回一个将位于ComboBox'按钮'区域内的节点。

getDisplayNode() - Method in class javafx.scene.control.skin. ComboBoxBaseSkin

该方法应该返回一个将位于ComboBox'按钮'区域内的节点。

getDisplayNode() - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

该方法应该返回一个将位于ComboBox'按钮'区域内的节点。

getDisplayNode() - Method in class javafx.scene.control.skin. DatePickerSkin

该方法应该返回一个将位于ComboBox'按钮'区域内的节点。

getDisplayPosition(String) - Method in class javafx.scene.chart. CategoryAxis

获取给定值的沿该轴的显示位置。

getDisplayPosition(T) - Method in class javafx.scene.chart. Axis

获取给定值的沿该轴的显示位置。

getDisplayPosition(T) - Method in class javafx.scene.chart. ValueAxis

获取给定值的沿该轴的显示位置。

getDisplayScript() - Method in class java.util. Locale

返回适合显示给用户的区域设置脚本的名称。

getDisplayScript(String, Locale) - Method in class java.util.spi. LocaleNameProvider

返回给定的 IETF BCP47脚本代码和适用于向用户显示的给定语言环境的本地化名称。

getDisplayScript(Locale) - Method in class java.util. Locale

返回适合显示给用户的区域设置脚本的名称。

getDisplaySize() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

返回显示区域的计算大小。

getDisplayText() - Method in class javafx.scene.input. KeyCharacterCombination

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

getDisplayText() - Method in class javafx.scene.input. KeyCodeCombination

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

getDisplayText() - Method in class javafx.scene.input. KeyCombination

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

getDisplayVariant() - Method in class java.util. Locale

返回适合显示给用户的区域设置变体代码的名称。

getDisplayVariant(String, Locale) - Method in class java.util.spi. LocaleNameProvider

返回适用于向用户显示的给定变体代码和给定语言环境的本地化名称。

getDisplayVariant(Locale) - Method in class java.util. Locale

返回适合显示给用户的区域设置变体代码的名称。

getDivider() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回顶部组件之间的分隔符。

getDividerBorderSize() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

已过时。
从Java 2平台v1.3开始，将边框设置在分隔线上。

getDividerLocation() - Method in class javax.swing. JSplitPane

返回传递给 setDividerLocation的最后一个值。

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回分隔符的位置，这可能与拆分器认为分隔符的位置有所不同。

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getDividerLocation方法。

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf. SplitPaneUI

返回分隔符的位置。

getDividerPositions() - Method in class javafx.scene.control. SplitPane

返回一个包含每个分隔符位置的double数组。

getDividers() - Method in class javafx.scene.control. SplitPane

返回此SplitPane中所有分隔符的不可修改列表。

getDividerSize() - Method in class javax.swing. JSplitPane

返回分隔符的大小。

getDividerSize() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

返回分隔符的大小，即分割窗口为HORIZONTAL_SPLIT时的宽度，或VERTICAL_SPLIT的高度。

getDivisions() - Method in class javafx.scene.shape. Cylinder

检索用于生成此气瓶的分区属性。

getDivisions() - Method in class javafx.scene.shape. Sphere

检索用于生成此球体的分区属性。

getDivisionType() - Method in class javax.sound.midi. MidiFileFormat

获取MIDI文件的时序分割类型。

getDivisionType() - Method in class javax.sound.midi. Sequence

获取此序列的时序分割类型。

getDoc() - Method in interface javax.print. MultiDoc

获取当前的doc对象。

getDocComment() - Method in class com.sun.source.util. DocTreePath

返回与此路径相关联的DocCommentTree。

getDocComment(TreePath) - Method in class com.sun.source.util. Trees

返回给定TreePath标识的Tree节点的doc注释（如果有）。

getDocComment(Element) - Method in interface javax.lang.model.util. Elements

返回元素的文档（“Javadoc”）注释的文本。

getDocCommentTree(TreePath) - Method in class com.sun.source.util. DocTrees

返回由给定TreePath标识的Tree节点的doc注释树（如果有）。

getDocCommentTree(Element) - Method in class com.sun.source.util. DocTrees

返回给定元素的文档注释树。

getDocCommentTree(Element, String) - Method in class com.sun.source.util. DocTrees

返回相对于给定元素指定路径的给定文件的doc注释树。

getDocCommentTree(FileObject) - Method in class com.sun.source.util. DocTrees

返回给定文件的文档注释树。

getDocFlavor() - Method in interface javax.print. Doc

确定此文档对象将提供其打印数据的文档风格。

getDocFlavor() - Method in class javax.print. SimpleDoc

确定此文档对象将提供其打印数据的文档风格。

getDockingColor() - Method in class javax.swing.plaf.basic. BasicToolBarUI

获取在停靠区域上显示的颜色

getDocTreeFactory() - Method in class com.sun.source.util. DocTrees

返回一个用于创建 DocTree对象的实用程序对象。

getDocTreePath(FileObject, PackageElement) - Method in class com.sun.source.util. DocTrees

返回包含给定文件的文档注释树的文档树路径。

getDocTrees() - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回一个 DocTrees实用程序类的实例。

getDoctype() - Method in interface org.w3c.dom. Document

与本文档相关联的文档类型声明（参见 DocumentType ）。

getDocument() - Method in class javafx.scene.web. WebEngine

获取属性文档的值。

getDocument() - Method in interface javax.swing.event. DocumentEvent

获取来源于更改事件的文档。

getDocument() - Method in class javax.swing.text. AbstractDocument.AbstractElement

检索基础模型。

getDocument() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

获取来源于更改事件的文档。

getDocument() - Method in class javax.swing.text. AbstractWriter

获取文档。

getDocument() - Method in class javax.swing.text. DocumentFilter.FilterBypass

返回发生突变的文档。

getDocument() - Method in interface javax.swing.text. Element

获取与此元素关联的文档。

getDocument() - Method in class javax.swing.text. JTextComponent

获取与编辑器相关联的模型。

getDocument() - Method in class javax.swing.text. View

获取与视图关联的模型。

getDocument() - Method in interface org.w3c.dom.views. AbstractView

来源 DocumentView其中这是一个 AbstractView 。

getDocumentBase() - Method in class java.applet. Applet

已过时。

获取嵌入此小程序的文档的URL。

getDocumentBase() - Method in interface java.applet. AppletStub

已过时。

获取嵌入小程序的文档的URL。

getDocumentBase() - Method in class javafx.application. HostServices

获取此应用程序的文档基础URI。

getDocumentBase() - Method in class javax.management.loading. MLetContent

获取MLet文本文件的基本URL。

getDocumentElement() - Method in interface org.w3c.dom. Document

这是一个方便属性，允许直接访问作为文档的文档元素的子节点。

getDocumentFilter() - Method in class javax.swing. JFormattedTextField.AbstractFormatter

如果您希望提供一个 DocumentFilter来限制可以输入的 DocumentFilter ，那么子类和覆盖。

getDocumentFilter() - Method in class javax.swing.text. AbstractDocument

返回负责插入/删除过滤的 DocumentFilter 。

getDocumentFilter() - Method in class javax.swing.text. DefaultFormatter

返回 DocumentFilter用于限制可以输入到 JFormattedTextField 。

getDocumentListeners() - Method in class javax.swing.text. AbstractDocument

返回在此文档上注册的所有文档监听器的数组。

getDocumentProperties() - Method in class javax.swing.text. AbstractDocument

支持管理一组属性。

getDocumentTypeDeclaration() - Method in interface javax.xml.stream.events. DTD

以字符串形式返回整个文档类型声明，包括内部DTD子集。

getDocumentURI() - Method in interface org.w3c.dom. Document

文件的位置或 null如果未定义）或 Document是使用 DOMImplementation.createDocument创建的。

getDoInput() - Method in class java.net. URLConnection

返回该值为 URLConnection的 doInput标志。

getDomain() - Method in class com.sun.security.auth.module. NTSystem

获取当前NT用户的域。

getDomain() - Method in class java.net. HttpCookie

返回为此cookie设置的域名。

getDomain() - Method in class javax.management. ObjectName

返回域部分。

getDomain() - Method in interface org.w3c.dom.html. HTMLDocument

服务于该文档的服务器的域名，如果服务器无法通过域名标识， null 。

getDomainCombiner() - Method in class java.security. AccessControlContext

获取 DomainCombiner与此 AccessControlContext相关联。

getDomains() - Method in interface javax.management. MBeanServer

getDomains() - Method in interface javax.management. MBeanServerConnection

返回任何MBean当前注册的域列表。

getDomains(Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.getDomains() 。

getDomains(Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getDomains(Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

getDomainSID() - Method in class com.sun.security.auth.module. NTSystem

获取当前NT用户域的可打印SID。

getDomConfig() - Method in interface org.w3c.dom. Document

调用 Document.normalizeDocument()时使用的配置。

getDomConfig() - Method in interface org.w3c.dom.ls. LSParser

解析输入源时使用的 DOMConfiguration对象。

getDomConfig() - Method in interface org.w3c.dom.ls. LSSerializer

LSSerializer在序列化DOM节点时使用的 DOMConfiguration对象。

getDOMImplementation() - Method in class javax.xml.parsers. DocumentBuilder

获取一个DOMImplementation对象的实例。

getDOMImplementation(String) - Method in class org.w3c.dom.bootstrap. DOMImplementationRegistry

返回具有所需功能的第一个实现，如果没有找到，则返回 null 。

getDOMImplementation(String) - Method in interface org.w3c.dom. DOMImplementationSource

一种请求支持指定功能的第一个DOM实现的方法。

getDOMImplementationList(String) - Method in class org.w3c.dom.bootstrap. DOMImplementationRegistry

返回支持所需功能的实现列表。

getDOMImplementationList(String) - Method in interface org.w3c.dom. DOMImplementationSource

一种方法来请求支持指定特征和版本的DOM实现的列表，如

getDoOutput() - Method in class java.net. URLConnection

返回此值 URLConnection的 doOutput标志。

getDot() - Method in class javax.swing.event. CaretEvent

获取插入符号的位置。

getDot() - Method in interface javax.swing.text. Caret

获取插入符号的当前位置。

getDot() - Method in class javax.swing.text. DefaultCaret

获取插入符号的当前位置。

getDotBias() - Method in class javax.swing.text. DefaultCaret

返回插入位置的偏移。

getDouble() - Method in class java.nio. ByteBuffer

读取双重值的相对 get方法。

getDouble(int) - Method in class java.nio. ByteBuffer

绝对 获取读取双重值的方法。

getDouble(int) - Method in interface java.sql. CallableStatement

以Java编程语言 double指定的JDBC DOUBLE参数的值作为 double 。

getDouble(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 double此 ResultSet对象的当前行中指定列的值。

getDouble(Object) - Method in class java.lang.reflect. Field

通过扩展转换获取类型为 double的静态或实例字段的 double或可转换为类型为 double的另一个基元类型的值。

getDouble(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中的索引组件的值，如 double 。

getDouble(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 double JDBC DOUBLE参数的值。

getDouble(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 double此 ResultSet对象的当前行中指定列的值。

getDouble(String, double) - Method in class java.util.prefs. AbstractPreferences

实现 getDouble方法按照在本说明书中 Preferences.getDouble(String,double) 。

getDouble(String, double) - Method in class java.util.prefs. Preferences

返回由此首选项节点中与指定键相关联的字符串表示的双精度值。

getDoubleBufferMaximumSize() - Method in class javax.swing. RepaintManager

返回最大双缓冲区大小。

getDoubleParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

将参数返回为双精度的方便方法。

getDpi() - Method in class javafx.stage. Screen

获得 Screen的分辨率（每英寸点数）。

getDragAction() - Method in class java.awt.dnd. DragGestureEvent

返回表示用户选择的动作的 int 。

getDragboard() - Method in class javafx.scene.input. DragEvent

可用于传输数据的拖板。

getDragEnabled() - Method in class javax.swing. JColorChooser

获取 dragEnabled属性的值。

getDragEnabled() - Method in class javax.swing. JFileChooser

获取 dragEnabled属性的值。

getDragEnabled() - Method in class javax.swing. JList

返回是否启用自动拖动处理。

getDragEnabled() - Method in class javax.swing. JTable

返回是否启用自动拖动处理。

getDragEnabled() - Method in class javax.swing. JTree

返回是否启用自动拖动处理。

getDragEnabled() - Method in class javax.swing.text. JTextComponent

返回是否启用自动拖动处理。

getDraggedColumn() - Method in class javax.swing.table. JTableHeader

返回拖动列，当且仅当拖动正在进行时，否则返回 null 。

getDraggedDistance() - Method in class javax.swing.table. JTableHeader

返回列的水平距离与其原始位置，当且仅当拖动正在进行时。

getDragImage() - Method in class javax.swing. TransferHandler

返回拖动图像。

getDragImageOffset() - Method in class javax.swing. TransferHandler

返回要拖动的图像的锚点偏移量。

getDragMode() - Method in class javax.swing. JDesktopPane

获取桌面窗格使用的当前“拖动样式”。

getDragOrigin() - Method in class java.awt.dnd. DragGestureEvent

返回 Point中的坐标 Component在开始拖动。

getDragSource() - Method in class java.awt.dnd. DragGestureEvent

返回 DragSource 。

getDragSource() - Method in class java.awt.dnd. DragGestureRecognizer

这个方法返回 DragSource这个 DragGestureRecognizer将会用来处理拖放操作。

getDragSource() - Method in class java.awt.dnd. DragSourceContext

返回 DragSource认为这个实例 DragSourceContext 。

getDragSourceContext() - Method in class java.awt.dnd. DragSourceEvent

此方法返回发起事件的 DragSourceContext 。

getDragSourceListeners() - Method in class java.awt.dnd. DragSource

获取所有 DragSourceListener注册此 DragSource 。

getDragSourceMotionListeners() - Method in class java.awt.dnd. DragSource

获取所有 DragSourceMotionListener注册了这个 DragSource 。

getDragThreshold() - Static method in class java.awt.dnd. DragSource

返回拖动手势运动阈值。

getDragView() - Method in class javafx.scene.input. Dragboard

获取用作拖动视图的图像。

getDragViewOffsetX() - Method in class javafx.scene.input. Dragboard

获取拖动视图图像光标的x位置。

getDragViewOffsetY() - Method in class javafx.scene.input. Dragboard

获取拖动视图图像光标的y位置。

getDrawGraphics() - Method in class java.awt. Component.BltBufferStrategy

getDrawGraphics() - Method in class java.awt. Component.FlipBufferStrategy

getDrawGraphics() - Method in class java.awt.image. BufferStrategy

为绘图缓冲区创建图形上下文。

getDrawMode() - Method in class javafx.scene.shape. Shape3D

获取属性drawMode的值。

getDrawsLayeredHighlights() - Method in class javax.swing.text. DefaultHighlighter

返回绘制分层的亮点。

getDriver(String) - Static method in class java.sql. DriverManager

尝试查找了解给定URL的驱动程序。

getDriverMajorVersion() - Method in interface java.sql. DatabaseMetaData

检索此JDBC驱动程序的主要版本号。

getDriverMinorVersion() - Method in interface java.sql. DatabaseMetaData

检索此JDBC驱动程序的次要版本号。

getDriverName() - Method in interface java.sql. DatabaseMetaData

检索此JDBC驱动程序的名称。

getDrivers() - Static method in class java.sql. DriverManager

使用当前调用者可以访问的所有当前加载的JDBC驱动程序检索枚举。

getDriverVersion() - Method in interface java.sql. DatabaseMetaData

以 String检索此JDBC驱动程序的版本号。

getDropAction() - Method in class java.awt.dnd. DragSourceDragEvent

此方法返回目标放置操作与拖动源支持的放置操作集合的逻辑交集。

getDropAction() - Method in class java.awt.dnd. DragSourceDropEvent

此方法返回一个 int表示由目标执行的关于该删除主题的操作。

getDropAction() - Method in class java.awt.dnd. DropTargetDragEvent

此方法返回用户放置操作。

getDropAction() - Method in class java.awt.dnd. DropTargetDropEvent

此方法返回用户放置操作。

getDropAction() - Method in class javax.swing. TransferHandler.TransferSupport

返回为下降选择的动作，当该 TransferSupport表示下降时。

getDropLineRect(JTree.DropLocation) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回下拉线的无界框。

getDropLocation() - Method in class javax.swing. JList

返回在组件中的DnD操作期间该组件应该可视地指示为放置位置的位置，如果没有显示当前位置，则返回 null 。

getDropLocation() - Method in class javax.swing. JTable

返回在组件中的DnD操作期间该组件应该可视地指示为放置位置的位置，或者如果当前没有显示位置，则返回 null 。

getDropLocation() - Method in class javax.swing. JTree

返回在组件的DnD操作期间该组件应该可视地指示为放置位置的位置，如果目前未显示任何位置，则返回 null 。

getDropLocation() - Method in class javax.swing.text. JTextComponent

返回在组件中的DnD操作期间该组件应该可视地指示为放置位置的位置，如果没有显示当前位置，则返回 null 。

getDropLocation() - Method in class javax.swing. TransferHandler.TransferSupport

返回组件的当前（非 null ）放置位置，当此 TransferSupport表示下降。

getDropMode() - Method in class javax.swing. JList

返回此组件的放置模式。

getDropMode() - Method in class javax.swing. JTable

返回此组件的放置模式。

getDropMode() - Method in class javax.swing. JTree

返回此组件的放置模式。

getDropMode() - Method in class javax.swing.text. JTextComponent

返回此组件的放置模式。

getDropPoint() - Method in class javax.swing. TransferHandler.DropLocation

返回下拉点，表示鼠标在组件内的当前位置。

getDropSuccess() - Method in class java.awt.dnd. DragSourceDropEvent

此方法返回一个 boolean指示下降是否成功。

getDropTarget() - Method in class java.awt. Component

获取 DropTarget与此相关 Component 。

getDropTarget() - Method in class java.awt.dnd. DropTargetContext

此方法返回 DropTarget与此相关 DropTargetContext 。

getDropTargetContext() - Method in class java.awt.dnd. DropTarget

获取 DropTargetContext与此 DropTarget相关联。

getDropTargetContext() - Method in class java.awt.dnd. DropTargetEvent

此方法返回 DropTargetContext与此相关 DropTargetEvent 。

getDSTSavings() - Method in class java.util. SimpleTimeZone

返回时钟在夏令时期间提前的时间（以毫秒为单位）。

getDSTSavings() - Method in class java.util. TimeZone

返回添加到本地标准时间以获取本地挂钟时间的时间量。

getDTD(String) - Static method in class javax.swing.text.html.parser. DTD

返回一个指定的 name的DTD。

getDTDHandler() - Method in class org.xml.sax.helpers. ParserAdapter

返回当前的DTD处理程序。

getDTDHandler() - Method in class org.xml.sax.helpers. XMLFilterImpl

获取当前的DTD事件处理程序。

getDTDHandler() - Method in interface org.xml.sax. XMLReader

返回当前的DTD处理程序。

getDTDType() - Method in interface javax.xml.stream.events. Attribute

获取此属性的类型，默认为String“CDATA”

getDuration() - Method in class com.sun.management. GcInfo

返回此GC的已用时间（以毫秒为单位）。

getDuration() - Method in enum java.time.temporal. ChronoUnit

在ISO日历系统中获取本机的预计持续时间。

getDuration() - Method in interface java.time.temporal. TemporalUnit

获取此单位的持续时间，这可能是一个估计。

getDuration() - Method in class java.time.zone. ZoneOffsetTransition

获取转换的持续时间。

getDuration() - Method in class javafx.animation. FadeTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.animation. FillTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.animation. PathTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.animation. PauseTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.animation. RotateTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.animation. ScaleTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.animation. StrokeTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.animation. TranslateTransition

获取属性持续时间的值。

getDuration() - Method in class javafx.scene.media. Media

检索介质的持续时间（以秒为单位）。

getDurationConverter() - Static method in class javafx.css. StyleConverter

返回一个StyleConverter ，将持续时间的字符串表示形式转换为Duration 。

getEarliestSequenceNumber() - Method in class javax.management.remote. NotificationResult

返回仍在缓冲区中的最早通知的序列号。

getEarlyReflectionDelay() - Method in class javax.sound.sampled. ReverbType

返回早期反射延迟时间（以微秒为单位）。

getEarlyReflectionIntensity() - Method in class javax.sound.sampled. ReverbType

以分贝返回早期反射强度。

getEastPane() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回东面。

getEchoChar() - Method in class java.awt. TextField

获取要用于回显的字符。

getEchoChar() - Method in class javax.swing. JPasswordField

返回要用于回显的字符。

getEcmaError() - Method in exception jdk.nashorn.api.scripting. NashornException

返回底层的ECMA错误对象（如果可用）。

getEdgeCondition() - Method in class java.awt.image. ConvolveOp

返回边缘条件。

getEdit() - Method in class javax.swing.event. UndoableEditEvent

返回编辑值。

getEditFormatter() - Method in class javax.swing.text. DefaultFormatterFactory

返回 JFormattedTextField.AbstractFormatter ，如果使用 JFormattedTextField正在编辑和任一的值不是空，或该值为空和null formatter的尚未指定。

getEditingCell() - Method in class javafx.scene.control. TableView

获取属性editingCell的值。

getEditingCell() - Method in class javafx.scene.control. TreeTableView

获取属性editingCell的值。

getEditingColumn() - Method in class javax.swing. JTable

返回包含当前正在编辑的单元格的列的索引。

getEditingIndex() - Method in class javafx.scene.control. ListView

返回ListView中当前正在编辑的项目的索引，如果没有编辑任何项目，则返回-1。

getEditingItem() - Method in class javafx.scene.control. TreeView

返回TreeView中当前正在编辑的TreeItem，如果没有编辑任何项目，则返回null。

getEditingPath() - Method in class javax.swing. JTree

返回当前正在编辑的元素的路径。

getEditingPath(JTree) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回正在编辑的元素的路径。

getEditingPath(JTree) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getEditingPath方法。

getEditingPath(JTree) - Method in class javax.swing.plaf. TreeUI

返回正在编辑的元素的路径。

getEditingRow() - Method in class javax.swing. JTable

返回包含当前正在编辑的单元格的行的索引。

getEditor() - Method in class javafx.scene.control. ComboBox

获取属性编辑器的值。

getEditor() - Method in class javafx.scene.control. DatePicker

获取属性编辑器的值。

getEditor() - Method in class javafx.scene.control.skin. ColorPickerSkin

ColorPicker不使用主文本字段，因此此方法已被覆盖以返回null。

getEditor() - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

子类负责获取编辑器。

getEditor() - Method in class javafx.scene.control.skin. ComboBoxPopupControl

子类负责获取编辑器。

getEditor() - Method in class javafx.scene.control.skin. DatePickerSkin

子类负责获取编辑器。

getEditor() - Method in class javafx.scene.control. Spinner

获取属性编辑器的值。

getEditor() - Method in class javafx.scene.control. TextInputDialog

返回此对话框中使用的TextField 。

getEditor() - Method in class javax.swing. JComboBox

返回编辑器，用于在 JComboBox字段中绘制和编辑所选项目。

getEditor() - Method in class javax.swing. JSpinner

返回显示的组件，并可能更改模型的值。

getEditor(ActionEvent) - Method in class javax.swing.text. StyledEditorKit.StyledTextAction

获取操作的目标编辑器。

getEditorComponent() - Method in interface javax.swing. ComboBoxEditor

返回应该添加到该编辑器的树层次结构中的组件

getEditorComponent() - Method in class javax.swing. JTable

返回处理编辑会话的组件。

getEditorComponent() - Method in class javax.swing.plaf.basic. BasicComboBoxEditor

getEditorKit() - Method in class javax.swing. JEditorPane

获取当前安装的套件以处理内容。

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.basic. BasicEditorPaneUI

获取用户界面的EditorKit。

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.basic. BasicTextUI

获取用户界面的EditorKit。

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getEditorKit方法。

getEditorKit(JTextComponent) - Method in class javax.swing.plaf. TextUI

获取为正在编辑的文档类型设置策略的服务的绑定。

getEditorKitClassNameForContentType(String) - Static method in class javax.swing. JEditorPane

返回当前注册的 EditorKit的类型的类名 type 。

getEditorKitForContentType(String) - Method in class javax.swing. JEditorPane

获取编辑器套件以用于给定类型的内容。

getEditorSearchPath() - Static method in class java.beans. PropertyEditorManager

获取将搜索属性编辑器的包名称。

getEffect() - Method in class javafx.scene. Node

获取属性效果的值。

getEffect(Effect) - Method in class javafx.scene.canvas. GraphicsContext

获取下一次绘图调用后应用的效果的副本。

getEffectConverter() - Static method in class javafx.css. StyleConverter

返回一个 StyleConverter ，一个解析后的表示转换 Effect至 Effect

getEffectiveKeyBits() - Method in class javax.crypto.spec. RC2ParameterSpec

以位为单位返回有效密钥大小。

getEffectiveNodeOrientation() - Method in class javafx.scene. Node

获取属性effectiveNodeOrientation的值。

getEffectiveNodeOrientation() - Method in class javafx.scene. Scene

获取属性effectiveNodeOrientation的值。

getElem(int) - Method in class java.awt.image. DataBuffer

从第一个（默认）库返回所请求的数据数组元素作为整数。

getElem(int) - Method in class java.awt.image. DataBufferByte

从第一个（默认）库返回所请求的数据数组元素。

getElem(int) - Method in class java.awt.image. DataBufferDouble

从第一个（默认）库返回所请求的数据数组元素作为 int 。

getElem(int) - Method in class java.awt.image. DataBufferFloat

从第一个（默认）库返回所请求的数据数组元素作为 int 。

getElem(int) - Method in class java.awt.image. DataBufferInt

从第一个（默认）库返回所请求的数据数组元素。

getElem(int) - Method in class java.awt.image. DataBufferShort

从第一个（默认）库返回所请求的数据数组元素。

getElem(int) - Method in class java.awt.image. DataBufferUShort

从第一个（默认）库返回所请求的数据数组元素。

getElem(int, int) - Method in class java.awt.image. DataBuffer

从指定的库返回所请求的数据数组元素作为整数。

getElem(int, int) - Method in class java.awt.image. DataBufferByte

从指定的库返回所请求的数据数组元素。

getElem(int, int) - Method in class java.awt.image. DataBufferDouble

从指定的库返回请求的数据数组元素作为 int 。

getElem(int, int) - Method in class java.awt.image. DataBufferFloat

从指定的库返回请求的数据数组元素作为 int 。

getElem(int, int) - Method in class java.awt.image. DataBufferInt

从指定的库返回所请求的数据数组元素。

getElem(int, int) - Method in class java.awt.image. DataBufferShort

从指定的库返回所请求的数据数组元素。

getElem(int, int) - Method in class java.awt.image. DataBufferUShort

从指定的库返回所请求的数据数组元素。

getElemDouble(int) - Method in class java.awt.image. DataBuffer

从第一个（默认）库返回所请求的数据数组元素作为双精度。

getElemDouble(int) - Method in class java.awt.image. DataBufferDouble

从第一个（默认）库返回所请求的数据数组元素作为 double 。

getElemDouble(int) - Method in class java.awt.image. DataBufferFloat

从第一个（默认）库返回所请求的数据数组元素作为 double 。

getElemDouble(int, int) - Method in class java.awt.image. DataBuffer

将所请求的数据数组元素从指定的库返回为双精度。

getElemDouble(int, int) - Method in class java.awt.image. DataBufferDouble

从指定的库返回请求的数据数组元素作为 double 。

getElemDouble(int, int) - Method in class java.awt.image. DataBufferFloat

从指定的库返回请求的数据数组元素作为 double 。

getElement() - Method in interface javax.swing.event. DocumentEvent.ElementChange

返回表示的元素。

getElement() - Method in class javax.swing.text. AbstractDocument.ElementEdit

返回底层元素。

getElement() - Method in class javax.swing.text.html.parser. TagElement

返回元素。

getElement() - Method in class javax.swing.text. View

获取该视图映射到的对象的结构部分。

getElement(int) - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取一个子元素。

getElement(int) - Method in class javax.swing.text. AbstractDocument.BranchElement

获取一个子元素。

getElement(int) - Method in class javax.swing.text. AbstractDocument.LeafElement

获取一个子元素。

getElement(int) - Method in interface javax.swing.text. Element

在给定索引处获取子元素。

getElement(int) - Method in class javax.swing.text.html.parser. DTD

通过索引获取元素。

getElement(DocTreePath) - Method in class com.sun.source.util. DocTrees

返回给定的DocTreePath的叶节点引用的语言模型元素，如果未知的话null 。

getElement(TreePath) - Method in class com.sun.source.util. Trees

返回给定TreePath标识的Tree节点的元素。

getElement(String) - Method in class javax.swing.text.html. HTMLDocument

返回给定id为 Attribute的元素。

getElement(String) - Method in class javax.swing.text.html.parser. DTD

通过名称获取元素。

getElement(MatrixType, int, int) - Method in class javafx.scene.transform. Transform

获取转换矩阵的指定元素。

getElement(Element, Object, Object) - Method in class javax.swing.text.html. HTMLDocument

返回的子元素 e包含属性， attribute与价值 value或者 null如果一个也没有找到。

getElement(DOMResult) - Method in class javax.xml.bind.annotation. W3CDomHandler

getElement(ResultT) - Method in interface javax.xml.bind.annotation. DomHandler

一旦发送到Result 。

getElementAdded() - Method in class javafx.collections. SetChangeListener.Change

获取新的元素。

getElementAt(int) - Method in class javax.swing. DefaultComboBoxModel

getElementAt(int) - Method in class javax.swing. DefaultListModel

返回指定索引处的组件。

getElementAt(int) - Method in interface javax.swing. ListModel

返回指定索引处的值。

getElementAt(int) - Method in class javax.swing.plaf.basic. BasicDirectoryModel

getElementAt(int) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxModel

getElementAt(int) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxModel

getElementById(String) - Method in class javax.xml.crypto.dom. DOMCryptoContext

返回具有指定ID属性值的 Element 。

getElementById(String) - Method in interface org.w3c.dom. Document

返回具有给定值的ID属性的 Element 。

getElementCount() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取元素的子元素数。

getElementCount() - Method in class javax.swing.text. AbstractDocument.BranchElement

获取元素的子元素数。

getElementCount() - Method in class javax.swing.text. AbstractDocument.LeafElement

返回子元素的数量。

getElementCount() - Method in interface javax.swing.text. Element

获取此元素包含的子元素的数量。

getElementDescription(String, Locale) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回 String含有指定元素，或的描述 null 。

getElementDescription(String, Locale) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

返回一个 String其中包含命名元素的描述，或 null 。

getElementIndex(int) - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取最接近给定模型偏移量的子元素索引。

getElementIndex(int) - Method in class javax.swing.text. AbstractDocument.BranchElement

获取最接近给定模型偏移量的子元素索引。

getElementIndex(int) - Method in class javax.swing.text. AbstractDocument.LeafElement

获取最接近给定模型偏移量的子元素索引。

getElementIndex(int) - Method in interface javax.swing.text. Element

获取最接近给定偏移量的子元素索引。

getElementIterator() - Method in class javax.swing.text. AbstractWriter

获取ElementIterator。

getElementMaxChildren(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最大子 CHILD_POLICY_REPEAT 。

getElementMaxChildren(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getElementMinChildren(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最 CHILD_POLICY_REPEAT 。

getElementMinChildren(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getElementName() - Method in interface javax.xml.soap. SOAPElement

返回此 SOAPElement对象的名称。

getElementName(Object) - Method in class javax.xml.bind. JAXBIntrospector

获取xml元素qname为 jaxbElement 。

getElementOpenType() - Method in class javax.management.openmbean. ArrayType

返回此 ArrayType实例描述的阵列中包含的元素值的 打开类型 。

getElementQName() - Method in interface javax.xml.soap. SOAPElement

返回此 SOAPElement对象的qname。

getElementRemoved() - Method in class javafx.collections. SetChangeListener.Change

获取旧元素。

getElements() - Method in class com.sun.source.util. JavacTask

返回用于处理程序元素的实用程序对象。

getElements() - Method in class javafx.scene.shape. Path

获取此路径的路径元素的可观察列表。

getElements() - Method in class javax.swing. ButtonGroup

返回参与此组的所有按钮。

getElements() - Method in interface jdk.nashorn.api.tree. ArrayLiteralTree

返回Array元素表达式的列表。

getElements() - Method in interface org.w3c.dom.html. HTMLFormElement

返回表单中所有控件元素的集合。

getElements(Vector<Element>) - Method in class javax.swing.text.html.parser. ContentModel

更新elemVec与该contentModel的一部分的元素列表。

getElementsAnnotatedWith(Class<? extends Annotation>) - Method in interface javax.annotation.processing. RoundEnvironment

返回使用给定注释类型注释的元素。

getElementsAnnotatedWith(TypeElement) - Method in interface javax.annotation.processing. RoundEnvironment

返回使用给定注释类型注释的元素。

getElementsAnnotatedWithAny(Set<Class<? extends Annotation>>) - Method in interface javax.annotation.processing. RoundEnvironment

返回使用一个或多个给定注释类型注释的元素。

getElementsAnnotatedWithAny(TypeElement...) - Method in interface javax.annotation.processing. RoundEnvironment

返回使用一个或多个给定注释类型注释的元素。

getElementsAt(HTMLDocument, int) - Method in class javax.swing.text.html. HTMLEditorKit.HTMLTextAction

返回包含 offset的元素的数组。

getElementsByName(String) - Method in interface org.w3c.dom.html. HTMLDocument

返回其值为 name值（可能为空）的集合，其值由 elementName给出。

getElementsByTagName(String) - Method in class javax.imageio.metadata. IIOMetadataNode

getElementsByTagName(String) - Method in interface org.w3c.dom. Document

以文件顺序返回 NodeList的所有 Elements ，并提供给定的标签名称，并包含在文档中。

getElementsByTagName(String) - Method in interface org.w3c.dom. Element

返回 NodeList所有子孙的 Elements具有给定标记名称，在文档顺序。

getElementsByTagNameNS(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode

相当于 getElementsByTagName(localName) 。

getElementsByTagNameNS(String, String) - Method in interface org.w3c.dom. Document

返回 NodeList的所有 Elements具有给定本地名称和命名空间URI在文档顺序。

getElementsByTagNameNS(String, String) - Method in interface org.w3c.dom. Element

返回 NodeList所有后代的 Elements具有给定本地名称和命名空间URI在文档顺序。

getElementText() - Method in class javax.xml.stream.util. EventReaderDelegate

getElementText() - Method in class javax.xml.stream.util. StreamReaderDelegate

getElementText() - Method in interface javax.xml.stream. XMLEventReader

读取纯文本元素的内容。

getElementText() - Method in interface javax.xml.stream. XMLStreamReader

读取纯文本元素的内容，如果这不是纯文本元素，则抛出异常。

getElementType() - Method in interface com.sun.javadoc. Type

已过时。

如果此类型是数组类型，则返回数组的元素类型。

getElementTypeInfo() - Method in class javax.xml.validation. TypeInfoProvider

返回当前元素的不可变的TypeInfo对象。

getElementUtils() - Method in interface javax.annotation.processing. ProcessingEnvironment

返回一些用于操作元素的实用方法的实现

getElementUtils() - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回一个 Elements实用程序类的实例。

getElementValues() - Method in interface javax.lang.model.element. AnnotationMirror

返回此注释元素的值。

getElementValuesWithDefaults(AnnotationMirror) - Method in interface javax.lang.model.util. Elements

返回注释元素的值，包括默认值。

getElemFloat(int) - Method in class java.awt.image. DataBuffer

作为浮点数从第一个（默认）库返回请求的数据数组元素。

getElemFloat(int) - Method in class java.awt.image. DataBufferDouble

从第一个（默认）库返回所请求的数据数组元素作为 float 。

getElemFloat(int) - Method in class java.awt.image. DataBufferFloat

从第一个（默认）库返回所请求的数据数组元素作为 float 。

getElemFloat(int, int) - Method in class java.awt.image. DataBuffer

以浮点形式从指定的库返回所请求的数据数组元素。

getElemFloat(int, int) - Method in class java.awt.image. DataBufferDouble

从指定的库返回请求的数据数组元素作为 float 。

getElemFloat(int, int) - Method in class java.awt.image. DataBufferFloat

从指定的库返回请求的数据数组元素作为 float 。

getElevation() - Method in class javafx.scene.effect. Light.Distant

获取属性高程的值。

getElevation() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的elevation属性定义。

getEllipsisString() - Method in class javafx.scene.control. Labeled

获取属性ellipsisString的值。

getElseStatement() - Method in interface com.sun.source.tree. IfTree

如果条件为false，则返回要执行的语句，如果没有这样的语句，则返回 null 。

getElseStatement() - Method in interface jdk.nashorn.api.tree. IfTree

返回此'if'语句的then语句。

getEmptyCells() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的empty-cells属性定义。

getEmptySet() - Method in interface javax.swing.text. AbstractDocument.AttributeContext

获取一个空的AttributeSet。

getEmptySet() - Method in class javax.swing.text. StyleContext

获取一个空的AttributeSet。

getEnabledAttributes() - Method in class javax.management. AttributeChangeNotificationFilter

获取此过滤器的所有已启用的属性名称。

getEnabledCipherSuites() - Method in class javax.net.ssl. SSLEngine

返回当前启用此引擎使用的SSL密码套件的名称。

getEnabledCipherSuites() - Method in class javax.net.ssl. SSLServerSocket

返回当前允许新接受连接使用的密码套件列表。

getEnabledCipherSuites() - Method in class javax.net.ssl. SSLSocket

返回当前启用此SSL连接的SSL密码套件的名称。

getEnabledCipherSuites() - Method in class javax.rmi.ssl. SslRMIServerSocketFactory

返回由此工厂创建的服务器套接字接受的SSL连接启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则 null 。

getEnabledObjectNames() - Method in class javax.management.relation. MBeanServerNotificationFilter

获取所有启用的ObjectName。

getEnabledProtocols() - Method in class javax.net.ssl. SSLEngine

返回当前允许与此 SSLEngine一起使用的协议版本的名称。

getEnabledProtocols() - Method in class javax.net.ssl. SSLServerSocket

返回当前启用以便新接受的连接使用的协议的名称。

getEnabledProtocols() - Method in class javax.net.ssl. SSLSocket

返回当前允许在此连接上使用的协议版本的名称。

getEnabledProtocols() - Method in class javax.rmi.ssl. SslRMIServerSocketFactory

返回在此工厂创建的服务器套接字所接受的SSL连接上启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则 null 。

getEnabledTypes() - Method in class javax.management. NotificationFilterSupport

获取此过滤器的所有启用的通知类型。

getEnableRetransmissions() - Method in class javax.net.ssl. SSLParameters

返回是否启用DTLS握手重传。

getEnableSessionCreation() - Method in class javax.net.ssl. SSLEngine

如果此引擎可能建立新的SSL会话，则返回true。

getEnableSessionCreation() - Method in class javax.net.ssl. SSLServerSocket

如果可以通过从该服务器套接字创建的套接字建立新的SSL会话，则返回true。

getEnableSessionCreation() - Method in class javax.net.ssl. SSLSocket

如果此套接字可能建立新的SSL会话，则返回true。

getEnclosedElements() - Method in interface javax.lang.model.element. Element

返回由这个元素直接包围的松散元素。

getEnclosedElements() - Method in interface javax.lang.model.element. ModuleElement

返回此模块中的包。

getEnclosedElements() - Method in interface javax.lang.model.element. PackageElement

返回此包中的 top-level类和接口。

getEnclosedElements() - Method in interface javax.lang.model.element. TypeElement

返回在此类或接口中直接声明的字段，方法，构造函数和成员类型。

getEnclosingClass() - Method in interface com.sun.source.tree. Scope

返回包含此作用域位置的最内部类型元素。

getEnclosingClass() - Method in class java.lang. Class

返回底层类的即时封闭类。

getEnclosingConstructor() - Method in class java.lang. Class

如果这个Class对象表示构造函数中的本地或匿名类，则返回一个Constructor对象，该对象表示基础类的立即封闭构造函数。

getEnclosingElement() - Method in interface javax.lang.model.element. Element

返回这个元素所在的最内层元素。

getEnclosingElement() - Method in interface javax.lang.model.element. ModuleElement

返回 null因为模块未被其他元素包围。

getEnclosingElement() - Method in interface javax.lang.model.element. PackageElement

如果存在这样的模块，则返回包围模块; 否则返回null 。

getEnclosingElement() - Method in interface javax.lang.model.element. TypeElement

返回顶级类型的包，并返回 nested类型的立即包含的元素。

getEnclosingElement() - Method in interface javax.lang.model.element. TypeParameterElement

返回此类型参数的 generic element 。

getEnclosingElement() - Method in interface javax.lang.model.element. VariableElement

返回此变量的包围元素。

getEnclosingExpression() - Method in interface com.sun.source.tree. NewClassTree

返回包含的表达式，如果没有，则返回 null 。

getEnclosingMethod() - Method in interface com.sun.source.tree. Scope

返回包含此范围位置的最内层可执行元素。

getEnclosingMethod() - Method in class java.lang. Class

如果此Class对象表示方法中的本地或匿名类，则返回一个表示基础类的即时封闭方法的方法对象。

getEnclosingScope() - Method in interface com.sun.source.tree. Scope

返回包围范围。

getEnclosingType() - Method in interface javax.lang.model.type. DeclaredType

如果没有包围实例，则返回最内层封闭实例的类型或类型为 NoType的 NONE 。

getEncoded() - Method in class java.security. AlgorithmParameters

返回其主要编码格式的参数。

getEncoded() - Method in class java.security.cert. Certificate

返回此证书的编码形式。

getEncoded() - Method in class java.security.cert. CertPath

使用默认编码返回此认证路径的编码形式。

getEncoded() - Method in class java.security.cert. PolicyQualifierInfo

返回此 PolicyQualifierInfo的ASN.1 DER编码形式。

getEncoded() - Method in class java.security.cert. X509CRL

返回此CRL的ASN.1 DER编码形式。

getEncoded() - Method in class java.security.cert. X509CRLEntry

返回此CRL条目的ASN.1 DER编码形式，即内部SEQUENCE。

getEncoded() - Method in interface java.security. Key

返回其主要编码格式的密钥，如果此密钥不支持编码，则返回null。

getEncoded() - Method in class java.security. PKCS12Attribute

返回属性的ASN.1 DER编码。

getEncoded() - Method in class java.security.spec. EncodedKeySpec

返回编码的密钥。

getEncoded() - Method in class java.security.spec. PKCS8EncodedKeySpec

返回按照PKCS＃8标准编码的关键字节。

getEncoded() - Method in class java.security.spec. X509EncodedKeySpec

返回按照X.509标准编码的关键字节。

getEncoded() - Method in class javax.crypto. EncryptedPrivateKeyInfo

返回此对象的ASN.1编码。

getEncoded() - Method in class javax.crypto.spec. SecretKeySpec

返回此密钥的密钥材料。

getEncoded() - Method in class javax.net.ssl. SNIServerName

返回此服务器名称的编码服务器名称值的副本。

getEncoded() - Method in class javax.security.auth.kerberos. EncryptionKey

返回此键的关键材料。

getEncoded() - Method in class javax.security.auth.kerberos. KerberosCredMessage

返回KRB_CRED消息的DER编码形式。

getEncoded() - Method in class javax.security.auth.kerberos. KerberosKey

返回此密钥的密钥材料。

getEncoded() - Method in class javax.security.auth.kerberos. KerberosTicket

返回整个票证的ASN.1编码。

getEncoded() - Method in class javax.security.auth.x500. X500Principal

以ASN.1 DER编码形式返回可分辨名称。

getEncoded() - Method in class javax.security.cert. Certificate

已过时。

返回此证书的编码形式。

getEncoded(String) - Method in class java.security. AlgorithmParameters

返回在指定方案中编码的参数。

getEncoded(String) - Method in class java.security.cert. CertPath

使用指定的编码返回此认证路径的编码形式。

getEncodedValue() - Method in class javax.naming.ldap. BasicControl

检索控制的ASN.1 BER编码值。

getEncodedValue() - Method in interface javax.naming.ldap. Control

检索LDAP控制的ASN.1 BER编码值。

getEncodedValue() - Method in interface javax.naming.ldap. ExtendedRequest

检索LDAP扩展操作请求的ASN.1 BER编码值。

getEncodedValue() - Method in interface javax.naming.ldap. ExtendedResponse

检索LDAP扩展操作响应的ASN.1 BER编码值。

getEncodedValue() - Method in class javax.naming.ldap. StartTlsRequest

检索StartTLS请求的ASN.1 BER编码值。

getEncodedValue() - Method in class javax.naming.ldap. StartTlsResponse

检索StartTLS响应的ASN.1 BER编码值。

getEncoder() - Static method in class java.util. Base64

返回一个Base64.Encoder ，它使用Basic类型base64编码方案进行编码。

getEncoding() - Method in class java.io. InputStreamReader

返回此流使用的字符编码的名称。

getEncoding() - Method in class java.io. OutputStreamWriter

返回此流使用的字符编码的名称。

getEncoding() - Method in class java.util.logging. Handler

返回这个 Handler的字符编码。

getEncoding() - Method in class javax.sound.sampled. AudioFormat

获取此格式的声音编码类型。

getEncoding() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

获取当前输出编码的便利方法。

getEncoding() - Method in interface javax.xml.crypto.dsig. XMLObject

返回此 XMLObject的编码URI。

getEncoding() - Method in class javax.xml.stream.util. StreamReaderDelegate

getEncoding() - Method in interface javax.xml.stream. XMLStreamReader

如果已知返回输入编码，如果未知则返回null。

getEncoding() - Method in interface org.w3c.dom.css. CSSCharsetRule

在这个 @charset规则中使用的编码信息。

getEncoding() - Method in interface org.w3c.dom.ls. LSInput

字符编码，如果知道。

getEncoding() - Method in interface org.w3c.dom.ls. LSOutput

用于输出的字符编码。

getEncoding() - Method in interface org.xml.sax.ext. Locator2

返回实体的字符编码的名称。

getEncoding() - Method in class org.xml.sax.ext. Locator2Impl

返回encoding属性的当前值。

getEncoding() - Method in class org.xml.sax. InputSource

获取字节流或URI的字符编码。

getEncodings() - Method in class java.security.cert. CertPath

返回此认证路径支持的编码的迭代，并使用默认编码。

getEncodingStyle() - Method in interface javax.xml.soap. SOAPElement

返回此 SOAPElement对象的编码样式。

getEncryptedData() - Method in class javax.crypto. EncryptedPrivateKeyInfo

返回加密数据。

getEnctype() - Method in interface org.w3c.dom.html. HTMLFormElement

提交表单的内容类型一般为“application / x-www-form-urlencoded”。

getEnd() - Method in class javafx.scene.control. IndexRange

返回范围的结束位置（排除）。

getEnd() - Method in class javax.swing. SpinnerDateModel

返回序列中的最后一个 Date 。

getEndCap() - Method in class java.awt. BasicStroke

返回端帽样式。

getEndContainer() - Method in interface org.w3c.dom.ranges. Range

范围结束的节点

getEndIndex() - Method in interface java.text. CharacterIterator

返回文本的结束索引。

getEndIndex() - Method in class java.text. FieldPosition

检索请求字段中最后一个字符后的字符索引。

getEndIndex() - Method in class java.text. StringCharacterIterator

为String执行CharacterIterator.getEndIndex（）。

getEndIndex() - Method in class javax.accessibility. AccessibleHyperlink

获取此链接结束的超文本文件的索引。

getEndIndex() - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

获取此链接结束的超文本文件的索引

getEndIndex() - Method in class javax.swing.text. Segment

返回文本的结束索引。

getEndMargin() - Method in class javafx.scene.chart. CategoryAxis

获取属性endMargin的值。

getEndOffset() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取元素模型中的结束偏移量。

getEndOffset() - Method in class javax.swing.text. AbstractDocument.BranchElement

获取元素模型中的结束偏移量。

getEndOffset() - Method in class javax.swing.text. AbstractDocument.LeafElement

获取元素模型中的结束偏移量。

getEndOffset() - Method in class javax.swing.text. AbstractWriter

返回要输出的最后一个偏移量。

getEndOffset() - Method in interface javax.swing.text. Element

从文档的开始处获取该元素结束的偏移量。

getEndOffset() - Method in class javax.swing.text. GlyphView

获取该视图负责的模型部分。

getEndOffset() - Method in interface javax.swing.text. Highlighter.Highlight

获取高亮的结束模型偏移量。

getEndOffset() - Method in class javax.swing.text.html. HTMLDocument.Iterator

返回定义当前出现的标记的范围的结尾，并具有相同的属性。

getEndOffset() - Method in class javax.swing.text. View

获取该视图负责的模型部分。

getEndOffset() - Method in interface org.w3c.dom.ranges. Range

Range范围内结束节点的偏移量。

getEndPage() - Method in class javafx.print. PageRange

getEndPoint() - Method in class java.awt.geom. Arc2D

返回圆弧的终点。

getEndPoint() - Method in class java.awt. LinearGradientPaint

返回渐变轴终点的副本。

getEndpointIdentificationAlgorithm() - Method in class javax.net.ssl. SSLParameters

获取端点识别算法。

getEndpointReference() - Method in interface javax.xml.ws. BindingProvider

返回 EndpointReference与此相关 BindingProvider实例。

getEndpointReference(Class<T>) - Method in interface javax.xml.ws. BindingProvider

返回 EndpointReference与此相关 BindingProvider实例。

getEndpointReference(Class<T>, Element...) - Method in class javax.xml.ws. Endpoint

返回 EndpointReference与此相关 Endpoint实例。

getEndpointReference(Class<T>, Element...) - Method in interface javax.xml.ws. WebServiceContext

返回与此端点关联的 EndpointReference 。

getEndpointReference(Element...) - Method in class javax.xml.ws. Endpoint

返回 EndpointReference与此相关 Endpoint实例。

getEndpointReference(Element...) - Method in interface javax.xml.ws. WebServiceContext

返回此端点的 EndpointReference 。

getEndpoints() - Method in class javax.xml.ws. EndpointContext

这给出了应用程序中的端点列表。

getEndPosition() - Method in class javax.swing.text. AbstractDocument

返回表示文档结尾的位置。

getEndPosition() - Method in interface javax.swing.text. Document

返回表示文档结尾的位置。

getEndPosition() - Method in interface javax.tools. Diagnostic

从与此诊断相关联的文件的开头返回指示问题结束的字符偏移量。

getEndPosition() - Method in class jdk.jshell. Diag

从与此诊断相关联的文件的开头返回指示问题结束的字符偏移量。

getEndPosition() - Method in interface jdk.nashorn.api.tree. 树

来源中此树的结束字符偏移量。

getEndPosition(CompilationUnitTree, DocCommentTree, DocTree) - Method in interface com.sun.source.util. DocSourcePositions

返回文件中注释中树的结束位置。

getEndPosition(CompilationUnitTree, Tree) - Method in interface com.sun.source.util. SourcePositions

返回文件中树的结束位置。

getEndTime() - Method in class com.sun.management. GcInfo

从Java虚拟机启动后返回此GC的结束时间（以毫秒为单位）。

getEndTime() - Method in class javax.security.auth.kerberos. KerberosTicket

返回此票证有效期的到期时间。

getEndValue() - Method in class javafx.animation. KeyValue

返回此 KeyValue的结束值

getEndX() - Method in class javafx.scene.paint. LinearGradient

定义渐变轴终点的X坐标。

getEndX() - Method in class javafx.scene.shape. CubicCurve

获取属性endX的值。

getEndX() - Method in class javafx.scene.shape. Line

获取属性endX的值。

getEndX() - Method in class javafx.scene.shape. QuadCurve

获取属性endX的值。

getEndY() - Method in class javafx.scene.paint. LinearGradient

定义渐变轴终点的Y坐标。

getEndY() - Method in class javafx.scene.shape. CubicCurve

获取属性endY的值。

getEndY() - Method in class javafx.scene.shape. Line

获取属性endY的值。

getEndY() - Method in class javafx.scene.shape. QuadCurve

获取属性endY的值。

getEngine() - Method in class javafx.scene.web. WebView

返回 WebEngine对象。

getEngine() - Method in class javax.script. CompiledScript

返回 ScriptEngine其 compile方法创建此 CompiledScript 。

getEngineByExtension(String) - Method in class javax.script. ScriptEngineManager

查找并为给定的分机创建一个 ScriptEngine 。

getEngineByMimeType(String) - Method in class javax.script. ScriptEngineManager

查找并为给定的MIME类型创建一个 ScriptEngine 。

getEngineByName(String) - Method in class javax.script. ScriptEngineManager

查找并为给定的名称创建一个 ScriptEngine 。

getEngineFactories() - Method in class javax.script. ScriptEngineManager

返回一个列表，其元素是发现机制找到的所有 ScriptEngineFactory类的实例。

getEngineName() - Method in interface javax.script. ScriptEngineFactory

返回 ScriptEngine的全名。

getEngineName() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getEngineVersion() - Method in interface javax.script. ScriptEngineFactory

返回 ScriptEngine的版本。

getEngineVersion() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getEntities() - Method in interface javax.xml.stream.events. DTD

返回一个包含在DTD中声明的外部和内部的一般实体的列表。

getEntities() - Method in interface org.w3c.dom. DocumentType

A NamedNodeMap包含在DTD中声明的外部和内部的一般实体。

getEntity(int) - Method in class javax.swing.text.html.parser. DTD

获取一个字符实体。

getEntity(String) - Method in class javax.swing.text.html.parser. DTD

通过名称获取实体。

getEntityResolver() - Method in class org.xml.sax.helpers. ParserAdapter

返回当前的实体解析器。

getEntityResolver() - Method in class org.xml.sax.helpers. XMLFilterImpl

获取当前的实体解析器。

getEntityResolver() - Method in interface org.xml.sax. XMLReader

返回当前的实体解析器。

getEntries() - Method in class java.util.jar. Manifest

返回此清单中包含的条目的地图。

getEntries() - Method in class javafx.scene.web. WebHistory

返回历史记录中所有条目的不可修改的可观察列表。

getEntry(String) - Method in class java.util.jar. JarFile

返回 ZipEntry用于给定基本条目名称 null如果没有找到。

getEntry(String) - Method in class java.util.zip. ZipFile

返回指定名称的zip文件条目，如果找不到则返回null。

getEntry(String, KeyStore.ProtectionParameter) - Method in class java.security. KeyStore

获取具有指定保护参数的指定别名的密钥库 Entry 。

getEntryName() - Method in class java.net. JarURLConnection

返回此连接的条目名称。

getEnumConstants() - Method in class java.lang. Class

返回此枚举类的元素，如果此Class对象不表示枚举类型，则返回null。

getEnumConverter(Class<E>) - Static method in class javafx.css. StyleConverter

返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。

getEnumValueTable() - Method in class javax.print.attribute. EnumSyntax

返回枚举值枚举类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. Chromaticity

返回类Chromaticity的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. ColorSupported

返回ColorSupported类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. Compression

返回类Compression的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. DialogTypeSelection

返回DialogTypeSelection类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. Fidelity

返回类Fidelity的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. Finishings

返回类Finishings的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. JobSheets

返回JobSheets类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. JobState

返回JobState类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. JobStateReason

返回JobStateReason类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. MediaName

返回MediaTray类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. MediaSizeName

返回类MediaSizeName的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. MediaTray

返回MediaTray类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. MultipleDocumentHandling

返回类MultipleDocumentHandling的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. OrientationRequested

返回类OrientationRequested的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. PDLOverrideSupported

返回类PDLOverrideSupported的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. PresentationDirection

返回类PresentationDirection的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. PrinterIsAcceptingJobs

返回PrinterIsAcceptingJobs类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. PrinterState

返回PrinterState类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. PrinterStateReason

返回PrinterStateReason类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. PrintQuality

返回PrintQuality类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. ReferenceUriSchemesSupported

返回ReferenceUriSchemesSupported类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. Severity

返回类Severity的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. SheetCollate

返回SheetCollate类的枚举值表。

getEnumValueTable() - Method in class javax.print.attribute.standard. Sides

返回类Sides的枚举值表。

getenv() - Static method in class java.lang. System

返回当前系统环境的不可修改的字符串映射视图。

getenv(String) - Static method in class java.lang. System

获取指定环境变量的值。

getEnvelope() - Method in class javax.xml.soap. SOAPPart

获取 SOAPEnvelope与此相关联的对象 SOAPPart对象。

getEnvironment() - Method in exception javax.naming. CannotProceedException

检索创建此异常时生效的环境。

getEnvironment() - Method in interface javax.naming. Context

检索此环境有效的环境。

getEnvironment() - Method in class javax.naming. InitialContext

getEon() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回 year XML Schema 1.0 dateTime数据类型字段的 year 。

getEonAndYear() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回 year的XML Schema 1.0 dateTime数据类型字段。

getEpochSecond() - Method in class java.time. Instant

从1970-01-01T00：00：00Z的Java时代获取秒数。

getEra() - Method in interface java.time.chrono. ChronoLocalDate

获得时代，按年表定义。

getEra() - Method in class java.time.chrono. HijrahDate

获得这个时代适用的时代。

getEra() - Method in class java.time.chrono. JapaneseDate

获得这个时代适用的时代。

getEra() - Method in class java.time.chrono. MinguoDate

获得这个时代适用的时代。

getEra() - Method in class java.time.chrono. ThaiBuddhistDate

获得这个时代适用的时代。

getEra() - Method in class java.time. LocalDate

获得这个时代适用的时代。

getEras() - Method in class java.text. DateFormatSymbols

获取时代字符串。

getError() - Method in class javafx.scene.media. Media

返回媒体中遇到的任何错误。

getError() - Method in class javafx.scene.media. MediaPlayer

检索 error属性的值或 null如果没有错误。

getErrorCode() - Method in exception java.sql. SQLException

检索此 SQLException对象的供应商特定异常代码。

getErrorCode() - Method in exception javax.xml.bind. JAXBException

获取供应商特定的错误代码

getErrorCode() - Method in exception javax.xml.bind. TypeConstraintException

获取供应商特定的错误代码

getErrorHandler() - Method in class javax.xml.validation. SchemaFactory

获取当前的ErrorHandler设置为这个SchemaFactory 。

getErrorHandler() - Method in class javax.xml.validation. Validator

获取当前的ErrorHandler设置为这个Validator 。

getErrorHandler() - Method in class javax.xml.validation. ValidatorHandler

获取当前的ErrorHandler设置为ValidatorHandler 。

getErrorHandler() - Method in class org.xml.sax.helpers. ParserAdapter

返回当前的错误处理程序。

getErrorHandler() - Method in class org.xml.sax.helpers. XMLFilterImpl

获取当前的错误事件处理程序。

getErrorHandler() - Method in interface org.xml.sax. XMLReader

返回当前的错误处理程序。

getErrorIndex() - Method in class java.text. ParsePosition

检索发生错误的索引，如果未设置错误索引，则返回-1。

getErrorIndex() - Method in exception java.time.format. DateTimeParseException

返回发现错误的索引。

getErrorIndex() - Method in exception java.util. IllformedLocaleException

返回发现错误的索引。

getErrorListener() - Method in class javax.xml.transform. Transformer

获取有效转换的错误事件处理程序。

getErrorListener() - Method in class javax.xml.transform. TransformerFactory

获取TransformerFactory的错误事件处理程序。

getErrorManager() - Method in class java.util.logging. Handler

检索此处理程序的ErrorManager。

getErrorOffset() - Method in exception java.text. ParseException

返回发现错误的位置。

getErrorsAny() - Method in class java.awt. MediaTracker

返回遇到错误的所有介质的列表。

getErrorsID(int) - Method in class java.awt. MediaTracker

返回具有遇到错误的指定ID的介质列表。

getErrorStream() - Method in class java.lang. Process

返回连接到进程的错误输出的输入流。

getErrorStream() - Method in class java.net. HttpURLConnection

如果连接失败但服务器发送有用的数据，则返回错误流。

getErrorTrees() - Method in interface com.sun.source.tree. ErroneousTree

返回保存在此节点中的任何树。

getErrorWriter() - Method in interface javax.script. ScriptContext

返回用于显示错误输出的 Writer 。

getErrorWriter() - Method in class javax.script. SimpleScriptContext

返回 Writer用于显示错误输出。

getEscapeProcessing() - Method in class javax.sql.rowset. BaseRowSet

确定是否为此 RowSet对象启用了转义处理。

getEscapeProcessing() - Method in interface javax.sql. RowSet

检索是否启用此 RowSet对象的转义处理。

getEstimatedMajorSpan() - Method in class javax.swing.text. AsyncBoxView

目前估计是主要跨度吗？

getEtchedBorderUIResource() - Static method in class javax.swing.plaf. BorderUIResource

返回蚀刻的边界UI资源。

getEtchedInsets() - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils

返回由 drawEtchedRect()绘制的边框占用的空间

getEtchType() - Method in class javax.swing.border. EtchedBorder

返回蚀刻边界上设置的蚀刻类型。

getEvent() - Method in interface org.w3c.dom.html. HTMLScriptElement

留作将来使用。

getEventAllocator() - Method in class javax.xml.stream. XMLInputFactory

获取由此工厂创建的流使用的分配器

getEventContext() - Method in class javax.naming.event. NamingEvent

检索触发此事件的事件源。

getEventContext() - Method in class javax.naming.event. NamingExceptionEvent

检索 EventContext了这个事件。

getEventDispatcher() - Method in class javafx.scene. Node

获取属性eventDispatcher的值。

getEventDispatcher() - Method in class javafx.scene. Scene

获取属性eventDispatcher的值。

getEventDispatcher() - Method in class javafx.stage. Window

获取属性eventDispatcher的值。

getEventHandler() - Method in class javax.xml.bind. Binder

返回当前事件处理程序或默认事件处理程序（如果尚未设置）。

getEventHandler() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

getEventHandler() - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

返回当前事件处理程序或默认事件处理程序（如果尚未设置）。

getEventHandler() - Method in interface javax.xml.bind. Marshaller

返回当前事件处理程序或默认事件处理程序（如果尚未设置）。

getEventHandler() - Method in interface javax.xml.bind. Unmarshaller

返回当前事件处理程序或默认事件处理程序（如果尚未设置）。

getEventHandler() - Method in interface javax.xml.bind. Validator

已过时。
自JAXB2.0起

getEventMask() - Method in class java.awt.event. AWTEventListenerProxy

返回与侦听器关联的事件掩码。

getEventPhase() - Method in interface org.w3c.dom.events. Event

用于指示当前正在评估事件流的哪个阶段。

getEventPropertyName() - Method in class java.beans. EventHandler

返回在应用于目标的操作中应该使用的事件的属性。

getEvents() - Method in class javax.xml.bind.util. ValidationEventCollector

返回一组ValidationEvent对象，其中包含每个收集的错误和警告的副本。

getEventSetDescriptors() - Method in interface java.beans. BeanInfo

返回bean定义此bean触发的事件类型的事件描述符。

getEventSetDescriptors() - Method in class java.beans. SimpleBeanInfo

否认事件集的知识。

getEventSetId() - Method in class javafx.scene.input. TouchEvent

获取表示相同多点触摸动作的一组触摸事件的顺序号。

getEventType() - Method in class javafx.event. ActionEvent

getEventType() - Method in class javafx.event. Event

获取此事件的事件类型。

getEventType() - Method in class javafx.scene.control. DialogEvent

getEventType() - Method in class javafx.scene.input. ContextMenuEvent

getEventType() - Method in class javafx.scene.input. DragEvent

getEventType() - Method in class javafx.scene.input. GestureEvent

getEventType() - Method in class javafx.scene.input. InputEvent

getEventType() - Method in class javafx.scene.input. InputMethodEvent

getEventType() - Method in class javafx.scene.input. KeyEvent

getEventType() - Method in class javafx.scene.input. MouseDragEvent

getEventType() - Method in class javafx.scene.input. MouseEvent

getEventType() - Method in class javafx.scene.input. RotateEvent

getEventType() - Method in class javafx.scene.input. ScrollEvent

getEventType() - Method in class javafx.scene.input. SwipeEvent

getEventType() - Method in class javafx.scene.input. TouchEvent

getEventType() - Method in class javafx.scene.input. ZoomEvent

getEventType() - Method in class javafx.scene.media. MediaErrorEvent

getEventType() - Method in class javafx.stage. WindowEvent

getEventType() - Method in class javax.swing.event. HyperlinkEvent

获取事件的类型。

getEventType() - Method in interface javax.xml.stream.events. XMLEvent

返回此事件的整数代码。

getEventType() - Method in class javax.xml.stream.util. StreamReaderDelegate

getEventType() - Method in interface javax.xml.stream. XMLStreamReader

返回指示光标指向的事件类型的整数代码。

getExactSizeIfKnown() - Method in interface java.util. Spliterator

方便的方法返回 Spliterator.estimateSize()如果这个Spliterator是 Spliterator.SIZED ，否则 -1 。

getException() - Method in class java.awt.event. InvocationEvent

返回在执行Runnable的 run()方法时捕获的任何异常。

getException() - Method in exception java.lang. ClassNotFoundException

返回在尝试加载类时发生错误时引发的异常。

getException() - Method in error java.lang. ExceptionInInitializerError

返回在静态初始化期间发生的异常，导致此错误被创建。

getException() - Method in exception java.security. PrivilegedActionException

返回导致此 PrivilegedActionException的特权计算抛出的异常。

getException() - Method in class java.util.concurrent. ForkJoinTask

返回由基本计算引发的异常，或者如果已取消， null如果没有，则返回 CancellationException ，否则 null方法尚未完成。

getException() - Method in class javafx.concurrent. Service

获取属性异常的值。

getException() - Method in class javafx.concurrent. Task

获取属性异常的值。

getException() - Method in interface javafx.concurrent. Worker

表示工人运行时发生的异常（如果有）。

getException() - Method in class javafx.scene.image. Image

获取属性异常的值。

getException() - Method in class javafx.scene.web. WebErrorEvent

返回与此事件关联的异常。

getException() - Method in class javax.naming.event. NamingExceptionEvent

检索抛出的异常。

getException() - Method in class javax.naming.ldap. SortResponseControl

检索适合结果代码的NamingException。

getException() - Method in interface javax.naming.ldap. UnsolicitedNotification

检索使用服务器发送的信息构造的异常。

getException() - Method in error javax.xml.parsers. FactoryConfigurationError

返回导致引发此异常的实际异常（如果有的话）。

getException() - Method in error javax.xml.stream. FactoryConfigurationError

返回嵌套异常（如果有）

getException() - Method in exception javax.xml.transform. TransformerException

此方法检索此异常包装的异常。

getException() - Method in error javax.xml.transform. TransformerFactoryConfigurationError

返回导致引发此异常的实际异常（如果有的话）。

getException() - Method in class jdk.dynalink.linker. GuardedInvocation

返回异常类型，如果调用抛出应该使该被守卫的调用的链接失效。

getException() - Method in exception org.xml.sax. SAXException

返回嵌入式异常（如果有）。

getExceptionClassName() - Method in exception jdk.jshell. EvalException

返回在执行客户机中抛出的Throwable子类的名称。

getExceptionListener() - Method in class java.beans. Encoder

获取此流的异常处理程序。

getExceptionListener() - Method in class java.beans. XMLDecoder

获取此流的异常处理程序。

getExceptionName() - Method in interface com.sun.source.doctree. ThrowsTree

返回正在记录的异常的名称。

getExceptionTypes() - Method in class java.lang.reflect. Constructor

返回一个 Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。

getExceptionTypes() - Method in class java.lang.reflect. Executable

返回一个 Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。

getExceptionTypes() - Method in class java.lang.reflect. 方法

返回一个 Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。

getExclusiveOwnerThread() - Method in class java.util.concurrent.locks. AbstractOwnableSynchronizer

返回最后设置的线程为 setExclusiveOwnerThread ，如果从未设置，则返回 null 。

getExclusiveQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回一个包含可能正在等待以独占模式获取的线程的集合。

getExclusiveQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回一个包含可能正在等待以独占模式获取的线程的集合。

getExecuteExistingDelayedTasksAfterShutdownPolicy() - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

获取关于是否执行现有延迟任务的策略，即使这个执行者已经是 shutdown 。

getExecutor() - Method in class com.sun.net.httpserver. HttpServer

如果指定了 HttpServer.setExecutor(Executor) ，则返回此服务器的Executor对象，如果没有指定，则 返回 null 。

getExecutor() - Method in class java.util.concurrent. SubmissionPublisher

返回用于异步传递的执行程序。

getExecutor() - Method in class javafx.concurrent. Service

获取属性执行器的值。

getExecutor() - Method in class javax.xml.ws. Endpoint

返回此 Endpoint实例的执行者。

getExecutor() - Method in class javax.xml.ws. Service

返回这个 Service实例的执行器。

getExecutor() - Method in class javax.xml.ws.spi. ServiceDelegate

返回这个 Service实例的执行器。

getExemptionMechanism() - Method in class javax.crypto. Cipher

返回与此密码一起使用的豁免机制对象。

getExp() - Method in exception javax.management. BadBinaryOpValueExpException

返回发起异常的 ValueExp 。

getExpandableContent() - Method in class javafx.scene.control. DialogPane

返回对话框可扩展内容节点（如果已设置），否则返回null。

getExpandedDescendants(TreePath) - Method in class javax.swing. JTree

返回一个 Enumeration路径的后裔 parent当前展开。

getExpandedIcon() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回展开的图标。

getExpandedIcon() - Method in class javax.swing.plaf.synth. SynthTreeUI

返回展开的图标。

getExpandedItemCount() - Method in class javafx.scene.control. TreeTableView

获取属性expandedItemCount的值。

getExpandedItemCount() - Method in class javafx.scene.control. TreeView

获取属性expandedItemCount的值。

getExpandedPane() - Method in class javafx.scene.control. Accordion

在手风琴中获得扩大的“TitledPane”。

getExpandedState(TreePath) - Method in class javax.swing.tree. AbstractLayoutCache

如果路径被展开且可见，则返回true。

getExpandedState(TreePath) - Method in class javax.swing.tree. FixedHeightLayoutCache

如果路径被展开且可见，则返回true。

getExpandedState(TreePath) - Method in class javax.swing.tree. VariableHeightLayoutCache

如果路径被展开且可见，则返回true。

getExpandEntityReferences() - Method in interface org.w3c.dom.traversal. NodeIterator

该标志的值确定实体引用节点的子节点是否可见 NodeIterator 。

getExpandEntityReferences() - Method in interface org.w3c.dom.traversal. TreeWalker

该标志的值确定实体引用节点的子节点是否可见 TreeWalker 。

getExpandsSelectedPaths() - Method in class javax.swing. JTree

返回 expandsSelectedPaths属性。

getExpectedPolicies() - Method in interface java.security.cert. PolicyNode

返回在待处理的下一个证书中满足此节点有效策略的一组预期策略。

getExpiration() - Method in class java.net. URLConnection

返回 expires标题字段的值。

getExpirationDate() - Method in class javax.jnlp. DownloadService2.ResourceSpec

返回资源到期的时间。

getExplanation() - Method in exception javax.naming. NamingException

检索与此异常相关的说明。

getExponent() - Method in class java.security.spec. RSAOtherPrimeInfo

返回素数的指数。

getExponent(double) - Static method in class java.lang. Math

返回在 double的表示中使用的无偏指数。

getExponent(double) - Static method in class java.lang. StrictMath

返回在 double的表示中使用的无偏指数。

getExponent(float) - Static method in class java.lang. Math

返回在 float的表示中使用的无偏指数。

getExponent(float) - Static method in class java.lang. StrictMath

返回 float的表示中使用的无偏指数。

getExponentSeparator() - Method in class java.text. DecimalFormatSymbols

返回用于将尾数与指数分隔开的字符串。

getExponentSize() - Method in class javax.crypto.spec. DHGenParameterSpec

返回随机指数（私有值）的位大小。

getExportedKeys(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索引用给定表的主键列（由表导出的外键）的外键列的描述。

getExportName() - Method in interface jdk.nashorn.api.tree. ExportEntryTree

返回条目的导出名称。

getExpression() - Method in interface com.sun.source.tree. ArrayAccessTree

返回正在访问的数组的表达式。

getExpression() - Method in interface com.sun.source.tree. AssignmentTree

返回分配给变量的表达式。

getExpression() - Method in interface com.sun.source.tree. CaseTree

返回case的表达式，如果这是默认情况，则返回 null 。

getExpression() - Method in interface com.sun.source.tree. CompoundAssignmentTree

返回复合赋值右侧的表达式。

getExpression() - Method in interface com.sun.source.tree. EnhancedForLoopTree

返回产生控制变量值的表达式。

getExpression() - Method in interface com.sun.source.tree. ExpressionStatementTree

返回构成该语句的表达式。

getExpression() - Method in interface com.sun.source.tree. InstanceOfTree

返回要测试的表达式。

getExpression() - Method in interface com.sun.source.tree. MemberSelectTree

返回要为其选择成员的表达式。

getExpression() - Method in interface com.sun.source.tree. ParenthesizedTree

返回括号内的表达式。

getExpression() - Method in interface com.sun.source.tree. ReturnTree

返回要返回的表达式。

getExpression() - Method in interface com.sun.source.tree. SwitchTree

返回 switch语句的表达式。

getExpression() - Method in interface com.sun.source.tree. SynchronizedTree

返回要同步的表达式。

getExpression() - Method in interface com.sun.source.tree. ThrowTree

返回要抛出的表达式。

getExpression() - Method in interface com.sun.source.tree. TypeCastTree

返回正在转换的表达式。

getExpression() - Method in interface com.sun.source.tree. UnaryTree

返回一元运算符的操作数的表达式。

getExpression() - Method in class javax.xml.crypto.dsig.spec. XPathType

返回要评估的XPath表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. ArrayAccessTree

返回访问的数组。

getExpression() - Method in interface jdk.nashorn.api.tree. AssignmentTree

返回此作业的右侧（RHS）。

getExpression() - Method in interface jdk.nashorn.api.tree. CaseTree

案例表达这个'case'语句。

getExpression() - Method in interface jdk.nashorn.api.tree. CompoundAssignmentTree

返回此作业的右侧（RHS）。

getExpression() - Method in interface jdk.nashorn.api.tree. ExpressionStatementTree

返回此表达式语句的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. ForInLoopTree

对象或数组的属性被迭代。

getExpression() - Method in interface jdk.nashorn.api.tree. ForOfLoopTree

对象或数组的属性被迭代。

getExpression() - Method in interface jdk.nashorn.api.tree. InstanceOfTree

返回正在检查类型的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. MemberSelectTree

正在选择其成员的对象表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. ParenthesizedTree

返回括号内的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. ReturnTree

返回正在返回的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. SpreadTree

返回正在传播的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. SwitchTree

返回此语句切换的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. ThrowTree

返回抛出的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. UnaryTree

返回由一元运算符操作的表达式。

getExpression() - Method in interface jdk.nashorn.api.tree. YieldTree

返回产生的表达式。

getExpressions() - Method in interface jdk.nashorn.api.tree. TemplateLiteralTree

返回此模板字符串中的表达式列表

getExtendedCacheKeys(JComponent) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter

获取绘图器实现想要包含在图像缓存查找中的任何额外的属性。

getExtendedKeyCode() - Method in class java.awt.event. KeyEvent

返回事件的扩展密钥代码。

getExtendedKeyCodeForChar(int) - Static method in class java.awt.event. KeyEvent

返回unicode字符的扩展密钥代码。

getExtendedKeyUsage() - Method in class java.security.cert. X509Certificate

获取表示扩展密钥使用扩展的 ExtKeyUsageSyntax字段的对象标识符（OID = 2.5.29.37）的字符串的不可修改列表。

getExtendedKeyUsage() - Method in class java.security.cert. X509CertSelector

返回extendedKeyUsage标准。

getExtendedState() - Method in class java.awt. Frame

获取此框架的状态。

getExtendsBound() - Method in interface javax.lang.model.type. WildcardType

返回此通配符的上限。

getExtendsClause() - Method in interface com.sun.source.tree. ClassTree

返回此类型声明的超类型，如果没有提供，则返回 null 。

getExtension() - Method in class javax.sound.sampled. AudioFileFormat.Type

获取此文件类型的公用文件扩展名。

getExtension(char) - Method in class java.util. Locale

返回与指定键相关联的扩展名（或私有使用）值，如果没有与密钥关联的扩展名，则返回null。

getExtensionFilters() - Method in class javafx.stage. FileChooser

获取显示文件对话框中使用的扩展过滤器。

getExtensionKeys() - Method in class java.util. Locale

返回与此语言环境相关联的扩展键集合，如果没有扩展名则返回空集合。

getExtensionLocation() - Method in interface javax.jnlp. ExtensionInstallerService

返回正在安装的扩展的位置

getExtensions() - Method in exception java.security.cert. CertificateRevokedException

返回X.509扩展名的地图，其中包含有关撤销证书的附加信息，例如无效日期扩展。

getExtensions() - Method in class javafx.stage. FileChooser.ExtensionFilter

获取此 ExtensionFilter的文件扩展名。

getExtensions() - Method in interface javax.script. ScriptEngineFactory

返回一个不可变的文件扩展名列表，它们通常标识以 ScriptEngine支持的语言编写的脚本。

getExtensions() - Method in class javax.swing.filechooser. FileNameExtensionFilter

返回所测试的文件扩展名文件集。

getExtensions() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getExtensionValue(String) - Method in interface java.security.cert. X509Extension

获取由传入的 oid字符串标识的扩展值（ extnValue ）的DER编码的OCTET字符串。

getExtensionVersion() - Method in interface javax.jnlp. ExtensionInstallerService

返回正在安装的扩展程序的版本

getExtent() - Method in interface javax.swing. BoundedRangeModel

返回模型的范围，以模型值开始的内部范围的长度。

getExtent() - Method in class javax.swing. DefaultBoundedRangeModel

返回模型的范围。

getExtent() - Method in class javax.swing. JSlider

从 BoundedRangeModel返回“extent”。

getExtentSize() - Method in class javax.swing. JViewport

返回视图坐标中视图的可见部分的大小。

getExternalElements() - Method in interface javax.xml.crypto.dsig.keyinfo. PGPData

返回一个XMLStructure代表来自外部命名空间的元素的unmodifiable list 。

getExternalSubset(String, String) - Method in class org.xml.sax.ext. DefaultHandler2

告诉解析器，如果在文档文本中没有声明外部子集，则不应使用任何外部子集。

getExternalSubset(String, String) - Method in interface org.xml.sax.ext. EntityResolver2

允许应用程序为未明确定义的文档提供外部子集。

getExtra() - Method in class java.util.zip. ZipEntry

返回条目的额外字段数据。

getExtraImageMetadataFormatNames() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回一个包含 String的数组， String包含由此插件生成或使用的图像元数据对象上的 getAsTree和 setFromTree方法识别的其他文档格式（本机和标准格式）。

getExtraMetadataFormatNames() - Method in class javax.imageio.metadata. IIOMetadata

返回的数组 String含的附加的元数据格式，比天然和标准格式，此插件中的识别名字小号 getAsTree ， setFromTree ，和 mergeTree方法。

getExtraNameCharacters() - Method in interface java.sql. DatabaseMetaData

检索可用于未引号的标识符名称（超出az，AZ，0-9和_）的所有“额外”字符。

getExtraStreamMetadataFormatNames() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回一个包含 String s的数组， String包含由此插件生成或使用的流元数据对象上的 getAsTree和 setFromTree方法识别的其他文档格式（本机和标准格式）。

getExtraValue() - Method in class javafx.scene.chart. XYChart.Data

获取属性extraValue的值。

getFace() - Method in interface org.w3c.dom.html. HTMLBaseFontElement

字体识别符

getFace() - Method in interface org.w3c.dom.html. HTMLFontElement

字体识别符

getFaceElementSize() - Method in class javafx.scene.shape. TriangleMesh

返回表示面部的元素数。

getFaces() - Method in class javafx.scene.shape. TriangleMesh

获取 faces阵列，索引到 points ， normals （可选，如果它是一个 VertexFormat.POINT_NORMAL_TEXCOORD目）和 texCoords阵列，此的 TriangleMesh 。

getFaceSmoothingGroups() - Method in class javafx.scene.shape. TriangleMesh

获取 faceSmoothingGroups阵列如此 TriangleMesh 。

getFactory() - Method in class java.util.concurrent. ForkJoinPool

返回用于构建新工人的工厂。

getFactory() - Method in interface javax.script. ScriptEngine

为这个 ScriptEngine所属的类返回一个 ScriptEngineFactory 。

getFactory() - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

getFactoryClassLocation() - Method in class javax.naming. Reference

检索此引用引用的对象的工厂位置。

getFactoryClassName() - Method in class javax.naming. Reference

检索此引用引用的对象的工厂类的名称。

getFailedProperties() - Method in exception java.sql. SQLClientInfoException

返回无法设置的客户端信息属性列表。

getFailureHandler() - Static method in class java.rmi.server. RMISocketFactory

返回由 setFailureHandler方法设置的套接字创建失败的处理程序。

getFallbackLocale(String, Locale) - Method in class java.util. ResourceBundle.Control

返回一个 Locale作为后备区域，用于通过 ResourceBundle.getBundle工厂方法进一步查找资源。

getFalseExpression() - Method in interface com.sun.source.tree. ConditionalExpressionTree

如果条件为false，则返回要评估的表达式。

getFalseExpression() - Method in interface jdk.nashorn.api.tree. ConditionalExpressionTree

返回这个三元表达式的虚假部分。

getFamilies() - Static method in class javafx.scene.text. Font

获取用户系统上安装的所有字体，包括任何应用程序字体或SDK字体。

getFamily() - Method in class java.awt. Font

返回此 Font的系列名称。

getFamily() - Method in class javafx.scene.text. Font

返回此字体的系列。

getFamily(Locale) - Method in class java.awt. Font

返回这个 Font的系列名称，用于指定的区域设置。

getFarClip() - Method in class javafx.scene. Camera

获取属性farClip的值。

getFault() - Method in interface javax.xml.soap. SOAPBody

返回此 SOAPFault对象中的 SOAPBody对象。

getFault() - Method in exception javax.xml.ws.soap. SOAPFaultException

获取嵌入式的 SOAPFault实例。

getFaultActor() - Method in interface javax.xml.soap. SOAPFault

获取此 SOAPFault对象的故障演员。

getFaultCode() - Method in interface javax.xml.soap. SOAPFault

获取此 SOAPFault对象的故障代码。

getFaultCodeAsName() - Method in interface javax.xml.soap. SOAPFault

获取此 SOAPFault对象的必需SOAP 1.1故障代码作为SAAJ Name对象。

getFaultCodeAsQName() - Method in interface javax.xml.soap. SOAPFault

获取此 SOAPFault对象的故障代码，作为 QName对象。

getFaultNode() - Method in interface javax.xml.soap. SOAPFault

返回此 SOAPFault对象的可选Node元素值。

getFaultReasonLocales() - Method in interface javax.xml.soap. SOAPFault

返回一个 Iterator了独特序列 Locale对此有关联Reason Text项秒。

getFaultReasonText(Locale) - Method in interface javax.xml.soap. SOAPFault

返回与给定的 Locale相关联的原因文本。

getFaultReasonTexts() - Method in interface javax.xml.soap. SOAPFault

通过 String对象的序列返回 Iterator ，其中包含此 SOAPFault所有原因文本项。

getFaultRole() - Method in interface javax.xml.soap. SOAPFault

返回此 SOAPFault对象的可选Role元素值。

getFaultString() - Method in interface javax.xml.soap. SOAPFault

获取此 SOAPFault对象的故障字符串。

getFaultStringLocale() - Method in interface javax.xml.soap. SOAPFault

获取此 SOAPFault对象的故障字符串的区域设置。

getFaultSubcodes() - Method in interface javax.xml.soap. SOAPFault

获取SOAPFault的子 SOAPFault作为迭代器超过 QNames 。

getFD() - Method in class java.io. FileInputStream

返回表示与此 FileInputStream正在使用的文件系统中实际文件的连接的 FileDescriptor对象。

getFD() - Method in class java.io. FileOutputStream

返回与此流相关联的文件描述符。

getFD() - Method in class java.io. RandomAccessFile

返回与此流关联的不透明文件描述符对象。

getFeature(String) - Method in class javax.xml.parsers. DocumentBuilderFactory

获取命名功能的状态。

getFeature(String) - Method in class javax.xml.parsers. SAXParserFactory

返回org.xml.sax.XMLReader的底层实现中请求的特定属性。

getFeature(String) - Method in class javax.xml.transform. TransformerFactory

查找功能的值。

getFeature(String) - Method in class javax.xml.validation. SchemaFactory

查找特征标记的值。

getFeature(String) - Method in class javax.xml.validation. Validator

查找特征标记的值。

getFeature(String) - Method in class javax.xml.validation. ValidatorHandler

查找特征标记的值。

getFeature(String) - Method in class javax.xml.xpath. XPathFactory

获取命名功能的状态。

getFeature(String) - Method in class org.xml.sax.helpers. ParserAdapter

检查解析器功能标志。

getFeature(String) - Method in class org.xml.sax.helpers. XMLFilterImpl

查找功能的值。

getFeature(String) - Method in interface org.xml.sax. XMLReader

查找特征标记的值。

getFeature(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode

IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

getFeature(String, String) - Method in interface org.w3c.dom. DOMImplementation

此方法返回一个专门的对象，该对象实现了特定功能和版本的专门API，如 DOM Features中所述 。

getFeature(String, String) - Method in interface org.w3c.dom. Node

该方法返回一个专门的对象，该对象实现指定的特征和版本的专门API，如

getFeedResolution() - Method in class javafx.print. PrintResolution

以dpi返回分辨率。 在送纸方向。

getFeedResolution(int) - Method in class javax.print.attribute. ResolutionSyntax

以给定单位返回此分辨率属性的进纸方向分辨率。

getFeedResolutionDphi() - Method in class javax.print.attribute. ResolutionSyntax

以dphi为单位返回此分辨率属性的Feed方向分辨率。

getFetchDirection() - Method in interface java.sql. ResultSet

检索此 ResultSet对象的抓取方向。

getFetchDirection() - Method in interface java.sql. Statement

检索从数据库表中获取行的方向，这是从此 Statement对象生成的结果集的默认值。

getFetchDirection() - Method in class javax.sql.rowset. BaseRowSet

检索此 RowSet对象的当前提取方向设置。

getFetchSize() - Method in interface java.sql. ResultSet

检索此 ResultSet对象的获取大小。

getFetchSize() - Method in interface java.sql. Statement

检索结果集合的行数是默认为获取大小 ResultSet从该生成的对象 Statement对象。

getFetchSize() - Method in class javax.sql.rowset. BaseRowSet

返回此 RowSet对象的提取大小。

getField() - Method in class java.security.spec. EllipticCurve

返回椭圆曲线结束的有限域 field 。

getField() - Method in class java.text. FieldPosition

检索字段标识符。

getField(String) - Method in class java.io. ObjectStreamClass

通过名称获取此类的字段。

getField(String) - Method in class java.lang. Class

返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定公共成员字段。

getField(DatatypeConstants.Field) - Method in class javax.xml.datatype. Duration

获取字段的值。

GetField() - Constructor for class java.io. ObjectInputStream.GetField

getFieldAttribute() - Method in class java.text. FieldPosition

从 Field子类之一返回字段标识符作为属性常量。

getFieldNames() - Method in interface javax.management. Descriptor

返回描述符中的所有字段名。

getFieldNames() - Method in class javax.management. ImmutableDescriptor

getFieldNames() - Method in class javax.management.modelmbean. DescriptorSupport

getFieldOfView() - Method in class javafx.scene. PerspectiveCamera

获取属性fieldOfView的值。

getFields() - Method in class java.io. ObjectStreamClass

返回此可序列化类的字段数组。

getFields() - Method in class java.lang. Class

返回一个包含 Field对象的数组， Field对象反映由该 Class对象表示的类或接口的所有可访问的公共字段。

getFields() - Method in interface javax.management. Descriptor

以字符串数组的形式返回此描述符中包含的所有字段。

getFields() - Method in class javax.management. ImmutableDescriptor

getFields() - Method in class javax.management.modelmbean. DescriptorSupport

getFields() - Method in class javax.sql.rowset.serial. SerialJavaObject

返回一个 Field对象的数组，其中包含该助手类序列化的对象的每个字段。

getFields(int) - Method in class javax.swing.text. InternationalFormatter

返回与文本 offset相关联的 Format.Field常量。

getFieldSize() - Method in interface java.security.spec. ECField

返回字段大小（以位为单位）。

getFieldSize() - Method in class java.security.spec. ECFieldF2m

返回该特征2有限域的字段大小（位数为 m 。

getFieldSize() - Method in class java.security.spec. ECFieldFp

返回这个主要有限域的素数p的大小的字段大小。

getFieldValue(String) - Method in interface javax.management. Descriptor

返回特定字段名称的值，如果该名称没有值，则返回null。

getFieldValue(String) - Method in class javax.management. ImmutableDescriptor

getFieldValue(String) - Method in class javax.management.modelmbean. DescriptorSupport

getFieldValues(String...) - Method in interface javax.management. Descriptor

将描述符中的所有字段值作为对象数组返回。

getFieldValues(String...) - Method in class javax.management. ImmutableDescriptor

getFieldValues(String...) - Method in class javax.management.modelmbean. DescriptorSupport

getFile() - Method in class java.awt. FileDialog

获取此文件对话框的选定文件。

getFile() - Method in class java.net. URL

获取此文件的名称 URL 。

getFile() - Method in exception java.nio.file. FileSystemException

返回用于创建此异常的文件。

getFile() - Method in class javax.activation. FileDataSource

返回与此FileDataSource对应的File对象。

getFileAttributeView(Class<V>) - Method in interface java.nio.file. SecureDirectoryStream

返回一个新的文件属性视图来访问此目录的文件属性。

getFileAttributeView(Path, Class<V>, LinkOption...) - Static method in class java.nio.file. Files

返回给定类型的文件属性视图。

getFileAttributeView(Path, Class<V>, LinkOption...) - Method in class java.nio.file.spi. FileSystemProvider

返回给定类型的文件属性视图。

getFileAttributeView(T, Class<V>, LinkOption...) - Method in interface java.nio.file. SecureDirectoryStream

返回一个新的文件属性视图来访问此目录中文件的文件属性。

getFileChooser() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回文件选择器。

getFileChooserDetailViewIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 FileChooserDetailViewIcon的实例。

getFileChooserHomeFolderIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 FileChooserHomeFolderIcon的实例。

getFileChooserListViewIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 FileChooserListViewIcon的实例。

getFileChooserNewFolderIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 FileChooserNewFolderIcon的实例。

getFileChooserUpFolderIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 FileChooserUpFolderIcon的实例。

getFileDescriptor() - Method in class java.net. DatagramSocketImpl

获取数据报套接字文件描述符。

getFileDescriptor() - Method in class java.net. SocketImpl

返回此套接字 fd字段的值。

getFileFilter() - Method in class javax.swing. JFileChooser

返回当前选择的文件过滤器。

getFileForInput(JavaFileManager.Location, String, String) - Method in class javax.tools. ForwardingJavaFileManager

getFileForInput(JavaFileManager.Location, String, String) - Method in interface javax.tools. JavaFileManager

返回file object用于表示指定的输入relative name中指定的包在给定的取向包位置。

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - Method in class javax.tools. ForwardingJavaFileManager

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - Method in interface javax.tools. JavaFileManager

返回file object用于表示指定的输出relative name中指定的包在给定的位置。

getFileKind(TypeElement) - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回类型元素的文件种类。

getFileName() - Method in class java.awt. JobAttributes

指定使用这些属性的作业的输出文件的文件名。

getFileName() - Method in class java.lang. StackTraceElement

返回包含由该堆栈跟踪元素表示的执行点的源文件的名称。

getFileName() - Method in interface java.lang. StackWalker.StackFrame

返回包含由该堆栈帧表示的执行点的源文件的名称。

getFileName() - Method in interface java.nio.file. Path

将此路径表示的文件或目录的名称返回为 Path对象。

getFileName() - Method in exception javax.script. ScriptException

获取导致错误的脚本的源。

getFileName() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回文件名。

getFileName() - Method in class javax.swing.plaf.metal. MetalFileChooserUI

getFileName() - Method in exception jdk.nashorn.api.scripting. NashornException

获取这个 NashornException的源文件名

getFileName() - Method in interface jdk.nashorn.api.tree. Diagnostic

获取源文件名。

getFilenameFilter() - Method in class java.awt. FileDialog

确定此文件对话框的文件名过滤器。

getFileNameMap() - Static method in class java.net. URLConnection

从数据文件加载文件名映射（模拟）。

getFilePointer() - Method in class java.io. RandomAccessFile

返回此文件中的当前偏移量。

getFilePointer() - Method in interface javax.jnlp. JNLPRandomAccessFile

返回此文件中的当前偏移量。

getFiler() - Method in interface javax.annotation.processing. ProcessingEnvironment

返回用于创建新的源，类或辅助文件的文件管理器。

getFiles() - Method in class java.awt.desktop. FilesEvent

获取文件列表

getFiles() - Method in class java.awt. FileDialog

返回用户选择的文件。

getFiles() - Method in class javafx.scene.input. Clipboard

从先前已注册的剪贴板获取文件列表。

getFiles() - Method in class javafx.scene.input. ClipboardContent

从先前已被放置的 ClipboardContent获取文件列表。

getFiles() - Method in class javax.swing.plaf.basic. BasicDirectoryModel

返回文件列表。

getFiles(File, boolean) - Method in class javax.swing.filechooser. FileSystemView

获取显示的列表（即不隐藏）文件。

getFileSelectionMode() - Method in class javax.swing. JFileChooser

返回当前的文件选择模式。

getFileStore(Path) - Static method in class java.nio.file. Files

返回表示文件所在文件存储区的FileStore 。

getFileStore(Path) - Method in class java.nio.file.spi. FileSystemProvider

返回表示文件所在文件存储区的FileStore 。

getFileStoreAttributeView(Class<V>) - Method in class java.nio.file. FileStore

返回给定类型的 FileStoreAttributeView 。

getFileStores() - Method in class java.nio.file. FileSystem

返回一个对象，以遍历底层文件存储。

getFileSuffixes() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回一个 String的数组， String包含与此服务提供商关联的 ImageReader或 ImageWriter实现通常可用的格式相关联的文件后缀列表。

getFileSystem() - Method in interface java.nio.file. Path

返回创建此对象的文件系统。

getFileSystem(URI) - Static method in class java.nio.file. FileSystems

返回对现有的 FileSystem的引用。

getFileSystem(URI) - Method in class java.nio.file.spi. FileSystemProvider

返回此提供商创建的现有 FileSystem 。

getFileSystemView() - Static method in class javax.swing.filechooser. FileSystemView

返回文件系统视图。

getFileSystemView() - Method in class javax.swing. JFileChooser

返回文件系统视图。

getFileView() - Method in class javax.swing. JFileChooser

返回当前文件视图。

getFileView(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

getFileView(JFileChooser) - Method in class javax.swing.plaf. FileChooserUI

返回文件视图。

getFileView(JFileChooser) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getFileView方法。

getFill() - Method in class javafx.scene.canvas. GraphicsContext

获取当前的填充颜色属性。

getFill() - Method in class javafx.scene.layout. BackgroundFill

油漆用于填充Region的背景。

getFill() - Method in class javafx.scene. Scene

获取属性填充的值。

getFill() - Method in class javafx.scene.shape. Shape

获取属性填充的值。

getFill() - Method in class javafx.scene. SnapshotParameters

获取当前填充。

getFill() - Method in class javafx.scene. SubScene

获取属性填充的值。

getFillRule() - Method in class javafx.scene.canvas. GraphicsContext

获取填充规则属性，以确定填充和剪辑操作中路径的内部。

getFillRule() - Method in class javafx.scene.shape. Path

获取属性fillRule的值。

getFillRule() - Method in class javafx.scene.shape. SVGPath

获取属性fillRule的值。

getFills() - Method in class javafx.scene.layout. Background

BackgroundFill的列表，它们一起定义了该背景的填充部分。

getFillsViewportHeight() - Method in class javax.swing. JTable

返回此表是否总是足够大以填充封闭视口的高度。

getFilter() - Method in class java.util.logging. Handler

获取当前的 Filter为这个 Handler 。

getFilter() - Method in class java.util.logging. Logger

获取此Logger的当前过滤器。

getFilter() - Method in class javafx.scene.control. TextFormatter

过滤器允许用户截取和修改对文本内容所做的任何更改。

getFilter() - Method in interface javax.sql.rowset. FilteredRowSet

检索此 FilteredRowSet对象的活动过滤器。

getFilter() - Method in class javax.xml.crypto.dsig.spec. XPathType

返回过滤器操作。

getFilter() - Method in interface org.w3c.dom.ls. LSParser

当提供过滤器时，在构建DOM树结构时，实现将调用过滤器。

getFilter() - Method in interface org.w3c.dom.ls. LSSerializer

当应用程序提供过滤器时，序列化程序将在序列化每个节点之前调用过滤器。

getFilter() - Method in interface org.w3c.dom.traversal. NodeIterator

NodeFilter用于屏幕节点。

getFilter() - Method in interface org.w3c.dom.traversal. TreeWalker

用于屏幕节点的过滤器。

getFilterInstance(ImageConsumer) - Method in class java.awt.image. ImageFilter

返回一个ImageFilter对象的唯一实例，该对象实际上将对指定的ImageConsumer进行过滤。

getFilters() - Method in class com.sun.net.httpserver. HttpContext

返回此上下文的过滤器列表。

getFinallyBlock() - Method in interface com.sun.source.tree. TryTree

返回 try语句中提供的finally块，如果没有，则返回 null 。

getFinallyBlock() - Method in interface jdk.nashorn.api.tree. TryTree

返回与'try'关联的'finally'块。

getFirst() - Method in class java.util. ArrayDeque

getFirst() - Method in class java.util.concurrent. ConcurrentLinkedDeque

getFirst() - Method in class java.util.concurrent. LinkedBlockingDeque

getFirst() - Method in interface java.util. Deque

检索，但不删除，这个deque的第一个元素。

getFirst() - Method in class java.util. LinkedList

返回此列表中的第一个元素。

getFirst(String) - Method in class com.sun.net.httpserver. Headers

从给定键的String列表中返回第一个值（如果至少存在一个）。

getFirstChild() - Method in class javax.imageio.metadata. IIOMetadataNode

返回此节点的第一个子节点，如果该节点没有子节点，则返回 null 。

getFirstChild() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的第一个子节点。

getFirstChild() - Method in interface org.w3c.dom. Node

这个节点的第一个孩子。

getFirstColumn() - Method in interface javax.accessibility. AccessibleTableModelChange

返回更改的第一列。

getFirstColumn() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange

返回第一列。

getFirstComponent(Container) - Method in class java.awt. ContainerOrderFocusTraversalPolicy

返回遍历周期中的第一个Component。

getFirstComponent(Container) - Method in class java.awt. FocusTraversalPolicy

返回遍历周期中的第一个Component。

getFirstComponent(Container) - Method in class javax.swing. DefaultFocusManager

返回第一个组件。

getFirstComponent(Container) - Method in class javax.swing. LayoutFocusTraversalPolicy

返回遍历周期中的第一个Component。

getFirstComponent(Container) - Method in class javax.swing. SortingFocusTraversalPolicy

返回遍历周期中的第一个Component。

getFirstDayOfWeek() - Method in class java.time.temporal. WeekFields

获得第一个星期。

getFirstDayOfWeek() - Method in class java.util. Calendar

得到一周的第一天是什么 例如， SUNDAY在美国， MONDAY在法国。

getFirstDayOfWeek(Locale) - Method in class java.util.spi. CalendarDataProvider

在给定的 locale返回一周的第一天。

getFirstElementChild() - Method in interface org.w3c.dom. ElementTraversal

返回对元素的第一个子节点的引用，它是Element类型。

getFirstIndex() - Method in class javax.swing.event. ListSelectionEvent

返回其选择可能已更改的第一行的索引。

getFirstLeaf() - Method in class javax.swing.tree. DefaultMutableTreeNode

找到并返回作为此节点的后代的第一个叶 - 该节点或其第一个孩子的第一个叶子。

getFirstLineIndent(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取第一行缩进设置。

getFirstQueuedThread() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回队列中的第一个（最长等待）线程，如果没有线程当前排队，则 null 。

getFirstQueuedThread() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回队列中的第一个（最长等待）线程，如果没有线程当前排队，则 null 。

getFirstRow() - Method in interface javax.accessibility. AccessibleTableModelChange

返回更改的第一行。

getFirstRow() - Method in class javax.swing.event. TableModelEvent

返回更改的第一行。

getFirstRow() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange

返回第一行。

getFirstSentence() - Method in interface com.sun.source.doctree. DocCommentTree

返回文档注释的第一个句子。

getFirstSentence(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory

获取内容列表中的第一个句子。

getFirstSentence(List<? extends DocTree>) - Method in class com.sun.source.util. DocTrees

返回表示评论第一句的DocTree的列表。

getFirstVisibleCell() - Method in class javafx.scene.control.skin. VirtualFlow

找到并返回部分或完全可见的第一个非空IndexedCell。

getFirstVisibleIndex() - Method in class javax.swing. JList

返回当前可见的最小列表索引。

getFitHeight() - Method in class javafx.scene.image. ImageView

获取属性fitHeight的值。

getFitHeight() - Method in class javafx.scene.media. MediaView

检索调整大小的媒体的边框的高度。

getFitWidth() - Method in class javafx.scene.image. ImageView

获取属性fitWidth的值。

getFitWidth() - Method in class javafx.scene.media. MediaView

检索调整大小的媒体的边框的宽度。

getFixedCellHeight() - Method in class javax.swing. JList

返回 fixedCellHeight属性的值。

getFixedCellSize() - Method in class javafx.scene.control. ListView

返回固定的单元格大小值。

getFixedCellSize() - Method in class javafx.scene.control.skin. VirtualFlow

获取属性fixedCellSize的值。

getFixedCellSize() - Method in class javafx.scene.control. TableView

返回固定的单元格大小值。

getFixedCellSize() - Method in class javafx.scene.control. TreeTableView

返回固定的单元格大小值。

getFixedCellSize() - Method in class javafx.scene.control. TreeView

返回固定的单元格大小值。

getFixedCellWidth() - Method in class javax.swing. JList

返回 fixedCellWidth属性的值。

getFixedRate(Integer) - Method in class javax.management.timer. Timer

获取标志的副本，指示是定期通知是以 固定延迟还是 固定速率执行 。

getFixedRate(Integer) - Method in interface javax.management.timer. TimerMBean

获取标志的副本，指示是定期通知是以 固定延迟还是 固定速率执行 。

getFlags() - Method in interface com.sun.source.tree. ModifiersTree

返回此修饰符树中的标志。

getFlags() - Method in exception java.util. DuplicateFormatFlagsException

返回包含重复标志的标志集。

getFlags() - Method in exception java.util. FormatFlagsConversionMismatchException

返回不兼容的标志。

getFlags() - Method in exception java.util. IllegalFormatFlagsException

返回包含非法组合的标志集。

getFlags() - Method in exception java.util. UnknownFormatFlagsException

返回包含未知标志的标志集。

getFlags() - Method in class javax.security.auth.kerberos. KerberosTicket

返回与此票证相关联的标志。

getFlatness() - Method in class java.awt.geom. CubicCurve2D

返回该曲线的平坦度。

getFlatness() - Method in class java.awt.geom. FlatteningPathIterator

返回此迭代器的平坦度。

getFlatness() - Method in class java.awt.geom. QuadCurve2D

返回 QuadCurve2D连接端点的控制点的平面度或最大距离。

getFlatness(double[], int) - Static method in class java.awt.geom. CubicCurve2D

返回由指定的数组中指定的索引处存储的控制点指定的三次曲线的平坦度。

getFlatness(double[], int) - Static method in class java.awt.geom. QuadCurve2D

返回控制点与连接终点的线的平坦度或最大距离，由指定的数组中存储在指示索引处的控制点指定的二次曲线。

getFlatness(double, double, double, double, double, double) - Static method in class java.awt.geom. QuadCurve2D

返回由指示的控制点指定的二次曲线的平滑度或控制点与连接端点的线的最大距离。

getFlatness(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom. CubicCurve2D

返回由指示的控制点指定的三次曲线的平坦度。

getFlatnessSq() - Method in class java.awt.geom. CubicCurve2D

返回该曲线的平坦度的平方。

getFlatnessSq() - Method in class java.awt.geom. QuadCurve2D

返回 QuadCurve2D的平面度或控制点与连接终点的线的最大距离的 QuadCurve2D 。

getFlatnessSq(double[], int) - Static method in class java.awt.geom. CubicCurve2D

返回由指定的数组中存储的指示索引指定的控制点指定的三次曲线的平坦度的平方。

getFlatnessSq(double[], int) - Static method in class java.awt.geom. QuadCurve2D

返回由指示的数组中存储的指示索引处存储的控制点指定的二次曲线的平坦度或控制点与连接终点的线的最大距离。

getFlatnessSq(double, double, double, double, double, double) - Static method in class java.awt.geom. QuadCurve2D

返回由指示的控制点指定的二次曲线的平坦度或控制点与连接终点的线的最大距离。

getFlatnessSq(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom. CubicCurve2D

返回由指示的控制点指定的三次曲线的平坦度的平方。

getFlavorListeners() - Method in class java.awt.datatransfer. Clipboard

返回当前在这个 Clipboard上注册的所有 FlavorListener的数组。

getFlavorMap() - Method in class java.awt.dnd. DragSource

此方法返回 FlavorMap这个 DragSource 。

getFlavorMap() - Method in class java.awt.dnd. DropTarget

获取 FlavorMap与此 DropTarget相关联。

getFlavorsForNative(String) - Method in interface java.awt.datatransfer. FlavorTable

返回 List的 DataFlavor s到其指定的 String对应。

getFlavorsForNative(String) - Method in class java.awt.datatransfer. SystemFlavorMap

返回 List的 DataFlavor ，其中指定的 String本机可以由数据传输子系统翻译。

getFlavorsForNatives(String[]) - Method in interface java.awt.datatransfer. FlavorMap

返回一个 Map的 String本地的对应的 DataFlavor 。

getFlavorsForNatives(String[]) - Method in class java.awt.datatransfer. SystemFlavorMap

返回 Map指定的 String原住民最受欢迎的 DataFlavor 。

getFlipContents() - Method in class java.awt. BufferCapabilities

getFloat() - Method in class java.nio. ByteBuffer

读取浮点值的相对 get方法。

getFloat(int) - Method in class java.nio. ByteBuffer

用于读取浮点值的绝对 get方法。

getFloat(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 float指定的JDBC FLOAT参数的值。

getFloat(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 float此 ResultSet对象的当前行中指定列的值。

getFloat(Object) - Method in class java.lang.reflect. Field

获取类型为 float的静态或实例字段的 float或通过加宽转换可转换为类型 float的另一个基本类型的值。

getFloat(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中索引组件的值，如 float 。

getFloat(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 float JDBC FLOAT参数的值。

getFloat(String) - Method in interface java.sql. ResultSet

以此Java编程语言中的 float此 ResultSet对象的当前行中指定列的值。

getFloat(String, float) - Method in class java.util.prefs. AbstractPreferences

实现 getFloat方法按照在本说明书中 Preferences.getFloat(String,float) 。

getFloat(String, float) - Method in class java.util.prefs. Preferences

返回由此首选项节点中与指定键相关联的字符串表示的浮点值。

getFloatingColor() - Method in class javax.swing.plaf.basic. BasicToolBarUI

获取在浮动区域上显示的颜色

getFloatParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

将参数返回为浮点数的方便方法。

getFloatValue(short) - Method in interface org.w3c.dom.css. CSSPrimitiveValue

此方法用于获取指定单位中的浮点值。

getFlowAxis() - Method in class javax.swing.text. FlowView

获取视图应该流过的轴。

getFlowSpan(int) - Method in class javax.swing.text. FlowView

为给定的子索引获取约束跨度。

getFlowSpan(int) - Method in class javax.swing.text. ParagraphView

为给定的子索引获取约束跨度。

getFlowStart(int) - Method in class javax.swing.text. FlowView

获取沿流动轴线开始流动跨度的位置。

getFlowStart(int) - Method in class javax.swing.text. ParagraphView

获取沿着流动轴线开始流动跨度的位置。

getFlushedPosition() - Method in interface javax.imageio.stream. ImageInputStream

返回可以执行搜索的流中的最早位置。

getFlushedPosition() - Method in class javax.imageio.stream. ImageInputStreamImpl

getFocusableWindowState() - Method in class java.awt. Window

如果满足 isFocusableWindow所述的其他要求，则返回此窗口是否可以成为关注窗口。

getFocusAccelerator() - Method in class javax.swing.text. JTextComponent

返回将导致接收文本组件获得焦点的关键加速器。

getFocusAngle() - Method in class javafx.scene.paint. RadialGradient

定义从渐变的中心到第一个颜色映射到的对焦点的角度（以度为单位）。

getFocusColor() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回焦点颜色。

getFocusColor() - Method in class javax.swing.plaf.metal. MetalButtonUI

返回对焦按钮的颜色。

getFocusColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的焦点颜色。

getFocusColor() - Method in class javax.swing.plaf.metal. MetalRadioButtonUI

返回聚焦的颜色 JRadioButton 。

getFocusColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回焦点颜色。

getFocusColor() - Method in class javax.swing.plaf.metal. MetalToggleButtonUI

返回重点切换按钮的颜色。

getFocusCycleRootAncestor() - Method in class java.awt. Component

返回作为该组件焦点遍历循环的焦点循环根的容器。

getFocusCycleRootAncestor() - Method in class java.awt. Window

始终返回null因为Windows没有祖先; 它们代表组件层次结构的顶部。

getFocusCycleRootAncestor() - Method in class javax.swing. JInternalFrame

始终返回 null因为 JInternalFrame必须始终是焦点遍历循环的根。

getFocusDistance() - Method in class javafx.scene.paint. RadialGradient

定义从渐变的中心到第一个颜色映射到的对焦点的距离。

getFocusedCell() - Method in class javafx.scene.control. TableView.TableViewFocusModel

获取focusCell属性的值。

getFocusedCell() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel

获取focusCell属性的值。

getFocusedComponent() - Method in class javax.swing.text. TextAction

获取当前具有焦点的文本组件。

getFocusedIndex() - Method in class javafx.scene.control. FocusModel

获取focusIndex属性的值。

getFocusedIndex() - Method in class javafx.scene.control. TableView.TableViewSelectionModel

getFocusedIndex() - Method in class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel

getFocusedItem() - Method in class javafx.scene.control. FocusModel

获取对focusItem的值。

getFocusedWindow() - Method in class java.awt. KeyboardFocusManager

如果集中的窗口与调用线程处于相同的上下文中，则返回关注的窗口。

getFocusIndex() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回具有焦点的选项卡的索引。

getFocusListeners() - Method in class java.awt. Component

返回在此组件上注册的所有焦点侦听器的数组。

getFocusLostBehavior() - Method in class javax.swing. JFormattedTextField

返回焦点丢失时的行为。

getFocusModel() - Method in class javafx.scene.control. ListView

返回当前安装的FocusModel 。

getFocusModel() - Method in class javafx.scene.control. TableView

获取属性focusModel的值。

getFocusModel() - Method in class javafx.scene.control. TreeTableView

返回当前安装的FocusModel 。

getFocusModel() - Method in class javafx.scene.control. TreeView

返回当前安装的FocusModel 。

getFocusOwner() - Method in class java.awt. KeyboardFocusManager

如果焦点所有者与调用线程处于相同的上下文中，则返回焦点所有者。

getFocusOwner() - Method in class java.awt. Window

如果此窗口被聚焦，则返回此窗口的具有焦点的子组件; 否则返回null。

getFocusOwner() - Method in class javafx.scene. Scene

获取focusOwner属性的值。

getFocusOwner() - Method in class javax.swing. JInternalFrame

如果此 JInternalFrame处于活动状态，则返回具有焦点的小孩。

getFocusPoint() - Method in class java.awt. RadialGradientPaint

返回径向渐变焦点的副本。

getFocusTraversalKeys(int) - Method in class java.awt. Component

返回此组件的给定遍历操作的聚焦遍历键集。

getFocusTraversalKeys(int) - Method in class java.awt. Container

返回此Container的给定遍历操作的聚焦遍历键集。

getFocusTraversalKeys(int) - Method in class java.awt. Window

获取此窗口的焦点遍历键。

getFocusTraversalKeysEnabled() - Method in class java.awt. Component

返回是否为此组件启用焦点遍历键。

getFocusTraversalPolicy() - Method in class java.awt. Container

返回将管理此Container的子项的键盘遍历的焦点遍历策略，如果此Container不是焦点循环根，则返回null。

getFollowRedirects() - Static method in class java.net. HttpURLConnection

返回一个 boolean指示是否应自动跟踪HTTP重定向（3xx）。

getFont() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的 Font 。

getFont() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的 Font 。

getFont() - Method in class java.awt. Component

获取此组件的字体。

getFont() - Method in class java.awt.font. GlyphVector

返回 Font与此相关 GlyphVector 。

getFont() - Method in class java.awt. FontMetrics

获取 Font通过此描述 FontMetrics对象。

getFont() - Method in class java.awt. Graphics

获取当前字体。

getFont() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的字体。

getFont() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的 Font 。

getFont() - Method in class java.awt. MenuComponent

获取用于此菜单组件的字体。

getFont() - Method in interface java.awt. MenuContainer

返回此容器正在使用的字体。

getFont() - Method in class javafx.scene.canvas. GraphicsContext

获取当前字体。

getFont() - Method in class javafx.scene.control. Labeled

获取属性字体的值。

getFont() - Method in class javafx.scene.control. TextInputControl

获取属性字体的值。

getFont() - Method in class javafx.scene.control. Tooltip

获取属性字体的值。

getFont() - Method in class javafx.scene.text. Text

获取属性字体的值。

getFont() - Method in interface javax.accessibility. AccessibleComponent

获取此对象的字体。

getFont() - Method in class javax.swing. DebugGraphics

返回用于文本绘图操作的字体。

getFont() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getFont() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的 Font 。

getFont() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

getFont() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getFont() - Method in class javax.swing.text. GlyphView

获取字形应该基于的字体。

getFont() - Method in class javax.swing.text. LabelView

获取字形应该基于的字体。

getFont() - Method in class javax.swing.tree. DefaultTreeCellEditor.DefaultTextField

getFont() - Method in class javax.swing.tree. DefaultTreeCellEditor

获取用于编辑的字体。

getFont() - Method in class javax.swing.tree. DefaultTreeCellRenderer

获取此组件的字体。

getFont() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font属性定义。

getFont(Component) - Method in class javax.swing.border. TitledBorder

返回标题边框的默认字体。

getFont(Object) - Method in class javax.swing. UIDefaults

如果 key的值是 Font返回，否则返回 null 。

getFont(Object) - Static method in class javax.swing. UIManager

从默认值返回一个字体。

getFont(Object, Locale) - Method in class javax.swing. UIDefaults

如果值 key对于给定 Locale是 Font返回它，否则返回 null 。

getFont(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回一个字体。

getFont(String) - Static method in class java.awt. Font

从系统属性列表中返回一个 Font对象。

getFont(String, int, int) - Method in class javax.swing.text. StyleContext

获取一个新的字体。

getFont(String, Font) - Static method in class java.awt. Font

从系统属性列表获取指定的 Font 。

getFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Static method in class java.awt. Font

返回一个适合于属性的 Font 。

getFont(SynthContext) - Method in class javax.swing.plaf.synth. SynthStyle

返回指定状态的Font。

getFont(AttributeSet) - Method in class javax.swing.text. DefaultStyledDocument

从属性集获取字体。

getFont(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

获取用于给定属性集的字体。

getFont(AttributeSet) - Method in class javax.swing.text. StyleContext

从属性集获取字体。

getFont(AttributeSet) - Method in interface javax.swing.text. StyledDocument

获取一组属性并将其转换为字体规范。

getFontConverter() - Static method in class javafx.css. StyleConverter

返回一个 StyleConverter ，其转换解析后的表示 Font至 Font 。

getFontFaces() - Method in class javafx.css. Stylesheet

getFontFamily() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-family属性定义。

getFontFamily(AttributeSet) - Static method in class javax.swing.text. StyleConstants

从属性列表中获取字体系列设置。

getFontForState(SynthContext) - Method in class javax.swing.plaf.nimbus. NimbusStyle

返回指定状态的字体。

getFontForState(SynthContext) - Method in class javax.swing.plaf.synth. SynthStyle

返回指定状态的字体。

getFontList() - Method in class java.awt. Toolkit

已过时。
见GraphicsEnvironment.getAvailableFontFamilyNames()

getFontMetrics() - Method in class java.awt. Graphics

获取当前字体的字体度量。

getFontMetrics() - Method in class javax.swing. DebugGraphics

覆盖 Graphics.getFontMetrics 。

getFontMetrics() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回字体指标。

getFontMetrics() - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

返回字体指标。

getFontMetrics() - Method in class javax.swing.text. FieldView

获取与托管此视图的组件相关联的字体度量。

getFontMetrics() - Method in class javax.swing.text. LabelView

已过时。
在JDK中运行时，FontMetrics不用于字形渲染。

getFontMetrics(Font) - Method in class com.sun.java.accessibility.util. Translator

获取此对象的 FontMetrics 。

getFontMetrics(Font) - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的 FontMetrics 。

getFontMetrics(Font) - Method in class java.awt. Component

获取指定字体的字体指标。

getFontMetrics(Font) - Method in class java.awt. Graphics

获取指定字体的字体指标。

getFontMetrics(Font) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的FontMetrics。

getFontMetrics(Font) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的 FontMetrics 。

getFontMetrics(Font) - Method in class java.awt. Toolkit

已过时。
截至JDK 1.2版，由Font替代getLineMetrics 。

getFontMetrics(Font) - Method in interface javax.accessibility. AccessibleComponent

获取此对象的 FontMetrics 。

getFontMetrics(Font) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.getFontMetrics 。

getFontMetrics(Font) - Method in class javax.swing. JComponent

获取 FontMetrics指定的 Font 。

getFontMetrics(Font) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getFontMetrics(Font) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的 FontMetrics 。

getFontMetrics(Font) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

getFontMetrics(Font) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getFontMetrics(Font) - Method in class javax.swing.text. StyleContext

返回字体的字体指标。

getFontName() - Method in class java.awt. Font

返回此 Font的字体名称。

getFontName(Locale) - Method in class java.awt. Font

返回 Font的字体名称，这些名称已针对指定的区域设置进行了本地化。

getFontNames() - Static method in class javafx.scene.text. Font

获取用户系统上安装的所有字体的名称，包括任何应用程序字体和SDK字体。

getFontNames(String) - Static method in class javafx.scene.text. Font

获取用户系统上安装的指定字体系列中所有字体的名称，包括任何应用程序字体和SDK字体。

getFontRenderContext() - Method in class java.awt.font. GlyphVector

返回FontRenderContext与此相关GlyphVector 。

getFontRenderContext() - Method in class java.awt. FontMetrics

获取 FontRenderContext使用此 FontMetrics对象测量文本。

getFontRenderContext() - Method in class java.awt. Graphics2D

获取此 Graphics2D上下文中的 Font的呈现上下文。

getFontScale() - Method in class javafx.scene.web. WebView

获取属性fontScale的值。

getFontSize() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-size属性定义。

getFontSize(AttributeSet) - Static method in class javax.swing.text. StyleConstants

从属性列表获取字体大小设置。

getFontSizeAdjust() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-size-adjust属性定义。

getFontSmoothingType() - Method in class javafx.scene.canvas. GraphicsContext

获取当前的字体平滑类型。

getFontSmoothingType() - Method in class javafx.scene.text. Text

获取属性fontSmoothingType的值。

getFontSmoothingType() - Method in class javafx.scene.web. WebView

获取属性fontSmoothingType的值。

getFontStretch() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-stretch属性定义。

getFontStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-style属性定义。

getFontTable(int) - Method in interface java.awt.font. OpenType

将表作为指定标记的字节数组返回。

getFontTable(int, int, int) - Method in interface java.awt.font. OpenType

将表的子集作为指定标记的字节数组返回。

getFontTable(String) - Method in interface java.awt.font. OpenType

将表作为指定标记的字节数组返回。

getFontTable(String, int, int) - Method in interface java.awt.font. OpenType

将表的子集作为指定标记的字节数组返回。

getFontTableSize(int) - Method in interface java.awt.font. OpenType

返回指定标记的表的大小。

getFontTableSize(String) - Method in interface java.awt.font. OpenType

返回指定标记的表的大小。

getFontVariant() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-variant属性定义。

getFontWeight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-weight属性定义。

getForeground() - Method in class com.sun.java.accessibility.util. Translator

获取此对象的前景 Color 。

getForeground() - Method in class java.awt. Component.AccessibleAWTComponent

获取此对象的前景色。

getForeground() - Method in class java.awt. Component

获取此组件的前景色。

getForeground() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取此对象的前景色。

getForeground() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

获取此对象的前景色。

getForeground() - Method in interface javax.accessibility. AccessibleComponent

获取此对象的前景色。

getForeground() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getForeground() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取此对象的前景色。

getForeground() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取此对象的前景色。

getForeground() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getForeground() - Method in class javax.swing.text. GlyphView

获取用于渲染字形的前景色。

getForeground() - Method in class javax.swing.text. LabelView

获取用于渲染字形的前景色。

getForeground(AttributeSet) - Method in class javax.swing.text. DefaultStyledDocument

从属性集获取前景色。

getForeground(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

获取一组属性，并将其转换为前景颜色规范。

getForeground(AttributeSet) - Static method in class javax.swing.text. StyleConstants

从属性列表获取前景色设置。

getForeground(AttributeSet) - Method in class javax.swing.text. StyleContext

获取一组属性，并将其转换为前景颜色规范。

getForeground(AttributeSet) - Method in interface javax.swing.text. StyledDocument

获取一组属性，并将其转换为前景颜色规范。

getForegroundAt(int) - Method in class javax.swing. JTabbedPane

返回标签前景色为 index 。

getForegroundPainter(SynthContext) - Method in class javax.swing.plaf.nimbus. NimbusStyle

获取适当的前景Painter，如果有的话，给定SynthContext中指定的状态。

getForkJoinTaskTag() - Method in class java.util.concurrent. ForkJoinTask

返回此任务的标签。

getForm() - Method in interface org.w3c.dom.html. HTMLButtonElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLFieldSetElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLInputElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLIsIndexElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLLabelElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLLegendElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLObjectElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLOptionElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLSelectElement

返回包含此控件的 FORM元素。

getForm() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

返回包含此控件的 FORM元素。

getFormat() - Method in interface java.security. Certificate

已过时。

返回编码格式的名称。

getFormat() - Method in interface java.security. Key

返回此键的主编码格式的名称，如果此键不支持编码，则返回null。

getFormat() - Method in class java.security.spec. EncodedKeySpec

返回与此密钥规范相关联的编码格式的名称。

getFormat() - Method in class java.security.spec. PKCS8EncodedKeySpec

返回与此密钥规范相关联的编码格式的名称。

getFormat() - Method in class java.security.spec. X509EncodedKeySpec

返回与此密钥规范相关联的编码格式的名称。

getFormat() - Method in class javafx.util.converter. FormatStringConverter

返回一个Format实例，用于在此StringConverter中进行格式化和解析。

getFormat() - Method in class javax.crypto.spec. SecretKeySpec

返回此密钥的编码格式的名称。

getFormat() - Method in class javax.security.auth.kerberos. EncryptionKey

返回此键的编码格式的名称。

getFormat() - Method in class javax.security.auth.kerberos. KerberosKey

返回此密钥的编码格式的名称。

getFormat() - Method in class javax.sound.sampled. AudioFileFormat

获取包含在音频文件中的音频数据的格式。

getFormat() - Method in class javax.sound.sampled. AudioInputStream

获取此音频输入流中声音数据的音频格式。

getFormat() - Method in interface javax.sound.sampled. DataLine

获取数据线音频数据的当前格式（编码，采样率，通道数等）。

getFormat() - Method in class javax.swing. JSpinner.DateEditor

返回 java.text.SimpleDateFormat对象 JFormattedTextField用于解析和格式化数字。

getFormat() - Method in class javax.swing. JSpinner.NumberEditor

返回 JFormattedTextField用于解析和格式化数字的 java.text.DecimalFormat对象。

getFormat() - Method in class javax.swing.text. InternationalFormatter

返回指定可编辑和显示的合法值的格式。

getFormatId() - Method in interface javax.transaction.xa. Xid

获取XID的格式标识符部分。

getFormatName() - Method in class javax.imageio. ImageReader

返回一个 String标识输入源的格式。

getFormatNames() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回一个 String的数组， String包含与此服务提供商相关联的 ImageReader或 ImageWriter实现通常可用的格式的可读取名称。

getFormats() - Method in class java.text. ChoiceFormat

获取在构造函数中传递的格式。

getFormats() - Method in class java.text. MessageFormat

获取用于先前设置的模式字符串中的格式元素的格式。

getFormats() - Method in class javax.sound.sampled. DataLine.Info

获取数据线支持的一组音频格式。

getFormats(String) - Method in class java.util. ResourceBundle.Control

返回 List的 String s，其中包含用于为给定的 baseName加载资源束的 baseName 。

getFormatsByArgumentIndex() - Method in class java.text. MessageFormat

获取用于传递给 format方法的值或从 parse方法返回的 parse 。

getFormatSpecifier() - Method in exception java.util. MissingFormatArgumentException

返回不匹配的格式说明符。

getFormatSpecifier() - Method in exception java.util. MissingFormatWidthException

返回没有宽度的格式说明符。

getFormattedTextField() - Method in class javax.swing. JFormattedTextField.AbstractFormatter

返回当前 JFormattedTextField的 AbstractFormatter上安装。

getFormatter() - Method in class java.util.logging. Handler

返回 Formatter为这个 Handler 。

getFormatter() - Method in class javax.swing. JFormattedTextField

返回用于格式化和解析当前值的 AbstractFormatter 。

getFormatter(JFormattedTextField) - Method in class javax.swing. JFormattedTextField.AbstractFormatterFactory

返回一个 AbstractFormatter ，可以处理 AbstractFormatter中传递的 JFormattedTextField 。

getFormatter(JFormattedTextField) - Method in class javax.swing.text. DefaultFormatterFactory

根据JFormattedTextField的状态返回默认格式化程序，显示格式化程序，编辑器格式化程序或空格式化程序。

getFormatterFactory() - Method in class javax.swing. JFormattedTextField

返回当前的 AbstractFormatterFactory 。

getForms() - Method in interface org.w3c.dom.html. HTMLDocument

文件的所有形式的集合。

getFraction() - Method in class javafx.scene.effect. Reflection

获取属性分数的值。

getFractionalMetricsHint() - Method in class java.awt.font. FontRenderContext

返回此 FontRenderContext使用的文本小数度量渲染模式提示。

getFractionalSecond() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回小数秒。

getFractions() - Method in class java.awt. MultipleGradientPaint

返回此梯度使用的浮点数组的副本以计算颜色分布。

getFragment() - Method in class java.net. URI

返回此URI的解码片段组件。

getFrame() - Method in class java.awt.geom. RectangularShape

返回定义此对象的整体形状的框架Rectangle2D 。

getFrame() - Method in interface org.w3c.dom.html. HTMLTableElement

指定要呈现的外部表格边框。

getFrameBorder() - Method in interface org.w3c.dom.html. HTMLFrameElement

请求帧边框。

getFrameBorder() - Method in interface org.w3c.dom.html. HTMLIFrameElement

请求帧边框。

getFrameCount() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回由不确定的JProgessBar使用的完整动画循环的帧数。

getFrameForComponent(Component) - Static method in class javax.swing. JOptionPane

返回指定的组件的 Frame 。

getFrameIcon() - Method in class javax.swing. JInternalFrame

返回显示在该内部框架的标题栏中的图像（通常位于左上角）。

getFrameLength() - Method in class javax.sound.sampled. AudioFileFormat

获取包含在文件中的音频数据的长度，以样本帧表示。

getFrameLength() - Method in class javax.sound.sampled. AudioInputStream

获取流的长度，以采样帧而不是字节表示。

getFrameLength() - Method in interface javax.sound.sampled. Clip

获取样品帧中的介质长度。

getFramePosition() - Method in interface javax.sound.sampled. DataLine

获取音频数据中的样本帧中的当前位置。

getFramePosition() - Method in class javax.sound.sampled. LineEvent

当事件发生时，获取该行的音频数据中的位置，以采样帧表示。

getFrameRate() - Method in class javax.sound.sampled. AudioFormat

以帧/秒获取帧速率。

getFrames() - Static method in class java.awt. Frame

返回由此应用程序创建的所有 Frame的数组。

getFrameSize() - Method in class javax.sound.sampled. AudioFormat

以字节获取帧大小。

getFreePhysicalMemorySize() - Method in interface com.sun.management. OperatingSystemMXBean

返回以字节为单位的空闲物理内存量。

getFreeSpace() - Method in class java.io. File

通过此抽象路径名返回分区 named中未分配字节的数量。

getFreeSwapSpaceSize() - Method in interface com.sun.management. OperatingSystemMXBean

返回以字节为单位的空闲交换空间量。

getFrom() - Method in class javafx.collections. ListChangeListener.Change

如果wasAdded为true，则间隔包含所有添加的值。

getFrom(TemporalAccessor) - Method in enum java.time.temporal. ChronoField

getFrom(TemporalAccessor) - Method in interface java.time.temporal. TemporalField

从指定的时间对象获取此字段的值。

getFromAngle() - Method in class javafx.animation. RotateTransition

获取属性fromAngle的值。

getFromIndex() - Method in class javax.swing.event. TableColumnModelEvent

返回fromIndex。

getFromPage() - Method in class java.awt. JobAttributes

对于使用这些属性的作业，如果要打印一系列页面，则返回要打印的第一页。

getFromValue() - Method in class javafx.animation. FadeTransition

获取属性fromValue的值。

getFromValue() - Method in class javafx.animation. FillTransition

获取属性fromValue的值。

getFromValue() - Method in class javafx.animation. StrokeTransition

获取属性fromValue的值。

getFromX() - Method in class javafx.animation. ScaleTransition

从X获取属性的值。

getFromX() - Method in class javafx.animation. TranslateTransition

从X获取属性的值。

getFromY() - Method in class javafx.animation. ScaleTransition

从Y获取属性的值。

getFromY() - Method in class javafx.animation. TranslateTransition

从Y获取属性的值。

getFromZ() - Method in class javafx.animation. ScaleTransition

从Z获取属性的值。

getFromZ() - Method in class javafx.animation. TranslateTransition

从Z获取属性的值。

getFrontBufferCapabilities() - Method in class java.awt. BufferCapabilities

getFullBody() - Method in interface com.sun.source.doctree. DocCommentTree

返回文档注释的整个正文，出现在任何块标记之前，包括第一个句子。

getFullScreenExitHint() - Method in class javafx.stage. Stage

获取属性fullScreenExitHint的值。

getFullScreenExitKeyCombination() - Method in class javafx.stage. Stage

获取用于退出全屏模式的当前顺序。

getFullScreenWindow() - Method in class java.awt. GraphicsDevice

如果设备处于全屏模式，则返回表示全屏窗口的 Window对象。

getFunctionalInterfaceClass() - Method in class java.lang.invoke. SerializedLambda

获取此lambda已转换到的调用类型的名称

getFunctionalInterfaceMethodName() - Method in class java.lang.invoke. SerializedLambda

获取此lambda已转换的功能界面的主要方法的名称。

getFunctionalInterfaceMethodSignature() - Method in class java.lang.invoke. SerializedLambda

获取此lambda已转换的功能界面的主要方法的签名。

getFunctionColumns(String, String, String, String) - Method in interface java.sql. DatabaseMetaData

检索给定目录的系统或用户功能参数和返回类型的描述。

getFunctions(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索给定目录中可用的系统和用户功能的描述。

getFunctionSelect() - Method in interface jdk.nashorn.api.tree. FunctionCallTree

返回被调用的函数。

getG() - Method in interface java.security.interfaces. DSAParams

返回基数， g 。

getG() - Method in class java.security.spec. DSAParameterSpec

返回基数 g 。

getG() - Method in class java.security.spec. DSAPrivateKeySpec

返回底座 g 。

getG() - Method in class java.security.spec. DSAPublicKeySpec

返回基数 g 。

getG() - Method in class javax.crypto.spec. DHParameterSpec

返回基本生成器 g 。

getG() - Method in class javax.crypto.spec. DHPrivateKeySpec

返回基本生成器 g 。

getG() - Method in class javax.crypto.spec. DHPublicKeySpec

返回基本生成器 g 。

getGain() - Method in class javafx.scene.media. EqualizerBand

检索应用于乐队的增益。

getGamma() - Method in class java.awt.color. ICC_ProfileGray

返回表示色调再现曲线（TRC）的伽马值。

getGamma(int) - Method in class java.awt.color. ICC_ProfileRGB

返回表示特定组件的色调再现曲线（TRC）的伽马值。

getGarbageCollectorMXBeans() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机中的GarbageCollectorMXBean个对象的列表。

getGcAction() - Method in class com.sun.management. GarbageCollectionNotificationInfo

返回垃圾收集器执行的操作

getGcCause() - Method in class com.sun.management. GarbageCollectionNotificationInfo

返回垃圾收集的原因

getGcInfo() - Method in class com.sun.management. GarbageCollectionNotificationInfo

返回与最后垃圾收集相关的GC信息

getGcName() - Method in class com.sun.management. GarbageCollectionNotificationInfo

返回用于执行集合的垃圾收集器的名称

getGeneratedKeys() - Method in interface java.sql. Statement

检索由于执行此 Statement对象而创建的任何自动生成的密钥。

getGenerator() - Method in class java.security.spec. ECParameterSpec

返回也称为基点的生成器。

getGenericComponentType() - Method in interface java.lang.reflect. GenericArrayType

返回表示此数组的组件类型的 Type对象。

getGenericDeclaration() - Method in interface java.lang.reflect. TypeVariable

返回表示声明为此类型变量的通用声明的 GenericDeclaration对象。

getGenericDisplayName(String, int, Locale) - Method in class java.util.spi. TimeZoneNameProvider

返回指定时区 ID的通用名称，适用于在指定的 locale向用户 locale 。

getGenericElement() - Method in interface javax.lang.model.element. TypeParameterElement

返回由此类型参数参数化的通用类，接口，方法或构造函数。

getGenericExceptionTypes() - Method in class java.lang.reflect. Constructor

返回一个 Type对象的数组，表示此可执行对象声明抛出的异常。

getGenericExceptionTypes() - Method in class java.lang.reflect. Executable

返回一个 Type对象的数组，表示此可执行对象声明抛出的异常。

getGenericExceptionTypes() - Method in class java.lang.reflect. 方法

返回一个 Type对象的数组，它们表示声明为该可执行对象抛出的异常。

getGenericInterfaces() - Method in class java.lang. Class

返回表示由该对象表示的类或接口直接实现的接口的 Type 。

getGenericParameterTypes() - Method in class java.lang.reflect. Constructor

返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。

getGenericParameterTypes() - Method in class java.lang.reflect. Executable

返回一个 Type对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。

getGenericParameterTypes() - Method in class java.lang.reflect. 方法

返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。

getGenericReturnType() - Method in class java.lang.reflect. 方法

返回一个 Type对象，表示由该 方法对象表示的方法的正式返回类型。

getGenericSuperclass() - Method in class java.lang. Class

返回表示由 Type表示的实体的直接超类（类，接口，原始类型或空白）的 Class 。

getGenericType() - Method in class java.lang.reflect. Field

返回一个 Type对象，表示由该 Field对象表示的字段的声明类型。

getGestureModifiers() - Method in class java.awt.dnd. DragSourceDragEvent

该方法返回表示与用户手势相关联的输入设备修饰符的当前状态的 int 。

getGestureModifiersEx() - Method in class java.awt.dnd. DragSourceDragEvent

该方法返回表示与用户手势相关联的输入设备扩展修饰符的当前状态的 int 。

getGestureSource() - Method in class javafx.scene.input. DragEvent

拖放手势的源对象。

getGestureSource() - Method in class javafx.scene.input. MouseDragEvent

返回正在进行的手势的源对象。

getGestureTarget() - Method in class javafx.scene.input. DragEvent

拖放手势的目标对象。

getGetListenerMethod() - Method in class java.beans. EventSetDescriptor

获取用于访问已注册事件侦听器的方法。

getGetter() - Method in interface jdk.nashorn.api.tree. PropertyTree

如果这是一个访问器属性，则返回此属性的setter函数。

getGid() - Method in class com.sun.security.auth.module. SolarisSystem

已过时。

获取当前Solaris用户的GID。

getGid() - Method in class com.sun.security.auth.module. UnixSystem

获取当前Unix用户的GID。

getGlassPane() - Method in class javax.swing. JApplet

已过时。

返回此applet的glassPane对象。

getGlassPane() - Method in class javax.swing. JDialog

返回此对话框的 glassPane对象。

getGlassPane() - Method in class javax.swing. JFrame

返回此帧的 glassPane对象。

getGlassPane() - Method in class javax.swing. JInternalFrame

返回此内部框架的玻璃窗格。

getGlassPane() - Method in class javax.swing. JLayer

返回 JLayer的glassPane组件或 null 。

getGlassPane() - Method in class javax.swing. JRootPane

返回此 JRootPane的当前玻璃窗格。

getGlassPane() - Method in class javax.swing. JWindow

返回此窗口的 glassPane Component 。

getGlassPane() - Method in interface javax.swing. RootPaneContainer

返回glassPane。

getGlobal() - Static method in class java.util.logging. Logger

返回名为Logger.GLOBAL_LOGGER_NAME的全局记录器对象。

getGlobalActiveWindow() - Method in class java.awt. KeyboardFocusManager

返回活动窗口，即使调用线程与活动窗口处于不同的上下文中。

getGlobalAlpha() - Method in class javafx.scene.canvas. GraphicsContext

获取当前的全局alpha。

getGlobalBlendMode() - Method in class javafx.scene.canvas. GraphicsContext

获取全局混合模式。

getGlobalCurrentFocusCycleRoot() - Method in class java.awt. KeyboardFocusManager

返回当前焦点循环根，即使调用线程与当前焦点循环根不同。

getGlobalFocusedWindow() - Method in class java.awt. KeyboardFocusManager

返回聚焦窗口，即使调用线程与聚焦窗口处于不同的上下文中。

getGlobalFocusOwner() - Method in class java.awt. KeyboardFocusManager

即使调用线程与焦点所有者的上下文不同，返回焦点所有者。

getGlobalPermanentFocusOwner() - Method in class java.awt. KeyboardFocusManager

返回永久焦点所有者，即使调用线程与永久焦点所有者处于不同的上下文中。

getGlobalTransactionId() - Method in interface javax.transaction.xa. Xid

获取XID的全局事务标识符作为字节数组。

getGlyphCharIndex(int) - Method in class java.awt.font. GlyphVector

返回指定字形的字符索引。

getGlyphCharIndices(int, int, int[]) - Method in class java.awt.font. GlyphVector

返回指定字形的字符索引。

getGlyphCode(int) - Method in class java.awt.font. GlyphVector

返回指定字形的字形代码。

getGlyphCodes(int, int, int[]) - Method in class java.awt.font. GlyphVector

返回指定字形的字形数组。

getGlyphJustificationInfo(int) - Method in class java.awt.font. GlyphVector

将指定索引中的字形的对齐信息返回到此 GlyphVector 。

getGlyphLogicalBounds(int) - Method in class java.awt.font. GlyphVector

返回此 GlyphVector指定字形的逻辑边界。

getGlyphMetrics(int) - Method in class java.awt.font. GlyphVector

将指定索引中的字形的度量返回到此 GlyphVector 。

getGlyphOutline(int) - Method in class java.awt.font. GlyphVector

返回一个 Shape其内部对应于此 GlyphVector指定字形的视觉表示。

getGlyphOutline(int, float, float) - Method in class java.awt.font. GlyphVector

返回一个 Shape其内部对应于该 GlyphVector内的指定字形的视觉表示，偏移到x，y。

getGlyphPainter() - Method in class javax.swing.text. GlyphView

获取当前安装的字形画家。

getGlyphPixelBounds(int, FontRenderContext, float, float) - Method in class java.awt.font. GlyphVector

当这个返回index字形的像素边界 GlyphVector在渲染 Graphics给定 FontRenderContext在给定位置。

getGlyphPosition(int) - Method in class java.awt.font. GlyphVector

返回指定字形相对于该 GlyphVector的原点的 GlyphVector 。

getGlyphPositions(int, int, float[]) - Method in class java.awt.font. GlyphVector

返回指定字形的字形位置数组。

getGlyphTransform(int) - Method in class java.awt.font. GlyphVector

返回此 GlyphVector指定字形的变换。

getGlyphVisualBounds(int) - Method in class java.awt.font. GlyphVector

返回 GlyphVector指定字形的视觉边界。

getGoHomeAction() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回回家行动。

getGrabbed() - Method in class javafx.scene.input. TouchPoint

获得抓住这个接触点的事件目标。

getGranularityPeriod() - Method in class javax.management.monitor. Monitor

获取粒度周期（以毫秒为单位）。

getGranularityPeriod() - Method in interface javax.management.monitor. MonitorMBean

获取粒度周期（以毫秒为单位）。

getGraphic() - Method in class javafx.scene.control. Dialog

获取属性图形的值。

getGraphic() - Method in class javafx.scene.control. DialogPane

获取属性图形的值。

getGraphic() - Method in class javafx.scene.control. Labeled

获取属性图形的值。

getGraphic() - Method in class javafx.scene.control. MenuItem

获取属性图形的值。

getGraphic() - Method in class javafx.scene.control. Tab

标签中显示的图形。

getGraphic() - Method in class javafx.scene.control. TableColumnBase

获取属性图形的值。

getGraphic() - Method in class javafx.scene.control. Tooltip

获取属性图形的值。

getGraphic() - Method in class javafx.scene.control. TreeItem

返回通常显示在value属性左侧的节点。

getGraphics() - Method in class java.awt. Component

为此组件创建图形上下文。

getGraphics() - Method in class java.awt.image. AbstractMultiResolutionImage

根据基础 Image#getGraphics()方法的合同，此实现将始终抛出 UnsupportedOperationException因为只有离屏图像可以返回 Graphics对象。

getGraphics() - Method in class java.awt.image. BufferedImage

此方法返回一个Graphics2D ，但这里是向后兼容性。

getGraphics() - Method in class java.awt. Image

创建图形上下文以绘制到离屏图像。

getGraphics() - Method in class java.awt.image. VolatileImage

此方法返回一个Graphics2D ，但这里是向后兼容性。

getGraphics() - Method in class java.awt. PrintJob

获取将绘制到下一页的Graphics对象。

getGraphics() - Method in class javax.swing. JApplet

已过时。

为此组件创建图形上下文。

getGraphics() - Method in class javax.swing. JComponent

返回此组件的图形上下文，可用于绘制组件。

getGraphics() - Method in class javax.swing. JDialog

为此组件创建图形上下文。

getGraphics() - Method in class javax.swing. JFrame

为此组件创建图形上下文。

getGraphics() - Method in class javax.swing. JWindow

为此组件创建图形上下文。

getGraphics() - Method in class javax.swing.text. View

获取 Graphics进行渲染。

getGraphicsConfiguration() - Method in class java.awt. Component

获取 GraphicsConfiguration与此 Component相关联。

getGraphicsContext2D() - Method in class javafx.scene.canvas. Canvas

返回 GraphicsContext与此 Canvas相关联。

getGraphicsUtils(SynthContext) - Method in class javax.swing.plaf.synth. SynthStyle

返回指定上下文的 SynthGraphicUtils 。

getGraphicTextGap() - Method in class javafx.scene.control. Labeled

获取属性graphicTextGap的值。

getGraphicTextGap() - Method in class javafx.scene.control. Tooltip

获取属性graphicTextGap的值。

getGreatestMinimum(int) - Method in class java.util. Calendar

返回此 Calendar实例的给定日历字段的最高最小值。

getGreatestMinimum(int) - Method in class java.util. GregorianCalendar

返回此 GregorianCalendar实例的给定日历字段的最高最小值。

getGreen() - Method in class java.awt. Color

返回默认sRGB空间中的0-255范围内的绿色组件。

getGreen() - Method in class javafx.scene.paint. Color

绿色成分 Color ，在 0.0-1.0的范围内。

getGreen() - Method in interface org.w3c.dom.css. RGBColor

该属性用于RGB颜色的绿色值。

getGreen(int) - Method in class java.awt.image. ColorModel

返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。

getGreen(int) - Method in class java.awt.image. ComponentColorModel

返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。

getGreen(int) - Method in class java.awt.image. DirectColorModel

返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getGreen(int) - Method in class java.awt.image. IndexColorModel

返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。

getGreen(Object) - Method in class java.awt.image. ColorModel

返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。

getGreen(Object) - Method in class java.awt.image. ComponentColorModel

返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getGreen(Object) - Method in class java.awt.image. DirectColorModel

返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getGreenMask() - Method in class java.awt.image. DirectColorModel

返回掩码，指示 int像素表示中的哪些位包含绿色分量。

getGreens(byte[]) - Method in class java.awt.image. IndexColorModel

将绿色组件数组复制到指定的数组中。

getGregorianChange() - Method in class java.util. GregorianCalendar

获取公历日历更改日期。

getGridColor() - Method in class javax.swing. JTable

返回用于绘制网格线的颜色。

getGridColumn() - Method in class javax.swing.text. TableView.TableCell

已过时。

获取网格位置的列

getGridRow() - Method in class javax.swing.text. TableView.TableCell

已过时。

获取网格位置的行

getGrooveInsets() - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils

返回由 drawGroove()绘制的边框占用的空间量

getGroup() - Method in class javax.swing. DefaultButtonModel

返回按钮所属的组。

getGroupID() - Method in class java.rmi.activation. ActivationDesc

返回由此描述符指定的对象的组标识符。

getGroupIDs() - Method in class com.sun.security.auth.module. NTSystem

获取当前NT用户的可打印组SID。

getGroupingSeparator() - Method in class java.text. DecimalFormatSymbols

获取用于千位分隔符的字符。

getGroupingSize() - Method in class java.text. DecimalFormat

返回分组大小。

getGroups() - Method in class com.sun.security.auth.module. SolarisSystem

已过时。

获取当前Solaris用户的补充组。

getGroups() - Method in class com.sun.security.auth.module. UnixSystem

获取当前Unix用户的补充组。

getGuarantor() - Method in interface java.security. Certificate

已过时。

返回证书的担保人，即与该证书相关联的公钥与该证书相关联的主体的主体。

getGuard() - Method in class jdk.dynalink.linker. GuardedInvocation

返回保护方法句柄。

getGuardedInvocation(LinkRequest) - Method in interface jdk.dynalink.linker. LinkerServices

创建一个守卫的调用委托回DynamicLinker公开这个链接器服务对象。

getGuardedInvocation(LinkRequest, LinkerServices) - Method in class jdk.dynalink.beans. BeansLinker

getGuardedInvocation(LinkRequest, LinkerServices) - Method in interface jdk.dynalink.linker. GuardingDynamicLinker

在调用站点上创建一个适合于具有指定参数的特定调用的保护调用。

getGuardedInvocation(LinkRequest, LinkerServices) - Method in class jdk.dynalink.linker.support. CompositeGuardingDynamicLinker

将呼叫委托给其组件链接器。

getGuardedInvocation(LinkRequest, LinkerServices) - Method in class jdk.dynalink.linker.support. CompositeTypeBasedGuardingDynamicLinker

getHAdjustable() - Method in class java.awt. ScrollPane

返回表示水平滚动条状态的 ScrollPaneAdjustable对象。

getHalignment() - Method in class javafx.scene.control. Separator

获取属性暂停的值。

getHalignment() - Method in class javafx.scene.layout. ColumnConstraints

获取属性暂停的值。

getHalignment(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，返回小孩的暂停约束。

getHandler() - Method in class com.sun.net.httpserver. HttpContext

返回此上下文的处理程序

getHandler() - Method in class javax.xml.transform.sax. SAXResult

获取结果的ContentHandler 。

getHandlerChain() - Method in interface javax.xml.ws. Binding

获取协议绑定实例的处理程序链的副本。

getHandlerChain(PortInfo) - Method in interface javax.xml.ws.handler. HandlerResolver

获取指定端口的处理程序链。

getHandlerResolver() - Method in class javax.xml.ws. Service

返回配置的处理程序解析器。

getHandlerResolver() - Method in class javax.xml.ws.spi. ServiceDelegate

返回配置的处理程序解析器。

getHandlers() - Method in class java.util.logging. Logger

获取与此记录器关联的处理程序。

getHandshakeApplicationProtocol() - Method in class javax.net.ssl. SSLEngine

返回当前正在进行的SSL / TLS握手协商的应用协议值。

getHandshakeApplicationProtocol() - Method in class javax.net.ssl. SSLSocket

返回当前正在进行的SSL / TLS握手协商的应用协议值。

getHandshakeApplicationProtocolSelector() - Method in class javax.net.ssl. SSLEngine

检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。

getHandshakeApplicationProtocolSelector() - Method in class javax.net.ssl. SSLSocket

检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。

getHandshakeSession() - Method in class javax.net.ssl. SSLEngine

返回在SSL / TLS / DTLS握手期间构建的 SSLSession 。

getHandshakeSession() - Method in class javax.net.ssl. SSLSocket

返回在SSL / TLS握手期间构建的 SSLSession 。

getHandshakeStatus() - Method in class javax.net.ssl. SSLEngine

返回此 SSLEngine的当前握手状态。

getHandshakeStatus() - Method in class javax.net.ssl. SSLEngineResult

获取 SSLEngine操作的握手状态。

getHardwareAddress() - Method in class java.net. NetworkInterface

返回接口的硬件地址（通常是MAC），如果它有一个，如果可以访问给定当前权限。

getHashColor() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回散列颜色。

getHbarPolicy() - Method in class javafx.scene.control. ScrollPane

获取属性hbarPolicy的值。

getHead(Handler) - Method in class java.util.logging. Formatter

返回一组格式化记录的标题字符串。

getHead(Handler) - Method in class java.util.logging. XMLFormatter

返回一组XML格式记录的标题字符串。

getHeader() - Method in class javafx.scene.control. DialogPane

用作对话框窗格标题的节点。

getHeader() - Method in interface javax.xml.soap. SOAPEnvelope

返回此 SOAPHeader对象的 SOAPEnvelope对象。

getHeader(String) - Method in class javax.xml.soap. MimeHeaders

将指定标题的所有值作为 String对象的数组 String 。

getHeaderField(int) - Method in class java.net. HttpURLConnection

返回的值 n th头字段。

getHeaderField(int) - Method in class java.net. URLConnection

返回的值 n th头字段。

getHeaderField(String) - Method in class java.net. URLConnection

返回命名头字段的值。

getHeaderFieldDate(String, long) - Method in class java.net. HttpURLConnection

getHeaderFieldDate(String, long) - Method in class java.net. URLConnection

返回以日期解析的命名字段的值。

getHeaderFieldInt(String, int) - Method in class java.net. URLConnection

返回被解析为命名字段的值。

getHeaderFieldKey(int) - Method in class java.net. HttpURLConnection

返回的关键 n th头字段。

getHeaderFieldKey(int) - Method in class java.net. URLConnection

返回的关键 n th头字段。

getHeaderFieldLong(String, long) - Method in class java.net. URLConnection

返回被解析为命名字段的值。

getHeaderFields() - Method in class java.net. URLConnection

返回不可修改的标题字段的映射。

getHeaderRect(int) - Method in class javax.swing.table. JTableHeader

返回包含标题图块的矩形为 column 。

getHeaderRenderer() - Method in class javax.swing.table. TableColumn

返回 TableCellRenderer用于绘制标题的 TableColumn 。

getHeaders() - Method in class java.net. CacheResponse

将响应标头作为Map返回。

getHeaders() - Method in interface javax.xml.ws.handler.soap. SOAPHandler

获取可由此处理程序实例处理的标题块。

getHeaders() - Method in interface org.w3c.dom.html. HTMLTableCellElement

标题单元的属性值为 id列表。

getHeaders(QName, JAXBContext, boolean) - Method in interface javax.xml.ws.handler.soap. SOAPMessageContext

从消息上下文中的消息获取具有特定限定名称的头文件。

getHeaderText() - Method in class javafx.scene.control. Dialog

返回此DialogPane的当前设置的标题文本。

getHeaderText() - Method in class javafx.scene.control. DialogPane

返回此DialogPane的当前设置的标题文本。

getHeaderValue() - Method in class javax.swing.table. TableColumn

返回用作标题渲染器的值的 Object 。

getHeapMemoryUsage() - Method in interface java.lang.management. MemoryMXBean

返回用于对象分配的堆的当前内存使用情况。

getHeight() - Method in class java.awt. Component

返回此组件的当前高度。

getHeight() - Method in class java.awt. Dimension

以双精度返回此 Dimension的高度。

getHeight() - Method in class java.awt. DisplayMode

返回显示的高度，以像素为单位。

getHeight() - Method in class java.awt.font. LineMetrics

返回文本的高度。

getHeight() - Method in class java.awt. FontMetrics

获取此字体中文本行的标准高度。

getHeight() - Method in class java.awt.geom. Arc2D.Double

以 double精度返回框架矩形的高度。

getHeight() - Method in class java.awt.geom. Arc2D.Float

返回 double精度的成帧矩形的高度。

getHeight() - Method in class java.awt.geom. Dimension2D

以双精度返回此 Dimension的高度。

getHeight() - Method in class java.awt.geom. Ellipse2D.Double

以 double精度返回框架矩形的高度。

getHeight() - Method in class java.awt.geom. Ellipse2D.Float

以 double精度返回框架矩形的高度。

getHeight() - Method in class java.awt.geom. Rectangle2D.Double

以 double精度返回框架矩形的高度。

getHeight() - Method in class java.awt.geom. Rectangle2D.Float

以 double精度返回框架矩形的高度。

getHeight() - Method in class java.awt.geom. RectangularShape

返回 double精度框架矩形的高度。

getHeight() - Method in class java.awt.geom. RoundRectangle2D.Double

以 double精度返回框架矩形的高度。

getHeight() - Method in class java.awt.geom. RoundRectangle2D.Float

以 double精度返回成帧矩形的高度。

getHeight() - Method in class java.awt.image. BufferedImage

返回 BufferedImage的高度。

getHeight() - Method in class java.awt.image. Kernel

返回此 Kernel的高度。

getHeight() - Method in class java.awt.image. PixelGrabber

获取像素缓冲区的高度（调整图像高度后）。

getHeight() - Method in class java.awt.image. Raster

返回栅格的高度（像素）。

getHeight() - Method in interface java.awt.image.renderable. RenderableImage

获取用户坐标空间中的高度。

getHeight() - Method in class java.awt.image.renderable. RenderableImageOp

获取用户坐标空间中的高度。

getHeight() - Method in interface java.awt.image. RenderedImage

返回RenderedImage的高度。

getHeight() - Method in class java.awt.image. SampleModel

返回以像素为单位的高度。

getHeight() - Method in class java.awt.image. VolatileImage

返回 VolatileImage的高度。

getHeight() - Method in class java.awt.print. PageFormat

返回页面的高1/7英寸的高度。

getHeight() - Method in class java.awt.print. Paper

返回页面的高度为1/72英寸。

getHeight() - Method in class java.awt. Rectangle

返回 double精度的边界 Rectangle的高度。

getHeight() - Method in class javafx.geometry. Bounds

这个高度 Bounds 。

getHeight() - Method in class javafx.geometry. Dimension2D

尺寸的高度。

getHeight() - Method in class javafx.geometry. Rectangle2D

这个高度 Rectangle2D 。

getHeight() - Method in class javafx.print. Paper

以磅数（1/72英寸）获取纸张的高度

getHeight() - Method in class javafx.scene.canvas. Canvas

获取属性高度的值。

getHeight() - Method in class javafx.scene.control. Dialog

返回对话框的高度。

getHeight() - Method in class javafx.scene.effect. BoxBlur

获取属性高度的值。

getHeight() - Method in class javafx.scene.effect. ColorInput

获取属性高度的值。

getHeight() - Method in class javafx.scene.effect. DropShadow

获取属性高度的值。

getHeight() - Method in class javafx.scene.effect. FloatMap

获取属性高度的值。

getHeight() - Method in class javafx.scene.effect. InnerShadow

获取属性高度的值。

getHeight() - Method in class javafx.scene.effect. Shadow

获取属性高度的值。

getHeight() - Method in class javafx.scene.image. Image

获取属性高度的值。

getHeight() - Method in class javafx.scene.layout. BackgroundSize

相关联的BackgroundImage应该呈现的区域内的区域的高度。

getHeight() - Method in class javafx.scene.layout. Region

获取属性高度的值。

getHeight() - Method in class javafx.scene.media. Media

检索媒体的像素高度。

getHeight() - Method in class javafx.scene.media. VideoTrack

检索轨道的高度。

getHeight() - Method in class javafx.scene.paint. ImagePattern

获取锚矩形的高度。

getHeight() - Method in class javafx.scene. Scene

获取属性高度的值。

getHeight() - Method in class javafx.scene.shape. Box

获取属性高度的值。

getHeight() - Method in class javafx.scene.shape. Cylinder

获取属性高度的值。

getHeight() - Method in class javafx.scene.shape. Rectangle

获取属性高度的值。

getHeight() - Method in class javafx.scene. SubScene

获取属性高度的值。

getHeight() - Method in class javafx.scene.web. WebView

获取属性高度的值。

getHeight() - Method in class javafx.stage. Window

获取属性高度的值。

getHeight() - Method in class javax.swing. JComponent

返回此组件的当前高度。

getHeight() - Method in class javax.swing. SpringLayout.Constraints

返回 height属性的值。

getHeight() - Method in class javax.swing.text. BoxView

返回框的当前高度。

getHeight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的height属性定义。

getHeight() - Method in interface org.w3c.dom.html. HTMLAppletElement

覆盖高度

getHeight() - Method in interface org.w3c.dom.html. HTMLIFrameElement

镜架高度

getHeight() - Method in interface org.w3c.dom.html. HTMLImageElement

覆盖高度

getHeight() - Method in interface org.w3c.dom.html. HTMLObjectElement

覆盖高度

getHeight() - Method in interface org.w3c.dom.html. HTMLTableCellElement

细胞高度

getHeight(int) - Method in class javax.imageio. ImageReader

返回输入源中给定图像的高度（以像素为单位）。

getHeight(int) - Method in class javax.print.attribute.standard. MediaPrintableArea

X- 2004545 X-

getHeight(ImageObserver) - Method in class java.awt.image. AbstractMultiResolutionImage

该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getHeight(observer) 。

getHeight(ImageObserver) - Method in class java.awt.image. BufferedImage

返回 BufferedImage的高度。

getHeight(ImageObserver) - Method in class java.awt. Image

确定图像的高度。

getHeight(GlyphView) - Method in class javax.swing.text. GlyphView.GlyphPainter

高度的回报。

getHeightOfHighValueLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最高值标签的高度。

getHeightOfLowValueLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最低值标签的高度。

getHeightOfTallestLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最高标签的高度。

getHelpMenu() - Method in class java.awt. MenuBar

获取菜单栏上的帮助菜单。

getHelpMenu() - Method in class javax.swing. JMenuBar

获取菜单栏的帮助菜单。

getHere() - Method in interface javax.xml.crypto.dom. DOMURIReference

返回此节点。

getHgap() - Method in class java.awt. BorderLayout

返回组件之间的水平间隙。

getHgap() - Method in class java.awt. CardLayout

获得组件之间的水平间隙。

getHgap() - Method in class java.awt. FlowLayout

获得组件之间以及组件之间的水平间隙和 Container的边框

getHgap() - Method in class java.awt. GridLayout

获得组件之间的水平间隙。

getHgap() - Method in class javafx.scene.layout. FlowPane

获取属性hgap的值。

getHgap() - Method in class javafx.scene.layout. GridPane

获取属性hgap的值。

getHgap() - Method in class javafx.scene.layout. TilePane

获取属性hgap的值。

getHgrow() - Method in class javafx.scene.layout. ColumnConstraints

获取属性hgrow的值。

getHgrow(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，返回小孩的hgrow约束。

getHgrow(Node) - Static method in class javafx.scene.layout. HBox

如果设置，返回小孩的hgrow约束。

getHideActionText() - Method in class javax.swing. AbstractButton

返回 hideActionText属性的值，它决定该按钮是否显示来自 Action文本。

getHideDelay() - Method in class javafx.scene.control. Tooltip

获取属性hideDelay的值。

getHierarchyBoundsListeners() - Method in class java.awt. Component

返回在此组件上注册的所有层次结构边界侦听器的数组。

getHierarchyListeners() - Method in class java.awt. Component

返回在此组件上注册的所有层级监听器的数组。

getHighestValue() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回标签表中有一个条目的最大值。

getHighestValueLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回与标签表中最低的滑块值对应的标签。

getHighlight() - Method in class javafx.scene.input. InputMethodTextRun

获取用于显示此文本的高亮。

getHighlightColor() - Method in class javax.swing.border. EtchedBorder

返回蚀刻边框的突出显示颜色。

getHighlightColor() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回突出显示颜色。

getHighlightColor(Component) - Method in class javax.swing.border. EtchedBorder

在指定的组件上渲染时返回蚀刻边框的突出显示颜色。

getHighlightedTextColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的突出显示的文本颜色。

getHighlightedTextColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回突出显示的文本颜色。

getHighlighter() - Method in class javax.swing.text. JTextComponent

获取负责制作亮点的对象。

getHighlightFill() - Method in class javafx.scene.control.skin. TextInputControlSkin

获取属性highlightFill的值。

getHighlightInnerColor() - Method in class javax.swing.border. BevelBorder

返回斜角边框的内部高亮颜色。

getHighlightInnerColor(Component) - Method in class javax.swing.border. BevelBorder

在指定的组件上渲染时返回斜角边框的内部高亮颜色。

getHighlightOuterColor() - Method in class javax.swing.border. BevelBorder

返回斜角边框的外部高亮颜色。

getHighlightOuterColor(Component) - Method in class javax.swing.border. BevelBorder

在指定的组件上呈现时，返回斜角边框的外部高亮颜色。

getHighlights() - Method in class javax.swing.text. DefaultHighlighter

备份亮点。

getHighlights() - Method in interface javax.swing.text. Highlighter

获取当前的亮点列表。

getHighlightTextFill() - Method in class javafx.scene.control.skin. TextInputControlSkin

获取属性highlightTextFill的值。

getHighThreshold() - Method in class javax.management.monitor. GaugeMonitor

获得所有观察到的MBean共有的高阈值。

getHighThreshold() - Method in interface javax.management.monitor. GaugeMonitorMBean

获得高阈值。

getHistoricalBytes() - Method in class javax.smartcardio. ATR

返回此ATR中历史字节的副本。

getHistory() - Method in class javafx.scene.web. WebEngine

返回会话历史记录对象。

getHmax() - Method in class javafx.scene.control. ScrollPane

获取属性hmax的值。

getHmin() - Method in class javafx.scene.control. ScrollPane

获取属性hmin的值。

getHoldability() - Method in interface java.sql. Connection

检索使用此 Connection对象创建的 ResultSet对象的当前可 Connection 。

getHoldability() - Method in interface java.sql. ResultSet

检索此 ResultSet对象的 ResultSet

getHoldCount() - Method in class java.util.concurrent.locks. ReentrantLock

查询当前线程对此锁的暂停数量。

getHoldCount() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock

查询当前线程对此写锁定的暂停数量。

getHomeDirectory() - Method in class javax.swing.filechooser. FileSystemView

返回主目录。

getHonorsVisibility() - Method in class javax.swing. GroupLayout

返回在确定组件的大小和位置时是否考虑组件可见性。

getHorizontalAlignment() - Method in class javax.swing. AbstractButton

返回图标和文字的水平对齐方式。

getHorizontalAlignment() - Method in class javax.swing. JLabel

返回标签内容沿X轴的对齐方式。

getHorizontalAlignment() - Method in class javax.swing. JTextField

返回文本的水平对齐方式。

getHorizontalLegBuffer() - Method in class javax.swing.plaf.basic. BasicTreeUI

默认情况下，节点之间的腿的水平元素从子节点左侧的右侧开始。

getHorizontalLegBuffer() - Method in class javax.swing.plaf.metal. MetalTreeUI

getHorizontalPosition() - Method in class javafx.scene.layout. BackgroundPosition

指示背景图像相对于由 horizontalSide属性指示的一侧的区域的位置的值。

getHorizontalScrollBar() - Method in class javafx.scene.control.skin. ScrollPaneSkin

返回此ScrollPaneSkin实例中使用的水平ScrollBar 。

getHorizontalScrollBar() - Method in class javax.swing. JScrollPane

返回控制视口水平视图位置的水平滚动条。

getHorizontalScrollBar() - Method in class javax.swing. ScrollPaneLayout

返回处理水平滚动的 JScrollBar对象。

getHorizontalScrollBarPolicy() - Method in class javax.swing. JScrollPane

返回水平滚动条策略值。

getHorizontalScrollBarPolicy() - Method in class javax.swing. ScrollPaneLayout

返回水平滚动条显示策略。

getHorizontalSide() - Method in class javafx.scene.layout. BackgroundPosition

背景图像被锚定在水平轴的一侧。

getHorizontalSliderThumbIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回水平滑块使用的缩略图标。

getHorizontalTextPosition() - Method in class javax.swing. AbstractButton

返回文本相对于图标的水平位置。

getHorizontalTextPosition() - Method in class javax.swing. JLabel

返回标签相对于其图像的文本的水平位置。

getHorizontalVisibility() - Method in class javax.swing. JTextField

获取文本字段的可见性。

getHost() - Method in class java.net. URI

返回此URI的主机组件。

getHost() - Method in class java.net. URL

获取此 URL的主机名（如适用）。

getHost() - Method in class javax.management.remote. JMXServiceURL

服务网址的主机部分。

getHostAddress() - Method in class java.net. Inet4Address

以文本表示形式返回IP地址字符串。

getHostAddress() - Method in class java.net. Inet6Address

返回文本显示中的IP地址字符串。

getHostAddress() - Method in class java.net. InetAddress

返回文本显示中的IP地址字符串。

getHostAddress(URL) - Method in class java.net. URLStreamHandler

获取我们的主机的IP地址。

getHostName() - Method in class java.net. InetAddress

获取此IP地址的主机名。

getHostName() - Method in class java.net. InetSocketAddress

获得 hostname 。

getHostnameVerifier() - Method in class javax.net.ssl. HttpsURLConnection

在这个实例上获得 HostnameVerifier 。

getHostServices() - Method in class javafx.application. Application

获取此应用程序的HostServices提供程序。

getHostString() - Method in class java.net. InetSocketAddress

如果没有主机名（使用文字创建），则返回主机名或地址的String形式。

getHotspotX() - Method in class javafx.scene. ImageCursor

获取属性hotspotX的值。

getHotspotY() - Method in class javafx.scene. ImageCursor

获取属性热点的值。

getHour() - Method in class java.time. LocalDateTime

获取时间字段。

getHour() - Method in class java.time. LocalTime

获取时间字段。

getHour() - Method in class java.time. OffsetDateTime

获取时间字段。

getHour() - Method in class java.time. OffsetTime

获取时间字段。

getHour() - Method in class java.time. ZonedDateTime

获取时间字段。

getHour() - Method in class javax.xml.datatype. XMLGregorianCalendar

如果未定义此字段，则返回小时数或 DatatypeConstants.FIELD_UNDEFINED 。

getHours() - Method in class java.sql. Date

已过时。

getHours() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.get(Calendar.HOUR_OF_DAY)替代。

getHours() - Method in class javax.xml.datatype. Duration

获取HOURS字段的值作为整数值，如果不存在，则为0。

getHpos() - Method in enum javafx.geometry. Pos

返回水平定位/对齐。

getHref() - Method in interface org.w3c.dom.css. CSSImportRule

要导入的样式表的位置。

getHref() - Method in interface org.w3c.dom.html. HTMLAnchorElement

链接资源的URI。

getHref() - Method in interface org.w3c.dom.html. HTMLAreaElement

链接资源的URI。

getHref() - Method in interface org.w3c.dom.html. HTMLBaseElement

基本URI。

getHref() - Method in interface org.w3c.dom.html. HTMLLinkElement

链接资源的URI。

getHref() - Method in interface org.w3c.dom.stylesheets. StyleSheet

如果样式表是链接的样式表，其属性的值就是它的位置。

getHreflang() - Method in interface org.w3c.dom.html. HTMLAnchorElement

链接资源的语言代码。

getHreflang() - Method in interface org.w3c.dom.html. HTMLLinkElement

链接资源的语言代码。

getHSBColor(float, float, float) - Static method in class java.awt. Color

基于HSB颜色模型的指定值创建一个 Color对象。

getHScrollbarHeight() - Method in class java.awt. ScrollPane

返回一个水平滚动条占用的高度，它与滚动窗格当前是否显示无关。

getHspace() - Method in interface org.w3c.dom.html. HTMLAppletElement

此图像左侧和右侧的水平空间，小程序或对象。

getHspace() - Method in interface org.w3c.dom.html. HTMLImageElement

此图像左侧和右侧的水平空间。

getHspace() - Method in interface org.w3c.dom.html. HTMLObjectElement

此图像左侧和右侧的水平空间，小程序或对象。

getHtml() - Method in class javafx.scene.input. Clipboard

从以前注册的剪贴板获取HTML文本字符串。

getHtml() - Method in class javafx.scene.input. ClipboardContent

从之前提供的 ClipboardContent获取HTML字符串。

getHTMLBaseline(View, int, int) - Static method in class javax.swing.plaf.basic. BasicHTML

返回html渲染器的基线。

getHTMLDocument(JEditorPane) - Method in class javax.swing.text.html. HTMLEditorKit.HTMLTextAction

getHTMLEditorKit(JEditorPane) - Method in class javax.swing.text.html. HTMLEditorKit.HTMLTextAction

getHtmlFor() - Method in interface org.w3c.dom.html. HTMLLabelElement

此属性将此标签与另一个表单控件 id属性相链接。

getHtmlFor() - Method in interface org.w3c.dom.html. HTMLScriptElement

留作将来使用。

getHTMLTag() - Method in class javax.swing.text.html.parser. TagElement

返回与 element的名称相对应的标签常量

getHtmlText() - Method in class javafx.scene.web. HTMLEditor

返回编辑器的HTML内容。

getHttpContext() - Method in class com.sun.net.httpserver. HttpExchange

获取此交换的HttpContext

getHttpContext() - Method in class javax.xml.ws.spi.http. HttpExchange

返回此交换的HttpContext 。

getHttpEquiv() - Method in interface org.w3c.dom.html. HTMLMetaElement

HTTP响应头名称。

getHttpsConfigurator() - Method in class com.sun.net.httpserver. HttpsParameters

返回此HttpsParameters的HttpsConfigurator。

getHttpsConfigurator() - Method in class com.sun.net.httpserver. HttpsServer

获取此服务器的HttpsConfigurator对象，如果已设置。

getHue() - Method in class javafx.scene.effect. ColorAdjust

获取属性色调的值。

getHue() - Method in class javafx.scene.paint. Color

获得这个 Color的色调分量。

getHumanPresentableName() - Method in class java.awt.datatransfer. DataFlavor

返回 DataFlavor表示的数据格式的人性化名称。

getHumanPresentableName() - Method in class javax.activation. ActivationDataFlavor

返回人类可呈现的名称。

getHvalue() - Method in class javafx.scene.control. ScrollPane

获取属性h值的值。

getHyperlinkListeners() - Method in class javax.swing. JEditorPane

返回使用addHyperlinkListener（）添加到此JEditorPane的所有 HyperLinkListener的数组。

getICC_Profiles() - Method in class java.awt.image. ColorConvertOp

返回用于构造此ColorConvertOp的ICC_Profiles数组。

getIcon() - Method in class javax.swing. AbstractButton

返回默认图标。

getIcon() - Method in class javax.swing. JLabel

返回标签显示的图形图像（字形，图标）。

getIcon() - Method in class javax.swing. JOptionPane

返回此窗格显示的图标。

getIcon() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

从 JOptionPane返回图标，接收器提供外观，或从 getDefaultIcon返回的默认图标。

getIcon(int) - Method in interface java.beans. BeanInfo

返回可用于在工具箱或工具栏中表示bean的图像。

getIcon(int) - Method in class java.beans. SimpleBeanInfo

声明没有可用的图标。

getIcon(File) - Method in class javax.swing.filechooser. FileView

在 JFileChooser中代表此文件的 JFileChooser 。

getIcon(File) - Method in class javax.swing. JFileChooser

返回此文件或文件类型的图标，具体取决于系统。

getIcon(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

在 JFileChooser中代表此文件的 JFileChooser 。

getIcon(Object) - Method in class javax.swing. UIDefaults

如果值 key是 Icon返回它，否则返回 null 。

getIcon(Object) - Static method in class javax.swing. UIManager

从默认值返回一个 Icon 。

getIcon(Object, Locale) - Method in class javax.swing. UIDefaults

如果 key的 Locale为 Icon回报，否则返回 null 。

getIcon(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回 Icon 。

getIcon(AbstractButton) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回用于绘制按钮的图标。

getIcon(SynthContext, Object) - Method in class javax.swing.plaf.synth. SynthStyle

方便的方法来获取一个特定的样式属性，其值是一个Icon。

getIcon(AttributeSet) - Static method in class javax.swing.text. StyleConstants

从属性列表中获取图标设置。

getIconAt(int) - Method in class javax.swing. JTabbedPane

返回标签图标 index 。

getIconForTab(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回标签的图标。

getIconForType(int) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回用于传入类型的图标。

getIconHeight() - Method in interface javax.swing. Icon

返回图标的高度。

getIconHeight() - Method in class javax.swing. ImageIcon

获取图标的高度。

getIconHeight() - Method in class javax.swing.plaf. IconUIResource

getIconHeight() - Method in class javax.swing.plaf.metal. MetalCheckBoxIcon

getIconHeight() - Method in class javax.swing.plaf.metal. MetalComboBoxIcon

创建一个存根来满足界面。

getIconHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.FileIcon16

getIconHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.FolderIcon16

getIconHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.PaletteCloseIcon

getIconHeight() - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeControlIcon

getIconHeight() - Method in interface javax.swing.plaf.synth. SynthIcon

getIconHeight(Icon, SynthContext) - Static method in class javax.swing.plaf.synth. SynthGraphicsUtils

返回图标的高度。

getIconHeight(SynthContext) - Method in interface javax.swing.plaf.synth. SynthIcon

返回给定合成器上下文的图标的高度。

getIconImage() - Method in class java.awt. Frame

返回要显示的图像作为此框架的图标。

getIconImage() - Method in class java.awt. Taskbar

获取此应用程序图标的图像。

getIconImages() - Method in class java.awt. Window

返回要显示为此窗口的图标的图像序列。

getIcons() - Method in class javafx.stage. Stage

获取窗口装饰中使用的图标图像和最小化时。

getIconTextGap() - Method in class javax.swing. AbstractButton

返回文本与此按钮中显示的图标之间的空格量。

getIconTextGap() - Method in class javax.swing. JLabel

返回文本与此标签中显示的图标之间的空间量。

getIconWidth() - Method in interface javax.swing. Icon

返回图标的宽度。

getIconWidth() - Method in class javax.swing. ImageIcon

获取图标的宽度。

getIconWidth() - Method in class javax.swing.plaf. IconUIResource

getIconWidth() - Method in class javax.swing.plaf.metal. MetalCheckBoxIcon

getIconWidth() - Method in class javax.swing.plaf.metal. MetalComboBoxIcon

创建一个存根来满足界面。

getIconWidth() - Method in class javax.swing.plaf.metal. MetalIconFactory.FileIcon16

getIconWidth() - Method in class javax.swing.plaf.metal. MetalIconFactory.FolderIcon16

getIconWidth() - Method in class javax.swing.plaf.metal. MetalIconFactory.PaletteCloseIcon

getIconWidth() - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeControlIcon

getIconWidth() - Method in interface javax.swing.plaf.synth. SynthIcon

getIconWidth(Icon, SynthContext) - Static method in class javax.swing.plaf.synth. SynthGraphicsUtils

返回图标的宽度。

getIconWidth(SynthContext) - Method in interface javax.swing.plaf.synth. SynthIcon

返回给定合成上下文的图标的宽度。

getId() - Method in class com.sun.management. GcInfo

返回此垃圾收集的标识符，该收集器是收集器完成的集合数。

getId() - Method in class java.lang. Thread

返回此线程的标识符。

getId() - Method in interface java.security.cert. Extension

获取扩展的对象标识符。

getId() - Method in interface java.time.chrono. Chronology

获取年表的ID。

getId() - Method in class java.time.chrono. HijrahChronology

获取年表的ID。

getId() - Method in class java.time.chrono. IsoChronology

获取年表的ID - “ISO”。

getId() - Method in class java.time.chrono. JapaneseChronology

获取年表的ID - “日语”。

getId() - Method in class java.time.chrono. MinguoChronology

获取年代的ID - “Minguo”。

getId() - Method in class java.time.chrono. ThaiBuddhistChronology

获取年代的ID - “泰国人”。

getId() - Method in class java.time. ZoneId

获取唯一的时区ID。

getId() - Method in class java.time. ZoneOffset

获取标准化区域偏移ID。

getId() - Method in class javafx.css. SimpleSelector

getId() - Method in interface javafx.css. Styleable

这个id的这个 Styleable 。

getId() - Method in class javafx.scene.control. MenuItem

获取属性ID的值。

getId() - Method in class javafx.scene.control. PopupControl

该 PopupControl为 PopupControl 。

getId() - Method in class javafx.scene.control. Tab

此选项卡的ID。

getId() - Method in class javafx.scene.control. TableColumnBase

获取属性ID的值。

getId() - Method in class javafx.scene.input. TouchPoint

获取此接触点的标识符。

getId() - Method in class javafx.scene. Node

这个id的这个 Node 。

getId() - Method in interface javax.net.ssl. SSLSession

返回分配给此会话的标识符。

getId() - Method in interface javax.xml.crypto.dsig.keyinfo. KeyInfo

返回此 KeyInfo的可选Id属性，这对于从其他XML结构引用此 KeyInfo可能很有用。

getId() - Method in interface javax.xml.crypto.dsig. Manifest

返回此 Manifest的ID。

getId() - Method in interface javax.xml.crypto.dsig. Reference

返回此 Reference的可选 Id属性，该属性允许从其他地方引用该引用。

getId() - Method in interface javax.xml.crypto.dsig. SignatureProperties

返回此 SignatureProperties的ID。

getId() - Method in interface javax.xml.crypto.dsig. SignatureProperty

返回此 SignatureProperty的ID。

getId() - Method in interface javax.xml.crypto.dsig. SignedInfo

返回此 SignedInfo的可选 Id属性。

getId() - Method in interface javax.xml.crypto.dsig. XMLObject

返回此 XMLObject的ID。

getId() - Method in interface javax.xml.crypto.dsig. XMLSignature

返回此 XMLSignature的可选ID。

getId() - Method in interface javax.xml.crypto.dsig. XMLSignature.SignatureValue

返回此 SignatureValue的可选 Id属性，该属性允许从其他地方引用此元素。

getId() - Method in class javax.xml.datatype. DatatypeConstants.Field

获取此字段的ID。

getId() - Method in exception org.omg.CORBA.portable. ApplicationException

返回异常的CORBA存储库ID，而不从异常输入流中删除它。

getId() - Method in interface org.w3c.dom.html. HTMLElement

元素的标识符。

getID() - Method in class java.awt. AWTEvent

返回事件类型。

getID() - Method in class java.rmi.activation. Activatable

返回对象的激活标识符。

getID() - Method in class java.util. TimeZone

获取此时区的ID。

getID() - Method in interface javax.naming.directory. Attribute

检索此属性的ID。

getID() - Method in class javax.naming.directory. BasicAttribute

getID() - Method in class javax.naming.ldap. BasicControl

检索控件的对象标识符字符串。

getID() - Method in interface javax.naming.ldap. Control

检索分配给LDAP控件的对象标识符。

getID() - Method in interface javax.naming.ldap. ExtendedRequest

检索请求的对象标识符。

getID() - Method in interface javax.naming.ldap. ExtendedResponse

检索响应的对象标识符。

getID() - Method in class javax.naming.ldap. StartTlsRequest

检索StartTLS请求的对象标识符字符串。

getID() - Method in class javax.naming.ldap. StartTlsResponse

检索StartTLS响应的对象标识符字符串。

getID() - Method in class javax.swing. LookAndFeel

返回一个识别这种外观和感觉的字符串。

getID() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

返回此外观的标识符。

getID() - Method in class javax.swing.plaf.multi. MultiLookAndFeel

返回一个适用于应用程序/服务的字符串，用于标识这种外观。

getID() - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

返回一个识别这种外观和感觉的字符串。

getID() - Method in class javax.swing.plaf.synth. ColorType

为此ColorType返回唯一的ID作为整数。

getID() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回一个识别这种外观和感觉的字符串。

getID() - Method in class javax.xml.ws. RespectBindingFeature

获取此WebServiceFeature的唯一标识符。

getID() - Method in class javax.xml.ws.soap. AddressingFeature

获取此WebServiceFeature的唯一标识符。

getID() - Method in class javax.xml.ws.soap. MTOMFeature

获取此WebServiceFeature的唯一标识符。

getID() - Method in class javax.xml.ws. WebServiceFeature

获取此WebServiceFeature的唯一标识符。

getIdentifier() - Method in interface com.sun.source.tree. MemberSelectTree

返回要选择的成员的名称。

getIdentifier() - Method in interface com.sun.source.tree. NewClassTree

返回要实例化的类的名称。

getIdentifier() - Method in class javax.swing. RowFilter.Entry

返回条目的标识符（在模型中）。

getIdentifier() - Method in class javax.swing.table. TableColumn

返回此列的 identifier对象。

getIdentifier() - Method in interface jdk.nashorn.api.tree. MemberSelectTree

返回属性的名称。

getIdentifier() - Method in interface org.w3c.dom.css. Counter

该属性用于计数器的标识符。

getIdentifier(int) - Method in class javax.swing. DefaultRowSorter.ModelWrapper

返回指定行的标识符。

getIdentifierQuoteString() - Method in interface java.sql. DatabaseMetaData

检索用于引用SQL标识符的字符串。

getIdentifiers() - Method in class javafx.scene.input. DataFormat

获取此DataFormat的不可修改的标识符集。

getIdentity(String) - Method in class java.security. IdentityScope

已过时。

以指定的名称（如果有）返回此范围中的身份。

getIdentity(Principal) - Method in class java.security. IdentityScope

已过时。

检索其名称与指定的主体相同的身份。

getIdentity(PublicKey) - Method in class java.security. IdentityScope

已过时。

使用指定的公钥检索身份。

getIdentityGuard(Object) - Static method in class jdk.dynalink.linker.support. Guards

创建一个保护方法，测试其唯一的参数与其他对象的位置相同

getIdentityHashCode() - Method in class java.lang.management. LockInfo

返回从 System.identityHashCode(java.lang.Object)方法返回的锁对象的标识哈希码。

getIds() - Method in interface javax.net.ssl. SSLSessionContext

返回所有会话ID的枚举，分组在这个 SSLSessionContext 。

getIDs() - Method in interface javax.naming.directory. Attributes

检索属性集中属性ID的枚举。

getIDs() - Method in class javax.naming.directory. BasicAttributes

getIDstring() - Method in class java.awt. GraphicsDevice

返回与此 GraphicsDevice相关联的标识字符串。

getIfModifiedSince() - Method in class java.net. URLConnection

返回此对象的 ifModifiedSince字段的值。

getIgnoreRepaint() - Method in class java.awt. Component

getImage() - Method in class java.awt. TexturePaint

返回用于填充形状的 BufferedImage纹理。

getImage() - Method in class java.awt. TrayIcon

返回用于此 TrayIcon的当前图像。

getImage() - Method in class javafx.scene.image. ImageView

获取属性映像的值。

getImage() - Method in class javafx.scene. ImageCursor

获取属性映像的值。

getImage() - Method in class javafx.scene.input. Clipboard

从先前已注册的剪贴板获取图像。

getImage() - Method in class javafx.scene.input. ClipboardContent

从 ClipboardContent获取图像，以前已经被放置。

getImage() - Method in class javafx.scene.layout. BackgroundImage

要使用的图像。

getImage() - Method in class javafx.scene.layout. BorderImage

要使用的图像。

getImage() - Method in class javafx.scene.paint. ImagePattern

获取要用作油漆的图像。

getImage() - Method in class javafx.scene. SnapshotResult

获取快照操作生成的图像。

getImage() - Method in class javax.swing. ImageIcon

返回此图标的 Image 。

getImage() - Method in class javax.swing.text.html. ImageView

返回要呈现的图像。

getImage(String) - Method in class java.awt. Toolkit

返回从指定文件获取像素数据的图像，其格式可以是GIF，JPEG或PNG。

getImage(URL) - Method in class java.applet. Applet

已过时。

返回一个 Image对象，然后可以在屏幕上绘制。

getImage(URL) - Method in interface java.applet. AppletContext

已过时。

返回一个 Image对象，然后可以在屏幕上绘制。

getImage(URL) - Method in class java.awt. Toolkit

返回从指定的URL获取像素数据的图像。

getImage(URL, String) - Method in class java.applet. Applet

已过时。

返回一个 Image对象，然后可以在屏幕上绘制。

getImageableHeight() - Method in class java.awt.print. PageFormat

返回页面可成像区域的高度，以1/72英寸为单位。

getImageableHeight() - Method in class java.awt.print. Paper

返回此 Paper对象的可成像区域的高度。

getImageableWidth() - Method in class java.awt.print. PageFormat

返回页面可成像区域的宽度（以1/72英寸为单位）。

getImageableWidth() - Method in class java.awt.print. Paper

返回此 Paper对象的可成像区域的宽度。

getImageableX() - Method in class java.awt.print. PageFormat

返回与此 PageFormat相关联的 Paper对象的可成像区域的左上角的x坐标。

getImageableX() - Method in class java.awt.print. Paper

返回此 Paper对象的可成像区域的左上角的x坐标。

getImageableY() - Method in class java.awt.print. PageFormat

返回与此 PageFormat相关联的 Paper对象的可成像区域的左上角的y坐标。

getImageableY() - Method in class java.awt.print. Paper

返回此 Paper对象的可成像区域的左上角的y坐标。

getImageCapabilities() - Method in class java.awt. GraphicsConfiguration

返回此 GraphicsConfiguration的图像功能。

getImageLoadStatus() - Method in class javax.swing. ImageIcon

返回图像加载操作的状态。

getImageMetadata(int) - Method in class javax.imageio. ImageReader

返回一个 IIOMetadata与给定图像，或相关联的对象包含元数据 null如果读取器不支持读取元数据，被设置为忽略元数据，或者，如果没有元数据可用。

getImageMetadata(int, String, Set<String>) - Method in class javax.imageio. ImageReader

返回一个 IIOMetadata表示与给定图像，或相关联的元数据对象 null如果读取器不支持读取元数据或没有可用的。

getImageMetadataFormat(String) - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回一个 IIOMetadataFormat对象描述给定的图像的元数据格式，或 null如果没有可用的描述。

getImageObserver() - Method in class javax.swing. ImageIcon

返回图像的图像观察者。

getImageReader(ImageWriter) - Static method in class javax.imageio. ImageIO

返回一个 ImageReader对应于给定 ImageWriter ，如果有一个或 null如果插件在此 ImageWriter没有指定相应 ImageReader ，如果给定 ImageWriter未注册。

getImageReaders(Object) - Static method in class javax.imageio. ImageIO

返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码所提供的 Object ，通常为 ImageInputStream 。

getImageReadersByFormatName(String) - Static method in class javax.imageio. ImageIO

返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码命名格式。

getImageReadersByMIMEType(String) - Static method in class javax.imageio. ImageIO

返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码具有给定MIME类型的文件。

getImageReadersBySuffix(String) - Static method in class javax.imageio. ImageIO

返回一个 Iterator包含所有当前已注册 ImageReader s表示声称能够将文件与给定后缀的解码。

getImageReaderSpiNames() - Method in class javax.imageio.spi. ImageWriterSpi

返回一个包含 String的数组， String包含所有 ImageReaderSpi类的所有完全限定名称，可以理解与此服务提供商关联的 ImageWriter所使用的内部元数据表示，或者如果没有指定此 null则 ImageReaders 。

getImages() - Method in class javafx.scene.layout. Background

BackgroundImages的列表，它们一起定义了此Background的图像部分。

getImages() - Method in class javafx.scene.layout. Border

BorderImages的列表，它们一起定义要使用的图像，而不是此边框的笔画。

getImages() - Method in interface org.w3c.dom.html. HTMLDocument

一个文件中的所有 IMG元素的集合。

getImageTranscoders(ImageReader, ImageWriter) - Static method in class javax.imageio. ImageIO

返回 Iterator含所有当前已注册 ImageTranscoder s表示声称能够在给定的元数据之间进行代码转换 ImageReader和 ImageWriter 。

getImageTypes(int) - Method in class javax.imageio. ImageReader

返回一个 Iterator其中包含可以解码给定图像的可能图像类型，格式为 ImageTypeSpecifiers s。

getImageURL() - Method in class java.awt. SplashScreen

返回当前的闪屏图像。

getImageURL() - Method in class javax.swing.text.html. ImageView

返回图像源的URL，如果无法确定，则返回null。

getImageWriter(ImageReader) - Static method in class javax.imageio. ImageIO

返回一个 ImageWriter对应于给定 ImageReader ，如果有一个或 null如果插件在此 ImageReader没有指定相应 ImageWriter ，如果给定 ImageReader未注册。

getImageWriters(ImageTypeSpecifier, String) - Static method in class javax.imageio. ImageIO

返回 Iterator含所有当前已注册 ImageWriter s表示声称能够编码给定的布局的图像（使用指定 ImageTypeSpecifier在给定的格式）。

getImageWritersByFormatName(String) - Static method in class javax.imageio. ImageIO

返回一个 Iterator包含所有当前已注册 ImageWriter s表示声称能够编码指定格式。

getImageWritersByMIMEType(String) - Static method in class javax.imageio. ImageIO

返回一个 Iterator包含所有当前已注册 ImageWriter s表示声称能够使用给定的MIME类型编码的文件。

getImageWritersBySuffix(String) - Static method in class javax.imageio. ImageIO

返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够使用给定的后缀对文件进行编码。

getImageWriterSpiNames() - Method in class javax.imageio.spi. ImageReaderSpi

返回的数组 String包含所有的完全合格的名称小号 ImageWriterSpi类，可以理解由所使用的内部元数据表示 ImageReader与此服务提供商相关联，或 null如果没有这样的 ImageWriter指定秒。

getImpact() - Method in class javax.management. MBeanOperationInfo

返回方法的影响，其中 INFO, ACTION, ACTION_INFO, UNKNOWN 。

getImpact() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo

返回一个 int常数，限定此 OpenMBeanOperationInfo实例描述的操作的影响。

getImpact(MBeanOperationInfo) - Method in class javax.management. StandardMBean

自定义钩子：获取将在此MBean返回的MBeanOperationInfo中使用的操作的 影响标志。

getImpersonationToken() - Method in class com.sun.security.auth.module. NTSystem

获取当前NT用户的模拟令牌。

getImplClass() - Method in class java.lang.invoke. SerializedLambda

获取包含实现方法的类的名称。

getImplementation() - Method in class javax.management. StandardMBean

获取此标准MBean（或MXBean）的实现。

getImplementation() - Method in interface org.w3c.dom. Document

处理此文档的 DOMImplementation对象。

getImplementationClass() - Method in class javax.management. StandardMBean

获取此标准MBean（或MXBean）的实现类。

getImplementationName() - Method in class javax.management. MBeanServerDelegate

返回JMX实现名称（此产品的名称）。

getImplementationName() - Method in interface javax.management. MBeanServerDelegateMBean

返回JMX实现名称（此产品的名称）。

getImplementationNames() - Method in interface com.sun.source.tree. ProvidesTree

返回正在提供的实现类型的名称。

getImplementations() - Method in interface javax.lang.model.element. ModuleElement.ProvidesDirective

返回正在提供的服务的实现。

getImplementationTitle() - Method in class java.lang. 软件包

返回此包的标题。

getImplementationVendor() - Method in class java.lang. 软件包

返回实现此软件包的供应商，如果不知道则返回 null 。

getImplementationVendor() - Method in class javax.management. MBeanServerDelegate

返回JMX实现供应商（该产品的供应商）。

getImplementationVendor() - Method in interface javax.management. MBeanServerDelegateMBean

返回JMX实现供应商（该产品的供应商）。

getImplementationVersion() - Method in class java.lang. 软件包

返回这个实现的版本。

getImplementationVersion() - Method in class javax.management. MBeanServerDelegate

返回JMX实现版本（此产品的版本）。

getImplementationVersion() - Method in interface javax.management. MBeanServerDelegateMBean

返回JMX实现版本（此产品的版本）。

getImplementor() - Method in class javax.xml.ws. Endpoint

返回此端点的实现对象。

getImplementsClause() - Method in interface com.sun.source.tree. ClassTree

返回由此类型声明实现的接口。

getImplicitDownCycleTraversal() - Method in class java.awt. ContainerOrderFocusTraversalPolicy

返回此ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行循环。

getImplicitDownCycleTraversal() - Method in class javax.swing. SortingFocusTraversalPolicy

返回此SortingFocusTraversalPolicy是否隐式转移焦点下行周期。

getImplMethodKind() - Method in class java.lang.invoke. SerializedLambda

获取方法处理类（见MethodHandleInfo ）的实现方法。

getImplMethodName() - Method in class java.lang.invoke. SerializedLambda

获取实现方法的名称。

getImplMethodSignature() - Method in class java.lang.invoke. SerializedLambda

获取实现方法的签名。

getImportedKeys(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索给定表的外键列（由表导入的主键）引用的主键列的描述。

getImportEntries() - Method in interface jdk.nashorn.api.tree. ModuleTree

返回导入条目的列表。

getImportName() - Method in interface jdk.nashorn.api.tree. ExportEntryTree

返回条目的导入名称。

getImportName() - Method in interface jdk.nashorn.api.tree. ImportEntryTree

返回条目的导入名称。

getImports() - Method in interface com.sun.source.tree. CompilationUnitTree

返回此编译单元中出现的导入声明。

getInactiveControlTextColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的非活动控件文本颜色。

getInactiveControlTextColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回非活动控件文本颜色。

getInactiveControlTextColor() - Method in class javax.swing.plaf.metal. OceanTheme

返回非活动控件文本颜色。

getInactiveSystemTextColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的非活动系统文本颜色。

getInactiveSystemTextColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回非活动的系统文本颜色。

getInCheck() - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。

getIncludedElements() - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回文档中应为 included的模块，包和类型元素。

getIndent() - Method in class javafx.scene.control.skin. TreeCellSkin

获取属性缩进的值。

getIndent() - Method in class javafx.scene.control.skin. TreeTableRowSkin

获取属性缩进的值。

getIndentLevel() - Method in class javax.swing.text. AbstractWriter

返回当前缩进级别。

getIndentSpace() - Method in class javax.swing.text. AbstractWriter

返回要缩进的空间量。

getIndex() - Method in interface com.sun.source.tree. ArrayAccessTree

返回索引的表达式。

getIndex() - Method in class java.beans. IndexedPropertyChangeEvent

获取已更改的属性的索引。

getIndex() - Method in class java.net. NetworkInterface

返回此网络接口的索引。

getIndex() - Method in exception java.net. URISyntaxException

将索引返回到发生解析错误的位置的输入字符串，如果此位置 -1则 -1 。

getIndex() - Method in exception java.nio.file. InvalidPathException

返回到发生错误的位置的输入字符串中的索引，如果该位置 -1则 -1 。

getIndex() - Method in exception java.security.cert. CertPathValidatorException

返回导致异常抛出的证书路径中的证书的索引。

getIndex() - Method in exception java.sql. DataTruncation

检索被截断的列或参数的索引。

getIndex() - Method in interface java.text. CharacterIterator

返回当前索引。

getIndex() - Method in class java.text. ParsePosition

检索当前的解析位置。

getIndex() - Method in class java.text. StringCharacterIterator

为String实现CharacterIterator.getIndex（）。

getIndex() - Method in exception java.util.regex. PatternSyntaxException

检索错误索引。

getIndex() - Method in class javafx.css. StyleClass

getIndex() - Method in class javafx.scene.control. IndexedCell

返回此单元格在底层控件数据模型中的索引。

getIndex() - Method in class javafx.scene.control. ListView.EditEvent

返回编辑发生的索引。

getIndex() - Method in interface javax.swing.event. DocumentEvent.ElementChange

获取代表的元素中的索引。

getIndex() - Method in class javax.swing. JList.DropLocation

返回列表中放置数据的索引。

getIndex() - Method in class javax.swing.text. AbstractDocument.ElementEdit

将索引返回到元素列表中。

getIndex() - Method in class javax.swing.text.html.parser. Element

获取索引。

getIndex() - Method in class javax.swing.text. JTextComponent.DropLocation

返回索引，其中删除的数据应插入关联的组件。

getIndex() - Method in class javax.swing.text. Segment

返回当前索引。

getIndex() - Method in interface jdk.nashorn.api.tree. ArrayAccessTree

返回访问的数组元素的索引。

getIndex() - Method in interface org.w3c.dom.html. HTMLOptionElement

该指数 OPTION在其母公司 SELECT ，从0开始。

getIndex(double, double) - Method in class javafx.scene.control.skin. TextAreaSkin

执行命中测试，映射到内容中的索引。

getIndex(double, double) - Method in class javafx.scene.control.skin. TextFieldSkin

执行命中测试，映射到内容中的索引。

getIndex(int) - Method in class javax.swing. SizeSequence

返回与指定位置对应的条目的索引。

getIndex(String) - Method in interface org.xml.sax. Attributes

通过XML合格（前缀）名称查找属性的索引。

getIndex(String) - Method in class org.xml.sax.helpers. AttributesImpl

通过合格（前缀）名称查找属性的索引。

getIndex(String, String) - Method in interface org.xml.sax. Attributes

通过命名空间名称查找属性的索引。

getIndex(String, String) - Method in class org.xml.sax.helpers. AttributesImpl

通过命名空间名称查找属性的索引。

getIndex(TreeNode) - Method in class javax.swing.text. AbstractDocument.AbstractElement

返回接收者子项中的索引 node 。

getIndex(TreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的子数组中指定子节点的索引。

getIndex(TreeNode) - Method in interface javax.swing.tree. TreeNode

返回接收儿童中的 node的索引。

getIndex0() - Method in class javax.swing.event. ListDataEvent

返回范围的较低的索引。

getIndex1() - Method in class javax.swing.event. ListDataEvent

返回范围的上部索引。

getIndexAtPoint(Point) - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

给定本地坐标点，返回该点下的字符从零开始的索引。

getIndexAtPoint(Point) - Method in interface javax.accessibility. AccessibleText

给定局部坐标点，返回该点下的字符的从零开始的索引。

getIndexAtPoint(Point) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

给定本地坐标点，返回该点下的字符从零开始的索引。

getIndexAtPoint(Point) - Method in class javax.swing. JLabel.AccessibleJLabel

给定本地坐标点，返回该点下的字符从零开始的索引。

getIndexAtPoint(Point) - Method in class javax.swing. JSpinner.AccessibleJSpinner

给定本地坐标点，返回该点下的字符从零开始的索引。

getIndexAtPoint(Point) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

给定本地坐标点，返回该点下的字符从零开始的索引。

getIndexAtPoint(Point) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

给定本地坐标点，返回该点下的字符从零开始的索引。

getIndexedPropertyType() - Method in class java.beans. IndexedPropertyDescriptor

返回索引属性的Java类型信息。

getIndexedReadMethod() - Method in class java.beans. IndexedPropertyDescriptor

获取应用于读取索引属性值的方法。

getIndexedWriteMethod() - Method in class java.beans. IndexedPropertyDescriptor

获取应用于编写索引属性值的方法。

getIndexInfo(String, String, String, boolean, boolean) - Method in interface java.sql. DatabaseMetaData

检索给定表的索引和统计信息的描述。

getIndexNames() - Method in class javax.management.openmbean. TabularType

按照与此实例的构造函数相同的顺序返回一个不可修改的列表，其名称的值用于唯一索引此 TabularType实例描述的表格数据值的每个行元素。

getIndexOf(Component) - Method in class javax.swing. JLayeredPane

返回指定Component的索引。

getIndexOf(Object) - Method in class javax.swing. DefaultComboBoxModel

返回列表中指定对象的索引位置。

getIndexOfChild(Object, Object) - Method in class javax.swing.tree. DefaultTreeModel

返回父项中的子项的索引。

getIndexOfChild(Object, Object) - Method in interface javax.swing.tree. TreeModel

返回父项中的子项的索引。

getIndexOfSize(float) - Static method in class javax.swing.text.html. StyleSheet

返回HTML / CSS大小模型的索引。

getIndirectExportEntries() - Method in interface jdk.nashorn.api.tree. ModuleTree

返回间接导出条目的列表。

getInetAddress() - Method in class java.net. DatagramSocket

返回此套接字连接到的地址。

getInetAddress() - Method in class java.net. ServerSocket

返回此服务器套接字的本地地址。

getInetAddress() - Method in class java.net. Socket

返回套接字所连接的地址。

getInetAddress() - Method in class java.net. SocketImpl

返回此套接字 address字段的值。

getInetAddresses() - Method in class java.net. NetworkInterface

获取绑定到此网络接口的所有或一部分InetAddress的枚举。

getInfinity() - Method in class java.text. DecimalFormatSymbols

获取用于表示无穷大的字符串。

getInfo() - Method in class java.security. Identity

已过时。

返回先前为此标识指定的一般信息。

getInfo() - Method in class java.security. Provider

返回提供商及其服务的可读描述。

getInheritsPopupMenu() - Method in class javax.swing. JComponent

如果JPopupMenu应该从父级继承，则返回true。

getInit() - Method in class java.lang.management. MemoryUsage

返回Java虚拟机最初从操作系统请求进行内存管理的以字节为单位的内存量。

getInitialAlignment() - Method in class javafx.scene.control. Labeled

返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。

getInitialAlignment() - Method in class javafx.scene.control. RadioButton

返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。

getInitialAlignment() - Method in class javafx.scene.control. ToggleButton

返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。

getInitialComponent(Window) - Method in class java.awt. FocusTraversalPolicy

返回当窗口第一次可见时应接收焦点的组件。

getInitialComponent(JInternalFrame) - Method in class javax.swing. InternalFrameFocusTraversalPolicy

返回当第一次选择JInternalFrame时应该接收焦点的组件。

getInitialContext(Hashtable<?, ?>) - Method in interface javax.naming.spi. InitialContextFactory

创建起始名称解析的初始上下文。

getInitialContext(Hashtable<?, ?>) - Static method in class javax.naming.spi. NamingManager

使用指定的环境属性创建初始上下文。

getInitialCursor() - Method in class javafx.scene.control. Hyperlink

返回此控件的初始游标状态，供JavaFX CSS引擎正确设置其初始值。

getInitialCursor() - Method in class javafx.scene. Node

返回此节点的初始游标状态，供JavaFX CSS引擎正确设置其初始值。

getInitialDelay() - Method in class javax.swing. Timer

返回 Timer的初始延迟。

getInitialDelay() - Method in class javax.swing. ToolTipManager

返回初始延迟值。

getInitialDirectory() - Method in class javafx.stage. DirectoryChooser

获取属性initialDirectory的值。

getInitialDirectory() - Method in class javafx.stage. FileChooser

获取属性initialDirectory的值。

getInitialFileName() - Method in class javafx.stage. FileChooser

获取属性initialFileName的值。

getInitialFocusTraversable() - Method in class javafx.scene.control. Accordion

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. ButtonBar

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. Cell

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. Control

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. Label

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. MenuBar

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. ProgressBar

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. ProgressIndicator

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. ScrollBar

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. ScrollPane

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. Separator

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. SplitPane

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene.control. ToolBar

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitialFocusTraversable() - Method in class javafx.scene. Node

返回此节点的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

getInitializer() - Method in interface com.sun.source.tree. ForLoopTree

返回 for语句的任何初始值。

getInitializer() - Method in interface com.sun.source.tree. VariableTree

返回变量的初始化器，如果没有，则返回 null 。

getInitializer() - Method in interface jdk.nashorn.api.tree. ForLoopTree

返回此'for'语句的初始化程序表达式。

getInitializer() - Method in interface jdk.nashorn.api.tree. VariableTree

返回此变量的初始值表达式。

getInitializers() - Method in interface com.sun.source.tree. NewArrayTree

返回初始化器表达式。

getInitialLocation(Insets) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

返回左插入，除非 Insets为null，在这种情况下返回0。

getInitialPolicies() - Method in class java.security.cert. PKIXParameters

返回一个不可变的初始策略标识符（OID字符串）的 Set ，表明证书用户为了认证路径处理的目的而可以接受这些策略中的任何一个。

getInitialSelectionValue() - Method in class javax.swing. JOptionPane

返回最初显示为用户的输入值。

getInitialValue() - Method in class javax.swing. JOptionPane

返回初始值。

getInitialValue(S) - Method in class javafx.css. CssMetaData

CssMetaData的初始值对应于代码中StyleableProperty的默认值。

getInitialValueIndex() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

将初始索引返回到要选择的按钮中。

getInitiatedClasses(ClassLoader) - Method in interface java.lang.instrument. Instrumentation

返回一个 loader是起始加载器的所有类的数组。

getInitiatorAddress() - Method in class org.ietf.jgss. ChannelBinding

获取此通道绑定的启动器地址。

getInitThreshold() - Method in class javax.management.monitor. CounterMonitor

获得所有观察对象共同的初始阈值。

getInitThreshold() - Method in interface javax.management.monitor. CounterMonitorMBean

获得所有观察对象共同的初始阈值。

getInput() - Method in exception java.net. URISyntaxException

返回输入字符串。

getInput() - Method in exception java.nio.file. InvalidPathException

返回输入字符串。

getInput() - Method in class javafx.scene.effect. Bloom

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. BoxBlur

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. ColorAdjust

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. DisplacementMap

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. DropShadow

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. GaussianBlur

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. Glow

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. InnerShadow

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. MotionBlur

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. Reflection

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. SepiaTone

获取属性输入的值。

getInput() - Method in class javafx.scene.effect. Shadow

获取属性输入的值。

getInput() - Method in class javax.imageio. ImageReader

返回 ImageInputStream或其他 Object以前设置为输入源。

getInput() - Method in interface org.w3c.dom.ls. LSLoadEvent

被解析的输入源。

getInput() - Method in interface org.w3c.dom.ls. LSProgressEvent

正在解析的输入源。

getInputArguments() - Method in interface java.lang.management. RuntimeMXBean

返回传递给Java虚拟机的输入参数，该虚拟机不包括 main方法的参数。

getInputAttributes() - Method in class javax.swing. JTextPane

获取窗格的输入属性。

getInputAttributes() - Method in class javax.swing.text.html. HTMLEditorKit

获取用于样式编辑操作的输入属性。

getInputAttributes() - Method in class javax.swing.text. StyledEditorKit

获取窗格的输入属性。

getInputClass() - Method in class javax.imageio.spi. ImageInputStreamSpi

返回一个 Class表示必须由输入源，以便被实现为“包装”在的类或接口类型的对象 ImageInputStream经由 createInputStreamInstance方法。

getInputContext() - Method in class java.awt. Component

获取此组件使用的输入上下文，以便在此组件中输入文本时处理与输入法的通信。

getInputContext() - Method in class java.awt. Window

获取此窗口的输入上下文。

getInputEncoding() - Method in interface org.w3c.dom. Document

指定在解析时用于此文档的编码的属性。

getInputEncoding() - Method in interface org.w3c.dom. Entity

指定在解析时用于该实体的编码的属性，当它是外部解析实体时。

getInputEvent() - Method in class javax.swing.event. HyperlinkEvent

返回触发超链接事件的 InputEvent 。

getInputLength() - Method in exception java.nio.charset. MalformedInputException

返回输入的长度。

getInputLength() - Method in exception java.nio.charset. UnmappableCharacterException

返回输入的长度。

getInputMap() - Method in class javax.swing. JComponent

返回当组件具有焦点时使用的 InputMap 。

getInputMap(int) - Method in class javax.swing. JComponent

返回 InputMap中使用的 condition 。

getInputMethodControlObject() - Method in class java.awt.im. InputContext

从当前输入法返回一个控件对象，或者返回null。

getInputMethodDisplayName(Locale, Locale) - Method in interface java.awt.im.spi. InputMethodDescriptor

以显示名称的语言返回给定输入区域设置的相应输入法的用户可见名称。

getInputMethodIcon(Locale) - Method in interface java.awt.im.spi. InputMethodDescriptor

返回相应输入法的图标。

getInputMethodListeners() - Method in class java.awt. Component

返回在此组件上注册的所有输入法侦听器的数组。

getInputMethodRequests() - Method in class java.awt. Component

获取支持该组件输入法的请求的输入法请求处理程序。

getInputMethodRequests() - Method in class java.awt. TextComponent

getInputMethodRequests() - Method in class javafx.embed.swing. JFXPanel

getInputMethodRequests() - Method in class javafx.scene. Node

获取属性inputMethodRequests的值。

getInputMethodRequests() - Method in class javax.swing.text. JTextComponent

getInputSource() - Method in class javax.xml.transform.sax. SAXSource

获取要用于源的SAX InputSource。

getInputStream() - Method in class java.lang. Process

返回连接到进程正常输出的输入流。

getInputStream() - Method in class java.net. Socket

返回此套接字的输入流。

getInputStream() - Method in class java.net. SocketImpl

返回此套接字的输入流。

getInputStream() - Method in class java.net. URLConnection

返回从此打开的连接读取的输入流。

getInputStream() - Method in interface java.rmi.server. RemoteCall

已过时。
没有替换

getInputStream() - Method in class javax.activation. DataHandler

获取此对象的InputStream。

getInputStream() - Method in interface javax.activation. DataSource

此方法返回一个表示数据的 InputStream ，如果不能这样做，则会抛出适当的异常。

getInputStream() - Method in class javax.activation. FileDataSource

此方法将返回一个表示数据的InputStream，如果不能执行此操作将抛出IOException。

getInputStream() - Method in class javax.activation. URLDataSource

来自URL的getInputStream方法。

getInputStream() - Method in interface javax.jnlp. FileContents

从文件获取 InputStream 。

getInputStream() - Method in class javax.xml.transform.stream. StreamSource

获取使用setByteStream设置的字节流。

getInputStream() - Method in exception org.omg.CORBA.portable. ApplicationException

返回可以读取异常数据作为参数的输入流。

getInputStream(ZipEntry) - Method in class java.util.jar. JarFile

返回用于读取指定zip文件条目内容的输入流。

getInputStream(ZipEntry) - Method in class java.util.zip. ZipFile

返回用于读取指定zip文件条目内容的输入流。

getInputTypes() - Method in class javax.imageio.spi. ImageReaderSpi

返回一个 Class对象的数组，指示可以使用什么类型的对象作为读者 setInput方法的参数。

getInputValue() - Method in class javax.swing. JOptionPane

返回用户输入的值，如果是 wantsInput 。

getInputVerifier() - Method in class javax.swing. JComponent

返回此组件的输入验证器。

getINS() - Method in class javax.smartcardio. CommandAPDU

返回指令字节INS的值。

getInsertionIndex() - Method in class java.awt.font. TextHitInfo

返回插入索引。

getInsertionIndex() - Method in class javafx.scene.text. HitInfo

返回插入位置的索引。

getInsertionPoint(double, double) - Method in class javafx.scene.control.skin. TextAreaSkin

返回给定位置的插入点。

getInsertionPoint(double, double) - Method in class javafx.scene.control.skin. TextInputControlSkin

返回给定位置的插入点。

getInsertPositionOffset() - Method in interface java.awt.im. InputMethodRequests

获取文本编辑组件中包含的提交文本中插入位置的偏移量。

getInset(int, View) - Method in class javax.swing.text.html. StyleSheet.BoxPainter

获取给定方面所需的插图，以说明边距，边框和填充。

getInsets() - Method in class java.awt. Container

确定此容器的插入，这表示容器边框的大小。

getInsets() - Method in class javafx.scene.layout. BackgroundFill

Insets用于填充。

getInsets() - Method in class javafx.scene.layout. Border

插图定义从区域边缘到边框最里边缘的距离，如果该距离是非负的。

getInsets() - Method in class javafx.scene.layout. BorderImage

BorderImage的内容定义边框相对于区域边缘的位置。

getInsets() - Method in class javafx.scene.layout. BorderStroke

定义BorderStroke的每一边的插图。

getInsets() - Method in class javafx.scene.layout. Region

获取属性插值的值。

getInsets() - Method in class javax.swing. JComponent

如果在此组件上设置了边框，则返回边框的插入; 否则拨打super.getInsets 。

getInsets() - Method in class javax.swing. JViewport

由于边框不支持 JViewport ，因此返回（0,0,0,0）的插图（边框）尺寸。

getInsets() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

从JComboBox获取插图。

getInsets() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

如果在此组件上设置了边框，则返回边框的插入，否则调用super.getInsets。

getInsets() - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow

getInsets(Insets) - Method in class javax.swing. JComponent

返回包含此组件的插入值的 Insets对象。

getInsets(Insets) - Method in class javax.swing. JViewport

返回一个 Insets对象，其中包含这个 JViewport的插入值。

getInsets(Object) - Method in class javax.swing. UIDefaults

如果值 key是 Insets返回它，否则返回 null 。

getInsets(Object) - Static method in class javax.swing. UIManager

从默认值返回一个 Insets对象。

getInsets(Object, Locale) - Method in class javax.swing. UIDefaults

如果 key为 Locale为 Insets回报，否则返回 null 。

getInsets(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回一个 Insets对象。

getInsets(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

返回插图。

getInsets(JComponent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回插图。

getInsets(SynthContext, Insets) - Method in class javax.swing.plaf.nimbus. NimbusStyle

返回用于计算大小信息的Insets。

getInsets(SynthContext, Insets) - Method in class javax.swing.plaf.synth. SynthStyle

返回用于计算大小信息的Insets。

getInsetsConverter() - Static method in class javafx.css. StyleConverter

返回一个转换[<length> |的StyleConverter <percentage>] {1,4}至Insets 。

getInsetSpan(int) - Method in class javax.swing.text. AsyncBoxView

沿着由插图占据的轴获取跨度。

getInsideAllocation(Shape) - Method in class javax.swing.text. CompositeView

将给予视图的不可变分配转换为表示内部分配的可变分配（即，删除顶，左，底和右插入的给定分配的边界。

getInsideBorder() - Method in class javax.swing.border. CompoundBorder

返回内部边框对象。

getInstalledJRE(URL, String) - Method in interface javax.jnlp. ExtensionInstallerService

返回给定JRE的可执行文件的路径。

getInstalledLookAndFeels() - Static method in class javax.swing. UIManager

返回一个 LookAndFeelInfo s的数组，代表当前可用的 LookAndFeel实现。

getInstallPath() - Method in interface javax.jnlp. ExtensionInstallerService

返回安装程序建议安装扩展程序的目录。

getInstance() - Static method in class java.awt.im. InputContext

返回一个新的InputContext实例。

getInstance() - Static method in class java.lang. StackWalker

返回一个 StackWalker实例。

getInstance() - Static method in class java.text. Collator

获取当前默认语言环境的Collator。

getInstance() - Static method in class java.text. DateFormat

获取在日期和时间上使用SHORT样式的默认日期/时间格式化程序。

getInstance() - Static method in class java.text. DateFormatSymbols

获取默认语言环境的 DateFormatSymbols实例。

getInstance() - Static method in class java.text. DecimalFormatSymbols

获取默认语言环境的 DecimalFormatSymbols实例。

getInstance() - Static method in class java.text. NumberFormat

返回当前默认的 FORMAT区域设置的通用数字格式。

getInstance() - Static method in class java.util. Calendar

使用默认时区和区域设置获取日历。

getInstance() - Static method in class javafx.css.converter. BooleanConverter

getInstance() - Static method in class javafx.css.converter. ColorConverter

getInstance() - Static method in class javafx.css.converter. CursorConverter

getInstance() - Static method in class javafx.css.converter. DeriveColorConverter

getInstance() - Static method in class javafx.css.converter. DeriveSizeConverter

getInstance() - Static method in class javafx.css.converter. DurationConverter

getInstance() - Static method in class javafx.css.converter. EffectConverter.DropShadowConverter

getInstance() - Static method in class javafx.css.converter. EffectConverter

getInstance() - Static method in class javafx.css.converter. EffectConverter.InnerShadowConverter

getInstance() - Static method in class javafx.css.converter. FontConverter.FontSizeConverter

getInstance() - Static method in class javafx.css.converter. FontConverter.FontStyleConverter

getInstance() - Static method in class javafx.css.converter. FontConverter.FontWeightConverter

getInstance() - Static method in class javafx.css.converter. FontConverter

getInstance() - Static method in class javafx.css.converter. InsetsConverter

getInstance() - Static method in class javafx.css.converter. InsetsConverter.SequenceConverter

getInstance() - Static method in class javafx.css.converter. LadderConverter

getInstance() - Static method in class javafx.css.converter. PaintConverter

getInstance() - Static method in class javafx.css.converter. PaintConverter.ImagePatternConverter

getInstance() - Static method in class javafx.css.converter. PaintConverter.LinearGradientConverter

getInstance() - Static method in class javafx.css.converter. PaintConverter.RadialGradientConverter

getInstance() - Static method in class javafx.css.converter. PaintConverter.RepeatingImagePatternConverter

getInstance() - Static method in class javafx.css.converter. PaintConverter.SequenceConverter

getInstance() - Static method in class javafx.css.converter. ShapeConverter

getInstance() - Static method in class javafx.css.converter. SizeConverter

getInstance() - Static method in class javafx.css.converter. SizeConverter.SequenceConverter

getInstance() - Static method in class javafx.css.converter. StopConverter

getInstance() - Static method in class javafx.css.converter. StringConverter

getInstance() - Static method in class javafx.css.converter. StringConverter.SequenceConverter

getInstance() - Static method in class javafx.css.converter. URLConverter

getInstance() - Static method in class javafx.css.converter. URLConverter.SequenceConverter

getInstance() - Static method in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

返回一个 BaselineTIFFTagSet的共享实例。

getInstance() - Static method in class javax.imageio.plugins.tiff. ExifGPSTagSet

返回一个 ExifGPSTagSet的共享实例。

getInstance() - Static method in class javax.imageio.plugins.tiff. ExifInteroperabilityTagSet

返回共享实例 ExifInteroperabilityTagSet 。

getInstance() - Static method in class javax.imageio.plugins.tiff. ExifParentTIFFTagSet

返回一个 ExifParentTIFFTagSet的共享实例。

getInstance() - Static method in class javax.imageio.plugins.tiff. ExifTIFFTagSet

返回一个 ExifTIFFTagSet的共享实例。

getInstance() - Static method in class javax.imageio.plugins.tiff. FaxTIFFTagSet

返回一个 FaxTIFFTagSet的共享实例。

getInstance() - Static method in class javax.imageio.plugins.tiff. GeoTIFFTagSet

返回一个 GeoTIFFTagSet的共享实例。

getInstance() - Static method in class javax.security.auth.kerberos. KeyTab

返回绑定到未知服务主体的默认 KeyTab实例。

getInstance() - Static method in class javax.swing. LayoutStyle

返回共享实例 LayoutStyle 。

getInstance() - Static method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

返回支持默认XML处理机制和表示类型（“DOM”）的 KeyInfoFactory 。

getInstance() - Static method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回支持默认XML处理机制和表示类型（“DOM”）的 XMLSignatureFactory 。

getInstance() - Static method in class org.ietf.jgss. GSSManager

返回默认的GSSManager实现。

getInstance(byte[]) - Static method in class java.awt.color. ICC_Profile

构造与字节数组中的数据相对应的ICC_Profile对象。

getInstance(byte[]) - Static method in class javax.security.cert. X509Certificate

已过时。

实例化一个X509Certificate对象，并用指定的字节数组初始化它。

getInstance(int) - Static method in class java.awt. AlphaComposite

使用指定的规则创建一个 AlphaComposite对象。

getInstance(int) - Static method in class java.awt.color. ColorSpace

返回表示特定预定义颜色空间之一的ColorSpace。

getInstance(int) - Static method in class java.awt.color. ICC_Profile

构造一个对应于由ColorSpace类定义的特定颜色空间之一的ICC_Profile（例如CS_sRGB）。

getInstance(int, float) - Static method in class java.awt. AlphaComposite

使用指定的规则创建一个 AlphaComposite对象，并将常量alpha与源的alpha进行乘法。

getInstance(File) - Static method in class javax.security.auth.kerberos. KeyTab

从绑定到未知服务主体的 File对象返回 KeyTab实例。

getInstance(File, char[]) - Static method in class java.security. KeyStore

返回相应密钥库类型的加载密钥库对象。

getInstance(File, KeyStore.LoadStoreParameter) - Static method in class java.security. KeyStore

返回相应密钥库类型的加载密钥库对象。

getInstance(InputStream) - Static method in class java.awt.color. ICC_Profile

构造一个与InputStream中数据对应的ICC_Profile。

getInstance(InputStream) - Static method in class javax.security.cert. X509Certificate

已过时。

实例化一个X509Certificate对象，并使用从输入流 inStream读取的数据进行初始化。

getInstance(StackWalker.Option) - Static method in class java.lang. StackWalker

返回一个具有给定选项的 StackWalker实例，指定可以访问的堆栈帧信息。

getInstance(String) - Static method in class java.awt.color. ICC_Profile

构造与文件中数据对应的ICC_Profile。

getInstance(String) - Static method in class java.security. AlgorithmParameterGenerator

返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

getInstance(String) - Static method in class java.security. AlgorithmParameters

返回指定算法的参数对象。

getInstance(String) - Static method in class java.security.cert. CertificateFactory

返回实现指定证书类型的证书工厂对象。

getInstance(String) - Static method in class java.security.cert. CertPathBuilder

返回实现指定算法的 CertPathBuilder对象。

getInstance(String) - Static method in class java.security.cert. CertPathValidator

返回实现指定算法的 CertPathValidator对象。

getInstance(String) - Static method in class java.security. KeyFactory

返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

getInstance(String) - Static method in class java.security. KeyPairGenerator

返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

getInstance(String) - Static method in class java.security. KeyStore

返回指定类型的密钥库对象。

getInstance(String) - Static method in class java.security. MessageDigest

返回实现指定摘要算法的MessageDigest对象。

getInstance(String) - Static method in class java.security. SecureRandom

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。

getInstance(String) - Static method in class java.security. Signature

返回实现指定签名算法的Signature对象。

getInstance(String) - Static method in class java.util. Currency

返回给定货币代码的 Currency实例。

getInstance(String) - Static method in class javafx.css.converter. EnumConverter

getInstance(String) - Static method in class javax.crypto. Cipher

返回实现指定转换的 Cipher对象。

getInstance(String) - Static method in class javax.crypto. ExemptionMechanism

返回实现指定的豁免机制算法的 ExemptionMechanism对象。

getInstance(String) - Static method in class javax.crypto. KeyAgreement

返回实现指定的密钥协商算法的 KeyAgreement对象。

getInstance(String) - Static method in class javax.crypto. KeyGenerator

返回一个产生指定算法的密钥的 KeyGenerator对象。

getInstance(String) - Static method in class javax.crypto. Mac

返回实现指定MAC算法的 Mac对象。

getInstance(String) - Static method in class javax.crypto. SecretKeyFactory

返回转换指定算法的秘密密钥的 SecretKeyFactory对象。

getInstance(String) - Static method in class javax.management. ObjectName

返回一个ObjectName实例，可以在任何地方使用可以使用 new ObjectName(name)获得的对象。

getInstance(String) - Static method in class javax.net.ssl. KeyManagerFactory

返回一个 KeyManagerFactory对象，作为主要管理员的工厂。

getInstance(String) - Static method in class javax.net.ssl. SSLContext

返回实现指定安全套接字协议的 SSLContext对象。

getInstance(String) - Static method in class javax.net.ssl. TrustManagerFactory

返回一个作为信任管理器的工厂的 TrustManagerFactory对象。

getInstance(String) - Static method in class javax.sql.rowset.spi. SyncFactory

返回由 providerID标识的 SyncProvider实例。

getInstance(String) - Static method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

返回支持指定的XML处理机制和表示类型（例如：“DOM”）的 KeyInfoFactory 。

getInstance(String) - Static method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回支持指定的XML处理机制和表示类型（例如：“DOM”）的 XMLSignatureFactory 。

getInstance(String, Object) - Static method in class javax.smartcardio. TerminalFactory

返回使用指定参数初始化的指定类型的TerminalFactory。

getInstance(String, Object, String) - Static method in class javax.smartcardio. TerminalFactory

返回使用指定参数初始化的指定类型的TerminalFactory。

getInstance(String, Object, Provider) - Static method in class javax.smartcardio. TerminalFactory

返回使用指定参数初始化的指定类型的TerminalFactory。

getInstance(String, String) - Static method in class java.security. AlgorithmParameterGenerator

返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

getInstance(String, String) - Static method in class java.security. AlgorithmParameters

返回指定算法的参数对象。

getInstance(String, String) - Static method in class java.security.cert. CertificateFactory

返回指定证书类型的证书工厂对象。

getInstance(String, String) - Static method in class java.security.cert. CertPathBuilder

返回实现指定算法的 CertPathBuilder对象。

getInstance(String, String) - Static method in class java.security.cert. CertPathValidator

返回实现指定算法的 CertPathValidator对象。

getInstance(String, String) - Static method in class java.security. KeyFactory

返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

getInstance(String, String) - Static method in class java.security. KeyPairGenerator

返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

getInstance(String, String) - Static method in class java.security. KeyStore

返回指定类型的密钥库对象。

getInstance(String, String) - Static method in class java.security. MessageDigest

返回实现指定摘要算法的MessageDigest对象。

getInstance(String, String) - Static method in class java.security. SecureRandom

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。

getInstance(String, String) - Static method in class java.security. Signature

返回实现指定签名算法的Signature对象。

getInstance(String, String) - Static method in class javax.crypto. Cipher

返回实现指定转换的 Cipher对象。

getInstance(String, String) - Static method in class javax.crypto. ExemptionMechanism

返回实现指定的豁免机制算法的 ExemptionMechanism对象。

getInstance(String, String) - Static method in class javax.crypto. KeyAgreement

返回一个 KeyAgreement对象，实现指定的密钥协商算法。

getInstance(String, String) - Static method in class javax.crypto. KeyGenerator

返回一个产生指定算法的密钥的 KeyGenerator对象。

getInstance(String, String) - Static method in class javax.crypto. Mac

返回实现指定的MAC算法的 Mac对象。

getInstance(String, String) - Static method in class javax.crypto. SecretKeyFactory

返回转换指定算法的秘密密钥的 SecretKeyFactory对象。

getInstance(String, String) - Static method in class javax.net.ssl. KeyManagerFactory

返回一个 KeyManagerFactory对象，作为主要管理员的工厂。

getInstance(String, String) - Static method in class javax.net.ssl. SSLContext

返回实现指定安全套接字协议的 SSLContext对象。

getInstance(String, String) - Static method in class javax.net.ssl. TrustManagerFactory

返回一个作为信任管理器的工厂的 TrustManagerFactory对象。

getInstance(String, String) - Static method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

返回一个 KeyInfoFactory ，它支持由指定提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

getInstance(String, String) - Static method in class javax.xml.crypto.dsig. TransformService

返回一个 TransformService支持指定算法URI（例如： Transform.XPATH2 ）和机制类型（比如：DOM）。

getInstance(String, String) - Static method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回一个 XMLSignatureFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

getInstance(String, String, String) - Static method in class javax.management. ObjectName

返回一个可以在任何可以使用 new ObjectName(domain, key, value)获得的对象的地方使用的ObjectName实例。

getInstance(String, String, String) - Static method in class javax.xml.crypto.dsig. TransformService

返回一个 TransformService支持指定算法URI（例如： Transform.XPATH2 ）和机制类型：由指定的提供者提供（例如，DOM）。

getInstance(String, String, Provider) - Static method in class javax.xml.crypto.dsig. TransformService

返回一个 TransformService支持指定算法URI（例如： Transform.XPATH2 ）和机制类型：由指定的提供者提供（例如，DOM）。

getInstance(String, CertStoreParameters) - Static method in class java.security.cert. CertStore

返回一个实现指定的 CertStore类型的 CertStore对象，并使用指定的参数进行初始化。

getInstance(String, CertStoreParameters, String) - Static method in class java.security.cert. CertStore

返回实现指定的 CertStore类型的 CertStore对象。

getInstance(String, CertStoreParameters, Provider) - Static method in class java.security.cert. CertStore

返回实现指定的 CertStore类型的 CertStore对象。

getInstance(String, Policy.Parameters) - Static method in class java.security. Policy

返回指定类型的Policy对象。

getInstance(String, Policy.Parameters, String) - Static method in class java.security. Policy

返回指定类型的Policy对象。

getInstance(String, Policy.Parameters, Provider) - Static method in class java.security. Policy

返回指定类型的Policy对象。

getInstance(String, Provider) - Static method in class java.security. AlgorithmParameterGenerator

返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

getInstance(String, Provider) - Static method in class java.security. AlgorithmParameters

返回指定算法的参数对象。

getInstance(String, Provider) - Static method in class java.security.cert. CertificateFactory

返回指定证书类型的证书工厂对象。

getInstance(String, Provider) - Static method in class java.security.cert. CertPathBuilder

返回实现指定算法的 CertPathBuilder对象。

getInstance(String, Provider) - Static method in class java.security.cert. CertPathValidator

返回实现指定算法的 CertPathValidator对象。

getInstance(String, Provider) - Static method in class java.security. KeyFactory

返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

getInstance(String, Provider) - Static method in class java.security. KeyPairGenerator

返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

getInstance(String, Provider) - Static method in class java.security. KeyStore

返回指定类型的密钥库对象。

getInstance(String, Provider) - Static method in class java.security. MessageDigest

返回实现指定摘要算法的MessageDigest对象。

getInstance(String, Provider) - Static method in class java.security. SecureRandom

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。

getInstance(String, Provider) - Static method in class java.security. Signature

返回实现指定签名算法的Signature对象。

getInstance(String, Provider) - Static method in class javax.crypto. Cipher

返回实现指定转换的 Cipher对象。

getInstance(String, Provider) - Static method in class javax.crypto. ExemptionMechanism

返回实现指定的免除机制算法的 ExemptionMechanism对象。

getInstance(String, Provider) - Static method in class javax.crypto. KeyAgreement

返回实现指定的密钥协商算法的 KeyAgreement对象。

getInstance(String, Provider) - Static method in class javax.crypto. KeyGenerator

返回产生指定算法的密钥的 KeyGenerator对象。

getInstance(String, Provider) - Static method in class javax.crypto. Mac

返回实现指定MAC算法的 Mac对象。

getInstance(String, Provider) - Static method in class javax.crypto. SecretKeyFactory

返回一个转换指定算法的密钥的 SecretKeyFactory对象。

getInstance(String, Provider) - Static method in class javax.net.ssl. KeyManagerFactory

返回一个 KeyManagerFactory对象，作为主要管理员的工厂。

getInstance(String, Provider) - Static method in class javax.net.ssl. SSLContext

返回实现指定安全套接字协议的 SSLContext对象。

getInstance(String, Provider) - Static method in class javax.net.ssl. TrustManagerFactory

返回一个 TrustManagerFactory对象，作为信任管理器的工厂。

getInstance(String, Provider) - Static method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

返回一个 KeyInfoFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

getInstance(String, Provider) - Static method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回一个 XMLSignatureFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

getInstance(String, SecureRandomParameters) - Static method in class java.security. SecureRandom

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。

getInstance(String, SecureRandomParameters, String) - Static method in class java.security. SecureRandom

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。

getInstance(String, SecureRandomParameters, Provider) - Static method in class java.security. SecureRandom

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。

getInstance(String, Hashtable<String, String>) - Static method in class javax.management. ObjectName

返回一个ObjectName实例，可以在任何地方使用可以使用 new ObjectName(domain, table)获得的对象。

getInstance(String, Configuration.Parameters) - Static method in class javax.security.auth.login. Configuration

返回指定类型的Configuration对象。

getInstance(String, Configuration.Parameters, String) - Static method in class javax.security.auth.login. Configuration

返回指定类型的Configuration对象。

getInstance(String, Configuration.Parameters, Provider) - Static method in class javax.security.auth.login. Configuration

返回指定类型的Configuration对象。

getInstance(Locale) - Static method in class java.text. Collator

获取所需语言环境的Collator。

getInstance(Locale) - Static method in class java.text. DateFormatSymbols

获取指定区域设置的 DateFormatSymbols实例。

getInstance(Locale) - Static method in class java.text. DecimalFormatSymbols

获取指定区域设置的 DecimalFormatSymbols实例。

getInstance(Locale) - Static method in class java.text. NumberFormat

返回指定区域设置的通用数字格式。

getInstance(Locale) - Method in class java.text.spi. CollatorProvider

为指定的区域设置返回一个新的 Collator实例。

getInstance(Locale) - Method in class java.text.spi. DateFormatSymbolsProvider

返回指定区域设置的新的 DateFormatSymbols实例。

getInstance(Locale) - Method in class java.text.spi. DecimalFormatSymbolsProvider

返回指定区域设置的新的 DecimalFormatSymbols实例。

getInstance(Locale) - Static method in class java.util. Calendar

使用默认时区和指定的区域设置获取日历。

getInstance(Locale) - Static method in class java.util. Currency

返回给定区域的国家/地区的 Currency实例。

getInstance(Set<StackWalker.Option>) - Static method in class java.lang. StackWalker

返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。

getInstance(Set<StackWalker.Option>, int) - Static method in class java.lang. StackWalker

返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。

getInstance(TimeZone) - Static method in class java.util. Calendar

使用指定的时区和默认语言环境获取日历。

getInstance(TimeZone, Locale) - Static method in class java.util. Calendar

获取具有指定时区和区域设置的日历。

getInstance(ObjectName) - Static method in class javax.management. ObjectName

返回可以在给定对象可以使用的任何地方使用的ObjectName实例。

getInstance(KerberosPrincipal) - Static method in class javax.security.auth.kerberos. KeyTab

返回绑定到指定服务主体的默认 KeyTab实例。

getInstance(KerberosPrincipal, File) - Static method in class javax.security.auth.kerberos. KeyTab

从绑定到指定服务主体的 File对象返回 KeyTab实例。

getInstanceFollowRedirects() - Method in class java.net. HttpURLConnection

返回此 HttpURLConnection的 instanceFollowRedirects字段的值。

getInstanceMethodNames(Class<?>) - Static method in class jdk.dynalink.beans. BeansLinker

返回一组类的所有实例方法的名称。

getInstanceOf(Object, Class<?>) - Static method in class java.beans. Beans

从给定的bean获取表示该源对象的指定类型视图的对象。

getInstanceOfGuard(Class<?>) - Static method in class jdk.dynalink.linker.support. Guards

创建一个保护方法，测试其唯一的参数作为特定类的实例。

getInstanceStrong() - Static method in class java.security. SecureRandom

返回通过使用securerandom.strongAlgorithms Security属性中指定的算法/提供程序选择的SecureRandom对象。

getInstant() - Method in class java.time.zone. ZoneOffsetTransition

获得转换时刻。

getInstant() - Method in class java.util.logging. LogRecord

获取事件发生的时刻。

getInstantiatedMethodType() - Method in class java.lang.invoke. SerializedLambda

在使用捕获站点的实例化代替类型变量后，获取主要功能接口方法的签名。

getInstrument(Patch) - Method in interface javax.sound.midi. Soundbank

获取一个 Instrument从给定的 Patch 。

getInstruments() - Method in interface javax.sound.midi. Soundbank

获取这个声音库中包含的乐器列表。

getInt() - Method in class java.nio. ByteBuffer

用于读取int值的相对 get方法。

getInt(int) - Method in class java.nio. ByteBuffer

用于读取int值的绝对 get方法。

getInt(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 int指定的JDBC INTEGER参数的值。

getInt(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 int此 ResultSet对象的当前行中指定列的值。

getInt(Object) - Method in class java.lang.reflect. Field

获取类型为 int的静态或实例字段的值，或通过扩大转换获得可转换为类型 int的另一个基本类型的值。

getInt(Object) - Method in class javax.swing. UIDefaults

如果 key值为 Integer返回其整数值，否则返回0。

getInt(Object) - Static method in class javax.swing. UIManager

从默认值返回一个整数。

getInt(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中索引组件的值，如 int 。

getInt(Object, Locale) - Method in class javax.swing. UIDefaults

如果值 key对于给定 Locale是 Integer返回其整数值，否则返回0。

getInt(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回一个整数。

getInt(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 int JDBC INTEGER参数的值。

getInt(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 int该 ResultSet对象的当前行中指定列的值。

getInt(String, int) - Method in class java.util.prefs. AbstractPreferences

实现 getInt方法按照在本说明书中 Preferences.getInt(String,int) 。

getInt(String, int) - Method in class java.util.prefs. Preferences

返回由此首选项节点中与指定键相关联的字符串表示的int值。

getInt(SynthContext, Object, int) - Method in class javax.swing.plaf.synth. SynthStyle

方便的方法来获取一个具体的样式属性，其值为 Number 。

getIntArgbInstance() - Static method in class javafx.scene.image. PixelFormat

返回描述像素布局的 WritablePixelFormat实例，其像素存储在32位整数中， 非预乘数组件按顺序存储，从MSb到LSb：alpha，红，绿，蓝。

getIntArgbPreInstance() - Static method in class javafx.scene.image. PixelFormat

返回描述像素布局的 WritablePixelFormat实例，其中以32位整数存储的像素，其中 预乘数组件按顺序存储，从MSb到LSb：alpha，红色，绿色，蓝色。

getInteger(String) - Static method in class java.lang. Integer

确定具有指定名称的系统属性的整数值。

getInteger(String, int) - Static method in class java.lang. Integer

确定具有指定名称的系统属性的整数值。

getInteger(String, Integer) - Static method in class java.lang. Integer

返回具有指定名称的系统属性的整数值。

getIntegerAttributeValue(AttributeSet, HTML.Attribute, int) - Static method in class javax.swing.text.html. HTML

获取整数属性值。

getIntegerInstance() - Static method in class java.text. NumberFormat

返回当前默认值 FORMAT区域设置的整数格式。

getIntegerInstance(Locale) - Static method in class java.text. NumberFormat

返回指定区域设置的整数格式。

getIntegerInstance(Locale) - Method in class java.text.spi. NumberFormatProvider

返回一个新的 NumberFormat实例，它为指定的区域设置格式化整数值。

getIntegState() - Method in interface org.ietf.jgss. GSSContext

确定数据完整性是否可用于上下文。

getIntercellSpacing() - Method in class javax.swing. JTable

返回单元格之间的水平和垂直空间。

getInterface() - Method in class java.net. MulticastSocket

检索用于组播数据包的网络接口的地址。

getInterface(Class<T>) - Method in interface javax.script. Invocable

使用在解释器中编译的函数返回接口的实现。

getInterface(Class<T>) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

getInterface(Object, Class<T>) - Method in interface javax.script. Invocable

使用解释器中编译的脚本对象的成员函数返回接口的实现。

getInterface(Object, Class<T>) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

getInterfaceAddresses() - Method in class java.net. NetworkInterface

获取此网络接口的全部或部分 InterfaceAddresses的列表。

getInterfaces() - Method in class java.lang. Class

返回由该对象表示的类或接口直接实现的接口。

getInterfaces() - Method in interface javax.lang.model.element. TypeElement

返回由此类直接实现的接口类或由此接口扩展的接口类型。

getInteriorRectangle(Component, int, int, int, int) - Method in class javax.swing.border. AbstractBorder

这种方便方法调用静态方法。

getInteriorRectangle(Component, Border, int, int, int, int) - Static method in class javax.swing.border. AbstractBorder

使用参数减去边框的插入返回一个矩形。

getInternalFrame() - Method in class javax.swing.event. InternalFrameEvent

返回事件的发起者。

getInternalFrame() - Method in class javax.swing. JInternalFrame.JDesktopIcon

返回 JInternalFrame与之相关联的 DesktopIcon 。

getInternalFrameAltMaximizeIcon(int) - Static method in class javax.swing.plaf.metal. MetalIconFactory

构造一个新的实例 InternalFrameAltMaximizeIcon 。

getInternalFrameBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JInternalFrame的边框实例。

getInternalFrameCloseIcon(int) - Static method in class javax.swing.plaf.metal. MetalIconFactory

构造一个新的实例 InternalFrameCloseIcon 。

getInternalFrameDefaultMenuIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 InternalFrameDefaultMenuIcon的实例。

getInternalFrameListeners() - Method in class javax.swing. JInternalFrame

返回所有 InternalFrameListener的数组，添加到这个 JInternalFrame与 addInternalFrameListener 。

getInternalFrameMaximizeIcon(int) - Static method in class javax.swing.plaf.metal. MetalIconFactory

构造一个新的实例 InternalFrameMaximizeIcon 。

getInternalFrameMinimizeIcon(int) - Static method in class javax.swing.plaf.metal. MetalIconFactory

构造一个新的实例 InternalFrameMinimizeIcon 。

getInternalSubset() - Method in interface org.w3c.dom. DocumentType

内部子集为字符串，如果没有， null 。

getInternationalCurrencySymbol() - Method in class java.text. DecimalFormatSymbols

返回这些DecimalFormatSymbols的货币的ISO 4217货币代码。

getInterpolationType() - Method in class java.awt.image. AffineTransformOp

返回此op使用的插值类型。

getInterpolator() - Method in class javafx.animation. KeyValue

Interpolator用于计算沿特定间隔的键值。

getInterpolator() - Method in class javafx.animation. Transition

获取属性interpolator的值。

getIntersectedDistance() - Method in class javafx.scene.input. PickResult

返回相机位置和相交点之间的相交距离。

getIntersectedFace() - Method in class javafx.scene.input. PickResult

返回所选节点的相交面，如果节点没有用户指定的面或被选中的边界，则返回FACE_UNDEFINED。

getIntersectedNode() - Method in class javafx.scene.input. PickResult

返回相交的节点。

getIntersectedNormal() - Method in class javafx.scene.input. PickResult

返回所选择的3D形状的相交法线。

getIntersectedPoint() - Method in class javafx.scene.input. PickResult

返回所选节点的局部坐标中的相交点。

getIntersectedTexCoord() - Method in class javafx.scene.input. PickResult

返回所选3D形状的相交纹理坐标。

getIntParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

以int形式返回参数的方便方法。

getInvalidCharacters() - Method in class javax.swing.text. MaskFormatter

返回对输入无效的字符。

getInvalidIteratorState() - Method in interface org.w3c.dom.xpath. XPathResult

表示迭代器已成为无效。

getInvalidityDate() - Method in exception java.security.cert. CertificateRevokedException

返回无效日期，按照此 CertificateRevokedException的无效日期扩展名指定。

getInverted() - Method in class javax.swing. JSlider

如果滑块显示的值范围相反，则返回true，

getInvocation() - Method in class jdk.dynalink.linker. GuardedInvocation

返回调用方法句柄。

getInvocationHandler(Object) - Static method in class java.lang.reflect. Proxy

返回指定代理实例的调用处理程序。

getInvoker() - Method in class javax.swing. JPopupMenu

返回该弹出菜单的“调用者”组件。

getInvokesStopCellEditing() - Method in class javax.swing. JTree

返回指示器，指示编辑中断时会发生什么。

getIOException() - Method in exception java.awt.print. PrinterIOException

返回终止打印作业的 IOException 。

getIsMap() - Method in interface org.w3c.dom.html. HTMLImageElement

使用服务器端映像映射。

getISO3Country() - Method in class java.util. Locale

返回此区域设置的国家/地区的三个字母的缩写。

getISO3Language() - Method in class java.util. Locale

返回此语言环境的三个字母缩写。

getISOCountries() - Static method in class java.util. Locale

返回ISO 3166中定义的所有2个字母的国家/地区代码的列表。

getISOCountries(Locale.IsoCountryCode) - Static method in class java.util. Locale

返回 Set的指定类型的ISO3166国家代码。

getISOLanguages() - Static method in class java.util. Locale

返回ISO 639中定义的所有2个字母的语言代码的列表。

getIssuer() - Method in class java.security.cert. X509CertSelector

作为 X500Principal返回发行人标准。

getIssuerAlternativeNames() - Method in class java.security.cert. X509Certificate

从 IssuerAltName扩展名（OID = 2.5.29.18）获取不可变的发行人替代名称集合。

getIssuerAsBytes() - Method in class java.security.cert. X509CertSelector

作为字节数组返回发行方标准。

getIssuerAsString() - Method in class java.security.cert. X509CertSelector

诋毁 ，使用 X509CertSelector.getIssuer()或者 X509CertSelector.getIssuerAsBytes()代替。

getIssuerDN() - Method in class java.security.cert. X509Certificate

诋毁 ，取而代之的是 X509Certificate.getIssuerX500Principal() 。

getIssuerDN() - Method in class java.security.cert. X509CRL

诋毁 ，取而代之的是 X509CRL.getIssuerX500Principal() 。

getIssuerDN() - Method in class javax.security.cert. X509Certificate

已过时。

从证书中获取 issuer （发行人可分辨名称）值。

getIssuerName() - Method in interface javax.xml.crypto.dsig.keyinfo. X509IssuerSerial

以 RFC 2253字符串格式返回此 X509IssuerSerial的X.500可分辨名称。

getIssuerNames() - Method in class java.security.cert. X509CRLSelector

返回issuerNames条件的副本。

getIssuers() - Method in class java.security.cert. X509CRLSelector

返回issuerNames条件。

getIssuerUniqueID() - Method in class java.security.cert. X509Certificate

从证书获得 issuerUniqueID价值。

getIssuerX500Principal() - Method in class java.security.cert. X509Certificate

从证书中返回发行人（发行人可分辨名称）值为 X500Principal 。

getIssuerX500Principal() - Method in class java.security.cert. X509CRL

从CRL返回发行人（发行人可分辨名称）值为 X500Principal 。

getItalicAngle() - Method in class java.awt. Font

返回这个 Font的斜体角。

getItem() - Method in class java.awt.event. ItemEvent

返回受事件影响的项目。

getItem() - Method in class javafx.scene.control. Cell

返回与该单元格相关联的数据值。

getItem() - Method in interface javax.swing. ComboBoxEditor

返回已编辑的项目

getItem() - Method in class javax.swing.plaf.basic. BasicComboBoxEditor

getItem(int) - Method in class java.awt. Choice

获取此 Choice菜单中指定索引处的字符串。

getItem(int) - Method in class java.awt. List

获取与指定索引关联的项目。

getItem(int) - Method in class java.awt. Menu

获取位于此菜单的指定索引处的项目。

getItem(int) - Method in class javax.swing. JMenu

返回指定位置的 JMenuItem 。

getItemAt(int) - Method in class javax.swing. JComboBox

返回指定索引处的列表项。

getItemCount() - Method in class java.awt. Choice

返回此 Choice菜单中的项目数。

getItemCount() - Method in class java.awt. List

获取列表中的项目数。

getItemCount() - Method in class java.awt. Menu

获取此菜单中的项目数量。

getItemCount() - Method in class javafx.scene.control. FocusModel

返回数据模型中支配控件的项目数。

getItemCount() - Method in class javafx.scene.control. SingleSelectionModel

获取可用于选择模型的项目数。

getItemCount() - Method in class javafx.scene.control.skin. ListViewSkin

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

getItemCount() - Method in class javafx.scene.control.skin. TableViewSkin

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

getItemCount() - Method in class javafx.scene.control.skin. TreeTableViewSkin

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

getItemCount() - Method in class javafx.scene.control.skin. TreeViewSkin

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

getItemCount() - Method in class javafx.scene.control.skin. VirtualContainerBase

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

getItemCount() - Method in class javafx.scene.control. TableView.TableViewFocusModel

返回数据模型中支配控件的项目数。

getItemCount() - Method in class javafx.scene.control. TableView.TableViewSelectionModel

返回数据模型中支配控件的项目数。

getItemCount() - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel

返回数据模型中支配控件的项目数。

getItemCount() - Method in class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel

返回数据模型中支配控件的项目数。

getItemCount() - Method in class javax.swing. JComboBox

返回列表中的项目数。

getItemCount() - Method in class javax.swing. JMenu

返回菜单上的项目数，包括分隔符。

getItemListeners() - Method in class java.awt. Checkbox

返回在此复选框上注册的所有项目侦听器的数组。

getItemListeners() - Method in class java.awt. CheckboxMenuItem

返回在此复选框菜单上注册的所有项目侦听器的数组。

getItemListeners() - Method in class java.awt. Choice

返回在此选项上注册的所有项目侦听器的数组。

getItemListeners() - Method in class java.awt. List

返回在此列表中注册的所有项目侦听器的数组。

getItemListeners() - Method in class javax.swing. AbstractButton

返回一个使用addItemListener（）添加到此AbstractButton的所有 ItemListener的数组。

getItemListeners() - Method in class javax.swing. DefaultButtonModel

返回在这个 DefaultButtonModel上注册的所有项目监听器的数组。

getItemListeners() - Method in class javax.swing. JComboBox

返回使用addItemListener（）添加到此JComboBox的所有 ItemListener的数组。

getItems() - Method in class java.awt. List

获取列表中的项目。

getItems() - Method in class javafx.scene.control.cell. ChoiceBoxListCell

返回要显示在ChoiceBox中的项目。

getItems() - Method in class javafx.scene.control.cell. ChoiceBoxTableCell

返回要显示在ChoiceBox中的项目。

getItems() - Method in class javafx.scene.control.cell. ChoiceBoxTreeCell

返回要显示在ChoiceBox中的项目。

getItems() - Method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell

返回要显示在ChoiceBox中的项目。

getItems() - Method in class javafx.scene.control.cell. ComboBoxListCell

返回要显示在ChoiceBox中的项目。

getItems() - Method in class javafx.scene.control.cell. ComboBoxTableCell

返回要显示在ComboBox中的项目。

getItems() - Method in class javafx.scene.control.cell. ComboBoxTreeCell

返回要显示在ComboBox中的项目。

getItems() - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

返回要显示在ComboBox中的项目。

getItems() - Method in class javafx.scene.control. ChoiceBox

获取属性项的值。

getItems() - Method in class javafx.scene.control. ChoiceDialog

返回将显示给用户的所有项目的列表。

getItems() - Method in class javafx.scene.control. ComboBox

获取属性项的值。

getItems() - Method in class javafx.scene.control. ContextMenu

上下文菜单中的菜单项。

getItems() - Method in class javafx.scene.control. ListView

返回一个ObservableList ，其中包含当前显示给用户的项目。

getItems() - Method in class javafx.scene.control. Menu

在此菜单中显示的项目。

getItems() - Method in class javafx.scene.control. MenuButton

在此按钮菜单中显示的项目。

getItems() - Method in class javafx.scene.control. SpinnerValueFactory.ListSpinnerValueFactory

返回一个ObservableList ，其中包含当前用户可以迭代的项目。

getItems() - Method in class javafx.scene.control. SplitPane

返回一个ObservableList，可用于修改SplitPane的内容。

getItems() - Method in class javafx.scene.control. TableView

获取属性项的值。

getItems() - Method in class javafx.scene.control. ToolBar

项目包含在 ToolBar 。

getItemSelectable() - Method in class java.awt.event. ItemEvent

返回事件的发起者。

getIterationCount() - Method in interface javax.crypto.interfaces. PBEKey

返回迭代计数，如果未指定则返回0。

getIterationCount() - Method in class javax.crypto.spec. PBEKeySpec

返回迭代计数，如果未指定则返回0。

getIterationCount() - Method in class javax.crypto.spec. PBEParameterSpec

返回迭代计数。

getIterations() - Method in class javafx.scene.effect. BoxBlur

获取属性迭代的值。

getIterator() - Method in class java.text. AttributedString

创建一个AttributedCharacterIterator实例，该实例提供对该字符串的整个内容的访问。

getIterator(AttributedCharacterIterator.Attribute[]) - Method in class java.text. AttributedString

创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。

getIterator(AttributedCharacterIterator.Attribute[], int, int) - Method in class java.text. AttributedString

创建一个AttributedCharacterIterator实例，该实例提供对此字符串的选定内容的访问。

getIterator(HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument

获取指定的HTML标签的迭代器。

getIV() - Method in class javax.crypto. Cipher

返回新缓冲区中的初始化向量（IV）。

getIV() - Method in class javax.crypto.spec. GCMParameterSpec

返回初始化向量（IV）。

getIV() - Method in class javax.crypto.spec. IvParameterSpec

返回初始化向量（IV）。

getIV() - Method in class javax.crypto.spec. RC2ParameterSpec

如果此参数集不包含IV，则返回IV或null。

getIV() - Method in class javax.crypto.spec. RC5ParameterSpec

如果此参数集不包含IV，则返回IV或null。

getJarEntry() - Method in class java.net. JarURLConnection

返回此连接的JAR条目对象（如果有）。

getJarEntry(String) - Method in class java.util.jar. JarFile

如果 JarEntry ，则返回给定基本条目名称的 null或 null 。

getJarFile() - Method in class java.net. JarURLConnection

返回此连接的JAR文件。

getJarFiles() - Method in class javax.management.loading. MLetContent

获取由 MLET标签的 ARCHIVE属性指定的 .jar文件列表。

getJarFileURL() - Method in class java.net. JarURLConnection

返回此连接的Jar文件的URL。

getJavaEncoding(String) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

从IANA名称获取相应的Java编码名称。

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - Method in class javax.tools. ForwardingJavaFileManager

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - Method in interface javax.tools. JavaFileManager

返回一个file object，用于在给定的面向包的位置中表示指定类型的指定类的输入。

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - Method in class javax.tools. ForwardingJavaFileManager

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - Method in interface javax.tools. JavaFileManager

返回一个file object，用于在给定的面向对象的位置中表示指定类型的指定类的输出。

getJavaFileManager() - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回用于读取和写入文件的文件管理器。

getJavaFileObjects(File...) - Method in interface javax.tools. StandardJavaFileManager

返回表示给定文件的文件对象。

getJavaFileObjects(String...) - Method in interface javax.tools. StandardJavaFileManager

返回表示给定文件名的文件对象。

getJavaFileObjects(Path...) - Method in interface javax.tools. StandardJavaFileManager

返回表示给定路径的文件对象。

getJavaFileObjectsFromFiles(Iterable<? extends File>) - Method in interface javax.tools. StandardJavaFileManager

返回表示给定文件的文件对象。

getJavaFileObjectsFromPaths(Iterable<? extends Path>) - Method in interface javax.tools. StandardJavaFileManager

返回表示给定路径的文件对象。

getJavaFileObjectsFromStrings(Iterable<String>) - Method in interface javax.tools. StandardJavaFileManager

返回表示给定文件名的文件对象。

getJavaInitializationString() - Method in interface java.beans. PropertyEditor

返回可用于设置属性以匹配编辑器当前状态的Java代码片段。

getJavaInitializationString() - Method in class java.beans. PropertyEditorSupport

此方法用于生成Java代码以设置属性值。

getJAXBNode(XmlNode) - Method in class javax.xml.bind. Binder

获取与给定XML元素关联的JAXB对象。

getJDBCMajorVersion() - Method in interface java.sql. DatabaseMetaData

检索此驱动程序的主要JDBC版本号。

getJDBCMinorVersion() - Method in interface java.sql. DatabaseMetaData

检索此驱动程序的次要JDBC版本号。

getJMenuBar() - Method in class javax.swing. JApplet

已过时。

返回此applet上的菜单栏。

getJMenuBar() - Method in class javax.swing. JDialog

返回此对话框上的菜单栏。

getJMenuBar() - Method in class javax.swing. JFrame

返回在此框架上设置的菜单栏。

getJMenuBar() - Method in class javax.swing. JInternalFrame

如果没有设置菜单栏，则返回 JMenuBar的当前 JInternalFrame ，或 null 。

getJMenuBar() - Method in class javax.swing. JRootPane

从分层窗格返回菜单栏。

getJobName() - Method in class java.awt.print. PrinterJob

获取要打印的文档的名称。

getJobName() - Method in class javafx.print. JobSettings

获取工作的名称。

getJobSettings() - Method in class javafx.print. PrinterJob

JobSettings封装了所有API支持的作业配置选项，例如份数，排序规则选项，双面选项等。

getJobStatus() - Method in class javafx.print. PrinterJob

获取工作的当前状态。

getJoinType() - Method in interface javax.sql.rowset. JoinRowSet

返回 int描述一组SQL JOIN类型此JoinRowSet实例。

getJustificationInfo() - Method in class java.awt.font. GraphicAttribute

返回此 GraphicAttribute的对齐信息。

getJustifiedLayout(float) - Method in class java.awt.font. TextLayout

创建一个 TextLayout的副本对齐到指定的宽度。

getKeepAlive() - Method in class java.net. Socket

测试是否启用了 SO_KEEPALIVE 。

getKeepAliveTime(TimeUnit) - Method in class java.util.concurrent. ThreadPoolExecutor

返回线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。

getKernel() - Method in class java.awt.image. ConvolveOp

返回内核。

getKernelData(float[]) - Method in class java.awt.image. Kernel

以行主顺序返回内核数据。

getKey() - Method in class java.awt. MenuShortcut

返回此MenuShortcut的原始密码。

getKey() - Method in class java.util. AbstractMap.SimpleEntry

返回与此条目相对应的键。

getKey() - Method in class java.util. AbstractMap.SimpleImmutableEntry

返回与此条目相对应的键。

getKey() - Method in interface java.util. Map.Entry

返回与此条目相对应的键。

getKey() - Method in exception java.util. MissingResourceException

获取由构造函数传递的参数。

getKey() - Method in class java.util.prefs. PreferenceChangeEvent

返回更改的首选项的键。

getKey() - Method in class javafx.collections. MapChangeListener.Change

与变更有关的一个关键。

getKey() - Method in class javafx.scene.input. KeyCombination.Modifier

获取此 Modifier的修饰符键。

getKey() - Method in class javafx.util. Pair

获得这对的钥匙。

getKey() - Method in class javax.accessibility. AccessibleRelation

返回此关系的关键。

getKey() - Method in class javax.crypto.spec. DESedeKeySpec

返回DES-EDE键。

getKey() - Method in class javax.crypto.spec. DESKeySpec

返回DES密钥材料。

getKey() - Method in interface javax.xml.crypto. KeySelectorResult

返回所选的键。

getKey() - Method in interface jdk.nashorn.api.tree. PropertyTree

返回此属性的名称。

getKey(String, char[]) - Method in class java.security. KeyStore

返回与给定别名相关联的密钥，使用给定的密码恢复它。

getKeyChar() - Method in class java.awt. AWTKeyStroke

返回此 AWTKeyStroke的字符。

getKeyChar() - Method in class java.awt.event. KeyEvent

返回与此事件中的键相关联的字符。

getKeyCode() - Method in class java.awt. AWTKeyStroke

返回 AWTKeyStroke的数字键码。

getKeyCode() - Method in class java.awt.event. KeyEvent

返回与此事件中的键相关联的整数keyCode。

getKeyCode(String) - Static method in enum javafx.scene.input. KeyCode

解析一个键的文本表示。

getKeyColumns() - Method in interface javax.sql.rowset. CachedRowSet

返回一个数组，其中包含一个或多个列号，表示形成唯一标识该 CachedRowSet对象行的键的列。

getKeyCombination() - Method in class javafx.scene.input. Mnemonic

返回KeyCombination

getKeyEventDispatchers() - Method in class java.awt. KeyboardFocusManager

将此KeyboardFocusManager的KeyEventDispatcher链作为列表返回。

getKeyEventPostProcessors() - Method in class java.awt. KeyboardFocusManager

将此KeyboardFocusManager的KeyEventPostProcessor链返回为列表。

getKeyEventType() - Method in class java.awt. AWTKeyStroke

返回对应于这个 AWTKeyStroke的 KeyEvent的类型。

getKeyFrames() - Method in class javafx.animation. Timeline

返回这Timeline的Timeline 。

getKeyId() - Method in interface javax.xml.crypto.dsig.keyinfo. PGPData

返回此的PGP公钥标识符 PGPData中定义 RFC 2440 ，11.2节。

getKeyInfo() - Method in interface javax.xml.crypto.dsig. XMLSignature

返回 XMLSignature的关键信息。

getKeyInfoFactory() - Method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回一个 KeyInfoFactory ，创建 KeyInfo对象。

getKeyLength() - Method in class javax.crypto.spec. PBEKeySpec

返回要导出的密钥长度，如果未指定则返回0。

getKeyListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

实现ComboPopup.getKeyListener（）。

getKeyListener() - Method in interface javax.swing.plaf.basic. ComboPopup

返回一个将被添加到组合框或null的关键侦听器。

getKeyListeners() - Method in class java.awt. Component

返回在此组件上注册的所有关键侦听器的数组。

getKeyLocation() - Method in class java.awt.event. KeyEvent

返回发起此键事件的键的位置。

getKeyManagers() - Method in class javax.net.ssl. KeyManagerFactory

返回每种类型的密钥材料的一个密钥管理器。

getKeymap() - Method in class javax.swing.text. JTextComponent

获取此文本组件中当前活动的键盘图。

getKeymap(String) - Static method in class javax.swing.text. JTextComponent

获取先前添加到文档的命名键盘映射。

getKeymapName() - Method in class javax.swing.plaf.basic. BasicTextUI

获取此UI将默认安装/使用的键盘映射的名称。

getKeyModifiersText(int) - Static method in class java.awt.event. KeyEvent

已过时。
建议使用扩展修饰键和InputEvent.getModifiersExText(int)

getKeyPacket() - Method in interface javax.xml.crypto.dsig.keyinfo. PGPData

返回此的PGP密钥材料包 PGPData中定义 RFC 2440 ，第5.5节。

getKeyProperty(String) - Method in class javax.management. ObjectName

获取与键属性中的键相关联的值。

getKeyPropertyList() - Method in class javax.management. ObjectName

将关键属性作为Hashtable返回。

getKeyPropertyListString() - Method in class javax.management. ObjectName

返回在创建时指定的关键属性列表的字符串表示形式。

getKeys() - Method in class java.util. ListResourceBundle

返回一个 Enumeration包含在此按键 ResourceBundle及其父包。

getKeys() - Method in class java.util. PropertyResourceBundle

返回一个 Enumeration包含在此按键 ResourceBundle及其父包。

getKeys() - Method in class java.util. ResourceBundle

返回键的枚举。

getKeys() - Method in class javax.swing. AbstractAction

返回一个 Object s的数组，它们是为这个 AbstractAction设置了值的键，如果没有键设置值，则 null 。

getKeys(KerberosPrincipal) - Method in class javax.security.auth.kerberos. KeyTab

返回给定Kerberos主体的新密钥。

getKeySelectionManager() - Method in class javax.swing. JComboBox

返回列表的密钥选择管理器。

getKeySelector() - Method in class javax.xml.crypto.dom. DOMCryptoContext

getKeySelector() - Method in interface javax.xml.crypto. XMLCryptoContext

返回用于查找密钥的密钥选择器。

getKeySelectorResult() - Method in interface javax.xml.crypto.dsig. XMLSignature

返回KeySelector的结果，如果指定，则在此后的XMLSignature已经签名或验证。

getKeysize() - Method in class java.security.spec. RSAKeyGenParameterSpec

返回keysize。

getKeySpec(Key) - Method in class javax.crypto. EncryptedPrivateKeyInfo

从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。

getKeySpec(Key, Class<T>) - Method in class java.security. KeyFactory

返回给定键对象的规范（关键材料）。

getKeySpec(Key, String) - Method in class javax.crypto. EncryptedPrivateKeyInfo

从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。

getKeySpec(Key, Provider) - Method in class javax.crypto. EncryptedPrivateKeyInfo

从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。

getKeySpec(Cipher) - Method in class javax.crypto. EncryptedPrivateKeyInfo

从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。

getKeySpec(SecretKey, Class<?>) - Method in class javax.crypto. SecretKeyFactory

以请求的格式返回给定键对象的规范（关键材料）。

getKeyStore() - Method in class java.security. KeyStore.Builder

返回此对象描述的KeyStore。

getKeyStroke(char) - Static method in class javax.swing. KeyStroke

返回一个 KeyStroke的共享实例，代表指定字符的 KEY_TYPED事件。

getKeyStroke(char, boolean) - Static method in class javax.swing. KeyStroke

已过时。
使用getKeyStroke（char）

getKeyStroke(int, int) - Static method in class javax.swing. KeyStroke

返回一个KeyStroke的共享实例，给出一个数字键代码和一组修饰符。

getKeyStroke(int, int, boolean) - Static method in class javax.swing. KeyStroke

返回一个KeyStroke的共享实例，给出一个数字键代码和一组修饰符，指定按下或释放该键是否被激活。

getKeyStroke(Character, int) - Static method in class javax.swing. KeyStroke

返回一个 KeyStroke的共享实例，该实例表示指定的Character对象的 KEY_TYPED事件和一组修饰符。

getKeyStroke(String) - Static method in class javax.swing. KeyStroke

解析一个字符串并返回一个 KeyStroke 。

getKeyStrokeForEvent(KeyEvent) - Static method in class javax.swing. KeyStroke

返回一个KeyStroke，它表示生成给定KeyEvent的笔触。

getKeyStrokesForAction(Action) - Method in interface javax.swing.text. Keymap

获取将导致给定操作的按键。

getKeyText(int) - Static method in class java.awt.event. KeyEvent

返回一个描述keyCode的String，如“HOME”，“F1”或“A”。

getKeyType() - Method in class javax.security.auth.kerberos. EncryptionKey

返回此键的键类型。

getKeyType() - Method in class javax.security.auth.kerberos. KerberosKey

返回此长期密钥的密钥类型。

getKeyUsage() - Method in class java.security.cert. X509Certificate

获取表示 KeyUsage扩展名（OID = 2.5.29.15）的位的布尔数组。

getKeyUsage() - Method in class java.security.cert. X509CertSelector

返回keyUsage标准。

getKind() - Method in interface com.sun.source.doctree. DocTree

返回此树的种类。

getKind() - Method in interface com.sun.source.tree. 树

返回此树的种类。

getKind() - Method in class com.sun.source.util. TaskEvent

返回此事件的种类。

getKind() - Method in interface javax.lang.model.element. Element

返回此元素的 kind 。

getKind() - Method in interface javax.lang.model.element. ModuleElement.Directive

返回此指令的 kind 。

getKind() - Method in interface javax.lang.model.type. TypeMirror

返回此类型的 kind 。

getKind() - Method in interface javax.tools. Diagnostic

返回此诊断的类型，例如错误或警告。

getKind() - Method in class javax.tools. ForwardingJavaFileObject

getKind() - Method in interface javax.tools. JavaFileObject

返回此文件对象的种类。

getKind() - Method in class javax.tools. SimpleJavaFileObject

getKind() - Method in interface jdk.javadoc.doclet. Doclet.Option

返回选项种类。

getKind() - Method in interface jdk.nashorn.api.tree. Diagnostic

获得此诊断的类型，例如错误或警告。

getKind() - Method in interface jdk.nashorn.api.tree. 树

获得这棵树的种类。

getL() - Method in class javax.crypto.spec. DHParameterSpec

返回随机指数（私有值）的大小（ l ）。

getLabel() - Method in interface com.sun.source.doctree. LinkTree

返回链接的标签（如果有）。

getLabel() - Method in interface com.sun.source.tree. BreakTree

返回此 break语句的标签。

getLabel() - Method in interface com.sun.source.tree. ContinueTree

返回此 continue语句的标签。

getLabel() - Method in interface com.sun.source.tree. LabeledStatementTree

返回标签。

getLabel() - Method in class java.awt. Button

获取此按钮的标签。

getLabel() - Method in class java.awt. Checkbox

获取此复选框的标签。

getLabel() - Method in class java.awt. MenuItem

获取此菜单项的标签。

getLabel() - Method in class javafx.scene.chart. Axis

获取属性标签的值。

getLabel() - Method in class javafx.scene.chart. Axis.TickMark

获取属性标签的值。

getLabel() - Method in class javax.swing. AbstractButton

已过时。
- 替换为getText

getLabel() - Method in class javax.swing. JPopupMenu

返回弹出菜单的标签

getLabel() - Method in class javax.swing.text.html. Option

获取与该选项相关联的标签。

getLabel() - Method in interface jdk.nashorn.api.tree. BreakTree

与此break语句关联的标签。

getLabel() - Method in interface jdk.nashorn.api.tree. ContinueTree

与此continue语句关联的标签。

getLabel() - Method in interface jdk.nashorn.api.tree. GotoTree

与此goto语句关联的标签。

getLabel() - Method in interface jdk.nashorn.api.tree. LabeledStatementTree

返回与此语句关联的标签。

getLabel() - Method in interface org.w3c.dom.html. HTMLOptGroupElement

为此选项组分配一个标签。

getLabel() - Method in interface org.w3c.dom.html. HTMLOptionElement

分层菜单中使用的选项标签。

getLabelFor() - Method in class javafx.scene.control. Label

获取属性labelFor的值。

getLabelFor() - Method in class javax.swing. JLabel

获取此标签的组件。

getLabelFormatter() - Method in class javafx.scene.control. Slider

获取属性labelFormatter的值。

getLabelLineLength() - Method in class javafx.scene.chart. PieChart

获取属性labelLineLength的值。

getLabelPadding() - Method in class javafx.scene.control. Labeled

获取属性labelPadding的值。

getLabelsVisible() - Method in class javafx.scene.chart. PieChart

指示是否绘制饼切片标签

getLabelTable() - Method in class javax.swing. JSlider

返回要在哪些值绘制哪些标签的字典。

getLang() - Method in interface org.w3c.dom.html. HTMLElement

RFC 1766中定义的语言代码。

getLanguage() - Method in class java.util. Locale

返回此区域设置的语言代码。

getLanguage() - Method in class javafx.scene.media. AudioTrack

已过时。
改用Track.getLocale() 。

getLanguageName() - Method in interface javax.script. ScriptEngineFactory

返回此 ScriptEngine支持的脚本语言的名称。

getLanguageName() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getLanguageVersion() - Method in interface javax.script. ScriptEngineFactory

返回此 ScriptEngine支持的脚本语言版本。

getLanguageVersion() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getLargeDisplayIcon() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

返回面板的大显示图标。

getLargeMaxRows() - Method in interface java.sql. Statement

检索一个的最大行数 ResultSet由此产生对象 Statement对象可以包含。

getLargestMinimum() - Method in class java.time.temporal. ValueRange

获取该字段可能采取的最大可能最小值。

getLargestPoolSize() - Method in class java.util.concurrent. ThreadPoolExecutor

返回在池中同时进行的最大线程数。

getLargeUpdateCount() - Method in interface java.sql. Statement

将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。

getLargeUpdateCounts() - Method in exception java.sql. BatchUpdateException

检索在发生此异常之前成功执行的批量更新中每个更新语句的更新计数。

getLast() - Method in class java.util. ArrayDeque

getLast() - Method in class java.util.concurrent. ConcurrentLinkedDeque

getLast() - Method in class java.util.concurrent. LinkedBlockingDeque

getLast() - Method in interface java.util. Deque

检索，但不删除，这个deque的最后一个元素。

getLast() - Method in class java.util. LinkedList

返回此列表中的最后一个元素。

getLastAccessedTime() - Method in interface javax.net.ssl. SSLSession

返回会话级基础架构访问该会话表示的最后一次，以毫秒为单位，自1970年1月1日UTC之后。

getLastAccessTime() - Method in class java.util.zip. ZipEntry

返回条目的最后访问时间。

getLastChild() - Method in class javax.imageio.metadata. IIOMetadataNode

返回此节点的最后一个子节点，如果该节点没有子节点，则返回 null 。

getLastChild() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的最后一个子节点。

getLastChild() - Method in interface org.w3c.dom. Node

这个节点的最后一个孩子。

getLastChildPath(TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回到最后一个孩子的路径 parent 。

getLastColumn() - Method in interface javax.accessibility. AccessibleTableModelChange

返回更改的最后一列。

getLastColumn() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange

返回最后一列。

getLastComponent(Container) - Method in class java.awt. ContainerOrderFocusTraversalPolicy

返回遍历周期中的最后一个组件。

getLastComponent(Container) - Method in class java.awt. FocusTraversalPolicy

返回遍历周期中的最后一个组件。

getLastComponent(Container) - Method in class javax.swing. DefaultFocusManager

返回最后一个组件。

getLastComponent(Container) - Method in class javax.swing. LayoutFocusTraversalPolicy

返回遍历周期中的最后一个组件。

getLastComponent(Container) - Method in class javax.swing. SortingFocusTraversalPolicy

返回遍历周期中的最后一个组件。

getLastCursor() - Method in class javax.swing. JInternalFrame

返回由 setCursor方法设置的最后一个 Cursor ，该方法不是可调整大小的 Cursor 。

getLastDividerLocation() - Method in class javax.swing. JSplitPane

返回分隔符所在的最后一个位置。

getLastDragLocation() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回 JSplitPane的最后一个拖动位置。

getLastElementChild() - Method in interface org.w3c.dom. ElementTraversal

返回对元素的最后一个子节点的引用，它是Element类型。

getLastGcInfo() - Method in interface com.sun.management. GarbageCollectorMXBean

返回有关最新GC的GC信息。

getLastIndex() - Method in class javax.swing.event. ListSelectionEvent

返回其选择可能已更改的最后一行的索引。

getLastLeaf() - Method in class javax.swing.tree. DefaultMutableTreeNode

查找并返回作为此节点的后代的最后一个叶 - 该节点或其最后一个子节点的最后一个叶。

getLastModified() - Method in class java.net. URLConnection

返回 last-modified标题字段的值。

getLastModified() - Method in class javax.jnlp. DownloadService2.ResourceSpec

返回上次修改资源的时间。

getLastModified() - Method in interface javax.tools. FileObject

返回此文件对象上次修改的时间。

getLastModified() - Method in class javax.tools. ForwardingFileObject

getLastModified() - Method in class javax.tools. SimpleJavaFileObject

此实现返回 0L 。

getLastModifiedTime() - Method in class java.util.zip. ZipEntry

返回条目的最后修改时间。

getLastModifiedTime(Path, LinkOption...) - Static method in class java.nio.file. Files

返回文件的上次修改时间。

getLastPathComponent() - Method in class javax.swing.tree. TreePath

返回此路径的最后一个元素。

getLastRow() - Method in interface javax.accessibility. AccessibleTableModelChange

返回更改的最后一行。

getLastRow() - Method in class javax.swing.event. TableModelEvent

返回更改的最后一行。

getLastRow() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange

返回最后一行。

getLastSelectedPathComponent() - Method in class javax.swing. JTree

返回所选路径的最后一个路径组件。

getLastValue() - Method in class javafx.concurrent. ScheduledService

获取属性lastValue的值。

getLastVisibleCell() - Method in class javafx.scene.control.skin. VirtualFlow

查找并返回当前部分或完全可见的最后一个非空IndexedCell。

getLastVisibleIndex() - Method in class javax.swing. JList

返回当前可见的最大列表索引。

getLastVisitedDate() - Method in class javafx.scene.web. WebHistory.Entry

获取属性lastVisitedDate的值。

getLatency() - Method in interface javax.sound.midi. Synthesizer

获得该合成器产生的处理延迟，以微秒表示。

getLateReflectionDelay() - Method in class javax.sound.sampled. ReverbType

返回延迟反射延迟时间（以微秒为单位）。

getLateReflectionIntensity() - Method in class javax.sound.sampled. ReverbType

以分贝返回后期反射强度。

getLayer() - Method in class java.lang. Module

如果此模块不在模块层中，则返回包含此模块的模块层或 null 。

getLayer() - Method in class javax.swing. JInternalFrame

获取此组件的图层属性的便捷方法。

getLayer(Component) - Method in class javax.swing. JLayeredPane

返回指定Component的layer属性。

getLayer(JComponent) - Static method in class javax.swing. JLayeredPane

获取JComponent的layer属性，它不会导致任何类似setLayer（）的副作用。

getLayeredPane() - Method in class javax.swing. JApplet

已过时。

返回此applet的layeredPane对象。

getLayeredPane() - Method in class javax.swing. JDialog

返回此对话框的 layeredPane对象。

getLayeredPane() - Method in class javax.swing. JFrame

返回此帧的 layeredPane对象。

getLayeredPane() - Method in class javax.swing. JInternalFrame

返回此内部框架的分层窗格。

getLayeredPane() - Method in class javax.swing. JRootPane

获取根窗格使用的分层窗格。

getLayeredPane() - Method in class javax.swing. JWindow

返回此窗口的 layeredPane对象。

getLayeredPane() - Method in interface javax.swing. RootPaneContainer

返回layeredPane。

getLayeredPaneAbove(Component) - Static method in class javax.swing. JLayeredPane

方便方法返回包含指定组件的第一个JLayeredPane。

getLayerEventMask() - Method in class javax.swing. JLayer

返回此 JLayer及其 LayerUI接收的事件掩码的位图。

getLayout() - Method in class java.awt. Container

获取此容器的布局管理器。

getLayout(int, int) - Method in class java.awt.font. TextMeasurer

在给定的字符范围内返回一个 TextLayout 。

getLayoutAlignmentX(Container) - Method in class java.awt. BorderLayout

返回沿x轴的对齐方式。

getLayoutAlignmentX(Container) - Method in class java.awt. CardLayout

返回沿x轴的对齐方式。

getLayoutAlignmentX(Container) - Method in class java.awt. GridBagLayout

返回沿x轴的对齐方式。

getLayoutAlignmentX(Container) - Method in interface java.awt. LayoutManager2

返回沿x轴的对齐方式。

getLayoutAlignmentX(Container) - Method in class javax.swing. BoxLayout

返回容器沿X轴的对齐方式。

getLayoutAlignmentX(Container) - Method in class javax.swing. GroupLayout

返回沿x轴的对齐方式。

getLayoutAlignmentX(Container) - Method in class javax.swing. JRootPane.RootLayout

getLayoutAlignmentX(Container) - Method in class javax.swing. OverlayLayout

返回容器沿x轴的对齐方式。

getLayoutAlignmentX(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

返回沿x轴的对齐方式。

getLayoutAlignmentX(Container) - Method in class javax.swing. SpringLayout

返回0.5f（居中）。

getLayoutAlignmentY(Container) - Method in class java.awt. BorderLayout

返回沿着y轴的对齐。

getLayoutAlignmentY(Container) - Method in class java.awt. CardLayout

返回沿着y轴的对齐。

getLayoutAlignmentY(Container) - Method in class java.awt. GridBagLayout

返回沿着y轴的对齐。

getLayoutAlignmentY(Container) - Method in interface java.awt. LayoutManager2

返回沿着y轴的对齐。

getLayoutAlignmentY(Container) - Method in class javax.swing. BoxLayout

返回容器沿着Y轴的对齐方式。

getLayoutAlignmentY(Container) - Method in class javax.swing. GroupLayout

返回沿着y轴的对齐。

getLayoutAlignmentY(Container) - Method in class javax.swing. JRootPane.RootLayout

getLayoutAlignmentY(Container) - Method in class javax.swing. OverlayLayout

返回容器沿y轴的对齐方式。

getLayoutAlignmentY(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

返回沿着y轴的对齐。

getLayoutAlignmentY(Container) - Method in class javax.swing. SpringLayout

返回0.5f（居中）。

getLayoutBounds() - Method in class javafx.scene. Node

获取属性layoutBounds的值。

getLayoutComponent(Container, Object) - Method in class java.awt. BorderLayout

基于目标 Container的组件方向返回与给定约束位置相对应的组件。

getLayoutComponent(Object) - Method in class java.awt. BorderLayout

获取使用给定约束添加的组件

getLayoutDimensions() - Method in class java.awt. GridBagLayout

确定布局网格的列宽和行高。

getLayoutFlags() - Method in class java.awt.font. GlyphVector

返回描述GlyphVector全局状态的标志。

getLayoutInfo(Container, int) - Method in class java.awt. GridBagLayout

针对当前管理的儿童组 GridBagLayoutInfo的例子。

GetLayoutInfo(Container, int) - Method in class java.awt. GridBagLayout

此方法已过时，仅供后向兼容; 新代码应该调用getLayoutInfo 。

getLayoutOrientation() - Method in class javax.swing. JList

返回列表的布局方向属性： VERTICAL如果布局是单列单元格， VERTICAL_WRAP如果布局是“报纸样式”，内容垂直然后水平流动，或 HORIZONTAL_WRAP如果布局是“报纸样式”与内容水平流动然后垂直。

getLayoutOrigin() - Method in class java.awt. GridBagLayout

确定目标容器的图形坐标空间中的布局区域的原点。

getLayoutPath() - Method in class java.awt.font. TextLayout

返回LayoutPath，如果布局路径是默认路径，则为null（x映射到advance，y映射到offset）。

getLayoutQueue() - Method in class javax.swing.text. AsyncBoxView

获取队列以用于布局。

getLayoutStyle() - Method in class javax.swing. GroupLayout

返回用于计算组件之间优选间隙的 LayoutStyle 。

getLayoutStyle() - Method in class javax.swing. LookAndFeel

返回 LayoutStyle这种外观。

getLayoutStyle() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

返回 LayoutStyle实现Java外观和作为指定觉得设计指南 http://www.oracle.com/technetwork/java/hig-136467.html 。

getLayoutView(int) - Method in class javax.swing.text. ParagraphView

返回给定的视图 index 。

getLayoutViewCount() - Method in class javax.swing.text. ParagraphView

返回此视图负责的视图数。

getLayoutWeights() - Method in class java.awt. GridBagLayout

确定布局网格的列和行的权重。

getLayoutX() - Method in class javafx.scene. Node

获取属性layoutX的值。

getLayoutY() - Method in class javafx.scene. Node

获取属性layoutY的值。

getLeader() - Method in class javax.swing.text. TabStop

返回标签的领导。

getLeading() - Method in class java.awt.font. LineMetrics

返回文本的前导。

getLeading() - Method in class java.awt.font. TextLayout

返回 TextLayout的领先 TextLayout 。

getLeading() - Method in class java.awt. FontMetrics

确定 FontMetrics对象描述的 Font的 标准引导 。

getLeadSelectionIndex() - Method in class javax.swing. DefaultListSelectionModel

将第二个索引参数从最近的调用返回给setSelectionInterval（），addSelectionInterval（）或removeSelectionInterval（）。

getLeadSelectionIndex() - Method in class javax.swing. JList

返回引导选择索引。

getLeadSelectionIndex() - Method in interface javax.swing. ListSelectionModel

将第二个索引参数从最近的调用返回给setSelectionInterval（），addSelectionInterval（）或removeSelectionInterval（）。

getLeadSelectionPath() - Method in class javax.swing. JTree

返回标识为铅的路径。

getLeadSelectionPath() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回添加的最后一个路径。

getLeadSelectionPath() - Method in interface javax.swing.tree. TreeSelectionModel

返回添加的最后一个路径。

getLeadSelectionRow() - Method in class javax.swing. JTree

返回与引导路径对应的行索引。

getLeadSelectionRow() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回选择的首行。

getLeadSelectionRow() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回引导选择索引。

getLeadSelectionRow() - Method in interface javax.swing.tree. TreeSelectionModel

返回引导选择索引。

getLeaf() - Method in class com.sun.source.util. DocTreePath

返回此路径的叶节点。

getLeaf() - Method in class com.sun.source.util. TreePath

返回此路径的叶节点。

getLeafCount() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回作为该节点后代的树叶总数。

getLeafIcon() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回用于表示叶节点的图标。

getLeastMaximum(int) - Method in class java.util. Calendar

返回此 Calendar实例的给定日历字段的最低最大值。

getLeastMaximum(int) - Method in class java.util. GregorianCalendar

返回此 GregorianCalendar实例的给定日历字段的最低最大值。

getLeastSignificantBits() - Method in class java.util. UUID

返回此UUID的128位值的最低有效64位。

getLeft() - Method in class javafx.geometry. Insets

左侧的插图

getLeft() - Method in class javafx.scene.layout. BorderPane

获取剩下的属性的值。

getLeft() - Method in class javafx.scene.layout. BorderWidths

非负值（ BorderWidths.AUTO除外 ），表示边框左侧的边框厚度。

getLeft() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的左侧属性定义。

getLeft() - Method in interface org.w3c.dom.css. Rect

该属性用于rect的左侧。

getLeftAnchor(Node) - Static method in class javafx.scene.layout. AnchorPane

如果设置，返回小孩的左锚约束。

getLeftChildIndent() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回左子缩进。

getLeftComponent() - Method in class javax.swing. JSplitPane

将分量返回到左侧（或上方）。

getLeftIndent(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取左缩进设置。

getLeftInset() - Method in class javax.swing.text. AsyncBoxView

在视图中获取边缘的左边部分。

getLeftInset() - Method in class javax.swing.text. CompositeView

得到左边的插图。

getLeftMargin() - Method in class javafx.print. PageLayout

以点为单位返回页面布局的左边距。

getLeftOperand() - Method in interface com.sun.source.tree. BinaryTree

返回表达式的左（第一）操作数。

getLeftOperand() - Method in interface jdk.nashorn.api.tree. BinaryTree

返回此二进制表达式的左侧（LHS）。

getLeftStroke() - Method in class javafx.scene.layout. BorderStroke

定义此边框左侧的填充。

getLeftStyle() - Method in class javafx.scene.layout. BorderStroke

定义此边框左侧的样式。

getLegalValues() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport

返回此 OpenMBeanAttributeInfoSupport实例描述的属性（如果指定）的不可修改的合法值集合，否则 null 。

getLegalValues() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回该参数的合法值集合，如果它有一个，否则 null 。

getLegalValues() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport

返回此 OpenMBeanParameterInfoSupport实例（如果指定）描述的参数的不可修改的合法值集合，否则 null 。

getLegend() - Method in class javafx.scene.chart. Chart

获取属性图例的值。

getLegendSide() - Method in class javafx.scene.chart. Chart

获取属性legendSide的值。

getLength() - Method in class java.net. DatagramPacket

返回要发送的数据的长度或接收到的数据的长度。

getLength() - Method in class java.text. Bidi

返回行中的文本长度。

getLength() - Method in class javafx.scene.control. IndexRange

返回范围的长度。

getLength() - Method in class javafx.scene.control. TextInputControl

获取属性长度的值。

getLength() - Method in class javafx.scene.shape. Arc

获取属性长度的值。

getLength() - Method in class javax.imageio.metadata. IIOMetadataNode

getLength() - Method in class javax.imageio.stream. IIOByteBuffer

返回由 getData返回的字节数组内的感兴趣的数据的长度。

getLength() - Method in interface javax.jnlp. FileContents

获取文件的长度。

getLength() - Method in class javax.sound.midi. MidiMessage

以字节获得MIDI消息的总长度。

getLength() - Method in interface javax.swing.event. DocumentEvent

返回更改的长度。

getLength() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

返回更改的长度。

getLength() - Method in class javax.swing.text. AbstractDocument

返回数据的长度。

getLength() - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

获取长度。

getLength() - Method in interface javax.swing.text. Document

返回文档中当前内容的字符数。

getLength() - Method in interface org.w3c.dom. CharacterData

可通过 data获得的16位单元 data和下面的 substringData方法。

getLength() - Method in interface org.w3c.dom.css. CSSRuleList

列表中的数量为 CSSRules 。

getLength() - Method in interface org.w3c.dom.css. CSSStyleDeclaration

在此声明块中已显式设置的属性数。

getLength() - Method in interface org.w3c.dom.css. CSSValueList

列表中的数量为 CSSValues 。

getLength() - Method in interface org.w3c.dom. DOMImplementationList

列表中的 DOMImplementation的数量。

getLength() - Method in interface org.w3c.dom. DOMStringList

列表中的数量为 DOMString 。

getLength() - Method in interface org.w3c.dom.html. HTMLCollection

此属性指定列表的长度或大小。

getLength() - Method in interface org.w3c.dom.html. HTMLFormElement

形式控件的数量。

getLength() - Method in interface org.w3c.dom.html. HTMLSelectElement

这个 SELECT的选项数量。

getLength() - Method in interface org.w3c.dom. NamedNodeMap

该地图中的节点数。

getLength() - Method in interface org.w3c.dom. NameList

列表中的对数（name和namespaceURI）。

getLength() - Method in interface org.w3c.dom. NodeList

列表中的节点数。

getLength() - Method in interface org.w3c.dom.stylesheets. MediaList

列表中的媒体数量。

getLength() - Method in interface org.w3c.dom.stylesheets. StyleSheetList

列表中的数量为 StyleSheets 。

getLength() - Method in interface org.xml.sax. AttributeList

已过时。

返回此列表中的属性数。

getLength() - Method in interface org.xml.sax. Attributes

返回列表中的属性数。

getLength() - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

返回列表中的属性数。

getLength() - Method in class org.xml.sax.helpers. AttributesImpl

返回列表中的属性数。

getLength(Object) - Static method in class java.lang.reflect. Array

返回指定数组对象的长度，如 int 。

getLengths() - Method in class javax.imageio.plugins.jpeg. JPEGHuffmanTable

返回一个 short s的数组， short包含霍夫曼表中每个长度的值的数量。

getLetterSpacing() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的letter-spacing属性定义。

getLevel() - Method in class java.util.logging. Handler

获取日志级别，指定 Handler将记录哪些消息。

getLevel() - Method in class java.util.logging. Logger

获取为此记录器指定的日志级别。

getLevel() - Method in class java.util.logging. LogRecord

获取日志消息级别，例如Level.SEVERE。

getLevel() - Method in class javafx.scene.effect. Glow

获取属性级别的值。

getLevel() - Method in class javafx.scene.effect. SepiaTone

获取属性级别的值。

getLevel() - Method in interface javax.sound.sampled. DataLine

获取该行的当前音量级别。

getLevel() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点以上的级别数 - 从根到该节点的距离。

getLevelAt(int) - Method in class java.text. Bidi

返回已解决的偏移角色级别。

getLexicalHandler() - Method in class javax.xml.transform.sax. SAXResult

获取SAX2 LexicalHandler的输出。

getLibraryDirectory() - Method in class javax.management.loading. MLet

获取库加载器用于存储本机库的当前目录，然后再将其加载到内存中。

getLibraryDirectory() - Method in interface javax.management.loading. MLetMBean

获取库加载器用于存储本机库的当前目录，然后再将其加载到内存中。

getLibraryPath() - Method in interface java.lang.management. RuntimeMXBean

返回Java库路径。

getLifetime() - Method in interface org.ietf.jgss. GSSContext

确定此上下文的剩余生命周期。

getLight() - Method in class javafx.scene.effect. Lighting

获取属性灯的值。

getLimit() - Method in class javax.swing.undo. UndoManager

返回 UndoManager所持有的最大编辑次数。

getLimits() - Method in class java.text. ChoiceFormat

获取构造函数中传递的限制。

getLine() - Method in class javax.sound.sampled. LineEvent

获取作为此事件的来源的音频线。

getLine(Line.Info) - Static method in class javax.sound.sampled. AudioSystem

获取与指定的 Line.Info对象中的描述匹配的行。

getLine(Line.Info) - Method in interface javax.sound.sampled. Mixer

获取可用的行，并与指定的 Line.Info对象中的描述相匹配。

getLineBreakIndex(int, float) - Method in class java.awt.font. TextMeasurer

返回在 start开始的行上不适合的第一个字符的索引，并且可以以图形宽度测量高达 maxAdvance 。

getLineBuffer() - Method in class javax.swing.text. PlainView

可以访问可用于从相关文档中获取文本的缓冲区。

getLineBuffer() - Method in class javax.swing.text. WrappedPlainView

可以访问可用于从相关文档中获取文本的缓冲区。

getLineCap() - Method in class javafx.scene.canvas. GraphicsContext

获取当前行程线上限。

getLineCap() - Method in class javafx.scene.layout. BorderStrokeStyle

如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。

getLineClass() - Method in class javax.sound.sampled. Line.Info

获取此Line.Info对象描述的行的类。

getLineColor() - Method in class javax.swing.border. LineBorder

返回边框的颜色。

getLineCount() - Method in class javax.swing. JTextArea

确定该区域中包含的行数。

getLineDashes() - Method in class javafx.scene.canvas. GraphicsContext

获取当前线短线阵列的副本。

getLineDashOffset() - Method in class javafx.scene.canvas. GraphicsContext

获取当前行的虚线偏移量。

getLineEndOffset(int) - Method in class javax.swing. JTextArea

确定给定行末端的偏移量。

getLineHeight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的line-height属性定义。

getLineIncrement() - Method in class java.awt. Scrollbar

已过时。
截至JDK 1.1版，由getUnitIncrement()替代。

getLineInfo() - Method in interface javax.sound.sampled. Line

获取描述此行的 Line.Info对象。

getLineInstance() - Static method in class java.text. BreakIterator

为 default locale返回一个新的 BreakIterator实例 line breaks 。

getLineInstance(Locale) - Static method in class java.text. BreakIterator

为给定的地区返回一个新的 BreakIterator实例 line breaks 。

getLineInstance(Locale) - Method in class java.text.spi. BreakIteratorProvider

为给定的区域设置返回一个新的 BreakIterator实例 line breaks 。

getLineJoin() - Method in class java.awt. BasicStroke

返回行连接样式。

getLineJoin() - Method in class javafx.scene.canvas. GraphicsContext

获取当前笔划行连接。

getLineJoin() - Method in class javafx.scene.layout. BorderStrokeStyle

定义路径段相遇时应用的装饰。

getLineLength() - Method in class javax.swing.text. AbstractWriter

返回最大行长度。

getLineMap() - Method in interface com.sun.source.tree. CompilationUnitTree

返回此编译单元的行图（如果可用）。

getLineMap() - Method in interface jdk.nashorn.api.tree. CompilationUnitTree

返回此编译单元的行图（如果可用）。

getLineMetrics(char[], int, int, FontRenderContext) - Method in class java.awt. Font

返回使用指定参数创建的一个 LineMetrics对象。

getLineMetrics(char[], int, int, Graphics) - Method in class java.awt. FontMetrics

返回指定的Graphics上下文中指定字符数组的LineMetrics对象。

getLineMetrics(String, int, int, FontRenderContext) - Method in class java.awt. Font

返回使用指定参数创建的 LineMetrics对象。

getLineMetrics(String, int, int, Graphics) - Method in class java.awt. FontMetrics

返回指定的Graphics上下文中指定的String的LineMetrics对象。

getLineMetrics(String, FontRenderContext) - Method in class java.awt. Font

返回使用指定的String和FontRenderContext创建的LineMetrics对象。

getLineMetrics(String, Graphics) - Method in class java.awt. FontMetrics

返回指定的Graphics上下文中指定的String的LineMetrics对象。

getLineMetrics(CharacterIterator, int, int, FontRenderContext) - Method in class java.awt. Font

返回使用指定参数创建的 LineMetrics对象。

getLineMetrics(CharacterIterator, int, int, Graphics) - Method in class java.awt. FontMetrics

返回指定的Graphics上下文中指定的CharacterIterator的LineMetrics对象。

getLineNumber() - Method in class java.io. LineNumberInputStream

已过时。

返回当前行号。

getLineNumber() - Method in class java.io. LineNumberReader

获取当前行号。

getLineNumber() - Method in class java.lang. StackTraceElement

返回包含由该堆栈跟踪元素表示的执行点的源行的行号。

getLineNumber() - Method in interface java.lang. StackWalker.StackFrame

返回包含由该堆栈帧表示的执行点的源行的行号。

getLineNumber() - Method in exception javax.script. ScriptException

获取发生错误的行号。

getLineNumber() - Method in interface javax.tools. Diagnostic

返回由 Diagnostic.getPosition()返回的字符偏移量的行号。

getLineNumber() - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

getLineNumber() - Method in interface javax.xml.bind. ValidationEventLocator

返回行号（如果有）

getLineNumber() - Method in interface javax.xml.stream. Location

返回当前事件结束的行号，如果没有可用，返回-1。

getLineNumber() - Method in interface javax.xml.transform. SourceLocator

返回当前文档事件结束的行号。

getLineNumber() - Method in exception jdk.nashorn.api.scripting. NashornException

获取此 NashornException的行号

getLineNumber() - Method in interface jdk.nashorn.api.tree. Diagnostic

获取由 Diagnostic.getPosition()返回的字符偏移量的行号。

getLineNumber() - Method in interface org.w3c.dom. DOMLocator

该定位器指向的行号，如果没有列号可用， -1 。

getLineNumber() - Method in class org.xml.sax.helpers. LocatorImpl

返回保存的行号（基于1）。

getLineNumber() - Method in interface org.xml.sax. Locator

返回当前文档事件结束的行号。

getLineNumber() - Method in exception org.xml.sax. SAXParseException

出现异常的文本结尾的行号。

getLineNumber(long) - Method in interface com.sun.source.tree. LineMap

找到包含位置的行; 线终止字符在其终止的行上。

getLineNumber(long) - Method in interface jdk.nashorn.api.tree. LineMap

找到包含一个位置的行; 线终止字符在其终止的行上。

getLineOfOffset(int) - Method in class javax.swing. JTextArea

将偏移量转换为组件文本为行号。

getLineSeparator() - Method in class javax.swing.text. AbstractWriter

返回用于表示换行符的字符串。

getLineSpacing() - Method in class javafx.scene.control. Labeled

获取属性lineSpacing的值。

getLineSpacing() - Method in class javafx.scene.text. Text

获取属性lineSpacing的值。

getLineSpacing() - Method in class javafx.scene.text. TextFlow

获取属性lineSpacing的值。

getLineSpacing(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取行距设置。

getLineStartOffset(int) - Method in class javax.swing. JTextArea

确定给定行开始的偏移量。

getLineWidth() - Method in class java.awt. BasicStroke

返回行宽。

getLineWidth() - Method in class javafx.scene.canvas. GraphicsContext

获取当前行宽。

getLineWrap() - Method in class javax.swing. JTextArea

获取文本区域的换行政策。

getLink() - Method in interface org.w3c.dom.html. HTMLBodyElement

没有活动和未访问的链接的颜色。

getLink(int) - Method in interface javax.accessibility. AccessibleHypertext

返回此超文本文件的第n个链接。

getLink(int) - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport

将索引返回到索引的超链接数组中。

getLinkCount() - Method in interface javax.accessibility. AccessibleHypertext

返回此超文本文件中的链接数。

getLinkCount() - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport

返回此超文本文档中的链接数。

getLinkCursor() - Method in class javax.swing.text.html. HTMLEditorKit

返回光标以超链接使用。

getLinkedCallSiteLocation() - Static method in class jdk.dynalink. DynamicLinker

返回一个堆栈跟踪元素，描述当前线程当前链接的 invokedynamic调用站点的位置。

getLinkedException() - Method in class javax.xml.bind.helpers. ValidationEventImpl

getLinkedException() - Method in exception javax.xml.bind. JAXBException

获取链接的异常

getLinkedException() - Method in exception javax.xml.bind. TypeConstraintException

获取链接的异常

getLinkedException() - Method in interface javax.xml.bind. ValidationEvent

检索此警告/错误的链接异常。

getLinkerForClass(Class<?>) - Method in class jdk.dynalink.beans. BeansLinker

返回特定单个类的bean连接器。

getLinkerServices() - Method in class jdk.dynalink. DynamicLinker

返回表示通常暴露给个人language-specific linkers的此类的链接器服务的对象。

getLinkExplanation() - Method in exception javax.naming. LinkException

检索与解决链接时遇到的问题相关的说明。

getLinkIndex(int) - Method in interface javax.accessibility. AccessibleHypertext

将索引返回到与此字符索引相关联的超链接数组中，如果没有与此索引相关联的超链接，则返回-1。

getLinkIndex(int) - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport

将索引返回到与此字符索引相关联的超链接数组中，如果没有与此索引相关联的超链接，则返回-1。

getLinkLocation(File) - Method in class javax.swing.filechooser. FileSystemView

如果指定的文件是shell解释链接，则返回指定链接文件引用的常规文件。

getLinkName() - Method in class javax.naming. LinkRef

检索此链接的名称。

getLinkRemainingName() - Method in exception javax.naming. LinkException

检索链接名称中剩余的未解决部分。

getLinkResolvedName() - Method in exception javax.naming. LinkException

检索已成功解析的链接名称的前导部分。

getLinkResolvedObj() - Method in exception javax.naming. LinkException

检索分辨率成功的对象。

getLinks() - Method in interface org.w3c.dom.html. HTMLDocument

所有 AREA元素和锚（ A ）元素的集合，其中一个值为 href属性的文档。

getLinkText(int) - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport

返回与该超链接相关联的文档中的连续文本。

getList() - Method in class javafx.collections. ListChangeListener.Change

源列表的更改。

getList() - Method in class javax.swing.plaf.basic. BasicComboPopup

实现ComboPopup.getList（）。

getList() - Method in interface javax.swing.plaf.basic. ComboPopup

返回用于在组合框中绘制项目的列表。

getList() - Method in class javax.swing. SpinnerListModel

返回定义此模型序列的 List 。

getListCellRendererComponent(JList<?>, Object, int, boolean, boolean) - Method in class javax.swing. DefaultListCellRenderer

getListCellRendererComponent(JList<?>, Object, int, boolean, boolean) - Method in class javax.swing.plaf.basic. BasicComboBoxRenderer

getListCellRendererComponent(JList<?>, Object, int, boolean, boolean) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxRenderer

getListCellRendererComponent(JList<? extends E>, E, int, boolean, boolean) - Method in interface javax.swing. ListCellRenderer

返回已配置为显示指定值的组件。

getListDataListeners() - Method in class javax.swing. AbstractListModel

返回在这个 AbstractListModel上注册的所有列表数据监听器的数组。

getListener() - Method in class java.util. EventListenerProxy

返回与代理关联的侦听器。

getListener() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

getListener() - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

getListener() - Method in interface javax.xml.bind. Marshaller

返回Marshaller.Listener注册了这个Marshaller 。

getListener() - Method in interface javax.xml.bind. Unmarshaller

返回Unmarshaller.Listener注册该Unmarshaller 。

getListenerCount() - Method in class com.sun.java.accessibility.util. AccessibilityListenerList

返回此侦听器列表的侦听器总数。

getListenerCount() - Method in class javax.swing.event. EventListenerList

返回此侦听器列表的侦听器总数。

getListenerCount(Class<?>) - Method in class javax.swing.event. EventListenerList

返回此侦听器列表提供的类型的侦听器总数。

getListenerCount(Class<? extends EventListener>) - Method in class com.sun.java.accessibility.util. AccessibilityListenerList

返回此侦听器列表提供的类型的侦听器总数。

getListenerID() - Method in class javax.management.remote. TargetedNotification

通知所针对的侦听器的ID。

getListenerList() - Method in class com.sun.java.accessibility.util. AccessibilityListenerList

将事件侦听器列表作为侦听器类型，侦听器对的数组传回。

getListenerList() - Method in class javax.swing.event. EventListenerList

将事件侦听器列表作为ListenerType侦听器对的数组传回。

getListenerMethodDescriptors() - Method in class java.beans. EventSetDescriptor

获取目标监听器界面的 MethodDescriptor s。

getListenerMethodName() - Method in class java.beans. EventHandler

返回将触发操作的方法的名称。

getListenerMethods() - Method in class java.beans. EventSetDescriptor

获取目标侦听器接口的方法。

getListeners(Class<T>) - Method in class java.awt. Button

返回当前注册为 FooListener的所有对象的数组，这个 Button 。

getListeners(Class<T>) - Method in class java.awt. Checkbox

返回当前注册为 FooListener的所有对象的数组，这个 Checkbox 。

getListeners(Class<T>) - Method in class java.awt. CheckboxMenuItem

返回当前注册为 FooListener的所有对象的数组，这个 CheckboxMenuItem 。

getListeners(Class<T>) - Method in class java.awt. Choice

返回此 Choice当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class java.awt. Component

返回当前注册为 FooListener的所有对象的数组，这个 Component 。

getListeners(Class<T>) - Method in class java.awt. Container

返回当前注册为 FooListener的所有对象的数组，此 Container 。

getListeners(Class<T>) - Method in class java.awt.dnd. DragSource

获取当前注册为 FooListener的所有对象，这个 DragSource 。

getListeners(Class<T>) - Method in class java.awt. List

返回当前注册的所有对象的数组 FooListener在这个S List 。

getListeners(Class<T>) - Method in class java.awt. MenuItem

返回当前注册为 FooListener的所有对象的数组，此 MenuItem 。

getListeners(Class<T>) - Method in class java.awt. Scrollbar

返回当前注册为 FooListener的所有对象的数组 Scrollbar 。

getListeners(Class<T>) - Method in class java.awt. TextComponent

返回当前注册为 FooListener的所有对象的数组，这个 TextComponent 。

getListeners(Class<T>) - Method in class java.awt. TextField

返回当前注册为 FooListener的所有对象的数组，这个 TextField 。

getListeners(Class<T>) - Method in class java.awt. Window

返回当前注册为 FooListener的所有对象的数组，此 Window 。

getListeners(Class<T>) - Method in class javax.swing. AbstractListModel

返回此模型上当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing. AbstractSpinnerModel

返回添加到此模型的给定类型的所有侦听器的数组。

getListeners(Class<T>) - Method in class javax.swing. DefaultBoundedRangeModel

返回此模型当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing. DefaultButtonModel

返回当前注册为 FooListener s的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing. DefaultListSelectionModel

返回当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing. DefaultSingleSelectionModel

返回当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing.event. EventListenerList

返回给定类型的所有侦听器的数组。

getListeners(Class<T>) - Method in class javax.swing. JComponent

返回当前注册为 FooListener的所有对象的数组，这个 JComponent 。

getListeners(Class<T>) - Method in class javax.swing.table. AbstractTableModel

返回当前注册的所有对象的数组 FooListener在这个S AbstractTableModel 。

getListeners(Class<T>) - Method in class javax.swing.table. DefaultTableColumnModel

返回此模型上当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing.text. AbstractDocument

返回当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing.text. DefaultCaret

返回当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing.text. StyleContext.NamedStyle

返回添加到此模型的给定类型的所有侦听器的数组。

getListeners(Class<T>) - Method in class javax.swing. Timer

返回当前注册为 FooListener的所有对象的数组，该 Timer 。

getListeners(Class<T>) - Method in class javax.swing.tree. DefaultTreeModel

返回此模型上当前注册为 FooListener的所有对象的数组。

getListeners(Class<T>) - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回当前注册为 FooListener的所有对象的数组。

getListeners(EventListener, Class<T>) - Static method in class java.awt. AWTEventMulticaster

返回由指定的 java.util.EventListener链接的所有对象的数组 FooListener s。

getListenerType() - Method in class java.beans. EventSetDescriptor

获取目标接口的 Class对象。

getListPainter(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

获取列表格式化程序以用于给定的一组CSS属性。

getListSelectionListeners() - Method in class javax.swing. DefaultListSelectionModel

返回在这个 DefaultListSelectionModel上注册的所有列表选择监听器的数组。

getListSelectionListeners() - Method in class javax.swing. JList

通过 JList的方式返回所有 ListSelectionListener添加的 JList的 addListSelectionListener 。

getListStyle() - Method in interface org.w3c.dom.css. Counter

该属性用于列表的样式。

getListStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style属性定义。

getListStyleImage() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style-image属性定义。

getListStylePosition() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style-position属性定义。

getListStyleType() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style-type属性定义。

getListView() - Method in class javafx.scene.control. ListCell

获取属性listView的值。

getLlx() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性llx的值。

getLly() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性lly的值。

getLoadedClassCount() - Method in interface java.lang.management. ClassLoadingMXBean

返回当前在Java虚拟机中加载的类的数量。

getLoadedInstruments() - Method in interface javax.sound.midi. Synthesizer

获取当前加载到这个 Synthesizer的仪器的列表。

getLoadingImageIcon() - Method in class javax.swing.text.html. ImageView

在加载图像的过程中返回要使用的图标。

getLoadListener() - Method in class javafx.fxml. FXMLLoader

返回此加载器的负载侦听器。

getLoadsSynchronously() - Method in class javax.swing.text.html. ImageView

如果第一次要求图像应该加载，返回 true 。

getLoadWorker() - Method in class javafx.scene.web. WebEngine

返回可用于跟踪加载进度的Worker对象。

getLocalAddress() - Method in class com.sun.net.httpserver. HttpExchange

返回接收请求的本地地址

getLocalAddress() - Method in class java.net. DatagramSocket

获取套接字所绑定的本地地址。

getLocalAddress() - Method in class java.net. Socket

获取套接字所绑定的本地地址。

getLocalAddress() - Method in class java.nio.channels. AsynchronousServerSocketChannel

返回此通道的套接字所绑定的套接字地址。

getLocalAddress() - Method in class java.nio.channels. AsynchronousSocketChannel

返回此通道的套接字所绑定的套接字地址。

getLocalAddress() - Method in class java.nio.channels. DatagramChannel

返回此通道的套接字所绑定的套接字地址。

getLocalAddress() - Method in interface java.nio.channels. NetworkChannel

返回此通道的套接字所绑定的套接字地址。

getLocalAddress() - Method in class java.nio.channels. ServerSocketChannel

返回此通道的套接字所绑定的套接字地址。

getLocalAddress() - Method in class java.nio.channels. SocketChannel

返回此通道的套接字所绑定的套接字地址。

getLocalAddress() - Method in class javax.xml.ws.spi.http. HttpExchange

返回收到请求的未解决的本地地址。

getLocalBounds(Component) - Static method in class javax.swing. SwingUtilities

返回组件 aComponent的矩形（0,0，bounds.width，bounds.height）

getLocalCertificateChain() - Method in class java.net. SecureCacheResponse

返回在握手检索网络资源的原始连接期间发送到服务器的证书链。

getLocalCertificates() - Method in class javax.net.ssl. HandshakeCompletedEvent

返回在握手期间发送给对等体的证书。

getLocalCertificates() - Method in class javax.net.ssl. HttpsURLConnection

返回在握手期间发送到服务器的证书。

getLocalCertificates() - Method in interface javax.net.ssl. SSLSession

返回在握手期间发送给对等体的证书。

getLocale() - Method in class com.sun.java.accessibility.util. Translator

获取组件的 Locale 。

getLocale() - Method in class java.applet. Applet

已过时。

获取小程序的区域设置。

getLocale() - Method in class java.awt. Component.AccessibleAWTComponent

返回此对象的区域设置。

getLocale() - Method in class java.awt. Component

获取此组件的区域设置。

getLocale() - Method in class java.awt.im. InputContext

返回当前输入法或键盘布局的当前语言环境。

getLocale() - Method in interface java.awt.im.spi. InputMethod

返回当前的输入区域设置。

getLocale() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

获取组件的区域设置。

getLocale() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回此对象的区域设置。

getLocale() - Method in class java.awt. Window

获取与此窗口相关联的 Locale对象，如果已设置了区域设置。

getLocale() - Method in class java.beans.beancontext. BeanContextSupport

获取这个 BeanContext的区域设置。

getLocale() - Method in class java.text. MessageFormat

获取创建或比较子格式时使用的区域设置。

getLocale() - Method in class java.time.format. DateTimeFormatter

获取格式化期间要使用的区域设置。

getLocale() - Method in class java.util. ResourceBundle

返回此资源包的区域设置。

getLocale() - Method in class javafx.scene.media. Track

Locale指定Track内容被格式化的语言以及可能的国家。

getLocale() - Method in class javax.accessibility. AccessibleContext

获取组件的区域设置。

getLocale() - Method in interface javax.annotation.processing. ProcessingEnvironment

如果没有语言环境 null则返回当前语言环境或 null 。

getLocale() - Method in class javax.imageio. ImageReader

返回当前设置 Locale ，或 null ;如果没有设置。

getLocale() - Method in class javax.imageio. ImageWriteParam

如果仅支持默认值 Locale则返回当前设置的 Locale ，或 null 。

getLocale() - Method in class javax.imageio. ImageWriter

如果没有设置，则返回当前设置的 Locale ，或 null 。

getLocale() - Method in class javax.print.attribute. TextSyntax

返回此文本属性的文本字符串的自然语言（locale）。

getLocale() - Method in class javax.security.auth.callback. LanguageCallback

获取检索的 Locale 。

getLocale() - Method in class javax.swing. ImageIcon.AccessibleImageIcon

返回此对象的区域设置。

getLocale() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getLocale() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

获取组件的区域设置。

getLocale() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

获取组件的区域设置。

getLocale() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

获取组件的区域设置。

getLocale() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocalElements() - Method in interface com.sun.source.tree. Scope

返回此范围中直接包含的元素。

getLocalExportEntries() - Method in interface jdk.nashorn.api.tree. ModuleTree

返回本地导出条目的列表。

getLocalGraphicsEnvironment() - Static method in class java.awt. GraphicsEnvironment

返回本地 GraphicsEnvironment 。

getLocalHost() - Static method in class java.net. InetAddress

返回本地主机的地址。

getLocalizedCompressionTypeName() - Method in class javax.imageio. ImageWriteParam

返回当前压缩类型名称的本地化版本，使用 Locale通过返回 getLocale 。

getLocalizedDateTimePattern(FormatStyle, FormatStyle, Chronology, Locale) - Static method in class java.time.format. DateTimeFormatterBuilder

获取区域设置和时间顺序的日期和时间样式的格式模式。

getLocalizedInputStream(InputStream) - Method in class java.lang. Runtime

不推荐用于删除：此API元素将在以后的版本中被删除。
从JDK 1.1开始，将本地编码中的字节流转换为Unicode中的字符流的首选方式是通过InputStreamReader和BufferedReader类。 此方法在将来的Java SE版本中可能会被删除。

getLocalizedLogger(String, ResourceBundle, Module) - Method in class java.lang. System.LoggerFinder

返回一个本地化的实例Logger对于给定module 。

getLocalizedMessage() - Method in class java.lang. Throwable

创建此可抛出的本地化描述。

getLocalizedName() - Method in class java.util.logging. Level

返回当前默认语言环境的Level的本地化字符串名称。

getLocalizedOutputStream(OutputStream) - Method in class java.lang. Runtime

不推荐用于删除：此API元素将在以后的版本中被删除。
从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。

getLocalName() - Method in class javax.imageio.metadata. IIOMetadataNode

相当于 getNodeName 。

getLocalName() - Method in interface javax.xml.soap. Name

获取此 Name对象所代表的XML名称的本地名称部分。

getLocalName() - Method in class javax.xml.stream.util. StreamReaderDelegate

getLocalName() - Method in interface javax.xml.stream. XMLStreamReader

返回当前事件的（本地）名称。

getLocalName() - Method in interface jdk.nashorn.api.tree. ExportEntryTree

返回条目的本地名称。

getLocalName() - Method in interface jdk.nashorn.api.tree. ImportEntryTree

返回条目的本地名称。

getLocalName() - Method in interface org.w3c.dom. Node

返回此节点的限定名称的本地部分。

getLocalName(int) - Method in interface org.xml.sax. Attributes

通过索引查找属性的本地名称。

getLocalName(int) - Method in class org.xml.sax.helpers. AttributesImpl

返回属性的本地名称。

getLocalPart() - Method in class javax.xml.namespace. QName

获取这个 QName的本地部分。

getLocalPatternChars() - Method in class java.text. DateFormatSymbols

获取本地化的日期时间模式字符。

getLocalPort() - Method in class java.net. DatagramSocket

返回此套接字绑定到的本地主机上的端口号。

getLocalPort() - Method in class java.net. DatagramSocketImpl

获取本地端口。

getLocalPort() - Method in class java.net. ServerSocket

返回此套接字正在侦听的端口号。

getLocalPort() - Method in class java.net. Socket

返回此套接字绑定到的本地端口号。

getLocalPort() - Method in class java.net. SocketImpl

返回此套接字 localport字段的值。

getLocalPrincipal() - Method in class java.net. SecureCacheResponse

返回在检索网络资源的原始连接中握手期间发送到服务器的主体。

getLocalPrincipal() - Method in class javax.net.ssl. HandshakeCompletedEvent

返回在握手期间发送给对等体的主体。

getLocalPrincipal() - Method in class javax.net.ssl. HttpsURLConnection

返回在握手期间发送到服务器的主体。

getLocalPrincipal() - Method in interface javax.net.ssl. SSLSession

返回在握手期间发送给对等体的主体。

getLocalSocketAddress() - Method in class java.net. DatagramSocket

返回此套接字绑定到的端点的地址。

getLocalSocketAddress() - Method in class java.net. ServerSocket

返回此套接字绑定到的端点的地址。

getLocalSocketAddress() - Method in class java.net. Socket

返回此套接字绑定到的端点的地址。

getLocalSupportedSignatureAlgorithms() - Method in class javax.net.ssl. ExtendedSSLSession

获取本地方面愿意使用的支持的签名算法数组。

getLocalTime() - Method in class java.time.zone. ZoneOffsetTransitionRule

获取必须用 ZoneOffsetTransitionRule.isMidnightEndOfDay()进行检查的 当地时间 。

getLocalToParentTransform() - Method in class javafx.scene. Node

获取属性localToParentTransform的值。

getLocalToSceneTransform() - Method in class javafx.scene. Node

获取属性localToSceneTransform的值。

getLocation() - Method in class com.sun.java.accessibility.util. Translator

返回对象相对于父对象的位置。

getLocation() - Method in class java.awt. Component.AccessibleAWTComponent

以指定对象的左上角的点的形式获取对象相对于父对象的位置。

getLocation() - Method in class java.awt. Component

以指定组件左上角的点的形式获取此组件的位置。

getLocation() - Method in class java.awt.dnd. DragSourceEvent

此方法返回一个 Point表示在此事件发生时屏幕坐标中的光标位置，如果未为此事件指定光标位置，则 null 。

getLocation() - Method in class java.awt.dnd. DropTargetDragEvent

该方法返回一个 Point指示 Cursor所述内的当前位置 Component'坐标。

getLocation() - Method in class java.awt.dnd. DropTargetDropEvent

该方法返回一个 Point指示 Cursor “在当前位置 Component坐标”。

getLocation() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

以指定对象的左上角的点的形式获取对象相对于父对象的位置。

getLocation() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

以指定对象的左上角的点的形式获取对象相对于父对象的位置。

getLocation() - Method in class java.awt. Point

返回这一点的位置。

getLocation() - Method in class java.awt. PointerInfo

返回表示指针在屏幕上的坐标的 Point 。

getLocation() - Method in class java.awt. Rectangle

返回此 Rectangle的位置。

getLocation() - Method in exception java.net. HttpRetryException

如果由重定向导致错误，则返回“位置”头域的值。

getLocation() - Method in class java.rmi.activation. ActivationDesc

返回由此描述符指定的对象的代码位置。

getLocation() - Method in class java.rmi.activation. ActivationGroupDesc

返回组的代码位置。

getLocation() - Method in class java.security. CodeSource

返回与此CodeSource关联的位置。

getLocation() - Method in class javafx.application. Preloader.ErrorNotification

检索与此错误相关联的URL（如果有）。

getLocation() - Method in class javafx.fxml. FXMLLoader

返回用于解析相对路径属性值的位置。

getLocation() - Method in class javafx.scene.web. WebEngine

获取属性位置的值。

getLocation() - Method in interface javax.accessibility. AccessibleComponent

以指定对象的左上角的点的形式获取对象相对于父对象的位置。

getLocation() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getLocation() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

以指定对象的左上角的点的形式获取对象相对于父对象的位置。

getLocation() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

getLocation() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocation() - Method in interface javax.xml.stream.events. XMLEvent

返回此事件的位置。

getLocation() - Method in class javax.xml.stream.util. StreamReaderDelegate

getLocation() - Method in exception javax.xml.stream. XMLStreamException

获取异常的位置

getLocation() - Method in interface javax.xml.stream. XMLStreamReader

返回处理器的当前位置。

getLocation() - Method in interface org.w3c.dom. DOMError

错误的位置。

getLocation(Point) - Method in class java.awt. Component

将该组件的x，y原点存储到“返回值” rv并返回 rv 。

getLocation(Point) - Method in class javax.swing. JComponent

将该组件的x，y原点存储到“返回值” rv并返回 rv 。

getLocation(JavaFileManager.Location) - Method in interface javax.tools. StandardJavaFileManager

返回与给定位置相关联的搜索路径。

getLocationAsPaths(JavaFileManager.Location) - Method in interface javax.tools. StandardJavaFileManager

返回与给定位置相关联的搜索路径。

getLocationAsString() - Method in exception javax.xml.transform. TransformerException

以字符串形式获取位置信息。

getLocationForModule(JavaFileManager.Location, String) - Method in class javax.tools. ForwardingJavaFileManager

getLocationForModule(JavaFileManager.Location, String) - Method in interface javax.tools. JavaFileManager

在位置中获取命名模块的位置，该位置可以是面向模块的位置或输出位置。

getLocationForModule(JavaFileManager.Location, JavaFileObject) - Method in class javax.tools. ForwardingJavaFileManager

getLocationForModule(JavaFileManager.Location, JavaFileObject) - Method in interface javax.tools. JavaFileManager

获取包含要在一个位置找到的特定文件的模块的位置，该位置可以是面向模块的位置或输出位置。

getLocationInJTree() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

返回节点的相对位置

getLocationOffset(int, int) - Method in interface java.awt.im. InputMethodRequests

获取屏幕上指定的绝对x和y坐标的组合文本中的偏移量。

getLocationOffset(int, int) - Method in interface javafx.scene.input. InputMethodRequests

获取屏幕上指定的绝对x和y坐标的组合文本中的偏移量。

getLocationOnScreen() - Method in class com.sun.java.accessibility.util. Translator

返回对象在屏幕上的位置。

getLocationOnScreen() - Method in class java.awt. Component.AccessibleAWTComponent

返回对象在屏幕上的位置。

getLocationOnScreen() - Method in class java.awt. Component

以指定组件左上角的点的形式获取此组件的位置。

getLocationOnScreen() - Method in class java.awt.event. MouseEvent

返回事件的绝对x，y位置。

getLocationOnScreen() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

返回对象在屏幕上的位置。

getLocationOnScreen() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回对象在屏幕上的位置。

getLocationOnScreen() - Method in interface javax.accessibility. AccessibleComponent

返回对象在屏幕上的位置。

getLocationOnScreen() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getLocationOnScreen() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

返回对象在屏幕上的位置。

getLocationOnScreen() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

getLocationOnScreen() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocator() - Method in class javax.xml.bind.helpers. ValidationEventImpl

getLocator() - Method in interface javax.xml.bind. ValidationEvent

检索此警告/错误的定位器。

getLocator() - Method in exception javax.xml.transform. TransformerException

方法getLocator检索一个SourceLocator对象的实例，该实例指定发生错误的位置。

getLockedMonitors() - Method in class java.lang.management. ThreadInfo

返回一个MonitorInfo个对象的数组，每个对象代表当前由与此ThreadInfo相关联的线程锁定的对象监视器。

getLockedStackDepth() - Method in class java.lang.management. MonitorInfo

返回堆栈跟踪中对象监视器被锁定的深度。

getLockedStackFrame() - Method in class java.lang.management. MonitorInfo

返回锁定对象监视器的堆栈帧。

getLockedSynchronizers() - Method in class java.lang.management. ThreadInfo

返回的数组LockInfo对象，每个对象的表示ownable synchronizer当前由与此相关联的线程锁定ThreadInfo 。

getLockInfo() - Method in class java.lang.management. ThreadInfo

返回 LockInfo ，与此相关的线程的对象的 ThreadInfo被阻塞等待。

getLockingKeyState(int) - Method in class java.awt. Toolkit

返回键盘上给定的锁定键是否处于“开启”状态。

getLockName() - Method in class java.lang.management. ThreadInfo

返回一个对象的 string representation ，该对象与此 ThreadInfo关联的线程被阻止等待。

getLockOwnerId() - Method in class java.lang.management. ThreadInfo

返回拥有与此 ThreadInfo相关联的线程被阻止等待的对象的线程的ID。

getLockOwnerName() - Method in class java.lang.management. ThreadInfo

返回拥有与此 ThreadInfo相关联的线程被阻止等待的对象的线程的名称。

getLog() - Static method in class java.rmi.server. RemoteServer

返回RMI通话记录的流。

getLogger() - Static method in class javax.sql.rowset.spi. SyncFactory

返回应用程序的记录对象，以检索SyncProvider实现发布的同步事件。

getLogger(String) - Static method in class java.lang. System

返回一个Logger的调用者使用的实例。

getLogger(String) - Static method in class java.util.logging. Logger

查找或创建一个命名子系统的记录器。

getLogger(String) - Method in class java.util.logging. LogManager

找到一个命名记录器的方法。

getLogger(String, Module) - Method in class java.lang. System.LoggerFinder

为给定的module返回一个Logger的实例。

getLogger(String, String) - Static method in class java.util.logging. Logger

查找或创建一个命名子系统的记录器。

getLogger(String, ResourceBundle) - Static method in class java.lang. System

返回可调用者使用的本地化实例Logger 。

getLoggerFinder() - Static method in class java.lang. System.LoggerFinder

返回 LoggerFinder实例。

getLoggerLevel(String) - Method in interface java.lang.management. PlatformLoggingMXBean

获取与指定记录器关联的日志 level的名称。

getLoggerLevel(String) - Method in interface java.util.logging. LoggingMXBean

已过时。

获取与指定记录器关联的日志级别的名称。

getLoggerName() - Method in class java.util.logging. LogRecord

获取源记录器的名称。

getLoggerNames() - Method in interface java.lang.management. PlatformLoggingMXBean

返回当前注册的logger名称的列表。

getLoggerNames() - Method in interface java.util.logging. LoggingMXBean

已过时。

返回当前注册的记录器名称的列表。

getLoggerNames() - Method in class java.util.logging. LogManager

获取已知记录器名称的枚举。

getLoggingMXBean() - Static method in class java.util.logging. LogManager

已过时。
java.util.logging.LoggingMXBean已被弃用，替换为java.lang.management.PlatformLoggingMXBean 。 改用ManagementFactory.getPlatformMXBean （PlatformLoggingMXBean.class）。

getLogicalBounds() - Method in class java.awt.font. GlyphVector

返回此 GlyphVector的逻辑范围。

getLogicalHighlightShape(int, int) - Method in class java.awt.font. TextLayout

返回一个包含在指定范围内的逻辑选择的 Shape ，扩展到此 TextLayout 。

getLogicalHighlightShape(int, int, Rectangle2D) - Method in class java.awt.font. TextLayout

返回一个包含在指定范围内的逻辑选择的 Shape ，扩展到指定的 bounds 。

getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo) - Method in class java.awt.font. TextLayout

返回与视觉选择对应的文本的逻辑范围。

getLogicalStyle() - Method in class javax.swing. JTextPane

获取分配给由插入符号的当前位置表示的段落的逻辑样式，或 null 。

getLogicalStyle(int) - Method in class javax.swing.text. DefaultStyledDocument

获取分配给由给定位置表示的段落的逻辑风格。

getLogicalStyle(int) - Method in interface javax.swing.text. StyledDocument

获取段落中给定位置的逻辑风格。

getLogicalView(FlowView) - Method in class javax.swing.text. FlowView.FlowStrategy

此方法使流策略访问FlowView的逻辑视图。

getLoginModuleName() - Method in class javax.security.auth.login. AppConfigurationEntry

获取配置的类名称 LoginModule 。

getLoginTimeout() - Static method in class java.sql. DriverManager

获取尝试登录数据库时驱动程序可以等待的最长时间（秒）。

getLoginTimeout() - Method in interface javax.sql. CommonDataSource

获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。

getLoginTimeout() - Method in interface javax.sql. ConnectionPoolDataSource

获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。

getLoginTimeout() - Method in interface javax.sql. DataSource

获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。

getLoginTimeout() - Method in interface javax.sql. XADataSource

获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。

getLogManager() - Static method in class java.util.logging. LogManager

返回全局LogManager对象。

getLogStream() - Static method in class java.sql. DriverManager

已过时。
使用getLogWriter

getLogTimers() - Static method in class javax.swing. Timer

如果启用日志记录，则返回 true 。

getLogWriter() - Static method in class java.sql. DriverManager

检索日志记录器。

getLogWriter() - Method in interface javax.sql. CommonDataSource

检索此 DataSource对象的日志记录器。

getLogWriter() - Method in interface javax.sql. ConnectionPoolDataSource

检索此 DataSource对象的日志记录器。

getLogWriter() - Method in interface javax.sql. DataSource

检索此 DataSource对象的日志记录器。

getLogWriter() - Method in interface javax.sql. XADataSource

检索 DataSource对象的日志记录器。

getLong() - Method in class java.nio. ByteBuffer

读取长值的相对 get方法。

getLong(int) - Method in class java.nio. ByteBuffer

绝对 获取读取长值的方法。

getLong(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 long指定的JDBC BIGINT参数的值。

getLong(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 long此 ResultSet对象的当前行中指定列的值。

getLong(Object) - Method in class java.lang.reflect. Field

获取类型为 long的静态或实例字段的值，或通过加宽转换获得可转换为类型 long的另一个原始类型的值。

getLong(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中的索引组件的值，如 long 。

getLong(String) - Static method in class java.lang. Long

确定具有指定名称的系统属性的值为 long 。

getLong(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 long JDBC BIGINT参数的值。

getLong(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 long该 ResultSet对象的当前行中指定列的值。

getLong(String, long) - Static method in class java.lang. Long

确定具有指定名称的系统属性的值为 long 。

getLong(String, long) - Method in class java.util.prefs. AbstractPreferences

实现 getLong方法按照在本说明书中 Preferences.getLong(String,long) 。

getLong(String, long) - Method in class java.util.prefs. Preferences

返回由此首选项节点中与指定键相关联的字符串表示的长整型值。

getLong(String, Long) - Static method in class java.lang. Long

返回具有指定名称的系统属性的值为 long 。

getLong(TemporalField) - Method in interface java.time.chrono. ChronoZonedDateTime

getLong(TemporalField) - Method in interface java.time.chrono. Era

从该时代获取指定字段的值为 long 。

getLong(TemporalField) - Method in class java.time.chrono. HijrahDate

getLong(TemporalField) - Method in class java.time.chrono. JapaneseDate

getLong(TemporalField) - Method in class java.time.chrono. MinguoDate

getLong(TemporalField) - Method in class java.time.chrono. ThaiBuddhistDate

getLong(TemporalField) - Method in enum java.time. DayOfWeek

从这个星期几获取指定字段的值作为 long 。

getLong(TemporalField) - Method in class java.time. Instant

从该时刻获取指定字段的值作为 long 。

getLong(TemporalField) - Method in class java.time. LocalDate

从此日期获取指定字段的值为 long 。

getLong(TemporalField) - Method in class java.time. LocalDateTime

从此日期时间获取指定字段的值为 long 。

getLong(TemporalField) - Method in class java.time. LocalTime

从此时间获取指定字段的值为 long 。

getLong(TemporalField) - Method in enum java.time. Month

从这个月份获取指定字段的值作为 long 。

getLong(TemporalField) - Method in class java.time. MonthDay

从这个月份获取指定字段的值作为 long 。

getLong(TemporalField) - Method in class java.time. OffsetDateTime

从此日期时间获取指定字段的值作为 long 。

getLong(TemporalField) - Method in class java.time. OffsetTime

从此时间获取指定字段的值为 long 。

getLong(TemporalField) - Method in interface java.time.temporal. TemporalAccessor

获取指定字段的 long 。

getLong(TemporalField) - Method in class java.time. Year

从今年获取指定字段的值为 long 。

getLong(TemporalField) - Method in class java.time. YearMonth

从本年度获取指定字段的值为 long 。

getLong(TemporalField) - Method in class java.time. ZonedDateTime

从此日期时间获取指定字段的值作为 long 。

getLong(TemporalField) - Method in class java.time. ZoneOffset

从该偏移量获取指定字段的值作为 long 。

getLongDesc() - Method in interface org.w3c.dom.html. HTMLFrameElement

URI指定此图像或框架的长描述。

getLongDesc() - Method in interface org.w3c.dom.html. HTMLIFrameElement

URI指定此图像或框架的长描述。

getLongDesc() - Method in interface org.w3c.dom.html. HTMLImageElement

URI指定此图像或框架的长描述。

getLongFramePosition() - Method in interface javax.sound.sampled. DataLine

获取音频数据中的样本帧中的当前位置。

getLongParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

一个方便返回参数的方法。

getLookAndFeel() - Static method in class javax.swing. UIManager

返回目前的外观或 null 。

getLookAndFeelDefaults() - Static method in class javax.swing. UIManager

从当前的外观和感觉返回 UIDefaults ，这是在安装外观时获得的。

getLookup() - Method in class jdk.dynalink. SecureLookupSupplier

返回由此 SecureLookupSupplier保护的查找。

getLookupPrivileged() - Method in class jdk.dynalink. SecureLookupSupplier

返回 SecureLookupSupplier.getLookup()的值，无需安全检查。

getLoopbackAddress() - Static method in class java.net. InetAddress

返回回送地址。

getLoopbackMode() - Method in class java.net. MulticastSocket

获取组播数据报的本地环回设置。

getLoopCount() - Method in interface javax.sound.midi. Sequencer

获取播放次数。

getLoopEndPoint() - Method in interface javax.sound.midi. Sequencer

获得循环的最终位置，以MIDI刻度。

getLoopStartPoint() - Method in interface javax.sound.midi. Sequencer

获取循环的开始位置，以MIDI刻度。

getLowerBound() - Method in class javafx.scene.chart. ValueAxis

获取属性lowerBound的值。

getLowerBound() - Method in interface javax.lang.model.type. TypeVariable

返回此类型变量的下限。

getLowerBounds() - Method in interface java.lang.reflect. WildcardType

返回一个表示此类型变量下限的 Type对象的数组。

getLoweredBevelBorderUIResource() - Static method in class javax.swing.plaf. BorderUIResource

返回降低的斜角边界UI资源。

getLowestSetBit() - Method in class java.math. BigInteger

返回此BigInteger中最右（最低位）一位的索引（最右边一位右侧的零位数）。

getLowestValue() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回标签表中具有条目的最小值。

getLowestValueLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回与标签表中最高的滑块值对应的标签。

getLowSrc() - Method in interface org.w3c.dom.html. HTMLImageElement

URI指定此图像的来源，用于低分辨率输出。

getLowThreshold() - Method in class javax.management.monitor. GaugeMonitor

获得所有观察到的MBean共有的低阈值。

getLowThreshold() - Method in interface javax.management.monitor. GaugeMonitorMBean

获得低阈值。

getLrx() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性lrx的值。

getLry() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性lry的值。

getLSB() - Method in class java.awt.font. GlyphMetrics

返回字形的左（上）侧方向。

getLub(CatchTree) - Method in class com.sun.source.util. Trees

返回在catch子句中声明的异常参数的lub。

getM() - Method in class java.security.spec. ECFieldF2m

返回该特征2有限域的值 m 。

getMacLength() - Method in class javax.crypto. Mac

以字节为单位返回MAC的长度。

getMagicCaretPosition() - Method in interface javax.swing.text. Caret

获取当前的插入符号视觉位置。

getMagicCaretPosition() - Method in class javax.swing.text. DefaultCaret

获取保留的插入符位置。

getMainAttributes() - Method in class java.net. JarURLConnection

返回此连接的JAR文件的主要属性。

getMainAttributes() - Method in class java.util.jar. Manifest

返回清单的主要属性。

getMajor() - Method in exception org.ietf.jgss. GSSException

返回导致引发此异常的问题的GSS-API级别主要错误代码。

getMajorAxis() - Method in class javax.swing.text. AsyncBoxView

取长轴（孩子们平行的轴）。

getMajorOffset() - Method in class javax.swing.text. AsyncBoxView.ChildState

沿着主轴获得偏移。

getMajorSpan() - Method in class javax.swing.text. AsyncBoxView.ChildState

沿长轴的跨度是多少？

getMajorString() - Method in exception org.ietf.jgss. GSSException

返回一个解释GSS-API级别主要错误代码的字符串。

getMajorTickSpacing() - Method in class javax.swing. JSlider

此方法返回主要的tick间距。

getMajorTickUnit() - Method in class javafx.scene.control. Slider

获取属性majorTickUnit的值。

getMajorVersion() - Method in class java.awt.color. ICC_Profile

返回配置文件主版本。

getMajorVersion() - Method in interface java.sql. Driver

检索司机的主要版本号。

getManagedChildren() - Method in class javafx.scene. Parent

获取此 Parent的所有受管孩子的 Parent 。

getManagementSpecVersion() - Method in interface java.lang.management. RuntimeMXBean

返回由运行的Java虚拟机实现的管理接口的规范版本。

getManifest() - Method in class java.net. JarURLConnection

返回此连接的清单，否则返回null。

getManifest() - Method in class java.util.jar. JarFile

返回jar文件清单，如果没有，则返回 null 。

getManifest() - Method in class java.util.jar. JarInputStream

返回此JAR文件的 null如果没有，则返回 Manifest 。

getMap() - Method in class javafx.collections. MapChangeListener.Change

与变化相关联的可观察的地图。

getMapData() - Method in class javafx.scene.effect. DisplacementMap

获取属性mapData的值。

getMappedValue() - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView

返回添加的默认映射值，如果不支持添加，则返回 null 。

getMapSize() - Method in class java.awt.image. IndexColorModel

返回此 IndexColorModel颜色/ alpha组件数组的 IndexColorModel 。

getMargin() - Method in class javax.swing. AbstractButton

返回按钮边框和标签之间的边距。

getMargin() - Method in class javax.swing. JMenuBar

返回菜单边框和菜单之间的边距。

getMargin() - Method in class javax.swing. JPopupMenu

返回弹出菜单的边框和容器之间的边距（以像素为单位）。

getMargin() - Method in class javax.swing. JToolBar

返回工具栏边框与其按钮之间的边距。

getMargin() - Method in class javax.swing.text. JTextComponent

返回文本组件的边框和文本之间的边距。

getMargin() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin属性定义。

getMargin(Node) - Static method in class javafx.scene.layout. BorderPane

如果设置，返回小孩的边距约束。

getMargin(Node) - Static method in class javafx.scene.layout. FlowPane

如果设置，返回小孩的边距约束。

getMargin(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，返回小孩的边距约束。

getMargin(Node) - Static method in class javafx.scene.layout. HBox

如果设置，返回小孩的边距约束。

getMargin(Node) - Static method in class javafx.scene.layout. StackPane

如果设置，返回小孩的边距约束。

getMargin(Node) - Static method in class javafx.scene.layout. TilePane

如果设置，返回小孩的边距约束。

getMargin(Node) - Static method in class javafx.scene.layout. VBox

如果设置，返回小孩的边距属性。

getMarginBottom() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-bottom属性定义。

getMarginHeight() - Method in interface org.w3c.dom.html. HTMLFrameElement

帧边距高度，以像素为单位。

getMarginHeight() - Method in interface org.w3c.dom.html. HTMLIFrameElement

帧边距高度，以像素为单位。

getMarginLeft() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-left属性定义。

getMarginRight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-right属性定义。

getMarginTop() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-top属性定义。

getMarginWidth() - Method in interface org.w3c.dom.html. HTMLFrameElement

帧边距宽度，以像素为单位。

getMarginWidth() - Method in interface org.w3c.dom.html. HTMLIFrameElement

帧边距宽度，以像素为单位。

getMark() - Method in class javax.swing.event. CaretEvent

获取逻辑选择的另一端的位置。

getMark() - Method in interface javax.swing.text. Caret

获取标记的当前位置。

getMark() - Method in class javax.swing.text. DefaultCaret

获取标记的当前位置。

getMarkBias() - Method in class javax.swing.text. DefaultCaret

返回标记的偏差。

getMarker() - Method in class javafx.scene.media. MediaMarkerEvent

检索事件代表的标记。

getMarkerOffset() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的marker-offset属性定义。

getMarkers() - Method in class javafx.scene.media. Media

检索此 Media实例上定义的标记。

getMarks() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的标记属性定义。

getMask() - Method in class javax.swing.text. MaskFormatter

返回格式化掩码。

getMask(int) - Method in class java.awt.image. PackedColorModel

返回掩码，指示像素中的哪些位包含指定的颜色/ alpha样本。

getMaskForButton(int) - Static method in class java.awt.event. InputEvent

获取任何现有鼠标按钮的掩码的方法。

getMasks() - Method in class java.awt.image. PackedColorModel

返回一个掩码数组，指示像素中的哪些位包含颜色和alpha样本。

getMasterSyncMode() - Method in interface javax.sound.midi. Sequencer

获取此音序器的当前主同步模式。

getMasterSyncModes() - Method in interface javax.sound.midi. Sequencer

获取此序列器支持的一组主同步模式。

getMatchAllSubjectAltNames() - Method in class java.security.cert. X509CertSelector

指示 X509Certificate必须包含 setSubjectAlternativeNames或 addSubjectAlternativeName方法中指定的所有或至少一个 subjectAlternativeNames 。

getMatchColumnIndexes() - Method in interface javax.sql.rowset. Joinable

检索使用方法 setMatchColumn(int[] columnIdxes)为此 RowSet对象设置的匹配列的索引。

getMatchColumnNames() - Method in interface javax.sql.rowset. Joinable

使用方法 setMatchColumn(String [] columnNames)检索为此 RowSet对象设置的匹配列的名称。

getMatchingHeaders(String[]) - Method in class javax.xml.soap. MimeHeaders

返回名称与给定名称数组中的名称相匹配的所有 MimeHeader对象。

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap. AttachmentPart

检索与给定数组中的名称相匹配的所有 MimeHeader对象。

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap. SOAPPart

检索与给定数组中的名称相匹配的所有 MimeHeader对象。

getMatchingRuleID() - Method in class javax.naming.ldap. SortKey

检索用于对属性值进行排序的匹配规则ID。

getMaterial() - Method in class javafx.scene.shape. Shape3D

获取物业资料的价值。

getMatrix() - Method in class java.awt.color. ICC_ProfileRGB

返回一个3x3 float矩阵从X，Y构造和配置文件的Z分量 redColorantTag ， greenColorantTag ，并 blueColorantTag 。

getMatrix() - Method in class java.awt.image. BandCombineOp

返回线性组合矩阵的副本。

getMatrix() - Method in class java.awt.print. PageFormat

返回一个转换矩阵，将用户空间渲染转换为页面的请求方向。

getMatrix(double[]) - Method in class java.awt.geom. AffineTransform

检索3x3仿射变换矩阵中的6个可指定值，并将它们置于双重精度值的数组中。

getMatteColor() - Method in class javax.swing.border. MatteBorder

返回用于平铺边框的颜色，如果正在使用图块图标，则返回null。

getMax() - Method in class java.lang.management. MemoryUsage

返回可用于内存管理的最大内存量（以字节为单位）。

getMax() - Method in class java.util. DoubleSummaryStatistics

如果任何记录值为NaN，则返回最大记录值 Double.NaN如果没有记录值，则返回 Double.NEGATIVE_INFINITY 。

getMax() - Method in class java.util. IntSummaryStatistics

返回记录的最大值，如果没有记录任何值，则返回 Integer.MIN_VALUE 。

getMax() - Method in class java.util. LongSummaryStatistics

返回记录的最大值，如果没有记录值，则返回 Long.MIN_VALUE

getMax() - Method in class javafx.scene.control. ScrollBar

获取最大值的属性值。

getMax() - Method in class javafx.scene.control. Slider

获取最大值的属性值。

getMax() - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory

获取最大值的属性值。

getMax() - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

获取最大值的属性值。

getMaxAdvance() - Method in class java.awt. FontMetrics

获取此 Font中任何字符的最大前进宽度。

getMaxAge() - Method in class java.net. HttpCookie

返回cookie的最大使用年限，以秒为单位。

getMaxAllowedKeyLength(String) - Static method in class javax.crypto. Cipher

根据已安装的JCE管辖区策略文件，返回指定转换的最大密钥长度。

getMaxAllowedParameterSpec(String) - Static method in class javax.crypto. Cipher

返回一个AlgorithmParameterSpec对象，该对象包含根据管辖区策略文件的最大密码参数值。

getMaxAscent() - Method in class java.awt. FontMetrics

确定 FontMetrics对象描述的 Font的最大上限。

getMaxBinaryLiteralLength() - Method in interface java.sql. DatabaseMetaData

检索数据库允许的内联二进制文字的最大十六进制数。

getMaxBufferCapacity() - Method in class java.util.concurrent. SubmissionPublisher

返回最大每用户缓冲区容量。

getMaxBufferSize() - Method in class javax.sound.sampled. DataLine.Info

获取数据线支持的最大缓冲区大小。

getMaxCatalogNameLength() - Method in interface java.sql. DatabaseMetaData

检索此数据库在目录名称中允许的最大字符数。

getMaxChainLength() - Method in class jdk.dynalink.support. ChainedCallSite

链中方法句柄的最大数量。

getMaxCharactersPerLineCount() - Method in class javax.swing. JOptionPane

返回在消息中放置在行上的最大字符数。

getMaxCharactersPerLineCount() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回一行中放置的最大字符数。

getMaxCharBounds(FontRenderContext) - Method in class java.awt. Font

返回具有指定的 FontRenderContext定义的最大边界的字符的边界。

getMaxCharBounds(Graphics) - Method in class java.awt. FontMetrics

返回指定 Graphics上下文中具有最大边界的字符的边界。

getMaxCharLiteralLength() - Method in interface java.sql. DatabaseMetaData

检索此数据库允许使用字符文字的最大字符数。

getMaxColumnNameLength() - Method in interface java.sql. DatabaseMetaData

检索此数据库允许列名称的最大字符数。

getMaxColumnsInGroupBy() - Method in interface java.sql. DatabaseMetaData

检索 GROUP BY子句中数据库允许的最大列数。

getMaxColumnsInIndex() - Method in interface java.sql. DatabaseMetaData

检索数据库在索引中允许的最大列数。

getMaxColumnsInOrderBy() - Method in interface java.sql. DatabaseMetaData

检索 ORDER BY子句中数据库允许的最大列数。

getMaxColumnsInSelect() - Method in interface java.sql. DatabaseMetaData

SELECT列表中数据库允许的最大列数。

getMaxColumnsInTable() - Method in interface java.sql. DatabaseMetaData

检索数据库在表中允许的最大列数。

getMaxConnections() - Method in interface java.sql. DatabaseMetaData

检索可能的此数据库的最大并发连接数。

getMaxCopies() - Method in class javafx.print. PrinterAttributes

最多支持的份数。

getMaxCRL() - Method in class java.security.cert. X509CRLSelector

返回maxCRLNumber标准。

getMaxCursorNameLength() - Method in interface java.sql. DatabaseMetaData

检索该数据库在游标名称中允许的最大字符数。

getMaxDecent() - Method in class java.awt. FontMetrics

已过时。
截至JDK 1.1.1版，由getMaxDescent()替代。

getMaxDegree() - Method in class javax.management.relation. RoleInfo

返回相应角色引用的最大度。

getMaxDescent() - Method in class java.awt. FontMetrics

确定 FontMetrics对象描述的 Font的最大下降。

getMaxExpansion(int) - Method in class java.text. CollationElementIterator

返回以指定的比较顺序结束的任何扩展序列的最大长度。

getMaxFieldSize() - Method in interface java.sql. Statement

检索由 ResultSet对象生成的 Statement对象中的字符和二进制列值可以返回的最大字节数。

getMaxFieldSize() - Method in class javax.sql.rowset. BaseRowSet

检索此 RowSet对象中可用于列值的最大字节数。

getMaxFieldSize() - Method in interface javax.sql. RowSet

检索某些列值可能返回的最大字节数。

getMaxFileDescriptorCount() - Method in interface com.sun.management. UnixOperatingSystemMXBean

返回文件描述符的最大数量。

getMaxHeight() - Method in class javafx.scene.control. PopupControl

覆盖控制计算最大高度的属性。

getMaxHeight() - Method in class javafx.scene.layout. Region

获取属性maxHeight的值。

getMaxHeight() - Method in class javafx.scene.layout. RowConstraints

获取属性maxHeight的值。

getMaxHeight() - Method in class javafx.scene.web. WebView

获取属性maxHeight的值。

getMaxHeight() - Method in class javafx.stage. Stage

获取属性maxHeight的值。

getMaxHeight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的max-height属性定义。

getMaximizedBounds() - Method in class java.awt. Frame

获得此框架的最大化边界。

getMaximum() - Method in interface java.awt. Adjustable

获取可调整对象的最大值。

getMaximum() - Method in class java.awt. Scrollbar

获取此滚动条的最大值。

getMaximum() - Method in class java.awt. ScrollPaneAdjustable

getMaximum() - Method in class java.time.temporal. ValueRange

获取字段可以占用的最大值。

getMaximum() - Method in class javax.sound.sampled. FloatControl

获得允许的最大值。

getMaximum() - Method in interface javax.swing. BoundedRangeModel

返回模型的最大值。

getMaximum() - Method in class javax.swing. DefaultBoundedRangeModel

返回模型的最大值。

getMaximum() - Method in class javax.swing. JProgressBar

从 BoundedRangeModel返回进度条的 maximum值。

getMaximum() - Method in class javax.swing. JScrollBar

滚动条的最大值是最大值。

getMaximum() - Method in class javax.swing. JSlider

从 BoundedRangeModel返回滑块支持的 BoundedRangeModel 。

getMaximum() - Method in class javax.swing. ProgressMonitor

返回最大值 - 进度值的高端。

getMaximum() - Method in class javax.swing. SpinnerNumberModel

返回序列中的最后一个数字。

getMaximum() - Method in class javax.swing.text. InternationalFormatter

返回最大允许值。

getMaximum(int) - Method in class java.util. Calendar

返回此 Calendar实例的给定日历字段的 Calendar 。

getMaximum(int) - Method in class java.util. GregorianCalendar

返回此 GregorianCalendar实例的给定日历字段的 GregorianCalendar 。

getMaximumAccessibleValue() - Method in class java.awt. Button.AccessibleAWTButton

获取该对象的最大值作为数字。

getMaximumAccessibleValue() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

获取该对象的最大值作为数字。

getMaximumAccessibleValue() - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

获取该对象的最大值作为数字。

getMaximumAccessibleValue() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

获取该对象的最大值作为数字。

getMaximumAccessibleValue() - Method in class java.awt. Scrollbar.AccessibleAWTScrollBar

获取此对象的最大可访问值。

getMaximumAccessibleValue() - Method in interface javax.accessibility. AccessibleValue

获取此对象的最大值为 Number 。

getMaximumAccessibleValue() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

获取该对象的最大值作为数字。

getMaximumAccessibleValue() - Method in class javax.swing. JInternalFrame.AccessibleJInternalFrame

获取该对象的最大值作为数字。

getMaximumAccessibleValue() - Method in class javax.swing. JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

获取此对象的最大值为 Number 。

getMaximumAccessibleValue() - Method in class javax.swing. JProgressBar.AccessibleJProgressBar

获取此对象的最大可访问值。

getMaximumAccessibleValue() - Method in class javax.swing. JScrollBar.AccessibleJScrollBar

获取此对象的最大可访问值。

getMaximumAccessibleValue() - Method in class javax.swing. JSlider.AccessibleJSlider

获取此对象的最大可访问值。

getMaximumAccessibleValue() - Method in class javax.swing. JSpinner.AccessibleJSpinner

获取该对象的最大值作为数字。

getMaximumAccessibleValue() - Method in class javax.swing. JSplitPane.AccessibleJSplitPane

获取此对象的最大可访问值。

getMaximumCharHeight(SynthContext) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils

返回在SynthContext中传递的Font的最大高度。

getMaximumColors() - Static method in class javafx.scene. ImageCursor

返回自定义图像光标调色板中支持的最大颜色数。

getMaximumCumulativePeriod() - Method in class javafx.concurrent. ScheduledService

获取属性maximumCumulativePeriod的值。

getMaximumCursorColors() - Method in class java.awt. Toolkit

返回Toolkit在自定义光标调色板中支持的最大颜色数。

getMaximumDividerLocation() - Method in class javax.swing. JSplitPane

从外观实现中返回分隔符的最大位置。

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

获得分隔线的最大位置。

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getMaximumDividerLocation方法。

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf. SplitPaneUI

返回分隔符的最大可能位置。

getMaximumFailureCount() - Method in class javafx.concurrent. ScheduledService

获取属性maximumFailureCount的值。

getMaximumFractionDigits() - Method in class java.text. DecimalFormat

获取数字小数部分中允许的最大位数。

getMaximumFractionDigits() - Method in class java.text. NumberFormat

返回数字小数部分允许的最大位数。

getMaximumIntegerDigits() - Method in class java.text. DecimalFormat

获取数字的整数部分允许的最大位数。

getMaximumIntegerDigits() - Method in class java.text. NumberFormat

返回数字整数部分允许的最大位数。

getMaximumPacketSize() - Method in class javax.net.ssl. SSLParameters

返回SSL / TLS / DTLS记录的最大预期网络数据包大小（以字节为单位）。

getMaximumPoolSize() - Method in class java.util.concurrent. ThreadPoolExecutor

返回允许的最大线程数。

getMaximumRowCount() - Method in class javax.swing. JComboBox

返回在没有滚动条的情况下组合框可以显示的最大项数

getMaximumSize() - Method in class java.awt. Component

获取此组件的最大大小。

getMaximumSize() - Method in class java.awt. Container

返回此容器的最大大小。

getMaximumSize() - Method in class javax.swing. JComponent

如果最大尺寸设置为非 null值，则返回。

getMaximumSize() - Method in class javax.swing. JScrollBar

滚动条沿其滚动轴线是柔性的，并且沿着另一个轴线是刚性的。

getMaximumSize() - Method in class javax.swing. JToolBar.Separator

返回分隔符的最大大小。

getMaximumSize() - Method in class javax.swing.plaf.basic. BasicArrowButton

返回 BasicArrowButton的最大大小。

getMaximumSize() - Method in class javax.swing.plaf.metal. MetalScrollButton

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

桌面图标无法调整大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回最大大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicLabelUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSeparatorUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最大大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回传入的组件的最大大小，这被传递给当前的布局管理器。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

返回标题的最大大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTableUI

返回表的最大大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTextUI

获取编辑器组件的最大大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回此组件的最大大小，如果实例当前处于JTree或0,0，则该大小将是首选大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf. ComponentUI

返回指定组件的最大尺寸，适合外观和感觉。

getMaximumSize(JComponent) - Method in class javax.swing.plaf. LayerUI

如果 JLayer的视图组件不是 null ，则返回视图 getMaximumSize()方法的结果。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.metal. MetalDesktopIconUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

返回 JFileChooser的最大大小。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI

在此对象处理的每个UI上调用 getMaximumSize方法。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回指定组件的最大尺寸，适合外观和感觉。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth. SynthLabelUI

返回指定组件的最大尺寸，适合外观和感觉。

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI

返回指定组件的最大尺寸，适合外观和感觉。

getMaximumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils

返回正确呈现图标和文本所需的最大大小。

getMaximumSpan(int) - Method in class javax.swing.text. AsyncBoxView

确定沿着轴的该视图的最大跨度。

getMaximumSpan(int) - Method in class javax.swing.text. BoxView

确定沿着轴的该视图的最大跨度。

getMaximumSpan(int) - Method in class javax.swing.text. ComponentView

确定沿着轴的该视图的最大跨度。

getMaximumSpan(int) - Method in class javax.swing.text.html. BlockView

确定沿着轴的该视图的最大跨度。

getMaximumSpan(int) - Method in class javax.swing.text.html. FormView

确定沿着轴的该视图的最大跨度。

getMaximumSpan(int) - Method in class javax.swing.text.html. ParagraphView

确定沿着轴的该视图的最大跨度。

getMaximumSpan(int) - Method in class javax.swing.text. TableView.TableRow

getMaximumSpan(int) - Method in class javax.swing.text. View

确定沿着轴的该视图的最大跨度。

getMaximumSpan(int) - Method in class javax.swing.text. WrappedPlainView

确定沿着轴的该视图的最大跨度。

getMaximumStreamFormatVersion() - Method in interface javax.rmi.CORBA. ValueHandlerMultiFormat

返回此ValueHandler对象支持的RMI / IDL自定义值类型的最大流格式版本。

getMaximumThumbSize() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

返回拇指的最大可接受尺寸。

getMaximumValue() - Method in class javax.swing. Spring

返回此 Spring的 最大值 。

getMaximumWindowBounds() - Method in class java.awt. GraphicsEnvironment

返回居中Windows的最大边界。

getMaximumZoneSize() - Method in class javax.swing.text. ZoneView

获取当前的最大区域大小。

getMaxIndexLength() - Method in interface java.sql. DatabaseMetaData

检索数据库允许索引的最大字节数，包括索引的所有部分。

getMaxLabel() - Method in class javax.sound.sampled. FloatControl

获取最大值的标签，例如“Right”或“Full”。

getMaxLength() - Method in interface javax.jnlp. FileContents

获取文件的最大文件长度，由此对象的创建者设置。

getMaxLength() - Method in interface org.w3c.dom.html. HTMLInputElement

文本字段的最大字符数，当 type具有值“文本”或“密码”时。

getMaxLines(Line.Info) - Method in interface javax.sound.sampled. Mixer

获得可以在混音器上同时打开的所请求类型的最大行数。

getMaxLogicalLobSize() - Method in interface java.sql. DatabaseMetaData

检索数据库允许 LOB的逻辑大小的最大字节数。

getMaxPage() - Method in class java.awt. JobAttributes

指定用户可以指定的最大值作为使用这些属性的作业打印的最后一页。

getMaxPageIndicatorCount() - Method in class javafx.scene.control. Pagination

返回页面指示符的最大数量。

getMaxPathLength() - Method in class java.security.cert. PKIXBuilderParameters

返回证书路径中可能存在的中间非自颁发证书的最大数量的值。

getMaxPolyphony() - Method in interface javax.sound.midi. Synthesizer

获取此合成器可以同时发声的最大音符数。

getMaxPriority() - Method in class java.lang. ThreadGroup

返回此线程组的最大优先级。

getMaxProcedureNameLength() - Method in interface java.sql. DatabaseMetaData

检索此数据库在过程名称中允许的最大字符数。

getMaxReceivers() - Method in interface javax.sound.midi. MidiDevice

获取此MIDI设备上可用于接收MIDI数据的MIDI IN连接的最大数量。

getMaxRows() - Method in interface java.sql. Statement

检索一个的最大行数 ResultSet由此产生对象 Statement对象可以包含。

getMaxRows() - Method in class javax.sql.rowset. BaseRowSet

检索此 RowSet对象可能包含的最大行数。

getMaxRows() - Method in interface javax.sql. RowSet

检索此 RowSet对象可以包含的最大行数。

getMaxRowSize() - Method in interface java.sql. DatabaseMetaData

检索数据库在单行中允许的最大字节数。

getMaxSchemaNameLength() - Method in interface java.sql. DatabaseMetaData

检索此数据库在模式名称中允许的最大字符数。

getMaxSelectionIndex() - Method in class javax.swing. DefaultListSelectionModel

返回上一个选定的索引，如果选择为空，则返回-1。

getMaxSelectionIndex() - Method in class javax.swing. JList

返回最大的所选单元 -1引，如果选择为空，则返回 -1 。

getMaxSelectionIndex() - Method in interface javax.swing. ListSelectionModel

返回上一个选定的索引，如果选择为空，则返回-1。

getMaxSelectionRow() - Method in class javax.swing. JTree

返回最大的选定行。

getMaxSelectionRow() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回从当前所选TreePath集合的RowMapper获取的最大值。

getMaxSelectionRow() - Method in interface javax.swing.tree. TreeSelectionModel

返回从当前所选TreePath集合的RowMapper获取的最大值。

getMaxSize() - Method in class javafx.scene.web. WebHistory

获取属性maxSize的值。

getMaxSortKeys() - Method in class javax.swing. DefaultRowSorter

返回最大排序键数。

getMaxStatementLength() - Method in interface java.sql. DatabaseMetaData

检索数据库在SQL语句中允许的最大字符数。

getMaxStatements() - Method in interface java.sql. DatabaseMetaData

检索可以同时打开的此数据库的活动语句的最大数量。

getMaxTableNameLength() - Method in interface java.sql. DatabaseMetaData

检索数据库在表名中允许的最大字符数。

getMaxTablesInSelect() - Method in interface java.sql. DatabaseMetaData

在 SELECT语句中检索此数据库允许的最大表数。

getMaxTransmitters() - Method in interface javax.sound.midi. MidiDevice

获取此MIDI设备上可用于发送MIDI数据的MIDI OUT连接的最大数量。

getMaxUserNameLength() - Method in interface java.sql. DatabaseMetaData

检索数据库在用户名中允许的最大字符数。

getMaxValue() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport

返回此 OpenMBeanAttributeInfoSupport实例描述的属性的最大值（如果指定），否则 null 。

getMaxValue() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回此参数的最大值，如果它有一个，否则 null 。

getMaxValue() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport

返回此 OpenMBeanParameterInfoSupport实例描述的参数的最大值（如果指定），否则 null 。

getMaxValue(int) - Method in class java.awt.color. ColorSpace

返回指定组件的最大标准化颜色分量值。

getMaxValue(int) - Method in class java.awt.color. ICC_ColorSpace

返回指定组件的最大标准化颜色分量值。

getMaxWidth() - Method in class javafx.scene.control. PopupControl

覆盖控件计算出的最大宽度的属性。

getMaxWidth() - Method in class javafx.scene.control. TableColumnBase

获取属性maxWidth的值。

getMaxWidth() - Method in class javafx.scene.layout. ColumnConstraints

获取属性maxWidth的值。

getMaxWidth() - Method in class javafx.scene.layout. Region

获取属性maxWidth的值。

getMaxWidth() - Method in class javafx.scene.web. WebView

获取属性maxWidth的值。

getMaxWidth() - Method in class javafx.stage. Stage

获取属性maxWidth的值。

getMaxWidth() - Method in class javax.swing.table. TableColumn

返回 TableColumn的最大宽度。

getMaxWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的max-width属性定义。

getMaxX() - Method in class java.awt.geom. RectangularShape

返回 double精度的 Shape框架矩形的最大X坐标。

getMaxX() - Method in class javafx.geometry. Bounds

这个 Bounds右下角的x坐标。

getMaxX() - Method in class javafx.geometry. Rectangle2D

这个 Rectangle2D右下角的x坐标。

getMaxY() - Method in class java.awt.geom. RectangularShape

返回 Shape中 double的框架矩形的最大Y坐标。

getMaxY() - Method in class javafx.geometry. Bounds

这个 Bounds右下角的y坐标。

getMaxY() - Method in class javafx.geometry. Rectangle2D

这个 Rectangle2D右下角的y坐标。

getMaxZ() - Method in class javafx.geometry. Bounds

该最大z坐标为 Bounds 。

getMaxZonesLoaded() - Method in class javax.swing.text. ZoneView

获取允许同时加载的区域数的当前设置。

getMBeanCount() - Method in interface javax.management. MBeanServer

返回在MBean服务器中注册的MBeans数。

getMBeanCount() - Method in interface javax.management. MBeanServerConnection

返回在MBean服务器中注册的MBeans数。

getMBeanCount(Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.getMBeanCount() 。

getMBeanCount(Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getMBeanCount(Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

getMBeanDescriptor() - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回包含MBean宽策略的ModelMBean描述符。

getMBeanDescriptor() - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

getMBeanInfo() - Method in interface javax.management. DynamicMBean

使用MBeanInfo对象提供动态MBean的公开属性和动作。

getMBeanInfo() - Method in class javax.management.modelmbean. RequiredModelMBean

返回此RequiredModelMBean所管理的属性，操作，构造函数和通知。

getMBeanInfo() - Method in class javax.management. StandardMBean

获取这个MBean的MBeanInfo 。

getMBeanInfo(ObjectName) - Method in interface javax.management. MBeanServer

getMBeanInfo(ObjectName) - Method in interface javax.management. MBeanServerConnection

此方法可以发现MBean公开管理的属性和操作。

getMBeanInfo(ObjectName, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.getMBeanInfo(ObjectName) 。

getMBeanInfo(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getMBeanInfo(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

getMBeanInterface() - Method in class javax.management. StandardMBean

获取此标准MBean（或MXBean）的管理界面。

getMBeanName() - Method in class javax.management. MBeanServerNotification

返回导致通知的MBean的对象名称。

getMBeanServer() - Static method in class javax.management. QueryEval

通过此线程返回最近给予 setMBeanServer方法的MBean服务器。

getMBeanServer() - Method in class javax.management.remote. JMXConnectorServer

返回此连接器服务器连接到的MBean服务器。

getMBeanServer() - Method in interface javax.management.remote. MBeanServerForwarder

返回要转发到的MBeanServer对象。

getMBeanServer() - Method in class javax.management.remote.rmi. RMIServerImpl

连接此连接器服务器的 MBeanServer 。

getMBeanServerConnection() - Method in interface com.sun.tools.jconsole. JConsoleContext

返回与应用程序的连接的MBeanServerConnection 。

getMBeanServerConnection() - Method in class javax.management. MBeanServerInvocationHandler

使用此处理程序的代理方法转发的MBean服务器连接。

getMBeanServerConnection() - Method in interface javax.management.remote. JMXConnector

返回表示远程MBean服务器的 MBeanServerConnection对象。

getMBeanServerConnection() - Method in class javax.management.remote.rmi. RMIConnector

getMBeanServerConnection(Subject) - Method in interface javax.management.remote. JMXConnector

返回一个表示远程MBean服务器的 MBeanServerConnection对象，代表所提供的委托主体执行操作。

getMBeanServerConnection(Subject) - Method in class javax.management.remote.rmi. RMIConnector

getMBeanServerId() - Method in class javax.management. MBeanServerDelegate

返回MBean服务器代理身份。

getMBeanServerId() - Method in interface javax.management. MBeanServerDelegateMBean

返回MBean服务器代理身份。

getMBeansFromURL(String) - Method in class javax.management.loading. MLet

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

getMBeansFromURL(String) - Method in interface javax.management.loading. MLetMBean

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

getMBeansFromURL(URL) - Method in class javax.management.loading. MLet

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

getMBeansFromURL(URL) - Method in interface javax.management.loading. MLetMBean

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

getMBeansToUnregister() - Method in class javax.management.relation. RelationNotification

返回由于删除关系而导致的预期未注册的MBean的ObjectName的列表（仅用于删除关系）。

getMech() - Method in interface org.ietf.jgss. GSSContext

确定在这个上下文中使用什么机制。

getMechanismName() - Method in interface javax.security.sasl. SaslClient

返回此SASL客户端的IANA注册机制名称。

getMechanismName() - Method in interface javax.security.sasl. SaslServer

返回该SASL服务器的IANA注册的机制名称。

getMechanismNames(Map<String, ?>) - Method in interface javax.security.sasl. SaslClientFactory

返回与指定的机制选择策略匹配的机制名称数组。

getMechanismNames(Map<String, ?>) - Method in interface javax.security.sasl. SaslServerFactory

返回与指定的机制选择策略匹配的机制名称数组。

getMechanismType() - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

返回此 KeyInfoFactory支持的XML处理机制和表示 KeyInfoFactory （例如：“DOM”）

getMechanismType() - Method in class javax.xml.crypto.dsig. TransformService

返回此 TransformService支持的机制类型。

getMechanismType() - Method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回此 XMLSignatureFactory （例如：“DOM”）支持的XML处理机制和表示形式。

getMechs() - Method in interface org.ietf.jgss. GSSCredential

返回此凭据支持的机制列表。

getMechs() - Method in class org.ietf.jgss. GSSManager

返回GSS-API调用者通过此GSSManager可用的机制列表。

getMechsForName(Oid) - Method in class org.ietf.jgss. GSSManager

返回支持指定名称类型的机制列表。

getMedia() - Method in class java.awt. PageAttributes

返回使用这些属性的页面的纸张大小。

getMedia() - Method in class javafx.scene.media. MediaPlayer

检索正在播放的Media实例。

getMedia() - Method in interface org.w3c.dom.css. CSSImportRule

可以使用此样式表的媒体类型列表。

getMedia() - Method in interface org.w3c.dom.css. CSSMediaRule

此规则的媒体类型列表。

getMedia() - Method in interface org.w3c.dom.html. HTMLLinkElement

设计用于一个或多个目标介质。

getMedia() - Method in interface org.w3c.dom.html. HTMLStyleElement

设计用于一个或多个目标介质。

getMedia() - Method in interface org.w3c.dom.stylesheets. StyleSheet

用于样式信息的目标介质。

getMediaError() - Method in class javafx.scene.media. MediaErrorEvent

检索与此事件相关联的错误。

getMediaPlayer() - Method in class javafx.scene.media. MediaView

检索其视图中正在处理的输出的 MediaPlayer 。

getMediaSizeForName(MediaSizeName) - Static method in class javax.print.attribute.standard. MediaSize

获取指定的指定介质的MediaSize。

getMediaSizeName() - Method in class javax.print.attribute.standard. MediaSize

获取此尺寸的媒体名称（如果有）。

getMediaSubtype() - Method in class javax.print. DocFlavor

返回此文档flavor对象的媒体子类型（从MIME类型）。

getMediaText() - Method in interface org.w3c.dom.stylesheets. MediaList

媒体列表的可解析文本表示。

getMediaType() - Method in class javax.print. DocFlavor

返回此文档flavor对象的媒体类型（从MIME类型）。

getMediaWhitePoint() - Method in class java.awt.color. ICC_ProfileGray

返回一个长度为3的浮点数组，其中包含ICC配置文件中mediaWhitePointTag的X，Y和Z组件。

getMediaWhitePoint() - Method in class java.awt.color. ICC_ProfileRGB

返回一个数组，其中包含配置文件的组件 mediaWhitePointTag 。

getMember(String) - Method in class jdk.nashorn.api.scripting. AbstractJSObject

getMember(String) - Method in interface jdk.nashorn.api.scripting. JSObject

检索此JavaScript对象的命名成员。

getMember(String) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

getMember(String) - Method in class netscape.javascript. JSObject

检索JavaScript对象的命名成员。

getMemberControls() - Method in class javax.sound.sampled. CompoundControl

返回构成复合控件的成员控件集。

getMembers() - Method in interface com.sun.source.tree. ClassTree

返回在此类型声明中声明的成员。

getMembers() - Method in class javax.print.attribute. SetOfIntegerSyntax

以规范数组形式获取此set-of-integer属性的成员。

getMemoryManagerMXBeans() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机中的MemoryManagerMXBean个对象的列表。

getMemoryManagerNames() - Method in interface java.lang.management. MemoryPoolMXBean

返回管理此内存池的内存管理器的名称。

getMemoryMXBean() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机的内存系统的托管bean。

getMemoryPoolMXBeans() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机中的MemoryPoolMXBean对象的列表。

getMemoryPoolNames() - Method in interface java.lang.management. MemoryManagerMXBean

返回此内存管理器管理的内存池的名称。

getMemoryUsageAfterGc() - Method in class com.sun.management. GcInfo

返回此GC结尾处的所有内存池的内存使用情况。

getMemoryUsageBeforeGc() - Method in class com.sun.management. GcInfo

返回此GC开头的所有内存池的内存使用情况。

getMemoryUsed() - Method in interface java.lang.management. BufferPoolMXBean

返回Java虚拟机正在为此缓冲池使用的内存估计值。

getMenu() - Method in class java.awt. Taskbar

获取用于在系统任务区域中将项目添加到此应用程序图标的PopupMenu。

getMenu(int) - Method in class java.awt. MenuBar

获取指定的菜单。

getMenu(int) - Method in class javax.swing. JMenuBar

返回菜单栏中指定位置的菜单。

getMenuArrowIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回菜单箭头图标。

getMenuArrowIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 JMenu要使用的 JMenu 。

getMenuBackground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的菜单背景颜色。

getMenuBackground() - Method in class javax.swing.plaf.metal. MetalTheme

返回菜单背景颜色。

getMenuBar() - Method in class java.awt. Frame

获取此框架的菜单栏。

getMenuBar() - Method in class javax.swing. JInternalFrame

已过时。
截至Swing 1.0.3版本，由getJMenuBar()替代。

getMenuBar() - Method in class javax.swing. JRootPane

已过时。
从Swing版本1.0.3替换为getJMenuBar() 。

getMenuBarBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JMenuBar的边框实例。

getMenuComponent(int) - Method in class javax.swing. JMenu

返回位置 n的组件。

getMenuComponentCount() - Method in class javax.swing. JMenu

返回菜单上的组件数。

getMenuComponents() - Method in class javax.swing. JMenu

返回菜单的子组件 Component的数组。

getMenuCount() - Method in class java.awt. MenuBar

获取菜单栏上的菜单数量。

getMenuCount() - Method in class javax.swing. JMenuBar

返回菜单栏中的项目数。

getMenuDisabledForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回菜单禁用的当前主题的前景色。

getMenuDisabledForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回菜单禁用的前景色。

getMenuDisabledForeground() - Method in class javax.swing.plaf.metal. OceanTheme

返回菜单禁用的前景色。

getMenuDragMouseListeners() - Method in class javax.swing. JMenuItem

返回使用addMenuDragMouseListener（）添加到此JMenuItem中的所有 MenuDragMouseListener的数组。

getMenuForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的菜单前景色。

getMenuForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回菜单前景色。

getMenuItemArrowIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回菜单项箭头图标。

getMenuItemArrowIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 JMenuItem要使用的 JMenuItem 。

getMenuItemCheckIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回菜单项检查图标。

getMenuItemCheckIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 JCheckBoxMenuItem要使用的 JCheckBoxMenuItem 。

getMenuKeyListeners() - Method in class javax.swing. JMenuItem

返回使用addMenuKeyListener（）添加到此JMenuItem的所有 MenuKeyListener的数组。

getMenuKeyListeners() - Method in class javax.swing. JPopupMenu

返回使用addMenuKeyListener（）添加到此JPopupMenu的所有 MenuKeyListener的数组。

getMenuListeners() - Method in class javax.swing. JMenu

返回使用addMenuListener（）添加到此JMenu的所有 MenuListener的数组。

getMenuPosition() - Method in class javafx.scene.control.skin. TextAreaSkin

根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。

getMenuPosition() - Method in class javafx.scene.control.skin. TextFieldSkin

根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。

getMenuPosition() - Method in class javafx.scene.control.skin. TextInputControlSkin

根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。

getMenus() - Method in class javafx.scene.control. MenuBar

在MenuBar中显示的菜单。

getMenuSelectedBackground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的菜单选择的背景颜色。

getMenuSelectedBackground() - Method in class javax.swing.plaf.metal. MetalTheme

返回菜单选择的背景颜色。

getMenuSelectedForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回菜单选择当前主题的前景色。

getMenuSelectedForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回菜单选择的前景色。

getMenuSelectionManager() - Method in class javax.swing.event. MenuDragMouseEvent

返回当前菜单选择管理器。

getMenuSelectionManager() - Method in class javax.swing.event. MenuKeyEvent

返回当前菜单选择管理器。

getMenuShortcutKeyMask() - Method in class java.awt. Toolkit

确定哪个修饰键是菜单快捷键的适当加速键。

getMenuTextFont() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回菜单文本字体。

getMenuTextFont() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的菜单文本字体。

getMenuTextFont() - Method in class javax.swing.plaf.metal. MetalTheme

返回菜单文本字体。

getMesh() - Method in class javafx.scene.shape. MeshView

获取属性网格的值。

getMessage() - Method in exception java.awt. HeadlessException

返回此 HeadlessException的详细消息字符串。

getMessage() - Method in exception java.io. InvalidClassException

生成消息并包括类名（如果存在）。

getMessage() - Method in exception java.io. WriteAbortedException

生成消息并将嵌套异常中的消息包含在内。

getMessage() - Method in class java.lang. Throwable

返回此throwable的详细消息字符串。

getMessage() - Method in exception java.net. URISyntaxException

返回描述解析错误的字符串。

getMessage() - Method in exception java.nio.charset. MalformedInputException

返回消息。

getMessage() - Method in exception java.nio.charset. UnmappableCharacterException

返回消息。

getMessage() - Method in exception java.nio.file. FileSystemException

返回详细消息字符串。

getMessage() - Method in exception java.nio.file. InvalidPathException

返回描述错误的字符串。

getMessage() - Method in exception java.rmi.activation. ActivationException

返回详细信息，包括原因的消息（如果有的话）的异常。

getMessage() - Method in exception java.rmi. RemoteException

返回详细信息，包括原因的消息（如果有的话）的异常。

getMessage() - Method in exception java.rmi.server. ServerCloneException

返回详细信息，包括原因的消息（如果有的话）的异常。

getMessage() - Method in exception java.security.cert. CertificateRevokedException

getMessage() - Method in exception java.util. DuplicateFormatFlagsException

getMessage() - Method in exception java.util. FormatFlagsConversionMismatchException

getMessage() - Method in exception java.util. IllegalFormatCodePointException

getMessage() - Method in exception java.util. IllegalFormatConversionException

getMessage() - Method in exception java.util. IllegalFormatFlagsException

getMessage() - Method in exception java.util. IllegalFormatPrecisionException

getMessage() - Method in exception java.util. IllegalFormatWidthException

getMessage() - Method in class java.util.logging. LogRecord

在本地化或格式化之前获取“原始”日志消息。

getMessage() - Method in exception java.util. MissingFormatArgumentException

getMessage() - Method in exception java.util. MissingFormatWidthException

getMessage() - Method in exception java.util.regex. PatternSyntaxException

返回一个多行字符串，其中包含语法错误及其索引的描述，错误的正则表达式模式以及模式中错误索引的可视指示。

getMessage() - Method in exception java.util. UnknownFormatConversionException

getMessage() - Method in exception java.util. UnknownFormatFlagsException

getMessage() - Method in class javafx.concurrent. Service

获取属性消息的值。

getMessage() - Method in class javafx.concurrent. Task

获取属性消息的值。

getMessage() - Method in interface javafx.concurrent. Worker

获取与此Worker的当前状态相关联的消息。

getMessage() - Method in class javafx.css. CssParser.ParseError

getMessage() - Method in class javafx.scene.web. PromptData

返回此数据对象携带的消息。

getMessage() - Method in class javafx.scene.web. WebErrorEvent

返回与此事件关联的文本消息。

getMessage() - Method in interface javax.annotation.processing. Completion

返回有关完成的信息性消息。

getMessage() - Method in class javax.management. Notification

获取通知消息。

getMessage() - Method in exception javax.script. ScriptException

返回包含传递给构造函数的String以及行和列号以及文件名（如果有的话）已知的消息。

getMessage() - Method in class javax.security.auth.callback. TextOutputCallback

获取要显示的消息。

getMessage() - Method in class javax.sound.midi. MidiEvent

获取事件中包含的MIDI消息。

getMessage() - Method in class javax.sound.midi. MidiMessage

获取MIDI消息数据。

getMessage() - Method in class javax.swing. JOptionPane

返回窗格显示的消息对象。

getMessage() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回从 JOptionPane显示的消息，接收器提供外观和感觉。

getMessage() - Method in class javax.xml.bind.helpers. ValidationEventImpl

getMessage() - Method in interface javax.xml.bind. ValidationEvent

检索此警告/错误的短信。

getMessage() - Method in error javax.xml.parsers. FactoryConfigurationError

返回此错误的消息（如果有）。

getMessage() - Method in exception javax.xml.soap. SOAPException

返回此 SOAPException对象的详细消息。

getMessage() - Method in error javax.xml.stream. FactoryConfigurationError

报告与此错误相关联的消息

getMessage() - Method in error javax.xml.transform. TransformerFactoryConfigurationError

返回此错误的消息（如果有）。

getMessage() - Method in interface javax.xml.ws.handler. LogicalMessageContext

从该消息上下文获取消息

getMessage() - Method in interface javax.xml.ws.handler.soap. SOAPMessageContext

从此消息上下文获取 SOAPMessage 。

getMessage() - Method in interface jdk.nashorn.api.tree. Diagnostic

获取此诊断的消息。

getMessage() - Method in exception org.ietf.jgss. GSSException

返回主要和次要状态代码的文本表示。

getMessage() - Method in interface org.w3c.dom. DOMError

描述发生错误的实现特定字符串。

getMessage() - Method in exception org.xml.sax. SAXException

返回此异常的详细消息。

getMessage(Locale) - Method in interface javax.tools. Diagnostic

返回给定区域设置的本地化消息。

getMessage(Locale) - Method in class jdk.jshell. Diag

返回给定区域设置的本地化消息。

getMessageAndLocation() - Method in exception javax.xml.transform. TransformerException

获取附加位置信息的错误消息。

getMessageContext() - Method in interface javax.xml.ws. WebServiceContext

在 MessageContext此方法时，返回 MessageContext的请求。

getMessageDigest() - Method in class java.security. DigestInputStream

返回与此流相关联的消息摘要。

getMessageDigest() - Method in class java.security. DigestOutputStream

返回与此流相关联的消息摘要。

getMessageFactory() - Method in interface javax.xml.ws.soap. SOAPBinding

获取此SOAP绑定使用的SAAJ MessageFactory实例。

getMessager() - Method in interface javax.annotation.processing. ProcessingEnvironment

返回用于报告错误，警告和其他通知的信使。

getMessageType() - Method in class javax.security.auth.callback. ConfirmationCallback

获取消息类型。

getMessageType() - Method in class javax.security.auth.callback. TextOutputCallback

获取消息类型。

getMessageType() - Method in class javax.swing. JOptionPane

返回消息类型。

getMeta() - Method in class javafx.scene.input. KeyCombination

meta键在这个关键组合的状态。

getMetadata() - Method in class javafx.scene.media. Media

检索此媒体源中包含的元数据。

getMetadata() - Method in class javafx.scene.media. Track

getMetadata() - Method in class javax.imageio. IIOImage

返回对当前 IIOMetadata对象的引用，或者 null是无设置的。

getMetadata() - Method in class javax.xml.ws. Endpoint

返回服务的元数据文档列表。

getMetaData() - Method in interface java.sql. Connection

检索一个 DatabaseMetaData对象，其中包含有关此 Connection对象表示连接的数据库的元数据。

getMetaData() - Method in interface java.sql. PreparedStatement

检索 ResultSetMetaData对象，其中包含有关执行此 PreparedStatement对象时将返回的 ResultSet对象的列的信息。

getMetaData() - Method in interface java.sql. ResultSet

检索此 ResultSet对象列的数量，类型和属性。

getMetadataFormat(String) - Method in class javax.imageio.metadata. IIOMetadata

返回一个 IIOMetadataFormat对象描述给定的元数据格式，或 null如果没有可用的描述。

getMetadataFormatNames() - Method in class javax.imageio.metadata. IIOMetadata

返回数组 String包含的所有元数据格式的名称，包括本地和标准格式，通过此插件的认为科学 getAsTree ， setFromTree ，并 mergeTree方法。

getMetaKey() - Method in interface org.w3c.dom.events. MouseEvent

用于指示在触发事件期间“元”键是否被压制。

getMethod() - Method in class java.beans. MethodDescriptor

获取此MethodDescriptor封装的方法。

getMethod() - Method in class java.util.zip. ZipEntry

返回条目的压缩方法。

getMethod() - Method in class javax.swing.text.html. FormSubmitEvent

获取表单方法类型。

getMethod() - Method in interface org.w3c.dom.html. HTMLFormElement

用于提交表单的HTTP方法。

getMethod(String, Class<?>...) - Method in class java.lang. Class

返回一个 方法对象，该对象反映由该 Class对象表示的类或接口的指定公共成员方法。

getMethodCallSyntax(String, String, String...) - Method in interface javax.script. ScriptEngineFactory

返回一个String，可以使用支持的脚本语言的语法来调用Java对象的方法。

getMethodCallSyntax(String, String, String...) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getMethodDescriptors() - Method in interface java.beans. BeanInfo

返回定义此bean支持的外部可见方法的bean的方法描述符。

getMethodDescriptors() - Method in class java.beans. SimpleBeanInfo

否认知识的方法。

getMethodName() - Method in class java.beans. Statement

返回要调用的方法的名称。

getMethodName() - Method in class java.lang. StackTraceElement

返回包含由该堆栈跟踪元素表示的执行点的方法的名称。

getMethodName() - Method in interface java.lang. StackWalker.StackFrame

获取由该堆栈帧表示的方法的名称。

getMethods() - Method in class java.lang. Class

返回一个包含 方法对象的数组， 方法对象反映由该 Class对象表示的类或接口的所有公共方法，包括由类或接口声明的那些对象以及从超类和超级接口继承的类。

getMethodSelect() - Method in interface com.sun.source.tree. MethodInvocationTree

返回标识要调用的方法的表达式。

getMethodType() - Method in interface java.lang.invoke. MethodHandleInfo

返回破解的符号引用的标称类型，表示为方法类型。

getMethodType() - Method in class jdk.dynalink. CallSiteDescriptor

呼叫站点的方法类型。

getMGFAlgorithm() - Method in class java.security.spec. PSSParameterSpec

返回掩码生成函数算法名称。

getMGFAlgorithm() - Method in class javax.crypto.spec. OAEPParameterSpec

返回掩码生成函数算法名称。

getMGFParameters() - Method in class java.security.spec. PSSParameterSpec

返回掩码生成函数的参数。

getMGFParameters() - Method in class javax.crypto.spec. OAEPParameterSpec

返回掩码生成函数的参数。

getMIC(byte[], int, int, MessageProp) - Method in interface org.ietf.jgss. GSSContext

返回包含所提供消息的加密消息完整性代码（MIC）的令牌，以传输到对等应用程序。

getMIC(InputStream, OutputStream, MessageProp) - Method in interface org.ietf.jgss. GSSContext

使用流来生成包含所提供消息的加密MIC的令牌，以传送到对等应用程序。

getMicrosecondLength() - Method in class javax.sound.midi. MidiFileFormat

获取MIDI文件的长度，以微秒表示。

getMicrosecondLength() - Method in class javax.sound.midi. Sequence

获得此序列的持续时间，以微秒表示。

getMicrosecondLength() - Method in interface javax.sound.midi. Sequencer

获取当前序列的长度，以微秒表示，如果没有设置序列，则为0。

getMicrosecondLength() - Method in interface javax.sound.sampled. Clip

获取媒体持续时间（以微秒为单位）。

getMicrosecondPosition() - Method in interface javax.sound.midi. MidiDevice

获取设备的当前时间戳，以微秒为单位。

getMicrosecondPosition() - Method in interface javax.sound.midi. Sequencer

获取序列中的当前位置，以微秒表示。

getMicrosecondPosition() - Method in interface javax.sound.sampled. DataLine

以微秒形式获取音频数据中的当前位置。

getMidiDevice() - Method in interface javax.sound.midi. MidiDeviceReceiver

获取一个MidiDevice对象，该对象是此Receiver的所有者。

getMidiDevice() - Method in interface javax.sound.midi. MidiDeviceTransmitter

获取一个MidiDevice对象，该对象是此Transmitter的所有者。

getMidiDevice(MidiDevice.Info) - Static method in class javax.sound.midi. MidiSystem

获取所请求的MIDI设备。

getMidiDeviceInfo() - Static method in class javax.sound.midi. MidiSystem

获取表示系统上可用的所有MIDI设备的集合的信息对象数组。

getMidiFileFormat(File) - Static method in class javax.sound.midi. MidiSystem

获取指定的 File的MIDI文件格式。

getMidiFileFormat(File) - Method in class javax.sound.midi.spi. MidiFileReader

获得提供的 File的MIDI文件格式。

getMidiFileFormat(InputStream) - Static method in class javax.sound.midi. MidiSystem

获取指定输入流中数据的MIDI文件格式。

getMidiFileFormat(InputStream) - Method in class javax.sound.midi.spi. MidiFileReader

获取所提供的输入流的MIDI文件格式。

getMidiFileFormat(URL) - Static method in class javax.sound.midi. MidiSystem

获取指定URL中数据的MIDI文件格式。

getMidiFileFormat(URL) - Method in class javax.sound.midi.spi. MidiFileReader

获取提供的URL的MIDI文件格式。

getMidiFileTypes() - Static method in class javax.sound.midi. MidiSystem

获取系统提供文件写入支持的一组MIDI文件类型。

getMidiFileTypes() - Method in class javax.sound.midi.spi. MidiFileWriter

获取此文件写入器提供文件写入支持的一组MIDI文件类型。

getMidiFileTypes(Sequence) - Static method in class javax.sound.midi. MidiSystem

获取系统可以从指定的顺序写入的一组MIDI文件类型。

getMidiFileTypes(Sequence) - Method in class javax.sound.midi.spi. MidiFileWriter

获取此文件写入器可以从指定的序列中写入的文件类型。

getMidLabel() - Method in class javax.sound.sampled. FloatControl

获取中点值的标签，例如“中心”或“默认”。

getMidTermsOfReductionPolynomial() - Method in class java.security.spec. ECFieldF2m

返回一个整数数组，其中包含多项式基础的缩减多项式的中间项的顺序，或者为正常的基数返回null。

getMillis() - Method in class java.util.logging. LogRecord

自1970年以来，截止事件时间为毫秒。

getMillisecond() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回毫秒精度为 XMLGregorianCalendar.getFractionalSecond() 。

getMillisToDecideToPopup() - Method in class javax.swing. ProgressMonitor

返回此对象等待的时间量，然后再决定是否弹出进度监视器。

getMillisToPopup() - Method in class javax.swing. ProgressMonitor

返回弹出窗口所需的时间。

getMimeDecoder() - Static method in class java.util. Base64

返回一个Base64.Decoder解码使用MIME型BASE64解码方案。

getMimeEncoder() - Static method in class java.util. Base64

返回一个Base64.Encoder ，它使用MIME类型的base64编码方案进行编码。

getMimeEncoder(int, byte[]) - Static method in class java.util. Base64

返回一个Base64.Encoder ，它使用具有指定行长和行分隔符的MIME类型base64编码方案进行编码。

getMimeHeader(String) - Method in class javax.xml.soap. AttachmentPart

获取由给定的 String标识的标题的所有值。

getMimeHeader(String) - Method in class javax.xml.soap. SOAPPart

获取的所有值 MimeHeader在这个对象 SOAPPart对象由给定的标识 String 。

getMimeHeaders() - Method in class javax.xml.soap. SOAPMessage

以传输独立的方式返回此 SOAPMessage对象的所有传输特定MIME标头。

getMimeType() - Method in class java.awt.datatransfer. DataFlavor

返回此 DataFlavor的MIME类型字符串。

getMimeType() - Method in class javax.activation. ActivationDataFlavor

返回此DataFlavor的MIME类型。

getMimeType() - Method in class javax.print. DocFlavor

根据规范表单返回此doc风格对象的MIME类型字符串。

getMimeType() - Method in interface javax.xml.crypto.dsig. XMLObject

返回这个 XMLObject的MIME类型。

getMimeType() - Method in class javax.xml.crypto. OctetStreamData

返回与此 OctetStreamData表示的数据对象关联的MIME类型。

getMimeTypes() - Method in interface javax.accessibility. AccessibleStreamable

返回此对象支持的MIME类型的 DataFlavor对象的数组。

getMimeTypes() - Method in class javax.activation. CommandMap

获取此命令映射已知的所有MIME类型。

getMimeTypes() - Method in class javax.activation. MailcapCommandMap

获取此命令映射已知的所有MIME类型。

getMimeTypes() - Method in interface javax.script. ScriptEngineFactory

返回一个不可变的mimetype列表，与引擎可执行的脚本相关联。

getMimeTypes() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getMIMETypes() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回一个包含 String s的数组， String包含与此服务提供商关联的 ImageReader或 ImageWriter实现通常可用的格式相关联的MIME类型列表。

getMin() - Method in class java.util. DoubleSummaryStatistics

如果任何记录值为NaN，则返回最低记录值 Double.NaN如果没有记录值，则返回 Double.POSITIVE_INFINITY 。

getMin() - Method in class java.util. IntSummaryStatistics

返回记录的最小值，如果没有记录值，则返回 Integer.MAX_VALUE 。

getMin() - Method in class java.util. LongSummaryStatistics

返回记录的最小值，如果没有记录值，则返回 Long.MAX_VALUE 。

getMin() - Method in class javafx.scene.control. ScrollBar

获取属性的值min。

getMin() - Method in class javafx.scene.control. Slider

获取属性的值min。

getMin() - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory

获取属性的值min。

getMin() - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

获取属性的值min。

getMinBufferSize() - Method in class javax.sound.sampled. DataLine.Info

获取数据线支持的最小缓冲区大小。

getMinCRL() - Method in class java.security.cert. X509CRLSelector

返回minCRLNumber标准。

getMinDegree() - Method in class javax.management.relation. RoleInfo

返回相应角色引用的最小度。

getMinHeight() - Method in class javafx.scene.control. PopupControl

超越控制计算的最小高度的属性。

getMinHeight() - Method in class javafx.scene.layout. Region

获取属性minHeight的值。

getMinHeight() - Method in class javafx.scene.layout. RowConstraints

获取属性minHeight的值。

getMinHeight() - Method in class javafx.scene.web. WebView

获取属性minHeight的值。

getMinHeight() - Method in class javafx.stage. Stage

获取属性minHeight的值。

getMinHeight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的min-height属性定义。

getMinimalDaysInFirstWeek() - Method in class java.time.temporal. WeekFields

在第一周内获得最少天数。

getMinimalDaysInFirstWeek() - Method in class java.util. Calendar

获得一年中第一周所需的最低限度的日子; 例如，如果第一周被定义为包含一年中的第一个月的第一个星期，则此方法返回1。

getMinimalDaysInFirstWeek(Locale) - Method in class java.util.spi. CalendarDataProvider

返回一年中第一周所需的最少天数。

getMinimum() - Method in interface java.awt. Adjustable

获取可调整对象的最小值。

getMinimum() - Method in class java.awt. Scrollbar

获取此滚动条的最小值。

getMinimum() - Method in class java.awt. ScrollPaneAdjustable

getMinimum() - Method in class java.time.temporal. ValueRange

获取字段可以占用的最小值。

getMinimum() - Method in class javax.sound.sampled. FloatControl

获得允许的最小值。

getMinimum() - Method in interface javax.swing. BoundedRangeModel

返回最小可接受值。

getMinimum() - Method in class javax.swing. DefaultBoundedRangeModel

返回模型的最小值。

getMinimum() - Method in class javax.swing. JProgressBar

从 BoundedRangeModel返回进度条的 minimum值。

getMinimum() - Method in class javax.swing. JScrollBar

返回滚动条支持的最小值（通常为零）。

getMinimum() - Method in class javax.swing. JSlider

从 BoundedRangeModel返回滑块支持的 BoundedRangeModel 。

getMinimum() - Method in class javax.swing. ProgressMonitor

返回最小值 - 进度值的下限。

getMinimum() - Method in class javax.swing. SpinnerNumberModel

返回此序列中的第一个数字。

getMinimum() - Method in class javax.swing.text. InternationalFormatter

返回最小允许值。

getMinimum(int) - Method in class java.util. Calendar

返回此 Calendar实例的给定日历字段的 Calendar 。

getMinimum(int) - Method in class java.util. GregorianCalendar

返回此 GregorianCalendar实例的给定日历字段的 GregorianCalendar 。

getMinimumAccessibleValue() - Method in class java.awt. Button.AccessibleAWTButton

将此对象的最小值作为数字获取。

getMinimumAccessibleValue() - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

将此对象的最小值作为数字获取。

getMinimumAccessibleValue() - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

将此对象的最小值作为数字获取。

getMinimumAccessibleValue() - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

将此对象的最小值作为数字获取。

getMinimumAccessibleValue() - Method in class java.awt. Scrollbar.AccessibleAWTScrollBar

获取此对象的最小可访问值。

getMinimumAccessibleValue() - Method in interface javax.accessibility. AccessibleValue

将此对象的最小值作为 Number 。

getMinimumAccessibleValue() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

将此对象的最小值作为数字获取。

getMinimumAccessibleValue() - Method in class javax.swing. JInternalFrame.AccessibleJInternalFrame

将此对象的最小值作为数字获取。

getMinimumAccessibleValue() - Method in class javax.swing. JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

获取此对象的最小值为 Number 。

getMinimumAccessibleValue() - Method in class javax.swing. JProgressBar.AccessibleJProgressBar

获取此对象的最小可访问值。

getMinimumAccessibleValue() - Method in class javax.swing. JScrollBar.AccessibleJScrollBar

获取此对象的最小可访问值。

getMinimumAccessibleValue() - Method in class javax.swing. JSlider.AccessibleJSlider

获取此对象的最小可访问值。

getMinimumAccessibleValue() - Method in class javax.swing. JSpinner.AccessibleJSpinner

将此对象的最小值作为数字获取。

getMinimumAccessibleValue() - Method in class javax.swing. JSplitPane.AccessibleJSplitPane

获取此对象的最小可访问值。

getMinimumDividerLocation() - Method in class javax.swing. JSplitPane

从外观实现中返回分隔符的最小位置。

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

获取分频器的最小位置。

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getMinimumDividerLocation方法。

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf. SplitPaneUI

返回分隔符的最小可能位置。

getMinimumFractionDigits() - Method in class java.text. DecimalFormat

获取数字小数部分中允许的最小位数。

getMinimumFractionDigits() - Method in class java.text. NumberFormat

返回数字小数部分允许的最小位数。

getMinimumHorizontalSize() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最小水平尺寸。

getMinimumIntegerDigits() - Method in class java.text. DecimalFormat

获取数字整数部分允许的最小位数。

getMinimumIntegerDigits() - Method in class java.text. NumberFormat

返回数字整数部分允许的最小位数。

getMinimumOptionPaneSize() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回选项窗格应该是最小的大小。

getMinimumSize() - Method in class java.awt. Component

获取此组件的最小大小。

getMinimumSize() - Method in class java.awt. Container

返回此容器的最小大小。

getMinimumSize() - Method in class java.awt. List

确定此滚动列表的最小大小。

getMinimumSize() - Method in class java.awt. TextArea

确定此文本区域的最小大小。

getMinimumSize() - Method in class java.awt. TextField

获取此文本字段的最小尺寸。

getMinimumSize() - Method in class javax.swing. JComponent

如果最小尺寸设置为非 null值，则返回。

getMinimumSize() - Method in class javax.swing. JScrollBar

滚动条沿其滚动轴线是柔性的，并且沿着另一个轴线是刚性的。

getMinimumSize() - Method in class javax.swing. JToolBar.Separator

返回分隔符的最小大小。

getMinimumSize() - Method in class javax.swing.plaf.basic. BasicArrowButton

返回 BasicArrowButton的最小大小。

getMinimumSize() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

返回dividerSize x dividerSize

getMinimumSize() - Method in class javax.swing.plaf.metal. MetalComboBoxButton

getMinimumSize() - Method in class javax.swing.plaf.metal. MetalScrollButton

getMinimumSize(int) - Method in class java.awt. List

获取具有指定行数的列表的最小尺寸。

getMinimumSize(int) - Method in class java.awt. TextField

获取具有指定列数的文本字段的最小尺寸。

getMinimumSize(int, int) - Method in class java.awt. TextArea

确定具有指定行数和列数的文本区域的最小大小。

getMinimumSize(Component) - Method in class javax.swing.border. TitledBorder

返回边框所需的最小尺寸，以便完全显示边框和标题。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

最小尺寸是显示区域的大小加上插页加上按钮。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回最小大小。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicLabelUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuBarUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

该组件的最小大小为10。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSeparatorUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最小大小。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回传入的组件的最小大小，这被传递给当前的布局管理器。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

返回标题的最小大小。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTableUI

返回表的最小大小。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTextAreaUI

该方法被覆盖以考虑插入符宽度。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTextUI

获取编辑器组件的最小大小。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回此组件的最小大小。

getMinimumSize(JComponent) - Method in class javax.swing.plaf. ComponentUI

返回指定组件的最小尺寸，适合外观和感觉。

getMinimumSize(JComponent) - Method in class javax.swing.plaf. LayerUI

如果 JLayer的视图组件不是 null ，则返回视图 getMinimalSize()方法的结果。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal. MetalComboBoxUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal. MetalDesktopIconUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

返回 JFileChooser的最小尺寸。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI

在此对象处理的每个UI上调用 getMinimumSize方法。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回指定组件的最小尺寸，适合外观和感觉。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth. SynthLabelUI

返回指定组件的最小尺寸，适合外观和感觉。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI

返回指定组件的最小尺寸，适合外观和感觉。

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth. SynthSliderUI

返回最小大小。

getMinimumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils

返回正确呈现图标和文本所需的最小尺寸。

getMinimumSpan(int) - Method in class javax.swing.text. AsyncBoxView

确定此视图沿轴的最小跨度。

getMinimumSpan(int) - Method in class javax.swing.text. BoxView

确定此视图沿轴的最小跨度。

getMinimumSpan(int) - Method in class javax.swing.text. ComponentView

确定此视图沿轴的最小跨度。

getMinimumSpan(int) - Method in class javax.swing.text. GlyphView

确定此视图沿轴的最小跨度。

getMinimumSpan(int) - Method in class javax.swing.text.html. BlockView

确定此视图沿轴的最小跨度。

getMinimumSpan(int) - Method in class javax.swing.text.html. ParagraphView

确定此视图沿轴的最小跨度。

getMinimumSpan(int) - Method in class javax.swing.text. TableView.TableRow

getMinimumSpan(int) - Method in class javax.swing.text. View

确定此视图沿轴的最小跨度。

getMinimumSpan(int) - Method in class javax.swing.text. WrappedPlainView

确定此视图沿轴的最小跨度。

getMinimumThumbSize() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

返回拇指的最小可接受尺寸。

getMinimumThumbSize() - Method in class javax.swing.plaf.metal. MetalScrollBarUI

getMinimumThumbSize() - Method in class javax.swing.plaf.synth. SynthScrollBarUI

返回拇指的最小可接受尺寸。

getMinimumValue() - Method in class javax.swing. Spring

返回此 Spring的 最小值 。

getMinimumVerticalSize() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最小垂直尺寸。

getMinIndex() - Method in class javax.imageio. ImageReader

返回读取图像，缩略图或图像元数据的最低有效索引。

getMinLabel() - Method in class javax.sound.sampled. FloatControl

获取最小值的标签，例如“左”或“关”。

getMinor() - Method in exception org.ietf.jgss. GSSException

返回导致引发此异常的问题的机制级别错误代码。

getMinorAxis() - Method in class javax.swing.text. AsyncBoxView

获取短轴（垂直于平铺轴的轴）。

getMinorOffset() - Method in class javax.swing.text. AsyncBoxView.ChildState

沿着短轴的偏移是多少？

getMinorSpan() - Method in class javax.swing.text. AsyncBoxView.ChildState

沿着短轴的跨度是多少？

getMinorStatus() - Method in class org.ietf.jgss. MessageProp

检索底层机制可能为每个消息操作设置的次要状态代码。

getMinorString() - Method in exception org.ietf.jgss. GSSException

返回一个解释机制特定错误代码的字符串。

getMinorString() - Method in class org.ietf.jgss. MessageProp

检索一个解释次要状态代码的字符串。

getMinorTickCount() - Method in class javafx.scene.chart. ValueAxis

获取属性minorTickCount的值。

getMinorTickCount() - Method in class javafx.scene.control. Slider

获取属性minorTickCount的值。

getMinorTickLength() - Method in class javafx.scene.chart. ValueAxis

获取属性minorTickLength的值。

getMinorTickSpacing() - Method in class javax.swing. JSlider

此方法返回较小的刻度间距。

getMinorVersion() - Method in class java.awt.color. ICC_Profile

返回配置文件小版本。

getMinorVersion() - Method in interface java.sql. Driver

获取驱动程序的次要版本号。

getMinPage() - Method in class java.awt. JobAttributes

指定用户可以指定的最小值作为使用这些属性的作业打印的第一页。

getMinSelectionIndex() - Method in class javax.swing. DefaultListSelectionModel

返回第一个选择的索引，如果选择为空，则返回-1。

getMinSelectionIndex() - Method in class javax.swing. JList

返回最小选择的单元 -1引，如果选择为空，则返回 -1 。

getMinSelectionIndex() - Method in interface javax.swing. ListSelectionModel

返回第一个选择的索引，如果选择为空，则返回-1。

getMinSelectionRow() - Method in class javax.swing. JTree

返回最小的选定行。

getMinSelectionRow() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回从当前所选TreePath集合的RowMapper获取的最小值。

getMinSelectionRow() - Method in interface javax.swing.tree. TreeSelectionModel

返回从当前所选TreePath集合的RowMapper获取的最小值。

getMinSize(Container, GridBagLayoutInfo) - Method in class java.awt. GridBagLayout

根据 getLayoutInfo的信息， getLayoutInfo主站的最小尺寸。

GetMinSize(Container, GridBagLayoutInfo) - Method in class java.awt. GridBagLayout

此方法已过时，仅供后向兼容; 新代码应该调用getMinSize 。

getMinTileX() - Method in class java.awt.image. BufferedImage

返回x方向上的最小拼贴索引。

getMinTileX() - Method in interface java.awt.image. RenderedImage

返回X方向上的最小平铺索引。

getMinTileY() - Method in class java.awt.image. BufferedImage

返回y方向上的最小瓦片索引。

getMinTileY() - Method in interface java.awt.image. RenderedImage

返回Y方向上的最小瓦片索引。

getMinusSign() - Method in class java.text. DecimalFormatSymbols

获取用于表示减号的字符。

getMinute() - Method in class java.time. LocalDateTime

获取小时字段。

getMinute() - Method in class java.time. LocalTime

获取小时字段。

getMinute() - Method in class java.time. OffsetDateTime

获取小时字段。

getMinute() - Method in class java.time. OffsetTime

获取小时字段。

getMinute() - Method in class java.time. ZonedDateTime

获取小时字段。

getMinute() - Method in class javax.xml.datatype. XMLGregorianCalendar

如果未定义该字段，则返回小时的分钟数或 DatatypeConstants.FIELD_UNDEFINED 。

getMinutes() - Method in class java.sql. Date

已过时。

getMinutes() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.get(Calendar.MINUTE)替代。

getMinutes() - Method in class javax.xml.datatype. Duration

获取MINUTES字段的值作为整数值，如果不存在，则为0。

getMinValue() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport

返回此 OpenMBeanAttributeInfoSupport实例描述的属性的 OpenMBeanAttributeInfoSupport （如果指定），否则 null 。

getMinValue() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回此参数的最小值（如果为1），否则 null 。

getMinValue() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport

返回此 OpenMBeanParameterInfoSupport实例描述的参数的 OpenMBeanParameterInfoSupport （如果指定），否则 null 。

getMinValue(int) - Method in class java.awt.color. ColorSpace

返回指定组件的最小标准化颜色分量值。

getMinValue(int) - Method in class java.awt.color. ICC_ColorSpace

返回指定组件的最小标准化颜色分量值。

getMinViewportHeight() - Method in class javafx.scene.control. ScrollPane

获取属性minViewportHeight的值。

getMinViewportWidth() - Method in class javafx.scene.control. ScrollPane

获取属性minViewportWidth的值。

getMinWidth() - Method in class javafx.scene.control. PopupControl

覆盖控制计算最小宽度的属性。

getMinWidth() - Method in class javafx.scene.control. TableColumnBase

获取属性minWidth的值。

getMinWidth() - Method in class javafx.scene.layout. ColumnConstraints

获取属性minWidth的值。

getMinWidth() - Method in class javafx.scene.layout. Region

获取属性minWidth的值。

getMinWidth() - Method in class javafx.scene.web. WebView

获取属性minWidth的值。

getMinWidth() - Method in class javafx.stage. Stage

获取属性minWidth的值。

getMinWidth() - Method in class javax.swing.table. TableColumn

返回 TableColumn的最小宽度。

getMinWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的min-width属性定义。

getMinX() - Method in class java.awt.geom. RectangularShape

返回 double精度的 Shape框架矩形的最小X坐标。

getMinX() - Method in class java.awt.image. BufferedImage

返回此 BufferedImage的最小x坐标。

getMinX() - Method in class java.awt.image. Raster

返回栅格的最小有效X坐标。

getMinX() - Method in interface java.awt.image.renderable. RenderableImage

获取与渲染无关的图像数据的最小X坐标。

getMinX() - Method in class java.awt.image.renderable. RenderableImageOp

获取与渲染无关的图像数据的最小X坐标。

getMinX() - Method in interface java.awt.image. RenderedImage

返回RenderedImage的最小X坐标（包括）。

getMinX() - Method in class javafx.geometry. Bounds

这个 Bounds左上角的x坐标。

getMinX() - Method in class javafx.geometry. Rectangle2D

这个 Rectangle2D左上角的x坐标。

getMinY() - Method in class java.awt.geom. RectangularShape

以 double精度返回 Shape框架矩形的最小Y坐标。

getMinY() - Method in class java.awt.image. BufferedImage

返回此 BufferedImage的最小y坐标。

getMinY() - Method in class java.awt.image. Raster

返回栅格的最小有效Y坐标。

getMinY() - Method in interface java.awt.image.renderable. RenderableImage

获取与渲染无关的图像数据的最小Y坐标。

getMinY() - Method in class java.awt.image.renderable. RenderableImageOp

获取与渲染无关的图像数据的最小Y坐标。

getMinY() - Method in interface java.awt.image. RenderedImage

返回RenderedImage的最小Y坐标（包括）。

getMinY() - Method in class javafx.geometry. Bounds

这个 Bounds左上角的y坐标。

getMinY() - Method in class javafx.geometry. Rectangle2D

这个 Rectangle2D左上角的y坐标。

getMinZ() - Method in class javafx.geometry. Bounds

这个最小的z坐标 Bounds 。

getMissingGlyphCode() - Method in class java.awt. Font

返回当这个 Font没有指定unicode代码点的字形时使用的 Font 。

getMiterLimit() - Method in class java.awt. BasicStroke

返回斜角连接的极限。

getMiterLimit() - Method in class javafx.scene.canvas. GraphicsContext

获得当前的斜角限制。

getMiterLimit() - Method in class javafx.scene.layout. BorderStrokeStyle

定义 StrokeLineJoin.MITER线连接样式的限制。

getMixer(Mixer.Info) - Static method in class javax.sound.sampled. AudioSystem

获得所要求的音频混音器。

getMixer(Mixer.Info) - Method in class javax.sound.sampled.spi. MixerProvider

获取由info对象表示的混音器的实例。

getMixerInfo() - Static method in class javax.sound.sampled. AudioSystem

获取一组混合信息对象，表示系统当前安装的一组音频混合器。

getMixerInfo() - Method in interface javax.sound.sampled. Mixer

获取有关此混音器的信息，包括产品的名称，版本，供应商等。

getMixerInfo() - Method in class javax.sound.sampled.spi. MixerProvider

获取代表由MixerProvider提供的混音器或混音器的一组信息对象。

getMnemonic() - Method in class javax.swing. AbstractButton

从当前模型返回键盘助记符。

getMnemonic() - Method in interface javax.swing. ButtonModel

获取按钮的键盘助记符。

getMnemonic() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

提供一个关于 KeyEvent.VK常数的外观和感觉的提示，可以用作助记符来访问面板。

getMnemonic() - Method in class javax.swing. DefaultButtonModel

获取按钮的键盘助记符。

getMnemonicAt(int) - Method in class javax.swing. JTabbedPane

返回用于访问指定选项卡的键盘助记符。

getMnemonics() - Method in class javafx.scene. Scene

获取 Scene的助记符列表。

getModalExclusionType() - Method in class java.awt. Window

返回此窗口的模态排除类型。

getModality() - Method in class javafx.scene.control. Dialog

检索此对话框的模态属性。

getModality() - Method in class javafx.stage. Stage

检索此阶段的模态属性。

getModalityType() - Method in class java.awt. Dialog

返回此对话框的模态类型。

getMode() - Method in interface com.sun.source.tree. MemberReferenceTree

返回引用的模式。

getMode() - Method in class java.awt. FileDialog

指示此文件对话框是从文件加载还是保存到文件。

getMode() - Method in class javafx.scene.effect. Blend

获取属性模式的值。

getModel() - Method in class javax.swing. AbstractButton

返回此按钮所代表的模型。

getModel() - Method in class javax.swing. DefaultRowSorter

返回底层模型。

getModel() - Method in class javax.swing. DefaultRowSorter.ModelWrapper

返回此 Model正在包装的底层模型。

getModel() - Method in class javax.swing. JComboBox

返回 JComboBox当前使用的数据模型。

getModel() - Method in class javax.swing. JList

返回包含由 JList组件显示的项目列表的数据模型。

getModel() - Method in class javax.swing. JProgressBar

返回此进度条使用的数据模型。

getModel() - Method in class javax.swing. JScrollBar

返回处理滚动条的四个基本属性的数据模型：minimum，maximum，value，extent。

getModel() - Method in class javax.swing. JSlider

返回 BoundedRangeModel ，它处理滑块的三个基本属性：minimum，maximum，value。

getModel() - Method in class javax.swing. JSpinner.DateEditor

返回我们的旋转器祖先的 SpinnerDateModel 。

getModel() - Method in class javax.swing. JSpinner

返回定义该旋转序列值的 SpinnerModel 。

getModel() - Method in class javax.swing. JSpinner.ListEditor

返回我们的旋转器祖先的 SpinnerNumberModel 。

getModel() - Method in class javax.swing. JSpinner.NumberEditor

返回我们的旋转器祖先的 SpinnerNumberModel 。

getModel() - Method in class javax.swing. JTabbedPane

返回与此选项卡窗格关联的模型。

getModel() - Method in class javax.swing. JTable

返回提供 TableModel显示的数据的 JTable 。

getModel() - Method in class javax.swing. JTree

返回提供数据的 TreeModel 。

getModel() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回模型。

getModel() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回树模型。

getModel() - Method in class javax.swing. RowFilter.Entry

返回底层模型。

getModel() - Method in class javax.swing. RowSorter

返回底层模型。

getModel() - Method in class javax.swing.tree. AbstractLayoutCache

返回提供数据的 TreeModel 。

getModelIndex() - Method in class javax.swing.table. TableColumn

返回此列的模型索引。

getModelItem(int) - Method in class javafx.scene.control. FocusModel

返回给定索引处的项目。

getModelItem(int) - Method in class javafx.scene.control. SingleSelectionModel

获取与特定索引关联的数据模型项。

getModelItem(int) - Method in class javafx.scene.control. TableView.TableViewFocusModel

返回给定索引处的项目。

getModelItem(int) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

返回给定索引处的项目。

getModelItem(int) - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel

返回给定索引处的项目。

getModelItem(int) - Method in class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel

返回给定索引处的项目。

getModelRowCount() - Method in class javax.swing. DefaultRowSorter

返回底层模型中的行数。

getModelRowCount() - Method in class javax.swing. RowSorter

返回底层模型中的行数。

getModelWrapper() - Method in class javax.swing. DefaultRowSorter

返回提供正在排序和过滤的数据的模型包装器。

getModificationOp() - Method in class javax.naming.directory. ModificationItem

检索此修改项目的修改代码。

getModifier() - Method in class javax.swing.text.html.parser. AttributeList

getModifiers() - Method in interface com.sun.source.tree. ClassTree

返回此类型声明的修饰符，包括任何注释。

getModifiers() - Method in interface com.sun.source.tree. MethodTree

返回修饰符，包括声明方法的任何注释。

getModifiers() - Method in interface com.sun.source.tree. VariableTree

在声明中返回修饰符，包括任何注释。

getModifiers() - Method in class java.awt. AWTKeyStroke

返回此 AWTKeyStroke的修饰键。

getModifiers() - Method in class java.awt.event. ActionEvent

返回此操作事件期间按住的修饰键。

getModifiers() - Method in class java.awt.event. InputEvent

已过时。
建议使用扩展修饰键和InputEvent.getModifiersEx()

getModifiers() - Method in class java.lang. Class

返回此类或接口的Java语言修饰符，以整数编码。

getModifiers() - Method in interface java.lang.invoke. MethodHandleInfo

返回底层成员的访问修饰符。

getModifiers() - Method in class java.lang.reflect. Constructor

返回由该对象表示的可执行文件的Java语言modifiers 。

getModifiers() - Method in class java.lang.reflect. Executable

返回由该对象表示的可执行文件的Java语言modifiers 。

getModifiers() - Method in class java.lang.reflect. Field

返回由该 Field对象表示的字段的Java语言修饰符，作为整数。

getModifiers() - Method in interface java.lang.reflect. Member

返回由此成员表示的成员或构造函数的Java语言修饰符，作为整数。

getModifiers() - Method in class java.lang.reflect. 方法

返回由该对象表示的可执行文件的Java语言modifiers 。

getModifiers() - Method in class java.lang.reflect. Parameter

获取由此 Parameter对象表示的参数的修饰符标志。

getModifiers() - Method in interface javax.lang.model.element. Element

返回此元素的修饰符，不包括注释。

getModifiersEx() - Method in class java.awt.event. InputEvent

返回此事件的扩展修饰符掩码。

getModifiersEx() - Method in class java.awt.event. MouseEvent

返回此事件的扩展修饰符掩码。

getModifiersExText(int) - Static method in class java.awt.event. InputEvent

返回一个描述扩展修饰符键和鼠标按钮的字符串，例如“Shift”，“Button1”或“Ctrl + Shift”。

getModule() - Method in class java.lang. Class

返回此类或接口所属的模块。

getModule() - Method in interface jdk.nashorn.api.tree. CompilationUnitTree

返回与此编译单元相关联的ModuleTree 。

getModuleElement(CharSequence) - Method in interface javax.lang.model.util. Elements

返回给出其完全限定名称的模块元素。

getModuleMode() - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回所需的模块文档级别。

getModuleName() - Method in interface com.sun.source.tree. RequiresTree

返回所需模块的名称。

getModuleName() - Method in class java.lang. StackTraceElement

返回包含由该堆栈跟踪元素表示的执行点的模块的模块名称。

getModuleNames() - Method in interface com.sun.source.tree. ExportsTree

返回包导出到的模块的名称，如果软件包导出到所有模块，则返回null。

getModuleNames() - Method in interface com.sun.source.tree. OpensTree

返回包打开的模块的名称，如果打包到所有模块，则返回null。

getModuleOf(Element) - Method in interface javax.lang.model.util. Elements

返回元素的模块。

getModuleRequest() - Method in interface jdk.nashorn.api.tree. ExportEntryTree

返回条目的模块请求。

getModuleRequest() - Method in interface jdk.nashorn.api.tree. ImportEntryTree

返回条目的模块请求。

getModuleType() - Method in interface com.sun.source.tree. ModuleTree

返回此模块的类型。

getModuleVersion() - Method in class java.lang. StackTraceElement

返回包含由该堆栈跟踪元素表示的执行点的模块的模块版本。

getModulus() - Method in interface java.security.interfaces. RSAKey

返回模数。

getModulus() - Method in class java.security.spec. RSAPrivateKeySpec

返回模数。

getModulus() - Method in class java.security.spec. RSAPublicKeySpec

返回模数。

getModulus() - Method in class javax.management.monitor. CounterMonitor

获得所有观察到的MBean共有的模数值。

getModulus() - Method in interface javax.management.monitor. CounterMonitorMBean

获得模数值。

getMonetaryDecimalSeparator() - Method in class java.text. DecimalFormatSymbols

返回货币小数分隔符。

getMono() - Method in interface javax.sound.midi. MidiChannel

获取当前单声道/多声道模式。

getMonth() - Method in class java.sql. Time

已过时。

getMonth() - Method in class java.time. LocalDate

使用 Month枚举获取月份字段。

getMonth() - Method in class java.time. LocalDateTime

使用 Month枚举获取月份字段。

getMonth() - Method in class java.time. MonthDay

使用 Month枚举获取月份字段。

getMonth() - Method in class java.time. OffsetDateTime

使用 Month枚举获取月份字段。

getMonth() - Method in class java.time. YearMonth

使用 Month枚举获取月份字段。

getMonth() - Method in class java.time.zone. ZoneOffsetTransitionRule

获得过渡的月份。

getMonth() - Method in class java.time. ZonedDateTime

使用 Month枚举获取月份字段。

getMonth() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.get(Calendar.MONTH)替代。

getMonth() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回此日历的月份或 DatatypeConstants.FIELD_UNDEFINED 。

getMonths() - Method in class java.text. DateFormatSymbols

获取月份字符串。

getMonths() - Method in class java.time. Period

获取此期间的月数。

getMonths() - Method in class javax.xml.datatype. Duration

获取MONTHS字段的值作为整数值，如果不存在，则为0。

getMonthValue() - Method in class java.time. LocalDate

将月份字段从1到12。

getMonthValue() - Method in class java.time. LocalDateTime

将月份字段从1到12。

getMonthValue() - Method in class java.time. MonthDay

将月份字段从1到12。

getMonthValue() - Method in class java.time. OffsetDateTime

将月份字段从1到12。

getMonthValue() - Method in class java.time. YearMonth

将月份字段从1到12。

getMonthValue() - Method in class java.time. ZonedDateTime

将月份字段从1到12。

getMoreResults() - Method in interface java.sql. Statement

移动到此 Statement对象的下一个结果，如果它是一个 ResultSet对象，则返回 true ，并隐式关闭使用方法 getResultSet获取的任何当前的 ResultSet对象。

getMoreResults(int) - Method in interface java.sql. Statement

移动到此 Statement对象的下一个结果，根据给定标志指定的指令处理任何当前的 ResultSet对象，如果下一个结果是一个 ResultSet对象，则返回 true 。

getMostRecentEventTime() - Static method in class java.awt. EventQueue

返回具有时间戳的最新事件的时间戳，并从与调用线程相关联的 EventQueue中调度。

getMostRecentFocusOwner() - Method in class java.awt. Window

返回此窗口的子组件，该窗口将在此窗口聚焦时接收焦点。

getMostRecentFocusOwner() - Method in class javax.swing. JInternalFrame

返回此的子组件 JInternalFrame当这是将接收焦点 JInternalFrame选择。

getMostSignificantBits() - Method in class java.util. UUID

返回此UUID的128位值的最高64位。

getMouseListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

实现ComboPopup.getMouseListener（）。

getMouseListener() - Method in interface javax.swing.plaf.basic. ComboPopup

返回一个将被添加到组合框或null的鼠标监听器。

getMouseListeners() - Method in class java.awt. Component

返回在此组件上注册的所有鼠标监听器的数组。

getMouseListeners() - Method in class java.awt. TrayIcon

返回在这个 TrayIcon上注册的所有鼠标监听器的数组。

getMouseModifiersText(int) - Static method in class java.awt.event. MouseEvent

返回一个 String实例，描述事件期间关闭的修改键和鼠标按钮，例如“Shift”或“Ctrl + Shift”。

getMouseMotionListener() - Method in class javax.swing.plaf.basic. BasicComboPopup

实现ComboPopup.getMouseMotionListener（）。

getMouseMotionListener() - Method in interface javax.swing.plaf.basic. ComboPopup

返回一个将被添加到组合框或null的鼠标移动侦听器。

getMouseMotionListeners() - Method in class java.awt. Component

返回在此组件上注册的所有鼠标移动侦听器的数组。

getMouseMotionListeners() - Method in class java.awt. TrayIcon

返回在此 TrayIcon上注册的所有鼠标移动侦听器的 TrayIcon 。

getMousePosition() - Method in class java.awt. Component

如果 Component直接位于鼠标指针下，则返回鼠标指针在 Component的坐标空间中的位置，否则返回 null 。

getMousePosition(boolean) - Method in class java.awt. Container

返回鼠标指针在该位置 Container的坐标空间，如果 Container是鼠标指针下，否则返回 null 。

getMouseWheelListeners() - Method in class java.awt. Component

返回在此组件上注册的所有鼠标滚轮侦听器的数组。

getMTU() - Method in class java.net. NetworkInterface

返回此接口的最大传输单元（MTU）。

getMultiClickThreshhold() - Method in class javax.swing. AbstractButton

获取鼠标按下事件之间所需的时间量（以毫秒为单位），用于生成相应的动作事件。

getMultiDocPrintServices(DocFlavor[], AttributeSet) - Method in class javax.print. PrintServiceLookup

不被应用程序直接调用

getMultiple() - Method in interface org.w3c.dom.html. HTMLSelectElement

如果为true，则可以在此 SELECT选择多个 OPTION元素。

getMultipleDocumentHandling() - Method in class java.awt. JobAttributes

指定对使用这些属性的作业处理多个副本（包括排序规则）。

getMultiplier() - Method in class java.text. DecimalFormat

以百分比，每mille和类似格式获取乘数。

getMultiplierX() - Method in class javafx.scene.input. ScrollEvent

获取用于将鼠标滚轮旋转单位转换为像素的乘数

getMultiplierY() - Method in class javafx.scene.input. ScrollEvent

获取用于将鼠标滚轮旋转单位转换为像素的乘数

getMustUnderstand() - Method in interface javax.xml.soap. SOAPHeaderElement

返回此 SOAPHeaderElement的mustUnderstand属性的布尔值。

getMute() - Method in interface javax.sound.midi. MidiChannel

获取此通道的当前静音状态。

getMutualAuthState() - Method in interface org.ietf.jgss. GSSContext

确定在此上下文中是否启用了相互验证。

getMxx() - Method in class javafx.scene.transform. Affine

获取属性mxx的值。

getMxx() - Method in class javafx.scene.transform. Rotate

getMxx() - Method in class javafx.scene.transform. Scale

getMxx() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的X坐标缩放元素。

getMxy() - Method in class javafx.scene.transform. Affine

获取属性mxy的值。

getMxy() - Method in class javafx.scene.transform. Rotate

getMxy() - Method in class javafx.scene.transform. Shear

getMxy() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的XY坐标元素。

getMxz() - Method in class javafx.scene.transform. Affine

获取属性mxz的值。

getMxz() - Method in class javafx.scene.transform. Rotate

getMxz() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的XZ坐标元素。

getMyx() - Method in class javafx.scene.transform. Affine

获取属性myx的值。

getMyx() - Method in class javafx.scene.transform. Rotate

getMyx() - Method in class javafx.scene.transform. Shear

getMyx() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的YX坐标元素。

getMyy() - Method in class javafx.scene.transform. Affine

获取属性myy的价值。

getMyy() - Method in class javafx.scene.transform. Rotate

getMyy() - Method in class javafx.scene.transform. Scale

getMyy() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的Y坐标缩放元素。

getMyz() - Method in class javafx.scene.transform. Affine

获取属性myz的值。

getMyz() - Method in class javafx.scene.transform. Rotate

getMyz() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的YZ坐标元素。

getMzx() - Method in class javafx.scene.transform. Affine

获取属性mzx的值。

getMzx() - Method in class javafx.scene.transform. Rotate

getMzx() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的ZX坐标元素。

getMzy() - Method in class javafx.scene.transform. Affine

获取属性mzy的值。

getMzy() - Method in class javafx.scene.transform. Rotate

getMzy() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的ZY坐标元素。

getMzz() - Method in class javafx.scene.transform. Affine

获取属性mzz的值。

getMzz() - Method in class javafx.scene.transform. Rotate

getMzz() - Method in class javafx.scene.transform. Scale

getMzz() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的Z坐标缩放元素。

getName() - Method in class com.sun.management. VMOption

返回此VM选项的名称。

getName() - Method in class com.sun.net.httpserver. HttpPrincipal

以 realm：username格式返回此主体的内容

getName() - Method in class com.sun.security.auth. LdapPrincipal

返回最初用于创建此主体的名称。

getName() - Method in class com.sun.security.auth.module. NTSystem

获取当前NT用户的用户名。

getName() - Method in class com.sun.security.auth. NTDomainPrincipal

返回这个 NTDomainPrincipal的Windows NT域名。

getName() - Method in class com.sun.security.auth. NTSid

返回这个 NTSid的字符串版本。

getName() - Method in class com.sun.security.auth. NTUserPrincipal

返回这个 NTPrincipal的Windows NT用户名。

getName() - Method in class com.sun.security.auth. SolarisNumericGroupPrincipal

已过时。

返回此 SolarisNumericGroupPrincipal的用户组标识号（GID）。

getName() - Method in class com.sun.security.auth. SolarisNumericUserPrincipal

已过时。

返回此 SolarisNumericUserPrincipal的用户标识号（UID）。

getName() - Method in class com.sun.security.auth. SolarisPrincipal

已过时。

返回此 SolarisPrincipal的Unix用户名。

getName() - Method in class com.sun.security.auth. UnixNumericGroupPrincipal

返回此 UnixNumericGroupPrincipal的用户组标识号（GID）。

getName() - Method in class com.sun.security.auth. UnixNumericUserPrincipal

返回此 UnixNumericUserPrincipal的用户标识号（UID）。

getName() - Method in class com.sun.security.auth. UnixPrincipal

返回此 UnixPrincipal的Unix用户名。

getName() - Method in class com.sun.security.auth. UserPrincipal

返回此主体的名称。

getName() - Method in class com.sun.security.auth. X500Principal

已过时。

返回此 X500Principal的Unix用户名。

getName() - Method in interface com.sun.source.doctree. AttributeTree

返回属性的名称。

getName() - Method in interface com.sun.source.doctree. AuthorTree

返回作者的名称。

getName() - Method in interface com.sun.source.doctree. EndElementTree

返回此元素的名称。

getName() - Method in interface com.sun.source.doctree. EntityTree

返回实体的名称或值。

getName() - Method in interface com.sun.source.doctree. IdentifierTree

返回标识符的名称。

getName() - Method in interface com.sun.source.doctree. ParamTree

返回参数的名称。

getName() - Method in interface com.sun.source.doctree. SerialFieldTree

返回串行字段的名称。

getName() - Method in interface com.sun.source.doctree. StartElementTree

返回元素的名称。

getName() - Method in interface com.sun.source.tree. IdentifierTree

返回标识符的名称。

getName() - Method in interface com.sun.source.tree. MemberReferenceTree

返回引用的名称。

getName() - Method in interface com.sun.source.tree. MethodTree

返回正在声明的方法的名称。

getName() - Method in interface com.sun.source.tree. ModuleTree

返回模块的名称。

getName() - Method in interface com.sun.source.tree. TypeParameterTree

返回type参数的名称。

getName() - Method in interface com.sun.source.tree. VariableTree

返回正在声明的变量的名称。

getName() - Method in interface com.sun.source.util. Plugin

返回此插件的用户友好名称。

getName() - Method in interface com.sun.tools.doclets. Taglet

已过时。

返回此自定义标签的名称。

getName() - Method in class java.awt. Component

获取组件的名称。

getName() - Method in class java.awt. Cursor

返回此游标的名称。

getName() - Method in class java.awt.datatransfer. Clipboard

返回此剪贴板对象的名称。

getName() - Method in class java.awt. Font

返回此 Font的逻辑名称。

getName() - Method in class java.awt. MenuComponent

获取菜单组件的名称。

getName() - Method in class java.beans. FeatureDescriptor

获取此功能的编程名称。

getName() - Method in class java.io. File

返回由此抽象路径名表示的文件或目录的名称。

getName() - Method in class java.io. ObjectStreamClass

返回此描述符描述的类的名称。

getName() - Method in class java.io. ObjectStreamField

获取此字段的名称。

getName() - Method in class java.lang. Class

返回由该 Class对象表示的实体的名称（类，接口，数组类，原始类型或无效），为 String 。

getName() - Method in class java.lang. ClassLoader

如果此类加载器未命名，则返回此类加载器的名称或 null 。

getName() - Method in interface java.lang.invoke. MethodHandleInfo

返回破解方法句柄的底层成员的名称。

getName() - Method in interface java.lang.management. BufferPoolMXBean

返回表示此缓冲池的名称。

getName() - Method in interface java.lang.management. CompilationMXBean

返回即时（JIT）编译器的名称。

getName() - Method in interface java.lang.management. MemoryManagerMXBean

返回表示此内存管理器的名称。

getName() - Method in interface java.lang.management. MemoryPoolMXBean

返回表示此内存池的名称。

getName() - Method in interface java.lang.management. OperatingSystemMXBean

返回操作系统名称。

getName() - Method in interface java.lang.management. RuntimeMXBean

返回表示正在运行的Java虚拟机的名称。

getName() - Method in class java.lang. Module

如果此模块是未命名模块，则返回模块名称或 null 。

getName() - Method in class java.lang. 软件包

返回此包的名称。

getName() - Method in class java.lang.reflect. Constructor

以字符串形式返回此构造函数的名称。

getName() - Method in class java.lang.reflect. Executable

返回由此对象表示的可执行文件的名称。

getName() - Method in class java.lang.reflect. Field

返回由此 Field对象表示的字段的名称。

getName() - Method in interface java.lang.reflect. Member

返回由此成员表示的基础成员或构造函数的简单名称。

getName() - Method in class java.lang.reflect. 方法

返回由该 方法对象表示的方法的名称，作为 String 。

getName() - Method in class java.lang.reflect. Parameter

返回参数的名称。

getName() - Method in interface java.lang.reflect. TypeVariable

返回此类型变量的名称，因为它在源代码中出现。

getName() - Method in interface java.lang. System.Logger

返回此记录器的名称。

getName() - Method in enum java.lang. System.Logger.Level

返回此级别的名称。

getName() - Method in class java.lang. Thread

返回此线程的名称。

getName() - Method in class java.lang. ThreadGroup

返回此线程组的名称。

getName() - Method in class java.net. HttpCookie

返回cookie的名称。

getName() - Method in class java.net. NetworkInterface

获取此网络接口的名称。

getName() - Method in exception java.nio.file.attribute. UserPrincipalNotFoundException

如果使用未找到的用户主体名称创建此异常，则返回用户主体名称，否则为 null 。

getName() - Method in interface java.security.acl. Acl

已过时。

返回此ACL的名称。

getName() - Method in class java.security. Identity

已过时。

返回此身份的名称。

getName() - Method in interface java.security. KeyStore.Entry.Attribute

返回属性的名称。

getName() - Method in class java.security. Permission

返回此权限的名称。

getName() - Method in class java.security. PKCS12Attribute

返回表示为点分隔整数列表的属性的ASN.1对象标识符。

getName() - Method in interface java.security. Principal

返回此主体的名称。

getName() - Method in class java.security. Provider

返回此提供程序的名称。

getName() - Method in class java.security.spec. ECGenParameterSpec

返回要生成的EC域参数的标准或预定义名称。

getName() - Method in enum java.sql. JDBCType

返回表示SQL数据类型的 SQLType名称。

getName() - Method in interface java.sql. SQLType

返回表示SQL数据类型的 SQLType名称。

getName() - Method in class java.text. AttributedCharacterIterator.Attribute

返回属性的名称。

getName() - Method in class java.util.logging. Level

返回Level的非本地化字符串名称。

getName() - Method in class java.util.logging. Logger

获取此记录器的名称。

getName() - Method in class java.util.zip. ZipEntry

返回条目的名称。

getName() - Method in class java.util.zip. ZipFile

返回ZIP文件的路径名。

getName() - Method in class javafx.animation. KeyFrame

返回这 name的 KeyFrame 。

getName() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. JavaBeanStringProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoubleProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringProperty

返回此属性的名称。

getName() - Method in interface javafx.beans.property. ReadOnlyProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleBooleanProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleDoubleProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleFloatProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleIntegerProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleListProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleLongProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleMapProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleObjectProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleSetProperty

返回此属性的名称。

getName() - Method in class javafx.beans.property. SimpleStringProperty

返回此属性的名称。

getName() - Method in class javafx.css. SimpleSelector

getName() - Method in class javafx.css. SimpleStyleableBooleanProperty

返回此属性的名称。

getName() - Method in class javafx.css. SimpleStyleableDoubleProperty

返回此属性的名称。

getName() - Method in class javafx.css. SimpleStyleableFloatProperty

返回此属性的名称。

getName() - Method in class javafx.css. SimpleStyleableIntegerProperty

返回此属性的名称。

getName() - Method in class javafx.css. SimpleStyleableLongProperty

返回此属性的名称。

getName() - Method in class javafx.css. SimpleStyleableObjectProperty

返回此属性的名称。

getName() - Method in class javafx.css. SimpleStyleableStringProperty

返回此属性的名称。

getName() - Method in class javafx.event. EventType

获取此事件类型的名称。

getName() - Method in class javafx.print. Paper

获取论文名称。

getName() - Method in class javafx.print. PaperSource

返回此纸张来源的名称。

getName() - Method in class javafx.print. Printer

返回基础系统使用的名称，以便向用户和/或应用程序标识打印机。

getName() - Method in class javafx.scene.chart. PieChart.Data

获取属性名称的值。

getName() - Method in class javafx.scene.chart. XYChart.Series

获取属性名称的值。

getName() - Method in class javafx.scene.input. KeyCharacterCombination

返回此 KeyCharacterCombination的字符串表示 KeyCharacterCombination 。

getName() - Method in enum javafx.scene.input. KeyCode

获取此密钥代码的名称。

getName() - Method in class javafx.scene.input. KeyCodeCombination

返回此 KeyCodeCombination的字符串表示 KeyCodeCombination 。

getName() - Method in class javafx.scene.input. KeyCombination

返回此 KeyCombination的字符串表示 KeyCombination 。

getName() - Method in class javafx.scene.media. Track

检索轨道的名称。

getName() - Method in class javafx.scene.text. Font

完整的字体名称。

getName() - Method in class javax.accessibility. AccessibilityProvider

返回此服务提供商的名称。

getName() - Method in class javax.activation. DataHandler

返回数据对象的名称。

getName() - Method in interface javax.activation. DataSource

返回此对象，其中对象的名称是依赖于底层的对象的性质 名称 。

getName() - Method in class javax.activation. FileDataSource

返回此对象的 名称 。

getName() - Method in class javax.activation. URLDataSource

在用于实例化对象的URL上调用 getFile方法。

getName() - Method in class javax.crypto. ExemptionMechanism

返回此 ExemptionMechanism对象的豁免机制名称。

getName() - Method in class javax.imageio.plugins.tiff. TIFFTag

返回标记的名称，因为它将显示在图像元数据中。

getName() - Method in interface javax.jnlp. FileContents

获取文件名为 String 。

getName() - Method in class javax.management. Attribute

返回一个包含属性名称的String。

getName() - Method in class javax.management.loading. MLetContent

获取 MLET标签的 NAME属性的值。

getName() - Method in class javax.management. MBeanFeatureInfo

返回功能的名称。

getName() - Method in interface javax.management.openmbean. OpenMBeanConstructorInfo

返回此 OpenMBeanConstructorInfo实例描述的构造函数的名称。

getName() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo

返回此 OpenMBeanOperationInfo实例描述的操作的名称。

getName() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回此 OpenMBeanParameterInfo实例描述的参数的名称。

getName() - Method in class javax.management.relation. RoleInfo

返回角色的名称。

getName() - Method in class javax.management.remote. JMXPrincipal

返回此主体的名称。

getName() - Method in class javax.naming. NameClassPair

检索此绑定的名称。

getName() - Method in class javax.net.ssl. SSLSessionBindingEvent

返回对象被绑定到的名称，或者对象被绑定的名称。

getName() - Method in interface javax.print.attribute. Attribute

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Chromaticity

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. ColorSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Compression

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Copies

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. CopiesSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. DateTimeAtCompleted

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. DateTimeAtCreation

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. DateTimeAtProcessing

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Destination

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. DialogTypeSelection

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. DocumentName

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Fidelity

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Finishings

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobHoldUntil

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobImpressions

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobImpressionsCompleted

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobImpressionsSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobKOctets

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobKOctetsProcessed

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobKOctetsSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobMediaSheets

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobMediaSheetsCompleted

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobMediaSheetsSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobMessageFromOperator

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobName

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobOriginatingUserName

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobPriority

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobPrioritySupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobSheets

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobState

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobStateReason

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. JobStateReasons

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Media

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. MediaPrintableArea

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. MediaSize

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. MultipleDocumentHandling

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. NumberOfDocuments

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. NumberOfInterveningJobs

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. NumberUp

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. NumberUpSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. OrientationRequested

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. OutputDeviceAssigned

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PageRanges

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PagesPerMinute

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PagesPerMinuteColor

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PDLOverrideSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PresentationDirection

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterInfo

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterIsAcceptingJobs

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterLocation

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterMakeAndModel

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterMessageFromOperator

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterMoreInfo

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterMoreInfoManufacturer

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterName

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterResolution

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterState

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterStateReason

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterStateReasons

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrinterURI

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. PrintQuality

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. QueuedJobCount

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. ReferenceUriSchemesSupported

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. RequestingUserName

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Severity

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. SheetCollate

获取此属性值是一个实例的类别的名称。

getName() - Method in class javax.print.attribute.standard. Sides

获取此属性值是一个实例的类别的名称。

getName() - Method in interface javax.print. PrintService

返回此打印服务的字符串名称，可由应用程序用于请求特定打印服务。

getName() - Method in class javax.security.auth.callback. NameCallback

获取检索到的名称。

getName() - Method in class javax.security.auth.kerberos. KerberosPrincipal

返回的字符串对应于 RFC 1964的第2.1节中指定的Kerberos主体名称的单字符串表示 形式 。

getName() - Method in class javax.security.auth.x500. X500Principal

使用RFC 2253中定义的格式返回X.500可分辨名称的字符串表示形式。

getName() - Method in class javax.smartcardio. CardTerminal

返回此终端的唯一名称。

getName() - Method in class javax.sound.midi. MidiDevice.Info

获取设备的名称。

getName() - Method in interface javax.sound.midi. Soundbank

获取声音库的名称。

getName() - Method in class javax.sound.midi. SoundbankResource

获取资源的名称。

getName() - Method in class javax.sound.sampled. Mixer.Info

获取混音器的名称。

getName() - Method in class javax.sound.sampled. Port.Info

获取端口的名称。

getName() - Method in class javax.sound.sampled. ReverbType

获取此混响类型的名称。

getName() - Method in class javax.swing. LookAndFeel

返回一个标识这种外观和感觉的短字符串，例如

getName() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回此主题的名称。

getName() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

返回这种外观的名称。

getName() - Method in class javax.swing.plaf.metal. MetalTheme

返回此主题的名称。

getName() - Method in class javax.swing.plaf.metal. OceanTheme

返回这个主题的名称，“海洋”。

getName() - Method in class javax.swing.plaf.multi. MultiLookAndFeel

返回适合在菜单中使用的字符串，用于标识这种外观。

getName() - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

返回一个标识这种外观和感觉的短字符串。

getName() - Method in class javax.swing.plaf.synth. Region

返回区域的名称。

getName() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回一个标识这种外观和感觉的短字符串。

getName() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取元素的名称。

getName() - Method in class javax.swing.text. AbstractDocument.BranchElement

获取元素名称。

getName() - Method in class javax.swing.text. AbstractDocument.LeafElement

获取元素名称。

getName() - Method in class javax.swing.text. DefaultStyledDocument.SectionElement

获取元素的名称。

getName() - Method in interface javax.swing.text. Element

获取元素的名称。

getName() - Method in class javax.swing.text.html. HTMLDocument.BlockElement

获取元素的名称。

getName() - Method in class javax.swing.text.html. HTMLDocument.RunElement

获取元素的名称。

getName() - Method in class javax.swing.text.html.parser. AttributeList

getName() - Method in class javax.swing.text.html.parser. DTD

获取DTD的名称。

getName() - Method in class javax.swing.text.html.parser. Element

获取元素的名称。

getName() - Method in class javax.swing.text.html.parser. Entity

获取实体的名称。

getName() - Method in interface javax.swing.text. Keymap

获取一组键绑定的名称。

getName() - Method in interface javax.swing.text. Style

获取样式的名称。

getName() - Method in class javax.swing.text. StyleContext.NamedStyle

获取样式的名称。

getName() - Method in class javax.swing. UIManager.LookAndFeelInfo

以适合于菜单或其他演示的形式返回外观的名称

getName() - Method in enum javax.tools. DocumentationTool.Location

getName() - Method in interface javax.tools. FileObject

返回此文件对象的用户友好名称。

getName() - Method in class javax.tools. ForwardingFileObject

getName() - Method in interface javax.tools. JavaFileManager.Location

返回此位置的名称。

getName() - Method in class javax.tools. SimpleJavaFileObject

getName() - Method in enum javax.tools. StandardLocation

getName() - Method in class javax.xml.bind. JAXBElement

返回xml元素标签名称。

getName() - Method in interface javax.xml.crypto.dsig.keyinfo. KeyName

返回此 KeyName的名称。

getName() - Method in class javax.xml.soap. MimeHeader

返回此 MimeHeader对象的名称。

getName() - Method in interface javax.xml.stream.events. Attribute

返回此属性的QName

getName() - Method in interface javax.xml.stream.events. EndElement

获取此事件的名称

getName() - Method in interface javax.xml.stream.events. EntityDeclaration

实体的名字

getName() - Method in interface javax.xml.stream.events. EntityReference

实体的名称

getName() - Method in interface javax.xml.stream.events. NotationDeclaration

符号名称。

getName() - Method in interface javax.xml.stream.events. StartElement

获取此事件的名称

getName() - Method in class javax.xml.stream.util. StreamReaderDelegate

getName() - Method in interface javax.xml.stream. XMLStreamReader

返回当前START_ELEMENT或END_ELEMENT活动的QName

getName() - Method in class jdk.dynalink. NamedOperation

返回此命名操作的名称。

getName() - Method in interface jdk.javadoc.doclet. Doclet

返回标识doclet的名称。

getName() - Method in class jdk.javadoc.doclet. StandardDoclet

getName() - Method in interface jdk.javadoc.doclet. Taglet

返回标签的名称。

getName() - Method in interface jdk.nashorn.api.tree. ClassDeclarationTree

类标识符

getName() - Method in interface jdk.nashorn.api.tree. ClassExpressionTree

类标识符

getName() - Method in interface jdk.nashorn.api.tree. FunctionDeclarationTree

返回正在声明的函数的名称。

getName() - Method in interface jdk.nashorn.api.tree. FunctionExpressionTree

返回正在声明的函数的名称。

getName() - Method in interface jdk.nashorn.api.tree. IdentifierTree

返回此标识符的名称。

getName() - Method in interface org.ietf.jgss. GSSCredential

检索证书所声明的实体的名称。

getName() - Method in interface org.w3c.dom. Attr

返回此属性的名称。

getName() - Method in interface org.w3c.dom. DocumentType

DTD的名称 即紧随DOCTYPE关键字后的名称。

getName() - Method in interface org.w3c.dom.html. HTMLAnchorElement

锚点名称

getName() - Method in interface org.w3c.dom.html. HTMLAppletElement

小程序的名称。

getName() - Method in interface org.w3c.dom.html. HTMLButtonElement

表单控件或表单提交时的对象名称。

getName() - Method in interface org.w3c.dom.html. HTMLFormElement

命名表格。

getName() - Method in interface org.w3c.dom.html. HTMLFrameElement

框架名称（ target属性的对象）。

getName() - Method in interface org.w3c.dom.html. HTMLIFrameElement

框架名称（ target属性的对象）。

getName() - Method in interface org.w3c.dom.html. HTMLImageElement

元素的名称（用于向后兼容）。

getName() - Method in interface org.w3c.dom.html. HTMLInputElement

表单控件或表单提交时的对象名称。

getName() - Method in interface org.w3c.dom.html. HTMLMapElement

命名地图（与 usemap一起使用）。

getName() - Method in interface org.w3c.dom.html. HTMLMetaElement

元信息名称。

getName() - Method in interface org.w3c.dom.html. HTMLObjectElement

表单控件或表单提交时的对象名称。

getName() - Method in interface org.w3c.dom.html. HTMLParamElement

运行时参数的名称。

getName() - Method in interface org.w3c.dom.html. HTMLSelectElement

表单控件或表单提交时的对象名称。

getName() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

表单控件或表单提交时的对象名称。

getName(int) - Method in class java.awt.color. ColorSpace

返回给定组件索引的组件的名称。

getName(int) - Static method in class java.lang. Character

返回指定字符的Unicode名称 codePoint ，如果代码点为 unassigned ，则返回null。

getName(int) - Method in interface java.nio.file. Path

将此路径的名称元素作为 Path对象返回。

getName(int) - Method in interface org.w3c.dom. NameList

返回集合中的 index th名称项。

getName(int) - Method in interface org.xml.sax. AttributeList

已过时。

返回此列表中的属性名称（按位置）。

getName(int) - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

获取属性的名称（按位置）。

getName(File) - Method in class javax.swing.filechooser. FileView

文件的名称。

getName(File) - Method in class javax.swing. JFileChooser

返回文件名。

getName(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

文件的名称。

getName(CharSequence) - Method in interface javax.lang.model.util. Elements

返回与参数相同的字符序列的名称。

getName(String) - Method in class javax.security.auth.x500. X500Principal

使用指定的格式返回X.500可分辨名称的字符串表示形式。

getName(String, Map<String, String>) - Method in class javax.security.auth.x500. X500Principal

使用指定的格式返回X.500可分辨名称的字符串表示形式。

getName(Operation) - Static method in class jdk.dynalink. NamedOperation

如果传递的操作是命名操作，则返回其 NamedOperation.getName() ，否则返回null。

getName(Oid) - Method in interface org.ietf.jgss. GSSCredential

检索机制凭证声明的实体的名称。

getNameConstraints() - Method in class java.security.cert. TrustAnchor

返回名称约束参数。

getNameConstraints() - Method in class java.security.cert. X509CertSelector

返回名称约束条件。

getNameCount() - Method in interface java.nio.file. Path

返回路径中的名称元素的数量。

getNamed() - Method in class javafx.application. Application.Parameters

检索命名参数的只读映射。

getNamedItem(String) - Method in interface org.w3c.dom. NamedNodeMap

检索由name指定的节点。

getNamedItemNS(String, String) - Method in interface org.w3c.dom. NamedNodeMap

检索由本地名称和命名空间URI指定的节点。

getNamedValues() - Method in class javax.imageio.plugins.tiff. TIFFTag

返回定义助记符名称的值的数组。

getNameExpression() - Method in interface com.sun.source.tree. VariableTree

返回名称为“声明”的合格标识符。

getNameInNamespace() - Method in interface javax.naming. Context

在其自己的命名空间中检索此上下文的全名。

getNameInNamespace() - Method in class javax.naming. InitialContext

getNameInNamespace() - Method in class javax.naming. NameClassPair

检索此绑定的全名。

getNameParser(String) - Method in interface javax.naming. Context

检索与命名上下文关联的解析器。

getNameParser(String) - Method in class javax.naming. InitialContext

getNameParser(Name) - Method in interface javax.naming. Context

检索与命名上下文关联的解析器。

getNameParser(Name) - Method in class javax.naming. InitialContext

getNames() - Method in class javax.activation. MimeTypeParameterList

检索此列表中所有名称的枚举。

getNames() - Method in interface javax.script. ScriptEngineFactory

返回短名称的不可变列表 ScriptEngine ，可用于识别 ScriptEngine由 ScriptEngineManager 。

getNames() - Method in interface jdk.javadoc.doclet. Doclet.Option

返回可用于标识该选项的名称列表。

getNames() - Method in class jdk.jshell. SourceCodeAnalysis.QualifiedNames

原始代码中给定简单名称的已知限定名称。

getNames() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getNames(URL) - Method in interface javax.jnlp. PersistenceService

返回一个字符串数组，其中包含给定URL的所有条目的名称。

getNamesForMech(Oid) - Method in class org.ietf.jgss. GSSManager

返回指定机制支持的名称类型。

getNamespace() - Method in class javafx.fxml. FXMLLoader

返回此装载器使用的命名空间。

getNamespace(int) - Method in class jdk.dynalink. NamespaceOperation

返回此命名空间操作中的第i个命名空间。

getNamespaceContext() - Method in interface javax.xml.stream.events. StartElement

获取只读命名空间上下文。

getNamespaceContext() - Method in class javax.xml.stream.util. StreamReaderDelegate

getNamespaceContext() - Method in interface javax.xml.stream. XMLEventWriter

返回当前的命名空间上下文。

getNamespaceContext() - Method in interface javax.xml.stream. XMLStreamReader

返回当前位置的只读命名空间上下文。

getNamespaceContext() - Method in interface javax.xml.stream. XMLStreamWriter

返回当前的命名空间上下文。

getNamespaceContext() - Method in interface javax.xml.xpath. XPath

返回当前命名空间上下文。

getNamespaceCount() - Method in class javax.xml.stream.util. StreamReaderDelegate

getNamespaceCount() - Method in interface javax.xml.stream. XMLStreamReader

返回在此START_ELEMENT或END_ELEMENT上声明的命名空间数，此方法仅适用于START_ELEMENT，END_ELEMENT或NAMESPACE。

getNamespaceCount() - Method in class jdk.dynalink. NamespaceOperation

返回此命名空间操作中的命名空间数。

getNamespaceMap() - Method in class javax.xml.crypto.dsig.spec. XPathFilterParameterSpec

返回名称空间前缀的映射。

getNamespaceMap() - Method in class javax.xml.crypto.dsig.spec. XPathType

返回名称空间前缀的映射。

getNamespacePrefix(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getNamespacePrefix(int) - Method in interface javax.xml.stream. XMLStreamReader

返回在索引处声明的命名空间的前缀。

getNamespacePrefix(String, String) - Method in class javax.xml.crypto.dom. DOMCryptoContext

此实现使用内部HashMap获取指定的URI映射到的前缀。

getNamespacePrefix(String, String) - Method in interface javax.xml.crypto. XMLCryptoContext

返回指定的命名空间URI与之关联的命名空间前缀。

getNamespacePrefixes() - Method in interface javax.xml.soap. SOAPElement

返回一个 Iterator在命名空间前缀 String此元素声明秒。

getNamespaces() - Method in interface javax.xml.stream.events. EndElement

返回超出范围的命名空间的迭代器。

getNamespaces() - Method in interface javax.xml.stream.events. StartElement

返回在此元素上声明的命名空间的迭代器。

getNamespaces() - Method in class jdk.dynalink. NamespaceOperation

返回此命名空间操作中的命名空间。

getNamespaces(Operation) - Static method in class jdk.dynalink. NamespaceOperation

如果传递的操作是命名空间操作，则返回其 NamespaceOperation.getNamespaces() ，否则返回一个空数组。

getNamespaceURI() - Method in class javax.imageio.metadata. IIOMetadataNode

返回 null ，因为不支持命名空间。

getNamespaceURI() - Method in class javax.xml.namespace. QName

获取此 QName的命名空间URI。

getNamespaceURI() - Method in interface javax.xml.stream.events. Namespace

获取绑定到此名称空间前缀的uri

getNamespaceURI() - Method in class javax.xml.stream.util. StreamReaderDelegate

getNamespaceURI() - Method in interface javax.xml.stream. XMLStreamReader

如果当前事件是START_ELEMENT或END_ELEMENT，则此方法返回前缀或缺省命名空间的URI。

getNamespaceURI() - Method in interface org.w3c.dom. Node

该节点的命名空间URI，如果未指定，请参阅 null （参见）。

getNamespaceURI(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getNamespaceURI(int) - Method in interface javax.xml.stream. XMLStreamReader

返回在索引处声明的命名空间的uri。

getNamespaceURI(int) - Method in interface org.w3c.dom. NameList

返回集合中的 index th namespaceURI项目。

getNamespaceURI(String) - Method in interface javax.xml.namespace. NamespaceContext

获取命名空间URI绑定到当前作用域中的前缀。

getNamespaceURI(String) - Method in interface javax.xml.soap. SOAPElement

返回具有给定前缀的命名空间的URI。

getNamespaceURI(String) - Method in interface javax.xml.stream.events. StartElement

在该元素的上下文中获取前缀所绑定的值。

getNamespaceURI(String) - Method in class javax.xml.stream.util. StreamReaderDelegate

getNamespaceURI(String) - Method in interface javax.xml.stream. XMLStreamReader

返回给定前缀的uri。

getNameType() - Method in class javax.security.auth.kerberos. KerberosPrincipal

返回 KerberosPrincipal的名称类型。

getNaN() - Method in class java.text. DecimalFormatSymbols

获取用于表示“不是数字”的字符串。

getNano() - Method in class java.time. Duration

在此持续时间内获得第二秒内的纳秒数。

getNano() - Method in class java.time. Instant

从第二个开始就从时间线获得纳秒的数量。

getNano() - Method in class java.time. LocalDateTime

获得纳秒第二场。

getNano() - Method in class java.time. LocalTime

获得纳秒第二场。

getNano() - Method in class java.time. OffsetDateTime

获得纳秒第二场。

getNano() - Method in class java.time. OffsetTime

获得纳秒第二场。

getNano() - Method in class java.time. ZonedDateTime

获得纳秒第二场。

getNanos() - Method in class java.sql. Timestamp

获取此 Timestamp对象的 nanos值。

getNativeCommands(String) - Method in class javax.activation. MailcapCommandMap

获取给定MIME类型的本机命令。

getNativeContainer(Component) - Static method in class java.awt. Toolkit

给本地对等体提供给本地组件查询本机容器的能力（例如，直接父级可能是轻量级的）。

getNativeImageMetadataFormatName() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回此插件的“本机”图像元数据格式的名称，通常允许以由该插件处理的格式存储的图像元数据的无损编码和传输。

getNativeMetadataFormatName() - Method in class javax.imageio.metadata. IIOMetadata

返回此插件的“本机”元数据格式的名称，通常允许以该插件处理的格式存储的元数据进行无损编码和传输。

getNativesForFlavor(DataFlavor) - Method in interface java.awt.datatransfer. FlavorTable

返回 List的 String当地人到指定 DataFlavor对应。

getNativesForFlavor(DataFlavor) - Method in class java.awt.datatransfer. SystemFlavorMap

返回 List的 String本地数据，数据传输子系统可以转换指定的 DataFlavor 。

getNativesForFlavors(DataFlavor[]) - Method in interface java.awt.datatransfer. FlavorMap

将 Map的 DataFlavor为相应的 String本机。

getNativesForFlavors(DataFlavor[]) - Method in class java.awt.datatransfer. SystemFlavorMap

将 Map的 DataFlavor为最优选的 String本机。

getNativeStreamMetadataFormatName() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回此插件的“本机”流元数据格式的名称，通常允许以该插件处理的格式存储的流元数据进行无损编码和传输。

getNavigationFilter() - Method in class javax.swing. JFormattedTextField.AbstractFormatter

如果您希望提供一个过滤器来限制用户可以导航的位置，则可以使用子类和覆盖。

getNavigationFilter() - Method in class javax.swing.text. DefaultFormatter

返回 NavigationFilter用于限制光标放置的位置。

getNavigationFilter() - Method in class javax.swing.text. JTextComponent

返回 NavigationFilter 。

getNbNotifications() - Method in class javax.management.timer. Timer

获取注册到通知列表中的定时器通知的数量。

getNbNotifications() - Method in interface javax.management.timer. TimerMBean

获取注册到通知列表中的定时器通知的数量。

getNbOccurences(Integer) - Method in class javax.management.timer. Timer

获取与定时器通知相关联的剩余发生次数的副本。

getNbOccurences(Integer) - Method in interface javax.management.timer. TimerMBean

获取与定时器通知相关联的剩余发生次数的副本。

getNc() - Method in class javax.smartcardio. CommandAPDU

返回命令体（Nc）中的数据字节数，如果该APDU没有正文，则返回0。

getNCharacterStream(int) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。

getNCharacterStream(int) - Method in interface java.sql. ResultSet

检索 ResultSet对象当前行中指定列的值为 java.io.Reader对象。

getNCharacterStream(String) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。

getNCharacterStream(String) - Method in interface java.sql. ResultSet

检索 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。

getNClob(int) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定的JDBC NCLOB参数的值作为 java.sql.NClob对象。

getNClob(int) - Method in interface java.sql. ResultSet

以Java编程语言的 ResultSet对象的形式 NClob此 ResultSet对象的当前行中指定列的值。

getNClob(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的一个 java.sql.NClob对象获取JDBC NCLOB参数的值。

getNClob(String) - Method in interface java.sql. ResultSet

这个检索的当前行中指定列的值 ResultSet对象为 NClob的Java编程语言对象。

getNe() - Method in class javax.smartcardio. CommandAPDU

返回响应APDU（Ne）中的最大预期数据字节数。

getNearClip() - Method in class javafx.scene. Camera

获取nearClip附近的属性的值。

getNeedClientAuth() - Method in class com.sun.net.httpserver. HttpsParameters

返回是否需要客户端身份验证。

getNeedClientAuth() - Method in class javax.net.ssl. SSLEngine

如果引擎 需要客户端验证，则返回true。

getNeedClientAuth() - Method in class javax.net.ssl. SSLParameters

返回是否需要客户端身份验证。

getNeedClientAuth() - Method in class javax.net.ssl. SSLServerSocket

如果新的 accept ed服务器模式 SSLSocket 需要客户端认证，则返回true。

getNeedClientAuth() - Method in class javax.net.ssl. SSLSocket

如果套接字 需要客户端认证，则返回true。

getNeedClientAuth() - Method in class javax.rmi.ssl. SslRMIServerSocketFactory

如果在此工厂创建的服务器套接字所接受的SSL连接上需要客户端验证，则返回 true 。

getNeededLocation(int, int) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController

返回x参数，因为它用于水平分割。

getNeededLocation(int, int) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.VerticalDragController

返回y参数，因为它用于垂直分割。

getNegativePrefix() - Method in class java.text. DecimalFormat

获取负前缀。

getNegativeSign() - Method in class java.time.format. DecimalStyle

获取表示负号的字符。

getNegativeSuffix() - Method in class java.text. DecimalFormat

得到负的后缀。

getNegotiatedProperty(String) - Method in interface javax.security.sasl. SaslClient

检索谈判的财产。

getNegotiatedProperty(String) - Method in interface javax.security.sasl. SaslServer

检索谈判的财产。

getNestedException() - Method in exception javax.xml.stream. XMLStreamException

获取嵌套的异常。

getNestingKind() - Method in interface javax.lang.model.element. TypeElement

返回此类型元素的 嵌套类型。

getNestingKind() - Method in class javax.tools. ForwardingJavaFileObject

getNestingKind() - Method in interface javax.tools. JavaFileObject

提供关于由该文件对象表示的类的嵌套级别的提示。

getNestingKind() - Method in class javax.tools. SimpleJavaFileObject

此实现返回 null 。

getNetworkInterface() - Method in class java.net. MulticastSocket

获取组播网络接口集。

getNetworkInterfaces() - Static method in class java.net. NetworkInterface

返回本机上所有接口的 Enumeration 。

getNetworkPrefixLength() - Method in class java.net. InterfaceAddress

返回此地址的网络前缀长度。

getNetworkTimeout() - Method in interface java.sql. Connection

检索驱动程序等待数据库请求完成的毫秒数。

getNewBinding() - Method in class javax.naming.event. NamingEvent

在更改后检索对象的绑定。

getNewDocument() - Method in interface org.w3c.dom.ls. LSLoadEvent

完成加载的文档。

getNewFolderAction() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回一个新的文件夹操作。

getNewLeadSelectionPath() - Method in class javax.swing.event. TreeSelectionEvent

返回当前引导路径。

getNewLine() - Method in interface org.w3c.dom.ls. LSSerializer

要在XML中使用的字符的行尾序列被写出。

getNewRoleValue() - Method in class javax.management.relation. RelationNotification

返回更新角色的新值（仅适用于角色更新）。

getNewState() - Method in class java.awt.event. WindowEvent

对于 WINDOW_STATE_CHANGED事件返回窗口的新状态。

getNewValue() - Method in class java.beans. PropertyChangeEvent

获取属性的新值，表示为Object。

getNewValue() - Method in class java.util.prefs. PreferenceChangeEvent

返回首选项的新值。

getNewValue() - Method in class javafx.scene.control. ListView.EditEvent

返回最终用户提供的新输入的值。

getNewValue() - Method in class javafx.scene.control. TableColumn.CellEditEvent

返回最终用户输入的新值。

getNewValue() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent

如果TreeItem的值已更改，则此方法将返回新值。

getNewValue() - Method in class javafx.scene.control. TreeTableColumn.CellEditEvent

返回最终用户输入的新值。

getNewValue() - Method in class javafx.scene.control. TreeTableView.EditEvent

返回最终用户输入到TreeItem的新值。

getNewValue() - Method in class javafx.scene.control. TreeView.EditEvent

返回最终用户输入到TreeItem的新值。

getNewValue() - Method in class javax.management. AttributeChangeNotification

获取已更改的属性的新值。

getNewValue() - Method in interface org.w3c.dom.events. MutationEvent

newValue表示的新值 Attr在DOMAttrModified事件节点和的 CharacterData在DOMCharacterDataModified事件节点。

getNext() - Method in class javax.swing.text.html.parser. AttributeList

getNextEastWestVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. CompositeView

返回光标的下一个视觉位置，以东或西方向。

getNextElementSibling() - Method in interface org.w3c.dom. ElementTraversal

返回对文档顺序中最紧随元素的元素的兄弟节点的引用，并且是Element类型的元素 。

getNextEntry() - Method in class java.util.jar. JarInputStream

读取下一个ZIP文件条目，并将流定位在条目数据的开头。

getNextEntry() - Method in class java.util.zip. ZipInputStream

读取下一个ZIP文件条目，并将流定位在条目数据的开头。

getNextEvent() - Method in class java.awt. EventQueue

从 EventQueue删除事件并返回。

getNextException() - Method in exception java.sql. SQLException

通过setNextException（SQLException ex）检索链接到此 SQLException对象的异常。

getNextFocusableComponent() - Method in class javax.swing. JComponent

已过时。
截至1.4，由FocusTraversalPolicy取代。

getNextJarEntry() - Method in class java.util.jar. JarInputStream

读取下一个JAR文件条目，并将流定位在条目数据的开头。

getNextLeaf() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点之后的叶，如果此节点是树中的最后一个叶，则返回null。

getNextLeftHit(int) - Method in class java.awt.font. TextLayout

返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。

getNextLeftHit(int, TextLayout.CaretPolicy) - Method in class java.awt.font. TextLayout

返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。

getNextLeftHit(TextHitInfo) - Method in class java.awt.font. TextLayout

返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。

getNextMatch(String, int, Position.Bias) - Method in class javax.swing. JList

返回下一个列表元素，其 toString值以给定的前缀开头。

getNextMatch(String, int, Position.Bias) - Method in class javax.swing. JTree

将TreePath返回到以前缀开头的下一个树元素。

getNextNode() - Method in class javax.swing.tree. DefaultMutableTreeNode

在此节点的树的预序遍历中返回此节点后面的节点。

getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. CompositeView

返回光标的下一个视觉位置，在北或南方向。

getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. ParagraphView

返回光标的下一个视觉位置，以东或西方向。

getNextRightHit(int) - Method in class java.awt.font. TextLayout

返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。

getNextRightHit(int, TextLayout.CaretPolicy) - Method in class java.awt.font. TextLayout

返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。

getNextRightHit(TextHitInfo) - Method in class java.awt.font. TextLayout

返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。

getNextSequenceNumber() - Method in class javax.management.remote. NotificationResult

返回可用于查询的下一个通知的序列号。

getNextSibling() - Method in class javax.imageio.metadata. IIOMetadataNode

返回此节点的下一个兄弟节点，如果该节点没有下一个兄弟节点，则返回 null 。

getNextSibling() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回父节点的子节点数组中该节点的下一个兄弟节点。

getNextSibling() - Method in class javax.xml.crypto.dsig.dom. DOMSignContext

返回nextSibling节点。

getNextSibling() - Method in class javax.xml.transform.dom. DOMResult

获取子节点之前，将插入结果节点。

getNextSibling() - Method in interface org.w3c.dom. Node

紧随该节点的节点。

getNextTabIndex(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回下一个选项卡索引。

getNextTabIndexInRun(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回运行中的下一个选项卡索引。

getNextTabRun(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回下一个选项卡运行。

getNextUpdate() - Method in class java.security.cert. X509CRL

从CRL获取 nextUpdate日期。

getNextValue() - Method in class javax.swing. JSpinner

返回由 getValue()返回的对象之后的序列中的对象。

getNextValue() - Method in class javax.swing. SpinnerDateModel

返回下 Date序列中，或 null如果下一个日期是后 end 。

getNextValue() - Method in class javax.swing. SpinnerListModel

如果值已经是最后一个元素，则返回底层序列的下一个合法值或 null 。

getNextValue() - Method in interface javax.swing. SpinnerModel

按 getValue()返回的对象后面的顺序返回对象。

getNextValue() - Method in class javax.swing. SpinnerNumberModel

返回序列中的下一个数字。

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. AsyncBoxView

提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. CompositeView

提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. GlyphView

提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. View

提供一种方法来确定下一个可视表示的模型位置，在该位置可以放置插入符。

getNextVisualPositionFrom(GlyphView, int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text. GlyphView.GlyphPainter

提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.basic. BasicTextUI

提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getNextVisualPositionFrom方法。

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf. TextUI

提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.text. NavigationFilter

返回下一个视觉位置，从现有位置放置插入符号。

getNextWarning() - Method in exception java.sql. SQLWarning

检索 SQLWarning对象由 setNextWarning链接的警告。

getNextWarning() - Method in exception javax.sql.rowset. RowSetWarning

检索此 RowSetWarning对象链接的警告。

getNextWord(JTextComponent, int) - Static method in class javax.swing.text. Utilities

确定给定位置的下一个字的开始。

getNode() - Method in class java.util.prefs. PreferenceChangeEvent

返回发出事件的首选节点。

getNode() - Method in class javafx.animation. FadeTransition

获取属性节点的值。

getNode() - Method in class javafx.animation. ParallelTransition

获取属性节点的值。

getNode() - Method in class javafx.animation. PathTransition

获取属性节点的值。

getNode() - Method in class javafx.animation. RotateTransition

获取属性节点的值。

getNode() - Method in class javafx.animation. ScaleTransition

获取属性节点的值。

getNode() - Method in class javafx.animation. SequentialTransition

获取属性节点的值。

getNode() - Method in class javafx.animation. TranslateTransition

获取属性节点的值。

getNode() - Method in class javafx.scene.chart. PieChart.Data

返回表示饼图切片的节点。

getNode() - Method in class javafx.scene.chart. XYChart.Data

获取属性节点的值。

getNode() - Method in class javafx.scene.chart. XYChart.Series

获取属性节点的值。

getNode() - Method in class javafx.scene.control.skin. ContextMenuSkin

获取代表此皮肤的节点。

getNode() - Method in interface javafx.scene.control. Skin

获取代表此皮肤的节点。

getNode() - Method in class javafx.scene.control.skin. TooltipSkin

获取代表此皮肤的节点。

getNode() - Method in class javafx.scene.control. SkinBase

获取代表此皮肤的节点。

getNode() - Method in class javafx.scene.input. Mnemonic

返回Node

getNode() - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

getNode() - Method in interface javax.xml.bind. ValidationEventLocator

返回对DOM节点的引用（如果可用）

getNode() - Method in class javax.xml.crypto.dom. DOMStructure

返回此 DOMStructure包含的节点。

getNode() - Method in class javax.xml.crypto.dsig.dom. DOMValidateContext

返回节点。

getNode() - Method in class javax.xml.transform.dom. DOMResult

获取将包含结果DOM树的节点。

getNode() - Method in class javax.xml.transform.dom. DOMSource

获取代表源DOM树的节点。

getNode(Object) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

默认情况下，getNode方法不受支持，并抛出一个UnsupportedOperationException 。

getNode(Object) - Method in interface javax.xml.bind. Marshaller

获取内容树的DOM树视图（可选）。

getNodeDimensions() - Method in class javax.swing.tree. AbstractLayoutCache

返回呈现树中节点的对象，负责计算各个节点的维度。

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.plaf.basic. BasicTreeUI.NodeDimensionsHandler

负责获取特定节点的大小。

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.tree. AbstractLayoutCache

通过参考，返回 placeIn ，代表 value所需的大小。

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.tree. AbstractLayoutCache.NodeDimensions

通过边界的引用返回大小和x的起始位置。

getNodeLevel(TreeItem<?>) - Static method in class javafx.scene.control. TreeTableView

已过时。
此方法无法正确计算从给定TreeItem到TreeTableView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeTableView.getTreeItemLevel(TreeItem)

getNodeLevel(TreeItem<?>) - Static method in class javafx.scene.control. TreeView

已过时。
此方法无法正确计算从给定TreeItem到TreeView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeView.getTreeItemLevel(TreeItem)

getNodeName() - Method in class javax.imageio.metadata. IIOMetadataNode

返回与此节点相关联的节点名称。

getNodeName() - Method in interface org.w3c.dom. Node

该节点的名称取决于其类型; 见上表。

getNodeOrientation() - Method in class javafx.css. SimpleSelector

getNodeOrientation() - Method in class javafx.scene. Node

获取属性nodeOrientation的值。

getNodeOrientation() - Method in class javafx.scene. Scene

获取属性nodeOrientation的值。

getNodeType() - Method in class javax.imageio.metadata. IIOMetadataNode

返回节点类型，始终为 ELEMENT_NODE 。

getNodeType() - Method in interface org.w3c.dom. Node

代表基础对象的类型的代码，如上所定义。

getNodeValue() - Method in class javax.imageio.metadata. IIOMetadataNode

返回与该节点关联的值。

getNodeValue() - Method in interface org.w3c.dom. Node

该节点的值取决于其类型; 见上表。

getNoFallbackControl(List<String>) - Static method in class java.util. ResourceBundle.Control

返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats ，而 getFallbackLocale方法返回 null 。

getNoHref() - Method in interface org.w3c.dom.html. HTMLAreaElement

指定该区域处于非活动状态，即没有关联的操作。

getNoImageIcon() - Method in class javax.swing.text.html. ImageView

如果找不到图像，则返回要使用的图标。

getNonContinuousLayoutDivider() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

当 JSplitPane配置为不连续布局时，返回使用的分隔符。

getNonCriticalExtensionOIDs() - Method in interface java.security.cert. X509Extension

获取由实现此接口的对象管理的证书/ CRL中标记为“非关键性”的扩展名的OID字符串集。

getNonHeapMemoryUsage() - Method in interface java.lang.management. MemoryMXBean

新新新新旗新新新新旗新新旗新新旗新新旗新新旗旗新新旗新新200新新新旗200新新新新旗：

getNonMatchingHeaders(String[]) - Method in class javax.xml.soap. MimeHeaders

返回名称与给定名称数组中的名称不匹配的所有 MimeHeader对象。

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap. AttachmentPart

检索名称与给定数组中的名称不匹配的所有 MimeHeader对象。

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap. SOAPPart

检索名称与给定数组中的名称不匹配的所有 MimeHeader对象。

getNonRolloverBorder(AbstractButton) - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回按钮的非滚动边框。

getNoNSSchemaLocation() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

获取当前noNamespaceSchemaLocation的便利方法。

getNoResize() - Method in interface org.w3c.dom.html. HTMLFrameElement

当为true时，禁止用户调整框架大小。

getNormalBounds() - Method in class javax.swing. JInternalFrame

如果JInternalFrame未处于最大化状态，则返回getBounds() ; 否则，返回JInternalFrame将被还原的范围。

getNormalElementSize() - Method in class javafx.scene.shape. TriangleMesh

返回表示法线的元素数。

getNormalIndexOffset() - Method in class javafx.scene.shape. VertexFormat

返回顶点中正常分量的面阵列中的索引偏移量。

getNormalizedComponents(int[], int, float[], int) - Method in class java.awt.image. ColorModel

给定一个非规范化的组件数组，以归一化形式返回所有颜色/ alpha分量的数组。

getNormalizedComponents(int[], int, float[], int) - Method in class java.awt.image. ComponentColorModel

给定一个非规范化的组件数组，以归一化形式返回所有颜色/ alpha分量的数组。

getNormalizedComponents(Object, float[], int) - Method in class java.awt.image. ColorModel

在这个 ColorModel给出一个像素，返回所有颜色/ alpha分量的 ColorModel 。

getNormalizedComponents(Object, float[], int) - Method in class java.awt.image. ComponentColorModel

给出这个 ColorModel一个像素，以归一化形式返回所有颜色/ alpha分量的 ColorModel 。

getNormalizingTransform() - Method in class java.awt. GraphicsConfiguration

返回一个 AffineTransform可以与默认级联 AffineTransform一个的 GraphicsConfiguration ，使得单元72在用户空间等于设备空间的1英寸。

getNormals() - Method in class javafx.scene.shape. TriangleMesh

获取 normals阵列如此 TriangleMesh 。

getNorthPane() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回北面。

getNoShade() - Method in interface org.w3c.dom.html. HTMLHRElement

向用户代理指示在渲染此元素时不应有阴影。

getNotAfter() - Method in class java.security.cert. X509Certificate

从证书的有效期获取 notAfter日期。

getNotAfter() - Method in class javax.security.cert. X509Certificate

已过时。

从证书的有效期获取 notAfter日期。

getNotationName() - Method in interface javax.xml.stream.events. EntityDeclaration

关联符号的名称。

getNotationName() - Method in interface org.w3c.dom. Entity

对于未解析的实体，该实体的符号的名称。

getNotations() - Method in interface javax.xml.stream.events. DTD

返回一个包含DTD中声明的符号的列表。

getNotations() - Method in interface org.w3c.dom. DocumentType

A NamedNodeMap包含在DTD中声明的符号。

getNotBefore() - Method in class java.security.cert. X509Certificate

从证书的有效期获取 notBefore日期。

getNotBefore() - Method in class javax.security.cert. X509Certificate

已过时。

从证书的有效期获取 notBefore日期。

getNote() - Method in class javax.swing. ProgressMonitor

指定与进度消息一起显示的附加注释。

getNotification() - Method in class javax.management.remote. TargetedNotification

发出的通知。

getNotification() - Method in class javax.naming.ldap. UnsolicitedNotificationEvent

返回非请求通知。

getNotification(String) - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回名称请求的ModelMBeanNotificationInfo。

getNotification(String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

getNotificationID() - Method in class javax.management.timer. TimerNotification

获取此定时器通知的标识符。

getNotificationIDs(String) - Method in class javax.management.timer. Timer

获取与指定类型相对应的定时器通知的所有标识符。

getNotificationIDs(String) - Method in interface javax.management.timer. TimerMBean

获取与指定类型相对应的定时器通知的所有标识符。

getNotificationInfo() - Method in class javax.management. MBeanServerDelegate

getNotificationInfo() - Method in class javax.management.modelmbean. RequiredModelMBean

返回始终由RequiredModelMBean生成的通知数组。

getNotificationInfo() - Method in class javax.management.monitor. CounterMonitor

返回一个 NotificationInfo对象，其中包含通知的Java类的名称以及计数器监视器发送的通知类型。

getNotificationInfo() - Method in class javax.management.monitor. GaugeMonitor

返回一个 NotificationInfo对象，其中包含通知的Java类的名称以及仪表监视器发送的通知类型。

getNotificationInfo() - Method in class javax.management.monitor. StringMonitor

返回一个 NotificationInfo对象，其中包含通知的Java类的名称以及字符串监视器发送的通知类型。

getNotificationInfo() - Method in interface javax.management. NotificationBroadcaster

返回一个数组，指示MBean可能发送的每个通知，通知的Java类的名称和通知类型。

getNotificationInfo() - Method in class javax.management. NotificationBroadcasterSupport

getNotificationInfo() - Method in class javax.management.relation. RelationService

返回一个NotificationInfo对象，该对象包含通知的Java类的名称以及发送的通知类型。

getNotificationInfo() - Method in class javax.management.remote. JMXConnectorServer

返回一个数组，指示此MBean发送的通知。

getNotificationInfo() - Method in class javax.management. StandardEmitterMBean

getNotificationInfo() - Method in class javax.management.timer. Timer

getNotificationMessage(Integer) - Method in class javax.management.timer. Timer

获取与指定标识符相对应的定时器通知详细消息。

getNotificationMessage(Integer) - Method in interface javax.management.timer. TimerMBean

获取与指定标识符相对应的定时器通知详细消息。

getNotifications() - Method in class javax.management. MBeanInfo

返回MBean发出的通知列表。

getNotifications() - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回MBean发出的通知列表。

getNotifications() - Method in interface javax.management.openmbean. OpenMBeanInfo

返回的数组 MBeanNotificationInfo实例说明通过此描述的开放MBean发出每个通知 OpenMBeanInfo实例。

getNotificationType(Integer) - Method in class javax.management.timer. Timer

获取与指定标识符对应的定时器通知类型。

getNotificationType(Integer) - Method in interface javax.management.timer. TimerMBean

获取与指定标识符对应的定时器通知类型。

getNotificationUserData(Integer) - Method in class javax.management.timer. Timer

获取与指定标识符相对应的定时器通知用户数据对象。

getNotificationUserData(Integer) - Method in interface javax.management.timer. TimerMBean

获取与指定标识符相对应的定时器通知用户数据对象。

getNotifTypes() - Method in class javax.management. MBeanNotificationInfo

返回包含MBean可能发出的通知类型的字符串数组（以点表示）。

getNotify() - Method in class javax.management.monitor. CounterMonitor

获取所有观察到的MBean通用的通/断开关值。

getNotify() - Method in interface javax.management.monitor. CounterMonitorMBean

获取通知的开/关开关值。

getNotifyDiffer() - Method in class javax.management.monitor. StringMonitor

获取所有观察到的MBean通用的不同通知的开关值。

getNotifyDiffer() - Method in interface javax.management.monitor. StringMonitorMBean

获取不同通知的开/关开关值。

getNotifyHigh() - Method in class javax.management.monitor. GaugeMonitor

获取所有观察到的MBean通用的高通知开/关切换值。

getNotifyHigh() - Method in interface javax.management.monitor. GaugeMonitorMBean

获取高通知的开/关开关值。

getNotifyLow() - Method in class javax.management.monitor. GaugeMonitor

获取所有观察到的MBean通用的低通知开/关切换值。

getNotifyLow() - Method in interface javax.management.monitor. GaugeMonitorMBean

获取低通知的开/关开关值。

getNotifyMatch() - Method in class javax.management.monitor. StringMonitor

获取匹配通知的所有观察到的MBean通用的开/关开关值。

getNotifyMatch() - Method in interface javax.management.monitor. StringMonitorMBean

获取匹配通知的开/关开关值。

getNoType(TypeKind) - Method in interface javax.lang.model.util. Types

返回在没有实际类型适用的情况下使用的伪类型。

getNow(T) - Method in class java.util.concurrent. CompletableFuture

如果已完成，则返回结果值（或抛出任何遇到的异常），否则返回给定的值IfAbsent。

getNoWrap() - Method in interface org.w3c.dom.html. HTMLTableCellElement

禁止字词包装。

getNr() - Method in class javax.smartcardio. ResponseAPDU

返回响应主体（Nr）中的数据字节数，如果此APDU没有正文，则返回0。

getNString(int) - Method in interface java.sql. CallableStatement

检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。

getNString(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 String此 ResultSet对象的当前行中指定列的值。

getNString(String) - Method in interface java.sql. CallableStatement

检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。

getNString(String) - Method in interface java.sql. ResultSet

检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 String 。

getNullFormatter() - Method in class javax.swing.text. DefaultFormatterFactory

如果值为null，则返回要使用的格式化程序。

getNullType() - Method in interface javax.lang.model.util. Types

返回null类型。

getNumBands() - Method in class java.awt.image. Raster

返回此光栅中的带数（每像素的样本数）。

getNumBands() - Method in class java.awt.image. SampleModel

返回图像数据的总带数。

getNumBands() - Method in class javax.imageio. ImageTypeSpecifier

返回此对象指定的频带数。

getNumBanks() - Method in class java.awt.image. DataBuffer

返回此DataBuffer中的存储区数。

getNumber() - Method in class javax.imageio.plugins.tiff. TIFFTag

返回用于表示标签的整数。

getNumber() - Method in class javax.swing. SpinnerNumberModel

返回序列的当前元素的值。

getNumberFormat() - Method in class java.text. DateFormat

获取此日期/时间格式化程序用于格式化和解析时间的数字格式化程序。

getNumberFormat() - Method in class javafx.util.converter. CurrencyStringConverter

返回一个NumberFormat实例，用于格式化和解析StringConverter 。

getNumberFormat() - Method in class javafx.util.converter. NumberStringConverter

返回一个NumberFormat实例，用于此StringConverter中的格式化和解析。

getNumberFormat() - Method in class javafx.util.converter. PercentageStringConverter

返回一个NumberFormat实例，用于格式化和解析StringConverter 。

getNumberInstance() - Static method in class java.text. NumberFormat

返回当前默认 值为FORMAT的通用数字格式。

getNumberInstance(Locale) - Static method in class java.text. NumberFormat

返回指定区域设置的通用数字格式。

getNumberInstance(Locale) - Method in class java.text.spi. NumberFormatProvider

返回指定区域设置的新通用 NumberFormat实例。

getNumberOfButtons() - Static method in class java.awt. MouseInfo

返回鼠标的按钮数量。

getNumberOfDependents() - Method in class java.util.concurrent. CompletableFuture

返回完成等待完成此CompletableFuture的CompletableFutures的估计数。

getNumberOfPages() - Method in class java.awt.print. Book

返回此 Book的页数。

getNumberOfPages() - Method in interface java.awt.print. Pageable

返回集合中的页数。

getNumberOfSubscribers() - Method in class java.util.concurrent. SubmissionPublisher

返回当前订阅者的数量。

getNumberValue() - Method in interface org.w3c.dom.xpath. XPathResult

这个数字的值结果。

getNumberWaiting() - Method in class java.util.concurrent. CyclicBarrier

返回目前正在等待障碍的各方的数量。

getNumChars() - Method in class java.awt.font. LineMetrics

返回由此 LineMetrics对象封装其度量标准的文本中的字符数（ char值）。

getNumColorComponents() - Method in class java.awt.image. ColorModel

返回此 ColorModel的颜色成 ColorModel 。

getNumComponents() - Method in class java.awt.color. ColorSpace

返回此ColorSpace的组件数。

getNumComponents() - Method in class java.awt.color. ICC_Profile

返回此配置文件的“输入”颜色空间中的颜色分量数。

getNumComponents() - Method in class java.awt.image. ColorModel

返回 ColorModel的组件数，包括alpha。

getNumComponents() - Method in class java.awt.image. LookupTable

返回查找表中的组件数。

getNumComponents() - Method in class javax.imageio. ImageTypeSpecifier

返回此对象指定的颜色成分数。

getNumDataElements() - Method in class java.awt.image. ComponentSampleModel

返回使用 ComponentSampleModel.getDataElements(int, int, Object, DataBuffer)和 ComponentSampleModel.setDataElements(int, int, Object, DataBuffer)方法传输像素所需的数据元素数。

getNumDataElements() - Method in class java.awt.image. MultiPixelPackedSampleModel

通过 MultiPixelPackedSampleModel.getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)和 MultiPixelPackedSampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)方法返回传输一个像素所需的数据元素数。

getNumDataElements() - Method in class java.awt.image. Raster

返回通过getDataElements和setDataElements方法传输一个像素所需的数据元素数。

getNumDataElements() - Method in class java.awt.image. SampleModel

返回通过getDataElements和setDataElements方法传输像素所需的数据元素数。

getNumDataElements() - Method in class java.awt.image. SinglePixelPackedSampleModel

返回通过getDataElements和setDataElements方法传输一个像素所需的数据元素数。

getNumDesignAxes() - Method in interface java.awt.font. MultipleMaster

返回多个主设计控件的数量。

getNumericCode() - Method in class java.util. Currency

返回此货币的ISO 4217数字代码。

getNumericCodeAsString() - Method in class java.util. Currency

返回此货币的3位数字ISO 4217数字代码，为 String 。

getNumericFunctions() - Method in interface java.sql. DatabaseMetaData

检索此数据库可用的逗号分隔的数学函数列表。

getNumericValue(char) - Static method in class java.lang. Character

返回指定的Unicode字符表示的值为 int 。

getNumericValue(int) - Static method in class java.lang. Character

返回指定字符（Unicode代码点）表示的值为 int 。

getNumFactors() - Method in class java.awt.image. RescaleOp

返回此RescaleOp中使用的缩放因子和偏移量的数量。

getNumGlyphs() - Method in class java.awt. Font

返回此 Font的字形数。

getNumGlyphs() - Method in class java.awt.font. GlyphVector

返回此 GlyphVector的字形数。

getNumImages(boolean) - Method in class javax.imageio. ImageReader

返回当前输入源可用的图像数量，不包括缩略图。

getNumParameters() - Method in class java.awt.image.renderable. ParameterBlock

返回参数数量（不包括源图像）。

getNumSources() - Method in class java.awt.image.renderable. ParameterBlock

返回源图像的数量。

getNumThumbnails() - Method in class javax.imageio. IIOImage

返回此 IIOImage存储的缩略图数。

getNumThumbnails(int) - Method in class javax.imageio. ImageReader

返回与给定图像相关联的缩略图预览图像的数量。

getNumThumbnailsSupported(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - Method in class javax.imageio. ImageWriter

给定图像类型以及编码期间将要使用的任何其他写入参数和元数据对象，返回由正在写入的格式支持的缩略图数。

getNumTIFFFields() - Method in class javax.imageio.plugins.tiff. TIFFDirectory

返回此目录中的TIFFField的数量。

getNumXTiles() - Method in class java.awt.image. BufferedImage

返回x方向上的图块数。

getNumXTiles() - Method in interface java.awt.image. RenderedImage

返回X方向上的图块数。

getNumYTiles() - Method in class java.awt.image. BufferedImage

返回y方向上的图块数。

getNumYTiles() - Method in interface java.awt.image. RenderedImage

返回Y方向上的图块数。

getObject() - Method in class java.security. GuardedObject

检索被保护的对象，或者如果对守卫对象的访问被守卫拒绝，则抛出异常。

getObject() - Method in class java.security. SignedObject

检索封装对象。

getObject() - Method in interface java.sql. Ref

检索此 Ref对象引用的SQL结构类型实例。

getObject() - Method in class javax.naming. Binding

检索绑定到此绑定名称的对象。

getObject() - Method in class javax.naming.spi. DirStateFactory.Result

检索要绑定的对象。

getObject() - Method in class javax.sql.rowset.serial. SerialJavaObject

返回一个 Object ，它是此副本 SerialJavaObject对象。

getObject() - Method in class javax.sql.rowset.serial. SerialRef

返回 Object表示对此的SQL结构类型 SerialRef对象引用。

getObject() - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

getObject() - Method in interface javax.xml.bind. ValidationEventLocator

返回Java内容树中对象的引用（如果可用）

getObject() - Method in interface org.w3c.dom.html. HTMLAppletElement

序列化小程序文件。

getObject(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 Object指定参数的值。

getObject(int) - Method in interface java.sql. ResultSet

将此 ResultSet对象的当前行中指定列的值作为Java编程语言中的 Object 。

getObject(int, Class<T>) - Method in interface java.sql. CallableStatement

返回表示OUT参数 parameterIndex的值的对象，并将转换为参数的SQL类型到所请求的Java数据类型，如果支持转换。

getObject(int, Class<T>) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值，并将转换为SQL类型的列到请求的Java数据类型，如果转换支持。

getObject(int, Map<String, Class<?>>) - Method in interface java.sql. CallableStatement

返回表示OUT参数 parameterIndex的值的对象，并使用 map作为参数值的自定义映射。

getObject(int, Map<String, Class<?>>) - Method in interface java.sql. ResultSet

以 ResultSet对象的当前行中的指定列的值作为Java编程语言中的 Object 。

getObject(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 Object检索参数的值。

getObject(String) - Method in interface java.sql. ResultSet

获取此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Object 。

getObject(String) - Method in class java.util. ResourceBundle

从此资源包或其父项之一获取给定密钥的对象。

getObject(String, Class<T>) - Method in interface java.sql. CallableStatement

返回一个表示OUT参数值 parameterName的对象，如果支持转换，则将从参数的SQL类型转换为请求的Java数据类型。

getObject(String, Class<T>) - Method in interface java.sql. ResultSet

检索此 ResultSet对象当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。

getObject(String, Map<String, Class<?>>) - Method in interface java.sql. CallableStatement

返回表示OUT参数值 parameterName的对象，并为参数值的自定义映射使用 map 。

getObject(String, Map<String, Class<?>>) - Method in interface java.sql. ResultSet

检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Object 。

getObject(Key) - Method in class javax.crypto. SealedObject

检索原始（封装）对象。

getObject(Key, String) - Method in class javax.crypto. SealedObject

检索原始（封装）对象。

getObject(Map<String, Class<?>>) - Method in interface java.sql. Ref

检索引用的对象，并使用给定的类型映射将其映射到Java类型。

getObject(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial. SerialRef

返回 Object表示对此的SQL结构类型 SerialRef对象引用。

getObject(Cipher) - Method in class javax.crypto. SealedObject

检索原始（封装）对象。

getObjectArrayMaxLength(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回可用于在指定元素中定义 Object引用的最大数组元素数。

getObjectArrayMaxLength(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObjectArrayMinLength(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回可用于定义指定元素中的 Object引用的最小数组元素数。

getObjectArrayMinLength(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObjectClass(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回存储在元素中的 Object参考的 Class类型。

getObjectClass(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObjectDefaultValue(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回一个 Object s，其中包含命名元素中的 Object引用的默认值。

getObjectDefaultValue(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObjectEnumerations(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回一个 Object的数组， Object包含命名元素中的 Object引用的合法枚举值。

getObjectEnumerations(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObjectForLayer(int) - Method in class javax.swing. JLayeredPane

返回与指定图层相关联的整数对象。

getObjectInputFilter() - Method in class java.io. ObjectInputStream

返回此流的序列化过滤器。

getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - Static method in class javax.naming.spi. NamingManager

为指定的对象和环境创建一个对象的实例。

getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - Method in interface javax.naming.spi. ObjectFactory

使用指定的位置或引用信息创建对象。

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - Static method in class javax.naming.spi. DirectoryManager

为指定的对象，属性和环境创建一个对象的实例。

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - Method in interface javax.naming.spi. DirObjectFactory

使用位置或参考信息和指定的属性创建对象。

getObjectInstance(ObjectName) - Method in interface javax.management. MBeanServer

getObjectInstance(ObjectName) - Method in interface javax.management. MBeanServerConnection

获取为MBean服务器注册的给定MBean的 ObjectInstance 。

getObjectInstance(ObjectName, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.getObjectInstance(ObjectName) 。

getObjectInstance(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

getObjectInstance(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

getObjectMaxValue(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回指定元素中的 Object引用的最大合法值。

getObjectMaxValue(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObjectMinValue(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回命名元素中的 Object引用的最小合法值。

getObjectMinValue(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObjectName() - Method in interface java.lang.management. PlatformManagedObject

返回表示此平台管理对象的对象名称的ObjectName实例。

getObjectName() - Method in class javax.management. MBeanServerInvocationHandler

MBean服务器中转发方法的MBean的名称。

getObjectName() - Method in class javax.management. ObjectInstance

返回对象名称部分。

getObjectName() - Method in class javax.management.relation. RelationNotification

返回创建/删除/更新的关系的ObjectName。

getObjectParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

获取参数作为对象。

getObjectPendingFinalizationCount() - Method in interface java.lang.management. MemoryMXBean

返回正在等待完成的对象的大致数量。

getObjects() - Method in interface javax.xml.crypto.dsig. XMLSignature

返回此XMLSignature中包含的XMLObject的XMLSignature 。

getObjectSize(Object) - Method in interface java.lang.instrument. Instrumentation

返回指定对象所消耗的存储量的实现特定近似值。

getObjectStreamClass() - Method in class java.io. ObjectInputStream.GetField

获取描述流中字段的ObjectStreamClass。

getObjectValueType(String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回从 VALUE_开始的枚举值 VALUE_ ，指示 Object引用允许的值（枚举，范围或数组）的 Object 。

getObjectValueType(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getObservedAttribute() - Method in class javax.management.monitor. Monitor

获取正在观察的属性。

getObservedAttribute() - Method in interface javax.management.monitor. MonitorMBean

获取正在观察的属性。

getObservedAttribute() - Method in class javax.management.monitor. MonitorNotification

获取此监视器通知的观察属性。

getObservedObject() - Method in class javax.management.monitor. Monitor

已过时。
截至JMX 1.2，由Monitor.getObservedObjects()取代

getObservedObject() - Method in interface javax.management.monitor. MonitorMBean

已过时。
截至JMX 1.2，由MonitorMBean.getObservedObjects()替代

getObservedObject() - Method in class javax.management.monitor. MonitorNotification

获取此监视器通知的观察对象。

getObservedObjects() - Method in class javax.management.monitor. Monitor

返回一个包含被观察对象的数组。

getObservedObjects() - Method in interface javax.management.monitor. MonitorMBean

返回一个包含被观察对象的数组。

getOcspExtensions() - Method in class java.security.cert. PKIXRevocationChecker

获取可选的OCSP请求扩展。

getOcspResponder() - Method in class java.security.cert. PKIXRevocationChecker

获取标识OCSP响应器位置的URI。

getOcspResponderCert() - Method in class java.security.cert. PKIXRevocationChecker

获取OCSP响应者的证书。

getOcspResponses() - Method in class java.security.cert. PKIXRevocationChecker

获得OCSP响应。

getOctetStream() - Method in class javax.xml.crypto. OctetStreamData

返回此 OctetStreamData的输入流。

getOffendingNode() - Method in exception javax.imageio.metadata. IIOInvalidTreeException

返回导致解析错误的 Node 。

getOffscreenBuffer(Component, int, int) - Method in class javax.swing. RepaintManager

返回应使用组件 c作为双缓冲区的屏幕外缓冲区。

getOffset() - Method in class java.awt.image. DataBuffer

返回数组元素中默认库的偏移量。

getOffset() - Method in class java.awt.image. LookupTable

返回偏移量。

getOffset() - Method in class java.io. ObjectStreamField

实例数据内的字段偏移量。

getOffset() - Method in class java.net. DatagramPacket

返回要发送的数据的偏移量或接收到的数据的偏移量。

getOffset() - Method in class java.text. CollationElementIterator

返回与下一个排序规则元素对应的原始文本中的字符偏移量。

getOffset() - Method in interface java.time.chrono. ChronoZonedDateTime

获取区域偏移量，例如“+01：00”。

getOffset() - Method in class java.time. OffsetDateTime

获取区域偏移量，例如“+01：00”。

getOffset() - Method in class java.time. OffsetTime

获取区域偏移量，例如“+01：00”。

getOffset() - Method in class java.time. ZonedDateTime

获取区域偏移量，例如“+01：00”。

getOffset() - Method in class javafx.scene.paint. Stop

获取一个范围从 0到 1 ，表示放置此梯度停止的位置。

getOffset() - Method in class javax.imageio.stream. IIOByteBuffer

返回由 getData的数据开始的 getData返回的字节数组内的偏移量。

getOffset() - Method in class javax.management.monitor. CounterMonitor

获取所有观察到的MBean公用的偏移值。

getOffset() - Method in interface javax.management.monitor. CounterMonitorMBean

获取偏移值。

getOffset() - Method in class javax.print.attribute. EnumSyntax

返回此枚举值枚举类使用的最小整数值。

getOffset() - Method in class javax.print.attribute.standard. Finishings

返回类Finishings所使用的最小整数值。

getOffset() - Method in class javax.print.attribute.standard. OrientationRequested

返回类OrientationRequested使用的最小整数值。

getOffset() - Method in class javax.print.attribute.standard. PrintQuality

返回PrintQuality类使用的最小整数值。

getOffset() - Method in interface javax.swing.event. DocumentEvent

返回变更开始文档中的偏移量。

getOffset() - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow

返回偏移量。

getOffset() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

返回变更开始文档中的偏移量。

getOffset() - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

获取起始偏移量。

getOffset() - Method in interface javax.swing.text. Position

获取文档中的当前偏移量。

getOffset() - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

getOffset() - Method in interface javax.xml.bind. ValidationEventLocator

如果可用，返回字节偏移量

getOffset(int, int) - Method in class java.awt.image. ComponentSampleModel

获取像素（x，y）的第一个带的偏移量。

getOffset(int, int) - Method in class java.awt.image. MultiPixelPackedSampleModel

返回数据数组元素中像素（x，y）的偏移量。

getOffset(int, int) - Method in class java.awt.image. SinglePixelPackedSampleModel

返回像素（x，y）的偏移（在数据数组元素中）。

getOffset(int, int) - Method in class javax.swing.text. BoxView

获取特定小孩当前布局的偏移量。

getOffset(int, int, int) - Method in class java.awt.image. ComponentSampleModel

获取像素（x，y）的带b的偏移。

getOffset(int, int, int, int, int, int) - Method in class java.util. SimpleTimeZone

在指定的日期和时间内，返回本地时间和UTC之间的毫秒数差异，同时考虑原始偏移量和夏令时的效果。

getOffset(int, int, int, int, int, int) - Method in class java.util. TimeZone

获取当前日期的时区偏移，在夏令时情况下进行修改。

getOffset(long) - Method in class java.util. SimpleTimeZone

在给定时间返回此时区与UTC的偏移量。

getOffset(long) - Method in class java.util. TimeZone

在指定的日期返回此时区与UTC的偏移量。

getOffset(Instant) - Method in class java.time.zone. ZoneRules

获得这些规则中指定时刻适用的偏移量。

getOffset(LocalDateTime) - Method in class java.time.zone. ZoneRules

在这些规则中为指定的本地日期时间获取适当的偏移量。

getOffsetAfter() - Method in class java.time.zone. ZoneOffsetTransition

获得转换后的偏移量。

getOffsetAfter() - Method in class java.time.zone. ZoneOffsetTransitionRule

获得转换后的偏移量。

getOffsetBefore() - Method in class java.time.zone. ZoneOffsetTransition

在转换之前获取偏移量。

getOffsetBefore() - Method in class java.time.zone. ZoneOffsetTransitionRule

在转换之前获取偏移量。

getOffsetHit(int) - Method in class java.awt.font. TextHitInfo

创建 TextHitInfo其字符索引由偏移 delta从 charIndex此的 TextHitInfo 。

getOffsets() - Method in class java.awt.image. DataBuffer

返回所有银行的偏移量（在数组元素中）。

getOffsets(float[]) - Method in class java.awt.image. RescaleOp

返回给定数组中的偏移量。

getOffsetX() - Method in class javafx.scene.effect. DisplacementMap

获取属性offsetX的值。

getOffsetX() - Method in class javafx.scene.effect. DropShadow

获取属性offsetX的值。

getOffsetX() - Method in class javafx.scene.effect. InnerShadow

获取属性offsetX的值。

getOffsetY() - Method in class javafx.scene.effect. DisplacementMap

获取属性offsetY的值。

getOffsetY() - Method in class javafx.scene.effect. DropShadow

获取属性offsetY的值。

getOffsetY() - Method in class javafx.scene.effect. InnerShadow

获取属性offsetY的值。

getOldBinding() - Method in class javax.naming.event. NamingEvent

在更改之前检索对象的绑定。

getOldLeadSelectionPath() - Method in class javax.swing.event. TreeSelectionEvent

返回先前是引导路径的路径。

getOldRoleValue() - Method in class javax.management.relation. RelationNotification

返回已更新角色的旧值（仅适用于角色更新）。

getOldState() - Method in class java.awt.event. WindowEvent

对于 WINDOW_STATE_CHANGED事件返回窗口的先前状态。

getOldValue() - Method in class java.beans. PropertyChangeEvent

获取属性的旧值，表示为对象。

getOldValue() - Method in class javafx.scene.control. TableColumn.CellEditEvent

尝试在 TableColumn.CellEditEvent.getTablePosition()返回的 TablePosition中提到的位置返回旧值。

getOldValue() - Method in class javafx.scene.control. TreeTableColumn.CellEditEvent

尝试在 TreeTableColumn.CellEditEvent.getTreeTablePosition()返回的 TablePosition中提到的位置返回旧值。

getOldValue() - Method in class javafx.scene.control. TreeTableView.EditEvent

返回在当前编辑事件之前的TreeItem中存在的旧值。

getOldValue() - Method in class javafx.scene.control. TreeView.EditEvent

返回在当前编辑事件之前的TreeItem中存在的旧值。

getOldValue() - Method in class javax.management. AttributeChangeNotification

获取已更改的属性的旧值。

getOmni() - Method in interface javax.sound.midi. MidiChannel

获取当前的全向模式。

getOnAction() - Method in class javafx.scene.control. ButtonBase

获取属性onAction的值。

getOnAction() - Method in class javafx.scene.control. ChoiceBox

获取属性onAction的值。

getOnAction() - Method in class javafx.scene.control. ComboBoxBase

获取属性onAction的值。

getOnAction() - Method in class javafx.scene.control. ContextMenu

获取属性onAction的值。

getOnAction() - Method in class javafx.scene.control. MenuItem

获取属性onAction的值。

getOnAction() - Method in class javafx.scene.control. TextField

获取属性onAction的值。

getOnAlert() - Method in class javafx.scene.web. WebEngine

获取属性onAlert的值。

getOnAutoHide() - Method in class javafx.stage. PopupWindow

获取属性onAutoHide的值。

getOnCancelled() - Method in class javafx.concurrent. Service

每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。

getOnCancelled() - Method in class javafx.concurrent. Task

每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。

getOnClosed() - Method in class javafx.scene.control. Tab

当选项卡关闭时与选项卡关联的事件处理程序。

getOnCloseRequest() - Method in class javafx.scene.control. Dialog

获取属性onCloseRequest的值。

getOnCloseRequest() - Method in class javafx.scene.control. Tab

获取属性onCloseRequest的值。

getOnCloseRequest() - Method in class javafx.stage. Window

获取属性onCloseRequest的值。

getOnContextMenuRequested() - Method in class javafx.scene. Node

获取属性onContextMenuRequested的值。

getOnContextMenuRequested() - Method in class javafx.scene. Scene

获取属性onContextMenuRequested的值。

getOnDragDetected() - Method in class javafx.scene. Node

获取属性onDragDetected的值。

getOnDragDetected() - Method in class javafx.scene. Scene

获取属性onDragDetected的值。

getOnDragDone() - Method in class javafx.scene. Node

获取属性onDragDone的值。

getOnDragDone() - Method in class javafx.scene. Scene

获取属性onDragDone的值。

getOnDragDropped() - Method in class javafx.scene. Node

获取属性onDragDropped的值。

getOnDragDropped() - Method in class javafx.scene. Scene

获取属性onDragDropped的值。

getOnDragEntered() - Method in class javafx.scene. Node

获取属性onDragEntered的值。

getOnDragEntered() - Method in class javafx.scene. Scene

获取属性onDragEntered的值。

getOnDragExited() - Method in class javafx.scene. Node

获取属性onDragExited的值。

getOnDragExited() - Method in class javafx.scene. Scene

获取属性onDragExited的值。

getOnDragOver() - Method in class javafx.scene. Node

获取属性onDragOver的值。

getOnDragOver() - Method in class javafx.scene. Scene

获取属性onDragOver的值。

getOnEditCancel() - Method in class javafx.scene.control. ListView

返回当用户取消编辑时将被调用的EventHandler 。

getOnEditCancel() - Method in class javafx.scene.control. TableColumn

获取属性onEditCancel的值。

getOnEditCancel() - Method in class javafx.scene.control. TreeTableColumn

获取属性onEditCancel的值。

getOnEditCancel() - Method in class javafx.scene.control. TreeView

返回当用户取消编辑时将被调用的EventHandler 。

getOnEditCommit() - Method in class javafx.scene.control. ListView

返回当用户提交编辑时将被调用的EventHandler 。

getOnEditCommit() - Method in class javafx.scene.control. TableColumn

获取属性onEditCommit的值。

getOnEditCommit() - Method in class javafx.scene.control. TreeTableColumn

获取属性onEditCommit的值。

getOnEditCommit() - Method in class javafx.scene.control. TreeView

返回当用户提交编辑时将被调用的EventHandler 。

getOnEditStart() - Method in class javafx.scene.control. ListView

返回当用户开始编辑时将被调用的EventHandler 。

getOnEditStart() - Method in class javafx.scene.control. TableColumn

获取onEditStart上的属性的值。

getOnEditStart() - Method in class javafx.scene.control. TreeTableColumn

获取onEditStart上的属性的值。

getOnEditStart() - Method in class javafx.scene.control. TreeView

返回当用户开始编辑时将被调用的EventHandler 。

getOnEndOfMedia() - Method in class javafx.scene.media. MediaPlayer

检索媒体事件处理程序的结束。

getOnError() - Method in class javafx.scene.media. Media

如果发生错误，则检索要调用的错误处理程序。

getOnError() - Method in class javafx.scene.media. MediaPlayer

检索错误的事件处理程序。

getOnError() - Method in class javafx.scene.media. MediaView

检索错误事件处理程序。

getOnError() - Method in class javafx.scene.web. WebEngine

获取属性onError的值。

getOnFailed() - Method in class javafx.concurrent. Service

每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。

getOnFailed() - Method in class javafx.concurrent. Task

每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。

getOnFinished() - Method in class javafx.animation. Animation

获取属性onFinished的值。

getOnFinished() - Method in class javafx.animation. KeyFrame

返回 onFinished此事件处理 KeyFrame 。

getOnHalted() - Method in class javafx.scene.media. MediaPlayer

检索 MediaPlayer.Status.HALTED事件处理程序。

getOnHidden() - Method in class javafx.scene.control. ChoiceBox

获取属性onHidden的值。

getOnHidden() - Method in class javafx.scene.control. ComboBoxBase

获取属性onHidden的值。

getOnHidden() - Method in class javafx.scene.control. Dialog

获取属性onHidden的值。

getOnHidden() - Method in class javafx.scene.control. Menu

获取属性onHidden的值。

getOnHidden() - Method in class javafx.stage. Window

获取属性onHidden的值。

getOnHiding() - Method in class javafx.scene.control. ChoiceBox

获取属性onHiding的值。

getOnHiding() - Method in class javafx.scene.control. ComboBoxBase

获取属性onHiding的值。

getOnHiding() - Method in class javafx.scene.control. Dialog

获取属性onHiding的值。

getOnHiding() - Method in class javafx.scene.control. Menu

获取属性onHiding的值。

getOnHiding() - Method in class javafx.stage. Window

获取属性onHiding的值。

getOnInputMethodTextChanged() - Method in class javafx.scene. Node

获取onInputMethodTextChanged属性的值。

getOnInputMethodTextChanged() - Method in class javafx.scene. Scene

获取onInputMethodTextChanged属性的值。

getOnKeyPressed() - Method in class javafx.scene. Node

获取属性onKeyPressed的值。

getOnKeyPressed() - Method in class javafx.scene. Scene

获取属性onKeyPressed的值。

getOnKeyReleased() - Method in class javafx.scene. Node

获取属性onKeyReleased的值。

getOnKeyReleased() - Method in class javafx.scene. Scene

获取属性onKeyReleased的值。

getOnKeyTyped() - Method in class javafx.scene. Node

获取属性onKeyTyped的值。

getOnKeyTyped() - Method in class javafx.scene. Scene

获取属性onKeyTyped的值。

getOnMarker() - Method in class javafx.scene.media. MediaPlayer

检索标记事件处理程序。

getOnMenuValidation() - Method in class javafx.scene.control. MenuItem

获取属性onMenuValidation的值。

getOnMouseClicked() - Method in class javafx.scene. Node

获取属性onMouseClicked的值。

getOnMouseClicked() - Method in class javafx.scene. Scene

获取属性onMouseClicked的值。

getOnMouseDragEntered() - Method in class javafx.scene. Node

获取属性onMouseDragEntered的值。

getOnMouseDragEntered() - Method in class javafx.scene. Scene

获取属性onMouseDragEntered的值。

getOnMouseDragExited() - Method in class javafx.scene. Node

获取属性onMouseDragExited的值。

getOnMouseDragExited() - Method in class javafx.scene. Scene

获取属性onMouseDragExited的值。

getOnMouseDragged() - Method in class javafx.scene. Node

获取属性onMouseDragged的值。

getOnMouseDragged() - Method in class javafx.scene. Scene

获取属性onMouseDragged的值。

getOnMouseDragOver() - Method in class javafx.scene. Node

获取属性onMouseDragOver的值。

getOnMouseDragOver() - Method in class javafx.scene. Scene

获取属性onMouseDragOver的值。

getOnMouseDragReleased() - Method in class javafx.scene. Node

获取属性onMouseDragReleased的值。

getOnMouseDragReleased() - Method in class javafx.scene. Scene

获取属性onMouseDragReleased的值。

getOnMouseEntered() - Method in class javafx.scene. Node

获取属性onMouseEntered的值。

getOnMouseEntered() - Method in class javafx.scene. Scene

获取属性onMouseEntered的值。

getOnMouseExited() - Method in class javafx.scene. Node

获取属性onMouseExited的值。

getOnMouseExited() - Method in class javafx.scene. Scene

获取属性onMouseExited的值。

getOnMouseMoved() - Method in class javafx.scene. Node

获取属性onMouseMoved的值。

getOnMouseMoved() - Method in class javafx.scene. Scene

获取属性onMouseMoved的值。

getOnMousePressed() - Method in class javafx.scene. Node

获取属性onMousePressed的值。

getOnMousePressed() - Method in class javafx.scene. Scene

获取属性onMousePressed的值。

getOnMouseReleased() - Method in class javafx.scene. Node

获取属性onMouseReleased的值。

getOnMouseReleased() - Method in class javafx.scene. Scene

获取属性onMouseReleased的值。

getOnPaused() - Method in class javafx.scene.media. MediaPlayer

检索 MediaPlayer.Status.PAUSED事件处理程序。

getOnPlaying() - Method in class javafx.scene.media. MediaPlayer

检索 MediaPlayer.Status.PLAYING事件处理程序。

getOnReady() - Method in class javafx.concurrent. Service

每当任务状态转换到READY状态时，都会调用onReady事件处理程序。

getOnReady() - Method in class javafx.scene.media. MediaPlayer

检索 MediaPlayer.Status.READY事件处理程序。

getOnRepeat() - Method in class javafx.scene.media. MediaPlayer

检索重复事件处理程序。

getOnResized() - Method in class javafx.scene.web. WebEngine

获取属性onResized的值。

getOnRotate() - Method in class javafx.scene. Node

获取属性onRotate的值。

getOnRotate() - Method in class javafx.scene. Scene

获取属性onRotate的值。

getOnRotationFinished() - Method in class javafx.scene. Node

获取属性onRotationFinished的值。

getOnRotationFinished() - Method in class javafx.scene. Scene

获取属性onRotationFinished的值。

getOnRotationStarted() - Method in class javafx.scene. Node

获取属性onRotationStarted的值。

getOnRotationStarted() - Method in class javafx.scene. Scene

获取属性onRotationStarted的值。

getOnRunning() - Method in class javafx.concurrent. Service

每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。

getOnRunning() - Method in class javafx.concurrent. Task

每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。

getOnScheduled() - Method in class javafx.concurrent. Service

每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。

getOnScheduled() - Method in class javafx.concurrent. Task

每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。

getOnScroll() - Method in class javafx.scene. Node

获取属性onScroll的值。

getOnScroll() - Method in class javafx.scene. Scene

获取属性onScroll的值。

getOnScrollFinished() - Method in class javafx.scene. Node

获取属性onScrollFinished的值。

getOnScrollFinished() - Method in class javafx.scene. Scene

获取属性onScrollFinished的值。

getOnScrollStarted() - Method in class javafx.scene. Node

获取属性onScrollStarted的值。

getOnScrollStarted() - Method in class javafx.scene. Scene

获取属性onScrollStarted的值。

getOnScrollTo() - Method in class javafx.scene.control. ListView

获取属性onScrollTo的值。

getOnScrollTo() - Method in class javafx.scene.control. TableView

获取属性onScrollTo的值。

getOnScrollTo() - Method in class javafx.scene.control. TreeTableView

获取属性onScrollTo的值。

getOnScrollTo() - Method in class javafx.scene.control. TreeView

获取属性onScrollTo的值。

getOnScrollToColumn() - Method in class javafx.scene.control. TableView

获取属性onScrollToColumn的值。

getOnScrollToColumn() - Method in class javafx.scene.control. TreeTableView

获取属性onScrollToColumn的值。

getOnSelectionChanged() - Method in class javafx.scene.control. Tab

与选项卡上的选择相关联的事件处理程序。

getOnShowing() - Method in class javafx.scene.control. ChoiceBox

获取属性onShowing的值。

getOnShowing() - Method in class javafx.scene.control. ComboBoxBase

获取属性onShowing的值。

getOnShowing() - Method in class javafx.scene.control. Dialog

获取属性onShowing的值。

getOnShowing() - Method in class javafx.scene.control. Menu

获取属性onShowing的值。

getOnShowing() - Method in class javafx.stage. Window

获取属性onShowing的值。

getOnShown() - Method in class javafx.scene.control. ChoiceBox

获取onShown属性的值。

getOnShown() - Method in class javafx.scene.control. ComboBoxBase

获取onShown属性的值。

getOnShown() - Method in class javafx.scene.control. Dialog

获取onShown属性的值。

getOnShown() - Method in class javafx.scene.control. Menu

获取onShown属性的值。

getOnShown() - Method in class javafx.stage. Window

获取onShown属性的值。

getOnSort() - Method in class javafx.scene.control. TableView

获取属性onSort的值。

getOnSort() - Method in class javafx.scene.control. TreeTableView

获取属性onSort的值。

getOnStalled() - Method in class javafx.scene.media. MediaPlayer

检索 MediaPlayer.Status.STALLED事件处理程序。

getOnStatusChanged() - Method in class javafx.scene.web. WebEngine

获取属性onStatusChanged的值。

getOnStopped() - Method in class javafx.scene.media. MediaPlayer

检索 MediaPlayer.Status.STOPPED事件处理程序。

getOnSucceeded() - Method in class javafx.concurrent. Service

每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。

getOnSucceeded() - Method in class javafx.concurrent. Task

每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。

getOnSwipeDown() - Method in class javafx.scene. Node

获取属性onSwipeDown的值。

getOnSwipeDown() - Method in class javafx.scene. Scene

获取属性onSwipeDown的值。

getOnSwipeLeft() - Method in class javafx.scene. Node

获取属性onSwipeLeft的值。

getOnSwipeLeft() - Method in class javafx.scene. Scene

获取属性onSwipeLeft的值。

getOnSwipeRight() - Method in class javafx.scene. Node

获取属性onSwipeRight的值。

getOnSwipeRight() - Method in class javafx.scene. Scene

获取属性onSwipeRight的值。

getOnSwipeUp() - Method in class javafx.scene. Node

获取属性onSwipeUp的值。

getOnSwipeUp() - Method in class javafx.scene. Scene

获取属性onSwipeUp的值。

getOnTouchMoved() - Method in class javafx.scene. Node

获取onTouchMoved属性的值。

getOnTouchMoved() - Method in class javafx.scene. Scene

获取onTouchMoved属性的值。

getOnTouchPressed() - Method in class javafx.scene. Node

获取onTouchPressed属性的值。

getOnTouchPressed() - Method in class javafx.scene. Scene

获取onTouchPressed属性的值。

getOnTouchReleased() - Method in class javafx.scene. Node

获取onTouchReleased属性的值。

getOnTouchReleased() - Method in class javafx.scene. Scene

获取onTouchReleased属性的值。

getOnTouchStationary() - Method in class javafx.scene. Node

获取属性onTouchStationary的值。

getOnTouchStationary() - Method in class javafx.scene. Scene

获取属性onTouchStationary的值。

getOnTransformChanged() - Method in class javafx.scene.transform. Transform

获取onTransformChanged事件处理程序。

getOnVisibilityChanged() - Method in class javafx.scene.web. WebEngine

获取属性onVisibilityChanged的值。

getOnZoom() - Method in class javafx.scene. Node

获取属性onZoom的值。

getOnZoom() - Method in class javafx.scene. Scene

获取属性onZoom的值。

getOnZoomFinished() - Method in class javafx.scene. Node

获取属性onZoomFinished的值。

getOnZoomFinished() - Method in class javafx.scene. Scene

获取属性onZoomFinished的值。

getOnZoomStarted() - Method in class javafx.scene. Node

获取属性onZoomStarted的值。

getOnZoomStarted() - Method in class javafx.scene. Scene

获取属性onZoomStarted的值。

getOOBInline() - Method in class java.net. Socket

测试是否启用了 SO_OOBINLINE 。

getOpacity() - Method in class java.awt. Window

返回窗口的不透明度。

getOpacity() - Method in class javafx.scene.effect. Blend

获取属性不透明度的值。

getOpacity() - Method in class javafx.scene. Node

获取属性不透明度的值。

getOpacity() - Method in class javafx.scene.paint. Color

对的不透明度 Color ，范围为 0.0-1.0 。

getOpacity() - Method in class javafx.stage. Window

获取属性不透明度的值。

getOpaque() - Method in class java.util.concurrent.atomic. AtomicBoolean

返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。

getOpaque() - Method in class java.util.concurrent.atomic. AtomicInteger

返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。

getOpaque() - Method in class java.util.concurrent.atomic. AtomicLong

返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。

getOpaque() - Method in class java.util.concurrent.atomic. AtomicReference

返回当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。

getOpaque(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

返回索引号为 i的元素的当前值，具有 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。

getOpaque(int) - Method in class java.util.concurrent.atomic. AtomicLongArray

返回索引号为 i的元素的当前值，由 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。

getOpaque(int) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

返回索引号为 i的元素的当前值，由 VarHandle.getOpaque(java.lang.Object...)指定的内存效果。

getOpaque(Object...) - Method in class java.lang.invoke. VarHandle

返回以程序顺序访问的变量的值，但不能保证相对于其他线程的内存排序效果。

getOpaqueInsets() - Method in class javafx.scene.layout. Region

获取属性opaqueInsets的值。

getOpenFileDescriptorCount() - Method in interface com.sun.management. UnixOperatingSystemMXBean

返回打开文件描述符的数量。

getOpenIcon() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回用于表示展开的非叶节点的图标。

getOpenType() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport

返回此 OpenMBeanAttributeInfoSupport实例描述的属性的值的打开类型。

getOpenType() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回此 OpenMBeanParameterInfo实例描述的参数的值的 打开类型 。

getOpenType() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport

返回此 OpenMBeanParameterInfoSupport实例描述的参数的值的打开类型。

getOperatingSystemMXBean() - Static method in class java.lang.management. ManagementFactory

返回运行Java虚拟机的操作系统的托管bean。

getOperation() - Method in class java.rmi.server. Operation

已过时。
没有替换

getOperation() - Method in class jdk.dynalink. CallSiteDescriptor

返回在呼叫站点的操作。

getOperation(String) - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回名称请求的ModelMBeanOperationInfo。

getOperation(String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

getOperations() - Method in interface java.rmi.server. Skeleton

已过时。
没有替换

getOperations() - Method in class javax.management. MBeanInfo

返回MBean的操作列表。

getOperations() - Method in interface javax.management.modelmbean. ModelMBeanInfo

返回MBean的操作列表。

getOperations() - Method in interface javax.management.openmbean. OpenMBeanInfo

返回的数组 OpenMBeanOperationInfo实例描述在此描述的开放MBean中的每个操作 OpenMBeanInfo实例。

getOppositeComponent() - Method in class java.awt.event. FocusEvent

返回此焦点更改中涉及的其他组件。

getOppositeWindow() - Method in class java.awt.event. WindowEvent

返回此焦点或激活更改中涉及的其他窗口。

getOptimizeHuffmanTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

返回传递到最近一次调用值 setOptimizeHuffmanTables ，或者 false如果 setOptimizeHuffmanTables从未被调用。

getOption(int) - Method in interface java.net. SocketOptions

获取选项的值。

getOption(SctpSocketOption<T>) - Method in class com.sun.nio.sctp. SctpChannel

返回套接字选项的值。

getOption(SctpSocketOption<T>) - Method in class com.sun.nio.sctp. SctpServerChannel

返回套接字选项的值。

getOption(SctpSocketOption<T>, Association) - Method in class com.sun.nio.sctp. SctpMultiChannel

返回套接字选项的值。

getOption(DatagramSocket, SocketOption<T>) - Static method in class jdk.net. Sockets

从DatagramSocket或MulticastSocket返回套接字选项的值

getOption(ServerSocket, SocketOption<T>) - Static method in class jdk.net. Sockets

从ServerSocket返回套接字选项的值

getOption(SocketOption<T>) - Method in class java.net. DatagramSocket

返回套接字选项的值。

getOption(SocketOption<T>) - Method in class java.net. DatagramSocketImpl

被称为获取套接字选项。

getOption(SocketOption<T>) - Method in class java.net. ServerSocket

返回套接字选项的值。

getOption(SocketOption<T>) - Method in class java.net. Socket

返回套接字选项的值。

getOption(SocketOption<T>) - Method in class java.net. SocketImpl

被称为获取套接字选项。

getOption(SocketOption<T>) - Method in interface java.nio.channels. NetworkChannel

返回套接字选项的值。

getOption(Socket, SocketOption<T>) - Static method in class jdk.net. Sockets

从Socket返回套接字选项的值

getOptions() - Method in class java.security.cert. PKIXRevocationChecker

获取吊销选项。

getOptions() - Method in interface javax.annotation.processing. ProcessingEnvironment

返回传递给注解处理工具的处理器特定选项。

getOptions() - Method in class javax.security.auth.callback. ConfirmationCallback

获取确认选项。

getOptions() - Method in class javax.security.auth.login. AppConfigurationEntry

获取为此配置的选项 LoginModule 。

getOptions() - Method in class javax.swing. JOptionPane

返回用户可以做出的选择。

getOptions() - Method in interface jdk.nashorn.api.tree. RegExpLiteralTree

正则表达式匹配选项。

getOptions() - Method in interface org.w3c.dom.html. HTMLSelectElement

此元素包含的 OPTION元素的集合。

getOptionType() - Method in class javax.security.auth.callback. ConfirmationCallback

获取选项类型。

getOptionType() - Method in class javax.swing. JOptionPane

返回显示的选项类型。

getOrDefault(Object, Object) - Method in class java.security. Provider

getOrDefault(Object, Object) - Method in class java.util. Properties

getOrDefault(Object, V) - Method in class java.util.concurrent. ConcurrentHashMap

返回指定键映射到的值，如果此映射不包含该键的映射，则返回给定的默认值。

getOrDefault(Object, V) - Method in interface java.util.concurrent. ConcurrentMap

返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。

getOrDefault(Object, V) - Method in class java.util.concurrent. ConcurrentSkipListMap

返回指定键映射到的值或给定的defaultValue，如果该映射不包含该键的映射。

getOrDefault(Object, V) - Method in class java.util. HashMap

getOrDefault(Object, V) - Method in class java.util. Hashtable

getOrDefault(Object, V) - Method in class java.util. LinkedHashMap

返回指定键映射到的值，如果此映射不包含键的映射，则返回 defaultValue 。

getOrDefault(Object, V) - Method in interface java.util. Map

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。

getOrder() - Method in class java.security.spec. ECParameterSpec

返回发生器的顺序。

getOrdinal() - Method in class javafx.css. Selector

getOrientation() - Method in interface java.awt. Adjustable

获取可调对象的方向。

getOrientation() - Method in class java.awt.print. PageFormat

返回此方向 PageFormat 。

getOrientation() - Method in class java.awt. Scrollbar

返回此滚动条的方向。

getOrientation() - Method in class java.awt. ScrollPaneAdjustable

返回此滚动条的方向。

getOrientation() - Method in class javafx.animation. PathTransition

获取属性方向的值。

getOrientation() - Method in class javafx.scene.control. ListView

返回ListView的当前方向，它决定了它是垂直滚动还是水平滚动。

getOrientation() - Method in class javafx.scene.control. ScrollBar

获取属性方向的值。

getOrientation() - Method in class javafx.scene.control. Separator

获取属性方向的值。

getOrientation() - Method in class javafx.scene.control. Slider

获取属性方向的值。

getOrientation() - Method in class javafx.scene.control. SplitPane

SplitPane的方向。

getOrientation() - Method in class javafx.scene.control. ToolBar

获取属性方向的值。

getOrientation() - Method in class javafx.scene.layout. FlowPane

获取属性方向的值。

getOrientation() - Method in class javafx.scene.layout. TilePane

获取属性方向的值。

getOrientation() - Method in class javax.swing. JProgressBar

返回 SwingConstants.VERTICAL或 SwingConstants.HORIZONTAL ，具体取决于进度条的方向。

getOrientation() - Method in class javax.swing. JScrollBar

返回组件的方向（水平或垂直）。

getOrientation() - Method in class javax.swing. JSeparator

返回此分隔符的方向。

getOrientation() - Method in class javax.swing. JSlider

返回此滑块的垂直或水平方向。

getOrientation() - Method in class javax.swing. JSplitPane

返回方向。

getOrientation() - Method in class javax.swing. JToolBar

返回工具栏的当前方向。

getOrientation() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回 JSplitPane的方向。

getOrientation() - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow

当工具栏浮动时返回工具栏窗口的方向。

getOrientation(Locale) - Static method in class java.awt. ComponentOrientation

返回适合给定区域设置的方向。

getOrientation(ResourceBundle) - Static method in class java.awt. ComponentOrientation

已过时。
从J2SE 1.4开始，使用ComponentOrientation.getOrientation(java.util.Locale) 。

getOrientationRequested() - Method in class java.awt. PageAttributes

返回使用这些属性的页面的打印方向。

getOrigin() - Method in class com.sun.management. VMOption

返回此VM选项的值的起始位置。

getOrigin() - Method in class java.awt. PageAttributes

返回是否使用这些属性绘制（0,0）到页面的物理页面的左上角或可打印区域的左上角。

getOrigin() - Method in class javafx.css. Rule

getOrigin() - Method in class javafx.css. Stylesheet

getOrigin(AnnotatedConstruct, AnnotationMirror) - Method in interface javax.lang.model.util. Elements

返回给定注释镜的 起点 。

getOrigin(Element) - Method in interface javax.lang.model.util. Elements

返回给定元素的 原点 。

getOrigin(ModuleElement, ModuleElement.Directive) - Method in interface javax.lang.model.util. Elements

返回给定模块指令的 原点 。

getOriginal() - Method in interface javax.sql.rowset. CachedRowSet

返回一个 ResultSet包含该原始值对象 CachedRowSet对象。

getOriginal() - Method in interface javax.sql. RowSetInternal

检索包含该 ResultSet对象的原始值的 RowSet对象。

getOriginalRow() - Method in interface javax.sql.rowset. CachedRowSet

返回一个 ResultSet包含当前行只有这个原始值对象 CachedRowSet对象。

getOriginalRow() - Method in interface javax.sql. RowSetInternal

检索包含当前行的原始值的 ResultSet对象。

getOriginalType(ErrorType) - Method in class com.sun.source.util. Trees

从ErrorType对象返回原始类型。

getOriginatingNode() - Method in interface javax.xml.transform.dom. DOMLocator

返回发生事件的节点。

getOriginatingProvider() - Method in class javax.imageio. ImageReader

返回传递给构造函数的 ImageReaderSpi 。

getOriginatingProvider() - Method in class javax.imageio. ImageWriter

返回 ImageWriterSpi创建此对象 ImageWriter ，或者 null如果这个对象不是通过创建 IIORegistry 。

getOrphans() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的孤儿属性定义。

getOtherFile() - Method in exception java.nio.file. FileSystemException

返回用于创建此异常的另一个文件。

getOtherHit() - Method in class java.awt.font. TextHitInfo

在插入点的另一侧创建一个 TextHitInfo 。

getOtherPrimeInfo() - Method in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

如果只有两个素因子（p和q），则返回otherPrimeInfo或null。

getOtherPrimeInfo() - Method in class java.security.spec. RSAMultiPrimePrivateCrtKeySpec

如果只有两个素因子（p和q），则返回otherPrimeInfo的副本或null。

getOutline() - Method in class java.awt.font. GlyphVector

返回一个 Shape其内部对应于该 GlyphVector的视觉表示。

getOutline() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的大纲属性定义。

getOutline(float, float) - Method in class java.awt.font. GlyphVector

返回一个 Shape其内部对应于在x，y渲染时的 GlyphVector的视觉表示。

getOutline(AffineTransform) - Method in class java.awt.font. GraphicAttribute

返回一个Shape ，表示该区域GraphicAttribute呈现。

getOutline(AffineTransform) - Method in class java.awt.font. ShapeGraphicAttribute

返回一个Shape ，表示该区域ShapeGraphicAttribute呈现。

getOutline(AffineTransform) - Method in class java.awt.font. TextLayout

返回一个表示 Shape的轮廓的 TextLayout 。

getOutlineColor() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的outline-color属性定义。

getOutlineStyle() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的outline-style属性定义。

getOutlineWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的outline-width属性定义。

getOutput() - Method in class javax.imageio. ImageWriter

返回 ImageOutputStream或其他 Object设置由最近调用的 setOutput方法。

getOutputClass() - Method in class javax.imageio.spi. ImageOutputStreamSpi

返回一个 Class表示必须由输出目的地，以便被实现为“包装”在的类或接口类型的对象 ImageOutputStream经由 createOutputStreamInstance方法。

getOutputFormat() - Method in class javax.print. StreamPrintService

返回此打印服务发出的文档格式。

getOutputFormat() - Method in class javax.print. StreamPrintServiceFactory

查询工厂获得的打印机发出的文档格式。

getOutputLength() - Method in class javax.xml.crypto.dsig.spec. HMACParameterSpec

返回截断长度。

getOutputProperties() - Method in interface javax.xml.transform. Templates

获取与有效xsl：output元素相对应的属性。

getOutputProperties() - Method in class javax.xml.transform. Transformer

获取转换的输出属性的副本。

getOutputProperty(String) - Method in class javax.xml.transform. Transformer

获取对变压器有效的输出属性。

getOutputScaleX() - Method in class javafx.stage. Screen

获取 Screen的水平（ X ）方向的推荐输出比例因子。

getOutputScaleX() - Method in class javafx.stage. Window

获取属性outputScaleX的值。

getOutputScaleY() - Method in class javafx.stage. Screen

获取 Screen在垂直（ Y ）方向的推荐输出比例因子。

getOutputScaleY() - Method in class javafx.stage. Window

获取属性outputScaleY的值。

getOutputSize(int) - Method in class javax.crypto. Cipher

给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 update或 doFinal操作的结果的字节长度。

getOutputSize(int) - Method in class javax.crypto. ExemptionMechanism

给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 genExemptionBlob操作结果的字节长度。

getOutputStatement(String) - Method in interface javax.script. ScriptEngineFactory

返回一个可用作语句的字符串，使用支持的脚本语言的语法显示指定的String。

getOutputStatement(String) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getOutputStream() - Method in class java.lang. Process

返回连接到进程正常输入的输出流。

getOutputStream() - Method in class java.net. Socket

返回此套接字的输出流。

getOutputStream() - Method in class java.net. SocketImpl

返回此套接字的输出流。

getOutputStream() - Method in class java.net. URLConnection

返回写入此连接的输出流。

getOutputStream() - Method in class java.rmi.server. LogStream

已过时。
没有替换

getOutputStream() - Method in interface java.rmi.server. RemoteCall

已过时。
没有替换

getOutputStream() - Method in class javax.activation. DataHandler

获取此DataHandler的OutputStream以允许覆盖底层数据。

getOutputStream() - Method in interface javax.activation. DataSource

此方法返回一个 OutputStream ，如果不能这样做，可以写入数据并抛出适当的异常。

getOutputStream() - Method in class javax.activation. FileDataSource

此方法将返回一个表示数据的OutputStream，如果不能执行此操作将抛出IOException。

getOutputStream() - Method in class javax.activation. URLDataSource

来自URL的getOutputStream方法。

getOutputStream() - Method in class javax.print. StreamPrintService

获取输出流。

getOutputStream() - Method in class javax.xml.transform.stream. StreamResult

获取使用setOutputStream设置的字节流。

getOutputStream(boolean) - Method in interface javax.jnlp. FileContents

获取该文件的 OutputStream 。

getOutputTypes() - Method in class javax.imageio.spi. ImageWriterSpi

返回一个 Class对象的数组，指示可以将什么类型的对象用作作者 setOutput方法的参数。

getOutsets() - Method in class javafx.scene.layout. Background

这个背景的外在。

getOutsets() - Method in class javafx.scene.layout. Border

边框外部定义要绘制的边框的最外边缘。

getOutsideBorder() - Method in class javax.swing.border. CompoundBorder

返回外部边框对象。

getOverflow() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的overflow属性定义。

getOverrideStyle(Element, String) - Method in interface org.w3c.dom.css. DocumentCSS

该方法用于检索指定元素和指定伪元素的覆盖样式声明。

getOverwriteMode() - Method in class javax.swing.text. DefaultFormatter

返回插入字符时的行为。

getOwnedWindows() - Method in class java.awt. Window

返回一个包含此窗口当前拥有的所有窗口的数组。

getOwner() - Method in class java.awt. Window

返回此窗口的所有者。

getOwner() - Method in class java.beans. XMLDecoder

获取此解码器的所有者。

getOwner() - Method in class java.beans. XMLEncoder

获取该编码器的所有者。

getOwner() - Method in interface java.nio.file.attribute. FileOwnerAttributeView

阅读文件所有者。

getOwner() - Method in class java.util.concurrent.locks. ReentrantLock

返回当前拥有此锁的线程，如果不拥有，则返回 null 。

getOwner() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回当前拥有写锁的线程，如果不拥有，则返回 null 。

getOwner() - Method in class javafx.scene.control. Dialog

检索该对话框的所有者窗口，或者取消未知对话框的null。

getOwner() - Method in class javafx.stage. Stage

检索该阶段的所有者窗口，或者取消未知阶段的空值。

getOwner(Path, LinkOption...) - Static method in class java.nio.file. Files

返回文件的所有者。

getOwnerDocument() - Method in class javax.imageio.metadata. IIOMetadataNode

退货 null ，由于 IIOMetadataNode不属于任何 Document 。

getOwnerDocument() - Method in interface org.w3c.dom. Node

与此节点相关联的 Document对象。

getOwnerElement() - Method in interface org.w3c.dom. Attr

此属性附加到的 Element节点或 null如果此属性未使用。

getOwnerElement() - Method in interface org.w3c.dom.xpath. XPathNamespace

命名空间在请求时位于其中的 Element 。

getOwnerlessWindows() - Static method in class java.awt. Window

返回由此应用程序创建的所有 Window的数组，该数组没有所有者。

getOwnerNode() - Method in class javafx.stage. PopupWindow

获取属性ownerNode的值。

getOwnerNode() - Method in interface org.w3c.dom.stylesheets. StyleSheet

将此样式表与文档相关联的节点。

getOwnerRule() - Method in interface org.w3c.dom.css. CSSStyleSheet

如果此样式表来自 @import规则，则 ownerRule属性将包含 CSSImportRule 。

getOwnerType() - Method in interface java.lang.reflect. ParameterizedType

返回一个 Type对象，表示此类型是其成员的类型。

getOwnerWindow() - Method in class javafx.stage. PopupWindow

获取属性ownerWindow的值。

getOwnKeys(boolean) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

返回与对象关联的自己的属性键的数组。

getOwnPropertyDescriptor(String) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

ECMA 8.12.1 [[GetOwnProperty]]（P）

getP() - Method in interface java.security.interfaces. DSAParams

返回素数， p 。

getP() - Method in class java.security.spec. DSAParameterSpec

退货 p 。

getP() - Method in class java.security.spec. DSAPrivateKeySpec

退货 p 。

getP() - Method in class java.security.spec. DSAPublicKeySpec

退货 p 。

getP() - Method in class java.security.spec. ECFieldFp

返回这个主要有限域的素数 p 。

getP() - Method in class javax.crypto.spec. DHParameterSpec

返回质数模数 p 。

getP() - Method in class javax.crypto.spec. DHPrivateKeySpec

返回质数模数 p 。

getP() - Method in class javax.crypto.spec. DHPublicKeySpec

返回素数模数 p 。

getP1() - Method in class java.awt.geom. CubicCurve2D.Double

返回起始点。

getP1() - Method in class java.awt.geom. CubicCurve2D.Float

返回起始点。

getP1() - Method in class java.awt.geom. CubicCurve2D

返回起始点。

getP1() - Method in class java.awt.geom. Line2D.Double

返回这个 Point2D的 Line2D 。

getP1() - Method in class java.awt.geom. Line2D.Float

返回 Point2D的起始 Line2D 。

getP1() - Method in class java.awt.geom. Line2D

返回该 Point2D的起始 Line2D 。

getP1() - Method in class java.awt.geom. QuadCurve2D.Double

返回起始点。

getP1() - Method in class java.awt.geom. QuadCurve2D.Float

返回起始点。

getP1() - Method in class java.awt.geom. QuadCurve2D

返回起始点。

getP1() - Method in class javax.smartcardio. CommandAPDU

返回参数字节P1的值。

getP2() - Method in class java.awt.geom. CubicCurve2D.Double

返回终点。

getP2() - Method in class java.awt.geom. CubicCurve2D.Float

返回终点。

getP2() - Method in class java.awt.geom. CubicCurve2D

返回终点。

getP2() - Method in class java.awt.geom. Line2D.Double

返回 Point2D的结尾 Line2D 。

getP2() - Method in class java.awt.geom. Line2D.Float

返回 Point2D的结尾 Line2D 。

getP2() - Method in class java.awt.geom. Line2D

返回 Point2D的结尾 Line2D 。

getP2() - Method in class java.awt.geom. QuadCurve2D.Double

返回终点。

getP2() - Method in class java.awt.geom. QuadCurve2D.Float

返回终点。

getP2() - Method in class java.awt.geom. QuadCurve2D

返回终点。

getP2() - Method in class javax.smartcardio. CommandAPDU

返回参数字节P2的值。

getPackage() - Method in interface com.sun.source.tree. CompilationUnitTree

返回与此编译单元关联的包树，或者如果没有包声明，则返回 null 。

getPackage() - Method in class java.lang. Class

获取此类的包。

getPackage() - Method in interface javax.lang.model.element. ModuleElement.ExportsDirective

返回正在导出的包。

getPackage() - Method in interface javax.lang.model.element. ModuleElement.OpensDirective

返回正在打开的包。

getPackage(String) - Method in class java.lang. ClassLoader

已过时。
如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包只会从父加载程序定义的package-info.class文件中公开注释，即使子载入程序定义的package-info.class文件中存在注释。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。

getPackage(String) - Static method in class java.lang. 软件包

已过时。
如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使子载入程序定义的package-info.class文件中存在注释。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。

getPackageAnnotations() - Method in interface com.sun.source.tree. CompilationUnitTree

返回在此编译单元头部的任何包装声明中列出的注释，如果没有包声明，则 null 。

getPackageElement(CharSequence) - Method in interface javax.lang.model.util. Elements

如果包在环境中是唯一的，则返回给定其全限定名称的包。

getPackageElement(ModuleElement, CharSequence) - Method in interface javax.lang.model.util. Elements

如给定模块所示，返回一个给定其全限定名称的包。

getPackageName() - Method in interface com.sun.source.tree. CompilationUnitTree

返回此编译单元头部的任何包装声明中包含的名称，如果没有包装声明，则 null 。

getPackageName() - Method in interface com.sun.source.tree. ExportsTree

返回要导出的包的名称。

getPackageName() - Method in interface com.sun.source.tree. OpensTree

返回要打开的包的名称。

getPackageName() - Method in interface com.sun.source.tree. PackageTree

返回正在声明的包的名称。

getPackageName() - Method in class java.lang. Class

返回完全限定的包名称。

getPackageOf(Element) - Method in interface javax.lang.model.util. Elements

返回元素的包。

getPackages() - Method in class java.lang. ClassLoader

返回此类加载器及其祖先定义的所有 软件包 。

getPackages() - Method in class java.lang. Module

返回此模块中软件包的软件包名称集。

getPackages() - Static method in class java.lang. 软件包

返回由调用者的类加载器及其祖先定义的所有 软件包 。

getPacketBufferSize() - Method in interface javax.net.ssl. SSLSession

获取使用此会话时预期的最大SSL / TLS / DTLS数据包的当前大小。

getPadding() - Method in class javafx.scene.layout. Region

获取属性填充的值。

getPadding() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

返回填充。

getPadding() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding属性定义。

getPaddingBottom() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-bottom属性定义。

getPaddingLeft() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-left属性定义。

getPaddingRight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-right属性定义。

getPaddingTop() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-top属性定义。

getPage() - Method in class javax.swing. JEditorPane

获取正在显示的当前URL。

getPage() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的页面属性定义。

getPageBreakAfter() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的page-break-after属性定义。

getPageBreakBefore() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的page-break-before属性定义。

getPageBreakInside() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的page-break-inside属性定义。

getPageCount() - Method in class javafx.scene.control. Pagination

返回页数。

getPageDimension() - Method in class java.awt. PrintJob

以像素为单位返回页面的尺寸。

getPageFactory() - Method in class javafx.scene.control. Pagination

返回页面工厂回调函数。

getPageFormat(int) - Method in class java.awt.print. Book

返回pageIndex指定页面的pageIndex 。

getPageFormat(int) - Method in interface java.awt.print. Pageable

返回 PageFormat指定页面的 pageIndex 。

getPageFormat(PrintRequestAttributeSet) - Method in class java.awt.print. PrinterJob

计算一个 PageFormat ，其值与本作业当前的 PrintService支持的值（即 getPrintService()返回的值）以及 attributes包含的介质，可打印区域和方向 attributes 。

getPageIncrement() - Method in class java.awt. Scrollbar

已过时。
从JDK 1.1版开始，由getBlockIncrement()替代。

getPageLayout() - Method in class javafx.print. JobSettings

获取此作业的当前页面布局。

getPageOrientation() - Method in class javafx.print. PageLayout

getPageRanges() - Method in class java.awt. JobAttributes

对于使用这些属性的作业，指定要打印的页面范围，如果要打印的页面范围。

getPageRanges() - Method in class javafx.print. JobSettings

要打印的页面范围。 null始终表示所有页面。

getPageResolution() - Method in class java.awt. PrintJob

返回页面的分辨率（以像素为单位）。

getPageSize() - Method in interface javax.sql.rowset. CachedRowSet

返回 CachedRowSet对象的页面大小

getPaint() - Method in class java.awt. Graphics2D

返回 Graphics2D上下文的当前 Paint 。

getPaint() - Method in class javafx.scene.effect. ColorInput

获取属性paint的值。

getPaint() - Method in class javax.swing.border. StrokeBorder

返回在边框渲染期间用于生成颜色的Paint对象。

getPaintContext() - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter

获取此Paint操作的PaintContext。

getPaintConverter() - Static method in class javafx.css. StyleConverter

返回一个 StyleConverter ，其转换解析后的表示 Paint为 Paint 。

getPainter() - Method in interface javax.swing.text. Highlighter.Highlight

获得荧光笔的画家。

getPainter(SynthContext) - Method in class javax.swing.plaf.nimbus. NimbusStyle

返回将用于绘画的 SynthPainter 。

getPainter(SynthContext) - Method in class javax.swing.plaf.synth. SynthStyle

返回将用于绘画的 SynthPainter 。

getPainter(GlyphView, int, int) - Method in class javax.swing.text. GlyphView.GlyphPainter

为给定的GlyphView创建一个画家。

getPaintLabels() - Method in class javax.swing. JSlider

告诉标签是否要涂漆。

getPaintTicks() - Method in class javax.swing. JSlider

告诉是否要勾画刻度线。

getPaintTrack() - Method in class javax.swing. JSlider

告诉曲目（滑块滑入的区域）是否要被绘制。

getPan() - Method in class javafx.scene.media. AudioClip

获取默认的平移值。

getPanes() - Method in class javafx.scene.control. Accordion

获得此手风琴中的TitledPane的列表。

getPaper() - Method in class java.awt.print. PageFormat

返回与此PageFormat相关联的Paper对象的副本。

getPaper() - Method in class javafx.print. PageLayout

用纸。

getPaperSource() - Method in class javafx.print. JobSettings

获取属性paperSource的值。

getParagraphAttributes() - Method in class javax.swing. JTextPane

获取当前段落属性在插入符号的位置，如果没有， null 。

getParagraphElement(int) - Method in class javax.swing.text. AbstractDocument

获取包含给定位置的段落元素。

getParagraphElement(int) - Method in class javax.swing.text. DefaultStyledDocument

获取偏移量的段落元素 pos 。

getParagraphElement(int) - Method in class javax.swing.text. PlainDocument

获取包含给定位置的段落元素。

getParagraphElement(int) - Method in interface javax.swing.text. StyledDocument

获取表示在文档中包含给定偏移量的段落的元素。

getParagraphElement(JTextComponent, int) - Static method in class javax.swing.text. Utilities

确定要用于段落/行的元素。

getParagraphs() - Method in class javafx.scene.control. TextArea

返回返回文本区域内容的字符序列的不可修改列表。

getParallelism() - Method in class java.util.concurrent. ForkJoinPool

返回此池的目标并行度级别。

getParamClasses() - Method in class java.awt.image.renderable. ParameterBlock

返回描述参数类型的Class对象数组。

getParameter() - Method in interface com.sun.source.tree. CatchTree

返回catch变量。

getParameter() - Method in exception java.sql. DataTruncation

指示truncated的值是参数值还是列值。

getParameter() - Method in interface jdk.nashorn.api.tree. CatchTree

返回捕获的异常的catch参数标识符或参数绑定模式。

getParameter(String) - Method in class java.applet. Applet

已过时。

返回HTML标签中命名参数的值。

getParameter(String) - Method in interface java.applet. AppletStub

已过时。

返回HTML标签中命名参数的值。

getParameter(String) - Method in class java.awt.datatransfer. DataFlavor

如果 paramName等于“humanPresentableName”，则返回此 DataFlavor paramName名称。

getParameter(String) - Method in class java.security. Signature

已过时。

getParameter(String) - Method in class javax.activation. MimeType

检索与给定名称相关联的值，如果没有当前关联，则返回null。

getParameter(String) - Method in class javax.print. DocFlavor

返回一个表示MIME参数的 String 。

getParameter(String) - Method in interface javax.script. ScriptEngineFactory

返回属性的值，该属性的含义可能是实现特定的。

getParameter(String) - Method in class javax.xml.transform. Transformer

获取使用setParameter显式设置的参数。

getParameter(String) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getParameter(String) - Method in interface org.w3c.dom. DOMConfiguration

如果已知，返回参数的值。

getParameterAnnotations() - Method in class java.lang.reflect. Constructor

返回 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。

getParameterAnnotations() - Method in class java.lang.reflect. Executable

返回一个 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。

getParameterAnnotations() - Method in class java.lang.reflect. 方法

返回一个 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。

getParameterBlock() - Method in class java.awt.image.renderable. RenderableImageOp

返回对当前参数块的引用。

getParameterClassName(int) - Method in interface java.sql. ParameterMetaData

检索要将其实例传递给方法的Java类的完全限定名称 PreparedStatement.setObject 。

getParameterCount() - Method in class java.lang.reflect. Constructor

返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。

getParameterCount() - Method in class java.lang.reflect. Executable

返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。

getParameterCount() - Method in class java.lang.reflect. 方法

返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。

getParameterCount() - Method in interface java.sql. ParameterMetaData

检索此 ParameterMetaData对象包含信息的 PreparedStatement对象中的参数数。

getParameterDescriptors() - Method in class java.beans. MethodDescriptor

获取每个此MethodDescriptor方法参数的ParameterDescriptor。

getParameterInfo() - Method in class java.applet. Applet

已过时。

返回有关此applet可以理解的参数的信息。

getParameterizedType() - Method in class java.lang.reflect. Parameter

返回一个 Type对象标识参数化的类型由该表示的参数 Parameter对象。

getParameterMetaData() - Method in interface java.sql. PreparedStatement

检索此 PreparedStatement对象的参数的数量，类型和属性。

getParameterMode(int) - Method in interface java.sql. ParameterMetaData

检索指定参数的模式。

getParameterName(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management. StandardMBean

自定义钩子：获取将用于MBean返回的MBeanConstructorInfo的 序列 MBeanParameterInfo的名称。

getParameterName(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management. StandardMBean

自定义钩子：获取将用于MBean返回的MBeanOperationInfo的 序列 MBeanParameterInfo的名称。

getParameterNames() - Method in interface org.w3c.dom. DOMConfiguration

该 DOMConfiguration对象支持的参数列表，应用程序可以设置至少一个值。

getParameters() - Method in interface com.sun.source.tree. LambdaExpressionTree

返回此lambda表达式的参数。

getParameters() - Method in interface com.sun.source.tree. MethodTree

返回正在声明的方法的参数。

getParameters() - Method in class java.awt.image.renderable. ParameterBlock

返回整个参数向量。

getParameters() - Method in class java.lang.reflect. Executable

返回一个 Parameter对象的数组，表示由该对象表示的底层可执行文件的所有参数。

getParameters() - Method in class java.security. Policy

退货政策参数。

getParameters() - Method in class java.security. SecureRandom

返回此SecureRandom实例的有效SecureRandomParameters 。

getParameters() - Method in class java.security. Signature

返回与此签名对象一起使用的参数。

getParameters() - Method in class java.util.logging. LogRecord

获取日志消息的参数。

getParameters() - Method in class javafx.application. Application

检索此应用程序的参数，包括在命令行上传递的任何参数以及Applet或WebStart应用程序的JNLP文件中指定的任何参数。

getParameters() - Method in class javax.activation. MimeType

检索此对象的参数列表。

getParameters() - Method in class javax.crypto. Cipher

返回与此密码一起使用的参数。

getParameters() - Method in interface javax.lang.model.element. ExecutableElement

返回此可执行文件的形式参数。

getParameters() - Method in class javax.net.ssl. CertPathTrustManagerParameters

返回此类封装的CertPathParameters的克隆。

getParameters() - Method in class javax.net.ssl. KeyStoreBuilderParameters

返回此对象封装的KeyStore.Builder的不可修改列表。

getParameters() - Method in class javax.security.auth.login. Configuration

返回配置参数。

getParameters() - Method in interface jdk.javadoc.doclet. Doclet.Option

返回该选项的参数。

getParameters() - Method in interface jdk.nashorn.api.tree. FunctionDeclarationTree

返回此函数的参数。

getParameters() - Method in interface jdk.nashorn.api.tree. FunctionExpressionTree

返回此函数的参数。

getParameterSpec() - Method in class javax.crypto.spec. PBEParameterSpec

返回密码算法参数规范。

getParameterSpec() - Method in interface javax.xml.crypto. AlgorithmMethod

返回这个 AlgorithmMethod的算法参数。

getParameterSpec() - Method in interface javax.xml.crypto.dsig. CanonicalizationMethod

返回与此 CanonicalizationMethod相关联的特定于算法的输入参数。

getParameterSpec() - Method in interface javax.xml.crypto.dsig. DigestMethod

返回与此 DigestMethod相关联的特定于算法的输入参数。

getParameterSpec() - Method in interface javax.xml.crypto.dsig. SignatureMethod

返回此 SignatureMethod的算法特定输入参数。

getParameterSpec() - Method in interface javax.xml.crypto.dsig. Transform

返回与此 Transform关联的特定于算法的输入参数。

getParameterSpec(Class<T>) - Method in class java.security. AlgorithmParameters

返回此参数对象的（透明）规范。

getParameterType(int) - Method in interface java.sql. ParameterMetaData

检索指定参数的SQL类型。

getParameterTypeName(int) - Method in interface java.sql. ParameterMetaData

检索指定参数的数据库特定类型名称。

getParameterTypes() - Method in class java.lang.reflect. Constructor

返回一个 Class对象的数组， Class以声明顺序表示由该对象表示的可执行文件的形式参数类型。

getParameterTypes() - Method in class java.lang.reflect. Executable

返回一个 Class对象的数组， Class以声明顺序表示由该对象表示的可执行文件的形式参数类型。

getParameterTypes() - Method in class java.lang.reflect. 方法

返回一个 Class对象的数组， Class以声明顺序表示由该对象表示的可执行文件的形式参数类型。

getParameterTypes() - Method in interface javax.lang.model.type. ExecutableType

返回此可执行文件的形式参数的类型。

getParameterTypes() - Method in class javax.management.loading. MLetContent

获取的值的列表 TYPE在中每个嵌套<PARAM>标记属性 MLET标签。

getParameterValues() - Method in class javax.management.loading. MLetContent

获取的值的列表 VALUE在中每个嵌套<PARAM>标记属性 MLET标签。

getParams() - Method in interface java.security.interfaces. DSAKey

返回特定于DSA的关键参数。

getParams() - Method in interface java.security.interfaces. ECKey

返回与此关键字关联的域参数。

getParams() - Method in class java.security.spec. ECPrivateKeySpec

返回相关的椭圆曲线域参数。

getParams() - Method in class java.security.spec. ECPublicKeySpec

返回相关的椭圆曲线域参数。

getParams() - Method in interface javax.crypto.interfaces. DHKey

返回关键参数。

getParams() - Method in class javax.sql.rowset. BaseRowSet

检索包含为此 RowSet对象的命令设置的参数值（对象和基元）的 SQLException如果尚未设置所有参数，则抛出一个 SQLException对象。

getParams() - Method in interface javax.sql. RowSetInternal

检索为此 RowSet对象的命令设置的参数。

getParent() - Method in class java.awt. Component

获取此组件的父级。

getParent() - Method in class java.awt.image. Raster

返回此栅格的父栅格（如果有）或null。

getParent() - Method in class java.awt. MenuComponent

返回此菜单组件的父容器。

getParent() - Method in class java.awt. PopupMenu

返回此菜单组件的父容器。

getParent() - Method in class java.io. File

返回此抽象路径名的父目录的路径名字符串，如果此路径名不指定父目录，则返回 null 。

getParent() - Method in class java.lang. ClassLoader

返回父类加载器进行委派。

getParent() - Method in class java.lang. ThreadGroup

返回此线程组的父级。

getParent() - Method in class java.net. NetworkInterface

如果这是一个子接口，则返回此接口的父NetworkInterface，如果它是物理（非虚拟）接口或没有父接口，则返回 null 。

getParent() - Method in interface java.nio.file. Path

返回 父路径 ，如果此路径没有 父项 ，则返回 null 。

getParent() - Method in interface java.security.cert. PolicyNode

返回此节点的父节点，如果这是根节点，则返回 null 。

getParent() - Method in class java.util.concurrent. Phaser

返回此移相器的父级，如果没有，则返回 null 。

getParent() - Method in class java.util.logging. Logger

返回此记录器的父级。

getParent() - Method in class java.util.prefs. NodeChangeEvent

返回添加或删除的节点的父节点。

getParent() - Method in class javafx.scene.control. TreeItem

这个TreeItem的父项。

getParent() - Method in class javafx.scene. Node

获取属性parent的值。

getParent() - Method in class javax.swing. ActionMap

返回这个 ActionMap的父母。

getParent() - Method in class javax.swing. InputMap

获得 InputMap的父母。

getParent() - Method in class javax.swing.text. AbstractDocument.AbstractElement

返回接收者的父母 TreeNode 。

getParent() - Method in class javax.swing.text. View

返回视图的父级。

getParent() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的父节点，如果此节点没有父节点，则返回null。

getParent() - Method in interface javax.swing.tree. TreeNode

返回接收者的父母 TreeNode 。

getParent() - Method in class javax.xml.crypto.dsig.dom. DOMSignContext

返回父节点。

getParent() - Method in class javax.xml.stream.util. EventReaderDelegate

获取此实例的父级。

getParent() - Method in class javax.xml.stream.util. StreamReaderDelegate

获取此实例的父级。

getParent() - Method in class org.xml.sax.helpers. XMLFilterImpl

得到父母的读者。

getParent() - Method in interface org.xml.sax. XMLFilter

得到父母的读者。

getParentColumn() - Method in class javafx.scene.control. TableColumnBase

获取属性parentColumn的值。

getParentDirectory(File) - Method in class javax.swing.filechooser. FileSystemView

返回父目录 dir 。

getParentElement() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取元素的父项。

getParentElement() - Method in interface javax.swing.text. Element

获取父元素。

getParentElement() - Method in interface javax.xml.soap. Node

返回此 Node对象的父元素。

getParentFile() - Method in class java.io. File

返回此抽象路径名的父目录的抽象路径名，如果此路径名未命名为父目录，则返回 null 。

getParentLogger() - Method in interface java.sql. Driver

返回此驱动程序使用的所有日志记录器的父记录器。

getParentLogger() - Method in interface javax.sql. CommonDataSource

返回此数据源使用的所有日志记录器的父记录器。

getParentLoggerName(String) - Method in interface java.lang.management. PlatformLoggingMXBean

返回指定记录器的 parent的名称。

getParentLoggerName(String) - Method in interface java.util.logging. LoggingMXBean

已过时。

返回指定记录器的父级名称。

getParentMenu() - Method in class javafx.scene.control. MenuItem

获取属性parentMenu的值。

getParentNode() - Method in class javax.imageio.metadata. IIOMetadataNode

返回此节点的父节点。

getParentNode() - Method in interface org.w3c.dom. Node

这个节点的父节点。

getParentPath() - Method in class com.sun.source.util. DocTreePath

返回包围节点的路径，如果没有包围节点，则返回 null 。

getParentPath() - Method in class com.sun.source.util. TreePath

返回包围节点的路径，如果没有包围节点，则返回 null 。

getParentPath() - Method in class javax.swing.tree. TreePath

返回父母的 TreePath 。

getParentPopup() - Method in class javafx.scene.control. MenuItem

获取属性parentPopup的值。

getParentRule() - Method in interface org.w3c.dom.css. CSSRule

如果此规则包含在另一个规则中（例如@media块中的样式规则），则这是包含规则。

getParentRule() - Method in interface org.w3c.dom.css. CSSStyleDeclaration

包含此声明块的CSS规则或 null如果此 CSSStyleDeclaration未附加到 CSSRule 。

getParentStyleSheet() - Method in interface org.w3c.dom.css. CSSRule

包含此规则的样式表。

getParentStyleSheet() - Method in interface org.w3c.dom.stylesheets. StyleSheet

对于支持样式表包含概念的样式表语言，此属性表示包含样式表（如果存在）。

getParentTag() - Method in class javax.imageio.plugins.tiff. TIFFDirectory

如果已经定义了该目录，则返回该目录的母版本TIFFTag ，否则返回null 。

getParentTargetNode() - Method in class javafx.animation. ParallelTransition

返回Transition的动画目标Transition 。

getParentTargetNode() - Method in class javafx.animation. SequentialTransition

返回Transition的动画的目标Transition 。

getParentTargetNode() - Method in class javafx.animation. Transition

返回目标Node为这个Transition动画。

getParsedString() - Method in exception java.time.format. DateTimeParseException

返回要解析的字符串。

getParsedValue() - Method in class javafx.css. Declaration

getParser() - Method in class javax.swing.text.html. HTMLDocument

返回将HTML插入现有文档时使用的解析器。

getParser() - Method in class javax.swing.text.html. HTMLEditorKit

获取解析器以用于读取HTML流。

getParser() - Method in class javax.xml.parsers. SAXParser

返回由该类实现封装的SAX解析器。

getPartialSize(int, int) - Method in class javax.swing.text. ParagraphView

返回 startOffset和 endOffset之间的视图使用的大小。

getPartialSpan(int, int) - Method in class javax.swing.text. GlyphView

确定视图的一部分沿与标签扩展相同的轴的跨度。

getPartialSpan(int, int) - Method in interface javax.swing.text. TabableView

确定视图的一部分沿与标签扩展相同的轴的跨度。

getParties() - Method in class java.util.concurrent. CyclicBarrier

返回旅行这个障碍所需的聚会数量。

getPassword() - Method in class java.net. PasswordAuthentication

返回用户密码。

getPassword() - Method in class java.security. KeyStore.PasswordProtection

获取密码。

getPassword() - Method in interface javax.crypto.interfaces. PBEKey

返回密码。

getPassword() - Method in class javax.crypto.spec. PBEKeySpec

返回密码的副本。

getPassword() - Method in class javax.security.auth.callback. PasswordCallback

获取检索到的密码。

getPassword() - Method in class javax.sql.rowset. BaseRowSet

返回用于为此 RowSet对象创建数据库连接的密码。

getPassword() - Method in interface javax.sql. RowSet

检索用于创建数据库连接的密码。

getPassword() - Method in class javax.swing. JPasswordField

返回此 TextComponent包含的文本。

getPasswordAuthentication() - Method in class java.net. Authenticator

当需要密码授权时调用。

getPasteAction() - Static method in class javax.swing. TransferHandler

返回从剪贴板执行粘贴操作的 Action 。

getPatch() - Method in class javax.sound.midi. Instrument

获取 Patch对象，指示将该乐器存储在合成器中的银行和节目编号。

getPatchList() - Method in class javax.sound.midi. Sequence

获取此序列中引用的修补程序列表。

getPath() - Method in class com.sun.net.httpserver. HttpContext

返回此上下文创建的路径

getPath() - Method in class java.io. File

将此抽象路径名转换为路径名字符串。

getPath() - Method in class java.net. HttpCookie

返回浏览器返回此Cookie的服务器上的路径。

getPath() - Method in class java.net. URI

返回此URI的解码路径组件。

getPath() - Method in class java.net. URL

获取此 URL的路径部分。

getPath() - Method in class javafx.animation. PathTransition

获取属性路径的值。

getPath() - Method in class javax.swing.event. MenuDragMouseEvent

返回所选菜单项的路径。

getPath() - Method in class javax.swing.event. MenuKeyEvent

返回此事件引用的菜单项的路径。

getPath() - Method in class javax.swing.event. TreeExpansionEvent

返回已经展开/折叠的值的路径。

getPath() - Method in class javax.swing.event. TreeModelEvent

从事件包装的TreePath实例获取对象数组的便利方法。

getPath() - Method in class javax.swing.event. TreeSelectionEvent

返回第一个路径元素。

getPath() - Method in class javax.swing. JTree.DropLocation

返回放置在树中的数据的路径。

getPath() - Method in class javax.swing.plaf.basic. BasicMenuItemUI

返回菜单元素路径。

getPath() - Method in class javax.swing.tree. DefaultMutableTreeNode

从根返回路径，以获取到此节点。

getPath() - Method in class javax.swing.tree. TreePath

返回此 TreePath的元素的有序数组。

getPath() - Method in class javax.xml.ws.spi.http. HttpContext

返回此上下文的路径。

getPath(CompilationUnitTree, Tree) - Static method in class com.sun.source.util. TreePath

返回编译单元中树节点的树路径，如果未找到该节点，则 null 。

getPath(CompilationUnitTree, Tree) - Method in class com.sun.source.util. Trees

返回指定编译单元中树节点的路径。

getPath(DocTreePath, DocTree) - Static method in class com.sun.source.util. DocTreePath

返回由DocTreePath对象标识的子树内的树节点的文档树路径，如果未找到节点，则 null 。

getPath(TreePath, DocCommentTree, DocTree) - Static method in class com.sun.source.util. DocTreePath

返回编译单元中树节点的文档树路径，如果未找到节点，则 null 。

getPath(TreePath, Tree) - Static method in class com.sun.source.util. TreePath

返回由TreePath对象标识的子树内的树节点的树路径。

getPath(String, String...) - Method in class java.nio.file. FileSystem

将路径字符串或将连接到路径字符串的字符串序列转换为 Path 。

getPath(String, String...) - Method in interface javax.tools. StandardJavaFileManager.PathFactory

将路径字符串或将路径字符串连接时的字符串序列转换为路径。

getPath(URI) - Method in class java.nio.file.spi. FileSystemProvider

通过转换给定的URI返回一个Path对象。

getPath(Element) - Method in class com.sun.source.util. Trees

返回给定元素的TreePath节点。

getPath(Element, AnnotationMirror) - Method in class com.sun.source.util. Trees

返回给定元素上的AnnotationMirror的TreePath节点。

getPath(Element, AnnotationMirror, AnnotationValue) - Method in class com.sun.source.util. Trees

返回指定元素上AnnotationMirror的AnnotationValue的TreePath节点。

getPathBetweenRows(int, int) - Method in class javax.swing. JTree

返回指定行之间的路径（包括）。

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回包围路径中最后一个项目将被绘制的标签部分的Rectangle。

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getPathBounds方法。

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf. TreeUI

返回包围路径中最后一个项目将被绘制的标签部分的Rectangle。

getPathBounds(TreePath) - Method in class javax.swing. JTree

返回指定节点将被绘制的 Rectangle 。

getPathClosestTo(int, int) - Method in class javax.swing.tree. AbstractLayoutCache

返回最接近x，y的节点的路径。

getPathClosestTo(int, int) - Method in class javax.swing.tree. FixedHeightLayoutCache

返回最接近x，y的节点的路径。

getPathClosestTo(int, int) - Method in class javax.swing.tree. VariableHeightLayoutCache

返回最接近x，y的节点的路径。

getPathComponent(int) - Method in class javax.swing.tree. TreePath

返回指定索引处的path元素。

getPathCount() - Method in class javax.swing.tree. TreePath

返回路径中的元素数。

getPathForLocation(int, int) - Method in class javax.swing. JTree

返回指定位置节点的路径。

getPathForRow(int) - Method in class javax.swing. JTree

返回指定行的路径。

getPathForRow(int) - Method in class javax.swing.tree. AbstractLayoutCache

返回在行中传递的路径。

getPathForRow(int) - Method in class javax.swing.tree. FixedHeightLayoutCache

返回在行中传递的路径。

getPathForRow(int) - Method in class javax.swing.tree. VariableHeightLayoutCache

返回 row的路径。

getPathForRow(JTree, int) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回在行中传递的路径。

getPathForRow(JTree, int) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getPathForRow方法。

getPathForRow(JTree, int) - Method in class javax.swing.plaf. TreeUI

返回在行中传递的路径。

getPathInfo() - Method in class javax.xml.ws.spi.http. HttpExchange

返回Web服务路径后面的额外路径信息，但在请求URI中的查询字符串之前，将以“/”字符开头。

getPathIterator(AffineTransform) - Method in class java.awt.geom. Arc2D

返回定义圆弧边界的迭代对象。

getPathIterator(AffineTransform) - Method in class java.awt.geom. Area

为此Area对象的轮廓创建一个PathIterator 。

getPathIterator(AffineTransform) - Method in class java.awt.geom. CubicCurve2D

返回定义形状边界的迭代对象。

getPathIterator(AffineTransform) - Method in class java.awt.geom. Ellipse2D

返回定义 Ellipse2D边界的迭代对象。

getPathIterator(AffineTransform) - Method in class java.awt.geom. Line2D

返回定义 Line2D边界的迭代对象。

getPathIterator(AffineTransform) - Method in class java.awt.geom. Path2D.Double

返回一个沿着 Shape边界进行迭代的迭代器对象，并提供对 Shape大纲的几何形状的访问。

getPathIterator(AffineTransform) - Method in class java.awt.geom. Path2D.Float

返回一个沿 Shape边界迭代的迭代器对象，并提供对 Shape大纲的几何形状的访问。

getPathIterator(AffineTransform) - Method in class java.awt.geom. QuadCurve2D

返回一个定义 QuadCurve2D形状边界的迭代对象。

getPathIterator(AffineTransform) - Method in class java.awt.geom. Rectangle2D

返回一个定义 Rectangle2D边界的迭代对象。

getPathIterator(AffineTransform) - Method in class java.awt.geom. RoundRectangle2D

返回一个定义 RoundRectangle2D边界的迭代对象。

getPathIterator(AffineTransform) - Method in class java.awt. Polygon

返回一个迭代器对象，它沿着这个 Polygon的边界进行迭代，并提供对这个 Polygon的轮廓几何的访问。

getPathIterator(AffineTransform) - Method in interface java.awt. Shape

返回一个沿 Shape边界迭代的迭代器对象，并提供对 Shape大纲的几何形状的访问。

getPathIterator(AffineTransform, double) - Method in class java.awt.geom. Area

为此 Area对象的扁平轮廓创建一个 PathIterator 。

getPathIterator(AffineTransform, double) - Method in class java.awt.geom. CubicCurve2D

返回定义展平形状边界的迭代对象。

getPathIterator(AffineTransform, double) - Method in class java.awt.geom. Line2D

返回一个迭代对象，该对象定义了此扁平化的边界 Line2D 。

getPathIterator(AffineTransform, double) - Method in class java.awt.geom. Path2D

返回一个沿 Shape边界进行迭代的迭代器对象，并提供对 Shape轮廓几何体的扁平化视图的访问。

getPathIterator(AffineTransform, double) - Method in class java.awt.geom. QuadCurve2D

返回定义此 QuadCurve2D的展平形状边界的迭代对象。

getPathIterator(AffineTransform, double) - Method in class java.awt.geom. Rectangle2D

返回一个迭代对象，它定义了 Rectangle2D化的边界 Rectangle2D 。

getPathIterator(AffineTransform, double) - Method in class java.awt.geom. RectangularShape

返回一个迭代器对象，它可以沿着 Shape对象的边界进行迭代，并提供对 Shape对象几何轮廓的扁平化视图的访问。

getPathIterator(AffineTransform, double) - Method in class java.awt. Polygon

返回一个迭代器对象，它沿着 Shape的边界进行迭代，并提供对 Shape轮廓几何的访问。

getPathIterator(AffineTransform, double) - Method in interface java.awt. Shape

返回一个沿着 Shape边界进行迭代的迭代器对象，并提供对 Shape轮廓几何的扁平化视图的访问。

getPathMatcher(String) - Method in class java.nio.file. FileSystem

返回一个PathMatcher ，通过解释给定的模式对Path对象的String表示执行匹配操作。

getPaths() - Method in class javax.swing.event. TreeSelectionEvent

返回从选择中添加或删除的路径。

getPathToNames() - Method in class java.security.cert. X509CertSelector

返回pathToNames条件的副本。

getPathToRoot(TreeNode) - Method in class javax.swing.tree. DefaultTreeModel

构建节点直到并包括根节点的父节点，其中原始节点是返回的数组中的最后一个元素。

getPathToRoot(TreeNode, int) - Method in class javax.swing.tree. DefaultMutableTreeNode

构建节点直到并包括根节点的父节点，其中原始节点是返回的数组中的最后一个元素。

getPathToRoot(TreeNode, int) - Method in class javax.swing.tree. DefaultTreeModel

构建节点直到并包括根节点的父节点，其中原始节点是返回的数组中的最后一个元素。

getPattern() - Method in exception java.util.regex. PatternSyntaxException

检索错误的正则表达式模式。

getPattern() - Method in interface jdk.nashorn.api.tree. RegExpLiteralTree

正则表达式模式匹配。

getPatternSeparator() - Method in class java.text. DecimalFormatSymbols

获取用于在模式中分离正和负子模式的字符。

getPause() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的pause属性定义。

getPauseAfter() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的pause-after属性定义。

getPauseBefore() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的pause-before属性定义。

getPayload() - Method in interface javax.xml.ws. LogicalMessage

将消息有效负载作为XML源，可以在同一个LogicalMessage实例上多次调用，总是返回一个可用于检索整个消息有效负载的新的 Source 。

getPayload(JAXBContext) - Method in interface javax.xml.ws. LogicalMessage

获取消息有效载荷作为JAXB对象。

getPCSType() - Method in class java.awt.color. ICC_Profile

返回配置文件连接空间（PCS）的颜色空间类型。

getPeakThreadCount() - Method in interface java.lang.management. ThreadMXBean

返回Java虚拟机启动或峰值复位后的峰值活动线程数。

getPeakUsage() - Method in interface java.lang.management. MemoryPoolMXBean

从Java虚拟机启动或从峰值重置以来，返回此内存池的高峰内存使用情况。

getPeerCertificateChain() - Method in class javax.net.ssl. HandshakeCompletedEvent

已过时。
应该使用返回java.security.cert.Certificate数组的HandshakeCompletedEvent.getPeerCertificates()方法。

getPeerCertificateChain() - Method in interface javax.net.ssl. SSLSession

已过时。
该SSLSession.getPeerCertificates()方法返回的数组java.security.cert.Certificate应改为使用。

getPeerCertificates() - Method in class javax.net.ssl. HandshakeCompletedEvent

返回作为定义会话的一部分而建立的对等体的身份。

getPeerCertificates() - Method in interface javax.net.ssl. SSLSession

返回作为定义会话的一部分而建立的对等体的身份。

getPeerHost() - Method in class javax.net.ssl. SSLEngine

返回对等体的主机名。

getPeerHost() - Method in interface javax.net.ssl. SSLSession

返回此会话中对等体的主机名。

getPeerPort() - Method in class javax.net.ssl. SSLEngine

返回对端的端口号。

getPeerPort() - Method in interface javax.net.ssl. SSLSession

返回此会话中对等端口的端口号。

getPeerPrincipal() - Method in class java.net. SecureCacheResponse

返回作为在检索网络资源的原始连接期间定义会话的一部分而建立的服务器的主体。

getPeerPrincipal() - Method in class javax.net.ssl. HandshakeCompletedEvent

返回作为定义会话的一部分而建立的对等体的身份。

getPeerPrincipal() - Method in class javax.net.ssl. HttpsURLConnection

返回作为定义会话的一部分而建立的服务器的主体。

getPeerPrincipal() - Method in interface javax.net.ssl. SSLSession

返回作为定义会话的一部分而建立的对等体的身份。

getPeerSupportedSignatureAlgorithms() - Method in class javax.net.ssl. ExtendedSSLSession

获得对等体能够使用的支持的签名算法数组。

getPendingCount() - Method in class java.util.concurrent. CountedCompleter

返回当前挂起的计数。

getPercent() - Method in class java.text. DecimalFormatSymbols

获取用于百分号的字符。

getPercentComplete() - Method in class javax.swing. JProgressBar

返回进度条的完成百分比。

getPercentHeight() - Method in class javafx.scene.layout. RowConstraints

获取属性percentHeight的值。

getPercentInstance() - Static method in class java.text. NumberFormat

返回当前默认 值为FORMAT的区域设置的百分比格式。

getPercentInstance(Locale) - Static method in class java.text. NumberFormat

返回指定区域设置的百分比格式。

getPercentInstance(Locale) - Method in class java.text.spi. NumberFormatProvider

返回一个新的 NumberFormat实例，用于格式化指定区域设置的百分比值。

getPercentWidth() - Method in class javafx.scene.layout. ColumnConstraints

获取属性percentWidth的值。

getPeriod() - Method in class javafx.concurrent. ScheduledService

获取属性期间的值。

getPeriod(Integer) - Method in class javax.management.timer. Timer

获取与定时器通知相关联的周期（以毫秒为单位）的副本。

getPeriod(Integer) - Method in interface javax.management.timer. TimerMBean

获取与定时器通知相关联的周期（以毫秒为单位）的副本。

getPermanentFocusOwner() - Method in class java.awt. KeyboardFocusManager

如果永久焦点所有者与调用线程处于相同的上下文中，则返回永久焦点所有者。

getPerMill() - Method in class java.text. DecimalFormatSymbols

获取每个mille标志使用的字符。

getPermission() - Method in class java.net. HttpURLConnection

返回表示连接到目标主机和端口所需的权限的SocketPermission对象。

getPermission() - Method in class java.net. URLConnection

返回一个权限对象，该对象表示创建此对象所表示的连接所需的权限。

getPermission() - Method in exception java.security. AccessControlException

获取与此异常关联的Permission对象，如果没有相应的Permission对象，则为null。

getPermissions() - Method in class java.security. ProtectionDomain

返回授予此域的静态权限。

getPermissions(CodeSource) - Method in class java.net. URLClassLoader

返回给定的代码源对象的权限。

getPermissions(CodeSource) - Method in class java.security. Policy

返回一个PermissionCollection对象，该对象包含授予指定CodeSource的一组权限。

getPermissions(CodeSource) - Method in class java.security. SecureClassLoader

返回给定CodeSource对象的权限。

getPermissions(Principal) - Method in interface java.security.acl. Acl

已过时。

返回指定主体的一组允许权限的枚举（表示一个实体，如个人或组）。

getPermissions(ProtectionDomain) - Method in class java.security. Policy

返回一个PermissionCollection对象，该对象包含授予指定ProtectionDomain的一组权限。

getPermissions(Subject, CodeSource) - Method in class com.sun.security.auth. PolicyFile

已过时。

检查此 Policy并返回授予给指定的 Subject和 CodeSource的权限。

getPermissions(Subject, CodeSource) - Method in class javax.security.auth. Policy

已过时。

检索授予与指定的 CodeSource相关的校长的权限。

getPermutation() - Method in class javafx.collections. ListChangeListener.Change

如果这个改变是一个排列，它返回一个描述排列的整数数组。

getPermutation(int) - Method in class javafx.collections. ListChangeListener.Change

通过调用这些方法，可以观察发生的排列。

getPersistenceDelegate(Class<?>) - Method in class java.beans. Encoder

返回给定类型的持久代理。

getPersonalizationString() - Method in class java.security. DrbgParameters.Instantiation

返回个性化字符串作为字节数组。

getPhase() - Method in class java.util.concurrent. Phaser

返回当前相位数。

getPickResult() - Method in class javafx.scene.input. ContextMenuEvent

返回有关选择的信息。

getPickResult() - Method in class javafx.scene.input. DragEvent

返回有关选择的信息。

getPickResult() - Method in class javafx.scene.input. GestureEvent

返回有关选择的信息。

getPickResult() - Method in class javafx.scene.input. MouseEvent

返回有关选择的信息。

getPickResult() - Method in class javafx.scene.input. TouchPoint

返回有关选择的信息。

getPIData() - Method in class javax.xml.stream.util. StreamReaderDelegate

getPIData() - Method in interface javax.xml.stream. XMLStreamReader

获取处理指令的数据部分

getPieValue() - Method in class javafx.scene.chart. PieChart.Data

获取属性pieValue的值。

getPITarget() - Method in class javax.xml.stream.util. StreamReaderDelegate

getPITarget() - Method in interface javax.xml.stream. XMLStreamReader

获取处理指令的目标

getPitch() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的音高属性定义。

getPitchBend() - Method in interface javax.sound.midi. MidiChannel

获得此通道的向上或向下音高偏移量。

getPitchRange() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的音高范围属性定义。

getPivotX() - Method in class javafx.scene.transform. Rotate

获取属性pivotX的值。

getPivotX() - Method in class javafx.scene.transform. Scale

获取属性pivotX的值。

getPivotX() - Method in class javafx.scene.transform. Shear

获取属性pivotX的值。

getPivotY() - Method in class javafx.scene.transform. Rotate

获取属性pivotY的值。

getPivotY() - Method in class javafx.scene.transform. Scale

获取属性pivotY的值。

getPivotY() - Method in class javafx.scene.transform. Shear

获取属性pivotY的值。

getPivotZ() - Method in class javafx.scene.transform. Rotate

获取属性pivotZ的值。

getPivotZ() - Method in class javafx.scene.transform. Scale

获取属性pivotZ的值。

getPixel(int, int, double[]) - Method in class java.awt.image. Raster

返回指定像素的double数组中的样本。

getPixel(int, int, double[], DataBuffer) - Method in class java.awt.image. SampleModel

返回double数组中指定像素的样本。

getPixel(int, int, float[]) - Method in class java.awt.image. Raster

返回指定像素的float数组中的样本。

getPixel(int, int, float[], DataBuffer) - Method in class java.awt.image. SampleModel

返回float数组中指定像素的样本。

getPixel(int, int, int[]) - Method in class java.awt.image. Raster

返回指定像素的int数组中的样本。

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. BandedSampleModel

返回int数组中指定像素的所有样本。

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. ComponentSampleModel

返回int数组中指定像素的所有样本，每个数组元素一个样本。

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. MultiPixelPackedSampleModel

返回 int数组的第一个元素中指定的单频带像素。

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. SampleModel

返回int数组中指定像素的样本，每个数组元素一个样本。

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

返回int数组中指定像素的所有样本。

getPixelBitStride() - Method in class java.awt.image. MultiPixelPackedSampleModel

返回像素位以位为单位。

getPixelBounds(FontRenderContext, float, float) - Method in class java.awt.font. GlyphVector

在给定位置给定的 FontRenderContext的图形中渲染时，返回此 GlyphVector的像素边界。

getPixelBounds(FontRenderContext, float, float) - Method in class java.awt.font. TextLayout

在给定位置的给定 FontRenderContext的图形中渲染时，返回此 TextLayout的像素边界。

getPixelColor(int, int) - Method in class java.awt. Robot

返回给定屏幕坐标处的像素颜色。

getPixelFormat() - Method in interface javafx.scene.image. PixelReader

该方法返回表面存储其像素的 PixelFormat ，或大致相当的像素格式，为了读取它们，它可以轻松地转换其像素。

getPixelFormat() - Method in interface javafx.scene.image. PixelWriter

该方法返回表面存储其像素的 PixelFormat ，或大致相当的像素格式，从而可以轻松地将像素转换为用于编写它们的像素。

getPixelReader() - Method in class javafx.scene.image. Image

该方法返回一个 PixelReader ，如果图像可读，则可以访问该图像的像素。

getPixels() - Method in class java.awt.image. PixelGrabber

获取像素缓冲区。

getPixels(int, int, int, int, double[]) - Method in class java.awt.image. Raster

返回一个包含像素矩形的所有样本的双数组，每个数组元素一个样本。

getPixels(int, int, int, int, double[], DataBuffer) - Method in class java.awt.image. SampleModel

返回双阵列中像素矩形的所有样本，每个数组元素一个样本。

getPixels(int, int, int, int, float[]) - Method in class java.awt.image. Raster

返回一个float数组，其中包含一个像素矩形的所有样本，每个数组元素一个样本。

getPixels(int, int, int, int, float[], DataBuffer) - Method in class java.awt.image. SampleModel

返回float数组中像素矩形的所有样本，每个数组元素一个样本。

getPixels(int, int, int, int, int[]) - Method in class java.awt.image. Raster

返回一个包含矩形像素的所有样本的int数组，每个数组元素一个样本。

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. BandedSampleModel

返回int数组中指定的像素矩形的所有样本，每个数据数组元素一个样本。

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. ComponentSampleModel

返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SampleModel

返回int数组中像素矩形的所有样本，每个数组元素一个样本。

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。

getPixels(int, int, int, int, WritablePixelFormat<ByteBuffer>, byte[], int, int) - Method in interface javafx.scene.image. PixelReader

将像素数据从表面的矩形区域读入指定的字节数组。

getPixels(int, int, int, int, WritablePixelFormat<IntBuffer>, int[], int, int) - Method in interface javafx.scene.image. PixelReader

将像素数据从表面的矩形区域读入指定的int数组。

getPixels(int, int, int, int, WritablePixelFormat<T>, T, int) - Method in interface javafx.scene.image. PixelReader

将像素数据从表面的矩形区域读入指定的缓冲区。

getPixelSize() - Method in class java.awt.image. ColorModel

返回此 ColorModel描述的每像素的 ColorModel 。

getPixelStride() - Method in class java.awt.image. ComponentSampleModel

返回此ComponentSampleModel的像素步幅。

getPixelWriter() - Method in class javafx.scene.canvas. GraphicsContext

返回一个PixelWriter对象，可用于修改与此GraphicsContext关联的Canvas的像素。

getPixelWriter() - Method in class javafx.scene.image. WritableImage

该方法返回一个 PixelWriter ，它提供访问以写入图像的像素。

getPlaceholder() - Method in class javafx.scene.control. ComboBox

获取属性占位符的值。

getPlaceholder() - Method in class javafx.scene.control. ListView

获取属性占位符的值。

getPlaceholder() - Method in class javafx.scene.control. TableView

获取属性占位符的值。

getPlaceholder() - Method in class javafx.scene.control. TreeTableView

获取属性占位符的值。

getPlaceholder() - Method in class javax.swing.text. MaskFormatter

如果值未完全填写掩码，则返回要使用的字符串。

getPlaceholderCharacter() - Method in class javax.swing.text. MaskFormatter

返回要用于代替值中不存在的字符的字符，即用户必须填写它们。

getPlain() - Method in class java.util.concurrent.atomic. AtomicBoolean

返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。

getPlain() - Method in class java.util.concurrent.atomic. AtomicInteger

返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。

getPlain() - Method in class java.util.concurrent.atomic. AtomicLong

返回当前值，具有读取的内存语义，就像该变量被声明为非 volatile 。

getPlain() - Method in class java.util.concurrent.atomic. AtomicReference

返回当前值，具有读取的内存语义，就好像变量被声明为非 volatile 。

getPlain(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

返回索引号为 i的元素的当前值，其读取的内存语义就好像变量被声明为非 volatile 。

getPlain(int) - Method in class java.util.concurrent.atomic. AtomicLongArray

返回索引号为 i的元素的当前值，读取的内存语义就好像变量被声明为非 volatile 。

getPlain(int) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

返回索引号为 i的元素的当前值，读取的内存语义就好像变量被声明为非 volatile 。

getPlatformClassLoader() - Static method in class java.lang. ClassLoader

返回用于委派的平台类加载器。

getPlatformManagementInterfaces() - Static method in class java.lang.management. ManagementFactory

返回Class对象的集合，子接口为PlatformManagedObject ，表示用于监视和管理Java平台的所有管理接口。

getPlatformMBeanServer() - Static method in class java.lang.management. ManagementFactory

返回平台MBeanServer 。

getPlatformMXBean(Class<T>) - Static method in class java.lang.management. ManagementFactory

返回实现给定的 mxbeanInterface的平台MXBean，它被指定为在Java虚拟机中具有一个实例。

getPlatformMXBean(MBeanServerConnection, Class<T>) - Static method in class java.lang.management. ManagementFactory

返回 mxbeanInterface的平台MXBean代理，该代理被指定为在Java虚拟机中具有一个实例，代理将通过给定的 MBeanServerConnection转发方法调用。

getPlatformMXBeans(Class<T>) - Static method in class java.lang.management. ManagementFactory

返回在Java虚拟机中实现给定的 mxbeanInterface的平台 mxbeanInterface列表。

getPlatformMXBeans(MBeanServerConnection, Class<T>) - Static method in class java.lang.management. ManagementFactory

返回平台MXBean代理的列表，用于通过给定的 MBeanServerConnection转发 mxbeanInterface的方法调用。

getPlayDuring() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的play-during属性定义。

getPlotChildren() - Method in class javafx.scene.chart. XYChart

情节中所有内容的可修改和可观察的列表。

getPluginClassName() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回与此服务提供商关联的 ImageReader或 ImageWriter插件的完全限定类名。

getPoint() - Method in class java.awt.event. MouseEvent

返回事件相对于源组件的x，y位置。

getPoint1() - Method in class java.awt. GradientPaint

返回锚点第一个颜色的点P1的副本。

getPoint2() - Method in class java.awt. GradientPaint

返回锚定第二种颜色的点P2的副本。

getPoint2D(Point2D, Point2D) - Method in class java.awt.image. AffineTransformOp

返回在源中给出点的对应目标点的位置。

getPoint2D(Point2D, Point2D) - Method in class java.awt.image. BandCombineOp

返回源 Raster给定点的对应目标点的位置。

getPoint2D(Point2D, Point2D) - Method in interface java.awt.image. BufferedImageOp

返回源图像中给定点的对应目标点的位置。

getPoint2D(Point2D, Point2D) - Method in class java.awt.image. ColorConvertOp

返回源中给定点的目标点的位置。

getPoint2D(Point2D, Point2D) - Method in class java.awt.image. ConvolveOp

返回源中给定点的目标点的位置。

getPoint2D(Point2D, Point2D) - Method in class java.awt.image. LookupOp

返回源中给定点的目标点的位置。

getPoint2D(Point2D, Point2D) - Method in interface java.awt.image. RasterOp

返回源光栅中给定点的目标点的位置。

getPoint2D(Point2D, Point2D) - Method in class java.awt.image. RescaleOp

返回源中给定点的目标点的位置。

getPointElementSize() - Method in class javafx.scene.shape. TriangleMesh

返回表示点的元素数。

getPointerInfo() - Static method in class java.awt. MouseInfo

返回表示当前鼠标指针位置的 PointerInfo实例。

getPointIndexOffset() - Method in class javafx.scene.shape. VertexFormat

返回顶点中点分量的面阵列中的索引偏移量。

getPoints() - Method in class javafx.scene.shape. Polygon

获取 Polygon顶点的坐标。

getPoints() - Method in class javafx.scene.shape. Polyline

获取 PolyLine段的坐标。

getPoints() - Method in class javafx.scene.shape. TriangleMesh

获取 points阵列如此 TriangleMesh 。

getPointsAtX() - Method in class javafx.scene.effect. Light.Spot

获取属性pointsAtX的值。

getPointsAtY() - Method in class javafx.scene.effect. Light.Spot

获取属性点的值。

getPointsAtZ() - Method in class javafx.scene.effect. Light.Spot

获取属性点AtZ的值。

getPointSize(int) - Method in class javax.swing.text.html. StyleSheet

给定大小索引返回点大小。

getPointSize(String) - Method in class javax.swing.text.html. StyleSheet

给定一个字符串，如“+2”，“-2”或“2”，返回一个点大小值。

getPolicy() - Method in class java.security.cert. X509CertSelector

返回策略标准。

getPolicy() - Static method in class java.security. Policy

返回已安装的Policy对象。

getPolicy() - Static method in class javax.security.auth. Policy

已过时。

返回已安装的Policy对象。

getPolicyQualifier() - Method in class java.security.cert. PolicyQualifierInfo

返回此 PolicyQualifierInfo的 qualifier字段的ASN.1 DER编码形式。

getPolicyQualifierId() - Method in class java.security.cert. PolicyQualifierInfo

返回 policyQualifierId这个领域 PolicyQualifierInfo 。

getPolicyQualifiers() - Method in interface java.security.cert. PolicyNode

返回与此节点所表示的有效策略相关联的策略限定符集。

getPolicyQualifiersRejected() - Method in class java.security.cert. PKIXParameters

获取PolicyQualifiersRejected标志。

getPolicyTree() - Method in class java.security.cert. PKIXCertPathValidatorResult

返回PKIX认证路径验证算法产生的有效策略树的根节点。

getPolyPressure(int) - Method in interface javax.sound.midi. MidiChannel

获得指定键被压下的压力。

getPool() - Static method in class java.util.concurrent. ForkJoinTask

返回托管当前线程的池，如果当前线程在任何ForkJoinPool之外执行，则返回 null 。

getPool() - Method in class java.util.concurrent. ForkJoinWorkerThread

返回托管此线程的池。

getPooledConnection() - Method in interface javax.sql. ConnectionPoolDataSource

尝试建立可用作池连接的物理数据库连接。

getPooledConnection(String, String) - Method in interface javax.sql. ConnectionPoolDataSource

尝试建立可用作池连接的物理数据库连接。

getPoolIndex() - Method in class java.util.concurrent. ForkJoinWorkerThread

返回此线程在其池中的唯一索引号。

getPoolName() - Method in class java.lang.management. MemoryNotificationInfo

返回触发此通知的内存池的名称。

getPoolSize() - Method in class java.util.concurrent. ForkJoinPool

返回已启动但尚未终止的工作线程数。

getPoolSize() - Method in class java.util.concurrent. ThreadPoolExecutor

返回池中当前的线程数。

getPopup(Component, Component, int, int) - Method in class javax.swing. PopupFactory

创建 Popup为组件 owner包含Component contents 。

getPopup(Component, Component, int, int, boolean) - Method in class javax.swing. PopupFactory

创建 Popup为组件 owner包含Component contents 。

getPopup(JPopupMenu, int, int) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 getPopup方法。

getPopup(JPopupMenu, int, int) - Method in class javax.swing.plaf. PopupMenuUI

返回 Popup ，负责显示 JPopupMenu 。

getPopupContent() - Method in class javafx.scene.control.skin. ColorPickerSkin

此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。

getPopupContent() - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。

getPopupContent() - Method in class javafx.scene.control.skin. ComboBoxPopupControl

此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。

getPopupContent() - Method in class javafx.scene.control.skin. DatePickerSkin

此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。

getPopupHeightForRowCount(int) - Method in class javax.swing.plaf.basic. BasicComboPopup

根据当前的ListCellRenderer和最大行数检索弹出窗口的高度。

getPopupLocation(MouseEvent) - Method in class javax.swing. JComponent

返回在该组件的坐标系中显示弹出菜单的首选位置。

getPopupMenu() - Method in class java.awt. TrayIcon

返回与此 TrayIcon关联的弹出菜单。

getPopupMenu() - Method in class javax.swing. JMenu

返回与此菜单关联的弹出菜单。

getPopupMenuListeners() - Method in class javax.swing. JComboBox

返回使用addPopupMenuListener（）添加到此JComboBox的所有 PopupMenuListener的数组。

getPopupMenuListeners() - Method in class javax.swing. JPopupMenu

返回使用addPopupMenuListener（）添加到该JMenuItem中的所有 PopupMenuListener的数组。

getPopupMenuOrigin() - Method in class javax.swing. JMenu

计算 JMenu的弹出菜单的原点。

getPopupSide() - Method in class javafx.scene.control. MenuButton

获取属性popupSide的值。

getPort() - Method in class java.net. DatagramPacket

返回发送数据报的远程主机上的端口号，或从中接收数据报的端口号。

getPort() - Method in class java.net. DatagramSocket

返回此套接字连接到的端口号。

getPort() - Method in class java.net. InetSocketAddress

获取端口号。

getPort() - Method in class java.net. Socket

返回此套接字连接到的远程端口号。

getPort() - Method in class java.net. SocketImpl

返回此套接字 port字段的值。

getPort() - Method in class java.net. URI

返回此URI的端口号。

getPort() - Method in class java.net. URL

获取此 URL的端口号。

getPort() - Method in class java.security.cert. LDAPCertStoreParameters

返回LDAP服务器的端口号。

getPort() - Method in class javax.management.remote. JMXServiceURL

服务网址的端口。

getPort(Class<T>) - Method in class javax.xml.ws. Service

getPort方法返回代理。

getPort(Class<T>) - Method in class javax.xml.ws.spi. ServiceDelegate

getPort方法返回代理。

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws. EndpointReference

getPort方法返回代理。

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws. Service

getPort方法返回代理。

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi. ServiceDelegate

getPort方法返回代理。

getPort(QName, Class<T>) - Method in class javax.xml.ws. Service

getPort方法返回代理。

getPort(QName, Class<T>) - Method in class javax.xml.ws.spi. ServiceDelegate

getPort方法返回代理。

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws. Service

getPort方法返回代理。

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi. ServiceDelegate

getPort方法返回代理。

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws. Service

getPort方法返回代理。

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi. Provider

getPort方法返回代理。

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi. ServiceDelegate

getPort方法返回代理。

getPortlist() - Method in class java.net. HttpCookie

返回cookie的端口列表属性

getPortName() - Method in interface javax.xml.ws.handler. PortInfo

获取被访问的WSDL端口的限定名称。

getPorts() - Method in class javax.xml.ws. Service

返回 Iterator的 QName的服务端点列表 QName服务分组

getPorts() - Method in class javax.xml.ws.spi. ServiceDelegate

返回 Iterator的 QName的服务端点列表， QName服务分组

getPosition() - Method in class java.awt.font. LineBreakMeasurer

返回此 LineBreakMeasurer的当前位置。

getPosition() - Method in class javafx.scene.chart. Axis.TickMark

获取属性位置的值。

getPosition() - Method in class javafx.scene.control.skin. VirtualFlow

获取属性位置的值。

getPosition() - Method in class javafx.scene.control. SplitPane.Divider

获取属性位置的值。

getPosition() - Method in class javafx.scene.layout. BackgroundImage

这个BackgroundImage相对于Region的位置。

getPosition() - Method in class javax.swing.text. TabStop

返回标签的位置，作为浮点数。

getPosition() - Method in interface javax.tools. Diagnostic

从与此诊断相关联的源对象的开头返回一个字符偏移量，表示问题的位置。

getPosition() - Method in class jdk.jshell. Diag

从与此诊断相关联的源对象的开头返回一个字符偏移量，表示问题的位置。

getPosition() - Method in interface jdk.nashorn.api.tree. Diagnostic

从与此诊断相关联的源对象的开始处获取一个字符偏移量，指示问题的位置。

getPosition() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的position属性定义。

getPosition() - Method in interface org.w3c.dom.ls. LSProgressEvent

输入源中的当前位置，包括已读取的所有外部实体和其他资源。

getPosition(int) - Method in class javax.swing. SizeSequence

返回指定条目的起始位置。

getPosition(long, long) - Method in interface com.sun.source.tree. LineMap

找到对应于（行，列）的位置。

getPosition(Component) - Method in class javax.swing. JLayeredPane

获取组件在其层内的相对位置。

getPositionAbove(JTextComponent, int, float) - Static method in class javax.swing.text. Utilities

确定模型中最接近上面行中给定视图位置的位置。

getPositionAbove(JTextComponent, int, int) - Static method in class javax.swing.text. Utilities

已过时。
替换为Utilities.getPositionAbove(JTextComponent, int, float)

getPositionBelow(JTextComponent, int, float) - Static method in class javax.swing.text. Utilities

确定模型中最接近下面行中给定视图位置的位置。

getPositionBelow(JTextComponent, int, int) - Static method in class javax.swing.text. Utilities

已过时。
代之以Utilities.getPositionBelow(JTextComponent, int, float)

getPositionsInRange(Vector, int, int) - Method in class javax.swing.text. GapContent

返回一个Vector，其中包含UndoPosRef的实例，其位置范围为 offset至 offset + length 。

getPositionsInRange(Vector, int, int) - Method in class javax.swing.text. StringContent

返回一个Vector包含UndoPosRef的实例，位置范围为 offset至 offset + length 。

getPositivePrefix() - Method in class java.text. DecimalFormat

获取正面前缀。

getPositiveSign() - Method in class java.time.format. DecimalStyle

获取表示正号的字符。

getPositiveSuffix() - Method in class java.text. DecimalFormat

获得积极的后缀。

getPosixFilePermissions(Path, LinkOption...) - Static method in class java.nio.file. Files

返回文件的POSIX文件权限。

getPreciseWheelRotation() - Method in class java.awt.event. MouseWheelEvent

返回鼠标滚轮旋转的“点击次数”为双倍。

getPrecision() - Method in class java.math. MathContext

返回 precision设置。

getPrecision() - Method in exception java.util. IllegalFormatPrecisionException

返回精度

getPrecision() - Method in class javax.sound.sampled. FloatControl

以控制措施的单位获得控制的决议或粒度。

getPrecision(int) - Method in interface java.sql. ParameterMetaData

检索指定参数的指定列大小。

getPrecision(int) - Method in interface java.sql. ResultSetMetaData

获取指定列的指定列大小。

getPrecision(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索存储在指定列中的值的总位数。

getPredefinedCursor(int) - Static method in class java.awt. Cursor

返回具有指定预定义类型的游标对象。

getPredicate() - Method in class javafx.collections.transformation. FilteredList

获取属性谓词的值。

getPredictionResistance() - Method in class java.security. DrbgParameters.NextBytes

返回是否请求预测电阻。

getPredictionResistance() - Method in class java.security. DrbgParameters.Reseed

返回是否请求预测电阻。

getPrefColumnCount() - Method in class javafx.scene.control. TextArea

获取属性prefColumnCount的值。

getPrefColumnCount() - Method in class javafx.scene.control. TextField

获取属性prefColumnCount的值。

getPrefColumns() - Method in class javafx.scene.layout. TilePane

获取属性prefColumns的值。

getPreferredButtonSize(AbstractButton, int) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils

返回按钮的首选大小。

getPreferredCommands() - Method in class javax.activation. DataHandler

返回此类型数据的 首选命令。

getPreferredCommands(String) - Method in class javax.activation. CommandMap

从MIME类型获取首选命令列表。

getPreferredCommands(String) - Method in class javax.activation. MailcapCommandMap

获取MIME类型的首选命令列表。

getPreferredCommands(String, DataSource) - Method in class javax.activation. CommandMap

从MIME类型获取首选命令列表。

getPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, Container) - Method in class javax.swing. LayoutStyle

返回两个组件之间使用的空间量。

getPreferredHeight() - Method in class javax.swing.tree. AbstractLayoutCache

返回首选高度。

getPreferredHeight() - Method in class javax.swing.tree. VariableHeightLayoutCache

返回首选高度。

getPreferredHorizontalSize() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回首选的水平尺寸。

getPreferredInnerHorizontal() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回首选尺寸的水平 JProgressBar 。

getPreferredInnerVertical() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

返回首选的垂直尺寸 JProgressBar 。

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

返回菜单项的首选大小。

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.synth. SynthMenuItemUI

返回菜单项的首选大小。

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.synth. SynthMenuUI

返回菜单项的首选大小。

getPreferredMinSize() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回最小首选大小。

getPreferredScrollableViewportSize() - Method in class javax.swing. JLayer

返回视图组件的视口的首选大小。

getPreferredScrollableViewportSize() - Method in class javax.swing. JList

计算显示 visibleRowCount行所需的视口大小。

getPreferredScrollableViewportSize() - Method in class javax.swing. JTable

返回此表的视口的首选大小。

getPreferredScrollableViewportSize() - Method in class javax.swing. JTextArea

如果此组件嵌入在JScrollPane中，则返回视口的首选大小。

getPreferredScrollableViewportSize() - Method in class javax.swing. JTree

返回首选显示尺寸为 JTree 。

getPreferredScrollableViewportSize() - Method in interface javax.swing. Scrollable

返回视图组件的视口的首选大小。

getPreferredScrollableViewportSize() - Method in class javax.swing.text. JTextComponent

返回视图组件的视口的首选大小。

getPreferredSize() - Method in class java.awt. Component

获取此组件的首选大小。

getPreferredSize() - Method in class java.awt. Container

返回此容器的首选大小。

getPreferredSize() - Method in class java.awt. List

获取此滚动列表的首选大小。

getPreferredSize() - Method in class java.awt. TextArea

确定此文本区域的首选大小。

getPreferredSize() - Method in class java.awt. TextField

获取此文本字段的首选大小。

getPreferredSize() - Method in class javafx.embed.swing. JFXPanel

返回此 JFXPanel的首选大小，以前设置为 JComponent.setPreferredSize(Dimension)或根据连接到此 JFXPanel的JavaFX场景的内容。

getPreferredSize() - Method in class javax.swing. JComponent

如果 preferredSize已经被设置为非 null值只是返回它。

getPreferredSize() - Method in class javax.swing. JEditorPane

返回 JEditorPane的首选大小。

getPreferredSize() - Method in class javax.swing. JTextArea

返回TextArea的首选大小。

getPreferredSize() - Method in class javax.swing. JTextField

返回 Dimensions所需的首选大小 TextField 。

getPreferredSize() - Method in class javax.swing. JToolBar.Separator

返回分隔符的首选大小。

getPreferredSize() - Method in class javax.swing.plaf.basic. BasicArrowButton

返回 BasicArrowButton的首选大小。

getPreferredSize() - Method in class javax.swing.plaf.basic. BasicComboBoxRenderer

getPreferredSize() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

返回dividerSize x dividerSize

getPreferredSize() - Method in class javax.swing.plaf.metal. MetalScrollButton

getPreferredSize() - Method in class javax.swing.table. JTableHeader

返回表头的首选大小。

getPreferredSize() - Method in class javax.swing.tree. DefaultTreeCellEditor.DefaultTextField

覆盖 JTextField.getPreferredSize以返回基于当前字体的首选大小，如果设置，或者使用渲染器的字体。

getPreferredSize() - Method in class javax.swing.tree. DefaultTreeCellEditor.EditorContainer

返回 Container的首选大小。

getPreferredSize() - Method in class javax.swing.tree. DefaultTreeCellRenderer

覆盖 JComponent.getPreferredSize以返回略宽的首选大小值。

getPreferredSize(int) - Method in class java.awt. List

获取具有指定行数的列表的首选尺寸。

getPreferredSize(int) - Method in class java.awt. TextField

使用指定的列数获取此文本字段的首选大小。

getPreferredSize(int, int) - Method in class java.awt. TextArea

确定具有指定行数和列数的文本区域的首选大小。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回首选大小。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicLabelUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicListUI

列表的preferredSize取决于布局方向。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

如果 c是 JOptionPane的接收器，则返回的首选大小是 LayoutManager的 JOptionPane和 getMinimumOptionPaneSize的首选大小的 getMinimumOptionPaneSize 。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicPopupMenuSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicRadioButtonUI

单选按钮的首选大小

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

垂直滚动条的首选宽度是（非 null ）增量/减量按钮的最大宽度和拇指的最小宽度的最大值。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSliderUI

返回首选大小。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回传入的组件的首选大小，这被传递给当前的布局管理器。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

返回标题的首选大小。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTableUI

返回表的首选大小。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTextAreaUI

该方法被覆盖以考虑插入符宽度。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTextUI

获取编辑器组件的首选大小。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicToolBarSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回首选大小以正确显示树，这是一个覆盖方法 getPreferredSize(c, true) 。

getPreferredSize(JComponent) - Method in class javax.swing.plaf. ComponentUI

返回指定组件的偏好大小，适合外观和感觉。

getPreferredSize(JComponent) - Method in class javax.swing.plaf. LayerUI

如果 JLayer的视图组件不是 null ，则返回视图的 getPreferredSize()方法的结果。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal. MetalDesktopIconUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

返回指定的首选大小 JFileChooser 。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal. MetalPopupMenuSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal. MetalScrollBarUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal. MetalSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal. MetalToolTipUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI

在此对象处理的每个UI上调用 getPreferredSize方法。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回指定组件的偏好大小，适合外观和感觉。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth. SynthLabelUI

返回指定组件的偏好大小，适合外观和感觉。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth. SynthProgressBarUI

返回指定组件的偏好大小，适合外观和感觉。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth. SynthScrollBarUI

垂直滚动条的首选宽度是（非 null ）增量/减量按钮的最大宽度和拇指的最小宽度的最大值。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI

返回指定组件的偏好大小，适合外观和感觉。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth. SynthSliderUI

返回首选大小。

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI

返回指定组件的偏好大小，适合外观和感觉。

getPreferredSize(JComponent, boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回在 c中表示树的首选大小。

getPreferredSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils

返回正确呈现图标和文字所需的首选大小。

getPreferredSizeOfComponent(Component) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

返回传递的组件首选大小的宽度。

getPreferredSpan(int) - Method in class javax.swing.text. AsyncBoxView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. BoxView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. ComponentView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. FieldView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. GlyphView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text.html. BlockView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text.html. ImageView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text.html. ParagraphView

确定此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. IconView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. PasswordView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. PlainView

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. TableView.TableRow

getPreferredSpan(int) - Method in class javax.swing.text. View

确定沿着轴的此视图的首选跨度。

getPreferredSpan(int) - Method in class javax.swing.text. WrappedPlainView

确定沿着轴的此视图的首选跨度。

getPreferredThumbnailSizes(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - Method in class javax.imageio. ImageWriter

返回 Dimension s的数组，表示缩略图的合法尺寸范围，因为它们将被编码在输出文件或流中。

getPreferredTileSizes() - Method in class javax.imageio. ImageWriteParam

返回一个 Dimension s的数组，表示瓦片的合法尺寸范围，因为它们将被编码在输出文件或流中。

getPreferredValue() - Method in class javax.swing. Spring

返回此 Spring的 首选值。

getPreferredVerticalSize() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回首选的垂直尺寸。

getPreferredWidth() - Method in class javax.swing.table. TableColumn

返回 TableColumn的首选宽度。

getPreferredWidth(Rectangle) - Method in class javax.swing.tree. AbstractLayoutCache

返回传入区域的首选宽度。

getPreferredWidth(Rectangle) - Method in class javax.swing.tree. VariableHeightLayoutCache

返回 visibleRegion该区域的首选宽度和高度。

getPrefHeight() - Method in class javafx.scene.control. PopupControl

用于覆盖控件计算的首选高度的属性。

getPrefHeight() - Method in class javafx.scene.layout. Region

获取属性prefHeight的值。

getPrefHeight() - Method in class javafx.scene.layout. RowConstraints

获取属性prefHeight的值。

getPrefHeight() - Method in class javafx.scene.web. WebView

获取属性prefHeight的值。

getPrefix() - Method in class javax.imageio.metadata. IIOMetadataNode

返回 null ，因为不支持命名空间。

getPrefix() - Method in class javax.xml.namespace. QName

获取此 QName的前缀。

getPrefix() - Method in interface javax.xml.soap. Name

返回在初始化 Name对象时指定的前缀。

getPrefix() - Method in interface javax.xml.stream.events. Namespace

获取前缀，如果这是默认命名空间声明，则返回“”。

getPrefix() - Method in class javax.xml.stream.util. StreamReaderDelegate

getPrefix() - Method in interface javax.xml.stream. XMLStreamReader

返回当前事件的前缀，如果事件没有前缀，则返回null

getPrefix() - Method in interface org.w3c.dom. Node

该节点的命名空间前缀，如果未指定， null 。

getPrefix(int) - Method in class javax.naming. CompositeName

创建一个组合名称，其组件由此组合名称中组件的前缀组成。

getPrefix(int) - Method in class javax.naming. CompoundName

创建一个复合名称，其组成部分由此化合物名称中的组件的前缀组成。

getPrefix(int) - Method in class javax.naming.ldap. LdapName

创建一个名称，其组件由此LDAP名称的组件的前缀组成。

getPrefix(int) - Method in interface javax.naming. Name

创建一个名称，其组件由此名称的组件的前缀组成。

getPrefix(String) - Method in interface javax.xml.namespace. NamespaceContext

获取前缀绑定到当前作用域中的命名空间URI。

getPrefix(String) - Method in interface javax.xml.stream. XMLEventWriter

获取uri绑定的前缀

getPrefix(String) - Method in interface javax.xml.stream. XMLStreamWriter

获取uri绑定的前缀

getPrefix(String) - Method in class org.xml.sax.helpers. NamespaceSupport

返回映射到命名空间URI的前缀之一。

getPrefixes() - Method in class org.xml.sax.helpers. NamespaceSupport

返回其声明在当前上下文中处于活动状态的所有前缀的枚举。

getPrefixes(String) - Method in interface javax.xml.namespace. NamespaceContext

获取绑定到当前作用域中的命名空间URI的所有前缀。

getPrefixes(String) - Method in class org.xml.sax.helpers. NamespaceSupport

返回给定URI的所有前缀的枚举，其声明在当前上下文中处于活动状态。

getPrefixList() - Method in class javax.xml.crypto.dsig.spec. ExcC14NParameterSpec

返回包含的名称空间前缀列表。

getPrefRowCount() - Method in class javafx.scene.control. TextArea

获取属性prefRowCount的值。

getPrefRows() - Method in class javafx.scene.layout. TilePane

获取属性prefRows的值。

getPrefTileHeight() - Method in class javafx.scene.layout. TilePane

获取属性prefTileHeight的值。

getPrefTileWidth() - Method in class javafx.scene.layout. TilePane

获取属性prefTileWidth的值。

getPrefViewportHeight() - Method in class javafx.scene.control. ScrollPane

获取属性prefViewportHeight的值。

getPrefViewportWidth() - Method in class javafx.scene.control. ScrollPane

获取属性prefViewportWidth的值。

getPrefWidth() - Method in class javafx.scene.control. PopupControl

覆盖控件计算的首选宽度的属性。

getPrefWidth() - Method in class javafx.scene.control. TableColumnBase

获取属性prefWidth的值。

getPrefWidth() - Method in class javafx.scene.layout. ColumnConstraints

获取属性prefWidth的值。

getPrefWidth() - Method in class javafx.scene.layout. Region

获取属性prefWidth的值。

getPrefWidth() - Method in class javafx.scene.web. WebView

获取属性prefWidth的值。

getPrefWrapLength() - Method in class javafx.scene.layout. FlowPane

获取属性prefWrapLength的值。

getPresentationName() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

提供适用于（例如更改日志）的此编辑的本地化，可读取的描述。

getPresentationName() - Method in class javax.swing.undo. AbstractUndoableEdit

此默认实现返回“”。

getPresentationName() - Method in class javax.swing.undo. CompoundEdit

从最后 UndoableEdit返回 getPresentationName加到 edits 。

getPresentationName() - Method in class javax.swing.undo. StateEdit

获取此编辑的演示文稿名称

getPresentationName() - Method in interface javax.swing.undo. UndoableEdit

例如，返回适用于更改日志的本编辑的本地化，可读取的描述。

getPreservesUnknownTags() - Method in class javax.swing.text.html. HTMLDocument

返回解析器遇到未知标记时观察到的行为。

getPressedIcon() - Method in class javax.swing. AbstractButton

返回按钮的按下图标。

getPreviewPanel() - Static method in class javax.swing.colorchooser. ColorChooserComponentFactory

返回预览面板。

getPreviewPanel() - Method in class javax.swing. JColorChooser

返回显示所选颜色的预览面板。

getPreviousBounds(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager

在组件最大化之前获取组件的正常范围。

getPreviousElementSibling() - Method in interface org.w3c.dom. ElementTraversal

返回对文档顺序中最紧靠元素之前的元素的兄弟节点的引用，并且是Element类型的引用 。

getPreviousLeaf() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点之前的叶子，如果此节点是树中的第一个叶子，则返回null。

getPreviousNode() - Method in class javax.swing.tree. DefaultMutableTreeNode

在此节点的树的预序遍历中返回此节点之前的节点。

getPreviousRowCount() - Method in class javax.swing.event. RowSorterEvent

返回排序前的行数。

getPreviousSibling() - Method in class javax.imageio.metadata. IIOMetadataNode

返回此节点以前的同级，如果此节点没有以前的同级，则返回 null 。

getPreviousSibling() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回父节点的子节点中此节点的前一个同级节点。

getPreviousSibling() - Method in interface org.w3c.dom. Node

紧邻节点之前的节点。

getPreviousTabIndex(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回上一个选项卡索引。

getPreviousTabIndexInRun(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回运行中的上一个选项卡索引。

getPreviousTabRun(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回上一个选项卡运行。

getPreviousValue() - Method in class javax.swing. JSpinner

返回 getValue()返回的对象之前的序列中的对象。

getPreviousValue() - Method in class javax.swing. SpinnerDateModel

返回以前 Date序列中，或 null如果上一个日期是前 start 。

getPreviousValue() - Method in class javax.swing. SpinnerListModel

如果值已经是第一个元素，则返回底层序列的前一个元素或 null 。

getPreviousValue() - Method in interface javax.swing. SpinnerModel

按 getValue()返回的对象之前的顺序返回对象。

getPreviousValue() - Method in class javax.swing. SpinnerNumberModel

返回序列中的前一个数字。

getPreviousWord(JTextComponent, int) - Static method in class javax.swing.text. Utilities

确定给定位置的上一个字的开始。

getPrevValue() - Method in interface org.w3c.dom.events. MutationEvent

prevValue指示的先前值 Attr在DOMAttrModified事件点，并且其的 CharacterData在DOMCharacterDataModified事件节点。

getPrimary() - Static method in class javafx.stage. Screen

主要 Screen 。

getPrimary1() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回主要1色。

getPrimary1() - Method in class javax.swing.plaf.metal. MetalTheme

返回主要1色。

getPrimary1() - Method in class javax.swing.plaf.metal. OceanTheme

返回主要1色。

getPrimary2() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回主2颜色。

getPrimary2() - Method in class javax.swing.plaf.metal. MetalTheme

返回主2颜色。

getPrimary2() - Method in class javax.swing.plaf.metal. OceanTheme

返回主2颜色。

getPrimary3() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回主3颜色。

getPrimary3() - Method in class javax.swing.plaf.metal. MetalTheme

返回主3颜色。

getPrimary3() - Method in class javax.swing.plaf.metal. OceanTheme

返回主3颜色。

getPrimaryControl() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的主控制颜色。

getPrimaryControl() - Method in class javax.swing.plaf.metal. MetalTheme

返回主控制颜色。

getPrimaryControlDarkShadow() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的主控制阴影颜色。

getPrimaryControlDarkShadow() - Method in class javax.swing.plaf.metal. MetalTheme

返回主控制暗影色。

getPrimaryControlHighlight() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的主控制突出显示颜色。

getPrimaryControlHighlight() - Method in class javax.swing.plaf.metal. MetalTheme

返回主控制高亮颜色。

getPrimaryControlInfo() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的主控制信息颜色。

getPrimaryControlInfo() - Method in class javax.swing.plaf.metal. MetalTheme

返回主控制信息颜色。

getPrimaryControlShadow() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的主控制阴影颜色。

getPrimaryControlShadow() - Method in class javax.swing.plaf.metal. MetalTheme

返回主控制阴影颜色。

getPrimaryGroupID() - Method in class com.sun.security.auth.module. NTSystem

获取当前NT用户的可打印主组SID。

getPrimaryKeys(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索给定表的主键列的描述。

getPrimaryType() - Method in class java.awt.datatransfer. DataFlavor

返回此 DataFlavor的主MIME类型。

getPrimaryType() - Method in class javax.activation. MimeType

检索此对象的主要类型。

getPrime() - Method in class java.security.spec. RSAOtherPrimeInfo

返回素数。

getPrimeExponentP() - Method in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

返回primeExponentP。

getPrimeExponentP() - Method in interface java.security.interfaces. RSAPrivateCrtKey

返回primeExponentP。

getPrimeExponentP() - Method in class java.security.spec. RSAMultiPrimePrivateCrtKeySpec

返回primeExponentP。

getPrimeExponentP() - Method in class java.security.spec. RSAPrivateCrtKeySpec

返回primeExponentP。

getPrimeExponentQ() - Method in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

返回primeExponentQ。

getPrimeExponentQ() - Method in interface java.security.interfaces. RSAPrivateCrtKey

返回primeExponentQ。

getPrimeExponentQ() - Method in class java.security.spec. RSAMultiPrimePrivateCrtKeySpec

返回primeExponentQ。

getPrimeExponentQ() - Method in class java.security.spec. RSAPrivateCrtKeySpec

返回primeExponentQ。

getPrimeP() - Method in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

返回primeP。

getPrimeP() - Method in interface java.security.interfaces. RSAPrivateCrtKey

返回primeP。

getPrimeP() - Method in class java.security.spec. RSAMultiPrimePrivateCrtKeySpec

返回primeP。

getPrimeP() - Method in class java.security.spec. RSAPrivateCrtKeySpec

返回primeP。

getPrimePLength() - Method in class java.security.spec. DSAGenParameterSpec

以位为单位返回要生成的DSA域参数的素数P的期望长度。

getPrimeQ() - Method in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

返回primeQ。

getPrimeQ() - Method in interface java.security.interfaces. RSAPrivateCrtKey

返回primeQ。

getPrimeQ() - Method in class java.security.spec. RSAMultiPrimePrivateCrtKeySpec

返回primeQ。

getPrimeQ() - Method in class java.security.spec. RSAPrivateCrtKeySpec

返回primeQ。

getPrimeSize() - Method in class javax.crypto.spec. DHGenParameterSpec

返回素数模数的大小。

getPrimitiveArrayType(Class<T>) - Static method in class javax.management.openmbean. ArrayType

以类型安全的方式创建一个 ArrayType实例。

getPrimitiveType() - Method in interface org.w3c.dom.css. CSSPrimitiveValue

由上面指定的常数定义的值的类型。

getPrimitiveType(Class<?>) - Static method in class jdk.dynalink.linker.support. TypeUtilities

当传递一个表示原始类型的包装器的类时，返回表示相应基本类型的类。

getPrimitiveType(TypeKind) - Method in interface javax.lang.model.util. Types

返回一个原始类型。

getPrimitiveTypeByName(String) - Static method in class jdk.dynalink.linker.support. TypeUtilities

给定一个原始类型的名称返回表示它的类。

getPrimitiveTypeKind() - Method in interface com.sun.source.tree. PrimitiveTypeTree

返回此类型的原始类型。

getPrincipal() - Method in class com.sun.net.httpserver. Authenticator.Success

返回经过身份验证的用户主体

getPrincipal() - Method in class com.sun.net.httpserver. HttpExchange

如果认证被设置在拥有这种交换的HttpContext，则此方法将返回HttpPrincipal ，表示此HttpExchange身份验证的用户。

getPrincipal() - Method in interface java.security.acl. AclEntry

已过时。

返回此ACL条目授予或拒绝权限的主体。

getPrincipal() - Method in interface java.security. Certificate

已过时。

返回担保人担保的主 - 对对的本金。

getPrincipal() - Method in class javax.security.auth.kerberos. KerberosKey

返回此密钥所属的主体。

getPrincipal() - Method in class javax.security.auth.kerberos. KeyTab

返回 KeyTab对象所绑定的服务主体。

getPrincipals() - Method in class java.security. ProtectionDomain

返回此域的主体数组。

getPrincipals() - Method in class javax.security.auth. PrivateCredentialPermission

返回与这个 PrivateCredentialPermission相关联的 Principal类和名称。

getPrincipals() - Method in class javax.security.auth. Subject

返回 Set与此相关的校长 Subject 。

getPrincipals(Class<T>) - Method in class javax.security.auth. Subject

返回 Set与此关联的Principal Subject是实例或指定的子类 Class 。

getPrintable(int) - Method in class java.awt.print. Book

返回Printable实例，负责渲染由pageIndex指定的pageIndex 。

getPrintable(int) - Method in interface java.awt.print. Pageable

返回 Printable实例，负责渲染由 pageIndex指定的 pageIndex 。

getPrintable(MessageFormat, MessageFormat) - Method in class javax.swing.text. JTextComponent

返回 Printable用于打印该内容 JTextComponent 。

getPrintable(JTable.PrintMode, MessageFormat, MessageFormat) - Method in class javax.swing. JTable

返回一个用于打印此JTable的 Printable 。

getPrintableArea(int) - Method in class javax.print.attribute.standard. MediaPrintableArea

将可打印区域按照x，y，w，h的顺序排列为4个数组。

getPrintableHeight() - Method in class javafx.print. PageLayout

考虑到方向，返回页面可打印区域的高度尺寸，以1/72英寸为单位。

getPrintableWidth() - Method in class javafx.print. PageLayout

考虑到方向，返回页面可打印区域的宽度尺寸，以1/72英寸为单位。

getPrintColor() - Method in class javafx.print. JobSettings

获取属性printColor的值。

getPrintData() - Method in interface javax.print. Doc

以与支持的文档风格相对应的格式获取包含此文档对象的打印数据的打印数据表示对象。

getPrintData() - Method in class javax.print. SimpleDoc

getPrinter() - Method in class java.awt. JobAttributes

使用这些属性返回作业的目标打印机。

getPrinter() - Method in class javafx.print. PrinterJob

获取当前与此作业相关联的打印机。

getPrinterAttributes() - Method in class javafx.print. Printer

检索封装打印机属性和功能的委托对象。

getPrinterJob() - Method in interface java.awt.print. PrinterGraphics

返回正在控制当前呈现请求的 PrinterJob 。

getPrinterJob() - Static method in class java.awt.print. PrinterJob

创建并返回最初与默认打印机相关联的 PrinterJob 。

getPrinterResolution() - Method in class java.awt. PageAttributes

返回使用这些属性的页面的打印分辨率。

getPrintEventType() - Method in class javax.print.event. PrintJobEvent

获取此事件的原因。

getPrintJob() - Method in interface java.awt. PrintGraphics

返回此PrintGraphics对象始发的PrintJob对象。

getPrintJob() - Method in class javax.print.event. PrintJobAttributeEvent

确定此打印作业事件所属的打印作业。

getPrintJob() - Method in class javax.print.event. PrintJobEvent

确定此打印作业事件所涉及的 DocPrintJob 。

getPrintJob(Frame, String, JobAttributes, PageAttributes) - Method in class java.awt. Toolkit

获取一个 PrintJob对象，这是在工具包的平台上启动打印操作的结果。

getPrintJob(Frame, String, Properties) - Method in class java.awt. Toolkit

获取一个 PrintJob对象，这是在工具包的平台上启动打印操作的结果。

getPrintQuality() - Method in class java.awt. PageAttributes

使用这些属性返回页面的打印质量。

getPrintQuality() - Method in class javafx.print. JobSettings

获取属性printQuality的值。

getPrintResolution() - Method in class javafx.print. JobSettings

getPrintService() - Method in class java.awt.print. PrinterJob

返回此打印机作业的服务（打印机）。

getPrintService() - Method in interface javax.print. DocPrintJob

确定此打印作业对象所绑定的PrintService对象。

getPrintService() - Method in class javax.print.event. PrintServiceAttributeEvent

返回打印服务。

getPrintService(OutputStream) - Method in class javax.print. StreamPrintServiceFactory

返回可以打印到指定输出流的 StreamPrintService 。

getPrintServices() - Method in class javax.print. PrintServiceLookup

不被应用程序直接调用

getPrintServices(DocFlavor, AttributeSet) - Method in class javax.print. PrintServiceLookup

找到可以肯定确认的服务，以支持指定的属性和DocFlavors的组合。

getPrintSides() - Method in class javafx.print. JobSettings

如果打印机支持它，则可以在介质（纸张）的两面上打印作业，即双面打印。

getPriority() - Method in class java.lang.management. ThreadInfo

返回 thread priority与此相关的线程 ThreadInfo 。

getPriority() - Method in class java.lang. Thread

返回此线程的优先级。

getPriority() - Method in class javafx.scene.media. AudioClip

获取默认播放优先级。

getPrivacy() - Method in class org.ietf.jgss. MessageProp

检索隐私状态。

getPrivate() - Method in class java.security. KeyPair

返回对此密钥对的私钥组件的引用。

getPrivateCredentials() - Method in class javax.security.auth. Subject

返回 Set所持有的私人证书 Subject 。

getPrivateCredentials(Class<T>) - Method in class javax.security.auth. Subject

返回一个 Set与此相关的私有证书 Subject是实例或指定的子类 Class 。

getPrivateExponent() - Method in interface java.security.interfaces. RSAPrivateKey

返回私有指数。

getPrivateExponent() - Method in class java.security.spec. RSAPrivateKeySpec

返回私有指数。

getPrivateKey() - Method in class java.security. KeyStore.PrivateKeyEntry

从此条目获取 PrivateKey 。

getPrivateKey() - Method in class java.security. Signer

已过时。

返回此签名者的私钥。

getPrivateKey() - Method in class javax.security.auth.x500. X500PrivateCredential

返回PrivateKey。

getPrivateKey(String) - Method in interface javax.net.ssl. X509KeyManager

返回与给定别名相关联的键。

getPrivateKeyValid() - Method in class java.security.cert. X509CertSelector

返回privateKeyValid条件。

getProblemType() - Method in class javax.management.relation. RoleUnresolved

检索问题类型。

getProcedureColumns(String, String, String, String) - Method in interface java.sql. DatabaseMetaData

检索给定目录的存储过程参数和结果列的描述。

getProcedures(String, String, String) - Method in interface java.sql. DatabaseMetaData

200的X- 200 200 X- 200 200 X- 200 200：

getProcedureTerm() - Method in interface java.sql. DatabaseMetaData

检索“程序”的数据库供应商的首选项。

getProcessCpuLoad() - Method in interface com.sun.management. OperatingSystemMXBean

返回Java虚拟机进程的“最近的cpu用法”。

getProcessCpuTime() - Method in interface com.sun.management. OperatingSystemMXBean

返回Java虚拟机运行的进程以纳秒为单位的CPU时间。

getProcessedDTD() - Method in interface javax.xml.stream.events. DTD

返回DTD的实现定义表示。

getProfile() - Method in class java.awt.color. ICC_ColorSpace

返回ICC_ColorSpace的ICC_Profile。

getProfile() - Method in interface org.w3c.dom.html. HTMLHeadElement

指定元数据配置文件的URI。

getProfileClass() - Method in class java.awt.color. ICC_Profile

返回概要文件类。

getProgram() - Method in interface javax.sound.midi. MidiChannel

获取此通道的当前程序编号。

getProgram() - Method in class javax.sound.midi. Patch

返回银行中 Patch指定的工具的 Patch 。

getProgram(String...) - Method in interface javax.script. ScriptEngineFactory

返回带有给定语句的有效脚本语言可执行程序。

getProgram(String...) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getProgress() - Method in class javafx.application. Preloader.ProgressNotification

检索此通知的进度。

getProgress() - Method in class javafx.concurrent. Service

获取属性进度的值。

getProgress() - Method in class javafx.concurrent. Task

获取属性进度的值。

getProgress() - Method in interface javafx.concurrent. Worker

表示该工作人员目前在完成百分比方面的进度。

getProgress() - Method in class javafx.scene.control. ProgressIndicator

获取属性进度的值。

getProgress() - Method in class javafx.scene.image. Image

获取属性进度的值。

getProgress() - Method in class javax.swing. SwingWorker

返回 progress绑定属性。

getProgressBarBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JProgressBar的边框实例。

getProgressiveMode() - Method in class javax.imageio. ImageWriteParam

返回以逐行方式写入流的当前模式。

getProgressMonitor() - Method in class javax.swing. ProgressMonitorInputStream

获取此流所使用的ProgressMonitor对象。

getPrompt() - Method in class javax.security.auth.callback. ChoiceCallback

获取提示。

getPrompt() - Method in class javax.security.auth.callback. ConfirmationCallback

获取提示。

getPrompt() - Method in class javax.security.auth.callback. NameCallback

获取提示。

getPrompt() - Method in class javax.security.auth.callback. PasswordCallback

获取提示。

getPrompt() - Method in class javax.security.auth.callback. TextInputCallback

获取提示。

getPrompt() - Method in interface org.w3c.dom.html. HTMLIsIndexElement

提示信息。

getPromptHandler() - Method in class javafx.scene.web. WebEngine

获取属性promptHandler的值。

getPromptText() - Method in class javafx.scene.control. ComboBoxBase

获取属性promptText的值。

getPromptText() - Method in class javafx.scene.control. Spinner

获取属性promptText的值。

getPromptText() - Method in class javafx.scene.control. TextInputControl

获取属性promptText的值。

getPromptTextFill() - Method in class javafx.scene.control.skin. TextInputControlSkin

获取属性promptTextFill的值。

getPropagatedFrom() - Method in class java.beans.beancontext. BeanContextEvent

获取传播此事件的 BeanContext 。

getPropagationId() - Method in class java.beans. PropertyChangeEvent

“propagationId”字段保留供将来使用。

getProperties() - Static method in class java.lang. System

确定当前的系统属性。

getProperties() - Method in class javafx.scene.control. MenuItem

返回此菜单项上可观察到的属性映射，主要由应用程序开发人员使用。

getProperties() - Method in class javafx.scene.control. Tab

返回此选项卡上属性的可观察图，主要由应用程序开发人员使用。

getProperties() - Method in class javafx.scene.control. TableColumnBase

返回此表列上属性的可观察图，主要由应用程序开发人员使用。

getProperties() - Method in interface javafx.scene.control. Toggle

返回此切换上属性的可观察地图，主要由应用程序开发人员使用。

getProperties() - Method in class javafx.scene.control. ToggleGroup

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

getProperties() - Method in class javafx.scene. Node

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

getProperties() - Method in class javafx.scene. Scene

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

getProperties() - Method in class javafx.stage. Window

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

getProperties() - Method in interface javax.xml.crypto.dsig. SignatureProperties

返回SignatureProperties中包含的一个或多个SignatureProperty的SignatureProperties 。

getProperties() - Method in class javax.xml.ws. Endpoint

返回此 Endpoint实例的属性包。

getProperties() - Method in interface jdk.nashorn.api.tree. ObjectLiteralTree

返回此对象文字的属性列表。

getProperty() - Method in class javafx.css. CssMetaData

getProperty() - Method in class javafx.css. Declaration

getProperty() - Method in class javafx.scene.control.cell. PropertyValueFactory

返回构造函数中提供的属性名称。

getProperty() - Method in class javafx.scene.control.cell. TreeItemPropertyValueFactory

返回构造函数中提供的属性名称。

getProperty(ParameterBlock, String) - Method in interface java.awt.image.renderable. ContextualRenderedImageFactory

获取由name参数指定的属性的适当实例。

getProperty(Object) - Method in interface com.sun.jdi.request. EventRequest

使用指定的键返回属性的值。

getProperty(Object) - Method in class javax.swing.text. AbstractDocument

查找属性值的方便方法。

getProperty(Object) - Method in interface javax.swing.text. Document

获取与文档关联的属性。

getProperty(String) - Method in class java.awt.image. BufferedImage

按名称返回图像的属性。

getProperty(String) - Method in interface java.awt.image.renderable. RenderableImage

从该图像的属性集获取属性。

getProperty(String) - Method in class java.awt.image.renderable. RenderableImageOp

从该图像的属性集获取属性。

getProperty(String) - Method in interface java.awt.image. RenderedImage

从该图像的属性集获取属性。

getProperty(String) - Static method in class java.lang. System

获取指定键指示的系统属性。

getProperty(String) - Method in class java.security. Provider

getProperty(String) - Static method in class java.security. Security

获取安全属性值。

getProperty(String) - Method in class java.util.logging. LogManager

获取日志记录属性的值。

getProperty(String) - Method in class java.util. Properties

使用此属性列表中指定的键搜索属性。

getProperty(String) - Method in class javax.sound.midi. MidiFileFormat

获取由密钥指定的属性值。

getProperty(String) - Method in class javax.sound.sampled. AudioFileFormat

获取由密钥指定的属性值。

getProperty(String) - Method in class javax.sound.sampled. AudioFormat

获取由密钥指定的属性值。

getProperty(String) - Method in class javax.xml.bind. Binder

获取底层实现中的特定属性 Binder 。

getProperty(String) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

getProperty方法的默认实现处理Marshaller中四个定义的属性。

getProperty(String) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

getProperty方法的默认实现总是抛出PropertyException，因为没有必需的属性。

getProperty(String) - Method in interface javax.xml.bind. Marshaller

获取底层实现中的特定属性 Marshaller 。

getProperty(String) - Method in interface javax.xml.bind. Unmarshaller

获取底层实现中的特定属性 Unmarshaller 。

getProperty(String) - Method in interface javax.xml.bind. Validator

已过时。
自JAXB2.0起

getProperty(String) - Method in class javax.xml.crypto.dom. DOMCryptoContext

此实现使用内部HashMap获取指定名称映射到的对象。

getProperty(String) - Method in interface javax.xml.crypto. XMLCryptoContext

返回指定属性的值。

getProperty(String) - Method in class javax.xml.parsers. SAXParser

返回底层实现中请求的特定属性XMLReader 。

getProperty(String) - Method in class javax.xml.soap. SOAPMessage

检索指定属性的值。

getProperty(String) - Method in class javax.xml.stream.util. EventReaderDelegate

getProperty(String) - Method in class javax.xml.stream.util. StreamReaderDelegate

getProperty(String) - Method in interface javax.xml.stream. XMLEventReader

从底层实现获取特征/属性的值

getProperty(String) - Method in class javax.xml.stream. XMLInputFactory

从底层实现获取特征/属性的值

getProperty(String) - Method in class javax.xml.stream. XMLOutputFactory

获取底层实现的功能/属性

getProperty(String) - Method in interface javax.xml.stream. XMLStreamReader

从底层实现获取特征/属性的值

getProperty(String) - Method in interface javax.xml.stream. XMLStreamWriter

从底层实现获取特征/属性的值

getProperty(String) - Method in class javax.xml.validation. SchemaFactory

查找属性的值。

getProperty(String) - Method in class javax.xml.validation. Validator

查找属性的值。

getProperty(String) - Method in class javax.xml.validation. ValidatorHandler

查找属性的值。

getProperty(String) - Method in class jdk.security.jarsigner. JarSigner

返回由指定键指示的附加实现特定属性的值。

getProperty(String) - Method in class org.xml.sax.helpers. ParserAdapter

获取解析器属性。

getProperty(String) - Method in class org.xml.sax.helpers. XMLFilterImpl

查找属性的值。

getProperty(String) - Method in interface org.xml.sax. XMLReader

查找属性的值。

getProperty(String, ImageObserver) - Method in class java.awt.image. AbstractMultiResolutionImage

该方法简单地委托给基本图像上相同的方法，它相当于： getBaseImage().getProperty(name, observer) 。

getProperty(String, ImageObserver) - Method in class java.awt.image. BufferedImage

按名称返回图像的属性。

getProperty(String, ImageObserver) - Method in class java.awt. Image

通过名称获取此图像的属性。

getProperty(String, String) - Static method in class java.awt. Toolkit

获取具有指定键和默认值的属性。

getProperty(String, String) - Static method in class java.lang. System

获取指定键指示的系统属性。

getProperty(String, String) - Method in class java.util. Properties

使用此属性列表中指定的键搜索属性。

getPropertyChangeEvent() - Method in exception java.beans. PropertyVetoException

获得否决权 PropertyChangeEvent 。

getPropertyChangeListeners() - Method in class java.awt. Component

返回在此组件上注册的所有属性更改侦听器的数组。

getPropertyChangeListeners() - Method in class java.awt. KeyboardFocusManager

返回在此键盘焦点管理器上注册的所有属性更改侦听器的数组。

getPropertyChangeListeners() - Method in class java.awt. Toolkit

返回在此工具包上注册的所有属性更改侦听器的数组。

getPropertyChangeListeners() - Method in class java.beans. PropertyChangeSupport

返回使用addPropertyChangeListener（）添加到PropertyChangeSupport对象的所有侦听器的数组。

getPropertyChangeListeners() - Method in class javax.swing. AbstractAction

返回使用addPropertyChangeListener（）添加到此AbstractAction的所有 PropertyChangeListener的数组。

getPropertyChangeListeners() - Method in class javax.swing.plaf.basic. BasicDirectoryModel

返回在此组件上注册的所有属性更改侦听器的数组。

getPropertyChangeListeners() - Method in class javax.swing.plaf. LayerUI

返回在此组件上注册的所有属性更改侦听器的数组。

getPropertyChangeListeners() - Method in class javax.swing.table. TableColumn

返回使用addPropertyChangeListener（）添加到此TableColumn的所有 PropertyChangeListener的数组。

getPropertyChangeListeners() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回在此 DefaultTreeSelectionModel上注册的所有属性更改侦听器的数组。

getPropertyChangeListeners() - Method in class javax.swing. UIDefaults

返回使用addPropertyChangeListener（）添加到此UIDefaults的所有 PropertyChangeListener的数组。

getPropertyChangeListeners() - Static method in class javax.swing. UIManager

返回使用addPropertyChangeListener（）添加到此UIManager的所有 PropertyChangeListener的数组。

getPropertyChangeListeners(String) - Method in class java.awt. Component

返回与named属性相关联的所有侦听器的数组。

getPropertyChangeListeners(String) - Method in class java.awt. KeyboardFocusManager

返回与命名属性相关联的所有 PropertyChangeListener的数组。

getPropertyChangeListeners(String) - Method in class java.awt. SystemTray

返回与named属性相关联的所有侦听器的数组。

getPropertyChangeListeners(String) - Method in class java.awt. Toolkit

返回与指定的桌面属性名称相关联的所有属性更改侦听器的数组。

getPropertyChangeListeners(String) - Method in class java.beans. PropertyChangeSupport

返回与named属性相关联的所有侦听器的数组。

getPropertyChangeListeners(String) - Method in class javax.swing.plaf. LayerUI

返回与named属性相关联的所有侦听器的数组。

getPropertyChangeSupport() - Method in class javax.swing. SwingWorker

返回 PropertyChangeSupport为这 SwingWorker 。

getPropertyCSSValue(String) - Method in interface org.w3c.dom.css. CSSStyleDeclaration

用于检索CSS属性值的对象表示，如果在该声明块中已经显式设置。

getPropertyDescriptors() - Method in interface java.beans. BeanInfo

返回bean的所有属性的描述符。

getPropertyDescriptors() - Method in class java.beans. SimpleBeanInfo

拒绝属性知识。

getPropertyEditorClass() - Method in class java.beans. PropertyDescriptor

获取已为此属性注册的任何显式PropertyEditor类。

getPropertyInfo(String, Properties) - Method in interface java.sql. Driver

获取有关此驱动程序可能属性的信息。

getPropertyName() - Method in class java.beans. PropertyChangeEvent

获取已更改的属性的编程名称。

getPropertyName() - Method in class java.beans. PropertyChangeListenerProxy

返回与侦听器关联的命名属性的名称。

getPropertyName() - Method in class java.beans. VetoableChangeListenerProxy

返回与侦听器关联的命名属性的名称。

getPropertyName() - Method in enum javax.xml.catalog. CatalogFeatures.Feature

返回相应系统属性的名称。

getPropertyNames() - Method in class java.awt.image. BufferedImage

如果不识别属性名称，则返回由 getProperty(String)或 null识别的名称数组。

getPropertyNames() - Method in interface java.awt.image.renderable. ContextualRenderedImageFactory

返回由getProperty识别的名称列表。

getPropertyNames() - Method in interface java.awt.image.renderable. RenderableImage

返回由getProperty识别的名称列表。

getPropertyNames() - Method in class java.awt.image.renderable. RenderableImageOp

返回由getProperty识别的名称列表。

getPropertyNames() - Method in interface java.awt.image. RenderedImage

如果未识别属性名称，则返回由 getProperty(String)或 null识别的名称数组。

getPropertyOverrides() - Method in class java.rmi.activation. ActivationGroupDesc

返回组的属性覆盖列表。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicButtonUI

返回属性前缀。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicCheckBoxMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicEditorPaneUI

获取通过UIManager查找属性的键。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicFormattedTextFieldUI

获取通过UIManager查找属性的键。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicMenuItemUI

返回属性前缀。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicMenuUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicPasswordFieldUI

获取用作密钥的名称，通过UIManager查找属性。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicRadioButtonMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicRadioButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicTextAreaUI

获取用作密钥的名称，通过UIManager查找属性。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicTextFieldUI

获取通过UIManager查找属性的键。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicTextPaneUI

获取通过UIManager查找属性的键。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicTextUI

获取通过UIManager查找属性的键。

getPropertyPrefix() - Method in class javax.swing.plaf.basic. BasicToggleButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.metal. MetalCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthCheckBoxMenuItemUI

返回属性前缀。

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthCheckBoxUI

返回属性前缀。

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthFormattedTextFieldUI

获取通过UIManager查找属性的键。

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthPasswordFieldUI

获取用作密钥的名称，通过UIManager查找属性。

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthRadioButtonMenuItemUI

返回属性前缀。

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthRadioButtonUI

返回属性前缀。

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthTextPaneUI

获取通过UIManager查找属性的键。

getPropertyPrefix() - Method in class javax.swing.plaf.synth. SynthToggleButtonUI

返回属性前缀。

getPropertyPriority(String) - Method in interface org.w3c.dom.css. CSSStyleDeclaration

如果在该声明块中已经明确设置了优先级，则用于检索CSS属性的优先级（例如， "important"限定符）。

getPropertyType() - Method in class java.beans. PropertyDescriptor

返回属性的Java类型信息。

getPropertyValue(String) - Method in interface org.w3c.dom.css. CSSStyleDeclaration

用于检索CSS属性的值（如果在该声明块中已经显式设置）。

getProtectionAlgorithm() - Method in class java.security. KeyStore.PasswordProtection

获取保护算法的名称。

getProtectionDomain() - Method in class java.lang. Class

返回 ProtectionDomain 。

getProtectionParameter() - Method in class java.security. DomainLoadStoreParameter

获取此域的密钥库保护参数。

getProtectionParameter() - Method in interface java.security. KeyStore.LoadStoreParameter

获取用于保护密钥库数据的参数。

getProtectionParameter(String) - Method in class java.security. KeyStore.Builder

返回应用于获取给定别名的Entry的ProtectionParameters。

getProtectionParameters() - Method in class java.security. KeyStore.PasswordProtection

获取为保护算法提供的参数。

getProtectionParams() - Method in class java.security. DomainLoadStoreParameter

获取此域中密钥库的密钥库保护参数。

getProto() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

返回此对象的__proto__。

getProtocol() - Method in class com.sun.net.httpserver. HttpExchange

从请求中以 协议/ majorVersion.minorVersion的形式返回协议串。

getProtocol() - Method in class java.net. URL

获取此 URL的协议名称。

getProtocol() - Method in class javax.management.remote. JMXServiceURL

服务网址的协议部分。

getProtocol() - Method in class javax.management.remote.rmi. RMIIIOPServerImpl

已过时。

getProtocol() - Method in class javax.management.remote.rmi. RMIJRMPServerImpl

getProtocol() - Method in class javax.management.remote.rmi. RMIServerImpl

返回此对象的协议字符串。

getProtocol() - Method in class javax.net.ssl. SSLContext

返回此 SSLContext对象的协议名称。

getProtocol() - Method in interface javax.net.ssl. SSLSession

返回用于会话中所有连接的协议的标准名称。

getProtocol() - Method in class javax.smartcardio. Card

返回此卡使用的协议。

getProtocol() - Method in class javax.xml.ws.spi.http. HttpExchange

从请求中以 协议/ majorVersion.minorVersion的形式返回协议串。

getProtocols() - Method in class com.sun.net.httpserver. HttpsParameters

返回协议数组的副本，如果没有设置，则返回null。

getProtocols() - Method in class javax.net.ssl. SSLParameters

返回协议数组的副本，如果没有设置，则返回null。

getPrototypeCellValue() - Method in class javax.swing. JList

返回“原型”单元格值 - 用于计算单元格的固定宽度和高度的值。

getPrototypeDisplayValue() - Method in class javax.swing. JComboBox

返回“原型显示”值 - 用于计算显示高度和宽度的对象。

getProvider() - Method in class java.security. AlgorithmParameterGenerator

返回此算法参数生成器对象的提供者。

getProvider() - Method in class java.security. AlgorithmParameters

返回此参数对象的提供者。

getProvider() - Method in class java.security.cert. CertificateFactory

返回此证书工厂的提供者。

getProvider() - Method in class java.security.cert. CertPathBuilder

返回此 CertPathBuilder的提供者。

getProvider() - Method in class java.security.cert. CertPathValidator

返回 Provider这个 CertPathValidator 。

getProvider() - Method in class java.security.cert. CertStore

返回此 CertStore的提供者。

getProvider() - Method in class java.security. KeyFactory

返回此关键工厂对象的提供者。

getProvider() - Method in class java.security. KeyPairGenerator

返回此密钥对生成器对象的提供者。

getProvider() - Method in class java.security. KeyStore

返回此密钥库的提供者。

getProvider() - Method in class java.security. MessageDigest

返回此消息摘要对象的提供者。

getProvider() - Method in class java.security. Policy

返回本政策的提供者。

getProvider() - Method in class java.security. Provider.Service

返回此服务的提供者。

getProvider() - Method in class java.security. SecureRandom

返回此 SecureRandom对象的提供者。

getProvider() - Method in class java.security. Signature

返回此签名对象的提供者。

getProvider() - Method in class javax.crypto. Cipher

返回此 Cipher对象的提供者。

getProvider() - Method in class javax.crypto. ExemptionMechanism

返回此 ExemptionMechanism对象的提供者。

getProvider() - Method in class javax.crypto. KeyAgreement

返回此 KeyAgreement对象的提供者。

getProvider() - Method in class javax.crypto. KeyGenerator

返回此 KeyGenerator对象的提供者。

getProvider() - Method in class javax.crypto. Mac

返回此 Mac对象的提供者。

getProvider() - Method in class javax.crypto. SecretKeyFactory

返回此 SecretKeyFactory对象的提供者。

getProvider() - Method in class javax.net.ssl. KeyManagerFactory

返回此 KeyManagerFactory对象的提供者。

getProvider() - Method in class javax.net.ssl. SSLContext

返回此 SSLContext对象的提供者。

getProvider() - Method in class javax.net.ssl. TrustManagerFactory

返回此 TrustManagerFactory对象的提供者。

getProvider() - Method in class javax.security.auth.login. Configuration

返回此配置的提供程序。

getProvider() - Method in class javax.smartcardio. TerminalFactory

返回此TerminalFactory的提供者。

getProvider() - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

返回此 KeyInfoFactory的提供者。

getProvider() - Method in class javax.xml.crypto.dsig. TransformService

返回这个 TransformService的提供者。

getProvider() - Method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回此 XMLSignatureFactory的提供者。

getProvider(String) - Static method in class java.security. Security

返回以指定名称安装的提供程序（如果有）。

getProviderGrade() - Method in class javax.sql.rowset.spi. SyncProvider

返回一个常量，表示 RowSet对象可以期望从 SyncProvider对象的同步等级。

getProviderID() - Method in class javax.sql.rowset.spi. SyncProvider

返回此 SyncProvider对象的唯一标识符。

getProviders() - Static method in class java.security. Security

返回包含所有已安装提供程序的数组。

getProviders(String) - Static method in class java.security. Security

返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。

getProviders(Map<String, String>) - Static method in class java.security. Security

返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。

getProxyClass(ClassLoader, Class<?>...) - Static method in class java.lang.reflect. Proxy

已过时。
在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在不可访问的代理类上调用时抛出IllegalAccessException 。 使用Proxy.newProxyInstance(ClassLoader, Class[], InvocationHandler)创建代理实例。

getPseudoClass(String) - Static method in class javafx.css. PseudoClass

给定的pseudoClass只有一个PseudoClass实例。

getPseudoClasses() - Method in class javafx.css. Match

getPseudoClassName() - Method in class javafx.css. PseudoClass

getPseudoClassStates() - Method in interface javafx.css. Styleable

返回此Styleable的伪类状态。

getPseudoClassStates() - Method in class javafx.scene.control. MenuItem

返回此Styleable的伪类状态。

getPseudoClassStates() - Method in class javafx.scene.control. PopupControl

返回此Styleable的伪类状态。

getPseudoClassStates() - Method in class javafx.scene.control. Tab

返回此Styleable的伪类状态。

getPseudoClassStates() - Method in class javafx.scene.control. TableColumnBase

返回此Styleable的伪类状态。

getPseudoClassStates() - Method in class javafx.scene. Node

getPseudoColumns(String, String, String, String) - Method in interface java.sql. DatabaseMetaData

检索指定目录和模式中给定表中可用的伪列或隐藏列的描述。

getPSName() - Method in class java.awt. Font

返回此 Font的后记名称。

getPSource() - Method in class javax.crypto.spec. OAEPParameterSpec

返回编码输入P的来源。

getPublic() - Method in class java.security. KeyPair

返回对此密钥对的公钥组件的引用。

getPublicCredentials() - Method in class javax.security.auth. Subject

返回 Set所持有的公开证书 Subject 。

getPublicCredentials(Class<T>) - Method in class javax.security.auth. Subject

返回一个 Set与此相关的公开证书 Subject是实例或指定的子类 Class 。

getPublicExponent() - Method in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

返回公共指数。

getPublicExponent() - Method in interface java.security.interfaces. RSAPrivateCrtKey

返回公共指数。

getPublicExponent() - Method in interface java.security.interfaces. RSAPublicKey

返回公共指数。

getPublicExponent() - Method in class java.security.spec. RSAKeyGenParameterSpec

返回public-exponent值。

getPublicExponent() - Method in class java.security.spec. RSAMultiPrimePrivateCrtKeySpec

返回公共指数。

getPublicExponent() - Method in class java.security.spec. RSAPrivateCrtKeySpec

返回公共指数。

getPublicExponent() - Method in class java.security.spec. RSAPublicKeySpec

返回公共指数。

getPublicId() - Method in interface javax.xml.stream.events. EntityDeclaration

实体的公共标识符，如果没有给定，则为null

getPublicId() - Method in interface javax.xml.stream.events. NotationDeclaration

符号的公共标识符，如果没有给定，则为null。

getPublicId() - Method in interface javax.xml.stream. Location

返回XML的公共ID

getPublicId() - Method in interface javax.xml.transform. SourceLocator

返回当前文档事件的公共标识符。

getPublicId() - Method in class javax.xml.transform.stream. StreamSource

获取使用setPublicId设置的公共标识符。

getPublicId() - Method in interface org.w3c.dom. DocumentType

外部子集的公共标识符。

getPublicId() - Method in interface org.w3c.dom. Entity

如果指定了与实体相关联的公共标识符，否则为 null 。

getPublicId() - Method in interface org.w3c.dom.ls. LSInput

该输入源的公共标识符。

getPublicId() - Method in interface org.w3c.dom. Notation

这个符号的公共标识符。

getPublicId() - Method in class org.xml.sax.helpers. LocatorImpl

返回保存的公共标识符。

getPublicId() - Method in class org.xml.sax. InputSource

获取此输入源的公共标识符。

getPublicId() - Method in interface org.xml.sax. Locator

返回当前文档事件的公共标识符。

getPublicId() - Method in exception org.xml.sax. SAXParseException

获取发生异常的实体的公共标识符。

getPublicKey() - Method in class java.security.cert. Certificate

从此证书获取公钥。

getPublicKey() - Method in class java.security.cert. PKIXCertPathValidatorResult

返回认证路径的主题（目标）的公钥，包括任何继承的公钥参数（如果适用）。

getPublicKey() - Method in interface java.security. Certificate

已过时。

返回担保人保证的主 - 关键对的关键字。

getPublicKey() - Method in class java.security. Identity

已过时。

返回此身份的公钥。

getPublicKey() - Method in class javax.security.cert. Certificate

已过时。

从此证书获取公钥。

getPublicKey() - Method in interface javax.xml.crypto.dsig.keyinfo. KeyValue

返回此 KeyValue 。

getPurgeFlag() - Method in class javax.management.relation. RelationService

返回标志，以指示是否在关系中引用的MBean的注销收到通知，如果必须立即执行关系的“清除”（寻找关系不再有效），或者是否将执行只有当purgeRelations方法被显式调用时才执行。

getPurgeFlag() - Method in interface javax.management.relation. RelationServiceMBean

返回标志，以指示是否在关系中引用的MBean的注销收到通知，如果必须立即执行关系的“清除”（查找关系不再有效），或者如果将仅当显式调用purgeRelations方法时执行。

getPushLevel() - Method in class java.util.logging. MemoryHandler

获取 pushLevel 。

getQ() - Method in interface java.security.interfaces. DSAParams

返回次级， q 。

getQ() - Method in class java.security.spec. DSAParameterSpec

返回 q 。

getQ() - Method in class java.security.spec. DSAPrivateKeySpec

返回子素数 q 。

getQ() - Method in class java.security.spec. DSAPublicKeySpec

返回次级 q 。

getQName(int) - Method in interface org.xml.sax. Attributes

通过索引查找属性的XML限定（前缀）名称。

getQName(int) - Method in class org.xml.sax.helpers. AttributesImpl

返回属性的合格（前缀）名称。

getQNameType(Class<?>) - Static method in enum javax.xml.xpath. XPathEvaluationResult.XPathResultType

返回与指定类类型相对应的XPathConstants中指定的QName类型。

getQOP() - Method in class org.ietf.jgss. MessageProp

检索QOP值。

getQTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageReadParam

返回在最近调用 setDecodeTables设置的量化表数组的副本，如果表当前未设置，则 null 。

getQTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

返回在最近调用 setEncodeTables或 null如果表当前未设置）时设置的量化表阵列的副本。

getQuadrantRotateInstance(int) - Static method in class java.awt.geom. AffineTransform

返回一个将坐标旋转指定数量的象限的变换。

getQuadrantRotateInstance(int, double, double) - Static method in class java.awt.geom. AffineTransform

返回一个转换，该变换将坐标指定指定锚点周围的指定数量的象限旋转。

getQualifiedIdentifier() - Method in interface com.sun.source.tree. ImportTree

返回要导入的声明的合格标识符。

getQualifiedName() - Method in interface javax.lang.model.element. ModuleElement

返回此模块的完全限定名称。

getQualifiedName() - Method in interface javax.lang.model.element. PackageElement

返回此包的完全限定名称。

getQualifiedName() - Method in interface javax.lang.model.element. QualifiedNameable

返回元素的完全限定名称。

getQualifiedName() - Method in interface javax.lang.model.element. TypeElement

返回此类型元素的完全限定名称。

getQualifiedName() - Method in interface javax.xml.soap. Name

获取此 Name对象所代表的XML名称的命名空间限定名称。

getQualifierExpression() - Method in interface com.sun.source.tree. MemberReferenceTree

返回参考的限定符表达式。

getQuery() - Method in class java.net. URI

返回此URI的解码查询组件。

getQuery() - Method in class java.net. URL

获取此 URL的查询部分。

getQueryString() - Method in class javax.xml.ws.spi.http. HttpExchange

返回路径后请求URI中包含的查询字符串。

getQueryTimeout() - Method in interface java.sql. Statement

检索驱动程序等待执行 Statement对象的 Statement 。

getQueryTimeout() - Method in class javax.sql.rowset. BaseRowSet

检索驱动程序等待查询执行的最大秒数。

getQueryTimeout() - Method in interface javax.sql. RowSet

检索驱动程序等待语句执行的最大秒数。

getQueue() - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

返回此执行程序使用的任务队列。

getQueue() - Method in class java.util.concurrent. ThreadPoolExecutor

返回此执行程序使用的任务队列。

getQueuedReaderThreads() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回一个包含可能正在等待获取读取锁的线程的集合。

getQueuedSubmissionCount() - Method in class java.util.concurrent. ForkJoinPool

返回提交给此池尚未开始执行的任务数量的估计。

getQueuedTaskCount() - Method in class java.util.concurrent. ForkJoinPool

返回由工作线程（但不包括提交到池中尚未开始执行的任务）当前在队列中保留的任务总数的估计值。

getQueuedTaskCount() - Static method in class java.util.concurrent. ForkJoinTask

返回当前工作线程已分配但尚未执行的任务数量的估计。

getQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回一个包含可能正在等待获取的线程的集合。

getQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回一个包含可能正在等待获取的线程的集合。

getQueuedThreads() - Method in class java.util.concurrent.locks. ReentrantLock

返回包含可能正在等待获取此锁的线程的集合。

getQueuedThreads() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回一个包含可能正在等待获取读取或写入锁定的线程的集合。

getQueuedThreads() - Method in class java.util.concurrent. Semaphore

返回一个包含可能正在等待获取的线程的集合。

getQueuedWriterThreads() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回一个包含可能正在等待获取写入锁的线程的集合。

getQueueLength() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回等待获取的线程数的估计。

getQueueLength() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回等待获取的线程数的估计。

getQueueLength() - Method in class java.util.concurrent.locks. ReentrantLock

返回等待获取此锁的线程数的估计。

getQueueLength() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回等待获取读取或写入锁定的线程数的估计。

getQueueLength() - Method in class java.util.concurrent. Semaphore

返回等待获取的线程数的估计。

getQuotes() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的引号属性定义。

getRadii() - Method in class javafx.scene.layout. BackgroundFill

用于表示BackgroundFill的四个半径的Radii。

getRadii() - Method in class javafx.scene.layout. BorderStroke

定义此BorderStroke的每个角落的半径。

getRadioButtonBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JRadioButton的边框实例。

getRadioButtonIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回单选按钮图标。

getRadioButtonIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 RadioButtonIcon的实例。

getRadioButtonMenuItemIcon() - Static method in class javax.swing.plaf.basic. BasicIconFactory

返回单选按钮菜单项图标。

getRadioButtonMenuItemIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 JRadioButtonMenuItem使用的 JRadioButtonMenuItem 。

getRadius() - Method in class java.awt. RadialGradientPaint

返回定义径向渐变的圆的半径。

getRadius() - Method in class javafx.scene.effect. DropShadow

获取属性半径的值。

getRadius() - Method in class javafx.scene.effect. GaussianBlur

获取属性半径的值。

getRadius() - Method in class javafx.scene.effect. InnerShadow

获取属性半径的值。

getRadius() - Method in class javafx.scene.effect. MotionBlur

获取属性半径的值。

getRadius() - Method in class javafx.scene.effect. Shadow

获取属性半径的值。

getRadius() - Method in class javafx.scene.paint. RadialGradient

指定定义颜色渐变范围的圆的半径。

getRadius() - Method in class javafx.scene.shape. Circle

获取属性半径的值。

getRadius() - Method in class javafx.scene.shape. Cylinder

获取属性半径的值。

getRadius() - Method in class javafx.scene.shape. Sphere

获取属性半径的值。

getRadiusX() - Method in class javafx.scene.shape. Arc

获取属性radiusX的值。

getRadiusX() - Method in class javafx.scene.shape. ArcTo

获取属性radiusX的值。

getRadiusX() - Method in class javafx.scene.shape. Ellipse

获取属性radiusX的值。

getRadiusY() - Method in class javafx.scene.shape. Arc

获取属性radiusY的值。

getRadiusY() - Method in class javafx.scene.shape. ArcTo

获取属性radiusY的值。

getRadiusY() - Method in class javafx.scene.shape. Ellipse

获取属性radiusY的值。

getRaisedBevelBorderUIResource() - Static method in class javax.swing.plaf. BorderUIResource

返回凸起的边框边界UI资源。

getRandomAccessFile(String) - Method in interface javax.jnlp. FileContents

返回表示文件内容的随机访问接口的 JNLPRandomAccessFile 。

getRange() - Method in class java.util. Locale.LanguageRange

返回此 LanguageRange的语言范围。

getRange() - Method in class javafx.scene.chart. Axis

被称为获取当前的轴范围。

getRange() - Method in class javafx.scene.chart. CategoryAxis

被称为获取当前的轴范围。

getRange() - Method in class javafx.scene.chart. NumberAxis

被称为获取当前的轴范围。

getRangeEnd() - Method in class javafx.scene.control. TextFormatter.Change

获取最终索引到 TextInputControl.getText()进行修改。

getRanges() - Method in class java.awt.font. NumericShaper

返回一个 int ，将所有范围的值组合在一起。

getRangeSet() - Method in class java.awt.font. NumericShaper

返回 Set代表所有的Unicode范围在此 NumericShaper将要成型。

getRangeShape(int, int) - Method in class javafx.scene.control.skin. TextAreaSkin

getRangeShape(int, int) - Method in class javafx.scene.control.skin. TextFieldSkin

getRangeShape(int, int) - Method in class javafx.scene.control.skin. TextInputControlSkin

getRangeStart() - Method in class javafx.scene.control. TextFormatter.Change

获取起始索引到 TextInputControl.getText()进行修改。

getRangeUnit() - Method in enum java.time.temporal. ChronoField

getRangeUnit() - Method in interface java.time.temporal. TemporalField

获取字段绑定的范围。

getRaster() - Method in class java.awt.image. BufferedImage

返回WritableRaster 。

getRaster() - Method in class javax.imageio. IIOImage

如果只有一个 RenderedImage可用，则返回当前设置的 Raster ，或 null 。

getRaster(int, int, int, int) - Method in interface java.awt. PaintContext

返回包含为图形操作生成的颜色的 Raster 。

getRate() - Method in class javafx.animation. Animation

获取房价的价值。

getRate() - Method in class javafx.scene.media. AudioClip

获取默认播放速度。

getRate() - Method in class javafx.scene.media. MediaPlayer

检索播放速度。

getRaw() - Method in class javafx.application. Application.Parameters

检索原始参数的只读列表。

getRawAuthority() - Method in class java.net. URI

返回此URI的原始权限组件。

getRawCommentText() - Method in interface com.sun.javadoc. Doc

已过时。

返回评论的完整未处理文本。

getRawContent() - Method in class javax.xml.soap. AttachmentPart

获取此内容 AttachmentPart对象作为InputStream仿佛调用了到 getContent ，没有 DataContentHandler已经登记为 content-type这一点 AttachmentPart 。

getRawContentBytes() - Method in class javax.xml.soap. AttachmentPart

获取此内容 AttachmentPart对象作为byte []数组仿佛呼叫已作出 getContent和无 DataContentHandler已经登记为 content-type此的 AttachmentPart 。

getRawFragment() - Method in class java.net. URI

返回此URI的原始片段组件。

getRawImageType(int) - Method in class javax.imageio. ImageReader

返回一个 ImageTypeSpecifier表示 SampleModel和 ColorModel ，其最接近地表示图像的“原始”内部格式。

getRawOffset() - Method in class java.util. SimpleTimeZone

获取此时区的GMT偏移量。

getRawOffset() - Method in class java.util. TimeZone

返回添加到UTC的时间（以毫秒为单位），以获得此时区的标准时间。

getRawPath() - Method in class java.net. URI

返回此URI的原始路径组件。

getRawQuery() - Method in class java.net. URI

返回此URI的原始查询组件。

getRawResult() - Method in class java.util.concurrent. CountedCompleter

返回计算结果。

getRawResult() - Method in class java.util.concurrent. ForkJoinTask

返回对返回的结果 ForkJoinTask.join() ，即使这个任务异常完成，或 null如果不知道这个任务已经完成。

getRawResult() - Method in class java.util.concurrent. RecursiveAction

始终返回 null 。

getRawResult() - Method in class java.util.concurrent. RecursiveTask

getRawSchemeSpecificPart() - Method in class java.net. URI

返回此URI的原始方案特定部分。

getRawType() - Method in interface java.lang.reflect. ParameterizedType

返回表示声明此类型的类或接口的 Type对象。

getRawUserInfo() - Method in class java.net. URI

返回此URI的原始用户信息组件。

getRdn(int) - Method in class javax.naming.ldap. LdapName

检索此LDAP名称的RDN作为Rdn。

getRdns() - Method in class javax.naming.ldap. LdapName

检索相对可分辨名称的列表。

getRead() - Method in exception java.sql. DataTruncation

指示值是否在读取时被截断。

getReadableInstancePropertyNames(Class<?>) - Static method in class jdk.dynalink.beans. BeansLinker

返回一组类的所有可读实例属性的名称。

getReadableStaticPropertyNames(Class<?>) - Static method in class jdk.dynalink.beans. BeansLinker

返回一组类的所有可读静态属性的名称。

getReader() - Method in interface javax.script. ScriptContext

返回一个 Reader ，由脚本用来读取输入。

getReader() - Method in class javax.script. SimpleScriptContext

返回一个 Reader ，由脚本用来读取输入。

getReader() - Method in class javax.xml.transform.stream. StreamSource

获取用setReader设置的字符流。

getReader(int) - Method in class javax.swing.text.html. HTMLDocument

在使用HTML加载文档时，将为读取器提供解析器。

getReader(int, int, int, HTML.Tag) - Method in class javax.swing.text.html. HTMLDocument

返回解析器的读取器，用于使用HTML加载文档。

getReaderFileSuffixes() - Static method in class javax.imageio. ImageIO

返回一个 String的数组，列出与当前注册读者集合所理解的格式相关联的所有文件后缀。

getReaderFormatNames() - Static method in class javax.imageio. ImageIO

返回一个 String的数组， String列出了当前注册读者集所理解的所有非正式格式名称。

getReaderForText() - Method in interface javax.print. Doc

获取从该文档中提取字符打印数据的读取器。

getReaderForText() - Method in class javax.print. SimpleDoc

获取从该文档中提取字符打印数据的读取器。

getReaderForText(Transferable) - Method in class java.awt.datatransfer. DataFlavor

获取一个文本风味的阅读器，如有必要，解码为预期的字符集（编码）。

getReaderMIMETypes() - Static method in class javax.imageio. ImageIO

返回一个 String的数组，列出了当前注册读者集所理解的所有MIME类型。

getReaderServiceProviderName() - Method in class javax.imageio.spi. ImageTranscoderSpi

返回 ImageReaderSpi类的完全限定类名，生成 IIOMetadata此代码转换器输入的 IIOMetadata对象。

getReadHoldCount() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

查询当前线程对此锁的可重入读取保留数。

getReadLockCount() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

查询为此锁持有的读取锁的数量。

getReadLockCount() - Method in class java.util.concurrent.locks. StampedLock

查询为此锁持有的读取锁的数量。

getReadMethod() - Method in class java.beans. PropertyDescriptor

获取应该用于读取属性值的方法。

getReadOnly() - Method in interface org.w3c.dom.html. HTMLInputElement

此控件是只读的。

getReadOnly() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

此控件是只读的。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyBooleanWrapper

返回readonly属性，该属性与此 ReadOnlyBooleanWrapper同步。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyDoubleWrapper

返回与该属性同步的只读属性 ReadOnlyDoubleWrapper 。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyFloatWrapper

返回readonly属性，与此同步 ReadOnlyFloatWrapper 。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyIntegerWrapper

返回readonly属性，该属性与此 ReadOnlyIntegerWrapper同步。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyListWrapper

返回readonly属性，该属性与此 ReadOnlyListWrapper同步。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyLongWrapper

返回readonly属性，该属性与此 ReadOnlyLongWrapper同步。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyMapWrapper

返回readonly属性，该属性与此 ReadOnlyMapWrapper同步。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyObjectWrapper

返回readonly属性，该属性与此 ReadOnlyObjectWrapper同步。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlySetWrapper

返回readonly属性，与此同步 ReadOnlySetWrapper 。

getReadOnlyProperty() - Method in class javafx.beans.property. ReadOnlyStringWrapper

返回readonly属性，该属性与此 ReadOnlyStringWrapper同步。

getReadTimeout() - Method in class java.net. URLConnection

返回读取超时的设置。 0返回意味着该选项被禁用（即无限超时）。

getReadUnknownTags() - Method in class javax.imageio.plugins.tiff. TIFFImageReadParam

检索是否读取对应于未知的字段的设置 TIFFTag s。

getRealm() - Method in class com.sun.net.httpserver. BasicAuthenticator

返回此BasicAuthenticator创建的领域

getRealm() - Method in class com.sun.net.httpserver. HttpPrincipal

返回此对象创建的领域。

getRealm() - Method in class javax.security.auth.kerberos. KerberosPrincipal

返回此Kerberos主体的领域组件。

getReason() - Method in class java.awt.desktop. UserSessionEvent

获取用户会话更改的原因。

getReason() - Method in exception java.net. HttpRetryException

返回一个字符串，解释为什么不能重试http请求。

getReason() - Method in exception java.net. URISyntaxException

返回一个字符串，解释为什么无法解析输入字符串。

getReason() - Method in exception java.nio.file. FileSystemException

返回解释为什么文件系统操作失败的字符串。

getReason() - Method in exception java.nio.file. InvalidPathException

返回一个字符串，解释为什么输入字符串被拒绝。

getReason() - Method in exception java.security.cert. CertPathValidatorException

返回验证失败的原因。

getReason() - Method in interface javax.print. URIException

返回事件的原因。

getReceiveBufferSize() - Method in class java.net. DatagramSocket

获取此 DatagramSocket的SO_RCVBUF选项的值，即平台在此 DatagramSocket上输入的缓冲区大小。

getReceiveBufferSize() - Method in class java.net. ServerSocket

获取的价值 SO_RCVBUF选择这个 ServerSocket ，那就是将用于从该接受的套接字的建议缓冲区大小 ServerSocket 。

getReceiveBufferSize() - Method in class java.net. Socket

获取的价值 SO_RCVBUF选择这个 Socket ，所使用的平台，输入这个缓冲区的大小 Socket 。

getReceiver() - Method in interface javax.sound.midi. MidiDevice

获取MIDI IN接收器，MIDI设备可以通过MIDI接收器接收MIDI数据。

getReceiver() - Static method in class javax.sound.midi. MidiSystem

从外部MIDI端口或其他默认设备获取MIDI接收器。

getReceiver() - Method in interface javax.sound.midi. Transmitter

获取此发送器将传送MIDI消息的当前接收器。

getReceiver() - Method in interface jdk.dynalink.linker. LinkRequest

返回被链接的调用的第一个参数; 这通常是接收器对象。

getReceiver() - Method in class jdk.dynalink.linker.support. SimpleLinkRequest

getReceiverParameter() - Method in interface com.sun.source.tree. MethodTree

返回一个显式的接收器参数（“this”参数），如果没有，则 null 。

getReceivers() - Method in interface javax.sound.midi. MidiDevice

返回与此MidiDevice连接的所有当前活动的非闭合接收器。

getReceiverType() - Method in interface javax.lang.model.element. ExecutableElement

返回此可执行文件的接收器类型，或NoType用一种NONE如果可执行文件没有接收器类型。

getReceiverType() - Method in interface javax.lang.model.type. ExecutableType

返回此可执行文件的接收器类型，或NoType用一种NONE如果可执行文件没有接收器类型。

getRecipient() - Method in class javax.security.auth.kerberos. KerberosCredMessage

返回此消息的收件人。

getRectValue() - Method in interface org.w3c.dom.css. CSSPrimitiveValue

此方法用于获取Rect值。

getRecursionLimit() - Method in class java.awt.geom. FlatteningPathIterator

返回此迭代器的递归限制。

getRed() - Method in class java.awt. Color

返回默认sRGB空间中0-255范围内的红色分量。

getRed() - Method in class javafx.scene.paint. Color

红色组件 Color ，范围 0.0-1.0 。

getRed() - Method in interface org.w3c.dom.css. RGBColor

该属性用于RGB颜色的红色值。

getRed(int) - Method in class java.awt.image. ColorModel

返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。

getRed(int) - Method in class java.awt.image. ComponentColorModel

返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。

getRed(int) - Method in class java.awt.image. DirectColorModel

返回默认RGB ColorSpace （sRGB）中指定像素的红色分量，从0到255。

getRed(int) - Method in class java.awt.image. IndexColorModel

返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。

getRed(Object) - Method in class java.awt.image. ColorModel

返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getRed(Object) - Method in class java.awt.image. ComponentColorModel

返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。

getRed(Object) - Method in class java.awt.image. DirectColorModel

返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。

getRedMask() - Method in class java.awt.image. DirectColorModel

返回掩码，指示 int像素表示中的哪些位包含红色成分。

getRedoPresentationName() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

提供本编辑的可重复形式的本地化，可读的描述，例如用作重做菜单项。

getRedoPresentationName() - Method in class javax.swing.undo. AbstractUndoableEdit

使用关键字 AbstractUndoableEdit.redoText从默认表格中检索值，并返回该值后跟一个空格，后跟 getPresentationName 。

getRedoPresentationName() - Method in class javax.swing.undo. CompoundEdit

从最后的 UndoableEdit返回 getRedoPresentationName加到 edits 。

getRedoPresentationName() - Method in interface javax.swing.undo. UndoableEdit

返回适用于例如Redo菜单项的本编辑的可重写形式的本地化，可读的描述。

getRedoPresentationName() - Method in class javax.swing.undo. UndoManager

返回此修改的可重写形式的描述。

getReds(byte[]) - Method in class java.awt.image. IndexColorModel

将红色组件数组复制到指定的数组中。

getReductionPolynomial() - Method in class java.security.spec. ECFieldF2m

返回一个BigInteger，其第i个位对应于多项式基础的缩小多项式的第i个系数，或者为正常值，返回null。

getRef() - Method in class java.net. URL

获得这个 URL的锚点（也称为“参考”）。

getRef() - Method in class java.rmi.server. RemoteObject

返回远程对象的远程引用。

getRef(int) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定的JDBC REF(<structured-type>)参数的值作为Ref对象。

getRef(int) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Ref对象。

getRef(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的Ref对象获取JDBC REF(<structured-type>)参数的值。

getRef(String) - Method in interface java.sql. ResultSet

这个检索的当前行中指定列的值 ResultSet对象为 Ref的Java编程语言对象。

getRefClass(ObjectOutput) - Method in interface java.rmi.server. RemoteRef

将要序列化的引用类型的类名返回到流“out”。

getReference() - Method in interface com.sun.source.doctree. LinkTree

返回链接的引用。

getReference() - Method in interface com.sun.source.doctree. SeeTree

返回引用。

getReference() - Method in interface com.sun.source.doctree. ValueTree

返回对该值的引用。

getReference() - Method in class java.util.concurrent.atomic. AtomicMarkableReference

返回引用的当前值。

getReference() - Method in class java.util.concurrent.atomic. AtomicStampedReference

返回引用的当前值。

getReference() - Method in interface javax.naming. Referenceable

检索此对象的引用。

getReferencedMBeans() - Method in interface javax.management.relation. Relation

检索在关系的各种角色中引用的MBean。

getReferencedMBeans() - Method in class javax.management.relation. RelationSupport

检索在关系的各种角色中引用的MBean。

getReferencedMBeans(String) - Method in class javax.management.relation. RelationService

检索在关系的各种角色中引用的MBean。

getReferencedMBeans(String) - Method in interface javax.management.relation. RelationServiceMBean

检索在关系的各种角色中引用的MBean。

getReferenceKind() - Method in interface java.lang.invoke. MethodHandleInfo

返回破解方法句柄的引用类型，这反过来确定方法句柄的底层成员是构造函数，方法还是字段。

getReferences() - Method in interface javax.xml.crypto.dsig. Manifest

返回此Manifest中包含的一个或多个Reference的Manifest 。

getReferences() - Method in interface javax.xml.crypto.dsig. SignedInfo

返回一个unmodifiable list一个或多个Reference秒。

getReferralContext() - Method in exception javax.naming.ldap. LdapReferralException

检索使用上下文环境继续该方法的上下文，而不使用控件。

getReferralContext() - Method in exception javax.naming. ReferralException

检索继续该方法的上下文。

getReferralContext(Hashtable<?, ?>) - Method in exception javax.naming.ldap. LdapReferralException

检索使用环境属性继续该方法的上下文，而不使用控件。

getReferralContext(Hashtable<?, ?>) - Method in exception javax.naming. ReferralException

检索使用环境属性继续该方法的上下文。

getReferralContext(Hashtable<?, ?>, Control[]) - Method in exception javax.naming.ldap. LdapReferralException

检索使用请求控件和环境属性继续该方法的上下文。

getReferralInfo() - Method in exception javax.naming. ReferralException

检索与此推介相关的信息（如URL）。

getReferrals() - Method in interface javax.naming.ldap. UnsolicitedNotification

检索由服务器发送的推荐。

getReferrer() - Method in interface org.w3c.dom.html. HTMLDocument

返回链接到此页面的页面的URI。

getRefMBeanClassName() - Method in class javax.management.relation. RoleInfo

返回预期在相应角色中引用的MBean类型的名称。

getRefreshRate() - Method in class java.awt. DisplayMode

以赫兹为单位返回显示刷新率。

getRegion() - Method in class javax.swing.plaf.synth. SynthContext

返回标识此状态的区域。

getRegion(JComponent) - Static method in class javax.swing.plaf.synth. SynthLookAndFeel

返回JComponent的区域 c 。

getRegisteredKeyStrokes() - Method in class javax.swing. JComponent

返回将启动注册操作的 KeyStrokes 。

getRegisteredParties() - Method in class java.util.concurrent. Phaser

返回在此移动设备上注册的各方数量。

getRegisteredProviders() - Static method in class javax.sql.rowset.spi. SyncFactory

返回当前注册的同步提供程序的枚举。

getRegistry() - Static method in class java.rmi.registry. LocateRegistry

返回对默认注册表端口1099的本地主机的远程对象 Registry的引用。

getRegistry(int) - Static method in class java.rmi.registry. LocateRegistry

返回对指定的 port的本地主机的远程对象 Registry的引用。

getRegistry(String) - Static method in class java.rmi.registry. LocateRegistry

返回对默认注册表端口1099上指定的 host上的远程对象 Registry的引用。

getRegistry(String, int) - Static method in class java.rmi.registry. LocateRegistry

返回对指定的 host和 port上的远程对象 Registry的 port 。

getRegistry(String, int, RMIClientSocketFactory) - Static method in class java.rmi.registry. LocateRegistry

返回本地创建的对指定的 host和 port的远程对象 Registry远程引用。

getRejectedExecutionHandler() - Method in class java.util.concurrent. ThreadPoolExecutor

返回不可执行任务的当前处理程序。

getRel() - Method in interface org.w3c.dom.html. HTMLAnchorElement

转发链接类型

getRel() - Method in interface org.w3c.dom.html. HTMLLinkElement

转发链接类型

getRelatedData() - Method in interface org.w3c.dom. DOMError

相关数据相关 DOMError.type 。

getRelatedException() - Method in interface org.w3c.dom. DOMError

相关的平台依赖异常如果有的话。

getRelatedNode() - Method in interface org.w3c.dom. DOMLocator

该定位器指向的节点，如果没有节点可用， null 。

getRelatedNode() - Method in interface org.w3c.dom.events. MutationEvent

relatedNode用于识别与突变事件相关的次要节点。

getRelatedTarget() - Method in interface org.w3c.dom.events. MouseEvent

用于识别与UI事件相关的辅助 EventTarget 。

getRelationId() - Method in interface javax.management.relation. Relation

返回关系标识符（用于唯一标识关系服务中的关系）。

getRelationId() - Method in class javax.management.relation. RelationNotification

返回创建/删除/更新的关系的关系标识符。

getRelationId() - Method in class javax.management.relation. RelationSupport

返回关系标识符（用于唯一标识关系服务中的关系）。

getRelationServiceName() - Method in interface javax.management.relation. Relation

返回处理关系的关系服务的ObjectName。

getRelationServiceName() - Method in class javax.management.relation. RelationSupport

返回处理关系的关系服务的ObjectName。

getRelationTypeName() - Method in interface javax.management.relation. Relation

返回关联关系类型的名称。

getRelationTypeName() - Method in class javax.management.relation. RelationNotification

返回创建/删除/更新的关系的关系类型名称。

getRelationTypeName() - Method in class javax.management.relation. RelationSupport

返回关联关系类型的名称。

getRelationTypeName() - Method in interface javax.management.relation. RelationType

返回关系类型名称。

getRelationTypeName() - Method in class javax.management.relation. RelationTypeSupport

返回关系类型名称。

getRelationTypeName(String) - Method in class javax.management.relation. RelationService

返回给定关系的关联关系类型的名称。

getRelationTypeName(String) - Method in interface javax.management.relation. RelationServiceMBean

返回给定关系的关联关系类型的名称。

getRelay() - Method in interface javax.xml.soap. SOAPHeaderElement

返回此 SOAPHeaderElement的 继电器属性的布尔值

getRemaining() - Method in class java.util.zip. Inflater

返回输入缓冲区中剩余的总字节数。

getRemainingAcceptLifetime(Oid) - Method in interface org.ietf.jgss. GSSCredential

返回凭证使用指定机制继续接受安全上下文的生命周期（以秒为单位）。

getRemainingInitLifetime(Oid) - Method in interface org.ietf.jgss. GSSCredential

返回凭证使用指定机制启动安全上下文的生命周期（以秒为单位）。

getRemainingLifetime() - Method in interface org.ietf.jgss. GSSCredential

返回凭证的剩余生命周期（以秒为单位）。

getRemainingName() - Method in exception javax.naming. NamingException

检索其余未解决的名称部分。

getRemainingName() - Method in class javax.naming.spi. ResolveResult

检索其余未解决的名称部分。

getRemainingNewName() - Method in exception javax.naming. CannotProceedException

检索此异常的“剩余新名称”字段，该字段在重命名（）操作期间抛出此异常时使用。

getRemoteAddress() - Method in class com.sun.net.httpserver. HttpExchange

返回调用此请求的远程实体的地址

getRemoteAddress() - Method in class java.nio.channels. AsynchronousSocketChannel

返回此通道的插座所连接的远程地址。

getRemoteAddress() - Method in class java.nio.channels. DatagramChannel

返回此通道的插座所连接的远程地址。

getRemoteAddress() - Method in class java.nio.channels. SocketChannel

返回此通道的插座所连接的远程地址。

getRemoteAddress() - Method in class javax.xml.ws.spi.http. HttpExchange

返回调用此请求的远程实体的未解析地址。

getRemoteAddresses() - Method in class com.sun.nio.sctp. SctpChannel

返回此通道的套接字所连接的所有远程地址。

getRemoteAddresses(Association) - Method in class com.sun.nio.sctp. SctpMultiChannel

返回此通道的套接字连接给定关联的所有远程地址。

getRemoteSocketAddress() - Method in class java.net. DatagramSocket

返回此套接字连接到的端点的地址，如果未连接，则 null 。

getRemoteSocketAddress() - Method in class java.net. Socket

返回此套接字连接到的端点的地址，如果未连接，则 null 。

getRemoved() - Method in class javafx.collections. ListChangeListener.Change

已删除/替换元素的不可变列表。

getRemovedChildren() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent

返回在此事件中从TreeItem中删除的子项，如果未添加子项，则返回空列表。

getRemovedSize() - Method in class javafx.collections. ListChangeListener.Change

getRemoved（）列表的大小。

getRemovedSize() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent

返回在此事件中删除的子项目数，如果没有删除子项，则返回零。

getRemoveListenerMethod() - Method in class java.beans. EventSetDescriptor

获取用于删除事件侦听器的方法。

getRemoveOnCancelPolicy() - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

获取关于在取消时是否应立即将已取消任务从工作队列中删除的策略。

getRenderableSource(int) - Method in class java.awt.image.renderable. ParameterBlock

作为RenderableImage返回一个源。

getRenderedImage() - Method in class javax.imageio. IIOImage

如果只有 Raster可用，则返回当前设置的 RenderedImage ，或 null 。

getRenderedSource(int) - Method in class java.awt.image.renderable. ParameterBlock

返回一个来源为 RenderedImage 。

getRenderer() - Method in class javax.swing. JComboBox

返回在 JComboBox字段中用于显示所选项目的渲染器。

getRenderingHint(RenderingHints.Key) - Method in class java.awt. Graphics2D

返回渲染算法的单个首选项的值。

getRenderingHints() - Method in class java.awt. Graphics2D

获取渲染算法的首选项。

getRenderingHints() - Method in class java.awt.image. AffineTransformOp

返回此变换操作使用的渲染提示。

getRenderingHints() - Method in class java.awt.image. BandCombineOp

返回此操作的呈现提示。

getRenderingHints() - Method in interface java.awt.image. BufferedImageOp

返回此操作的呈现提示。

getRenderingHints() - Method in class java.awt.image. ColorConvertOp

返回此op使用的渲染提示。

getRenderingHints() - Method in class java.awt.image. ConvolveOp

返回此操作的渲染提示。

getRenderingHints() - Method in class java.awt.image. LookupOp

返回此操作的渲染提示。

getRenderingHints() - Method in interface java.awt.image. RasterOp

返回此RasterOp的渲染提示。

getRenderingHints() - Method in class java.awt.image.renderable. RenderContext

获取这个 RenderContext的渲染提示。

getRenderingHints() - Method in class java.awt.image. RescaleOp

返回此操作的渲染提示。

getRenderScaleX() - Method in class javafx.stage. Window

获取属性renderScaleX的值。

getRenderScaleY() - Method in class javafx.stage. Window

获取属性renderScaleY的值。

getRenewTill() - Method in class javax.security.auth.kerberos. KerberosTicket

返回此机票的最新到期时间，包括所有续订。

getReorderingAllowed() - Method in class javax.swing.table. JTableHeader

如果允许用户通过拖动其头来重新排列列，则返回true，否则返回false。

getRepeatX() - Method in class javafx.scene.layout. BackgroundImage

以什么方式（如果有的话）表示背景图像将沿着该区域的x轴重复。

getRepeatX() - Method in class javafx.scene.layout. BorderImage

以什么方式（如果有的话）表示边框图像将沿着该区域的x轴重复。

getRepeatY() - Method in class javafx.scene.layout. BackgroundImage

以什么方式（如果有的话）表示背景图像将沿着该区域的y轴重复。

getRepeatY() - Method in class javafx.scene.layout. BorderImage

以什么方式（如果有的话）表示边框图像将沿着该区域的y轴重复。

getReplacementText() - Method in interface javax.xml.stream.events. EntityDeclaration

实体的替换文本。

getReplayDetState() - Method in interface org.ietf.jgss. GSSContext

确定是否从此上下文为每个消息安全服务启用重放检测。

getRepresentationClass() - Method in class java.awt.datatransfer. DataFlavor

返回 Class其对象支持此 DataFlavor时，这将返回 DataFlavor请求。

getRepresentationClass() - Method in class javax.activation. ActivationDataFlavor

返回代表类。

getRepresentationClassName() - Method in class javax.print. DocFlavor

返回此文档flavor对象的表示类的名称。

getRepresentedClass() - Method in class jdk.dynalink.beans. StaticClass

返回表示的Java类。

getRequestBody() - Method in class com.sun.net.httpserver. HttpExchange

返回可以从中读取请求主体的流。

getRequestBody() - Method in class javax.xml.ws.spi.http. HttpExchange

返回可以从中读取请求主体的流。

getRequestContext() - Method in interface javax.xml.ws. BindingProvider

获取用于初始化请求消息的消息上下文的上下文。

getRequestControls() - Method in class javax.naming.ldap. InitialLdapContext

getRequestControls() - Method in interface javax.naming.ldap. LdapContext

检索对该上下文有效的请求控件。

getRequestedHeight() - Method in class javafx.scene.image. Image

获取必要时调整大小的源图像的边界框的高度。

getRequestedServerNames() - Method in class javax.net.ssl. ExtendedSSLSession

获取List，其中包含所请求的服务器名称指示（SNI）扩展的所有SNIServerName 。

getRequestedWidth() - Method in class javafx.scene.image. Image

获取必要时调整大小的源图像的边界框的宽度。

getRequestHeader(String) - Method in class javax.xml.ws.spi.http. HttpExchange

返回指定请求标头的值。

getRequestHeaders() - Method in class com.sun.net.httpserver. HttpExchange

返回包含此请求中包含的HTTP标头的不可变地图。

getRequestHeaders() - Method in class javax.xml.ws.spi.http. HttpExchange

返回包含此请求中包含的HTTP标头的不可变地图。

getRequestingHost() - Method in class java.net. Authenticator

获取 hostname的网站或代理请求验证的，或 null如果不可用。

getRequestingPort() - Method in class java.net. Authenticator

获取请求的连接的端口号。

getRequestingPrompt() - Method in class java.net. Authenticator

获取请求者给出的提示字符串。

getRequestingProtocol() - Method in class java.net. Authenticator

给出请求连接的协议。

getRequestingScheme() - Method in class java.net. Authenticator

获取请求者的方案（例如HTTP防火墙的HTTP方案）。

getRequestingSite() - Method in class java.net. Authenticator

获取 InetAddress请求授权的站点，或者 null如果不可用。

getRequestingURL() - Method in class java.net. Authenticator

返回导致此请求验证的URL。

getRequestMethod() - Method in class com.sun.net.httpserver. HttpExchange

获取请求方法

getRequestMethod() - Method in class java.net. HttpURLConnection

获取请求方法。

getRequestMethod() - Method in class javax.xml.ws.spi.http. HttpExchange

获取HTTP请求方法

getRequestorType() - Method in class java.net. Authenticator

返回请求者是Proxy还是Server。

getRequestProperties() - Method in class java.net. URLConnection

返回此连接的一般请求属性的不可修改映射。

getRequestProperty(String) - Method in class java.net. URLConnection

返回此连接的命名的常规请求属性的值。

getRequestURI() - Method in class com.sun.net.httpserver. HttpExchange

获取请求URI

getRequestURI() - Method in class javax.xml.ws.spi.http. HttpExchange

将请求的URI的一部分从协议名称返回到HTTP请求的第一行中的查询字符串。

getReshowDelay() - Method in class javax.swing. ToolTipManager

返回重新显示延迟属性。

getResizable() - Method in class javax.swing.table. TableColumn

如果允许用户调整 TableColumn的宽度，返回true，否则返回false。

getResizeWeight() - Method in class javax.swing. JSplitPane

返回确定如何分配额外空间的数字。

getResizeWeight(int) - Method in class javax.swing.text. BoxView

获得调整重量。

getResizeWeight(int) - Method in class javax.swing.text. FieldView

确定沿着给定轴的视图的可复位性。

getResizeWeight(int) - Method in class javax.swing.text.html. BlockView

获得调整重量。

getResizeWeight(int) - Method in class javax.swing.text. TableView.TableRow

确定沿着给定轴的视图的可复位性。

getResizeWeight(int) - Method in class javax.swing.text. View

确定沿着给定轴的视图的可复位性。

getResizingAllowed() - Method in class javax.swing.table. JTableHeader

如果允许用户通过在其标题之间拖动来调整列大小，则返回true，否则返回false。

getResizingColumn() - Method in class javax.swing.table. JTableHeader

返回调整大小列。

getResolution() - Method in class javax.sound.midi. MidiFileFormat

获取MIDI文件的时间分辨率。

getResolution() - Method in class javax.sound.midi. Sequence

获取此序列的时序分辨率。

getResolution(int) - Method in class javax.print.attribute. ResolutionSyntax

以给定单位获取此分辨率属性的分辨率值。

getResolutionVariant(double, double) - Method in class java.awt.image. BaseMultiResolutionImage

getResolutionVariant(double, double) - Method in interface java.awt.image. MultiResolutionImage

获取一个特定的图像，这是以指定大小表示该逻辑图像的最佳变体。

getResolutionVariants() - Method in class java.awt.image. BaseMultiResolutionImage

getResolutionVariants() - Method in interface java.awt.image. MultiResolutionImage

获取所有分辨率变体的可读列表。

getResolvedName() - Method in exception javax.naming. NamingException

检索已成功解决的名称的主要部分。

getResolvedObj() - Method in exception javax.naming. NamingException

检索分辨率成功的对象。

getResolvedObj() - Method in class javax.naming.spi. ResolveResult

检索分辨率成功的对象。

getResolveParent() - Method in class javax.swing.text. AbstractDocument.AbstractElement

得到解决的父母。

getResolveParent() - Method in interface javax.swing.text. AttributeSet

得到解决的父母。

getResolveParent() - Method in class javax.swing.text.html. HTMLDocument.BlockElement

得到解决的父母。

getResolveParent() - Method in class javax.swing.text.html. HTMLDocument.RunElement

得到解决的父母。

getResolveParent() - Method in interface javax.swing.text. Keymap

获取用于解析键绑定的父键盘映射。

getResolveParent() - Method in class javax.swing.text. SimpleAttributeSet

得到解决的父母。

getResolveParent() - Method in class javax.swing.text. StyleContext.NamedStyle

从父级获取属性。

getResolveParent() - Method in class javax.swing.text. StyleContext.SmallAttributeSet

如果未覆盖，则解析父项默认为父元素。

getResolverFields() - Method in class java.time.format. DateTimeFormatter

获取在解析期间使用的解析器字段。

getResolverStyle() - Method in class java.time.format. DateTimeFormatter

获取在解析过程中使用的解析器样式。

getResource(String) - Method in class java.lang. Class

查找具有给定名称的资源。

getResource(String) - Method in class java.lang. ClassLoader

找到具有给定名称的资源。

getResource(String) - Method in interface javax.management.loading. MLetMBean

找到具有给定名称的资源。

getResource(String, BeanContextChild) - Method in interface java.beans.beancontext. BeanContext

对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。

getResource(String, BeanContextChild) - Method in class java.beans.beancontext. BeanContextSupport

getResource(JavaFileManager.Location, CharSequence, CharSequence) - Method in interface javax.annotation.processing. Filer

返回一个读取现有资源的对象。

getResourceAsStream(String) - Method in class java.lang. Class

查找具有给定名称的资源。

getResourceAsStream(String) - Method in class java.lang. ClassLoader

返回用于读取指定资源的输入流。

getResourceAsStream(String) - Method in class java.lang. Module

返回用于读取此模块中资源的输入流。

getResourceAsStream(String) - Method in class java.net. URLClassLoader

返回用于读取指定资源的输入流。

getResourceAsStream(String) - Method in interface javax.management.loading. MLetMBean

返回用于读取指定资源的输入流。

getResourceAsStream(String, BeanContextChild) - Method in interface java.beans.beancontext. BeanContext

对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。

getResourceAsStream(String, BeanContextChild) - Method in class java.beans.beancontext. BeanContextSupport

getResourceBaseName() - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

返回当前设置的基本名称，以查找 ResourceBundle s。

getResourceBundle() - Method in class java.util.logging. Logger

检索此记录器的本地化资源包。

getResourceBundle() - Method in class java.util.logging. LogRecord

获取本地化资源包

getResourceBundleName() - Method in class java.util.logging. Level

返回级别的本地化资源包名称，如果未定义本地化包，则返回null。

getResourceBundleName() - Method in class java.util.logging. Logger

检索此记录器的本地化资源包名称。

getResourceBundleName() - Method in class java.util.logging. LogRecord

获取本地化资源包名称

getResourceResolver() - Method in class javax.xml.validation. SchemaFactory

获得当前的LSResourceResolver设置为SchemaFactory 。

getResourceResolver() - Method in class javax.xml.validation. Validator

获取当前的LSResourceResolver设置为Validator 。

getResourceResolver() - Method in class javax.xml.validation. ValidatorHandler

获得当前的LSResourceResolver设置为ValidatorHandler 。

getResources() - Method in interface com.sun.source.tree. TryTree

返回 try语句中提供的任何资源声明。

getResources() - Method in class javafx.fxml. FXMLLoader

返回用于解析资源密钥属性值的资源。

getResources() - Method in interface javax.sound.midi. Soundbank

提取声音库中包含的非仪器资源列表。

getResources(String) - Method in class java.lang. ClassLoader

查找具有给定名称的所有资源。

getResources(String) - Method in interface javax.management.loading. MLetMBean

查找具有给定名称的所有资源。

getResponse() - Method in exception jdk.incubator.http. WebSocketHandshakeException

返回服务器对应的开启握手。

getResponseBody() - Method in class com.sun.net.httpserver. HttpExchange

返回响应主体必须写入的流。

getResponseBody() - Method in class javax.xml.ws.spi.http. HttpExchange

返回响应主体必须写入的流。

getResponseCode() - Method in class com.sun.net.httpserver. Authenticator.Failure

返回发送给客户端的响应代码

getResponseCode() - Method in class com.sun.net.httpserver. Authenticator.Retry

返回发送给客户端的响应代码

getResponseCode() - Method in class com.sun.net.httpserver. HttpExchange

返回响应代码（如果已经设置）

getResponseCode() - Method in class java.net. HttpURLConnection

从HTTP响应消息获取状态代码。

getResponseContext() - Method in interface javax.xml.ws. BindingProvider

获取处理响应消息产生的上下文。

getResponseControls() - Method in class javax.naming.ldap. InitialLdapContext

getResponseControls() - Method in interface javax.naming.ldap. LdapContext

检索由此上下文调用的最后一个方法生成的响应控件。

getResponseHeaders() - Method in class com.sun.net.httpserver. HttpExchange

返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。

getResponseHeaders() - Method in class javax.xml.ws.spi.http. HttpExchange

返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。

getResponseMessage() - Method in class java.net. HttpURLConnection

获取与服务器的响应代码一起返回的HTTP响应消息（如果有）。

getResponses() - Method in class javax.xml.ws.soap. AddressingFeature

如果启用寻址，则此属性确定端点是否需要使用匿名响应，或非匿名响应或所有响应。

getRestartMode() - Method in class java.rmi.activation. ActivationDesc

返回与此激活描述符关联的对象的“重启”模式。

getRestartOnFailure() - Method in class javafx.concurrent. ScheduledService

获取属性restartOnFailure的值。

getResult() - Method in class javafx.scene.control. Dialog

获取属性结果的值。

getResult() - Method in interface javax.xml.bind. UnmarshallerHandler

获得未组织的结果。

getResult() - Method in class javax.xml.bind.util. JAXBResult

获取由转换创建的未编组对象。

getResult() - Method in class javax.xml.soap. SAAJResult

getResultCode() - Method in class javax.naming.ldap. SortResponseControl

检索排序操作的LDAP结果代码。

getResultConverter() - Method in class javafx.scene.control. Dialog

获取属性resultConverter的值。

getResultSet() - Method in interface java.sql. Array

检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。

getResultSet() - Method in interface java.sql. Statement

以 ResultSet对象的形式获取当前结果。

getResultSet() - Method in class javax.sql.rowset.serial. SerialArray

检索 ResultSet对象，其中包含 SerialArray对象所代表的 ARRAY值中的所有元素。

getResultSet(long, int) - Method in interface java.sql. Array

检索一个结果集，该结果集包含从索引 index开始的子阵列元素，并包含最多 count连续元素。

getResultSet(long, int) - Method in class javax.sql.rowset.serial. SerialArray

检索一个 ResultSet对象，保存从索引 索引开始的子阵列的元素，并包含最多 计数连续元素。

getResultSet(long, int, Map<String, Class<?>>) - Method in interface java.sql. Array

检索一个结果集，该结果集包含从索引 index开始的子阵列的元素，并包含最多 count连续元素。

getResultSet(long, int, Map<String, Class<?>>) - Method in class javax.sql.rowset.serial. SerialArray

检索设置保持其开始于检索所述子阵列的元素的结果 ResultSet对象，其中包含在该元件的子阵列 SerialArray对象，开始于索引 指数和包含 count个连续元素。

getResultSet(Map<String, Class<?>>) - Method in interface java.sql. Array

检索包含由此 Array对象指定的SQL ARRAY值的元素的结果集。

getResultSet(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial. SerialArray

检索 ResultSet对象，它包含所有的SQL的元件的 ARRAY由该表示值 SerialArray对象。

getResultSetConcurrency() - Method in interface java.sql. Statement

检索由 ResultSet对象生成的 Statement对象的结果集并发。

getResultSetHoldability() - Method in interface java.sql. DatabaseMetaData

检索 ResultSet对象的数据库默认保持 ResultSet 。

getResultSetHoldability() - Method in interface java.sql. Statement

检索由 ResultSet对象生成的 Statement对象的结果集 Statement 。

getResultSetType() - Method in interface java.sql. Statement

检索由 ResultSet对象生成的 Statement对象的结果集类型。

getResultSize() - Method in class javax.naming.ldap. PagedResultsResponseControl

检索（估计）搜索结果中的条目数。

getResultStream(boolean) - Method in interface java.rmi.server. RemoteCall

已过时。
没有替换

getResultType() - Method in interface org.w3c.dom.xpath. XPathResult

代表该结果类型的代码，由类型常量定义。

getReturningAttributes() - Method in class javax.naming.directory. SearchControls

检索将作为搜索的一部分返回的属性。

getReturningObjFlag() - Method in class javax.naming.directory. SearchControls

确定对象是否将作为结果的一部分返回。

getReturnOpenType() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo

返回由此 OpenMBeanOperationInfo实例描述的操作返回的值的 打开类型 。

getReturnOpenType() - Method in class javax.management.openmbean. OpenMBeanOperationInfoSupport

返回由此 OpenMBeanOperationInfo实例描述的操作返回的值的 打开类型 。

getReturnType() - Method in interface com.sun.source.tree. MethodTree

返回正在声明的方法的返回类型。

getReturnType() - Method in class java.lang.reflect. 方法

返回一个 Class对象，表示由该 方法对象表示的方法的正式返回类型。

getReturnType() - Method in enum javafx.scene. AccessibleAttribute

getReturnType() - Method in interface javax.lang.model.element. ExecutableElement

返回此可执行文件的返回类型。

getReturnType() - Method in interface javax.lang.model.type. ExecutableType

返回此可执行文件的返回类型。

getReturnType() - Method in class javax.management. MBeanOperationInfo

返回方法的返回值的类型。

getReturnType() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo

返回由此 OpenMBeanOperationInfo实例描述的操作返回的值的完全限定的Java类名称。

getReuseAddress() - Method in class java.net. DatagramSocket

测试是否启用了SO_REUSEADDR。

getReuseAddress() - Method in class java.net. ServerSocket

测试是否启用了 SO_REUSEADDR 。

getReuseAddress() - Method in class java.net. Socket

测试是否启用了 SO_REUSEADDR 。

getRev() - Method in interface org.w3c.dom.html. HTMLAnchorElement

反向链接类型。

getRev() - Method in interface org.w3c.dom.html. HTMLLinkElement

反向链接类型。

getRevocationChecker() - Method in class java.security.cert. CertPathBuilder

返回 CertPathChecker封装的 CertPathBuilderSpi实现用于检查证书的吊销状态。

getRevocationChecker() - Method in class java.security.cert. CertPathValidator

返回 CertPathChecker封装的 CertPathValidatorSpi实现用于检查证书的撤销状态。

getRevocationDate() - Method in exception java.security.cert. CertificateRevokedException

返回证书被撤销的日期。

getRevocationDate() - Method in class java.security.cert. X509CRLEntry

从此X509CRLEntry（ revocationDate）获取撤销日期。

getRevocationReason() - Method in exception java.security.cert. CertificateRevokedException

返回证书被撤销的原因。

getRevocationReason() - Method in class java.security.cert. X509CRLEntry

返回证书被撤销的原因，如CRL条目的“原因码”扩展中所指定。

getRevokedCertificate(BigInteger) - Method in class java.security.cert. X509CRL

获取给定证书serialNumber的CRL条目（如果有）。

getRevokedCertificate(X509Certificate) - Method in class java.security.cert. X509CRL

获取给定证书的CRL条目（如果有）。

getRevokedCertificates() - Method in class java.security.cert. X509CRL

获取此CRL中的所有条目。

getRGB() - Method in class java.awt. Color

返回表示默认sRGB ColorModel中颜色的RGB值。

getRGB(int) - Method in class java.awt.image. ColorModel

以默认RGB颜色模型格式返回像素的颜色/ alpha分量。

getRGB(int) - Method in class java.awt.image. ComponentColorModel

以默认RGB颜色模型格式返回像素的颜色/ alpha分量。

getRGB(int) - Method in class java.awt.image. DirectColorModel

以默认RGB颜色模型格式返回像素的颜色/ alpha分量。

getRGB(int) - Method in class java.awt.image. IndexColorModel

以默认RGB颜色模型格式返回像素的颜色/ alpha分量。

getRGB(int, int) - Method in class java.awt.image. BufferedImage

返回默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素。

getRGB(int, int, int, int, int[], int, int) - Method in class java.awt.image. BufferedImage

从图像数据的一部分返回默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素数组。

getRGB(Object) - Method in class java.awt.image. ColorModel

以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。

getRGB(Object) - Method in class java.awt.image. ComponentColorModel

以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。

getRGB(Object) - Method in class java.awt.image. DirectColorModel

以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。

getRGBColorComponents(float[]) - Method in class java.awt. Color

返回一个 float阵列只包含的颜色分量 Color ，在默认的sRGB色彩空间。

getRGBColorValue() - Method in interface org.w3c.dom.css. CSSPrimitiveValue

此方法用于获取RGB颜色。

getRGBComponents(float[]) - Method in class java.awt. Color

返回一个包含 float的颜色和alpha组件的 Color ，如默认的sRGB颜色空间所示。

getRGBdefault() - Static method in class java.awt.image. ColorModel

返回一个 DirectColorModel ，它描述了AWT图像接口中许多方法中使用的整数RGB值的默认格式，以方便程序员。

getRGBs(int[]) - Method in class java.awt.image. IndexColorModel

将每个索引的数据从颜色和alpha组件数组转换为默认RGB ColorModel格式的int，并将生成的32位ARGB值复制到指定的数组中。

getRichness() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的richness属性定义。

getRight() - Method in class javafx.geometry. Insets

右侧的插图

getRight() - Method in class javafx.scene.layout. BorderPane

获取产权的价值。

getRight() - Method in class javafx.scene.layout. BorderWidths

非负值（ BorderWidths.AUTO除外 ），表示边框右侧的边框厚度。

getRight() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的正确的属性定义。

getRight() - Method in interface org.w3c.dom.css. Rect

该属性用于rect的右侧。

getRightAnchor(Node) - Static method in class javafx.scene.layout. AnchorPane

如果设置，返回小孩的右侧锚点约束。

getRightChildIndent() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回正确的子缩进。

getRightComponent() - Method in class javax.swing. JSplitPane

将分量返回到右侧（或更低）。

getRightIndent(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取正确的缩进设置。

getRightInset() - Method in class javax.swing.text. AsyncBoxView

在视图中获取边缘的正确部分。

getRightInset() - Method in class javax.swing.text. CompositeView

获取正确的插图。

getRightMargin() - Method in class javafx.print. PageLayout

以分数返回页面布局的右边距。

getRightOperand() - Method in interface com.sun.source.tree. BinaryTree

返回表达式的右（第二）操作数。

getRightOperand() - Method in interface jdk.nashorn.api.tree. BinaryTree

返回此二进制表达式的右侧（RHS）。

getRightStroke() - Method in class javafx.scene.layout. BorderStroke

定义此边框右侧的填充。

getRightStyle() - Method in class javafx.scene.layout. BorderStroke

定义此边框右侧的样式。

getRMIRepositoryID(Class) - Method in interface javax.rmi.CORBA. ValueHandler

返回给定Java类的CORBA RepositoryId。

getRole() - Method in interface javax.xml.soap. SOAPHeaderElement

返回此的 角色属性的值 SOAPHeaderElement 。

getRole(String) - Method in interface javax.management.relation. Relation

检索给定角色名称的角色值。

getRole(String) - Method in class javax.management.relation. RelationSupport

检索给定角色名称的角色值。

getRole(String, String) - Method in class javax.management.relation. RelationService

在给定关系中为给定的角色名称检索角色值。

getRole(String, String) - Method in interface javax.management.relation. RelationServiceMBean

在给定关系中为给定的角色名称检索角色值。

getRoleCardinality(String) - Method in interface javax.management.relation. Relation

返回当前在给定角色中引用的MBean数。

getRoleCardinality(String) - Method in class javax.management.relation. RelationSupport

返回当前在给定角色中引用的MBean数。

getRoleCardinality(String, String) - Method in class javax.management.relation. RelationService

检索当前在给定角色中引用的MBeans数。

getRoleCardinality(String, String) - Method in interface javax.management.relation. RelationServiceMBean

检索当前在给定角色中引用的MBeans数。

getRoleInfo(String) - Method in interface javax.management.relation. RelationType

返回给定角色信息名称的角色信息（RoleInfo对象）（如果未找到，则返回null）。

getRoleInfo(String) - Method in class javax.management.relation. RelationTypeSupport

返回给定角色信息名称的角色信息（RoleInfo对象）（如果未找到，则返回null）。

getRoleInfo(String, String) - Method in class javax.management.relation. RelationService

检索给定关系类型的给定角色名称的角色信息。

getRoleInfo(String, String) - Method in interface javax.management.relation. RelationServiceMBean

检索给定关系类型的给定角色的角色信息。

getRoleInfos() - Method in interface javax.management.relation. RelationType

返回角色定义列表（RoleInfo对象的ArrayList）。

getRoleInfos() - Method in class javax.management.relation. RelationTypeSupport

返回角色定义列表（RoleInfo对象的ArrayList）。

getRoleInfos(String) - Method in class javax.management.relation. RelationService

检索给定关系类型的角色信息（RoleInfo对象）的列表。

getRoleInfos(String) - Method in interface javax.management.relation. RelationServiceMBean

检索给定关系类型的角色信息（RoleInfo对象）的列表。

getRoleName() - Method in class javax.management.relation. RelationNotification

返回更新关系的更新角色的名称（仅用于角色更新）。

getRoleName() - Method in class javax.management.relation. Role

检索角色名称。

getRoleName() - Method in class javax.management.relation. RoleUnresolved

检索角色名称。

getRoles() - Method in class javax.management.relation. RoleResult

检索已成功访问的角色列表。

getRoles() - Method in interface javax.xml.ws.handler.soap. SOAPMessageContext

获取与执行处理程序链相关联的SOAP actor角色。

getRoles() - Method in interface javax.xml.ws.soap. SOAPBinding

获取SOAP绑定实例扮演的角色。

getRoles(String[]) - Method in interface javax.management.relation. Relation

检索具有给定名称的角色值。

getRoles(String[]) - Method in class javax.management.relation. RelationSupport

检索具有给定名称的角色值。

getRoles(String, String[]) - Method in class javax.management.relation. RelationService

以给定的关系取得给定名称的角色值。

getRoles(String, String[]) - Method in interface javax.management.relation. RelationServiceMBean

以给定的关系取得给定名称的角色值。

getRolesUnresolved() - Method in class javax.management.relation. RoleResult

检索未成功访问的角色列表。

getRoleValue() - Method in class javax.management.relation. Role

检索角色值。

getRoleValue() - Method in class javax.management.relation. RoleUnresolved

检索角色值。

getRolloverBorder(AbstractButton) - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回按钮的翻转边框。

getRolloverColumn() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

返回鼠标当前所在的列标题的索引。

getRolloverIcon() - Method in class javax.swing. AbstractButton

返回按钮的翻转图标。

getRolloverSelectedIcon() - Method in class javax.swing. AbstractButton

返回按钮的翻转选择图标。

getRolloverTab() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回鼠标当前结束的选项卡，如果鼠标不再位于任何选项卡上，则返回 -1 。

getRoot() - Method in interface java.nio.file. Path

返回此路径的根组分作为 Path对象，或 null如果该路径不具有根组件。

getRoot() - Method in class java.util.concurrent. CountedCompleter

返回当前计算的根; 即这个任务，如果它没有完成，否则它的完成者的根。

getRoot() - Method in class java.util.concurrent. Phaser

返回此移相器的根祖先，如果它没有父代，则与该移相器相同。

getRoot() - Method in class javafx.fxml. FXMLLoader

返回对象层次结构的根。

getRoot() - Method in class javafx.scene.control. TreeTableView

返回此TreeTableView的当前根节点，如果未指定根节点，则返回null。

getRoot() - Method in class javafx.scene.control. TreeView

返回此TreeView的当前根节点，如果未指定根节点，则返回null。

getRoot() - Method in class javafx.scene. Scene

获取属性根的值。

getRoot() - Method in class javafx.scene. SubScene

获取属性根的值。

getRoot() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回包含此节点的树的根。

getRoot() - Method in class javax.swing.tree. DefaultTreeModel

返回树的根。

getRoot() - Method in interface javax.swing.tree. TreeModel

返回树的根。

getRoot() - Method in interface org.w3c.dom.traversal. NodeIterator

NodeIterator ，在创建时指定。

getRoot() - Method in interface org.w3c.dom.traversal. TreeWalker

所述 root节点的 TreeWalker ，它被创建时指定。

getRoot(Component) - Static method in class javax.swing. SwingUtilities

返回当前组件树的根组件。

getRootCause() - Method in exception javax.naming. NamingException

检索此NamingException的根本原因（如果有）。

getRootDirectories() - Method in class java.nio.file. FileSystem

返回一个对象来遍历根目录的路径。

getRootElement() - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer

获取根元素。

getRootElements() - Method in interface javax.annotation.processing. RoundEnvironment

返回上一轮生成的注释处理的root elements 。

getRootElements() - Method in class javax.swing.text. AbstractDocument

获取定义的所有根元素。

getRootElements() - Method in interface javax.swing.text. Document

返回定义的所有根元素。

getRootFrame() - Static method in class javax.swing. JOptionPane

返回用于不提供框架的类方法的 Frame 。

getRootName() - Method in interface javax.imageio.metadata. IIOMetadataFormat

返回格式的根元素的名称。

getRootName() - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

getRootPane() - Method in class javax.swing. JApplet

已过时。

返回此applet的rootPane对象。

getRootPane() - Method in class javax.swing. JComponent

返回此组件的 JRootPane祖先。

getRootPane() - Method in class javax.swing. JDialog

返回此对话框的 rootPane对象。

getRootPane() - Method in class javax.swing. JFrame

返回此框架的 rootPane对象。

getRootPane() - Method in class javax.swing. JInternalFrame

返回此内部框架的 rootPane对象。

getRootPane() - Method in class javax.swing. JWindow

返回此窗口的 rootPane对象。

getRootPane() - Method in interface javax.swing. RootPaneContainer

返回此组件的单个JRootPane小孩。

getRootPane(Component) - Static method in class javax.swing. SwingUtilities

如果c是JRootPane后代，则返回其JRootPane祖先。

getRoots() - Method in class javax.swing.filechooser. FileSystemView

返回此系统上的所有根分区。

getRootView(JTextComponent) - Method in class javax.swing.plaf.basic. BasicTextUI

通过分配可以遍历的关联文本组件（即层次结构的根）来获取视图，以确定模型在空间上的表示方式。

getRootView(JTextComponent) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getRootView方法。

getRootView(JTextComponent) - Method in class javax.swing.plaf. TextUI

通过分配可以遍历的关联文本组件（即层次结构的根）来获取视图，以确定模型在空间上的表示方式。

getRotate() - Method in class javafx.scene. Node

获取属性旋转的值。

getRotateInstance(double) - Static method in class java.awt.geom. AffineTransform

返回表示旋转变换的变换。

getRotateInstance(double, double) - Static method in class java.awt.geom. AffineTransform

返回一个根据旋转矢量旋转坐标的变换。

getRotateInstance(double, double, double) - Static method in class java.awt.geom. AffineTransform

返回一个在锚点周围旋转坐标的变换。

getRotateInstance(double, double, double, double) - Static method in class java.awt.geom. AffineTransform

返回一个根据旋转向量旋转锚点周围的坐标点的变换。

getRotationAxis() - Method in class javafx.scene. Node

获取属性rotateAxis的值。

getRoundedCorners() - Method in class javax.swing.border. LineBorder

返回此边框是否以圆角绘制。

getRoundingMode() - Method in class java.math. MathContext

返回roundingMode设置。

getRoundingMode() - Method in class java.text. DecimalFormat

获取此DecimalFormat中使用的RoundingMode 。

getRoundingMode() - Method in class java.text. NumberFormat

获取此NumberFormat中使用的RoundingMode 。

getRounds() - Method in class javax.crypto.spec. RC5ParameterSpec

返回轮数。

getRow() - Method in interface java.sql. ResultSet

检索当前行号。

getRow() - Method in class javafx.scene.control. TablePositionBase

TablePosition在TableView中表示的行。

getRow() - Method in class javax.swing. JTable.DropLocation

返回放置在表中的行索引。

getRow(TreeItem<S>) - Method in class javafx.scene.control. TreeTableView

返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。

getRow(TreeItem<T>) - Method in class javafx.scene.control. TreeView

返回给定TreeItem的索引位置，假设它目前可通过树层次结构访问（最显着的是所有父树项目都被扩展）。

getRowBounds(int) - Method in class javax.swing. JTree

返回指定行中的节点被绘制的 Rectangle 。

getRowConstraints() - Method in class javafx.scene.layout. GridPane

返回行约束列表。

getRowCount() - Method in class javafx.scene.layout. GridPane

返回此GridPane中的行数。

getRowCount() - Method in class javax.swing. DefaultRowSorter.ModelWrapper

返回模型中的行数。

getRowCount() - Method in class javax.swing. JTable

返回在 JTable可以显示的行数，给定无限空间。

getRowCount() - Method in class javax.swing. JTree

返回可见节点的数量。

getRowCount() - Method in class javax.swing.table. DefaultTableModel

返回此数据表中的行数。

getRowCount() - Method in interface javax.swing.table. TableModel

返回模型中的行数。

getRowCount() - Method in class javax.swing.text. TableView.TableCell

已过时。

获取单元格跨越的行数（即网格高度）。

getRowCount() - Method in class javax.swing.tree. AbstractLayoutCache

显示的行数

getRowCount() - Method in class javax.swing.tree. FixedHeightLayoutCache

返回可见行数。

getRowCount() - Method in class javax.swing.tree. VariableHeightLayoutCache

返回可见行数。

getRowCount(JTree) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回正在显示的行数。

getRowCount(JTree) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getRowCount方法。

getRowCount(JTree) - Method in class javax.swing.plaf. TreeUI

返回正在显示的行数。

getRowEnd(JTextComponent, int) - Static method in class javax.swing.text. Utilities

确定包含指定模型位置的行的结束行模型位置。

getRowFactory() - Method in class javafx.scene.control. TableView

获取属性rowFactory的值。

getRowFactory() - Method in class javafx.scene.control. TreeTableView

获取属性rowFactory的值。

getRowFilter() - Method in class javax.swing. DefaultRowSorter

返回确定哪些行（如果有的话）应该从视图中隐藏的过滤器。

getRowForLocation(int, int) - Method in class javax.swing. JTree

返回指定位置的行。

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回在路径中识别的最后一个项目可见的行。

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 getRowForPath方法。

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf. TreeUI

返回在路径中识别的最后一个项目可见的行。

getRowForPath(TreePath) - Method in class javax.swing. JTree

返回显示由指定路径标识的节点的行。

getRowForPath(TreePath) - Method in class javax.swing.tree. AbstractLayoutCache

返回在路径中识别的最后一个项目可见的行。

getRowForPath(TreePath) - Method in class javax.swing.tree. FixedHeightLayoutCache

返回在路径中识别的最后一个项目可见的行。

getRowForPath(TreePath) - Method in class javax.swing.tree. VariableHeightLayoutCache

返回路径中识别的最后一个项目可见的行。

getRowHeader() - Method in class javax.swing. JScrollPane

返回行标题。

getRowHeader() - Method in class javax.swing. ScrollPaneLayout

返回作为行标题的 JViewport对象。

getRowHeight() - Method in class javax.swing. JTable

返回表行的高度（以像素为单位）。

getRowHeight() - Method in class javax.swing. JTextArea

定义一行高度的含义。

getRowHeight() - Method in class javax.swing. JTree

返回每行的高度。

getRowHeight() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回行高。

getRowHeight() - Method in class javax.swing.tree. AbstractLayoutCache

返回每行的高度。

getRowHeight(int) - Method in class javax.swing. JTable

返回 row单元格的高度（以像素为 row 。

getRowHeight(int) - Method in class javax.swing.plaf.basic. BasicListUI

根据当前布局返回指定行的高度。

getRowId(int) - Method in interface java.sql. CallableStatement

以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。

getRowId(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 ResultSet对象的形式 java.sql.RowId此 ResultSet对象的当前行中指定列的值。

getRowId(String) - Method in interface java.sql. CallableStatement

将指定的JDBC ROWID参数的值作为 java.sql.RowId对象 java.sql.RowId 。

getRowId(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 java.sql.RowId对象获取此 ResultSet对象的当前行中指定列的值。

getRowIdLifetime() - Method in interface java.sql. DatabaseMetaData

指示此数据源是否支持SQL ROWID类型，以及RowId对象保持有效的生命周期。

getRowIndex() - Method in interface org.w3c.dom.html. HTMLTableRowElement

该行的索引相对于整个表，从0开始。

getRowIndex(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，返回小孩的行索引约束。

getRowMapper() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回能够将TreePath映射到行的RowMapper实例。

getRowMapper() - Method in interface javax.swing.tree. TreeSelectionModel

返回能够将TreePath映射到行的RowMapper实例。

getRowMargin() - Method in class javax.swing. JTable

获取单元格之间的空白空间（以像素为单位）的数量。

getRows() - Method in class java.awt. GridLayout

获取此布局中的行数。

getRows() - Method in class java.awt. List

获取此列表中的可见行数。

getRows() - Method in class java.awt. TextArea

返回文本区域中的行数。

getRows() - Method in class javax.swing. JTextArea

返回TextArea中的行数。

getRows() - Method in interface org.w3c.dom.html. HTMLFrameSetElement

框架集中的帧数。

getRows() - Method in interface org.w3c.dom.html. HTMLTableElement

返回表中的所有行，包括所有的集合 THEAD ， TFOOT ，所有 TBODY元素。

getRows() - Method in interface org.w3c.dom.html. HTMLTableSectionElement

此表部分中的行集合。

getRows() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

文本行数。

getRowSelectionAllowed() - Method in class javax.swing. JTable

如果可以选择行，则返回true。

getRowSetNames() - Method in interface javax.sql.rowset. JoinRowSet

返回一个 String数组，其中包含添加到此 JoinRowSet对象的 RowSet对象的名称。

getRowSetReader() - Method in class javax.sql.rowset.spi. SyncProvider

返回一个 javax.sql.RowSetReader对象，可以用于使用数据填充 RowSet对象。

getRowSets() - Method in interface javax.sql.rowset. JoinRowSet

返回 Collection包含对象 RowSet已经添加到该物体 JoinRowSet对象。

getRowSetWarnings() - Method in interface javax.sql.rowset. CachedRowSet

检索通过此 RowSet对象的呼叫报告的第一个警告。

getRowSetWarnings() - Method in interface javax.sql.rowset. JdbcRowSet

检索通过此 JdbcRowSet对象的呼叫报告的第一个警告。

getRowSetWriter() - Method in class javax.sql.rowset.spi. SyncProvider

返回一个 javax.sql.RowSetWriter对象，其可用于写一个 RowSet对象的数据回底层数据源。

getRowsForPaths(TreePath[]) - Method in class javax.swing.tree. AbstractLayoutCache

返回 path中显示的 TreePath实例的行。

getRowsForPaths(TreePath[]) - Method in interface javax.swing.tree. RowMapper

返回在 path中显示的TreePath实例的行。

getRowSorter() - Method in class javax.swing. JTable

返回负责排序的对象。

getRowSpan() - Method in interface org.w3c.dom.html. HTMLTableCellElement

单元格跨越的行数。

getRowSpan(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，返回小孩的行跨限制。

getRowStart(JTextComponent, int) - Static method in class javax.swing.text. Utilities

确定包含指定模型位置的行的起始行模型位置。

getRowType() - Method in class javax.management.openmbean. TabularType

返回此 TabularType实例描述的表格数据值的行元素的类型。

getRowValignment() - Method in class javafx.scene.layout. FlowPane

获取属性rowValignment的值。

getRowValue() - Method in class javafx.scene.control. TableColumn.CellEditEvent

为TableColumn.CellEditEvent.getTablePosition()中返回的TablePosition中包含的行返回行的值（即TableView items列表）的便利方法。

getRowValue() - Method in class javafx.scene.control. TreeTableColumn.CellEditEvent

为TreeTableColumn.CellEditEvent.getTreeTablePosition()中返回的TablePosition所包含的行返回行的值（即TableView items列表）的便利方法。

getRowX(int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回沿x轴的位置，以呈现特定的行。

getRowX(int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI.NodeDimensionsHandler

返回量为给定行的缩进。

getRowX(int, int) - Method in class javax.swing.plaf.synth. SynthTreeUI

返回沿x轴的位置，以呈现特定的行。

getRSB() - Method in class java.awt.font. GlyphMetrics

返回字形的右侧（底部）侧面。

getRtf() - Method in class javafx.scene.input. Clipboard

从以前注册的剪贴板获取RTF文本字符串。

getRtf() - Method in class javafx.scene.input. ClipboardContent

从以前被放置的 ClipboardContent获取RTF字符串。

getRule() - Method in class java.awt. AlphaComposite

返回此 AlphaComposite的合成规则。

getRule() - Method in class javafx.css. Declaration

getRule() - Method in class javafx.css. Selector

getRule(String) - Method in class javax.swing.text.html. StyleSheet

获取与字符串形式给出的选择器最匹配的规则。

getRule(HTML.Tag, Element) - Method in class javax.swing.text.html. StyleSheet

获取用于呈现给定类型的HTML标签的样式。

getRules() - Method in class java.text. RuleBasedCollator

获取排序规则对象的基于表的规则。

getRules() - Method in class java.time. ZoneId

获取此ID的时区规则，允许执行计算。

getRules() - Method in class java.time. ZoneOffset

获取相关的时区规则。

getRules() - Method in class javafx.css. Stylesheet

getRules() - Method in interface org.w3c.dom.html. HTMLTableElement

指定要呈现的内部表格边框。

getRules(String, boolean) - Static method in class java.time.zone. ZoneRulesProvider

获取区域ID的规则。

getRunCount() - Method in class java.text. Bidi

返回级别运行次数。

getRunForTab(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回一个选项卡的运行。

getRunLevel(int) - Method in class java.text. Bidi

返回此行中第n个逻辑运行的级别。

getRunLimit() - Method in interface java.text. AttributedCharacterIterator

相对于包含当前字符的所有属性返回运行后第一个字符的索引。

getRunLimit(int) - Method in class java.text. Bidi

返回该行的第n个逻辑运行结束之后的索引，作为与行开头的偏移量。

getRunLimit(AttributedCharacterIterator.Attribute) - Method in interface java.text. AttributedCharacterIterator

返回运行后相对于包含当前字符的给定的 attribute的第一个字符的索引。

getRunLimit(Set<? extends AttributedCharacterIterator.Attribute>) - Method in interface java.text. AttributedCharacterIterator

返回运行后相对于包含当前字符的给定的 attributes的第一个字符的索引。

getRunningThreadCount() - Method in class java.util.concurrent. ForkJoinPool

返回等待加入任务或其他受管同步的未阻止的工作线程数的估计。

getRunStart() - Method in interface java.text. AttributedCharacterIterator

相对于包含当前字符的所有属性返回运行的第一个字符的索引。

getRunStart(int) - Method in class java.text. Bidi

返回此行中第n个逻辑运行开始处的字符索引，作为与行开头的偏移量。

getRunStart(AttributedCharacterIterator.Attribute) - Method in interface java.text. AttributedCharacterIterator

返回相对于包含当前字符的给定的 attribute的运行的第一个字符的索引。

getRunStart(Set<? extends AttributedCharacterIterator.Attribute>) - Method in interface java.text. AttributedCharacterIterator

返回相对于包含当前字符的给定的 attributes的运行的第一个字符的索引。

getRuntime() - Static method in class java.lang. Runtime

返回与当前Java应用程序关联的运行时对象。

getRunTimeCodeBase() - Method in interface javax.rmi.CORBA. ValueHandler

返回此ValueHandler的CodeBase。

getRuntimeMXBean() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机的运行时系统的托管bean。

getS() - Method in interface java.security.interfaces. ECPrivateKey

返回私有值S.

getS() - Method in class java.security.spec. ECPrivateKeySpec

返回私有值S.

getSalt() - Method in interface javax.crypto.interfaces. PBEKey

如果没有指定，则返回salt或null。

getSalt() - Method in class javax.crypto.spec. PBEKeySpec

如果没有指定，则返回salt的副本。

getSalt() - Method in class javax.crypto.spec. PBEParameterSpec

返回盐。

getSaltLength() - Method in class java.security.spec. PSSParameterSpec

返回盐长度（以位为单位）。

getSample(int, int, int) - Method in class java.awt.image. Raster

将位于（x，y）处的像素的指定带中的样本返回为int。

getSample(int, int, int, DataBuffer) - Method in class java.awt.image. BandedSampleModel

返回为位于（x，y）处的像素的指定带中的样本int。

getSample(int, int, int, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

返回为位于（x，y）处的像素的指定带中的样本int。

getSample(int, int, int, DataBuffer) - Method in class java.awt.image. MultiPixelPackedSampleModel

对于位于（x，y）的像素，在指定的带中返回 int样本。

getSample(int, int, int, DataBuffer) - Method in class java.awt.image. SampleModel

将位于（x，y）处的像素的指定带中的样本返回为int。

getSample(int, int, int, DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

返回为位于（x，y）处的像素的指定带中的样本int。

getSampleDouble(int, int, int) - Method in class java.awt.image. Raster

将位于（x，y）的像素的指定带中的样本返回为双倍。

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image. BandedSampleModel

将位于（x，y）的像素的指定带中的样本返回为双倍。

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

将位于（x，y）的像素的指定带中的样本返回为双倍。

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image. SampleModel

将位于（x，y）的像素的指定带中的样本返回为双倍。

getSampleFloat(int, int, int) - Method in class java.awt.image. Raster

将位于（x，y）处的像素的指定带中的样本作为浮点返回。

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image. BandedSampleModel

将位于（x，y）处的像素的指定带中的样本作为浮点返回。

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

将位于（x，y）处的像素的指定带中的样本作为浮点返回。

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image. SampleModel

将位于（x，y）处的像素的指定带中的样本作为浮点返回。

getSampleModel() - Method in class java.awt.image. BufferedImage

返回 SampleModel与此 BufferedImage相关联。

getSampleModel() - Method in class java.awt.image. Raster

返回描述图像数据布局的SampleModel。

getSampleModel() - Method in interface java.awt.image. RenderedImage

返回与此图像关联的SampleModel。

getSampleModel() - Method in class javax.imageio. ImageTypeSpecifier

根据封装在此对象内的设置返回 SampleModel 。

getSampleModel(int, int) - Method in class javax.imageio. ImageTypeSpecifier

根据封装在此对象内的设置返回 SampleModel 。

getSampleModelTranslateX() - Method in class java.awt.image. Raster

从SampleModel的坐标系返回到Raster的X转换。

getSampleModelTranslateY() - Method in class java.awt.image. Raster

从SampleModel的坐标系返回到Raster的Y转换。

getSampleRate() - Method in class javax.sound.sampled. AudioFormat

获取采样率。

getSamples(int, int, int, int, int, double[]) - Method in class java.awt.image. Raster

返回双阵列中指定的像素矩形的指定波段的样本，每个数组元素一个样本。

getSamples(int, int, int, int, int, double[], DataBuffer) - Method in class java.awt.image. SampleModel

返回双阵列中指定的像素矩形的指定波段的样本，每个数组元素一个样本。

getSamples(int, int, int, int, int, float[]) - Method in class java.awt.image. Raster

返回浮点数组中指定的像素矩形的指定波段的样本，每个数组元素一个样本。

getSamples(int, int, int, int, int, float[], DataBuffer) - Method in class java.awt.image. SampleModel

返回浮点数组中指定的像素矩形的指定波段的样本，每个数组元素一个样本。

getSamples(int, int, int, int, int, int[]) - Method in class java.awt.image. Raster

返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. BandedSampleModel

返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. ComponentSampleModel

返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SampleModel

返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。

getSampleSize() - Method in class java.awt.image. ComponentSampleModel

返回所有频带的每个样本的位数。

getSampleSize() - Method in class java.awt.image. MultiPixelPackedSampleModel

返回所有频带的每个样本的位数。

getSampleSize() - Method in class java.awt.image. SampleModel

返回所有频段的采样位数。

getSampleSize() - Method in class java.awt.image. SinglePixelPackedSampleModel

返回所有频带的每个样本的位数。

getSampleSize(int) - Method in class java.awt.image. ComponentSampleModel

返回指定频带的每个样本的位数。

getSampleSize(int) - Method in class java.awt.image. MultiPixelPackedSampleModel

返回指定频带的每个样本的位数。

getSampleSize(int) - Method in class java.awt.image. SampleModel

返回指定波段的采样位的大小。

getSampleSize(int) - Method in class java.awt.image. SinglePixelPackedSampleModel

返回指定频带的每个样本的位数。

getSampleSizeInBits() - Method in class javax.sound.sampled. AudioFormat

获取样本的大小。

getSaslClientFactories() - Static method in class javax.security.sasl. Sasl

获得已知工厂的列表，生产 SaslClient 。

getSaslServerFactories() - Static method in class javax.security.sasl. Sasl

获得已知工厂的计算，生产 SaslServer 。

getSaturation() - Method in class javafx.scene.effect. ColorAdjust

获取属性饱和度的值。

getSaturation() - Method in class javafx.scene.paint. Color

获得此 Color的饱和分量。

getSavepointId() - Method in interface java.sql. Savepoint

检索此 Savepoint对象所代表的保存点的生成ID。

getSavepointName() - Method in interface java.sql. Savepoint

检索此 Savepoint对象所代表的保存点的名称。

getScale() - Method in class javafx.scene.chart. ValueAxis

获取属性比例的值。

getScale(int) - Method in interface java.sql. ParameterMetaData

检索小数点右侧指定参数的位数。 对于不适用比例的数据类型，返回0。

getScale(int) - Method in interface java.sql. ResultSetMetaData

获取小数点右侧的指定列的位数。 对于不适用比例的数据类型，返回0。

getScale(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索存储在指定列中的值的小数点右边的位数。

getScaledInstance(float, boolean) - Method in class javax.imageio.plugins.jpeg. JPEGQTable

返回一个新的量化表，其中值乘以 scaleFactor ，然后钳位到1..32767的范围（如果 forceBaseline为真，则 forceBaseline到1..255）。

getScaledInstance(int, int, int) - Method in class java.awt. Image

创建此图像的缩放版本。

getScaleFactors(float[]) - Method in class java.awt.image. RescaleOp

返回给定数组中的比例因子。

getScaleInstance(double, double) - Static method in class java.awt.geom. AffineTransform

返回表示缩放变换的变换。

getScaleX() - Method in class java.awt.geom. AffineTransform

返回3x3仿射变换矩阵的 m00元素。

getScaleX() - Method in class javafx.scene.effect. DisplacementMap

获取属性scaleX的值。

getScaleX() - Method in class javafx.scene. Node

获取属性scaleX的值。

getScaleY() - Method in class java.awt.geom. AffineTransform

返回3x3仿射变换矩阵的 m11元素。

getScaleY() - Method in class javafx.scene.effect. DisplacementMap

获取属性scaleY的值。

getScaleY() - Method in class javafx.scene. Node

获取属性scaleY的值。

getScaleZ() - Method in class javafx.scene. Node

获取属性scaleZ的值。

getScanlineStride() - Method in class java.awt.image. ComponentSampleModel

返回此ComponentSampleModel的扫描线步幅。

getScanlineStride() - Method in class java.awt.image. MultiPixelPackedSampleModel

返回扫描线步幅。

getScanlineStride() - Method in class java.awt.image. SinglePixelPackedSampleModel

返回此SinglePixelPackedSampleModel的扫描线步幅。

getScene() - Method in class javafx.embed.swing. JFXPanel

返回附加到此 JFXPanel的JavaFX场景。

getScene() - Method in class javafx.scene. Node

获取属性场景的值。

getScene() - Method in class javafx.stage. Window

获取属性场景的值。

getSceneX() - Method in class javafx.scene.input. ContextMenuEvent

返回事件相对于包含ContextMenuEvent源的 Scene的原点的水平位置。

getSceneX() - Method in class javafx.scene.input. DragEvent

返回事件相对于包含DragEvent源的 Scene的原点的水平位置。

getSceneX() - Method in class javafx.scene.input. GestureEvent

获取事件相对于包含事件源的 Scene的原点的水平位置。

getSceneX() - Method in class javafx.scene.input. MouseEvent

返回事件相对于包含MouseEvent源的 Scene的原点的水平位置。

getSceneX() - Method in class javafx.scene.input. TouchPoint

获取触摸点的相对原点的水平位置 Scene包含TouchEvent的来源。

getSceneY() - Method in class javafx.scene.input. ContextMenuEvent

返回事件相对于包含ContextMenuEvent源的 Scene的原点的垂直位置。

getSceneY() - Method in class javafx.scene.input. DragEvent

返回事件相对于包含DragEvent源的 Scene的原点的垂直位置。

getSceneY() - Method in class javafx.scene.input. GestureEvent

获取事件相对于包含事件源的 Scene的原点的垂直位置。

getSceneY() - Method in class javafx.scene.input. MouseEvent

返回事件相对于包含MouseEvent源的 Scene的原点的垂直位置。

getSceneY() - Method in class javafx.scene.input. TouchPoint

获取触摸点的相对原点的垂直位置 Scene包含TouchEvent的来源。

getSchema() - Method in interface java.sql. Connection

检索此 Connection对象的当前模式名称。

getSchema() - Method in class javax.xml.bind. Binder

获取Binder.setSchema(Schema)方法设置的最后一个Schema对象（包括null）。

getSchema() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

getSchema() - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

getSchema() - Method in interface javax.xml.bind. Marshaller

获取用于执行组织时间验证的JAXP 1.3 Schema对象。

getSchema() - Method in interface javax.xml.bind. Unmarshaller

获取用于执行解密时间验证的JAXP 1.3 Schema对象。

getSchema() - Method in class javax.xml.parsers. DocumentBuilder

参考XML处理器使用的Schema 。

getSchema() - Method in class javax.xml.parsers. DocumentBuilderFactory

获取通过DocumentBuilderFactory.setSchema(Schema schema)方法指定的Schema对象。

getSchema() - Method in class javax.xml.parsers. SAXParser

参考XML处理器使用的Schema 。

getSchema() - Method in class javax.xml.parsers. SAXParserFactory

通过SAXParserFactory.setSchema(Schema schema)方法获取Schema对象。

getSchema(String) - Method in interface javax.naming.directory. DirContext

检索与命名对象关联的模式。

getSchema(String) - Method in class javax.naming.directory. InitialDirContext

getSchema(Name) - Method in interface javax.naming.directory. DirContext

检索与命名对象关联的模式。

getSchema(Name) - Method in class javax.naming.directory. InitialDirContext

getSchemaClassDefinition(String) - Method in interface javax.naming.directory. DirContext

检索包含命名对象的类定义的模式对象的上下文。

getSchemaClassDefinition(String) - Method in class javax.naming.directory. InitialDirContext

getSchemaClassDefinition(Name) - Method in interface javax.naming.directory. DirContext

检索包含命名对象的类定义的模式对象的上下文。

getSchemaClassDefinition(Name) - Method in class javax.naming.directory. InitialDirContext

getSchemaLocation() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

获取当前schemaLocation的便利方法。

getSchemaName(int) - Method in interface java.sql. ResultSetMetaData

获取指定列的表的模式。

getSchemaName(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索从中导出指定列中的值的表的模式名称。

getSchemas() - Method in interface java.sql. DatabaseMetaData

检索此数据库中可用的模式名称。

getSchemas(String, String) - Method in interface java.sql. DatabaseMetaData

检索此数据库中可用的模式名称。

getSchemaTerm() - Method in interface java.sql. DatabaseMetaData

检索“模式”的数据库供应商的首选项。

getSchemaType() - Method in interface javax.xml.stream.events. XMLEvent

提供了该方法用于实现以提供关于事件的可选类型信息。

getSchemaTypeInfo() - Method in class javax.imageio.metadata. IIOMetadataNode

IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

getSchemaTypeInfo() - Method in interface org.w3c.dom. Attr

与此属性相关联的类型信息。

getSchemaTypeInfo() - Method in interface org.w3c.dom. Element

与此元素相关联的类型信息。

getScheme() - Method in class java.net. URI

返回此URI的方案组件。

getScheme() - Method in class java.nio.file.spi. FileSystemProvider

返回标识此提供程序的URI方案。

getScheme() - Method in class javax.xml.ws.spi.http. HttpExchange

返回用于创建此请求的方案的名称，例如：http或https。

getScheme() - Method in interface org.w3c.dom.html. HTMLMetaElement

选择内容形式。

getSchemeSpecificPart() - Method in class java.net. URI

返回此URI的解码方案特定部分。

getScope() - Method in class java.security. Identity

已过时。

返回此身份的范围。

getScope() - Method in class javafx.scene. LightBase

获取指定此Light的分层范围的节点列表。

getScope() - Method in class javax.xml.bind. JAXBElement

返回xml元素声明的范围。

getScope() - Method in interface jdk.nashorn.api.tree. WithTree

这个'with'语句的scope对象表达式。

getScope() - Method in interface org.w3c.dom.html. HTMLTableCellElement

标题单元覆盖的范围。

getScope(TreePath) - Method in class com.sun.source.util. Trees

返回给定TreePath标识的Tree节点的范围。

getScope(String) - Method in interface javax.xml.ws.handler. MessageContext

获取属性的范围。

getScopedInterface() - Method in class java.net. Inet6Address

如果此实例是使用范围界面创建的，则返回范围界面。

getScopeId() - Method in class java.net. Inet6Address

如果此实例与接口相关联，则返回数字scopeId。

getScopes() - Method in interface javax.script. ScriptContext

为ScriptContext中范围的所有有效值返回不可变的 List 。

getScopes() - Method in class javax.script. SimpleScriptContext

返回不可变的 List ScriptContext中范围的所有有效值。

getScreenDevices() - Method in class java.awt. GraphicsEnvironment

返回所有屏幕 GraphicsDevice对象的数组。

getScreenInsets(GraphicsConfiguration) - Method in class java.awt. Toolkit

获取屏幕的插图。

getScreenResolution() - Method in class java.awt. Toolkit

以英寸为单位返回屏幕分辨率。

getScreens() - Static method in class javafx.stage. Screen

目前可用的可观察列表 Screens 。

getScreensForRectangle(double, double, double, double) - Static method in class javafx.stage. Screen

返回与所提供的矩形相交的ObservableList Screens 。

getScreensForRectangle(Rectangle2D) - Static method in class javafx.stage. Screen

返回与所提供的矩形相交的ObservableList为 Screens 。

getScreenSize() - Method in class java.awt. Toolkit

获取屏幕的大小。

getScreenX() - Method in class javafx.scene.input. ContextMenuEvent

返回事件的绝对水平位置。

getScreenX() - Method in class javafx.scene.input. DragEvent

返回事件的绝对水平位置。

getScreenX() - Method in class javafx.scene.input. GestureEvent

获取事件的绝对水平位置。

getScreenX() - Method in class javafx.scene.input. MouseEvent

返回事件的绝对水平位置。

getScreenX() - Method in class javafx.scene.input. TouchPoint

获取触摸点的绝对水平位置。

getScreenX() - Method in interface org.w3c.dom.events. MouseEvent

事件发生的水平坐标相对于屏幕坐标系的原点。

getScreenY() - Method in class javafx.scene.input. ContextMenuEvent

返回事件的绝对垂直位置。

getScreenY() - Method in class javafx.scene.input. DragEvent

返回事件的绝对垂直位置。

getScreenY() - Method in class javafx.scene.input. GestureEvent

获取事件的绝对垂直位置。

getScreenY() - Method in class javafx.scene.input. MouseEvent

返回事件的绝对垂直位置。

getScreenY() - Method in class javafx.scene.input. TouchPoint

获取触摸点的绝对垂直位置。

getScreenY() - Method in interface org.w3c.dom.events. MouseEvent

事件发生的垂直坐标相对于屏幕坐标系的原点。

getScript() - Method in class java.util. Locale

返回此语言环境的脚本，该脚本应为空字符串或ISO 15924 4字母脚本代码。

getScriptContext(Bindings) - Method in class javax.script. AbstractScriptEngine

返回一个 SimpleScriptContext 。

getScriptEngine() - Method in interface javax.script. ScriptEngineFactory

返回与此 ScriptEngineFactory相关联的 ScriptEngine的实例。

getScriptEngine() - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

getScriptEngine(ClassLoader) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

创建一个使用给定的类加载器初始化的新脚本引擎。

getScriptEngine(String...) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

创建一个使用给定参数初始化的新脚本引擎。

getScriptEngine(String[], ClassLoader) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

创建一个新的Script引擎，并使用给定的参数和给定的类加载器进行初始化。

getScriptEngine(String[], ClassLoader, ClassFilter) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

创建一个使用给定参数，类加载器和类过滤器初始化的新脚本引擎。

getScriptEngine(ClassFilter) - Method in class jdk.nashorn.api.scripting. NashornScriptEngineFactory

创建一个使用给定的类过滤器初始化的新脚本引擎。

getScriptFrames(Throwable) - Static method in exception jdk.nashorn.api.scripting. NashornException

从给定的异常对象返回数组JavaScript堆栈帧。

getScriptStackString(Throwable) - Static method in exception jdk.nashorn.api.scripting. NashornException

返回格式化的脚本堆栈跟踪字符串，框架信息由“\ n”分隔

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing. JLayer

返回滚动增量，这是显示逻辑行或列的组件所必需的，以便根据方向的值完全暴露一个行或列的块。

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing. JList

返回要滚动以显示下一个或上一个块的距离。

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing. JTable

返回 visibleRect.height或 visibleRect.width ，具体取决于该表的方向。

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing. JTree

返回块增量，这是高度或宽度的量 visibleRect ，基于 orientation 。

getScrollableBlockIncrement(Rectangle, int, int) - Method in interface javax.swing. Scrollable

显示逻辑行或列的组件应计算将根据取向值完全暴露一行行或列的滚动增量。

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.text. JTextComponent

显示逻辑行或列的组件应计算将根据取向值完全暴露一行行或列的滚动增量。

getScrollableTracksViewportHeight() - Method in class javax.swing. JEditorPane

如果视口应始终强制此 Scrollable的高度与视口的高度相匹配，则返回true。

getScrollableTracksViewportHeight() - Method in class javax.swing. JLayer

返回 false以表示视口的高度不能确定图层的高度，除非图层的首选高度小于视口的高度。

getScrollableTracksViewportHeight() - Method in class javax.swing. JList

返回true如果JList显示在JViewport和视口比列表的首选高度更高，或者布局方向为VERTICAL_WRAP和visibleRowCount <= 0 ; 否则返回false 。

getScrollableTracksViewportHeight() - Method in class javax.swing. JTable

返回 false以表示视口的高度不能确定表的高度，除非 getFillsViewportHeight为 true并且表的首选高度小于视口的高度。

getScrollableTracksViewportHeight() - Method in class javax.swing. JTree

返回false以指示视口的高度不会确定表的高度，除非树的首选高度小于视口高度。

getScrollableTracksViewportHeight() - Method in interface javax.swing. Scrollable

如果视口总是强制此Scrollable的高度与视口的高度相匹配，则返回true。

getScrollableTracksViewportHeight() - Method in class javax.swing.text. JTextComponent

如果视口应始终强制此 Scrollable的高度与视口的高度相匹配，则返回true。

getScrollableTracksViewportWidth() - Method in class javax.swing. JEditorPane

如果一个视口总是强制这个 Scrollable的宽度来匹配视口的宽度，则返回true。

getScrollableTracksViewportWidth() - Method in class javax.swing. JLayer

返回 false以表示视口的宽度不确定图层的宽度，除非图层的首选宽度小于视口的宽度。

getScrollableTracksViewportWidth() - Method in class javax.swing. JList

返回true如果JList显示在JViewport ，并且视口比列表的首选宽度宽，或者布局方向为HORIZONTAL_WRAP和visibleRowCount <= 0 ; 否则返回false 。

getScrollableTracksViewportWidth() - Method in class javax.swing. JTable

如果 autoResizeMode设置为 AUTO_RESIZE_OFF ，则返回false，这表示视口的宽度不会确定表的宽度。

getScrollableTracksViewportWidth() - Method in class javax.swing. JTextArea

如果视口应始终强制此Scrollable的宽度与视口的宽度相匹配，则返回true。

getScrollableTracksViewportWidth() - Method in class javax.swing. JTree

返回false以指示视口的宽度不会确定表的宽度，除非树的首选宽度小于视口宽度。

getScrollableTracksViewportWidth() - Method in interface javax.swing. Scrollable

如果一个视口应该总是强制这个 Scrollable的宽度来匹配视口的宽度，则返回true。

getScrollableTracksViewportWidth() - Method in class javax.swing.text. JTextComponent

如果视口应始终强制此 Scrollable的宽度与视口的宽度相匹配，则返回true。

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing. JLayer

返回滚动增量，这是显示逻辑行或列的组件所必需的，以便根据方向的值完全暴露一个新行或列。

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing. JList

返回滚动的距离以显示下一行或上一行（垂直滚动）或列（用于水平滚动）。

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing. JTable

返回完全暴露一个新行或列的滚动增量（以像素为单位）（取决于方向）。

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing. JTextArea

显示逻辑行或列的组件应计算将根据取向值完全暴露一个新行或列的滚动增量。

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing. JTree

返回滚动时增加的量。

getScrollableUnitIncrement(Rectangle, int, int) - Method in interface javax.swing. Scrollable

显示逻辑行或列的组件应计算将根据取向值完全暴露一个新行或列的滚动增量。

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.text. JTextComponent

显示逻辑行或列的组件应计算将根据取向值完全暴露一个新行或列的滚动增量。

getScrollAmount() - Method in class java.awt.event. MouseWheelEvent

返回每次点击鼠标滚轮旋转时应滚动的单位数。

getScrollbarDisplayPolicy() - Method in class java.awt. ScrollPane

返回滚动条的显示策略。

getScrollbarVisibility() - Method in class java.awt. TextArea

返回枚举值，指示文本区域使用的滚动条。

getScrolling() - Method in interface org.w3c.dom.html. HTMLFrameElement

指定框架是否应该有滚动条。

getScrolling() - Method in interface org.w3c.dom.html. HTMLIFrameElement

指定框架是否应该有滚动条。

getScrollLeft() - Method in class javafx.scene.control. TextArea

获取属性scrollLeft的值。

getScrollMode() - Method in class javax.swing. JViewport

返回当前滚动模式。

getScrollOffset() - Method in class javax.swing. JTextField

获取滚动偏移量，以像素为单位。

getScrollPane() - Method in class javax.swing.plaf.basic. BasicTreeUI.ComponentHandler

返回 JScrollPane的 JTree ，如果没有找到，则返回null。

getScrollPosition() - Method in class java.awt. ScrollPane

返回显示在滚动面板视图端口的0,0位置的子项内的当前x，y位置。

getScrollsOnExpand() - Method in class javax.swing. JTree

返回 scrollsOnExpand属性的值。

getScrollTarget() - Method in class javafx.scene.control. ScrollToEvent

getScrollTop() - Method in class javafx.scene.control. TextArea

获取属性scrollTop的值。

getScrollType() - Method in class java.awt.event. MouseWheelEvent

返回响应此事件应该发生的滚动类型。

getSearchScope() - Method in class javax.naming.directory. SearchControls

检索这些SearchControls的搜索范围。

getSearchStringEscape() - Method in interface java.sql. DatabaseMetaData

检索可用于转义通配符的字符串。

getSearchTerm() - Method in interface com.sun.source.doctree. IndexTree

返回指定的搜索项。

getSearchTerm() - Method in class java.awt.desktop. OpenFilesEvent

获取搜索字词。

getSecond() - Method in class java.time. LocalDateTime

获得第二分钟的字段。

getSecond() - Method in class java.time. LocalTime

获得第二分钟的字段。

getSecond() - Method in class java.time. OffsetDateTime

获得第二分钟的字段。

getSecond() - Method in class java.time. OffsetTime

获得第二分钟的字段。

getSecond() - Method in class java.time. ZonedDateTime

获得第二分钟的字段。

getSecond() - Method in class javax.xml.datatype. XMLGregorianCalendar

如果此字段 未定义，则返回 秒数或 DatatypeConstants.FIELD_UNDEFINED的秒数 。

getSecondary1() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回辅助1颜色。

getSecondary1() - Method in class javax.swing.plaf.metal. MetalTheme

返回辅助1颜色。

getSecondary1() - Method in class javax.swing.plaf.metal. OceanTheme

返回辅助1颜色。

getSecondary2() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回辅助2颜色。

getSecondary2() - Method in class javax.swing.plaf.metal. MetalTheme

返回辅助2颜色。

getSecondary2() - Method in class javax.swing.plaf.metal. OceanTheme

返回辅助2颜色。

getSecondary3() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回辅助3颜色。

getSecondary3() - Method in class javax.swing.plaf.metal. MetalTheme

返回辅助3颜色。

getSecondary3() - Method in class javax.swing.plaf.metal. OceanTheme

返回辅助3颜色。

getSeconds() - Method in class java.sql. Date

已过时。

getSeconds() - Method in class java.time. Duration

获取此持续时间内的秒数。

getSeconds() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，替换为Calendar.get(Calendar.SECOND) 。

getSeconds() - Method in class javax.xml.datatype. Duration

获取SECONDS字段的值作为整数值，如果不存在则取为0。

getSecretKey() - Method in class java.security. KeyStore.SecretKeyEntry

从此条目获取 SecretKey 。

getSectionRowIndex() - Method in interface org.w3c.dom.html. HTMLTableRowElement

此行的索引，相对于当前部分（ THEAD ， TFOOT ，或 TBODY ），从0开始。

getSecure() - Method in class java.net. HttpCookie

如果发送此cookie应该被限制为安全协议，则返回 true ，否则可以使用任何协议发送 false 。

getSecurityContext() - Method in class java.lang. SecurityManager

创建封装当前执行环境的对象。

getSecurityContext(ClassLoader) - Method in interface java.rmi.server. LoaderHandler

已过时。
没有替换

getSecurityContext(ClassLoader) - Static method in class java.rmi.server. RMIClassLoader

已过时。
没有替换。 从Java 2平台v1.2开始，RMI不再使用此方法来获取类加载器的安全上下文。

getSecurityManager() - Static method in class java.lang. System

获取系统安全界面。

getSeed() - Method in class java.security.spec. EllipticCurve

返回在曲线生成期间使用的播种字节 seed 。

getSeed(int) - Static method in class java.security. SecureRandom

返回给定数量的种子字节，使用该类用于种子本身的种子生成算法计算。

getSeedLength() - Method in class java.security.spec. DSAGenParameterSpec

以比特返回域参数种子的所需长度。

getSelectColor() - Method in class javax.swing.plaf.metal. MetalButtonUI

返回所选按钮的颜色。

getSelectColor() - Method in class javax.swing.plaf.metal. MetalRadioButtonUI

返回所选 JRadioButton的颜色。

getSelectColor() - Method in class javax.swing.plaf.metal. MetalToggleButtonUI

返回所选按钮的颜色。

getSelected() - Method in interface org.w3c.dom.html. HTMLOptionElement

在交互式用户代理中表示相应表单控件的当前状态。

getSelectedAccessibleColumns() - Method in interface javax.accessibility. AccessibleTable

返回表中选定的列。

getSelectedAccessibleColumns() - Method in class javax.swing. JTable.AccessibleJTable

返回表中选定的列。

getSelectedAccessibleRows() - Method in interface javax.accessibility. AccessibleTable

返回表中选定的行。

getSelectedAccessibleRows() - Method in class javax.swing. JTable.AccessibleJTable

返回表中选定的行。

getSelectedCells() - Method in class javafx.scene.control. TableView.TableViewSelectionModel

一个只读ObservableList，表示此TableView中当前选定的单元格。

getSelectedCells() - Method in class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel

一个只读ObservableList，表示此TreeTableView中当前选定的单元格。

getSelectedCheckbox() - Method in class java.awt. CheckboxGroup

从此复选框组获取当前选择。

getSelectedColor() - Method in interface javax.swing.colorchooser. ColorSelectionModel

返回所选的 Color ，应为非 null 。

getSelectedColor() - Method in class javax.swing.colorchooser. DefaultColorSelectionModel

返回所选的 Color ，应为非 null 。

getSelectedColumn() - Method in class javax.swing. JTable

返回第一个选定列的索引，如果未选择列，则返回-1。

getSelectedColumnCount() - Method in class javax.swing. JTable

返回所选列的数量。

getSelectedColumnCount() - Method in class javax.swing.table. DefaultTableColumnModel

返回所选列数。

getSelectedColumnCount() - Method in interface javax.swing.table. TableColumnModel

返回所选列的数量。

getSelectedColumns() - Method in class javax.swing. JTable

返回所有列的索引。

getSelectedColumns() - Method in class javax.swing.table. DefaultTableColumnModel

返回所选列的数组。

getSelectedColumns() - Method in interface javax.swing.table. TableColumnModel

返回所有选定列的指标数组。

getSelectedComponent() - Method in class javax.swing. JTabbedPane

返回此选项卡窗格当前选定的组件。

getSelectedExtensionFilter() - Method in class javafx.stage. FileChooser

获取selectedExtensionFilter属性的值。

getSelectedFile() - Method in class javax.swing. JFileChooser

返回所选文件。

getSelectedFiles() - Method in class javax.swing. JFileChooser

如果文件选择器设置为允许多个选择，则返回所选文件的列表。

getSelectedFrame() - Method in class javax.swing. JDesktopPane

返回当前活动 JInternalFrame这个 JDesktopPane ，或 null如果没有 JInternalFrame当前处于活动状态。

getSelectedIcon() - Method in class javax.swing. AbstractButton

返回按钮的选定图标。

getSelectedIndex() - Method in class java.awt. Choice

返回当前所选项目的索引。

getSelectedIndex() - Method in class java.awt. List

获取列表中所选项目的索引，

getSelectedIndex() - Method in class javafx.scene.control. SelectionModel

返回此模型中指示当前所选索引的整数值。

getSelectedIndex() - Method in class javax.security.auth.callback. ConfirmationCallback

获取所选的确认选项。

getSelectedIndex() - Method in class javax.swing. DefaultSingleSelectionModel

返回模型的选择。

getSelectedIndex() - Method in class javax.swing. JComboBox

返回列表中与给定项目匹配的第一个项目。

getSelectedIndex() - Method in class javax.swing. JList

返回最小的选定单元格索引; 在列表中仅选择单个项目时的选择。

getSelectedIndex() - Method in class javax.swing. JTabbedPane

返回此选项卡窗格的当前选择的索引。

getSelectedIndex() - Method in interface javax.swing. SingleSelectionModel

返回模型的选择。

getSelectedIndex() - Method in interface org.w3c.dom.html. HTMLSelectElement

所选选项的序数索引，从0开始。

getSelectedIndexes() - Method in class java.awt. List

获取列表中选定的索引。

getSelectedIndexes() - Method in class javax.security.auth.callback. ChoiceCallback

获取所选择的选项。

getSelectedIndices() - Method in class javafx.scene.control. MultipleSelectionModel

返回所有选定索引的 只读 ObservableList。

getSelectedIndices() - Method in class javax.swing. JList

以递增的顺序返回所有选定索引的数组。

getSelectedItem() - Method in class java.awt. Choice

获取当前选择的表示形式作为字符串。

getSelectedItem() - Method in class java.awt. List

获取此滚动列表中选定的项目。

getSelectedItem() - Method in class javafx.scene.control. ChoiceDialog

返回对话框中当前选定的项目。

getSelectedItem() - Method in class javafx.scene.control. SelectionModel

返回当前选定的对象（位于所选索引位置）。

getSelectedItem() - Method in interface javax.swing. ComboBoxModel

返回所选项目

getSelectedItem() - Method in class javax.swing. DefaultComboBoxModel

getSelectedItem() - Method in class javax.swing. JComboBox

返回当前所选项目。

getSelectedItem() - Method in class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxModel

getSelectedItem() - Method in class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxModel

getSelectedItems() - Method in class java.awt. List

获取此滚动列表中选定的项目。

getSelectedItems() - Method in class javafx.scene.control. MultipleSelectionModel

返回所有选定项目的 只读 ObservableList。

getSelectedObjects() - Method in class java.awt. Checkbox

返回一个包含复选框标签的数组（长度1），如果未选中该复选框，则返回null。

getSelectedObjects() - Method in class java.awt. CheckboxMenuItem

返回包含复选框菜单项标签的数组（长度1），如果未选中复选框，则返回null。

getSelectedObjects() - Method in class java.awt. Choice

返回一个包含当前所选项目的数组（长度1）。

getSelectedObjects() - Method in interface java.awt. ItemSelectable

如果没有选择项目，则返回所选项目或 null 。

getSelectedObjects() - Method in class java.awt. List

在对象数组中获取此滚动列表中选定的项目。

getSelectedObjects() - Method in class javax.swing. AbstractButton

如果未选择按钮，则返回包含标签的数组（长度1）或 null 。

getSelectedObjects() - Method in class javax.swing. DefaultButtonModel

被 null返回 null 。

getSelectedObjects() - Method in class javax.swing. JCheckBoxMenuItem

返回一个包含复选框菜单项标签的数组（长度1），如果未选中该复选框，则返回null。

getSelectedObjects() - Method in class javax.swing. JComboBox

返回一个包含所选项目的数组。

getSelectedPath() - Method in class javax.swing. MenuSelectionManager

返回当前选择的菜单项的路径

getSelectedRow() - Method in class javax.swing. JTable

返回第一个选定行的索引，如果没有选择行，则返回-1。

getSelectedRowCount() - Method in class javax.swing. JTable

返回所选行的数量。

getSelectedRows() - Method in class javax.swing. JTable

返回所有选定行的索引。

getSelectedStateCallback() - Method in class javafx.scene.control.cell. CheckBoxListCell

返回由屏幕上显示的复选框绑定的Callback 。

getSelectedStateCallback() - Method in class javafx.scene.control.cell. CheckBoxTableCell

返回由屏幕上显示的复选框绑定的Callback 。

getSelectedStateCallback() - Method in class javafx.scene.control.cell. CheckBoxTreeCell

返回由屏幕上显示的复选框绑定的Callback 。

getSelectedStateCallback() - Method in class javafx.scene.control.cell. CheckBoxTreeTableCell

返回由屏幕上显示的复选框绑定的Callback 。

getSelectedTabPadInsets(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回所选的选项卡垫插入。

getSelectedText() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回所选文本的部分。

getSelectedText() - Method in class java.awt. TextComponent

从由此文本组件呈现的文本中返回所选文本。

getSelectedText() - Method in class javafx.scene.control. TextInputControl

获取属性selectedText的值。

getSelectedText() - Method in interface javafx.scene.input. InputMethodRequests

从文本编辑节点获取当前选定的文本。

getSelectedText() - Method in interface javax.accessibility. AccessibleText

返回所选文本的部分。

getSelectedText() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回所选文本的部分。

getSelectedText() - Method in class javax.swing. JLabel.AccessibleJLabel

返回所选文本的部分。

getSelectedText() - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回所选文本的部分。

getSelectedText() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回所选文本的部分。

getSelectedText() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回所选文本的部分。

getSelectedText() - Method in class javax.swing.text. JTextComponent

返回此 TextComponent包含的选定文本。

getSelectedText(AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im. InputMethodRequests

从文本编辑组件获取当前选定的文本。

getSelectedTextColor() - Method in class javax.swing.text. JTextComponent

获取用于呈现所选文本的当前颜色。

getSelectedToggle() - Method in class javafx.scene.control. ToggleGroup

获取所选的 Toggle 。

getSelectedValue() - Method in class javax.swing. JList

返回最小选定单元索引的值; 在列表中仅选择单个项目时的选定值 。

getSelectedValues() - Method in class javax.swing. JList

已过时。
截至JDK 1.7，由JList.getSelectedValuesList()替代

getSelectedValuesList() - Method in class javax.swing. JList

根据列表中的索引，按照增加的顺序返回所有选定项目的列表。

getSelection() - Method in class javafx.scene.control. TextFormatter.Change

获取此更改的选择。

getSelection() - Method in class javafx.scene.control. TextInputControl

获取属性选择的值。

getSelection() - Method in class javax.swing. ButtonGroup

返回所选按钮的型号。

getSelectionBackground() - Method in class javax.swing. JList

返回用于绘制所选项目背景的颜色。

getSelectionBackground() - Method in class javax.swing. JTable

返回所选单元格的背景颜色。

getSelectionBackground() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

“selectionBackground”是当文字绘制在进度条的未填充区域时的颜色。

getSelectionColor() - Method in class javax.swing.text. JTextComponent

获取用于渲染选择的当前颜色。

getSelectionCount() - Method in class javax.swing. JTree

返回所选节点数。

getSelectionCount() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回所选路径的数量。

getSelectionCount() - Method in interface javax.swing.tree. TreeSelectionModel

返回所选路径的数量。

getSelectionEnd() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回所选文本中的结束偏移量。

getSelectionEnd() - Method in class java.awt. TextComponent

获取此文本组件中所选文本的最终位置。

getSelectionEnd() - Method in class javafx.scene.text. Text

获取属性selectionEnd的值。

getSelectionEnd() - Method in interface javax.accessibility. AccessibleText

返回所选文本中的结束偏移量。

getSelectionEnd() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回所选文本中的结束偏移量。

getSelectionEnd() - Method in class javax.swing. JLabel.AccessibleJLabel

返回所选文本中的结束偏移量。

getSelectionEnd() - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回所选文本中的结束偏移量。

getSelectionEnd() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回所选文本中的结束偏移量。

getSelectionEnd() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回所选文本中的结束偏移量。

getSelectionEnd() - Method in class javax.swing.text. JTextComponent

返回所选文本的结束位置。

getSelectionFill() - Method in class javafx.scene.text. Text

获取属性selectionFill的值。

getSelectionForeground() - Method in class javax.swing. JList

返回用于绘制所选项目前景的颜色。

getSelectionForeground() - Method in class javax.swing. JTable

返回所选单元格的前景颜色。

getSelectionForeground() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

“selectionForeground”是当绘制在进度条的填充区域时的文本颜色。

getSelectionMode() - Method in class javafx.scene.control. MultipleSelectionModel

获取属性selectionMode的值。

getSelectionMode() - Method in class javax.swing. DefaultListSelectionModel

返回当前选择模式。

getSelectionMode() - Method in class javax.swing. JList

返回列表的当前选择模式。

getSelectionMode() - Method in interface javax.swing. ListSelectionModel

返回当前选择模式。

getSelectionMode() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回选择模式，一个 SINGLE_TREE_SELECTION ， DISCONTIGUOUS_TREE_SELECTION或者 CONTIGUOUS_TREE_SELECTION 。

getSelectionMode() - Method in interface javax.swing.tree. TreeSelectionModel

返回当前选择模式，一个 SINGLE_TREE_SELECTION ， CONTIGUOUS_TREE_SELECTION或者 DISCONTIGUOUS_TREE_SELECTION 。

getSelectionModel() - Method in class javafx.scene.control. ChoiceBox

获取属性selectionModel的值。

getSelectionModel() - Method in class javafx.scene.control. ComboBox

获取属性selectionModel的值。

getSelectionModel() - Method in class javafx.scene.control. ListView

返回当前安装的选择模型。

getSelectionModel() - Method in class javafx.scene.control. TableView

获取属性selectionModel的值。

getSelectionModel() - Method in class javafx.scene.control. TabPane

获取用于选项卡选择的模型。

getSelectionModel() - Method in class javafx.scene.control. TreeTableView

返回当前安装的选择模型。

getSelectionModel() - Method in class javafx.scene.control. TreeView

返回当前安装的选择模型。

getSelectionModel() - Method in class javax.swing. JColorChooser

返回处理颜色选择的数据模型。

getSelectionModel() - Method in class javax.swing. JList

返回当前的选择模型。

getSelectionModel() - Method in class javax.swing. JMenuBar

返回处理单个选择的模型对象。

getSelectionModel() - Method in class javax.swing. JPopupMenu

返回处理单个选择的模型对象。

getSelectionModel() - Method in class javax.swing. JTable

返回用于维持行选择状态的 ListSelectionModel 。

getSelectionModel() - Method in class javax.swing. JTree

返回模型进行选择。

getSelectionModel() - Method in class javax.swing.plaf.basic. BasicTreeUI

返回树选择模型。

getSelectionModel() - Method in class javax.swing.table. DefaultTableColumnModel

返回用于维护列选择状态的 ListSelectionModel 。

getSelectionModel() - Method in interface javax.swing.table. TableColumnModel

返回当前的选择模型。

getSelectionModel() - Method in class javax.swing.tree. AbstractLayoutCache

返回用于维护选择的模型。

getSelectionPainter() - Method in class javax.swing.text. DefaultCaret

获得荧光笔的画家。

getSelectionPath() - Method in class javax.swing. JTree

返回到第一个选定节点的路径。

getSelectionPath() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回选择中的第一个路径。

getSelectionPath() - Method in interface javax.swing.tree. TreeSelectionModel

返回选择中的第一个路径。

getSelectionPaths() - Method in class javax.swing. JTree

返回所有选定值的路径。

getSelectionPaths() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回选择。

getSelectionPaths() - Method in interface javax.swing.tree. TreeSelectionModel

返回选择中的路径。

getSelectionRows() - Method in class javax.swing. JTree

返回当前选定的所有行。

getSelectionRows() - Method in class javax.swing.tree. DefaultTreeSelectionModel

以行为单位返回选择。

getSelectionRows() - Method in interface javax.swing.tree. TreeSelectionModel

返回当前选定的所有行。

getSelectionShape() - Method in class javafx.scene.text. Text

局部坐标选择形状。

getSelectionStart() - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

返回所选文本中的起始偏移量。

getSelectionStart() - Method in class java.awt. TextComponent

获取此文本组件中所选文本的起始位置。

getSelectionStart() - Method in class javafx.scene.text. Text

获取属性selectionStart的值。

getSelectionStart() - Method in interface javax.accessibility. AccessibleText

返回所选文本中的起始偏移量。

getSelectionStart() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回所选文本中的起始偏移量。

getSelectionStart() - Method in class javax.swing. JLabel.AccessibleJLabel

返回所选文本中的起始偏移量。

getSelectionStart() - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回所选文本中的起始偏移量。

getSelectionStart() - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

返回所选文本中的起始偏移量。

getSelectionStart() - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回所选文本中的起始偏移量。

getSelectionStart() - Method in class javax.swing.text. JTextComponent

返回所选文本的起始位置。

getSelectionValues() - Method in class javax.swing. JOptionPane

返回输入选择值。

getSelector() - Method in class javafx.css. Match

getSelector() - Method in class javafx.css. Style

选择器可能有多个选择器。

getSelectors() - Method in class javafx.css. CompoundSelector

组合此复合选择器的选择器

getSelectors() - Method in class javafx.css. Rule

此方法是支持可能希望从Rule添加选择器或从Rule中删除选择器的工具。

getSelectorText() - Method in interface org.w3c.dom.css. CSSPageRule

规则的页面选择器的可解析文本表示。

getSelectorText() - Method in interface org.w3c.dom.css. CSSStyleRule

规则集的选择器的文本表示。

getSelfIlluminationMap() - Method in class javafx.scene.paint. PhongMaterial

获取属性selfIlluminationMap的值。

getSendBufferSize() - Method in class java.net. DatagramSocket

获取此 DatagramSocket的SO_SNDBUF选项的值，即该平台用于在此 DatagramSocket上输出的缓冲区大小。

getSendBufferSize() - Method in class java.net. Socket

获取这个 Socket的 SO_SNDBUF选项的值，即该平台用于在此 Socket上输出的缓冲区大小。

getSender() - Method in class javax.security.auth.kerberos. KerberosCredMessage

返回此消息的发件人。

getSendPastNotifications() - Method in class javax.management.timer. Timer

获取指示定时器是否发送过去通知的标志。

getSendPastNotifications() - Method in interface javax.management.timer. TimerMBean

获取指示定时器是否发送过去通知的标志。

getSentenceInstance() - Static method in class java.text. BreakIterator

返回一个新 BreakIterator例如 sentence breaks为 default locale 。

getSentenceInstance(Locale) - Static method in class java.text. BreakIterator

为给定的区域设置返回一个新的 BreakIterator实例 sentence breaks 。

getSentenceInstance(Locale) - Method in class java.text.spi. BreakIteratorProvider

为给定的区域设置返回一个新的 BreakIterator实例 sentence breaks 。

getSeparator() - Method in class java.nio.file. FileSystem

返回名称分隔符，表示为字符串。

getSeparator() - Method in interface org.w3c.dom.css. Counter

该属性用于嵌套计数器的分隔符。

getSeparatorBackground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的分隔符背景颜色。

getSeparatorBackground() - Method in class javax.swing.plaf.metal. MetalTheme

返回分隔符背景颜色。

getSeparatorForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的分隔符前景颜色。

getSeparatorForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回分隔符前景颜色。

getSeparatorSize() - Method in class javax.swing. JToolBar.Separator

返回分隔符的大小

getSequence() - Method in interface javax.sound.midi. Sequencer

获取序列器当前正在操作的顺序。

getSequence(File) - Static method in class javax.sound.midi. MidiSystem

从指定的 File获取MIDI序列。

getSequence(File) - Method in class javax.sound.midi.spi. MidiFileReader

从提供的 File获取MIDI序列。

getSequence(InputStream) - Static method in class javax.sound.midi. MidiSystem

从指定的输入流中获取MIDI序列。

getSequence(InputStream) - Method in class javax.sound.midi.spi. MidiFileReader

从提供的输入流中获取MIDI序列。

getSequence(URL) - Static method in class javax.sound.midi. MidiSystem

从指定的URL获取MIDI序列。

getSequence(URL) - Method in class javax.sound.midi.spi. MidiFileReader

从提供的URL获取MIDI序列。

getSequenceDetState() - Method in interface org.ietf.jgss. GSSContext

确定是否从此上下文为每个消息安全服务启用了序列检查。

getSequenceNumber() - Method in class java.util.logging. LogRecord

获取序列号。

getSequenceNumber() - Method in class javax.management. Notification

获取通知序列号。

getSequencer() - Static method in class javax.sound.midi. MidiSystem

获取默认值 Sequencer ，连接到默认设备。

getSequencer(boolean) - Static method in class javax.sound.midi. MidiSystem

获取默认值 Sequencer ，可选地连接到默认设备。

getSerialFilter() - Static method in class java.io. ObjectInputFilter.Config

如果未配置，则返回过程范围的序列化过滤器或 null 。

getSerializedObject() - Method in class javax.management.loading. MLetContent

获取 MLET标签的 OBJECT属性的值。

getSerialNumber() - Method in class java.security.cert. X509Certificate

从证书中获取 serialNumber值。

getSerialNumber() - Method in class java.security.cert. X509CertSelector

返回serialNumber标准。

getSerialNumber() - Method in class java.security.cert. X509CRLEntry

从这个X509CRLEntry， userCertificate获取序列号。

getSerialNumber() - Method in class javax.security.cert. X509Certificate

已过时。

从证书获取 serialNumber价值。

getSerialNumber() - Method in interface javax.xml.crypto.dsig.keyinfo. X509IssuerSerial

返回此 X509IssuerSerial的序列号。

getSerialVersionUID() - Method in class java.io. ObjectStreamClass

返回此类的serialVersionUID。

getServer() - Method in class com.sun.net.httpserver. HttpContext

返回创建该上下文的服务器

getServer() - Method in class javax.security.auth.kerberos. KerberosTicket

返回与此票证相关联的服务主体。

getServerAliases(String, Principal[]) - Method in interface javax.net.ssl. X509KeyManager

获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的服务器端。

getServerCertificateChain() - Method in class java.net. SecureCacheResponse

返回服务器的证书链，它是作为在检索网络资源的原始连接中从缓存定义会话的一部分而建立的。

getServerCertificates() - Method in class javax.net.ssl. HttpsURLConnection

返回作为定义会话的一部分而建立的服务器的证书链。

getServerName() - Method in class java.security.cert. LDAPCertStoreParameters

返回LDAP服务器的DNS名称。

getServerNames() - Method in class javax.net.ssl. SSLParameters

返回List包含所有SNIServerName •服务器名称指示的（SNI）的参数，如果没有则为null已设置。

getServerSessionContext() - Method in class javax.net.ssl. SSLContext

返回服务器会话上下文，代表可在服务器端SSL套接字握手阶段使用的SSL会话集。

getServerSocketFactory() - Method in class javax.net.ssl. SSLContext

为此上下文返回一个 ServerSocketFactory对象。

getService() - Method in interface javax.lang.model.element. ModuleElement.ProvidesDirective

返回正在提供的服务。

getService() - Method in interface javax.lang.model.element. ModuleElement.UsesDirective

返回使用的服务。

getService(BeanContextChild, Object, Class<?>, Object, BeanContextServiceRevokedListener) - Method in interface java.beans.beancontext. BeanContextServices

A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。

getService(BeanContextChild, Object, Class<?>, Object, BeanContextServiceRevokedListener) - Method in class java.beans.beancontext. BeanContextServicesSupport

获得可能委托的服务

getService(BeanContextServices, Object, Class<?>, Object) - Method in interface java.beans.beancontext. BeanContextServiceProvider

这个方法由 BeanContextServices调用，从这个 BeanContextServiceProvider请求一个服务实例。

getService(BeanContextServices, Object, Class<?>, Object) - Method in class java.beans.beancontext. BeanContextServicesSupport.BCSSProxyServiceProvider

getService(String, String) - Method in class java.security. Provider

获取描述此提供程序实现该算法或别名的指定类型的服务。

getServiceClass() - Method in class java.beans.beancontext. BeanContextServiceAvailableEvent

获取作为此通知主题的服务类。

getServiceClass() - Method in class java.beans.beancontext. BeanContextServiceRevokedEvent

获取作为此通知主题的服务类

getServiceLoader(JavaFileManager.Location, Class<S>) - Method in class javax.tools. ForwardingJavaFileManager

getServiceLoader(JavaFileManager.Location, Class<S>) - Method in interface javax.tools. JavaFileManager

从给定位置获取特定服务类的服务加载程序。

getServiceName() - Method in interface com.sun.source.tree. ProvidesTree

返回正在提供的服务类型的名称。

getServiceName() - Method in interface com.sun.source.tree. UsesTree

返回服务类型的名称。

getServiceName() - Method in interface javax.xml.ws.handler. PortInfo

获取包含正在访问的端口的WSDL服务名称的限定名称。

getServiceName() - Method in class javax.xml.ws. Service

获取此服务的名称。

getServiceName() - Method in class javax.xml.ws.spi. ServiceDelegate

获取此服务的名称。

getServiceNames() - Static method in class javax.jnlp. ServiceManager

返回由JNLP Client实现的所有服务的名称。

getServiceNames() - Method in interface javax.jnlp. ServiceManagerStub

请参阅 ServiceManager.getServiceNames()的说明

getServiceProvider() - Method in class java.beans.beancontext. BeanContextServicesSupport.BCSSServiceProvider

返回服务提供者。

getServiceProviderByClass(Class<T>) - Method in class javax.imageio.spi. ServiceRegistry

返回给定类类型的当前注册的服务提供者对象。

getServiceProviders(Class<T>, boolean) - Method in class javax.imageio.spi. ServiceRegistry

返回包含给定类别的所有注册服务提供商的 Iterator 。

getServiceProviders(Class<T>, ServiceRegistry.Filter, boolean) - Method in class javax.imageio.spi. ServiceRegistry

返回 Iterator一个给定类别中满足由所提供的定义的条件的含服务提供程序对象 ServiceRegistry.Filter对象的 filter方法。

getServices() - Method in class java.security. Provider

获取不可修改的此提供程序支持的所有服务的集合。

getServicesBeanInfo() - Method in interface java.beans.beancontext. BeanContextServiceProviderBeanInfo

获取一个 BeanInfo阵列，一个针对每个ServiceProvider静态可用的服务类或接口。

getServiceType() - Method in interface com.sun.source.doctree. ProvidesTree

返回正在记录的服务类型的名称。

getServiceType() - Method in interface com.sun.source.doctree. UsesTree

返回正在记录的服务类型的名称。

getServiceUIFactory() - Method in interface javax.print. PrintService

返回用于UI组件的工厂，允许用户以各种角色与服务进行交互。

getSession() - Method in class javax.net.ssl. HandshakeCompletedEvent

返回触发此事件的会话。

getSession() - Method in class javax.net.ssl. SSLEngine

返回此 SSLSession中使用的 SSLEngine 。

getSession() - Method in class javax.net.ssl. SSLSessionBindingEvent

返回侦听器被绑定到的SSLSession或侦听器被绑定到的SSLSession。

getSession() - Method in class javax.net.ssl. SSLSocket

返回此连接正在使用的SSL会话。

getSession(byte[]) - Method in interface javax.net.ssl. SSLSessionContext

返回绑定到指定会话ID的 SSLSession 。

getSessionCacheSize() - Method in interface javax.net.ssl. SSLSessionContext

返回用于存储 SSLSession对象的高速缓存的大小，分组在此 SSLSessionContext 。

getSessionContext() - Method in interface javax.net.ssl. SSLSession

返回此会话绑定的上下文。

getSessionKey() - Method in class javax.security.auth.kerberos. KerberosTicket

返回与此故障单关联的会话密钥。

getSessionKeyType() - Method in class javax.security.auth.kerberos. KerberosTicket

返回由Kerberos协议规范定义的与此故障单关联的会话密钥的密钥类型。

getSessionTimeout() - Method in interface javax.net.ssl. SSLSessionContext

返回的超时限制 SSLSession级这个组合的对象 SSLSessionContext 。

getSet() - Method in class javafx.collections. SetChangeListener.Change

与变化相关联的可观察集合。

getSetter() - Method in interface jdk.nashorn.api.tree. PropertyTree

如果这是一个访问器属性，则返回此属性的getter函数。

getSeverity() - Method in enum java.lang. System.Logger.Level

返回此级别的严重性。

getSeverity() - Method in class javax.xml.bind.helpers. ValidationEventImpl

getSeverity() - Method in interface javax.xml.bind. ValidationEvent

检索此警告/错误的严重性代码。

getSeverity() - Method in interface org.w3c.dom. DOMError

错误的严重性，无论是 SEVERITY_WARNING ， SEVERITY_ERROR ，或 SEVERITY_FATAL_ERROR 。

getShadowColor() - Method in class javax.swing.border. EtchedBorder

返回蚀刻边框的阴影颜色。

getShadowColor() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回阴影颜色。

getShadowColor(Component) - Method in class javax.swing.border. EtchedBorder

在指定的组件上呈现时，返回蚀刻边框的阴影颜色。

getShadowInnerColor() - Method in class javax.swing.border. BevelBorder

返回斜角边框的内阴影颜色。

getShadowInnerColor(Component) - Method in class javax.swing.border. BevelBorder

在指定的组件上呈现时，返回斜角边框的内阴影颜色。

getShadowOuterColor() - Method in class javax.swing.border. BevelBorder

返回斜角边框的外部阴影颜色。

getShadowOuterColor(Component) - Method in class javax.swing.border. BevelBorder

在指定的组件上呈现时，返回斜角边框的外阴影颜色。

getShape() - Method in class java.awt. Window

返回窗口的形状。

getShape() - Method in class javafx.animation. FillTransition

获取属性形状的值。

getShape() - Method in class javafx.animation. StrokeTransition

获取属性形状的值。

getShape() - Method in class javafx.scene.layout. Region

获取属性形状的值。

getShape() - Method in interface org.w3c.dom.html. HTMLAnchorElement

活动区域的形状。

getShape() - Method in interface org.w3c.dom.html. HTMLAreaElement

活动区域的形状。

getShaper(int) - Static method in class java.awt.font. NumericShaper

返回提供的unicode范围的整形器。

getShaper(NumericShaper.Range) - Static method in class java.awt.font. NumericShaper

返回提供的Unicode范围的整形器。

getSharedAncestor(DefaultMutableTreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点最近的共同祖先和 aNode 。

getSharedInstance() - Static method in class javax.swing. PopupFactory

返回共享的 PopupFactory ，可用于获取 Popup s。

getSharedQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回包含可能正在等待在共享模式下获取的线程的集合。

getSharedQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回包含可能正在等待在共享模式下获取的线程的集合。

getShearInstance(double, double) - Static method in class java.awt.geom. AffineTransform

返回代表剪切变换的变换。

getShearX() - Method in class java.awt.geom. AffineTransform

返回3x3仿射变换矩阵的X坐标剪切元素（m01）。

getShearY() - Method in class java.awt.geom. AffineTransform

返回3x3仿射变换矩阵的Y坐标剪切元素（m10）。

getSheet() - Method in interface org.w3c.dom.stylesheets. LinkStyle

样式表。

getShift() - Method in class javafx.scene.input. KeyCombination

shift键在这个关键组合的状态。

getShift() - Method in class javax.swing.plaf.metal. MetalIconFactory.FileIcon16

返回图标的移动。

getShift() - Method in class javax.swing.plaf.metal. MetalIconFactory.FolderIcon16

返回图标的移动。

getShift() - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeFolderIcon

getShift() - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeLeafIcon

getShiftKey() - Method in interface org.w3c.dom.events. MouseEvent

用于指示在触发事件期间“shift”键是否被压制。

getShort() - Method in class java.nio. ByteBuffer

相对 获取方法读取一个简短的值。

getShort(int) - Method in class java.nio. ByteBuffer

绝对 获取读取一个简短值的方法。

getShort(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 short指定的JDBC SMALLINT参数的值。

getShort(int) - Method in interface java.sql. ResultSet

检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 short 。

getShort(Object) - Method in class java.lang.reflect. Field

获取类型为 short的静态或实例字段的值，或通过扩大转换获得可转换为类型 short的另一个原始类型的值。

getShort(Object, int) - Static method in class java.lang.reflect. Array

返回指定数组对象中索引组件的值，如 short 。

getShort(String) - Method in interface java.sql. CallableStatement

以Java编程语言中的 short JDBC SMALLINT参数的值。

getShort(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 short此 ResultSet对象的当前行中指定列的值。

getShortcut() - Method in class java.awt. MenuItem

获取与 MenuShortcut相关联的 MenuShortcut对象，

getShortcut() - Method in class javafx.scene.input. KeyCombination

这个关键组合中的 shortcut键的状态。

getShortcutMenuItem(MenuShortcut) - Method in class java.awt. MenuBar

获取的实例 MenuItem与指定相关 MenuShortcut的对象，或者 null如果被管理没有菜单项的通过该菜单栏与指定的菜单快捷方式有关。

getShortDescription() - Method in class java.beans. FeatureDescriptor

获取此功能的简短描述。

getShortMonths() - Method in class java.text. DateFormatSymbols

获得短的月份字符串。

getShortParameter(int) - Method in class java.awt.image.renderable. ParameterBlock

一个简单的方法返回一个参数。

getShortWeekdays() - Method in class java.text. DateFormatSymbols

获得短周日字符串。

getShowDelay() - Method in class javafx.scene.control. Tooltip

获取属性showDelay的值。

getShowDeleted() - Method in class javax.sql.rowset. BaseRowSet

检索一个 boolean指示标记为删除的行是否显示在当前行的集合中。

getShowDeleted() - Method in interface javax.sql.rowset. CachedRowSet

检索一个 boolean指示标记为删除的行是否显示在当前行的集合中。

getShowDeleted() - Method in interface javax.sql.rowset. JdbcRowSet

检索一个 boolean指示标记为删除的行是否显示在当前行的集合中。

getShowDuration() - Method in class javafx.scene.control. Tooltip

获取属性showDuration的值。

getShowHorizontalLines() - Method in class javax.swing. JTable

如果表在单元格之间绘制水平线，则返回true，否则返回false。

getShowsRootHandles() - Method in class javax.swing. JTree

返回 showsRootHandles属性的值。

getShowsRootHandles() - Method in class javax.swing.plaf.basic. BasicTreeUI

如果要显示根句柄，则返回 true 。

getShowVerticalLines() - Method in class javax.swing. JTable

如果表在单元格之间绘制垂直线，则返回true，否则返回false。

getSiblingCount() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的兄弟节点数。

getSide() - Method in class javafx.scene.chart. Axis

获取属性侧的值。

getSide() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的当前位置。

getSides() - Method in class java.awt. JobAttributes

返回在使用这些属性的作业的打印介质的两侧应该如何施加连续的页面。

getSigAlgName() - Method in class java.security.cert. X509Certificate

获取证书签名算法的签名算法名称。

getSigAlgName() - Method in class java.security.cert. X509CRL

获取CRL签名算法的签名算法名称。

getSigAlgName() - Method in class javax.security.cert. X509Certificate

已过时。

获取证书签名算法的签名算法名称。

getSigAlgOID() - Method in class java.security.cert. X509Certificate

从证书获取签名算法OID字符串。

getSigAlgOID() - Method in class java.security.cert. X509CRL

从CRL获取签名算法OID字符串。

getSigAlgOID() - Method in class javax.security.cert. X509Certificate

已过时。

从证书获取签名算法OID字符串。

getSigAlgParams() - Method in class java.security.cert. X509Certificate

从该证书的签名算法获取DER编码的签名算法参数。

getSigAlgParams() - Method in class java.security.cert. X509CRL

从该CRL的签名算法获取DER编码的签名算法参数。

getSigAlgParams() - Method in class javax.security.cert. X509Certificate

已过时。

从该证书的签名算法获取DER编码的签名算法参数。

getSign() - Method in class javax.xml.datatype. Duration

以-1,0或1的形式返回此持续时间的符号。

getSignature() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索JAR文件的签名。

getSignature() - Method in interface com.sun.source.doctree. ReferenceTree

返回被引用的Java语言元素的签名，如 @see和类似的节点所示。

getSignature() - Method in class java.security.cert. X509Certificate

获取 signature中的 signature值（原始签名位）。

getSignature() - Method in class java.security.cert. X509CRL

获取CRL中的 signature值（原始签名位）。

getSignature() - Method in class java.security. SignedObject

以一个字节数组的形式检索签名对象上的签名。

getSignature() - Method in class javax.management. MBeanConstructorInfo

返回此构造函数的参数列表。

getSignature() - Method in class javax.management. MBeanOperationInfo

返回此操作的参数列表。

getSignature() - Method in interface javax.management.openmbean. OpenMBeanConstructorInfo

返回一个 OpenMBeanParameterInfo实例的数组，描述由该 OpenMBeanConstructorInfo实例描述的构造函数的签名中的每个参数。

getSignature() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo

返回的数组 OpenMBeanParameterInfo实例描述在此描述的操作的签名中的每个参数 OpenMBeanOperationInfo实例。

getSignatureAlgorithm() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索签名算法的名称。

getSignatureAlgorithm() - Method in class jdk.security.jarsigner. JarSigner

返回此 JarSigner的签名算法。

getSignatureMethod() - Method in interface javax.xml.crypto.dsig. SignedInfo

返回此 SignedInfo的签名方法。

getSignatureValue() - Method in interface javax.xml.crypto.dsig. XMLSignature

返回此 XMLSignature的签名值。

getSignedInfo() - Method in interface javax.xml.crypto.dsig. XMLSignature

返回此 XMLSignature的签名信息。

getSignerCertificateChain() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索签名人的X.509证书链。

getSignerCertPath() - Method in class java.security. CodeSigner

返回签名者的证书路径。

getSignerCertPath() - Method in class java.security. Timestamp

返回时间戳权限的证书路径。

getSignerName() - Method in class jdk.security.jarsigner. JarSigner

返回此 JarSigner的签名者名称。

getSigners() - Method in class java.lang. Class

获得这个类的签名者。

getSigProvider() - Method in class java.security.cert. PKIXParameters

返回签名提供者的名称，如果未设置，则返回 null 。

getSimpleName() - Method in interface com.sun.source.tree. ClassTree

返回此类型声明的简单名称。

getSimpleName() - Method in class java.lang. Class

返回源代码中给出的基础类的简单名称。

getSimpleName() - Method in interface javax.lang.model.element. Element

返回此元素的简单（不合格）名称。

getSimpleName() - Method in interface javax.lang.model.element. ExecutableElement

返回构造函数，方法或初始值设置的简单名称。

getSimpleName() - Method in interface javax.lang.model.element. ModuleElement

返回此模块的简单名称。

getSimpleName() - Method in interface javax.lang.model.element. PackageElement

返回此包的简单名称。

getSimpleName() - Method in interface javax.lang.model.element. TypeElement

返回此类型元素的简单名称。

getSimpleName() - Method in interface javax.lang.model.element. VariableElement

返回此变量元素的简单名称。

getSimpleNameLength() - Method in class jdk.jshell. SourceCodeAnalysis.QualifiedNames

原始代码中的限定名称所在的简单名称的长度。

getSingleNodeValue() - Method in interface org.w3c.dom.xpath. XPathResult

该单节点结果的值可能为 null 。

getSize() - Method in class com.sun.java.accessibility.util. Translator

返回此对象的当前大小。

getSize() - Method in class java.awt. Component.AccessibleAWTComponent

以 Dimension对象的形式返回此对象的大小。

getSize() - Method in class java.awt. Component

以 Dimension对象的形式返回此组件的大小。

getSize() - Method in class java.awt. Dimension

获取此 Dimension对象的大小。

getSize() - Method in class java.awt. Font

返回此 Font的点大小，舍入为整数。

getSize() - Method in class java.awt.image. DataBuffer

返回所有存储区的大小（以数组为单位）。

getSize() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

以Dimension对象的形式返回此对象的大小。

getSize() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

以 Dimension对象的形式返回此对象的大小。

getSize() - Method in class java.awt. Rectangle

获得这个 Rectangle的大小，由返回的 Dimension代表。

getSize() - Method in class java.awt. SplashScreen

以Dimension返回闪屏的大小。

getSize() - Method in class java.awt. TrayIcon

返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。

getSize() - Method in class java.util.zip. ZipEntry

返回条目数据的未压缩大小。

getSize() - Method in class javafx.beans.binding. ListExpression

列表的大小

getSize() - Method in class javafx.beans.binding. MapExpression

地图的大小

getSize() - Method in class javafx.beans.binding. SetExpression

集合的大小

getSize() - Method in class javafx.scene.layout. BackgroundImage

该图像相对于Region的大小。

getSize() - Method in class javafx.scene.text. Font

该字体的点大小。

getSize() - Method in interface javax.accessibility. AccessibleComponent

以 Dimension对象的形式返回此对象的大小。

getSize() - Method in class javax.jnlp. DownloadService2.ResourceSpec

返回资源的大小。

getSize() - Method in class javax.swing. DefaultComboBoxModel

getSize() - Method in class javax.swing. DefaultListModel

返回此列表中的组件数。

getSize() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

getSize() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

getSize() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

getSize() - Method in interface javax.swing. ListModel

返回列表的长度。

getSize() - Method in class javax.swing.plaf.basic. BasicDirectoryModel

getSize() - Method in class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxModel

getSize() - Method in class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxModel

getSize() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getSize() - Method in class javax.xml.soap. AttachmentPart

返回此 AttachmentPart对象中的字节数。

getSize() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的size属性定义。

getSize() - Method in interface org.w3c.dom.html. HTMLBaseFontElement

字体大小。

getSize() - Method in interface org.w3c.dom.html. HTMLFontElement

字体大小。

getSize() - Method in interface org.w3c.dom.html. HTMLHRElement

规则的高度。

getSize() - Method in interface org.w3c.dom.html. HTMLInputElement

尺寸信息。

getSize() - Method in interface org.w3c.dom.html. HTMLSelectElement

可见行数

getSize(int) - Method in class javax.print.attribute. Size2DSyntax

以给定单位获取此二维尺寸属性的尺寸作为浮点值。

getSize(int) - Method in class javax.swing. SizeSequence

返回指定条目的大小。

getSize(Dimension) - Method in class java.awt. Component

将该组件的宽度/高度存储到“返回值” rv并返回 rv 。

getSize(Dimension) - Method in class javax.swing. JComponent

将该组件的宽度/高度存储为“返回值” rv并返回 rv 。

getSize2D() - Method in class java.awt. Font

返回此点大小 Font在 float值。

getSizeButtonsToSameWidth() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

返回 true ，基本的L＆F希望所有的按钮具有相同的宽度。

getSizeButtonsToSameWidth() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI

返回 true ，基本的L＆F希望所有的按钮具有相同的宽度。

getSizeConverter() - Static method in class javafx.css. StyleConverter

将CSS长度和数值解析为Size对象，该对象在应用该值之前转换为Number。

getSizeForComponent(Component) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

如果用作单元格渲染器，则返回组件将具有的大小。

getSizeOfComponent(Component) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

返回传入组件的宽度。

getSizeOfType(int) - Static method in class javax.imageio.plugins.tiff. TIFFTag

返回用于存储给定数据类型的值的字节数。

getSizes() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

返回组件的大小。

getSizes() - Method in class javax.swing. SizeSequence

返回所有条目的大小。

getSizingIcon(AbstractButton) - Method in class javax.swing.plaf.synth. SynthButtonUI

返回用于计算首选/最小/最大大小的图标。

getSizingIcon(AbstractButton) - Method in class javax.swing.plaf.synth. SynthRadioButtonUI

返回用于计算首选/最小/最大大小的图标。

getSkin() - Method in class javafx.scene.control. Control

获取属性皮肤的值。

getSkin() - Method in class javafx.scene.control. PopupControl

获取属性皮肤的值。

getSkin() - Method in interface javafx.scene.control. Skinnable

返回呈现此皮肤的皮肤Control

getSkinnable() - Method in class javafx.scene.control.skin. ContextMenuSkin

获取此皮肤分配到的Skinnable。

getSkinnable() - Method in interface javafx.scene.control. Skin

获取此皮肤分配到的Skinnable。

getSkinnable() - Method in class javafx.scene.control.skin. TooltipSkin

获取此皮肤分配到的Skinnable。

getSkinnable() - Method in class javafx.scene.control. SkinBase

获取此皮肤分配到的Skinnable。

getSlaveSyncMode() - Method in interface javax.sound.midi. Sequencer

获取此定序器的当前从同步模式。

getSlaveSyncModes() - Method in interface javax.sound.midi. Sequencer

获取音序器支持的一组从属同步模式。

getSlices() - Method in class javafx.scene.layout. BorderImage

定义图像的切片。

getSlot(int) - Method in class jdk.nashorn.api.scripting. AbstractJSObject

getSlot(int) - Method in interface jdk.nashorn.api.scripting. JSObject

检索此JavaScript对象的索引成员。

getSlot(int) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

getSlot(int) - Method in class netscape.javascript. JSObject

检索JavaScript对象的索引成员。

getSmallDisplayIcon() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

返回面板的小显示图标。

getSmallestMaximum() - Method in class java.time.temporal. ValueRange

获取该字段可以采用的最小可能最大值。

getSnapshot() - Method in class java.awt.image. VolatileImage

返回此对象的静态快照图像。

getSnapshotLength() - Method in interface org.w3c.dom.xpath. XPathResult

结果快照中的节点数。

getSnapshotParameters() - Method in class javafx.scene. SnapshotResult

获取用于生成快照的SnapshotParameters的副本。

getSnapToTicks() - Method in class javax.swing. JSlider

如果旋钮（及其表示的数据值）解析为用户放置旋钮的最近刻度标记，则返回true。

getSNIMatchers() - Method in class javax.net.ssl. SSLParameters

返回Collection包含所有SNIMatcher •服务器名称指示的（SNI）的参数，如果没有则为null已设置。

getSnippet() - Method in exception jdk.jshell. UnresolvedReferenceException

返回具有未解决的引用的代码段。

getSOAPBody() - Method in class javax.xml.soap. SOAPMessage

获取此 SOAPMessage对象中包含的SOAP Body。

getSOAPFactory() - Method in interface javax.xml.ws.soap. SOAPBinding

获取此SOAP绑定使用的SAAJ SOAPFactory实例。

getSOAPHeader() - Method in class javax.xml.soap. SOAPMessage

获取此 SOAPMessage对象中包含的SOAP头。

getSOAPPart() - Method in class javax.xml.soap. SOAPMessage

获取此 SOAPMessage对象的SOAP部分。

getSocket() - Method in class javax.net.ssl. HandshakeCompletedEvent

返回作为此事件源的套接字。

getSocketAddress() - Method in class java.net. DatagramPacket

获取该数据包发送到或正在从其发送的远程主机的SocketAddress（通常为IP地址+端口号）。

getSocketFactory() - Static method in class java.rmi.server. RMISocketFactory

返回由 setSocketFactory方法设置的套接字工厂。

getSocketFactory() - Method in class javax.net.ssl. SSLContext

为此上下文返回一个 SocketFactory对象。

getSoftFailExceptions() - Method in class java.security.cert. PKIXRevocationChecker

返回一个列表，其中包含当设置了 SOFT_FAIL选项时撤销检查器忽略的异常。

getSoLinger() - Method in class java.net. Socket

退款设置为 SO_LINGER 。

getSolo() - Method in interface javax.sound.midi. MidiChannel

获取此频道的当前独奏状态。

getSortKeys() - Method in class javax.swing. DefaultRowSorter

返回当前的排序键。

getSortKeys() - Method in class javax.swing. RowSorter

返回当前的排序键。

getSortMode() - Method in class javafx.scene.control. TreeTableView

获取属性sortMode的值。

getSortNode() - Method in class javafx.scene.control. TableColumnBase

获取属性sortNode的值。

getSortOrder() - Method in class javafx.scene.control. TableView

sortOrder列表定义了TableColumn实例进行排序的顺序。

getSortOrder() - Method in class javafx.scene.control. TreeTableView

sortOrder列表定义了TreeTableColumn实例进行排序的顺序。

getSortOrder() - Method in class javax.swing. RowSorter.SortKey

返回列的排序顺序。

getSortPolicy() - Method in class javafx.scene.control. TableView

获取属性sortPolicy的值。

getSortPolicy() - Method in class javafx.scene.control. TreeTableView

获取属性sortPolicy的值。

getSortsOnUpdates() - Method in class javax.swing. DefaultRowSorter

如果在更新底层模型时发生排序，则返回true; 否则返回false。

getSortType() - Method in class javafx.scene.control. TableColumn

获取属性sortType的值。

getSortType() - Method in class javafx.scene.control. TreeTableColumn

获取属性sortType的值。

getSoTimeout() - Method in class java.net. DatagramSocket

检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。

getSoTimeout() - Method in class java.net. ServerSocket

检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。

getSoTimeout() - Method in class java.net. Socket

退款设置为SO_TIMEOUT 。 0返回意味着该选项被禁用（即无限超时）。

getSoundbank() - Method in class javax.sound.midi. SoundbankResource

获取包含这个 SoundbankResource的声音库。

getSoundbank(File) - Static method in class javax.sound.midi. MidiSystem

构造一个 Soundbank通过从指定的阅读它 File 。

getSoundbank(File) - Method in class javax.sound.midi.spi. SoundbankReader

从提供的 File获取 File对象。

getSoundbank(InputStream) - Static method in class javax.sound.midi. MidiSystem

通过从指定的流中读取来构建MIDI声音库。

getSoundbank(InputStream) - Method in class javax.sound.midi.spi. SoundbankReader

从提供的 InputStream获取 InputStream库对象。

getSoundbank(URL) - Static method in class javax.sound.midi. MidiSystem

通过从指定的URL读取它构建一个 Soundbank 。

getSoundbank(URL) - Method in class javax.sound.midi.spi. SoundbankReader

从提供的URL获取声音库对象。

getSource() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

在签署之前检索原始的ZIP文件。

getSource() - Method in class com.sun.java.accessibility.util. Translator

获取 Object的来源 Translator 。

getSource() - Method in class java.awt.image. AbstractMultiResolutionImage

该方法简单地委托给基本图像上相同的方法，它相当于： getBaseImage().getSource() 。

getSource() - Method in class java.awt.image. BufferedImage

返回产生图像像素的对象。

getSource() - Method in class java.awt. Image

获取产生图像像素的对象。

getSource() - Method in class java.awt.image. VolatileImage

这将为此VolatileImage返回ImageProducer。

getSource() - Method in class java.beans. PropertyEditorSupport

返回用作事件源的bean。

getSource() - Method in class java.util. EventObject

事件最初发生的对象。

getSource() - Method in class javafx.collections.transformation. TransformationList

在此转换列表的构造函数中指定的源列表。

getSource() - Method in class javafx.concurrent. WorkerStateEvent

事件最初发生的工人。

getSource() - Method in class javafx.scene.control. ListView.EditEvent

返回发生编辑的ListView。

getSource() - Method in class javafx.scene.control. SortEvent

getSource() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent

返回发生此事件的TreeItem。

getSource() - Method in class javafx.scene.control. TreeTableView.EditEvent

返回发生编辑的TreeTableView。

getSource() - Method in class javafx.scene.control. TreeView.EditEvent

返回发生编辑的TreeView。

getSource() - Method in class javafx.scene.effect. ImageInput

获取属性源的值。

getSource() - Method in class javafx.scene.media. AudioClip

获取用于创建此源的源URL AudioClip 。

getSource() - Method in class javafx.scene.media. Media

检索媒体的源URI。

getSource() - Method in class javafx.scene. SnapshotResult

获取调用快照的源节点或场景。

getSource() - Method in class javax.swing.event. RowSorterEvent

以 RowSorter返回事件的 RowSorter 。

getSource() - Method in interface javax.tools. Diagnostic

返回与此诊断关联的源对象。

getSource(int) - Method in class java.awt.image.renderable. ParameterBlock

将源作为一般对象返回。

getSource(Class<T>) - Method in interface java.sql. SQLXML

返回一个用于读取此SQLXML实例指定的XML值的源。

getSourceActions() - Method in class java.awt.dnd. DragGestureRecognizer

此方法返回一个表示此拖放操作将支持的操作类型的int。

getSourceActions() - Method in class java.awt.dnd. DragSourceContext

返回 DnDConstants的按位掩码，表示与此 DragSourceContext相关联的拖动操作的拖动源支持的放置操作集。

getSourceActions() - Method in class java.awt.dnd. DropTargetDragEvent

此方法返回源放置操作。

getSourceActions() - Method in class java.awt.dnd. DropTargetDropEvent

此方法返回源放置操作。

getSourceActions(JComponent) - Method in class javax.swing. TransferHandler

返回源的支持类型; 任何按位或组合COPY ， MOVE和LINK 。

getSourceAsBeanContextServices() - Method in class java.beans.beancontext. BeanContextServiceAvailableEvent

获取来源作为参考类型 BeanContextServices 。

getSourceAsBeanContextServices() - Method in class java.beans.beancontext. BeanContextServiceRevokedEvent

获取来源作为参考类型 BeanContextServices

getSourceAsDragGestureRecognizer() - Method in class java.awt.dnd. DragGestureEvent

返回源为 DragGestureRecognizer 。

getSourceBands() - Method in class javax.imageio. IIOParam

返回要使用的源频带集。

getSourceClassName() - Method in class java.util.logging. LogRecord

获取（据称）发出日志记录请求的类的名称。

getSourceDataLine(AudioFormat) - Static method in class javax.sound.sampled. AudioSystem

获取可用于以 AudioFormat对象指定的格式播放音频数据的源数据线。

getSourceDataLine(AudioFormat, Mixer.Info) - Static method in class javax.sound.sampled. AudioSystem

获得可用于在由指定的格式回放音频数据的源数据线 AudioFormat对象，通过由指定的混频器提供 Mixer.Info对象。

getSourceDropActions() - Method in class javax.swing. TransferHandler.TransferSupport

当这个 TransferSupport代表一个下降时，返回拖动源支持的放置操作。

getSourceElement() - Method in class javax.swing.event. HyperlinkEvent

返回与事件源相对应的 Element 。

getSourceElements() - Method in interface jdk.nashorn.api.tree. CompilationUnitTree

返回此编译单元中的源元素列表。

getSourceEncodings() - Method in class javax.sound.sampled.spi. FormatConversionProvider

获取由该提供商提供格式转换服务的源格式编码集合。

getSourceFile() - Method in interface com.sun.source.tree. CompilationUnitTree

返回包含此编译单元的源的文件对象。

getSourceFile() - Method in class com.sun.source.util. TaskEvent

返回此事件的源文件。

getSourceIndex(int) - Method in class javafx.collections.transformation. FilteredList

getSourceIndex(int) - Method in class javafx.collections.transformation. SortedList

getSourceIndex(int) - Method in class javafx.collections.transformation. TransformationList

将此列表元素的索引映射到直接源列表中的索引。

getSourceIndexFor(ObservableList<?>, int) - Method in class javafx.collections.transformation. TransformationList

将此列表元素的索引映射到所提供的索引 list 。

getSourceLineInfo() - Method in interface javax.sound.sampled. Mixer

获取有关此混音器支持的源线组的信息。

getSourceLineInfo(Line.Info) - Static method in class javax.sound.sampled. AudioSystem

获取有关所安装的混音器支持的特定类型的所有源行的信息。

getSourceLineInfo(Line.Info) - Method in interface javax.sound.sampled. Mixer

获取有关由混音器支持的特定类型的源行的信息。

getSourceLines() - Method in interface javax.sound.sampled. Mixer

获取当前打开这个混音器的所有源线的集合。

getSourceMaxProgressivePass() - Method in class javax.imageio. ImageReadParam

如果 getSourceNumProgressivePasses等于 Integer.MAX_VALUE ，则返回 Integer.MAX_VALUE 。

getSourceMethodName() - Method in class java.util.logging. LogRecord

获取（据称）发出日志记录请求的方法的名称。

getSourceMinProgressivePass() - Method in class javax.imageio. ImageReadParam

返回将被解码的第一个循环遍的索引。

getSourceName() - Method in interface jdk.nashorn.api.tree. CompilationUnitTree

返回此脚本编译单元的源名称。

getSourceNumProgressivePasses() - Method in class javax.imageio. ImageReadParam

返回将被解码的渐进道次数。

getSourcePositions() - Method in class com.sun.source.util. DocTrees

返回用于访问文档树节点的源位置的实用程序对象。

getSourcePositions() - Method in class com.sun.source.util. Trees

返回用于获取源位置的实用程序对象。

getSourceRegion() - Method in class javax.imageio. IIOParam

返回要使用的源区域。

getSourceRegion(ImageReadParam, int, int) - Static method in class javax.imageio. ImageReader

阅读器可以使用的实用方法来计算应该读取的源图像的区域，同时考虑到所提供的 ImageReadParam区域和子采样偏移设置的 ImageReadParam 。

getSourceRenderSize() - Method in class javax.imageio. ImageReadParam

如果它们是通过 setSourceRenderSize方法设置的，则返回源映像在解码过程中渲染的宽度和高度。

getSources() - Method in class java.awt.image. BufferedImage

返回Vector的RenderedImage对象是直接来源，而不是这些直接来源的来源，该图像数据的BufferedImage 。

getSources() - Method in class java.awt.image.renderable. ParameterBlock

返回整个Vector的Vector。

getSources() - Method in interface java.awt.image.renderable. RenderableImage

返回作为此RenderableImage的图像数据的源的RenderableImages的向量。

getSources() - Method in class java.awt.image.renderable. RenderableImageOp

返回作为此RenderableImage的图像数据的源的RenderableImages的向量。

getSources() - Method in interface java.awt.image. RenderedImage

返回RenderedImages的矢量，该矢量是此RenderedImage的图像数据的直接来源。

getSourceString() - Method in class java.text. CollationKey

返回此CollationKey表示的String。

getSourceVersion() - Method in interface javax.annotation.processing. ProcessingEnvironment

返回任何生成的 source和 class文件应符合的源版本。

getSourceVersion() - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回读取的源文件的源版本。

getSourceVersions() - Method in interface javax.tools. Tool

返回此工具支持的Java™编程语言的源代码版本。

getSourceXSubsampling() - Method in class javax.imageio. IIOParam

返回每个像素前进的源列数。

getSourceYSubsampling() - Method in class javax.imageio. IIOParam

返回每个像素的行数。

getSouthPane() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回南面。

getSpaceAbove(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取上述设置的空间。

getSpaceBelow(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取下面的空间设置。

getSpacing() - Method in class javafx.scene.control.skin. MenuBarSkin

获取属性间距的值。

getSpacing() - Method in class javafx.scene.layout. HBox

获取属性间距的值。

getSpacing() - Method in class javafx.scene.layout. VBox

获取属性间距的值。

getSpan() - Method in interface org.w3c.dom.html. HTMLTableColElement

表示组中的列数或分组影响的列数。

getSpan(int, int) - Method in class javax.swing.text. BoxView

获取特定小孩当前布局的跨度。

getSpan(GlyphView, int, int, TabExpander, float) - Method in class javax.swing.text. GlyphView.GlyphPainter

确定给定起始位置的字形的跨度（用于制表符扩展）。

getSpeak() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的说话属性定义。

getSpeakHeader() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的speak-header属性定义。

getSpeakNumeral() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的speak-numbers属性定义。

getSpeakPunctuation() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的说话标点属性定义。

getSpecificationName() - Method in class javax.management. MBeanServerDelegate

返回此产品实现的JMX规范的全称。

getSpecificationName() - Method in interface javax.management. MBeanServerDelegateMBean

返回此产品实现的JMX规范的全称。

getSpecificationTitle() - Method in class java.lang. 软件包

返回此程序包实现的规范的标题。

getSpecificationVendor() - Method in class java.lang. 软件包

返回拥有和维护实现此程序包的类的规范的组织，供应商或公司的名称。

getSpecificationVendor() - Method in class javax.management. MBeanServerDelegate

返回由本产品实现的JMX规范的供应商。

getSpecificationVendor() - Method in interface javax.management. MBeanServerDelegateMBean

返回由本产品实现的JMX规范的供应商。

getSpecificationVersion() - Method in class java.lang. 软件包

返回此程序包实现的规范的版本号。

getSpecificationVersion() - Method in class javax.management. MBeanServerDelegate

返回此产品实现的JMX规范版本。

getSpecificationVersion() - Method in interface javax.management. MBeanServerDelegateMBean

返回此产品实现的JMX规范版本。

getSpecificity() - Method in class javafx.css. Match

getSpecified() - Method in interface org.w3c.dom. Attr

True如果该属性在实例文档中被明确赋予了一个值，那么这个属性是 false 。

getSpecifiedElements() - Method in interface jdk.javadoc.doclet. DocletEnvironment

当调用该工具时返回元素 specified 。

getSpecName() - Method in interface java.lang.management. RuntimeMXBean

返回Java虚拟机规范名称。

getSpecularColor() - Method in class javafx.scene.paint. PhongMaterial

获取属性specularColor的值。

getSpecularConstant() - Method in class javafx.scene.effect. Lighting

获取属性specularConstant的值。

getSpecularExponent() - Method in class javafx.scene.effect. Light.Spot

获取属性specularExponent的值。

getSpecularExponent() - Method in class javafx.scene.effect. Lighting

获取属性specularExponent的值。

getSpecularMap() - Method in class javafx.scene.paint. PhongMaterial

获取属性specularMap的值。

getSpecularPower() - Method in class javafx.scene.paint. PhongMaterial

获取属性specularPower的值。

getSpecVendor() - Method in interface java.lang.management. RuntimeMXBean

返回Java虚拟机规范供应商。

getSpecVersion() - Method in interface java.lang.management. RuntimeMXBean

返回Java虚拟机规范版本。

getSpeechRate() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的语速率属性定义。

getSpi(String) - Method in class java.util.prefs. AbstractPreferences

在此首选项节点返回与指定键相关联的值，如果此键不存在关联，则 null ，否则此时无法确定关联。

getSpinner() - Method in class javax.swing. JSpinner.DefaultEditor

如果没有一个祖先是 null则返回此编辑器的 JSpinner祖先或 JSpinner 。

getSplashScreen() - Static method in class java.awt. SplashScreen

返回用于支持显示的系统上的Java启动启动屏幕控件的 SplashScreen对象。

getSplitPane() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

返回此实例当前包含的 JSplitPane 。

getSplitPaneBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JSplitPane的边框实例。

getSplitPaneDividerBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JSplitPane分隔符的边框实例。

getSpread() - Method in class javafx.scene.effect. DropShadow

获取属性的价值。

getSQLException() - Method in class javax.sql. ConnectionEvent

检索 SQLException此 ConnectionEvent对象。

getSQLException() - Method in class javax.sql. StatementEvent

返回驱动程序即将抛出的 SQLException

getSQLKeywords() - Method in interface java.sql. DatabaseMetaData

检索所有这些数据库的SQL关键字的逗号分隔列表，这些关键字也不是SQL：2003关键字。

getSQLState() - Method in exception java.sql. SQLException

检索此 SQLException对象的SQLState。

getSQLStateType() - Method in interface java.sql. DatabaseMetaData

指示由 SQLException.getSQLState返回的SQLSTATE是X / Open（现在称为Open Group）SQL CLI或SQL：2003。

getSQLTypeName() - Method in interface java.sql. SQLData

返回此对象表示的SQL用户定义类型的完全限定名称。

getSQLTypeName() - Method in interface java.sql. Struct

检索此 Struct对象所代表的SQL结构类型的SQL类型名称。

getSQLTypeName() - Method in class javax.sql.rowset.serial. SerialStruct

检索此 SerialStruct对象的SQL类型名称。

getSQLXML(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 java.sql.SQLXML对象的形式获取指定的 SQL XML参数的值。

getSQLXML(int) - Method in interface java.sql. ResultSet

以Java编程语言的 java.sql.SQLXML对象的形式获取此 ResultSet的当前行中指定列的值。

getSQLXML(String) - Method in interface java.sql. CallableStatement

以Java编程语言的形式获取指定的 SQL XML参数的值作为 java.sql.SQLXML对象。

getSQLXML(String) - Method in interface java.sql. ResultSet

检索此 ResultSet的当前行中指定列的值为Java编程语言中的 java.sql.SQLXML对象。

getSrc() - Method in interface org.w3c.dom.html. HTMLFrameElement

指定初始帧内容的URI。

getSrc() - Method in interface org.w3c.dom.html. HTMLIFrameElement

指定初始帧内容的URI。

getSrc() - Method in interface org.w3c.dom.html. HTMLImageElement

URI指定此图像的来源。

getSrc() - Method in interface org.w3c.dom.html. HTMLInputElement

当 type属性具有值“Image”时，此属性指定用于装饰图形提交按钮的图像的位置。

getSrc() - Method in interface org.w3c.dom.html. HTMLScriptElement

URI指定外部脚本。

getSrcName() - Method in interface org.ietf.jgss. GSSContext

返回上下文启动器的名称。

getSSLContext() - Method in class com.sun.net.httpserver. HttpsConfigurator

返回此HttpsConfigurator的SSLContext。

getSSLParameters() - Method in class javax.net.ssl. SSLEngine

返回此SSLEngine有效的SSLParameters。

getSSLParameters() - Method in class javax.net.ssl. SSLServerSocket

返回对新接受的连接有效的SSLParameters。

getSSLParameters() - Method in class javax.net.ssl. SSLSocket

返回此SSLSocket有效的SSLParameters。

getSSLSession() - Method in class com.sun.net.httpserver. HttpsExchange

获得SSLSession用于此交换。

getSSLSocketFactory() - Method in class javax.net.ssl. HttpsURLConnection

获取为安全的https URL连接创建套接字时要使用的SSL套接字工厂。

getStackTrace() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程的堆栈跟踪。

getStackTrace() - Method in class java.lang. Thread

返回表示此线程的堆栈转储的堆栈跟踪元素数组。

getStackTrace() - Method in class java.lang. Throwable

提供对由 Throwable.printStackTrace()打印的堆栈跟踪信息的编程访问。

getStamp() - Method in class java.util.concurrent.atomic. AtomicStampedReference

返回邮票的当前值。

getStandardChromaNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的色度信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardCompressionNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的压缩信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardDataNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的数据格式信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardDimensionNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的尺寸信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardDocumentNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的文档信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset) - Method in interface javax.tools. DocumentationTool

返回此工具的标准文件管理器实现的新实例。

getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset) - Method in interface javax.tools. JavaCompiler

返回此工具的标准文件管理器实现的新实例。

getStandardFormatInstance() - Static method in class javax.imageio.metadata. IIOMetadataFormatImpl

返回描述 javax.imageio.metadata包的注释中描述的标准，插件中性 javax.imageio_1.0元数据文档格式的 IIOMetadataFormat对象。

getStandardOffset() - Method in class java.time.zone. ZoneOffsetTransitionRule

在转换时获得有效的标准偏移量。

getStandardOffset(Instant) - Method in class java.time.zone. ZoneRules

获取此区域中指定时刻的标准偏移量。

getStandardTextNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的文字信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardTileNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的平铺信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardTransparencyNode() - Method in class javax.imageio.metadata. IIOMetadata

返回 IIOMetadataNode表示标准的透明度信息 javax_imageio_1.0元数据格式，或 null如果没有这样的信息是可用的。

getStandardTree() - Method in class javax.imageio.metadata. IIOMetadata

根据标准 javax_imageio_1.0元数据格式的约定，返回表示包含在该对象内的元数据的一个 IIOMetadataNode的树的实用方法。

getStandby() - Method in interface org.w3c.dom.html. HTMLObjectElement

加载对象时要呈现的消息。

getStarExportEntries() - Method in interface jdk.nashorn.api.tree. ModuleTree

返回明星导出条目的列表。

getStart() - Method in class javafx.scene.control. IndexRange

返回范围的起始位置。

getStart() - Method in class javax.swing. SpinnerDateModel

返回序列中的第一个 Date 。

getStart() - Method in interface org.w3c.dom.html. HTMLOListElement

启动序列号。

getStartAngle() - Method in class javafx.scene.chart. PieChart

获取属性startAngle的值。

getStartAngle() - Method in class javafx.scene.shape. Arc

获取属性startAngle的值。

getStartContainer() - Method in interface org.w3c.dom.ranges. Range

范围开始的节点

getStartIndex() - Method in class javax.accessibility. AccessibleHyperlink

获取此链接开始的超文本文件的索引。

getStartIndex() - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

使用此链接开始的超文本文件获取索引

getStartMargin() - Method in class javafx.scene.chart. CategoryAxis

获取属性startMargin的值。

getStartOffset() - Method in class javax.swing.text. AbstractDocument.AbstractElement

获取元素模型中的起始偏移量。

getStartOffset() - Method in class javax.swing.text. AbstractDocument.BranchElement

获取元素模型中的起始偏移量。

getStartOffset() - Method in class javax.swing.text. AbstractDocument.LeafElement

获取元素模型中的起始偏移量。

getStartOffset() - Method in class javax.swing.text. AbstractWriter

返回要输出的第一个偏移量。

getStartOffset() - Method in interface javax.swing.text. Element

从该元素开头的文档开始处获取偏移量。

getStartOffset() - Method in class javax.swing.text. GlyphView

获取该视图负责的模型部分。

getStartOffset() - Method in interface javax.swing.text. Highlighter.Highlight

获取突出显示的起始模型偏移量。

getStartOffset() - Method in class javax.swing.text.html. HTMLDocument.Iterator

返回定义标签的当前出现的范围的起始点，并具有相同的属性。

getStartOffset() - Method in class javax.swing.text. View

获取该视图负责的模型部分。

getStartOffset() - Method in interface org.w3c.dom.ranges. Range

距离起始节点内的偏移量。

getStartPage() - Method in class javafx.print. PageRange

getStartPoint() - Method in class java.awt.geom. Arc2D

返回圆弧的起始点。

getStartPoint() - Method in class java.awt. LinearGradientPaint

返回渐变轴起始点的副本。

getStartPosition() - Method in class javax.swing.text. AbstractDocument

返回表示文档开头的位置。

getStartPosition() - Method in interface javax.swing.text. Document

返回表示文档开头的位置。

getStartPosition() - Method in interface javax.tools. Diagnostic

返回与该诊断相关联的文件开头的字符偏移量，表示问题的开始。

getStartPosition() - Method in class jdk.jshell. Diag

返回与该诊断相关联的文件开头的字符偏移量，表示问题的开始。

getStartPosition() - Method in interface jdk.nashorn.api.tree. 树

在源中开始此树的字符偏移量。

getStartPosition(long) - Method in interface com.sun.source.tree. LineMap

找到一行的起始位置。

getStartPosition(CompilationUnitTree, DocCommentTree, DocTree) - Method in interface com.sun.source.util. DocSourcePositions

返回文件内注释中树的起始位置。

getStartPosition(CompilationUnitTree, Tree) - Method in interface com.sun.source.util. SourcePositions

返回文件中树的起始位置。

getStartTime() - Method in class com.sun.management. GcInfo

从Java虚拟机启动后返回此GC的开始时间（以毫秒为单位）。

getStartTime() - Method in interface java.lang.management. RuntimeMXBean

以毫秒为单位返回Java虚拟机的开始时间。

getStartTime() - Method in class javafx.scene.media. MediaPlayer

检索开始时间。

getStartTime() - Method in class javax.security.auth.kerberos. KerberosTicket

返回此票证有效期的开始时间。

getStartX() - Method in class javafx.scene.paint. LinearGradient

定义渐变轴起始点的X坐标。

getStartX() - Method in class javafx.scene.shape. CubicCurve

获取属性startX的值。

getStartX() - Method in class javafx.scene.shape. Line

获取属性startX的值。

getStartX() - Method in class javafx.scene.shape. QuadCurve

获取属性startX的值。

getStartY() - Method in class javafx.scene.paint. LinearGradient

定义渐变轴起始点的Y坐标。

getStartY() - Method in class javafx.scene.shape. CubicCurve

获取属性startY的值。

getStartY() - Method in class javafx.scene.shape. Line

获取属性startY的值。

getStartY() - Method in class javafx.scene.shape. QuadCurve

获取属性startY的值。

getState() - Method in class java.awt. Checkbox

确定此复选框是否处于“开”或“关”状态。

getState() - Method in class java.awt. CheckboxMenuItem

确定此复选框菜单项的状态是“开”还是“关”。

getState() - Method in class java.awt. Frame

获取此框架的状态（已过时）。

getState() - Method in class java.awt.im. InputMethodHighlight

返回文本范围的转换状态。

getState() - Method in class java.lang. Thread

返回此线程的状态。

getState() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回同步状态的当前值。

getState() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回同步状态的当前值。

getState() - Method in class javafx.concurrent. Service

获取属性状态的值。

getState() - Method in class javafx.concurrent. Task

获取属性状态的值。

getState() - Method in interface javafx.concurrent. Worker

指定此Worker的当前状态。

getState() - Method in class javafx.scene.input. TouchPoint

获取此触点的状态

getState() - Method in class javax.swing. JCheckBoxMenuItem

返回项目的选择状态。

getState() - Method in class javax.swing. SwingWorker

返回 SwingWorker状态绑定属性。

getStateChange() - Method in class java.awt.event. ItemEvent

返回状态更改的类型（选择或取消选择）。

getStateLabel(boolean) - Method in class javax.sound.sampled. BooleanControl

获取指定状态的标签。

getStatement() - Method in interface com.sun.source.tree. DoWhileLoopTree

返回循环的正文。

getStatement() - Method in interface com.sun.source.tree. EnhancedForLoopTree

返回循环的正文。

getStatement() - Method in interface com.sun.source.tree. ForLoopTree

返回 for语句的 for 。

getStatement() - Method in interface com.sun.source.tree. LabeledStatementTree

返回标记的语句。

getStatement() - Method in interface com.sun.source.tree. WhileLoopTree

返回循环的正文。

getStatement() - Method in interface java.sql. ResultSet

检索 Statement生成此对象 ResultSet对象。

getStatement() - Method in class javax.sql. StatementEvent

返回正在关闭或无效的 PreparedStatement

getStatement() - Method in interface jdk.nashorn.api.tree. DoWhileLoopTree

该声明包含在此do-while语句中。

getStatement() - Method in interface jdk.nashorn.api.tree. ForInLoopTree

该声明中包含的声明。

getStatement() - Method in interface jdk.nashorn.api.tree. ForLoopTree

返回此'for'语句中包含的语句。

getStatement() - Method in interface jdk.nashorn.api.tree. ForOfLoopTree

声明中包含的声明。

getStatement() - Method in interface jdk.nashorn.api.tree. LabeledStatementTree

返回被标记的语句。

getStatement() - Method in interface jdk.nashorn.api.tree. LoopTree

返回此“循环”语句中包含的语句。

getStatement() - Method in interface jdk.nashorn.api.tree. WhileLoopTree

该声明中包含的声明。

getStatement() - Method in interface jdk.nashorn.api.tree. WithTree

该声明中包含的声明。

getStatements() - Method in interface com.sun.source.tree. BlockTree

返回包含此块的语句。

getStatements() - Method in interface com.sun.source.tree. CaseTree

返回由案例标注的语句。

getStatements() - Method in interface jdk.nashorn.api.tree. BlockTree

返回此块中的语句列表。

getStatements() - Method in interface jdk.nashorn.api.tree. CaseTree

返回这个“case”的语句列表。

getStateToBind(Object, Name, Context, Hashtable<?, ?>) - Static method in class javax.naming.spi. NamingManager

检索绑定对象的状态。

getStateToBind(Object, Name, Context, Hashtable<?, ?>) - Method in interface javax.naming.spi. StateFactory

检索绑定对象的状态。

getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - Static method in class javax.naming.spi. DirectoryManager

当给定原始对象及其属性时，检索绑定对象的状态。

getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - Method in interface javax.naming.spi. DirStateFactory

在给定要转换的对象和属性的情况下，检索绑定对象的状态。

getStaticAttribute(Object) - Static method in class javax.swing.text. StyleContext

返回先前使用 registerStaticAttributeKey注册的对象。

getStaticAttributeKey(Object) - Static method in class javax.swing.text. StyleContext

返回 key注册的字符串。

getStaticMethodNames(Class<?>) - Static method in class jdk.dynalink.beans. BeansLinker

返回类的所有静态方法的一组名称。

getStatus() - Method in class java.awt.image. PixelGrabber

返回像素的状态。

getStatus() - Method in class javafx.animation. Animation

获取属性状态的值。

getStatus() - Method in class javafx.scene.media. MediaPlayer

检索当前播放器的状态。

getStatus() - Method in class javax.net.ssl. SSLEngineResult

获取此 SSLEngine操作的返回值。

getStatus() - Method in class javax.sound.midi. MidiMessage

获取MIDI消息的状态字节。

getStatus() - Method in interface javax.sql.rowset.spi. SyncResolver

检索此 SyncResolver的当前行的冲突状态，表示 RowSet对象在发生冲突时正在尝试的操作。

getStatusCode() - Method in exception javax.xml.ws.http. HTTPException

获取HTTP状态代码。

getStatusResponses() - Method in class javax.net.ssl. ExtendedSSLSession

返回一个List含DER编码OCSP应答（使用RFC 6960中定义的ASN.1类型OCSPResponse）为客户端握手期间，以验证服务器证书的状态。

getStealCount() - Method in class java.util.concurrent. ForkJoinPool

返回从另一个线程的工作队列中偷取的任务总数的估计值。

getStepSize() - Method in class javax.swing. SpinnerNumberModel

返回由 getNextValue和 getPreviousValue方法计算的值变化的大小。

getStops() - Method in class javafx.scene.paint. LinearGradient

2个或多个 Stop值的序列，指定如何沿着渐变分布颜色。

getStops() - Method in class javafx.scene.paint. RadialGradient

指定如何沿着渐变分布颜色的2个或更多个 Stop序列。

getStopTime() - Method in class javafx.scene.media. MediaPlayer

检索停止时间。

getStream(DataFlavor) - Method in interface javax.accessibility. AccessibleStreamable

返回一个 InputStream为 DataFlavor 。

getStream(String) - Method in interface java.applet. AppletContext

已过时。

返回指定键在此applet上下文中相关联的流。

getStream(URL) - Method in class javax.swing. JEditorPane

获取给定URL的流，即将由 setPage方法加载。

getStreamForBytes() - Method in interface javax.print. Doc

获取从该文档中提取字节打印数据的输入流。

getStreamForBytes() - Method in class javax.print. SimpleDoc

获取从该文档中提取字节打印数据的输入流。

getStreamKeys() - Method in interface java.applet. AppletContext

已过时。

在此applet上下文中查找流的所有键。

getStreamMetadata() - Method in class javax.imageio. ImageReader

返回一个 IIOMetadata对象，表示与整个输入源相关联的元数据（即与任何特定图像 null ），如果阅读器不支持读取元数据，则返回 IIOMetadata对象，被设置为忽略元数据，或者没有元数据可用。

getStreamMetadata(String, Set<String>) - Method in class javax.imageio. ImageReader

返回一个 IIOMetadata对象，表示与整个输入源相关联的元数据（即与任何特定图像无关）。

getStreamMetadataFormat(String) - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回一个 IIOMetadataFormat对象描述给定的流元数据格式，或 null如果没有可用的描述。

getStreamPosition() - Method in interface javax.imageio.stream. ImageInputStream

返回流的当前字节位置。

getStreamPosition() - Method in class javax.imageio.stream. ImageInputStreamImpl

getStrength() - Method in class java.security. DrbgParameters.Instantiation

以比特返回安全强度。

getStrength() - Method in class java.security. DrbgParameters.NextBytes

返回以位为单位的安全强度。

getStrength() - Method in class java.text. Collator

返回此Collator的强度属性。

getStress() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的stress属性定义。

getStrictErrorChecking() - Method in interface org.w3c.dom. Document

指定是否强制执行错误检查的属性。

getStrikethroughOffset() - Method in class java.awt.font. LineMetrics

返回贯穿线相对于基线的位置。

getStrikethroughThickness() - Method in class java.awt.font. LineMetrics

返回穿透线的厚度。

getString() - Method in interface java.sql. SQLXML

返回此SQLXML实例指定的XML值的字符串表示形式。

getString() - Method in class javafx.scene.input. Clipboard

从以前注册的剪贴板中获取纯文本字符串。

getString() - Method in class javafx.scene.input. ClipboardContent

从以前被放置的 ClipboardContent获取纯文本字符串。

getString() - Method in class javax.swing. JProgressBar

返回当前进度的 String表示。

getString() - Method in class javax.swing.text.html.parser. Entity

返回数据为 String 。

getString(int) - Method in interface java.sql. CallableStatement

以Java编程语言中的 CHAR VARCHAR指定的JDBC CHAR或 LONGVARCHAR参数的 String 。

getString(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 String该 ResultSet对象的当前行中指定列的值。

getString(int, int) - Method in interface javax.swing.text. AbstractDocument.Content

获取序列中包含的一串字符。

getString(int, int) - Method in class javax.swing.text. GapContent

检索一部分内容。

getString(int, int) - Method in class javax.swing.text. StringContent

检索一部分内容。

getString(Object) - Method in class javax.swing. UIDefaults

如果 key的值是 String返回，否则返回 null 。

getString(Object) - Static method in class javax.swing. UIManager

从默认值返回一个字符串。

getString(Object, Locale) - Method in class javax.swing. UIDefaults

如果值 key对于给定 Locale是 String返回它，否则返回 null 。

getString(Object, Locale) - Static method in class javax.swing. UIManager

从适用于给定语言环境的默认值返回一个字符串。

getString(String) - Method in interface java.sql. CallableStatement

检索JDBC的价值 CHAR ， VARCHAR ，或 LONGVARCHAR参数为 String的Java编程语言。

getString(String) - Method in interface java.sql. ResultSet

以 ResultSet对象的当前行中的指定列的值作为Java编程语言中的 String 。

getString(String) - Method in class java.util. ResourceBundle

从此资源束或其父项之一获取给定密钥的字符串。

getString(SynthContext, Object, String) - Method in class javax.swing.plaf.synth. SynthStyle

方便的方法来获取一个特定的style属性，其值是一个String。

getStringArray(String) - Method in class java.util. ResourceBundle

从此资源包或其父项之一获取给定键的字符串数组。

getStringBounds(char[], int, int, FontRenderContext) - Method in class java.awt. Font

返回指定的 FontRenderContext中指定字符数组的逻辑边界。

getStringBounds(char[], int, int, Graphics) - Method in class java.awt. FontMetrics

返回指定的 Graphics上下文中指定的字符数组的范围。

getStringBounds(String, int, int, FontRenderContext) - Method in class java.awt. Font

返回指定的 String中指定的 FontRenderContext的逻辑边界。

getStringBounds(String, int, int, Graphics) - Method in class java.awt. FontMetrics

返回指定的 Graphics上下文中指定的 String的边界。

getStringBounds(String, FontRenderContext) - Method in class java.awt. Font

返回指定的 String中指定的 FontRenderContext的逻辑边界。

getStringBounds(String, Graphics) - Method in class java.awt. FontMetrics

返回指定的 Graphics上下文中指定的 String的边界。

getStringBounds(CharacterIterator, int, int, FontRenderContext) - Method in class java.awt. Font

返回指定索引的字符的逻辑边界CharacterIterator指定FontRenderContext 。

getStringBounds(CharacterIterator, int, int, Graphics) - Method in class java.awt. FontMetrics

返回在指定的 Graphics上下文中指定的 CharacterIterator中索引的字符的边界。

getStringConverter() - Static method in class javafx.css. StyleConverter

用于引用的字符串的转换器，可以嵌入unicode字符。

getStringConverter() - Method in class javax.swing.table. TableRowSorter

返回负责将值从模型转换为字符串的对象。

getStringData() - Method in interface org.w3c.dom.ls. LSInput

要解析的字符串数据。

getStringFunctions() - Method in interface java.sql. DatabaseMetaData

检索此数据库可用的逗号分隔的字符串函数列表。

getStringNameType() - Method in interface org.ietf.jgss. GSSName

返回可从 toString方法获取的该名称的可打印表示的名称类型。

getStringPlacement(Graphics, String, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

指定进度字符串将被绘制的地方。

getStringTable() - Method in class javax.print.attribute. EnumSyntax

返回枚举值枚举类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. Chromaticity

返回类Chromaticity的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. ColorSupported

返回ColorSupported类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. Compression

返回类Compression的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. DialogTypeSelection

返回DialogTypeSelection类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. Fidelity

返回Fidelity类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. Finishings

返回类Finishings的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. JobSheets

返回JobSheets类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. JobState

返回JobState类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. JobStateReason

返回JobStateReason类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. MediaName

返回类MediaTray的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. MediaSizeName

返回类MediaSizeName的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. MediaTray

返回类MediaTray的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. MultipleDocumentHandling

返回类MultipleDocumentHandling的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. OrientationRequested

返回类OrientationRequested的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. PDLOverrideSupported

返回类PDLOverrideSupported的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. PresentationDirection

返回类PresentationDirection的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. PrinterIsAcceptingJobs

返回PrinterIsAcceptingJobs类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. PrinterState

返回PrinterState类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. PrinterStateReason

返回PrinterStateReason类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. PrintQuality

返回PrintQuality类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. ReferenceUriSchemesSupported

返回ReferenceUriSchemesSupported类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. Severity

返回类Severity的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. SheetCollate

返回SheetCollate类的字符串表。

getStringTable() - Method in class javax.print.attribute.standard. Sides

返回类Sides的字符串表。

getStringToCompare() - Method in class javax.management.monitor. StringMonitor

获取与所有观察到的MBean共有的观察属性进行比较的字符串。

getStringToCompare() - Method in interface javax.management.monitor. StringMonitorMBean

获取与所观察属性进行比较的字符串。

getStringValue() - Method in interface org.w3c.dom.css. CSSPrimitiveValue

此方法用于获取字符串值。

getStringValue() - Method in interface org.w3c.dom.xpath. XPathResult

该字符串的值为result。

getStringValue(int) - Method in class javax.swing. RowFilter.Entry

返回指定索引处的字符串值。

getStringValueAt(int, int) - Method in class javax.swing. DefaultRowSorter.ModelWrapper

在指定索引处返回值为 String 。

getStringWidth(JComponent, FontMetrics, String) - Static method in class javax.swing.plaf.basic. BasicGraphicsUtils

使用提供的组件的文本属性和反锯齿提示返回传入的字符串的宽度。

getStroke() - Method in class java.awt. Graphics2D

返回 Graphics2D上下文中的当前 Stroke 。

getStroke() - Method in class javafx.scene.canvas. GraphicsContext

获取当前行程。

getStroke() - Method in class javafx.scene.shape. Shape

获取属性笔画的值。

getStroke() - Method in class javax.swing.border. StrokeBorder

返回在边框渲染期间用于描边形状的BasicStroke对象。

getStrokeDashArray() - Method in class javafx.scene.shape. Shape

定义表示短划线段长度的数组。

getStrokeDashOffset() - Method in class javafx.scene.shape. Shape

获取属性strokeDashOffset的值。

getStrokeLineCap() - Method in class javafx.scene.shape. Shape

获取属性strokeLineCap的值。

getStrokeLineJoin() - Method in class javafx.scene.shape. Shape

获取属性strokeLineJoin的值。

getStrokeMiterLimit() - Method in class javafx.scene.shape. Shape

获取属性strokeMiterLimit的值。

getStrokes() - Method in class javafx.scene.layout. Border

BorderStrokes列表，它们一起定义了此边框的划线部分。

getStrokeType() - Method in class javafx.scene.shape. Shape

获取属性strokeType的值。

getStrokeWidth() - Method in class javafx.scene.shape. Shape

获取属性strokeWidth的值。

getStrongCaret(TextHitInfo, TextHitInfo, TextLayout) - Method in class java.awt.font. TextLayout.CaretPolicy

在指定的 TextHitInfo选择一个指定的 TextHitInfo实例作为强 TextLayout符。

getStyle() - Method in class java.awt. Font

返回这个 Font的样式。

getStyle() - Method in class java.awt.im. InputMethodHighlight

返回文本范围的渲染样式属性，或返回null。

getStyle() - Method in interface javafx.css. Styleable

与此特定 Node相关联的CSS样式的字符串表示 Node 。

getStyle() - Method in class javafx.scene.control. MenuItem

获取属性样式的值。

getStyle() - Method in class javafx.scene.control. PopupControl

与此特定 PopupControl相关联的CSS样式的字符串表示 PopupControl 。

getStyle() - Method in class javafx.scene.control. Tab

与此选项卡关联的CSS样式字符串。

getStyle() - Method in class javafx.scene.control. TableColumnBase

获取属性样式的值。

getStyle() - Method in class javafx.scene. Node

与此特定 Node相关联的CSS样式的字符串表示 Node 。

getStyle() - Method in class javafx.scene.text. Font

描述字体系列中的样式的字体指定字符串。

getStyle() - Method in class javafx.stage. Stage

检索此阶段的样式属性。

getStyle() - Method in class javax.swing.plaf.synth. SynthContext

返回与该区域相关联的样式。

getStyle() - Method in interface org.w3c.dom.css. CSSFontFaceRule

这个规则的声明块。

getStyle() - Method in interface org.w3c.dom.css. CSSPageRule

这个规则的声明块。

getStyle() - Method in interface org.w3c.dom.css. CSSStyleRule

该规则集的声明块。

getStyle() - Method in interface org.w3c.dom.css. ElementCSSInlineStyle

风格属性。

getStyle(String) - Method in class javax.swing. JTextPane

获取以前添加的命名非 null样式。

getStyle(String) - Method in class javax.swing.text. DefaultStyledDocument

获取先前添加的命名样式。

getStyle(String) - Method in class javax.swing.text. StyleContext

获取先前添加到文档的命名样式

getStyle(String) - Method in interface javax.swing.text. StyledDocument

获取先前添加的命名样式。

getStyle(JComponent, Region) - Static method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

获取与给定组件和区域相关联的样式。

getStyle(JComponent, Region) - Static method in class javax.swing.plaf.synth. SynthLookAndFeel

获取指定组件的指定区域的SynthStyle。

getStyle(JComponent, Region) - Method in class javax.swing.plaf.synth. SynthStyleFactory

返回指定组件的样式。

getStyleableNode() - Method in interface javafx.css. Styleable

返回表示此Styleable对象的Node。

getStyleableNode() - Method in class javafx.scene.control. MenuItem

返回表示此Styleable对象的Node。

getStyleableNode() - Method in class javafx.scene.control. PopupControl

返回表示此Styleable对象的Node。

getStyleableNode() - Method in class javafx.scene.control. TableColumn

返回表示此Styleable对象的Node。

getStyleableNode() - Method in class javafx.scene.control. TreeTableColumn

返回表示此Styleable对象的Node。

getStyleableParent() - Method in interface javafx.css. Styleable

返回此Styleable的父项，如果没有父项则返回null。

getStyleableParent() - Method in class javafx.scene.control. MenuItem

返回此Styleable的父项，如果没有父项则返回null。

getStyleableParent() - Method in class javafx.scene.control. PopupControl.CSSBridge

该方法应被视为最终方法，不应被CSSBridge的任何子类覆盖。

getStyleableParent() - Method in class javafx.scene.control. PopupControl

返回此Styleable的父项，如果没有父项则返回null。

getStyleableParent() - Method in class javafx.scene.control. Tab

返回此Styleable的父项，如果没有父项则返回null。

getStyleableParent() - Method in class javafx.scene.control. TableColumn

返回此Styleable的父项，如果没有父项则返回null。

getStyleableParent() - Method in class javafx.scene.control. Tooltip

getStyleableParent() - Method in class javafx.scene.control. TreeTableColumn

返回此Styleable的父项，如果没有父项则返回null。

getStyleableParent() - Method in class javafx.scene. Node

返回此Styleable的父项，如果没有父项则返回null。

getStyleableProperty(S) - Method in class javafx.css. CssMetaData

返回相应的给定节点的StyleableProperty 。

getStyleClass() - Method in interface javafx.css. Styleable

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

getStyleClass() - Method in class javafx.scene.control. MenuItem

*公开API * *

getStyleClass() - Method in class javafx.scene.control. PopupControl

返回构成此PopupControl的styleClass的String标识符列表。

getStyleClass() - Method in class javafx.scene.control. Tab

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

getStyleClass() - Method in class javafx.scene.control. TableColumnBase

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

getStyleClass() - Method in class javafx.scene. Node

getStyleClasses() - Method in class javafx.css. SimpleSelector

getStyleClassName() - Method in class javafx.css. StyleClass

getStyleClassSet() - Method in class javafx.css. SimpleSelector

getStyledDocument() - Method in class javax.swing. JTextPane

获取与编辑器相关联的模型。

getStyledDocument(JEditorPane) - Method in class javax.swing.text. StyledEditorKit.StyledTextAction

获取与编辑器窗格关联的文档。

getStyledEditorKit() - Method in class javax.swing. JTextPane

获得编辑工具包。

getStyledEditorKit(JEditorPane) - Method in class javax.swing.text. StyledEditorKit.StyledTextAction

获取与编辑器窗格相关联的编辑工具包。

getStyleFactory() - Static method in class javax.swing.plaf.synth. SynthLookAndFeel

返回当前的SynthStyleFactory。

getStyleNames() - Method in class javax.swing.text. DefaultStyledDocument

获取样式名称列表。

getStyleNames() - Method in class javax.swing.text. StyleContext

获取定义的样式的名称。

getStyleOrigin() - Method in class javafx.css. StyleableBooleanProperty

告诉物业的价值的起源。

getStyleOrigin() - Method in class javafx.css. StyleableDoubleProperty

告诉物业的价值的起源。

getStyleOrigin() - Method in class javafx.css. StyleableFloatProperty

告诉物业的价值的起源。

getStyleOrigin() - Method in class javafx.css. StyleableIntegerProperty

告诉物业的价值的起源。

getStyleOrigin() - Method in class javafx.css. StyleableLongProperty

告诉物业的价值的起源。

getStyleOrigin() - Method in class javafx.css. StyleableObjectProperty

告诉物业的价值的起源。

getStyleOrigin() - Method in interface javafx.css. StyleableProperty

告诉物业的价值的起源。

getStyleOrigin() - Method in class javafx.css. StyleableStringProperty

告诉物业的价值的起源。

getStylesheet() - Method in class javafx.css. Rule

getStylesheet() - Method in class javax.xml.crypto.dsig.spec. XSLTTransformParameterSpec

返回样式表。

getStyleSheet() - Method in class javax.swing.text.html. BlockView

方便的方法来获取StyleSheet。

getStyleSheet() - Method in class javax.swing.text.html. HTMLDocument

使用HTML文档本身指定的文档特定显示规则（CSS）获取 StyleSheet 。

getStyleSheet() - Method in class javax.swing.text.html. HTMLEditorKit

获取当前用于呈现HTML元素的一组样式。

getStyleSheet() - Method in class javax.swing.text.html. ImageView

方便的方法来获取StyleSheet。

getStyleSheet() - Method in class javax.swing.text.html. InlineView

方便的方法来获取StyleSheet。

getStyleSheet() - Method in class javax.swing.text.html. ParagraphView

方便的方法来获取StyleSheet。

getStyleSheet() - Method in interface org.w3c.dom.css. CSSImportRule

此规则引用的样式表，如果已加载。

getStylesheets() - Method in class javafx.scene. Parent

获取链接到此父项内容使用的样式表的字符串URL的可观察列表。

getStylesheets() - Method in class javafx.scene. Scene

获取链接到与场景内容一起使用的样式表的字符串URL的可观察列表。

getStyleSheets() - Method in class javax.swing.text.html. StyleSheet

返回链接的样式表的数组。

getStyleSheets() - Method in interface org.w3c.dom.stylesheets. DocumentStyle

包含明确链接到或嵌入到文档中的所有样式表的列表。

getSubElements() - Method in class javax.swing. JMenu

返回一个 MenuElement的数组， MenuElement包含此菜单组件的子菜单。

getSubElements() - Method in class javax.swing. JMenuBar

实现为 MenuElement - 返回此菜单栏中的菜单。

getSubElements() - Method in class javax.swing. JMenuItem

此方法返回一个包含此菜单组件的子菜单组件的数组。

getSubElements() - Method in class javax.swing. JPopupMenu

返回一个 MenuElement的数组，包含此菜单组件的子菜单。

getSubElements() - Method in interface javax.swing. MenuElement

该方法应该返回一个包含接收菜单元素的子元素的数组。

getSubimage(int, int, int, int) - Method in class java.awt.image. BufferedImage

返回由指定的矩形区域定义的子图像。

getSubInterfaces() - Method in class java.net. NetworkInterface

获取连接到此网络接口的所有子接口（也称为虚拟接口）的枚举。

getSubject() - Method in class java.security.cert. X509CertSelector

返回主题标准为 X500Principal 。

getSubject() - Method in class javax.security.auth.login. LoginContext

返回认证的主题。

getSubject() - Method in class javax.security.auth. SubjectDomainCombiner

获取 Subject与此 SubjectDomainCombiner相关联。

getSubject(AccessControlContext) - Static method in class javax.security.auth. Subject

得到 Subject与所提供的相关 AccessControlContext 。

getSubjectAlternativeNames() - Method in class java.security.cert. X509Certificate

从 SubjectAltName扩展名（OID = 2.5.29.17）获取不可变的主题备用名称集合。

getSubjectAlternativeNames() - Method in class java.security.cert. X509CertSelector

返回subjectAlternativeNames条件的副本。

getSubjectAsBytes() - Method in class java.security.cert. X509CertSelector

以字节数组形式返回主题标准。

getSubjectAsString() - Method in class java.security.cert. X509CertSelector

诋毁 ，使用 X509CertSelector.getSubject()或者 X509CertSelector.getSubjectAsBytes()代替。

getSubjectDN() - Method in class java.security.cert. X509Certificate

诋毁 ，取而代之的是 X509Certificate.getSubjectX500Principal() 。

getSubjectDN() - Method in class javax.security.cert. X509Certificate

已过时。

从证书中获取 subject （主题可分辨名称）值。

getSubjectKeyIdentifier() - Method in class java.security.cert. X509CertSelector

返回subjectKeyIdentifier标准。

getSubjectPublicKey() - Method in class java.security.cert. X509CertSelector

返回subjectPublicKey标准。

getSubjectPublicKeyAlgID() - Method in class java.security.cert. X509CertSelector

返回subjectPublicKeyAlgID条件。

getSubjectUniqueID() - Method in class java.security.cert. X509Certificate

从证书获取 subjectUniqueID值。

getSubjectX500Principal() - Method in class java.security.cert. X509Certificate

从证书中返回主题（主体可分辨名称）值 X500Principal 。

getSubprimeQLength() - Method in class java.security.spec. DSAGenParameterSpec

以位为单位返回要生成的DSA域参数的子素数Q的期望长度。

getSubProperties() - Method in class javafx.css. CssMetaData

子属性是指该属性的组成属性（如果有）。

getSubprotocol() - Method in interface jdk.incubator.http. WebSocket

返回一个 subprotocol已被选为这个 WebSocket 。

getSubsamplingXOffset() - Method in class javax.imageio. IIOParam

返回子采样网格的水平偏移。

getSubsamplingYOffset() - Method in class javax.imageio. IIOParam

返回子采样网格的垂直偏移。

getSubscribers() - Method in class java.util.concurrent. SubmissionPublisher

返回用于监视和跟踪目的的当前用户列表，而不是在订阅者上调用Flow.Subscriber方法。

getSubString(long, int) - Method in interface java.sql. Clob

在 Clob对象指定的 CLOB值中检索指定子字符串的副本。

getSubString(long, int) - Method in class javax.sql.rowset.serial. SerialClob

返回此 SerialClob对象中包含的子字符串的副本，从给定位置开始，并继续指定的数字或字符。

getSubTextFont() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回子文本字体。

getSubTextFont() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的子文本字体。

getSubTextFont() - Method in class javax.swing.plaf.metal. MetalTheme

返回子文本字体。

getSubType() - Method in class java.awt.datatransfer. DataFlavor

返回此 DataFlavor的子MIME类型。

getSubType() - Method in class javax.activation. MimeType

检索此对象的子类型。

getSuffix(int) - Method in class javax.naming. CompositeName

创建一个组合名称，其组件由此组合名称中的组件的后缀组成。

getSuffix(int) - Method in class javax.naming. CompoundName

创建一个复合名称，其组成部分由此化合物名称中的组件的后缀组成。

getSuffix(int) - Method in class javax.naming.ldap. LdapName

创建一个名称，其组件由此LDAP名称中的组件的后缀组成。

getSuffix(int) - Method in interface javax.naming. Name

创建一个名称，其组件由此名称中的组件的后缀组成。

getSum() - Method in class java.util. DoubleSummaryStatistics

返回记录的值的总和，如果没有记录值，则返回零。

getSum() - Method in class java.util. IntSummaryStatistics

返回记录的值的总和，如果没有记录值，则返回零。

getSum() - Method in class java.util. LongSummaryStatistics

返回记录的值的总和，如果没有记录值，则返回零。

getSummary() - Method in interface org.w3c.dom.html. HTMLTableElement

关于表的目的或结构的描述。

getSuperBound() - Method in interface javax.lang.model.type. WildcardType

返回此通配符的下限。

getSuperclass() - Method in class java.lang. Class

返回表示由 Class表示的实体的直接超类（类，接口，原始类型或空白）的 Class 。

getSuperclass() - Method in interface javax.lang.model.element. TypeElement

返回此类型元素的直接超类。

getSuperTables(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索此数据库中特定模式中定义的表层次结构的描述。

getSuperType() - Method in class javafx.event. EventType

获取此类型的超级类型。

getSuperTypes(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索此数据库中特定模式中定义的用户定义类型（UDT）层次结构的描述。

getSupportedAnnotationTypes() - Method in class javax.annotation.processing. AbstractProcessor

如果使用SupportedAnnotationTypes注释处理器类，则返回与注释具有相同字符串集的不可修改集。

getSupportedAnnotationTypes() - Method in interface javax.annotation.processing. Processor

返回此处理器支持的注释类型的名称。

getSupportedAttributeCategories() - Method in interface javax.print. PrintService

确定在为此打印服务设置作业时客户端可以指定的打印属性类别。

getSupportedAttributeValues(Class<? extends Attribute>, DocFlavor, AttributeSet) - Method in interface javax.print. PrintService

确定为此打印服务设置作业时客户端可以在给定类别中指定的打印属性值。

getSupportedCipherSuites() - Method in class javax.net.ssl. SSLEngine

返回可以在此引擎上使用的密码套件的名称。

getSupportedCipherSuites() - Method in class javax.net.ssl. SSLServerSocket

返回可以在SSL连接上使用的密码套件的名称。

getSupportedCipherSuites() - Method in class javax.net.ssl. SSLServerSocketFactory

返回可以在此工厂创建的SSL连接上启用的密码套件的名称。

getSupportedCipherSuites() - Method in class javax.net.ssl. SSLSocket

返回可以在此连接上使用的密码套件的名称。

getSupportedCipherSuites() - Method in class javax.net.ssl. SSLSocketFactory

返回可以在SSL连接上使用的密码套件的名称。

getSupportedCollations() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的归类设置的不可修改的集合。

getSupportedDocFlavors() - Method in interface javax.print. PrintService

确定在为此 PrintService设置作业时，客户端可以指定的打印数据格式。

getSupportedDocFlavors() - Method in class javax.print. StreamPrintServiceFactory

查询工厂的文件风味，可以从本厂获得的打印机接受。

getSupportedExtensions() - Method in class java.security.cert. PKIXCertPathChecker

返回此 PKIXCertPathChecker支持（即识别，能够处理）的X.509证书扩展的不可变 Set ，如果不支持扩展名，则 null 。

getSupportedOptions() - Method in class javax.annotation.processing. AbstractProcessor

如果使用SupportedOptions注释处理器类，则返回与注释具有相同字符串集的不可修改集。

getSupportedOptions() - Method in interface javax.annotation.processing. Processor

返回此处理器识别的选项。

getSupportedOptions() - Method in interface jdk.javadoc.doclet. Doclet

返回所有支持的选项。

getSupportedOptions() - Method in class jdk.javadoc.doclet. StandardDoclet

getSupportedPageOrientations() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的方向的不可修改的一组。

getSupportedPapers() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的纸张尺寸不可修改的集合。

getSupportedPaperSources() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的纸张来源（即输入纸盒或纸盘）的不可修改的一组。

getSupportedPrintColors() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的颜色设置的不可修改的集合。

getSupportedPrintQuality() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的质量设置的一组不可修改的集合。

getSupportedPrintResolutions() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的打印分辨率的一组不可修改的集合。

getSupportedPrintSides() - Method in class javafx.print. PrinterAttributes

返回此打印机支持的双面设置的不可修改的一组。

getSupportedProtocols() - Method in class javax.net.ssl. SSLEngine

返回可用于此 SSLEngine使用的协议的名称。

getSupportedProtocols() - Method in class javax.net.ssl. SSLServerSocket

返回可以启用的协议的名称。

getSupportedProtocols() - Method in class javax.net.ssl. SSLSocket

返回可以在SSL连接上使用的协议的名称。

getSupportedSourceVersion() - Method in class javax.annotation.processing. AbstractProcessor

如果处理器类注释为SupportedSourceVersion ，则返回注释中的源版本。

getSupportedSourceVersion() - Method in interface javax.annotation.processing. Processor

返回此注释处理器支持的最新的源版本。

getSupportedSourceVersion() - Method in interface jdk.javadoc.doclet. Doclet

返回此doclet支持的Java编程语言的版本。

getSupportedSourceVersion() - Method in class jdk.javadoc.doclet. StandardDoclet

getSupportedSSLParameters() - Method in class javax.net.ssl. SSLContext

返回SSLParameters的副本，表示支持的SSL上下文设置。

getSupportsAbsolutePositioning() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

指示用户是否可以用鼠标手势（通常是鼠标中键）绝对定位拇指。

getSupportsAbsolutePositioning() - Method in class javax.swing.plaf.synth. SynthScrollBarUI

指示用户是否可以用鼠标手势（通常是鼠标中键）绝对定位拇指。

getSupportsWindowDecorations() - Method in class javax.swing. LookAndFeel

返回 true如果 LookAndFeel返回的 RootPaneUI实例支持在 JRootPane提供 Window装饰。

getSupportsWindowDecorations() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

退货true ; 金属可以提供Window装饰。

getSuppressed() - Method in class java.lang. Throwable

通过 try -with-resources语句，返回一个包含所有被抑制的异常的数组，以便传递这个异常。

getSurfaceScale() - Method in class javafx.scene.effect. Lighting

获取属性surfaceScale的值。

getSurplusQueuedTaskCount() - Static method in class java.util.concurrent. ForkJoinTask

返回当前工作线程保留的本地排队任务数量多于可能窃取它们的其他工作线程的估计值，如果此线程未在ForkJoinPool中运行，则返回零。

getSurrendersFocusOnKeystroke() - Method in class javax.swing. JTable

如果编辑器在击键导致编辑器被激活时得到焦点，则返回true

getSW() - Method in class javax.smartcardio. ResponseAPDU

将状态字节SW1和SW2的值作为单个状态字SW返回。

getSW1() - Method in class javax.smartcardio. ResponseAPDU

将状态字节SW1的值作为0到255之间的值返回。

getSW2() - Method in class javax.smartcardio. ResponseAPDU

将状态字节SW2的值作为0和255之间的值返回。

getSwitchPoints() - Method in class jdk.dynalink.linker. GuardedInvocation

返回可用于使该调用句柄的链接无效的切换点。

getSymbol() - Method in class java.util. Currency

获取默认的 DISPLAY区域设置的货币符号。

getSymbol(String, Locale) - Method in class java.util.spi. CurrencyNameProvider

获取指定区域设置的给定货币代码的符号。

getSymbol(Locale) - Method in class java.util. Currency

获取指定区域设置的货币符号。

getSyncAllWidths() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

如果孩子的宽度应该同步，则返回。

getSyncFactory() - Static method in class javax.sql.rowset.spi. SyncFactory

返回 SyncFactory单身人士。

getSyncProvider() - Method in interface javax.sql.rowset. CachedRowSet

检索 CachedRowSet对象的 SyncProvider实现。

getSyncResolver() - Method in exception javax.sql.rowset.spi. SyncProviderException

检索 SyncResolver已设置此对象 SyncProviderException对象，如果没有设置，默认的实例 SyncResolver执行包含在参考实现。

getSynthesizer() - Static method in class javax.sound.midi. MidiSystem

获取默认合成器。

getSystem() - Static method in class java.rmi.activation. ActivationGroup

返回VM的激活系统。

getSystem() - Method in class java.rmi.activation. ActivationGroupID

返回组的激活系统。

getSystemClassLoader() - Static method in class java.lang. ClassLoader

返回用于委派的系统类加载器。

getSystemClipboard() - Method in class java.awt. Toolkit

获取与本地平台提供的剪贴板工具接口的系统剪贴板的单例实例。

getSystemClipboard() - Static method in class javafx.scene.input. Clipboard

获取当前系统剪贴板，通过该剪贴板可以存储和检索数据。

getSystemCpuLoad() - Method in interface com.sun.management. OperatingSystemMXBean

返回整个系统的“最近的cpu用法”。

getSystemCustomCursor(String) - Static method in class java.awt. Cursor

返回与指定名称匹配的特定于系统的自定义游标对象。

getSystemDisplayName(File) - Method in class javax.swing.filechooser. FileSystemView

在系统文件浏览器中显示的文件，目录或文件夹的名称。

getSystemDocumentationTool() - Static method in class javax.tools. ToolProvider

返回此平台提供的Java编程语言文档工具。

getSystemEventQueue() - Method in class java.awt. Toolkit

获取应用程序或小程序的EventQueue实例。

getSystemEventQueueImpl() - Method in class java.awt. Toolkit

获取应用程序或小程序的 EventQueue实例，而无需检查访问。

getSystemFunctions() - Method in interface java.sql. DatabaseMetaData

检索此数据库可用的系统函数的逗号分隔列表。

getSystemIcon(File) - Method in class javax.swing.filechooser. FileSystemView

文件，目录或文件夹的图标，将显示在系统文件浏览器中。

getSystemId() - Method in interface javax.xml.stream.events. EntityDeclaration

实体的系统标识符。

getSystemId() - Method in interface javax.xml.stream.events. NotationDeclaration

符号的系统标识符，如果没有给定，则为null。

getSystemId() - Method in interface javax.xml.stream.events. StartDocument

返回XML数据的系统ID

getSystemId() - Method in interface javax.xml.stream. Location

返回XML的系统ID

getSystemId() - Method in class javax.xml.transform.dom. DOMResult

获取系统标识符。

getSystemId() - Method in class javax.xml.transform.dom. DOMSource

获取基址（URL或系统ID），从中解析URL。

getSystemId() - Method in interface javax.xml.transform. Result

获取使用setSystemId设置的系统标识符。

getSystemId() - Method in class javax.xml.transform.sax. SAXResult

获取使用setSystemId设置的系统标识符。

getSystemId() - Method in class javax.xml.transform.sax. SAXSource

获取URI将被解析的基本ID（URI或系统ID）。

getSystemId() - Method in interface javax.xml.transform.sax. TemplatesHandler

获取从其中相对URL被解析的基本ID（URI或系统ID）。

getSystemId() - Method in interface javax.xml.transform.sax. TransformerHandler

获取从其中相对URL被解析的基本ID（URI或系统ID）。

getSystemId() - Method in interface javax.xml.transform. Source

获取使用setSystemId设置的系统标识符。

getSystemId() - Method in interface javax.xml.transform. SourceLocator

返回当前文档事件的系统标识符。

getSystemId() - Method in class javax.xml.transform.stax. StAXResult

返回的系统标识符始终为 null 。

getSystemId() - Method in class javax.xml.transform.stax. StAXSource

获取此 StAXSource使用的系统标识符。

getSystemId() - Method in class javax.xml.transform.stream. StreamResult

获取使用setSystemId设置的系统标识符。

getSystemId() - Method in class javax.xml.transform.stream. StreamSource

获取使用setSystemId设置的系统标识符。

getSystemId() - Method in interface org.w3c.dom. DocumentType

外部子集的系统标识符。

getSystemId() - Method in interface org.w3c.dom. Entity

如果指定了与实体相关的系统标识符，否则为 null 。

getSystemId() - Method in interface org.w3c.dom.ls. LSInput

系统标识符，一个URI引用[ IETF RFC 2396 ]，用于此输入源。

getSystemId() - Method in interface org.w3c.dom.ls. LSOutput

该输出目的地的系统标识符，URI引用[ IETF RFC 2396 ]。

getSystemId() - Method in interface org.w3c.dom. Notation

该符号的系统标识符。

getSystemId() - Method in class org.xml.sax.helpers. LocatorImpl

返回保存的系统标识符。

getSystemId() - Method in class org.xml.sax. InputSource

获取此输入源的系统标识符。

getSystemId() - Method in interface org.xml.sax. Locator

返回当前文档事件的系统标识符。

getSystemId() - Method in exception org.xml.sax. SAXParseException

获取发生异常的实体的系统标识符。

getSystemJavaCompiler() - Static method in class javax.tools. ToolProvider

返回此平台提供的Java编程语言编译器。

getSystemLoadAverage() - Method in interface java.lang.management. OperatingSystemMXBean

返回最后一分钟的系统负载平均值。

getSystemLookAndFeelClassName() - Static method in class javax.swing. UIManager

返回实现本机系统外观的 LookAndFeel类的名称，如果有的话，否则为默认的跨平台 LookAndFeel类的名称。

getSystemProperties() - Method in class com.sun.tools.attach. VirtualMachine

返回目标虚拟机中的当前系统属性。

getSystemProperties() - Method in interface java.lang.management. RuntimeMXBean

返回所有系统属性的名称和值的映射。

getSystemResource(String) - Static method in class java.lang. ClassLoader

从用于加载类的搜索路径中查找指定名称的资源。

getSystemResourceAsStream(String) - Static method in class java.lang. ClassLoader

打开阅读，从用于加载类的搜索路径中指定名称的资源。

getSystemResources(String) - Static method in class java.lang. ClassLoader

从用于加载类的搜索路径中查找指定名称的所有资源。

getSystemScope() - Static method in class java.security. IdentityScope

已过时。

返回系统的身份范围。

getSystemSelection() - Method in class java.awt. Toolkit

获取系统选择的单例实例为 Clipboard对象。

getSystemTextColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的系统文本颜色。

getSystemTextColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回系统文本颜色。

getSystemTextFont() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回系统文本字体。

getSystemTextFont() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的系统文本字体。

getSystemTextFont() - Method in class javax.swing.plaf.metal. MetalTheme

返回系统文本字体。

getSystemToolClassLoader() - Static method in class javax.tools. ToolProvider

已过时。
此方法在将来的Java SE版本中可能会被删除。 使用system tool provider或service loader机制来定位系统工具以及用户安装的工具。

getSystemTray() - Static method in class java.awt. SystemTray

获取表示桌面托盘区域的 SystemTray实例。

getSystemTypeDescription(File) - Method in class javax.swing.filechooser. FileSystemView

键入在系统文件浏览器中显示的文件，目录或文件夹的描述。

getTab(int) - Method in class javax.swing.text. TabSet

返回TabStop，索引号为 index 。

getTabAfter(float) - Method in class javax.swing.text. TabSet

在 location后返回Tab实例。

getTabAreaInsets(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回标签区域插入。

getTabBase() - Method in class javax.swing.text. ParagraphView

返回从中计算制表符的位置。

getTabbedSpan(float, TabExpander) - Method in class javax.swing.text. GlyphView

确定使用给定的选项卡扩展实现时所需的跨度。

getTabbedSpan(float, TabExpander) - Method in interface javax.swing.text. TabableView

确定使用给定的选项卡扩展实现时所需的跨度。

getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean) - Static method in class javax.swing.text. Utilities

确定最佳表示视图坐标系中给定跨度的给定文本的相对偏移量。

getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int) - Static method in class javax.swing.text. Utilities

已过时。
代之以Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)

getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int, boolean) - Static method in class javax.swing.text. Utilities

已过时。
替换为Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)

getTabbedTextWidth(Segment, FontMetrics, float, TabExpander, int) - Static method in class javax.swing.text. Utilities

确定考虑到选项卡的给定段文本的宽度。

getTabbedTextWidth(Segment, FontMetrics, int, TabExpander, int) - Static method in class javax.swing.text. Utilities

已过时。
代之以Utilities.getTabbedTextWidth(Segment, FontMetrics, float, TabExpander, int)

getTabBounds(int, Rectangle) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回JTabbedPane组件坐标空间中指定选项卡的边界。

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回指定选项卡索引的边界。

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 getTabBounds方法。

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf. TabbedPaneUI

返回Tab边界的矩形。

getTabClosingPolicy() - Method in class javafx.scene.control. TabPane

选项卡的关闭策略。

getTabComponentAt(int) - Method in class javax.swing. JTabbedPane

返回标签组件 index 。

getTabCount() - Method in class javax.swing. JTabbedPane

返回此 tabbedpane的选项卡数。

getTabCount() - Method in class javax.swing.text. TabSet

返回接收器包含的Tab实例数。

getTabExpander() - Method in class javax.swing.text. GlyphView

如果此视图中存在选项卡，则获取TabExpander。

getTabIndex() - Method in interface org.w3c.dom.html. HTMLAnchorElement

表示元素在分页顺序中的位置的索引。

getTabIndex() - Method in interface org.w3c.dom.html. HTMLAreaElement

表示元素在分页顺序中的位置的索引。

getTabIndex() - Method in interface org.w3c.dom.html. HTMLButtonElement

表示元素在分页顺序中的位置的索引。

getTabIndex() - Method in interface org.w3c.dom.html. HTMLInputElement

表示元素在分页顺序中的位置的索引。

getTabIndex() - Method in interface org.w3c.dom.html. HTMLObjectElement

表示元素在分页顺序中的位置的索引。

getTabIndex() - Method in interface org.w3c.dom.html. HTMLSelectElement

表示元素在分页顺序中的位置的索引。

getTabIndex() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

表示元素在分页顺序中的位置的索引。

getTabIndex(TabStop) - Method in class javax.swing.text. TabSet

返回接受tab的索引 tab ，或-1，如果 tab不包含在接收机中。

getTabIndexAfter(float) - Method in class javax.swing.text. TabSet

返回 location后使用的Tab的索引。

getTabInsets(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回标签插入。

getTabInsets(int, int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

返回标签插入。

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回标签移位x。

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

被覆盖为Java L＆F不做任何事情。

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

返回标签移位x。

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回标签标签shift y。

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

被覆盖为Java L＆F不做任何事情。

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

返回标签标签shift y。

getTabLayoutPolicy() - Method in class javax.swing. JTabbedPane

当所有选项卡不适合单个运行时，返回标签页窗口用于布局选项卡的策略。

getTable() - Method in class java.awt.image. ByteLookupTable

通过引用返回查找表数据。

getTable() - Method in class java.awt.image. LookupOp

返回 LookupTable 。

getTable() - Method in class java.awt.image. ShortLookupTable

通过引用返回查找表数据。

getTable() - Method in class javafx.scene.control. TableView.ResizeFeatures

返回执行resize操作的TableView。

getTable() - Method in class javafx.scene.control. TreeTableView.ResizeFeatures

返回在其上进行调整大小操作的TreeTableView。

getTable() - Method in class javax.imageio.plugins.jpeg. JPEGQTable

以自然（不是之字形）顺序将当前量化表的副本作为 int的数组返回。

getTable() - Method in class javax.swing.table. JTableHeader

返回与此标题关联的表。

getTableCellEditorComponent(JTable, Object, boolean, int, int) - Method in class javax.swing. DefaultCellEditor

实现 TableCellEditor接口。

getTableCellEditorComponent(JTable, Object, boolean, int, int) - Method in interface javax.swing.table. TableCellEditor

为编辑器设置初始 value 。

getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - Method in class javax.swing.table. DefaultTableCellRenderer

返回默认的表格单元格渲染器。

getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - Method in interface javax.swing.table. TableCellRenderer

返回用于绘制单元格的组件。

getTableColumn() - Method in class javafx.scene.control.skin. TableCellSkinBase

获取属性tableColumn的值。

getTableColumn() - Method in class javafx.scene.control.skin. TableColumnHeader

获取属性tableColumn的值。

getTableColumn() - Method in class javafx.scene.control. TableCell

获取属性tableColumn的值。

getTableColumn() - Method in class javafx.scene.control. TableColumn.CellDataFeatures

返回传递给构造函数的TableColumn 。

getTableColumn() - Method in class javafx.scene.control. TableColumn.CellEditEvent

返回发生此事件的TableColumn。

getTableColumn() - Method in class javafx.scene.control. TablePosition

Table Table在TableView中表示的TableColumn。

getTableColumn() - Method in class javafx.scene.control. TablePositionBase

Table Table在TableView中表示的TableColumn。

getTableColumn() - Method in class javafx.scene.control. TreeTableCell

获取属性tableColumn的值。

getTableColumn() - Method in class javafx.scene.control. TreeTableColumn.CellEditEvent

返回发生此事件的TreeTableColumn。

getTableColumn() - Method in class javafx.scene.control. TreeTablePosition

getTableColumn(TableCell<T, ?>) - Method in class javafx.scene.control.skin. TableRowSkin

返回给定单元格实例的TableColumnBase实例。

getTableColumn(TreeTableCell) - Method in class javafx.scene.control.skin. TreeTableRowSkin

返回给定单元格实例的TableColumnBase实例。

getTableColumn(R) - Method in class javafx.scene.control.skin. TableRowSkinBase

返回给定单元格实例的TableColumnBase实例。

getTableHeader() - Method in class javax.swing. JTable

返回此 tableHeader使用的 JTable 。

getTableLayout() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的table-layout属性定义。

getTableModel() - Method in class javafx.scene.control. TableView.TableViewSelectionModel

getTableView（）。getItems（）的方便方法。

getTableModelListeners() - Method in class javax.swing.table. AbstractTableModel

返回在此模型上注册的所有表模型侦听器的数组。

getTableName() - Method in interface javax.sql.rowset. CachedRowSet

返回用于创建此 CachedRowSet对象的对象（表）的标识符。

getTableName(int) - Method in interface java.sql. ResultSetMetaData

获取指定列的表名称。

getTableName(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索从中导出指定列中的值的表的名称。

getTablePosition() - Method in class javafx.scene.control. TableColumn.CellEditEvent

返回此事件发生的位置。

getTablePrivileges(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索目录中可用的每个表的访问权限的描述。

getTableRow() - Method in class javafx.scene.control. TableCell

获取属性tableRow的值。

getTables(String, String, String, String[]) - Method in interface java.sql. DatabaseMetaData

检索给定目录中可用表的描述。

getTableTypes() - Method in interface java.sql. DatabaseMetaData

检索此数据库中可用的表类型。

getTableView() - Method in class javafx.scene.control. TableCell

获取属性tableView的值。

getTableView() - Method in class javafx.scene.control. TableColumn.CellDataFeatures

返回传递给构造函数的TableView 。

getTableView() - Method in class javafx.scene.control. TableColumn.CellEditEvent

返回发生此事件的TableView。

getTableView() - Method in class javafx.scene.control. TableColumn

获取属性tableView的值。

getTableView() - Method in class javafx.scene.control. TablePosition

TableView这个TablePosition是相关的。

getTableView() - Method in class javafx.scene.control. TableRow

获取属性tableView的值。

getTableView() - Method in class javafx.scene.control. TableView.TableViewSelectionModel

返回安装此选择模型的TableView实例。

getTabMaxHeight() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最大高度。

getTabMaxWidth() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最大宽度。

getTabMinHeight() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最小高度。

getTabMinWidth() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最小宽度。

getTabPane() - Method in class javafx.scene.control. Tab

对包含此选项卡实例的TabPane的引用。

getTabPlacement() - Method in class javax.swing. JTabbedPane

返回此标签页窗格的标签页的位置。

getTabRunCount() - Method in class javax.swing. JTabbedPane

返回当前用于显示选项卡的选项卡运行次数。

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 getTabRunCount方法。

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf. TabbedPaneUI

返回选项卡运行计数。

getTabRunIndent(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回标签运行缩进。

getTabRunOffset(int, int, int, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回选项卡运行偏移量。

getTabRunOverlay(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回标签运行叠加层。

getTabRunOverlay(int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

getTabs() - Method in class com.sun.tools.jconsole. JConsolePlugin

返回要在JConsole窗口中添加的选项卡。

getTabs() - Method in class javafx.scene.control. TabPane

要在此TabPane中显示的选项卡。

getTabSet() - Method in class javax.swing.text. ParagraphView

获取 Tabset用于计算选项卡。

getTabSet(AttributeSet) - Static method in class javax.swing.text. StyleConstants

获取TabSet。

getTabSize() - Method in class javax.swing. JTextArea

获取用于扩展选项卡的字符数。

getTabSize() - Method in class javax.swing.text. PlainView

返回为文档设置的选项卡大小，默认为8。

getTabSize() - Method in class javax.swing.text. WrappedPlainView

返回为文档设置的选项卡大小，默认为8。

getTabularType() - Method in interface javax.management.openmbean. TabularData

返回描述此 TabularData实例的 表格类型 。

getTabularType() - Method in class javax.management.openmbean. TabularDataSupport

返回描述此 TabularData实例的 表格类型 。

getTag() - Method in class javax.imageio.plugins.tiff. TIFFField

检索与此字段关联的标签。

getTag() - Method in class javax.swing.text.html. HTMLDocument.Iterator

迭代器代表的标签类型。

getTag(int) - Method in class javax.imageio.plugins.tiff. TIFFDirectory

返回TIFFTag ，其标签号等于tagNumber或null如果与此目录相关联的TIFFTagSet s中没有此类标记。

getTag(int) - Method in class javax.imageio.plugins.tiff. TIFFTagSet

返回该集合中与给定标签号相关联的 null如果该数字没有标签，则返回 TIFFTag 。

getTag(String) - Method in class javax.imageio.plugins.tiff. TIFFTagSet

返回 TIFFTag具有给定标记名称，或者 null如果指定的标记不属于这个标签集。

getTag(String) - Static method in class javax.swing.text.html. HTML

获取一个公知标签名称的标签常量（即集合{A，ADDRESS，APPLET，AREA，B，BASE，BASEFONT，BIG，BLOCKQUOTE，BODY，BR，CAPTION，CENTER，CITE，CODE中的一个标签，DD，DFN，DIR，DIV，DL，DT，EM，FONT，FORM，FRAME，FRAMESET，H1，H2，H3，H4，H5，H6，HEAD，HR，HTML，I，IMG，INPUT，ISINDEX，KBD ，LI，LINK，MAP，MENU，META，NOBR，NOFRAMES，OBJECT，OL，OPTION，P，PARAM，PRE，SAMP，SCRIPT，SELECT，SMALL，SPAN，STRIKE，S，STRONG，STYLE，SUB，SUP，TABLE ，TD，TEXTAREA，TH，TITLE，TR，TT，U，UL，VAR}。

getTag(URL) - Method in interface javax.jnlp. PersistenceService

返回与给定URL相关联的持久性数据存储条目的标签的当前值对应的 int 。

getTagName() - Method in interface com.sun.source.doctree. BlockTagTree

返回标签的名称。

getTagName() - Method in interface com.sun.source.doctree. InlineTagTree

返回标签的名称。

getTagName() - Method in class javax.imageio.metadata. IIOMetadataNode

相当于 getNodeName 。

getTagName() - Method in interface org.w3c.dom. Element

元素的名称。

getTagNames() - Method in class javax.imageio.plugins.tiff. TIFFTagSet

检索不可修改的词典增加的标签名称集合。

getTagNumber() - Method in class javax.imageio.plugins.tiff. TIFFField

检索 [0,65535]范围内的标签号。

getTagNumbers() - Method in class javax.imageio.plugins.tiff. TIFFTagSet

检索一个不可修改的数字增加的标签号集合。

getTags() - Method in interface java.beans. PropertyEditor

如果属性值必须是一组已知标记值，则该方法应返回一个标记数组。

getTags() - Method in class java.beans. PropertyEditorSupport

如果属性值必须是一组已知标记值之一，则该方法应返回一个标记值的数组。

getTagSet() - Method in class javax.imageio.plugins.tiff. TIFFTag

返回该标签是其中的 TIFFTagSet 。

getTagSets() - Method in class javax.imageio.plugins.tiff. TIFFDirectory

返回此目录所知道的TIFFTagSet s。

getTail(Handler) - Method in class java.util.logging. Formatter

返回一组格式化记录的尾部字符串。

getTail(Handler) - Method in class java.util.logging. XMLFormatter

返回一组XML格式记录的尾字符串。

getTarget() - Method in class java.beans. EventHandler

返回此事件处理程序将发送消息的对象。

getTarget() - Method in class java.beans. Statement

返回此语句的目标对象。

getTarget() - Method in class java.lang.invoke. CallSite

根据此调用站点的特定类定义的行为，返回调用站点的目标方法。

getTarget() - Method in class java.lang.invoke. ConstantCallSite

返回调用点，其行为类似于目标方法 final的领域 ConstantCallSite 。

getTarget() - Method in class java.lang.invoke. MutableCallSite

返回调用站点的目标方法，其行为类似于 MutableCallSite的正常字段。

getTarget() - Method in class java.lang.invoke. VolatileCallSite

返回调用点，其行为类似于目标方法 volatile的领域 VolatileCallSite 。

getTarget() - Method in class javafx.animation. KeyValue

返回此 KeyValue的目标

getTarget() - Method in class javafx.event. Event

返回此事件的事件目标。

getTarget() - Method in class javafx.scene.input. TouchPoint

获取触发此触摸点触发事件的事件目标。

getTarget() - Method in class javax.accessibility. AccessibleRelation

返回此关系的目标对象。

getTarget() - Method in interface javax.rmi.CORBA. Tie

返回此领带的目标。

getTarget() - Method in class javax.swing. BoxLayout

返回使用此布局管理器的容器。

getTarget() - Method in class javax.swing. OverlayLayout

返回使用此布局管理器的容器。

getTarget() - Method in class javax.swing.text.html. HTMLFrameHyperlinkEvent

返回链接的目标。

getTarget() - Method in interface javax.xml.crypto.dsig. SignatureProperty

返回此 SignatureProperty的目标URI。

getTarget() - Method in interface javax.xml.stream.events. ProcessingInstruction

处理指令的目标部分

getTarget() - Method in interface org.w3c.dom.events. Event

用于指示事件最初发送到的 EventTarget 。

getTarget() - Method in interface org.w3c.dom.html. HTMLAnchorElement

框架来渲染资源。

getTarget() - Method in interface org.w3c.dom.html. HTMLAreaElement

框架来渲染资源。

getTarget() - Method in interface org.w3c.dom.html. HTMLBaseElement

默认目标框架。

getTarget() - Method in interface org.w3c.dom.html. HTMLFormElement

框架来渲染资源。

getTarget() - Method in interface org.w3c.dom.html. HTMLLinkElement

框架来渲染资源。

getTarget() - Method in interface org.w3c.dom. ProcessingInstruction

该处理指令的目标。

getTargetActions() - Method in class java.awt.dnd. DragSourceDragEvent

此方法返回目标放置操作。

getTargetActions() - Method in class java.awt.dnd. DropTargetContext

此方法返回一个 int表示 DropTarget将接受的当前操作。

getTargetCertConstraints() - Method in class java.security.cert. PKIXParameters

返回目标证书所需的约束。

getTargetDataLine(AudioFormat) - Static method in class javax.sound.sampled. AudioSystem

获取可用于以 AudioFormat对象指定的格式录制音频数据的目标数据线。

getTargetDataLine(AudioFormat, Mixer.Info) - Static method in class javax.sound.sampled. AudioSystem

获得可用于在由指定的格式记录音频数据的目标数据线 AudioFormat对象，通过由指定的混频器提供 Mixer.Info对象。

getTargetedNotifications() - Method in class javax.management.remote. NotificationResult

返回查询产生的通知，以及它们对应的侦听器。

getTargetEncodings() - Method in class javax.sound.sampled.spi. FormatConversionProvider

获取此提供商提供格式转换服务的一组目标格式编码。

getTargetEncodings(AudioFormat) - Static method in class javax.sound.sampled. AudioSystem

获取系统可以使用一组已安装的格式转换器从指定格式的音频输入流中获取的编码。

getTargetEncodings(AudioFormat) - Method in class javax.sound.sampled.spi. FormatConversionProvider

获取格式转换器支持的一组目标格式编码，给定特定的源格式。

getTargetEncodings(AudioFormat.Encoding) - Static method in class javax.sound.sampled. AudioSystem

获取系统可以使用一组已安装的格式转换器从具有指定编码的音频输入流中获取的编码。

getTargetError() - Method in exception javax.management. RuntimeErrorException

返回实际抛出的Error 。

getTargetException() - Method in exception java.lang.reflect. InvocationTargetException

获取抛出的目标异常。

getTargetException() - Method in exception javax.management. MBeanException

返回实际抛出异常 。

getTargetException() - Method in exception javax.management. ReflectionException

返回实际抛出的异常 。

getTargetException() - Method in exception javax.management. RuntimeMBeanException

返回实际抛出的RuntimeException 。

getTargetException() - Method in exception javax.management. RuntimeOperationsException

返回实际抛出的RuntimeException 。

getTargetFormats(AudioFormat.Encoding, AudioFormat) - Static method in class javax.sound.sampled. AudioSystem

获取具有特定编码的格式，并且系统可以使用一组已安装的格式转换器从指定格式的流中获取。

getTargetFormats(AudioFormat.Encoding, AudioFormat) - Method in class javax.sound.sampled.spi. FormatConversionProvider

使用格式转换器支持的编码获取目标格式集。

getTargetFramerate() - Method in class javafx.animation. Animation

目标帧率是 Animation将以每秒帧数运行的最大帧率。

getTargetLineInfo() - Method in interface javax.sound.sampled. Mixer

获取有关此混音器支持的目标行集的信息。

getTargetLineInfo(Line.Info) - Static method in class javax.sound.sampled. AudioSystem

获取有关所安装的混音器支持的特定类型的所有目标行的信息。

getTargetLineInfo(Line.Info) - Method in interface javax.sound.sampled. Mixer

获取有关混合器支持的特定类型的目标行的信息。

getTargetLines() - Method in interface javax.sound.sampled. Mixer

获取当前从此混音器打开的所有目标线的集合。

getTargetModules() - Method in interface javax.lang.model.element. ModuleElement.ExportsDirective

返回要导出软件包的特定模块，如果软件包导出到具有对该模块的可读性的所有模块，则返回null。

getTargetModules() - Method in interface javax.lang.model.element. ModuleElement.OpensDirective

如果程序包打开了对该模块具有可读性的所有模块，则返回打包程序包的特定模块或空值。

getTargName() - Method in interface org.ietf.jgss. GSSContext

返回上下文接收器的名称。

getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Class<?>, Iterable<String>, Iterable<? extends JavaFileObject>) - Method in interface javax.tools. DocumentationTool

使用给定的组件和参数为文档任务创建未来。

getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Iterable<String>, Iterable<String>, Iterable<? extends JavaFileObject>) - Method in interface javax.tools. JavaCompiler

使用给定的组件和参数创建编译任务的未来。

getTaskbar() - Static method in class java.awt. Taskbar

返回当前任务栏上下文的 Taskbar实例。

getTaskCount() - Method in class java.util.concurrent. ThreadPoolExecutor

返回计划执行的任务的大概总数。

getTBodies() - Method in interface org.w3c.dom.html. HTMLTableElement

返回定义的表体的集合。

getTBSCertificate() - Method in class java.security.cert. X509Certificate

从该证书获取DER编码的证书信息， tbsCertificate 。

getTBSCertList() - Method in class java.security.cert. X509CRL

获取DER编码的CRL信息，来自此CRL的 tbsCertList 。

getTcpNoDelay() - Method in class java.net. Socket

测试是否启用了 TCP_NODELAY 。

getTemplates() - Method in interface javax.xml.transform.sax. TemplatesHandler

当将TemplatesHandler对象用作解析转换指令的ContentHandler时，它将创建一个Templates对象，一旦SAX事件完成，调用者就可以获取该对象。

getTempoFactor() - Method in interface javax.sound.midi. Sequencer

返回音序器的当前速度因子。

getTempoInBPM() - Method in interface javax.sound.midi. Sequencer

获得当前节奏，以每分钟的节拍表示。

getTempoInMPQ() - Method in interface javax.sound.midi. Sequencer

获得当前的节奏，以每季度的微秒表示。

getter(Method) - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder

直接设置getter方法。

getter(Method) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder

直接设置getter方法。

getter(String) - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder

设置吸气剂的替代名称。

getter(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder

设置吸气剂的替代名称。

getTerminal(String) - Method in class javax.smartcardio. CardTerminals

返回具有指定名称的终端，如果不存在此类终端则返回null。

getTexCoordElementSize() - Method in class javafx.scene.shape. TriangleMesh

返回表示纹理坐标的元素数。

getTexCoordIndexOffset() - Method in class javafx.scene.shape. VertexFormat

返回顶点内的纹理坐标组件的面阵列中的索引偏移量。

getTexCoords() - Method in class javafx.scene.shape. TriangleMesh

获取此 TriangleMesh的 texCoords数组。

getText() - Method in class java.awt.event. InputMethodEvent

获取组合的承诺和合成文本。

getText() - Method in class java.awt. Label

获取此标签的文本。

getText() - Method in class java.awt. TextComponent

返回此文本组件显示的文本。

getText() - Method in class java.text. BreakIterator

获取正在扫描的文本

getText() - Method in class javafx.scene.control. ButtonType

返回在构造函数中为此ButtonType指定的文本。

getText() - Method in class javafx.scene.control. Labeled

获取属性文本的值。

getText() - Method in class javafx.scene.control. MenuItem

获取属性文本的值。

getText() - Method in class javafx.scene.control. Tab

选项卡中显示的文本。

getText() - Method in class javafx.scene.control. TableColumnBase

获取属性文本的值。

getText() - Method in class javafx.scene.control. TextFormatter.Change

获取此更改中使用的文本。

getText() - Method in class javafx.scene.control. TextInputControl

获取属性文本的值。

getText() - Method in class javafx.scene.control. Tooltip

获取属性文本的值。

getText() - Method in class javafx.scene.input. InputMethodTextRun

获取此运行中的文本。

getText() - Method in class javafx.scene.input. KeyEvent

描述按键和键释放事件的键代码的字符串，如“HOME”，“F1”或“A”。

getText() - Method in class javafx.scene.text. Text

获取属性文本的值。

getText() - Method in class javax.security.auth.callback. TextInputCallback

获取检索到的文本。

getText() - Method in class javax.swing. AbstractButton

返回按钮的文字。

getText() - Method in class javax.swing. JEditorPane

根据此编辑器的内容类型返回此 TextComponent中包含的文本。

getText() - Method in class javax.swing. JLabel

返回标签显示的文本字符串。

getText() - Method in class javax.swing. JPasswordField

已过时。
从Java 2平台v1.2开始，由getPassword代替。

getText() - Method in class javax.swing.text. JTextComponent

返回此 TextComponent包含的文本。

getText() - Method in interface javax.xml.stream.events. Comment

返回注释的字符串数据，如果不存在则返回空字符串

getText() - Method in class javax.xml.stream.util. StreamReaderDelegate

getText() - Method in interface javax.xml.stream. XMLStreamReader

以字符串形式返回解析事件的当前值，返回CHARACTERS事件的字符串值，返回COMMENT的值，ENTITY_REFERENCE的替换值，CDATA部分的字符串值，SPACE的字符串值事件或DTD的内部子集的String值。

getText() - Method in interface org.w3c.dom.html. HTMLBodyElement

记录文字颜色。

getText() - Method in interface org.w3c.dom.html. HTMLOptionElement

选项元素中包含的文本。

getText() - Method in interface org.w3c.dom.html. HTMLScriptElement

元素的脚本内容。

getText() - Method in interface org.w3c.dom.html. HTMLTitleElement

指定的标题为字符串。

getText(int, int) - Method in class javafx.scene.control. TextInputControl

返回文本输入内容的一个子集。

getText(int, int) - Method in class javax.swing. JPasswordField

已过时。
从Java 2平台v1.2开始，由getPassword替代。

getText(int, int) - Method in class javax.swing.text. AbstractDocument

从文档中获取文本序列。

getText(int, int) - Method in interface javax.swing.text. Document

获取文档给定部分中包含的文本。

getText(int, int) - Method in class javax.swing.text. GlyphView

获取对占用给定范围的文本的引用。

getText(int, int) - Method in class javax.swing.text. JTextComponent

获取由组件表示的文本的一部分。

getText(int, int, Segment) - Method in class javax.swing.text. AbstractDocument

获取文档给定部分中包含的文本。

getText(int, int, Segment) - Method in interface javax.swing.text. Document

获取文档给定部分中包含的文本。

getText(Element) - Method in class javax.swing.text. AbstractWriter

返回与元素关联的文本。

getTextAlign() - Method in class javafx.scene.canvas. GraphicsContext

获得当前的 TextAlignment 。

getTextAlign() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-align属性定义。

getTextAlignment() - Method in class javafx.scene.control. Labeled

获取属性textAlignment的值。

getTextAlignment() - Method in class javafx.scene.control. Tooltip

获取属性textAlignment的值。

getTextAlignment() - Method in class javafx.scene.text. Text

获取属性textAlignment的值。

getTextAlignment() - Method in class javafx.scene.text. TextFlow

获取属性textAlignment的值。

getTextBaseline() - Method in class javafx.scene.canvas. GraphicsContext

获取当前的文本基线。

getTextBorder() - Static method in class javax.swing.plaf.metal. MetalBorders

返回文本组件的边框实例。

getTextBounds(int, int) - Method in interface javax.accessibility. AccessibleExtendedText

返回两个索引之间文本的边界矩形。

getTextBounds(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回 Rectangle在两个指标之间加上文本。

getTextCharacters() - Method in class javax.xml.stream.util. StreamReaderDelegate

getTextCharacters() - Method in interface javax.xml.stream. XMLStreamReader

返回一个包含此事件中的字符的数组。

getTextCharacters(int, char[], int, int) - Method in class javax.xml.stream.util. StreamReaderDelegate

getTextCharacters(int, char[], int, int) - Method in interface javax.xml.stream. XMLStreamReader

获取与CHARACTERS，SPACE或CDATA事件关联的文本。

getTextComponent(ActionEvent) - Method in class javax.swing.text. TextAction

确定要用于操作的组件。

getTextContent() - Method in class javax.imageio.metadata. IIOMetadataNode

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

getTextContent() - Method in interface org.w3c.dom. Node

此属性返回此节点及其后代的文本内容。

getTextDecoration() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-decoration属性定义。

getTextDeltaX() - Method in class javafx.scene.input. ScrollEvent

获取基于水平文本的滚动量。

getTextDeltaXUnits() - Method in class javafx.scene.input. ScrollEvent

获取基于文本滚动的水平滚动单位。

getTextDeltaY() - Method in class javafx.scene.input. ScrollEvent

获取垂直的基于文本的滚动量。

getTextDeltaYUnits() - Method in class javafx.scene.input. ScrollEvent

获取基于文本滚动的垂直滚动单位。

getTextField() - Method in class javax.swing. JSpinner.DefaultEditor

返回此编辑器的 JFormattedTextField小孩。

getTextFieldBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JTextField的边框实例。

getTextFieldBorder() - Static method in class javax.swing.plaf.metal. MetalBorders

返回 JTextField的边框实例。

getTextFill() - Method in class javafx.scene.control. Labeled

获取属性textFill的值。

getTextFill() - Method in class javafx.scene.control.skin. TextInputControlSkin

获取属性textFill的值。

getTextFormatter() - Method in class javafx.scene.control. TextInputControl

获取属性textFormatter的值。

getTextHighlightColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的文本突出显示颜色。

getTextHighlightColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回文本突出显示颜色。

getTextIndent() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-indent属性定义。

getTextLength() - Method in class javax.xml.stream.util. StreamReaderDelegate

getTextLength() - Method in interface javax.xml.stream. XMLStreamReader

返回文本字符数组中此Text事件的字符序列长度。

getTextListeners() - Method in class java.awt. TextComponent

返回在此文本组件上注册的所有文本侦听器的数组。

getTextLocation(int) - Method in interface javafx.scene.input. InputMethodRequests

获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。

getTextLocation(TextHitInfo) - Method in interface java.awt.im. InputMethodRequests

获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。

getTextNonSelectionColor() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回当未选择节点时绘制文本的颜色。

getTextOrigin() - Method in class javafx.scene.text. Text

获取属性textOrigin的值。

getTextOverrun() - Method in class javafx.scene.control. Labeled

获取textOverrun属性的值。

getTextOverrun() - Method in class javafx.scene.control. Tooltip

获取textOverrun属性的值。

getTextPlainUnicodeFlavor() - Static method in class java.awt.datatransfer. DataFlavor

返回一个 DataFlavor用Unicode编码表示纯文本，其中：

getTextRange(int, int) - Method in interface javax.accessibility. AccessibleEditableText

返回两个索引之间的文本字符串。

getTextRange(int, int) - Method in interface javax.accessibility. AccessibleExtendedText

返回两个索引之间的文本。

getTextRange(int, int) - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

返回两个文本之间的 indices 。

getTextRange(int, int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

返回两个索引之间的文本字符串。

getTextRange(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回两个索引之间的文本字符串。

getTextSelectionColor() - Method in class javax.swing.tree. DefaultTreeCellRenderer

返回在选择节点时绘制文本的颜色。

getTextSequenceAfter(int, int) - Method in interface javax.accessibility. AccessibleExtendedText

给定索引后返回 AccessibleTextSequence 。

getTextSequenceAfter(int, int) - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

返回 AccessibleTextSequence给定后 index 。

getTextSequenceAfter(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回 AccessibleTextSequence给定后 index 。

getTextSequenceAt(int, int) - Method in interface javax.accessibility. AccessibleExtendedText

返回给定索引的 AccessibleTextSequence 。

getTextSequenceAt(int, int) - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

返回 AccessibleTextSequence在给定 index 。

getTextSequenceAt(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回 AccessibleTextSequence在给定 index 。

getTextSequenceBefore(int, int) - Method in interface javax.accessibility. AccessibleExtendedText

返回给定索引前的 AccessibleTextSequence 。

getTextSequenceBefore(int, int) - Method in class javax.swing. JPasswordField.AccessibleJPasswordField

返回 AccessibleTextSequence给定前 index 。

getTextSequenceBefore(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

返回 AccessibleTextSequence给定前 index 。

getTextShadow() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-shadow属性定义。

getTextShiftOffset() - Method in class javax.swing.plaf.basic. BasicButtonUI

返回文本的偏移量。

getTextShiftOffset() - Method in class javax.swing.plaf.basic. BasicToggleButtonUI

覆盖，以便文本不会被转换为切换按钮和子类。

getTextStart() - Method in class javax.xml.stream.util. StreamReaderDelegate

getTextStart() - Method in interface javax.xml.stream. XMLStreamReader

返回文本字符数组中存在第一个字符（该文本事件）的偏移量。

getTextTransform() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-transform属性定义。

getTextViewForTab(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回为指定选项卡呈现风格化文本（HTML）所需的文本View对象，如果此选项卡不需要专门的文本呈现，则返回null。

getTFoot() - Method in interface org.w3c.dom.html. HTMLTableElement

返回表 TFOOT ，如果不存在，则返回 null 。

getTHead() - Method in interface org.w3c.dom.html. HTMLTableElement

返回表的 THEAD ，如果不存在，则返回 null 。

getThenReset() - Method in class java.util.concurrent.atomic. DoubleAccumulator

相当于 DoubleAccumulator.get()，其次是 DoubleAccumulator.reset() 。

getThenReset() - Method in class java.util.concurrent.atomic. LongAccumulator

相当于 LongAccumulator.get()，其次是 LongAccumulator.reset() 。

getThenStatement() - Method in interface com.sun.source.tree. IfTree

如果条件为真，则返回要执行的语句

getThenStatement() - Method in interface jdk.nashorn.api.tree. IfTree

返回此'if'语句的'then'语句。

getThickness() - Method in class javax.swing.border. LineBorder

返回边框的厚度。

getThisUpdate() - Method in class java.security.cert. X509CRL

从CRL获取 thisUpdate日期。

getThreadAllocatedBytes(long) - Method in interface com.sun.management. ThreadMXBean

返回指定ID的线程在堆内存中分配的内存总量（以字节为单位）的近似值。

getThreadAllocatedBytes(long[]) - Method in interface com.sun.management. ThreadMXBean

返回在ID为输入数组 ids中的每个线程的堆内存中分配的内存总量（以字节为单位）的 ids 。

getThreadCount() - Method in interface java.lang.management. ThreadMXBean

返回当前线程数，包括守护进程线程和非守护程序线程数。

getThreadCpuTime(long) - Method in interface java.lang.management. ThreadMXBean

以纳秒为单位返回指定ID的线程的总CPU时间。

getThreadCpuTime(long[]) - Method in interface com.sun.management. ThreadMXBean

返回ID为输入数组 ids每个线程的总CPU时间， ids为纳秒。

getThreadFactory() - Method in class java.util.concurrent. ThreadPoolExecutor

返回用于创建新线程的线程工厂。

getThreadGroup() - Method in class java.lang. SecurityManager

返回要在其被调用时实例化任何正在创建的新线程的线程组。

getThreadGroup() - Method in class java.lang. Thread

返回此线程所属的线程组。

getThreadId() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程的ID。

getThreadID() - Method in class java.util.logging. LogRecord

获取消息发起的线程的标识符。

getThreadInfo(long) - Method in interface java.lang.management. ThreadMXBean

返回没有堆栈跟踪的指定的 id的线程的线程信息。

getThreadInfo(long[]) - Method in interface java.lang.management. ThreadMXBean

返回其ID位于输入数组 ids中的每个线程的线程信息，无堆栈跟踪。

getThreadInfo(long[], boolean, boolean) - Method in interface java.lang.management. ThreadMXBean

返回ID为输入数组 ids每个线程的线程信息，并具有堆栈跟踪和同步信息。

getThreadInfo(long[], int) - Method in interface java.lang.management. ThreadMXBean

返回其ID位于输入数组 ids中的每个线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素。

getThreadInfo(long, int) - Method in interface java.lang.management. ThreadMXBean

返回指定 id的线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素。

getThreadMXBean() - Static method in class java.lang.management. ManagementFactory

返回Java虚拟机的线程系统的托管bean。

getThreadName() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程的名称。

getThreadState() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程的状态。

getThreadUserTime(long) - Method in interface java.lang.management. ThreadMXBean

返回指定ID的线程在用户模式下以纳秒为单位的CPU时间。

getThreadUserTime(long[]) - Method in interface com.sun.management. ThreadMXBean

返回输入数组中的ID为 ids每个线程在用户模式下以纳秒为单位的CPU时间。

getThreshold() - Method in class javafx.scene.effect. Bloom

获取属性阈值的值。

getThreshold() - Method in class javax.management.monitor. CounterMonitor

已过时。
截至JMX 1.2，由CounterMonitor.getThreshold(ObjectName)替代

getThreshold() - Method in interface javax.management.monitor. CounterMonitorMBean

已过时。
截至JMX 1.2，由CounterMonitorMBean.getThreshold(ObjectName)替代

getThreshold() - Method in class javax.xml.ws.soap. MTOMFeature

获取用于确定二进制数据何时作为附件发送的阈值。

getThreshold(ObjectName) - Method in class javax.management.monitor. CounterMonitor

如果该对象包含在观察到的MBean集合中，则获取指定对象的当前阈值，否则为 null 。

getThreshold(ObjectName) - Method in interface javax.management.monitor. CounterMonitorMBean

获取指定MBean的阈值。

getThrowable() - Method in class java.awt.event. InvocationEvent

在执行Runnable的 run()方法时返回任何Throwable捕获。

getThrown() - Method in class java.util.logging. LogRecord

获取与日志记录相关联的任何可抛出的值。

getThrown() - Method in exception jdk.nashorn.api.scripting. NashornException

获取抛出的对象。

getThrownTypes() - Method in interface javax.lang.model.element. ExecutableElement

以声明顺序返回此方法或构造函数 throws子句中列出的异常和其他可抛出物。

getThrownTypes() - Method in interface javax.lang.model.type. ExecutableType

返回此可执行文件 throws子句中列出的异常和其他可 throws 。

getThrows() - Method in interface com.sun.source.tree. MethodTree

返回此方法抛出的异常。

getThumbBounds() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

返回当前的大小/位置。

getThumbnail(int) - Method in class javax.imageio. IIOImage

返回与主图像相关联的缩略图。

getThumbnailHeight(int, int) - Method in class javax.imageio. ImageReader

返回索引的缩略图预览图像的高度 thumbnailIndex ，通过索引的图像关联 ImageIndex 。

getThumbnails() - Method in class javax.imageio. IIOImage

如果没有设置，则返回当前 List的缩略图 BufferedImage s，或 null 。

getThumbnailWidth(int, int) - Method in class javax.imageio. ImageReader

返回由索引的缩略图的预览图像的宽度 thumbnailIndex ，与由索引的图像相关联 ImageIndex 。

getThumbOverhang() - Method in class javax.swing.plaf.metal. MetalSliderUI

返回拇指经过滑动条的量。

getThumbSize() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回拇指大小。

getThumbSize() - Method in class javax.swing.plaf.metal. MetalSliderUI

getThumbSize() - Method in class javax.swing.plaf.synth. SynthSliderUI

返回拇指大小。

getTick() - Method in class javax.sound.midi. MidiEvent

获取事件的时间戳，以MIDI刻度。

getTickLabelFill() - Method in class javafx.scene.chart. Axis

获取属性tickLabelFill的值。

getTickLabelFont() - Method in class javafx.scene.chart. Axis

获取属性tickLabelFont的值。

getTickLabelFormatter() - Method in class javafx.scene.chart. ValueAxis

获取属性tickLabelFormatter的值。

getTickLabelGap() - Method in class javafx.scene.chart. Axis

获取属性tickLabelGap的值。

getTickLabelRotation() - Method in class javafx.scene.chart. Axis

获取属性tickLabelRotation的值。

getTickLength() - Method in class javafx.scene.chart. Axis

获取属性tickLength的值。

getTickLength() - Method in class javax.sound.midi. Sequence

获取此序列的持续时间，以MIDI刻度表示。

getTickLength() - Method in interface javax.sound.midi. Sequencer

获取当前序列的长度，以MIDI刻度表示，如果没有设置序列，则为0。

getTickLength() - Method in class javax.swing.plaf.basic. BasicSliderUI

获取水平滑块的刻度区域的高度以及垂直滑块的刻度区域的宽度。

getTickLength() - Method in class javax.swing.plaf.metal. MetalSliderUI

获取水平滑块的刻度区域的高度以及垂直滑块的刻度区域的宽度。

getTickMarkLabel(Number) - Method in class javafx.scene.chart. NumberAxis

获取具有给定值的刻度线的字符串标签名称。

getTickMarkLabel(String) - Method in class javafx.scene.chart. CategoryAxis

获取具有给定值的刻度线的字符串标签名称

getTickMarkLabel(T) - Method in class javafx.scene.chart. Axis

获取具有给定值的刻度线的字符串标签名称

getTickMarks() - Method in class javafx.scene.chart. Axis

不可修改的可观察的刻度表列表，每个TickMark在此轴上直接表示一个刻度。

getTickPosition() - Method in interface javax.sound.midi. Sequencer

获取序列中的当前位置，以MIDI刻度表示。

getTickUnit() - Method in class javafx.scene.chart. NumberAxis

获取属性tickUnit的值。

getTie(Remote) - Static method in class javax.rmi.CORBA. Util

返回给定目标对象的tie（如果有）。

getTie(Remote) - Method in interface javax.rmi.CORBA. UtilDelegate

代表团要求 Util.getTie(java.rmi.Remote) 。

getTIFFField(int) - Method in class javax.imageio.plugins.tiff. TIFFDirectory

从目录中检索TIFF字段。

getTIFFFields() - Method in class javax.imageio.plugins.tiff. TIFFDirectory

从目录中检索所有TIFF字段。

getTile(int, int) - Method in class java.awt.image. BufferedImage

返回瓦（ tileX ， tileY ）。

getTile(int, int) - Method in interface java.awt.image. RenderedImage

返回tile（tileX，tileY）。

getTileAlignment() - Method in class javafx.scene.layout. TilePane

获取属性tileAlignment的值。

getTiledSizeRequirements(SizeRequirements[]) - Static method in class javax.swing. SizeRequirements

确定端点到端放置一组组件所需的总空间。

getTileGridXOffset() - Method in class java.awt.image. BufferedImage

返回瓦片网格相对于原点的x偏移量，例如，tile（0，0）的位置的x坐标。

getTileGridXOffset() - Method in interface java.awt.image. RenderedImage

返回瓦片网格相对于原点的X偏移量，即瓦片（0,0）左上角像素的X坐标。

getTileGridXOffset() - Method in class javax.imageio. ImageWriteParam

返回图像的水平瓦片网格偏移，因为它将被写入输出流。

getTileGridXOffset(int) - Method in class javax.imageio. ImageReader

返回给定图像中瓦片（0，0）左上角的X坐标。

getTileGridYOffset() - Method in class java.awt.image. BufferedImage

返回瓦片网格相对于原点的y偏移量，例如，tile（0,0）的位置的y坐标。

getTileGridYOffset() - Method in interface java.awt.image. RenderedImage

返回瓦片网格相对于原点的Y偏移量，即瓦片（0,0）左上角像素的Y坐标。

getTileGridYOffset() - Method in class javax.imageio. ImageWriteParam

返回图像的垂直瓦片网格偏移，因为它将被写入输出流。

getTileGridYOffset(int) - Method in class javax.imageio. ImageReader

返回给定图像中瓦片（0，0）左上角的Y坐标。

getTileHeight() - Method in class java.awt.image. BufferedImage

返回瓷砖高度（像素）。

getTileHeight() - Method in interface java.awt.image. RenderedImage

返回瓷砖高度（像素）。

getTileHeight() - Method in class javafx.scene.layout. TilePane

获取属性tileHeight的值。

getTileHeight() - Method in class javax.imageio. ImageWriteParam

返回图像中每个图块的高度，因为它将被写入输出流。

getTileHeight(int) - Method in class javax.imageio. ImageReader

返回给定图像中图块的高度。

getTileIcon() - Method in class javax.swing.border. MatteBorder

返回用于平铺边框的图标，如果使用纯色，则返回null。

getTileWidth() - Method in class java.awt.image. BufferedImage

返回瓷砖宽度（以像素为单位）

getTileWidth() - Method in interface java.awt.image. RenderedImage

返回瓷砖宽度（以像素为单位）

getTileWidth() - Method in class javafx.scene.layout. TilePane

获取属性tileWidth的值。

getTileWidth() - Method in class javax.imageio. ImageWriteParam

返回图像中每个图块的宽度，因为它将被写入输出流。

getTileWidth(int) - Method in class javax.imageio. ImageReader

返回给定图像中图块的宽度。

getTilingMode() - Method in class javax.imageio. ImageWriteParam

如果支持平铺，返回当前的平铺模式。

getTime() - Method in class java.sql. Timestamp

返回自1970年1月1日以来，由 Timestamp对象表示的00:00:00 GMT的毫秒数。

getTime() - Method in class java.util. Calendar

返回一个表示 Calendar的时间值（与 Epoch毫秒偏移量）的 Date对象。

getTime() - Method in class java.util. Date

返回自1970年1月1日以来，由 Date对象表示的00:00:00 GMT的毫秒数。

getTime() - Method in class java.util.zip. ZipEntry

返回条目的最后修改时间。

getTime() - Method in class javafx.animation. KeyFrame

返回此 KeyFrame的时间偏移量。

getTime(int) - Method in interface java.sql. CallableStatement

以 java.sql.Time对象的形式获取指定的JDBC TIME参数的值。

getTime(int) - Method in interface java.sql. ResultSet

检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。

getTime(int, Calendar) - Method in interface java.sql. CallableStatement

检索指定的JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象来构造时间。

getTime(int, Calendar) - Method in interface java.sql. ResultSet

检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。

getTime(String) - Method in interface java.sql. CallableStatement

检索作为 java.sql.Time对象的JDBC TIME参数的值。

getTime(String) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。

getTime(String, Calendar) - Method in interface java.sql. CallableStatement

检索JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象来构建时间。

getTime(String, Calendar) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Time对象。

getTimeDateFunctions() - Method in interface java.sql. DatabaseMetaData

检索此数据库可用的时间和日期函数的逗号分隔列表。

getTimeDefinition() - Method in class java.time.zone. ZoneOffsetTransitionRule

获取时间定义，指定如何将时间转换为即时。

getTimeInMillis() - Method in class java.util. Calendar

以毫秒为单位返回此日历的时间值。

getTimeInMillis(Calendar) - Method in class javax.xml.datatype. Duration

以毫秒为单位返回持续时间的长度。

getTimeInMillis(Date) - Method in class javax.xml.datatype. Duration

以毫秒为单位返回持续时间的长度。

getTimeInstance() - Static method in class java.text. DateFormat

获取默认格式化样式为默认的 FORMAT区域设置的时间格式化程序。

getTimeInstance(int) - Static method in class java.text. DateFormat

获取默认的 FORMAT区域设置的给定格式化样式的时间格式化程序。

getTimeInstance(int, Locale) - Static method in class java.text. DateFormat

获取给定区域设置的给定格式化样式的时间格式化程序。

getTimeInstance(int, Locale) - Method in class java.text.spi. DateFormatProvider

返回一个新的 DateFormat实例，用于指定区域设置的给定格式化样式格式化时间。

getTimeLimit() - Method in class javax.naming.directory. SearchControls

以毫秒为单位检索这些SearchControls的时间限制。

getTimeLocal() - Method in class java.util.zip. ZipEntry

返回本地日期时间的条目的最后修改时间。

getTimestamp() - Method in class java.security. CodeSigner

返回签名时间戳。

getTimestamp() - Method in class java.security. Timestamp

返回生成时间戳的日期和时间。

getTimestamp(int) - Method in interface java.sql. CallableStatement

以 java.sql.Timestamp对象的形式获取指定的JDBC TIMESTAMP参数的值。

getTimestamp(int) - Method in interface java.sql. ResultSet

以该Java编程语言中的 ResultSet对象的形式 java.sql.Timestamp此 ResultSet对象的当前行中指定列的值。

getTimestamp(int, Calendar) - Method in interface java.sql. CallableStatement

将指定的JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象 java.sql.Timestamp ，使用给定的 Calendar对象构造 Timestamp对象。

getTimestamp(int, Calendar) - Method in interface java.sql. ResultSet

以Java编程语言中的 java.sql.Timestamp对象的形式，检索此 ResultSet对象的当前行中指定列的值。

getTimestamp(String) - Method in interface java.sql. CallableStatement

检索作为 java.sql.Timestamp对象的JDBC TIMESTAMP参数的值。

getTimestamp(String) - Method in interface java.sql. ResultSet

以Java编程语言中的 ResultSet对象的形式 java.sql.Timestamp该 ResultSet对象当前行中指定列的值。

getTimestamp(String, Calendar) - Method in interface java.sql. CallableStatement

检索作为 java.sql.Timestamp对象的JDBC TIMESTAMP参数的值，使用给定的 Calendar对象构造 Timestamp对象。

getTimestamp(String, Calendar) - Method in interface java.sql. ResultSet

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Timestamp对象。

getTimeStamp() - Method in class javax.management. Notification

获取通知时间戳。

getTimeStamp() - Method in interface org.w3c.dom.events. Event

用于指定创建事件的时间（以秒为单位）。

getTimestampingAuthority() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索时间戳管理机构（TSA）的标识符。

getTimestampingAuthorityCertificate() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索时间戳管理局（TSA）的证书。

getTimeToLive() - Method in class java.net. DatagramSocketImpl

检索TTL（生存时间）选项。

getTimeToLive() - Method in class java.net. MulticastSocket

获取在套接字上发送的组播数据包的默认生存时间。

getTimeToLive(String, Locale) - Method in class java.util. ResourceBundle.Control

返回在此 ResourceBundle.Control下加载的资源束的生存时间（TTL）值。

getTimezone() - Method in class javax.xml.datatype. XMLGregorianCalendar

如果 未定义此可选字段，则返回分钟内的时区偏移量（ DatatypeConstants.FIELD_UNDEFINED） 。

getTimeZone() - Method in class java.text. DateFormat

获取时区。

getTimeZone() - Method in class java.util. Calendar

获取时区。

getTimeZone() - Method in class java.util. GregorianCalendar

getTimeZone(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

返回 java.util.TimeZone 。

getTimeZone(String) - Static method in class java.util. TimeZone

获取给定ID的 TimeZone 。

getTimeZone(ZoneId) - Static method in class java.util. TimeZone

获得 TimeZone给定的 zoneId 。

getTimezoneOffset() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，替换为-(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 。

getTipText() - Method in class javax.swing. JToolTip

返回显示工具提示时显示的文本。

getTitle() - Method in class java.awt. Dialog

获取对话框的标题。

getTitle() - Method in class java.awt. Frame

获取框架的标题。

getTitle() - Method in class javafx.concurrent. Service

获取属性标题的值。

getTitle() - Method in class javafx.concurrent. Task

获取属性标题的值。

getTitle() - Method in interface javafx.concurrent. Worker

应该与此Worker关联的可选标题。

getTitle() - Method in class javafx.scene.chart. Chart

获取属性标题的值。

getTitle() - Method in class javafx.scene.control. Dialog

返回对话框的标题。

getTitle() - Method in class javafx.scene.web. WebEngine

获取属性标题的值。

getTitle() - Method in class javafx.scene.web. WebHistory.Entry

获取属性标题的值。

getTitle() - Method in class javafx.stage. DirectoryChooser

获取属性标题的值。

getTitle() - Method in class javafx.stage. FileChooser

获取属性标题的值。

getTitle() - Method in class javafx.stage. Stage

获取属性标题的值。

getTitle() - Method in class javax.swing.border. TitledBorder

返回标题边框的标题。

getTitle() - Method in class javax.swing. JInternalFrame

返回 JInternalFrame的标题。

getTitle() - Method in interface org.w3c.dom.html. HTMLDocument

由文件头文件中的 TITLE元素指定的文件的标题。

getTitle() - Method in interface org.w3c.dom.html. HTMLElement

该元素的咨询标题。

getTitle() - Method in interface org.w3c.dom.stylesheets. StyleSheet

咨询标题。

getTitle(String, FontMetrics, int) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

返回标题。

getTitleAt(int) - Method in class javax.swing. JTabbedPane

返回标签标题 index 。

getTitleColor() - Method in class javax.swing.border. TitledBorder

返回标题边框的标题颜色。

getTitledBorderText() - Method in interface javax.accessibility. AccessibleExtendedComponent

返回标题边框文本。

getTitledBorderText() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回标题边框文本

getTitledBorderText() - Method in class javax.swing. JComponent.AccessibleJComponent

返回标题边框文本

getTitledBorderText() - Method in class javax.swing. JLabel.AccessibleJLabel

返回标题边框文本

getTitleFont() - Method in class javax.swing.border. TitledBorder

返回标题边框的标题字体。

getTitleJustification() - Method in class javax.swing.border. TitledBorder

返回标题边框的标题对齐。

getTitlePosition() - Method in class javax.swing.border. TitledBorder

返回标题边框的标题位置。

getTitleSide() - Method in class javafx.scene.chart. Chart

获取属性titleSide的值。

getTLen() - Method in class javax.crypto.spec. GCMParameterSpec

返回认证标签长度。

getTo() - Method in class javafx.collections. ListChangeListener.Change

更改间隔的结束。

getToAngle() - Method in class javafx.animation. RotateTransition

获取属性的值为Agle。

getToggleButtonBorder() - Static method in class javax.swing.plaf.basic. BasicBorders

返回 JToggleButton的边框实例。

getToggleButtonBorder() - Static method in class javax.swing.plaf.metal. MetalBorders

返回 JToggleButton的边框实例。

getToggleClickCount() - Method in class javax.swing. JTree

返回扩展或关闭节点所需的鼠标点击次数。

getToggleGroup() - Method in class javafx.scene.control. RadioMenuItem

获取属性toggleGroup的值。

getToggleGroup() - Method in interface javafx.scene.control. Toggle

返回的ToggleGroup到这个Toggle所属。

getToggleGroup() - Method in class javafx.scene.control. ToggleButton

获取属性toggleGroup的值。

getToggles() - Method in class javafx.scene.control. ToggleGroup

ToggleGroup中的切换列表。

getToIndex() - Method in class javax.swing.event. TableColumnModelEvent

返回toIndex。

getToken() - Method in class com.sun.security.auth. NTNumericCredential

返回此 NTNumericCredential的整数表示。

getTokenThreshold() - Method in class javax.swing.text.html. HTMLDocument

在尝试更新文档元素结构之前，获取要缓冲的令牌数。

getToolkit() - Method in class java.awt. Component

获取此组件的工具包。

getToolkit() - Method in class java.awt. Window

返回此框架的工具包。

getTooltip() - Method in class javafx.scene.control. Control

获取属性工具提示的值。

getTooltip() - Method in class javafx.scene.control. Tab

与此选项卡关联的工具提示。

getToolTip() - Method in class java.awt. TrayIcon

返回与此 TrayIcon关联的工具提示字符串。

getToolTipLocation(MouseEvent) - Method in class javax.swing. JComponent

返回此组件坐标系中的工具提示位置。

getToolTipText() - Method in interface javax.accessibility. AccessibleExtendedComponent

返回工具提示文本。

getToolTipText() - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

返回工具提示文本

getToolTipText() - Method in class javax.swing. JComponent.AccessibleJComponent

返回工具提示文本

getToolTipText() - Method in class javax.swing. JComponent

返回已设置为 setToolTipText的工具提示字符串。

getToolTipText() - Method in class javax.swing. JLabel.AccessibleJLabel

返回工具提示文本

getToolTipText(float, float, Shape) - Method in class javax.swing.text.html. ImageView

对于图像，工具提示文本来自使用 ALT属性指定的文本。

getToolTipText(float, float, Shape) - Method in class javax.swing.text. View

返回指定位置的工具提示文本。

getToolTipText(MouseEvent) - Method in class javax.swing. JComponent

返回要用作 事件的工具提示的字符串。

getToolTipText(MouseEvent) - Method in class javax.swing. JList

返回用于给定事件的工具提示文本。

getToolTipText(MouseEvent) - Method in class javax.swing. JTabbedPane

返回由鼠标事件位置确定的组件的工具提示文本。

getToolTipText(MouseEvent) - Method in class javax.swing. JTable

覆盖 JComponent的 getToolTipText方法，以便允许使用渲染器的提示，如果它具有文本集。

getToolTipText(MouseEvent) - Method in class javax.swing. JTree

覆盖 JComponent的 getToolTipText方法，以便允许使用渲染器的提示，如果它具有文本集。

getToolTipText(MouseEvent) - Method in class javax.swing.table. JTableHeader

允许渲染器的提示被使用，如果有文本集。

getToolTipText(MouseEvent) - Method in class javax.swing.text. JTextComponent

返回要用作 event的工具提示的 event 。

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.basic. BasicTextUI

返回要用作传入位置的工具提示的字符串。

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 getToolTipText方法。

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf. TextUI

已过时。
替换为TextUI.getToolTipText2D(JTextComponent, Point2D)

getToolTipText2D(JTextComponent, Point2D) - Method in class javax.swing.plaf. TextUI

返回要用作传入位置的工具提示的字符串。

getToolTipTextAt(int) - Method in class javax.swing. JTabbedPane

在 index返回选项卡工具提示文本。

getTop() - Method in class javafx.geometry. Insets

顶端的插图

getTop() - Method in class javafx.scene.layout. BorderPane

获取属性顶部的值。

getTop() - Method in class javafx.scene.layout. BorderWidths

非负值（ BorderWidths.AUTO除外 ），表示边框顶部的边框厚度。

getTop() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的顶层属性定义。

getTop() - Method in interface org.w3c.dom.css. Rect

该属性用于rect的顶部。

getToPage() - Method in class java.awt. JobAttributes

对于要使用这些属性的作业，如果要打印的页面范围，则返回要打印的最后一页（包括）。

getTopAnchor(Node) - Static method in class javafx.scene.layout. AnchorPane

如果设置，返回小孩的顶部锚约束。

getTopComponent() - Method in class javax.swing. JSplitPane

返回上面的组件，或者分隔符的左边。

getTopInput() - Method in class javafx.scene.effect. Blend

获取属性topInput的值。

getTopInset() - Method in class javax.swing.text. AsyncBoxView

获取视图边缘的顶部。

getTopInset() - Method in class javax.swing.text. CompositeView

获得顶级插图。

getTopLeftHorizontalRadius() - Method in class javafx.scene.layout. CornerRadii

左上角水平半径的长度。

getTopLeftVerticalRadius() - Method in class javafx.scene.layout. CornerRadii

左上角垂直半径的长度。

getTopLevelAncestor() - Method in class javax.swing. JComponent

返回此组件的顶级祖先（包含 Window或 Applet ），如果此组件尚未添加到任何容器，则 null 。

getTopLevelWindows() - Static method in class com.sun.java.accessibility.util. EventQueueMonitor

返回在Java虚拟机中使用的顶级Windows的列表。

getTopLevelWindowWithFocus() - Static method in class com.sun.java.accessibility.util. EventQueueMonitor

返回目前具有键盘焦点的顶级 Window 。

getTopMargin() - Method in class javafx.print. PageLayout

以分数返回页面布局的上边距。

getTopOffset() - Method in class javafx.scene.effect. Reflection

获取属性topOffset的值。

getTopOpacity() - Method in class javafx.scene.effect. Reflection

获取属性topOpacity的值。

getTopRightHorizontalRadius() - Method in class javafx.scene.layout. CornerRadii

右上角水平半径的长度。

getTopRightVerticalRadius() - Method in class javafx.scene.layout. CornerRadii

右上角垂直半径的长度。

getTopStroke() - Method in class javafx.scene.layout. BorderStroke

定义此边框顶部的填充。

getTopStyle() - Method in class javafx.scene.layout. BorderStroke

定义此边框顶部的样式。

getTotalAngle() - Method in class javafx.scene.input. RotateEvent

获取此手势的累积旋转角度。

getTotalCapacity() - Method in interface java.lang.management. BufferPoolMXBean

返回此池中缓冲区总容量的估计值。

getTotalColumnWidth() - Method in class javax.swing.table. DefaultTableColumnModel

返回所有列的总合并宽度。

getTotalColumnWidth() - Method in interface javax.swing.table. TableColumnModel

返回所有列的总宽度。

getTotalCompilationTime() - Method in interface java.lang.management. CompilationMXBean

返回在编译中花费的大概累积的经过时间（以毫秒为单位）。

getTotalDeltaX() - Method in class javafx.scene.input. ScrollEvent

获取整个手势的累积水平滚动量。

getTotalDeltaY() - Method in class javafx.scene.input. ScrollEvent

获取整个手势的累积垂直滚动量。

getTotalDuration() - Method in class javafx.animation. Animation

获取属性totalDuration的值。

getTotalDuration() - Method in class javafx.scene.media. MediaPlayer

检索总播放持续时间，包括所有周期（重复）。

getTotalIn() - Method in class java.util.zip. Deflater

返回到目前为止输入的未压缩字节的总数。

getTotalIn() - Method in class java.util.zip. Inflater

返回到目前为止输入的压缩字节的总数。

getTotalLoadedClassCount() - Method in interface java.lang.management. ClassLoadingMXBean

返回从Java虚拟机开始执行以来已加载的类的总数。

getTotalOut() - Method in class java.util.zip. Deflater

返回到目前为止输出的压缩字节总数。

getTotalOut() - Method in class java.util.zip. Inflater

返回到目前为止输出的未压缩字节的总数。

getTotalPhysicalMemorySize() - Method in interface com.sun.management. OperatingSystemMXBean

以字节为单位返回物理内存总量。

getTotalSeconds() - Method in class java.time. ZoneOffset

获取总区域偏移量（以秒为单位）。

getTotalSize() - Method in interface org.w3c.dom.ls. LSProgressEvent

文档的总大小包括所有外部资源，如果查看到更多外部资源的引用，则此数字可能会随文档解析而改变。

getTotalSpace() - Method in class java.io. File

通过此抽象路径名返回分区大小 named 。

getTotalSpace() - Method in class java.nio.file. FileStore

返回文件存储的大小（以字节为单位）。

getTotalStartedThreadCount() - Method in interface java.lang.management. ThreadMXBean

返回自Java虚拟机启动以来创建并启动的线程总数。

getTotalSwapSpaceSize() - Method in interface com.sun.management. OperatingSystemMXBean

返回交换空间的总数（以字节为单位）。

getTotalWork() - Method in class javafx.concurrent. Service

获取属性totalWork的值。

getTotalWork() - Method in class javafx.concurrent. Task

获取属性totalWork的值。

getTotalWork() - Method in interface javafx.concurrent. Worker

表示 Worker.workDoneProperty()属性的最大值。

getTotalZoomFactor() - Method in class javafx.scene.input. ZoomEvent

获取此手势的缩放量。

getTouchCount() - Method in class javafx.scene.input. ScrollEvent

获得导致此事件的触摸点数。

getTouchCount() - Method in class javafx.scene.input. SwipeEvent

获得导致此事件的触摸点数。

getTouchCount() - Method in class javafx.scene.input. TouchEvent

返回此触摸事件集所表示的触摸点数。

getTouchPoint() - Method in class javafx.scene.input. TouchEvent

获取此事件的触点。

getTouchPoints() - Method in class javafx.scene.input. TouchEvent

获取由这组触摸事件表示的所有触摸点，包括此事件的触摸点。

getToValue() - Method in class javafx.animation. FadeTransition

获取属性值到值。

getToValue() - Method in class javafx.animation. FillTransition

获取属性值到值。

getToValue() - Method in class javafx.animation. StrokeTransition

获取属性值到值。

getToX() - Method in class javafx.animation. ScaleTransition

获取属性toX的值。

getToX() - Method in class javafx.animation. TranslateTransition

获取属性toX的值。

getToY() - Method in class javafx.animation. ScaleTransition

获取属性的值为Y。

getToY() - Method in class javafx.animation. TranslateTransition

获取属性的值为Y。

getToZ() - Method in class javafx.animation. ScaleTransition

获取属性到Z的值。

getToZ() - Method in class javafx.animation. TranslateTransition

获取属性到Z的值。

getTrackBounds() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

返回轨道的当前边界，即增量和减量按钮之间的空间，减去插值。

getTrackID() - Method in class javafx.scene.media. Track

获取由媒体容器格式定义的曲目ID。

getTrackLength() - Method in class javax.swing.plaf.metal. MetalSliderUI

返回滑动条的较长尺寸。

getTrackMute(int) - Method in interface javax.sound.midi. Sequencer

获取当前静音状态的轨道。

getTracks() - Method in class javafx.scene.media. Media

检索此媒体源中包含的曲目。

getTracks() - Method in class javax.sound.midi. Sequence

获取包含此序列中所有曲目的数组。

getTrackSolo(int) - Method in interface javax.sound.midi. Sequencer

获得目前的独奏状态。

getTrackWidth() - Method in class javax.swing.plaf.metal. MetalSliderUI

返回轨道的较短尺寸。

getTrafficClass() - Method in class java.net. DatagramSocket

在从该DatagramSocket发送的数据包的IP数据报头中获取流量类或服务类型。

getTrafficClass() - Method in class java.net. Socket

在从此Socket发送的数据包的IP头中获取流量类或服务类型

getTrailerField() - Method in class java.security.spec. PSSParameterSpec

返回预告片字段的值，即PKCS＃1 v2.1中的bc。

getTransactionIsolation() - Method in interface java.sql. Connection

检索此 Connection对象的当前事务隔离级别。

getTransactionIsolation() - Method in class javax.sql.rowset. BaseRowSet

返回此 RowSet对象的连接的事务隔离属性。

getTransactionIsolation() - Method in interface javax.sql. RowSet

检索为此 RowSet对象设置的事务隔离级别。

getTransactionTimeout() - Method in interface javax.transaction.xa. XAResource

获取为此XAResource实例设置的当前事务超时值。

getTransferable() - Method in class java.awt.dnd. DragSourceContext

返回 Transferable与此相关 DragSourceContext 。

getTransferable() - Method in class java.awt.dnd. DropTargetContext

获取此操作的可转移（代理）操作数

getTransferable() - Method in class java.awt.dnd. DropTargetDragEvent

此方法返回表示与当前拖动操作相关联的数据的Transferable对象。

getTransferable() - Method in class java.awt.dnd. DropTargetDropEvent

此方法返回与该drop相关联的 Transferable对象。

getTransferable() - Method in class javax.swing. TransferHandler.TransferSupport

返回与此转移相关联的 Transferable 。

getTransferData(DataFlavor) - Method in class java.awt.datatransfer. StringSelection

返回 Transferable所请求的数据 DataFlavor如果可能的话。

getTransferData(DataFlavor) - Method in interface java.awt.datatransfer. Transferable

返回表示要传输的数据的对象。

getTransferData(DataFlavor) - Method in class java.awt.dnd. DropTargetContext.TransferableProxy

返回一个对象，该对象表示由所请求的数据风格的可封装转移提供的数据。

getTransferData(DataFlavor) - Method in class javax.activation. DataHandler

返回表示要传输的数据的对象。

getTransferData(DataFlavor, DataSource) - Method in interface javax.activation. DataContentHandler

返回表示要传输的数据的对象。

getTransferDataFlavors() - Method in class java.awt.datatransfer. StringSelection

返回一个数组，其中这个 Transferable可以提供 Transferable 。

getTransferDataFlavors() - Method in interface java.awt.datatransfer. Transferable

返回一个DataFlavor对象数组，指示可以提供数据的风格。

getTransferDataFlavors() - Method in class java.awt.dnd. DropTargetContext.TransferableProxy

返回一个DataFlavor对象数组，表示可封装的可传递数据可以提供数据的风格。

getTransferDataFlavors() - Method in interface javax.activation. DataContentHandler

返回一个DataFlavor对象数组，指示可以提供数据的风格。

getTransferDataFlavors() - Method in class javax.activation. DataHandler

返回此数据可用的DataFlavors。

getTransferHandler() - Method in class javax.swing. JApplet

已过时。

获取 transferHandler属性。

getTransferHandler() - Method in class javax.swing. JComponent

获取 transferHandler属性。

getTransferHandler() - Method in class javax.swing. JDialog

获取 transferHandler属性。

getTransferHandler() - Method in class javax.swing. JFrame

获取 transferHandler属性。

getTransferHandler() - Method in class javax.swing. JWindow

获取 transferHandler属性。

getTransferMode() - Method in class javafx.scene.input. DragEvent

数据传输模式。

getTransferModes() - Method in class javafx.scene.input. Dragboard

获取由此拖动操作的源支持的一组传输模式。

getTransferSize() - Method in exception java.sql. DataTruncation

获取实际传输的数据的字节数。

getTransferType() - Method in class java.awt.image. ColorModel

返回此 ColorModel的传输类型。

getTransferType() - Method in class java.awt.image. MultiPixelPackedSampleModel

返回用于通过 getDataElements和 setDataElements方法传输像素的TransferType。

getTransferType() - Method in class java.awt.image. Raster

返回用于通过getDataElements和setDataElements方法传输像素的TransferType。

getTransferType() - Method in class java.awt.image. SampleModel

返回用于通过getDataElements和setDataElements方法传输像素的TransferType。

getTransform() - Method in class java.awt.font. FontRenderContext

获取用于将排印点缩放到像素的变换，这个 FontRenderContext 。

getTransform() - Method in class java.awt. Font

返回与此 Font相关联的转换的副本。

getTransform() - Method in class java.awt.font. TransformAttribute

返回包装转换的副本。

getTransform() - Method in class java.awt. Graphics2D

在 Graphics2D上下文中返回当前 Transform的 Graphics2D 。

getTransform() - Method in class java.awt.image. AffineTransformOp

返回此变换操作使用的仿射变换。

getTransform() - Method in class java.awt.image.renderable. RenderContext

获取当前的用户到设备的AffineTransform。

getTransform() - Method in class java.awt. MultipleGradientPaint

返回应用于渐变的变换的副本。

getTransform() - Method in class javafx.scene.canvas. GraphicsContext

返回当前变换的副本。

getTransform() - Method in class javafx.scene. SnapshotParameters

获取当前的变换。

getTransform(Affine) - Method in class javafx.scene.canvas. GraphicsContext

拷贝电流转换成所提供的对象，创建新Affine对象，如果它是零，并返回包含复制的对象。

getTransformer() - Method in interface javax.xml.transform.sax. TransformerHandler

获取与此处理程序关联的 Transformer ，这是为了设置参数和输出属性所必需的。

getTransforms() - Method in class javafx.scene. Node

定义的ObservableList Transform个对象被应用到这个Node 。

getTransforms() - Method in interface javax.xml.crypto.dsig.keyinfo. RetrievalMethod

返回这RetrievalMethod的Transform的RetrievalMethod 。

getTransforms() - Method in interface javax.xml.crypto.dsig. Reference

返回一个unmodifiable list的Transform包含在这个S Reference 。

getTransformType() - Method in class java.awt.font. FontRenderContext

返回 FontRenderContext的仿射变换的整数类型，由 AffineTransform.getType()

getTransition(LocalDateTime) - Method in class java.time.zone. ZoneRules

在这些规则中获取在指定的本地日期时间中适用的偏移量转换。

getTransitionRules() - Method in class java.time.zone. ZoneRules

获得过渡规则列表，超出转换列表中定义的年限。

getTransitions() - Method in class java.time.zone. ZoneRules

获取完全定义的转换的完整列表。

getTranslateInstance(double, double) - Static method in class java.awt.geom. AffineTransform

返回表示平移变换的变换。

getTranslateX() - Method in class java.awt.geom. AffineTransform

返回3x3仿射变换矩阵的平移元素（m02）的X坐标。

getTranslateX() - Method in class javafx.scene. Node

获取属性translateX的值。

getTranslateY() - Method in class java.awt.geom. AffineTransform

返回3x3仿射变换矩阵的平移元素（m12）的Y坐标。

getTranslateY() - Method in class javafx.scene. Node

获取属性translateY的值。

getTranslateZ() - Method in class javafx.scene. Node

获取属性translateZ的值。

getTranslatorClass(Class<?>) - Static method in class com.sun.java.accessibility.util. Translator

找到这个班的翻译。

getTransmitter() - Method in interface javax.sound.midi. MidiDevice

获取一个MIDI OUT连接，MIDI设备将从该MIDI连接传输MIDI数据。

getTransmitter() - Static method in class javax.sound.midi. MidiSystem

从外部MIDI端口或其他默认来源获取MIDI发送器。

getTransmitters() - Method in interface javax.sound.midi. MidiDevice

返回与此MidiDevice连接的所有当前有效的非闭合发射器。

getTransparency() - Method in class java.awt. Color

返回此 Color的透明度模式。

getTransparency() - Method in class java.awt. GradientPaint

返回此 GradientPaint的透明度模式。

getTransparency() - Method in class java.awt.image. BufferedImage

返回透明度。

getTransparency() - Method in class java.awt.image. ColorModel

返回透明度。

getTransparency() - Method in class java.awt.image. IndexColorModel

返回透明度。

getTransparency() - Method in class java.awt.image. VolatileImage

返回透明度。

getTransparency() - Method in class java.awt. MultipleGradientPaint

返回此 Paint对象的透明度模式。

getTransparency() - Method in class java.awt. TexturePaint

返回此 TexturePaint的透明度模式。

getTransparency() - Method in interface java.awt. Transparency

返回此 Transparency的类型。

getTransparentPixel() - Method in class java.awt.image. IndexColorModel

如果没有Alpha值为0的像素，则返回此 IndexColorModel中的透明像素的索引或-1。

getTrayIcons() - Method in class java.awt. SystemTray

返回此应用程序添加到托盘中的所有图标的数组。

getTrayIconSize() - Method in class java.awt. SystemTray

返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。

getTRC() - Method in class java.awt.color. ICC_ProfileGray

将TRC作为一组短裤返回。

getTRC(int) - Method in class java.awt.color. ICC_ProfileRGB

将特定组件的TRC作为数组返回。

getTree(Element) - Method in class com.sun.source.util. Trees

返回给定元素的Tree节点。

getTree(Element, AnnotationMirror) - Method in class com.sun.source.util. Trees

返回给定元素上的AnnotationMirror的Tree节点。

getTree(Element, AnnotationMirror, AnnotationValue) - Method in class com.sun.source.util. Trees

返回给定元素上AnnotationMirror的AnnotationValue的Tree节点。

getTree(ExecutableElement) - Method in class com.sun.source.util. Trees

返回给定ExecutableElement的MethodTree节点。

getTree(TypeElement) - Method in class com.sun.source.util. Trees

返回给定TypeElement的ClassTree节点。

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing. DefaultCellEditor

实现 TreeCellEditor界面。

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.tree. DefaultTreeCellEditor

配置编辑器。

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in interface javax.swing.tree. TreeCellEditor

设置编辑器的初始 值 。

getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - Method in class javax.swing.tree. DefaultTreeCellRenderer

根据传入的组件配置渲染器。

getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - Method in interface javax.swing.tree. TreeCellRenderer

将当前树状单元格的值设置为 value 。

getTreeColumn() - Method in class javafx.scene.control. TreeTableView

获取属性treeColumn的值。

getTreeComputerIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 TreeComputerIcon的实例。

getTreeControlIcon(boolean) - Static method in class javax.swing.plaf.metal. MetalIconFactory

构造一个新的实例 TreeControlIcon 。

getTreeExpansionListeners() - Method in class javax.swing. JTree

返回使用addTreeExpansionListener（）添加到此JTree的所有 TreeExpansionListener的数组。

getTreeFloppyDriveIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 TreeFloppyDriveIcon的实例。

getTreeFolderIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

构造一个新的实例 TreeFolderIcon 。

getTreeHardDriveIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回 TreeHardDriveIcon的实例。

getTreeItem() - Method in class javafx.scene.control. CheckBoxTreeItem.TreeModificationEvent

返回此事件发生的CheckBoxTreeItem。

getTreeItem() - Method in class javafx.scene.control. TreeCell

返回当前在此TreeCell中设置的TreeItem。

getTreeItem() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent

返回此事件发生的TreeItem。

getTreeItem() - Method in class javafx.scene.control. TreeTablePosition

返回TreeItem那背上TablePositionBase.getRow()行}。

getTreeItem() - Method in class javafx.scene.control. TreeTableRow

返回当前在此TreeTableRow中设置的TreeItem。

getTreeItem() - Method in class javafx.scene.control. TreeTableView.EditEvent

返回编辑发生的TreeItem 。

getTreeItem() - Method in class javafx.scene.control. TreeView.EditEvent

返回编辑发生的TreeItem 。

getTreeItem(int) - Method in class javafx.scene.control. TreeTableView

返回给定索引中的TreeItem，如果超出范围则返回null。

getTreeItem(int) - Method in class javafx.scene.control. TreeView

返回给定索引中的TreeItem，如果超出范围则返回null。

getTreeItemLevel(TreeItem<?>) - Method in class javafx.scene.control. TreeTableView

根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。

getTreeItemLevel(TreeItem<?>) - Method in class javafx.scene.control. TreeView

根据getParent（）可以递归调用的次数，返回给定TreeItem的“缩进”级别数。

getTreeLeafIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

构造一个新的实例 TreeLeafIcon 。

getTreeLock() - Method in class java.awt. Component

获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。

getTreeLock() - Method in class java.awt. MenuComponent

获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。

getTreeModelListeners() - Method in class javax.swing.tree. DefaultTreeModel

返回在此模型上注册的所有树模型侦听器的数组。

getTreePath() - Method in class com.sun.source.util. DocTreePath

返回与此路径相关联的TreePath。

getTreePath() - Method in class javax.swing.event. TreeModelEvent

对于所有事件，除了treeStructureChanged，返回已更改节点的父节点。

getTreeSelectionListeners() - Method in class javax.swing. JTree

返回使用addTreeSelectionListener（）添加到此JTree的所有 TreeSelectionListener的数组。

getTreeSelectionListeners() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回在此模型上注册的所有树选择侦听器的数组。

getTreeTableColumn() - Method in class javafx.scene.control. TreeTableColumn.CellDataFeatures

返回传递给构造函数的TreeTableColumn 。

getTreeTablePosition() - Method in class javafx.scene.control. TreeTableColumn.CellEditEvent

返回此事件发生的位置。

getTreeTableRow() - Method in class javafx.scene.control. TreeTableCell

getTreeTableView() - Method in class javafx.scene.control. TreeTableCell

获取属性treeTableView的值。

getTreeTableView() - Method in class javafx.scene.control. TreeTableColumn.CellDataFeatures

返回传递给构造函数的TableView 。

getTreeTableView() - Method in class javafx.scene.control. TreeTableColumn.CellEditEvent

返回发生此事件的TableView。

getTreeTableView() - Method in class javafx.scene.control. TreeTableColumn

获取属性treeTableView的值。

getTreeTableView() - Method in class javafx.scene.control. TreeTablePosition

TreeTablePosition与此TreeTablePosition相关。

getTreeTableView() - Method in class javafx.scene.control. TreeTableRow

返回与此TreeTableCell关联的TreeTableView。

getTreeTableView() - Method in class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel

返回安装此选择模型的TreeTableView实例。

getTreeView() - Method in class javafx.scene.control. TreeCell

返回与此TreeCell关联的TreeView。

getTreeWillExpandListeners() - Method in class javax.swing. JTree

返回使用addTreeWillExpandListener（）添加到此JTree的所有 TreeWillExpandListener的数组。

getTrigger() - Method in class java.awt.dnd. DragSourceContext

返回最初触发拖动的 DragGestureEvent 。

getTrigger() - Method in class javax.management.monitor. MonitorNotification

获取触发此监视器通知的阈值/字符串（取决于监视器类型）。

getTriggerEvent() - Method in class java.awt.dnd. DragGestureEvent

返回触发手势的初始事件。

getTriggerEvent() - Method in class java.awt.dnd. DragGestureRecognizer

此方法返回启动拖放操作的一系列事件中的第一个事件。

getTrueExpression() - Method in interface com.sun.source.tree. ConditionalExpressionTree

如果条件为真，返回要评估的表达式。

getTrueExpression() - Method in interface jdk.nashorn.api.tree. ConditionalExpressionTree

返回这个三元表达式的真实部分。

getTrustAnchor() - Method in class java.security.cert. PKIXCertPathValidatorResult

返回描述作为证书路径的信任锚点的CA的 TrustAnchor 。

getTrustAnchors() - Method in class java.security.cert. PKIXParameters

返回一个不可变的 Set最受信任的CA。

getTrustedCert() - Method in class java.security.cert. TrustAnchor

返回最受信任的CA证书。

getTrustedCertificate() - Method in class java.security. KeyStore.TrustedCertificateEntry

从此条目获取值得信赖的 Certficate 。

getTrustManagers() - Method in class javax.net.ssl. TrustManagerFactory

为每种类型的信任资料返回一位信托管理员。

getTsa() - Method in class jdk.security.jarsigner. JarSigner

返回时间戳局（TSA）的URI。

getTSADigestAlg() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索用于生成要发送到TSA服务器的消息印记的消息摘要算法。

getTSAPolicyID() - Method in interface com.sun.jarsigner. ContentSignerParameters

已过时。

检索时间戳权限（TSA）的TSAPolicyID。

getTTL() - Method in class java.net. DatagramSocketImpl

已过时。
使用getTimeToLive代替。

getTTL() - Method in class java.net. MulticastSocket

已过时。
使用getTimeToLive方法，它返回一个int而不是一个字节 。

getTx() - Method in class javafx.scene.transform. Affine

获取属性tx的值。

getTx() - Method in class javafx.scene.transform. Rotate

getTx() - Method in class javafx.scene.transform. Scale

getTx() - Method in class javafx.scene.transform. Shear

getTx() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的X坐标转换元素。

getTx() - Method in class javafx.scene.transform. Translate

getTy() - Method in class javafx.scene.transform. Affine

获取属性值的值。

getTy() - Method in class javafx.scene.transform. Rotate

getTy() - Method in class javafx.scene.transform. Scale

getTy() - Method in class javafx.scene.transform. Shear

getTy() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的Y坐标转换元素。

getTy() - Method in class javafx.scene.transform. Translate

getType() - Method in class com.sun.security.jgss. AuthorizationDataEntry

获取广告类型字段。

getType() - Method in interface com.sun.source.doctree. SerialFieldTree

返回串行字段的类型。

getType() - Method in interface com.sun.source.tree. ArrayTypeTree

返回此数组类型的元素类型。

getType() - Method in interface com.sun.source.tree. InstanceOfTree

返回要检查的类型。

getType() - Method in interface com.sun.source.tree. NewArrayTree

返回表达式的基本类型。

getType() - Method in interface com.sun.source.tree. ParameterizedTypeTree

返回基本类型。

getType() - Method in interface com.sun.source.tree. TypeCastTree

返回转换的目标类型。

getType() - Method in interface com.sun.source.tree. VariableTree

返回正在声明的变量的类型。

getType() - Method in class java.awt.color. ColorSpace

返回此ColorSpace的颜色空间类型（例如TYPE_RGB，TYPE_XYZ，...）。

getType() - Method in class java.awt. Cursor

返回此游标的类型。

getType() - Method in class java.awt.font. GlyphMetrics

返回原始字形类型代码。

getType() - Method in class java.awt.geom. AffineTransform

检索描述此转换的转换属性的标志位。

getType() - Method in class java.awt. GraphicsDevice

返回此类型 GraphicsDevice 。

getType() - Method in class java.awt.image. BufferedImage

返回图像类型。

getType() - Method in class java.awt. Window

返回窗口的类型。

getType() - Method in class java.io. ObjectStreamField

获取字段的类型。

getType() - Method in interface java.lang.management. MemoryPoolMXBean

返回此内存池的类型。

getType() - Method in interface java.lang.reflect. AnnotatedType

返回此注释类型表示的基础类型。

getType() - Method in class java.lang.reflect. Field

返回一个 Class对象，标识由该 Field对象表示的字段的声明类型。

getType() - Method in class java.lang.reflect. Parameter

返回一个 Class对象，该对象标识由此 Parameter对象表示的参数的声明类型。

getType() - Method in class java.security.cert. Certificate

返回此证书的类型。

getType() - Method in class java.security.cert. CertificateFactory

返回与该证书工厂相关联的证书类型的名称。

getType() - Method in class java.security.cert. CertPath

返回此认证路径中的 Certificate的类型。

getType() - Method in class java.security.cert. CertStore

返回此 CertStore的类型。

getType() - Method in class java.security.cert. CRL

返回此CRL的类型。

getType() - Method in class java.security. KeyStore

返回此密钥库的类型。

getType() - Method in class java.security. Policy

返回此策略的类型。

getType() - Method in class java.security. Provider.Service

获取此服务的类型。

getType() - Method in interface java.sql. ResultSet

检索此 ResultSet对象的类型。

getType() - Method in class javafx.application. Preloader.StateChangeNotification

返回通知的类型。

getType() - Method in class javafx.scene.image. PixelFormat

返回表示由此 PixelFormat对象管理的像素的存储格式的枚举。

getType() - Method in class javafx.scene.layout. BorderStrokeStyle

定义将strokeWidth应用于形状边界的方向（内部，外部或两者）。

getType() - Method in exception javafx.scene.media. MediaException

检索此错误所在的类别。

getType() - Method in class javafx.scene.shape. Arc

获取属性类型的值。

getType() - Method in interface javax.accessibility. AccessibleTableModelChange

返回事件的类型。

getType() - Method in class javax.imageio.plugins.tiff. TIFFField

返回字段中存储的数据类型。

getType() - Method in class javax.jnlp. DownloadService2.ResourceSpec

返回此资源的类型。

getType() - Method in class javax.management. MBeanAttributeInfo

返回属性的类名。

getType() - Method in class javax.management. MBeanParameterInfo

返回数据的类型或类名。

getType() - Method in class javax.management. Notification

获取通知类型。

getType() - Method in class javax.naming.event. NamingEvent

返回此事件的类型。

getType() - Method in class javax.naming.ldap. Rdn

检索此Rdn类型之一。

getType() - Method in class javax.naming. RefAddr

检索此地址的地址类型。

getType() - Method in class javax.net.ssl. SNIMatcher

返回此 SNIMatcher对象的服务器名称类型。

getType() - Method in class javax.net.ssl. SNIServerName

返回此服务器名称的名称类型。

getType() - Method in class javax.security.auth.login. Configuration

返回此配置的类型。

getType() - Method in class javax.smartcardio. TerminalFactory

返回此TerminalFactory的类型。

getType() - Method in class javax.sound.midi. MetaMessage

获得 MetaMessage的类型。

getType() - Method in class javax.sound.midi. MidiFileFormat

获取MIDI文件类型。

getType() - Method in class javax.sound.sampled. AudioFileFormat

获取音频文件类型，如 WAVE或 AU 。

getType() - Method in class javax.sound.sampled. Control

获取控件的类型。

getType() - Method in class javax.sound.sampled. LineEvent

获取事件的类型。

getType() - Method in class javax.sql.rowset. BaseRowSet

返回此 RowSet对象的类型。

getType() - Method in interface javax.swing.event. DocumentEvent

获取事件的类型。

getType() - Method in class javax.swing.event. ListDataEvent

返回事件类型。

getType() - Method in class javax.swing.event. RowSorterEvent

返回事件的类型。

getType() - Method in class javax.swing.event. TableModelEvent

返回事件的类型 - 其中之一：INSERT，UPDATE和DELETE。

getType() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange

返回类型。

getType() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

返回事件的类型。

getType() - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

获取元素类型。

getType() - Method in class javax.swing.text.html.parser. AttributeList

getType() - Method in class javax.swing.text.html.parser. Element

获取类型。

getType() - Method in class javax.swing.text.html.parser. Entity

获取实体的类型。

getType() - Method in interface javax.xml.crypto. URIReference

返回此URI引用的数据类型。

getType() - Method in interface jdk.nashorn.api.tree. InstanceOfTree

返回类型表达式。

getType() - Method in interface org.w3c.dom.css. CSSRule

规则的类型，如上所定义。

getType() - Method in interface org.w3c.dom. DOMError

A DOMString ，其中指出在 relatedData预期哪些相关数据。

getType() - Method in interface org.w3c.dom.events. Event

事件的名称（不区分大小写）。

getType() - Method in interface org.w3c.dom.html. HTMLAnchorElement

咨询内容类型。

getType() - Method in interface org.w3c.dom.html. HTMLButtonElement

按钮的类型。

getType() - Method in interface org.w3c.dom.html. HTMLInputElement

创建的控件类型。

getType() - Method in interface org.w3c.dom.html. HTMLLIElement

列出项目项目符号样式。

getType() - Method in interface org.w3c.dom.html. HTMLLinkElement

咨询内容类型。

getType() - Method in interface org.w3c.dom.html. HTMLObjectElement

通过 data属性下载的数据的内容类型。

getType() - Method in interface org.w3c.dom.html. HTMLOListElement

编号风格

getType() - Method in interface org.w3c.dom.html. HTMLParamElement

当 valuetype的值为“ref”时， value属性的内容类型。

getType() - Method in interface org.w3c.dom.html. HTMLScriptElement

脚本语言的内容类型。

getType() - Method in interface org.w3c.dom.html. HTMLSelectElement

此表单控件的类型。

getType() - Method in interface org.w3c.dom.html. HTMLStyleElement

内容类型pf样式表语言。

getType() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

此表单控件的类型。

getType() - Method in interface org.w3c.dom.html. HTMLUListElement

子弹风格。

getType() - Method in interface org.w3c.dom.stylesheets. StyleSheet

这将指定此样式表的样式表语言。

getType(char) - Static method in class java.lang. Character

返回一个值，表示一个字符的一般类别。

getType(int) - Static method in class java.lang. Character

返回一个值，表示一个字符的一般类别。

getType(int) - Method in interface org.xml.sax. AttributeList

已过时。

返回列表中的属性类型（按位置）。

getType(int) - Method in interface org.xml.sax. Attributes

通过索引查找属性的类型。

getType(int) - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

获取属性的类型（按位置）。

getType(int) - Method in class org.xml.sax.helpers. AttributesImpl

通过索引返回属性的类型。

getType(String) - Method in class javax.management.openmbean. CompositeType

返回 开放类型 ，其名称为 itemName，或该项目的 null如果 CompositeType实例不定义其名称为 itemName的任何项目。

getType(String) - Method in interface org.xml.sax. AttributeList

已过时。

返回列表中的属性类型（按名称）。

getType(String) - Method in interface org.xml.sax. Attributes

通过XML合格（前缀）名称查找属性的类型。

getType(String) - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

获取属性的类型（按名称）。

getType(String) - Method in class org.xml.sax.helpers. AttributesImpl

通过合格（前缀）名称查找属性的类型。

getType(String, String) - Method in interface org.xml.sax. Attributes

通过命名空间名称查找属性的类型。

getType(String, String) - Method in class org.xml.sax.helpers. AttributesImpl

通过Namespace限定名称查找属性的类型。

getTypeAlternatives() - Method in interface com.sun.source.tree. UnionTypeTree

返回替代类型表达式。

getTypeArguments() - Method in interface com.sun.source.tree. MemberReferenceTree

返回引用的类型参数。

getTypeArguments() - Method in interface com.sun.source.tree. MethodInvocationTree

返回此方法调用的类型参数。

getTypeArguments() - Method in interface com.sun.source.tree. NewClassTree

返回正在创建的对象的类型参数。

getTypeArguments() - Method in interface com.sun.source.tree. ParameterizedTypeTree

返回类型参数。

getTypeArguments() - Method in interface javax.lang.model.type. DeclaredType

返回此类型的实际类型参数。

getTypeByName(String) - Static method in class javax.imageio.plugins.tiff. TIFFField

返回与提供的数据类型名称相对应的数据类型常量。

getTypeCode() - Method in class java.io. ObjectStreamField

返回字段类型的字符编码。

getTypeCode() - Method in enum javafx.scene.control. ButtonBar.ButtonData

返回 button order字符串中用于表示ButtonData注释的单个字符代码。

getTypeConverter(Class<?>, Class<?>) - Method in interface jdk.dynalink.linker. LinkerServices

给定一个源和目标类型，返回一个在它们之间进行转换的方法句柄。

getTypeDecls() - Method in interface com.sun.source.tree. CompilationUnitTree

返回此编译单元中出现的类型声明。

getTypeDescription(File) - Method in class javax.swing.filechooser. FileView

对文件类型的可读描述。

getTypeDescription(File) - Method in class javax.swing. JFileChooser

返回文件类型。

getTypeDescription(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

对文件类型的可读描述。

getTypeElement() - Method in class com.sun.source.util. TaskEvent

返回此事件的type元素。

getTypeElement(CharSequence) - Method in interface javax.lang.model.util. Elements

如果类型元素在环境中是唯一的，则返回给出其规范名称的类型元素。

getTypeElement(ModuleElement, CharSequence) - Method in interface javax.lang.model.util. Elements

返回给定其规范名称的类型元素，从给定的模块中可以看出。

getTypeInfo() - Method in interface java.sql. DatabaseMetaData

检索此数据库支持的所有数据类型的描述。

getTypeInfoProvider() - Method in class javax.xml.validation. ValidatorHandler

获得TypeInfoProvider实现这一点ValidatorHandler 。

getTypeMap() - Method in interface java.sql. Connection

检索 Map与此相关联的对象 Connection对象。

getTypeMap() - Method in class javax.sql.rowset. BaseRowSet

检索与该关联的类型映射 Connection对象此 RowSet对象。

getTypeMap() - Method in interface javax.sql. RowSet

检索与此 Map对象关联的 RowSet对象，该对象指定SQL用户定义类型的自定义映射（如果有）。

getTypeMirror() - Method in exception javax.lang.model.type. MirroredTypeException

返回与正在访问的类型相对应的类型镜像。

getTypeMirror(TreePath) - Method in class com.sun.source.util. Trees

返回给定TreePath标识的Tree节点的TypeMirror。

getTypeMirror(Iterable<? extends Tree>) - Method in class com.sun.source.util. JavacTask

返回由指定路径确定的树节点的类型镜像。

getTypeMirrors() - Method in exception javax.lang.model.type. MirroredTypesException

返回与正在访问的类型相对应的类型镜像。

getTypeName() - Method in class java.lang. Class

为此类型的名称返回一个内容丰富的字符串。

getTypeName() - Method in interface java.lang.reflect. Type

返回描述此类型的字符串，包括有关任何类型参数的信息。

getTypeName() - Method in class javax.management.openmbean. OpenType

返回此 OpenType实例的名称。

getTypeName() - Method in interface org.w3c.dom. TypeInfo

为关联的元素或属性声明的类型的名称，如果未知， null 。

getTypeName(int) - Static method in class javax.imageio.plugins.tiff. TIFFField

返回提供的数据类型常量的名称。

getTypeNamespace() - Method in interface org.w3c.dom. TypeInfo

如果该元素没有声明或没有命名空间信息可用， null相关元素或属性声明的类型的命名空间或 null 。

getTypeParameters() - Method in interface com.sun.source.tree. ClassTree

返回此类型声明的任何类型参数。

getTypeParameters() - Method in interface com.sun.source.tree. MethodTree

返回正在声明的方法的类型参数。

getTypeParameters() - Method in class java.lang. Class

返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

getTypeParameters() - Method in class java.lang.reflect. Constructor

返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

getTypeParameters() - Method in class java.lang.reflect. Executable

返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

getTypeParameters() - Method in interface java.lang.reflect. GenericDeclaration

返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

getTypeParameters() - Method in class java.lang.reflect. 方法

返回一个 TypeVariable对象的数组，表示由该 GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。

getTypeParameters() - Method in interface javax.lang.model.element. ExecutableElement

以声明顺序返回此可执行文件的正式类型参数。

getTypeParameters() - Method in interface javax.lang.model.element. Parameterizable

以声明顺序返回元素的形式类型参数。

getTypeParameters() - Method in interface javax.lang.model.element. TypeElement

以声明顺序返回此类型元素的形式类型参数。

getTypes() - Method in class com.sun.source.util. JavacTask

返回用于处理类型镜像的实用程序对象。

getTypeSelector() - Method in interface javafx.css. Styleable

这种 Styleable的类型用于选择器匹配。

getTypeSelector() - Method in class javafx.scene.control. MenuItem

这种 Styleable的类型用于选择器匹配。

getTypeSelector() - Method in class javafx.scene.control. PopupControl

这种 Styleable的类型用于选择器匹配。

getTypeSelector() - Method in class javafx.scene.control. Tab

这种 Styleable的类型用于选择器匹配。

getTypeSelector() - Method in class javafx.scene.control. TableColumn

这种 Styleable的类型用于选择器匹配。

getTypeSelector() - Method in class javafx.scene.control. TreeTableColumn

这种 Styleable的类型用于选择器匹配。

getTypeSelector() - Method in class javafx.scene. Node

这种 Styleable的类型用于选择器匹配。

getTypeString() - Method in class java.io. ObjectStreamField

返回JVM类型签名。

getTypeUtils() - Method in interface javax.annotation.processing. ProcessingEnvironment

返回一些用于对类型进行操作的实用方法的实现。

getTypeUtils() - Method in interface jdk.javadoc.doclet. DocletEnvironment

返回一个 Types实用程序类的实例。

getTypeVariables() - Method in interface javax.lang.model.type. ExecutableType

返回由此可执行文件的形式类型参数声明的类型变量。

getTz() - Method in class javafx.scene.transform. Affine

获取属性tz的值。

getTz() - Method in class javafx.scene.transform. Rotate

getTz() - Method in class javafx.scene.transform. Scale

getTz() - Method in class javafx.scene.transform. Transform

获取3x4矩阵的Z坐标转换元素。

getTz() - Method in class javafx.scene.transform. Translate

getUDTs(String, String, String, int[]) - Method in interface java.sql. DatabaseMetaData

检索在特定模式中定义的用户定义类型（UDT）的描述。

getUI() - Method in class javax.swing. AbstractButton

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JColorChooser

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JComboBox

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JComponent

返回渲染此组件的外观和委托。

getUI() - Method in class javax.swing. JDesktopPane

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JFileChooser

获取实现此组件的L＆F的UI对象。

getUI() - Method in class javax.swing. JInternalFrame

返回渲染此组件的外观和对象。

getUI() - Method in class javax.swing. JInternalFrame.JDesktopIcon

返回渲染此组件的外观和对象。

getUI() - Method in class javax.swing. JLabel

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JLayer

返回LayerUI为这个JLayer 。

getUI() - Method in class javax.swing. JList

返回 ListUI ，呈现此组件的外观和感觉对象。

getUI() - Method in class javax.swing. JMenuBar

返回菜单栏当前的UI。

getUI() - Method in class javax.swing. JOptionPane

返回实现该组件的L＆F的UI对象。

getUI() - Method in class javax.swing. JPanel

返回渲染此组件的外观和感觉（L＆amp; F）对象。

getUI() - Method in class javax.swing. JPopupMenu

返回渲染此组件的外观和感觉（L＆F）对象。

getUI() - Method in class javax.swing. JProgressBar

返回渲染此组件的外观和对象。

getUI() - Method in class javax.swing. JRootPane

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JScrollBar

返回实现该组件外观的委托。

getUI() - Method in class javax.swing. JScrollPane

返回渲染此组件的外观和感觉（L＆F）对象。

getUI() - Method in class javax.swing. JSeparator

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JSlider

获取实现此组件的L＆F的UI对象。

getUI() - Method in class javax.swing. JSpinner

返回渲染此组件的外观和感觉（L＆F）对象。

getUI() - Method in class javax.swing. JSplitPane

返回提供当前外观的 SplitPaneUI 。

getUI() - Method in class javax.swing. JTabbedPane

返回实现该组件的L＆F的UI对象。

getUI() - Method in class javax.swing. JTable

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JToolBar

返回工具栏的当前UI。

getUI() - Method in class javax.swing. JToolTip

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JTree

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing. JViewport

返回渲染此组件的L＆F对象。

getUI() - Method in class javax.swing.table. JTableHeader

返回渲染此组件的外观和感觉（L＆F）对象。

getUI() - Method in class javax.swing.text. JTextComponent

获取此面向文本的编辑器的用户界面工厂。

getUI(int, String) - Method in class javax.print. ServiceUIFactory

获取UI对象，该对象可能被应用程序转换为请求的UI类型，并在其用户界面中使用。

getUI(JComponent) - Method in class javax.swing. UIDefaults

为指定的组件创建一个 ComponentUI实现。

getUI(JComponent) - Static method in class javax.swing. UIManager

返回相应 ComponentUI实施 target 。

getUIActionMap(JComponent) - Static method in class javax.swing. SwingUtilities

返回UI在组件 component提供的ActionMap。

getUIClass(String) - Method in class javax.swing. UIDefaults

返回呈现此组件的L＆F类。

getUIClass(String, ClassLoader) - Method in class javax.swing. UIDefaults

get(uidClassID)的值必须是实现相应的 ComponentUI类的类的 String名称。

getUIClassID() - Method in class javax.swing. JButton

返回一个字符串，它指定呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JCheckBox

返回一个字符串，它指定呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JCheckBoxMenuItem

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JColorChooser

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JComboBox

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JComponent

返回 UIDefaults键，用于查找定义该组件的外观的 swing.plaf.ComponentUI类的名称。

getUIClassID() - Method in class javax.swing. JDesktopPane

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JEditorPane

获取UI的类ID。

getUIClassID() - Method in class javax.swing. JFileChooser

返回一个字符串，它指定呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JFormattedTextField

获取UI的类ID。

getUIClassID() - Method in class javax.swing. JInternalFrame

返回呈现此组件的look-and-feel类的名称。

getUIClassID() - Method in class javax.swing. JInternalFrame.JDesktopIcon

返回呈现此组件的look-and-feel类的名称。

getUIClassID() - Method in class javax.swing. JLabel

返回一个字符串，指定呈现此组件的l＆f类的名称。

getUIClassID() - Method in class javax.swing. JList

返回 "ListUI" ，该 UIDefaults用于查找该名关键 javax.swing.plaf.ListUI类定义的外观和感觉这个组件。

getUIClassID() - Method in class javax.swing. JMenu

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JMenuBar

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JMenuItem

返回用于构造用于呈现此组件的L＆F类的名称的后缀。

getUIClassID() - Method in class javax.swing. JOptionPane

返回实现该组件的L＆F的UI类的名称。

getUIClassID() - Method in class javax.swing. JPanel

返回一个字符串，它指定呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JPasswordField

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JPopupMenu

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JPopupMenu.Separator

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JProgressBar

返回呈现此组件的look-and-feel类的名称。

getUIClassID() - Method in class javax.swing. JRadioButton

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JRadioButtonMenuItem

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JRootPane

返回一个字符串，它指定呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JScrollBar

返回此组件的LookAndFeel类的名称。

getUIClassID() - Method in class javax.swing. JScrollPane

返回用于构造用于呈现此组件的L＆F类的名称的后缀。

getUIClassID() - Method in class javax.swing. JSeparator

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JSlider

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JSpinner

返回用于构造用于渲染此组件的外观（L＆F）类的名称的后缀。

getUIClassID() - Method in class javax.swing. JSplitPane

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JTabbedPane

返回实现该组件的L＆F的UI类的名称。

getUIClassID() - Method in class javax.swing. JTable

返回用于构造用于呈现此组件的L＆F类的名称的后缀。

getUIClassID() - Method in class javax.swing. JTextArea

返回UI的类ID。

getUIClassID() - Method in class javax.swing. JTextField

获取UI的类ID。

getUIClassID() - Method in class javax.swing. JTextPane

返回UI的类ID。

getUIClassID() - Method in class javax.swing. JToggleButton

返回一个字符串，指定呈现此组件的l＆f类的名称。

getUIClassID() - Method in class javax.swing. JToolBar

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JToolBar.Separator

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JToolTip

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JTree

返回呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing. JViewport

返回一个字符串，它指定呈现此组件的L＆F类的名称。

getUIClassID() - Method in class javax.swing.table. JTableHeader

返回用于构造用于渲染此组件的外观（L＆F）类的名称的后缀。

getUIClassNamesForRole(int) - Method in class javax.print. ServiceUIFactory

给定从这个工厂获得的UI角色，获取从这个工厂实现这个角色的UI类型。

getUid() - Method in class com.sun.security.auth.module. SolarisSystem

已过时。

获取当前Solaris用户的UID。

getUid() - Method in class com.sun.security.auth.module. UnixSystem

获取当前Unix用户的UID。

getUIError(String) - Method in class javax.swing. UIDefaults

如果由于任何原因 getUI()失败，则在返回 null之前调用此方法。

getUIInputMap(JComponent, int) - Static method in class javax.swing. SwingUtilities

返回由组件 component条件 condition的UI提供的InputMap。

getUIs() - Method in class javax.swing.plaf.multi. MultiButtonUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiColorChooserUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiComboBoxUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiFileChooserUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiLabelUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiListUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiMenuBarUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiMenuItemUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiPanelUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiProgressBarUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiRootPaneUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiScrollBarUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiSeparatorUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiSliderUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiSpinnerUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiTableUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiTextUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiToolBarUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiToolTipUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiTreeUI

返回与此复用UI相关联的UI列表。

getUIs() - Method in class javax.swing.plaf.multi. MultiViewportUI

返回与此复用UI相关联的UI列表。

getUlx() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性ulx的值。

getUly() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性的值。

getUnallocatedSpace() - Method in class java.nio.file. FileStore

返回文件存储区中未分配字节的数量。

getUnarrivedParties() - Method in class java.util.concurrent. Phaser

返回尚未到达此移相器当前阶段的已注册方的数量。

getUnboundInstance() - Static method in class javax.security.auth.kerberos. KeyTab

返回默认未绑定的 KeyTab实例。

getUnboundInstance(File) - Static method in class javax.security.auth.kerberos. KeyTab

从 File对象返回未绑定的 KeyTab实例。

getUncaughtExceptionHandler() - Method in class java.lang. Thread

返回由于未捕获的异常，此线程突然终止时调用的处理程序。

getUncaughtExceptionHandler() - Method in class java.util.concurrent. ForkJoinPool

返回由于在执行任务时遇到不可恢复的错误而终止的内部工作线程的处理程序。

getUndeclaredThrowable() - Method in exception java.lang.reflect. UndeclaredThrowableException

返回包含在这个 UndeclaredThrowableException中的 Throwable实例，可能是 null 。

getUnderlineOffset() - Method in class java.awt.font. LineMetrics

返回下划线相对于基线的位置。

getUnderlineShape(int, int) - Method in class javafx.scene.control.skin. TextAreaSkin

getUnderlineShape(int, int) - Method in class javafx.scene.control.skin. TextFieldSkin

getUnderlineShape(int, int) - Method in class javafx.scene.control.skin. TextInputControlSkin

getUnderlineThickness() - Method in class java.awt.font. LineMetrics

返回下划线的厚度。

getUnderlyingType() - Method in interface com.sun.source.tree. AnnotatedTypeTree

返回与注释关联的底层类型。

getUndoableEditListeners() - Method in class javax.swing.text. AbstractDocument

返回在此文档中注册的所有可撤销编辑监听器的数组。

getUndoableEditListeners() - Method in class javax.swing.undo. UndoableEditSupport

返回使用addUndoableEditListener（）添加到此UndoableEditSupport的所有 UndoableEditListener的数组。

getUndoOrRedoPresentationName() - Method in class javax.swing.undo. UndoManager

方便方法返回 getUndoPresentationName或 getRedoPresentationName 。

getUndoPresentationName() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

提供本编辑的可撤销形式的本地化，可读的描述，例如用作撤消菜单项。

getUndoPresentationName() - Method in class javax.swing.undo. AbstractUndoableEdit

使用键值 AbstractUndoableEdit.undoText从默认表格中检索值，并返回该值后跟一个空格，后跟 getPresentationName 。

getUndoPresentationName() - Method in class javax.swing.undo. CompoundEdit

从最后 UndoableEdit返回 getUndoPresentationName添加到 edits 。

getUndoPresentationName() - Method in interface javax.swing.undo. UndoableEdit

返回适用于例如撤消菜单项的此编辑的可撤销形式的本地化，可读的描述。

getUndoPresentationName() - Method in class javax.swing.undo. UndoManager

返回此修改的可撤销形式的描述。

getUnexecutedModifications() - Method in exception javax.naming.directory. AttributeModificationException

检索未执行的修改列表。

getUnicodeBidi() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的unicode-bidi属性定义。

getUnicodeLocaleAttributes() - Method in class java.util. Locale

返回与此区域设置关联的unicode区域设置属性集，如果没有属性，则返回空集合。

getUnicodeLocaleKeys() - Method in class java.util. Locale

返回此区域设置定义的Unicode区域设置键的集合，如果此区域设置没有，则返回空集合。

getUnicodeLocaleType(String) - Method in class java.util. Locale

返回与该区域设置的指定Unicode区域设置键相关联的Unicode区域设置类型。

getUnicodeStream(int) - Method in interface java.sql. ResultSet

已过时。
使用getCharacterStream代替getUnicodeStream

getUnicodeStream(String) - Method in interface java.sql. ResultSet

已过时。
请改用getCharacterStream

getUnitIncrement() - Method in interface java.awt. Adjustable

获取可调整对象的单位增量。

getUnitIncrement() - Method in class java.awt. Scrollbar

获取此滚动条的单位增量。

getUnitIncrement() - Method in class java.awt. ScrollPaneAdjustable

getUnitIncrement() - Method in class javafx.scene.control. ScrollBar

获取属性unitIncrement的值。

getUnitIncrement() - Method in class javax.swing. JScrollBar

为了向后兼容java.awt.Scrollbar。

getUnitIncrement(int) - Method in class javax.swing. JScrollBar

给出单位加/减请求，返回滚动条的值的更改量。

getUnitIncrement(int) - Method in class javax.swing. JScrollPane.ScrollBar

如果视口的视图为 Scrollable对象，则计算滚动的单位增量。

getUnits() - Method in interface java.time.chrono. ChronoPeriod

获取此期间支持的单位集。

getUnits() - Method in class java.time. Duration

获取此持续时间支持的单位集。

getUnits() - Method in class java.time. Period

获取此期间支持的单位集。

getUnits() - Method in interface java.time.temporal. TemporalAmount

返回唯一定义此TemporalAmount值的单位列表。

getUnits() - Method in class javafx.css. Size

返回单位

getUnits() - Method in class javax.sound.sampled. FloatControl

获取表示控件值的单位的标签，例如“dB”或“每秒帧数”。

getUnitsToScroll() - Method in class java.awt.event. MouseWheelEvent

这是一个方便的方法来帮助实现常用的MouseWheelListener - 将ScrollPane或JScrollPane滚动一个符合平台设置的量。

getUnknownAnnotationValue() - Method in exception javax.lang.model.element. UnknownAnnotationValueException

返回未知的注释值。

getUnknownDirective() - Method in exception javax.lang.model.element. UnknownDirectiveException

返回未知指令。

getUnknownElement() - Method in exception javax.lang.model.element. UnknownElementException

返回未知元素。

getUnknownTree() - Method in exception jdk.nashorn.api.tree. UnknownTreeException

返回未知树。

getUnknownType() - Method in exception javax.lang.model.type. UnknownTypeException

返回未知类型。

getUnloadedClassCount() - Method in interface java.lang.management. ClassLoadingMXBean

返回从Java虚拟机开始执行以来卸载的类的总数。

getUnmarshallerHandler() - Method in interface javax.xml.bind. Unmarshaller

获取可以用作XML管道中组件的解组员处理程序对象。

getUnnamed() - Method in class javafx.application. Application.Parameters

检索未命名参数的只读列表。

getUnnamedModule() - Method in class java.lang. ClassLoader

返回此类加载器的未命名的 Module 。

getUnnormalizedComponents(float[], int, int[], int) - Method in class java.awt.image. ColorModel

给定一个归一化的组件数组，以非规范化形式返回所有颜色/ alpha分量的数组。

getUnnormalizedComponents(float[], int, int[], int) - Method in class java.awt.image. ComponentColorModel

给定一个归一化的组件数组，以非规范化形式返回所有颜色/ alpha分量的数组。

getUnresolvedActions() - Method in class java.security. UnresolvedPermission

获取尚未解决的基础权限的操作。

getUnresolvedCerts() - Method in class java.security. UnresolvedPermission

获取尚未解决的底层权限的签名者证书（无任何支持链）。

getUnresolvedName() - Method in class java.security. UnresolvedPermission

获取尚未解决的基础权限的目标名称。

getUnresolvedType() - Method in class java.security. UnresolvedPermission

获取尚未解决的基础权限的类型（类名）。

getUnsupportedAttributes() - Method in interface javax.print. AttributeException

返回Print Service实例根本不支持该属性的打印属性类的数组，如果没有这样的属性，则返回null。

getUnsupportedAttributes(DocFlavor, AttributeSet) - Method in interface javax.print. PrintService

在特定DocFlavor的上下文中标识不支持打印请求的属性。

getUnsupportedFlavors() - Method in interface javax.print. FlavorException

返回不支持的风格。

getUnsupportedURI() - Method in interface javax.print. URIException

返回URI。

getUnsupportedValues() - Method in interface javax.print. AttributeException

返回Print Service实例支持该属性的打印属性数组，但不支持该属性的特定值;如果没有此属性值，则返回null。

getUnwrappedParent(Component) - Static method in class javax.swing. SwingUtilities

返回component的第一个祖先，而不是JLayer的一个实例。

getUnwrappedView(JViewport) - Static method in class javax.swing. SwingUtilities

返回第 JViewport的后代，不是 JLayer的实例。

getUpdate() - Method in interface com.sun.source.tree. ForLoopTree

返回 for语句的更新表达式。

getUpdate() - Method in interface jdk.nashorn.api.tree. ForLoopTree

返回此'for'语句的更新表达式。

getUpdateAction() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

返回更新操作。

getUpdateAvailableResources(DownloadService2.ResourceSpec) - Method in interface javax.jnlp. DownloadService2

返回缓存中与指定的资源规范之一匹配的所有资源，并具有从其服务器可用的更新。

getUpdateCount() - Method in interface java.sql. Statement

将当前结果作为更新计数检索; 如果结果是一个ResultSet对象或没有更多结果，则返回-1。

getUpdateCounts() - Method in exception java.sql. BatchUpdateException

检索在发生此异常之前成功执行的批量更新中每个更新语句的更新计数。

getUpdateLevel() - Method in class javax.swing.undo. UndoableEditSupport

返回更新级别值。

getUpdatePeriod() - Method in class javax.sound.sampled. FloatControl

获取最小时间间隔（以微秒为单位），控制的值可以在换档期间改变。

getUpdatePolicy() - Method in class javax.swing.text. DefaultCaret

获取有关文档更新的插入符号移动策略。

getUpdateRect() - Method in class java.awt.event. PaintEvent

返回表示需要重绘的区域的矩形，以响应此事件。

getUpdateSelectionOnSort() - Method in class javax.swing. JTable

如果选择应在排序后更新，则返回true。

getUpdateTableInRealTime() - Method in class javax.swing.table. JTableHeader

作为Java 2平台v1.3的过时。

getUpperBound() - Method in class javafx.scene.chart. ValueAxis

获取属性upperBound的值。

getUpperBound() - Method in interface javax.lang.model.type. TypeVariable

返回此类型变量的上限。

getUpperBounds() - Method in interface java.lang.reflect. WildcardType

返回表示此类型变量的上限的 Type对象的数组。

getUptime() - Method in interface java.lang.management. RuntimeMXBean

以毫秒为单位返回Java虚拟机的正常运行时间。

getUri() - Method in interface org.w3c.dom. DOMLocator

该定位器指向的URI，如果没有URI可用， null 。

getURI() - Method in class java.awt.desktop. OpenURIEvent

获取 URI的应用程序被要求打开

getURI() - Method in class java.security.cert. URICertStoreParameters

返回用于构造此 URICertStoreParameters对象的URI。

getURI() - Method in class java.security. URIParameter

返回URI。

getURI() - Method in class javax.print.attribute. URISyntax

返回此URI属性的URI值。

getURI() - Method in interface javax.xml.crypto.dsig.keyinfo. RetrievalMethod

返回引用的 KeyInfo信息的URI。

getURI() - Method in class javax.xml.crypto. OctetStreamData

返回标识由此 OctetStreamData表示的数据对象的URI字符串。

getURI() - Method in interface javax.xml.crypto. URIReference

返回引用的数据对象的URI。

getURI() - Method in interface javax.xml.soap. Name

返回此 Name对象表示的XML名称的命名空间的URI。

getURI(int) - Method in interface org.xml.sax. Attributes

通过索引查找属性的Namespace URI。

getURI(int) - Method in class org.xml.sax.helpers. AttributesImpl

返回属性的命名空间URI。

getURI(String) - Method in class org.xml.sax.helpers. NamespaceSupport

查找前缀并获取当前映射的命名空间URI。

getURIDereferencer() - Method in class javax.xml.crypto.dom. DOMCryptoContext

getURIDereferencer() - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

返回对URIDereferencer引用，默认情况下，它用于取消引用RetrievalMethod对象中的URI。

getURIDereferencer() - Method in class javax.xml.crypto.dsig. XMLSignatureFactory

返回对URIDereferencer引用，默认情况下，它用于取消引用Reference对象中的URI。

getURIDereferencer() - Method in interface javax.xml.crypto. XMLCryptoContext

返回一个URIDereferencer ，用于取消引用URIReference s。

getURIReference() - Method in exception javax.xml.crypto. URIReferenceException

返回在抛出异常时正在取消引用的 URIReference 。

getURIResolver() - Method in class javax.xml.transform. Transformer

获取一个用于解析document（）中使用的URI的对象。

getURIResolver() - Method in class javax.xml.transform. TransformerFactory

获取在转换过程中默认使用的对象来解析document（），xsl：import或xsl：include中使用的URI。

getURIs() - Method in interface java.net. CookieStore

获取标识Cookie存储区中的Cookie的所有URI。

getUrl() - Method in class javafx.css. Stylesheet

加载样式表的URL。

getUrl() - Method in class javafx.scene.image. Image

返回用于获取Image实例中包含的像素数据的URL，如果在构造函数中指定。

getUrl() - Method in class javafx.scene.input. Clipboard

从先前已注册的剪贴板获取URL字符串。

getUrl() - Method in class javafx.scene.input. ClipboardContent

从以前放置的 ClipboardContent获取URL字符串。

getUrl() - Method in class javafx.scene.web. WebHistory.Entry

返回页面的URL。

getUrl() - Method in class javax.jnlp. DownloadService2.ResourceSpec

返回此资源的URL。

getUrl() - Method in class javax.sql.rowset. BaseRowSet

检索此 RowSet对象的 javax.sql.Reader对象用于使用启用了JDBC技术的驱动程序与关系数据库建立连接的JDBC URL。

getUrl() - Method in interface javax.sql. RowSet

检索此 RowSet对象将用于创建连接的url属性，如果使用 DriverManager而不是 DataSource对象建立连接。

getURL() - Method in class java.net. URLConnection

返回此 URLConnection的 URL字段的值。

getURL() - Method in interface java.sql. DatabaseMetaData

检索此DBMS的URL。

getURL() - Method in class javax.activation. URLDataSource

返回用于创建此DataSource的URL。

getURL() - Method in class javax.swing.event. HyperlinkEvent

获取链接引用的URL。

getURL() - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

getURL() - Method in interface javax.xml.bind. ValidationEventLocator

返回XML源的名称作为URL（如果可用）

getURL() - Method in class jdk.nashorn.api.scripting. URLReader

这位读者的网址

getURL() - Method in interface org.w3c.dom.html. HTMLDocument

文档的完整URI。

getURL(int) - Method in interface java.sql. CallableStatement

以 java.net.URL对象的形式获取指定的JDBC DATALINK参数的值。

getURL(int) - Method in interface java.sql. ResultSet

以Java编程语言中的 ResultSet对象的形式 java.net.URL此 ResultSet对象的当前行中指定列的值。

getURL(String) - Method in interface java.sql. CallableStatement

检索作为 java.net.URL对象的JDBC DATALINK参数的值。

getURL(String) - Method in interface java.sql. ResultSet

检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 java.net.URL对象。

getURLContext(String, Hashtable<?, ?>) - Static method in class javax.naming.spi. NamingManager

为给定的URL方案ID创建上下文。

getUrlConverter() - Static method in class javafx.css. StyleConverter

用于URL字符串的转换器。

getUrlDecoder() - Static method in class java.util. Base64

返回一个Base64.Decoder ，它使用URL and Filename safe类型base64编码方案进行解码。

getUrlEncoder() - Static method in class java.util. Base64

返回一个Base64.Encoder ，它使用URL and Filename safe类型的base64编码方案进行编码。

getURLOrDefaultInitCtx(String) - Method in class javax.naming. InitialContext

检索用于解析字符串名称 name的上下文。

getURLOrDefaultInitCtx(Name) - Method in class javax.naming. InitialContext

检索用于解析的上下文 name 。

getURLPath() - Method in class javax.management.remote. JMXServiceURL

服务网址的URL路径部分。

getURLs() - Method in class java.net. URLClassLoader

返回加载类和资源的URL的搜索路径。

getURLs() - Method in class javax.management.loading. MLet

返回加载类和资源的URL的搜索路径。

getURLs() - Method in interface javax.management.loading. MLetMBean

返回加载类和资源的URL的搜索路径。

getUrx() - Method in class javafx.scene.effect. PerspectiveTransform

获取属性urx的值。

getUry() - Method in class javafx.scene.effect. PerspectiveTransform

获取财产的价值。

getUsableSpace() - Method in class java.io. File

通过此抽象路径名返回分区 named上此虚拟机可用的字节数。

getUsableSpace() - Method in class java.nio.file. FileStore

返回文件存储上此Java虚拟机可用的字节数。

getUsage() - Method in class java.lang.management. MemoryNotificationInfo

构建此通知时返回内存池的内存使用情况。

getUsage() - Method in interface java.lang.management. MemoryPoolMXBean

返回此内存池的内存使用情况的估计。

getUsage() - Method in interface org.ietf.jgss. GSSCredential

返回凭据使用模式。

getUsage(Oid) - Method in interface org.ietf.jgss. GSSCredential

返回特定机制的凭据使用模式。

getUsageThreshold() - Method in interface java.lang.management. MemoryPoolMXBean

以字节为单位返回此内存池的使用阈值。

getUsageThresholdCount() - Method in interface java.lang.management. MemoryPoolMXBean

返回内存使用量超过使用率阈值的次数。

getUseCache() - Static method in class javax.imageio. ImageIO

返回当前值设置由 setUseCache ，或 true如果没有明确的设定已经取得进展。

getUseCaches() - Method in class java.net. URLConnection

返回此 URLConnection的 useCaches字段的值。

getUseCipherSuitesOrder() - Method in class javax.net.ssl. SSLParameters

返回是否应该遵守本地密码套件的偏好。

getUseClientMode() - Method in class javax.net.ssl. SSLEngine

如果在握手时将引擎设置为使用客户端模式，则返回true。

getUseClientMode() - Method in class javax.net.ssl. SSLServerSocket

如果接受的连接将处于SSL客户端模式，则返回true。

getUseClientMode() - Method in class javax.net.ssl. SSLSocket

如果在握手时将套接字设置为使用客户端模式，则返回true。

getUsed() - Method in class java.lang.management. MemoryUsage

以字节为单位返回使用的内存量。

getUseMap() - Method in interface org.w3c.dom.html. HTMLImageElement

使用客户端图像映射。

getUseMap() - Method in interface org.w3c.dom.html. HTMLInputElement

使用客户端图像映射。

getUseMap() - Method in interface org.w3c.dom.html. HTMLObjectElement

使用客户端图像映射。

getUseParentHandlers() - Method in class java.util.logging. Logger

发现这个记录器是否将其输出发送到其父记录器。

getUserAction() - Method in class java.awt.dnd. DragSourceDragEvent

此方法返回用户放置操作。

getUserAgent() - Method in class javafx.scene.web. WebEngine

获取属性userAgent的值。

getUserAgentStylesheet() - Static method in class javafx.application. Application

获取整个应用程序使用的用户代理样式表。

getUserAgentStylesheet() - Method in class javafx.scene.layout. Region

实现可以通过覆盖此方法来为该Region及其子项指定其自己的用户代理样式。

getUserAgentStylesheet() - Method in class javafx.scene. Scene

获取此场景将使用的用户代理样式表的URL。

getUserAgentStylesheet() - Method in class javafx.scene. SubScene

获取此SubScene将使用的用户代理样式表的URL。

getUserData() - Method in class javafx.scene.control. MenuItem

返回先前设置的Object属性，如果没有使用 MenuItem.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in class javafx.scene.control. Tab

返回先前设置的Object属性，如果没有使用 Tab.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in class javafx.scene.control. TableColumnBase

返回先前设置的Object属性，如果没有使用 TableColumnBase.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in interface javafx.scene.control. Toggle

返回先前设置的Object属性，如果没有使用 Node.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in class javafx.scene.control. ToggleGroup

返回先前设置的Object属性，如果没有使用 ToggleGroup.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in class javafx.scene. Node

返回先前设置的Object属性，如果没有使用 Node.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in class javafx.scene. Scene

返回先前设置的Object属性，如果没有使用 Scene.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in class javafx.stage. Window

返回先前设置的Object属性，如果没有使用 Window.setUserData(java.lang.Object)方法设置此属性，则返回null。

getUserData() - Method in class javax.management. Notification

获取用户数据。

getUserData(String) - Method in class javax.imageio.metadata. IIOMetadataNode

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

getUserData(String) - Method in interface org.w3c.dom. Node

检索与该节点上的键相关联的对象。

getUserDataDirectory() - Method in class javafx.scene.web. WebEngine

获取属性userDataDirectory的值。

getUserDropAction() - Method in class javax.swing. TransferHandler.TransferSupport

返回用于drop的用户drop操作，当此 TransferSupport表示丢弃时。

getUserInfo() - Method in class java.net. URI

返回此URI的解码的用户信息组件。

getUserInfo() - Method in class java.net. URL

获取这个 URL的userInfo部分。

getUserJVMDefaults() - Static method in interface jdk.packager.services. UserJvmOptionsService

获取使用UserJvmOptionService的实例。

getUserJVMOptionDefaults() - Method in interface jdk.packager.services. UserJvmOptionsService

UserJVMOptions的“默认”集合。

getUserJVMOptions() - Method in interface jdk.packager.services. UserJvmOptionsService

UserJVMOptions的“当前”集合。

getUsername() - Method in class com.sun.net.httpserver. HttpPrincipal

返回此对象创建的用户名。

getUsername() - Method in class com.sun.security.auth.module. SolarisSystem

已过时。

获取当前Solaris用户的用户名。

getUsername() - Method in class com.sun.security.auth.module. UnixSystem

获取当前Unix用户的用户名。

getUsername() - Method in class javax.sql.rowset. BaseRowSet

返回用于创建数据库连接的用户名。

getUsername() - Method in interface javax.sql. RowSet

检索用于为此 RowSet对象创建数据库连接的用户名。

getUserName() - Method in class java.awt.print. PrinterJob

获取打印用户的名称。

getUserName() - Method in class java.net. PasswordAuthentication

返回用户名。

getUserName() - Method in interface java.sql. DatabaseMetaData

检索此数据库已知的用户名。

getUserObject() - Method in class javax.imageio.metadata. IIOMetadataNode

返回与此节点相关联的 Object值。

getUserObject() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回此节点的用户对象。

getUserObjectPath() - Method in class javax.swing.tree. DefaultMutableTreeNode

从根中返回用户对象路径，以获取到此节点。

getUserPrincipal() - Method in class javax.xml.ws.spi.http. HttpExchange

返回表示HttpExchange的已认证用户的HttpExchange 。

getUserPrincipal() - Method in interface javax.xml.ws. WebServiceContext

返回标识当前正在处理的请求的发件人的Principal。

getUserPrincipalLookupService() - Method in class java.nio.file. FileSystem

返回此文件系统的 UserPrincipalLookupService （可选操作） 。

getUserSID() - Method in class com.sun.security.auth.module. NTSystem

获取当前NT用户的可打印SID。

getUserStyleSheetLocation() - Method in class javafx.scene.web. WebEngine

获取属性userStyleSheetLocation的值。

getUserTextColor() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的用户文本颜色。

getUserTextColor() - Method in class javax.swing.plaf.metal. MetalTheme

返回用户文本颜色。

getUserTextFont() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回用户文本字体。

getUserTextFont() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的用户文本字体。

getUserTextFont() - Method in class javax.swing.plaf.metal. MetalTheme

返回用户文本字体。

getUtf16Offset() - Method in interface org.w3c.dom. DOMLocator

如[ISO]和[ISO / IEC 10646]的[Unicode]和修正1中定义的UTF-16，如果没有UTF-16偏移可用，则偏移到此定位器指向的输入源或 -1 。

getVAdjustable() - Method in class java.awt. ScrollPane

返回表示垂直滚动条状态的 ScrollPaneAdjustable对象。

getValidCharacters() - Method in class javax.swing.text. MaskFormatter

返回可以输入的有效字符。

getValidOffsets(LocalDateTime) - Method in class java.time.zone. ZoneRules

在这些规则中获取在指定的本地日期时间中适用的偏移量。

getValidPixels() - Method in class java.awt.image. IndexColorModel

返回一个 BigInteger ，表示 BigInteger中的有效/无效像素。

getValidPolicy() - Method in interface java.security.cert. PolicyNode

返回此节点所表示的有效策略。

getVAlign() - Method in interface org.w3c.dom.html. HTMLTableCellElement

数据在单元格中的垂直对齐。

getVAlign() - Method in interface org.w3c.dom.html. HTMLTableColElement

列中的单元格数据的垂直对齐。

getVAlign() - Method in interface org.w3c.dom.html. HTMLTableRowElement

此行的单元格内的数据的垂直对齐方式。

getVAlign() - Method in interface org.w3c.dom.html. HTMLTableSectionElement

数据在单元格中的垂直对齐。

getValignment() - Method in class javafx.scene.control. Separator

获取属性对齐的值。

getValignment() - Method in class javafx.scene.layout. RowConstraints

获取属性对齐的值。

getValignment(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，则返回小孩的对齐约束。

getValue() - Method in class com.sun.management. VMOption

在创建此 VMOption时返回此VM选项的值。

getValue() - Method in interface com.sun.source.doctree. AttributeTree

返回属性的值，如果该类型为EMPTY，则返回 null 。

getValue() - Method in interface com.sun.source.tree. LiteralTree

返回文字表达式的值。

getValue() - Method in interface java.awt. Adjustable

获取可调整对象的当前值。

getValue() - Method in class java.awt.event. AdjustmentEvent

返回调整事件中的当前值。

getValue() - Method in class java.awt. Scrollbar

获取此滚动条的当前值。

getValue() - Method in class java.awt. ScrollPaneAdjustable

getValue() - Method in class java.beans. Expression

如果此实例的value属性尚未设置，则此方法使用这些参数动态地找到具有指定的methodName的方法并调用该实例。

getValue() - Method in interface java.beans. PropertyEditor

获取属性值。

getValue() - Method in class java.beans. PropertyEditorSupport

获取属性的值。

getValue() - Method in class java.net. HttpCookie

返回cookie的值。

getValue() - Method in class java.rmi.dgc. Lease

返回租期。

getValue() - Method in interface java.security.cert. Extension

获取扩展程序的DER编码值。

getValue() - Method in interface java.security. KeyStore.Entry.Attribute

返回属性的值。

getValue() - Method in class java.security. PKCS12Attribute

返回属性的ASN.1 DER编码值作为字符串。

getValue() - Method in class java.text. Annotation

返回属性的值，可以为null。

getValue() - Method in interface java.time.chrono. Era

获取与年龄相关联的数值，按时间顺序定义。

getValue() - Method in enum java.time.chrono. HijrahEra

获得数字时代 int价值。

getValue() - Method in enum java.time.chrono. IsoEra

获得数字时代 int价值。

getValue() - Method in class java.time.chrono. JapaneseEra

获得数字时代 int价值。

getValue() - Method in enum java.time.chrono. MinguoEra

获得数字时代 int价值。

getValue() - Method in enum java.time.chrono. ThaiBuddhistEra

获得数字时代 int价值。

getValue() - Method in enum java.time. DayOfWeek

获得 int价值。

getValue() - Method in enum java.time. Month

获得年度 int价值。

getValue() - Method in class java.time. Year

获取年值。

getValue() - Method in class java.util. AbstractMap.SimpleEntry

返回与此条目相对应的值。

getValue() - Method in class java.util. AbstractMap.SimpleImmutableEntry

返回与此条目相对应的值。

getValue() - Method in interface java.util. Map.Entry

返回与此条目相对应的值。

getValue() - Method in class java.util.zip. Adler32

返回校验和值。

getValue() - Method in interface java.util.zip. Checksum

返回当前的校验和值。

getValue() - Method in class java.util.zip. CRC32

返回CRC-32值。

getValue() - Method in class java.util.zip. CRC32C

返回CRC-32C值。

getValue() - Method in class javafx.beans.binding. BooleanExpression

getValue() - Method in class javafx.beans.binding. DoubleExpression

getValue() - Method in class javafx.beans.binding. FloatExpression

getValue() - Method in class javafx.beans.binding. IntegerExpression

getValue() - Method in class javafx.beans.binding. ListExpression

getValue() - Method in class javafx.beans.binding. LongExpression

getValue() - Method in class javafx.beans.binding. MapExpression

getValue() - Method in class javafx.beans.binding. ObjectExpression

getValue() - Method in class javafx.beans.binding. SetExpression

getValue() - Method in class javafx.beans.binding. StringExpression

getValue() - Method in interface javafx.beans.value. ObservableValue

返回此 ObservableValue的当前值

getValue() - Method in interface javafx.beans.value. WritableValue

获取包装的值。

getValue() - Method in class javafx.concurrent. Service

获取属性值的值。

getValue() - Method in class javafx.concurrent. Task

获取属性值的值。

getValue() - Method in interface javafx.concurrent. Worker

指定此Worker的值或结果。

getValue() - Method in class javafx.css. ParsedValue

getValue() - Method in class javafx.css. Size

返回值

getValue() - Method in class javafx.scene.chart. Axis.TickMark

获取属性值的值。

getValue() - Method in class javafx.scene.control. ChoiceBox

获取属性值的值。

getValue() - Method in class javafx.scene.control. ComboBoxBase

获取属性值的值。

getValue() - Method in class javafx.scene.control. ScrollBar

获取属性值的值。

getValue() - Method in class javafx.scene.control. Slider

获取属性值的值。

getValue() - Method in class javafx.scene.control. Spinner

获取属性值的值。

getValue() - Method in class javafx.scene.control. SpinnerValueFactory

获取属性值的值。

getValue() - Method in class javafx.scene.control. TableColumn.CellDataFeatures

返回传递给构造函数的值。

getValue() - Method in class javafx.scene.control. TextFormatter

获取属性值的值。

getValue() - Method in class javafx.scene.control. TreeItem

返回此TreeItem表示的特定于应用程序的数据。

getValue() - Method in class javafx.scene.control. TreeTableColumn.CellDataFeatures

返回传递给构造函数的值。

getValue() - Method in class javafx.scene.input. KeyCombination.Modifier

获取此修改值 Modifier 。

getValue() - Method in class javafx.util. Pair

获取此对的值。

getValue() - Method in interface javax.annotation.processing. Completion

返回建议完成的文本。

getValue() - Method in class javax.crypto.spec. PSource.PSpecified

返回编码输入P的值。

getValue() - Method in interface javax.lang.model.element. AnnotationValue

返回值。

getValue() - Method in class javax.management. Attribute

返回作为此属性值的Object。

getValue() - Method in class javax.management. StringValueExp

返回由 StringValueExp实例表示的字符串。

getValue() - Method in class javax.naming.ldap. Rdn

检索此Rdn值之一。

getValue() - Method in class javax.print.attribute. DateTimeSyntax

返回此日期时间属性的 java.util.Date值。

getValue() - Method in class javax.print.attribute. EnumSyntax

返回此枚举值的整数值。

getValue() - Method in class javax.print.attribute. IntegerSyntax

返回此整数属性的整数值。

getValue() - Method in class javax.print.attribute. TextSyntax

返回此文本属性的文本字符串。

getValue() - Method in class javax.sound.sampled. BooleanControl

获取此控件的当前值。

getValue() - Method in class javax.sound.sampled. EnumControl

获取此控件的当前值。

getValue() - Method in class javax.sound.sampled. FloatControl

获取此控件的当前值。

getValue() - Method in interface javax.swing. BoundedRangeModel

返回模型的当前值。

getValue() - Method in class javax.swing. DefaultBoundedRangeModel

返回模型的当前值。

getValue() - Method in class javax.swing. JFormattedTextField

返回最后一个有效值。

getValue() - Method in class javax.swing. JOptionPane

返回用户选择的值。

getValue() - Method in class javax.swing. JProgressBar

进度条的电流返回 value从 BoundedRangeModel 。

getValue() - Method in class javax.swing. JScrollBar

返回滚动条的值。

getValue() - Method in class javax.swing. JSlider

从 BoundedRangeModel返回滑块的当前值。

getValue() - Method in class javax.swing. JSpinner

返回模型的当前值，通常这个值由 editor显示。

getValue() - Method in class javax.swing. SpinnerDateModel

返回此序列中的当前元素 Date s。

getValue() - Method in class javax.swing. SpinnerListModel

返回序列的当前元素。

getValue() - Method in interface javax.swing. SpinnerModel

序列的 当前元素 。

getValue() - Method in class javax.swing. SpinnerNumberModel

返回序列的当前元素的值。

getValue() - Method in class javax.swing. Spring

返回此 Spring的当前 值 。

getValue() - Method in class javax.swing.text.html. Option

方便返回与 value相关的字符串属性。

getValue() - Method in class javax.swing.text.html.parser. AttributeList

getValue() - Method in class javax.xml.bind. JAXBElement

返回此元素的内容模型和属性值。

getValue() - Method in interface javax.xml.crypto.dsig. XMLSignature.SignatureValue

返回此 SignatureValue的签名值。

getValue() - Method in class javax.xml.soap. MimeHeader

返回此 MimeHeader对象的值。

getValue() - Method in interface javax.xml.soap. Node

如果此节点为 Text节点，则返回此节点的值，否则返回此节点的直接子节点的值。

getValue() - Method in interface javax.xml.stream.events. Attribute

获取此属性的归一化值

getValue() - Method in interface jdk.nashorn.api.tree. LiteralTree

返回此文字的值。

getValue() - Method in interface jdk.nashorn.api.tree. PropertyTree

返回此属性的值。

getValue() - Method in interface org.w3c.dom. Attr

在检索时，属性的值作为字符串返回。

getValue() - Method in interface org.w3c.dom.html. HTMLButtonElement

当前窗体控件的值。

getValue() - Method in interface org.w3c.dom.html. HTMLInputElement

当元素的 type属性具有值“文本”，“文件”或“密码”时，表示交互式用户代理中相应表单控件的当前内容。

getValue() - Method in interface org.w3c.dom.html. HTMLLIElement

在 OL使用复位序列号。

getValue() - Method in interface org.w3c.dom.html. HTMLOptionElement

当前窗体控件的值。

getValue() - Method in interface org.w3c.dom.html. HTMLParamElement

运行时参数的值。

getValue() - Method in interface org.w3c.dom.html. HTMLSelectElement

当前窗体控件的值。

getValue() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

在交互式用户代理中表示相应表单控件的当前内容。

getValue(int) - Method in interface com.sun.jdi. ArrayReference

返回数组组件值。

getValue(int) - Method in class javax.swing. RowFilter.Entry

返回指定索引处的值。

getValue(int) - Method in interface org.xml.sax. AttributeList

已过时。

返回列表中的属性值（按位置）。

getValue(int) - Method in interface org.xml.sax. Attributes

通过索引查找属性的值。

getValue(int) - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

获取属性的值（按位置）。

getValue(int) - Method in class org.xml.sax.helpers. AttributesImpl

通过索引返回属性的值。

getValue(Field) - Method in interface com.sun.jdi. ObjectReference

获取此对象中给定实例或静态字段的值。

getValue(Field) - Method in interface com.sun.jdi. ReferenceType

获取Value给定的静态Field这种类型。

getValue(LocalVariable) - Method in interface com.sun.jdi. StackFrame

获取此框架中的LocalVariable的Value 。

getValue(Object) - Static method in class javax.xml.bind. JAXBIntrospector

获取JAXB元素的元素值。

getValue(String) - Method in class java.beans. FeatureDescriptor

使用此功能检索命名属性。

getValue(String) - Method in class java.util.jar. Attributes

返回指定为字符串的指定属性名称的值，如果未找到该属性，则返回null。

getValue(String) - Method in interface javax.net.ssl. SSLSession

返回绑定到会话应用层数据中给定名称的对象。

getValue(String) - Method in class javax.swing. AbstractAction

获取与指定键相关联的 Object 。

getValue(String) - Method in interface javax.swing. Action

使用关联的键获取该对象的属性之一。

getValue(String) - Method in interface org.xml.sax. AttributeList

已过时。

返回列表中的属性值（按名称）。

getValue(String) - Method in interface org.xml.sax. Attributes

通过XML限定（前缀）名称查找属性的值。

getValue(String) - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

获取属性的值（按名称）。

getValue(String) - Method in class org.xml.sax.helpers. AttributesImpl

通过合格（前缀）名称查找属性的值。

getValue(String, String) - Method in interface org.xml.sax. Attributes

通过命名空间名称查找属性的值。

getValue(String, String) - Method in class org.xml.sax.helpers. AttributesImpl

通过Namespace限定名查找属性的值。

getValue(Attributes.Name) - Method in class java.util.jar. Attributes

返回指定的Attributes.Name的值，如果未找到该属性，则返回null。

getValueAdded() - Method in class javafx.collections. MapChangeListener.Change

获取密钥的新值。

getValueAsString(int) - Method in class javax.imageio.plugins.tiff. TIFFField

返回包含数据项的人性化版本的 String 。

getValueAt(int, int) - Method in class javax.swing. DefaultRowSorter.ModelWrapper

返回指定索引处的值。

getValueAt(int, int) - Method in class javax.swing. JTable

返回单元格值为 row和 column 。

getValueAt(int, int) - Method in class javax.swing.table. DefaultTableModel

返回单元格的属性值为 row和 column 。

getValueAt(int, int) - Method in interface javax.swing.table. TableModel

返回单元格的值为 columnIndex和 rowIndex 。

getValueClass() - Method in class javax.swing.text. DefaultFormatter

返回用于创建新对象的类。

getValueContainsLiteralCharacters() - Method in class javax.swing.text. MaskFormatter

如果 stringToValue应该返回掩码中的文字字符，则返回true。

getValueConverter() - Method in class javafx.scene.control. TextFormatter

值之间的转换器和文本。

getValueCount() - Method in class javax.swing. RowFilter.Entry

返回条目中的值的数量。

getValueFactory() - Method in class javafx.scene.control. Spinner

获取属性valueFactory的值。

getValueForDisplay(double) - Method in class javafx.scene.chart. Axis

获取此轴上给定显示位置的数据值。

getValueForDisplay(double) - Method in class javafx.scene.chart. CategoryAxis

获取此轴上给定显示位置的数据值。

getValueForDisplay(double) - Method in class javafx.scene.chart. ValueAxis

获取此轴上给定显示位置的数据值。

getValueIsAdjusting() - Method in class java.awt.event. AdjustmentEvent

如果这是多个调整事件之一，则返回 true 。

getValueIsAdjusting() - Method in class java.awt. Scrollbar

如果值正在由于用户执行的操作而改变，则返回true。

getValueIsAdjusting() - Method in class java.awt. ScrollPaneAdjustable

如果值正在由于用户执行的操作而改变，则返回true。

getValueIsAdjusting() - Method in interface javax.swing. BoundedRangeModel

如果当前对value属性的更改是一系列更改的一部分，则返回true。

getValueIsAdjusting() - Method in class javax.swing. DefaultBoundedRangeModel

如果值正在由于用户执行的操作而改变，则返回true。

getValueIsAdjusting() - Method in class javax.swing. DefaultListSelectionModel

如果选择正在进行一系列更改，则返回 true 。

getValueIsAdjusting() - Method in class javax.swing.event. ListSelectionEvent

返回是否是一系列多个事件中的一个，其中仍在进行更改。

getValueIsAdjusting() - Method in class javax.swing. JList

返回选择模型的 isAdjusting属性。

getValueIsAdjusting() - Method in class javax.swing. JScrollBar

如果滚动条旋钮被拖动，则为真。

getValueIsAdjusting() - Method in class javax.swing. JSlider

从模型中返回 valueIsAdjusting属性。

getValueIsAdjusting() - Method in interface javax.swing. ListSelectionModel

如果选择正在进行一系列更改，则返回 true 。

getValueKind() - Method in interface com.sun.source.doctree. AttributeTree

返回属性的种类。

getValueName(int) - Method in class javax.imageio.plugins.tiff. TIFFTag

返回与该标签的数据可能占用的特定值相关联的助记符名称，如果没有名称，则 null 。

getValueNames() - Method in interface javax.net.ssl. SSLSession

返回绑定到会话中的所有应用层数据对象的名称数组。

getValueRemoved() - Method in class javafx.collections. MapChangeListener.Change

获取密钥的旧值。

getValues() - Method in interface com.sun.jdi. ArrayReference

返回此数组中的所有组件。

getValues() - Method in class javafx.animation. KeyFrame

返回Set不可变的Set实例。

getValues() - Method in class javax.imageio.plugins.jpeg. JPEGHuffmanTable

返回一个 short的数组， short包含通过增加相应代码的长度来排列的值。

getValues() - Method in class javax.sound.sampled. EnumControl

返回此控件的可能值集。

getValues() - Method in class javax.swing.text.html.parser. AttributeList

getValues(int, int) - Method in interface com.sun.jdi. ArrayReference

返回一系列数组组件。

getValues(List<? extends Field>) - Method in interface com.sun.jdi. ObjectReference

获取此对象中多个实例和/或静态字段的值。

getValues(List<? extends Field>) - Method in interface com.sun.jdi. ReferenceType

返回包含给定列表中每个静态Field的Value的地图。

getValues(List<? extends LocalVariable>) - Method in interface com.sun.jdi. StackFrame

返回此框架中多个局部变量的值。

getValueSafe() - Method in class javafx.beans.binding. StringExpression

通常返回此值 StringExpression 。

getValueType() - Method in interface org.w3c.dom.html. HTMLParamElement

关于 value属性值的含义的信息。

getVariable() - Method in interface com.sun.source.tree. AssignmentTree

返回被分配给的变量。

getVariable() - Method in interface com.sun.source.tree. CompoundAssignmentTree

返回复合赋值左侧的变量。

getVariable() - Method in interface com.sun.source.tree. EnhancedForLoopTree

返回循环的控制变量。

getVariable() - Method in interface jdk.nashorn.api.tree. AssignmentTree

返回此作业的左侧（LHS）。

getVariable() - Method in interface jdk.nashorn.api.tree. CompoundAssignmentTree

返回此作业的左侧（LHS）。

getVariable() - Method in interface jdk.nashorn.api.tree. ForInLoopTree

在左手边表达。

getVariable() - Method in interface jdk.nashorn.api.tree. ForOfLoopTree

左手边表达。

getVariant() - Method in class java.util. Locale

返回此区域设置的变体代码。

getVariation() - Method in class java.awt.im. InputMethodHighlight

返回文本范围的变化。

getVbarPolicy() - Method in class javafx.scene.control. ScrollPane

获取属性vbarPolicy的值。

getVendor() - Method in enum java.sql. JDBCType

返回支持此数据类型的供应商的名称。

getVendor() - Method in interface java.sql. SQLType

返回支持此数据类型的供应商的名称。

getVendor() - Method in class javax.sound.midi. MidiDevice.Info

获取提供设备的公司的名称。

getVendor() - Method in interface javax.sound.midi. Soundbank

获得一个 string命名提供声银行的公司。

getVendor() - Method in class javax.sound.sampled. Mixer.Info

获得混音器的供应商。

getVendor() - Method in class javax.sql.rowset.spi. SyncProvider

返回此 SyncProvider实例的供应商名称

getVendorName() - Method in class javax.imageio.spi. IIOServiceProvider

返回负责创建此服务提供商及其关联实施的供应商的名称。

getVendorTypeNumber() - Method in enum java.sql. JDBCType

返回数据类型的供应商特定类型编号。

getVendorTypeNumber() - Method in interface java.sql. SQLType

返回数据类型的供应商特定类型编号。

getVerifyInputWhenFocusTarget() - Method in class javax.swing. JComponent

返回指示在此组件请求焦点之前是否调用当前焦点所有者的输入验证器的值。

getVersion() - Method in interface java.awt.font. OpenType

返回OpenType字体的版本。 1.0表示为0x00010000。

getVersion() - Method in interface java.lang.management. OperatingSystemMXBean

返回操作系统版本。

getVersion() - Method in class java.net. HttpCookie

返回该Cookie符合的协议版本。

getVersion() - Method in class java.security.cert. X509Certificate

从证书获取 version （版本号）值。

getVersion() - Method in class java.security.cert. X509CRL

从CRL获取 version （版本号）值。

getVersion() - Method in class java.security. Provider

已过时。
改用Provider.getVersionStr() 。

getVersion() - Method in class java.util.jar. JarFile

返回搜索版本化条目时使用的最大版本。

getVersion() - Method in class javax.crypto.spec. RC5ParameterSpec

返回版本。

getVersion() - Method in class javax.imageio.spi. IIOServiceProvider

返回描述此服务提供商及其关联实现的版本号的字符串。

getVersion() - Method in class javax.jnlp. DownloadService2.ResourceSpec

返回此资源的版本。

getVersion() - Method in class javax.management.loading. MLetContent

获取 MLET标签的 VERSION属性的值。

getVersion() - Method in interface javax.management.remote.rmi. RMIServer

该连接器服务器了解的RMI连接器协议版本。

getVersion() - Method in class javax.management.remote.rmi. RMIServerImpl_Stub

getVersion() - Method in class javax.management.remote.rmi. RMIServerImpl

getVersion() - Method in class javax.security.cert. X509Certificate

已过时。

从证书获取 version （版本号）值。

getVersion() - Method in class javax.sound.midi. MidiDevice.Info

获取设备的版本。

getVersion() - Method in interface javax.sound.midi. Soundbank

获取声音库的版本字符串。

getVersion() - Method in class javax.sound.sampled. Mixer.Info

获取混音器的版本。

getVersion() - Method in class javax.sql.rowset.spi. SyncProvider

返回此 SyncProvider实例的发布版本。

getVersion() - Method in interface javax.xml.stream.events. StartDocument

返回此XML流的XML版本

getVersion() - Method in class javax.xml.stream.util. StreamReaderDelegate

getVersion() - Method in interface javax.xml.stream. XMLStreamReader

获取在xml声明中声明的xml版本如果没有声明，则返回null

getVersion() - Method in interface org.w3c.dom.html. HTMLHtmlElement

有关文档DTD的版本信息。

getVersionColumns(String, String, String) - Method in interface java.sql. DatabaseMetaData

检索表中更新行中任何值时自动更新的表的列的说明。

getVersionNumber() - Method in class javax.security.auth.kerberos. KerberosKey

返回密钥版本号。

getVersions(String) - Static method in class java.time.zone. ZoneRulesProvider

获取区域ID的规则历史记录。

getVersionStr() - Method in class java.security. Provider

返回此提供程序的版本字符串。

getVertexFormat() - Method in class javafx.scene.shape. TriangleMesh

获取属性vertexFormat的值。

getVertexIndexSize() - Method in class javafx.scene.shape. VertexFormat

返回表示顶点的组件索引数。

getVerticalAlign() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的vertical-align属性定义。

getVerticalAlignment() - Method in class javax.swing. AbstractButton

返回文本和图标的垂直对齐方式。

getVerticalAlignment() - Method in class javax.swing. JLabel

返回标签内容沿着Y轴的对齐方式。

getVerticalGridLinesVisible() - Method in class javafx.scene.chart. XYChart

指示垂直网格线是否可见。

getVerticalLegBuffer() - Method in class javax.swing.plaf.basic. BasicTreeUI

默认情况下，节点之间的腿的垂直元素从父节点的底部开始。

getVerticalPosition() - Method in class javafx.scene.layout. BackgroundPosition

表示BackgroundImage相对于由 verticalSide属性指示的一侧的区域的位置的值。

getVerticalScrollBar() - Method in class javafx.scene.control.skin. ScrollPaneSkin

返回此ScrollPaneSkin实例中使用的垂直ScrollBar 。

getVerticalScrollBar() - Method in class javax.swing. JScrollPane

返回控制视口垂直视图位置的垂直滚动条。

getVerticalScrollBar() - Method in class javax.swing. ScrollPaneLayout

返回处理垂直滚动的 JScrollBar对象。

getVerticalScrollBarPolicy() - Method in class javax.swing. JScrollPane

返回垂直滚动条策略值。

getVerticalScrollBarPolicy() - Method in class javax.swing. ScrollPaneLayout

返回垂直滚动条显示策略。

getVerticalSide() - Method in class javafx.scene.layout. BackgroundPosition

沿着垂直轴的SideMap背景。

getVerticalSliderThumbIcon() - Static method in class javax.swing.plaf.metal. MetalIconFactory

返回一个用于垂直滑块的缩略图标。

getVerticalTextPosition() - Method in class javax.swing. AbstractButton

返回文本相对于图标的垂直位置。

getVerticalTextPosition() - Method in class javax.swing. JLabel

返回标签相对于其图像的文本的垂直位置。

getVetoableChangeListeners() - Method in class java.awt. KeyboardFocusManager

返回在此键盘焦点管理器上注册的所有否决变更监听器的数组。

getVetoableChangeListeners() - Method in class java.beans. VetoableChangeSupport

返回使用addVetoableChangeListener（）添加到VetoableChangeSupport对象的所有侦听器的数组。

getVetoableChangeListeners() - Method in class javax.swing. JComponent

返回在此组件上注册的所有可变更改监听器的数组。

getVetoableChangeListeners(String) - Method in class java.awt. KeyboardFocusManager

返回与命名属性相关联的所有 VetoableChangeListener的数组。

getVetoableChangeListeners(String) - Method in class java.beans. VetoableChangeSupport

返回与named属性相关联的所有侦听器的数组。

getVgap() - Method in class java.awt. BorderLayout

返回组件之间的垂直间距。

getVgap() - Method in class java.awt. CardLayout

获取组件之间的垂直间距。

getVgap() - Method in class java.awt. FlowLayout

获得组件之间和组件之间的垂直间隙以及 Container的边框。

getVgap() - Method in class java.awt. GridLayout

获取组件之间的垂直间距。

getVgap() - Method in class javafx.scene.layout. FlowPane

获取属性vgap的值。

getVgap() - Method in class javafx.scene.layout. GridPane

获取属性vgap的值。

getVgap() - Method in class javafx.scene.layout. TilePane

获取属性vgap的值。

getVgrow() - Method in class javafx.scene.layout. RowConstraints

获取属性vgrow的值。

getVgrow(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，则返回小孩的vgrow约束。

getVgrow(Node) - Static method in class javafx.scene.layout. VBox

如果设置，返回小孩的vgrow属性。

getView() - Method in class javax.swing. JLayer

返回 JLayer的视图组件或 null 。

getView() - Method in class javax.swing. JViewport

返回 JViewport的一个孩子或 null 。

getView() - Method in interface org.w3c.dom.events. UIEvent

view属性标识生成事件的 AbstractView 。

getView(int) - Method in class javax.swing.text. AsyncBoxView

获取第n个子视图。

getView(int) - Method in class javax.swing.text. CompositeView

返回此容器中的第n个视图。

getView(int) - Method in class javax.swing.text. View

获取第 n个子视图。

getViewAtPoint(int, int, Rectangle) - Method in class javax.swing.text. BoxView

在给定坐标处获取子视图。

getViewAtPoint(int, int, Rectangle) - Method in class javax.swing.text. CompositeView

在给定坐标处获取子视图。

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text. CompositeView

获取代表模型中给定位置的子视图。

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text. TableView

获取代表模型中给定位置的子视图。

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text. TableView.TableRow

获取代表模型中给定位置的子视图。

getViewAttributes(View) - Method in class javax.swing.text.html. StyleSheet

获取要在视图中显示的一组属性。

getViewCount() - Method in class javax.swing.text. AsyncBoxView

返回此视图中的视图数。

getViewCount() - Method in class javax.swing.text. CompositeView

返回此视图的子视图数。

getViewCount() - Method in class javax.swing.text. View

返回此视图中的视图数。

getViewFactory() - Method in class javax.swing.text. DefaultEditorKit

获取适合产生由该套件生产的任何型号的视图的工厂。

getViewFactory() - Method in class javax.swing.text. EditorKit

获取适合产生由该套件生产的任何型号的视图的工厂。

getViewFactory() - Method in class javax.swing.text.html. HTMLEditorKit

获取适合产生由该套件生产的任何型号的视图的工厂。

getViewFactory() - Method in class javax.swing.text. StyledEditorKit

获取适合产生由该套件生产的任何型号的视图的工厂。

getViewFactory() - Method in class javax.swing.text. View

获取正在提供视图层次结构的 ViewFactory实现。

getViewIndex(float, float, Shape) - Method in class javax.swing.text. View

返回表示视图中给定位置的子视图索引。

getViewIndex(int) - Method in class javafx.collections.transformation. FilteredList

getViewIndex(int) - Method in class javafx.collections.transformation. SortedList

getViewIndex(int) - Method in class javafx.collections.transformation. TransformationList

将直接源列表的元素的索引映射到此列表中的索引。

getViewIndex(int, Position.Bias) - Method in class javax.swing.text. AsyncBoxView

返回表示模型中给定位置的子视图索引。

getViewIndex(int, Position.Bias) - Method in class javax.swing.text. CompositeView

返回表示模型中给定位置的子视图索引。

getViewIndex(int, Position.Bias) - Method in class javax.swing.text. View

返回表示模型中给定位置的子视图索引。

getViewIndexAtPoint(float, float, Shape) - Method in class javax.swing.text. AsyncBoxView.ChildLocator

在给定点获取子视图索引。

getViewIndexAtPosition(int) - Method in class javax.swing.text. CompositeView

获取代表模型中给定位置的子视图索引。

getViewIndexAtPosition(int) - Method in class javax.swing.text. FlowView

获取代表模型中给定位置的子视图索引。

getViewIndexAtPosition(int) - Method in class javax.swing.text. ZoneView

返回表示模型中给定位置的子视图索引。

getViewIndexAtPosition(int, Position.Bias) - Method in class javax.swing.text. AsyncBoxView

获取代表模型中给定位置的子视图索引。

getViewIndexAtVisualOffset(float) - Method in class javax.swing.text. AsyncBoxView.ChildLocator

将负责偏移的视图定位到沿主轴的框中。

getViewOrder() - Method in class javafx.scene. Node

获取属性viewOrder的值。

getViewport() - Method in class javafx.scene.image. ImageView

获取属性视口的值。

getViewport() - Method in class javafx.scene.media. MediaView

将矩形视口检索到媒体框架中。

getViewport() - Method in class javafx.scene. SnapshotParameters

获取当前视口

getViewport() - Method in class javax.swing. JScrollPane

返回当前的 JViewport 。

getViewport() - Method in class javax.swing. ScrollPaneLayout

返回显示可滚动内容的 JViewport对象。

getViewportBorder() - Method in class javax.swing. JScrollPane

返回视口周围的 Border对象。

getViewportBorderBounds() - Method in class javax.swing. JScrollPane

返回视口边框的边界。

getViewportBorderBounds(JScrollPane) - Method in class javax.swing. ScrollPaneLayout

已过时。
从JDK版本起，Swing1.1由JScrollPane.getViewportBorderBounds()替代。

getViewportBounds() - Method in class javafx.scene.control. ScrollPane

获取属性viewportBounds的值。

getViewportSize() - Method in class java.awt. ScrollPane

返回滚动窗格视图端口的当前大小。

getViewPosition() - Method in class javax.swing. JViewport

返回出现在视口左上角的视图坐标，如果没有视图则返回0,0。

getViewRect() - Method in class javax.swing. JViewport

返回原点为 getViewPosition ，大小为 getExtentSize 。

getViewRowCount() - Method in class javax.swing. DefaultRowSorter

返回视图中的行数。

getViewRowCount() - Method in class javax.swing. RowSorter

返回视图中的行数。

getViewSize() - Method in class javax.swing. JViewport

如果视图的大小尚未被明确设置，返回首选大小，否则返回视图的当前大小。

getVisibility() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的visibility属性定义。

getVisible() - Method in class java.awt. Scrollbar

已过时。
从JDK 1.1版开始，由getVisibleAmount()替代。

getVisibleAdvance() - Method in class java.awt.font. TextLayout

返回此 TextLayout的提前，减去尾随空格。

getVisibleAmount() - Method in interface java.awt. Adjustable

获取比例指示器的长度。

getVisibleAmount() - Method in class java.awt. Scrollbar

获取此滚动条的可见数量。

getVisibleAmount() - Method in class java.awt. ScrollPaneAdjustable

getVisibleAmount() - Method in class javafx.scene.control. ScrollBar

获取属性visibleAmount的值。

getVisibleAmount() - Method in class javax.swing. JScrollBar

返回滚动条的范围，又称为“visibleAmount”。

getVisibleCell(int) - Method in class javafx.scene.control.skin. VirtualFlow

如果单元格已创建和布局，则获取给定索引的单元格。

getVisibleChildCount(TreePath) - Method in class javax.swing.tree. AbstractLayoutCache

返回行的可见子项数。

getVisibleChildCount(TreePath) - Method in class javax.swing.tree. FixedHeightLayoutCache

返回行的可见子项数。

getVisibleChildCount(TreePath) - Method in class javax.swing.tree. VariableHeightLayoutCache

返回 path的可见子 path 。

getVisibleComponent() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回可见组件。

getVisibleEditorRect() - Method in class javax.swing.plaf.basic. BasicTextUI

获取分配给根视图。

getVisibleIndex() - Method in class java.awt. List

获取方法 makeVisible上次显示的项目的索引。

getVisibleLeafColumn(int) - Method in class javafx.scene.control. TableView

相对于所有其他可见的叶子列，返回给定列索引中的TableColumn。

getVisibleLeafColumn(int) - Method in class javafx.scene.control. TreeTableView

相对于所有其他可见的叶子列，返回给定列索引中的TreeTableColumn。

getVisibleLeafColumns() - Method in class javafx.scene.control.skin. TableRowSkin

返回一个不可修改的列表，其中包含当前可见的叶子列。

getVisibleLeafColumns() - Method in class javafx.scene.control.skin. TableRowSkinBase

返回一个不可修改的列表，其中包含当前可见的叶子列。

getVisibleLeafColumns() - Method in class javafx.scene.control.skin. TreeTableRowSkin

返回一个不可修改的列表，其中包含当前可见的叶子列。

getVisibleLeafColumns() - Method in class javafx.scene.control. TableView

返回一个不可修改的列表，其中包含当前可见的叶子列。

getVisibleLeafColumns() - Method in class javafx.scene.control. TreeTableView

返回一个不可修改的列表，其中包含当前可见的叶子列。

getVisibleLeafIndex(TableColumn<S, ?>) - Method in class javafx.scene.control. TableView

相对于所有其他可见的叶子列，返回给定列的位置。

getVisibleLeafIndex(TreeTableColumn<S, ?>) - Method in class javafx.scene.control. TreeTableView

相对于所有其他可见的叶子列，返回给定列的位置。

getVisibleNamespacePrefixes() - Method in interface javax.xml.soap. SOAPElement

在该元素可见的名称空间前缀 String返回 Iterator 。

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree. AbstractLayoutCache

返回一个 Enumerator ，从传入的位置开始可见的路径递增。

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree. FixedHeightLayoutCache

返回一个枚举器，它从传入的位置开始，以可见路径递增。

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree. VariableHeightLayoutCache

返回一个 Enumerator ，从传入的位置开始可见的路径递增。

getVisiblePosition() - Method in class java.awt.event. InputMethodEvent

获取最显着的位置。

getVisibleRect() - Method in class javax.swing. JComponent

返回 Component的“可见矩形” - 该组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight())与其所有祖先的可见矩形的交集。

getVisibleRowCount() - Method in class javafx.scene.control. ComboBox

获取属性visibleRowCount的值。

getVisibleRowCount() - Method in class javax.swing. JList

返回 visibleRowCount属性的值。

getVisibleRowCount() - Method in class javax.swing. JTree

返回显示区域中显示的行数。

getVisualBounds() - Method in class java.awt.font. GlyphVector

返回此 GlyphVector的边界 GlyphVector可视边界是这个 GlyphVector的轮廓的边界框。

getVisualBounds() - Method in class javafx.stage. Screen

获得这个 Screen的视觉界限。

getVisualHighlightShape(TextHitInfo, TextHitInfo) - Method in class java.awt.font. TextLayout

返回一个 Shape将视觉选择包围在指定的范围内，扩展到边界。

getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D) - Method in class java.awt.font. TextLayout

返回包含指定范围内的视觉选择的路径，扩展为 bounds 。

getVisualOtherHit(TextHitInfo) - Method in class java.awt.font. TextLayout

返回指定命中的插入符号对面的命中。

getVisualRepresentation(Transferable) - Method in class javax.swing. TransferHandler

返回一个建立传输外观的对象。

getVLink() - Method in interface org.w3c.dom.html. HTMLBodyElement

用户访问过的链接的颜色。

getVmax() - Method in class javafx.scene.control. ScrollPane

获取属性vmax的值。

getVMID() - Method in class java.rmi.dgc. Lease

返回与租约相关联的客户端VMID。

getVmin() - Method in class javafx.scene.control. ScrollPane

获取属性vmin的值。

getVmName() - Method in interface java.lang.management. RuntimeMXBean

返回Java虚拟机实现名称。

getVMOption(String) - Method in interface com.sun.management. HotSpotDiagnosticMXBean

返回给定名称的VM选项的 VMOption对象。

getVmVendor() - Method in interface java.lang.management. RuntimeMXBean

返回Java虚拟机实现供应商。

getVmVersion() - Method in interface java.lang.management. RuntimeMXBean

返回Java虚拟机实现版本。

getVoiceFamily() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的voice-family属性定义。

getVoiceStatus() - Method in interface javax.sound.midi. Synthesizer

获取此合成器产生的声音的当前状态。

getVolatile(Object...) - Method in class java.lang.invoke. VarHandle

返回变量的值，读取的内存语义就像变量声明为 volatile 。

getVolatileOffscreenBuffer(Component, int, int) - Method in class javax.swing. RepaintManager

返回一个应该用作具有指定组件 c的双缓冲区的易失性的屏幕外缓冲区。

getVolume() - Method in class javafx.scene.media. AudioClip

获取默认音量级别。

getVolume() - Method in class javafx.scene.media. MediaPlayer

检索音频播放音量。

getVolume() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的卷属性定义。

getVpos() - Method in enum javafx.geometry. Pos

返回垂直定位/对齐。

getVScrollbarWidth() - Method in class java.awt. ScrollPane

返回垂直滚动条将占用的宽度，该宽度与滚动窗格当前是否显示无关。

getVspace() - Method in interface org.w3c.dom.html. HTMLAppletElement

这个图像，小程序或对象之上和之下的垂直空间。

getVspace() - Method in interface org.w3c.dom.html. HTMLImageElement

此图像上下方向的垂直空间。

getVspace() - Method in interface org.w3c.dom.html. HTMLObjectElement

这个图像，小程序或对象之上和之下的垂直空间。

getVvalue() - Method in class javafx.scene.control. ScrollPane

获取属性vvalue的值。

getW() - Method in interface java.security.interfaces. ECPublicKey

返回公共点W.

getW() - Method in class java.security.spec. ECPublicKeySpec

返回公共点W.

getWaitedCount() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程等待通知的总次数。

getWaitedTime() - Method in class java.lang.management. ThreadInfo

返回与此 ThreadInfo相关联的线程等待通知的大致累积经过时间（以毫秒为单位），因为启用了线程争用监控。

getWaitingConsumerCount() - Method in class java.util.concurrent. LinkedTransferQueue

getWaitingConsumerCount() - Method in interface java.util.concurrent. TransferQueue

通过 BlockingQueue.take()或定时 poll返回等待接收元素的消费者数量的估计。

getWaitingThreads() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject

返回一个包含可能在此条件下等待的线程的集合。

getWaitingThreads() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject

返回一个包含可能在此条件下等待的线程的集合。

getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。

getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。

getWaitingThreads(Condition) - Method in class java.util.concurrent.locks. ReentrantLock

返回包含可能在与此锁相关联的给定条件下等待的线程的集合。

getWaitingThreads(Condition) - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回包含可能在与写锁相关联的给定条件下等待的线程的集合。

getWaitQueueLength() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject

返回等待此条件的线程数的估计。

getWaitQueueLength() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject

返回等待此条件的线程数的估计。

getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回等待与此同步器相关联的给定条件的线程数量的估计。

getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回等待与此同步器相关联的给定条件的线程数量的估计。

getWaitQueueLength(Condition) - Method in class java.util.concurrent.locks. ReentrantLock

返回与此锁相关联的给定条件等待的线程数的估计。

getWaitQueueLength(Condition) - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回与写入锁相关联的给定条件等待的线程数的估计。

getWantClientAuth() - Method in class com.sun.net.httpserver. HttpsParameters

返回是否应请求客户端身份验证。

getWantClientAuth() - Method in class javax.net.ssl. SSLEngine

如果引擎将 请求客户端身份验证，则返回true。

getWantClientAuth() - Method in class javax.net.ssl. SSLParameters

返回是否应请求客户端身份验证。

getWantClientAuth() - Method in class javax.net.ssl. SSLServerSocket

如果在新接受的服务器模式连接上 请求客户端认证，则返回true。

getWantClientAuth() - Method in class javax.net.ssl. SSLSocket

如果套接字 要求客户端认证，则返回true。

getWantsInput() - Method in class javax.swing. JOptionPane

返回 wantsInput属性的值。

getWarnings() - Method in interface java.sql. Connection

检索此 Connection对象上的呼叫报告的第一个警告。

getWarnings() - Method in interface java.sql. ResultSet

检索该 ResultSet对象上通过电话报告的第一个警告。

getWarnings() - Method in interface java.sql. Statement

检索通过此 Statement对象的呼叫报告的第一个警告。

getWarningString() - Method in class java.awt. Window

获取此窗口显示的警告字符串。

getWarningString() - Method in class javax.swing. JInternalFrame

获取与此内部框架一起显示的警告字符串。

getWebContext() - Method in class javafx.application. HostServices

不推荐用于删除：此API元素将在以后的版本中被删除。
自JDK 9 以来，此方法已被弃用，因为不推荐使用该API Applet API。

getWeekdays() - Method in class java.text. DateFormatSymbols

获得平日字符串。

getWeeksInWeekYear() - Method in class java.util. Calendar

返回此 Calendar代表的星期内的星期 Calendar 。

getWeeksInWeekYear() - Method in class java.util. GregorianCalendar

返回周在数量 week year由这代表 GregorianCalendar 。

getWeekYear() - Method in class java.util. Calendar

返回此 Calendar代表的 Calendar 。

getWeekYear() - Method in class java.util. GregorianCalendar

返回此 GregorianCalendar所代表的 GregorianCalendar 。

getWeight() - Method in class java.util. Locale.LanguageRange

返回这个 LanguageRange的权重。

getWeight() - Method in enum javafx.scene.text. FontWeight

返回此 FontWeight指定的视觉重量（黑度或厚度）。

getWestPane() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回西面。

getWhatToShow() - Method in interface org.w3c.dom.ls. LSParserFilter

告诉 LSParser什么类型的节点要显示给方法 LSParserFilter.acceptNode 。

getWhatToShow() - Method in interface org.w3c.dom.ls. LSSerializerFilter

告诉 LSSerializer筛选器显示哪些类型的节点。

getWhatToShow() - Method in interface org.w3c.dom.traversal. NodeIterator

此属性确定通过 NodeIterator呈现哪些节点类型。

getWhatToShow() - Method in interface org.w3c.dom.traversal. TreeWalker

此属性确定通过 TreeWalker显示哪些节点类型。

getWheelRotation() - Method in class java.awt.event. MouseWheelEvent

返回鼠标滚轮旋转的“点击次数”为整数。

getWhen() - Method in class java.awt.event. ActionEvent

返回发生此事件的时间戳。

getWhen() - Method in class java.awt.event. InputEvent

返回此事件发生的时间戳与1970年1月1日UTC之间的毫秒之间的差异。

getWhen() - Method in class java.awt.event. InputMethodEvent

返回发生此事件的时间戳。

getWhen() - Method in class java.awt.event. InvocationEvent

返回发生此事件的时间戳。

getWhereClause() - Method in interface javax.sql.rowset. JoinRowSet

返回在JoinRowSet对象中使用的WHERE子句的类似SQL的描述。

getWhite() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的白色。

getWhite() - Method in class javax.swing.plaf.metal. MetalTheme

返回白色。

getWhiteSpace() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的空格属性定义。

getWholeText() - Method in interface org.w3c.dom. Text

将逻辑相邻的文本节点的所有文本的 Text文本返回到此节点，以文档顺序连接。

getWidows() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的widows属性定义。

getWidth() - Method in class java.awt. Component

返回此组件的当前宽度。

getWidth() - Method in class java.awt. Dimension

以双精度返回此 Dimension的宽度。

getWidth() - Method in class java.awt. DisplayMode

返回显示的宽度，以像素为单位。

getWidth() - Method in class java.awt.geom. Arc2D.Double

返回 double精度的成帧矩形的宽度。

getWidth() - Method in class java.awt.geom. Arc2D.Float

返回 double精度的框架矩形的宽度。

getWidth() - Method in class java.awt.geom. Dimension2D

以双精度返回此 Dimension的宽度。

getWidth() - Method in class java.awt.geom. Ellipse2D.Double

返回 double精度的框架矩形的宽度。

getWidth() - Method in class java.awt.geom. Ellipse2D.Float

以 double精度返回成帧矩形的宽度。

getWidth() - Method in class java.awt.geom. Rectangle2D.Double

以 double精度返回框架矩形的宽度。

getWidth() - Method in class java.awt.geom. Rectangle2D.Float

返回 double精度的成帧矩形的宽度。

getWidth() - Method in class java.awt.geom. RectangularShape

返回 double精度的成帧矩形的宽度。

getWidth() - Method in class java.awt.geom. RoundRectangle2D.Double

返回 double精度的成帧矩形的宽度。

getWidth() - Method in class java.awt.geom. RoundRectangle2D.Float

返回 double精度的成帧矩形的宽度。

getWidth() - Method in class java.awt.image. BufferedImage

返回 BufferedImage的宽度。

getWidth() - Method in class java.awt.image. Kernel

返回此 Kernel的宽度。

getWidth() - Method in class java.awt.image. PixelGrabber

获取像素缓冲区的宽度（调整图像宽度后）。

getWidth() - Method in class java.awt.image. Raster

返回栅格宽度（以像素为单位）。

getWidth() - Method in interface java.awt.image.renderable. RenderableImage

获取用户坐标空间中的宽度。

getWidth() - Method in class java.awt.image.renderable. RenderableImageOp

获取用户坐标空间中的宽度。

getWidth() - Method in interface java.awt.image. RenderedImage

返回RenderedImage的宽度。

getWidth() - Method in class java.awt.image. SampleModel

返回以像素为单位的宽度。

getWidth() - Method in class java.awt.image. VolatileImage

返回 VolatileImage的宽度。

getWidth() - Method in class java.awt.print. PageFormat

返回页面宽度的1/7英寸。

getWidth() - Method in class java.awt.print. Paper

返回1 / 72nds英寸的页面宽度。

getWidth() - Method in class java.awt. Rectangle

返回边界的宽度 Rectangle在 double精度。

getWidth() - Method in exception java.util. IllegalFormatWidthException

返回宽度

getWidth() - Method in class javafx.geometry. Bounds

该宽度为 Bounds 。

getWidth() - Method in class javafx.geometry. Dimension2D

尺寸的宽度。

getWidth() - Method in class javafx.geometry. Rectangle2D

该宽度为 Rectangle2D 。

getWidth() - Method in class javafx.print. Paper

以磅数（1/72英寸）获取纸张的宽度

getWidth() - Method in class javafx.scene.canvas. Canvas

获取属性宽度的值。

getWidth() - Method in class javafx.scene.control. Dialog

返回对话框的宽度。

getWidth() - Method in class javafx.scene.control. TableColumnBase

获取属性宽度的值。

getWidth() - Method in class javafx.scene.effect. BoxBlur

获取属性宽度的值。

getWidth() - Method in class javafx.scene.effect. ColorInput

获取属性宽度的值。

getWidth() - Method in class javafx.scene.effect. DropShadow

获取属性宽度的值。

getWidth() - Method in class javafx.scene.effect. FloatMap

获取属性宽度的值。

getWidth() - Method in class javafx.scene.effect. InnerShadow

获取属性宽度的值。

getWidth() - Method in class javafx.scene.effect. Shadow

获取属性宽度的值。

getWidth() - Method in class javafx.scene.image. Image

获取属性宽度的值。

getWidth() - Method in class javafx.scene.layout. BackgroundSize

相关联的BackgroundImage应该呈现的区域内的区域的宽度。

getWidth() - Method in class javafx.scene.layout. Region

获取属性宽度的值。

getWidth() - Method in class javafx.scene.media. Media

检索媒体的像素宽度。

getWidth() - Method in class javafx.scene.media. VideoTrack

检索轨道的宽度。

getWidth() - Method in class javafx.scene.paint. ImagePattern

获取锚矩形的宽度。

getWidth() - Method in class javafx.scene. Scene

获取属性宽度的值。

getWidth() - Method in class javafx.scene.shape. Box

获取属性宽度的值。

getWidth() - Method in class javafx.scene.shape. Rectangle

获取属性宽度的值。

getWidth() - Method in class javafx.scene. SubScene

获取属性宽度的值。

getWidth() - Method in class javafx.scene.web. WebView

获取属性宽度的值。

getWidth() - Method in class javafx.stage. Window

获取属性宽度的值。

getWidth() - Method in class javax.swing. JComponent

返回此组件的当前宽度。

getWidth() - Method in class javax.swing. SpringLayout.Constraints

返回 width属性的值。

getWidth() - Method in class javax.swing.table. TableColumn

返回 TableColumn的宽度。

getWidth() - Method in class javax.swing.text. BoxView

返回框的当前宽度。

getWidth() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的width属性定义。

getWidth() - Method in interface org.w3c.dom.html. HTMLAppletElement

覆盖宽度

getWidth() - Method in interface org.w3c.dom.html. HTMLHRElement

规则的宽度。

getWidth() - Method in interface org.w3c.dom.html. HTMLIFrameElement

框宽。

getWidth() - Method in interface org.w3c.dom.html. HTMLImageElement

覆盖宽度

getWidth() - Method in interface org.w3c.dom.html. HTMLObjectElement

覆盖宽度

getWidth() - Method in interface org.w3c.dom.html. HTMLPreElement

固定宽度的内容。

getWidth() - Method in interface org.w3c.dom.html. HTMLTableCellElement

单元宽度。

getWidth() - Method in interface org.w3c.dom.html. HTMLTableColElement

默认列宽。

getWidth() - Method in interface org.w3c.dom.html. HTMLTableElement

指定所需的表格宽度。

getWidth(int) - Method in class javax.imageio. ImageReader

返回输入源中给定图像的宽度（以像素为单位）。

getWidth(int) - Method in class javax.print.attribute.standard. MediaPrintableArea

以指定单位获取可打印区域的宽度。

getWidth(ImageObserver) - Method in class java.awt.image. AbstractMultiResolutionImage

该方法简单地委托给基本图像上的相同方法，它等效于： getBaseImage().getWidth(observer) 。

getWidth(ImageObserver) - Method in class java.awt.image. BufferedImage

返回 BufferedImage的宽度。

getWidth(ImageObserver) - Method in class java.awt. Image

确定图像的宽度。

getWidthOfHighValueLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最高值标签的宽度。

getWidthOfLowValueLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最小值标签的宽度。

getWidthOfWidestLabel() - Method in class javax.swing.plaf.basic. BasicSliderUI

返回最宽标签的宽度。

getWidths() - Method in class java.awt. FontMetrics

获取 Font前256个字符的提前宽度。

getWidths() - Method in class javafx.scene.layout. BorderImage

每侧边框的宽度。

getWidths() - Method in class javafx.scene.layout. BorderStroke

定义BorderStroke的每一边的厚度。

getWildcardType(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util. Types

返回一个新的通配符类型参数。

getWindingRule() - Method in class java.awt.geom. FlatteningPathIterator

返回确定路径内部的绕组规则。

getWindingRule() - Method in class java.awt.geom. Path2D

返回填充样式卷绕规则。

getWindingRule() - Method in interface java.awt.geom. PathIterator

返回确定路径内部的绕组规则。

getWindow() - Method in class java.awt.event. WindowEvent

返回事件的发起者。

getWindow() - Method in class javafx.scene. Scene

获取属性窗口的值。

getWindow(Applet) - Static method in class netscape.javascript. JSObject

已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

getWindowAncestor(Component) - Static method in class javax.swing. SwingUtilities

返回第 Window祖先 c ，或 null如果 c未包含在里面 Window 。

getWindowBackground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的窗口背景颜色。

getWindowBackground() - Method in class javax.swing.plaf.metal. MetalTheme

返回窗口背景颜色。

getWindowDecorationStyle() - Method in class javax.swing. JRootPane

返回一个常数，用于标识 JRootPane提供的窗口装饰类型。

getWindowFocusListeners() - Method in class java.awt. Window

返回在此窗口上注册的所有窗口焦点侦听器的数组。

getWindowListeners() - Method in class java.awt. Window

返回在此窗口上注册的所有窗口侦听器的数组。

getWindows() - Static method in class java.awt. Window

返回由此应用程序创建的所有 Window的数组，包括拥有和无主。

getWindows() - Static method in class javafx.stage. Window

返回一个包含对当前显示的JavaFX窗口的引用的列表。

getWindowStateListeners() - Method in class java.awt. Window

返回在此窗口上注册的所有窗口状态侦听器的数组。

getWindowTitleBackground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的窗口标题背景颜色。

getWindowTitleBackground() - Method in class javax.swing.plaf.metal. MetalTheme

返回窗口标题背景颜色。

getWindowTitleFont() - Method in class javax.swing.plaf.metal. DefaultMetalTheme

返回窗口标题字体。

getWindowTitleFont() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的窗口标题字体。

getWindowTitleFont() - Method in class javax.swing.plaf.metal. MetalTheme

返回窗口标题字体。

getWindowTitleForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的窗口标题前景色。

getWindowTitleForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回窗口标题前景色。

getWindowTitleInactiveBackground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的窗口标题无效背景颜色。

getWindowTitleInactiveBackground() - Method in class javax.swing.plaf.metal. MetalTheme

返回窗口标题无效背景颜色。

getWindowTitleInactiveForeground() - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

返回当前主题的窗口标题无效的前景色。

getWindowTitleInactiveForeground() - Method in class javax.swing.plaf.metal. MetalTheme

返回窗口标题无效的前景色。

getWithLookup(Supplier<T>, SecureLookupSupplier) - Method in interface jdk.dynalink.linker. LinkerServices

在特定的 MethodHandles.Lookup查找对象的上下文中执行操作。

getWordEnd(JTextComponent, int) - Static method in class javax.swing.text. Utilities

确定给定位置的单词的结尾。

getWordInstance() - Static method in class java.text. BreakIterator

为 default locale返回一个新的 BreakIterator实例 word breaks 。

getWordInstance(Locale) - Static method in class java.text. BreakIterator

为给定的区域设置返回一个新的 BreakIterator实例 word breaks 。

getWordInstance(Locale) - Method in class java.text.spi. BreakIteratorProvider

为给定的区域设置返回一个新的 BreakIterator实例 word breaks 。

getWordSize() - Method in class javax.crypto.spec. RC5ParameterSpec

以位为单位返回字大小。

getWordSpacing() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的word-spacing属性定义。

getWordStart(JTextComponent, int) - Static method in class javax.swing.text. Utilities

确定给定模型位置的单词开始。

getWorkDone() - Method in class javafx.concurrent. Service

获取属性workDone的值。

getWorkDone() - Method in class javafx.concurrent. Task

获取属性workDone的值。

getWorkDone() - Method in interface javafx.concurrent. Worker

表示已完成的当前工作量。

getWrapperType(Class<?>) - Static method in class jdk.dynalink.linker.support. TypeUtilities

当传递表示原始类型的类时，返回表示相应包装器类型的类。

getWrappingWidth() - Method in class javafx.scene.text. Text

获取propertyWidth的值。

getWrapSizeLimit(int, boolean, int) - Method in interface org.ietf.jgss. GSSContext

用于确定可传递给 wrap的消息大小的限制。

getWrapStyleWord() - Method in class javax.swing. JTextArea

如果文本区域是包装线，则获取使用的包装样式。

getWritableInstancePropertyNames(Class<?>) - Static method in class jdk.dynalink.beans. BeansLinker

返回一组类的所有可写实例属性的名称。

getWritableParent() - Method in class java.awt.image. WritableRaster

返回此WritableRaster的父WritableRaster（如果有），否则返回null。

getWritableStaticPropertyNames(Class<?>) - Static method in class jdk.dynalink.beans. BeansLinker

返回一组类的所有可写静态属性的名称。

getWritableTile(int, int) - Method in class java.awt.image. BufferedImage

检查一个瓦片写作。

getWritableTile(int, int) - Method in interface java.awt.image. WritableRenderedImage

检查一个瓦片写作。

getWritableTileIndices() - Method in class java.awt.image. BufferedImage

返回一个Point个对象的数组，指示哪些图块被签出用于写入。

getWritableTileIndices() - Method in interface java.awt.image. WritableRenderedImage

返回一个Point对象数组，指示哪些tile被签出用于写入。

getWriteHoldCount() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

查询当前线程对此锁的可重入写入数量。

getWriteMethod() - Method in class java.beans. PropertyDescriptor

获取应用于写入属性值的方法。

getWriter() - Method in interface javax.script. ScriptContext

返回显示输出时要使用的脚本的 Writer 。

getWriter() - Method in class javax.script. SimpleScriptContext

返回显示输出时要使用的脚本的 Writer 。

getWriter() - Method in class javax.swing.text. AbstractWriter

返回用于输出内容的Writer。

getWriter() - Method in class javax.xml.transform.stream. StreamResult

获取使用setWriter设置的字符流。

getWriterFileSuffixes() - Static method in class javax.imageio. ImageIO

返回一个 String的数组， String列出了与当前注册作者集合所理解的格式相关联的所有文件后缀。

getWriterFormatNames() - Static method in class javax.imageio. ImageIO

返回一个 String的数组， String列出了当前注册作者集所理解的所有非正式格式名称。

getWriterMIMETypes() - Static method in class javax.imageio. ImageIO

返回一个 String的数组， String列出了当前注册的作者集所理解的所有MIME类型。

getWriterServiceProviderName() - Method in class javax.imageio.spi. ImageTranscoderSpi

返回 ImageWriterSpi类的完全限定类名，该类可生成 IIOMetadata此代码转换器输入的 IIOMetadata对象。

getWSDLDocumentLocation() - Method in class javax.xml.ws. Service

获取此服务的WSDL文档的位置。

getWSDLDocumentLocation() - Method in class javax.xml.ws.spi. ServiceDelegate

获取此服务的WSDL文档的位置。

getX() - Method in class java.awt. Component

返回组件原点的当前x坐标。

getX() - Method in class java.awt.dnd. DragSourceEvent

此方法在此事件发生时返回屏幕坐标中光标位置的水平坐标，如果未为此事件指定光标位置，则返回0。

getX() - Method in class java.awt.event. MouseEvent

返回事件相对于源组件的水平x位置。

getX() - Method in class java.awt.geom. Arc2D.Double

返回 double精度的框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. Arc2D.Float

返回 double精度的框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. Ellipse2D.Double

返回 double精度的框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. Ellipse2D.Float

返回 double精度的框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. Point2D.Double

返回这个 Point2D的X坐标在 double精度。

getX() - Method in class java.awt.geom. Point2D.Float

以 double精度返回此 Point2D的X坐标。

getX() - Method in class java.awt.geom. Point2D

返回 Point2D的X坐标 double精度。

getX() - Method in class java.awt.geom. Rectangle2D.Double

以 double精度返回框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. Rectangle2D.Float

返回 double精度的框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. RectangularShape

返回 double精度的框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. RoundRectangle2D.Double

返回 double精度的框架矩形左上角的X坐标。

getX() - Method in class java.awt.geom. RoundRectangle2D.Float

以 double精度返回成帧矩形左上角的X坐标。

getX() - Method in class java.awt. Point

返回 Point2D的 double精度的X坐标。

getX() - Method in class java.awt. Rectangle

返回 double精度的边界 Rectangle的X坐标。

getX() - Method in interface java.security.interfaces. DSAPrivateKey

返回私钥的值， x 。

getX() - Method in class java.security.spec. DSAPrivateKeySpec

返回私钥 x 。

getX() - Method in class javafx.geometry. Point2D

x坐标。

getX() - Method in class javafx.geometry. Point3D

x坐标。

getX() - Method in class javafx.scene.control. Dialog

获取属性x的值。

getX() - Method in class javafx.scene.effect. ColorInput

获取属性x的值。

getX() - Method in class javafx.scene.effect. ImageInput

获取属性x的值。

getX() - Method in class javafx.scene.effect. Light.Point

获取属性x的值。

getX() - Method in class javafx.scene.image. ImageView

获取属性x的值。

getX() - Method in class javafx.scene.input. ContextMenuEvent

事件的水平位置相对于ContextMenuEvent的来源的原点。

getX() - Method in class javafx.scene.input. DragEvent

事件相对于DragEvent源的原点的水平位置。

getX() - Method in class javafx.scene.input. GestureEvent

获取事件相对于事件源的原点的水平位置。

getX() - Method in class javafx.scene.input. MouseEvent

事件的水平位置相对于MouseEvent源的来源。

getX() - Method in class javafx.scene.input. TouchPoint

获取触摸点相对于TouchEvent源的原点的水平位置。

getX() - Method in class javafx.scene.media. MediaView

检索 MediaView原点的x坐标。

getX() - Method in class javafx.scene.paint. ImagePattern

获取锚矩形的x原点。

getX() - Method in class javafx.scene. Scene

获取属性x的值。

getX() - Method in class javafx.scene.shape. ArcTo

获取属性x的值。

getX() - Method in class javafx.scene.shape. CubicCurveTo

获取属性x的值。

getX() - Method in class javafx.scene.shape. HLineTo

获取属性x的值。

getX() - Method in class javafx.scene.shape. LineTo

获取属性x的值。

getX() - Method in class javafx.scene.shape. MoveTo

获取属性x的值。

getX() - Method in class javafx.scene.shape. QuadCurveTo

获取属性x的值。

getX() - Method in class javafx.scene.shape. Rectangle

获取属性x的值。

getX() - Method in class javafx.scene.text. Text

获取属性x的值。

getX() - Method in class javafx.scene.transform. Scale

获取属性x的值。

getX() - Method in class javafx.scene.transform. Shear

获取属性x的值。

getX() - Method in class javafx.scene.transform. Translate

获取属性x的值。

getX() - Method in class javafx.stage. Window

获取属性x的值。

getX() - Method in interface javax.crypto.interfaces. DHPrivateKey

返回私有值， x 。

getX() - Method in class javax.crypto.spec. DHPrivateKeySpec

返回私有值 x 。

getX() - Method in class javax.swing. JComponent

返回组件原点的当前x坐标。

getX() - Method in class javax.swing. SpringLayout.Constraints

返回 x属性的值。

getX(int) - Method in class javax.print.attribute. Size2DSyntax

将给定单位的二维大小属性的X维度作为浮点值返回。

getX(int) - Method in class javax.print.attribute.standard. MediaPrintableArea

以指定单位获取可打印区域的原点的x位置。

getX1() - Method in class java.awt.geom. CubicCurve2D.Double

200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200

getX1() - Method in class java.awt.geom. CubicCurve2D.Float

200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200

getX1() - Method in class java.awt.geom. CubicCurve2D

200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200

getX1() - Method in class java.awt.geom. Line2D.Double

200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200

getX1() - Method in class java.awt.geom. Line2D.Float

200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200

getX1() - Method in class java.awt.geom. Line2D

200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200

getX1() - Method in class java.awt.geom. QuadCurve2D.Double

以 double的精度返回起始点的X坐标。

getX1() - Method in class java.awt.geom. QuadCurve2D.Float

以 double的精度返回起始点的X坐标。

getX1() - Method in class java.awt.geom. QuadCurve2D

以 double的精度返回起始点的X坐标。

getX2() - Method in class java.awt.geom. CubicCurve2D.Double

X-

getX2() - Method in class java.awt.geom. CubicCurve2D.Float

X-

getX2() - Method in class java.awt.geom. CubicCurve2D

X-

getX2() - Method in class java.awt.geom. Line2D.Double

X-

getX2() - Method in class java.awt.geom. Line2D.Float

X-

getX2() - Method in class java.awt.geom. Line2D

X-

getX2() - Method in class java.awt.geom. QuadCurve2D.Double

以 double精度返回终点的X坐标。

getX2() - Method in class java.awt.geom. QuadCurve2D.Float

以 double精度返回终点的X坐标。

getX2() - Method in class java.awt.geom. QuadCurve2D

以 double精度返回终点的X坐标。

getXAConnection() - Method in interface javax.sql. XADataSource

尝试建立可在分布式事务中使用的物理数据库连接。

getXAConnection(String, String) - Method in interface javax.sql. XADataSource

尝试使用给定的用户名和密码建立物理数据库连接。

getXAResource() - Method in interface javax.sql. XAConnection

检索一个 XAResource对象，事务管理器将使用管理这个 XAConnection分布式事务对象的参与。

getXAxis() - Method in class javafx.scene.chart. XYChart

获取X轴，默认情况下，它是沿着图的底部

getXAxisRotation() - Method in class javafx.scene.shape. ArcTo

以度数获取x轴旋转。

getXMicrometers() - Method in class javax.print.attribute. Size2DSyntax

以微米（μm）为单位返回此二维尺寸属性的X尺寸。

getXmlEncoding() - Method in interface org.w3c.dom. Document

作为 XML declaration的一部分的属性，指定此文档的编码。

getXmlEncoding() - Method in interface org.w3c.dom. Entity

作为文本声明的一部分的属性，指定该实体的编码，当它是外部解析实体时。

getXMLEventReader() - Method in class javax.xml.transform.stax. StAXSource

获取 XMLEventReader使用的 StAXSource 。

getXMLEventWriter() - Method in class javax.xml.transform.stax. StAXResult

获取此 XMLEventWriter使用的 StAXResult 。

getXMLNode(Object) - Method in class javax.xml.bind. Binder

获取与给定JAXB对象关联的XML元素。

getXMLReader() - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

获取配置的XMLReader。

getXMLReader() - Method in class javax.xml.parsers. SAXParser

返回由该类实现封装的XMLReader 。

getXMLReader() - Method in class javax.xml.transform.sax. SAXSource

获取XMLReader用于源。

getXMLReporter() - Method in class javax.xml.stream. XMLInputFactory

该记者会设置在由此工厂实例创建的任何XMLStreamReader或XMLEventReader上。

getXMLResolver() - Method in class javax.xml.stream. XMLInputFactory

将在此工厂实例创建的任何XMLStreamReader或XMLEventReader上设置的解析器。

getXMLSchemaType() - Method in class javax.xml.datatype. Duration

返回此实例映射到的XML模式日期/时间类型的名称。

getXMLSchemaType() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回此实例映射到的XML模式日期/时间类型的名称。

getXmlStandalone() - Method in interface org.w3c.dom. Document

作为 XML declaration的一部分，属性指定此文档是否是独立的。

getXMLStreamReader() - Method in class javax.xml.transform.stax. StAXSource

获取 XMLStreamReader使用的 StAXSource 。

getXMLStreamWriter() - Method in class javax.xml.transform.stax. StAXResult

获取此 XMLStreamWriter使用的 StAXResult 。

getXmlVersion() - Method in interface org.w3c.dom. Document

作为 XML declaration的一部分的属性，指定此文档的版本号。

getXmlVersion() - Method in interface org.w3c.dom. Entity

作为文本声明的一部分的属性，当作为外部解析实体时，指定该实体的版本号。

getXMLVersion() - Method in interface org.xml.sax.ext. Locator2

返回实体使用的XML版本。

getXMLVersion() - Method in class org.xml.sax.ext. Locator2Impl

返回version属性的当前值。

getXOnScreen() - Method in class java.awt.event. MouseEvent

返回事件的绝对水平x位置。

getXOrigin() - Method in class java.awt.image. Kernel

返回此 Kernel的X原点。

getXPath() - Method in class javax.xml.crypto.dsig.spec. XPathFilterParameterSpec

返回要评估的XPath表达式。

getXPathFunctionResolver() - Method in interface javax.xml.xpath. XPath

返回当前函数解析器。

getXPathList() - Method in class javax.xml.crypto.dsig.spec. XPathFilter2ParameterSpec

返回一个或多个XPathType对象的列表。

getXPathVariableResolver() - Method in interface javax.xml.xpath. XPath

返回当前变量解析器。

getXValue() - Method in class javafx.scene.chart. XYChart.Data

获取在X轴上绘制的通用数据值。

getY() - Method in class java.awt. Component

返回组件原点的当前y坐标。

getY() - Method in class java.awt.dnd. DragSourceEvent

此方法返回在此事件发生时屏幕坐标中光标位置的垂直坐标，如果未为此事件指定光标位置，则返回0。

getY() - Method in class java.awt.event. MouseEvent

返回事件相对于源组件的垂直y位置。

getY() - Method in class java.awt.geom. Arc2D.Double

返回 double精度的框架矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. Arc2D.Float

返回 double精度的成帧矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. Ellipse2D.Double

返回 double精度的框架矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. Ellipse2D.Float

返回 double精度的框架矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. Point2D.Double

返回 Point2D的Y坐标 double精度。

getY() - Method in class java.awt.geom. Point2D.Float

返回 Point2D的Y坐标 double精度。

getY() - Method in class java.awt.geom. Point2D

返回此的Y坐标 Point2D在 double精度。

getY() - Method in class java.awt.geom. Rectangle2D.Double

返回 double精度的框架矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. Rectangle2D.Float

返回 double精度的框架矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. RectangularShape

返回 double精度的框架矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. RoundRectangle2D.Double

返回 double精度的框架矩形左上角的Y坐标。

getY() - Method in class java.awt.geom. RoundRectangle2D.Float

返回 double精度的成帧矩形左上角的Y坐标。

getY() - Method in class java.awt. Point

返回 Point2D的这个 double精度的Y坐标。

getY() - Method in class java.awt. Rectangle

返回 double精度的界限 Rectangle的Y坐标。

getY() - Method in interface java.security.interfaces. DSAPublicKey

返回公钥的值， y 。

getY() - Method in class java.security.spec. DSAPublicKeySpec

返回公钥 y 。

getY() - Method in class javafx.geometry. Point2D

y坐标。

getY() - Method in class javafx.geometry. Point3D

y坐标。

getY() - Method in class javafx.scene.control. Dialog

获取属性y的值。

getY() - Method in class javafx.scene.effect. ColorInput

获取属性y的值。

getY() - Method in class javafx.scene.effect. ImageInput

获取属性y的值。

getY() - Method in class javafx.scene.effect. Light.Point

获取属性y的值。

getY() - Method in class javafx.scene.image. ImageView

获取属性y的值。

getY() - Method in class javafx.scene.input. ContextMenuEvent

事件的相对于ContextMenuEvent源的起始位置的垂直位置。

getY() - Method in class javafx.scene.input. DragEvent

事件相对于DragEvent源的原点的垂直位置。

getY() - Method in class javafx.scene.input. GestureEvent

获取事件相对于事件源的原点的垂直位置。

getY() - Method in class javafx.scene.input. MouseEvent

事件相对于MouseEvent来源的垂直位置。

getY() - Method in class javafx.scene.input. TouchPoint

获取触摸点相对于TouchEvent源的原点的垂直位置。

getY() - Method in class javafx.scene.media. MediaView

检索 MediaView原点的y坐标。

getY() - Method in class javafx.scene.paint. ImagePattern

获取锚矩形的y原点。

getY() - Method in class javafx.scene. Scene

获取属性y的值。

getY() - Method in class javafx.scene.shape. ArcTo

获取属性y的值。

getY() - Method in class javafx.scene.shape. CubicCurveTo

获取属性y的值。

getY() - Method in class javafx.scene.shape. LineTo

获取属性y的值。

getY() - Method in class javafx.scene.shape. MoveTo

获取属性y的值。

getY() - Method in class javafx.scene.shape. QuadCurveTo

获取属性y的值。

getY() - Method in class javafx.scene.shape. Rectangle

获取属性y的值。

getY() - Method in class javafx.scene.shape. VLineTo

获取属性y的值。

getY() - Method in class javafx.scene.text. Text

获取属性y的值。

getY() - Method in class javafx.scene.transform. Scale

获取属性y的值。

getY() - Method in class javafx.scene.transform. Shear

获取属性y的值。

getY() - Method in class javafx.scene.transform. Translate

获取属性y的值。

getY() - Method in class javafx.stage. Window

获取属性y的值。

getY() - Method in interface javax.crypto.interfaces. DHPublicKey

返回公共值， y 。

getY() - Method in class javax.crypto.spec. DHPublicKeySpec

返回公开值 y 。

getY() - Method in class javax.swing. JComponent

返回组件原点的当前y坐标。

getY() - Method in class javax.swing. SpringLayout.Constraints

返回 y属性的值。

getY(int) - Method in class javax.print.attribute. Size2DSyntax

以给定单位返回此二维大小属性的Y维度作为浮点值。

getY(int) - Method in class javax.print.attribute.standard. MediaPrintableArea

以指定单位获取可打印区域的原点的y位置。

getY1() - Method in class java.awt.geom. CubicCurve2D.Double

新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200

getY1() - Method in class java.awt.geom. CubicCurve2D.Float

新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200

getY1() - Method in class java.awt.geom. CubicCurve2D

新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200

getY1() - Method in class java.awt.geom. Line2D.Double

新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200

getY1() - Method in class java.awt.geom. Line2D.Float

新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200

getY1() - Method in class java.awt.geom. Line2D

新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200

getY1() - Method in class java.awt.geom. QuadCurve2D.Double

以 double精度返回起始点的Y坐标。

getY1() - Method in class java.awt.geom. QuadCurve2D.Float

返回起始点的Y坐标在 double精度。

getY1() - Method in class java.awt.geom. QuadCurve2D

以 double精度返回起始点的Y坐标。

getY2() - Method in class java.awt.geom. CubicCurve2D.Double

以双精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. CubicCurve2D.Float

以双精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. CubicCurve2D

以双精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. Line2D.Double

以双精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. Line2D.Float

以双精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. Line2D

以双精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. QuadCurve2D.Double

以 double精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. QuadCurve2D.Float

以 double精度返回终点的Y坐标。

getY2() - Method in class java.awt.geom. QuadCurve2D

以 double精度返回终点的Y坐标。

getYAxis() - Method in class javafx.scene.chart. XYChart

获取Y轴，默认情况下它在图的左侧

getYear() - Method in class java.sql. Time

已过时。

getYear() - Method in class java.time. LocalDate

获取年份字段。

getYear() - Method in class java.time. LocalDateTime

获取年份字段。

getYear() - Method in class java.time. OffsetDateTime

获取年份字段。

getYear() - Method in class java.time. YearMonth

获取年份字段。

getYear() - Method in class java.time. ZonedDateTime

获取年份字段。

getYear() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.get(Calendar.YEAR) - 1900替代。

getYear() - Method in class javax.xml.datatype. XMLGregorianCalendar

为 year或 DatatypeConstants.FIELD_UNDEFINED返回XML Schema 1.0 dateTime数据类型字段的 year 组件 。

getYears() - Method in class java.time. Period

获得这段时间的年数。

getYears() - Method in class javax.xml.datatype. Duration

如果不存在，请将该 Duration的年份值作为 int或 0 。

getYMicrometers() - Method in class javax.print.attribute. Size2DSyntax

以微米（μm）为单位返回此二维尺寸属性的Y尺寸。

getYOnScreen() - Method in class java.awt.event. MouseEvent

返回事件的绝对垂直y位置。

getYOrigin() - Method in class java.awt.image. Kernel

返回此 Kernel的Y原点。

getYValue() - Method in class javafx.scene.chart. XYChart.Data

获取在Y轴上绘制的通用数据值。

getZ() - Method in class javafx.geometry. Point3D

z坐标。

getZ() - Method in class javafx.scene.effect. Light.Point

获取属性z的值。

getZ() - Method in class javafx.scene.input. ContextMenuEvent

事件的相对于MouseEvent源的来源的深度位置。

getZ() - Method in class javafx.scene.input. DragEvent

事件的相对于MouseEvent源的来源的深度位置。

getZ() - Method in class javafx.scene.input. GestureEvent

事件的相对于MouseEvent源的来源的深度位置。

getZ() - Method in class javafx.scene.input. MouseEvent

事件的相对于MouseEvent源的来源的深度位置。

getZ() - Method in class javafx.scene.input. TouchPoint

事件的相对于MouseEvent源的来源的深度位置。

getZ() - Method in class javafx.scene.transform. Scale

获取属性z的值。

getZ() - Method in class javafx.scene.transform. Translate

获取属性z的值。

getZeroDigit() - Method in class java.text. DecimalFormatSymbols

获取用于零的字符。

getZeroDigit() - Method in class java.time.format. DecimalStyle

获取表示零的字符。

getZeroPosition() - Method in class javafx.scene.chart. Axis

获取沿该轴的零线的显示位置。

getZeroPosition() - Method in class javafx.scene.chart. CategoryAxis

获取沿该轴的零线的显示位置。

getZeroPosition() - Method in class javafx.scene.chart. ValueAxis

获取零轴沿该轴的显示位置。

getZIndex() - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的z-index属性定义。

getZone() - Method in interface java.time.chrono. ChronoZonedDateTime

获取区域ID，例如“欧洲/巴黎”。

getZone() - Method in class java.time. Clock

获取用于创建日期和时间的时区。

getZone() - Method in class java.time.format. DateTimeFormatter

获取在格式化期间使用的覆盖区域。

getZone() - Method in class java.time. ZonedDateTime

获得时区，如“欧洲/巴黎”。

getZoneStrings() - Method in class java.text. DateFormatSymbols

获取时区字符串。

getZoom() - Method in class javafx.scene.web. WebView

获取属性变焦的值。

getZoomFactor() - Method in class javafx.scene.input. ZoomEvent

获取此事件的缩放量。

GHOSTWHITE - Static variable in class javafx.scene.paint. Color

颜色为Ghost的白色，RGB值为＃F8F8FF

gid - Variable in class com.sun.security.auth.module. SolarisSystem

已过时。

gid - Variable in class com.sun.security.auth.module. UnixSystem

GIF - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "image/gif" ，打印数据表示类名= "[B" （字节数组）。

GIF - Static variable in class javax.print. DocFlavor.INPUT_STREAM

文件风味与MIME类型= "image/gif" ，打印数据表示类名= "java.io.InputStream" （字节流）。

GIF - Static variable in class javax.print. DocFlavor.URL

具有MIME类型的文档风味= "image/gif" ，打印数据表示类名= "java.net.URL" 。

GLAGOLITIC - java.lang. Character.UnicodeScript

Unicode脚本“Glagolitic”。

GLAGOLITIC - Static variable in class java.lang. Character.UnicodeBlock

“Glagolitic”Unicode字符块的常量。

GLASS_PANE - Static variable in class javax.accessibility. AccessibleRole

保证在其下方的所有窗格的顶部绘制的窗格。

GLASS_PANE_PROPERTY - Static variable in class javax.swing. JInternalFrame

绑定属性名称。

glassPane - Variable in class javax.swing. JRootPane

玻璃窗格覆盖菜单栏和内容窗格，因此可以拦截鼠标移动等。

glassPaneDispatcher - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI

玻璃窗格调度器

GlassPaneDispatcher() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher

global - Static variable in class java.util.logging. Logger

已过时。
此字段的初始化容易出现死锁。 该字段必须由Logger类初始化初始化，这可能会导致与LogManager类初始化的死锁。 在这种情况下，两个类初始化等待彼此完成。 获取全局记录器对象的首选方法是通过调用Logger.getGlobal() 。 为了兼容Logger.getGlobal()不可用的旧JDK版本，请使用电话Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)或Logger.getLogger("global") 。

GLOBAL() - Constructor for class javax.xml.bind.annotation. XmlElementDecl.GLOBAL

GLOBAL_LOGGER_NAME - Static variable in class java.util.logging. Logger

GLOBAL_LOGGER_NAME是全球记录器的名称。

GLOBAL_SCOPE - Static variable in interface javax.script. ScriptContext

由相同ScriptEngineFactory创建的所有引擎都可以看到GlobalScope属性。

globalHierarchyLock - Static variable in interface java.beans.beancontext. BeanContext

这个全局锁由 BeanContext和 BeanContextServices实现者使用，以序列化 BeanContext层次结构和任何服务请求等中的更改。

globalScope - Variable in class javax.script. SimpleScriptContext

这是全局范围绑定。

GlobalScope() - Constructor for class javax.xml.bind. JAXBElement.GlobalScope

Glow - Class in javafx.scene.effect

基于可配置的阈值，使输入图像看起来发亮的高级效果。

Glow() - Constructor for class javafx.scene.effect. Glow

使用默认参数创建一个新的Glow实例。

Glow(double) - Constructor for class javafx.scene.effect. Glow

创建一个新的具有指定级别的Glow实例。

GlyphJustificationInfo - Class in java.awt.font

GlyphJustificationInfo类表示有关字形对齐属性的信息。

GlyphJustificationInfo(float, boolean, int, float, float, boolean, int, float, float) - Constructor for class java.awt.font. GlyphJustificationInfo

构造关于字形对齐属性的信息。

GlyphMetrics - Class in java.awt.font

GlyphMetrics类代表单个字形的信息。

GlyphMetrics(boolean, float, float, Rectangle2D, byte) - Constructor for class java.awt.font. GlyphMetrics

构造一个 GlyphMetrics对象。

GlyphMetrics(float, Rectangle2D, byte) - Constructor for class java.awt.font. GlyphMetrics

构造一个 GlyphMetrics对象。

GlyphPainter() - Constructor for class javax.swing.text. GlyphView.GlyphPainter

GlyphVector - Class in java.awt.font

GlyphVector对象是包含几何信息的字形的集合，用于在对应于最终显示 GlyphVector的设备的变换的坐标空间中放置每个字形。

GlyphVector() - Constructor for class java.awt.font. GlyphVector

GlyphView - Class in javax.swing.text

GlyphView是一种风格的文本块，表示在文本模型中映射到元素上的视图。

GlyphView(Element) - Constructor for class javax.swing.text. GlyphView

构造一个包含在元素上的新视图。

GlyphView.GlyphPainter - Class in javax.swing.text

一个执行字形渲染的类。

GMONTH - Static variable in class javax.xml.datatype. DatatypeConstants

W3C XML Schema 1.0数据类型 gMonth完全限定名称。

GMONTHDAY - Static variable in class javax.xml.datatype. DatatypeConstants

W3C XML Schema 1.0数据类型 gMonthDay完全限定名称。

go(int) - Method in class javafx.scene.web. WebHistory

将Web引擎导航到 Entry对象在相对于当前条目的指定位置中定义的URL。

GoHomeAction() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.GoHomeAction

构造一个 GoHomeAction 。

GOLD - Static variable in class javafx.scene.paint. Color

彩色金色，RGB值为＃FFD700

GOLDENROD - Static variable in class javafx.scene.paint. Color

颜色金色，RGB值为＃DAA520

GoodBreakWeight - Static variable in class javax.swing.text. View

指示视图的重量支持突破，但可能存在更好的机会。

GOPHER - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported

Gopher议定书。

GOT_FOCUS - Static variable in class java.awt. Event

已过时。

一个组件获得了重点。

gotDefault - Variable in class javax.naming. InitialContext

指示是否通过调用NamingManager.getInitialContext（）获取初始上下文的字段。

gotFocus(Event, Object) - Method in class java.awt. Component

已过时。
从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。

GOTHIC - java.lang. Character.UnicodeScript

Unicode脚本“哥特式”。

GOTHIC - Static variable in class java.lang. Character.UnicodeBlock

“哥特式”Unicode字符块的常数。

GotoTree - Interface in jdk.nashorn.api.tree

用于跳转到目标的语句的树节点。

GPS_VERSION_2_2 - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

与“GPSVersionID”标签一起使用以指示GPS版本2.2的值。

grab() - Method in class javafx.scene.input. TouchPoint

抓住这个接触点的当前事件来源。

grab(EventTarget) - Method in class javafx.scene.input. TouchPoint

按照给定的目标抓住这个接触点。

grabFocus() - Method in class javax.swing. JComponent

请求此组件获取输入焦点，并且该组件的顶级祖先成为关注的窗口。

grabPixels() - Method in class java.awt.image. PixelGrabber

请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送。

grabPixels(long) - Method in class java.awt.image. PixelGrabber

请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送，或者直到指定的超时过去。

GRAD - javafx.css. SizeUnits

GRADE_CHECK_ALL_AT_COMMIT - Static variable in class javax.sql.rowset.spi. SyncProvider

表示相对于始发数据源的高级乐观同步等级。

GRADE_CHECK_MODIFIED_AT_COMMIT - Static variable in class javax.sql.rowset.spi. SyncProvider

表示相对于始发数据源的低级乐观同步等级。

GRADE_LOCK_WHEN_LOADED - Static variable in class javax.sql.rowset.spi. SyncProvider

表示相对于始发数据源最悲观的同步等级。

GRADE_LOCK_WHEN_MODIFIED - Static variable in class javax.sql.rowset.spi. SyncProvider

表示相对于始发数据源的悲观同步等级。

GRADE_NONE - Static variable in class javax.sql.rowset.spi. SyncProvider

表示不提供与始发数据源的同步。

GradientPaint - Class in java.awt

GradientPaint课程提供了一种填充Shape线性颜色渐变模式的方式。

GradientPaint(float, float, Color, float, float, Color) - Constructor for class java.awt. GradientPaint

构造一个简单的非循环 GradientPaint对象。

GradientPaint(float, float, Color, float, float, Color, boolean) - Constructor for class java.awt. GradientPaint

根据 boolean参数构建循环或非循环 GradientPaint对象。

GradientPaint(Point2D, Color, Point2D, Color) - Constructor for class java.awt. GradientPaint

构造一个简单的非循环 GradientPaint对象。

GradientPaint(Point2D, Color, Point2D, Color, boolean) - Constructor for class java.awt. GradientPaint

根据 boolean参数构建循环或非循环 GradientPaint对象。

GRANTHA - java.lang. Character.UnicodeScript

Unicode脚本“Grantha”。

GRANTHA - Static variable in class java.lang. Character.UnicodeBlock

“Grantha”Unicode字符块的常量。

GRAPHIC_ONLY - javafx.scene.control. ContentDisplay

只会显示内容。

GraphicAttribute - Class in java.awt.font

该类与CHAR_REPLACEMENT属性一起使用。

GraphicAttribute(int) - Constructor for class java.awt.font. GraphicAttribute

构造一个 GraphicAttribute 。

graphicChangedEvent() - Static method in class javafx.scene.control. TreeItem

当TreeItem接收到其图形属性的修改时使用的EventType。

graphicProperty() - Method in class javafx.scene.control. Dialog

对话图形，在标题中显示，如果显示，或在左边的 content 。

graphicProperty() - Method in class javafx.scene.control. DialogPane

对话图形，显示在标题中，如果显示，或在 content的左侧。

graphicProperty() - Method in class javafx.scene.control. Labeled

标签的可选图标。

graphicProperty() - Method in class javafx.scene.control. MenuItem

MenuItem的可选图形。

graphicProperty() - Method in class javafx.scene.control.skin. TableRowSkinBase

返回在公开节点内部绘制的图形。

graphicProperty() - Method in class javafx.scene.control.skin. TreeTableRowSkin

返回在公开节点内部绘制的图形。

graphicProperty() - Method in class javafx.scene.control. Tab

选项卡中的图形。

graphicProperty() - Method in class javafx.scene.control. TableColumnBase

在表列中显示的图形，以允许用户以图形方式指示列中的内容。

graphicProperty() - Method in class javafx.scene.control. Tooltip

工具提示的可选图标。

graphicProperty() - Method in class javafx.scene.control. TreeItem

通常显示在value属性左侧的节点。

Graphics - Class in java.awt

Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及到屏幕外图像上。

Graphics() - Constructor for class java.awt. Graphics

构造一个新的 Graphics对象。

GRAPHICS - javafx.application. ConditionalFeature

表示在此平台上提供了提供图形功能的JavaFX类。

Graphics2D - Class in java.awt

这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。

Graphics2D() - Constructor for class java.awt. Graphics2D

构造一个新的 Graphics2D对象。

GraphicsConfigTemplate - Class in java.awt

GraphicsConfigTemplate类用于获取有效的GraphicsConfiguration 。

GraphicsConfigTemplate() - Constructor for class java.awt. GraphicsConfigTemplate

这个类是一个抽象类，所以只有子类可以被实例化。

GraphicsConfiguration - Class in java.awt

GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特征。

GraphicsConfiguration() - Constructor for class java.awt. GraphicsConfiguration

这是一个无法直接实例化的抽象类。

GraphicsContext - Class in javafx.scene.canvas

此类用于使用缓冲区发出对Canvas的绘制调用。

GraphicsDevice - Class in java.awt

GraphicsDevice类描述了在特定图形环境中可能可用的图形设备。

GraphicsDevice() - Constructor for class java.awt. GraphicsDevice

这是一个无法直接实例化的抽象类。

GraphicsDevice.WindowTranslucency - Enum in java.awt

底层系统支持的半透明度。

GraphicsEnvironment - Class in java.awt

GraphicsEnvironment类描述了可用于特定平台上的Java（tm）应用程序的GraphicsDevice对象和Font对象的集合。

GraphicsEnvironment() - Constructor for class java.awt. GraphicsEnvironment

这是一个抽象类，不能直接实例化。

graphicTextGapProperty() - Method in class javafx.scene.control. Labeled

图形和文字之间的空间量

graphicTextGapProperty() - Method in class javafx.scene.control. Tooltip

图形和文字之间的空间量

gray - Static variable in class java.awt. Color

颜色灰色。

gray(double) - Static method in class javafx.scene.paint. Color

创建不透明的灰色。

gray(double, double) - Static method in class javafx.scene.paint. Color

创建灰色。

GRAY - javafx.scene.text. FontSmoothingType

指定默认的灰度平滑，最适合图形和动画使用。

GRAY - Static variable in class java.awt. Color

颜色灰色。

GRAY - Static variable in class javafx.scene.paint. Color

颜色为灰色，RGB值为＃808080

GRAY_RESPONSE_UNIT_HUNDRED_THOUSANDTHS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“GrayResponseUnit”标签一起使用的值。

GRAY_RESPONSE_UNIT_HUNDREDTHS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“GrayResponseUnit”标签一起使用的值。

GRAY_RESPONSE_UNIT_TEN_THOUSANDTHS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“GrayResponseUnit”标签一起使用的值。

GRAY_RESPONSE_UNIT_TENTHS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“GrayResponseUnit”标签一起使用的值。

GRAY_RESPONSE_UNIT_THOUSANDTHS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“GrayResponseUnit”标签一起使用的值。

GrayFilter - Class in javax.swing

通过将图像转换成灰度图像来“禁用”图像并增亮图像中的像素的图像滤镜。

GrayFilter(boolean, int) - Constructor for class javax.swing. GrayFilter

构造一个将彩色图像过滤到灰度图像的GrayFilter对象。

grayRgb(int) - Static method in class javafx.scene.paint. Color

这是 rgb(gray, gray, gray)的快捷方式。

grayRgb(int, double) - Static method in class javafx.scene.paint. Color

这是 rgb(gray, gray, gray, opacity)的快捷方式。

grayscale() - Method in class javafx.scene.paint. Color

创建一个与此颜色相当的灰度等级的新颜色。

GREATER - javafx.scene.input. KeyCode

常数为 Greater键。

GREATER - Static variable in class javax.xml.datatype. DatatypeConstants

比较结果。

GREATER_THAN - com.sun.source.tree. Tree.Kind

用于实例BinaryTree代表大于> 。

GREATER_THAN - jdk.nashorn.api.tree. Tree.Kind

用于实例BinaryTree代表大于> 。

GREATER_THAN_EQUAL - com.sun.source.tree. Tree.Kind

用于实例BinaryTree代表大于平等>= 。

GREATER_THAN_EQUAL - jdk.nashorn.api.tree. Tree.Kind

用于实例BinaryTree代表大于平等>= 。

greaterThan(double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。

greaterThan(double) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThan(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。

greaterThan(float) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。

greaterThan(float) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThan(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。

greaterThan(int) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression大于恒定值，则保留true 。

greaterThan(int) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThan(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。

greaterThan(long) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果该NumberExpression大于恒定值，则保留true 。

greaterThan(long) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThan(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个恒定值比的值越大ObservableNumberValue 。

greaterThan(String) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个StringExpression大于恒定值，则保留true 。

greaterThan(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个恒定值的值比的值越大ObservableStringValue 。

greaterThan(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding持有true如果NumberExpression大于另一个ObservableNumberValue 。

greaterThan(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThan(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值大于常数值，则保留true 。

greaterThan(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值大于一个恒定值，则保留true 。

greaterThan(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。

greaterThan(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue比恒定值。

greaterThan(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建新的BooleanBinding ，如果第一个ObservableNumberValue的值大于第二个值，则保留true 。

greaterThan(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，其持有true如果这StringExpression大于另一个ObservableStringValue 。

greaterThan(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue比恒定值。

greaterThan(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值大于第二个值，则保留true 。

greaterThan(Duration) - Method in class javafx.util. Duration

如果指定的持续时间大于（>）此实例，则返回true。

greaterThanOrEqual(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。

greaterThanOrEqual(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。

greaterThanOrEqual(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。

greaterThanOrEqual(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableNumberValue 。

greaterThanOrEqual(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableStringValue 。

greaterThanOrEqual(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。

greaterThanOrEqual(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。

greaterThanOrEqual(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值大于或等于一个恒定值，则保留true 。

greaterThanOrEqual(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue大于或等于恒定值。

greaterThanOrEqual(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建新的BooleanBinding ，如果第一个ObservableNumberValue的值大于或等于第二个值，则保留true 。

greaterThanOrEqual(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding保持true如果a的值ObservableStringValue大于或等于恒定值。

greaterThanOrEqual(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings

创建新的BooleanBinding ，如果第一个ObservableStringValue的值大于或等于第二个值，则保留true 。

greaterThanOrEqualTo(double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保存true 。

greaterThanOrEqualTo(double) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThanOrEqualTo(float) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保留true 。

greaterThanOrEqualTo(float) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThanOrEqualTo(int) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保存true 。

greaterThanOrEqualTo(int) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThanOrEqualTo(long) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression大于或等于一个恒定值，则保存true 。

greaterThanOrEqualTo(long) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThanOrEqualTo(String) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个StringExpression大于或等于一个恒定值，则保留true 。

greaterThanOrEqualTo(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding持有true如果NumberExpression大于或等于另一个ObservableNumberValue 。

greaterThanOrEqualTo(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase

greaterThanOrEqualTo(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding持有true如果StringExpression大于或等于另一个ObservableStringValue 。

greaterThanOrEqualTo(Duration) - Method in class javafx.util. Duration

如果指定的持续时间大于或等于（> =）此实例，则返回true。

GREEK - java.lang. Character.UnicodeScript

Unicode脚本“希腊语”。

GREEK - Static variable in class java.lang. Character.UnicodeBlock

“希腊和科普特”Unicode字符块的常数。

GREEK_EXTENDED - Static variable in class java.lang. Character.UnicodeBlock

“希腊语扩展”Unicode字符块的常量。

green - Static variable in class java.awt. Color

颜色绿色。

GREEN - javafx.scene.effect. BlendMode

底部输入的绿色分量被顶部输入的绿色分量替换; 其他颜色成分不受影响。

GREEN - Static variable in class java.awt. Color

颜色绿色。

GREEN - Static variable in class javafx.scene.paint. Color

颜色绿色，RGB值为＃008000

GREENCOMPONENT - Static variable in class java.awt.color. ICC_ProfileRGB

用于获取绿色组件的伽马值或TRC。

GREENYELLOW - Static variable in class javafx.scene.paint. Color

颜色为绿色黄色，RGB值为＃ADFF2F

GregorianCalendar - Class in java.util

GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。

GregorianCalendar() - Constructor for class java.util. GregorianCalendar

使用缺省 GregorianCalendar的默认时区使用默认值 GregorianCalendar 。

GregorianCalendar(int, int, int) - Constructor for class java.util. GregorianCalendar

构造一个 GregorianCalendar ，其中给定日期在默认时区中设置为默认语言环境。

GregorianCalendar(int, int, int, int, int) - Constructor for class java.util. GregorianCalendar

构造一个 GregorianCalendar ，其中给定的日期和时间为默认时区设置为默认语言环境。

GregorianCalendar(int, int, int, int, int, int) - Constructor for class java.util. GregorianCalendar

构造一个GregorianCalendar，其中给定的日期和时间为默认时区设置为默认语言环境。

GregorianCalendar(Locale) - Constructor for class java.util. GregorianCalendar

根据给定语言环境的默认时区中的当前时间构建一个 GregorianCalendar 。

GregorianCalendar(TimeZone) - Constructor for class java.util. GregorianCalendar

根据给定时区的当前时间，使用默认的 FORMAT区域设置构建一个 GregorianCalendar 。

GregorianCalendar(TimeZone, Locale) - Constructor for class java.util. GregorianCalendar

根据给定时区的当前时间，使用给定的区域设置构建一个 GregorianCalendar 。

GREY - Static variable in class javafx.scene.paint. Color

颜色为灰色，RGB值为＃808080

GridBagConstraints - Class in java.awt

GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。

GridBagConstraints() - Constructor for class java.awt. GridBagConstraints

创建一个 GridBagConstraint对象，其所有字段都设置为其默认值。

GridBagConstraints(int, int, int, int, double, double, int, int, Insets, int, int) - Constructor for class java.awt. GridBagConstraints

创建一个 GridBagConstraints对象，其所有字段都设置为传入参数。

GridBagLayout - Class in java.awt

GridBagLayout类是一种灵活的布局管理器，可以垂直，水平或沿其基准对齐组件，而不需要组件的大小相同。

GridBagLayout() - Constructor for class java.awt. GridBagLayout

创建网格包布局管理器。

GridBagLayoutInfo - Class in java.awt

GridBagLayoutInfo是一个用于 GridBagLayout布局管理器的实用程序类。

gridColor - Variable in class javax.swing. JTable

网格的颜色。

gridheight - Variable in class java.awt. GridBagConstraints

指定组件显示区域的列中的单元格数。

GridLayout - Class in java.awt

GridLayout类是一个布局管理器，它将容器的组件放置在矩形网格中。

GridLayout() - Constructor for class java.awt. GridLayout

在单个行中创建一个每个组件的默认值为一列的网格布局。

GridLayout(int, int) - Constructor for class java.awt. GridLayout

创建具有指定行数和列数的网格布局。

GridLayout(int, int, int, int) - Constructor for class java.awt. GridLayout

创建具有指定行数和列数的网格布局。

gridLinesVisibleProperty() - Method in class javafx.scene.layout. GridPane

仅用于调试目的：控制是否显示行是否显示网格板的行和列。

GridPane - Class in javafx.scene.layout

GridPane将其孩子放在一个灵活的行和列格网中。

GridPane() - Constructor for class javafx.scene.layout. GridPane

使用hgap / vgap = 0和TOP_LEFT对齐创建一个GridPane布局。

gridwidth - Variable in class java.awt. GridBagConstraints

指定组件显示区域的一行中的单元格数。

gridx - Variable in class java.awt. GridBagConstraints

指定包含组件显示区域的前沿的单元格，其中一行中的第一个单元格具有 gridx=0 。

gridy - Variable in class java.awt. GridBagConstraints

指定组件显示区域顶部的单元格，其中最上面的单元格具有 gridy=0 。

group - Variable in class javax.swing. DefaultButtonModel

按钮所属的按钮组。

group() - Method in class java.nio.channels. MembershipKey

返回创建此成员资格密钥的多播组。

group() - Method in interface java.nio.file.attribute. PosixFileAttributes

返回该文件的组所有者。

group() - Method in class java.util.regex. Matcher

返回与上一个匹配匹配的输入子序列。

group() - Method in interface java.util.regex. MatchResult

返回与上一个匹配匹配的输入子序列。

group(int) - Method in class java.util.regex. Matcher

返回在上一次匹配操作期间由给定组捕获的输入子序列。

group(int) - Method in interface java.util.regex. MatchResult

返回在上一次匹配操作期间由给定组捕获的输入子序列。

group(String) - Method in class java.util.regex. Matcher

返回在上一次匹配操作期间由给定的 named-capturing group捕获的输入子序列。

Group - Class in javafx.scene

一个 Group节点包含一个可观察的子节点列表，每当呈现该节点时，它们按顺序渲染。

Group - Interface in java.security.acl

已过时。
自1.2以来，该软件包已被java.security.Policy及相关课程所取代。

Group() - Constructor for class javafx.scene. Group

构建一个组。

Group(Collection<Node>) - Constructor for class javafx.scene. Group

构建由给定的孩子组成的组。

Group(Node...) - Constructor for class javafx.scene. Group

构建一个由儿童组成的小组。

GROUP_BOX - Static variable in class javax.accessibility. AccessibleRole

A GROUP_BOX是一个简单的容器，其中包含一个边框，并在其中包含组件。

GROUP_EXECUTE - java.nio.file.attribute. PosixFilePermission

执行/搜索权限，组。

GROUP_PROVIDER - Variable in class com.sun.security.auth.module. JndiLoginModule

GROUP_READ - java.nio.file.attribute. PosixFilePermission

读权限，组。

GROUP_WRITE - java.nio.file.attribute. PosixFilePermission

写权限，组。

groupCount() - Method in class java.util.regex. Matcher

返回此匹配器模式中捕获组的数量。

groupCount() - Method in interface java.util.regex. MatchResult

返回此匹配结果模式中捕获组的数量。

GROUPING_SEPARATOR - Static variable in class java.text. NumberFormat.Field

常数标识分组分隔符字段。

groupingBy(Function<? super T, ? extends K>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，对 T类型的输入元素进行“group by”操作，根据分类功能对元素进行分组，并将结果返回到一个 Map 。

groupingBy(Function<? super T, ? extends K>, Supplier<M>, Collector<? super T, A, D>) - Static method in class java.util.stream. Collectors

返回一个 Collector对类型为 T输入元素进行级联“分组”操作，根据分类功能分组元素，然后使用指定的下游 Collector对与给定键相关联的值执行缩减操作。

groupingBy(Function<? super T, ? extends K>, Collector<? super T, A, D>) - Static method in class java.util.stream. Collectors

返回 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定与给定键相关联的值进行还原操作 Collector 。

groupingByConcurrent(Function<? super T, ? extends K>) - Static method in class java.util.stream. Collectors

返回一个并发 Collector “由基团”上的类型的输入元件操作实现 T ，根据分类功能分组元素。

groupingByConcurrent(Function<? super T, ? extends K>, Supplier<M>, Collector<? super T, A, D>) - Static method in class java.util.stream. Collectors

返回一个并发 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定执行与给定键相关联的值的归约运算 Collector 。

groupingByConcurrent(Function<? super T, ? extends K>, Collector<? super T, A, D>) - Static method in class java.util.stream. Collectors

返回一个并发 Collector “由基团”上的类型的输入元件操作实现级联 T ，根据分类功能分组元素，然后使用下游的指定执行与给定键相关联的值的归约运算 Collector 。

GroupLayout - Class in javax.swing

GroupLayout是一个 LayoutManager ，分层组合组件，以便将它们定位在一个 Container 。

GroupLayout(Container) - Constructor for class javax.swing. GroupLayout

创建 GroupLayout为指定 Container 。

GroupLayout.Alignment - Enum in javax.swing

枚举可能的方式 ParallelGroup可以对 ParallelGroup 。

GroupLayout.Group - Class in javax.swing

Group为GroupLayout支持的两种类型的操作提供GroupLayout ：一个接一个地布置组件（ SequentialGroup ）或对齐（ ParallelGroup ）。

GroupLayout.ParallelGroup - Class in javax.swing

一个 Group ，它对齐和大小它的孩子。

GroupLayout.SequentialGroup - Class in javax.swing

A Group一个接一个地依次定位和调整其元素的大小。

GroupPrincipal - Interface in java.nio.file.attribute

A UserPrincipal表示 组身份 ，用于确定文件系统中对象的访问权限。

groups - Variable in class com.sun.security.auth.module. SolarisSystem

已过时。

groups - Variable in class com.sun.security.auth.module. UnixSystem

grow(int, int) - Method in class java.awt. Rectangle

水平和垂直调整 Rectangle 。

growAbsorb - Variable in class java.awt.font. GlyphJustificationInfo

如果是 true ，这个字形在增长时会吸收这个和较低优先级的所有额外的空间。

growLeftLimit - Variable in class java.awt.font. GlyphJustificationInfo

这个字形左侧的最大数量可以增长。

growPriority - Variable in class java.awt.font. GlyphJustificationInfo

这个字形的优先级正在增长。

growRightLimit - Variable in class java.awt.font. GlyphJustificationInfo

这个字形的右侧可以增长的最大数量。

GSSContext - Interface in org.ietf.jgss

该接口封装了GSS-API安全上下文，并提供了可用于上下文的安全服务。

GSSCredential - Interface in org.ietf.jgss

该接口封装了实体的GSS-API凭据。

GSSException - Exception in org.ietf.jgss

发生GSS-API错误时会抛出此异常，包括任何机制特定的错误。

GSSException(int) - Constructor for exception org.ietf.jgss. GSSException

创建具有指定主要代码的GSSException对象。

GSSException(int, int, String) - Constructor for exception org.ietf.jgss. GSSException

创建具有指定主要代码，次要代码和次要代码文本说明的GSSException对象。

GSSManager - Class in org.ietf.jgss

该类作为其他重要GSS-API类的工厂，并提供有关支持的机制的信息。

GSSManager() - Constructor for class org.ietf.jgss. GSSManager

GSSName - Interface in org.ietf.jgss

该接口封装了单个GSS-API主体实体。

GSSUtil - Class in com.sun.security.jgss

GSS-API实用程序与Sun Microsystem的Java GSS-API实现结合使用。

GSSUtil() - Constructor for class com.sun.security.jgss. GSSUtil

gt(ValueExp, ValueExp) - Static method in class javax.management. Query

返回一个对两个值表示“大于”约束的查询表达式。

GT - Static variable in class javax.management. Query

代表 Query.gt(javax.management.ValueExp, javax.management.ValueExp)查询的代码。

Guard - Interface in java.security

该接口表示一个保护，它是一个用于保护对另一个对象的访问的对象。

GuardedInvocation - Class in jdk.dynalink.linker

表示有条件的有效方法句柄。

GuardedInvocation(MethodHandle) - Constructor for class jdk.dynalink.linker. GuardedInvocation

创建一个新的无条件守卫调用。

GuardedInvocation(MethodHandle, MethodHandle) - Constructor for class jdk.dynalink.linker. GuardedInvocation

创建一个新的守卫调用，具有保护方法句柄。

GuardedInvocation(MethodHandle, MethodHandle, SwitchPoint) - Constructor for class jdk.dynalink.linker. GuardedInvocation

创建一个新的守卫调用，同时具有保护方法句柄和可用于使其无效的切换点。

GuardedInvocation(MethodHandle, MethodHandle, SwitchPoint[], Class<? extends Throwable>) - Constructor for class jdk.dynalink.linker. GuardedInvocation

创建一个新的有保护的调用，具有保护方法句柄，可以使用任何数量的切换点来使其无效，以及如果在调用时抛出的异常也会使其失效。

GuardedInvocation(MethodHandle, MethodHandle, SwitchPoint, Class<? extends Throwable>) - Constructor for class jdk.dynalink.linker. GuardedInvocation

创建一个新的守卫调用，具有保护方法句柄，可用于使其无效的切换点，以及如果在调用时抛出也会使其失效的异常。

GuardedInvocation(MethodHandle, SwitchPoint) - Constructor for class jdk.dynalink.linker. GuardedInvocation

创建一个新的受保护的调用，可以由切换点无效。

GuardedInvocationTransformer - Interface in jdk.dynalink.linker

用于将一个受保护的调用转换为另一个的对象的接口。

GuardedObject - Class in java.security

GuardedObject是一个用于保护对另一个对象的访问的对象。

GuardedObject(Object, Guard) - Constructor for class java.security. GuardedObject

使用指定的对象和守卫构造一个GuardedObject。

GuardingDynamicLinker - Interface in jdk.dynalink.linker

语言特定动态链接器的基本界面。

GuardingDynamicLinkerExporter - Class in jdk.dynalink.linker

作为保护动态链接器的供应商的类，可以由其他语言运行时自动加载。

GuardingDynamicLinkerExporter() - Constructor for class jdk.dynalink.linker. GuardingDynamicLinkerExporter

创建一个新的链接器导出器。

GuardingTypeConverterFactory - Interface in jdk.dynalink.linker

可选接口，可以由GuardingDynamicLinker实现来实现，以提供特定于语言的类型转换功能。

Guards - Class in jdk.dynalink.linker.support

用于创建 MethodHandles.guardWithTest(MethodHandle, MethodHandle, MethodHandle)的典型防护 罩并调整其方法类型的实用方法。

guardWithTest(MethodHandle, MethodHandle) - Method in class java.lang.invoke. SwitchPoint

返回一个方法句柄，它始终将它们委托给目标或后备。

guardWithTest(MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles

使用方法句柄来调整目标方法句柄，通过用测试保护它，一个布尔值方法句柄。

guessContentTypeFromName(String) - Static method in class java.net. URLConnection

根据URL的指定“文件”组件，尝试确定对象的内容类型。

guessContentTypeFromStream(InputStream) - Static method in class java.net. URLConnection

根据输入流开头的字符，尝试确定输入流的类型。

guiInitialized() - Method in interface com.sun.java.accessibility.util. GUIInitializedListener

当GUI子系统初始化时调用，并且辅助技术可以创建GUI对象的实例。

GUIInitializedListener - Interface in com.sun.java.accessibility.util

GUIInitializedListener接口由EventQueueMonitor类用于在GUI子系统初始化时通知感兴趣方。

GUJARATI - java.awt.font. NumericShaper.Range

古吉拉特语古吉拉特语数字。

GUJARATI - java.lang. Character.UnicodeScript

Unicode脚本“古吉拉特”。

GUJARATI - Static variable in class java.awt.font. NumericShaper

标识GUJARATI范围和十进制基数。

GUJARATI - Static variable in class java.lang. Character.UnicodeBlock

“古吉拉特文”Unicode字符块的常数。

GURMUKHI - java.awt.font. NumericShaper.Range

古尔穆赫（Gurmukhi）范围与古尔穆奇数字。

GURMUKHI - java.lang. Character.UnicodeScript

Unicode脚本“Gurmukhi”。

GURMUKHI - Static variable in class java.awt.font. NumericShaper

标识GURMUKHI范围和十进制基数。

GURMUKHI - Static variable in class java.lang. Character.UnicodeBlock

常数为“古尔穆基”Unicode字符块。

GYEAR - Static variable in class javax.xml.datatype. DatatypeConstants

W3C XML Schema 1.0数据类型 gYear完全限定名称。

GYEARMONTH - Static variable in class javax.xml.datatype. DatatypeConstants

W3C XML Schema 1.0数据类型 gYearMonth完全限定名称。

GZIP - Static variable in class javax.print.attribute.standard. Compression

GNU zip压缩技术描述于 RFC 1952 。

GZIP_MAGIC - Static variable in class java.util.zip. GZIPInputStream

GZIP标题魔数。

GZIPInputStream - Class in java.util.zip

该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。

GZIPInputStream(InputStream) - Constructor for class java.util.zip. GZIPInputStream

创建一个默认缓冲区大小的新输入流。

GZIPInputStream(InputStream, int) - Constructor for class java.util.zip. GZIPInputStream

创建具有指定缓冲区大小的新输入流。

GZIPOutputStream - Class in java.util.zip

该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。

GZIPOutputStream(OutputStream) - Constructor for class java.util.zip. GZIPOutputStream

创建一个具有默认缓冲区大小的新输出流。

GZIPOutputStream(OutputStream, boolean) - Constructor for class java.util.zip. GZIPOutputStream

创建具有默认缓冲区大小和指定刷新模式的新输出流。

GZIPOutputStream(OutputStream, int) - Constructor for class java.util.zip. GZIPOutputStream

创建具有指定缓冲区大小的新输出流。

GZIPOutputStream(OutputStream, int, boolean) - Constructor for class java.util.zip. GZIPOutputStream

创建具有指定缓冲区大小和刷新模式的新输出流。

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

Report a bug or suggest an enhancement


H-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

H

h - Variable in class java.lang.reflect. Proxy
该代理实例的调用处理程序。
H - javafx.scene.input. KeyCode
常数为 H键。
H_RESIZE - Static variable in class javafx.scene. Cursor
水平光标类型。
H1 - Static variable in class javax.swing.text.html. HTML.Tag
标签<h1>
H2 - Static variable in class javax.swing.text.html. HTML.Tag
标签<h2>
H3 - Static variable in class javax.swing.text.html. HTML.Tag
标签<h3>
H4 - Static variable in class javax.swing.text.html. HTML.Tag
标签<h4>
H5 - Static variable in class javax.swing.text.html. HTML.Tag
标签<h5>
H6 - Static variable in class javax.swing.text.html. HTML.Tag
标签<h6>
HALF_DAYS - java.time.temporal. ChronoUnit
代表AM / PM使用的半天的概念的单位。
HALF_DOWN - java.math. RoundingMode
四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，这是倒圆的。
HALF_EVEN - java.math. RoundingMode
四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，朝向偶数邻居。
HALF_UP - java.math. RoundingMode
四舍五入模式向“最近邻居”转弯，除非两个邻居都是等距的，在这种情况下是圆括弧的。
HALF_WIDTH - javafx.scene.input. KeyCode
半角字符功能键的常数。
HALFWIDTH_AND_FULLWIDTH_FORMS - Static variable in class java.lang. Character.UnicodeBlock
Unicode字符块的“半宽和全宽”的常量。
HALFWIDTH_KATAKANA - Static variable in class java.awt.im. InputSubset
Unicode半宽和全宽形式字符块的半宽片假名子集的常数。
HALIGN - Static variable in class javax.swing.text.html. HTML.Attribute
属性“halign”
halignmentProperty() - Method in class javafx.scene.control. Separator
对于垂直分隔符，指定分隔线在空间中的水平位置。
halignmentProperty() - Method in class javafx.scene.layout. ColumnConstraints
列的水平对齐。
halt(int) - Method in class java.lang. Runtime
强制终止当前正在运行的Java虚拟机。
HALTED - javafx.scene.media. MediaPlayer.Status
发生严重错误的玩家状态。
HAN - java.lang. Character.UnicodeScript
Unicode脚本“汉”。
HAND - Static variable in class javafx.scene. Cursor
手指游标类型，类似于指针，通常用于指示可以点击某些内容，例如超链接。
HAND_CURSOR - Static variable in class java.awt. Cursor
手指光标类型。
HAND_CURSOR - Static variable in class java.awt. Frame
已过时。
代之以Cursor.HAND_CURSOR 。
handle(long) - Method in class javafx.animation. AnimationTimer
这个方法需要被扩展类覆盖。
handle(short, String, Object, Node, Node) - Method in interface org.w3c.dom. UserDataHandler
每当注册此处理程序的节点被导入或克隆时，都会调用此方法。
handle(HttpExchange) - Method in interface com.sun.net.httpserver. HttpHandler
处理给定的请求并产生适当的响应。
handle(BiFunction<? super T, Throwable, ? extends U>) - Method in class java.util.concurrent. CompletableFuture
handle(BiFunction<? super T, Throwable, ? extends U>) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。
handle(Callback[]) - Method in class com.sun.security.auth.callback. TextCallbackHandler
处理指定的一组回调。
handle(Callback[]) - Method in interface javax.security.auth.callback. CallbackHandler
检索或显示提供的回调中请求的信息。
handle(HttpExchange) - Method in class javax.xml.ws.spi.http. HttpHandler
处理给定的请求并生成适当的响应。
handle(T) - Method in interface javafx.event. EventHandler
当注册此处理程序的类型的特定事件发生时调用。
handle(T) - Method in class javafx.event. WeakEventHandler
向相关事件处理程序发送事件通知。
handleAbout(AboutEvent) - Method in interface java.awt.desktop. AboutHandler
当应用程序被要求显示其对话框时调用。
handleApplicationNotification(Preloader.PreloaderNotification) - Method in class javafx.application. Preloader
表示应用程序生成的通知。
handleAsync(BiFunction<? super T, Throwable, ? extends U>) - Method in class java.util.concurrent. CompletableFuture
handleAsync(BiFunction<? super T, Throwable, ? extends U>) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。
handleAsync(BiFunction<? super T, Throwable, ? extends U>, Executor) - Method in class java.util.concurrent. CompletableFuture
handleAsync(BiFunction<? super T, Throwable, ? extends U>, Executor) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。
handleComment(char[]) - Method in class javax.swing.text.html.parser. DocumentParser
handleComment(char[]) - Method in class javax.swing.text.html.parser. Parser
遇到HTML注释时调用。
handleComment(char[], int) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
handleComment(char[], int) - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
由解析器调用来指示遇到一段注释。
handleEmptyTag(TagElement) - Method in class javax.swing.text.html.parser. DocumentParser
处理空标签。
handleEmptyTag(TagElement) - Method in class javax.swing.text.html.parser. Parser
遇到空标签时调用。
handleEndOfLineString(String) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
在流已解析后，但在 flush之前 flush 。
handleEndOfLineString(String) - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
在流已解析后，但在 flush之前 flush 。
handleEndTag(HTML.Tag, int) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
从解析器回调。
handleEndTag(HTML.Tag, int) - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
从解析器回调。
handleEndTag(TagElement) - Method in class javax.swing.text.html.parser. DocumentParser
处理结束标签
handleEndTag(TagElement) - Method in class javax.swing.text.html.parser. Parser
当遇到结束标记时调用。
handleEOFInComment() - Method in class javax.swing.text.html.parser. Parser
当内容终止而不关闭HTML注释时调用。
handleError(int, String) - Method in class javax.swing.text.html.parser. DocumentParser
handleError(int, String) - Method in class javax.swing.text.html.parser. Parser
发生了错误。
handleError(String, int) - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
从解析器回调。
handleError(DOMError) - Method in interface org.w3c.dom. DOMErrorHandler
当发生错误时，该错误处理程序将调用此方法。
handleErrorNotification(Preloader.ErrorNotification) - Method in class javafx.application. Preloader
发生错误时调用。
handleEvent(Event) - Method in class java.awt. Component
已过时。
从JDK版本1.1替换为processEvent（AWTEvent）。
handleEvent(ValidationEvent) - Method in class javax.xml.bind.helpers. DefaultValidationEventHandler
handleEvent(ValidationEvent) - Method in class javax.xml.bind.util. ValidationEventCollector
handleEvent(ValidationEvent) - Method in interface javax.xml.bind. ValidationEventHandler
接收验证警告或错误的通知。
handleEvent(Event) - Method in interface org.w3c.dom.events. EventListener
每当发生 EventListener接口注册的类型的事件时，将调用此方法。
handleExpandControlClick(TreePath, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI
当用户点击特定的行时消息 toggleExpandState ，这将调用 toggleExpandState 。
handleFault(C) - Method in interface javax.xml.ws.handler. Handler
调用 handleFault方法进行故障消息处理。
handleGetObject(String) - Method in class java.util. ListResourceBundle
handleGetObject(String) - Method in class java.util. PropertyResourceBundle
handleGetObject(String) - Method in class java.util. ResourceBundle
从此资源包获取给定键的对象。
handleInputMethodEvent(InputMethodEvent) - Method in class javafx.scene.control.skin. TextInputControlSkin
handleJustify(float) - Method in class java.awt.font. TextLayout
证明这个布局。
handleKeySet() - Method in class java.util. ListResourceBundle
返回一个 Set的键 只包含在这个 ResourceBundle 。
handleKeySet() - Method in class java.util. PropertyResourceBundle
返回一个 Set的键 只包含在这个 ResourceBundle 。
handleKeySet() - Method in class java.util. ResourceBundle
返回一个 Set的键 只包含在这个 ResourceBundle 。
handleMBeanUnregistration(ObjectName, String) - Method in interface javax.management.relation. Relation
当角色引用的MBean未注册时，关系服务使用的回调。
handleMBeanUnregistration(ObjectName, String) - Method in class javax.management.relation. RelationSupport
当角色引用的MBean未注册时，关系服务使用的回调。
handleMessage(C) - Method in interface javax.xml.ws.handler. Handler
handleMessage方法被调用用于正常处理入站和出站邮件。
handleNotification(AssociationChangeNotification, T) - Method in class com.sun.nio.sctp. AbstractNotificationHandler
当从SCTP堆栈接收到AssociationChangeNotification时调用。
handleNotification(Notification, T) - Method in class com.sun.nio.sctp. AbstractNotificationHandler
当从SCTP堆栈接收到实现特定通知时调用。
handleNotification(Notification, T) - Method in interface com.sun.nio.sctp. NotificationHandler
从SCTP堆栈收到通知时调用。
handleNotification(PeerAddressChangeNotification, T) - Method in class com.sun.nio.sctp. AbstractNotificationHandler
当从SCTP堆栈接收到PeerAddressChangeNotification时调用。
handleNotification(SendFailedNotification, T) - Method in class com.sun.nio.sctp. AbstractNotificationHandler
当从SCTP堆栈接收到SendFailedNotification时调用。
handleNotification(ShutdownNotification, T) - Method in class com.sun.nio.sctp. AbstractNotificationHandler
当从SCTP堆栈接收到ShutdownNotification时调用。
handleNotification(NotificationListener, Notification, Object) - Method in class javax.management. NotificationBroadcasterSupport
为每个侦听器调用此方法为 sendNotification ，以便向该侦听器发送通知。
handleNotification(Notification, Object) - Method in interface javax.management. NotificationListener
JMX通知发生时调用。
handleNotification(Notification, Object) - Method in class javax.management.relation. RelationService
JMX通知发生时调用。
handleOption(String, Iterator<String>) - Method in class javax.tools. ForwardingJavaFileManager
handleOption(String, Iterator<String>) - Method in interface javax.tools. JavaFileManager
处理一个选项
handlePreferences(PreferencesEvent) - Method in interface java.awt.desktop. PreferencesHandler
当应用程序被要求显示其首选项UI时调用。
handleProgressNotification(Preloader.ProgressNotification) - Method in class javafx.application. Preloader
表示下载进度。
handleQuitRequestWith(QuitEvent, QuitResponse) - Method in interface java.awt.desktop. QuitHandler
当应用程序被要求退出时调用。
handler - Variable in class javax.xml.ws.spi.http. HttpContext
为此上下文设置的处理程序。
Handler - Class in java.util.logging
一个 Handler对象从需要日志消息 Logger和出口他们。
Handler< C extends MessageContext> - Interface in javax.xml.ws.handler
Handler接口是JAX-WS处理程序的基础接口。
Handler() - Constructor for class java.util.logging. Handler
默认构造函数。
HANDLER - javax.xml.ws.handler. MessageContext.Scope
处理能见度。
HandlerBase - Class in org.xml.sax
已过时。
此类与已弃用的DocumentHandler接口配合使用。 它已被SAX2 DefaultHandler类所取代。
HandlerBase() - Constructor for class org.xml.sax. HandlerBase
已过时。
HandlerChain - Annotation Type in javax.jws
handleResponse(Response<T>) - Method in interface javax.xml.ws. AsyncHandler
当异步操作的响应可用时调用。
HandlerResolver - Interface in javax.xml.ws.handler
HandlerResolver是由应用程序实现的接口，用于在创建代理/调度对象时获取对代理/调度对象上设置的处理程序链的控制。
HandlerResult - Enum in com.sun.nio.sctp
定义通知处理程序结果。
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
从解析器回调。
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
从解析器回调。
handleStartTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
从解析器回调。
handleStartTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
从解析器回调。
handleStartTag(TagElement) - Method in class javax.swing.text.html.parser. DocumentParser
处理起始标签。
handleStartTag(TagElement) - Method in class javax.swing.text.html.parser. Parser
遇到开始标签时调用。
handleStateChangeNotification(Preloader.StateChangeNotification) - Method in class javafx.application. Preloader
表示应用程序状态发生变化。
handleText(char[]) - Method in class javax.swing.text.html.parser. DocumentParser
处理文本。
handleText(char[]) - Method in class javax.swing.text.html.parser. Parser
新新新旗新新新旗新新新新旗新新旗新新旗新新旗新新旗旗新新旗新新旗旗新新旗新新200新
handleText(char[], int) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
由解析器调用来指示遇到一个文本块。
handleText(char[], int) - Method in class javax.swing.text.html. HTMLEditorKit.ParserCallback
由解析器调用来指示遇到一个文本块。
handleTitle(char[]) - Method in class javax.swing.text.html.parser. Parser
遇到HTML标题标签时调用。
handshakeCompleted(HandshakeCompletedEvent) - Method in interface javax.net.ssl. HandshakeCompletedListener
当SSL握手完成时，在注册对象上调用此方法。
HandshakeCompletedEvent - Class in javax.net.ssl
此事件表示在给定SSL连接上完成SSL握手。
HandshakeCompletedEvent(SSLSocket, SSLSession) - Constructor for class javax.net.ssl. HandshakeCompletedEvent
构造一个新的HandshakeCompletedEvent。
HandshakeCompletedListener - Interface in javax.net.ssl
该接口由希望接收关于在给定SSL连接上完成SSL协议握手的通知的任何类实现。
HANGING_BASELINE - Static variable in class java.awt.font. GraphicAttribute
将图形的起点与线的垂直基线对齐。
HANGING_BASELINE - Static variable in class java.awt. Font
Devanagari中使用的基线和类似的脚本。
HANGUL - java.lang. Character.UnicodeScript
Unicode脚本“Hangul”。
HANGUL_COMPATIBILITY_JAMO - Static variable in class java.lang. Character.UnicodeBlock
“Hanul兼容性Jamo”Unicode字符块的常量。
HANGUL_JAMO - Static variable in class java.lang. Character.UnicodeBlock
“Hanul Jamo”Unicode字符块的常数。
HANGUL_JAMO_EXTENDED_A - Static variable in class java.lang. Character.UnicodeBlock
“Hanul Jamo Extended-A”Unicode字符块的常数。
HANGUL_JAMO_EXTENDED_B - Static variable in class java.lang. Character.UnicodeBlock
“Hanul Jamo Extended-B”Unicode字符块的常数。
HANGUL_SYLLABLES - Static variable in class java.lang. Character.UnicodeBlock
“汉字音节”Unicode字符块的常数。
HANJA - Static variable in class java.awt.im. InputSubset
所有汉字用于韩文的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的韩文汉字。
HANUNOO - java.lang. Character.UnicodeScript
Unicode脚本“Hanunoo”。
HANUNOO - Static variable in class java.lang. Character.UnicodeBlock
“Hanunoo”Unicode字符块的常量。
HARD_LIGHT - javafx.scene.effect. BlendMode
根据顶部输入颜色，输入颜色分量是相乘或屏蔽的。
hardDriveIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
硬盘图标
HARDWARE_MINIMUM - javafx.print. Printer.MarginType
请求边距设置为硬件允许的每一侧最小。
has_no_active_member() - Method in class org.omg.DynamicAny. _DynUnionStub
如果联合没有活动成员，则返回true，即，联合值仅由其标识符组成，因为鉴别符具有未列为明确案例标签的值。
has_no_active_member() - Method in interface org.omg.DynamicAny. DynUnionOperations
如果联合没有活动成员，则返回true，即，联合值仅由其标识符组成，因为鉴别符具有未列为明确案例标签的值。
hasAlpha() - Method in class java.awt.image. ColorModel
返回此 ColorModel中是否支持 ColorModel 。
hasAnchoringBounds() - Method in class java.util.regex. Matcher
查询该匹配器的区域边界的锚定。
hasArray() - Method in class java.nio. Buffer
告诉这个缓冲区是否由可访问的数组支持。
hasArray() - Method in class java.nio. ByteBuffer
告诉这个缓冲区是否由可访问的字节数组支持。
hasArray() - Method in class java.nio. CharBuffer
告诉这个缓冲区是否由可访问的字符数组支持。
hasArray() - Method in class java.nio. DoubleBuffer
告诉这个缓冲区是否由可访问的双阵列支持。
hasArray() - Method in class java.nio. FloatBuffer
告诉这个缓冲区是否由可访问的浮点数组支持。
hasArray() - Method in class java.nio. IntBuffer
告诉这个缓冲区是否由可访问的int数组支持。
hasArray() - Method in class java.nio. LongBuffer
告诉这个缓冲区是否由可访问的长阵列支持。
hasArray() - Method in class java.nio. ShortBuffer
告诉这个缓冲区是否由可访问的短阵列支持。
hasAssociation(String, String[]) - Method in interface javax.jnlp. IntegrationService
检查此应用程序是否与指定的mimetype和文件扩展名相关联。
hasAttribute(String) - Method in class javax.imageio.metadata. IIOMetadataNode
hasAttribute(String) - Method in interface org.w3c.dom. Element
返回 true当具有给定名称的属性在此元素上指定或具有默认值（ false 。
hasAttributeNS(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode
相当于 hasAttribute(localName) 。
hasAttributeNS(String, String) - Method in interface org.w3c.dom. Element
返回 true在此元素上被指定或具有默认值，与给定的本地名称和命名空间的属性URI false否则。
hasAttributes() - Method in class javax.imageio.metadata. IIOMetadataNode
hasAttributes() - Method in interface org.w3c.dom. Node
返回此节点（如果它是一个元素）是否具有任何属性。
hasBeenExpanded(TreePath) - Method in class javax.swing. JTree
如果已经扩展了路径标识的节点，则返回true。
hasBeenInvalidated() - Method in class java.lang.invoke. SwitchPoint
确定此切换点是否已被无效。
hasBeenInvalidated() - Method in class jdk.dynalink.linker. GuardedInvocation
当且仅当该被守卫的调用至少有一个无效的切换点时才返回true。
hasChanged() - Method in class java.util. Observable
已过时。
测试此对象是否已更改。
hasCharacteristics(int) - Method in interface java.util. Spliterator
如果此Spliterator的 Spliterator.characteristics()包含所有给定的特征，则返回 true 。
hasChildNodes() - Method in class javax.imageio.metadata. IIOMetadataNode
如果此节点具有子节点，则返回 true 。
hasChildNodes() - Method in interface org.w3c.dom. Node
返回此节点是否有任何子节点。
hasChildren - Variable in class javax.swing. JTree.DynamicUtilTreeNode
这个 JTree有孩子吗？
hasContended() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
查询任何线程是否有争取获取此同步器; 也就是说，如果获取方法被阻止。
hasContended() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
查询任何线程是否有争取获取此同步器; 也就是说，如果获取方法被阻止。
hasContent(DataFormat) - Method in class javafx.scene.input. Clipboard
测试给定DataFormat类型的此剪贴板上是否有任何内容。
hasController() - Method in class javax.imageio. IIOParam
如果为此 IIOParam对象安装了控制器，则返回 true 。
hasController() - Method in class javax.imageio.metadata. IIOMetadata
如果为此 IIOMetadata对象安装了控制器，则返回 true 。
HasControls - Interface in javax.naming.ldap
此接口用于使用NamingEnumerations返回的对象返回控件。
hasCustomComponents - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI
如果组件包含在消息或按钮中，则在validateComponent中设置为true。
hasDefaultValue() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport
如果此 OpenMBeanAttributeInfoSupport实例指定了所描述属性的非空默认值，则返回 true ，否则为 false 。
hasDefaultValue() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo
返回 true如果此参数存在指定的默认值，或 false否则。
hasDefaultValue() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport
如果此 OpenMBeanParameterInfoSupport实例指定了所描述的参数的非空默认值，则返回 true ，否则为 false 。
hasDesktopShortcut() - Method in interface javax.jnlp. IntegrationService
检查应用程序是否具有桌面快捷方式。
hasDetail() - Method in interface javax.xml.soap. SOAPFault
如果这个 SOAPFault有一个 Detail子元素，则返回true，否则返回false。
hasDirectory() - Method in class javax.imageio.plugins.tiff. TIFFField
返回字段是否有 TIFFDirectory 。
hasDynamicLocaleList() - Method in interface java.awt.im.spi. InputMethodDescriptor
返回可用区域设置的列表是否可以在运行时更改。
hasEntered - Variable in class javax.swing.plaf.basic. BasicComboPopup
true如果鼠标光标在弹出窗口。
hasEvents() - Method in class javax.xml.bind.util. ValidationEventCollector
如果此事件收集器至少包含一个ValidationEvent，则返回true。
hasExpired() - Method in class java.net. HttpCookie
报告此HTTP Cookie是否已过期。
hasExtensions() - Method in class java.security.cert. X509CRLEntry
如果此CRL条目具有扩展名，则返回true。
hasExtensions() - Method in class java.util. Locale
返回 true如果 Locale有任何 extensions 。
hasFault() - Method in interface javax.xml.soap. SOAPBody
指示是否 SOAPFault在此存在对象 SOAPBody对象。
hasFeature(String, String) - Method in interface org.w3c.dom. DOMImplementation
测试DOM实现是否实现了特定功能和版本，如 DOM Features中所述 。
hasFiles() - Method in class javafx.scene.input. Clipboard
获取文件列表（DataFormat.FILES）是否已在此剪贴板上注册。
hasFiles() - Method in class javafx.scene.input. ClipboardContent
获取文件列表（ DataFormat.FILES ）是否已被放入此 ClipboardContent 。
hasFocus - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
此保护字段是实现特定的。
hasFocus - Variable in class javax.swing.tree. DefaultTreeCellRenderer
如果有焦点的话。
hasFocus() - Method in class java.awt. Component
如果这个 Component是焦点所有者，则返回 true 。
hash(Object...) - Static method in class java.util. Objects
为输入值序列生成哈希码。
hash(Object, int) - Method in class org.omg.CORBA.portable. Delegate
返回此对象引用的ORB内部标识符（hashcode）。
HashAttributeSet - Class in javax.print.attribute
HashAttributeSet类提供了具有哈希映射特征的 AttributeSet实现。
HashAttributeSet() - Constructor for class javax.print.attribute. HashAttributeSet
构造一个新的空属性集。
HashAttributeSet(Class<?>) - Constructor for class javax.print.attribute. HashAttributeSet
构造一个新的空属性集，其中属性集的成员被限制到给定的接口。
HashAttributeSet(Attribute) - Constructor for class javax.print.attribute. HashAttributeSet
构造一个新的属性集，最初用给定的属性填充。
HashAttributeSet(Attribute[]) - Constructor for class javax.print.attribute. HashAttributeSet
构造一个新的属性集，最初用给定数组的值填充。
HashAttributeSet(Attribute[], Class<?>) - Constructor for class javax.print.attribute. HashAttributeSet
构造一个新的属性集，其中属性集的成员被限制到给定的接口。
HashAttributeSet(Attribute, Class<?>) - Constructor for class javax.print.attribute. HashAttributeSet
构造一个新的属性集，最初用给定的属性填充，属性集的成员被限制到给定的接口。
HashAttributeSet(AttributeSet) - Constructor for class javax.print.attribute. HashAttributeSet
构造新的属性集，最初用给定集合中的值填充。
HashAttributeSet(AttributeSet, Class<?>) - Constructor for class javax.print.attribute. HashAttributeSet
构造一个新的属性集，最初使用给定集合中的值进行填充，其中属性集的成员被限制到给定的接口。
hashCode() - Method in class com.sun.java.accessibility.util. Translator
返回哈希码。
hashCode() - Method in interface com.sun.jdi. BooleanValue
返回此BooleanValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. ByteValue
返回此BooleanValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. CharValue
返回此CharValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. DoubleValue
返回此DoubleValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. Field
返回此字段的哈希码值。
hashCode() - Method in interface com.sun.jdi. FloatValue
返回此FloatValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. IntegerValue
返回此IntegerValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. LocalVariable
返回此LocalVariable的哈希码值。
hashCode() - Method in interface com.sun.jdi. Location
返回此位置的哈希码值。
hashCode() - Method in interface com.sun.jdi. LongValue
返回此LongValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. 方法
返回此方法的哈希码值。
hashCode() - Method in interface com.sun.jdi. ObjectReference
返回此ObjectReference的哈希码值。
hashCode() - Method in interface com.sun.jdi. ReferenceType
返回此ObjectReference的哈希码值。
hashCode() - Method in interface com.sun.jdi. ShortValue
返回此ShortValue的哈希码值。
hashCode() - Method in interface com.sun.jdi. VoidValue
返回此VoidValue的哈希码值。
hashCode() - Method in class com.sun.management. GcInfo
hashCode() - Method in class com.sun.net.httpserver. Headers
hashCode() - Method in class com.sun.net.httpserver. HttpPrincipal
返回此HttpPrincipal的哈希码。
hashCode() - Method in class com.sun.nio.sctp. SctpStandardSocketOptions.InitMaxStreams
返回此init数据流的哈希码值。
hashCode() - Method in class com.sun.security.auth. LdapPrincipal
计算此主体的哈希码。
hashCode() - Method in class com.sun.security.auth. NTDomainPrincipal
返回这个 NTDomainPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. NTNumericCredential
返回这个 NTNumericCredential的哈希码。
hashCode() - Method in class com.sun.security.auth. NTSid
返回这个 NTSid的哈希码。
hashCode() - Method in class com.sun.security.auth. NTUserPrincipal
返回这个 NTUserPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. SolarisNumericGroupPrincipal
已过时。
返回这个 SolarisNumericGroupPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. SolarisNumericUserPrincipal
已过时。
返回这个 SolarisNumericUserPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. SolarisPrincipal
已过时。
返回这个 SolarisPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. UnixNumericGroupPrincipal
返回这个 UnixNumericGroupPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. UnixNumericUserPrincipal
返回这个 UnixNumericUserPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. UnixPrincipal
返回这个 UnixPrincipal的哈希码。
hashCode() - Method in class com.sun.security.auth. UserPrincipal
返回此主体的哈希码。
hashCode() - Method in class com.sun.security.auth. X500Principal
已过时。
返回这个 X500Principal的哈希码。
hashCode() - Method in class com.sun.tools.attach. VirtualMachine
返回此VirtualMachine的哈希码值。
hashCode() - Method in class com.sun.tools.attach. VirtualMachineDescriptor
返回此VirtualMachineDescriptor的哈希码值。
hashCode() - Method in class java.awt. AlphaComposite
返回此复合的哈希码。
hashCode() - Method in class java.awt. AWTKeyStroke
返回可能是唯一的该对象的数值，使其成为哈希表中的索引值的良好选择。
hashCode() - Method in class java.awt. BasicStroke
返回此笔画的哈希码。
hashCode() - Method in class java.awt. Color
计算这个 Color的哈希码。
hashCode() - Method in class java.awt.datatransfer. DataFlavor
返回这个 DataFlavor哈希码。
hashCode() - Method in class java.awt. Dimension
返回此 Dimension的哈希码。
hashCode() - Method in class java.awt. DisplayMode
返回对象的哈希码值。
hashCode() - Method in class java.awt.font. FontRenderContext
返回此FontRenderContext的哈希码。
hashCode() - Method in class java.awt. Font
返回这个 Font的哈希 Font 。
hashCode() - Method in class java.awt.font. ImageGraphicAttribute
返回这个 ImageGraphicAttribute的哈希 ImageGraphicAttribute 。
hashCode() - Method in class java.awt.font. NumericShaper
返回此整形器的哈希码。
hashCode() - Method in class java.awt.font. ShapeGraphicAttribute
返回这个 ShapeGraphicAttribute的哈希 ShapeGraphicAttribute 。
hashCode() - Method in class java.awt.font. TextHitInfo
返回哈希码。
hashCode() - Method in class java.awt.font. TransformAttribute
hashCode() - Method in class java.awt.geom. AffineTransform
返回此转换的哈希码。
hashCode() - Method in class java.awt.geom. Arc2D
返回此 Arc2D的哈希 Arc2D 。
hashCode() - Method in class java.awt.geom. Ellipse2D
返回此 Ellipse2D的哈希 Ellipse2D 。
hashCode() - Method in class java.awt.geom. Point2D
返回这个 Point2D的哈希 Point2D 。
hashCode() - Method in class java.awt.geom. Rectangle2D
返回此 Rectangle2D的哈希 Rectangle2D 。
hashCode() - Method in class java.awt.geom. RoundRectangle2D
返回此 RoundRectangle2D的哈希 RoundRectangle2D 。
hashCode() - Method in class java.awt.image. BandedSampleModel
hashCode() - Method in class java.awt.image. ColorModel
该方法简单地委托到 Object的默认实现，返回该类的系统ID。
hashCode() - Method in class java.awt.image. ComponentColorModel
返回此ComponentColorModel的哈希码。
hashCode() - Method in class java.awt.image. ComponentSampleModel
hashCode() - Method in class java.awt.image. IndexColorModel
返回IndexColorModel的哈希码。
hashCode() - Method in class java.awt.image. MultiPixelPackedSampleModel
hashCode() - Method in class java.awt.image. PackedColorModel
返回此PackedColorModel的哈希码。
hashCode() - Method in class java.awt.image. PixelInterleavedSampleModel
hashCode() - Method in class java.awt.image. SinglePixelPackedSampleModel
hashCode() - Method in class java.awt. Insets
返回此Insets的哈希码。
hashCode() - Method in class java.awt. JobAttributes
返回此JobAttributes的哈希码值。
hashCode() - Method in class java.awt. MenuShortcut
返回此MenuShortcut的哈希码。
hashCode() - Method in class java.awt. PageAttributes
返回此PageAttributes的哈希码值。
hashCode() - Method in class java.awt. RenderingHints
返回此 RenderingHints的哈希码值。
hashCode() - Method in class java.awt. RenderingHints.Key
所有Key对象的哈希码将与System.identityHashCode（）方法定义的对象的系统标识码相同。
hashCode() - Method in class java.beans. IndexedPropertyDescriptor
返回对象的哈希码值。
hashCode() - Method in class java.beans. PropertyDescriptor
返回对象的哈希码值。
hashCode() - Method in class java.io. File
计算此抽象路径名的哈希码。
hashCode() - Method in class java.io. FilePermission
返回此对象的哈希码值。
hashCode() - Method in interface java.lang.annotation. Annotation
返回此注释的哈希码，定义如下：
hashCode() - Method in class java.lang. Boolean
返回此 Boolean对象的哈希码。
hashCode() - Method in class java.lang. Byte
返回这个Byte的哈希码; 等于调用intValue()的结果。
hashCode() - Method in class java.lang. Character
返回这个Character的哈希码; 等于调用charValue()的结果。
hashCode() - Method in class java.lang. Character.Subset
返回由 Object.hashCode()方法定义的标准哈希码。
hashCode() - Method in class java.lang. Double
返回此 Double对象的哈希码。
hashCode() - Method in class java.lang. Enum
返回此枚举常量的哈希码。
hashCode() - Method in class java.lang. Float
返回此 Float对象的哈希码。
hashCode() - Method in class java.lang. Integer
返回此 Integer的哈希码。
hashCode() - Method in class java.lang.invoke. MethodType
返回此方法类型的哈希码值。
hashCode() - Method in class java.lang. Long
返回这个 Long的哈希码。
hashCode() - Method in class java.lang.module. ModuleDescriptor.Exports
计算此模块导出的哈希码。
hashCode() - Method in class java.lang.module. ModuleDescriptor
计算此模块描述符的哈希码。
hashCode() - Method in class java.lang.module. ModuleDescriptor.Opens
计算此模块的哈希码打开。
hashCode() - Method in class java.lang.module. ModuleDescriptor.Provides
计算这个提供的哈希码。
hashCode() - Method in class java.lang.module. ModuleDescriptor.Requires
计算此模块依赖的哈希码。
hashCode() - Method in class java.lang.module. ModuleDescriptor.Version
计算此模块版本的哈希码。
hashCode() - Method in class java.lang.module. ResolvedModule
计算此解析模块的哈希码。
hashCode() - Method in class java.lang. Object
返回对象的哈希码值。
hashCode() - Method in class java.lang. 软件包
返回从包名称计算的哈希码。
hashCode() - Method in class java.lang. ProcessBuilder.Redirect
返回此 Redirect的哈希码值。
hashCode() - Method in interface java.lang. ProcessHandle
返回此ProcessHandle的哈希码值。
hashCode() - Method in class java.lang.reflect. Constructor
返回这个 Constructor的哈希 Constructor 。
hashCode() - Method in class java.lang.reflect. Field
返回此 Field的哈希 Field 。
hashCode() - Method in class java.lang.reflect. 方法
返回这个 方法的哈希 方法 。
hashCode() - Method in class java.lang.reflect. Parameter
根据可执行文件的哈希码和索引返回哈希码。
hashCode() - Method in class java.lang. Runtime.Version
返回此版本的哈希码。
hashCode() - Method in class java.lang. Short
返回这个Short的哈希码; 等于调用intValue()的结果。
hashCode() - Method in class java.lang. StackTraceElement
返回此堆栈跟踪元素的哈希码值。
hashCode() - Method in class java.lang. String
返回此字符串的哈希码。
hashCode() - Method in class java.math. BigDecimal
返回此 BigDecimal的哈希码。
hashCode() - Method in class java.math. BigInteger
返回此BigInteger的哈希码。
hashCode() - Method in class java.math. MathContext
返回此 MathContext的哈希码。
hashCode() - Method in class java.net. HttpCookie
返回此HTTP cookie的哈希码。
hashCode() - Method in class java.net. Inet4Address
返回此IP地址的哈希码。
hashCode() - Method in class java.net. Inet6Address
返回此IP地址的哈希码。
hashCode() - Method in class java.net. InetAddress
返回此IP地址的哈希码。
hashCode() - Method in class java.net. InetSocketAddress
返回此套接字地址的哈希码。
hashCode() - Method in class java.net. InterfaceAddress
返回此接口地址的哈希码。
hashCode() - Method in class java.net. NetworkInterface
hashCode() - Method in class java.net. Proxy
返回此代理的哈希码。
hashCode() - Method in class java.net. SocketPermission
返回此对象的哈希码值。
hashCode() - Method in class java.net. URI
返回此URI的哈希码值。
hashCode() - Method in class java.net. URL
创建适合哈希表索引的整数。
hashCode() - Method in class java.net. URLPermission
返回从动作字符串和url字符串的哈希码计算的哈希码。
hashCode() - Method in class java.nio. ByteBuffer
返回此缓冲区的当前哈希码。
hashCode() - Method in class java.nio. CharBuffer
返回此缓冲区的当前哈希码。
hashCode() - Method in class java.nio.charset. Charset
计算此字符集的哈希码。
hashCode() - Method in class java.nio. DoubleBuffer
返回此缓冲区的当前哈希码。
hashCode() - Method in class java.nio.file.attribute. AclEntry
返回此ACL条目的哈希码值。
hashCode() - Method in class java.nio.file.attribute. FileTime
计算此文件时间的哈希码。
hashCode() - Method in interface java.nio.file. Path
计算此路径的哈希码。
hashCode() - Method in class java.nio. FloatBuffer
返回此缓冲区的当前哈希码。
hashCode() - Method in class java.nio. IntBuffer
返回此缓冲区的当前哈希码。
hashCode() - Method in class java.nio. LongBuffer
返回此缓冲区的当前哈希码。
hashCode() - Method in class java.nio. ShortBuffer
返回此缓冲区的当前哈希码。
hashCode() - Method in class java.rmi.activation. ActivationDesc
返回相同的hashCode类似的 ActivationDesc s。
hashCode() - Method in class java.rmi.activation. ActivationGroupDesc.CommandEnvironment
返回相似值 CommandEnvironment s。
hashCode() - Method in class java.rmi.activation. ActivationGroupDesc
为类似的产品生成相同的号码 ActivationGroupDesc 。
hashCode() - Method in class java.rmi.activation. ActivationGroupID
返回组的标识符的哈希码。
hashCode() - Method in class java.rmi.activation. ActivationID
返回激活ID的哈希码。
hashCode() - Method in class java.rmi.dgc. VMID
计算此VMID的哈希码。
hashCode() - Method in class java.rmi. MarshalledObject
返回这个 MarshalledObject的哈希码。
hashCode() - Method in class java.rmi.server. ObjID
返回此对象标识符（对象编号）的哈希码值。
hashCode() - Method in class java.rmi.server. RemoteObject
返回一个远程对象的哈希码。
hashCode() - Method in class java.rmi.server. UID
返回此 UID的哈希码值。
hashCode() - Method in class java.security. AccessControlContext
返回此上下文的哈希码值。
hashCode() - Method in class java.security. AllPermission
返回此对象的哈希码值。
hashCode() - Method in class java.security. BasicPermission
返回此对象的哈希码值。
hashCode() - Method in class java.security.cert. Certificate
从其编码形式返回此证书的哈希码值。
hashCode() - Method in class java.security.cert. CertPath
返回此认证路径的哈希码。
hashCode() - Method in class java.security.cert. URICertStoreParameters
返回此参数对象的哈希码值。
hashCode() - Method in class java.security.cert. X509CRL
从其编码形式返回此CRL的哈希码值。
hashCode() - Method in class java.security.cert. X509CRLEntry
从其编码形式返回此CRL条目的哈希码值。
hashCode() - Method in class java.security. CodeSigner
返回此代码签名者的哈希码值。
hashCode() - Method in class java.security. CodeSource
返回此对象的哈希码值。
hashCode() - Method in class java.security. Identity
已过时。
返回此标识的哈希码。
hashCode() - Method in class java.security. Permission
返回此Permission对象的哈希码值。
hashCode() - Method in class java.security. PKCS12Attribute
返回此 PKCS12Attribute的哈希 PKCS12Attribute 。
hashCode() - Method in interface java.security. Principal
返回此主体的哈希码。
hashCode() - Method in class java.security.spec. ECFieldF2m
返回此特征2有限域的哈希码值。
hashCode() - Method in class java.security.spec. ECFieldFp
返回此主要有限域的哈希码值。
hashCode() - Method in class java.security.spec. ECPoint
返回此椭圆曲线点的哈希码值。
hashCode() - Method in class java.security.spec. EllipticCurve
返回此椭圆曲线的哈希码值。
hashCode() - Method in class java.security. Timestamp
返回此时间戳的哈希码值。
hashCode() - Method in class java.security. UnresolvedPermission
返回此对象的哈希码值。
hashCode() - Method in interface java.sql. RowId
返回此 RowId对象的哈希码值。
hashCode() - Method in class java.sql. Timestamp
返回此对象的哈希码值。
hashCode() - Method in class java.text. AttributedCharacterIterator.Attribute
返回对象的哈希码值。
hashCode() - Method in class java.text. ChoiceFormat
生成消息格式对象的哈希码。
hashCode() - Method in class java.text. Collator
生成此Collator的哈希码。
hashCode() - Method in class java.text. DateFormat
覆盖hashCode
hashCode() - Method in class java.text. DateFormatSymbols
覆盖hashCode。
hashCode() - Method in class java.text. DecimalFormat
覆盖hashCode
hashCode() - Method in class java.text. DecimalFormatSymbols
覆盖hashCode。
hashCode() - Method in class java.text. FieldPosition
返回此FieldPosition的哈希码。
hashCode() - Method in class java.text. MessageFormat
生成消息格式对象的哈希码。
hashCode() - Method in class java.text. NumberFormat
覆盖hashCode。
hashCode() - Method in class java.text. ParsePosition
返回此ParsePosition的哈希码。
hashCode() - Method in class java.text. RuleBasedCollator
生成基于表的归类对象的哈希码
hashCode() - Method in class java.text. SimpleDateFormat
返回此 SimpleDateFormat对象的哈希码值。
hashCode() - Method in class java.text. StringCharacterIterator
计算此迭代器的哈希码。
hashCode() - Method in class java.time.chrono. AbstractChronology
这个年表的哈希码。
hashCode() - Method in interface java.time.chrono. ChronoLocalDate
这个日期的哈希码。
hashCode() - Method in interface java.time.chrono. ChronoLocalDateTime
这个日期时间的哈希码。
hashCode() - Method in interface java.time.chrono. Chronology
这个年表的哈希码。
hashCode() - Method in interface java.time.chrono. ChronoPeriod
此期间的哈希码。
hashCode() - Method in interface java.time.chrono. ChronoZonedDateTime
这个日期时间的哈希码。
hashCode() - Method in class java.time.chrono. HijrahDate
这个日期的哈希码。
hashCode() - Method in class java.time.chrono. JapaneseDate
这个日期的哈希码。
hashCode() - Method in class java.time.chrono. MinguoDate
这个日期的哈希码。
hashCode() - Method in class java.time.chrono. ThaiBuddhistDate
这个日期的哈希码。
hashCode() - Method in class java.time. Clock
这个时钟的哈希码。
hashCode() - Method in class java.time. Duration
这个持续时间的哈希码。
hashCode() - Method in class java.time.format. DecimalStyle
这个DecimalStyle的哈希码。
hashCode() - Method in class java.time. Instant
返回此时刻的哈希码。
hashCode() - Method in class java.time. LocalDate
这个日期的哈希码。
hashCode() - Method in class java.time. LocalDateTime
这个日期时间的哈希码。
hashCode() - Method in class java.time. LocalTime
这个时候的哈希码。
hashCode() - Method in class java.time. MonthDay
这个月的哈希码。
hashCode() - Method in class java.time. OffsetDateTime
这个日期时间的哈希码。
hashCode() - Method in class java.time. OffsetTime
这个时候的哈希码。
hashCode() - Method in class java.time. Period
此期间的哈希码。
hashCode() - Method in class java.time.temporal. ValueRange
此范围的哈希码。
hashCode() - Method in class java.time.temporal. WeekFields
这个 WeekFields哈希码。
hashCode() - Method in class java.time. Year
今年的哈希码。
hashCode() - Method in class java.time. YearMonth
今年的哈希码。
hashCode() - Method in class java.time.zone. ZoneOffsetTransition
返回一个合适的哈希码。
hashCode() - Method in class java.time.zone. ZoneOffsetTransitionRule
返回一个合适的哈希码。
hashCode() - Method in class java.time.zone. ZoneRules
返回给定 #equals的合适的哈希码。
hashCode() - Method in class java.time. ZonedDateTime
这个日期时间的哈希码。
hashCode() - Method in class java.time. ZoneId
此时区ID的哈希码。
hashCode() - Method in class java.time. ZoneOffset
这个偏移的哈希码。
hashCode() - Method in class java.util. AbstractList
返回此列表的哈希码值。
hashCode() - Method in class java.util. AbstractMap
返回此地图的哈希码值。
hashCode() - Method in class java.util. AbstractMap.SimpleEntry
返回此映射条目的哈希码值。
hashCode() - Method in class java.util. AbstractMap.SimpleImmutableEntry
返回此映射条目的哈希码值。
hashCode() - Method in class java.util. AbstractSet
返回此集合的哈希码值。
hashCode() - Method in class java.util. BitSet
返回此位集的哈希码值。
hashCode() - Method in class java.util. Calendar
返回此日历的哈希码。
hashCode() - Method in interface java.util. Collection
返回此集合的哈希码值。
hashCode() - Method in class java.util.concurrent. ConcurrentHashMap
返回此Map的哈希码值，即映射中每个键值对的总和，即key.hashCode() ^ value.hashCode() 。
hashCode() - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView
hashCode() - Method in class java.util.concurrent. CopyOnWriteArrayList
返回此列表的哈希码值。
hashCode() - Method in class java.util. Date
返回此对象的哈希码值。
hashCode() - Method in class java.util. EnumMap
返回此地图的哈希码值。
hashCode() - Method in class java.util. GregorianCalendar
生成此 GregorianCalendar对象的哈希码。
hashCode() - Method in class java.util. Hashtable
按照Map界面中的定义返回此Map的哈希码值。
hashCode() - Method in class java.util. IdentityHashMap
返回此地图的哈希码值。
hashCode() - Method in class java.util.jar. Attributes
返回此Map的哈希码值。
hashCode() - Method in class java.util.jar. Attributes.Name
计算此属性名称的哈希值。
hashCode() - Method in class java.util.jar. Manifest
返回此清单的哈希码。
hashCode() - Method in interface java.util. List
返回此列表的哈希码值。
hashCode() - Method in class java.util. Locale
覆盖hashCode。
hashCode() - Method in class java.util. Locale.LanguageRange
返回对象的哈希码值。
hashCode() - Method in class java.util.logging. Level
生成哈希码。
hashCode() - Method in interface java.util. Map.Entry
返回此映射条目的哈希码值。
hashCode() - Method in interface java.util. Map
返回此地图的哈希码值。
hashCode() - Method in class java.util. Optional
返回值的哈希码（如果存在），否则为 0 （零），如果没有值。
hashCode() - Method in class java.util. OptionalDouble
返回值的哈希码，如果存在，否则为 0 （零），如果不存在值。
hashCode() - Method in class java.util. OptionalInt
返回值的哈希码，如果存在，否则为 0 （零），如果不存在值。
hashCode() - Method in class java.util. OptionalLong
返回值的哈希码，如果存在，否则为 0 （零），如果没有值。
hashCode() - Method in class java.util. Properties
hashCode() - Method in class java.util. PropertyPermission
返回此对象的哈希码值。
hashCode() - Method in interface java.util. Set
返回此集合的哈希码值。
hashCode() - Method in class java.util. SimpleTimeZone
生成SimpleDateFormat对象的哈希码。
hashCode() - Method in class java.util. UUID
返回这个 UUID的哈希码。
hashCode() - Method in class java.util. Vector
返回此Vector的哈希码值。
hashCode() - Method in class java.util.zip. ZipEntry
返回此条目的哈希码值。
hashCode() - Method in class javafx.animation. KeyFrame
返回此 KeyFrame对象的哈希码。
hashCode() - Method in class javafx.animation. KeyValue
返回此 KeyValue对象的哈希码。
hashCode() - Method in class javafx.beans.property. ReadOnlyListProperty
hashCode() - Method in class javafx.beans.property. ReadOnlyMapProperty
返回此 ReadOnlyMapProperty对象的哈希码。
hashCode() - Method in class javafx.beans.property. ReadOnlySetProperty
返回此 ReadOnlySetProperty对象的哈希码。
hashCode() - Method in class javafx.css. CompoundSelector
hashCode() - Method in class javafx.css.converter. EnumConverter
hashCode() - Method in class javafx.css. CssMetaData
hashCode() - Method in class javafx.css. Declaration
hashCode() - Method in class javafx.css. SimpleSelector
hashCode() - Method in class javafx.css. Size
hashCode() - Method in class javafx.css. Style
hashCode() - Method in class javafx.css. Stylesheet
hashCode() - Method in class javafx.geometry. BoundingBox
返回对象的哈希码值。
hashCode() - Method in class javafx.geometry. Dimension2D
返回Dimension2D对象的哈希码值。
hashCode() - Method in class javafx.geometry. Insets
返回插值的哈希码值。
hashCode() - Method in class javafx.geometry. Point2D
返回该点的哈希码值。
hashCode() - Method in class javafx.geometry. Point3D
返回此 Point3D对象的哈希码。
hashCode() - Method in class javafx.geometry. Rectangle2D
返回此 Rectangle2D对象的哈希码。
hashCode() - Method in class javafx.print. PageLayout
hashCode() - Method in class javafx.print. Paper
hashCode() - Method in class javafx.print. PrintResolution
hashCode() - Method in class javafx.scene.control. IndexRange
返回此 Range对象的哈希码。
hashCode() - Method in class javafx.scene.control. TablePositionBase
返回此 TablePosition对象的哈希码。
hashCode() - Method in class javafx.scene.input. DataFormat
返回此 DataFormat对象的哈希码。
hashCode() - Method in class javafx.scene.input. KeyCharacterCombination
返回此 KeyCharacterCombination的哈希码值。
hashCode() - Method in class javafx.scene.input. KeyCodeCombination
返回此 KeyCodeCombination的哈希码值。
hashCode() - Method in class javafx.scene.input. KeyCombination
返回此 KeyCombination的哈希码值。
hashCode() - Method in class javafx.scene.layout. Background
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BackgroundFill
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BackgroundImage
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BackgroundPosition
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BackgroundSize
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. Border
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BorderImage
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BorderStroke
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BorderStrokeStyle
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. BorderWidths
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.layout. CornerRadii
返回对象的哈希码值。
hashCode() - Method in class javafx.scene.paint. Color
Color
hashCode() - Method in class javafx.scene.paint. LinearGradient
返回此 LinearGradient对象的哈希码。
hashCode() - Method in class javafx.scene.paint. RadialGradient
返回此 RadialGradient对象的哈希码。
hashCode() - Method in class javafx.scene.paint. Stop
返回此 Stop对象的哈希码。
hashCode() - Method in class javafx.scene.text. Font
返回此 Font对象的哈希码。
hashCode() - Method in class javafx.stage. Screen
返回此 Screen对象的哈希码。
hashCode() - Method in class javafx.util. Duration
返回此 Duration对象的哈希码。
hashCode() - Method in class javafx.util. Pair
为此 Pair生成哈希码。
hashCode() - Method in class javax.crypto.spec. RC2ParameterSpec
计算对象的哈希码值。
hashCode() - Method in class javax.crypto.spec. RC5ParameterSpec
计算对象的哈希码值。
hashCode() - Method in class javax.crypto.spec. SecretKeySpec
计算对象的哈希码值。
hashCode() - Method in class javax.imageio. ImageTypeSpecifier
返回此ImageTypeSpecifier的哈希码。
hashCode() - Method in interface javax.lang.model.element. Element
遵守 Object.hashCode的总合同。
hashCode() - Method in interface javax.lang.model.element. Name
遵守 Object.hashCode的总合同。
hashCode() - Method in interface javax.lang.model.type. TypeMirror
服从总协议 Object.hashCode 。
hashCode() - Method in class javax.management. Attribute
返回此属性的哈希码值。
hashCode() - Method in interface javax.management. Descriptor
返回此描述符的哈希码值。
hashCode() - Method in class javax.management. ImmutableDescriptor
返回此描述符的哈希码值。
hashCode() - Method in class javax.management. MBeanAttributeInfo
hashCode() - Method in class javax.management. MBeanConstructorInfo
hashCode() - Method in class javax.management. MBeanFeatureInfo
hashCode() - Method in class javax.management. MBeanInfo
hashCode() - Method in class javax.management. MBeanNotificationInfo
hashCode() - Method in class javax.management. MBeanOperationInfo
hashCode() - Method in class javax.management. MBeanParameterInfo
hashCode() - Method in class javax.management. MBeanPermission
返回此对象的哈希码值。
hashCode() - Method in class javax.management. MBeanServerPermission
hashCode() - Method in class javax.management.modelmbean. DescriptorSupport
返回此描述符的哈希码值。
hashCode() - Method in class javax.management. ObjectInstance
hashCode() - Method in class javax.management. ObjectName
返回此对象名称的哈希码。
hashCode() - Method in class javax.management.openmbean. ArrayType
返回此 ArrayType实例的哈希码值。
hashCode() - Method in interface javax.management.openmbean. CompositeData
返回此 CompositeData实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. CompositeDataSupport
返回此 CompositeDataSupport实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. CompositeType
返回此 CompositeType实例的哈希码值。
hashCode() - Method in interface javax.management.openmbean. OpenMBeanAttributeInfo
返回此 OpenMBeanAttributeInfo实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport
返回此 OpenMBeanAttributeInfoSupport实例的哈希码值。
hashCode() - Method in interface javax.management.openmbean. OpenMBeanConstructorInfo
返回此 OpenMBeanConstructorInfo实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. OpenMBeanConstructorInfoSupport
返回此 OpenMBeanConstructorInfoSupport实例的哈希码值。
hashCode() - Method in interface javax.management.openmbean. OpenMBeanInfo
返回此 OpenMBeanInfo实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. OpenMBeanInfoSupport
返回此 OpenMBeanInfoSupport实例的哈希码值。
hashCode() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo
返回此 OpenMBeanOperationInfo实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. OpenMBeanOperationInfoSupport
返回此 OpenMBeanOperationInfoSupport实例的哈希码值。
hashCode() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo
返回此 OpenMBeanParameterInfo实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport
返回此 OpenMBeanParameterInfoSupport实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. OpenType
hashCode() - Method in class javax.management.openmbean. SimpleType
返回此 SimpleType实例的哈希码值。
hashCode() - Method in interface javax.management.openmbean. TabularData
返回此 TabularData实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. TabularDataSupport
返回此 TabularDataSupport实例的哈希码值。
hashCode() - Method in class javax.management.openmbean. TabularType
返回此 TabularType实例的哈希码值。
hashCode() - Method in class javax.management.remote. JMXPrincipal
返回此 JMXPrincipal的哈希码。
hashCode() - Method in class javax.management.remote. JMXServiceURL
hashCode() - Method in class javax.naming. BinaryRefAddr
使用其地址类型和内容计算该地址的哈希码。
hashCode() - Method in class javax.naming. CompositeName
计算此复合名称的哈希码。
hashCode() - Method in class javax.naming. CompoundName
计算此化合物名称的哈希码。
hashCode() - Method in class javax.naming.directory. BasicAttribute
计算此属性的哈希码。
hashCode() - Method in class javax.naming.directory. BasicAttributes
计算此BasicAttributes的哈希码。
hashCode() - Method in class javax.naming.ldap. LdapName
计算此LDAP名称的哈希码。
hashCode() - Method in class javax.naming.ldap. Rdn
返回此RDN的哈希码。
hashCode() - Method in class javax.naming. RefAddr
使用其地址类型和内容计算该地址的哈希码。
hashCode() - Method in class javax.naming. Reference
计算此引用的哈希码。
hashCode() - Method in class javax.net.ssl. SNIHostName
返回此 SNIHostName的哈希码值。
hashCode() - Method in class javax.net.ssl. SNIServerName
返回此服务器名称的哈希码值。
hashCode() - Method in interface javax.print.attribute. AttributeSet
返回此属性集的哈希码值。
hashCode() - Method in class javax.print.attribute. DateTimeSyntax
返回此日期时间属性的哈希码值。
hashCode() - Method in class javax.print.attribute. EnumSyntax
返回此枚举值的哈希码值。
hashCode() - Method in class javax.print.attribute. HashAttributeSet
返回此属性集的哈希码值。
hashCode() - Method in class javax.print.attribute. IntegerSyntax
返回此整数属性的哈希码值。
hashCode() - Method in class javax.print.attribute. ResolutionSyntax
返回此分辨率属性的哈希码值。
hashCode() - Method in class javax.print.attribute. SetOfIntegerSyntax
返回此整数属性的哈希码值。
hashCode() - Method in class javax.print.attribute. Size2DSyntax
返回此二维大小属性的哈希码值。
hashCode() - Method in class javax.print.attribute.standard. MediaPrintableArea
返回此属性的哈希码值。
hashCode() - Method in class javax.print.attribute. TextSyntax
返回此文本属性的哈希码。
hashCode() - Method in class javax.print.attribute. URISyntax
返回此URI属性的哈希码。
hashCode() - Method in class javax.print. DocFlavor
返回此文档风格对象的哈希码。
hashCode() - Method in interface javax.print. PrintService
该方法应与 equals(Object)一致实施。
hashCode() - Method in class javax.rmi.CORBA. Stub
返回对象的哈希码值，该代码对于表示同一个远程对象的所有存根都是相同的。
hashCode() - Method in class javax.rmi.ssl. SslRMIClientSocketFactory
返回此 SslRMIClientSocketFactory的哈希码值。
hashCode() - Method in class javax.rmi.ssl. SslRMIServerSocketFactory
返回此 SslRMIServerSocketFactory的哈希码值。
hashCode() - Method in class javax.security.auth.kerberos. DelegationPermission
返回此对象的哈希码值。
hashCode() - Method in class javax.security.auth.kerberos. EncryptionKey
返回这个 EncryptionKey的哈希码。
hashCode() - Method in class javax.security.auth.kerberos. KerberosCredMessage
返回这个 KerberosCredMessage的哈希码。
hashCode() - Method in class javax.security.auth.kerberos. KerberosKey
返回这个 KerberosKey的哈希码。
hashCode() - Method in class javax.security.auth.kerberos. KerberosPrincipal
返回这个 KerberosPrincipal的哈希码。
hashCode() - Method in class javax.security.auth.kerberos. KerberosTicket
返回此 KerberosTicket的哈希码。
hashCode() - Method in class javax.security.auth.kerberos. KeyTab
返回这个 KeyTab的哈希码。
hashCode() - Method in class javax.security.auth.kerberos. ServicePermission
返回此对象的哈希码值。
hashCode() - Method in class javax.security.auth. PrivateCredentialPermission
返回此对象的哈希码值。
hashCode() - Method in class javax.security.auth. Subject
返回这个 Subject的哈希 Subject 。
hashCode() - Method in class javax.security.auth.x500. X500Principal
返回这个 X500Principal的哈希码。
hashCode() - Method in class javax.security.cert. Certificate
已过时。
从其编码形式返回此证书的哈希码值。
hashCode() - Method in class javax.smartcardio. ATR
返回此ATR的哈希码值。
hashCode() - Method in class javax.smartcardio. CardPermission
返回此CardPermission对象的哈希码值。
hashCode() - Method in class javax.smartcardio. CommandAPDU
返回此命令APDU的哈希码值。
hashCode() - Method in class javax.smartcardio. ResponseAPDU
返回此响应APDU的哈希码值。
hashCode() - Method in class javax.sound.midi. MidiDevice.Info
完成哈希码方法。
hashCode() - Method in class javax.sound.midi. Sequencer.SyncMode
完成哈希码方法。
hashCode() - Method in class javax.sound.sampled. AudioFileFormat.Type
完成hashCode方法。
hashCode() - Method in class javax.sound.sampled. AudioFormat.Encoding
完成hashCode方法。
hashCode() - Method in class javax.sound.sampled. Control.Type
完成hashCode方法。
hashCode() - Method in class javax.sound.sampled. LineEvent.Type
完成哈希码方法。
hashCode() - Method in class javax.sound.sampled. Mixer.Info
完成哈希码方法。
hashCode() - Method in class javax.sound.sampled. Port.Info
完成hashCode方法。
hashCode() - Method in class javax.sound.sampled. ReverbType
完成哈希码方法。
hashCode() - Method in class javax.sql.rowset.serial. SerialArray
返回此SerialArray的哈希码。
hashCode() - Method in class javax.sql.rowset.serial. SerialBlob
返回这个 SerialBlob的哈希码。
hashCode() - Method in class javax.sql.rowset.serial. SerialClob
返回这个 SerialClob的哈希码。
hashCode() - Method in class javax.sql.rowset.serial. SerialDatalink
返回此 SerialDatalink的哈希码。
hashCode() - Method in class javax.sql.rowset.serial. SerialJavaObject
返回此SerialJavaObject的哈希码。
hashCode() - Method in class javax.sql.rowset.serial. SerialRef
返回这个 SerialRef的哈希码。
hashCode() - Method in class javax.sql.rowset.serial. SerialStruct
返回此 SerialStruct的哈希码。
hashCode() - Method in class javax.swing. RowSorter.SortKey
返回此 SortKey的哈希码。
hashCode() - Method in class javax.swing.text.html. HTML.UnknownTag
返回与该标签的字符串对应的哈希码。
hashCode() - Method in class javax.swing.text. SimpleAttributeSet
返回此属性集的哈希码。
hashCode() - Method in class javax.swing.text. StyleContext.SmallAttributeSet
返回此属性集的哈希码。
hashCode() - Method in class javax.swing.text. TabSet
返回此组TabStops的哈希码。
hashCode() - Method in class javax.swing.text. TabStop
返回对象的hashCode。
hashCode() - Method in class javax.swing.tree. TreePath
返回此 TreePath的哈希码。
hashCode() - Method in class javax.xml.datatype. Duration
返回与equals方法的定义一致的哈希码。
hashCode() - Method in class javax.xml.datatype. XMLGregorianCalendar
返回与equals方法的定义一致的哈希码。
hashCode() - Method in class javax.xml.namespace. QName
生成这个 QName的哈希码。
hashCode() - Method in class jdk.dynalink. CallSiteDescriptor
返回从其操作，方法类型和查找对象的查找类和查找模式计算的此调用站点描述符的基于值的哈希码。
hashCode() - Method in class jdk.dynalink. NamedOperation
返回此命名操作的哈希码。
hashCode() - Method in class jdk.dynalink. NamespaceOperation
返回此命名空间操作的哈希码。
hashCode() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
hashCode() - Method in class org.ietf.jgss. ChannelBinding
返回此ChannelBinding对象的哈希码值。
hashCode() - Method in interface org.ietf.jgss. GSSCredential
返回此GSSCredential的哈希码值。
hashCode() - Method in interface org.ietf.jgss. GSSName
返回此GSSName的哈希码值。
hashCode() - Method in class org.ietf.jgss. Oid
返回此Oid的哈希码值。
hashCode() - Method in class org.omg.CORBA.portable. ObjectImpl
返回此 ObjectImpl对象的哈希码。
hashCode(boolean) - Static method in class java.lang. Boolean
返回一个boolean值的哈希码; 兼容Boolean.hashCode() 。
hashCode(boolean[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(byte) - Static method in class java.lang. Byte
返回一个byte值的哈希码; 兼容Byte.hashCode() 。
hashCode(byte[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(char) - Static method in class java.lang. Character
返回值为char的哈希码; 兼容Character.hashCode() 。
hashCode(char[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(double) - Static method in class java.lang. Double
返回一个double值的哈希码; 兼容Double.hashCode() 。
hashCode(double[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(float) - Static method in class java.lang. Float
返回一个float值的哈希码; 兼容Float.hashCode() 。
hashCode(float[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(int) - Static method in class java.lang. Integer
返回值为int的哈希码; 兼容Integer.hashCode() 。
hashCode(int[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(long) - Static method in class java.lang. Long
返回一个long值的哈希码; 兼容Long.hashCode() 。
hashCode(long[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(short) - Static method in class java.lang. Short
返回一个short值的哈希码; 兼容Short.hashCode() 。
hashCode(short[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(Object) - Static method in class java.util. Objects
返回非的哈希码 null参数，0为 null参数。
hashCode(Object[]) - Static method in class java.util. Arrays
根据指定数组的内容返回哈希码。
hashCode(URL) - Method in class java.net. URLStreamHandler
提供默认散列计算。
hashCode(Stub) - Method in interface javax.rmi.CORBA. StubDelegate
代表团要求 Stub.hashCode() 。
hashCode(Object) - Method in class org.omg.CORBA.portable. Delegate
提供实现来覆盖委托CORBA对象的hashCode（）方法。
HashDocAttributeSet - Class in javax.print.attribute
HashDocAttributeSet类提供了一个从HashAttributeSet类继承其实现的属性集，并强制实现了接口DocAttributeSet的语义限制。
HashDocAttributeSet() - Constructor for class javax.print.attribute. HashDocAttributeSet
构造一个新的，空的哈希文档属性集。
HashDocAttributeSet(DocAttribute) - Constructor for class javax.print.attribute. HashDocAttributeSet
构造一个新的哈希文档属性集，最初用给定的值填充。
HashDocAttributeSet(DocAttribute[]) - Constructor for class javax.print.attribute. HashDocAttributeSet
构造一个新的哈希文档属性集，最初用给定数组的值填充。
HashDocAttributeSet(DocAttributeSet) - Constructor for class javax.print.attribute. HashDocAttributeSet
构造一个新的属性集，最初使用给定集合中的值进行填充，其中属性集的成员被限制到 DocAttribute接口。
HashMap< K, V> - Class in java.util
基于哈希表的实现 Map接口。
HashMap() - Constructor for class java.util. HashMap
构造一个空的 HashMap ，默认的初始容量（16）和默认负载因子（0.75）。
HashMap(int) - Constructor for class java.util. HashMap
构造一个空的 HashMap具有指定的初始容量和默认负载因子（0.75）。
HashMap(int, float) - Constructor for class java.util. HashMap
构造一个空的 HashMap具有指定的初始容量和负载因子。
HashMap(Map<? extends K, ? extends V>) - Constructor for class java.util. HashMap
构造新的 HashMap具有与指定的相同的映射 Map 。
HashPrintJobAttributeSet - Class in javax.print.attribute
HashPrintJobAttributeSet类提供了一个从HashAttributeSet类继承其实现的属性集，并强制实现了接口PrintJobAttributeSet的语义限制。
HashPrintJobAttributeSet() - Constructor for class javax.print.attribute. HashPrintJobAttributeSet
构造一个新的，空的哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute) - Constructor for class javax.print.attribute. HashPrintJobAttributeSet
构造一个新的哈希打印作业属性集，最初用给定的值填充。
HashPrintJobAttributeSet(PrintJobAttribute[]) - Constructor for class javax.print.attribute. HashPrintJobAttributeSet
构造一个新的哈希打印作业属性集，最初使用给定数组中的值填充。
HashPrintJobAttributeSet(PrintJobAttributeSet) - Constructor for class javax.print.attribute. HashPrintJobAttributeSet
构造一个新的属性集，最初使用给定集合中的值进行填充，其中属性集的成员被限制到 PrintJobAttribute接口。
HashPrintRequestAttributeSet - Class in javax.print.attribute
HashPrintRequestAttributeSet类继承自HashAttributeSet类的实现，并强制接口PrintRequestAttributeSet的语义限制。
HashPrintRequestAttributeSet() - Constructor for class javax.print.attribute. HashPrintRequestAttributeSet
构造一个新的空的打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute) - Constructor for class javax.print.attribute. HashPrintRequestAttributeSet
构造一个新的打印请求属性集，最初用给定的值填充。
HashPrintRequestAttributeSet(PrintRequestAttribute[]) - Constructor for class javax.print.attribute. HashPrintRequestAttributeSet
构造一个新的打印请求属性集，最初用给定数组的值填充。
HashPrintRequestAttributeSet(PrintRequestAttributeSet) - Constructor for class javax.print.attribute. HashPrintRequestAttributeSet
构造一个新的属性集，最初使用给定集合中的值进行填充，其中属性集的成员被限制到 (PrintRequestAttributeSe接口。
HashPrintServiceAttributeSet - Class in javax.print.attribute
HashPrintServiceAttributeSet类提供了一个从HashAttributeSet类继承其实现的属性集，并强制接口PrintServiceAttributeSet的语义限制。
HashPrintServiceAttributeSet() - Constructor for class javax.print.attribute. HashPrintServiceAttributeSet
构造一个新的，空的哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute) - Constructor for class javax.print.attribute. HashPrintServiceAttributeSet
构造一个新的哈希打印服务属性集，最初用给定的值填充。
HashPrintServiceAttributeSet(PrintServiceAttribute[]) - Constructor for class javax.print.attribute. HashPrintServiceAttributeSet
构造一个新的打印服务属性集，最初用给定数组的值填充。
HashPrintServiceAttributeSet(PrintServiceAttributeSet) - Constructor for class javax.print.attribute. HashPrintServiceAttributeSet
构造一个新的属性集，最初使用给定集合中的值进行填充，其中属性集的成员被限制到 PrintServiceAttribute接口。
HashSet< E> - Class in java.util
该类实现了 Set接口，由哈希表（实际为 HashMap实例）支持。
HashSet() - Constructor for class java.util. HashSet
构造一个新的空集合; 支持HashMap实例具有默认初始容量（16）和负载因子（0.75）。
HashSet(int) - Constructor for class java.util. HashSet
构造一个新的空集合; 背景HashMap实例具有指定的初始容量和默认负载因子（0.75）。
HashSet(int, float) - Constructor for class java.util. HashSet
构造一个新的空集合; 背景HashMap实例具有指定的初始容量和指定的负载因子。
HashSet(Collection<? extends E>) - Constructor for class java.util. HashSet
构造一个包含指定集合中的元素的新集合。
Hashtable< K, V> - Class in java.util
该类实现了一个哈希表，它将键映射到值。
Hashtable() - Constructor for class java.util. Hashtable
构造一个新的，空的散列表，默认初始容量（11）和负载因子（0.75）。
Hashtable(int) - Constructor for class java.util. Hashtable
构造一个新的，空的哈希表，具有指定的初始容量和默认负载因子（0.75）。
Hashtable(int, float) - Constructor for class java.util. Hashtable
构造一个新的，空的哈希表，具有指定的初始容量和指定的负载因子。
Hashtable(Map<? extends K, ? extends V>) - Constructor for class java.util. Hashtable
构造一个与给定地图相同的映射的新哈希表。
hasHtml() - Method in class javafx.scene.input. Clipboard
获取HTML文本String（DataFormat.HTML）是否已在此剪贴板上注册。
hasHtml() - Method in class javafx.scene.input. ClipboardContent
获取HTML字符串（ DataFormat.HTML ）是否已被放置到此 ClipboardContent 。
hasImage() - Method in class javafx.scene.input. Clipboard
获取图像（DataFormat.IMAGE）是否已在此剪贴板上注册。
hasImage() - Method in class javafx.scene.input. ClipboardContent
获取图像（ DataFormat.IMAGE ）是否已被放入此 ClipboardContent 。
hasInitialContextFactoryBuilder() - Static method in class javax.naming.spi. NamingManager
确定初始上下文工厂生成器是否已设置。
hasInitialResponse() - Method in interface javax.security.sasl. SaslClient
确定此机制是否具有可选的初始响应。
hasLayoutAttributes() - Method in class java.awt. Font
如果此字体包含需要额外布局处理的属性，则返回true。
hasLegalValues() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport
返回 true如果 OpenMBeanAttributeInfoSupport实例指定所描述属性的非null的合法值集， false不然。
hasLegalValues() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo
返回 true如果此参数存在指定的合法值，或 false其他。
hasLegalValues() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport
返回 true如果 OpenMBeanParameterInfoSupport实例指定所描述参数的非null的合法值集， false不然。
hasListeners() - Method in class javafx.collections. ObservableListBase
如果为此列表注册了一些监听器，则返回true。
hasListeners(String) - Method in class java.beans. PropertyChangeSupport
检查是否有特定属性的监听器，包括在所有属性上注册的监听器。
hasListeners(String) - Method in class java.beans. VetoableChangeSupport
检查是否有特定属性的监听器，包括在所有属性上注册的监听器。
hasLocation(JavaFileManager.Location) - Method in class javax.tools. ForwardingJavaFileManager
hasLocation(JavaFileManager.Location) - Method in interface javax.tools. JavaFileManager
确定此文件管理器是否已知位置。
hasMaxValue() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport
如果此 OpenMBeanAttributeInfoSupport实例指定了所描述的属性的非空最大值，则返回 true ，否则为 false 。
hasMaxValue() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo
返回 true如果此参数存在指定的最大值，或者 false否则。
hasMaxValue() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport
如果此 OpenMBeanParameterInfoSupport实例指定了所描述的参数的非零最大值，则返回 true ，否则为 false 。
hasMember(String) - Method in class jdk.nashorn.api.scripting. AbstractJSObject
hasMember(String) - Method in interface jdk.nashorn.api.scripting. JSObject
该对象是否具有命名成员？
hasMember(String) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
hasMenu() - Method in class javafx.scene.web. PopupFeatures
返回菜单栏是否存在。
hasMenuShortcut() - Method in interface javax.jnlp. IntegrationService
检查应用程序是否具有菜单快捷方式。
hasMinValue() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport
如果此 OpenMBeanAttributeInfoSupport实例指定了所描述的属性的非空最小值，则返回 true ，否则为 false 。
hasMinValue() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo
返回 true如果此参数存在指定的最小值，或 false否则。
hasMinValue() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport
如果此 OpenMBeanParameterInfoSupport实例指定了所描述的参数的非空最小值，则返回 true ，否则为 false 。
hasMore() - Method in interface javax.naming. NamingEnumeration
确定枚举中是否有更多的元素。
hasMoreElements() - Method in interface java.util. Enumeration
测试此枚举是否包含更多元素。
hasMoreElements() - Method in class java.util. StringTokenizer
返回与 hasMoreTokens方法相同的值。
hasMoreTokens() - Method in class java.util. StringTokenizer
测试此令牌化程序的字符串是否有更多的令牌可用。
hasName() - Method in class javax.xml.stream.util. StreamReaderDelegate
hasName() - Method in interface javax.xml.stream. XMLStreamReader
返回一个布尔值，表示当前事件是否具有名称（是START_ELEMENT或END_ELEMENT）。
hasNext() - Method in class java.beans.beancontext. BeanContextSupport.BCSIterator
hasNext() - Method in interface java.util. Iterator
如果迭代具有更多元素，则返回 true 。
hasNext() - Method in interface java.util. ListIterator
如果此列表迭代器在向前方向遍历列表时具有更多元素，则返回 true 。
hasNext() - Method in class java.util. Scanner
如果此扫描仪在其输入中有另一个令牌，则返回true。
hasNext() - Method in class javax.xml.stream.util. EventReaderDelegate
hasNext() - Method in class javax.xml.stream.util. StreamReaderDelegate
hasNext() - Method in interface javax.xml.stream. XMLEventReader
检查是否有更多的事件。
hasNext() - Method in interface javax.xml.stream. XMLStreamReader
如果有更多的解析事件，返回true，如果没有更多的事件，返回false。
hasNext(String) - Method in class java.util. Scanner
如果下一个令牌匹配从指定字符串构造的模式，则返回true。
hasNext(Pattern) - Method in class java.util. Scanner
如果下一个完整的令牌匹配指定的模式，则返回true。
hasNextBigDecimal() - Method in class java.util. Scanner
如果此扫描仪输入中的下一个令牌可以使用 Scanner.nextBigDecimal()方法解释为 BigDecimal则返回true。
hasNextBigInteger() - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextBigInteger()方法将其解释为默认基数中的 BigInteger ，则返回true。
hasNextBigInteger(int) - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextBigInteger()方法解释为指定基数中的 BigInteger ，则返回true。
hasNextBoolean() - Method in class java.util. Scanner
如果此扫描器输入中的下一个标记可以使用从字符串“true | false”创建的不区分大小写的模式解释为布尔值，则返回true。
hasNextByte() - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextByte()方法将其解释为默认基数中的字节值，则返回true。
hasNextByte(int) - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextByte()方法解释为指定基数中的字节值，则返回true。
hasNextDouble() - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextDouble()方法将其解释为双重值，则返回true。
hasNextFloat() - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextFloat()方法将其解释为浮点值，则返回true。
hasNextInt() - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextInt()方法将其解释为默认基数中的int值，则返回true。
hasNextInt(int) - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextInt()方法解释为指定基数中的int值，则返回true。
hasNextLine() - Method in class java.util. Scanner
如果扫描仪的输入中有另一行，则返回true。
hasNextLong() - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextLong()方法将其解释为默认基数中的长值，则返回true。
hasNextLong(int) - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextLong()方法将其解释为指定基数的长 整型值，则返回true。
hasNextShort() - Method in class java.util. Scanner
如果扫描仪的输入中的下一个标记可以使用 Scanner.nextShort()方法将其解释为默认基数中的一个短值，则返回true。
hasNextShort(int) - Method in class java.util. Scanner
如果此扫描仪输入中的下一个标记可以使用 Scanner.nextShort()方法解释为指定基数中的一个短值，则返回true。
hasPrevious() - Method in interface java.util. ListIterator
如果此列表迭代器在相反方向遍历列表时具有更多元素，则返回 true 。
hasPrimitives() - Method in class java.lang.invoke. MethodType
报告此类型是否包含原始参数或返回值。
hasPrivateAccess() - Method in class java.lang.invoke. MethodHandles.Lookup
如果此查找具有 PRIVATE访问权限，则返回 true 。
hasProperties() - Method in class javafx.scene.control. Tab
测试此选项卡是否具有属性。
hasProperties() - Method in class javafx.scene.control. TableColumnBase
测试此表列是否具有属性。
hasProperties() - Method in class javafx.scene.control. ToggleGroup
测试ToggleGroup是否具有属性。
hasProperties() - Method in class javafx.scene. Node
测试节点是否具有属性。
hasProperties() - Method in class javafx.scene. Scene
测试场景是否具有属性。
hasProperties() - Method in class javafx.stage. Window
测试窗口是否具有属性。
hasQueuedPredecessors() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
查询任何线程是否等待获取比当前线程更长的时间。
hasQueuedPredecessors() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
查询任何线程是否等待获取比当前线程更长的时间。
hasQueuedSubmissions() - Method in class java.util.concurrent. ForkJoinPool
如果有任何任务提交到此池尚未开始执行，则返回 true 。
hasQueuedThread(Thread) - Method in class java.util.concurrent.locks. ReentrantLock
查询给定线程是否等待获取此锁。
hasQueuedThread(Thread) - Method in class java.util.concurrent.locks. ReentrantReadWriteLock
查询给定线程是否等待获取读取或写入锁定。
hasQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
查询任何线程是否等待获取。
hasQueuedThreads() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
查询任何线程是否等待获取。
hasQueuedThreads() - Method in class java.util.concurrent.locks. ReentrantLock
查询是否有线程正在等待获取此锁。
hasQueuedThreads() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock
查询是否有任何线程正在等待获取读取或写入锁定。
hasQueuedThreads() - Method in class java.util.concurrent. Semaphore
查询任何线程是否等待获取。
hasRaster() - Method in class javax.imageio. IIOImage
退货 true如果这 IIOImage存储 Raster而不是 RenderedImage 。
hasRelation(String) - Method in class javax.management.relation. RelationService
检查在关系服务中是否存在与给定关系ID相关联的关系。
hasRelation(String) - Method in interface javax.management.relation. RelationServiceMBean
检查在关系服务中是否存在与给定关系ID相关联的关系。
hasRemaining() - Method in class java.nio. Buffer
告诉当前位置和极限之间是否存在任何元素。
hasRtf() - Method in class javafx.scene.input. Clipboard
获取RTF字符串（DataFormat.RTF）是否已在此剪贴板上注册。
hasRtf() - Method in class javafx.scene.input. ClipboardContent
获取RTF字符串（ DataFormat.RTF ）是否已被放入此 ClipboardContent 。
hasSameRules(TimeZone) - Method in class java.util. SimpleTimeZone
如果此区域与其他区域具有相同的规则和偏移量，则返回 true 。
hasSameRules(TimeZone) - Method in class java.util. TimeZone
如果此区域具有与其他区域相同的规则和偏移量，则返回true。
hasService(Class<?>) - Method in interface java.beans.beancontext. BeanContextServices
报告当前是否可以从此上下文获得给定的服务。
hasService(Class<?>) - Method in class java.beans.beancontext. BeanContextServicesSupport
有一个可以委派的服务
hasSlot(int) - Method in class jdk.nashorn.api.scripting. AbstractJSObject
hasSlot(int) - Method in interface jdk.nashorn.api.scripting. JSObject
该对象是否具有索引属性？
hasSlot(int) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
hasStatus() - Method in class javafx.scene.web. PopupFeatures
返回状态栏是否应该存在。
hasString() - Method in class javafx.scene.input. Clipboard
获取是否在此剪贴板上注册了纯文本String（DataFormat.PLAIN_TEXT）。
hasString() - Method in class javafx.scene.input. ClipboardContent
获取纯文本字符串（ DataFormat.PLAIN_TEXT ）是否已被放入此 ClipboardContent 。
hasSubscribers() - Method in class java.util.concurrent. SubmissionPublisher
如果此发布者有任何订阅者，则返回true。
hasText() - Method in class javax.xml.stream.util. StreamReaderDelegate
hasText() - Method in interface javax.xml.stream. XMLStreamReader
返回一个布尔值，指示当前事件是否具有文本。
hasThumbnails(int) - Method in class javax.imageio. ImageReader
如果给定的图像具有与其相关联的缩略图预览图像，则返回 true 。
hasTileWriters() - Method in class java.awt.image. BufferedImage
返回是否检出任何图块以进行写入。
hasTileWriters() - Method in interface java.awt.image. WritableRenderedImage
返回是否签出任何图块以进行写入。
hasToolbar() - Method in class javafx.scene.web. PopupFeatures
返回是否存在工具栏。
hasTransparentBounds() - Method in class java.util.regex. Matcher
查询此匹配器的区域边界的透明度。
hasUniformLineMetrics() - Method in class java.awt. Font
检查此 Font是否具有统一的线路度量。
hasUniformLineMetrics() - Method in class java.awt. FontMetrics
检查 Font是否具有统一的线度量。
hasUnsupportedCriticalExtension() - Method in interface java.security.cert. X509Extension
检查是否有不支持的关键扩展。
hasUrl() - Method in class javafx.scene.input. Clipboard
获取是否在此剪贴板上注册了一个url String（DataFormat.URL）。
hasUrl() - Method in class javafx.scene.input. ClipboardContent
获取URL字符串（ DataFormat.URL ）是否已被放置到此 ClipboardContent 。
hasValue() - Method in enum jdk.jshell. Snippet.SubKind
指示这个 SubKind是否可执行，而不是 void 。
hasValueNames() - Method in class javax.imageio.plugins.tiff. TIFFTag
如果存在与该标签相关联的数据的合法值集合的助记名称，则返回 true 。
hasWaiters() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject
查询是否有线程正在等待这种情况。
hasWaiters() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject
查询是否有线程正在等待这种情况。
hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
查询任何线程是否等待与此同步器相关联的给定条件。
hasWaiters(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
查询任何线程是否等待与此同步器相关联的给定条件。
hasWaiters(Condition) - Method in class java.util.concurrent.locks. ReentrantLock
查询任何线程是否等待与此锁相关联的给定条件。
hasWaiters(Condition) - Method in class java.util.concurrent.locks. ReentrantReadWriteLock
查询任何线程是否等待与写锁相关联的给定条件。
hasWaitingConsumer() - Method in class java.util.concurrent. LinkedTransferQueue
hasWaitingConsumer() - Method in interface java.util.concurrent. TransferQueue
返回 true ，如果有至少一个消费者等待经由以接收元件 BlockingQueue.take()或定时 poll 。
hasWrappers() - Method in class java.lang.invoke. MethodType
报告此类型是否包含包装器参数或返回值。
HATRAN - java.lang. Character.UnicodeScript
Unicode脚本“Hatran”。
HATRAN - Static variable in class java.lang. Character.UnicodeBlock
“Hatran”Unicode字符块的常量。
hbarPolicyProperty() - Method in class javafx.scene.control. ScrollPane
指定显示水平滚动条的策略。
HBox - Class in javafx.scene.layout
HBox将孩子放在一排水平排列中。
HBox() - Constructor for class javafx.scene.layout. HBox
创建一个间距= 0的HBox布局。
HBox(double) - Constructor for class javafx.scene.layout. HBox
创建一个具有指定间隔的HBox布局。
HBox(double, Node...) - Constructor for class javafx.scene.layout. HBox
创建一个具有指定间隔的HBox布局。
HBox(Node...) - Constructor for class javafx.scene.layout. HBox
创建一个间距= 0的HBox布局。
head - Variable in class javax.swing.text.html.parser. DTD
元素对应头。
HEAD - Static variable in class javax.swing.text.html. HTML.Tag
标记<head>
header - Variable in class javax.swing.plaf.basic. BasicTableHeaderUI
将绘画委托给此UI的 JTableHeader 。
header(String, String) - Method in class jdk.incubator.http. HttpRequest.Builder
将给定的名称值对添加到此请求的头文件集中。
header(String, String) - Method in interface jdk.incubator.http. WebSocket.Builder
将给定的名称 - 值对添加到开启握手的附加标题列表中。
HEADER - javafx.scene. AccessibleAttribute
返回节点的头。
HEADER - Static variable in class javax.accessibility. AccessibleRole
文字标题
HEADER_RENDERER_PROPERTY - Static variable in class javax.swing.table. TableColumn
作为Java 2平台v1.3的过时。
HEADER_ROW - Static variable in class javax.swing.event. TableModelEvent
标识标题行。
HEADER_VALUE_PROPERTY - Static variable in class javax.swing.table. TableColumn
作为Java 2平台v1.3的过时。
headerProperty() - Method in class javafx.scene.control. DialogPane
表示对话框窗格的标题区域的属性。
headerRenderer - Variable in class javax.swing.table. TableColumn
渲染器用于绘制列的标题。
headers() - Method in class jdk.incubator.http. HttpRequest
此请求（或将要）发送的（用户可访问的）请求标头。
headers() - Method in class jdk.incubator.http. HttpResponse
返回接收到的响应头。
headers(String...) - Method in class jdk.incubator.http. HttpRequest.Builder
将给定的名称值对添加到此请求的标题集。
Headers - Class in com.sun.net.httpserver
HTTP请求和响应头通过此类，它实现接口表示Map < String ， List < String >>。
Headers() - Constructor for class com.sun.net.httpserver. Headers
headerTextProperty() - Method in class javafx.scene.control. Dialog
表示对话框窗格的标题文本的属性。
headerTextProperty() - Method in class javafx.scene.control. DialogPane
表示对话框窗格的标题文本的属性。
headerValue - Variable in class javax.swing.table. TableColumn
列的标题值。
HeadlessException - Exception in java.awt
在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
HeadlessException() - Constructor for exception java.awt. HeadlessException
构造新的 HeadlessException与空消息。
HeadlessException(String) - Constructor for exception java.awt. HeadlessException
使用指定的详细错误消息创建一个新实例。
headMap(K) - Method in interface java.util.concurrent. ConcurrentNavigableMap
headMap(K) - Method in class java.util.concurrent. ConcurrentSkipListMap
headMap(K) - Method in interface java.util. NavigableMap
返回此地图部分的视图，其密钥严格小于 toKey 。
headMap(K) - Method in interface java.util. SortedMap
返回此地图部分的视图，其密钥严格小于 toKey 。
headMap(K) - Method in class java.util. TreeMap
headMap(K, boolean) - Method in interface java.util.concurrent. ConcurrentNavigableMap
headMap(K, boolean) - Method in class java.util.concurrent. ConcurrentSkipListMap
headMap(K, boolean) - Method in interface java.util. NavigableMap
返回此地图部分的视图，其键值小于（或等于，如果 inclusive为真） toKey 。
headMap(K, boolean) - Method in class java.util. TreeMap
HEADPHONE - Static variable in class javax.sound.sampled. Port.Info
一种将音频发送到耳机插孔的端口。
headSet(E) - Method in class java.util.concurrent. ConcurrentSkipListSet
headSet(E) - Method in interface java.util. NavigableSet
返回该集合的部分视图，其元素严格小于 toElement 。
headSet(E) - Method in interface java.util. SortedSet
返回此集合的部分的视图，其元素严格小于 toElement 。
headSet(E) - Method in class java.util. TreeSet
headSet(E, boolean) - Method in class java.util.concurrent. ConcurrentSkipListSet
headSet(E, boolean) - Method in interface java.util. NavigableSet
返回该集合的部分的视图，该部分的元素小于（或等于，如果 inclusive为true） toElement 。
headSet(E, boolean) - Method in class java.util. TreeSet
HEAP - java.lang.management. MemoryType
堆内存类型。
heavyWeightPopupEnabled - Variable in class javax.swing. ToolTipManager
重量级弹出窗口启用。
HEBREW - java.lang. Character.UnicodeScript
Unicode脚本“希伯来语”。
HEBREW - Static variable in class java.lang. Character.UnicodeBlock
“希伯来语”Unicode字符块的常量。
height - Variable in class java.awt. Component.BltBufferStrategy
后缓冲器的高度
height - Variable in class java.awt. Dimension
高度尺寸 可以使用负值。
height - Variable in class java.awt.geom. Arc2D.Double
整个椭圆的整体高度，其圆弧为部分剖面（不考虑角度范围）。
height - Variable in class java.awt.geom. Arc2D.Float
整个椭圆的整体高度，其圆弧为部分剖面（不考虑角度范围）。
height - Variable in class java.awt.geom. Ellipse2D.Double
整体高度为 Ellipse2D 。
height - Variable in class java.awt.geom. Ellipse2D.Float
这个 Ellipse2D的整体高度。
height - Variable in class java.awt.geom. Rectangle2D.Double
这个高度 Rectangle2D 。
height - Variable in class java.awt.geom. Rectangle2D.Float
这个高度 Rectangle2D 。
height - Variable in class java.awt.geom. RoundRectangle2D.Double
这个高度 RoundRectangle2D 。
height - Variable in class java.awt.geom. RoundRectangle2D.Float
这个高度 RoundRectangle2D 。
height - Variable in class java.awt.image. Raster
这个光栅的高度。
height - Variable in class java.awt.image. SampleModel
该SampleModel描述的图像数据区域的像素高度。
height - Variable in class java.awt. Rectangle
Rectangle的高度。
height(Component) - Static method in class javax.swing. Spring
返回一个弹簧，其 最小值 ， 首选 值 ， 最大值和 值属性由所提供组件的 minimumSize ， preferredSize ， maximumSize和 size属性的高度定义。
HEIGHT - Static variable in interface java.awt.image. ImageObserver
imageUpdate的infoflags参数中的此标志表示基本图像的高度现在可用，可以从imageUpdate回调方法的height参数中获取。
HEIGHT - Static variable in class javax.swing. SpringLayout
指定组件的边界矩形的高度。
HEIGHT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“height”。
HEIGHT - Static variable in class javax.swing.text.html. HTML.Attribute
属性“height”
heightProperty() - Method in class javafx.scene.canvas. Canvas
定义画布的高度。
heightProperty() - Method in class javafx.scene.control. Dialog
表示对话框高度的属性。
heightProperty() - Method in class javafx.scene.effect. BoxBlur
模糊效果的垂直尺寸。
heightProperty() - Method in class javafx.scene.effect. ColorInput
相对于内容 Node的局部坐标空间设置要淹没区域的高度。
heightProperty() - Method in class javafx.scene.effect. DropShadow
阴影模糊内核的垂直尺寸。
heightProperty() - Method in class javafx.scene.effect. FloatMap
地图的高度，以像素为单位。
heightProperty() - Method in class javafx.scene.effect. InnerShadow
阴影模糊内核的垂直尺寸。
heightProperty() - Method in class javafx.scene.effect. Shadow
阴影模糊内核的垂直尺寸。
heightProperty() - Method in class javafx.scene.image. Image
图像高度或 0如果图像加载失败。
heightProperty() - Method in class javafx.scene.layout. Region
这个可调节大小的节点的高度。
heightProperty() - Method in class javafx.scene.media. Media
源媒体的像素高度。
heightProperty() - Method in class javafx.scene. Scene
这个高度 Scene
heightProperty() - Method in class javafx.scene.shape. Box
定义Box的高度或Y尺寸。
heightProperty() - Method in class javafx.scene.shape. Cylinder
定义气缸的高度或Y尺寸。
heightProperty() - Method in class javafx.scene.shape. Rectangle
定义矩形的高度。
heightProperty() - Method in class javafx.scene. SubScene
定义这个 SubScene的高度
heightProperty() - Method in class javafx.scene.web. WebView
身高 WebView 。
heightProperty() - Method in class javafx.stage. Window
这个高度 Window 。
HEISEI - Static variable in class java.time.chrono. JapaneseEra
“平成”时代的单身例子（1989-01-08 - 现在），价值2。
HELP - javafx.scene. AccessibleAttribute
返回节点的帮助文本。
HELP - javafx.scene.control. ButtonBar.ButtonData
通常应该在右侧的“帮助”按钮的标签。
HELP - javafx.scene.input. KeyCode
常数为 帮助键。
HELP_2 - javafx.scene.control. ButtonBar.ButtonData
“help2”按钮的标签通常应在左侧。
helpButtonMnemonic - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
帮助按钮助记符
helpButtonText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
帮助按钮文字
helpButtonToolTipText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
帮助按钮工具提示文本
helpComplete(int) - Method in class java.util.concurrent. CountedCompleter
如果此任务尚未完成，则尝试至少处理此任务在完成路径上的给定数量的其他未处理任务（如果有）。
helpQuiesce() - Static method in class java.util.concurrent. ForkJoinTask
可能执行任务，直到托管当前任务的池 is quiescent 。
HexBinaryAdapter - Class in javax.xml.bind.annotation.adapters
XmlAdapter，适用于xs:hexBinary 。
HexBinaryAdapter() - Constructor for class javax.xml.bind.annotation.adapters. HexBinaryAdapter
hgapProperty() - Method in class javafx.scene.layout. FlowPane
水平流图中每个节点之间的水平空间量或垂直流动叶片中的列间空间量。
hgapProperty() - Method in class javafx.scene.layout. GridPane
列之间的水平间隙的宽度。
hgapProperty() - Method in class javafx.scene.layout. TilePane
一行中每个图块之间的水平空间量。
hgrowProperty() - Method in class javafx.scene.layout. ColumnConstraints
该列的横向增长优先级。
HIDDEN - com.sun.source.doctree. DocTree.Kind
用于实例HiddenTree表示@hidden标签。
HiddenAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.HiddenAction
hiddenDivider - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
用于非连续布局模式的分隔线。
HiddenTree - Interface in com.sun.source.doctree
@hidden块标记的树节点。
hide() - Method in class java.awt. Component
已过时。
自JDK 1.1版起，由setVisible(boolean)取代。
hide() - Method in class java.awt. Dialog
已过时。
从JDK版本1.5开始，由setVisible(boolean)替代。
hide() - Method in class java.awt. Window
已过时。
从JDK版本1.5开始，由Window.setVisible(boolean)代替。
hide() - Method in class javafx.scene.control. ChoiceBox
关闭选择列表。
hide() - Method in class javafx.scene.control. ComboBoxBase
关闭 ComboBoxBase.show()被调用时显示的弹出/对话框。
hide() - Method in class javafx.scene.control. ContextMenu
隐藏这个 ContextMenu和任何可见的子菜单，假设当这个函数被调用时显示 ContextMenu 。
hide() - Method in class javafx.scene.control. Dialog
隐藏这 Dialog 。
hide() - Method in class javafx.scene.control. Menu
隐藏ContextMenu如果以前显示，和任何显示子菜单。
hide() - Method in class javafx.scene.control. MenuButton
隐藏ContextMenu 。
hide() - Method in class javafx.scene.control.skin. ComboBoxBaseSkin
当隐藏ComboBox弹出窗口时，将调用此方法。
hide() - Method in class javafx.scene.control.skin. ComboBoxPopupControl
当隐藏ComboBox弹出窗口时，将调用此方法。
hide() - Method in class javafx.stage. PopupWindow
隐藏此弹出窗口及其所有子项
hide() - Method in class javafx.stage. Window
尝试通过将可见性设置为false来隐藏此窗口。
hide() - Method in class javax.swing. JComponent
已过时。
hide() - Method in class javax.swing. JInternalFrame
hide() - Method in class javax.swing.plaf.basic. BasicComboPopup
实现ComboPopup.hide（）。
hide() - Method in interface javax.swing.plaf.basic. ComboPopup
隐藏弹出窗口
hide() - Method in class javax.swing. Popup
隐藏和处置的 Popup 。
HIDE_ON_CLOSE - Static variable in interface javax.swing. WindowConstants
隐藏窗口默认窗口关闭操作
hideDelayProperty() - Method in class javafx.scene.control. Tooltip
在鼠标离开节点后继续显示工具提示的持续时间。
hideOnClickProperty() - Method in class javafx.scene.control. CustomMenuItem
如果为真，则在单击此菜单项时，将隐藏此菜单项和所有可见菜单。
hideOnClickProperty() - Method in class javafx.scene.control.skin. ComboBoxListViewSkin
默认情况下，只要点击ListView，该皮肤就会隐藏弹出窗口。
hideOnEscapeProperty() - Method in class javafx.stage. PopupWindow
指定在弹出对焦时按下未处理的转义键时是否应该隐藏PopupWindow。
hidePopup() - Method in class javax.swing. JComboBox
导致组合框关闭其弹出窗口。
hideProgressBar() - Method in interface javax.jnlp. ExtensionInstallerService
隐藏进度条。
hides(Element, Element) - Method in interface javax.lang.model.util. Elements
测试一种类型，方法或字段是否隐藏另一种。
hideStatusWindow() - Method in interface javax.jnlp. ExtensionInstallerService
隐藏状态窗口。
hideWindows() - Method in interface java.awt.im.spi. InputMethod
关闭或隐藏由此输入法实例或其类打开的所有窗口。
HIERARCHY_BOUNDS_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择层次结构事件的事件掩码。
HIERARCHY_CHANGED - Static variable in class java.awt.event. HierarchyEvent
事件id表示对整个层次结构树进行了修改。
HIERARCHY_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择层次结构事件的事件掩码。
HIERARCHY_FIRST - Static variable in class java.awt.event. HierarchyEvent
标记层次结构事件ID范围的第一个整数ID。
HIERARCHY_LAST - Static variable in class java.awt.event. HierarchyEvent
标记祖先事件ID的范围的最后一个整数ID。
HIERARCHY_REQUEST_ERR - Static variable in exception org.w3c.dom. DOMException
如果任何 Node插入到某处，它不属于。
HierarchyBoundsAdapter - Class in java.awt.event
用于接收祖先移动和调整大小的事件的抽象适配器类。
HierarchyBoundsAdapter() - Constructor for class java.awt.event. HierarchyBoundsAdapter
HierarchyBoundsListener - Interface in java.awt.event
用于接收祖先移动和调整大小的事件的侦听器接口。
hierarchyChanged(HierarchyEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的hierarchyChanged方法来处理hierarchyChanged事件。
hierarchyChanged(HierarchyEvent) - Method in interface java.awt.event. HierarchyListener
当层次结构被更改时调用。
HierarchyEvent - Class in java.awt.event
指示 Component属于 Component层次结构的更改的事件。
HierarchyEvent(Component, int, Component, Container) - Constructor for class java.awt.event. HierarchyEvent
构造一个 HierarchyEvent对象，以标识 Component层次结构中的更改。
HierarchyEvent(Component, int, Component, Container, long) - Constructor for class java.awt.event. HierarchyEvent
构造一个 HierarchyEvent对象，以标识 Component层次结构中的更改。
HierarchyListener - Interface in java.awt.event
用于接收层次结构的侦听器界面更改事件。
HIGH - javafx.print. PrintQuality
指定高质量打印。
HIGH - Static variable in class java.awt. PageAttributes.PrintQualityType
PrintQualityType实例用于指定高打印质量。
HIGH - Static variable in class javax.print.attribute.standard. PrintQuality
打印机最高质量可用。
HIGH_PRIORITY - Static variable in class jdk.net. SocketFlow
HIGH_PRIVATE_USE_SURROGATES - Static variable in class java.lang. Character.UnicodeBlock
“高私人使用代理”Unicode字符块的常量。
HIGH_SURROGATES - Static variable in class java.lang. Character.UnicodeBlock
常数为“高代理”Unicode字符块。
higher(E) - Method in class java.util.concurrent. ConcurrentSkipListSet
higher(E) - Method in interface java.util. NavigableSet
返回此集中的最小元素严格大于给定元素，如果没有此元素，则 null 。
higher(E) - Method in class java.util. TreeSet
higherEntry(K) - Method in class java.util.concurrent. ConcurrentSkipListMap
返回与最小密钥相关联的密钥值映射严格大于给定密钥，如果没有这样的密钥，则 null 。
higherEntry(K) - Method in interface java.util. NavigableMap
返回与最小键相关联的键值映射严格大于给定的键，如果没有这样的键，则 null 。
higherEntry(K) - Method in class java.util. TreeMap
higherKey(K) - Method in class java.util.concurrent. ConcurrentSkipListMap
higherKey(K) - Method in interface java.util. NavigableMap
返回严格大于给定键的最小键，如果没有这样的键，则返回 null 。
higherKey(K) - Method in class java.util. TreeMap
highestLayer() - Method in class javax.swing. JLayeredPane
返回所有当前子节点的最高层值。
highestOneBit(int) - Static method in class java.lang. Integer
在指定的 int值中，最高位（最左边）为1位，最多 int返回一个 int值。
highestOneBit(long) - Static method in class java.lang. Long
在指定的 long值中，最高位（最左侧）为1位，最多 long返回一个 long值。
highlight - Variable in class javax.swing.border. EtchedBorder
用于蚀刻高亮的颜色。
highlight - Variable in class javax.swing.plaf.basic. BasicBorders.ButtonBorder
亮点的颜色。
highlight - Variable in class javax.swing.plaf.basic. BasicBorders.FieldBorder
亮点的颜色。
highlight - Variable in class javax.swing.plaf.basic. BasicBorders.SplitPaneBorder
亮点的颜色
highlight - Variable in class javax.swing.plaf.basic. BasicSeparatorUI
突出显示的颜色。
highlight - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
突出显示颜色
highlightColor - Static variable in class javax.swing.plaf.metal. MetalSliderUI
突出的颜色。
Highlighter - Interface in javax.swing.text
用于允许用彩色区域标记背景的对象的界面。
Highlighter.Highlight - Interface in javax.swing.text
亮点
Highlighter.HighlightPainter - Interface in javax.swing.text
突出显示渲染器。
highlightFillProperty() - Method in class javafx.scene.control.skin. TextInputControlSkin
突出显示时用于文本的填充。
highlightInner - Variable in class javax.swing.border. BevelBorder
用于斜面内部高光的颜色。
highlightOuter - Variable in class javax.swing.border. BevelBorder
用于斜面外部高光的颜色。
highlightTextFillProperty() - Method in class javafx.scene.control.skin. TextInputControlSkin
highSurrogate(int) - Static method in class java.lang. Character
返回主导替代（一个 high surrogate code unit所述的） surrogate pair表示在UTF-16编码指定的补充的字符（Unicode代码点）。
HijrahChronology - Class in java.time.chrono
Hijrah日历是支持伊斯兰教日历的农历。
HijrahDate - Class in java.time.chrono
日期在Hijrah日历系统。
HijrahEra - Enum in java.time.chrono
Hijrah日历系统中的一个时代。
HINTS_OBSERVED - Static variable in interface java.awt.image.renderable. RenderableImage
可以用于标识通过createRendering或createScaledRendering方法获得的RenderedImage上的属性的字符串常量。
HIRAGANA - java.lang. Character.UnicodeScript
Unicode脚本“平假名”。
HIRAGANA - javafx.scene.input. KeyCode
平假名功能键的常数。
HIRAGANA - Static variable in class java.lang. Character.UnicodeBlock
“Hiragana”Unicode字符块的常量。
hit(Rectangle, Shape, boolean) - Method in class java.awt. Graphics2D
检查指定的Shape是否与设备空间中指定的Shape相交。
hitClip(int, int, int, int) - Method in class java.awt. Graphics
如果指定的矩形区域可能与当前裁剪区域相交，则返回true。
hitEnd() - Method in class java.util.regex. Matcher
如果在匹配器执行的最后一次匹配操作中输入的结尾被搜索引擎命中，则返回true。
HitInfo - Class in javafx.scene.text
表示文本节点中的命中信息。
hitTest(Point2D) - Method in class javafx.scene.text. Text
将本地点映射到内容中的索引。
hitTest(Point2D) - Method in class javafx.scene.text. TextFlow
将本地点映射到内容中的索引。
hitTestChar(float, float) - Method in class java.awt.font. TextLayout
返回对应于指定点的 TextHitInfo 。
hitTestChar(float, float, Rectangle2D) - Method in class java.awt.font. TextLayout
返回对应于指定点的 TextHitInfo 。
hitToPoint(TextHitInfo, Point2D) - Method in class java.awt.font. TextLayout
将命中转换为标准坐标中的一个点。
HLineTo - Class in javafx.scene.shape
创建从当前点到x的水平线路元素。
HLineTo() - Constructor for class javafx.scene.shape. HLineTo
创建一个空的HLineTo实例。
HLineTo(double) - Constructor for class javafx.scene.shape. HLineTo
创建一个HLineTo的实例。
HMAC_SHA1 - Static variable in interface javax.xml.crypto.dsig. SignatureMethod
HMAC-SHA1 MAC签名方法算法URI
HMACParameterSpec - Class in javax.xml.crypto.dsig.spec
参数为 XML Signature HMAC Algorithm 。
HMACParameterSpec(int) - Constructor for class javax.xml.crypto.dsig.spec. HMACParameterSpec
创建具有指定截断长度的 HMACParameterSpec 。
hmaxProperty() - Method in class javafx.scene.control. ScrollPane
此ScrollPane的最大允许 数为 hvalue 。
hminProperty() - Method in class javafx.scene.control. ScrollPane
该ScrollPane的最小允许 值为hvalue 。
HOLD_CURSORS_OVER_COMMIT - Static variable in interface java.sql. ResultSet
这表明开放的不断 ResultSet当前事务时承诺的对象具有此可保存性将继续开放。
hold_requests(boolean) - Method in interface org.omg.PortableServer. POAManagerOperations
该操作将POA管理器的状态改变为保持状态，导致相关的POA排队传入的请求。
holder() - Method in interface com.sun.javadoc. Tag
已过时。
返回此Tag元素的包含Doc 。
Holder< T> - Class in javax.xml.ws
持有值类型 T 。
Holder() - Constructor for class javax.xml.ws. Holder
创建一个新的持有人，价值 null 。
Holder(T) - Constructor for class javax.xml.ws. Holder
创建一个具有指定值的新持有者。
HOLDING - Interface in org.omg.PortableInterceptor
org / omg / PortableInterceptor / HOLDING.java。
HOLDING - Static variable in class org.omg.PortableServer.POAManagerPackage. State
holdsLock(Object) - Static method in class java.lang. Thread
返回 true当且仅当当前线程保存指定对象上的监视器锁定。
home() - Method in class javafx.scene.control. TextInputControl
将插入符移动到文本的第一个字符之前。
HOME - javafx.scene.input. KeyCode
常数为 Home键。
HOME - Static variable in class java.awt. Event
已过时。
主键，非ASCII动作键。
homeFolderIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
主文件夹图标
homeKey - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
HONEYDEW - Static variable in class javafx.scene.paint. Color
彩色蜜汁，RGB值为＃F0FFF0
HONOR_DISPLAY_PROPERTIES - Static variable in class javax.swing. JEditorPane
客户端属性的键用于指示如果在样式文本中未指定字体或前景颜色，则会使用来自组件的默认字体和前景颜色。
HORIZONTAL - javafx.geometry. Orientation
横向（右< - >左）方向
HORIZONTAL - Static variable in interface java.awt. Adjustable
表示 Adjustable具有水平方向。
HORIZONTAL - Static variable in class java.awt. GridBagConstraints
调整组件水平但不垂直。
HORIZONTAL - Static variable in class java.awt. Scrollbar
一个常量，表示水平滚动条。
HORIZONTAL - Static variable in class javax.accessibility. AccessibleState
表示此对象的方向是水平的。
HORIZONTAL - Static variable in interface javax.swing. SwingConstants
水平方向。
HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按钮的水平对齐方式的变化。
HORIZONTAL_CENTER - Static variable in class javax.swing. SpringLayout
指定组件边界矩形的水平中心。
HORIZONTAL_SCROLLBAR - javafx.scene. AccessibleAttribute
返回节点的水平滚动条。
HORIZONTAL_SCROLLBAR - Static variable in interface javax.swing. ScrollPaneConstants
标识一个水平滚动条。
HORIZONTAL_SCROLLBAR_ALWAYS - Static variable in interface javax.swing. ScrollPaneConstants
用于设置水平滚动条策略，以便始终显示水平滚动条。
HORIZONTAL_SCROLLBAR_AS_NEEDED - Static variable in interface javax.swing. ScrollPaneConstants
用于设置水平滚动条策略，以便仅在需要时才显示水平滚动条。
HORIZONTAL_SCROLLBAR_NEVER - Static variable in interface javax.swing. ScrollPaneConstants
用于设置水平滚动条策略，从而不会显示水平滚动条。
HORIZONTAL_SCROLLBAR_POLICY - Static variable in interface javax.swing. ScrollPaneConstants
标识水平滚动条策略属性。
HORIZONTAL_SPLIT - Static variable in class javax.swing. JSplitPane
水平分割表示 Component s沿x轴分割。
HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按钮的水平文本位置的变化。
HORIZONTAL_WRAP - Static variable in class javax.swing. JList
表示“报纸风格”布局，单元格水平方向垂直。
HorizontalDirection - Enum in javafx.geometry
表示水平方向的枚举。
horizontalGridLinesVisibleProperty() - Method in class javafx.scene.chart. XYChart
如果水平网格线应绘制，则为真
horizontalScrollBar - Variable in class javax.swing. JScrollPane
滚动盘的水平滚动条小孩。
horizontalScrollBarPolicy - Variable in class javax.swing. JScrollPane
水平滚动条的显示策略。
horizontalZeroLineVisibleProperty() - Method in class javafx.scene.chart. XYChart
如果这是真的并且横轴具有正值和负值，则在零点处将绘制另外的轴线
horizThumbIcon - Static variable in class javax.swing.plaf.metal. MetalSliderUI
默认的水平拇指 Icon 。
hostEncoding - Static variable in class javax.print. DocFlavor
代表主机操作系统编码的字符串。
hostnameVerifier - Variable in class javax.net.ssl. HttpsURLConnection
这个对象的 hostnameVerifier 。
HostnameVerifier - Interface in javax.net.ssl
此类是主机名验证的基本界面。
hostsEqual(URL, URL) - Method in class java.net. URLStreamHandler
比较两个URL的主机组件。
HostServices - Class in javafx.application
此类为应用程序提供HostServices。
HOTPINK - Static variable in class javafx.scene.paint. Color
颜色热粉红色，RGB值为＃FF69B4
HotSpotDiagnosticMXBean - Interface in com.sun.management
HotSpot虚拟机的诊断管理界面。
hotspotXProperty() - Method in class javafx.scene. ImageCursor
光标热点的X坐标。
hotspotYProperty() - Method in class javafx.scene. ImageCursor
光标热点的Y坐标。
HOUR - Static variable in class java.util. Calendar
字段编号为 get和 set表示上午或下午的小时。
HOUR_OF_AMPM - java.time.temporal. ChronoField
上午的小时。
HOUR_OF_DAY - java.time.temporal. ChronoField
一天的时间
HOUR_OF_DAY - Static variable in class java.util. Calendar
字段编号为 get和 set表示当天的小时数。
HOUR_OF_DAY0 - Static variable in class java.text. DateFormat.Field
常数确定小时的字段，其中合法值为0到23。
HOUR_OF_DAY0_FIELD - Static variable in class java.text. DateFormat
基于零的HOUR_OF_DAY字段对齐的常用常数。
HOUR_OF_DAY1 - Static variable in class java.text. DateFormat.Field
常数确定时间字段，法定值为1到24。
HOUR_OF_DAY1_FIELD - Static variable in class java.text. DateFormat
基于一个HOUR_OF_DAY字段对齐的常用常数。
HOUR0 - Static variable in class java.text. DateFormat.Field
常数标识小时字段，合法值为0到11。
HOUR0_FIELD - Static variable in class java.text. DateFormat
基于零的HOUR场对齐的有用常数。
HOUR1 - Static variable in class java.text. DateFormat.Field
常数标识小时字段，合法值为1到12。
HOUR1_FIELD - Static variable in class java.text. DateFormat
基于一个HOUR字段对齐的常用常数。
hours(double) - Static method in class javafx.util. Duration
返回一个表示指定小时数的Duration实例的Factory方法。
HOURS - java.time.temporal. ChronoUnit
代表一小时概念的单位。
HOURS - java.util.concurrent. TimeUnit
时间单位代表六十分钟。
HOURS - Static variable in class javax.xml.datatype. DatatypeConstants
表示小时字段的常数。
hoverProperty() - Method in class javafx.scene. Node
这个 Node是否被徘徊。
HPos - Enum in javafx.geometry
用于描述水平定位和对齐的一组值。
HR - Static variable in class javax.swing.text.html. HTML.Tag
标签<hr>
HREF - Static variable in class javax.swing.text.html. HTML.Attribute
属性“href”
hsb - Variable in class javax.swing. ScrollPaneLayout
滚动盘的水平滚动条小孩。
hsb(double, double, double) - Static method in class javafx.scene.paint. Color
基于HSB颜色模型中指定的值创建不透明的 Color 。
hsb(double, double, double, double) - Static method in class javafx.scene.paint. Color
根据HSB颜色模型中的指定值和给定的不透明度创建 Color 。
hsbChangeListener - Variable in class javax.swing.plaf.basic. BasicScrollPaneUI
ChangeListener安装在水平滚动条上。
HSBChangeListener() - Constructor for class javax.swing.plaf.basic. BasicScrollPaneUI.HSBChangeListener
hsbPolicy - Variable in class javax.swing. ScrollPaneLayout
水平滚动条的显示策略。
HSBtoRGB(float, float, float) - Static method in class java.awt. Color
将HSB模型指定的颜色组件转换为默认RGB模型的等效值。
HSPACE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“hspace”
html - Variable in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction
HTML插入。
html - Variable in class javax.swing.text.html.parser. DTD
元素对应于html。
HTML - Class in javax.swing.text.html
常数用于 HTMLDocument 。
HTML - javax.tools. JavaFileObject.Kind
HTML文件。
HTML - Static variable in class javafx.scene.input. DataFormat
表示HTML格式的字符串。
HTML - Static variable in class javax.swing.text.html. HTML.Tag
标签<html>
HTML() - Constructor for class javax.swing.text.html. HTML
HTML_CONTAINER - Static variable in class javax.accessibility. AccessibleRole
一个包含 Accessibles的集合的对象一起表示 HTML内容。
HTML.Attribute - Class in javax.swing.text.html
表示HTML属性的Typesafe枚举。
HTML.Tag - Class in javax.swing.text.html
HTML标签的类型安全枚举。
HTML.UnknownTag - Class in javax.swing.text.html
类代表未知的HTML标签。
HTMLAnchorElement - Interface in org.w3c.dom.html
锚点元素。
HTMLAppletElement - Interface in org.w3c.dom.html
嵌入式Java小程序。
HTMLAreaElement - Interface in org.w3c.dom.html
客户端图像映射区域定义。
HTMLBaseElement - Interface in org.w3c.dom.html
文件库URI。
HTMLBaseFontElement - Interface in org.w3c.dom.html
基本字体。
HTMLBodyElement - Interface in org.w3c.dom.html
HTML文档正文。
HTMLBRElement - Interface in org.w3c.dom.html
强制换行
HTMLButtonElement - Interface in org.w3c.dom.html
按钮。
HTMLCollection - Interface in org.w3c.dom.html
一个 HTMLCollection是节点列表。
HTMLDirectoryElement - Interface in org.w3c.dom.html
目录列表。
HTMLDivElement - Interface in org.w3c.dom.html
通用块容器。
HTMLDListElement - Interface in org.w3c.dom.html
定义清单
HTMLDocument - Class in javax.swing.text.html
建立HTML的文档。
HTMLDocument - Interface in org.w3c.dom.html
一个 HTMLDocument是HTML层次结构的根，并保存整个内容。
HTMLDocument() - Constructor for class javax.swing.text.html. HTMLDocument
使用默认缓冲区大小和默认值构建HTML文档 StyleSheet 。
HTMLDocument(AbstractDocument.Content, StyleSheet) - Constructor for class javax.swing.text.html. HTMLDocument
使用给定的内容存储实现和给定的样式/属性存储机制构造一个HTML文档。
HTMLDocument(StyleSheet) - Constructor for class javax.swing.text.html. HTMLDocument
构造具有默认内容存储实现和指定样式/属性存储机制的HTML文档。
HTMLDocument.BlockElement - Class in javax.swing.text.html
表示HTML的结构 块的元素。
HTMLDocument.HTMLReader - Class in javax.swing.text.html
HTML读取器，用于加载HTML元素结构的HTML文档。
HTMLDocument.HTMLReader.BlockAction - Class in javax.swing.text.html
默认情况下分配的操作来处理读取器的Block任务。
HTMLDocument.HTMLReader.CharacterAction - Class in javax.swing.text.html
默认分配的操作来处理读者的Character任务。
HTMLDocument.HTMLReader.FormAction - Class in javax.swing.text.html
通过构建用于表示表单控件的所有元素来支持表单的操作。
HTMLDocument.HTMLReader.HiddenAction - Class in javax.swing.text.html
默认分配的操作来处理读者的隐藏任务。
HTMLDocument.HTMLReader.IsindexAction - Class in javax.swing.text.html
默认情况下分配的操作来处理读取器的Isindex任务。
HTMLDocument.HTMLReader.ParagraphAction - Class in javax.swing.text.html
默认分配的操作来处理读者的Paragraph任务。
HTMLDocument.HTMLReader.PreAction - Class in javax.swing.text.html
默认情况下分配的操作来处理读卡器的Pre块任务。
HTMLDocument.HTMLReader.SpecialAction - Class in javax.swing.text.html
默认情况下分配的操作来处理读者的特殊任务。
HTMLDocument.HTMLReader.TagAction - Class in javax.swing.text.html
响应解析标签而执行的操作。
HTMLDocument.Iterator - Class in javax.swing.text.html
迭代器迭代特定类型的标签。
HTMLDocument.RunElement - Class in javax.swing.text.html
表示一组文本的元素，该文本块分配有一组HTML字符级属性。
HTMLDOMImplementation - Interface in org.w3c.dom.html
所述 HTMLDOMImplementation接口扩展了 DOMImplementation接口与用于创建HTML文档实例的方法。
HTMLEditor - Class in javafx.scene.web
允许用户编辑文本并将样式应用于此文本的控件。
HTMLEditor() - Constructor for class javafx.scene.web. HTMLEditor
创建HTMLEditor控件的新实例。
HTMLEditorKit - Class in javax.swing.text.html
Swing JEditorPane文本组件通过称为EditorKit的插件机制来支持不同类型的内容。
HTMLEditorKit() - Constructor for class javax.swing.text.html. HTMLEditorKit
构造一个HTMLEditorKit，创建一个StyleContext，并加载样式表。
HTMLEditorKit.HTMLFactory - Class in javax.swing.text.html
为HTML创建视图的工厂。
HTMLEditorKit.HTMLTextAction - Class in javax.swing.text.html
一个抽象的Action提供了一些方便的方法，可能有助于将HTML插入到现有文档中。
HTMLEditorKit.InsertHTMLTextAction - Class in javax.swing.text.html
InsertHTMLTextAction可用于将HTML的任意字符串插入到现有的HTML文档中。
HTMLEditorKit.LinkController - Class in javax.swing.text.html
在适当的时候，类可以观看相关组件并在其上触发超链接事件。
HTMLEditorKit.Parser - Class in javax.swing.text.html
接口由解析器支持。
HTMLEditorKit.ParserCallback - Class in javax.swing.text.html
解析的结果驱动这些回调方法。
HTMLEditorSkin - Class in javafx.scene.web
HTML编辑器皮肤。
HTMLEditorSkin(HTMLEditor) - Constructor for class javafx.scene.web. HTMLEditorSkin
创建一个新的HTMLEditorSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
HTMLEditorSkin.Command - Enum in javafx.scene.web
表示可以传递到HTMLEditor Web引擎的命令。
HTMLElement - Interface in org.w3c.dom.html
所有HTML元素接口派生自此类。
HTMLFactory() - Constructor for class javax.swing.text.html. HTMLEditorKit.HTMLFactory
HTMLFieldSetElement - Interface in org.w3c.dom.html
将表单控件组织成逻辑组。
HTMLFontElement - Interface in org.w3c.dom.html
本地更改为字体。
HTMLFormElement - Interface in org.w3c.dom.html
FORM元素包含与集合和元素相似的行为。
HTMLFrameElement - Interface in org.w3c.dom.html
创建一个框架。
HTMLFrameHyperlinkEvent - Class in javax.swing.text.html
HTMLFrameHyperlinkEvent用于通知相关方链接已在一帧中激活。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - Constructor for class javax.swing.text.html. HTMLFrameHyperlinkEvent
创建一个表示html框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, String) - Constructor for class javax.swing.text.html. HTMLFrameHyperlinkEvent
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, InputEvent, String) - Constructor for class javax.swing.text.html. HTMLFrameHyperlinkEvent
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, String) - Constructor for class javax.swing.text.html. HTMLFrameHyperlinkEvent
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, Element, String) - Constructor for class javax.swing.text.html. HTMLFrameHyperlinkEvent
创建一个表示超文本链接事件的新对象。
HTMLFrameSetElement - Interface in org.w3c.dom.html
创建一个网格的框架。
HTMLHeadElement - Interface in org.w3c.dom.html
文件头信息。
HTMLHeadingElement - Interface in org.w3c.dom.html
对于 H1到 H6元素。
HTMLHRElement - Interface in org.w3c.dom.html
创建一个水平规则。
HTMLHtmlElement - Interface in org.w3c.dom.html
HTML文档的根。
HTMLIFrameElement - Interface in org.w3c.dom.html
内联子窗口。
HTMLImageElement - Interface in org.w3c.dom.html
嵌入图像。
HTMLInputElement - Interface in org.w3c.dom.html
表格控制。
HTMLIsIndexElement - Interface in org.w3c.dom.html
此元素用于单行文本输入。
HTMLLabelElement - Interface in org.w3c.dom.html
表单字段标签文本。
HTMLLegendElement - Interface in org.w3c.dom.html
提供 FIELDSET分组的标题。
HTMLLIElement - Interface in org.w3c.dom.html
列表项。
HTMLLink(Element) - Constructor for class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
构造一个 HTMLLink 。
HTMLLinkElement - Interface in org.w3c.dom.html
LINK元素指定到外部资源的链接，并定义该文档与该资源的关系（反之亦然）。
HTMLMapElement - Interface in org.w3c.dom.html
客户端图像映射。
HTMLMenuElement - Interface in org.w3c.dom.html
菜单列表。
HTMLMetaElement - Interface in org.w3c.dom.html
这包含有关该文档的通用元信息。
HTMLModElement - Interface in org.w3c.dom.html
修改文件部分的通知。
HTMLObjectElement - Interface in org.w3c.dom.html
通用嵌入对象。
HTMLOListElement - Interface in org.w3c.dom.html
有序列表
HTMLOptGroupElement - Interface in org.w3c.dom.html
组合选项集合在逻辑细分。
HTMLOptionElement - Interface in org.w3c.dom.html
可选择的选择。
HTMLParagraphElement - Interface in org.w3c.dom.html
段落。
HTMLParamElement - Interface in org.w3c.dom.html
参数馈送到 OBJECT元素。
HTMLPreElement - Interface in org.w3c.dom.html
预格式文本。
HTMLQuoteElement - Interface in org.w3c.dom.html
对于 Q和 BLOCKQUOTE元素。
HTMLReader(int) - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader
使用默认的弹出和推送深度构建HTMLReader，并且不插入任何标签。
HTMLReader(int, int, int, HTML.Tag) - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader
构造一个HTMLReader。
HTMLScriptElement - Interface in org.w3c.dom.html
脚本语句。
HTMLSelectElement - Interface in org.w3c.dom.html
select元素允许选择一个选项。
HTMLStyleElement - Interface in org.w3c.dom.html
风格信息。
HTMLTableCaptionElement - Interface in org.w3c.dom.html
表格标题请参阅HTML 4.0中的CAPTION元素定义。
HTMLTableCellElement - Interface in org.w3c.dom.html
该对象用于表示 TH和 TD元素。
HTMLTableColElement - Interface in org.w3c.dom.html
重新分组 COL和 COLGROUP元素。
HTMLTableElement - Interface in org.w3c.dom.html
表上的create *和delete *方法允许作者构造和修改表。
HTMLTableRowElement - Interface in org.w3c.dom.html
一排在表中。
HTMLTableSectionElement - Interface in org.w3c.dom.html
该 THEAD ， TFOOT ，并 TBODY元素。
HTMLTextAction(String) - Constructor for class javax.swing.text.html. HTMLEditorKit.HTMLTextAction
从字符串操作名称创建一个新的HTMLTextAction。
HTMLTextAreaElement - Interface in org.w3c.dom.html
多行文本字段。
HTMLTitleElement - Interface in org.w3c.dom.html
文件标题。
HTMLUListElement - Interface in org.w3c.dom.html
无序列表。
HTMLWriter - Class in javax.swing.text.html
这是HTMLDocuments的作者。
HTMLWriter(Writer, HTMLDocument) - Constructor for class javax.swing.text.html. HTMLWriter
创建一个新的HTMLWriter。
HTMLWriter(Writer, HTMLDocument, int, int) - Constructor for class javax.swing.text.html. HTMLWriter
创建一个新的HTMLWriter。
HTTP - java.net. Proxy.Type
代表HTTP或FTP等高级协议的代理。
HTTP - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported
超文本传输协议（HTTP）。
HTTP_1_1 - jdk.incubator.http. HttpClient.Version
HTTP版本1.1
HTTP_2 - jdk.incubator.http. HttpClient.Version
HTTP版本2
HTTP_ACCEPTED - Static variable in class java.net. HttpURLConnection
HTTP状态码202：接受。
HTTP_BAD_GATEWAY - Static variable in class java.net. HttpURLConnection
HTTP状态码502：坏网关。
HTTP_BAD_METHOD - Static variable in class java.net. HttpURLConnection
HTTP状态代码405：不允许的方法。
HTTP_BAD_REQUEST - Static variable in class java.net. HttpURLConnection
HTTP状态代码400：错误请求。
HTTP_BINDING - Static variable in interface javax.xml.ws.http. HTTPBinding
表示XML / HTTP绑定的身份的常量。
HTTP_CLIENT_TIMEOUT - Static variable in class java.net. HttpURLConnection
HTTP状态码408：请求超时。
HTTP_CONFLICT - Static variable in class java.net. HttpURLConnection
HTTP状态代码409：冲突。
HTTP_CREATED - Static variable in class java.net. HttpURLConnection
HTTP状态代码201：创建。
HTTP_ENTITY_TOO_LARGE - Static variable in class java.net. HttpURLConnection
HTTP状态码413：请求实体太大。
HTTP_FORBIDDEN - Static variable in class java.net. HttpURLConnection
HTTP状态码403：禁止。
HTTP_GATEWAY_TIMEOUT - Static variable in class java.net. HttpURLConnection
HTTP状态代码504：网关超时。
HTTP_GONE - Static variable in class java.net. HttpURLConnection
HTTP状态代码410：没有。
HTTP_INTERNAL_ERROR - Static variable in class java.net. HttpURLConnection
HTTP状态码500：内部服务器错误。
HTTP_LENGTH_REQUIRED - Static variable in class java.net. HttpURLConnection
HTTP状态码411：需要长度。
HTTP_MOVED_PERM - Static variable in class java.net. HttpURLConnection
HTTP状态代码301：永久移动。
HTTP_MOVED_TEMP - Static variable in class java.net. HttpURLConnection
HTTP状态码302：临时重定向。
HTTP_MULT_CHOICE - Static variable in class java.net. HttpURLConnection
HTTP状态代码300：多个选择。
HTTP_NO_CONTENT - Static variable in class java.net. HttpURLConnection
HTTP状态代码204：无内容。
HTTP_NOT_ACCEPTABLE - Static variable in class java.net. HttpURLConnection
HTTP状态码406：不可接受
HTTP_NOT_AUTHORITATIVE - Static variable in class java.net. HttpURLConnection
HTTP状态码203：非授权信息。
HTTP_NOT_FOUND - Static variable in class java.net. HttpURLConnection
HTTP状态码404：未找到。
HTTP_NOT_IMPLEMENTED - Static variable in class java.net. HttpURLConnection
HTTP状态码501：未实现。
HTTP_NOT_MODIFIED - Static variable in class java.net. HttpURLConnection
HTTP状态码304：未修改。
HTTP_OK - Static variable in class java.net. HttpURLConnection
HTTP状态码200：确定。
HTTP_PARTIAL - Static variable in class java.net. HttpURLConnection
HTTP状态码206：部分内容。
HTTP_PAYMENT_REQUIRED - Static variable in class java.net. HttpURLConnection
HTTP状态码402：需要支付。
HTTP_PRECON_FAILED - Static variable in class java.net. HttpURLConnection
HTTP状态码412：前提条件失败。
HTTP_PROXY_AUTH - Static variable in class java.net. HttpURLConnection
HTTP状态码407：需要代理验证。
HTTP_REQ_TOO_LONG - Static variable in class java.net. HttpURLConnection
HTTP状态代码414：请求URI太大。
HTTP_REQUEST_HEADERS - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：HTTP请求头。
HTTP_REQUEST_METHOD - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：HTTP请求方法。
HTTP_RESET - Static variable in class java.net. HttpURLConnection
HTTP状态码205：重置内容。
HTTP_RESPONSE_CODE - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：HTTP响应状态码。
HTTP_RESPONSE_HEADERS - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：HTTP响应头。
HTTP_SEE_OTHER - Static variable in class java.net. HttpURLConnection
HTTP状态码303：查看其他。
HTTP_SERVER_ERROR - Static variable in class java.net. HttpURLConnection
已过时。
它是错误的，不应该存在。
HTTP_UNAUTHORIZED - Static variable in class java.net. HttpURLConnection
HTTP状态码401：未经授权
HTTP_UNAVAILABLE - Static variable in class java.net. HttpURLConnection
HTTP状态码503：服务不可用。
HTTP_UNSUPPORTED_TYPE - Static variable in class java.net. HttpURLConnection
HTTP状态码415：不支持的媒体类型。
HTTP_USE_PROXY - Static variable in class java.net. HttpURLConnection
HTTP状态码305：使用代理。
HTTP_VERSION - Static variable in class java.net. HttpURLConnection
HTTP状态码505：不支持HTTP版本。
HTTPBinding - Interface in javax.xml.ws.http
HTTPBinding接口是XML / HTTP绑定的抽象。
HttpClient - Class in jdk.incubator.http
用于多个HttpRequest的通用配置信息的容器。
HttpClient() - Constructor for class jdk.incubator.http. HttpClient
创建一个HttpClient。
HttpClient.Builder - Class in jdk.incubator.http
不可变的建筑师HttpClient s。
HttpClient.Redirect - Enum in jdk.incubator.http
定义自动重定向策略。
HttpClient.Version - Enum in jdk.incubator.http
HTTP协议版本。
HttpContext - Class in com.sun.net.httpserver
HttpContext表示应用程序的根URI路径与HttpHandler之间的映射，该对象被调用以处理在相关联的HttpServer或HttpsServer上发往该路径的请求。
HttpContext - Class in javax.xml.ws.spi.http
HttpContext表示Web服务的根URI路径与HttpHandler之间的映射，该对象被调用以处理发往关联容器上的该路径的请求。
HttpContext() - Constructor for class com.sun.net.httpserver. HttpContext
HttpContext() - Constructor for class javax.xml.ws.spi.http. HttpContext
HttpCookie - Class in java.net
HttpCookie对象表示HTTP cookie，它承载服务器和用户代理之间的状态信息。
HttpCookie(String, String) - Constructor for class java.net. HttpCookie
构造具有指定名称和值的cookie。
HTTPEQUIV - Static variable in class javax.swing.text.html. HTML.Attribute
属性“http-equiv”
HTTPException - Exception in javax.xml.ws.http
HTTPException异常表示XML / HTTP故障。
HTTPException(int) - Constructor for exception javax.xml.ws.http. HTTPException
HTTPException的构造方法
HttpExchange - Class in com.sun.net.httpserver
此类封装了收到的HTTP请求和在一个交换中生成的响应。
HttpExchange - Class in javax.xml.ws.spi.http
此类封装了收到的HTTP请求和在一个交换中生成的响应。
HttpExchange() - Constructor for class com.sun.net.httpserver. HttpExchange
HttpExchange() - Constructor for class javax.xml.ws.spi.http. HttpExchange
HttpHandler - Class in javax.xml.ws.spi.http
被调用以处理HTTP请求的处理程序。
HttpHandler - Interface in com.sun.net.httpserver
被调用以处理HTTP交换的处理程序。
HttpHandler() - Constructor for class javax.xml.ws.spi.http. HttpHandler
HttpHeaders - Interface in jdk.incubator.http
一组HTTP标头的只读视图。
HttpPrincipal - Class in com.sun.net.httpserver
表示通过HTTP Basic或Digest身份验证身份验证的用户。
HttpPrincipal(String, String) - Constructor for class com.sun.net.httpserver. HttpPrincipal
从给定的用户名和领域创建一个HttpPrincipal
HttpRequest - Class in jdk.incubator.http
表示可以发送到服务器的一个HTTP请求。
HttpRequest() - Constructor for class jdk.incubator.http. HttpRequest
创建一个HttpRequest。
HttpRequest.BodyProcessor - Interface in jdk.incubator.http
将高级Java对象转换为适合作为请求体发送的ByteBuffer的流的处理器 。
HttpRequest.Builder - Class in jdk.incubator.http
一个建筑师HttpRequest s。
HttpResponse< T> - Class in jdk.incubator.http
代表对HttpRequest的回复 。
HttpResponse() - Constructor for class jdk.incubator.http. HttpResponse
创建一个HttpResponse。
HttpResponse.BodyHandler< T> - Interface in jdk.incubator.http
响应机构的处理程序。
HttpResponse.BodyProcessor< T> - Interface in jdk.incubator.http
响应机构的处理器。
HttpResponse.MultiProcessor< U, T> - Interface in jdk.incubator.http
用于HTTP / 2多响应的响应处理器。
HttpRetryException - Exception in java.net
抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。
HttpRetryException(String, int) - Constructor for exception java.net. HttpRetryException
从指定的响应代码和异常详细信息构造一个新的 HttpRetryException
HttpRetryException(String, int, String) - Constructor for exception java.net. HttpRetryException
构造一个新的 HttpRetryException其中包含详细的消息响应代码和位置响应头域的内容。
HTTPS - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported
安全超文本传输协议（HTTPS）。
HttpsConfigurator - Class in com.sun.net.httpserver
此类用于配置HttpsServer上每个传入https连接的https参数。
HttpsConfigurator(SSLContext) - Constructor for class com.sun.net.httpserver. HttpsConfigurator
使用给定的SSLContext创建一个Https配置。
HttpServer - Class in com.sun.net.httpserver
这个类实现了一个简单的HTTP服务器。
HttpServer() - Constructor for class com.sun.net.httpserver. HttpServer
HttpServerProvider - Class in com.sun.net.httpserver.spi
HttpServer的服务提供者类。
HttpServerProvider() - Constructor for class com.sun.net.httpserver.spi. HttpServerProvider
初始化此类的新实例。
HttpsExchange - Class in com.sun.net.httpserver
此类封装了收到的HTTPS请求和在一个交换中生成的响应，并定义了特定于HTTPS协议的HttpExchange扩展。
HttpsExchange() - Constructor for class com.sun.net.httpserver. HttpsExchange
HttpsParameters - Class in com.sun.net.httpserver
表示与客户端协商的每个https连接的参数集。
HttpsParameters() - Constructor for class com.sun.net.httpserver. HttpsParameters
HttpsServer - Class in com.sun.net.httpserver
此类是HttpServer的扩展，它为HTTPS提供支持。
HttpsServer() - Constructor for class com.sun.net.httpserver. HttpsServer
HttpsURLConnection - Class in javax.net.ssl
HttpsURLConnection扩展了 HttpURLConnection ，支持https特定的功能。
HttpsURLConnection(URL) - Constructor for class javax.net.ssl. HttpsURLConnection
使用指定的URL创建一个 HttpsURLConnection 。
HttpTimeoutException - Exception in jdk.incubator.http
在指定时间段内没有收到回应时抛出。
HttpTimeoutException(String) - Constructor for exception jdk.incubator.http. HttpTimeoutException
HttpURLConnection - Class in java.net
支持HTTP特定功能的URLConnection。
HttpURLConnection(URL) - Constructor for class java.net. HttpURLConnection
HttpURLConnection的构造方法。
hueProperty() - Method in class javafx.scene.effect. ColorAdjust
色调调整值。
HUFFMAN_ONLY - Static variable in class java.util.zip. Deflater
仅用于霍夫曼编码的压缩策略。
hvalueProperty() - Method in class javafx.scene.control. ScrollPane
ScrollPane的当前水平滚动位置。
Hyperlink - Class in javafx.scene.control
一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。
Hyperlink() - Constructor for class javafx.scene.control. Hyperlink
创建没有标签的超链接。
Hyperlink(String) - Constructor for class javafx.scene.control. Hyperlink
创建指定文本的超链接作为其标签。
Hyperlink(String, Node) - Constructor for class javafx.scene.control. Hyperlink
创建指定文本和图形作为其标签的超链接。
HYPERLINK - javafx.scene. AccessibleRole
超链接角色。
HYPERLINK - Static variable in class javax.accessibility. AccessibleRole
超文本锚。
HyperlinkEvent - Class in javax.swing.event
HyperlinkEvent用于通知有关方面，超文本链接发生了一些事情。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL) - Constructor for class javax.swing.event. HyperlinkEvent
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - Constructor for class javax.swing.event. HyperlinkEvent
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element) - Constructor for class javax.swing.event. HyperlinkEvent
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, InputEvent) - Constructor for class javax.swing.event. HyperlinkEvent
创建一个表示超文本链接事件的新对象。
HyperlinkEvent.EventType - Class in javax.swing.event
定义ENTERED，EXITED和ACTIVATED事件类型以及由toString（）返回的字符串表示形式。
HyperlinkListener - Interface in javax.swing.event
HyperlinkListener
HyperlinkSkin - Class in javafx.scene.control.skin
默认皮肤实现为Hyperlink控件。
HyperlinkSkin(Hyperlink) - Constructor for class javafx.scene.control.skin. HyperlinkSkin
创建一个新的HyperlinkSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
hyperlinkUpdate(HyperlinkEvent) - Method in interface javax.swing.event. HyperlinkListener
当更新超文本链接时调用。
hypot(double, double) - Static method in class java.lang. Math
返回sqrt（ x 2 + y 2 ），没有中间溢出或下溢。
hypot(double, double) - Static method in class java.lang. StrictMath
返回sqrt（ x 2 + y 2 ），没有中间溢出或下溢。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


I-Index (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

SEARCH:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
I

I - javafx.scene.input. KeyCode

常数为 I键。

I - Static variable in class javax.swing.text.html. HTML.Tag

标记<i>

icAbsoluteColorimetric - Static variable in class java.awt.color. ICC_Profile

ICC配置文件渲染意图：绝对色度。

ICC_ColorSpace - Class in java.awt.color

ICC_ColorSpace类是抽象ColorSpace类的一个实现。

ICC_ColorSpace(ICC_Profile) - Constructor for class java.awt.color. ICC_ColorSpace

从ICC_Profile对象构造一个新的ICC_ColorSpace。

ICC_Profile - Class in java.awt.color

基于国际色彩联盟规范ICC.1：2001-12，颜色配置文件格式（参见 http://www.color.org ）的设备无关和设备相关色彩空间的颜色配置文件数据的表示。

ICC_ProfileGray - Class in java.awt.color

ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为TYPE_GRAY，配置文件包含grayTRCTag和mediaWhitePointTag标签。

ICC_ProfileRGB - Class in java.awt.color

ICC_ProfileRGB类是ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为RGB。 该配置文件包含redColorantTag ， greenColorantTag ， blueColorantTag ， redTRCTag ， greenTRCTag ， blueTRCTag ，并mediaWhitePointTag标签。 当满足这些条件时， ICC_Profile getInstance方法将返回一个ICC_ProfileRGB对象。

icCurveCount - Static variable in class java.awt.color. ICC_Profile

ICC Profile Constant：curveType count。

icCurveData - Static variable in class java.awt.color. ICC_Profile

ICC Profile Constant：curveType数据。

icHdrAttributes - Static variable in class java.awt.color. ICC_Profile

ICC配置文件头位置：设备属性。

icHdrCmmId - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：此配置文件的CMM。

icHdrColorSpace - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：数据的颜色空间。

icHdrCreator - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：个人资料创建者。

icHdrDate - Static variable in class java.awt.color. ICC_Profile

ICC配置文件头位置：创建日期配置文件。

icHdrDeviceClass - Static variable in class java.awt.color. ICC_Profile

ICC配置文件头位置：配置文件的类型。

icHdrFlags - Static variable in class java.awt.color. ICC_Profile

ICC配置文件头位置：各种位设置。

icHdrIlluminant - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：配置文件。

icHdrMagic - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：icMagicNumber。

icHdrManufacturer - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：设备制造商。

icHdrModel - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：设备型号。

icHdrPcs - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：PCS - XYZ或Lab。

icHdrPlatform - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：主平台。

icHdrProfileID - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：个人资料ID。

icHdrRenderingIntent - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：渲染意图。

icHdrSize - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：配置文件大小（以字节为单位）。

icHdrVersion - Static variable in class java.awt.color. ICC_Profile

ICC Profile Header位置：格式版本号。

icICCAbsoluteColorimetric - Static variable in class java.awt.color. ICC_Profile

ICC Profile Rendering Intent：ICC-AbsoluteColorimetric。

icMediaRelativeColorimetric - Static variable in class java.awt.color. ICC_Profile

ICC配置文件渲染意图：Media-RelativeColorimetric。

icon - Variable in class javax.swing. JOptionPane

窗格中使用的图标。

icon - Variable in class javax.swing.plaf.basic. BasicRadioButtonUI

图标。

Icon - Interface in javax.swing

一个小的固定大小的图片，通常用于装饰组件。

ICON - Static variable in class javax.accessibility. AccessibleRole

一个小的固定大小的图片，通常用于装饰组件。

ICON_BADGE_IMAGE_WINDOW - java.awt. Taskbar.Feature

表示窗口的图形图标徽标功能。

ICON_BADGE_NUMBER - java.awt. Taskbar.Feature

代表一个数字图标标志功能。

ICON_BADGE_TEXT - java.awt. Taskbar.Feature

表示文字图标徽章功能。

ICON_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton

标识代表该按钮的图标的更改。

ICON_COLOR_16x16 - Static variable in interface java.beans. BeanInfo

常数表示16 x 16颜色图标。

ICON_COLOR_32x32 - Static variable in interface java.beans. BeanInfo

常数表示32 x 32颜色图标。

ICON_IMAGE - java.awt. Taskbar.Feature

表示图标功能。

ICON_MONO_16x16 - Static variable in interface java.beans. BeanInfo

常数表示16 x 16黑白图标。

ICON_MONO_32x32 - Static variable in interface java.beans. BeanInfo

常数表示32 x 32黑白图标。

ICON_PROPERTY - Static variable in class javax.swing. JOptionPane

绑定属性名称为 icon 。

iconable - Variable in class javax.swing. JInternalFrame

框架可以“图标化”（缩小并显示为图标图像）。

IconAttribute - Static variable in class javax.swing.text. StyleConstants

图标属性的名称。

iconButton - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

图标按钮。

iconCache - Variable in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

图标缓存

IconElementName - Static variable in class javax.swing.text. StyleConstants

用于表示图标的元素名称。

iconIcon - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

图标图标。

ICONIFIED - Static variable in class java.awt. Frame

该状态位指示帧被图标化。

ICONIFIED - Static variable in class javax.accessibility. AccessibleState

表示此对象被最小化，仅由图标表示。

iconifiedProperty() - Method in class javafx.stage. Stage

定义 Stage是否被图标化。

ICONIFY_CMD - Static variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

最小化按钮文本属性。

iconifyAction - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

一个 IconifyAction的实例。

IconifyAction() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.IconifyAction

构造一个新的实例 IconifyAction 。

iconifyFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager

从其父项中移除框架，并将其 desktopIcon添加到父级。

iconifyFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager

通常，从其父项中删除此框架，并添加一个标志性表示。

iconifyFrame(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

当用户想要图标化帧时调用此方法。

iconOnly - Variable in class javax.swing.plaf.metal. MetalComboBoxButton

iconOnly价值。

iconPane - Variable in class javax.swing.plaf.basic. BasicDesktopIconUI

桌面图标中使用的标题窗格组件。

IconUIResource - Class in javax.swing.plaf

一个实现UIResource的图标包装类。

IconUIResource(Icon) - Constructor for class javax.swing.plaf. IconUIResource

创建一个UIResource图标对象，该对象包装现有的图标实例。

IconView - Class in javax.swing.text

图标装饰器实现视图界面。

IconView(Element) - Constructor for class javax.swing.text. IconView

创建一个代表元素的新图标视图。

icPerceptual - Static variable in class java.awt.color. ICC_Profile

ICC概要呈现意图：感性。

icRelativeColorimetric - Static variable in class java.awt.color. ICC_Profile

ICC配置文件渲染意图：RelativeColorimetric。

icSaturation - Static variable in class java.awt.color. ICC_Profile

ICC配置文件渲染意图：饱和度。

icSigAbstractClass - Static variable in class java.awt.color. ICC_Profile

ICC简介类别签名：'abst'。

icSigAToB0Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'A2B0'。

icSigAToB1Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'A2B1'。

icSigAToB2Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'A2B2'。

icSigBlueColorantTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'bXYZ'。

icSigBlueMatrixColumnTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'bXYZ'。

icSigBlueTRCTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'bTRC'。

icSigBToA0Tag - Static variable in class java.awt.color. ICC_Profile

ICC Profile Tag签名：'B2A0'。

icSigBToA1Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'B2A1'。

icSigBToA2Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'B2A2'。

icSigCalibrationDateTimeTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'calt'。

icSigCharTargetTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'targ'。

icSigChromaticAdaptationTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'乍得'。

icSigChromaticityTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'chrm'。

icSigCmyData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'CMY'。

icSigCmykData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'CMYK'。

icSigColorantOrderTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'clro'。

icSigColorantTableTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'clrt'。

icSigColorSpaceClass - Static variable in class java.awt.color. ICC_Profile

ICC Profile Class签名：'spac'。

icSigCopyrightTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'cprt'。

icSigCrdInfoTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'crdi'。

icSigDeviceMfgDescTag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'dmnd'。

icSigDeviceModelDescTag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'dmdd'。

icSigDeviceSettingsTag - Static variable in class java.awt.color. ICC_Profile

ICC Profile Tag签名：'devs'。

icSigDisplayClass - Static variable in class java.awt.color. ICC_Profile

ICC简介类别签名：'mntr'。

icSigGamutTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'gamt'。

icSigGrayData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'GREY'。

icSigGrayTRCTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'kTRC'。

icSigGreenColorantTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'gXYZ'。

icSigGreenMatrixColumnTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'gXYZ'。

icSigGreenTRCTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'gTRC'。

icSigHead - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'头' - 特别。

icSigHlsData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'HLS'。

icSigHsvData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'HSV'。

icSigInputClass - Static variable in class java.awt.color. ICC_Profile

ICC档案类签名：'scnr'。

icSigLabData - Static variable in class java.awt.color. ICC_Profile

ICC简介颜色空间类型签名：'实验室'。

icSigLinkClass - Static variable in class java.awt.color. ICC_Profile

ICC档案类签名：'link'。

icSigLuminanceTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'lumi'。

icSigLuvData - Static variable in class java.awt.color. ICC_Profile

ICC简介颜色空间类型签名：'Luv'。

icSigMeasurementTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'meas'。

icSigMediaBlackPointTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'bkpt'。

icSigMediaWhitePointTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'wtpt'。

icSigNamedColor2Tag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'ncl2'。

icSigNamedColorClass - Static variable in class java.awt.color. ICC_Profile

ICC简介类签名：'nmcl'。

icSigOutputClass - Static variable in class java.awt.color. ICC_Profile

ICC档案类签名：'prtr'。

icSigOutputResponseTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'resp'。

icSigPreview0Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'pre0'。

icSigPreview1Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'pre1'。

icSigPreview2Tag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'pre2'。

icSigProfileDescriptionTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'desc'。

icSigProfileSequenceDescTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'pseq'。

icSigPs2CRD0Tag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'psd0'。

icSigPs2CRD1Tag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'psd1'。

icSigPs2CRD2Tag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'psd2'。

icSigPs2CRD3Tag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'psd3'。

icSigPs2CSATag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'ps2s'。

icSigPs2RenderingIntentTag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'ps2i'。

icSigRedColorantTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'rXYZ'。

icSigRedMatrixColumnTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'rXYZ'。

icSigRedTRCTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'rTRC'。

icSigRgbData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'RGB'。

icSigScreeningDescTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'scrd'。

icSigScreeningTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'scrn'。

icSigSpace2CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'2CLR'。

icSigSpace3CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'3CLR'。

icSigSpace4CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'4CLR'。

icSigSpace5CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'5CLR'。

icSigSpace6CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'6CLR'。

icSigSpace7CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'7CLR'。

icSigSpace8CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'8CLR'。

icSigSpace9CLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'9CLR'。

icSigSpaceACLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'ACLR'。

icSigSpaceBCLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'BCLR'。

icSigSpaceCCLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'CCLR'。

icSigSpaceDCLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'DCLR'。

icSigSpaceECLR - Static variable in class java.awt.color. ICC_Profile

ICC简介颜色空间类型签名：'ECLR'。

icSigSpaceFCLR - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'FCLR'。

icSigTechnologyTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'科技'。

icSigUcrBgTag - Static variable in class java.awt.color. ICC_Profile

ICC配置文件标签签名：'bfd'。

icSigViewingCondDescTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'vued'。

icSigViewingConditionsTag - Static variable in class java.awt.color. ICC_Profile

ICC简介标签签名：'视图'。

icSigXYZData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'XYZ'。

icSigYCbCrData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'YCbr'。

icSigYxyData - Static variable in class java.awt.color. ICC_Profile

ICC配置文件颜色空间类型签名：'Yxy'。

icTagReserved - Static variable in class java.awt.color. ICC_Profile

ICC配置常数：保留。

icTagType - Static variable in class java.awt.color. ICC_Profile

ICC Profile Constant：标签类型签名。

icXYZNumberX - Static variable in class java.awt.color. ICC_Profile

ICC配置常数：XYZNumber X.

id - Variable in class java.awt. AWTEvent

事件的id

id - Variable in class java.awt. Event

已过时。

指示事件的事件类型，以及哪些其他 Event变量与事件相关。

id - Variable in class javax.naming.ldap. BasicControl

控件的对象标识符字符串。

id - Variable in class org.omg.CORBA. NameValuePair

与 NameValuePair对象的值相关联的名称。

id - Variable in class org.omg.CORBA. ValueMember

由 ValueMember对象描述的 value成员的存储库ID;

id - Variable in class org.omg.CosNaming. NameComponent

id - Variable in class org.omg.DynamicAny. NameDynAnyPair

与DynAny关联的名称。

id - Variable in class org.omg.DynamicAny. NameValuePair

与Any相关联的名称。

id() - Method in class com.sun.tools.attach. VirtualMachine

返回此Java虚拟机的标识符。

id() - Method in class com.sun.tools.attach. VirtualMachineDescriptor

返回此描述符的标识符组件。

id() - Method in class jdk.jshell. Snippet

代码段的唯一标识符。

id() - Method in exception jdk.jshell.spi. ExecutionControl.ResolutionException

检索未解析的标识符的内部标识符。

id() - Method in exception jdk.jshell.spi. SPIResolutionException

检索未解析的标识符的内部标识符。

id() - Static method in class org.omg.CORBA. AnySeqHelper

id() - Static method in class org.omg.CORBA. BooleanSeqHelper

id() - Static method in class org.omg.CORBA. BoundsHelper

id() - Static method in class org.omg.CORBA. CharSeqHelper

id() - Static method in class org.omg.CORBA. CompletionStatusHelper

id() - Static method in class org.omg.CORBA. CurrentHelper

id() - Static method in class org.omg.CORBA. DefinitionKindHelper

id() - Static method in class org.omg.CORBA. DoubleSeqHelper

id() - Static method in class org.omg.CORBA. FieldNameHelper

id() - Static method in class org.omg.CORBA. FloatSeqHelper

id() - Static method in class org.omg.CORBA. IdentifierHelper

id() - Static method in class org.omg.CORBA. IDLTypeHelper

id() - Static method in class org.omg.CORBA. LongLongSeqHelper

id() - Static method in class org.omg.CORBA. LongSeqHelper

id() - Static method in class org.omg.CORBA. NameValuePairHelper

id() - Static method in class org.omg.CORBA. ObjectHelper

id() - Static method in class org.omg.CORBA. OctetSeqHelper

id() - Static method in class org.omg.CORBA.ORBPackage. InvalidNameHelper

id() - Static method in class org.omg.CORBA. ParameterModeHelper

id() - Static method in class org.omg.CORBA. PolicyErrorCodeHelper

id() - Static method in class org.omg.CORBA. PolicyErrorHelper

id() - Static method in class org.omg.CORBA. PolicyHelper

id() - Static method in class org.omg.CORBA. PolicyListHelper

id() - Static method in class org.omg.CORBA. PolicyTypeHelper

id() - Static method in class org.omg.CORBA. RepositoryIdHelper

id() - Static method in class org.omg.CORBA. ServiceDetailHelper

id() - Static method in class org.omg.CORBA. ServiceInformationHelper

id() - Static method in class org.omg.CORBA. SetOverrideTypeHelper

id() - Static method in class org.omg.CORBA. ShortSeqHelper

id() - Static method in class org.omg.CORBA. StringSeqHelper

id() - Static method in class org.omg.CORBA. StringValueHelper

id() - Static method in class org.omg.CORBA. StructMemberHelper

id() - Method in class org.omg.CORBA. TypeCode

检索RepositoryId，全局标识此 TypeCode对象的类型。

id() - Static method in class org.omg.CORBA.TypeCodePackage. BadKindHelper

id() - Static method in class org.omg.CORBA.TypeCodePackage. BoundsHelper

id() - Static method in class org.omg.CORBA. ULongLongSeqHelper

id() - Static method in class org.omg.CORBA. ULongSeqHelper

id() - Static method in class org.omg.CORBA. UnionMemberHelper

id() - Static method in class org.omg.CORBA. UnknownUserExceptionHelper

id() - Static method in class org.omg.CORBA. UShortSeqHelper

id() - Static method in class org.omg.CORBA. ValueBaseHelper

id() - Static method in class org.omg.CORBA. ValueMemberHelper

id() - Static method in class org.omg.CORBA. VersionSpecHelper

id() - Static method in class org.omg.CORBA. VisibilityHelper

id() - Static method in class org.omg.CORBA. WCharSeqHelper

id() - Static method in class org.omg.CORBA. WrongTransactionHelper

id() - Static method in class org.omg.CORBA. WStringSeqHelper

id() - Static method in class org.omg.CORBA. WStringValueHelper

id() - Static method in class org.omg.CosNaming. BindingHelper

id() - Static method in class org.omg.CosNaming. BindingIteratorHelper

id() - Static method in class org.omg.CosNaming. BindingListHelper

id() - Static method in class org.omg.CosNaming. BindingTypeHelper

id() - Static method in class org.omg.CosNaming. IstringHelper

id() - Static method in class org.omg.CosNaming. NameComponentHelper

id() - Static method in class org.omg.CosNaming. NameHelper

id() - Static method in class org.omg.CosNaming. NamingContextExtHelper

id() - Static method in class org.omg.CosNaming.NamingContextExtPackage. AddressHelper

id() - Static method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHelper

id() - Static method in class org.omg.CosNaming.NamingContextExtPackage. StringNameHelper

id() - Static method in class org.omg.CosNaming.NamingContextExtPackage. URLStringHelper

id() - Static method in class org.omg.CosNaming. NamingContextHelper

id() - Static method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHelper

id() - Static method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHelper

id() - Static method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHelper

id() - Static method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHelper

id() - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundHelper

id() - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHelper

id() - Static method in class org.omg.DynamicAny. AnySeqHelper

id() - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper

id() - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCodeHelper

id() - Static method in class org.omg.DynamicAny. DynAnyHelper

id() - Static method in class org.omg.DynamicAny.DynAnyPackage. InvalidValueHelper

id() - Static method in class org.omg.DynamicAny.DynAnyPackage. TypeMismatchHelper

id() - Static method in class org.omg.DynamicAny. DynAnySeqHelper

id() - Static method in class org.omg.DynamicAny. DynArrayHelper

id() - Static method in class org.omg.DynamicAny. DynEnumHelper

id() - Static method in class org.omg.DynamicAny. DynFixedHelper

id() - Static method in class org.omg.DynamicAny. DynSequenceHelper

id() - Static method in class org.omg.DynamicAny. DynStructHelper

id() - Static method in class org.omg.DynamicAny. DynUnionHelper

id() - Static method in class org.omg.DynamicAny. DynValueHelper

id() - Static method in class org.omg.DynamicAny. FieldNameHelper

id() - Static method in class org.omg.DynamicAny. NameDynAnyPairHelper

id() - Static method in class org.omg.DynamicAny. NameDynAnyPairSeqHelper

id() - Static method in class org.omg.DynamicAny. NameValuePairHelper

id() - Static method in class org.omg.DynamicAny. NameValuePairSeqHelper

id() - Static method in class org.omg.IOP. CodecFactoryHelper

id() - Static method in class org.omg.IOP.CodecFactoryPackage. UnknownEncodingHelper

id() - Static method in class org.omg.IOP.CodecPackage. FormatMismatchHelper

id() - Static method in class org.omg.IOP.CodecPackage. InvalidTypeForEncodingHelper

id() - Static method in class org.omg.IOP.CodecPackage. TypeMismatchHelper

id() - Static method in class org.omg.IOP. ComponentIdHelper

id() - Static method in class org.omg.IOP. IORHelper

id() - Static method in class org.omg.IOP. MultipleComponentProfileHelper

id() - Static method in class org.omg.IOP. ProfileIdHelper

id() - Static method in class org.omg.IOP. ServiceContextHelper

id() - Static method in class org.omg.IOP. ServiceContextListHelper

id() - Static method in class org.omg.IOP. ServiceIdHelper

id() - Static method in class org.omg.IOP. TaggedComponentHelper

id() - Static method in class org.omg.IOP. TaggedProfileHelper

id() - Static method in class org.omg.Messaging. SyncScopeHelper

id() - Static method in class org.omg.PortableInterceptor. AdapterManagerIdHelper

id() - Static method in class org.omg.PortableInterceptor. AdapterNameHelper

id() - Static method in class org.omg.PortableInterceptor. AdapterStateHelper

id() - Static method in class org.omg.PortableInterceptor. CurrentHelper

id() - Static method in class org.omg.PortableInterceptor. ForwardRequestHelper

id() - Static method in class org.omg.PortableInterceptor. InvalidSlotHelper

id() - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper

id() - Static method in class org.omg.PortableInterceptor. ObjectIdHelper

id() - Static method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHelper

id() - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHelper

id() - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHelper

id() - Static method in class org.omg.PortableInterceptor. ORBIdHelper

id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateNameHelper

id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidNameHelper

id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. ObjectIdHelper

id() - Static method in class org.omg.PortableInterceptor. ServerIdHelper

id() - Static method in class org.omg.PortableServer. CurrentHelper

id() - Static method in class org.omg.PortableServer.CurrentPackage. NoContextHelper

id() - Static method in class org.omg.PortableServer. ForwardRequestHelper

id() - Static method in class org.omg.PortableServer. POAHelper

id() - Static method in class org.omg.PortableServer.POAManagerPackage. AdapterInactiveHelper

id() - Method in interface org.omg.PortableServer. POAOperations

这将在其创建的过程中返回POA的唯一ID。

id() - Static method in class org.omg.PortableServer.POAPackage. AdapterAlreadyExistsHelper

id() - Static method in class org.omg.PortableServer.POAPackage. AdapterNonExistentHelper

id() - Static method in class org.omg.PortableServer.POAPackage. InvalidPolicyHelper

id() - Static method in class org.omg.PortableServer.POAPackage. NoServantHelper

id() - Static method in class org.omg.PortableServer.POAPackage. ObjectAlreadyActiveHelper

id() - Static method in class org.omg.PortableServer.POAPackage. ObjectNotActiveHelper

id() - Static method in class org.omg.PortableServer.POAPackage. ServantAlreadyActiveHelper

id() - Static method in class org.omg.PortableServer.POAPackage. ServantNotActiveHelper

id() - Static method in class org.omg.PortableServer.POAPackage. WrongAdapterHelper

id() - Static method in class org.omg.PortableServer.POAPackage. WrongPolicyHelper

id() - Static method in class org.omg.PortableServer. ServantActivatorHelper

id() - Static method in class org.omg.PortableServer. ServantLocatorHelper

ID - Static variable in class javax.swing.text.html. HTML.Attribute

属性“id”

ID - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于ID

ID - Static variable in class javax.xml.ws. RespectBindingFeature

识别RespectBindingFeature的常量值

ID - Static variable in class javax.xml.ws.soap. AddressingFeature

识别寻址功能的常数值

ID - Static variable in class javax.xml.ws.soap. MTOMFeature

识别MTOMFeature的恒定值

ID_ASSIGNMENT_POLICY_ID - Interface in org.omg.PortableServer

org / omg / PortableServer / ID_ASSIGNMENT_POLICY_ID.java。

id_to_reference(byte[]) - Method in interface org.omg.PortableServer. POAOperations

如果具有指定的Object Id值的对象当前处于活动状态，则返回封装用于激活对象的信息的引用。

id_to_servant(byte[]) - Method in interface org.omg.PortableServer. POAOperations

如果POA具有RETAIN策略，并且指定的ObjectId位于活动对象映射中，则此操作将返回与活动对象映射中该对象关联的servant。

ID_UNIQUENESS_POLICY_ID - Interface in org.omg.PortableServer

org / omg / PortableServer / ID_UNIQUENESS_POLICY_ID.java。

IdAssignmentPolicy - Interface in org.omg.PortableServer

IdAssignmentPolicy指定创建的POA中的对象Id是由应用程序还是由ORB生成。

IdAssignmentPolicyOperations - Interface in org.omg.PortableServer

IdAssignmentPolicy指定创建的POA中的对象Id是由应用程序还是由ORB生成。

IdAssignmentPolicyValue - Class in org.omg.PortableServer

IdAssignmentPolicyValue可以具有以下值。

IdAssignmentPolicyValue(int) - Constructor for class org.omg.PortableServer. IdAssignmentPolicyValue

identical(Object, Object) - Static method in class jdk.nashorn.api.scripting. ScriptObjectMirror

给定的对象是否反映到相同的底层对象？

IDENTICAL - Static variable in class java.text. Collator

整理器强度值。

identifier - Variable in class javax.swing.table. TableColumn

这个对象不是由内部的绘图机械使用的JTable ; 可以在TableColumn设置标识符，作为标记和查找表列的可选方法。

IDENTIFIER - com.sun.source.doctree. DocTree.Kind

用于表示标识符的IdentifierTree的实例。

IDENTIFIER - com.sun.source.tree. Tree.Kind

用于IdentifierTree的实例。

IDENTIFIER - jdk.nashorn.api.tree. Tree.Kind

用于IdentifierTree的实例。

IdentifierHelper - Class in org.omg.CORBA

助手 Identifier 。

IdentifierHelper() - Constructor for class org.omg.CORBA. IdentifierHelper

IdentifierTree - Interface in com.sun.source.doctree

文档注释中的标识符。

IdentifierTree - Interface in com.sun.source.tree

标识符表达式的树节点。

IdentifierTree - Interface in jdk.nashorn.api.tree

标识符表达式的树节点。

identities() - Method in class java.security. IdentityScope

已过时。

返回此身份范围内所有身份的枚举。

identity() - Static method in interface java.util.function. DoubleUnaryOperator

返回始终返回其输入参数的一元运算符。

identity() - Static method in interface java.util.function. Function

返回一个总是返回其输入参数的函数。

identity() - Static method in interface java.util.function. IntUnaryOperator

返回始终返回其输入参数的一元运算符。

identity() - Static method in interface java.util.function. LongUnaryOperator

返回始终返回其输入参数的一元运算符。

identity() - Static method in interface java.util.function. UnaryOperator

返回始终返回其输入参数的一元运算符。

identity(Class<?>) - Static method in class java.lang.invoke. MethodHandles

生成方法句柄，在调用时返回其唯一参数。

Identity - Class in java.security

已过时。
此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

Identity() - Constructor for class java.security. Identity

已过时。

仅用于序列化的构造方法。

Identity(String) - Constructor for class java.security. Identity

已过时。

构造一个具有指定名称的标识符，而不指定范围。

Identity(String, IdentityScope) - Constructor for class java.security. Identity

已过时。

构造具有指定名称和范围的身份。

IDENTITY - Static variable in class java.awt.font. TransformAttribute

A TransformAttribute表示身份转换。

IDENTITY_FINISH - java.util.stream. Collector.Characteristics

表示整理器功能是身份功能，可以被删除。

IDENTITY_STRING_CONVERTER - Static variable in class javafx.scene.control. TextFormatter

该字符串转换器将文本转换为相同的String值。

identityEquals(Identity) - Method in class java.security. Identity

已过时。

测试指定身份与此身份之间的相等性。

identityHashCode(Object) - Static method in class java.lang. System

返回与默认方法hashCode（）返回的给定对象相同的哈希码，无论给定对象的类是否覆盖了hashCode（）。

IdentityHashMap< K, V> - Class in java.util

该类使用哈希表实现 Map接口，在比较键（和值）时使用引用相等代替对象相等。

IdentityHashMap() - Constructor for class java.util. IdentityHashMap

构造一个带有默认预期最大大小的新的空标识哈希映射（21）。

IdentityHashMap(int) - Constructor for class java.util. IdentityHashMap

构造一个具有指定的预期最大大小的新的空白地图。

IdentityHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util. IdentityHashMap

构造一个新的标识哈希映射，其中包含指定地图中的键值映射。

identityProperty() - Method in class javafx.scene.transform. Transform

确定这是否是当前的身份转换。

IdentityScope - Class in java.security

已过时。
此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

IdentityScope() - Constructor for class java.security. IdentityScope

已过时。

此构造函数仅用于序列化，不应由子类使用。

IdentityScope(String) - Constructor for class java.security. IdentityScope

已过时。

构造具有指定名称的新的身份范围。

IdentityScope(String, IdentityScope) - Constructor for class java.security. IdentityScope

已过时。

构造具有指定名称和范围的新的身份范围。

IDEOGRAPHIC_DESCRIPTION_CHARACTERS - Static variable in class java.lang. Character.UnicodeBlock

Unicode字符块的“表意描述字符”的常量。

idGenerator(BiFunction<Snippet, Integer, String>) - Method in class jdk.jshell. JShell.Builder

设置代码段识别名称的生成器。

IDLE - Static variable in class javax.print.attribute.standard. PrinterState

表示新作业可以开始处理而无需等待。

IDLEntity - Interface in org.omg.CORBA.portable

没有成员的界面，其唯一目的是作为标记，指示实现类是具有相应助手类的IDL的Java值类型。

IDLType - Interface in org.omg.CORBA

由代表OMG IDL类型的所有Interface Repository（IR）对象继承的抽象接口。

IDLTypeHelper - Class in org.omg.CORBA

助手 IDLType 。

IDLTypeHelper() - Constructor for class org.omg.CORBA. IDLTypeHelper

IDLTypeOperations - Interface in org.omg.CORBA

该接口必须由所有IDLType对象实现。

IDN - Class in java.net

提供在正常Unicode表示和ASCII兼容编码（ACE）表示之间转换国际化域名（IDN）的方法。

idProperty() - Method in class javafx.scene.control. MenuItem

该MenuItem的ID。

idProperty() - Method in class javafx.scene.control. PopupControl

该 PopupControl为 PopupControl 。

idProperty() - Method in class javafx.scene.control. Tab

此选项卡的ID。

idProperty() - Method in class javafx.scene.control. TableColumnBase

此TableColumnBase的ID。

idProperty() - Method in class javafx.scene. Node

该 Node为 Node 。

IDREF - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于IDREF

IDREFS - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于IDREFS

IdUniquenessPolicy - Interface in org.omg.PortableServer

IdUniquenessPolicy指定在创建的POA中激活的服务器是否必须具有唯一对象i身份。

IdUniquenessPolicyOperations - Interface in org.omg.PortableServer

IdUniquenessPolicy指定在创建的POA中激活的服务器是否必须具有唯一对象i身份。

IdUniquenessPolicyValue - Class in org.omg.PortableServer

IdUniquenessPolicyValue可以具有以下值。

IdUniquenessPolicyValue(int) - Constructor for class org.omg.PortableServer. IdUniquenessPolicyValue

IEEEremainder(double, double) - Static method in class java.lang. Math

根据IEEE 754标准计算两个参数的余数运算。

IEEEremainder(double, double) - Static method in class java.lang. StrictMath

根据IEEE 754标准计算两个参数的余数运算。

IF - com.sun.source.tree. Tree.Kind

用于IfTree的实例。

IF - jdk.nashorn.api.tree. Tree.Kind

用于IfTree的实例。

ifModifiedSince - Variable in class java.net. URLConnection

某些协议支持跳过对象的提取，除非对象在某个时间以前已被更新。

ifPresent(Consumer<? super T>) - Method in class java.util. Optional

如果存在值，则使用该值执行给定的操作，否则不执行任何操作。

ifPresent(DoubleConsumer) - Method in class java.util. OptionalDouble

如果存在值，则使用该值执行给定的操作，否则不执行任何操作。

ifPresent(IntConsumer) - Method in class java.util. OptionalInt

如果存在值，则使用该值执行给定的操作，否则不执行任何操作。

ifPresent(LongConsumer) - Method in class java.util. OptionalLong

如果存在值，则使用该值执行给定的操作，否则不执行任何操作。

ifPresentOrElse(Consumer<? super T>, Runnable) - Method in class java.util. Optional

如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。

ifPresentOrElse(DoubleConsumer, Runnable) - Method in class java.util. OptionalDouble

如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。

ifPresentOrElse(IntConsumer, Runnable) - Method in class java.util. OptionalInt

如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。

ifPresentOrElse(LongConsumer, Runnable) - Method in class java.util. OptionalLong

如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。

IfTree - Interface in com.sun.source.tree

一个用于 if语句的树节点。

IfTree - Interface in jdk.nashorn.api.tree

“if”语句的树结点。

ignorableWhitespace(char[], int, int) - Method in interface org.xml.sax. ContentHandler

在元素内容中接收到可忽略的空白的通知。

ignorableWhitespace(char[], int, int) - Method in interface org.xml.sax. DocumentHandler

已过时。

在元素内容中接收到可忽略的空白的通知。

ignorableWhitespace(char[], int, int) - Method in class org.xml.sax. HandlerBase

已过时。

在元素内容中接收到可忽略的空白的通知。

ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers. DefaultHandler

在元素内容中接收到可忽略的空白的通知。

ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers. ParserAdapter

适配器实现方法; 不要打电话。

ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers. XMLFilterImpl

过滤可疑的空白事件。

ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers. XMLReaderAdapter

适应SAX2可忽略的空白事件。

IGNORE - Static variable in class java.nio.charset. CodingErrorAction

指示通过丢弃错误输入并恢复编码操作来处理编码错误的动作。

IGNORE_ALL_BEANINFO - Static variable in class java.beans. Introspector

标记以表示忽略所有beaninfo。

IGNORE_EXTENDED_RANGES - java.util. Locale.FilteringMode

指定基本过滤：请注意，给定语言优先级列表中包含的任何扩展语言范围都将被忽略。

IGNORE_IMMEDIATE_BEANINFO - Static variable in class java.beans. Introspector

标记表示忽略直接beaninfo。

ignoreMetadata - Variable in class javax.imageio. ImageReader

true如果当前输入源已被标记为允许元数据被 setInput忽略。

IIOByteBuffer - Class in javax.imageio.stream

表示对字节数组的可变引用以及该数组中的偏移量和长度的类。

IIOByteBuffer(byte[], int, int) - Constructor for class javax.imageio.stream. IIOByteBuffer

构造引用给定字节数组，偏移量和长度的 IIOByteBuffer 。

IIOException - Exception in javax.imageio

用于发信号读取和写入操作失败的异常类。

IIOException(String) - Constructor for exception javax.imageio. IIOException

构造一个 IIOException与给定的消息 String 。

IIOException(String, Throwable) - Constructor for exception javax.imageio. IIOException

构造一个 IIOException与给定的消息 String和一个 Throwable这是其根本原因。

IIOImage - Class in javax.imageio

用于聚合图像的简单容器类，一组缩略图（预览）图像，以及表示与该图像相关联的元数据的对象。

IIOImage(Raster, List<? extends BufferedImage>, IIOMetadata) - Constructor for class javax.imageio. IIOImage

构造一个 IIOImage含有 Raster ，和缩略图和元数据与之相关联。

IIOImage(RenderedImage, List<? extends BufferedImage>, IIOMetadata) - Constructor for class javax.imageio. IIOImage

构造一个 IIOImage含有 RenderedImage ，和缩略图和元数据与之相关联。

IIOInvalidTreeException - Exception in javax.imageio.metadata

一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。

IIOInvalidTreeException(String, Throwable, Node) - Constructor for exception javax.imageio.metadata. IIOInvalidTreeException

构造一个 IIOInvalidTreeException其中包含一条消息字符串，引用了引发此异常的异常的引用，以及引用该解析错误的 Node引用。

IIOInvalidTreeException(String, Node) - Constructor for exception javax.imageio.metadata. IIOInvalidTreeException

构造一个 IIOInvalidTreeException其中包含一条消息字符串，并引用了导致解析错误的 Node 。

IIOMetadata - Class in javax.imageio.metadata

由与图像和流相关联的元数据（非图像数据）的对象扩展的抽象类。

IIOMetadata() - Constructor for class javax.imageio.metadata. IIOMetadata

构造一个空的 IIOMetadata对象。

IIOMetadata(boolean, String, String, String[], String[]) - Constructor for class javax.imageio.metadata. IIOMetadata

使用给定的格式名称和格式类名构造一个 IIOMetadata对象，以及一个布尔值，指示是否支持标准格式。

IIOMetadataController - Interface in javax.imageio.metadata

要由可以通过建立GUI以从用户获取值或通过其他方式确定 IIOMetadata对象的设置的对象来实现的接口。

IIOMetadataFormat - Interface in javax.imageio.metadata

描述从 IIOMetadata.getAsTree返回并传递给 IIOMetadata.setFromTree和 mergeTree的元数据文档的结构的对象。

IIOMetadataFormatImpl - Class in javax.imageio.metadata

一个具体的类，提供可重用的 IIOMetadataFormat接口的实现。

IIOMetadataFormatImpl(String, int) - Constructor for class javax.imageio.metadata. IIOMetadataFormatImpl

构造一个空白的 IIOMetadataFormatImpl实例，具有给定的根元素名称和子策略（ CHILD_POLICY_REPEAT ）。

IIOMetadataFormatImpl(String, int, int) - Constructor for class javax.imageio.metadata. IIOMetadataFormatImpl

构造一个空白的 IIOMetadataFormatImpl实例，具有给定的根元素名称和子策略为 CHILD_POLICY_REPEAT 。

IIOMetadataNode - Class in javax.imageio.metadata

表示元数据树中的节点的类，其实现 org.w3c.dom.Element接口，并且还允许通过 getUserObject和 setUserObject方法存储非文本对象。

IIOMetadataNode() - Constructor for class javax.imageio.metadata. IIOMetadataNode

构造一个空的 IIOMetadataNode 。

IIOMetadataNode(String) - Constructor for class javax.imageio.metadata. IIOMetadataNode

构造具有给定节点名称的 IIOMetadataNode 。

IIOParam - Class in javax.imageio

描述流如何解码或编码的所有类的超类。

IIOParam() - Constructor for class javax.imageio. IIOParam

受保护的构造函数只能由子类调用。

IIOParamController - Interface in javax.imageio

要由可以通过建立GUI以从用户获取值或通过其他方式确定 IIOParam对象的设置的对象来实现的接口。

IIOReadProgressListener - Interface in javax.imageio.event

ImageReader实现的接口通知呼叫者他们的图像和缩略图读取进度方法。

IIOReadUpdateListener - Interface in javax.imageio.event

ImageReader实现使用的接口来通知呼叫者他们的图像和缩略图读取像素更新方法。

IIOReadWarningListener - Interface in javax.imageio.event

通过 ImageReader实现来通知呼叫者他们的图像和缩略图读取警告方法（非致命错误）的界面。

IIORegistry - Class in javax.imageio.spi

服务提供商实例的注册表。

IIOServiceProvider - Class in javax.imageio.spi

所有Image I / O服务提供商接口（SPI）通用功能的超级界面。

IIOServiceProvider() - Constructor for class javax.imageio.spi. IIOServiceProvider

构造空白 IIOServiceProvider 。

IIOServiceProvider(String, String) - Constructor for class javax.imageio.spi. IIOServiceProvider

构造具有给定供应商名称和版本标识符的 IIOServiceProvider 。

IIOWriteProgressListener - Interface in javax.imageio.event

由 ImageWriter实现使用的接口通知呼叫者他们的图像写入方法的进度。

IIOWriteWarningListener - Interface in javax.imageio.event

ImageWriter实现的接口通知呼叫者他们的图像和缩略图读取警告方法（非致命错误）。

IllegalAccessError - Error in java.lang

如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。

IllegalAccessError() - Constructor for error java.lang. IllegalAccessError

构造一个 IllegalAccessError ，没有详细消息。

IllegalAccessError(String) - Constructor for error java.lang. IllegalAccessError

构造一个具有指定详细消息的 IllegalAccessError 。

IllegalAccessException - Exception in java.lang

当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。

IllegalAccessException() - Constructor for exception java.lang. IllegalAccessException

构造一个 IllegalAccessException没有详细消息。

IllegalAccessException(String) - Constructor for exception java.lang. IllegalAccessException

构造一个 IllegalAccessException的详细消息。

IllegalArgumentException - Exception in java.lang

抛出表示一种方法已经通过了非法或不正确的参数。

IllegalArgumentException() - Constructor for exception java.lang. IllegalArgumentException

构造一个 IllegalArgumentException ，没有详细消息。

IllegalArgumentException(String) - Constructor for exception java.lang. IllegalArgumentException

构造一个具有指定详细消息的 IllegalArgumentException 。

IllegalArgumentException(String, Throwable) - Constructor for exception java.lang. IllegalArgumentException

构造一个新的异常与指定的详细信息和原因。

IllegalArgumentException(Throwable) - Constructor for exception java.lang. IllegalArgumentException

构造具有指定原因的新异常和 (cause==null ? null : cause.toString())的详细消息（通常包含类和详细消息为 cause ）。

IllegalBlockingModeException - Exception in java.nio.channels

当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。

IllegalBlockingModeException() - Constructor for exception java.nio.channels. IllegalBlockingModeException

构造这个类的一个实例。

IllegalBlockSizeException - Exception in javax.crypto

当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。

IllegalBlockSizeException() - Constructor for exception javax.crypto. IllegalBlockSizeException

构造一个没有详细消息的IllegalBlockSizeException。

IllegalBlockSizeException(String) - Constructor for exception javax.crypto. IllegalBlockSizeException

构造具有指定详细消息的IllegalBlockSizeException。

IllegalCallerException - Exception in java.lang

被抛出来表示一个方法已被不适当的调用者调用。

IllegalCallerException() - Constructor for exception java.lang. IllegalCallerException

构造一个没有详细消息的IllegalCallerException。

IllegalCallerException(String) - Constructor for exception java.lang. IllegalCallerException

构造具有指定详细消息的IllegalCallerException。

IllegalCallerException(String, Throwable) - Constructor for exception java.lang. IllegalCallerException

构造一个新的异常与指定的详细信息和原因。

IllegalCallerException(Throwable) - Constructor for exception java.lang. IllegalCallerException

构造具有指定原因的新异常和 (cause==null ? null : cause.toString())的详细消息（通常包含类和详细消息为 cause ）。

IllegalChannelGroupException - Exception in java.nio.channels

尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。

IllegalChannelGroupException() - Constructor for exception java.nio.channels. IllegalChannelGroupException

构造这个类的一个实例。

IllegalCharsetNameException - Exception in java.nio.charset

当不使用不是 legal charset name的字符串时抛出未检查的异常。

IllegalCharsetNameException(String) - Constructor for exception java.nio.charset. IllegalCharsetNameException

构造这个类的一个实例。

IllegalClassFormatException - Exception in java.lang.instrument

当其输入参数无效时，实施 ClassFileTransformer.transform时抛出。

IllegalClassFormatException() - Constructor for exception java.lang.instrument. IllegalClassFormatException

构造一个没有详细消息的 IllegalClassFormatException 。

IllegalClassFormatException(String) - Constructor for exception java.lang.instrument. IllegalClassFormatException

构造一个具有指定详细消息的 IllegalClassFormatException 。

IllegalComponentStateException - Exception in java.awt

表示AWT组件对于请求的操作不在适当的状态。

IllegalComponentStateException() - Constructor for exception java.awt. IllegalComponentStateException

构造一个没有详细消息的IllegalComponentStateException。

IllegalComponentStateException(String) - Constructor for exception java.awt. IllegalComponentStateException

构造具有指定详细消息的IllegalComponentStateException。

IllegalConnectorArgumentsException - Exception in com.sun.jdi.connect

抛出表示无效参数或不一致传递给Connector 。

IllegalConnectorArgumentsException(String, String) - Constructor for exception com.sun.jdi.connect. IllegalConnectorArgumentsException

构造一个具有指定的详细消息的 IllegalConnectorArgumentsException和无效或不一致的参数的名称。

IllegalConnectorArgumentsException(String, List<String>) - Constructor for exception com.sun.jdi.connect. IllegalConnectorArgumentsException

构建 IllegalConnectorArgumentsException带指定详细消息和 List的参数，其是无效的或不一致的名字。

IllegalFormatCodePointException - Exception in java.util

当将由Character.isValidCodePoint(int)定义的Unicode代码无效的字符传递给Formatter时，将抛出未经检查的异常。

IllegalFormatCodePointException(int) - Constructor for exception java.util. IllegalFormatCodePointException

使用 Character.isValidCodePoint(int)定义的指定的非法代码点构造此类的实例。

IllegalFormatConversionException - Exception in java.util

当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。

IllegalFormatConversionException(char, Class<?>) - Constructor for exception java.util. IllegalFormatConversionException

使用不匹配的转换和相应的参数类构造此类的实例。

IllegalFormatException - Exception in java.util

当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。

IllegalFormatFlagsException - Exception in java.util

提供非法组合标志时抛出未检查的异常。

IllegalFormatFlagsException(String) - Constructor for exception java.util. IllegalFormatFlagsException

使用指定的标志构造此类的实例。

IllegalFormatPrecisionException - Exception in java.util

当精度为 -1以外的负值时，抛出异常异常，转换不支持精度，否则不支持该值。

IllegalFormatPrecisionException(int) - Constructor for exception java.util. IllegalFormatPrecisionException

构造具有指定精度的此类的实例。

IllegalFormatWidthException - Exception in java.util

当格式宽度为 -1以外的否定值时，抛出未经检查的异常，否则不受支持。

IllegalFormatWidthException(int) - Constructor for exception java.util. IllegalFormatWidthException

构造具有指定宽度的此类的实例。

IllegalMonitorStateException - Exception in java.lang

抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。

IllegalMonitorStateException() - Constructor for exception java.lang. IllegalMonitorStateException

构造一个没有详细消息的 IllegalMonitorStateException 。

IllegalMonitorStateException(String) - Constructor for exception java.lang. IllegalMonitorStateException

构造具有指定详细消息的 IllegalMonitorStateException 。

IllegalPathStateException - Exception in java.awt.geom

如果在相对于正在执行的特定操作处于非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段追加到GeneralPath 。

IllegalPathStateException() - Constructor for exception java.awt.geom. IllegalPathStateException

构造一个 IllegalPathStateException ，没有详细消息。

IllegalPathStateException(String) - Constructor for exception java.awt.geom. IllegalPathStateException

构造具有指定详细消息的 IllegalPathStateException 。

IllegalReceiveException - Exception in com.sun.nio.sctp

当试图调用未经检查的异常receive的方法SctpChannel或SctpMultiChannel从通知处理程序。

IllegalReceiveException() - Constructor for exception com.sun.nio.sctp. IllegalReceiveException

构造这个类的一个实例。

IllegalReceiveException(String) - Constructor for exception com.sun.nio.sctp. IllegalReceiveException

使用指定的消息构造此类的实例。

IllegalSelectorException - Exception in java.nio.channels

当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。

IllegalSelectorException() - Constructor for exception java.nio.channels. IllegalSelectorException

构造这个类的一个实例。

IllegalStateException - Exception in java.lang

表示在非法或不适当的时间调用了一种方法。

IllegalStateException() - Constructor for exception java.lang. IllegalStateException

构造一个没有详细消息的IllegalStateException。

IllegalStateException(String) - Constructor for exception java.lang. IllegalStateException

构造具有指定详细消息的IllegalStateException。

IllegalStateException(String, Throwable) - Constructor for exception java.lang. IllegalStateException

构造一个新的异常与指定的详细信息和原因。

IllegalStateException(Throwable) - Constructor for exception java.lang. IllegalStateException

构造具有指定原因的新异常和详细消息 (cause==null ? null : cause.toString()) （通常包含类和详细消息为 cause ）。

IllegalThreadStateException - Exception in java.lang

抛出以指示线程不处于所请求操作的适当状态。

IllegalThreadStateException() - Constructor for exception java.lang. IllegalThreadStateException

构造一个 IllegalThreadStateException ，没有详细消息。

IllegalThreadStateException(String) - Constructor for exception java.lang. IllegalThreadStateException

构造具有指定详细消息的 IllegalThreadStateException 。

IllegalUnbindException - Exception in com.sun.nio.sctp

尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。

IllegalUnbindException() - Constructor for exception com.sun.nio.sctp. IllegalUnbindException

构造这个类的一个实例。

IllegalUnbindException(String) - Constructor for exception com.sun.nio.sctp. IllegalUnbindException

使用指定的详细消息构造此类的实例。

IllformedLocaleException - Exception in java.util

由Locale和Locale.Builder中的方法抛出，以表明参数不是一个格式正确的BCP 47标签。

IllformedLocaleException() - Constructor for exception java.util. IllformedLocaleException

构造一个新的 IllformedLocaleException ，没有详细消息，-1作为错误索引。

IllformedLocaleException(String) - Constructor for exception java.util. IllformedLocaleException

构造一个新的 IllformedLocaleException给定的消息和-1作为错误索引。

IllformedLocaleException(String, int) - Constructor for exception java.util. IllformedLocaleException

构造一个新的 IllformedLocaleException与给定的消息和错误索引。

image - Variable in class javax.imageio. IIOImage

参考的 RenderedImage 。

Image - Class in java.awt

抽象类 Image是表示图形图像的所有类的超类。

Image - Class in javafx.scene.image

Image类表示图形图像，用于从指定的URL加载图像。

Image() - Constructor for class java.awt. Image

Image(InputStream) - Constructor for class javafx.scene.image. Image

构造一个 Image并从指定的输入流中加载内容。

Image(InputStream, double, double, boolean, boolean) - Constructor for class javafx.scene.image. Image

使用指定的参数构建新的 Image 。

Image(String) - Constructor for class javafx.scene.image. Image

构造一个 Image其中包含从指定的url加载的内容。

Image(String, boolean) - Constructor for class javafx.scene.image. Image

使用指定的参数构建新的 Image 。

Image(String, double, double, boolean, boolean) - Constructor for class javafx.scene.image. Image

使用指定的参数构造新的 Image 。

Image(String, double, double, boolean, boolean, boolean) - Constructor for class javafx.scene.image. Image

使用指定的参数构建新的 Image 。

IMAGE - Static variable in class javafx.scene.input. DataFormat

一种特殊的平台特定图像类型，例如通常用于剪贴板并与其他应用程序广泛互操作。

IMAGE - Static variable in interface javax.jnlp. DownloadService2

匹配图像文件 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。

IMAGE_INCOMPATIBLE - Static variable in class java.awt.image. VolatileImage

验证的图像与提供的 GraphicsConfiguration对象不兼容，并应根据需要重新创建。

IMAGE_OK - Static variable in class java.awt.image. VolatileImage

经过验证的图像可以按原样使用。

IMAGE_RESTORED - Static variable in class java.awt.image. VolatileImage

已验证的图像已恢复，现在可以使用。

IMAGE_VIEW - javafx.scene. AccessibleRole

图像查看角色。

IMAGEABORTED - Static variable in interface java.awt.image. ImageConsumer

图像创建过程故意中止。

ImageCapabilities - Class in java.awt

图像的能力和属性。

ImageCapabilities(boolean) - Constructor for class java.awt. ImageCapabilities

创建一个用于指定图像功能的新对象。

imageComplete(int) - Method in class java.awt.image. BufferedImageFilter

过滤 ImageConsumer接口 imageComplete方法中提供的信息。

imageComplete(int) - Method in interface java.awt.image. ImageConsumer

当ImageProducer完成传递源图像所包含的所有像素时，或者当多帧动画的单帧已经完成时，或者当加载或生成图像发生错误时，将调用imageComplete方法。

imageComplete(int) - Method in class java.awt.image. ImageFilter

过滤ImageConsumer界面的imageComplete方法中提供的信息。

imageComplete(int) - Method in class java.awt.image. PixelGrabber

imageComplete方法是ImageConsumer API的一部分，该类必须实现以检索像素。

imageComplete(ImageReader) - Method in interface javax.imageio.event. IIOReadProgressListener

报告当前图像读取操作已完成。

imageComplete(ImageWriter) - Method in interface javax.imageio.event. IIOWriteProgressListener

报告图像写入操作已完成。

ImageConsumer - Interface in java.awt.image

通过ImageProducer界面表示对图像数据感兴趣的对象的界面。

ImageCursor - Class in javafx.scene

鼠标光标的自定义图像表示。

ImageCursor() - Constructor for class javafx.scene. ImageCursor

构造一个新的空的 ImageCursor它将看起来像 Cursor.DEFAULT 。

ImageCursor(Image) - Constructor for class javafx.scene. ImageCursor

从指定的图像构造一个 ImageCursor 。

ImageCursor(Image, double, double) - Constructor for class javafx.scene. ImageCursor

从指定的图像和热点坐标构造一个 ImageCursor 。

IMAGEERROR - Static variable in interface java.awt.image. ImageConsumer

生成图像时遇到错误。

ImageFilter - Class in java.awt.image

此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。

ImageFilter() - Constructor for class java.awt.image. ImageFilter

imageFlavor - Static variable in class java.awt.datatransfer. DataFlavor

代表Java Image类的 DataFlavor其中：

ImageGraphicAttribute - Class in java.awt.font

该ImageGraphicAttribute类的实现GraphicAttribute其中提请在图像TextLayout 。

ImageGraphicAttribute(Image, int) - Constructor for class java.awt.font. ImageGraphicAttribute

构造一个ImageGraphicAttribute从指定Image 。

ImageGraphicAttribute(Image, int, float, float) - Constructor for class java.awt.font. ImageGraphicAttribute

构造一个 ImageGraphicAttribute从指定 Image 。

ImageIcon - Class in javax.swing

从图像绘制图标的图标界面的实现。

ImageIcon() - Constructor for class javax.swing. ImageIcon

创建未初始化的图像图标。

ImageIcon(byte[]) - Constructor for class javax.swing. ImageIcon

从包含支持的图像格式（如GIF，JPEG或（1.3）PNG）的图像文件中读取的字节数组创建一个ImageIcon。

ImageIcon(byte[], String) - Constructor for class javax.swing. ImageIcon

从包含支持的图像格式（如GIF，JPEG或（1.3）PNG）的图像文件中读取的字节数组创建一个ImageIcon。

ImageIcon(Image) - Constructor for class javax.swing. ImageIcon

从图像对象创建一个ImageIcon。

ImageIcon(Image, String) - Constructor for class javax.swing. ImageIcon

从图像创建一个ImageIcon。

ImageIcon(String) - Constructor for class javax.swing. ImageIcon

从指定的文件创建一个ImageIcon。

ImageIcon(String, String) - Constructor for class javax.swing. ImageIcon

从指定的文件创建一个ImageIcon。

ImageIcon(URL) - Constructor for class javax.swing. ImageIcon

从指定的URL创建一个ImageIcon。

ImageIcon(URL, String) - Constructor for class javax.swing. ImageIcon

从指定的URL创建一个ImageIcon。

ImageIcon.AccessibleImageIcon - Class in javax.swing

该类实现 ImageIcon类的辅助功能支持。

ImageInput - Class in javafx.scene.effect

一种源效果，只是将给定的 Image通过，未修改，作为输入到另一个 Effect 。

ImageInput() - Constructor for class javafx.scene.effect. ImageInput

使用默认参数创建一个新的ImageInput实例。

ImageInput(Image) - Constructor for class javafx.scene.effect. ImageInput

使用指定的源创建一个新的ImageInput实例。

ImageInput(Image, double, double) - Constructor for class javafx.scene.effect. ImageInput

使用指定的源x和y创建一个新的ImageInput实例。

ImageInputStream - Interface in javax.imageio.stream

一个可寻求的输入流接口，供 ImageReader使用。

ImageInputStreamImpl - Class in javax.imageio.stream

一个实现 ImageInputStream接口的抽象类。

ImageInputStreamImpl() - Constructor for class javax.imageio.stream. ImageInputStreamImpl

构造一个 ImageInputStreamImpl 。

ImageInputStreamSpi - Class in javax.imageio.spi

服务提供商接口（SPI），用于 ImageInputStream s。

ImageInputStreamSpi() - Constructor for class javax.imageio.spi. ImageInputStreamSpi

构造空白 ImageInputStreamSpi 。

ImageInputStreamSpi(String, String, Class<?>) - Constructor for class javax.imageio.spi. ImageInputStreamSpi

构造一个给定值的一个 ImageInputStreamSpi 。

ImageIO - Class in javax.imageio

一个包含静态方便方法的类，用于定位 ImageReader和 ImageWriter ，并执行简单的编码和解码。

ImageObserver - Interface in java.awt.image

异步更新界面用于在构建图像时接收关于图像信息的通知。

ImageOutputStream - Interface in javax.imageio.stream

一个可寻求的输出流接口，供 ImageWriter使用。

ImageOutputStreamImpl - Class in javax.imageio.stream

一个实现 ImageOutputStream接口的抽象类。

ImageOutputStreamImpl() - Constructor for class javax.imageio.stream. ImageOutputStreamImpl

构造一个 ImageOutputStreamImpl 。

ImageOutputStreamSpi - Class in javax.imageio.spi

ImageOutputStream的服务提供商接口（SPI）。

ImageOutputStreamSpi() - Constructor for class javax.imageio.spi. ImageOutputStreamSpi

构造一个空白的 ImageOutputStreamSpi 。

ImageOutputStreamSpi(String, String, Class<?>) - Constructor for class javax.imageio.spi. ImageOutputStreamSpi

构造一个给定值的一个 ImageOutputStreamSpi 。

ImagePattern - Class in javafx.scene.paint

ImagePattern类用图像模式填充形状。

ImagePattern(Image) - Constructor for class javafx.scene.paint. ImagePattern

从指定的图像创建一个新的ImagePattern实例。

ImagePattern(Image, double, double, double, double, boolean) - Constructor for class javafx.scene.paint. ImagePattern

创建一个新的ImagePattern实例。

ImageProducer - Interface in java.awt.image

可以为图像生成图像数据的对象的界面。

imageProgress(ImageReader, float) - Method in interface javax.imageio.event. IIOReadProgressListener

报告当前完成近似程度 read调用相关的 ImageReader 。

imageProgress(ImageWriter, float) - Method in interface javax.imageio.event. IIOWriteProgressListener

报告相关 ImageWriter内的当前 write电话的大致完成程度。

imageProperty() - Method in class javafx.scene.image. ImageView

这个Image要画ImageView 。

imageProperty() - Method in class javafx.scene. ImageCursor

光标激活时显示的图像。

ImageReader - Class in javax.imageio

用于解析和解码图像的抽象超类。

ImageReader(ImageReaderSpi) - Constructor for class javax.imageio. ImageReader

构造一个 ImageReader并将其 originatingProvider字段设置为提供的值。

ImageReaderSpi - Class in javax.imageio.spi

ImageReader的服务提供商接口（SPI）。

ImageReaderSpi() - Constructor for class javax.imageio.spi. ImageReaderSpi

构造一个空白 ImageReaderSpi 。

ImageReaderSpi(String, String, String[], String[], String[], String, Class<?>[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi. ImageReaderSpi

构造一个给定值的一个 ImageReaderSpi 。

ImageReaderWriterSpi - Class in javax.imageio.spi

一个包含实例变量的超类和 ImageReaderSpi和 ImageWriterSpi共同的方法。

ImageReaderWriterSpi() - Constructor for class javax.imageio.spi. ImageReaderWriterSpi

构造一个空白的 ImageReaderWriterSpi 。

ImageReaderWriterSpi(String, String, String[], String[], String[], String, boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi. ImageReaderWriterSpi

构造一个给定值的一个 ImageReaderWriterSpi 。

ImageReadParam - Class in javax.imageio

描述流如何解码的类。

ImageReadParam() - Constructor for class javax.imageio. ImageReadParam

构造一个 ImageReadParam 。

imageStarted(ImageReader, int) - Method in interface javax.imageio.event. IIOReadProgressListener

报告图像读取操作开始。

imageStarted(ImageWriter, int) - Method in interface javax.imageio.event. IIOWriteProgressListener

报告图像写入操作开始。

imageSubmit(String) - Method in class javax.swing.text.html. FormView

调用此方法以响应点击图像 - “image”类型的<INPUT>表单元素提交表单。

ImageTranscoder - Interface in javax.imageio

提供元数据转码功能的界面。

ImageTranscoderSpi - Class in javax.imageio.spi

ImageTranscoder的服务提供商接口（SPI）。

ImageTranscoderSpi() - Constructor for class javax.imageio.spi. ImageTranscoderSpi

构造一个空白 ImageTranscoderSpi 。

ImageTranscoderSpi(String, String) - Constructor for class javax.imageio.spi. ImageTranscoderSpi

构造一个给定值的一个 ImageTranscoderSpi 。

ImageTypeSpecifier - Class in javax.imageio

允许以方便的方式指定图像的格式（特别是其 SampleModel和 ColorModel ）的类。

ImageTypeSpecifier(ColorModel, SampleModel) - Constructor for class javax.imageio. ImageTypeSpecifier

构造一个 ImageTypeSpecifier直接从 ColorModel和 SampleModel 。

ImageTypeSpecifier(RenderedImage) - Constructor for class javax.imageio. ImageTypeSpecifier

构造一个 ImageTypeSpecifier从 RenderedImage 。

imageUpdate(Image, int, int, int, int, int) - Method in class java.awt. Component

当图像发生变化时重新编辑组件。

imageUpdate(Image, int, int, int, int, int) - Method in interface java.awt.image. ImageObserver

当先前使用异步接口请求的图像的信息变得可用时，将调用此方法。

imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing. AbstractButton

如果当前的 Icon的 Image不等于 Image img传递的值，则这被覆盖返回false。

imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing. JLabel

如果当前图标的图像不等于图像 img传递的图像，则这被覆盖以返回false。

imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing. JLayer

将其功能委托给 LayerUI.imageUpdate(java.awt.Image, int, int, int, int, int, JLayer)方法，如果设置了 LayerUI 。

imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing. JSlider

当图像发生变化时重新编辑组件。

imageUpdate(Image, int, int, int, int, int, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI

将其功能委托给继承自 JLayer的基类的 JLayer.imageUpdate方法的默认实现。

imageUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event. IIOReadUpdateListener

报告图像的给定区域已更新。

ImageView - Class in javafx.scene.image

ImageView是一个Node用于绘制图像加载Image类。

ImageView - Class in javax.swing.text.html

视图，旨在支持HTML <IMG>标签。

ImageView() - Constructor for class javafx.scene.image. ImageView

分配一个新的ImageView对象。

ImageView(String) - Constructor for class javafx.scene.image. ImageView

分配一个新的ImageView对象，并从指定的URL加载图像。

ImageView(Image) - Constructor for class javafx.scene.image. ImageView

使用给定的图像分配一个新的ImageView对象。

ImageView(Element) - Constructor for class javax.swing.text.html. ImageView

创建一个代表IMG元素的新视图。

ImageWriteParam - Class in javax.imageio

描述流如何编码的类。

ImageWriteParam() - Constructor for class javax.imageio. ImageWriteParam

构造一个空的 ImageWriteParam 。

ImageWriteParam(Locale) - Constructor for class javax.imageio. ImageWriteParam

构造一个 ImageWriteParam集使用给定的 Locale 。

ImageWriter - Class in javax.imageio

用于编码和写入图像的抽象超类。

ImageWriter(ImageWriterSpi) - Constructor for class javax.imageio. ImageWriter

构造一个 ImageWriter并将其 originatingProvider实例变量设置为提供的值。

ImageWriterSpi - Class in javax.imageio.spi

服务提供商接口（SPI），用于 ImageWriter s。

ImageWriterSpi() - Constructor for class javax.imageio.spi. ImageWriterSpi

构造空白 ImageWriterSpi 。

ImageWriterSpi(String, String, String[], String[], String[], String, Class<?>[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi. ImageWriterSpi

构造一个给定值的一个 ImageWriterSpi 。

ImagingOpException - Exception in java.awt.image

所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。

ImagingOpException(String) - Constructor for exception java.awt.image. ImagingOpException

使用指定的消息构造一个 ImagingOpException对象。

IMG - Static variable in class javax.swing.text.html. HTML.Tag

标签<img>

IMG_ALIGN_BOTTOM - Static variable in class javax.swing.text.html. HTMLEditorKit

将图像对齐在底部。

IMG_ALIGN_MIDDLE - Static variable in class javax.swing.text.html. HTMLEditorKit

在中间对齐图像。

IMG_ALIGN_TOP - Static variable in class javax.swing.text.html. HTMLEditorKit

将图像对齐在顶部。

IMG_BORDER - Static variable in class javax.swing.text.html. HTMLEditorKit

在边框对齐图像。

IMMUTABLE - Static variable in interface java.util. Spliterator

特征值表示元素源不能在结构上进行修改; 也就是说，不能添加，替换或删除元素，因此在遍历过程中不会发生这种更改。

IMMUTABLE_INFO_FIELD - Static variable in class javax.management. JMX

名称为 immutableInfo字段。

ImmutableDescriptor - Class in javax.management

一个不可变的描述符。

ImmutableDescriptor(String...) - Constructor for class javax.management. ImmutableDescriptor

构造一个包含给定字段的描述符。

ImmutableDescriptor(String[], Object[]) - Constructor for class javax.management. ImmutableDescriptor

构造一个包含给定字段和值的描述符。

ImmutableDescriptor(Map<String, ?>) - Constructor for class javax.management. ImmutableDescriptor

构造描述符，其中字段的名称和值是给定Map的键和值。

IMP_LIMIT - Exception in org.omg.CORBA

此异常表示在ORB运行时间中超出了实施限制。

IMP_LIMIT() - Constructor for exception org.omg.CORBA. IMP_LIMIT

构造一个 IMP_LIMIT异常，默认次要代码为0，完成状态为COMPLETED_NO。

IMP_LIMIT(int, CompletionStatus) - Constructor for exception org.omg.CORBA. IMP_LIMIT

构造具有指定的次要代码和完成状态的 IMP_LIMIT异常。

IMP_LIMIT(String) - Constructor for exception org.omg.CORBA. IMP_LIMIT

构造一个 IMP_LIMIT异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

IMP_LIMIT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. IMP_LIMIT

构造一个 IMP_LIMIT异常，指定的详细消息，次要代码和完成状态。

IMPERIAL_ARAMAIC - java.lang. Character.UnicodeScript

Unicode脚本“Imperial_Aramaic”。

IMPERIAL_ARAMAIC - Static variable in class java.lang. Character.UnicodeBlock

“皇家阿拉姆语”Unicode字符块的常数。

impersonate(GSSName) - Method in interface com.sun.security.jgss. ExtendedGSSCredential

假冒一名校长

implAccept(Socket) - Method in class java.net. ServerSocket

ServerSocket的子类使用这个方法来覆盖accept（）来返回自己的套接字子类。

implCloseChannel() - Method in class java.nio.channels.spi. AbstractInterruptibleChannel

关闭此频道。

implCloseChannel() - Method in class java.nio.channels.spi. AbstractSelectableChannel

关闭此频道。

implCloseSelectableChannel() - Method in class java.nio.channels.spi. AbstractSelectableChannel

关闭此可选择的频道。

implCloseSelector() - Method in class java.nio.channels.spi. AbstractSelector

关闭此选择器。

implConfigureBlocking(boolean) - Method in class java.nio.channels.spi. AbstractSelectableChannel

调整此频道的屏蔽模式。

IMPLEMENTATION_TITLE - Static variable in class java.util.jar. Attributes.Name

Name对象为 Implementation-Title用于包版本控制的manifest属性。

IMPLEMENTATION_URL - Static variable in class java.util.jar. Attributes.Name

已过时。
扩展机制不再受支持。

IMPLEMENTATION_VENDOR - Static variable in class java.util.jar. Attributes.Name

Name对象为 Implementation-Vendor用于包版本控制的manifest属性。

IMPLEMENTATION_VENDOR_ID - Static variable in class java.util.jar. Attributes.Name

已过时。
扩展机制不再受支持。

IMPLEMENTATION_VERSION - Static variable in class java.util.jar. Attributes.Name

Name对象为 Implementation-Version用于包版本控制的清单属性。

implementors() - Method in interface com.sun.jdi. InterfaceType

获取直接实现此接口的当前准备的类。

implFlush(ByteBuffer) - Method in class java.nio.charset. CharsetEncoder

刷新编码器。

implFlush(CharBuffer) - Method in class java.nio.charset. CharsetDecoder

刷新此解码器。

IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer. ImplicitActivationPolicyValue

IMPLICIT_ACTIVATION_POLICY_ID - Interface in org.omg.PortableServer

org / omg / PortableServer / IMPLICIT_ACTIVATION_POLICY_ID.java。

ImplicitActivationPolicy - Interface in org.omg.PortableServer

此策略指定在创建的POA中是否支持仆人的隐式激活。

ImplicitActivationPolicyOperations - Interface in org.omg.PortableServer

此策略指定在创建的POA中是否支持仆人的隐式激活。

ImplicitActivationPolicyValue - Class in org.omg.PortableServer

ImplicitActivationPolicyValue具有以下语义。

ImplicitActivationPolicyValue(int) - Constructor for class org.omg.PortableServer. ImplicitActivationPolicyValue

IMPLIED - Static variable in class javax.swing.text.html. HTML.Tag

所有文本内容必须在段落元素中。

IMPLIED - Static variable in class javax.swing.text.html. HTMLEditorKit.ParserCallback

这是作为属性集中的一个属性传递的，以表示元素是隐含的，例如，字符串'<> foo <\ t>'包含隐含的html元素和隐含的body元素。

IMPLIED - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于IMPLIED

implies(CodeSource) - Method in class java.security. CodeSource

如果此CodeSource对象“暗示”指定的CodeSource，则返回true。

implies(Permission) - Method in class java.io. FilePermission

检查此FilePermission对象是否“暗示”指定的权限。

implies(Permission) - Method in class java.net. SocketPermission

检查此套接字许可对象是否“暗示”指定的权限。

implies(Permission) - Method in class java.net. URLPermission

检查此URLPermission是否意味着给定的权限。

implies(Permission) - Method in class java.security. AllPermission

检查指定的权限是否被该对象“隐含”。

implies(Permission) - Method in class java.security. BasicPermission

检查指定的权限是否被该对象“隐含”。

implies(Permission) - Method in class java.security. Permission

检查指定权限的操作是否由此对象的操作“隐含”。

implies(Permission) - Method in class java.security. PermissionCollection

检查此PermissionCollection中持有的Permission对象的集合是否暗示了指定的权限。

implies(Permission) - Method in class java.security. Permissions

检查此对象的PermissionCollection是否具有指定权限类的权限，这意味着在 权限对象中表达的 权限 。

implies(Permission) - Method in class java.security. ProtectionDomain

检查并看看ProtectionDomain是否隐含在Permission对象中表达的权限。

implies(Permission) - Method in class java.security. UnresolvedPermission

对于未解决的权限，此方法总是返回false。

implies(Permission) - Method in class java.util. PropertyPermission

检查此PropertyPermission对象是否“暗示”指定的权限。

implies(Permission) - Method in class javax.management. MBeanPermission

检查这个MBeanPermission对象是否“暗示”指定的权限。

implies(Permission) - Method in class javax.management. MBeanServerPermission

检查此MBeanServerPermission对象是否“暗示”指定的权限。

implies(Permission) - Method in class javax.security.auth.kerberos. DelegationPermission

检查此Kerberos委托许可对象是否“暗示”指定的权限。

implies(Permission) - Method in class javax.security.auth.kerberos. ServicePermission

检查此Kerberos服务权限对象是否“暗示”指定的权限。

implies(Permission) - Method in class javax.security.auth. PrivateCredentialPermission

检查这个 PrivateCredentialPermission意味着指定的 Permission 。

implies(Permission) - Method in class javax.smartcardio. CardPermission

检查此CardPermission对象是否意味着指定的权限。

implies(ProtectionDomain, Permission) - Method in class java.security. Policy

评估授予ProtectionDomain的权限的全局策略，并测试是否授予权限。

implies(Subject) - Method in interface com.sun.security.auth. PrincipalComparator

检查该对象是否暗示了指定的 Subject 。

implies(Subject) - Method in interface java.security. Principal

如果该主体隐含指定的主题，则返回true。

implOnMalformedInput(CodingErrorAction) - Method in class java.nio.charset. CharsetDecoder

报告对此解码器的格式错误的输入操作的更改。

implOnMalformedInput(CodingErrorAction) - Method in class java.nio.charset. CharsetEncoder

报告对该编码器的格式错误的输入操作的更改。

implOnUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset. CharsetDecoder

报告对此解码器的不可映射角色操作的更改。

implOnUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset. CharsetEncoder

报告此编码器的不可映射角色动作的更改。

implReplaceWith(byte[]) - Method in class java.nio.charset. CharsetEncoder

报告对该编码器的替换值的更改。

implReplaceWith(String) - Method in class java.nio.charset. CharsetDecoder

报告对该解码器的替换值的更改。

implReset() - Method in class java.nio.charset. CharsetDecoder

重置此解码器，清除特定于字符集的内部状态。

implReset() - Method in class java.nio.charset. CharsetEncoder

复位该编码器，清除任何字符集特定的内部状态。

IMPORT - com.sun.source.tree. Tree.Kind

用于ImportTree的实例。

IMPORT - jdk.jshell. Snippet.Kind

进口申报： import ...

IMPORT_ENTRY - jdk.nashorn.api.tree. Tree.Kind

用于ImportEntryTree的实例。

IMPORT_PROCESSING_INSTRUCTION - Static variable in class javafx.fxml. FXMLLoader

导入处理指令的标签名称。

IMPORT_RULE - Static variable in interface org.w3c.dom.css. CSSRule

规则是一个 CSSImportRule 。

importData(JComponent, Transferable) - Method in class javax.swing. TransferHandler

导致从剪贴板或DND丢弃操作传输到组件。

importData(TransferHandler.TransferSupport) - Method in class javax.swing. TransferHandler

导致从剪贴板或拖放操作发生转移。

importedClasses() - Method in interface com.sun.javadoc. ClassDoc

已过时。
导入声明是不应该在这里公开的实现细节。 另外，并不是所有导入的类都是通过单一类型导入的声明导入的。

importedKeyCascade - Static variable in interface java.sql. DatabaseMetaData

对于列 UPDATE_RULE ，表示当主键被更新时，外键（导入的键）被更改以与其一致。

importedKeyInitiallyDeferred - Static variable in interface java.sql. DatabaseMetaData

表示延迟。

importedKeyInitiallyImmediate - Static variable in interface java.sql. DatabaseMetaData

表示延迟。

importedKeyNoAction - Static variable in interface java.sql. DatabaseMetaData

对于列 UPDATE_RULE和 DELETE_RULE ，表示如果主键已导入，则不能更新或删除。

importedKeyNotDeferrable - Static variable in interface java.sql. DatabaseMetaData

表示延迟。

importedKeyRestrict - Static variable in interface java.sql. DatabaseMetaData

对于列 UPDATE_RULE ，表示主键可能不被更新，如果它已被其他表导入为外键。

importedKeySetDefault - Static variable in interface java.sql. DatabaseMetaData

对于列 UPDATE_RULE和 DELETE_RULE ，表示如果主键被更新或删除，则外键（导入的键）被设置为默认值。

importedKeySetNull - Static variable in interface java.sql. DatabaseMetaData

对于列 UPDATE_RULE和 DELETE_RULE ，表示当主键被更新或删除时，外键（导入的键）被更改为 NULL 。

importedPackages() - Method in interface com.sun.javadoc. ClassDoc

已过时。
导入声明是不应该在这里公开的实现细节。 此外，此方法的返回类型不允许返回所有类型导入按需的声明。

ImportEntryTree - Interface in jdk.nashorn.api.tree

用于导入条目的树节点 Module information 。

importNode(Node, boolean) - Method in interface org.w3c.dom. Document

将节点从另一个文档导入到本文档中，而不从原始文档更改或删除源节点; 此方法创建源节点的新副本。

importPreferences(InputStream) - Static method in class java.util.prefs. Preferences

在指定的输入流中导入由XML文档表示的所有首选项。

imports() - Method in class jdk.jshell. JShell

返回活动的导入片段。

ImportSnippet - Class in jdk.jshell

导入声明的代码段。

importStyleSheet(URL) - Method in class javax.swing.text.html. StyleSheet

从 url导入样式表。

ImportTree - Interface in com.sun.source.tree

导入声明的树节点。

in - Static variable in class java.io. FileDescriptor

标准输入流的句柄。

in - Variable in class java.io. FilterInputStream

要过滤的输入流。

in - Variable in class java.io. FilterReader

底层字符输入流。

in - Variable in class java.io. PipedInputStream

在从连接的管道输出流接收到的数据的下一个字节将被存储的循环缓冲区中的位置的索引。

in - Static variable in class java.lang. System

“标准”输入流。

in(InputStream) - Method in class jdk.jshell. JShell.Builder

设置运行评估的输入（它是 System.in ）。

in(InputStream, InputStream) - Method in interface jdk.jshell.tool. JavaShellToolBuilder

设置输入通道。

in(Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup

在指定的新查找类上创建一个查找。

in(ValueExp, ValueExp[]) - Static method in class javax.management. Query

返回一个将值限制为显式列表的表达式。

IN - javafx.css. SizeUnits

IN - javax.jws. WebParam.Mode

IN - jdk.nashorn.api.tree. Tree.Kind

用于代表操作员in的BinaryTree的实例。

IN_PROGRESS - jdk.net. SocketFlow.Status

正在创建一个流程。

InaccessibleObjectException - Exception in java.lang.reflect

Java语言访问检查无法被抑制时抛出。

InaccessibleObjectException() - Constructor for exception java.lang.reflect. InaccessibleObjectException

构造一个 InaccessibleObjectException ，没有详细消息。

InaccessibleObjectException(String) - Constructor for exception java.lang.reflect. InaccessibleObjectException

构造具有给定详细信息的 InaccessibleObjectException 。

inactive(ActivationID) - Static method in class java.rmi.activation. Activatable

通知系统当前激活的对象 id当前处于非活动状态。

INACTIVE - Interface in org.omg.PortableInterceptor

org / omg / PortableInterceptor / INACTIVE.java。

INACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage. State

INACTIVE_CAPTION - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.inactiveCaption系统颜色。

INACTIVE_CAPTION_BORDER - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.inactiveCaptionBorder系统颜色。

INACTIVE_CAPTION_TEXT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.inactiveCaptionText系统颜色。

inactiveCaption - Static variable in class java.awt. SystemColor

为非活动窗口的窗口标题背景呈现的颜色。

inactiveCaptionBorder - Static variable in class java.awt. SystemColor

为不活动窗口周围的边框渲染颜色。

inactiveCaptionText - Static variable in class java.awt. SystemColor

为非活动窗口的窗口标题文本呈现的颜色。

inactiveGroup() - Method in class java.rmi.activation. ActivationGroup

这个受保护的方法对于子类来说是必需的，以使 inactiveGroup回调到组的监视器。

inactiveGroup(ActivationGroupID, long) - Method in interface java.rmi.activation. ActivationMonitor

通知组现在处于非活动状态。

inactiveObject(ActivationID) - Method in class java.rmi.activation. ActivationGroup

该组的 inactiveObject方法通过调用 Activatable.inactive方法间接调用。

inactiveObject(ActivationID) - Method in interface java.rmi.activation. ActivationMonitor

激活组在其组中的对象变为无效（停用）时调用其监视器的 inactiveObject方法。

INBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler. MessageContext

标准属性：入站邮件的邮件附件地图，密钥是MIME Content-ID，值是DataHandler。

incarnate(byte[], POA) - Method in class org.omg.PortableServer. _ServantActivatorStub

假设POA具有USE_SERVANT_MANAGER和RETAIN策略，POA每当POA收到对当前不活动的对象的请求时，POA将调用此操作。

incarnate(byte[], POA) - Method in interface org.omg.PortableServer. ServantActivatorOperations

假设POA具有USE_SERVANT_MANAGER和RETAIN策略，POA每当POA收到对当前不活动的对象的请求时，POA将调用此操作。

INCH - Static variable in class javax.print.attribute. Size2DSyntax

值表示英寸单位（英寸）。

INCH - Static variable in class javax.print.attribute.standard. MediaPrintableArea

值表示英寸单位（英寸）。

inCheck - Variable in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此字段在将来的Java SE版本中可能会被删除。

inClass(String) - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。

inClassLoader() - Method in class java.lang. SecurityManager

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。

include(RowFilter.Entry<? extends M, ? extends I>) - Method in class javax.swing. RowFilter

如果指定的条目应该显示，则返回true; 如果条目应该隐藏，则返回false。

INCLUDE_CHARSET_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader

<fx：include>'charset'属性。

INCLUDE_RESOURCES_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader

<fx：include>'资源'属性。

INCLUDE_SOURCE_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader

<fx：include>'source'属性。

INCLUDE_TAG - Static variable in class javafx.fxml. FXMLLoader

标签名称为<fx：include>。

inclusions - Variable in class javax.swing.text.html.parser. Element

可以在元素内发生的一组元素

INCLUSIVE - Static variable in interface javax.xml.crypto.dsig. CanonicalizationMethod

Canonical XML (without comments)规范化方法算法URI。

INCLUSIVE_WITH_COMMENTS - Static variable in interface javax.xml.crypto.dsig. CanonicalizationMethod

Canonical XML with comments规范化方法算法URI。

IncompatibleClassChangeError - Error in java.lang

当一些类定义发生不兼容的类更改时抛出。

IncompatibleClassChangeError() - Constructor for error java.lang. IncompatibleClassChangeError

构造一个没有详细消息的 IncompatibleClassChangeError 。

IncompatibleClassChangeError(String) - Constructor for error java.lang. IncompatibleClassChangeError

构造具有指定详细消息的 IncompatibleClassChangeError 。

IncompatibleThreadStateException - Exception in com.sun.jdi

抛出以指示所请求的操作在指定线程处于当前状态时无法完成。

IncompatibleThreadStateException() - Constructor for exception com.sun.jdi. IncompatibleThreadStateException

IncompatibleThreadStateException(String) - Constructor for exception com.sun.jdi. IncompatibleThreadStateException

IncompleteAnnotationException - Exception in java.lang.annotation

抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。

IncompleteAnnotationException(Class<? extends Annotation>, String) - Constructor for exception java.lang.annotation. IncompleteAnnotationException

构造一个IncompleteAnnotationException来指示指定的元素在指定的注释类型中丢失。

InconsistentDebugInfoException - Exception in com.sun.jdi

被抛出以表明目标VM提供的调试信息有不一致之处。

InconsistentDebugInfoException() - Constructor for exception com.sun.jdi. InconsistentDebugInfoException

InconsistentDebugInfoException(String) - Constructor for exception com.sun.jdi. InconsistentDebugInfoException

InconsistentTypeCode - Exception in org.omg.CORBA.ORBPackage

尝试创建一个不符合 DynAny特定子类的类型代码的动态任务时，会抛出 DynAny 。

InconsistentTypeCode - Exception in org.omg.DynamicAny.DynAnyFactoryPackage

org / omg / DynamicAny / DynAnyFactoryPackage / InconsistentTypeCode.java。

InconsistentTypeCode() - Constructor for exception org.omg.CORBA.ORBPackage. InconsistentTypeCode

构造一个没有原因消息的 InconsistentTypeCode用户异常。

InconsistentTypeCode() - Constructor for exception org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCode

InconsistentTypeCode(String) - Constructor for exception org.omg.CORBA.ORBPackage. InconsistentTypeCode

构造具有指定原因消息的 InconsistentTypeCode用户异常。

InconsistentTypeCode(String) - Constructor for exception org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCode

InconsistentTypeCodeHelper - Class in org.omg.DynamicAny.DynAnyFactoryPackage

org / omg / DynamicAny / DynAnyFactoryPackage / InconsistentTypeCodeHelper.java。

InconsistentTypeCodeHelper() - Constructor for class org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCodeHelper

inConstructor() - Method in interface com.sun.tools.doclets. Taglet

已过时。

如果在构造函数文档中使用了这个 Taglet则返回true。

incrButton - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

增量按钮

INCREASE_HIGHLIGHT - Static variable in class javax.swing.plaf.basic. BasicScrollBarUI

增加亮点

increaseButton - Variable in class javax.swing.plaf.metal. MetalScrollBarUI

增加按钮。

increment() - Method in class java.util.concurrent.atomic. LongAdder

相当于 add(1) 。

increment() - Method in class javafx.scene.control. ScrollBar

由 unitIncrement增加 ScrollBar的 价值

increment() - Method in class javafx.scene.control. Slider

将值增加 blockIncrement ，由最大值

increment() - Method in class javafx.scene.control. Spinner

尝试将 value factory增加一步，通过调用一个参数的 SpinnerValueFactory.increment(int)方法。

increment(int) - Method in class javafx.scene.control. Spinner

尝试通过调用 SpinnerValueFactory.increment(int)方法并转发步骤参数来增加 value factory给定的步数。

increment(int) - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory

试图通过给定的步数来弥补 value 。

increment(int) - Method in class javafx.scene.control. SpinnerValueFactory

试图通过给定的步数来弥补 value 。

increment(int) - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

试图通过给定的步数来弥补 value 。

increment(int) - Method in class javafx.scene.control. SpinnerValueFactory.ListSpinnerValueFactory

试图通过给定的步数来弥补 value 。

INCREMENT - javafx.scene. AccessibleAction

请求节点递增一个较小的值。

INCREMENT - Static variable in interface javax.accessibility. AccessibleAction

增加值的动作。

INCREMENT_BUTTON - javafx.scene. AccessibleRole

增量按钮角色。

incrementAndGet() - Method in class java.util.concurrent.atomic. AtomicInteger

按照 VarHandle.getAndAdd(java.lang.Object...)所规定的内存效果，原子地增加当前值。

incrementAndGet() - Method in class java.util.concurrent.atomic. AtomicLong

以 VarHandle.getAndAdd(java.lang.Object...)指定的内存效应原子地递增当前值。

incrementAndGet(int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

在索引号 i原子方式递增元素的值，其值由 VarHandle.getAndAdd(java.lang.Object...)指定。

incrementAndGet(int) - Method in class java.util.concurrent.atomic. AtomicLongArray

按索引 i原子地增加元素的值，具有由 VarHandle.getAndAdd(java.lang.Object...)指定的内存效果。

incrementAndGet(T) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

由此更新程序管理的给定对象的字段的当前值以原子方式递增1。

incrementAndGet(T) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

由此更新程序管理的给定对象的字段的当前值以原子方式递增1。

incrementAnimationIndex() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

将当前动画帧的索引设置为下一个有效值，这将导致进度条被重新绘制。

incrementExact(int) - Static method in class java.lang. Math

返回一个增加1的参数，如果结果溢出一个 int ，则抛出异常。

incrementExact(long) - Static method in class java.lang. Math

返回一个加1的参数，如果结果溢出一个 long ，则抛出异常。

incrGap - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

增量按钮和轨道之间的距离。

incrIndent() - Method in class javax.swing.text. AbstractWriter

增加缩进级别。

inDaylightTime(Date) - Method in class java.util. SimpleTimeZone

查询给定日期是否在夏令时。

inDaylightTime(Date) - Method in class java.util. TimeZone

查询给定的 date是否在此时区的 date时制。

INDEFINITE - Static variable in class javafx.animation. Animation

用于指定无限期重复的动画，直到调用 stop()方法。

INDEFINITE - Static variable in class javafx.scene.media. AudioClip

当 cycleCount设置为此值时， AudioClip将连续循环，直到停止。

INDEFINITE - Static variable in class javafx.scene.media. MediaPlayer

表示有效无限数量的回放周期的值。

INDEFINITE - Static variable in class javafx.util. Duration

无限期。

INDEFINITE_LIFETIME - Static variable in interface org.ietf.jgss. GSSContext

一个代表不确定上下文生命周期的生命周期。

INDEFINITE_LIFETIME - Static variable in interface org.ietf.jgss. GSSCredential

代表无限期凭证寿命的终生常数。

indent() - Method in class javax.swing.text. AbstractWriter

缩进

INDENT - javafx.scene.web. HTMLEditorSkin.Command

INDENT - javax.swing. LayoutStyle.ComponentPlacement

正在请求指示缩进组件的距离的枚举值。

INDENT - Static variable in class javax.xml.transform. OutputKeys

indent =“yes”| “没有”。

indentProperty() - Method in class javafx.scene.control.skin. TreeCellSkin

要获取树形单元格的左边距的树形空间乘以的空间量。

indentProperty() - Method in class javafx.scene.control.skin. TreeTableRowSkin

要获取树形单元格的左边距的树形空间乘以的空间量。

independentProperty() - Method in class javafx.scene.control. CheckBoxTreeItem

A BooleanProperty用于表示此CheckBoxTreeItem的独立状态。

INDETERMINATE - java.awt. Taskbar.State

进度指示器显示活动而不指定进度完成的比例。

INDETERMINATE - javafx.scene. AccessibleAttribute

返回true的节点是indeterminaite，否则为false。

INDETERMINATE - jdk.dynalink.linker. ConversionComparator.Comparison

无法比较转换。

INDETERMINATE - Static variable in class javafx.scene.control. Pagination

用于指示页数不确定的值。

INDETERMINATE - Static variable in class javax.accessibility. AccessibleState

表示对象状态不确定。

INDETERMINATE - Static variable in class javax.xml.datatype. DatatypeConstants

比较结果。

INDETERMINATE_PROGRESS - Static variable in class javafx.scene.control. ProgressIndicator

进度值显示进度是不确定的。

indeterminateProperty() - Method in class javafx.scene.control. CheckBox

确定复选框是否处于不确定状态。

indeterminateProperty() - Method in class javafx.scene.control. CheckBoxTreeItem

A BooleanProperty用于表示此CheckBoxTreeItem的不确定状态。

indeterminateProperty() - Method in class javafx.scene.control. ProgressIndicator

指示是否可以确定ProgressIndicator的进度的标志。

index - Variable in class javax.swing.text.html.parser. Element

元素索引

index - Variable in exception org.omg.PortableServer.POAPackage. InvalidPolicy

INDEX - com.sun.source.doctree. DocTree.Kind

用于表示搜索项的IndexTree的实例。

INDEX - javafx.scene. AccessibleAttribute

返回节点的索引。

INDEX_SIZE_ERR - Static variable in exception org.w3c.dom. DOMException

如果索引或大小为负，或大于允许的值。

indexAtLocation(int, int) - Method in class javax.swing. JTabbedPane

返回与其边界与指定位置相交的选项卡对应的选项卡索引。

IndexColorModel - Class in java.awt.image

IndexColorModel类是一个 ColorModel类，适用于由单个样本组成的像素值，该样本是默认sRGB颜色空间中固定色彩映射的索引。

IndexColorModel(int, int, byte[], byte[], byte[]) - Constructor for class java.awt.image. IndexColorModel

从指定的红色，绿色和蓝色组件数组构造一个 IndexColorModel 。

IndexColorModel(int, int, byte[], byte[], byte[], byte[]) - Constructor for class java.awt.image. IndexColorModel

从给定的红色，绿色，蓝色和alpha组件阵列构造一个 IndexColorModel 。

IndexColorModel(int, int, byte[], byte[], byte[], int) - Constructor for class java.awt.image. IndexColorModel

从给定的红色，绿色和蓝色组件阵列构造一个 IndexColorModel 。

IndexColorModel(int, int, byte[], int, boolean) - Constructor for class java.awt.image. IndexColorModel

从单个交错的红色，绿色，蓝色和可选的alpha组件阵列构造一个 IndexColorModel 。

IndexColorModel(int, int, byte[], int, boolean, int) - Constructor for class java.awt.image. IndexColorModel

从单个交错的红色，绿色，蓝色和可选的Alpha组件阵列构造一个 IndexColorModel 。

IndexColorModel(int, int, int[], int, boolean, int, int) - Constructor for class java.awt.image. IndexColorModel

从int数组构造一个 IndexColorModel ，其中每个int由默认RGB颜色模型格式的红，绿，蓝和可选alpha组件组成。

IndexColorModel(int, int, int[], int, int, BigInteger) - Constructor for class java.awt.image. IndexColorModel

从 int阵列构造一个 IndexColorModel ，其中每个 int由默认RGB颜色模型格式的红，绿，蓝和Alpha组件组成。

IndexedCell< T> - Class in javafx.scene.control

一个Cell的实现，其中包含一个索引属性，它映射到可视化的基础上的数据模型。

IndexedCell() - Constructor for class javafx.scene.control. IndexedCell

使用默认样式类“indexed-cell”创建默认IndexedCell。

IndexedPropertyChangeEvent - Class in java.beans

只要符合JavaBeans¢规范（“bean”）的组件更改绑定的索引属性，就会传递“IndexedPropertyChange”事件。

IndexedPropertyChangeEvent(Object, String, Object, Object, int) - Constructor for class java.beans. IndexedPropertyChangeEvent

构造一个新的 IndexedPropertyChangeEvent对象。

IndexedPropertyDescriptor - Class in java.beans

IndexedPropertyDescriptor描述了一个像数组一样的属性，并且具有索引的读取和/或索引的写入方法来访问数组的特定元素。

IndexedPropertyDescriptor(String, Class<?>) - Constructor for class java.beans. IndexedPropertyDescriptor

该构造函数通过使用getFoo和setFoo访问器方法为索引访问和数组访问来构造遵循标准Java约定的属性的IndexedPropertyDescriptor。

IndexedPropertyDescriptor(String, Class<?>, String, String, String, String) - Constructor for class java.beans. IndexedPropertyDescriptor

此构造函数使用简单属性的名称，以及用于读取和写入属性的方法名称，包括索引和非索引。

IndexedPropertyDescriptor(String, Method, Method, Method, Method) - Constructor for class java.beans. IndexedPropertyDescriptor

此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。

indexOf(int) - Method in class java.lang. String

返回指定字符第一次出现的字符串内的索引。

indexOf(int, int) - Method in class java.lang. String

返回指定字符第一次出现的字符串内的索引，以指定的索引开始搜索。

indexOf(E, int) - Method in class java.util.concurrent. CopyOnWriteArrayList

返回此列表中指定元素的第一次出现的索引，从 index搜索，如果未找到该元素，则返回-1。

indexOf(Object) - Method in class java.util. AbstractList

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

indexOf(Object) - Method in class java.util. ArrayList

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

indexOf(Object) - Method in class java.util.concurrent. CopyOnWriteArrayList

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

indexOf(Object) - Method in class java.util. LinkedList

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

indexOf(Object) - Method in interface java.util. List

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

indexOf(Object) - Method in class java.util. Vector

返回此向量中指定元素的第一次出现的索引，如果此向量不包含元素，则返回-1。

indexOf(Object) - Method in class javafx.beans.binding. ListExpression

indexOf(Object) - Method in class javax.swing. DefaultListModel

搜索首次发生 elem 。

indexOf(Object) - Method in class javax.swing.plaf.basic. BasicDirectoryModel

返回文件缓存中元素 o的索引。

indexOf(Object, int) - Method in class java.util. Vector

返回此向量中指定元素的第一次出现的索引，从 index向前搜索，如果未找到该元素，则返回-1。

indexOf(Object, int) - Method in class javax.swing. DefaultListModel

搜索第一次发生 elem ，开始搜索 index 。

indexOf(String) - Method in class java.lang. String

返回指定子字符串第一次出现的字符串内的索引。

indexOf(String) - Method in class java.lang. StringBuffer

indexOf(String) - Method in class java.lang. StringBuilder

indexOf(String, int) - Method in class java.lang. String

返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。

indexOf(String, int) - Method in class java.lang. StringBuffer

indexOf(String, int) - Method in class java.lang. StringBuilder

indexOfComponent(Component) - Method in class javax.swing. JTabbedPane

返回指定组件的选项卡的索引。

indexOfSubList(List<?>, List<?>) - Static method in class java.util. Collections

返回指定源列表中指定目标列表的第一次出现的起始位置，如果没有此类事件，则返回-1。

indexOfTab(String) - Method in class javax.swing. JTabbedPane

返回具有给定的 title的第一个选项卡索引，如果没有选项卡具有此标题，则返回-1。

indexOfTab(Icon) - Method in class javax.swing. JTabbedPane

返回具有给定的 icon的第一个选项卡索引，如果没有选项卡具有此图标，则返回-1。

indexOfTabComponent(Component) - Method in class javax.swing. JTabbedPane

返回指定选项卡组件的选项卡的索引。

IndexOutOfBoundsException - Exception in java.lang

抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。

IndexOutOfBoundsException() - Constructor for exception java.lang. IndexOutOfBoundsException

构造一个 IndexOutOfBoundsException ，没有详细信息。

IndexOutOfBoundsException(int) - Constructor for exception java.lang. IndexOutOfBoundsException

构造一个新的 IndexOutOfBoundsException类，其中包含指示非法索引的参数。

IndexOutOfBoundsException(String) - Constructor for exception java.lang. IndexOutOfBoundsException

构造具有指定详细消息的 IndexOutOfBoundsException 。

indexProperty() - Method in class javafx.scene.control. IndexedCell

（：例如，在虚拟化控制这个小区的位置ListView ， TreeView ， TableView等）。

IndexRange - Class in javafx.scene.control

表示整数值的连续范围的类。

IndexRange(int, int) - Constructor for class javafx.scene.control. IndexRange

创建一个IndexRange的实例，表示范围在 start和 end之间。

IndexRange(IndexRange) - Constructor for class javafx.scene.control. IndexRange

通过复制给定的IndexRange对象的值来创建IndexRange的实例。

indexToLocation(int) - Method in class javax.swing. JList

返回列表坐标系中指定项目的原点。

indexToLocation(JList<?>, int) - Method in class javax.swing.plaf.basic. BasicListUI

返回列表坐标系中给定的 JList中指定项目的原点。

indexToLocation(JList<?>, int) - Method in class javax.swing.plaf. ListUI

返回列表坐标系中给定的 JList中指定项目的原点。

indexToLocation(JList<?>, int) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 indexToLocation方法。

IndexTree - Interface in com.sun.source.doctree

@index或@index内联标记的树形节点。

INDIANRED - Static variable in class javafx.scene.paint. Color

彩色印度红色，RGB值为＃CD5C5C

INDIGO - Static variable in class javafx.scene.paint. Color

RGB值为＃4B0082的彩色靛蓝

IndirectionException - Exception in org.omg.CORBA.portable

间接异常是一个Java特定的系统异常。

IndirectionException(int) - Constructor for exception org.omg.CORBA.portable. IndirectionException

创建具有正确偏移值的IndirectionException。

INET - java.net. StandardProtocolFamily

互联网协议版本4（IPv4）

Inet4Address - Class in java.net

该类表示Internet协议版本4（IPv4）地址。

INET6 - java.net. StandardProtocolFamily

互联网协议版本6（IPv6）

Inet6Address - Class in java.net

该类表示Internet协议版本6（IPv6）地址。

InetAddress - Class in java.net

此类表示Internet协议（IP）地址。

inetAddresses() - Method in class java.net. NetworkInterface

获取绑定到此网络接口的InetAddresses的全部或一部分子流。

InetSocketAddress - Class in java.net

该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。

InetSocketAddress(int) - Constructor for class java.net. InetSocketAddress

创建一个套接字地址，其中IP地址为通配符地址，端口号为指定值。

InetSocketAddress(String, int) - Constructor for class java.net. InetSocketAddress

从主机名和端口号创建套接字地址。

InetSocketAddress(InetAddress, int) - Constructor for class java.net. InetSocketAddress

从IP地址和端口号创建套接字地址。

inf - Variable in class java.util.zip. InflaterInputStream

解压缩此流。

inf - Variable in class java.util.zip. InflaterOutputStream

解压缩此流。

inferBinaryName(JavaFileManager.Location, JavaFileObject) - Method in class javax.tools. ForwardingJavaFileManager

inferBinaryName(JavaFileManager.Location, JavaFileObject) - Method in interface javax.tools. JavaFileManager

基于面向包的位置来触发文件对象的二进制名称。

inferModuleName(JavaFileManager.Location) - Method in class javax.tools. ForwardingJavaFileManager

inferModuleName(JavaFileManager.Location) - Method in interface javax.tools. JavaFileManager

从其位置输入模块的名称，由 getLocationForModule或 listModuleLocations返回。

inField() - Method in interface com.sun.tools.doclets. Taglet

已过时。

如果在现场文档中使用了 Taglet则返回true。

inflate(byte[]) - Method in class java.util.zip. Inflater

将字节解压缩到指定的缓冲区。

inflate(byte[], int, int) - Method in class java.util.zip. Inflater

将字节解压缩到指定的缓冲区。

Inflater - Class in java.util.zip

此类提供对使用流行的ZLIB压缩库的通用解压缩的支持。

Inflater() - Constructor for class java.util.zip. Inflater

创建一个新的解压缩程序。

Inflater(boolean) - Constructor for class java.util.zip. Inflater

创建一个新的解压缩程序。

InflaterInputStream - Class in java.util.zip

该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。

InflaterInputStream(InputStream) - Constructor for class java.util.zip. InflaterInputStream

使用默认解压缩器和缓冲区大小创建新的输入流。

InflaterInputStream(InputStream, Inflater) - Constructor for class java.util.zip. InflaterInputStream

使用指定的解压缩器和默认缓冲区大小创建新的输入流。

InflaterInputStream(InputStream, Inflater, int) - Constructor for class java.util.zip. InflaterInputStream

使用指定的解压缩器和缓冲区大小创建新的输入流。

InflaterOutputStream - Class in java.util.zip

实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。

InflaterOutputStream(OutputStream) - Constructor for class java.util.zip. InflaterOutputStream

使用默认解压缩器和缓冲区大小创建新的输出流。

InflaterOutputStream(OutputStream, Inflater) - Constructor for class java.util.zip. InflaterOutputStream

使用指定的解压缩器和默认缓冲区大小创建新的输出流。

InflaterOutputStream(OutputStream, Inflater, int) - Constructor for class java.util.zip. InflaterOutputStream

使用指定的解压缩器和缓冲区大小创建新的输出流。

info - Static variable in class java.awt. SystemColor

为工具提示背景提供的颜色或现场帮助。

info() - Method in class java.lang. Process

返回有关进程信息的快照。

info() - Method in interface java.lang. ProcessHandle

返回有关进程信息的快照。

info(String) - Method in class java.util.logging. Logger

记录INFO消息。

info(Supplier<String>) - Method in class java.util.logging. Logger

记录INFO消息，只有在记录级别实际记录消息时，才能构建INFO消息。

Info(Class<?>) - Constructor for class javax.sound.sampled. Line.Info

构造一个描述指定类的行的信息对象。

Info(Class<?>, String, boolean) - Constructor for class javax.sound.sampled. Port.Info

根据给出的信息构造端口的信息对象。

Info(Class<?>, AudioFormat) - Constructor for class javax.sound.sampled. DataLine.Info

根据指定的信息构建数据行的信息对象，其中包含单个音频格式。

Info(Class<?>, AudioFormat[], int, int) - Constructor for class javax.sound.sampled. DataLine.Info

根据指定的信息构建数据行的信息对象，其中包括一组支持的音频格式和缓冲区大小的范围。

Info(Class<?>, AudioFormat, int) - Constructor for class javax.sound.sampled. DataLine.Info

从指定的信息构建数据行的信息对象，其中包含单个音频格式和所需的缓冲区大小。

Info(String, String, String, String) - Constructor for class javax.sound.midi. MidiDevice.Info

构造一个设备信息对象。

Info(String, String, String, String) - Constructor for class javax.sound.sampled. Mixer.Info

构建混音器的信息对象，传递给定的文本信息。

INFO - java.awt. TrayIcon.MessageType

一条信息消息

INFO - java.lang. System.Logger.Level

INFO级别：通常用于记录信息消息。

INFO - javafx.scene.input. KeyCode

常数为 Info键。

INFO - Static variable in class java.awt. SystemColor

SystemColor.info系统颜色的数组索引。

INFO - Static variable in class java.util.logging. Level

INFO是信息性消息的消息级别。

INFO - Static variable in class javax.management. MBeanOperationInfo

表示操作是类似的：它返回信息，但不会更改任何状态。

INFO_TEXT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.infoText系统颜色。

inFontTag() - Method in class javax.swing.text.html. MinimalHTMLWriter

如果我们目前使用的是<font>标签，则返回true。

inForkJoinPool() - Static method in class java.util.concurrent. ForkJoinTask

返回true如果当前线程是ForkJoinWorkerThread执行作为ForkJoinPool计算。

INFORMATION - javafx.scene.control. Alert.AlertType

“信息”警报类型配置“警报”对话框，以提示对话框的内容通知用户一条信息的方式显示。

INFORMATION - Static variable in class javax.security.auth.callback. ConfirmationCallback

信息消息类型。

INFORMATION - Static variable in class javax.security.auth.callback. TextOutputCallback

信息讯息。

INFORMATION_DIALOG - Static variable in class javax.swing. JRootPane

用于windowDecorationStyle属性的常量。

INFORMATION_MESSAGE - Static variable in class javax.swing. JOptionPane

X-

infoText - Static variable in class java.awt. SystemColor

为文本提供的工具提示颜色或点帮助。

INHERIT - java.lang. ProcessBuilder.Redirect.Type

类型 Redirect.INHERIT 。

INHERIT - javafx.geometry. NodeOrientation

表示节点从父节点继承方向。

INHERIT - javafx.scene. DepthTest

指定深度测试状态是从父级继承的。

INHERIT - Static variable in class java.lang. ProcessBuilder.Redirect

表示子进程I / O源或目标将与当前进程的相同。

INHERIT_DOC - com.sun.source.doctree. DocTree.Kind

用于实例InheritDocTree表示@inheritDoc标签。

INHERIT_ONLY - java.nio.file.attribute. AclEntryFlag

可以放在目录上，但不适用于目录，只适用于由 AclEntryFlag.FILE_INHERIT和 AclEntryFlag.DIRECTORY_INHERIT标志指定的新创建的文件/目录。

InheritableThreadLocal< T> - Class in java.lang

该类扩展了 ThreadLocal以提供从父线程到子线程的值的继承：当创建子线程时，子接收到父值具有值的所有可继承线程局部变量的初始值。

InheritableThreadLocal() - Constructor for class java.lang. InheritableThreadLocal

InheritDocTree - Interface in com.sun.source.doctree

@inheritDoc内联标记的树形节点。

Inherited - Annotation Type in java.lang.annotation

表示注释类型自动继承。

INHERITED - java.lang. Character.UnicodeScript

Unicode脚本“Inherited”。

inheritedChannel() - Static method in class java.lang. System

返回从创建此Java虚拟机的实体继承的通道。

inheritedChannel() - Method in class java.nio.channels.spi. SelectorProvider

返回从创建此Java虚拟机的实体继承的通道。

inheritIO() - Method in class java.lang. ProcessBuilder

将子进程标准I / O的源和目标设置为与当前Java进程相同。

inHitRegion(int, int) - Method in class javax.swing.tree. DefaultTreeCellEditor

如果传入的位置是开始编辑的有效的鼠标位置，则返回true。

init() - Method in class java.applet. Applet

已过时。

由浏览器或小程序查看器调用以通知此小程序已将其加载到系统中。

init() - Method in class javafx.application. Application

应用程序初始化方法。

init() - Static method in class org.omg.CORBA. ORB

返回 ORB单例对象。

init(boolean) - Method in interface java.security.cert. CertPathChecker

初始化这个 CertPathChecker的内部状态。

init(boolean) - Method in class java.security.cert. PKIXCertPathChecker

初始化这个 PKIXCertPathChecker的内部状态。

init(byte[]) - Method in class java.security. AlgorithmParameters

导入指定的参数，并根据参数的主要解码格式进行解码。

init(byte[], String) - Method in class java.security. AlgorithmParameters

从 params导入参数，并根据指定的解码方案进行解码。

init(int) - Method in class java.security. AlgorithmParameterGenerator

初始化此参数生成器达一定大小。

init(int) - Method in class javax.crypto. KeyGenerator

初始化此密钥生成器用于某些密钥大小。

init(int, Certificate) - Method in class javax.crypto. Cipher

使用给定证书中的公钥初始化此密码。

init(int, Certificate, SecureRandom) - Method in class javax.crypto. Cipher

使用给定证书中的公钥和随机源初始化此密码。

init(int, Key) - Method in class javax.crypto. Cipher

用密钥初始化此密码。

init(int, Key, AlgorithmParameters) - Method in class javax.crypto. Cipher

使用密钥和一组算法参数初始化此密码。

init(int, Key, AlgorithmParameters, SecureRandom) - Method in class javax.crypto. Cipher

使用密钥，一组算法参数和随机源初始化此密码。

init(int, Key, SecureRandom) - Method in class javax.crypto. Cipher

用密钥和随机源初始化此密码。

init(int, Key, AlgorithmParameterSpec) - Method in class javax.crypto. Cipher

使用密钥和一组算法参数初始化此密码。

init(int, Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto. Cipher

使用密钥，一组算法参数和随机源初始化此密码。

init(int, SecureRandom) - Method in class java.security. AlgorithmParameterGenerator

初始化此参数生成器以获得一定的大小和随机源。

init(int, SecureRandom) - Method in class javax.crypto. KeyGenerator

使用用户提供的随机源，初始化该密钥生成器以进行某些密钥化。

init(JavacTask, String...) - Method in interface com.sun.source.util. Plugin

初始化给定编译任务的插件。

init(Applet, Properties) - Static method in class org.omg.CORBA. ORB

为小程序创建一个新的 ORB实例。

init(String[], Properties) - Static method in class org.omg.CORBA. ORB

为独立应用程序创建一个新的 ORB实例。

init(String, Icon) - Method in class javax.swing. AbstractButton

初始化 AbstractButton 。

init(String, Icon) - Method in class javax.swing. JMenuItem

用指定的文本和图标初始化菜单项。

init(Key) - Method in class javax.crypto. ExemptionMechanism

使用密钥初始化此豁免机制。

init(Key) - Method in class javax.crypto. KeyAgreement

使用给定的密钥初始化此密钥协议，该密钥需要包含此密钥协议所需的所有算法参数。

init(Key) - Method in class javax.crypto. Mac

使用给定的键初始化此 Mac对象。

init(Key, AlgorithmParameters) - Method in class javax.crypto. ExemptionMechanism

使用密钥和一组算法参数初始化此豁免机制。

init(Key, SecureRandom) - Method in class javax.crypto. KeyAgreement

用给定的密钥和随机源初始化这个密钥协商。

init(Key, AlgorithmParameterSpec) - Method in class javax.crypto. ExemptionMechanism

使用密钥和一组算法参数初始化此豁免机制。

init(Key, AlgorithmParameterSpec) - Method in class javax.crypto. KeyAgreement

使用给定的密钥和算法参数集初始化此密钥协议。

init(Key, AlgorithmParameterSpec) - Method in class javax.crypto. Mac

使用给定的键和算法参数初始化此 Mac对象。

init(Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto. KeyAgreement

使用给定的密钥，算法参数集合和随机源初始化此密钥协议。

init(KeyStore) - Method in class javax.net.ssl. TrustManagerFactory

使用证书颁发机构和相关信托资料来源初始化该工厂。

init(KeyStore, char[]) - Method in class javax.net.ssl. KeyManagerFactory

使用关键材料来源初始化该工厂。

init(SecureRandom) - Method in class javax.crypto. KeyGenerator

初始化此密钥生成器。

init(AlgorithmParameterSpec) - Method in class java.security. AlgorithmParameterGenerator

使用一组特定于算法的参数生成值初始化此参数生成器。

init(AlgorithmParameterSpec) - Method in class java.security. AlgorithmParameters

使用 paramSpec指定的参数初始化此参数对象。

init(AlgorithmParameterSpec) - Method in class javax.crypto. KeyGenerator

使用指定的参数集初始化此密钥生成器。

init(AlgorithmParameterSpec, SecureRandom) - Method in class java.security. AlgorithmParameterGenerator

使用一组特定于算法的参数生成值初始化此参数生成器。

init(AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto. KeyGenerator

使用指定的参数集和用户提供的随机源初始化此密钥生成器。

init(Hashtable<?, ?>) - Method in class javax.naming. InitialContext

使用提供的环境初始化初始上下文。

init(Locale, Reporter) - Method in interface jdk.javadoc.doclet. Doclet

使用给定的区域设置和错误报告器初始化此doclet。

init(Locale, Reporter) - Method in class jdk.javadoc.doclet. StandardDoclet

init(ProcessingEnvironment) - Method in class javax.annotation.processing. AbstractProcessor

通过将 processingEnv字段设置为 processingEnv参数的值，通过处理环境初始化处理器。

init(ProcessingEnvironment) - Method in interface javax.annotation.processing. Processor

使用处理环境初始化处理器。

init(KeyManager[], TrustManager[], SecureRandom) - Method in class javax.net.ssl. SSLContext

初始化此上下文。

init(ManagerFactoryParameters) - Method in class javax.net.ssl. KeyManagerFactory

使用提供商特定的密钥材料来源初始化该工厂。

init(ManagerFactoryParameters) - Method in class javax.net.ssl. TrustManagerFactory

使用提供商特定的信任资料来源初始化该工厂。

init(StateEditable, String) - Method in class javax.swing.undo. StateEdit

初始化状态编辑。

init(TransformParameterSpec) - Method in class javax.xml.crypto.dsig. TransformService

使用指定的参数初始化此 TransformService 。

init(XMLStructure, XMLCryptoContext) - Method in class javax.xml.crypto.dsig. TransformService

使用指定的参数和文档上下文初始化此 TransformService 。

init(DocletEnvironment, Doclet) - Method in interface jdk.javadoc.doclet. Taglet

使用给定的doclet环境和doclet初始化此taglet。

initCause(Throwable) - Method in class java.lang. Throwable

将此throwable的 原因初始化为指定值。

initCause(Throwable) - Method in exception javax.naming. NamingException

将此异常的原因初始化为指定的值。

initCause(Throwable) - Method in exception javax.security.sasl. SaslException

initCause(Throwable) - Method in exception javax.xml.soap. SOAPException

使用给定的 Throwable对象初始化此 SOAPException对象的 cause字段。

initCause(Throwable) - Method in exception javax.xml.transform. TransformerException

将此throwable的 原因初始化为指定值。

initCause(Throwable) - Method in exception jdk.incubator.http. WebSocketHandshakeException

initClassDefaults(UIDefaults) - Method in class javax.swing.plaf.basic. BasicLookAndFeel

填写 table的映射，从 uiClassID到ui类的完全限定名称。

initClassDefaults(UIDefaults) - Method in class javax.swing.plaf.metal. MetalLookAndFeel

填充 table从映射 uiClassID到ui类的完全限定名。

initComponentDefaults(UIDefaults) - Method in class javax.swing.plaf.basic. BasicLookAndFeel

填充 table与默认的基本外观和感觉。

initComponentDefaults(UIDefaults) - Method in class javax.swing.plaf.metal. MetalLookAndFeel

填充 table与金属的默认值。

initEvent(String, boolean, boolean) - Method in interface org.w3c.dom.events. Event

该 initEvent方法用于初始化的值 Event通过创建 DocumentEvent接口。

INITIAL_CONTEXT_FACTORY - Static variable in interface javax.naming. Context

用于指定要使用的初始上下文工厂的环境属性的名称的常量。

INITIAL_QUOTE_PUNCTUATION - Static variable in class java.lang. Character

Unicode规范中的一般类别“Pi”。

INITIAL_SELECTION_VALUE_PROPERTY - Static variable in class javax.swing. JOptionPane

绑定属性名称为 initialSelectionValue 。

INITIAL_VALUE_PROPERTY - Static variable in class javax.swing. JOptionPane

绑定属性名称为 initialValue 。

InitialContext - Class in javax.naming

这个类是执行命名操作的起始上下文。

InitialContext() - Constructor for class javax.naming. InitialContext

构建一个初始上下文。

InitialContext(boolean) - Constructor for class javax.naming. InitialContext

构造一个初始上下文，并选择不初始化它。

InitialContext(Hashtable<?, ?>) - Constructor for class javax.naming. InitialContext

使用提供的环境构建初始上下文。

InitialContextFactory - Interface in javax.naming.spi

此接口表示创建初始上下文的工厂。

InitialContextFactoryBuilder - Interface in javax.naming.spi

此接口表示创建初始上下文工厂的构建器。

InitialDirContext - Class in javax.naming.directory

此类是执行目录操作的起始上下文。

InitialDirContext() - Constructor for class javax.naming.directory. InitialDirContext

构造一个初始DirContext。

InitialDirContext(boolean) - Constructor for class javax.naming.directory. InitialDirContext

构造一个初始DirContext，可选择不初始化它。

InitialDirContext(Hashtable<?, ?>) - Constructor for class javax.naming.directory. InitialDirContext

使用提供的环境构建初始DirContext。

initialDirectoryProperty() - Method in class javafx.stage. DirectoryChooser

显示对话框的初始目录。

initialDirectoryProperty() - Method in class javafx.stage. FileChooser

显示文件对话框的初始目录。

initialFileNameProperty() - Method in class javafx.stage. FileChooser

显示对话框的初始文件名。

initialFocusComponent - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI

在使用selectInitialValue消息时接收焦点的组件。

Initializable - Interface in javafx.fxml

控制器初始化界面

initialize() - Method in class java.beans.beancontext. BeanContextServicesSupport

在构造和反序列化期间由BeanContextSupport超类调用以初始化子类暂态。

initialize() - Method in class java.beans.beancontext. BeanContextSupport

protected方法从构造函数和readObject调用，初始化BeanContextSupport实例的暂态。

initialize() - Method in class javax.swing. LookAndFeel

初始化外观和感觉。

initialize() - Method in class javax.swing.plaf.basic. BasicLookAndFeel

初始化外观和感觉。

initialize() - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

当这个外观和感觉被安装时，由UIManager打来的。

initialize() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

当这个外观和感觉被安装时，由UIManager打来的。

initialize(int) - Method in class java.security. KeyPairGenerator

使用默认参数集和最高优先级安装的提供程序的 SecureRandom实现来初始化密钥对生成器作为随机性的来源。

initialize(int, boolean, SecureRandom) - Method in interface java.security.interfaces. DSAKeyPairGenerator

为给定的模数长度（而不是参数）初始化密钥对生成器以及可选的SecureRandom位源。

initialize(int, SecureRandom) - Method in class java.security. KeyPairGenerator

使用给定的随机源（和默认参数集）初始化特定密钥大小的密钥对生成器。

initialize(int, SecureRandom) - Method in class java.security. KeyPairGeneratorSpi

使用默认参数集初始化某个密钥对的密钥对生成器。

initialize(Applet, BeanContext) - Method in interface java.beans. AppletInitializer

已过时。

如果传递给java.beans.Beans.instantiate的相应变体，则将调用此方法，以便将新实例化的Applet（JavaBean）与其AppletContext，AppletStub和Container关联。

initialize(Class<?>, Object, Object, Encoder) - Method in class java.beans. DefaultPersistenceDelegate

这个 initialize方法的默认实现假定这个类型的对象中的所有状态都是通过匹配的“setter”和“getter”方法按Introspector返回的顺序公开的。

initialize(Class<?>, Object, Object, Encoder) - Method in class java.beans. PersistenceDelegate

对 newInstance产生一系列具有副作用的语句，使新实例变为 等同于 oldInstance 。

initialize(MethodHandle) - Method in interface jdk.dynalink. RelinkableCallSite

由动态链接器调用，通过设置relink-and-invoke方法句柄来初始化可重新链接的调用站点。

initialize(MethodHandle) - Method in class jdk.dynalink.support. AbstractRelinkableCallSite

initialize(URL, ResourceBundle) - Method in interface javafx.fxml. Initializable

被调用以在其根元素被完全处理之后初始化控制器。

initialize(DSAParams, SecureRandom) - Method in interface java.security.interfaces. DSAKeyPairGenerator

使用DSA系列参数（p，q和g）和可选的SecureRandom位源初始化密钥对生成器。

initialize(AlgorithmParameterSpec) - Method in class java.security. KeyPairGenerator

使用指定的参数集和最优先安装的提供程序的 SecureRandom实现来初始化密钥对生成器作为随机源。

initialize(AlgorithmParameterSpec, SecureRandom) - Method in class java.security. KeyPairGenerator

使用给定的参数集和随机源初始化密钥对生成器。

initialize(AlgorithmParameterSpec, SecureRandom) - Method in class java.security. KeyPairGeneratorSpi

使用指定的参数集和用户提供的随机源初始化密钥对生成器。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in class com.sun.security.auth.module. JndiLoginModule

初始化 LoginModule 。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in class com.sun.security.auth.module. KeyStoreLoginModule

初始化这个 LoginModule 。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in class com.sun.security.auth.module. Krb5LoginModule

初始化这个 LoginModule 。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in class com.sun.security.auth.module. LdapLoginModule

初始化 LoginModule 。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in class com.sun.security.auth.module. NTLoginModule

初始化这个 LoginModule 。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in class com.sun.security.auth.module. SolarisLoginModule

已过时。

初始化这个 LoginModule 。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in class com.sun.security.auth.module. UnixLoginModule

初始化 LoginModule 。

initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in interface javax.security.auth.spi. LoginModule

初始化此LoginModule。

INITIALIZE - Exception in org.omg.CORBA

当ORB在其初始化期间遇到故障（例如无法获取网络资源或检测到配置错误）时抛出异常。

INITIALIZE() - Constructor for exception org.omg.CORBA. INITIALIZE

构造一个 INITIALIZE异常，默认次要代码为0，完成状态为 CompletionStatus.COMPLETED_NO 。

INITIALIZE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INITIALIZE

构造具有指定的次要代码和完成状态的 INITIALIZE异常。

INITIALIZE(String) - Constructor for exception org.omg.CORBA. INITIALIZE

构造具有指定详细消息的 INITIALIZE异常，次要代码为0，完成状态为 CompletionStatus.COMPLETED_NO 。

INITIALIZE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INITIALIZE

构造具有指定的详细消息，次要代码和完成状态的 INITIALIZE异常。

INITIALIZE_METHOD_NAME - Static variable in class javafx.fxml. FXMLLoader

初始化方法的名称。

initializeAutoscrolling(Point) - Method in class java.awt.dnd. DropTarget

初始化自动滚动

initializeBeanContextResources() - Method in class java.beans.beancontext. BeanContextChildSupport

该方法可能被子类覆盖，以提供自己的初始化行为。

initializeBeanContextResources() - Method in class java.beans.beancontext. BeanContextServicesSupport

从setBeanContext调用通知一个BeanContextChild来分配从嵌套BeanContext获取的资源。

initializeDesktopProperties() - Method in class java.awt. Toolkit

initializeDesktopProperties

initializeLocalVars() - Method in class javax.swing. JTable

将表属性初始化为其默认值。

initializeLocalVars() - Method in class javax.swing.table. JTableHeader

使用默认值初始化局部变量和属性。

InitialLdapContext - Class in javax.naming.ldap

此类是执行LDAPv3风格的扩展操作和控件的起始上下文。

InitialLdapContext() - Constructor for class javax.naming.ldap. InitialLdapContext

构造一个不使用环境属性或连接请求控件的初始上下文。

InitialLdapContext(Hashtable<?, ?>, Control[]) - Constructor for class javax.naming.ldap. InitialLdapContext

使用环境属性和连接请求控件构造初始上下文。

initialSelectionValue - Variable in class javax.swing. JOptionPane

初始值在 selectionValues进行选择。

initialSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management. Query

返回一个表示字符串参数匹配约束的查询表达式。

initialValue - Variable in class javax.swing. JOptionPane

应在 options最初选择的 options 。

initialValue() - Method in class java.lang. ThreadLocal

返回此线程局部变量的当前线程的“初始值”。

INITIATE_AND_ACCEPT - Static variable in interface org.ietf.jgss. GSSCredential

凭证使用标志，要求其可用于上下文启动和接受。

INITIATE_ONLY - Static variable in interface org.ietf.jgss. GSSCredential

凭证使用标志，要求仅用于上下文启动。

initModality(Modality) - Method in class javafx.scene.control. Dialog

指定此对话框的模态。

initModality(Modality) - Method in class javafx.stage. Stage

指定此阶段的模式。

initMouseEvent(String, boolean, boolean, AbstractView, int, int, int, int, int, boolean, boolean, boolean, boolean, short, EventTarget) - Method in interface org.w3c.dom.events. MouseEvent

该 initMouseEvent方法用于初始化的值 MouseEvent通过创建 DocumentEvent接口。

initMutationEvent(String, boolean, boolean, Node, String, String, String, short) - Method in interface org.w3c.dom.events. MutationEvent

initMutationEvent方法用于初始化通过 MutationEvent创建的 DocumentEvent接口的值。

initOwner(Window) - Method in class javafx.scene.control. Dialog

指定此对话框的所有者Window ，或者对于顶级的未知对话框，该值为null。

initOwner(Window) - Method in class javafx.stage. Stage

指定此阶段的所有者窗口，或者指定顶级，未知级别的空值。

InitParam - Annotation Type in javax.jws.soap

已过时。

initParams() - Method in class javax.sql.rowset. BaseRowSet

执行必要的内部配置和初始化，以允许任何JDBC RowSet实现开始使用 BaseRowSet实例提供的标准工具。

initSecContext(byte[], int, int) - Method in interface org.ietf.jgss. GSSContext

由上下文发起者调用以启动上下文创建阶段 acceptSecContext对等体的 acceptSecContext方法生成的任何令牌。

initSecContext(InputStream, OutputStream) - Method in interface org.ietf.jgss. GSSContext

由上下文发起者调用以启动上下文创建阶段， acceptSecContext对等体的 acceptSecContext方法使用流生成的任何令牌。

initSign(PrivateKey) - Method in class java.security. Signature

初始化此对象进行签名。

initSign(PrivateKey, SecureRandom) - Method in class java.security. Signature

初始化此对象进行签名。

initStyle(StageStyle) - Method in class javafx.scene.control. Dialog

指定此对话框的样式。

initStyle(StageStyle) - Method in class javafx.stage. Stage

指定此阶段的样式。

initSystemColorDefaults(UIDefaults) - Method in class javax.swing.plaf.basic. BasicLookAndFeel

用系统颜色填充 table 。

initSystemColorDefaults(UIDefaults) - Method in class javax.swing.plaf.metal. MetalLookAndFeel

用系统颜色填充 table 。

initUIEvent(String, boolean, boolean, AbstractView, int) - Method in interface org.w3c.dom.events. UIEvent

该 initUIEvent方法用于初始化的值 UIEvent通过创建 DocumentEvent接口。

initVerify(Certificate) - Method in class java.security. Signature

使用给定证书中的公钥初始化此对象进行验证。

initVerify(PublicKey) - Method in class java.security. Signature

初始化此对象进行验证。

inject(WebServiceContext) - Method in class javax.xml.ws.spi. Invoker

JAX-WS运行时调用此方法来请求容器在端点实例上注入WebServiceContext。

INK_SET_CMYK - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“InkSet”标签一起使用的值。

INK_SET_NOT_CMYK - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“InkSet”标签一起使用的值。

INLINE - javafx.css. StyleOrigin

样式是从Node通过setStyle

inlineTags() - Method in interface com.sun.javadoc. Doc

已过时。

将注释作为标签数组返回。

inlineTags() - Method in interface com.sun.javadoc. Tag

已过时。

有关嵌入式 {@link}标签的文档注释，请返回 Tag对象的数组。

InlineTagTree - Interface in com.sun.source.doctree

一个树节点用作不同类型的内联标签的基类。

InlineView - Class in javax.swing.text.html

基于CSS属性显示 内联元素样式。

InlineView(Element) - Constructor for class javax.swing.text.html. InlineView

构造一个包含在元素上的新视图。

inMethod() - Method in interface com.sun.tools.doclets. Taglet

已过时。

如果在方法文档中使用了 Taglet则返回true。

INNER_JOIN - Static variable in interface javax.sql.rowset. JoinRowSet

ANSI样式的 JOIN提供两个表之间的内部连接。

innerClasses() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回 included此类或接口中的嵌套类和接口。

innerClasses(boolean) - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回此类或接口中的嵌套类和接口，过滤到指定的 access modifier option 。

InnerShadow - Class in javafx.scene.effect

使用指定的颜色，半径和偏移量在给定内容的边缘内部呈现阴影的高级效果。

InnerShadow() - Constructor for class javafx.scene.effect. InnerShadow

使用默认参数创建一个新的InnerShadow实例。

InnerShadow(double, double, double, Color) - Constructor for class javafx.scene.effect. InnerShadow

创建一个新的具有指定半径，offsetX，offsetY和color的InnerShadow实例。

InnerShadow(double, Color) - Constructor for class javafx.scene.effect. InnerShadow

创建一个新的具有指定半径和颜色的InnerShadow实例。

InnerShadow(BlurType, Color, double, double, double, double) - Constructor for class javafx.scene.effect. InnerShadow

使用指定的blurType，color，radius，spread，offsetX和offsetY创建一个新的InnerShadow实例。

INOUT - javax.jws. WebParam.Mode

inOverview() - Method in interface com.sun.tools.doclets. Taglet

已过时。

如果在概述文档中使用了 Taglet则返回true。

inPackage() - Method in interface com.sun.tools.doclets. Taglet

已过时。

如果在包文档中使用了 Taglet则返回true。

input - Variable in class javax.imageio. ImageReader

所述 ImageInputStream或其它 Object通过 setInput和由检索 getInput 。

INPUT - Static variable in class javax.swing.text.html. HTML.Tag

标签<input>

INPUT_METHOD - javafx.application. ConditionalFeature

表示文本输入法在平台上可用。

INPUT_METHOD_EVENT_MASK - Static variable in class java.awt. AWTEvent

用于选择输入法事件的事件掩码。

INPUT_METHOD_FIRST - Static variable in class java.awt.event. InputMethodEvent

标记输入法事件ids范围的第一个整数ID。

INPUT_METHOD_HIGHLIGHT - Static variable in class java.awt.font. TextAttribute

输入法高亮样式的属性键。

INPUT_METHOD_LAST - Static variable in class java.awt.event. InputMethodEvent

标记输入法事件ids范围的最后一个整数ID。

INPUT_METHOD_ON_OFF - javafx.scene.input. KeyCode

输入法/常规键的常数。

INPUT_METHOD_SEGMENT - Static variable in class java.text. AttributedCharacterIterator.Attribute

输入方法段的属性键。

INPUT_METHOD_TEXT_CHANGED - Static variable in class java.awt.event. InputMethodEvent

事件类型指示改变的输入法文本。

INPUT_METHOD_TEXT_CHANGED - Static variable in class javafx.scene.input. InputMethodEvent

InputMethodEvent唯一有效的EventType。

INPUT_METHOD_UNDERLINE - Static variable in class java.awt.font. TextAttribute

输入法的属性键加下划线。

INPUT_MULTITOUCH - javafx.application. ConditionalFeature

指示提供多点触摸输入的触摸屏是否连接到运行JavaFX的设备上。

INPUT_POINTER - javafx.application. ConditionalFeature

指示是否附加了诸如鼠标，触控板或轨迹球的相对运动指针装置。

INPUT_STREAM(String) - Constructor for class javax.print. DocFlavor.INPUT_STREAM

构造具有给定MIME类型和打印数据表示类名称 "java.io.InputStream" （字节流）的新文档风格。

INPUT_TOUCH - javafx.application. ConditionalFeature

指示触摸屏是否连接到运行JavaFX的设备上。

INPUT_TRAY_MISSING - Static variable in class javax.print.attribute.standard. PrinterStateReason

一个或多个输入托盘不在设备中。

INPUT_VALUE_PROPERTY - Static variable in class javax.swing. JOptionPane

绑定属性名称为 inputValue 。

inputClass - Variable in class javax.imageio.spi. ImageInputStreamSpi

一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。

inputComponent - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI

如果optionPane.getWantsInput（）返回true，则JComponent提供输入。

InputContext - Class in java.awt.im

提供控制文本输入设备（如输入法和键盘布局）的方法。

InputContext() - Constructor for class java.awt.im. InputContext

构造一个InputContext。

InputEvent - Class in java.awt.event

所有组件级输入事件的根事件类。

InputEvent - Class in javafx.scene.input

指示用户输入的事件。

InputEvent(Object, EventTarget, EventType<? extends InputEvent>) - Constructor for class javafx.scene.input. InputEvent

创建新的InputEvent实例。

InputEvent(EventType<? extends InputEvent>) - Constructor for class javafx.scene.input. InputEvent

创建新的InputEvent实例。

InputMap - Class in javax.swing

InputMap提供输入事件之间的绑定（目前仅使用 KeyStroke ）和 Object 。

InputMap() - Constructor for class javax.swing. InputMap

创建一个 InputMap ，没有父对象，没有映射。

InputMapUIResource - Class in javax.swing.plaf

实现UIResource的javax.swing.InputMap的子类。

InputMapUIResource() - Constructor for class javax.swing.plaf. InputMapUIResource

构造一个 InputMapUIResource 。

InputMethod - Interface in java.awt.im.spi

定义支持复杂文本输入的输入法的界面。

InputMethodContext - Interface in java.awt.im.spi

提供输入方法可用于与其客户端组件通信或请求其他服务的方法。

InputMethodDescriptor - Interface in java.awt.im.spi

定义提供有关输入法的足够信息以启用该输入法的选择和加载的方法。

InputMethodEvent - Class in java.awt.event

输入法事件包含使用输入法组合的文本信息。

InputMethodEvent - Class in javafx.scene.input

一个表示底层输入法在Node中通知其文本更改的事件 。

InputMethodEvent(Component, int, long, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event. InputMethodEvent

构造具有指定源组件，类型，时间，文本，插入符和 InputMethodEvent 。

InputMethodEvent(Component, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event. InputMethodEvent

构造一个具有指定的源组件，类型，插入符号和 InputMethodEvent 。

InputMethodEvent(Component, int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event. InputMethodEvent

构造具有指定源组件，类型，文本，插入符和 InputMethodEvent 。

InputMethodEvent(Object, EventTarget, EventType<InputMethodEvent>, List<InputMethodTextRun>, String, int) - Constructor for class javafx.scene.input. InputMethodEvent

构造新的InputMethodEvent事件。

InputMethodEvent(EventType<InputMethodEvent>, List<InputMethodTextRun>, String, int) - Constructor for class javafx.scene.input. InputMethodEvent

构造具有空源和目标的新的InputMethodEvent事件。

InputMethodHighlight - Class in java.awt.im

InputMethodHighlight用于描述正在组成的文本的突出显示属性。

InputMethodHighlight - Enum in javafx.scene.input

包含输入法文本的枚举突出显示。

InputMethodHighlight(boolean, int) - Constructor for class java.awt.im. InputMethodHighlight

构造输入法高亮记录。

InputMethodHighlight(boolean, int, int) - Constructor for class java.awt.im. InputMethodHighlight

构造输入法高亮记录。

InputMethodHighlight(boolean, int, int, Map<TextAttribute, ?>) - Constructor for class java.awt.im. InputMethodHighlight

构造输入法高亮记录。

InputMethodListener - Interface in java.awt.event

用于接收输入法事件的侦听器接口。

InputMethodRequests - Interface in java.awt.im

InputMethodRequests定义文本编辑组件必须处理的请求，以便使用输入法。

InputMethodRequests - Interface in javafx.scene.input

InputMethodRequests定义文本编辑节点必须处理的请求以便处理输入法。

inputMethodRequestsProperty() - Method in class javafx.scene. Node

属性保存InputMethodRequests。

inputMethodTextChanged(InputMethodEvent) - Method in class java.awt. AWTEventMulticaster

通过调用listener-a和listener-b上的inputMethodTextChanged方法来处理inputMethodTextChanged事件。

inputMethodTextChanged(InputMethodEvent) - Method in interface java.awt.event. InputMethodListener

当通过输入法输入的文本已更改时调用。

InputMethodTextRun - Class in javafx.scene.input

表示单个运行，其中字符在输入法文本中具有相同的高亮集。

InputMethodTextRun(String, InputMethodHighlight) - Constructor for class javafx.scene.input. InputMethodTextRun

构造输入法的单个文本运行。

InputMismatchException - Exception in java.util

由 Scanner抛出，表示检索到的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。

InputMismatchException() - Constructor for exception java.util. InputMismatchException

构造一个 InputMismatchException其中包含 null作为其错误消息字符串。

InputMismatchException(String) - Constructor for exception java.util. InputMismatchException

构造一个 InputMismatchException ，保存对错误消息字符串 s的引用，以供稍后通过 getMessage方法检索。

inputProperty() - Method in class javafx.scene.effect. Bloom

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. BoxBlur

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. ColorAdjust

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. DisplacementMap

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. DropShadow

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. GaussianBlur

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. Glow

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. InnerShadow

该输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. MotionBlur

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. PerspectiveTransform

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. Reflection

该输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. SepiaTone

这个输入为 Effect 。

inputProperty() - Method in class javafx.scene.effect. Shadow

这个输入为 Effect 。

InputSource - Class in org.xml.sax

XML实体的单一输入源。

InputSource() - Constructor for class org.xml.sax. InputSource

零参数默认构造函数。

InputSource(InputStream) - Constructor for class org.xml.sax. InputSource

创建一个带有字节流的新输入源。

InputSource(Reader) - Constructor for class org.xml.sax. InputSource

创建一个带有字符流的新输入源。

InputSource(String) - Constructor for class org.xml.sax. InputSource

创建一个带有系统标识符的新输入源。

InputStream - Class in java.io

这个抽象类是表示输入字节流的所有类的超类。

InputStream - Class in org.omg.CORBA_2_3.portable

InputStream提供从流中读取所有映射的IDL类型。

InputStream - Class in org.omg.CORBA.portable

InputStream是用于从CDR元数据流读取IDL类型的Java API。

InputStream() - Constructor for class java.io. InputStream

InputStream() - Constructor for class org.omg.CORBA_2_3.portable. InputStream

创建一个这个类的新实例。

InputStream() - Constructor for class org.omg.CORBA.portable. InputStream

InputStreamReader - Class in java.io

InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。

InputStreamReader(InputStream) - Constructor for class java.io. InputStreamReader

创建一个使用默认字符集的InputStreamReader。

InputStreamReader(InputStream, String) - Constructor for class java.io. InputStreamReader

创建一个使用命名字符集的InputStreamReader。

InputStreamReader(InputStream, Charset) - Constructor for class java.io. InputStreamReader

创建一个使用给定字符集的InputStreamReader。

InputStreamReader(InputStream, CharsetDecoder) - Constructor for class java.io. InputStreamReader

创建一个使用给定字符集解码器的InputStreamReader。

InputSubset - Class in java.awt.im

定义输入法使用的其他Unicode子集。

inputTypes - Variable in class javax.imageio.spi. ImageReaderSpi

从 getInputTypes返回的 Class对象的数组，最初为 null 。

inputValue - Variable in class javax.swing. JOptionPane

用户输入的价值

InputVerifier - Class in javax.swing

此类为Swing组件提供了验证机制。

InputVerifier() - Constructor for class javax.swing. InputVerifier

inquireSecContext(InquireType) - Method in interface com.sun.security.jgss. ExtendedGSSContext

返回与 type相关联的机制特定属性。

InquireSecContextPermission - Class in com.sun.security.jgss

该类用于保护可以使用 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立GSS安全上下文的各种属性。

InquireSecContextPermission(String) - Constructor for class com.sun.security.jgss. InquireSecContextPermission

构造具有指定名称的新的 InquireSecContextPermission对象。

InquireType - Enum in com.sun.security.jgss

可以指定为 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)参数的属性类型

inRange(Element) - Method in class javax.swing.text. AbstractWriter

此方法确定当前元素是否在指定的范围内。

INSCRIPTIONAL_PAHLAVI - java.lang. Character.UnicodeScript

Unicode脚本“Inscriptional_Pahlavi”。

INSCRIPTIONAL_PAHLAVI - Static variable in class java.lang. Character.UnicodeBlock

常数为“Inscriptional Pahlavi”Unicode字符块。

INSCRIPTIONAL_PARTHIAN - java.lang. Character.UnicodeScript

Unicode脚本“Inscriptional_Parthian”。

INSCRIPTIONAL_PARTHIAN - Static variable in class java.lang. Character.UnicodeBlock

“Inscriptional Parthian”Unicode字符块的常数。

insert(int, boolean) - Method in class java.lang. StringBuffer

insert(int, boolean) - Method in class java.lang. StringBuilder

insert(int, char) - Method in class java.lang. StringBuffer

insert(int, char) - Method in class java.lang. StringBuilder

insert(int, char[]) - Method in class java.lang. StringBuffer

insert(int, char[]) - Method in class java.lang. StringBuilder

insert(int, char[], int, int) - Method in class java.lang. StringBuffer

insert(int, char[], int, int) - Method in class java.lang. StringBuilder

insert(int, double) - Method in class java.lang. StringBuffer

insert(int, double) - Method in class java.lang. StringBuilder

insert(int, float) - Method in class java.lang. StringBuffer

insert(int, float) - Method in class java.lang. StringBuilder

insert(int, int) - Method in class java.lang. StringBuffer

insert(int, int) - Method in class java.lang. StringBuilder

insert(int, int, DefaultStyledDocument.ElementSpec[], AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer

插入新内容。

insert(int, long) - Method in class java.lang. StringBuffer

insert(int, long) - Method in class java.lang. StringBuilder

insert(int, CharSequence) - Method in class java.lang. StringBuffer

insert(int, CharSequence) - Method in class java.lang. StringBuilder

insert(int, CharSequence, int, int) - Method in class java.lang. StringBuffer

insert(int, CharSequence, int, int) - Method in class java.lang. StringBuilder

insert(int, Object) - Method in class java.lang. StringBuffer

insert(int, Object) - Method in class java.lang. StringBuilder

insert(int, String) - Method in class java.lang. StringBuffer

insert(int, String) - Method in class java.lang. StringBuilder

insert(int, String, boolean) - Method in interface javafx.scene.control. TextInputControl.Content

在内容中插入一串字符。

insert(int, DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text. DefaultStyledDocument

批量插入新元素。

insert(int, DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.html. HTMLDocument

批量插入新元素。

insert(int, View) - Method in class javax.swing.text. View

插入单个子视图。

insert(Component, int) - Method in class javax.swing. JPopupMenu

将指定的组件插入到给定位置的菜单中。

insert(MenuItem, int) - Method in class java.awt. Menu

在指定位置的菜单中插入菜单项。

insert(String, int) - Method in class java.awt. Choice

在指定位置将项目插入此选项。

insert(String, int) - Method in class java.awt. Menu

在指定位置的菜单中插入带有指定标签的菜单项。

insert(String, int) - Method in class java.awt. TextArea

在此文本区域的指定位置插入指定的文本。

insert(String, int) - Method in class javax.swing. JMenu

在给定的位置插入一个带有指定文本的新菜单项。

insert(String, int) - Method in class javax.swing. JTextArea

在指定的位置插入指定的文本。

insert(Action, int) - Method in class javax.swing. JMenu

在指定的位置插入一个附加到指定的 Action对象的新菜单项。

insert(Action, int) - Method in class javax.swing. JPopupMenu

在给定位置插入指定的 Action对象的菜单项。

insert(JMenuItem, int) - Method in class javax.swing. JMenu

在给定位置插入指定的 JMenuitem 。

insert(MutableTreeNode, int) - Method in class javax.swing.tree. DefaultMutableTreeNode

从其当前父项（如果它有一个父项）中删除 newChild ，将该子节点的父节点设置为此节点，然后将该子节点添加到此节点的子阵列（索引号为 childIndex 。

insert(MutableTreeNode, int) - Method in interface javax.swing.tree. MutableTreeNode

在 child向接收方添加 index 。

insert(Any, boolean[]) - Static method in class org.omg.CORBA. BooleanSeqHelper

insert(Any, byte[]) - Static method in class org.omg.CORBA. OctetSeqHelper

insert(Any, byte[]) - Static method in class org.omg.PortableInterceptor. ObjectIdHelper

insert(Any, char[]) - Static method in class org.omg.CORBA. CharSeqHelper

insert(Any, char[]) - Static method in class org.omg.CORBA. WCharSeqHelper

insert(Any, double[]) - Static method in class org.omg.CORBA. DoubleSeqHelper

insert(Any, float[]) - Static method in class org.omg.CORBA. FloatSeqHelper

insert(Any, int) - Static method in class org.omg.CORBA. PolicyTypeHelper

insert(Any, int) - Static method in class org.omg.IOP. ComponentIdHelper

insert(Any, int) - Static method in class org.omg.IOP. ProfileIdHelper

insert(Any, int) - Static method in class org.omg.IOP. ServiceIdHelper

insert(Any, int) - Static method in class org.omg.PortableInterceptor. AdapterManagerIdHelper

insert(Any, int[]) - Static method in class org.omg.CORBA. LongSeqHelper

insert(Any, int[]) - Static method in class org.omg.CORBA. ULongSeqHelper

insert(Any, long[]) - Static method in class org.omg.CORBA. LongLongSeqHelper

insert(Any, long[]) - Static method in class org.omg.CORBA. ULongLongSeqHelper

insert(Any, short) - Static method in class org.omg.CORBA. PolicyErrorCodeHelper

insert(Any, short) - Static method in class org.omg.CORBA. VisibilityHelper

insert(Any, short) - Static method in class org.omg.Messaging. SyncScopeHelper

insert(Any, short) - Static method in class org.omg.PortableInterceptor. AdapterStateHelper

insert(Any, short[]) - Static method in class org.omg.CORBA. ShortSeqHelper

insert(Any, short[]) - Static method in class org.omg.CORBA. UShortSeqHelper

insert(Any, Serializable) - Static method in class org.omg.CORBA. ValueBaseHelper

insert(Any, String) - Static method in class org.omg.CORBA. FieldNameHelper

insert(Any, String) - Static method in class org.omg.CORBA. IdentifierHelper

insert(Any, String) - Static method in class org.omg.CORBA. RepositoryIdHelper

insert(Any, String) - Static method in class org.omg.CORBA. StringValueHelper

insert(Any, String) - Static method in class org.omg.CORBA. VersionSpecHelper

insert(Any, String) - Static method in class org.omg.CORBA. WStringValueHelper

insert(Any, String) - Static method in class org.omg.CosNaming. IstringHelper

insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage. AddressHelper

insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage. StringNameHelper

insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage. URLStringHelper

insert(Any, String) - Static method in class org.omg.DynamicAny. FieldNameHelper

insert(Any, String) - Static method in class org.omg.PortableInterceptor. ORBIdHelper

insert(Any, String) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. ObjectIdHelper

insert(Any, String) - Static method in class org.omg.PortableInterceptor. ServerIdHelper

insert(Any, String[]) - Static method in class org.omg.CORBA. StringSeqHelper

insert(Any, String[]) - Static method in class org.omg.CORBA. WStringSeqHelper

insert(Any, String[]) - Static method in class org.omg.PortableInterceptor. AdapterNameHelper

insert(Any, Any[]) - Static method in class org.omg.CORBA. AnySeqHelper

insert(Any, Any[]) - Static method in class org.omg.DynamicAny. AnySeqHelper

insert(Any, Bounds) - Static method in class org.omg.CORBA. BoundsHelper

insert(Any, CompletionStatus) - Static method in class org.omg.CORBA. CompletionStatusHelper

insert(Any, Current) - Static method in class org.omg.CORBA. CurrentHelper

insert(Any, DefinitionKind) - Static method in class org.omg.CORBA. DefinitionKindHelper

insert(Any, IDLType) - Static method in class org.omg.CORBA. IDLTypeHelper

insert(Any, NameValuePair) - Static method in class org.omg.CORBA. NameValuePairHelper

insert(Any, Object) - Static method in class org.omg.CORBA. ObjectHelper

insert(Any, InvalidName) - Static method in class org.omg.CORBA.ORBPackage. InvalidNameHelper

insert(Any, ParameterMode) - Static method in class org.omg.CORBA. ParameterModeHelper

insert(Any, Policy) - Static method in class org.omg.CORBA. PolicyHelper

insert(Any, Policy[]) - Static method in class org.omg.CORBA. PolicyListHelper

insert(Any, PolicyError) - Static method in class org.omg.CORBA. PolicyErrorHelper

insert(Any, ServiceDetail) - Static method in class org.omg.CORBA. ServiceDetailHelper

insert(Any, ServiceInformation) - Static method in class org.omg.CORBA. ServiceInformationHelper

insert(Any, SetOverrideType) - Static method in class org.omg.CORBA. SetOverrideTypeHelper

insert(Any, StructMember) - Static method in class org.omg.CORBA. StructMemberHelper

insert(Any, BadKind) - Static method in class org.omg.CORBA.TypeCodePackage. BadKindHelper

insert(Any, Bounds) - Static method in class org.omg.CORBA.TypeCodePackage. BoundsHelper

insert(Any, UnionMember) - Static method in class org.omg.CORBA. UnionMemberHelper

insert(Any, UnknownUserException) - Static method in class org.omg.CORBA. UnknownUserExceptionHelper

insert(Any, ValueMember) - Static method in class org.omg.CORBA. ValueMemberHelper

insert(Any, WrongTransaction) - Static method in class org.omg.CORBA. WrongTransactionHelper

insert(Any, Binding) - Static method in class org.omg.CosNaming. BindingHelper

insert(Any, Binding[]) - Static method in class org.omg.CosNaming. BindingListHelper

insert(Any, BindingIterator) - Static method in class org.omg.CosNaming. BindingIteratorHelper

insert(Any, BindingType) - Static method in class org.omg.CosNaming. BindingTypeHelper

insert(Any, NameComponent) - Static method in class org.omg.CosNaming. NameComponentHelper

insert(Any, NameComponent[]) - Static method in class org.omg.CosNaming. NameHelper

insert(Any, NamingContext) - Static method in class org.omg.CosNaming. NamingContextHelper

insert(Any, NamingContextExt) - Static method in class org.omg.CosNaming. NamingContextExtHelper

insert(Any, InvalidAddress) - Static method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHelper

insert(Any, AlreadyBound) - Static method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHelper

insert(Any, CannotProceed) - Static method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHelper

insert(Any, InvalidName) - Static method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHelper

insert(Any, NotEmpty) - Static method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHelper

insert(Any, NotFound) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundHelper

insert(Any, NotFoundReason) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHelper

insert(Any, DynAny) - Static method in class org.omg.DynamicAny. DynAnyHelper

insert(Any, DynAny[]) - Static method in class org.omg.DynamicAny. DynAnySeqHelper

insert(Any, DynAnyFactory) - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper

insert(Any, InconsistentTypeCode) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCodeHelper

insert(Any, InvalidValue) - Static method in class org.omg.DynamicAny.DynAnyPackage. InvalidValueHelper

insert(Any, TypeMismatch) - Static method in class org.omg.DynamicAny.DynAnyPackage. TypeMismatchHelper

insert(Any, DynArray) - Static method in class org.omg.DynamicAny. DynArrayHelper

insert(Any, DynEnum) - Static method in class org.omg.DynamicAny. DynEnumHelper

insert(Any, DynFixed) - Static method in class org.omg.DynamicAny. DynFixedHelper

insert(Any, DynSequence) - Static method in class org.omg.DynamicAny. DynSequenceHelper

insert(Any, DynStruct) - Static method in class org.omg.DynamicAny. DynStructHelper

insert(Any, DynUnion) - Static method in class org.omg.DynamicAny. DynUnionHelper

insert(Any, DynValue) - Static method in class org.omg.DynamicAny. DynValueHelper

insert(Any, NameDynAnyPair) - Static method in class org.omg.DynamicAny. NameDynAnyPairHelper

insert(Any, NameDynAnyPair[]) - Static method in class org.omg.DynamicAny. NameDynAnyPairSeqHelper

insert(Any, NameValuePair) - Static method in class org.omg.DynamicAny. NameValuePairHelper

insert(Any, NameValuePair[]) - Static method in class org.omg.DynamicAny. NameValuePairSeqHelper

insert(Any, CodecFactory) - Static method in class org.omg.IOP. CodecFactoryHelper

insert(Any, UnknownEncoding) - Static method in class org.omg.IOP.CodecFactoryPackage. UnknownEncodingHelper

insert(Any, FormatMismatch) - Static method in class org.omg.IOP.CodecPackage. FormatMismatchHelper

insert(Any, InvalidTypeForEncoding) - Static method in class org.omg.IOP.CodecPackage. InvalidTypeForEncodingHelper

insert(Any, TypeMismatch) - Static method in class org.omg.IOP.CodecPackage. TypeMismatchHelper

insert(Any, IOR) - Static method in class org.omg.IOP. IORHelper

insert(Any, ServiceContext) - Static method in class org.omg.IOP. ServiceContextHelper

insert(Any, ServiceContext[]) - Static method in class org.omg.IOP. ServiceContextListHelper

insert(Any, TaggedComponent) - Static method in class org.omg.IOP. TaggedComponentHelper

insert(Any, TaggedComponent[]) - Static method in class org.omg.IOP. MultipleComponentProfileHelper

insert(Any, TaggedProfile) - Static method in class org.omg.IOP. TaggedProfileHelper

insert(Any, Current) - Static method in class org.omg.PortableInterceptor. CurrentHelper

insert(Any, ForwardRequest) - Static method in class org.omg.PortableInterceptor. ForwardRequestHelper

insert(Any, InvalidSlot) - Static method in class org.omg.PortableInterceptor. InvalidSlotHelper

insert(Any, IORInterceptor_3_0) - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper

insert(Any, ObjectReferenceFactory) - Static method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHelper

insert(Any, ObjectReferenceTemplate) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHelper

insert(Any, ObjectReferenceTemplate[]) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHelper

insert(Any, DuplicateName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateNameHelper

insert(Any, InvalidName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidNameHelper

insert(Any, Current) - Static method in class org.omg.PortableServer. CurrentHelper

insert(Any, NoContext) - Static method in class org.omg.PortableServer.CurrentPackage. NoContextHelper

insert(Any, ForwardRequest) - Static method in class org.omg.PortableServer. ForwardRequestHelper

insert(Any, POA) - Static method in class org.omg.PortableServer. POAHelper

insert(Any, AdapterInactive) - Static method in class org.omg.PortableServer.POAManagerPackage. AdapterInactiveHelper

insert(Any, AdapterAlreadyExists) - Static method in class org.omg.PortableServer.POAPackage. AdapterAlreadyExistsHelper

insert(Any, AdapterNonExistent) - Static method in class org.omg.PortableServer.POAPackage. AdapterNonExistentHelper

insert(Any, InvalidPolicy) - Static method in class org.omg.PortableServer.POAPackage. InvalidPolicyHelper

insert(Any, NoServant) - Static method in class org.omg.PortableServer.POAPackage. NoServantHelper

insert(Any, ObjectAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage. ObjectAlreadyActiveHelper

insert(Any, ObjectNotActive) - Static method in class org.omg.PortableServer.POAPackage. ObjectNotActiveHelper

insert(Any, ServantAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage. ServantAlreadyActiveHelper

insert(Any, ServantNotActive) - Static method in class org.omg.PortableServer.POAPackage. ServantNotActiveHelper

insert(Any, WrongAdapter) - Static method in class org.omg.PortableServer.POAPackage. WrongAdapterHelper

insert(Any, WrongPolicy) - Static method in class org.omg.PortableServer.POAPackage. WrongPolicyHelper

insert(Any, ServantActivator) - Static method in class org.omg.PortableServer. ServantActivatorHelper

insert(Any, ServantLocator) - Static method in class org.omg.PortableServer. ServantLocatorHelper

INSERT - javafx.scene.input. KeyCode

常数为 Insert键。

INSERT - javax.swing. DropMode

应该根据插入新数据的位置跟踪放置位置。

INSERT - Static variable in class java.awt. Event

已过时。

插入键，非ASCII操作键。

INSERT - Static variable in interface javax.accessibility. AccessibleTableModelChange

标识新行和/或列的插入。

INSERT - Static variable in class javax.swing.event. DocumentEvent.EventType

插入类型。

INSERT - Static variable in class javax.swing.event. TableModelEvent

标识新行或列的添加。

insert_any(Any) - Method in class org.omg.CORBA. Any

将给定的 Any对象插入到此 Any对象的 value字段中。

insert_any(Any) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 org.omg.CORBA.Any对象作为此 DynAny对象的值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynAnyStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynArrayStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynEnumStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynFixedStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynSequenceStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynStructStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynUnionStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in class org.omg.DynamicAny. _DynValueStub

在此DynAny表示的Any中插入任何值。

insert_any(Any) - Method in interface org.omg.DynamicAny. DynAnyOperations

在此DynAny表示的Any中插入任何值。

insert_boolean(boolean) - Method in class org.omg.CORBA. Any

将给定的 boolean插入到这个 Any对象的 value字段中。

insert_boolean(boolean) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 boolean作为此 DynAny对象的值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个布尔值。

insert_boolean(boolean) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个布尔值。

insert_char(char) - Method in class org.omg.CORBA. Any

将给定的 char插入到这个 Any对象的 value字段中。

insert_char(char) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 char作为此 DynAny对象的值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个char值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个char值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个char值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个char值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个char值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个char值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个char值。

insert_char(char) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个char值。

insert_char(char) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个char值。

INSERT_COLS - javax.swing. DropMode

应根据列索引来跟踪放置位置，其中应插入新列以适应丢弃的数据。

insert_double(double) - Method in class org.omg.CORBA. Any

将给定的 double插入到这个 Any对象的 value字段中。

insert_double(double) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 double作为该 DynAny对象的值插入。

insert_double(double) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个双重值。

insert_double(double) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个双重值。

insert_double(double) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个双重值。

insert_double(double) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个双重值。

insert_double(double) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个双重值。

insert_double(double) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个双重值。

insert_double(double) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个双重值。

insert_double(double) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个双重值。

insert_double(double) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个双重值。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynAnyStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynArrayStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynEnumStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynFixedStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynSequenceStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynStructStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynUnionStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny. _DynValueStub

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_dyn_any(DynAny) - Method in interface org.omg.DynamicAny. DynAnyOperations

将包含在参数DynAny中的Any值插入到此DynAny表示的Any中。

insert_fixed(BigDecimal) - Method in class org.omg.CORBA. Any

抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。

insert_fixed(BigDecimal, TypeCode) - Method in class org.omg.CORBA. Any

抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。

insert_float(float) - Method in class org.omg.CORBA. Any

将给定的 float插入到这个 Any对象的 value字段中。

insert_float(float) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 float作为此 DynAny对象的值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个浮点值。

insert_float(float) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个浮点值。

INSERT_HORIZONTAL_RULE - javafx.scene.web. HTMLEditorSkin.Command

insert_long(int) - Method in class org.omg.CORBA. Any

将给定的 int插入到这个 Any对象的 value字段中。

insert_long(int) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 int作为此 DynAny对象的值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个整数值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个整数值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个整数值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个整数值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个整数值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个整数值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个整数值。

insert_long(int) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个整数值。

insert_long(int) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个整数值。

insert_longlong(long) - Method in class org.omg.CORBA. Any

将给定的 long插入到这个 Any对象的 value字段中。

insert_longlong(long) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 long作为此 DynAny对象的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个长的值。

insert_longlong(long) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个长的值。

INSERT_NEW_LINE - javafx.scene.web. HTMLEditorSkin.Command

insert_Object(Object) - Method in class org.omg.CORBA. Any

将给定的 org.omg.CORBA.Object对象插入到这个 Any对象的 value字段中。

insert_Object(Object, TypeCode) - Method in class org.omg.CORBA. Any

将给定的 org.omg.CORBA.Object对象插入到此 Any对象的 value字段中。

insert_octet(byte) - Method in class org.omg.CORBA. Any

将给定的 byte插入到这个 Any对象的 value字段中。

insert_octet(byte) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 byte插入作为此 DynAny对象的值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个字节值。

insert_octet(byte) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个字节值。

insert_Principal(Principal) - Method in class org.omg.CORBA. Any

已过时。
被CORBA弃用2.2。

insert_reference(Object) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 org.omg.CORBA.Object插入作为此 DynAny对象的值。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynAnyStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynArrayStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynEnumStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynFixedStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynSequenceStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynStructStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynUnionStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in class org.omg.DynamicAny. _DynValueStub

将CORBA对象的引用插入到DynAny中。

insert_reference(Object) - Method in interface org.omg.DynamicAny. DynAnyOperations

将CORBA对象的引用插入到DynAny中。

INSERT_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi. SyncResolver

表示当 RowSet对象尝试在数据源中插入一行时发生冲突。

INSERT_ROWS - javax.swing. DropMode

应该根据行索引来跟踪放置位置，其中应插入新行以适应丢弃的数据。

insert_short(short) - Method in class org.omg.CORBA. Any

将给定的 short插入到这个 Any对象的 value字段中。

insert_short(short) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 short插入作为此 DynAny对象的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个简短的值。

insert_short(short) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个简短的值。

insert_Streamable(Streamable) - Method in class org.omg.CORBA. Any

将给定的 Streamable对象插入到此 Any对象的 value字段中。

insert_string(String) - Method in class org.omg.CORBA. Any

将给定的 String对象插入到此 Any对象的 value字段中。

insert_string(String) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 String对象作为此 DynAny对象的值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个字符串值。

insert_string(String) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个字符串值。

INSERT_TAB - javafx.scene.web. HTMLEditorSkin.Command

insert_typecode(TypeCode) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 org.omg.CORBA.TypeCode作为此 DynAny对象的值。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynAnyStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynArrayStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynEnumStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynFixedStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynSequenceStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynStructStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynUnionStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in class org.omg.DynamicAny. _DynValueStub

将TypeCode对象插入到DynAny中。

insert_typecode(TypeCode) - Method in interface org.omg.DynamicAny. DynAnyOperations

将TypeCode对象插入到DynAny中。

insert_TypeCode(TypeCode) - Method in class org.omg.CORBA. Any

将给定的 TypeCode对象插入到此 Any对象的 value字段中。

insert_ulong(int) - Method in class org.omg.CORBA. Any

将给定的 int插入到这个 Any对象的 value字段中。

insert_ulong(int) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 int插入作为此 DynAny对象的值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个整数值。

insert_ulong(int) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个整数值。

insert_ulonglong(long) - Method in class org.omg.CORBA. Any

将给定的 long插入到这个 Any对象的 value字段中。

insert_ulonglong(long) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 long作为该 DynAny对象的值插入。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个长的值。

insert_ulonglong(long) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个长的值。

insert_ushort(short) - Method in class org.omg.CORBA. Any

将给定的 short插入到这个 Any对象的 value字段中。

insert_ushort(short) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 short作为此 DynAny对象的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个简短的值。

insert_ushort(short) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个简短的值。

insert_val(Serializable) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 java.io.Serializable对象插入作为此 DynAny对象的值。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynAnyStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynArrayStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynEnumStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynFixedStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynSequenceStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynStructStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynUnionStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in class org.omg.DynamicAny. _DynValueStub

将可序列化对象的引用插入此DynAny。

insert_val(Serializable) - Method in interface org.omg.DynamicAny. DynAnyOperations

将可序列化对象的引用插入此DynAny。

insert_Value(Serializable) - Method in class org.omg.CORBA. Any

将给定的 java.io.Serializable对象插入到此 Any对象的 value字段中。

insert_Value(Serializable, TypeCode) - Method in class org.omg.CORBA. Any

将给定的 java.io.Serializable对象插入到此 Any对象的 value字段中。

insert_wchar(char) - Method in class org.omg.CORBA. Any

将给定的 char插入到这个 Any对象的 value字段中。

insert_wchar(char) - Method in interface org.omg.CORBA. DynAny

已过时。

插入给定的 char作为此 DynAny对象的值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个char值。

insert_wchar(char) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个char值。

insert_wstring(String) - Method in class org.omg.CORBA. Any

将给定的 String对象插入到此 Any对象的 value字段中。

insert_wstring(String) - Method in interface org.omg.CORBA. DynAny

已过时。

将给定的 String插入作为此 DynAny对象的值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynAnyStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynArrayStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynEnumStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynFixedStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynSequenceStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynStructStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynUnionStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in class org.omg.DynamicAny. _DynValueStub

在DynAny中插入一个字符串值。

insert_wstring(String) - Method in interface org.omg.DynamicAny. DynAnyOperations

在DynAny中插入一个字符串值。

insertAfterEnd(Element, String) - Method in class javax.swing.text.html. HTMLDocument

在给定元素结束后插入指定为字符串的HTML。

insertAfterStart(Element, String) - Method in class javax.swing.text.html. HTMLDocument

在元素的开始处插入指定为字符串的HTML。

insertArguments(MethodHandle, int, Object...) - Static method in class java.lang.invoke. MethodHandles

在方法句柄的调用之前提供一个具有一个或多个 绑定参数的目标方法句柄。

insertAtBoundary(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - Method in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction

在插入边界时调用这一点。

insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - Method in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction

已过时。
从Java 2平台v1.3开始，使用insertAtBoundary

insertBefore(Node, Node) - Method in class javax.imageio.metadata. IIOMetadataNode

插入节点 newChild现有的子节点之前 refChild 。

insertBefore(Node, Node) - Method in interface org.w3c.dom. Node

插入节点 newChild现有的子节点之前 refChild 。

insertBeforeEnd(Element, String) - Method in class javax.swing.text.html. HTMLDocument

在元素的末尾插入指定为字符串的HTML。

insertBeforeStart(Element, String) - Method in class javax.swing.text.html. HTMLDocument

在给定元素开始之前插入指定为字符串的HTML。

insertBreakAction - Static variable in class javax.swing.text. DefaultEditorKit

将行/段落段落放入文档的操作名称。

InsertBreakAction() - Constructor for class javax.swing.text. DefaultEditorKit.InsertBreakAction

使用相应的标识符创建此对象。

insertCell(int) - Method in interface org.w3c.dom.html. HTMLTableRowElement

在此行中插入一个空的 TD单元格。

insertChar(AttributedCharacterIterator, int) - Method in class java.awt.font. LineBreakMeasurer

在将单个字符插入到文本中后，更新此 LineBreakMeasurer ，并将当前位置设置为段落的开头。

insertChar(AttributedCharacterIterator, int) - Method in class java.awt.font. TextMeasurer

更新 TextMeasurer单个字符已经被插入到当前这个表示的段落后 TextMeasurer 。

insertComponent(Component) - Method in class javax.swing. JTextPane

将组件插入到文档中作为当前所选内容的替代。

insertContentAction - Static variable in class javax.swing.text. DefaultEditorKit

将内容放入关联文档的操作名称。

InsertContentAction() - Constructor for class javax.swing.text. DefaultEditorKit.InsertContentAction

使用相应的标识符创建此对象。

insertData(int, String) - Method in interface org.w3c.dom. CharacterData

以指定的16位单位偏移量插入字符串。

insertElementAt(E, int) - Method in class java.util. Vector

在指定的 index插入指定对象作为此向量中的 index 。

insertElementAt(E, int) - Method in class javax.swing. DefaultComboBoxModel

insertElementAt(E, int) - Method in class javax.swing. DefaultListModel

在指定的 index中将指定的元素插入此列表中的 index 。

insertElementAt(E, int) - Method in interface javax.swing. MutableComboBoxModel

在特定索引中添加项目。

insertEntries(int, int, int) - Method in class javax.swing. SizeSequence

在这个 SizeSequence添加一组连续的条目。

insertHTML(JEditorPane, HTMLDocument, int, String, int, int, HTML.Tag) - Method in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction

HTMLEditorKit.insertHTML的封面。

insertHTML(HTMLDocument, int, String, int, int, HTML.Tag) - Method in class javax.swing.text.html. HTMLEditorKit

将HTML插入到现有文档中。

InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag) - Constructor for class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction

创建一个新的InsertHTMLTextAction。

InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag, HTML.Tag, HTML.Tag) - Constructor for class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction

创建一个新的InsertHTMLTextAction。

insertIcon(Icon) - Method in class javax.swing. JTextPane

将图标插入到文档中作为当前所选内容的替代。

insertIndexForLayer(int, int) - Method in class javax.swing. JLayeredPane

确定基于层和位置请求插入新孩子的正确位置的原始方法。

insertIndexInterval(int, int, boolean) - Method in class javax.swing. DefaultListSelectionModel

在索引之前/之后插入长度索引。

insertIndexInterval(int, int, boolean) - Method in interface javax.swing. ListSelectionModel

插入 length指数开始前/后 index 。

insertItemAt(E, int) - Method in class javax.swing. JComboBox

在给定索引的项目列表中插入项目。

insertNode(Node) - Method in interface org.w3c.dom.ranges. Range

在Range的开头插入一个节点到Document或DocumentFragment。

insertNodeInto(MutableTreeNode, MutableTreeNode, int) - Method in class javax.swing.tree. DefaultTreeModel

调用此选项将parentChild插入到父项子节点的位置索引中。

insertParameterTypes(int, Class<?>...) - Method in class java.lang.invoke. MethodType

查找或创建具有其他参数类型的方法类型。

insertParameterTypes(int, List<Class<?>>) - Method in class java.lang.invoke. MethodType

查找或创建具有其他参数类型的方法类型。

insertProviderAt(Provider, int) - Static method in class java.security. Security

在指定的位置添加一个新的提供者。

insertRow() - Method in interface java.sql. ResultSet

将插入行的内容插入到此 ResultSet对象中并进入数据库。

insertRow(int) - Method in interface org.w3c.dom.html. HTMLTableElement

在表中插入一个新的空行。

insertRow(int) - Method in interface org.w3c.dom.html. HTMLTableSectionElement

在此部分插入一行。

insertRow(int, Object[]) - Method in class javax.swing.table. DefaultTableModel

在模型中插入一行 row 。

insertRow(int, Vector<?>) - Method in class javax.swing.table. DefaultTableModel

在模型中插入一行 row 。

insertRule(String, int) - Method in interface org.w3c.dom.css. CSSMediaRule

用于在媒体块中插入新的规则。

insertRule(String, int) - Method in interface org.w3c.dom.css. CSSStyleSheet

用于在样式表中插入新规则。

insertsAreDetected(int) - Method in interface java.sql. DatabaseMetaData

检索是否可以通过调用方法 ResultSet.rowInserted检测到可见的行插入。

insertSeparator(int) - Method in class java.awt. Menu

在指定位置插入分隔符。

insertSeparator(int) - Method in class javax.swing. JMenu

在指定位置插入分隔符。

insertString(int, String) - Method in interface javax.swing.text. AbstractDocument.Content

在序列中插入一串字符。

insertString(int, String) - Method in class javax.swing.text. GapContent

在内容中插入一个字符串。

insertString(int, String) - Method in class javax.swing.text. StringContent

在内容中插入一个字符串。

insertString(int, String, AttributeSet) - Method in class javax.swing.text. AbstractDocument

在文档中插入一些内容。

insertString(int, String, AttributeSet) - Method in interface javax.swing.text. Document

插入一串内容。

insertString(int, String, AttributeSet) - Method in class javax.swing.text. DocumentFilter.FilterBypass

插入指定的文本，绕过DocumentFilter。

insertString(int, String, AttributeSet) - Method in class javax.swing.text. PlainDocument

在文档中插入一些内容。

insertString(DocumentFilter.FilterBypass, int, String, AttributeSet) - Method in class javax.swing.text. DocumentFilter

在将文本插入指定的文档之前调用。

insertTab(String, Icon, Component, String, int) - Method in class javax.swing. JTabbedPane

在给定的索引处插入给定组件的新选项卡，由给定的标题和/或图标表示，其中任一个可能为 null 。

insertTabAction - Static variable in class javax.swing.text. DefaultEditorKit

将标签字符放入文档的操作名称。

InsertTabAction() - Constructor for class javax.swing.text. DefaultEditorKit.InsertTabAction

使用相应的标识符创建此对象。

insertText(int, String) - Method in class javafx.scene.control. TextInputControl

在内容中插入一串字符。

insertText(String, int) - Method in class java.awt. TextArea

已过时。
从JDK 1.1版开始，由insert(String, int)替代。

insertTextAtIndex(int, String) - Method in interface javax.accessibility. AccessibleEditableText

在指定的索引处插入指定的字符串。

insertTextAtIndex(int, String) - Method in class javax.swing. JSpinner.AccessibleJSpinner

在指定的索引/

insertTextAtIndex(int, String) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

在指定的索引处插入指定的字符串

insertUpdate(DocumentEvent) - Method in interface javax.swing.event. DocumentListener

通知文件中插入文件。

insertUpdate(DocumentEvent) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

处理文档插入（触发适当的属性更改事件AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. FieldView

在该视图负责的位置发出通知。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. FlowView

在该视图负责的位置发出通知。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. GlyphView

在该视图负责的位置发出通知。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html. InlineView

在该视图负责的位置发出通知。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. PlainView

在该视图负责的位置发出通知。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. View

在该视图负责的位置发出通知。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. WrappedPlainView

在该视图负责的位置发出通知。

insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. ZoneView

在该视图负责的位置发出通知。

insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text. AbstractDocument

更新由于文本插入而导致的文档结构。

insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text. DefaultStyledDocument

更新由于文本插入而导致的文档结构。

insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.html. HTMLDocument

更新由于文本插入而导致的文档结构。

insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text. PlainDocument

更新由于文本插入而导致的文档结构。

insertUpdate(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer

在文档中插入更新。

insertUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text. FlowView.FlowStrategy

在给定的流程视图负责的位置发出通知。

insetCache - Variable in class javax.swing.plaf.basic. BasicSliderUI

插入缓存

insets - Variable in class java.awt. GridBagConstraints

该字段指定组件的外部填充，组件与其显示区域的边缘之间的最小空间量。

insets() - Method in class java.awt. Container

已过时。
从JDK 1.1版开始，由getInsets()替代。

Insets - Class in java.awt

一个 Insets对象是容器边框的表示。

Insets - Class in javafx.geometry

一组矩形区域的4边的内部偏移量

Insets(double) - Constructor for class javafx.geometry. Insets

为所有四个偏移量构造一个新的Insets实例，具有相同的值。

Insets(double, double, double, double) - Constructor for class javafx.geometry. Insets

构造一个具有四个不同偏移量的新Insets实例。

Insets(int, int, int, int) - Constructor for class java.awt. Insets

使用指定的顶部，左侧，底部和右侧插入创建并初始化新的 Insets对象。

InsetsConverter - Class in javafx.css.converter

将1到4个大小组件的解析值数组转换为Insets。

InsetsConverter.SequenceConverter - Class in javafx.css.converter

将一组解析的值转换为Insets对象数组，每个值都是1到4个大小的数组。

insetsProperty() - Method in class javafx.scene.layout. Region

区域的插图定义从区域边缘（其布局边界，或（0,0，宽度，高度））到内容区域边缘的距离。

InsetsUIResource - Class in javax.swing.plaf

Insets实现UIResource的子类。

InsetsUIResource(int, int, int, int) - Constructor for class javax.swing.plaf. InsetsUIResource

构造一个 InsetsUIResource 。

inside(int, int) - Method in class java.awt. Component

已过时。
从JDK 1.1版开始，由contains（int，int）替换。

inside(int, int) - Method in class java.awt. Polygon

已过时。
从JDK 1.1版开始，由contains(int, int)替代。

inside(int, int) - Method in class java.awt. Rectangle

已过时。
从JDK 1.1版开始，由contains(int, int)替代。

INSIDE - javafx.scene.shape. StrokeType

通过将封闭的Shape节点的边界延伸到其内部由strokeWidth指定的距离来应用行程 。

insideBorder - Variable in class javax.swing.border. CompoundBorder

内边界。

insideTimerAction() - Constructor for class javax.swing. ToolTipManager.insideTimerAction

install(Node, Tooltip) - Static method in class javafx.scene.control. Tooltip

将给定的Tooltip与给定的Node相关联 。

install(JEditorPane) - Method in class javax.swing.text. EditorKit

当该套件安装到JEditorPane中时调用。

install(JEditorPane) - Method in class javax.swing.text.html. HTMLEditorKit

当该套件安装到JEditorPane中时调用。

install(JEditorPane) - Method in class javax.swing.text. StyledEditorKit

将套件安装到JEditorPane中时调用。

install(JFormattedTextField) - Method in class javax.swing. JFormattedTextField.AbstractFormatter

将 AbstractFormatter安装到特定的 JFormattedTextField 。

install(JFormattedTextField) - Method in class javax.swing.text. DefaultFormatter

将 DefaultFormatter安装到特定的 JFormattedTextField 。

install(JFormattedTextField) - Method in class javax.swing.text. InternationalFormatter

将 DefaultFormatter安装到特定的 JFormattedTextField 。

install(JFormattedTextField) - Method in class javax.swing.text. MaskFormatter

将 DefaultFormatter安装到特定的 JFormattedTextField 。

install(JTextComponent) - Method in interface javax.swing.text. Caret

当UI被安装到JTextComponent的接口时调用。

install(JTextComponent) - Method in class javax.swing.text. DefaultCaret

当UI被安装到JTextComponent的接口时调用。

install(JTextComponent) - Method in class javax.swing.text. DefaultHighlighter

当UI被安装到JTextComponent的接口时调用。

install(JTextComponent) - Method in interface javax.swing.text. Highlighter

当UI被安装到JTextComponent的接口时调用。

installAncestorListener() - Method in class javax.swing. JComboBox

注册祖先监听器，以便它或它的任何祖先移动或使其可见或不可见时将接收 AncestorEvents 。

installBorder(JComponent, String) - Static method in class javax.swing. LookAndFeel

使用默认值设置组件边框属性的便利方法。

installChooserPanel(JColorChooser) - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

当面板添加到选择器时调用。

installColors(JComponent, String, String) - Static method in class javax.swing. LookAndFeel

使用默认值设置组件的前景和背景颜色属性的便利方法。

installColorsAndFont(JComponent, String, String, String) - Static method in class javax.swing. LookAndFeel

使用默认值设置组件的前景，背景和字体属性的便利方法。

installComboBoxListeners() - Method in class javax.swing.plaf.basic. BasicComboPopup

此方法将必要的侦听器添加到JComboBox。

installComboBoxModelListeners(ComboBoxModel<?>) - Method in class javax.swing.plaf.basic. BasicComboPopup

在组合框模型上安装侦听器。

installComponents() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

创建和初始化构成聚合组合框的组件。

installComponents() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

注册组件。

installComponents() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

安装组件。

installComponents() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

注册组件。

installComponents() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

安装组件。

installComponents() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

为JTabbedPane创建并安装任何所需的子组件。

installComponents() - Method in class javax.swing.plaf.basic. BasicToolBarUI

注册组件。

installComponents() - Method in class javax.swing.plaf.basic. BasicTreeUI

填充树的子组件，即渲染器窗格。

installComponents() - Method in class javax.swing.plaf.metal. MetalDesktopIconUI

installComponents() - Method in class javax.swing.plaf.synth. SynthDesktopIconUI

注册组件。

installComponents() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI

注册组件。

installComponents() - Method in class javax.swing.plaf.synth. SynthToolBarUI

注册组件。

installComponents(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

安装组件。

installComponents(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

installComponents(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI

注册组件。

installComponents(JMenuItem) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

installComponents(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI

安装组件

installDefaults() - Method in class javax.swing.plaf.basic. BasicColorChooserUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

将默认颜色，默认字体，默认渲染器和默认编辑器安装到JComboBox中。

installDefaults() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

安装默认值。

installDefaults() - Method in class javax.swing.plaf.basic. BasicListUI

初始化字体，前景和背景等列表属性，并添加CellRendererPane。

installDefaults() - Method in class javax.swing.plaf.basic. BasicMenuBarUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicMenuItemUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicMenuUI

installDefaults() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicPasswordFieldUI

在JPasswordField上安装必要的属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicPopupMenuUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

安装默认值。

installDefaults() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

初始化 JSpinner border ， foreground和 background基于从默认值表中对应的“微调。*”的属性，属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

安装UI默认值。

installDefaults() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

安装默认值。

installDefaults() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

初始化JTableHeader属性，如字体，前景和背景。

installDefaults() - Method in class javax.swing.plaf.basic. BasicTableUI

初始化JTable属性，例如字体，前景和背景。

installDefaults() - Method in class javax.swing.plaf.basic. BasicTextAreaUI

installDefaults() - Method in class javax.swing.plaf.basic. BasicTextUI

初始化组件属性，如字体，前景，背景，插入符号颜色，选择颜色，选定的文本颜色，禁用的文本颜色和边框颜色。

installDefaults() - Method in class javax.swing.plaf.basic. BasicToolBarUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.basic. BasicTreeUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.metal. MetalDesktopIconUI

installDefaults() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane

installDefaults() - Method in class javax.swing.plaf.metal. MetalScrollBarUI

installDefaults() - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

installDefaults() - Method in class javax.swing.plaf.synth. SynthColorChooserUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthComboBoxUI

installDefaults() - Method in class javax.swing.plaf.synth. SynthDesktopIconUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthEditorPaneUI

初始化组件属性，如字体，前景，背景，插入符号颜色，选择颜色，选定的文本颜色，禁用的文本颜色和边框颜色。

installDefaults() - Method in class javax.swing.plaf.synth. SynthInternalFrameUI

安装默认值。

installDefaults() - Method in class javax.swing.plaf.synth. SynthListUI

初始化字体，前景和背景等列表属性，并添加CellRendererPane。

installDefaults() - Method in class javax.swing.plaf.synth. SynthMenuBarUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthMenuItemUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthMenuUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthPopupMenuUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthProgressBarUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthScrollBarUI

安装默认值。

installDefaults() - Method in class javax.swing.plaf.synth. SynthSpinnerUI

初始化 JSpinner border ， foreground和 background基于从默认值表中对应的“微调。*”的属性，属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthSplitPaneUI

安装UI默认值。

installDefaults() - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

安装默认值。

installDefaults() - Method in class javax.swing.plaf.synth. SynthTableHeaderUI

初始化JTableHeader属性，如字体，前景和背景。

installDefaults() - Method in class javax.swing.plaf.synth. SynthTableUI

初始化JTable属性，如字体，前景和背景。

installDefaults() - Method in class javax.swing.plaf.synth. SynthTextAreaUI

初始化组件属性，如字体，前景，背景，插入符号颜色，选择颜色，选定的文本颜色，禁用的文本颜色和边框颜色。

installDefaults() - Method in class javax.swing.plaf.synth. SynthTextFieldUI

初始化组件属性，如字体，前景，背景，插入符号颜色，选择颜色，选定的文本颜色，禁用的文本颜色和边框颜色。

installDefaults() - Method in class javax.swing.plaf.synth. SynthToolBarUI

安装默认属性。

installDefaults() - Method in class javax.swing.plaf.synth. SynthTreeUI

安装默认属性。

installDefaults(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI

安装默认属性。

installDefaults(AbstractButton) - Method in class javax.swing.plaf.basic. BasicRadioButtonUI

installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalButtonUI

installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalCheckBoxUI

installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalRadioButtonUI

installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalToggleButtonUI

installDefaults(AbstractButton) - Method in class javax.swing.plaf.synth. SynthButtonUI

安装默认属性。

installDefaults(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI

安装默认属性。

installDefaults(JComponent) - Method in class javax.swing.plaf.basic. BasicViewportUI

安装视图端口属性。

installDefaults(JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI

安装默认属性。

installDefaults(JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI

安装视口的默认值。

installDefaults(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

安装默认值。

installDefaults(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI

安装默认属性。

installDefaults(JLabel) - Method in class javax.swing.plaf.synth. SynthLabelUI

安装默认属性。

installDefaults(JPanel) - Method in class javax.swing.plaf.basic. BasicPanelUI

安装面板属性的方法。

installDefaults(JPanel) - Method in class javax.swing.plaf.synth. SynthPanelUI

安装面板属性的方法。

installDefaults(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI

安装默认属性。

installDefaults(JRootPane) - Method in class javax.swing.plaf.synth. SynthRootPaneUI

安装默认属性。

installDefaults(JScrollPane) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

安装默认属性。

installDefaults(JScrollPane) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI

安装默认属性。

installDefaults(JSeparator) - Method in class javax.swing.plaf.basic. BasicSeparatorUI

安装默认属性。

installDefaults(JSeparator) - Method in class javax.swing.plaf.basic. BasicToolBarSeparatorUI

installDefaults(JSeparator) - Method in class javax.swing.plaf.metal. MetalSeparatorUI

installDefaults(JSeparator) - Method in class javax.swing.plaf.synth. SynthSeparatorUI

安装默认设置。

installDefaults(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

安装默认值。

installDefaults(JSlider) - Method in class javax.swing.plaf.synth. SynthSliderUI

安装默认值。

installDefaults(SynthContext) - Method in class javax.swing.plaf.nimbus. NimbusStyle

从 JComponent从 context安装此样式所需的状态。

installDefaults(SynthContext) - Method in class javax.swing.plaf.synth. SynthStyle

从 JComponent从 context安装此样式所需的状态。

installDesktopManager() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

安装桌面管理器。

installDesktopManager() - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI

安装桌面管理器。

installed() - Method in exception jdk.jshell.spi. ExecutionControl.ClassInstallException

指示哪些已传递的类已成功加载/重新定义。

installedProviders() - Static method in class java.nio.file.spi. FileSystemProvider

返回已安装文件系统提供程序的列表。

installFailed() - Method in interface javax.jnlp. ExtensionInstallerService

如果安装失败，应该调用这个。

installIcons(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

安装图标。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

将键盘操作添加到JComboBox。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicComboPopup

注册键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

安装键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

安装键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicListUI

注册 JList与 BasicListUI相关联的键盘绑定。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicMenuBarUI

注册键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicMenuItemUI

注册键盘动作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicMenuUI

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

注册键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicPopupMenuUI

注册键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

安装键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

将键盘操作安装到JSpinner上。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

安装UI的键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

安装键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

注册JTableHeader上的所有键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTableUI

注册JTable上的所有键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTextUI

注册键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicToolBarUI

注册键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTreeUI

注册键盘操作。

installKeyboardActions() - Method in class javax.swing.plaf.metal. MetalInternalFrameUI

installKeyboardActions() - Method in class javax.swing.plaf.synth. SynthPasswordFieldUI

注册键盘操作。

installKeyboardActions(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI

注册键盘操作。

installKeyboardActions(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonListener

注册默认按键操作：按空格键“点击”一个按钮并注册键盘助记符（如果有的话）。

installKeyboardActions(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI

注册键盘操作。

installKeyboardActions(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI

注册键盘操作。

installKeyboardActions(JScrollPane) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

注册键盘操作。

installKeyboardActions(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

安装键盘操作。

installListeners() - Method in class javax.swing.plaf.basic. BasicColorChooserUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

为组合框及其模型创建并安装侦听器。

installListeners() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

安装 PropertyChangeListener从返回 createPropertyChangeListener上 JDesktopPane 。

installListeners() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

安装侦听器

installListeners() - Method in class javax.swing.plaf.basic. BasicListUI

创建并安装JList，其模型及其selectionModel的侦听器。

installListeners() - Method in class javax.swing.plaf.basic. BasicMenuBarUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicMenuItemUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicMenuUI

installListeners() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicPopupMenuUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

安装侦听器

installListeners() - Method in class javax.swing.plaf.basic. BasicSpinnerUI

使用共享对象初始化 PropertyChangeListener ，该对象将有趣的PropertyChangeEvents委托给受保护的方法。

installListeners() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

安装UI的事件监听器。

installListeners() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

安装侦听器

installListeners() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

将侦听器附加到JTableHeader。

installListeners() - Method in class javax.swing.plaf.basic. BasicTableUI

将侦听器附加到JTable。

installListeners() - Method in class javax.swing.plaf.basic. BasicTextUI

安装用户界面的侦听器。

installListeners() - Method in class javax.swing.plaf.basic. BasicToolBarUI

注册听众。

installListeners() - Method in class javax.swing.plaf.basic. BasicTreeUI

注册听众。

installListeners() - Method in class javax.swing.plaf.metal. MetalDesktopIconUI

installListeners() - Method in class javax.swing.plaf.metal. MetalInternalFrameUI

installListeners() - Method in class javax.swing.plaf.metal. MetalScrollBarUI

installListeners() - Method in class javax.swing.plaf.metal. MetalToolBarUI

installListeners() - Method in class javax.swing.plaf.synth. SynthColorChooserUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthComboBoxUI

为组合框及其模型创建并安装侦听器。

installListeners() - Method in class javax.swing.plaf.synth. SynthDesktopIconUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI

安装 PropertyChangeListener从返回 createPropertyChangeListener上 JDesktopPane 。

installListeners() - Method in class javax.swing.plaf.synth. SynthInternalFrameUI

安装侦听器

installListeners() - Method in class javax.swing.plaf.synth. SynthListUI

创建并安装JList，其模型及其selectionModel的侦听器。

installListeners() - Method in class javax.swing.plaf.synth. SynthMenuBarUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthMenuItemUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthMenuUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthPopupMenuUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthProgressBarUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthScrollBarUI

安装侦听器

installListeners() - Method in class javax.swing.plaf.synth. SynthSpinnerUI

使用共享对象初始化 PropertyChangeListener ，该对象将感兴趣的PropertyChangeEvents委托给受保护的方法。

installListeners() - Method in class javax.swing.plaf.synth. SynthSplitPaneUI

安装UI的事件监听器。

installListeners() - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

安装侦听器

installListeners() - Method in class javax.swing.plaf.synth. SynthTableHeaderUI

将侦听器附加到JTableHeader。

installListeners() - Method in class javax.swing.plaf.synth. SynthTableUI

将侦听器附加到JTable。

installListeners() - Method in class javax.swing.plaf.synth. SynthToolBarUI

注册听众。

installListeners() - Method in class javax.swing.plaf.synth. SynthTreeUI

注册听众。

installListeners(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI

注册听众。

installListeners(AbstractButton) - Method in class javax.swing.plaf.basic. BasicRadioButtonUI

installListeners(AbstractButton) - Method in class javax.swing.plaf.synth. SynthButtonUI

注册听众。

installListeners(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI

注册听众。

installListeners(JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI

注册听众。

installListeners(JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI

将侦听器安装到视口中。

installListeners(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

安装侦听器

installListeners(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

installListeners(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI

注册听众。

installListeners(JPanel) - Method in class javax.swing.plaf.synth. SynthPanelUI

将侦听器安装到面板中。

installListeners(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI

注册听众。

installListeners(JScrollPane) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

注册听众。

installListeners(JScrollPane) - Method in class javax.swing.plaf.metal. MetalScrollPaneUI

installListeners(JScrollPane) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI

注册听众。

installListeners(JSeparator) - Method in class javax.swing.plaf.basic. BasicSeparatorUI

注册听众。

installListeners(JSeparator) - Method in class javax.swing.plaf.synth. SynthSeparatorUI

安装侦听器

installListeners(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI

安装侦听器

installListeners(JSlider) - Method in class javax.swing.plaf.synth. SynthSliderUI

安装侦听器

installListListeners() - Method in class javax.swing.plaf.basic. BasicComboPopup

将侦听器添加到列表控件。

installLookAndFeel(String, String) - Static method in class javax.swing. UIManager

添加指定的外观和感觉的一套可用的外观和感觉。

installLookAndFeel(UIManager.LookAndFeelInfo) - Static method in class javax.swing. UIManager

添加指定的外观和感觉的一套可用的外观和感觉。

installMouseHandlers(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

安装鼠标处理程序。

installNextButtonListeners(Component) - Method in class javax.swing.plaf.basic. BasicSpinnerUI

在下一个按钮 c安装必要的听众，以更新 JSpinner以响应用户的手势。

installNonRolloverBorders(JComponent) - Method in class javax.swing.plaf.basic. BasicToolBarUI

在JComponent的所有子组件上安装非滚动边框。

installNormalBorders(JComponent) - Method in class javax.swing.plaf.basic. BasicToolBarUI

在JComponent的所有子组件上安装正常边界。

installPreviewPanel() - Method in class javax.swing.plaf.basic. BasicColorChooserUI

安装预览面板。

installPreviousButtonListeners(Component) - Method in class javax.swing.plaf.basic. BasicSpinnerUI

在上一个按钮 c上安装必要的侦听 c ，以更新 JSpinner以响应用户的手势。

installProperty(JComponent, String, Object) - Static method in class javax.swing. LookAndFeel

如果开发人员尚未设置该属性，则在方法上安装具有指定名称和值的属性。

installRolloverBorders(JComponent) - Method in class javax.swing.plaf.basic. BasicToolBarUI

在JComponent的所有子组件上安装滚动边框。

installStrings(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

安装字符串。

installStrings(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

installSucceeded(boolean) - Method in interface javax.jnlp. ExtensionInstallerService

成功安装扩展程序后，安装程序应调用此操作。

installTitlePane() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

安装标题窗格。

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicColorChooserUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicEditorPaneUI

安装组件的UI。

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

安装UI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

安装UI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicLabelUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicListUI

初始化 this.list致电 installDefaults() ， installListeners() ，并 installKeyboardActions()秩序。

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuBarUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

将接收机安装为 JOptionPane传递的L＆F。

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicPanelUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicPopupMenuUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicRootPaneUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

安装UI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSeparatorUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSliderUI

安装一个UI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSpinnerUI

电话 installDefaults ， installListeners ，然后将返回的组件 createNextButton ， createPreviousButton ，并 createEditor 。

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

安装UI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTableUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTextPaneUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTextUI

安装组件的UI。

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicToolBarUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTreeUI

installUI(JComponent) - Method in class javax.swing.plaf.basic. BasicViewportUI

installUI(JComponent) - Method in class javax.swing.plaf. ComponentUI

适当地配置指定的组件的外观和感觉。

installUI(JComponent) - Method in class javax.swing.plaf. LayerUI

配置 JLayer这个 LayerUI设置为。

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalInternalFrameUI

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalMenuBarUI

配置适合金属外观的指定组件。

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalRootPaneUI

调用 installUI实现 installUI安装必要的状态到 JRootPane传递给金属外观和执行 RootPaneUI 。

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalScrollPaneUI

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalSliderUI

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalToolBarUI

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalToolTipUI

installUI(JComponent) - Method in class javax.swing.plaf.metal. MetalTreeUI

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiListUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI

在此对象处理的每个UI上调用 installUI方法。

installUI(JComponent) - Method in class javax.swing.plaf.synth. SynthComboBoxUI

适当地配置指定的组件的外观和感觉。

installUI(JComponent) - Method in class javax.swing.plaf.synth. SynthPanelUI

适当地配置指定的组件的外观和感觉。

installUI(JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI

适当地配置指定的组件的外观和感觉。

installUI(JComponent) - Method in class javax.swing.plaf.synth. SynthTextPaneUI

安装组件的UI。

installUI(JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI

适当地配置指定的组件的外观和感觉。

instance(ProcessingEnvironment) - Static method in class com.sun.source.util. DocTrees

返回给定的ProcessingEnvironment的DocTrees对象。

instance(ProcessingEnvironment) - Static method in class com.sun.source.util. JavacTask

返回 JavacTask为 ProcessingEnvironment 。

instance(ProcessingEnvironment) - Static method in class com.sun.source.util. Trees

返回给定ProcessingEnvironment的Trees对象。

instance(JavaCompiler.CompilationTask) - Static method in class com.sun.source.util. DocTrees

返回给定CompilationTask的DocTrees对象。

instance(JavaCompiler.CompilationTask) - Static method in class com.sun.source.util. Trees

返回给定CompilationTask的Trees对象。

INSTANCE - Static variable in class java.time.chrono. HijrahChronology

沙特阿拉伯伊斯兰教Umm Al-Qura日历的单身人士例子。

INSTANCE - Static variable in class java.time.chrono. IsoChronology

ISO年代的单例实例。

INSTANCE - Static variable in class java.time.chrono. JapaneseChronology

日本年代的单身人士例子。

INSTANCE - Static variable in class java.time.chrono. MinguoChronology

孟国时代的单身人士实例。

INSTANCE - Static variable in class java.time.chrono. ThaiBuddhistChronology

佛教年龄的单身人士例子。

INSTANCE_INIT - javax.lang.model.element. ElementKind

一个实例初始化器。

INSTANCE_OF - com.sun.source.tree. Tree.Kind

用于InstanceOfTree的实例。

INSTANCE_OF - jdk.nashorn.api.tree. Tree.Kind

用于InstanceOfTree的实例。

InstanceAlreadyExistsException - Exception in javax.management

MBean已经在存储库中注册。

InstanceAlreadyExistsException() - Constructor for exception javax.management. InstanceAlreadyExistsException

默认构造函数。

InstanceAlreadyExistsException(String) - Constructor for exception javax.management. InstanceAlreadyExistsException

允许指定特定错误消息的构造方法。

instanceCounts(List<? extends ReferenceType>) - Method in interface com.sun.jdi. VirtualMachine

返回“refTypes”列表中每个ReferenceType的实例数。

instanceFollowRedirects - Variable in class java.net. HttpURLConnection

如果 true ，协议将自动跟随重定向。

InstanceNotFoundException - Exception in javax.management

存储库中不存在指定的MBean。

InstanceNotFoundException() - Constructor for exception javax.management. InstanceNotFoundException

默认构造函数。

InstanceNotFoundException(String) - Constructor for exception javax.management. InstanceNotFoundException

允许指定特定错误消息的构造方法。

InstanceOfTree - Interface in com.sun.source.tree

一个 instanceof表达式的树节点。

InstanceOfTree - Interface in jdk.nashorn.api.tree

“instanceof”表达式的树节点。

instances(long) - Method in interface com.sun.jdi. ReferenceType

返回此ReferenceType的实例。

instant() - Method in class java.time. Clock

获取当前的时钟瞬间。

Instant - Class in java.time

在时间线上的瞬间点。

INSTANT_SECONDS - java.time.temporal. ChronoField

瞬间的时代。

instantiate(ClassLoader, String) - Static method in class java.beans. Beans

实例化JavaBean。

instantiate(ClassLoader, String, BeanContext) - Static method in class java.beans. Beans

实例化JavaBean。

instantiate(ClassLoader, String, BeanContext, AppletInitializer) - Static method in class java.beans. Beans

已过时。
建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

instantiate(Object, Encoder) - Method in class java.beans. DefaultPersistenceDelegate

instantiate方法的此默认实现返回一个表达式，其中包含预定义方法名“new”，表示使用 DefaultPersistenceDelegate的构造函数中指定的参数调用构造函数。

instantiate(Object, Encoder) - Method in class java.beans. PersistenceDelegate

返回一个值为 oldInstance的表达式。

instantiate(String) - Method in interface javax.management. MBeanServer

使用在MBean服务器的Class Loader Repository中注册的所有类加载器的列表来实例化一个对象。

instantiate(String, Object[], String[]) - Method in interface javax.management. MBeanServer

使用在MBean服务器Class Loader Repository中注册的所有类加载器的列表来实例化对象。

instantiate(String, ObjectName) - Method in interface javax.management. MBeanServer

使用由其 ObjectName指定的类Loader来实例化对象。

instantiate(String, ObjectName, Object[], String[]) - Method in interface javax.management. MBeanServer

实例化一个对象。

instantiateChild(String) - Method in interface java.beans.beancontext. BeanContext

实例化命名为此 BeanContext的小孩的javaBean。

instantiateChild(String) - Method in class java.beans.beancontext. BeanContextSupport

instantiateChild方法是BeanContext中的一个方便的钩子，用于简化将Bean实例化的任务嵌套到一个 BeanContext 。

instantiation(int, DrbgParameters.Capability, byte[]) - Static method in class java.security. DrbgParameters

生成一个DrbgParameters.Instantiation对象。

InstantiationError - Error in java.lang

当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。

InstantiationError() - Constructor for error java.lang. InstantiationError

构造一个 InstantiationError ，没有详细消息。

InstantiationError(String) - Constructor for error java.lang. InstantiationError

构造具有指定详细消息的 InstantiationError 。

InstantiationException - Exception in java.lang

当应用程序试图创建使用一个类的实例抛出 newInstance方法在类 Class ，而指定的类对象不能被实例化。

InstantiationException() - Constructor for exception java.lang. InstantiationException

构造一个 InstantiationException ，没有详细信息。

InstantiationException(String) - Constructor for exception java.lang. InstantiationException

构造具有指定详细消息的 InstantiationException 。

Instrument - Class in javax.sound.midi

仪器是具有某些参数设置的声音合成算法，通常设计为模拟特定的真实乐器或实现特定类型的声音效果。

Instrument(Soundbank, Patch, String, Class<?>) - Constructor for class javax.sound.midi. Instrument

从指定的 Patch构建一个新的MIDI乐器。

Instrumentation - Interface in java.lang.instrument

该类提供了用于设计Java编程语言代码所需的服务。

InsufficientResourcesException - Exception in javax.naming

当资源不可用来完成请求的操作时，抛出此异常。

InsufficientResourcesException() - Constructor for exception javax.naming. InsufficientResourcesException

构造具有所有名称解析字段的InsufficientResourcesException的新实例，并将解释初始化为null。

InsufficientResourcesException(String) - Constructor for exception javax.naming. InsufficientResourcesException

使用说明构造一个新的InsufficientResourcesException实例。

insureRowContinuity() - Method in class javax.swing.tree. DefaultTreeSelectionModel

确保当前选择的 TreePath s对当前选择模式有效。

insureUniqueness() - Method in class javax.swing.tree. DefaultTreeSelectionModel

这种方法已经过时了，它的实现现在是一个noop。

INT - javax.lang.model.type. TypeKind

原始类型 int 。

INT_ARGB - javafx.scene.image. PixelFormat.Type

像素以32位整数存储，非预分量按顺序存储，从MSb到LSb：alpha，红，绿，蓝。

INT_ARGB_PRE - javafx.scene.image. PixelFormat.Type

像素以32位整数存储，预分量按顺序存储，从MSb到LSb：alpha，红，绿，蓝。

INT_LITERAL - com.sun.source.tree. Tree.Kind

用于表示int类型的整数文字表达式的int 。

IntBinaryOperator - Interface in java.util.function

代表两个 int操作数的操作，并产生一个 int结果。

intBitsToFloat(int) - Static method in class java.lang. Float

返回与给定位表示相对应的 float值。

IntBuffer - Class in java.nio

一个int缓冲区

IntConsumer - Interface in java.util.function

表示接受单个 int参数的操作，并且不返回任何结果。

Integer - Class in java.lang

Integer类包装一个对象中的基元类型 int的值。

Integer(int) - Constructor for class java.lang. Integer

已过时。
很少使用这个构造函数。 静态工厂Integer.valueOf(int)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。

Integer(String) - Constructor for class java.lang. Integer

已过时。
很少使用这个构造函数。 使用Integer.parseInt(String)将字符串转换为int原语，或使用Integer.valueOf(String)将字符串转换为Integer对象。

INTEGER - java.sql. JDBCType

标识通用SQL类型 INTEGER 。

INTEGER - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 INTEGER 。

INTEGER - Static variable in class java.text. NumberFormat.Field

常量识别整数字段。

INTEGER - Static variable in class javax.management.openmbean. SimpleType

描述Java类名称为 java.lang.Integer值的 SimpleType实例。

INTEGER_FIELD - Static variable in class java.text. NumberFormat

用于构造FieldPosition对象的字段常量。

IntegerBinding - Class in javafx.beans.binding

提供实现int的int所需的大部分功能的基类。

IntegerBinding() - Constructor for class javafx.beans.binding. IntegerBinding

integerExpression(ObservableIntegerValue) - Static method in class javafx.beans.binding. IntegerExpression

返回一个IntegerExpression ，其中包含一个ObservableIntegerValue 。

integerExpression(ObservableValue<T>) - Static method in class javafx.beans.binding. IntegerExpression

返回一个IntegerExpression ，其中包含一个ObservableValue 。

IntegerExpression - Class in javafx.beans.binding

IntegerExpression是一个ObservableIntegerValue加上额外的便利方法，以流利的风格生成绑定。

IntegerExpression() - Constructor for class javafx.beans.binding. IntegerExpression

integerProperty(Property<Integer>) - Static method in class javafx.beans.property. IntegerProperty

返回一个IntegerProperty ，它包装一个Property ，并双向绑定到它。

IntegerProperty - Class in javafx.beans.property

这个类定义了一个Property包装int值。

IntegerProperty() - Constructor for class javafx.beans.property. IntegerProperty

IntegerPropertyBase - Class in javafx.beans.property

类 IntegerPropertyBase是包含一个 int值的属性的基类。

IntegerPropertyBase() - Constructor for class javafx.beans.property. IntegerPropertyBase

IntegerPropertyBase的构造 IntegerPropertyBase 。

IntegerPropertyBase(int) - Constructor for class javafx.beans.property. IntegerPropertyBase

的构造函数为 IntegerPropertyBase 。

IntegerSpinnerValueFactory(int, int) - Constructor for class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

构造一个新的IntegerSpinnerValueFactory，将初始值设置为等于最小值，默认 amountToStepBy 。

IntegerSpinnerValueFactory(int, int, int) - Constructor for class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

构造一个新的IntegerSpinnerValueFactory，默认 amountToStepBy 。

IntegerSpinnerValueFactory(int, int, int, int) - Constructor for class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

构造一个新的IntegerSpinnerValueFactory。

IntegerStringConverter - Class in javafx.util.converter

StringConverter实现Integer （和int原语）值。

IntegerStringConverter() - Constructor for class javafx.util.converter. IntegerStringConverter

IntegerSyntax - Class in javax.print.attribute

Class IntegerSyntax是一个抽象基类，提供了具有整数值的所有属性的通用实现。

IntegerSyntax(int) - Constructor for class javax.print.attribute. IntegerSyntax

使用给定的整数值构造一个新的整数属性。

IntegerSyntax(int, int, int) - Constructor for class javax.print.attribute. IntegerSyntax

使用给定的整数值构造一个新的整数属性，它必须在给定的范围内。

IntegerType - Interface in com.sun.jdi

在目标VM中访问的所有原语 int值的类型。

IntegerValue - Interface in com.sun.jdi

提供对目标虚拟机中基元 int值的访问。

integerValueAt(ObservableIntegerArray, int) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。

integerValueAt(ObservableIntegerArray, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray元素。

integerValueAt(ObservableIntegerArray, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含指定位置的ObservableArray的元素。

integerValueAt(ObservableList<? extends Number>, int) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。

integerValueAt(ObservableList<? extends Number>, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。

integerValueAt(ObservableList<? extends Number>, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。

integerValueAt(ObservableMap<K, ? extends Number>, ObservableValue<? extends K>) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。

integerValueAt(ObservableMap<K, ? extends Number>, K) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。

IntegrationService - Interface in javax.jnlp

为JNLP应用程序提供桌面集成。

Interceptor - Interface in org.omg.PortableInterceptor

所有便携式拦截器实施拦截器。

InterceptorOperations - Interface in org.omg.PortableInterceptor

所有便携式拦截器实施拦截器。

interestOps() - Method in class java.nio.channels. SelectionKey

检索此密钥的兴趣集。

interestOps(int) - Method in class java.nio.channels. SelectionKey

将此键的兴趣设置为给定值。

INTERFACE - com.sun.source.tree. Tree.Kind

用于表示接口的ClassTree的实例。

INTERFACE - javax.lang.model.element. ElementKind

一个不具体描述的界面（如 ANNOTATION_TYPE ）。

INTERFACE - Static variable in class java.lang.reflect. Modifier

int值代表 interface修正值。

INTERFACE_CLASS_NAME_FIELD - Static variable in class javax.management. JMX

名称为 interfaceClassName字段。

INTERFACE_SUBKIND - jdk.jshell. Snippet.SubKind

接口声明。

InterfaceAddress - Class in java.net

此类表示网络接口地址。

interfaceModifiers() - Static method in class java.lang.reflect. Modifier

返回一个 int值将OR-ing组合在一起可以应用于接口的源语言修饰符。

interfaceName(QName) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder

将 interfaceName设置为 wsam:InterfaceName元素中的 wsa:Metadata元素。

interfaces() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回由此类实现的接口或此接口扩展的接口。

interfaces() - Method in interface com.sun.javadoc. PackageDoc

已过时。

在此包中获取包含的接口，省略注释类型。

interfaces() - Method in interface com.sun.jdi. ClassType

获取由此类直接实现的接口。

InterfaceType - Interface in com.sun.jdi

目标虚拟机中的接口的镜像。

interfaceTypes() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回由此类实现的接口或此接口扩展的接口。

interfaceTypes() - Method in interface com.sun.javadoc. ParameterizedType

已过时。

返回由该参数化类型直接实现或扩展的接口类型。

INTERLOCK_OPEN - Static variable in class javax.print.attribute.standard. PrinterStateReason

打印机上的一个或多个互锁装置被解锁。

intern() - Method in class java.lang. String

返回字符串对象的规范表示。

INTERNAL - Exception in org.omg.CORBA

此异常指示ORB中的内部故障，例如，如果ORB检测到其内部数据结构的损坏。

INTERNAL() - Constructor for exception org.omg.CORBA. INTERNAL

构造一个 INTERNAL异常，默认次要代码为0，完成状态为COMPLETED_NO。

INTERNAL(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INTERNAL

构造具有指定的次要代码和完成状态的 INTERNAL异常。

INTERNAL(String) - Constructor for exception org.omg.CORBA. INTERNAL

构造一个 INTERNAL异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INTERNAL(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INTERNAL

构造具有指定的详细信息，次要代码和完成状态的 INTERNAL异常。

INTERNAL_CLOCK - Static variable in class javax.sound.midi. Sequencer.SyncMode

主同步模式，使序列发生器从其内部时钟获取其定时信息。

INTERNAL_FRAME - Static variable in class javax.accessibility. AccessibleRole

由桌面窗格剪辑的类似帧的对象。

INTERNAL_FRAME - Static variable in class javax.swing.plaf.synth. Region

InternalFrame区域。

INTERNAL_FRAME_ACTIVATED - Static variable in class javax.swing.event. InternalFrameEvent

“窗口激活”事件类型。

INTERNAL_FRAME_CLOSED - Static variable in class javax.swing.event. InternalFrameEvent

“窗口关闭”事件。

INTERNAL_FRAME_CLOSING - Static variable in class javax.swing.event. InternalFrameEvent

“窗口正在关闭”事件。

INTERNAL_FRAME_DEACTIVATED - Static variable in class javax.swing.event. InternalFrameEvent

“窗口停用”事件类型。

INTERNAL_FRAME_DEICONIFIED - Static variable in class javax.swing.event. InternalFrameEvent

“窗口去识别”事件类型。

INTERNAL_FRAME_FIRST - Static variable in class javax.swing.event. InternalFrameEvent

用于内部帧事件的ID范围中的第一个数字。

INTERNAL_FRAME_ICONIFIED - Static variable in class javax.swing.event. InternalFrameEvent

“窗口图标化”事件。

INTERNAL_FRAME_LAST - Static variable in class javax.swing.event. InternalFrameEvent

用于内部帧事件的ID范围中的最后一个数字。

INTERNAL_FRAME_OPENED - Static variable in class javax.swing.event. InternalFrameEvent

“窗口打开”事件。

INTERNAL_FRAME_TITLE_PANE - Static variable in class javax.swing.plaf.synth. Region

内部框架的标题。

internalEntityDecl(String, String) - Method in interface org.xml.sax.ext. DeclHandler

报告内部实体声明。

internalEntityDecl(String, String) - Method in class org.xml.sax.ext. DefaultHandler2

InternalError - Error in java.lang

在Java虚拟机中引发了一些意外的内部错误。

InternalError() - Constructor for error java.lang. InternalError

构造一个没有详细消息的 InternalError 。

InternalError(String) - Constructor for error java.lang. InternalError

构造具有指定详细消息的 InternalError 。

InternalError(String, Throwable) - Constructor for error java.lang. InternalError

构造一个具有指定的详细消息和原因的 InternalError 。

InternalError(Throwable) - Constructor for error java.lang. InternalError

构造一个 InternalError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

InternalException - Exception in com.sun.jdi

抛出，表示出现意外的内部错误。

InternalException() - Constructor for exception com.sun.jdi. InternalException

InternalException(int) - Constructor for exception com.sun.jdi. InternalException

InternalException(String) - Constructor for exception com.sun.jdi. InternalException

InternalException(String) - Constructor for exception jdk.jshell.spi. ExecutionControl.InternalException

InternalException(String, int) - Constructor for exception com.sun.jdi. InternalException

INTERNALFRAME - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing InternalFrame支持（即InternalFrameListener）

internalFrameActivated(InternalFrameEvent) - Method in class javax.swing.event. InternalFrameAdapter

激活内部框架时调用。

internalFrameActivated(InternalFrameEvent) - Method in interface javax.swing.event. InternalFrameListener

激活内部框架时调用。

internalFrameActivated(InternalFrameEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener

激活内部框架时调用。

InternalFrameAdapter - Class in javax.swing.event

用于接收内部帧事件的抽象适配器类。

InternalFrameAdapter() - Constructor for class javax.swing.event. InternalFrameAdapter

InternalFrameBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.InternalFrameBorder

internalFrameClosed(InternalFrameEvent) - Method in class javax.swing.event. InternalFrameAdapter

内部框架已关闭时调用。

internalFrameClosed(InternalFrameEvent) - Method in interface javax.swing.event. InternalFrameListener

内部框架已关闭时调用。

internalFrameClosed(InternalFrameEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener

内部框架已关闭时调用。

internalFrameClosing(InternalFrameEvent) - Method in class javax.swing.event. InternalFrameAdapter

当内部框架处于关闭状态时调用。

internalFrameClosing(InternalFrameEvent) - Method in interface javax.swing.event. InternalFrameListener

当内部框架处于关闭状态时调用。

internalFrameClosing(InternalFrameEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener

当内部框架处于关闭状态时调用。

internalFrameDeactivated(InternalFrameEvent) - Method in class javax.swing.event. InternalFrameAdapter

当内部框架被禁用时调用。

internalFrameDeactivated(InternalFrameEvent) - Method in interface javax.swing.event. InternalFrameListener

当内部框架被禁用时调用。

internalFrameDeactivated(InternalFrameEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener

当内部框架被禁用时调用。

internalFrameDeiconified(InternalFrameEvent) - Method in class javax.swing.event. InternalFrameAdapter

内部框架被去图标化时调用。

internalFrameDeiconified(InternalFrameEvent) - Method in interface javax.swing.event. InternalFrameListener

内部框架被去图标化时调用。

internalFrameDeiconified(InternalFrameEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener

内部框架被去图标化时调用。

InternalFrameEvent - Class in javax.swing.event

一个 AWTEvent添加了对 JInternalFrame对象的支持作为事件源。

InternalFrameEvent(JInternalFrame, int) - Constructor for class javax.swing.event. InternalFrameEvent

构造一个 InternalFrameEvent对象。

InternalFrameFocusTraversalPolicy - Class in javax.swing

FocusTraversalPolicy可以选择提供一种用于确定JInternalFrame初始组件的算法。

InternalFrameFocusTraversalPolicy() - Constructor for class javax.swing. InternalFrameFocusTraversalPolicy

internalFrameIconified(InternalFrameEvent) - Method in class javax.swing.event. InternalFrameAdapter

当内部框架被图标化时调用。

internalFrameIconified(InternalFrameEvent) - Method in interface javax.swing.event. InternalFrameListener

当内部框架被图标化时调用。

internalFrameIconified(InternalFrameEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener

当内部框架被图标化时调用。

internalFrameLayout - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI

内部框架布局

InternalFrameLayout() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFrameLayout

InternalFrameListener - Interface in javax.swing.event

用于接收内部帧事件的侦听器接口。

internalFrameOpened(InternalFrameEvent) - Method in class javax.swing.event. InternalFrameAdapter

内部框架打开时调用。

internalFrameOpened(InternalFrameEvent) - Method in interface javax.swing.event. InternalFrameListener

内部框架打开时调用。

internalFrameOpened(InternalFrameEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BasicInternalFrameListener

内部框架打开时调用。

InternalFramePropertyChangeListener() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFramePropertyChangeListener

InternalFrameUI - Class in javax.swing.plaf

JInternalFrame可插拔的外观和界面。

InternalFrameUI() - Constructor for class javax.swing.plaf. InternalFrameUI

internalGet(int) - Method in class java.util. Calendar

返回给定日历字段的值。

InternationalFormatter - Class in javax.swing.text

InternationalFormatter延伸 DefaultFormatter ，使用的实例 java.text.Format来处理转换为字符串，并从字符串的转换。

InternationalFormatter() - Constructor for class javax.swing.text. InternationalFormatter

创建一个 InternationalFormatter ，没有指定 Format 。

InternationalFormatter(Format) - Constructor for class javax.swing.text. InternationalFormatter

创建一个 InternationalFormatter与指定的 Format实例。

INTEROPERABILITY_INDEX_R98 - Static variable in class javax.imageio.plugins.tiff. ExifInteroperabilityTagSet

要与“InteroperabilityIndex”标签一起使用的值。

INTEROPERABILITY_INDEX_THM - Static variable in class javax.imageio.plugins.tiff. ExifInteroperabilityTagSet

要与“InteroperabilityIndex”标签一起使用的值。

Interpolatable< T> - Interface in javafx.animation

可以插值的值。

interpolate(boolean, boolean, double) - Method in class javafx.animation. Interpolator

这个方法有两个 boolean与沿值 fraction之间 0.0和 1.0并返回插补值。

interpolate(double) - Method in class javafx.animation. FadeTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. FillTransition

该方法 interpolate()必须通过的实现来提供 Transition 。

interpolate(double) - Method in class javafx.animation. ParallelTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. PathTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. PauseTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. RotateTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. ScaleTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. SequentialTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. StrokeTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. Transition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double) - Method in class javafx.animation. TranslateTransition

方法 interpolate()必须由 Transition的实现来提供。

interpolate(double, double, double) - Method in class javafx.animation. Interpolator

这个方法有两个 double与沿值 fraction之间 0.0和 1.0并返回插补值。

interpolate(int, int, double) - Method in class javafx.animation. Interpolator

这个方法有两个 int与沿值 fraction之间 0.0和 1.0并返回插补值。

interpolate(long, long, double) - Method in class javafx.animation. Interpolator

这个方法有两个 int与沿值 fraction之间 0.0和 1.0并返回插补值。

interpolate(Object, Object, double) - Method in class javafx.animation. Interpolator

这个方法有两个 Objects与沿 fraction之间 0.0和 1.0并返回插补值。

interpolate(Color, double) - Method in class javafx.scene.paint. Color

该功能计算沿 0.0和 1.0之间的分数 t的内插值。

interpolate(T, double) - Method in interface javafx.animation. Interpolatable

该函数计算沿 0.0和 1.0之间的分数 t的内插值。

Interpolator - Class in javafx.animation

抽象类定义了几个 interpolate方法，用于计算内插值。

Interpolator() - Constructor for class javafx.animation. Interpolator

构造函数为 Interpolator 。

interpolatorProperty() - Method in class javafx.animation. Transition

控制每个 Transition周期的加速和减速时序。

INTERPRETER_RESOURCE_UNAVAILABLE - Static variable in class javax.print.attribute.standard. PrinterStateReason

解释器资源不可用（例如，字体，表单）。

interrupt() - Method in interface com.sun.jdi. ThreadReference

中断此线程，除非线程已被调试器挂起。

interrupt() - Method in class java.lang. Thread

中断这个线程。

interrupt() - Method in class java.lang. ThreadGroup

中断此线程组中的所有线程。

interrupted() - Static method in class java.lang. Thread

测试当前线程是否已中断。

InterruptedByTimeoutException - Exception in java.nio.channels

在异步操作完成之前经过一段时间后线程接收到的异常检查。

InterruptedByTimeoutException() - Constructor for exception java.nio.channels. InterruptedByTimeoutException

构造这个类的一个实例。

InterruptedException - Exception in java.lang

线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。

InterruptedException() - Constructor for exception java.lang. InterruptedException

构造一个 InterruptedException ，没有详细信息。

InterruptedException(String) - Constructor for exception java.lang. InterruptedException

构造具有指定详细消息的 InterruptedException 。

InterruptedIOException - Exception in java.io

表示I / O操作已中断。

InterruptedIOException() - Constructor for exception java.io. InterruptedIOException

构造 InterruptedIOException其中包含 null作为其错误详细消息。

InterruptedIOException(String) - Constructor for exception java.io. InterruptedIOException

构造具有指定详细消息的 InterruptedIOException 。

InterruptedNamingException - Exception in javax.naming

正在调用的命名操作已被中断时抛出此异常。

InterruptedNamingException() - Constructor for exception javax.naming. InterruptedNamingException

构造一个具有所有名称解析字段的InterruptedNamingException实例，并将解释初始化为null。

InterruptedNamingException(String) - Constructor for exception javax.naming. InterruptedNamingException

使用问题的解释构造InterruptedNamingException的实例。

InterruptibleChannel - Interface in java.nio.channels

可以异步关闭和中断的通道。

intersect(Area) - Method in class java.awt.geom. Area

将此 Area的形状设置为其当前形状和指定的形状 Area 。

intersect(Rectangle2D, Rectangle2D, Rectangle2D) - Static method in class java.awt.geom. Rectangle2D

相互对对指定的源 Rectangle2D对象，并将结果放入指定的目的地 Rectangle2D对象。

intersect(Shape, Shape) - Static method in class javafx.scene.shape. Shape

返回一个新的 Shape ，它被创建为指定的输入形状的交点。

INTERSECT - Static variable in class javax.xml.crypto.dsig.spec. XPathType.Filter

相交过滤器操作。

intersection(Rectangle) - Method in class java.awt. Rectangle

计算 Rectangle与指定的 Rectangle 。

INTERSECTION - javax.lang.model.type. TypeKind

交叉路口型。

INTERSECTION_TYPE - com.sun.source.tree. Tree.Kind

用于IntersectionTypeTree的实例。

IntersectionType - Interface in javax.lang.model.type

表示交叉路口类型。

IntersectionTypeTree - Interface in com.sun.source.tree

转换表达式中交叉路口类型的树节点。

intersects(double, double, double, double) - Method in class java.awt.geom. Arc2D

确定圆弧的内部是否与指定矩形的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. Area

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. CubicCurve2D

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. Ellipse2D

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. Line2D

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. Path2D

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. QuadCurve2D

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. Rectangle2D

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt.geom. RoundRectangle2D

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class java.awt. Polygon

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in interface java.awt. Shape

测试 Shape的内部是否与指定矩形区域的内部相交。

intersects(double, double, double, double) - Method in class javafx.geometry. BoundingBox

测试这个 Bounds的内部是否与指定的矩形区域的内部相交。

intersects(double, double, double, double) - Method in class javafx.geometry. Bounds

测试这个 Bounds的内部是否与指定的矩形区域的内部相交。

intersects(double, double, double, double) - Method in class javafx.geometry. Rectangle2D

测试这个 Rectangle2D的内部是否与指定的矩形区域的内部相交。

intersects(double, double, double, double) - Method in class javafx.scene. Node

返回 true如果给定的矩形（在指定在局部坐标的此空间 Node ）相交此的形状 Node 。

intersects(double, double, double, double, double, double) - Method in class javafx.geometry. BoundingBox

测试这个 Bounds的内部是否与指定的矩形区域的内部相交。

intersects(double, double, double, double, double, double) - Method in class javafx.geometry. Bounds

测试这个 Bounds的内部是否与指定的矩形区域的内部相交。

intersects(PathIterator, double, double, double, double) - Static method in class java.awt.geom. Path2D

测试指定的PathIterator的内部是否与指定的一组直角坐标的内部相交。

intersects(PathIterator, Rectangle2D) - Static method in class java.awt.geom. Path2D

测试指定的内部PathIterator是否与指定的内部相交Rectangle2D 。

intersects(Rectangle2D) - Method in class java.awt.geom. Area

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle2D) - Method in class java.awt.geom. CubicCurve2D

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle2D) - Method in class java.awt.geom. Line2D

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle2D) - Method in class java.awt.geom. Path2D

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle2D) - Method in class java.awt.geom. QuadCurve2D

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle2D) - Method in class java.awt.geom. RectangularShape

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle2D) - Method in class java.awt. Polygon

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle2D) - Method in interface java.awt. Shape

测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

intersects(Rectangle) - Method in class java.awt. Rectangle

确定此 Rectangle和指定的 Rectangle相交。

intersects(BitSet) - Method in class java.util. BitSet

如果指定，则返回true BitSet具有设置为任何位 true ，它们也设置为 true这个 BitSet 。

intersects(Bounds) - Method in class javafx.geometry. BoundingBox

测试这个 Bounds的内部是否与指定的边界 b的内部相交。

intersects(Bounds) - Method in class javafx.geometry. Bounds

测试这个 Bounds的内部是否与指定的边界（ b的内部相交。

intersects(Bounds) - Method in class javafx.scene. Node

返回 true如果给定的范围（在当地指定的坐标这个空间 Node ）相交这个形状 Node 。

intersects(Rectangle2D) - Method in class javafx.geometry. Rectangle2D

测试这个 Rectangle2D的内部是否与指定的Rectangle2D， r的内部相交。

intersectsLine(double, double, double, double) - Method in class java.awt.geom. Line2D

测试从 (x1,y1)到 (x2,y2)线段 (x2,y2)与此线段相交。

intersectsLine(double, double, double, double) - Method in class java.awt.geom. Rectangle2D

测试指定的线段是否与此 Rectangle2D的内部相交。

intersectsLine(Line2D) - Method in class java.awt.geom. Line2D

测试指定的线段是否与此线段相交。

intersectsLine(Line2D) - Method in class java.awt.geom. Rectangle2D

测试指定的线段是否与此 Rectangle2D的内部相交。

INTERVAL_ADDED - Static variable in class javax.swing.event. ListDataEvent

标识列表中添加一个或多个连续项目

INTERVAL_REMOVED - Static variable in class javax.swing.event. ListDataEvent

标识从列表中删除一个或多个连续项

intervalAdded(ListDataEvent) - Method in interface javax.swing.event. ListDataListener

在index0中的索引之后发送，index1间隔已经插入到数据模型中。

intervalAdded(ListDataEvent) - Method in class javax.swing. JComboBox

这种方法是公共的，作为实现的副作用。

intervalAdded(ListDataEvent) - Method in class javax.swing. JList.AccessibleJList

列表数据监听器间隔添加方法。

intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ListDataHandler

intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ListDataHandler

intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicDirectoryModel

已过时 - 未使用。

intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicListUI.ListDataHandler

intervalRemoved(ListDataEvent) - Method in interface javax.swing.event. ListDataListener

在index0，index1间隔的索引之后发送已经从数据模型中删除。

intervalRemoved(ListDataEvent) - Method in class javax.swing. JComboBox

这种方法是公共的，作为实现的副作用。

intervalRemoved(ListDataEvent) - Method in class javax.swing. JList.AccessibleJList

列表数据监听器间隔删除方法。

intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ListDataHandler

intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ListDataHandler

intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicDirectoryModel

已过时 - 未使用。

intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic. BasicListUI.ListDataHandler

INTF_REPOS - Exception in org.omg.CORBA

当ORB无法到达接口存储库或检测到与接口存储库相关的某些其他故障时引发异常。

INTF_REPOS() - Constructor for exception org.omg.CORBA. INTF_REPOS

构造一个 INTF_REPOS异常，默认次要代码为0，完成状态为COMPLETED_NO。

INTF_REPOS(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INTF_REPOS

构造具有指定的次要代码和完成状态的 INTF_REPOS异常。

INTF_REPOS(String) - Constructor for exception org.omg.CORBA. INTF_REPOS

构造具有指定详细信息的 INTF_REPOS异常。

INTF_REPOS(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INTF_REPOS

构造一个 INTF_REPOS异常，指定的详细消息，次要代码和完成状态。

IntFunction< R> - Interface in java.util.function

表示一个接受int值参数并产生结果的函数。

IntHolder - Class in org.omg.CORBA

持有人 Int 。

IntHolder() - Constructor for class org.omg.CORBA. IntHolder

构造一个新的 IntHolder对象，其 value字段初始化为 0 。

IntHolder(int) - Constructor for class org.omg.CORBA. IntHolder

构造一个新的 IntHolder对象，其 value字段初始化为给定的 int 。

intKey() - Method in class java.awt. RenderingHints.Key

返回该子类实例化此Key的私有整数键。

IntPredicate - Interface in java.util.function

表示一个 int值参数的谓词（布尔值函数）。

IntrospectionException - Exception in java.beans

内省时发生异常时抛出。

IntrospectionException - Exception in javax.management

在MBean的内省期间发生了一个例外。

IntrospectionException() - Constructor for exception javax.management. IntrospectionException

默认构造函数。

IntrospectionException(String) - Constructor for exception java.beans. IntrospectionException

构造一个 IntrospectionException的详细消息。

IntrospectionException(String) - Constructor for exception javax.management. IntrospectionException

允许指定特定错误消息的构造方法。

Introspector - Class in java.beans

Introspector类提供了一种标准的工具来了解目标Java Bean支持的属性，事件和方法。

ints() - Method in class java.util.concurrent. ThreadLocalRandom

返回一个有效的无限流的伪随机数 int值。

ints() - Method in class java.util. Random

返回一个有效无限流的伪随机数 int值。

ints() - Method in class java.util. SplittableRandom

从这个发生器返回一个有效的无限流的伪随机数 int值，和/或从其中分离出一个值。

ints(int, int) - Method in class java.util.concurrent. ThreadLocalRandom

返回一个有效的无限流伪随机数 int值，每个符合给定的起始（包括）和绑定（排除）。

ints(int, int) - Method in class java.util. Random

返回一个有效无限流的伪随机数 int ，每个符合给定的起始（包括）和绑定（排除）。

ints(int, int) - Method in class java.util. SplittableRandom

从这个发生器返回一个有效的无限流的伪随机数int值， 每个值符合给定的起始（包括）和绑定（排他）。

ints(long) - Method in class java.util.concurrent. ThreadLocalRandom

返回一个流，产生给定的 streamSize伪随机数 int值。

ints(long) - Method in class java.util. Random

返回一个流，产生给定的 streamSize个伪随机数 int值。

ints(long) - Method in class java.util. SplittableRandom

返回一个流，产生给定的 streamSize伪随机 int从这个发生器和/或从它的一个分割的数值 int 。

ints(long, int, int) - Method in class java.util.concurrent. ThreadLocalRandom

返回一个流，产生给定的 streamSize伪随机数 int值，每个值符合给定的起始（包括）和绑定（排他）。

ints(long, int, int) - Method in class java.util. Random

返回一个流，产生给定的 streamSize伪随机数 int值，每个值符合给定的起始（包括）和绑定（排他）。

ints(long, int, int) - Method in class java.util. SplittableRandom

返回一个流，产生给定的streamSize伪随机数int ，该值来自该发生器和/或从其分离; 每个值符合给定的起始（包括）和绑定（排他）。

intStream(Supplier<? extends Spliterator.OfInt>, int, boolean) - Static method in class java.util.stream. StreamSupport

创建一个新的顺序或并行 IntStream从 Supplier的 Spliterator.OfInt 。

intStream(Spliterator.OfInt, boolean) - Static method in class java.util.stream. StreamSupport

创建一个新的串行或并行 IntStream从 Spliterator.OfInt 。

IntStream - Interface in java.util.stream

支持顺序和并行聚合操作的原始int值元素序列。

IntStream.Builder - Interface in java.util.stream

一个可变的构建器为 IntStream 。

IntSummaryStatistics - Class in java.util

统计数据的收集状态，如count，min，max，sum和average。

IntSummaryStatistics() - Constructor for class java.util. IntSummaryStatistics

使用零计数，零和， Integer.MAX_VALUE分钟， Integer.MIN_VALUE最大和零平均值构造空实例。

IntSupplier - Interface in java.util.function

代表 int结果。

IntToDoubleFunction - Interface in java.util.function

表示接受一个int值参数并产生一个双值结果的函数。

IntToLongFunction - Interface in java.util.function

表示接受一个int值参数并产生一个长效结果的函数。

IntUnaryOperator - Interface in java.util.function

表示对单个 int值的操作数的操作，产生一个 int结果。

intValue() - Method in interface com.sun.jdi.connect. Connector.IntegerArgument

将参数的值作为int返回。

intValue() - Method in interface com.sun.jdi. PrimitiveValue

将此值转换为IntegerValue，并将结果作为int返回。

intValue() - Method in class java.lang. Byte

返回此的值 Byte作为 int加宽原始转换之后。

intValue() - Method in class java.lang. Double

返回此的值 Double作为 int的基本收缩转换之后。

intValue() - Method in class java.lang. Float

返回此的值 Float作为 int的基本收缩转换之后。

intValue() - Method in class java.lang. Integer

返回 Integer的值作为 int 。

intValue() - Method in class java.lang. Long

返回此的值 Long作为 int的基本收缩转换之后。

intValue() - Method in class java.lang. Number

返回指定数字的值作为 int 。

intValue() - Method in class java.lang. Short

返回此的值 Short作为 int加宽原始转换之后。

intValue() - Method in class java.math. BigDecimal

将此 BigDecimal转换为 int 。

intValue() - Method in class java.math. BigInteger

将此BigInteger转换为 int 。

intValue() - Method in class java.util.concurrent.atomic. AtomicInteger

将 AtomicInteger的当前值作为 int ，具有 VarHandle.getVolatile(java.lang.Object...)指定的记忆效应。

intValue() - Method in class java.util.concurrent.atomic. AtomicLong

在 int之后返回 AtomicLong的当前值，这是 int之后的原始转换，其记忆效应由 VarHandle.getVolatile(java.lang.Object...)指定。

intValue() - Method in class java.util.concurrent.atomic. DoubleAccumulator

在缩小原始转换后，返回 current value作为 int 。

intValue() - Method in class java.util.concurrent.atomic. DoubleAdder

在缩小原始转换后，返回 DoubleAdder.sum()作为 int 。

intValue() - Method in class java.util.concurrent.atomic. LongAccumulator

在缩小原始转换后返回 current value作为 int 。

intValue() - Method in class java.util.concurrent.atomic. LongAdder

在缩小原始转换后，返回 LongAdder.sum()作为 int 。

intValue() - Method in class java.util.logging. Level

获取此级别的整数值。

intValue() - Method in class javafx.beans.binding. DoubleExpression

intValue() - Method in class javafx.beans.binding. FloatExpression

intValue() - Method in class javafx.beans.binding. IntegerExpression

intValue() - Method in class javafx.beans.binding. LongExpression

intValue() - Method in interface javafx.beans.value. ObservableNumberValue

返回 ObservableNumberValue的值作为 int 。

intValueExact() - Method in class java.math. BigDecimal

将此 BigDecimal转换为 int ，检查丢失的信息。

intValueExact() - Method in class java.math. BigInteger

将此 BigInteger转换为 int ，检查丢失的信息。

inType() - Method in interface com.sun.tools.doclets. Taglet

已过时。

如果在类型文档（类或接口）中使用了 Taglet则返回true。

INUSE_ATTRIBUTE_ERR - Static variable in exception org.w3c.dom. DOMException

如果尝试添加其他地方已经使用的属性。

INV_FLAG - Exception in org.omg.CORBA

当一个无效标志传递给一个操作时（例如创建一个DII请求）时抛出异常。

INV_FLAG() - Constructor for exception org.omg.CORBA. INV_FLAG

构造一个 INV_FLAG异常，默认次要代码为0，完成状态为COMPLETED_NO。

INV_FLAG(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_FLAG

构造具有指定的次要代码和完成状态的 INV_FLAG异常。

INV_FLAG(String) - Constructor for exception org.omg.CORBA. INV_FLAG

构造一个 INV_FLAG异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INV_FLAG(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_FLAG

构造具有指定的详细消息，次要代码和完成状态的 INV_FLAG异常。

INV_IDENT - Exception in org.omg.CORBA

此异常表示IDL标识符在语法上无效。

INV_IDENT() - Constructor for exception org.omg.CORBA. INV_IDENT

构造一个 INV_IDENT异常，默认次要代码为0，完成状态为COMPLETED_NO。

INV_IDENT(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_IDENT

构造具有指定的次要代码和完成状态的 INV_IDENT异常。

INV_IDENT(String) - Constructor for exception org.omg.CORBA. INV_IDENT

构造一个 INV_IDENT异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INV_IDENT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_IDENT

构造具有指定的详细消息，次要代码和完成状态的 INV_IDENT异常。

INV_OBJREF - Exception in org.omg.CORBA

此异常表示对象引用在内部格式错误。

INV_OBJREF() - Constructor for exception org.omg.CORBA. INV_OBJREF

构造一个 INV_OBJREF异常，默认次要代码为0，完成状态为COMPLETED_NO。

INV_OBJREF(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_OBJREF

构造具有指定的次要代码和完成状态的 INV_OBJREF异常。

INV_OBJREF(String) - Constructor for exception org.omg.CORBA. INV_OBJREF

构造一个 INV_OBJREF异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INV_OBJREF(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_OBJREF

构造具有指定的详细消息，次要代码和完成状态的 INV_OBJREF异常。

INV_POLICY - Exception in org.omg.CORBA

由于 Policy适用于特定调用的覆盖不兼容，因此无法进行调用时抛出标准异常。

INV_POLICY() - Constructor for exception org.omg.CORBA. INV_POLICY

构造一个 INV_POLICY异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。

INV_POLICY(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_POLICY

构造具有指定的次要代码和完成状态的 INV_POLICY异常。

INV_POLICY(String) - Constructor for exception org.omg.CORBA. INV_POLICY

构造一个 INV_POLICY异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

INV_POLICY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INV_POLICY

构造具有指定的描述消息，次要代码和完成状态的 INV_POLICY异常。

Invalid - Exception in org.omg.CORBA.DynAnyPackage

当传递错误的 DynAny或 Any作为参数时，动态的任何操作都会抛出无效。

Invalid() - Constructor for exception org.omg.CORBA.DynAnyPackage. Invalid

构造一个 Invalid对象。

Invalid(String) - Constructor for exception org.omg.CORBA.DynAnyPackage. Invalid

构造一个 Invalid对象。

INVALID_ACCESS_ERR - Static variable in exception org.w3c.dom. DOMException

如果基础对象不支持参数或操作。

INVALID_ACTIVITY - Exception in org.omg.CORBA

如果事务或活动在与其挂起的环境不同的上下文中恢复，则可能会在“活动”或“事务服务”恢复方法上引发 INVALID_ACTIVITY系统异常。

INVALID_ACTIVITY() - Constructor for exception org.omg.CORBA. INVALID_ACTIVITY

构造一个 INVALID_ACTIVITY异常，次要代码设置为0，CompletionStatus设置为COMPLETED_NO。

INVALID_ACTIVITY(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INVALID_ACTIVITY

构造具有指定的次要代码和完成状态的 INVALID_ACTIVITY异常。

INVALID_ACTIVITY(String) - Constructor for exception org.omg.CORBA. INVALID_ACTIVITY

使用指定的消息构造一个 INVALID_ACTIVITY异常。

INVALID_ACTIVITY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INVALID_ACTIVITY

构造具有指定消息，次要代码和完成状态的 INVALID_ACTIVITY异常。

INVALID_CHARACTER_ERR - Static variable in exception org.w3c.dom. DOMException

如果指定了无效或非法字符，例如XML名称。

INVALID_EXPRESSION_ERR - Static variable in exception org.w3c.dom.xpath. XPathException

如果该表达式具有语法错误或根据特定的 XPathEvaluator的规则不是合法表达式，或包含此实现不支持的专用扩展函数或变量。

INVALID_KEY_USAGE - java.security.cert. PKIXReason

证书的密钥使用无效。

INVALID_MODIFICATION_ERR - Static variable in exception org.w3c.dom. DOMException

如果尝试修改底层对象的类型。

INVALID_NAME - java.security.cert. PKIXReason

名称限制已被违反。

INVALID_NODE_TYPE_ERR - Static variable in exception org.w3c.dom.ranges. RangeException

如果Range的边界点的容器被设置为无效类型的节点或具有无效类型的祖先的节点。

INVALID_POLICY - java.security.cert. PKIXReason

政策制约因素受到侵犯。

INVALID_SIGNATURE - java.security.cert. CertPathValidatorException.BasicReason

签名无效。

INVALID_STATE_ERR - Static variable in exception org.w3c.dom. DOMException

如果尝试使用不是或不再可用的对象。

INVALID_TRANSACTION - Exception in org.omg.CORBA

当请求携带无效的事务上下文时抛出异常。

INVALID_TRANSACTION() - Constructor for exception org.omg.CORBA. INVALID_TRANSACTION

构造一个 INVALID_TRANSACTION异常，默认次要代码为0，完成状态为COMPLETED_NO。

INVALID_TRANSACTION(int, CompletionStatus) - Constructor for exception org.omg.CORBA. INVALID_TRANSACTION

构造具有指定的次要代码和完成状态的 INVALID_TRANSACTION异常。

INVALID_TRANSACTION(String) - Constructor for exception org.omg.CORBA. INVALID_TRANSACTION

构造具有指定详细消息的 INVALID_TRANSACTION异常。

INVALID_TRANSACTION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. INVALID_TRANSACTION

构造一个 INVALID_TRANSACTION例外，其中包含指定的详细信息，次要代码和完成状态。

InvalidActivityException - Exception in javax.activity

可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。

InvalidActivityException() - Constructor for exception javax.activity. InvalidActivityException

构造一个具有null作为其详细消息的新实例。

InvalidActivityException(String) - Constructor for exception javax.activity. InvalidActivityException

构造具有指定详细消息的新实例。

InvalidActivityException(String, Throwable) - Constructor for exception javax.activity. InvalidActivityException

构造一个新的可抛出指定的详细信息和原因。

InvalidActivityException(Throwable) - Constructor for exception javax.activity. InvalidActivityException

构造具有指定原因的新的throwable。

InvalidAddress - Exception in org.omg.CosNaming.NamingContextExtPackage

org / omg / CosNaming / NamingContextExtPackage / InvalidAddress.java。

InvalidAddress() - Constructor for exception org.omg.CosNaming.NamingContextExtPackage. InvalidAddress

InvalidAddress(String) - Constructor for exception org.omg.CosNaming.NamingContextExtPackage. InvalidAddress

InvalidAddressHelper - Class in org.omg.CosNaming.NamingContextExtPackage

org / omg / CosNaming / NamingContextExtPackage / InvalidAddressHelper.java。

InvalidAddressHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHelper

InvalidAddressHolder - Class in org.omg.CosNaming.NamingContextExtPackage

org / omg / CosNaming / NamingContextExtPackage / InvalidAddressHolder.java。

InvalidAddressHolder() - Constructor for class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHolder

InvalidAddressHolder(InvalidAddress) - Constructor for class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHolder

InvalidAlgorithmParameterException - Exception in java.security

这是无效或不合适的算法参数的例外。

InvalidAlgorithmParameterException() - Constructor for exception java.security. InvalidAlgorithmParameterException

构造一个InvalidAlgorithmParameterException，没有详细信息。

InvalidAlgorithmParameterException(String) - Constructor for exception java.security. InvalidAlgorithmParameterException

使用指定的详细消息构造InvalidAlgorithmParameterException。

InvalidAlgorithmParameterException(String, Throwable) - Constructor for exception java.security. InvalidAlgorithmParameterException

创建一个 InvalidAlgorithmParameterException与指定的详细信息和原因。

InvalidAlgorithmParameterException(Throwable) - Constructor for exception java.security. InvalidAlgorithmParameterException

创建一个 InvalidAlgorithmParameterException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

InvalidApplicationException - Exception in javax.management

当尝试应用以下任一操作时抛出：将MBean的子查询表达式或对错误类的MBean的限定属性表达式。

InvalidApplicationException(Object) - Constructor for exception javax.management. InvalidApplicationException

构造一个 InvalidApplicationException与指定的 Object 。

invalidate() - Method in class java.awt. Component

无效此组件及其祖先。

invalidate() - Method in class java.awt. Container

使容器无效。

invalidate() - Method in class java.awt. Polygon

无效或刷新取决于该 Polygon的顶点坐标的任何内部缓存的数据。

invalidate() - Method in interface javafx.beans.binding. Binding

将绑定标记为无效。

invalidate() - Method in class javafx.beans.binding. BooleanBinding

invalidate() - Method in class javafx.beans.binding. DoubleBinding

invalidate() - Method in class javafx.beans.binding. FloatBinding

invalidate() - Method in class javafx.beans.binding. IntegerBinding

invalidate() - Method in class javafx.beans.binding. ListBinding

invalidate() - Method in class javafx.beans.binding. LongBinding

invalidate() - Method in class javafx.beans.binding. MapBinding

invalidate() - Method in class javafx.beans.binding. ObjectBinding

invalidate() - Method in class javafx.beans.binding. SetBinding

invalidate() - Method in class javafx.beans.binding. StringBinding

invalidate() - Method in interface javax.net.ssl. SSLSession

使会话无效。

invalidate() - Method in class javax.swing. CellRendererPane

当配置单元格渲染器子时，覆盖以避免传播使树无效。

invalidate() - Method in class javax.swing. DefaultListCellRenderer

由于性能原因而被覆盖。

invalidate() - Method in class javax.swing.table. DefaultTableCellRenderer

由于性能原因而被覆盖。

invalidate() - Method in class javax.swing.tree. DefaultTreeCellRenderer

由于性能原因而被覆盖。

invalidateAll(SwitchPoint[]) - Static method in class java.lang.invoke. SwitchPoint

将所有给定的切换点设置为无效状态。

invalidated() - Method in class javafx.beans.property. BooleanPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. DoublePropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. FloatPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. IntegerPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. ListPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. LongPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. MapPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. ObjectPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. SetPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated() - Method in class javafx.beans.property. StringPropertyBase

可以覆盖方法 invalidated()以接收无效通知。

invalidated(Observable) - Method in interface javafx.beans. InvalidationListener

该方法需要通过 InvalidationListener的实现来提供。

invalidated(Observable) - Method in class javafx.beans. WeakInvalidationListener

该方法需要通过 InvalidationListener的实现来提供。

invalidateFileCache() - Method in class javax.swing.plaf.basic. BasicDirectoryModel

该方法用于中断文件加载线程。

invalidateLayout(Container) - Method in class java.awt. BorderLayout

使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。

invalidateLayout(Container) - Method in class java.awt. CardLayout

使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。

invalidateLayout(Container) - Method in class java.awt. GridBagLayout

使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。

invalidateLayout(Container) - Method in interface java.awt. LayoutManager2

使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。

invalidateLayout(Container) - Method in class javax.swing. BoxLayout

表示一个孩子已经更改了其布局相关信息，因此应该刷新任何缓存的计算。

invalidateLayout(Container) - Method in class javax.swing. GroupLayout

使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。

invalidateLayout(Container) - Method in class javax.swing. JRootPane.RootLayout

invalidateLayout(Container) - Method in class javax.swing. OverlayLayout

表示小孩已更改其布局相关信息，这会导致任何缓存计算被刷新。

invalidateLayout(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

什么也没做。

invalidateLayout(Container) - Method in class javax.swing. SpringLayout

invalidateMetrics() - Method in class javafx.scene.control.skin. TextAreaSkin

对TextInputControl的缓存最小和最小大小无效。

invalidateMetrics() - Method in class javafx.scene.control.skin. TextInputControlSkin

对TextInputControl的缓存最小和最小大小无效。

invalidatePathBounds(TreePath) - Method in class javax.swing.tree. AbstractLayoutCache

指示 LayoutCache ，对于边界 path是无效的，并需要进行更新。

invalidatePathBounds(TreePath) - Method in class javax.swing.tree. FixedHeightLayoutCache

没有什么，FixedHeightLayoutCache不缓存宽度，这是可以改变的。

invalidatePathBounds(TreePath) - Method in class javax.swing.tree. VariableHeightLayoutCache

指示 LayoutCache ，对于边界 path是无效的，并需要进行更新。

invalidateRange() - Method in class javafx.scene.chart. Axis

将当前范围标记为无效，这将导致在下一个布局上重新计算取决于范围的任何内容。

invalidateRange(List<String>) - Method in class javafx.scene.chart. CategoryAxis

数据更改时调用，范围可能不再有效。

invalidateRange(List<T>) - Method in class javafx.scene.chart. Axis

数据更改时调用，范围可能不再有效。

invalidateRange(List<T>) - Method in class javafx.scene.chart. ValueAxis

当数据发生变化并且范围可能不再有效时调用。

invalidateSizes() - Method in class javax.swing.tree. AbstractLayoutCache

通知 TreeState它需要重新计算它所引用的所有大小。

invalidateSizes() - Method in class javax.swing.tree. FixedHeightLayoutCache

通知TreeState需要重新计算它所引用的所有大小。

invalidateSizes() - Method in class javax.swing.tree. VariableHeightLayoutCache

通知 TreeState它需要重新计算它所引用的所有大小。

InvalidationListener - Interface in javafx.beans

一个InvalidationListener每当被通知Observable变为无效。

InvalidAttributeIdentifierException - Exception in javax.naming.directory

当尝试添加以创建具有无效属性标识符的属性时，会抛出此异常。

InvalidAttributeIdentifierException() - Constructor for exception javax.naming.directory. InvalidAttributeIdentifierException

构造InvalidAttributeIdentifierException的新实例。

InvalidAttributeIdentifierException(String) - Constructor for exception javax.naming.directory. InvalidAttributeIdentifierException

使用提供的说明构造一个InvalidAttributeIdentifierException的新实例。

InvalidAttributesException - Exception in javax.naming.directory

尝试添加或修改不完整或不正确指定的属性集时，会抛出此异常。

InvalidAttributesException() - Constructor for exception javax.naming.directory. InvalidAttributesException

构造InvalidAttributesException的新实例。

InvalidAttributesException(String) - Constructor for exception javax.naming.directory. InvalidAttributesException

使用说明构造一个InvalidAttributesException的新实例。

InvalidAttributeValueException - Exception in javax.management

指定的值对属性无效。

InvalidAttributeValueException - Exception in javax.naming.directory

当尝试向属性添加与属性的模式定义冲突的值时，将抛出此类。

InvalidAttributeValueException() - Constructor for exception javax.management. InvalidAttributeValueException

默认构造函数。

InvalidAttributeValueException() - Constructor for exception javax.naming.directory. InvalidAttributeValueException

构造InvalidAttributeValueException的新实例。

InvalidAttributeValueException(String) - Constructor for exception javax.management. InvalidAttributeValueException

允许指定特定错误消息的构造方法。

InvalidAttributeValueException(String) - Constructor for exception javax.naming.directory. InvalidAttributeValueException

使用说明构造一个InvalidAttributeValueException的新实例。

InvalidClassException - Exception in java.io

当序列化运行时检测到类中的以下问题之一时抛出。

InvalidClassException(String) - Constructor for exception java.io. InvalidClassException

针对指定的原因报告InvalidClassException。

InvalidClassException(String, String) - Constructor for exception java.io. InvalidClassException

构造一个InvalidClassException对象。

InvalidCodeIndexException - Exception in com.sun.jdi

已过时。
不再抛出此异常

InvalidCodeIndexException() - Constructor for exception com.sun.jdi. InvalidCodeIndexException

已过时。

InvalidCodeIndexException(String) - Constructor for exception com.sun.jdi. InvalidCodeIndexException

已过时。

InvalidDnDOperationException - Exception in java.awt.dnd

java.awt.dnd包中的各种方法抛出此异常。

InvalidDnDOperationException() - Constructor for exception java.awt.dnd. InvalidDnDOperationException

创建一个默认的异常

InvalidDnDOperationException(String) - Constructor for exception java.awt.dnd. InvalidDnDOperationException

使用自己的描述性消息创建异常

invalidEdit() - Method in class javax.swing. JFormattedTextField.AbstractFormatter

当用户键入无效字符时，应该调用此值。

invalidEdit() - Method in class javax.swing. JFormattedTextField

当用户输入无效值时调用。

InvalidKeyException - Exception in java.security

这是无效键（无效编码，长度错误，未初始化等）的例外。

InvalidKeyException - Exception in javax.management.openmbean

抛出此运行时异常以指示预期为 复合数据的项名称或 表格数据的行索引的方法参数无效。

InvalidKeyException() - Constructor for exception java.security. InvalidKeyException

构造一个InvalidKeyException，没有详细信息。

InvalidKeyException() - Constructor for exception javax.management.openmbean. InvalidKeyException

InvalidKeyException，没有详细消息。

InvalidKeyException(String) - Constructor for exception java.security. InvalidKeyException

构造具有指定详细消息的InvalidKeyException。

InvalidKeyException(String) - Constructor for exception javax.management.openmbean. InvalidKeyException

带有详细消息的InvalidKeyException。

InvalidKeyException(String, Throwable) - Constructor for exception java.security. InvalidKeyException

创建一个具有指定的详细信息和原因的 InvalidKeyException 。

InvalidKeyException(Throwable) - Constructor for exception java.security. InvalidKeyException

创建一个 InvalidKeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

InvalidKeySpecException - Exception in java.security.spec

这是无效密钥规范的例外。

InvalidKeySpecException() - Constructor for exception java.security.spec. InvalidKeySpecException

构造一个InvalidKeySpecException，没有详细消息。

InvalidKeySpecException(String) - Constructor for exception java.security.spec. InvalidKeySpecException

使用指定的详细消息构造InvalidKeySpecException。

InvalidKeySpecException(String, Throwable) - Constructor for exception java.security.spec. InvalidKeySpecException

创建一个具有指定的详细信息和原因的 InvalidKeySpecException 。

InvalidKeySpecException(Throwable) - Constructor for exception java.security.spec. InvalidKeySpecException

创建一个 InvalidKeySpecException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

InvalidLineNumberException - Exception in com.sun.jdi

已过时。
不再抛出此异常

InvalidLineNumberException() - Constructor for exception com.sun.jdi. InvalidLineNumberException

已过时。

InvalidLineNumberException(String) - Constructor for exception com.sun.jdi. InvalidLineNumberException

已过时。

InvalidMarkException - Exception in java.nio

当未定义其标记时尝试复位缓冲区时抛出未检查的异常。

InvalidMarkException() - Constructor for exception java.nio. InvalidMarkException

构造这个类的一个实例。

InvalidMidiDataException - Exception in javax.sound.midi

一个 InvalidMidiDataException表示遇到不适当的MIDI数据。

InvalidMidiDataException() - Constructor for exception javax.sound.midi. InvalidMidiDataException

构造一个 InvalidMidiDataException与 null的错误详细信息。

InvalidMidiDataException(String) - Constructor for exception javax.sound.midi. InvalidMidiDataException

构造具有指定详细消息的 InvalidMidiDataException 。

InvalidModuleDescriptorException - Exception in java.lang.module

读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。

InvalidModuleDescriptorException() - Constructor for exception java.lang.module. InvalidModuleDescriptorException

构造一个没有详细消息的 InvalidModuleDescriptorException 。

InvalidModuleDescriptorException(String) - Constructor for exception java.lang.module. InvalidModuleDescriptorException

构造具有指定详细消息的 InvalidModuleDescriptorException 。

InvalidModuleException - Exception in com.sun.jdi

抛出以表明所请求的模块在卸载模块后无效或无效。

InvalidModuleException() - Constructor for exception com.sun.jdi. InvalidModuleException

构造一个 InvalidModuleException ，没有详细信息。

InvalidModuleException(String) - Constructor for exception com.sun.jdi. InvalidModuleException

构造具有给定详细消息的 InvalidModuleException 。

InvalidName - Exception in org.omg.CORBA.ORBPackage

InvalidName异常在 ORB.resolve_initial_references传递一个没有初始引用的名称时 ORB.resolve_initial_references 。

InvalidName - Exception in org.omg.CosNaming.NamingContextPackage

org / omg / CosNaming / NamingContextPackage / InvalidName.java。

InvalidName - Exception in org.omg.PortableInterceptor.ORBInitInfoPackage

org / omg / PortableInterceptor / ORBInitInfoPackage / InvalidName.java。

InvalidName() - Constructor for exception org.omg.CORBA.ORBPackage. InvalidName

构造一个没有原因信息的 InvalidName异常。

InvalidName() - Constructor for exception org.omg.CosNaming.NamingContextPackage. InvalidName

InvalidName() - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidName

InvalidName(String) - Constructor for exception org.omg.CORBA.ORBPackage. InvalidName

构造具有指定原因消息的 InvalidName异常。

InvalidName(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage. InvalidName

InvalidName(String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidName

InvalidNameException - Exception in javax.naming

此异常表示指定的名称不符合命名系统的命名语法。

InvalidNameException() - Constructor for exception javax.naming. InvalidNameException

构造一个InvalidNameException的实例，所有字段都设置为null。

InvalidNameException(String) - Constructor for exception javax.naming. InvalidNameException

使用问题的解释构造InvalidNameException的实例。

InvalidNameHelper - Class in org.omg.CORBA.ORBPackage

这个Helper类用于方便编组 ORBPackage/InvalidName 。

InvalidNameHelper - Class in org.omg.CosNaming.NamingContextPackage

org / omg / CosNaming / NamingContextPackage / InvalidNameHelper.java。

InvalidNameHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage

org / omg / PortableInterceptor / ORBInitInfoPackage / InvalidNameHelper.java。

InvalidNameHelper() - Constructor for class org.omg.CORBA.ORBPackage. InvalidNameHelper

InvalidNameHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage. InvalidNameHelper

InvalidNameHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidNameHelper

InvalidNameHolder - Class in org.omg.CosNaming.NamingContextPackage

org / omg / CosNaming / NamingContextPackage / InvalidNameHolder.java。

InvalidNameHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage. InvalidNameHolder

InvalidNameHolder(InvalidName) - Constructor for class org.omg.CosNaming.NamingContextPackage. InvalidNameHolder

InvalidObjectException - Exception in java.io

表示一个或多个反序列化对象失败的验证测试。

InvalidObjectException(String) - Constructor for exception java.io. InvalidObjectException

构造一个 InvalidObjectException 。

InvalidOpenTypeException - Exception in javax.management.openmbean

抛出此运行时异常以指示 打开的类型的 打开数据值不是预期的。

InvalidOpenTypeException() - Constructor for exception javax.management.openmbean. InvalidOpenTypeException

InvalidOpenTypeException，没有详细消息。

InvalidOpenTypeException(String) - Constructor for exception javax.management.openmbean. InvalidOpenTypeException

带有详细消息的InvalidOpenTypeException。

InvalidParameterException - Exception in java.security

当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。

InvalidParameterException() - Constructor for exception java.security. InvalidParameterException

构造一个无详细消息的InvalidParameterException。

InvalidParameterException(String) - Constructor for exception java.security. InvalidParameterException

构造具有指定详细消息的InvalidParameterException。

InvalidParameterSpecException - Exception in java.security.spec

这是无效参数规范的例外。

InvalidParameterSpecException() - Constructor for exception java.security.spec. InvalidParameterSpecException

构造一个没有详细信息的InvalidParameterSpecException。

InvalidParameterSpecException(String) - Constructor for exception java.security.spec. InvalidParameterSpecException

使用指定的详细消息构造InvalidParameterSpecException。

InvalidPathException - Exception in java.nio.file

当路径字符串不能转换为Path时，由于路径字符串包含无效字符或路径字符串对其他文件系统特定的原因无效，因此抛出未检查的异常。

InvalidPathException(String, String) - Constructor for exception java.nio.file. InvalidPathException

从给定的输入字符串构造一个实例和原因。

InvalidPathException(String, String, int) - Constructor for exception java.nio.file. InvalidPathException

从给定的输入字符串，原因和错误索引构造一个实例。

InvalidPolicy - Exception in org.omg.PortableServer.POAPackage

org / omg / PortableServer / POAPackage / InvalidPolicy.java。

InvalidPolicy() - Constructor for exception org.omg.PortableServer.POAPackage. InvalidPolicy

InvalidPolicy(short) - Constructor for exception org.omg.PortableServer.POAPackage. InvalidPolicy

InvalidPolicy(String, short) - Constructor for exception org.omg.PortableServer.POAPackage. InvalidPolicy

InvalidPolicyHelper - Class in org.omg.PortableServer.POAPackage

org / omg / PortableServer / POAPackage / InvalidPolicyHelper.java。

InvalidPolicyHelper() - Constructor for class org.omg.PortableServer.POAPackage. InvalidPolicyHelper

InvalidPreferencesFormatException - Exception in java.util.prefs

抛出以表示操作无法完成，因为输入符合Preferences规范的首选项集合的相应XML文档类型。

InvalidPreferencesFormatException(String) - Constructor for exception java.util.prefs. InvalidPreferencesFormatException

使用指定的详细消息构造InvalidPreferencesFormatException。

InvalidPreferencesFormatException(String, Throwable) - Constructor for exception java.util.prefs. InvalidPreferencesFormatException

构造一个InvalidPreferencesFormatException与指定的详细信息和原因。

InvalidPreferencesFormatException(Throwable) - Constructor for exception java.util.prefs. InvalidPreferencesFormatException

构造具有指定原因的InvalidPreferencesFormatException。

InvalidPropertiesFormatException - Exception in java.util

抛出以表示操作无法完成，因为输入不符合属性集合的相应XML文档类型，按照Properties规范。

InvalidPropertiesFormatException(String) - Constructor for exception java.util. InvalidPropertiesFormatException

使用指定的详细消息构造InvalidPropertiesFormatException。

InvalidPropertiesFormatException(Throwable) - Constructor for exception java.util. InvalidPropertiesFormatException

构造具有指定原因的InvalidPropertiesFormatException。

InvalidRelationIdException - Exception in javax.management.relation

当已经使用关系id提供给关系时，引发异常。

InvalidRelationIdException() - Constructor for exception javax.management.relation. InvalidRelationIdException

默认构造函数，没有消息放在异常中。

InvalidRelationIdException(String) - Constructor for exception javax.management.relation. InvalidRelationIdException

具有给定消息的构造方法放在异常中。

InvalidRelationServiceException - Exception in javax.management.relation

当提供无效的关系服务时，引发异常。

InvalidRelationServiceException() - Constructor for exception javax.management.relation. InvalidRelationServiceException

默认构造函数，没有消息放在异常中。

InvalidRelationServiceException(String) - Constructor for exception javax.management.relation. InvalidRelationServiceException

具有给定消息的构造方法放在异常中。

InvalidRelationTypeException - Exception in javax.management.relation

关系类型无效

InvalidRelationTypeException() - Constructor for exception javax.management.relation. InvalidRelationTypeException

默认构造函数，没有消息放在异常中。

InvalidRelationTypeException(String) - Constructor for exception javax.management.relation. InvalidRelationTypeException

具有给定消息的构造方法放在异常中。

InvalidRequestStateException - Exception in com.sun.jdi.request

抛出以表示所请求的事件由于启用而无法修改。

InvalidRequestStateException() - Constructor for exception com.sun.jdi.request. InvalidRequestStateException

InvalidRequestStateException(String) - Constructor for exception com.sun.jdi.request. InvalidRequestStateException

InvalidRoleInfoException - Exception in javax.management.relation

当在角色信息中，其最小度大于其最大度时，会引发此异常。

InvalidRoleInfoException() - Constructor for exception javax.management.relation. InvalidRoleInfoException

默认构造函数，没有消息放在异常中。

InvalidRoleInfoException(String) - Constructor for exception javax.management.relation. InvalidRoleInfoException

具有给定消息的构造方法放在异常中。

InvalidRoleValueException - Exception in javax.management.relation

角色值无效。

InvalidRoleValueException() - Constructor for exception javax.management.relation. InvalidRoleValueException

默认构造函数，没有消息放在异常中。

InvalidRoleValueException(String) - Constructor for exception javax.management.relation. InvalidRoleValueException

具有给定消息的构造方法放在异常中。

InvalidSearchControlsException - Exception in javax.naming.directory

当搜索操作的SearchControls的规范无效时，抛出此异常。

InvalidSearchControlsException() - Constructor for exception javax.naming.directory. InvalidSearchControlsException

构造一个InvalidSearchControlsException的新实例。

InvalidSearchControlsException(String) - Constructor for exception javax.naming.directory. InvalidSearchControlsException

构造一个新的InvalidSearchControlsException实例，并带有解释。

InvalidSearchFilterException - Exception in javax.naming.directory

当搜索过滤器的规范无效时抛出此异常。

InvalidSearchFilterException() - Constructor for exception javax.naming.directory. InvalidSearchFilterException

构造一个InvalidSearchFilterException的新实例。

InvalidSearchFilterException(String) - Constructor for exception javax.naming.directory. InvalidSearchFilterException

构造一个InvalidSearchFilterException的新实例，并带有解释。

InvalidSeq - Exception in org.omg.CORBA.DynAnyPackage

InvalidSeq异常被所有操作抛出，在动态任务中，当序列无效时，它将一个序列（Java数组）作为参数。

InvalidSeq() - Constructor for exception org.omg.CORBA.DynAnyPackage. InvalidSeq

构造一个 InvalidSeq对象。

InvalidSeq(String) - Constructor for exception org.omg.CORBA.DynAnyPackage. InvalidSeq

构造一个 InvalidSeq对象。

InvalidSlot - Exception in org.omg.PortableInterceptor

org / omg / PortableInterceptor / InvalidSlot.java。

InvalidSlot() - Constructor for exception org.omg.PortableInterceptor. InvalidSlot

InvalidSlot(String) - Constructor for exception org.omg.PortableInterceptor. InvalidSlot

InvalidSlotHelper - Class in org.omg.PortableInterceptor

org / omg / PortableInterceptor / InvalidSlotHelper.java。

InvalidSlotHelper() - Constructor for class org.omg.PortableInterceptor. InvalidSlotHelper

InvalidStackFrameException - Exception in com.sun.jdi

抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。

InvalidStackFrameException() - Constructor for exception com.sun.jdi. InvalidStackFrameException

InvalidStackFrameException(String) - Constructor for exception com.sun.jdi. InvalidStackFrameException

InvalidStreamException - Exception in com.sun.nio.sctp

尝试将消息发送到无效流时抛出未检查的异常。

InvalidStreamException() - Constructor for exception com.sun.nio.sctp. InvalidStreamException

构造这个类的一个实例。

InvalidStreamException(String) - Constructor for exception com.sun.nio.sctp. InvalidStreamException

使用指定的详细消息构造此类的实例。

InvalidTargetObjectTypeException - Exception in javax.management.modelmbean

指定无效目标对象类型时抛出异常。

InvalidTargetObjectTypeException() - Constructor for exception javax.management.modelmbean. InvalidTargetObjectTypeException

默认构造函数。

InvalidTargetObjectTypeException(Exception, String) - Constructor for exception javax.management.modelmbean. InvalidTargetObjectTypeException

构造器接受异常和字符串。

InvalidTargetObjectTypeException(String) - Constructor for exception javax.management.modelmbean. InvalidTargetObjectTypeException

一个字符串的构造方法

InvalidTransactionException - Exception in javax.transaction

此异常表示请求携带无效的事务上下文。

InvalidTransactionException() - Constructor for exception javax.transaction. InvalidTransactionException

构造一个 InvalidTransactionException 。

InvalidTransactionException(String) - Constructor for exception javax.transaction. InvalidTransactionException

构造一个 InvalidTransactionException 。

InvalidTypeException - Exception in com.sun.jdi

抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。

InvalidTypeException() - Constructor for exception com.sun.jdi. InvalidTypeException

InvalidTypeException(String) - Constructor for exception com.sun.jdi. InvalidTypeException

InvalidTypeForEncoding - Exception in org.omg.IOP.CodecPackage

org / omg / IOP / CodecPackage / InvalidTypeForEncoding.java。

InvalidTypeForEncoding() - Constructor for exception org.omg.IOP.CodecPackage. InvalidTypeForEncoding

InvalidTypeForEncoding(String) - Constructor for exception org.omg.IOP.CodecPackage. InvalidTypeForEncoding

InvalidTypeForEncodingHelper - Class in org.omg.IOP.CodecPackage

org / omg / IOP / CodecPackage / InvalidTypeForEncodingHelper.java。

InvalidTypeForEncodingHelper() - Constructor for class org.omg.IOP.CodecPackage. InvalidTypeForEncodingHelper

InvalidValue - Exception in org.omg.CORBA.DynAnyPackage

InvalidValue - Exception in org.omg.DynamicAny.DynAnyPackage

org / omg / DynamicAny / DynAnyPackage / InvalidValue.java。

InvalidValue() - Constructor for exception org.omg.CORBA.DynAnyPackage. InvalidValue

构造一个 InvalidValue对象。

InvalidValue() - Constructor for exception org.omg.DynamicAny.DynAnyPackage. InvalidValue

InvalidValue(String) - Constructor for exception org.omg.CORBA.DynAnyPackage. InvalidValue

构造一个 InvalidValue对象。

InvalidValue(String) - Constructor for exception org.omg.DynamicAny.DynAnyPackage. InvalidValue

InvalidValueHelper - Class in org.omg.DynamicAny.DynAnyPackage

org / omg / DynamicAny / DynAnyPackage / InvalidValueHelper.java。

InvalidValueHelper() - Constructor for class org.omg.DynamicAny.DynAnyPackage. InvalidValueHelper

inverseDeltaTransform(double, double) - Method in class javafx.scene.transform. Affine

inverseDeltaTransform(double, double) - Method in class javafx.scene.transform. Rotate

inverseDeltaTransform(double, double) - Method in class javafx.scene.transform. Scale

inverseDeltaTransform(double, double) - Method in class javafx.scene.transform. Shear

inverseDeltaTransform(double, double) - Method in class javafx.scene.transform. Transform

通过该变换的逆变换相对幅度矢量。

inverseDeltaTransform(double, double) - Method in class javafx.scene.transform. Translate

inverseDeltaTransform(double, double, double) - Method in class javafx.scene.transform. Affine

inverseDeltaTransform(double, double, double) - Method in class javafx.scene.transform. Rotate

inverseDeltaTransform(double, double, double) - Method in class javafx.scene.transform. Scale

inverseDeltaTransform(double, double, double) - Method in class javafx.scene.transform. Shear

inverseDeltaTransform(double, double, double) - Method in class javafx.scene.transform. Transform

通过该变换的逆变换相对幅度矢量。

inverseDeltaTransform(double, double, double) - Method in class javafx.scene.transform. Translate

inverseDeltaTransform(Point2D) - Method in class javafx.scene.transform. Transform

将由指定的 Point2D实例表示的相对幅度向量转换为该变换的倒数。

inverseDeltaTransform(Point2D) - Method in class javafx.scene.transform. Translate

inverseDeltaTransform(Point3D) - Method in class javafx.scene.transform. Transform

将由指定的 Point3D实例表示的相对幅度向量转换为该变换的倒数。

inverseDeltaTransform(Point3D) - Method in class javafx.scene.transform. Translate

inverseTransform(double[], int, double[], int, int) - Method in class java.awt.geom. AffineTransform

通过此变换反向转换双精度坐标数组。

inverseTransform(double, double) - Method in class javafx.scene.transform. Affine

inverseTransform(double, double) - Method in class javafx.scene.transform. Rotate

inverseTransform(double, double) - Method in class javafx.scene.transform. Scale

inverseTransform(double, double) - Method in class javafx.scene.transform. Shear

inverseTransform(double, double) - Method in class javafx.scene.transform. Transform

通过该变换的逆变换指定点。

inverseTransform(double, double) - Method in class javafx.scene.transform. Translate

inverseTransform(double, double, double) - Method in class javafx.scene.transform. Affine

inverseTransform(double, double, double) - Method in class javafx.scene.transform. Rotate

inverseTransform(double, double, double) - Method in class javafx.scene.transform. Scale

inverseTransform(double, double, double) - Method in class javafx.scene.transform. Shear

inverseTransform(double, double, double) - Method in class javafx.scene.transform. Transform

通过该变换的逆变换指定点。

inverseTransform(double, double, double) - Method in class javafx.scene.transform. Translate

inverseTransform(Point2D, Point2D) - Method in class java.awt.geom. AffineTransform

反转换指定的 ptSrc并将结果存储在 ptDst 。

inverseTransform(Bounds) - Method in class javafx.scene.transform. Transform

通过该变换的倒数转换指定的边界。

inverseTransform(Point2D) - Method in class javafx.scene.transform. Transform

通过该变换的逆变换指定点。

inverseTransform(Point3D) - Method in class javafx.scene.transform. Transform

通过该变换的逆变换指定点。

inverseTransform2DPoints(double[], int, double[], int, int) - Method in class javafx.scene.transform. Transform

通过这个变换的逆变换一个坐标数组。

inverseTransform3DPoints(double[], int, double[], int, int) - Method in class javafx.scene.transform. Transform

通过该变换的倒数转换浮点坐标数组。

invert() - Method in class java.awt.geom. AffineTransform

将此变换设置为本身的倒数。

invert() - Method in class javafx.scene.paint. Color

创建一个反映此颜色的新颜色。

invert() - Method in class javafx.scene.transform. Affine

将此转换转换到位。

INVERTED_EXCLAMATION_MARK - javafx.scene.input. KeyCode

反转感叹号的常数。

INVITE - Static variable in class java.awt. PageAttributes.MediaType

INVITE_ENVELOPE的别名。

INVITE_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

邀请信封的MediaType实例，220 x 220毫米。

Invocable - Interface in javax.script

由ScriptEngines实现的可选接口，其方法允许在先前执行的脚本中调用过程。

INVOCATION_DEFAULT - Static variable in class java.awt.event. InvocationEvent

所有InvocationEvents的默认ID。

INVOCATION_EVENT_MASK - Static variable in class java.awt. AWTEvent

用于选择调用事件的事件掩码。

INVOCATION_FIRST - Static variable in class java.awt.event. InvocationEvent

标记调用事件ID的范围的第一个整数ID。

INVOCATION_LAST - Static variable in class java.awt.event. InvocationEvent

标记调用事件ID的范围的最后一个整数ID。

InvocationEvent - Class in java.awt.event

它执行的事件 run()上的方法 Runnable当通过AWT事件调度线程进行调度。

InvocationEvent(Object, int, Runnable, Object, boolean) - Constructor for class java.awt.event. InvocationEvent

构造一个 InvocationEvent具有指定源和ID将执行可运行的 run时调度方法。

InvocationEvent(Object, Runnable) - Constructor for class java.awt.event. InvocationEvent

构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

InvocationEvent(Object, Runnable, Object, boolean) - Constructor for class java.awt.event. InvocationEvent

构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

InvocationEvent(Object, Runnable, Runnable, boolean) - Constructor for class java.awt.event. InvocationEvent

构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

InvocationException - Exception in com.sun.jdi

抛出以指示目标VM中的调用方法中发生异常。

InvocationException(ObjectReference) - Constructor for exception com.sun.jdi. InvocationException

InvocationHandler - Interface in java.lang.reflect

InvocationHandler是由代理实例的 调用处理程序实现的接口。

InvocationKeyHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.InvocationKeyHandler

InvocationMouseHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.InvocationMouseHandler

InvocationMouseMotionHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.InvocationMouseMotionHandler

InvocationTargetException - Exception in java.lang.reflect

InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。

InvocationTargetException() - Constructor for exception java.lang.reflect. InvocationTargetException

构造一个 InvocationTargetException其中 null作为目标异常。

InvocationTargetException(Throwable) - Constructor for exception java.lang.reflect. InvocationTargetException

构造一个具有目标异常的InvocationTargetException。

InvocationTargetException(Throwable, String) - Constructor for exception java.lang.reflect. InvocationTargetException

构造一个具有目标异常和详细消息的InvocationTargetException。

INVOICE - Static variable in class java.awt. PageAttributes.MediaType

发票的MediaType实例，5 1/2 x 8 1/2 in。

INVOICE - Static variable in class javax.print.attribute.standard. MediaSize.Other

指定发票大小，5.5英寸×8.5英寸。

INVOICE - Static variable in class javax.print.attribute.standard. MediaSizeName

发票大小

invoke() - Method in class java.util.concurrent. ForkJoinTask

执行此任务后，如有必要，等待完成，并返回其结果，或者如果基础计算执行此操作，则抛出（未选中） RuntimeException或 Error 。

invoke() - Method in class org.omg.CORBA. Request

使用 Request对象中的信息进行同步调用。

invoke(Object...) - Method in class java.lang.invoke. MethodHandle

调用方法句柄，允许任何调用者类型描述符，以及可选地对参数和返回值执行转换。

invoke(Object, Object...) - Method in class java.lang.reflect. 方法

在具有指定参数的指定对象上调用此 方法对象表示的底层方法。

invoke(Object, Method, Object[]) - Method in class java.beans. EventHandler

从事件中提取相应的属性值，并将其传递到与此 EventHandler相关联的操作。

invoke(Object, Method, Object[]) - Method in interface java.lang.reflect. InvocationHandler

处理代理实例上的方法调用并返回结果。

invoke(Object, Method, Object[]) - Method in class java.rmi.server. RemoteObjectInvocationHandler

处理在封装代理实例（ proxy上进行的方法调用，并返回结果。

invoke(Object, Method, Object[]) - Method in class javax.management. MBeanServerInvocationHandler

invoke(Object, Method, Object[]) - Method in class javax.management.openmbean. CompositeDataInvocationHandler

invoke(Method) - Method in class jdk.jshell.execution. DirectExecutionControl

调用指定的“doit-method”，一个没有参数的静态方法。

invoke(Method) - Method in class jdk.jshell.execution. LocalExecutionControl

invoke(Method) - Method in class jdk.jshell.execution. RemoteExecutionControl

invoke(Method, Object...) - Method in class javax.xml.ws.spi. Invoker

JAX-WS运行时调用此方法来对端点实例执行实际的Web服务调用。

invoke(String, Object[], String[]) - Method in interface javax.management. DynamicMBean

允许在动态MBean上调用操作。

invoke(String, Object[], String[]) - Method in class javax.management.modelmbean. RequiredModelMBean

通过或者通过RequiredModelMBean调用方法，并返回方法执行的结果。

invoke(String, Object[], String[]) - Method in class javax.management. StandardMBean

invoke(String, String) - Method in class jdk.jshell.execution. DirectExecutionControl

invoke(String, String) - Method in class jdk.jshell.execution. JdiDefaultExecutionControl

invoke(String, String) - Method in class jdk.jshell.execution. StreamingExecutionControl

invoke(String, String) - Method in interface jdk.jshell.spi. ExecutionControl

通过调用指定的包装类上的方法来调用可执行代码段。

invoke(Remote, Method, Object[], long) - Method in interface java.rmi.server. RemoteRef

调用方法。

invoke(RemoteCall) - Method in interface java.rmi.server. RemoteRef

已过时。
1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。

invoke(ForkJoinTask<T>) - Method in class java.util.concurrent. ForkJoinPool

执行给定的任务，在完成后返回其结果。

invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management. MBeanServer

invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management. MBeanServerConnection

调用MBean上的操作。

invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 。

invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

invoke(Object, OutputStream) - Method in class org.omg.CORBA.portable. Delegate

invoke被一个stub调用来调用一个操作。

invoke(ServerRequest) - Method in class org.omg.CORBA. DynamicImplementation

已过时。
便携式对象适配器已弃用

invoke(ServerRequest) - Method in class org.omg.CosNaming. _BindingIteratorImplBase

invoke(ServerRequest) - Method in class org.omg.CosNaming. _NamingContextImplBase

invoke(ServerRequest) - Method in class org.omg.PortableServer. DynamicImplementation

接收由DSI servant生成的CORBA对象发出的请求，并执行执行请求所需的处理。

invoke(T) - Method in interface javax.xml.ws. Dispatch

同步调用服务操作。

invoke(T) - Method in interface javax.xml.ws. Provider

根据请求消息的内容调用操作。

INVOKE - com.sun.source.tree. MemberReferenceTree.ReferenceMode

枚举常数用于方法引用。

INVOKE_NONVIRTUAL - Static variable in interface com.sun.jdi. ObjectReference

执行非虚拟方法调用

INVOKE_SINGLE_THREADED - Static variable in interface com.sun.jdi. ClassType

仅执行调用线程执行方法调用

INVOKE_SINGLE_THREADED - Static variable in interface com.sun.jdi. ObjectReference

仅执行调用线程执行方法调用

invokeAll(Collection<? extends Callable<T>>) - Method in class java.util.concurrent. AbstractExecutorService

invokeAll(Collection<? extends Callable<T>>) - Method in interface java.util.concurrent. ExecutorService

执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。

invokeAll(Collection<? extends Callable<T>>) - Method in class java.util.concurrent. ForkJoinPool

invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - Method in class java.util.concurrent. AbstractExecutorService

invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - Method in interface java.util.concurrent. ExecutorService

执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。

invokeAll(Collection<T>) - Static method in class java.util.concurrent. ForkJoinTask

叉指定集合中的所有任务，当 isDone适用于每个任务或返回（未检查）异常时返回，在这种情况下，异常被重新引导。

invokeAll(ForkJoinTask<?>...) - Static method in class java.util.concurrent. ForkJoinTask

叉出给定的任务，当 isDone适用于每个任务时返回，或遇到（未检查）异常，在这种情况下异常被重新引导。

invokeAll(ForkJoinTask<?>, ForkJoinTask<?>) - Static method in class java.util.concurrent. ForkJoinTask

叉出给定的任务，当 isDone适用于每个任务时返回，或遇到（未检查）异常，在这种情况下，异常被重新引导。

invokeAndWait(Runnable) - Static method in class java.awt. EventQueue

导致 runnable要求其 run方法在 dispatch thread的 the system EventQueue中被调用。

invokeAndWait(Runnable) - Static method in class javax.swing. SwingUtilities

导致在AWT事件调度线程上同步执行 doRun.run() 。

invokeAny(Collection<? extends Callable<T>>) - Method in class java.util.concurrent. AbstractExecutorService

invokeAny(Collection<? extends Callable<T>>) - Method in interface java.util.concurrent. ExecutorService

执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。

invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - Method in class java.util.concurrent. AbstractExecutorService

invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - Method in interface java.util.concurrent. ExecutorService

执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。

invokeAsync(T) - Method in interface javax.xml.ws. Dispatch

异步调用服务操作。

invokeAsync(T, AsyncHandler<T>) - Method in interface javax.xml.ws. Dispatch

异步调用服务操作。

invokeExact(Object...) - Method in class java.lang.invoke. MethodHandle

调用方法句柄，允许任何调用者类型描述符，但需要确切的类型匹配。

invokeFunction(String, Object...) - Method in interface javax.script. Invocable

用于调用脚本中定义的顶级过程和函数。

invokeFunction(String, Object...) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

InvokeHandler - Interface in org.omg.CORBA.portable

该接口为来电提供调度机制。

invokeLater(Runnable) - Static method in class java.awt. EventQueue

原因 runnable有 run的 dispatch thread的 run方法 。

invokeLater(Runnable) - Static method in class javax.swing. SwingUtilities

导致 doRun.run（）在AWT事件分派线程上异步执行。

invokeMethod(ThreadReference, Method, List<? extends Value>, int) - Method in interface com.sun.jdi. ClassType

在目标VM中调用指定的静态方法 。

invokeMethod(ThreadReference, Method, List<? extends Value>, int) - Method in interface com.sun.jdi. InterfaceType

调用目标VM中指定的静态方法 。

invokeMethod(ThreadReference, Method, List<? extends Value>, int) - Method in interface com.sun.jdi. ObjectReference

在目标VM中调用此对象上指定的方法 。

invokeMethod(Object, String, Object...) - Method in interface javax.script. Invocable

调用在前一个脚本执行期间编译的脚本对象上的方法，该方法保留在 ScriptEngine的状态。

invokeMethod(Object, String, Object...) - Method in class jdk.nashorn.api.scripting. NashornScriptEngine

invokeOneWay(T) - Method in interface javax.xml.ws. Dispatch

使用单向交互模式调用服务操作。

invoker(MethodType) - Static method in class java.lang.invoke. MethodHandles

产生一个特殊的 调用方法句柄 ，可以用来调用与给定类型兼容的任何方法句柄，就像通过 invoke一样 。

Invoker - Class in javax.xml.ws.spi

Invoker隐藏了调用应用程序端点实现的细节。

Invoker() - Constructor for class javax.xml.ws.spi. Invoker

INVOKES_STOP_CELL_EDITING_PROPERTY - Static variable in class javax.swing. JTree

绑定属性名称为 messagesStopCellEditing 。

invokesStopCellEditing - Variable in class javax.swing. JTree

如果为真，当通过选择更改来停止编辑时，将调用树更改或其他方法中的数据 stopCellEditing ，并保存更改。

invokeWithArguments(Object...) - Method in class java.lang.invoke. MethodHandle

执行变量arity调用，将给定列表中的参数传递给方法句柄，好像通过来自调用站点的不正确的 invoke ，其中仅提及类型为 Object ，其arity为参数列表的长度。

invokeWithArguments(List<?>) - Method in class java.lang.invoke. MethodHandle

执行变量arity调用，将给定数组中的参数传递给方法句柄，好像通过来自调用站点的不精确的 invoke ，其中仅提及类型为 Object ，其arity为参数数组的长度。

IOError - Error in java.io

当出现严重I / O错误时抛出。

IOError(Throwable) - Constructor for error java.io. IOError

构造具有指定原因的新的IOError实例。

ioException() - Method in class java.util. Formatter

返回IOException最后通过此格式的抛出Appendable 。

ioException() - Method in class java.util. Scanner

返回 IOException最后抛出的 Scanner的底层 Readable 。

IOException - Exception in java.io

表示发生某种类型的I / O异常。

IOException() - Constructor for exception java.io. IOException

构造一个 IOException其中包含 null作为其错误详细消息。

IOException(String) - Constructor for exception java.io. IOException

构造具有指定详细消息的 IOException 。

IOException(String, Throwable) - Constructor for exception java.io. IOException

构造一个具有指定的详细信息和原因的 IOException 。

IOException(Throwable) - Constructor for exception java.io. IOException

构造一个 IOException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

IOR - Class in org.omg.IOP

org / omg / IOP / IOR.java。

IOR() - Constructor for class org.omg.IOP. IOR

IOR(String, TaggedProfile[]) - Constructor for class org.omg.IOP. IOR

IORHelper - Class in org.omg.IOP

org / omg / IOP / IORHelper.java。

IORHelper() - Constructor for class org.omg.IOP. IORHelper

IORHolder - Class in org.omg.IOP

org / omg / IOP / IORHolder.java。

IORHolder() - Constructor for class org.omg.IOP. IORHolder

IORHolder(IOR) - Constructor for class org.omg.IOP. IORHolder

IORInfo - Interface in org.omg.PortableInterceptor

在IOR构造期间提供服务器端ORB服务访问适用的策略以及添加组件的能力。

IORInfoOperations - Interface in org.omg.PortableInterceptor

在IOR构造期间提供服务器端ORB服务访问适用的策略以及添加组件的能力。

IORInterceptor - Interface in org.omg.PortableInterceptor

拦截器用于在IOR中的配置文件中建立标记的组件。

IORInterceptor_3_0 - Interface in org.omg.PortableInterceptor

org / omg / PortableInterceptor / IORInterceptor_3_0.java。

IORInterceptor_3_0Helper - Class in org.omg.PortableInterceptor

org / omg / PortableInterceptor / IORInterceptor_3_0Helper.java。

IORInterceptor_3_0Helper() - Constructor for class org.omg.PortableInterceptor. IORInterceptor_3_0Helper

IORInterceptor_3_0Holder - Class in org.omg.PortableInterceptor

org / omg / PortableInterceptor / IORInterceptor_3_0Holder.java。

IORInterceptor_3_0Holder() - Constructor for class org.omg.PortableInterceptor. IORInterceptor_3_0Holder

IORInterceptor_3_0Holder(IORInterceptor_3_0) - Constructor for class org.omg.PortableInterceptor. IORInterceptor_3_0Holder

IORInterceptor_3_0Operations - Interface in org.omg.PortableInterceptor

org / omg / PortableInterceptor / IORInterceptor_3_0Operations.java。

IORInterceptorOperations - Interface in org.omg.PortableInterceptor

拦截器用于在IOR中的配置文件中建立标记的组件。

IP_MULTICAST_IF - Static variable in interface java.net. SocketOptions

设置发送组播数据包的出接口。

IP_MULTICAST_IF - Static variable in class java.net. StandardSocketOptions

互联网协议（IP）组播数据报的网络接口。

IP_MULTICAST_IF2 - Static variable in interface java.net. SocketOptions

与上述相同。

IP_MULTICAST_LOOP - Static variable in interface java.net. SocketOptions

此选项启用或禁用组播数据报的本地环回。

IP_MULTICAST_LOOP - Static variable in class java.net. StandardSocketOptions

互联网协议（IP）组播数据报的环回。

IP_MULTICAST_TTL - Static variable in class java.net. StandardSocketOptions

互联网协议（IP）组播数据报 的生存时间 。

IP_TOS - Static variable in interface java.net. SocketOptions

此选项将TCP或UDP套接字的IP头中的服务类型或流量类别字段设置。

IP_TOS - Static variable in class java.net. StandardSocketOptions

互联网协议（IP）头中的服务类型（ToS）八位字节。

IPA_EXTENSIONS - Static variable in class java.lang. Character.UnicodeBlock

“IPA扩展”Unicode字符块的常量。

ipadx - Variable in class java.awt. GridBagConstraints

该字段指定组件的内部填充，添加到组件最小宽度的空间。

ipady - Variable in class java.awt. GridBagConstraints

该字段指定内部填充，即要添加到组件最小高度的空间。

IRObject - Interface in org.omg.CORBA

IRObject IDL接口代表所有其他接口存储库接口派生的最通用接口，即使是Repository本身。

IRObjectOperations - Interface in org.omg.CORBA

这是 IRObject映射的操作界面。

is_a(Object, String) - Method in class org.omg.CORBA.portable. Delegate

检查对象引用是否是给定接口的实例。

is_a(Servant, String) - Method in interface org.omg.PortableServer.portable. Delegate

此方法检查_all_interfaces（）返回的列表中是否存在指定的repid，或者是通用CORBA对象的存储库标识。

IS_CLOSED_PROPERTY - Static variable in class javax.swing. JInternalFrame

内部框架关闭的约束属性名称。

IS_COALESCING - Static variable in class javax.xml.stream. XMLInputFactory

需要解析器来合并相邻字符数据部分的属性

is_equivalent(Object, Object) - Method in class org.omg.CORBA.portable. Delegate

确定两个对象引用是否相等。

IS_ICON_PROPERTY - Static variable in class javax.swing. JInternalFrame

指示内部框架被图标化的约束属性名称。

is_local(Object) - Method in class org.omg.CORBA.portable. Delegate

如果此对象由本地服务器实现，则返回true。

IS_MAXIMUM_PROPERTY - Static variable in class javax.swing. JInternalFrame

指示内部框架最大化的约束属性名称。

IS_NAMESPACE_AWARE - Static variable in class javax.xml.stream. XMLInputFactory

该属性用于打开/关闭命名空间支持，这是为了支持XML 1.0文档，只有真正的设置必须被支持

is_null() - Method in class org.omg.DynamicAny. _DynValueStub

如果DynValueCommon表示空值类型，则返回true。

is_null() - Method in interface org.omg.DynamicAny. DynValueCommonOperations

如果DynValueCommon表示空值类型，则返回true。

IS_PALETTE - Static variable in class javax.swing.plaf.metal. MetalInternalFrameUI

物业 JInternalFrame.isPalette 。

IS_REPAIRING_NAMESPACES - Static variable in class javax.xml.stream. XMLOutputFactory

用于在输出端设置前缀默认值的属性

IS_REPLACING_ENTITY_REFERENCES - Static variable in class javax.xml.stream. XMLInputFactory

需要解析器用其替换文本替换内部实体引用并将其报告为字符

IS_SELECTED_PROPERTY - Static variable in class javax.swing. JInternalFrame

受限属性名称表示此框已选择状态。

IS_SUPPORTING_EXTERNAL_ENTITIES - Static variable in class javax.xml.stream. XMLInputFactory

需要解析器解析外部解析实体的属性

IS_VALIDATING - Static variable in class javax.xml.stream. XMLInputFactory

用于打开/关闭实现特定验证的属性

is2D() - Method in enum javafx.scene.transform. MatrixType

指定这是否是2D变换矩阵

isAbsolute() - Method in class java.io. File

测试这个抽象路径名是否是绝对的。

isAbsolute() - Method in class java.net. URI

告诉这个URI是否是绝对的。

isAbsolute() - Method in interface java.nio.file. Path

告诉这条路是否是绝对的。

isAbsolute() - Method in class javafx.css. Size

返回此Size是否为绝对值或相对值。

isAbsolute() - Method in enum javafx.css. SizeUnits

isAbsolute() - Method in class javafx.scene.shape. PathElement

获取属性的值绝对值。

isAbstract() - Method in interface com.sun.javadoc. ClassDoc

已过时。

如果这个类是抽象的，返回true。

isAbstract() - Method in interface com.sun.javadoc. MethodDoc

已过时。

如果这个方法是抽象的，返回true

isAbstract() - Method in interface com.sun.jdi. 方法

确定这个方法是否是抽象的。

isAbstract() - Method in interface com.sun.jdi. ReferenceType

确定此类型是否被声明为抽象。

isAbstract(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 abstract修改， false否则。

isAccelerated() - Method in class java.awt. ImageCapabilities

如果能够封装在此 ImageCapabilities的对象可以被加速，则返回 true 。

isAcceleratorHidden() - Method in class javax.swing.plaf.metal. MetalToolTipUI

如果加速器隐藏，该方法返回 true ，否则返回 false 。

isAcceptable() - Method in class java.nio.channels. SelectionKey

测试此密钥的通道是否已准备好接受新的套接字连接。

isAcceptAllFileFilterUsed() - Method in class javax.swing. JFileChooser

返回是否使用 AcceptAll FileFilter 。

isAccepted() - Method in class javafx.scene.input. DragEvent

表示此事件是否已被接受。

isAccessibilityActive() - Static method in class javafx.application. Platform

获取属性accessibilityActive的值。

isAccessible() - Method in class java.lang.reflect. AccessibleObject

已过时。
此方法已被弃用，因为它的名称提示它检查反射对象是否可访问，当它实际指示是否抑制对Java语言访问控制的检查。 此方法可能会在调用者可访问的反射对象上返回false 。 要测试此反射对象是否可访问，应使用AccessibleObject.canAccess(Object) 。

isAccessible(Scope, Element, DeclaredType) - Method in class com.sun.source.util. Trees

检查给定元素是否可以作为给定范围内给定类型的成员访问。

isAccessible(Scope, TypeElement) - Method in class com.sun.source.util. Trees

检查给定范围内是否可访问给定类型。

isAccessibleChildSelected(int) - Method in class java.awt. List.AccessibleAWTList

如果选择此对象的当前子级，则返回true。

isAccessibleChildSelected(int) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

确定是否选择了此对象的当前子级。

isAccessibleChildSelected(int) - Method in interface javax.accessibility. AccessibleSelection

确定是否选择了此对象的当前子级。

isAccessibleChildSelected(int) - Method in class javax.swing. JComboBox.AccessibleJComboBox

确定是否选择了此对象的当前子级。

isAccessibleChildSelected(int) - Method in class javax.swing. JList.AccessibleJList

如果选择此对象的当前子级，则返回true。

isAccessibleChildSelected(int) - Method in class javax.swing. JMenu.AccessibleJMenu

如果选择了此对象的当前子项（即，如果此子是弹出子菜单），则返回true。

isAccessibleChildSelected(int) - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

如果选择此对象的当前子级，则返回true。

isAccessibleChildSelected(int) - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

isAccessibleChildSelected(int) - Method in class javax.swing. JTable.AccessibleJTable

确定是否选择了此对象的当前子级。

isAccessibleChildSelected(int) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

如果选择此对象的当前子级，则返回true。

isAccessibleChildSelected(int) - Method in class javax.swing. JTree.AccessibleJTree

如果选择此对象的当前子级，则返回true。

isAccessibleColumnSelected(int) - Method in interface javax.accessibility. AccessibleTable

返回一个布尔值，指示是否选择了指定的列。

isAccessibleColumnSelected(int) - Method in class javax.swing. JTable.AccessibleJTable

返回一个布尔值，指示是否选择了指定的列。

isAccessibleRowSelected(int) - Method in interface javax.accessibility. AccessibleTable

返回一个布尔值，指示是否选择了指定的行。

isAccessibleRowSelected(int) - Method in class javax.swing. JTable.AccessibleJTable

返回一个布尔值，指示是否选择了指定的行。

isAccessibleSelected(int, int) - Method in interface javax.accessibility. AccessibleTable

返回一个布尔值，指示是否选择了在指定的行和列可访问。

isAccessibleSelected(int, int) - Method in class javax.swing. JTable.AccessibleJTable

返回一个布尔值，指示是否选择在给定（行，列）可访问。

isAccessModeSupported(VarHandle.AccessMode) - Method in class java.lang.invoke. VarHandle

如果支持给定的访问模式，则返回 true ，否则为 false 。

isActionKey() - Method in class java.awt.event. KeyEvent

返回此事件中的键是否为“动作”键。

isActivated() - Method in class javafx.scene.control. Tooltip

获取激活的属性的值。

isActive() - Method in class java.applet. Applet

已过时。

确定此applet是否处于活动状态。

isActive() - Method in interface java.applet. AppletStub

已过时。

确定小程序是否处于活动状态。

isActive() - Method in class java.awt.dnd. DropTarget

报告此 DropTarget是否当前处于活动状态（准备接受滴液）。

isActive() - Method in class java.awt. Window

返回此窗口是否处于活动状态。

isActive() - Method in class javax.management.monitor. Monitor

测试监视器MBean是否处于活动状态。

isActive() - Method in interface javax.management.monitor. MonitorMBean

测试监视器MBean是否处于活动状态。

isActive() - Method in class javax.management.relation. RelationService

检查关系服务是否处于活动状态。

isActive() - Method in interface javax.management.relation. RelationServiceMBean

检查关系服务是否处于活动状态。

isActive() - Method in interface javax.management.remote. JMXConnectorServerMBean

确定连接器服务器是否处于活动状态。

isActive() - Method in class javax.management.remote.rmi. RMIConnectorServer

isActive() - Method in class javax.management.timer. Timer

测试定时器MBean是否处于活动状态。

isActive() - Method in interface javax.management.timer. TimerMBean

测试定时器MBean是否处于活动状态。

isActive() - Method in interface javax.sound.sampled. DataLine

指示线路是否处于活动I / O（例如播放或捕获）。

isActive() - Method in class javax.swing.text. DefaultCaret

确定插入符号当前是否处于活动状态。

isActive() - Method in enum jdk.jshell. Snippet.Status

指示代码段是否处于活动状态，即，当调用可能更改其状态的新的JShell.eval(String)或JShell.drop(Snippet)时，将重新评估一个persistent代码段。

isAdded() - Method in class javafx.scene.control. TextFormatter.Change

获取此更改是否响应添加的文本。

isAddedPath() - Method in class javax.swing.event. TreeSelectionEvent

返回由 getPath标识的路径是否添加到选择。

isAddedPath(int) - Method in class javax.swing.event. TreeSelectionEvent

返回是否将 getPaths()[index]的路径添加到选择。

isAddedPath(TreePath) - Method in class javax.swing.event. TreeSelectionEvent

返回指定的路径是否添加到选择。

isAfter(int, int, Rectangle) - Method in class javax.swing.text. BoxView

确定一个点是否落在分配的区域之后。

isAfter(int, int, Rectangle) - Method in class javax.swing.text. CompositeView

测试一个点是否在矩形范围之后。

isAfter(ChronoLocalDate) - Method in interface java.time.chrono. ChronoLocalDate

检查此日期是否在忽略年表的指定日期之后。

isAfter(ChronoLocalDate) - Method in class java.time. LocalDate

检查此日期是否在指定日期之后。

isAfter(ChronoLocalDateTime<?>) - Method in interface java.time.chrono. ChronoLocalDateTime

检查这个日期时间是否在指定的日期时间之后，忽略年表。

isAfter(ChronoLocalDateTime<?>) - Method in class java.time. LocalDateTime

检查这个日期时间是否在指定的日期之后。

isAfter(ChronoZonedDateTime<?>) - Method in interface java.time.chrono. ChronoZonedDateTime

检查此日期时间是否在指定的日期时间之后。

isAfter(Instant) - Method in class java.time. Instant

检查这个瞬间是否在指定的时刻之后。

isAfter(LocalTime) - Method in class java.time. LocalTime

检查此时间是否在指定时间后。

isAfter(MonthDay) - Method in class java.time. MonthDay

检查这个月日是否在指定的月日之后。

isAfter(OffsetDateTime) - Method in class java.time. OffsetDateTime

检查此日期时间是否在指定的日期时间之后。

isAfter(OffsetTime) - Method in class java.time. OffsetTime

检查此 OffsetTime是否在指定的时间之后，将两次都应用到通用日期。

isAfter(Year) - Method in class java.time. Year

检查今年是否在指定的年份之后。

isAfter(YearMonth) - Method in class java.time. YearMonth

检查这个年月是否在指定的年月之后。

isAfterLast() - Method in interface java.sql. ResultSet

检索光标是否在此 ResultSet对象中的最后一行之后。

isAlive() - Method in class java.lang. Process

测试此 Process表示的过程是否存活。

isAlive() - Method in interface java.lang. ProcessHandle

测试此 ProcessHandle表示的过程是否存活。

isAlive() - Method in class java.lang. Thread

测试这个线程是否活着。

isAllocationValid() - Method in class javax.swing.text. BoxView

孩子的分配是否仍然有效？

isAllowIndeterminate() - Method in class javafx.scene.control. CheckBox

获取属性allowIndeterminate的值。

isAlphabetic(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是否是字母表。

isAlphaPremultiplied() - Method in class java.awt.image. BufferedImage

返回alpha是否被预乘。

isAlphaPremultiplied() - Method in class java.awt.image. ColorModel

返回Alpha ColorModel要翻译的像素值中是否预先使用 ColorModel 。

isAltDown() - Method in class java.awt.event. InputEvent

返回此事件的Alt修饰符是否关闭。

isAltDown() - Method in class javafx.scene.input. GestureEvent

指示此事件的Alt修饰符是否关闭。

isAltDown() - Method in class javafx.scene.input. KeyEvent

返回此事件的Alt修饰符是否关闭。

isAltDown() - Method in class javafx.scene.input. MouseEvent

此修改器是否关闭此事件。

isAltDown() - Method in class javafx.scene.input. TouchEvent

此修改器是否关闭此事件。

isAlternativeColumnFillVisible() - Method in class javafx.scene.chart. XYChart

获取propertyColumnFillVisible属性的值。

isAlternativeRowFillVisible() - Method in class javafx.scene.chart. XYChart

获取属性alternativeRowFillVisible的值。

isAltGraphDown() - Method in class java.awt.event. InputEvent

返回此事件的AltGraph修饰符是否关闭。

isAlwaysOnTop() - Method in class java.awt. Window

返回此窗口是否为始终在上的窗口。

isAlwaysOnTop() - Method in class javafx.stage. Stage

获取属性alwaysOnTop的值。

isAlwaysOnTopSupported() - Method in class java.awt. Toolkit

返回此工具包是否支持始终在线模式。

isAlwaysOnTopSupported() - Method in class java.awt. Window

返回此窗口是否支持始终在线模式。

isAncestorOf(Component) - Method in class java.awt. Container

检查组件是否包含在此容器的组件层次结构中。

isAnimated() - Method in class javafx.scene.control. TitledPane

返回TitledPane的动画状态。

isAnnotation() - Method in class java.lang. Class

如果此 Class对象表示注释类型，则返回true。

isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang. Class

如果此元素上 存在指定类型的注释，则返回true，否则返回false。

isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang. 软件包

如果此元素上 存在指定类型的注释，则返回true，否则返回false。

isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang.reflect. AccessibleObject

如果此元素上 存在指定类型的注释，则返回true，否则返回false。

isAnnotationPresent(Class<? extends Annotation>) - Method in interface java.lang.reflect. AnnotatedElement

如果此元素上 存在指定类型的注释，则返回true，否则返回false。

isAnnotationType() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是否是注释类型？

isAnnotationTypeElement() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是否是注释类型元素？

isAnonymous() - Method in interface org.ietf.jgss. GSSName

测试此名称对象是否表示匿名实体。

isAnonymousClass() - Method in class java.lang. Class

返回 true当且仅当基础类是匿名类时。

isAntiAliased() - Method in class java.awt.font. FontRenderContext

返回一个布尔值，表示某个形式的抗锯齿是否由此 FontRenderContext指定。

isAnyLocalAddress() - Method in class java.net. Inet4Address

检查InetAddress是否为通配符地址的实用程序。

isAnyLocalAddress() - Method in class java.net. Inet6Address

检查InetAddress是否为通配符地址的实用程序。

isAnyLocalAddress() - Method in class java.net. InetAddress

检查InetAddress是否为通配符地址的实用程序。

isAnyPolicyInhibited() - Method in class java.security.cert. PKIXParameters

检查是否应将任何策略OID包含在证书中进行处理。

isArchive() - Method in interface java.nio.file.attribute. DosFileAttributes

返回归档属性的值。

isArgument() - Method in interface com.sun.jdi. LocalVariable

确定此变量是否为其方法的参数。

isArmed() - Method in class javafx.scene.control. ButtonBase

获得武器的价值。

isArmed() - Method in class javafx.scene.control. ComboBoxBase

获得武器的价值。

isArmed() - Method in interface javax.swing. ButtonModel

表示部分承诺触发按钮。

isArmed() - Method in class javax.swing. DefaultButtonModel

表示部分承诺触发按钮。

isArmed() - Method in class javax.swing. JMenuItem

返回菜单项是否为“布防”。

isArray() - Method in class java.lang. Class

确定此 Class对象是否表示数组类。

isArray() - Method in class javax.management.openmbean. OpenType

返回 true如果打开的类型描述的开放数据值是数组，否则为 false 。

isArray() - Method in class jdk.nashorn.api.scripting. AbstractJSObject

isArray() - Method in interface jdk.nashorn.api.scripting. JSObject

这是一个数组对象吗？

isArray() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

isArray(int, MethodType) - Static method in class jdk.dynalink.linker.support. Guards

创建方法句柄，如果指定位置的参数是Java数组，则返回true。

isArrow() - Method in interface jdk.nashorn.api.tree. FunctionExpressionTree

这是一个箭头功能吗？

isArrowKey() - Method in enum javafx.scene.input. KeyCode

左，右，上，下键（包括键盘箭头）

isAscending() - Method in class javax.naming.ldap. SortKey

确定排序顺序。

isAssignable(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util. Types

测试一种类型是否可分配给另一种。

isAssignableFrom(Class<?>) - Method in class java.lang. Class

确定由此 Class对象表示的类或接口是否与由指定的 Class参数表示的类或接口相同或是超类或超级接口。

isAtBreakpoint() - Method in interface com.sun.jdi. ThreadReference

确定线程是否在断点处挂起。

isAttribute() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是属性。

isAttributeCategorySupported(Class<? extends Attribute>) - Method in interface javax.print. PrintService

确定在为此打印服务设置作业时，客户端是否可以指定给定的打印属性类别。

isAttributeRequired(String, String) - Method in interface javax.imageio.metadata. IIOMetadataFormat

如果命名的属性必须存在于命名的元素中，则返回 true 。

isAttributeRequired(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

isAttributeSpecified(int) - Method in class javax.xml.stream.util. StreamReaderDelegate

isAttributeSpecified(int) - Method in interface javax.xml.stream. XMLStreamReader

返回一个布尔值，表示此属性是否默认创建

isAttributeValueSupported(Attribute, DocFlavor, AttributeSet) - Method in interface javax.print. PrintService

确定在为此打印服务设置作业时，客户端是否可以指定给定的打印属性值。

isAuthorized() - Method in class javax.security.sasl. AuthorizeCallback

确定验证ID是否被允许代表授权ID进行操作。

isAutoDetecting() - Method in class java.nio.charset. CharsetDecoder

告知该解码器是否实现自动检测字符集。

isAutoFix() - Method in class javafx.stage. PopupWindow

获取属性autoFix的值。

isAutoFormSubmission() - Method in class javax.swing.text.html. HTMLEditorKit

指示是自动处理html表单提交还是仅 FormSubmitEvent 。

isAutoHide() - Method in class javafx.stage. PopupWindow

获取属性autoHide的值。

isAutoIncrement(int) - Method in interface java.sql. ResultSetMetaData

指示指定列是否自动编号。

isAutoIncrement(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索存储在指定列中的值是否自动编号，因此是唯读的。

isAutomatic() - Method in class java.lang.module. ModuleDescriptor

如果这是自动模块，则返回 true 。

isAutoPlay() - Method in class javafx.scene.media. MediaPlayer

检索 autoPlay属性值。

isAutoRanging() - Method in class javafx.scene.chart. Axis

获取属性autoRanging的值。

isAutoRequestFocus() - Method in class java.awt. Window

返回此窗口是否应该随后显示焦点（调用 setVisible(true) ）或被移动到前面（调用 Window.toFront() ）。

isAutoReverse() - Method in class javafx.animation. Animation

获取属性autoReverse的值。

isAutoScrolling - Variable in class javax.swing.plaf.basic. BasicComboPopup

如果 true启用自动滚动。

isAutoSizeChildren() - Method in class javafx.scene. Group

获取属性autoSizeChildren的值。

isAutoWaitForIdle() - Method in class java.awt. Robot

返回此机器人是否在生成事件后自动调用 waitForIdle 。

isBackgroundLoading() - Method in class javafx.scene.image. Image

指示图像是否在后台加载。

isBackgroundSet() - Method in class java.awt. Component

返回是否为此组件显式设置了背景颜色。

isBackingStoreEnabled() - Method in class javax.swing. JViewport

已过时。
从Java 2平台v1.3开始，由getScrollMode()替代。

isBefore(int, int, Rectangle) - Method in class javax.swing.text. BoxView

确定一个点是否落在分配的区域之前。

isBefore(int, int, Rectangle) - Method in class javax.swing.text. CompositeView

测试点是否在矩形范围之前。

isBefore(ChronoLocalDate) - Method in interface java.time.chrono. ChronoLocalDate

检查此日期是否在忽略年表前的指定日期之前。

isBefore(ChronoLocalDate) - Method in class java.time. LocalDate

检查此日期是否在指定日期之前。

isBefore(ChronoLocalDateTime<?>) - Method in interface java.time.chrono. ChronoLocalDateTime

检查这个日期时间是否在指定的日期时间之前忽略年表。

isBefore(ChronoLocalDateTime<?>) - Method in class java.time. LocalDateTime

检查此日期时间是否在指定的日期时间之前。

isBefore(ChronoZonedDateTime<?>) - Method in interface java.time.chrono. ChronoZonedDateTime

检查此日期时间是否在指定的日期时间之前。

isBefore(Instant) - Method in class java.time. Instant

检查这个时刻是否在指定的时刻之前。

isBefore(LocalTime) - Method in class java.time. LocalTime

检查此时间是否在指定时间之前。

isBefore(MonthDay) - Method in class java.time. MonthDay

检查这个月日是否在指定的月日之前。

isBefore(OffsetDateTime) - Method in class java.time. OffsetDateTime

检查此日期时间是否在指定的日期时间之前。

isBefore(OffsetTime) - Method in class java.time. OffsetTime

检查这个 OffsetTime是否在指定的时间内应用两个时间到普通的日期。

isBefore(Year) - Method in class java.time. Year

检查今年是否在指定年份之前。

isBefore(YearMonth) - Method in class java.time. YearMonth

检查这个年月是否在指定的年份之前。

isBeforeFirst() - Method in interface java.sql. ResultSet

检索光标是否在此 ResultSet对象的第一行之前。

isBigEndian() - Method in class javax.sound.sampled. AudioFormat

指示音频数据是以big-endian还是小端字节顺序存储。

isBlock() - Method in class javax.swing.text.html. HTML.Tag

返回 true如果此标记是块标记，它是用于向文档添加结构的标签。

isBlocking() - Method in class java.nio.channels. SelectableChannel

告诉这个通道上的每个I / O操作是否会阻塞直到完成。

isBlocking() - Method in class java.nio.channels.spi. AbstractSelectableChannel

isBlockTag(AttributeSet) - Method in class javax.swing.text.html. HTMLWriter

确定与元素关联的HTML.Tag是否是块标记。

isBmpCodePoint(int) - Static method in class java.lang. Character

确定指定字符（Unicode代码点）是否在 Basic Multilingual Plane (BMP)中 。

isBold() - Method in class java.awt. Font

指示此 Font对象的样式是否为BOLD。

isBold(AttributeSet) - Static method in class javax.swing.text. StyleConstants

检查是否设置了粗体属性。

isBootClassPathSupported() - Method in interface java.lang.management. RuntimeMXBean

测试Java虚拟机是否支持bootstrap类加载器用于搜索类文件的引导类路径机制。

isBorderOpaque() - Method in class javax.swing.border. AbstractBorder

此默认实现返回false。

isBorderOpaque() - Method in class javax.swing.border. BevelBorder

返回边框是否不透明。

isBorderOpaque() - Method in interface javax.swing.border. Border

返回边框是否不透明。

isBorderOpaque() - Method in class javax.swing.border. CompoundBorder

返回复合边框是否不透明。

isBorderOpaque() - Method in class javax.swing.border. EmptyBorder

返回边框是否不透明。

isBorderOpaque() - Method in class javax.swing.border. EtchedBorder

返回边框是否不透明。

isBorderOpaque() - Method in class javax.swing.border. LineBorder

返回边框是否不透明。

isBorderOpaque() - Method in class javax.swing.border. MatteBorder

返回边框是否不透明。

isBorderOpaque() - Method in class javax.swing.border. SoftBevelBorder

返回边框是否不透明。

isBorderOpaque() - Method in class javax.swing.border. TitledBorder

返回边框是否不透明。

isBorderOpaque() - Method in class javax.swing.plaf.basic. BasicBorders.SplitPaneBorder

isBorderOpaque() - Method in class javax.swing.plaf. BorderUIResource

isBorderPainted() - Method in class javax.swing. AbstractButton

获取 borderPainted属性。

isBorderPainted() - Method in class javax.swing. JMenuBar

如果菜单栏边框应该绘制，则返回true。

isBorderPainted() - Method in class javax.swing. JPopupMenu

检查边框是否应该涂漆。

isBorderPainted() - Method in class javax.swing. JProgressBar

返回 borderPainted属性。

isBorderPainted() - Method in class javax.swing. JToolBar

获取 borderPainted属性。

isBorderPaintedFlat() - Method in class javax.swing. JCheckBox

获取 borderPaintedFlat属性的值。

isBottomAsPercentage() - Method in class javafx.scene.layout. BorderWidths

指定 bottom属性是否应解释为区域高度的百分比（ true ）（ false ）。

isBottomLeftHorizontalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 bottomLeftHorizontalRadius解释为值或百分比。

isBottomLeftVerticalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 bottomLeftVerticalRadius解释为值或百分比。

isBottomRightHorizontalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 bottomRightHorizontalRadius解释为值或百分比。

isBottomRightVerticalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 bottomRightVerticalRadius解释为值或百分比。

isBound() - Method in class java.beans. PropertyDescriptor

对“绑定”属性的更新将导致在属性更改时触发“PropertyChange”事件。

isBound() - Method in class java.net. DatagramSocket

返回套接字的绑定状态。

isBound() - Method in class java.net. ServerSocket

返回ServerSocket的绑定状态。

isBound() - Method in class java.net. Socket

返回套接字的绑定状态。

isBound() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty

可以用来检查，如果一个 Property被绑定。

isBound() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property.adapter. JavaBeanStringProperty

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property. BooleanPropertyBase

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property. DoublePropertyBase

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property. FloatPropertyBase

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property. IntegerPropertyBase

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property. ListPropertyBase

isBound() - Method in class javafx.beans.property. LongPropertyBase

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property. MapPropertyBase

isBound() - Method in class javafx.beans.property. ObjectPropertyBase

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in interface javafx.beans.property. Property

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javafx.beans.property. SetPropertyBase

isBound() - Method in class javafx.beans.property. StringPropertyBase

可以用来检查，如果一个 Property是绑定的。

isBound() - Method in class javax.security.auth.kerberos. KeyTab

如果keytab绑定到一个主体返回

isBoundary(int) - Method in class java.text. BreakIterator

如果指定的字符偏移量是文本边界，则返回true。

isBridge() - Method in interface com.sun.jdi. 方法

确定此方法是否为桥接方法。

isBridge() - Method in class java.lang.reflect. 方法

如果此方法是桥接方法，则返回true ; 否则返回false 。

isBridge(ExecutableElement) - Method in interface javax.lang.model.util. Elements

返回 true如果可执行元素是bridge方法， false否则。

isBroken() - Method in class java.util.concurrent. CyclicBarrier

询问这个障碍是否处于破碎状态。

isButtonUniformSize(Node) - Static method in class javafx.scene.control. ButtonBar

返回给定节点是否是统一尺寸计算的一部分。

isCache() - Method in class javafx.scene. Node

获取属性缓存的值。

isCached() - Method in class javax.imageio.stream. FileCacheImageInputStream

返回 true因为此 ImageInputStream缓存数据以允许向后搜索。

isCached() - Method in class javax.imageio.stream. FileCacheImageOutputStream

返回 true因为此 ImageOutputStream缓存数据以允许向后搜索。

isCached() - Method in interface javax.imageio.stream. ImageInputStream

返回 true如果这个 ImageInputStream缓存数据本身以允许向后搜索。

isCached() - Method in class javax.imageio.stream. ImageInputStreamImpl

默认实现返回false。

isCached() - Method in class javax.imageio.stream. MemoryCacheImageInputStream

返回 true因为这 ImageInputStream缓存数据，以便向后 ImageInputStream 。

isCached() - Method in class javax.imageio.stream. MemoryCacheImageOutputStream

返回 true因为这 ImageOutputStream缓存数据，以便向后 ImageOutputStream 。

isCachedFile() - Method in class javax.imageio.stream. FileCacheImageInputStream

返回 true因为这个 ImageInputStream维护一个文件缓存。

isCachedFile() - Method in class javax.imageio.stream. FileCacheImageOutputStream

返回 true因为这个 ImageOutputStream维护一个文件缓存。

isCachedFile() - Method in interface javax.imageio.stream. ImageInputStream

返回 true如果这个 ImageInputStream缓存数据本身，以便允许向后搜索，缓存保存在一个临时文件中。

isCachedFile() - Method in class javax.imageio.stream. ImageInputStreamImpl

默认实现返回false。

isCachedFile() - Method in class javax.imageio.stream. MemoryCacheImageInputStream

返回 false因为这个 ImageInputStream没有维护一个文件缓存。

isCachedFile() - Method in class javax.imageio.stream. MemoryCacheImageOutputStream

返回 false因为这个 ImageOutputStream不保存文件缓存。

isCachedMemory() - Method in class javax.imageio.stream. FileCacheImageInputStream

返回 false因为这个 ImageInputStream没有维护主内存缓存。

isCachedMemory() - Method in class javax.imageio.stream. FileCacheImageOutputStream

返回 false因为这个 ImageOutputStream不维护主内存缓存。

isCachedMemory() - Method in interface javax.imageio.stream. ImageInputStream

返回 true如果这个 ImageInputStream缓存数据本身以便允许向后搜索，并且高速缓存保存在主内存中。

isCachedMemory() - Method in class javax.imageio.stream. ImageInputStreamImpl

默认实现返回false。

isCachedMemory() - Method in class javax.imageio.stream. MemoryCacheImageInputStream

返回 true因为该 ImageInputStream维护主内存缓存。

isCachedMemory() - Method in class javax.imageio.stream. MemoryCacheImageOutputStream

返回 true因为这个 ImageOutputStream维护一个主内存缓存。

isCacheShape() - Method in class javafx.scene.layout. Region

获取属性cacheShape的值。

isCallSiteUnstable() - Method in interface jdk.dynalink.linker. LinkRequest

如果调用站点被认为是不稳定的，那么返回true，也就是说，它已经重新链接多于 DynamicLinkerFactory.setUnstableRelinkThreshold(int)中指定的 时间 。

isCallSiteUnstable() - Method in class jdk.dynalink.linker.support. SimpleLinkRequest

isCancelButton() - Method in class javafx.scene.control. Button

获取属性cancelButton的值。

isCancelButton() - Method in enum javafx.scene.control. ButtonBar.ButtonData

指示从ButtonData枚举创建的按钮是否应该是用户界面中的“取消”按钮。

isCanceled() - Method in class javax.swing. ProgressMonitor

如果用户点击“取消”按钮或关闭进度对话框，则返回true。

isCancelled() - Method in class java.awt.print. PrinterJob

退货true如果打印作业正在进行，但将在下一次机会被取消; 否则返回false 。

isCancelled() - Method in class java.util.concurrent. CompletableFuture

如果此CompletableFuture在正常完成之前被取消，则返回 true 。

isCancelled() - Method in class java.util.concurrent. ForkJoinTask

isCancelled() - Method in interface java.util.concurrent. Future

如果此任务在正常完成之前已被取消，则返回 true 。

isCancelled() - Method in class java.util.concurrent. FutureTask

isCancelled() - Method in class javax.swing. SwingWorker

如果此任务在正常完成之前被取消，则返回 true 。

isCardPresent() - Method in class javax.smartcardio. CardTerminal

返回此终端中是否存在卡。

isCaretBias() - Method in class javafx.scene.text. Text

获取属性caretBias的值。

isCaseIgnored() - Method in interface javax.naming.directory. Attributes

确定属性集是否在检索或添加属性时忽略属性标识符的情况。

isCaseIgnored() - Method in class javax.naming.directory. BasicAttributes

isCaseSensitive(int) - Method in interface java.sql. ResultSetMetaData

指示列的大小写是否重要。

isCaseSensitive(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

指示指定列的名称是否重要。

isCatalogAtStart() - Method in interface java.sql. DatabaseMetaData

检索目录是否在完全限定的表名开始时显示。

isCData() - Method in interface javax.xml.stream.events. Characters

如果是CData部分，则返回true。

isCellEditable(int, int) - Method in class javax.swing. JTable

如果 row和 column的单元格是可编辑的，则返回true。

isCellEditable(int, int) - Method in class javax.swing.table. AbstractTableModel

返回false。

isCellEditable(int, int) - Method in class javax.swing.table. DefaultTableModel

无论参数值如何，都会返回true。

isCellEditable(int, int) - Method in interface javax.swing.table. TableModel

如果 rowIndex和 columnIndex的单元格是可编辑的，则返回true。

isCellEditable(EventObject) - Method in class javax.swing. AbstractCellEditor

返回true。

isCellEditable(EventObject) - Method in interface javax.swing. CellEditor

要求编辑器是否可以使用 anEvent开始编辑。

isCellEditable(EventObject) - Method in class javax.swing. DefaultCellEditor.EditorDelegate

如果返回true anEvent 不是 MouseEvent 。

isCellEditable(EventObject) - Method in class javax.swing. DefaultCellEditor

将消息从 CellEditor转发到 delegate 。

isCellEditable(EventObject) - Method in class javax.swing.tree. DefaultTreeCellEditor

如果 realEditor返回true，则返回 prepareForEditing ，并返回true。

isCellSelected(int, int) - Method in class javax.swing. JTable

如果指定的索引在行和列的有效范围内并且选定了指定位置的单元格，则返回true。

isCellSelectionEnabled() - Method in class javafx.scene.control. TableSelectionModel

获取属性cellSelectionEnabled的值。

isCenterShape() - Method in class javafx.scene.layout. Region

获取属性centerShape的值。

isCertificateEntry(String) - Method in class java.security. KeyStore

如果由给定别名标识的条目是通过调用 setCertificateEntry创建的，或者通过调用 setEntry （ TrustedCertificateEntry ）创建的条目，则返回true。

isCharacters() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是字符。

isCharacters() - Method in class javax.xml.stream.util. StreamReaderDelegate

isCharacters() - Method in interface javax.xml.stream. XMLStreamReader

如果光标指向字符数据事件，则返回true

isCharsetDetected() - Method in class java.nio.charset. CharsetDecoder

告知该解码器是否还检测到字符集 （可选操作） 。

isClass() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是否是 class （而不是界面或注释类型）？

isClass() - Method in enum javax.lang.model.element. ElementKind

如果这是一个类，返回 true ： CLASS或 ENUM 。

isClockwise() - Method in class javafx.scene.chart. PieChart

顺时针方向获取属性值。

isClosable() - Method in class javafx.scene.control. Tab

如果此选项卡是可关闭的，则返回 true 。

isClosable() - Method in class javax.swing. JInternalFrame

返回这个 JInternalFrame是否可以被某些用户操作关闭。

isClosed - Variable in class javax.swing. JInternalFrame

框架已关闭。

isClosed() - Method in class java.net. DatagramSocket

返回套接字是否关闭。

isClosed() - Method in class java.net. ServerSocket

返回ServerSocket的关闭状态。

isClosed() - Method in class java.net. Socket

返回套接字的关闭状态。

isClosed() - Method in interface java.sql. Connection

检索此 Connection对象是否已关闭。

isClosed() - Method in interface java.sql. ResultSet

检索此 ResultSet对象是否已关闭。

isClosed() - Method in interface java.sql. Statement

检索此 Statement对象是否已关闭。

isClosed() - Method in class java.util.concurrent. SubmissionPublisher

如果此发布商不接受提交，则返回true。

isClosed() - Method in class javax.swing. JInternalFrame

返回此 JInternalFrame当前是否关闭。

isClosed() - Method in interface jdk.incubator.http. WebSocket

告诉 WebSocket是否关闭。

isCloseOnCompletion() - Method in interface java.sql. Statement

返回一个值，指示当其所有相关结果集都关闭时，是否关闭此 Statement 。

isCoalesce() - Method in class javax.swing. Timer

如果 Timer合并了多个待处理的动作事件，则返回 true 。

isCoalescing() - Method in class javax.xml.parsers. DocumentBuilderFactory

指示工厂是否配置为生成将CDATA节点转换为文本节点并将其附加到相邻（如果有）文本节点）的解析器。

isCollapsed(int) - Method in class javax.swing. JTree

如果指定的显示行中的节点折叠，则返回true。

isCollapsed(TreePath) - Method in class javax.swing. JTree

如果path标识的值当前已折叠，则返回true，如果当前没有显示路径中的任何值，则返回false。

isCollapsible() - Method in class javafx.scene.control. TitledPane

返回TitlePane的可折叠状态。

isCollected() - Method in interface com.sun.jdi. ObjectReference

确定此对象是否已在目标虚拟机中进行垃圾回收。

isCollectionUsageThresholdExceeded() - Method in interface java.lang.management. MemoryPoolMXBean

测试Java虚拟机所耗费的最新集合之后的内存池的内存使用情况是否已达到或超过其集合使用率阈值。

isCollectionUsageThresholdSupported() - Method in interface java.lang.management. MemoryPoolMXBean

测试此内存池是否支持集合使用阈值。

isColorTransparencySelectionEnabled() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

获取颜色选择器面板是否允许选择颜色的透明度（alpha值）。

isColumnSelected(int) - Method in class javax.swing. JTable

如果指定的索引在列的有效范围内，并且该索引的列被选中，则返回true。

isCombining() - Method in class java.awt.font. GlyphMetrics

如果这是一个组合字形，则返回 true 。

isComboBoxEditable() - Method in class javafx.scene.control.cell. ComboBoxListCell

如果ComboBox是可编辑的，则返回true。

isComboBoxEditable() - Method in class javafx.scene.control.cell. ComboBoxTableCell

如果ComboBox是可编辑的，则返回true。

isComboBoxEditable() - Method in class javafx.scene.control.cell. ComboBoxTreeCell

如果ComboBox是可编辑的，则返回true。

isComboBoxEditable() - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

如果ComboBox是可编辑的，则返回true。

isComment() - Method in interface javax.xml.soap. Text

检索此 Text对象是否表示注释。

isCompatibleRaster(Raster) - Method in class java.awt.image. ColorModel

退货 true如果 raster是兼容这个 ColorModel和 false如果不是。

isCompatibleRaster(Raster) - Method in class java.awt.image. ComponentColorModel

如果raster与此ColorModel兼容，则返回true; 假如不是的话。

isCompatibleRaster(Raster) - Method in class java.awt.image. DirectColorModel

返回 true如果 raster是兼容这个 ColorModel和 false如果不是。

isCompatibleRaster(Raster) - Method in class java.awt.image. IndexColorModel

返回 true如果 raster与此兼容 ColorModel或者 false如果不是与此兼容 ColorModel 。

isCompatibleSampleModel(SampleModel) - Method in class java.awt.image. ColorModel

检查 SampleModel是否与此 ColorModel兼容。

isCompatibleSampleModel(SampleModel) - Method in class java.awt.image. ComponentColorModel

检查指定的 SampleModel是否与此 ColorModel兼容。

isCompatibleSampleModel(SampleModel) - Method in class java.awt.image. IndexColorModel

检查指定的 SampleModel是否与此 ColorModel兼容。

isCompatibleSampleModel(SampleModel) - Method in class java.awt.image. PackedColorModel

检查指定的 SampleModel是否与此 ColorModel兼容。

isCompatibleValue(Object) - Method in class java.awt. RenderingHints.Key

如果指定的对象是此Key的有效值，则返回true。

isCompatibleWith(String) - Method in class java.lang. 软件包

将该软件包的规格版本与所需版本进行比较。

isCompilationTimeMonitoringSupported() - Method in interface java.lang.management. CompilationMXBean

测试Java虚拟机是否支持对编译时间的监视。

isComplete() - Method in class com.sun.nio.sctp. MessageInfo

告知邮件是否完整。

isComplete() - Method in interface javax.security.sasl. SaslClient

确定认证交换是否已完成。

isComplete() - Method in interface javax.security.sasl. SaslServer

确定认证交换是否已完成。

isComplete() - Method in enum jdk.jshell. SourceCodeAnalysis.Completeness

指示第一个源代码片段是否完整。

isCompletedAbnormally() - Method in class java.util.concurrent. ForkJoinTask

如果此任务抛出异常或被取消，则返回 true 。

isCompletedExceptionally() - Method in class java.util.concurrent. CompletableFuture

如果此CompletableFuture以任何方式非常完成，则返回 true 。

isCompletedNormally() - Method in class java.util.concurrent. ForkJoinTask

如果此任务完成而不抛出异常并且未被取消，则返回 true 。

isCompletelyDirty(JComponent) - Method in class javax.swing. RepaintManager

如果 aComponent在下一个paintDirtyRegions（）中将被完全绘制，则返回true的方便方法。

isComponent() - Method in class java.awt.font. GlyphMetrics

如果这是一个组件字形，则返回 true 。

isComponentPartOfCurrentMenu(Component) - Method in class javax.swing. MenuSelectionManager

如果 c是当前使用的菜单的一部分，则返回true

isCompositionEnabled() - Method in class java.awt.im. InputContext

确定组合是否启用当前输入法。

isCompositionEnabled() - Method in interface java.awt.im.spi. InputMethod

确定是否启用此输入法。

isCompressionLossless() - Method in class javax.imageio. ImageWriteParam

如果当前压缩类型提供无损压缩，则返回 true 。

isCompressionLossless() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

返回 false因为JPEG插件仅支持有损压缩。

isComputed() - Method in interface jdk.nashorn.api.tree. PropertyTree

这是计算财产吗？

isComputerNode(File) - Method in class javax.swing.filechooser. FileSystemView

由UI类用于决定是否显示计算机节点的特殊图标，例如

isConfigured() - Method in class java.security. Provider

检查此提供程序实例是否已配置。

isConnectable() - Method in class java.nio.channels. SelectionKey

测试此密钥的通道是否已完成或未完成其套接字连接操作。

isConnected() - Method in class java.net. DatagramSocket

返回套接字的连接状态。

isConnected() - Method in class java.net. Socket

返回套接字的连接状态。

isConnected() - Method in class java.nio.channels. DatagramChannel

告诉这个通道的插座是否连接。

isConnected() - Method in class java.nio.channels. SocketChannel

告知本频道的网络插座是否连接。

isConnectionPending() - Method in class com.sun.nio.sctp. SctpChannel

告知此频道是否正在进行连接操作。

isConnectionPending() - Method in class java.nio.channels. SocketChannel

告知此频道是否正在进行连接操作。

isConst() - Method in interface jdk.nashorn.api.tree. VariableTree

这是一个const声明吗？

isConstrained() - Method in class java.beans. PropertyDescriptor

尝试更新“受限制”属性将导致在属性更改时触发“VetoableChange”事件。

isConstructor() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是否是构造函数？

isConstructor() - Method in interface com.sun.jdi. 方法

确定这个方法是否是一个构造函数。

isConsumed() - Method in class java.awt. AWTEvent

返回此事件是否已被使用。

isConsumed() - Method in class java.awt.event. InputEvent

返回此事件是否已被使用。

isConsumed() - Method in class java.awt.event. InputMethodEvent

返回此事件是否已被使用。

isConsumed() - Method in class javafx.event. Event

指示此 Event是否已被任何过滤器或处理程序使用。

isConsumer(ImageConsumer) - Method in class java.awt.image. FilteredImageSource

确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。

isConsumer(ImageConsumer) - Method in interface java.awt.image. ImageProducer

确定指定的 ImageConsumer对象当前是否已注册到此 ImageProducer作为其消费者之一。

isConsumer(ImageConsumer) - Method in class java.awt.image. MemoryImageSource

确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。

isConsumer(ImageConsumer) - Method in class java.awt.image.renderable. RenderableImageProducer

确定ImageConsumer是否位于当前对该图像的数据感兴趣的消费者列表中。

isContain() - Method in class javafx.scene.layout. BackgroundSize

如果为真，则缩放图像，同时将其固有长宽比（如果有的话）保持为最大尺寸，使其宽度和高度都可以适合背景定位区域。

isContainsLookups() - Method in class javafx.css. ParsedValue

如果值本身是ParsedValue或值序列，并且应该查找任何这些值，则会设置此标志。

isContentAreaFilled() - Method in class javax.swing. AbstractButton

获取 contentAreaFilled属性。

isContentChange() - Method in class javafx.scene.control. TextFormatter.Change

内容更改是任何添加，删除或替换更改。

isContextMenuEnabled() - Method in class javafx.scene.web. WebView

获取属性contextMenuEnabled的值。

isContextual() - Method in class java.awt.font. NumericShaper

返回一个 boolean指示此成形器是否在内容上形成。

isContinuousLayout() - Method in class javax.swing. JSplitPane

获取 continuousLayout属性。

isContinuousLayout() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

确定 JSplitPane是否设置为使用连续布局。

isControlDown() - Method in class java.awt.event. InputEvent

返回此修改器是否关闭此事件。

isControlDown() - Method in class javafx.scene.input. GestureEvent

指示此事件的“控制”修饰符是否关闭。

isControlDown() - Method in class javafx.scene.input. KeyEvent

返回此修改器是否关闭此事件。

isControlDown() - Method in class javafx.scene.input. MouseEvent

Control修饰符是否关闭此事件。

isControlDown() - Method in class javafx.scene.input. TouchEvent

Control修饰符是否关闭此事件。

isControlSupported(Control.Type) - Method in interface javax.sound.sampled. Line

指示线路是否支持指定类型的控制。

isConversionSupported(AudioFormat.Encoding, AudioFormat) - Static method in class javax.sound.sampled. AudioSystem

指示是否可以从具有指定格式的音频输入流获取指定编码的音频输入流。

isConversionSupported(AudioFormat.Encoding, AudioFormat) - Method in class javax.sound.sampled.spi. FormatConversionProvider

指示格式转换器是否支持从特定格式转换为特定编码。

isConversionSupported(AudioFormat, AudioFormat) - Static method in class javax.sound.sampled. AudioSystem

指示是否可以从另一指定格式的音频输入流获取指定格式的音频输入流。

isConversionSupported(AudioFormat, AudioFormat) - Method in class javax.sound.sampled.spi. FormatConversionProvider

指示格式转换器是否支持从另一种格式转换为一种特定格式。

isConvertibleWithoutLoss(Class<?>, Class<?>) - Static method in class jdk.dynalink.linker.support. TypeUtilities

确定类型是否可以转换为另一个而不会失去任何精度。

isCover() - Method in class javafx.scene.layout. BackgroundSize

如果为真，则缩放图像，同时将其固有长宽比（如果有的话）保留为最小尺寸，使其宽度和高度都可以完全覆盖背景定位区域。

isCritical() - Method in interface java.security.cert. Extension

获取扩展的临界值设置。

isCritical() - Method in interface java.security.cert. PolicyNode

返回最近处理的证书中的证书策略扩展的关键指标。

isCritical() - Method in class javax.naming.ldap. BasicControl

确定控制的关键性。

isCritical() - Method in interface javax.naming.ldap. Control

确定LDAP控件的关键性。

isCryptoAllowed(Key) - Method in class javax.crypto. ExemptionMechanism

返回此豁免机制是否已成功生成结果blob。

isCS_sRGB() - Method in class java.awt.color. ColorSpace

如果ColorSpace为CS_sRGB，则返回true。

isCurrency(int) - Method in interface java.sql. ResultSetMetaData

指示指定的列是现金值。

isCurrency(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

指示存储在指定列中的值是否为现金值。

isCurrent() - Method in class javax.security.auth.kerberos. KerberosTicket

确定这张票是否仍然是最新的。

isCurrent() - Method in interface javax.security.auth. Refreshable

确定这个 Object是否是最新的。

isCurrentServiceInvalidNow() - Method in class java.beans.beancontext. BeanContextServiceRevokedEvent

报告当前服务是否被强制撤销，在这种情况下，引用现在将无效并且不可用。

isCurrentThreadCpuTimeSupported() - Method in interface java.lang.management. ThreadMXBean

测试Java虚拟机是否支持当前线程的CPU时间测量。

isCursorSet() - Method in class java.awt. Component

返回是否已经为此组件显式设置了游标。

isCustomMarshaled(Class) - Method in interface javax.rmi.CORBA. ValueHandler

指示给定的类是执行自定义还是默认编组。

isCyclic() - Method in class java.awt. GradientPaint

如果梯度在两个颜色C1和C2之间重复循环，则返回 true 。

isDaemon() - Method in class java.lang.management. ThreadInfo

测试与此 ThreadInfo相关联的线程是否为 daemon thread 。

isDaemon() - Method in class java.lang. Thread

测试这个线程是否是守护线程。

isDaemon() - Method in class java.lang. ThreadGroup

测试此线程组是否是守护线程组。

isDataFlavorAvailable(DataFlavor) - Method in class java.awt.datatransfer. Clipboard

返回是否可以在指定的 DataFlavor提供此剪贴板的当前内容。

isDataFlavorSupported(DataFlavor) - Method in class java.awt.datatransfer. StringSelection

返回此 Transferable是否支持请求的风格。

isDataFlavorSupported(DataFlavor) - Method in interface java.awt.datatransfer. Transferable

返回此对象是否支持指定的数据flavor。

isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd. DropTargetContext

此方法返回一个 boolean表示该 DataFlavor是否支持给定的 DropTargetContext 。

isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd. DropTargetContext.TransferableProxy

返回指定的数据风格是否被封装的可转移支持。

isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd. DropTargetDragEvent

此方法返回一个 boolean表示是否支持指定的 DataFlavor 。

isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd. DropTargetDropEvent

此方法返回一个 boolean指示是否可以从源中指定 DataFlavor 。

isDataFlavorSupported(DataFlavor) - Method in class javax.activation. DataHandler

返回此对象是否支持指定的数据flavor。

isDataFlavorSupported(DataFlavor) - Method in class javax.swing. TransferHandler.TransferSupport

返回是否支持给定的数据风格。

isDataTypeOK(int) - Method in class javax.imageio.plugins.tiff. TIFFTag

如果给定的数据类型可以用于与此标签关联的数据，则返回 true 。

isDateBased() - Method in enum java.time.temporal. ChronoField

检查此字段是否表示日期的组件。

isDateBased() - Method in enum java.time.temporal. ChronoUnit

检查本机是否是日期单位。

isDateBased() - Method in interface java.time.temporal. TemporalField

检查此字段是否表示日期的组件。

isDateBased() - Method in interface java.time.temporal. TemporalUnit

检查本机是否代表日期的组成部分。

isDaylightSavings(Instant) - Method in class java.time.zone. ZoneRules

检查指定的时间是否是夏令时。

isDecimalSeparatorAlwaysShown() - Method in class java.text. DecimalFormat

允许您使用整数获取小数分隔符的行为。

isDeclared() - Method in enum javax.lang.model.util. Elements.Origin

对于隐式或明确声明的结构对应的值，返回 true ，否则为 false 。

isDeclared(int) - Method in interface org.xml.sax.ext. Attributes2

返回false，除非属性在DTD中声明。

isDeclared(int) - Method in class org.xml.sax.ext. Attributes2Impl

返回属性的“声明”标志的当前值。

isDeclared(String) - Method in interface org.xml.sax.ext. Attributes2

返回false，除非属性在DTD中声明。

isDeclared(String) - Method in class org.xml.sax.ext. Attributes2Impl

返回属性的“声明”标志的当前值。

isDeclared(String, String) - Method in interface org.xml.sax.ext. Attributes2

返回false，除非属性在DTD中声明。

isDeclared(String, String) - Method in class org.xml.sax.ext. Attributes2Impl

返回属性的“声明”标志的当前值。

isDefault() - Method in interface com.sun.javadoc. MethodDoc

已过时。

如果此方法为默认值，则返回true

isDefault() - Method in interface com.sun.jdi. 方法

确定此方法是否为默认方法

isDefault() - Method in class java.lang.reflect. 方法

如果此方法是默认方法，则返回true ; 否则返回false 。

isDefault() - Method in interface javax.lang.model.element. ExecutableElement

返回 true如果此方法是默认的方法，并返回 false否则。

isDefault() - Method in interface jdk.nashorn.api.tree. IdentifierTree

这是在模块导出条目中使用的“默认”

isDefaultButton() - Method in class javafx.scene.control. Button

获取属性defaultButton的值。

isDefaultButton() - Method in enum javafx.scene.control. ButtonBar.ButtonData

指示从ButtonData枚举创建的按钮是否应该是用户界面中的“默认”按钮。

isDefaultButton() - Method in class javax.swing. JButton

获取 defaultButton属性的值，如果 true意味着此按钮是其 JRootPane的当前默认按钮。

isDefaultCapable() - Method in class javax.swing. JButton

获取 defaultCapable属性的值。

isDefaultLookAndFeelDecorated() - Static method in class javax.swing. JDialog

如果新创建的 JDialog应该具有当前的外观所提供的窗口装饰，则返回true。

isDefaultLookAndFeelDecorated() - Static method in class javax.swing. JFrame

如果新创建的 JFrame应该具有当前的外观提供的窗口装饰，则返回true。

isDefaultNamespace(String) - Method in class javax.imageio.metadata. IIOMetadataNode

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

isDefaultNamespace(String) - Method in interface org.w3c.dom. Node

此方法检查指定的 namespaceURI是否为默认命名空间。

isDefaultNamespaceDeclaration() - Method in interface javax.xml.stream.events. Namespace

如果此属性声明默认命名空间，则返回true

isDefined() - Method in enum jdk.jshell. Snippet.Status

指示该片段是否是JShell的已定义状态的一部分。

isDefined(char) - Static method in class java.lang. Character

确定字符是否以Unicode定义。

isDefined(int) - Static method in class java.lang. Character

确定Unicode中是否定义了一个字符（Unicode代码点）。

isDefined(Object) - Method in class javax.swing.text. AbstractDocument.AbstractElement

检查给定属性是否被定义。

isDefined(Object) - Method in interface javax.swing.text. AttributeSet

检查命名属性是否具有在集合中指定的值，而不通过另一个属性集进行解析。

isDefined(Object) - Method in class javax.swing.text. SimpleAttributeSet

告诉是否定义了一个给定的属性。

isDefined(Object) - Method in class javax.swing.text. StyleContext.NamedStyle

检查给定属性是否被定义。

isDefined(Object) - Method in class javax.swing.text. StyleContext.SmallAttributeSet

检查给定属性是否被定义。

isDefinitelyWritable(int) - Method in interface java.sql. ResultSetMetaData

指示指定列上的写入是否会成功。

isDefinitelyWritable(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

指示指定列上的写操作是否一定会成功。

isDelegated() - Method in class java.beans.beancontext. BeanContextChildSupport

报告这个班级是否是另一个班级的代表。

isDeleted() - Method in class javafx.scene.control. TextFormatter.Change

获取此更改是否正在删除文本。

isDeprecated(Element) - Method in interface javax.lang.model.util. Elements

返回 true如果元素已过时， false否则。

isDepthBuffer() - Method in class javafx.scene. Scene

检索此场景的深度缓冲区属性。

isDepthBuffer() - Method in class javafx.scene. SnapshotParameters

获取当前的depthBuffer标志。

isDepthBuffer() - Method in class javafx.scene. SubScene

检索此 SubScene的深度缓冲区属性。

isDerivedFrom(String, String, int) - Method in interface org.w3c.dom. TypeInfo

如果引用类型定义之间有一个派生，即 TypeInfo该方法的 TypeInfo和另一个类型定义（即作为参数传递的定义）之间的派生，则返回此方法。

isDescendant(TreePath) - Method in class javax.swing.tree. TreePath

如果 aTreePath是这个 TreePath的后代，则返回true。

isDescendingFrom(Component, Component) - Static method in class javax.swing. SwingUtilities

返回 true如果组件 a从组件下降 b

isDesignTime() - Method in class java.beans.beancontext. BeanContextSupport

报告此对象是否在当前处于设计时模式。

isDesignTime() - Static method in class java.beans. Beans

测试我们是否处于设计模式。

isDesignTime() - Method in interface java.beans. DesignMode

值为true表示JavaBeans应该在设计时模式下运行，值为false表示运行时行为。

isDesktopSupported() - Static method in class java.awt. Desktop

测试此类是否在当前平台上得到支持。

isDestroyed() - Method in class java.lang. ThreadGroup

测试此线程组是否已被破坏。

isDestroyed() - Method in class java.security. KeyStore.PasswordProtection

确定密码是否已被清除。

isDestroyed() - Method in interface javax.security.auth. Destroyable

确定这 Object是否已被销毁。

isDestroyed() - Method in class javax.security.auth.kerberos. EncryptionKey

isDestroyed() - Method in class javax.security.auth.kerberos. KerberosCredMessage

isDestroyed() - Method in class javax.security.auth.kerberos. KerberosKey

确定此密钥是否已被销毁。

isDestroyed() - Method in class javax.security.auth.kerberos. KerberosTicket

确定这张票是否已被销毁。

isDestroyed() - Method in class javax.security.auth.x500. X500PrivateCredential

确定对此对象中X.509证书和私钥的引用是否已被清除。

isDeviceSupported(MidiDevice.Info) - Method in class javax.sound.midi.spi. MidiDeviceProvider

指示设备提供商是否支持由指定的设备信息对象表示的设备。

isDigit(char) - Static method in class java.lang. Character

确定指定的字符是否是数字。

isDigit(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是否为数字。

isDigitKey() - Method in enum javafx.scene.input. KeyCode

所有数字键（包括键盘数字）

isDirect() - Method in class java.nio. Buffer

告诉这个缓冲区是否是 direct 。

isDirect() - Method in class java.nio. ByteBuffer

告诉这个字节缓冲区是否是直接的。

isDirect() - Method in class java.nio. CharBuffer

告诉这个char缓冲区是否直接。

isDirect() - Method in class java.nio. DoubleBuffer

告诉这个双缓冲区是否直接。

isDirect() - Method in class java.nio. FloatBuffer

告诉这个浮动缓冲区是否直接。

isDirect() - Method in class java.nio. IntBuffer

告诉这个int缓冲区是否直接。

isDirect() - Method in class java.nio. LongBuffer

告诉这个长缓冲区是否直接。

isDirect() - Method in class java.nio. ShortBuffer

告诉这个短缓冲区是否直接。

isDirect() - Method in class javafx.scene.input. GestureEvent

指示此手势是由直接或间接输入设备引起的。

isDirectory() - Method in class java.io. File

测试此抽象路径名表示的文件是否为目录。

isDirectory() - Method in interface java.nio.file.attribute. BasicFileAttributes

告诉文件是否是目录。

isDirectory() - Method in class java.util.zip. ZipEntry

如果这是目录条目，则返回true。

isDirectory(Path, LinkOption...) - Static method in class java.nio.file. Files

测试文件是否是目录。

isDirectorySelected() - Method in class javax.swing.plaf.basic. BasicFileChooserUI

要记住当前是否在UI中选择了一个目录的属性。

isDirectorySelectionEnabled() - Method in class javax.swing. JFileChooser

方便电话确定目录是否可以根据当前的文件选择模式进行选择。

isDisable() - Method in class javafx.scene.control. MenuItem

获取属性禁用的值。

isDisable() - Method in class javafx.scene.control. Tab

如果此选项卡 true禁用 true则返回 true 。

isDisable() - Method in class javafx.scene. Node

获取属性禁用的值。

isDisabled() - Method in class javafx.scene.control. Tab

当 Tab disable设置为 true或者如果 TabPane被禁用，则返回true。

isDisabled() - Method in class javafx.scene. Node

获取禁用的属性的值。

isDispatched() - Method in class java.awt.event. InvocationEvent

返回 true如果事件被分派或者在发送任何异常被抛出， false否则。

isDispatchThread() - Static method in class java.awt. EventQueue

如果调用线程是 the current AWT EventQueue的分派线程，则返回true。

isDisplayable() - Method in class java.awt. Component

确定此组件是否可显示。

isDisplayChangeSupported() - Method in class java.awt. GraphicsDevice

如果 GraphicsDevice支持低级显示更改，则返回 true 。

isDisposed() - Method in class javax.print. StreamPrintService

返回一个 boolean表示该 StreamPrintService是否已被处理。

isDocFlavorSupported(DocFlavor) - Method in interface javax.print. PrintService

确定此打印服务是否支持特定的 DocFlavor 。

isDomainPattern() - Method in class javax.management. ObjectName

检查对象名称是否是域部件上的模式。

isDone() - Method in class java.awt.geom. FlatteningPathIterator

测试迭代是否完成。

isDone() - Method in interface java.awt.geom. PathIterator

测试迭代是否完成。

isDone() - Method in class java.util.concurrent. CompletableFuture

退货 true如果以任何方式完成：通常，特别地，或通过取消。

isDone() - Method in class java.util.concurrent. ForkJoinTask

isDone() - Method in interface java.util.concurrent. Future

如果此任务完成，则返回 true 。

isDone() - Method in class java.util.concurrent. FutureTask

isDone() - Method in class javax.swing. SwingWorker

如果此任务完成，则返回 true 。

isDoubleBuffered() - Method in class java.awt. Component

如果此组件被绘制到稍后复制到屏幕的屏幕外图像（“缓冲区”），则返回true。

isDoubleBuffered() - Method in class javax.swing. JComponent

返回此组件是否应该使用缓冲区来绘制。

isDoubleBufferingEnabled() - Method in class javax.swing. RepaintManager

如果此RepaintManager是双缓冲的，则返回true。

isDragDetect() - Method in class javafx.scene.input. MouseEvent

确定此事件是否会后跟 DRAG_DETECTED事件。

isDragging - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

拖延

isDragging - Variable in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener

true如果 JToolBar被拖动。

isDragging() - Method in class javax.swing.plaf.basic. BasicSliderUI

如果用户拖动滑块，则返回true。

isDragImageSupported() - Static method in class java.awt.dnd. DragSource

报告是否在基础平台上提供拖动 Image支持。

isDrawingBuffer() - Method in class javax.swing. DebugGraphics

返回drawingBuffer值。

isDrive(File) - Method in class javax.swing.filechooser. FileSystemView

由UI类用于决定是否显示驱动器或分区的特殊图标，例如“硬盘”图标。

isDrop() - Method in class javax.swing. TransferHandler.TransferSupport

返回此 TransferSupport是否代表放置操作。

isDropCompleted() - Method in class javafx.scene.input. DragEvent

是否 setDropCompleted(true)已被呼吁这个事件。

isDropLine(JTree.DropLocation) - Method in class javax.swing.plaf.basic. BasicTreeUI

告诉一个 DropLocation是否应该由节点之间的一条线指示。

isDuplicateToken() - Method in class org.ietf.jgss. MessageProp

测试这是否与较早的令牌重复。

isDurationEstimated() - Method in enum java.time.temporal. ChronoUnit

检查单位的持续时间是否是估计。

isDurationEstimated() - Method in interface java.time.temporal. TemporalUnit

检查单位的持续时间是否是估计。

isDynamic() - Method in interface java.awt.image.renderable. ContextualRenderedImageFactory

如果使用相同参数的连续渲染（即，调用create（RenderContext，ParameterBlock）））可能会产生不同的结果，则返回true。

isDynamic() - Method in interface java.awt.image.renderable. RenderableImage

如果连续的渲染（即对createRendering（）或createScaledRendering（））的调用具有相同的参数，则返回true可能会产生不同的结果。

isDynamic() - Method in class java.awt.image.renderable. RenderableImageOp

如果连续的渲染（即对createRendering（）或createScaledRendering（））的调用具有相同的参数，则返回true可能会产生不同的结果。

isDynamicConstructor(Object) - Static method in class jdk.dynalink.beans. BeansLinker

如果对象是Java构造函数（通过 BeansLinker.getConstructorMethod(Class, String)获得），则返回true。

isDynamicLayoutActive() - Method in class java.awt. Toolkit

返回是否在底层操作系统和/或窗口管理器上启用了容器在resize上的动态布局。

isDynamicLayoutSet() - Method in class java.awt. Toolkit

返回容器的布局在调整大小期间是否动态进行验证，或者在调整大小之后静态地验证。

isDynamicMethod(Object) - Static method in class jdk.dynalink.beans. BeansLinker

如果对象是Java动态方法（例如，通过Java对象上的GET:METHOD操作或StaticClass或通过BeansLinker.getConstructorMethod(Class, String)获取的对象），则返回true。

isEchoOn() - Method in class javax.security.auth.callback. PasswordCallback

返回密码是否应该正在键入时显示。

isEditable - Variable in class javax.swing. JComboBox

此保护字段是实现特定的。

isEditable() - Method in class java.awt. TextComponent

指示此文本组件是否可编辑。

isEditable() - Method in class javafx.scene.control. Cell

返回此单元格是否被允许进入编辑状态。

isEditable() - Method in class javafx.scene.control. ComboBoxBase

获取可编辑属性的值。

isEditable() - Method in class javafx.scene.control. ListView

获取可编辑属性的值。

isEditable() - Method in class javafx.scene.control. Spinner

获取可编辑属性的值。

isEditable() - Method in class javafx.scene.control. TableColumnBase

获取可编辑属性的值。

isEditable() - Method in class javafx.scene.control. TableView

获取可编辑属性的值。

isEditable() - Method in class javafx.scene.control. TextInputControl

获取可编辑属性的值。

isEditable() - Method in class javafx.scene.control. TreeTableView

获取可编辑属性的值。

isEditable() - Method in class javafx.scene.control. TreeView

获取可编辑属性的值。

isEditable() - Method in class javax.swing. JComboBox

如果 JComboBox可编辑，则返回true。

isEditable() - Method in class javax.swing. JTree

如果树可编辑，则返回true。

isEditable() - Method in class javax.swing.plaf.basic. BasicTreeUI

如果树是可编辑的，则返回 true 。

isEditable() - Method in class javax.swing.text. JTextComponent

返回指示此 TextComponent是否可编辑的布尔值。

isEditing() - Method in class javafx.scene.control. Cell

表示单元格当前是否处于编辑状态。

isEditing() - Method in class javax.swing. JTable

如果正在编辑单元格，则返回true。

isEditing() - Method in class javax.swing. JTree

如果正在编辑树，则返回true。

isEditing(JTree) - Method in class javax.swing.plaf.basic. BasicTreeUI

如果正在编辑树，则返回true。

isEditing(JTree) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 isEditing方法。

isEditing(JTree) - Method in class javax.swing.plaf. TreeUI

如果正在编辑树，则返回true。

isEditValid() - Method in class javax.swing. JFormattedTextField

如果正在编辑的当前值有效，则返回true。

isElement(Object) - Method in class javax.xml.bind. JAXBIntrospector

如果 object表示JAXB元素，则返回true。

isElementContentWhitespace() - Method in interface org.w3c.dom. Text

返回此文本节点是否包含 element content whitespace ，经常被称为“可忽略的空白”。

isEmpty() - Method in class com.sun.net.httpserver. Headers

isEmpty() - Method in class java.awt.geom. Arc2D.Double

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. Arc2D.Float

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. Area

测试此 Area对象是否包围任何区域。

isEmpty() - Method in class java.awt.geom. Ellipse2D.Double

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. Ellipse2D.Float

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. Rectangle2D.Double

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. Rectangle2D.Float

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. RectangularShape

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. RoundRectangle2D.Double

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt.geom. RoundRectangle2D.Float

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt. Rectangle

确定 RectangularShape是否为空。

isEmpty() - Method in class java.awt. RenderingHints

如果此 RenderingHints包含键值映射，则返回 true 。

isEmpty() - Method in class java.beans.beancontext. BeanContextSupport

报告此 BeanContext是否为空。

isEmpty() - Method in class java.lang. String

返回 true如果，且仅当 String.length()为 0 。

isEmpty() - Method in class java.util. AbstractCollection

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util. AbstractMap

如果此地图不包含键值映射，则返回 true 。

isEmpty() - Method in class java.util. ArrayDeque

如果此deque不包含元素，则返回 true 。

isEmpty() - Method in class java.util. ArrayList

如果此列表不包含元素，则返回 true 。

isEmpty() - Method in class java.util. BitSet

如果此 BitSet包含设置为 true位，则返回true。

isEmpty() - Method in interface java.util. Collection

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util.concurrent. ConcurrentHashMap

如果此映射不包含键值映射，则返回 true 。

isEmpty() - Method in class java.util.concurrent. ConcurrentLinkedDeque

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util.concurrent. ConcurrentLinkedQueue

如果此队列不包含元素，则返回 true 。

isEmpty() - Method in class java.util.concurrent. ConcurrentSkipListMap

如果此地图不包含键值映射，则返回 true 。

isEmpty() - Method in class java.util.concurrent. ConcurrentSkipListSet

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util.concurrent. CopyOnWriteArrayList

如果此列表不包含元素，则返回 true 。

isEmpty() - Method in class java.util.concurrent. CopyOnWriteArraySet

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util.concurrent. LinkedTransferQueue

如果此队列不包含元素，则返回 true 。

isEmpty() - Method in class java.util.concurrent. SynchronousQueue

始终返回 true 。

isEmpty() - Method in class java.util. Dictionary

测试这个字典是否将键值映射到值。

isEmpty() - Method in class java.util. HashMap

如果此地图不包含键值映射，则返回 true 。

isEmpty() - Method in class java.util. HashSet

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util. Hashtable

测试这个哈希表是否将值映射到值。

isEmpty() - Method in class java.util. IdentityHashMap

如果此标识哈希映射不包含键值映射，则返回 true 。

isEmpty() - Method in class java.util.jar. Attributes

如果此Map不包含属性，则返回true。

isEmpty() - Method in interface java.util. List

如果此列表不包含元素，则返回 true 。

isEmpty() - Method in interface java.util. Map

如果此地图不包含键值映射，则返回 true 。

isEmpty() - Method in class java.util. Properties

isEmpty() - Method in interface java.util. Set

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util. TreeSet

如果此集合不包含元素，则返回 true 。

isEmpty() - Method in class java.util. Vector

测试此矢量是否没有组件。

isEmpty() - Method in class java.util. WeakHashMap

如果此映射不包含键值映射，则返回 true 。

isEmpty() - Method in class javafx.beans.binding. ListExpression

获取属性的值为空。

isEmpty() - Method in class javafx.beans.binding. MapExpression

获取属性的值为空。

isEmpty() - Method in class javafx.beans.binding. SetExpression

获取属性的值为空。

isEmpty() - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个StringExpression是空的，则保留true 。

isEmpty() - Method in class javafx.geometry. BoundingBox

指示此边界的任何尺寸（宽度，高度或深度）是否小于零。

isEmpty() - Method in class javafx.geometry. Bounds

指示此边界的任何尺寸（宽度，高度或深度）是否小于零。

isEmpty() - Method in class javafx.scene.control. Cell

返回一个布尔值，表示单元格是否被认为是空的。

isEmpty() - Method in class javafx.scene.control. SelectionModel

该方法可用于测试是否有任何选定的索引/项目。

isEmpty() - Method in class javafx.scene.control. SingleSelectionModel

该方法可用于测试是否有任何选定的索引/项目。

isEmpty() - Method in class javafx.scene.layout. Background

获取背景是否为空。

isEmpty() - Method in class javafx.scene.layout. Border

获取边框是否为空。

isEmpty() - Method in class javax.activation. MimeTypeParameterList

确定此列表是否为空。

isEmpty() - Method in interface javax.management.openmbean. TabularData

如果此 TabularData实例中包含的值为 CompositeData （即行数） true则返回 true 。

isEmpty() - Method in class javax.management.openmbean. TabularDataSupport

如果此 TabularDataSupport实例不包含任何行，则返回 true 。

isEmpty() - Method in class javax.management.timer. Timer

测试定时器通知的列表是否为空。

isEmpty() - Method in interface javax.management.timer. TimerMBean

测试定时器通知的列表是否为空。

isEmpty() - Method in class javax.naming. CompositeName

确定此复合名称是否为空。

isEmpty() - Method in class javax.naming. CompoundName

确定此化合物名称是否为空。

isEmpty() - Method in class javax.naming.ldap. LdapName

确定此LDAP名称是否为空。

isEmpty() - Method in interface javax.naming. Name

确定此名称是否为空。

isEmpty() - Method in interface javax.print.attribute. AttributeSet

如果此属性集不包含属性，则返回true。

isEmpty() - Method in class javax.print.attribute. HashAttributeSet

如果此属性集不包含属性，则返回true。

isEmpty() - Method in class javax.script. SimpleBindings

如果此地图不包含键值映射，则返回 true 。

isEmpty() - Method in class javax.swing. DefaultListModel

测试此列表是否包含任何组件。

isEmpty() - Method in class javax.swing.text.html.parser. Element

检查是否空

isEmpty() - Method in class javax.swing.text. SimpleAttributeSet

检查属性集是否为空。

isEmpty() - Method in class javax.xml.transform.dom. DOMSource

指示 DOMSource对象是否为空。

isEmpty() - Method in class javax.xml.transform.sax. SAXSource

指示 SAXSource对象是否为空。

isEmpty() - Method in interface javax.xml.transform. Source

指示 Source对象是否为空。

isEmpty() - Method in class javax.xml.transform.stax. StAXSource

指示 StAXSource对象是否为空。

isEmpty() - Method in class javax.xml.transform.stream. StreamSource

指示 StreamSource对象是否为空。

isEmpty() - Method in class jdk.incubator.http. MultiMapResult

isEmpty() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

isEmpty() - Method in class org.xml.sax. InputSource

指示 InputSource对象是否为空。

isEmpty(ObservableStringValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果ObservableStringValue的值为空，则保留true 。

isEmpty(ObservableList<E>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果给定的ObservableList为空，则保留true 。

isEmpty(ObservableMap<K, V>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果给定的ObservableMap为空，则保留true 。

isEmpty(ObservableSet<E>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果给定的ObservableSet为空，则保留true 。

isEnabled() - Method in class com.sun.java.accessibility.util. Translator

确定对象是否已启用。

isEnabled() - Method in interface com.sun.jdi.request. EventRequest

确定此事件请求当前是否已启用。

isEnabled() - Method in class java.awt. Component.AccessibleAWTComponent

确定对象是否已启用。

isEnabled() - Method in class java.awt. Component

确定是否启用此组件。

isEnabled() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

确定对象是否已启用。

isEnabled() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

确定对象是否已启用。

isEnabled() - Method in class java.awt. MenuItem

检查此菜单项是否启用。

isEnabled() - Method in class javafx.scene.media. AudioEqualizer

获取启用属性的值。

isEnabled() - Method in interface javax.accessibility. AccessibleComponent

确定对象是否已启用。

isEnabled() - Method in class javax.swing. AbstractAction

如果启用该操作，则返回true。

isEnabled() - Method in interface javax.swing. Action

返回启用状态的 Action 。

isEnabled() - Method in interface javax.swing. ButtonModel

指示按钮是否可以由输入设备（如鼠标指针）选择或触发。

isEnabled() - Method in class javax.swing. DefaultButtonModel

指示按钮是否可以由输入设备（如鼠标指针）选择或触发。

isEnabled() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

isEnabled() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

确定对象是否已启用。

isEnabled() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

isEnabled() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.CloseAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.MaximizeAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.MinimizeAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.NavigateAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI.OpenAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicSliderUI.ActionScroller

如果启用该操作，则返回true。

isEnabled() - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeCancelEditingAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeHomeAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeIncrementAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicTreeUI.TreePageAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeToggleAction

isEnabled() - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeTraverseAction

isEnabled() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

isEnabled() - Method in class javax.swing. ToolTipManager

如果启用此对象，则返回true。

isEnabled() - Method in class javax.xml.ws. WebServiceFeature

如果启用此功能，则返回 true 。

isEnabledAt(int) - Method in class javax.swing. JTabbedPane

返回当前是否启用了 index的选项卡。

isEndDocument() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是一个EndDocument。

isEndElement() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是EndElement。

isEndElement() - Method in class javax.xml.stream.util. StreamReaderDelegate

isEndElement() - Method in interface javax.xml.stream. XMLStreamReader

如果光标指向结束标记（否则为false），则返回true

isEnqueued() - Method in class java.lang.ref. Reference

通过程序或垃圾收集器来告知这个引用对象是否已经入队。

isEntityReference() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是一个EntityReference。

isEnum() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是枚举类型吗？

isEnum() - Method in interface com.sun.jdi. ClassType

确定这个类是否被声明为一个枚举。

isEnum() - Method in class java.lang. Class

当且仅当该类在源代码中被声明为枚举时才返回true。

isEnumConstant() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是否是一个常量？

isEnumConstant() - Method in interface com.sun.jdi. Field

确定这是否是一个表示枚举常数的字段。

isEnumConstant() - Method in class java.lang.reflect. Field

如果此字段表示枚举类型的元素，则返回true ; 否则返回false 。

isEqual(byte[], byte[]) - Static method in class java.security. MessageDigest

比较两个平等的消息。

isEqual(Object) - Static method in interface java.util.function. Predicate

返回一个谓词，根据 Objects.equals(Object, Object)测试两个参数是否相等。

isEqual(ChronoLocalDate) - Method in interface java.time.chrono. ChronoLocalDate

检查这个日期是否等于忽略年表的指定日期。

isEqual(ChronoLocalDate) - Method in class java.time. LocalDate

检查此日期是否等于指定的日期。

isEqual(ChronoLocalDateTime<?>) - Method in interface java.time.chrono. ChronoLocalDateTime

检查这个日期时间是否等于指定的日期时间，忽略年表。

isEqual(ChronoLocalDateTime<?>) - Method in class java.time. LocalDateTime

检查此日期时间是否等于指定的日期时间。

isEqual(ChronoZonedDateTime<?>) - Method in interface java.time.chrono. ChronoZonedDateTime

检查此日期时间的时间是否等于指定的日期时间。

isEqual(OffsetDateTime) - Method in class java.time. OffsetDateTime

检查此日期时间的时间是否等于指定的日期时间。

isEqual(OffsetTime) - Method in class java.time. OffsetTime

检查这个 OffsetTime是否等于同时应用到公共日期的时间。

isEqual(AttributeSet) - Method in class javax.swing.text. AbstractDocument.AbstractElement

检查两个属性集是否相等。

isEqual(AttributeSet) - Method in interface javax.swing.text. AttributeSet

确定两个属性集是否相等。

isEqual(AttributeSet) - Method in class javax.swing.text. SimpleAttributeSet

比较两个属性集。

isEqual(AttributeSet) - Method in class javax.swing.text. StyleContext.NamedStyle

检查两个属性集是否相等。

isEqual(AttributeSet) - Method in class javax.swing.text. StyleContext.SmallAttributeSet

检查两个属性集是否相等。

isEqualNode(Node) - Method in class javax.imageio.metadata. IIOMetadataNode

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

isEqualNode(Node) - Method in interface org.w3c.dom. Node

测试两个节点是否相等。

isEqualTo(double, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果该NumberExpression等于一个常数值（具有公差），则保留true 。

isEqualTo(double, double) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(float, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值（具有公差），则保留true 。

isEqualTo(float, double) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(int) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。

isEqualTo(int) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(int, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数值（具有公差），则保留true 。

isEqualTo(int, double) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(long) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression等于一个恒定值，则保留true 。

isEqualTo(long) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(long, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression等于一个常数（容差），则保留true 。

isEqualTo(long, double) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(Object) - Method in class javafx.beans.binding. ObjectExpression

创建一个新的 BooleanExpression ，其持有 true如果该 ObjectExpression等于常数值。

isEqualTo(String) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个StringExpression等于一个恒定值，它将保留true 。

isEqualTo(ObservableBooleanValue) - Method in class javafx.beans.binding. BooleanExpression

创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。

isEqualTo(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等，则保留true 。

isEqualTo(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(ObservableNumberValue, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue相等（具有公差），则保持true 。

isEqualTo(ObservableNumberValue, double) - Method in class javafx.beans.binding. NumberExpressionBase

isEqualTo(ObservableObjectValue<?>) - Method in class javafx.beans.binding. ObjectExpression

创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue是相等的，则保留true 。

isEqualTo(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue相等，则保留true 。

isEqualTo(ObservableList<?>) - Method in class javafx.beans.binding. ListExpression

创建一个新的BooleanBinding持有true如果此列表等于另一个ObservableList 。

isEqualTo(ObservableMap<?, ?>) - Method in class javafx.beans.binding. MapExpression

创建一个新的BooleanBinding持有true如果此映射等于另一个ObservableMap 。

isEqualTo(ObservableSet<?>) - Method in class javafx.beans.binding. SetExpression

创建一个新的BooleanBinding持有true如果此集合等于另一个ObservableSet 。

isEqualToIgnoreCase(String) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，其持有true如果这个StringExpression等于恒定值忽略大小写。

isEqualToIgnoreCase(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue是相等的忽略大小写，则保留true 。

isError() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是错误类吗？

isError() - Method in class java.nio.charset. CoderResult

告知该对象是否描述错误状况。

isError() - Method in class javafx.scene.image. Image

获取属性错误的值。

isError() - Method in class jdk.jshell. Diag

指示此诊断是否是错误（与警告或注释相反）。

isErrorAny() - Method in class java.awt. MediaTracker

检查所有图像的错误状态。

isErrorID(int) - Method in class java.awt. MediaTracker

检查具有指定标识符的此媒体跟踪器跟踪的所有图像的错误状态。

isEstablished() - Method in interface org.ietf.jgss. GSSContext

在上下文建立期间使用以确定上下文的状态。

isEventDispatchThread() - Static method in class javax.swing. SwingUtilities

如果当前线程是AWT事件调度线程，则返回true。

isException() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是异常类吗？

isExecutable() - Method in enum jdk.jshell. Snippet.SubKind

指示这个 SubKind是否可执行。

isExecutable(Path) - Static method in class java.nio.file. Files

测试文件是否可执行。

isExpanded() - Method in class javafx.scene.control. DialogPane

返回是否扩展了dialogPane。

isExpanded() - Method in class javafx.scene.control. TitledPane

获取扩展的属性的值。

isExpanded() - Method in class javafx.scene.control. TreeItem

返回此TreeItem的展开状态。

isExpanded(int) - Method in class javax.swing. JTree

如果指定的显示行中的节点当前被展开，则返回true。

isExpanded(TreePath) - Method in class javax.swing. JTree

如果路径标识的节点当前被展开，则返回true，

isExpanded(TreePath) - Method in class javax.swing.tree. AbstractLayoutCache

如果当前标识的值目前已被扩展，则返回true。

isExpanded(TreePath) - Method in class javax.swing.tree. FixedHeightLayoutCache

如果当前标识的值目前已被扩展，则返回true。

isExpanded(TreePath) - Method in class javax.swing.tree. VariableHeightLayoutCache

如果当前扩展了 path标识的值，则返回true。

isExpandEntityReferences() - Method in class javax.xml.parsers. DocumentBuilderFactory

指示工厂是否配置为生成扩展实体引用节点的解析器。

isExpert() - Method in class java.beans. FeatureDescriptor

“专家”标志用于区分专门用于专家用户的那些功能，用于普通用户。

isExplicitPolicyRequired() - Method in class java.security.cert. PKIXParameters

检查是否需要明确的策略。

isExported(String) - Method in class java.lang. Module

如果此模块无条件导出给定的包，则返回 true 。

isExported(String, Module) - Method in class java.lang. Module

如果此模块将给定的包导出到至少给定的模块，则返回 true 。

isExpression() - Method in enum jdk.nashorn.api.tree. Tree.Kind

如果这是一个表达式树类，返回。

isExtensible() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

检查此脚本对象是否可扩展

isExtensionPartCached(URL, String, String) - Method in interface javax.jnlp. DownloadService

如果给定的扩展名的给定部分被缓存，并且扩展名和部分在应用程序的JNLP文件中被提到，则返回 true 。

isExtensionPartCached(URL, String, String[]) - Method in interface javax.jnlp. DownloadService

如果给定扩展的给定部分被缓存，并且在应用程序的JNLP文件中提到扩展和部件，则返回 true 。

isExternalizable() - Method in interface com.sun.javadoc. ClassDoc

已过时。

如果这个类实现或接口扩展返回true java.io.Externalizable 。

isFair() - Method in class java.util.concurrent.locks. ReentrantLock

如果此锁的公平设置为true，则返回 true 。

isFair() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

如果此锁的公平设置为true，则返回 true 。

isFair() - Method in class java.util.concurrent. Semaphore

如果此信号量的公平设置为true，则返回 true 。

isFeatureSupported(String) - Method in class javax.xml.crypto.dom. DOMStructure

isFeatureSupported(String) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory

指示是否支持指定的功能。

isFeatureSupported(String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory

指示是否支持指定的功能。

isFeatureSupported(String) - Method in interface javax.xml.crypto. XMLStructure

指示是否支持指定的功能。

isField() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是一个字段（但不是枚举常量）？

isField() - Method in enum javax.lang.model.element. ElementKind

如果这是一种字段，则返回 true ： 字段或 ENUM_CONSTANT 。

isFile() - Method in class java.io. File

测试此抽象路径名表示的文件是否为普通文件。

isFileHidingEnabled() - Method in class javax.swing. JFileChooser

如果文件选择器中未显示隐藏文件，则返回true; 否则返回false。

isFileSelectionEnabled() - Method in class javax.swing. JFileChooser

方便电话确定文件是否可以基于当前文件选择模式进行选择。

isFileSystem(File) - Method in class javax.swing.filechooser. FileSystemView

检查是否 f代表一个真正的目录或文件，而不是一个特殊的文件夹，如 "Desktop" 。

isFileSystemRoot(File) - Method in class javax.swing.filechooser. FileSystemView

dir是文件系统中树的根，例如驱动器或分区。

isFileTypeSupported(int) - Static method in class javax.sound.midi. MidiSystem

指示文件是否支持指定的MIDI文件类型由系统提供。

isFileTypeSupported(int) - Method in class javax.sound.midi.spi. MidiFileWriter

指示文件写入器是否为指定的MIDI文件类型提供文件写入。

isFileTypeSupported(int, Sequence) - Static method in class javax.sound.midi. MidiSystem

指示是否可以从指定的顺序写入指定的文件类型的MIDI文件。

isFileTypeSupported(int, Sequence) - Method in class javax.sound.midi.spi. MidiFileWriter

指示是否可以从指定的顺序写入指定的文件类型的MIDI文件。

isFileTypeSupported(AudioFileFormat.Type) - Static method in class javax.sound.sampled. AudioSystem

指示系统是否提供了对指定文件类型的文件写入支持。

isFileTypeSupported(AudioFileFormat.Type) - Method in class javax.sound.sampled.spi. AudioFileWriter

指示此音频文件写入器是否提供对指定文件类型的文件写入支持。

isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - Static method in class javax.sound.sampled. AudioSystem

指示是否可以从指定的音频输入流中写入指定的文件类型的音频文件。

isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - Method in class javax.sound.sampled.spi. AudioFileWriter

指示是否可以从指定的音频输入流中写入指定类型的音频文件。

isFilled() - Method in class javafx.scene.layout. BorderImage

指定是否应绘制中心补丁（由左，右，上，下切片定义）。

isFillHeight() - Method in class javafx.scene.layout. HBox

获取属性fillHeight的值。

isFillHeight() - Method in class javafx.scene.layout. RowConstraints

获取属性fillHeight的值。

isFillHeight(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，返回小孩的垂直填充策略

isFillPercentageBased() - Method in class javafx.scene.layout. Background

获取此背景的填充是基于百分比（即相对于被定制的区域的大小）。

isFillWidth() - Method in class javafx.scene.layout. ColumnConstraints

获取属性fillWidth的值。

isFillWidth() - Method in class javafx.scene.layout. VBox

获取属性fillWidth的值。

isFillWidth(Node) - Static method in class javafx.scene.layout. GridPane

如果设置，返回小孩的横向填充策略

isFinal() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

如果此程序元素为final，则返回true。

isFinal() - Method in interface com.sun.jdi. ReferenceType

确定此类型是否被声明为final。

isFinal() - Method in interface com.sun.jdi. TypeComponent

确定此TypeComponent是否为final。

isFinal(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 final修改， false否则。

isFinite(double) - Static method in class java.lang. Double

如果参数是有限浮点值，则返回true ; 返回false （对于NaN和无穷大参数）。

isFinite(float) - Static method in class java.lang. Float

如果参数是有限浮点值，则返回true ; 返回false （对于NaN和无穷大参数）。

isFirst() - Method in interface java.sql. ResultSet

检索光标是否位于此 ResultSet对象的第一行。

isFitToHeight() - Method in class javafx.scene.control. ScrollPane

获取属性fitToHeight的值。

isFitToWidth() - Method in class javafx.scene.control. ScrollPane

获取属性fitToWidth的值。

isFixed() - Method in class java.time.temporal. ValueRange

值范围是固定的并且是完全已知的。

isFixedEyeAtCameraZero() - Method in class javafx.scene. PerspectiveCamera

返回一个标志，指示本相机是否在相机原点使用固定的眼睛位置。

isFixedOffset() - Method in class java.time.zone. ZoneRules

检查区域规则是固定的，使得偏移量不变。

isFixedRowHeight() - Method in class javax.swing. JTree

如果每个显示行的高度是固定大小，则返回true。

isFixedRowHeight() - Method in class javax.swing.tree. AbstractLayoutCache

如果每行的高度是固定大小，则返回true。

isFlavorJavaFileListType() - Method in class java.awt.datatransfer. DataFlavor

如果指定的 DataFlavor表示文件对象的列表，则返回 true 。

isFlavorRemoteObjectType() - Method in class java.awt.datatransfer. DataFlavor

如果指定的 DataFlavor表示远程对象，则返回 true 。

isFlavorSerializedObjectType() - Method in class java.awt.datatransfer. DataFlavor

如果指定的 DataFlavor表示序列化对象，则返回 true 。

isFlavorTextType() - Method in class java.awt.datatransfer. DataFlavor

返回这个 DataFlavor是否是Java平台实现的有效文本风格。

isFloatable() - Method in class javax.swing. JToolBar

获取 floatable属性。

isFloating() - Method in class javax.swing.plaf.basic. BasicToolBarUI

如果 JToolBar是浮动的，则返回 true

isFloppyDrive(File) - Method in class javax.swing.filechooser. FileSystemView

由UI类用于决定是否显示软盘的特殊图标。

isFocusable() - Method in class java.awt. Component

返回是否可以对该Component进行聚焦。

isFocusableWindow() - Method in class java.awt. Window

返回此窗口是否可以成为关注的窗口，也就是说，此窗口或其任何子组件是否可以成为焦点所有者。

isFocusCycleRoot() - Method in class java.awt. Container

返回此容器是否是焦点遍历循环的根。

isFocusCycleRoot() - Method in class java.awt. Window

始终返回 true因为所有Windows必须是焦点遍历循环的根。

isFocusCycleRoot() - Method in class javax.swing. JInternalFrame

始终返回 true因为所有 JInternalFrame s必须是焦点遍历循环的根。

isFocusCycleRoot(Container) - Method in class java.awt. Component

返回指定的Container是否是此组件焦点遍历周期的焦点循环根。

isFocusCycleRoot(Container) - Method in class java.awt. Container

返回指定的Container是否是此Container的焦点遍历循环的焦点循环根。

isFocused() - Method in class java.awt. Window

返回此窗口是否聚焦。

isFocused() - Method in class javafx.scene. Node

获取关注的属性的值。

isFocused() - Method in class javafx.stage. Window

获取关注的属性的值。

isFocused(int) - Method in class javafx.scene.control. FocusModel

方便的方法来通知给定的索引当前是否集中在此SelectionModel中。

isFocused(int, TableColumn<S, ?>) - Method in class javafx.scene.control. TableView.TableViewFocusModel

测试给定位置的行/单元格当前是否具有TableView内的焦点。

isFocused(int, TreeTableColumn<S, ?>) - Method in class javafx.scene.control. TreeTableView.TreeTableViewFocusModel

测试给定位置的行/单元格当前是否具有TableView内的焦点。

isFocused(int, TC) - Method in class javafx.scene.control. TableFocusModel

测试给定位置的行/单元格是否在UI控件内具有焦点。

isFocusManagerEnabled() - Static method in class javax.swing. FocusManager

已过时。
截至1.4，由KeyboardFocusManager.getDefaultFocusTraversalPolicy()取代

isFocusOwner() - Method in class java.awt. Component

如果这个 Component是焦点所有者，则返回 true 。

isFocusPainted() - Method in class javax.swing. AbstractButton

获取 paintFocus属性。

isFocusTraversable() - Method in class com.sun.java.accessibility.util. Translator

返回此对象是否可以接受焦点。

isFocusTraversable() - Method in class java.awt. Component.AccessibleAWTComponent

返回此对象是否可以接受焦点。

isFocusTraversable() - Method in class java.awt. Component

已过时。
截至1.4，由isFocusable()取代。

isFocusTraversable() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

返回此对象是否可以接受焦点。

isFocusTraversable() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

返回此对象是否可以接受焦点。

isFocusTraversable() - Method in class javafx.scene. Node

获取属性focusTraversable的值。

isFocusTraversable() - Method in interface javax.accessibility. AccessibleComponent

返回此对象是否可以接受焦点。

isFocusTraversable() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

isFocusTraversable() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

isFocusTraversable() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

isFocusTraversable() - Method in class javax.swing.plaf.basic. BasicArrowButton

返回箭头按钮是否应该获得焦点。

isFocusTraversable() - Method in class javax.swing.plaf.basic. BasicComboPopup

覆盖无条件返回假。

isFocusTraversable() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.SystemMenuBar

isFocusTraversable() - Method in class javax.swing.plaf.metal. MetalComboBoxButton

isFocusTraversable() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

isFocusTraversable(JComboBox<?>) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

确定JComboBox是否可以聚焦。

isFocusTraversable(JComboBox<?>) - Method in class javax.swing.plaf. ComboBoxUI

确定组合框本身是否可遍历

isFocusTraversable(JComboBox<?>) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 isFocusTraversable方法。

isFocusTraversalPolicyProvider() - Method in class java.awt. Container

返回此容器是否提供焦点遍历策略。

isFocusTraversalPolicySet() - Method in class java.awt. Container

返回是否为此Container显式设置了重点遍历策略。

isFontSet() - Method in class java.awt. Component

返回是否已经为此组件显式设置了字体。

isForceIntegerRenderScale() - Method in class javafx.stage. Window

获取属性forceIntegerRenderScale的值。

isForceZeroInRange() - Method in class javafx.scene.chart. NumberAxis

获取属性forceZeroInRange的值。

isForEach() - Method in interface jdk.nashorn.api.tree. ForInLoopTree

如果这是一个for..each..in语句返回。

isForegroundSet() - Method in class java.awt. Component

返回是否为此组件显式设置了前景色。

isFormatLossless() - Method in class javax.imageio.spi. ImageWriterSpi

如果此写入器输出的格式可精确保留像素数据，则返回 true 。

isFormatSupported(AudioFormat) - Method in class javax.sound.sampled. DataLine.Info

指示此数据线是否支持特定的音频格式。

isFormattedOutput() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

获取格式化输出标志的方便方法。

isForwardable() - Method in class javax.security.auth.kerberos. KerberosTicket

确定此机票是否可转发。

isForwardBias() - Method in class javafx.scene.control.skin. TextInputControlSkin

获取属性forwardBias的值。

isForwardCheckingSupported() - Method in interface java.security.cert. CertPathChecker

指示是否支持转发检查。

isForwardCheckingSupported() - Method in class java.security.cert. PKIXCertPathChecker

指示是否支持转发检查。

isForwarded() - Method in class javax.security.auth.kerberos. KerberosTicket

确定这张票是否已经转发或基于涉及转发的票证授予票证的认证。

isFragment() - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

获取片段标志的便利方法。

isFrameStateSupported(int) - Method in class java.awt. Toolkit

返回Toolkit是否支持 Frame的状态。

isFreeStanding - Variable in class javax.swing.plaf.metal. MetalScrollBarUI

物业的价值 JScrollBar.isFreeStanding 。

isFrozen() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

检查此脚本对象是否被冻结

isFullScreen() - Method in class javafx.stage. Stage

获取属性fullScreen的值。

isFullScreenRequired() - Method in class java.awt. BufferCapabilities

isFullScreenSupported() - Method in class java.awt. GraphicsDevice

返回 true如果这个 GraphicsDevice支持全屏独占模式。

isFunction() - Method in class jdk.nashorn.api.scripting. AbstractJSObject

isFunction() - Method in interface jdk.nashorn.api.scripting. JSObject

这是一个函数对象吗？

isFunction() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

isFunctionalInterface(TypeElement) - Method in interface javax.lang.model.util. Elements

返回 true如果类型元件是功能性的接口， false否则。

isFunctionKey() - Method in enum javafx.scene.input. KeyCode

F1，F2等功能键

isFxApplicationThread() - Static method in class javafx.application. Platform

如果调用线程是JavaFX应用程序线程，则返回true。

isGap() - Method in class java.time.zone. ZoneOffsetTransition

这个转变是否代表了本地时间线的差距。

isGapStartAndEnd() - Method in class javafx.scene.chart. CategoryAxis

获取属性gapStartAndEnd的值。

isGapToken() - Method in class org.ietf.jgss. MessageProp

测试是否未收到预期的令牌，即一个或多个前身令牌尚未成功处理。

isGeneral() - Method in class javax.swing.text.html.parser. Entity

如果是一般实体，则返回 true 。

isGenerator() - Method in interface jdk.nashorn.api.tree. FunctionDeclarationTree

这是发电机功能吗？

isGenerator() - Method in interface jdk.nashorn.api.tree. FunctionExpressionTree

这是发电机功能吗？

isGlobalScope() - Method in class javax.xml.bind. JAXBElement

如果这个xml元素声明是全局的，则返回true。

isGraphicsConfigSupported(GraphicsConfiguration) - Method in class java.awt. GraphicsConfigTemplate

返回一个 boolean指示是否可以使用指定的 GraphicsConfiguration来创建支持指定功能的绘图面。

isGridLinesVisible() - Method in class javafx.scene.layout. GridPane

获取属性gridLinesVisible的值。

isGroupingUsed() - Method in class java.text. NumberFormat

新新新旗新新新新旗新新旗新新旗新新旗旗新新旗新新旗旗新新旗新旗旗

isGuiAvailable() - Static method in class java.beans. Beans

确定bean是否可以承担GUI可用。

isGUIInitialized() - Static method in class com.sun.java.accessibility.util. EventQueueMonitor

说明GUI子系统是否已被初始化？

isHeadless() - Static method in class java.awt. GraphicsEnvironment

测试此环境中是否可以支持显示器，键盘和鼠标。

isHeadlessInstance() - Method in class java.awt. GraphicsEnvironment

返回在此图形环境中是否可以支持显示，键盘和鼠标。

isHeightAsPercentage() - Method in class javafx.scene.layout. BackgroundSize

指定 height包含的值是否应解释为百分比或正常值。

isHeldByCurrentThread() - Method in class java.util.concurrent.locks. ReentrantLock

查询此锁是否由当前线程持有。

isHeldByCurrentThread() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock

查询这个写锁是否由当前线程持有。

isHeldExclusively() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

如果同步仅针对当前（调用）线程进行 true则返回 true 。

isHeldExclusively() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回 true如果同步仅针对当前（调用）线程进行。

isHidden() - Method in class java.beans. FeatureDescriptor

“隐藏”标志用于识别仅用于工具使用的功能，不应该暴露于人类。

isHidden() - Method in class java.io. File

测试此抽象路径名命名的文件是否为隐藏文件。

isHidden() - Method in interface java.nio.file.attribute. DosFileAttributes

返回隐藏属性的值。

isHidden(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.BasicFileView

返回是否隐藏文件。

isHidden(Path) - Static method in class java.nio.file. Files

告知文件是否被 隐藏 。

isHidden(Path) - Method in class java.nio.file.spi. FileSystemProvider

告知文件是否被 隐藏 。

isHiddenFile(File) - Method in class javax.swing.filechooser. FileSystemView

返回文件是否被隐藏。

isHideOnClick() - Method in class javafx.scene.control. CustomMenuItem

获取属性hideOnClick的值。

isHideOnClick() - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

获取属性hideOnClick的值。

isHideOnEscape() - Method in class javafx.stage. PopupWindow

获取属性hideOnEscape的值。

isHighSurrogate(char) - Static method in class java.lang. Character

确定给定的 char值是否为 Unicode high-surrogate code unit （也称为 引导代理单元 ）。

isHorizontal() - Method in class java.awt. ComponentOrientation

线条水平吗？

isHorizontal() - Method in enum javafx.geometry. Side

指示这是否是一个矩形的水平侧（返回 true为 TOP和 BOTTOM 。

isHorizontalAsPercentage() - Method in class javafx.scene.layout. BackgroundPosition

指定 horizontalPosition是否应解释为文字数字或百分比。

isHorizontalGridLinesVisible() - Method in class javafx.scene.chart. XYChart

获取属性horizontalGridLinesVisible的值。

isHorizontalZeroLineVisible() - Method in class javafx.scene.chart. XYChart

获取属性horizontalZeroLineVisible的值。

isHover() - Method in class javafx.scene. Node

获取属性悬停的值。

isHTMLString(String) - Static method in class javax.swing.plaf.basic. BasicHTML

检查给定的字符串，看看它是否应该在支持html呈现的非文本组件中触发html渲染逻辑。

isHttpOnly() - Method in class java.net. HttpCookie

如果此cookie包含 HttpOnly属性，则返回 true 。

isIcon - Variable in class javax.swing. JInternalFrame

框架已经被图标化了。

isIcon() - Method in class javax.swing. JInternalFrame

返回 JInternalFrame是否被图标化。

isIconifiable() - Method in class javax.swing. JInternalFrame

获取 iconable属性，默认为 false 。

isIconified() - Method in class javafx.stage. Stage

获取图标属性的值。

isIconOnly() - Method in class javax.swing.plaf.metal. MetalComboBoxButton

返回 isIconOnly值。

isId() - Method in interface org.w3c.dom. Attr

返回此属性是否已知为类型ID（即包含其所有者元素的标识符）。

isIdAttribute(int) - Method in class javax.xml.validation. TypeInfoProvider

如果指定的属性被确定为ID，则返回 true 。

isIdentifier(CharSequence) - Static method in enum javax.lang.model. SourceVersion

返回 name是否是最新版本中的语法有效的标识符（简称）或关键字。

isIdentifierIgnorable(char) - Static method in class java.lang. Character

确定指定的字符是否应被视为Java标识符或Unicode标识符中的可忽略字符。

isIdentifierIgnorable(int) - Static method in class java.lang. Character

确定指定字符（Unicode代码点）是否应被视为Java标识符或Unicode标识符中的可忽略字符。

isIdentity() - Method in class java.awt.font. TransformAttribute

如果包装的转换是一个身份转换，则返回 true 。

isIdentity() - Method in class java.awt.geom. AffineTransform

如果这个 AffineTransform是一个身份转换，则返回 true 。

isIdentity() - Method in class javafx.scene.transform. Transform

获取属性标识的值。

isIdeographic(int) - Static method in class java.lang. Character

确定指定字符（Unicode代码点）是否是Unicode标准定义的CJKV（中文，日文，韩文和越南文）表意文字。

isIFDPointer() - Method in class javax.imageio.plugins.tiff. TIFFTag

如果此标记用于指向包含其他标签的IFD结构，则返回 true 。

isIgnorableWhiteSpace() - Method in interface javax.xml.stream.events. Characters

如果这是可忽略的话，返回true。

isIgnoringComments() - Method in class javax.xml.parsers. DocumentBuilderFactory

指示工厂是否配置为生成忽略注释的解析器。

isIgnoringElementContentWhitespace() - Method in class javax.xml.parsers. DocumentBuilderFactory

指示工厂是否配置为生成忽略元素内容中的可忽略空白的解析器。

isIgnoringMetadata() - Method in class javax.imageio. ImageReader

返回 true如果当前输入源已经被标记为允许元数据通过传递被忽略 true为 ignoreMetadata参数传递给 setInput方法。

isImageAutoSize() - Method in class java.awt. TrayIcon

返回auto-size属性的值。

isImageTiled(int) - Method in class javax.imageio. ImageReader

返回 true如果图像被组织成 瓦片 ，也就是等大小的非重叠矩形。

isImplicit() - Method in class java.lang.reflect. Parameter

如果此参数在源代码中隐式声明，则返回true ; 否则返回false 。

isImplicitExit() - Static method in class javafx.application. Platform

获取implicitExit属性的值。

isImportant() - Method in class javafx.css. Declaration

isInboundDone() - Method in class javax.net.ssl. SSLEngine

返回是否 SSLEngine.unwrap(ByteBuffer, ByteBuffer)将接受任何更多的入站数据消息。

isIncluded() - Method in interface com.sun.javadoc. Doc

已过时。

如果此文档项目是结果集中的 included ，则返回true。

isIncluded(Element) - Method in interface jdk.javadoc.doclet. DocletEnvironment

如果文档中的元素应为 included ，则返回true。

isInDefaultEventSet() - Method in class java.beans. EventSetDescriptor

报告事件集是否在“默认”集中。

isIndefinite() - Method in class javafx.util. Duration

获取此Duration实例是否是不确定的。

isIndependent() - Method in class javafx.scene.control. CheckBoxTreeItem

获取属性的值独立。

isIndeterminate() - Method in class javafx.scene.control. CheckBox

获取属性的值不确定。

isIndeterminate() - Method in class javafx.scene.control. CheckBoxTreeItem

返回此CheckBoxTreeItem的不确定状态。

isIndeterminate() - Method in class javafx.scene.control. ProgressIndicator

获取属性的值不确定。

isIndeterminate() - Method in class javax.swing. JProgressBar

返回 indeterminate属性的值。

isindex - Variable in class javax.swing.text.html.parser. DTD

与isindex相对应的元素。

ISINDEX - Static variable in class javax.swing.text.html. HTML.Tag

标签<isindex>

IsindexAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.IsindexAction

isIndexSelected(int) - Method in class java.awt. List

确定是否选择了此滚动列表中的指定项目。

isInertia() - Method in class javafx.scene.input. GestureEvent

指示此事件是否表示已经完成的手势的惯性。

isInfinite() - Method in class java.lang. Double

如果 Double价值无限大，则返回 true ，否则为 false 。

isInfinite() - Method in class java.lang. Float

如果这个 Float价值无限大，则返回 true ，否则为 false 。

isInfinite(double) - Static method in class java.lang. Double

返回 true如果指定的数是无限大， false否则。

isInfinite(float) - Static method in class java.lang. Float

返回 true如果指定的数是无限大， false否则。

isInherited() - Method in class javax.swing.text.html. CSS.Attribute

指示属性是否应该从父级继承。

isInherits() - Method in class javafx.css. CssMetaData

如果为true，则此属性的值与父属的此属性的计算值相同。

isInitial() - Method in class javax.security.auth.kerberos. KerberosTicket

确定是否使用Kerberos AS-Exchange协议发出此机票，而不是根据一些票证授予票据发出。

isInitialized() - Method in interface com.sun.jdi. ReferenceType

确定此类型是否已初始化。

isInitialized() - Method in class javax.annotation.processing. AbstractProcessor

如果此对象已被 initialized ，则返回 true ，否则为 false 。

isInitiator() - Method in interface org.ietf.jgss. GSSContext

确定这是否是上下文启动器。

isInlineTag() - Method in interface com.sun.tools.doclets. Taglet

已过时。

如果这个 Taglet是一个内联标签，返回true。

isInlineTag() - Method in interface jdk.javadoc.doclet. Taglet

指示此taglet是否用于内联标签。

isInNative() - Method in class java.lang.management. ThreadInfo

测试与此 ThreadInfo相关联的线程是否通过Java本机接口（JNI）执行本机代码。

isInProgress() - Method in class javax.swing.undo. CompoundEdit

如果此编辑正在进行，则返回true - 也就是说，它没有收到结束。

isInputShutdown() - Method in class java.net. Socket

返回套接字连接的一半是否关闭。

isInRelationService() - Method in class javax.management.relation. RelationSupport

返回一个内部标志，指定对象是否仍由关系服务处理。

isInRelationService() - Method in interface javax.management.relation. RelationSupportMBean

返回一个内部标志，指定对象是否仍由关系服务处理。

isInsert() - Method in class javax.swing. JList.DropLocation

返回此位置是否表示插入位置。

isInsertColumn() - Method in class javax.swing. JTable.DropLocation

返回此位置是否表示列的插入。

isInsertRow() - Method in class javax.swing. JTable.DropLocation

返回此位置是否表示行的插入。

isInstance(Class<?>, int, MethodType) - Static method in class jdk.dynalink.linker.support. Guards

使用指定类型的参数创建方法句柄，但使用布尔值返回值。

isInstance(Class<?>, MethodType) - Static method in class jdk.dynalink.linker.support. Guards

使用指定类型的参数创建方法句柄，但使用布尔值返回值。

isInstance(Object) - Method in class java.lang. Class

确定指定的 Object是否与此 Class表示的对象分配兼容。

isInstance(Object) - Method in class jdk.nashorn.api.scripting. AbstractJSObject

isInstance(Object) - Method in interface jdk.nashorn.api.scripting. JSObject

检查给定对象是否为“this”对象的实例。

isInstance(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

isInstanceOf(Object) - Method in class jdk.nashorn.api.scripting. AbstractJSObject

isInstanceOf(Object) - Method in interface jdk.nashorn.api.scripting. JSObject

检查此对象是否是给定的“clazz”对象的实例。

isInstanceOf(Object, Class<?>) - Static method in class java.beans. Beans

检查一个bean是否可以被看作给定的目标类型。

isInstanceOf(ObjectName, String) - Method in interface javax.management. MBeanServer

isInstanceOf(ObjectName, String) - Method in interface javax.management. MBeanServerConnection

如果指定的MBean是指定类的实例，则返回true，否则返回false。

isInstanceOf(ObjectName, String, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.isInstanceOf(ObjectName, String) 。

isInstanceOf(ObjectName, String, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

isInstanceOf(ObjectName, String, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

isInstanceOf(StringValueExp) - Static method in class javax.management. Query

返回一个表示MBean类继承约束的查询表达式。

isInState(T) - Method in class javax.swing.plaf.nimbus. State

获取指定的JComponent是否处于由此类表示的自定义状态。

isIntegral() - Method in class javax.imageio.plugins.tiff. TIFFField

指示与该字段相关联的值是否为整数数据类型。

isInterface() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是否是一个界面（但不是注释类型）？

isInterface() - Method in class java.lang. Class

确定指定的 Class对象是否表示接口类型。

isInterface() - Method in enum javax.lang.model.element. ElementKind

如果这是一种接口，则返回 true ： INTERFACE或 ANNOTATION_TYPE 。

isInterface(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 interface修改， false否则。

isInterrupted() - Method in class java.lang. Thread

测试这个线程是否被中断。

isInTransformationChain(ObservableList<?>) - Method in class javafx.collections.transformation. TransformationList

检查提供的列表是否在此 TransformationList下的链中。

isIntValue() - Method in class java.time.temporal. ValueRange

检查范围内的所有值是否适合 int 。

isIPv4CompatibleAddress() - Method in class java.net. Inet6Address

检查InetAddress是否与IPv4兼容的IPv6地址的实用程序。

isIs() - Method in class javax.management. MBeanAttributeInfo

表示此属性是否为“是”吸气剂。

isIs() - Method in interface javax.management.openmbean. OpenMBeanAttributeInfo

返回 true如果此描述的属性 OpenMBeanAttributeInfo实例通过访问 isXXX吸气剂（仅适用于 boolean和 Boolean值）， false否则。

isISOControl(char) - Static method in class java.lang. Character

确定指定的字符是否是ISO控制字符。

isISOControl(int) - Static method in class java.lang. Character

确定引用的字符（Unicode代码点）是否是ISO控制字符。

isItalic() - Method in class java.awt. Font

指示此 Font对象的样式是否为ITALIC。

isItalic(AttributeSet) - Static method in class javax.swing.text. StyleConstants

检查是否设置了斜体属性。

isItemChanged(T, T) - Method in class javafx.scene.control. Cell

该方法由Cell子类调用，以便某些CPU密集型操作（具体来说，调用 Cell.updateItem(Object, boolean) ）仅在必要时执行（即，仅当当前设置的 item被认为与所提出的新项目不同时才执行设置）。

isJavaIdentifierPart(char) - Static method in class java.lang. Character

确定指定的字符是否可以是Java标识符的一部分，而不是第一个字符。

isJavaIdentifierPart(int) - Static method in class java.lang. Character

确定字符（Unicode代码点）可能是Java标识符的一部分，而不是第一个字符。

isJavaIdentifierStart(char) - Static method in class java.lang. Character

确定指定字符是否允许作为Java标识符中的第一个字符。

isJavaIdentifierStart(int) - Static method in class java.lang. Character

确定字符（Unicode代码点）是否允许作为Java标识符中的第一个字符。

isJavaLetter(char) - Static method in class java.lang. Character

已过时。
替换为isJavaIdentifierStart（char）。

isJavaLetterOrDigit(char) - Static method in class java.lang. Character

已过时。
由isJavaIdentifierPart（char）替代。

isJavaMIMEType(String) - Static method in class java.awt.datatransfer. SystemFlavorMap

返回指定的 String是否是编码的Java MIME类型。

isJavaScriptEnabled() - Method in class javafx.scene.web. WebEngine

获取属性javaScriptEnabled的值。

isKeyBindingActive() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回是否激活密钥绑定。

isKeyBindingRegistered() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

返回是否注册了键绑定。

isKeyboardTrigger() - Method in class javafx.scene.input. ContextMenuEvent

确定此事件是源自键盘。

isKeyDown - Variable in class javax.swing.plaf.basic. BasicTreeUI.KeyHandler

keyPressed处于活动状态时设置为true。

isKeyEntry(String) - Method in class java.security. KeyStore

如果给定别名标识的条目是通过调用创建返回true setKeyEntry ，或者创建通过调用 setEntry与 PrivateKeyEntry或者 SecretKeyEntry 。

isKeypadKey() - Method in enum javafx.scene.input. KeyCode

键盘上的所有键

isKeyword(CharSequence) - Static method in enum javax.lang.model. SourceVersion

返回 s是否是最新源版本中的关键字，布尔文字或空文字。

isKeyword(CharSequence, SourceVersion) - Static method in enum javax.lang.model. SourceVersion

返回在给定的源版本中， s是关键字，布尔文字或空文字。

isLargeArcFlag() - Method in class javafx.scene.shape. ArcTo

获取属性largeArcFlag的值。

isLargeModel() - Method in class javax.swing. JTree

如果将树配置为大型模型，则返回true。

isLargeModel() - Method in class javax.swing.plaf.basic. BasicTreeUI

如果设置大型号，返回 true 。

isLast() - Method in interface java.sql. ResultSet

检索光标是否在 ResultSet对象的最后一行。

isLayoutValid() - Method in class javax.swing.text. AsyncBoxView.ChildState

孩子的观点已被布置。

isLayoutValid(int) - Method in class javax.swing.text. BoxView

确定布局是否沿着给定的轴有效。

isLeadAnchorNotificationEnabled() - Method in class javax.swing. DefaultListSelectionModel

返回 leadAnchorNotificationEnabled标志的值。

isLeading() - Method in class javafx.scene.text. HitInfo

指示命中是否在字符的前缘。

isLeadingEdge() - Method in class java.awt.font. TextHitInfo

如果角色的前缘被击中，则返回 true 。

isLeaf() - Method in class javafx.scene.control. TreeItem

TreeItem是一个叶子，如果它没有孩子。

isLeaf() - Method in class javax.swing. JTree.DynamicUtilTreeNode

如果此节点允许孩子，则返回true。

isLeaf() - Method in class javax.swing.text. AbstractDocument.AbstractElement

检查元素是否是叶子。

isLeaf() - Method in class javax.swing.text. AbstractDocument.BranchElement

检查元素是否是叶子。

isLeaf() - Method in class javax.swing.text. AbstractDocument.LeafElement

检查元素是否是叶子。

isLeaf() - Method in interface javax.swing.text. Element

这个元素是叶元素吗？

isLeaf() - Method in class javax.swing.tree. DefaultMutableTreeNode

如果此节点没有子节点，则返回true。

isLeaf() - Method in interface javax.swing.tree. TreeNode

如果接收者是叶子，则返回true。

isLeaf(int) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回 true如果在节点 row是叶。

isLeaf(Object) - Method in class javax.swing.tree. DefaultTreeModel

返回指定节点是否为叶节点。

isLeaf(Object) - Method in interface javax.swing.tree. TreeModel

如果 node是叶，则返回 true 。

isLeap() - Method in class java.time. Year

根据ISO培训日历系统规则，检查年份是否是闰年。

isLeap(long) - Static method in class java.time. Year

根据ISO培训日历系统规则，检查年份是否是闰年。

isLeapYear() - Method in interface java.time.chrono. ChronoLocalDate

检查年份是否是日历系统定义的闰年。

isLeapYear() - Method in class java.time.chrono. HijrahDate

根据Hijrah日历系统规则检查年份是否是闰年。

isLeapYear() - Method in class java.time. LocalDate

根据ISO培训日历系统规则，检查年份是否是闰年。

isLeapYear() - Method in class java.time. YearMonth

根据ISO培训日历系统规则，检查年份是否是闰年。

isLeapYear(int) - Method in class java.util. GregorianCalendar

确定给定年份是否是闰年。

isLeapYear(long) - Method in interface java.time.chrono. Chronology

检查指定年份是否是闰年。

isLeapYear(long) - Method in class java.time.chrono. HijrahChronology

isLeapYear(long) - Method in class java.time.chrono. IsoChronology

根据ISO培训日历系统规则，检查年份是否是闰年。

isLeapYear(long) - Method in class java.time.chrono. JapaneseChronology

检查指定年份是否是闰年。

isLeapYear(long) - Method in class java.time.chrono. MinguoChronology

检查指定年份是否是闰年。

isLeapYear(long) - Method in class java.time.chrono. ThaiBuddhistChronology

检查指定年份是否是闰年。

isLeftAsPercentage() - Method in class javafx.scene.layout. BorderWidths

指定 left属性是否应解释为区域宽度的百分比（ true ）（ false ）。

isLeftMouseButton(MouseEvent) - Static method in class javax.swing. SwingUtilities

如果鼠标事件指定鼠标左键，则返回true。

isLeftToRight() - Method in class java.awt. ComponentOrientation

HorizontalLines：项目是否从左到右运行？

isLeftToRight() - Method in class java.awt.font. TextLayout

如果这个 TextLayout具有从左到右基本方向或 false如果它具有从右到左的基本方向），则返回 true 。

isLeftToRight() - Method in class java.text. Bidi

如果行是从左到右的文本，并且基本方向是从左到右，返回true。

isLegalReplacement(byte[]) - Method in class java.nio.charset. CharsetEncoder

告知给定的字节数组是否是该编码器的合法替换值。

isLegendVisible() - Method in class javafx.scene.chart. Chart

获取属性legendVisible的值。

isLenient() - Method in class java.text. DateFormat

告诉日期/时间解析是否宽松。

isLenient() - Method in class java.util. Calendar

告诉日期/时间的解释是否宽松。

isLet() - Method in interface jdk.nashorn.api.tree. VariableTree

这是一个让声明吗？

isLetter(char) - Static method in class java.lang. Character

确定指定的字符是否是一个字母。

isLetter(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是否是一个字母。

isLetterKey() - Method in enum javafx.scene.input. KeyCode

所有键与字母

isLetterOrDigit(char) - Static method in class java.lang. Character

确定指定的字符是字母还是数字。

isLetterOrDigit(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是字母还是数字。

isLigature() - Method in class java.awt.font. GlyphMetrics

返回 true如果这是一个连字符号。

isLight - Variable in class javax.swing.plaf.metal. MetalIconFactory.TreeControlIcon

如果 true图标折叠。

isLightOn() - Method in class javafx.scene. LightBase

获取属性lightOn的值。

isLightweight() - Method in class java.awt. Component

轻量级组件没有本机工具包对等体。

isLightweightComponent(Component) - Static method in class javax.swing. JComponent

如果此组件是轻量级的，则返回true，也就是说，如果该组件没有本机窗口系统对等体，则返回true。

isLightWeightPopupEnabled() - Method in class javax.swing. JComboBox

获取 lightWeightPopupEnabled属性的值。

isLightWeightPopupEnabled() - Method in class javax.swing. JPopupMenu

获取 lightWeightPopupEnabled属性。

isLightWeightPopupEnabled() - Method in class javax.swing. ToolTipManager

如果轻量级（全Java） Tooltips正在使用，则返回true;如果正在使用重量级（本机对等体） Tooltips则返回false。

isLineEmpty() - Method in class javax.swing.text. AbstractWriter

如果当前行被视为空，则返回true。

isLineSupported(Line.Info) - Static method in class javax.sound.sampled. AudioSystem

指示系统是否支持与指定的 Line.Info对象匹配的任何行。

isLineSupported(Line.Info) - Method in interface javax.sound.sampled. Mixer

指示混音器是否支持与指定的 Line.Info对象匹配的行（或行）。

isLink(File) - Method in class javax.swing.filechooser. FileSystemView

返回指定的文件是否表示可以通过 FileSystemView.getLinkLocation(File)获取的shell解释链接。

isLinkLocalAddress() - Method in class java.net. Inet4Address

检查InetAddress是否是链接本地地址的实用程序。

isLinkLocalAddress() - Method in class java.net. Inet6Address

检查InetAddress是否是链接本地地址的实用程序。

isLinkLocalAddress() - Method in class java.net. InetAddress

检查InetAddress是否是链接本地地址的实用程序。

isLiteral() - Method in enum jdk.nashorn.api.tree. Tree.Kind

如果这是一个文字树类，返回。

isLoaded() - Method in class java.nio. MappedByteBuffer

告诉这个缓冲区的内容是否驻留在物理内存中。

isLocal - Variable in class java.awt.dnd. DropTargetContext.TransferableProxy

A boolean指示封装的 Transferable对象是否表示本地拖放操作的结果（在同一个JVM中）。

isLocal(Stub) - Static method in class javax.rmi.CORBA. Util

该 isLocal方法具有相同的语义 ObjectImpl._is_local方法，不同之处在于它可以抛出一个 RemoteException 。

isLocal(Stub) - Method in interface javax.rmi.CORBA. UtilDelegate

代表团要求 Util.isLocal(javax.rmi.CORBA.Stub) 。

isLocalClass() - Method in class java.lang. Class

返回 true当且仅当基础类是本地类时。

isLocallyDefined(KeyStroke) - Method in interface javax.swing.text. Keymap

确定给定的键序列是否在本地定义。

isLocalTransfer() - Method in class java.awt.dnd. DropTargetDropEvent

此方法返回一个 int指示源是否与目标位于相同的JVM。

isLocationByPlatform() - Method in class java.awt. Window

如果此窗口在本窗口系统的默认位置显示，下次此窗口可见时，返回 true 。

isLocationInExpandControl(int, int, int, int) - Method in class javax.swing.plaf.metal. MetalTreeUI

如果具有X坐标 mouseX和Y坐标 mouseY点处于扩展控制中，则返回 true 。

isLocationInExpandControl(TreePath, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI

如果 mouseX和 mouseY落在用于展开/折叠节点的行的区域中，则返回 true ，并且在 row处的节点不表示叶。

isLocked() - Method in class java.util.concurrent.locks. ReentrantLock

查询此锁是否由任何线程持有。

isLoggable(System.Logger.Level) - Method in interface java.lang. System.Logger

检查该记录器是否记录给定级别的消息。

isLoggable(Level) - Method in class java.util.logging. Logger

检查该记录器是否实际记录给定级别的消息。

isLoggable(LogRecord) - Method in interface java.util.logging. Filter

检查是否应发布给定的日志记录。

isLoggable(LogRecord) - Method in class java.util.logging. Handler

检查这个 Handler是否会实际记录一个给定的 LogRecord 。

isLoggable(LogRecord) - Method in class java.util.logging. MemoryHandler

检查这个 Handler是否会将给定的 LogRecord实际记录到其内部缓冲区中。

isLoggable(LogRecord) - Method in class java.util.logging. StreamHandler

检查这个 Handler是否会实际记录给定的 LogRecord 。

isLongerThan(Duration) - Method in class javax.xml.datatype. Duration

检查此持续时间对象是否严格超过另一个 Duration对象。

isLookup() - Method in class javafx.css. ParsedValue

如果值引用另一个属性，则需要查找实际值。

isLoopback() - Method in class java.net. NetworkInterface

返回网络接口是否是环回接口。

isLoopbackAddress() - Method in class java.net. Inet4Address

检查InetAddress是否是环回地址的实用程序。

isLoopbackAddress() - Method in class java.net. Inet6Address

检查InetAddress是否是环回地址的实用程序。

isLoopbackAddress() - Method in class java.net. InetAddress

检查InetAddress是否是环回地址的实用程序。

isLowerCase(char) - Static method in class java.lang. Character

确定指定的字符是否是小写字符。

isLowerCase(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是否是小写字符。

isLowSurrogate(char) - Static method in class java.lang. Character

确定给定的 char值是否为 Unicode low-surrogate code unit （也称为 尾随代理单元 ）。

isMalformed() - Method in class java.nio.charset. CoderResult

告知这个对象是否描述了格式错误的输入错误。

isManaged() - Method in class javafx.scene. Node

获取管理的属性的值。

isManagingFocus() - Method in class javax.swing. JComponent

已过时。
截至1.4，由Component.setFocusTraversalKeys(int, Set)和Container.setFocusCycleRoot(boolean) 。

ISMAP - Static variable in class javax.swing.text.html. HTML.Attribute

属性“ismap”

isMarked() - Method in class java.util.concurrent.atomic. AtomicMarkableReference

返回标记的当前值。

isMaximizable() - Method in class javax.swing. JInternalFrame

获取 maximizable属性的值。

isMaximized() - Method in class javafx.stage. Stage

获取最大化的属性值。

isMaximum - Variable in class javax.swing. JInternalFrame

框架已经扩展到最大尺寸。

isMaximum() - Method in class javax.swing. JInternalFrame

返回 JInternalFrame是否最大化。

isMaximumSizeSet() - Method in class java.awt. Component

如果最大大小设置为非 null值，则返回true，否则返回false。

isMCGlobal() - Method in class java.net. Inet4Address

检查多播地址是否具有全局范围的实用程序。

isMCGlobal() - Method in class java.net. Inet6Address

检查多播地址是否具有全局范围的实用程序。

isMCGlobal() - Method in class java.net. InetAddress

检查多播地址是否具有全局范围的实用程序。

isMCLinkLocal() - Method in class java.net. Inet4Address

检查组播地址是否具有链路范围的实用程序。

isMCLinkLocal() - Method in class java.net. Inet6Address

检查组播地址是否具有链路范围的实用程序。

isMCLinkLocal() - Method in class java.net. InetAddress

检查组播地址是否具有链路范围的实用程序。

isMCNodeLocal() - Method in class java.net. Inet4Address

检查多播地址是否具有节点范围的实用程序。

isMCNodeLocal() - Method in class java.net. Inet6Address

检查多播地址是否具有节点范围的实用程序。

isMCNodeLocal() - Method in class java.net. InetAddress

检查多播地址是否具有节点范围的实用程序。

isMCOrgLocal() - Method in class java.net. Inet4Address

检查组播地址是否具有组织范围的实用程序。

isMCOrgLocal() - Method in class java.net. Inet6Address

检查组播地址是否具有组织范围的实用程序。

isMCOrgLocal() - Method in class java.net. InetAddress

检查组播地址是否具有组织范围的实用程序。

isMCSiteLocal() - Method in class java.net. Inet4Address

检查多播地址是否具有站点范围的实用程序。

isMCSiteLocal() - Method in class java.net. Inet6Address

检查多播地址是否具有站点范围的实用程序。

isMCSiteLocal() - Method in class java.net. InetAddress

检查多播地址是否具有站点范围的实用程序。

isMediaKey() - Method in enum javafx.scene.input. KeyCode

所有多媒体键（通道上/下，音量控制等）

isMember(Principal) - Method in interface java.security.acl. Group

已过时。

如果传递的主体是组的成员，则返回true。

isMemberClass() - Method in class java.lang. Class

如果且仅当底层类是成员类，则返回 true 。

isMenuComponent(Component) - Method in class javax.swing. JMenu

如果指定的组件存在于子菜单层次结构中，则返回true。

isMetaDown() - Method in class java.awt.event. InputEvent

返回Meta修饰符在此事件上是否关闭。

isMetaDown() - Method in class javafx.scene.input. GestureEvent

表示Meta修饰符在此事件中是否关闭。

isMetaDown() - Method in class javafx.scene.input. KeyEvent

返回Meta修饰符在此事件上是否关闭。

isMetaDown() - Method in class javafx.scene.input. MouseEvent

Meta修饰符在此事件中是否关闭。

isMetaDown() - Method in class javafx.scene.input. TouchEvent

Meta修饰符在此事件中是否关闭。

isMethod() - Method in interface com.sun.javadoc. Doc

已过时。

这个Doc项目是一种方法（但不是构造函数或注释类型元素）？

isMethodInvocationConvertible(Class<?>, Class<?>) - Static method in class jdk.dynalink.linker.support. TypeUtilities

根据JLS 5.3“方法调用转换”，确定是否可以使用方法调用转换将一种类型转换为其他类型。

isMiddleButtonDown() - Method in class javafx.scene.input. MouseEvent

如果中间按钮（按钮2）当前被按下，则返回 true 。

isMiddleMouseButton(MouseEvent) - Static method in class javax.swing. SwingUtilities

如果鼠标事件指定鼠标中键，则返回true。

isMidnightEndOfDay() - Method in class java.time.zone. ZoneOffsetTransitionRule

当天的时间是午夜的过渡时间。

isMimeTypeEqual(DataFlavor) - Method in class java.awt.datatransfer. DataFlavor

比较 mimeType的 DataFlavor对象。

isMimeTypeEqual(String) - Method in class java.awt.datatransfer. DataFlavor

返回传入的MIME类型的字符串表示是否等同于此 DataFlavor的MIME类型。

isMimeTypeEqual(String) - Method in class javax.activation. ActivationDataFlavor

MIME类型的字符串表示形式相当于此DataFlavor的MIME类型。

isMimeTypeSerializedObject() - Method in class java.awt.datatransfer. DataFlavor

DataFlavor是否代表序列化对象？

isMinimumSizeDirty - Variable in class javax.swing.plaf.basic. BasicComboBoxUI

重新计算最小优选大小的标志。

isMinimumSizeSet() - Method in class java.awt. Component

返回是否使用非空值调用了 setMinimumSize 。

isMinorTickVisible() - Method in class javafx.scene.chart. ValueAxis

获取属性minorTickVisible的值。

isMirrored(char) - Static method in class java.lang. Character

根据Unicode规范确定字符是否镜像。

isMirrored(int) - Static method in class java.lang. Character

确定是否根据Unicode规范镜像指定的字符（Unicode代码点）。

isMixed() - Method in class java.text. Bidi

如果行不是从左到右还是从右到左，返回true。

isMixerSupported(Mixer.Info) - Method in class javax.sound.sampled.spi. MixerProvider

指示混音器提供商是否支持由指定的混音器信息对象表示的混音器。

isMN() - Method in interface org.ietf.jgss. GSSName

测试此名称对象是否表示机制名称（MN）。

isMnemonicParsing() - Method in class javafx.scene.control. Labeled

获取属性mnemonicParsing的值。

isMnemonicParsing() - Method in class javafx.scene.control. MenuItem

获取属性mnemonicParsing的值。

isModal() - Method in class java.awt. Dialog

指示对话框是否为模态。

isModalExclusionTypeSupported(Dialog.ModalExclusionType) - Method in class java.awt. Toolkit

返回此工具包是否支持给定的模式排除类型。

isModalityTypeSupported(Dialog.ModalityType) - Method in class java.awt. Toolkit

返回此工具包是否支持给定的模态类型。

isModifiableClass(Class<?>) - Method in interface java.lang.instrument. Instrumentation

测试课程是否可修改 retransformation或 redefinition 。

isModifiableModule(Module) - Method in interface java.lang.instrument. Instrumentation

测试模块是否可以使用 redefineModule进行修改。

isModifierKey() - Method in enum javafx.scene.input. KeyCode

可以作为修饰符的键

isModuleOrientedLocation() - Method in interface javax.tools. JavaFileManager.Location

指出这个位置是否是面向模块的位置，因此与面向包的位置相比，预期它将包含一个 模块/包/类层次结构中的 类 ，该位置预期包含一个 包/类层次结构中的 类 。

isModuleOrientedLocation() - Method in enum javax.tools. StandardLocation

指出这个位置是否是面向模块的位置，因此与面向包的位置相比，预期它将包含一个 模块/包/类层次结构中的 类 ，该位置预期包含一个 包/类层次结构中的 类 。

isMouseOver() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

返回鼠标是否在分隔线上

isMouseTransparent() - Method in class javafx.scene. Node

获取属性mouseTransparent的值。

isMTOMEnabled() - Method in interface javax.xml.ws.soap. SOAPBinding

如果使用MTOM，则返回 true 。

isMultiBufferAvailable() - Method in class java.awt. BufferCapabilities

isMulticastAddress() - Method in class java.net. Inet4Address

检查InetAddress是否是IP组播地址的实用程序。

isMulticastAddress() - Method in class java.net. Inet6Address

检查InetAddress是否是IP组播地址的实用程序。 11111111在地址开头将该地址标识为多播地址。

isMulticastAddress() - Method in class java.net. InetAddress

检查InetAddress是否是IP组播地址的实用程序。

isMultipleMode() - Method in class java.awt. FileDialog

返回文件对话框是否允许多个文件选择。

isMultipleMode() - Method in class java.awt. List

确定此列表是否允许多个选择。

isMultiRelease() - Method in class java.util.jar. JarFile

指示此jar文件是否为多版本jar文件。

isMultiSelectEvent(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回 true表示节点上的鼠标事件应从锚点中选择。

isMultiSelectionEnabled() - Method in class javax.swing. JFileChooser

如果可以选择多个文件，则返回true。

isMute() - Method in class javafx.scene.media. MediaPlayer

检索 MediaPlayer.muteProperty()的价值。

isMXBean() - Method in class javax.management. MBeanServerInvocationHandler

如果为true，则代理为MXBean，适当的映射应用于方法参数和返回值。

isMXBeanInterface(Class<?>) - Static method in class javax.management. JMX

测试接口是否是MXBean接口。

isName(CharSequence) - Static method in enum javax.lang.model. SourceVersion

返回 name是否是最新版本的语法上有效的限定名称。

isName(CharSequence, SourceVersion) - Static method in enum javax.lang.model. SourceVersion

返回是否 name是给定源版本中的语法有效的限定名称。

isNameCompatible(String, JavaFileObject.Kind) - Method in class javax.tools. ForwardingJavaFileObject

isNameCompatible(String, JavaFileObject.Kind) - Method in interface javax.tools. JavaFileObject

检查此文件对象是否与指定的简单名称和种类兼容。

isNameCompatible(String, JavaFileObject.Kind) - Method in class javax.tools. SimpleJavaFileObject

此实现将其URI的路径与给定的简单名称进行比较。

isNamed() - Method in class java.lang. Module

如果此模块是命名模块，则返回 true 。

isNamePresent() - Method in class java.lang.reflect. Parameter

如果参数具有根据类文件的名称，则返回true; 否则返回false。

isNamespace() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是一个命名空间。

isNamespaceAware() - Method in class javax.xml.parsers. DocumentBuilder

指示此解析器是否配置为了解命名空间。

isNamespaceAware() - Method in class javax.xml.parsers. DocumentBuilderFactory

指示工厂是否配置为生成名称空间感知的解析器。

isNamespaceAware() - Method in class javax.xml.parsers. SAXParser

指示此解析器是否配置为了解命名空间。

isNamespaceAware() - Method in class javax.xml.parsers. SAXParserFactory

指示工厂是否配置为生成名称空间感知的解析器。

isNamespaceDeclUris() - Method in class org.xml.sax.helpers. NamespaceSupport

如果将命名空间声明属性放入命名空间，则返回true。

isNaN() - Method in class java.lang. Double

返回 true如果此 Double值是不是非数字（NAN）， false否则。

isNaN() - Method in class java.lang. Float

返回 true如果此 Float值是不是非数字（NAN）， false否则。

isNaN(double) - Static method in class java.lang. Double

返回 true如果指定的号码是一个不一个数字（NaN）值， false否则。

isNaN(float) - Static method in class java.lang. Float

返回 true如果指定的号码是一个不一个数字（NaN）值， false否则。

isNative() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

如果这个方法是原生的，返回true

isNative() - Method in interface com.sun.jdi. 方法

确定此方法是否为本机。

isNative(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 native修改， false否则。

isNativeLookAndFeel() - Method in class javax.swing. LookAndFeel

如果底层平台具有“本机”的外观，这是一个实现方法，请返回 true 。

isNativeLookAndFeel() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

退货false ; MetalLookAndFeel不是原生的外观。

isNativeLookAndFeel() - Method in class javax.swing.plaf.multi. MultiLookAndFeel

退货false ; 这种外观和感觉不是任何平台的原生。

isNativeLookAndFeel() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回false，SynthLookAndFeel不是原生的外观。

isNativeMethod() - Method in class java.lang. StackTraceElement

如果包含由此堆栈跟踪元素表示的执行点的方法是本机方法，则返回true。

isNativeMethod() - Method in interface java.lang. StackWalker.StackFrame

如果包含由此堆栈帧表示的执行点的方法是本机方法，则返回 true 。

isNativeMethodPrefixSupported() - Method in interface java.lang.instrument. Instrumentation

返回当前的JVM配置是否支持 setting a native method prefix 。

isNavigationKey() - Method in enum javafx.scene.input. KeyCode

导航键是箭头键和Page Down，Page Up，Home，End（包括键盘键）

isNavigationKey(int) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

返回是否提供的keyCode映射到用于导航的密钥。

isNeedsLayout() - Method in class javafx.scene. Parent

获取propertyLayout属性的值。

isNegative() - Method in interface java.security.acl. AclEntry

已过时。

如果这是一个否定的ACL条目（一个拒绝相关主体的条目中的权限集），则返回true，否则返回false。

isNegative() - Method in interface java.time.chrono. ChronoPeriod

检查此期间的受支持单位是否为负。

isNegative() - Method in class java.time. Duration

检查此持续时间是否为负，不包括零。

isNegative() - Method in class java.time. Period

检查此期间的三个单位是否为负。

isNested() - Method in enum javax.lang.model.element. NestingKind

这个常数是否对应于嵌套的类型元素？

isNestedLoopRunning() - Static method in class javafx.application. Platform

检查嵌套事件循环是否正在运行，如果没有嵌套事件循环当前正在运行，则返回true以指示一个为true;如果为false。

isNil() - Method in class javax.xml.bind. JAXBElement

如果此元素实例内容模型为零，则返回 true 。

isNodeAncestor(TreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

如果 anotherNode是此节点的祖先 - 如果是此节点，此节点的父节点或此节点的父节点的祖先，则返回true。

isNodeChild(TreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

如果 aNode是此节点的子节点，则返回true。

isNodeDescendant(DefaultMutableTreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

如果 anotherNode是此节点的后代 - 如果是此节点，该节点的子节点之一，或该节点的子节点之一，则返回true。

isNodeRelated(DefaultMutableTreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

当且仅当 aNode与该节点在同一棵树中时，返回true。

isNodeSibling(TreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

如果 anotherNode是这个节点的（与父节点相同）的兄弟，则返回true。

isNormalized(CharSequence, Normalizer.Form) - Static method in class java.text. Normalizer

确定给定的char值序列是否被归一化。

isNotEmpty() - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个StringExpression不是空，则保留true 。

isNotEmpty(ObservableStringValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不是空的。

isNotEmpty(ObservableList<E>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果给定的ObservableList不为空，则保留true 。

isNotEmpty(ObservableMap<K, V>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果给定的ObservableMap不为空，则保留true 。

isNotEmpty(ObservableSet<E>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果给定的ObservableSet不为空，则保留true 。

isNotEqualTo(double, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。

isNotEqualTo(double, double) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(float, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。

isNotEqualTo(float, double) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(int) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个恒定值，则保留true 。

isNotEqualTo(int) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(int, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常数（容差），则保留true 。

isNotEqualTo(int, double) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(long) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression不等于恒定值，则保留true 。

isNotEqualTo(long) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(long, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个NumberExpression不等于一个常量值（容差），则保留true 。

isNotEqualTo(long, double) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(Object) - Method in class javafx.beans.binding. ObjectExpression

创建一个新的 BooleanExpression ，其持有 true如果这个 ObjectExpression不等于一个恒定值。

isNotEqualTo(String) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个StringExpression不等于一个恒定值，则保留true 。

isNotEqualTo(ObservableBooleanValue) - Method in class javafx.beans.binding. BooleanExpression

创建一个新的BooleanExpression ，如果这个和另一个ObservableBooleanValue相等，则保留true 。

isNotEqualTo(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等，则保留true 。

isNotEqualTo(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(ObservableNumberValue, double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableNumberValue不相等（容差），则保留true 。

isNotEqualTo(ObservableNumberValue, double) - Method in class javafx.beans.binding. NumberExpressionBase

isNotEqualTo(ObservableObjectValue<?>) - Method in class javafx.beans.binding. ObjectExpression

创建一个新的BooleanExpression ，如果这个和另一个ObservableObjectValue不相等，则保留true 。

isNotEqualTo(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等，则保留true 。

isNotEqualTo(ObservableList<?>) - Method in class javafx.beans.binding. ListExpression

创建一个新的BooleanBinding持有true如果此列表不等于另一个ObservableList 。

isNotEqualTo(ObservableMap<?, ?>) - Method in class javafx.beans.binding. MapExpression

创建一个新的BooleanBinding持有true如果此映射不等于另一个ObservableMap 。

isNotEqualTo(ObservableSet<?>) - Method in class javafx.beans.binding. SetExpression

创建一个新的BooleanBinding持有true如果此集合不等于另一个ObservableSet 。

isNotEqualToIgnoreCase(String) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个StringExpression不等于恒定值忽略大小写，则保存true 。

isNotEqualToIgnoreCase(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，如果这个和另一个ObservableStringValue不相等，则保留true 。

isNotificationEnabled(Notification) - Method in class javax.management. AttributeChangeNotificationFilter

在将指定的通知发送给侦听器之前调用。

isNotificationEnabled(Notification) - Method in interface javax.management. NotificationFilter

在将指定的通知发送给侦听器之前调用。

isNotificationEnabled(Notification) - Method in class javax.management. NotificationFilterSupport

在将指定的通知发送给侦听器之前调用。

isNotificationEnabled(Notification) - Method in class javax.management.relation. MBeanServerNotificationFilter

在将指定的通知发送给侦听器之前调用。

isNotifyOnEDT() - Method in class javax.swing.event. SwingPropertyChangeSupport

返回 notifyOnEDT属性。

isNotNull() - Method in class javafx.beans.binding. ListExpression

创建一个新的BooleanBinding持有true如果包装列表不null 。

isNotNull() - Method in class javafx.beans.binding. MapExpression

创建一个新的BooleanBinding持有true如果包装地图不是null 。

isNotNull() - Method in class javafx.beans.binding. ObjectExpression

创建一个新的BooleanBinding持有true如果ObjectExpression不null 。

isNotNull() - Method in class javafx.beans.binding. SetExpression

创建一个新的BooleanBinding持有true如果包装集不是null 。

isNotNull() - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，其持有true如果这StringExpression不是null 。

isNotNull() - Static method in class jdk.dynalink.linker.support. Guards

返回一个检测第一个参数是否不为空的警戒。

isNotNull(ObservableObjectValue<?>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding持有true如果一个价值ObservableObjectValue不null 。

isNull() - Method in class javafx.beans.binding. ListExpression

创建一个新的BooleanBinding持有true如果包装列表为null 。

isNull() - Method in class javafx.beans.binding. MapExpression

创建一个新的BooleanBinding持有true如果包装映射为null 。

isNull() - Method in class javafx.beans.binding. ObjectExpression

创建一个新的BooleanBinding ，保留true如果这ObjectExpression是null 。

isNull() - Method in class javafx.beans.binding. SetExpression

创建一个新的BooleanBinding持有true如果包装集为null 。

isNull() - Method in class javafx.beans.binding. StringExpression

创建一个新的BooleanBinding ，其持有true如果这StringExpression是null 。

isNull() - Static method in class jdk.dynalink.linker.support. Guards

返回一个检测第一个参数是否为空的警戒。

isNull(Object) - Static method in class java.util. Objects

返回 true如果提供的参考是 null ，否则返回 false 。

isNull(ObservableObjectValue<?>) - Static method in class javafx.beans.binding. Bindings

创建一个新的BooleanBinding ，如果true的值为null，则null 。

isNullable(int) - Method in interface java.sql. ParameterMetaData

检索指定参数中是否允许空值。

isNullable(int) - Method in interface java.sql. ResultSetMetaData

表示指定列中的值的无效性。

isNullable(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

检索一个常量，指示是否可以在指定列中存储 NULL值。

ISO - Static variable in class java.time.temporal. WeekFields

ISO-8601定义，一周从星期一开始，第一周至少有4天。

ISO_2A0 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS 2A0的MediaType实例，1189 x 1682 mm。

ISO_4A0 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS 4A0的MediaType实例，1682 x 2378 mm。

ISO_8859_1 - Static variable in class java.nio.charset. StandardCharsets

ISO拉丁字母1号，又名

ISO_A0 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A0的MediaType实例，841 x 1189 mm。

ISO_A0 - Static variable in class javax.print.attribute.standard. MediaSizeName

A0大小。

ISO_A1 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A1的MediaType实例，为594 x 841 mm。

ISO_A1 - Static variable in class javax.print.attribute.standard. MediaSizeName

A1尺寸。

ISO_A10 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A10的MediaType实例，26 x 37 mm。

ISO_A10 - Static variable in class javax.print.attribute.standard. MediaSizeName

A10尺寸

ISO_A2 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A2的MediaType实例，420 x 594 mm。

ISO_A2 - Static variable in class javax.print.attribute.standard. MediaSizeName

A2尺寸。

ISO_A3 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A3的MediaType实例，297 x 420 mm。

ISO_A3 - Static variable in class javax.print.attribute.standard. MediaSizeName

A3尺寸。

ISO_A4 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A4的MediaType实例，210 x 297 mm。

ISO_A4 - Static variable in class javax.print.attribute.standard. MediaSizeName

A4尺寸。

ISO_A4_TRANSPARENT - Static variable in class javax.print.attribute.standard. MediaName

A4透明度。

ISO_A4_WHITE - Static variable in class javax.print.attribute.standard. MediaName

白色A4纸。

ISO_A5 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A5的MediaType实例，148 x 210 mm。

ISO_A5 - Static variable in class javax.print.attribute.standard. MediaSizeName

A5尺寸。

ISO_A6 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A6的MediaType实例，105 x 148 mm。

ISO_A6 - Static variable in class javax.print.attribute.standard. MediaSizeName

A6尺寸

ISO_A7 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A7的MediaType实例，74 x 105 mm。

ISO_A7 - Static variable in class javax.print.attribute.standard. MediaSizeName

A7尺寸

ISO_A8 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A8的MediaType实例，52 x 74 mm。

ISO_A8 - Static variable in class javax.print.attribute.standard. MediaSizeName

A8尺寸

ISO_A9 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN和JIS A9的MediaType实例，37 x 52 mm。

ISO_A9 - Static variable in class javax.print.attribute.standard. MediaSizeName

A9尺寸

ISO_B0 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B0，1000 x 1414 mm的MediaType实例。

ISO_B0 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B0尺寸。

ISO_B1 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B1，707 x 1000 mm的MediaType实例。

ISO_B1 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B1尺寸。

ISO_B10 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B10的MediaType实例，31 x 44 mm。

ISO_B10 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B10尺寸。

ISO_B2 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B2的MediaType实例，500 x 707 mm。

ISO_B2 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B2尺寸。

ISO_B3 - Static variable in class java.awt. PageAttributes.MediaType

ISO / DIN B3的MediaType实例，353 x 500 mm。

ISO_B3 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B3尺寸。

ISO_B4 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B4的MediaType实例，250 x 353 mm。

ISO_B4 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B4尺寸。

ISO_B4_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_B4的别名。

ISO_B5 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B5的介质类型实例，176 x 250 mm。

ISO_B5 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B5尺寸。

ISO_B5_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_B5的别名。

ISO_B6 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B6的MediaType实例，125 x 176 mm。

ISO_B6 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B6尺寸。

ISO_B7 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B7的MediaType实例，88 x 125 mm。

ISO_B7 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B7尺寸。

ISO_B8 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B8的MediaType实例，62 x 88 mm。

ISO_B8 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B8尺寸。

ISO_B9 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN B9的MediaType实例，44 x 62 mm。

ISO_B9 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO B9尺寸。

ISO_C0 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C0的MediaType实例，917 x 1297 mm。

ISO_C0 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO C0尺寸。

ISO_C0_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C0的别名。

ISO_C1 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C1的MediaType实例，648 x 917 mm。

ISO_C1 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO C1尺寸。

ISO_C1_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C1的别名。

ISO_C10 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C10的MediaType实例，28 x 40 mm。

ISO_C10_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C10的别名。

ISO_C2 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C2的MediaType实例，458 x 648 mm。

ISO_C2 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO C2尺寸。

ISO_C2_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C2的别名。

ISO_C3 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C3的MediaType实例，324 x 458 mm。

ISO_C3 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO C3尺寸。

ISO_C3_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C3的别名。

ISO_C4 - Static variable in class java.awt. PageAttributes.MediaType

ISO / DIN C4的MediaType实例，229 x 324 mm。

ISO_C4 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO C4尺寸。

ISO_C4_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C4的别名。

ISO_C5 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C5的MediaType实例，162 x 229 mm。

ISO_C5 - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO C5尺寸。

ISO_C5_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C5的别名。

ISO_C6 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C6的MediaType实例，114 x 162 mm。

ISO_C6 - Static variable in class javax.print.attribute.standard. MediaSizeName

字母大小。

ISO_C6_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C6的别名。

ISO_C7 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C7的MediaType实例，81 x 114 mm。

ISO_C7_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C7的别名。

ISO_C8 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C8的MediaType实例，57 x 81 mm。

ISO_C8_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C8的别名。

ISO_C9 - Static variable in class java.awt. PageAttributes.MediaType

用于ISO / DIN C9的MediaType实例，40 x 57 mm。

ISO_C9_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_C9的别名。

ISO_DATE - Static variable in class java.time.format. DateTimeFormatter

ISO日期格式化程序格式化或解析具有偏移量的日期（如可用），如“2011-12-03”或“2011-12-03 + 01：00”。

ISO_DATE_TIME - Static variable in class java.time.format. DateTimeFormatter

类似ISO的日期格式化程序，用于格式化或解析具有偏移量和区域（如果有的话）的日期时间，如“2011-12-03T10：15：30”，“2011-12-03T10：15：30 + 01” ：00'或'2011-12-03T10：15：30 + 01：00 [欧洲/巴黎]'。

ISO_DESIGNATED_LONG - Static variable in class java.awt. PageAttributes.MediaType

ISO指定长的介质类型实例，110 x 220 mm。

ISO_DESIGNATED_LONG - Static variable in class javax.print.attribute.standard. MediaSizeName

ISO指定长尺寸。

ISO_DESIGNATED_LONG_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

ISO_DESIGNATED_LONG的别名。

ISO_INSTANT - Static variable in class java.time.format. DateTimeFormatter

ISO即时格式化程序，用于格式化或解析UTC中的即时消息，例如“2011-12-03T10：15：30Z”。

ISO_LOCAL_DATE - Static variable in class java.time.format. DateTimeFormatter

ISO日期格式化程序格式化或解析没有偏移量的日期，如“2011-12-03”。

ISO_LOCAL_DATE_TIME - Static variable in class java.time.format. DateTimeFormatter

ISO日期格式化程序格式化或解析没有偏移量的日期时间，例如“2011-12-03T10：15：30”。

ISO_LOCAL_TIME - Static variable in class java.time.format. DateTimeFormatter

ISO时间格式化程序格式化或解析一个没有偏移量的时间，例如“10：15”或“10：15：30”。

ISO_OFFSET_DATE - Static variable in class java.time.format. DateTimeFormatter

ISO日期格式化程序格式化或解析具有偏移量的日期，例如“2011-12-03 + 01：00”。

ISO_OFFSET_DATE_TIME - Static variable in class java.time.format. DateTimeFormatter

ISO日期格式化程序格式化或解析具有偏移量的日期时间，例如“2011-12-03T10：15：30 + 01：00”。

ISO_OFFSET_TIME - Static variable in class java.time.format. DateTimeFormatter

格式化或解析时间偏移的ISO时间格式化程序，例如“10：15 + 01：00”或“10：15：30 + 01：00”。

ISO_ORDINAL_DATE - Static variable in class java.time.format. DateTimeFormatter

ISO日期格式化程序格式化或解析没有偏移量的序数日期，例如“2012-337”。

ISO_TIME - Static variable in class java.time.format. DateTimeFormatter

格式化或解析时间的ISO时间格式化程序，如果可用的偏移量，如“10：15”，“10：15：30”或“10：15：30 + 01：00”。

ISO_WEEK_DATE - Static variable in class java.time.format. DateTimeFormatter

ISO日期格式化程序，用于格式化或解析不带偏移量的基于周的日期，例如“2012-W48-6”。

ISO_ZONED_DATE_TIME - Static variable in class java.time.format. DateTimeFormatter

类似ISO的日期格式化程序，用于格式化或解析具有偏移和区域的日期时间，例如“2011-12-03T10：15：30 + 01：00 [Europe / Paris]”。

isObjectModelSupported(String) - Method in class javax.xml.xpath. XPathFactory

这个 XPathFactory支持的指定对象模型？

isObjectMonitorUsageSupported() - Method in interface java.lang.management. ThreadMXBean

测试Java虚拟机是否支持监视对象监视器的使用情况。

isObsolete() - Method in interface com.sun.jdi. 方法

确定此方法是否已过时。

IsoChronology - Class in java.time.chrono

ISO日历系统。

IsoEra - Enum in java.time.chrono

ISO日历系统中的一个时代。

isOfClass(Class<?>, MethodType) - Static method in class jdk.dynalink.linker.support. Guards

使用指定类型的参数创建一个保护方法句柄，但使用布尔返回值。

isOffline() - Method in interface javax.jnlp. BasicService

确定系统是否脱机。

IsoFields - Class in java.time.temporal

特定于ISO-8601日历系统的领域和单位，包括季度和周年。

isOldToken() - Method in class org.ietf.jgss. MessageProp

测试此令牌的有效期是否已过期，即令牌太旧，无法检查重复。

isOneTouchExpandable() - Method in class javax.swing. JSplitPane

获取 oneTouchExpandable属性。

isOnKeyRelease() - Method in class java.awt. AWTKeyStroke

返回这个 AWTKeyStroke是否是一个关键版本。

isOpaque() - Method in class java.awt. Component

如果此组件完全不透明，则返回true，默认情况下返回false。

isOpaque() - Method in class java.awt. Window

指示窗口当前是否不透明。

isOpaque() - Method in class java.net. URI

告知这个URI是否不透明。

isOpaque() - Method in class javafx.embed.swing. JFXPanel

JFXPanel的不透明度由该组件中显示的JavaFX内容控制，因此此方法将覆盖 JComponent.isOpaque()以始终返回 false值。

isOpaque() - Method in class javafx.scene.paint. Color

获取此Paint是否完全不透明。

isOpaque() - Method in class javafx.scene.paint. ImagePattern

isOpaque() - Method in class javafx.scene.paint. LinearGradient

获取此Paint是否完全不透明。

isOpaque() - Method in class javafx.scene.paint. Paint

获取此Paint是否完全不透明。

isOpaque() - Method in class javafx.scene.paint. RadialGradient

获取此Paint是否完全不透明。

isOpaque() - Method in class javax.swing. DefaultListCellRenderer

由于性能原因而被覆盖。

isOpaque() - Method in class javax.swing. JComponent

如果此组件完全不透明，则返回true。

isOpaque() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.SystemMenuBar

isOpaque() - Method in class javax.swing.table. DefaultTableCellRenderer

由于性能原因而被覆盖。

isOpaque(SynthContext) - Method in class javax.swing.plaf.nimbus. NimbusStyle

如果区域不透明，则返回true。

isOpaque(SynthContext) - Method in class javax.swing.plaf.synth. SynthStyle

如果区域不透明，则返回true。

isOpen() - Method in class com.sun.jdi.connect.spi. Connection

告诉这个连接是否打开。

isOpen() - Method in class java.lang.module. ModuleDescriptor

如果这是一个开放模块，则返回 true 。

isOpen() - Method in interface java.nio.channels. Channel

告诉这个频道是否开放。

isOpen() - Method in class java.nio.channels. Selector

告诉这个选择器是否打开。

isOpen() - Method in class java.nio.channels.spi. AbstractInterruptibleChannel

isOpen() - Method in class java.nio.channels.spi. AbstractSelector

isOpen() - Method in class java.nio.file. FileSystem

告诉这个文件系统是否打开。

isOpen() - Method in interface javax.lang.model.element. ModuleElement

返回 true ，如果这是一个开放的模块和 false否则。

isOpen() - Method in interface javax.sound.midi. MidiDevice

报告设备是否打开。

isOpen() - Method in interface javax.sound.sampled. Line

表示线路是否打开，这意味着它已经预留了系统资源并且可以运行，尽管它可能当前没有播放或捕获声音。

isOpen(String) - Method in class java.lang. Module

如果此模块无条件 打开包，则返回 true 。

isOpen(String, Module) - Method in class java.lang. Module

返回 true如果该模块已经 打开了至少给定模块的包。

isOptimizedDrawingEnabled() - Method in class javax.swing. JComponent

如果此组件贴图其子项，则返回true - 即，如果可以保证子项不会重叠。

isOptimizedDrawingEnabled() - Method in class javax.swing. JLayer

JLayer覆盖此方法的默认实现（在 JComponent ）以返回 false 。

isOptimizedDrawingEnabled() - Method in class javax.swing. JLayeredPane

如果窗格中的组件可以重叠，则返回false，这样使得优化的绘图不可能。

isOptimizedDrawingEnabled() - Method in class javax.swing. JRootPane

glassPane和 contentPane具有相同的界限，这意味着 JRootPane不会对其子代码进行拼贴，并且应该返回false。

isOptimizedDrawingEnabled() - Method in class javax.swing. JViewport

JViewport覆盖此方法的默认实现（在 JComponent ）返回false。

isOrdered() - Method in interface javax.naming.directory. Attribute

确定此属性的值是否被排序。

isOrdered() - Method in class javax.naming.directory. BasicAttribute

isOrdinaryClass() - Method in interface com.sun.javadoc. Doc

已过时。

这个文件是 ordinary class吗？

isOther() - Method in interface java.nio.file.attribute. BasicFileAttributes

告诉该文件是否是常规文件，目录或符号链接以外的其他内容。

isOutboundDone() - Method in class javax.net.ssl. SSLEngine

返回 SSLEngine.wrap(ByteBuffer, ByteBuffer)是否会产生更多的出站数据消息。

isOutputLocation() - Method in enum javax.tools. DocumentationTool.Location

isOutputLocation() - Method in interface javax.tools. JavaFileManager.Location

确定这是否是输出位置。

isOutputLocation() - Method in enum javax.tools. StandardLocation

isOutputShutdown() - Method in class java.net. Socket

返回套接字连接的写半是否关闭。

isOverflow() - Method in class java.nio.charset. CoderResult

告知该对象是否描述溢出状况。

isOverlap() - Method in class java.time.zone. ZoneOffsetTransition

这个转换是否代表本地时间线的重叠。

isOwner(Principal) - Method in interface java.security.acl. Owner

已过时。

如果给定的主体是ACL的所有者，则返回true。

isOwnReader(ImageReader) - Method in class javax.imageio.spi. ImageReaderSpi

如果传入的 ImageReader对象是与此服务提供商关联的 ImageReader一个实例，则返回 true 。

isOwnWriter(ImageWriter) - Method in class javax.imageio.spi. ImageWriterSpi

如果传递的 ImageWriter对象是与此服务提供商关联的 ImageWriter的实例，则返回 true 。

isPackagePrivate() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

如果这个程序元素是私有的，返回true。

isPackagePrivate() - Method in interface com.sun.jdi. Accessible

确定此对象是否反映包私有项。

isPageFlipping() - Method in class java.awt. BufferCapabilities

isPaintable() - Method in interface java.beans. PropertyEditor

确定此属性编辑器是否可绘制。

isPaintable() - Method in class java.beans. PropertyEditorSupport

确定类是否符合paintValue方法。

isPaintingForPrint() - Method in class javax.swing. JComponent

如果此组件上的当前绘画操作是 print操作的一部分，则返回 true 。

isPaintingOrigin() - Method in class javax.swing. JComponent

返回 true如果在子组件上触发的绘画应该导致绘制源自此组件或其祖先之一。

isPaintingOrigin() - Method in class javax.swing. JLayer

始终返回 true ，使绘画始于 JLayer ，或其祖先之一。

isPaintingOrigin() - Method in class javax.swing. JViewport

如果滚动模式是一个 BACKINGSTORE_SCROLL_MODE ，使绘画起源于 JViewport或其祖先之一，则返回true。

isPaintingTile() - Method in class javax.swing. JComponent

如果组件当前正在绘制图块，则返回true。

isPalette - Variable in class javax.swing.plaf.metal. MetalInternalFrameTitlePane

值 isPalette

isPannable() - Method in class javafx.scene.control. ScrollPane

获取pannable属性的值。

isPannable() - Method in class javafx.scene.control.skin. VirtualFlow

获取pannable属性的值。

isParallel() - Method in interface java.util.stream. BaseStream

返回此流是否要执行终端操作，将并行执行。

isParameter() - Method in class javax.swing.text.html.parser. Entity

如果是参数实体，则返回 true 。

isParent(File, File) - Method in class javax.swing.filechooser. FileSystemView

在Windows上，文件可以出现在多个文件夹中，而不是文件系统中的父目录。

isParityAdjusted(byte[], int) - Static method in class javax.crypto.spec. DESedeKeySpec

检查给定的DES-EDE密钥是否从 offset开始进行奇偶校验。

isParityAdjusted(byte[], int) - Static method in class javax.crypto.spec. DESKeySpec

检查给定的DES密钥材料，从 offset开始，是奇偶校验调整的。

isParseBigDecimal() - Method in class java.text. DecimalFormat

返回 DecimalFormat.parse(java.lang.String, java.text.ParsePosition)方法是否返回 BigDecimal 。

isParseIntegerOnly() - Method in class java.text. NumberFormat

如果此格式将仅将数字解析为整数，则返回true。

isPartCached(String) - Method in interface javax.jnlp. DownloadService

如果给定字符串引用的部分被缓存，并且该部分在应用程序的JNLP文件中被提及，则返回 true 。

isPartCached(String[]) - Method in interface javax.jnlp. DownloadService

如果给定数组引用的部分被缓存，并且这些部分在应用程序的JNLP文件中被提到，则返回 true 。

isPartialReturn() - Method in class javax.swing.text. Segment

标记表示部分退货有效。

isPathEditable(TreePath) - Method in class javax.swing. JTree

退货 isEditable 。

isPathSelected(TreePath) - Method in class javax.swing. JTree

如果路径标识的项目当前被选中，则返回true。

isPathSelected(TreePath) - Method in class javax.swing.tree. DefaultTreeSelectionModel

如果路径 path在当前选择中，则返回true。

isPathSelected(TreePath) - Method in interface javax.swing.tree. TreeSelectionModel

如果路径 path位于当前选择中，则返回true。

isPattern() - Method in class javax.management. ObjectName

检查对象名称是否为模式。

isPeriodic() - Method in interface java.util.concurrent. RunnableScheduledFuture

如果此任务是周期性的，则返回 true 。

isPersistent() - Method in enum jdk.jshell. Snippet.Kind

指示此 Kind段的这个 Kind是否持续存在。

isPickOnBounds() - Method in class javafx.scene. Node

获取属性pickOnBounds的值。

isPlain() - Method in class java.awt. Font

指示此是否 Font对象的样式为普通纸。

isPlaying() - Method in class javafx.scene.media. AudioClip

指示这个 AudioClip是否正在播放。

isPointInPath(double, double) - Method in class javafx.scene.canvas. GraphicsContext

如果给定的x，y点在路径内，则返回true。

isPointToPoint() - Method in class java.net. NetworkInterface

返回网络接口是否是点对点接口。

isPolicyMappingInhibited() - Method in class java.security.cert. PKIXParameters

检查策略映射是否被禁止。

isPolygonal() - Method in class java.awt.geom. Area

测试这个 Area是否完全由直边多边形几何组成。

isPoolable() - Method in interface java.sql. Statement

返回一个值，指示 Statement是否可 Statement 。

isPopupMenuVisible() - Method in class javax.swing. JMenu

如果菜单的弹出窗口可见，则返回true。

isPopupTrigger() - Method in class java.awt.event. MouseEvent

返回此鼠标事件是否为平台的弹出菜单触发器事件。

isPopupTrigger() - Method in class javafx.scene.input. MouseEvent

如果此鼠标事件是平台的弹出菜单触发事件，则返回 true 。

isPopupTrigger(MouseEvent) - Method in class javax.swing. JPopupMenu

如果 MouseEvent被 JPopupMenu当前安装的UI视为弹出式触发器，则返回true。

isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.basic. BasicPopupMenuUI

isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI

在此对象处理的每个UI上调用 isPopupTrigger方法。

isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf. PopupMenuUI

返回给定的 MouseEvent是否是平台的弹出菜单触发事件

isPopupVisible() - Method in class javax.swing. JComboBox

确定弹出窗口的可见性。

isPopupVisible(JComboBox<?>) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

告诉弹出窗口是否可见。

isPopupVisible(JComboBox<?>) - Method in class javax.swing.plaf. ComboBoxUI

确定弹出窗口的可见性

isPopupVisible(JComboBox<?>) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 isPopupVisible方法。

isPostdated() - Method in class javax.security.auth.kerberos. KerberosTicket

确定这张票是过时的。

isPreferred() - Method in class java.beans. FeatureDescriptor

“首选”标志用于识别对人类呈现特别重要的特征。

isPreferredSizeSet() - Method in class java.awt. Component

如果首选大小设置为非 null值，则返回true，否则返回false。

isPreformatted() - Method in class javax.swing.text.html. HTML.Tag

如果此标签是预格式的，则返回 true ，如果标记为 PRE或 TEXTAREA ，则返回true。

isPreformatted() - Method in class javax.swing.text.html.parser. TagElement

如果此标签是预先格式化的，则返回 true 。

isPremultiplied() - Method in class javafx.scene.image. PixelFormat

如果通过此格式解码（或编码）的颜色分量被alpha分量预乘以更有效的混合计算，则返回true。

isPrepared() - Method in interface com.sun.jdi. ReferenceType

确定此类型是否已准备好。

isPresent() - Method in class java.util. Optional

如果存在值，则返回 true ，否则为 false 。

isPresent() - Method in class java.util. OptionalDouble

如果存在值，则返回 true ，否则为 false 。

isPresent() - Method in class java.util. OptionalInt

如果存在值，则返回 true ，否则为 false 。

isPresent() - Method in class java.util. OptionalLong

如果存在值，则返回 true ，否则为 false 。

isPreserveRatio() - Method in class javafx.scene.image. Image

指示当缩放以适应 width和 height提供的边界框内的图像时是否保留原始图像的 height 。

isPreserveRatio() - Method in class javafx.scene.image. ImageView

获取属性preserveRatio的值。

isPreserveRatio() - Method in class javafx.scene.media. MediaView

返回在缩放时是否保留媒体宽高比。

isPressed() - Method in class javafx.scene. Node

获取按下的属性的值。

isPressed() - Method in interface javax.swing. ButtonModel

指示按下按钮。

isPressed() - Method in class javax.swing. DefaultButtonModel

指示按下按钮。

isPrimaryButtonDown() - Method in class javafx.scene.input. MouseEvent

如果主按钮（按钮1，通常是左））当前被按下，则返回 true 。

isPrimaryGroup() - Method in class com.sun.security.auth. SolarisNumericGroupPrincipal

已过时。

返回此组标识号（GID）是否表示此用户所属的主组。

isPrimaryGroup() - Method in class com.sun.security.auth. UnixNumericGroupPrincipal

返回此组标识号（GID）是否表示此用户所属的主组。

isPrimitive() - Method in interface com.sun.javadoc. Type

已过时。

如果此类型表示原始类型，则返回true。

isPrimitive() - Method in class java.io. ObjectStreamField

如果此字段具有原始类型，则返回true。

isPrimitive() - Method in class java.lang. Class

确定指定的 Class对象是否表示原始类型。

isPrimitive() - Method in enum javax.lang.model.type. TypeKind

返回 true如果这种对应于基本型和 false否则。

isPrimitiveArray() - Method in class javax.management.openmbean. ArrayType

返回 true如果打开类型的开放数据值是原始数组，否则为 false 。

isPrivate() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

如果此程序元素是私有的，则返回true。

isPrivate() - Method in interface com.sun.jdi. Accessible

确定此对象是否反映私有项目。

isPrivate(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 private修改， false否则。

isProbablePrime(int) - Method in class java.math. BigInteger

返回 true如果这个BigInteger可能是素数， false如果它是绝对复合的。

isProcessingInstruction() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是ProcessingInstruction。

isPropagated() - Method in class java.beans.beancontext. BeanContextEvent

报告此事件是否从其他 BeanContext传播。

isPropertyListPattern() - Method in class javax.management. ObjectName

检查对象名称是否是密钥属性列表上的模式。

isPropertyPattern() - Method in class javax.management. ObjectName

检查对象名称是否是关键属性上的模式。

isPropertySupported(String) - Method in class javax.xml.stream. XMLInputFactory

查询此工厂支持的属性集。

isPropertySupported(String) - Method in class javax.xml.stream. XMLOutputFactory

查询此工厂支持的属性集。

isPropertyValuePattern() - Method in class javax.management. ObjectName

检查对象名称是否是至少一个关键属性的值部分上的模式。

isPropertyValuePattern(String) - Method in class javax.management. ObjectName

检查与键属性中的键相关联的值是否为模式。

isProportional() - Method in class javafx.scene.paint. ImagePattern

获取一个布尔值，指示开始和结束位置是成比例还是绝对。

isProportional() - Method in class javafx.scene.paint. LinearGradient

指示开始和结束位置是成比例还是绝对。

isProportional() - Method in class javafx.scene.paint. RadialGradient

指示中心和半径值是正比还是绝对。

isProtected() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

如果该程序元素被保护，返回true。

isProtected() - Method in interface com.sun.jdi. Accessible

确定此对象是否反映受保护的项目。

isProtected(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 protected修改， false否则。

isProtReady() - Method in interface org.ietf.jgss. GSSContext

确定上下文是否准备好用于每个消息操作。

isProxiable() - Method in class javax.security.auth.kerberos. KerberosTicket

确定这张票是否可以投票。

isProxy() - Method in class javax.security.auth.kerberos. KerberosTicket

确定这张票是一张代理机票。

isProxyClass(Class<?>) - Static method in class java.lang.reflect. Proxy

如果给定的类是代理类，则返回true。

isPublic() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

如果此程序元素为public，则返回true。

isPublic() - Method in interface com.sun.jdi. Accessible

确定此对象是否反映公共项目。

isPublic(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 public修改， false否则。

isPublished() - Method in class javax.xml.ws. Endpoint

如果端点处于已发布状态，则返回true。

isQualified() - Method in class java.lang.module. ModuleDescriptor.Exports

如果这是合格的出口，则返回 true 。

isQualified() - Method in class java.lang.module. ModuleDescriptor.Opens

如果这是合格的打开，则返回 true 。

isQueued(Thread) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

如果给定的线程当前排队，则返回true。

isQueued(Thread) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

如果给定的线程当前排队，则返回true。

isQuiescent() - Method in class java.util.concurrent. ForkJoinPool

如果所有工作线程当前处于空闲状态，则返回 true 。

isRandomAccessEasy(int) - Method in class javax.imageio. ImageReader

如果给定图像的存储格式不会随机访问像素，则返回 true 。

isRangeValid() - Method in class javafx.scene.chart. Axis

查看当前范围是否有效，如果不是，则在下一个布局通过时不需要重新排列任何范围相关的计算

isReachable(int) - Method in class java.net. InetAddress

测试该地址是否可达。

isReachable(NetworkInterface, int, int) - Method in class java.net. InetAddress

测试该地址是否可达。

isReadable() - Method in class java.nio.channels. SelectionKey

测试此密钥的频道是否可以阅读。

isReadable() - Method in class javax.management. MBeanAttributeInfo

是否可以读取属性的值。

isReadable() - Method in interface javax.management.openmbean. OpenMBeanAttributeInfo

返回 true如果此描述的属性 OpenMBeanAttributeInfo实例是可读的， false否则。

isReadable() - Method in class javax.management.relation. RoleInfo

返回角色的读访问模式（如果可读，则返回true）。

isReadable(Path) - Static method in class java.nio.file. Files

测试文件是否可读。

isReadLocked() - Method in class java.util.concurrent.locks. StampedLock

如果锁定当前非排他地，则返回 true 。

isReadOnly() - Method in class java.nio. Buffer

告知这个缓冲区是否是只读的。

isReadOnly() - Method in interface java.nio.file.attribute. DosFileAttributes

返回只读属性的值。

isReadOnly() - Method in class java.nio.file. FileStore

告诉这个文件存储是否是只读的。

isReadOnly() - Method in class java.nio.file. FileSystem

告诉这个文件系统是否只允许只读访问其文件存储。

isReadOnly() - Method in class java.security. PermissionCollection

如果此PermissionCollection对象被标记为只读方式，则返回true。

isReadOnly() - Method in interface java.sql. Connection

检索此 Connection对象是否处于只读模式。

isReadOnly() - Method in interface java.sql. DatabaseMetaData

检索该数据库是否处于只读模式。

isReadOnly() - Method in class javax.imageio.metadata. IIOMetadata

返回 true如果此对象不支持 mergeTree ， setFromTree ，并 reset方法。

isReadOnly() - Method in class javax.security.auth. Subject

查询 Subject是否为只读。

isReadOnly() - Method in class javax.sql.rowset. BaseRowSet

返回一个 boolean表示该 RowSet对象是否为只读。

isReadOnly() - Method in interface javax.sql. RowSet

检索此 RowSet对象是否为只读。

isReadOnly(int) - Method in interface java.sql. ResultSetMetaData

指示指定列是否绝对不可写。

isReadOnly(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

指示指定的列是否绝对不可写，因此只读。

isRecording() - Method in interface javax.sound.midi. Sequencer

指示音序器当前正在录制。

isRectangleContainingRectangle(Rectangle, Rectangle) - Static method in class javax.swing. SwingUtilities

返回 true如果@ {代码}包含 b

isRectangular() - Method in class java.awt.geom. Area

测试这个 Area是否是矩形的。

isRedefineClassesSupported() - Method in interface java.lang.instrument. Instrumentation

返回当前的JVM配置是否支持重新定义类。

isRedoable() - Method in class javafx.scene.control. TextInputControl

获取属性值可重新生成。

isRegistered() - Method in class java.nio.channels. SelectableChannel

告知这个频道当前是否在任何选择器上注册。

isRegistered() - Method in class java.nio.channels.spi. AbstractSelectableChannel

isRegistered() - Method in class java.nio.charset. Charset

告诉这个字符集是否在 IANA Charset Registry中注册。

isRegistered(ObjectName) - Method in interface javax.management. MBeanServer

isRegistered(ObjectName) - Method in interface javax.management. MBeanServerConnection

检查由其对象名称标识的MBean是否已经向MBean服务器注册。

isRegistered(ObjectName, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.isRegistered(ObjectName) 。

isRegistered(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

isRegistered(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

isRegisteredAsParallelCapable() - Method in class java.lang. ClassLoader

返回 true如果这个类加载器被注册为 parallel capable ，否则 false 。

isRegularFile() - Method in interface java.nio.file.attribute. BasicFileAttributes

告知文件是否是具有不透明内容的常规文件。

isRegularFile(Path, LinkOption...) - Static method in class java.nio.file. Files

测试文件是否是具有不透明内容的常规文件。

isRelation(ObjectName) - Method in class javax.management.relation. RelationService

如果MBean作为关系服务中的关系添加，则返回与给定ObjectName关联的关系id。

isRelation(ObjectName) - Method in interface javax.management.relation. RelationServiceMBean

如果MBean作为关系服务中的关系添加，则返回与给定ObjectName关联的关系id。

isRelationMBean(String) - Method in class javax.management.relation. RelationService

如果关系由MBean（由用户创建并在关系服务中添加为关系）表示，则返回MBean的ObjectName。

isRelationMBean(String) - Method in interface javax.management.relation. RelationServiceMBean

如果关系由MBean（由用户创建并在关系服务中添加为关系）表示，则返回MBean的ObjectName。

isRelative() - Method in class javax.naming. NameClassPair

确定此绑定的名称是否相对于目标上下文（由 list()方法的第一个参数命名）。

isReleasable() - Method in interface java.util.concurrent. ForkJoinPool.ManagedBlocker

如果不需要阻塞，则返回 true 。

isRemoved() - Method in class java.util.prefs. AbstractPreferences

返回 true如果此节点（或其祖先）已经被除去的 AbstractPreferences.removeNode()方法。

isRenewable() - Method in class javax.security.auth.kerberos. KerberosTicket

确定这张票是可续期的。

isReorderable() - Method in class javafx.scene.control. TableColumnBase

获取属性可重新排序的值。

isRepeats() - Method in class javax.swing. Timer

返回 true （默认），如果 Timer将多次向其侦听器发送操作事件。

isReplaced() - Method in class javafx.scene.control. TextFormatter.Change

获取此更改是否正在替换文本。

isReplacing - Variable in class javax.swing.text. DefaultStyledDocument.AttributeUndoableEdit

如果元素中的所有属性首先被删除，则为true。

isRepresentationClassByteBuffer() - Method in class java.awt.datatransfer. DataFlavor

返回此 DataFlavor的表示类是 java.nio.ByteBuffer还是其子类。

isRepresentationClassCharBuffer() - Method in class java.awt.datatransfer. DataFlavor

返回此 DataFlavor的表示类是 java.nio.CharBuffer还是其子类。

isRepresentationClassInputStream() - Method in class java.awt.datatransfer. DataFlavor

DataFlavor是 java.io.InputStream吗？

isRepresentationClassReader() - Method in class java.awt.datatransfer. DataFlavor

返回此 DataFlavor的表示类是 java.io.Reader还是其子类。

isRepresentationClassRemote() - Method in class java.awt.datatransfer. DataFlavor

返回 true如果表示形式类为 Remote 。

isRepresentationClassSerializable() - Method in class java.awt.datatransfer. DataFlavor

如果表示类可以序列化，则返回 true 。

isRequestFocusEnabled() - Method in class javax.swing. JComponent

返回true如果这JComponent应该得到焦点; 否则返回false 。

isRequired() - Method in class javax.xml.ws.soap. AddressingFeature

如果启用寻址，则此属性确定端点是否需要WS-Addressing。

isResizable - Variable in class javax.swing.table. TableColumn

如果为true，则允许用户调整列的大小; 默认值为true。

isResizable() - Method in class java.awt. Dialog

指示用户是否可以调整此对话框的大小。

isResizable() - Method in class java.awt. Frame

指示该框架是否可由用户调整大小。

isResizable() - Method in class javafx.embed.swing. SwingNode

isResizable() - Method in class javafx.scene.control. Control

返回 true因为所有的控件都可调整大小。

isResizable() - Method in class javafx.scene.control. Dialog

返回对话框是否可调整大小。

isResizable() - Method in class javafx.scene.control. TableColumnBase

获取属性可调整大小的值。

isResizable() - Method in class javafx.scene.layout. Region

返回 true因为所有地区都可调整大小。

isResizable() - Method in class javafx.scene. Node

指示该节点是否可以由父节点调整大小。

isResizable() - Method in class javafx.scene.web. PopupFeatures

返回弹出窗口是否应该调整大小。

isResizable() - Method in class javafx.scene.web. WebView

isResizable() - Method in class javafx.stage. Stage

获取属性可调整大小的值。

isResizable() - Method in class javax.swing. JInternalFrame

返回是否可以通过某些用户操作调整 JInternalFrame大小。

isResizableWithParent(Node) - Static method in class javafx.scene.control. SplitPane

如果父容器调整大小为false时，如果节点可调整大小，则返回true。

isResolvable() - Method in class jdk.jshell. SourceCodeAnalysis.QualifiedNames

指示原始代码中给定的简单名称是否指可解析元素。

isResourceCached(URL, String) - Method in interface javax.jnlp. DownloadService

如果给定的URL和版本引用的资源被缓存，并且该资源在调用的应用程序JNLP文件中被提及，则在调用应用程序JNLP文件的代码库中，或者调用应用程序已被授予所有权限，则返回true 。 。

isRestParameter() - Method in interface jdk.nashorn.api.tree. IdentifierTree

这是一个函数的休息参数还是数组的其余元素？

isRetransformClassesSupported() - Method in interface java.lang.instrument. Instrumentation

返回当前JVM配置是否支持对类的重新创建。

isRevocationEnabled() - Method in class java.security.cert. PKIXParameters

检查RevocationEnabled标志。

isRevoked(Certificate) - Method in class java.security.cert. CRL

检查给定的证书是否在此CRL上。

isRightAsPercentage() - Method in class javafx.scene.layout. BorderWidths

指定 right属性是否应解释为区域宽度的百分比（ true ）（ false ）。

isRightMouseButton(MouseEvent) - Static method in class javax.swing. SwingUtilities

如果鼠标事件指定了鼠标右键，则返回true。

isRightToLeft() - Method in class java.text. Bidi

如果行是从右到左文本，并且基本方向是从右到左，返回true。

isRoleStatus(int) - Static method in class javax.management.relation. RoleStatus

如果给定值对应于已知角色状态，则返回true，否则返回false。

isRollover() - Method in interface javax.swing. ButtonModel

表示鼠标在按钮上方。

isRollover() - Method in class javax.swing. DefaultButtonModel

表示鼠标在按钮上方。

isRollover() - Method in class javax.swing. JToolBar

返回翻转状态。

isRolloverBorders() - Method in class javax.swing.plaf.basic. BasicToolBarUI

返回一个标志，以确定是否启用滚动按钮边框。

isRolloverEnabled() - Method in class javax.swing. AbstractButton

获取 rolloverEnabled属性。

isRoot() - Method in class javax.swing.tree. DefaultMutableTreeNode

如果此节点是树的根，则返回true。

isRoot(File) - Method in class javax.swing.filechooser. FileSystemView

确定给定文件是否是可导航树中的根。

isRootPaneCheckingEnabled() - Method in class javax.swing. JApplet

已过时。

是否向 add转发到 add和 setLayout的 contentPane 。

isRootPaneCheckingEnabled() - Method in class javax.swing. JDialog

返回是否向 add转发 add和 setLayout的 contentPane 。

isRootPaneCheckingEnabled() - Method in class javax.swing. JFrame

返回是否向 add转发了对 add和 setLayout的 contentPane 。

isRootPaneCheckingEnabled() - Method in class javax.swing. JInternalFrame

返回是否向 add转发到 add和 setLayout的 contentPane 。

isRootPaneCheckingEnabled() - Method in class javax.swing. JWindow

返回是否向 add转发了对 add和 setLayout的 contentPane 。

isRootVisible() - Method in class javax.swing. JTree

如果显示树的根节点，则返回true。

isRootVisible() - Method in class javax.swing.plaf.basic. BasicTreeUI

如果树根可见，则返回 true 。

isRootVisible() - Method in class javax.swing.tree. AbstractLayoutCache

如果显示树的根节点，则返回true。

isRotateGraphic() - Method in class javafx.scene.control. TabPane

如果Tab中的图形旋转，则返回 true 。

isRowSelected(int) - Method in class javax.swing. JTable

如果指定的索引在行的有效范围内，则返回true，并选择该索引处的行。

isRowSelected(int) - Method in class javax.swing. JTree

如果选择了由行标识的节点，则返回true。

isRowSelected(int) - Method in class javax.swing.tree. DefaultTreeSelectionModel

如果选择了由 row确定的行，则返回true。

isRowSelected(int) - Method in interface javax.swing.tree. TreeSelectionModel

如果选择 row标识的行，则返回true。

isRunning() - Method in class javafx.concurrent. Service

获取运行的属性的值。

isRunning() - Method in class javafx.concurrent. Task

获取运行的属性的值。

isRunning() - Method in interface javafx.concurrent. Worker

如果状态为SCHEDULED或RUNNING，则为真。

isRunning() - Method in interface javax.sound.midi. Sequencer

指示排序器当前是否正在运行。

isRunning() - Method in interface javax.sound.sampled. DataLine

指示该行是否正在运行。

isRunning() - Method in class javax.swing. Timer

如果 Timer正在运行，则返回 true 。

isSameFile(Path, Path) - Static method in class java.nio.file. Files

测试两个路径是否找到相同的文件。

isSameFile(Path, Path) - Method in class java.nio.file.spi. FileSystemProvider

测试两个路径是否找到相同的文件。

isSameFile(FileObject, FileObject) - Method in class javax.tools. ForwardingJavaFileManager

isSameFile(FileObject, FileObject) - Method in interface javax.tools. JavaFileManager

比较两个文件对象，如果它们代表相同的底层对象，则返回true。

isSameFile(FileObject, FileObject) - Method in interface javax.tools. StandardJavaFileManager

比较两个文件对象，如果它们表示相同的规范文件，zip文件条目或任何基于文件系统的容器中的条目，则返回true。

isSameNode(Node) - Method in class javax.imageio.metadata. IIOMetadataNode

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

isSameNode(Node) - Method in interface org.w3c.dom. Node

返回此节点是否与给定节点相同。

isSameRM(XAResource) - Method in interface javax.transaction.xa. XAResource

调用此方法来确定由目标对象表示的资源管理器实例是否与由参数 xares表示的资源管理器实例 相同 。

isSameType(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util. Types

测试两个 TypeMirror对象是否代表相同的类型。

isScaleShape() - Method in class javafx.scene.layout. Region

获取属性scaleShape的值。

isSchemaLanguageSupported(String) - Method in class javax.xml.validation. SchemaFactory

这个 SchemaFactory支持的指定模式？

isSealed() - Method in class java.lang. 软件包

如果封装密封，则返回true。

isSealed() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

检查这个脚本对象是否被密封

isSealed(URL) - Method in class java.lang. 软件包

如果该包是针对指定的代码源 url进行了密封，则返回true。

isSearchable(int) - Method in interface java.sql. ResultSetMetaData

指示指定的列是否可以在where子句中使用。

isSearchable(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

指示是否可以在 WHERE子句中使用指定列中存储的值。

isSecondaryButtonDown() - Method in class javafx.scene.input. MouseEvent

如果第二个按钮（按钮1，通常是右））当前被按下，则返回 true 。

isSeekForwardOnly() - Method in class javax.imageio. ImageReader

返回 true如果当前输入源已经被标记为寻找前进，只有通过传递 true作为 seekForwardOnly参数到 setInput方法。

isSelected - Variable in class javax.swing. JInternalFrame

该帧当前被选中。

isSelected - Variable in class javax.swing.plaf.basic. BasicMenuUI.ChangeHandler

true如果选择了弹出菜单项。

isSelected() - Method in class java.awt.im. InputMethodHighlight

返回是否选择文本范围。

isSelected() - Method in class javafx.scene.control. Cell

返回此单元格当前是否被选中。

isSelected() - Method in class javafx.scene.control. CheckBox

获取所选属性的值。

isSelected() - Method in class javafx.scene.control. CheckBoxTreeItem

返回此CheckBoxTreeItem的选定状态。

isSelected() - Method in class javafx.scene.control. CheckMenuItem

获取所选属性的值。

isSelected() - Method in class javafx.scene.control. RadioMenuItem

获取所选属性的值。

isSelected() - Method in class javafx.scene.control. Tab

表示此选项卡是否为当前选定的选项卡，要更改所选的选项卡，请使用 tabPane.getSelectionModel().select()

isSelected() - Method in interface javafx.scene.control. Toggle

指示是否选择此 Toggle 。

isSelected() - Method in class javafx.scene.control. ToggleButton

获取所选属性的值。

isSelected() - Method in class javax.swing. AbstractButton

返回按钮的状态。

isSelected() - Method in interface javax.swing. ButtonModel

指示按钮是否已被选中。

isSelected() - Method in class javax.swing. DefaultButtonModel

指示按钮是否已被选中。

isSelected() - Method in class javax.swing. DefaultSingleSelectionModel

如果选择模型当前具有选定的值，则返回true。

isSelected() - Method in class javax.swing. JInternalFrame

返回 JInternalFrame是否是当前的“已选择”或活动帧。

isSelected() - Method in class javax.swing. JMenu

如果当前选择菜单（高亮显示），则返回true。

isSelected() - Method in class javax.swing. JMenuBar

如果菜单栏当前已选择一个组件，则返回true。

isSelected() - Method in class javax.swing. JToggleButton.ToggleButtonModel

检查按钮是否被选中。

isSelected() - Method in interface javax.swing. SingleSelectionModel

如果选择模型当前具有选定的值，则返回true。

isSelected() - Method in class javax.swing.text.html. Option

获取与此选项关联的选择状态。

isSelected(int) - Method in class java.awt. List

已过时。
从JDK 1.1版开始，由isIndexSelected(int)替代。

isSelected(int) - Method in class javafx.scene.control. SelectionModel

通知此SelectionModel中当前选定给定索引的方便方法。

isSelected(int) - Method in class javafx.scene.control. SingleSelectionModel

如果给定的索引是此SingleSelectionModel中当前选定的索引，则此方法将返回true。

isSelected(int, TableColumn<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

测试在此表实例中当前是否选择给定行和列索引的便利函数。

isSelected(int, TableColumnBase<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

测试在此表实例中当前是否选择给定行和列索引的便利函数。

isSelected(int, TableColumnBase<T, ?>) - Method in class javafx.scene.control. TableSelectionModel

测试在此表实例中当前是否选择给定行和列索引的便利函数。

isSelected(Element) - Method in interface jdk.javadoc.doclet. DocletEnvironment

如果元素是 selected，则返回true。

isSelected(ButtonModel) - Method in class javax.swing. ButtonGroup

返回是否选择了 ButtonModel 。

isSelectedIndex(int) - Method in class javax.swing. DefaultListSelectionModel

如果选择了指定的索引，则返回true。

isSelectedIndex(int) - Method in class javax.swing. JList

如果选择了指定的索引，则返回 true ，否则为 false 。

isSelectedIndex(int) - Method in interface javax.swing. ListSelectionModel

如果选择了指定的索引，则返回true。

isSelectionEmpty() - Method in class javax.swing. DefaultListSelectionModel

如果没有选择索引，则返回true。

isSelectionEmpty() - Method in class javax.swing. JList

如果没有选择，则返回 true ，否则为 false 。

isSelectionEmpty() - Method in class javax.swing. JTree

如果选择当前为空，则返回true。

isSelectionEmpty() - Method in interface javax.swing. ListSelectionModel

如果没有选择索引，则返回true。

isSelectionEmpty() - Method in class javax.swing.tree. DefaultTreeSelectionModel

如果选择当前为空，则返回true。

isSelectionEmpty() - Method in interface javax.swing.tree. TreeSelectionModel

如果选择当前为空，则返回true。

isSelectionVisible() - Method in interface javax.swing.text. Caret

确定选择当前是否可见。

isSelectionVisible() - Method in class javax.swing.text. DefaultCaret

检查当前选择是否可见。

isSelfClosing() - Method in interface com.sun.source.doctree. StartElementTree

如果这是一个自动关闭元素，则返回true，如关闭“>”之前的“/”所示。

isSerializable() - Method in interface com.sun.javadoc. ClassDoc

已过时。

如果这个类实现或接口扩展返回true java.io.Serializable 。

isSerializing() - Method in class java.beans.beancontext. BeanContextSupport

这是 BeanContext在串行化的过程吗？

isServiceClass(Class<?>) - Method in class java.beans.beancontext. BeanContextServiceRevokedEvent

检查此事件以确定被撤销的服务是否属于特定类。

isSet - Variable in class java.util. Calendar

说明是否设置日历的指定日历字段的标志。

isSet(int) - Method in class java.util. Calendar

确定给定的日历字段是否具有值集，包括通过 get方法调用触发的内部字段计算设置的值。

isSet(DatatypeConstants.Field) - Method in class javax.xml.datatype. Duration

检查是否设置了一个字段。

isSettable(S) - Method in class javafx.css. CssMetaData

检查给定节点上的相应属性是否可设置。

isShared() - Method in class java.nio.channels. FileLock

告诉这个锁是否共享。

isShiftDown() - Method in class java.awt.event. InputEvent

返回此事件的Shift修饰符是否关闭。

isShiftDown() - Method in class javafx.scene.input. GestureEvent

指示此事件的Shift修饰符是否关闭。

isShiftDown() - Method in class javafx.scene.input. KeyEvent

返回此事件的Shift修饰符是否关闭。

isShiftDown() - Method in class javafx.scene.input. MouseEvent

Shift修饰符是否关闭此事件。

isShiftDown() - Method in class javafx.scene.input. TouchEvent

Shift修饰符是否关闭此事件。

isShortcutDown() - Method in class javafx.scene.input. GestureEvent

指示主机平台公共快捷方式修饰符在此事件上是否关闭。

isShortcutDown() - Method in class javafx.scene.input. KeyEvent

返回主机平台常用快捷方式修饰符是否在此事件上关闭。

isShortcutDown() - Method in class javafx.scene.input. MouseEvent

返回主机平台常用快捷方式修饰符是否在此事件上关闭。

isShorterThan(Duration) - Method in class javax.xml.datatype. Duration

检查此持续时间对象是否严格短于另一个 Duration对象。

isShowing() - Method in class com.sun.java.accessibility.util. Translator

确定对象是否显示。

isShowing() - Method in class java.awt. Component.AccessibleAWTComponent

确定对象是否正在显示。

isShowing() - Method in class java.awt. Component

确定此组件是否在屏幕上显示。

isShowing() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

确定对象是否显示。

isShowing() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

确定对象是否正在显示。

isShowing() - Method in class java.awt. Window

检查此窗口是否在屏幕上显示。

isShowing() - Method in class javafx.scene.control. ChoiceBox

获取显示的属性的值。

isShowing() - Method in class javafx.scene.control. ComboBoxBase

获取显示的属性的值。

isShowing() - Method in class javafx.scene.control. Dialog

返回对话框是否显示。

isShowing() - Method in class javafx.scene.control. Menu

获取显示的属性的值。

isShowing() - Method in class javafx.scene.control. MenuButton

获取显示的属性的值。

isShowing() - Method in class javafx.stage. Window

获取显示的属性的值。

isShowing() - Method in interface javax.accessibility. AccessibleComponent

确定对象是否正在显示。

isShowing() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

isShowing() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

确定对象是否正在显示。

isShowing() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

isShowing() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

isShowRoot() - Method in class javafx.scene.control. TreeTableView

如果应该显示TreeTableView的根，则返回true，否则返回false。

isShowRoot() - Method in class javafx.scene.control. TreeView

如果应该显示TreeView的根，则返回true，否则返回false。

isShowTickLabels() - Method in class javafx.scene.control. Slider

获取属性showTickLabels的值。

isShowTickMarks() - Method in class javafx.scene.control. Slider

获取属性showTickMarks的值。

isShowWeekNumbers() - Method in class javafx.scene.control. DatePicker

获取属性showWeekNumbers的值。

isShutdown() - Method in class java.nio.channels. AsynchronousChannelGroup

告知这个异步通道组是否关闭。

isShutdown() - Method in interface java.util.concurrent. ExecutorService

如果这个执行者已被关闭，则返回 true 。

isShutdown() - Method in class java.util.concurrent. ForkJoinPool

如果此池已关闭，则返回 true 。

isShutdown() - Method in class java.util.concurrent. ThreadPoolExecutor

isSignatureChange() - Method in class jdk.jshell. SnippetEvent

指示签名是否已更改。

isSigned(int) - Method in interface java.sql. ParameterMetaData

检索指定参数的值是否可以是符号数。

isSigned(int) - Method in interface java.sql. ResultSetMetaData

指示指定列中的值是否为有符号数。

isSigned(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

指示存储在指定列中的值是否为有符号数。

isSignificant() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

DefaultDocument事件很重要。

isSignificant() - Method in class javax.swing.undo. AbstractUndoableEdit

此默认实现返回true。

isSignificant() - Method in class javax.swing.undo. CompoundEdit

如果 UndoableEdit的任何 edits都可以返回true。

isSignificant() - Method in interface javax.swing.undo. UndoableEdit

如果此编辑被认为是重要的，则返回true。

isSimpleIdentifier(String) - Method in interface java.sql. Statement

检索 identifier是否是一个简单的SQL标识符。

isSingular() - Method in class java.awt.geom. Area

测试这个 Area是否由一个封闭的子路径组成。

isSiteLocalAddress() - Method in class java.net. Inet4Address

检查InetAddress是否是站点本地地址的实用程序。

isSiteLocalAddress() - Method in class java.net. Inet6Address

检查InetAddress是否是站点本地地址的实用程序。

isSiteLocalAddress() - Method in class java.net. InetAddress

检查InetAddress是否是站点本地地址的实用程序。

isSmooth() - Method in class javafx.scene.image. Image

指示是否使用更好的质量过滤算法或更快的过滤算法缩放此图像以适合 width和 height提供的边界框内。

isSmooth() - Method in class javafx.scene.image. ImageView

获取属性的值平滑。

isSmooth() - Method in class javafx.scene.media. MediaView

返回是否在缩放时平滑媒体。

isSmooth() - Method in class javafx.scene.shape. Shape

获取属性的值平滑。

isSnapToPixel() - Method in class javafx.scene.layout. Region

获取属性snapToPixel的值。

isSnapToTicks() - Method in class javafx.scene.control. Slider

获取属性snapToTicks的值。

isSortable() - Method in class javafx.scene.control. TableColumnBase

获取属性可排序的值。

isSortable(int) - Method in class javax.swing. DefaultRowSorter

如果指定的列是可排序的，则返回true; 否则，假。

isSorted() - Method in class javax.naming.ldap. SortResponseControl

确定搜索结果是否已成功排序。

isSoundbankSupported(Soundbank) - Method in interface javax.sound.midi. Synthesizer

通知呼叫者该合成器是否能够从指定的声音库加载仪器。

isSource() - Method in class javax.sound.sampled. Port.Info

指示端口是混合器的源还是目标。

isSourceEncodingSupported(AudioFormat.Encoding) - Method in class javax.sound.sampled.spi. FormatConversionProvider

指示格式转换器是否支持从指定的源格式编码转换。

isSpace(char) - Static method in class java.lang. Character

已过时。
替换为isWhitespace（char）。

isSpaceChar(char) - Static method in class java.lang. Character

确定指定的字符是否是Unicode空格字符。

isSpaceChar(int) - Static method in class java.lang. Character

确定指定字符（Unicode代码点）是否为Unicode空格字符。

isSpecified() - Method in interface javax.xml.stream.events. Attribute

指示该属性是否实际在其元素的起始标记中指定，或者是从模式中默认的标志。

isSpecified(int) - Method in class javax.xml.validation. TypeInfoProvider

如果该属性由验证器添加，则返回 false 。

isSpecified(int) - Method in interface org.xml.sax.ext. Attributes2

返回true，除非属性值由DTD默认提供。

isSpecified(int) - Method in class org.xml.sax.ext. Attributes2Impl

返回属性的“指定”标志的当前值。

isSpecified(String) - Method in interface org.xml.sax.ext. Attributes2

返回true，除非属性值由DTD默认提供。

isSpecified(String) - Method in class org.xml.sax.ext. Attributes2Impl

返回属性的“指定”标志的当前值。

isSpecified(String, String) - Method in interface org.xml.sax.ext. Attributes2

返回true，除非属性值由DTD默认提供。

isSpecified(String, String) - Method in class org.xml.sax.ext. Attributes2Impl

返回属性的“指定”标志的当前值。

isStandalone() - Method in enum java.time.format. TextStyle

如果Style是独立风格，则返回true。

isStandalone() - Method in interface javax.xml.stream.events. StartDocument

如果这个XML是独立的，则返回

isStandalone() - Method in class javax.xml.stream.util. StreamReaderDelegate

isStandalone() - Method in interface javax.xml.stream. XMLStreamReader

从xml声明获取独立声明

isStandard() - Method in class java.awt.font. GlyphMetrics

如果这是标准字形，则返回 true 。

isStandardImageMetadataFormatSupported() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回 true如果标准元数据格式是由所述识别的文档格式中 getAsTree种 setFromTree上产生或通过此插件消耗的图像元数据对象的方法。

isStandardMetadataFormatSupported() - Method in class javax.imageio.metadata. IIOMetadata

返回 true如果标准元数据格式是由支持 getMetadataFormat ， getAsTree ， setFromTree ，并 mergeTree 。

isStandardStreamMetadataFormatSupported() - Method in class javax.imageio.spi. ImageReaderWriterSpi

返回 true如果标准元数据格式是由所述识别的文档格式中 getAsTree种 setFromTree上产生或通过此插件消耗的流元数据对象的方法。

isStar() - Method in interface jdk.nashorn.api.tree. IdentifierTree

这个“*”在模块导出条目中使用吗？

isStar() - Method in interface jdk.nashorn.api.tree. YieldTree

这是生成函数中的yield *表达式吗？

isStarDefaultStar() - Method in interface jdk.nashorn.api.tree. IdentifierTree

在模块导出条目中使用这个“* default *”吗？

isStartDocument() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是一个StartDocument。

isStartElement() - Method in interface javax.xml.stream.events. XMLEvent

一个效用函数来检查这个事件是否是一个StartElement。

isStartElement() - Method in class javax.xml.stream.util. StreamReaderDelegate

isStartElement() - Method in interface javax.xml.stream. XMLStreamReader

如果光标指向起始标记（否则为false），则返回true

isStatement() - Method in enum jdk.nashorn.api.tree. Tree.Kind

如果这是一种语句树类型返回。

isStatic() - Method in interface com.sun.javadoc. ProgramElementDoc

已过时。

如果此程序元素是静态的，则返回true。

isStatic() - Method in interface com.sun.jdi. ReferenceType

确定此类型是否声明为静态。

isStatic() - Method in interface com.sun.jdi. TypeComponent

确定此TypeComponent是否为静态。

isStatic() - Method in interface com.sun.source.tree. BlockTree

当且仅当这是静态的初始化程序块时才返回true。

isStatic() - Method in interface com.sun.source.tree. ImportTree

如果这是静态导入声明，则返回true。

isStatic() - Method in interface com.sun.source.tree. RequiresTree

如果这是一个“require static”指令，则返回true。

isStatic() - Method in interface javax.lang.model.element. ModuleElement.RequiresDirective

返回这是否是静态依赖关系。

isStatic() - Method in class jdk.jshell. ImportSnippet

指示此代码段是否表示静态导入。

isStatic() - Method in interface jdk.nashorn.api.tree. PropertyTree

这是一个静态属性吗？

isStatic(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 static修改， false否则。

isStaticInitializer() - Method in interface com.sun.jdi. 方法

确定此方法是否为静态初始化程序。

isStillSincePress() - Method in class javafx.scene.input. MouseEvent

指示鼠标光标是否停留在系统提供的滞后区域内，因为在此事件之前发生的上次按下的事件。

isStrict() - Method in interface jdk.nashorn.api.tree. CompilationUnitTree

如果这是一个ECMAScript“严格”编译单元，则返回。

isStrict() - Method in interface jdk.nashorn.api.tree. FunctionDeclarationTree

这是一个严格的功能吗？

isStrict() - Method in interface jdk.nashorn.api.tree. FunctionExpressionTree

这是一个严格的功能吗？

isStrict(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 strictfp修改， false否则。

isStrictFunction() - Method in class jdk.nashorn.api.scripting. AbstractJSObject

isStrictFunction() - Method in interface jdk.nashorn.api.scripting. JSObject

这是一个'使用strict'功能对象吗？

isStrictFunction() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

isStrikethrough() - Method in class javafx.scene.text. Text

获取属性删除线的值。

isStrikeThrough() - Method in class javax.swing.text. GlyphView

确定字形是否应该有删除线。

isStrikeThrough() - Method in class javax.swing.text. LabelView

确定字形是否应该有删除线。

isStrikeThrough(AttributeSet) - Static method in class javax.swing.text. StyleConstants

检查是否设置了删除线属性。

isStringPainted() - Method in class javax.swing. JProgressBar

返回 stringPainted属性的值。

isStrokeUniform() - Method in class javafx.scene.layout. BorderStroke

均匀的笔触具有相同颜色，宽度和风格的全部（顶，底，左，右）笔画

isSubregion() - Method in class javax.swing.plaf.synth. Region

如果Region是Component的子区域，则返回true，否则返回false。

isSubscribed(Flow.Subscriber<? super T>) - Method in class java.util.concurrent. SubmissionPublisher

如果给定订阅者当前订阅，则返回true。

isSubscript() - Method in class javax.swing.text. GlyphView

确定字形是否应呈现为上标。

isSubscript() - Method in class javax.swing.text. LabelView

确定字形是否应呈现为上标。

isSubscript(AttributeSet) - Static method in class javax.swing.text. StyleConstants

检查下标属性是否设置。

isSubsignature(ExecutableType, ExecutableType) - Method in interface javax.lang.model.util. Types

测试一个方法的签名是否是另一个类的 子签名 。

isSubtype(Class<?>, Class<?>) - Static method in class jdk.dynalink.linker.support. TypeUtilities

根据JLS 4.10“子类型”确定一种类型是否是另一种类型的子类型。

isSubtype(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util. Types

测试一种类型是否是另一种类型。

isSuper() - Method in interface jdk.nashorn.api.tree. IdentifierTree

这个超级标识符是？

isSuperscript() - Method in class javax.swing.text. GlyphView

确定字形是否应呈现为下标。

isSuperscript() - Method in class javax.swing.text. LabelView

确定字形是否应呈现为下标。

isSuperscript(AttributeSet) - Static method in class javax.swing.text. StyleConstants

检查是否设置了上标属性。

isSupplementaryCodePoint(int) - Static method in class java.lang. Character

确定指定字符（Unicode代码点）是否在 supplementary character范围内。

isSupported() - Static method in class java.awt. SystemTray

返回当前平台是否支持系统托盘。

isSupported(Desktop.Action) - Method in class java.awt. Desktop

测试当前平台是否支持操作。

isSupported(Taskbar.Feature) - Method in class java.awt. Taskbar

测试当前平台是否支持 Feature 。

isSupported(String) - Static method in class java.nio.charset. Charset

告诉是否支持命名的字符集。

isSupported(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode

返回 false因为不支持DOM功能。

isSupported(String, String) - Method in interface org.w3c.dom. Node

测试DOM实现是否实现特定功能，并且此节点支持该功能，如下所述。

isSupported(TemporalField) - Method in interface java.time.chrono. ChronoLocalDate

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in interface java.time.chrono. ChronoLocalDateTime

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in interface java.time.chrono. ChronoZonedDateTime

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in interface java.time.chrono. Era

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time.chrono. JapaneseDate

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in enum java.time. DayOfWeek

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. Instant

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. LocalDate

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. LocalDateTime

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. LocalTime

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in enum java.time. Month

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. MonthDay

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. OffsetDateTime

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. OffsetTime

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in interface java.time.temporal. TemporalAccessor

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. Year

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. YearMonth

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. ZonedDateTime

检查指定的字段是否受支持。

isSupported(TemporalField) - Method in class java.time. ZoneOffset

检查指定的字段是否受支持。

isSupported(TemporalUnit) - Method in interface java.time.chrono. ChronoLocalDate

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in interface java.time.chrono. ChronoLocalDateTime

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in interface java.time.chrono. ChronoZonedDateTime

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. Instant

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. LocalDate

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. LocalDateTime

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. LocalTime

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. OffsetDateTime

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. OffsetTime

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in interface java.time.temporal. Temporal

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. Year

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. YearMonth

检查指定的单位是否受支持。

isSupported(TemporalUnit) - Method in class java.time. ZonedDateTime

检查指定的单位是否受支持。

isSupported(ConditionalFeature) - Static method in class javafx.application. Platform

查询平台是否支持特定条件功能。

isSupportedBy(Temporal) - Method in enum java.time.temporal. ChronoUnit

isSupportedBy(Temporal) - Method in interface java.time.temporal. TemporalUnit

检查本机是否受指定的时间对象的支持。

isSupportedBy(TemporalAccessor) - Method in enum java.time.temporal. ChronoField

isSupportedBy(TemporalAccessor) - Method in interface java.time.temporal. TemporalField

检查时间对象是否支持该字段。

isSupportedLocale(Locale) - Method in class java.util.spi. LocaleServiceProvider

如果本地区服务提供商支持给定的 locale则返回 true 。

isSupportedLookAndFeel() - Method in class javax.swing. LookAndFeel

如果底层平台支持和/或允许此外观，则返回 true 。

isSupportedLookAndFeel() - Method in class javax.swing.plaf.metal. MetalLookAndFeel

退货true ; MetalLookAndFeel可以在任何平台上运行。

isSupportedLookAndFeel() - Method in class javax.swing.plaf.multi. MultiLookAndFeel

退货true ; 每个平台都允许这种外观和感觉。

isSupportedLookAndFeel() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回true，始终支持SynthLookAndFeel。

isSupportedOption(String) - Method in class javax.tools. ForwardingJavaFileManager

isSupportedOption(String) - Method in interface javax.tools. OptionChecker

确定给定选项是否受支持，如果是，该选项的参数数量。

isSurrogate(char) - Static method in class java.lang. Character

确定给定的 char值是否是Unicode 代理代码单元 。

isSurrogatePair(char, char) - Static method in class java.lang. Character

确定指定的一对 char值是否有效 Unicode surrogate pair 。

isSuspended() - Method in interface com.sun.jdi. ThreadReference

确定线程是否已被调试器挂起。

isSuspended() - Method in class java.lang.management. ThreadInfo

测试与此 ThreadInfo相关联的线程是否暂停。

isSweepFlag() - Method in class javafx.scene.shape. ArcTo

获取属性sweepFlag的值。

isSymbolicLink() - Method in interface java.nio.file.attribute. BasicFileAttributes

告诉文件是否是符号链接。

isSymbolicLink(Path) - Static method in class java.nio.file. Files

测试文件是否是符号链接。

isSynchronizationSupported(Line[], boolean) - Method in interface javax.sound.sampled. Mixer

报告此混音器是否支持同步指定的一组行。

isSynchronized() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

如果此方法同步，返回true

isSynchronized() - Method in interface com.sun.jdi. 方法

确定此方法是否同步。

isSynchronized(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 synchronized修改， false否则。

isSynchronizerUsageSupported() - Method in interface java.lang.management. ThreadMXBean

测试Java虚拟机是否支持对 ownable synchronizer的使用情况的监控。

isSynthesized() - Method in interface com.sun.javadoc. AnnotationDesc

已过时。

检查注释上的合成位。

isSynthesized() - Method in class javafx.scene.input. MouseEvent

指示此事件是否使用触摸屏而不是通常的鼠标事件源设备（如鼠标或跟踪板）进行合成。

isSynthetic() - Method in interface com.sun.javadoc. MemberDoc

已过时。

如果该成员由编译器合成，则返回true。

isSynthetic() - Method in interface com.sun.jdi. TypeComponent

确定此TypeComponent是否合成。

isSynthetic() - Method in class java.lang. Class

如果此类是合成类，则返回true ; 否则返回false 。

isSynthetic() - Method in class java.lang.reflect. Constructor

如果这个可执行文件是一个合成的结构，则返回true ; 否则返回false 。

isSynthetic() - Method in class java.lang.reflect. Executable

如果这个可执行文件是一个合成的结构，则返回true ; 否则返回false 。

isSynthetic() - Method in class java.lang.reflect. Field

如果此字段是合成字段，则返回true ; 否则返回false 。

isSynthetic() - Method in interface java.lang.reflect. Member

如果该成员由编译器引入，则返回true ; 否则返回false 。

isSynthetic() - Method in class java.lang.reflect. 方法

如果这个可执行文件是一个合成结构，则返回true ; 否则返回false 。

isSynthetic() - Method in class java.lang.reflect. Parameter

返回true如果此参数既不在源代码中隐式也不显式声明; 否则返回false 。

isSystem() - Method in interface java.nio.file.attribute. DosFileAttributes

返回系统属性的值。

isTableMenuButtonVisible() - Method in class javafx.scene.control. TableView

获取属性tableMenuButtonVisible的值。

isTableMenuButtonVisible() - Method in class javafx.scene.control. TreeTableView

获取属性tableMenuButtonVisible的值。

isTargetEncodingSupported(AudioFormat.Encoding) - Method in class javax.sound.sampled.spi. FormatConversionProvider

指示格式转换器是否支持转换为指定的目标格式编码。

isTaskbarSupported() - Static method in class java.awt. Taskbar

测试此类是否在当前平台上得到支持。

isTearOff() - Method in class java.awt. Menu

指示此菜单是否为撕纸菜单。

isTearOff() - Method in class javax.swing. JMenu

如果菜单被拆除，则返回true。

isTemporary() - Method in class java.awt.event. FocusEvent

将焦点更改事件标识为临时或永久。

isTerminated() - Method in class java.nio.channels. AsynchronousChannelGroup

告诉本组是否已经终止。

isTerminated() - Method in interface java.util.concurrent. ExecutorService

如果所有任务在关闭后完成，则返回 true 。

isTerminated() - Method in class java.util.concurrent. ForkJoinPool

如果所有任务在关闭后完成，则返回 true 。

isTerminated() - Method in class java.util.concurrent. Phaser

如果此移相器已被终止，则返回 true 。

isTerminated() - Method in class java.util.concurrent. ThreadPoolExecutor

isTerminating() - Method in class java.util.concurrent. ForkJoinPool

如果终止程序已经开始但尚未完成，则返回 true 。

isTerminating() - Method in class java.util.concurrent. ThreadPoolExecutor

如果此执行者在 ThreadPoolExecutor.shutdown()或 ThreadPoolExecutor.shutdownNow()之后终止，但尚未完全终止，则返回true。

isText(Element) - Method in class javax.swing.text.html. MinimalHTMLWriter

如果元素是文本元素，则返回true。

isTextVisible() - Method in class javafx.scene.chart. Axis.TickMark

指示是否显示此刻度标签标签文本。

isThis() - Method in interface jdk.nashorn.api.tree. IdentifierTree

这是'这个'标识符吗？

isThreadAllocatedMemoryEnabled() - Method in interface com.sun.management. ThreadMXBean

测试是否启用了线程内存分配测量。

isThreadAllocatedMemorySupported() - Method in interface com.sun.management. ThreadMXBean

测试Java虚拟机实现是否支持线程内存分配测量。

isThreadContentionMonitoringEnabled() - Method in interface java.lang.management. ThreadMXBean

测试是否启用线程争用监控。

isThreadContentionMonitoringSupported() - Method in interface java.lang.management. ThreadMXBean

测试Java虚拟机是否支持线程争用监控。

isThreadCpuTimeEnabled() - Method in interface java.lang.management. ThreadMXBean

测试线程CPU时间测量是否启用。

isThreadCpuTimeSupported() - Method in interface java.lang.management. ThreadMXBean

测试Java虚拟机实现是否支持任何线程的CPU时间测量。

isThumbRollover() - Method in class javax.swing.plaf.basic. BasicScrollBarUI

如果鼠标当前在拇指上，则返回true。

isTickLabelsVisible() - Method in class javafx.scene.chart. Axis

获取属性tickLabelsVisible的值。

isTickMarkVisible() - Method in class javafx.scene.chart. Axis

获取属性tickMarkVisible的值。

isTileWritable(int, int) - Method in class java.awt.image. BufferedImage

返回是否当前签出拼贴以进行书写。

isTileWritable(int, int) - Method in interface java.awt.image. WritableRenderedImage

返回是否当前签出图块以进行写入。

isTimeBased() - Method in enum java.time.temporal. ChronoField

检查此字段是否表示时间的一个组成部分。

isTimeBased() - Method in enum java.time.temporal. ChronoUnit

检查本机是否是时间单位。

isTimeBased() - Method in interface java.time.temporal. TemporalField

检查此字段是否表示时间的一个组成部分。

isTimeBased() - Method in interface java.time.temporal. TemporalUnit

检查本机是否代表时间的一个组成部分。

isTimeSet - Variable in class java.util. Calendar

如果那么 time的值是有效的， time真。

isTitleCase(char) - Static method in class java.lang. Character

确定指定的字符是否是一个titlecase字符。

isTitleCase(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是否是一个titlecase字符。

isToggleEvent(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回 true表示鼠标下的行应根据事件切换。

isToggleSelectionEvent(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI

返回 true表示节点上的鼠标事件应该只切换鼠标下的行的选择。

isTopAsPercentage() - Method in class javafx.scene.layout. BorderWidths

指定 top属性是否应解释为区域高度的百分比（ true ）（ false ）。

isTopDown() - Method in class javax.imageio.plugins.bmp. BMPImageWriteParam

返回 topDown参数的值。

isTopLeftHorizontalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 topLeftHorizontalRadius解释为值或百分比。

isTopLeftVerticalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 topLeftVerticalRadius解释为值或百分比。

isTopLevelMenu() - Method in class javax.swing. JMenu

如果菜单是“顶级菜单”，则返回true，即如果它是菜单栏的直接子菜单。

isTopRightHorizontalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 topRightHorizontalRadius解释为值或百分比。

isTopRightVerticalRadiusAsPercentage() - Method in class javafx.scene.layout. CornerRadii

表示是否将 topRightVerticalRadius解释为值或百分比。

isTransferable() - Method in interface org.ietf.jgss. GSSContext

通过使用 export方法确定上下文是否可转移到其他进程。

isTransformed() - Method in class java.awt.font. FontRenderContext

指示此 FontRenderContext对象是否测量转换后的渲染上下文中的文本。

isTransformed() - Method in class java.awt. Font

指示此 Font对象是否具有影响其大小的变换以及Size属性。

isTransient() - Method in interface com.sun.javadoc. FieldDoc

已过时。

如果这个字段是短暂的，返回true

isTransient() - Method in interface com.sun.jdi. Field

确定这是否是一个瞬态场。

isTransient(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 transient修改， false否则。

isTransitive() - Method in interface com.sun.source.tree. RequiresTree

如果这是一个“需要传递”的指令，则返回true。

isTransitive() - Method in interface javax.lang.model.element. ModuleElement.RequiresDirective

返回这是否是传递依赖关系。

isTranslucencyCapable() - Method in class java.awt. GraphicsConfiguration

返回是否 GraphicsConfiguration支持 PERPIXEL_TRANSLUCENT的半透明。

isTraversable(File) - Method in class javax.swing.filechooser. FileSystemView

如果可以访问文件（目录），则返回true。

isTraversable(File) - Method in class javax.swing.filechooser. FileView

该目录是否可遍历。

isTraversable(File) - Method in class javax.swing. JFileChooser

如果可以访问文件（目录），则返回true。

IstringHelper - Class in org.omg.CosNaming

org / omg / CosNaming / IstringHelper.java。

IstringHelper() - Constructor for class org.omg.CosNaming. IstringHelper

isTrueVolatile() - Method in class java.awt. ImageCapabilities

如果由 VolatileImage描述的 ImageCapabilities可以丢失其表面，则返回 true 。

isType2D() - Method in class javafx.scene.transform. Transform

获取属性type2D的值。

isTypeParameter() - Method in interface com.sun.javadoc. ParamTag

已过时。

如果此 ParamTag对应于类型参数，则返回true。

isTypeParameter() - Method in interface com.sun.source.doctree. ParamTree

如果这是记录类型参数，则返回true。

isTypeSubstituted() - Method in class javax.xml.bind. JAXBElement

如果此xml元素实例的值与xml元素声明的声明类型具有不同的类型，则返回true。

isUndecorated() - Method in class java.awt. Dialog

指示此对话框是否未装饰。

isUndecorated() - Method in class java.awt. Frame

指示此框架是否未装饰。

isUndefined(Object) - Static method in class jdk.nashorn.api.scripting. ScriptObjectMirror

检查给定对象的实用程序是否为ECMAScript未定义的值

isUnderflow() - Method in class java.nio.charset. CoderResult

告知该对象是否描述了下溢条件。

isUnderline() - Method in class javafx.scene.control. Labeled

获取属性下划线的值。

isUnderline() - Method in class javafx.scene.text. Text

获取属性下划线的值。

isUnderline() - Method in class javax.swing.text. GlyphView

确定字形是否应加下划线。

isUnderline() - Method in class javax.swing.text. LabelView

确定字形是否应加下划线。

isUnderline(AttributeSet) - Static method in class javax.swing.text. StyleConstants

检查是否设置了下划线属性。

isUndoable() - Method in class javafx.scene.control. TextInputControl

200新200新新新200新200新200新200新新新200新200新新新200新新新200新新200新新200新新新新旗新新200新新200新新200新

isUnicast() - Method in class java.beans. EventSetDescriptor

通常情况来源是组播。

isUnicodeIdentifierPart(char) - Static method in class java.lang. Character

确定指定的字符是否可以是Unicode标识符的一部分，而不是第一个字符。

isUnicodeIdentifierPart(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是否可能是Unicode标识符的一部分，而不是第一个字符。

isUnicodeIdentifierStart(char) - Static method in class java.lang. Character

确定指定字符是否允许为Unicode标识符中的第一个字符。

isUnicodeIdentifierStart(int) - Static method in class java.lang. Character

确定Unicode标识符中的第一个字符是否允许指定的字符（Unicode代码点）。

isUniform() - Method in class javafx.scene.layout. CornerRadii

指示每个拐角半径是否完全相同，并且每个角半径均为基于百分比或不均匀。

isUnique() - Static method in class java.rmi.dgc. VMID

已过时。

isUnknown() - Method in class javafx.util. Duration

获取此Duration实例是否为未知。

isUnmappable() - Method in class java.nio.charset. CoderResult

告知该对象是否描述不可映射的字符错误。

isUnnamed() - Method in interface javax.lang.model.element. ModuleElement

返回 true ，如果这是一个未命名的模块和 false否则。

isUnnamed() - Method in interface javax.lang.model.element. PackageElement

返回 true如果这是一个未命名的包和 false否则。

isUnordered() - Method in class com.sun.nio.sctp. MessageInfo

告知邮件是否无序。

isUnresolved() - Method in class java.net. InetSocketAddress

检查地址是否已解决。

isUnseqToken() - Method in class org.ietf.jgss. MessageProp

测试后一个令牌是否已被处理。

isUnshared() - Method in class java.io. ObjectStreamField

返回指示此ObjectStreamField实例表示的可序列化字段是否未共享的布尔值。

isUp() - Method in class java.net. NetworkInterface

返回网络接口是否启动并运行。

isUpperCase(char) - Static method in class java.lang. Character

确定指定的字符是否为大写字符。

isUpperCase(int) - Static method in class java.lang. Character

确定指定的字符（Unicode代码点）是否为大写字符。

isUpToDate() - Method in class jdk.jshell. SourceCodeAnalysis.QualifiedNames

指示结果是否基于最新数据。

isUsageThresholdExceeded() - Method in interface java.lang.management. MemoryPoolMXBean

测试此内存池的内存使用情况是否达到或超过其使用阈值。

isUsageThresholdSupported() - Method in interface java.lang.management. MemoryPoolMXBean

测试此内存池是否支持使用阈值。

isUserInRole(String) - Method in class javax.xml.ws.spi.http. HttpExchange

指示经过身份验证的用户是否包含在指定的逻辑“角色”中。

isUserInRole(String) - Method in interface javax.xml.ws. WebServiceContext

返回一个布尔值，指示经过身份验证的用户是否包含在指定的逻辑角色中。

isUserNode() - Method in class java.util.prefs. AbstractPreferences

实现 isUserNode方法按照在本说明书中 Preferences.isUserNode() 。

isUserNode() - Method in class java.util.prefs. Preferences

返回 true如果此首选项节点位于用户首选项树， false ，如果它在系统首选项树。

isUseSystemMenuBar() - Method in class javafx.scene.control. MenuBar

获取propertySystemMenuBar属性的值。

isValid() - Method in class java.awt. Component

确定此组件是否有效。

isValid() - Method in class java.awt.image. IndexColorModel

返回所有像素是否有效。

isValid() - Method in interface java.lang.management. MemoryManagerMXBean

测试此内存管理器是否在Java虚拟机中有效。

isValid() - Method in interface java.lang.management. MemoryPoolMXBean

测试此内存池是否在Java虚拟机中有效。

isValid() - Method in class java.nio.channels. FileLock

告诉这个锁是否有效。

isValid() - Method in class java.nio.channels. MembershipKey

告知这个会员资格是否有效。

isValid() - Method in class java.nio.channels. SelectionKey

告知这个密钥是否有效。

isValid() - Method in class java.nio.channels.spi. AbstractSelectionKey

isValid() - Method in interface java.nio.file. WatchKey

告知这个手表键是否有效。

isValid() - Method in interface javafx.beans.binding. Binding

检查绑定是否有效。

isValid() - Method in class javafx.beans.binding. BooleanBinding

isValid() - Method in class javafx.beans.binding. DoubleBinding

isValid() - Method in class javafx.beans.binding. FloatBinding

isValid() - Method in class javafx.beans.binding. IntegerBinding

isValid() - Method in class javafx.beans.binding. ListBinding

isValid() - Method in class javafx.beans.binding. LongBinding

isValid() - Method in class javafx.beans.binding. MapBinding

isValid() - Method in class javafx.beans.binding. ObjectBinding

isValid() - Method in class javafx.beans.binding. SetBinding

isValid() - Method in class javafx.beans.binding. StringBinding

isValid() - Method in class javax.accessibility. AccessibleHyperlink

由于链接关联的文档可能已更改，因此此方法将返回此链接是否仍然有效（相对于其引用的文档）。

isValid() - Method in interface javax.management. Descriptor

如果所有字段都具有给定名称的合法值，则返回true。

isValid() - Method in class javax.management. ImmutableDescriptor

如果所有字段都具有给定名称的合法值，则返回true。

isValid() - Method in class javax.management.modelmbean. DescriptorSupport

如果所有字段都具有给定名称的合法值，则返回true。

isValid() - Method in interface javax.net.ssl. SSLSession

返回此会话是否有效并可用于恢复或加入。

isValid() - Method in class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

由于链接关联的文档可能已更改，因此此方法将返回此链接是否有效（相对于其引用的文档）。

isValid() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController

如果拖动会话有效，则返回 true 。

isValid() - Method in class javax.swing.text.html. HTMLDocument.Iterator

指示迭代器当前是否表示标签的出现。

isValid() - Method in class javax.xml.datatype. XMLGregorianCalendar

验证实例 getXMLSchemaType()约束。

isValid(int) - Method in interface com.sun.jdi.connect. Connector.IntegerArgument

对参数进行基本的理性检查。

isValid(int) - Method in class java.awt.image. IndexColorModel

返回像素是否有效。

isValid(int) - Method in interface java.sql. Connection

如果连接尚未关闭并且仍然有效，则返回true。

isValid(String) - Method in interface com.sun.jdi.connect. Connector.Argument

对参数进行基本的理性检查。

isValid(String) - Method in interface com.sun.jdi.connect. Connector.BooleanArgument

对参数进行基本的理性检查。

isValid(String) - Method in interface com.sun.jdi.connect. Connector.IntegerArgument

对参数进行基本的理性检查。

isValid(String) - Method in interface com.sun.jdi.connect. Connector.SelectedArgument

对参数进行基本的理性检查。

isValid(String) - Method in interface com.sun.jdi.connect. Connector.StringArgument

对参数进行基本的理性检查。

isValidateRoot() - Method in class java.applet. Applet

已过时。

指示此容器是否为验证根。

isValidateRoot() - Method in class java.awt. Container

指示此容器是否为 验证根 。

isValidateRoot() - Method in class java.awt. Window

指示此容器是否为验证根。

isValidateRoot() - Method in class javax.swing. JComponent

如果此方法返回true， revalidate此组件的后代的调用将导致从该根开始的整个树被验证。

isValidateRoot() - Method in class javax.swing. JRootPane

如果这个 JRootPane的后代 JRootPane给 revalidate ，从这里下来验证。

isValidateRoot() - Method in class javax.swing. JScrollPane

被 revalidate返回true，所以对这个 JScrollPane任何后代的任何调用 JScrollPane将导致从这个 JScrollPane开始的整个树被验证。

isValidateRoot() - Method in class javax.swing. JSplitPane

返回true，因此对此 revalidate的任何后代的 JSplitPane将导致请求排队，这将验证 JSplitPane及其所有后代。

isValidateRoot() - Method in class javax.swing. JTextField

来自textfield本身的 revalidate调用将通过验证文本字段来处理，除非textfield包含在一个 JViewport ，在这种情况下返回false。

isValidating() - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

指示Unmarshaller是否配置为在解组操作期间进行验证。

isValidating() - Method in interface javax.xml.bind. Unmarshaller

已过时。
由于JAXB2.0 ，请参阅Unmarshaller.getSchema()

isValidating() - Method in class javax.xml.parsers. DocumentBuilder

指示此解析器是否配置为验证XML文档。

isValidating() - Method in class javax.xml.parsers. DocumentBuilderFactory

指示工厂是否配置为生成在解析期间验证XML内容的解析器。

isValidating() - Method in class javax.xml.parsers. SAXParser

指示此解析器是否配置为验证XML文档。

isValidating() - Method in class javax.xml.parsers. SAXParserFactory

指示工厂是否配置为生成在解析期间验证XML内容的解析器。

isValidCodePoint(int) - Static method in class java.lang. Character

确定指定的代码点是否有效 Unicode code point value 。

isValidDay(int) - Method in class java.time. YearMonth

检查月日是否在今年有效。

isValidIntValue(long) - Method in class java.time.temporal. ValueRange

检查值是否在有效范围内，范围内的所有值都适合 int 。

isValidMonthDay(MonthDay) - Method in class java.time. Year

检查今年的月日是否有效。

isValidOffset(LocalDateTime, ZoneOffset) - Method in class java.time.zone. ZoneRules

检查偏移日期时间对于这些规则是否有效。

isValidOffset(ZoneOffset) - Method in class java.time.zone. ZoneOffsetTransition

在此转换期间检查指定的偏移是否有效。

isValidValue(long) - Method in class java.time.temporal. ValueRange

检查该值是否在有效范围内。

isValidYear(int) - Method in class java.time. MonthDay

检查年份是否适用于本月。

isValue(Object) - Method in class javax.management.openmbean. ArrayType

测试 obj是否为此 ArrayType实例的值。

isValue(Object) - Method in class javax.management.openmbean. CompositeType

测试 obj是否可以由此 CompositeType实例描述的值。

isValue(Object) - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport

测试 obj是 OpenMBeanAttributeInfoSupport实例描述的属性的 OpenMBeanAttributeInfoSupport 。

isValue(Object) - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

测试 obj是否为此 OpenMBeanParameterInfo实例描述的参数的 OpenMBeanParameterInfo 。

isValue(Object) - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport

测试 obj是 OpenMBeanParameterInfo实例描述的参数的 OpenMBeanParameterInfo 。

isValue(Object) - Method in class javax.management.openmbean. OpenType

测试 obj是否是此打开类型的值。

isValue(Object) - Method in class javax.management.openmbean. SimpleType

测试 obj是否为此 SimpleType实例的值。

isValue(Object) - Method in class javax.management.openmbean. TabularType

测试 obj是否可以由此 TabularType实例描述的值。

isValueChanging() - Method in class javafx.scene.control. Slider

获取属性valueChanging的值。

isValueOnAxis(String) - Method in class javafx.scene.chart. CategoryAxis

检查给定值是否在该轴上是可绘制的

isValueOnAxis(T) - Method in class javafx.scene.chart. Axis

检查给定值是否在该轴上是可绘制的

isValueOnAxis(T) - Method in class javafx.scene.chart. ValueAxis

检查给定值是否在该轴上是可绘制的

isVarArgs() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

如果此方法被声明为使用可变数量的参数，则返回true。

isVarArgs() - Method in interface com.sun.jdi. 方法

确定此方法是否接受可变数量的参数。

isVarArgs() - Method in interface java.lang.invoke. MethodHandleInfo

确定底层成员是变量arity方法还是构造函数。

isVarArgs() - Method in class java.lang.reflect. Constructor

如果此可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。

isVarArgs() - Method in class java.lang.reflect. Executable

如果这个可执行文件被声明为使用可变数量的参数，则返回true ; 否则返回false 。

isVarArgs() - Method in class java.lang.reflect. 方法

如果此可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。

isVarArgs() - Method in class java.lang.reflect. Parameter

如果此参数表示可变参数列表，则返回true ; 否则返回false 。

isVarArgs() - Method in interface javax.lang.model.element. ExecutableElement

返回 true如果此方法或构造接受可变数量的参数，并返回 false否则。

isVarargsCollector() - Method in class java.lang.invoke. MethodHandle

确定此方法是否支持 variable arity调用。

isVerbose() - Method in interface java.lang.management. ClassLoadingMXBean

测试类加载系统的详细输出是否启用。

isVerbose() - Method in interface java.lang.management. MemoryMXBean

测试是否启用了内存系统的详细输出。

isVerified() - Method in interface com.sun.jdi. ReferenceType

确定此类型是否已被验证。

isVertical() - Method in class java.awt.font. TextLayout

如果这个 TextLayout是垂直的，则返回 true 。

isVertical() - Method in enum javafx.geometry. Side

指示这是否是一个矩形的垂直边（返回 true为 LEFT和 RIGHT 。

isVertical() - Method in class javafx.scene.control.skin. VirtualFlow

获取属性垂直的值。

isVerticalAsPercentage() - Method in class javafx.scene.layout. BackgroundPosition

指定 verticalPosition是否应解释为文字数字或百分比。

isVerticalFieldOfView() - Method in class javafx.scene. PerspectiveCamera

获取属性verticalFieldOfView的值。

isVerticalZeroLineVisible() - Method in class javafx.scene.chart. XYChart

获取属性verticalZeroLineVisible的值。

isViewSizeSet - Variable in class javax.swing. JViewport

当确定视口尺寸时为真。

isVirtual() - Method in class java.net. NetworkInterface

返回此接口是否为虚拟接口（也称为子接口）。

isVisible() - Method in class com.sun.java.accessibility.util. Translator

确定对象是否可见。

isVisible() - Method in class java.awt. Component.AccessibleAWTComponent

确定对象是否可见。

isVisible() - Method in class java.awt. Component

确定当该组件的父级可见时是否应该可见。

isVisible() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

确定对象是否可见。

isVisible() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

确定对象是否可见。

isVisible() - Method in class java.awt. SplashScreen

确定启动屏幕是否可见。

isVisible() - Method in class javafx.scene.control. MenuItem

获取属性的值可见。

isVisible() - Method in class javafx.scene.control. TableColumnBase

获取属性的值可见。

isVisible() - Method in class javafx.scene. Node

获取属性的值可见。

isVisible() - Method in interface javax.accessibility. AccessibleComponent

确定对象是否可见。

isVisible() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

isVisible() - Method in class javax.swing. JPopupMenu

如果弹出菜单可见（正在显示），则返回true。

isVisible() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

确定此对象是否可见。

isVisible() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

isVisible() - Method in interface javax.swing.plaf.basic. ComboPopup

如果弹出窗口可见（正在显示），则返回true。

isVisible() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

isVisible() - Method in interface javax.swing.text. Caret

确定插入符号当前是否可见。

isVisible() - Method in class javax.swing.text. DefaultCaret

指示插入符号是否可见。

isVisible() - Method in class javax.swing.text.html. ParagraphView

指示是否显示此视图。

isVisible() - Method in class javax.swing.text. View

返回一个布尔值，指示视图是否可见。

isVisible(StackFrame) - Method in interface com.sun.jdi. LocalVariable

确定是否可以从给定的StackFrame访问此变量。

isVisible(TreePath) - Method in class javax.swing. JTree

如果由path标识的值当前是可视的，则返回true，这意味着它是根或全部的父对象被展开。

isVisited() - Method in class javafx.scene.control. Hyperlink

获取访问的属性的值。

isVolatile() - Method in interface com.sun.javadoc. FieldDoc

已过时。

如果此字段不稳定，返回true

isVolatile() - Method in interface com.sun.jdi. Field

确定这是否是一个易失性的领域。

isVolatile(int) - Static method in class java.lang.reflect. Modifier

返回 true如果整数参数包括 volatile修改， false否则。

isWeak(byte[], int) - Static method in class javax.crypto.spec. DESKeySpec

检查给定的DES密钥材料是弱还是弱弱。

isWebBrowserSupported() - Method in interface javax.jnlp. BasicService

检查当前平台和给定的JNLP客户端是否支持Web浏览器。

isWeekDateSupported() - Method in class java.util. Calendar

是否返回 Calendar是否支持星期。

isWeekDateSupported() - Method in class java.util. GregorianCalendar

返回 true表示 GregorianCalendar支持周日期。

isWheelScrollingEnabled() - Method in class java.awt. ScrollPane

指示是否会响应于鼠标滚轮进行滚动。

isWheelScrollingEnabled() - Method in class javax.swing. JScrollPane

指示是否会响应于鼠标滚轮进行滚动。

isWhitespace() - Method in class java.awt.font. GlyphMetrics

如果这是空白字形，则返回 true 。

isWhitespace(char) - Static method in class java.lang. Character

根据Java确定指定的字符是否为空格。

isWhitespace(int) - Static method in class java.lang. Character

根据Java确定指定字符（Unicode代码点）是否为空格。

isWhiteSpace() - Method in interface javax.xml.stream.events. Characters

如果这组字符都是空格，则返回true。

isWhiteSpace() - Method in class javax.xml.stream.util. StreamReaderDelegate

isWhiteSpace() - Method in interface javax.xml.stream. XMLStreamReader

如果游标指向由所有空格组成的字符数据事件，则返回true

isWhiteSpace(char) - Static method in class javax.xml.bind.annotation.adapters. CollapsedStringAdapter

如果指定的字符是空白字符，则返回true。

isWhiteSpaceExceptSpace(char) - Static method in class javax.xml.bind.annotation.adapters. NormalizedStringAdapter

如果指定的字符是空白字符而不是0x20，则返回true。

isWhitespaceKey() - Method in enum javafx.scene.input. KeyCode

空格，制表符并输入

isWidthAsPercentage() - Method in class javafx.scene.layout. BackgroundSize

指定 width包含的值是否应解释为百分比或正常值。

isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency) - Method in class java.awt. GraphicsDevice

返回此图形设备是否支持给定的半透明级别。

isWrap() - Method in class javafx.scene.effect. DisplacementMap

获取属性包装的值。

isWrapAround() - Method in class javafx.scene.control. SpinnerValueFactory

获取属性wrapAround的值。

isWrapperFor(Class<?>) - Method in interface java.sql. Wrapper

如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。

isWrapperFor(Class<?>) - Method in class javax.sql.rowset. RowSetMetaDataImpl

如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。

isWrapperInstance(Object) - Static method in class java.lang.invoke. MethodHandleProxies

确定给定对象是否通过调用 asInterfaceInstance生成 。

isWrapperType(Class<?>) - Static method in class jdk.dynalink.linker.support. TypeUtilities

如果传递的类型是原始类型的包装器，则返回true。

isWrapText() - Method in class javafx.scene.control. Labeled

获取propertyTextText的值。

isWrapText() - Method in class javafx.scene.control. TextArea

获取propertyTextText的值。

isWrapText() - Method in class javafx.scene.control. Tooltip

获取propertyTextText的值。

isWritable() - Method in class java.nio.channels. SelectionKey

测试此密钥的通道是否准备好进行写入。

isWritable() - Method in class javafx.scene.image. PixelFormat

如果这个 PixelFormat对象可以将颜色信息转换为像素表示，则返回true。

isWritable() - Method in class javafx.scene.image. WritablePixelFormat

isWritable() - Method in class javax.management. MBeanAttributeInfo

是否可以将新值写入属性。

isWritable() - Method in interface javax.management.openmbean. OpenMBeanAttributeInfo

返回 true如果此描述的属性 OpenMBeanAttributeInfo实例是可写的， false否则。

isWritable() - Method in class javax.management.relation. RoleInfo

返回角色的写访问模式（如果可写，则为true）。

isWritable(int) - Method in interface java.sql. ResultSetMetaData

指示指定列上的写入是否成功。

isWritable(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

指示指定列上的写操作是否可以成功。

isWritable(Path) - Static method in class java.nio.file. Files

测试文件是否可写。

isWriteable() - Method in class com.sun.management. VMOption

测试此VM选项是否可写。

isWriteLocked() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

查询写锁是否由任何线程持有。

isWriteLocked() - Method in class java.util.concurrent.locks. StampedLock

如果锁当前仅被 true则返回 true 。

isWriteLockedByCurrentThread() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

查询写锁是否由当前线程持有。

isXIncludeAware() - Method in class javax.xml.parsers. DocumentBuilder

获取此解析器的XInclude处理模式。

isXIncludeAware() - Method in class javax.xml.parsers. DocumentBuilderFactory

获取XInclude处理的状态。

isXIncludeAware() - Method in class javax.xml.parsers. SAXParser

获取此解析器的XInclude处理模式。

isXIncludeAware() - Method in class javax.xml.parsers. SAXParserFactory

获取XInclude处理的状态。

isXOPPackage() - Method in class javax.xml.bind.attachment. AttachmentMarshaller

只读属性，如果JAXB编组器应该启用XOP创建，则返回true。

isXOPPackage() - Method in class javax.xml.bind.attachment. AttachmentUnmarshaller

只读属性，如果JAXB解组器需要执行XOP处理，则返回true。

isZero() - Method in interface java.time.chrono. ChronoPeriod

检查此期间所有受支持的单位是否为零。

isZero() - Method in class java.time. Duration

检查此持续时间是否为零长度。

isZero() - Method in class java.time. Period

检查此期间的所有三个单位是否为零。

isZoneLoaded(View) - Method in class javax.swing.text. ZoneView

确定区域是否处于加载状态。

ITALIAN - Static variable in class java.util. Locale

有用的语言常数

Italic - Static variable in class javax.swing.text. StyleConstants

斜体属性的名称。

ITALIC - javafx.scene.text. FontPosture

代表斜体

ITALIC - javafx.scene.web. HTMLEditorSkin.Command

ITALIC - Static variable in class java.awt. Font

斜体风格常数。

ITALIC_ACTION - Static variable in class javax.swing.text.html. HTMLEditorKit

斜体动作标识符

ItalicAction() - Constructor for class javax.swing.text. StyledEditorKit.ItalicAction

构造一个新的斜体动作。

ITALY - Static variable in class java.awt. PageAttributes.MediaType

ITALY_ENVELOPE的别名。

ITALY - Static variable in class java.util. Locale

对国家有用的常数。

ITALY_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType

意大利信封的MediaType实例，110 x 230毫米。

ITALY_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.Other

指定意大利信封尺寸，110 mm×230 mm。

ITALY_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName

意大利信封尺寸。

item(int) - Method in class javax.imageio.metadata. IIOMetadataNode

item(int) - Method in class org.omg.CORBA. ContextList

返回给定索引处的 String对象。

item(int) - Method in class org.omg.CORBA. ExceptionList

返回给定索引处的 TypeCode对象。

item(int) - Method in class org.omg.CORBA. NVList

检索给定索引中的 NamedValue对象。

item(int) - Method in interface org.w3c.dom.css. CSSRuleList

用于通过序数索引检索CSS规则。

item(int) - Method in interface org.w3c.dom.css. CSSStyleDeclaration

用于检索在此声明块中已显式设置的属性。

item(int) - Method in interface org.w3c.dom.css. CSSValueList

用于通过序数索引检索 CSSValue 。

item(int) - Method in interface org.w3c.dom. DOMImplementationList

返回集合中的 index项目。

item(int) - Method in interface org.w3c.dom. DOMStringList

返回集合中的 index项目。

item(int) - Method in interface org.w3c.dom.html. HTMLCollection

此方法检索由序数索引指定的节点。

item(int) - Method in interface org.w3c.dom. NamedNodeMap

返回地图中的 index项目。

item(int) - Method in interface org.w3c.dom. NodeList

返回集合中的 index项。

item(int) - Method in interface org.w3c.dom.stylesheets. MediaList

返回列表中的 index th。

item(int) - Method in interface org.w3c.dom.stylesheets. StyleSheetList

用于通过序数索引检索样式表。

ITEM - Static variable in class com.sun.java.accessibility.util. EventID

映射到AWT项目支持（即ItemListener和ItemEvent）

ITEM_AT_INDEX - javafx.scene. AccessibleAttribute

返回给定索引处的项目。

ITEM_COUNT - javafx.scene. AccessibleAttribute

返回节点的项目计数。

ITEM_EVENT_MASK - Static variable in class java.awt. AWTEvent

用于选择项目事件的事件掩码。

ITEM_FIRST - Static variable in class java.awt.event. ItemEvent

用于项目事件的ids范围中的第一个数字。

ITEM_LAST - Static variable in class java.awt.event. ItemEvent

用于项目事件的ID的范围中的最后一个数字。

ITEM_STATE_CHANGED - Static variable in class java.awt.event. ItemEvent

此事件id表示项目状态已更改。

ItemEvent - Class in java.awt.event

表示选择或取消选择项目的语义事件。

ItemEvent(ItemSelectable, int, Object, int) - Constructor for class java.awt.event. ItemEvent

构造一个 ItemEvent对象。

ItemHandler() - Constructor for class javax.swing.plaf.basic. BasicComboBoxUI.ItemHandler

ItemHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.ItemHandler

itemListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor

不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。

itemListener - Variable in class javax.swing. AbstractButton

按钮型号 ItemListener 。

itemListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI

此保护字段是实现特定的。

itemListener - Variable in class javax.swing.plaf.basic. BasicComboPopup

此保护字段是实现特定的。

ItemListener - Interface in java.awt.event

用于接收项目事件的侦听器接口。

itemProperty() - Method in class javafx.scene.control. Cell

与该单元格相关联的数据值。

ItemSelectable - Interface in java.awt

可以选择包含零个或多个项目的对象的对象接口。

itemsProperty() - Method in class javafx.scene.control. ChoiceBox

要在选框中显示的项目。

itemsProperty() - Method in class javafx.scene.control. ComboBox

在ComboBox弹出窗口中显示的项目列表。

itemsProperty() - Method in class javafx.scene.control. ListView

ListView的底层数据模型。

itemsProperty() - Method in class javafx.scene.control. SpinnerValueFactory.ListSpinnerValueFactory

ListView的底层数据模型。

itemsProperty() - Method in class javafx.scene.control. TableView

TableView的基础数据模型。

itemStateChanged(ItemEvent) - Method in class java.awt. AWTEventMulticaster

通过调用listener-a和listener-b上的itemStateChanged方法来处理itemStateChanged事件。

itemStateChanged(ItemEvent) - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

当触发按钮的状态改变时，可触及的属性更改事件。

itemStateChanged(ItemEvent) - Method in interface java.awt.event. ItemListener

当用户选择或取消选择项目时调用。

itemStateChanged(ItemEvent) - Method in class java.awt. List.AccessibleAWTList

itemStateChanged(ItemEvent) - Method in class javax.swing. DefaultCellEditor.EditorDelegate

当项目的状态改变时，编辑结束。

itemStateChanged(ItemEvent) - Method in class javax.swing. JToggleButton.AccessibleJToggleButton

当触发按钮的状态改变时，可触及的属性更改事件。

itemStateChanged(ItemEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ItemHandler

itemStateChanged(ItemEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ItemHandler

Iterable< T> - Interface in java.lang

实现此接口允许对象成为增强型 for语句的目标（有时称为“for-each loop”语句）。

iterate(double, DoublePredicate, DoubleUnaryOperator) - Static method in interface java.util.stream. DoubleStream

返回通过将给定的 next函数迭代应用于初始元素 DoubleStream产生的顺序 DoubleStream ，其条件是满足给定的 hasNext谓词。

iterate(double, DoubleUnaryOperator) - Static method in interface java.util.stream. DoubleStream

返回有序无限连续 DoubleStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等

iterate(int, IntPredicate, IntUnaryOperator) - Static method in interface java.util.stream. IntStream

返回通过将给定的 next函数迭代应用于初始元素 IntStream产生的顺序的 IntStream ，其条件是满足给定的 hasNext谓词。

iterate(int, IntUnaryOperator) - Static method in interface java.util.stream. IntStream

返回有序无限连续 IntStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等

iterate(long, LongPredicate, LongUnaryOperator) - Static method in interface java.util.stream. LongStream

返回通过将给定的 next函数迭代应用于初始元素 LongStream产生的顺序 LongStream ，其条件是满足给定的 hasNext谓词。

iterate(long, LongUnaryOperator) - Static method in interface java.util.stream. LongStream

返回有序无限连续 LongStream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等

iterate(T, Predicate<? super T>, UnaryOperator<T>) - Static method in interface java.util.stream. Stream

返回通过将给定的 next函数迭代应用于初始元素 Stream产生的顺序排列的 Stream ，其条件是满足给定的 hasNext谓词。

iterate(T, UnaryOperator<T>) - Static method in interface java.util.stream. Stream

返回有序无限连续 Stream由函数的迭代应用产生 f到初始元素 seed ，产生 Stream由 seed ， f(seed) ， f(f(seed))等

iteratedLoop(MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles

构造一个范围超过由 Iterator<T>生成的值的 Iterator<T> 。

iterateNext() - Method in interface org.w3c.dom.xpath. XPathResult

如果没有更多的节点，迭代并返回节点集中的下一个节点，或者 null 。

iterationsProperty() - Method in class javafx.scene.effect. BoxBlur

迭代模糊效果以提高其“质量”或“平滑度”的次数。

iterator() - Method in class com.sun.source.util. DocTreePath

iterator() - Method in class com.sun.source.util. TreePath

从叶到叶重迭。

iterator() - Method in class java.awt.dnd. DragGestureEvent

对于包含手势的事件，返回一个 Iterator 。

iterator() - Method in class java.beans.beancontext. BeanContextMembershipEvent

获取受此事件影响的子项数组。

iterator() - Method in class java.beans.beancontext. BeanContextSupport

获取当前嵌套在此 BeanContext中的所有JavaBean或 BeanContext实例。

iterator() - Method in interface java.lang. Iterable

返回类型为 T元素的迭代器。

iterator() - Method in interface java.nio.file. DirectoryStream

返回与此 DirectoryStream相关联的迭代器。

iterator() - Method in interface java.nio.file. Path

返回此路径的名称元素的迭代器。

iterator() - Method in exception java.sql. SQLException

返回链接的SQLExceptions的迭代器。

iterator() - Method in class java.util. AbstractCollection

返回包含在该集合中的元素的迭代器。

iterator() - Method in class java.util. AbstractList

以正确的顺序返回该列表中的元素的迭代器。

iterator() - Method in class java.util. AbstractSequentialList

返回此列表中的元素的迭代器（按适当的顺序）。

iterator() - Method in class java.util. ArrayDeque

返回此deque中的元素的迭代器。

iterator() - Method in class java.util. ArrayList

以正确的顺序返回该列表中的元素的迭代器。

iterator() - Method in interface java.util. Collection

返回此集合中元素的迭代器。

iterator() - Method in class java.util.concurrent. ArrayBlockingQueue

以正确的顺序返回该队列中的元素的迭代器。

iterator() - Method in interface java.util.concurrent. BlockingDeque

以正确的顺序返回此deque中的元素的迭代器。

iterator() - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView

iterator() - Method in class java.util.concurrent. ConcurrentLinkedDeque

以正确的顺序返回此deque中的元素的迭代器。

iterator() - Method in class java.util.concurrent. ConcurrentLinkedQueue

以正确的顺序返回该队列中的元素的迭代器。

iterator() - Method in class java.util.concurrent. ConcurrentSkipListSet

以升序返回该集合中的元素的迭代器。

iterator() - Method in class java.util.concurrent. CopyOnWriteArrayList

以正确的顺序返回该列表中的元素的迭代器。

iterator() - Method in class java.util.concurrent. CopyOnWriteArraySet

按照添加这些元素的顺序返回此集合中包含的元素的迭代器。

iterator() - Method in class java.util.concurrent. DelayQueue

返回此队列中所有元素（已过期和未过期）的迭代器。

iterator() - Method in class java.util.concurrent. LinkedBlockingDeque

以正确的顺序返回此deque中的元素的迭代器。

iterator() - Method in class java.util.concurrent. LinkedBlockingQueue

以正确的顺序返回该队列中的元素的迭代器。

iterator() - Method in class java.util.concurrent. LinkedTransferQueue

以正确的顺序返回该队列中的元素的迭代器。

iterator() - Method in class java.util.concurrent. PriorityBlockingQueue

返回此队列中的元素的迭代器。

iterator() - Method in class java.util.concurrent. SynchronousQueue

返回一个空的迭代器，其中 hasNext总是返回 false 。

iterator() - Method in interface java.util. Deque

以正确的顺序返回此deque中的元素的迭代器。

iterator() - Method in class java.util. HashSet

返回此集合中元素的迭代器。

iterator() - Method in interface java.util. List

以正确的顺序返回该列表中的元素的迭代器。

iterator() - Method in interface java.util. NavigableSet

以升序返回此集合中的元素的迭代器。

iterator() - Method in class java.util. PriorityQueue

返回此队列中的元素的迭代器。

iterator() - Method in class java.util. ServiceLoader

返回一个迭代器来懒洋洋地加载和实例化此加载程序服务的可用提供程序。

iterator() - Method in interface java.util. Set

返回此集合中元素的迭代器。

iterator() - Method in interface java.util.stream. BaseStream

返回此流的元素的迭代器。

iterator() - Method in interface java.util.stream. DoubleStream

iterator() - Method in interface java.util.stream. IntStream

iterator() - Method in interface java.util.stream. LongStream

iterator() - Method in class java.util. TreeSet

以升序返回该集合中的元素的迭代器。

iterator() - Method in class java.util. Vector

以正确的顺序返回该列表中的元素的迭代器。

iterator() - Method in class javafx.beans.binding. ListExpression

iterator() - Method in class javafx.beans.binding. SetExpression

iterator() - Method in class javax.xml.crypto.dom. DOMCryptoContext

在这个 DOMCryptoContext的Id / Element映射集中返回一个只读迭代器。

iterator() - Method in interface javax.xml.crypto. NodeSetData

在 NodeSetData中的 NodeSetData中包含的节点上返回一个只读迭代器。

iterator() - Method in interface javax.xml.xpath. XPathNodes

返回Nodes的迭代器。

iterator(Spliterator.OfDouble) - Static method in class java.util. Spliterators

创建一个 PrimitiveIterator.OfDouble从 Spliterator.OfDouble 。

iterator(Spliterator.OfInt) - Static method in class java.util. Spliterators

创建一个 PrimitiveIterator.OfInt从 Spliterator.OfInt 。

iterator(Spliterator.OfLong) - Static method in class java.util. Spliterators

创建一个 PrimitiveIterator.OfLong从 Spliterator.OfLong 。

iterator(Spliterator<? extends T>) - Static method in class java.util. Spliterators

创建一个 Iterator从 Spliterator 。

Iterator< E> - Interface in java.util

一个集合的迭代器。

Iterator() - Constructor for class javax.swing.text.html. HTMLDocument.Iterator

IVORY - Static variable in class javafx.scene.paint. Color

颜色象牙，RGB值为＃FFFFF0

IvParameterSpec - Class in javax.crypto.spec

该类指定 初始化向量 （IV）。

IvParameterSpec(byte[]) - Constructor for class javax.crypto.spec. IvParameterSpec

使用 iv的字节作为IV创建一个IvParameterSpec对象。

IvParameterSpec(byte[], int, int) - Constructor for class javax.crypto.spec. IvParameterSpec

创建使用第一构造一个IvParameterSpec对象 len字节 iv ，在开始 offset以下，作为IV。

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

Report a bug or suggest an enhancement


_-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

_

_ACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage. State
_ADD_OVERRIDE - Static variable in class org.omg.CORBA. SetOverrideType
int常量为枚举值ADD_OVERRIDE。
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming. BindingIteratorPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming. NamingContextExtPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming. NamingContextPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer. Servant
由ORB用于从仆人获取完整的类型信息。
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer. ServantActivatorPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer. ServantLocatorPOA
_BindingIteratorImplBase - Class in org.omg.CosNaming
_BindingIteratorImplBase() - Constructor for class org.omg.CosNaming. _BindingIteratorImplBase
_BindingIteratorStub - Class in org.omg.CosNaming
BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
_BindingIteratorStub() - Constructor for class org.omg.CosNaming. _BindingIteratorStub
_COMPLETED_MAYBE - Static variable in class org.omg.CORBA. CompletionStatus
表示在抛出 SystemException之前运行的方法的常量。
_COMPLETED_NO - Static variable in class org.omg.CORBA. CompletionStatus
表示在抛出 SystemException之前运行的方法的常量。
_COMPLETED_YES - Static variable in class org.omg.CORBA. CompletionStatus
指示在抛出 SystemException之前运行的方法的常量。
_create_request(Context, String, NVList, NamedValue) - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个本地约束的对象”。
_create_request(Context, String, NVList, NamedValue) - Method in interface org.omg.CORBA. Object
创建一个使用给定上下文，方法名称，参数列表初始化的 Request实例，并为方法的返回值创建容器。
_create_request(Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.portable. ObjectImpl
创建一个包含给定上下文，方法，参数列表和容器的 Request对象。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部受限的对象”。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in interface org.omg.CORBA. Object
创建一个使用给定上下文，方法名称，参数列表，方法返回值的容器，可能的异常列表和需要解析的上下文串列表初始化的 Request实例。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.portable. ObjectImpl
创建一个 Request对象，其中包含给定的上下文，方法，参数列表，结果容器，异常以及用于解析上下文字符串的属性名称列表。
_default_POA() - Method in class org.omg.PortableServer. Servant
从与服务器关联的ORB实例返回根POA。
_DISCARDING - Static variable in class org.omg.PortableServer.POAManagerPackage. State
_dk_AbstractInterface - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Alias - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_all - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Array - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Attribute - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Constant - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Enum - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Exception - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Fixed - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Interface - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Module - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Native - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_none - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Operation - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Primitive - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Repository - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Sequence - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_String - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Struct - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Typedef - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Union - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Value - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_ValueBox - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_ValueMember - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_dk_Wstring - Static variable in class org.omg.CORBA. DefinitionKind
指示Interface Repository对象没有定义类型的常量。
_duplicate() - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部受限的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_duplicate() - Method in interface org.omg.CORBA. Object
返回此CORBA对象引用的副本。
_duplicate() - Method in class org.omg.CORBA.portable. ObjectImpl
返回此 ObjectImpl对象的副本。
_DynAnyFactoryStub - Class in org.omg.DynamicAny
可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。
_DynAnyFactoryStub() - Constructor for class org.omg.DynamicAny. _DynAnyFactoryStub
_DynAnyStub - Class in org.omg.DynamicAny
任何值都可以动态解释（遍历）并通过DynAny对象构造。
_DynAnyStub() - Constructor for class org.omg.DynamicAny. _DynAnyStub
_DynArrayStub - Class in org.omg.DynamicAny
DynArray对象支持IDL数组的操作。
_DynArrayStub() - Constructor for class org.omg.DynamicAny. _DynArrayStub
_DynEnumStub - Class in org.omg.DynamicAny
DynEnum对象支持对IDL枚举值的操作。
_DynEnumStub() - Constructor for class org.omg.DynamicAny. _DynEnumStub
_DynFixedStub - Class in org.omg.DynamicAny
DynFixed对象支持IDL固定值的操作。
_DynFixedStub() - Constructor for class org.omg.DynamicAny. _DynFixedStub
_DynSequenceStub - Class in org.omg.DynamicAny
DynSequence对象支持IDL序列的操作。
_DynSequenceStub() - Constructor for class org.omg.DynamicAny. _DynSequenceStub
_DynStructStub - Class in org.omg.DynamicAny
DynStruct对象支持IDL结构和异常值的操作。
_DynStructStub() - Constructor for class org.omg.DynamicAny. _DynStructStub
_DynUnionStub - Class in org.omg.DynamicAny
DynUnion对象支持IDL联盟的操纵。
_DynUnionStub() - Constructor for class org.omg.DynamicAny. _DynUnionStub
_DynValueStub - Class in org.omg.DynamicAny
DynValue对象支持IDL非盒装值类型的操作。
_DynValueStub() - Constructor for class org.omg.DynamicAny. _DynValueStub
_get_codebase() - Method in class org.omg.CORBA_2_3.portable. ObjectImpl
返回此对象引用的代码库。
_get_delegate() - Method in class org.omg.CORBA.portable. ObjectImpl
检索对这个 ObjectImpl对象委托给它的所有方法的供应商特定的 Delegate对象的引用。
_get_delegate() - Method in class org.omg.PortableServer. Servant
获取ORB供应商特定的 PortableServer::Servant实现。
_get_domain_managers() - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部受限的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_get_domain_managers() - Method in interface org.omg.CORBA. Object
检索此对象的 DomainManagers 。
_get_domain_managers() - Method in class org.omg.CORBA.portable. ObjectImpl
检索此 ObjectImpl对象的域管理员列表。
_get_interface() - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_get_interface_def() - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部约束的对象”。
_get_interface_def() - Method in interface org.omg.CORBA. Object
获取此对象引用引用的对象实现的 InterfaceDef 。
_get_interface_def() - Method in class org.omg.CORBA.portable. ObjectImpl
检索此 ObjectImpl对象的接口定义。
_get_interface_def() - Method in class org.omg.PortableServer. Servant
将 InterfaceDef对象作为 CORBA::Object返回，该对象定义由 CORBA::Object实现的 Servant的运行时类型。
_get_policy(int) - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部约束的对象”。
_get_policy(int) - Method in interface org.omg.CORBA. Object
返回适用于此对象的指定类型的 Policy对象。
_get_policy(int) - Method in class org.omg.CORBA.portable. ObjectImpl
检索具有给定策略类型的 Policy对象的 ObjectImpl对象。
_hash(int) - Method in class org.omg.CORBA. LocalObject
返回使用给定数字作为最大值的对象生命周期一致的哈希值。
_hash(int) - Method in interface org.omg.CORBA. Object
返回此对象引用的ORB内部标识符。
_hash(int) - Method in class org.omg.CORBA.portable. ObjectImpl
检索作为此 ObjectImpl对象的ORB内部标识符的哈希码。
_HOLDING - Static variable in class org.omg.PortableServer.POAManagerPackage. State
_IDLTypeStub - Class in org.omg.CORBA
存根为 IDLType 。
_IDLTypeStub() - Constructor for class org.omg.CORBA. _IDLTypeStub
构造默认的 _IDLTypeStub对象。
_IDLTypeStub(Delegate) - Constructor for class org.omg.CORBA. _IDLTypeStub
构造一个 _IDLTypeStub给定初始化的对象 Delegate对象。
_ids() - Method in class org.omg.CORBA. _IDLTypeStub
_ids() - Method in class org.omg.CORBA. _PolicyStub
_ids() - Method in class org.omg.CORBA. DynamicImplementation
已过时。
_ids() - Method in class org.omg.CORBA.portable. ObjectImpl
检索包含此 ObjectImpl对象支持的存储库标识符的字符串数组。
_ids() - Method in class org.omg.CosNaming. _BindingIteratorImplBase
_ids() - Method in class org.omg.CosNaming. _BindingIteratorStub
_ids() - Method in class org.omg.CosNaming. _NamingContextExtStub
_ids() - Method in class org.omg.CosNaming. _NamingContextImplBase
_ids() - Method in class org.omg.CosNaming. _NamingContextStub
_ids() - Method in class org.omg.DynamicAny. _DynAnyFactoryStub
_ids() - Method in class org.omg.DynamicAny. _DynAnyStub
_ids() - Method in class org.omg.DynamicAny. _DynArrayStub
_ids() - Method in class org.omg.DynamicAny. _DynEnumStub
_ids() - Method in class org.omg.DynamicAny. _DynFixedStub
_ids() - Method in class org.omg.DynamicAny. _DynSequenceStub
_ids() - Method in class org.omg.DynamicAny. _DynStructStub
_ids() - Method in class org.omg.DynamicAny. _DynUnionStub
_ids() - Method in class org.omg.DynamicAny. _DynValueStub
_ids() - Method in class org.omg.PortableServer. _ServantActivatorStub
_ids() - Method in class org.omg.PortableServer. _ServantLocatorStub
_ids() - Method in class org.omg.stub.java.rmi. _Remote_Stub
返回对象实现的存储库ID数组。
_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer. ImplicitActivationPolicyValue
_INACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage. State
_invoke(String, InputStream, ResponseHandler) - Method in interface org.omg.CORBA.portable. InvokeHandler
由ORB调用，向仆人发出请求。
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming. BindingIteratorPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming. NamingContextExtPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming. NamingContextPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.PortableServer. ServantActivatorPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.PortableServer. ServantLocatorPOA
_invoke(OutputStream) - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部约束的对象”。
_invoke(OutputStream) - Method in class org.omg.CORBA.portable. ObjectImpl
调用一个操作并返回一个 InputStream对象来读取响应。
_is_a(String) - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部约束的对象”。
_is_a(String) - Method in interface org.omg.CORBA. Object
检查此对象是否是实现给定接口的类的实例。
_is_a(String) - Method in class org.omg.CORBA.portable. ObjectImpl
检查由给定的存储库标识符标识的对象是否为 ObjectImpl对象。
_is_a(String) - Method in class org.omg.PortableServer. Servant
检查是否指定 repository_id存在通过返回的列表上 _all_interfaces()或为 repository_id的通用CORBA对象。
_is_equivalent(Object) - Method in class org.omg.CORBA. LocalObject
确定两个对象引用是否相等，只要ORB可以轻松确定。
_is_equivalent(Object) - Method in interface org.omg.CORBA. Object
确定两个对象引用是否相等，只要ORB可以轻松确定。
_is_equivalent(Object) - Method in class org.omg.CORBA.portable. ObjectImpl
检查给定的 ObjectImpl对象是否等同于此 ObjectImpl对象。
_is_local() - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_is_local() - Method in class org.omg.CORBA.portable. ObjectImpl
检查此 ObjectImpl对象是否由本地仆人实现。
_missing_node - Static variable in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
_MULTIPLE_ID - Static variable in class org.omg.PortableServer. IdUniquenessPolicyValue
_NamingContextExtStub - Class in org.omg.CosNaming
NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
_NamingContextExtStub() - Constructor for class org.omg.CosNaming. _NamingContextExtStub
_NamingContextImplBase - Class in org.omg.CosNaming
_NamingContextImplBase() - Constructor for class org.omg.CosNaming. _NamingContextImplBase
_NamingContextStub - Class in org.omg.CosNaming
命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
_NamingContextStub() - Constructor for class org.omg.CosNaming. _NamingContextStub
_ncontext - Static variable in class org.omg.CosNaming. BindingType
_NO_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer. ImplicitActivationPolicyValue
_nobject - Static variable in class org.omg.CosNaming. BindingType
_non_existent() - Method in class org.omg.CORBA. LocalObject
总是返回 false 。
_non_existent() - Method in interface org.omg.CORBA. Object
确定此对象引用的服务器对象是否已被销毁。
_non_existent() - Method in class org.omg.CORBA.portable. ObjectImpl
检查此 ObjectImpl对象的服务器对象是否已被销毁。
_non_existent() - Method in class org.omg.PortableServer. Servant
检查是否存在 Object 。
_NON_RETAIN - Static variable in class org.omg.PortableServer. ServantRetentionPolicyValue
_not_context - Static variable in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
_not_object - Static variable in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
_object_id() - Method in class org.omg.PortableServer. Servant
允许轻松执行常用方法，相当于调用 PortableServer::Current::get_object_id 。
_opsClass - Static variable in class org.omg.DynamicAny. _DynAnyFactoryStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynAnyStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynArrayStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynEnumStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynFixedStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynSequenceStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynStructStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynUnionStub
_opsClass - Static variable in class org.omg.DynamicAny. _DynValueStub
_opsClass - Static variable in class org.omg.PortableServer. _ServantActivatorStub
_opsClass - Static variable in class org.omg.PortableServer. _ServantLocatorStub
_orb() - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部受限的对象”。
_orb() - Method in class org.omg.CORBA.portable. ObjectImpl
返回与该对象及其委托关联的ORB的引用。
_orb() - Method in class org.omg.PortableServer. Servant
返回当前与 Servant （方便方法）相关联的ORB的实例。
_ORB_CTRL_MODEL - Static variable in class org.omg.PortableServer. ThreadPolicyValue
_PARAM_IN - Static variable in class org.omg.CORBA. ParameterMode
_PARAM_INOUT - Static variable in class org.omg.CORBA. ParameterMode
_PARAM_OUT - Static variable in class org.omg.CORBA. ParameterMode
_PERSISTENT - Static variable in class org.omg.PortableServer. LifespanPolicyValue
_poa() - Method in class org.omg.PortableServer. Servant
允许轻松执行常用方法，相当于 PortableServer::Current:get_POA 。
_PolicyStub - Class in org.omg.CORBA
存根为 Policy 。
_PolicyStub() - Constructor for class org.omg.CORBA. _PolicyStub
构造函数注意：如果使用默认构造函数，该对象在_set_delegate（...）之前无效
_PolicyStub(Delegate) - Constructor for class org.omg.CORBA. _PolicyStub
构造一个 _PolicyStub给定初始化的对象 Delegate对象。
_postEdit(UndoableEdit) - Method in class javax.swing.undo. UndoableEditSupport
仅限于 postEdit和 endUpdate 。
_read(InputStream) - Method in class org.omg.CORBA. AnyHolder
从 input读取，并通过未编组的数据启动持有人的值。
_read(InputStream) - Method in class org.omg.CORBA. AnySeqHolder
_read(InputStream) - Method in class org.omg.CORBA. BooleanHolder
从 input读取未编组的数据，并将其分配给此 BooleanHolder对象的 value字段。
_read(InputStream) - Method in class org.omg.CORBA. BooleanSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. ByteHolder
从 input读取，并使用未编组的数据 ByteHolder此 ByteHolder对象的值。
_read(InputStream) - Method in class org.omg.CORBA. CharHolder
从 input读取，并使用未编组的数据启用此 CharHolder对象的值。
_read(InputStream) - Method in class org.omg.CORBA. CharSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. CurrentHolder
_read(InputStream) - Method in class org.omg.CORBA. DoubleHolder
从输入流读取一个double值并将其存储在值成员中。
_read(InputStream) - Method in class org.omg.CORBA. DoubleSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. FixedHolder
从输入流读取固定点值，并将其存储在值成员中。
_read(InputStream) - Method in class org.omg.CORBA. FloatHolder
从输入流读取浮点数，并使用float值初始化值成员。
_read(InputStream) - Method in class org.omg.CORBA. FloatSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. IntHolder
从 input读取未编组的数据，并将其分配给此 IntHolder对象中的 value字段。
_read(InputStream) - Method in class org.omg.CORBA. LongHolder
从 input读取，并通过未编组的数据启动持有人的值。
_read(InputStream) - Method in class org.omg.CORBA. LongLongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. LongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. ObjectHolder
从 input读取，并使用未编组的数据启用此 ObjectHolder对象的值。
_read(InputStream) - Method in class org.omg.CORBA. OctetSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. ParameterModeHolder
_read(InputStream) - Method in class org.omg.CORBA. PolicyErrorHolder
_read(InputStream) - Method in class org.omg.CORBA. PolicyHolder
_read(InputStream) - Method in class org.omg.CORBA. PolicyListHolder
_read(InputStream) - Method in interface org.omg.CORBA.portable. Streamable
从 istream读取数据，并使用未编组的数据 value持有人的 value字段。
_read(InputStream) - Method in class org.omg.CORBA. PrincipalHolder
已过时。
_read(InputStream) - Method in class org.omg.CORBA. ServiceInformationHolder
从输入流 in读取未编组的数据，并将其分配给此 ServiceInformationHolder对象中的 value字段。
_read(InputStream) - Method in class org.omg.CORBA. ShortHolder
从 input读取，并使用未编组的数据启用此 ShortHolder对象的值。
_read(InputStream) - Method in class org.omg.CORBA. ShortSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. StringHolder
从 input读取未编组的数据，并将其分配给该 StringHolder对象的 value字段。
_read(InputStream) - Method in class org.omg.CORBA. StringSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. TypeCodeHolder
从 input读取，并使用未编组的数据启用此 TypeCodeHolder对象的值。
_read(InputStream) - Method in class org.omg.CORBA. ULongLongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. ULongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. UnknownUserExceptionHolder
_read(InputStream) - Method in class org.omg.CORBA. UShortSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. ValueBaseHolder
从 input读取，并使用未编组的数据启动持有人的值。
_read(InputStream) - Method in class org.omg.CORBA. WCharSeqHolder
_read(InputStream) - Method in class org.omg.CORBA. WrongTransactionHolder
_read(InputStream) - Method in class org.omg.CORBA. WStringSeqHolder
_read(InputStream) - Method in class org.omg.CosNaming. BindingHolder
_read(InputStream) - Method in class org.omg.CosNaming. BindingIteratorHolder
_read(InputStream) - Method in class org.omg.CosNaming. BindingListHolder
_read(InputStream) - Method in class org.omg.CosNaming. BindingTypeHolder
_read(InputStream) - Method in class org.omg.CosNaming. NameComponentHolder
_read(InputStream) - Method in class org.omg.CosNaming. NameHolder
_read(InputStream) - Method in class org.omg.CosNaming. NamingContextExtHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHolder
_read(InputStream) - Method in class org.omg.CosNaming. NamingContextHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage. NotFoundHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHolder
_read(InputStream) - Method in class org.omg.IOP. IORHolder
_read(InputStream) - Method in class org.omg.IOP. MultipleComponentProfileHolder
_read(InputStream) - Method in class org.omg.IOP. ServiceContextHolder
_read(InputStream) - Method in class org.omg.IOP. ServiceContextListHolder
_read(InputStream) - Method in class org.omg.IOP. TaggedComponentHolder
_read(InputStream) - Method in class org.omg.IOP. TaggedProfileHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor. IORInterceptor_3_0Holder
_read(InputStream) - Method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHolder
_read(InputStream) - Method in class org.omg.PortableServer.ServantLocatorPackage. CookieHolder
_release() - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个本地约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_release() - Method in interface org.omg.CORBA. Object
通过使用此对象引用来指示调用者，因此可以释放与此对象引用关联的内部ORB资源。
_release() - Method in class org.omg.CORBA.portable. ObjectImpl
释放与此 ObjectImpl对象关联的资源。
_releaseReply(InputStream) - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个本地约束的对象”。
_releaseReply(InputStream) - Method in class org.omg.CORBA.portable. ObjectImpl
在调用方法 _invoke后解组已完成时，将给定的回复流释放回ORB。
_Remote_Stub - Class in org.omg.stub.java.rmi
该类提供了远程类型的存根。
_Remote_Stub() - Constructor for class org.omg.stub.java.rmi. _Remote_Stub
_request(String) - Method in class org.omg.CORBA. LocalObject
使用消息“这是本地约束对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_request(String) - Method in interface org.omg.CORBA. Object
创建一个用于动态调用接口的 Request实例。
_request(String) - Method in class org.omg.CORBA.portable. ObjectImpl
创建一个包含可以与动态调用接口一起使用的给定方法的 Request对象。
_request(String, boolean) - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_request(String, boolean) - Method in class org.omg.CORBA.portable. ObjectImpl
返回一个用于编组给定方法的参数的 OutputStream对象。
_RETAIN - Static variable in class org.omg.PortableServer. ServantRetentionPolicyValue
_servant_postinvoke(ServantObject) - Method in class org.omg.CORBA. LocalObject
抛出一个 org.omg.CORBA.NO_IMPLEMENT异常，并显示“This is a org.omg.CORBA.NO_IMPLEMENT constrained object”。
_servant_postinvoke(ServantObject) - Method in class org.omg.CORBA.portable. ObjectImpl
在本地存根调用了对方法 _servant_preinvoke的调用以前检索到的本地仆人的操作后，本地存根调用。
_servant_preinvoke(String, Class) - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部受限的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_servant_preinvoke(String, Class) - Method in class org.omg.CORBA.portable. ObjectImpl
返回对本地servant的Java引用，该引用应用于发送请求方法。
_ServantActivatorStub - Class in org.omg.PortableServer
当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。
_ServantActivatorStub() - Constructor for class org.omg.PortableServer. _ServantActivatorStub
_ServantLocatorStub - Class in org.omg.PortableServer
当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。
_ServantLocatorStub() - Constructor for class org.omg.PortableServer. _ServantLocatorStub
_set_delegate(Delegate) - Method in class org.omg.CORBA.portable. ObjectImpl
将此 ObjectImpl实例的代理设置为给定的 Delegate对象。
_set_delegate(Delegate) - Method in class org.omg.PortableServer. Servant
通过为通过委派支持ORB可移植性的类设置方法来设置其委托，支持Java ORB可移植性接口。
_SET_OVERRIDE - Static variable in class org.omg.CORBA. SetOverrideType
int常量为枚举值SET_OVERRIDE。
_set_policy_override(Policy[], SetOverrideType) - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
_set_policy_override(Policy[], SetOverrideType) - Method in interface org.omg.CORBA. Object
使用给定的策略返回一个新的 Object ，取代该 Object现有策略，或者根据给定的 SetOverrideType对象的值添加到现有策略中。
_set_policy_override(Policy[], SetOverrideType) - Method in class org.omg.CORBA.portable. ObjectImpl
将给定策略的 ObjectImpl对象的覆盖类型设置为给定的实例 SetOverrideType 。
_SINGLE_THREAD_MODEL - Static variable in class org.omg.PortableServer. ThreadPolicyValue
_SYSTEM_ID - Static variable in class org.omg.PortableServer. IdAssignmentPolicyValue
_this() - Method in class org.omg.CosNaming. BindingIteratorPOA
_this() - Method in class org.omg.CosNaming. NamingContextExtPOA
_this() - Method in class org.omg.CosNaming. NamingContextPOA
_this() - Method in class org.omg.PortableServer. ServantActivatorPOA
_this() - Method in class org.omg.PortableServer. ServantLocatorPOA
_this(ORB) - Method in class org.omg.CosNaming. BindingIteratorPOA
_this(ORB) - Method in class org.omg.CosNaming. NamingContextExtPOA
_this(ORB) - Method in class org.omg.CosNaming. NamingContextPOA
_this(ORB) - Method in class org.omg.PortableServer. ServantActivatorPOA
_this(ORB) - Method in class org.omg.PortableServer. ServantLocatorPOA
_this_object() - Method in class org.omg.PortableServer. Servant
允许仆人获取其针对该请求的目标CORBA对象的对象引用。
_this_object(ORB) - Method in class org.omg.PortableServer. Servant
允许仆人获取它为该请求所体现的目标CORBA对象的对象引用。
_tk_abstract_interface - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 abstract interface 。
_tk_alias - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 alias 。
_tk_any - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 any 。
_tk_array - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 array 。
_tk_boolean - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 boolean 。
_tk_char - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 char 。
_tk_double - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 double 。
_tk_enum - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 枚举 。
_tk_except - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 except 。
_tk_fixed - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 fixed 。
_tk_float - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 float 。
_tk_long - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 long 。
_tk_longdouble - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 longdouble 。
_tk_longlong - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 longlong 。
_tk_native - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 native 。
_tk_null - Static variable in class org.omg.CORBA. TCKind
int常数为 null IDL数据类型。
_tk_objref - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 objref 。
_tk_octet - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 octet 。
_tk_Principal - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 Principal 。
_tk_sequence - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 sequence 。
_tk_short - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 short 。
_tk_string - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 string 。
_tk_struct - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 struct 。
_tk_TypeCode - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 TypeCode 。
_tk_ulong - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 ulong 。
_tk_ulonglong - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 ulonglong 。
_tk_union - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 union 。
_tk_ushort - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 ushort 。
_tk_value - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 value 。
_tk_value_box - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 value_box 。
_tk_void - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 void 。
_tk_wchar - Static variable in class org.omg.CORBA. TCKind
int常量为IDL数据类型 wchar 。
_tk_wstring - Static variable in class org.omg.CORBA. TCKind
int常数为IDL数据类型 wstring 。
_TRANSIENT - Static variable in class org.omg.PortableServer. LifespanPolicyValue
_truncatable_ids() - Method in interface org.omg.CORBA.portable. ValueBase
提供可截断的存储库ID。
_type() - Method in class org.omg.CORBA. AnyHolder
返回 TypeCode对应于该保存的值对象 AnyHolder对象。
_type() - Method in class org.omg.CORBA. AnySeqHolder
_type() - Method in class org.omg.CORBA. BooleanHolder
检索 TypeCode对应于该保存的值对象 BooleanHolder对象。
_type() - Method in class org.omg.CORBA. BooleanSeqHolder
_type() - Method in class org.omg.CORBA. ByteHolder
返回与此 ByteHolder对象中保存的值相对应的TypeCode。
_type() - Method in class org.omg.CORBA. CharHolder
返回 TypeCode对应于该保存的值对象 CharHolder对象。
_type() - Method in class org.omg.CORBA. CharSeqHolder
_type() - Method in class org.omg.CORBA. CurrentHolder
_type() - Method in class org.omg.CORBA. DoubleHolder
返回此持有人对象的 TypeCode 。
_type() - Method in class org.omg.CORBA. DoubleSeqHolder
_type() - Method in class org.omg.CORBA. FixedHolder
返回此持有人对象的 TypeCode 。
_type() - Method in class org.omg.CORBA. FloatHolder
返回此 TypeCode的TypeCode。
_type() - Method in class org.omg.CORBA. FloatSeqHolder
_type() - Method in class org.omg.CORBA. IntHolder
检索 TypeCode对应于该保存的值对象 IntHolder对象 value场。
_type() - Method in class org.omg.CORBA. LongHolder
返回对应于持有人持有的值的 TypeCode对象。
_type() - Method in class org.omg.CORBA. LongLongSeqHolder
_type() - Method in class org.omg.CORBA. LongSeqHolder
_type() - Method in class org.omg.CORBA. ObjectHolder
返回与此 ObjectHolder对象中保存的值相对应的TypeCode
_type() - Method in class org.omg.CORBA. OctetSeqHolder
_type() - Method in class org.omg.CORBA. ParameterModeHolder
_type() - Method in class org.omg.CORBA. PolicyErrorHolder
_type() - Method in class org.omg.CORBA. PolicyHolder
_type() - Method in class org.omg.CORBA. PolicyListHolder
_type() - Method in interface org.omg.CORBA.portable. Streamable
检索对应于持有人的 value字段中的值的 TypeCode对象。
_type() - Method in class org.omg.CORBA. PrincipalHolder
已过时。
_type() - Method in class org.omg.CORBA. ServiceInformationHolder
检索 TypeCode对应于该保存的值对象 ServiceInformationHolder对象 value场。
_type() - Method in class org.omg.CORBA. ShortHolder
返回与此 ShortHolder对象中保存的值相对应的TypeCode。
_type() - Method in class org.omg.CORBA. ShortSeqHolder
_type() - Method in class org.omg.CORBA. StringHolder
检索 TypeCode对应于该保存的值对象 StringHolder对象。
_type() - Method in class org.omg.CORBA. StringSeqHolder
_type() - Method in class org.omg.CORBA. TypeCodeHolder
返回与此 TypeCodeHolder对象中保存的值相对应的TypeCode。
_type() - Method in class org.omg.CORBA. ULongLongSeqHolder
_type() - Method in class org.omg.CORBA. ULongSeqHolder
_type() - Method in class org.omg.CORBA. UnknownUserExceptionHolder
_type() - Method in class org.omg.CORBA. UShortSeqHolder
_type() - Method in class org.omg.CORBA. ValueBaseHolder
返回对应于持有人持有的值的 TypeCode对象。
_type() - Method in class org.omg.CORBA. WCharSeqHolder
_type() - Method in class org.omg.CORBA. WrongTransactionHolder
_type() - Method in class org.omg.CORBA. WStringSeqHolder
_type() - Method in class org.omg.CosNaming. BindingHolder
_type() - Method in class org.omg.CosNaming. BindingIteratorHolder
_type() - Method in class org.omg.CosNaming. BindingListHolder
_type() - Method in class org.omg.CosNaming. BindingTypeHolder
_type() - Method in class org.omg.CosNaming. NameComponentHolder
_type() - Method in class org.omg.CosNaming. NameHolder
_type() - Method in class org.omg.CosNaming. NamingContextExtHolder
_type() - Method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHolder
_type() - Method in class org.omg.CosNaming. NamingContextHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage. NotFoundHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHolder
_type() - Method in class org.omg.IOP. IORHolder
_type() - Method in class org.omg.IOP. MultipleComponentProfileHolder
_type() - Method in class org.omg.IOP. ServiceContextHolder
_type() - Method in class org.omg.IOP. ServiceContextListHolder
_type() - Method in class org.omg.IOP. TaggedComponentHolder
_type() - Method in class org.omg.IOP. TaggedProfileHolder
_type() - Method in class org.omg.PortableInterceptor. IORInterceptor_3_0Holder
_type() - Method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHolder
_type() - Method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHolder
_type() - Method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHolder
_type() - Method in class org.omg.PortableServer.ServantLocatorPackage. CookieHolder
_UNIQUE_ID - Static variable in class org.omg.PortableServer. IdUniquenessPolicyValue
_USE_ACTIVE_OBJECT_MAP_ONLY - Static variable in class org.omg.PortableServer. RequestProcessingPolicyValue
_USE_DEFAULT_SERVANT - Static variable in class org.omg.PortableServer. RequestProcessingPolicyValue
_USE_SERVANT_MANAGER - Static variable in class org.omg.PortableServer. RequestProcessingPolicyValue
_USER_ID - Static variable in class org.omg.PortableServer. IdAssignmentPolicyValue
_write(OutputStream) - Method in class org.omg.CORBA. AnyHolder
乘警 output值在此 AnyHolder对象。
_write(OutputStream) - Method in class org.omg.CORBA. AnySeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. BooleanHolder
将此 BooleanHolder对象的 value字段中的值 value到输出流 output 。
_write(OutputStream) - Method in class org.omg.CORBA. BooleanSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. ByteHolder
在这个 ByteHolder对象中的数据 ByteHolder给 output 。
_write(OutputStream) - Method in class org.omg.CORBA. CharHolder
在这个 CharHolder对象中发送给 output的值。
_write(OutputStream) - Method in class org.omg.CORBA. CharSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. CurrentHolder
_write(OutputStream) - Method in class org.omg.CORBA. DoubleHolder
将此持有 OutputStream存储的双重值写入 OutputStream 。
_write(OutputStream) - Method in class org.omg.CORBA. DoubleSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. FixedHolder
将此持有人存储的固定点值写入 OutputStream 。
_write(OutputStream) - Method in class org.omg.CORBA. FloatHolder
将float值写入输出流。
_write(OutputStream) - Method in class org.omg.CORBA. FloatSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. IntHolder
将此 IntHolder对象的 value字段中的值 value到输出流 output 。
_write(OutputStream) - Method in class org.omg.CORBA. LongHolder
在 output人员中持有人的价值。
_write(OutputStream) - Method in class org.omg.CORBA. LongLongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. LongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. ObjectHolder
乘警 output值在此 ObjectHolder对象。
_write(OutputStream) - Method in class org.omg.CORBA. OctetSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. ParameterModeHolder
_write(OutputStream) - Method in class org.omg.CORBA. PolicyErrorHolder
_write(OutputStream) - Method in class org.omg.CORBA. PolicyHolder
_write(OutputStream) - Method in class org.omg.CORBA. PolicyListHolder
_write(OutputStream) - Method in interface org.omg.CORBA.portable. Streamable
乘警 ostream的价值 value持有人的领域。
_write(OutputStream) - Method in class org.omg.CORBA. PrincipalHolder
已过时。
_write(OutputStream) - Method in class org.omg.CORBA. ServiceInformationHolder
将此 ServiceInformationHolder对象的 value字段中的值 value到输出流 out 。
_write(OutputStream) - Method in class org.omg.CORBA. ShortHolder
在这个 ShortHolder对象中的数据 ShortHolder给 output 。
_write(OutputStream) - Method in class org.omg.CORBA. ShortSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. StringHolder
将此 StringHolder对象持有的值 StringHolder到输出流 output 。
_write(OutputStream) - Method in class org.omg.CORBA. StringSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. TypeCodeHolder
在这个 TypeCodeHolder对象中的值传送给 output 。
_write(OutputStream) - Method in class org.omg.CORBA. ULongLongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. ULongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. UnknownUserExceptionHolder
_write(OutputStream) - Method in class org.omg.CORBA. UShortSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. ValueBaseHolder
在 output持有人的价值。
_write(OutputStream) - Method in class org.omg.CORBA. WCharSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA. WrongTransactionHolder
_write(OutputStream) - Method in class org.omg.CORBA. WStringSeqHolder
_write(OutputStream) - Method in class org.omg.CosNaming. BindingHolder
_write(OutputStream) - Method in class org.omg.CosNaming. BindingIteratorHolder
_write(OutputStream) - Method in class org.omg.CosNaming. BindingListHolder
_write(OutputStream) - Method in class org.omg.CosNaming. BindingTypeHolder
_write(OutputStream) - Method in class org.omg.CosNaming. NameComponentHolder
_write(OutputStream) - Method in class org.omg.CosNaming. NameHolder
_write(OutputStream) - Method in class org.omg.CosNaming. NamingContextExtHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHolder
_write(OutputStream) - Method in class org.omg.CosNaming. NamingContextHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage. NotFoundHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHolder
_write(OutputStream) - Method in class org.omg.IOP. IORHolder
_write(OutputStream) - Method in class org.omg.IOP. MultipleComponentProfileHolder
_write(OutputStream) - Method in class org.omg.IOP. ServiceContextHolder
_write(OutputStream) - Method in class org.omg.IOP. ServiceContextListHolder
_write(OutputStream) - Method in class org.omg.IOP. TaggedComponentHolder
_write(OutputStream) - Method in class org.omg.IOP. TaggedProfileHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor. IORInterceptor_3_0Holder
_write(OutputStream) - Method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHolder
_write(OutputStream) - Method in class org.omg.PortableServer.ServantLocatorPackage. CookieHolder
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


J-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

J

J - javafx.scene.input. KeyCode
常数为 J键。
JANUARY - java.time. Month
1月份的单身实例31天。
JANUARY - Static variable in class java.util. Calendar
Calendar.MONTH字段的值表示今年第一个月在公历和朱利安日历。
JANUARY - Static variable in class javax.xml.datatype. DatatypeConstants
一年的第一个月的价值
JAPAN - Static variable in class java.util. Locale
对国家有用的常数。
JAPANESE - Static variable in class java.util. Locale
有用的语言常数
JAPANESE_DOUBLE_POSTCARD - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定日本双明信片尺寸，148 mm×200 mm。
JAPANESE_DOUBLE_POSTCARD - Static variable in class javax.print.attribute.standard. MediaSizeName
日本双明信片大小。
JAPANESE_HIRAGANA - javafx.scene.input. KeyCode
日文 - 平假名功能键的常数。
JAPANESE_KATAKANA - javafx.scene.input. KeyCode
日本片假名功能键的常数。
JAPANESE_POSTCARD - Static variable in class javafx.print. Paper
指定日本明信片大小，100毫米×148毫米。
JAPANESE_POSTCARD - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定日本明信片大小，100毫米×148毫米。
JAPANESE_POSTCARD - Static variable in class javax.print.attribute.standard. MediaSizeName
日本明信片大小。
JAPANESE_ROMAN - javafx.scene.input. KeyCode
日常罗马功能键的常数。
JapaneseChronology - Class in java.time.chrono
日本帝国历法系统。
JapaneseDate - Class in java.time.chrono
在日本帝国日历系统的日期。
JapaneseEra - Class in java.time.chrono
日本帝国日历系统的一个时代。
JApplet - Class in javax.swing
已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
JApplet() - Constructor for class javax.swing. JApplet
已过时。
创建一个swing applet实例。
JApplet.AccessibleJApplet - Class in javax.swing
已过时。
该类实现 JApplet类的可访问性支持。
JAR - Static variable in interface javax.jnlp. DownloadService2
匹配JARs在 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec) 。
JarEntry - Class in java.util.jar
此类用于表示JAR文件条目。
JarEntry(String) - Constructor for class java.util.jar. JarEntry
为指定的JAR文件条目名称创建一个新的 JarEntry 。
JarEntry(JarEntry) - Constructor for class java.util.jar. JarEntry
使用从指定的 JarEntry对象获取的字段创建一个新的 JarEntry 。
JarEntry(ZipEntry) - Constructor for class java.util.jar. JarEntry
创建一个新的 JarEntry其中的字段取自指定的 ZipEntry对象。
JarException - Exception in java.util.jar
表示在读取或写入JAR文件时发生了某种错误。
JarException() - Constructor for exception java.util.jar. JarException
构造一个没有详细消息的JarException。
JarException(String) - Constructor for exception java.util.jar. JarException
构造具有指定详细消息的JarException。
JarFile - Class in java.util.jar
JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。
JarFile(File) - Constructor for class java.util.jar. JarFile
创建一个新的 JarFile从指定的 File对象读取。
JarFile(File, boolean) - Constructor for class java.util.jar. JarFile
创建一个新的 JarFile从指定的 File对象读取。
JarFile(File, boolean, int) - Constructor for class java.util.jar. JarFile
创建新的 JarFile以指定的模式从指定的 File对象读取。
JarFile(File, boolean, int, Runtime.Version) - Constructor for class java.util.jar. JarFile
创建新的 JarFile以指定的方式从指定的 File对象中读取。
JarFile(String) - Constructor for class java.util.jar. JarFile
创建一个新的 JarFile从指定的文件 name 。
JarFile(String, boolean) - Constructor for class java.util.jar. JarFile
创建一个新的 JarFile从指定的文件读取 name 。
Java Collections Framework - Search tag in util
jarFileURLConnection - Variable in class java.net. JarURLConnection
与JAR文件URL的连接，如果连接已启动。
JarInputStream - Class in java.util.jar
JarInputStream类用于从任何输入流读取JAR文件的内容。
JarInputStream(InputStream) - Constructor for class java.util.jar. JarInputStream
创建一个新的 JarInputStream并读取可选的清单。
JarInputStream(InputStream, boolean) - Constructor for class java.util.jar. JarInputStream
创建一个新的 JarInputStream并读取可选的清单。
JarOutputStream - Class in java.util.jar
JarOutputStream类用于将JAR文件的内容写入任何输出流。
JarOutputStream(OutputStream) - Constructor for class java.util.jar. JarOutputStream
创建一个新的 JarOutputStream没有清单。
JarOutputStream(OutputStream, Manifest) - Constructor for class java.util.jar. JarOutputStream
创建一个新的 JarOutputStream与指定的 Manifest 。
JarSigner - Class in jdk.security.jarsigner
一个不可变的实用程序类来签名一个jar文件。
JarSigner.Builder - Class in jdk.security.jarsigner
一个可变的构建器类，可以从各种签名相关参数创建一个不可变的 JarSigner 。
JarSignerException - Exception in jdk.security.jarsigner
当 JarSigner.sign(java.util.zip.ZipFile, java.io.OutputStream)失败时抛出此异常。
JarSignerException(String, Throwable) - Constructor for exception jdk.security.jarsigner. JarSignerException
构造一个新的 JarSignerException具有指定的详细信息和原因。
JarURLConnection - Class in java.net
与Java ARchive（JAR）文件或JAR文件中的条目的URL连接。
JarURLConnection(URL) - Constructor for class java.net. JarURLConnection
创建新的JarURLConnection到指定的URL。
JAVA_1_1 - com.sun.javadoc. LanguageVersion
已过时。
1.1添加了嵌套类和接口。
JAVA_1_5 - com.sun.javadoc. LanguageVersion
已过时。
1.5添加通用类型，注释，枚举和varArgs。
JAVA_OBJECT - java.sql. JDBCType
表示SQL类型是特定于数据库的，并且映射到可以通过getObject和setObject方法访问的Java对象。
JAVA_OBJECT - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 JAVA_OBJECT 。
java.activation - module java.activation
定义JavaBean激活框架（JAF）API。
java.applet - package java.applet
提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
java.awt - package java.awt
包含用于创建用户界面和绘制图形和图像的所有类。
java.awt.color - package java.awt.color
提供颜色空间的类。
java.awt.datatransfer - package java.awt.datatransfer
提供用于在应用程序之间和之间传输数据的接口和类。
java.awt.desktop - package java.awt.desktop
提供与各种桌面功能交互的接口和类。
java.awt.dnd - package java.awt.dnd
拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
java.awt.event - package java.awt.event
提供用于处理AWT组件触发的不同类型事件的接口和类。
java.awt.font - package java.awt.font
提供与字体相关的类和界面。
java.awt.geom - package java.awt.geom
提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
java.awt.im - package java.awt.im
提供输入法框架的类和接口。
jrt - Search tag in java.base
jrt
jrunscript - Search tag in java.scripting
jrunscript tool
javac - Search tag in jdk.compiler
javac tool
javah - Search tag in jdk.compiler
javah tool
jhsdb - Search tag in jdk.hotspot.agent
jhsdb tool
jar - Search tag in jdk.jartool
jar tool
jarsigner - Search tag in jdk.jartool
jarsigner tool
javadoc - Search tag in jdk.javadoc
javadoc tool
javac - Search tag in jdk.compiler
javac tool
javah - Search tag in jdk.compiler
javah tool
jcmd - Search tag in jdk.jcmd
jcmd tool
jps - Search tag in jdk.jcmd
jps tool
jstat - Search tag in jdk.jcmd
jstat tool
jconsole - Search tag in jdk.jconsole
jconsole
jdeps - Search tag in jdk.jdeps
jdeps tool
javap - Search tag in jdk.jdeps
javap tool
jdeprscan - Search tag in jdk.jdeps
jdeprscan tool
jdb - Search tag in jdk.jdi
jdb tool
jlink - Search tag in jdk.jlink
jlink tool
jmod - Search tag in jdk.jlink
jmod tool
jimage - Search tag in jdk.jlink
jimage tool
jshell - Search tag in jdk.jshell
jshell tool
jstatd - Search tag in jdk.jstatd
jstatd tool
java.awt.im.spi - package java.awt.im.spi
提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
java.awt.image - package java.awt.image
提供创建和修改图像的类。
java.awt.image.renderable - package java.awt.image.renderable
提供用于生成与渲染无关的图像的类和接口。
java.awt.print - package java.awt.print
提供通用打印API的类和接口。
java.base - module java.base
定义Java SE平台的基础API。
java.beans - package java.beans
包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
java.beans.beancontext - package java.beans.beancontext
提供与bean上下文相关的类和接口。
java.compiler - module java.compiler
定义语言模型，注释处理和Java编译器API。
java.corba - module java.corba
定义OMG CORBA API和RMI-IIOP API的Java绑定。
java.datatransfer - module java.datatransfer
定义用于在应用程序之间和之间传输数据的API。
java.desktop - module java.desktop
定义AWT和Swing用户界面工具包，以及可访问性，音频，映像，打印和JavaBeans的API。
java.instrument - module java.instrument
定义允许代理程序在JVM上运行程序的服务。
java.io - package java.io
通过数据流，序列化和文件系统提供系统输入和输出。
java.jnlp - module java.jnlp
定义Java网络启动协议API（JNLP）。
java.lang - package java.lang
提供对Java编程语言设计至关重要的类。
java.lang.annotation - package java.lang.annotation
为Java编程语言注释工具提供库支持。
java.lang.instrument - package java.lang.instrument
提供允许Java编程语言代理仪器在JVM上运行程序的服务。
java.lang.invoke - package java.lang.invoke
java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
java.lang.management - package java.lang.management
提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
java.lang.module - package java.lang.module
通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
java.lang.ref - package java.lang.ref
提供参考对象类，它支持与垃圾收集器的有限度的交互。
java.lang.reflect - package java.lang.reflect
提供用于获取关于类和对象的反射信息的类和接口。
java.logging - module java.logging
定义Java Logging API。
java.management - module java.management
定义Java管理扩展（JMX）API。
java.management.rmi - module java.management.rmi
定义Java管理扩展（JMX）Remote API的 RMI connector 。
java.math - package java.math
提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
java.naming - module java.naming
定义Java命名和目录接口（JNDI）API。
java.net - package java.net
提供实现网络应用程序的类。
java.net.spi - package java.net.spi
服务提供商类为 java.net包。
java.nio - package java.nio
定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
java.nio.channels - package java.nio.channels
定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
java.nio.channels.spi - package java.nio.channels.spi
服务提供商类为 java.nio.channels包。
java.nio.charset - package java.nio.charset
定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
java.nio.charset.spi - package java.nio.charset.spi
java.nio.charset包的服务提供商类。
java.nio.file - package java.nio.file
定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
java.nio.file.attribute - package java.nio.file.attribute
提供访问文件和文件系统属性的接口和类。
java.nio.file.spi - package java.nio.file.spi
服务提供商类为 java.nio.file包。
java.prefs - module java.prefs
定义首选项API。
java.rmi - module java.rmi
定义远程方法调用（RMI）API。
java.rmi - package java.rmi
提供RMI包。
java.rmi.activation - package java.rmi.activation
提供对RMI对象激活的支持。
java.rmi.dgc - package java.rmi.dgc
提供RMI分布式垃圾收集（DGC）的类和接口。
java.rmi.registry - package java.rmi.registry
为RMI注册表提供一个类和两个接口。
java.rmi.server - package java.rmi.server
提供用于支持RMI服务器端的类和接口。
java.scripting - module java.scripting
定义脚本API。
java.se - module java.se
定义核心Java SE API。
java.se.ee - module java.se.ee
定义Java SE平台的完整API。
java.security - package java.security
提供安全框架的类和接口。
java.security.acl - package java.security.acl
此包中的类和接口已被弃用。
java.security.cert - package java.security.cert
提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
java.security.interfaces - package java.security.interfaces
提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
java.security.jgss - module java.security.jgss
定义IETF通用安全服务API（GSS-API）的Java绑定。
java.security.sasl - module java.security.sasl
定义IETF简单认证和安全层（SASL）的Java支持。
java.security.spec - package java.security.spec
提供关键规范和算法参数规范的类和接口。
java.smartcardio - module java.smartcardio
定义Java智能卡I / O API。
java.sql - module java.sql
定义JDBC API。
java.sql - package java.sql
提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
java.sql.rowset - module java.sql.rowset
定义JDBC RowSet API。
java.text - package java.text
提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
java.text.spi - package java.text.spi
java.text包中类的服务提供者类。
java.time - package java.time
日期，时间，瞬间和持续时间的主要API。
java.time.chrono - package java.time.chrono
除默认ISO之外的日历系统的通用API。
java.time.format - package java.time.format
提供打印和解析日期和时间的类。
java.time.temporal - package java.time.temporal
使用字段和单位访问日期和时间，以及日期时间调整器。
java.time.zone - package java.time.zone
支持时区及其规则。
java.transaction - module java.transaction
定义Java Transaction API（JTA）的一个子集来支持CORBA互操作。
java.util - package java.util
包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
java.util.concurrent - package java.util.concurrent
实用程序类通常用于并发编程。
java.util.concurrent.atomic - package java.util.concurrent.atomic
一个小型工具包，支持单个变量上的无锁线程安全编程。
java.util.concurrent.locks - package java.util.concurrent.locks
接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
java.util.function - package java.util.function
功能界面提供了lambda表达式和方法引用的目标类型。
java.util.jar - package java.util.jar
提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
java.util.logging - package java.util.logging
提供Java¢2平台核心日志记录工具的类和接口。
java.util.prefs - package java.util.prefs
该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
java.util.regex - package java.util.regex
匹配字符序列与正则表达式指定的模式的类。
java.util.spi - package java.util.spi
java.util包中类的服务提供者类。
java.util.stream - package java.util.stream
支持元素流功能性操作的类，例如集合上的map-reduce转换。
java.util.zip - package java.util.zip
提供读写标准ZIP和GZIP文件格式的类。
java.xml - module java.xml
定义用于XML处理的Java API（JAXP），Streaming API for XML（StAX），Simple API for XML（SAX）和W3C文档对象模型（DOM）API。
java.xml.bind - module java.xml.bind
定义用于XML绑定（JAXB）API的Java体系结构。
java.xml.crypto - module java.xml.crypto
定义XML加密的API。
java.xml.ws - module java.xml.ws
定义基于XML的Web服务（JAX-WS）的Java API和Web服务元数据API。
java.xml.ws.annotation - module java.xml.ws.annotation
定义Common Annotations API的一个子集，以支持在Java SE平台上运行的程序。
JavaBean - Annotation Type in java.beans
用于为自动生成的BeanInfo类指定一些类相关信息的注释。
JavaBeanBooleanProperty - Class in javafx.beans.property.adapter
A JavaBeanBooleanProperty提供了一种类型为 boolean或 Boolean的常规Java Bean属性和JavaFX BooleanProperty之间的适配器。
JavaBeanBooleanPropertyBuilder - Class in javafx.beans.property.adapter
A JavaBeanBooleanPropertyBuilder可以用来创建JavaBeanBooleanProperties 。
JavaBeanBooleanPropertyBuilder() - Constructor for class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder
JavaBeanDoubleProperty - Class in javafx.beans.property.adapter
A JavaBeanDoubleProperty提供了一种类型为 double或 Double的常规Java Bean属性和JavaFX DoubleProperty之间的适配器。
JavaBeanDoublePropertyBuilder - Class in javafx.beans.property.adapter
A JavaBeanDoublePropertyBuilder可以用来创建JavaBeanDoubleProperties 。
JavaBeanDoublePropertyBuilder() - Constructor for class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder
JavaBeanFloatProperty - Class in javafx.beans.property.adapter
A JavaBeanFloatProperty在类型为 float或 Float的常规Java Bean属性和JavaFX FloatProperty之间提供了适配器。
JavaBeanFloatPropertyBuilder - Class in javafx.beans.property.adapter
A JavaBeanFloatPropertyBuilder可以用来创建JavaBeanFloatProperties 。
JavaBeanFloatPropertyBuilder() - Constructor for class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder
JavaBeanIntegerProperty - Class in javafx.beans.property.adapter
A JavaBeanIntegerProperty在类型为 int或 Integer的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。
JavaBeanIntegerPropertyBuilder - Class in javafx.beans.property.adapter
A JavaBeanIntegerPropertyBuilder可以用来创建JavaBeanIntegerProperties 。
JavaBeanIntegerPropertyBuilder() - Constructor for class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder
JavaBeanLongProperty - Class in javafx.beans.property.adapter
A JavaBeanLongProperty在类型为 long或 Long的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。
JavaBeanLongPropertyBuilder - Class in javafx.beans.property.adapter
A JavaBeanLongPropertyBuilder可用于创建JavaBeanLongProperties 。
JavaBeanLongPropertyBuilder() - Constructor for class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder
JavaBeanObjectProperty< T> - Class in javafx.beans.property.adapter
A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了适配器。
JavaBeanObjectPropertyBuilder< T> - Class in javafx.beans.property.adapter
A JavaBeanObjectPropertyBuilder可以用来创建JavaBeanObjectProperties 。
JavaBeanObjectPropertyBuilder() - Constructor for class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder
JavaBeanProperty< T> - Interface in javafx.beans.property.adapter
JavaBeanProperty是可写Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
JavaBeanStringProperty - Class in javafx.beans.property.adapter
A JavaBeanStringProperty在类型为 String的常规Java Bean属性和JavaFX StringProperty之间提供了一个适配器。
JavaBeanStringPropertyBuilder - Class in javafx.beans.property.adapter
A JavaBeanStringPropertyBuilder可以用来创建JavaBeanStringProperties 。
JavaBeanStringPropertyBuilder() - Constructor for class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder
JavaCompiler - Interface in javax.tools
从程序中调用Java编程语言编译器的接口。
JavaCompiler.CompilationTask - Interface in javax.tools
代表编译任务的未来的接口。
JavacTask - Class in com.sun.source.util
提供对JDK Java编译器javac特有的功能的访问。
JavacTask() - Constructor for class com.sun.source.util. JavacTask
javadoc() - Method in interface jdk.jshell. SourceCodeAnalysis.Documentation
给定元素的javadoc。
javaFileListFlavor - Static variable in class java.awt.datatransfer. DataFlavor
要将文件列表/从Java（和底层平台） DataFlavor到此类型/类型的 java.util.List和表示类别为 java.util.List 。
JavaFileManager - Interface in javax.tools
用于Java编程语言源和类文件的工具的文件管理器。
JavaFileManager.Location - Interface in javax.tools
文件对象的位置接口。
JavaFileObject - Interface in javax.tools
用于Java编程语言源和类文件的工具的文件抽象。
JavaFileObject.Kind - Enum in javax.tools
种类的JavaFileObjects。
JAVAFX_VERSION - Static variable in class javafx.fxml. FXMLLoader
包含当前的javafx版本。
javafx.animation - package javafx.animation
提供一组类，便于使用基于过渡的动画。
javafx.application - package javafx.application
提供应用程序生命周期类。
javafx.base - module javafx.base
定义JavaFX UI工具包的基本API，包括用于绑定，属性，集合和事件的API。
javafx.beans - package javafx.beans
包 javafx.beans包含定义最通用形式的可观察性的接口。
javafx.beans.binding - package javafx.beans.binding
提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。
javafx.beans.property - package javafx.beans.property
程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。
javafx.beans.property.adapter - package javafx.beans.property.adapter
提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
javafx.beans.value - package javafx.beans.value
包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
javafx.collections - package javafx.collections
包含基本的JavaFX集合和集合实用程序
javafx.collections.transformation - package javafx.collections.transformation
提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
javafx.concurrent - package javafx.concurrent
提供javafx.task的一组类。
javafx.controls - module javafx.controls
定义可用于JavaFX UI工具包的UI控件，图表和外观。
javafx.css - package javafx.css
提供API，通过CSS使属性变得风格，并支持伪类状态。
javafx.css.converter - package javafx.css.converter
提供各种转换CSS解析值的StyleConverter类。
javafx.embed.swing - package javafx.embed.swing
提供一组在Swing应用程序中使用JavaFX的类。
javafx.event - package javafx.event
为FX事件，交付和处理提供基本框架。
javafx.fxml - module javafx.fxml
定义JavaFX UI工具包的FXML API。
javafx.fxml - package javafx.fxml
包含用于从标记加载对象层次结构的类。
javafx.geometry - package javafx.geometry
提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
javafx.graphics - module javafx.graphics
定义JavaFX UI工具包的核心场景API（如布局容器，应用程序生命周期，形状，转换，画布，输入，绘画，图像处理和效果），以及用于动画，CSS，并发，几何，打印的API和窗口。
javafx.media - module javafx.media
定义用于播放媒体和音频内容的API，作为JavaFX UI工具包的一部分，包括MediaView和MediaPlayer 。
javafx.print - package javafx.print
提供JavaFX Printing API的公共类。
javafx.scene - package javafx.scene
为JavaFX Scene Graph API提供核心的基类集。
javafx.scene.canvas - package javafx.scene.canvas
为canvas提供一组类，即渲染API的立即模式样式。
javafx.scene.chart - package javafx.scene.chart
JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
javafx.scene.control - package javafx.scene.control
JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
javafx.scene.control.cell - package javafx.scene.control.cell
所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
javafx.scene.control.skin - package javafx.scene.control.skin
javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
javafx.scene.effect - package javafx.scene.effect
提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
javafx.scene.image - package javafx.scene.image
提供加载和显示图像的一组类。
javafx.scene.input - package javafx.scene.input
提供一组用于鼠标和键盘输入事件处理的类。
javafx.scene.layout - package javafx.scene.layout
提供类来支持用户界面布局。
javafx.scene.media - package javafx.scene.media
提供用于将音频和视频集成到Java FX应用程序中的一组类。
javafx.scene.paint - package javafx.scene.paint
提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
javafx.scene.shape - package javafx.scene.shape
提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
javafx.scene.text - package javafx.scene.text
为字体和可渲染的文本节点提供一组类。
javafx.scene.transform - package javafx.scene.transform
提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
javafx.scene.web - package javafx.scene.web
该软件包提供了加载和显示Web内容的方法。
javafx.stage - package javafx.stage
提供JavaFX内容的顶级容器类。
javafx.swing - module javafx.swing
定义JavaFX UI工具包中包含的JavaFX / Swing互操作性支持API，包括SwingNode （用于嵌入JavaFX应用程序中的Swing）和JFXPanel （用于在Swing应用程序中嵌入JavaFX）。
javafx.util - package javafx.util
包含各种实用程序和助手类。
javafx.util.converter - package javafx.util.converter
此包用于JavaFX的标准字符串转换器。
javafx.web - module javafx.web
定义JavaFX UI工具包中包含的WebView功能的API。
JavaFXBuilderFactory - Class in javafx.fxml
JavaFX构建工厂。
JavaFXBuilderFactory() - Constructor for class javafx.fxml. JavaFXBuilderFactory
默认构造函数。
JavaFXBuilderFactory(ClassLoader) - Constructor for class javafx.fxml. JavaFXBuilderFactory
构造器接收类加载器。
javaJVMLocalObjectMimeType - Static variable in class java.awt.datatransfer. DataFlavor
要将引用传递给具有相关MIME内容类型的任意Java对象引用，跨 Transferable在同一JVM中的 Transferable接口，将 DataFlavor具有此类型/子类型的 representationClass ，其中 representationClass等于类/接口的类型正在通过 Transferable 。
JAVANESE - java.awt.font. NumericShaper.Range
爪哇范围与爪哇数字。
JAVANESE - java.lang. Character.UnicodeScript
Unicode脚本“爪哇”。
JAVANESE - Static variable in class java.lang. Character.UnicodeBlock
“爪哇”Unicode字符块的常量。
javaRemoteObjectMimeType - Static variable in class java.awt.datatransfer. DataFlavor
为了通过拖放 ACTION_LINK操作将实时链接传递给远程对象， ACTION_LINK使用Mime Content应用程序类型/ x-java-remote-object，其中 DataFlavor的表示类表示 Remote接口的类型被转移。
javaScriptEnabledProperty() - Method in class javafx.scene.web. WebEngine
指定是否启用JavaScript执行。
javaSerializedObjectMimeType - Static variable in class java.awt.datatransfer. DataFlavor
MIME内容 - 应用程序类型/ x-java-serialized-object表示已被持久化的Java对象的图形。
JavaShellToolBuilder - Interface in jdk.jshell.tool
用于配置和运行Java Shell工具实例的接口。
javax.accessibility - package javax.accessibility
定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
javax.activation - package javax.activation
javax.activity - package javax.activity
包含ORB机械在解组时抛出的活动服务相关异常。
javax.annotation - package javax.annotation
javax.annotation.processing - package javax.annotation.processing
用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
javax.crypto - package javax.crypto
提供加密操作的类和接口。
javax.crypto.interfaces - package javax.crypto.interfaces
提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
javax.crypto.spec - package javax.crypto.spec
提供关键规范和算法参数规范的类和接口。
javax.imageio - package javax.imageio
Java Image I / O API的主要包。
javax.imageio.event - package javax.imageio.event
一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
javax.imageio.metadata - package javax.imageio.metadata
处理读写元数据的Java Image I / O API的一个包。
javax.imageio.plugins.bmp - package javax.imageio.plugins.bmp
包含内置BMP插件使用的公共类的软件包。
javax.imageio.plugins.jpeg - package javax.imageio.plugins.jpeg
支持内置JPEG插件的类。
javax.imageio.plugins.tiff - package javax.imageio.plugins.tiff
内置TIFF插件使用的公共类。
javax.imageio.spi - package javax.imageio.spi
包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
javax.imageio.stream - package javax.imageio.stream
Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
javax.jnlp - package javax.jnlp
JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
javax.jws - package javax.jws
javax.jws.soap - package javax.jws.soap
javax.lang.model - package javax.lang.model
用于建模Java编程语言的软件包的类和层次结构。
javax.lang.model.element - package javax.lang.model.element
用于建模Java编程语言元素的接口。
javax.lang.model.type - package javax.lang.model.type
用于建模Java编程语言类型的接口。
javax.lang.model.util - package javax.lang.model.util
协助处理 program elements及 types的公用事业 。
javax.management - package javax.management
提供Java管理扩展的核心类。
javax.management.loading - package javax.management.loading
提供实现高级动态加载的类。
javax.management.modelmbean - package javax.management.modelmbean
提供ModelMBean类的定义。
javax.management.monitor - package javax.management.monitor
提供监视器类的定义。
javax.management.openmbean - package javax.management.openmbean
提供打开的数据类型和Open MBean描述符类。
javax.management.relation - package javax.management.relation
提供关系服务的定义。
javax.management.remote - package javax.management.remote
用于远程访问JMX MBean服务器的接口。
javax.management.remote.rmi - package javax.management.remote.rmi
RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
javax.management.timer - package javax.management.timer
提供定时器MBean的定义。
javax.naming - package javax.naming
提供用于访问命名服务的类和接口。
javax.naming.directory - package javax.naming.directory
扩展 javax.naming包以提供访问目录服务的功能。
javax.naming.event - package javax.naming.event
访问命名和目录服务时，提供对事件通知的支持。
javax.naming.ldap - package javax.naming.ldap
提供对LDAPv3扩展操作和控件的支持。
javax.naming.spi - package javax.naming.spi
提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
javax.net - package javax.net
提供网络应用程序的类。
javax.net.ssl - package javax.net.ssl
为安全套接字包提供类。
javax.print - package javax.print
提供Java®打印服务API的主要类和接口。
javax.print.attribute - package javax.print.attribute
提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
javax.print.attribute.standard - package javax.print.attribute.standard
包javax.print.attribute.standard包含特定打印属性的类。
javax.print.event - package javax.print.event
程序包javax.print.event包含事件类和侦听器接口。
javax.rmi - package javax.rmi
包含RMI-IIOP的用户API。
javax.rmi.CORBA - package javax.rmi.CORBA
包含RMI-IIOP的可移植API。
javax.rmi.ssl - package javax.rmi.ssl
通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
javax.script - package javax.script
脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
javax.security.auth - package javax.security.auth
此软件包提供了认证和授权的框架。
javax.security.auth.callback - package javax.security.auth.callback
该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
javax.security.auth.kerberos - package javax.security.auth.kerberos
此包包含与Kerberos网络身份验证协议相关的实用程序类。
javax.security.auth.login - package javax.security.auth.login
该包提供了一个可插拔的认证框架。
javax.security.auth.spi - package javax.security.auth.spi
该包提供了用于实现可插拔认证模块的接口。
javax.security.auth.x500 - package javax.security.auth.x500
该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
javax.security.cert - package javax.security.cert
提供公钥证书类。
javax.security.sasl - package javax.security.sasl
包含用于支持SASL的类和接口。
javax.smartcardio - package javax.smartcardio
Java™智能卡I / O API
javax.sound.midi - package javax.sound.midi
提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
javax.sound.midi.spi - package javax.sound.midi.spi
为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
javax.sound.sampled - package javax.sound.sampled
提供用于捕获，处理和播放采样音频数据的接口和类。
javax.sound.sampled.spi - package javax.sound.sampled.spi
为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
javax.sql - package javax.sql
通过Java编程语言为服务器端数据源访问和处理提供API。
javax.sql.rowset - package javax.sql.rowset
JDBC RowSet实现的标准接口和基类。
javax.sql.rowset.serial - package javax.sql.rowset.serial
提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
javax.sql.rowset.spi - package javax.sql.rowset.spi
第三方供应商在实施同步提供程序时必须使用的标准类和接口。
javax.swing - package javax.swing
提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
javax.swing.border - package javax.swing.border
提供用于绘制Swing组件周围特殊边框的类和接口。
javax.swing.colorchooser - package javax.swing.colorchooser
包含 JColorChooser组件使用的类和接口。
javax.swing.event - package javax.swing.event
提供Swing组件触发的事件。
javax.swing.filechooser - package javax.swing.filechooser
包含 JFileChooser组件使用的类和接口。
javax.swing.plaf - package javax.swing.plaf
提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
javax.swing.plaf.basic - package javax.swing.plaf.basic
提供根据“基本”外观构建的用户界面对象。
javax.swing.plaf.metal - package javax.swing.plaf.metal
提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
javax.swing.plaf.multi - package javax.swing.plaf.multi
提供组合两种或多种外观和感觉的用户界面对象。
javax.swing.plaf.nimbus - package javax.swing.plaf.nimbus
提供根据跨平台Nimbus外观构建的用户界面对象。
javax.swing.plaf.synth - package javax.swing.plaf.synth
合成是一种可以让所有绘画委托的外观和感觉。
javax.swing.table - package javax.swing.table
提供处理 javax.swing.JTable类和接口。
javax.swing.text - package javax.swing.text
提供处理可编辑和不可编辑文本组件的类和接口。
javax.swing.text.html - package javax.swing.text.html
提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。
javax.swing.text.html.parser - package javax.swing.text.html.parser
提供默认的HTML解析器以及支持类。
javax.swing.text.rtf - package javax.swing.text.rtf
提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
javax.swing.tree - package javax.swing.tree
提供处理 javax.swing.JTree类和接口。
javax.swing.undo - package javax.swing.undo
允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
javax.tools - package javax.tools
为可以从程序调用的工具提供接口，例如编译器。
javax.transaction - package javax.transaction
包含ORB机械在解组期间抛出的三个异常。
javax.transaction.xa - package javax.transaction.xa
提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。
javax.xml - package javax.xml
定义XML处理的常量。
javax.xml.bind - package javax.xml.bind
为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
javax.xml.bind.annotation - package javax.xml.bind.annotation
定义用于将Java程序元素定制到XML模式映射的注释。
javax.xml.bind.annotation.adapters - package javax.xml.bind.annotation.adapters
XmlAdapter及其指定的子类允许任意Java类与JAXB一起使用。
javax.xml.bind.attachment - package javax.xml.bind.attachment
该包由基于MIME的包处理器实现，可以在基于MIME的包格式中解释和创建优化的二进制数据。
javax.xml.bind.helpers - package javax.xml.bind.helpers
仅限JAXB提供者使用：为部分 javax.xml.bind接口提供部分默认实现。
javax.xml.bind.util - package javax.xml.bind.util
有用的客户端工具类。
javax.xml.catalog - package javax.xml.catalog
提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
javax.xml.crypto - package javax.xml.crypto
XML加密的通用类。
javax.xml.crypto.dom - package javax.xml.crypto.dom
针对 javax.xml.crypto包的DOM特定类。
javax.xml.crypto.dsig - package javax.xml.crypto.dsig
用于生成和验证XML数字签名的类。
javax.xml.crypto.dsig.dom - package javax.xml.crypto.dsig.dom
针对 javax.xml.crypto.dsig包的DOM特定类。
javax.xml.crypto.dsig.keyinfo - package javax.xml.crypto.dsig.keyinfo
用于解析和处理的元素和结构的类别KeyInfo 。
javax.xml.crypto.dsig.spec - package javax.xml.crypto.dsig.spec
XML数字签名的参数类。
javax.xml.datatype - package javax.xml.datatype
定义XML / Java类型映射。
javax.xml.namespace - package javax.xml.namespace
定义XML命名空间处理。
javax.xml.parsers - package javax.xml.parsers
提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
javax.xml.soap - package javax.xml.soap
提供用于创建和构建SOAP消息的API。
javax.xml.stream - package javax.xml.stream
定义Streaming API for XML（StAX）的接口和类。
javax.xml.stream.events - package javax.xml.stream.events
定义Streaming API for XML（StAX）的事件接口。
javax.xml.stream.util - package javax.xml.stream.util
为Streaming API for XML（StAX）提供实用程序类。
javax.xml.transform - package javax.xml.transform
定义用于处理转换指令的通用API，以及执行从源到结果的转换。
javax.xml.transform.dom - package javax.xml.transform.dom
提供DOM特定的转换类。
javax.xml.transform.sax - package javax.xml.transform.sax
提供SAX特定的转换类。
javax.xml.transform.stax - package javax.xml.transform.stax
提供StAX特定的转换类。
javax.xml.transform.stream - package javax.xml.transform.stream
提供流和URI特定的转换类。
javax.xml.validation - package javax.xml.validation
提供用于验证XML文档的API。
javax.xml.ws - package javax.xml.ws
此软件包包含核心JAX-WS API。
javax.xml.ws.handler - package javax.xml.ws.handler
新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
javax.xml.ws.handler.soap - package javax.xml.ws.handler.soap
此包定义SOAP消息处理程序的API。
javax.xml.ws.http - package javax.xml.ws.http
该包定义了特定于HTTP绑定的API。
javax.xml.ws.soap - package javax.xml.ws.soap
该包定义了SOAP绑定专用的API。
javax.xml.ws.spi - package javax.xml.ws.spi
此套件为JAX-WS定义了SPI。
javax.xml.ws.spi.http - package javax.xml.ws.spi.http
提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
javax.xml.ws.wsaddressing - package javax.xml.ws.wsaddressing
此包定义与WS-Addressing相关的API。
javax.xml.xpath - package javax.xml.xpath
提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
JAXB - Class in javax.xml.bind
定义方便方法的类用于常见，简单的使用JAXB。
JAXB_CONTEXT_FACTORY - Static variable in class javax.xml.bind. JAXBContext
包含能够创建新的 JAXBContext对象的类的名称的属性的名称。
JAXB_ENCODING - Static variable in interface javax.xml.bind. Marshaller
用于在编组的XML数据中指定输出编码的属性的名称。
JAXB_FORMATTED_OUTPUT - Static variable in interface javax.xml.bind. Marshaller
用于指定编组的XML数据是否使用换行符和缩进格式化的属性的名称。
JAXB_FRAGMENT - Static variable in interface javax.xml.bind. Marshaller
用于指定编组器是否生成文档级事件（即调用startDocument或endDocument）的属性的名称。
JAXB_NO_NAMESPACE_SCHEMA_LOCATION - Static variable in interface javax.xml.bind. Marshaller
用于指定要排列在编组XML输出中的xsi：noNamespaceSchemaLocation属性值的属性名称。
JAXB_SCHEMA_LOCATION - Static variable in interface javax.xml.bind. Marshaller
用于指定要排列在编组XML输出中的xsi：schemaLocation属性值的属性名称。
JAXBContext - Class in javax.xml.bind
JAXBContext类为客户端提供了JAXB API的入口点。
JAXBContext() - Constructor for class javax.xml.bind. JAXBContext
JAXBContextFactory - Interface in javax.xml.bind
创建新的 JAXBContext实例的工厂。
JAXBElement< T> - Class in javax.xml.bind
一个Xml元素的JAXB表示。
JAXBElement(QName, Class<T>, Class, T) - Constructor for class javax.xml.bind. JAXBElement
构造一个xml元素实例。
JAXBElement(QName, Class<T>, T) - Constructor for class javax.xml.bind. JAXBElement
构造一个xml元素实例。
JAXBElement.GlobalScope - Class in javax.xml.bind
指定xml元素的全局范围。
JAXBException - Exception in javax.xml.bind
这是所有JAXB异常的根异常类。
JAXBException(String) - Constructor for exception javax.xml.bind. JAXBException
构造具有指定详细消息的JAXBException。
JAXBException(String, String) - Constructor for exception javax.xml.bind. JAXBException
构造具有指定的详细消息和供应商特定的错误代码的JAXBException。
JAXBException(String, String, Throwable) - Constructor for exception javax.xml.bind. JAXBException
构造具有指定的详细消息，供应商特定的错误代码和linkedException的JAXBException。
JAXBException(String, Throwable) - Constructor for exception javax.xml.bind. JAXBException
构造具有指定的详细消息和linkedException的JAXBException。
JAXBException(Throwable) - Constructor for exception javax.xml.bind. JAXBException
使用linkedException构造一个JAXBException。
JAXBIntrospector - Class in javax.xml.bind
提供对JAXB对象的JAXB xml绑定数据的访问。
JAXBIntrospector() - Constructor for class javax.xml.bind. JAXBIntrospector
JAXBPermission - Class in javax.xml.bind
此类用于JAXB权限。
JAXBPermission(String) - Constructor for class javax.xml.bind. JAXBPermission
创建具有指定名称的新JAXBPermission。
JAXBResult - Class in javax.xml.bind.util
JAXP Result实现解组JAXB对象。
JAXBResult(JAXBContext) - Constructor for class javax.xml.bind.util. JAXBResult
创建一个使用指定的JAXBContext解组的新实例。
JAXBResult(Unmarshaller) - Constructor for class javax.xml.bind.util. JAXBResult
创建一个使用指定的Unmarshaller解组对象的新实例。
JAXBSource - Class in javax.xml.bind.util
编写 JAXB生成的对象的JAXP Source实现。
JAXBSource(JAXBContext, Object) - Constructor for class javax.xml.bind.util. JAXBSource
为给定的内容对象创建一个新的Source 。
JAXBSource(Marshaller, Object) - Constructor for class javax.xml.bind.util. JAXBSource
为给定的内容对象创建一个新的Source 。
JButton - Class in javax.swing
实现“推”按钮。
JButton() - Constructor for class javax.swing. JButton
创建一个没有设置文本或图标的按钮。
JButton(String) - Constructor for class javax.swing. JButton
创建一个带文本的按钮。
JButton(String, Icon) - Constructor for class javax.swing. JButton
创建一个带有初始文本和图标的按钮。
JButton(Action) - Constructor for class javax.swing. JButton
创建一个按钮，其属性取自提供的 Action 。
JButton(Icon) - Constructor for class javax.swing. JButton
创建一个带有图标的按钮。
JButton.AccessibleJButton - Class in javax.swing
这个类实现 JButton类的辅助功能支持。
JCheckBox - Class in javax.swing
复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
JCheckBox() - Constructor for class javax.swing. JCheckBox
创建一个最初未选择的复选框按钮，没有文字，没有图标。
JCheckBox(String) - Constructor for class javax.swing. JCheckBox
创建一个最初未选择的复选框与文本。
JCheckBox(String, boolean) - Constructor for class javax.swing. JCheckBox
创建一个带有文本的复选框，并指定是否最初选择它。
JCheckBox(String, Icon) - Constructor for class javax.swing. JCheckBox
使用指定的文本和图标创建最初未选择的复选框。
JCheckBox(String, Icon, boolean) - Constructor for class javax.swing. JCheckBox
创建一个带有文本和图标的复选框，并指定是否最初选择它。
JCheckBox(Action) - Constructor for class javax.swing. JCheckBox
创建一个复选框，其中从提供的操作中获取属性。
JCheckBox(Icon) - Constructor for class javax.swing. JCheckBox
创建一个带有图标的最初未选中的复选框。
JCheckBox(Icon, boolean) - Constructor for class javax.swing. JCheckBox
创建一个带有图标的复选框，并指定是否最初选择它。
JCheckBox.AccessibleJCheckBox - Class in javax.swing
该类实现 JCheckBox类的辅助功能支持。
JCheckBoxMenuItem - Class in javax.swing
可以选择或取消选择的菜单项。
JCheckBoxMenuItem() - Constructor for class javax.swing. JCheckBoxMenuItem
创建一个没有设置文本或图标的初始未选择的复选框菜单项。
JCheckBoxMenuItem(String) - Constructor for class javax.swing. JCheckBoxMenuItem
用文本创建一个初始未选择的复选框菜单项。
JCheckBoxMenuItem(String, boolean) - Constructor for class javax.swing. JCheckBoxMenuItem
创建具有指定文本和选择状态的复选框菜单项。
JCheckBoxMenuItem(String, Icon) - Constructor for class javax.swing. JCheckBoxMenuItem
使用指定的文本和图标创建最初未选择的复选框菜单项。
JCheckBoxMenuItem(String, Icon, boolean) - Constructor for class javax.swing. JCheckBoxMenuItem
创建带有指定文本，图标和选择状态的复选框菜单项。
JCheckBoxMenuItem(Action) - Constructor for class javax.swing. JCheckBoxMenuItem
创建一个菜单项，其属性取自提供的操作。
JCheckBoxMenuItem(Icon) - Constructor for class javax.swing. JCheckBoxMenuItem
创建一个带有图标的最初未选中的复选框菜单项。
JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem - Class in javax.swing
这个类实现 JCheckBoxMenuItem类的可访问性支持。
JColorChooser - Class in javax.swing
JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
JColorChooser() - Constructor for class javax.swing. JColorChooser
创建一个初始颜色为白色的颜色选择器窗格。
JColorChooser(Color) - Constructor for class javax.swing. JColorChooser
创建具有指定初始颜色的颜色选择器窗格。
JColorChooser(ColorSelectionModel) - Constructor for class javax.swing. JColorChooser
创建具有指定的颜色选择器窗格 ColorSelectionModel 。
JColorChooser.AccessibleJColorChooser - Class in javax.swing
这个类实现 JColorChooser类的可访问性支持。
JComboBox< E> - Class in javax.swing
组合按钮或可编辑字段和下拉列表的组件。
JComboBox() - Constructor for class javax.swing. JComboBox
使用默认数据模型创建 JComboBox 。
JComboBox(E[]) - Constructor for class javax.swing. JComboBox
创建一个 JComboBox ，其中包含指定数组中的元素。
JComboBox(Vector<E>) - Constructor for class javax.swing. JComboBox
创建包含指定向量中的元素的 JComboBox 。
JComboBox(ComboBoxModel<E>) - Constructor for class javax.swing. JComboBox
创建一个 JComboBox ，从现有的 ComboBoxModel获取它的项目。
JComboBox.AccessibleJComboBox - Class in javax.swing
该类为 JComboBox类实现可访问性支持。
JComboBox.KeySelectionManager - Interface in javax.swing
界面定义了一个 KeySelectionManager 。
JComponent - Class in javax.swing
除顶级容器之外的所有Swing组件的基类。
JComponent() - Constructor for class javax.swing. JComponent
默认 JComponent构造函数。
JCOMPONENT_UI - Static variable in class javax.print. ServiceUIFactory
表示实现为Swing组件的UI。
JComponent.AccessibleJComponent - Class in javax.swing
JComponent的内部类用于为辅助功能提供默认支持。
JComponent.AccessibleJComponent.AccessibleContainerHandler - Class in javax.swing
Fire PropertyChange监听器，如果一个注册，当孩子添加/删除。
JComponent.AccessibleJComponent.AccessibleFocusHandler - Class in javax.swing
已过时。
此类不再使用或需要。 java.awt.Component.AccessibleAWTComponent提供相同的功能，它在Component处理。
JConsoleContext - Interface in com.sun.tools.jconsole
JConsoleContext表示与目标应用程序的JConsole连接。
JConsoleContext.ConnectionState - Enum in com.sun.tools.jconsole
ConnectionState绑定属性的值。
JConsolePlugin - Class in com.sun.tools.jconsole
一个JConsole插件类。
JConsolePlugin() - Constructor for class com.sun.tools.jconsole. JConsolePlugin
构造函数。
jdbcCompliant() - Method in interface java.sql. Driver
报告此驱动程序是否是一个真正的JDBC兼容驱动程序。
JdbcRowSet - Interface in javax.sql.rowset
JdbcRowSet所有标准实现必须实现的标准接口。
JDBCType - Enum in java.sql
定义用于标识通用SQL类型（称为JDBC类型）的常量。
JDesktopIcon(JInternalFrame) - Constructor for class javax.swing. JInternalFrame.JDesktopIcon
创建内部框架的图标。
JDesktopPane - Class in javax.swing
用于创建多文档界面或虚拟桌面的容器。
JDesktopPane() - Constructor for class javax.swing. JDesktopPane
创建一个新的 JDesktopPane 。
JDesktopPane.AccessibleJDesktopPane - Class in javax.swing
该类实现 JDesktopPane类的可访问性支持。
JDialog - Class in javax.swing
创建对话窗口的主要类。
JDialog() - Constructor for class javax.swing. JDialog
创建一个没有标题的无模式对话框，而不指定 Frame所有者。
JDialog(Dialog) - Constructor for class javax.swing. JDialog
创建一个无 Dialog对话框，其中指定的是 Dialog作为其所有者，并且是空的标题。
JDialog(Dialog, boolean) - Constructor for class javax.swing. JDialog
创建一个具有空标题和指定模态的 Dialog ，其中所有者为 Dialog 。
JDialog(Dialog, String) - Constructor for class javax.swing. JDialog
使用指定的标题和指定的所有者对话框创建无模式对话框。
JDialog(Dialog, String, boolean) - Constructor for class javax.swing. JDialog
创建一个具有指定标题，模态和指定所有者的 Dialog 。
JDialog(Dialog, String, boolean, GraphicsConfiguration) - Constructor for class javax.swing. JDialog
创建一个具有指定标题的对话框，所有者 Dialog ，模式和 GraphicsConfiguration 。
JDialog(Frame) - Constructor for class javax.swing. JDialog
使用指定的 Frame作为其所有者创建无模式对话框，并创建一个空标题。
JDialog(Frame, boolean) - Constructor for class javax.swing. JDialog
创建一个具有空标题和指定模态的 Frame ，其中所有者为 Frame 。
JDialog(Frame, String) - Constructor for class javax.swing. JDialog
使用指定的标题和指定的所有者框架创建无模式对话框。
JDialog(Frame, String, boolean) - Constructor for class javax.swing. JDialog
创建一个具有指定标题的对话框，拥有者 Frame和模态。
JDialog(Frame, String, boolean, GraphicsConfiguration) - Constructor for class javax.swing. JDialog
创建一个具有指定标题的对话框，所有者 Frame ，模式和 GraphicsConfiguration 。
JDialog(Window) - Constructor for class javax.swing. JDialog
创建一个无模式对话框，其中指定的 Window为 Window ，并且为空标题。
JDialog(Window, Dialog.ModalityType) - Constructor for class javax.swing. JDialog
创建一个具有空标题和指定模态的 Window ，其中所有者为 Window 。
JDialog(Window, String) - Constructor for class javax.swing. JDialog
使用指定的标题和所有者创建无模式对话框 Window 。
JDialog(Window, String, Dialog.ModalityType) - Constructor for class javax.swing. JDialog
创建一个具有指定标题的对话框，拥有者 Window和模态。
JDialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - Constructor for class javax.swing. JDialog
创建一个具有指定标题的对话框，所有者 Window ，模式和 GraphicsConfiguration 。
JDIALOG_UI - Static variable in class javax.print. ServiceUIFactory
表示实现为Swing对话框的UI。
JDialog.AccessibleJDialog - Class in javax.swing
该类实现 JDialog类的可访问性支持。
JdiDefaultExecutionControl - Class in jdk.jshell.execution
默认情况下，JShell-core的使用实现为ExecutionControl 。
JdiExecutionControl - Class in jdk.jshell.execution
摘要JDI实现ExecutionControl 。
JdiExecutionControl(ObjectOutput, ObjectInput) - Constructor for class jdk.jshell.execution. JdiExecutionControl
创建一个实例。
JdiExecutionControlProvider - Class in jdk.jshell.execution
远程JDI控制执行引擎的提供者。
JdiExecutionControlProvider() - Constructor for class jdk.jshell.execution. JdiExecutionControlProvider
创建一个实例。
JdiInitiator - Class in jdk.jshell.execution
设置JDI连接，提供生成的JDI VirtualMachine和远程代理正在运行的Process 。
JdiInitiator(int, List<String>, String, boolean, String, int, Map<String, String>) - Constructor for class jdk.jshell.execution. JdiInitiator
启动远程代理并建立一个JDI连接。
JDIPermission - Class in com.sun.jdi
JDIPermission类代表对 VirtualMachineManager访问权限。
JDIPermission(String) - Constructor for class com.sun.jdi. JDIPermission
JDIPermission类代表对 VirtualMachineManager访问权限
JDIPermission(String, String) - Constructor for class com.sun.jdi. JDIPermission
构造一个新的JDIPermission对象。
jdk.accessibility - module jdk.accessibility
定义Assistive Technologies实施者使用的JDK实用程序类。
jdk.attach - module jdk.attach
定义附加API。
jdk.charsets - module jdk.charsets
提供charsets ，不在java.base （大多是双字节和IBM字符集）。
jdk.compiler - module jdk.compiler
定义了 system Java compiler及其命令行等效的实现， javac以及 javah 。
jdk.crypto.cryptoki - module jdk.crypto.cryptoki
提供SunPKCS11安全提供程序的实现。
jdk.crypto.ec - module jdk.crypto.ec
提供SunEC安全提供商的实施。
jdk.dynalink - module jdk.dynalink
定义用于动态链接对象上的高级操作的API。
jdk.dynalink - package jdk.dynalink
包含用于链接 invokedynamic呼叫站点的接口和类。
jdk.dynalink.beans - package jdk.dynalink.beans
包含普通Java对象的链接器。
jdk.dynalink.linker - package jdk.dynalink.linker
包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
jdk.dynalink.linker.support - package jdk.dynalink.linker.support
包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
jdk.dynalink.support - package jdk.dynalink.support
包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。
jdk.editpad - module jdk.editpad
提供 jdk.jshell使用的编辑垫服务的 实现 。
jdk.hotspot.agent - module jdk.hotspot.agent
定义HotSpot Serviceability Agent的实现。
jdk.httpserver - module jdk.httpserver
定义JDK特定的HTTP服务器API。
jdk.incubator.http - package jdk.incubator.http
高级HTTP和WebSocket API
jdk.incubator.httpclient - module jdk.incubator.httpclient
定义高级HTTP和WebSocket API。
jdk.jartool - module jdk.jartool
定义用于操作Java Archive（JAR）文件的工具，包括 jar和 jarsigner工具。
jdk.javadoc - module jdk.javadoc
定义 system documentation tool及其命令行等效的实现， javadoc 。
jdk.javadoc.doclet - package jdk.javadoc.doclet
Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
jdk.jcmd - module jdk.jcmd
定义诊断和故障排除一个JVM，如工具 jcmd ， jps ， jstat个工具。
jdk.jconsole - module jdk.jconsole
定义JMX图形工具， jconsole ，用于监视和管理正在运行的应用程序。
jdk.jdeps - module jdk.jdeps
定义用于分析Java库和程序，包括依赖工具 jdeps ， javap ，并 jdeprscan工具。
jdk.jdi - module jdk.jdi
定义Java调试接口。
jdk.jdwp.agent - module jdk.jdwp.agent
提供Java调试线协议（JDWP）代理的实现。
jdk.jlink - module jdk.jlink
定义 jlink创建运行时图像，工具 jmod工具，用于创建和操纵JMOD文件，以及 jimage工具用于检查类和资源的JDK实现特定的容器文件。
jdk.jshell - module jdk.jshell
该模块提供对Java编程语言“片段”评估工具的支持，例如读取评估打印循环（REPL），包括 jshell工具。
jdk.jshell - package jdk.jshell
提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
jdk.jshell.execution - package jdk.jshell.execution
提供构建JShell执行引擎的实现支持。
jdk.jshell.spi - package jdk.jshell.spi
定义可插拔JShell执行引擎的服务提供程序接口。
jdk.jshell.tool - package jdk.jshell.tool
提供一种启动Javaâ壳工具实例的机制。
jdk.jsobject - module jdk.jsobject
定义JavaScript对象的API。
jdk.jstatd - module jdk.jstatd
定义用于启动jstat工具的远程监控JVM统计信息的守护程序的 jstatd工具。
jdk.localedata - module jdk.localedata
提供 US locale以外的语言环境的语言环境数据。
jdk.management - module jdk.management
为JVM定义JDK特定的管理界面。
jdk.management.agent - module jdk.management.agent
定义JMX管理代理。
jdk.naming.dns - module jdk.naming.dns
提供DNS Java命名提供程序的实现。
jdk.naming.rmi - module jdk.naming.rmi
提供RMI Java命名提供程序的实现。
jdk.nashorn.api.scripting - package jdk.nashorn.api.scripting
这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
jdk.nashorn.api.tree - package jdk.nashorn.api.tree
Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
jdk.net - module jdk.net
定义JDK特定的网络API。
jdk.net - package jdk.net
适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。
jdk.pack - module jdk.pack
定义用于将JAR文件转换为压缩的pack200文件并将打包文件转换为JAR文件的工具，包括 pack200和 unpack200工具。
jdk.packager.services - module jdk.packager.services
定义Java Packager工具使用的服务。
jdk.packager.services - package jdk.packager.services
定义Java Packager工具使用的服务。
jdk.policytool - module jdk.policytool
定义用于管理名为 policytool的策略文件的GUI工具。
jdk.rmic - module jdk.rmic
定义 rmic编译器，用于使用Java远程方法协议（JRMP）生成存根和骨架，并为远程对象使用存根和绑定类文件（IIOP协议）。
jdk.scripting.nashorn - module jdk.scripting.nashorn
提供Nashorn脚本引擎的实现和用ECMAScript 5.1编写的程序的运行时环境。
jdk.sctp - module jdk.sctp
定义用于SCTP的JDK特定API。
jdk.security.auth - module jdk.security.auth
提供 javax.security.auth.*接口和各种认证模块的实现。
jdk.security.jarsigner - package jdk.security.jarsigner
jdk.security.jgss - module jdk.security.jgss
定义GSS-API的Java扩展和SASL GSSAPI机制的实现。
jdk.snmp - module jdk.snmp
定义SNMP管理代理。
jdk.xml.dom - module jdk.xml.dom
定义不属于Java SE API的W3C文档对象模型（DOM）API的子集。
jdk.zipfs - module jdk.zipfs
提供zip文件系统提供程序的实现。
JEditorPane - Class in javax.swing
用于编辑各种内容的文本组件。
JEditorPane() - Constructor for class javax.swing. JEditorPane
创建一个新的 JEditorPane 。
JEditorPane(String) - Constructor for class javax.swing. JEditorPane
基于包含URL规范的字符串创建 JEditorPane 。
JEditorPane(String, String) - Constructor for class javax.swing. JEditorPane
创建已初始化为给定文本的 JEditorPane 。
JEditorPane(URL) - Constructor for class javax.swing. JEditorPane
根据指定的URL创建 JEditorPane输入。
JEditorPane.AccessibleJEditorPane - Class in javax.swing
该类为 JEditorPane类实现可访问性支持。
JEditorPane.AccessibleJEditorPaneHTML - Class in javax.swing
此类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。
JEditorPane.JEditorPaneAccessibleHypertextSupport - Class in javax.swing
AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText 。
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink - Class in javax.swing
一个HTML链接。
JEditorPaneAccessibleHypertextSupport() - Constructor for class javax.swing. JEditorPane.JEditorPaneAccessibleHypertextSupport
做这些小狗之一
JFileChooser - Class in javax.swing
JFileChooser为用户提供了一种简单的机制来选择文件。
JFileChooser() - Constructor for class javax.swing. JFileChooser
构造指向用户的默认目录的 JFileChooser 。
JFileChooser(File) - Constructor for class javax.swing. JFileChooser
构造一个 JFileChooser使用给定的 File作为路径。
JFileChooser(File, FileSystemView) - Constructor for class javax.swing. JFileChooser
构造一个 JFileChooser使用给定的当前目录和 FileSystemView 。
JFileChooser(String) - Constructor for class javax.swing. JFileChooser
构造一个使用给定路径的 JFileChooser 。
JFileChooser(String, FileSystemView) - Constructor for class javax.swing. JFileChooser
使用给定的当前目录路径构建一个 JFileChooser和 FileSystemView 。
JFileChooser(FileSystemView) - Constructor for class javax.swing. JFileChooser
构造一个 JFileChooser使用给定的 FileSystemView 。
JFileChooser.AccessibleJFileChooser - Class in javax.swing
这个类实现 JFileChooser类的辅助功能支持。
JFormattedTextField - Class in javax.swing
JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑文本，就检索一个特定的对象。
JFormattedTextField() - Constructor for class javax.swing. JFormattedTextField
创建 JFormattedTextField ，无 AbstractFormatterFactory 。
JFormattedTextField(Object) - Constructor for class javax.swing. JFormattedTextField
创建一个具有指定值的JFormattedTextField。
JFormattedTextField(Format) - Constructor for class javax.swing. JFormattedTextField
创建一个 JFormattedTextField 。
JFormattedTextField(JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing. JFormattedTextField
创建一个 JFormattedTextField与指定的 AbstractFormatter 。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory) - Constructor for class javax.swing. JFormattedTextField
创建一个 JFormattedTextField与指定的 AbstractFormatterFactory 。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory, Object) - Constructor for class javax.swing. JFormattedTextField
创建一个 JFormattedTextField具有指定的 AbstractFormatterFactory和初始值。
JFormattedTextField.AbstractFormatter - Class in javax.swing
AbstractFormatter实例由 JFormattedTextField用于处理从对象到字符串的转换，并从字符串返回到对象。
JFormattedTextField.AbstractFormatterFactory - Class in javax.swing
AbstractFormatterFactory实例由 JFormattedTextField用于获取 JFormattedTextField实例， AbstractFormatter这些实例又用于格式化值。
JFrame - Class in javax.swing
扩展版本的 java.awt.Frame增加了对JFC / Swing组件架构的支持。
JFrame() - Constructor for class javax.swing. JFrame
构造一个最初不可见的新框架。
JFrame(GraphicsConfiguration) - Constructor for class javax.swing. JFrame
在屏幕设备的指定 GraphicsConfiguration中创建一个 Frame和一个空白标题。
JFrame(String) - Constructor for class javax.swing. JFrame
创建一个新的，最初不可见的 Frame与指定的标题。
JFrame(String, GraphicsConfiguration) - Constructor for class javax.swing. JFrame
创建 JFrame具有指定标题和指定 GraphicsConfiguration屏幕设备的。
JFrame.AccessibleJFrame - Class in javax.swing
该类为 JFrame类实现可访问性支持。
JFXPanel - Class in javafx.embed.swing
JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。
JFXPanel() - Constructor for class javafx.embed.swing. JFXPanel
创建一个新的 JFXPanel对象。
JInternalFrame - Class in javax.swing
一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
JInternalFrame() - Constructor for class javax.swing. JInternalFrame
创建一个不可调整大小，不可关闭，不可最大化，非图形化的 JInternalFrame没有标题。
JInternalFrame(String) - Constructor for class javax.swing. JInternalFrame
创建不可调整大小，不可关闭，不可最大化，非图形化的 JInternalFrame具有指定的标题。
JInternalFrame(String, boolean) - Constructor for class javax.swing. JInternalFrame
创建一个不可关闭，不可最大化，非图形化的 JInternalFrame具有指定的标题和可 JInternalFrame性。
JInternalFrame(String, boolean, boolean) - Constructor for class javax.swing. JInternalFrame
创建一个不可最大化，非图形化的 JInternalFrame具有指定的标题，可重定位和可关闭性。
JInternalFrame(String, boolean, boolean, boolean) - Constructor for class javax.swing. JInternalFrame
创建具有指定标题，可重定位性，可关闭性和最大化性能的非图形化 JInternalFrame 。
JInternalFrame(String, boolean, boolean, boolean, boolean) - Constructor for class javax.swing. JInternalFrame
创建 JInternalFrame具有指定标题，可调整，可关闭，可最大化和图标化。
JInternalFrame.AccessibleJInternalFrame - Class in javax.swing
该类为 JInternalFrame类实现可访问性支持。
JInternalFrame.JDesktopIcon - Class in javax.swing
该组件代表 JInternalFrame的图标化版本。
JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon - Class in javax.swing
这个类实现 JInternalFrame.JDesktopIcon类的可访问性支持。
JIS_B0 - Static variable in class java.awt. PageAttributes.MediaType
JIS B0的MediaType实例，1030 x 1456 mm。
JIS_B0 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B0尺寸。
JIS_B1 - Static variable in class java.awt. PageAttributes.MediaType
JIS B1的MediaType实例，728 x 1030 mm。
JIS_B1 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B1尺寸。
JIS_B10 - Static variable in class java.awt. PageAttributes.MediaType
JIS B10的MediaType实例，32 x 45 mm。
JIS_B10 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B10尺寸。
JIS_B2 - Static variable in class java.awt. PageAttributes.MediaType
JIS B2的MediaType实例，515 x 728 mm。
JIS_B2 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B2尺寸。
JIS_B3 - Static variable in class java.awt. PageAttributes.MediaType
JIS B3的MediaType实例，364 x 515毫米。
JIS_B3 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B3尺寸。
JIS_B4 - Static variable in class java.awt. PageAttributes.MediaType
JIS B4的MediaType实例，257 x 364 mm。
JIS_B4 - Static variable in class javafx.print. Paper
指定JIS B4尺寸，257 mm×364 mm。
JIS_B4 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B4尺寸。
JIS_B5 - Static variable in class java.awt. PageAttributes.MediaType
JIS B5的MediaType实例，182 x 257 mm。
JIS_B5 - Static variable in class javafx.print. Paper
指定JIS B5尺寸，182 mm×257 mm。
JIS_B5 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B5尺寸。
JIS_B6 - Static variable in class java.awt. PageAttributes.MediaType
JIS B6的MediaType实例，128 x 182 mm。
JIS_B6 - Static variable in class javafx.print. Paper
指定JIS B6尺寸，128 mm×182 mm。
JIS_B6 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B6尺寸。
JIS_B7 - Static variable in class java.awt. PageAttributes.MediaType
用于JIS B7的MediaType实例，91 x 128 mm。
JIS_B7 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B7尺寸。
JIS_B8 - Static variable in class java.awt. PageAttributes.MediaType
用于JIS B8的MediaType实例，64 x 91毫米。
JIS_B8 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B8尺寸。
JIS_B9 - Static variable in class java.awt. PageAttributes.MediaType
JIS B9的MediaType实例，45 x 64 mm。
JIS_B9 - Static variable in class javax.print.attribute.standard. MediaSizeName
JIS B9尺寸。
JLabel - Class in javax.swing
用于短文本字符串或图像的显示区域，或两者。
JLabel() - Constructor for class javax.swing. JLabel
创建一个没有图像的 JLabel实例，标题为空字符串。
JLabel(String) - Constructor for class javax.swing. JLabel
创建一个具有指定文本的 JLabel实例。
JLabel(String, int) - Constructor for class javax.swing. JLabel
创建一个具有指定文本和水平对齐的 JLabel实例。
JLabel(String, Icon, int) - Constructor for class javax.swing. JLabel
创建一个具有指定文本，图像和水平对齐的 JLabel实例。
JLabel(Icon) - Constructor for class javax.swing. JLabel
创建具有指定图像的 JLabel实例。
JLabel(Icon, int) - Constructor for class javax.swing. JLabel
创建一个具有指定图像和水平对齐的 JLabel实例。
JLabel.AccessibleJLabel - Class in javax.swing
该类用于获取此对象的可访问角色。
JLayer< V extends Component> - Class in javax.swing
JLayer是Swing组件的通用装饰器，可以实现各种先进的绘画效果，并且可以接收在其边框内生成的所有 AWTEvent的通知。
JLayer() - Constructor for class javax.swing. JLayer
使用null视图组件创建一个新的JLayer对象，默认为LayerUI 。
JLayer(V) - Constructor for class javax.swing. JLayer
创建一个新的JLayer对象，默认为LayerUI 。
JLayer(V, LayerUI<V>) - Constructor for class javax.swing. JLayer
创建一个新的JLayer具有指定视图组件和对象LayerUI对象。
JLayeredPane - Class in javax.swing
JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
JLayeredPane() - Constructor for class javax.swing. JLayeredPane
创建一个新的JLayeredPane
JLayeredPane.AccessibleJLayeredPane - Class in javax.swing
这个类实现 JLayeredPane类的可访问性支持。
JList< E> - Class in javax.swing
显示对象列表并允许用户选择一个或多个项目的组件。
JList() - Constructor for class javax.swing. JList
构造一个空的只读模型的 JList 。
JList(E[]) - Constructor for class javax.swing. JList
构造一个 JList ，显示指定数组中的元素。
JList(Vector<? extends E>) - Constructor for class javax.swing. JList
构造一个 JList ，显示指定的 Vector的元素。
JList(ListModel<E>) - Constructor for class javax.swing. JList
构造一个 JList ，显示来自指定的 non-null型号的元素。
JList.AccessibleJList - Class in javax.swing
这个类实现 JList类的可访问性支持。
JList.AccessibleJList.AccessibleJListChild - Class in javax.swing
该类实现适用于列表子级的辅助功能支持。
JList.DropLocation - Class in javax.swing
的一个子类 TransferHandler.DropLocation表示用于一个放置位置 JList 。
JMenu - Class in javax.swing
一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户选择 JMenuBar上的项目时 JMenuBar 。
JMenu() - Constructor for class javax.swing. JMenu
构造一个新的 JMenu ，没有文字。
JMenu(String) - Constructor for class javax.swing. JMenu
构造一个新的 JMenu ，其中提供的字符串作为其文本。
JMenu(String, boolean) - Constructor for class javax.swing. JMenu
构造一个新的 JMenu ，其中提供的字符串作为其文本并指定为撕下菜单。
JMenu(Action) - Constructor for class javax.swing. JMenu
构造一个菜单，其属性取自提供的 Action 。
JMenu.AccessibleJMenu - Class in javax.swing
这个类实现 JMenu类的可访问性支持。
JMenu.WinListener - Class in javax.swing
监听一个弹出窗口关闭的监听器类。
JMenuBar - Class in javax.swing
一个菜单栏的实现。
JMenuBar() - Constructor for class javax.swing. JMenuBar
创建一个新的菜单栏。
JMenuBar.AccessibleJMenuBar - Class in javax.swing
这个类实现 JMenuBar类的可访问性支持。
JMenuItem - Class in javax.swing
菜单中项目的实现。
JMenuItem() - Constructor for class javax.swing. JMenuItem
创建一个没有设置文本或图标的 JMenuItem 。
JMenuItem(String) - Constructor for class javax.swing. JMenuItem
用指定的文本创建一个 JMenuItem 。
JMenuItem(String, int) - Constructor for class javax.swing. JMenuItem
使用指定的文本和键盘助记符创建一个 JMenuItem 。
JMenuItem(String, Icon) - Constructor for class javax.swing. JMenuItem
创建一个 JMenuItem与指定的文本和图标。
JMenuItem(Action) - Constructor for class javax.swing. JMenuItem
创建一个菜单项，其属性取自指定的 Action 。
JMenuItem(Icon) - Constructor for class javax.swing. JMenuItem
使用指定的图标创建一个 JMenuItem 。
JMenuItem.AccessibleJMenuItem - Class in javax.swing
该类实现 JMenuItem类的可访问性支持。
JMException - Exception in javax.management
JMX实现抛出异常。
JMException() - Constructor for exception javax.management. JMException
默认构造函数。
JMException(String) - Constructor for exception javax.management. JMException
允许指定特定错误消息的构造方法。
JMRuntimeException - Exception in javax.management
JMX实现发出的运行时异常。
JMRuntimeException() - Constructor for exception javax.management. JMRuntimeException
默认构造函数。
JMRuntimeException(String) - Constructor for exception javax.management. JMRuntimeException
允许指定特定错误消息的构造方法。
JMX - Class in javax.management
来自JMX API的静态方法。
JMXAddressable - Interface in javax.management.remote
由具有 JMXServiceURL地址的对象实现。
JMXAuthenticator - Interface in javax.management.remote
用于定义远程凭据如何转换为JAAS主题的界面。
JMXConnectionNotification - Class in javax.management.remote
客户端连接打开或关闭或通知丢失时发出的通知。
JMXConnectionNotification(String, Object, String, long, String, Object) - Constructor for class javax.management.remote. JMXConnectionNotification
构造一个新的连接通知。
JMXConnector - Interface in javax.management.remote
JMX API连接器的客户端。
JMXConnectorFactory - Class in javax.management.remote
工厂创建JMX API连接器客户端。
JMXConnectorProvider - Interface in javax.management.remote
使用给定协议创建JMX API连接器客户端的提供程序。
JMXConnectorServer - Class in javax.management.remote
每个连接器服务器的超类。
JMXConnectorServer() - Constructor for class javax.management.remote. JMXConnectorServer
构造一个连接器服务器，该连接器服务器将在其所连接的MBean服务器中注册为MBean。
JMXConnectorServer(MBeanServer) - Constructor for class javax.management.remote. JMXConnectorServer
构造一个连接到给定MBean服务器的连接器服务器。
JMXConnectorServerFactory - Class in javax.management.remote
工厂创建JMX API连接器服务器。
JMXConnectorServerMBean - Interface in javax.management.remote
连接器服务器的MBean接口。
JMXConnectorServerProvider - Interface in javax.management.remote
使用给定协议创建JMX API连接器服务器的提供程序。
JMXPrincipal - Class in javax.management.remote
JMX Remote API的远程客户端的身份。
JMXPrincipal(String) - Constructor for class javax.management.remote. JMXPrincipal
为给定的身份创建一个JMXPrincipal。
JMXProviderException - Exception in javax.management.remote
当提供者存在所需协议但不能由于某种原因使用时，由JMXConnectorFactory和JMXConnectorServerFactory抛出异常。
JMXProviderException() - Constructor for exception javax.management.remote. JMXProviderException
构造一个没有指定详细信息的 JMXProviderException 。
JMXProviderException(String) - Constructor for exception javax.management.remote. JMXProviderException
构造具有指定详细消息的 JMXProviderException 。
JMXProviderException(String, Throwable) - Constructor for exception javax.management.remote. JMXProviderException
构造具有指定的详细消息和嵌套异常的 JMXProviderException 。
JMXServerErrorException - Exception in javax.management.remote
在处理远程MBean服务器中的调用时抛出Error时，由于远程MBeanServer方法调用的结果抛出异常。
JMXServerErrorException(String, Error) - Constructor for exception javax.management.remote. JMXServerErrorException
构造具有指定的详细消息和嵌套错误的 JMXServerErrorException 。
JMXServiceURL - Class in javax.management.remote
JMX API连接器服务器的地址。
JMXServiceURL(String) - Constructor for class javax.management.remote. JMXServiceURL
通过解析服务URL字符串构造一个 JMXServiceURL 。
JMXServiceURL(String, String, int) - Constructor for class javax.management.remote. JMXServiceURL
使用给定的协议，主机和端口构造一个 JMXServiceURL 。
JMXServiceURL(String, String, int, String) - Constructor for class javax.management.remote. JMXServiceURL
构造一个 JMXServiceURL与给定的部分。
JNDI_REBIND_ATTRIBUTE - Static variable in class javax.management.remote.rmi. RMIConnectorServer
指定表示RMI连接器服务器的RMIServer存根是否应覆盖同一地址的现有存根的属性名称。
JndiLoginModule - Class in com.sun.security.auth.module
模块提示输入用户名和密码，然后根据存储在JNDI下配置的目录服务中的密码验证密码。
JndiLoginModule() - Constructor for class com.sun.security.auth.module. JndiLoginModule
JNLPRandomAccessFile - Interface in javax.jnlp
该类的实例支持读取和写入随机访问文件。
JOB_CANCELED - Static variable in class javax.print.event. PrintJobEvent
该工作由PrintService取消。
JOB_CANCELED_AT_DEVICE - Static variable in class javax.print.attribute.standard. JobStateReason
该作业被不明身份的本地用户取消，即设备上的控制台上的用户。
JOB_CANCELED_BY_OPERATOR - Static variable in class javax.print.attribute.standard. JobStateReason
该作业被操作者取消，即由被认证为具有操作者特权的用户（无论是本地的还是远程的）被取消。
JOB_CANCELED_BY_USER - Static variable in class javax.print.attribute.standard. JobStateReason
该作业被作业的所有者取消，即由经过身份验证的身份与创建打印作业的始发用户的值相同的用户或由其他授权的最终用户（例如，工作主人的安全组。
JOB_COMPLETE - Static variable in class javax.print.event. PrintJobEvent
文件顺式完全印刷。
JOB_COMPLETED_SUCCESSFULLY - Static variable in class javax.print.attribute.standard. JobStateReason
工作成功完成
JOB_COMPLETED_WITH_ERRORS - Static variable in class javax.print.attribute.standard. JobStateReason
工作完成时有错误（也可能是警告）。
JOB_COMPLETED_WITH_WARNINGS - Static variable in class javax.print.attribute.standard. JobStateReason
工作完成了警告。
JOB_DATA_INSUFFICIENT - Static variable in class javax.print.attribute.standard. JobStateReason
打印机已创建打印作业，但打印机期待其他打印数据，然后才能将作业移动到PROCESSING状态。
JOB_FAILED - Static variable in class javax.print.event. PrintJobEvent
打印服务报告该作业无法完成。
JOB_HOLD_UNTIL_SPECIFIED - Static variable in class javax.print.attribute.standard. JobStateReason
作业JobHoldUntil属性的值已指定，日期时间仍在将来。
JOB_INCOMING - Static variable in class javax.print.attribute.standard. JobStateReason
打印机已创建打印作业，但打印机尚未完成访问或接受所有打印数据。
JOB_INTERPRETING - Static variable in class javax.print.attribute.standard. JobStateReason
作业处于PROCESSING状态，但更具体地说，打印机ia解释文档数据。
JOB_OUTGOING - Static variable in class javax.print.attribute.standard. JobStateReason
打印机将作业发送到输出设备。
JOB_PRINTING - Static variable in class javax.print.attribute.standard. JobStateReason
输出设备是标记介质。
JOB_QUEUED - Static variable in class javax.print.attribute.standard. JobStateReason
该作业处于PROCESSING状态，但更具体地说，打印机已将文档数据排队。
JOB_QUEUED_FOR_MARKER - Static variable in class javax.print.attribute.standard. JobStateReason
该作业处于PENDING_HELD，PENDING或PROCESSING状态，但更具体地说，打印机已经完成了足够的文档处理，以便能够开始标记，并且作业正在等待标记。
JOB_RESTARTABLE - Static variable in class javax.print.attribute.standard. JobStateReason
此作业已保留，并且当前可以重新启动。
JOB_TRANSFORMING - Static variable in class javax.print.attribute.standard. JobStateReason
该作业处于PROCESSING状态，但更具体地说，打印机正在解释文档数据并产生另一电子表示。
JobAttributes - Class in java.awt
一组控制打印作业的属性。
JobAttributes() - Constructor for class java.awt. JobAttributes
构造一个具有每个属性的默认值的 JobAttributes实例。
JobAttributes(int, JobAttributes.DefaultSelectionType, JobAttributes.DestinationType, JobAttributes.DialogType, String, int, int, JobAttributes.MultipleDocumentHandlingType, int[][], String, JobAttributes.SidesType) - Constructor for class java.awt. JobAttributes
为每个属性构造具有指定值的 JobAttributes实例。
JobAttributes(JobAttributes) - Constructor for class java.awt. JobAttributes
构造一个 JobAttributes实例，它是所提供的 JobAttributes的副本。
JobAttributes.DefaultSelectionType - Class in java.awt
可能的默认选择状态的类型安全枚举。
JobAttributes.DestinationType - Class in java.awt
可能的工作目的地的类型安全枚举。
JobAttributes.DialogType - Class in java.awt
可以显示给用户的可能对话框的类型安全枚举。
JobAttributes.MultipleDocumentHandlingType - Class in java.awt
可能的多重复制处理状态的类型安全枚举。
JobAttributes.SidesType - Class in java.awt
可能的多页面强制的类型安全枚举。
JobHoldUntil - Class in javax.print.attribute.standard
JobHoldUntil类是一个打印属性类，一个日期时间属性，用于指定作业必须成为打印候选者的确切日期和时间。
JobHoldUntil(Date) - Constructor for class javax.print.attribute.standard. JobHoldUntil
构造新的作业保持，直到date-time属性与给定的Date值。
JobImpressions - Class in javax.print.attribute.standard
JobImpress类是一个整数值打印属性类，它指定要提交的文档的展示次数的总大小。
JobImpressions(int) - Constructor for class javax.print.attribute.standard. JobImpressions
使用给定的整数值构造新的作业展示属性。
JobImpressionsCompleted - Class in javax.print.attribute.standard
JobImpressionsCompleted类是一个整数值的打印属性类，用于指定目前为该作业完成的展示次数。
JobImpressionsCompleted(int) - Constructor for class javax.print.attribute.standard. JobImpressionsCompleted
使用给定的整数值构造新的作业展示完成属性。
JobImpressionsSupported - Class in javax.print.attribute.standard
JobImpressions类支持是打印属性类，一组整数，它为JobImpressions属性提供支持的值。
JobImpressionsSupported(int, int) - Constructor for class javax.print.attribute.standard. JobImpressionsSupported
构造包含单个整数范围的新的作业展示支持属性。
JobKOctets - Class in javax.print.attribute.standard
JobKOctets类是一个整数值打印属性类，用于指定以K个八位字节为单位的文档的总大小，即以作业中请求处理的1024个八位字节为单位。
JobKOctets(int) - Constructor for class javax.print.attribute.standard. JobKOctets
构造具有给定整数值的新作业K个八位字节属性。
JobKOctetsProcessed - Class in javax.print.attribute.standard
JobKOctetsProcessed类是一个整数值打印属性类，它指定了目前以K个八位字节处理的打印数据八位字节的总数，即1024个八位字节的单位。
JobKOctetsProcessed(int) - Constructor for class javax.print.attribute.standard. JobKOctetsProcessed
使用给定的整数值构造新的作业K个八位字节处理的属性。
JobKOctetsSupported - Class in javax.print.attribute.standard
JobKOctetsSupported类是一个打印属性类，一组整数，为JobKOctets属性提供支持的值。
JobKOctetsSupported(int, int) - Constructor for class javax.print.attribute.standard. JobKOctetsSupported
构造新的作业K个八位字节支持的属性，其中包含单个范围的整数。
JobMediaSheets - Class in javax.print.attribute.standard
JobMediaSheets类是一个整数值打印属性类，它指定要为此作业生成的介质页的总数。
JobMediaSheets(int) - Constructor for class javax.print.attribute.standard. JobMediaSheets
使用给定的整数值构造新的作业媒体工作表属性。
JobMediaSheetsCompleted - Class in javax.print.attribute.standard
JobMediaSheetsCompleted类是一个整数值的打印属性类，它指定了到目前为止整个作业已经完成标记和堆叠的介质页数，无论这些工作表是在一边还是两者上进行处理。
JobMediaSheetsCompleted(int) - Constructor for class javax.print.attribute.standard. JobMediaSheetsCompleted
使用给定的整数值构造新的作业介质单完成属性。
JobMediaSheetsSupported - Class in javax.print.attribute.standard
类JobMediaSheetsSupported是打印属性类，一组整数，它为JobMediaSheets属性提供支持的值。
JobMediaSheetsSupported(int, int) - Constructor for class javax.print.attribute.standard. JobMediaSheetsSupported
构造包含单个整数范围的新的作业介质单支持属性。
JobMessageFromOperator - Class in javax.print.attribute.standard
JobMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示对作业执行修改或其他管理操作的原因。
JobMessageFromOperator(String, Locale) - Constructor for class javax.print.attribute.standard. JobMessageFromOperator
使用给定的消息和语言环境构造来自operator属性的新作业消息。
JobName - Class in javax.print.attribute.standard
JobName类是一个打印属性类，一个指定打印作业名称的文本属性。
JobName(String, Locale) - Constructor for class javax.print.attribute.standard. JobName
构造具有给定作业名称和区域设置的新作业名称属性。
jobNameProperty() - Method in class javafx.print. JobSettings
StringProperty代表作业的名称。
JobOriginatingUserName - Class in javax.print.attribute.standard
JobOriginatingUserName类是一个打印属性类，一个文本属性，其中包含提交打印作业的最终用户的名称。
JobOriginatingUserName(String, Locale) - Constructor for class javax.print.attribute.standard. JobOriginatingUserName
构造具有给定用户名和区域设置的新作业发起用户名属性。
JobPriority - Class in javax.print.attribute.standard
JobPriority类是一个整数值打印属性类，用于指定打印作业的优先级。
JobPriority(int) - Constructor for class javax.print.attribute.standard. JobPriority
构造具有给定整数值的新作业优先级属性。
JobPrioritySupported - Class in javax.print.attribute.standard
JobPrioritySupported类是一个整数值打印属性类，用于指定打印服务实例是否支持JobPriority属性和支持的不同作业优先级的数量。
JobPrioritySupported(int) - Constructor for class javax.print.attribute.standard. JobPrioritySupported
使用给定的整数值构造新的作业优先级支持属性。
JobSettings - Class in javafx.print
JobSettings类封装了打印作业的大部分配置。
JobSheets - Class in javax.print.attribute.standard
JobSheets类是打印属性类（枚举），用于确定必须使用作业打印哪些作业开始和结束工作表（如果有）。
JobSheets(int) - Constructor for class javax.print.attribute.standard. JobSheets
使用给定的整数值构造新的工作表枚举值。
JobState - Class in javax.print.attribute.standard
JobState是一个打印属性类，一个枚举，用于标识打印作业的当前状态。
JobState(int) - Constructor for class javax.print.attribute.standard. JobState
构造具有给定整数值的新作业状态枚举值。
JobStateReason - Class in javax.print.attribute.standard
JobStateReason类是一个打印属性类，枚举，提供有关作业当前状态的其他信息，即增加作业JobState属性值的信息。
JobStateReason(int) - Constructor for class javax.print.attribute.standard. JobStateReason
使用给定的整数值构造新的作业状态原因枚举值。
JobStateReasons - Class in javax.print.attribute.standard
JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
JobStateReasons() - Constructor for class javax.print.attribute.standard. JobStateReasons
构造一个新的，空的作业状态原因属性; 底层哈希集具有默认的初始容量和负载因子。
JobStateReasons(int) - Constructor for class javax.print.attribute.standard. JobStateReasons
构造一个新的，空的作业状态原因属性; 底层哈希集具有给定的初始容量和默认负载因子。
JobStateReasons(int, float) - Constructor for class javax.print.attribute.standard. JobStateReasons
构造一个新的，空的作业状态原因属性; 底层哈希集具有给定的初始容量和负载因子。
JobStateReasons(Collection<JobStateReason>) - Constructor for class javax.print.attribute.standard. JobStateReasons
构造一个新的作业状态原因属性，其中包含与给定集合相同的JobStateReason对象。
jobStatusProperty() - Method in class javafx.print. PrinterJob
一个只读对象属性，代表当前的 JobStatus
join() - Method in class java.lang. Thread
等待这个线程死亡。
join() - Method in class java.util.concurrent. CompletableFuture
完成后返回结果值，如果完成异常，则返回（未检查）异常。
join() - Method in class java.util.concurrent. ForkJoinTask
当它 返回is done的计算结果。
join(long) - Method in class java.lang. Thread
等待这个线程死亡最多 millis毫秒。
join(long, int) - Method in class java.lang. Thread
等待最多 millis毫秒加上这个线程死亡的 nanos纳秒。
join(CharSequence, CharSequence...) - Static method in class java.lang. String
返回一个由连接在一起的 CharSequence elements的副本组成的新的字符串，并附带指定的 delimiter的副本。
join(CharSequence, Iterable<? extends CharSequence>) - Static method in class java.lang. String
返回一个新 String的副本组成 CharSequence elements与指定的副本一起加入 delimiter 。
join(InetAddress) - Method in class java.net. DatagramSocketImpl
加入组播组。
join(InetAddress, NetworkInterface) - Method in interface java.nio.channels. MulticastChannel
加入组播组，开始接收发送到组的所有数据报，返回成员密钥。
join(InetAddress, NetworkInterface, InetAddress) - Method in interface java.nio.channels. MulticastChannel
加入组播组，开始从给定的源地址接收发送到组的数据报。
JOIN_BEVEL - Static variable in class java.awt. BasicStroke
通过连接其广泛轮廓的外角与直线段来连接路段。
JOIN_MITER - Static variable in class java.awt. BasicStroke
通过延伸它们的外边缘直到它们相遇来连接路段。
JOIN_ROUND - Static variable in class java.awt. BasicStroke
通过以半角宽度的半径舍入角落来连接路径段。
Joinable - Interface in javax.sql.rowset
1.0背景
JoinFractureDirection - Static variable in class javax.swing.text. DefaultStyledDocument.ElementSpec
getDirection的可能值。
joinGroup(InetAddress) - Method in class java.net. MulticastSocket
加入组播组。
joinGroup(SocketAddress, NetworkInterface) - Method in class java.net. DatagramSocketImpl
加入组播组。
joinGroup(SocketAddress, NetworkInterface) - Method in class java.net. MulticastSocket
在指定的接口加入指定的组播组。
joining() - Static method in class java.util.stream. Collectors
返回一个 Collector ，将输入元素连接到一个 String ，按照顺序。
joining(CharSequence) - Static method in class java.util.stream. Collectors
返回一个 Collector ，按照遇到的顺序连接由指定的分隔符分隔的输入元素。
joining(CharSequence, CharSequence, CharSequence) - Static method in class java.util.stream. Collectors
返回一个 Collector ，它将按照指定的分隔符分隔的输入元素与指定的前缀和后缀进行连接。
JoinNextDirection - Static variable in class javax.swing.text. DefaultStyledDocument.ElementSpec
getDirection的可能值。
JoinPreviousDirection - Static variable in class javax.swing.text. DefaultStyledDocument.ElementSpec
getDirection的可能值。
JoinRowSet - Interface in javax.sql.rowset
JoinRowSet接口提供了一种机制，用于将来自不同 RowSet对象的相关数据组合到一个 JoinRowSet对象中，该对象表示SQL JOIN 。
JOptionPane - Class in javax.swing
JOptionPane可以方便地弹出一个标准对话框，提示用户获取值或通知他们某些东西。
JOptionPane() - Constructor for class javax.swing. JOptionPane
创建一个 JOptionPane的测试消息。
JOptionPane(Object) - Constructor for class javax.swing. JOptionPane
创建 JOptionPane的实例以使用简单消息消息类型和UI提供的默认选项来显示消息。
JOptionPane(Object, int) - Constructor for class javax.swing. JOptionPane
创建一个 JOptionPane的实例以显示具有指定消息类型和默认选项的消息，
JOptionPane(Object, int, int) - Constructor for class javax.swing. JOptionPane
创建一个 JOptionPane的实例以显示具有指定消息类型和选项的消息。
JOptionPane(Object, int, int, Icon) - Constructor for class javax.swing. JOptionPane
创建一个 JOptionPane的实例以显示具有指定消息类型，选项和图标的消息。
JOptionPane(Object, int, int, Icon, Object[]) - Constructor for class javax.swing. JOptionPane
创建一个 JOptionPane的实例以显示具有指定消息类型，图标和选项的消息。
JOptionPane(Object, int, int, Icon, Object[], Object) - Constructor for class javax.swing. JOptionPane
创建一个 JOptionPane的实例以显示具有指定消息类型，图标和选项的消息，并指定最初选择的选项。
JOptionPane.AccessibleJOptionPane - Class in javax.swing
该类实现 JOptionPane课程的可访问性支持。
JPanel - Class in javax.swing
JPanel是一个通用的轻型容器。
JPanel() - Constructor for class javax.swing. JPanel
创建一个新的 JPanel双缓冲区和流布局。
JPanel(boolean) - Constructor for class javax.swing. JPanel
创建一个新的 JPanel与 FlowLayout和指定的缓冲策略。
JPanel(LayoutManager) - Constructor for class javax.swing. JPanel
使用指定的布局管理器创建一个新的缓冲JPanel
JPanel(LayoutManager, boolean) - Constructor for class javax.swing. JPanel
使用指定的布局管理器和缓冲策略创建一个新的JPanel。
JPanel.AccessibleJPanel - Class in javax.swing
这个类实现 JPanel类的可访问性支持。
JPasswordField - Class in javax.swing
JPasswordField是一个轻量级组件，允许编辑单行文本，其中该视图表示某些内容是键入的，但不显示原始字符。
JPasswordField() - Constructor for class javax.swing. JPasswordField
构造新的 JPasswordField ，默认文档为 null起始文本字符串和0列宽。
JPasswordField(int) - Constructor for class javax.swing. JPasswordField
构造一个新的空的 JPasswordField具有指定的列数。
JPasswordField(String) - Constructor for class javax.swing. JPasswordField
构造一个新的 JPasswordField ，用指定的文本初始化。
JPasswordField(String, int) - Constructor for class javax.swing. JPasswordField
构造一个新的 JPasswordField ，用指定的文本和列进行初始化。
JPasswordField(Document, String, int) - Constructor for class javax.swing. JPasswordField
构造一个新的 JPasswordField ，它使用给定的文本存储模型和给定的列数。
JPasswordField.AccessibleJPasswordField - Class in javax.swing
该类实现 JPasswordField类的辅助功能支持。
JPEG - Static variable in class javax.print. DocFlavor.BYTE_ARRAY
Doc风格与MIME类型= "image/jpeg" ，打印数据表示类名= "[B" （字节数组）。
JPEG - Static variable in class javax.print. DocFlavor.INPUT_STREAM
文件风味与MIME类型= "image/jpeg" ，打印数据表示类名= "java.io.InputStream" （字节流）。
JPEG - Static variable in class javax.print. DocFlavor.URL
文件风味与MIME类型= "image/jpeg" ，打印数据表示类名= "java.net.URL" 。
JPEG_PROC_BASELINE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“JPEGProc”标签一起使用的值。
JPEG_PROC_LOSSLESS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“JPEGProc”标签一起使用的值。
JPEGHuffmanTable - Class in javax.imageio.plugins.jpeg
一个封装单个JPEG霍夫曼表的类。
JPEGHuffmanTable(short[], short[]) - Constructor for class javax.imageio.plugins.jpeg. JPEGHuffmanTable
创建一个霍夫曼表并进行初始化。
JPEGImageReadParam - Class in javax.imageio.plugins.jpeg
此类增加了在使用内置JPEG阅读器插件时设置JPEG量化和霍夫曼表的功能。
JPEGImageReadParam() - Constructor for class javax.imageio.plugins.jpeg. JPEGImageReadParam
构造一个 JPEGImageReadParam 。
JPEGImageWriteParam - Class in javax.imageio.plugins.jpeg
该类增加了在使用内置JPEG writer插件时设置JPEG量化和霍夫曼表的能力，并请求为图像计算优化的霍夫曼表。
JPEGImageWriteParam(Locale) - Constructor for class javax.imageio.plugins.jpeg. JPEGImageWriteParam
构造一个 JPEGImageWriteParam 。
JPEGQTable - Class in javax.imageio.plugins.jpeg
一个封装单个JPEG量化表的类。
JPEGQTable(int[]) - Constructor for class javax.imageio.plugins.jpeg. JPEGQTable
从参数构造一个量化表，它必须包含自然顺序的64个元素（不是zig-zag顺序）。
JPopupMenu - Class in javax.swing
弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
JPopupMenu() - Constructor for class javax.swing. JPopupMenu
构造一个 JPopupMenu而没有“调用者”。
JPopupMenu(String) - Constructor for class javax.swing. JPopupMenu
构造具有指定标题的 JPopupMenu 。
JPopupMenu.AccessibleJPopupMenu - Class in javax.swing
这个类实现 JPopupMenu类的可访问性支持。
JPopupMenu.Separator - Class in javax.swing
弹出菜单特定的分隔符。
JProgressBar - Class in javax.swing
可视化显示某些任务进度的组件。
JProgressBar() - Constructor for class javax.swing. JProgressBar
创建一个显示边框但没有进度字符串的水平进度条。
JProgressBar(int) - Constructor for class javax.swing. JProgressBar
创建具有指定方向的进度条，可以是 SwingConstants.VERTICAL或 SwingConstants.HORIZONTAL 。
JProgressBar(int, int) - Constructor for class javax.swing. JProgressBar
创建具有指定的最小和最大值的水平进度条。
JProgressBar(int, int, int) - Constructor for class javax.swing. JProgressBar
使用指定的方向，最小和最大值创建进度条。
JProgressBar(BoundedRangeModel) - Constructor for class javax.swing. JProgressBar
创建一个水平进度条，使用指定的模型来保存进度条的数据。
JProgressBar.AccessibleJProgressBar - Class in javax.swing
该类为 JProgressBar类实现可访问性支持。
JRadioButton - Class in javax.swing
单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
JRadioButton() - Constructor for class javax.swing. JRadioButton
创建一个没有设置文本的最初未选择的单选按钮。
JRadioButton(String) - Constructor for class javax.swing. JRadioButton
使用指定的文本创建一个未选择的单选按钮。
JRadioButton(String, boolean) - Constructor for class javax.swing. JRadioButton
创建具有指定文本和选择状态的单选按钮。
JRadioButton(String, Icon) - Constructor for class javax.swing. JRadioButton
创建具有指定文本和图像的单选按钮，最初未被选择。
JRadioButton(String, Icon, boolean) - Constructor for class javax.swing. JRadioButton
创建具有指定文本，图像和选择状态的单选按钮。
JRadioButton(Action) - Constructor for class javax.swing. JRadioButton
创建一个单选按钮，其中从提供的Action提取属性。
JRadioButton(Icon) - Constructor for class javax.swing. JRadioButton
创建一个初始未选择的单选按钮与指定的图像，但没有文字。
JRadioButton(Icon, boolean) - Constructor for class javax.swing. JRadioButton
创建具有指定图像和选择状态的单选按钮，但不包含文本。
JRadioButton.AccessibleJRadioButton - Class in javax.swing
该类为 JRadioButton类实现可访问性支持。
JRadioButtonMenuItem - Class in javax.swing
单选按钮菜单项的实现。
JRadioButtonMenuItem() - Constructor for class javax.swing. JRadioButtonMenuItem
创建一个没有设置文本或图标的 JRadioButtonMenuItem 。
JRadioButtonMenuItem(String) - Constructor for class javax.swing. JRadioButtonMenuItem
创建一个 JRadioButtonMenuItem与文本。
JRadioButtonMenuItem(String, boolean) - Constructor for class javax.swing. JRadioButtonMenuItem
创建具有指定文本和选择状态的单选按钮菜单项。
JRadioButtonMenuItem(String, Icon) - Constructor for class javax.swing. JRadioButtonMenuItem
创建一个包含指定文本的单选按钮菜单项和 Icon 。
JRadioButtonMenuItem(String, Icon, boolean) - Constructor for class javax.swing. JRadioButtonMenuItem
创建具有指定文本，图像和选择状态的单选按钮菜单项。
JRadioButtonMenuItem(Action) - Constructor for class javax.swing. JRadioButtonMenuItem
创建一个单选按钮菜单项，其属性取自提供的 Action 。
JRadioButtonMenuItem(Icon) - Constructor for class javax.swing. JRadioButtonMenuItem
创建一个带有图标的 JRadioButtonMenuItem 。
JRadioButtonMenuItem(Icon, boolean) - Constructor for class javax.swing. JRadioButtonMenuItem
创建具有指定图像和选择状态但无文字的单选按钮菜单项。
JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem - Class in javax.swing
这个类实现 JRadioButtonMenuItem类的可访问性支持。
JRootPane - Class in javax.swing
通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
JRootPane() - Constructor for class javax.swing. JRootPane
创建 JRootPane ，建立其 glassPane ， layeredPane ，并 contentPane 。
JRootPane.AccessibleJRootPane - Class in javax.swing
这个类实现 JRootPane类的可访问性支持。
JRootPane.RootLayout - Class in javax.swing
一个自定义布局管理器，负责分层面，玻璃面和菜单栏的布局。
JScrollBar - Class in javax.swing
一个滚动条的实现。
JScrollBar() - Constructor for class javax.swing. JScrollBar
创建具有以下初始值的垂直滚动条：
JScrollBar(int) - Constructor for class javax.swing. JScrollBar
创建具有指定方向和以下初始值的滚动条：
JScrollBar(int, int, int, int, int) - Constructor for class javax.swing. JScrollBar
创建具有指定方向，值，范围，最小值和最大值的滚动条。
JScrollBar.AccessibleJScrollBar - Class in javax.swing
该类实现对 JScrollBar类的可访问性支持。
JScrollPane - Class in javax.swing
提供轻量级组件的可滚动视图。
JScrollPane() - Constructor for class javax.swing. JScrollPane
创建一个空（ JScrollPane口视图） JScrollPane其中水平和垂直滚动条在需要时出现。
JScrollPane(int, int) - Constructor for class javax.swing. JScrollPane
使用指定的滚动条策略创建一个空（ JScrollPane口视图） JScrollPane 。
JScrollPane(Component) - Constructor for class javax.swing. JScrollPane
创建一个 JScrollPane ，显示指定组件的内容，当组件的内容大于视图时，会显示水平和垂直滚动条。
JScrollPane(Component, int, int) - Constructor for class javax.swing. JScrollPane
创建一个 JScrollPane ，它可以在一个视口中显示视图组件，其视图位置可以通过一对滚动条来控制。
JScrollPane.AccessibleJScrollPane - Class in javax.swing
这个类实现 JScrollPane类的辅助功能支持。
JScrollPane.ScrollBar - Class in javax.swing
默认情况下， JScrollPane创建作为此类的实例的滚动条。
JSeparator - Class in javax.swing
JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
JSeparator() - Constructor for class javax.swing. JSeparator
创建一个新的水平分隔符。
JSeparator(int) - Constructor for class javax.swing. JSeparator
创建一个具有指定的水平或垂直方向的新分隔符。
JSeparator.AccessibleJSeparator - Class in javax.swing
这个类实现 JSeparator类的可访问性支持。
JSException - Exception in netscape.javascript
在JavaScript引擎中引发异常时抛出。
JSException() - Constructor for exception netscape.javascript. JSException
构造一个新的JavaScript异常，为null，因为它是详细的消息。
JSException(String) - Constructor for exception netscape.javascript. JSException
使用指定的详细消息构造新的JavaScript异常。
JSException(Throwable) - Constructor for exception netscape.javascript. JSException
构造具有指定原因的新JavaScript异常。
JShell - Class in jdk.jshell
JShell评估状态引擎。
JShell.Builder - Class in jdk.jshell
Builder为 JShell实例。
JShell.Subscription - Class in jdk.jshell
订阅是引用订阅的标记，因此可以是 unsubscribed 。
JShellException - Exception in jdk.jshell
JShell的超类生成异常
JSlider - Class in javax.swing
允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
JSlider() - Constructor for class javax.swing. JSlider
创建一个水平滑块，范围为0到100，初始值为50。
JSlider(int) - Constructor for class javax.swing. JSlider
使用范围为 0至 100的指定方向创建滑块，初始值为 50 。
JSlider(int, int) - Constructor for class javax.swing. JSlider
使用指定的最小和最大值创建水平滑块，初始值等于最小加最大值的平均值。
JSlider(int, int, int) - Constructor for class javax.swing. JSlider
使用指定的最小值，最大值和值创建水平滑块。
JSlider(int, int, int, int) - Constructor for class javax.swing. JSlider
创建具有指定方向和指定的最小值，最大值和初始值的滑块。
JSlider(BoundedRangeModel) - Constructor for class javax.swing. JSlider
使用指定的BoundedRangeModel创建水平滑块。
JSlider.AccessibleJSlider - Class in javax.swing
这个类实现 JSlider类的辅助功能支持。
JSObject - Class in netscape.javascript
允许Java代码来操纵JavaScript对象。
JSObject - Interface in jdk.nashorn.api.scripting
该接口可以由任意Java类实现。
JSObject() - Constructor for class netscape.javascript. JSObject
构造一个新的JSObject。
JSpinner - Class in javax.swing
单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
JSpinner() - Constructor for class javax.swing. JSpinner
构造一个带有初始值为0的 Integer SpinnerNumberModel的旋转器，没有最小或最大限制。
JSpinner(SpinnerModel) - Constructor for class javax.swing. JSpinner
构造给定模型的旋转器。
JSpinner.AccessibleJSpinner - Class in javax.swing
AccessibleJSpinner实现 JSpinner类的辅助功能支持。
JSpinner.DateEditor - Class in javax.swing
一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
JSpinner.DefaultEditor - Class in javax.swing
更专业的编辑器的简单基类，通过 JFormattedTextField显示模型当前值的 JFormattedTextField 。
JSpinner.ListEditor - Class in javax.swing
一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
JSpinner.NumberEditor - Class in javax.swing
一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
JSplitPane - Class in javax.swing
JSplitPane用于分割二（只有两个） Component s。
JSplitPane() - Constructor for class javax.swing. JSplitPane
创建一个新的 JSplitPane配置为使用组件的两个按钮水平地并排排列子组件。
JSplitPane(int) - Constructor for class javax.swing. JSplitPane
JSplitPane新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新 JSplitPane新新
JSplitPane(int, boolean) - Constructor for class javax.swing. JSplitPane
创建一个新的 JSplitPane具有指定的方向和重绘样式。
JSplitPane(int, boolean, Component, Component) - Constructor for class javax.swing. JSplitPane
使用指定的方向和重绘样式以及指定的组件创建新的 JSplitPane 。
JSplitPane(int, Component, Component) - Constructor for class javax.swing. JSplitPane
创建一个新的 JSplitPane具有指定的方向和指定的组件。
JSplitPane.AccessibleJSplitPane - Class in javax.swing
该类实现 JSplitPane类的可访问性支持。
JTabbedPane - Class in javax.swing
通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
JTabbedPane() - Constructor for class javax.swing. JTabbedPane
创建一个空的 TabbedPane ，默认标签位置为 JTabbedPane.TOP 。
JTabbedPane(int) - Constructor for class javax.swing. JTabbedPane
创建空 TabbedPane与任一指定的选项卡放置： JTabbedPane.TOP ， JTabbedPane.BOTTOM ， JTabbedPane.LEFT ，或 JTabbedPane.RIGHT 。
JTabbedPane(int, int) - Constructor for class javax.swing. JTabbedPane
创建一个空的 TabbedPane与指定的选项 TabbedPane和选项卡布局策略。
JTabbedPane.AccessibleJTabbedPane - Class in javax.swing
该类为 JTabbedPane类实现可访问性支持。
JTabbedPane.ModelListener - Class in javax.swing
我们通过 ModelChanged （而不是模型本身）将 ModelChanged事件传递给听众，作为事件源。
JTable - Class in javax.swing
JTable用于显示和编辑单元格的常规二维表。
JTable() - Constructor for class javax.swing. JTable
构造使用默认数据模型，默认列模型和默认选择模型初始化的默认值 JTable 。
JTable(int, int) - Constructor for class javax.swing. JTable
使用 numRows构建 JTable与 numRows和 numColumns空单元 DefaultTableModel 。
JTable(Object[][], Object[]) - Constructor for class javax.swing. JTable
构造一个 JTable以显示二维数组中的值， rowData ，列名称为 columnNames 。
JTable(Vector<? extends Vector>, Vector<?>) - Constructor for class javax.swing. JTable
构造一个 JTable以显示的值 Vector的 Vectors ， rowData ，其列名称为 columnNames 。
JTable(TableModel) - Constructor for class javax.swing. JTable
构造一个 JTable ，它以 dm作为数据模型初始化，默认列模型和默认选择模型。
JTable(TableModel, TableColumnModel) - Constructor for class javax.swing. JTable
构造一个 JTable是与初始化 dm作为数据模型， cm作为列模型和默认的选择模型。
JTable(TableModel, TableColumnModel, ListSelectionModel) - Constructor for class javax.swing. JTable
构造一个 JTable是与初始化 dm作为数据模型， cm作为列模型，和 sm作为选择模型。
JTable.AccessibleJTable - Class in javax.swing
该类实现 JTable类的可访问性支持。
JTable.AccessibleJTable.AccessibleJTableCell - Class in javax.swing
该类提供了适用于表单元格的Java Accessibility API的实现。
JTable.AccessibleJTable.AccessibleJTableModelChange - Class in javax.swing
描述可访问表模型的变化。
JTable.DropLocation - Class in javax.swing
的一个子类 TransferHandler.DropLocation表示用于一个放置位置 JTable 。
JTable.PrintMode - Enum in javax.swing
打印模式，用于打印 JTable s。
JTableHeader - Class in javax.swing.table
这是管理 JTable的标题的 JTable 。
JTableHeader() - Constructor for class javax.swing.table. JTableHeader
构造一个 JTableHeader ，默认为 TableColumnModel 。
JTableHeader(TableColumnModel) - Constructor for class javax.swing.table. JTableHeader
构造一个 JTableHeader ，它以 cm作为列模型初始化。
JTableHeader.AccessibleJTableHeader - Class in javax.swing.table
该类为 JTableHeader类实现可访问性支持。
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry - Class in javax.swing.table
该类提供了适用于JTableHeader条目的Java Accessibility API的实现。
JTextArea - Class in javax.swing
A JTextArea是显示纯文本的多行区域。
JTextArea() - Constructor for class javax.swing. JTextArea
构造一个新的TextArea。
JTextArea(int, int) - Constructor for class javax.swing. JTextArea
构造具有指定行数和列数的新的空TextArea。
JTextArea(String) - Constructor for class javax.swing. JTextArea
构造一个新的TextArea，并显示指定的文本。
JTextArea(String, int, int) - Constructor for class javax.swing. JTextArea
构造具有指定文本和行数和列数的新TextArea。
JTextArea(Document) - Constructor for class javax.swing. JTextArea
使用给定的文档模型构造一个新的JTextArea，默认为所有其他参数（null，0，0）。
JTextArea(Document, String, int, int) - Constructor for class javax.swing. JTextArea
构造具有指定行数和列数的新JTextArea以及给定模型。
JTextArea.AccessibleJTextArea - Class in javax.swing
这个类实现 JTextArea类的可访问性支持。
JTextComponent - Class in javax.swing.text
JTextComponent是摆动文本组件的基类。
JTextComponent() - Constructor for class javax.swing.text. JTextComponent
创建一个新的 JTextComponent 。
JTextComponent.AccessibleJTextComponent - Class in javax.swing.text
该类实现 JTextComponent课程的可访问性支持。
JTextComponent.DropLocation - Class in javax.swing.text
代表 JTextComponent的下载位置。
JTextComponent.KeyBinding - Class in javax.swing.text
用于创建密钥绑定的绑定记录。
JTextField - Class in javax.swing
JTextField是一个轻量级组件，允许编辑单行文本。
JTextField() - Constructor for class javax.swing. JTextField
构造新的 TextField 。
JTextField(int) - Constructor for class javax.swing. JTextField
构造一个新的空的 TextField与指定的列数。
JTextField(String) - Constructor for class javax.swing. JTextField
构造一个新的 TextField ，用指定的文本进行初始化。
JTextField(String, int) - Constructor for class javax.swing. JTextField
构造一个新的 TextField ，用指定的文本和列初始化。
JTextField(Document, String, int) - Constructor for class javax.swing. JTextField
构造一个新的 JTextField ，它使用给定的文本存储模型和给定的列数。
JTextField.AccessibleJTextField - Class in javax.swing
这个类实现 JTextField类的可访问性支持。
JTextPane - Class in javax.swing
可以用图形化的属性标记的文本组件。
JTextPane() - Constructor for class javax.swing. JTextPane
创建一个新的 JTextPane 。
JTextPane(StyledDocument) - Constructor for class javax.swing. JTextPane
创建一个新的 JTextPane ，具有指定的文档模型。
JToggleButton - Class in javax.swing
一个两状态按钮的实现。
JToggleButton() - Constructor for class javax.swing. JToggleButton
创建最初未选择的切换按钮，而不设置文本或图像。
JToggleButton(String) - Constructor for class javax.swing. JToggleButton
使用指定的文本创建一个未选择的切换按钮。
JToggleButton(String, boolean) - Constructor for class javax.swing. JToggleButton
创建具有指定文本和选择状态的切换按钮。
JToggleButton(String, Icon) - Constructor for class javax.swing. JToggleButton
创建具有指定文本和图像的切换按钮，最初未被选择。
JToggleButton(String, Icon, boolean) - Constructor for class javax.swing. JToggleButton
创建具有指定文本，图像和选择状态的切换按钮。
JToggleButton(Action) - Constructor for class javax.swing. JToggleButton
创建一个切换按钮，其属性取自提供的操作。
JToggleButton(Icon) - Constructor for class javax.swing. JToggleButton
创建一个最初未选择的切换按钮与指定的图像，但没有文本。
JToggleButton(Icon, boolean) - Constructor for class javax.swing. JToggleButton
创建具有指定图像和选择状态但不包含文本的切换按钮。
JToggleButton.AccessibleJToggleButton - Class in javax.swing
该类为 JToggleButton类实现可访问性支持。
JToggleButton.ToggleButtonModel - Class in javax.swing
ToggleButton模型
JToolBar - Class in javax.swing
JToolBar提供了一个组件，可用于显示常用的 Action或控件。
JToolBar() - Constructor for class javax.swing. JToolBar
创建一个新的工具栏; 方向默认为HORIZONTAL 。
JToolBar(int) - Constructor for class javax.swing. JToolBar
用指定的 orientation创建一个新的工具栏。
JToolBar(String) - Constructor for class javax.swing. JToolBar
用指定的 name创建一个新的工具栏。
JToolBar(String, int) - Constructor for class javax.swing. JToolBar
创建一个指定的 name和 orientation的新工具栏。
JToolBar.AccessibleJToolBar - Class in javax.swing
该类为 JToolBar类实现可访问性支持。
JToolBar.Separator - Class in javax.swing
工具栏特定的分隔符。
JToolTip - Class in javax.swing
用于显示组件的“提示”。
JToolTip() - Constructor for class javax.swing. JToolTip
创建工具提示。
JToolTip.AccessibleJToolTip - Class in javax.swing
该类为 JToolTip类实现可访问性支持。
JTree - Class in javax.swing
将一组分层数据显示为轮廓的控件。
JTree() - Constructor for class javax.swing. JTree
以示例模型返回 JTree 。
JTree(Object[]) - Constructor for class javax.swing. JTree
返回一个 JTree与指定数组的每个元素作为未显示的新根节点的子节点。
JTree(Hashtable<?, ?>) - Constructor for class javax.swing. JTree
返回一个 JTree创建的 Hashtable ，它不会用root显示。
JTree(Vector<?>) - Constructor for class javax.swing. JTree
返回一个 JTree ，其中指定的 Vector每个元素作为未显示的新根节点的子节点。
JTree(TreeModel) - Constructor for class javax.swing. JTree
返回显示根节点的 JTree的实例 - 使用指定的数据模型创建树。
JTree(TreeNode) - Constructor for class javax.swing. JTree
返回一个 JTree ，其中指定的 TreeNode作为根，显示根节点。
JTree(TreeNode, boolean) - Constructor for class javax.swing. JTree
以指定的 TreeNode作为根，返回一个 JTree ，其根显示根节点，并以指定的方式决定节点是否为叶节点。
JTree.AccessibleJTree - Class in javax.swing
该类为 JTree类实现可访问性支持。
JTree.AccessibleJTree.AccessibleJTreeNode - Class in javax.swing
该类为 JTree孩子实现可访问性支持。
JTree.DropLocation - Class in javax.swing
的一个子类 TransferHandler.DropLocation表示用于一个放置位置 JTree 。
JTree.DynamicUtilTreeNode - Class in javax.swing
DynamicUtilTreeNode可以包装向量/哈希表/数组/字符串，并根据需要创建适当的子树节点。
JTree.EmptySelectionModel - Class in javax.swing
EmptySelectionModel是一个 TreeSelectionModel ，不允许任何东西被选择。
JTree.TreeModelHandler - Class in javax.swing
监听模型，并在节点被删除或更改时相应更新 expandedState 。
JTree.TreeSelectionRedirector - Class in javax.swing
手柄创建一个新的 TreeSelectionEvent与 JTree作为来源，并将其传递给所有的听众。
JULIAN_DAY - Static variable in class java.time.temporal. JulianFields
朱利安日字段。
JulianFields - Class in java.time.temporal
一组提供访问朱利安日的日期字段。
JULY - java.time. Month
7月份的单身人士31天。
JULY - Static variable in class java.util. Calendar
Calendar.MONTH字段的值表示公历和朱利安日历中的第七个月。
JULY - Static variable in class javax.xml.datatype. DatatypeConstants
一年七月的价值
jumpTo(String) - Method in class javafx.animation. Animation
Animation此 Animation的预定义位置。
jumpTo(Duration) - Method in class javafx.animation. Animation
Animation这个 Animation的给定位置。
JUNE - java.time. Month
6月份的单身人士30天。
JUNE - Static variable in class java.util. Calendar
Calendar.MONTH字段的价值，表示今年第六个月在公历和朱利安日历。
JUNE - Static variable in class javax.xml.datatype. DatatypeConstants
一年六月的价值
JUSTIFICATION - Static variable in class java.awt.font. TextAttribute
段落的理由的属性关键。
JUSTIFICATION_FULL - Static variable in class java.awt.font. TextAttribute
将线对齐为满请求宽度。
JUSTIFICATION_NONE - Static variable in class java.awt.font. TextAttribute
不要让线路有道理。
JUSTIFY - javafx.scene.text. TextAlignment
表示对齐文本对齐。
JViewport - Class in javax.swing
您可以通过它查看基础信息的“视口”或“舷窗”。
JViewport() - Constructor for class javax.swing. JViewport
创建一个 JViewport 。
JViewport.AccessibleJViewport - Class in javax.swing
这个类实现 JViewport类的可访问性支持。
JViewport.ViewListener - Class in javax.swing
视图的监听器。
JWindow - Class in javax.swing
A JWindow是可以在用户桌面上的任何位置显示的容器。
JWindow() - Constructor for class javax.swing. JWindow
创建一个没有指定所有者的窗口。
JWindow(Frame) - Constructor for class javax.swing. JWindow
创建具有指定所有者框架的窗口。
JWindow(GraphicsConfiguration) - Constructor for class javax.swing. JWindow
使用指定的屏幕设备 GraphicsConfiguration创建一个窗口。
JWindow(Window) - Constructor for class javax.swing. JWindow
创建具有指定所有者窗口的窗口。
JWindow(Window, GraphicsConfiguration) - Constructor for class javax.swing. JWindow
创建具有指定所有者窗口和屏幕设备 GraphicsConfiguration的窗口。
JWindow.AccessibleJWindow - Class in javax.swing
该类为 JWindow类实现可访问性支持。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


K-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

K

K - javafx.scene.input. KeyCode
常数为 K键。
K1Div2Luminance - Static variable in class javax.imageio.plugins.jpeg. JPEGQTable
JPEG规范中给出的采样亮度量化表，表K.1，所有元素除以2。
K1Luminance - Static variable in class javax.imageio.plugins.jpeg. JPEGQTable
JPEG规范中给出的样本亮度量化表，表K.1。
K2Chrominance - Static variable in class javax.imageio.plugins.jpeg. JPEGQTable
JPEG规范中给出的样本色度量化表，表K.2。
K2Div2Chrominance - Static variable in class javax.imageio.plugins.jpeg. JPEGQTable
JPEG规范中给出的样本色度量化表，表K.1，所有元素除以2。
KAITHI - java.lang. Character.UnicodeScript
Unicode脚本“Kaithi”。
KAITHI - Static variable in class java.lang. Character.UnicodeBlock
“Kaithi”Unicode字符块的常数。
KAKU_0 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃0信封尺寸，287 mm×382 mm。
KAKU_1 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃1信封尺寸，270 mm×382 mm。
KAKU_2 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃2信封尺寸，240 mm×332 mm。
KAKU_20 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃20信封尺寸，229 mm×324 mm。
KAKU_3 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃3信封尺寸，216 mm×277 mm。
KAKU_4 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃4信封尺寸，197 mm×267 mm。
KAKU_5 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃5信封尺寸，190 mm×240 mm。
KAKU_6 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃6信封尺寸，162 mm×229 mm。
KAKU_7 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃7信封尺寸，142 mm×205 mm。
KAKU_8 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）＃8信封尺寸，119 mm×197 mm。
KAKU_A4 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS Kaku（“square”）A4信封尺寸，228 mm乘以312 mm。
KANA - javafx.scene.input. KeyCode
常数为 Kana键。
KANA_LOCK - javafx.scene.input. KeyCode
锁定假名功能键的常数。
KANA_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“假名补充”Unicode字符块的常数。
KANBUN - Static variable in class java.lang. Character.UnicodeBlock
“Kanbun”Unicode字符块的常量。
KANGXI_RADICALS - Static variable in class java.lang. Character.UnicodeBlock
常数为“康熙激进”Unicode字符块。
KANJI - javafx.scene.input. KeyCode
常数为 Kanji键。
KANJI - Static variable in class java.awt.im. InputSubset
所有用于日文的汉字的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的日文汉字。
KANNADA - java.awt.font. NumericShaper.Range
卡纳达范围与卡纳达数字。
KANNADA - java.lang. Character.UnicodeScript
Unicode脚本“Kannada”。
KANNADA - Static variable in class java.awt.font. NumericShaper
标识KANNADA范围和十进制基数。
KANNADA - Static variable in class java.lang. Character.UnicodeBlock
“Kannada”Unicode字符块的常量。
KATAKANA - java.lang. Character.UnicodeScript
Unicode脚本“片假名”。
KATAKANA - javafx.scene.input. KeyCode
片假名功能键的常数。
KATAKANA - Static variable in class java.lang. Character.UnicodeBlock
“片假名”Unicode字符块的常数。
KATAKANA_PHONETIC_EXTENSIONS - Static variable in class java.lang. Character.UnicodeBlock
“片假名语音扩展”Unicode字符块的常数。
KAYAH_LI - java.awt.font. NumericShaper.Range
Kayah Li范围与Kayah Li数字。
KAYAH_LI - java.lang. Character.UnicodeScript
Unicode脚本“Kayah_Li”。
KAYAH_LI - Static variable in class java.lang. Character.UnicodeBlock
常数为“Kayah Li”Unicode字符块。
KBD - Static variable in class javax.swing.text.html. HTML.Tag
标签<kbd>
KEEP - Static variable in interface java.util.jar. Pack200.Packer
字符串“keep”是某些属性的可能值。
KEEP - Static variable in interface java.util.jar. Pack200.Unpacker
字符串“keep”是某些属性的可能值。
KEEP_CURRENT_RESULT - Static variable in interface java.sql. Statement
常量表示当调用 getMoreResults时不应关闭当前的 ResultSet对象。
KEEP_FILE_ORDER - Static variable in interface java.util.jar. Pack200.Packer
如果此属性设置为 Pack200.Packer.TRUE ，则 打包程序将以源原始文件中的原始顺序传输所有元素。
KerberosCredMessage - Class in javax.security.auth.kerberos
此类封装了Kerberos 5 KRB_CRED消息，可用于将Kerberos凭据从一个主体发送到另一个主体。
KerberosCredMessage(KerberosPrincipal, KerberosPrincipal, byte[]) - Constructor for class javax.security.auth.kerberos. KerberosCredMessage
构造一个 KerberosCredMessage对象。
KerberosKey - Class in javax.security.auth.kerberos
该类封装了Kerberos主体的长期密钥。
KerberosKey(KerberosPrincipal, byte[], int, int) - Constructor for class javax.security.auth.kerberos. KerberosKey
当密钥类型和密钥版本号已知时，从给定字节构造一个 KerberosKey 。
KerberosKey(KerberosPrincipal, char[], String) - Constructor for class javax.security.auth.kerberos. KerberosKey
使用指定的算法名称从主体的密码构造一个 KerberosKey 。
KerberosPrincipal - Class in javax.security.auth.kerberos
这个类封装了一个Kerberos主体。
KerberosPrincipal(String) - Constructor for class javax.security.auth.kerberos. KerberosPrincipal
从提供的字符串输入构造一个 KerberosPrincipal 。
KerberosPrincipal(String, int) - Constructor for class javax.security.auth.kerberos. KerberosPrincipal
从提供的字符串和名称类型输入构造一个 KerberosPrincipal 。
KerberosTicket - Class in javax.security.auth.kerberos
从客户端的角度来看，该类封装了Kerberos票证和相关信息。
KerberosTicket(byte[], KerberosPrincipal, KerberosPrincipal, byte[], int, boolean[], Date, Date, Date, Date, InetAddress[]) - Constructor for class javax.security.auth.kerberos. KerberosTicket
构造一个 KerberosTicket使用客户端从KDC接收或从缓存读取的凭据信息。
Kernel - Class in java.awt.image
Kernel类定义了一个矩阵，描述了指定像素及其周围像素如何影响对滤波操作的输出图像中像素的位置计算的值。
Kernel(int, int, float[]) - Constructor for class java.awt.image. Kernel
从浮动数组构造一个 Kernel对象。
KERNING - Static variable in class java.awt.font. TextAttribute
要求字距调整的属性键。
KERNING_ON - Static variable in class java.awt.font. TextAttribute
请求标准字距。
key - Variable in class java.awt. Event
已过时。
在键盘事件中按下的键的键代码。
key - Variable in class javax.accessibility. AccessibleBundle
州的独立名称。
key - Variable in class javax.swing.text. JTextComponent.KeyBinding
钥匙。
Key - Interface in java.security
Key界面是所有键的顶级界面。
Key(int) - Constructor for class java.awt. RenderingHints.Key
使用指定的私钥构建密钥。
KEY - Static variable in class com.sun.java.accessibility.util. EventID
映射到AWT键支持（即KeyListener和KeyEvent）
KEY_ACTION - Static variable in class java.awt. Event
已过时。
用户按下非ASCII 操作键。
KEY_ACTION_RELEASE - Static variable in class java.awt. Event
已过时。
用户已经发布了非ASCII 动作键。
KEY_AGREEMENT - java.security. CryptoPrimitive
非对称原语：密钥协商和密钥分发
KEY_ALPHA_INTERPOLATION - Static variable in class java.awt. RenderingHints
Alpha插补提示键。
KEY_ANTIALIASING - Static variable in class java.awt. RenderingHints
抗锯齿提示键。
KEY_COLOR_RENDERING - Static variable in class java.awt. RenderingHints
显色提示键。
KEY_COMPROMISE - java.security.cert. CRLReason
这个原因表明已知或怀疑证书对象的私钥已经被泄密。
KEY_DITHERING - Static variable in class java.awt. RenderingHints
抖动提示键。
KEY_ENCAPSULATION - java.security. CryptoPrimitive
不对称原语：密钥封装机制
KEY_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择关键事件的事件掩码。
KEY_FIRST - Static variable in class java.awt.event. KeyEvent
用于关键事件的ids范围中的第一个数字。
KEY_FRACTIONALMETRICS - Static variable in class java.awt. RenderingHints
字体分数指标提示键。
KEY_INTERPOLATION - Static variable in class java.awt. RenderingHints
插值提示键。
KEY_LAST - Static variable in class java.awt.event. KeyEvent
用于关键事件的ids范围中的最后一个数字。
KEY_LOCATION_LEFT - Static variable in class java.awt.event. KeyEvent
指示按下或释放的键位于左键位置（该键有多个可能位置）的常数。
KEY_LOCATION_NUMPAD - Static variable in class java.awt.event. KeyEvent
指示键数据小键盘上的密钥事件或与数字小键盘对应的虚拟键的常数。
KEY_LOCATION_RIGHT - Static variable in class java.awt.event. KeyEvent
一个常数表示按下或释放的键位于正确的键位置（该键有多个可能的位置）。
KEY_LOCATION_STANDARD - Static variable in class java.awt.event. KeyEvent
指示按键或释放的键不被区分为键的左或右版本，并且不起源于数字键盘（或不是源自与数字键盘对应的虚拟键）。
KEY_LOCATION_UNKNOWN - Static variable in class java.awt.event. KeyEvent
一个常量，表示keyLocation不确定或不相关。
KEY_PRESS - Static variable in class java.awt. Event
已过时。
用户已按下正常键。
KEY_PRESSED - Static variable in class java.awt.event. KeyEvent
“按键”事件。
KEY_PRESSED - Static variable in class javafx.scene.input. KeyEvent
当按下键时，会发生此事件。
KEY_RELEASE - Static variable in class java.awt. Event
已过时。
用户已经释放了一个普通键。
KEY_RELEASED - Static variable in class java.awt.event. KeyEvent
“关键发布”事件。
KEY_RELEASED - Static variable in class javafx.scene.input. KeyEvent
当一个键被释放时，会发生这种情况。
KEY_RENDERING - Static variable in class java.awt. RenderingHints
呈现提示键。
KEY_RESOLUTION_VARIANT - Static variable in class java.awt. RenderingHints
图像分辨率变体提示键。
KEY_STROKE_CONTROL - Static variable in class java.awt. RenderingHints
中风归一化控制提示键。
KEY_TEXT_ANTIALIASING - Static variable in class java.awt. RenderingHints
文本抗锯齿提示键。
KEY_TEXT_LCD_CONTRAST - Static variable in class java.awt. RenderingHints
LCD文字对比度提示键。
KEY_TYPED - Static variable in class java.awt.event. KeyEvent
“键入”事件。
KEY_TYPED - Static variable in class javafx.scene.input. KeyEvent
当字符生成键被键入（按下并释放）时，会发生此事件。
KEY_WRAP - java.security. CryptoPrimitive
对称原语：键包装
KeyAdapter - Class in java.awt.event
用于接收键盘事件的抽象适配器类。
KeyAdapter() - Constructor for class java.awt.event. KeyAdapter
KeyAgreement - Class in javax.crypto
该类提供了密钥协议（或密钥交换）协议的功能。
KeyAgreement(KeyAgreementSpi, Provider, String) - Constructor for class javax.crypto. KeyAgreement
创建一个KeyAgreement对象。
KeyAgreementSpi - Class in javax.crypto
该类为 KeyAgreement类定义了 （ SPI ）。
KeyAgreementSpi() - Constructor for class javax.crypto. KeyAgreementSpi
KeyAlreadyExistsException - Exception in javax.management.openmbean
抛出此运行时异常以指示要添加到 表格数据实例的行的索引已被用于引用此 表格数据实例中的另一行。
KeyAlreadyExistsException() - Constructor for exception javax.management.openmbean. KeyAlreadyExistsException
没有详细信息的KeyAlreadyExistsException。
KeyAlreadyExistsException(String) - Constructor for exception javax.management.openmbean. KeyAlreadyExistsException
具有详细消息的KeyAlreadyExistsException。
KeyBinding(KeyStroke, String) - Constructor for class javax.swing.text. JTextComponent.KeyBinding
创建一个新的键绑定。
KEYBOARD_DIVIDER_MOVE_OFFSET - Static variable in class javax.swing.plaf.basic. BasicSplitPaneUI
当分隔符通过键盘上的光标键移动时移动多远（相对）。
KeyboardDownRightHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardDownRightHandler
keyboardDownRightListener - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
KeyboardEndHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardEndHandler
keyboardEndListener - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
KeyboardFocusManager - Class in java.awt
KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。
KeyboardFocusManager() - Constructor for class java.awt. KeyboardFocusManager
初始化KeyboardFocusManager。
KeyboardHomeHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardHomeHandler
keyboardHomeListener - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
KeyboardResizeToggleHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardResizeToggleHandler
keyboardResizeToggleListener - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
KeyboardUpLeftHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.KeyboardUpLeftHandler
keyboardUpLeftListener - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
KeyCharacterCombination - Class in javafx.scene.input
该类表示主键由其字符指定的组合键。
KeyCharacterCombination(String, KeyCombination.Modifier...) - Constructor for class javafx.scene.input. KeyCharacterCombination
为指定的主键字符和指定的修饰符列表构造一个 KeyCharacterCombination 。
KeyCharacterCombination(String, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue) - Constructor for class javafx.scene.input. KeyCharacterCombination
为指定的主键字符构建一个 KeyCharacterCombination ，并显式指定所有修改键。
KeyCode - Enum in javafx.scene.input
KeyEvent对象的关键代码集。
KeyCodeCombination - Class in javafx.scene.input
这个类代表一个组合键，其主键由它的 KeyCode指定。
KeyCodeCombination(KeyCode, KeyCombination.Modifier...) - Constructor for class javafx.scene.input. KeyCodeCombination
为指定的主键和指定的修饰符列表构造一个 KeyCodeCombination 。
KeyCodeCombination(KeyCode, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue) - Constructor for class javafx.scene.input. KeyCodeCombination
为指定的主键构建一个 KeyCodeCombination ，并显式指定所有修改键。
keyCombination(String) - Static method in class javafx.scene.input. KeyCombination
从指定的字符串构造一个新的 KeyCombination 。
KeyCombination - Class in javafx.scene.input
表示在键盘快捷键中使用的键组合。
KeyCombination(KeyCombination.Modifier...) - Constructor for class javafx.scene.input. KeyCombination
构造具有指定的修饰符列表的 KeyCombination 。
KeyCombination(KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue, KeyCombination.ModifierValue) - Constructor for class javafx.scene.input. KeyCombination
构造一个 KeyCombination ，具有所有修饰键的显式规范。
KeyCombination.Modifier - Class in javafx.scene.input
此类表示一对修饰符键及其值。
KeyCombination.ModifierValue - Enum in javafx.scene.input
ModifierValue指定修饰键的状态。
keyDown(Event, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
keyEqualsCharSet() - Method in exception javax.swing.text. ChangedCharSetException
返回字符集键。
KeyEvent - Class in java.awt.event
指示组件中发生击键的事件。
KeyEvent - Class in javafx.scene.input
一个事件，表示一个击键发生在一个Node 。
KeyEvent(Component, int, long, int, int) - Constructor for class java.awt.event. KeyEvent
已过时。
截至JDK1.1; 改用KeyEvent(Component, int, long, int, int, char)
KeyEvent(Component, int, long, int, int, char) - Constructor for class java.awt.event. KeyEvent
构造一个 KeyEvent对象。
KeyEvent(Component, int, long, int, int, char, int) - Constructor for class java.awt.event. KeyEvent
构造一个 KeyEvent对象。
KeyEvent(Object, EventTarget, EventType<KeyEvent>, String, String, KeyCode, boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.input. KeyEvent
从指定的参数构造一个新的 KeyEvent事件。
KeyEvent(EventType<KeyEvent>, String, String, KeyCode, boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.input. KeyEvent
从指定的参数构建一个新的 KeyEvent事件，具有 null源和目标。
KeyEventDispatcher - Interface in java.awt
KeyEventDispatcher与所有KeyEvents的目标和调度中的当前KeyboardFocusManager配合使用。
KeyEventPostProcessor - Interface in java.awt
KeyEventPostProcessor与所有未消耗的KeyEvents的最终分辨率中的当前KeyboardFocusManager配合使用。
KeyException - Exception in java.security
这是基本的关键例外。
KeyException() - Constructor for exception java.security. KeyException
构造一个没有详细消息的KeyException。
KeyException(String) - Constructor for exception java.security. KeyException
构造具有指定详细消息的KeyException。
KeyException(String, Throwable) - Constructor for exception java.security. KeyException
创建一个具有指定的详细信息和原因的 KeyException 。
KeyException(Throwable) - Constructor for exception java.security. KeyException
创建 KeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
KeyFactory - Class in java.security
主要工厂用于将 密钥 （类型为 Key不透明加密密钥）转换为 密钥规范 （基础密钥材料的透明表示），反之亦然。
KeyFactory(KeyFactorySpi, Provider, String) - Constructor for class java.security. KeyFactory
创建一个KeyFactory对象。
KeyFactorySpi - Class in java.security
该类定义了 KeyFactory类的 （ SPI ）。
KeyFactorySpi() - Constructor for class java.security. KeyFactorySpi
keyFor(Selector) - Method in class java.nio.channels. SelectableChannel
检索表示频道注册的键与给定的选择器。
keyFor(Selector) - Method in class java.nio.channels.spi. AbstractSelectableChannel
KeyFrame - Class in javafx.animation
在指定的时间点定义一组沿Timeline内插的变量的目标值 。
KeyFrame(Duration, String, KeyValue...) - Constructor for class javafx.animation. KeyFrame
构造函数 KeyFrame
KeyFrame(Duration, String, EventHandler<ActionEvent>, Collection<KeyValue>) - Constructor for class javafx.animation. KeyFrame
构造函数 KeyFrame
KeyFrame(Duration, String, EventHandler<ActionEvent>, KeyValue...) - Constructor for class javafx.animation. KeyFrame
构造函数 KeyFrame
KeyFrame(Duration, KeyValue...) - Constructor for class javafx.animation. KeyFrame
构造函数 KeyFrame
KeyFrame(Duration, EventHandler<ActionEvent>, KeyValue...) - Constructor for class javafx.animation. KeyFrame
构造函数 KeyFrame
KeyGenerator - Class in javax.crypto
该类提供了一个秘密（对称）密钥生成器的功能。
KeyGenerator(KeyGeneratorSpi, Provider, String) - Constructor for class javax.crypto. KeyGenerator
创建一个KeyGenerator对象。
KeyGeneratorSpi - Class in javax.crypto
该类定义了 KeyGenerator类的 （ SPI ）。
KeyGeneratorSpi() - Constructor for class javax.crypto. KeyGeneratorSpi
KeyHandler() - Constructor for class javax.swing.plaf.basic. BasicComboBoxUI.KeyHandler
KeyHandler() - Constructor for class javax.swing.plaf.basic. BasicTableUI.KeyHandler
KeyHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.KeyHandler
KeyInfo - Interface in javax.xml.crypto.dsig.keyinfo
KeyInfo中定义的XML KeyInfo元素的 表示 。
KeyInfoFactory - Class in javax.xml.crypto.dsig.keyinfo
用于从头开始创建KeyInfo个对象的工厂，或从对应的XML表示中解组KeyInfo对象。
KeyInfoFactory() - Constructor for class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
默认构造函数，用于由子类调用。
keyListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor
不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。
keyListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
此保护字段是实现特定的。
keyListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
keyListener - Variable in class javax.swing.plaf.basic. BasicTableUI
KeyListener ，附于 JTable 。
KeyListener - Interface in java.awt.event
用于接收键盘事件（按键）的侦听器界面。
KeyManagementException - Exception in java.security
这是处理密钥管理的所有操作的一般密钥管理例外。
KeyManagementException() - Constructor for exception java.security. KeyManagementException
构造一个没有详细消息的KeyManagementException。
KeyManagementException(String) - Constructor for exception java.security. KeyManagementException
构造具有指定详细消息的KeyManagementException。
KeyManagementException(String, Throwable) - Constructor for exception java.security. KeyManagementException
创建一个具有指定的详细信息和原因的 KeyManagementException 。
KeyManagementException(Throwable) - Constructor for exception java.security. KeyManagementException
创建 KeyManagementException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
KeyManager - Interface in javax.net.ssl
这是JSSE密钥管理器的基础接口。
KeyManagerFactory - Class in javax.net.ssl
该类作为关键管理人员基于关键材料来源的工厂。
KeyManagerFactory(KeyManagerFactorySpi, Provider, String) - Constructor for class javax.net.ssl. KeyManagerFactory
创建一个KeyManagerFactory对象。
KeyManagerFactorySpi - Class in javax.net.ssl
该类定义了 KeyManagerFactory类的 （ SPI ）。
KeyManagerFactorySpi() - Constructor for class javax.net.ssl. KeyManagerFactorySpi
Keymap - Interface in javax.swing.text
KeyStrokes绑定到动作的集合。
KeyName - Interface in javax.xml.crypto.dsig.keyinfo
在 KeyName中定义的XML KeyName元素的 表示 。
KeyPair - Class in java.security
这个类是密钥对（一个公钥和一个私钥）的简单持有者。
KeyPair(PublicKey, PrivateKey) - Constructor for class java.security. KeyPair
从给定的公钥和私钥构造一个密钥对。
KeyPairGenerator - Class in java.security
KeyPairGenerator类用于生成公钥和私钥对。
KeyPairGenerator(String) - Constructor for class java.security. KeyPairGenerator
为指定的算法创建一个KeyPairGenerator对象。
KeyPairGeneratorSpi - Class in java.security
该类定义了 KeyPairGenerator类的 （ SPI ），用于生成公钥和私钥对。
KeyPairGeneratorSpi() - Constructor for class java.security. KeyPairGeneratorSpi
keyPress(int) - Method in class java.awt. Robot
按一个给定的键。
keyPressed(KeyEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用keyPressed方法来处理keyPressed事件。
keyPressed(KeyEvent) - Method in class java.awt.event. KeyAdapter
按下键时调用。
keyPressed(KeyEvent) - Method in interface java.awt.event. KeyListener
按下键时调用。
keyPressed(KeyEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.KeyHandler
keyPressed(KeyEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.KeyHandler
keyPressed(KeyEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.KeyHandler
keyRelease(int) - Method in class java.awt. Robot
释放给定的键
keyReleased(KeyEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的keyReleased方法来处理keyReleased事件。
keyReleased(KeyEvent) - Method in class java.awt.event. KeyAdapter
当键已被释放时调用。
keyReleased(KeyEvent) - Method in interface java.awt.event. KeyListener
当键已被释放时调用。
keyReleased(KeyEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.InvocationKeyHandler
keyReleased(KeyEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.KeyHandler
keyReleased(KeyEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.KeyHandler
KeyRep - Class in java.security
序列化关键对象的标准化表示。
KeyRep(KeyRep.Type, String, String, byte[]) - Constructor for class java.security. KeyRep
构造备用Key类。
KeyRep.Type - Enum in java.security
钥匙类型
keys() - Method in class java.nio.channels. Selector
返回此选择器的键集。
keys() - Method in class java.security. Provider
keys() - Method in class java.util.concurrent. ConcurrentHashMap
返回此表中键的枚举。
keys() - Method in class java.util. Dictionary
返回此字典中键的枚举。
keys() - Method in class java.util. Hashtable
返回此散列表中键的枚举。
keys() - Method in class java.util.prefs. AbstractPreferences
实现 keys方法按照在本说明书中 Preferences.keys() 。
keys() - Method in class java.util.prefs. Preferences
返回在此首选项节点中具有关联值的所有键。
keys() - Method in class java.util. Properties
keys() - Method in class javax.swing. ActionMap
返回 Action了在这个约束的名字 ActionMap 。
keys() - Method in class javax.swing. InputMap
返回此 KeyStroke中绑定的 InputMap 。
keySelectionManager - Variable in class javax.swing. JComboBox
此保护字段是实现特定的。
KeySelector - Class in javax.xml.crypto
使用KeyInfo对象中包含的数据查找并返回键的选择器。
KeySelector() - Constructor for class javax.xml.crypto. KeySelector
默认的无参数构造函数; 仅供子类调用。
KeySelector.Purpose - Class in javax.xml.crypto
要选择的键的目的。
KeySelectorException - Exception in javax.xml.crypto
表示由KeySelector抛出的异常情况。
KeySelectorException() - Constructor for exception javax.xml.crypto. KeySelectorException
构建新的 KeySelectorException其中包含 null作为其详细信息。
KeySelectorException(String) - Constructor for exception javax.xml.crypto. KeySelectorException
构造一个新的 KeySelectorException具有指定的详细消息。
KeySelectorException(String, Throwable) - Constructor for exception javax.xml.crypto. KeySelectorException
构造一个新的 KeySelectorException与指定的详细信息和原因。
KeySelectorException(Throwable) - Constructor for exception javax.xml.crypto. KeySelectorException
构造一个新的 KeySelectorException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
KeySelectorResult - Interface in javax.xml.crypto
结果由 KeySelector.select方法返回。
keySet() - Method in class com.sun.net.httpserver. Headers
keySet() - Method in class java.awt. RenderingHints
返回此 RenderingHints包含的键的 Set视图。
keySet() - Method in class java.security. Provider
返回此提供程序中包含的属性键的不可修改的Set视图。
keySet() - Method in class java.util. AbstractMap
返回此地图中包含的键的Set视图。
keySet() - Method in class java.util.concurrent. ConcurrentHashMap
返回此地图中包含的键的Set视图。
keySet() - Method in interface java.util.concurrent. ConcurrentNavigableMap
返回此地图中包含的键的NavigableSet视图。
keySet() - Method in class java.util.concurrent. ConcurrentSkipListMap
返回此地图中包含的键的NavigableSet视图。
keySet() - Method in class java.util. EnumMap
返回此地图中包含的键的Set视图。
keySet() - Method in class java.util. HashMap
返回此地图中包含的键的Set视图。
keySet() - Method in class java.util. Hashtable
返回此地图中包含的键的Set视图。
keySet() - Method in class java.util. IdentityHashMap
返回此地图中包含的键的基于身份的设置视图。
keySet() - Method in class java.util.jar. Attributes
返回此Map中包含的属性名称（键）的Set视图。
keySet() - Method in class java.util. LinkedHashMap
返回此地图中包含的键的Set视图。
keySet() - Method in interface java.util. Map
返回此地图中包含的键的Set视图。
keySet() - Method in class java.util. Properties
keySet() - Method in class java.util. ResourceBundle
返回 Set包含在此的所有键的 ResourceBundle及其父包。
keySet() - Method in interface java.util. SortedMap
返回此地图中包含的键的Set视图。
keySet() - Method in class java.util. TreeMap
返回此地图中包含的键的Set视图。
keySet() - Method in class java.util. WeakHashMap
返回此地图中包含的键的Set视图。
keySet() - Method in class javafx.beans.binding. MapExpression
keySet() - Method in class javax.management.openmbean. CompositeType
返回此 CompositeType实例定义的所有项目名称的不可修改的集合视图。
keySet() - Method in interface javax.management.openmbean. TabularData
返回 TabularData实例中包含的 CompositeData值（即行）的键的集合视图（即索引值）。
keySet() - Method in class javax.management.openmbean. TabularDataSupport
返回包含在此索引行的 TabularDataSupport实例的底层映射中的键的集合视图。
keySet() - Method in class javax.script. SimpleBindings
返回此地图中包含的键的Set视图。
keySet() - Method in class jdk.incubator.http. MultiMapResult
keySet() - Method in class jdk.nashorn.api.scripting. AbstractJSObject
keySet() - Method in interface jdk.nashorn.api.scripting. JSObject
返回此对象的所有属性名称集。
keySet() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
keySet(V) - Method in class java.util.concurrent. ConcurrentHashMap
使用给定的公共映射值为任何添加（即Collection.add(E)和Collection.addAll(Collection) ）返回此地图中键的Set视图。
KeySpec - Interface in java.security.spec
构成加密密钥的密钥材料的（透明）规范。
keysSpi() - Method in class java.util.prefs. AbstractPreferences
返回在此首选项节点中具有关联值的所有键。
KeyStore - Class in java.security
该类代表加密密钥和证书的存储设备。
KeyStore(KeyStoreSpi, Provider, String) - Constructor for class java.security. KeyStore
创建给定类型的KeyStore对象，并封装给定的提供者实现（SPI对象）。
KeyStore.Builder - Class in java.security
要实例化的KeyStore对象的描述。
KeyStore.CallbackHandlerProtection - Class in java.security
一个封装CallbackHandler的ProtectionParameter。
KeyStore.Entry - Interface in java.security
KeyStore条目类型的标记界面。
KeyStore.Entry.Attribute - Interface in java.security
与密钥库条目关联的属性。
KeyStore.LoadStoreParameter - Interface in java.security
KeyStore load和 store参数的标记界面。
KeyStore.PasswordProtection - Class in java.security
基于密码的实现 ProtectionParameter 。
KeyStore.PrivateKeyEntry - Class in java.security
A KeyStore条目，其中包含 PrivateKey及相应的证书链。
KeyStore.ProtectionParameter - Interface in java.security
用于密钥库保护参数的标记界面。
KeyStore.SecretKeyEntry - Class in java.security
A KeyStore条目，其中包含一个 SecretKey 。
KeyStore.TrustedCertificateEntry - Class in java.security
A KeyStore条目，其中包含受信任的 Certificate 。
KeyStoreBuilderParameters - Class in javax.net.ssl
封装KeyStore.Builders列表的X509KeyManagers的参数对象。
KeyStoreBuilderParameters(KeyStore.Builder) - Constructor for class javax.net.ssl. KeyStoreBuilderParameters
从指定的KeyStore.Builder构造新的KeyStoreBuilderParameters。
KeyStoreBuilderParameters(List<KeyStore.Builder>) - Constructor for class javax.net.ssl. KeyStoreBuilderParameters
从KeyStore.Builder的列表中构造新的KeyStoreBuilderParameters。
KeyStoreException - Exception in java.security
这是通用的KeyStore异常。
KeyStoreException() - Constructor for exception java.security. KeyStoreException
构造一个没有详细消息的KeyStoreException。
KeyStoreException(String) - Constructor for exception java.security. KeyStoreException
构造具有指定详细消息的KeyStoreException。
KeyStoreException(String, Throwable) - Constructor for exception java.security. KeyStoreException
创建一个 KeyStoreException与指定的详细信息和原因。
KeyStoreException(Throwable) - Constructor for exception java.security. KeyStoreException
创建 KeyStoreException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
KeyStoreLoginModule - Class in com.sun.security.auth.module
提供一个JAAS登录模块，提示密钥存储别名，并使用别名的主体和凭据填充主题。
KeyStoreLoginModule() - Constructor for class com.sun.security.auth.module. KeyStoreLoginModule
KeyStoreSpi - Class in java.security
该类定义了 KeyStore类的 （ SPI ）。
KeyStoreSpi() - Constructor for class java.security. KeyStoreSpi
KeyStroke - Class in javax.swing
KeyStroke表示键盘或等效输入设备上的关键操作。
KeyTab - Class in javax.security.auth.kerberos
这个类封装了一个keytab文件。
keyTyped(KeyEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用keyTyped方法来处理keyTyped事件。
keyTyped(KeyEvent) - Method in class java.awt.event. KeyAdapter
键入键时调用。
keyTyped(KeyEvent) - Method in interface java.awt.event. KeyListener
键入键时调用。
keyTyped(KeyEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.KeyHandler
keyTyped(KeyEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.KeyHandler
键入键时调用。
keyUp(Event, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
KeyValue - Class in javafx.animation
定义要在动画中的特定间隔内插的键值。
KeyValue - Interface in javax.xml.crypto.dsig.keyinfo
在 KeyValue中定义的XML KeyValue元素的 表示 。
KeyValue(WritableValue<T>, T) - Constructor for class javafx.animation. KeyValue
创建一个 KeyValue ，使用 Interpolator.LINEAR 。
KeyValue(WritableValue<T>, T, Interpolator) - Constructor for class javafx.animation. KeyValue
创建一个 KeyValue 。
KHAKI - Static variable in class javafx.scene.paint. Color
颜色卡其色，RGB值为＃F0E68C
KHAROSHTHI - java.lang. Character.UnicodeScript
Unicode脚本“Kharoshthi”。
KHAROSHTHI - Static variable in class java.lang. Character.UnicodeBlock
“Kharoshthi”Unicode字符块的常数。
KHMER - java.awt.font. NumericShaper.Range
高棉范围与高棉数字。
KHMER - java.lang. Character.UnicodeScript
Unicode脚本“高棉”。
KHMER - Static variable in class java.awt.font. NumericShaper
标识KHMER范围和十进制基数。
KHMER - Static variable in class java.lang. Character.UnicodeBlock
“高棉”Unicode字符块的常数。
KHMER_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
“高棉符号”Unicode字符块的常数。
KHOJKI - java.lang. Character.UnicodeScript
Unicode脚本“Khojki”。
KHOJKI - Static variable in class java.lang. Character.UnicodeBlock
“Khojki”Unicode字符块的常数。
KHUDAWADI - java.lang. Character.UnicodeScript
Unicode脚本“Khudawadi”。
KHUDAWADI - Static variable in class java.lang. Character.UnicodeBlock
“Khudawadi”Unicode字符块的常量。
kind - Variable in class javax.tools. SimpleJavaFileObject
这种文件对象的种类。
kind - Variable in class org.omg.CosNaming. NameComponent
kind() - Method in interface com.sun.javadoc. Tag
已过时。
返回这个标签的种类。
kind() - Method in interface java.nio.file. WatchEvent
返回事件类型。
kind() - Method in class jdk.jshell. Snippet
该代码段的Snippet.Kind 。
kind() - Method in enum jdk.jshell. Snippet.SubKind
Snippet.Kind对应于这个SubKind 。
kind() - Method in interface jdk.jshell. SourceCodeAnalysis.SnippetWrapper
返回SourceCodeAnalysis.SnippetWrapper.source()的Snippet.Kind 。
kind() - Method in class org.omg.CORBA. TypeCode
检索这个 TypeCode对象的种类。
KOREA - Static variable in class java.util. Locale
对国家有用的常数。
KOREAN - Static variable in class java.util. Locale
有用的语言常数
KP_DOWN - javafx.scene.input. KeyCode
常数为数字键盘 向下箭头键。
KP_LEFT - javafx.scene.input. KeyCode
常数为数字键盘 左箭头键。
KP_RIGHT - javafx.scene.input. KeyCode
数字键盘 右箭头键的常数。
KP_UP - javafx.scene.input. KeyCode
常数为数字键盘 向上箭头键。
KRB_NT_PRINCIPAL - Static variable in class javax.security.auth.kerberos. KerberosPrincipal
用户主体名称类型。
KRB_NT_SRV_HST - Static variable in class javax.security.auth.kerberos. KerberosPrincipal
服务主机名称为实例（telnet，rcommands）的名称类型。
KRB_NT_SRV_INST - Static variable in class javax.security.auth.kerberos. KerberosPrincipal
服务和其他唯一实例（krbtgt）的名称类型。
KRB_NT_SRV_XHST - Static variable in class javax.security.auth.kerberos. KerberosPrincipal
服务与主机作为剩余组件名称类型。
KRB_NT_UID - Static variable in class javax.security.auth.kerberos. KerberosPrincipal
唯一的ID名称类型。
KRB_NT_UNKNOWN - Static variable in class javax.security.auth.kerberos. KerberosPrincipal
未知名称类型。
KRB5_GET_AUTHTIME - com.sun.security.jgss. InquireType
用于检索已建立的Kerberos 5安全上下文的服务票证中的authtime的属性类型。
KRB5_GET_AUTHZ_DATA - com.sun.security.jgss. InquireType
用于检索已建立的Kerberos 5安全上下文的服务票证中的授权数据的属性类型。
KRB5_GET_KRB_CRED - com.sun.security.jgss. InquireType
用于检索启动器即将发送给接受者的KRB_CRED消息的属性类型。
KRB5_GET_SESSION_KEY - com.sun.security.jgss. InquireType
已过时。
截至9，替换为InquireType.KRB5_GET_SESSION_KEY_EX ，其返回实现SecretKey接口的EncryptionKey的实例，并具有与KerberosKey类似的方法。
KRB5_GET_SESSION_KEY_EX - com.sun.security.jgss. InquireType
用于检索已建立的Kerberos 5安全上下文的会话密钥的属性类型。
KRB5_GET_TKT_FLAGS - com.sun.security.jgss. InquireType
用于检索已建立的Kerberos 5安全上下文的服务票证标志的属性类型。
Krb5LoginModule - Class in com.sun.security.auth.module
此 LoginModule使用Kerberos协议对用户进行身份验证。
Krb5LoginModule() - Constructor for class com.sun.security.auth.module. Krb5LoginModule
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


L-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

L

L - javafx.scene.input. KeyCode
常数为 L键。
label - Variable in class org.omg.CORBA. UnionMember
由该 UnionMember对象描述的联盟成员的标签。
label() - Method in interface com.sun.javadoc. SeeTag
已过时。
获取标签的 @see标签。
label() - Method in interface com.sun.jdi.connect. Connector.Argument
为此参数返回一个简短的可读标签。
Label - Class in java.awt
A Label对象是用于将文本放置在容器中的组件。
Label - Class in javafx.scene.control
标签是不可编辑的文本控件。
Label() - Constructor for class java.awt. Label
构造一个空标签。
Label() - Constructor for class javafx.scene.control. Label
创建一个空标签
Label(String) - Constructor for class java.awt. Label
用指定的文本字符串构造一个新的标签，左对齐。
Label(String) - Constructor for class javafx.scene.control. Label
创建带有提供文本的标签。
Label(String, int) - Constructor for class java.awt. Label
构造一个新的标签，以指定的对齐方式显示指定的文本字符串。
Label(String, Node) - Constructor for class javafx.scene.control. Label
使用提供的文本和图形创建标签。
LABEL - Static variable in class javax.accessibility. AccessibleRole
用于在界面中呈现图标或短字符串的对象。
LABEL - Static variable in class javax.swing.plaf.synth. Region
标签区域。
LABEL_FOR - Static variable in class javax.accessibility. AccessibleRelation
表示一个对象是一个或多个目标对象的标签。
LABEL_FOR_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
标识标签的目标组已更改。
Label.AccessibleAWTLabel - Class in java.awt
该类实现对 Label类的可访问性支持。
Labeled - Class in javafx.scene.control
标签Control是与其用户界面的一部分相关联的文本内容。
Labeled() - Constructor for class javafx.scene.control. Labeled
创建一个没有文字和图形的标签
Labeled(String) - Constructor for class javafx.scene.control. Labeled
创建带有文本的标签
Labeled(String, Node) - Constructor for class javafx.scene.control. Labeled
创建带有文本和图形的标签
LABELED_BY - javafx.scene. AccessibleAttribute
返回作为该节点的标签的节点。
LABELED_BY - Static variable in class javax.accessibility. AccessibleRelation
表示一个对象被一个或多个目标对象标记。
LABELED_BY_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
标识正在进行标签的对象已更改。
LABELED_STATEMENT - com.sun.source.tree. Tree.Kind
用于LabeledStatementTree的实例。
LABELED_STATEMENT - jdk.nashorn.api.tree. Tree.Kind
用于LabeledStatementTree的实例。
LabeledSkinBase< C extends Labeled> - Class in javafx.scene.control.skin
控件的默认皮肤实现扩展为Labeled 。
LabeledSkinBase(C) - Constructor for class javafx.scene.control.skin. LabeledSkinBase
LabeledSkinBase的构造方法。
LabeledStatementTree - Interface in com.sun.source.tree
标记语句的树节点。
LabeledStatementTree - Interface in jdk.nashorn.api.tree
标记语句的树节点。
labelFor - Variable in class javax.swing. JLabel
该标签用于 如果标签不是组件的标签，则为null
labelFormatterProperty() - Method in class javafx.scene.control. Slider
用于格式化主要刻度的标签的功能。
labelForProperty() - Method in class javafx.scene.control. Label
标签可以作为不同控件或节点的标签。
labelLineLengthProperty() - Method in class javafx.scene.chart. PieChart
从饼图的外部到切片标签的线的长度。
labelPaddingProperty() - Method in class javafx.scene.control. Labeled
标签周围的文字和图形内容。
labelProperty() - Method in class javafx.scene.chart. Axis
轴标签
labelProperty() - Method in class javafx.scene.chart. Axis.TickMark
刻度线的显示文字
labelRect - Variable in class javax.swing.plaf.basic. BasicSliderUI
标签矩形
labelsHaveSameBaselines() - Method in class javax.swing.plaf.basic. BasicSliderUI
如果标签表中的所有标签具有相同的基线，则返回true。
LabelSkin - Class in javafx.scene.control.skin
默认皮肤实现为Label控件。
LabelSkin(Label) - Constructor for class javafx.scene.control.skin. LabelSkin
创建一个新的LabelSkin实例，将必需的子节点安装到控件 children列表中。
labelsVisibleProperty() - Method in class javafx.scene.chart. PieChart
当绘制真实的饼图切片标签时
labelUI - Static variable in class javax.swing.plaf.basic. BasicLabelUI
默认为 BasicLabelUI实例。
LabelUI - Class in javax.swing.plaf
JLabel可插拔的外观和界面。
LabelUI() - Constructor for class javax.swing.plaf. LabelUI
LabelView - Class in javax.swing.text
A LabelView是一种风格的文本块，表示在文本模型中映射到元素上的视图。
LabelView(Element) - Constructor for class javax.swing.text. LabelView
构造一个包含在元素上的新视图。
LadderConverter - Class in javafx.css.converter
LAMBDA_EXPRESSION - com.sun.source.tree. Tree.Kind
用于LambdaExpressionTree的实例。
LambdaConversionException - Exception in java.lang.invoke
LambdaConversionException
LambdaConversionException() - Constructor for exception java.lang.invoke. LambdaConversionException
构造一个 LambdaConversionException 。
LambdaConversionException(String) - Constructor for exception java.lang.invoke. LambdaConversionException
构造一个 LambdaConversionException与消息。
LambdaConversionException(String, Throwable) - Constructor for exception java.lang.invoke. LambdaConversionException
构造一个 LambdaConversionException的消息和原因。
LambdaConversionException(String, Throwable, boolean, boolean) - Constructor for exception java.lang.invoke. LambdaConversionException
构造一个 LambdaConversionException与消息，原因和其他设置。
LambdaConversionException(Throwable) - Constructor for exception java.lang.invoke. LambdaConversionException
构造一个 LambdaConversionException的原因。
LambdaExpressionTree - Interface in com.sun.source.tree
lambda表达式的树节点。
LambdaExpressionTree.BodyKind - Enum in com.sun.source.tree
Lambda表达式有两种形式：表达式lambdas，其主体是表达式，语句lambdas，其主体是块
LambdaMetafactory - Class in java.lang.invoke
方法是通过委派给所提供的MethodHandle来实现一个或多个接口的简单“功能对象”的创建，可能在类型适配和参数的部分评估之后。
LANDSCAPE - javafx.print. PageOrientation
可打印区域的起点位于纸张的左下方。
LANDSCAPE - Static variable in class java.awt. PageAttributes.OrientationRequestedType
用于指定横向的OrientationRequestedType实例。
LANDSCAPE - Static variable in class java.awt.print. PageFormat
原点在纸张的左下角，x从底部到顶部运行，y从左到右运行。
LANDSCAPE - Static variable in class javax.print.attribute.standard. OrientationRequested
内容将在介质的长边缘成像。
LANG - Static variable in class javax.swing.text.html. HTML.Attribute
属性“lang”
LANGUAGE - Static variable in class java.text. AttributedCharacterIterator.Attribute
一些文本的语言的属性键。
LANGUAGE - Static variable in interface javax.naming. Context
包含用于指定与服务一起使用的首选语言的环境属性名称的常量。
LANGUAGE - Static variable in interface javax.script. ScriptEngine
作为实现支持的脚本语言的全名的命名值的保留键。
LANGUAGE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“语言”
LANGUAGE_PROCESSING_INSTRUCTION - Static variable in class javafx.fxml. FXMLLoader
语言处理指令的标签名称。
LANGUAGE_VERSION - Static variable in interface javax.script. ScriptEngine
用于标识实现支持的脚本语言版本的命名值的保留键。
LanguageCallback - Class in javax.security.auth.callback
基础安全服务实例化并通过一个 LanguageCallback的 handle方法的 CallbackHandler来检索用于本地化文本的 Locale 。
LanguageCallback() - Constructor for class javax.security.auth.callback. LanguageCallback
构造一个 LanguageCallback 。
LanguageRange(String) - Constructor for class java.util. Locale.LanguageRange
构造一个 LanguageRange使用给定的 range 。
LanguageRange(String, double) - Constructor for class java.util. Locale.LanguageRange
构造一个 LanguageRange使用给定 range和 weight 。
languageVersion() - Static method in class com.sun.javadoc. Doclet
已过时。
返回此doclet支持的Java编程语言版本。
languageVersion() - Static method in class com.sun.tools.doclets.standard. Standard
已过时。
LanguageVersion - Enum in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
LAO - java.awt.font. NumericShaper.Range
老挝数字老挝范围。
LAO - java.lang. Character.UnicodeScript
Unicode脚本“老挝”。
LAO - Static variable in class java.awt.font. NumericShaper
标识LAO范围和十进制基数。
LAO - Static variable in class java.lang. Character.UnicodeBlock
常数为“老挝”Unicode字符块。
LARGE_CAPACITY - Static variable in class javafx.print. PaperSource
指定选择LARGE_CAPACITY托盘。
LARGE_CAPACITY - Static variable in class javax.print.attribute.standard. MediaTray
打印机中的大容量进纸盘。
LARGE_ICON_KEY - Static variable in interface javax.swing. Action
用于存储 Icon的键。
LARGE_KEY - Static variable in class javax.swing.plaf.nimbus. NimbusStyle
大钥匙
LARGE_MODEL_PROPERTY - Static variable in class javax.swing. JTree
绑定属性名称为 largeModel 。
LARGE_SCALE - Static variable in class javax.swing.plaf.nimbus. NimbusStyle
大规模
largeArcFlagProperty() - Method in class javafx.scene.shape. ArcTo
大弧标志。
largeModel - Variable in class javax.swing. JTree
这棵树是大模型吗？
largeModel - Variable in class javax.swing.plaf.basic. BasicTreeUI
如果对largeModel进行优化，则为true。
last() - Method in interface java.sql. ResultSet
将光标移动到此 ResultSet对象中的最后一行。
last() - Method in class java.text. BreakIterator
返回最后一个边界。
last() - Method in interface java.text. CharacterIterator
将位置设置为getEndIndex（） - 1（如果文本为空，则为getEndIndex（）），并返回该位置处的字符。
last() - Method in class java.text. StringCharacterIterator
为String实现CharacterIterator.last（）。
last() - Method in class java.util.concurrent. ConcurrentSkipListSet
last() - Method in interface java.util. SortedSet
返回此集合中当前的最后（最高）元素。
last() - Method in class java.util. TreeSet
last() - Method in class javax.swing.text. Segment
将位置设置为getEndIndex（） - 1（如果文本为空，则为getEndIndex（）），并返回该位置处的字符。
last(Container) - Method in class java.awt. CardLayout
翻转到容器的最后一张卡片。
LAST - jdk.incubator.http. WebSocket.MessagePart
序列中消息的最后一部分。
LAST_DIVIDER_LOCATION_PROPERTY - Static variable in class javax.swing. JSplitPane
最后位置的绑定属性。
LAST_LINE_END - Static variable in class java.awt. GridBagConstraints
将组件放置在其显示区域的一角，其中页面上的最后一行文本将正常结束当前的 ComponentOrientation 。
LAST_LINE_START - Static variable in class java.awt. GridBagConstraints
将组件放置在其显示区域的一角，其中页面上的最后一行文本通常将为当前的 ComponentOrientation启动。
lastAccessTime() - Method in interface java.nio.file.attribute. BasicFileAttributes
返回上一次访问的时间。
lastAlloc - Variable in class javax.swing.text. AsyncBoxView.ChildLocator
最后看到的分配（当更改被刷新时重新绘制）。
lastChild() - Method in interface org.w3c.dom.traversal. TreeWalker
将 TreeWalker移动到当前节点的最后一个可见子节点，并返回新节点。
lastColumn - Variable in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange
最后一列
lastDayOfMonth() - Static method in class java.time.temporal. TemporalAdjusters
返回“最后一个月的”调整器，该日期设置为当前月份的最后一天。
lastDayOfYear() - Static method in class java.time.temporal. TemporalAdjusters
返回“最后一天的”调整器，其返回设置为当前年份的最后一天的新日期。
lastDividerLocation - Variable in class javax.swing. JSplitPane
拆分窗格的上一个位置。
lastEdit() - Method in class javax.swing.undo. CompoundEdit
返回最后 UndoableEdit在 edits ，或 null如果 edits是空的。
lastElement() - Method in class java.util. Vector
返回向量的最后一个组件。
lastElement() - Method in class javax.swing. DefaultListModel
返回列表的最后一个组件。
lastEntry() - Method in class java.util.concurrent. ConcurrentSkipListMap
返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
lastEntry() - Method in interface java.util. NavigableMap
返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
lastEntry() - Method in class java.util. TreeMap
lastIndexOf(int) - Method in class java.lang. String
返回指定字符的最后一次出现的字符串中的索引。
lastIndexOf(int, int) - Method in class java.lang. String
返回指定字符的最后一次出现的字符串中的索引，从指定的索引开始向后搜索。
lastIndexOf(E, int) - Method in class java.util.concurrent. CopyOnWriteArrayList
返回此列表中指定元素的最后一次出现的索引，从 index向后搜索，如果未找到该元素，则返回-1。
lastIndexOf(Object) - Method in class java.util. AbstractList
返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
lastIndexOf(Object) - Method in class java.util. ArrayList
返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
lastIndexOf(Object) - Method in class java.util.concurrent. CopyOnWriteArrayList
返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
lastIndexOf(Object) - Method in class java.util. LinkedList
返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
lastIndexOf(Object) - Method in interface java.util. List
返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。
lastIndexOf(Object) - Method in class java.util. Vector
返回此向量中指定元素的最后一次出现的索引，如果此向量不包含元素，则返回-1。
lastIndexOf(Object) - Method in class javafx.beans.binding. ListExpression
lastIndexOf(Object) - Method in class javax.swing. DefaultListModel
返回上一次发生的索引 elem 。
lastIndexOf(Object, int) - Method in class java.util. Vector
返回此向量中指定元素的最后一次出现的索引，从 index向后搜索，如果未找到该元素，则返回-1。
lastIndexOf(Object, int) - Method in class javax.swing. DefaultListModel
向后搜索 elem ，从指定的索引开始，并返回一个索引。
lastIndexOf(String) - Method in class java.lang. String
返回指定子字符串最后一次出现的字符串中的索引。
lastIndexOf(String) - Method in class java.lang. StringBuffer
lastIndexOf(String) - Method in class java.lang. StringBuilder
lastIndexOf(String, int) - Method in class java.lang. String
返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。
lastIndexOf(String, int) - Method in class java.lang. StringBuffer
lastIndexOf(String, int) - Method in class java.lang. StringBuilder
lastIndexOfSubList(List<?>, List<?>) - Static method in class java.util. Collections
返回指定源列表中指定目标列表的最后一次出现的起始位置，如果没有此类事件则返回-1。
lastInMonth(DayOfWeek) - Static method in class java.time.temporal. TemporalAdjusters
返回最近一个月的调整器，它返回与最后一个匹配的星期几相同月份的新日期。
lastKey() - Method in class java.util.concurrent. ConcurrentSkipListMap
lastKey() - Method in interface java.util. SortedMap
返回当前在此地图中的最后（最高）键。
lastKey() - Method in class java.util. TreeMap
lastModified() - Method in class java.io. File
返回此抽象路径名表示的文件上次修改的时间。
lastModifiedTime() - Method in interface java.nio.file.attribute. BasicFileAttributes
返回上次修改的时间。
LastOwnerException - Exception in java.security.acl
已过时。
自1.2版起，该软件包已被java.security.Policy及相关课程所取代。
LastOwnerException() - Constructor for exception java.security.acl. LastOwnerException
已过时。
构造一个LastOwnerException。
lastPageFirst() - Method in class java.awt. PrintJob
如果最后一页将首先打印，则返回true。
lastPaintPosition - Variable in class javax.swing. JViewport
最后一个 viewPosition我们画了，所以我们知道多少后备店的图像是有效的。
lastPath - Variable in class javax.swing.tree. DefaultTreeCellEditor
所选的最后路径。
lastRow - Variable in class javax.swing.event. TableModelEvent
最后一行已更改。
lastRow - Variable in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange
最后一行
lastRow - Variable in class javax.swing.tree. DefaultTreeCellEditor
最后传入 getTreeCellEditorComponent 。
lastSelectedRow - Variable in class javax.swing.plaf.basic. BasicTreeUI
上次选择的行的索引。
lastTabInRun(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
返回运行中的最后一个选项卡。
lastValidOffset - Variable in class javax.swing.text. AsyncBoxView.ChildLocator
上次偏移计算的位置有效。
lastValueProperty() - Method in class javafx.concurrent. ScheduledService
最后成功计算的值。
lastVisitedDateProperty() - Method in class javafx.scene.web. WebHistory.Entry
定义页面最后访问的Date 。
latest() - Static method in enum javax.lang.model. SourceVersion
返回可以建模的最新的源版本。
LATEST - Static variable in interface java.util.jar. Pack200.Packer
字符串“最新”，某些属性的可能值。
latestSupported() - Static method in enum javax.lang.model. SourceVersion
返回当前执行环境完全支持的最新源版本。
LATIN - java.lang. Character.UnicodeScript
Unicode脚本“拉丁文”。
LATIN - Static variable in class java.awt.im. InputSubset
所有拉丁字符的常数，包括BASIC_LATIN，LATIN_1_SUPPLEMENT，LATIN_EXTENDED_A，LATIN_EXTENDED_B Unicode字符块中的字符。
LATIN_1_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“Latin-1 Supplement”Unicode字符块的常数。
LATIN_DIGITS - Static variable in class java.awt.im. InputSubset
BASIC_LATIN Unicode字符块中包含的数字的常数。
LATIN_EXTENDED_A - Static variable in class java.lang. Character.UnicodeBlock
“Latin Extended-A”Unicode字符块的常量。
LATIN_EXTENDED_ADDITIONAL - Static variable in class java.lang. Character.UnicodeBlock
“拉丁扩展附加”Unicode字符块的常量。
LATIN_EXTENDED_B - Static variable in class java.lang. Character.UnicodeBlock
“拉丁扩展B”Unicode字符块的常量。
LATIN_EXTENDED_C - Static variable in class java.lang. Character.UnicodeBlock
“拉丁扩展C”Unicode字符块的常量。
LATIN_EXTENDED_D - Static variable in class java.lang. Character.UnicodeBlock
“拉丁扩展D”Unicode字符块的常数。
LATIN_EXTENDED_E - Static variable in class java.lang. Character.UnicodeBlock
“拉丁扩展E”Unicode字符块的常量。
LATITUDE_REF_NORTH - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。
LATITUDE_REF_SOUTH - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。
launch(Class<? extends Application>, String...) - Static method in class javafx.application. Application
启动独立应用程序。
launch(String...) - Static method in class javafx.application. Application
启动独立应用程序。
launch(Map<String, ? extends Connector.Argument>) - Method in interface com.sun.jdi.connect. LaunchingConnector
启动应用程序并连接到其VM。
LaunchingConnector - Interface in com.sun.jdi.connect
连接前可以启动目标虚拟机的连接器。
launchingConnectors() - Method in interface com.sun.jdi. VirtualMachineManager
返回已知的LaunchingConnector对象的列表。
LAVENDER - Static variable in class javafx.scene.paint. Color
彩色薰衣草，RGB值为＃E6E6FA
LAVENDERBLUSH - Static variable in class javafx.scene.paint. Color
颜色薰衣草腮红，RGB值为＃FFF0F5
LAWNGREEN - Static variable in class javafx.scene.paint. Color
颜色草坪绿色，RGB值为＃7CFC00
layer() - Method in class java.lang. ModuleLayer.Controller
返回此对象控制的图层。
LAYER_PROPERTY - Static variable in class javax.swing. JLayeredPane
绑定财产
LAYERED_PANE - Static variable in class javax.accessibility. AccessibleRole
一个专门的窗格，允许其子层被绘制，提供一个堆叠顺序的形式。
LAYERED_PANE_PROPERTY - Static variable in class javax.swing. JInternalFrame
绑定属性名称。
LayeredHighlighter - Class in javax.swing.text
LayeredHighlighter() - Constructor for class javax.swing.text. LayeredHighlighter
LayeredHighlighter.LayerPainter - Class in javax.swing.text
分层突出显示渲染器。
layeredPane - Variable in class javax.swing. JRootPane
管理菜单栏和内容窗格的分层窗格。
LayerInstantiationException - Exception in java.lang
创建module layer时抛出失败。
LayerInstantiationException() - Constructor for exception java.lang. LayerInstantiationException
构造一个 LayerInstantiationException ，没有详细信息。
LayerInstantiationException(String) - Constructor for exception java.lang. LayerInstantiationException
使用给定的详细信息构造一个 LayerInstantiationException 。
LayerInstantiationException(String, Throwable) - Constructor for exception java.lang. LayerInstantiationException
构造一个 LayerInstantiationException与给定的详细信息和原因。
LayerInstantiationException(Throwable) - Constructor for exception java.lang. LayerInstantiationException
构造一个 LayerInstantiationException与给定的原因。
LayerPainter() - Constructor for class javax.swing.text. LayeredHighlighter.LayerPainter
LayerUI< V extends Component> - Class in javax.swing.plaf
所有JLayer的UI代表的基类。
LayerUI() - Constructor for class javax.swing.plaf. LayerUI
layout() - Method in class java.awt. Component
已过时。
自JDK 1.1版起，由doLayout()替代。
layout() - Method in class java.awt. Container
已过时。
从JDK 1.1版开始，由doLayout()取代。
layout() - Method in class java.awt. ScrollPane
已过时。
从JDK 1.1版开始，由doLayout()替代。
layout() - Method in class javafx.scene. Parent
在此父项下的场景图上执行自上而下的布局传递。
layout() - Method in class javax.swing.plaf.synth. SynthSliderUI
滑出滑块。
layout(int, int) - Method in class javax.swing.text. BoxView
在框上执行布局
layout(int, int) - Method in class javax.swing.text. FlowView
把孩子带走
layout(FlowView) - Method in class javax.swing.text. FlowView.FlowStrategy
更新给定FlowView的流程。
LAYOUT_LEFT_TO_RIGHT - Static variable in class java.awt. Font
一个用于布局GlyphVector的标志，指示由Bidi分析确定的文本是从左到右。
LAYOUT_NO_LIMIT_CONTEXT - Static variable in class java.awt. Font
一个用于layoutGlyphVector的标志，指示在指定的限制之后的char数组中的文本不应被检查。
LAYOUT_NO_START_CONTEXT - Static variable in class java.awt. Font
layoutGlyphVector的一个标志，指示在指定的开始之前的char数组中的文本不应被检查。
LAYOUT_RIGHT_TO_LEFT - Static variable in class java.awt. Font
一个标记为layoutGlyphVector的标志，指示由Bidi分析确定的文本是从右到左。
layoutBoundsProperty() - Method in class javafx.scene. Node
应该用于此节点的布局计算的矩形边界。
layoutChanged(int) - Method in class javax.swing.text. BoxView
沿着轴使布局无效。
layoutChartChildren(double, double, double, double) - Method in class javafx.scene.chart. Chart
调用更新和布局从getChartChildren（）
layoutChartChildren(double, double, double, double) - Method in class javafx.scene.chart. PieChart
调用更新和布局从getChartChildren（）
layoutChartChildren(double, double, double, double) - Method in class javafx.scene.chart. XYChart
调用更新和布局从getChartChildren（）
layoutChildren() - Method in class javafx.scene.chart. Axis
在布局传递期间调用以布局此轴及其所有内容。
layoutChildren() - Method in class javafx.scene.chart. Chart
在布局传递期间调用以布局此图表及其所有内容。
layoutChildren() - Method in class javafx.scene.chart. ValueAxis
在布局传递期间调用以布局此轴及其所有内容。
layoutChildren() - Method in class javafx.scene.control. Cell
在布局传递过程中调用这个 Parent的孩子。
layoutChildren() - Method in class javafx.scene.control. Control
在布局传递期间调用这个 Parent的孩子进行布局。
layoutChildren() - Method in class javafx.scene.control. DialogPane
在布局传递过程中调用这个 Parent的子 Parent 。
layoutChildren() - Method in class javafx.scene.control.skin. NestedTableColumnHeader
在布局传递期间调用这个 Parent的孩子进行布局。
layoutChildren() - Method in class javafx.scene.control.skin. TableColumnHeader
在布局传递期间调用这个 Parent的孩子。
layoutChildren() - Method in class javafx.scene.control.skin. TableHeaderRow
在布局传递过程中调用这个 Parent的孩子。
layoutChildren() - Method in class javafx.scene.control.skin. VirtualFlow
在布局传递过程中调用这个 Parent的孩子进行布局。
layoutChildren() - Method in class javafx.scene.control. TableCell
layoutChildren() - Method in class javafx.scene.control. TreeTableCell
layoutChildren() - Method in class javafx.scene.control. TreeTableView
在布局传递过程中调用这个 Parent的孩子。
layoutChildren() - Method in class javafx.scene.control. TreeView
在布局传递期间调用这个 Parent的孩子。
layoutChildren() - Method in class javafx.scene. Group
组实现layoutChildren，以便每个小孩都调整为首选大小，如果小孩可调整大小。
layoutChildren() - Method in class javafx.scene.layout. AnchorPane
layoutChildren() - Method in class javafx.scene.layout. BorderPane
layoutChildren() - Method in class javafx.scene.layout. FlowPane
layoutChildren() - Method in class javafx.scene.layout. GridPane
layoutChildren() - Method in class javafx.scene.layout. HBox
layoutChildren() - Method in class javafx.scene.layout. StackPane
layoutChildren() - Method in class javafx.scene.layout. TilePane
layoutChildren() - Method in class javafx.scene.layout. VBox
layoutChildren() - Method in class javafx.scene. Parent
在布局传递期间调用这个 Parent的孩子进行布局。
layoutChildren() - Method in class javafx.scene.text. TextFlow
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. AccordionSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. CheckBoxSkin
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ChoiceBoxSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ColorPickerSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxBaseSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. DateCellSkin
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ListViewSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. MenuBarSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. MenuButtonSkinBase
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. PaginationSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ProgressBarSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ProgressIndicatorSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. RadioButtonSkin
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ScrollBarSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ScrollPaneSkin
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. SeparatorSkin
我们只需要处理单一的“线”儿童地区。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. SliderSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. SpinnerSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. SplitPaneSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TableCellSkinBase
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TableRowSkinBase
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TableViewSkinBase
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TabPaneSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TextAreaSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TextFieldSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TitledPaneSkin
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. ToolBarSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TreeCellSkin
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TreeTableRowSkin
布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. TreeViewSkin
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control.skin. VirtualContainerBase
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.control. SkinBase
在场景图的布局过程中调用。
layoutChildren(double, double, double, double) - Method in class javafx.scene.web. HTMLEditorSkin
在场景图的布局过程中调用。
layoutCL(JLabel, FontMetrics, String, Icon, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.basic. BasicLabelUI
转发给SwingUtilities.layoutCompoundLabel（）的调用。
layoutColumns(int, int[], int[], SizeRequirements[]) - Method in class javax.swing.text. TableView
将列排出以适应给定的目标范围。
layoutComboBox(Container, MetalComboBoxUI.MetalComboBoxLayoutManager) - Method in class javax.swing.plaf.metal. MetalComboBoxUI
勾画出 JComboBox在 parent容器。
layoutCompoundLabel(FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - Static method in class javax.swing. SwingUtilities
计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。
layoutCompoundLabel(JComponent, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - Static method in class javax.swing. SwingUtilities
计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。
layoutContainer(Container) - Method in class java.awt. BorderLayout
使用此边框布局来填充容器参数。
layoutContainer(Container) - Method in class java.awt. CardLayout
使用此卡布局来放出指定的容器。
layoutContainer(Container) - Method in class java.awt. FlowLayout
放出容器。
layoutContainer(Container) - Method in class java.awt. GridBagLayout
使用此网格包布局来放出指定的容器。
layoutContainer(Container) - Method in class java.awt. GridLayout
使用此布局放出指定的容器。
layoutContainer(Container) - Method in interface java.awt. LayoutManager
放出指定的容器。
layoutContainer(Container) - Method in class javax.swing. BoxLayout
由AWT召集 当指定的容器需要布置时。
layoutContainer(Container) - Method in class javax.swing. GroupLayout
放出指定的容器。
layoutContainer(Container) - Method in class javax.swing. JRootPane.RootLayout
指示布局管理器执行指定容器的布局。
layoutContainer(Container) - Method in class javax.swing. JSpinner.DefaultEditor
调整一个（而且只）的孩子，以完全填补父母插图内的区域。
layoutContainer(Container) - Method in class javax.swing. OverlayLayout
当指定的容器需要布置时，由AWT调用。
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ComboBoxLayoutManager
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.TitlePaneLayout
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFrameLayout
放出指定的容器。
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DividerLayout
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
实际布局。
layoutContainer(Container) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
放出指定的容器。
layoutContainer(Container) - Method in class javax.swing.plaf.metal. MetalComboBoxUI.MetalComboBoxLayoutManager
layoutContainer(Container) - Method in class javax.swing. ScrollPaneLayout
吹出滚屏。
layoutContainer(Container) - Method in class javax.swing. SpringLayout
layoutContainer(Container) - Method in class javax.swing. ViewportLayout
当指定的容器需要布置时，由AWT调用。
LayoutFocusTraversalPolicy - Class in javax.swing
一个SortingFocusTraversalPolicy，它根据大小，位置和方向对组件进行排序。
LayoutFocusTraversalPolicy() - Constructor for class javax.swing. LayoutFocusTraversalPolicy
构造一个LayoutFocusTraversalPolicy。
layoutGlyphVector(FontRenderContext, char[], int, int, int) - Method in class java.awt. Font
返回一个新的 GlyphVector对象，如果可能，执行文本的全面布局。
layoutHScrollbar(JScrollBar) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
垂直滚动条。
layoutInArea(Node, double, double, double, double, double, HPos, VPos) - Method in class javafx.scene.control. SkinBase
其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
layoutInArea(Node, double, double, double, double, double, HPos, VPos) - Method in class javafx.scene.layout. Region
其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
layoutInArea(Node, double, double, double, double, double, Insets, boolean, boolean, HPos, VPos) - Method in class javafx.scene.control. SkinBase
其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
layoutInArea(Node, double, double, double, double, double, Insets, boolean, boolean, HPos, VPos) - Method in class javafx.scene.layout. Region
其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
layoutInArea(Node, double, double, double, double, double, Insets, boolean, boolean, HPos, VPos, boolean) - Static method in class javafx.scene.layout. Region
其中规定了儿童的它的区域内的工具方法的父通过定义 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
layoutInArea(Node, double, double, double, double, double, Insets, HPos, VPos) - Method in class javafx.scene.control. SkinBase
其中规定了子由所限定的本皮肤区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
layoutInArea(Node, double, double, double, double, double, Insets, HPos, VPos) - Method in class javafx.scene.layout. Region
其中规定了子由所限定的本地区的区域内实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
layoutInfo - Variable in class java.awt. GridBagLayout
该字段保存网格包的布局信息。
layoutLabel(int, FontMetrics, int, String, Icon, Rectangle, Rectangle, Rectangle, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
Laysout一个标签。
layoutLabelInArea(double, double, double, double) - Method in class javafx.scene.control.skin. LabeledSkinBase
在给定的区域内执行标签内容的实际布局。
layoutLabelInArea(double, double, double, double, Pos) - Method in class javafx.scene.control.skin. LabeledSkinBase
在给定的区域内执行标签内容的实际布局。
layoutMajorAxis(int, int, int[], int[]) - Method in class javax.swing.text. BoxView
执行框的主轴的布局（即它所表示的轴）。
layoutMajorAxis(int, int, int[], int[]) - Method in class javax.swing.text. TableView.TableRow
执行框的主轴的布局（即其表示的轴）。
layoutManager - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已创建并放入拆分窗格的LayoutManager。
LayoutManager - Interface in java.awt
定义知道如何布置 Container的类的界面。
LayoutManager2 - Interface in java.awt
为知道如何根据布局约束对象布局容器的类定义接口。
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text. BoxView
执行框的短轴的布局（即与其所表示的轴正交的轴）。
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text.html. BlockView
执行框的短轴的布局（即与其所表示的轴正交的轴）。
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text. TableView
执行框的短轴的布局（即与其所表示的轴正交的轴）。
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text. TableView.TableRow
执行框的短轴的布局（即与其所表示的轴正交的轴）。
LayoutPath - Class in java.awt.font
LayoutPath提供了相对于基准的位置和用户空间中的点之间的映射。
LayoutPath() - Constructor for class java.awt.font. LayoutPath
layoutPlotChildren() - Method in class javafx.scene.chart. AreaChart
被要求更新和布局情节儿童。
layoutPlotChildren() - Method in class javafx.scene.chart. BarChart
被要求更新和布局情节儿童。
layoutPlotChildren() - Method in class javafx.scene.chart. BubbleChart
被要求更新和布局情节儿童。
layoutPlotChildren() - Method in class javafx.scene.chart. LineChart
被要求更新和布局情节儿童。
layoutPlotChildren() - Method in class javafx.scene.chart. ScatterChart
被要求更新和布局情节儿童。
layoutPlotChildren() - Method in class javafx.scene.chart. StackedAreaChart
被要求更新和布局情节儿童。
layoutPlotChildren() - Method in class javafx.scene.chart. StackedBarChart
被要求更新和布局情节儿童。
layoutPlotChildren() - Method in class javafx.scene.chart. XYChart
被要求更新和布局情节儿童。
layoutPool - Variable in class javax.swing.text. FlowView
这些是表示此视图表示的元素的子元素的视图（转换为物理视图的逻辑视图）。
LayoutQueue - Class in javax.swing.text
文本布局任务的队列。
LayoutQueue() - Constructor for class javax.swing.text. LayoutQueue
构造一个布局队列。
layoutRow(FlowView, int, int) - Method in class javax.swing.text. FlowView.FlowStrategy
创建一行将适合该行的布局范围内的视图。
layoutSpan - Variable in class javax.swing.text. FlowView
针对其创建流的默认约束。
LayoutStyle - Class in javax.swing
LayoutStyle提供了有关如何定位组件的信息。
LayoutStyle() - Constructor for class javax.swing. LayoutStyle
创建一个新的 LayoutStyle 。
LayoutStyle.ComponentPlacement - Enum in javax.swing
ComponentPlacement是可以相对于彼此放置两个组件的可能方式的列举。
layoutText(SynthContext, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils
通过引用将文本和图标返回，放置图标和文本的位置。
layoutVScrollbar(JScrollBar) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
垂直滚动条。
layoutXProperty() - Method in class javafx.scene. Node
定义添加到此 Node的转换中用于布局目的的转换的x坐标。
layoutYProperty() - Method in class javafx.scene. Node
定义添加到此 Node的转换的布局的y坐标。
lazilyLoadDesktopProperty(String) - Method in class java.awt. Toolkit
懒惰评估桌面属性值的机会。
LazyInputMap(Object[]) - Constructor for class javax.swing. UIDefaults.LazyInputMap
构造一个 LazyInputMap 。
lazySet(boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean
将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
lazySet(int) - Method in class java.util.concurrent.atomic. AtomicInteger
将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
lazySet(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
lazySet(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray
将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
lazySet(int, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。
lazySet(long) - Method in class java.util.concurrent.atomic. AtomicLong
将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的记忆效果。
lazySet(T, int) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
lazySet(T, long) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater
最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
lazySet(T, V) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater
最终将由此更新程序管理的给定对象的字段设置为给定的更新值。
lazySet(V) - Method in class java.util.concurrent.atomic. AtomicReference
将值设置为 newValue ，其记忆效应由 VarHandle.setRelease(java.lang.Object...)指定。
LCD - javafx.scene.text. FontSmoothingType
指定亚像素LCD文本，利用数字LCD显示面板的特性来实现更高的像素分辨率。
LDAPCertStoreParameters - Class in java.security.cert
参数用作LDAP CertStore算法的输入。
LDAPCertStoreParameters() - Constructor for class java.security.cert. LDAPCertStoreParameters
使用默认参数值（服务器名“localhost”，端口389）创建一个 LDAPCertStoreParameters的实例。
LDAPCertStoreParameters(String) - Constructor for class java.security.cert. LDAPCertStoreParameters
使用指定的服务器名称创建一个 LDAPCertStoreParameters的实例，默认端口为389。
LDAPCertStoreParameters(String, int) - Constructor for class java.security.cert. LDAPCertStoreParameters
创建具有指定参数值的 LDAPCertStoreParameters实例。
LdapContext - Interface in javax.naming.ldap
此接口表示您可以使用LDAPv3样式控件执行操作并执行LDAPv3样式扩展操作的上下文。
LdapLoginModule - Class in com.sun.security.auth.module
此LoginModule执行基于LDAP的身份验证。
LdapLoginModule() - Constructor for class com.sun.security.auth.module. LdapLoginModule
LdapName - Class in javax.naming.ldap
该类表示由 RFC 2253指定的专有名称。
LdapName(String) - Constructor for class javax.naming.ldap. LdapName
从给定的可分辨名称构造一个LDAP名称。
LdapName(List<Rdn>) - Constructor for class javax.naming.ldap. LdapName
给出其解析的RDN组件构造一个LDAP名称。
LdapPrincipal - Class in com.sun.security.auth
由 RFC 2253指定的专有名称确定的 主体 。
LdapPrincipal(String) - Constructor for class com.sun.security.auth. LdapPrincipal
创建一个LDAP主体。
LdapReferralException - Exception in javax.naming.ldap
此抽象类用于表示LDAP引用异常。
LdapReferralException() - Constructor for exception javax.naming.ldap. LdapReferralException
构造一个新的LdapReferralException实例。
LdapReferralException(String) - Constructor for exception javax.naming.ldap. LdapReferralException
使用提供的说明构造一个新的LdapReferralException实例。
LE - Static variable in class javax.management. Query
代表 Query.leq(javax.management.ValueExp, javax.management.ValueExp)查询的代码。
LEAD_DOTS - Static variable in class javax.swing.text. TabStop
铅点
LEAD_EQUALS - Static variable in class javax.swing.text. TabStop
铅等于
LEAD_HYPHENS - Static variable in class javax.swing.text. TabStop
铅连字符
LEAD_NONE - Static variable in class javax.swing.text. TabStop
无领导
LEAD_SELECTION_PATH_PROPERTY - Static variable in class javax.swing. JTree
绑定属性名称为 leadSelectionPath 。
LEAD_THICKLINE - Static variable in class javax.swing.text. TabStop
铅粗线
LEAD_UNDERLINE - Static variable in class javax.swing.text. TabStop
铅下划线
leadAnchorNotificationEnabled - Variable in class javax.swing. DefaultListSelectionModel
是否启用牵头锚通知。
leadIndex - Variable in class javax.swing.tree. DefaultTreeSelectionModel
引导路径的索引在选择。
leading(int) - Static method in class java.awt.font. TextHitInfo
在指定的 charIndex字符的 TextHitInfo创建一个 charIndex 。
LEADING - javax.swing. GroupLayout.Alignment
表示元素应与原点对齐。
LEADING - Static variable in class java.awt. FlowLayout
该值表示组件的每一行应该对齐到容器方向的前端，例如从左到右的方向向左。
LEADING - Static variable in class javax.swing.border. TitledBorder
将边框线左侧的标题文本从左到右定位，位于边框线右侧从右到左。
LEADING - Static variable in interface javax.swing. SwingConstants
标识用于从左到右和从右到左的语言的文本的前沿。
LEADING_ELLIPSIS - javafx.scene.control. OverrunStyle
与ELLIPSIS相同，但将“...”放在文本的开头，而不是结尾
LEADING_WORD_ELLIPSIS - javafx.scene.control. OverrunStyle
与WORD_ELLIPSIS相同，但将“...”放在文本的开头，而不是结尾
leadPath - Variable in class javax.swing.tree. DefaultTreeSelectionModel
添加的最后路径
leadRow - Variable in class javax.swing.tree. DefaultTreeSelectionModel
铅排。
LEAF - javafx.scene. AccessibleAttribute
如果节点是叶元素，则返回true，否则返回false。
LeafElement(Element, AttributeSet, int, int) - Constructor for class javax.swing.text. AbstractDocument.LeafElement
构造一个表示文档内容（没有子项）的元素。
leafIcon - Variable in class javax.swing.tree. DefaultTreeCellRenderer
用于显示叶节点的图标。
leafProperty() - Method in class javafx.scene.control. TreeItem
表示TreeItem leaf属性，如果TreeItem没有子节点，则属性为true。
Lease - Class in java.rmi.dgc
租赁包含唯一的VM标识符和租期。
Lease(VMID, long) - Constructor for class java.rmi.dgc. Lease
构建具有特定VMID和租期的租约。
leave(InetAddress) - Method in class java.net. DatagramSocketImpl
离开组播组。
leaveGroup(InetAddress) - Method in class java.net. MulticastSocket
离开多播组。
leaveGroup(SocketAddress, NetworkInterface) - Method in class java.net. DatagramSocketImpl
离开组播组。
leaveGroup(SocketAddress, NetworkInterface) - Method in class java.net. MulticastSocket
在指定的本地接口上留下组播组。
LEDGER - Static variable in class java.awt. PageAttributes.MediaType
Ledger的MediaType实例，11 x 17 in。
LEDGER - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定分类帐大小，11英寸×17英寸。
LEDGER - Static variable in class javax.print.attribute.standard. MediaSizeName
分类帐大小。
left - Variable in class java.awt. Insets
从左边的插图。
left - Variable in class javax.swing.border. EmptyBorder
边界的左边插图。
LEFT - javafx.geometry. HorizontalDirection
向左的方向
LEFT - javafx.geometry. HPos
表示左侧水平位置。
LEFT - javafx.geometry. Side
表示矩形的左侧。
LEFT - javafx.scene.control. ButtonBar.ButtonData
带有此样式标签的按钮将静态地结束在栏的左侧。
LEFT - javafx.scene.control. ContentDisplay
内容将放置在标签的左侧。
LEFT - javafx.scene.control.skin. TextInputControlSkin.Direction
LEFT - javafx.scene.input. KeyCode
常数为非numpad 左箭头键。
LEFT - javafx.scene.text. TextAlignment
表示左侧的文本对齐方式（左对齐，右对齐）。
LEFT - Static variable in class java.awt. Event
已过时。
左箭头键，非ASCII操作键。
LEFT - Static variable in class java.awt. FlowLayout
该值表示每一行的组件应为左对齐。
LEFT - Static variable in class java.awt. Label
表示标签应该保持对齐。
LEFT - Static variable in class javax.swing.border. TitledBorder
在边界线左侧放置标题文本。
LEFT - Static variable in class javax.swing. JSplitPane
用于将添加 Component其他左侧 Component 。
LEFT - Static variable in interface javax.swing. SwingConstants
方框常数用于指定框的左侧。
LEFT_ALIGNMENT - Static variable in class java.awt. Component
易于使用的常数为 getAlignmentX 。
LEFT_JUSTIFY - Static variable in class java.util. FormattableFlags
左对齐输出。
LEFT_OUTER_JOIN - Static variable in interface javax.sql.rowset. JoinRowSet
ANSI样式的 JOIN提供两个表之间的左外连接。
LEFT_PARENTHESIS - javafx.scene.input. KeyCode
常数为“（”键。
LEFT_SHIFT - com.sun.source.tree. Tree.Kind
用于实例BinaryTree代表左移<< 。
LEFT_SHIFT - jdk.nashorn.api.tree. Tree.Kind
用于表示左移<<的270457411403416的实例。
LEFT_SHIFT_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于实例CompoundAssignmentTree代表左移分配<<= 。
LEFT_SHIFT_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例CompoundAssignmentTree代表左移分配<<= 。
LEFT_TO_RIGHT - javafx.geometry. NodeOrientation
表示节点从左到右绘制。
LEFT_TO_RIGHT - Static variable in class java.awt. ComponentOrientation
项目从左到右运行，线条从上到下实例：英语，法语。
leftButton - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
用于快速切换左组件的按钮。
leftChildIndent - Variable in class javax.swing.plaf.basic. BasicTreeUI
左边距和垂直线之间的距离将被绘制。
leftComponent - Variable in class javax.swing. JSplitPane
左或顶部组件。
LeftIndent - Static variable in class javax.swing.text. StyleConstants
缩进段落左侧的数量。
leftKey - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
leftKey - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
已过时。
从Java 2平台v1.3开始。
leftKey - Variable in class javax.swing.plaf.basic. BasicToolBarUI
已过时。
从Java 2平台v1.3开始。
leftProperty() - Method in class javafx.scene.layout. BorderPane
节点位于此边框的左边缘。
leftToRightCache - Variable in class javax.swing.plaf.basic. BasicSliderUI
从左到右缓存
LEGAL - Static variable in class java.awt. PageAttributes.MediaType
NA_LEGAL的别名。
LEGAL - Static variable in class javafx.print. Paper
指定北美合法尺寸，8.5英寸×14英寸。
LEGAL - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美合法尺寸，8.5英寸×14英寸。
LEGAL_VALUES_FIELD - Static variable in class javax.management. JMX
名称为 legalValues字段。
legendProperty() - Method in class javafx.scene.chart. Chart
该节点显示为Legend。
legendSideProperty() - Method in class javafx.scene.chart. Chart
图表侧面应显示图例
legendVisibleProperty() - Method in class javafx.scene.chart. Chart
当为true时，如果图表实现支持图例，图表将显示图例。
LEMONCHIFFON - Static variable in class javafx.scene.paint. Color
颜色柠檬雪纺，RGB值为#FFFACD
len - Variable in class java.util.zip. InflaterInputStream
输入缓冲区的长度。
length - Variable in exception java.io. OptionalDataException
可用于在当前缓冲区中读取的原始数据的字节数。
length - Variable in class javax.sound.midi. MidiMessage
MIDI消息中的字节数，包括状态字节和任何数据字节。
length() - Method in interface com.sun.jdi. ArrayReference
返回此数组中的组件数。
length() - Method in class java.io. File
返回由此抽象路径名表示的文件的长度。
length() - Method in class java.io. RandomAccessFile
返回此文件的长度。
length() - Method in interface java.lang. CharSequence
返回此字符序列的长度。
length() - Method in class java.lang. String
返回此字符串的长度。
length() - Method in class java.lang. StringBuffer
length() - Method in class java.nio. CharBuffer
返回此字符缓冲区的长度。
length() - Method in class java.nio.charset. CoderResult
返回此对象描述的错误输入的长度 （可选操作） 。
length() - Method in interface java.sql. Blob
返回此 Blob对象指定的 BLOB值中的字节数。
length() - Method in interface java.sql. Clob
检索字符的在数 CLOB由该指定值 Clob对象。
length() - Method in class java.time. Year
在几天内获得今年的长度。
length() - Method in class java.util. BitSet
返回这个 BitSet的“逻辑大小”： BitSet加上最高位的索引。
length() - Method in class java.util.concurrent.atomic. AtomicIntegerArray
返回数组的长度。
length() - Method in class java.util.concurrent.atomic. AtomicLongArray
返回数组的长度。
length() - Method in class java.util.concurrent.atomic. AtomicReferenceArray
返回数组的长度。
length() - Method in class java.util. StringJoiner
返回此 StringJoiner的 String表示的 StringJoiner 。
length() - Method in class javafx.beans.binding. StringExpression
创建一个新的IntegerBinding ，其长度为StringExpression 。
length() - Method in interface javafx.scene.control. TextInputControl.Content
返回由内容表示的字符数。
length() - Method in class javax.imageio.stream. FileCacheImageOutputStream
length() - Method in class javax.imageio.stream. FileImageInputStream
返回底层文件的长度，如果未知，则返回 -1 。
length() - Method in class javax.imageio.stream. FileImageOutputStream
length() - Method in interface javax.imageio.stream. ImageInputStream
如果已知，返回流的总长度。
length() - Method in class javax.imageio.stream. ImageInputStreamImpl
返回 -1L以表示该流具有未知长度。
length() - Method in class javax.imageio.stream. MemoryCacheImageOutputStream
length() - Method in interface javax.jnlp. JNLPRandomAccessFile
返回此文件的长度。
length() - Method in class javax.sql.rowset.serial. SerialBlob
检索此 SerialBlob对象的字节数组中的字节数。
length() - Method in class javax.sql.rowset.serial. SerialClob
检索此 SerialClob对象的字符数组中的字符数。
length() - Method in interface javax.swing.text. AbstractDocument.Content
字符内容序列的当前长度。
length() - Method in class javax.swing.text. GapContent
返回内容的长度。
length() - Method in class javax.swing.text. Segment
返回此字符序列的长度。
length() - Method in class javax.swing.text. StringContent
返回内容的长度。
length() - Method in interface org.omg.CORBA. DynSequence
已过时。
返回由此 DynFixed对象表示的序列的长度。
length() - Method in class org.omg.CORBA. TypeCode
返回此 TypeCode对象描述的类型中的元素数。
length(boolean) - Method in enum java.time. Month
以天为单位获得本月的长度。
length(int) - Method in interface org.omg.CORBA. DynSequence
已过时。
将由此 DynFixed对象表示的序列的长度设置为给定的参数。
length(ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的IntegerBinding ，其长度为ObservableStringValue 。
lengthOfMonth() - Method in interface java.time.chrono. ChronoLocalDate
返回由日历系统定义的由此日期表示的月份的长度。
lengthOfMonth() - Method in class java.time.chrono. HijrahDate
返回由此日期表示的月份的长度。
lengthOfMonth() - Method in class java.time.chrono. JapaneseDate
返回由此日期表示的月份的长度。
lengthOfMonth() - Method in class java.time.chrono. MinguoDate
返回由此日期表示的月份的长度。
lengthOfMonth() - Method in class java.time.chrono. ThaiBuddhistDate
返回由此日期表示的月份的长度。
lengthOfMonth() - Method in class java.time. LocalDate
返回由此日期表示的月份的长度。
lengthOfMonth() - Method in class java.time. YearMonth
返回月份的长度，考虑到年份。
lengthOfYear() - Method in interface java.time.chrono. ChronoLocalDate
返回由日历系统定义的由此日期表示的年份的长度。
lengthOfYear() - Method in class java.time.chrono. HijrahDate
返回由此日期表示的年份的长度。
lengthOfYear() - Method in class java.time.chrono. JapaneseDate
lengthOfYear() - Method in class java.time. LocalDate
返回由此日期表示的年份的长度。
lengthOfYear() - Method in class java.time. YearMonth
返回一年的长度。
lengthProperty() - Method in class javafx.scene.control. TextInputControl
文本输入中的字符数。
lengthProperty() - Method in class javafx.scene.shape. Arc
以弧度定义弧的角度范围。
LENIENT - java.time.format. ResolverStyle
风格大方地解决日期和时间。
LEPCHA - java.awt.font. NumericShaper.Range
Lepcha范围与Lepcha数字。
LEPCHA - java.lang. Character.UnicodeScript
Unicode脚本“Lepcha”。
LEPCHA - Static variable in class java.lang. Character.UnicodeBlock
“Lepcha”Unicode字符块的常数。
leq(ValueExp, ValueExp) - Static method in class javax.management. Query
返回一个对两个值表示“小于或等于”约束的查询表达式。
LESS - javafx.scene.input. KeyCode
常数为 Less键。
LESS_THAN - com.sun.source.tree. Tree.Kind
用于实例BinaryTree代表小于号< 。
LESS_THAN - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree代表小于号< 。
LESS_THAN_EQUAL - com.sun.source.tree. Tree.Kind
用于实例BinaryTree较低于等于<= 。
LESS_THAN_EQUAL - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree较低于等于<= 。
LESS_THAN_MIN_ROLE_DEGREE - Static variable in class javax.management.relation. RoleStatus
尝试使用较少的ObjectNames设置角色值的问题类型，而不是最小预期基数。
LESSER - Static variable in class javax.xml.datatype. DatatypeConstants
比较结果。
lessThan(double) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
lessThan(double) - Method in class javafx.beans.binding. NumberExpressionBase
lessThan(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
lessThan(float) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
lessThan(float) - Method in class javafx.beans.binding. NumberExpressionBase
lessThan(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
lessThan(int) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
lessThan(int) - Method in class javafx.beans.binding. NumberExpressionBase
lessThan(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
lessThan(long) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于恒定值，则保留true 。
lessThan(long) - Method in class javafx.beans.binding. NumberExpressionBase
lessThan(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableNumberValue 。
lessThan(String) - Method in class javafx.beans.binding. StringExpression
创建一个新的BooleanBinding ，如果这个StringExpression小于恒定值，则保留true 。
lessThan(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableStringValue 。
lessThan(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding持有true如果NumberExpression比另一个较小ObservableNumberValue 。
lessThan(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase
lessThan(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
lessThan(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
lessThan(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值小于一个恒定值，则保留true 。
lessThan(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个值ObservableNumberValue小于一个恒定值。
lessThan(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果第一个ObservableNumberValue的值小于第二个值，则保留true 。
lessThan(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression
创建一个新的BooleanBinding持有true如果StringExpression小于另一个ObservableStringValue 。
lessThan(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个值ObservableStringValue小于一个恒定值。
lessThan(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果第一个ObservableStringValue的值小于第二个值，则保留true 。
lessThan(Duration) - Method in class javafx.util. Duration
如果指定的持续时间小于（<），则返回true。
lessThanOrEqual(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
lessThanOrEqual(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
lessThanOrEqual(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
lessThanOrEqual(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableNumberValue 。
lessThanOrEqual(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableStringValue 。
lessThanOrEqual(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
lessThanOrEqual(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
lessThanOrEqual(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
lessThanOrEqual(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableNumberValue小于或等于恒定值。
lessThanOrEqual(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建新的BooleanBinding ，如果第一个ObservableNumberValue的值小于或等于第二个值，则保留true 。
lessThanOrEqual(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableStringValue小于或等于恒定值。
lessThanOrEqual(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建新的BooleanBinding ，如果第一个ObservableStringValue的值小于或等于第二个值，则保留true 。
lessThanOrEquals(ResolutionSyntax) - Method in class javax.print.attribute. ResolutionSyntax
确定此分辨率属性的值是否小于或等于给定分辨率属性的值。
lessThanOrEqualTo(double) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于一个恒定值，则保留true 。
lessThanOrEqualTo(double) - Method in class javafx.beans.binding. NumberExpressionBase
lessThanOrEqualTo(float) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于常数值，则保留true 。
lessThanOrEqualTo(float) - Method in class javafx.beans.binding. NumberExpressionBase
lessThanOrEqualTo(int) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于一个恒定值，则保留true 。
lessThanOrEqualTo(int) - Method in class javafx.beans.binding. NumberExpressionBase
lessThanOrEqualTo(long) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding ，如果这个NumberExpression小于或等于一个恒定值，则保留true 。
lessThanOrEqualTo(long) - Method in class javafx.beans.binding. NumberExpressionBase
lessThanOrEqualTo(String) - Method in class javafx.beans.binding. StringExpression
创建一个新的BooleanBinding ，如果这个StringExpression小于或等于常数值，则保留true 。
lessThanOrEqualTo(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的BooleanBinding持有true如果NumberExpression小于或等于另一个ObservableNumberValue 。
lessThanOrEqualTo(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase
lessThanOrEqualTo(ObservableStringValue) - Method in class javafx.beans.binding. StringExpression
创建一个新的BooleanBinding持有true如果StringExpression小于或等于另一个ObservableStringValue 。
lessThanOrEqualTo(Duration) - Method in class javafx.util. Duration
如果指定的持续时间小于或等于（<=），则返回true。
LETTER - Static variable in class java.awt. PageAttributes.MediaType
NA_LETTER的别名。
LETTER - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美字母大小，8.5英寸×11英寸。
LETTER_NUMBER - Static variable in class java.lang. Character
Unicode规范中的一般类别“Nl”。
LETTER_SPACING - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“letter-spacing”。
LETTERLIKE_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
Unicode字符块的“字母符号”的常量。
Level - Class in java.util.logging
Level类定义了一组可用于控制日志输出的标准日志记录级别。
Level(String, int) - Constructor for class java.util.logging. Level
创建一个具有给定整数值的命名级别。
Level(String, int, String) - Constructor for class java.util.logging. Level
创建一个具有给定整数值和给定的本地化资源名称的命名级别。
levelProperty() - Method in class javafx.scene.effect. Glow
水平值，用于控制发光效果的强度。
levelProperty() - Method in class javafx.scene.effect. SepiaTone
水平值，其控制棕褐色效果的强度。
LexicalHandler - Interface in org.xml.sax.ext
用于词汇事件的SAX2扩展处理程序。
LI - Static variable in class javax.swing.text.html. HTML.Tag
标记<li>
LIFESPAN_POLICY_ID - Interface in org.omg.PortableServer
org / omg / PortableServer / LIFESPAN_POLICY_ID.java。
LifespanPolicy - Interface in org.omg.PortableServer
LifespanPolicy指定在创建的POA中实现的对象的使用寿命。
LifespanPolicyOperations - Interface in org.omg.PortableServer
LifespanPolicy指定在创建的POA中实现的对象的使用寿命。
LifespanPolicyValue - Class in org.omg.PortableServer
LifespanPolicyValue可以具有以下值。
LifespanPolicyValue(int) - Constructor for class org.omg.PortableServer. LifespanPolicyValue
LIGATURE - Static variable in class java.awt.font. GlyphMetrics
表示一个字形，表示多个字符为连字，例如“fi”或“ffi”。
LIGATURES - Static variable in class java.awt.font. TextAttribute
启用可选连字的属性键。
LIGATURES_ON - Static variable in class java.awt.font. TextAttribute
请求标准可选连字。
Light - Class in javafx.scene.effect
所有轻型实现的抽象基类。
Light() - Constructor for class javafx.scene.effect. Light
创造一个新的光。
LIGHT - javafx.scene.text. FontWeight
表示轻型字体重量（300）。
LIGHT - Static variable in class javax.swing.plaf.metal. MetalIconFactory
LIGHT用于属性 Tree.collapsedIcon 。
LIGHT_GRAY - Static variable in class java.awt. Color
颜色浅灰色。
LIGHT_SOURCE_CLOUDY_WEATHER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_COOL_WHITE_FLUORESCENT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_D50 - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_D55 - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_D65 - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_D75 - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_DAY_WHITE_FLUORESCENT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_DAYLIGHT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_DAYLIGHT_FLUORESCENT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_FINE_WEATHER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_FLASH - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_FLUORESCENT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_ISO_STUDIO_TUNGSTEN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_OTHER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_SHADE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_STANDARD_LIGHT_A - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_STANDARD_LIGHT_B - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_STANDARD_LIGHT_C - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_TUNGSTEN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_UNKNOWN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
LIGHT_SOURCE_WHITE_FLUORESCENT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“LightSource”标签一起使用的值。
Light.Distant - Class in javafx.scene.effect
代表遥远的光源。
Light.Point - Class in javafx.scene.effect
表示3D空间中给定位置的光源。
Light.Spot - Class in javafx.scene.effect
在3D空间中的给定位置表示点光源，具有可配置的方向和焦点。
LightBase - Class in javafx.scene
LightBase类提供了代表光源形式的对象的常用属性的定义。
LightBase() - Constructor for class javafx.scene. LightBase
使用默认的Color.WHITE光源创建一个 LightBase类的新实例。
LightBase(Color) - Constructor for class javafx.scene. LightBase
使用指定的颜色创建一个 LightBase类的新实例。
LIGHTBLUE - Static variable in class javafx.scene.paint. Color
颜色浅蓝色，RGB值为＃ADD8E6
LIGHTCORAL - Static variable in class javafx.scene.paint. Color
彩色珊瑚，RGB值为＃F08080
LIGHTCYAN - Static variable in class javafx.scene.paint. Color
颜色浅蓝色，RGB值为＃E0FFFF
LIGHTEN - javafx.scene.effect. BlendMode
来自两个输入的颜色分量的打火机被选择以产生所得到的颜色。
LIGHTGOLDENRODYELLOW - Static variable in class javafx.scene.paint. Color
颜色浅黄色，RGB值为#FAFAD2
lightGray - Static variable in class java.awt. Color
颜色浅灰色。
LIGHTGRAY - Static variable in class javafx.scene.paint. Color
颜色浅灰色，RGB值为＃D3D3D3
LIGHTGREEN - Static variable in class javafx.scene.paint. Color
颜色浅绿色，RGB值为＃90EE90
LIGHTGREY - Static variable in class javafx.scene.paint. Color
颜色浅灰色，RGB值为＃D3D3D3
lightHighlight - Variable in class javax.swing.plaf.basic. BasicBorders.ButtonBorder
光的颜色突出。
lightHighlight - Variable in class javax.swing.plaf.basic. BasicBorders.FieldBorder
光的颜色突出。
lightHighlight - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
光亮色彩
Lighting - Class in javafx.scene.effect
模拟照亮给定内容的光源的效果，可用于给平坦物体更逼真的三维外观。
Lighting() - Constructor for class javafx.scene.effect. Lighting
使用默认参数创建一个新的照明实例。
Lighting(Light) - Constructor for class javafx.scene.effect. Lighting
用指定的光线创建一个新的照明实例。
lightOnProperty() - Method in class javafx.scene. LightBase
定义灯亮或熄灭。
LIGHTPINK - Static variable in class javafx.scene.paint. Color
颜色浅粉红色，RGB值为＃FFB6C1
lightProperty() - Method in class javafx.scene.effect. Lighting
该光源为这 Lighting效果。
LIGHTSALMON - Static variable in class javafx.scene.paint. Color
RGB值为＃FFA07A的彩色三文鱼
LIGHTSEAGREEN - Static variable in class javafx.scene.paint. Color
颜色浅绿色，RGB值为＃20B2AA
LIGHTSKYBLUE - Static variable in class javafx.scene.paint. Color
彩色天空蓝色，RGB值为＃87CEFA
LIGHTSLATEGRAY - Static variable in class javafx.scene.paint. Color
颜色浅灰色，RGB值为＃778899
LIGHTSLATEGREY - Static variable in class javafx.scene.paint. Color
颜色浅灰色，RGB值为＃778899
LIGHTSTEELBLUE - Static variable in class javafx.scene.paint. Color
颜色浅蓝色，RGB值为＃B0C4DE
lightWeightPopupEnabled - Variable in class javax.swing. JComboBox
此保护字段是实现特定的。
lightWeightPopupEnabled - Variable in class javax.swing. ToolTipManager
启用轻量级弹出窗口。
LIGHTYELLOW - Static variable in class javafx.scene.paint. Color
颜色浅黄色，RGB值为＃FFFFE0
LIMBU - java.awt.font. NumericShaper.Range
Limbu范围与Limbu数字。
LIMBU - java.lang. Character.UnicodeScript
Unicode脚本“Limbu”。
LIMBU - Static variable in class java.lang. Character.UnicodeBlock
“Limbu”Unicode字符块的常量。
LIME - Static variable in class javafx.scene.paint. Color
RGB灰度值为＃00FF00
LIMEGREEN - Static variable in class javafx.scene.paint. Color
灰绿色，RGB值为＃32CD32
limit() - Method in class java.nio. Buffer
返回此缓冲区的限制。
limit(int) - Method in class java.nio. Buffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. ByteBuffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. CharBuffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. DoubleBuffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. FloatBuffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. IntBuffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. LongBuffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. MappedByteBuffer
设置此缓冲区的限制。
limit(int) - Method in class java.nio. ShortBuffer
设置此缓冲区的限制。
limit(long) - Method in interface java.util.stream. DoubleStream
返回由此流的元素组成的流，截短长度不能超过 maxSize 。
limit(long) - Method in interface java.util.stream. IntStream
返回由此流的元素组成的流，截短长度不得超过 maxSize 。
limit(long) - Method in interface java.util.stream. LongStream
返回由此流的元素组成的流，截短长度不能超过 maxSize 。
limit(long) - Method in interface java.util.stream. Stream
返回由此流的元素组成的流，截短长度不要超过 maxSize 。
LimitExceededException - Exception in javax.naming
当方法由于用户或系统指定的限制而异常终止时，会抛出此异常。
LimitExceededException() - Constructor for exception javax.naming. LimitExceededException
构造一个具有所有名称解析字段的LimitExceededException的新实例，并将说明初始化为null。
LimitExceededException(String) - Constructor for exception javax.naming. LimitExceededException
使用说明构造一个新的LimitExceededException实例。
line() - Method in interface com.sun.javadoc. SourcePosition
已过时。
源文件中的行。
Line - Class in javafx.scene.shape
此行代表 (x,y)坐标空间中的一个线段。
Line - Interface in javax.sound.sampled
Line接口表示单声道或多声道音频馈送。
Line() - Constructor for class javafx.scene.shape. Line
创建一个空的实例的线。
Line(double, double, double, double) - Constructor for class javafx.scene.shape. Line
创建一个新的Line实例。
LINE - javafx.scene.control.skin. TextInputControlSkin.TextUnit
LINE - javafx.scene.shape. DrawMode
将多边形原语渲染为在多边形的连续顶点之间绘制的线条。
LINE - Static variable in interface javax.accessibility. AccessibleExtendedText
常数用于表示应检索的文本的一部分是文本行。
LINE_AXIS - Static variable in class javax.swing. BoxLayout
指定组件应按目标容器的 ComponentOrientation属性确定的文本行的方向 ComponentOrientation 。
LINE_END - javafx.scene. AccessibleAttribute
返回给定行索引的行末端偏移量。
LINE_END - Static variable in class java.awt. BorderLayout
组件在布局的行方向的末尾。
LINE_END - Static variable in class java.awt. GridBagConstraints
将组件沿其显示区域的边缘放置，其中文本行将正常结束当前的 ComponentOrientation 。
LINE_FOR_OFFSET - javafx.scene. AccessibleAttribute
返回给定字符偏移量的行索引。
LINE_HEIGHT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“line-height”。
LINE_IN - Static variable in class javax.sound.sampled. Port.Info
一种从线路级音频输入插孔获取音频的端口。
LINE_OUT - Static variable in class javax.sound.sampled. Port.Info
一种将音频发送到线路级音频输出插孔的端口。
LINE_SEPARATOR - Static variable in class java.lang. Character
Unicode规范中的一般类别“Zl”。
LINE_START - javafx.scene. AccessibleAttribute
返回给定行索引的行开始偏移量。
LINE_START - Static variable in class java.awt. BorderLayout
组件在布局的行方向的开始处。
LINE_START - Static variable in class java.awt. GridBagConstraints
将组件沿其显示区域的边缘放置，其中文本行通常正在为当前的 ComponentOrientation开始。
Line.Info - Class in javax.sound.sampled
A Line.Info对象包含有关行的信息。
Line2D - Class in java.awt.geom
这个 Line2D表示 (x,y)坐标空间中的一个线段。
Line2D() - Constructor for class java.awt.geom. Line2D
这是一个无法直接实例化的抽象类。
Line2D.Double - Class in java.awt.geom
用双坐标指定的线段。
Line2D.Float - Class in java.awt.geom
用浮点坐标指定的线段。
LINEAR - Static variable in class javafx.animation. Interpolator
内置插值器，提供线性时间插值。
LINEAR_A - java.lang. Character.UnicodeScript
Unicode脚本“线性A”。
LINEAR_A - Static variable in class java.lang. Character.UnicodeBlock
“线性A”Unicode字符块的常量。
LINEAR_B - java.lang. Character.UnicodeScript
Unicode脚本“Linear_B”。
LINEAR_B_IDEOGRAMS - Static variable in class java.lang. Character.UnicodeBlock
“线性B表意符号”Unicode字符块的常数。
LINEAR_B_SYLLABARY - Static variable in class java.lang. Character.UnicodeBlock
“线性B音节”Unicode字符块的常数。
LINEAR_BACKOFF_STRATEGY - Static variable in class javafx.concurrent. ScheduledService
对于 backoffStrategy属性的回调实现，将在失败的情况 backoffStrategy性地回退重新执行之间的时间段。
LINEAR_RGB - java.awt. MultipleGradientPaint.ColorSpaceType
表示颜色插值应发生在线性化的RGB空间中。
LinearGradient - Class in javafx.scene.paint
LinearGradient类用线性颜色渐变模式填充形状。
LinearGradient(double, double, double, double, boolean, CycleMethod, List<Stop>) - Constructor for class javafx.scene.paint. LinearGradient
创建一个新的LinearGradient实例。
LinearGradient(double, double, double, double, boolean, CycleMethod, Stop...) - Constructor for class javafx.scene.paint. LinearGradient
创建一个新的LinearGradient实例。
LinearGradientPaint - Class in java.awt
LinearGradientPaint类提供了一种填充Shape的线性颜色渐变模式的方法。
LinearGradientPaint(float, float, float, float, float[], Color[]) - Constructor for class java.awt. LinearGradientPaint
构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
LinearGradientPaint(float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt. LinearGradientPaint
构造一个 LinearGradientPaint ，具有默认的 SRGB颜色空间。
LinearGradientPaint(Point2D, Point2D, float[], Color[]) - Constructor for class java.awt. LinearGradientPaint
构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt. LinearGradientPaint
构造一个 LinearGradientPaint具有默认 SRGB色彩空间。
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - Constructor for class java.awt. LinearGradientPaint
构造一个 LinearGradientPaint 。
LineBorder - Class in javax.swing.border
实现任意厚度和单一颜色的线边框的类。
LineBorder(Color) - Constructor for class javax.swing.border. LineBorder
创建具有指定颜色和厚度= 1的线边框。
LineBorder(Color, int) - Constructor for class javax.swing.border. LineBorder
创建具有指定颜色和厚度的线边框。
LineBorder(Color, int, boolean) - Constructor for class javax.swing.border. LineBorder
创建具有指定颜色，粗细和拐角形状的线条边框。
LineBorderUIResource(Color) - Constructor for class javax.swing.plaf. BorderUIResource.LineBorderUIResource
构造一个 LineBorderUIResource 。
LineBorderUIResource(Color, int) - Constructor for class javax.swing.plaf. BorderUIResource.LineBorderUIResource
构造一个 LineBorderUIResource 。
LineBreakMeasurer - Class in java.awt.font
LineBreakMeasurer类允许将样式文本分解成适合特定视觉进步的线（或段）。
LineBreakMeasurer(AttributedCharacterIterator, FontRenderContext) - Constructor for class java.awt.font. LineBreakMeasurer
为指定的文本构造一个 LineBreakMeasurer 。
LineBreakMeasurer(AttributedCharacterIterator, BreakIterator, FontRenderContext) - Constructor for class java.awt.font. LineBreakMeasurer
为指定的文本构造一个 LineBreakMeasurer 。
LineChart< X, Y> - Class in javafx.scene.chart
线图绘制了连接数据点的行。
LineChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. LineChart
用给定的轴构造一个新的LineChart。
LineChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>) - Constructor for class javafx.scene.chart. LineChart
使用给定的轴和数据构造一个新的LineChart。
LineChart.SortingPolicy - Enum in javafx.scene.chart
此枚举定义了一个 LineChart.axisSortingPolicyProperty()的策略。
lineColor - Variable in class javax.swing.border. LineBorder
边框颜色
LineEvent - Class in javax.sound.sampled
LineEvent类封装了线路打开，关闭，启动或停止时线路发送其监听器的信息。
LineEvent(Line, LineEvent.Type, long) - Constructor for class javax.sound.sampled. LineEvent
构造指定类型的新事件，源自指定的行。
LineEvent.Type - Class in javax.sound.sampled
LineEvent.Type内部类标识一行发生的事件。
lineLimitAttribute - Static variable in class javax.swing.text. PlainDocument
如果有最大长度，则指定一行的最大长度的属性名称。
LineListener - Interface in javax.sound.sampled
实现 LineListener接口的类的实例可以注册以在线路状态更改时接收事件。
LineMap - Interface in com.sun.source.tree
提供在编译单元的字符位置和行号之间进行转换的方法。
LineMap - Interface in jdk.nashorn.api.tree
提供在编译单元的字符位置和行号之间进行转换的方法。
LineMetrics - Class in java.awt.font
LineMetrics类允许访问沿线排列字符和布局一组行所需的度量。
LineMetrics() - Constructor for class java.awt.font. LineMetrics
LINEN - Static variable in class javafx.scene.paint. Color
颜色亚麻布，RGB值为#FAF0E6
lineno() - Method in class java.io. StreamTokenizer
返回当前行号。
lineNumber() - Method in interface com.sun.jdi. Location
获取此位置的行号。
lineNumber(String) - Method in interface com.sun.jdi. Location
此位置的行号。
LineNumberInputStream - Class in java.io
已过时。
该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。
LineNumberInputStream(InputStream) - Constructor for class java.io. LineNumberInputStream
已过时。
构造从指定输入流读取其输入的换行符输入流。
LineNumberReader - Class in java.io
缓冲字符输入流，跟踪行号。
LineNumberReader(Reader) - Constructor for class java.io. LineNumberReader
使用默认的输入缓冲区大小创建一个新的行号阅读器。
LineNumberReader(Reader, int) - Constructor for class java.io. LineNumberReader
创建一个新的行号阅读器，将字符读入给定大小的缓冲区。
lines() - Method in class java.io. BufferedReader
返回一个 Stream ，其元素是从这个 BufferedReader读取的行。
lines(Path) - Static method in class java.nio.file. Files
从文件中读取所有行作为 Stream 。
lines(Path, Charset) - Static method in class java.nio.file. Files
从文件中读取所有行作为 Stream 。
LINES - javafx.scene.input. ScrollEvent.VerticalTextScrollUnits
垂直的基于文本的滚动量是要滚动的行数。
lineSeparator() - Static method in class java.lang. System
返回与系统相关的行分隔符字符串。
linesIntersect(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom. Line2D
测试，如果线段从 (x1,y1)到 (x2,y2)相交的线段从 (x3,y3)到 (x4,y4) 。
LineSpacing - Static variable in class javax.swing.text. StyleConstants
段落之间的空格数量。
lineSpacingProperty() - Method in class javafx.scene.control. Labeled
指定行之间的像素间距。
lineSpacingProperty() - Method in class javafx.scene.text. Text
定义行之间像素的垂直空间。
lineSpacingProperty() - Method in class javafx.scene.text. TextFlow
定义行之间像素的垂直空间。
lineTo(double, double) - Method in class java.awt.geom. Path2D.Double
通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
lineTo(double, double) - Method in class java.awt.geom. Path2D.Float
通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
lineTo(double, double) - Method in class java.awt.geom. Path2D
通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
lineTo(double, double) - Method in class javafx.scene.canvas. GraphicsContext
将段添加到当前路径，以形成与给定x，y坐标的一条线。
lineTo(float, float) - Method in class java.awt.geom. Path2D.Float
通过从当前坐标绘制直线到浮点精度指定的新指定坐标，向路径添加点。
LineTo - Class in javafx.scene.shape
通过从当前坐标绘制直线到新坐标来创建线路元素。
LineTo() - Constructor for class javafx.scene.shape. LineTo
创建一个空的LineTo实例。
LineTo(double, double) - Constructor for class javafx.scene.shape. LineTo
创建LineTo的新功能。
lineToRect(Shape, int) - Method in class javax.swing.text. PlainView
确定表示给定行的矩形。
LineUnavailableException - Exception in javax.sound.sampled
A LineUnavailableException是一个例外，指示由于不可用而无法打开该行。
LineUnavailableException() - Constructor for exception javax.sound.sampled. LineUnavailableException
构造一个 LineUnavailableException ，其中有 null作为其错误详细消息。
LineUnavailableException(String) - Constructor for exception javax.sound.sampled. LineUnavailableException
构造一个具有指定详细消息的 LineUnavailableException 。
link(T) - Method in class jdk.dynalink. DynamicLinker
链接一个invokedynamic调用站点。
LINK - com.sun.source.doctree. DocTree.Kind
用于表示@link标签的LinkTree的实例。
LINK - javafx.scene.input. TransferMode
表示支持或预期数据的链接。
LINK - Static variable in class javax.swing.text.html. HTML.Attribute
属性“链接”
LINK - Static variable in class javax.swing.text.html. HTML.Tag
标记<link>
LINK - Static variable in class javax.swing. TransferHandler
代表“链接”转移动作的 int 。
LINK_PLAIN - com.sun.source.doctree. DocTree.Kind
用于实例LinkTree表示@linkplain标签。
LinkageError - Error in java.lang
LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
LinkageError() - Constructor for error java.lang. LinkageError
构造一个 LinkageError ，没有详细消息。
LinkageError(String) - Constructor for error java.lang. LinkageError
构造具有指定详细消息的 LinkageError 。
LinkageError(String, Throwable) - Constructor for error java.lang. LinkageError
构造一个具有指定的详细信息和原因的 LinkageError 。
LinkController() - Constructor for class javax.swing.text.html. HTMLEditorKit.LinkController
LinkedBlockingDeque< E> - Class in java.util.concurrent
基于链接节点的可选限定的blocking deque 。
LinkedBlockingDeque() - Constructor for class java.util.concurrent. LinkedBlockingDeque
创建 LinkedBlockingDeque ，容量为 Integer.MAX_VALUE 。
LinkedBlockingDeque(int) - Constructor for class java.util.concurrent. LinkedBlockingDeque
创建一个给定（固定）容量的 LinkedBlockingDeque 。
LinkedBlockingDeque(Collection<? extends E>) - Constructor for class java.util.concurrent. LinkedBlockingDeque
创建一个 LinkedBlockingDeque ，容量为 Integer.MAX_VALUE ，最初包含给定集合的元素，以遍历顺序添加集合的迭代器。
LinkedBlockingQueue< E> - Class in java.util.concurrent
基于链接节点的可选限定的blocking queue 。
LinkedBlockingQueue() - Constructor for class java.util.concurrent. LinkedBlockingQueue
创建 LinkedBlockingQueue ，容量为 Integer.MAX_VALUE 。
LinkedBlockingQueue(int) - Constructor for class java.util.concurrent. LinkedBlockingQueue
创建一个给定（固定）容量的 LinkedBlockingQueue 。
LinkedBlockingQueue(Collection<? extends E>) - Constructor for class java.util.concurrent. LinkedBlockingQueue
创建一个 LinkedBlockingQueue ，容量为 Integer.MAX_VALUE ，最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
LinkedHashMap< K, V> - Class in java.util
哈希表和链表实现的 Map接口，具有可预测的迭代次序。
LinkedHashMap() - Constructor for class java.util. LinkedHashMap
构造具有默认初始容量（16）和负载因子（0.75）的空插入订购的 LinkedHashMap实例。
LinkedHashMap(int) - Constructor for class java.util. LinkedHashMap
构造具有指定初始容量和默认负载因子（0.75）的空插入订单 LinkedHashMap实例。
LinkedHashMap(int, float) - Constructor for class java.util. LinkedHashMap
构造具有指定的初始容量和负载因子的空插入订单 LinkedHashMap实例。
LinkedHashMap(int, float, boolean) - Constructor for class java.util. LinkedHashMap
构造一个空的 LinkedHashMap实例，具有指定的初始容量，负载因子和排序模式。
LinkedHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util. LinkedHashMap
构造具有与指定地图相同的映射的插入式 LinkedHashMap实例。
LinkedHashSet< E> - Class in java.util
哈希表和链表实现的 Set接口，具有可预测的迭代次序。
LinkedHashSet() - Constructor for class java.util. LinkedHashSet
构造一个具有默认初始容量（16）和负载因子（0.75）的新的，空的链接散列集。
LinkedHashSet(int) - Constructor for class java.util. LinkedHashSet
构造一个具有指定初始容量和默认负载因子（0.75）的新的，空的链接散列集。
LinkedHashSet(int, float) - Constructor for class java.util. LinkedHashSet
构造具有指定的初始容量和负载因子的新的，空的链接散列集。
LinkedHashSet(Collection<? extends E>) - Constructor for class java.util. LinkedHashSet
构造与指定集合相同的元素的新的链接散列集。
LinkedList< E> - Class in java.util
双链表实现了 List和 Deque接口。
LinkedList() - Constructor for class java.util. LinkedList
构造一个空列表。
LinkedList(Collection<? extends E>) - Constructor for class java.util. LinkedList
构造一个包含指定集合的元素的列表，按照它们由集合的迭代器返回的顺序。
LinkedTransferQueue< E> - Class in java.util.concurrent
基于链接节点的无界TransferQueue 。
LinkedTransferQueue() - Constructor for class java.util.concurrent. LinkedTransferQueue
创建一个最初的空 LinkedTransferQueue 。
LinkedTransferQueue(Collection<? extends E>) - Constructor for class java.util.concurrent. LinkedTransferQueue
创建一个 LinkedTransferQueue最初包含给定集合的元素，以集合的迭代器的遍历顺序添加。
LinkerServices - Interface in jdk.dynalink.linker
由DynamicLinker提供给GuardingDynamicLinker实例的服务接口，拥有它们。
LinkException - Exception in javax.naming
此异常用于描述解决链接时遇到的问题。
LinkException() - Constructor for exception javax.naming. LinkException
构造一个新的LinkException实例。
LinkException(String) - Constructor for exception javax.naming. LinkException
构造一个新的LinkException实例，并给出解释。
linkExplanation - Variable in exception javax.naming. LinkException
包含为什么解决链接失败的例外。
LinkLoopException - Exception in javax.naming
当尝试解析链接时检测到一个循环，或者达到链接计数的实现特定限制时，会抛出此异常。
LinkLoopException() - Constructor for exception javax.naming. LinkLoopException
构造一个新的LinkLoopException实例。
LinkLoopException(String) - Constructor for exception javax.naming. LinkLoopException
构造一个新的LinkLoopException实例和解释。
LinkOption - Enum in java.nio.file
定义如何处理符号链接的选项。
LinkPermission - Class in java.nio.file
Permission类链接创建操作。
LinkPermission(String) - Constructor for class java.nio.file. LinkPermission
构造具有指定名称的 LinkPermission 。
LinkPermission(String, String) - Constructor for class java.nio.file. LinkPermission
构造具有指定名称的 LinkPermission 。
LinkRef - Class in javax.naming
此类表示一个引用，其内容是名称，称为链接名称，该名称绑定到上下文中的原子名称。
LinkRef(String) - Constructor for class javax.naming. LinkRef
构造一个字符串名称的LinkRef。
LinkRef(Name) - Constructor for class javax.naming. LinkRef
为一个名称构造一个LinkRef。
linkRemainingName - Variable in exception javax.naming. LinkException
包含尚未解决的剩余链接名称。
LinkRequest - Interface in jdk.dynalink.linker
表示在特定呼叫站点链接特定调用的请求。
linkResolvedName - Variable in exception javax.naming. LinkException
包含已成功解决的链接部分。
linkResolvedObj - Variable in exception javax.naming. LinkException
包含链接部分的分辨率成功的对象。
linkSize(int, Component...) - Method in class javax.swing. GroupLayout
强制指定的组件沿指定的轴具有相同的大小，而不管其首选，最小或最大尺寸。
linkSize(Component...) - Method in class javax.swing. GroupLayout
强制指定的组件具有相同的大小，无论其首选，最小或最大大小如何。
LinkStyle - Interface in org.w3c.dom.stylesheets
LinkStyle接口提供了一种机制，通过该机制，可以从负责将其链接到文档的节点检索样式表。
LinkTree - Interface in com.sun.source.doctree
@link或@linkplain内联标记的树形节点。
list - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
list - Variable in class javax.swing.plaf.basic. BasicListUI
实例 JList 。
list() - Static method in class com.sun.tools.attach. VirtualMachine
返回Java虚拟机的列表。
list() - Method in class java.awt. Component
将此组件的列表打印到标准系统输出流 System.out 。
list() - Method in class java.io. File
返回一个字符串数组，命名由此抽象路径名表示的目录中的文件和目录。
list() - Method in interface java.lang.module. ModuleReader
列出模块的内容，返回作为模块中所有资源名称的元素流。
list() - Method in class java.lang. ThreadGroup
将有关此线程组的信息打印到标准输出。
list() - Method in interface java.nio.file.attribute. UserDefinedFileAttributeView
返回包含用户定义属性名称的列表。
list() - Method in interface java.rmi.registry. Registry
返回在此注册表中绑定的名称的数组。
list() - Method in class javax.smartcardio. CardTerminals
返回所有可用终端的不可修改列表。
list(int, BindingListHolder, BindingIteratorHolder) - Method in class org.omg.CosNaming. _NamingContextExtStub
列表操作允许客户端在命名上下文中遍历一组绑定。
list(int, BindingListHolder, BindingIteratorHolder) - Method in class org.omg.CosNaming. _NamingContextStub
列表操作允许客户端在命名上下文中遍历一组绑定。
list(int, BindingListHolder, BindingIteratorHolder) - Method in interface org.omg.CosNaming. NamingContextOperations
列表操作允许客户端在命名上下文中遍历一组绑定。
list(FilenameFilter) - Method in class java.io. File
返回一个字符串数组，命名由此抽象路径名表示的目录中满足指定过滤器的文件和目录。
list(PrintStream) - Method in class java.awt. Component
将此组件的列表打印到指定的输出流。
list(PrintStream) - Method in class java.util. Properties
将此属性列表打印到指定的输出流。
list(PrintStream, int) - Method in class java.awt. Component
从指定的缩进开始列出指定的打印流的列表。
list(PrintStream, int) - Method in class java.awt. Container
将此容器的列表打印到指定的输出流。
list(PrintWriter) - Method in class java.awt. Component
将列表打印到指定的打印作者。
list(PrintWriter) - Method in class java.util. Properties
将此属性列表打印到指定的输出流。
list(PrintWriter, int) - Method in class java.awt. Component
从指定的缩进开始列出指定的打印作者的列表。
list(PrintWriter, int) - Method in class java.awt. Container
从指定的缩进开始列出指定的打印作者的列表。
list(String) - Static method in class java.rmi. Naming
返回在注册表中绑定的名称的数组。
list(String) - Method in interface javax.naming. Context
枚举在命名上下文中绑定的名称以及绑定到它们的对象的类名。
list(String) - Method in class javax.naming. InitialContext
list(Path) - Static method in class java.nio.file. Files
返回一个懒惰的填充 Stream ，其元素是目录中的条目。
list(Enumeration<T>) - Static method in class java.util. Collections
返回一个数组列表，其中包含由枚举返回的顺序由指定的枚举返回的元素。
list(Name) - Method in interface javax.naming. Context
枚举在命名上下文中绑定的名称以及绑定到它们的对象的类名。
list(Name) - Method in class javax.naming. InitialContext
list(CardTerminals.State) - Method in class javax.smartcardio. CardTerminals
返回与指定状态匹配的所有终端的不可修改列表。
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - Method in class javax.tools. ForwardingJavaFileManager
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - Method in interface javax.tools. JavaFileManager
列出与给定的面向对象位置匹配的所有文件对象。
List - Class in java.awt
List组件向用户显示文本项目的滚动列表。
List< E> - Interface in java.util
有序集合（也称为 序列 ）。
List() - Constructor for class java.awt. List
创建一个新的滚动列表。
List(int) - Constructor for class java.awt. List
创建一个以指定数量的可见行初始化的新滚动列表。
List(int, boolean) - Constructor for class java.awt. List
创建一个初始化的新滚动列表，以显示指定的行数。
LIST - Static variable in class javax.accessibility. AccessibleRole
向对象呈现对象的列表，并允许用户选择一个或多个对象。
LIST - Static variable in class javax.swing.plaf.synth. Region
列表区域。
LIST_DESELECT - Static variable in class java.awt. Event
已过时。
列表中的项目已被取消选择。
LIST_DIRECTORY - Static variable in enum java.nio.file.attribute. AclEntryPermission
列出目录的条目的权限（等于 AclEntryPermission.READ_DATA ）
list_initial_services() - Method in class org.omg.CORBA. ORB
返回最初可用的CORBA对象引用的列表，例如“NameService”和“InterfaceRepository”。
LIST_ITEM - javafx.scene. AccessibleRole
列出项目角色。
LIST_ITEM - Static variable in class javax.accessibility. AccessibleRole
在列表中呈现元素的对象。
LIST_SELECT - Static variable in class java.awt. Event
已过时。
已选择列表中的项目。
LIST_STYLE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“list-style”。
LIST_STYLE_IMAGE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“list-style-image”。
LIST_STYLE_POSITION - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“list-style-position”。
LIST_STYLE_TYPE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“list-style-type”。
LIST_VIEW - javafx.scene. AccessibleRole
列表视图角色。
List.AccessibleAWTList - Class in java.awt
这个类实现 List类的可访问性支持。
List.AccessibleAWTList.AccessibleAWTListChild - Class in java.awt
此类实现对List子项的可访问性支持。
ListBinding< E> - Class in javafx.beans.binding
提供实现ObservableList的Binding所需的大部分功能的基类。
ListBinding() - Constructor for class javafx.beans.binding. ListBinding
listBindings(String) - Method in interface javax.naming. Context
枚举在命名上下文中绑定的名称以及绑定到它们的对象。
listBindings(String) - Method in class javax.naming. InitialContext
listBindings(Name) - Method in interface javax.naming. Context
枚举在命名上下文中绑定的名称以及绑定到它们的对象。
listBindings(Name) - Method in class javax.naming. InitialContext
listBox - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
此列表用于在组合框中绘制当前项。
listBox - Variable in class javax.swing.plaf.metal. MetalComboBoxButton
实例 JList 。
ListCell< T> - Class in javafx.scene.control
Cell类型中使用的ListView实例。
ListCell() - Constructor for class javafx.scene.control. ListCell
使用默认样式类“list-cell”创建默认的ListCell。
ListCellRenderer< E> - Interface in javax.swing
识别可以用作“橡皮图章”来绘制JList中的单元格的组件。
ListCellSkin< T> - Class in javafx.scene.control.skin
默认皮肤实现为ListCell控件。
ListCellSkin(ListCell<T>) - Constructor for class javafx.scene.control.skin. ListCellSkin
创建一个新的ListCellSkin实例，将必要的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
ListChangeListener< E> - Interface in javafx.collections
接收ObservableList更改通知的接口。
ListChangeListener.Change< E> - Class in javafx.collections
表示对Observablelist进行的更改的报告。
LISTDATA - Static variable in class com.sun.java.accessibility.util. EventID
映射到Swing ListData支持（即ListDataListener和ListDataEvent）
ListDataEvent - Class in javax.swing.event
定义将更改封装到列表的事件。
ListDataEvent(Object, int, int, int) - Constructor for class javax.swing.event. ListDataEvent
构造一个ListDataEvent对象。
ListDataHandler() - Constructor for class javax.swing.plaf.basic. BasicComboBoxUI.ListDataHandler
ListDataHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.ListDataHandler
ListDataHandler() - Constructor for class javax.swing.plaf.basic. BasicListUI.ListDataHandler
listDataListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
此保护字段是实现特定的。
listDataListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
listDataListener - Variable in class javax.swing.plaf.basic. BasicListUI
ListDataListener ，附于 JList 。
ListDataListener - Interface in javax.swing.event
的ListDataListener
ListEditor(JSpinner) - Constructor for class javax.swing. JSpinner.ListEditor
构造一个 JSpinner编辑器，支持显示和编辑一个 SpinnerListModel的值，具有 JFormattedTextField 。
listen(int) - Method in class java.net. SocketImpl
将传入连接指示（请求连接）的最大队列长度设置为 count参数。
Listener() - Constructor for class javax.xml.bind. Marshaller.Listener
Listener() - Constructor for class javax.xml.bind. Unmarshaller.Listener
listenerList - Static variable in class com.sun.java.accessibility.util. AccessibilityEventMonitor
目前已注册的PropertyChangeListener课程名单。
listenerList - Variable in class com.sun.java.accessibility.util. AccessibilityListenerList
侦听器类型列表，侦听器对
listenerList - Static variable in class com.sun.java.accessibility.util. SwingEventMonitor
其他类注册的所有听众的主列表。
listenerList - Variable in class javax.swing. AbstractCellEditor
听众列表。
listenerList - Variable in class javax.swing. AbstractListModel
听众列表。
listenerList - Variable in class javax.swing. AbstractSpinnerModel
此模型的ChangeListeners列表。
listenerList - Variable in class javax.swing.colorchooser. DefaultColorSelectionModel
听众列表。
listenerList - Variable in class javax.swing. DefaultBoundedRangeModel
听众等待模型更改。
listenerList - Variable in class javax.swing. DefaultButtonModel
在这个模型上存储听众。
listenerList - Variable in class javax.swing. DefaultListSelectionModel
听众列表。
listenerList - Variable in class javax.swing. DefaultSingleSelectionModel
收集注册听众
listenerList - Variable in class javax.swing.event. EventListenerList
ListenerType - Listener对的列表
listenerList - Variable in class javax.swing. JComponent
此组件的事件侦听器的列表。
listenerList - Variable in class javax.swing. MenuSelectionManager
收集注册听众
listenerList - Variable in class javax.swing.table. AbstractTableModel
听众列表
listenerList - Variable in class javax.swing.table. DefaultTableColumnModel
TableColumnModelListener列表
listenerList - Variable in class javax.swing.text. AbstractDocument
文档的事件监听器列表。
listenerList - Variable in class javax.swing.text. DefaultCaret
事件侦听器列表。
listenerList - Variable in class javax.swing.text. StyleContext.NamedStyle
模型的变化监听器。
listenerList - Variable in class javax.swing. Timer
收集注册听众
listenerList - Variable in class javax.swing.tree. DefaultTreeModel
听众。
listenerList - Variable in class javax.swing.tree. DefaultTreeSelectionModel
事件侦听器列表。
ListenerNotFoundException - Exception in javax.management
存储库中不存在指定的MBean侦听器。
ListenerNotFoundException() - Constructor for exception javax.management. ListenerNotFoundException
默认构造函数。
ListenerNotFoundException(String) - Constructor for exception javax.management. ListenerNotFoundException
允许指定特定错误消息的构造方法。
listeners - Variable in class javax.swing.undo. UndoableEditSupport
听众列表。
ListeningConnector - Interface in com.sun.jdi.connect
侦听由目标虚拟机启动的连接的连接器。
listeningConnectors() - Method in interface com.sun.jdi. VirtualMachineManager
返回已知的ListeningConnector对象的列表。
ListenKey() - Constructor for class com.sun.jdi.connect.spi. TransportService.ListenKey
listExpression(ObservableListValue<E>) - Static method in class javafx.beans.binding. ListExpression
返回一个ListExpression ，其中包含一个ObservableListValue 。
ListExpression< E> - Class in javafx.beans.binding
ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
ListExpression() - Constructor for class javafx.beans.binding. ListExpression
listFiles() - Method in class java.io. File
返回一个抽象路径名数组，表示由该抽象路径名表示的目录中的文件。
listFiles(FileFilter) - Method in class java.io. File
返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
listFiles(FilenameFilter) - Method in class java.io. File
返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
listIterator() - Method in class java.util. AbstractList
返回列表中的列表迭代器（按适当的顺序）。
listIterator() - Method in class java.util. ArrayList
返回列表中的列表迭代器（按适当的顺序）。
listIterator() - Method in class java.util.concurrent. CopyOnWriteArrayList
返回列表中的列表迭代器（按适当的顺序）。
listIterator() - Method in interface java.util. List
返回列表中的列表迭代器（按适当的顺序）。
listIterator() - Method in class java.util. Vector
返回列表中的列表迭代器（按适当的顺序）。
listIterator() - Method in class javafx.beans.binding. ListExpression
listIterator(int) - Method in class java.util. AbstractList
从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
listIterator(int) - Method in class java.util. AbstractSequentialList
返回列表中的列表迭代器（按适当的顺序）。
listIterator(int) - Method in class java.util. ArrayList
从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
listIterator(int) - Method in class java.util.concurrent. CopyOnWriteArrayList
从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
listIterator(int) - Method in class java.util. LinkedList
从列表中的指定位置开始，返回此列表中元素的列表迭代器（按适当的顺序）。
listIterator(int) - Method in interface java.util. List
从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
listIterator(int) - Method in class java.util. Vector
从列表中的指定位置开始，返回列表中的元素（按正确顺序）的列表迭代器。
listIterator(int) - Method in class javafx.beans.binding. ListExpression
ListIterator< E> - Interface in java.util
用于允许程序员沿任一方向遍历列表的列表的迭代器，在迭代期间修改列表，并获取列表中迭代器的当前位置。
listLocationsForModules(JavaFileManager.Location) - Method in class javax.tools. ForwardingJavaFileManager
listLocationsForModules(JavaFileManager.Location) - Method in interface javax.tools. JavaFileManager
列出面向模块的位置或输出位置中所有模块的位置。
ListModel< E> - Interface in javax.swing
该界面定义了JList使用的方法组件来获取列表中每个单元格的值以及列表的长度。
ListMouseHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.ListMouseHandler
listMouseListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
ListMouseMotionHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.ListMouseMotionHandler
listMouseMotionListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
ListProperty< E> - Class in javafx.beans.property
这个类提供了一个Property的全面实现，包装了一个ObservableList 。
ListProperty() - Constructor for class javafx.beans.property. ListProperty
ListPropertyBase< E> - Class in javafx.beans.property
ListPropertyBase类是包装ObservableList的属性的基类。
ListPropertyBase() - Constructor for class javafx.beans.property. ListPropertyBase
构造函数 ListPropertyBase
ListPropertyBase(ObservableList<E>) - Constructor for class javafx.beans.property. ListPropertyBase
ListPropertyBase的构造 ListPropertyBase 。
listQualifiedNames(String, int) - Method in class jdk.jshell. SourceCodeAnalysis
列出给定代码中简单名称的限定名称，直接指定给定光标位置的左侧。
ListResourceBundle - Class in java.util
ListResourceBundle是一个抽象类 ResourceBundle管理资源，以方便和易于使用的列表区域设置。
ListResourceBundle() - Constructor for class java.util. ListResourceBundle
唯一的构造函数。
listRoots() - Static method in class java.io. File
列出可用的文件系统根。
LISTSELECTION - Static variable in class com.sun.java.accessibility.util. EventID
映射到Swing ListSelection支持（即ListSelectionListener和ListSelectionEvent）
ListSelectionEvent - Class in javax.swing.event
表征选择变化的事件。
ListSelectionEvent(Object, int, int, boolean) - Constructor for class javax.swing.event. ListSelectionEvent
表示 firstIndex和 lastIndex之间的选择状态的变化，包括。
ListSelectionHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.ListSelectionHandler
ListSelectionHandler() - Constructor for class javax.swing.plaf.basic. BasicListUI.ListSelectionHandler
listSelectionListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
listSelectionListener - Variable in class javax.swing.plaf.basic. BasicListUI
ListSelectionListener ，附于 JList 。
ListSelectionListener - Interface in javax.swing.event
列表选择值更改时通知的侦听器。
listSelectionModel - Variable in class javax.swing.tree. DefaultTreeSelectionModel
处理维护列表选择模型。
ListSelectionModel - Interface in javax.swing
该接口表示显示具有稳定索引的值列表的任何组件的选择的当前状态。
ListSpinnerValueFactory(ObservableList<T>) - Constructor for class javafx.scene.control. SpinnerValueFactory.ListSpinnerValueFactory
创建一个ListSpinnerValueFactory的新实例，其中给定的列表用作列表以逐步完成。
ListUI - Class in javax.swing.plaf
JList可插拔的外观和感觉代表。
ListUI() - Constructor for class javax.swing.plaf. ListUI
ListView< T> - Class in javafx.scene.control
ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。
ListView - Class in javax.swing.text.html
显示html列表的视图实现
ListView() - Constructor for class javafx.scene.control. ListView
创建一个默认的ListView，它将显示垂直堆叠的内容。
ListView(ObservableList<T>) - Constructor for class javafx.scene.control. ListView
创建一个默认的ListView，它将堆叠从垂直提供的ObservableList检索的内容。
ListView(Element) - Constructor for class javax.swing.text.html. ListView
创建一个表示列表元素的新视图。
ListView.EditEvent< T> - Class in javafx.scene.control
一个Event子类，专门用于ListView中用于表示编辑相关事件。
listViewIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
列表视图图标
listViewProperty() - Method in class javafx.scene.control. ListCell
与此单元格关联的ListView。
ListViewSkin< T> - Class in javafx.scene.control.skin
默认皮肤实现为ListView控件。
ListViewSkin(ListView<T>) - Constructor for class javafx.scene.control.skin. ListViewSkin
创建一个新的ListViewSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。
listVirtualMachines() - Method in class com.sun.tools.attach.spi. AttachProvider
列出此提供程序已知的Java虚拟机。
LISU - java.lang. Character.UnicodeScript
Unicode脚本“Lisu”。
LISU - Static variable in class java.lang. Character.UnicodeBlock
“Lisu”Unicode字符块的常量。
LITERAL - com.sun.source.doctree. DocTree.Kind
用于实例LiteralTree表示@literal标签。
LITERAL - javax.jws.soap. SOAPBinding.Use
LITERAL - Static variable in class java.util.regex. Pattern
启用模式的文字解析。
LiteralTree - Interface in com.sun.source.doctree
@literal或@code内联标记的树状结点。
LiteralTree - Interface in com.sun.source.tree
一个文字表达式的树结点。
LiteralTree - Interface in jdk.nashorn.api.tree
一个文字表达式的树结点。
LITTLE_ENDIAN - Static variable in class java.nio. ByteOrder
常量表示小端字节顺序。
LIVE_DRAG_MODE - Static variable in class javax.swing. JDesktopPane
表示正在拖动的项目的全部内容应显示在桌面窗格中。
llxProperty() - Method in class javafx.scene.effect. PerspectiveTransform
源的左下角映射到的输出位置的x坐标。
llyProperty() - Method in class javafx.scene.effect. PerspectiveTransform
源的左下角映射到的输出位置的y坐标。
load() - Method in class java.nio. MappedByteBuffer
将此缓冲区的内容加载到物理内存中。
load() - Method in class javafx.fxml. FXMLLoader
从FXML文档加载对象层次结构。
load() - Method in class javax.management.modelmbean. RequiredModelMBean
使用在永久存储中找到的MBean数据来实例化此MBean实例。
load() - Method in interface javax.management. PersistentMBean
使用在持久存储中找到的MBean数据来实例化此MBean实例。
load(InputStream) - Method in class java.security. Provider
从输入流读取属性列表（键和元素对）。
load(InputStream) - Method in class java.util. Properties
从输入字节流读取属性列表（键和元素对）。
load(InputStream) - Method in class javafx.fxml. FXMLLoader
从FXML文档加载对象层次结构。
load(InputStream, char[]) - Method in class java.security. KeyStore
从给定的输入流加载此KeyStore。
load(InputStream, Class<?>) - Method in class javax.swing.plaf.synth. SynthLookAndFeel
载入 SynthStyle将使用的一组 SynthLookAndFeel 。
load(Reader) - Method in class java.util. Properties
以简单的线性格式从输入字符流读取属性列表（关键字和元素对）。
load(Class<S>) - Static method in class java.util. ServiceLoader
使用当前线程的 context class loader为给定的服务类型创建一个新的服务加载器。
load(Class<S>, ClassLoader) - Static method in class java.util. ServiceLoader
为给定的服务创建一个新的服务加载器。
load(ModuleLayer, Class<S>) - Static method in class java.util. ServiceLoader
为给定的服务类型创建新的服务加载器，以便从给定模块层及其祖先的模块加载服务提供者。
load(String) - Method in class java.lang. Runtime
加载由filename参数指定的本机库。
load(String) - Static method in class java.lang. System
加载由filename参数指定的本机库。
load(String) - Method in class javafx.scene.web. WebEngine
将网页加载到此引擎中。
load(URL) - Static method in class javafx.fxml. FXMLLoader
从FXML文档加载对象层次结构。
load(URL) - Method in class javax.swing.plaf.synth. SynthLookAndFeel
加载组 SynthStyle将由本使用的S SynthLookAndFeel 。
load(URL, ResourceBundle) - Static method in class javafx.fxml. FXMLLoader
从FXML文档加载对象层次结构。
load(URL, ResourceBundle, BuilderFactory) - Static method in class javafx.fxml. FXMLLoader
从FXML文档加载对象层次结构。
load(URL, ResourceBundle, BuilderFactory, Callback<Class<?>, Object>) - Static method in class javafx.fxml. FXMLLoader
从FXML文档加载对象层次结构。
load(URL, ResourceBundle, BuilderFactory, Callback<Class<?>, Object>, Charset) - Static method in class javafx.fxml. FXMLLoader
从FXML文档加载对象层次结构。
load(KeyStore.LoadStoreParameter) - Method in class java.security. KeyStore
使用给定的 LoadStoreParameter加载此密钥库。
load(ExecutionControl.ClassBytecodes[]) - Method in class jdk.jshell.execution. DirectExecutionControl
load(ExecutionControl.ClassBytecodes[]) - Method in interface jdk.jshell.execution. LoaderDelegate
尝试加载新类。
load(ExecutionControl.ClassBytecodes[]) - Method in class jdk.jshell.execution. StreamingExecutionControl
load(ExecutionControl.ClassBytecodes[]) - Method in interface jdk.jshell.spi. ExecutionControl
尝试加载新类。
LOAD - Static variable in class java.awt. FileDialog
该常量值表示文件对话窗口的目的是找到要从中读取的文件。
LOAD_FILE - Static variable in class java.awt. Event
已过时。
文件加载事件。
loadAgent(String) - Method in class com.sun.tools.attach. VirtualMachine
加载代理
loadAgent(String, String) - Method in class com.sun.tools.attach. VirtualMachine
加载代理
loadAgentLibrary(String) - Method in class com.sun.tools.attach. VirtualMachine
加载代理库。
loadAgentLibrary(String, String) - Method in class com.sun.tools.attach. VirtualMachine
加载代理库。
loadAgentPath(String) - Method in class com.sun.tools.attach. VirtualMachine
以完整路径名加载本地代理库。
loadAgentPath(String, String) - Method in class com.sun.tools.attach. VirtualMachine
以完整路径名加载本地代理库。
loadAllInstruments(Soundbank) - Method in interface javax.sound.midi. Synthesizer
载入 Synthesizer包含的所有仪器 Soundbank 。
loadBinary(URL) - Static method in class javafx.css. Stylesheet
从输入流加载二进制样式表文件。
loadChildren() - Method in class javax.swing. JTree.DynamicUtilTreeNode
加载孩子基于 childValue 。
loadChildren(ViewFactory) - Method in class javax.swing.text. AsyncBoxView
加载所有的孩子以初始化视图。
loadChildren(ViewFactory) - Method in class javax.swing.text. CompositeView
加载所有的孩子以初始化视图。
loadChildren(ViewFactory) - Method in class javax.swing.text. FlowView
加载所有的孩子以初始化视图。
loadChildren(ViewFactory) - Method in class javax.swing.text. WrappedPlainView
加载所有的孩子以初始化视图。
loadChildren(ViewFactory) - Method in class javax.swing.text. ZoneView
加载所有的孩子以初始化视图。
loadClass(String) - Method in class java.lang. ClassLoader
加载指定的 类别binary name 。
loadClass(String) - Method in interface java.rmi.server. LoaderHandler
已过时。
没有替换
loadClass(String) - Static method in class java.rmi.server. RMIClassLoader
已过时。
替换为loadClass(String,String)方法
loadClass(String) - Static method in class javax.management. DefaultLoaderRepository
已过时。
浏览类加载器列表，并尝试加载所请求的类。
loadClass(String) - Method in interface javax.management.loading. ClassLoaderRepository
通过类加载器列表加载给定的类名。
loadClass(String) - Static method in class javax.management.loading. DefaultLoaderRepository
已过时。
浏览类加载器列表，并尝试加载所请求的类。
loadClass(String, boolean) - Method in class java.lang. ClassLoader
用指定的 binary name加载课程。
loadClass(String, String) - Static method in class java.rmi.server. RMIClassLoader
从代码库URL路径加载一个类。
loadClass(String, String, ClassLoader) - Static method in class java.rmi.server. RMIClassLoader
从代码库URL路径加载类，可选地使用提供的加载程序。
loadClass(String, String, ClassLoader) - Method in class java.rmi.server. RMIClassLoaderSpi
 为贯彻
RMIClassLoader.loadClass(URL,String) ，
RMIClassLoader.loadClass(String,String) ，并
RMIClassLoader.loadClass(String,String,ClassLoader) 。
loadClass(String, String, ClassLoader) - Static method in class javax.rmi.CORBA. Util
返回指定类的类实例。
loadClass(String, String, ClassLoader) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 。
loadClass(String, ClassLoaderRepository) - Method in class javax.management.loading. MLet
加载一个类，使用给定的ClassLoaderRepository如果该类没有在这个MLet的URL中找到。
loadClass(URL, String) - Method in interface java.rmi.server. LoaderHandler
已过时。
没有替换
loadClass(URL, String) - Static method in class java.rmi.server. RMIClassLoader
从代码库URL加载一个类。
loadClassBefore(ClassLoader, String) - Method in interface javax.management.loading. ClassLoaderRepository
通过加载器列表加载给定的类名，停止在给定的类名称。
loadClassWithout(ClassLoader, String) - Static method in class javax.management. DefaultLoaderRepository
已过时。
通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。
loadClassWithout(ClassLoader, String) - Method in interface javax.management.loading. ClassLoaderRepository
通过类加载器列表加载给定的类名，不包括给定的类名。
loadClassWithout(ClassLoader, String) - Static method in class javax.management.loading. DefaultLoaderRepository
已过时。
通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。
loadContent(String) - Method in class javafx.scene.web. WebEngine
直接加载给定的HTML内容。
loadContent(String, String) - Method in class javafx.scene.web. WebEngine
直接载入给定的内容。
loadedChildren - Variable in class javax.swing. JTree.DynamicUtilTreeNode
孩子们已经装满了吗？
LoaderDelegate - Interface in jdk.jshell.execution
此接口指定ExecutionControl的加载特定子集。
LoaderHandler - Interface in java.rmi.server
已过时。
没有替换
LoadException - Exception in javafx.fxml
在加载操作期间遇到错误时抛出。
LoadException() - Constructor for exception javafx.fxml. LoadException
LoadException(String) - Constructor for exception javafx.fxml. LoadException
LoadException(String, Throwable) - Constructor for exception javafx.fxml. LoadException
LoadException(Throwable) - Constructor for exception javafx.fxml. LoadException
loadExtensionPart(URL, String, String[], DownloadServiceListener) - Method in interface javax.jnlp. DownloadService
如果在应用程序的JNLP文件中提到了部件和扩展名，请下载给定扩展的给定部分。
loadExtensionPart(URL, String, String, DownloadServiceListener) - Method in interface javax.jnlp. DownloadService
如果在应用程序的JNLP文件中提到了部分和扩展名，请下载给定扩展的给定部分。
loadFont(InputStream, double) - Static method in class javafx.scene.text. Font
从指定的输入流加载字体资源。
loadFont(String, double) - Static method in class javafx.scene.text. Font
从指定的URL加载字体资源。
loadFonts(InputStream, double) - Static method in class javafx.scene.text. Font
从指定的输入流中加载字体资源。
loadFonts(String, double) - Static method in class javafx.scene.text. Font
从指定的URL加载字体资源。
loadFromXML(InputStream) - Method in class java.util. Properties
将指定输入流中的XML文档表示的所有属性加载到此属性表中。
loadImage(Image) - Method in class javax.swing. ImageIcon
加载图像，仅在加载图像时返回。
loadImage(String) - Method in class java.beans. SimpleBeanInfo
这是一种帮助加载图标图像的实用方法。
LOADING - Static variable in class java.awt. MediaTracker
指示媒体当前正在加载的标志。
loadInstalled(Class<S>) - Static method in class java.util. ServiceLoader
使用 platform class loader为给定的服务类型创建一个新的服务加载程序。
loadInstrument(Instrument) - Method in interface javax.sound.midi. Synthesizer
使特定的仪器可用于合成。
loadInstruments(Soundbank, Patch[]) - Method in interface javax.sound.midi. Synthesizer
从指定的 Soundbank加载指定补丁引用的仪器。
loadKeyBindings(InputMap, Object[]) - Static method in class javax.swing. LookAndFeel
使用指定的绑定填充 InputMap 。
loadKeymap(Keymap, JTextComponent.KeyBinding[], Action[]) - Static method in class javax.swing.text. JTextComponent
用一堆绑定加载键盘映射。
loadLibrary(String) - Method in class java.lang. Runtime
加载由 libname参数指定的本机库。
loadLibrary(String) - Static method in class java.lang. System
加载由 libname参数指定的本机库。
LoadListener - Interface in javafx.fxml
加载侦听器界面。
loadLoadFence() - Static method in class java.lang.invoke. VarHandle
确保栅栏之前的载荷在栅栏后不会被重新排列。
loadPart(String[], DownloadServiceListener) - Method in interface javax.jnlp. DownloadService
如果在应用程序的JNLP文件中提到了这些部分，请下载给定的部分。
loadPart(String, DownloadServiceListener) - Method in interface javax.jnlp. DownloadService
下载给定的部分，如果该部分在应用程序的JNLP文件中被提到。
loadProxyClass(String, String[], ClassLoader) - Static method in class java.rmi.server. RMIClassLoader
加载动态代理类（请参阅Proxy ），该代码类从代码库URL路径中实现一组与给定名称的接口。
loadProxyClass(String, String[], ClassLoader) - Method in class java.rmi.server. RMIClassLoaderSpi
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。
loadResource(URL, String, DownloadServiceListener) - Method in interface javax.jnlp. DownloadService
如果在调用的应用程序JNLP文件中提到资源，请下载给定的资源，是在调用应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
loadRules(Reader, URL) - Method in class javax.swing.text.html. StyleSheet
加载一组以CSS1语法指定的规则。
loadSystemColors(int[]) - Method in class java.awt. Toolkit
填充以当前系统颜色值作为参数提供的整数数组。
loadSystemColors(UIDefaults, String[], boolean) - Method in class javax.swing.plaf.basic. BasicLookAndFeel
填充 table与 name-color对在 systemColors 。
loadType(String) - Static method in class javafx.fxml. FXMLLoader
已过时。
此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
loadType(String, String) - Static method in class javafx.fxml. FXMLLoader
已过时。
此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
LOCAL - javax.lang.model.element. NestingKind
在类型之外的构造中声明的命名类型。
LOCAL_VARIABLE - java.lang.annotation. ElementType
局部变量声明
LOCAL_VARIABLE - javax.lang.model.element. ElementKind
一个局部变量。
localControl(boolean) - Method in interface javax.sound.midi. MidiChannel
打开或关闭本地控制。
localDate() - Static method in class java.time.temporal. TemporalQueries
对于 LocalDate的查询，如果找不到则返回null。
LocalDate - Class in java.time
在ISO- 2007-12-03 ，如 2007-12-03 。
LocalDateStringConverter - Class in javafx.util.converter
StringConverter实现LocalDate值。
LocalDateStringConverter() - Constructor for class javafx.util.converter. LocalDateStringConverter
创建StringConverter为LocalDate值，使用基于默认格式化器和解析器IsoChronology ， FormatStyle.SHORT ，以及用户的Locale 。
LocalDateStringConverter(DateTimeFormatter, DateTimeFormatter) - Constructor for class javafx.util.converter. LocalDateStringConverter
使用提供的格式化程序和解析器为LocalDate值创建{#link StringConverter}。
LocalDateStringConverter(FormatStyle) - Constructor for class javafx.util.converter. LocalDateStringConverter
创建StringConverter为LocalDate值，使用基于默认格式化器和解析器IsoChronology ，指定FormatStyle ，以及用户的Locale 。
LocalDateStringConverter(FormatStyle, Locale, Chronology) - Constructor for class javafx.util.converter. LocalDateStringConverter
创建一个字符串转换LocalDate个使用默认的格式和语法分析器，它会根据所提供的值FormatStyle ， Locale ，并Chronology 。
localDateTime(TemporalAccessor) - Method in interface java.time.chrono. Chronology
从另一个时间对象获取本年龄的本地日期时间。
localDateTime(TemporalAccessor) - Method in class java.time.chrono. HijrahChronology
localDateTime(TemporalAccessor) - Method in class java.time.chrono. IsoChronology
从另一个日期时间对象获取ISO本地日期时间。
localDateTime(TemporalAccessor) - Method in class java.time.chrono. JapaneseChronology
localDateTime(TemporalAccessor) - Method in class java.time.chrono. MinguoChronology
localDateTime(TemporalAccessor) - Method in class java.time.chrono. ThaiBuddhistChronology
LocalDateTime - Class in java.time
在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
LocalDateTimeStringConverter - Class in javafx.util.converter
StringConverter实现LocalDateTime值。
LocalDateTimeStringConverter() - Constructor for class javafx.util.converter. LocalDateTimeStringConverter
创建StringConverter为LocalDateTime值，使用基于默认格式化器和解析器IsoChronology ， FormatStyle.SHORT的日期和时间，以及用户的Locale 。
LocalDateTimeStringConverter(DateTimeFormatter, DateTimeFormatter) - Constructor for class javafx.util.converter. LocalDateTimeStringConverter
使用提供的格式化程序和解析器为LocalDateTime创建一个StringConverter值。
LocalDateTimeStringConverter(FormatStyle, FormatStyle) - Constructor for class javafx.util.converter. LocalDateTimeStringConverter
为LocalDateTime创建一个StringConverter值，使用基于IsoChronology的默认格式化程序和解析器，日期和时间的指定值为FormatStyle ，以及用户的Locale 。
LocalDateTimeStringConverter(FormatStyle, FormatStyle, Locale, Chronology) - Constructor for class javafx.util.converter. LocalDateTimeStringConverter
创建StringConverter为LocalDateTime使用默认格式化器和解析器，其将基于所提供的值FormatStyle个 S， Locale ，和Chronology 。
locale - Variable in class java.beans.beancontext. BeanContextSupport
此BeanContext的当前区域设置。
locale - Variable in class javafx.util.converter. DateTimeStringConverter
locale - Variable in class javax.imageio. ImageReader
目前 Locale用于定位，或 null ;如果没有设置。
locale - Variable in class javax.imageio. ImageWriteParam
A Locale用于本地化压缩类型名称和质量描述，或 null使用默认值 Locale 。
locale - Variable in class javax.imageio. ImageWriter
目前 Locale用于定位，或 null ;如果没有设置。
locale() - Method in class java.util. Formatter
返回通过构建此格式化程序设置的区域设置。
locale() - Method in class java.util. Scanner
返回此扫描仪的区域设置。
locale(Locale) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置区域设置。
Locale - Class in java.util
一个 Locale对象代表一个具体的地理，政治或文化地区。
Locale(String) - Constructor for class java.util. Locale
从语言代码构建语言环境。
Locale(String, String) - Constructor for class java.util. Locale
从语言和国家构建语言环境。
Locale(String, String, String) - Constructor for class java.util. Locale
从语言，国家和变体构建语言环境。
Locale.Builder - Class in java.util
Builder用于从设置器配置的值构建 Locale实例。
Locale.Category - Enum in java.util
枚举地区类别。
Locale.FilteringMode - Enum in java.util
此枚举提供常量来选择区域设置匹配的过滤模式。
Locale.IsoCountryCode - Enum in java.util
用于指定ISO 3166中定义的类型的枚举。
Locale.LanguageRange - Class in java.util
该类表示在 RFC 4647 Matching of Language Tags中定义的 语言范围 。
LocaleNameProvider - Class in java.util.spi
为Locale类提供本地化名称的服务提供商的抽象类。
LocaleNameProvider() - Constructor for class java.util.spi. LocaleNameProvider
唯一的构造函数。
LocaleServiceProvider - Class in java.util.spi
这是所有区域设置敏感的服务提供商接口（SPI）的超类。
LocaleServiceProvider() - Constructor for class java.util.spi. LocaleServiceProvider
初始化新的区域设置服务提供程序。
LocalExecutionControl - Class in jdk.jshell.execution
一个实现的ExecutionControl它在与JShell核心相同的JVM中执行。
LocalExecutionControl() - Constructor for class jdk.jshell.execution. LocalExecutionControl
使用默认的类加载创建一个实例。
LocalExecutionControl(LoaderDelegate) - Constructor for class jdk.jshell.execution. LocalExecutionControl
创建一个实例，将加载器操作委派给指定的委托。
LocalExecutionControlProvider - Class in jdk.jshell.execution
执行引擎的提供者以与JShell相同的方式运行。
LocalExecutionControlProvider() - Constructor for class jdk.jshell.execution. LocalExecutionControlProvider
创建一个实例。
LocalObject - Class in org.omg.CORBA
用作在Java语言映射中实现本地IDL接口的基类。
LocalObject() - Constructor for class org.omg.CORBA. LocalObject
构造一个默认的 LocalObject实例。
localport - Variable in class java.net. SocketImpl
此套接字连接到的本地端口号。
localPort - Variable in class java.net. DatagramSocketImpl
本地端口号。
localTime() - Static method in class java.time.temporal. TemporalQueries
对于 LocalTime的查询，如果找不到， LocalTime返回null。
LocalTime - Class in java.time
在ISO- 10:15:30 ，如 10:15:30 。
LocalTimeStringConverter - Class in javafx.util.converter
StringConverter实现LocalTime值。
LocalTimeStringConverter() - Constructor for class javafx.util.converter. LocalTimeStringConverter
创建StringConverter为LocalTime值，使用默认格式化器和解析器与FormatStyle.SHORT ，和用户的Locale 。
LocalTimeStringConverter(DateTimeFormatter, DateTimeFormatter) - Constructor for class javafx.util.converter. LocalTimeStringConverter
使用提供的格式化程序和解析器为LocalTime值创建一个StringConverter，它们负责选择所需的Locale 。
LocalTimeStringConverter(FormatStyle) - Constructor for class javafx.util.converter. LocalTimeStringConverter
为LocalTime创建一个StringConverter值，使用默认格式化程序和解析器与指定的FormatStyle，并基于用户的Locale 。
LocalTimeStringConverter(FormatStyle, Locale) - Constructor for class javafx.util.converter. LocalTimeStringConverter
为LocalTime创建一个StringConverter值，使用默认格式化程序和解析器与指定的FormatStyle和Locale 。
localToParent(double, double) - Method in class javafx.scene. Node
将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
localToParent(double, double, double) - Method in class javafx.scene. Node
将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
localToParent(Bounds) - Method in class javafx.scene. Node
将此 Node的局部坐标空间的 Node转换为其父节点的坐标空间。
localToParent(Point2D) - Method in class javafx.scene. Node
将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
localToParent(Point3D) - Method in class javafx.scene. Node
将一个点从该 Node的局部坐标空间转换为其父节点的坐标空间。
localToParentTransformProperty() - Method in class javafx.scene. Node
保存计算的本地到父变换的仿射变换。
localToScene(double, double) - Method in class javafx.scene. Node
将一个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
localToScene(double, double, boolean) - Method in class javafx.scene. Node
将一个点从该 Node的局部坐标空间转换为其场景的坐标空间。
localToScene(double, double, double) - Method in class javafx.scene. Node
将这个 Node的局部坐标空间的 Node转换为其场景的坐标空间。
localToScene(double, double, double, boolean) - Method in class javafx.scene. Node
将一个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
localToScene(Bounds) - Method in class javafx.scene. Node
将这个 Node的局部坐标空间的 Node转换为其场景的坐标空间。
localToScene(Bounds, boolean) - Method in class javafx.scene. Node
将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
localToScene(Point2D) - Method in class javafx.scene. Node
将此 Node的局部坐标空间的 Node转换为其场景的坐标空间。
localToScene(Point2D, boolean) - Method in class javafx.scene. Node
将一个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
localToScene(Point3D) - Method in class javafx.scene. Node
将一个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
localToScene(Point3D, boolean) - Method in class javafx.scene. Node
将一个点从这个 Node的局部坐标空间 Node到其场景的坐标空间。
localToSceneTransformProperty() - Method in class javafx.scene. Node
拥有计算的局部到场景变换的仿射变换。
localToScreen(double, double) - Method in class javafx.scene. Node
将一个点从这个Node的局部坐标空间Node到它的Screen的坐标空间。
localToScreen(double, double, double) - Method in class javafx.scene. Node
将一个点从这个Node的局部坐标空间Node到它的Screen的坐标空间。
localToScreen(Bounds) - Method in class javafx.scene. Node
将这个Node的局部坐标空间的边界变换为其Screen的坐标空间。
localToScreen(Point2D) - Method in class javafx.scene. Node
将一个点从该Node的局部坐标空间Node到其Screen的坐标空间。
localToScreen(Point3D) - Method in class javafx.scene. Node
将一个点从这个Node的局部坐标空间Node到它的Screen的坐标空间。
LocalVariable - Interface in com.sun.jdi
目标VM中的局部变量。
Locatable - Interface in com.sun.jdi
一个镜子有一个Location 。
LocatableEvent - Interface in com.sun.jdi.event
具有位置和线程的事件的抽象超界面。
locate(int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由getComponentAt（int，int）替换。
locate(int, int) - Method in class java.awt. Container
已过时。
从JDK 1.1版开始，由getComponentAt(int, int)替代。
LocateRegistry - Class in java.rmi.registry
LocateRegistry用于获取对特定主机（包括本地主机）上的引导远程对象注册表的引用，或用于创建接受特定端口上的调用的远程对象注册表。
location - Variable in exception javax.xml.stream. XMLStreamException
location() - Method in interface com.sun.jdi. Locatable
返回此镜像的Location ，如果有可执行代码与之相关联。
location() - Method in interface com.sun.jdi. 方法
返回此方法的Location ，如果有可执行代码与之相关联。
location() - Method in interface com.sun.jdi.request. BreakpointRequest
返回请求断点的位置。
location() - Method in interface com.sun.jdi. StackFrame
返回帧中当前指令的Location 。
location() - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由getLocation()代替。
location() - Method in class java.lang.module. ModuleReference
如果已知，返回此模块内容的位置。
location(int, int) - Method in class java.awt. GridBagLayout
确定布局网格中的单元格包含由 (x, y)指定的点。
Location - Interface in com.sun.jdi
目标VM的执行代码中的一个点。
Location - Interface in javax.xml.stream
提供有关活动位置的信息。
LOCATION_FORWARD - Interface in org.omg.PortableInterceptor
org / omg / PortableInterceptor / LOCATION_FORWARD.java。
LOCATION_KEY - Static variable in class javafx.fxml. FXMLLoader
命名空间地图中位置URL的键。
locationFor(String) - Static method in enum javax.tools. StandardLocation
返回具有给定名称的位置对象。
locationOfCodeIndex(long) - Method in interface com.sun.jdi. 方法
返回给定代码索引的Location 。
locationProperty() - Method in class javafx.scene.web. WebEngine
当前网页的URL。
locationsOfLine(int) - Method in interface com.sun.jdi. 方法
返回包含映射到给定行号的所有Location对象的列表。
locationsOfLine(int) - Method in interface com.sun.jdi. ReferenceType
返回包含映射到给定行号的所有Location对象的列表。
locationsOfLine(String, String, int) - Method in interface com.sun.jdi. 方法
返回包含映射到给定行号和源名称的所有Location对象的列表。
locationsOfLine(String, String, int) - Method in interface com.sun.jdi. ReferenceType
返回包含映射到给定行号的所有Location对象的列表。
locationToIndex(Point) - Method in class javax.swing. JList
返回最接近列表坐标系中给定位置的单元格索引。
locationToIndex(JList<?>, Point) - Method in class javax.swing.plaf.basic. BasicListUI
返回最接近列表坐标系中给定位置的指定的 JList中的单元 JList 。
locationToIndex(JList<?>, Point) - Method in class javax.swing.plaf. ListUI
返回最接近列表坐标系中给定位置的指定的 JList中的单元 JList 。
locationToIndex(JList<?>, Point) - Method in class javax.swing.plaf.multi. MultiListUI
在此对象处理的每个UI上调用 locationToIndex方法。
locator - Variable in class javax.swing.text. AsyncBoxView
管理孩子偏移的对象。
Locator - Interface in org.xml.sax
用于将SAX事件与文档位置相关联的界面。
Locator2 - Interface in org.xml.sax.ext
SAX2扩展增加了通过Locator提供的实体信息。
Locator2Impl - Class in org.xml.sax.ext
SAX2扩展助手用于保存其他实体信息，实现Locator2界面。
Locator2Impl() - Constructor for class org.xml.sax.ext. Locator2Impl
构造一个新的，空的Locator2Impl对象。
Locator2Impl(Locator) - Constructor for class org.xml.sax.ext. Locator2Impl
复制现有的定位器或Locator2对象。
LocatorImpl - Class in org.xml.sax.helpers
提供Locator的可选便利实现。
LocatorImpl() - Constructor for class org.xml.sax.helpers. LocatorImpl
零参数构造函数。
LocatorImpl(Locator) - Constructor for class org.xml.sax.helpers. LocatorImpl
复制构造函数。
locatorsUpdateCopy() - Method in interface java.sql. DatabaseMetaData
指示对LOB进行的更新是在副本上还是直接进行到LOB。
lock - Variable in class java.io. Reader
用于同步此流上的操作的对象。
lock - Variable in class java.io. Writer
用于同步此流上的操作的对象。
lock - Variable in class java.util.prefs. AbstractPreferences
监视器用于锁定此节点的对象。
lock() - Method in class java.nio.channels. AsynchronousFileChannel
获取此通道文件的排他锁。
lock() - Method in class java.nio.channels. FileChannel
获取此通道文件的排他锁。
lock() - Method in interface java.util.concurrent.locks. Lock
获得锁。
lock() - Method in class java.util.concurrent.locks. ReentrantLock
获得锁。
lock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock
获取读锁。
lock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock
获取写锁。
lock(long, long, boolean) - Method in class java.nio.channels. AsynchronousFileChannel
获取此通道文件的给定区域的锁定。
lock(long, long, boolean) - Method in class java.nio.channels. FileChannel
获取此通道文件的给定区域的锁定。
lock(long, long, boolean, A, CompletionHandler<FileLock, ? super A>) - Method in class java.nio.channels. AsynchronousFileChannel
获取此通道文件的给定区域的锁定。
lock(A, CompletionHandler<FileLock, ? super A>) - Method in class java.nio.channels. AsynchronousFileChannel
获取此通道文件的排他锁。
Lock - Interface in java.util.concurrent.locks
Lock实现提供比使用 synchronized方法和语句可以获得的更广泛的锁定操作。
LOCK - java.awt.desktop. UserSessionEvent.Reason
会话已被锁定/解锁。
LockInfo - Class in java.lang.management
有关 锁的信息。
LockInfo(String, int) - Constructor for class java.lang.management. LockInfo
构造一个 LockInfo对象。
lockInterruptibly() - Method in interface java.util.concurrent.locks. Lock
获取锁定，除非当前线程是 interrupted 。
lockInterruptibly() - Method in class java.util.concurrent.locks. ReentrantLock
获取锁定，除非当前线程是 interrupted 。
lockInterruptibly() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock
获取读锁定，除非当前线程是 interrupted 。
lockInterruptibly() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock
获取写锁定，除非当前线程是 interrupted 。
LockSupport - Class in java.util.concurrent.locks
用于创建锁和其他同步类的基本线程阻塞原语。
log(double) - Static method in class java.lang. Math
返回 double值的自然对数（基数 e ）。
log(double) - Static method in class java.lang. StrictMath
返回 double值的自然对数（基数 e ）。
log(String) - Static method in class java.rmi.server. LogStream
已过时。
没有替换
log(System.Logger.Level, Object) - Method in interface java.lang. System.Logger
记录从给定对象生成的消息。
log(System.Logger.Level, String) - Method in interface java.lang. System.Logger
记录消息。
log(System.Logger.Level, String, Object...) - Method in interface java.lang. System.Logger
使用可选参数列表记录消息。
log(System.Logger.Level, String, Throwable) - Method in interface java.lang. System.Logger
记录与给定的可抛弃关联的消息。
log(System.Logger.Level, Supplier<String>) - Method in interface java.lang. System.Logger
记录一个懒惰的提供的消息。
log(System.Logger.Level, Supplier<String>, Throwable) - Method in interface java.lang. System.Logger
记录与给定的可抛物线相关联的延迟提供的消息。
log(System.Logger.Level, ResourceBundle, String, Object...) - Method in interface java.lang. System.Logger
使用资源束和可选的参数列表记录消息。
log(System.Logger.Level, ResourceBundle, String, Throwable) - Method in interface java.lang. System.Logger
记录与给定的可抛物线相关联的本地化消息。
log(Level, String) - Method in class java.util.logging. Logger
记录消息，没有参数。
log(Level, String, Object) - Method in class java.util.logging. Logger
使用一个对象参数记录消息。
log(Level, String, Object[]) - Method in class java.util.logging. Logger
用一个对象参数数组记录消息。
log(Level, String, Throwable) - Method in class java.util.logging. Logger
使用相关联的Throwable信息记录消息。
log(Level, Throwable, Supplier<String>) - Method in class java.util.logging. Logger
记录一个懒惰构造的消息，并附带相关的Throwable信息。
log(Level, Supplier<String>) - Method in class java.util.logging. Logger
记录一条消息，只有在日志记录级别实际上记录该消息时才会被构造。
log(LogRecord) - Method in class java.util.logging. Logger
登录LogRecord。
LOG_OPTION - Static variable in class javax.swing. DebugGraphics
记录图形操作。
log10(double) - Static method in class java.lang. Math
返回值为 double的基数10对数。
log10(double) - Static method in class java.lang. StrictMath
返回 double值的基数10对数。
log1p(double) - Static method in class java.lang. Math
返回参数和1的和的自然对数。
log1p(double) - Static method in class java.lang. StrictMath
返回参数和1的和的自然对数。
LOGARITHMIC_BACKOFF_STRATEGY - Static variable in class javafx.concurrent. ScheduledService
backoffStrategy属性的回调实现将在失败的情况下对数地 backoffStrategy重新执行之间的时间段。
Logger - Class in java.util.logging
Logger对象用于记录特定系统或应用程序组件的消息。
Logger(String, String) - Constructor for class java.util.logging. Logger
构建命名子系统的记录器的受保护方法。
LoggerFinder() - Constructor for class java.lang. System.LoggerFinder
创建一个新的实例 LoggerFinder 。
LOGGING_MXBEAN_NAME - Static variable in class java.util.logging. LogManager
ObjectName用于日志记录工具的管理界面的字符串表示。
LoggingMXBean - Interface in java.util.logging
已过时。
LoggingMXBean不再是platform MXBean ，而是用PlatformLoggingMXBean替代。 它不会在平台上注册MBeanServer 。 改用ManagementFactory.getPlatformMXBean(PlatformLoggingMXBean.class) 。
LoggingPermission - Class in java.util.logging
当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。
LoggingPermission(String, String) - Constructor for class java.util.logging. LoggingPermission
创建一个新的LoggingPermission对象。
LOGICAL - javafx.scene.text. TextBoundsType
使用逻辑边界作为计算边界的依据。
LOGICAL_COMPLEMENT - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表逻辑补运算符! 。
LOGICAL_COMPLEMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表逻辑补运算符! 。
LOGICAL_STYLE_ACTION - Static variable in class javax.swing.text.html. HTMLEditorKit
逻辑样式选择动作标识符逻辑样式作为参数传入
LOGICAL_VERTICAL_CENTER - javafx.scene.text. TextBoundsType
使用逻辑垂直居中边界作为计算边界的依据。
logicalAnd(boolean, boolean) - Static method in class java.lang. Boolean
返回将逻辑AND运算符应用于指定的 boolean操作数的结果。
LogicalHandler< C extends LogicalMessageContext> - Interface in javax.xml.ws.handler
LogicalHandler扩展了Handler，为消息上下文参数提供了类型化。
LogicalMessage - Interface in javax.xml.ws
LogicalMessage接口表示协议不可知的XML消息，并且包含提供对消息的有效载荷的访问的方法。
LogicalMessageContext - Interface in javax.xml.ws.handler
LogicalMessageContext接口扩展了 MessageContext以提供对包含的消息的访问作为协议中性逻辑消息
logicalOr(boolean, boolean) - Static method in class java.lang. Boolean
返回将逻辑OR运算符应用于指定的 boolean操作数的结果。
logicalXor(boolean, boolean) - Static method in class java.lang. Boolean
返回将逻辑XOR运算符应用于指定的 boolean操作数的结果。
login() - Method in class com.sun.security.auth.module. JndiLoginModule
提示用户名和密码。
login() - Method in class com.sun.security.auth.module. KeyStoreLoginModule
验证用户。
login() - Method in class com.sun.security.auth.module. Krb5LoginModule
验证用户
login() - Method in class com.sun.security.auth.module. LdapLoginModule
开始用户认证。
login() - Method in class com.sun.security.auth.module. NTLoginModule
导入底层NT系统身份信息。
login() - Method in class com.sun.security.auth.module. SolarisLoginModule
已过时。
验证用户（第一阶段）。
login() - Method in class com.sun.security.auth.module. UnixLoginModule
验证用户（第一阶段）。
login() - Method in class javax.security.auth.login. LoginContext
执行认证。
login() - Method in interface javax.security.auth.spi. LoginModule
验证 Subject （第1阶段）的方法。
login(Subject, CallbackHandler) - Method in class java.security. AuthProvider
登录此提供商。
LoginContext - Class in javax.security.auth.login
LoginContext类描述了用于验证主题的基本方法，并提供了一种独立于基础身份验证技术开发应用程序的方法。
LoginContext(String) - Constructor for class javax.security.auth.login. LoginContext
使用名称实例化一个新的 LoginContext对象。
LoginContext(String, CallbackHandler) - Constructor for class javax.security.auth.login. LoginContext
实例化一个新的 LoginContext的名称和一个对象 CallbackHandler对象。
LoginContext(String, Subject) - Constructor for class javax.security.auth.login. LoginContext
实例化一个新的 LoginContext的名称和一个对象 Subject对象。
LoginContext(String, Subject, CallbackHandler) - Constructor for class javax.security.auth.login. LoginContext
实例化一个新的 LoginContext对象，名称为 Subject ，需要验证，以及一个 CallbackHandler对象。
LoginContext(String, Subject, CallbackHandler, Configuration) - Constructor for class javax.security.auth.login. LoginContext
实例化一个新的 LoginContext对象，名称为 Subject ，需要验证， CallbackHandler对象和登录名 Configuration 。
LoginException - Exception in javax.security.auth.login
这是基本的登录异常。
LoginException() - Constructor for exception javax.security.auth.login. LoginException
构造一个没有详细消息的LoginException。
LoginException(String) - Constructor for exception javax.security.auth.login. LoginException
构造一个具有指定的详细消息的LoginException。
LoginModule - Interface in javax.security.auth.spi
用于认证技术提供商的服务提供者接口。
LogManager - Class in java.util.logging
有一个全局LogManager对象用于维护关于日志记录器和日志服务的一组共享状态。
LogManager() - Constructor for class java.util.logging. LogManager
受保护的构造函数。
logout() - Method in class com.sun.security.auth.module. JndiLoginModule
注销用户。
logout() - Method in class com.sun.security.auth.module. KeyStoreLoginModule
注销用户。
logout() - Method in class com.sun.security.auth.module. Krb5LoginModule
注销用户。
logout() - Method in class com.sun.security.auth.module. LdapLoginModule
注销用户。
logout() - Method in class com.sun.security.auth.module. NTLoginModule
注销用户。
logout() - Method in class com.sun.security.auth.module. SolarisLoginModule
已过时。
注销用户
logout() - Method in class com.sun.security.auth.module. UnixLoginModule
注销用户
logout() - Method in class java.security. AuthProvider
从此提供商注销。
logout() - Method in class javax.security.auth.login. LoginContext
退出 Subject 。
logout() - Method in interface javax.security.auth.spi. LoginModule
注销 Subject 。
logp(Level, String, String, String) - Method in class java.util.logging. Logger
记录消息，指定源类和方法，没有参数。
logp(Level, String, String, String, Object) - Method in class java.util.logging. Logger
使用单个对象参数记录消息，指定源类和方法到日志消息。
logp(Level, String, String, String, Object[]) - Method in class java.util.logging. Logger
使用对象参数数组记录消息，指定源类和方法。
logp(Level, String, String, String, Throwable) - Method in class java.util.logging. Logger
使用相关联的Throwable信息记录消息，指定源类和方法。
logp(Level, String, String, Throwable, Supplier<String>) - Method in class java.util.logging. Logger
记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。
logp(Level, String, String, Supplier<String>) - Method in class java.util.logging. Logger
记录一个延迟构造的消息，指定源类和方法，没有参数。
logrb(Level, String, String, String, String) - Method in class java.util.logging. Logger
已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
logrb(Level, String, String, String, String, Object) - Method in class java.util.logging. Logger
已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)
logrb(Level, String, String, String, String, Object[]) - Method in class java.util.logging. Logger
已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
logrb(Level, String, String, String, String, Throwable) - Method in class java.util.logging. Logger
已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。
logrb(Level, String, String, ResourceBundle, String, Object...) - Method in class java.util.logging. Logger
使用可选的消息参数列表记录消息，指定源类，方法和资源包。
logrb(Level, String, String, ResourceBundle, String, Throwable) - Method in class java.util.logging. Logger
使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
logrb(Level, ResourceBundle, String, Object...) - Method in class java.util.logging. Logger
使用可选的消息参数列表记录消息，指定源类，方法和资源包。
logrb(Level, ResourceBundle, String, Throwable) - Method in class java.util.logging. Logger
使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
LogRecord - Class in java.util.logging
LogRecord对象用于在日志框架和各个日志处理程序之间传递日志请求。
LogRecord(Level, String) - Constructor for class java.util.logging. LogRecord
使用给定的级别和消息值构造LogRecord。
logStream() - Static method in class javax.swing. DebugGraphics
返回DebugGraphics记录绘图操作的流。
LogStream - Class in java.rmi.server
已过时。
没有替换
Long - Class in java.lang
Long类包装一个对象中的基元类型 long的值。
Long(long) - Constructor for class java.lang. Long
已过时。
很少使用这个构造函数。 静态工厂Long.valueOf(long)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
Long(String) - Constructor for class java.lang. Long
已过时。
很少使用这个构造函数。 使用Long.parseLong(String)将字符串转换为long原语，或使用Long.valueOf(String)将字符串转换为Long对象。
LONG - java.time.format. FormatStyle
长文字风格，有很多细节。
LONG - javax.lang.model.type. TypeKind
原始类型 long 。
LONG - Static variable in class java.text. DateFormat
恒久的长款式。
LONG - Static variable in class java.util. Calendar
一个样式说明符 getDisplayName和 getDisplayNames相当于 Calendar.LONG_FORMAT 。
LONG - Static variable in class java.util. TimeZone
getDisplayName()的样式说明符，表示长名称，如“太平洋标准时间”。
LONG - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.lang.Long值的 SimpleType实例。
LONG_DESCRIPTION - Static variable in interface javax.swing. Action
用于存储更长的 String描述的关键字可用于上下文相关帮助。
LONG_FORMAT - Static variable in class java.util. Calendar
getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的长名称。
LONG_LITERAL - com.sun.source.tree. Tree.Kind
用于表示long类型的整数字面值表达式的long 。
LONG_STANDALONE - Static variable in class java.util. Calendar
getDisplayName和 getDisplayNames的样式说明 符 ，表示独立使用的长名称，例如月份名称作为日历标题。
LongAccumulator - Class in java.util.concurrent.atomic
一个或多个变量一起保持正在运行的 long值，使用提供的函数进行更新。
LongAccumulator(LongBinaryOperator, long) - Constructor for class java.util.concurrent.atomic. LongAccumulator
使用给定的累加器函数和identity元素创建一个新的实例。
LongAdder - Class in java.util.concurrent.atomic
一个或多个变量一起保持初始为零 long 。
LongAdder() - Constructor for class java.util.concurrent.atomic. LongAdder
创建一个新的加法器，初始和为零。
LongBinaryOperator - Interface in java.util.function
代表对两个 long操作数的操作，并产生一个 long结果。
LongBinding - Class in javafx.beans.binding
提供实现long值Binding所需的大部分功能的基类。
LongBinding() - Constructor for class javafx.beans.binding. LongBinding
longBitsToDouble(long) - Static method in class java.lang. Double
返回与给定位表示对应的 double值。
LongBuffer - Class in java.nio
一个长缓冲区。
LongConsumer - Interface in java.util.function
表示接受单个 long参数的操作，并且不返回任何结果。
longExpression(ObservableLongValue) - Static method in class javafx.beans.binding. LongExpression
返回一个LongExpression ，其中包含一个ObservableLongValue 。
longExpression(ObservableValue<T>) - Static method in class javafx.beans.binding. LongExpression
返回一个LongExpression的LongExpression 。
LongExpression - Class in javafx.beans.binding
LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。
LongExpression() - Constructor for class javafx.beans.binding. LongExpression
LongFunction< R> - Interface in java.util.function
表示接受长期参数并产生结果的函数。
LongHolder - Class in org.omg.CORBA
持有人 Long 。
LongHolder() - Constructor for class org.omg.CORBA. LongHolder
构造一个新的 LongHolder对象，其 value字段初始化为 0 。
LongHolder(long) - Constructor for class org.omg.CORBA. LongHolder
构造一个新的 LongHolder对象，其 value字段初始化为给定的 long 。
LONGITUDE_REF_EAST - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。
LONGITUDE_REF_WEST - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。
LongLongSeqHelper - Class in org.omg.CORBA
助手 LongLongSeq 。
LongLongSeqHelper() - Constructor for class org.omg.CORBA. LongLongSeqHelper
LongLongSeqHolder - Class in org.omg.CORBA
持有人 LongLongSeq 。
LongLongSeqHolder() - Constructor for class org.omg.CORBA. LongLongSeqHolder
LongLongSeqHolder(long[]) - Constructor for class org.omg.CORBA. LongLongSeqHolder
LONGNVARCHAR - java.sql. JDBCType
标识通用SQL类型 LONGNVARCHAR 。
LONGNVARCHAR - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 LONGNVARCHAR 。
LongPredicate - Interface in java.util.function
表示一个 long值参数的谓词（布尔值函数）。
longProperty(Property<Long>) - Static method in class javafx.beans.property. LongProperty
返回一个LongProperty ，它包装一个Property ，并且双向绑定到它。
LongProperty - Class in javafx.beans.property
这个类定义了一个270457595456333包装long值。
LongProperty() - Constructor for class javafx.beans.property. LongProperty
LongPropertyBase - Class in javafx.beans.property
LongPropertyBase类是包装 long值的属性的基类。
LongPropertyBase() - Constructor for class javafx.beans.property. LongPropertyBase
LongPropertyBase的构造 LongPropertyBase 。
LongPropertyBase(long) - Constructor for class javafx.beans.property. LongPropertyBase
LongPropertyBase的构造 LongPropertyBase 。
longs() - Method in class java.util.concurrent. ThreadLocalRandom
返回一个有效的无限流的伪随机数 long值。
longs() - Method in class java.util. Random
返回一个有效的无限流的伪随机数 long值。
longs() - Method in class java.util. SplittableRandom
从这个发生器返回一个有效的无限流的伪随机数 long值，和/或从其中分离出一个值。
longs(long) - Method in class java.util.concurrent. ThreadLocalRandom
返回一个流，产生给定的 streamSize数量的伪随机数 long值。
longs(long) - Method in class java.util. Random
返回一个流，产生给定的 streamSize数量的伪随机数 long值。
longs(long) - Method in class java.util. SplittableRandom
返回一个流，产生给定的 streamSize数量的伪随机数 long值来自该发生器和/或从其分离。
longs(long, long) - Method in class java.util.concurrent. ThreadLocalRandom
返回一个有效无限流的伪随机数 long ，每个值都符合给定的起始（包括）和绑定（排他）。
longs(long, long) - Method in class java.util. Random
返回一个有效的无限流的伪随机数 long ，每个符合给定的起始（包括）和绑定（排除）。
longs(long, long) - Method in class java.util. SplittableRandom
从这个发生器返回一个有效的无限流的伪随机数long值，和/或从它分离一个; 每个值符合给定的起始（包括）和绑定（排他）。
longs(long, long, long) - Method in class java.util.concurrent. ThreadLocalRandom
返回一个流，产生给定的 streamSize伪随机数 long ，每个符合给定的起始（包括）和绑定（排他）。
longs(long, long, long) - Method in class java.util. Random
返回产生所述给定流 streamSize数的伪随机的 long ，每个符合给定的原点（含）和结合（不包括）。
longs(long, long, long) - Method in class java.util. SplittableRandom
返回一个流，产生给定的streamSize个伪随机数， long值来自该发生器和/或从它分离出一个值; 每个值符合给定的起始（包括）和绑定（排他）。
LongSeqHelper - Class in org.omg.CORBA
助手 LongSeqHelper 。
LongSeqHelper() - Constructor for class org.omg.CORBA. LongSeqHelper
LongSeqHolder - Class in org.omg.CORBA
持有人 LongSeq 。
LongSeqHolder() - Constructor for class org.omg.CORBA. LongSeqHolder
LongSeqHolder(int[]) - Constructor for class org.omg.CORBA. LongSeqHolder
longStream(Supplier<? extends Spliterator.OfLong>, int, boolean) - Static method in class java.util.stream. StreamSupport
创建一个新的顺序或并行 LongStream从 Supplier的 Spliterator.OfLong 。
longStream(Spliterator.OfLong, boolean) - Static method in class java.util.stream. StreamSupport
创建一个新的串行或并行 LongStream从 Spliterator.OfLong 。
LongStream - Interface in java.util.stream
支持顺序和并行聚合操作的原始长值元素序列。
LongStream.Builder - Interface in java.util.stream
一个可变的构建器，用于 LongStream 。
LongStringConverter - Class in javafx.util.converter
StringConverter实现Long （和长基元）值。
LongStringConverter() - Constructor for class javafx.util.converter. LongStringConverter
LongSummaryStatistics - Class in java.util
统计数据的收集状态，如count，min，max，sum和average。
LongSummaryStatistics() - Constructor for class java.util. LongSummaryStatistics
构造一个零实例，零计数，零和， Long.MAX_VALUE分，最大和零平均值 Long.MIN_VALUE 。
LongSupplier - Interface in java.util.function
代表 long结果。
LongToDoubleFunction - Interface in java.util.function
表示接受长期参数并产生双值结果的函数。
LongToIntFunction - Interface in java.util.function
表示接受长值参数并产生int值结果的函数。
LongType - Interface in com.sun.jdi
在目标VM中访问的所有原语 long值的类型。
LongUnaryOperator - Interface in java.util.function
表示对单个 long值操作数的操作，产生一个 long结果。
longValue() - Method in interface com.sun.jdi. PrimitiveValue
将此值转换为LongValue，并将结果返回为长。
longValue() - Method in class com.sun.security.auth. SolarisNumericGroupPrincipal
已过时。
返回这个 SolarisNumericGroupPrincipal的用户组标识号（GID）长。
longValue() - Method in class com.sun.security.auth. SolarisNumericUserPrincipal
已过时。
返回这个 SolarisNumericUserPrincipal的用户标识号（UID）长。
longValue() - Method in class com.sun.security.auth. UnixNumericGroupPrincipal
返回这个 UnixNumericGroupPrincipal的用户组标识号（GID）长。
longValue() - Method in class com.sun.security.auth. UnixNumericUserPrincipal
返回这个 UnixNumericUserPrincipal的用户标识号（UID）长。
longValue() - Method in class java.lang. Byte
返回此值 Byte为 long一个宽元转换后。
longValue() - Method in class java.lang. Double
返回此值 Double为 long的基本收缩转换后。
longValue() - Method in class java.lang. Float
在缩小原始转换后，将此 Float值作为 long返回。
longValue() - Method in class java.lang. Integer
返回此值 Integer为 long一个宽元转换后。
longValue() - Method in class java.lang. Long
返回此值 Long为 long值。
longValue() - Method in class java.lang. Number
返回指定数字的值作为 long 。
longValue() - Method in class java.lang. Short
返回此值 Short为 long一个宽元转换后。
longValue() - Method in class java.math. BigDecimal
将此 BigDecimal转换为 long 。
longValue() - Method in class java.math. BigInteger
将此BigInteger转换为 long 。
longValue() - Method in class java.util.concurrent.atomic. AtomicInteger
返回此的当前值 AtomicInteger作为 long加宽原始转换后，通过规定的，具有记忆效果 VarHandle.getVolatile(java.lang.Object...) 。
longValue() - Method in class java.util.concurrent.atomic. AtomicLong
将此 AtomicLong的当前值作为 long ，具有 VarHandle.getVolatile(java.lang.Object...)指定的内存效果。
longValue() - Method in class java.util.concurrent.atomic. DoubleAccumulator
在缩小原始转换后，返回 current value作为 long 。
longValue() - Method in class java.util.concurrent.atomic. DoubleAdder
在缩小原始转换后返回 DoubleAdder.sum()作为 long 。
longValue() - Method in class java.util.concurrent.atomic. LongAccumulator
相当于 LongAccumulator.get() 。
longValue() - Method in class java.util.concurrent.atomic. LongAdder
相当于 LongAdder.sum() 。
longValue() - Method in class javafx.beans.binding. DoubleExpression
longValue() - Method in class javafx.beans.binding. FloatExpression
longValue() - Method in class javafx.beans.binding. IntegerExpression
longValue() - Method in class javafx.beans.binding. LongExpression
longValue() - Method in interface javafx.beans.value. ObservableNumberValue
返回 ObservableNumberValue的值作为 long 。
LongValue - Interface in com.sun.jdi
提供对目标虚拟机 long语 long值的访问。
longValueAt(ObservableList<? extends Number>, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。
longValueAt(ObservableList<? extends Number>, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。
longValueAt(ObservableList<? extends Number>, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。
longValueAt(ObservableMap<K, ? extends Number>, ObservableValue<? extends K>) - Static method in class javafx.beans.binding. Bindings
创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
longValueAt(ObservableMap<K, ? extends Number>, K) - Static method in class javafx.beans.binding. Bindings
创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
longValueExact() - Method in class java.math. BigDecimal
将此 BigDecimal转换为 long ，检查丢失的信息。
longValueExact() - Method in class java.math. BigInteger
将此 BigInteger转换为 long ，检查丢失的信息。
LONGVARBINARY - java.sql. JDBCType
标识通用SQL类型 LONGVARBINARY 。
LONGVARBINARY - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 LONGVARBINARY 。
LONGVARCHAR - java.sql. JDBCType
标识通用SQL类型 LONGVARCHAR 。
LONGVARCHAR - Static variable in class java.sql. Types
Java编程语言中的常量（有时称为类型代码），用于标识通用SQL类型 LONGVARCHAR 。
LookAndFeel - Class in javax.swing
LookAndFeel ，顾名思义，封装外观。
LookAndFeel() - Constructor for class javax.swing. LookAndFeel
LookAndFeelInfo(String, String) - Constructor for class javax.swing. UIManager.LookAndFeelInfo
构造一个 UIManager的 LookAndFeelInfo对象。
lookingAt() - Method in class java.util.regex. Matcher
尝试将输入序列从区域开头开始与模式相匹配。
lookup() - Static method in class java.lang.invoke. MethodHandles
返回一个lookup object，具有完整的功能，可以模拟调用者的所有支持的字节码行为。
lookup(Class<?>) - Static method in class java.io. ObjectStreamClass
找到可以序列化的类的描述符。
lookup(String) - Static method in class java.rmi. Naming
返回与指定的 name相关联的远程对象的引用，存根。
lookup(String) - Method in interface java.rmi.registry. Registry
返回绑定到此注册表中指定的 name的远程引用。
lookup(String) - Method in class javafx.scene.control. TabPane
找到这个 Node ，或第一个子节点，基于给定的CSS选择器。
lookup(String) - Method in class javafx.scene. Node
找到这个 Node ，或第一个子节点，基于给定的CSS选择器。
lookup(String) - Method in class javafx.scene. Parent
lookup(String) - Method in class javafx.scene. Scene
根据指定的CSS选择器查找场景图中的任何节点。
lookup(String) - Static method in class javax.jnlp. ServiceManager
向JNLP客户端询问具有给定名称的服务。
lookup(String) - Method in interface javax.jnlp. ServiceManagerStub
参见 ServiceManager.lookup(java.lang.String)的说明
lookup(String) - Method in interface javax.naming. Context
检索命名对象。
lookup(String) - Method in class javax.naming. InitialContext
lookup(List<Locale.LanguageRange>, Collection<Locale>) - Static method in class java.util. Locale
使用RFC 4647中定义的查找机制返回 Locale最佳匹配语言标记的实例。
lookup(Name) - Method in interface javax.naming. Context
检索命名对象。
lookup(Name) - Method in class javax.naming. InitialContext
Lookup - Class in jdk.dynalink.linker.support
一个封装MethodHandles.Lookup ，掩盖了检查的异常。
Lookup(MethodHandles.Lookup) - Constructor for class jdk.dynalink.linker.support. Lookup
创建一个新实例，绑定到一个MethodHandles.Lookup的实例。
lookup_value_factory(String) - Method in class org.omg.CORBA_2_3. ORB
lookupAll(String) - Method in class javafx.scene.control. TabPane
查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。
lookupAll(String) - Method in class javafx.scene. Node
查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。
lookupAny(Class<?>) - Static method in class java.io. ObjectStreamClass
返回任何类的描述符，无论是否实现Serializable 。
lookupButton(ButtonType) - Method in class javafx.scene.control. DialogPane
该方法提供了开发人员可以为给定的ButtonType检索实际节点（假设它是button types列表的一部分）的方式。
lookupClass() - Method in class java.lang.invoke. MethodHandles.Lookup
告诉哪个类执行查找。
lookupConstraints(Component) - Method in class java.awt. GridBagLayout
检索指定组件的约束。
lookupDefaultPrintService() - Static method in class javax.print. PrintServiceLookup
找到此环境的默认打印服务。
lookupLink(String) - Method in interface javax.naming. Context
检索命名对象，除了名称的终端原子组件以外的链接。
lookupLink(String) - Method in class javax.naming. InitialContext
lookupLink(Name) - Method in interface javax.naming. Context
检索命名对象，除了名称的终端原子组件以外的链接。
lookupLink(Name) - Method in class javax.naming. InitialContext
lookupMimeType(String) - Static method in class javafx.scene.input. DataFormat
查找之前使用给定的MIME类型创建的DataFormat作为其IDID之一。
lookupModes() - Method in class java.lang.invoke. MethodHandles.Lookup
告诉这个查找对象可以产生哪些访问保护类的成员。
lookupMultiDocPrintServices(DocFlavor[], AttributeSet) - Static method in class javax.print. PrintServiceLookup
找到能够打印包含所有指定文档风格的MultiDoc的MultiDoc打印服务。
lookupNamespaceURI(String) - Method in class javax.imageio.metadata. IIOMetadataNode
这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。
lookupNamespaceURI(String) - Method in interface org.w3c.dom. Node
从该节点开始，查找与给定前缀相关联的命名空间URI。
lookupNamespaceURI(String) - Method in interface org.w3c.dom.xpath. XPathNSResolver
查找与给定名称空间前缀相关联的命名空间URI。
LookupOp - Class in java.awt.image
该类实现从源到目标的查找操作。
LookupOp(LookupTable, RenderingHints) - Constructor for class java.awt.image. LookupOp
给出了一个 LookupOp对象，给出了查找表和一个 RenderingHints对象，可能是 null 。
lookupPixel(byte[], byte[]) - Method in class java.awt.image. ByteLookupTable
返回用查找表翻译的像素数组。
lookupPixel(int[], int[]) - Method in class java.awt.image. ByteLookupTable
返回用查找表翻译的像素数组。
lookupPixel(int[], int[]) - Method in class java.awt.image. LookupTable
返回一个像素的 int组件数组。
lookupPixel(int[], int[]) - Method in class java.awt.image. ShortLookupTable
返回用查找表翻译的像素数组。
lookupPixel(short[], short[]) - Method in class java.awt.image. ShortLookupTable
返回用查找表翻译的像素数组。
lookupPrefix(String) - Method in class javax.imageio.metadata. IIOMetadataNode
IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。
lookupPrefix(String) - Method in interface org.w3c.dom. Node
从该节点开始查找与给定名称空间URI关联的前缀。
lookupPrincipalByGroupName(String) - Method in class java.nio.file.attribute. UserPrincipalLookupService
按组名查找组主体。
lookupPrincipalByName(String) - Method in class java.nio.file.attribute. UserPrincipalLookupService
按名称查找用户主体。
lookupPrintServices() - Static method in class java.awt.print. PrinterJob
查找2D打印服务的便捷方法。
lookupPrintServices(DocFlavor, AttributeSet) - Static method in class javax.print. PrintServiceLookup
找到能打印指定的打印服务DocFlavor 。
lookupProviders(Class<T>) - Static method in class javax.imageio.spi. ServiceRegistry
使用上下文类加载器定位并递增实例化给定服务的可用提供程序。
lookupProviders(Class<T>, ClassLoader) - Static method in class javax.imageio.spi. ServiceRegistry
使用给定的类加载器搜索特定服务类的实现。
lookupStreamPrintServiceFactories(DocFlavor, String) - Static method in class javax.print. StreamPrintServiceFactory
找到可用于打印作业的打印服务的工厂，以 outputMimeType指定的格式输出数据流。
lookupStreamPrintServices(String) - Static method in class java.awt.print. PrinterJob
一种方便的方法，可以定位可以对2D图形进行图像处理的流打印服务的工厂。
LookupTable - Class in java.awt.image
这个抽象类定义了一个查找表对象。
LookupTable(int, int) - Constructor for class java.awt.image. LookupTable
从组件数量和查找表中的偏移量构造一个新的LookupTable。
lookupTag(List<Locale.LanguageRange>, Collection<String>) - Static method in class java.util. Locale
使用RFC 4647中定义的查找机制返回最匹配的语言标签。
loop() - Method in interface java.applet. AudioClip
已过时。
开始循环播放此音频剪辑。
loop(int) - Method in interface javax.sound.sampled. Clip
从当前位置开始循环播放。
loop(MethodHandle[]...) - Static method in class java.lang.invoke. MethodHandles
构造一个表示循环的方法句柄，该循环具有在每次迭代时更新和检查的多个循环变量。
LOOP_CONTINUOUSLY - Static variable in interface javax.sound.midi. Sequencer
一个值，指示循环应该在无限期之后继续，而不是在特定循环数之后完成。
LOOP_CONTINUOUSLY - Static variable in interface javax.sound.sampled. Clip
一个值，指示循环应该在无限期之后继续，而不是在特定循环数之后完成。
LoopTree - Interface in jdk.nashorn.api.tree
一个混合的“循环”语句。
LOST_FOCUS - Static variable in class java.awt. Event
已过时。
一个组件失去了焦点。
lostFocus(Event, Object) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
lostOwnership(Clipboard, Transferable) - Method in interface java.awt.datatransfer. ClipboardOwner
通知此对象不再是剪贴板所有者。
lostOwnership(Clipboard, Transferable) - Method in class java.awt.datatransfer. StringSelection
LOW - javafx.print. PrintQuality
指定低质量打印。
LOW_SURROGATES - Static variable in class java.lang. Character.UnicodeBlock
“低代理”Unicode字符块的常数。
lower(E) - Method in class java.util.concurrent. ConcurrentSkipListSet
lower(E) - Method in interface java.util. NavigableSet
返回这个集合中最大的元素，严格小于给定的元素，如果没有这样的元素，则 null 。
lower(E) - Method in class java.util. TreeSet
LOWER_LEADING_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口的下前缘角。
LOWER_LEFT_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口的左下角。
LOWER_RIGHT_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口右下角。
LOWER_TRAILING_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口的较低后缘角。
lowerBoundProperty() - Method in class javafx.scene.chart. ValueAxis
该轴下限值（最小值）。
LOWERCASE_LETTER - Static variable in class java.lang. Character
Unicode规范中的一般类别“L1”。
lowerCaseMode(boolean) - Method in class java.io. StreamTokenizer
确定字标记是否自动降低。
LOWERED - Static variable in class javax.swing.border. BevelBorder
低斜角型
LOWERED - Static variable in class javax.swing.border. EtchedBorder
降蚀刻型。
lowerEntry(K) - Method in class java.util.concurrent. ConcurrentSkipListMap
返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥，则 null 。
lowerEntry(K) - Method in interface java.util. NavigableMap
返回与最大密钥相关联的密钥值映射严格小于给定密钥，如果没有这样的密钥，则 null 。
lowerEntry(K) - Method in class java.util. TreeMap
lowerKey(K) - Method in class java.util.concurrent. ConcurrentSkipListMap
lowerKey(K) - Method in interface java.util. NavigableMap
返回严格小于给定键的最大键，如果没有这样的键，则返回 null 。
lowerKey(K) - Method in class java.util. TreeMap
lowerLeft - Variable in class javax.swing. JScrollPane
要显示在左下角的组件。
lowerLeft - Variable in class javax.swing. ScrollPaneLayout
要显示在左下角的组件。
lowerRight - Variable in class javax.swing. JScrollPane
要显示在右下角的组件。
lowerRight - Variable in class javax.swing. ScrollPaneLayout
要显示在右下角的组件。
lowestLayer() - Method in class javax.swing. JLayeredPane
返回所有当前子项的最低层值。
lowestOneBit(int) - Static method in class java.lang. Integer
在指定的 int值中，最低位（最右边）为1位，最多返回一个 int值，最多只有一个1位。
lowestOneBit(long) - Static method in class java.lang. Long
在指定的 long值中，最低位（最右侧）为1位的位置返回 long最多一个单一位的值。
LOWSRC - Static variable in class javax.swing.text.html. HTML.Attribute
属性“lowsrc”
lowSurrogate(int) - Static method in class java.lang. Character
返回尾随替代（一个 low surrogate code unit所述的） surrogate pair表示在UTF-16编码指定的补充的字符（Unicode代码点）。
lrxProperty() - Method in class javafx.scene.effect. PerspectiveTransform
源映射到其右下角的输出位置的x坐标。
lryProperty() - Method in class javafx.scene.effect. PerspectiveTransform
映射源的右下角的输出位置的y坐标。
LSException - Exception in org.w3c.dom.ls
如果处理停止，解析器或写入操作可能会抛出 LSException 。
LSException(short, String) - Constructor for exception org.w3c.dom.ls. LSException
LSInput - Interface in org.w3c.dom.ls
此接口表示数据的输入源。
LSLoadEvent - Interface in org.w3c.dom.ls
该接口表示负载事件对象，用于表示文档加载的完成。
LSOutput - Interface in org.w3c.dom.ls
该接口表示数据的输出目的地。
LSParser - Interface in org.w3c.dom.ls
能够从各种输入源构建或增加DOM树的对象的接口。
LSParserFilter - Interface in org.w3c.dom.ls
LSParserFilter提供应用程序在分析时正在构造时检查节点的能力。
LSProgressEvent - Interface in org.w3c.dom.ls
此接口表示一个进度事件对象，该对象在解析文档时通知应用程序进度。
LSResourceResolver - Interface in org.w3c.dom.ls
LSResourceResolver提供了一种应用程序将引用重定向到外部资源的方法。
LSSerializer - Interface in org.w3c.dom.ls
A LSSerializer提供了将DOM文档序列化（写入）到XML中的API。
LSSerializerFilter - Interface in org.w3c.dom.ls
LSSerializerFilter为应用程序提供了检查节点的序列化能力，并决定哪些节点应该被序列化。
lt(File, File) - Method in class javax.swing.plaf.basic. BasicDirectoryModel
已过时 - 未使用
lt(ValueExp, ValueExp) - Static method in class javax.management. Query
返回一个对两个值表示“小于”约束的查询表达式。
LT - Static variable in class javax.management. Query
代表 Query.lt(javax.management.ValueExp, javax.management.ValueExp)查询的代码。
LYCIAN - java.lang. Character.UnicodeScript
Unicode脚本“Lycian”。
LYCIAN - Static variable in class java.lang. Character.UnicodeBlock
“Lycian”Unicode字符块的常数。
LYDIAN - java.lang. Character.UnicodeScript
Unicode脚本“Lydian”。
LYDIAN - Static variable in class java.lang. Character.UnicodeBlock
常数为“Lydian”Unicode字符块。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


M-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

M

M - javafx.scene.input. KeyCode
常数为 M键。
Mac - Class in javax.crypto
该类提供了“消息验证码”（MAC）算法的功能。
Mac(MacSpi, Provider, String) - Constructor for class javax.crypto. Mac
创建MAC对象。
MAC - java.security. CryptoPrimitive
对称原语：消息认证码
MacSpi - Class in javax.crypto
该类定义了 Mac类的 （ SPI ）。
MacSpi() - Constructor for class javax.crypto. MacSpi
magenta - Static variable in class java.awt. Color
颜色洋红色。
MAGENTA - Static variable in class java.awt. Color
颜色洋红色。
MAGENTA - Static variable in class javafx.scene.paint. Color
颜色洋红色，RGB值为＃FF00FF
magnitude() - Method in class javafx.geometry. Point2D
计算由该实例表示的相对幅度向量的幅度（长度）。
magnitude() - Method in class javafx.geometry. Point3D
计算由该实例表示的相对幅度向量的幅度（长度）。
MAHAJANI - java.lang. Character.UnicodeScript
Unicode脚本“Mahajani”。
MAHAJANI - Static variable in class java.lang. Character.UnicodeBlock
“Mahajani”Unicode字符块的常数。
MAHJONG_TILES - Static variable in class java.lang. Character.UnicodeBlock
“麻将瓷砖”Unicode字符块的常数。
mail() - Method in class java.awt. Desktop
启动用户默认邮件客户端的邮件组合窗口。
mail(URI) - Method in class java.awt. Desktop
启动用户默认邮件客户端的邮件组合窗口，填写由 mailto: URI指定的邮件字段。
MAIL - java.awt. Desktop.Action
代表“邮件”动作。
MailcapCommandMap - Class in javax.activation
MailcapCommandMap扩展了CommandMap抽象类。
MailcapCommandMap() - Constructor for class javax.activation. MailcapCommandMap
默认构造函数。
MailcapCommandMap(InputStream) - Constructor for class javax.activation. MailcapCommandMap
构造函数允许调用者指定一个包含mailcap文件的 InputStream 。
MailcapCommandMap(String) - Constructor for class javax.activation. MailcapCommandMap
构造函数允许调用者指定 mailcap文件的路径。
main(String[]) - Static method in class com.sun.tools.javac. Main
发射器的主入口点。
main(String...) - Static method in class com.sun.tools.javadoc. Main
已过时。
命令行界面。
main(String[]) - Static method in class jdk.jshell.execution. RemoteExecutionControl
启动代理，通过命令行参数指定的套接字连接到JShell核心。
Main - Class in com.sun.tools.javac
Java编程语言编译器javac的遗留编程接口。
Main - Class in com.sun.tools.javadoc
已过时。
此类现在已被弃用，可能会在将来的版本中删除。 有关替换功能，请参阅javax.tools.ToolProvider::getSystemDocumentationTool和javax.tools.DocumentationTool 。
Main() - Constructor for class com.sun.tools.javac. Main
MAIN - Static variable in class javafx.print. PaperSource
指定选择MAIN纸盘。
MAIN - Static variable in class javax.print.attribute.standard. MediaTray
打印机中的主进纸盒。
MAIN_CLASS - Static variable in class java.util.jar. Attributes.Name
Name对象用于启动打包在JAR文件中的应用程序的 Main-Class清单属性。
MAIN_UIROLE - Static variable in class javax.print. ServiceUIFactory
表示执行正常最终用户角色的UI。
mainClass() - Method in class java.lang.module. ModuleDescriptor
返回模块主类。
mainClass(String) - Method in class java.lang.module. ModuleDescriptor.Builder
设置模块主类。
major() - Method in class java.lang. Runtime.Version
返回 major版本号。
major_version - Variable in class org.omg.IOP. Encoding
这种编码格式的主要版本。
majorInterfaceVersion() - Method in interface com.sun.jdi. VirtualMachineManager
返回JDI界面的主版本号。
majorRequirementChange(AsyncBoxView.ChildState, float) - Method in class javax.swing.text. AsyncBoxView
要求沿主轴变化。
majorTickSpacing - Variable in class javax.swing. JSlider
主要刻度线之间的值的数量 - 分解小刻度线的较大的标记。
majorTickUnitProperty() - Method in class javafx.scene.control. Slider
主要刻度线之间的单位距离。
majorVersion() - Method in interface com.sun.jdi. ReferenceType
返回类主要版本号，如Java虚拟机规范的类文件格式所定义。
make_object(String, byte[]) - Method in interface org.omg.PortableInterceptor. ObjectReferenceFactory
make_object根据此模板中的数据，使用给定的存储库ID和对象ID创建CORBA对象引用。
makeBounds(double, double, double, double) - Method in class java.awt.geom. Arc2D.Double
构造一个适合精度的 Rectangle2D ，以将计算的参数保存为该弧的框架矩形。
makeBounds(double, double, double, double) - Method in class java.awt.geom. Arc2D.Float
构造一个适合精度的 Rectangle2D ，以将计算的参数保持为该弧的框架矩形。
makeBounds(double, double, double, double) - Method in class java.awt.geom. Arc2D
构造一个适合精度的 Rectangle2D ，以将计算的参数保持为该弧的框架矩形。
makeClient(String, Subject) - Method in class javax.management.remote.rmi. RMIIIOPServerImpl
已过时。
makeClient(String, Subject) - Method in class javax.management.remote.rmi. RMIJRMPServerImpl
创建一个新的客户端连接作为通过JRMP导出的RMI对象。
makeClient(String, Subject) - Method in class javax.management.remote.rmi. RMIServerImpl
创建一个新的客户端连接。
makeComponentInputMap(JComponent, Object[]) - Static method in class javax.swing. LookAndFeel
创建 ComponentInputMapUIResource从 keys 。
makeConcat(MethodHandles.Lookup, String, MethodType) - Static method in class java.lang.invoke. StringConcatFactory
促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
makeConcatWithConstants(MethodHandles.Lookup, String, MethodType, String, Object...) - Static method in class java.lang.invoke. StringConcatFactory
促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
makeIcon(Class<?>, String) - Static method in class javax.swing. LookAndFeel
创建并返回加载图像的 UIDefault.LazyValue 。
makeInputMap(Object[]) - Static method in class javax.swing. LookAndFeel
创建一个 InputMapUIResource从 keys 。
makeKeyBindings(Object[]) - Static method in class javax.swing. LookAndFeel
方便构建 KeyBindings数组的 KeyBindings 。
makeParser() - Static method in class org.xml.sax.helpers. ParserFactory
已过时。
使用`org.xml.sax.parser'系统属性创建一个新的SAX解析器。
makeParser(String) - Static method in class org.xml.sax.helpers. ParserFactory
已过时。
使用提供的类名创建一个新的SAX解析器对象。
makeSynchronizedFunction(Object, Object) - Static method in class jdk.nashorn.api.scripting. ScriptUtils
创建一个调用包装函数 func上同步 sync或者，如果是不确定的， self 。
makeTag(Element) - Method in class javax.swing.text.html.parser. Parser
创建一个TagElement。
makeTag(Element, boolean) - Method in class javax.swing.text.html.parser. Parser
创建一个TagElement。
makeVisible(int) - Method in class java.awt. List
使指定索引处的项目可见。
makeVisible(TreePath) - Method in class javax.swing. JTree
确保通过路径识别的节点当前是可见的。
MALAYALAM - java.awt.font. NumericShaper.Range
马拉雅拉姆岛的马拉雅拉姆数字。
MALAYALAM - java.lang. Character.UnicodeScript
Unicode脚本“马拉雅拉姆”。
MALAYALAM - Static variable in class java.awt.font. NumericShaper
标识MALAYALAM范围和十进制基数。
MALAYALAM - Static variable in class java.lang. Character.UnicodeBlock
“马拉雅拉姆”Unicode字符块的常量。
malformedForLength(int) - Static method in class java.nio.charset. CoderResult
静态工厂方法返回描述给定长度的格式错误的唯一对象。
malformedInputAction() - Method in class java.nio.charset. CharsetDecoder
返回此解码器当前的格式输入错误的操作。
malformedInputAction() - Method in class java.nio.charset. CharsetEncoder
返回此编码器当前针对格式错误输入错误的操作。
MalformedInputException - Exception in java.nio.charset
当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
MalformedInputException(int) - Constructor for exception java.nio.charset. MalformedInputException
构造一个给定长度的 MalformedInputException 。
MalformedLinkException - Exception in javax.naming
当解决或构建链接时遇到格式错误的链接时抛出此异常。
MalformedLinkException() - Constructor for exception javax.naming. MalformedLinkException
构造一个新的Malformed LinkException实例。
MalformedLinkException(String) - Constructor for exception javax.naming. MalformedLinkException
构造一个新的MalformedLinkException实例，并给出解释。
MalformedObjectNameException - Exception in javax.management
字符串的格式不对应于有效的ObjectName。
MalformedObjectNameException() - Constructor for exception javax.management. MalformedObjectNameException
默认构造函数。
MalformedObjectNameException(String) - Constructor for exception javax.management. MalformedObjectNameException
允许指定特定错误消息的构造方法。
MalformedParameterizedTypeException - Exception in java.lang.reflect
当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。
MalformedParameterizedTypeException() - Constructor for exception java.lang.reflect. MalformedParameterizedTypeException
MalformedParametersException - Exception in java.lang.reflect
当 the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。
MalformedParametersException() - Constructor for exception java.lang.reflect. MalformedParametersException
创建一个空的原因 MalformedParametersException 。
MalformedParametersException(String) - Constructor for exception java.lang.reflect. MalformedParametersException
创建一个 MalformedParametersException 。
MalformedURLException - Exception in java.net
抛出以表示发生格式不正确的网址。
MalformedURLException() - Constructor for exception java.net. MalformedURLException
构造一个 MalformedURLException ，没有详细信息。
MalformedURLException(String) - Constructor for exception java.net. MalformedURLException
构造具有指定详细消息的 MalformedURLException 。
managedBlock(ForkJoinPool.ManagedBlocker) - Static method in class java.util.concurrent. ForkJoinPool
运行给定的可能的阻止任务。
managedProperty() - Method in class javafx.scene. Node
定义该节点的布局是否由父节点管理。
MANAGEMENT - com.sun.management. VMOption.Origin
虚拟机启动后，通过管理界面设置VM选项。
ManagementFactory - Class in java.lang.management
ManagementFactory类是用于获取Java平台的托管Bean的工厂类。
ManagementPermission - Class in java.lang.management
当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。
ManagementPermission(String) - Constructor for class java.lang.management. ManagementPermission
构造具有指定名称的ManagementPermission。
ManagementPermission(String, String) - Constructor for class java.lang.management. ManagementPermission
构造一个新的ManagementPermission对象。
manager_id() - Method in interface org.omg.PortableInterceptor. IORInfoOperations
返回刚刚创建的对象适配器的适配器管理器ID，并运行IOR拦截器。
ManageReferralControl - Class in javax.naming.ldap
请求将引用和其他特殊LDAP对象作为普通LDAP对象进行操作。
ManageReferralControl() - Constructor for class javax.naming.ldap. ManageReferralControl
构建关键的ManageReferral控件。
ManageReferralControl(boolean) - Constructor for class javax.naming.ldap. ManageReferralControl
构建一个ManageReferral控件。
ManagerFactoryParameters - Interface in javax.net.ssl
此类是向KeyManagerFactory或TrustManagerFactory提供特定于算法的信息的基本界面。
MANAGES_DESCENDANTS - Static variable in class javax.accessibility. AccessibleState
表示此对象负责管理其子组件。
MANDAIC - java.lang. Character.UnicodeScript
Unicode脚本“Mandaic”。
MANDAIC - Static variable in class java.lang. Character.UnicodeBlock
常数为“Mandaic”Unicode字符块。
MANDATED - java.lang.module. ModuleDescriptor.Exports.Modifier
导出在模块声明的来源中被隐式声明。
MANDATED - java.lang.module. ModuleDescriptor.Modifier
该模块被隐式声明。
MANDATED - java.lang.module. ModuleDescriptor.Opens.Modifier
开放包被隐式声明在模块声明的源中。
MANDATED - java.lang.module. ModuleDescriptor.Requires.Modifier
依赖性在模块声明的来源中被隐式声明。
MANDATED - javax.lang.model.util. Elements.Origin
一个强制的构造是在源代码中没有明确声明的，但它的存在是由规范强制的。
MANDATORY_WARNING - javax.tools. Diagnostic.Kind
类似于警告的问题，但是由工具规范强制执行。
MANDATORY_WARNING - jdk.nashorn.api.tree. Diagnostic.Kind
类似于警告的问题，但是由工具规范强制执行。
MANICHAEAN - java.lang. Character.UnicodeScript
Unicode脚本“Manichaean”。
MANICHAEAN - Static variable in class java.lang. Character.UnicodeBlock
“Manichaean”Unicode字符块的常量。
Manifest - Class in java.util.jar
Manifest类用于维护清单条目名称及其相关属性。
Manifest - Interface in javax.xml.crypto.dsig
在 Manifest中定义的XML Manifest元素的 表示 。
Manifest() - Constructor for class java.util.jar. Manifest
构建一个新的，空的清单。
Manifest(InputStream) - Constructor for class java.util.jar. Manifest
从指定的输入流构造一个新的清单。
Manifest(Manifest) - Constructor for class java.util.jar. Manifest
构造一个新的清单，它是指定的清单的副本。
MANIFEST_NAME - Static variable in class java.util.jar. JarFile
JAR清单文件名。
MANIFEST_VERSION - Static variable in class java.util.jar. Attributes.Name
Name对象为 Manifest-Version清单属性。
MANUAL - Static variable in class javafx.print. PaperSource
指定选择手动纸盘。
MANUAL - Static variable in class javax.print.attribute.standard. MediaTray
打印机中的手动进纸盘。
map - Variable in class java.util.jar. Attributes
属性名称 - 值映射。
map() - Method in interface jdk.incubator.http. HttpHeaders
返回此HttpHeaders的不可修改的多Map视图。
map(FileChannel.MapMode, long, long) - Method in class java.nio.channels. FileChannel
将此频道文件的区域直接映射到内存中。
map(DoubleUnaryOperator) - Method in interface java.util.stream. DoubleStream
返回由给定函数应用于此流的元素的结果组成的流。
map(Function<? super T, ? extends R>) - Method in interface java.util.stream. Stream
返回由给定函数应用于此流的元素的结果组成的流。
map(Function<? super T, ? extends U>) - Method in class java.util. Optional
如果存在一个值，则返回一个 Optional描述（如果由 Optional.ofNullable(T) ）将给定的映射函数应用于该值的结果，否则返回一个空的 Optional 。
map(IntUnaryOperator) - Method in interface java.util.stream. IntStream
返回由给定函数应用于此流的元素的结果组成的流。
map(LongUnaryOperator) - Method in interface java.util.stream. LongStream
返回由给定函数应用于此流的元素的结果组成的流。
Map< K, V> - Interface in java.util
将键映射到值的对象。
MAP - Static variable in class javax.swing.text.html. HTML.Tag
标签<map>
MAP_EXTENDED_RANGES - java.util. Locale.FilteringMode
指定基本过滤：如果任何扩展语言范围包含在给定的语言优先级列表中，它们将映射到基本语言范围。
Map.Entry< K, V> - Interface in java.util
地图条目（键值对）。
MapBinding< K, V> - Class in javafx.beans.binding
提供实现ObservableMap的270457297273636所需的大部分功能的基类。
MapBinding() - Constructor for class javafx.beans.binding. MapBinding
MapChangeListener< K, V> - Interface in javafx.collections
接收到ObservableMap更改通知的接口。
MapChangeListener.Change< K, V> - Class in javafx.collections
对ObservableMap做一个基本的改动。
mapDataProperty() - Method in class javafx.scene.effect. DisplacementMap
这个 Effect的地图数据。
mapEquivalents(List<Locale.LanguageRange>, Map<String, List<String>>) - Static method in class java.util. Locale.LanguageRange
使用给定的 priorityList和 map生成新的自定义语言优先级列表。
mapExpression(ObservableMapValue<K, V>) - Static method in class javafx.beans.binding. MapExpression
返回一个MapExpression ，其中包含一个ObservableMapValue 。
MapExpression< K, V> - Class in javafx.beans.binding
MapExpression是一个ObservableMapValue，另外还有一个方便的方法来生成流畅的绑定。
MapExpression() - Constructor for class javafx.beans.binding. MapExpression
mapInputMethodHighlight(InputMethodHighlight) - Method in class java.awt. Toolkit
返回给定输入法突出显示的抽象级别描述的可视属性映射，如果没有找到映射，则返回null。
mapLibraryName(String) - Static method in class java.lang. System
将库名称映射到表示本地库的平台特定字符串。
MappedByteBuffer - Class in java.nio
直接字节缓冲器，其内容是文件的存储器映射区域。
mapping(Function<? super T, ? extends U>, Collector<? super U, A, R>) - Static method in class java.util.stream. Collectors
适应一个 Collector类型的接受元件 U到类型的一个接受元件 T通过积累前应用映射函数到每个输入元素。
mappingCount() - Method in class java.util.concurrent. ConcurrentHashMap
返回映射数。
MapProperty< K, V> - Class in javafx.beans.property
这个类提供了一个Property的全面实现，包装了一个ObservableMap 。
MapProperty() - Constructor for class javafx.beans.property. MapProperty
MapPropertyBase< K, V> - Class in javafx.beans.property
MapPropertyBase类是包装ObservableMap的属性的基类。
MapPropertyBase() - Constructor for class javafx.beans.property. MapPropertyBase
构造函数 MapPropertyBase
MapPropertyBase(ObservableMap<K, V>) - Constructor for class javafx.beans.property. MapPropertyBase
MapPropertyBase的构造 MapPropertyBase 。
mapRenderContext(int, RenderContext, ParameterBlock, RenderableImage) - Method in interface java.awt.image.renderable. ContextualRenderedImageFactory
将操作的输出RenderContext映射到每个操作源的RenderContext中。
mapSystemException(SystemException) - Static method in class javax.rmi.CORBA. Util
将SystemException映射到RemoteException。
mapSystemException(SystemException) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.mapSystemException(org.omg.CORBA.SystemException) 。
mapToDouble(IntToDoubleFunction) - Method in interface java.util.stream. IntStream
返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
mapToDouble(LongToDoubleFunction) - Method in interface java.util.stream. LongStream
返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
mapToDouble(ToDoubleFunction<? super T>) - Method in interface java.util.stream. Stream
返回一个 DoubleStream其中包含将给定函数应用于此流的元素的结果。
mapToInt(DoubleToIntFunction) - Method in interface java.util.stream. DoubleStream
返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
mapToInt(LongToIntFunction) - Method in interface java.util.stream. LongStream
返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
mapToInt(ToIntFunction<? super T>) - Method in interface java.util.stream. Stream
返回一个 IntStream其中包含将给定函数应用于此流的元素的结果。
mapToLong(DoubleToLongFunction) - Method in interface java.util.stream. DoubleStream
返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
mapToLong(IntToLongFunction) - Method in interface java.util.stream. IntStream
返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
mapToLong(ToLongFunction<? super T>) - Method in interface java.util.stream. Stream
返回一个 LongStream其中包含将给定函数应用于此流的元素的结果。
mapToObj(DoubleFunction<? extends U>) - Method in interface java.util.stream. DoubleStream
返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
mapToObj(IntFunction<? extends U>) - Method in interface java.util.stream. IntStream
返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
mapToObj(LongFunction<? extends U>) - Method in interface java.util.stream. LongStream
返回一个对象值 Stream其中包含将给定函数应用于此流的元素的结果。
MapValueFactory< T> - Class in javafx.scene.control.cell
Callback界面的方便实现，专为TableColumn cell value factory使用而设计。
MapValueFactory(Object) - Constructor for class javafx.scene.control.cell. MapValueFactory
创建默认的MapValueFactory，它将使用提供的键来查找安装此MapValueFactory的TableColumn中的单元格值（通过cell value factory属性）。
MARCH - java.time. Month
3月份的单身人士31天。
MARCH - Static variable in class java.util. Calendar
Calendar.MONTH字段的值表示公历和朱利安日历中的第三个月。
MARCH - Static variable in class javax.xml.datatype. DatatypeConstants
一年的第三个月的价值。
MARGIN - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“margin”。
MARGIN_BOTTOM - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“margin-bottom”。
MARGIN_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按钮边距的变化。
MARGIN_LEFT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“margin-left”。
MARGIN_RIGHT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“margin-right”。
MARGIN_TOP - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“margin-top”。
MarginBorder() - Constructor for class javax.swing.plaf.basic. BasicBorders.MarginBorder
MARGINHEIGHT - Static variable in class javax.swing.text.html. HTML.Attribute
属性“marginheight”
MARGINWIDTH - Static variable in class javax.swing.text.html. HTML.Attribute
属性“marginwidth”
mark - Variable in class java.io. ByteArrayInputStream
流中当前标记的位置。
mark() - Method in class java.nio. Buffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. ByteBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. CharBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. DoubleBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. FloatBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. IntBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. LongBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. MappedByteBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in class java.nio. ShortBuffer
将此缓冲区的标记设置在其位置。
mark() - Method in interface javax.imageio.stream. ImageInputStream
在流中标记要通过后续调用 reset返回的位置。
mark() - Method in class javax.imageio.stream. ImageInputStreamImpl
将当前流位置推送到标记位置的堆栈。
mark(int) - Method in class java.io. BufferedInputStream
见 mark法 InputStream的一般合同。
mark(int) - Method in class java.io. BufferedReader
标记流中的当前位置。
mark(int) - Method in class java.io. ByteArrayInputStream
设置流中当前标记的位置。
mark(int) - Method in class java.io. CharArrayReader
标记流中的当前位置。
mark(int) - Method in class java.io. FilterInputStream
标记此输入流中的当前位置。
mark(int) - Method in class java.io. FilterReader
标记流中的当前位置。
mark(int) - Method in class java.io. InputStream
标记此输入流中的当前位置。
mark(int) - Method in class java.io. LineNumberInputStream
已过时。
标记此输入流中的当前位置。
mark(int) - Method in class java.io. LineNumberReader
标记流中的当前位置。
mark(int) - Method in class java.io. PushbackInputStream
标记此输入流中的当前位置。
mark(int) - Method in class java.io. PushbackReader
标记流中的当前位置。
mark(int) - Method in class java.io. Reader
标记流中的当前位置。
mark(int) - Method in class java.io. StringReader
标记流中的当前位置。
mark(int) - Method in class java.util.zip. DeflaterInputStream
不支持此操作 。
mark(int) - Method in class java.util.zip. InflaterInputStream
标记此输入流中的当前位置。
mark(int) - Method in class javax.sound.sampled. AudioInputStream
标记此音频输入流中的当前位置。
markCompletelyClean(JComponent) - Method in class javax.swing. RepaintManager
标记一个组件完全干净。
markCompletelyDirty(JComponent) - Method in class javax.swing. RepaintManager
标记一个组件完全脏了
markedPos - Variable in class java.io. CharArrayReader
标记在缓冲区中的位置。
MARKER_SUPPLY_EMPTY - Static variable in class javax.print.attribute.standard. PrinterStateReason
该设备至少有一个标记供应品（例如墨粉，墨水，色带）。
MARKER_SUPPLY_LOW - Static variable in class javax.print.attribute.standard. PrinterStateReason
该设备至少有一个标记供应（例如墨粉，墨水，墨带）。
MARKER_WASTE_ALMOST_FULL - Static variable in class javax.print.attribute.standard. PrinterStateReason
设备标记供应废物容器几乎已满。
MARKER_WASTE_FULL - Static variable in class javax.print.attribute.standard. PrinterStateReason
设备标记供应废物容器已满。
markFirstTime(Element) - Method in class javax.swing.text.html.parser. Parser
标记在文档中第一次看到标签
markItemCountDirty() - Method in class javafx.scene.control.skin. VirtualContainerBase
调用此方法来指示应在下一个脉冲上更新项目计数。
marklimit - Variable in class java.io. BufferedInputStream
读取的最大的一个电话后，允许提前 mark后续调用方法之前 reset方法失败。
markpos - Variable in class java.io. BufferedInputStream
pos字段在最后一个 mark方法被调用时的值。
markSupported() - Method in class java.io. BufferedInputStream
测试此输入流是否支持 mark和 reset方法。
markSupported() - Method in class java.io. BufferedReader
告诉这个流是否支持mark（）操作。
markSupported() - Method in class java.io. ByteArrayInputStream
测试 InputStream支持标记/复位。
markSupported() - Method in class java.io. CharArrayReader
告诉这个流是否支持mark（）操作。
markSupported() - Method in class java.io. FilterInputStream
测试此输入流是否支持 mark和 reset方法。
markSupported() - Method in class java.io. FilterReader
告诉这个流是否支持mark（）操作。
markSupported() - Method in class java.io. InputStream
测试此输入流是否支持 mark和 reset方法。
markSupported() - Method in class java.io. PushbackInputStream
测试这个输入流是否支持 mark和 reset方法，而不是。
markSupported() - Method in class java.io. PushbackReader
告诉这个流是否支持mark（）操作，它不是。
markSupported() - Method in class java.io. Reader
告诉这个流是否支持mark（）操作。
markSupported() - Method in class java.io. StringReader
告诉这个流是否支持mark（）操作。
markSupported() - Method in class java.util.zip. DeflaterInputStream
始终返回 false因为此输入流不支持 mark()和 reset()方法。
markSupported() - Method in class java.util.zip. InflaterInputStream
测试此输入流是否支持 mark和 reset方法。
markSupported() - Method in class javax.crypto. CipherInputStream
测试这个输入流是否支持 mark和 reset方法，而不是。
markSupported() - Method in class javax.sound.sampled. AudioInputStream
测试此音频输入流是否支持 mark和 reset方法。
MAROON - Static variable in class javafx.scene.paint. Color
颜色栗色，RGB值为＃800000
marshal(byte[]) - Method in class javax.xml.bind.annotation.adapters. HexBinaryAdapter
marshal(BoundType) - Method in class javax.xml.bind.annotation.adapters. XmlAdapter
将绑定类型转换为值类型。
marshal(ElementT, ValidationEventHandler) - Method in interface javax.xml.bind.annotation. DomHandler
当JAXB提供程序需要将元素编组为XML时，将调用此方法。
marshal(Object, File) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl
marshal(Object, File) - Static method in class javax.xml.bind. JAXB
将Java对象树写入XML并将其存储到指定的位置。
marshal(Object, File) - Method in interface javax.xml.bind. Marshaller
将根据 jaxbElement的内容树 jaxbElement成一个文件。
marshal(Object, OutputStream) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl
marshal(Object, OutputStream) - Static method in class javax.xml.bind. JAXB
将Java对象树写入XML并将其存储到指定的位置。
marshal(Object, OutputStream) - Method in interface javax.xml.bind. Marshaller
将根据 jaxbElement的内容树 jaxbElement组成输出流。
marshal(Object, Writer) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl
marshal(Object, Writer) - Static method in class javax.xml.bind. JAXB
将Java对象树写入XML并将其存储到指定的位置。
marshal(Object, Writer) - Method in interface javax.xml.bind. Marshaller
将根据 jaxbElement的内容树 jaxbElement成一个作家。
marshal(Object, String) - Static method in class javax.xml.bind. JAXB
将Java对象树写入XML并将其存储到指定的位置。
marshal(Object, URI) - Static method in class javax.xml.bind. JAXB
将Java对象树写入XML并将其存储到指定的位置。
marshal(Object, URL) - Static method in class javax.xml.bind. JAXB
将Java对象树写入XML并将其存储到指定的位置。
marshal(Object, XMLEventWriter) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl
marshal(Object, XMLEventWriter) - Method in interface javax.xml.bind. Marshaller
将根据jaxbElement的内容树jaxbElement成一个XMLEventWriter 。
marshal(Object, XMLStreamWriter) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl
marshal(Object, XMLStreamWriter) - Method in interface javax.xml.bind. Marshaller
将基于jaxbElement的内容树jaxbElement成一个XMLStreamWriter 。
marshal(Object, Result) - Static method in class javax.xml.bind. JAXB
将Java对象树写入XML并将其存储到指定的位置。
marshal(Object, Result) - Method in interface javax.xml.bind. Marshaller
将根据 jaxbElement的内容树 jaxbElement到指定的 javax.xml.transform.Result 。
marshal(Object, Node) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl
marshal(Object, Node) - Method in interface javax.xml.bind. Marshaller
将根据 jaxbElement的内容树 jaxbElement到DOM树中。
marshal(Object, ContentHandler) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl
marshal(Object, ContentHandler) - Method in interface javax.xml.bind. Marshaller
将根据 jaxbElement的内容树 jaxbElement成SAX2事件。
marshal(Object, XmlNode) - Method in class javax.xml.bind. Binder
将JAXB对象树编组到新的XML文档。
marshal(String) - Method in class javax.xml.bind.annotation.adapters. CollapsedStringAdapter
无操作。
marshal(String) - Method in class javax.xml.bind.annotation.adapters. NormalizedStringAdapter
无操作。
marshal(XMLStructure, XMLCryptoContext) - Method in interface javax.xml.crypto.dsig.keyinfo. KeyInfo
将关键信息传达给XML。
marshal(DataOutputStream) - Method in interface org.omg.CORBA. CustomMarshal
元帅法必须由定制的元帅班执行。
marshal(Element, ValidationEventHandler) - Method in class javax.xml.bind.annotation. W3CDomHandler
MARSHAL - Exception in org.omg.CORBA
来自网络的请求或回复在结构上是无效的。
MARSHAL() - Constructor for exception org.omg.CORBA. MARSHAL
构造一个 MARSHAL异常，默认的次要代码为0，完成状态为CompletionStatus.COMPLETED_NO和一个空描述。
MARSHAL(int, CompletionStatus) - Constructor for exception org.omg.CORBA. MARSHAL
构造具有指定的次要代码和完成状态的 MARSHAL异常。
MARSHAL(String) - Constructor for exception org.omg.CORBA. MARSHAL
构造一个 MARSHAL异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。
MARSHAL(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. MARSHAL
构造具有指定的描述消息，次要代码和完成状态的 MARSHAL异常。
MarshalException - Exception in java.rmi
如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。
MarshalException - Exception in javax.xml.bind
此异常表示在执行提供程序无法恢复的组织操作时发生错误。
MarshalException - Exception in javax.xml.crypto
表示在XML编组或解组过程中发生的异常情况。
MarshalException() - Constructor for exception javax.xml.crypto. MarshalException
构造一个新的 MarshalException作为其详细信息 null 。
MarshalException(String) - Constructor for exception java.rmi. MarshalException
构造具有指定详细消息的 MarshalException 。
MarshalException(String) - Constructor for exception javax.xml.bind. MarshalException
使用指定的详细消息构造MarshalException。
MarshalException(String) - Constructor for exception javax.xml.crypto. MarshalException
构造一个新的 MarshalException具有指定的详细信息。
MarshalException(String, Exception) - Constructor for exception java.rmi. MarshalException
构造具有指定的详细消息和嵌套异常的 MarshalException 。
MarshalException(String, String) - Constructor for exception javax.xml.bind. MarshalException
构造具有指定的详细消息和供应商特定的错误代码的MarshalException。
MarshalException(String, String, Throwable) - Constructor for exception javax.xml.bind. MarshalException
构造具有指定的详细消息，供应商特定的错误代码和linkedException的MarshalException。
MarshalException(String, Throwable) - Constructor for exception javax.xml.bind. MarshalException
使用指定的详细消息和linkedException构造MarshalException。
MarshalException(String, Throwable) - Constructor for exception javax.xml.crypto. MarshalException
构造一个新的 MarshalException具有指定的详细信息和原因。
MarshalException(Throwable) - Constructor for exception javax.xml.bind. MarshalException
使用linkedException构造MarshalException。
MarshalException(Throwable) - Constructor for exception javax.xml.crypto. MarshalException
构造一个新的 MarshalException具有指定原因和详细信息 (cause==null ? null : cause.toString()) （通常包含类别和详细信息 cause ）。
MarshalledObject< T> - Class in java.rmi
A MarshalledObject包含具有给其构造函数的对象的序列化表示的字节流。
MarshalledObject(T) - Constructor for class java.rmi. MarshalledObject
创建一个新的 MarshalledObject ，其中包含所提供对象的当前状态的序列化表示。
Marshaller - Interface in javax.xml.bind
Marshaller课程负责管理将Java内容树序列化为XML数据的过程。
Marshaller.Listener - Class in javax.xml.bind
使用Marshaller注册此类的实现的实例，以外部监听元帅事件。
marshalParams(XMLStructure, XMLCryptoContext) - Method in class javax.xml.crypto.dsig. TransformService
协调算法特定的参数。
MaskFormatter - Class in javax.swing.text
MaskFormatter用于格式化和编辑字符串。
MaskFormatter() - Constructor for class javax.swing.text. MaskFormatter
创建一个没有掩码的MaskFormatter。
MaskFormatter(String) - Constructor for class javax.swing.text. MaskFormatter
使用指定的掩码创建一个 MaskFormatter 。
maskText(String) - Method in class javafx.scene.control.skin. TextFieldSkin
子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。
maskText(String) - Method in class javafx.scene.control.skin. TextInputControlSkin
子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。
MASTER_GAIN - Static variable in class javax.sound.sampled. FloatControl.Type
代表一条线上整体收益的控制。
match() - Method in class java.util. Scanner
返回此扫描仪执行的最后扫描操作的匹配结果。
match(DataFlavor) - Method in class java.awt.datatransfer. DataFlavor
与 DataFlavor.equals(DataFlavor)相同。
match(String) - Method in class javax.activation. MimeType
确定此对象的主要类型和子类型是否与rawdata中描述的内容类型相同。
match(Certificate) - Method in interface java.security.cert. CertSelector
决定是否选择 Certificate 。
match(Certificate) - Method in class java.security.cert. X509CertSelector
决定是否选择 Certificate 。
match(CRL) - Method in interface java.security.cert. CRLSelector
决定是否选择 CRL 。
match(CRL) - Method in class java.security.cert. X509CRLSelector
决定是否选择 CRL 。
match(KeyEvent) - Method in class javafx.scene.input. KeyCharacterCombination
测试此组合是否与给定的 KeyEvent组合键匹配。
match(KeyEvent) - Method in class javafx.scene.input. KeyCodeCombination
测试此键组合是否与给定的 KeyEvent组合键匹配。
match(KeyEvent) - Method in class javafx.scene.input. KeyCombination
测试此组合是否与给定的 KeyEvent中的组合相匹配。
match(MimeType) - Method in class javax.activation. MimeType
确定此对象的主类型和子类型是否与给定类型中的相同。
match(AttributeValueExp, StringValueExp) - Static method in class javax.management. Query
返回一个表示字符串参数匹配约束的查询表达式。
Match - Class in javafx.css
由Rule使用，以确定选择器是否适用于给定的对象。
matcher(CharSequence) - Method in class java.util.regex. Pattern
创建一个匹配器，匹配给定的输入与此模式。
Matcher - Class in java.util.regex
通过解释Pattern对character sequence执行匹配操作的引擎。
matches() - Method in class java.util.regex. Matcher
尝试将整个区域与模式进行匹配。
matches(String) - Method in class java.lang. String
告诉这个字符串是否匹配给定的 regular expression 。
matches(String, CharSequence) - Static method in class java.util.regex. Pattern
编译给定的正则表达式，并尝试匹配给定的输入。
matches(Path) - Method in interface java.nio.file. PathMatcher
告诉给定路径是否匹配该匹配器的模式。
matches(SNIServerName) - Method in class javax.net.ssl. SNIMatcher
尝试匹配给定的SNIServerName 。
matches(AudioFormat) - Method in class javax.sound.sampled. AudioFormat
指示此格式是否与指定的格式相匹配。
matches(Line.Info) - Method in class javax.sound.sampled. DataLine.Info
确定指定的信息对象是否与此匹配。
matches(Line.Info) - Method in class javax.sound.sampled. Line.Info
指示指定的信息对象是否与此匹配。
matches(Line.Info) - Method in class javax.sound.sampled. Port.Info
指示此信息对象是否与此匹配。
matchesType() - Method in interface jdk.jshell. SourceCodeAnalysis.Suggestion
指示输入连续性是否与目标类型匹配，因此更可能是期望的延续。
matchNameAttribute(AttributeSet, HTML.Tag) - Method in class javax.swing.text.html. HTMLWriter
如果StyleConstants.NameAttribute等于作为参数传入的标签，则返回true。
matchPublic(String) - Method in interface javax.xml.catalog. Catalog
尝试通过publicId在目录中找到匹配的条目。
MatchResult - Interface in java.util.regex
匹配操作的结果。
matchSystem(String) - Method in interface javax.xml.catalog. Catalog
尝试通过systemId在目录中找到匹配的条目。
matchURI(String) - Method in interface javax.xml.catalog. Catalog
尝试通过uri元素在目录中找到匹配的条目。
Material - Class in javafx.scene.paint
用于表示3D表面材质的基类。
Material() - Constructor for class javafx.scene.paint. Material
materialProperty() - Method in class javafx.scene.shape. Shape3D
定义材料 Shape3D 。
Math - Class in java.lang
Math类包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。
MATH_SYMBOL - Static variable in class java.lang. Character
Unicode规范中的通用类别“Sm”。
MathContext - Class in java.math
封装描述数字运算符某些规则的上下文设置的不可变对象，例如由BigDecimal类实现的那些规则。
MathContext(int) - Constructor for class java.math. MathContext
构造新的 MathContext具有指定的精度和 HALF_UP舍入模式。
MathContext(int, RoundingMode) - Constructor for class java.math. MathContext
构造一个新的 MathContext具有指定的精度和舍入模式。
MathContext(String) - Constructor for class java.math. MathContext
从一个字符串构造一个新的 MathContext 。
MATHEMATICAL_ALPHANUMERIC_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
“数学字母数字符号”Unicode字符块的常数。
MATHEMATICAL_OPERATORS - Static variable in class java.lang. Character.UnicodeBlock
常数为“数学运算符”Unicode字符块。
MatrixType - Enum in javafx.scene.transform
指定转换矩阵的类型。
MatteBorder - Class in javax.swing.border
一个提供纯色或平铺图标的无光泽边框的课程。
MatteBorder(int, int, int, int, Color) - Constructor for class javax.swing.border. MatteBorder
创建具有指定插图和颜色的无光泽边框。
MatteBorder(int, int, int, int, Icon) - Constructor for class javax.swing.border. MatteBorder
使用指定的插图和图块图标创建无光泽边框。
MatteBorder(Insets, Color) - Constructor for class javax.swing.border. MatteBorder
创建具有指定插图和颜色的无光泽边框。
MatteBorder(Insets, Icon) - Constructor for class javax.swing.border. MatteBorder
使用指定的插图和图块图标创建无光泽边框。
MatteBorder(Icon) - Constructor for class javax.swing.border. MatteBorder
使用指定的图块图标创建无光泽边框。
MatteBorderUIResource(int, int, int, int, Color) - Constructor for class javax.swing.plaf. BorderUIResource.MatteBorderUIResource
构造一个 MatteBorderUIResource 。
MatteBorderUIResource(int, int, int, int, Icon) - Constructor for class javax.swing.plaf. BorderUIResource.MatteBorderUIResource
构造一个 MatteBorderUIResource 。
MatteBorderUIResource(Icon) - Constructor for class javax.swing.plaf. BorderUIResource.MatteBorderUIResource
构造一个 MatteBorderUIResource 。
max() - Method in interface com.sun.jdi.connect. Connector.IntegerArgument
值的上限。
max() - Method in interface java.util.stream. DoubleStream
返回描述此流的最大元素的 OptionalDouble ，如果此流为空，则返回空的OptionalDouble。
max() - Method in interface java.util.stream. IntStream
返回描述此流的最大元素的 OptionalInt ，如果此流为空，则为空可选。
max() - Method in interface java.util.stream. LongStream
返回描述此流的最大元素的 OptionalLong ，如果此流为空，则返回一个空的可选项。
max(double, double) - Static method in class java.lang. Double
返回两个 double中的较大值，如同通过调用 Math.max一样 。
max(double, double) - Static method in class java.lang. Math
返回两个 double值中的较大值。
max(double, double) - Static method in class java.lang. StrictMath
返回两个 double中的较大值。
max(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最大值和常数值。
max(float, float) - Static method in class java.lang. Float
返回两个 float中的较大值，如同通过调用 Math.max一样 。
max(float, float) - Static method in class java.lang. Math
返回两个 float中的较大值。
max(float, float) - Static method in class java.lang. StrictMath
返回两个 float值中的较大值。
max(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个恒定值。
max(int, int) - Static method in class java.lang. Integer
返回两个 int中的较大值，如同通过调用 Math.max一样 。
max(int, int) - Static method in class java.lang. Math
返回两个 int中的较大值。
max(int, int) - Static method in class java.lang. StrictMath
返回两个 int中的较大值。
max(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个恒定值。
max(long, long) - Static method in class java.lang. Long
返回两个 long中的较大值，如同通过调用 Math.max一样 。
max(long, long) - Static method in class java.lang. Math
返回两个 long值中的较大值。
max(long, long) - Static method in class java.lang. StrictMath
返回两个 long中的较大值。
max(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
max(BigDecimal) - Method in class java.math. BigDecimal
返回此 BigDecimal和 val 。
max(BigInteger) - Method in class java.math. BigInteger
返回此BigInteger的最大值和 val 。
max(Collection<? extends T>) - Static method in class java.util. Collections
根据其元素的 自然顺序返回给定集合的最大元素。
max(Collection<? extends T>, Comparator<? super T>) - Static method in class java.util. Collections
根据指定的比较器引发的顺序返回给定集合的最大元素。
max(Comparator<? super T>) - Method in interface java.util.stream. Stream
根据提供的 Comparator返回此流的最大元素。
max(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，它计算一个ObservableNumberValue的值的最大值和一个恒定值。
max(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
max(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值的最大值和常数值。
max(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最大值和一个恒定值。
max(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue两个实例的值的最大值 。
max(Priority, Priority) - Static method in enum javafx.scene.layout. Priority
回收两个优先级较高的便利方法。
max(Spring, Spring) - Static method in class javax.swing. Spring
返回 max(s1, s2) ：一个弹簧的值始终大于（或等于） s1和 s2的值。
MAX - Static variable in class java.time. Instant
最大支持 Instant ，'1000000000-12-31T23：59：59.999999999Z'。
MAX - Static variable in class java.time. LocalDate
最大支持 LocalDate ，'+ 999999999-12-31'。
MAX - Static variable in class java.time. LocalDateTime
最大支持 LocalDateTime ，'+ 999999999-12-31T23：59：59.999999999'。
MAX - Static variable in class java.time. LocalTime
最大支持 LocalTime ，'23：59：59.999999999'。
MAX - Static variable in class java.time. OffsetDateTime
最大支持 OffsetDateTime ，'+ 999999999-12-31T23：59：59.999999999-18：00'。
MAX - Static variable in class java.time. OffsetTime
最大支持 OffsetTime ，'23：59：59.999999999-18：00'。
MAX - Static variable in class java.time. ZoneOffset
最大支持偏移量的常数。
MAX_BUFFER - Static variable in class javax.security.sasl. Sasl
它指定的字节接收缓冲器的最大大小的属性的名称 SaslClient / SaslServer 。
MAX_CODE_POINT - Static variable in class java.lang. Character
最大值为 Unicode code point ，常数为 U+10FFFF 。
MAX_COUNT - Static variable in class javax.swing.plaf.synth. ColorType
最大数量 ColorType秒。
MAX_DATATYPE - Static variable in class javax.imageio.plugins.tiff. TIFFTag
表示TIFF数据类型的数字最大常数。
MAX_EXPONENT - Static variable in class java.lang. Double
最大指数有限的 double变量可能有。
MAX_EXPONENT - Static variable in class java.lang. Float
最大指数有限的 float变量可能有。
MAX_GAIN - Static variable in class javafx.scene.media. EqualizerBand
最大可能的增益值。
MAX_HIGH_SURROGATE - Static variable in class java.lang. Character
一个 Unicode high-surrogate code unit的最大值在UTF-16编码中，常数为 '\uDBFF' 。
MAX_KEY_LENGTH - Static variable in class java.util.prefs. Preferences
字符串允许的最大长度（80个字符）。
MAX_LOW_SURROGATE - Static variable in class java.lang. Character
一个 Unicode low-surrogate code unit的最大值在UTF-16编码中，常数为 '\uDFFF' 。
MAX_NAME_LENGTH - Static variable in class java.util.prefs. Preferences
节点名称的最大长度（80个字符）。
MAX_NUM_BANDS - Static variable in class javafx.scene.media. AudioEqualizer
AudioEqualizer可能包含的最大频带数。
MAX_PRIORITY - Static variable in class java.lang. Thread
线程可以拥有的最大优先级。
MAX_RADIX - Static variable in class java.lang. Character
用于转换到字符串和从字符串转换的最大基数。
MAX_SCROLL - Static variable in class javax.swing.plaf.basic. BasicSliderUI
最大滚动
MAX_SURROGATE - Static variable in class java.lang. Character
UTF-16编码中的Unicode代理代码单元的最大值，常数为 '\uDFFF' 。
MAX_TIMEZONE_OFFSET - Static variable in class javax.xml.datatype. DatatypeConstants
W3C XML模式最大时区偏移为-14：00。
MAX_VALUE - javafx.scene. AccessibleAttribute
返回节点的最大值。
MAX_VALUE - Static variable in class java.lang. Byte
一个保持最大值一个 byte可以有2 7 -1。
MAX_VALUE - Static variable in class java.lang. Character
该字段的常数值是 char '\uFFFF' 。
MAX_VALUE - Static variable in class java.lang. Double
的常量保持型的最大正的有限值 double ，（2-2 -52）A·2 1023。
MAX_VALUE - Static variable in class java.lang. Float
的常量保持型的最大正的有限值 float ，（2-2 -23）A·2 127。
MAX_VALUE - Static variable in class java.lang. Integer
保持最大值一个 int可以有2 31 -1。
MAX_VALUE - Static variable in class java.lang. Long
一个持有最大值的常数a long可以有2 63 -1。
MAX_VALUE - Static variable in class java.lang. Short
一个持有最大值一个 short可以有2 15 -1。
MAX_VALUE - Static variable in class java.time. Year
最大支持年份为'+ 999,999,999'。
MAX_VALUE_FIELD - Static variable in class javax.management. JMX
名称为 maxValue字段。
MAX_VALUE_LENGTH - Static variable in class java.util.prefs. Preferences
字符串的最大长度允许为一个值（8192个字符）。
MAX_WEIGHT - Static variable in class java.util. Locale.LanguageRange
持有权重最大值的常数为1.0，表示语言范围适合用户。
MAXBQUALSIZE - Static variable in interface javax.transaction.xa. Xid
getBqual返回的最大字节数。
maxButton - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
最大化按钮。
maxBy(Comparator<? super T>) - Static method in interface java.util.function. BinaryOperator
返回一个BinaryOperator ，根据指定的Comparator返回两个元素中的较大者。
maxBy(Comparator<? super T>) - Static method in class java.util.stream. Collectors
返回一个 Collector ，它根据给定的 Comparator产生最大元素，描述为 Optional<T> 。
maxBytesPerChar() - Method in class java.nio.charset. CharsetEncoder
返回为每个输入字符产生的最大字节数。
maxCharsPerByte() - Method in class java.nio.charset. CharsetDecoder
返回每个字节输入的最大字符数。
MAXGRIDSIZE - Static variable in class java.awt. GridBagLayout
此字段不再用于保留阵列并保留向后兼容性。
MAXGTRIDSIZE - Static variable in interface javax.transaction.xa. Xid
getGtrid返回的最大字节数。
maxHeight(double) - Method in class javafx.embed.swing. SwingNode
返回 SwingNode用于布局计算的最大高度。
maxHeight(double) - Method in class javafx.scene.control. PopupControl
在布局期间调用以确定此节点的最大高度。
maxHeight(double) - Method in class javafx.scene.layout. Region
在布局期间调用以确定此节点的最大高度。
maxHeight(double) - Method in class javafx.scene. Node
返回节点在布局计算中使用的最大高度。
maxHeight(double) - Method in class javafx.scene.web. WebView
在布局期间调用以确定此节点的最大高度。
maxHeightProperty() - Method in class javafx.scene.control. PopupControl
覆盖控制计算最大高度的属性。
maxHeightProperty() - Method in class javafx.scene.layout. Region
覆盖该地区计算出的最大高度的属性。
maxHeightProperty() - Method in class javafx.scene.layout. RowConstraints
行的最大高度。
maxHeightProperty() - Method in class javafx.scene.web. WebView
最大高度属性。
maxHeightProperty() - Method in class javafx.stage. Stage
定义这个 Stage的最大高度。
maxIcon - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
最大化图标。
maximizable - Variable in class javax.swing. JInternalFrame
该框架可以扩展到桌面窗格的大小。
MAXIMIZE_CMD - Static variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
最大化按钮文本属性。
maximizeAction - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
一个 MaximizeAction的实例。
MaximizeAction() - Constructor for class javax.swing.plaf.basic. BasicDesktopPaneUI.MaximizeAction
MaximizeAction() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.MaximizeAction
构造一个新的实例 MaximizeAction 。
MAXIMIZED_BOTH - Static variable in class java.awt. Frame
该状态位掩码表示帧完全最大化（即水平和垂直）。
MAXIMIZED_HORIZ - Static variable in class java.awt. Frame
该状态位指示帧在水平方向上最大化。
MAXIMIZED_VERT - Static variable in class java.awt. Frame
该状态位指示帧在垂直方向上最大化。
maximizedProperty() - Method in class javafx.stage. Stage
定义 Stage是否最大化。
maximizeFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
调整框架大小以填补父母的边界。
maximizeFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager
通常，框架应调整大小以匹配其父级边界。
maximizeFrame(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
当用户想要最大化帧时调用此方法。
maximizeKey - Variable in class javax.swing.plaf.basic. BasicDesktopPaneUI
已过时。
截至1.3。
maximum - Variable in class javax.swing. SizeRequirements
允许的最大大小。
maximumCumulativePeriodProperty() - Method in class javafx.concurrent. ScheduledService
累积百分比的最大允许值。
maximumFailureCountProperty() - Method in class javafx.concurrent. ScheduledService
在完成FAILED状态之前，ScheduledService可以失败的最大次数。
maximumLayoutSize(Container) - Method in class java.awt. BorderLayout
给定指定目标容器中的组件的返回布局的最大尺寸。
maximumLayoutSize(Container) - Method in class java.awt. CardLayout
给定指定目标容器中的组件的返回布局的最大尺寸。
maximumLayoutSize(Container) - Method in class java.awt. GridBagLayout
给定指定目标容器中的组件的返回布局的最大尺寸。
maximumLayoutSize(Container) - Method in interface java.awt. LayoutManager2
给定指定容器的最大尺寸尺寸，给定其包含的组件。
maximumLayoutSize(Container) - Method in class javax.swing. BoxLayout
返回目标容器可用于布局其包含的组件的最大尺寸。
maximumLayoutSize(Container) - Method in class javax.swing. GroupLayout
返回指定容器的最大大小。
maximumLayoutSize(Container) - Method in class javax.swing. JRootPane.RootLayout
返回布局可以使用的最大空间量。
maximumLayoutSize(Container) - Method in class javax.swing. OverlayLayout
返回布局包含在指定目标容器中的组件所需的最大尺寸。
maximumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
返回两个方向的最大布局大小，即Integer.MAX_VALUE。
maximumLayoutSize(Container) - Method in class javax.swing. SpringLayout
maximumRowCount - Variable in class javax.swing. JComboBox
此保护字段是实现特定的。
maximumThumbSize - Variable in class javax.swing.plaf.basic. BasicScrollBarUI
最大拇指大小
maxInboundStreams() - Method in class com.sun.nio.sctp. Association
返回此关联支持的入站流的最大数量。
maxInStreams() - Method in class com.sun.nio.sctp. SctpStandardSocketOptions.InitMaxStreams
返回入站流的最大数量。
maxLength() - Method in enum java.time. Month
以天为单位获得本月的最大长度。
MAXLENGTH - Static variable in class javax.swing.text.html. HTML.Attribute
属性“maxlength”
maxMemory() - Method in class java.lang. Runtime
返回Java虚拟机将尝试使用的最大内存量。
maxOutboundStreams() - Method in class com.sun.nio.sctp. Association
返回此关联支持的最大出站流数。
maxOutStreams() - Method in class com.sun.nio.sctp. SctpStandardSocketOptions.InitMaxStreams
返回出站流的最大数量。
maxPageIndicatorCountProperty() - Method in class javafx.scene.control. Pagination
用于此分页控件的页面指示符的最大数量。
maxProperty() - Method in class javafx.scene.control. ScrollBar
由该 ScrollBar表示的 ScrollBar 。
maxProperty() - Method in class javafx.scene.control. Slider
由此滑块表示的最大值。
maxProperty() - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory
设置该值工厂的最大允许值
maxProperty() - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory
设置该值工厂的最大允许值
maxSizeProperty() - Method in class javafx.scene.web. WebHistory
定义历史记录列表的最大大小。
maxTabHeight - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
最大标签高度
maxTabWidth - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
最大标签宽度
maxWidth - Variable in class javax.swing.table. TableColumn
列的最大宽度。
maxWidth(double) - Method in class javafx.embed.swing. SwingNode
返回 SwingNode用于布局计算的最大宽度。
maxWidth(double) - Method in class javafx.scene.control. PopupControl
在布局期间调用以确定此节点的最大宽度。
maxWidth(double) - Method in class javafx.scene.layout. Region
在布局期间调用以确定此节点的最大宽度。
maxWidth(double) - Method in class javafx.scene. Node
返回节点在布局计算中使用的最大宽度。
maxWidth(double) - Method in class javafx.scene.web. WebView
在布局期间调用以确定此节点的最大宽度。
maxWidthProperty() - Method in class javafx.scene.control. PopupControl
覆盖控件计算出的最大宽度的属性。
maxWidthProperty() - Method in class javafx.scene.control. TableColumnBase
表列允许调整大小的最大宽度。
maxWidthProperty() - Method in class javafx.scene.layout. ColumnConstraints
列的最大宽度。
maxWidthProperty() - Method in class javafx.scene.layout. Region
覆盖该地区计算出的最大宽度的属性。
maxWidthProperty() - Method in class javafx.scene.web. WebView
最大宽度属性。
maxWidthProperty() - Method in class javafx.stage. Stage
定义 Stage的最大宽度。
MAY - java.time. Month
5月份的单身人士31天。
MAY - Static variable in class java.util. Calendar
价值 Calendar.MONTH字段表示今年第五个月在公历和朱利安日历。
MAY - Static variable in class javax.xml.datatype. DatatypeConstants
一年的第五个月的价值
maybeInitialize() - Static method in class com.sun.java.accessibility.util. EventQueueMonitor
告诉 EventQueueMonitor开始听事件。
maybeUpdateLayoutState() - Method in class javax.swing.plaf.basic. BasicListUI
如果updateLayoutStateNeeded不为零，请调用updateLayoutState（）并重置updateLayoutStateNeeded。
MBeanAttributeInfo - Class in javax.management
描述为管理而公开的MBean属性。
MBeanAttributeInfo(String, String, Method, Method) - Constructor for class javax.management. MBeanAttributeInfo
该构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - Constructor for class javax.management. MBeanAttributeInfo
构造一个 MBeanAttributeInfo对象。
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - Constructor for class javax.management. MBeanAttributeInfo
构造一个 MBeanAttributeInfo对象。
MBeanConstructorInfo - Class in javax.management
描述由MBean公开的构造函数。
MBeanConstructorInfo(String, Constructor<?>) - Constructor for class javax.management. MBeanConstructorInfo
构造一个 MBeanConstructorInfo对象。
MBeanConstructorInfo(String, String, MBeanParameterInfo[]) - Constructor for class javax.management. MBeanConstructorInfo
构造一个 MBeanConstructorInfo对象。
MBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - Constructor for class javax.management. MBeanConstructorInfo
构造一个 MBeanConstructorInfo对象。
MBeanException - Exception in javax.management
表示代理中MBean方法抛出的“用户定义”异常。
MBeanException(Exception) - Constructor for exception javax.management. MBeanException
创建一个 MBeanException包裹实际的 java.lang.Exception 。
MBeanException(Exception, String) - Constructor for exception javax.management. MBeanException
创建一个 MBeanException ，其中包含实际的 java.lang.Exception与详细消息。
MBeanFeatureInfo - Class in javax.management
提供MBean描述符对象的一般信息。
MBeanFeatureInfo(String, String) - Constructor for class javax.management. MBeanFeatureInfo
构造一个 MBeanFeatureInfo对象。
MBeanFeatureInfo(String, String, Descriptor) - Constructor for class javax.management. MBeanFeatureInfo
构造一个 MBeanFeatureInfo对象。
MBeanInfo - Class in javax.management
描述MBean暴露的管理界面; 即可用于管理操作的一组属性和操作。
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[]) - Constructor for class javax.management. MBeanInfo
构造一个 MBeanInfo 。
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - Constructor for class javax.management. MBeanInfo
构造一个 MBeanInfo 。
MBeanNotificationInfo - Class in javax.management
MBeanNotificationInfo类用于描述针对给定Java类通知的MBean发出的不同通知实例的特性。
MBeanNotificationInfo(String[], String, String) - Constructor for class javax.management. MBeanNotificationInfo
构造一个 MBeanNotificationInfo对象。
MBeanNotificationInfo(String[], String, String, Descriptor) - Constructor for class javax.management. MBeanNotificationInfo
构造一个 MBeanNotificationInfo对象。
MBeanOperationInfo - Class in javax.management
描述MBean公开的管理操作。
MBeanOperationInfo(String, Method) - Constructor for class javax.management. MBeanOperationInfo
构造一个 MBeanOperationInfo对象。
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - Constructor for class javax.management. MBeanOperationInfo
构造一个 MBeanOperationInfo对象。
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - Constructor for class javax.management. MBeanOperationInfo
构造一个 MBeanOperationInfo对象。
MBeanParameterInfo - Class in javax.management
描述MBean暴露的操作的参数。
MBeanParameterInfo(String, String, String) - Constructor for class javax.management. MBeanParameterInfo
构造一个 MBeanParameterInfo对象。
MBeanParameterInfo(String, String, String, Descriptor) - Constructor for class javax.management. MBeanParameterInfo
构造一个 MBeanParameterInfo对象。
MBeanPermission - Class in javax.management
控制访问MBeanServer操作的权限。
MBeanPermission(String, String) - Constructor for class javax.management. MBeanPermission
使用指定的目标名称和操作创建一个新的MBeanPermission对象。
MBeanPermission(String, String, ObjectName, String) - Constructor for class javax.management. MBeanPermission
使用指定的目标名称（类名，成员，对象名称）和操作创建新的MBeanPermission对象。
MBeanRegistration - Interface in javax.management
可以由MBean实现，以便在从MBean服务器注册或注销之前和之后执行操作。
MBeanRegistrationException - Exception in javax.management
包含由preRegister（），preDeregister（）方法抛出的异常 MBeanRegistration接口。
MBeanRegistrationException(Exception) - Constructor for exception javax.management. MBeanRegistrationException
创建一个 MBeanRegistrationException ，包裹实际的 java.lang.Exception 。
MBeanRegistrationException(Exception, String) - Constructor for exception javax.management. MBeanRegistrationException
创建一个 MBeanRegistrationException ，其中包含实际的 java.lang.Exception详细消息。
MBeanServer - Interface in javax.management
这是代理方面的MBean操作界面。
MBeanServerBuilder - Class in javax.management
此类表示创建默认的MBeanServer实现的构建器。
MBeanServerBuilder() - Constructor for class javax.management. MBeanServerBuilder
公共默认构造函数。
MBeanServerConnection - Interface in javax.management
此接口表示与MBean服务器通信的方式，无论是本地还是远程。
MBeanServerDelegate - Class in javax.management
从管理的角度来看MBean服务器。
MBeanServerDelegate() - Constructor for class javax.management. MBeanServerDelegate
创建一个MBeanServerDelegate对象。
MBeanServerDelegateMBean - Interface in javax.management
定义MBeanServerDelegate类的对象的管理界面。
MBeanServerFactory - Class in javax.management
提供MBean服务器引用。
MBeanServerForwarder - Interface in javax.management.remote
此类的一个对象实现MBeanServer接口并包装另一个也实现该接口的对象。
MBeanServerInvocationHandler - Class in javax.management
InvocationHandler将MBean管理界面中的方法通过MBean服务器转发到MBean。
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName) - Constructor for class javax.management. MBeanServerInvocationHandler
调用处理程序，将方法通过MBean服务器转发到标准MBean。
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName, boolean) - Constructor for class javax.management. MBeanServerInvocationHandler
调用处理程序，可以将方法通过MBean服务器转发到标准MBean或MXBean。
MBeanServerNotification - Class in javax.management
表示MBean服务器通过MBeanServerDelegate MBean发出的通知。
MBeanServerNotification(String, Object, long, ObjectName) - Constructor for class javax.management. MBeanServerNotification
创建一个MBeanServerNotification对象，指定导致通知的MBean的对象名称和指定的通知类型。
MBeanServerNotificationFilter - Class in javax.management.relation
过滤器MBeanServerNotification 。
MBeanServerNotificationFilter() - Constructor for class javax.management.relation. MBeanServerNotificationFilter
创建一个过滤器，为所有ObjectNames选择所有MBeanServerNotification通知。
MBeanServerPermission - Class in javax.management
A执行与MBeanServers有关的操作的权限。
MBeanServerPermission(String) - Constructor for class javax.management. MBeanServerPermission
使用给定的名称创建一个新的MBeanServerPermission。
MBeanServerPermission(String, String) - Constructor for class javax.management. MBeanServerPermission
使用给定的名称创建一个新的MBeanServerPermission。
MBeanTrustPermission - Class in javax.management
此权限在签名者或代码库中表示“信任”。
MBeanTrustPermission(String) - Constructor for class javax.management. MBeanTrustPermission
使用给定的名称创建一个新的MBeanTrustPermission。
MBeanTrustPermission(String, String) - Constructor for class javax.management. MBeanTrustPermission
使用给定的名称创建一个新的MBeanTrustPermission。
MD - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于MD
MEASURE_MODE_2D - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
要与“GPSMeasureMode”标签一起使用的值。
MEASURE_MODE_3D - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet
要与“GPSMeasureMode”标签一起使用的值。
measureTickMarkLabelSize(String, double) - Method in class javafx.scene.chart. Axis
测量给定刻度标记值的标签尺寸。
measureTickMarkSize(Number, Object) - Method in class javafx.scene.chart. NumberAxis
测量给定刻度标记值的标签尺寸。
measureTickMarkSize(String, Object) - Method in class javafx.scene.chart. CategoryAxis
测量给定刻度标记值的标签尺寸。
measureTickMarkSize(T, double) - Method in class javafx.scene.chart. Axis
测量给定刻度标记值的标签尺寸。
measureTickMarkSize(T, Object) - Method in class javafx.scene.chart. Axis
测量给定刻度标记值的标签尺寸。
Media - Class in javafx.scene.media
Media类代表媒体资源。
Media - Class in javax.print.attribute.standard
Class Media是一个打印属性类，用于指定要打印的介质。
Media(int) - Constructor for class javax.print.attribute.standard. Media
构造由name指定的新媒体属性。
Media(String) - Constructor for class javafx.scene.media. Media
构造一个 Media实例。
MEDIA - javafx.application. ConditionalFeature
表示javafx.scene.media包在此平台上可用。
MEDIA_CORRUPTED - javafx.scene.media. MediaException.Type
表示发生错误：媒体似乎无效或损坏。
MEDIA_EMPTY - Static variable in class javax.print.attribute.standard. PrinterStateReason
至少有一个进纸盒是空的。
MEDIA_ERROR - Static variable in class javafx.scene.media. MediaErrorEvent
唯一有效的事件类型为 MediaErrorEvent 。
MEDIA_INACCESSIBLE - javafx.scene.media. MediaException.Type
表示发生错误：虽然媒体可能存在，但它是不可访问的。
MEDIA_JAM - Static variable in class javax.print.attribute.standard. PrinterStateReason
设备有媒体卡纸。
MEDIA_LOW - Static variable in class javax.print.attribute.standard. PrinterStateReason
介质上至少有一个进纸盒低。
MEDIA_NEEDED - Static variable in class javax.print.attribute.standard. PrinterStateReason
托盘已经用完了媒体。
MEDIA_RULE - Static variable in interface org.w3c.dom.css. CSSRule
规则是一个 CSSMediaRule 。
MEDIA_TYPE - Static variable in class javax.xml.transform. OutputKeys
media-type = string 。
MEDIA_UNAVAILABLE - javafx.scene.media. MediaException.Type
表示发生错误：介质不存在或不可用。
MEDIA_UNSPECIFIED - javafx.scene.media. MediaException.Type
表示尚未指定介质。
MEDIA_UNSUPPORTED - javafx.scene.media. MediaException.Type
表示此平台不支持此媒体类型。
MediaErrorEvent - Class in javafx.scene.media
一个Event代表在处理媒体时发生错误。
MediaException - Exception in javafx.scene.media
甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。
MediaException.Type - Enum in javafx.scene.media
描述错误类别的枚举。
MediaList - Interface in org.w3c.dom.stylesheets
MediaList接口提供了有序的媒体集合的抽象，而不定义或限制如何实现此集合。
MediaMarkerEvent - Class in javafx.scene.media
代表媒体标记的ActionEvent 。
MediaName - Class in javax.print.attribute.standard
MediaName类是Media的子类，它是打印属性类（枚举），用于将打印作业的媒体指定为名称。
MediaName(int) - Constructor for class javax.print.attribute.standard. MediaName
构造具有给定整数值的新媒体名称枚举值。
MediaPlayer - Class in javafx.scene.media
MediaPlayer课程提供播放媒体的控制。
MediaPlayer(Media) - Constructor for class javafx.scene.media. MediaPlayer
为特定媒体创建播放器。
MediaPlayer.Status - Enum in javafx.scene.media
描述一个MediaPlayer的不同状态值的枚举 。
mediaPlayerProperty() - Method in class javafx.scene.media. MediaView
mediaPlayer的输出将由此视图处理。
MediaPrintableArea - Class in javax.print.attribute.standard
MediaPrintableArea类是用于区分可打印区域和不可打印区域的打印属性。
MediaPrintableArea(float, float, float, float, int) - Constructor for class javax.print.attribute.standard. MediaPrintableArea
从浮点值构造一个MediaPrintableArea对象。
MediaPrintableArea(int, int, int, int, int) - Constructor for class javax.print.attribute.standard. MediaPrintableArea
从整数值构造MediaPrintableArea对象。
MediaSize - Class in javax.print.attribute.standard
MediaSize类是一种二维尺寸值的打印属性类，它以纵向方向指示介质的尺寸，X尺寸沿着底边缘运行，Y尺寸沿着左边缘运行。
MediaSize(float, float, int) - Constructor for class javax.print.attribute.standard. MediaSize
从给定的浮点值构造新的媒体大小属性。
MediaSize(float, float, int, MediaSizeName) - Constructor for class javax.print.attribute.standard. MediaSize
从给定的浮点值构造新的媒体大小属性。
MediaSize(int, int, int) - Constructor for class javax.print.attribute.standard. MediaSize
从给定的整数值构造一个新的媒体大小属性。
MediaSize(int, int, int, MediaSizeName) - Constructor for class javax.print.attribute.standard. MediaSize
从给定的整数值构造一个新的媒体大小属性。
MediaSize.Engineering - Class in javax.print.attribute.standard
类MediaSize.Engineering包括工程媒体的MediaSize值。
MediaSize.ISO - Class in javax.print.attribute.standard
MediaSize.ISO类包含ISO媒体的MediaSize值。
MediaSize.JIS - Class in javax.print.attribute.standard
Class MediaSize.JIS包括JIS（日本）媒体的MediaSize值
MediaSize.NA - Class in javax.print.attribute.standard
MediaSize.NA类包括北美媒体的MediaSize值。
MediaSize.Other - Class in javax.print.attribute.standard
Class MediaSize.Other包括杂项媒体的MediaSize值。
MediaSizeName - Class in javax.print.attribute.standard
MediaSizeName类是Media的子类。
MediaSizeName(int) - Constructor for class javax.print.attribute.standard. MediaSizeName
使用给定的整数值构造新的媒体大小枚举值。
MediaTracker - Class in java.awt
MediaTracker类是一个实用程序类，用于跟踪多个媒体对象的状态。
MediaTracker(Component) - Constructor for class java.awt. MediaTracker
创建媒体跟踪器以跟踪给定组件的图像。
MediaTray - Class in javax.print.attribute.standard
MediaTray类是Media的一个子类。
MediaTray(int) - Constructor for class javax.print.attribute.standard. MediaTray
用给定的整数值构建新的媒体托盘枚举值。
MediaView - Class in javafx.scene.media
甲Node提供的视图Media由正在播放MediaPlayer 。
MediaView() - Constructor for class javafx.scene.media. MediaView
创建一个MediaView实例，没有关联的MediaPlayer 。
MediaView(MediaPlayer) - Constructor for class javafx.scene.media. MediaView
创建与指定的MediaPlayer关联的MediaView实例。
MEDIUM - java.time.format. FormatStyle
中等文字风格，有一些细节。
MEDIUM - javafx.scene.text. FontWeight
表示中等字体重量（500）。
MEDIUM - Static variable in class java.text. DateFormat
中等风格图案的常数。
MEDIUM - Static variable in class javafx.scene.layout. BorderStroke
指定“medium”时的默认值
MEDIUMAQUAMARINE - Static variable in class javafx.scene.paint. Color
彩色介质海蓝宝石，RGB值为＃66CDAA
MEDIUMBLUE - Static variable in class javafx.scene.paint. Color
颜色中等蓝色，RGB值为＃0000CD
MEDIUMORCHID - Static variable in class javafx.scene.paint. Color
颜色中等兰花，RGB值为＃BA55D3
MEDIUMPURPLE - Static variable in class javafx.scene.paint. Color
颜色中等紫色，RGB值为＃9370DB
MEDIUMSEAGREEN - Static variable in class javafx.scene.paint. Color
彩色中型海绿，RGB值为＃3CB371
MEDIUMSLATEBLUE - Static variable in class javafx.scene.paint. Color
彩色介质为蓝色，RGB值为＃7B68EE
MEDIUMSPRINGGREEN - Static variable in class javafx.scene.paint. Color
彩色介质弹簧绿色，RGB值为＃00FA9A
MEDIUMTURQUOISE - Static variable in class javafx.scene.paint. Color
颜色介质绿松石，RGB值为＃48D1CC
MEDIUMVIOLETRED - Static variable in class javafx.scene.paint. Color
颜色中等紫色，RGB值为＃C71585
MEETEI_MAYEK - java.awt.font. NumericShaper.Range
Meetei Mayek系列与Meetei Mayek数字。
MEETEI_MAYEK - java.lang. Character.UnicodeScript
Unicode脚本“Meetei_Mayek”。
MEETEI_MAYEK - Static variable in class java.lang. Character.UnicodeBlock
“Meetei Mayek”Unicode字符块的常数。
MEETEI_MAYEK_EXTENSIONS - Static variable in class java.lang. Character.UnicodeBlock
“Meetei Mayek Extensions”Unicode字符块的常数。
MEIJI - Static variable in class java.time.chrono. JapaneseEra
“明治”时代（1868-01-01 - 1912-07-29）的单身实例，其值为-1。
member() - Method in interface org.omg.CORBA. DynUnion
已过时。
返回用于插入/获取此联合成员的DynAny对象引用。
member() - Method in class org.omg.DynamicAny. _DynUnionStub
返回当前活动的成员。
member() - Method in interface org.omg.DynamicAny. DynUnionOperations
返回当前活动的成员。
Member - Interface in java.lang.reflect
Member是一个反映关于单个成员（字段或方法）或构造函数的标识信息的接口。
MEMBER - javax.lang.model.element. NestingKind
作为另一种类型的命名成员的类型。
member_count() - Method in class org.omg.CORBA. TypeCode
检索由 TypeCode对象描述的类型的成员数。
member_kind() - Method in interface org.omg.CORBA. DynUnion
已过时。
返回与该联合成员关联的TCKind。
member_kind() - Method in class org.omg.DynamicAny. _DynUnionStub
返回当前活动成员TypeCode的TCKind值。
member_kind() - Method in interface org.omg.DynamicAny. DynUnionOperations
返回当前活动成员TypeCode的TCKind值。
member_label(int) - Method in class org.omg.CORBA. TypeCode
检索由给定索引识别的联盟成员的标签。
member_name() - Method in interface org.omg.CORBA. DynUnion
已过时。
允许检查该联合成员的名称，而不检查鉴别器的值。
member_name() - Method in class org.omg.DynamicAny. _DynUnionStub
返回当前活动成员的名称。
member_name() - Method in interface org.omg.DynamicAny. DynUnionOperations
返回当前活动成员的名称。
member_name(int) - Method in class org.omg.CORBA. TypeCode
检索由给定索引识别的成员的简单名称。
member_name(String) - Method in interface org.omg.CORBA. DynUnion
已过时。
允许分配该联盟成员的名称。
MEMBER_OF - Static variable in class javax.accessibility. AccessibleRelation
表示对象是一个或多个目标对象组的成员。
MEMBER_OF_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
标识组成员资格已更改。
MEMBER_REFERENCE - com.sun.source.tree. Tree.Kind
用于MemberReferenceTree的实例。
MEMBER_SELECT - com.sun.source.tree. Tree.Kind
用于MemberSelectTree的实例。
MEMBER_SELECT - jdk.nashorn.api.tree. Tree.Kind
用于MemberSelectTree的实例。
member_type(int) - Method in class org.omg.CORBA. TypeCode
描述描述由给定索引识别的成员的类型的 TypeCode对象。
member_visibility(int) - Method in class org.omg.CORBA. TypeCode
返回指示给定索引处成员的可见性的常量。
MemberDoc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
MemberReferenceTree - Interface in com.sun.source.tree
成员引用表达式的树节点。
MemberReferenceTree.ReferenceMode - Enum in com.sun.source.tree
有两种成员引用：（i）方法引用和（ii）构造函数引用
members() - Method in interface java.security.acl. Group
已过时。
返回组中成员的枚举。
MemberSelectTree - Interface in com.sun.source.tree
成员访问表达式的树节点。
MemberSelectTree - Interface in jdk.nashorn.api.tree
成员访问表达式的树节点。
MembershipKey - Class in java.nio.channels
代表互联网协议（IP）组播组成员身份的令牌。
MembershipKey() - Constructor for class java.nio.channels. MembershipKey
初始化此类的新实例。
MEMORY_COLLECTION_THRESHOLD_EXCEEDED - Static variable in class java.lang.management. MemoryNotificationInfo
通知类型表示在Java虚拟机已经花费了在该内存池中回收未使用的对象的努力之后，内存池的内存使用量大于或等于其内存池的内存使用量为 collection usage threshold 。
MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE - Static variable in class java.lang.management. ManagementFactory
ObjectName的域名和类型密钥属性为MemoryManagerMXBean 。
MEMORY_MXBEAN_NAME - Static variable in class java.lang.management. ManagementFactory
字符串表示的ObjectName为MemoryMXBean 。
MEMORY_POOL_MXBEAN_DOMAIN_TYPE - Static variable in class java.lang.management. ManagementFactory
域名和类型密钥属性在ObjectName为MemoryPoolMXBean 。
MEMORY_THRESHOLD_EXCEEDED - Static variable in class java.lang.management. MemoryNotificationInfo
通知类型表示内存池的内存使用量已达到或超过其 usage threshold值。
MemoryCacheImageInputStream - Class in javax.imageio.stream
一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
MemoryCacheImageInputStream(InputStream) - Constructor for class javax.imageio.stream. MemoryCacheImageInputStream
构造一个 MemoryCacheImageInputStream ，它将从给定的 InputStream读取。
MemoryCacheImageOutputStream - Class in javax.imageio.stream
一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
MemoryCacheImageOutputStream(OutputStream) - Constructor for class javax.imageio.stream. MemoryCacheImageOutputStream
构造一个 MemoryCacheImageOutputStream ，它将写入给定的 OutputStream 。
MemoryHandler - Class in java.util.logging
Handler缓冲在内存中的循环缓冲区中的请求。
MemoryHandler() - Constructor for class java.util.logging. MemoryHandler
创建一个 MemoryHandler并配置它基于 LogManager配置属性。
MemoryHandler(Handler, int, Level) - Constructor for class java.util.logging. MemoryHandler
创建一个 MemoryHandler 。
MemoryImageSource - Class in java.awt.image
该类是ImageProducer接口的一个实现，它使用一个数组为图像生成像素值。
MemoryImageSource(int, int, int[], int, int) - Constructor for class java.awt.image. MemoryImageSource
构造一个ImageProducer对象，它使用默认RGB ColorModel中的整数数组来生成一个Image对象的数据。
MemoryImageSource(int, int, int[], int, int, Hashtable<?, ?>) - Constructor for class java.awt.image. MemoryImageSource
构造一个ImageProducer对象，它使用默认RGB ColorModel中的整数数组来生成一个Image对象的数据。
MemoryImageSource(int, int, ColorModel, byte[], int, int) - Constructor for class java.awt.image. MemoryImageSource
构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
MemoryImageSource(int, int, ColorModel, byte[], int, int, Hashtable<?, ?>) - Constructor for class java.awt.image. MemoryImageSource
构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
MemoryImageSource(int, int, ColorModel, int[], int, int) - Constructor for class java.awt.image. MemoryImageSource
构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。
MemoryImageSource(int, int, ColorModel, int[], int, int, Hashtable<?, ?>) - Constructor for class java.awt.image. MemoryImageSource
构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。
MemoryManagerMXBean - Interface in java.lang.management
内存管理器的管理界面。
MemoryMXBean - Interface in java.lang.management
Java虚拟机的内存系统的管理界面。
MemoryNotificationInfo - Class in java.lang.management
有关内存通知的信息。
MemoryNotificationInfo(String, MemoryUsage, long) - Constructor for class java.lang.management. MemoryNotificationInfo
构造一个 MemoryNotificationInfo对象。
MemoryPoolMXBean - Interface in java.lang.management
内存池的管理界面。
MemoryType - Enum in java.lang.management
类型memory pools 。
MemoryUsage - Class in java.lang.management
MemoryUsage对象表示内存使用的快照。
MemoryUsage(long, long, long, long) - Constructor for class java.lang.management. MemoryUsage
构造一个 MemoryUsage对象。
MENDE_KIKAKUI - java.lang. Character.UnicodeScript
Unicode脚本“Mende Kikakui”。
MENDE_KIKAKUI - Static variable in class java.lang. Character.UnicodeBlock
常数为“Mende Kikakui”Unicode字符块。
menu - Static variable in class java.awt. SystemColor
呈现为菜单背景的颜色。
menu - Variable in class javax.swing.plaf.basic. BasicMenuUI.ChangeHandler
实例 JMenu 。
Menu - Class in java.awt
Menu对象是从菜单栏部署的下拉菜单组件。
Menu - Class in javafx.scene.control
可触发的项目的弹出菜单，仅根据请求向用户显示。
Menu() - Constructor for class java.awt. Menu
构造一个带有空标签的新菜单。
Menu() - Constructor for class javafx.scene.control. Menu
为其显示文本构造一个空字符串的菜单。
Menu(String) - Constructor for class java.awt. Menu
构造一个带有指定标签的新菜单。
Menu(String) - Constructor for class javafx.scene.control. Menu
构造一个菜单，并将显示文本设置为指定的文本。
Menu(String, boolean) - Constructor for class java.awt. Menu
构造具有指定标签的新菜单，指示菜单是否可以被拆除。
Menu(String, Node) - Constructor for class javafx.scene.control. Menu
构造菜单并使用指定的文本设置显示文本，并将图形Node设置为给定节点。
Menu(String, Node, MenuItem...) - Constructor for class javafx.scene.control. Menu
构造菜单，并将指定文本的显示文本（给定节点的图形Node）设置，并将给定项目插入到items列表中。
MENU - java.awt. Taskbar.Feature
表示菜单功能。
MENU - javafx.scene. AccessibleRole
菜单角色。
MENU - Static variable in class com.sun.java.accessibility.util. EventID
映射到Swing菜单支持（即MenuListener和MenuEvent）
MENU - Static variable in class java.awt. SystemColor
阵列索引为 SystemColor.menu系统颜色。
MENU - Static variable in class javax.accessibility. AccessibleRole
通常在菜单栏中找到的对象，其中包含用户可以选择的操作列表。
MENU - Static variable in class javax.swing.plaf.synth. Region
菜单区域。
MENU - Static variable in class javax.swing.text.html. HTML.Tag
标签<menu>
MENU_BAR - javafx.scene. AccessibleRole
菜单栏角色。
MENU_BAR - Static variable in class javax.accessibility. AccessibleRole
通常在应用程序的主对话框顶部绘制的对象，其中包含用户可以选择的菜单列表。
MENU_BAR - Static variable in class javax.swing.plaf.synth. Region
MenuBar区域。
MENU_BAR_PROPERTY - Static variable in class javax.swing. JInternalFrame
绑定属性名称。
MENU_BUTTON - javafx.scene. AccessibleRole
菜单按钮角色。
MENU_ITEM - javafx.scene. AccessibleRole
菜单项的作用。
MENU_ITEM - Static variable in class javax.accessibility. AccessibleRole
一个通常包含在菜单中的对象，呈现用户可以选择的动作。
MENU_ITEM - Static variable in class javax.swing.plaf.synth. Region
MenuItem区域。
MENU_ITEM_ACCELERATOR - Static variable in class javax.swing.plaf.synth. Region
一个MenuItem的加速器区域。
MENU_TEXT - Static variable in class java.awt. SystemColor
阵列索引为 SystemColor.menuText系统颜色。
MENU_VALIDATION_EVENT - Static variable in class javafx.scene.control. MenuItem
当调用Menuitem的加速器时调用
Menu.AccessibleAWTMenu - Class in java.awt
菜单的内部类用于提供对辅助功能的默认支持。
menuBar - Variable in class javax.swing. JRootPane
菜单栏。
menuBar - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
实例 JMenuBar 。
menuBar - Variable in class javax.swing.plaf.basic. BasicMenuBarUI
实例 JMenuBar 。
MenuBar - Class in java.awt
MenuBar类封装了平台的框架结构的菜单栏的概念。
MenuBar - Class in javafx.scene.control
MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。
MenuBar() - Constructor for class java.awt. MenuBar
创建一个新的菜单栏。
MenuBar() - Constructor for class javafx.scene.control. MenuBar
创建一个新的空MenuBar。
MenuBar(Menu...) - Constructor for class javafx.scene.control. MenuBar
使用给定的菜单创建一个新的MenuBar。
MenuBar.AccessibleAWTMenuBar - Class in java.awt
MenuBar的内部类用于为辅助功能提供默认支持。
MenuBarBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.MenuBarBorder
MenuBarBorder(Color, Color) - Constructor for class javax.swing.plaf.basic. BasicBorders.MenuBarBorder
构造一个新的 MenuBarBorder实例。
MenuBarSkin - Class in javafx.scene.control.skin
默认皮肤实现为MenuBar控件。
MenuBarSkin(MenuBar) - Constructor for class javafx.scene.control.skin. MenuBarSkin
创建一个新的MenuBarSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
MenuBarUI - Class in javax.swing.plaf
JMenuBar可插拔的外观和界面。
MenuBarUI() - Constructor for class javax.swing.plaf. MenuBarUI
MenuButton - Class in javafx.scene.control
MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。
MenuButton() - Constructor for class javafx.scene.control. MenuButton
创建一个新的空的菜单按钮。
MenuButton(String) - Constructor for class javafx.scene.control. MenuButton
创建一个新的空的菜单按钮，给定的文本显示在按钮上。
MenuButton(String, Node) - Constructor for class javafx.scene.control. MenuButton
创建一个新的空的菜单按钮，给定的文本和图形显示在按钮上。
MenuButton(String, Node, MenuItem...) - Constructor for class javafx.scene.control. MenuButton
创建一个新的菜单按钮，给定的文本和图形显示在按钮上，并将给定的项目插入到 items列表中。
MenuButtonSkin - Class in javafx.scene.control.skin
默认皮肤实现为MenuButton控件。
MenuButtonSkin(MenuButton) - Constructor for class javafx.scene.control.skin. MenuButtonSkin
创建一个新的MenuButtonSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
MenuButtonSkinBase< C extends MenuButton> - Class in javafx.scene.control.skin
MenuButtonSkin和SplitMenuButtonSkin的基类。
MenuButtonSkinBase(C) - Constructor for class javafx.scene.control.skin. MenuButtonSkinBase
创建一个新的MenuButtonSkinBase实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。
menuCanceled(MenuEvent) - Method in interface javax.swing.event. MenuListener
菜单取消时调用。
MenuComponent - Class in java.awt
抽象类 MenuComponent是所有菜单相关组件的超类。
MenuComponent() - Constructor for class java.awt. MenuComponent
创建一个 MenuComponent 。
MenuComponent.AccessibleAWTMenuComponent - Class in java.awt
内部类别 MenuComponent用于为辅助功能提供默认支持。
MenuContainer - Interface in java.awt
所有菜单相关容器的超类。
menuDeselected(MenuEvent) - Method in interface javax.swing.event. MenuListener
当菜单被取消选择时调用。
menuDragMouseDragged(MenuDragMouseEvent) - Method in interface javax.swing.event. MenuDragMouseListener
当鼠标在菜单组件的显示区域中拖动时调用。
menuDragMouseEntered(MenuDragMouseEvent) - Method in interface javax.swing.event. MenuDragMouseListener
当拖动的鼠标进入菜单组件的显示区域时调用。
MenuDragMouseEvent - Class in javax.swing.event
MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。
MenuDragMouseEvent(Component, int, long, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - Constructor for class javax.swing.event. MenuDragMouseEvent
构造一个MenuDragMouseEvent对象。
MenuDragMouseEvent(Component, int, long, int, int, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - Constructor for class javax.swing.event. MenuDragMouseEvent
构造一个MenuDragMouseEvent对象。
menuDragMouseExited(MenuDragMouseEvent) - Method in interface javax.swing.event. MenuDragMouseListener
当拖动的鼠标离开菜单组件的显示区域时调用。
menuDragMouseListener - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
实例 MenuDragMouseListener 。
MenuDragMouseListener - Interface in javax.swing.event
定义一个菜单鼠标拖动监听器。
menuDragMouseReleased(MenuDragMouseEvent) - Method in interface javax.swing.event. MenuDragMouseListener
当拖动的鼠标在菜单组件的显示区域中释放时调用。
MenuElement - Interface in javax.swing
任何可以放入菜单的组件都应该实现这个接口。
MenuEvent - Class in javax.swing.event
MenuEvent用于通知有关方面，事件源的菜单已经过滤，选择或取消。
MenuEvent(Object) - Constructor for class javax.swing.event. MenuEvent
构造一个MenuEvent对象。
menuItem - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
实例 JMenuItem 。
MenuItem - Class in java.awt
菜单中的所有项目必须属于类别 MenuItem或其子类之一。
MenuItem - Class in javafx.scene.control
MenuItem旨在与Menu一起使用，以向用户提供选项。
MenuItem() - Constructor for class java.awt. MenuItem
构造一个带有空标签的新菜单项，而不需要键盘快捷方式。
MenuItem() - Constructor for class javafx.scene.control. MenuItem
构造一个没有显示文本的MenuItem。
MenuItem(String) - Constructor for class java.awt. MenuItem
使用指定的标签构建一个新的MenuItem，而不需要键盘快捷方式。
MenuItem(String) - Constructor for class javafx.scene.control. MenuItem
构造一个MenuItem并设置具有指定文本的显示文本
MenuItem(String, MenuShortcut) - Constructor for class java.awt. MenuItem
创建一个带有相关键盘快捷方式的菜单项。
MenuItem(String, Node) - Constructor for class javafx.scene.control. MenuItem
构造函数的MenuItem，并使用指定的文本设置显示文本，并将图形设置为给定节点Node 。
MenuItem.AccessibleAWTMenuItem - Class in java.awt
MenuItem的内部类用于为辅助功能提供默认支持。
MenuItemBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.MenuItemBorder
MenuItemUI - Class in javax.swing.plaf
JMenuItem可插拔的外观和界面。
MenuItemUI() - Constructor for class javax.swing.plaf. MenuItemUI
MenuKeyEvent - Class in javax.swing.event
MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。
MenuKeyEvent(Component, int, long, int, int, char, MenuElement[], MenuSelectionManager) - Constructor for class javax.swing.event. MenuKeyEvent
构造一个MenuKeyEvent对象。
menuKeyListener - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
实例 MenuKeyListener 。
MenuKeyListener - Interface in javax.swing.event
MenuKeyListener添加
menuKeyPressed(MenuKeyEvent) - Method in interface javax.swing.event. MenuKeyListener
按下键时调用。
menuKeyReleased(MenuKeyEvent) - Method in interface javax.swing.event. MenuKeyListener
当键已被释放时调用。
menuKeyTyped(MenuKeyEvent) - Method in interface javax.swing.event. MenuKeyListener
键入键时调用。
menuListener - Variable in class javax.swing.plaf.basic. BasicMenuUI
实例 MenuListener 。
MenuListener - Interface in javax.swing.event
定义菜单事件的侦听器。
menuSelected(MenuEvent) - Method in interface javax.swing.event. MenuListener
选择菜单时调用。
menuSelectionChanged(boolean) - Method in class javax.swing. JMenu
当菜单选择更改以激活或停用此菜单时发生消息。
menuSelectionChanged(boolean) - Method in class javax.swing. JMenuBar
实现是一个 MenuElement - 什么也没做。
menuSelectionChanged(boolean) - Method in class javax.swing. JMenuItem
由被叫 MenuSelectionManager当 MenuElement被选择或取消选择。
menuSelectionChanged(boolean) - Method in class javax.swing. JPopupMenu
当菜单选择更改以激活或停用此菜单时发生消息。
menuSelectionChanged(boolean) - Method in interface javax.swing. MenuElement
由呼叫 MenuSelectionManager当 MenuElement添加或从菜单中选择删除。
MenuSelectionManager - Class in javax.swing
MenuSelectionManager拥有菜单层次结构中的选择。
MenuSelectionManager() - Constructor for class javax.swing. MenuSelectionManager
MenuShortcut - Class in java.awt
MenuShortcut类代表一个MenuItem的键盘加速器。
MenuShortcut(int) - Constructor for class java.awt. MenuShortcut
为指定的虚拟键码构造一个新的MenuShortcut。
MenuShortcut(int, boolean) - Constructor for class java.awt. MenuShortcut
为指定的虚拟键码构造一个新的MenuShortcut。
menuText - Static variable in class java.awt. SystemColor
为菜单文本呈现的颜色。
merge(Object, Object, BiFunction<? super Object, ? super Object, ?>) - Method in class java.util. Properties
merge(Object, Object, BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security. Provider
如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。
merge(StringJoiner) - Method in class java.util. StringJoiner
添加给定的 StringJoiner的内容，没有前缀和后缀作为下一个元素，如果它是非空的。
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentHashMap
如果指定的键尚未与（非空）值相关联，则将其与给定值相关联。
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in interface java.util.concurrent. ConcurrentMap
如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentSkipListMap
如果指定的键尚未与值相关联，则将其与给定值相关联。
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util. HashMap
如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util. Hashtable
如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in interface java.util. Map
如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。
mergeTree(String, Node) - Method in class javax.imageio.metadata. IIOMetadata
从XML DOM Node的树中更改此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。
MEROITIC_CURSIVE - java.lang. Character.UnicodeScript
Unicode脚本“Meroitic Cursive”。
MEROITIC_CURSIVE - Static variable in class java.lang. Character.UnicodeBlock
“Meroitic Cursive”Unicode字符块的常量。
MEROITIC_HIEROGLYPHS - java.lang. Character.UnicodeScript
Unicode脚本“Meroitic象形文字”。
MEROITIC_HIEROGLYPHS - Static variable in class java.lang. Character.UnicodeBlock
“Meroitic象形文字”Unicode字符块的常数。
Mesh - Class in javafx.scene.shape
用于表示3D几何表面的基类。
Mesh() - Constructor for class javafx.scene.shape. Mesh
meshProperty() - Method in class javafx.scene.shape. MeshView
指定此 MeshView的3D网格数据。
MeshView - Class in javafx.scene.shape
MeshView类定义了具有指定3D网格数据的曲面。
MeshView() - Constructor for class javafx.scene.shape. MeshView
创建一个新的实例 MeshView类。
MeshView(Mesh) - Constructor for class javafx.scene.shape. MeshView
创建具有指定的 Mesh表面的 MeshView类的新实例。
message - Variable in class javax.swing. JOptionPane
消息显示。
MESSAGE - javax.xml.ws. Service.Mode
消息模式。
MESSAGE_DIGEST - java.security. CryptoPrimitive
散列函数
MESSAGE_OUTBOUND_PROPERTY - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：消息方向， true用于出站邮件， false用于入站。
MESSAGE_PROPERTY - Static variable in class javax.swing. JOptionPane
绑定属性名称为 message 。
MESSAGE_TYPE_PROPERTY - Static variable in class javax.swing. JOptionPane
绑定属性名称为 type 。
MessageContext - Interface in javax.xml.ws.handler
接口 MessageContext从 handle方法中 handle由处理程序处理的消息上下文。
MessageContext.Scope - Enum in javax.xml.ws.handler
财产范围
MessageDigest - Class in java.security
该MessageDigest类为应用程序提供消息摘要算法的功能，如SHA-1或SHA-256。
MessageDigest(String) - Constructor for class java.security. MessageDigest
使用指定的算法名称创建消息摘要。
MessageDigestSpi - Class in java.security
该类定义了 MessageDigest类的 （ SPI ），它提供消息摘要算法（如MD5或SHA）的功能。
MessageDigestSpi() - Constructor for class java.security. MessageDigestSpi
MessageFactory - Class in javax.xml.soap
创建 SOAPMessage对象的工厂。
MessageFactory() - Constructor for class javax.xml.soap. MessageFactory
MessageFormat - Class in java.text
MessageFormat提供了一种以语言中立的方式产生连接消息的方法。
MessageFormat(String) - Constructor for class java.text. MessageFormat
为默认的 FORMAT区域设置和指定的模式构造一个MessageFormat。
MessageFormat(String, Locale) - Constructor for class java.text. MessageFormat
为指定的区域设置和模式构造一个MessageFormat。
MessageFormat.Field - Class in java.text
定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。
MessageInfo - Class in com.sun.nio.sctp
MessageInfo课程提供有关消息的其他辅助信息。
MessageInfo() - Constructor for class com.sun.nio.sctp. MessageInfo
初始化此类的新实例。
MessageProp - Class in org.ietf.jgss
这是在每消息GSSContext方法中使用的实用程序类，用于传递每消息属性。
MessageProp(boolean) - Constructor for class org.ietf.jgss. MessageProp
设置所需隐私状态的构造方法。
MessageProp(int, boolean) - Constructor for class org.ietf.jgss. MessageProp
构造函数，用于设置qop和隐私状态的值。
messageProperty() - Method in class javafx.concurrent. Service
messageProperty() - Method in class javafx.concurrent. Task
messageProperty() - Method in interface javafx.concurrent. Worker
获取表示消息的ReadOnlyStringProperty。
Messager - Interface in javax.annotation.processing
A Messager为注释处理器报告错误消息，警告和其他通知提供了方法。
messageType - Variable in class javax.swing. JOptionPane
消息类型。
meta - Variable in class javax.swing.text.html.parser. DTD
元素对应于元。
meta(MetaMessage) - Method in interface javax.sound.midi. MetaEventListener
在Sequencer遇到并处理了MetaMessage的Sequence进行处理时调用。
META - javafx.scene.input. KeyCode
常数为 Meta键。
META - Static variable in class javax.sound.midi. MetaMessage
MetaMessage （0xFF或255）的状态字节，用于MIDI文件。
META - Static variable in class javax.swing.text.html. HTML.Tag
标签<meta>
META_ANY - Static variable in class javafx.scene.input. KeyCombination
指定 meta键的 meta可以是向上还是向下。
META_DOWN - Static variable in class javafx.scene.input. KeyCombination
修饰符指定 meta键必须关闭。
META_DOWN_MASK - Static variable in class java.awt.event. InputEvent
Meta键扩展修饰符常数。
META_MASK - Static variable in class java.awt.event. ActionEvent
元修饰符。
META_MASK - Static variable in class java.awt.event. InputEvent
已过时。
建议使用META_DOWN_MASK和InputEvent.getModifiersEx()
META_MASK - Static variable in class java.awt. Event
已过时。
该标志表示事件发生时Meta键已关闭。
metadata - Variable in class javax.imageio. IIOImage
包含与图像相关联的元数据的 IIOMetadata对象。
metadata(Element) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
将 metadataElement添加到 W3CEndpointReference实例的 wsa:Metadata元素。
metaDown() - Method in class java.awt. Event
已过时。
注意： Event类已过时，仅适用于向后兼容性。
MetaEventListener - Interface in javax.sound.midi
MetaEventListener接口应当由Sequencer处理MetaMessage时需要通知实例的类实现。
metafactory(MethodHandles.Lookup, String, MethodType, MethodType, MethodHandle, MethodType) - Static method in class java.lang.invoke. LambdaMetafactory
在适当的类型适配和参数的部分评估之后，便于创建简单的“功能对象”，实现一个或多个接口，通过委派给所提供的MethodHandle 。
MetalBorders - Class in javax.swing.plaf.metal
工厂对象可以出售边界适合金属L＆F.
MetalBorders() - Constructor for class javax.swing.plaf.metal. MetalBorders
MetalBorders.ButtonBorder - Class in javax.swing.plaf.metal
该类代表 JButton的边界。
MetalBorders.Flush3DBorder - Class in javax.swing.plaf.metal
该类代表3D边框。
MetalBorders.InternalFrameBorder - Class in javax.swing.plaf.metal
该类代表一个 JInternalFrame的边界。
MetalBorders.MenuBarBorder - Class in javax.swing.plaf.metal
该类代表一个 JMenuBar的边界。
MetalBorders.MenuItemBorder - Class in javax.swing.plaf.metal
该类代表 JMenuItem的边界。
MetalBorders.OptionDialogBorder - Class in javax.swing.plaf.metal
该类表示选项对话框的边框。
MetalBorders.PaletteBorder - Class in javax.swing.plaf.metal
边框的调色板。
MetalBorders.PopupMenuBorder - Class in javax.swing.plaf.metal
该类代表 JPopupMenu的边界。
MetalBorders.RolloverButtonBorder - Class in javax.swing.plaf.metal
该类代表翻转的边界 Button 。
MetalBorders.ScrollPaneBorder - Class in javax.swing.plaf.metal
该类代表 JScrollPane的边界。
MetalBorders.TableHeaderBorder - Class in javax.swing.plaf.metal
表头的边框
MetalBorders.TextFieldBorder - Class in javax.swing.plaf.metal
该类代表 JTestField的边界。
MetalBorders.ToggleButtonBorder - Class in javax.swing.plaf.metal
MetalBorders.ToolBarBorder - Class in javax.swing.plaf.metal
该类代表一个 JToolBar的边界。
MetalButtonUI - Class in javax.swing.plaf.metal
MetalButtonUI实现
MetalButtonUI() - Constructor for class javax.swing.plaf.metal. MetalButtonUI
MetalCheckBoxIcon - Class in javax.swing.plaf.metal
OrganicCheckBoxUI的CheckboxIcon实现
MetalCheckBoxIcon() - Constructor for class javax.swing.plaf.metal. MetalCheckBoxIcon
MetalCheckBoxUI - Class in javax.swing.plaf.metal
MetalCheckboxUI的CheckboxUI实现
MetalCheckBoxUI() - Constructor for class javax.swing.plaf.metal. MetalCheckBoxUI
MetalComboBoxButton - Class in javax.swing.plaf.metal
JButton子类来帮助MetalComboBoxUI
MetalComboBoxButton(JComboBox<Object>, Icon, boolean, CellRendererPane, JList<Object>) - Constructor for class javax.swing.plaf.metal. MetalComboBoxButton
构造一个新的实例 MetalComboBoxButton 。
MetalComboBoxButton(JComboBox<Object>, Icon, CellRendererPane, JList<Object>) - Constructor for class javax.swing.plaf.metal. MetalComboBoxButton
构造一个新的实例 MetalComboBoxButton 。
MetalComboBoxEditor - Class in javax.swing.plaf.metal
Metal可编辑组合框的默认编辑器
MetalComboBoxEditor() - Constructor for class javax.swing.plaf.metal. MetalComboBoxEditor
构造一个新的实例 MetalComboBoxEditor 。
MetalComboBoxEditor.UIResource - Class in javax.swing.plaf.metal
BasicComboBoxEditor的子类实现UIResource。
MetalComboBoxIcon - Class in javax.swing.plaf.metal
此实用程序类绘制指示MetalComboBox的水平条
MetalComboBoxIcon() - Constructor for class javax.swing.plaf.metal. MetalComboBoxIcon
MetalComboBoxLayoutManager() - Constructor for class javax.swing.plaf.metal. MetalComboBoxUI.MetalComboBoxLayoutManager
MetalComboBoxUI - Class in javax.swing.plaf.metal
JComboBox的金属UI
MetalComboBoxUI() - Constructor for class javax.swing.plaf.metal. MetalComboBoxUI
MetalComboBoxUI.MetalComboBoxLayoutManager - Class in javax.swing.plaf.metal
这个类应该被视为一个“受保护”的内部类。
MetalComboBoxUI.MetalComboPopup - Class in javax.swing.plaf.metal
已过时。
从Java 2平台v1.4开始。
MetalComboBoxUI.MetalPropertyChangeListener - Class in javax.swing.plaf.metal
这个类应该被视为一个“受保护”的内部类。
MetalComboPopup(JComboBox<Object>) - Constructor for class javax.swing.plaf.metal. MetalComboBoxUI.MetalComboPopup
已过时。
构造一个新的实例 MetalComboPopup 。
MetalContainerListener() - Constructor for class javax.swing.plaf.metal. MetalToolBarUI.MetalContainerListener
MetalDesktopIconUI - Class in javax.swing.plaf.metal
金属桌面图标。
MetalDesktopIconUI() - Constructor for class javax.swing.plaf.metal. MetalDesktopIconUI
构造一个新的实例 MetalDesktopIconUI 。
MetalDockingListener(JToolBar) - Constructor for class javax.swing.plaf.metal. MetalToolBarUI.MetalDockingListener
构造 MetalDockingListener 。
MetalFileChooserUI - Class in javax.swing.plaf.metal
金属L＆F实现的FileChooser。
MetalFileChooserUI(JFileChooser) - Constructor for class javax.swing.plaf.metal. MetalFileChooserUI
构造一个新的实例 MetalFileChooserUI 。
MetalFileChooserUI.DirectoryComboBoxAction - Class in javax.swing.plaf.metal
当DirectoryComboBox更改所选项目时使用。
MetalFileChooserUI.DirectoryComboBoxModel - Class in javax.swing.plaf.metal
类型面部选择组合框的数据模型。
MetalFileChooserUI.FileRenderer - Class in javax.swing.plaf.metal
已过时。
截至JDK版本9.过时的课程。
MetalFileChooserUI.FilterComboBoxModel - Class in javax.swing.plaf.metal
类型面部选择组合框的数据模型。
MetalFileChooserUI.FilterComboBoxRenderer - Class in javax.swing.plaf.metal
渲染不同类型的尺寸和样式。
MetalFileChooserUI.SingleClickListener - Class in javax.swing.plaf.metal
已过时。
截至JDK版本9.过时的课程。
MetalIconFactory - Class in javax.swing.plaf.metal
工厂对象为Java的“外观”（Metal）提供 Icon s。
MetalIconFactory() - Constructor for class javax.swing.plaf.metal. MetalIconFactory
MetalIconFactory.FileIcon16 - Class in javax.swing.plaf.metal
警告：此类的序列化对象与将来的Swing版本不兼容。
MetalIconFactory.FolderIcon16 - Class in javax.swing.plaf.metal
警告：此类的序列化对象与将来的Swing版本不兼容。
MetalIconFactory.PaletteCloseIcon - Class in javax.swing.plaf.metal
定义调色板关闭的图标
MetalIconFactory.TreeControlIcon - Class in javax.swing.plaf.metal
警告：此类的序列化对象与将来的Swing版本不兼容。
MetalIconFactory.TreeFolderIcon - Class in javax.swing.plaf.metal
警告：此类的序列化对象与将来的Swing版本不兼容。
MetalIconFactory.TreeLeafIcon - Class in javax.swing.plaf.metal
该类代表树叶图标。
MetalInternalFrameTitlePane - Class in javax.swing.plaf.metal
管理JLF标题栏的类
MetalInternalFrameTitlePane(JInternalFrame) - Constructor for class javax.swing.plaf.metal. MetalInternalFrameTitlePane
构造一个新的实例 MetalInternalFrameTitlePane
MetalInternalFrameUI - Class in javax.swing.plaf.metal
金属实现JInternalFrame。
MetalInternalFrameUI(JInternalFrame) - Constructor for class javax.swing.plaf.metal. MetalInternalFrameUI
构造一个新的 MetalInternalFrameUI实例。
metalLabelUI - Static variable in class javax.swing.plaf.metal. MetalLabelUI
默认为 MetalLabelUI实例。
MetalLabelUI - Class in javax.swing.plaf.metal
LabelUI的Windows L＆F实现。
MetalLabelUI() - Constructor for class javax.swing.plaf.metal. MetalLabelUI
MetalLookAndFeel - Class in javax.swing.plaf.metal
Java外观和感觉，也称为金属。
MetalLookAndFeel() - Constructor for class javax.swing.plaf.metal. MetalLookAndFeel
MetalMenuBarUI - Class in javax.swing.plaf.metal
金属执行 MenuBarUI 。
MetalMenuBarUI() - Constructor for class javax.swing.plaf.metal. MetalMenuBarUI
MetalPopupMenuSeparatorUI - Class in javax.swing.plaf.metal
PopupMenuSeparatorUI的金属L＆F实现。
MetalPopupMenuSeparatorUI() - Constructor for class javax.swing.plaf.metal. MetalPopupMenuSeparatorUI
MetalProgressBarUI - Class in javax.swing.plaf.metal
ProgressBarUI的Metal实现。
MetalProgressBarUI() - Constructor for class javax.swing.plaf.metal. MetalProgressBarUI
MetalPropertyChangeListener() - Constructor for class javax.swing.plaf.metal. MetalComboBoxUI.MetalPropertyChangeListener
MetalPropertyListener() - Constructor for class javax.swing.plaf.metal. MetalSliderUI.MetalPropertyListener
MetalRadioButtonUI - Class in javax.swing.plaf.metal
MetalBadtonButtonUI的RadioButtonUI实现
MetalRadioButtonUI() - Constructor for class javax.swing.plaf.metal. MetalRadioButtonUI
MetalRolloverListener() - Constructor for class javax.swing.plaf.metal. MetalToolBarUI.MetalRolloverListener
MetalRootPaneUI - Class in javax.swing.plaf.metal
提供金属外观实现 RootPaneUI 。
MetalRootPaneUI() - Constructor for class javax.swing.plaf.metal. MetalRootPaneUI
MetalScrollBarUI - Class in javax.swing.plaf.metal
实现ScrollBarUI的金属外观和感觉
MetalScrollBarUI() - Constructor for class javax.swing.plaf.metal. MetalScrollBarUI
MetalScrollButton - Class in javax.swing.plaf.metal
金属滚动条箭头的JButton对象。
MetalScrollButton(int, int, boolean) - Constructor for class javax.swing.plaf.metal. MetalScrollButton
构造一个 MetalScrollButton的实例。
MetalScrollPaneUI - Class in javax.swing.plaf.metal
ScrollPaneUI的金属L＆F实现。
MetalScrollPaneUI() - Constructor for class javax.swing.plaf.metal. MetalScrollPaneUI
MetalSeparatorUI - Class in javax.swing.plaf.metal
SeparatorUI的金属L＆F实现。
MetalSeparatorUI() - Constructor for class javax.swing.plaf.metal. MetalSeparatorUI
MetalSliderUI - Class in javax.swing.plaf.metal
SliderUI的Java L＆F实现。
MetalSliderUI() - Constructor for class javax.swing.plaf.metal. MetalSliderUI
构造一个 MetalSliderUI实例。
MetalSliderUI.MetalPropertyListener - Class in javax.swing.plaf.metal
PropertyListener适用于 JSlider.isFilled 。
MetalSplitPaneUI - Class in javax.swing.plaf.metal
金属分割窗格。
MetalSplitPaneUI() - Constructor for class javax.swing.plaf.metal. MetalSplitPaneUI
MetalTabbedPaneUI - Class in javax.swing.plaf.metal
BasicTabbedPaneUI的Metal子类。
MetalTabbedPaneUI() - Constructor for class javax.swing.plaf.metal. MetalTabbedPaneUI
MetalTabbedPaneUI.TabbedPaneLayout - Class in javax.swing.plaf.metal
这个类应该被视为一个“受保护”的内部类。
MetalTextFieldUI - Class in javax.swing.plaf.metal
JTextField的外观和感觉的基础。
MetalTextFieldUI() - Constructor for class javax.swing.plaf.metal. MetalTextFieldUI
MetalTheme - Class in javax.swing.plaf.metal
MetalTheme提供了Java Look and Feel使用的调色板和字体。
MetalTheme() - Constructor for class javax.swing.plaf.metal. MetalTheme
MetalToggleButtonUI - Class in javax.swing.plaf.metal
MetalToggleButton实现
MetalToggleButtonUI() - Constructor for class javax.swing.plaf.metal. MetalToggleButtonUI
MetalToolBarUI - Class in javax.swing.plaf.metal
金属外观实现ToolBarUI。
MetalToolBarUI() - Constructor for class javax.swing.plaf.metal. MetalToolBarUI
MetalToolBarUI.MetalContainerListener - Class in javax.swing.plaf.metal
不再使用
MetalToolBarUI.MetalDockingListener - Class in javax.swing.plaf.metal
DockingListener为 MetalToolBarUI 。
MetalToolBarUI.MetalRolloverListener - Class in javax.swing.plaf.metal
不再使用
MetalToolTipUI - Class in javax.swing.plaf.metal
BasicToolTipUI的金属L＆F扩展。
MetalToolTipUI() - Constructor for class javax.swing.plaf.metal. MetalToolTipUI
构造一个 MetalToolTipUI的实例。
MetalTreeUI - Class in javax.swing.plaf.metal
金属外观实现 TreeUI 。
MetalTreeUI() - Constructor for class javax.swing.plaf.metal. MetalTreeUI
构造 MetalTreeUI 。
MetaMessage - Class in javax.sound.midi
A MetaMessage是一个MidiMessage ， 它对合成器没有意义，但可以存储在MIDI文件中并由音序器程序解释。
MetaMessage() - Constructor for class javax.sound.midi. MetaMessage
构造新的 MetaMessage 。
MetaMessage(byte[]) - Constructor for class javax.sound.midi. MetaMessage
构造新的 MetaMessage 。
MetaMessage(int, byte[], int) - Constructor for class javax.sound.midi. MetaMessage
构造一个新的 MetaMessage并设置消息参数。
METERING_MODE_AVERAGE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_CENTER_WEIGHTED_AVERAGE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_MAX_RESERVED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_MIN_RESERVED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_MULTI_SPOT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_OTHER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_PARTIAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_PATTERN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_SPOT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
METERING_MODE_UNKNOWN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
与“MeteringMode”标签一起使用的值。
method - Variable in class java.net. HttpURLConnection
HTTP方法（GET，POST，PUT等）。
method() - Method in interface com.sun.jdi.event. MethodEntryEvent
返回输入的方法。
method() - Method in interface com.sun.jdi.event. MethodExitEvent
返回退出的方法。
method() - Method in interface com.sun.jdi. Location
获取包含此位置的方法。
method() - Method in class jdk.incubator.http. HttpRequest
返回此请求的请求方法。
method(String, HttpRequest.BodyProcessor) - Method in class jdk.incubator.http. HttpRequest.Builder
将此构建器的请求方法和请求体设置为给定值。
方法 - Class in java.lang.reflect
A 方法提供有关类和接口上单一方法的信息和访问权限。
方法 - Interface in com.sun.jdi
目标VM中的静态或实例方法。
METHOD - com.sun.source.tree. Tree.Kind
用于MethodTree的实例。
METHOD - java.lang.annotation. ElementType
方法声明
METHOD - javax.lang.model.element. ElementKind
一个方法。
METHOD - jdk.dynalink. StandardNamespace
对象方法的标准命名空间。
METHOD - jdk.javadoc.doclet. Taglet.Location
在一个方法的文档中。
METHOD - jdk.jshell. Snippet.Kind
方法声明
METHOD - Static variable in class javax.swing.text.html. HTML.Attribute
属性“方法”
METHOD - Static variable in class javax.xml.transform. OutputKeys
method =“xml”| “html”| “text”| 扩展名称
METHOD_ATTRIBUTE_PFX - Static variable in interface java.util.jar. Pack200.Packer
当与方法属性名称连接时，表示该属性的格式。
METHOD_INVOCATION - com.sun.source.tree. Tree.Kind
用于MethodInvocationTree的实例。
METHOD_SUBKIND - jdk.jshell. Snippet.SubKind
一个方法。
MethodDescriptor - Class in java.beans
MethodDescriptor描述了Java Bean支持的特定方法，用于从其他组件进行外部访问。
MethodDescriptor(Method) - Constructor for class java.beans. MethodDescriptor
构造一个 MethodDescriptor从 方法 。
MethodDescriptor(Method, ParameterDescriptor[]) - Constructor for class java.beans. MethodDescriptor
从 方法构造一个 MethodDescriptor ，为每个方法的参数提供描述性信息。
MethodDoc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
MethodEntryEvent - Interface in com.sun.jdi.event
在目标虚拟机中通知方法调用。
MethodEntryRequest - Interface in com.sun.jdi.request
在目标虚拟机中调用方法时请求通知。
methodEntryRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的方法条目请求的不可修改列表。
MethodExitEvent - Interface in com.sun.jdi.event
在目标VM中返回方法的通知。
MethodExitRequest - Interface in com.sun.jdi.request
当方法在目标虚拟机中返回时请求通知。
methodExitRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的方法退出请求的不可修改的列表。
MethodHandle - Class in java.lang.invoke
方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
MethodHandleInfo - Interface in java.lang.invoke
通过将直接方法句柄破解成其宪法符号部分获得的象征性参考。
MethodHandleProxies - Class in java.lang.invoke
此类仅由静态方法组成，可帮助将方法句柄修改为其他JVM类型（如接口）。
MethodHandles - Class in java.lang.invoke
该类仅由静态方法组成，或者返回方法句柄。
MethodHandles.Lookup - Class in java.lang.invoke
查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。
MethodHandleTransformer - Interface in jdk.dynalink.linker
描述变换方法句柄的操作的通用界面。
MethodInvocationTree - Interface in com.sun.source.tree
方法调用表达式的树节点。
methodModifiers() - Static method in class java.lang.reflect. Modifier
返回一个 int值将可以应用于方法的源语言修饰符OR组合在一起。
methodName() - Method in enum java.lang.invoke. VarHandle.AccessMode
返回与此 AccessMode值相关联的 VarHandle签名 - 多态方法名称。
methods() - Method in interface com.sun.javadoc. ClassDoc
已过时。
返回 此类或接口中的 included方法。
methods() - Method in interface com.sun.jdi. ReferenceType
返回包含此类型直接声明的每个方法的列表。
methods() - Method in class jdk.jshell. JShell
返回活动方法代码段。
methods(boolean) - Method in interface com.sun.javadoc. ClassDoc
已过时。
在此类或接口中返回方法，过滤到指定的 access modifier option 。
methodsByName(String) - Method in interface com.sun.jdi. ReferenceType
返回一个列表，其中包含具有给定名称的每个可见的方法 。
methodsByName(String, String) - Method in interface com.sun.jdi. ReferenceType
返回包含具有给定名称和签名的每个可见的方法的列表。
methodsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
返回 elements中的方法列表。
methodsIn(Set<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
返回一组方法在 elements 。
MethodSnippet - Class in jdk.jshell
方法定义的代码段。
MethodTree - Interface in com.sun.source.tree
用于方法或注释类型元素声明的树节点。
methodType(Class<?>) - Static method in class java.lang.invoke. MethodType
查找或创建具有给定组件的方法类型。
methodType(Class<?>, Class<?>) - Static method in class java.lang.invoke. MethodType
查找或创建具有给定组件的方法类型。
methodType(Class<?>, Class<?>[]) - Static method in class java.lang.invoke. MethodType
查找或创建给定方法类型的实例。
methodType(Class<?>, Class<?>, Class<?>...) - Static method in class java.lang.invoke. MethodType
查找或创建具有给定组件的方法类型。
methodType(Class<?>, MethodType) - Static method in class java.lang.invoke. MethodType
查找或创建具有给定组件的方法类型。
methodType(Class<?>, List<Class<?>>) - Static method in class java.lang.invoke. MethodType
查找或创建具有给定组件的方法类型。
MethodType - Class in java.lang.invoke
方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。
MethodTypeConversionStrategy - Interface in jdk.dynalink.linker
表示用于将方法句柄转换为新类型的策略的对象的接口。
metrics - Variable in class javax.swing.text. PlainView
当前字体的字体指标。
MGF1ParameterSpec - Class in java.security.spec
该类别指定在 PKCS #1 v2.1标准中定义的OAEP填充和RSA-PSS签名方案中与掩码生成函数MGF1一起使用的参数集合。
MGF1ParameterSpec(String) - Constructor for class java.security.spec. MGF1ParameterSpec
为PKCS＃1标准中定义的掩码生成函数MGF1构造一个参数集。
MIAO - java.lang. Character.UnicodeScript
Unicode脚本“苗”。
MIAO - Static variable in class java.lang. Character.UnicodeBlock
常量为“Miao”Unicode字符块。
MICRO_OF_DAY - java.time.temporal. ChronoField
微观的一天。
MICRO_OF_SECOND - java.time.temporal. ChronoField
微秒。
MICROPHONE - Static variable in class javax.sound.sampled. Port.Info
一种从内置麦克风或麦克风插孔获取音频的端口。
MICROS - java.time.temporal. ChronoUnit
代表微秒的概念的单位。
microsecondLength - Variable in class javax.sound.midi. MidiFileFormat
MIDI文件的持续时间（以微秒为单位）。
MICROSECONDS - java.util.concurrent. TimeUnit
时间单位代表千分之一毫秒。
MIDDLE - javafx.scene.input. MouseButton
表示中间（按钮2）鼠标按钮。
MIDDLE - Static variable in class javafx.print. PaperSource
指定选择MIDDLE纸盘。
MIDDLE - Static variable in class javax.print.attribute.standard. MediaTray
打印机中的中间进纸盘。
MIDI_SYNC - Static variable in class javax.sound.midi. Sequencer.SyncMode
主或从同步模式，指定使用MIDI时钟消息。
MIDI_TIME_CODE - Static variable in class javax.sound.midi. Sequencer.SyncMode
指定使用MIDI时间码的主或从同步模式。
MIDI_TIME_CODE - Static variable in class javax.sound.midi. ShortMessage
MIDI时间码四分之一帧消息（0xF1或241）的状态字节。
MidiChannel - Interface in javax.sound.midi
MidiChannel对象表示单个MIDI通道。
MidiDevice - Interface in javax.sound.midi
MidiDevice是所有MIDI设备的基础接口。
MidiDevice.Info - Class in javax.sound.midi
A MidiDevice.Info对象包含有关MidiDevice的各种数据，包括其名称，创建它的公司和描述性文本。
MidiDeviceProvider - Class in javax.sound.midi.spi
A MidiDeviceProvider是特定类型的MIDI设备的工厂或提供商。
MidiDeviceProvider() - Constructor for class javax.sound.midi.spi. MidiDeviceProvider
MidiDeviceReceiver - Interface in javax.sound.midi
MidiDeviceReceiver是 Receiver其表示的MIDI输入连接器 MidiDevice （见 MidiDevice.getReceiver() ）。
MidiDeviceTransmitter - Interface in javax.sound.midi
MidiDeviceTransmitter是 Transmitter其表示的MIDI输入连接器 MidiDevice （见 MidiDevice.getTransmitter() ）。
MidiEvent - Class in javax.sound.midi
MIDI事件包含一个MIDI消息和相应的时间戳记，以秒表形式表示，并且可以表示存储在MIDI文件或Sequence对象中的MIDI事件信息。
MidiEvent(MidiMessage, long) - Constructor for class javax.sound.midi. MidiEvent
构造新的 MidiEvent 。
MidiFileFormat - Class in javax.sound.midi
一个 MidiFileFormat对象封装了一个MIDI文件的类型，以及它的长度和时间信息。
MidiFileFormat(int, float, int, int, long) - Constructor for class javax.sound.midi. MidiFileFormat
构造一个 MidiFileFormat 。
MidiFileFormat(int, float, int, int, long, Map<String, Object>) - Constructor for class javax.sound.midi. MidiFileFormat
构造一个 MidiFileFormat与一组属性。
MidiFileReader - Class in javax.sound.midi.spi
A MidiFileReader提供MIDI文件阅读服务。
MidiFileReader() - Constructor for class javax.sound.midi.spi. MidiFileReader
MidiFileWriter - Class in javax.sound.midi.spi
A MidiFileWriter提供MIDI文件写入服务。
MidiFileWriter() - Constructor for class javax.sound.midi.spi. MidiFileWriter
MidiMessage - Class in javax.sound.midi
MidiMessage是MIDI消息的基类。
MidiMessage(byte[]) - Constructor for class javax.sound.midi. MidiMessage
构造新的 MidiMessage 。
MidiSystem - Class in javax.sound.midi
MidiSystem课程提供对安装的MIDI系统资源的访问，包括合成器，音序器和MIDI输入和输出端口等设备。
MidiUnavailableException - Exception in javax.sound.midi
当请求的MIDI组件由于不可用而无法打开或创建时，将抛出 MidiUnavailableException 。
MidiUnavailableException() - Constructor for exception javax.sound.midi. MidiUnavailableException
构造一个 MidiUnavailableException ，它具有 null作为其错误详细消息。
MidiUnavailableException(String) - Constructor for exception javax.sound.midi. MidiUnavailableException
构造具有指定详细消息的 MidiUnavailableException 。
MIDNIGHT - Static variable in class java.time. LocalTime
午夜开始的时候，'00：00'。
MIDNIGHTBLUE - Static variable in class javafx.scene.paint. Color
颜色为午夜蓝色，RGB值为＃191970
midpoint(double, double) - Method in class javafx.geometry. Point2D
返回位于该点与指定坐标之间的中间点。
midpoint(double, double, double) - Method in class javafx.geometry. Point3D
返回位于该点与指定坐标之间的中间点。
midpoint(Point2D) - Method in class javafx.geometry. Point2D
返回位于该点与指定点之间的中点。
midpoint(Point3D) - Method in class javafx.geometry. Point3D
返回位于该点与指定点之间的中点。
MILLENNIA - java.time.temporal. ChronoUnit
代表千年概念的单位。
MILLI_OF_DAY - java.time.temporal. ChronoField
毫无疑问
MILLI_OF_SECOND - java.time.temporal. ChronoField
毫秒。
millis() - Method in class java.time. Clock
获取时钟的当前毫秒时间。
millis(double) - Static method in class javafx.util. Duration
返回一个指定数毫秒的Duration实例的Factory方法。
MILLIS - java.time.temporal. ChronoUnit
代表毫秒概念的单位。
MILLISECOND - Static variable in class java.text. DateFormat.Field
常量标识毫秒字段。
MILLISECOND - Static variable in class java.util. Calendar
get字段编号和 set表示秒内的毫秒数。
MILLISECOND_FIELD - Static variable in class java.text. DateFormat
MILLISECOND字段对齐的常用常数。
MILLISECONDS - java.util.concurrent. TimeUnit
时间单位为千分之一秒。
MimeHeader - Class in javax.xml.soap
一个存储MIME头名称及其值的对象。
MimeHeader(String, String) - Constructor for class javax.xml.soap. MimeHeader
构造一个以给定名称和值初始化的 MimeHeader对象。
MimeHeaders - Class in javax.xml.soap
一个 MimeHeader对象的容器，它们表示消息的MIME部分中出现的MIME头。
MimeHeaders() - Constructor for class javax.xml.soap. MimeHeaders
构造一个默认 MimeHeaders用空初始化的对象 Vector对象。
MimeType - Class in javax.activation
多功能Internet邮件扩展（MIME）类型，如RFC 2045和2046中所定义。
MimeType() - Constructor for class javax.activation. MimeType
默认构造函数。
MimeType(String) - Constructor for class javax.activation. MimeType
从String构建MimeType的构造方法。
MimeType(String, String) - Constructor for class javax.activation. MimeType
构造函数，它使用给定的主类型和子类型构建MimeType，但具有空参数列表。
MimeTypeParameterList - Class in javax.activation
RFC 2045和2046中定义的MimeType的参数列表。
MimeTypeParameterList() - Constructor for class javax.activation. MimeTypeParameterList
默认构造函数。
MimeTypeParameterList(String) - Constructor for class javax.activation. MimeTypeParameterList
使用传入的数据构造一个新的MimeTypeParameterList。
MimeTypeParseException - Exception in java.awt.datatransfer
封装MimeType解析相关异常的类。
MimeTypeParseException - Exception in javax.activation
封装MimeType解析相关异常的类。
MimeTypeParseException() - Constructor for exception java.awt.datatransfer. MimeTypeParseException
构造一个没有指定的详细信息的MimeTypeParseException。
MimeTypeParseException() - Constructor for exception javax.activation. MimeTypeParseException
构造一个没有指定的详细信息的MimeTypeParseException。
MimeTypeParseException(String) - Constructor for exception java.awt.datatransfer. MimeTypeParseException
构造具有指定详细消息的MimeTypeParseException。
MimeTypeParseException(String) - Constructor for exception javax.activation. MimeTypeParseException
构造具有指定详细消息的MimeTypeParseException。
MIMETypes - Variable in class javax.imageio.spi. ImageReaderWriterSpi
要从 getMIMETypes返回的字符串数组，最初为 null 。
MimetypesFileTypeMap - Class in javax.activation
该类扩展了FileTypeMap，并通过其文件扩展名提供了文件的数据输入。
MimetypesFileTypeMap() - Constructor for class javax.activation. MimetypesFileTypeMap
默认构造函数。
MimetypesFileTypeMap(InputStream) - Constructor for class javax.activation. MimetypesFileTypeMap
构造一个MimetypesFileTypeMap，其中包含从InputStream中添加的程序化条目。
MimetypesFileTypeMap(String) - Constructor for class javax.activation. MimetypesFileTypeMap
构造MimetypesFileTypeMap，并从命名文件中添加程序化条目。
min() - Method in interface com.sun.jdi.connect. Connector.IntegerArgument
价值的下限。
min() - Method in interface java.util.stream. DoubleStream
返回描述此流的最小元素的 OptionalDouble ，如果此流为空，则返回空的OptionalDouble。
min() - Method in interface java.util.stream. IntStream
返回描述此流的最小元素的 OptionalInt ，如果此流为空，则返回一个空的可选项。
min() - Method in interface java.util.stream. LongStream
返回描述此流的最小元素的 OptionalLong ，如果此流为空，则返回一个空的可选项。
min(double, double) - Static method in class java.lang. Double
返回两个 double中的较小值，如同通过调用 Math.min一样 。
min(double, double) - Static method in class java.lang. Math
返回两个 double中的较小值。
min(double, double) - Static method in class java.lang. StrictMath
返回两个 double中的较小值。
min(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，它计算一个ObservableNumberValue的值的最小值和一个恒定值。
min(float, float) - Static method in class java.lang. Float
返回两个 float中的较小值，就像调用 Math.min一样 。
min(float, float) - Static method in class java.lang. Math
返回两个 float中的较小值。
min(float, float) - Static method in class java.lang. StrictMath
返回两个 float中的较小值。
min(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
min(int, int) - Static method in class java.lang. Integer
返回两个 int中的较小值，就像调用 Math.min一样 。
min(int, int) - Static method in class java.lang. Math
返回两个 int中的较小值。
min(int, int) - Static method in class java.lang. StrictMath
返回两个 int中的较小值。
min(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值的最小值和常数值。
min(long, long) - Static method in class java.lang. Long
返回两个 long中的较小值，如同通过调用 Math.min一样 。
min(long, long) - Static method in class java.lang. Math
返回两个 long中的较小值。
min(long, long) - Static method in class java.lang. StrictMath
返回两个 long中的较小值。
min(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最小值和一个恒定值。
min(BigDecimal) - Method in class java.math. BigDecimal
返回此 BigDecimal和 val 。
min(BigInteger) - Method in class java.math. BigInteger
返回此BigInteger和 val 。
min(Collection<? extends T>) - Static method in class java.util. Collections
根据其元素的 自然顺序返回给定集合的最小元素。
min(Collection<? extends T>, Comparator<? super T>) - Static method in class java.util. Collections
根据指定的比较器引发的顺序返回给定集合的最小元素。
min(Comparator<? super T>) - Method in interface java.util.stream. Stream
根据提供的 Comparator返回此流的最小元素。
min(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，计算ObservableNumberValue的值的最小值和常数值。
min(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算值为ObservableNumberValue的最小值和常数值。
min(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最小值和一个恒定值。
min(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算一个ObservableNumberValue的值的最小值和一个恒定值。
min(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue两个实例的值的最小值 。
min(Priority, Priority) - Static method in enum javafx.scene.layout. Priority
方便返回两个优先级较低的方法。
MIN - Static variable in class java.time. Instant
最低支持 Instant ，'-1000000000-01-01T00：00Z'。
MIN - Static variable in class java.time. LocalDate
最低支持 LocalDate ，'- LocalDate '。
MIN - Static variable in class java.time. LocalDateTime
最低支持 LocalDateTime ：00：00'。
MIN - Static variable in class java.time. LocalTime
最低支持 LocalTime ：00'。
MIN - Static variable in class java.time. OffsetDateTime
最低支持 OffsetDateTime ：00：00 + 18：00'。
MIN - Static variable in class java.time. OffsetTime
最低支持 OffsetTime ：00：00 + 18：00'。
MIN - Static variable in class java.time. ZoneOffset
最小支持偏移量的常数。
MIN_CODE_POINT - Static variable in class java.lang. Character
最小值为 Unicode code point ，常数为 U+0000 。
MIN_DATATYPE - Static variable in class javax.imageio.plugins.tiff. TIFFTag
表示TIFF数据类型的数字最小的常数。
MIN_EXPONENT - Static variable in class java.lang. Double
最小指数归一化 double变量可能有。
MIN_EXPONENT - Static variable in class java.lang. Float
最小指数归一化 float变量可能有。
MIN_GAIN - Static variable in class javafx.scene.media. EqualizerBand
最小可能的增益值。
MIN_HIGH_SURROGATE - Static variable in class java.lang. Character
一个 Unicode high-surrogate code unit的最小值在UTF-16编码中，常数为 '\uD800' 。
MIN_LOW_SURROGATE - Static variable in class java.lang. Character
最小值为 Unicode low-surrogate code unit ，在UTF-16编码中，常数为 '\uDC00' 。
MIN_NORMAL - Static variable in class java.lang. Double
一个常数保持 double型最小的正常值，2 -1022 。
MIN_NORMAL - Static variable in class java.lang. Float
常数保持类型为 float的最小正常值，2 -126 。
MIN_PRIORITY - Static variable in class java.lang. Thread
线程可以拥有的最小优先级。
MIN_RADIX - Static variable in class java.lang. Character
可用于转换到字符串和从字符串转换的最小基数。
MIN_SCROLL - Static variable in class javax.swing.plaf.basic. BasicSliderUI
最小滚动
MIN_SUPPLEMENTARY_CODE_POINT - Static variable in class java.lang. Character
最小值为 Unicode supplementary code point ，常数为 U+10000 。
MIN_SURROGATE - Static variable in class java.lang. Character
UTF-16编码中的Unicode代理代码单元的最小值，常数为 '\uD800' 。
MIN_TIMEZONE_OFFSET - Static variable in class javax.xml.datatype. DatatypeConstants
W3C XML Schema最小时区偏移为+14：00。
MIN_VALUE - javafx.scene. AccessibleAttribute
返回节点的最小值。
MIN_VALUE - Static variable in class java.lang. Byte
的常量保持的最小值的 byte可以具有，-2 7。
MIN_VALUE - Static variable in class java.lang. Character
该字段的常数值是 char '\u0000' 。
MIN_VALUE - Static variable in class java.lang. Double
一个常数保持最小的正非零值，类型为 double -1074 。
MIN_VALUE - Static variable in class java.lang. Float
一个常数保持最小的正非零值，类型为 float -149 。
MIN_VALUE - Static variable in class java.lang. Integer
持有最小值的常数为 int可以为-2 31 。
MIN_VALUE - Static variable in class java.lang. Long
一个保持最小值的常数a long可以具有-2 63 。
MIN_VALUE - Static variable in class java.lang. Short
的常量保持的最小值的 short可以具有，-2 15。
MIN_VALUE - Static variable in class java.time. Year
最低支持年份为'-999,999,999'。
MIN_VALUE_FIELD - Static variable in class javax.management. JMX
名称为 minValue字段。
MIN_WEIGHT - Static variable in class java.util. Locale.LanguageRange
保持最小权重值的常数为0.0，表示语言范围不适合用户。
minBy(Comparator<? super T>) - Static method in interface java.util.function. BinaryOperator
返回一个BinaryOperator ，它根据指定的Comparator返回两个元素中的较小者。
minBy(Comparator<? super T>) - Static method in class java.util.stream. Collectors
返回一个 Collector ，它根据给定的 Comparator产生最小元素，描述为 Optional<T> 。
MinguoChronology - Class in java.time.chrono
国际日历系统。
MinguoDate - Class in java.time.chrono
在日语系统中的日期。
MinguoEra - Enum in java.time.chrono
国际日历系统中的一个时代。
minHeight(double) - Method in class javafx.embed.swing. SwingNode
返回 SwingNode的最小高度用于布局计算。
minHeight(double) - Method in class javafx.scene.control. PopupControl
在布局期间调用以确定此节点的最小高度。
minHeight(double) - Method in class javafx.scene. Group
minHeight(double) - Method in class javafx.scene.layout. Region
在布局期间调用以确定此节点的最小高度。
minHeight(double) - Method in class javafx.scene. Node
返回节点在布局计算中使用的最小高度。
minHeight(double) - Method in class javafx.scene. Parent
minHeight(double) - Method in class javafx.scene.web. WebView
在布局期间调用以确定此节点的最小高度。
minHeightProperty() - Method in class javafx.scene.control. PopupControl
超越控制计算的最小高度的属性。
minHeightProperty() - Method in class javafx.scene.layout. Region
覆盖该地区计算最小高度的属性。
minHeightProperty() - Method in class javafx.scene.layout. RowConstraints
行的最小高度。
minHeightProperty() - Method in class javafx.scene.web. WebView
最小高度属性。
minHeightProperty() - Method in class javafx.stage. Stage
定义 Stage的最小高度。
MINI_KEY - Static variable in class javax.swing.plaf.nimbus. NimbusStyle
迷你钥匙
MINI_SCALE - Static variable in class javax.swing.plaf.nimbus. NimbusStyle
迷你刻度
minIcon - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
最小化图标。
minimalCompletionStage() - Method in class java.util.concurrent. CompletableFuture
返回一个新的CompletionStage，它在正常完成时正常完成与此CompletableFuture相同的值，并且不能以未由接口CompletionStage定义的方式独立完成或以其他方式使用。
MinimalHTMLWriter - Class in javax.swing.text.html
MinimalHTMLWriter是由HTMLEditorKit用于为不是由EditorKit生成的文档编写HTML的后备书写器。
MinimalHTMLWriter(Writer, StyledDocument) - Constructor for class javax.swing.text.html. MinimalHTMLWriter
创建一个新的MinimalHTMLWriter。
MinimalHTMLWriter(Writer, StyledDocument, int, int) - Constructor for class javax.swing.text.html. MinimalHTMLWriter
创建一个新的MinimalHTMLWriter。
MinimizeAction() - Constructor for class javax.swing.plaf.basic. BasicDesktopPaneUI.MinimizeAction
minimizeFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
在 maximizeFrame呼叫之前将帧恢复到其大小和位置。
minimizeFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager
一般来说，这表明在maximFrame（）调用之前，框架应该恢复到其大小和位置。
minimizeFrame(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
当用户想要最小化帧时调用此方法。
minimizeKey - Variable in class javax.swing.plaf.basic. BasicDesktopPaneUI
已过时。
截至1.3。
minimum - Variable in class javax.swing. SizeRequirements
所需最小尺寸
MinimumHeight - Static variable in class javax.swing.plaf.basic. BasicOptionPaneUI
JOptionPane高度为 JOptionPane 。
minimumLayoutSize(Container) - Method in class java.awt. BorderLayout
使用此布局管理器确定 target容器的最小大小。
minimumLayoutSize(Container) - Method in class java.awt. CardLayout
计算指定面板的最小尺寸。
minimumLayoutSize(Container) - Method in class java.awt. FlowLayout
返回布局指定目标容器中包含的 可见组件所需的最小尺寸。
minimumLayoutSize(Container) - Method in class java.awt. GridBagLayout
使用此网格包布局确定 parent容器的最小尺寸。
minimumLayoutSize(Container) - Method in class java.awt. GridLayout
使用此网格布局确定容器参数的最小大小。
minimumLayoutSize(Container) - Method in interface java.awt. LayoutManager
计算指定容器的最小尺寸尺寸，给定其包含的组件。
minimumLayoutSize(Container) - Method in class javax.swing. BoxLayout
返回布局包含在指定目标容器中的组件所需的最小尺寸。
minimumLayoutSize(Container) - Method in class javax.swing. GroupLayout
返回指定容器的最小大小。
minimumLayoutSize(Container) - Method in class javax.swing. JRootPane.RootLayout
返回布局所需的最小空间量。
minimumLayoutSize(Container) - Method in class javax.swing. JSpinner.DefaultEditor
返回第一个（且仅））小孩的最小大小加上父母插入的大小。
minimumLayoutSize(Container) - Method in class javax.swing. OverlayLayout
返回布局包含在指定目标容器中的组件所需的最小尺寸。
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ComboBoxLayoutManager
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.TitlePaneLayout
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFrameLayout
计算指定容器的最小尺寸尺寸，给定其包含的组件。
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DividerLayout
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
返回包含子项所需的最小大小。
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
minimumLayoutSize(Container) - Method in class javax.swing. ScrollPaneLayout
ScrollPane的最小大小是 ScrollPane的大小加上视口的最小尺寸，加上滚动窗口的viewportBorder插入，加上可见标题的最小大小，以及displayPolicy不是永远不会滚动条的最小大小。
minimumLayoutSize(Container) - Method in class javax.swing. SpringLayout
minimumLayoutSize(Container) - Method in class javax.swing. ViewportLayout
返回布局指定目标容器中包含的组件所需的最小尺寸。
minimumSize - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI
大小 JOptionPane 。
minimumSize() - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，替换为getMinimumSize() 。
minimumSize() - Method in class java.awt. Container
已过时。
从JDK 1.1版开始，由getMinimumSize()替代。
minimumSize() - Method in class java.awt. List
已过时。
从JDK 1.1版开始，由getMinimumSize()替代。
minimumSize() - Method in class java.awt. TextArea
已过时。
从JDK 1.1版开始，由getMinimumSize()代替。
minimumSize() - Method in class java.awt. TextField
已过时。
从JDK 1.1版开始，由getMinimumSize()替代。
minimumSize(int) - Method in class java.awt. List
已过时。
从JDK 1.1版开始，由getMinimumSize(int)替代。
minimumSize(int) - Method in class java.awt. TextField
已过时。
从JDK 1.1版开始，由getMinimumSize(int)替代。
minimumSize(int, int) - Method in class java.awt. TextArea
已过时。
从JDK 1.1版开始，由getMinimumSize(int, int)替代。
minimumThumbSize - Variable in class javax.swing.plaf.basic. BasicScrollBarUI
最小拇指尺寸
MinimumWidth - Static variable in class javax.swing.plaf.basic. BasicOptionPaneUI
JOptionPane宽度为 JOptionPane 。
minIndex - Variable in class javax.imageio. ImageReader
读取的最小有效索引，最初为0。
minLength() - Method in enum java.time. Month
以天为单位获得本月的最小长度。
minor - Variable in exception org.omg.CORBA. SystemException
CORBA异常次要代码。
minor() - Method in class java.lang. Runtime.Version
如果未设置，则返回 minor版本号或零。
minor_version - Variable in class org.omg.IOP. Encoding
此编码格式的次要版本。
minorInterfaceVersion() - Method in interface com.sun.jdi. VirtualMachineManager
返回JDI接口的次要版本号。
minorRequirementChange(AsyncBoxView.ChildState) - Method in class javax.swing.text. AsyncBoxView
要求沿着短轴改变。
minorTickCountProperty() - Method in class javafx.scene.chart. ValueAxis
每个主要刻度线之间显示的小刻度分割数。
minorTickCountProperty() - Method in class javafx.scene.control. Slider
任何两个主要蜱之间的次要蜱的数量。
minorTickLengthProperty() - Method in class javafx.scene.chart. ValueAxis
小刻度线的长度。
minorTickSpacing - Variable in class javax.swing. JSlider
较小刻度线之间的值数 - 主刻度线之间发生的较小的标记。
minorTickVisibleProperty() - Method in class javafx.scene.chart. ValueAxis
如果显示较小的刻度线，则为真
minorVersion() - Method in interface com.sun.jdi. ReferenceType
返回类的次要版本号，如Java虚拟机规范的类文件格式所定义。
minProgressivePass - Variable in class javax.imageio. ImageReadParam
从源读取的逐行传递的最小索引。
minProperty() - Method in class javafx.scene.control. ScrollBar
由该 ScrollBar表示的 ScrollBar 。
minProperty() - Method in class javafx.scene.control. Slider
由此滑块表示的最小值。
minProperty() - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory
设置该值工厂的最小允许值
minProperty() - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory
设置该值工厂的最小允许值
MINSIZE - Static variable in class java.awt. GridBagLayout
可以通过网格布局布局的最小网格。
minTabWidth - Variable in class javax.swing.plaf.metal. MetalTabbedPaneUI
窗格的最小宽度。
MINTCREAM - Static variable in class javafx.scene.paint. Color
颜色薄荷奶油，RGB值为＃F5FFFA
minus(long) - Method in enum java.time. DayOfWeek
返回指定天数之前的星期几。
minus(long) - Method in enum java.time. Month
返回指定月份之前的月份。
minus(long, TemporalUnit) - Method in interface java.time.chrono. ChronoLocalDate
返回与该对象相同类型的对象，并减去指定的时间段。
minus(long, TemporalUnit) - Method in interface java.time.chrono. ChronoLocalDateTime
返回与该对象相同类型的对象，并减去指定的时间段。
minus(long, TemporalUnit) - Method in interface java.time.chrono. ChronoZonedDateTime
返回与该对象相同类型的对象，并减去指定的时间段。
minus(long, TemporalUnit) - Method in class java.time.chrono. HijrahDate
minus(long, TemporalUnit) - Method in class java.time.chrono. JapaneseDate
minus(long, TemporalUnit) - Method in class java.time.chrono. MinguoDate
minus(long, TemporalUnit) - Method in class java.time.chrono. ThaiBuddhistDate
minus(long, TemporalUnit) - Method in class java.time. Duration
返回指定持续时间的副本减去。
minus(long, TemporalUnit) - Method in class java.time. Instant
返回此时刻的副本，减去指定的金额。
minus(long, TemporalUnit) - Method in class java.time. LocalDate
返回此日期的副本，减去指定的金额。
minus(long, TemporalUnit) - Method in class java.time. LocalDateTime
返回此日期时间的副本，并减去指定的金额。
minus(long, TemporalUnit) - Method in class java.time. LocalTime
返回此次的副本，减去指定的金额。
minus(long, TemporalUnit) - Method in class java.time. OffsetDateTime
返回此日期时间的副本，并减去指定的金额。
minus(long, TemporalUnit) - Method in class java.time. OffsetTime
返回此次的副本，减去指定的金额。
minus(long, TemporalUnit) - Method in interface java.time.temporal. Temporal
返回与该对象相同类型的对象，并减去指定的时间段。
minus(long, TemporalUnit) - Method in class java.time. Year
返回今年的副本，减去指定的金额。
minus(long, TemporalUnit) - Method in class java.time. YearMonth
返回减去指定数量的今年的副本。
minus(long, TemporalUnit) - Method in class java.time. ZonedDateTime
返回此日期时间的副本，并减去指定的金额。
minus(Duration) - Method in class java.time. Duration
返回指定持续时间的副本减去。
minus(TemporalAmount) - Method in interface java.time.chrono. ChronoLocalDate
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in interface java.time.chrono. ChronoLocalDateTime
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in interface java.time.chrono. ChronoPeriod
返回此期间的副本，并减去指定的时间段。
minus(TemporalAmount) - Method in interface java.time.chrono. ChronoZonedDateTime
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in class java.time.chrono. HijrahDate
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in class java.time.chrono. JapaneseDate
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in class java.time.chrono. MinguoDate
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in class java.time.chrono. ThaiBuddhistDate
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in class java.time. Instant
返回此时刻的副本，减去指定的金额。
minus(TemporalAmount) - Method in class java.time. LocalDate
返回此日期的副本，减去指定的金额。
minus(TemporalAmount) - Method in class java.time. LocalDateTime
返回此日期时间的副本，并减去指定的金额。
minus(TemporalAmount) - Method in class java.time. LocalTime
返回此次的副本，减去指定的金额。
minus(TemporalAmount) - Method in class java.time. OffsetDateTime
返回此日期时间的副本，并减去指定的金额。
minus(TemporalAmount) - Method in class java.time. OffsetTime
返回此次的副本，减去指定的金额。
minus(TemporalAmount) - Method in class java.time. Period
返回此期间的副本，并减去指定的时间段。
minus(TemporalAmount) - Method in interface java.time.temporal. Temporal
返回与该对象相同类型的对象，并减去一个数量。
minus(TemporalAmount) - Method in class java.time. Year
返回今年的副本，减去指定的金额。
minus(TemporalAmount) - Method in class java.time. YearMonth
返回减去指定数量的今年的副本。
minus(TemporalAmount) - Method in class java.time. ZonedDateTime
返回此日期时间的副本，并减去指定的金额。
minus(ValueExp, ValueExp) - Static method in class javax.management. Query
返回表示两个数值之间的差异的二进制表达式。
minus(Spring) - Static method in class javax.swing. Spring
返回 -s ：弹簧的方向与 s相反。
MINUS - com.sun.source.tree. Tree.Kind
用于BinaryTree的实例，表示减法- 。
MINUS - javafx.scene.input. KeyCode
常数为减号，“ - ”
MINUS - jdk.nashorn.api.tree. Tree.Kind
用于表示减法-的BinaryTree的实例。
MINUS - Static variable in class javax.management. Query
代表 Query.minus(javax.management.ValueExp, javax.management.ValueExp)表达式的代码。
MINUS_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于表示减法分配-=的CompoundAssignmentTree的实例。
MINUS_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于表示减法分配-=的CompoundAssignmentTree的实例。
minusDays(long) - Method in class java.time. Duration
在标准的24小时内减去指定的持续时间，返回此持续时间的副本。
minusDays(long) - Method in class java.time. LocalDate
返回此 LocalDate的副本，并减去指定的天数。
minusDays(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并减去指定的天数。
minusDays(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的天数。
minusDays(long) - Method in class java.time. Period
返回此期间的副本，并减去指定的天数。
minusDays(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并减去指定的天数。
minusHours(long) - Method in class java.time. Duration
以缩小的小时返回指定持续时间的此持续时间的副本。
minusHours(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并减去指定的小时数。
minusHours(long) - Method in class java.time. LocalTime
返回此 LocalTime的副本，并减去指定的小时数。
minusHours(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的小时数。
minusHours(long) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并减去指定的小时数。
minusHours(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并减去指定的小时数。
minusMillis(long) - Method in class java.time. Duration
以指定的持续时间返回此持续时间的副本，以毫秒为单位。
minusMillis(long) - Method in class java.time. Instant
以毫秒为单位的指定持续时间返回此瞬间的副本。
minusMinutes(long) - Method in class java.time. Duration
以指定的持续时间返回此持续时间的副本，以分钟为单位。
minusMinutes(long) - Method in class java.time. LocalDateTime
以指定的分钟数减去此 LocalDateTime的副本。
minusMinutes(long) - Method in class java.time. LocalTime
返回此 LocalTime的副本，并减去指定的分钟数。
minusMinutes(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的分钟数。
minusMinutes(long) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并减去指定的分钟数。
minusMinutes(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并减去指定的分钟数。
minusMonths(long) - Method in class java.time. LocalDate
返回此 LocalDate的副本，并减去指定的月数。
minusMonths(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并减去指定的月数。
minusMonths(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的月数。
minusMonths(long) - Method in class java.time. Period
返回此期间的副本，减去指定的月份。
minusMonths(long) - Method in class java.time. YearMonth
返回此 YearMonth的副本，并减去指定的月数。
minusMonths(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并减去指定的月数。
minusNanos(long) - Method in class java.time. Duration
以指定的持续时间返回此持续时间的副本，减去纳秒。
minusNanos(long) - Method in class java.time. Instant
以纳秒为单位返回指定持续时间的此瞬间的副本。
minusNanos(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并减去指定的纳秒数。
minusNanos(long) - Method in class java.time. LocalTime
返回此 LocalTime的副本，减去指定的纳秒数。
minusNanos(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的纳秒数。
minusNanos(long) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并减去指定的纳秒数。
minusNanos(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并减去指定的纳秒数。
minusSeconds(long) - Method in class java.time. Duration
以指定的持续时间返回此持续时间的副本，以秒为单位。
minusSeconds(long) - Method in class java.time. Instant
以秒为单位返回指定持续时间的此瞬间的副本。
minusSeconds(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并减去指定的秒数。
minusSeconds(long) - Method in class java.time. LocalTime
返回此 LocalTime的副本，并减去指定的秒数。
minusSeconds(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的秒数。
minusSeconds(long) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并减去指定的秒数。
minusSeconds(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并减去指定的秒数。
minusWeeks(long) - Method in class java.time. LocalDate
返回此 LocalDate的副本，并 LocalDate指定的周数。
minusWeeks(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并减去指定的星期数。
minusWeeks(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的周数。
minusWeeks(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并 ZonedDateTime指定的周数。
minusYears(long) - Method in class java.time. LocalDate
返回此 LocalDate的副本，减去指定的年数。
minusYears(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，减去指定的年数。
minusYears(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并减去指定的年数。
minusYears(long) - Method in class java.time. Period
返回此期间的副本，并减去指定的年数。
minusYears(long) - Method in class java.time. Year
返回此 Year的副本，减去指定的年数。
minusYears(long) - Method in class java.time. YearMonth
返回此 YearMonth的副本，并减去指定的年数。
minusYears(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并减去指定的年数。
MINUTE - Static variable in class java.text. DateFormat.Field
常数识别分钟字段。
MINUTE - Static variable in class java.util. Calendar
get字段编号和 set表示小时内的分钟。
MINUTE_FIELD - Static variable in class java.text. DateFormat
MINUTE字段对齐的常用常数。
MINUTE_OF_DAY - java.time.temporal. ChronoField
一天的时间。
MINUTE_OF_HOUR - java.time.temporal. ChronoField
分钟的小时。
minutes(double) - Static method in class javafx.util. Duration
返回一个表示指定分钟数的Duration实例的Factory方法。
MINUTES - java.time.temporal. ChronoUnit
代表一分钟概念的单位。
MINUTES - java.util.concurrent. TimeUnit
时间单位代表60秒。
MINUTES - Static variable in class javax.xml.datatype. DatatypeConstants
表示分钟字段的常数。
minViewportHeightProperty() - Method in class javafx.scene.control. ScrollPane
指定ScrollPane视口的最小高度。
minViewportWidthProperty() - Method in class javafx.scene.control. ScrollPane
指定ScrollPane视口的最小宽度。
minWidth - Variable in class javax.swing.table. TableColumn
列的最小宽度。
minWidth(double) - Method in class javafx.embed.swing. SwingNode
返回 SwingNode用于布局计算的最小宽度。
minWidth(double) - Method in class javafx.scene.control. PopupControl
在布局期间调用以确定此节点的最小宽度。
minWidth(double) - Method in class javafx.scene. Group
minWidth(double) - Method in class javafx.scene.layout. Region
在布局期间调用以确定此节点的最小宽度。
minWidth(double) - Method in class javafx.scene. Node
返回节点在布局计算中使用的最小宽度。
minWidth(double) - Method in class javafx.scene. Parent
minWidth(double) - Method in class javafx.scene.web. WebView
在布局期间调用以确定此节点的最小宽度。
minWidthProperty() - Method in class javafx.scene.control. PopupControl
覆盖控制计算最小宽度的属性。
minWidthProperty() - Method in class javafx.scene.control. TableColumnBase
允许表列调整大小的最小宽度。
minWidthProperty() - Method in class javafx.scene.layout. ColumnConstraints
列的最小宽度。
minWidthProperty() - Method in class javafx.scene.layout. Region
覆盖该地区计算出的最小宽度的属性。
minWidthProperty() - Method in class javafx.scene.web. WebView
最小宽度属性。
minWidthProperty() - Method in class javafx.stage. Stage
定义这个 Stage的最小宽度。
minX - Variable in class java.awt.image. Raster
此栅格左上角像素的X坐标。
minY - Variable in class java.awt.image. Raster
此光栅左上角像素的Y坐标。
Mirror - Interface in com.sun.jdi
调试器使用的代理来检查或操纵另一个虚拟机中的某个实体。
MirroredTypeException - Exception in javax.lang.model.type
当应用程序尝试访问对应于TypeMirror的Class对象时抛出 。
MirroredTypeException(TypeMirror) - Constructor for exception javax.lang.model.type. MirroredTypeException
为指定的类型构造一个新的MirroredTypeException。
MirroredTypesException - Exception in javax.lang.model.type
当应用程序试图访问的序列抛出Class个每一个对应于对象TypeMirror 。
MirroredTypesException(List<? extends TypeMirror>) - Constructor for exception javax.lang.model.type. MirroredTypesException
为指定的类型构造一个新的MirroredTypesException。
mirrorOf(boolean) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个BooleanValue 。
mirrorOf(byte) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个ByteValue 。
mirrorOf(char) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个CharValue 。
mirrorOf(double) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个DoubleValue 。
mirrorOf(float) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个FloatValue 。
mirrorOf(int) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个IntegerValue 。
mirrorOf(long) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个LongValue 。
mirrorOf(short) - Method in interface com.sun.jdi. VirtualMachine
为给定值创建一个ShortValue 。
mirrorOf(String) - Method in interface com.sun.jdi. VirtualMachine
在此虚拟机中创建一个字符串。
mirrorOfVoid() - Method in interface com.sun.jdi. VirtualMachine
创建一个VoidValue 。
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A - Static variable in class java.lang. Character.UnicodeBlock
“Miscellaneous Mathematical Symbols-A”Unicode字符块的常数。
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B - Static variable in class java.lang. Character.UnicodeBlock
“Miscellaneous Mathematical Symbols-B”Unicode字符块的常数。
MISCELLANEOUS_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
“杂项符号”Unicode字符块的常量。
MISCELLANEOUS_SYMBOLS_AND_ARROWS - Static variable in class java.lang. Character.UnicodeBlock
“杂项符号和箭头”Unicode字符块的常量。
MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS - Static variable in class java.lang. Character.UnicodeBlock
“Miscellaneous Symbols and Pictographs”Unicode字符块的常数。
MISCELLANEOUS_TECHNICAL - Static variable in class java.lang. Character.UnicodeBlock
“杂项技术”Unicode字符块的常数。
mismatch(boolean[], boolean[]) - Static method in class java.util. Arrays
查找并返回两个 boolean数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(boolean[], int, int, boolean[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 boolean数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。
mismatch(byte[], byte[]) - Static method in class java.util. Arrays
查找并返回两个 byte数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(byte[], int, int, byte[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 byte数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
mismatch(char[], char[]) - Static method in class java.util. Arrays
查找并返回两个 char数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(char[], int, int, char[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 char数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
mismatch(double[], double[]) - Static method in class java.util. Arrays
查找并返回两个 double数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(double[], int, int, double[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 double数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
mismatch(float[], float[]) - Static method in class java.util. Arrays
查找并返回两个 float数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(float[], int, int, float[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 float数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
mismatch(int[], int[]) - Static method in class java.util. Arrays
查找并返回两个 int数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(int[], int, int, int[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 int数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。
mismatch(long[], int, int, long[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 long数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。
mismatch(long[], long[]) - Static method in class java.util. Arrays
查找并返回两个 long数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(short[], int, int, short[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 short数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
mismatch(short[], short[]) - Static method in class java.util. Arrays
查找并返回两个 short数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(Object[], int, int, Object[], int, int) - Static method in class java.util. Arrays
查找并返回指定范围内两个 Object数组之间的第一个不匹配的相对索引，否则返回-1（如果未发现不匹配）。
mismatch(Object[], Object[]) - Static method in class java.util. Arrays
查找并返回两个 Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
mismatch(T[], int, int, T[], int, int, Comparator<? super T>) - Static method in class java.util. Arrays
查找并返回指定范围内的两个 Object数组之间的第一个不匹配的相对索引，否则返回-1，如果没有发现不匹配。
mismatch(T[], T[], Comparator<? super T>) - Static method in class java.util. Arrays
查找并返回两个 Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。
missing_node - Static variable in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
MissingFormatArgumentException - Exception in java.util
当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
MissingFormatArgumentException(String) - Constructor for exception java.util. MissingFormatArgumentException
使用不匹配的格式说明符构造此类的实例。
MissingFormatWidthException - Exception in java.util
需要格式宽度时抛出未检查的异常。
MissingFormatWidthException(String) - Constructor for exception java.util. MissingFormatWidthException
使用指定的格式说明符构造此类的实例。
MissingMemberHandlerFactory - Interface in jdk.dynalink.beans
用于创建方法句柄的工厂，用于链接缺少的成员行为BeansLinker 。
MissingResourceException - Exception in java.util
表示资源丢失。
MissingResourceException(String, String, String) - Constructor for exception java.util. MissingResourceException
构造具有指定信息的MissingResourceException。
MISTYROSE - Static variable in class javafx.scene.paint. Color
颜色朦胧，RGB值为＃FFE4E1
MITER - javafx.scene.shape. StrokeLineJoin
通过延伸它们的外边缘直到它们相遇来连接路段。
Mixer - Interface in javax.sound.sampled
混音器是具有一行或多行的音频设备。
Mixer.Info - Class in javax.sound.sampled
Mixer.Info课程表示有关音频混音器的信息，包括产品的名称，版本和供应商以及文本说明。
MixerProvider - Class in javax.sound.sampled.spi
特定搅拌机型号的供应商或工厂。
MixerProvider() - Constructor for class javax.sound.sampled.spi. MixerProvider
mkdir() - Method in class java.io. File
创建由此抽象路径名命名的目录。
mkdirs() - Method in class java.io. File
创建由此抽象路径名命名的目录，包括任何必需但不存在的父目录。
MLet - Class in javax.management.loading
允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
MLet() - Constructor for class javax.management.loading. MLet
使用默认委派父类ClassLoader构造新的MLet。
MLet(URL[]) - Constructor for class javax.management.loading. MLet
使用默认的委派父类ClassLoader构造指定URL的新MLet。
MLet(URL[], boolean) - Constructor for class javax.management.loading. MLet
使用默认的委派父类ClassLoader构造指定URL的新MLet。
MLet(URL[], ClassLoader) - Constructor for class javax.management.loading. MLet
为给定的URL构造一个新的MLet。
MLet(URL[], ClassLoader, boolean) - Constructor for class javax.management.loading. MLet
为给定的URL构造一个新的MLet。
MLet(URL[], ClassLoader, URLStreamHandlerFactory) - Constructor for class javax.management.loading. MLet
为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
MLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - Constructor for class javax.management.loading. MLet
为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
MLetContent - Class in javax.management.loading
该类表示 MLET标签的内容。
MLetContent(URL, Map<String, String>, List<String>, List<String>) - Constructor for class javax.management.loading. MLetContent
创建一个 MLet实例，使用从MLet文本文件中的 MLET标记读取的属性初始化。
MLetMBean - Interface in javax.management.loading
暴露MLet MBean的远程管理界面。
MM - javafx.css. SizeUnits
MM - Static variable in class javax.print.attribute. Size2DSyntax
值表示毫米（mm）单位。
MM - Static variable in class javax.print.attribute.standard. MediaPrintableArea
值表示毫米（mm）单位。
mnemonic - Variable in class javax.swing. DefaultButtonModel
按钮的助记符
Mnemonic - Class in javafx.scene.input
创建助记符时使用此类。
Mnemonic(Node, KeyCombination) - Constructor for class javafx.scene.input. Mnemonic
构造一个Mnemonic与指定的目标Node和触发KeyCombination 。
MNEMONIC - javafx.scene. AccessibleAttribute
返回节点的助记符。
MNEMONIC_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按钮的助记符的更改。
MNEMONIC_KEY - Static variable in interface javax.swing. Action
用于存储的密钥 Integer对应于所述的一个 KeyEvent键码。
mnemonicParsingProperty() - Method in class javafx.scene.control. Labeled
助记符属性启用/禁用文本解析。
mnemonicParsingProperty() - Method in class javafx.scene.control. MenuItem
助记符属性启用/禁用文本解析。
MOCCASIN - Static variable in class javafx.scene.paint. Color
颜色莫卡辛，RGB值为＃FFE4B5
mod(BigInteger) - Method in class java.math. BigInteger
返回值为 (this mod m的BigInteger）。
MODAL - Static variable in class javax.accessibility. AccessibleState
在用户可以与不同窗口中的对象进行交互之前，表示必须使用此对象完成任务。
MODAL_LAYER - Static variable in class javax.swing. JLayeredPane
定义模态层的便利对象。
Modality - Enum in javafx.stage
该枚举定义了 Stage的可能的模式类型。
modCount - Variable in class java.util. AbstractList
此列表已被 结构修改的次数 。
mode - Variable in class org.omg.Dynamic. Parameter
MODE_ASYNCHRONOUS - Static variable in interface org.w3c.dom.ls. DOMImplementationLS
创建一个异步的 LSParser 。
MODE_COPY_FROM_METADATA - Static variable in class javax.imageio. ImageWriteParam
可通入的方法，如恒定值 setTilingMode ， setProgressiveMode ，或 setCompressionMode以启用该功能用于以后的写入。
MODE_DEFAULT - Static variable in class javax.imageio. ImageWriteParam
可通入的方法，如恒定值 setTilingMode ， setProgressiveMode和 setCompressionMode启用该功能用于以后的写入。
MODE_DISABLED - Static variable in class javax.imageio. ImageWriteParam
可通入的方法，如恒定值 setTilingMode ， setProgressiveMode和 setCompressionMode到用于以后的写入禁用的特征。
MODE_EXPLICIT - Static variable in class javax.imageio. ImageWriteParam
可以传递给诸如 setTilingMode或 setCompressionMode方法的常量值，以启用将来写入的功能。
MODE_SYNCHRONOUS - Static variable in interface org.w3c.dom.ls. DOMImplementationLS
创建同步 LSParser 。
MODECHANGE - javafx.scene.input. KeyCode
常数为 Mode Change键。
model - Variable in class javax.swing. AbstractButton
确定按钮状态的数据模型。
model - Variable in class javax.swing. JProgressBar
保存进度条数据的对象。
model - Variable in class javax.swing. JScrollBar
表示滚动条最小值，最大值，范围（又称“visibleAmount”）和当前值的模型。
model - Variable in class javax.swing. JTabbedPane
默认选择模型
MODEL - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于MODEL
MODEL_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按钮模型的变化。
ModelAttribute - Static variable in class javax.swing.text. StyleConstants
用于识别具有模型视图分离的嵌入对象的模型的属性。
modelChanged - Static variable in class javax.swing.plaf.basic. BasicListUI
该位与模型更改属性有关。
modelChanged() - Method in class javax.swing.plaf.basic. BasicTextUI
标志模型更改。
MODELESS - java.awt. Dialog.ModalityType
MODELESS对话框不会阻止任何顶级窗口。
modelIndex - Variable in class javax.swing.table. TableColumn
模型中由该 TableColumn显示的列的索引。
modelListener - Variable in class javax.swing.plaf.basic. BasicScrollBarUI
模特儿听众
ModelListener() - Constructor for class javax.swing. JTabbedPane.ModelListener
ModelListener() - Constructor for class javax.swing.plaf.basic. BasicScrollBarUI.ModelListener
ModelMBean - Interface in javax.management.modelmbean
该接口必须由ModelMBeans实现。
ModelMBeanAttributeInfo - Class in javax.management.modelmbean
ModelMBeanAttributeInfo对象描述了ModelMBean的属性。
ModelMBeanAttributeInfo(String, String, Method, Method) - Constructor for class javax.management.modelmbean. ModelMBeanAttributeInfo
使用默认描述符构造一个ModelMBeanAttributeInfo对象。
ModelMBeanAttributeInfo(String, String, Method, Method, Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanAttributeInfo
构造一个ModelMBeanAttributeInfo对象。
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - Constructor for class javax.management.modelmbean. ModelMBeanAttributeInfo
使用默认描述符构造一个ModelMBeanAttributeInfo对象。
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanAttributeInfo
构造一个ModelMBeanAttributeInfo对象。
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo) - Constructor for class javax.management.modelmbean. ModelMBeanAttributeInfo
从此ModelMBeanAttributeInfo对象构造一个新的ModelMBeanAttributeInfo对象。
ModelMBeanConstructorInfo - Class in javax.management.modelmbean
ModelMBeanConstructorInfo对象描述了ModelMBean的构造函数。
ModelMBeanConstructorInfo(String, Constructor<?>) - Constructor for class javax.management.modelmbean. ModelMBeanConstructorInfo
使用默认描述符构造一个ModelMBeanConstructorInfo对象。
ModelMBeanConstructorInfo(String, Constructor<?>, Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanConstructorInfo
构造一个ModelMBeanConstructorInfo对象。
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[]) - Constructor for class javax.management.modelmbean. ModelMBeanConstructorInfo
使用默认描述符构造一个ModelMBeanConstructorInfo对象。
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanConstructorInfo
构造一个ModelMBeanConstructorInfo对象。
ModelMBeanInfo - Interface in javax.management.modelmbean
该接口由ModelMBeanInfo为每个ModelMBean实现。
ModelMBeanInfoSupport - Class in javax.management.modelmbean
此类表示ModelMBeans的元数据。
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[]) - Constructor for class javax.management.modelmbean. ModelMBeanInfoSupport
使用提供的信息创建一个ModelMBeanInfoSupport，但描述符是默认值。
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[], Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanInfoSupport
使用参数中提供的信息和描述符创建一个ModelMBeanInfoSupport。
ModelMBeanInfoSupport(ModelMBeanInfo) - Constructor for class javax.management.modelmbean. ModelMBeanInfoSupport
构造一个ModelMBeanInfoSupport，它与给定的ModelMBeanInfo重复。
ModelMBeanNotificationBroadcaster - Interface in javax.management.modelmbean
该接口必须由ModelMBeans实现。
ModelMBeanNotificationInfo - Class in javax.management.modelmbean
ModelMBeanNotificationInfo对象描述了由ModelMBean发出的通知。
ModelMBeanNotificationInfo(String[], String, String) - Constructor for class javax.management.modelmbean. ModelMBeanNotificationInfo
使用默认描述符构造一个ModelMBeanNotificationInfo对象。
ModelMBeanNotificationInfo(String[], String, String, Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanNotificationInfo
构造一个ModelMBeanNotificationInfo对象。
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo) - Constructor for class javax.management.modelmbean. ModelMBeanNotificationInfo
从此ModelMBeanNotfication对象构造一个新的ModelMBeanNotificationInfo对象。
ModelMBeanOperationInfo - Class in javax.management.modelmbean
ModelMBeanOperationInfo对象描述了ModelMBean的管理操作。
ModelMBeanOperationInfo(String, Method) - Constructor for class javax.management.modelmbean. ModelMBeanOperationInfo
使用默认描述符构造一个ModelMBeanOperationInfo对象。
ModelMBeanOperationInfo(String, Method, Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanOperationInfo
构造一个ModelMBeanOperationInfo对象。
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - Constructor for class javax.management.modelmbean. ModelMBeanOperationInfo
使用默认描述符构造一个ModelMBeanOperationInfo对象。
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - Constructor for class javax.management.modelmbean. ModelMBeanOperationInfo
构造一个ModelMBeanOperationInfo对象。
ModelMBeanOperationInfo(ModelMBeanOperationInfo) - Constructor for class javax.management.modelmbean. ModelMBeanOperationInfo
从此ModelMBeanOperation对象构造一个新的ModelMBeanOperationInfo对象。
modelStructureChanged() - Method in class javax.swing. DefaultRowSorter
当底层模型结构完全改变时调用。
modelStructureChanged() - Method in class javax.swing. RowSorter
当底层模型结构完全改变时调用。
modelToView(int) - Method in class javax.swing.text. JTextComponent
已过时。
替换为JTextComponent.modelToView2D(int)
modelToView(int, Shape) - Method in class javax.swing.text. View
已过时。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. AsyncBoxView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. BoxView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. ComponentView
提供从模型的坐标空间到视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. CompositeView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. FieldView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. GlyphView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.html. ImageView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. IconView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. PasswordView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. PlainView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text. View
提供给定字符从文档模型坐标空间到视图坐标空间的映射。
modelToView(int, Position.Bias, int, Position.Bias, Shape) - Method in class javax.swing.text. CompositeView
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(int, Position.Bias, int, Position.Bias, Shape) - Method in class javax.swing.text. View
为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
modelToView(GlyphView, int, Position.Bias, Shape) - Method in class javax.swing.text. GlyphView.GlyphPainter
提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
modelToView(JTextComponent, int) - Method in class javax.swing.plaf.basic. BasicTextUI
已过时。
替换为BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
modelToView(JTextComponent, int) - Method in class javax.swing.plaf.multi. MultiTextUI
已过时。
替换为MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)
modelToView(JTextComponent, int) - Method in class javax.swing.plaf. TextUI
已过时。
替换为TextUI.modelToView2D(JTextComponent, int, Position.Bias)
modelToView(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf.basic. BasicTextUI
已过时。
取代BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
modelToView(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf.multi. MultiTextUI
已过时。
替换为MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)
modelToView(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf. TextUI
已过时。
替换为TextUI.modelToView2D(JTextComponent, int, Position.Bias)
modelToView2D(int) - Method in class javax.swing.text. JTextComponent
将模型中的给定位置转换为视图坐标系中的一个位置。
modelToView2D(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf.basic. BasicTextUI
modelToView2D(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf.multi. MultiTextUI
modelToView2D(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf. TextUI
将模型中的给定位置转换为视图坐标系中的一个位置。
ModelWrapper() - Constructor for class javax.swing. DefaultRowSorter.ModelWrapper
创建一个新的 ModelWrapper 。
modeProperty() - Method in class javafx.scene.effect. Blend
BlendMode用于将两个输入混合在一起。
MODI - java.lang. Character.UnicodeScript
Unicode脚本“Modi”。
MODI - Static variable in class java.lang. Character.UnicodeBlock
“Modi”Unicode字符块的常量。
ModifiableObservableListBase< E> - Class in javafx.collections
抽象类作为可修改的ObservableList实现的基类。
ModifiableObservableListBase() - Constructor for class javafx.collections. ModifiableObservableListBase
MODIFICATION - Static variable in interface org.w3c.dom.events. MutationEvent
Attr已修改到位。
MODIFICATION_TIME - Static variable in interface java.util.jar. Pack200.Packer
如果此属性设置为特殊字符串 Pack200.Packer.LATEST ，则 打包程序将尝试确定最初修改时间，原始存档中的所有可用条目或每个段中所有可用条目的最新修改时间。
ModificationItem - Class in javax.naming.directory
此类表示修改项。
ModificationItem(int, Attribute) - Constructor for class javax.naming.directory. ModificationItem
创建一个新的ModificationItem实例。
ModificationWatchpointEvent - Interface in com.sun.jdi.event
通知目标VM中的字段修改。
ModificationWatchpointRequest - Interface in com.sun.jdi.request
设置字段时请求通知。
modificationWatchpointRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的修改观察点请求的不可修改的列表。
MODIFIED_JULIAN_DAY - Static variable in class java.time.temporal. JulianFields
修改儒略日字段。
modifier - Variable in class javax.swing.text.html.parser. AttributeList
属性修饰符
Modifier - Class in java.lang.reflect
Modifier类提供了 static方法和常量来解码类和成员访问修饰符。
Modifier - Enum in javax.lang.model.element
表示程序元素（如类，方法或字段）上的修饰符。
Modifier() - Constructor for class java.lang.reflect. Modifier
MODIFIER_LETTER - Static variable in class java.lang. Character
Unicode规范中的一般类别“Lm”。
MODIFIER_SYMBOL - Static variable in class java.lang. Character
Unicode规范中的一般类别“Sk”。
MODIFIER_TONE_LETTERS - Static variable in class java.lang. Character.UnicodeBlock
“Modifier Tone Letters”Unicode字符块的常数。
modifiers - Variable in class java.awt. Event
已过时。
修饰键的状态。
modifiers() - Method in interface com.sun.javadoc. ProgramElementDoc
已过时。
获取修饰符字符串。
modifiers() - Method in interface com.sun.jdi. Accessible
返回编码为整数的Java编程语言修饰符。
modifiers() - Method in class java.lang.module. ModuleDescriptor.Exports
返回一组修饰符。
modifiers() - Method in class java.lang.module. ModuleDescriptor
返回一组模块修饰符。
modifiers() - Method in class java.lang.module. ModuleDescriptor.Opens
返回一组修饰符。
modifiers() - Method in class java.lang.module. ModuleDescriptor.Requires
返回一组修饰符。
MODIFIERS - com.sun.source.tree. Tree.Kind
用于ModifiersTree的实例。
modifierSpecifier() - Method in interface com.sun.javadoc. ProgramElementDoc
已过时。
获取修饰符说明符整数。
ModifiersTree - Interface in com.sun.source.tree
用于声明的修饰符的树节点（包括注释）。
modifyAttributes(String, int, Attributes) - Method in interface javax.naming.directory. DirContext
修改与命名对象关联的属性。
modifyAttributes(String, int, Attributes) - Method in class javax.naming.directory. InitialDirContext
modifyAttributes(String, ModificationItem[]) - Method in interface javax.naming.directory. DirContext
使用有序的修改列表修改与命名对象关联的属性。
modifyAttributes(String, ModificationItem[]) - Method in class javax.naming.directory. InitialDirContext
modifyAttributes(Name, int, Attributes) - Method in interface javax.naming.directory. DirContext
修改与命名对象关联的属性。
modifyAttributes(Name, int, Attributes) - Method in class javax.naming.directory. InitialDirContext
modifyAttributes(Name, ModificationItem[]) - Method in interface javax.naming.directory. DirContext
使用有序的修改列表修改与命名对象关联的属性。
modifyAttributes(Name, ModificationItem[]) - Method in class javax.naming.directory. InitialDirContext
modInverse(BigInteger) - Method in class java.math. BigInteger
返回值为 (this -1 mod m)的BigInteger。
modPow(BigInteger, BigInteger) - Method in class java.math. BigInteger
返回值为 (thisexponent mod m)的BigInteger。
module() - Method in interface com.sun.jdi. ReferenceType
获取包含与此类型对应的类的模块对象。
Module - Class in java.lang
代表一个运行时模块，可以是 named或者是未命名的。
MODULE - com.sun.source.tree. Tree.Kind
用于表示模块声明的ModuleTree的实例。
MODULE - java.lang.annotation. ElementType
模块声明。
MODULE - javax.lang.model.element. ElementKind
一个模块
MODULE - javax.lang.model.type. TypeKind
对应于模块元素的伪类型。
MODULE - jdk.javadoc.doclet. Taglet.Location
在一个模块的文档中。
MODULE - jdk.nashorn.api.tree. Tree.Kind
用于ModuleTree的实例。
MODULE - Static variable in class java.lang.invoke. MethodHandles.Lookup
代表 module访问（默认访问）的单位掩码，这可能有助于 lookupModes的结果。
MODULE_PATH - javax.tools. StandardLocation
搜索预编译用户模块的位置。
MODULE_SOURCE_PATH - javax.tools. StandardLocation
搜索模块的源代码的位置。
ModuleDescriptor - Class in java.lang.module
模块描述符。
ModuleDescriptor.Builder - Class in java.lang.module
建立ModuleDescriptor对象的构建器。
ModuleDescriptor.Exports - Class in java.lang.module
由模块导出的包可能有资格或不合格。
ModuleDescriptor.Exports.Modifier - Enum in java.lang.module
导出包上的修饰符。
ModuleDescriptor.Modifier - Enum in java.lang.module
模块上的修饰符。
ModuleDescriptor.Opens - Class in java.lang.module
由模块打开的包可能有资格或不合格。
ModuleDescriptor.Opens.Modifier - Enum in java.lang.module
打开包装上的修饰符。
ModuleDescriptor.Provides - Class in java.lang.module
模块提供一个或多个实现的服务。
ModuleDescriptor.Requires - Class in java.lang.module
对模块的依赖
ModuleDescriptor.Requires.Modifier - Enum in java.lang.module
模块依赖的修饰符。
ModuleDescriptor.Version - Class in java.lang.module
模块的版本字符串。
ModuleElement - Interface in javax.lang.model.element
表示一个模块程序元素。
ModuleElement.Directive - Interface in javax.lang.model.element
在本模块的声明中表示一个指令。
ModuleElement.DirectiveKind - Enum in javax.lang.model.element
一个指令的 kind 。
ModuleElement.DirectiveVisitor< R, P> - Interface in javax.lang.model.element
模块指令的访问者，以访客设计模式的风格。
ModuleElement.ExportsDirective - Interface in javax.lang.model.element
一个模块的导出包。
ModuleElement.OpensDirective - Interface in javax.lang.model.element
一个开放的模块包。
ModuleElement.ProvidesDirective - Interface in javax.lang.model.element
由模块提供的服务的实现。
ModuleElement.RequiresDirective - Interface in javax.lang.model.element
模块的依赖。
ModuleElement.UsesDirective - Interface in javax.lang.model.element
对模块使用的服务的引用。
ModuleFinder - Interface in java.lang.module
模块的取景器。
ModuleLayer - Class in java.lang
Java虚拟机中的一层模块。
ModuleLayer.Controller - Class in java.lang
控制模块层。
ModuleReader - Interface in java.lang.module
提供访问模块的内容。
ModuleReference - Class in java.lang.module
参考模块的内容。
ModuleReference - Interface in com.sun.jdi
目标虚拟机中的一个模块。
ModuleReference(ModuleDescriptor, URI) - Constructor for class java.lang.module. ModuleReference
构造一个这个类的新实例。
modules() - Method in class java.lang.module. Configuration
在此配置中返回一组不可变的已解析模块。
modules() - Method in class java.lang. ModuleLayer
返回此图层中的模块集。
modulesIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
返回 elements中的模块列表。
modulesIn(Set<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
返回一组 elements的模块。
ModuleTree - Interface in com.sun.source.tree
模块声明的树节点。
ModuleTree - Interface in jdk.nashorn.api.tree
一个树节点为 Module information 。
ModuleTree.ModuleKind - Enum in com.sun.source.tree
模块的种类。
MONARCH - Static variable in class java.awt. PageAttributes.MediaType
MONARCH_ENVELOPE的别名。
MONARCH_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
Monarch Envelope的MediaType实例，3 7/8 x 7 1/2 in。
MONARCH_ENVELOPE - Static variable in class javafx.print. Paper
指定Monarch信封尺寸，3.87英寸×7.5英寸。
MONARCH_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定Monarch信封尺寸，3.87英寸×7.5英寸。
MONARCH_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
君主信封大小。
MONDAY - java.time. DayOfWeek
星期一星期几的单身人士例子。
MONDAY - Static variable in class java.util. Calendar
Calendar.DAY_OF_WEEK字段的值表示星期一。
MONGOLIAN - java.awt.font. NumericShaper.Range
蒙古数字与蒙古数字。
MONGOLIAN - java.lang. Character.UnicodeScript
Unicode脚本“蒙古语”。
MONGOLIAN - Static variable in class java.awt.font. NumericShaper
标识MONGOLIAN范围和十进制基数。
MONGOLIAN - Static variable in class java.lang. Character.UnicodeBlock
“蒙古”Unicode字符块的常数。
monitor() - Method in interface com.sun.jdi.event. MonitorContendedEnteredEvent
返回输入的监视器。
monitor() - Method in interface com.sun.jdi.event. MonitorContendedEnterEvent
返回输入的方法。
monitor() - Method in interface com.sun.jdi.event. MonitorWaitedEvent
返回此线程等待的监视器对象。
monitor() - Method in interface com.sun.jdi.event. MonitorWaitEvent
返回线程要等待的监视器对象。
monitor() - Method in interface com.sun.jdi. MonitorInfo
返回显示器的ObjectReference对象。
Monitor - Class in javax.management.monitor
定义所有监视器MBean的通用部分。
Monitor() - Constructor for class javax.management.monitor. Monitor
MonitorContendedEnteredEvent - Interface in com.sun.jdi.event
通知目标VM中的线程等待其他线程释放后进入监视器。
MonitorContendedEnteredRequest - Interface in com.sun.jdi.request
在等待其他线程释放之后，请求目标VM中的线程通知进入监视器。
monitorContendedEnteredRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回已启用和禁用的已监视输入请求的不可修改的列表。
MonitorContendedEnterEvent - Interface in com.sun.jdi.event
通知目标虚拟机中的线程正在尝试进入已被另一个线程获取的监视器。
MonitorContendedEnterRequest - Interface in com.sun.jdi.request
请求在目标VM中尝试进入另一个线程已经获取的监视器的线程的通知。
monitorContendedEnterRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的监视器竞争的输入请求的不可修改的列表。
MonitorInfo - Class in java.lang.management
有关对象监视器锁的信息。
MonitorInfo - Interface in com.sun.jdi
有关线程拥有的监视器的信息。
MonitorInfo(String, int, int, StackTraceElement) - Constructor for class java.lang.management. MonitorInfo
构造一个 MonitorInfo对象。
MonitorMBean - Interface in javax.management.monitor
暴露监视器MBean的远程管理界面。
MonitorNotification - Class in javax.management.monitor
提供监视器MBean发送的通知的定义。
MonitorSettingException - Exception in javax.management.monitor
监视器设置在监视器运行时无效时由监视器抛出异常。
MonitorSettingException() - Constructor for exception javax.management.monitor. MonitorSettingException
默认构造函数。
MonitorSettingException(String) - Constructor for exception javax.management.monitor. MonitorSettingException
允许指定错误消息的构造方法。
MonitorWaitedEvent - Interface in com.sun.jdi.event
通知目标VM中的线程已经完成等待监视器对象。
MonitorWaitedRequest - Interface in com.sun.jdi.request
当目标虚拟机中的线程已经完成等待监视对象时，请求通知。
monitorWaitedRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的监视器等待请求的不可修改的列表。
MonitorWaitEvent - Interface in com.sun.jdi.event
通知目标VM中的线程即将等待监视器对象。
MonitorWaitRequest - Interface in com.sun.jdi.request
当目标虚拟机中的线程即将等待监视对象时，请求通知。
monitorWaitRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的监视器等待请求的不可修改的列表。
MONOCHROME - javafx.print. PrintColor
指定单色或灰阶打印。
MONOCHROME - Static variable in class java.awt. PageAttributes.ColorType
用于指定单色打印的ColorType实例。
MONOCHROME - Static variable in class javax.print.attribute.standard. Chromaticity
单色打印。
MONOSPACED - Static variable in class java.awt. Font
逻辑字体“Monospaced”的规范系列名称的字符串常量。
Month - Enum in java.time
一个月，如“七月”。
MONTH - Static variable in class java.text. DateFormat.Field
不断识别月份字段。
MONTH - Static variable in class java.util. Calendar
字段编号为 get和 set表示该月。
MONTH_FIELD - Static variable in class java.text. DateFormat
MONTH字段对齐的常用常数。
MONTH_OF_YEAR - java.time.temporal. ChronoField
一月份，如三月。
MonthDay - Class in java.time
ISO- --12-03 ，如 --12-03 。
MONTHS - java.time.temporal. ChronoUnit
代表一个月概念的单位。
MONTHS - Static variable in class javax.xml.datatype. DatatypeConstants
代表月份字段的常数。
MORE_THAN_MAX_ROLE_DEGREE - Static variable in class javax.management.relation. RoleStatus
尝试将角色值设置为具有比最大预期基数更多的ObjectName时的问题类型。
MOTION - Static variable in class com.sun.java.accessibility.util. EventID
映射到AWT MouseMotion支持（即MouseMotionListener和MouseMotionEvent）
MotionBlur - Class in javafx.scene.effect
使用高斯卷积核的运动模糊效果，具有可配置的半径和角度。
MotionBlur() - Constructor for class javafx.scene.effect. MotionBlur
使用默认参数创建MotionBlur的新实例。
MotionBlur(double, double) - Constructor for class javafx.scene.effect. MotionBlur
以指定的角度和半径创建MotionBlur的新实例。
MOUSE - Static variable in class com.sun.java.accessibility.util. EventID
映射到AWT鼠标支持（即MouseListener和MouseEvent）
MOUSE_CLICKED - Static variable in class java.awt.event. MouseEvent
“鼠标点击”事件。
MOUSE_CLICKED - Static variable in class javafx.scene.input. MouseEvent
当单击鼠标按钮（在同一节点上按下并释放）时，会发生此事件。
MOUSE_DOWN - Static variable in class java.awt. Event
已过时。
用户按下了鼠标按钮。
MOUSE_DRAG - Static variable in class java.awt. Event
已过时。
用户已按下按钮移动鼠标。
MOUSE_DRAG_ENTERED - Static variable in class javafx.scene.input. MouseDragEvent
当手势进入节点时，会发生此事件。
MOUSE_DRAG_ENTERED_TARGET - Static variable in class javafx.scene.input. MouseDragEvent
当手势进入节点时，会发生此事件。
MOUSE_DRAG_EXITED - Static variable in class javafx.scene.input. MouseDragEvent
当手势退出节点时，会发生此事件。
MOUSE_DRAG_EXITED_TARGET - Static variable in class javafx.scene.input. MouseDragEvent
当手势退出节点时，会发生此事件。
MOUSE_DRAG_OVER - Static variable in class javafx.scene.input. MouseDragEvent
当该节点内的手势进行时，会发生此事件。
MOUSE_DRAG_RELEASED - Static variable in class javafx.scene.input. MouseDragEvent
当手势在该节点上结束（通过释放鼠标按钮）时，会发生此事件。
MOUSE_DRAGGED - Static variable in class java.awt.event. MouseEvent
“鼠标拖动”事件。
MOUSE_DRAGGED - Static variable in class javafx.scene.input. MouseEvent
当鼠标按下按钮移动时，会发生此事件。
MOUSE_ENTER - Static variable in class java.awt. Event
已过时。
鼠标已经输入了一个组件。
MOUSE_ENTERED - Static variable in class java.awt.event. MouseEvent
“鼠标进入”事件。
MOUSE_ENTERED - Static variable in class javafx.scene.input. MouseEvent
当鼠标进入节点时，会发生此事件。
MOUSE_ENTERED_TARGET - Static variable in class javafx.scene.input. MouseEvent
当鼠标进入节点时，会发生此事件。
MOUSE_EVENT - java.awt.event. FocusEvent.Cause
激活鼠标事件。
MOUSE_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择鼠标事件的事件掩码。
MOUSE_EXIT - Static variable in class java.awt. Event
已过时。
鼠标已经退出了一个组件。
MOUSE_EXITED - Static variable in class java.awt.event. MouseEvent
“鼠标退出”事件。
MOUSE_EXITED - Static variable in class javafx.scene.input. MouseEvent
当鼠标退出节点时，会发生此事件。
MOUSE_EXITED_TARGET - Static variable in class javafx.scene.input. MouseEvent
当鼠标退出节点时，会发生此事件。
MOUSE_FIRST - Static variable in class java.awt.event. MouseEvent
用于鼠标事件的ids范围中的第一个数字。
MOUSE_LAST - Static variable in class java.awt.event. MouseEvent
用于鼠标事件的ids范围中的最后一个数字。
MOUSE_MOTION_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择鼠标运动事件的事件掩码。
MOUSE_MOVE - Static variable in class java.awt. Event
已过时。
鼠标已经移动，没有按下按钮。
MOUSE_MOVED - Static variable in class java.awt.event. MouseEvent
“鼠标移动”事件。
MOUSE_MOVED - Static variable in class javafx.scene.input. MouseEvent
当鼠标在节点内移动并且没有按钮被按下时，会发生此事件。
MOUSE_OVER - Static variable in interface javax.swing.plaf.synth. SynthConstants
表示鼠标的主状态位于该区域之上。
MOUSE_PRESSED - Static variable in class java.awt.event. MouseEvent
“鼠标按下”事件。
MOUSE_PRESSED - Static variable in class javafx.scene.input. MouseEvent
当按下鼠标按钮时，会发生此事件。
MOUSE_RELEASED - Static variable in class java.awt.event. MouseEvent
“鼠标释放”事件。
MOUSE_RELEASED - Static variable in class javafx.scene.input. MouseEvent
当鼠标按钮被释放时，会发生此事件。
MOUSE_UP - Static variable in class java.awt. Event
已过时。
用户已经释放鼠标按钮。
MOUSE_WHEEL - Static variable in class java.awt.event. MouseEvent
“鼠标滚轮”事件。
MOUSE_WHEEL_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择鼠标滚轮事件的事件掩码。
MouseAdapter - Class in java.awt.event
用于接收鼠标事件的抽象适配器类。
MouseAdapter() - Constructor for class java.awt.event. MouseAdapter
MouseButton - Enum in javafx.scene.input
按钮名称映射
mouseClicked(MouseEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mouseClicked方法来处理mouseClicked事件。
mouseClicked(MouseEvent) - Method in class java.awt.dnd. MouseDragGestureRecognizer
当鼠标点击组件时调用。
mouseClicked(MouseEvent) - Method in class java.awt.event. MouseAdapter
在组件上单击（按下并释放）鼠标按钮时调用。
mouseClicked(MouseEvent) - Method in interface java.awt.event. MouseListener
在组件上单击（按下并释放）鼠标按钮时调用。
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.DoubleClickListener
在组件上单击（按下并释放）鼠标按钮时调用。
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher
在组件上单击（按下并释放）鼠标按钮时调用。
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
在组件上单击（按下并释放）鼠标按钮时调用。
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.text. DefaultCaret
当鼠标点击时调用。
mouseClicked(MouseEvent) - Method in class javax.swing.text.html. HTMLEditorKit.LinkController
被称为鼠标点击事件。
mouseDown(Event, int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
mouseDrag(Event, int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
MouseDragEvent - Class in javafx.scene.input
鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
MouseDragEvent(Object, EventTarget, EventType<MouseDragEvent>, double, double, double, double, MouseButton, int, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, PickResult, Object) - Constructor for class javafx.scene.input. MouseDragEvent
构造新的MouseDragEvent事件。
MouseDragEvent(EventType<MouseDragEvent>, double, double, double, double, MouseButton, int, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, PickResult, Object) - Constructor for class javafx.scene.input. MouseDragEvent
构造具有null源和目标的新的MouseDragEvent事件。
mouseDragged(MouseEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mouseDragged方法来处理mouseDragged事件。
mouseDragged(MouseEvent) - Method in class java.awt.dnd. MouseDragGestureRecognizer
在组件上按下鼠标按钮时调用。
mouseDragged(MouseEvent) - Method in class java.awt.event. MouseAdapter
在组件上按下鼠标按钮然后拖动时调用。
mouseDragged(MouseEvent) - Method in class java.awt.event. MouseMotionAdapter
在组件上按下鼠标按钮然后拖动时调用。
mouseDragged(MouseEvent) - Method in interface java.awt.event. MouseMotionListener
在组件上按下鼠标按钮然后拖动时调用。
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.InvocationMouseMotionHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher
在组件上按下鼠标按钮然后拖动时调用。
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
在组件上按下鼠标按钮然后拖动时调用。
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
在菜单上按下鼠标按钮然后拖动时调用。
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener
将模型值设置为垂直滚动条的顶部的位置，或水平滚动条左右对齐/左右滚动条相对于轨迹原点的左/右。
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.TrackListener
将模型值设置为拇指顶部/左侧相对于轨迹原点的位置。
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.MouseHandler
如果dragger不为null，则会使用continueDrag进行消息传递。
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.metal. MetalToolBarUI.MetalDockingListener
mouseDragged(MouseEvent) - Method in class javax.swing.text. DefaultCaret
根据鼠标指针的当前位置移动插入符号位置。
mouseDragged(MouseEvent) - Method in class javax.swing.text.html. HTMLEditorKit.LinkController
mouseDragged(MouseEvent) - Method in class javax.swing. ToolTipManager
当鼠标被按下并拖动时调用。
MouseDragGestureRecognizer - Class in java.awt.dnd
DragGestureRecognizer这个抽象子类定义了一个基于鼠标的手势的 DragGestureRecognizer 。
MouseDragGestureRecognizer(DragSource) - Constructor for class java.awt.dnd. MouseDragGestureRecognizer
构造一个新的 MouseDragGestureRecognizer给予 DragSource为 Component 。
MouseDragGestureRecognizer(DragSource, Component) - Constructor for class java.awt.dnd. MouseDragGestureRecognizer
构造新的 MouseDragGestureRecognizer给出 DragSource为 Component c和 Component观察。
MouseDragGestureRecognizer(DragSource, Component, int) - Constructor for class java.awt.dnd. MouseDragGestureRecognizer
构造一个新的 MouseDragGestureRecognizer给出 DragSource的 Component c， Component进行观察，并允许此拖动操作的动作。
MouseDragGestureRecognizer(DragSource, Component, int, DragGestureListener) - Constructor for class java.awt.dnd. MouseDragGestureRecognizer
构造一个新的 MouseDragGestureRecognizer给出 DragSource为 Component c， Component观察，这个拖动操作允许的动作，以及 DragGestureListener通知何时检测到拖动手势。
mouseEnter(Event, int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
mouseEntered(MouseEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mouseEntered方法来处理mouseEntered事件。
mouseEntered(MouseEvent) - Method in class java.awt.dnd. MouseDragGestureRecognizer
当鼠标进入组件时调用。
mouseEntered(MouseEvent) - Method in class java.awt.event. MouseAdapter
当鼠标进入组件时调用。
mouseEntered(MouseEvent) - Method in interface java.awt.event. MouseListener
当鼠标进入组件时调用。
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.DoubleClickListener
用于表示文件的JList是由子类创建的，但是在此类中监视选择。
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher
当鼠标进入组件时调用。
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
当鼠标进入组件时调用。
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
当光标进入菜单时调用。
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.MouseHandler
当鼠标进入组件时调用。
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.text. DefaultCaret
当鼠标进入区域时调用。
mouseEntered(MouseEvent) - Method in class javax.swing. ToolTipManager
当鼠标进入组件的区域时调用。
MouseEvent - Class in java.awt.event
指示组件中发生鼠标操作的事件。
MouseEvent - Class in javafx.scene.input
当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
MouseEvent - Interface in org.w3c.dom.events
MouseEvent界面提供与鼠标事件相关联的特定上下文信息。
MouseEvent(Component, int, long, int, int, int, int, boolean) - Constructor for class java.awt.event. MouseEvent
使用指定的源组件，类型，修饰符，坐标，点击计数和弹出触发标志构造一个 MouseEvent对象。
MouseEvent(Component, int, long, int, int, int, int, boolean, int) - Constructor for class java.awt.event. MouseEvent
构造具有指定源组件，类型，时间，修饰符，坐标，点击计数，弹出触发标志和按钮编号的 MouseEvent对象。
MouseEvent(Component, int, long, int, int, int, int, int, int, boolean, int) - Constructor for class java.awt.event. MouseEvent
使用指定的源组件，类型，时间，修饰符，坐标，绝对坐标，点击计数，弹出触发器标志和按钮编号构建一个 MouseEvent对象。
MouseEvent(Object, EventTarget, EventType<? extends MouseEvent>, double, double, double, double, MouseButton, int, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, PickResult) - Constructor for class javafx.scene.input. MouseEvent
构造新的MouseEvent事件。
MouseEvent(EventType<? extends MouseEvent>, double, double, double, double, MouseButton, int, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, PickResult) - Constructor for class javafx.scene.input. MouseEvent
构造具有null源和目标的新的MouseEvent事件。
MouseEventListener() - Constructor for class javax.swing.text.html. FormView.MouseEventListener
mouseExit(Event, int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
mouseExited(MouseEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mouseExited方法来处理mouseExited事件。
mouseExited(MouseEvent) - Method in class java.awt.dnd. MouseDragGestureRecognizer
当鼠标退出组件时调用。
mouseExited(MouseEvent) - Method in class java.awt.event. MouseAdapter
当鼠标退出组件时调用。
mouseExited(MouseEvent) - Method in interface java.awt.event. MouseListener
当鼠标退出组件时调用。
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher
当鼠标退出组件时调用。
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
当鼠标退出组件时调用。
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener
当鼠标退出滚动条时调用。
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.MouseHandler
当鼠标退出组件时调用。
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.text. DefaultCaret
当鼠标退出区域时调用。
mouseExited(MouseEvent) - Method in class javax.swing. ToolTipManager
当鼠标退出组件的区域时调用。
mouseHandler - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
处理来自这个类和拆分窗格的鼠标事件。
MouseHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneDivider.MouseHandler
MouseHandler() - Constructor for class javax.swing.plaf.basic. BasicTabbedPaneUI.MouseHandler
MouseHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.MouseHandler
MouseInfo - Class in java.awt
MouseInfo提供了获取鼠标信息的方法，如鼠标指针位置和鼠标按键数量。
MouseInputAdapter - Class in javax.swing.event
MouseInputListener接口的空实现，通过仅扩展和实现感兴趣的方法，为简化创建侦听器的任务提供了方便。
MouseInputAdapter() - Constructor for class javax.swing.event. MouseInputAdapter
MouseInputHandler() - Constructor for class javax.swing.plaf.basic. BasicDesktopIconUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
MouseInputHandler(Component, Component, MouseEvent) - Constructor for class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
构造一个新的实例 MouseInputHandler 。
mouseInputListener - Variable in class javax.swing.plaf.basic. BasicListUI
MouseInputListener ，附于 JList 。
mouseInputListener - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
实例 MouseInputListener 。
mouseInputListener - Variable in class javax.swing.plaf.basic. BasicTableHeaderUI
连接到 JTable
mouseInputListener - Variable in class javax.swing.plaf.basic. BasicTableUI
MouseInputListener ，附于 JTable 。
MouseInputListener - Interface in javax.swing.event
在 MouseListener和 MouseMotionListener接口中实现所有方法的侦听器。
mouseListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor
不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。
mouseListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
mouseListener - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
鼠标更改侦听器
MouseListener - Interface in java.awt.event
用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
MouseMotionAdapter - Class in java.awt.event
用于接收鼠标运动事件的抽象适配器类。
MouseMotionAdapter() - Constructor for class java.awt.event. MouseMotionAdapter
mouseMotionListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor
不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。
mouseMotionListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
MouseMotionListener - Interface in java.awt.event
用于在组件上接收鼠标运动事件的侦听器界面。
mouseMove(int, int) - Method in class java.awt. Robot
将鼠标指针移动到给定的屏幕坐标。
mouseMove(Event, int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
mouseMoved(MouseEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mouseMoved方法来处理mouseMoved事件。
mouseMoved(MouseEvent) - Method in class java.awt.dnd. MouseDragGestureRecognizer
在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
mouseMoved(MouseEvent) - Method in class java.awt.event. MouseAdapter
当鼠标光标移动到组件上但没有按钮被按下时调用。
mouseMoved(MouseEvent) - Method in class java.awt.event. MouseMotionAdapter
在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
mouseMoved(MouseEvent) - Method in interface java.awt.event. MouseMotionListener
当鼠标光标移动到组件上但没有按钮被按下时调用。
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ListMouseMotionHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher
当鼠标光标移动到组件上但没有按钮被按下时调用。
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
当鼠标光标移动到组件上但没有按钮被按下时调用。
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener
当鼠标光标移动到组件上但没有按钮被按下时调用。
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.TrackListener
当鼠标光标移动到组件上但没有按钮被按下时调用。
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.MouseHandler
根据方向重新设置光标。
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseHandler
在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.text. DefaultCaret
当鼠标移动时调用。
mouseMoved(MouseEvent) - Method in class javax.swing.text.html. HTMLEditorKit.LinkController
mouseMoved(MouseEvent) - Method in class javax.swing. ToolTipManager
当鼠标移动时调用。
mousePress(int) - Method in class java.awt. Robot
按一个或多个鼠标按钮。
mousePressed(MouseEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mousePressed方法来处理mousePressed事件。
mousePressed(MouseEvent) - Method in class java.awt.dnd. MouseDragGestureRecognizer
在 Component上按下鼠标按钮时调用。
mousePressed(MouseEvent) - Method in class java.awt.event. MouseAdapter
在组件上按下鼠标按钮时调用。
mousePressed(MouseEvent) - Method in interface java.awt.event. MouseListener
在组件上按下鼠标按钮时调用。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.InvocationMouseHandler
响应组合框上的鼠标按下的事件。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ListMouseHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher
在组件上按下鼠标按钮时调用。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
在组件上按下鼠标按钮时调用。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
当鼠标在菜单上点击时调用。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.ArrowButtonListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener
如果鼠标按在“thumb”组件上方，则将滚动条值减少一页（“向上”），否则将其增加一页。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.TrackListener
如果鼠标按在“thumb”组件上方，则将滚动条值减少一页（“向上”），否则将其增加一页。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.MouseHandler
通过创建适当的DragController实例来启动拖动会话。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.MouseHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseHandler
在组件上按下鼠标按钮时调用。
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.metal. MetalToolBarUI.MetalDockingListener
mousePressed(MouseEvent) - Method in class javax.swing.text. DefaultCaret
如果按下按钮1，则将其实现为请求关注相关联的文本组件，并设置插入符位置。
mousePressed(MouseEvent) - Method in class javax.swing. ToolTipManager
当鼠标被按下时调用。
mouseRelease(int) - Method in class java.awt. Robot
释放一个或多个鼠标按钮。
mouseReleased(MouseEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mouseReleased方法来处理mouseReleased事件。
mouseReleased(MouseEvent) - Method in class java.awt.dnd. MouseDragGestureRecognizer
在组件上释放鼠标按钮时调用。
mouseReleased(MouseEvent) - Method in class java.awt.event. MouseAdapter
在组件上释放鼠标按钮时调用。
mouseReleased(MouseEvent) - Method in interface java.awt.event. MouseListener
在组件上释放鼠标按钮时调用。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.InvocationMouseHandler
响应用户终止组合框上开始的点击或拖动。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ListMouseHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.GlassPaneDispatcher
在组件上释放鼠标按钮时调用。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicListUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI.MouseInputHandler
在组件上释放鼠标按钮时调用。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.MouseInputHandler
当鼠标在菜单上释放时调用。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.ArrowButtonListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener
在组件上释放鼠标按钮时调用。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.TrackListener
在组件上释放鼠标按钮时调用。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.MouseHandler
如果dragger不为null，则会使用completeDrag进行消息传递。
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTableUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.text. DefaultCaret
当鼠标释放时调用。
mouseReleased(MouseEvent) - Method in class javax.swing.text.html. FormView.MouseEventListener
mouseTransparentProperty() - Method in class javafx.scene. Node
如果是 true ，这个节点（和它的所有子节点）对于鼠标事件是完全透明的。
mouseUp(Event, int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
mouseWheel(int) - Method in class java.awt. Robot
在装有轮子的鼠标上旋转滚轮。
MouseWheelEvent - Class in java.awt.event
指示鼠标轮在组件中旋转的事件。
MouseWheelEvent(Component, int, long, int, int, int, int, boolean, int, int, int) - Constructor for class java.awt.event. MouseWheelEvent
构造具有指定的源组件，类型，修饰符，坐标，滚动类型，滚动量和轮子旋转的 MouseWheelEvent对象。
MouseWheelEvent(Component, int, long, int, int, int, int, int, int, boolean, int, int, int) - Constructor for class java.awt.event. MouseWheelEvent
构造具有指定源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮转的 MouseWheelEvent对象。
MouseWheelEvent(Component, int, long, int, int, int, int, int, int, boolean, int, int, int, double) - Constructor for class java.awt.event. MouseWheelEvent
构造具有指定的源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮子旋转的 MouseWheelEvent对象。
MouseWheelHandler() - Constructor for class javax.swing.plaf.basic. BasicScrollPaneUI.MouseWheelHandler
MouseWheelListener - Interface in java.awt.event
用于在组件上接收鼠标滚轮事件的侦听器界面。
mouseWheelMoved(MouseWheelEvent) - Method in class java.awt. AWTEventMulticaster
通过在listener-a和listener-b上调用mouseWheelMoved方法来处理mouseWheelMoved事件。
mouseWheelMoved(MouseWheelEvent) - Method in class java.awt.event. MouseAdapter
当鼠标滚轮旋转时调用。
mouseWheelMoved(MouseWheelEvent) - Method in interface java.awt.event. MouseWheelListener
当鼠标滚轮旋转时调用。
mouseWheelMoved(MouseWheelEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI.MouseWheelHandler
当鼠标滚轮在JScrollPane上旋转时调用。
move(int, int) - Method in class java.awt. Component
已过时。
自JDK 1.1版起，由setLocation(int, int)替代。
move(int, int) - Method in class java.awt. Point
将此点移动到 (x,y)坐标平面中的指定位置。
move(int, int) - Method in class java.awt. Rectangle
已过时。
截至JDK 1.1版，由setLocation(int, int)替代。
move(Path, Path, CopyOption...) - Static method in class java.nio.file. Files
将文件移动或重命名为目标文件。
move(Path, Path, CopyOption...) - Method in class java.nio.file.spi. FileSystemProvider
将文件移动或重命名为目标文件。
move(T, SecureDirectoryStream<T>, T) - Method in interface java.nio.file. SecureDirectoryStream
将文件从该目录移动到另一个目录。
MOVE - javafx.scene.input. TransferMode
表示支持或打算移动数据。
MOVE - Static variable in class javafx.scene. Cursor
移动光标类型。
MOVE - Static variable in class javax.swing. TransferHandler
代表“移动”转移动作的 int 。
MOVE_CMD - Static variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
移动按钮文本属性。
MOVE_CURSOR - Static variable in class java.awt. Cursor
移动光标类型。
MOVE_CURSOR - Static variable in class java.awt. Frame
已过时。
替换为Cursor.MOVE_CURSOR 。
MOVE_TO_TRASH - java.awt. Desktop.Action
代表垃圾的移动
moveAction - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
一个 MoveAction的实例。
MoveAction() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.MoveAction
构造一个新的 MoveAction实例。
moveAndRepaint(JComponent, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI.MouseInputHandler
移动并重新绘制组件 f 。
moveCaret(MouseEvent) - Method in class javax.swing.text. DefaultCaret
尝试使用viewToModel（）从鼠标事件的坐标移动插入符的位置。
moveCaret(TextInputControlSkin.TextUnit, TextInputControlSkin.Direction, boolean) - Method in class javafx.scene.control.skin. TextAreaSkin
按照给定的方向，以指定文本单位之一移动插入符号。
moveCaret(TextInputControlSkin.TextUnit, TextInputControlSkin.Direction, boolean) - Method in class javafx.scene.control.skin. TextFieldSkin
按照给定的方向，以指定文本单位之一移动插入符号。
moveCaret(TextInputControlSkin.TextUnit, TextInputControlSkin.Direction, boolean) - Method in class javafx.scene.control.skin. TextInputControlSkin
按照给定的方向，以指定文本单位之一移动插入符号。
moveCaretPosition(int) - Method in class javax.swing.text. JTextComponent
将插入符号移动到一个新的位置，留下最后一次 setCaretPosition被定义的标记。
moveColumn(int, int) - Method in class javax.swing. JTable
将列 column移动到视图中的列 targetColumn当前占用的位置。
moveColumn(int, int) - Method in class javax.swing.table. DefaultTableColumnModel
将列和标题从 columnIndex移动到 newIndex 。
moveColumn(int, int) - Method in interface javax.swing.table. TableColumnModel
将列及其标题 columnIndex到 newIndex 。
MOVED - javafx.scene.input. TouchPoint.State
触摸点已移动
moveDot(int) - Method in interface javax.swing.text. Caret
将插入符号位置（点）移动到其他位置，留下标记。
moveDot(int) - Method in class javax.swing.text. DefaultCaret
将插入符号位置移动到指定的位置，并具有正向偏置。
moveDot(int, Position.Bias) - Method in class javax.swing.text. DefaultCaret
将插入符号位置移动到指定的位置，并指定偏置。
moveDot(int, Position.Bias) - Method in class javax.swing.text. NavigationFilter.FilterBypass
绕过NavigationFilter移动插入位置。
moveDot(NavigationFilter.FilterBypass, int, Position.Bias) - Method in class javax.swing.text. NavigationFilter
在插入点移动点之前调用。
moveLeadSelectionIndex(int) - Method in class javax.swing. DefaultListSelectionModel
设置引导选择索引，保持所有选择值不变。
movePointLeft(int) - Method in class java.math. BigDecimal
返回一个 BigDecimal ，相当于这个小数点左边的 n地方。
movePointRight(int) - Method in class java.math. BigDecimal
返回一个 BigDecimal ，相当于这个小数点，移动了 n地方。
moveRow(int, int, int) - Method in class javax.swing.table. DefaultTableModel
将一行或多行从包含范围 start到 end到模型中的 to位置。
moveTo(double, double) - Method in class java.awt.geom. Path2D.Double
通过移动到以双精度指定的指定坐标添加点到路径。
moveTo(double, double) - Method in class java.awt.geom. Path2D.Float
通过移动到以双精度指定的指定坐标添加点到路径。
moveTo(double, double) - Method in class java.awt.geom. Path2D
通过移动到以双精度指定的指定坐标添加点到路径。
moveTo(double, double) - Method in class javafx.scene.canvas. GraphicsContext
X- 20045 X- 20045 X- 20045 X- 20045 X- 2001-
moveTo(float, float) - Method in class java.awt.geom. Path2D.Float
通过移动到以float精度指定的指定坐标，向路径添加点。
MoveTo - Class in javafx.scene.shape
通过移动到指定的坐标来创建对路径的补充。
MoveTo() - Constructor for class javafx.scene.shape. MoveTo
创建一个空的MoveTo实例。
MoveTo(double, double) - Constructor for class javafx.scene.shape. MoveTo
创建一个新的MoveTo实例。
moveToBack() - Method in class javax.swing. JInternalFrame
便利方法将该组件移动到位置-1，如果其父对象是一个 JLayeredPane 。
moveToBack(Component) - Method in class javax.swing. JLayeredPane
将组件移动到当前层中的组件底部（位置-1）。
moveToCurrentRow() - Method in interface java.sql. ResultSet
将光标移动到记住的光标位置，通常是当前行。
moveToFront() - Method in class javax.swing. JInternalFrame
便利方法将该组件移动到位置0，如果其父对象是一个 JLayeredPane 。
moveToFront(Component) - Method in class javax.swing. JLayeredPane
将组件移动到当前层（位置0）中组件的顶部。
moveToInsertRow() - Method in interface java.sql. ResultSet
将光标移动到插入行。
moveToTrash(File) - Method in class java.awt. Desktop
将指定的文件移动到垃圾桶。
MOVING_TO_PAUSED - Static variable in class javax.print.attribute.standard. PrinterStateReason
有人暂停了打印机，但是设备正在花费相当的时间来停止。
MRO - java.lang. Character.UnicodeScript
Unicode脚本“Mro”。
MRO - Static variable in class java.lang. Character.UnicodeBlock
“Mro”Unicode字符块的常量。
MS - javafx.css. SizeUnits
MS - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于MS
MT_2D_2x3 - javafx.scene.transform. MatrixType
包含以下值的2行和3列的2D仿射变换矩阵：
MT_2D_3x3 - javafx.scene.transform. MatrixType
3行3列的2D变换矩阵。
MT_3D_3x4 - javafx.scene.transform. MatrixType
包含以下值的3行和4列的3D仿射变换矩阵：
MT_3D_4x4 - javafx.scene.transform. MatrixType
4行4列的3D变换矩阵。
MTOM - Annotation Type in javax.xml.ws.soap
此功能表示使用具有Web服务的MTOM。
MTOMFeature - Class in javax.xml.ws.soap
此功能表示使用具有Web服务的MTOM。
MTOMFeature() - Constructor for class javax.xml.ws.soap. MTOMFeature
创建一个 MTOMFeature 。
MTOMFeature(boolean) - Constructor for class javax.xml.ws.soap. MTOMFeature
创建一个 MTOMFeature 。
MTOMFeature(boolean, int) - Constructor for class javax.xml.ws.soap. MTOMFeature
创建一个 MTOMFeature 。
MTOMFeature(int) - Constructor for class javax.xml.ws.soap. MTOMFeature
创建一个 MTOMFeature 。
MULTANI - java.lang. Character.UnicodeScript
Unicode脚本“Multani”。
MULTANI - Static variable in class java.lang. Character.UnicodeBlock
“Multani”Unicode字符块的常量。
MULTI_LINE - Static variable in class javax.accessibility. AccessibleState
表示此（文本）对象可以包含多行文本。
MULTI_RELEASE - Static variable in class java.util.jar. Attributes.Name
Name对象为 Multi-Release manifest属性，表示这是一个多版本的JAR文件。
MULTI_SELECTION_ENABLED_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser
启用多文件选择。
MultiButtonUI - Class in javax.swing.plaf.multi
用于组合 ButtonUI的复用UI。
MultiButtonUI() - Constructor for class javax.swing.plaf.multi. MultiButtonUI
MulticastChannel - Interface in java.nio.channels
支持互联网协议（IP）组播的网络通道。
MulticastSocket - Class in java.net
组播数据报套接字类对发送和接收IP组播数据包很有用。
MulticastSocket() - Constructor for class java.net. MulticastSocket
创建组播套接字。
MulticastSocket(int) - Constructor for class java.net. MulticastSocket
创建组播套接字并将其绑定到特定端口。
MulticastSocket(SocketAddress) - Constructor for class java.net. MulticastSocket
创建一个绑定到指定套接字地址的MulticastSocket。
MultiColorChooserUI - Class in javax.swing.plaf.multi
用于组合 ColorChooserUI的复用UI。
MultiColorChooserUI() - Constructor for class javax.swing.plaf.multi. MultiColorChooserUI
MultiComboBoxUI - Class in javax.swing.plaf.multi
用于组合 ComboBoxUI的复用UI。
MultiComboBoxUI() - Constructor for class javax.swing.plaf.multi. MultiComboBoxUI
MultiDesktopIconUI - Class in javax.swing.plaf.multi
用于组合 DesktopIconUI的复用UI。
MultiDesktopIconUI() - Constructor for class javax.swing.plaf.multi. MultiDesktopIconUI
MultiDesktopPaneUI - Class in javax.swing.plaf.multi
用于组合 DesktopPaneUI的复用UI。
MultiDesktopPaneUI() - Constructor for class javax.swing.plaf.multi. MultiDesktopPaneUI
MultiDoc - Interface in javax.print
界面MultiDoc指定为打印作业提供多个打印数据的对象的接口。
MultiDocPrintJob - Interface in javax.print
从MultiDocPrintService获取，MultiDocPrintJob可以将指定的文档集合打印为具有一组作业属性的单个打印作业。
MultiDocPrintService - Interface in javax.print
Interface MultiPrintService是MultiDocPrintJob的工厂。
MultiFileChooserUI - Class in javax.swing.plaf.multi
用于组合 FileChooserUI的复用UI。
MultiFileChooserUI() - Constructor for class javax.swing.plaf.multi. MultiFileChooserUI
MultiInternalFrameUI - Class in javax.swing.plaf.multi
用于组合 InternalFrameUI的复用UI。
MultiInternalFrameUI() - Constructor for class javax.swing.plaf.multi. MultiInternalFrameUI
MultiLabelUI - Class in javax.swing.plaf.multi
用于组合 LabelUI的复用UI。
MultiLabelUI() - Constructor for class javax.swing.plaf.multi. MultiLabelUI
MULTILINE - Static variable in class java.util.regex. Pattern
启用多行模式。
MultiListUI - Class in javax.swing.plaf.multi
用于组合 ListUI的复用UI。
MultiListUI() - Constructor for class javax.swing.plaf.multi. MultiListUI
MultiLookAndFeel - Class in javax.swing.plaf.multi
复用外观和感觉，允许多个UI同时与组件相关联。
MultiLookAndFeel() - Constructor for class javax.swing.plaf.multi. MultiLookAndFeel
MultiMapResult< V> - Class in jdk.incubator.http
A Map包含HTTP / 2请求和多响应的结果。
MultiMenuBarUI - Class in javax.swing.plaf.multi
用于组合 MenuBarUI的复用UI。
MultiMenuBarUI() - Constructor for class javax.swing.plaf.multi. MultiMenuBarUI
MultiMenuItemUI - Class in javax.swing.plaf.multi
用于组合 MenuItemUI的复用UI。
MultiMenuItemUI() - Constructor for class javax.swing.plaf.multi. MultiMenuItemUI
MultiOptionPaneUI - Class in javax.swing.plaf.multi
用于组合 OptionPaneUI的复用UI。
MultiOptionPaneUI() - Constructor for class javax.swing.plaf.multi. MultiOptionPaneUI
MultiPanelUI - Class in javax.swing.plaf.multi
用于组合 PanelUI的复用UI。
MultiPanelUI() - Constructor for class javax.swing.plaf.multi. MultiPanelUI
MultiPixelPackedSampleModel - Class in java.awt.image
MultiPixelPackedSampleModel类表示单带图像，可以将多个单样本像素包装到一个数据元素中。
MultiPixelPackedSampleModel(int, int, int, int) - Constructor for class java.awt.image. MultiPixelPackedSampleModel
构造具有指定数据类型，宽度，高度和每像素位数的 MultiPixelPackedSampleModel 。
MultiPixelPackedSampleModel(int, int, int, int, int, int) - Constructor for class java.awt.image. MultiPixelPackedSampleModel
构造具有指定数据类型，宽度，高度，每像素位数，扫描线步幅和数据位偏移的 MultiPixelPackedSampleModel 。
MULTIPLE - javafx.scene.control. SelectionMode
允许一次选择一个或多个连续的索引范围。
MULTIPLE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“多”
MULTIPLE_ID - Static variable in class org.omg.PortableServer. IdUniquenessPolicyValue
MULTIPLE_INTERVAL_SELECTION - Static variable in interface javax.swing. ListSelectionModel
selectionMode属性的值：一次选择一个或多个连续的索引范围。
MULTIPLE_SELECTION - javafx.scene. AccessibleAttribute
如果节点允许多个选择，则返回true，否则返回false。
MultipleComponentProfileHelper - Class in org.omg.IOP
一组标记的组件，形成一个多组件配置文件。
MultipleComponentProfileHelper() - Constructor for class org.omg.IOP. MultipleComponentProfileHelper
MultipleComponentProfileHolder - Class in org.omg.IOP
一组标记的组件，形成一个多组件配置文件。
MultipleComponentProfileHolder() - Constructor for class org.omg.IOP. MultipleComponentProfileHolder
MultipleComponentProfileHolder(TaggedComponent[]) - Constructor for class org.omg.IOP. MultipleComponentProfileHolder
MultipleDocumentHandling - Class in javax.print.attribute.standard
MultipleDocumentHandling类是一个打印属性类，一个枚举，用于控制整理操作，以及将一个或多个打印流页面放置到展示位置和介质页面上。
MultipleDocumentHandling(int) - Constructor for class javax.print.attribute.standard. MultipleDocumentHandling
使用给定的整数值构造新的多文档处理枚举值。
MultipleGradientPaint - Class in java.awt
这是Paints的超类，它使用多色渐变填充其栅格。
MultipleGradientPaint.ColorSpaceType - Enum in java.awt
执行渐变插值的颜色空间。
MultipleGradientPaint.CycleMethod - Enum in java.awt
绘画之外使用的方法边界渐变。
MultipleMaster - Interface in java.awt.font
MultipleMaster接口代表Type 1 Multiple Master字体。
MultipleSelectionModel< T> - Class in javafx.scene.control
一个抽象类，扩展了SelectionModel以添加API来支持多选。
MultipleSelectionModel() - Constructor for class javafx.scene.control. MultipleSelectionModel
创建一个默认的MultipleSelectionModel实例。
multipliedBy(int) - Method in interface java.time.chrono. ChronoPeriod
返回一个新的实例，其中在此期间的每个金额乘以指定的标量。
multipliedBy(int) - Method in class java.time. Period
返回一个新的实例，该时间段中的每个元素乘以指定的标量。
multipliedBy(long) - Method in class java.time. Duration
返回此持续时间的副本乘以标量。
multiply(double) - Method in class javafx.beans.binding. DoubleExpression
multiply(double) - Method in class javafx.beans.binding. FloatExpression
multiply(double) - Method in class javafx.beans.binding. IntegerExpression
multiply(double) - Method in class javafx.beans.binding. LongExpression
multiply(double) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算此NumberExpression和一个常数值。
multiply(double) - Method in class javafx.geometry. Point2D
返回一个点，其点坐标乘以指定因子
multiply(double) - Method in class javafx.geometry. Point3D
返回一个点，其点坐标乘以指定因子
multiply(double) - Method in class javafx.util. Duration
将此实例与代表毫秒的数字相乘并返回新的持续时间。
multiply(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
multiply(float) - Method in class javafx.beans.binding. DoubleExpression
multiply(float) - Method in class javafx.beans.binding. FloatExpression
multiply(float) - Method in class javafx.beans.binding. IntegerExpression
multiply(float) - Method in class javafx.beans.binding. LongExpression
multiply(float) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算该NumberExpression和一个常数值。
multiply(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
multiply(int) - Method in class javafx.beans.binding. DoubleExpression
multiply(int) - Method in class javafx.beans.binding. FloatExpression
multiply(int) - Method in class javafx.beans.binding. IntegerExpression
multiply(int) - Method in class javafx.beans.binding. LongExpression
multiply(int) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算此NumberExpression和常数值。
multiply(int) - Method in class javax.xml.datatype. Duration
计算一个新的持续时间，其值是该持续时间的值的 factor倍。
multiply(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
multiply(long) - Method in class javafx.beans.binding. DoubleExpression
multiply(long) - Method in class javafx.beans.binding. FloatExpression
multiply(long) - Method in class javafx.beans.binding. IntegerExpression
multiply(long) - Method in class javafx.beans.binding. LongExpression
multiply(long) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算此NumberExpression和常数值。
multiply(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，它计算ObservableNumberValue的值和常数值的乘积 。
multiply(BigDecimal) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this × multiplicand) ，其标为 (this.scale() + multiplicand.scale()) 。
multiply(BigDecimal) - Method in class javax.xml.datatype. Duration
计算一个新的持续时间，其值为该持续时间的值的 factor倍。
multiply(BigDecimal, MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this × multiplicand) ，根据上下文设置进行舍入。
multiply(BigInteger) - Method in class java.math. BigInteger
返回值为 (this * val)的BigInteger。
multiply(ObservableNumberValue) - Method in class javafx.beans.binding. DoubleExpression
multiply(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding ，计算该NumberExpression和另一个ObservableNumberValue的产品 。
multiply(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase
multiply(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的DoubleBinding ，计算ObservableNumberValue的值和常数值的乘积 。
multiply(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
multiply(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
multiply(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的值和常数值的乘积 。
multiply(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算ObservableNumberValue的两个实例的值的乘积 。
multiply(Duration) - Method in class javafx.util. Duration
已过时。
这种方法通过不考虑单位产生令人惊讶的结果。 改用Duration.multiply(double) 。
MULTIPLY - com.sun.source.tree. Tree.Kind
用于表示乘法*的BinaryTree的实例。
MULTIPLY - javafx.scene.effect. BlendMode
来自第一输入的颜色分量与来自第二输入的颜色分量相乘。
MULTIPLY - javafx.scene.input. KeyCode
常数为 Multiply键。
MULTIPLY - jdk.nashorn.api.tree. Tree.Kind
用于代表乘法*的BinaryTree的实例。
MULTIPLY_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于表示乘法赋值*=的CompoundAssignmentTree的实例。
MULTIPLY_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于表示乘法赋值*=的CompoundAssignmentTree的实例。
multiplyExact(int, int) - Static method in class java.lang. Math
返回参数的乘积，如果结果溢出 int ，则抛出异常。
multiplyExact(int, int) - Static method in class java.lang. StrictMath
返回参数的乘积，如果结果溢出 int ，则抛出异常。
multiplyExact(long, int) - Static method in class java.lang. Math
返回参数的乘积，如果结果溢出 long ，则抛出异常。
multiplyExact(long, int) - Static method in class java.lang. StrictMath
返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
multiplyExact(long, long) - Static method in class java.lang. Math
返回参数的乘积，如果结果溢出 long ，则抛出异常。
multiplyExact(long, long) - Static method in class java.lang. StrictMath
返回参数的乘积，如果结果溢出 long ，则抛出异常。
multiplyFull(int, int) - Static method in class java.lang. Math
返回参数的确切数学积。
multiplyFull(int, int) - Static method in class java.lang. StrictMath
返回参数的确切数学积。
multiplyHigh(long, long) - Static method in class java.lang. Math
作为 long返回两个64位因子的128位乘积的最高64位。
multiplyHigh(long, long) - Static method in class java.lang. StrictMath
作为 long返回的两个64位因子的128位乘积中最重要的64位。
MultiPopupMenuUI - Class in javax.swing.plaf.multi
用于组合 PopupMenuUI的复用UI。
MultiPopupMenuUI() - Constructor for class javax.swing.plaf.multi. MultiPopupMenuUI
MultiProgressBarUI - Class in javax.swing.plaf.multi
用于组合 ProgressBarUI的复用UI。
MultiProgressBarUI() - Constructor for class javax.swing.plaf.multi. MultiProgressBarUI
MultiResolutionImage - Interface in java.awt.image
该接口被设计为一些可选的附加API，由Image的一些实现支持，以允许它们为各种渲染分辨率提供备用图像。
MultiRootPaneUI - Class in javax.swing.plaf.multi
用于组合 RootPaneUI的复用UI。
MultiRootPaneUI() - Constructor for class javax.swing.plaf.multi. MultiRootPaneUI
MultiScrollBarUI - Class in javax.swing.plaf.multi
用于组合 ScrollBarUI的复用UI。
MultiScrollBarUI() - Constructor for class javax.swing.plaf.multi. MultiScrollBarUI
MultiScrollPaneUI - Class in javax.swing.plaf.multi
用于组合 ScrollPaneUI的复用UI。
MultiScrollPaneUI() - Constructor for class javax.swing.plaf.multi. MultiScrollPaneUI
MULTISELECTABLE - Static variable in class javax.accessibility. AccessibleState
表示此对象允许同时选择多个子项。
MultiSeparatorUI - Class in javax.swing.plaf.multi
用于组合 SeparatorUI的复用UI。
MultiSeparatorUI() - Constructor for class javax.swing.plaf.multi. MultiSeparatorUI
MultiSliderUI - Class in javax.swing.plaf.multi
用于组合 SliderUI的复用UI。
MultiSliderUI() - Constructor for class javax.swing.plaf.multi. MultiSliderUI
MultiSpinnerUI - Class in javax.swing.plaf.multi
用于组合 SpinnerUI的复用UI。
MultiSpinnerUI() - Constructor for class javax.swing.plaf.multi. MultiSpinnerUI
MultiSplitPaneUI - Class in javax.swing.plaf.multi
用于组合 SplitPaneUI的复用UI。
MultiSplitPaneUI() - Constructor for class javax.swing.plaf.multi. MultiSplitPaneUI
MultiTabbedPaneUI - Class in javax.swing.plaf.multi
用于组合 TabbedPaneUI的复用UI。
MultiTabbedPaneUI() - Constructor for class javax.swing.plaf.multi. MultiTabbedPaneUI
MultiTableHeaderUI - Class in javax.swing.plaf.multi
用于组合 TableHeaderUI的复用UI。
MultiTableHeaderUI() - Constructor for class javax.swing.plaf.multi. MultiTableHeaderUI
MultiTableUI - Class in javax.swing.plaf.multi
用于组合 TableUI的复用UI。
MultiTableUI() - Constructor for class javax.swing.plaf.multi. MultiTableUI
MultiTextUI - Class in javax.swing.plaf.multi
用于组合 TextUI的复用UI。
MultiTextUI() - Constructor for class javax.swing.plaf.multi. MultiTextUI
MultiToolBarUI - Class in javax.swing.plaf.multi
用于组合 ToolBarUI的复用UI。
MultiToolBarUI() - Constructor for class javax.swing.plaf.multi. MultiToolBarUI
MultiToolTipUI - Class in javax.swing.plaf.multi
用于组合 ToolTipUI的复用UI。
MultiToolTipUI() - Constructor for class javax.swing.plaf.multi. MultiToolTipUI
MultiTreeUI - Class in javax.swing.plaf.multi
用于组合 TreeUI的复用UI。
MultiTreeUI() - Constructor for class javax.swing.plaf.multi. MultiTreeUI
MultiViewportUI - Class in javax.swing.plaf.multi
用于组合 ViewportUI的复用UI。
MultiViewportUI() - Constructor for class javax.swing.plaf.multi. MultiViewportUI
MUSICAL_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
常数为“音符”Unicode字符块。
mustSpecify() - Method in interface com.sun.jdi.connect. Connector.Argument
指示是否必须指定参数。
MutableAttributeSet - Interface in javax.swing.text
用于可变集合的唯一属性的通用界面。
MutableCallSite - Class in java.lang.invoke
A MutableCallSite是一个CallSite，其目标变量的行为像一个普通字段。
MutableCallSite(MethodHandle) - Constructor for class java.lang.invoke. MutableCallSite
创建一个具有初始目标方法句柄的调用站点对象。
MutableCallSite(MethodType) - Constructor for class java.lang.invoke. MutableCallSite
使用给定的方法类型创建一个空白的调用站点对象。
MutableComboBoxModel< E> - Interface in javax.swing
一个可变版本的 ComboBoxModel 。
MutableTreeNode - Interface in javax.swing.tree
定义可以通过添加或删除子节点或通过更改存储在节点中的用户对象的内容来更改的树节点对象的要求。
mutatesTo(Object, Object) - Method in class java.beans. DefaultPersistenceDelegate
如果指定构造函数中的参数数为非零，并且类别为 oldInstance显式声明“equals”方法，则此方法返回值为 oldInstance.equals(newInstance) 。
mutatesTo(Object, Object) - Method in class java.beans. PersistenceDelegate
如果通过将一系列语句应用于 newInstance可以创建 oldInstance的 等效副本，则返回true。
MutationEvent - Interface in org.w3c.dom.events
MutationEvent接口提供与Mutation事件相关的特定上下文信息。
MUTE - javafx.scene.input. KeyCode
常数为 Mute键。
MUTE - Static variable in class javax.sound.sampled. BooleanControl.Type
表示线路的静音状态的控制。
muteProperty() - Method in class javafx.scene.media. MediaPlayer
播放器音频是否静音
MXBean - Annotation Type in javax.management
用于将界面明确标记为MXBean接口或不作为MXBean接口的注释。
MXBEAN_FIELD - Static variable in class javax.management. JMX
名称为 mxbean字段。
mxxProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的X坐标缩放元素。
mxyProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的XY坐标元素。
mxzProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的XZ坐标元素。
MYANMAR - java.awt.font. NumericShaper.Range
缅甸的数字与缅甸数字相同。
MYANMAR - java.lang. Character.UnicodeScript
Unicode脚本“缅甸”。
MYANMAR - Static variable in class java.awt.font. NumericShaper
标识MYANMAR范围和十进制基数。
MYANMAR - Static variable in class java.lang. Character.UnicodeBlock
常数为“缅甸”Unicode字符块。
MYANMAR_EXTENDED_A - Static variable in class java.lang. Character.UnicodeBlock
“Myanmar Extended-A”Unicode字符块的常数。
MYANMAR_EXTENDED_B - Static variable in class java.lang. Character.UnicodeBlock
“缅甸扩展B”Unicode字符块的常量。
MYANMAR_SHAN - java.awt.font. NumericShaper.Range
缅甸与缅甸山脉的数字。
MYANMAR_TAI_LAING - java.awt.font. NumericShaper.Range
缅甸扩大B区与缅甸泰安数字。
myProps - Variable in class javax.naming. InitialContext
与此InitialContext关联的环境。
mySyntax - Variable in class javax.naming. CompoundName
此化合物名称的语法属性。
myxProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的YX坐标元素。
myyProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的Y坐标缩放元素。
myzProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的YZ坐标元素。
mzxProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的ZX坐标元素。
mzyProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的ZY坐标元素。
mzzProperty() - Method in class javafx.scene.transform. Affine
定义3x4矩阵的Z坐标缩放元素。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


N-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

N

N - javafx.scene.input. KeyCode
常数为 N关键。
N - Static variable in class javax.swing.text.html. HTML.Attribute
属性“n”
N_RESIZE - Static variable in class javafx.scene. Cursor
北移大小的游标类型。
N_RESIZE_CURSOR - Static variable in class java.awt. Cursor
北移大小的游标类型。
N_RESIZE_CURSOR - Static variable in class java.awt. Frame
已过时。
替换为Cursor.N_RESIZE_CURSOR 。
NA_10x13_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美10英寸×13英寸的信封尺寸。
NA_10X13_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
MediaType实例为北美10 x 13 in。
NA_10X13_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
10x13北美信封尺寸。
NA_10x14_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美10英寸×14英寸的信封尺寸。
NA_10X14_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美10 x 14英寸的MediaType实例。
NA_10X14_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
10x14美国信封大小。
NA_10X15_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
MediaType实例为北美10 x 15英寸
NA_10X15_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美10英寸×15英寸的信封尺寸。
NA_10X15_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
10x15北美信封尺寸。
NA_5X7 - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美5寸×7英寸的纸。
NA_5X7 - Static variable in class javax.print.attribute.standard. MediaSizeName
5x7北美纸。
NA_6X9_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美6 x 9的MediaType实例。
NA_6X9_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美6英寸×9英寸的信封尺寸。
NA_6X9_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
6x9北美信封尺寸。
NA_7X9_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美7 x 9英寸的MediaType实例。
NA_7X9_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美7英寸×9英寸的信封尺寸。
NA_7X9_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
7x9北美信封尺寸。
NA_8X10 - Static variable in class javafx.print. Paper
指定北美8寸×10英寸的纸。
NA_8X10 - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美8寸×10英寸的纸。
NA_8X10 - Static variable in class javax.print.attribute.standard. MediaSizeName
8x10美国北美纸。
NA_9x11_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美9英寸×11英寸的信封尺寸。
NA_9X11_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美9 x 11英寸的MediaType实例
NA_9X11_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
9x11北美信封尺寸。
NA_9x12_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美9英寸×12英寸的信封尺寸。
NA_9X12_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美9 x 12英寸的MediaType实例
NA_9X12_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
9x12北美信封尺寸。
NA_LEGAL - Static variable in class java.awt. PageAttributes.MediaType
北美法律的MediaType实例，8 1/2 x 14英寸
NA_LEGAL - Static variable in class javax.print.attribute.standard. MediaSizeName
合法尺寸
NA_LETTER - Static variable in class java.awt. PageAttributes.MediaType
北美信的MediaType实例，8 1/2 x 11 in。
NA_LETTER - Static variable in class javafx.print. Paper
指定北美字母大小，8.5英寸×11英寸
NA_LETTER - Static variable in class javax.print.attribute.standard. MediaSizeName
字母大小。
NA_LETTER_TRANSPARENT - Static variable in class javax.print.attribute.standard. MediaName
信件透明度。
NA_LETTER_WHITE - Static variable in class javax.print.attribute.standard. MediaName
白信纸。
NA_NUMBER_10_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
North America＃10 Business Envelope的MediaType实例，4 1/8 x 9 1/2 in。
NA_NUMBER_10_ENVELOPE - Static variable in class javafx.print. Paper
指定北美10号商业信封尺寸，4.125英寸×9.5英寸。
NA_NUMBER_10_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美10号商业信封尺寸，4.125英寸×9.5英寸。
NA_NUMBER_10_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
10号信封尺寸。
NA_NUMBER_11_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美＃11商业信封的MediaType实例，4 1/2 x 10 3/8 in。
NA_NUMBER_11_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美11号商业信封尺寸，4.5英寸×10.375英寸。
NA_NUMBER_11_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
11号信封尺寸。
NA_NUMBER_12_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美＃12商业信封的MediaType实例，4 3/4 x 11英寸
NA_NUMBER_12_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美第12号业务信封尺寸，4.75英寸×11英寸。
NA_NUMBER_12_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
12号信封尺寸。
NA_NUMBER_14_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
North American＃14 Business Envelope的MediaType实例，5 x 11 1/2 in。
NA_NUMBER_14_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美第14号业务信封尺寸，5英寸×11.5英寸。
NA_NUMBER_14_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
14号信封尺寸。
NA_NUMBER_9_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
北美＃9商业信封的MediaType实例，3 7/8 x 8 7/8 in。
NA_NUMBER_9_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.NA
指定北美第9号业务信封尺寸，3.875英寸×8.875英寸。
NA_NUMBER_9_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
9号信封尺寸。
NABATAEAN - java.lang. Character.UnicodeScript
Unicode脚本“Nabataean”。
NABATAEAN - Static variable in class java.lang. Character.UnicodeBlock
“Nabataean”Unicode字符块的常数。
name - Variable in class java.awt. Cursor
光标的用户可见名称。
name - Variable in class java.awt. Font
这个 Font的逻辑名称，传递给构造函数。
name - Variable in class java.sql. DriverPropertyInfo
物业的名称。
name - Variable in class javax.management. MBeanFeatureInfo
功能的名称。
name - Variable in class javax.swing.text.html.parser. AttributeList
属性名称
name - Variable in class javax.swing.text.html.parser. DTD
DTD的名称
name - Variable in class javax.swing.text.html.parser. Element
元素的名称
name - Variable in class javax.swing.text.html.parser. Entity
实体的名称。
name - Variable in class javax.xml.bind. JAXBElement
xml元素标签名称
name - Variable in class org.omg.CORBA. StructMember
由该 StructMember对象描述的结构体成员的名称。
name - Variable in class org.omg.CORBA. UnionMember
由该 UnionMember对象描述的联盟成员的名称。
name - Variable in class org.omg.CORBA. ValueMember
由 ValueMember对象描述的 value成员的名称。
name - Variable in exception org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateName
已经有一个拦截器的名字已经注册了。
name() - Method in interface com.sun.javadoc. Doc
已过时。
返回此Doc文件的非限定名称。
name() - Method in interface com.sun.javadoc. Parameter
已过时。
获取此参数的本地名称。
name() - Method in interface com.sun.javadoc. Tag
已过时。
返回此标签的名称。
name() - Method in interface com.sun.jdi.connect. Connector.Argument
返回参数的简短唯一标识符。
name() - Method in interface com.sun.jdi.connect. Connector
返回连接器的短标识符。
name() - Method in class com.sun.jdi.connect.spi. TransportService
返回一个名称以识别传输服务。
name() - Method in interface com.sun.jdi.connect. Transport
返回传输的简短标识符。
name() - Method in interface com.sun.jdi. LocalVariable
获取局部变量的名称。
name() - Method in interface com.sun.jdi. ModuleReference
返回模块名称。
name() - Method in interface com.sun.jdi. ReferenceType
获取此类型的完全限定名称。
name() - Method in interface com.sun.jdi. ThreadGroupReference
返回此线程组的名称。
name() - Method in interface com.sun.jdi. ThreadReference
返回此线程的名称。
name() - Method in interface com.sun.jdi. Type
name() - Method in interface com.sun.jdi. TypeComponent
获取此类型组件的名称。
name() - Method in interface com.sun.jdi. VirtualMachine
返回由属性 java.vm.name报告的目标VM的名称。
name() - Method in class com.sun.tools.attach.spi. AttachProvider
返回此提供商的名称。
name() - Method in class java.lang. Enum
返回此枚举常量的名称，与其枚举声明中声明的完全相同。
name() - Method in class java.lang.module. ModuleDescriptor
返回模块名称。
name() - Method in class java.lang.module. ModuleDescriptor.Requires
返回模块名称。
name() - Method in class java.lang.module. ResolvedModule
返回模块名称。
name() - Method in interface java.net. ProtocolFamily
返回协议族的名称。
name() - Method in interface java.net. SocketOption
返回套接字选项的名称。
name() - Method in class java.nio.charset. Charset
返回此字符集的规范名称。
name() - Method in interface java.nio.file.attribute. AclFileAttributeView
返回属性视图的名称。
name() - Method in interface java.nio.file.attribute. AttributeView
返回属性视图的名称。
name() - Method in interface java.nio.file.attribute. BasicFileAttributeView
返回属性视图的名称。
name() - Method in interface java.nio.file.attribute. DosFileAttributeView
返回属性视图的名称。
name() - Method in interface java.nio.file.attribute. FileAttribute
返回属性名称。
name() - Method in interface java.nio.file.attribute. FileOwnerAttributeView
返回属性视图的名称。
name() - Method in interface java.nio.file.attribute. PosixFileAttributeView
返回属性视图的名称。
name() - Method in interface java.nio.file.attribute. UserDefinedFileAttributeView
返回此属性视图的名称。
name() - Method in class java.nio.file. FileStore
返回此文件存储的名称。
name() - Method in interface java.nio.file. WatchEvent.Kind
返回事件类型的名称。
name() - Method in interface java.nio.file. WatchEvent.Modifier
返回修饰符的名称。
name() - Method in class java.util.prefs. AbstractPreferences
实现 name方法按照在本说明书中 Preferences.name() 。
name() - Method in class java.util.prefs. Preferences
返回此首选项节点的名称，相对于其父项。
name() - Method in interface java.util.spi. ToolProvider
返回此工具提供程序的名称。
name() - Method in interface javax.tools. Tool
返回此工具的名称，如果未提供名称，则返回空字符串。
name() - Method in class jdk.jshell.execution. FailOverExecutionControlProvider
这个唯一的名字 ExecutionControlProvider 。
name() - Method in class jdk.jshell.execution. JdiExecutionControlProvider
这个独特的名字 ExecutionControlProvider 。
name() - Method in class jdk.jshell.execution. LocalExecutionControlProvider
这个独特的名字 ExecutionControlProvider 。
name() - Method in class jdk.jshell. ExpressionSnippet
变量名称是表达式的值。
name() - Method in class jdk.jshell. ImportSnippet
导入的识别名称。
name() - Method in class jdk.jshell. PersistentSnippet
代码片段的名称
name() - Method in class jdk.jshell.spi. ExecutionControl.ClassBytecodes
班级名称
name() - Method in interface jdk.jshell.spi. ExecutionControlProvider
这个独特的名字 ExecutionControlProvider 。
name() - Method in class org.omg.CORBA. NamedValue
检索此 NamedValue对象的名称。
name() - Method in class org.omg.CORBA. Principal
已过时。
被CORBA弃用2.2。
name() - Method in class org.omg.CORBA. TypeCode
检索在其封闭范围内识别此 TypeCode对象的简单名称。
name() - Method in interface org.omg.PortableInterceptor. InterceptorOperations
返回拦截器的名称。
name(byte[]) - Method in class org.omg.CORBA. Principal
已过时。
被CORBA弃用2.2。
name(String) - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder
设置属性的名称
name(String) - Method in class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder
设置属性的名称
Name - Interface in javax.lang.model.element
一个不可变的人物序列。
Name - Interface in javax.naming
Name接口表示通用名称 - 组件的有序序列。
Name - Interface in javax.xml.soap
XML名称的表示形式。
Name(String) - Constructor for class java.util.jar. Attributes.Name
使用给定的字符串名称构造一个新的属性名称。
NAME - Static variable in interface javax.script. ScriptEngine
用于标识脚本语言的短名称的命名值的保留键。
NAME - Static variable in interface javax.swing. Action
用于存储用于操作的 String名称的键，用于菜单或按钮。
NAME - Static variable in class javax.swing.text.html. HTML.Attribute
属性“名称”
NAME - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NAME
NAME_CHAINING - java.security.cert. PKIXReason
证书链不正确。
NAME_NOT_MN - Static variable in exception org.ietf.jgss. GSSException
名称包含多机制元素。
name2type(String) - Static method in class javax.swing.text.html.parser. AttributeList
将属性名称转换为类型
name2type(String) - Static method in class javax.swing.text.html.parser. Element
转换 nm输入。
name2type(String) - Static method in class javax.swing.text.html.parser. Entity
将 nm字符串转换为相应的实体类型。
NameAlreadyBoundException - Exception in javax.naming
通过方法抛出此异常，表示无法添加绑定，因为该名称已被绑定到另一个对象。
NameAlreadyBoundException() - Constructor for exception javax.naming. NameAlreadyBoundException
构造一个新的NameAlreadyBoundException实例。
NameAlreadyBoundException(String) - Constructor for exception javax.naming. NameAlreadyBoundException
使用提供的说明构造一个新的NameAlreadyBoundException实例。
NameAttribute - Static variable in interface javax.swing.text. AttributeSet
用于命名属性集合的属性名称。
NameAttribute - Static variable in class javax.swing.text. StyleConstants
用于命名属性集合的属性名称。
NameCallback - Class in javax.security.auth.callback
基础安全服务实例，并通过一个 NameCallback至 handle一个方法 CallbackHandler ，以获取名称信息。
NameCallback(String) - Constructor for class javax.security.auth.callback. NameCallback
构造一个 NameCallback提示符。
NameCallback(String, String) - Constructor for class javax.security.auth.callback. NameCallback
构造一个 NameCallback具有提示和默认名称。
NameClassPair - Class in javax.naming
此类表示在上下文中找到的绑定的对象名称和类名称对。
NameClassPair(String, String) - Constructor for class javax.naming. NameClassPair
构造一个NameClassPair的实例，其名称和类名称。
NameClassPair(String, String, boolean) - Constructor for class javax.naming. NameClassPair
构造一个NameClassPair的实例，其名称，类名称以及它是否与列表上下文相关。
NameComponent - Class in org.omg.CosNaming
org / omg / CosNaming / NameComponent.java。
NameComponent() - Constructor for class org.omg.CosNaming. NameComponent
NameComponent(String, String) - Constructor for class org.omg.CosNaming. NameComponent
NameComponentHelper - Class in org.omg.CosNaming
org / omg / CosNaming / NameComponentHelper.java。
NameComponentHelper() - Constructor for class org.omg.CosNaming. NameComponentHelper
NameComponentHolder - Class in org.omg.CosNaming
org / omg / CosNaming / NameComponentHolder.java。
NameComponentHolder() - Constructor for class org.omg.CosNaming. NameComponentHolder
NameComponentHolder(NameComponent) - Constructor for class org.omg.CosNaming. NameComponentHolder
named(Object) - Method in interface jdk.dynalink. Operation
以此操作为基础返回一个NamedOperation 。
NamedArg - Annotation Type in javafx.beans
提供参数名称信息的注释。
namedItem(String) - Method in interface org.w3c.dom.html. HTMLCollection
此方法使用名称检索 Node 。
NamedNodeMap - Interface in org.w3c.dom
实现 NamedNodeMap接口的对象用于表示可以通过名称访问的节点集合。
NamedOperation - Class in jdk.dynalink
将名称与另一个操作相关联的操作。
NamedOperation(Operation, Object) - Constructor for class jdk.dynalink. NamedOperation
创建一个新的命名操作。
NamedStyle() - Constructor for class javax.swing.text. StyleContext.NamedStyle
创建一个新的命名样式，具有null名称和父项。
NamedStyle(String, Style) - Constructor for class javax.swing.text. StyleContext.NamedStyle
创建一个新的命名样式。
NamedStyle(Style) - Constructor for class javax.swing.text. StyleContext.NamedStyle
创建一个新的命名样式。
NamedValue - Class in org.omg.CORBA
DII和DSI中使用的对象来描述参数和返回值。
NamedValue() - Constructor for class org.omg.CORBA. NamedValue
NameDynAnyPair - Class in org.omg.DynamicAny
org / omg / DynamicAny / NameDynAnyPair.java。
NameDynAnyPair() - Constructor for class org.omg.DynamicAny. NameDynAnyPair
NameDynAnyPair(String, DynAny) - Constructor for class org.omg.DynamicAny. NameDynAnyPair
NameDynAnyPairHelper - Class in org.omg.DynamicAny
org / omg / DynamicAny / NameDynAnyPairHelper.java。
NameDynAnyPairHelper() - Constructor for class org.omg.DynamicAny. NameDynAnyPairHelper
NameDynAnyPairSeqHelper - Class in org.omg.DynamicAny
org / omg / DynamicAny / NameDynAnyPairSeqHelper.java。
NameDynAnyPairSeqHelper() - Constructor for class org.omg.DynamicAny. NameDynAnyPairSeqHelper
NameHelper - Class in org.omg.CosNaming
名称是名称组件的序列。
NameHelper() - Constructor for class org.omg.CosNaming. NameHelper
NameHolder - Class in org.omg.CosNaming
名称是名称组件的序列。
NameHolder() - Constructor for class org.omg.CosNaming. NameHolder
NameHolder(NameComponent[]) - Constructor for class org.omg.CosNaming. NameHolder
NameList - Interface in org.w3c.dom
NameList接口提供了并行对名称和命名空间值（可以为空值）的抽象，而不定义或约束如何实现此集合。
NameNotFoundException - Exception in javax.naming
当名称的组件由于未绑定而无法解析时抛出此异常。
NameNotFoundException() - Constructor for exception javax.naming. NameNotFoundException
构造一个新的NameNotFoundException实例。
NameNotFoundException(String) - Constructor for exception javax.naming. NameNotFoundException
使用提供的说明构造一个新的NameNotFoundException实例。
NameParser - Interface in javax.naming
此接口用于从分层命名空间中解析名称。
nameProperty() - Method in class javafx.scene.chart. PieChart.Data
饼图的名称
nameProperty() - Method in class javafx.scene.chart. XYChart.Series
该系列的用户可显示的名称
names - Variable in class javax.imageio.spi. ImageReaderWriterSpi
要从 getFormatNames返回的字符串数组，最初为 null 。
NAMES - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NAMES
Namespace - Interface in javax.xml.stream.events
包含名称空间信息的界面。
Namespace - Interface in jdk.dynalink
描述作为对象的动态操作目标的命名空间的对象。
NAMESPACE - Static variable in interface javax.xml.stream. XMLStreamConstants
表示事件是一个命名空间声明
NAMESPACE_ERR - Static variable in exception org.w3c.dom. DOMException
如果尝试以不符合命名空间的方式创建或更改对象。
NamespaceChangeListener - Interface in javax.naming.event
指定对名称空间更改感兴趣的侦听器必须实现的方法。
NamespaceContext - Interface in javax.xml.namespace
只读XML接口名称空间上下文处理。
NamespaceOperation - Class in jdk.dynalink
描述对一个对象的至少一个Namespace进行操作的操作。
NamespaceOperation(Operation, Namespace...) - Constructor for class jdk.dynalink. NamespaceOperation
构造一个新的命名空间操作。
NamespaceSupport - Class in org.xml.sax.helpers
封装使用SAX的应用程序或由SAX驱动程序内部使用的命名空间逻辑。
NamespaceSupport() - Constructor for class org.xml.sax.helpers. NamespaceSupport
创建一个新的Namespace支持对象。
nameUUIDFromBytes(byte[]) - Static method in class java.util. UUID
静态工厂根据指定的字节数组检索类型3（基于名称） UUID 。
NameValuePair - Class in org.omg.CORBA
将名称与作为IDL结构体的属性的值相关联，并在 DynStruct API中使用。
NameValuePair - Class in org.omg.DynamicAny
org / omg / DynamicAny / NameValuePair.java。
NameValuePair() - Constructor for class org.omg.CORBA. NameValuePair
构造一个空的 NameValuePair对象。
NameValuePair() - Constructor for class org.omg.DynamicAny. NameValuePair
NameValuePair(String, Any) - Constructor for class org.omg.CORBA. NameValuePair
构造一个 NameValuePair对象，它将给定的名称与给定的 org.omg.CORBA.Any对象相关联。
NameValuePair(String, Any) - Constructor for class org.omg.DynamicAny. NameValuePair
NameValuePairHelper - Class in org.omg.CORBA
助手 NameValuePair 。
NameValuePairHelper - Class in org.omg.DynamicAny
org / omg / DynamicAny / NameValuePairHelper.java。
NameValuePairHelper() - Constructor for class org.omg.CORBA. NameValuePairHelper
NameValuePairHelper() - Constructor for class org.omg.DynamicAny. NameValuePairHelper
NameValuePairSeqHelper - Class in org.omg.DynamicAny
org / omg / DynamicAny / NameValuePairSeqHelper.java。
NameValuePairSeqHelper() - Constructor for class org.omg.DynamicAny. NameValuePairSeqHelper
Naming - Class in java.rmi
Naming类提供了存储和获取对远程对象注册表中远程对象的引用的方法。
NamingContext - Interface in org.omg.CosNaming
命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
NamingContextExt - Interface in org.omg.CosNaming
NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
NamingContextExtHelper - Class in org.omg.CosNaming
NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
NamingContextExtHelper() - Constructor for class org.omg.CosNaming. NamingContextExtHelper
NamingContextExtHolder - Class in org.omg.CosNaming
NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
NamingContextExtHolder() - Constructor for class org.omg.CosNaming. NamingContextExtHolder
NamingContextExtHolder(NamingContextExt) - Constructor for class org.omg.CosNaming. NamingContextExtHolder
NamingContextExtOperations - Interface in org.omg.CosNaming
NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
NamingContextExtPOA - Class in org.omg.CosNaming
NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
NamingContextExtPOA() - Constructor for class org.omg.CosNaming. NamingContextExtPOA
NamingContextHelper - Class in org.omg.CosNaming
命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
NamingContextHelper() - Constructor for class org.omg.CosNaming. NamingContextHelper
NamingContextHolder - Class in org.omg.CosNaming
命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
NamingContextHolder() - Constructor for class org.omg.CosNaming. NamingContextHolder
NamingContextHolder(NamingContext) - Constructor for class org.omg.CosNaming. NamingContextHolder
NamingContextOperations - Interface in org.omg.CosNaming
命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
NamingContextPOA - Class in org.omg.CosNaming
命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
NamingContextPOA() - Constructor for class org.omg.CosNaming. NamingContextPOA
NamingEnumeration< T> - Interface in javax.naming
此接口用于枚举javax.naming和javax.naming.directory包中的方法返回的列表。
NamingEvent - Class in javax.naming.event
此类表示由命名/目录服务触发的事件。
NamingEvent(EventContext, int, Binding, Binding, Object) - Constructor for class javax.naming.event. NamingEvent
构造一个 NamingEvent的实例。
NamingException - Exception in javax.naming
这是Context和DirContext接口中的操作抛出的所有异常的超类。
NamingException() - Constructor for exception javax.naming. NamingException
构造一个新的NamingException。
NamingException(String) - Constructor for exception javax.naming. NamingException
构造一个新的NamingException和解释。
NamingExceptionEvent - Class in javax.naming.event
此类表示当用于收集通知听众的信息的过程/过程 NamingEvent抛出 NamingException 。
NamingExceptionEvent(EventContext, NamingException) - Constructor for class javax.naming.event. NamingExceptionEvent
构造一个实例 NamingExceptionEvent使用其中的背景下 NamingException被抛出，并且抛出的异常。
namingExceptionThrown(NamingExceptionEvent) - Method in interface javax.naming.event. NamingListener
在尝试触发 NamingEvent抛出命名异常时调用。
NamingListener - Interface in javax.naming.event
此接口是处理 NamingEvent s的侦听器接口的根。
NamingManager - Class in javax.naming.spi
该类包含用于创建命名或目录服务中位置信息引用的上下文对象和对象的方法。
NamingSecurityException - Exception in javax.naming
这是Context和DirContext接口中的操作抛出的与安全相关异常的超类。
NamingSecurityException() - Constructor for exception javax.naming. NamingSecurityException
构造一个新的NamingSecurityException实例。
NamingSecurityException(String) - Constructor for exception javax.naming. NamingSecurityException
使用提供的说明构造一个新的NamingSecurityException实例。
NaN - Static variable in class java.lang. Double
一个持有非数字（NaN）值的常数，类型为 double 。
NaN - Static variable in class java.lang. Float
一个持有非数字（NaN）值的常数，类型为 float 。
NANO_OF_DAY - java.time.temporal. ChronoField
纳纳天。
NANO_OF_SECOND - java.time.temporal. ChronoField
纳秒秒。
NANOS - java.time.temporal. ChronoUnit
代表纳秒概念的单位，最小支持的时间单位。
NANOSECONDS - java.util.concurrent. TimeUnit
时间单位代表千分之一千分之一。
nanoTime() - Static method in class java.lang. System
以纳秒为单位返回正在运行的Java虚拟机的高分辨率时间源的当前值。
narrow(Object, Class) - Method in interface javax.rmi.CORBA. PortableRemoteObjectDelegate
代表团要求 PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 。
narrow(Object, Class) - Static method in class javax.rmi. PortableRemoteObject
检查以确保远程或抽象接口类型的对象可以转换为所需类型。
narrow(Object) - Static method in class org.omg.CORBA. CurrentHelper
narrow(Object) - Static method in class org.omg.CORBA. IDLTypeHelper
narrow(Object) - Static method in class org.omg.CORBA. PolicyHelper
narrow(Object) - Static method in class org.omg.CosNaming. BindingIteratorHelper
narrow(Object) - Static method in class org.omg.CosNaming. NamingContextExtHelper
narrow(Object) - Static method in class org.omg.CosNaming. NamingContextHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynAnyHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynArrayHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynEnumHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynFixedHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynSequenceHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynStructHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynUnionHelper
narrow(Object) - Static method in class org.omg.DynamicAny. DynValueHelper
narrow(Object) - Static method in class org.omg.IOP. CodecFactoryHelper
narrow(Object) - Static method in class org.omg.PortableInterceptor. CurrentHelper
narrow(Object) - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper
narrow(Object) - Static method in class org.omg.PortableServer. CurrentHelper
narrow(Object) - Static method in class org.omg.PortableServer. POAHelper
narrow(Object) - Static method in class org.omg.PortableServer. ServantActivatorHelper
narrow(Object) - Static method in class org.omg.PortableServer. ServantLocatorHelper
NARROW - java.time.format. TextStyle
缩小的文字，通常是单个字母。
NARROW_FORMAT - Static variable in class java.util. Calendar
getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的窄名称。
NARROW_STANDALONE - java.time.format. TextStyle
单独使用的窄文本，通常是单个字母。
NARROW_STANDALONE - Static variable in class java.util. Calendar
getDisplayName和 getDisplayNames的样式说明符独立地表示一个狭义的名称。
NASHORN_GLOBAL - Static variable in class jdk.nashorn.api.scripting. NashornScriptEngine
用于将Nashorn全局对象镜像与任意Bindings实例相关联的关键字。
NashornException - Exception in jdk.nashorn.api.scripting
这是所有Nashorn异常的基础例外。
NashornException(String, String, int, int) - Constructor for exception jdk.nashorn.api.scripting. NashornException
构造函数初始化错误消息，文件名，行和列号。
NashornException(String, Throwable) - Constructor for exception jdk.nashorn.api.scripting. NashornException
构造器初始化错误消息并导致异常。
NashornException(String, Throwable, String, int, int) - Constructor for exception jdk.nashorn.api.scripting. NashornException
构造器初始化错误消息，导致异常，文件名，行和列号。
NashornScriptEngine - Class in jdk.nashorn.api.scripting
适用于Nashorn的JSR-223兼容脚本引擎。
NashornScriptEngineFactory - Class in jdk.nashorn.api.scripting
适用于Nashorn的JSR-223兼容脚本引擎工厂。
NashornScriptEngineFactory() - Constructor for class jdk.nashorn.api.scripting. NashornScriptEngineFactory
Native - Annotation Type in java.lang.annotation
表示定义常量值的字段可以从本地代码引用。
NATIVE - javax.lang.model.element. Modifier
修饰词 native
NATIVE - Static variable in class java.awt. JobAttributes.DialogType
用于指定平台的本机打印对话框的 DialogType实例。
NATIVE - Static variable in class java.lang.reflect. Modifier
int值代表 native修饰符。
NATIVE - Static variable in class javax.print.attribute.standard. DialogTypeSelection
NATIVE_HEADER_OUTPUT - javax.tools. StandardLocation
新的本地头文件的位置。
nativeImageMetadataFormatClassName - Variable in class javax.imageio.spi. ImageReaderWriterSpi
A String其中包含此插件支持的本机流元数据格式的类名，最初为 null 。
nativeImageMetadataFormatName - Variable in class javax.imageio.spi. ImageReaderWriterSpi
A String包含此插件支持的本机流元数据格式的名称，最初为 null 。
nativeMetadataFormatClassName - Variable in class javax.imageio.metadata. IIOMetadata
实现 IIOMetadataFormat并表示原生元数据格式的类的名称，初始化为 null并通过构造函数设置。
nativeMetadataFormatName - Variable in class javax.imageio.metadata. IIOMetadata
此对象的本机元数据格式的名称，初始化为 null并通过构造函数设置。
NativeMethodException - Exception in com.sun.jdi
抛出表示操作无法完成，因为它对本机方法无效。
NativeMethodException() - Constructor for exception com.sun.jdi. NativeMethodException
NativeMethodException(String) - Constructor for exception com.sun.jdi. NativeMethodException
nativeOrder() - Static method in class java.nio. ByteOrder
检索底层平台的本机字节顺序。
nativeSQL(String) - Method in interface java.sql. Connection
将给定的SQL语句转换为系统的本机SQL语法。
nativeStreamMetadataFormatClassName - Variable in class javax.imageio.spi. ImageReaderWriterSpi
A String其中包含此插件支持的本机流元数据格式的类名，最初为 null 。
nativeStreamMetadataFormatName - Variable in class javax.imageio.spi. ImageReaderWriterSpi
A String其中包含此插件支持的本机流元数据格式的名称，最初为 null 。
naturalOrder() - Static method in interface java.util. Comparator
返回一个以自然顺序比较Comparable对象的比较器。
NAVAJOWHITE - Static variable in class javafx.scene.paint. Color
颜色navajo白色，RGB值为#FFDEAD
navigableKeySet() - Method in interface java.util.concurrent. ConcurrentNavigableMap
返回此地图中包含的键的NavigableSet视图。
navigableKeySet() - Method in class java.util.concurrent. ConcurrentSkipListMap
navigableKeySet() - Method in interface java.util. NavigableMap
返回此地图中包含的键的NavigableSet视图。
navigableKeySet() - Method in class java.util. TreeMap
NavigableMap< K, V> - Interface in java.util
A SortedMap扩展了导航方法返回给定搜索目标的最接近的匹配。
NavigableSet< E> - Interface in java.util
A SortedSet扩展了导航方法，报告给定搜索目标的最匹配的匹配。
NavigateAction() - Constructor for class javax.swing.plaf.basic. BasicDesktopPaneUI.NavigateAction
navigateFocusedComp(int) - Method in class javax.swing.plaf.basic. BasicToolBarUI
浏览关注的组件。
navigateKey - Variable in class javax.swing.plaf.basic. BasicDesktopPaneUI
已过时。
截至1.3。
navigateKey2 - Variable in class javax.swing.plaf.basic. BasicDesktopPaneUI
已过时。
截至1.3。
navigateSelectedTab(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
浏览所选标签。
NavigationFilter - Class in javax.swing.text
可以使用 NavigationFilter来限制光标所在的位置。
NavigationFilter() - Constructor for class javax.swing.text. NavigationFilter
NavigationFilter.FilterBypass - Class in javax.swing.text
用来作为一种避开回调插入符来定位光标的方式。
NAVY - Static variable in class javafx.scene.paint. Color
RGB值为＃000080的彩色海军
NCHAR - java.sql. JDBCType
标识通用SQL类型 NCHAR 。
NCHAR - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NCHAR
NClob - Interface in java.sql
在Java的编程语言中映射为SQL NCLOB类型。
NCLOB - java.sql. JDBCType
标识通用SQL类型 NCLOB 。
NCLOB - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NCLOB 。
ncontext - Static variable in class org.omg.CosNaming. BindingType
nCopies(int, T) - Static method in class java.util. Collections
返回由指定对象的 n副本组成的不可变列表。
NE_RESIZE - Static variable in class javafx.scene. Cursor
东北调整大小的光标类型。
NE_RESIZE_CURSOR - Static variable in class java.awt. Cursor
东北调整大小的光标类型。
NE_RESIZE_CURSOR - Static variable in class java.awt. Frame
已过时。
替换为Cursor.NE_RESIZE_CURSOR 。
nearClipProperty() - Method in class javafx.scene. Camera
指定眼睛坐标空间中该 Camera的近剪取平面眼睛的距离。
NEED_TASK - javax.net.ssl. SSLEngineResult.HandshakeStatus
SSLEngine在握手之前需要一个（或多个）委派任务的结果。
NEED_UNWRAP - javax.net.ssl. SSLEngineResult.HandshakeStatus
握手之前， SSLEngine需要从远端接收数据。
NEED_UNWRAP_AGAIN - javax.net.ssl. SSLEngineResult.HandshakeStatus
SSLEngine需要在握手前展开才能继续。
NEED_WRAP - javax.net.ssl. SSLEngineResult.HandshakeStatus
SSLEngine必须在握手之前将数据发送到远程端才能继续，所以应该调用 SSLEngine.wrap() 。
needsCacheFile() - Method in class javax.imageio.spi. ImageInputStreamSpi
返回 true如果 ImageInputStream与此服务提供相关的实施需要使用一个缓存 File 。
needsCacheFile() - Method in class javax.imageio.spi. ImageOutputStreamSpi
返回 true如果 ImageOutputStream与此服务提供相关的实施需要使用一个缓存 File 。
needsDictionary() - Method in class java.util.zip. Inflater
如果需要预设字典进行解压缩，则返回true。
needsGui() - Method in class java.beans.beancontext. BeanContextSupport
通常从环境中调用此方法，以确定实现者是否“需要”GUI。
needsGui() - Method in interface java.beans. Visibility
确定这个bean是否需要GUI。
needsInput() - Method in class java.util.zip. Deflater
如果输入数据缓冲区为空，则返回true，并调用setInput（）以提供更多的输入。
needsInput() - Method in class java.util.zip. Inflater
如果输入缓冲区中没有数据，则返回true。
needsLayoutProperty() - Method in class javafx.scene. Parent
表示此节点及其子节点需要对下一个脉冲进行布局传递。
needsReload(String, Locale, String, ClassLoader, ResourceBundle, long) - Method in class java.util. ResourceBundle.Control
根据 loadTime或其他一些标准确定加载时间是否需要重新加载缓存中的过期 bundle 。
negate() - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (-this) ，其标为 this.scale() 。
negate() - Method in class java.math. BigInteger
返回值为 (-this)的BigInteger。
negate() - Method in interface java.util.function. BiPredicate
返回表示此谓词的逻辑否定的谓词。
negate() - Method in interface java.util.function. DoublePredicate
返回表示此谓词的逻辑否定的谓词。
negate() - Method in interface java.util.function. IntPredicate
返回表示此谓词的逻辑否定的谓词。
negate() - Method in interface java.util.function. LongPredicate
返回表示此谓词的逻辑否定的谓词。
negate() - Method in interface java.util.function. Predicate
返回表示此谓词的逻辑否定的谓词。
negate() - Method in class javafx.beans.binding. DoubleExpression
negate() - Method in class javafx.beans.binding. FloatExpression
negate() - Method in class javafx.beans.binding. IntegerExpression
negate() - Method in class javafx.beans.binding. LongExpression
negate() - Method in interface javafx.beans.binding. NumberExpression
创建一个新的NumberBinding计算的否定NumberExpression 。
negate() - Method in class javafx.util. Duration
从此实例返回一个具有负数毫秒的新的Duration实例。
negate() - Method in class javax.xml.datatype. Duration
返回值为 -this的新的 Duration对象。
negate(MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (-this) ，根据上下文设置进行舍入。
negate(ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的NumberBinding ，计算一个ObservableNumberValue的否定。
negated() - Method in interface java.time.chrono. ChronoPeriod
返回一个新的实例，每个金额在此期间被否定。
negated() - Method in class java.time. Duration
返回长度为否定的此持续时间的副本。
negated() - Method in class java.time. Period
返回一个新的实例，每个金额在此期间被否定。
negateExact(int) - Static method in class java.lang. Math
返回参数的否定，如果结果溢出一个 int ，则抛出异常。
negateExact(long) - Static method in class java.lang. Math
返回参数的否定，如果结果溢出一个 long ，则抛出异常。
NEGATIVE_INFINITY - Static variable in class java.lang. Double
持有 double类型的负无穷大的 double 。
NEGATIVE_INFINITY - Static variable in class java.lang. Float
持有 float型负无穷大的 float 。
NEGATIVE_SCROLL - Static variable in class javax.swing.plaf.basic. BasicSliderUI
负卷轴
NegativeArraySizeException - Exception in java.lang
抛出一个应用程序尝试创建一个负数大小的数组。
NegativeArraySizeException() - Constructor for exception java.lang. NegativeArraySizeException
构造一个没有详细消息的 NegativeArraySizeException 。
NegativeArraySizeException(String) - Constructor for exception java.lang. NegativeArraySizeException
构造具有指定详细消息的 NegativeArraySizeException 。
negotiate() - Method in class javax.naming.ldap. StartTlsResponse
使用默认的SSL套接字工厂协商TLS会话。
negotiate(SSLSocketFactory) - Method in class javax.naming.ldap. StartTlsResponse
使用SSL套接字工厂协商TLS会话。
nested - Variable in exception javax.xml.stream. XMLStreamException
NestedTableColumnHeader - Class in javafx.scene.control.skin
此类用于构造TableView的头。
NestedTableColumnHeader(TableColumnBase) - Constructor for class javafx.scene.control.skin. NestedTableColumnHeader
创建一个新的NestedTableColumnHeader实例来可视化地表示给定的TableColumnBase实例。
nestedTypes() - Method in interface com.sun.jdi. ReferenceType
返回一个包含ReferenceType对象的列表， 该对象在此类型中声明并且当前加载到虚拟机中。
NestingKind - Enum in javax.lang.model.element
一种类型元素的 嵌套类型。
NetPermission - Class in java.net
此类用于各种网络权限。
NetPermission(String) - Constructor for class java.net. NetPermission
创建一个具有指定名称的新NetPermission。
NetPermission(String, String) - Constructor for class java.net. NetPermission
创建具有指定名称的新NetPermission对象。
netscape.javascript - package netscape.javascript
使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
NetworkChannel - Interface in java.nio.channels
到网络插座的通道。
networkInterface() - Method in class java.nio.channels. MembershipKey
返回创建此会员密钥的网络接口。
NetworkInterface - Class in java.net
此类表示由名称组成的网络接口和分配给此接口的IP地址列表。
networkInterfaces() - Static method in class java.net. NetworkInterface
返回本机上所有接口的 Stream 。
NetworkPermission - Class in jdk.net
表示访问jdk.net包中定义的扩展网络功能的权限。
NetworkPermission(String) - Constructor for class jdk.net. NetworkPermission
使用给定的目标名称创建一个NetworkPermission。
NetworkPermission(String, String) - Constructor for class jdk.net. NetworkPermission
使用给定的目标名称创建一个NetworkPermission。
NEVER - java.time.format. SignStyle
样式从不输出符号，只输出绝对值。
NEVER - javafx.scene.control. ScrollPane.ScrollBarPolicy
表示不应显示滚动条。
NEVER - javafx.scene.layout. Priority
当区域可用空间有所增加（或减少）时，布局区域将永远不会增长（或缩小）。
NEVER - jdk.incubator.http. HttpClient.Redirect
从不重定向
NEVER_UPDATE - Static variable in class javax.swing.text. DefaultCaret
表示插入符号应保持在文档中相同的绝对位置，无论文档更新如何，除非文档长度由于删除而小于当前插入符号位置。
NEW - com.sun.source.tree. MemberReferenceTree.ReferenceMode
枚举常数用于构造函数引用。
NEW - java.lang. Thread.State
线程尚未启动的线程状态。
NEW - jdk.dynalink. StandardOperation
调用构造函数对象。
NEW - jdk.nashorn.api.tree. Tree.Kind
用于NewTree的实例。
NEW_ARRAY - com.sun.source.tree. Tree.Kind
用于NewArrayTree的实例。
NEW_CLASS - com.sun.source.tree. Tree.Kind
用于NewClassTree的实例。
new_context() - Method in class org.omg.CosNaming. _NamingContextExtStub
此操作返回与调用操作的上下文相同的命名服务器实现的命名上下文。
new_context() - Method in class org.omg.CosNaming. _NamingContextStub
此操作返回与调用操作的上下文相同的命名服务器实现的命名上下文。
new_context() - Method in interface org.omg.CosNaming. NamingContextOperations
此操作返回与调用操作的上下文相同的命名服务器实现的命名上下文。
NEW_SUBFILE_TYPE_REDUCED_RESOLUTION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“NewSubfileType”标签一起使用的掩码。
NEW_SUBFILE_TYPE_SINGLE_PAGE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“NewSubfileType”标签一起使用的掩码。
NEW_SUBFILE_TYPE_TRANSPARENCY - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“NewSubfileType”标签一起使用的掩码。
NEW_TAI_LUE - java.awt.font. NumericShaper.Range
新泰乐系列与新泰乐数位。
NEW_TAI_LUE - java.lang. Character.UnicodeScript
Unicode脚本“New_Tai_Lue”。
NEW_TAI_LUE - Static variable in class java.lang. Character.UnicodeBlock
“新泰乐”Unicode字符块的常数。
newActivation(String[]) - Method in interface javax.jnlp. SingleInstanceListener
该方法应该由应用程序来实现，以处理单一实例行为 - 应用程序如何使用params调用应用程序的另一个实例时如何处理参数。
NewArrayTree - Interface in com.sun.source.tree
用于创建数组的新实例的表达式的树节点。
newAsynchronousFileChannel(Path, Set<? extends OpenOption>, ExecutorService, FileAttribute<?>...) - Method in class java.nio.file.spi. FileSystemProvider
打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
newAttributes - Variable in class javax.swing.text. DefaultStyledDocument.AttributeUndoableEdit
包含其他条目的AttributeSet必须是不可变的！
newAttributeTree(Name, AttributeTree.ValueKind, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 AttributeTree对象，以在HTML标签中表示HTML属性。
newAudioClip(URL) - Static method in class java.applet. Applet
已过时。
从给定的URL获取音频剪辑。
newAuthorTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 AuthorTree对象，以表示一个 {@author }标签。
newAutomaticModule(String) - Static method in class java.lang.module. ModuleDescriptor
实例化构建器为自动模块构建模块描述符。
newBinding - Variable in class javax.naming.event. NamingEvent
更改后包含有关对象的信息。
newBufferedReader(Path) - Static method in class java.nio.file. Files
打开一个文件进行阅读，返回一个 BufferedReader以高效的方式从文件读取文本。
newBufferedReader(Path, Charset) - Static method in class java.nio.file. Files
打开一个文件进行阅读，返回一个 BufferedReader ，可以用来以有效的方式从文件中读取文本。
newBufferedWriter(Path, Charset, OpenOption...) - Static method in class java.nio.file. Files
打开或创建一个写入文件，返回一个 BufferedWriter ，可用于以有效的方式将文本写入文件。
newBufferedWriter(Path, OpenOption...) - Static method in class java.nio.file. Files
打开或创建一个写入文件，返回一个 BufferedWriter以高效的方式写入文件。
newBuilder() - Static method in class java.nio.file.attribute. AclEntry
构建一个新的构建器。
newBuilder() - Static method in class jdk.incubator.http. HttpClient
创建一个新的 HttpClient构建器。
newBuilder() - Static method in class jdk.incubator.http. HttpRequest
创建一个 HttpRequest器。
newBuilder(URI) - Static method in class jdk.incubator.http. HttpRequest
创建一个 HttpRequest构建器。
newBuilder(AclEntry) - Static method in class java.nio.file.attribute. AclEntry
使用现有ACL条目的组件构造一个新构建器。
newBundle(String, Locale, String, ClassLoader, boolean) - Method in class java.util. ResourceBundle.Control
为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。
newByteChannel(Path, OpenOption...) - Static method in class java.nio.file. Files
打开或创建文件，返回可访问的字节通道以访问该文件。
newByteChannel(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Static method in class java.nio.file. Files
打开或创建文件，返回可访问的字节通道以访问该文件。
newByteChannel(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Method in class java.nio.file.spi. FileSystemProvider
打开或创建文件，返回可访问的字节通道以访问该文件。
newByteChannel(T, Set<? extends OpenOption>, FileAttribute<?>...) - Method in interface java.nio.file. SecureDirectoryStream
在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。
newCachedThreadPool() - Static method in class java.util.concurrent. Executors
创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程。
newCachedThreadPool(ThreadFactory) - Static method in class java.util.concurrent. Executors
创建一个根据需要创建新线程的线程池，但在可用时将重新使用以前构造的线程，并在需要时使用提供的ThreadFactory创建新线程。
newCall(RemoteObject, Operation[], int, long) - Method in interface java.rmi.server. RemoteRef
已过时。
1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
newCanonicalizationMethod(String, C14NMethodParameterSpec) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
为指定的算法URI和参数创建一个 CanonicalizationMethod 。
newCanonicalizationMethod(String, XMLStructure) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
为指定的算法URI和参数创建一个 CanonicalizationMethod 。
newChannel(InputStream) - Static method in class java.nio.channels. Channels
构造从给定流读取字节的通道。
newChannel(OutputStream) - Static method in class java.nio.channels. Channels
构造一个向给定流写入字节的通道。
NewClassTree - Interface in com.sun.source.tree
一个树节点来声明一个类的新实例。
newClient(Object) - Method in interface javax.management.remote.rmi. RMIServer
通过此RMI连接器进行新的连接。
newClient(Object) - Method in class javax.management.remote.rmi. RMIServerImpl_Stub
newClient(Object) - Method in class javax.management.remote.rmi. RMIServerImpl
创建一个新的客户端连接。
newCodeTree(TextTree) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 CodeTree对象，以表示一个 {@code }标签。
newCommentTree(String) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 CommentTree ，以表示HTML注释。
newCondition() - Method in interface java.util.concurrent.locks. Lock
返回一个新Condition绑定到该实例Lock实例。
newCondition() - Method in class java.util.concurrent.locks. ReentrantLock
返回Condition与此使用实例Lock实例。
newCondition() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock
抛出 UnsupportedOperationException因为 ReadLocks不支持条件。
newCondition() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock
返回Condition与此使用实例Lock实例。
newDataAvailable(TableModelEvent) - Method in class javax.swing.table. DefaultTableModel
相当于 fireTableChanged 。
newDecoder() - Method in class java.nio.charset. Charset
为此字符集构造一个新的解码器。
newDefaultFactory() - Static method in class javax.xml.stream. XMLEventFactory
创建一个 XMLEventFactory内建系统默认实现的新实例。
newDefaultFactory() - Static method in class javax.xml.stream. XMLInputFactory
创建一个 XMLInputFactory内置系统默认实现的新实例。
newDefaultFactory() - Static method in class javax.xml.stream. XMLOutputFactory
创建一个新的 XMLOutputFactory内置系统默认实现实例。
newDefaultInstance() - Static method in class javax.xml.datatype. DatatypeFactory
创建一个新的实例 DatatypeFactory builtin system-default implementation 。
newDefaultInstance() - Static method in class javax.xml.parsers. DocumentBuilderFactory
创建一个 DocumentBuilderFactory内置系统默认实现的新实例。
newDefaultInstance() - Static method in class javax.xml.parsers. SAXParserFactory
创建一个 SAXParserFactory内置系统默认实现的新实例。
newDefaultInstance() - Static method in class javax.xml.transform. TransformerFactory
创建一个新的 TransformerFactory内置系统默认实现实例。
newDefaultInstance() - Static method in class javax.xml.validation. SchemaFactory
创建一个新的 SchemaFactory内置系统默认实现实例。
newDefaultInstance() - Static method in class javax.xml.xpath. XPathFactory
创建一个新的 XPathFactory内建系统默认实现实例。
newDeprecatedTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 DeprecatedTree对象，以表示一个 {@deprecated }标签。
newDigestMethod(String, DigestMethodParameterSpec) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
为指定的算法URI和参数创建一个 DigestMethod 。
newDirectoryStream(Path) - Static method in class java.nio.file. Files
打开一个目录，返回一个DirectoryStream以遍历目录中的所有条目。
newDirectoryStream(Path, String) - Static method in class java.nio.file. Files
打开一个目录，返回一个DirectoryStream以遍历目录中的条目。
newDirectoryStream(Path, DirectoryStream.Filter<? super Path>) - Static method in class java.nio.file. Files
打开一个目录，返回一个DirectoryStream来迭代目录中的条目。
newDirectoryStream(Path, DirectoryStream.Filter<? super Path>) - Method in class java.nio.file.spi. FileSystemProvider
打开一个目录，返回一个 DirectoryStream以遍历目录中的条目。
newDirectoryStream(T, LinkOption...) - Method in interface java.nio.file. SecureDirectoryStream
打开由给定路径标识的目录，返回一个 SecureDirectoryStream以遍历目录中的条目。
newDocCommentTree(List<? extends DocTree>, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 DocCommentTree对象，以表示完整的文档注释。
newDocRootTree() - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 DocRootTree对象，以表示一个 {@docroot}标签。
newDocument() - Method in class javax.xml.parsers. DocumentBuilder
获取DOM Document对象的新实例来构建一个DOM树。
newDocumentBuilder() - Method in class javax.xml.parsers. DocumentBuilderFactory
使用当前配置的参数创建一个新的DocumentBuilder实例。
newDuration(boolean, int, int, int, int, int, int) - Method in class javax.xml.datatype. DatatypeFactory
获取一个新的 Duration实例，指定 Duration为isPositive，年，月，日，小时，分钟，秒。
newDuration(boolean, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigDecimal) - Method in class javax.xml.datatype. DatatypeFactory
获取一个新的 Duration实例，指定 Duration为isPositive，年，月，日，小时，分钟，秒。
newDuration(long) - Method in class javax.xml.datatype. DatatypeFactory
获取 Duration的新实例，指定 Duration为毫秒。
newDuration(String) - Method in class javax.xml.datatype. DatatypeFactory
获取 Duration的新实例，指定 Duration作为其XML Schema 1.0第3.2.6.1节中定义的字符串表示形式“PnYnMnDTnHnMnS”。
newDurationDayTime(boolean, int, int, int, int) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration类型的 xdt:dayTimeDuration使用指定 day ， hour ， minute和 second中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 。
newDurationDayTime(boolean, BigInteger, BigInteger, BigInteger, BigInteger) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration类型的 xdt:dayTimeDuration使用指定 day ， hour ， minute和 second中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 。
newDurationDayTime(long) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration类型的 xdt:dayTimeDuration使用指定毫秒中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 。
newDurationDayTime(String) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration型 xdt:dayTimeDuration通过分析其 String表示 ，“PnDTnHnMnS” XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 。
newDurationYearMonth(boolean, int, int) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration类型的 xdt:yearMonthDuration使用指定 year和 month中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 。
newDurationYearMonth(boolean, BigInteger, BigInteger) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration类型的 xdt:yearMonthDuration使用指定 year和 month中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 。
newDurationYearMonth(long) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration类型的 xdt:yearMonthDuration使用指定毫秒中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 。
newDurationYearMonth(String) - Method in class javax.xml.datatype. DatatypeFactory
创建 Duration型 xdt:yearMonthDuration通过分析其 String表示 ，“PnYnM” XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 。
newEncoder() - Method in class java.nio.charset. Charset
为此字符集构造一个新的编码器。
newEndElementTree(Name) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 EndElement对象，以表示HTML元素的结尾。
newEntityTree(Name) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 EntityTree对象，以表示HTML实体。
newErroneousTree(String, Diagnostic<JavaFileObject>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ErroneousTree对象，以表示一些不可 ErroneousTree输入。
newExceptionTree(ReferenceTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ExceptionTree对象，以表示一个 @exception标签。
newFactory() - Static method in class javax.sql.rowset. RowSetProvider
创建一个新的 RowSetFactory实例。
newFactory() - Static method in class javax.xml.stream. XMLEventFactory
创建一个新的工厂实例。
newFactory() - Static method in class javax.xml.stream. XMLInputFactory
已过时。
newFactory() - Static method in class javax.xml.stream. XMLOutputFactory
创建一个新的工厂实例。
newFactory(String) - Method in class javax.xml.validation. SchemaFactoryLoader
为指定的模式语言创建一个新的SchemaFactory对象。
newFactory(String, ClassLoader) - Static method in class javax.sql.rowset. RowSetProvider
从指定的工厂类名称创建一个新的实例 RowSetFactory 。
newFactory(String, ClassLoader) - Static method in class javax.xml.stream. XMLEventFactory
创建一个新的工厂实例。
newFactory(String, ClassLoader) - Static method in class javax.xml.stream. XMLInputFactory
创建一个新的工厂实例。
newFactory(String, ClassLoader) - Static method in class javax.xml.stream. XMLOutputFactory
创建一个新的工厂实例。
newFileChannel(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Method in class java.nio.file.spi. FileSystemProvider
打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。
newFileSystem(URI, Map<String, ?>) - Static method in class java.nio.file. FileSystems
构造一个由URI标识的新文件系统
newFileSystem(URI, Map<String, ?>) - Method in class java.nio.file.spi. FileSystemProvider
构造一个由URI标识的新的 FileSystem对象。
newFileSystem(URI, Map<String, ?>, ClassLoader) - Static method in class java.nio.file. FileSystems
构造一个由URI标识的新文件系统
newFileSystem(Path, ClassLoader) - Static method in class java.nio.file. FileSystems
构造新的 FileSystem以访问文件的内容作为文件系统。
newFileSystem(Path, Map<String, ?>) - Method in class java.nio.file.spi. FileSystemProvider
构造新的 FileSystem以访问文件的内容作为文件系统。
newFixedThreadPool(int) - Static method in class java.util.concurrent. Executors
创建一个线程池，该线程池重用固定数量的从共享无界队列中运行的线程。
newFixedThreadPool(int, ThreadFactory) - Static method in class java.util.concurrent. Executors
创建一个线程池，重用固定数量的线程，从共享无界队列中运行，使用提供的ThreadFactory在需要时创建新线程。
NewFolderAction() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.NewFolderAction
构造一个 NewFolderAction 。
newFolderIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
新文件夹图标
newHiddenTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 HiddenTree对象，以表示一个 {@hidden }标签。
newHttpClient() - Static method in class jdk.incubator.http. HttpClient
返回具有默认设置的新HttpClient。
newIdentifierTree(Name) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 IdentifierTree对象，以表示一个标识符，如 @param标签。
newIncompleteFuture() - Method in class java.util.concurrent. CompletableFuture
返回由CompletionStage方法返回的类型的新的不完整的CompletableFuture。
newIndexTree(DocTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 IndexTree对象，以表示一个 {@index }标签。
newInheritDocTree() - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 InheritDocTree对象，以表示一个 {@inheritDoc}标签。
newInputStream(AsynchronousByteChannel) - Static method in class java.nio.channels. Channels
构造从给定通道读取字节的流。
newInputStream(ReadableByteChannel) - Static method in class java.nio.channels. Channels
构造从给定通道读取字节的流。
newInputStream(Path, OpenOption...) - Static method in class java.nio.file. Files
打开一个文件，返回输入流以从文件中读取。
newInputStream(Path, OpenOption...) - Method in class java.nio.file.spi. FileSystemProvider
打开一个文件，返回输入流以从文件中读取。
newInstance() - Method in class java.lang. Class
已过时。
此方法传播由nullary构造函数抛出的任何异常，包括已检查的异常。 使用此方法有效地绕过编译器异常检查，否则将由编译器执行。 Constructor.newInstance方法通过在（检查） InvocationTargetException中包含构造函数抛出的任何异常来避免此问题。

电话

   clazz.newInstance()
可以替换
   clazz.getDeclaredConstructor().newInstance()
后一个调用序列被推断为能够抛出额外的异常类型InvocationTargetException和NoSuchMethodException 。 这两个异常类型都是ReflectiveOperationException的子类。
newInstance() - Static method in class javax.xml.datatype. DatatypeFactory
获取一个新的实例 DatatypeFactory 。
newInstance() - Static method in class javax.xml.parsers. DocumentBuilderFactory
获取一个新的实例 DocumentBuilderFactory 。
newInstance() - Static method in class javax.xml.parsers. SAXParserFactory
获得一个 SAXParserFactory的新实例。
newInstance() - Static method in class javax.xml.soap. MessageFactory
创建一个新的 MessageFactory对象，该对象是默认实现（SOAP 1.1）的一个实例。
newInstance() - Static method in class javax.xml.soap. SOAPConnectionFactory
创建默认的 SOAPConnectionFactory对象的实例。
newInstance() - Static method in class javax.xml.soap. SOAPElementFactory
已过时。
创建一个新的实例 SOAPElementFactory 。
newInstance() - Static method in class javax.xml.soap. SOAPFactory
创建一个新的 SOAPFactory对象，该对象是默认实现（SOAP 1.1）的一个实例。
newInstance() - Method in interface javax.xml.stream.util. XMLEventAllocator
此方法创建XMLEventAllocator的实例。
newInstance() - Static method in class javax.xml.stream. XMLEventFactory
以与 XMLEventFactory.newFactory()方法完全相同的方式创建工厂的新实例。
newInstance() - Static method in class javax.xml.stream. XMLInputFactory
以与 XMLInputFactory.newFactory()方法完全相同的方式创建工厂的新实例。
newInstance() - Static method in class javax.xml.stream. XMLOutputFactory
以与 XMLOutputFactory.newFactory()方法完全相同的方式创建工厂的新实例。
newInstance() - Static method in class javax.xml.transform. TransformerFactory
获得一个新的实例 TransformerFactory 。
newInstance() - Static method in class javax.xml.xpath. XPathFactory
使用默认对象模型， XPathFactory.DEFAULT_OBJECT_MODEL_URI ，W3C DOM获取新的 XPathFactory实例。
newInstance() - Static method in class org.w3c.dom.bootstrap. DOMImplementationRegistry
获取一个新的实例 DOMImplementationRegistry 。
newInstance(int) - Method in interface com.sun.jdi. ArrayType
在目标VM中创建此数组类的新实例。
newInstance(ThreadReference, Method, List<? extends Value>, int) - Method in interface com.sun.jdi. ClassType
使用目标VM中的给定构造函数方法构造此类型的新实例。
newInstance(File, KeyStore.ProtectionParameter) - Static method in class java.security. KeyStore.Builder
返回一个新的Builder对象。
newInstance(Class<?>...) - Static method in class javax.xml.bind. JAXBContext
创建一个新的 JAXBContext类的实例。
newInstance(Class<?>[], Map<String, ?>) - Static method in class javax.xml.bind. JAXBContext
创建一个新的 JAXBContext类的实例。
newInstance(Class<?>, int) - Static method in class java.lang.reflect. Array
创建具有指定组件类型和长度的新数组。
newInstance(Class<?>, int...) - Static method in class java.lang.reflect. Array
创建具有指定组件类型和尺寸的新数组。
newInstance(Object) - Method in class java.security. Provider.Service
返回此服务描述的实现的新实例。
newInstance(Object...) - Method in class java.lang.reflect. Constructor
使用此 Constructor对象表示的构造函数，使用指定的初始化参数来创建和初始化构造函数的声明类的新实例。
newInstance(String) - Static method in class javax.xml.bind. JAXBContext
创建一个新的 JAXBContext类的实例。
newInstance(String) - Static method in class javax.xml.soap. MessageFactory
创建一个新的 MessageFactory对象，该对象是指定实现的实例。
newInstance(String) - Static method in class javax.xml.soap. SOAPFactory
创建一个新的 SOAPFactory对象，该对象是指定实现的实例，此方法使用SAAJMetaFactory来定位实现类并创建SOAPFactory实例。
newInstance(String) - Static method in class javax.xml.validation. SchemaFactory
查找支持指定模式语言并返回它的 SchemaFactory的实现。
newInstance(String) - Static method in class javax.xml.xpath. XPathFactory
使用指定的对象模型获取新的 XPathFactory实例。
newInstance(String, ClassLoader) - Static method in class javax.xml.bind. JAXBContext
创建一个新的 JAXBContext类的实例。
newInstance(String, ClassLoader) - Static method in class javax.xml.datatype. DatatypeFactory
从类名获取一个新的实例 DatatypeFactory 。
newInstance(String, ClassLoader) - Static method in class javax.xml.parsers. DocumentBuilderFactory
从类名获取一个新的 DocumentBuilderFactory实例。
newInstance(String, ClassLoader) - Static method in class javax.xml.parsers. SAXParserFactory
从类名获取一个新的实例 SAXParserFactory 。
newInstance(String, ClassLoader) - Static method in class javax.xml.stream. XMLEventFactory
已过时。
该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替代XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
newInstance(String, ClassLoader) - Static method in class javax.xml.stream. XMLInputFactory
已过时。
该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替代XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
newInstance(String, ClassLoader) - Static method in class javax.xml.stream. XMLOutputFactory
已过时。
此方法已被弃用，因为它返回一个XMLInputFactory的实例，该实例是错误的类。 改用新方法XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) 。
newInstance(String, ClassLoader) - Static method in class javax.xml.transform. TransformerFactory
从工厂类名称获取一个新的 TransformerFactory实例。
newInstance(String, ClassLoader, Map<String, ?>) - Static method in class javax.xml.bind. JAXBContext
创建一个新的 JAXBContext类的实例。
newInstance(String, String, ClassLoader) - Static method in class javax.xml.validation. SchemaFactory
从类名获取一个新的 SchemaFactory实例。
newInstance(String, String, ClassLoader) - Static method in class javax.xml.xpath. XPathFactory
从工厂类名称获取一个新的实例 XPathFactory 。
newInstance(String, Provider, File, KeyStore.ProtectionParameter) - Static method in class java.security. KeyStore.Builder
返回一个新的Builder对象。
newInstance(String, Provider, KeyStore.ProtectionParameter) - Static method in class java.security. KeyStore.Builder
返回一个新的Builder对象。
newInstance(URL[]) - Static method in class java.net. URLClassLoader
为指定的URL和默认父类加载器创建URLClassLoader的新实例。
newInstance(URL[], ClassLoader) - Static method in class java.net. URLClassLoader
为指定的URL和父类加载器创建URLClassLoader的新实例。
newInstance(ActivationID, ActivationDesc) - Method in class java.rmi.activation. ActivationGroup_Stub
存根方法 ActivationGroup.newInstance 。
newInstance(ActivationID, ActivationDesc) - Method in interface java.rmi.activation. ActivationInstantiator
激活者调用实例化器的 newInstance方法，以便在该组中重新创建具有激活标识符 id和描述符 desc 。
newInstance(KeyStore, KeyStore.ProtectionParameter) - Static method in class java.security. KeyStore.Builder
返回封装给定KeyStore的新Builder。
newInstance(Control[]) - Method in class javax.naming.ldap. InitialLdapContext
newInstance(Control[]) - Method in interface javax.naming.ldap. LdapContext
创建使用请求控件初始化的此上下文的新实例。
newJMXConnector(JMXServiceURL, Map<String, ?>) - Static method in class javax.management.remote. JMXConnectorFactory
在给定的地址创建连接器服务器的连接器客户端。
newJMXConnector(JMXServiceURL, Map<String, ?>) - Method in interface javax.management.remote. JMXConnectorProvider
创建一个新的连接器客户端，可以在给定的地址连接到连接器服务器。
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - Static method in class javax.management.remote. JMXConnectorServerFactory
在给定的地址创建一个连接器服务器。
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - Method in interface javax.management.remote. JMXConnectorServerProvider
在给定的地址创建一个新的连接器服务器。
newKeyInfo(List<? extends XMLStructure>) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
创建一个 KeyInfo其中包含指定的关键信息类型列表。
newKeyInfo(List<? extends XMLStructure>, String) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
创建一个 KeyInfo其中包含指定的关键信息类型和可选标识列表。
newKeyName(String) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从指定的名称创建一个 KeyName 。
newKeySet() - Static method in class java.util.concurrent. ConcurrentHashMap
创建一个新的Set支持的ConcurrentHashMap从给定的类型到Boolean.TRUE 。
newKeySet(int) - Static method in class java.util.concurrent. ConcurrentHashMap
创建一个新的Set支持的ConcurrentHashMap从给定的类型到Boolean.TRUE 。
newKeyValue(PublicKey) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从指定的公钥中创建一个 KeyValue 。
newLeadSelectionPath - Variable in class javax.swing.event. TreeSelectionEvent
leadSelectionPath在路径更改后可能为null。
newLine() - Method in class java.io. BufferedWriter
写一行行分隔符。
NEWLINE - Static variable in class javax.swing.text. AbstractWriter
文本包如何模型换行。
newLinkPlainTree(ReferenceTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 LinkPlainTree对象，以表示一个 {@linkplain }标签。
newLinkTree(ReferenceTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 LinkTree对象，以表示一个 {@link }标签。
newLiteralTree(TextTree) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 LiteralTree对象，以表示一个 {@literal }标签。
newManifest(List<? extends Reference>) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建Manifest包含指定的列表Reference秒。
newManifest(List<? extends Reference>, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建一个Manifest其中包含Reference s和可选id的指定列表。
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - Static method in class javax.management. JMX
在本地或远程MBean服务器中为标准MBean创建代理。
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - Static method in class javax.management. JMX
为本地或远程MBean服务器中的标准MBean进行代理，该服务器也可以支持NotificationEmitter的方法。
newMBeanServer() - Static method in class javax.management. MBeanServerFactory
使用标准默认域名返回实现MBeanServer接口的新对象，而不保留对此新对象的内部引用。
newMBeanServer(String) - Static method in class javax.management. MBeanServerFactory
使用指定的默认域名返回实现MBeanServer接口的新对象，而不保留对此新对象的内部引用。
newMBeanServer(String, MBeanServer, MBeanServerDelegate) - Method in class javax.management. MBeanServerBuilder
此方法创建一个新的MBeanServer实现对象。
newMBeanServerDelegate() - Method in class javax.management. MBeanServerBuilder
此方法为新的MBeanServer创建一个新的MBeanServerDelegate。
newMessageFactory(String) - Method in class javax.xml.soap. SAAJMetaFactory
为给定的 String协议创建一个 MessageFactory对象。
newmodel - Variable in class java.awt.image. RGBImageFilter
ColorModel用来替代 origmodel当用户拨打 substituteColorModel 。
newModule(String) - Static method in class java.lang.module. ModuleDescriptor
实例化构建器以构建 正常模块的模块描述符。
newModule(String, Set<ModuleDescriptor.Modifier>) - Static method in class java.lang.module. ModuleDescriptor
实例化构建器以构建模块描述符。
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - Static method in class javax.management. JMX
在本地或远程MBean服务器中为MXBean创建代理。
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - Static method in class javax.management. JMX
在本地或远程MBean服务器中为MXBean创建代理，该服务器也可能支持NotificationEmitter的方法。
newNode - Variable in class java.util.prefs. AbstractPreferences
如果此节点在创建此对象之前在后台存储中不存在，则该字段应为 true 。
newObject(Object...) - Method in class jdk.nashorn.api.scripting. AbstractJSObject
newObject(Object...) - Method in interface jdk.nashorn.api.scripting. JSObject
调用这个“构造函数”JavaScript函数来创建一个新对象。
newObject(Object...) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
newOpenModule(String) - Static method in class java.lang.module. ModuleDescriptor
实例化构建器为开放模块构建模块描述符。
newOutputStream(AsynchronousByteChannel) - Static method in class java.nio.channels. Channels
构造将字节写入给定通道的流。
newOutputStream(WritableByteChannel) - Static method in class java.nio.channels. Channels
构造将字节写入给定通道的流。
newOutputStream(Path, OpenOption...) - Static method in class java.nio.file. Files
打开或创建文件，返回可用于向文件写入字节的输出流。
newOutputStream(Path, OpenOption...) - Method in class java.nio.file.spi. FileSystemProvider
打开或创建文件，返回可用于向文件写入字节的输出流。
newPacker() - Static method in class java.util.jar. Pack200
获取实现Packer的类的新实例。
newParamTree(boolean, IdentifierTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ParamTree对象，以表示一个 @param标签。
newPermissionCollection() - Method in class java.io. FilePermission
返回一个新的PermissionCollection对象，用于存储FilePermission对象。
newPermissionCollection() - Method in class java.net. SocketPermission
返回一个新的PermissionCollection对象，用于存储SocketPermission对象。
newPermissionCollection() - Method in class java.security. AllPermission
返回一个新的PermissionCollection对象，用于存储AllPermission对象。
newPermissionCollection() - Method in class java.security. BasicPermission
返回一个新的PermissionCollection对象，用于存储BasicPermission对象。
newPermissionCollection() - Method in class java.security. Permission
为给定的Permission对象返回一个空的PermissionCollection，如果未定义，则返回null。
newPermissionCollection() - Method in class java.security. UnresolvedPermission
返回一个新的PermissionCollection对象，用于存储UnresolvedPermission对象。
newPermissionCollection() - Method in class java.util. PropertyPermission
返回一个用于存储PropertyPermission对象的新的PermissionCollection对象。
newPermissionCollection() - Method in class javax.management. MBeanServerPermission
newPermissionCollection() - Method in class javax.security.auth.kerberos. DelegationPermission
返回一个PermissionCollection对象，用于存储DelegationPermission对象。
newPermissionCollection() - Method in class javax.security.auth.kerberos. ServicePermission
返回一个用于存储ServicePermission对象的PermissionCollection对象。
newPermissionCollection() - Method in class javax.security.auth. PrivateCredentialPermission
返回PrivateCredentialPermissions的同类集合在 PermissionCollection 。
newPGPData(byte[]) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
根据指定的PGP公钥标识符创建 PGPData 。
newPGPData(byte[], byte[], List<? extends XMLStructure>) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从指定的PGP公共密钥标识符和可选的密钥材料数据包和外部元素列表创建一个 PGPData 。
newPGPData(byte[], List<? extends XMLStructure>) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从指定的PGP密钥材料数据包和外部元素的可选列表中创建一个 PGPData 。
newPixels() - Method in class java.awt.image. MemoryImageSource
向目前对此图像的数据感兴趣的任何ImageConsumers发送一个全新的像素缓冲区，并通知他们动画帧完成。
newPixels(byte[], ColorModel, int, int) - Method in class java.awt.image. MemoryImageSource
更改新的字节数组来保存此图像的像素。
newPixels(int[], ColorModel, int, int) - Method in class java.awt.image. MemoryImageSource
更改一个新的int数组来保存此图像的像素。
newPixels(int, int, int, int) - Method in class java.awt.image. MemoryImageSource
将像素缓冲区的矩形区域发送到当前对该图像的数据感兴趣的任何ImageConsumers，并通知它们动画帧完成。
newPixels(int, int, int, int, boolean) - Method in class java.awt.image. MemoryImageSource
将像素缓冲区的矩形区域发送到当前对该图像的数据感兴趣的任何ImageConsumers。
newPlatformMXBeanProxy(MBeanServerConnection, String, Class<T>) - Static method in class java.lang.management. ManagementFactory
返回给定的平台MXBean接口的代理 MXBean name转发其方法调用通过给定 MBeanServerConnection 。
newProvidesTree(ReferenceTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ProvidesTree对象，以表示一个 @provides标签。
newProxyInstance(ClassLoader, Class<?>[], InvocationHandler) - Static method in class java.lang.reflect. Proxy
返回指定接口的代理实例，该代理实例将方法调用分派给指定的调用处理程序。
newProxyInstance(MBeanServerConnection, ObjectName, Class<T>, boolean) - Static method in class javax.management. MBeanServerInvocationHandler
通过将其方法通过给定的MBean服务器转发到指定的MBean来返回实现给定接口的代理。
newReader(ReadableByteChannel, String) - Static method in class java.nio.channels. Channels
构造一个读取器，根据命名的字符集解码来自给定通道的字节。
newReader(ReadableByteChannel, CharsetDecoder, int) - Static method in class java.nio.channels. Channels
构造一个读取器，使用给定的解码器解码来自给定通道的字节。
newReference(String, DigestMethod) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
使用指定的URI和摘要方法创建一个 Reference 。
newReference(String, DigestMethod, List<? extends Transform>, String, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建一个具有指定参数的 Reference 。
newReference(String, DigestMethod, List<? extends Transform>, String, String, byte[]) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建具有指定参数的 Reference和预先计算的摘要值。
newReference(String, DigestMethod, List<? extends Transform>, Data, List<? extends Transform>, String, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建具有指定参数的 Reference 。
newReferenceTree(String) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ReferenceTree对象，以表示对API元素的引用。
newRetrievalMethod(String) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从指定的URI创建一个 RetrievalMethod 。
newRetrievalMethod(String, String, List<? extends Transform>) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从指定的参数创建一个 RetrievalMethod 。
newReturnTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ReturnTree对象，以表示一个 @return标签。
newRowsAdded(TableModelEvent) - Method in class javax.swing.table. DefaultTableModel
确保新行的列数正确。
NEWS - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported
USENET新闻
newSAXParser() - Method in class javax.xml.parsers. SAXParserFactory
使用当前配置的工厂参数创建SAXParser的新实例。
newScheduledThreadPool(int) - Static method in class java.util.concurrent. Executors
创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
newScheduledThreadPool(int, ThreadFactory) - Static method in class java.util.concurrent. Executors
创建一个线程池，可以调度命令在给定的延迟之后运行，或定期执行。
newSchema() - Method in class javax.xml.validation. SchemaFactory
创建一个特殊的Schema对象。
newSchema(File) - Method in class javax.xml.validation. SchemaFactory
将指定的 File作为模式解析，并将其作为 Schema返回。
newSchema(URL) - Method in class javax.xml.validation. SchemaFactory
将指定的 URL解析为模式，并将其作为 Schema返回。
newSchema(Source) - Method in class javax.xml.validation. SchemaFactory
将指定的源解析为模式，并将其作为模式返回。
newSchema(Source[]) - Method in class javax.xml.validation. SchemaFactory
将指定的源解析为模式并将其作为模式返回。
newSeeTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 SeeTree对象，以表示一个 @see标签。
newSerialDataTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 SerialDataTree对象，以表示一个 @serialData标签。
newSerialFieldTree(IdentifierTree, ReferenceTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 SerialFieldTree对象，以表示一个 @serialField标签。
newSerialTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 SerialTree对象，以表示一个 @serial标签。
newSetFromMap(Map<E, Boolean>) - Static method in class java.util. Collections
返回由指定地图支持的集合。
newSignatureMethod(String, SignatureMethodParameterSpec) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
为指定的算法URI和参数创建一个 SignatureMethod 。
newSignatureProperties(List<? extends SignatureProperty>, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建SignatureProperties包含指定的列表SignatureProperty个 S和可选id。
newSignatureProperty(List<? extends XMLStructure>, String, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建一个SignatureProperty其中包含XMLStructure的目标URI和可选的id的指定列表。
newSignedInfo(CanonicalizationMethod, SignatureMethod, List<? extends Reference>) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建具有指定的规范化和签名方法的 SignedInfo以及一个或多个引用的列表。
newSignedInfo(CanonicalizationMethod, SignatureMethod, List<? extends Reference>, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建具有指定参数的 SignedInfo 。
newSinceTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 SinceTree对象，以表示一个 @since标签。
newSingleThreadExecutor() - Static method in class java.util.concurrent. Executors
创建一个使用从无界队列运行的单个工作线程的执行程序。
newSingleThreadExecutor(ThreadFactory) - Static method in class java.util.concurrent. Executors
创建一个使用单个工作线程运行无界队列的执行程序，并在需要时使用提供的ThreadFactory创建一个新线程。
newSingleThreadScheduledExecutor() - Static method in class java.util.concurrent. Executors
创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。
newSingleThreadScheduledExecutor(ThreadFactory) - Static method in class java.util.concurrent. Executors
创建一个单线程执行器，可以调度命令在给定的延迟之后运行，或定期执行。
newSOAPFactory(String) - Method in class javax.xml.soap. SAAJMetaFactory
为给定的 String协议创建一个 SOAPFactory对象。
newStartElementTree(Name, List<? extends DocTree>, boolean) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 StartElementTree对象，以表示HTML元素的开始。
newSwingWorker() - Method in class com.sun.tools.jconsole. JConsolePlugin
返回一个SwingWorker以与JConsole更新GUI相同的间隔执行此插件的GUI更新。
newTaskFor(Runnable, T) - Method in class java.util.concurrent. AbstractExecutorService
对于给定的可运行和默认值，返回一个 RunnableFuture 。
newTaskFor(Runnable, T) - Method in class java.util.concurrent. ForkJoinPool
newTaskFor(Callable<T>) - Method in class java.util.concurrent. AbstractExecutorService
为给定的可调用任务返回一个 RunnableFuture 。
newTaskFor(Callable<T>) - Method in class java.util.concurrent. ForkJoinPool
newTemplates(Source) - Method in class javax.xml.transform. TransformerFactory
将源处理为一个Templates对象，它是源的编译表示。
newTemplatesHandler() - Method in class javax.xml.transform.sax. SAXTransformerFactory
获取一个可以将SAX ContentHandler事件处理到Templates对象的TemplatesHandler对象。
newTextTree(String) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 TextTree对象，以表示一些纯文本。
newThread(Runnable) - Method in interface java.util.concurrent. ThreadFactory
构造新的 Thread 。
newThread(ForkJoinPool) - Method in interface java.util.concurrent. ForkJoinPool.ForkJoinWorkerThreadFactory
返回在给定池中运行的新工作线程。
newThrowsTree(ReferenceTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ThrowsTree对象，以表示一个 @throws标签。
newTransform(String, TransformParameterSpec) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
为指定的算法URI和参数创建一个 Transform 。
newTransform(String, XMLStructure) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
为指定的算法URI和参数创建一个 Transform 。
newTransformer() - Method in interface javax.xml.transform. Templates
为此Templates对象创建一个新的转换上下文。
newTransformer() - Method in class javax.xml.transform. TransformerFactory
创建一个新的 Transformer ，执行 Source到 Result 。
newTransformer(Source) - Method in class javax.xml.transform. TransformerFactory
处理 Source成 Transformer Object 。
newTransformerHandler() - Method in class javax.xml.transform.sax. SAXTransformerFactory
获取可以将SAX ContentHandler事件处理为Result的TransformerHandler对象。
newTransformerHandler(Source) - Method in class javax.xml.transform.sax. SAXTransformerFactory
获取一个TransformerHandler对象，可以根据参数指定的转换指令，将SAX ContentHandler事件处理成Result。
newTransformerHandler(Templates) - Method in class javax.xml.transform.sax. SAXTransformerFactory
获取一个TransformerHandler对象，该对象可以根据Templates参数将SAX ContentHandler事件处理为Result。
NewTree - Interface in jdk.nashorn.api.tree
一个树节点来声明一个类的新实例。
newUnknownBlockTagTree(Name, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 UnknownBlockTagTree对象，以表示一个无法识别的块标签。
newUnknownInlineTagTree(Name, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 UnknownInlineTagTree对象，以表示无法识别的内联标签。
newUnpacker() - Static method in class java.util.jar. Pack200
获取实现Unpacker的类的新实例。
newUpdater(Class<U>, Class<W>, String) - Static method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater
创建并返回具有给定字段的对象的更新程序。
newUpdater(Class<U>, String) - Static method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
创建并返回具有给定字段的对象的更新程序。
newUpdater(Class<U>, String) - Static method in class java.util.concurrent.atomic. AtomicLongFieldUpdater
创建并返回具有给定字段的对象的更新程序。
newUsesTree(ReferenceTree, List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 UsesTree对象，以表示一个 @uses标签。
newValidator() - Method in class javax.xml.validation. Schema
创建一个新Validator这个Schema 。
newValidatorHandler() - Method in class javax.xml.validation. Schema
创建一个新ValidatorHandler这个Schema 。
newValueTree(ReferenceTree) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 ValueTree对象，以表示一个 {@value }标签。
newVersionTree(List<? extends DocTree>) - Method in interface com.sun.source.util. DocTreeFactory
创建一个新的 VersionTree对象，以表示一个 {@version }标签。
newWatchService() - Method in class java.nio.file. FileSystem
构造新的WatchService （可选操作） 。
newWebSocketBuilder(URI, WebSocket.Listener) - Method in class jdk.incubator.http. HttpClient
创建连接到给定URI的WebSocket实例的构建器，并接收给定的Listener事件和消息。
newWorkStealingPool() - Static method in class java.util.concurrent. Executors
创建一个工作窃取线程池，使用号码为 available processors作为其目标并行级别。
newWorkStealingPool(int) - Static method in class java.util.concurrent. Executors
创建一个维护足够的线程以支持给定的并行级别的线程池，并且可以使用多个队列来减少争用。
newWriter(WritableByteChannel, String) - Static method in class java.nio.channels. Channels
构造一个根据命名的字符集对字符进行编码的写入程序，并将生成的字节写入给定的通道。
newWriter(WritableByteChannel, CharsetEncoder, int) - Static method in class java.nio.channels. Channels
构造一个使用给定编码器编码字符的写入器，并将生成的字节写入给定的通道。
newX509Data(List<?>) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
创建一个包含指定的X.509内容列表的 X509Data 。
newX509IssuerSerial(String, BigInteger) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从指定的X.500发行人可分辨名称和序列号创建 X509IssuerSerial 。
newXMLFilter(Source) - Method in class javax.xml.transform.sax. SAXTransformerFactory
创建一个使用给定的源作为转换指令的XMLFilter。
newXMLFilter(Templates) - Method in class javax.xml.transform.sax. SAXTransformerFactory
根据Templates参数创建一个XMLFilter。
newXMLGregorianCalendar() - Method in class javax.xml.datatype. DatatypeFactory
创建一个新的实例 XMLGregorianCalendar 。
newXMLGregorianCalendar(int, int, int, int, int, int, int, int) - Method in class javax.xml.datatype. DatatypeFactory
java.util.GregorianCalendar实例需要转换为 XMLGregorianCalendar实例的值空间构造方法。
newXMLGregorianCalendar(String) - Method in class javax.xml.datatype. DatatypeFactory
通过解析String作为词法表示来创建一个新的XMLGregorianCalendar。
newXMLGregorianCalendar(BigInteger, int, int, int, int, int, BigDecimal, int) - Method in class javax.xml.datatype. DatatypeFactory
允许W3C XML Schema 1.0允许的完整值空间的构造方法，用于xsd：dateTime和相关的内置数据类型。
newXMLGregorianCalendar(GregorianCalendar) - Method in class javax.xml.datatype. DatatypeFactory
创建XMLGregorianCalendar从GregorianCalendar 。
newXMLGregorianCalendarDate(int, int, int, int) - Method in class javax.xml.datatype. DatatypeFactory
创建XML Schema内置数据类型 date或 g*的Java表示 g* 。
newXMLGregorianCalendarTime(int, int, int, int) - Method in class javax.xml.datatype. DatatypeFactory
创建一个XML Schema内置数据类型 time的Java实例。
newXMLGregorianCalendarTime(int, int, int, int, int) - Method in class javax.xml.datatype. DatatypeFactory
创建XML Schema内置数据类型时间的Java实例。
newXMLGregorianCalendarTime(int, int, int, BigDecimal, int) - Method in class javax.xml.datatype. DatatypeFactory
创建XML Schema内置数据类型时间的Java实例。
newXMLObject(List<? extends XMLStructure>, String, String, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
从指定的参数创建一个 XMLObject 。
newXMLSignature(SignedInfo, KeyInfo) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建一个 XMLSignature并使用指定的 SignedInfo和 KeyInfo对象的内容进行初始化。
newXMLSignature(SignedInfo, KeyInfo, List<? extends XMLObject>, String, String) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
创建一个 XMLSignature并用指定的参数进行初始化。
newXPath() - Method in class javax.xml.xpath. XPathFactory
使用 XPathFactory实例化时确定的底层对象模型返回一个新的 XPath 。
next - Variable in class javax.swing.text.html.parser. AttributeList
列表中的下一个属性
next - Variable in class javax.swing.text.html.parser. ContentModel
下一个内容模型（在'，'，'|'或'＆'表达式中）。
next() - Method in class java.awt.geom. FlatteningPathIterator
只要在该方向上有更多的点，将迭代器沿着遍历的主要方向向前移动到路径的下一个段。
next() - Method in interface java.awt.geom. PathIterator
只要在该方向上有更多的点，将迭代器沿着遍历的主要方向向前移动到路径的下一个段。
next() - Method in class java.beans.beancontext. BeanContextSupport.BCSIterator
next() - Method in interface java.sql. ResultSet
将光标从当前位置向前移动一行。
next() - Method in class java.text. BreakIterator
返回当前边界之后的边界。
next() - Method in interface java.text. CharacterIterator
将迭代器的索引增加1，并返回新索引处的字符。
next() - Method in class java.text. CollationElementIterator
获取字符串中的下一个排序规则元素。
next() - Method in class java.text. StringCharacterIterator
为String执行CharacterIterator.next（）。
next() - Method in interface java.util. Iterator
返回迭代中的下一个元素。
next() - Method in interface java.util. ListIterator
返回列表中的下一个元素，并且前进光标位置。
next() - Method in interface java.util. PrimitiveIterator.OfDouble
返回迭代中的下一个元素。
next() - Method in interface java.util. PrimitiveIterator.OfInt
返回迭代中的下一个元素。
next() - Method in interface java.util. PrimitiveIterator.OfLong
返回迭代中的下一个元素。
next() - Method in class java.util. Scanner
查找并返回此扫描仪的下一个完整令牌。
next() - Method in class javafx.collections. ListChangeListener.Change
转到下一个变化。
next() - Method in interface javax.naming. NamingEnumeration
检索枚举中的下一个元素。
next() - Method in interface javax.print. MultiDoc
转到包含doc对象序列中的下一个doc对象的多对象对象。
next() - Method in class javax.swing.text. ElementIterator
获取下一个元素。
next() - Method in class javax.swing.text.html. HTMLDocument.Iterator
将迭代器向前移动到下一次出现的代码。
next() - Method in class javax.swing.text. Segment
将迭代器的索引增加1，并返回新索引处的字符。
next() - Method in class javax.xml.stream.util. EventReaderDelegate
next() - Method in class javax.xml.stream.util. StreamReaderDelegate
next() - Method in interface javax.xml.stream. XMLStreamReader
获取下一个解析事件 - 处理器可能会在单个块中返回所有连续的字符数据，也可能会将其拆分成多个块。
next() - Method in interface org.omg.CORBA. DynAny
已过时。
移动到此 DynAny对象的下一个组件。
next() - Method in class org.omg.DynamicAny. _DynAnyStub
将当前位置提前到下一个组件。
next() - Method in class org.omg.DynamicAny. _DynArrayStub
将当前位置提前到下一个组件。
next() - Method in class org.omg.DynamicAny. _DynEnumStub
将当前位置提前到下一个组件。
next() - Method in class org.omg.DynamicAny. _DynFixedStub
将当前位置提前到下一个组件。
next() - Method in class org.omg.DynamicAny. _DynSequenceStub
将当前位置提前到下一个组件。
next() - Method in class org.omg.DynamicAny. _DynStructStub
将当前位置提前到下一个组件。
next() - Method in class org.omg.DynamicAny. _DynUnionStub
将当前位置提前到下一个组件。
next() - Method in class org.omg.DynamicAny. _DynValueStub
将当前位置提前到下一个组件。
next() - Method in interface org.omg.DynamicAny. DynAnyOperations
将当前位置提前到下一个组件。
next(int) - Method in class java.security. SecureRandom
生成一个包含用户指定数量的伪随机位的整数（右对齐，带前导零）。
next(int) - Method in class java.text. BreakIterator
从当前边界返回第n个边界。
next(int) - Method in class java.util.concurrent. ThreadLocalRandom
生成带有指定数量的低位位的伪随机数。
next(int) - Method in class java.util. Random
生成下一个伪随机数。
next(int) - Method in class javax.print.attribute. SetOfIntegerSyntax
确定该set-of-integer属性中大于给定值的最小整数。
next(Container) - Method in class java.awt. CardLayout
翻转到指定容器的下一张卡片。
next(String) - Method in class java.util. Scanner
如果匹配从指定字符串构造的模式，则返回下一个令牌。
next(DayOfWeek) - Static method in class java.time.temporal. TemporalAdjusters
返回下一个星期的调整器，该调整器将日期调整为在调整日期之后的指定日期的第一次出现。
next(Pattern) - Method in class java.util. Scanner
如果匹配指定的模式，则返回下一个令牌。
NEXT - Static variable in class javafx.scene.control. ButtonType
预先定义的ButtonType显示“下一步”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.NEXT_FORWARD 。
NEXT - Static variable in interface javax.swing. SwingConstants
标识序列中的下一个方向。
NEXT_FORWARD - javafx.scene.control. ButtonBar.ButtonData
“下一个”或“前进”按钮的标签。
next_n(int, BindingListHolder) - Method in class org.omg.CosNaming. _BindingIteratorStub
此操作最多返回所请求的绑定数量。
next_n(int, BindingListHolder) - Method in interface org.omg.CosNaming. BindingIteratorOperations
此操作最多返回所请求的绑定数量。
next_one(BindingHolder) - Method in class org.omg.CosNaming. _BindingIteratorStub
此操作返回下一个绑定。
next_one(BindingHolder) - Method in interface org.omg.CosNaming. BindingIteratorOperations
此操作返回下一个绑定。
nextAdd(int, int) - Method in class javafx.collections. ObservableListBase
对更改添加新的添加操作。
nextAfter(double, double) - Static method in class java.lang. Math
返回与第二个参数方向相邻的第一个参数的浮点数。
nextAfter(double, double) - Static method in class java.lang. StrictMath
返回与第二个参数方向相邻的第一个参数的浮点数。
nextAfter(float, double) - Static method in class java.lang. Math
返回与第二个参数方向相邻的第一个参数的浮点数。
nextAfter(float, double) - Static method in class java.lang. StrictMath
返回与第二个参数方向相邻的第一个参数的浮点数。
nextBigDecimal() - Method in class java.util. Scanner
将输入的下一个标记扫描为BigDecimal 。
nextBigInteger() - Method in class java.util. Scanner
将输入的下一个标记扫描为BigInteger 。
nextBigInteger(int) - Method in class java.util. Scanner
将输入的下一个标记扫描为BigInteger 。
nextBoolean() - Method in class java.util.concurrent. ThreadLocalRandom
返回一个伪随机数 boolean值。
nextBoolean() - Method in class java.util. Random
从该随机数生成器的序列返回下一个伪随机数，均匀分布的值为 boolean 。
nextBoolean() - Method in class java.util. Scanner
将输入的下一个标记扫描为布尔值，并返回该值。
nextBoolean() - Method in class java.util. SplittableRandom
返回一个伪随机数 boolean值。
nextByte() - Method in class java.util. Scanner
将输入的下一个标记扫描为 byte 。
nextByte(int) - Method in class java.util. Scanner
将输入的下一个标记扫描为 byte 。
nextBytes(byte[]) - Method in class java.security. SecureRandom
生成用户指定的随机字节数。
nextBytes(byte[]) - Method in class java.util. Random
生成随机字节并将它们放入用户提供的字节数组中。
nextBytes(byte[], SecureRandomParameters) - Method in class java.security. SecureRandom
使用附加参数生成用户指定的随机字节数。
nextBytes(int, boolean, byte[]) - Static method in class java.security. DrbgParameters
生成一个DrbgParameters.NextBytes对象。
nextClearBit(int) - Method in class java.util. BitSet
返回在指定的起始索引上或之后发生的第一个位的索引，设置为 false 。
nextComplete() - Method in class java.util.concurrent. CountedCompleter
如果此任务没有完成，请调用 ForkJoinTask.quietlyComplete()并返回 null 。
nextConflict() - Method in interface javax.sql.rowset.spi. SyncResolver
将光标从当前位置向下移动到包含冲突值的下一行。
nextDouble() - Method in class java.util.concurrent. ThreadLocalRandom
返回0（包括）和1（排除）之间的伪随机数 double 。
nextDouble() - Method in interface java.util. PrimitiveIterator.OfDouble
返回下一个 double元素的迭代。
nextDouble() - Method in class java.util. Random
返回下一个伪，均匀分布 double之间价值 0.0和 1.0从这个随机数生成器的序列。
nextDouble() - Method in class java.util. Scanner
将输入的下一个标记扫描为 double 。
nextDouble() - Method in class java.util. SplittableRandom
返回0（包括）和1（排除）之间的伪随机数 double值。
nextDouble(double) - Static method in class java.text. ChoiceFormat
找到的最小双倍大于 d 。
nextDouble(double) - Method in class java.util.concurrent. ThreadLocalRandom
返回在0.0（含）和指定的边界（排除）之间的伪随机数 double值。
nextDouble(double) - Method in class java.util. SplittableRandom
返回在0.0（含）和指定的边界（排除）之间的伪随机数 double值。
nextDouble(double, boolean) - Static method in class java.text. ChoiceFormat
寻找到 d （如果 positive是 true ）的最小双倍，或最大的双倍小于 d （如果 positive是 false ）。
nextDouble(double, double) - Method in class java.util.concurrent. ThreadLocalRandom
返回指定原点（含）和绑定（排除）之间的伪随机数 double值。
nextDouble(double, double) - Method in class java.util. SplittableRandom
返回指定原点（包括）和绑定（排除）之间的伪随机数 double值。
nextDown(double) - Static method in class java.lang. Math
返回与负无穷大方向相邻的 d的浮点值。
nextDown(double) - Static method in class java.lang. StrictMath
返回与负无穷大方向相邻的 d的浮点值。
nextDown(float) - Static method in class java.lang. Math
以负无穷大的方向返回与 f相邻的浮点值。
nextDown(float) - Static method in class java.lang. StrictMath
返回与负无穷大方向相邻的 f的浮点值。
nextElement() - Method in interface java.util. Enumeration
如果此枚举对象至少有一个要提供的元素，则返回此枚举的下一个元素。
nextElement() - Method in class java.util. StringTokenizer
返回与 nextToken方法相同的值，但其声明的返回值为 Object而不是 String 。
nextEvent() - Method in interface com.sun.jdi.event. EventIterator
nextEvent() - Method in class javax.xml.stream.util. EventReaderDelegate
nextEvent() - Method in interface javax.xml.stream. XMLEventReader
获取下一个XMLEvent。
nextFloat() - Method in class java.util.concurrent. ThreadLocalRandom
返回一个零值（包括）和一（独占）之间的伪随机数 float 。
nextFloat() - Method in class java.util. Random
返回下一个伪，均匀分布 float之间价值 0.0和 1.0从这个随机数生成器的序列。
nextFloat() - Method in class java.util. Scanner
将输入的下一个标记扫描为 float 。
nextFocus() - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由transferFocus（）替换。
nextGaussian() - Method in class java.util.concurrent. ThreadLocalRandom
nextGaussian() - Method in class java.util. Random
返回下一个伪随机数，高斯（“正常”）分布的 double值，平均值为 0.0 ，标准偏差为 1.0 。
nextIndex() - Method in interface java.util. ListIterator
返回由后续调用 ListIterator.next()返回的元素的索引。
nextInt() - Method in class java.util.concurrent. ThreadLocalRandom
返回一个伪随机数 int值。
nextInt() - Method in interface java.util. PrimitiveIterator.OfInt
返回下一个 int元素的迭代。
nextInt() - Method in class java.util. Random
返回下一个伪随机数，从这个随机数发生器的序列中均匀分布 int值。
nextInt() - Method in class java.util. Scanner
将输入的下一个标记扫描为 int 。
nextInt() - Method in class java.util. SplittableRandom
返回一个伪随机数 int值。
nextInt(int) - Method in class java.util.concurrent. ThreadLocalRandom
返回0（包括）和指定的bound（exclusive）之间的伪随机数 int 。
nextInt(int) - Method in class java.util. Random
返回伪随机的，均匀分布 int值介于0（含）和指定值（不包括），从该随机数生成器的序列绘制。
nextInt(int) - Method in class java.util. Scanner
将输入的下一个标记扫描为 int 。
nextInt(int) - Method in class java.util. SplittableRandom
返回0（包括）和指定的bound（exclusive）之间的伪随机数 int 。
nextInt(int, int) - Method in class java.util.concurrent. ThreadLocalRandom
返回指定的起始点（含）和指定的绑定（排除）之间的伪随机数 int值。
nextInt(int, int) - Method in class java.util. SplittableRandom
返回指定的原点（含）和指定的界限（排除）之间的伪随机值 int 。
nextLayout(float) - Method in class java.awt.font. LineBreakMeasurer
返回下一个布局，并更新当前位置。
nextLayout(float, int, boolean) - Method in class java.awt.font. LineBreakMeasurer
返回下一个布局，并更新当前位置。
nextLine() - Method in class java.util. Scanner
将此扫描仪推进到当前行并返回跳过的输入。
nextLong() - Method in class java.util.concurrent. ThreadLocalRandom
返回伪随机数 long值。
nextLong() - Method in interface java.util. PrimitiveIterator.OfLong
返回下一个 long元素的迭代。
nextLong() - Method in class java.util. Random
返回下一个伪随机数，从这个随机数生成器的序列中均匀分布 long值。
nextLong() - Method in class java.util. Scanner
将输入的下一个标记扫描为 long 。
nextLong() - Method in class java.util. SplittableRandom
返回一个伪随机数 long值。
nextLong(int) - Method in class java.util. Scanner
将输入的下一个标记扫描为 long 。
nextLong(long) - Method in class java.util.concurrent. ThreadLocalRandom
返回0（包括）和指定的bound（exclusive）之间的伪随机数 long 。
nextLong(long) - Method in class java.util. SplittableRandom
返回0（包括）和指定的bound（exclusive）之间的伪随机数 long 。
nextLong(long, long) - Method in class java.util.concurrent. ThreadLocalRandom
返回指定原点（含）和指定边界（独占）之间的伪随机 long值。
nextLong(long, long) - Method in class java.util. SplittableRandom
返回指定原点（含）和指定边界（排除）之间的伪随机数 long值。
nextNode() - Method in interface org.w3c.dom.traversal. NodeIterator
返回集合中的下一个节点，并使集合中的 NodeIterator的位置前进。
nextNode() - Method in interface org.w3c.dom.traversal. TreeWalker
将 TreeWalker以相对于当前节点的文档顺序移动到下一个可见节点，并返回新节点。
nextOffset(float) - Method in class java.awt.font. LineBreakMeasurer
返回下一个布局末尾的位置。
nextOffset(float, int, boolean) - Method in class java.awt.font. LineBreakMeasurer
返回下一个布局末尾的位置。
nextOrSame(DayOfWeek) - Static method in class java.time.temporal. TemporalAdjusters
返回下一个或相同的星期几调整器，该调整器将日期调整为在调整日期之后指定的星期几的第一次出现，除非它已在当天在同一对象被返回。
nextPage() - Method in interface javax.sql.rowset. CachedRowSet
增加当前页面的 CachedRowSet 。
nextPermutation(int, int, int[]) - Method in class javafx.collections. ObservableListBase
为更改添加新的置换操作。
nextProbablePrime() - Method in class java.math. BigInteger
返回大于这个 BigInteger的第一个整数，这可能是素数。
nextRemove(int, E) - Method in class javafx.collections. ObservableListBase
在删除单个项目的情况下，添加新的删除操作。
nextRemove(int, List<? extends E>) - Method in class javafx.collections. ObservableListBase
在更改中添加一个新的删除操作，删除多个项目。
nextReplace(int, int, List<? extends E>) - Method in class javafx.collections. ObservableListBase
为更改添加新的替换操作。
nextSet(int, E) - Method in class javafx.collections. ObservableListBase
为更改添加新的集合操作。
nextSetBit(int) - Method in class java.util. BitSet
返回在指定的起始索引上或之后发生的第一个位的索引，设置为 true 。
nextShort() - Method in class java.util. Scanner
将输入的下一个标记扫描为 short 。
nextShort(int) - Method in class java.util. Scanner
将输入的下一个标记扫描为 short 。
nextSibling() - Method in class javafx.scene.control. TreeItem
返回TreeItem的下一个兄弟节点。
nextSibling() - Method in interface org.w3c.dom.traversal. TreeWalker
将 TreeWalker移动到当前节点的下一个兄弟节点，并返回新节点。
nextSibling(TreeItem<T>) - Method in class javafx.scene.control. TreeItem
返回给定节点之后的下一个兄弟节点。
nextTabStop(float, int) - Method in class javax.swing.text. ParagraphView
返回给定参考位置的下一个制表位置位置。
nextTabStop(float, int) - Method in class javax.swing.text. PlainView
返回给定参考位置后的下一个制表位置停止位置。
nextTabStop(float, int) - Method in interface javax.swing.text. TabExpander
返回给定参考位置的下一个制表位置位置。
nextTabStop(float, int) - Method in class javax.swing.text. WrappedPlainView
返回给定参考位置后的下一个制表位置停止位置。
nextTag() - Method in class javax.xml.stream.util. EventReaderDelegate
nextTag() - Method in class javax.xml.stream.util. StreamReaderDelegate
nextTag() - Method in interface javax.xml.stream. XMLEventReader
跳过任何微不足道的空间事件，直到达到START_ELEMENT或END_ELEMENT。
nextTag() - Method in interface javax.xml.stream. XMLStreamReader
跳过任何空白处（isWhiteSpace（）返回true），COMMENT或PROCESSING_INSTRUCTION，直到达到START_ELEMENT或END_ELEMENT。
nextToken() - Method in class java.io. StreamTokenizer
从此分类器的输入流中解析下一个令牌。
nextToken() - Method in class java.util. StringTokenizer
从此字符串标记器返回下一个令牌。
nextToken(String) - Method in class java.util. StringTokenizer
返回此字符串tokenizer字符串中的下一个令牌。
nextTransition(Instant) - Method in class java.time.zone. ZoneRules
在指定的时刻之后获取下一个转换。
nextUp(double) - Static method in class java.lang. Math
返回与正无穷大方向相邻的 d的浮点值。
nextUp(double) - Static method in class java.lang. StrictMath
返回与正无穷大方向相邻的 d的浮点值。
nextUp(float) - Static method in class java.lang. Math
返回与正无穷大方向相邻的 f的浮点值。
nextUp(float) - Static method in class java.lang. StrictMath
返回与正无穷大方向相邻的 f的浮点值。
nextUpdate(int) - Method in class javafx.collections. ObservableListBase
对更改添加新的更新操作。
nextWord() - Method in class javafx.scene.control. TextInputControl
将插入符号移到下一个字的开头。
nextWordAction - Static variable in class javax.swing.text. DefaultEditorKit
Action名称，用于将插入符号移动到下一个字的开头。
NFC - java.text. Normalizer.Form
经典分解，其次是规范组成。
NFD - java.text. Normalizer.Form
规范分解。
NFKC - java.text. Normalizer.Form
兼容性分解，其次是规范组成。
NFKD - java.text. Normalizer.Form
兼容性分解
nil - Variable in class javax.xml.bind. JAXBElement
如果xml元素实例具有xsi：nil =“true”，则为true。
NimbusLookAndFeel - Class in javax.swing.plaf.nimbus
NimbusLookAndFeel类。
NimbusLookAndFeel() - Constructor for class javax.swing.plaf.nimbus. NimbusLookAndFeel
创建一个新的NimbusLookAndFeel。
NimbusStyle - Class in javax.swing.plaf.nimbus
Nimbus使用的SynthStyle实现。
NINE_SQUARE_SCALE - javax.swing.plaf.nimbus. AbstractRegionPainter.PaintContext.CacheMode
九平方尺。
NKO - java.awt.font. NumericShaper.Range
N'Ko范围与N'Ko数字。
NKO - java.lang. Character.UnicodeScript
Unicode脚本“Nko”。
NKO - Static variable in class java.lang. Character.UnicodeBlock
“NKo”Unicode字符块的常数。
NMTOKEN - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NMTOKEN
NMTOKENS - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NMTOKENS
NNTP - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported
USENET新闻使用网络新闻传输协议（NNTP）。
NO - javafx.scene.control. ButtonBar.ButtonData
“no”按钮的标签。
NO - Static variable in class javafx.scene.control. ButtonType
预先定义的ButtonType显示“否”，并具有ButtonBar.ButtonData.NO的ButtonBar.ButtonData 。
NO - Static variable in class javax.security.auth.callback. ConfirmationCallback
NO选项。
NO_CACHING - javax.swing.plaf.nimbus. AbstractRegionPainter.PaintContext.CacheMode
没有缓存。
NO_COMPRESSION - Static variable in class java.util.zip. Deflater
压缩等级为无压缩。
NO_CONTEXT - Static variable in exception org.ietf.jgss. GSSException
安全上下文无效
NO_CRED - Static variable in exception org.ietf.jgss. GSSException
无效证件。
NO_CYCLE - java.awt. MultipleGradientPaint.CycleMethod
使用终端颜色填充剩余的区域。
NO_CYCLE - javafx.scene.paint. CycleMethod
定义使用终端颜色填充剩余区域的循环方法。
NO_DATA_ALLOWED_ERR - Static variable in exception org.w3c.dom. DOMException
如果为不支持数据的 Node指定了数据。
NO_DECOMPOSITION - Static variable in class java.text. Collator
分解模式值。
NO_EXCLUDE - java.awt. Dialog.ModalExclusionType
没有模式排除。
NO_FALLBACK - java.security.cert. PKIXRevocationChecker.Option
禁用后备机制。
NO_FIELDS - Static variable in class java.io. ObjectStreamClass
serialPersistentFields值，表示无可序列化的字段
NO_FLUSH - Static variable in class java.util.zip. Deflater
压缩冲洗模式用于实现最佳压缩效果。
NO_GENERATED_KEYS - Static variable in interface java.sql. Statement
常数表示生成的密钥不应该可用于检索。
NO_HIGHLIGHT - Static variable in class javax.swing.plaf.basic. BasicScrollBarUI
没有高光
NO_IMPLEMENT - Exception in org.omg.CORBA
此异常表示即使已调用的操作存在（它具有IDL定义），也不存在该操作的实现。
NO_IMPLEMENT() - Constructor for exception org.omg.CORBA. NO_IMPLEMENT
构造一个 NO_IMPLEMENT异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。
NO_IMPLEMENT(int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_IMPLEMENT
构造具有指定的次要代码和完成状态的 NO_IMPLEMENT异常。
NO_IMPLEMENT(String) - Constructor for exception org.omg.CORBA. NO_IMPLEMENT
构造一个 NO_IMPLEMENT异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。
NO_IMPLEMENT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_IMPLEMENT
构造具有指定的描述消息，次要代码和完成状态的 NO_IMPLEMENT异常。
NO_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer. ImplicitActivationPolicyValue
NO_LOCATION - Static variable in annotation type javax.xml.bind.annotation. XmlSchema
XmlSchema.location()属性的默认值，表示模式生成器将在此命名空间中生成组件。
NO_MATCH - Static variable in class javafx.scene.input. KeyCombination
与任何事件匹配的KeyCombination。
NO_MEMORY - Exception in org.omg.CORBA
ORB运行时内存不足时抛出异常。
NO_MEMORY() - Constructor for exception org.omg.CORBA. NO_MEMORY
构造一个 NO_MEMORY异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。
NO_MEMORY(int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_MEMORY
构造具有指定的次要代码和完成状态的 NO_MEMORY异常。
NO_MEMORY(String) - Constructor for exception org.omg.CORBA. NO_MEMORY
构造一个 NO_MEMORY异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。
NO_MEMORY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_MEMORY
构造具有指定的描述消息，次要代码和完成状态的 NO_MEMORY异常。
NO_MODIFICATION_ALLOWED_ERR - Static variable in exception org.w3c.dom. DOMException
如果尝试修改不允许修改的对象。
NO_MORE_EVENTS - Static variable in class javax.print.event. PrintJobEvent
并不是所有的打印服务都可以提供有趣的事件，甚至可以告诉工作何时完成。
NO_OPTION - Static variable in class javax.swing. JOptionPane
如果选择NO，则从类方法返回值。
NO_ORIENTATION - Static variable in interface java.awt. Adjustable
表示 Adjustable没有方向。
NO_PERMISSION - Exception in org.omg.CORBA
调用失败时引发异常，因为调用者的权限不足。
NO_PERMISSION - jdk.net. SocketFlow.Status
来电者没有权限创建流。
NO_PERMISSION() - Constructor for exception org.omg.CORBA. NO_PERMISSION
构造一个 NO_PERMISSION异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，以及一个空说明。
NO_PERMISSION(int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_PERMISSION
构造具有指定的次要代码和完成状态的 NO_PERMISSION异常。
NO_PERMISSION(String) - Constructor for exception org.omg.CORBA. NO_PERMISSION
构造一个 NO_PERMISSION异常，指定描述，次要代码为0，完成状态为COMPLETED_NO。
NO_PERMISSION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_PERMISSION
构造一个 NO_PERMISSION异常，指定的描述消息，次要代码和完成状态。
NO_PROPAGATE_INHERIT - java.nio.file.attribute. AclEntryFlag
可以放置在目录上，以指示ACL条目不应放置在创建的目录的子目录可继承的新创建的目录上。
NO_PROXY - Static variable in class java.net. Proxy
代理设置代表一个 DIRECT连接，基本上告诉协议处理程序不使用任何代理。
NO_REPEAT - javafx.scene.layout. BackgroundRepeat
图像放置一次，不重复
NO_RESOURCES - Exception in org.omg.CORBA
当ORB遇到一些一般资源限制时抛出异常。
NO_RESOURCES() - Constructor for exception org.omg.CORBA. NO_RESOURCES
构造一个 NO_RESOURCES异常，默认的次要代码为0，完成状态为CompletionStatus.COMPLETED_NO和一个空描述。
NO_RESOURCES(int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_RESOURCES
构造具有指定的次要代码和完成状态的 NO_RESOURCES异常。
NO_RESOURCES(String) - Constructor for exception org.omg.CORBA. NO_RESOURCES
构造一个 NO_RESOURCES异常，指定的描述，次要代码为0，完成状态为COMPLETED_NO。
NO_RESOURCES(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_RESOURCES
构造具有指定的描述消息，次要代码和完成状态的 NO_RESOURCES异常。
NO_RESPONSE - Exception in org.omg.CORBA
如果客户端尝试检索延迟同步调用的结果，但该请求的响应尚不可用，则会引发此异常。
NO_RESPONSE() - Constructor for exception org.omg.CORBA. NO_RESPONSE
构造一个 NO_RESPONSE异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。
NO_RESPONSE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_RESPONSE
构造具有指定的次要代码和完成状态的 NO_RESPONSE异常。
NO_RESPONSE(String) - Constructor for exception org.omg.CORBA. NO_RESPONSE
构造一个 NO_RESPONSE异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。
NO_RESPONSE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. NO_RESPONSE
构造具有指定的描述消息，次要代码和完成状态的 NO_RESPONSE异常。
NO_ROLE_WITH_NAME - Static variable in class javax.management.relation. RoleStatus
尝试访问未知角色时出现问题类型。
NO_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi. SyncResolver
表示 RowSet对象尝试在数据源中更新，删除或插入行时 不会发生冲突。
NO_STATUS - jdk.net. SocketFlow.Status
设置或获取套接字选项尚未被调用。
NO_SUCH_PAGE - Static variable in interface java.awt.print. Printable
从 print返回，表示 pageIndex太大，请求的页面不存在。
NO_SYNC - Static variable in class javax.sound.midi. Sequencer.SyncMode
从机同步模式，指示不应将定时信息发送到接收机。
NO_TRUST_ANCHOR - java.security.cert. PKIXReason
找不到可接受的信托锚点。
NO_USAGE_RESTRICTIONS - java.sql. PseudoColumnUsage
伪/隐藏列的使用没有限制。
nobject - Static variable in class org.omg.CosNaming. BindingType
noBody() - Static method in class jdk.incubator.http. HttpRequest
请求体处理程序，不发送请求体。
NOBUTTON - Static variable in class java.awt.event. MouseEvent
表示没有鼠标按钮; 由MouseEvent.getButton()使用 。
NoClassDefFoundError - Error in java.lang
如果Java虚拟机或 ClassLoader实例尝试加载类的定义（作为普通方法调用的一部分或作为使用 new表达式创建新实例的 new ），则 new并且不会找到该类的定义。
NoClassDefFoundError() - Constructor for error java.lang. NoClassDefFoundError
构造一个没有详细消息的 NoClassDefFoundError 。
NoClassDefFoundError(String) - Constructor for error java.lang. NoClassDefFoundError
构造具有指定详细消息的 NoClassDefFoundError 。
NoConnectionPendingException - Exception in java.nio.channels
当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
NoConnectionPendingException() - Constructor for exception java.nio.channels. NoConnectionPendingException
构造这个类的一个实例。
NoContext - Exception in org.omg.PortableServer.CurrentPackage
org / omg / PortableServer / CurrentPackage / NoContext.java。
NoContext() - Constructor for exception org.omg.PortableServer.CurrentPackage. NoContext
NoContext(String) - Constructor for exception org.omg.PortableServer.CurrentPackage. NoContext
NoContextHelper - Class in org.omg.PortableServer.CurrentPackage
org / omg / PortableServer / CurrentPackage / NoContextHelper.java。
NoContextHelper() - Constructor for class org.omg.PortableServer.CurrentPackage. NoContextHelper
node() - Method in class java.util. UUID
与此UUID相关联的节点值。
node(String) - Method in class java.util.prefs. AbstractPreferences
实现 node方法按照在本说明书中 Preferences.node(String) 。
node(String) - Method in class java.util.prefs. Preferences
返回与该节点相同树中的命名偏好节点，创建它及其任何祖先（如果它们不存在）。
Node - Class in javafx.scene
场景图节点的基类。
Node - Interface in javax.xml.soap
XML文档中节点（元素）的表示。
Node - Interface in org.w3c.dom
Node接口是整个文档对象模型的主要数据类型。
Node() - Constructor for class javafx.scene. Node
创建一个新的Node实例。
NODE - javafx.scene. AccessibleRole
节点角色。
NODE - javax.xml.xpath. XPathEvaluationResult.XPathResultType
XPath 1.0 NodeSet数据类型。
NODE - Static variable in class javax.xml.xpath. XPathConstants
XPath 1.0 NodeSet数据类型。
NODE_ADOPTED - Static variable in interface org.w3c.dom. UserDataHandler
采用节点，采用 Document.adoptNode() 。
NODE_AT_POINT - javafx.scene. AccessibleAttribute
返回给定位置的节点。
NODE_CLONED - Static variable in interface org.w3c.dom. UserDataHandler
该节点被克隆，使用 Node.cloneNode() 。
NODE_DELETED - Static variable in interface org.w3c.dom. UserDataHandler
节点被删除。
NODE_IMPORTED - Static variable in interface org.w3c.dom. UserDataHandler
节点导入，使用 Document.importNode() 。
NODE_RENAMED - Static variable in interface org.w3c.dom. UserDataHandler
该节点被重命名，使用 Document.renameNode() 。
nodeChanged(TreeNode) - Method in class javax.swing.tree. DefaultTreeModel
在更改树中如何表示节点之后调用此方法。
NodeChangeEvent - Class in java.util.prefs
由 Preferences节点发出的用于指示该节点的子节点已被添加或删除的事件。
NodeChangeEvent(Preferences, Preferences) - Constructor for class java.util.prefs. NodeChangeEvent
构造一个新的 NodeChangeEvent实例。
NodeChangeListener - Interface in java.util.prefs
用于接收偏好节点更改事件的侦听器。
nodeDimensions - Variable in class javax.swing.plaf.basic. BasicTreeUI
代表告诉TreeState一个节点所需的大小。
nodeDimensions - Variable in class javax.swing.tree. AbstractLayoutCache
负责获取节点大小的对象。
NodeDimensions() - Constructor for class javax.swing.tree. AbstractLayoutCache.NodeDimensions
NodeDimensionsHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.NodeDimensionsHandler
nodeExists(String) - Method in class java.util.prefs. AbstractPreferences
实现 nodeExists方法按照在本说明书中 Preferences.nodeExists(String) 。
nodeExists(String) - Method in class java.util.prefs. Preferences
如果指定的首选节点存在于与该节点相同的树中，则返回true。
NodeFilter - Interface in org.w3c.dom.traversal
过滤器是知道如何“过滤掉”节点的对象。
NodeIterator - Interface in org.w3c.dom.traversal
NodeIterators用于逐步通过一组节点，例如
NodeList - Interface in org.w3c.dom
NodeList接口提供了节点的有序集合的抽象，而不定义或约束如何实现该集合。
NodeOrientation - Enum in javafx.geometry
一组用于描述节点视觉数据流的值。
nodeOrientationProperty() - Method in class javafx.scene. Node
属性保存NodeOrientation。
nodeOrientationProperty() - Method in class javafx.scene. Scene
属性保存NodeOrientation。
nodeProperty() - Method in class javafx.animation. FadeTransition
这个 Transition的目标节点。
nodeProperty() - Method in class javafx.animation. ParallelTransition
这个Node用于所有的孩子Transitions ，它们不定义目标Node本身。
nodeProperty() - Method in class javafx.animation. PathTransition
这个 PathTransition的目标节点。
nodeProperty() - Method in class javafx.animation. RotateTransition
这个 RotateTransition的目标节点。
nodeProperty() - Method in class javafx.animation. ScaleTransition
该目标节点为 ScaleTransition 。
nodeProperty() - Method in class javafx.animation. SequentialTransition
这个Node用于所有的孩子Transitions ，它们不定义目标Node本身。
nodeProperty() - Method in class javafx.animation. TranslateTransition
这个 TranslateTransition的目标节点。
nodeProperty() - Method in class javafx.scene.chart. PieChart.Data
访问表示饼图切片的节点。
nodeProperty() - Method in class javafx.scene.chart. XYChart.Data
要显示此数据项的节点。
nodeProperty() - Method in class javafx.scene.chart. XYChart.Series
该系列显示的节点。
nodesChanged(TreeNode, int[]) - Method in class javax.swing.tree. DefaultTreeModel
在更改了如何在树中表示由childIndicies标识的子项后调用此方法。
NODESET - javax.xml.xpath. XPathEvaluationResult.XPathResultType
XPath 1.0 NodeSet数据类型。
NODESET - Static variable in class javax.xml.xpath. XPathConstants
XPath 1.0 NodeSet数据类型。
NodeSetData< T> - Interface in javax.xml.crypto
包含节点集的 Data类型的抽象表示。
nodeStructureChanged(TreeNode) - Method in class javax.swing.tree. DefaultTreeModel
如果您完全改变了节点及其子节点的子节点，则调用此方法
nodesWereInserted(TreeNode, int[]) - Method in class javax.swing.tree. DefaultTreeModel
在将一些TreeNodes插入节点后调用此方法。
nodesWereRemoved(TreeNode, int[], Object[]) - Method in class javax.swing.tree. DefaultTreeModel
从节点中删除一些TreeNodes后，调用此方法。
noFocusBorder - Static variable in class javax.swing. DefaultListCellRenderer
没有焦点边界
noFocusBorder - Static variable in class javax.swing.plaf.basic. BasicComboBoxRenderer
一个空的 Border 。
noFocusBorder - Static variable in class javax.swing.table. DefaultTableCellRenderer
边框无焦点。
NOFOLLOW_LINKS - java.nio.file. LinkOption
不要跟随符号链接。
NOFRAMES - Static variable in class javax.swing.text.html. HTML.Tag
标签<noframes>
NOHREF - Static variable in class javax.swing.text.html. HTML.Attribute
属性“nohref”
NoInitialContextException - Exception in javax.naming
当不能创建初始上下文实现时，抛出此异常。
NoInitialContextException() - Constructor for exception javax.naming. NoInitialContextException
构造一个NoInitialContextException的实例。
NoInitialContextException(String) - Constructor for exception javax.naming. NoInitialContextException
构造一个NoInitialContextException的实例，并带有解释。
NON_ANONYMOUS - javax.xml.ws.soap. AddressingFeature.Responses
指定仅使用非匿名响应。
NON_CONTINUOUS_DIVIDER - Static variable in class javax.swing.plaf.basic. BasicSplitPaneUI
用于非连续布局的分隔符将添加到具有此对象的拆分窗格中。
non_existent(Object) - Method in class org.omg.CORBA.portable. Delegate
确定对象引用的服务器对象是否已被销毁。
non_existent(Servant) - Method in interface org.omg.PortableServer.portable. Delegate
此操作用于检查对象的存在。
NON_EXISTENT - Interface in org.omg.PortableInterceptor
org / omg / PortableInterceptor / NON_EXISTENT.java。
NON_HEAP - java.lang.management. MemoryType
非堆内存类型。
NON_RETAIN - Static variable in class org.omg.PortableServer. ServantRetentionPolicyValue
NON_SPACING_MARK - Static variable in class java.lang. Character
Unicode规范中的一般类别“Mn”。
NON_ZERO - javafx.scene.shape. FillRule
定义用于确定路径内部的非零填充规则。
nonContinuousLayoutDivider - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
当使用非连续布局时，分隔线阴影的实例。
NONCONVERT - javafx.scene.input. KeyCode
不转换功能键的常数。
NONCRITICAL - Static variable in interface javax.naming.ldap. Control
表示非关键控制。
NONE - java.awt. TrayIcon.MessageType
简单的信息
NONE - java.security. DrbgParameters.Capability
既不预测抵抗也不抵消。
NONE - javafx.animation. PathTransition.OrientationType
目标 node的旋转矩阵沿着几何路径保持不变。
NONE - javafx.scene.chart. LineChart.SortingPolicy
数据应按 XYChart.dataProperty()中的列表定义的顺序 保留 。
NONE - javafx.scene.control. Alert.AlertType
NONE警报类型具有在Alert中未设置任何默认属性的效果。
NONE - javafx.scene.input. MouseButton
不表示按钮
NONE - javafx.scene.input. ScrollEvent.HorizontalTextScrollUnits
基于水平文本的滚动数据不可用（不由底层平台提供）。
NONE - javafx.scene.input. ScrollEvent.VerticalTextScrollUnits
垂直的基于文本的滚动数据不可用（不由底层平台提供）。
NONE - javafx.scene.shape. CullFace
不要进行任何脸剔除。
NONE - javafx.stage. Modality
定义不是模态的顶级窗口，并且不会阻止任何其他窗口。
NONE - javax.lang.model.type. TypeKind
在没有实际类型适合的情况下使用的伪类型。
NONE - javax.xml.bind.annotation. XmlAccessType
没有字段或属性绑定到XML，除非它们被特定的注释与一些JAXB注释。
NONE - Static variable in class java.awt. GridBagConstraints
不要调整组件的大小。
NONE - Static variable in class java.awt. JobAttributes.DialogType
用于指定不打印对话框的 DialogType实例。
NONE - Static variable in class javafx.scene. Cursor
无光标类型。
NONE - Static variable in enum javafx.scene.input. TransferMode
空数组传输模式。
NONE - Static variable in class javafx.scene.layout. BorderStrokeStyle
表示不应绘制中风。
NONE - Static variable in class javax.print.attribute.standard. Compression
不使用压缩。
NONE - Static variable in class javax.print.attribute.standard. Finishings
不执行任何约束。
NONE - Static variable in class javax.print.attribute.standard. JobSheets
没有打印工作表。
NONE - Static variable in class javax.swing. JRootPane
用于windowDecorationStyle属性的常量。
NONE - Static variable in class javax.swing. TransferHandler
一个 int表示转移动作。
NONE_OPTION - Static variable in class javax.swing. DebugGraphics
不要调试图形操作。
noneMatch(DoublePredicate) - Method in interface java.util.stream. DoubleStream
返回此流的元素是否与提供的谓词匹配。
noneMatch(IntPredicate) - Method in interface java.util.stream. IntStream
返回此流的元素是否与提供的谓词匹配。
noneMatch(LongPredicate) - Method in interface java.util.stream. LongStream
返回此流的元素是否与提供的谓词匹配。
noneMatch(Predicate<? super T>) - Method in interface java.util.stream. Stream
返回此流的元素是否与提供的谓词匹配。
noneOf(Class<E>) - Static method in class java.util. EnumSet
使用指定的元素类型创建一个空的枚举集。
NONEXISTENT - jdk.jshell. Snippet.Status
该代码段不活跃，因为它不存在。
NoninvertibleTransformException - Exception in java.awt.geom
NoninvertibleTransformException类表示如果执行操作需要AffineTransform对象的反向但AffineTransform处于非可逆状态时抛出的异常。
NoninvertibleTransformException(String) - Constructor for exception java.awt.geom. NoninvertibleTransformException
构造具有指定详细消息的 NoninvertibleTransformException实例。
NonInvertibleTransformException - Exception in javafx.scene.transform
NonInvertibleTransformException类表示如果执行的操作需要 Transform对象处于非可逆状态的对象时抛出异常。
NonInvertibleTransformException(String) - Constructor for exception javafx.scene.transform. NonInvertibleTransformException
使用指定的详细信息创建一个新实例 NonInvertibleTransformException 。
nonNull(Object) - Static method in class java.util. Objects
返回 true如果提供的参考是非 null否则返回 false 。
NONNULL - Static variable in interface java.util. Spliterator
特征值表示源保证遇到的元素不会是 null 。
NonReadableChannelException - Exception in java.nio.channels
尝试从最初打开阅读的频道中读取时未抛出的异常。
NonReadableChannelException() - Constructor for exception java.nio.channels. NonReadableChannelException
构造这个类的一个实例。
NONUPDATABLE_VIEW_SYNC - Static variable in class javax.sql.rowset.spi. SyncProvider
表明 SyncProvider实现 不支持之间的同步 RowSet对象和SQL VIEW用来填充它。
NonWritableChannelException - Exception in java.nio.channels
尝试写入最初未打开的通道进行写入时抛出未检查的异常。
NonWritableChannelException() - Constructor for exception java.nio.channels. NonWritableChannelException
构造这个类的一个实例。
NOON - Static variable in class java.time. LocalTime
中午的时候，“12：00”。
NoPermissionException - Exception in javax.naming
尝试执行客户端没有权限的操作时抛出此异常。
NoPermissionException() - Constructor for exception javax.naming. NoPermissionException
构造一个新的NoPermissionException实例。
NoPermissionException(String) - Constructor for exception javax.naming. NoPermissionException
使用解释构造一个新的NoPermissionException实例。
NOPOS - Static variable in interface javax.tools. Diagnostic
用于表示没有位置可用。
NOPOS - Static variable in class jdk.jshell. Diag
用于表示没有位置可用。
NOPOS - Static variable in interface jdk.nashorn.api.tree. Diagnostic
用于表示没有位置可用。
NORESIZE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“noresize”
NORM_PRIORITY - Static variable in class java.lang. Thread
分配给线程的默认优先级。
NORMAL - java.awt. Taskbar.State
进度指示器以正常颜色和确定模式显示。
NORMAL - java.awt. Window.Type
表示 正常窗口。
NORMAL - java.time.format. SignStyle
只有当值为负时，才能输出符号。
NORMAL - javafx.print. PrintQuality
指定NORMAL质量打印。
NORMAL - javafx.scene.text. FontWeight
表示正常字体重量（400）。
NORMAL - javax.swing. JTable.PrintMode
将表格打印为当前尺寸的打印模式，如果需要，可以跨多页扩展列和行。
NORMAL - Static variable in class java.awt. Frame
框架处于“正常”状态。
NORMAL - Static variable in class java.awt. PageAttributes.PrintQualityType
PrintQualityType实例用于指定正常的打印质量。
NORMAL - Static variable in class javax.print.attribute.standard. PrintQuality
正常或中等质量的打印机。
NORMAL_CLOSURE - Static variable in interface jdk.incubator.http. WebSocket
WebSocket关闭消息状态码（ 1000 ），表示正常关闭，意味着建立连接的目的已经实现。
NORMAL_EXIT - java.awt.desktop. QuitStrategy
通过拨打 System.exit(0)关闭应用程序。
NORMAL_PRIORITY - Static variable in class jdk.net. SocketFlow
normalize() - Method in class java.net. URI
规范此URI的路径。
normalize() - Method in interface java.nio.file. Path
返回一个路径，该路径是冗余名称元素的消除。
normalize() - Method in class javafx.geometry. Point2D
归一化由该实例表示的相对幅度向量。
normalize() - Method in class javafx.geometry. Point3D
归一化由该实例表示的相对幅度向量。
normalize() - Method in class javax.imageio.metadata. IIOMetadataNode
没有，因为 IIOMetadataNode的不包含 Text孩子。
normalize() - Method in class javax.xml.datatype. XMLGregorianCalendar
将此实例归一化为UTC。
normalize() - Method in interface org.w3c.dom. Node
将这个 Node （包括属性节点）下的子树的全部深度全部 Text “正常”形式中，其中只有结构（例如元素，注释，处理指令，CDATA部分和实体引用）分离 Text节点即，既没有相邻的 Text节点也没有空的 Text节点。
normalize(int, int) - Static method in class javafx.scene.control. IndexRange
创建一个具有较小值作为起始索引的IndexRange实例的便利方法，较大的值作为结束索引。
normalize(CharSequence, Normalizer.Form) - Static method in class java.text. Normalizer
归一化一个char值序列。
normalized() - Method in interface java.time.chrono. ChronoPeriod
返回此期间的副本，并将每个单位的金额归一化。
normalized() - Method in class java.time. Period
返回此期间的副本，其中标准化了几年和几个月。
normalized() - Method in class java.time. ZoneId
规范时区ID，尽可能返回 ZoneOffset 。
normalizeDocument() - Method in interface org.w3c.dom. Document
该方法的作用就好像文档正在进行保存和加载循环，将文档置于“正常”形式。
NormalizedStringAdapter - Class in javax.xml.bind.annotation.adapters
XmlAdapter处理xs:normalizedString 。
NormalizedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters. NormalizedStringAdapter
normalizeMimeType(String) - Method in class java.awt.datatransfer. DataFlavor
已过时。
此方法从1.1开始就不会被此实现所调用
normalizeMimeType(String) - Method in class javax.activation. ActivationDataFlavor
已过时。
normalizeMimeTypeParameter(String, String) - Method in class java.awt.datatransfer. DataFlavor
已过时。
此方法从1.1开始就不会被此实现所调用
normalizeMimeTypeParameter(String, String) - Method in class javax.activation. ActivationDataFlavor
已过时。
Normalizer - Class in java.text
该类提供了方法 normalize ，它将Unicode文本转换为等效的组合或分解形式，允许更容易地对文本进行排序和搜索。
Normalizer.Form - Enum in java.text
此枚举提供了 Unicode Standard Annex #15 — Unicode Normalization Forms中描述的四个Unicode规范化表单的常量，以及访问它们的两种方法。
normalizeTabRuns(int, int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
规范标签运行。
normalizeTabRuns(int, int, int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI.TabbedPaneLayout
normalizeWith(Calendar) - Method in class javax.xml.datatype. Duration
通过使用特定的时刻作为参考点，将几个月和几个字段转换为日期字段。
NoRouteToHostException - Exception in java.net
指示尝试将套接字连接到远程地址和端口时发生错误。
NoRouteToHostException() - Constructor for exception java.net. NoRouteToHostException
构造一个没有详细消息的新的NoRouteToHostException。
NoRouteToHostException(String) - Constructor for exception java.net. NoRouteToHostException
构造一个新的NoRouteToHostException，其中指定的详细信息是为什么无法访问远程主机。
NORTH - Static variable in class java.awt. BorderLayout
北面布局约束（容器顶部）。
NORTH - Static variable in class java.awt. GridBagConstraints
将组件放置在其显示区域的顶部，水平居中。
NORTH - Static variable in class javax.swing. SpringLayout
指定组件的边界矩形的顶边。
NORTH - Static variable in interface javax.swing. SwingConstants
指南针方向北（向上）。
NORTH_EAST - Static variable in interface javax.swing. SwingConstants
指南针方向东北（右上）。
NORTH_WEST - Static variable in interface javax.swing. SwingConstants
罗盘方向西北（左上）。
NORTHEAST - Static variable in class java.awt. GridBagConstraints
将组件放在其显示区域的右上角。
northPane - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI
北面
NORTHWEST - Static variable in class java.awt. GridBagConstraints
将组件放在其显示区域的左上角。
NoServant - Exception in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / NoServant.java。
NoServant() - Constructor for exception org.omg.PortableServer.POAPackage. NoServant
NoServant(String) - Constructor for exception org.omg.PortableServer.POAPackage. NoServant
NoServantHelper - Class in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / NoServantHelper.java。
NoServantHelper() - Constructor for class org.omg.PortableServer.POAPackage. NoServantHelper
NOSHADE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“noshade”
NoSuchAlgorithmException - Exception in java.security
当请求特定的加密算法但在环境中不可用时抛出此异常。
NoSuchAlgorithmException() - Constructor for exception java.security. NoSuchAlgorithmException
构造一个没有详细消息的NoSuchAlgorithmException。
NoSuchAlgorithmException(String) - Constructor for exception java.security. NoSuchAlgorithmException
构造具有指定详细消息的NoSuchAlgorithmException。
NoSuchAlgorithmException(String, Throwable) - Constructor for exception java.security. NoSuchAlgorithmException
创建一个具有指定的详细信息和原因的 NoSuchAlgorithmException 。
NoSuchAlgorithmException(Throwable) - Constructor for exception java.security. NoSuchAlgorithmException
创建 NoSuchAlgorithmException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
NoSuchAttributeException - Exception in javax.naming.directory
尝试访问不存在的属性时抛出此异常。
NoSuchAttributeException() - Constructor for exception javax.naming.directory. NoSuchAttributeException
构造一个新的NoSuchAttributeException实例。
NoSuchAttributeException(String) - Constructor for exception javax.naming.directory. NoSuchAttributeException
使用解释构造一个新的NoSuchAttributeException实例。
NoSuchDynamicMethodException - Exception in jdk.dynalink
如果呼叫站点无法通过任何可用的GuardingDynamicLinker链接，则在调用时抛出。
NoSuchDynamicMethodException(String) - Constructor for exception jdk.dynalink. NoSuchDynamicMethodException
创建一个新的NoSuchDynamicMethodException
NoSuchElementException - Exception in java.util
被各种访问器方法抛出，表示被请求的元素不存在。
NoSuchElementException() - Constructor for exception java.util. NoSuchElementException
构造 NoSuchElementException其中包含 null作为其错误消息字符串。
NoSuchElementException(String) - Constructor for exception java.util. NoSuchElementException
构造一个 NoSuchElementException ，保存对错误消息字符串 s的引用，以供稍后通过 getMessage方法检索。
NoSuchFieldError - Error in java.lang
如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。
NoSuchFieldError() - Constructor for error java.lang. NoSuchFieldError
构造一个没有详细消息的 NoSuchFieldError 。
NoSuchFieldError(String) - Constructor for error java.lang. NoSuchFieldError
构造具有指定详细消息的 NoSuchFieldError 。
NoSuchFieldException - Exception in java.lang
表示该类没有指定名称的字段。
NoSuchFieldException() - Constructor for exception java.lang. NoSuchFieldException
构造函数。
NoSuchFieldException(String) - Constructor for exception java.lang. NoSuchFieldException
具有详细消息的构造方法。
NoSuchFileException - Exception in java.nio.file
当尝试访问不存在的文件时抛出检查的异常。
NoSuchFileException(String) - Constructor for exception java.nio.file. NoSuchFileException
构造这个类的一个实例。
NoSuchFileException(String, String, String) - Constructor for exception java.nio.file. NoSuchFileException
构造这个类的一个实例。
NoSuchMechanismException - Exception in javax.xml.crypto
当请求特定的XML机制但在环境中不可用时抛出此异常。
NoSuchMechanismException() - Constructor for exception javax.xml.crypto. NoSuchMechanismException
构造一个新的 NoSuchMechanismException与 null作为其详细信息。
NoSuchMechanismException(String) - Constructor for exception javax.xml.crypto. NoSuchMechanismException
构造一个新的 NoSuchMechanismException具有指定的详细信息。
NoSuchMechanismException(String, Throwable) - Constructor for exception javax.xml.crypto. NoSuchMechanismException
构造一个新的 NoSuchMechanismException与指定的详细信息和原因。
NoSuchMechanismException(Throwable) - Constructor for exception javax.xml.crypto. NoSuchMechanismException
构造一个新的 NoSuchMechanismException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
NoSuchMethodError - Error in java.lang
如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。
NoSuchMethodError() - Constructor for error java.lang. NoSuchMethodError
构造一个 NoSuchMethodError ，没有详细信息。
NoSuchMethodError(String) - Constructor for error java.lang. NoSuchMethodError
构造具有指定详细消息的 NoSuchMethodError 。
NoSuchMethodException - Exception in java.lang
当无法找到特定方法时抛出。
NoSuchMethodException() - Constructor for exception java.lang. NoSuchMethodException
构造一个 NoSuchMethodException没有详细信息。
NoSuchMethodException(String) - Constructor for exception java.lang. NoSuchMethodException
构造一个 NoSuchMethodException的详细消息。
NoSuchObjectException - Exception in java.rmi
如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
NoSuchObjectException(String) - Constructor for exception java.rmi. NoSuchObjectException
构造具有指定详细消息的 NoSuchObjectException 。
NoSuchPaddingException - Exception in javax.crypto
当请求特定的填充机制但在环境中不可用时抛出此异常。
NoSuchPaddingException() - Constructor for exception javax.crypto. NoSuchPaddingException
构造一个没有详细消息的NoSuchPaddingException。
NoSuchPaddingException(String) - Constructor for exception javax.crypto. NoSuchPaddingException
构造具有指定详细消息的NoSuchPaddingException。
NoSuchProviderException - Exception in java.security
当特定安全提供程序被请求但在环境中不可用时抛出此异常。
NoSuchProviderException() - Constructor for exception java.security. NoSuchProviderException
构造一个没有详细信息的NoSuchProviderException。
NoSuchProviderException(String) - Constructor for exception java.security. NoSuchProviderException
构造具有指定详细消息的NoSuchProviderException。
not() - Method in class java.math. BigInteger
返回值为 (~this)的BigInteger。
not() - Method in class javafx.beans.binding. BooleanExpression
创建一个新的 BooleanExpression ，计算这个 BooleanExpression的否定。
not(ObservableBooleanValue) - Static method in class javafx.beans.binding. Bindings
创建一个BooleanBinding ，计算ObservableBooleanValue的值的倒数 。
not(QueryExp) - Static method in class javax.management. Query
返回一个约束，它是其参数的否定。
NOT_ACCEPTING_JOBS - Static variable in class javax.print.attribute.standard. PrinterIsAcceptingJobs
打印机目前正在拒绝发送给它的任何作业。
NOT_ATTEMPTED - Static variable in class javax.print.attribute.standard. PDLOverrideSupported
打印机不尝试使外部作业属性值优先于文档打印数据中的嵌入式指令。
NOT_CA_CERT - java.security.cert. PKIXReason
证书不是CA证书。
NOT_CONNECTED - jdk.net. SocketFlow.Status
无法创建流程，因为套接字未连接。
not_context - Static variable in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
NOT_EQUAL - javax.swing. RowFilter.ComparisonType
表示应包含值不等于提供值的条目。
NOT_EQUAL_TO - com.sun.source.tree. Tree.Kind
用于实例BinaryTree代表不等于对!= 。
NOT_EQUAL_TO - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree代表不等于对!= 。
NOT_FOUND_ERR - Static variable in exception org.w3c.dom. DOMException
如果尝试在不存在的情况下引用 Node 。
NOT_HANDSHAKING - javax.net.ssl. SSLEngineResult.HandshakeStatus
SSLEngine目前不握手。
NOT_NEGATIVE - java.time.format. SignStyle
风格阻止负值，在打印时抛出异常。
not_object - Static variable in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
NOT_SPECIFIED - Static variable in class javax.sound.sampled. AudioSystem
一个代表未知数值的整数。
NOT_STARTED - javafx.print. PrinterJob.JobStatus
新工作状态。
NOT_SUPPORTED - jdk.net. SocketFlow.Status
此套接字不支持流创建。
NOT_SUPPORTED - Static variable in class javax.print.attribute.standard. ColorSupported
打印机不能进行任何类型的彩色打印。
NOT_SUPPORTED_ERR - Static variable in exception org.w3c.dom. DOMException
如果实现不支持所请求的对象或操作类型。
NOT_YET_VALID - java.security.cert. CertPathValidatorException.BasicReason
证书尚未生效。
NotActiveException - Exception in java.io
序列化或反序列化不活跃时抛出。
NotActiveException() - Constructor for exception java.io. NotActiveException
构造函数创建一个新的NotActiveException没有理由。
NotActiveException(String) - Constructor for exception java.io. NotActiveException
构造函数创建一个新的NotActiveException与给定的原因。
Notation - Interface in org.w3c.dom
该接口表示在DTD中声明的符号。
NOTATION - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NOTATION
NOTATION_DECLARATION - Static variable in interface javax.xml.stream. XMLStreamConstants
表示符号
NOTATION_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 Notation 。
notationDecl(String, String, String) - Method in interface org.xml.sax. DTDHandler
接收符号声明事件的通知。
notationDecl(String, String, String) - Method in class org.xml.sax. HandlerBase
已过时。
接收符号声明的通知。
notationDecl(String, String, String) - Method in class org.xml.sax.helpers. DefaultHandler
接收符号声明的通知。
notationDecl(String, String, String) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤符号声明事件。
NotationDeclaration - Interface in javax.xml.stream.events
用于处理符号声明的接口接收符号声明事件的通知。
NotBoundException - Exception in java.rmi
如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出 NotBoundException 。
NotBoundException() - Constructor for exception java.rmi. NotBoundException
构造一个没有指定详细信息的 NotBoundException 。
NotBoundException(String) - Constructor for exception java.rmi. NotBoundException
构造具有指定详细消息的 NotBoundException 。
NotCompliantMBeanException - Exception in javax.management
尝试在不符合JMX的MBean的MBean服务器中注册对象时发生的异常。
NotCompliantMBeanException() - Constructor for exception javax.management. NotCompliantMBeanException
默认构造函数。
NotCompliantMBeanException(String) - Constructor for exception javax.management. NotCompliantMBeanException
允许指定特定错误消息的构造方法。
NotContextException - Exception in javax.naming
当命名操作进行到需要上下文以继续操作的点时抛出此异常，但解析的对象不是上下文。
NotContextException() - Constructor for exception javax.naming. NotContextException
构造一个新的NotContextException实例。
NotContextException(String) - Constructor for exception javax.naming. NotContextException
使用解释构造一个新的NotContextException实例。
NotDirectoryException - Exception in java.nio.file
当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
NotDirectoryException(String) - Constructor for exception java.nio.file. NotDirectoryException
构造这个类的一个实例。
note - Variable in class javax.sound.midi. VoiceStatus
这个声音正在播放的MIDI音符。
NOTE - javax.tools. Diagnostic.Kind
来自工具的信息性消息。
NOTE - jdk.nashorn.api.tree. Diagnostic.Kind
来自工具的信息性消息。
NOTE - Static variable in class java.awt. PageAttributes.MediaType
NA_LETTER的别名。
NOTE_OFF - Static variable in class javax.sound.midi. ShortMessage
注释消息（0x80或128）的命令值。
NOTE_ON - Static variable in class javax.sound.midi. ShortMessage
注释消息（0x90或144）的命令值。
NotEmpty - Exception in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / NotEmpty.java。
NotEmpty() - Constructor for exception org.omg.CosNaming.NamingContextPackage. NotEmpty
NotEmpty(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage. NotEmpty
NotEmptyHelper - Class in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / NotEmptyHelper.java。
NotEmptyHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage. NotEmptyHelper
NotEmptyHolder - Class in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / NotEmptyHolder.java。
NotEmptyHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage. NotEmptyHolder
NotEmptyHolder(NotEmpty) - Constructor for class org.omg.CosNaming.NamingContextPackage. NotEmptyHolder
noteOff(int) - Method in interface javax.sound.midi. MidiChannel
关闭指定的音符。
noteOff(int, int) - Method in interface javax.sound.midi. MidiChannel
关闭指定的音符。
noteOn(int, int) - Method in interface javax.sound.midi. MidiChannel
开始指定的音符声音。
notEqual(double, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
notEqual(float, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个价值ObservableNumberValue不等于一个恒定值（用公差）。
notEqual(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
notEqual(int, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
notEqual(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
notEqual(long, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
notEqual(Object, ObservableObjectValue<?>) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值不等于一个恒定值，则保留true 。
notEqual(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableStringValue的值不等于一个恒定值，则保留true 。
notEqual(ObservableBooleanValue, ObservableBooleanValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableBooleanValue不相等。
notEqual(ObservableNumberValue, double, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常量值（具有公差），则保留true 。
notEqual(ObservableNumberValue, float, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
notEqual(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
notEqual(ObservableNumberValue, int, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常数（容差），则保留true 。
notEqual(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个恒定值，则保留true 。
notEqual(ObservableNumberValue, long, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableNumberValue的值不等于一个常量值（具有公差），则保留true 。
notEqual(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等。
notEqual(ObservableNumberValue, ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableNumberValue不相等（与公差）。
notEqual(ObservableObjectValue<?>, Object) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值不等于一个恒定值，则保留true 。
notEqual(ObservableObjectValue<?>, ObservableObjectValue<?>) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableObjectValue不相等。
notEqual(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不等于一个恒定值。
notEqual(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不相等。
notEqualIgnoreCase(String, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。
notEqualIgnoreCase(ObservableStringValue, String) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。
notEqualIgnoreCase(ObservableStringValue, ObservableStringValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的BooleanBinding持有true如果两个实例的值ObservableStringValue不等于忽略大小写。
notExists(Path, LinkOption...) - Static method in class java.nio.file. Files
测试此路径所在的文件是否不存在。
notFilter(RowFilter<M, I>) - Static method in class javax.swing. RowFilter
如果提供的过滤器不包含条目，则返回一个 RowFilter ，其中包含条目。
NotFound - Exception in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / NotFound.java。
NotFound() - Constructor for exception org.omg.CosNaming.NamingContextPackage. NotFound
NotFound(String, NotFoundReason, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage. NotFound
NotFound(NotFoundReason, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage. NotFound
NotFoundHelper - Class in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / NotFoundHelper.java。
NotFoundHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage. NotFoundHelper
NotFoundHolder - Class in org.omg.CosNaming.NamingContextPackage
org / omg / CosNaming / NamingContextPackage / NotFoundHolder.java。
NotFoundHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage. NotFoundHolder
NotFoundHolder(NotFound) - Constructor for class org.omg.CosNaming.NamingContextPackage. NotFoundHolder
NotFoundReason - Class in org.omg.CosNaming.NamingContextPackage
表示无法解决的原因。
NotFoundReason(int) - Constructor for class org.omg.CosNaming.NamingContextPackage. NotFoundReason
NotFoundReasonHelper - Class in org.omg.CosNaming.NamingContextPackage
表示无法解决的原因。
NotFoundReasonHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHelper
NotFoundReasonHolder - Class in org.omg.CosNaming.NamingContextPackage
表示无法解决的原因。
NotFoundReasonHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHolder
NotFoundReasonHolder(NotFoundReason) - Constructor for class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHolder
NotIdentifiableEvent - Interface in javax.xml.bind
此事件表示解决ID / IDREF时遇到问题。
NotIdentifiableEventImpl - Class in javax.xml.bind.helpers
NotIdentifiableEvent接口的默认实现。
NotIdentifiableEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers. NotIdentifiableEventImpl
创建一个新的NotIdentifiableEventImpl。
NotIdentifiableEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers. NotIdentifiableEventImpl
创建一个新的NotIdentifiableEventImpl。
Notification - Class in javax.management
Notification类表示由MBean发出的通知。
Notification - Interface in com.sun.nio.sctp
来自SCTP堆栈的通知。
Notification(String, Object, long) - Constructor for class javax.management. Notification
创建Notification对象。
Notification(String, Object, long, long) - Constructor for class javax.management. Notification
创建Notification对象。
Notification(String, Object, long, long, String) - Constructor for class javax.management. Notification
创建Notification对象。
Notification(String, Object, long, String) - Constructor for class javax.management. Notification
创建Notification对象。
NotificationBroadcaster - Interface in javax.management
由发出通知的MBean实现的接口。
NotificationBroadcasterSupport - Class in javax.management
提供NotificationEmitter接口的实现。
NotificationBroadcasterSupport() - Constructor for class javax.management. NotificationBroadcasterSupport
构造一个NotificationBroadcasterSupport，其中每个侦听器被发送通知的线程调用。
NotificationBroadcasterSupport(Executor) - Constructor for class javax.management. NotificationBroadcasterSupport
构造一个NotificationBroadcasterSupport，其中使用给定的Executor调用每个侦听器 。
NotificationBroadcasterSupport(Executor, MBeanNotificationInfo...) - Constructor for class javax.management. NotificationBroadcasterSupport
构造一个NotificationBroadcasterSupport，其中包含有关可能发送的通知的信息，以及使用给定的Executor调用每个监听器的信息 。
NotificationBroadcasterSupport(MBeanNotificationInfo...) - Constructor for class javax.management. NotificationBroadcasterSupport
构建一个NotificationBroadcasterSupport，其中包含可能发送的通知的信息。
NotificationEmitter - Interface in javax.management
由发出通知的MBean实现的接口。
NotificationFilter - Interface in javax.management
由任何作为通知过滤器的类来实现。
NotificationFilterSupport - Class in javax.management
提供NotificationFilter接口的实现。
NotificationFilterSupport() - Constructor for class javax.management. NotificationFilterSupport
NotificationHandler< T> - Interface in com.sun.nio.sctp
用于从SCTP堆栈中消费通知的处理程序。
NotificationListener - Interface in javax.management
应该由想要接收通知的对象来实现。
notificationReceived(UnsolicitedNotificationEvent) - Method in interface javax.naming.ldap. UnsolicitedNotificationListener
收到未经请求的通知后发出。
NotificationResult - Class in javax.management.remote
对缓冲通知的查询结果。
NotificationResult(long, long, TargetedNotification[]) - Constructor for class javax.management.remote. NotificationResult
构造通知查询结果。
notifier - Variable in class java.awt.event. InvocationEvent
在Runnable.run（）方法返回或抛出异常之后或事件处理完毕后，将立即调用其notifyAll（）方法的（可能为空）的对象。
NOTIFS_LOST - Static variable in class javax.management.remote. JMXConnectionNotification
可能丢失通知的连接的通知类型字符串。
notify() - Method in class java.lang. Object
唤醒正在等待对象监视器的单个线程。
notifyAccessibleAttributeChanged(AccessibleAttribute) - Method in class javafx.scene. Node
该方法由应用程序调用，以通知辅助技术属性的值已更改。
notifyAction - Static variable in class javax.swing. JTextField
要发送通知的操作的名称，该字段的内容已被接受。
notifyAction(Action, KeyStroke, KeyEvent, Object, int) - Static method in class javax.swing. SwingUtilities
如果 action不是 null并且接受发件人对象，则可以调用 actionPerformed （ action 。
notifyAll() - Method in class java.lang. Object
唤醒正在等待对象监视器的所有线程。
notifyCaught() - Method in interface com.sun.jdi.request. ExceptionRequest
返回所请求类型的捕获异常是否会在抛出异常时生成事件。
notifyClientWindowChange(Rectangle) - Method in interface java.awt.im.spi. InputMethod
通知客户端窗口位置或状态的这种输入方式的更改。
notifyCursorMoved() - Method in class javax.sql.rowset. BaseRowSet
通知所有注册到这个 RowSet对象的侦听器，它的光标已经移动。
notifyObservers() - Method in class java.util. Observable
已过时。
如果此对象已更改，如 hasChanged方法所示，则通知其所有观察者，然后调用 clearChanged方法来指示此对象已不再更改。
notifyObservers(Object) - Method in class java.util. Observable
已过时。
如果此对象已更改，如 hasChanged方法所示，则通知其所有观察者，然后调用 clearChanged方法来指示此对象已不再更改。
notifyPathChange(Vector<?>, TreePath) - Method in class javax.swing.tree. DefaultTreeSelectionModel
已过时。
从JDK版本1.7开始
notifyPreloader(Preloader.PreloaderNotification) - Method in class javafx.application. Application
通过应用程序生成的通知通知预加载器。
notifyRowChanged() - Method in class javax.sql.rowset. BaseRowSet
通知所有注册此 RowSet对象的监听器，其中一行已更改。
notifyRowSetChanged() - Method in class javax.sql.rowset. BaseRowSet
通知所有注册此 RowSet对象的听众，其全部内容已更改。
notifyUncaught() - Method in interface com.sun.jdi.request. ExceptionRequest
返回所请求类型的未捕获异常是否在抛出时生成事件。
NotImplementedException(String) - Constructor for exception jdk.jshell.spi. ExecutionControl.NotImplementedException
NotLinkException - Exception in java.nio.file
由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
NotLinkException(String) - Constructor for exception java.nio.file. NotLinkException
构造这个类的一个实例。
NotLinkException(String, String, String) - Constructor for exception java.nio.file. NotLinkException
构造这个类的一个实例。
NotOwnerException - Exception in java.security.acl
已过时。
这个包自java.security.Policy以来被替换为java.security.Policy和相关类。
NotOwnerException() - Constructor for exception java.security.acl. NotOwnerException
已过时。
构造一个NotOwnerException。
notSelectedTextColor - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
未选择文字的颜色。
notSelectedTitleColor - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
未选择标题的颜色。
NotSerializableException - Exception in java.io
抛出一个实例需要一个Serializable接口。
NotSerializableException() - Constructor for exception java.io. NotSerializableException
构造一个NotSerializableException对象。
NotSerializableException(String) - Constructor for exception java.io. NotSerializableException
构造带有消息字符串的NotSerializableException对象。
NotYetBoundException - Exception in java.nio.channels
尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
NotYetBoundException() - Constructor for exception java.nio.channels. NotYetBoundException
构造这个类的一个实例。
NotYetConnectedException - Exception in java.nio.channels
当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
NotYetConnectedException() - Constructor for exception java.nio.channels. NotYetConnectedException
构造这个类的一个实例。
NoType - Interface in javax.lang.model.type
在没有实际类型适合的情况下使用的伪类型。
NOVEMBER - java.time. Month
11月份的单身人士30天。
NOVEMBER - Static variable in class java.util. Calendar
Calendar.MONTH字段的价值，表示公历和朱利安日历中的第十一个月。
NOVEMBER - Static variable in class javax.xml.datatype. DatatypeConstants
一年十一个月的价值
now() - Static method in class java.time.chrono. HijrahDate
在默认时区内获得伊斯兰教Umm Al-Qura日历的当前 HijrahDate 。
now() - Static method in class java.time.chrono. JapaneseDate
从默认时区的系统时钟获取当前的 JapaneseDate 。
now() - Static method in class java.time.chrono. MinguoDate
从默认时区的系统时钟获取当前的 MinguoDate 。
now() - Static method in class java.time.chrono. ThaiBuddhistDate
从默认时区的系统时钟获取当前的 ThaiBuddhistDate 。
now() - Static method in class java.time. Instant
从系统时钟获取当前瞬间。
now() - Static method in class java.time. LocalDate
从默认时区的系统时钟获取当前日期。
now() - Static method in class java.time. LocalDateTime
从默认时区的系统时钟获取当前的日期时间。
now() - Static method in class java.time. LocalTime
从默认时区的系统时钟获取当前时间。
now() - Static method in class java.time. MonthDay
从默认时区的系统时钟获取当前月日。
now() - Static method in class java.time. OffsetDateTime
从默认时区的系统时钟获取当前的日期时间。
now() - Static method in class java.time. OffsetTime
从默认时区的系统时钟获取当前时间。
now() - Static method in class java.time. Year
从默认时区的系统时钟获取当前年份。
now() - Static method in class java.time. YearMonth
从默认时区的系统时钟获取当前的一个月。
now() - Static method in class java.time. ZonedDateTime
从默认时区的系统时钟获取当前的日期时间。
now(Clock) - Static method in class java.time.chrono. HijrahDate
从指定的时钟获取当前的 HijrahDate伊斯兰教Umm Al-Qura日历。
now(Clock) - Static method in class java.time.chrono. JapaneseDate
从指定的时钟获取当前的 JapaneseDate 。
now(Clock) - Static method in class java.time.chrono. MinguoDate
从指定的时钟获取当前的 MinguoDate 。
now(Clock) - Static method in class java.time.chrono. ThaiBuddhistDate
从指定的时钟获取当前的 ThaiBuddhistDate 。
now(Clock) - Static method in class java.time. Instant
从指定的时钟获取当前时刻。
now(Clock) - Static method in class java.time. LocalDate
从指定的时钟获取当前日期。
now(Clock) - Static method in class java.time. LocalDateTime
从指定的时钟获取当前的日期时间。
now(Clock) - Static method in class java.time. LocalTime
从指定的时钟获取当前时间。
now(Clock) - Static method in class java.time. MonthDay
从指定的时钟获取当前的月日。
now(Clock) - Static method in class java.time. OffsetDateTime
从指定的时钟获取当前的日期时间。
now(Clock) - Static method in class java.time. OffsetTime
从指定的时钟获取当前时间。
now(Clock) - Static method in class java.time. Year
从指定时钟获取当年。
now(Clock) - Static method in class java.time. YearMonth
从指定的时钟获取当前的一个月。
now(Clock) - Static method in class java.time. ZonedDateTime
从指定的时钟获取当前的日期时间。
now(ZoneId) - Static method in class java.time.chrono. HijrahDate
在指定的时区获得伊斯兰教Umm Al-Qura日历的当前 HijrahDate 。
now(ZoneId) - Static method in class java.time.chrono. JapaneseDate
从指定时区的系统时钟获取当前的 JapaneseDate 。
now(ZoneId) - Static method in class java.time.chrono. MinguoDate
从指定时区的系统时钟获取当前的 MinguoDate 。
now(ZoneId) - Static method in class java.time.chrono. ThaiBuddhistDate
从指定时区的系统时钟获取当前的 ThaiBuddhistDate 。
now(ZoneId) - Static method in class java.time. LocalDate
从指定时区的系统时钟获取当前日期。
now(ZoneId) - Static method in class java.time. LocalDateTime
从指定时区的系统时钟获取当前的日期时间。
now(ZoneId) - Static method in class java.time. LocalTime
从指定时区的系统时钟获取当前时间。
now(ZoneId) - Static method in class java.time. MonthDay
从指定时区的系统时钟获取当前的月日。
now(ZoneId) - Static method in class java.time. OffsetDateTime
从指定时区的系统时钟获取当前的日期时间。
now(ZoneId) - Static method in class java.time. OffsetTime
从指定时区的系统时钟获取当前时间。
now(ZoneId) - Static method in class java.time. Year
从指定时区的系统时钟获取当年。
now(ZoneId) - Static method in class java.time. YearMonth
从指定时区的系统时钟获取当前的一个月。
now(ZoneId) - Static method in class java.time. ZonedDateTime
从指定时区的系统时钟获取当前的日期时间。
NOWRAP - Static variable in class javax.swing.text.html. HTML.Attribute
属性“nowrap”
npoints - Variable in class java.awt. Polygon
总分数。
NS - Static variable in class javax.xml.ws.wsaddressing. W3CEndpointReference
寻址命名空间
NSDECL - Static variable in class org.xml.sax.helpers. NamespaceSupport
命名空间声明URI为常量。
NT_ANONYMOUS - Static variable in interface org.ietf.jgss. GSSName
用于表示匿名实体的名称类型。
NT_EXPORT_NAME - Static variable in interface org.ietf.jgss. GSSName
用于指示由导出方法生成的导出名称的名称类型。
NT_HOSTBASED_SERVICE - Static variable in interface org.ietf.jgss. GSSName
Oid表示基于主机的服务名称形式。
NT_MACHINE_UID_NAME - Static variable in interface org.ietf.jgss. GSSName
用于指示与本地系统上的用户对应的数字用户标识符的名称类型。
NT_STRING_UID_NAME - Static variable in interface org.ietf.jgss. GSSName
名称类型，用于指示表示本地系统上用户的数字用户标识符的数字字符串。
NT_USER_NAME - Static variable in interface org.ietf.jgss. GSSName
用于指示本地系统上的命名用户的名称类型。
NTDomainPrincipal - Class in com.sun.security.auth
该类实现了 Principal接口，并表示用户认证的Windows NT域的名称。
NTDomainPrincipal(String) - Constructor for class com.sun.security.auth. NTDomainPrincipal
创建一个具有Windows NT域名的 NTDomainPrincipal 。
NTLoginModule - Class in com.sun.security.auth.module
这个 LoginModule将用户的NT安全信息呈现为 Principal的一些数字， Principal其与 Subject相关联。
NTLoginModule() - Constructor for class com.sun.security.auth.module. NTLoginModule
NTNumericCredential - Class in com.sun.security.auth
该类抽象出一个NT安全性令牌，并提供了一种进行相同进程安全模拟的机制。
NTNumericCredential(long) - Constructor for class com.sun.security.auth. NTNumericCredential
创建一个具有整数值的 NTNumericCredential 。
NTSid - Class in com.sun.security.auth
此类实现了 Principal接口，并表示有关Windows NT用户，组或领域的信息。
NTSid(String) - Constructor for class com.sun.security.auth. NTSid
使用Windows NT SID创建一个 NTSid 。
NTSidDomainPrincipal - Class in com.sun.security.auth
该类扩展了 NTSid ，代表Windows NT用户的域SID。
NTSidDomainPrincipal(String) - Constructor for class com.sun.security.auth. NTSidDomainPrincipal
使用Windows NT SID创建一个 NTSidDomainPrincipal 。
NTSidGroupPrincipal - Class in com.sun.security.auth
此类扩展为 NTSid ，代表Windows NT用户所属的组之一。
NTSidGroupPrincipal(String) - Constructor for class com.sun.security.auth. NTSidGroupPrincipal
创建一个具有Windows NT组名称的 NTSidGroupPrincipal 。
NTSidPrimaryGroupPrincipal - Class in com.sun.security.auth
此类扩展为 NTSid ，表示Windows NT用户的主组SID。
NTSidPrimaryGroupPrincipal(String) - Constructor for class com.sun.security.auth. NTSidPrimaryGroupPrincipal
使用Windows NT组SID创建一个 NTSidPrimaryGroupPrincipal 。
NTSidUserPrincipal - Class in com.sun.security.auth
此类扩展为 NTSid ，表示Windows NT用户的SID。
NTSidUserPrincipal(String) - Constructor for class com.sun.security.auth. NTSidUserPrincipal
使用Windows NT SID创建一个 NTSidUserPrincipal 。
NTSystem - Class in com.sun.security.auth.module
此类实现检索并为当前用户提供可用的NT安全信息。
NTSystem() - Constructor for class com.sun.security.auth.module. NTSystem
实例化一个 NTSystem并加载本机库来访问底层系统信息。
NTUserPrincipal - Class in com.sun.security.auth
该类实现了 Principal接口，代表了Windows NT用户。
NTUserPrincipal(String) - Constructor for class com.sun.security.auth. NTUserPrincipal
创建一个具有Windows NT用户名的 NTUserPrincipal 。
NULL - java.sql. JDBCType
标识通用SQL值 NULL 。
NULL - javax.lang.model.type. TypeKind
空类型。
NULL - Static variable in class java.sql. Types
Java编程语言中的常量，用于标识通用SQL值 NULL 。
NULL_ATTRIBUTE_VALUE - Static variable in class javax.swing.text.html. HTML
NULL_ATTRIBUTE_VALUE用于未指定属性值的情况。
NULL_KEYWORD - Static variable in class javafx.fxml. FXMLLoader
代表'null'的值。
NULL_LITERAL - com.sun.source.tree. Tree.Kind
用于实例LiteralTree代表使用的null 。
NULL_LITERAL - jdk.nashorn.api.tree. Tree.Kind
用于实例LiteralTree代表使用的null 。
NULL_NS_URI - Static variable in class javax.xml. XMLConstants
用于表示没有命名空间的命名空间URI。
NULL_SOURCE_TARGET - Static variable in class javafx.event. Event
表示未知事件源/目标的常数。
NullCipher - Class in javax.crypto
NullCipher类是提供“身份密码”的类，不会转换纯文本。
NullCipher() - Constructor for class javax.crypto. NullCipher
创建一个NullCipher对象。
NULLORDER - Static variable in class java.text. CollationElementIterator
指示字符串结束的空白顺序由光标到达。
nullPlusNonNullIsNull() - Method in interface java.sql. DatabaseMetaData
检索此数据库是否支持 NULL和非 NULL值之间的连接值为 NULL 。
NullPointerException - Exception in java.lang
在需要对象的情况下，当应用程序尝试使用 null时抛出。
NullPointerException() - Constructor for exception java.lang. NullPointerException
构造一个 NullPointerException没有详细消息。
NullPointerException(String) - Constructor for exception java.lang. NullPointerException
构造具有指定详细消息的 NullPointerException 。
nullsAreSortedAtEnd() - Method in interface java.sql. DatabaseMetaData
检索最终是否排序 NULL值，无论排序顺序如何。
nullsAreSortedAtStart() - Method in interface java.sql. DatabaseMetaData
检索 NULL值是否在开始排序，无论排序顺序如何。
nullsAreSortedHigh() - Method in interface java.sql. DatabaseMetaData
检索 NULL值是否排序高。
nullsAreSortedLow() - Method in interface java.sql. DatabaseMetaData
检索 NULL值是否排序低。
nullsFirst(Comparator<? super T>) - Static method in interface java.util. Comparator
返回一个非常友好的比较器，认为 null小于非空值。
nullsLast(Comparator<? super T>) - Static method in interface java.util. Comparator
返回一个比较友好的比较器，认为 null大于非空值。
NullType - Interface in javax.lang.model.type
表示空类型。
NUM_COLORS - Static variable in class java.awt. SystemColor
数组中的系统颜色数。
NUM_LOCK - javafx.scene.input. KeyCode
常数为 Num Lock键。
NUM_LOCK - Static variable in class java.awt. Event
已过时。
数字锁定键，非ASCII动作键。
numBands - Variable in class java.awt.image. ComponentSampleModel
这个 ComponentSampleModel的乐队数。
numBands - Variable in class java.awt.image. Raster
光栅中的乐队数。
numBands - Variable in class java.awt.image. SampleModel
该SampleModel描述的图像数据的频带数。
numBanks - Variable in class java.awt.image. ComponentSampleModel
这个数量在这个 ComponentSampleModel 。
Number - Class in java.lang
抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
Number() - Constructor for class java.lang. Number
NUMBER - javax.xml.xpath. XPathEvaluationResult.XPathResultType
XPath 1.0号数据类型。
NUMBER - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NUMBER
NUMBER - Static variable in class javax.xml.xpath. XPathConstants
XPath 1.0号数据类型。
NUMBER_FORMS - Static variable in class java.lang. Character.UnicodeBlock
“数字形式”Unicode字符块的常量。
NUMBER_LITERAL - jdk.nashorn.api.tree. Tree.Kind
用于表示double的数字字面值的double 。
NUMBER_SIGN - javafx.scene.input. KeyCode
“＃”键的常数。
NUMBER_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是定义的数字。
NumberAxis - Class in javafx.scene.chart
一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。
NumberAxis() - Constructor for class javafx.scene.chart. NumberAxis
创建自动范围NumberAxis。
NumberAxis(double, double, double) - Constructor for class javafx.scene.chart. NumberAxis
使用给定的上限，下限和滴答单位创建非自动范围的NumberAxis。
NumberAxis(String, double, double, double) - Constructor for class javafx.scene.chart. NumberAxis
用给定的下限，上限和滴答单位创建非自动范围的NumberAxis。
NumberAxis.DefaultFormatter - Class in javafx.scene.chart
NumberAxis的默认数字格式化程序，与自动量程保持同步，并适当地格式化值。
NumberBinding - Interface in javafx.beans.binding
标记界面，用于标记所有绑定数字值的绑定。
NumberEditor(JSpinner) - Constructor for class javax.swing. JSpinner.NumberEditor
构造一个 JSpinner编辑器，支持显示和编辑一个 SpinnerNumberModel的值，带有 JFormattedTextField 。
NumberEditor(JSpinner, String) - Constructor for class javax.swing. JSpinner.NumberEditor
构造一个 JSpinner编辑器，支持显示和编辑一个 SpinnerNumberModel的值，一个 JFormattedTextField 。
numberExpression(ObservableNumberValue) - Static method in class javafx.beans.binding. NumberExpressionBase
返回一个NumberExpressionBase ，包装一个ObservableNumberValue 。
NumberExpression - Interface in javafx.beans.binding
NumberExpression是一个ObservableNumberValue加上额外的便利方法，以流利的风格生成绑定。
NumberExpressionBase - Class in javafx.beans.binding
NumberExpressionBase包含以流畅样式生成绑定的方便方法，这对于所有NumberExpression子类都是常见的。
NumberExpressionBase() - Constructor for class javafx.beans.binding. NumberExpressionBase
numberFilter(RowFilter.ComparisonType, Number, int...) - Static method in class javax.swing. RowFilter
返回一个 RowFilter ，其中包含符合指定条件的值至少有一个 Number条目。
numberFormat - Variable in class java.text. DateFormat
DateFormat用于在日期和时间格式化数字的数字格式化程序。
NumberFormat - Class in java.text
NumberFormat是所有数字格式的抽象基类。
NumberFormat() - Constructor for class java.text. NumberFormat
唯一的构造函数。
NumberFormat.Field - Class in java.text
定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
NumberFormatException - Exception in java.lang
抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
NumberFormatException() - Constructor for exception java.lang. NumberFormatException
构造一个没有详细消息的 NumberFormatException 。
NumberFormatException(String) - Constructor for exception java.lang. NumberFormatException
构造具有指定详细消息的 NumberFormatException 。
NumberFormatProvider - Class in java.text.spi
提供NumberFormat类的具体实现的服务提供者的抽象类。
NumberFormatProvider() - Constructor for class java.text.spi. NumberFormatProvider
唯一的构造函数。
NumberFormatter - Class in javax.swing.text
NumberFormatter子类 InternationalFormatter为数字添加特殊行为。
NumberFormatter() - Constructor for class javax.swing.text. NumberFormatter
创建一个 NumberFormatter具有从 NumberFormat.getNumberInstance()获取的默认 NumberFormat实例。
NumberFormatter(NumberFormat) - Constructor for class javax.swing.text. NumberFormatter
使用指定的Format实例创建NumberFormatter。
NumberOfDocuments - Class in javax.print.attribute.standard
类NumberOfDocuments是一个整数值打印属性，表示打印机已接受此作业的单个文档的数量，无论文档的打印数据是否到达打印机。
NumberOfDocuments(int) - Constructor for class javax.print.attribute.standard. NumberOfDocuments
使用给定的整数值构造新的文档数量属性。
NumberOfInterveningJobs - Class in javax.print.attribute.standard
Class NumberOfInterveningJobs是一个整数值打印属性，它以预期完成时间（即当前调度顺序）的相对时间顺序指示该作业前面的作业数。
NumberOfInterveningJobs(int) - Constructor for class javax.print.attribute.standard. NumberOfInterveningJobs
使用给定的整数值构造新数量的介入作业属性。
numberOfLeadingZeros(int) - Static method in class java.lang. Integer
返回在指定的 int值的二进制补码二进制表示中的最高位（“最左”）1位之前的零位数。
numberOfLeadingZeros(long) - Static method in class java.lang. Long
返回在指定的 long值的二进制补码二进制表示中的最高位（“最左”）1位之前的零位数。
numberOfTrailingZeros(int) - Static method in class java.lang. Integer
返回在指定的 int值的二进制补码二进制表示中的最低位（“最右”）1位之后的零位数。
numberOfTrailingZeros(long) - Static method in class java.lang. Long
返回在指定的 long值的二进制补码二进制表示中的最低位（“最右”）1位之后的零位数。
NUMBERS - javafx.scene.web. HTMLEditorSkin.Command
NUMBERS - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NUMBERS
NumberStringConverter - Class in javafx.util.converter
StringConverter实现Number值。
NumberStringConverter() - Constructor for class javafx.util.converter. NumberStringConverter
NumberStringConverter(String) - Constructor for class javafx.util.converter. NumberStringConverter
NumberStringConverter(NumberFormat) - Constructor for class javafx.util.converter. NumberStringConverter
NumberStringConverter(Locale) - Constructor for class javafx.util.converter. NumberStringConverter
NumberStringConverter(Locale, String) - Constructor for class javafx.util.converter. NumberStringConverter
NumberUp - Class in javax.print.attribute.standard
类NumberUp是一个整数值打印属性类，它指定要在所选介质的实例的单侧施加的打印流页数。
NumberUp(int) - Constructor for class javax.print.attribute.standard. NumberUp
使用给定的整数值构造一个新的加号属性。
NumberUpSupported - Class in javax.print.attribute.standard
NumberUpSupported类是一个打印属性类，一组整数，它为NumberUp属性提供支持的值。
NumberUpSupported(int) - Constructor for class javax.print.attribute.standard. NumberUpSupported
构造一个包含单个整数的新的数字支持属性。
NumberUpSupported(int[][]) - Constructor for class javax.print.attribute.standard. NumberUpSupported
使用给定的成员构造一个新的数字支持属性。
NumberUpSupported(int, int) - Constructor for class javax.print.attribute.standard. NumberUpSupported
构造一个包含单个整数范围的新的数字支持属性。
numBuffers - Variable in class java.awt. Component.FlipBufferStrategy
缓冲区的数量
numDataElements - Variable in class java.awt.image. Raster
每像素DataBuffer数据元素的数量。
NUMERIC - java.sql. JDBCType
标识通用SQL类型 NUMERIC 。
NUMERIC - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NUMERIC 。
NUMERIC_SHAPING - Static variable in class java.awt.font. TextAttribute
将ASCII十进制数字转换为其他十进制范围的属性键。
NumericShaper - Class in java.awt.font
NumericShaper类用于将Latin-1（欧洲）数字转换为其他Unicode十进制数字。
NumericShaper.Range - Enum in java.awt.font
A NumericShaper.Range表示具有其自己的十进制数字的脚本的Unicode范围。
NUMPAD0 - javafx.scene.input. KeyCode
常数为 Numpad 0键。
NUMPAD1 - javafx.scene.input. KeyCode
常数为 Numpad 1键。
NUMPAD2 - javafx.scene.input. KeyCode
常数为 Numpad 2键。
NUMPAD3 - javafx.scene.input. KeyCode
常数为 Numpad 3键。
NUMPAD4 - javafx.scene.input. KeyCode
常数为 Numpad 4键。
NUMPAD5 - javafx.scene.input. KeyCode
常数为 Numpad 5键。
NUMPAD6 - javafx.scene.input. KeyCode
常数为 Numpad 6键。
NUMPAD7 - javafx.scene.input. KeyCode
常数为 Numpad 7键。
NUMPAD8 - javafx.scene.input. KeyCode
常数为 Numpad 8键。
NUMPAD9 - javafx.scene.input. KeyCode
常数为 Numpad 9键。
numProgressivePasses - Variable in class javax.imageio. ImageReadParam
从源头读取的最大次数。
NUTOKEN - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NUTOKEN
NUTOKENS - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于NUTOKENS
nval - Variable in class java.io. StreamTokenizer
如果当前令牌是一个数字，则此字段包含该数字的值。
NVARCHAR - java.sql. JDBCType
标识通用SQL类型 NVARCHAR 。
NVARCHAR - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 NVARCHAR 。
NVList - Class in org.omg.CORBA
包含 NamedValue对象的可修改列表。
NVList() - Constructor for class org.omg.CORBA. NVList
NW_RESIZE - Static variable in class javafx.scene. Cursor
西北大小的游标类型。
NW_RESIZE_CURSOR - Static variable in class java.awt. Cursor
西北大小的游标类型。
NW_RESIZE_CURSOR - Static variable in class java.awt. Frame
已过时。
替换为Cursor.NW_RESIZE_CURSOR 。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


O-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

O

O - javafx.scene.input. KeyCode
常数为 O键。
OAEPParameterSpec - Class in javax.crypto.spec
该类指定与OAEP填充一起使用的参数集，如 PKCS #1标准中所定义。
OAEPParameterSpec(String, String, AlgorithmParameterSpec, PSource) - Constructor for class javax.crypto.spec. OAEPParameterSpec
构造为使用指定的消息摘要算法在PKCS＃1标准中定义的OAEP冗余参数集 mdName ，掩码生成函数算法 mgfName ，掩码生成函数参数 mgfSpec编码输入P的，和源 pSrc 。
OBJ_ADAPTER - Exception in org.omg.CORBA
此异常通常表示管理不匹配，例如，服务器可能尝试以已经在使用的名称或对存储库未知的实现存储库注册自身。
OBJ_ADAPTER() - Constructor for exception org.omg.CORBA. OBJ_ADAPTER
构造一个 OBJ_ADAPTER异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。
OBJ_ADAPTER(int, CompletionStatus) - Constructor for exception org.omg.CORBA. OBJ_ADAPTER
构造具有指定的次要代码和完成状态的 OBJ_ADAPTER异常。
OBJ_ADAPTER(String) - Constructor for exception org.omg.CORBA. OBJ_ADAPTER
构造一个 OBJ_ADAPTER异常，指定的描述，次要代码为0，完成状态为COMPLETED_NO。
OBJ_ADAPTER(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. OBJ_ADAPTER
构造具有指定的描述消息，次要代码和完成状态的 OBJ_ADAPTER异常。
ObjDoubleConsumer< T> - Interface in java.util.function
表示接受对象值和 double值参数的操作，并且不返回任何结果。
object - Variable in class javax.swing.undo. StateEdit
正在编辑的对象
object() - Method in interface com.sun.jdi.event. WatchpointEvent
返回字段即将被访问/修改的对象。
Object - Class in java.lang
类 Object是类层次结构的根。
Object - Interface in org.omg.CORBA
CORBA对象引用的定义。
Object() - Constructor for class java.lang. Object
构造一个新对象。
OBJECT - Static variable in class javax.swing.text.html. HTML.Tag
标签<object>
OBJECT_ADDED - Static variable in class javax.naming.event. NamingEvent
用于指示已添加新对象的命名事件类型。
OBJECT_CHANGED - Static variable in class javax.naming.event. NamingEvent
用于指示对象已更改的命名事件类型。
OBJECT_FACTORIES - Static variable in interface javax.naming. Context
用于指定要使用的对象工厂列表的环境属性的名称的常量。
object_id() - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations
返回描述操作调用目标的不透明 object_id 。
object_id(Servant) - Method in interface org.omg.PortableServer.portable. Delegate
方法_object_id（）等效于调用PortableServer :: Current :: get_object_id。
OBJECT_LITERAL - jdk.nashorn.api.tree. Tree.Kind
用于ObjectLiteralTree的实例。
OBJECT_NOT_EXIST - Exception in org.omg.CORBA
每当执行对被删除对象的调用时，就会引发异常。
OBJECT_NOT_EXIST() - Constructor for exception org.omg.CORBA. OBJECT_NOT_EXIST
构造一个 OBJECT_NOT_EXIST异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。
OBJECT_NOT_EXIST(int, CompletionStatus) - Constructor for exception org.omg.CORBA. OBJECT_NOT_EXIST
构造具有指定的次要代码和完成状态的 OBJECT_NOT_EXIST异常。
OBJECT_NOT_EXIST(String) - Constructor for exception org.omg.CORBA. OBJECT_NOT_EXIST
构造一个 OBJECT_NOT_EXIST异常，指定描述，次要代码为0，完成状态为COMPLETED_NO。
OBJECT_NOT_EXIST(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. OBJECT_NOT_EXIST
构造一个 OBJECT_NOT_EXIST异常，其中包含指定的描述消息，次要代码和完成状态。
OBJECT_REMOVED - Static variable in class javax.naming.event. NamingEvent
用于指示对象已被删除的命名事件类型。
OBJECT_RENAMED - Static variable in class javax.naming.event. NamingEvent
用于指示对象已被重命名的命名事件类型。
OBJECT_SCOPE - Static variable in class javax.naming.directory. SearchControls
搜索命名对象。
OBJECT_SCOPE - Static variable in interface javax.naming.event. EventContext
用于表示对由目标命名的对象的事件感兴趣的常数。
object_to_string(Object) - Method in class org.omg.CORBA. ORB
将给定的CORBA对象引用转换为字符串。
objectAdded(NamingEvent) - Method in interface javax.naming.event. NamespaceChangeListener
在添加对象时调用。
ObjectAlreadyActive - Exception in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / ObjectAlreadyActive.java。
ObjectAlreadyActive() - Constructor for exception org.omg.PortableServer.POAPackage. ObjectAlreadyActive
ObjectAlreadyActive(String) - Constructor for exception org.omg.PortableServer.POAPackage. ObjectAlreadyActive
ObjectAlreadyActiveHelper - Class in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / ObjectAlreadyActiveHelper.java。
ObjectAlreadyActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage. ObjectAlreadyActiveHelper
ObjectBinding< T> - Class in javafx.beans.binding
基类，提供大多数的实现所需的功能Binding的的Object 。
ObjectBinding() - Constructor for class javafx.beans.binding. ObjectBinding
objectChanged(NamingEvent) - Method in interface javax.naming.event. ObjectChangeListener
当对象被更改时调用。
ObjectChangeListener - Interface in javax.naming.event
指定 NamingEvent的侦听器的事件类型为 OBJECT_CHANGED必须实现的方法。
ObjectCollectedException - Exception in com.sun.jdi
抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。
ObjectCollectedException() - Constructor for exception com.sun.jdi. ObjectCollectedException
ObjectCollectedException(String) - Constructor for exception com.sun.jdi. ObjectCollectedException
objectExpression(ObservableObjectValue<T>) - Static method in class javafx.beans.binding. ObjectExpression
返回一个ObjectExpression ，其中包含一个ObservableObjectValue 。
ObjectExpression< T> - Class in javafx.beans.binding
ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。
ObjectExpression() - Constructor for class javafx.beans.binding. ObjectExpression
ObjectFactory - Interface in javax.naming.spi
此接口表示用于创建对象的工厂。
ObjectFactoryBuilder - Interface in javax.naming.spi
此接口表示创建对象工厂的构建器。
ObjectHelper - Class in org.omg.CORBA
ObjectHelper() - Constructor for class org.omg.CORBA. ObjectHelper
ObjectHolder - Class in org.omg.CORBA
持有人 Object 。
ObjectHolder() - Constructor for class org.omg.CORBA. ObjectHolder
构造一个新的 ObjectHolder对象，其 value字段初始化为 null 。
ObjectHolder(Object) - Constructor for class org.omg.CORBA. ObjectHolder
构造一个新的 ObjectHolder对象，其 value字段初始化为给定的 Object 。
ObjectIdHelper - Class in org.omg.PortableInterceptor
对象ID的类型。
ObjectIdHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage
对象标识，表示为字符串
ObjectIdHelper() - Constructor for class org.omg.PortableInterceptor. ObjectIdHelper
ObjectIdHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage. ObjectIdHelper
ObjectImpl - Class in org.omg.CORBA_2_3.portable
ObjectImpl类是所有存根的基类。
ObjectImpl - Class in org.omg.CORBA.portable
所有存根类的公共基类; 提供org.omg.CORBA.Object方法的默认实现。
ObjectImpl() - Constructor for class org.omg.CORBA_2_3.portable. ObjectImpl
ObjectImpl() - Constructor for class org.omg.CORBA.portable. ObjectImpl
ObjectInput - Interface in java.io
ObjectInput扩展了DataInput接口以包含对象的读取。
ObjectInputFilter - Interface in java.io
反序列化过程中过滤类，数组长度和图形指标。
ObjectInputFilter.Config - Class in java.io
一个实用程序类，用于设置和获取过程范围的过滤器或从模式字符串创建过滤器。
ObjectInputFilter.FilterInfo - Interface in java.io
FilterInfo提供对反序列化当前对象和ObjectInputStream的状态的信息的访问 。
ObjectInputFilter.Status - Enum in java.io
对类的检查状态，数组长度，引用次数，深度和流大小。
ObjectInputStream - Class in java.io
ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
ObjectInputStream() - Constructor for class java.io. ObjectInputStream
为完全重新实现ObjectInputStream的子类提供一种方法，不必分配刚刚被ObjectInputStream实现使用的私有数据。
ObjectInputStream(InputStream) - Constructor for class java.io. ObjectInputStream
创建从指定的InputStream读取的ObjectInputStream。
ObjectInputStream.GetField - Class in java.io
提供对从输入流读取的持久性字段的访问。
ObjectInputValidation - Interface in java.io
回调界面允许验证图中的对象。
ObjectInstance - Class in javax.management
用于表示MBean的对象名称及其类名。
ObjectInstance(String, String) - Constructor for class javax.management. ObjectInstance
允许创建对象实例，并提供对象名称和完整类名称（包括包名称）的字符串表示形式。
ObjectInstance(ObjectName, String) - Constructor for class javax.management. ObjectInstance
允许在给定对象名称和完整的类名称（包括包名称）的情况下创建对象实例。
ObjectLiteralTree - Interface in jdk.nashorn.api.tree
表示ECMAScript对象文字表达式。
ObjectName - Class in javax.management
表示MBean的对象名称，或可匹配多个MBean名称的模式。
ObjectName(String) - Constructor for class javax.management. ObjectName
从给定的字符串构造一个对象名称。
ObjectName(String, String, String) - Constructor for class javax.management. ObjectName
用一个key属性构造对象名。
ObjectName(String, Hashtable<String, String>) - Constructor for class javax.management. ObjectName
从Hashtable构造具有多个关键属性的对象名称。
OBJECTNAME - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 javax.management.ObjectName值的 SimpleType实例。
ObjectNotActive - Exception in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / ObjectNotActive.java。
ObjectNotActive() - Constructor for exception org.omg.PortableServer.POAPackage. ObjectNotActive
ObjectNotActive(String) - Constructor for exception org.omg.PortableServer.POAPackage. ObjectNotActive
ObjectNotActiveHelper - Class in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / ObjectNotActiveHelper.java。
ObjectNotActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage. ObjectNotActiveHelper
ObjectOutput - Interface in java.io
ObjectOutput扩展了DataOutput接口，包括写入对象。
ObjectOutputStream - Class in java.io
ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
ObjectOutputStream() - Constructor for class java.io. ObjectOutputStream
为完全重新实现ObjectOutputStream的子类提供一种方法，不必分配刚刚被ObjectOutputStream实现使用的私有数据。
ObjectOutputStream(OutputStream) - Constructor for class java.io. ObjectOutputStream
创建一个写入指定的OutputStream的ObjectOutputStream。
ObjectOutputStream.PutField - Class in java.io
提供对要写入ObjectOutput的持久字段的编程访问。
ObjectProperty< T> - Class in javafx.beans.property
这个类提供了一个包含任意Object的Property的完整实现。
ObjectProperty() - Constructor for class javafx.beans.property. ObjectProperty
ObjectPropertyBase< T> - Class in javafx.beans.property
类 ObjectPropertyBase是包含任意 Object的属性的基类。
ObjectPropertyBase() - Constructor for class javafx.beans.property. ObjectPropertyBase
ObjectPropertyBase的构造 ObjectPropertyBase 。
ObjectPropertyBase(T) - Constructor for class javafx.beans.property. ObjectPropertyBase
ObjectPropertyBase的构造 ObjectPropertyBase 。
ObjectReference - Interface in com.sun.jdi
当前存在于目标VM中的对象。
ObjectReferenceFactory - Interface in org.omg.PortableInterceptor
对象引用工厂。
ObjectReferenceFactoryHelper - Class in org.omg.PortableInterceptor
对象引用工厂。
ObjectReferenceFactoryHelper() - Constructor for class org.omg.PortableInterceptor. ObjectReferenceFactoryHelper
ObjectReferenceFactoryHolder - Class in org.omg.PortableInterceptor
对象引用工厂。
ObjectReferenceFactoryHolder() - Constructor for class org.omg.PortableInterceptor. ObjectReferenceFactoryHolder
ObjectReferenceFactoryHolder(ObjectReferenceFactory) - Constructor for class org.omg.PortableInterceptor. ObjectReferenceFactoryHolder
ObjectReferenceTemplate - Interface in org.omg.PortableInterceptor
对象引用模板。
ObjectReferenceTemplateHelper - Class in org.omg.PortableInterceptor
对象引用模板。
ObjectReferenceTemplateHelper() - Constructor for class org.omg.PortableInterceptor. ObjectReferenceTemplateHelper
ObjectReferenceTemplateHolder - Class in org.omg.PortableInterceptor
对象引用模板。
ObjectReferenceTemplateHolder() - Constructor for class org.omg.PortableInterceptor. ObjectReferenceTemplateHolder
ObjectReferenceTemplateHolder(ObjectReferenceTemplate) - Constructor for class org.omg.PortableInterceptor. ObjectReferenceTemplateHolder
ObjectReferenceTemplateSeqHelper - Class in org.omg.PortableInterceptor
对象引用模板的序列用于报告适配器管理器上不发生的状态更改。
ObjectReferenceTemplateSeqHelper() - Constructor for class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHelper
ObjectReferenceTemplateSeqHolder - Class in org.omg.PortableInterceptor
对象引用模板的序列用于报告适配器管理器上不发生的状态更改。
ObjectReferenceTemplateSeqHolder() - Constructor for class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHolder
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[]) - Constructor for class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHolder
objectRemoved(NamingEvent) - Method in interface javax.naming.event. NamespaceChangeListener
当对象被删除时调用。
objectRenamed(NamingEvent) - Method in interface javax.naming.event. NamespaceChangeListener
在对象重命名时调用。
Objects - Class in java.util
此类由 static用于在对象上操作的实用方法或在操作之前检查某些条件。
ObjectStreamClass - Class in java.io
序列化的类的描述符。
ObjectStreamConstants - Interface in java.io
写入对象序列化流的常量。
ObjectStreamException - Exception in java.io
对象流类别特有的所有异常的超类。
ObjectStreamException() - Constructor for exception java.io. ObjectStreamException
创建一个ObjectStreamException。
ObjectStreamException(String) - Constructor for exception java.io. ObjectStreamException
使用指定的参数创建一个ObjectStreamException。
ObjectStreamField - Class in java.io
Serializable类的Serializable字段的描述。
ObjectStreamField(String, Class<?>) - Constructor for class java.io. ObjectStreamField
创建一个具有指定类型的Serializable字段。
ObjectStreamField(String, Class<?>, boolean) - Constructor for class java.io. ObjectStreamField
创建一个ObjectStreamField，表示具有给定名称和类型的可序列化字段。
ObjectView - Class in javax.swing.text.html
实现<object>元素的视图接口的组件装饰器。
ObjectView(Element) - Constructor for class javax.swing.text.html. ObjectView
创建一个新的ObjectView对象。
ObjID - Class in java.rmi.server
ObjID用于标识导出到RMI运行时的远程对象。
ObjID() - Constructor for class java.rmi.server. ObjID
生成唯一的对象标识符。
ObjID(int) - Constructor for class java.rmi.server. ObjID
创建一个“众所周知”的对象标识符。
ObjIntConsumer< T> - Interface in java.util.function
表示接受对象值和 int值参数的操作，不返回任何结果。
ObjLongConsumer< T> - Interface in java.util.function
表示接受对象值和 long值参数的操作，不返回任何结果。
Observable - Class in java.util
已过时。
此类和Observer接口已被弃用。 由Observer和Observable支持的事件模型是非常有限的，由Observable发送的通知的Observable是未指定的，状态更改不与通知一一对应。 对于更丰富的事件模型，请考虑使用java.beans软件包。 对于线程之间的可靠和有序的消息传递，请考虑使用java.util.concurrent包中的并发数据结构之一。 对于反应流样式编程，请参阅Flow API。
Observable - Interface in javafx.beans
一个 Observable是一个包含内容并允许观察内容无效的实体。
Observable() - Constructor for class java.util. Observable
已过时。
用零观察者构建可观测值。
ObservableArray< T extends ObservableArray< T>> - Interface in javafx.collections
ObservableArray是一个数组，允许监听器在发生变化时跟踪变化。
ObservableArrayBase< T extends ObservableArray< T>> - Class in javafx.collections
抽象类作为ObservableArray实现的基类。
ObservableArrayBase() - Constructor for class javafx.collections. ObservableArrayBase
observableArrayList() - Static method in class javafx.collections. FXCollections
创建一个由数组列表支持的新的可观察列表。
observableArrayList(E...) - Static method in class javafx.collections. FXCollections
创建一个新的可观察数组列表， items添加了 items 。
observableArrayList(Collection<? extends E>) - Static method in class javafx.collections. FXCollections
创建一个新的可观察数组列表，并向其添加一个集合 col的内容。
observableArrayList(Callback<E, Observable[]>) - Static method in class javafx.collections. FXCollections
创建一个由arraylist支持的新的可观察列表。
ObservableBooleanValue - Interface in javafx.beans.value
一个可观察的布尔值。
ObservableDoubleValue - Interface in javafx.beans.value
一个可观察到的双重值。
ObservableFaceArray - Interface in javafx.scene.shape
ObservableFaceArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
observableFloatArray() - Static method in class javafx.collections. FXCollections
创建一个新的空可观察浮点数组。
observableFloatArray(float...) - Static method in class javafx.collections. FXCollections
创建一个新的可观察浮点数组， values设置了 values 。
observableFloatArray(ObservableFloatArray) - Static method in class javafx.collections. FXCollections
使用给定的 array的元素副本创建一个新的可观察浮点数组。
ObservableFloatArray - Interface in javafx.collections
ObservableFloatArray是一个 float[]数组，允许监听器在发生变化时跟踪它们。
ObservableFloatValue - Interface in javafx.beans.value
一个可观察的浮点值。
observableHashMap() - Static method in class javafx.collections. FXCollections
创建一个由HashMap支持的新的可观察的地图。
observableIntegerArray() - Static method in class javafx.collections. FXCollections
创建一个新的空可观察整数数组。
observableIntegerArray(int...) - Static method in class javafx.collections. FXCollections
创建一个新的可观察整数数组， values设置了 values 。
observableIntegerArray(ObservableIntegerArray) - Static method in class javafx.collections. FXCollections
使用给定的 array的元素副本创建一个新的可观察整数数组。
ObservableIntegerArray - Interface in javafx.collections
ObservableIntegerArray是一个 int[]数组，允许监听器在发生变化时跟踪它们。
ObservableIntegerValue - Interface in javafx.beans.value
一个可观察的整数值。
observableList(List<E>) - Static method in class javafx.collections. FXCollections
构造由指定列表支持的ObservableList。
observableList(List<E>, Callback<E, Observable[]>) - Static method in class javafx.collections. FXCollections
构造由指定列表支持的ObservableList。
ObservableList< E> - Interface in javafx.collections
允许侦听器发生变化的列表。
ObservableListBase< E> - Class in javafx.collections
抽象类，用作ObservableList实现的基类。
ObservableListBase() - Constructor for class javafx.collections. ObservableListBase
ObservableListValue< E> - Interface in javafx.beans.value
可以参考一个ObservableList 。
ObservableLongValue - Interface in javafx.beans.value
一个可观察的长期价值。
observableMap(Map<K, V>) - Static method in class javafx.collections. FXCollections
构造由指定地图支持的ObservableMap。
ObservableMap< K, V> - Interface in javafx.collections
一个允许观察者跟踪发生变化的地图。
ObservableMapValue< K, V> - Interface in javafx.beans.value
可以参考一个ObservableMap 。
ObservableNumberValue - Interface in javafx.beans.value
ObservableValue的所有子接口的公共接口包装一个数字。
ObservableObjectValue< T> - Interface in javafx.beans.value
一个可观察的类型 Object价值。
observableSet(E...) - Static method in class javafx.collections. FXCollections
构造一个由包含所有指定元素的HashSet支持的ObservableSet。
observableSet(Set<E>) - Static method in class javafx.collections. FXCollections
构造由指定集合支持的ObservableSet。
ObservableSet< E> - Interface in javafx.collections
一组允许观察者跟踪变化发生时的变化。
ObservableSetValue< E> - Interface in javafx.beans.value
可以参考一个ObservableSet 。
ObservableStringValue - Interface in javafx.beans.value
一个可观察的字符串值。
ObservableValue< T> - Interface in javafx.beans.value
一个 ObservableValue是一个包含值并允许观察变化值的实体。
ObservableValueBase< T> - Class in javafx.beans.value
一个方便类创建ObservableValue的实现。
ObservableValueBase() - Constructor for class javafx.beans.value. ObservableValueBase
OBSERVED_ATTRIBUTE_ERROR - Static variable in class javax.management.monitor. MonitorNotification
通知类型表示观察到的属性不包含在观察对象中。
OBSERVED_ATTRIBUTE_ERROR_NOTIFIED - Static variable in class javax.management.monitor. Monitor
表示在更改观察属性后发生通知。
OBSERVED_ATTRIBUTE_TYPE_ERROR - Static variable in class javax.management.monitor. MonitorNotification
通知类型表示观察属性的类型不正确。
OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED - Static variable in class javax.management.monitor. Monitor
表示在更改观察到的对象或观察到的属性之后发生通知。
OBSERVED_OBJECT_ERROR - Static variable in class javax.management.monitor. MonitorNotification
通知类型表示观察到的对象未在MBean服务器中注册。
OBSERVED_OBJECT_ERROR_NOTIFIED - Static variable in class javax.management.monitor. Monitor
表示在更改观察到的对象之后发生通知。
Observer - Interface in java.util
已过时。
此接口已被弃用。 有关更多信息，请参阅Observable课程。
observesDaylightTime() - Method in class java.util. SimpleTimeZone
如果这个 SimpleTimeZone遵守夏令时，则返回 true 。
observesDaylightTime() - Method in class java.util. TimeZone
如果这个 TimeZone当前处于夏令时，或者如果从将来的时间发生从标准时间到夏令时的转换，则返回 true 。
obtrudeException(Throwable) - Method in class java.util.concurrent. CompletableFuture
强制导致后续调用方法 CompletableFuture.get()和相关方法抛出给定的异常，无论是否已经完成。
obtrudeValue(T) - Method in class java.util.concurrent. CompletableFuture
强制设置或重置方法 CompletableFuture.get()及相关方法随后返回的值，无论是否已完成。
OceanTheme - Class in javax.swing.plaf.metal
默认主题为 MetalLookAndFeel 。
OceanTheme() - Constructor for class javax.swing.plaf.metal. OceanTheme
创建一个 OceanTheme的实例
OctetSeqHelper - Class in org.omg.CORBA
助手 OctetSeq 。
OctetSeqHelper() - Constructor for class org.omg.CORBA. OctetSeqHelper
OctetSeqHolder - Class in org.omg.CORBA
持有人 OctetSeq 。
OctetSeqHolder() - Constructor for class org.omg.CORBA. OctetSeqHolder
OctetSeqHolder(byte[]) - Constructor for class org.omg.CORBA. OctetSeqHolder
OctetStreamData - Class in javax.xml.crypto
包含八位字节流的 Data类型的表示。
OctetStreamData(InputStream) - Constructor for class javax.xml.crypto. OctetStreamData
创建一个新的 OctetStreamData 。
OctetStreamData(InputStream, String, String) - Constructor for class javax.xml.crypto. OctetStreamData
创建一个新的 OctetStreamData 。
OCTOBER - java.time. Month
10月份的单身人士31天。
OCTOBER - Static variable in class java.util. Calendar
价值 Calendar.MONTH字段表示今年第十个月在公历和朱利安日历。
OCTOBER - Static variable in class javax.xml.datatype. DatatypeConstants
一年的第十个月的价值
oEnd - Variable in class javax.swing.text.html.parser. Element
true如果可以省略结束标签
of() - Static method in interface java.util. List
返回包含零个元素的不可变列表。
of() - Static method in interface java.util. Map
返回一个包含零映射的不可变地图。
of() - Static method in interface java.util. Set
返回一个包含零个元素的不可变集合。
of(char) - Static method in class java.lang. Character.UnicodeBlock
返回表示包含给定字符的Unicode块的对象，如果字符不是定义块的成员，则返回 null 。
of(double) - Static method in class java.util. OptionalDouble
返回描述给定值的 OptionalDouble 。
of(double) - Static method in interface java.util.stream. DoubleStream
返回包含单个元素的序列 DoubleStream 。
of(double...) - Static method in interface java.util.stream. DoubleStream
返回其元素是指定值的顺序排序流。
of(int) - Static method in class java.lang. Character.UnicodeBlock
返回表示包含给定字符（Unicode代码点）的Unicode块的对象，如果字符不是定义块的成员，则 null 。
of(int) - Static method in enum java.lang. Character.UnicodeScript
返回表示给定字符（Unicode代码点）分配给的Unicode脚本的枚举常量。
of(int) - Static method in enum java.time.chrono. HijrahEra
从 int获取 HijrahEra的实例。
of(int) - Static method in enum java.time.chrono. IsoEra
从 int获取 IsoEra的实例。
of(int) - Static method in class java.time.chrono. JapaneseEra
从 int获取 JapaneseEra的实例。
of(int) - Static method in enum java.time.chrono. MinguoEra
从 int获取 MinguoEra的实例。
of(int) - Static method in enum java.time.chrono. ThaiBuddhistEra
从 int获取 ThaiBuddhistEra的实例。
of(int) - Static method in enum java.time. DayOfWeek
从 int获取 DayOfWeek的实例。
of(int) - Static method in enum java.time. Month
从 int获得 Month的实例。
of(int) - Static method in class java.time. Year
获得 Year的实例。
of(int) - Static method in class java.util. OptionalInt
返回描述给定值的 OptionalInt 。
of(int) - Static method in interface java.util.stream. IntStream
返回包含单个元素的序列 IntStream 。
of(int...) - Static method in interface java.util.stream. IntStream
返回其元素是指定值的顺序排序流。
of(int, int) - Static method in class java.time. LocalTime
从一小时分钟获得 LocalTime的实例。
of(int, int) - Static method in class java.time. MonthDay
获得 MonthDay的实例。
of(int, int) - Static method in class java.time. YearMonth
从一年和一个月获得 YearMonth的实例。
of(int, int, int) - Static method in class java.time.chrono. HijrahDate
从 HijrahDate年，月 - 日和日月份获得伊斯兰教 HijrahDate Al-Qura日历的 HijrahDate 。
of(int, int, int) - Static method in class java.time.chrono. JapaneseDate
获取 JapaneseDate表示日历日历系统中的日期，月份和月份字段中的日期。
of(int, int, int) - Static method in class java.time.chrono. MinguoDate
获取一个 MinguoDate代表了 MinguoDate日，月和月的月份日期。
of(int, int, int) - Static method in class java.time.chrono. ThaiBuddhistDate
获得 ThaiBuddhistDate代表泰国佛教日历系统的日期，从 ThaiBuddhistDate ，月 - 日和日 - 月的字段。
of(int, int, int) - Static method in class java.time. LocalDate
从一年，一个月和一天获得 LocalDate的实例。
of(int, int, int) - Static method in class java.time. LocalTime
从一小时，分钟和秒钟获取 LocalTime的实例。
of(int, int, int) - Static method in class java.time. Period
获得代表数年，数月和日数的 Period 。
of(int, int, int, int) - Static method in class java.time. LocalTime
从一小时，分钟，秒和纳秒获得 LocalTime的实例。
of(int, int, int, int, int) - Static method in class java.time. LocalDateTime
从年，月，日，小时和分钟获得 LocalDateTime的实例，将秒和纳秒设置为零。
of(int, int, int, int, int, int) - Static method in class java.time. LocalDateTime
从年，月，日，小时，分钟和秒获得 LocalDateTime的实例，将纳秒设置为零。
of(int, int, int, int, int, int, int) - Static method in class java.time. LocalDateTime
从年，月，日，时，分，秒，纳秒获得 LocalDateTime的实例。
of(int, int, int, int, int, int, int, ZoneId) - Static method in class java.time. ZonedDateTime
从年，月，日，时，分，秒，纳秒和时区获取 ZonedDateTime的实例。
of(int, int, int, int, int, int, int, ZoneOffset) - Static method in class java.time. OffsetDateTime
从年，月，日，小时，分钟，秒，纳秒和偏移中获取 OffsetDateTime的实例。
of(int, int, int, int, ZoneOffset) - Static method in class java.time. OffsetTime
从一小时，分钟，秒和纳秒获取 OffsetTime的实例。
of(int, Month) - Static method in class java.time. YearMonth
从一年和一个月获得 YearMonth的实例。
of(int, Month, int) - Static method in class java.time. LocalDate
从一年，一个月和一天获得 LocalDate的实例。
of(int, Month, int, int, int) - Static method in class java.time. LocalDateTime
从年，月，日，小时和分钟获得 LocalDateTime的实例，将第二和纳秒设置为零。
of(int, Month, int, int, int, int) - Static method in class java.time. LocalDateTime
从年，月，日，小时，分钟和秒获得 LocalDateTime的实例，将纳秒设置为零。
of(int, Month, int, int, int, int, int) - Static method in class java.time. LocalDateTime
从年，月，日，时，分，秒，纳秒获得 LocalDateTime的实例。
of(long) - Static method in interface java.lang. ProcessHandle
返回现有本机进程的 Optional<ProcessHandle> 。
of(long) - Static method in class java.util. OptionalLong
返回描述给定值的 OptionalLong 。
of(long) - Static method in interface java.util.stream. LongStream
返回包含单个元素的序列 LongStream 。
of(long...) - Static method in interface java.util.stream. LongStream
返回其元素是指定值的顺序排序流。
of(long, long) - Static method in class java.time.temporal. ValueRange
获得固定值范围。
of(long, long, long) - Static method in class java.time.temporal. ValueRange
获取变量值范围。
of(long, long, long, long) - Static method in class java.time.temporal. ValueRange
获得完全可变的值范围。
of(long, TemporalUnit) - Static method in class java.time. Duration
获得 Duration表示指定单位的金额。
of(E) - Static method in class java.util. EnumSet
创建一个最初包含指定元素的枚举集。
of(E) - Static method in interface java.util. List
返回一个包含一个元素的不可变列表。
of(E) - Static method in interface java.util. Set
返回一个包含一个元素的不可变集合。
of(E...) - Static method in interface java.util. List
返回包含任意数量元素的不可变列表。
of(E...) - Static method in interface java.util. Set
返回一个包含任意数量元素的不可变集合。
of(E, E) - Static method in class java.util. EnumSet
创建一个最初包含指定元素的枚举集。
of(E, E) - Static method in interface java.util. List
返回一个包含两个元素的不可变列表。
of(E, E) - Static method in interface java.util. Set
返回一个包含两个元素的不可变集合。
of(E, E...) - Static method in class java.util. EnumSet
创建一个最初包含指定元素的枚举集。
of(E, E, E) - Static method in class java.util. EnumSet
创建一个最初包含指定元素的枚举集。
of(E, E, E) - Static method in interface java.util. List
返回一个包含三个元素的不可变列表。
of(E, E, E) - Static method in interface java.util. Set
返回一个包含三个元素的不可变集合。
of(E, E, E, E) - Static method in class java.util. EnumSet
创建一个最初包含指定元素的枚举集。
of(E, E, E, E) - Static method in interface java.util. List
返回一个包含四个元素的不可变列表。
of(E, E, E, E) - Static method in interface java.util. Set
返回一个包含四个元素的不可变集合。
of(E, E, E, E, E) - Static method in class java.util. EnumSet
创建一个最初包含指定元素的枚举集。
of(E, E, E, E, E) - Static method in interface java.util. List
返回包含五个元素的不可变列表。
of(E, E, E, E, E) - Static method in interface java.util. Set
返回一个包含五个元素的不可变集合。
of(E, E, E, E, E, E) - Static method in interface java.util. List
返回包含六个元素的不可变列表。
of(E, E, E, E, E, E) - Static method in interface java.util. Set
返回一个包含六个元素的不可变集合。
of(E, E, E, E, E, E, E) - Static method in interface java.util. List
返回包含七个元素的不可变列表。
of(E, E, E, E, E, E, E) - Static method in interface java.util. Set
返回一个包含七个元素的不可变集合。
of(E, E, E, E, E, E, E, E) - Static method in interface java.util. List
返回包含八个元素的不可变列表。
of(E, E, E, E, E, E, E, E) - Static method in interface java.util. Set
返回一个包含八个元素的不可变集合。
of(E, E, E, E, E, E, E, E, E) - Static method in interface java.util. List
返回包含九个元素的不可变列表。
of(E, E, E, E, E, E, E, E, E) - Static method in interface java.util. Set
返回一个包含九个元素的不可变集合。
of(E, E, E, E, E, E, E, E, E, E) - Static method in interface java.util. List
返回一个包含十个元素的不可变列表。
of(E, E, E, E, E, E, E, E, E, E) - Static method in interface java.util. Set
返回一个包含十个元素的不可变集合。
of(String) - Static method in interface java.time.chrono. Chronology
从时间顺序ID或日历系统类型获取 Chronology的实例。
of(String) - Static method in class java.time. ZoneId
从ID获取一个 ZoneId的实例，确保该ID有效并且可以使用。
of(String) - Static method in class java.time. ZoneOffset
使用ID获取 ZoneOffset的实例。
of(String) - Static method in class javax.annotation.processing. Completions
返回值的完成和空消息
of(String, String) - Static method in class javax.annotation.processing. Completions
返回值和消息的完成。
of(String, Map<String, String>) - Static method in class java.time. ZoneId
获取 ZoneId的实例，使用其ID使用别名映射来补充标准区域ID。
of(InetSocketAddress) - Static method in class java.net. ProxySelector
返回一个ProxySelector，它为所有HTTP和HTTPS请求使用给定的代理地址。
of(Path...) - Static method in interface java.lang.module. ModuleFinder
返回通过搜索一系列目录和/或打包模块来定位文件系统上的模块的模块查找器。
of(JapaneseEra, int, int, int) - Static method in class java.time.chrono. JapaneseDate
从日期，年龄，月份和月份字段中获取 JapaneseDate表示日历日历系统中的日期。
of(DayOfWeek, int) - Static method in class java.time.temporal. WeekFields
从第一个星期几到最短的几天内获得 WeekFields的实例。
of(LocalDate, LocalTime) - Static method in class java.time. LocalDateTime
从日期和时间获取 LocalDateTime的实例。
of(LocalDate, LocalTime, ZoneId) - Static method in class java.time. ZonedDateTime
从当地的日期和时间获取 ZonedDateTime的实例。
of(LocalDate, LocalTime, ZoneOffset) - Static method in class java.time. OffsetDateTime
从日期，时间和偏移量获取 OffsetDateTime的实例。
of(LocalDateTime, ZoneId) - Static method in class java.time. ZonedDateTime
从本地日期时间获取 ZonedDateTime的实例。
of(LocalDateTime, ZoneOffset) - Static method in class java.time. OffsetDateTime
从日期时间和偏移量获取 OffsetDateTime的实例。
of(LocalDateTime, ZoneOffset, ZoneOffset) - Static method in class java.time.zone. ZoneOffsetTransition
获取定义两个偏移之间的转换的实例。
of(LocalTime, ZoneOffset) - Static method in class java.time. OffsetTime
从当地时间和偏移量获取 OffsetTime的实例。
of(Month, int) - Static method in class java.time. MonthDay
获得 MonthDay的实例。
of(Month, int, DayOfWeek, LocalTime, boolean, ZoneOffsetTransitionRule.TimeDefinition, ZoneOffset, ZoneOffset, ZoneOffset) - Static method in class java.time.zone. ZoneOffsetTransitionRule
获取定义年度规则以在两个偏移之间创建转换的实例。
of(ChronoUnit) - Static method in enum java.util.concurrent. TimeUnit
将 ChronoUnit转换为等效的 TimeUnit 。
of(ZoneOffset) - Static method in class java.time.zone. ZoneRules
获取具有固定区域规则的ZoneRules实例。
of(ZoneOffset, ZoneOffset, List<ZoneOffsetTransition>, List<ZoneOffsetTransition>, List<ZoneOffsetTransitionRule>) - Static method in class java.time.zone. ZoneRules
获取ZoneRules的实例。
of(Supplier<A>, BiConsumer<A, T>, BinaryOperator<A>, Function<A, R>, Collector.Characteristics...) - Static method in interface java.util.stream. Collector
返回一个新 Collector由给定的描述 supplier ， accumulator ， combiner ，并 finisher功能。
of(Supplier<R>, BiConsumer<R, T>, BinaryOperator<R>, Collector.Characteristics...) - Static method in interface java.util.stream. Collector
返回一个新 Collector由给定的描述 supplier ， accumulator ，并 combiner功能。
of(Locale) - Static method in class java.time.format. DecimalStyle
获取指定区域设置的DecimalStyle。
of(Locale) - Static method in class java.time.temporal. WeekFields
获得一个适合于语言环境的 WeekFields的实例。
of(K, V) - Static method in interface java.util. Map
返回包含单个映射的不可变地图。
of(K, V, K, V) - Static method in interface java.util. Map
返回包含两个映射的不可变地图。
of(K, V, K, V, K, V) - Static method in interface java.util. Map
返回包含三个映射的不可变地图。
of(K, V, K, V, K, V, K, V) - Static method in interface java.util. Map
返回包含四个映射的不可变地图。
of(K, V, K, V, K, V, K, V, K, V) - Static method in interface java.util. Map
返回一个包含五个映射的不可变地图。
of(K, V, K, V, K, V, K, V, K, V, K, V) - Static method in interface java.util. Map
返回包含六个映射的不可变地图。
of(K, V, K, V, K, V, K, V, K, V, K, V, K, V) - Static method in interface java.util. Map
返回包含七个映射的不可变地图。
of(K, V, K, V, K, V, K, V, K, V, K, V, K, V, K, V) - Static method in interface java.util. Map
返回包含八个映射的不可变地图。
of(K, V, K, V, K, V, K, V, K, V, K, V, K, V, K, V, K, V) - Static method in interface java.util. Map
返回包含九个映射的不可变地图。
of(K, V, K, V, K, V, K, V, K, V, K, V, K, V, K, V, K, V, K, V) - Static method in interface java.util. Map
返回包含十个映射的不可变地图。
of(T) - Static method in class java.util. Optional
返回一个 Optional描述给定的非 null值。
of(T) - Static method in interface java.util.stream. Stream
返回包含单个元素的序列 Stream 。
of(T...) - Static method in interface java.util.stream. Stream
返回其元素是指定值的顺序排序流。
ofCalendarField(int) - Static method in class java.text. DateFormat.Field
返回 Field常数，对应于 Calendar常数 calendarField 。
ofDateAdjuster(UnaryOperator<LocalDate>) - Static method in class java.time.temporal. TemporalAdjusters
获取一个包含日期调整器的 TemporalAdjuster 。
ofDays(int) - Static method in class java.time. Period
获得 Period代表天数。
ofDays(long) - Static method in class java.time. Duration
获得 Duration代表标准的24小时天数。
ofDefaultLocale() - Static method in class java.time.format. DecimalStyle
获取默认的 FORMAT区域设置的 DecimalStyle 。
ofEntries(Map.Entry<? extends K, ? extends V>...) - Static method in interface java.util. Map
返回包含从给定条目提取的键和值的不可变地图。
ofEpochDay(long) - Static method in class java.time. LocalDate
从纪元日数获得 LocalDate的实例。
ofEpochMilli(long) - Static method in class java.time. Instant
从1970-01-01T00：00：00Z的时期获取使用毫秒的 Instant实例。
ofEpochSecond(long) - Static method in class java.time. Instant
使用从1970-01-01T00：00：00Z的时代开始的秒数获得 Instant的实例。
ofEpochSecond(long, int, ZoneOffset) - Static method in class java.time. LocalDateTime
使用从1970-01-01T00：00：00Z的时代开始的秒数获得 LocalDateTime的实例。
ofEpochSecond(long, long) - Static method in class java.time. Instant
使用从1970-01-01T00：00：00Z的时期开始的秒数获得 Instant的实例， Instant获得秒的纳秒分数。
OFF - java.awt. Taskbar.State
停止显示进度。
OFF - java.lang. System.Logger.Level
指示所有级别都被禁用的标记。
OFF - Static variable in class java.util.logging. Level
OFF是可用于关闭日志记录的特殊级别。
offendingNode - Variable in exception javax.imageio.metadata. IIOInvalidTreeException
该 Node ，导致了解析错误，或 null 。
offer(E) - Method in class java.util. ArrayDeque
在此deque的末尾插入指定的元素。
offer(E) - Method in class java.util.concurrent. ArrayBlockingQueue
插入指定的元素在这个队列的尾部，如果有可能立即这样做不超过该队列的容量，返回 true在成功和 false如果此队列已满。
offer(E) - Method in interface java.util.concurrent. BlockingDeque
将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回 true在成功和 false ，如果当前没有空间可用。
offer(E) - Method in interface java.util.concurrent. BlockingQueue
将指定的元素插入此队列中，如果它是立即可行且不会违反容量限制，返回 true在成功和 false如果当前没有空间可用。
offer(E) - Method in class java.util.concurrent. ConcurrentLinkedDeque
在此deque的尾部插入指定的元素。
offer(E) - Method in class java.util.concurrent. ConcurrentLinkedQueue
在该队列的尾部插入指定的元素。
offer(E) - Method in class java.util.concurrent. DelayQueue
将指定的元素插入到此延迟队列中。
offer(E) - Method in class java.util.concurrent. LinkedBlockingDeque
offer(E) - Method in class java.util.concurrent. LinkedBlockingQueue
插入指定的元素在这个队列的尾部，如果有可能立即这样做不超过该队列的容量，返回 true在成功和 false如果此队列已满。
offer(E) - Method in class java.util.concurrent. LinkedTransferQueue
在该队列的尾部插入指定的元素。
offer(E) - Method in class java.util.concurrent. PriorityBlockingQueue
将指定的元素插入到此优先级队列中。
offer(E) - Method in class java.util.concurrent. SynchronousQueue
如果另一个线程正在等待接收，则将指定的元素插入到此队列中。
offer(E) - Method in interface java.util. Deque
将指定的元素插入此双端队列表示的队列中（换句话说，在此双端队列的尾部），如果它是立即可行且不会违反容量限制，返回 true在成功和 false ，如果当前没有空间可用。
offer(E) - Method in class java.util. LinkedList
将指定的元素添加为此列表的尾部（最后一个元素）。
offer(E) - Method in class java.util. PriorityQueue
将指定的元素插入到此优先级队列中。
offer(E) - Method in interface java.util. Queue
如果在不违反容量限制的情况下立即执行，则将指定的元素插入到此队列中。
offer(E, long, TimeUnit) - Method in class java.util.concurrent. ArrayBlockingQueue
在该队列的尾部插入指定的元素，等待指定的等待时间，以使空间在队列已满时变为可用。
offer(E, long, TimeUnit) - Method in interface java.util.concurrent. BlockingDeque
将指定的元素插入由此deque表示的队列中（换句话说，在该deque的尾部），等待指定的等待时间（如果需要空间可用）。
offer(E, long, TimeUnit) - Method in interface java.util.concurrent. BlockingQueue
将指定的元素插入到此队列中，等待指定的等待时间（如有必要）才能使空间变得可用。
offer(E, long, TimeUnit) - Method in class java.util.concurrent. DelayQueue
将指定的元素插入到此延迟队列中。
offer(E, long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingDeque
offer(E, long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingQueue
在该队列的尾部插入指定的元素，必要时等待指定的等待时间才能使空间变得可用。
offer(E, long, TimeUnit) - Method in class java.util.concurrent. LinkedTransferQueue
在该队列的尾部插入指定的元素。
offer(E, long, TimeUnit) - Method in class java.util.concurrent. PriorityBlockingQueue
将指定的元素插入到此优先级队列中。
offer(E, long, TimeUnit) - Method in class java.util.concurrent. SynchronousQueue
将指定的元素插入到此队列中，如果需要，等待另一个线程接收到的指定等待时间。
offer(T, long, TimeUnit, BiPredicate<Flow.Subscriber<? super T>, ? super T>) - Method in class java.util.concurrent. SubmissionPublisher
如果可能的话，通过异步调用其 onNext方法来发布给定的项目，阻止当任何订阅的资源不可用时，直到指定的超时或直到调用者线程被中断，此时给定的处理程序-null）被调用，如果返回true，则重试一次。
offer(T, BiPredicate<Flow.Subscriber<? super T>, ? super T>) - Method in class java.util.concurrent. SubmissionPublisher
如果可能，通过异步调用其 onNext方法向每个当前用户发布给定项目。
offerFirst(E) - Method in class java.util. ArrayDeque
在此deque前面插入指定的元素。
offerFirst(E) - Method in interface java.util.concurrent. BlockingDeque
插入此双端队列的前面，如果它是立即可行且不会违反容量限制，返回指定的元素 true在成功 false如果当前没有空间可用。
offerFirst(E) - Method in class java.util.concurrent. ConcurrentLinkedDeque
在此deque前面插入指定的元素。
offerFirst(E) - Method in class java.util.concurrent. LinkedBlockingDeque
offerFirst(E) - Method in interface java.util. Deque
在此deque的前面插入指定的元素，除非它会违反容量限制。
offerFirst(E) - Method in class java.util. LinkedList
在此列表的前面插入指定的元素。
offerFirst(E, long, TimeUnit) - Method in interface java.util.concurrent. BlockingDeque
在此deque的前面插入指定的元素，等待指定的等待时间（如果需要空间可用）。
offerFirst(E, long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingDeque
offerLast(E) - Method in class java.util. ArrayDeque
在此deque的末尾插入指定的元素。
offerLast(E) - Method in interface java.util.concurrent. BlockingDeque
插入此双端队列的末尾，如果它是立即可行且不会违反容量限制，返回指定的元素 true在成功 false如果当前没有空间可用。
offerLast(E) - Method in class java.util.concurrent. ConcurrentLinkedDeque
在此deque的末尾插入指定的元素。
offerLast(E) - Method in class java.util.concurrent. LinkedBlockingDeque
offerLast(E) - Method in interface java.util. Deque
在此deque的末尾插入指定的元素，除非它会违反容量限制。
offerLast(E) - Method in class java.util. LinkedList
在该列表的末尾插入指定的元素。
offerLast(E, long, TimeUnit) - Method in interface java.util.concurrent. BlockingDeque
在此deque的末尾插入指定的元素，如果需要空间可用，等待指定的等待时间。
offerLast(E, long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingDeque
offset - Variable in class java.awt.image. DataBuffer
偏移到默认（第一）银行，从中获取第一个元素。
offset - Variable in class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener
偏移
offset - Variable in class javax.swing.plaf.basic. BasicSliderUI.TrackListener
偏移
offset - Variable in class javax.swing.text. Segment
这是所需文本开始的数组中的偏移量。
offset - Variable in class javax.swing.tree. DefaultTreeCellEditor
用于编辑。
offset - Variable in exception org.omg.CORBA.portable. IndirectionException
指向流的偏移量。
offset() - Static method in class java.time.temporal. TemporalQueries
对于 ZoneOffset的查询，如果找不到， ZoneOffset返回null。
offset(Clock, Duration) - Static method in class java.time. Clock
获取一个时钟，从指定的时钟周期返回时钟，并添加指定的时间
OFFSET_AT_POINT - javafx.scene. AccessibleAttribute
返回给定位置的字符偏移量。
OFFSET_SECONDS - java.time.temporal. ChronoField
从UTC /格林威治的偏移。
offsetByCodePoints(char[], int, int, int, int) - Static method in class java.lang. Character
返回给定的 char子阵列中的索引，该子阵列与给定的 index由 codePointOffset代码点偏移。
offsetByCodePoints(int, int) - Method in class java.lang. String
返回此 String内的指数，该指数与给定的 index codePointOffset代码点。
offsetByCodePoints(int, int) - Method in class java.lang. StringBuffer
offsetByCodePoints(CharSequence, int, int) - Static method in class java.lang. Character
返回与给定的 index （ codePointOffset代码点偏移的给定char序列中的索引。
OffsetDateTime - Class in java.time
在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
offsetRequested() - Method in exception javax.swing.text. BadLocationException
返回文档中不合法的偏移量。
offsets - Variable in class java.awt.image. DataBuffer
抵销所有银行。
OffsetTime - Class in java.time
在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
offsetXProperty() - Method in class javafx.scene.effect. DisplacementMap
FloatMap中的所有x坐标偏移值在被缩放之后被移位的偏移量。
offsetXProperty() - Method in class javafx.scene.effect. DropShadow
x方向的阴影偏移量，以像素为单位。
offsetXProperty() - Method in class javafx.scene.effect. InnerShadow
x方向的阴影偏移量，以像素为单位。
offsetYProperty() - Method in class javafx.scene.effect. DisplacementMap
FloatMap中所有y坐标偏移值的偏移量在缩放 FloatMap被移位。
offsetYProperty() - Method in class javafx.scene.effect. DropShadow
y方向的阴影偏移，以像素为单位。
offsetYProperty() - Method in class javafx.scene.effect. InnerShadow
y方向的阴影偏移，以像素为单位。
ofHours(int) - Static method in class java.time. ZoneOffset
获取 ZoneOffset的实例，使用小时数的偏移量。
ofHours(long) - Static method in class java.time. Duration
获得代表多个标准时数的 Duration 。
ofHoursMinutes(int, int) - Static method in class java.time. ZoneOffset
获取 ZoneOffset的实例，以小时和分钟为 ZoneOffset使用偏移量。
ofHoursMinutesSeconds(int, int, int) - Static method in class java.time. ZoneOffset
获取 ZoneOffset的实例，使用小时，分和秒的偏移量。
ofInstant(Instant, ZoneId) - Static method in class java.time. LocalDate
从 Instant和区域ID获取 LocalDate的实例。
ofInstant(Instant, ZoneId) - Static method in class java.time. LocalDateTime
从 Instant和区域ID获取 LocalDateTime的实例。
ofInstant(Instant, ZoneId) - Static method in class java.time. LocalTime
从 Instant和区域ID获取 LocalTime的实例。
ofInstant(Instant, ZoneId) - Static method in class java.time. OffsetDateTime
从 Instant和区域ID获取 OffsetDateTime的实例。
ofInstant(Instant, ZoneId) - Static method in class java.time. OffsetTime
从 Instant和区域ID获取 OffsetTime的实例。
ofInstant(Instant, ZoneId) - Static method in class java.time. ZonedDateTime
从 Instant获取 ZonedDateTime的实例。
ofInstant(LocalDateTime, ZoneOffset, ZoneId) - Static method in class java.time. ZonedDateTime
从本地日期时间和偏移量组合形成的瞬间获取 ZonedDateTime的实例。
ofLocal(LocalDateTime, ZoneId, ZoneOffset) - Static method in class java.time. ZonedDateTime
从本地日期时间获取 ZonedDateTime的实例，如果可能，使用首选偏移量。
ofLocale(Locale) - Static method in interface java.time.chrono. Chronology
从一个地区获取一个 Chronology的实例。
ofLocalizedDate(FormatStyle) - Static method in class java.time.format. DateTimeFormatter
返回ISO年表的区域设置特定日期格式。
ofLocalizedDateTime(FormatStyle) - Static method in class java.time.format. DateTimeFormatter
返回ISO时代的区域设置特定的日期时间格式化程序。
ofLocalizedDateTime(FormatStyle, FormatStyle) - Static method in class java.time.format. DateTimeFormatter
返回ISO时代的特定日期和时间格式。
ofLocalizedTime(FormatStyle) - Static method in class java.time.format. DateTimeFormatter
返回ISO时代的区域设置特定时间格式。
ofMillis(long) - Static method in class java.time. Duration
获得 Duration表示毫秒数。
ofMinutes(long) - Static method in class java.time. Duration
获得一个 Duration代表多个标准分钟。
ofMonths(int) - Static method in class java.time. Period
获得代表数月的 Period 。
ofNanoOfDay(long) - Static method in class java.time. LocalTime
从 LocalTime值获取 LocalTime的实例。
ofNanos(long) - Static method in class java.time. Duration
获得一个 Duration代表数纳秒。
ofNullable(T) - Static method in class java.util. Optional
返回描述给定值的 Optional ，如果 null ，否则返回一个空的 Optional 。
ofNullable(T) - Static method in interface java.util.stream. Stream
返回包含单个元素的序列 Stream ，如果非空，则返回一个空的 Stream 。
ofOffset(String, ZoneOffset) - Static method in class java.time. ZoneId
获取包裹一个偏移量的 ZoneId的实例。
ofPattern(String) - Static method in class java.time.format. DateTimeFormatter
使用指定的模式创建格式化程序。
ofPattern(String, Locale) - Static method in class java.time.format. DateTimeFormatter
使用指定的模式和区域设置创建格式化程序。
ofSecondOfDay(long) - Static method in class java.time. LocalTime
从第二天的价值获得一个 LocalTime的实例。
ofSeconds(long) - Static method in class java.time. Duration
获得代表秒数的 Duration 。
ofSeconds(long, long) - Static method in class java.time. Duration
获得 Duration代表秒数和纳秒的调整。
ofStrict(LocalDateTime, ZoneOffset, ZoneId) - Static method in class java.time. ZonedDateTime
获取 ZonedDateTime的实例，严格验证本地日期时间，偏移量和区域ID的组合。
ofSystem() - Static method in interface java.lang.module. ModuleFinder
返回找到 系统模块的模块查找器。
ofTotalSeconds(int) - Static method in class java.time. ZoneOffset
获取 ZoneOffset的实例，指定总偏移量（以秒为单位）
ofWeeks(int) - Static method in class java.time. Period
获得代表数周的 Period 。
ofYearDay(int, int) - Static method in class java.time. LocalDate
从一年和一年的一年中获得 LocalDate的实例。
ofYears(int) - Static method in class java.time. Period
获得代表多年的 Period 。
OGHAM - java.lang. Character.UnicodeScript
Unicode脚本“Ogham”。
OGHAM - Static variable in class java.lang. Character.UnicodeBlock
“Ogham”Unicode字符块的常量。
Oid - Class in org.ietf.jgss
该类表示通用对象标识符（Oid）及其相关联的操作。
Oid(byte[]) - Constructor for class org.ietf.jgss. Oid
从其ASN.1 DER编码创建一个Oid对象。
Oid(InputStream) - Constructor for class org.ietf.jgss. Oid
从其ASN.1 DER编码创建一个Oid对象。
Oid(String) - Constructor for class org.ietf.jgss. Oid
从其整数组件的字符串表示形式构造一个Oid对象。
OID - Static variable in class javax.naming.ldap. ManageReferralControl
管理控制台的分配对象标识符为2.16.840.1.113730.3.4.2。
OID - Static variable in class javax.naming.ldap. PagedResultsControl
分页结果控件的分配对象标识符为1.2.840.113556.1.4.319。
OID - Static variable in class javax.naming.ldap. PagedResultsResponseControl
分页结果响应控件的分配对象标识符为1.2.840.113556.1.4.319。
OID - Static variable in class javax.naming.ldap. SortControl
服务器端排序控件的分配对象标识符为1.2.840.113556.1.4.473。
OID - Static variable in class javax.naming.ldap. SortResponseControl
服务器端排序响应控件的分配对象标识符为1.2.840.113556.1.4.474。
OID - Static variable in class javax.naming.ldap. StartTlsRequest
StartTLS扩展请求的分配对象标识符为1.3.6.1.4.1.1466.20037。
OID - Static variable in class javax.naming.ldap. StartTlsResponse
StartTLS扩展响应的分配对象标识符为1.3.6.1.4.1.1466.20037。
OK - javax.net.ssl. SSLEngineResult.Status
SSLEngine完成了操作，可以处理类似的通话。
OK - jdk.net. SocketFlow.Status
流程成功创建。
OK - Static variable in class javafx.scene.control. ButtonType
预先定义的ButtonType显示“确定”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.OK_DONE 。
OK - Static variable in class javax.security.auth.callback. ConfirmationCallback
确定选项。
OK_CANCEL_OPTION - Static variable in class javax.security.auth.callback. ConfirmationCallback
OK / CANCEL确认确认选项。
OK_CANCEL_OPTION - Static variable in class javax.swing. JOptionPane
类型用于 showConfirmDialog 。
OK_DONE - javafx.scene.control. ButtonBar.ButtonData
“ok”或“done”按钮的标签。
OK_OPTION - Static variable in class javax.swing. JOptionPane
如果选择OK，则返回值表单类方法。
okToUseGui - Variable in class java.beans.beancontext. BeanContextSupport
A boolean指示此实例现在是否可以呈现GUI。
okToUseGui() - Method in class java.beans.beancontext. BeanContextSupport
通知此实例，它现在可以呈现GUI
okToUseGui() - Method in interface java.beans. Visibility
这个方法指示bean可以使用Gui。
OL - Static variable in class javax.swing.text.html. HTML.Tag
标记<ol>
OL_CHIKI - java.awt.font. NumericShaper.Range
Ol Chiki数字的Ol Chiki系列。
OL_CHIKI - java.lang. Character.UnicodeScript
Unicode脚本“Ol_Chiki”。
OL_CHIKI - Static variable in class java.lang. Character.UnicodeBlock
“Ol Chiki”Unicode字符块的常量。
OLD_HUNGARIAN - java.lang. Character.UnicodeScript
Unicode脚本“古匈牙利”。
OLD_HUNGARIAN - Static variable in class java.lang. Character.UnicodeBlock
“古匈牙利”Unicode字符块的常数。
OLD_ITALIC - java.lang. Character.UnicodeScript
Unicode脚本“Old_Italic”。
OLD_ITALIC - Static variable in class java.lang. Character.UnicodeBlock
“旧斜体”Unicode字符块的常量。
OLD_NORTH_ARABIAN - java.lang. Character.UnicodeScript
Unicode脚本“老北阿拉伯”。
OLD_NORTH_ARABIAN - Static variable in class java.lang. Character.UnicodeBlock
常数为“旧北阿拉伯”Unicode字符块。
OLD_PERMIC - java.lang. Character.UnicodeScript
Unicode脚本“Old Permic”。
OLD_PERMIC - Static variable in class java.lang. Character.UnicodeBlock
“Old Permic”Unicode字符块的常量。
OLD_PERSIAN - java.lang. Character.UnicodeScript
Unicode脚本“Old_Persian”。
OLD_PERSIAN - Static variable in class java.lang. Character.UnicodeBlock
“老波斯”Unicode字符块的常数。
OLD_SOUTH_ARABIAN - java.lang. Character.UnicodeScript
Unicode脚本“Old_South_Arabian”。
OLD_SOUTH_ARABIAN - Static variable in class java.lang. Character.UnicodeBlock
“旧南阿拉伯”Unicode字符块的常数。
OLD_TOKEN - Static variable in exception org.ietf.jgss. GSSException
令牌的有效期已过。
OLD_TURKIC - java.lang. Character.UnicodeScript
Unicode脚本“Old_Turkic”。
OLD_TURKIC - Static variable in class java.lang. Character.UnicodeBlock
常数为“古突厥语”Unicode字符块。
oldBinding - Variable in class javax.naming.event. NamingEvent
在更改之前包含有关对象的信息。
oldBorderPainted - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
该值表示如果旧边框被绘制。
OLDLACE - Static variable in class javafx.scene.paint. Color
颜色旧花边，RGB值为＃FDF5E6
oldLeadSelectionPath - Variable in class javax.swing.event. TreeSelectionEvent
leadSelectionPath在路径更改之前，可能为null。
OLIVE - Static variable in class javafx.scene.paint. Color
颜色橄榄，RGB值为＃808000
OLIVEDRAB - Static variable in class javafx.scene.paint. Color
彩色橄榄色，RGB值为＃6B8E23
OMGVMCID - Interface in org.omg.CORBA
为OMG保留的供应商次要代码ID。
OMIT_XML_DECLARATION - Static variable in class javax.xml.transform. OutputKeys
omit-xml-declaration =“yes”| “没有”。
omitEnd() - Method in class javax.swing.text.html.parser. Element
如果结束标签可以省略，返回true。
omitStart() - Method in class javax.swing.text.html.parser. Element
如果可以省略起始标签，则返回true。
on(boolean) - Method in class java.security. DigestInputStream
打开或关闭摘要功能。
on(boolean) - Method in class java.security. DigestOutputStream
打开或关闭摘要功能。
ON - javax.swing. DropMode
应根据现有项目的索引跟踪放置位置。
ON_HIDDEN - Static variable in class javafx.scene.control. ChoiceBox
当ChoiceBox弹出窗口被隐藏时调用。
ON_HIDDEN - Static variable in class javafx.scene.control. ComboBoxBase
当ComboBox弹出/显示已被隐藏时调用。
ON_HIDDEN - Static variable in class javafx.scene.control. Menu
当此菜单的contextMenu隐藏时调用。
ON_HIDDEN - Static variable in class javafx.scene.control. MenuButton
当MenuButton弹出窗口被隐藏时调用。
ON_HIDING - Static variable in class javafx.scene.control. ChoiceBox
调用的时候ChoiceBox弹出窗口 将被隐藏。
ON_HIDING - Static variable in class javafx.scene.control. ComboBoxBase
当ComboBox弹出/显示 将被隐藏时调用。
ON_HIDING - Static variable in class javafx.scene.control. Menu
当该菜单的contextMenu 将被隐藏时调用。
ON_HIDING - Static variable in class javafx.scene.control. MenuButton
调用的时候，菜单按钮弹出 将被隐藏。
ON_OR_INSERT - javax.swing. DropMode
此模式是 ON和 INSERT的组合，指定数据可以删除现有项目或插入位置，如 INSERT所指定。
ON_OR_INSERT_COLS - javax.swing. DropMode
此模式是 ON和 INSERT_COLS的组合，指定可以将数据删除在现有项目上，或作为 INSERT_COLS指定的插入列。
ON_OR_INSERT_ROWS - javax.swing. DropMode
此模式是 ON和 INSERT_ROWS的组合，指定数据可以删除现有项目，或作为插入行，由 INSERT_ROWS指定。
ON_SHOWING - Static variable in class javafx.scene.control. ChoiceBox
在选择框之前调用，在用户单击或以其他方式与ChoiceBox进行交互之后显示弹出窗口。
ON_SHOWING - Static variable in class javafx.scene.control. ComboBoxBase
在ComboBox之前调用，在用户单击或以其他方式与ComboBox进行交互之后显示弹出/显示。
ON_SHOWING - Static variable in class javafx.scene.control. Menu
当此菜单的contextMenu 将被显示时调用。
ON_SHOWING - Static variable in class javafx.scene.control. MenuButton
在MenuButton显示弹出窗口之前，在用户单击或以其他方式与MenuButton进行交互之后调用。
ON_SHOWN - Static variable in class javafx.scene.control. ChoiceBox
在ChoiceBox显示弹出窗口后调用。
ON_SHOWN - Static variable in class javafx.scene.control. ComboBoxBase
在ComboBox显示弹出/显示后调用。
ON_SHOWN - Static variable in class javafx.scene.control. Menu
当此菜单的contextMenu显示时调用。
ON_SHOWN - Static variable in class javafx.scene.control. MenuButton
在MenuButton显示弹出窗口后调用。
onActionProperty() - Method in class javafx.scene.control. ButtonBase
按钮的动作，当按钮被触发时被调用。
onActionProperty() - Method in class javafx.scene.control. ChoiceBox
ChoiceBox操作，每当更改ChoiceBox value属性时调用。
onActionProperty() - Method in class javafx.scene.control. ComboBoxBase
ComboBox操作，当ComboBox value属性更改时调用。
onActionProperty() - Method in class javafx.scene.control. ContextMenu
当这个 ContextMenu包含的项目被激活时，回调功能被通知。
onActionProperty() - Method in class javafx.scene.control. MenuItem
每当MenuItem被触发时调用该动作。
onActionProperty() - Method in class javafx.scene.control. TextField
与此文本字段关联的操作处理程序，如果没有分配操作处理程序， null 。
onAdvance(int, int) - Method in class java.util.concurrent. Phaser
在即将进行的相位提前执行动作的可覆盖方法，并控制终止。
onAlertProperty() - Method in class javafx.scene.web. WebEngine
JavaScript alert处理程序属性。
onAutoHideProperty() - Method in class javafx.stage. PopupWindow
autoHide运行后调用。
onBinary(WebSocket, ByteBuffer, WebSocket.MessagePart) - Method in interface jdk.incubator.http. WebSocket.Listener
接收二进制消息。
onCancelledProperty() - Method in class javafx.concurrent. Service
每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
onCancelledProperty() - Method in class javafx.concurrent. Task
每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。
onChanged(ListChangeListener.Change<? extends E>) - Method in interface javafx.collections. ListChangeListener
在对ObservableList进行了更改后调用。
onChanged(ListChangeListener.Change<? extends E>) - Method in class javafx.collections. WeakListChangeListener
在对ObservableList进行了更改后调用。
onChanged(MapChangeListener.Change<? extends K, ? extends V>) - Method in interface javafx.collections. MapChangeListener
在对ObservableMap进行了更改后调用。
onChanged(MapChangeListener.Change<? extends K, ? extends V>) - Method in class javafx.collections. WeakMapChangeListener
在对ObservableMap进行了更改后调用。
onChanged(SetChangeListener.Change<? extends E>) - Method in interface javafx.collections. SetChangeListener
在对ObservableSet进行了更改后调用。
onChanged(SetChangeListener.Change<? extends E>) - Method in class javafx.collections. WeakSetChangeListener
在对ObservableSet进行了更改后调用。
onChanged(T, boolean, int, int) - Method in interface javafx.collections. ArrayChangeListener
在对ObservableArray进行了更改后调用。
onClose(Runnable) - Method in interface java.util.stream. BaseStream
返回带有附加关闭处理程序的等效流。
onClose(WebSocket, int, String) - Method in interface jdk.incubator.http. WebSocket.Listener
接收到一条关闭消息。
onClosedProperty() - Method in class javafx.scene.control. Tab
当选项卡关闭时与选项卡关联的事件处理程序。
onCloseRequestProperty() - Method in class javafx.scene.control. Dialog
当有外部请求关闭这个 Dialog 。
onCloseRequestProperty() - Method in class javafx.scene.control. Tab
当有外部请求关闭这个 Tab 。
onCloseRequestProperty() - Method in class javafx.stage. Window
当有外部请求关闭这个 Window 。
onComplete() - Method in interface java.util.concurrent. Flow.Subscriber
当已知对于还没有被错误终止的订阅不会发生额外的订户方法调用时，调用方法，之后订阅不会调用其他订阅者方法。
onCompletion(CountedCompleter<?>) - Method in class java.util.concurrent. CountedCompleter
当方法 CountedCompleter.tryComplete()被调用并且挂起的计数为零时，或当无条件方法 CountedCompleter.complete(T)被调用时执行动作。
onContextMenuRequestedProperty() - Method in class javafx.scene. Node
定义在 Node上请求上下文菜单时要调用的函数。
onContextMenuRequestedProperty() - Method in class javafx.scene. Scene
定义当这个 Scene点击（按下并释放）鼠标按钮时要调用的功能。
onDeregistration(ServiceRegistry, Class<?>) - Method in class javax.imageio.spi. IIOServiceProvider
每当Spi课程从 ServiceRegistry注销时，将会回调。
onDeregistration(ServiceRegistry, Class<?>) - Method in interface javax.imageio.spi. RegisterableService
当实现该接口的对象从给定的删除称为 category给定的 registry 。
onDragDetectedProperty() - Method in class javafx.scene. Node
定义检测到拖动手势时要调用的功能。
onDragDetectedProperty() - Method in class javafx.scene. Scene
定义检测到拖动手势时要调用的功能。
onDragDoneProperty() - Method in class javafx.scene. Node
定义当这个 Node是数据放在放置目标上之后的拖放手势源时要调用的函数。
onDragDoneProperty() - Method in class javafx.scene. Scene
定义当这个 Scene是数据放在放置目标上之后的拖放手势源时要调用的函数。
onDragDroppedProperty() - Method in class javafx.scene. Node
定义当在拖放手势时释放 Node鼠标按钮时要调用的功能。
onDragDroppedProperty() - Method in class javafx.scene. Scene
定义当在拖放手势时释放 Scene鼠标按钮时要调用的功能。
onDragEnteredProperty() - Method in class javafx.scene. Node
定义拖动手势进入 Node时要调用的功能。
onDragEnteredProperty() - Method in class javafx.scene. Scene
定义当拖动手势进入 Scene时要调用的功能。
onDragExitedProperty() - Method in class javafx.scene. Node
定义当拖动手势退出 Node时要调用的函数。
onDragExitedProperty() - Method in class javafx.scene. Scene
定义当拖动手势退出 Scene时要调用的函数。
onDragOverProperty() - Method in class javafx.scene. Node
定义当这个 Node拖动手势进度时要调用的函数。
onDragOverProperty() - Method in class javafx.scene. Scene
定义当这个 Scene拖动手势进度时要调用的函数。
ONE - Static variable in class java.math. BigDecimal
值1，标度为0。
ONE - Static variable in class java.math. BigInteger
BigInteger常数。
ONE - Static variable in class javafx.util. Duration
持续时间为1毫秒。
ONE_DAY - Static variable in class javax.management.timer. Timer
一天中的毫秒数。
ONE_HOUR - Static variable in class javax.management.timer. Timer
一小时内的毫秒数。
ONE_MINUTE - Static variable in class javax.management.timer. Timer
一分钟内的毫秒数。
ONE_PASS_BOX - javafx.scene.effect. BlurType
使用单个过滤器的单次通过来模糊阴影。
ONE_SECOND - Static variable in class javax.management.timer. Timer
一秒钟的毫秒数。
ONE_SIDED - javafx.print. PrintSides
单面打印
ONE_SIDED - Static variable in class java.awt. JobAttributes.SidesType
用于指定连续作业页面的 SidesType实例应打印在连续介质页的同一侧。
ONE_SIDED - Static variable in class javax.print.attribute.standard. Sides
将每个连续的打印流页面设置在连续的介质页面的同一侧。
ONE_TOUCH_EXPANDABLE_PROPERTY - Static variable in class javax.swing. JSplitPane
1TouchExpandable的绑定属性。
ONE_TOUCH_OFFSET - Static variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
分隔线的偏移。
ONE_TOUCH_SIZE - Static variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
基于方向的分频器的宽度或高度 BasicSplitPaneUI增加了两个。
ONE_WEEK - Static variable in class javax.management.timer. Timer
一周内的毫秒数。
onEditCancelProperty() - Method in class javafx.scene.control. ListView
当用户取消编辑单元格时，将触发此事件处理程序。
onEditCancelProperty() - Method in class javafx.scene.control. TableColumn
当用户取消编辑单元格时，将触发此事件处理程序。
onEditCancelProperty() - Method in class javafx.scene.control. TreeTableColumn
当用户取消编辑单元格时，将触发此事件处理程序。
onEditCancelProperty() - Method in class javafx.scene.control. TreeView
当用户取消编辑单元格时，将触发此事件处理程序。
onEditCommitProperty() - Method in class javafx.scene.control. ListView
当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
onEditCommitProperty() - Method in class javafx.scene.control. TableColumn
当用户成功提交编辑时，会触发此事件处理程序。
onEditCommitProperty() - Method in class javafx.scene.control. TreeTableColumn
当用户成功提交编辑时，会触发此事件处理程序。
onEditCommitProperty() - Method in class javafx.scene.control. TreeView
当用户执行应导致其编辑输入持久化的操作时，将使用此属性。
onEditStartProperty() - Method in class javafx.scene.control. ListView
当用户成功启动编辑时，会触发此事件处理程序。
onEditStartProperty() - Method in class javafx.scene.control. TableColumn
当用户成功启动编辑时，会触发此事件处理程序。
onEditStartProperty() - Method in class javafx.scene.control. TreeTableColumn
当用户成功启动编辑时，会触发此事件处理程序。
onEditStartProperty() - Method in class javafx.scene.control. TreeView
当用户成功启动编辑时，会触发此事件处理程序。
ONELEVEL_SCOPE - Static variable in class javax.naming.directory. SearchControls
搜索一级命名上下文。
ONELEVEL_SCOPE - Static variable in interface javax.naming.event. EventContext
用于表达对目标命名的上下文中关于对象的事件的兴趣的常数，不包括目标命名的上下文。
onEndOfMediaProperty() - Method in class javafx.scene.media. MediaPlayer
当播放器 currentTime达到 stopTime时调用事件处理程序。
onError(Throwable) - Method in interface java.util.concurrent. Flow.Subscriber
由发布商或订阅者遇到的不可恢复错误调用方法，之后订阅不会调用其他订阅者方法。
onError(HttpRequest, Throwable) - Method in interface jdk.incubator.http. HttpResponse.MultiProcessor
如果接收到响应发生错误，则调用。
onError(WebSocket, Throwable) - Method in interface jdk.incubator.http. WebSocket.Listener
通知发生I / O或协议错误。
onErrorProperty() - Method in class javafx.scene.media. Media
发生错误时调用事件处理程序。
onErrorProperty() - Method in class javafx.scene.media. MediaPlayer
发生错误时调用事件处理程序。
onErrorProperty() - Method in class javafx.scene.media. MediaView
当这个 MediaView出现错误时调用事件处理程序。
onErrorProperty() - Method in class javafx.scene.web. WebEngine
当发生错误时调用事件处理程序。
oneTouchExpandable - Variable in class javax.swing. JSplitPane
是否提供了一个小部件来快速展开/折叠拆分窗格？
oneTouchExpandableChanged() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider
当JSplitPane的oneTouchExpandable值接收器包含在更改中时发生消息。
Oneway - Annotation Type in javax.jws
onExceptionalCompletion(Throwable, CountedCompleter<?>) - Method in class java.util.concurrent. CountedCompleter
方法 ForkJoinTask.completeExceptionally(Throwable)被调用或方法 CountedCompleter.compute()引发异常，并且此任务尚未正常完成时执行操作。
onExit() - Method in class java.lang. Process
返回一个 CompletableFuture<Process>终止进程。
onExit() - Method in interface java.lang. ProcessHandle
返回一个 CompletableFuture<ProcessHandle>用于终止进程。
onFailedProperty() - Method in class javafx.concurrent. Service
每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
onFailedProperty() - Method in class javafx.concurrent. Task
每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。
onFinishedProperty() - Method in class javafx.animation. Animation
在 Animation的结论执行的行动。
onHaltedProperty() - Method in class javafx.scene.media. MediaPlayer
事件处理程序在状态更改为 HALTED时调用。
onHiddenProperty() - Method in class javafx.scene.control. ChoiceBox
在ChoiceBox弹出窗口之后刚刚被隐藏。
onHiddenProperty() - Method in class javafx.scene.control. ComboBoxBase
在ComboBoxBase弹出/显示已被隐藏之后调用。
onHiddenProperty() - Method in class javafx.scene.control. Dialog
Dialog已被隐藏之后调用。
onHiddenProperty() - Method in class javafx.scene.control. Menu
在ContextMenu之后刚刚被隐藏。
onHiddenProperty() - Method in class javafx.stage. Window
在窗口被隐藏之后调用。
onHidingProperty() - Method in class javafx.scene.control. ChoiceBox
在ChoiceBox弹出窗口被隐藏之前调用。
onHidingProperty() - Method in class javafx.scene.control. ComboBoxBase
在ComboBox弹出/显示被隐藏之前调用。
onHidingProperty() - Method in class javafx.scene.control. Dialog
在对话框被隐藏之前调用。
onHidingProperty() - Method in class javafx.scene.control. Menu
被称为在ContextMenu之前被隐藏。
onHidingProperty() - Method in class javafx.stage. Window
在Window被隐藏之前调用。
onInputMethodTextChangedProperty() - Method in class javafx.scene. Node
定义当 Node具有输入焦点并且输入法文本已更改时调用的函数。
onInputMethodTextChangedProperty() - Method in class javafx.scene. Scene
定义当这个 Node具有输入焦点并且输入法文本已更改时要调用的函数。
onInvalidating() - Method in class javafx.beans.binding. BooleanBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. DoubleBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. FloatBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. IntegerBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. ListBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. LongBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. MapBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. ObjectBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. SetBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onInvalidating() - Method in class javafx.beans.binding. StringBinding
如果此绑定变为无效，那么onInvalidating（）方法可以被扩展类覆盖。
onKeyPressedProperty() - Method in class javafx.scene. Node
定义当 Node或其子项 Node具有输入焦点并按下键时要调用的函数。
onKeyPressedProperty() - Method in class javafx.scene. Scene
当 Node的 Scene具有输入焦点并按下一个键时，定义要调用的功能。
onKeyReleasedProperty() - Method in class javafx.scene. Node
定义当这个 Node或其子代 Node具有输入焦点并且键被释放时要调用的函数。
onKeyReleasedProperty() - Method in class javafx.scene. Scene
定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经释放。
onKeyTypedProperty() - Method in class javafx.scene. Node
定义当此 Node或其子项 Node具有输入焦点并键入了键时要调用的函数。
onKeyTypedProperty() - Method in class javafx.scene. Scene
定义要调用的函数，当一些 Node如此 Scene具有输入焦点和重点已经输入。
ONLY_END_ENTITY - java.security.cert. PKIXRevocationChecker.Option
仅检查终端实体证书的撤销状态。
ONLY_FIRST_LEVEL - javafx.scene.control. TreeSortMode
仅排序第一级节点，而不管实际是否显示根。
onMalformedInput(CodingErrorAction) - Method in class java.nio.charset. CharsetDecoder
更改此解码器的错误格式输入错误的操作。
onMalformedInput(CodingErrorAction) - Method in class java.nio.charset. CharsetEncoder
更改编码器对格式错误输入错误的操作。
onMarkerProperty() - Method in class javafx.scene.media. MediaPlayer
当播放器 currentTime到达媒体标记时调用事件处理程序。
onMenuValidationProperty() - Method in class javafx.scene.control. MenuItem
与调用MenuItem的加速器相关联的事件处理程序。
onMouseClickedProperty() - Method in class javafx.scene. Node
定义当这个 Node点击（按下和释放）鼠标按钮时要调用的功能。
onMouseClickedProperty() - Method in class javafx.scene. Scene
定义当这个 Scene点击（按下和释放）鼠标按钮时要调用的功能。
onMouseDragEnteredProperty() - Method in class javafx.scene. Node
定义当全按压拖动手势进入 Node时要调用的功能。
onMouseDragEnteredProperty() - Method in class javafx.scene. Scene
定义当全按压拖动手势进入这个 Scene时要调用的功能。
onMouseDragExitedProperty() - Method in class javafx.scene. Node
定义当完全按下 - 拖动释放手势离开这个 Node时要调用的功能。
onMouseDragExitedProperty() - Method in class javafx.scene. Scene
定义当完全按下 - 拖动释放手势退出 Scene时要调用的功能。
onMouseDraggedProperty() - Method in class javafx.scene. Node
定义当在此 Node上按下鼠标按钮然后拖动时要调用的功能。
onMouseDraggedProperty() - Method in class javafx.scene. Scene
定义当在此 Scene上按下鼠标按钮然后拖动时要调用的功能。
onMouseDragOverProperty() - Method in class javafx.scene. Node
定义当这个 Node完全按下 - 拖动释放手势进行时要调用的功能。
onMouseDragOverProperty() - Method in class javafx.scene. Scene
定义当这个 Scene完全按下 - 拖动释放手势时进行调用的功能。
onMouseDragReleasedProperty() - Method in class javafx.scene. Node
定义当完全按下 - 拖动释放手势结束（通过释放鼠标按钮）在此 Node内时 Node 。
onMouseDragReleasedProperty() - Method in class javafx.scene. Scene
定义当完全按下 - 拖动释放手势在此 Scene内结束时调用的功能。
onMouseEnteredProperty() - Method in class javafx.scene. Node
定义当鼠标进入 Node时要调用的功能。
onMouseEnteredProperty() - Method in class javafx.scene. Scene
定义当鼠标进入 Scene时要调用的功能。
onMouseExitedProperty() - Method in class javafx.scene. Node
定义当鼠标退出 Node时调用的函数。
onMouseExitedProperty() - Method in class javafx.scene. Scene
定义当鼠标退出 Scene时要调用的函数。
onMouseMovedProperty() - Method in class javafx.scene. Node
定义当这个 Node鼠标光标移动时调用的功能，但没有按钮被按下。
onMouseMovedProperty() - Method in class javafx.scene. Scene
定义当这个 Scene鼠标光标移动时调用的功能，但没有按钮被按下。
onMousePressedProperty() - Method in class javafx.scene. Node
定义当这个 Node上按下鼠标按钮时要调用的功能。
onMousePressedProperty() - Method in class javafx.scene. Scene
定义在 Scene上按下鼠标按钮时要调用的功能。
onMouseReleasedProperty() - Method in class javafx.scene. Node
定义当这个 Node释放鼠标按钮时要调用的函数。
onMouseReleasedProperty() - Method in class javafx.scene. Scene
定义当这个 Scene已经释放鼠标按钮时要调用的函数。
onNext(T) - Method in interface java.util.concurrent. Flow.Subscriber
使用订阅的下一个项目调用的方法。
onOpen(WebSocket) - Method in interface jdk.incubator.http. WebSocket.Listener
通知 Listener它连接到提供的 WebSocket 。
onPausedProperty() - Method in class javafx.scene.media. MediaPlayer
当状态更改为 PAUSED时调用事件处理程序。
onPing(WebSocket, ByteBuffer) - Method in interface jdk.incubator.http. WebSocket.Listener
接收Ping消息。
onPlayingProperty() - Method in class javafx.scene.media. MediaPlayer
事件处理程序在状态更改为 PLAYING时调用。
onPong(WebSocket, ByteBuffer) - Method in interface jdk.incubator.http. WebSocket.Listener
收到乒乓消息。
onReadyProperty() - Method in class javafx.concurrent. Service
每当任务状态转换到READY状态时，都会调用onReady事件处理程序。
onReadyProperty() - Method in class javafx.scene.media. MediaPlayer
事件处理程序在状态更改为 READY时调用。
onRegistration(ServiceRegistry, Class<?>) - Method in class javax.imageio.spi. IIOServiceProvider
在Spi类已被实例化并在 ServiceRegistry注册后，将被调用一次的 ServiceRegistry 。
onRegistration(ServiceRegistry, Class<?>) - Method in interface javax.imageio.spi. RegisterableService
当将实现此接口的对象添加到给定的 category的给定 registry 。
onRepeatProperty() - Method in class javafx.scene.media. MediaPlayer
当玩家的事件处理函数调用 currentTime达到 stopTime ， 将被重复。
onRequest(HttpRequest) - Method in interface jdk.incubator.http. HttpResponse.MultiProcessor
被称为主要请求和每个推送承诺。
onResizedProperty() - Method in class javafx.scene.web. WebEngine
JavaScript窗口调整大小处理程序属性。
onResponse(HttpResponse<T>) - Method in interface jdk.incubator.http. HttpResponse.MultiProcessor
呼叫收到的每个响应。
onRotateProperty() - Method in class javafx.scene. Node
定义当用户执行旋转操作时要调用的函数。
onRotateProperty() - Method in class javafx.scene. Scene
定义当用户执行旋转操作时要调用的函数。
onRotationFinishedProperty() - Method in class javafx.scene. Node
定义旋转手势结束时要调用的功能。
onRotationFinishedProperty() - Method in class javafx.scene. Scene
定义当旋转手势结束时要调用的功能。
onRotationStartedProperty() - Method in class javafx.scene. Node
定义检测到旋转手势时要调用的功能。
onRotationStartedProperty() - Method in class javafx.scene. Scene
定义检测到旋转手势时要调用的功能。
onRunningProperty() - Method in class javafx.concurrent. Service
每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
onRunningProperty() - Method in class javafx.concurrent. Task
每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。
onScheduledProperty() - Method in class javafx.concurrent. Service
每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
onScheduledProperty() - Method in class javafx.concurrent. Task
每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。
onScrollFinishedProperty() - Method in class javafx.scene. Node
定义当滚动手势结束时要调用的函数。
onScrollFinishedProperty() - Method in class javafx.scene. Scene
定义当滚动手势结束时要调用的函数。
onScrollProperty() - Method in class javafx.scene. Node
定义当用户执行滚动操作时要调用的函数。
onScrollProperty() - Method in class javafx.scene. Scene
定义当用户执行滚动操作时要调用的函数。
onScrollStartedProperty() - Method in class javafx.scene. Node
定义检测到滚动手势时要调用的函数。
onScrollStartedProperty() - Method in class javafx.scene. Scene
定义检测到滚动手势时要调用的函数。
onScrollToColumnProperty() - Method in class javafx.scene.control. TableView
当有请求使用 TableView.scrollToColumn(TableColumn)或 TableView.scrollToColumnIndex(int)将列滚动到视图时 调用
onScrollToColumnProperty() - Method in class javafx.scene.control. TreeTableView
当有请求使用 TreeTableView.scrollToColumn(TreeTableColumn)或 TreeTableView.scrollToColumnIndex(int)将列滚动到视图时 调用
onScrollToProperty() - Method in class javafx.scene.control. ListView
当有请求使用 ListView.scrollTo(int)或 ListView.scrollTo(Object)将索引滚动到视图时 调用
onScrollToProperty() - Method in class javafx.scene.control. TableView
当有请求使用 TableView.scrollTo(int)或 TableView.scrollTo(Object)将索引滚动到视图时 调用
onScrollToProperty() - Method in class javafx.scene.control. TreeTableView
当有请求使用 TreeTableView.scrollTo(int)将索引滚动到视图时 调用
onScrollToProperty() - Method in class javafx.scene.control. TreeView
当有请求使用 TreeView.scrollTo(int)将索引滚动到视图时 调用
onSelectionChangedProperty() - Method in class javafx.scene.control. Tab
与选项卡上的选择相关联的事件处理程序。
onShowingProperty() - Method in class javafx.scene.control. ChoiceBox
在 ChoiceBox弹出窗口之前调用。
onShowingProperty() - Method in class javafx.scene.control. ComboBoxBase
在刚刚显示的 ComboBoxBase弹出窗口之前调用。
onShowingProperty() - Method in class javafx.scene.control. Dialog
在对话框显示之前调用。
onShowingProperty() - Method in class javafx.scene.control. Menu
ContextMenu显示 ContextMenu之前即使菜单没有显示项目。
onShowingProperty() - Method in class javafx.stage. Window
在窗口显示之前调用。
onShownProperty() - Method in class javafx.scene.control. ChoiceBox
在ChoiceBox弹出窗口之后调用。
onShownProperty() - Method in class javafx.scene.control. ComboBoxBase
在ComboBoxBase弹出/显示后显示。
onShownProperty() - Method in class javafx.scene.control. Dialog
在对话框显示之后调用。
onShownProperty() - Method in class javafx.scene.control. Menu
在ContextMenu之后就显示。
onShownProperty() - Method in class javafx.stage. Window
在窗口显示之后调用。
onShutdown(Consumer<JShell>) - Method in class jdk.jshell. JShell
当JShell实例终止时，注册要调用的回调。
onSnippetEvent(Consumer<SnippetEvent>) - Method in class jdk.jshell. JShell
当代码段的状态更改时，注册要调用的回调。
onSortProperty() - Method in class javafx.scene.control. TableView
当有请求排序控件时调用。
onSortProperty() - Method in class javafx.scene.control. TreeTableView
当有请求排序控件时调用。
onSpinWait() - Static method in class java.lang. Thread
表示呼叫方暂时无法进行，直到发生其他活动的一个或多个动作。
onStalledProperty() - Method in class javafx.scene.media. MediaPlayer
当状态更改为 STALLED时调用事件处理程序。
onStart() - Method in class java.util.concurrent. ForkJoinWorkerThread
在施工后初始化内部状态，但在处理任何任务之前。
onStatusChangedProperty() - Method in class javafx.scene.web. WebEngine
JavaScript状态处理程序属性。
onStoppedProperty() - Method in class javafx.scene.media. MediaPlayer
事件处理程序在状态更改为 STOPPED时调用。
onSubscribe(Flow.Subscription) - Method in interface java.util.concurrent. Flow.Subscriber
在调用给定订阅的任何其他订阅者方法之前调用的方法。
onSucceededProperty() - Method in class javafx.concurrent. Service
每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
onSucceededProperty() - Method in class javafx.concurrent. Task
每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。
onSwipeDownProperty() - Method in class javafx.scene. Node
定义当在该节点上居中的向下滑动手势发生时要调用的功能。
onSwipeDownProperty() - Method in class javafx.scene. Scene
定义当在此场景中发生向下滑动手势时要调用的功能。
onSwipeLeftProperty() - Method in class javafx.scene. Node
定义当以该节点为中心的向左滑动手势发生时要调用的功能。
onSwipeLeftProperty() - Method in class javafx.scene. Scene
定义当在此场景中发生向左滑动手势时要调用的功能。
onSwipeRightProperty() - Method in class javafx.scene. Node
定义当以该节点为中心的向右滑动手势发生时要调用的功能。
onSwipeRightProperty() - Method in class javafx.scene. Scene
定义当在此场景中发生向右滑动手势时要调用的功能。
onSwipeUpProperty() - Method in class javafx.scene. Node
定义当在该节点上居中的向上滑动手势发生时要调用的功能。
onSwipeUpProperty() - Method in class javafx.scene. Scene
定义当在此场景中发生向上滑动手势时要调用的功能。
onTermination(Throwable) - Method in class java.util.concurrent. ForkJoinWorkerThread
执行与该工作线程的终止相关联的清除。
onText(WebSocket, CharSequence, WebSocket.MessagePart) - Method in interface jdk.incubator.http. WebSocket.Listener
接收短信。
onTouchMovedProperty() - Method in class javafx.scene. Node
定义当触摸点移动时要调用的函数。
onTouchMovedProperty() - Method in class javafx.scene. Scene
定义当触摸点移动时要调用的函数。
onTouchPressedProperty() - Method in class javafx.scene. Node
定义当按下新的触摸点时要调用的功能。
onTouchPressedProperty() - Method in class javafx.scene. Scene
定义当按下新的触摸点时要调用的功能。
onTouchReleasedProperty() - Method in class javafx.scene. Node
定义触发点释放时要调用的功能。
onTouchReleasedProperty() - Method in class javafx.scene. Scene
定义当按下新的触摸点时要调用的功能。
onTouchStationaryProperty() - Method in class javafx.scene. Node
定义当触摸点保持按下并静止时要调用的功能。
onTouchStationaryProperty() - Method in class javafx.scene. Scene
定义当触摸点保持按下并静止时要调用的功能。
onTransformChangedProperty() - Method in class javafx.scene.transform. Transform
只要变换改变其任何参数，就调用onTransformChanged事件处理程序。
onUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset. CharsetDecoder
更改此解码器的操作为不可映射的字符错误。
onUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset. CharsetEncoder
更改此编码器对不可映射字符错误的操作。
onVisibilityChangedProperty() - Method in class javafx.scene.web. WebEngine
JavaScript窗口可见性处理器属性。
onZoomFinishedProperty() - Method in class javafx.scene. Node
定义当缩放手势结束时要调用的功能。
onZoomFinishedProperty() - Method in class javafx.scene. Scene
定义当缩放手势结束时要调用的功能。
onZoomProperty() - Method in class javafx.scene. Node
定义当用户执行缩放操作时要调用的函数。
onZoomProperty() - Method in class javafx.scene. Scene
定义当用户执行缩放操作时要调用的函数。
onZoomStartedProperty() - Method in class javafx.scene. Node
定义检测到缩放手势时要调用的功能。
onZoomStartedProperty() - Method in class javafx.scene. Scene
定义检测到缩放手势时要调用的功能。
OP_ACCEPT - Static variable in class java.nio.channels. SelectionKey
操作集位用于插座接受操作。
OP_CONNECT - Static variable in class java.nio.channels. SelectionKey
用于套接字连接操作的操作集位。
op_name() - Method in class org.omg.CORBA. ServerRequest
已过时。
使用操作（）
OP_READ - Static variable in class java.nio.channels. SelectionKey
读操作的操作位。
OP_WRITE - Static variable in class java.nio.channels. SelectionKey
写操作的操作位。
opacityProperty() - Method in class javafx.scene.effect. Blend
不透明度值，它在混合前用顶部输入进行调制。
opacityProperty() - Method in class javafx.scene. Node
指定 Node出现的不透明（即固体）。
opacityProperty() - Method in class javafx.stage. Window
将 Window的不透明度定义为0.0和1.0之间的值。
OPAQUE - Static variable in interface java.awt. Transparency
表示保证完全不透明的图像数据，意味着所有像素的alpha值为1.0。
OPAQUE - Static variable in class javax.accessibility. AccessibleState
表示此对象绘制其矩形区域内的每个像素。
opaqueInsetsProperty() - Method in class javafx.scene.layout. Region
定义绘制完全不透明像素的区域的面积。
OPC_LIFE_OVER - Static variable in class javax.print.attribute.standard. PrinterStateReason
光导体不再起作用。
OPC_NEAR_EOL - Static variable in class javax.print.attribute.standard. PrinterStateReason
光学光导体接近寿命。
open() - Static method in class com.sun.nio.sctp. SctpChannel
打开SCTP通道。
open() - Static method in class com.sun.nio.sctp. SctpMultiChannel
打开SCTP多通道。
open() - Static method in class com.sun.nio.sctp. SctpServerChannel
打开SCTP服务器通道。
open() - Method in class java.lang.module. ModuleReference
打开模块内容进行阅读。
open() - Static method in class java.nio.channels. AsynchronousServerSocketChannel
打开异步服务器套接字通道。
open() - Static method in class java.nio.channels. AsynchronousSocketChannel
打开异步套接字通道。
open() - Static method in class java.nio.channels. DatagramChannel
打开数据报通道。
open() - Static method in class java.nio.channels. Pipe
打开管道。
open() - Static method in class java.nio.channels. Selector
打开选择器。
open() - Static method in class java.nio.channels. ServerSocketChannel
打开服务器插槽通道。
open() - Static method in class java.nio.channels. SocketChannel
打开套接字通道。
open() - Method in interface javax.sound.midi. MidiDevice
打开设备，表明它现在应该获得所需的任何系统资源并可以运行。
open() - Method in interface javax.sound.sampled. Line
打开该行，表明它应该获取任何所需的系统资源并运行。
open() - Method in interface org.w3c.dom.html. HTMLDocument
注意。
open(File) - Method in class java.awt. Desktop
启动相关应用程序以打开文件。
open(String) - Method in interface java.lang.module. ModuleReader
打开资源，返回输入流以读取模块中的资源。
open(ProtocolFamily) - Static method in class java.nio.channels. DatagramChannel
打开数据报通道。
open(SocketAddress) - Static method in class java.nio.channels. SocketChannel
打开套接字通道并将其连接到远程地址。
open(SocketAddress, int, int) - Static method in class com.sun.nio.sctp. SctpChannel
打开SCTP通道并将其连接到远程地址。
open(AsynchronousChannelGroup) - Static method in class java.nio.channels. AsynchronousServerSocketChannel
打开异步服务器套接字通道。
open(AsynchronousChannelGroup) - Static method in class java.nio.channels. AsynchronousSocketChannel
打开异步套接字通道。
open(Path, OpenOption...) - Static method in class java.nio.channels. AsynchronousFileChannel
打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
open(Path, OpenOption...) - Static method in class java.nio.channels. FileChannel
打开或创建文件，返回文件通道以访问该文件。
open(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Static method in class java.nio.channels. FileChannel
打开或创建文件，返回文件通道以访问该文件。
open(Path, Set<? extends OpenOption>, ExecutorService, FileAttribute<?>...) - Static method in class java.nio.channels. AsynchronousFileChannel
打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
open(AudioFormat) - Method in interface javax.sound.sampled. SourceDataLine
以指定的格式打开行，使该行获取任何所需的系统资源，并可以运行。
open(AudioFormat) - Method in interface javax.sound.sampled. TargetDataLine
以指定的格式打开行，使该行获取任何所需的系统资源，并可以运行。
open(AudioFormat, byte[], int, int) - Method in interface javax.sound.sampled. Clip
打开剪辑，这意味着它应该获取任何所需的系统资源并可以运行。
open(AudioFormat, int) - Method in interface javax.sound.sampled. SourceDataLine
以指定的格式和建议的缓冲区大小打开行，使该行获取任何所需的系统资源并变为可操作。
open(AudioFormat, int) - Method in interface javax.sound.sampled. TargetDataLine
打开具有指定格式和请求的缓冲区大小的行，使该行获取任何所需的系统资源并变为可操作。
open(AudioInputStream) - Method in interface javax.sound.sampled. Clip
以提供的音频输入流中存在的格式和音频数据打开剪辑。
OPEN - com.sun.source.tree. ModuleTree.ModuleKind
开模块
OPEN - java.awt. Desktop.Action
代表“开放”行动。
OPEN - java.lang.module. ModuleDescriptor.Modifier
一个开放模块。
OPEN - javafx.scene.shape. ArcType
用于开弧的闭合类型，没有连接弧段两端的路段。
OPEN - Static variable in class java.awt.geom. Arc2D
用于开弧的闭合类型，没有连接弧段两端的路段。
OPEN - Static variable in class javax.sound.sampled. LineEvent.Type
在线路打开时发送的事件类型，为其自身保留系统资源。
OPEN_BRACKET - javafx.scene.input. KeyCode
常数为打开括号的键，“[”
OPEN_DELETE - Static variable in class java.util.zip. ZipFile
模式标志打开一个zip文件并标记为删除。
OPEN_DIALOG - Static variable in class javax.swing. JFileChooser
键入值表示 JFileChooser支持“打开”文件操作。
OPEN_FAILURE - Static variable in class java.util.logging. ErrorManager
当输出流的打开失败时使用OPEN_FAILURE。
OPEN_HAND - Static variable in class javafx.scene. Cursor
用手打开的光标
OPEN_READ - Static variable in class java.util.zip. ZipFile
模式标志打开一个zip文件进行阅读。
OPEN_TYPE_FIELD - Static variable in class javax.management. JMX
名称为 openType字段。
OpenAction() - Constructor for class javax.swing.plaf.basic. BasicDesktopPaneUI.OpenAction
openAsynchronousChannelGroup(int, ThreadFactory) - Method in class java.nio.channels.spi. AsynchronousChannelProvider
构造一个具有固定线程池的新的异步通道组。
openAsynchronousChannelGroup(ExecutorService, int) - Method in class java.nio.channels.spi. AsynchronousChannelProvider
使用给定的线程池构造新的异步通道组。
openAsynchronousServerSocketChannel(AsynchronousChannelGroup) - Method in class java.nio.channels.spi. AsynchronousChannelProvider
打开异步服务器套接字通道。
openAsynchronousSocketChannel(AsynchronousChannelGroup) - Method in class java.nio.channels.spi. AsynchronousChannelProvider
打开异步套接字通道。
openButtonMnemonic - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
打开按钮助记符
openButtonText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
打开按钮文本
openButtonToolTipText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
打开按钮工具提示文本
openConnection() - Method in class java.net. URL
返回一个URLConnection实例表示由所引用的远程对象的连接URL 。
openConnection(Proxy) - Method in class java.net. URL
与URL.openConnection()相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
openConnection(URL) - Method in class java.net. URLStreamHandler
打开与 URL参数引用的对象的连接。
openConnection(URL, Proxy) - Method in class java.net. URLStreamHandler
与openConnection（URL）相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
OpenDataException - Exception in javax.management.openmbean
当 打开类型 ， 打开数据或 打开的MBean元数据信息实例无法构造时，抛出此检查的异常，因为一个或多个有效性约束不被满足。
OpenDataException() - Constructor for exception javax.management.openmbean. OpenDataException
没有详细信息的OpenDataException。
OpenDataException(String) - Constructor for exception javax.management.openmbean. OpenDataException
具有详细消息的OpenDataException。
openDatagramChannel() - Method in class java.nio.channels.spi. SelectorProvider
打开数据报通道。
openDatagramChannel(ProtocolFamily) - Method in class java.nio.channels.spi. SelectorProvider
打开数据报通道。
OPENED - Static variable in class javax.management.remote. JMXConnectionNotification
连接打开通知的通知类型字符串。
openFile(File) - Method in interface javax.jnlp. ExtendedService
允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
openFileDialog(String, String[]) - Method in interface javax.jnlp. FileOpenService
要求用户选择一个文件。
openFiles(OpenFilesEvent) - Method in interface java.awt.desktop. OpenFilesHandler
当应用程序被要求打开文件列表时调用。
openFiles(File[]) - Method in interface javax.jnlp. ExtendedService
允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
OpenFilesEvent - Class in java.awt.desktop
当应用程序被要求打开文件列表时发送事件。
OpenFilesEvent(List<File>, String) - Constructor for class java.awt.desktop. OpenFilesEvent
构造一个 OpenFilesEvent
OpenFilesHandler - Interface in java.awt.desktop
当应用程序被要求打开文件列表时，通知实施者。
openFrame(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
通常这种方法不会被调用。
openFrame(JInternalFrame) - Method in interface javax.swing. DesktopManager
如果可能，请将此框架显示在适当的位置。
openHelpViewer() - Method in class java.awt. Desktop
打开本机帮助查看器应用程序。
openIcon - Variable in class javax.swing.tree. DefaultTreeCellRenderer
用于显示展开的非叶节点的图标。
openInputStream() - Method in interface javax.tools. FileObject
返回此文件对象的InputStream。
openInputStream() - Method in class javax.tools. ForwardingFileObject
openInputStream() - Method in class javax.tools. SimpleJavaFileObject
这个实现总是抛出UnsupportedOperationException 。
openLogicalChannel() - Method in class javax.smartcardio. Card
打开一个新的逻辑通道卡并返回。
OpenMBeanAttributeInfo - Interface in javax.management.openmbean
描述一个打开的MBean的属性。
OpenMBeanAttributeInfoSupport - Class in javax.management.openmbean
描述一个打开的MBean的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean) - Constructor for class javax.management.openmbean. OpenMBeanAttributeInfoSupport
构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放MBean的与指定的属性 name ， openType和 description ，以及指定的读/写访问属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean, Descriptor) - Constructor for class javax.management.openmbean. OpenMBeanAttributeInfoSupport
构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放的MBean具有指定的属性 name ， openType ， description ，读/写访问属性，和 Descriptor 。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T) - Constructor for class javax.management.openmbean. OpenMBeanAttributeInfoSupport
构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放MBean的属性具有指定 name ， openType ， description和 defaultValue ，以及指定的读/写访问属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, Comparable<T>, Comparable<T>) - Constructor for class javax.management.openmbean. OpenMBeanAttributeInfoSupport
构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放MBean的属性，与指定 name ， openType ， description ， defaultValue ， minValue和 maxValue 。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, T[]) - Constructor for class javax.management.openmbean. OpenMBeanAttributeInfoSupport
构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放的MBean具有指定的属性 name ， openType ， description ， defaultValue和 legalValues ，以及指定的读/写访问属性。
OpenMBeanConstructorInfo - Interface in javax.management.openmbean
描述一个开放MBean的构造函数。
OpenMBeanConstructorInfoSupport - Class in javax.management.openmbean
描述一个开放MBean的构造函数。
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[]) - Constructor for class javax.management.openmbean. OpenMBeanConstructorInfoSupport
构造一个 OpenMBeanConstructorInfoSupport实例，该实例描述open MBean类的构造函数与指定 name ， description和 signature 。
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[], Descriptor) - Constructor for class javax.management.openmbean. OpenMBeanConstructorInfoSupport
构造一个 OpenMBeanConstructorInfoSupport实例，该实例描述open MBean类与指定的构造 name ， description ， signature ，并 descriptor 。
OpenMBeanInfo - Interface in javax.management.openmbean
描述一个开放的MBean：如果一个开放的MBean的getMBeanInfo()方法返回一个实现OpenMBeanInfo接口的类的实例，通常是OpenMBeanInfoSupport ，那么它将被识别 。
OpenMBeanInfoSupport - Class in javax.management.openmbean
OpenMBeanInfoSupport类描述了一个开放的MBean的管理信息：它是一个MBeanInfo的子类，它实现了OpenMBeanInfo接口。
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[]) - Constructor for class javax.management.openmbean. OpenMBeanInfoSupport
构造一个 OpenMBeanInfoSupport实例，其描述了open MBean类具有指定的 className ， description ， openAttributes ， openConstructors ， openOperations和 notifications 。
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - Constructor for class javax.management.openmbean. OpenMBeanInfoSupport
构造一个 OpenMBeanInfoSupport实例，其描述了open MBean类具有指定的 className ， description ， openAttributes ， openConstructors ， openOperations ， notifications ，和 descriptor 。
OpenMBeanOperationInfo - Interface in javax.management.openmbean
描述一个Open MBean的操作。
OpenMBeanOperationInfoSupport - Class in javax.management.openmbean
描述一个Open MBean的操作。
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int) - Constructor for class javax.management.openmbean. OpenMBeanOperationInfoSupport
构造一个 OpenMBeanOperationInfoSupport实例，该实例描述了一类open MBeans的的操作中，与指定的 name ， description ， signature ， returnOpenType和 impact 。
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int, Descriptor) - Constructor for class javax.management.openmbean. OpenMBeanOperationInfoSupport
构造一个 OpenMBeanOperationInfoSupport实例，该实例描述了一类open MBeans的的操作中，与指定的 name ， description ， signature ， returnOpenType ， impact ，和 descriptor 。
OpenMBeanParameterInfo - Interface in javax.management.openmbean
描述在开放MBean的一个或多个操作或构造函数中使用的参数。
OpenMBeanParameterInfoSupport - Class in javax.management.openmbean
描述在开放MBean的一个或多个操作或构造函数中使用的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<?>) - Constructor for class javax.management.openmbean. OpenMBeanParameterInfoSupport
构造一个 OpenMBeanParameterInfoSupport实例，它描述了一个或多个开放MBean类的一个或多个操作或构造函数中使用的参数，其中指定的 name openType和 description 。
OpenMBeanParameterInfoSupport(String, String, OpenType<?>, Descriptor) - Constructor for class javax.management.openmbean. OpenMBeanParameterInfoSupport
构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ，和 descriptor 。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T) - Constructor for class javax.management.openmbean. OpenMBeanParameterInfoSupport
构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description和 defaultValue 。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, Comparable<T>, Comparable<T>) - Constructor for class javax.management.openmbean. OpenMBeanParameterInfoSupport
构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ， defaultValue ， minValue和 maxValue 。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, T[]) - Constructor for class javax.management.openmbean. OpenMBeanParameterInfoSupport
构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ， defaultValue和 legalValues 。
openMenuKey - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI
已过时。
从Java 2平台v1.3开始。
openMultiFileDialog(String, String[]) - Method in interface javax.jnlp. FileOpenService
要求用户选择一个或多个文件。
OpenOption - Interface in java.nio.file
配置如何打开或创建文件的对象。
openOutputStream() - Method in interface javax.tools. FileObject
返回此文件对象的OutputStream。
openOutputStream() - Method in class javax.tools. ForwardingFileObject
openOutputStream() - Method in class javax.tools. SimpleJavaFileObject
这个实现总是抛出UnsupportedOperationException 。
openPipe() - Method in class java.nio.channels.spi. SelectorProvider
打开管道。
openReader(boolean) - Method in interface javax.tools. FileObject
返回此对象的读取器。
openReader(boolean) - Method in class javax.tools. ForwardingFileObject
openReader(boolean) - Method in class javax.tools. SimpleJavaFileObject
在阅读器中包装 SimpleJavaFileObject.getCharContent(boolean)的结果。
opens() - Method in class java.lang.module. ModuleDescriptor
返回表示开放包的 Opens对象集。
opens(ModuleDescriptor.Opens) - Method in class java.lang.module. ModuleDescriptor.Builder
添加一个开放的包。
opens(String) - Method in class java.lang.module. ModuleDescriptor.Builder
添加一个开放的包。
opens(String, Set<String>) - Method in class java.lang.module. ModuleDescriptor.Builder
添加一个开放的包。
opens(Set<ModuleDescriptor.Opens.Modifier>, String) - Method in class java.lang.module. ModuleDescriptor.Builder
添加一个带有给定（可能为空）的修饰符集的开放包。
opens(Set<ModuleDescriptor.Opens.Modifier>, String, Set<String>) - Method in class java.lang.module. ModuleDescriptor.Builder
添加一个带有给定（可能为空）的修饰符集的开放包。
OPENS - com.sun.source.tree. Tree.Kind
用于表示模块声明中打开指令的ExportsTree的实例。
OPENS - javax.lang.model.element. ModuleElement.DirectiveKind
“打开package-name [to module-name-list]”指令。
openSelector() - Method in class java.nio.channels.spi. SelectorProvider
打开选择器。
openServerSocketChannel() - Method in class java.nio.channels.spi. SelectorProvider
打开服务器插槽通道。
opensIn(Iterable<? extends ModuleElement.Directive>) - Static method in class javax.lang.model.util. ElementFilter
在 directives返回 opens指令的列表。
openSocketChannel() - Method in class java.nio.channels.spi. SelectorProvider
打开套接字通道。
openStream() - Method in class java.net. URL
打开与此 URL的连接，并返回一个 InputStream用于从该连接读取。
OpensTree - Interface in com.sun.source.tree
模块声明中的“打开”指令的树节点。
OpenType< T> - Class in javax.management.openmbean
OpenType类是描述开放数据值的实际 开放类型的所有类的父抽象类。
OpenType - Interface in java.awt.font
OpenType接口表示OpenType和TrueType字体。
OpenType(String, String, String) - Constructor for class javax.management.openmbean. OpenType
构造一个 OpenType实例（实际上是一个子类实例为 OpenType是抽象的），检查给定参数的有效性。
openURI(OpenURIEvent) - Method in interface java.awt.desktop. OpenURIHandler
当应用程序被要求打开一个 URI
OpenURIEvent - Class in java.awt.desktop
当应用程序被要求打开一个 URI时发送的事件。
OpenURIEvent(URI) - Constructor for class java.awt.desktop. OpenURIEvent
构造一个 OpenURIEvent
OpenURIHandler - Interface in java.awt.desktop
当应用程序被要求打开一个URI时，通知一个实现者。
openWriter() - Method in interface javax.tools. FileObject
返回此文件对象的Writer。
openWriter() - Method in class javax.tools. ForwardingFileObject
openWriter() - Method in class javax.tools. SimpleJavaFileObject
在Writer中将openOutputStream的结果包起来。
OPERATING_SYSTEM_MXBEAN_NAME - Static variable in class java.lang.management. ManagementFactory
字符串表示的ObjectName为OperatingSystemMXBean 。
OperatingSystemMXBean - Interface in com.sun.management
运行Java虚拟机的操作系统的平台特定管理界面。
OperatingSystemMXBean - Interface in java.lang.management
运行Java虚拟机的操作系统的管理界面。
operation() - Method in class org.omg.CORBA. Request
检索要调用的方法的名称。
operation() - Method in class org.omg.CORBA. ServerRequest
抛出一个 org.omg.CORBA.NO_IMPLEMENT例外。
operation() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
返回被调用的操作的名称。
Operation - Class in java.rmi.server
已过时。
没有替换
Operation - Interface in jdk.dynalink
描述动态操作的对象。
Operation(String) - Constructor for class java.rmi.server. Operation
已过时。
没有替换
operation_context() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
返回一个 String对象的数组，包含在请求中发送的上下文。
OPERATION_UNSUPPORTED - javafx.scene.media. MediaException.Type
表示此平台不支持在介质上执行的操作。
OperationNotSupportedException - Exception in javax.naming
当上下文实现不支持正在调用的操作时，抛出此异常。
OperationNotSupportedException() - Constructor for exception javax.naming. OperationNotSupportedException
构造一个新的OperationNotSupportedException实例。
OperationNotSupportedException(String) - Constructor for exception javax.naming. OperationNotSupportedException
使用说明构造一个新的OperationNotSupportedException实例。
OperationsException - Exception in javax.management
表示对MBean执行操作时MBean服务器中抛出的异常。
OperationsException() - Constructor for exception javax.management. OperationsException
默认构造函数。
OperationsException(String) - Constructor for exception javax.management. OperationsException
允许指定特定错误消息的构造方法。
OPTICAL_CHARACTER_RECOGNITION - Static variable in class java.lang. Character.UnicodeBlock
Unicode字符块的“光学字符识别”常数。
optimize(Iterable<? extends GuardingDynamicLinker>) - Static method in class jdk.dynalink.linker.support. CompositeTypeBasedGuardingDynamicLinker
优化基于类型的链接器的列表。
Option - Class in javax.swing.text.html
用于表示<option>元素的ListModel的值。
Option(AttributeSet) - Constructor for class javax.swing.text.html. Option
创建一个新的Option对象。
OPTION - Static variable in class javax.swing.text.html. HTML.Tag
标签<选项>
OPTION_PANE - Static variable in class javax.accessibility. AccessibleRole
主要用于 DIALOG专用窗格。
OPTION_PANE - Static variable in class javax.swing.plaf.synth. Region
OptionPane区域。
OPTION_TYPE_PROPERTY - Static variable in class javax.swing. JOptionPane
绑定属性名称为 optionType 。
optional() - Method in class java.lang. Runtime.Version
返回 optional附加识别构建信息。
Optional< T> - Class in java.util
可能包含或不包含非 null值的容器对象。
OPTIONAL - Static variable in class javax.security.auth.login. AppConfigurationEntry.LoginModuleControlFlag
可选 LoginModule 。
OptionalDataException - Exception in java.io
表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。
OptionalDouble - Class in java.util
可能含有也可能不包含 double值的容器对象。
optionalEnd() - Method in class java.time.format. DateTimeFormatterBuilder
结束可选部分。
OptionalInt - Class in java.util
可能包含或可能不包含 int价值的容器对象。
OptionalLong - Class in java.util
一个可能含有也可能不包含 long值的容器对象。
optionalStart() - Method in class java.time.format. DateTimeFormatterBuilder
标记可选部分的开始。
OptionChecker - Interface in javax.tools
用于识别选项的界面。
OptionDialogBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.OptionDialogBorder
optionLength(String) - Static method in class com.sun.javadoc. Doclet
已过时。
检查doclet添加的选项。
optionLength(String) - Static method in class com.sun.tools.doclets.standard. Standard
已过时。
optionPane - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI
JOptionPane接收机提供外观和感觉。
OptionPaneUI - Class in javax.swing.plaf
JOptionPane可插拔的外观和界面。
OptionPaneUI() - Constructor for class javax.swing.plaf. OptionPaneUI
options - Variable in class javax.swing. JOptionPane
向用户显示的选项。
options() - Method in interface com.sun.javadoc. RootDoc
已过时。
命令行选项。
OPTIONS_PROPERTY - Static variable in class javax.swing. JOptionPane
绑定属性名称为 option 。
optionType - Variable in class javax.swing. JOptionPane
选项类型的一个 DEFAULT_OPTION ， YES_NO_OPTION ， YES_NO_CANCEL_OPTION或 OK_CANCEL_OPTION 。
or(BigInteger) - Method in class java.math. BigInteger
返回值为 (this | val)的BigInteger。
or(BitSet) - Method in class java.util. BitSet
使用位设置参数执行该位的逻辑 或 。
or(BiPredicate<? super T, ? super U>) - Method in interface java.util.function. BiPredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
or(DoublePredicate) - Method in interface java.util.function. DoublePredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
or(IntPredicate) - Method in interface java.util.function. IntPredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
or(LongPredicate) - Method in interface java.util.function. LongPredicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
or(Predicate<? super T>) - Method in interface java.util.function. Predicate
返回一个组合的谓词，表示该谓词与另一个谓词的短路逻辑或。
or(Supplier<? extends Optional<? extends T>>) - Method in class java.util. Optional
如果值存在时，返回一个 Optional描述的值，否则返回一个 Optional通过供给函数产生。
or(ObservableBooleanValue) - Method in class javafx.beans.binding. BooleanExpression
创建一个新的BooleanExpression执行这一条件或操作BooleanExpression和ObservableBooleanValue 。
or(ObservableBooleanValue, ObservableBooleanValue) - Static method in class javafx.beans.binding. Bindings
创建一个BooleanBinding ，它为ObservableBooleanValue的两个实例的值计算条件OR操作。
or(QueryExp, QueryExp) - Static method in class javax.management. Query
返回一个查询表达式，它是两个其他查询表达式的分离。
OR - com.sun.source.tree. Tree.Kind
用于实例BinaryTree代表按位和逻辑“或” | 。
OR - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree代表按位和逻辑“或” | 。
OR_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于实例CompoundAssignmentTree代表按位和逻辑“或”分配|= 。
OR_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例CompoundAssignmentTree代表按位和逻辑“或”分配|= 。
orange - Static variable in class java.awt. Color
颜色橙色。
ORANGE - Static variable in class java.awt. Color
颜色橙色。
ORANGE - Static variable in class javafx.scene.paint. Color
颜色为橙色，RGB值为＃FFA500
ORANGERED - Static variable in class javafx.scene.paint. Color
颜色橙红色，RGB值为＃FF4500
orb() - Method in interface javax.rmi.CORBA. Tie
返回这个领带的ORB。
orb() - Method in class org.omg.CORBA.portable. InputStream
返回创建此InputStream的ORB。
orb() - Method in class org.omg.CORBA.portable. OutputStream
返回创建此OutputStream的ORB。
orb(Object) - Method in class org.omg.CORBA.portable. Delegate
提供与其参数相关联的球体的参考。
orb(ORB) - Method in interface javax.rmi.CORBA. Tie
设置这个领带的ORB。
orb(Servant) - Method in interface org.omg.PortableServer.portable. Delegate
方便方法返回当前与仆人关联的ORB的实例。
ORB - Class in org.omg.CORBA_2_3
一个扩展 org.omg.CORBA.ORB的类使ORB可移植到OMG CORBA 2.3版规范之下。
ORB - Class in org.omg.CORBA
一个为CORBA对象请求代理功能提供API的类。
ORB() - Constructor for class org.omg.CORBA_2_3. ORB
ORB() - Constructor for class org.omg.CORBA. ORB
ORB_CTRL_MODEL - Static variable in class org.omg.PortableServer. ThreadPolicyValue
orb_id() - Method in interface org.omg.PortableInterceptor. ObjectReferenceTemplate
orb_id() - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
返回正在初始化的ORB的ID。
orb_id() - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations
返回用于创建ORB的ID。
ORBIdHelper - Class in org.omg.PortableInterceptor
org / omg / PortableInterceptor / ORBIdHelper.java。
ORBIdHelper() - Constructor for class org.omg.PortableInterceptor. ORBIdHelper
ORBInitializer - Interface in org.omg.PortableInterceptor
方便拦截器注册和ORB初始化。
ORBInitializerOperations - Interface in org.omg.PortableInterceptor
方便拦截器注册和ORB初始化。
ORBInitInfo - Interface in org.omg.PortableInterceptor
传递给每个 ORBInitializer ，允许它在ORB初始化时注册拦截器并执行其他任务。
ORBInitInfoOperations - Interface in org.omg.PortableInterceptor
传递给每个 ORBInitializer ，允许它在ORB初始化时注册拦截器并执行其他任务。
ORCHID - Static variable in class javafx.scene.paint. Color
颜色兰花，RGB值为＃DA70D6
order() - Method in class java.nio. ByteBuffer
检索此缓冲区的字节顺序。
order() - Method in class java.nio. CharBuffer
检索此缓冲区的字节顺序。
order() - Method in class java.nio. DoubleBuffer
检索此缓冲区的字节顺序。
order() - Method in class java.nio. FloatBuffer
检索此缓冲区的字节顺序。
order() - Method in class java.nio. IntBuffer
检索此缓冲区的字节顺序。
order() - Method in class java.nio. LongBuffer
检索此缓冲区的字节顺序。
order() - Method in class java.nio. ShortBuffer
检索此缓冲区的字节顺序。
order(ByteOrder) - Method in class java.nio. ByteBuffer
修改缓冲区的字节顺序。
ordered - Variable in class javax.naming.directory. BasicAttribute
用于记录此属性的值是否被排序的标志。
ORDERED - Static variable in interface java.util. Spliterator
特征值表示为元素定义遇到顺序。
ORDERED_NODE_ITERATOR_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是由定义的节点集将被迭代地访问，这将产生文档排序的节点。
ORDERED_NODE_SNAPSHOT_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是由定义的节点集将被作为将以原始文档顺序的节点的快照列表来访问。
ordinal() - Method in class java.lang. Enum
返回此枚举常数的序数（其枚举声明中的位置，其中初始常数的序数为零）。
ordinaryChar(int) - Method in class java.io. StreamTokenizer
指定此标记器中的字符参数为“普通”。
ordinaryChars(int, int) - Method in class java.io. StreamTokenizer
指定此标记器中 low <= c <= high范围内的所有字符 c均为“普通”。
ordinaryClasses() - Method in interface com.sun.javadoc. PackageDoc
已过时。
在此包中包含 ordinary类（即，排除异常，错误，枚举，接口和注释类型）。
orElse(double) - Method in class java.util. OptionalDouble
如果存在值，则返回值，否则返回 other 。
orElse(int) - Method in class java.util. OptionalInt
如果存在值，则返回值，否则返回 other 。
orElse(long) - Method in class java.util. OptionalLong
如果存在值，返回值，否则返回 other 。
orElse(T) - Method in class java.util. Optional
如果存在值，返回值，否则返回 other 。
orElseGet(DoubleSupplier) - Method in class java.util. OptionalDouble
如果存在值，则返回值，否则返回由供应函数产生的结果。
orElseGet(IntSupplier) - Method in class java.util. OptionalInt
如果存在值，则返回值，否则返回由供应函数产生的结果。
orElseGet(LongSupplier) - Method in class java.util. OptionalLong
如果存在值，则返回值，否则返回由供应函数产生的结果。
orElseGet(Supplier<? extends T>) - Method in class java.util. Optional
如果存在值，则返回值，否则返回由供应函数产生的结果。
orElseThrow(Supplier<? extends X>) - Method in class java.util. Optional
如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
orElseThrow(Supplier<? extends X>) - Method in class java.util. OptionalDouble
如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
orElseThrow(Supplier<? extends X>) - Method in class java.util. OptionalInt
如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
orElseThrow(Supplier<? extends X>) - Method in class java.util. OptionalLong
如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
orFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - Static method in class javax.swing. RowFilter
返回一个 RowFilter ，如果任何提供的过滤器包含条目，则包含条目。
org.ietf.jgss - package org.ietf.jgss
该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
org.omg.CORBA - package org.omg.CORBA
提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使程序员可以将其用作全功能对象请求代理（ORB）。
org.omg.CORBA_2_3 - package org.omg.CORBA_2_3
CORBA_2_3包定义了Java [tm]标准版6中现有CORBA接口的添加。这些更改发生在由OMG定义的CORBA API的最新修订版本中。 将新方法添加到从CORBA包中相应接口派生的接口。 这提供向后兼容性，并避免破坏JCK测试。
org.omg.CORBA_2_3.portable - package org.omg.CORBA_2_3.portable
提供输入和输出值类型的方法，并包含 org/omg/CORBA/portable包的其他更新。
org.omg.CORBA.DynAnyPackage - package org.omg.CORBA.DynAnyPackage
提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。
org.omg.CORBA.ORBPackage - package org.omg.CORBA.ORBPackage
提供异常 InvalidName ，由方法 ORB.resolve_initial_references抛出，异常 InconsistentTypeCode由ORB类中的动态任何创建方法抛出。
org.omg.CORBA.portable - package org.omg.CORBA.portable
提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
org.omg.CORBA.TypeCodePackage - package org.omg.CORBA.TypeCodePackage
提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。
org.omg.CosNaming - package org.omg.CosNaming
为Java IDL提供命名服务。
org.omg.CosNaming.NamingContextExtPackage - package org.omg.CosNaming.NamingContextExtPackage
此包装包含以下类别，其用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress
org.omg.CosNaming.NamingContextPackage - package org.omg.CosNaming.NamingContextPackage
该包包含 org.omg.CosNaming包的异常类。
org.omg.Dynamic - package org.omg.Dynamic
该软件包包含OMG便携式拦截器规范中规定的 Dynamic模块， ptc/2000-08-06 ，第21.9节。
org.omg.DynamicAny - package org.omg.DynamicAny
提供类和接口，可以在运行时遍历与 any相关的数据值，并提取数据值的原始组成部分。
org.omg.DynamicAny.DynAnyFactoryPackage - package org.omg.DynamicAny.DynAnyFactoryPackage
该包包含OMG “通用对象请求代理：体系结构与规范 ” 270257139266540第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。
org.omg.DynamicAny.DynAnyPackage - package org.omg.DynamicAny.DynAnyPackage
该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。
org.omg.IOP - package org.omg.IOP
该包包含OMG文档 “通用对象请求代理：体系结构和规范 ” formal/99-10-07第13.6节中指定的 IOP模块。
org.omg.IOP.CodecFactoryPackage - package org.omg.IOP.CodecFactoryPackage
该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。
org.omg.IOP.CodecPackage - package org.omg.IOP.CodecPackage
该包是从IOP :: Codec IDL接口定义生成的。
org.omg.Messaging - package org.omg.Messaging
该软件包包含OMG CORBA消息传递规范 formal/99-10-07中指定的 Messaging模块。
org.omg.PortableInterceptor - package org.omg.PortableInterceptor
提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。
org.omg.PortableInterceptor.ORBInitInfoPackage - package org.omg.PortableInterceptor.ORBInitInfoPackage
该包包含OMG便携式拦截器规范 ptc/2000-08-06 ，第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。
org.omg.PortableServer - package org.omg.PortableServer
提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
org.omg.PortableServer.CurrentPackage - package org.omg.PortableServer.CurrentPackage
提供方法实现，访问方法被调用的对象的标识。
org.omg.PortableServer.POAManagerPackage - package org.omg.PortableServer.POAManagerPackage
封装与之相关的POA的处理状态。
org.omg.PortableServer.POAPackage - package org.omg.PortableServer.POAPackage
允许程序员构建可在不同ORB产品之间移植的对象实现。
org.omg.PortableServer.portable - package org.omg.PortableServer.portable
提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
org.omg.PortableServer.ServantLocatorPackage - package org.omg.PortableServer.ServantLocatorPackage
提供用于定位仆人的类和接口。
org.omg.SendingContext - package org.omg.SendingContext
为组合值类型提供支持。
org.omg.stub.java.rmi - package org.omg.stub.java.rmi
包含 java.rmi包中出现的远程类型的RMI-IIOP存根。
org.w3c.dom - package org.w3c.dom
提供文档对象模型（DOM）的接口。
org.w3c.dom.bootstrap - package org.w3c.dom.bootstrap
提供一个工厂来获取 DOMImplementation实例。
org.w3c.dom.css - package org.w3c.dom.css
提供DOM Level 2 Style Specification的界面。
org.w3c.dom.events - package org.w3c.dom.events
提供DOM Level 2事件的接口。
org.w3c.dom.html - package org.w3c.dom.html
提供DOM Level 2 HTML规范的接口。
org.w3c.dom.ls - package org.w3c.dom.ls
提供DOM Level 3加载和保存的界面。
org.w3c.dom.ranges - package org.w3c.dom.ranges
提供DOM Level 2范围的界面。
org.w3c.dom.stylesheets - package org.w3c.dom.stylesheets
提供DOM Level 2 Style Specification的界面。
org.w3c.dom.traversal - package org.w3c.dom.traversal
提供DOM Level 2遍历的界面。
org.w3c.dom.views - package org.w3c.dom.views
提供DOM Level 2 Views的界面。
org.w3c.dom.xpath - package org.w3c.dom.xpath
提供DOM Level 3 XPath规范的接口。
org.xml.sax - package org.xml.sax
提供核心SAX API。
org.xml.sax.ext - package org.xml.sax.ext
提供与符合SAX驱动程序不一定支持的SAX2设施的接口。
org.xml.sax.helpers - package org.xml.sax.helpers
提供帮助类，包括支持引导基于SAX的应用程序。
orientation - Variable in class javax.swing. JProgressBar
进度条是水平还是垂直。
orientation - Variable in class javax.swing. JScrollBar
orientation - Variable in class javax.swing. JSlider
滑块是水平还是垂直默认为水平。
orientation - Variable in class javax.swing. JSplitPane
观点如何分裂。
orientation - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
JSplitPane的方向。
Orientation - Enum in javafx.geometry
方向
Orientation - Static variable in class javax.swing.text. StyleConstants
段落的方向。
ORIENTATION - javafx.scene. AccessibleAttribute
返回节点的方向。
ORIENTATION_PROPERTY - Static variable in class javax.swing. JSplitPane
方向（水平或垂直）的绑定属性名称。
ORIENTATION_ROW_0_BOTTOM_COLUMN_0_LEFT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
ORIENTATION_ROW_0_BOTTOM_COLUMN_0_RIGHT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
ORIENTATION_ROW_0_LEFT_COLUMN_0_BOTTOM - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
ORIENTATION_ROW_0_LEFT_COLUMN_0_TOP - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
ORIENTATION_ROW_0_RIGHT_COLUMN_0_BOTTOM - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
ORIENTATION_ROW_0_RIGHT_COLUMN_0_TOP - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
ORIENTATION_ROW_0_TOP_COLUMN_0_LEFT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
ORIENTATION_ROW_0_TOP_COLUMN_0_RIGHT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Orientation”标签一起使用的值。
orientationProperty() - Method in class javafx.animation. PathTransition
指定 node沿 path的直立方向。
orientationProperty() - Method in class javafx.scene.control. ListView
ListView的方向 - 这可以是水平还是垂直。
orientationProperty() - Method in class javafx.scene.control. ScrollBar
ScrollBar的方向可以是 HORIZONTAL或 VERTICAL 。
orientationProperty() - Method in class javafx.scene.control. Separator
Separator的方向可以是水平还是垂直。
orientationProperty() - Method in class javafx.scene.control. Slider
Slider的方向可以是水平还是垂直。
orientationProperty() - Method in class javafx.scene.control. SplitPane
SplitPane的方向。
orientationProperty() - Method in class javafx.scene.control. ToolBar
ToolBar的方向 - 这可以是水平还是垂直。
orientationProperty() - Method in class javafx.scene.layout. FlowPane
这个流面的方向。
orientationProperty() - Method in class javafx.scene.layout. TilePane
这个瓦片的方向。
OrientationRequested - Class in javax.print.attribute.standard
类OrientationRequested是打印属性类，枚举，指示打印的打印流页面的所需方向; 它不描述客户端提供的打印流页面的方向。
OrientationRequested(int) - Constructor for class javax.print.attribute.standard. OrientationRequested
使用给定的整数值构造新的定向请求枚举值。
origin - Variable in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener
原点。
ORIGINAL_TYPE_FIELD - Static variable in class javax.management. JMX
名称为 originalType字段。
originalEx - Variable in exception org.omg.CORBA.portable. UnknownException
一个可抛出的 - 包含在CORBA UnknownException中的原始异常。
OriginateDirection - Static variable in class javax.swing.text. DefaultStyledDocument.ElementSpec
getDirection的可能值。
originatingProvider - Variable in class javax.imageio. ImageReader
该 ImageReaderSpi认为这个实例化对象，或者 null如果其身份未知或不存在。
originatingProvider - Variable in class javax.imageio. ImageWriter
该 ImageWriterSpi认为这个实例化对象，或者 null如果其身份未知或不存在。
origmodel - Variable in class java.awt.image. RGBImageFilter
ColorModel由 newmodel替换时用户拨打 substituteColorModel 。
ORIYA - java.awt.font. NumericShaper.Range
Oriya系列与Oriya数字。
ORIYA - java.lang. Character.UnicodeScript
Unicode脚本“Oriya”。
ORIYA - Static variable in class java.awt.font. NumericShaper
标识ORIYA范围和十进制基数。
ORIYA - Static variable in class java.lang. Character.UnicodeBlock
“Oriya”Unicode字符块的常量。
ORNAMENTAL_DINGBATS - Static variable in class java.lang. Character.UnicodeBlock
“Ornamental Dingbats”Unicode字符块的常数。
ORTHOGONAL_TO_TANGENT - javafx.animation. PathTransition.OrientationType
目标节点的旋转矩阵设置为保持 node垂直于沿几何路径的路径切线。
orTimeout(long, TimeUnit) - Method in class java.util.concurrent. CompletableFuture
如果在给定的超时之前未完成，可以使用TimeoutException完成此CompletableFuture。
OSMANYA - java.lang. Character.UnicodeScript
Unicode脚本“Osmanya”。
OSMANYA - Static variable in class java.lang. Character.UnicodeBlock
常量为“Osmanya”Unicode字符块。
oStart - Variable in class javax.swing.text.html.parser. Element
true如果可以省略起始标签
OTHER - com.sun.management. VMOption.Origin
VM选项是通过其他机制设置的。
OTHER - com.sun.source.doctree. DocTree.Kind
实现保留节点。
OTHER - com.sun.source.tree. Tree.Kind
实现保留节点。
OTHER - java.awt. Component.BaselineResizeBehavior
表示使用任何其他常量不能表示基准调整大小行为。
OTHER - java.sql. JDBCType
表示SQL类型是特定于数据库的，并且映射到可以通过getObject和setObject方法访问的Java对象。
OTHER - javafx.scene.control. ButtonBar.ButtonData
所有未分类，其他或“未知”按钮。
OTHER - javax.lang.model.element. ElementKind
一个实现保留元素。
OTHER - javax.lang.model.type. TypeKind
实现保留类型。
OTHER - javax.tools. Diagnostic.Kind
诊断不适合其他种类。
OTHER - javax.tools. JavaFileObject.Kind
任何其他类型。
OTHER - jdk.javadoc.doclet. Doclet.Option.Kind
一个实现保留选项
OTHER - jdk.nashorn.api.tree. Diagnostic.Kind
诊断不适合其他种类。
OTHER - jdk.nashorn.api.tree. Tree.Kind
实现保留节点。
OTHER - jdk.net. SocketFlow.Status
一些其他未指定的错误。
OTHER - Static variable in class java.sql. Types
Java编程语言中的常量表示SQL类型是特定于数据库的，并且映射到可以通过方法 getObject和 setObject访问的Java对象。
OTHER - Static variable in class javax.print.attribute.standard. PrinterStateReason
打印机检测到以下列出的错误。
OTHER_EXPRESSION_SUBKIND - jdk.jshell. Snippet.SubKind
一个尚未包装在临时变量（保留）中的表达式。
OTHER_LETTER - Static variable in class java.lang. Character
Unicode规范中的一般类别“Lo”。
OTHER_NUMBER - Static variable in class java.lang. Character
Unicode规范中的常规类别“否”。
OTHER_PUNCTUATION - Static variable in class java.lang. Character
Unicode规范中的一般类别“Po”。
OTHER_SYMBOL - Static variable in class java.lang. Character
Unicode规范中的一般类别“So”。
OTHERS_EXECUTE - java.nio.file.attribute. PosixFilePermission
执行/搜索许可，其他。
OTHERS_READ - java.nio.file.attribute. PosixFilePermission
阅读权限，其他人。
OTHERS_WRITE - java.nio.file.attribute. PosixFilePermission
写许可，其他。
othersDeletesAreVisible(int) - Method in interface java.sql. DatabaseMetaData
检索他人删除是否可见。
othersInsertsAreVisible(int) - Method in interface java.sql. DatabaseMetaData
检索他人所做的插入是否可见。
othersUpdatesAreVisible(int) - Method in interface java.sql. DatabaseMetaData
检索其他人所做的更新是否可见。
otherwise(boolean) - Method in class javafx.beans.binding. When.BooleanConditionBuilder
定义三元表达式的常量值，如果条件为 false则返回。
otherwise(double) - Method in class javafx.beans.binding. When.NumberConditionBuilder
定义三元表达式的常量值，如果条件为 false则返回。
otherwise(float) - Method in class javafx.beans.binding. When.NumberConditionBuilder
定义三元表达式的常量值，如果条件为 false则返回。
otherwise(int) - Method in class javafx.beans.binding. When.NumberConditionBuilder
定义三元表达式的常量值，如果条件为 false则返回。
otherwise(long) - Method in class javafx.beans.binding. When.NumberConditionBuilder
定义三元表达式的常量值，如果条件为 false则返回。
otherwise(String) - Method in class javafx.beans.binding. When.StringConditionBuilder
定义三元表达式的常量值，如果条件为 false ，则返回该 false 。
otherwise(ObservableBooleanValue) - Method in class javafx.beans.binding. When.BooleanConditionBuilder
定义ObservableBooleanValue如果条件为false则由三元表达式返回该值。
otherwise(ObservableNumberValue) - Method in class javafx.beans.binding. When.NumberConditionBuilder
定义ObservableNumberValue如果条件为false ， 则该值由三元表达式返回。
otherwise(ObservableObjectValue<T>) - Method in class javafx.beans.binding. When.ObjectConditionBuilder
定义ObservableObjectValue ，如果条件为false ， 则该值由三元表达式返回。
otherwise(ObservableStringValue) - Method in class javafx.beans.binding. When.StringConditionBuilder
定义ObservableStringValue如果条件是false ，那么三元表达式返回哪个值。
otherwise(T) - Method in class javafx.beans.binding. When.ObjectConditionBuilder
定义三元表达式的常量值，如果条件为 false则返回。
out - Static variable in class java.io. FileDescriptor
标准输出流的句柄。
out - Variable in class java.io. FilterOutputStream
要过滤的底层输出流。
out - Variable in class java.io. FilterWriter
底层字符输出流。
out - Variable in class java.io. PipedInputStream
循环缓冲区中的位置的索引，在该缓冲区中下一个字节的数据将被该管道输入流读取。
out - Variable in class java.io. PrintWriter
这个 PrintWriter的底层字符输出流。
out - Static variable in class java.lang. System
“标准”输出流。
out() - Method in class java.util. Formatter
返回输出的目的地。
out(PrintStream) - Method in class jdk.jshell. JShell.Builder
设置运行评估的输出（它是 System.out ）。
out(PrintStream) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置输出通道。
out(PrintStream, PrintStream, PrintStream) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置输出通道。
OUT - javax.jws. WebParam.Mode
OUT_BOTTOM - Static variable in class java.awt.geom. Rectangle2D
该位掩码表示一个点位于此 Rectangle2D 。
OUT_LEFT - Static variable in class java.awt.geom. Rectangle2D
表示一个点位于此 Rectangle2D左侧的位掩码。
OUT_RIGHT - Static variable in class java.awt.geom. Rectangle2D
该位掩码表示一个点位于此 Rectangle2D的右侧。
OUT_TOP - Static variable in class java.awt.geom. Rectangle2D
该位掩码表示一个点位于此 Rectangle2D 。
OUTBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：出站邮件的邮件附件地图，密钥是MIME Content-ID，值是DataHandler。
outcode(double, double) - Method in class java.awt.geom. Rectangle2D.Double
确定相对于这个 Rectangle2D指定坐标的 Rectangle2D 。
outcode(double, double) - Method in class java.awt.geom. Rectangle2D.Float
确定相对于这个 Rectangle2D指定坐标的 Rectangle2D 。
outcode(double, double) - Method in class java.awt.geom. Rectangle2D
确定相对于这个 Rectangle2D指定坐标的 Rectangle2D 。
outcode(double, double) - Method in class java.awt. Rectangle
确定相对于这个 Rectangle2D指定坐标的 Rectangle2D 。
outcode(Point2D) - Method in class java.awt.geom. Rectangle2D
确定指定的Point2D相对于该Rectangle2D 。
OUTDENT - javafx.scene.web. HTMLEditorSkin.Command
OUTLINE_DRAG_MODE - Static variable in class javax.swing. JDesktopPane
表示只有正在拖动的项目的轮廓应该出现在桌面窗格中。
OutOfMemoryError - Error in java.lang
当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。
OutOfMemoryError() - Constructor for error java.lang. OutOfMemoryError
构造一个 OutOfMemoryError ，没有详细信息。
OutOfMemoryError(String) - Constructor for error java.lang. OutOfMemoryError
构造具有指定详细消息的 OutOfMemoryError 。
outpixbuf - Variable in class java.awt.image. ReplicateScaleFilter
A byte数组初始化大小为ReplicateScaleFilter.destWidth ，用于将一行像素数据传送到ImageConsumer 。
output - Variable in class javax.imageio. ImageWriter
所述 ImageOutputStream或其它 Object通过设置 setOutput ，并通过检索 getOutput 。
output(char[], int, int) - Method in class javax.swing.text. AbstractWriter
写出内容的最后一站。
output(char[], int, int) - Method in class javax.swing.text.html. HTMLWriter
该方法被覆盖以映射任何字符实体，例如<到＆lt;。
OUTPUT_AREA_ALMOST_FULL - Static variable in class javax.print.attribute.standard. PrinterStateReason
一个或多个输出区域几乎已满（例如托盘，堆垛机，整理机）。
OUTPUT_AREA_FULL - Static variable in class javax.print.attribute.standard. PrinterStateReason
一个或多个输出区域已满（例如，托盘，堆垛机，整理机）。
OUTPUT_TRAY_MISSING - Static variable in class javax.print.attribute.standard. PrinterStateReason
一个或多个输出托盘不在设备中。
outputClass - Variable in class javax.imageio.spi. ImageOutputStreamSpi
一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。
OutputDeviceAssigned - Class in javax.print.attribute.standard
类OutputDeviceAssigned是一个打印属性类，一个文本属性，用于标识服务分配了此作业的输出设备。
OutputDeviceAssigned(String, Locale) - Constructor for class javax.print.attribute.standard. OutputDeviceAssigned
使用给定的设备名称和语言环境构造新的输出设备分配的属性。
OutputKeys - Class in javax.xml.transform
提供可用于设置Transformer的输出属性或从Transformer或Templates对象检索输出属性的字符串常量。
outputScaleXProperty() - Method in class javafx.stage. Window
Window将适用于水平场景坐标在渲染和合成输出到屏幕或其他目标设备的所有阶段的比例。
outputScaleYProperty() - Method in class javafx.stage. Window
Window将适用于垂直场景坐标在渲染和合成输出到屏幕或其他目标设备的所有阶段的规模。
OutputStream - Class in java.io
这个抽象类是表示字节输出流的所有类的超类。
OutputStream - Class in org.omg.CORBA_2_3.portable
OutputStream提供了将所有映射的IDL类型写入流的接口。
OutputStream - Class in org.omg.CORBA.portable
OuputStream是用于将IDL类型写入CDR元数据流的Java API。
OutputStream() - Constructor for class java.io. OutputStream
OutputStream() - Constructor for class org.omg.CORBA_2_3.portable. OutputStream
创建一个这个类的新实例。
OutputStream() - Constructor for class org.omg.CORBA.portable. OutputStream
OutputStreamWriter - Class in java.io
OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入的字符编码为字节。
OutputStreamWriter(OutputStream) - Constructor for class java.io. OutputStreamWriter
创建一个使用默认字符编码的OutputStreamWriter。
OutputStreamWriter(OutputStream, String) - Constructor for class java.io. OutputStreamWriter
创建一个使用命名字符集的OutputStreamWriter。
OutputStreamWriter(OutputStream, Charset) - Constructor for class java.io. OutputStreamWriter
创建一个使用给定字符集的OutputStreamWriter。
OutputStreamWriter(OutputStream, CharsetEncoder) - Constructor for class java.io. OutputStreamWriter
创建一个使用给定字符集编码器的OutputStreamWriter。
outputTypes - Variable in class javax.imageio.spi. ImageWriterSpi
从 getOutputTypes返回的 Class对象的数组，最初为 null 。
OUTSIDE - javafx.scene.shape. StrokeType
通过将strokeWidth指定的距离延伸到其外部的封闭式Shape节点的边界来施加行程。
outsideBorder - Variable in class javax.swing.border. CompoundBorder
外界。
outsideTimerAction() - Constructor for class javax.swing. ToolTipManager.outsideTimerAction
OVER - Static variable in class java.awt.dnd. DragSourceContext
一个 int由updateCurrentCursor（）使用，表示 Cursor超过了 DropTarget 。
OVERFLOW - Static variable in class java.nio.charset. CoderResult
指示溢出的结果对象，意味着输出缓冲区空间不足。
OVERFLOW - Static variable in class java.nio.file. StandardWatchEventKinds
一个特殊事件，表明事件可能已丢失或丢弃。
OVERFLOW_BUTTON - javafx.scene. AccessibleAttribute
返回节点的溢出按钮。
OverlappingFileLockException - Exception in java.nio.channels
当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
OverlappingFileLockException() - Constructor for exception java.nio.channels. OverlappingFileLockException
构造这个类的一个实例。
overlaps(long, long) - Method in class java.nio.channels. FileLock
告诉这个锁是否与给定的锁定范围重叠。
OVERLAY - javafx.scene.effect. BlendMode
根据底部输入颜色，输入颜色分量是相乘或屏蔽的。
OverlayLayout - Class in javax.swing
布局管理器将组件排列在彼此的顶部。
OverlayLayout(Container) - Constructor for class javax.swing. OverlayLayout
构建一个布局管理器，执行子项的覆盖排列。
overriddenClass() - Method in interface com.sun.javadoc. MethodDoc
已过时。
返回包含此方法覆盖的方法的类。
overriddenMethod() - Method in interface com.sun.javadoc. MethodDoc
已过时。
返回此方法覆盖的方法。
overriddenType() - Method in interface com.sun.javadoc. MethodDoc
已过时。
返回包含此方法覆盖的方法的类型。
Override - Annotation Type in java.lang
表示方法声明旨在覆盖超类型中的方法声明。
overrides(MethodDoc) - Method in interface com.sun.javadoc. MethodDoc
已过时。
测试此方法是否覆盖其他方法。
overrides(ExecutableElement, ExecutableElement, TypeElement) - Method in interface javax.lang.model.util. Elements
测试一种方法，作为给定类型的成员，覆盖其他方法。
OverrunStyle - Enum in javafx.scene.control
当渲染文本的空间小于渲染整个字符串所需的空间时，定义标记的控件的行为。
OVERVIEW - jdk.javadoc.doclet. Taglet.Location
在概述文档中。
OVERWRITTEN - jdk.jshell. Snippet.Status
该代码段已被替换为新的代码段，因此无效。
ownDeletesAreVisible(int) - Method in interface java.sql. DatabaseMetaData
检索结果集自身的删除是否可见。
ownedMonitors() - Method in interface com.sun.jdi. ThreadReference
返回列表，该列表包含线程拥有的每个监视器的一个ObjectReference 。
ownedMonitorsAndFrames() - Method in interface com.sun.jdi. ThreadReference
返回一个列表，该列表包含线程拥有的每个监视器的一个MonitorInfo对象。
owner - Variable in class java.awt.datatransfer. Clipboard
剪贴板的所有者。
owner() - Method in interface com.sun.javadoc. TypeVariable
已过时。
返回声明此类型变量的类，接口，方法或构造函数。
owner() - Method in interface java.nio.file.attribute. PosixFileAttributes
返回文件的所有者。
Owner - Interface in java.security.acl
已过时。
该软件包自java.security.Policy以来已被java.security.Policy及相关课程所取代。
OWNER_EXECUTE - java.nio.file.attribute. PosixFilePermission
执行/搜索权限，所有者。
OWNER_READ - java.nio.file.attribute. PosixFilePermission
读权限，所有者。
OWNER_WRITE - java.nio.file.attribute. PosixFilePermission
书面许可，所有者。
ownerNodeProperty() - Method in class javafx.stage. PopupWindow
该弹出窗口的所有者的节点。
ownerWindowProperty() - Method in class javafx.stage. PopupWindow
作为此弹出窗口的父窗口。
owningThread() - Method in interface com.sun.jdi. ObjectReference
返回当前拥有该对象的显示器的线程（如果有的话）的ThreadReference 。
ownInsertsAreVisible(int) - Method in interface java.sql. DatabaseMetaData
检索结果集是否可以看到自己的插入。
owns(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
查询给定的ConditionObject是否将此同步器用作其锁。
owns(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
查询给定的ConditionObject是否将此同步器用作其锁。
ownUpdatesAreVisible(int) - Method in interface java.sql. DatabaseMetaData
检索对于给定类型的 ResultSet对象，结果集的自己的更新是可见的。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


P-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

P

p - Variable in class javax.swing.text.html.parser. DTD
元素对应于p。
P - javafx.scene.input. KeyCode
常数为 P键。
P - Static variable in class javax.swing.text.html. HTML.Tag
标签<p>
pack() - Method in class java.awt. Window
使此窗口的大小适合其子组件的首选大小和布局。
pack() - Method in class javax.swing. JInternalFrame
导致此 JInternalFrame子组件按其首选大小 JInternalFrame 。
pack() - Method in class javax.swing. JPopupMenu
放出容器，使其使用显示其内容所需的最小空间。
pack(JarFile, OutputStream) - Method in interface java.util.jar. Pack200.Packer
使用JarFile并将其转换为Pack200存档。
pack(JarInputStream, OutputStream) - Method in interface java.util.jar. Pack200.Packer
使用JarInputStream并将其转换为Pack200归档文件。
Pack200 - Class in java.util.jar
从Pack200格式的压缩流转换JAR文件。
Pack200.Packer - Interface in java.util.jar
打包机引擎对输入的JAR文件进行各种转换，使包流由压缩器（如gzip或zip）高度压缩。
Pack200.Unpacker - Interface in java.util.jar
解包器引擎将打包流转换为JAR文件。
软件包 - Class in java.lang
表示与类加载器关联的运行时包的元数据。
PACKAGE - com.sun.source.tree. Tree.Kind
用于PackageTree的实例。
PACKAGE - java.lang.annotation. ElementType
包装声明
PACKAGE - javax.lang.model.element. ElementKind
一套。
PACKAGE - javax.lang.model.type. TypeKind
对应于封装元件的伪类型。
PACKAGE - jdk.javadoc.doclet. Taglet.Location
在包的文档中。
PACKAGE - Static variable in class java.lang.invoke. MethodHandles.Lookup
代表 package访问（默认访问）的单位掩码，这可能有助于 lookupModes的结果。
PackageDoc - Interface in com.sun.javadoc
已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
PackageElement - Interface in javax.lang.model.element
表示包程序元素。
pack200 - Search tag in jdk.pack
pack200 tool
packageNamed(String) - Method in interface com.sun.javadoc. RootDoc
已过时。
为指定的包名返回一个PackageDoc。
packagePrefix - Static variable in interface java.rmi.server. LoaderHandler
已过时。
系统封装 LoaderHandler实现。
packagePrefix - Static variable in interface java.rmi.server. RemoteRef
初始化服务器包前缀：假定服务器参考类的实现（例如，UnicastRef，UnicastServerRef）位于由前缀定义的包中。
packages() - Method in class java.lang.module. ModuleDescriptor
返回模块中的一组包。
packages(Set<String>) - Method in class java.lang.module. ModuleDescriptor.Builder
将包添加到模块。
packagesIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
返回 elements中的软件包列表。
packagesIn(Set<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter
在 elements返回一组软件包。
PackageTree - Interface in com.sun.source.tree
表示包声明。
PackedColorModel - Class in java.awt.image
PackedColorModel类是一个抽象的ColorModel类，它与像素值一起使用，它们将颜色和alpha信息表示为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。
PackedColorModel(ColorSpace, int, int[], int, boolean, int, int) - Constructor for class java.awt.image. PackedColorModel
从颜色掩码数组构造一个 PackedColorModel ，它指定 int像素表示中的哪个位包含每个颜色样本和alpha掩码。
PackedColorModel(ColorSpace, int, int, int, int, int, boolean, int, int) - Constructor for class java.awt.image. PackedColorModel
从指定的掩码构造一个 PackedColorModel ，它们指示 int像素表示中的哪些位包含alpha，红，绿和蓝色样本。
padding - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
如果指定了这些插值，则在组合框中布置和绘制“选定”项时，这些插值将围绕单元格渲染器充当填充。
padding - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout
填充值。
PADDING - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“padding”。
PADDING_BOTTOM - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“padding-bottom”。
PADDING_LEFT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“padding-left”。
PADDING_RIGHT - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“padding-right”。
PADDING_TOP - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“padding-top”。
paddingProperty() - Method in class javafx.scene.layout. Region
顶部，右侧，底部和左侧填充该区域的内容。
padNext(int) - Method in class java.time.format. DateTimeFormatterBuilder
使下一个添加的打印机/解析器使用空格来填充到固定宽度。
padNext(int, char) - Method in class java.time.format. DateTimeFormatterBuilder
使下一个添加的打印机/解析器粘贴到固定的宽度。
padSelectedTab(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
贴片选择标签。
padSelectedTab(int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI.TabbedPaneLayout
padSpaceBetweenStrings - Static variable in class javax.swing.plaf.metal. MetalToolTipUI
字符串之间的空格。
padTabRun(int, int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
粘贴选项卡运行。
PAGE - javafx.scene.control.skin. TextInputControlSkin.TextUnit
PAGE_AXIS - Static variable in class javax.swing. BoxLayout
指定组件应按照目标容器的 ComponentOrientation属性所确定的方向排列在一个页面上。
PAGE_DOWN - javafx.scene.input. KeyCode
常数为 Page Down键。
PAGE_END - Static variable in class java.awt. BorderLayout
该组件来自布局内容的最后一行。
PAGE_END - Static variable in class java.awt. GridBagConstraints
将组件沿着与当前 ComponentOrientation的页面末尾相关联的显示区域的边缘 ComponentOrientation 。
PAGE_EXISTS - Static variable in interface java.awt.print. Printable
从 Printable.print(Graphics, PageFormat, int)返回，表示请求的页面被呈现。
PAGE_ITEM - javafx.scene. AccessibleRole
页面角色。
PAGE_RULE - Static variable in interface org.w3c.dom.css. CSSRule
规则是一个 CSSPageRule 。
PAGE_START - Static variable in class java.awt. BorderLayout
该组件位于布局内容的第一行之前。
PAGE_START - Static variable in class java.awt. GridBagConstraints
将组件沿着与当前 ComponentOrientation的页面开头相关联的显示区域的边缘 ComponentOrientation 。
PAGE_TAB - Static variable in class javax.accessibility. AccessibleRole
作为页面选项卡列表的子对象。
PAGE_TAB_LIST - Static variable in class javax.accessibility. AccessibleRole
一个对象，通过对象提供的一些机制，一次显示一系列面板（或页面选项卡）。
PAGE_UP - javafx.scene.input. KeyCode
常数为 Page Up键。
Pageable - Interface in java.awt.print
Pageable实现代表一组要打印的页面。
PAGEABLE - Static variable in class javax.print. DocFlavor.SERVICE_FORMATTED
服务格式化打印数据doc风格与打印数据表示类名= "java.awt.print.Pageable" （可分页对象）。
PageAttributes - Class in java.awt
一组控制打印页面输出的属性。
PageAttributes() - Constructor for class java.awt. PageAttributes
为每个属性构造具有默认值的PageAttributes实例。
PageAttributes(PageAttributes) - Constructor for class java.awt. PageAttributes
构造一个PageAttributes实例，它是提供的PageAttributes的副本。
PageAttributes(PageAttributes.ColorType, PageAttributes.MediaType, PageAttributes.OrientationRequestedType, PageAttributes.OriginType, PageAttributes.PrintQualityType, int[]) - Constructor for class java.awt. PageAttributes
为每个属性构造一个具有指定值的PageAttributes实例。
PageAttributes.ColorType - Class in java.awt
可能的颜色状态的类型安全枚举。
PageAttributes.MediaType - Class in java.awt
可能的纸张尺寸的类型安全枚举。
PageAttributes.OrientationRequestedType - Class in java.awt
可能的方向的类型安全的枚举。
PageAttributes.OriginType - Class in java.awt
可能来源的类型安全枚举。
PageAttributes.PrintQualityType - Class in java.awt
可能的打印质量的类型安全枚举。
pageCountProperty() - Method in class javafx.scene.control. Pagination
此分页控件的页数。
pageDialog(PageFormat) - Method in class java.awt.print. PrinterJob
显示允许修改 PageFormat实例的对话框。
pageDialog(PrintRequestAttributeSet) - Method in class java.awt.print. PrinterJob
显示跨平台页面设置对话框的便捷方法。
pageDownAction - Static variable in class javax.swing.text. DefaultEditorKit
垂直向下翻页的动作名称。
PagedResultsControl - Class in javax.naming.ldap
请求LDAP服务器以指定大小的批量返回搜索操作的结果。
PagedResultsControl(int, boolean) - Constructor for class javax.naming.ldap. PagedResultsControl
构造一个控件以设置每页结果返回的条目数。
PagedResultsControl(int, byte[], boolean) - Constructor for class javax.naming.ldap. PagedResultsControl
构造一个控件以设置每页结果返回的条目数。
PagedResultsResponseControl - Class in javax.naming.ldap
表示一批搜索结果的结束。
PagedResultsResponseControl(String, boolean, byte[]) - Constructor for class javax.naming.ldap. PagedResultsResponseControl
构建分页结果响应控件。
pageFactoryProperty() - Method in class javafx.scene.control. Pagination
当应用程序或用户选择页面时调用的pageFactory回调函数。
PageFormat - Class in java.awt.print
PageFormat类描述了要打印的页面的大小和方向。
PageFormat() - Constructor for class java.awt.print. PageFormat
创建一个默认的，面向肖像的 PageFormat 。
PageLayout - Class in javafx.print
PageLayout封装了布局内容所需的信息。
pageLayoutProperty() - Method in class javafx.print. JobSettings
代表 PageLayout的实例的 PageLayout 。
PageOrientation - Enum in javafx.print
指定打印页面的介质页的方向。
PageRange - Class in javafx.print
A PageRange用于选择或约束要打印的作业打印流页面。
PageRange(int, int) - Constructor for class javafx.print. PageRange
使用指定的开始和结束页码创建一个新的PageRange。
PageRanges - Class in javax.print.attribute.standard
Class PageRanges是一个打印属性类，一组整数，用于标识打印机对象用于打印每个文档的每个副本的打印流页面的范围。
PageRanges(int) - Constructor for class javax.print.attribute.standard. PageRanges
构造包含单个整数的新页面范围属性。
PageRanges(int[][]) - Constructor for class javax.print.attribute.standard. PageRanges
使用给定的成员构造一个新的页面范围属性。
PageRanges(int, int) - Constructor for class javax.print.attribute.standard. PageRanges
构造包含单个整数范围的新页面范围属性。
PageRanges(String) - Constructor for class javax.print.attribute.standard. PageRanges
使用字符串形式的给定成员构造新的页面范围属性。
pageRangesProperty() - Method in class javafx.print. JobSettings
一个 ObjectProperty其值表示作为PageRange数组打印的作业页面。
PAGES - javafx.scene.input. ScrollEvent.VerticalTextScrollUnits
垂直的基于文本的滚动量是要滚动的页面数。
PagesPerMinute - Class in javax.print.attribute.standard
Class PagesPerMinute是一个整数值打印属性，它表示可能由此打印机生成的最接近的整数的每分钟的标称页数（例如单面，黑白）。
PagesPerMinute(int) - Constructor for class javax.print.attribute.standard. PagesPerMinute
使用给定的整数值构建每分钟新的页面属性。
PagesPerMinuteColor - Class in javax.print.attribute.standard
Class PagesPerMinuteColor是一个整数值打印属性，表示当打印颜色（例如，单色，颜色）时可能由此打印机生成的最近整数的每分钟的标称页数。
PagesPerMinuteColor(int) - Constructor for class javax.print.attribute.standard. PagesPerMinuteColor
使用给定的整数值构建每分钟颜色属性的新页面。
pageUpAction - Static variable in class javax.swing.text. DefaultEditorKit
要垂直翻页的动作名称。
Pagination - Class in javafx.scene.control
分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。
Pagination() - Constructor for class javafx.scene.control. Pagination
构造具有 Pagination.INDETERMINATE页数和页索引等于零的分页控件。
Pagination(int) - Constructor for class javafx.scene.control. Pagination
构造一个具有指定页数的新的分页控件。
Pagination(int, int) - Constructor for class javafx.scene.control. Pagination
使用指定的页数和页索引构造一个新的分页控件。
PAGINATION - javafx.scene. AccessibleRole
分页角色
PaginationSkin - Class in javafx.scene.control.skin
默认皮肤实现为Pagination控件。
PaginationSkin(Pagination) - Constructor for class javafx.scene.control.skin. PaginationSkin
创建一个新的PaginationSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。
PAHAWH_HMONG - java.lang. Character.UnicodeScript
Unicode脚本“Pahawh Hmong”。
PAHAWH_HMONG - Static variable in class java.lang. Character.UnicodeBlock
“Pahawh Hmong”Unicode字符块的常量。
paint(Graphics) - Method in class java.awt. Canvas
画这幅画。
paint(Graphics) - Method in class java.awt. Component
涂抹这个组件。
paint(Graphics) - Method in class java.awt. Container
涂上容器
paint(Graphics) - Method in class java.awt. Window
涂上容器
paint(Graphics) - Method in class javax.swing. CellRendererPane
不应该叫
paint(Graphics) - Method in class javax.swing.colorchooser. AbstractColorChooserPanel
画面板。
paint(Graphics) - Method in class javax.swing. JComponent
由Swing调用来绘制组件。
paint(Graphics) - Method in class javax.swing. JLayer
代表所有绘画到LayerUI对象。
paint(Graphics) - Method in class javax.swing. JLayeredPane
在指定的图形上下文中绘制JLayeredPane。
paint(Graphics) - Method in class javax.swing. JViewport
根据是否启用 backingStore ，可以通过后备存储来绘制图像，也可以仅绘制最近暴露的零件，使用后备存储将“剩余”部分“blit”。
paint(Graphics) - Method in class javax.swing.plaf.basic. BasicArrowButton
paint(Graphics) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.SystemMenuBar
paint(Graphics) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider
涂抹分隔线。
paint(Graphics) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow
paint(Graphics) - Method in class javax.swing.plaf.metal. MetalScrollButton
paint(Graphics) - Method in interface javax.swing.text. Caret
渲染插入符号。
paint(Graphics) - Method in class javax.swing.text. DefaultCaret
将插入符号作为垂直线。
paint(Graphics) - Method in class javax.swing.text. DefaultHighlighter
渲染亮点。
paint(Graphics) - Method in interface javax.swing.text. Highlighter
渲染亮点。
paint(Graphics) - Method in class javax.swing.tree. DefaultTreeCellEditor.EditorContainer
覆盖 Container.paint以绘制节点的图标，并使用背景的选择颜色。
paint(Graphics) - Method in class javax.swing.tree. DefaultTreeCellRenderer
绘制价值。
paint(Graphics2D, JComponent, int, int) - Method in class javax.swing.plaf.nimbus. AbstractRegionPainter
给予给定的Graphics2D对象。
paint(Graphics2D, T, int, int) - Method in interface javax.swing. Painter
渲染给给定的Graphics2D对象。
paint(Graphics, float, float, float, float, View) - Method in class javax.swing.text.html. StyleSheet.BoxPainter
根据给出的属性绘制CSS框。
paint(Graphics, float, float, float, float, View, int) - Method in class javax.swing.text.html. StyleSheet.ListPainter
根据给出的属性绘制CSS列表装饰。
paint(Graphics, int, int, Shape, JTextComponent) - Method in class javax.swing.text. DefaultHighlighter.DefaultHighlightPainter
画亮点
paint(Graphics, int, int, Shape, JTextComponent) - Method in interface javax.swing.text. Highlighter.HighlightPainter
渲染亮点。
paint(Graphics, Shape) - Method in class javax.swing.text. AsyncBoxView
使用给定的分配和渲染表面渲染视图。
paint(Graphics, Shape) - Method in class javax.swing.text. BoxView
使用给定的渲染表面和该表面上的区域渲染 BoxView 。
paint(Graphics, Shape) - Method in class javax.swing.text. ComponentView
真正的绘画行为自然地发生在组件与其父容器（托管此视图的同一容器）的关联中。
paint(Graphics, Shape) - Method in class javax.swing.text. FieldView
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, Shape) - Method in class javax.swing.text. GlyphView
渲染文本样式运行的一部分。
paint(Graphics, Shape) - Method in class javax.swing.text.html. BlockView
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, Shape) - Method in class javax.swing.text.html. ImageView
绘制视图。
paint(Graphics, Shape) - Method in class javax.swing.text.html. ListView
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, Shape) - Method in class javax.swing.text.html. ParagraphView
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, Shape) - Method in class javax.swing.text. IconView
画图标。
paint(Graphics, Shape) - Method in class javax.swing.text. ParagraphView
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, Shape) - Method in class javax.swing.text. PlainView
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, Shape) - Method in class javax.swing.text. View
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, Shape) - Method in class javax.swing.text. WrappedPlainView
渲染使用给定的渲染表面和该表面上的区域。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicButtonUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicLabelUI
用前景颜色绘制标签文本，如果标签不透明，则使用背景颜色绘制整个背景。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicListUI
绘制与Graphics对象clipRect相交的行。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicPopupMenuSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI
代表绘画为两种方法之一：paintDeterminate或paintIndeterminate。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicRadioButtonUI
画单选按钮
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicSliderUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
适当地涂抹指定的组件的外观和感觉。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicTableUI
绘制在installUI（）中设置的 table实例的表示。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicTextUI
绘制界面。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicToggleButtonUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicToolBarSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicTreeUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf. ComponentUI
适当地涂抹指定的组件的外观和感觉。
paint(Graphics, JComponent) - Method in class javax.swing.plaf. LayerUI
绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalComboBoxUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalPopupMenuSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalRadioButtonUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalToolTipUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalTreeUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiListUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI
在此对象处理的每个UI上调用 paint方法。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthButtonUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthColorChooserUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthComboBoxUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthDesktopIconUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthLabelUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthMenuBarUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthMenuItemUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthMenuUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthOptionPaneUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthPanelUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthPopupMenuUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthProgressBarUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthRootPaneUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthScrollBarUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSliderUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSpinnerUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTableUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthToolBarUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTreeUI
根据外观和外观绘制指定的组件。
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI
根据外观和外观绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthButtonUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthColorChooserUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthComboBoxUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthDesktopIconUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthEditorPaneUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthLabelUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthMenuBarUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthMenuItemUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthMenuUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthOptionPaneUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthPanelUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthPopupMenuUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthProgressBarUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthRootPaneUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthScrollBarUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthSliderUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthSpinnerUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthTableUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthTextAreaUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthTextFieldUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthToolBarUI
绘制工具栏。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthToolTipUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthTreeUI
绘制指定的组件。
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth. SynthViewportUI
绘制指定的组件。
paint(GlyphView, Graphics, Shape, int, int) - Method in class javax.swing.text. GlyphView.GlyphPainter
绘制表示给定范围的字形。
Paint - Class in javafx.scene.paint
用于在渲染场景图时填充形状和背景的颜色或渐变的基类。
Paint - Interface in java.awt
这个Paint接口定义了如何为Graphics2D操作生成颜色模式。
PAINT - Static variable in class java.awt.event. PaintEvent
油漆事件类型。
PAINT_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择油漆事件的事件掩码。
PAINT_FIRST - Static variable in class java.awt.event. PaintEvent
标记paint事件ID范围的第一个整数id。
PAINT_LAST - Static variable in class java.awt.event. PaintEvent
标记paint事件ID范围的最后一个整数id。
paintAll(Graphics) - Method in class java.awt. Component
绘制此组件及其所有子组件。
paintArrowButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制箭头按钮的背景。
paintArrowButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个箭头按钮的边框。
paintArrowButtonForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个箭头按钮的前景。
paintBackground(Graphics) - Method in class javax.swing.plaf.basic. BasicTextUI
绘制视图的背景。
paintBackground(Graphics) - Method in class javax.swing.plaf.synth. SynthEditorPaneUI
绘制视图的背景。
paintBackground(Graphics) - Method in class javax.swing.plaf.synth. SynthTextAreaUI
绘制视图的背景。
paintBackground(Graphics) - Method in class javax.swing.plaf.synth. SynthTextFieldUI
绘制视图的背景。
paintBackground(Graphics, JMenuItem, Color) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
绘制菜单项的背景。
paintBorder - Variable in class javax.swing. JProgressBar
是否在进度条周围显示边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. AbstractBorder
此默认实现不绘画。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. BevelBorder
用指定的位置和大小绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in interface javax.swing.border. Border
用指定的位置和大小绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. CompoundBorder
通过用指定的位置和大小绘制外部边框来绘制复合边框，然后通过外部边框的插入在指定位置和大小偏移处绘制内边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. EmptyBorder
默认情况下不绘图。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. EtchedBorder
用指定的位置和大小绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. LineBorder
用指定的位置和大小绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. MatteBorder
涂抹无光泽的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. SoftBevelBorder
用指定的位置和大小绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. StrokeBorder
用指定的位置和大小绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. TitledBorder
用指定的位置和大小绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicBorders.ButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicBorders.FieldBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicBorders.MenuBarBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicBorders.RadioButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicBorders.RolloverButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicBorders.SplitPaneBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicBorders.ToggleButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf. BorderUIResource
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.ButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.Flush3DBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.InternalFrameBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.MenuBarBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.MenuItemBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.OptionDialogBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.PaletteBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.PopupMenuBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.RolloverButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.ScrollPaneBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.TableHeaderBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.TextFieldBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.ToggleButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalBorders.ToolBarBorder
paintBorder(Graphics) - Method in class javax.swing. AbstractButton
如果 BorderPainted属性为true并且按钮具有边框，则 BorderPainted按钮的边框。
paintBorder(Graphics) - Method in class javax.swing. JComponent
绘制组件的边框。
paintBorder(Graphics) - Method in class javax.swing. JMenuBar
如果 BorderPainted属性为true，则绘制菜单栏的边框。
paintBorder(Graphics) - Method in class javax.swing. JPopupMenu
如果 borderPainted属性为 true绘制弹出菜单的边框。
paintBorder(Graphics) - Method in class javax.swing. JProgressBar
如果 borderPainted属性为 true则绘制进度条的边框。
paintBorder(Graphics) - Method in class javax.swing. JToolBar
如果 borderPainted属性为 true则绘制工具栏的边框。
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthButtonUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthCheckBoxMenuItemUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthCheckBoxUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthColorChooserUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthComboBoxUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthDesktopIconUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthEditorPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthFormattedTextFieldUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthLabelUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthListUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthMenuBarUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthMenuItemUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthMenuUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthOptionPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPanelUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPasswordFieldUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPopupMenuUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthProgressBarUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthRadioButtonMenuItemUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthRadioButtonUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthRootPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthScrollBarUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthSliderUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthSpinnerUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthTableUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthTextAreaUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthTextFieldUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthTextPaneUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthToggleButtonUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthToolBarUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthToolTipUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthTreeUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in interface javax.swing.plaf.synth. SynthUI
画边框
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthViewportUI
画边框
paintBottomTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
绘制底部标签边框。
paintButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个按钮的背景。
paintButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个按钮的边框。
paintButtonPressed(Graphics, AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI
画一个按下的按钮。
paintButtonPressed(Graphics, AbstractButton) - Method in class javax.swing.plaf.metal. MetalButtonUI
paintButtonPressed(Graphics, AbstractButton) - Method in class javax.swing.plaf.metal. MetalToggleButtonUI
paintCell(Graphics, int, Rectangle, ListCellRenderer<Object>, ListModel<Object>, ListSelectionModel, int) - Method in class javax.swing.plaf.basic. BasicListUI
绘制一个列表单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane绘制。
paintCheckBoxBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个复选框的背景。
paintCheckBoxBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个复选框的边框。
paintCheckBoxMenuItemBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制复选框菜单项的背景。
paintCheckBoxMenuItemBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制复选框菜单项的边框。
paintChild(Graphics, Rectangle, int) - Method in class javax.swing.text. BoxView
涂一个孩子
paintChild(Graphics, Rectangle, int) - Method in class javax.swing.text.html. ListView
画一个孩子; 由paint（）调用。
paintChildren(Graphics) - Method in class javax.swing. JComponent
涂抹这个组件的孩子。
paintChildren(Graphics) - Method in class javax.swing. JSplitPane
Subclassed消息的UI与 finishedPaintingChildren之后超级已经被消息，以及画边框。
paintChildren(Graphics) - Method in class javax.swing.text. AsyncBoxView.ChildLocator
绘制与剪辑区域相交的孩子。
paintColorChooserBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个颜色选择器的背景。
paintColorChooserBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制颜色选择器的边框。
paintComboBoxBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个组合框的背景。
paintComboBoxBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个组合框的边框。
paintComponent(Graphics) - Method in class javafx.embed.swing. JFXPanel
覆盖 JComponent.paintComponent(Graphics)方法来绘制附加到此 JFXpanel的JavaFX场景的内容。
paintComponent(Graphics) - Method in class javax.swing. Box.Filler
Filler这 Filler 。
paintComponent(Graphics) - Method in class javax.swing. Box
Box这 Box 。
paintComponent(Graphics) - Method in class javax.swing. JComponent
调用UI null的paint方法，如果UI null 。
paintComponent(Graphics) - Method in class javax.swing. JInternalFrame
被覆盖以允许在拖动内部框架时优化绘画。
paintComponent(Graphics) - Method in class javax.swing. JLayer
这种方法是空的，因为所有的绘画都是由 JLayer.paint(Graphics)和 ComponentUI.update(Graphics, JComponent)方法完成的
paintComponent(Graphics) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
paintComponent(Graphics) - Method in class javax.swing.plaf.metal. MetalComboBoxButton
paintComponent(Graphics) - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
paintComponent(Graphics, Component, Container, int, int, int, int) - Method in class javax.swing. CellRendererPane
调用this.paintComponent（g，c，p，x，y，w，h，false）。
paintComponent(Graphics, Component, Container, int, int, int, int) - Static method in class javax.swing. SwingUtilities
绘制一个组件到指定的 Graphics 。
paintComponent(Graphics, Component, Container, int, int, int, int, boolean) - Method in class javax.swing. CellRendererPane
在图形对象上绘制单元格渲染器组件c。
paintComponent(Graphics, Component, Container, Rectangle) - Method in class javax.swing. CellRendererPane
调用this.paintComponent（）与矩形x，y，width，height字段。
paintComponent(Graphics, Component, Container, Rectangle) - Static method in class javax.swing. SwingUtilities
绘制一个组件到指定的 Graphics 。
paintComponents(Graphics) - Method in class java.awt. Container
涂抹此容器中的每个组件。
paintContent(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth. SynthToolBarUI
绘制工具栏内容。
paintContentBorder(Graphics, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制内容边框。
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制内容边框底边。
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制内容边框左边缘。
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制内容边框右边缘。
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制内容边框上边缘。
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
PaintContext - Interface in java.awt
PaintContext接口定义封装和优化的环境，以在Graphics2D中为填充或笔画操作生成设备空间中的颜色模式。
PaintContext(Insets, Dimension, boolean) - Constructor for class javax.swing.plaf.nimbus. AbstractRegionPainter.PaintContext
创建一个新的PaintContext，它不会尝试缓存或缩放任何缓存的图像。
PaintContext(Insets, Dimension, boolean, AbstractRegionPainter.PaintContext.CacheMode, double, double) - Constructor for class javax.swing.plaf.nimbus. AbstractRegionPainter.PaintContext
创建一个新的PaintContext。
PaintConverter - Class in javafx.css.converter
PaintConverter.ImagePatternConverter - Class in javafx.css.converter
PaintConverter.LinearGradientConverter - Class in javafx.css.converter
PaintConverter.RadialGradientConverter - Class in javafx.css.converter
PaintConverter.RepeatingImagePatternConverter - Class in javafx.css.converter
PaintConverter.SequenceConverter - Class in javafx.css.converter
将解析值数组转换为Paint对象数组。
paintCurrentValue(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.basic. BasicComboBoxUI
绘制当前选定的项目。
paintCurrentValue(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.metal. MetalComboBoxUI
如果需要，可以涂抹当前选择的项目。
paintCurrentValue(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.synth. SynthComboBoxUI
绘制当前选定的项目。
paintCurrentValueBackground(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.basic. BasicComboBoxUI
绘制当前所选项目的背景。
paintCurrentValueBackground(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.metal. MetalComboBoxUI
如果需要，可以画出当前所选项目的背景。
paintDecreaseHighlight(Graphics) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
绘制减少亮点。
paintDesktopIconBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制桌面图标的背景。
paintDesktopIconBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制桌面图标的边框。
paintDesktopPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制桌面窗格的背景。
paintDesktopPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制桌面窗格的背景。
paintDeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI
所有目的的油漆方法应该对几乎所有线性，确定进度条做正确的事情。
paintDeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalProgressBarUI
在进度条上画出一点特别的亮点。
paintDirtyRegions() - Method in class javax.swing. RepaintManager
绘制所有被标记为脏的组件。
paintDisabledText(JLabel, Graphics, String, int, int) - Method in class javax.swing.plaf.basic. BasicLabelUI
在textX上绘制clippedText，textY与background.lighter（），然后向下移动并向右移动一个像素与background.darker（）。
paintDisabledText(JLabel, Graphics, String, int, int) - Method in class javax.swing.plaf.metal. MetalLabelUI
只需将文字画成灰色（Label.disabledForeground），而不是标签前景色。
paintDragWindow(Graphics) - Method in class javax.swing.plaf.basic. BasicToolBarUI
绘制用于拖动的窗口的内容。
paintDragWindow(Graphics) - Method in class javax.swing.plaf.synth. SynthToolBarUI
绘制用于拖动的窗口的内容。
paintDropLine(Graphics) - Method in class javax.swing.plaf.basic. BasicTreeUI
画下线。
paintDropLine(Graphics) - Method in class javax.swing.plaf.synth. SynthTreeUI
画下线。
paintEditorPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制编辑器窗格的背景。
paintEditorPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制编辑器窗格的边框。
paintEnabledText(JLabel, Graphics, String, int, int) - Method in class javax.swing.plaf.basic. BasicLabelUI
在textX上绘制clippedText，textY带有标签前景色。
Painter< T> - Interface in javax.swing
绘画代表。
PaintEvent - Class in java.awt.event
组件级paint事件。
PaintEvent(Component, int, Rectangle) - Constructor for class java.awt.event. PaintEvent
使用指定的源组件和类型构造一个 PaintEvent对象。
paintExpandControl(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI
绘制一行的展开（切换）部分。
paintExpandControl(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.synth. SynthTreeUI
绘制一行的展开（切换）部分。
paintFileChooserBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制文件选择器的背景。
paintFileChooserBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制文件选择器的边框。
paintFocus(Graphics) - Method in class javax.swing.plaf.basic. BasicSliderUI
油漆重点
paintFocus(Graphics) - Method in class javax.swing.plaf.metal. MetalSliderUI
paintFocus(Graphics, Rectangle, Dimension) - Method in class javax.swing.plaf.basic. BasicRadioButtonUI
油漆聚焦单选按钮。
paintFocus(Graphics, Rectangle, Dimension) - Method in class javax.swing.plaf.metal. MetalRadioButtonUI
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.basic. BasicButtonUI
涂一个专注的按钮。
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.metal. MetalButtonUI
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.metal. MetalToggleButtonUI
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制焦点指示器。
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
paintFormattedTextFieldBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制格式化文本字段的背景。
paintFormattedTextFieldBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制格式化文本字段的边框。
paintHighlightBelowTab() - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
油漆在下面的选项卡。
paintHorizontalLabel(Graphics, int, Component) - Method in class javax.swing.plaf.basic. BasicSliderUI
为标签表中的每个标签调用。
paintHorizontalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI
画一条水平线。
paintHorizontalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.synth. SynthTreeUI
画一条水平线。
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI
涂抹腿部的水平部分。
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.metal. MetalTreeUI
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.synth. SynthTreeUI
涂抹腿部的水平部分。
paintHorizontalSeparators(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalTreeUI
绘制水平分隔符。
paintIcon(Component, Graphics, int, int) - Method in interface javax.swing. Icon
在指定位置绘制图标。
paintIcon(Component, Graphics, int, int) - Method in class javax.swing. ImageIcon
画图标。
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf. IconUIResource
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalCheckBoxIcon
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalComboBoxIcon
涂上水平条
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalIconFactory.FileIcon16
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalIconFactory.FolderIcon16
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalIconFactory.PaletteCloseIcon
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeControlIcon
paintIcon(Component, Graphics, int, int) - Method in interface javax.swing.plaf.synth. SynthIcon
paintIcon(Graphics, int, int, Icon, Rectangle, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
画一个图标。
paintIcon(Graphics, AbstractButton, Rectangle) - Method in class javax.swing.plaf.basic. BasicToggleButtonUI
在指定位置绘制图标。
paintIcon(Graphics, AbstractButton, Rectangle) - Method in class javax.swing.plaf.metal. MetalToggleButtonUI
在空间 iconRect绘制按钮 b的相应图标。
paintIcon(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.basic. BasicButtonUI
绘制当前按钮的图标。
paintIcon(Icon, SynthContext, Graphics, int, int, int, int) - Static method in class javax.swing.plaf.synth. SynthGraphicsUtils
画图标。
paintIcon(SynthContext, Graphics, int, int, int, int) - Method in interface javax.swing.plaf.synth. SynthIcon
在给定的合成器上下文的指定位置绘制图标。
paintImmediately(int, int, int, int) - Method in class javax.swing. JComponent
立即绘制该组件及其与该区域重叠的所有后代的指定区域。
paintImmediately(int, int, int, int) - Method in class javax.swing. JLayer
将其功能委托给 LayerUI.paintImmediately(int, int, int, int, JLayer)方法，如果设置了 LayerUI 。
paintImmediately(int, int, int, int, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
JLayer在 JLayer的指定区域，这个 LayerUI被设置为立即。
paintImmediately(Rectangle) - Method in class javax.swing. JComponent
现在涂漆指定区域。
paintIncreaseHighlight(Graphics) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
涂抹增加亮点。
paintIndeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI
所有的线性弹跳框进度条都应该做正确的事情。
paintIndeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalProgressBarUI
在进度条和弹跳框上绘制一点特别的亮点。
paintInternalFrameBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
描绘内部框架的背景。
paintInternalFrameBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制内部框架的边框。
paintInternalFrameTitlePaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制内部框架标题窗格的背景。
paintInternalFrameTitlePaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制内部框架标题窗格的边框。
paintLabelBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
涂上标签的背景。
paintLabelBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
涂上标签的边框。
paintLabels(Graphics) - Method in class javax.swing.plaf.basic. BasicSliderUI
涂上标签。
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text. DefaultHighlighter.DefaultHighlightPainter
画出一部分亮点。
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text. LayeredHighlighter.LayerPainter
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text. DefaultHighlighter
当叶视图（如LabelView）呈现时，它们应该调用此方法。
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text. LayeredHighlighter
当叶视图（如LabelView）呈现时，它们应该调用此方法。
paintLeftTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
画左标签边框。
paintListBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制列表的背景。
paintListBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制列表的边框。
paintLoweredBevel(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. BevelBorder
用指定的位置和大小绘制指定部件的下降斜面。
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic. BasicSliderUI
绘制水平滑块的主要刻度。
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal. MetalSliderUI
paintMajorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic. BasicSliderUI
绘制垂直滑块的主要刻度。
paintMajorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal. MetalSliderUI
paintMe(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal. MetalIconFactory.TreeControlIcon
TreeControlIcon 。
paintMenuBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个菜单的背景。
paintMenuBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个菜单栏的背景。
paintMenuBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制菜单栏的边框。
paintMenuBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个菜单的边框。
paintMenuItem(Graphics, JComponent, Icon, Icon, Color, Color, int) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
画一个菜单项。
paintMenuItemBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制菜单项的背景。
paintMenuItemBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制菜单项的边框。
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic. BasicSliderUI
为水平滑块绘制小刻度。
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal. MetalSliderUI
paintMinorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic. BasicSliderUI
为垂直滑块绘制小刻度。
paintMinorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal. MetalSliderUI
paintOptionPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制选项窗格的背景。
paintOptionPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制选项窗格的边框。
paintPalette(Graphics) - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
油漆调色板
paintPanelBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个面板的背景。
paintPanelBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个面板的边框。
paintPasswordFieldBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个密码字段的背景。
paintPasswordFieldBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制密码字段的边框。
paintPopupMenuBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个弹出菜单的背景。
paintPopupMenuBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制弹出菜单的边框。
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个进度条的背景。
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个进度条的背景。
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制进度条的边框。
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制进度条的边框。
paintProgressBarForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制进度条的前景。 负责提供进度条进度的指示。
paintProperty() - Method in class javafx.scene.effect. ColorInput
Paint用于洪水地区。
paintRadioButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个单选按钮的背景。
paintRadioButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个单选按钮的边框。
paintRadioButtonMenuItemBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制单选按钮菜单项的背景。
paintRadioButtonMenuItemBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制单选按钮菜单项的边框。
paintRaisedBevel(Component, Graphics, int, int, int, int) - Method in class javax.swing.border. BevelBorder
用指定的位置和大小绘制指定组件的凸起斜面。
paintRightTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
绘制正确的标签边框。
paintRootPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制根窗格的背景。
paintRootPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制根窗格的边框。
paintRow(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI
绘制一行的渲染器部分。
paintSafely(Graphics) - Method in class javax.swing.plaf.basic. BasicTextUI
保证界面安全，保证模型不会从此线程的视图中改变。
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条的背景。
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条的背景。
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条的边框。
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条的边框。
paintScrollBarThumbBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个滚动条的拇指的背景。
paintScrollBarThumbBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条的拇指的边框。
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条的轨迹的背景。
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条的轨迹的背景。
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条轨迹的边框。
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动条轨迹的边框。
paintScrollPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动窗格的背景。
paintScrollPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滚动窗格的边框。
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个分隔符的背景。
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个分隔符的背景。
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制分隔符的边框。
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制分隔符的边框。
paintSeparatorForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个分隔符的前景。
paintSliderBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的背景。
paintSliderBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的背景。
paintSliderBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的边框。
paintSliderBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的边框。
paintSliderThumbBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的拇指的背景。
paintSliderThumbBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的拇指的边框。
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的轨迹的背景。
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块的轨迹的背景。
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块轨迹的边框。
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制滑块轨迹的边框。
paintSpinnerBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个旋转器的背景。
paintSpinnerBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个旋转器的边框。
paintSplitPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制拆分窗格的背景。
paintSplitPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制拆分窗格的边框。
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制拆分窗格的分隔符的背景。
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制拆分窗格的分隔符的背景。
paintSplitPaneDividerForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制拆分窗格的分隔符的前景。
paintSplitPaneDragDivider(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
当用户拖动分隔线时，绘制分割窗格的分隔线。
paintString - Variable in class javax.swing. JProgressBar
是否在进度条上显示文本字符串。
paintString(Graphics, int, int, int, int, int, Insets) - Method in class javax.swing.plaf.basic. BasicProgressBarUI
绘制进度字符串。
paintTab(Graphics, int, Rectangle[], int, Rectangle, Rectangle) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
画一个标签。
paintTabArea(Graphics, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制标签区域中的选项卡。
paintTabArea(Graphics, int, int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
绘制标签背景。
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
paintTabbedPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的背景。
paintTabbedPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的边框。
paintTabbedPaneContentBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制包含选项卡窗格选定选项卡内容的区域的背景。
paintTabbedPaneContentBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制包含选项卡窗格选定选项卡内容的区域的边框。
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的选项卡后面区域的背景。
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的选项卡后面区域的背景。
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的标签后面区域的边框。
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的标签后面区域的边框。
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的选项卡的背景。
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的选项卡的背景。
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的选项卡的边框。
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制标签窗格的选项卡的边框。
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
此函数绘制每个选项卡周围的边框，该函数现在绘制该选项卡的背景。
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
paintTableBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一张桌子的背景。
paintTableBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一张桌子的边框。
paintTableHeaderBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制表格标题的背景。
paintTableHeaderBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制表格标题的边框。
paintText(Graphics, int, Font, FontMetrics, int, String, Rectangle, boolean) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
油漆文字。
paintText(Graphics, AbstractButton, Rectangle, String) - Method in class javax.swing.plaf.basic. BasicButtonUI
呈现当前按钮文本的方法。
paintText(Graphics, JComponent, Rectangle, String) - Method in class javax.swing.plaf.basic. BasicButtonUI
呈现当前按钮文本的方法。
paintText(Graphics, JComponent, Rectangle, String) - Method in class javax.swing.plaf.metal. MetalButtonUI
paintText(Graphics, JComponent, Rectangle, String) - Method in class javax.swing.plaf.metal. MetalToggleButtonUI
paintText(Graphics, JMenuItem, Rectangle, String) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
呈现当前菜单项的文本。
paintText(SynthContext, Graphics, String) - Method in class javax.swing.plaf.synth. SynthProgressBarUI
绘制组件的文本。
paintText(SynthContext, Graphics, String, int, int, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils
在指定位置绘制文本。
paintText(SynthContext, Graphics, String, Rectangle, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils
在指定位置绘制文本。
paintText(SynthContext, Graphics, String, Icon, int, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthGraphicsUtils
画一个图标和文字。
paintTextAreaBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个文本区域的背景。
paintTextAreaBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制文本区域的边框。
paintTextFieldBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制文本字段的背景。
paintTextFieldBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制文本字段的边框。
paintTextPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制文本窗格的背景。
paintTextPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制文本窗格的边框。
paintThumb(Graphics) - Method in class javax.swing.plaf.basic. BasicSliderUI
画拇指
paintThumb(Graphics) - Method in class javax.swing.plaf.metal. MetalSliderUI
paintThumb(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
画拇指
paintThumb(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.metal. MetalScrollBarUI
paintThumb(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth. SynthScrollBarUI
绘制滚动条拇指。
paintThumb(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth. SynthSliderUI
绘制滑块拇指。
paintTicks(Graphics) - Method in class javax.swing.plaf.basic. BasicSliderUI
油漆滴答
paintTitleBackground(Graphics) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
从paintComponent调用。
paintToggleButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一个切换按钮的背景。
paintToggleButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制切换按钮的边框。
paintToolBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏的背景。
paintToolBarBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏的背景。
paintToolBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏的边框。
paintToolBarBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏的边框。
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏内容区域的背景。
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏内容区域的背景。
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏的内容区域的边框。
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制工具栏的内容区域的边框。
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制包含工具栏的窗口的背景，当它与主框架分离时。
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制包含工具栏的窗口的背景，当它与主框架分离时。
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制包含工具栏的窗口的边框，当它与主框架分离时。
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制包含工具栏的窗口的边框，当它与主框架分离时。
paintToolTipBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
描绘工具提示的背景。
paintToolTipBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
涂抹工具尖端的边框。
paintTopTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
绘制顶部标签边框。
paintTrack(Graphics) - Method in class javax.swing.plaf.basic. BasicSliderUI
油漆轨道。
paintTrack(Graphics) - Method in class javax.swing.plaf.metal. MetalSliderUI
paintTrack(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
画轨道。
paintTrack(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.metal. MetalScrollBarUI
paintTrack(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth. SynthScrollBarUI
绘制滚动条轨道。
paintTrack(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth. SynthSliderUI
绘制滑块轨道。
paintTreeBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一棵树的背景。
paintTreeBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
画一棵树的边界。
paintTreeCellBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
在树中绘制包含单元格的行的背景。
paintTreeCellBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制包含树中单元格的行的边框。
paintTreeCellFocus(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
在树中具有焦点时，绘制单元格的焦点指示符。
paintTriangle(Graphics, int, int, int, int, boolean) - Method in class javax.swing.plaf.basic. BasicArrowButton
涂三角形
paintValue(Graphics, Rectangle) - Method in interface java.beans. PropertyEditor
将值的表示绘制到屏幕不动产的给定区域。
paintValue(Graphics, Rectangle) - Method in class java.beans. PropertyEditorSupport
将值的表示绘制到屏幕不动产的给定区域。
paintVerticalLabel(Graphics, int, Component) - Method in class javax.swing.plaf.basic. BasicSliderUI
为标签表中的每个标签调用。
paintVerticalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.basic. BasicTreeUI
画一条垂直线。
paintVerticalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.synth. SynthTreeUI
画一条垂直线。
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI
涂上腿部的垂直部分。
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - Method in class javax.swing.plaf.metal. MetalTreeUI
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - Method in class javax.swing.plaf.synth. SynthTreeUI
涂上腿部的垂直部分。
paintViewportBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制视口的背景。
paintViewportBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth. SynthPainter
绘制视口的边框。
Pair< K, V> - Class in javafx.util
一个方便的类来表示名称 - 值对。
Pair(K, V) - Constructor for class javafx.util. Pair
创建一个新的对
PALEGOLDENROD - Static variable in class javafx.scene.paint. Color
颜色淡黄色，RGB值为＃EEE8AA
PALEGREEN - Static variable in class javafx.scene.paint. Color
颜色淡绿色，RGB值为＃98FB98
PALETTE_LAYER - Static variable in class javax.swing. JLayeredPane
定义调色板层的方便对象。
PaletteBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.PaletteBorder
paletteCloseIcon - Variable in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
调色板关闭图标。
PaletteCloseIcon() - Constructor for class javax.swing.plaf.metal. MetalIconFactory.PaletteCloseIcon
paletteTitleHeight - Variable in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
调色板标题的高度。
PALETURQUOISE - Static variable in class javafx.scene.paint. Color
颜色淡绿色，RGB值为#AFEEEE
PALEVIOLETRED - Static variable in class javafx.scene.paint. Color
颜色为淡紫色，RGB值为＃DB7093
PALMYRENE - java.lang. Character.UnicodeScript
Unicode脚本“棕榈”。
PALMYRENE - Static variable in class java.lang. Character.UnicodeBlock
常数为“棕榈”Unicode字符块。
PAN - Static variable in class javax.sound.sampled. FloatControl.Type
表示信号的相对平移（左右定位）的控制。
Pane - Class in javafx.scene.layout
布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。
Pane() - Constructor for class javafx.scene.layout. Pane
创建一个窗格布局。
Pane(Node...) - Constructor for class javafx.scene.layout. Pane
创建一个窗格布局。
Panel - Class in java.awt
Panel是最简单的容器类。
Panel() - Constructor for class java.awt. Panel
使用默认布局管理器创建新面板。
Panel(LayoutManager) - Constructor for class java.awt. Panel
使用指定的布局管理器创建一个新面板。
PANEL - Static variable in class javax.accessibility. AccessibleRole
通常用于分组对象的通用容器。
PANEL - Static variable in class javax.swing.plaf.synth. Region
面板区域。
PANEL_UI - Static variable in class javax.print. ServiceUIFactory
表示作为AWT面板实现的UI。
Panel.AccessibleAWTPanel - Class in java.awt
该类实现 Panel类的可访问性支持。
PanelUI - Class in javax.swing.plaf
面板可插拔的外观和界面。
PanelUI() - Constructor for class javax.swing.plaf. PanelUI
pannableProperty() - Method in class javafx.scene.control. ScrollPane
指定用户是否应该能够使用鼠标平移视口。
pannableProperty() - Method in class javafx.scene.control.skin. VirtualFlow
指示VirtualFlow视口是否能够被用户平移（通过鼠标或触摸事件）。
panProperty() - Method in class javafx.scene.media. AudioClip
剪辑的相对“中心”。
PAPAYAWHIP - Static variable in class javafx.scene.paint. Color
颜色番木瓜鞭，RGB值为＃FFEFD5
Paper - Class in java.awt.print
Paper类描述了一张纸的物理特性。
Paper - Class in javafx.print
封装打印机使用的纸介质尺寸的类。
Paper() - Constructor for class java.awt.print. Paper
创建一个字母大小的纸，一英寸的边距。
PaperSource - Class in javafx.print
PaperSource是用于纸张的进纸盘。
paperSourceProperty() - Method in class javafx.print. JobSettings
代表 PaperSource的实例的 PaperSource 。
PARA_INDENT_LEFT - Static variable in class javax.swing.text.html. HTMLEditorKit
段落为缩进动作标识符
PARA_INDENT_RIGHT - Static variable in class javax.swing.text.html. HTMLEditorKit
段落正确的缩进动作标识符
PARAGRAPH - javafx.scene.control.skin. TextInputControlSkin.TextUnit
PARAGRAPH - Static variable in class javax.accessibility. AccessibleRole
一段文字。
PARAGRAPH_SEPARATOR - Static variable in class java.lang. Character
Unicode规范中的一般类别“Zp”。
ParagraphAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.ParagraphAction
ParagraphElementName - Static variable in class javax.swing.text. AbstractDocument
用于表示段落的元素的名称
ParagraphView - Class in javax.swing.text.html
显示一个段落，并使用css属性进行配置。
ParagraphView - Class in javax.swing.text
查看支持多种字体，颜色，组件，图标等的简单换行段落。
ParagraphView(Element) - Constructor for class javax.swing.text.html. ParagraphView
为给定元素构造ParagraphView。
ParagraphView(Element) - Constructor for class javax.swing.text. ParagraphView
为给定元素构造一个 ParagraphView 。
parallel() - Method in interface java.util.stream. BaseStream
返回平行的等效流。
parallel() - Method in interface java.util.stream. DoubleStream
parallel() - Method in interface java.util.stream. IntStream
parallel() - Method in interface java.util.stream. LongStream
ParallelCamera - Class in javafx.scene
指定用于渲染场景而不进行透视校正的并行相机。
ParallelCamera() - Constructor for class javafx.scene. ParallelCamera
创建一个空的ParallelCamera实例。
parallelPrefix(double[], int, int, DoubleBinaryOperator) - Static method in class java.util. Arrays
对于数组的给定子范围执行 Arrays.parallelPrefix(double[], DoubleBinaryOperator) 。
parallelPrefix(double[], DoubleBinaryOperator) - Static method in class java.util. Arrays
使用提供的功能，并行地计算给定阵列的每个元素。
parallelPrefix(int[], int, int, IntBinaryOperator) - Static method in class java.util. Arrays
对于数组的给定子范围执行 Arrays.parallelPrefix(int[], IntBinaryOperator) 。
parallelPrefix(int[], IntBinaryOperator) - Static method in class java.util. Arrays
使用提供的功能，并行地计算给定阵列的每个元素。
parallelPrefix(long[], int, int, LongBinaryOperator) - Static method in class java.util. Arrays
对于数组的给定子范围执行 Arrays.parallelPrefix(long[], LongBinaryOperator) 。
parallelPrefix(long[], LongBinaryOperator) - Static method in class java.util. Arrays
使用提供的功能，并行地计算给定阵列的每个元素。
parallelPrefix(T[], int, int, BinaryOperator<T>) - Static method in class java.util. Arrays
对于数组的给定子范围执行 Arrays.parallelPrefix(Object[], BinaryOperator) 。
parallelPrefix(T[], BinaryOperator<T>) - Static method in class java.util. Arrays
使用提供的功能，并行地计算给定阵列的每个元素。
parallelSetAll(double[], IntToDoubleFunction) - Static method in class java.util. Arrays
使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
parallelSetAll(int[], IntUnaryOperator) - Static method in class java.util. Arrays
使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
parallelSetAll(long[], IntToLongFunction) - Static method in class java.util. Arrays
使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
parallelSetAll(T[], IntFunction<? extends T>) - Static method in class java.util. Arrays
使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。
parallelSort(byte[]) - Static method in class java.util. Arrays
按照数字顺序排列指定的数组。
parallelSort(byte[], int, int) - Static method in class java.util. Arrays
按照数字顺序排列数组的指定范围。
parallelSort(char[]) - Static method in class java.util. Arrays
按照数字顺序排列指定的数组。
parallelSort(char[], int, int) - Static method in class java.util. Arrays
按照数字顺序排列数组的指定范围。
parallelSort(double[]) - Static method in class java.util. Arrays
按照数字顺序排列指定的数组。
parallelSort(double[], int, int) - Static method in class java.util. Arrays
按照数字顺序排列数组的指定范围。
parallelSort(float[]) - Static method in class java.util. Arrays
按照数字顺序排列指定的数组。
parallelSort(float[], int, int) - Static method in class java.util. Arrays
按照数字顺序排列数组的指定范围。
parallelSort(int[]) - Static method in class java.util. Arrays
按照数字顺序排列指定的数组。
parallelSort(int[], int, int) - Static method in class java.util. Arrays
按照数字顺序排列数组的指定范围。
parallelSort(long[]) - Static method in class java.util. Arrays
按照数字顺序排列指定的数组。
parallelSort(long[], int, int) - Static method in class java.util. Arrays
按照数字顺序排列数组的指定范围。
parallelSort(short[]) - Static method in class java.util. Arrays
按照数字顺序排列指定的数组。
parallelSort(short[], int, int) - Static method in class java.util. Arrays
按照数字顺序排列数组的指定范围。
parallelSort(T[]) - Static method in class java.util. Arrays
根据其元素的natural ordering按照升序排列指定的对象数组。
parallelSort(T[], int, int) - Static method in class java.util. Arrays
根据其元素的natural ordering ，按照升序排列指定数组对象的指定范围。
parallelSort(T[], int, int, Comparator<? super T>) - Static method in class java.util. Arrays
根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。
parallelSort(T[], Comparator<? super T>) - Static method in class java.util. Arrays
根据指定的比较器引发的顺序对指定的对象数组进行排序。
parallelStream() - Method in interface java.util. Collection
返回可能并行的 Stream与此集合作为其来源。
ParallelTransition - Class in javafx.animation
这Transition剧目Animations并行。
ParallelTransition() - Constructor for class javafx.animation. ParallelTransition
构造函数为 ParallelTransition 。
ParallelTransition(Animation...) - Constructor for class javafx.animation. ParallelTransition
构造函数为 ParallelTransition 。
ParallelTransition(Node) - Constructor for class javafx.animation. ParallelTransition
构造函数为 ParallelTransition 。
ParallelTransition(Node, Animation...) - Constructor for class javafx.animation. ParallelTransition
构造函数为 ParallelTransition 。
param - Variable in class javax.swing.text.html.parser. DTD
与param对应的元素
PARAM - com.sun.source.doctree. DocTree.Kind
用于表示@param标签的ParamTree的实例。
PARAM - Static variable in class javax.swing.text.html. HTML.Tag
标签<param>
PARAM_HOST_NAME - Static variable in class jdk.jshell.execution. JdiExecutionControlProvider
要连接的本地主机名。
PARAM_IN - Static variable in class org.omg.CORBA. ParameterMode
PARAM_INOUT - Static variable in class org.omg.CORBA. ParameterMode
PARAM_LAUNCH - Static variable in class jdk.jshell.execution. JdiExecutionControlProvider
应该使用JDI控制发射吗？
PARAM_OUT - Static variable in class org.omg.CORBA. ParameterMode
PARAM_REMOTE_AGENT - Static variable in class jdk.jshell.execution. JdiExecutionControlProvider
远程代理启动。
PARAM_TIMEOUT - Static variable in class jdk.jshell.execution. JdiExecutionControlProvider
连接超时前的毫秒数。
Parameter - Class in java.lang.reflect
有关方法参数的信息。
Parameter - Class in org.omg.Dynamic
org / omg / Dynamic / Parameter.java。
Parameter - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
Parameter() - Constructor for class org.omg.Dynamic. Parameter
Parameter(Any, ParameterMode) - Constructor for class org.omg.Dynamic. Parameter
PARAMETER - java.lang.annotation. ElementType
正式参数声明
PARAMETER - javax.lang.model.element. ElementKind
方法或构造函数的参数。
PARAMETER - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于PARAMETER
parameterArray() - Method in class java.lang.invoke. MethodType
将参数类型显示为数组（方便方法）。
ParameterBlock - Class in java.awt.image.renderable
A ParameterBlock封装了所有关于RenderableImageOp或处理图像的其他类所需的源和参数（对象）的信息。
ParameterBlock() - Constructor for class java.awt.image.renderable. ParameterBlock
一个虚拟构造函数。
ParameterBlock(Vector<Object>) - Constructor for class java.awt.image.renderable. ParameterBlock
构造一个 ParameterBlock与给定矢量的源。
ParameterBlock(Vector<Object>, Vector<Object>) - Constructor for class java.awt.image.renderable. ParameterBlock
构造一个 ParameterBlock与给定矢量的源和参数矢量。
parameterComment() - Method in interface com.sun.javadoc. ParamTag
已过时。
返回与此 ParamTag相关联的参数注释。
parameterCount() - Method in class java.lang.invoke. MethodType
返回此方法类型中的参数类型数。
ParameterDescriptor - Class in java.beans
ParameterDescriptor类允许bean实现者提供关于每个参数的附加信息，超出java.lang.reflect.Method类提供的低级类型信息。
ParameterDescriptor() - Constructor for class java.beans. ParameterDescriptor
公共默认构造函数。
Parameterizable - Interface in javax.lang.model.element
用于具有类型参数的元素的mixin接口。
PARAMETERIZED_TYPE - com.sun.source.tree. Tree.Kind
用于ParameterizedTypeTree的实例。
ParameterizedType - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
ParameterizedType - Interface in java.lang.reflect
ParameterizedType表示一个参数化类型，如Collection <String>。
ParameterizedTypeTree - Interface in com.sun.source.tree
涉及类型参数的类型表达式的树节点。
parameterList() - Method in class java.lang.invoke. MethodType
将参数类型显示为列表（方便方法）。
ParameterMetaData - Interface in java.sql
可用于获取有关 PreparedStatement对象中每个参数标记的类型和属性的 PreparedStatement对象。
ParameterMode - Class in org.omg.CORBA
枚举参数的参数模式。
ParameterMode(int) - Constructor for class org.omg.CORBA. ParameterMode
ParameterModeHelper - Class in org.omg.CORBA
枚举参数的参数模式。
ParameterModeHelper() - Constructor for class org.omg.CORBA. ParameterModeHelper
ParameterModeHolder - Class in org.omg.CORBA
枚举参数的参数模式。
ParameterModeHolder() - Constructor for class org.omg.CORBA. ParameterModeHolder
ParameterModeHolder(ParameterMode) - Constructor for class org.omg.CORBA. ParameterModeHolder
parameterModeIn - Static variable in interface java.sql. ParameterMetaData
常数表示参数的模式为IN。
parameterModeInOut - Static variable in interface java.sql. ParameterMetaData
常数表示参数的模式为INOUT。
parameterModeOut - Static variable in interface java.sql. ParameterMetaData
常数表示参数的模式为OUT。
parameterModeUnknown - Static variable in interface java.sql. ParameterMetaData
常数表示参数的模式未知。
parameterModifiers() - Static method in class java.lang.reflect. Modifier
返回一个值 int OR-ing组合在一起可以应用于参数的源语言修饰符。
parameterName() - Method in interface com.sun.javadoc. ParamTag
已过时。
返回与此 ParamTag相关联的参数或类型参数的名称。
parameterNoNulls - Static variable in interface java.sql. ParameterMetaData
该常量指示参数不允许 NULL值。
parameterNullable - Static variable in interface java.sql. ParameterMetaData
该常量指示一个参数将允许 NULL值。
parameterNullableUnknown - Static variable in interface java.sql. ParameterMetaData
指示参数的无效性的常数未知。
parameters - Variable in class java.awt.image.renderable. ParameterBlock
非源参数向量，存储为任意对象。
parameters() - Method in interface com.sun.javadoc. ExecutableMemberDoc
已过时。
获取参数信息。
Parameters() - Constructor for class javafx.application. Application.Parameters
构造一个新的 Parameters实例。
parameterType(int) - Method in class java.lang.invoke. MethodType
在此方法类型中返回指定索引处的参数类型。
parameterTypes() - Method in class jdk.jshell. MethodSnippet
方法的参数类型的字符串表示形式。
params(NVList) - Method in class org.omg.CORBA. ServerRequest
已过时。
使用方法arguments
paramString() - Method in class java.awt. AWTEvent
返回表示 Event的状态的字符串。
paramString() - Method in class java.awt. Button
返回一个表示 Button状态的字符串。
paramString() - Method in class java.awt. Checkbox
返回表示 Checkbox的状态的字符串。
paramString() - Method in class java.awt. CheckboxMenuItem
返回一个表示 CheckBoxMenuItem状态的字符串。
paramString() - Method in class java.awt. Choice
返回表示此 Choice菜单状态的字符串。
paramString() - Method in class java.awt. Component
返回表示此组件状态的字符串。
paramString() - Method in class java.awt. Container
返回一个表示 Container的状态的字符串。
paramString() - Method in class java.awt. Dialog
返回表示此对话框状态的字符串。
paramString() - Method in class java.awt.event. ActionEvent
返回标识此操作事件的参数字符串。
paramString() - Method in class java.awt.event. AdjustmentEvent
paramString() - Method in class java.awt.event. ComponentEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. ContainerEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. FocusEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. HierarchyEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. InputMethodEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. InvocationEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. ItemEvent
返回标识此项事件的参数字符串。
paramString() - Method in class java.awt.event. KeyEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. MouseEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. MouseWheelEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt.event. PaintEvent
paramString() - Method in class java.awt. Event
已过时。
注意： Event类已过时，仅适用于向后兼容性。
paramString() - Method in class java.awt.event. TextEvent
返回标识此文本事件的参数字符串。
paramString() - Method in class java.awt.event. WindowEvent
返回标识此事件的参数字符串。
paramString() - Method in class java.awt. FileDialog
返回一个表示 FileDialog窗口状态的字符串。
paramString() - Method in class java.awt. Frame
返回表示 Frame的状态的字符串。
paramString() - Method in class java.awt. Label
返回一个表示 Label状态的字符串。
paramString() - Method in class java.awt. List
返回表示此滚动列表状态的参数字符串。
paramString() - Method in class java.awt. Menu
返回一个表示 Menu状态的字符串。
paramString() - Method in class java.awt. MenuComponent
返回一个表示 MenuComponent状态的字符串。
paramString() - Method in class java.awt. MenuItem
返回一个表示 MenuItem状态的字符串。
paramString() - Method in class java.awt. MenuShortcut
返回表示此MenuShortcut状态的参数字符串。
paramString() - Method in class java.awt. Scrollbar
返回表示 Scrollbar的状态的字符串。
paramString() - Method in class java.awt. ScrollPane
返回表示 ScrollPane的状态的字符串。
paramString() - Method in class java.awt. ScrollPaneAdjustable
返回一个表示此滚动条状态的字符串。
paramString() - Method in class java.awt. TextArea
返回一个表示 TextArea状态的字符串。
paramString() - Method in class java.awt. TextComponent
返回一个表示 TextComponent状态的字符串。
paramString() - Method in class java.awt. TextField
返回一个表示 TextField状态的字符串。
paramString() - Method in class javax.swing. AbstractButton
返回此 AbstractButton的字符串表示 AbstractButton 。
paramString() - Method in class javax.swing.event. InternalFrameEvent
返回标识此事件的参数字符串。
paramString() - Method in class javax.swing. JApplet
已过时。
返回此JApplet的字符串表示形式。
paramString() - Method in class javax.swing. JButton
返回此 JButton的字符串表示 JButton 。
paramString() - Method in class javax.swing. JCheckBox
返回此JCheckBox的字符串表示形式。
paramString() - Method in class javax.swing. JCheckBoxMenuItem
返回此JCheckBoxMenuItem的字符串表示形式。
paramString() - Method in class javax.swing. JColorChooser
返回此 JColorChooser的字符串表示 JColorChooser 。
paramString() - Method in class javax.swing. JComboBox
返回此 JComboBox的字符串表示 JComboBox 。
paramString() - Method in class javax.swing. JComponent
返回此 JComponent的字符串表示 JComponent 。
paramString() - Method in class javax.swing. JDesktopPane
返回此 JDesktopPane的字符串表示 JDesktopPane 。
paramString() - Method in class javax.swing. JDialog
返回此 JDialog的字符串表示 JDialog 。
paramString() - Method in class javax.swing. JEditorPane
返回此 JEditorPane的字符串表示 JEditorPane 。
paramString() - Method in class javax.swing. JFileChooser
返回此 JFileChooser的字符串表示 JFileChooser 。
paramString() - Method in class javax.swing. JFrame
返回此 JFrame的字符串表示 JFrame 。
paramString() - Method in class javax.swing. JInternalFrame
返回此 JInternalFrame的字符串表示 JInternalFrame 。
paramString() - Method in class javax.swing. JLabel
返回此JLabel的字符串表示形式。
paramString() - Method in class javax.swing. JLayeredPane
返回此JLayeredPane的字符串表示形式。
paramString() - Method in class javax.swing. JList
返回此 JList的 String表示。
paramString() - Method in class javax.swing. JMenu
返回此 JMenu的字符串表示 JMenu 。
paramString() - Method in class javax.swing. JMenuBar
返回此 JMenuBar的字符串表示 JMenuBar 。
paramString() - Method in class javax.swing. JMenuItem
返回此 JMenuItem的字符串表示 JMenuItem 。
paramString() - Method in class javax.swing. JOptionPane
返回此 JOptionPane的字符串表示 JOptionPane 。
paramString() - Method in class javax.swing. JPanel
返回此JPanel的字符串表示形式。
paramString() - Method in class javax.swing. JPasswordField
返回此 JPasswordField的字符串表示 JPasswordField 。
paramString() - Method in class javax.swing. JPopupMenu
返回此 JPopupMenu的字符串表示 JPopupMenu 。
paramString() - Method in class javax.swing. JProgressBar
返回此 JProgressBar的字符串表示 JProgressBar 。
paramString() - Method in class javax.swing. JRadioButton
返回此JRadioButton的字符串表示形式。
paramString() - Method in class javax.swing. JRadioButtonMenuItem
返回此 JRadioButtonMenuItem的字符串表示 JRadioButtonMenuItem 。
paramString() - Method in class javax.swing. JRootPane
返回此 JRootPane的字符串表示 JRootPane 。
paramString() - Method in class javax.swing. JScrollBar
返回此JScrollBar的字符串表示形式。
paramString() - Method in class javax.swing. JScrollPane
返回此 JScrollPane的字符串表示 JScrollPane 。
paramString() - Method in class javax.swing. JSeparator
返回此 JSeparator的字符串表示 JSeparator 。
paramString() - Method in class javax.swing. JSlider
返回此JSlider的字符串表示形式。
paramString() - Method in class javax.swing. JSplitPane
返回此 JSplitPane的字符串表示 JSplitPane 。
paramString() - Method in class javax.swing. JTabbedPane
返回此 JTabbedPane的字符串表示 JTabbedPane 。
paramString() - Method in class javax.swing. JTable
返回此表的字符串表示形式。
paramString() - Method in class javax.swing. JTextArea
返回此JTextArea的字符串表示形式。
paramString() - Method in class javax.swing. JTextField
返回此 JTextField的字符串表示 JTextField 。
paramString() - Method in class javax.swing. JTextPane
返回此 JTextPane的字符串表示 JTextPane 。
paramString() - Method in class javax.swing. JToggleButton
返回此JToggleButton的字符串表示形式。
paramString() - Method in class javax.swing. JToolBar
返回此 JToolBar的字符串表示 JToolBar 。
paramString() - Method in class javax.swing. JToolTip
返回此 JToolTip的字符串表示 JToolTip 。
paramString() - Method in class javax.swing. JTree
返回此 JTree的字符串表示 JTree 。
paramString() - Method in class javax.swing. JViewport
返回此 JViewport的字符串表示 JViewport 。
paramString() - Method in class javax.swing. JWindow
返回此 JWindow的字符串表示 JWindow 。
paramString() - Method in class javax.swing.table. JTableHeader
返回此 JTableHeader的字符串表示 JTableHeader 。
paramString() - Method in class javax.swing.text. JTextComponent
返回此 JTextComponent的字符串表示 JTextComponent 。
ParamTag - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
paramTags() - Method in interface com.sun.javadoc. ExecutableMemberDoc
已过时。
返回此方法中的参数标签，不包括类型参数标签。
ParamTree - Interface in com.sun.source.doctree
@param块标记的树节点。
parent - Variable in class java.awt.image. Raster
此栅格的父项，或null。
parent - Variable in class java.util. ResourceBundle
此捆绑包的父捆绑。
parent - Variable in class javax.swing.tree. DefaultMutableTreeNode
该节点的父节点，如果此节点没有父节点，则为null
parent() - Method in interface com.sun.jdi. ThreadGroupReference
返回此线程组的父级。
parent() - Method in interface java.lang. ProcessHandle
返回父进程的 Optional<ProcessHandle> 。
parent() - Method in class java.util.prefs. AbstractPreferences
实现 parent方法按照在本说明书中 Preferences.parent() 。
parent() - Method in class java.util.prefs. Preferences
返回此首选项节点的父节点，如果是根节点，则返回 null 。
parent() - Method in class org.omg.CORBA. Context
检索此 Context对象的父项。
Parent - Class in javafx.scene
在场景图中有子节点的所有节点的基类。
Parent() - Constructor for class javafx.scene. Parent
构造一个新的 Parent 。
PARENT - javafx.scene. AccessibleAttribute
返回节点的父节点。
PARENT - javafx.scene. AccessibleRole
家长角色。
PARENT_CHANGED - Static variable in class java.awt.event. HierarchyEvent
更改标志表示 HIERARCHY_CHANGED事件是由重新启动操作生成的。
PARENT_MENU - javafx.scene. AccessibleAttribute
返回节点的父菜单。
PARENT_WINDOW_OF - Static variable in class javax.accessibility. AccessibleRelation
表示对象是一个或多个对象的父窗口。
PARENT_WINDOW_OF_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation
表示两个或多个对象之间的 PARENT_WINDOW_OF关系已更改。
parentColumnProperty() - Method in class javafx.scene.control. TableColumnBase
在使用嵌套列的情况下，此只读属性将始终引用此列的父级。
PARENTHESIZED - com.sun.source.tree. Tree.Kind
用于ParenthesizedTree的实例。
PARENTHESIZED - jdk.nashorn.api.tree. Tree.Kind
用于ParenthesizedTree的实例。
ParenthesizedTree - Interface in com.sun.source.tree
括号表达式的树节点。
ParenthesizedTree - Interface in jdk.nashorn.api.tree
括号表达式的树节点。
parentMenuProperty() - Method in class javafx.scene.control. MenuItem
这是Menu在此MenuItem存在。
parentNode() - Method in interface org.w3c.dom.traversal. TreeWalker
移动并返回当前节点的最近可见的祖先节点。
parentOf(ThreadGroup) - Method in class java.lang. ThreadGroup
测试此线程组是线程组参数还是其祖先线程组之一。
parentPopupProperty() - Method in class javafx.scene.control. MenuItem
这是ContextMenu ，其中MenuItem存在。
parentProperty() - Method in class javafx.scene.control. TreeItem
表示此TreeItem父项的属性。
parentProperty() - Method in class javafx.scene. Node
这是 Node的父母。
parents() - Method in class java.lang.module. Configuration
按照搜索顺序返回此配置的父母的不可修改列表。
parents() - Method in class java.lang. ModuleLayer
返回这个图层的父母的列表，除非这是 empty layer ，它没有父母，所以返回一个空列表。
parentTag - Variable in class javax.swing.text.html. HTMLEditorKit.InsertHTMLTextAction
在文档中检查的标签。
parentToLocal(double, double) - Method in class javafx.scene. Node
将一个点从母体的坐标空间转换为该 Node的局部坐标空间。
parentToLocal(double, double, double) - Method in class javafx.scene. Node
将一个点从父母的坐标空间转换为此 Node的局部坐标空间。
parentToLocal(Bounds) - Method in class javafx.scene. Node
将矩形从母体的坐标空间转换为此 Node的局部坐标空间。
parentToLocal(Point2D) - Method in class javafx.scene. Node
将一个点从父节点的坐标空间转换为此 Node的局部坐标空间。
parentToLocal(Point3D) - Method in class javafx.scene. Node
将一个点从母体的坐标空间转换为此 Node的局部坐标空间。
park() - Static method in class java.util.concurrent.locks. LockSupport
禁止当前线程进行线程调度，除非许可证可用。
park(Object) - Static method in class java.util.concurrent.locks. LockSupport
禁止当前线程进行线程调度，除非许可证可用。
parkNanos(long) - Static method in class java.util.concurrent.locks. LockSupport
禁用当前线程进行线程调度，直到指定的等待时间，除非许可证可用。
parkNanos(Object, long) - Static method in class java.util.concurrent.locks. LockSupport
禁用当前线程进行线程调度，直到指定的等待时间，除非许可证可用。
parkUntil(long) - Static method in class java.util.concurrent.locks. LockSupport
禁用当前线程进行线程调度，直到指定的截止日期，除非许可证可用。
parkUntil(Object, long) - Static method in class java.util.concurrent.locks. LockSupport
禁用当前线程进行线程调度，直到指定的截止日期，除非许可证可用。
parse() - Method in class com.sun.source.util. JavacTask
解析指定的文件，返回抽象语法树列表。
parse(File) - Method in class javax.xml.parsers. DocumentBuilder
将给定文件的内容解析为XML文档，并返回一个新的DOM Document对象。
parse(File, DiagnosticListener) - Method in interface jdk.nashorn.api.tree. Parser
解析源文件并返回编译单元树
parse(File, HandlerBase) - Method in class javax.xml.parsers. SAXParser
使用指定的HandlerBase解析指定为XML的文件的内容。
parse(File, DefaultHandler) - Method in class javax.xml.parsers. SAXParser
使用指定的DefaultHandler解析指定为XML的文件的内容。
parse(InputStream) - Method in class javax.xml.parsers. DocumentBuilder
将给定的InputStream的内容解析为XML文档并返回一个新的DOM Document对象。
parse(InputStream, String) - Method in class javax.xml.parsers. DocumentBuilder
将给定的InputStream的内容解析为XML文档并返回一个新的DOM Document对象。
parse(InputStream, HandlerBase) - Method in class javax.xml.parsers. SAXParser
使用指定的HandlerBase将给定的InputStream实例的内容解析为XML。
parse(InputStream, HandlerBase, String) - Method in class javax.xml.parsers. SAXParser
使用指定的HandlerBase将给定的InputStream实例的内容解析为XML。
parse(InputStream, DefaultHandler) - Method in class javax.xml.parsers. SAXParser
使用指定的DefaultHandler将给定的InputStream实例的内容解析为XML。
parse(InputStream, DefaultHandler, String) - Method in class javax.xml.parsers. SAXParser
使用指定的DefaultHandler将给定的InputStream实例的内容解析为XML。
parse(Reader) - Method in class javax.swing.text.html.parser. Parser
解析一个HTML流，给出一个DTD。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - Method in class javax.swing.text.html. HTMLEditorKit.Parser
解析给定的流，并使用解析的结果驱动给定的回调。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - Method in class javax.swing.text.html.parser. DocumentParser
解析一个HTML流，给出一个DTD。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - Method in class javax.swing.text.html.parser. ParserDelegator
parse(CharSequence) - Static method in class java.time. Duration
从文本字符串获取 Duration ，如 PnDTnHnMn.nS 。
parse(CharSequence) - Method in class java.time.format. DateTimeFormatter
完全解析产生时间对象的文本。
parse(CharSequence) - Static method in class java.time. Instant
从文本字符串（例如 2007-12-03T10:15:30.00Z获取 Instant的实例。
parse(CharSequence) - Static method in class java.time. LocalDate
从文本字符串（例如 2007-12-03获取 LocalDate的实例。
parse(CharSequence) - Static method in class java.time. LocalDateTime
从文本字符串（例如 2007-12-03T10:15:30获取 LocalDateTime的实例。
parse(CharSequence) - Static method in class java.time. LocalTime
从文本字符串（例如 10:15获取 LocalTime的实例。
parse(CharSequence) - Static method in class java.time. MonthDay
从文本字符串（例如 --12-03获取 MonthDay的实例。
parse(CharSequence) - Static method in class java.time. OffsetDateTime
从文本字符串（例如 2007-12-03T10:15:30+01:00获取 OffsetDateTime的实例。
parse(CharSequence) - Static method in class java.time. OffsetTime
从 10:15:30+01:00等文本字符串获取 OffsetTime的实例。
parse(CharSequence) - Static method in class java.time. Period
从文本字符串获取 Period ，如 PnYnMnD 。
parse(CharSequence) - Static method in class java.time. Year
从文本字符串（例如 2007获取 Year的实例。
parse(CharSequence) - Static method in class java.time. YearMonth
从文本字符串获取 YearMonth的实例，如 2007-12 。
parse(CharSequence) - Static method in class java.time. ZonedDateTime
从文本字符串（例如 2007-12-03T10:15:30+01:00[Europe/Paris]获取 ZonedDateTime的实例。
parse(CharSequence, ParsePosition) - Method in class java.time.format. DateTimeFormatter
使用此格式化器解析文本，提供对文本位置的控制。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. LocalDate
使用特定的格式化程序从文本字符串获取 LocalDate的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. LocalDateTime
使用特定的格式化程序从文本字符串获取一个 LocalDateTime的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. LocalTime
使用特定的格式化程序从文本字符串获取 LocalTime的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. MonthDay
使用特定的格式化程序从文本字符串获取 MonthDay的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. OffsetDateTime
使用特定的格式化程序从文本字符串获取 OffsetDateTime的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. OffsetTime
使用特定的格式化程序从文本字符串获取 OffsetTime的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. Year
使用特定的格式化程序从文本字符串获取 Year的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. YearMonth
使用特定的格式化程序从文本字符串获取 YearMonth的实例。
parse(CharSequence, DateTimeFormatter) - Static method in class java.time. ZonedDateTime
使用特定的格式化程序从文本字符串获取 ZonedDateTime的实例。
parse(CharSequence, TemporalQuery<T>) - Method in class java.time.format. DateTimeFormatter
完全解析产生指定类型对象的文本。
parse(String) - Static method in class java.lang.module. ModuleDescriptor.Version
将给定的字符串解析为版本字符串。
parse(String) - Static method in class java.lang. Runtime.Version
将给定的字符串解析为有效的 version string，其中包含一个 version number，其后是预发布和构建信息。
parse(String) - Static method in class java.net. HttpCookie
从set-cookie或set-cookie2头字符串构造cookie。
parse(String) - Method in class java.text. DateFormat
从给定字符串的开始解析文本以生成日期。
parse(String) - Method in class java.text. MessageFormat
从给定字符串的开头解析文本以产生一个对象数组。
parse(String) - Method in class java.text. NumberFormat
从给定字符串的开头解析文本以产生一个数字。
parse(String) - Static method in class java.util. Date
已过时。
从JDK 1.1版开始，由DateFormat.parse(String s)替代。
parse(String) - Static method in class java.util. Locale.LanguageRange
解析给定的 ranges以生成语言优先级列表。
parse(String) - Static method in class java.util.logging. Level
将级别名称字符串解析为级别。
parse(String) - Method in class javafx.css. CssParser
从CSS文档字符串创建样式表。
parse(String) - Method in class javax.activation. MimeTypeParameterList
用于从String解析参数列表的例程。
parse(String) - Method in interface javax.naming. NameParser
在其组件中解析名称。
parse(String) - Method in class javax.xml.parsers. DocumentBuilder
将给定URI的内容解析为XML文档，并返回一个新的DOM Document对象。
parse(String) - Method in class org.xml.sax.helpers. ParserAdapter
解析一个XML文档。
parse(String) - Method in class org.xml.sax.helpers. XMLFilterImpl
解析文件
parse(String) - Method in class org.xml.sax.helpers. XMLReaderAdapter
解析文件。
parse(String) - Method in interface org.xml.sax. Parser
已过时。
从系统标识符（URI）解析XML文档。
parse(String) - Method in interface org.xml.sax. XMLReader
从系统标识符（URI）解析XML文档。
parse(String, Reader, DiagnosticListener) - Method in interface jdk.nashorn.api.tree. Parser
解读读者并返回编译单元树
parse(String, String) - Method in class javafx.css. CssParser
使用docbase作为解析样式表中的引用的基本URL从CSS文档字符串创建样式表。
parse(String, String, boolean) - Static method in class jdk.nashorn.api.scripting. ScriptUtils
将AST返回为JSON兼容字符串。
parse(String, String, DiagnosticListener) - Method in interface jdk.nashorn.api.tree. Parser
解析字符串源并返回编译单元树
parse(String, ParsePosition) - Method in class java.text. ChoiceFormat
从输入文本中解析一个数字。
parse(String, ParsePosition) - Method in class java.text. DateFormat
根据给定的解析位置解析日期/时间字符串。
parse(String, ParsePosition) - Method in class java.text. DecimalFormat
从字符串中解析文本，产生一个 Number 。
parse(String, ParsePosition) - Method in class java.text. MessageFormat
解析字符串。
parse(String, ParsePosition) - Method in class java.text. NumberFormat
如果可能，返回长（例如，在[Long.MIN_VALUE，Long.MAX_VALUE]范围内，无小数），否则为Double。
parse(String, ParsePosition) - Method in class java.text. SimpleDateFormat
从字符串中解析文本以产生一个 Date 。
parse(String, Map<String, List<String>>) - Static method in class java.util. Locale.LanguageRange
解析给定的 ranges生成语言优先级列表，然后使用给定的 map自定义列表。
parse(String, HandlerBase) - Method in class javax.xml.parsers. SAXParser
使用指定的HandlerBase解析使用给定统一资源标识符（URI）作为XML描述的内容。
parse(String, DefaultHandler) - Method in class javax.xml.parsers. SAXParser
使用指定的DefaultHandler解析使用给定统一资源标识符（URI）作为XML描述的内容。
parse(URL) - Method in class javafx.css. CssParser
通过从URL读取CSS文档来更新给定的样式表，假设UTF-8编码。
parse(URL, DiagnosticListener) - Method in interface jdk.nashorn.api.tree. Parser
解析源URL并返回编译单元树
parse(Path, DiagnosticListener) - Method in interface jdk.nashorn.api.tree. Parser
解析源路径并返回编译单元树
parse(ScriptObjectMirror, DiagnosticListener) - Method in interface jdk.nashorn.api.tree. Parser
从脚本对象解析源并返回编译单元树
parse(LSInput) - Method in interface org.w3c.dom.ls. LSParser
从由 LSInput标识的资源中解析XML文档。
parse(InputSource) - Method in class javax.xml.parsers. DocumentBuilder
将给定输入源的内容解析为XML文档，并返回一个新的DOM Document对象。
parse(InputSource) - Method in class org.xml.sax.helpers. ParserAdapter
解析一个XML文档。
parse(InputSource) - Method in class org.xml.sax.helpers. XMLFilterImpl
解析文件
parse(InputSource) - Method in class org.xml.sax.helpers. XMLReaderAdapter
解析文件。
parse(InputSource) - Method in interface org.xml.sax. Parser
已过时。
解析一个XML文档。
parse(InputSource) - Method in interface org.xml.sax. XMLReader
解析一个XML文档。
parse(InputSource, HandlerBase) - Method in class javax.xml.parsers. SAXParser
解析给出的内容InputSource使用指定为XML HandlerBase 。
parse(InputSource, DefaultHandler) - Method in class javax.xml.parsers. SAXParser
解析给出的内容InputSource使用指定为XML DefaultHandler 。
PARSE - com.sun.source.util. TaskEvent.Kind
对于与解析文件有关的事件。
PARSE_ERR - Static variable in exception org.w3c.dom.ls. LSException
如果尝试使用 LSParser加载文档或XML片段，并且处理已停止。
parseAnySimpleType(String) - Static method in class javax.xml.bind. DatatypeConverter
返回一个包含简单类型的词法表示的字符串。
parseAnySimpleType(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
返回一个包含简单类型的词法表示的字符串。
parseBase64Binary(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为字节数组。
parseBase64Binary(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为字节数组。
parseBest(CharSequence, TemporalQuery<?>...) - Method in class java.time.format. DateTimeFormatter
完全解析产生指定类型之一的对象的文本。
parseBoolean(String) - Static method in class java.lang. Boolean
将字符串参数解析为布尔值。
parseBoolean(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为布尔值。
parseBoolean(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为布尔值。
parseBuffer - Variable in class javax.swing.text.html. HTMLDocument.HTMLReader
缓冲区以保持建筑元素。
parseByte(String) - Static method in class java.lang. Byte
将字符串参数解析为有符号的二进制 byte 。
parseByte(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为字节值。
parseByte(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为字节值。
parseByte(String, int) - Static method in class java.lang. Byte
将字符串参数解析为由第二个参数指定的基数中的带符号的 byte 。
parseCaseInsensitive() - Method in class java.time.format. DateTimeFormatterBuilder
将解析样式更改为格式化程序的其余部分不区分大小写。
parseCaseSensitive() - Method in class java.time.format. DateTimeFormatterBuilder
将解析样式更改为格式化程序的其余部分区分大小写。
ParseConversionEvent - Interface in javax.xml.bind
此事件表示将字符串从XML数据转换为目标Java数据类型的值时遇到问题。
ParseConversionEventImpl - Class in javax.xml.bind.helpers
ParseConversionEvent接口的默认实现。
ParseConversionEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers. ParseConversionEventImpl
创建一个新的ParseConversionEventImpl。
ParseConversionEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers. ParseConversionEventImpl
创建一个新的ParseConversionEventImpl。
parseDate(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为日历值。
parseDate(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为日历值。
parseDateTime(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为日历值。
parseDateTime(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为日历值。
parseDecimal(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为BigDecimal值。
parseDecimal(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为BigDecimal值。
parseDefaulting(TemporalField, long) - Method in class java.time.format. DateTimeFormatterBuilder
将字段的默认值追加到格式化程序以用于解析。
parsedExcessDays() - Static method in class java.time.format. DateTimeFormatter
一个查询，可以访问已解析的多余天数。
parsedLeapSecond() - Static method in class java.time.format. DateTimeFormatter
提供访问是否解析了跨越秒的查询。
parseDouble(String) - Static method in class java.lang. Double
返回一个新 double初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Double 。
parseDouble(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为双精度值。
parseDouble(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为双精度值。
parseDTDMarkup() - Method in class javax.swing.text.html.parser. Parser
解析文档类型声明标记声明。
ParsedValue< V, T> - Class in javafx.css
解析的CSS值的表示。
ParsedValue(V, StyleConverter<V, T>) - Constructor for class javafx.css. ParsedValue
创建ParsedValue的实例，其中使用给定的转换器将值类型V转换为目标类型T.
ParseError(String) - Constructor for class javafx.css. CssParser.ParseError
ParseException - Exception in java.text
表示解析时意外出现错误。
ParseException(String, int) - Constructor for exception java.text. ParseException
构造具有指定的详细消息和偏移量的ParseException。
parseFloat(String) - Static method in class java.lang. Float
返回一个新 float初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Float 。
parseFloat(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为浮点值。
parseFloat(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为浮点值。
parseHexBinary(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为字节数组。
parseHexBinary(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为字节数组。
parseInlineStyle(Styleable) - Method in class javafx.css. CssParser
从节点解析一个在线样式。
parseInt(CharSequence, int, int, int) - Static method in class java.lang. Integer
解析CharSequence参数作为有符号int指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
parseInt(String) - Static method in class java.lang. Integer
将字符串参数解析为带符号的十进制整数。
parseInt(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为int值。
parseInt(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为int值。
parseInt(String, int) - Static method in class java.lang. Integer
将字符串参数解析为第二个参数指定的基数中的有符号整数。
parseInteger(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为BigInteger值。
parseInteger(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为BigInteger值。
parseLenient() - Method in class java.time.format. DateTimeFormatterBuilder
将解析样式更改为对于格式化程序的其余部分来说宽松。
parseLevel(String) - Static method in class java.rmi.server. LogStream
已过时。
没有替换
parseLong(CharSequence, int, int, int) - Static method in class java.lang. Long
解析CharSequence参数作为有符号long指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
parseLong(String) - Static method in class java.lang. Long
解析字符串参数作为带符号的二进制数 long 。
parseLong(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为长整型值。
parseLong(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为长整型值。
parseLong(String, int) - Static method in class java.lang. Long
将字符串参数解析为第二个参数指定的基数中的带符号的 long 。
parseMarkupDeclarations(StringBuffer) - Method in class javax.swing.text.html.parser. Parser
解析标记声明。
parseNumbers() - Method in class java.io. StreamTokenizer
指定数字应由此分段器解析。
parseObject(String) - Method in class java.text. Format
从给定字符串的开头解析文本以产生一个对象。
parseObject(String, ParsePosition) - Method in class java.text. DateFormat
从字符串中解析文本，产生一个 Date 。
parseObject(String, ParsePosition) - Method in class java.text. Format
从字符串中解析文本以生成对象。
parseObject(String, ParsePosition) - Method in class java.text. MessageFormat
从字符串中解析文本以生成对象数组。
parseObject(String, ParsePosition) - Method in class java.text. NumberFormat
从字符串中解析文本，生成一个 Number 。
ParsePosition - Class in java.text
ParsePosition是一个简单的类，由 Format及其子类使用，用于在解析过程中跟踪当前位置。
ParsePosition(int) - Constructor for class java.text. ParsePosition
使用给定的初始索引创建一个新的ParsePosition。
parseQName(String, NamespaceContext) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为字节值。
parseQName(String, NamespaceContext) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为QName值。
Parser - Class in javax.swing.text.html.parser
一个简单的DTD驱动的HTML解析器。
Parser - Interface in jdk.nashorn.api.tree
代表nashorn ECMAScript解析器实例。
Parser - Interface in org.xml.sax
已过时。
该接口已被SAX2 XMLReader接口所取代，其中包括Namespace支持。
Parser() - Constructor for class javax.swing.text.html. HTMLEditorKit.Parser
Parser(DTD) - Constructor for class javax.swing.text.html.parser. Parser
使用指定的 dtd创建解析器。
ParserAdapter - Class in org.xml.sax.helpers
将SAX1解析器调整为SAX2 XMLReader。
ParserAdapter() - Constructor for class org.xml.sax.helpers. ParserAdapter
构造一个新的解析器适配器。
ParserAdapter(Parser) - Constructor for class org.xml.sax.helpers. ParserAdapter
构造一个新的解析器适配器。
ParserCallback() - Constructor for class javax.swing.text.html. HTMLEditorKit.ParserCallback
ParserConfigurationException - Exception in javax.xml.parsers
表示严重的配置错误。
ParserConfigurationException() - Constructor for exception javax.xml.parsers. ParserConfigurationException
创建一个新的 ParserConfigurationException没有详细信息。
ParserConfigurationException(String) - Constructor for exception javax.xml.parsers. ParserConfigurationException
创建一个新的 ParserConfigurationException ，其中 String指定为错误消息。
ParserDelegator - Class in javax.swing.text.html.parser
每次调用它的解析方法时，负责启动一个新的DocumentParser。
ParserDelegator() - Constructor for class javax.swing.text.html.parser. ParserDelegator
使用默认DTD创建 ParserDelegator 。
ParserFactory - Class in org.xml.sax.helpers
已过时。
此类与已弃用的Parser接口配合使用。
parseServerAuthority() - Method in class java.net. URI
尝试将此URI的权限组件（如果已定义）解析为用户信息，主机和端口组件。
parseShort(String) - Static method in class java.lang. Short
将字符串参数解析为有符号的二进制 short 。
parseShort(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为短值。
parseShort(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为短值。
parseShort(String, int) - Static method in class java.lang. Short
将字符串参数解析为第二个参数指定的基数中的带符号的 short 。
parseStrict() - Method in class java.time.format. DateTimeFormatterBuilder
将解析样式更改为严格的格式化程序的其余部分。
parseString(String) - Static method in class javax.xml.bind. DatatypeConverter
将词法XSD字符串参数转换为字符串值。
parseString(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为字符串。
parseTime(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为日历值。
parseTime(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为日历值。
parseUnresolved(CharSequence, ParsePosition) - Method in class java.time.format. DateTimeFormatter
使用此格式化程序解析文本，而无需解析结果，用于高级用例。
parseUnsignedInt(CharSequence, int, int, int) - Static method in class java.lang. Integer
解析CharSequence参数为一个无符号int在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
parseUnsignedInt(String) - Static method in class java.lang. Integer
将字符串参数解析为无符号十进制整数。
parseUnsignedInt(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为长整型值。
parseUnsignedInt(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为长整型值。
parseUnsignedInt(String, int) - Static method in class java.lang. Integer
将字符串参数解析为第二个参数指定的基数中的无符号整数。
parseUnsignedLong(CharSequence, int, int, int) - Static method in class java.lang. Long
解析CharSequence参数为一个无符号long在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
parseUnsignedLong(String) - Static method in class java.lang. Long
将字符串参数解析为无符号小数 long 。
parseUnsignedLong(String, int) - Static method in class java.lang. Long
将字符串参数解析为第二个参数指定的基数中的无符号 long 。
parseUnsignedShort(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为int值。
parseUnsignedShort(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为int值。
parseURI(String) - Method in interface org.w3c.dom.ls. LSParser
从由URI引用[ IETF RFC 2396 ]标识的位置解析XML文档。
parseURL(URL, String, int, int) - Method in class java.net. URLStreamHandler
将 URL的字符串表示解析为 URL对象。
parseWithContext(LSInput, Node, short) - Method in interface org.w3c.dom.ls. LSParser
从由 LSInput标识的资源中解析XML片段，并将内容插入到现有文档中，位置由 context和 action参数指定。
PART - jdk.incubator.http. WebSocket.MessagePart
序列中的消息的中间部分。
PART1_ALPHA2 - java.util. Locale.IsoCountryCode
PART1_ALPHA2用于表示ISO3166-1 alpha-2两个字母的国家代码。
PART1_ALPHA3 - java.util. Locale.IsoCountryCode
PART1_ALPHA3用于表示ISO3166-1 alpha-3三字母国家代码。
PART3 - java.util. Locale.IsoCountryCode
PART3用于表示ISO3166-3四个字母的国家/地区代码。
PartialResultException - Exception in javax.naming
抛出此异常以指示到目前为止返回或返回的结果是部分的，并且该操作无法完成。
PartialResultException() - Constructor for exception javax.naming. PartialResultException
构造一个新的PartialResultException实例。
PartialResultException(String) - Constructor for exception javax.naming. PartialResultException
使用指定的说明消息构造异常的新实例。
partitioningBy(Predicate<? super T>) - Static method in class java.util.stream. Collectors
返回 Collector由划分根据所述输入元件 Predicate ，并且将它们组织到一个 Map<Boolean, List<T>> 。
partitioningBy(Predicate<? super T>, Collector<? super T, A, D>) - Static method in class java.util.stream. Collectors
返回 Collector由划分根据所述输入元件 Predicate ，减少了在根据另一每个分区中的值 Collector ，并且将它们组织到一个 Map<Boolean, D>其值是下游减少的结果。
PASS - Static variable in interface java.util.jar. Pack200.Packer
字符串“pass”是某些属性的可能值。
PASS_FILE_PFX - Static variable in interface java.util.jar. Pack200.Packer
表示一个文件应该被传递通过，没有压缩。
passComplete(ImageReader, BufferedImage) - Method in interface javax.imageio.event. IIOReadUpdateListener
报告当前的读取操作已经完成了逐行通过。
passStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event. IIOReadUpdateListener
报告当前读取操作即将开始逐行传递。
password(String) - Method in interface java.sql. ConnectionBuilder
指定创建连接时要使用的密码
password(String) - Method in interface javax.sql. PooledConnectionBuilder
指定创建连接时要使用的密码
password(String) - Method in interface javax.sql. XAConnectionBuilder
指定创建连接时要使用的密码
PASSWORD_FIELD - javafx.scene. AccessibleRole
密码字段角色。
PASSWORD_FIELD - Static variable in class javax.swing.plaf.synth. Region
PasswordField区域。
PASSWORD_PROPERTY - Static variable in interface javax.xml.ws. BindingProvider
标准属性：验证密码。
PASSWORD_TEXT - Static variable in class javax.accessibility. AccessibleRole
用于密码的文本对象，或文本内容未被显示给用户的其他地方。
PasswordAuthentication - Class in java.net
PasswordAuthentication类是Authenticator使用的数据持有者。
PasswordAuthentication(String, char[]) - Constructor for class java.net. PasswordAuthentication
从给定的用户名和密码创建一个新的 PasswordAuthentication对象。
PasswordCallback - Class in javax.security.auth.callback
基础安全服务实例，并通过一个 PasswordCallback至 handle一个方法 CallbackHandler ，以获取密码信息。
PasswordCallback(String, boolean) - Constructor for class javax.security.auth.callback. PasswordCallback
构造一个带有提示和布尔值的 PasswordCallback ，指定是否应该在输入密码时显示密码。
PasswordField - Class in javafx.scene.control
掩码输入字符的文本字段。
PasswordField() - Constructor for class javafx.scene.control. PasswordField
创建一个默认的PasswordField实例。
PasswordProtection(char[]) - Constructor for class java.security. KeyStore.PasswordProtection
创建一个密码参数。
PasswordProtection(char[], String, AlgorithmParameterSpec) - Constructor for class java.security. KeyStore.PasswordProtection
创建密码参数，并指定在加密密钥库条目时使用的保护算法和相关参数。
PasswordView - Class in javax.swing.text
实现适合在JPasswordField UI实现中使用的视图。
PasswordView(Element) - Constructor for class javax.swing.text. PasswordView
构造一个包含在元素上的新视图。
paste() - Method in class javafx.scene.control. TextInputControl
将剪贴板中的内容传输到此文本中，替换当前选择。
paste() - Method in class javax.swing.text. JTextComponent
将系统剪贴板的内容传输到关联的文本模型中。
paste(int) - Method in interface javax.accessibility. AccessibleEditableText
将文本从系统剪贴板粘贴到从指定索引开始的文本。
paste(int) - Method in class javax.swing. JSpinner.AccessibleJSpinner
将文本从系统剪贴板粘贴到从指定索引开始的文本。
paste(int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent
将文本从系统剪贴板粘贴到从指定索引开始的文本。
PASTE - javafx.scene.input. KeyCode
常数为 Paste键。
PASTE - javafx.scene.web. HTMLEditorSkin.Command
pasteAction - Static variable in class javax.swing.text. DefaultEditorKit
将系统剪贴板的内容粘贴到所选区域或插入符之前的动作名称，如果未选择任何内容。
PasteAction() - Constructor for class javax.swing.text. DefaultEditorKit.PasteAction
使用相应的标识符创建此对象。
Patch - Class in javax.sound.midi
Patch对象表示在MIDI合成器上存储（加载）单个乐器的位置。
Patch(int, int) - Constructor for class javax.sound.midi. Patch
从指定的银行和程序编号构建一个新的补丁对象。
PATCH_MODULE_PATH - javax.tools. StandardLocation
搜索模块补丁的位置。
path - Variable in class javax.swing.event. TreeExpansionEvent
此事件代表的值的路径。
path - Variable in class javax.swing.event. TreeModelEvent
到已更改节点的父节点的路径。
Path - Class in javafx.scene.shape
Path类代表一个简单的形状，并提供了基本构建和管理几何路径所需的工具。
Path - Interface in java.nio.file
可用于在文件系统中定位文件的对象。
Path() - Constructor for class javafx.scene.shape. Path
创建一个空的路径实例。
Path(Collection<? extends PathElement>) - Constructor for class javafx.scene.shape. Path
创建路径的新实例
Path(PathElement...) - Constructor for class javafx.scene.shape. Path
创建一个新的路径实例
PATH_INFO - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：请求路径信息
PATH_TOO_LONG - java.security.cert. PKIXReason
路径长度约束已被违反。
Path2D - Class in java.awt.geom
Path2D类提供了一个简单而又灵活的形状，表示任意的几何路径。
Path2D.Double - Class in java.awt.geom
Double类定义了一个几何路径，坐标存储在双精度浮点中。
Path2D.Float - Class in java.awt.geom
Float类定义了具有存储在单精度浮点中的坐标的几何路径。
pathByAddingChild(Object) - Method in class javax.swing.tree. TreePath
返回一条新路径，其中包含此路径的所有元素加上 child 。
PathElement - Class in javafx.scene.shape
所述PathElement类表示的一个抽象元素Path能够表示像直线，圆弧，二次曲线，三次曲线等的任何几何对象
PathElement() - Constructor for class javafx.scene.shape. PathElement
pathFromAncestorEnumeration(TreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode
创建并返回从 ancestor到此节点的路径 ancestor的枚举。
PathIterator - Interface in java.awt.geom
PathIterator接口为实现Shape接口的对象提供了通过允许调用者一次检索该边界的路径来返回其边界的几何形状的机制。
PathMatcher - Interface in java.nio.file
由对路径执行匹配操作的对象实现的接口。
pathProperty() - Method in class javafx.animation. PathTransition
大纲节点应该被动画的形状。
paths - Variable in class javax.swing.event. TreeSelectionEvent
此事件代表的路径。
Paths - Class in java.nio.file
该类仅由静态方法组成，通过转换路径字符串返回Path或URI 。
PathSearchingVirtualMachine - Interface in com.sun.jdi
通过路径搜索类的虚拟机
pathSeparator - Static variable in class java.io. File
与系统相关的路径分隔符字符，为方便起见，表示为字符串。
pathSeparatorChar - Static variable in class java.io. File
与系统相关的路径分隔符。
pathToPoint(Point2D, boolean, Point2D) - Method in class java.awt.font. LayoutPath
将相对于路径的位置转换为用户坐标中的某个点。
PathTransition - Class in javafx.animation
这个 Transition创建了一个跨越其 PathTransition.duration的路径动画。
PathTransition() - Constructor for class javafx.animation. PathTransition
构造函数为 PathTransition 。
PathTransition(Duration, Shape) - Constructor for class javafx.animation. PathTransition
构造函数为 PathTransition 。
PathTransition(Duration, Shape, Node) - Constructor for class javafx.animation. PathTransition
构造函数为 PathTransition 。
PathTransition.OrientationType - Enum in javafx.animation
指定 node沿 path的直立方向。
pathWasCollapsed(TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI
VisibleTreeNode了 VisibleTreeNode之后就崩溃了。
pathWasExpanded(TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI
从 VisibleTreeNode消息 VisibleTreeNode之后就已经扩大了。
pattern - Variable in class javafx.util.converter. DateTimeStringConverter
pattern() - Method in class java.util.regex. Matcher
返回该匹配器解释的模式。
pattern() - Method in class java.util.regex. Pattern
返回编译此模式的正则表达式。
Pattern - Class in java.util.regex
正则表达式的编译表示。
PatternSyntaxException - Exception in java.util.regex
抛出未经检查的异常，以指示正则表达式模式中的语法错误。
PatternSyntaxException(String, String, int) - Constructor for exception java.util.regex. PatternSyntaxException
构造一个这个类的新实例。
PAU_CIN_HAU - java.lang. Character.UnicodeScript
Unicode脚本“Pau Cin Hau”。
PAU_CIN_HAU - Static variable in class java.lang. Character.UnicodeBlock
“Pau Cin Hau”Unicode字符块的常数。
pause() - Method in class javafx.animation. Animation
暂停动画。
pause() - Method in class javafx.scene.media. MediaPlayer
暂停播放器
PAUSE - javafx.scene.input. KeyCode
常数为 Pause键。
PAUSE - Static variable in class java.awt. Event
已过时。
暂停键，非ASCII操作键。
PAUSED - java.awt. Taskbar.State
显示进度为暂停，进度可以由用户恢复。
PAUSED - javafx.animation. Animation.Status
暂停状态。
PAUSED - javafx.scene.media. MediaPlayer.Status
播放暂停时播放器的状态
PAUSED - Static variable in class javax.print.attribute.standard. PrinterStateReason
有人暂停了打印机，打印机的PrinterState是STOPPED。
PauseTransition - Class in javafx.animation
这个 Transition在其 PauseTransition.duration的末尾执行一个 Animation.onFinished 。
PauseTransition() - Constructor for class javafx.animation. PauseTransition
构造函数为 PauseTransition
PauseTransition(Duration) - Constructor for class javafx.animation. PauseTransition
构造函数为 PauseTransition 。
PAYLOAD - javax.xml.ws. Service.Mode
有效载荷模式。
payloadProtocolID() - Method in class com.sun.nio.sctp. MessageInfo
返回有效负载协议标识符。
payloadProtocolID(int) - Method in class com.sun.nio.sctp. MessageInfo
设置有效载荷协议标识符。
PBEKey - Interface in javax.crypto.interfaces
与PBE密钥的接口。
PBEKeySpec - Class in javax.crypto.spec
用户选择的密码，可用于基于密码的加密（ PBE ）。
PBEKeySpec(char[]) - Constructor for class javax.crypto.spec. PBEKeySpec
使用密码的构造方法。
PBEKeySpec(char[], byte[], int) - Constructor for class javax.crypto.spec. PBEKeySpec
构造函数采用密码，盐，迭代计数，生成固定密钥大小的PBE密码的PBEKey。
PBEKeySpec(char[], byte[], int, int) - Constructor for class javax.crypto.spec. PBEKeySpec
构造函数，它使用密码，盐，迭代计数和待导出的密钥长度来生成可变密钥大小的PBE密码的PBEKey。
PBEParameterSpec - Class in javax.crypto.spec
此类指定与 PKCS #5标准中定义的基于密码的加密（PBE）一起使用的参数集。
PBEParameterSpec(byte[], int) - Constructor for class javax.crypto.spec. PBEParameterSpec
构建PKCS＃5标准中定义的基于密码的加密参数集。
PBEParameterSpec(byte[], int, AlgorithmParameterSpec) - Constructor for class javax.crypto.spec. PBEParameterSpec
构建PKCS＃5标准中定义的基于密码的加密参数集。
PC - javafx.css. SizeUnits
pcdata - Variable in class javax.swing.text.html.parser. DTD
与pcdata对应的元素。
PCL - Static variable in class javax.print. DocFlavor.BYTE_ARRAY
文件风格与MIME类型= "application/vnd.hp-PCL" ，打印数据表示类名= "[B" （字节数组）。
PCL - Static variable in class javax.print. DocFlavor.INPUT_STREAM
文件风味与MIME类型= "application/vnd.hp-PCL" ，打印数据表示类名= "java.io.InputStream" （字节流）。
PCL - Static variable in class javax.print. DocFlavor.URL
文件风味与MIME类型= "application/vnd.hp-PCL" ，打印数据表示类名= "java.net.URL" 。
PCM_FLOAT - Static variable in class javax.sound.sampled. AudioFormat.Encoding
指定浮点PCM数据。
PCM_SIGNED - Static variable in class javax.sound.sampled. AudioFormat.Encoding
指定带符号的线性PCM数据。
PCM_UNSIGNED - Static variable in class javax.sound.sampled. AudioFormat.Encoding
指定无符号线性PCM数据。
pcSupport - Variable in class java.beans.beancontext. BeanContextChildSupport
该 PropertyChangeSupport与此 BeanContextChildSupport相关联。
PDF - Static variable in class javax.print. DocFlavor.BYTE_ARRAY
Doc风格与MIME类型= "application/pdf" ，打印数据表示类名= "[B" （字节数组）。
PDF - Static variable in class javax.print. DocFlavor.INPUT_STREAM
文件风格与MIME类型= "application/pdf" ，打印数据表示类名= "java.io.InputStream" （字节流）。
PDF - Static variable in class javax.print. DocFlavor.URL
文件风味与MIME类型= "application/pdf" ，打印数据表示类名= "java.net.URL" 。
PDLOverrideSupported - Class in javax.print.attribute.standard
类PDLOverrideSupported是打印属性类，枚举，表示打印机尝试覆盖嵌入在文档打印数据中的处理指令的能力，处理指令指定为打印数据之外的属性。
PDLOverrideSupported(int) - Constructor for class javax.print.attribute.standard. PDLOverrideSupported
使用给定的整数值构造一个新的PDL覆盖支持的枚举值。
PEACHPUFF - Static variable in class javafx.scene.paint. Color
彩色桃红色，其值为＃FFDAB9
peek() - Method in class java.util. ArrayDeque
检索但不删除由此deque表示的队列的头，或者如果此deque为空，则返回 null 。
peek() - Method in class java.util.concurrent. ArrayBlockingQueue
peek() - Method in interface java.util.concurrent. BlockingDeque
检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
peek() - Method in class java.util.concurrent. ConcurrentLinkedDeque
peek() - Method in class java.util.concurrent. ConcurrentLinkedQueue
peek() - Method in class java.util.concurrent. DelayQueue
检索但不删除此队列的头，如果此队列为空，则返回 null 。
peek() - Method in class java.util.concurrent. LinkedBlockingDeque
peek() - Method in class java.util.concurrent. LinkedBlockingQueue
peek() - Method in class java.util.concurrent. LinkedTransferQueue
peek() - Method in class java.util.concurrent. PriorityBlockingQueue
peek() - Method in class java.util.concurrent. SynchronousQueue
始终返回 null 。
peek() - Method in interface java.util. Deque
检索但不删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
peek() - Method in class java.util. LinkedList
检索但不删除此列表的头（第一个元素）。
peek() - Method in class java.util. PriorityQueue
peek() - Method in interface java.util. Queue
检索但不删除此队列的头，如果此队列为空，则返回 null 。
peek() - Method in class java.util. Stack
查看此堆栈顶部的对象，而不从堆栈中删除它。
peek() - Method in class javax.xml.stream.util. EventReaderDelegate
peek() - Method in interface javax.xml.stream. XMLEventReader
检查下一个XMLEvent，而不从流中读取它。
peek(InetAddress) - Method in class java.net. DatagramSocketImpl
仔细看看它是从哪里来的。
peek(Consumer<? super T>) - Method in interface java.util.stream. Stream
返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
peek(DoubleConsumer) - Method in interface java.util.stream. DoubleStream
返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
peek(IntConsumer) - Method in interface java.util.stream. IntStream
返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
peek(LongConsumer) - Method in interface java.util.stream. LongStream
返回由该流的元素组成的流，另外在从生成的流中消耗元素时对每个元素执行提供的操作。
peekData(DatagramPacket) - Method in class java.net. DatagramSocketImpl
仔细看看它是从哪里来的。
peekEvent() - Method in class java.awt. EventQueue
返回 EventQueue上的第一个事件，而不删除它。
peekEvent(int) - Method in class java.awt. EventQueue
返回具有指定ID的第一个事件（如果有）。
peekFirst() - Method in class java.util. ArrayDeque
peekFirst() - Method in class java.util.concurrent. ConcurrentLinkedDeque
peekFirst() - Method in class java.util.concurrent. LinkedBlockingDeque
peekFirst() - Method in interface java.util. Deque
检索但不删除此deque的第一个元素，如果此deque为空，则返回 null 。
peekFirst() - Method in class java.util. LinkedList
检索但不删除此列表的第一个元素，如果此列表为空，则返回 null 。
peekLast() - Method in class java.util. ArrayDeque
peekLast() - Method in class java.util.concurrent. ConcurrentLinkedDeque
peekLast() - Method in class java.util.concurrent. LinkedBlockingDeque
peekLast() - Method in interface java.util. Deque
检索但不删除此deque的最后一个元素，如果此deque为空，则返回 null 。
peekLast() - Method in class java.util. LinkedList
检索但不删除此列表的最后一个元素，如果此列表为空，则返回 null 。
peekNextLocalTask() - Static method in class java.util.concurrent. ForkJoinTask
返回，但不会取消调度或执行当前线程排队但尚未执行的任务（如果可以立即可用）。
PeerAddressChangeNotification - Class in com.sun.nio.sctp
多宿主对等体上的目标地址发生更改时发出的通知。
PeerAddressChangeNotification() - Constructor for class com.sun.nio.sctp. PeerAddressChangeNotification
初始化此类的新实例。
PeerAddressChangeNotification.AddressChangeEvent - Enum in com.sun.nio.sctp
定义在多宿主对等体遇到更改接口详细信息时发生到目标地址的地址更改事件的类型。
PENDING - javax.swing. SwingWorker.StateValue
初始 SwingWorker状态。
PENDING - Static variable in class javax.print.attribute.standard. JobState
该工作是开始处理的候选人，但尚未处理。
PENDING_HELD - Static variable in class javax.print.attribute.standard. JobState
该工作不是任何理由的处理候选人，但一旦原因不再存在，就会返回到待定状态。
PERCENT - javafx.css. SizeUnits
PERCENT - Static variable in class java.text. NumberFormat.Field
不断识别百分比字段。
PercentageStringConverter - Class in javafx.util.converter
StringConverter实现Number代表百分比的值。
PercentageStringConverter() - Constructor for class javafx.util.converter. PercentageStringConverter
PercentageStringConverter(NumberFormat) - Constructor for class javafx.util.converter. PercentageStringConverter
PercentageStringConverter(Locale) - Constructor for class javafx.util.converter. PercentageStringConverter
percentHeightProperty() - Method in class javafx.scene.layout. RowConstraints
行的高度百分比。
percentWidthProperty() - Method in class javafx.scene.layout. ColumnConstraints
列的宽度百分比。
perform_work() - Method in class org.omg.CORBA. ORB
如果主线程调用，则执行依赖于实现的工作单元。
performCommand(HTMLEditorSkin.Command) - Method in class javafx.scene.web. HTMLEditorSkin
某些命令的特殊情况处理。
performDefaultLayout() - Method in class java.awt.font. GlyphVector
为此 GlyphVector每个字形分配默认位置。
performQuit() - Method in interface java.awt.desktop. QuitResponse
通知外部退出请求者退出将进行，并执行默认值QuitStrategy 。
period(int, int, int) - Method in interface java.time.chrono. Chronology
根据几年，几个月和几天的时间表获得一段时间。
period(int, int, int) - Method in class java.time.chrono. IsoChronology
根据几年，几个月和几天的时间表获得一段时间。
Period - Class in java.time
ISO-8601日历系统中的日期时间，例如“2年3个月4天”。
PERIOD - javafx.scene.input. KeyCode
期间关键的常数“”。
periodProperty() - Method in class javafx.concurrent. ScheduledService
允许在最后一次运行开始和下次运行开始之间的最短时间。
PERMILLE - Static variable in class java.text. NumberFormat.Field
常数识别容错字段。
Permission - Class in java.security
用于表示访问系统资源的抽象类。
Permission - Interface in java.security.acl
已过时。
自1.2版起，该软件包已被java.security.Policy及相关课程所取代。
Permission(String) - Constructor for class java.security. Permission
构造具有指定名称的权限。
PermissionCollection - Class in java.security
代表Permission对象集合的抽象类。
PermissionCollection() - Constructor for class java.security. PermissionCollection
permissions() - Method in class java.nio.file.attribute. AclEntry
返回权限组件的副本。
permissions() - Method in interface java.nio.file.attribute. PosixFileAttributes
返回文件的权限。
permissions() - Method in interface java.security.acl. AclEntry
已过时。
返回此ACL条目中权限的枚举。
Permissions - Class in java.security
此类表示许多权限的异构集合。
Permissions() - Constructor for class java.security. Permissions
创建一个不包含PermissionCollections的新Permissions对象。
permits(Set<CryptoPrimitive>, String, AlgorithmParameters) - Method in interface java.security. AlgorithmConstraints
确定是否为算法授予了指定的加密原语的权限。
permits(Set<CryptoPrimitive>, String, Key, AlgorithmParameters) - Method in interface java.security. AlgorithmConstraints
确定算法和相应的密钥是否被授予对指定的加密原语的许可。
permits(Set<CryptoPrimitive>, Key) - Method in interface java.security. AlgorithmConstraints
确定一个密钥是否被授予了指定的加密原语的权限。
permuteArguments(MethodHandle, MethodType, int...) - Static method in class java.lang.invoke. MethodHandles
生成方法句柄，通过重新排序参数，将方法句柄调整到新类型的调用顺序。
PERPIXEL_TRANSLUCENT - java.awt. GraphicsDevice.WindowTranslucency
表示在底层系统中支持包含或可能包含0.0和1.0之间任意α值的像素的Windows。
PERPIXEL_TRANSPARENT - java.awt. GraphicsDevice.WindowTranslucency
表示对底层系统的支持，每个像素的窗口保证完全不透明，alpha值为1.0，或者完全透明，Alpha值为0.0。
PERSIST - Static variable in class javax.swing. JFormattedTextField
常数确定当焦点丢失时，编辑的值应该保留。
PERSIST_STORE - Exception in org.omg.CORBA
此异常表示持续存储故障，例如，无法建立数据库连接或数据库损坏。
PERSIST_STORE() - Constructor for exception org.omg.CORBA. PERSIST_STORE
构造一个 PERSIST_STORE异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。
PERSIST_STORE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. PERSIST_STORE
构造具有指定的次要代码和完成状态的 PERSIST_STORE异常。
PERSIST_STORE(String) - Constructor for exception org.omg.CORBA. PERSIST_STORE
构造一个 PERSIST_STORE异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。
PERSIST_STORE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. PERSIST_STORE
构造一个 PERSIST_STORE异常与指定的描述消息，次要代码和完成状态。
persistence(Map<String, String>) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置包含输入历史记录和保留设置的持久信息的存储机制。
persistence(Preferences) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置包含输入历史记录和保留设置的持久信息的存储机制。
PersistenceDelegate - Class in java.beans
PersistenceDelegate类负责根据类的公共API中的方法来表达给定类的实例的状态。
PersistenceDelegate() - Constructor for class java.beans. PersistenceDelegate
PersistenceService - Interface in javax.jnlp
PersistenceService提供了在客户端系统上本地存储数据的方法，即使是在不受信任的执行环境中运行的应用程序。
PERSISTENT - Static variable in class org.omg.PortableServer. LifespanPolicyValue
PersistentMBean - Interface in javax.management
这个类是由MBeans实现的，旨在持久化的接口。
PersistentSnippet - Class in jdk.jshell
对持续存在并影响未来代码的片段进行分组。
PERSONAL - Static variable in class java.awt. PageAttributes.MediaType
PERSONAL_ENVELOPE的别名。
PERSONAL_ENVELOPE - Static variable in class java.awt. PageAttributes.MediaType
6 3/4信封的MediaType实例，3 5/8 x 6 1/2 in。
PERSONAL_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定个人信封尺寸，3.625英寸×6.5英寸。
PERSONAL_ENVELOPE - Static variable in class javax.print.attribute.standard. MediaSizeName
个人信封尺寸。
PerspectiveCamera - Class in javafx.scene
指定用于渲染场景的透视相机。
PerspectiveCamera() - Constructor for class javafx.scene. PerspectiveCamera
创建PerspectiveCamera的空实例。
PerspectiveCamera(boolean) - Constructor for class javafx.scene. PerspectiveCamera
用指定的fixedEyeAtCameraZero标志构建PerspectiveCamera。
PerspectiveTransform - Class in javafx.scene.effect
提供输入内容的非仿射变换的效果。
PerspectiveTransform() - Constructor for class javafx.scene.effect. PerspectiveTransform
使用默认参数创建PerspectiveTransform的新实例。
PerspectiveTransform(double, double, double, double, double, double, double, double) - Constructor for class javafx.scene.effect. PerspectiveTransform
用指定的ulx，uly，urx，ury，lrx，lry，llx和lly创建一个PerspectiveTransform的新实例。
PERU - Static variable in class javafx.scene.paint. Color
颜色为紫色，RGB值为＃CD853F
PGDN - Static variable in class java.awt. Event
已过时。
Page Down键，非ASCII操作键。
PGPData - Interface in javax.xml.crypto.dsig.keyinfo
PGPData中定义的XML PGPData元素的 表示 。
PGUP - Static variable in class java.awt. Event
已过时。
Page Up键，非ASCII操作键。
PHAGS_PA - java.lang. Character.UnicodeScript
Unicode脚本“Phags_Pa”。
PHAGS_PA - Static variable in class java.lang. Character.UnicodeBlock
“Phags-pa”Unicode字符块的常数。
PHAISTOS_DISC - Static variable in class java.lang. Character.UnicodeBlock
“Phaistos Disc”Unicode字符块的常量。
PhantomReference< T> - Class in java.lang.ref
在收集者确定其指示物可能被回收之后排入队列的Phantom参考对象。
PhantomReference(T, ReferenceQueue<? super T>) - Constructor for class java.lang.ref. PhantomReference
创建引用给定对象并在给定队列中注册的新幻影引用。
Phaser - Class in java.util.concurrent
一个可重复使用的同步屏障，功能类似于CyclicBarrier和CountDownLatch，但支持更灵活的使用。
Phaser() - Constructor for class java.util.concurrent. Phaser
创建一个新的移相器，没有最初的注册方，没有父级和初始阶段数0。
Phaser(int) - Constructor for class java.util.concurrent. Phaser
创建一个新的移相器与给定数量的注册无障碍方，没有父母和初始阶段0。
Phaser(Phaser) - Constructor for class java.util.concurrent. Phaser
相当于 Phaser(parent, 0) 。
Phaser(Phaser, int) - Constructor for class java.util.concurrent. Phaser
与给定的父母和注册的无礼方的数量创建一个新的移相器。
PHOENICIAN - java.lang. Character.UnicodeScript
Unicode脚本“腓尼基”。
PHOENICIAN - Static variable in class java.lang. Character.UnicodeBlock
“腓尼基”Unicode字符块的常数。
PHONETIC_EXTENSIONS - Static variable in class java.lang. Character.UnicodeBlock
常量为“语音扩展”Unicode字符块。
PHONETIC_EXTENSIONS_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“语音扩展补充”Unicode字符块的常数。
PhongMaterial - Class in javafx.scene.paint
PhongMaterial类提供了代表Phong阴影材料的属性的定义。
PhongMaterial() - Constructor for class javafx.scene.paint. PhongMaterial
使用默认的Color.WHITE diffuseColor属性创建一个新的 PhongMaterial类的实例。
PhongMaterial(Color) - Constructor for class javafx.scene.paint. PhongMaterial
使用指定的颜色为其创建 PhongMaterial类的新实例 diffuseColor属性。
PhongMaterial(Color, Image, Image, Image, Image) - Constructor for class javafx.scene.paint. PhongMaterial
使用指定的颜色和图像为其 diffuseColor属性创建一个新的实例 PhongMaterial类。
PHOTOMETRIC_INTERPRETATION_BLACK_IS_ZERO - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_CIELAB - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_CMYK - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_ICCLAB - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_PALETTE_COLOR - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_RGB - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_TRANSPARENCY_MASK - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_WHITE_IS_ZERO - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHOTOMETRIC_INTERPRETATION_Y_CB_CR - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
用于“光度测量解释”标签的值。
PHYSICAL - Static variable in class java.awt. PageAttributes.OriginType
用于指定物理原点的OriginType实例。
PI - Static variable in class java.lang. Math
double值比任何其他 pi更接近，圆周长与其直径的比率。
PI - Static variable in class java.lang. StrictMath
double值比任何其他的更接近 pi ，圆周长与其直径的比率。
PI - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于PI
PI_DISABLE_OUTPUT_ESCAPING - Static variable in interface javax.xml.transform. Result
如果结果树禁用输出转义，则发送的处理指令的名称。
PI_ENABLE_OUTPUT_ESCAPING - Static variable in interface javax.xml.transform. Result
如果结果树在接收到PI_DISABLE_OUTPUT_ESCAPING处理指令之后在某个时间点使输出转义，则发送的处理指令的名称。
pickOnBoundsProperty() - Method in class javafx.scene. Node
定义当由 MouseEvent或 contains函数调用触发时，如何为此节点完成拣选计算。
PickResult - Class in javafx.scene.input
包含pick事件结果的容器对象
PickResult(EventTarget, double, double) - Constructor for class javafx.scene.input. PickResult
为不需要额外信息的2D情况创建选择结果。
PickResult(Node, Point3D, double) - Constructor for class javafx.scene.input. PickResult
为非3d形状的目标创建一个新的PickResult实例。
PickResult(Node, Point3D, double, int, Point2D) - Constructor for class javafx.scene.input. PickResult
创建一个新的PickResult实例。
PickResult(Node, Point3D, double, int, Point3D, Point2D) - Constructor for class javafx.scene.input. PickResult
创建一个新的PickResult实例。
pid() - Method in class java.lang. Process
返回进程的本机进程ID。
pid() - Method in interface java.lang. ProcessHandle
返回进程的本机进程ID。
PIE - Static variable in class java.awt.geom. Arc2D
通过将直线段从弧段开始到完全椭圆的中心并从该点到弧段的末端将闭合类型关闭。
PieChart - Class in javafx.scene.chart
显示PieChart。
PieChart() - Constructor for class javafx.scene.chart. PieChart
构造一个新的空的PieChart。
PieChart(ObservableList<PieChart.Data>) - Constructor for class javafx.scene.chart. PieChart
用给定的数据构建一个新的PieChart
PieChart.Data - Class in javafx.scene.chart
PieChart数据项，表示PieChart中的一个切片
pieValueProperty() - Method in class javafx.scene.chart. PieChart.Data
饼图的值
pink - Static variable in class java.awt. Color
颜色粉红色。
PINK - Static variable in class java.awt. Color
颜色粉红色。
PINK - Static variable in class javafx.scene.paint. Color
颜色粉红色，RGB值为＃FFC0CB
Pipe - Class in java.nio.channels
实现单向管道的一对通道。
Pipe() - Constructor for class java.nio.channels. Pipe
初始化此类的新实例。
PIPE - java.lang. ProcessBuilder.Redirect.Type
类型 Redirect.PIPE 。
PIPE - Static variable in class java.lang. ProcessBuilder.Redirect
表示子流程I / O将通过管道连接到当前的Java进程。
PIPE_SIZE - Static variable in class java.io. PipedInputStream
管道循环输入缓冲区的默认大小。
Pipe.SinkChannel - Class in java.nio.channels
一个代表Pipe可写端的通道 。
Pipe.SourceChannel - Class in java.nio.channels
一个代表Pipe可读端的通道 。
PipedInputStream - Class in java.io
管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。
PipedInputStream() - Constructor for class java.io. PipedInputStream
创建一个 PipedInputStream ，使其尚未 connected 。
PipedInputStream(int) - Constructor for class java.io. PipedInputStream
创建一个 PipedInputStream ，使其尚未 connected，并为管道缓冲区使用指定的管道大小。
PipedInputStream(PipedOutputStream) - Constructor for class java.io. PipedInputStream
创建一个 PipedInputStream ，使其连接到管道输出流 src 。
PipedInputStream(PipedOutputStream, int) - Constructor for class java.io. PipedInputStream
创建一个 PipedInputStream ，使其连接到管道输出流 src并为管道缓冲区使用指定的管道大小。
PipedOutputStream - Class in java.io
管道输出流可以连接到管道输入流以创建通信管道。
PipedOutputStream() - Constructor for class java.io. PipedOutputStream
创建一个尚未连接到管道输入流的管道输出流。
PipedOutputStream(PipedInputStream) - Constructor for class java.io. PipedOutputStream
创建连接到指定管道输入流的管道输出流。
PipedReader - Class in java.io
流水字符输入流。
PipedReader() - Constructor for class java.io. PipedReader
创建一个 PipedReader ，使其尚未 connected 。
PipedReader(int) - Constructor for class java.io. PipedReader
创建一个 PipedReader ，使其尚未 connected并使用指定的管道大小作为管道的缓冲区。
PipedReader(PipedWriter) - Constructor for class java.io. PipedReader
创建一个 PipedReader ，使其连接到管道写入器 src 。
PipedReader(PipedWriter, int) - Constructor for class java.io. PipedReader
创建一个 PipedReader ，使其连接到管道写入器 src并为管道缓冲区使用指定的管道大小。
PipedWriter - Class in java.io
流水字符输出流。
PipedWriter() - Constructor for class java.io. PipedWriter
创建一个尚未连接到管道读取器的管道写入器。
PipedWriter(PipedReader) - Constructor for class java.io. PipedWriter
创建连接到指定管道读取器的管道写入器。
PITCH_BEND - Static variable in class javax.sound.midi. ShortMessage
Pitch Bend消息的命令值（0xE0或224）。
pivotXProperty() - Method in class javafx.scene.transform. Rotate
定义旋转枢轴点的X坐标。
pivotXProperty() - Method in class javafx.scene.transform. Scale
定义刻度出现点的X坐标。
pivotXProperty() - Method in class javafx.scene.transform. Shear
定义剪切枢轴点的X坐标。
pivotYProperty() - Method in class javafx.scene.transform. Rotate
定义旋转枢轴点的Y坐标。
pivotYProperty() - Method in class javafx.scene.transform. Scale
定义关于刻度出现点的Y坐标。
pivotYProperty() - Method in class javafx.scene.transform. Shear
定义剪切枢轴点的Y坐标。
pivotZProperty() - Method in class javafx.scene.transform. Rotate
定义旋转枢轴点的Z坐标。
pivotZProperty() - Method in class javafx.scene.transform. Scale
定义刻度出现点的Z坐标。
pixel_bits - Variable in class java.awt.image. ColorModel
像素中的总位数。
PixelFormat< T extends Buffer> - Class in javafx.scene.image
A PixelFormat对象定义给定格式的像素的数据布局。
PixelFormat.Type - Enum in javafx.scene.image
一个枚举，描述由PixelFormat管理的单个像素的阵列存储格式。
PixelGrabber - Class in java.awt.image
PixelGrabber类实现了一个ImageConsumer，它可以附加到Image或ImageProducer对象，以检索该图像中的像素的子集。
PixelGrabber(ImageProducer, int, int, int, int, int[], int, int) - Constructor for class java.awt.image. PixelGrabber
创建一个PixelGrabber对象，从指定的ImageProducer生成的图像中获取像素的（x，y，w，h）矩形部分到给定的数组中。
PixelGrabber(Image, int, int, int, int, boolean) - Constructor for class java.awt.image. PixelGrabber
创建一个PixelGrabber对象，从指定的图像中获取像素的（x，y，w，h）矩形部分。
PixelGrabber(Image, int, int, int, int, int[], int, int) - Constructor for class java.awt.image. PixelGrabber
创建一个PixelGrabber对象，将（x，y，w，h）像素的矩形部分从指定的图像进入给定的数组。
PixelInterleavedSampleModel - Class in java.awt.image
该类表示以像素交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
PixelInterleavedSampleModel(int, int, int, int, int, int[]) - Constructor for class java.awt.image. PixelInterleavedSampleModel
构造具有指定参数的PixelInterleavedSampleModel。
PixelReader - Interface in javafx.scene.image
该界面定义了从Image或包含像素的其他表面中检索像素数据的方法。
pixels() - Method in class javafx.css. Size
一个方便的方法来调用 pixels(1)
pixels(double, double, Font) - Method in enum javafx.css. SizeUnits
pixels(double, Font) - Method in class javafx.css. Size
将此大小转换为像素
pixels(Font) - Method in class javafx.css. Size
如果尺寸不是绝对尺寸，请返回字体大小的乘积，以像素和值为单位。
pixelStride - Variable in class java.awt.image. ComponentSampleModel
由该ComponentSampleModel描述的图像数据区域的像素（在数据数组元素中）。
PixelWriter - Interface in javafx.scene.image
该界面定义了用于写入WritableImage或包含可写入像素的其他表面的像素数据的方法。
PKCS12Attribute - Class in java.security
与PKCS12密钥库条目关联的属性。
PKCS12Attribute(byte[]) - Constructor for class java.security. PKCS12Attribute
从其ASN.1 DER编码构造PKCS12属性。
PKCS12Attribute(String, String) - Constructor for class java.security. PKCS12Attribute
从其名称和值构造PKCS12属性。
PKCS8EncodedKeySpec - Class in java.security.spec
该类代表私有密钥的ASN.1编码，根据ASN.1类型 PrivateKeyInfo编码。
PKCS8EncodedKeySpec(byte[]) - Constructor for class java.security.spec. PKCS8EncodedKeySpec
使用给定的编码密钥创建一个新的 PKCS8EncodedKeySpec 。
PKCS8EncodedKeySpec(byte[], String) - Constructor for class java.security.spec. PKCS8EncodedKeySpec
使用给定的编码密钥和算法创建一个新的 PKCS8EncodedKeySpec 。
PKIXBuilderParameters - Class in java.security.cert
参数用作PKIX CertPathBuilder算法的输入。
PKIXBuilderParameters(KeyStore, CertSelector) - Constructor for class java.security.cert. PKIXBuilderParameters
创建一个 PKIXBuilderParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。
PKIXBuilderParameters(Set<TrustAnchor>, CertSelector) - Constructor for class java.security.cert. PKIXBuilderParameters
使用指定的 Set最受信任的CA创建 PKIXBuilderParameters的实例。
PKIXCertPathBuilderResult - Class in java.security.cert
此类表示PKIX认证路径构建器算法的成功结果。
PKIXCertPathBuilderResult(CertPath, TrustAnchor, PolicyNode, PublicKey) - Constructor for class java.security.cert. PKIXCertPathBuilderResult
创建包含指定参数的 PKIXCertPathBuilderResult实例。
PKIXCertPathChecker - Class in java.security.cert
在 X509Certificate上执行一个或多个检查的抽象类。
PKIXCertPathChecker() - Constructor for class java.security.cert. PKIXCertPathChecker
默认构造函数。
PKIXCertPathValidatorResult - Class in java.security.cert
该类代表PKIX认证路径验证算法的成功结果。
PKIXCertPathValidatorResult(TrustAnchor, PolicyNode, PublicKey) - Constructor for class java.security.cert. PKIXCertPathValidatorResult
创建包含指定参数的 PKIXCertPathValidatorResult实例。
PKIXParameters - Class in java.security.cert
参数用作PKIX CertPathValidator算法的输入。
PKIXParameters(KeyStore) - Constructor for class java.security.cert. PKIXParameters
创建一个 PKIXParameters的实例，它从指定的 KeyStore包含的受信任证书条目填充最受信任的CA KeyStore 。
PKIXParameters(Set<TrustAnchor>) - Constructor for class java.security.cert. PKIXParameters
创建一个 PKIXParameters的实例，其中指定了 Set的最受信任的CA。
PKIXReason - Enum in java.security.cert
PKIXReason列举了根据PKIX（RFC 5280）标准，X.509认证路径可能无效的潜在PKIX特定原因。
PKIXRevocationChecker - Class in java.security.cert
A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。
PKIXRevocationChecker() - Constructor for class java.security.cert. PKIXRevocationChecker
默认构造函数。
PKIXRevocationChecker.Option - Enum in java.security.cert
可以为吊销检查机制指定的各种撤销选项。
placeholderProperty() - Method in class javafx.scene.control. ComboBox
当ComboBox没有内容显示时，该节点将显示给用户。
placeholderProperty() - Method in class javafx.scene.control. ListView
当列表视图没有显示的内容时，向用户显示该节点。
placeholderProperty() - Method in class javafx.scene.control. TableView
当表没有显示的内容时，向用户显示该节点。
placeholderProperty() - Method in class javafx.scene.control. TreeTableView
当表没有显示的内容时，向用户显示该节点。
PLAIN - Static variable in class java.awt. Font
平原风格常数。
PLAIN_DIALOG - Static variable in class javax.swing. JRootPane
用于windowDecorationStyle属性的常量。
PLAIN_MESSAGE - Static variable in class javax.swing. JOptionPane
没有使用图标。
PLAIN_TEXT - Static variable in class javafx.scene.input. DataFormat
表示纯文本字符串。
PlainDocument - Class in javax.swing.text
一个不保留字符属性的简单文档。
PlainDocument() - Constructor for class javax.swing.text. PlainDocument
构造一个纯文本文档。
PlainDocument(AbstractDocument.Content) - Constructor for class javax.swing.text. PlainDocument
构造一个纯文本文档。
plainTextFlavor - Static variable in class java.awt.datatransfer. DataFlavor
已过时。
截至1.3。 使用DataFlavor.getReaderForText(java.awt.datatransfer.Transferable)而不是Transferable.getTransferData(DataFlavor.plainTextFlavor) 。
PlainView - Class in javax.swing.text
实现一个简单的多行文本视图的视图界面，它具有一种字体和颜色的文本。
PlainView(Element) - Constructor for class javax.swing.text. PlainView
构造一个包含在元素上的新PlainView。
PLANAR_CONFIGURATION_CHUNKY - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“PlanarConfiguration”标签一起使用的值。
PLANAR_CONFIGURATION_PLANAR - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“PlanarConfiguration”标签一起使用的值。
Platform - Class in javafx.application
应用平台支持类。
PLATFORM_CLASS_PATH - javax.tools. StandardLocation
搜索平台类的位置。
PlatformLoggingMXBean - Interface in java.lang.management
logging设施的管理界面。
PlatformManagedObject - Interface in java.lang.management
平台管理对象是用于监视和管理Java平台中的组件的JMX MXBean 。
play() - Method in interface java.applet. AudioClip
已过时。
开始播放此音频剪辑。
play() - Method in class javafx.animation. Animation
起着 Animation从在所指示的方向当前位置 rate 。
play() - Method in class javafx.scene.media. AudioClip
使用所有默认参数播放 AudioClip 。
play() - Method in class javafx.scene.media. MediaPlayer
开始播放媒体。
play(double) - Method in class javafx.scene.media. AudioClip
使用除卷外的所有默认参数播放 AudioClip 。
play(double, double, double, double, int) - Method in class javafx.scene.media. AudioClip
使用给定的参数播放 AudioClip 。
play(URL) - Method in class java.applet. Applet
已过时。
以指定的绝对URL播放音频剪辑。
play(URL, String) - Method in class java.applet. Applet
已过时。
播放给定URL的音频剪辑和与之相关的说明符。
PLAY - javafx.scene.input. KeyCode
常数为 Play键。
PLAYBACK_ERROR - javafx.scene.media. MediaException.Type
表示不属于任何其他预定义类别的播放错误。
PLAYBACK_HALTED - javafx.scene.media. MediaException.Type
表示导致停止播放的不可恢复的错误。
playFrom(String) - Method in class javafx.animation. Animation
从预定位置播放 Animation方便方法。
playFrom(Duration) - Method in class javafx.animation. Animation
从特定位置播放这个 Animation方便方法。
playFromStart() - Method in class javafx.animation. Animation
从正向起始位置播放 Animation 。
PLAYING - javafx.scene.media. MediaPlayer.Status
播放器正在播放时的状态。
PLAYING_CARDS - Static variable in class java.lang. Character.UnicodeBlock
常规为“纸牌”Unicode字符块。
playSound(Action) - Method in class javax.swing.plaf.basic. BasicLookAndFeel
如有需要，可 actionPerformed ， audioAction播放声音。
Plugin - Interface in com.sun.source.util
javac插件的接口。
pluginClassName - Variable in class javax.imageio.spi. ImageReaderWriterSpi
A String包含相关插件类的名称，最初为 null 。
PLUM - Static variable in class javafx.scene.paint. Color
颜色李子，RGB值为＃DDA0DD
plus() - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (+this) ，其标为 this.scale() 。
plus(long) - Method in enum java.time. DayOfWeek
返回这一天后指定天数的星期几。
plus(long) - Method in enum java.time. Month
返回指定月份之后的月份。
plus(long, TemporalUnit) - Method in interface java.time.chrono. ChronoLocalDate
返回与此对象相同类型的对象，并添加指定的句点。
plus(long, TemporalUnit) - Method in interface java.time.chrono. ChronoLocalDateTime
返回与此对象相同类型的对象，并添加指定的句点。
plus(long, TemporalUnit) - Method in interface java.time.chrono. ChronoZonedDateTime
返回与此对象相同类型的对象，并添加指定的句点。
plus(long, TemporalUnit) - Method in class java.time.chrono. HijrahDate
plus(long, TemporalUnit) - Method in class java.time.chrono. JapaneseDate
plus(long, TemporalUnit) - Method in class java.time.chrono. MinguoDate
plus(long, TemporalUnit) - Method in class java.time.chrono. ThaiBuddhistDate
plus(long, TemporalUnit) - Method in class java.time. Duration
返回此持续时间的副本，并添加指定的持续时间。
plus(long, TemporalUnit) - Method in class java.time. Instant
返回添加指定数量的此瞬间的副本。
plus(long, TemporalUnit) - Method in class java.time. LocalDate
返回此日期的副本，并添加指定的金额。
plus(long, TemporalUnit) - Method in class java.time. LocalDateTime
返回此日期时间的副本，并添加指定的数量。
plus(long, TemporalUnit) - Method in class java.time. LocalTime
返回此时添加了指定数量的副本。
plus(long, TemporalUnit) - Method in class java.time. OffsetDateTime
返回此日期时间的副本，并添加指定的数量。
plus(long, TemporalUnit) - Method in class java.time. OffsetTime
返回此时添加了指定数量的副本。
plus(long, TemporalUnit) - Method in interface java.time.temporal. Temporal
返回与此对象相同类型的对象，并添加指定的句点。
plus(long, TemporalUnit) - Method in class java.time. Year
返回今年的副本，并附加指定的金额。
plus(long, TemporalUnit) - Method in class java.time. YearMonth
返回此年份的副本，并添加指定的金额。
plus(long, TemporalUnit) - Method in class java.time. ZonedDateTime
返回此日期时间的副本，并添加指定的数量。
plus(MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (+this) ，根据上下文设置进行舍入。
plus(Duration) - Method in class java.time. Duration
返回此持续时间的副本，并添加指定的持续时间。
plus(TemporalAmount) - Method in interface java.time.chrono. ChronoLocalDate
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in interface java.time.chrono. ChronoLocalDateTime
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in interface java.time.chrono. ChronoPeriod
返回指定期间添加的此期间的副本。
plus(TemporalAmount) - Method in interface java.time.chrono. ChronoZonedDateTime
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in class java.time.chrono. HijrahDate
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in class java.time.chrono. JapaneseDate
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in class java.time.chrono. MinguoDate
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in class java.time.chrono. ThaiBuddhistDate
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in class java.time. Instant
返回添加指定数量的此瞬间的副本。
plus(TemporalAmount) - Method in class java.time. LocalDate
返回此日期的副本，并添加指定的金额。
plus(TemporalAmount) - Method in class java.time. LocalDateTime
返回此日期时间的副本，并添加指定的数量。
plus(TemporalAmount) - Method in class java.time. LocalTime
返回此时添加了指定数量的副本。
plus(TemporalAmount) - Method in class java.time. OffsetDateTime
返回此日期时间的副本，并添加指定的数量。
plus(TemporalAmount) - Method in class java.time. OffsetTime
返回此时添加了指定数量的副本。
plus(TemporalAmount) - Method in class java.time. Period
返回指定期间添加的此期间的副本。
plus(TemporalAmount) - Method in interface java.time.temporal. Temporal
返回与此对象相同类型的对象，并添加一个金额。
plus(TemporalAmount) - Method in class java.time. Year
返回今年的副本，并附加指定的金额。
plus(TemporalAmount) - Method in class java.time. YearMonth
返回此年份的副本，并添加指定的金额。
plus(TemporalAmount) - Method in class java.time. ZonedDateTime
返回此日期时间的副本，并添加指定的数量。
plus(ValueExp, ValueExp) - Static method in class javax.management. Query
返回表示两个数值之和的二进制表达式，或两个字符串值的并置。
PLUS - com.sun.source.tree. Tree.Kind
用于实例BinaryTree代表加法或字符串连接+ 。
PLUS - javafx.scene.input. KeyCode
常数为“+”键。
PLUS - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree代表加法或字符串连接+ 。
PLUS - Static variable in class javax.management. Query
代表 Query.plus(javax.management.ValueExp, javax.management.ValueExp)表达式的代码。
PLUS_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于实例CompoundAssignmentTree代表加法或字符串连接分配+= 。
PLUS_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例CompoundAssignmentTree代表加法或字符串连接分配+= 。
plusDays(long) - Method in class java.time. Duration
在标准的24小时内添加指定的持续时间返回此持续时间的副本。
plusDays(long) - Method in class java.time. LocalDate
以指定的天数返回此 LocalDate的副本。
plusDays(long) - Method in class java.time. LocalDateTime
以指定的天数返回此 LocalDateTime的副本。
plusDays(long) - Method in class java.time. OffsetDateTime
以指定的天数返回此OffsetDateTime的副本。
plusDays(long) - Method in class java.time. Period
返回添加指定日期的此期间的副本。
plusDays(long) - Method in class java.time. ZonedDateTime
返回添加了指定天数的 ZonedDateTime的副本。
plusHours(long) - Method in class java.time. Duration
以指定的持续时间返回此持续时间的副本，小时数。
plusHours(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并附加指定的小时数。
plusHours(long) - Method in class java.time. LocalTime
返回此 LocalTime的副本，并附加指定的小时数。
plusHours(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并附加指定的小时数。
plusHours(long) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并附加指定的小时数。
plusHours(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并附加指定的小时数。
plusMillis(long) - Method in class java.time. Duration
以指定的持续时间（以毫秒为单位）返回此持续时间的副本。
plusMillis(long) - Method in class java.time. Instant
以毫秒为单位的指定持续时间返回此瞬间的副本。
plusMinutes(long) - Method in class java.time. Duration
以指定的持续时间（以分钟为单位）返回此持续时间的副本。
plusMinutes(long) - Method in class java.time. LocalDateTime
以指定的分钟数返回此 LocalDateTime的副本。
plusMinutes(long) - Method in class java.time. LocalTime
以指定的分钟数返回此 LocalTime的副本。
plusMinutes(long) - Method in class java.time. OffsetDateTime
以指定的分钟数返回此 OffsetDateTime的副本。
plusMinutes(long) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并添加指定的分钟数。
plusMinutes(long) - Method in class java.time. ZonedDateTime
以指定的分钟数返回此 ZonedDateTime的副本。
plusMonths(long) - Method in class java.time. LocalDate
返回此 LocalDate的副本，并附加指定的月数。
plusMonths(long) - Method in class java.time. LocalDateTime
返回添加了指定月数的 LocalDateTime的副本。
plusMonths(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并附加指定的月数。
plusMonths(long) - Method in class java.time. Period
返回添加指定月份的此期间的副本。
plusMonths(long) - Method in class java.time. YearMonth
返回这个 YearMonth的副本，并附加指定的月数。
plusMonths(long) - Method in class java.time. ZonedDateTime
返回这个 ZonedDateTime的副本，并附加指定的月数。
plusNanos(long) - Method in class java.time. Duration
以指定的持续时间返回此持续时间的副本，以纳秒为单位。
plusNanos(long) - Method in class java.time. Instant
以指定的持续时间返回此瞬间的副本，以纳秒为单位。
plusNanos(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本， LocalDateTime添加了指定的纳秒数。
plusNanos(long) - Method in class java.time. LocalTime
返回这个 LocalTime的副本， LocalTime添加了指定的纳秒数。
plusNanos(long) - Method in class java.time. OffsetDateTime
返回这个 OffsetDateTime的副本， OffsetDateTime添加了指定的纳秒数。
plusNanos(long) - Method in class java.time. OffsetTime
返回这个 OffsetTime的副本， OffsetTime添加了指定的纳秒数。
plusNanos(long) - Method in class java.time. ZonedDateTime
返回这个 ZonedDateTime的副本， ZonedDateTime添加了指定的纳秒数。
plusSeconds(long) - Method in class java.time. Duration
以指定的持续时间（以秒为单位）返回此持续时间的副本。
plusSeconds(long) - Method in class java.time. Instant
以指定的持续时间返回此瞬间的副本，以秒为单位。
plusSeconds(long) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并添加指定的秒数。
plusSeconds(long) - Method in class java.time. LocalTime
返回此 LocalTime的副本，并添加指定的秒数。
plusSeconds(long) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并添加指定的秒数。
plusSeconds(long) - Method in class java.time. OffsetTime
返回 OffsetTime的副本，并添加指定的秒数。
plusSeconds(long) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并添加指定的秒数。
plusWeeks(long) - Method in class java.time. LocalDate
以指定的周数返回此 LocalDate的副本。
plusWeeks(long) - Method in class java.time. LocalDateTime
以指定的周数返回此 LocalDateTime的副本。
plusWeeks(long) - Method in class java.time. OffsetDateTime
返回添加了指定周数的此OffsetDateTime的副本。
plusWeeks(long) - Method in class java.time. ZonedDateTime
以指定的周数返回此 ZonedDateTime的副本。
plusYears(long) - Method in class java.time. LocalDate
以指定的年数返回此 LocalDate的副本。
plusYears(long) - Method in class java.time. LocalDateTime
返回添加了指定年数的 LocalDateTime的副本。
plusYears(long) - Method in class java.time. OffsetDateTime
以指定的年数返回此 OffsetDateTime的副本。
plusYears(long) - Method in class java.time. Period
返回添加指定年份的此期间的副本。
plusYears(long) - Method in class java.time. Year
以指定的年数返回此 Year的副本。
plusYears(long) - Method in class java.time. YearMonth
以指定的年数返回此 YearMonth的副本。
plusYears(long) - Method in class java.time. ZonedDateTime
以指定的年数返回此 ZonedDateTime的副本。
PM - Static variable in class java.util. Calendar
Calendar.AM_PM字段的值表示从中午到午夜之前的一天中的一段时间。
PNG - Static variable in class javax.print. DocFlavor.BYTE_ARRAY
Doc风格与MIME类型= "image/png" ，打印数据表示类名= "[B" （字节数组）。
PNG - Static variable in class javax.print. DocFlavor.INPUT_STREAM
具有MIME类型的文档风味= "image/png" ，打印数据表示类名= "java.io.InputStream" （字节流）。
PNG - Static variable in class javax.print. DocFlavor.URL
Doc风格与MIME类型= "image/png" ，打印数据表示类名= "java.net.URL" 。
poa(Servant) - Method in interface org.omg.PortableServer.portable. Delegate
方法_poa（）等效于调用PortableServer :: Current：get_POA。
POA - Interface in org.omg.PortableServer
POA对象管理对象集合的实现。
POAHelper - Class in org.omg.PortableServer
POA对象管理对象集合的实现。
POAHelper() - Constructor for class org.omg.PortableServer. POAHelper
POAManager - Interface in org.omg.PortableServer
每个POA对象都有一个关联的POAManager对象。
POAManagerOperations - Interface in org.omg.PortableServer
每个POA对象都有一个关联的POAManager对象。
POAOperations - Interface in org.omg.PortableServer
POA对象管理对象集合的实现。
Point - Class in java.awt
表示 (x,y)坐标空间中的位置的点，以整数精度指定。
Point() - Constructor for class java.awt. Point
构造并初始化坐标空间原点（0，0）的点。
Point() - Constructor for class javafx.scene.effect. Light.Point
使用默认参数创建点光源的新实例。
Point(double, double, double, Color) - Constructor for class javafx.scene.effect. Light.Point
用指定的x，y，x和color创建一个新的点光实例。
Point(int, int) - Constructor for class java.awt. Point
构造并初始化坐标空间中指定的 (x,y)位置的点。
Point(Point) - Constructor for class java.awt. Point
构造和初始化与指定的 Point对象相同位置的点。
POINT_INFINITY - Static variable in class java.security.spec. ECPoint
这定义了无限远的点。
POINT_NORMAL_TEXCOORD - Static variable in class javafx.scene.shape. VertexFormat
指定由点，法线和纹理坐标组成的顶点的格式。
POINT_TEXCOORD - Static variable in class javafx.scene.shape. VertexFormat
指定由点和纹理坐标组成的顶点的格式。
Point2D - Class in java.awt.geom
Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
Point2D - Class in javafx.geometry
通常代表x，y坐标的二维几何点。
Point2D() - Constructor for class java.awt.geom. Point2D
这是一个无法直接实例化的抽象类。
Point2D(double, double) - Constructor for class javafx.geometry. Point2D
创建一个新的实例 Point2D 。
Point2D.Double - Class in java.awt.geom
Double类定义了 double精度指定的点。
Point2D.Float - Class in java.awt.geom
Float类定义浮点精度指定的点。
Point3D - Class in javafx.geometry
通常表示x，y，z坐标的3D几何点。
Point3D(double, double, double) - Constructor for class javafx.geometry. Point3D
创建一个新的实例 Point3D 。
PointerInfo - Class in java.awt
描述指针位置的类。
PointLight - Class in javafx.scene
定义点光源对象。
PointLight() - Constructor for class javafx.scene. PointLight
使用默认的Color.WHITE光源创建一个 PointLight类的新实例。
PointLight(Color) - Constructor for class javafx.scene. PointLight
使用指定的颜色创建一个新的 PointLight类的实例。
points(double, double, Font) - Method in enum javafx.css. SizeUnits
pointsAtXProperty() - Method in class javafx.scene.effect. Light.Spot
该光的方向矢量的x坐标。
pointsAtYProperty() - Method in class javafx.scene.effect. Light.Spot
该光的方向矢量的y坐标。
pointsAtZProperty() - Method in class javafx.scene.effect. Light.Spot
该光的方向矢量的z坐标。
pointSize - Variable in class java.awt. Font
该点的大小 Font在 float 。
pointToPath(Point2D, Point2D) - Method in class java.awt.font. LayoutPath
将用户空间中的点转换为相对于路径的位置。
Policy - Class in java.security
Policy对象负责确定在Java运行时环境中执行的代码是否具有执行安全敏感操作的权限。
Policy - Class in javax.security.auth
已过时。
从JDK版本1.4开始 - 由java.security.Policy替代。 java.security.Policy有一个方法：
  public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
和ProtectionDomain有一个构造函数：
  public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
这两个API为呼叫者提供查询基于Principal权限条目的策略的方法。
Policy - Interface in org.omg.CORBA
从 Policy接口派生的接口允许ORB或CORBA服务访问影响其操作的某些选择。
Policy() - Constructor for class java.security. Policy
Policy() - Constructor for class javax.security.auth. Policy
已过时。
唯一的构造函数。
POLICY_FORWARD_SECRECY - Static variable in class javax.security.sasl. Sasl
指定是否需要在会话之间实现向前保密的机制的属性的名称。
POLICY_NOACTIVE - Static variable in class javax.security.sasl. Sasl
指定是否允许容易受到活动（非字典）攻击的机制的属性的名称。
POLICY_NOANONYMOUS - Static variable in class javax.security.sasl. Sasl
指定是否允许接受匿名登录的机制的属性的名称。
POLICY_NODICTIONARY - Static variable in class javax.security.sasl. Sasl
指定是否允许容易受被动字典攻击的机制的属性的名称。
POLICY_NOPLAINTEXT - Static variable in class javax.security.sasl. Sasl
指定是否允许容易受到简单的被动攻击的机制（例如“PLAIN”）的属性的名称。
POLICY_PASS_CREDENTIALS - Static variable in class javax.security.sasl. Sasl
指定是否需要传递客户端凭据的机制的属性的名称。
policy_type() - Method in class org.omg.CORBA. _PolicyStub
返回与策略对象类型对应的常量值。
policy_type() - Method in interface org.omg.CORBA. PolicyOperations
返回与策略对象类型对应的常量值。
Policy.Parameters - Interface in java.security
这表示Policy参数的标记界面。
PolicyError - Exception in org.omg.CORBA
发生策略错误时抛出的用户异常。
PolicyError() - Constructor for exception org.omg.CORBA. PolicyError
构造默认的 PolicyError用户异常，没有原因代码和空的原因详细信息。
PolicyError(short) - Constructor for exception org.omg.CORBA. PolicyError
构造一个 PolicyError用户异常，它使用给定的原因代码和一个空的原因详细信息进行初始化。
PolicyError(String, short) - Constructor for exception org.omg.CORBA. PolicyError
构造一个 PolicyError用户异常，并使用给定的原因详细信息和原因代码进行初始化。
PolicyErrorCodeHelper - Class in org.omg.CORBA
封装“策略”可能无效的原因。
PolicyErrorCodeHelper() - Constructor for class org.omg.CORBA. PolicyErrorCodeHelper
PolicyErrorHelper - Class in org.omg.CORBA
抛出，表示参数值传递给 ORB.create_policy操作的问题。
PolicyErrorHelper() - Constructor for class org.omg.CORBA. PolicyErrorHelper
PolicyErrorHolder - Class in org.omg.CORBA
抛出指示参数值传递给 ORB.create_policy操作的问题。
PolicyErrorHolder() - Constructor for class org.omg.CORBA. PolicyErrorHolder
PolicyErrorHolder(PolicyError) - Constructor for class org.omg.CORBA. PolicyErrorHolder
PolicyFactory - Interface in org.omg.PortableInterceptor
使用 CORBA.ORB.create_policy构建策略类型。
PolicyFactoryOperations - Interface in org.omg.PortableInterceptor
启用使用 CORBA.ORB.create_policy构建的策略类型。
PolicyFile - Class in com.sun.security.auth
不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由sun.security.provider.PolicyFile替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
PolicyFile() - Constructor for class com.sun.security.auth. PolicyFile
已过时。
初始化Policy对象，并将默认策略配置文件读入Policy对象。
PolicyHelper - Class in org.omg.CORBA
助手 Policy 。
PolicyHelper() - Constructor for class org.omg.CORBA. PolicyHelper
PolicyHolder - Class in org.omg.CORBA
持有人 Policy 。
PolicyHolder() - Constructor for class org.omg.CORBA. PolicyHolder
PolicyHolder(Policy) - Constructor for class org.omg.CORBA. PolicyHolder
PolicyListHelper - Class in org.omg.CORBA
助手 PolicyList 。
PolicyListHelper() - Constructor for class org.omg.CORBA. PolicyListHelper
PolicyListHolder - Class in org.omg.CORBA
持有人 PolicyList 。
PolicyListHolder() - Constructor for class org.omg.CORBA. PolicyListHolder
PolicyListHolder(Policy[]) - Constructor for class org.omg.CORBA. PolicyListHolder
PolicyNode - Interface in java.security.cert
由PKIX认证路径验证算法定义的不可变的有效策略树节点。
PolicyOperations - Interface in org.omg.CORBA
提供 Policy对象的操作。
PolicyQualifierInfo - Class in java.security.cert
由ASN.1 PolicyQualifierInfo结构表示的不可变策略限定符。
PolicyQualifierInfo(byte[]) - Constructor for class java.security.cert. PolicyQualifierInfo
从编码字节创建一个 PolicyQualifierInfo的实例。
PolicySpi - Class in java.security
该类定义了 Policy类的 （ SPI ）。
PolicySpi() - Constructor for class java.security. PolicySpi
PolicyTypeHelper - Class in org.omg.CORBA
助手 PolicyType 。
PolicyTypeHelper() - Constructor for class org.omg.CORBA. PolicyTypeHelper
policytool - Search tag in jdk.policytool
policytool
poll() - Method in class java.lang.ref. ReferenceQueue
轮询此队列以查看引用对象是否可用。
poll() - Method in interface java.nio.file. WatchService
检索并删除下一个监视键，如果不存在，则 null 。
poll() - Method in class java.util. ArrayDeque
检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
poll() - Method in class java.util.concurrent. ArrayBlockingQueue
poll() - Method in interface java.util.concurrent. BlockingDeque
检索并删除由此deque（换句话说，此deque的第一个元素）表示的队列的头，或者如果此deque为空，则返回 null 。
poll() - Method in interface java.util.concurrent. CompletionService
检索并删除代表下一个完成的任务的未来，或者如果没有，则 null 。
poll() - Method in class java.util.concurrent. ConcurrentLinkedDeque
poll() - Method in class java.util.concurrent. ConcurrentLinkedQueue
poll() - Method in class java.util.concurrent. DelayQueue
检索并删除此队列的头，或者如果此队列没有延迟到期的元素，则返回 null 。
poll() - Method in class java.util.concurrent. ExecutorCompletionService
poll() - Method in class java.util.concurrent. LinkedBlockingDeque
poll() - Method in class java.util.concurrent. LinkedBlockingQueue
poll() - Method in class java.util.concurrent. LinkedTransferQueue
poll() - Method in class java.util.concurrent. PriorityBlockingQueue
poll() - Method in class java.util.concurrent. SynchronousQueue
如果另一个线程正在使一个元素可用，则检索并删除此队列的头。
poll() - Method in interface java.util. Deque
检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素），如果此deque为空，则返回 null 。
poll() - Method in class java.util. LinkedList
检索并删除此列表的头（第一个元素）。
poll() - Method in class java.util. PriorityQueue
poll() - Method in interface java.util. Queue
检索并删除此队列的头部，如果此队列为空，则返回 null 。
poll(long, TimeUnit) - Method in interface java.nio.file. WatchService
检索并删除下一个watch键，如果还没有，则等待必要时直到指定的等待时间。
poll(long, TimeUnit) - Method in class java.util.concurrent. ArrayBlockingQueue
poll(long, TimeUnit) - Method in interface java.util.concurrent. BlockingDeque
检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，等待到指定的等待时间（如有必要）使元素变为可用。
poll(long, TimeUnit) - Method in interface java.util.concurrent. BlockingQueue
检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
poll(long, TimeUnit) - Method in interface java.util.concurrent. CompletionService
检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
poll(long, TimeUnit) - Method in class java.util.concurrent. DelayQueue
检索并删除此队列的头部，如果需要，等待具有到期延迟的元素可用于此队列，或指定的等待时间到期。
poll(long, TimeUnit) - Method in class java.util.concurrent. ExecutorCompletionService
poll(long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingDeque
poll(long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingQueue
poll(long, TimeUnit) - Method in class java.util.concurrent. LinkedTransferQueue
poll(long, TimeUnit) - Method in class java.util.concurrent. PriorityBlockingQueue
poll(long, TimeUnit) - Method in class java.util.concurrent. SynchronousQueue
检索并删除此队列的头，如果需要等待指定的等待时间，另一个线程插入它。
poll_next_response() - Method in class org.omg.CORBA. ORB
找出任何延迟（异步）调用是否有响应。
poll_response() - Method in class org.omg.CORBA. Request
允许用户通过 send_deferred方法确定先前触发的调用是否已收到响应。
pollEvents() - Method in interface java.nio.file. WatchKey
检索并删除此监视键的所有挂起的事件，返回一个 List检索到的事件。
pollFirst() - Method in class java.util. ArrayDeque
pollFirst() - Method in class java.util.concurrent. ConcurrentLinkedDeque
pollFirst() - Method in class java.util.concurrent. ConcurrentSkipListSet
pollFirst() - Method in class java.util.concurrent. LinkedBlockingDeque
pollFirst() - Method in interface java.util. Deque
检索并删除此deque的第一个元素，如果此deque为空，则返回 null 。
pollFirst() - Method in class java.util. LinkedList
检索并删除此列表的第一个元素，如果此列表为空，则返回 null 。
pollFirst() - Method in interface java.util. NavigableSet
检索并删除第一个（最低）元素，如果此集合为空，则返回 null 。
pollFirst() - Method in class java.util. TreeSet
pollFirst(long, TimeUnit) - Method in interface java.util.concurrent. BlockingDeque
检索并删除此deque的第一个元素，等待到指定的等待时间（如有必要）使元素变为可用。
pollFirst(long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingDeque
pollFirstEntry() - Method in class java.util.concurrent. ConcurrentSkipListMap
删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
pollFirstEntry() - Method in interface java.util. NavigableMap
删除并返回与该地图中的最小键相关联的键值映射，如果地图为空，则 null 。
pollFirstEntry() - Method in class java.util. TreeMap
pollLast() - Method in class java.util. ArrayDeque
pollLast() - Method in class java.util.concurrent. ConcurrentLinkedDeque
pollLast() - Method in class java.util.concurrent. ConcurrentSkipListSet
pollLast() - Method in class java.util.concurrent. LinkedBlockingDeque
pollLast() - Method in interface java.util. Deque
检索并删除此deque的最后一个元素，如果此deque为空，则返回 null 。
pollLast() - Method in class java.util. LinkedList
检索并删除此列表的最后一个元素，如果此列表为空，则返回 null 。
pollLast() - Method in interface java.util. NavigableSet
检索并删除最后一个（最高）元素，如果此集合为空，则返回 null 。
pollLast() - Method in class java.util. TreeSet
pollLast(long, TimeUnit) - Method in interface java.util.concurrent. BlockingDeque
检索并删除此deque的最后一个元素，等待到指定的等待时间，如果需要，元素可用。
pollLast(long, TimeUnit) - Method in class java.util.concurrent. LinkedBlockingDeque
pollLastEntry() - Method in class java.util.concurrent. ConcurrentSkipListMap
删除并返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
pollLastEntry() - Method in interface java.util. NavigableMap
删除并返回与该地图中最大键相关联的键值映射，如果地图为空，则 null 。
pollLastEntry() - Method in class java.util. TreeMap
pollNextLocalTask() - Static method in class java.util.concurrent. ForkJoinTask
如果当前线程正在ForkJoinPool中运行，则不执行当前线程排队的下一个任务但尚未执行的时间并返回。
pollSubmission() - Method in class java.util.concurrent. ForkJoinPool
删除并返回下一个未执行的提交（如果有）。
pollSubmission() - Static method in class java.util.concurrent. ForkJoinTask
如果当前线程在ForkJoinPool中运行，则不执行外部提交到池的任务（如果有的话）可以取消调度和返回。
pollTask() - Static method in class java.util.concurrent. ForkJoinTask
如果当前线程在ForkJoinPool中运行，则不执行下一个任务，返回当前线程排队的下一个任务，但尚未执行，如果一个可用，或者如果不可用，则由其他线程分派的任务，如果可供使用的话。
POLY_PRESSURE - Static variable in class javax.sound.midi. ShortMessage
复音键压力（触发后）消息（0xA0或160）的指令值。
Polygon - Class in java.awt
Polygon类封装了坐标空间内封闭的二维区域的描述。
Polygon - Class in javafx.scene.shape
创建由x，y坐标数组定义的多边形。
Polygon() - Constructor for class java.awt. Polygon
创建一个空多边形。
Polygon() - Constructor for class javafx.scene.shape. Polygon
创建一个空的Polygon实例。
Polygon(double...) - Constructor for class javafx.scene.shape. Polygon
创建一个新的多边形实例。
Polygon(int[], int[], int) - Constructor for class java.awt. Polygon
从指定的参数构造和初始化 Polygon 。
Polyline - Class in javafx.scene.shape
创建折线，由分段点数组定义。
Polyline() - Constructor for class javafx.scene.shape. Polyline
创建一个空的Polyline实例。
Polyline(double...) - Constructor for class javafx.scene.shape. Polyline
创建一个新的Polyline实例。
PooledConnection - Interface in javax.sql
提供连接池管理钩子的对象。
PooledConnectionBuilder - Interface in javax.sql
从 ConnectionPoolDataSource对象创建的构建器，用于建立与 data source对象所表示的数据库的连接。
pop() - Method in class java.awt. EventQueue
停止使用这个 EventQueue调度事件。
pop() - Method in class java.util. ArrayDeque
从这个deque表示的堆栈中弹出一个元素。
pop() - Method in class java.util.concurrent. ConcurrentLinkedDeque
pop() - Method in class java.util.concurrent. LinkedBlockingDeque
pop() - Method in interface java.util. Deque
从这个deque表示的堆栈中弹出一个元素。
pop() - Method in class java.util. LinkedList
从此列表表示的堆栈中弹出一个元素。
pop() - Method in class java.util. Stack
删除此堆栈顶部的对象，并将该对象作为此函数的值返回。
popCharacterStyle() - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
将先前推送的字符样式从堆栈中弹出以返回到先前的样式。
popContext() - Method in class org.xml.sax.helpers. NamespaceSupport
恢复到以前的命名空间上下文。
popFrames(StackFrame) - Method in interface com.sun.jdi. ThreadReference
弹出框架。
populate(ResultSet) - Method in interface javax.sql.rowset. CachedRowSet
填充此 CachedRowSet从给定数据对象 ResultSet对象。
populate(ResultSet, int) - Method in interface javax.sql.rowset. CachedRowSet
填充此 CachedRowSet从给定数据对象 ResultSet对象。
popup - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
执行 ComboPopup这是用来显示弹出窗口。
Popup - Class in javafx.stage
弹出窗口是用于场景图形的特殊的类似窗口的容器。
Popup - Class in javax.swing
弹出窗口用于向用户显示一个 Component ，通常位于特定包含层次结构中的所有其他 Component 。
Popup() - Constructor for class javafx.stage. Popup
Popup() - Constructor for class javax.swing. Popup
创建一个 Popup 。
Popup(Component, Component, int, int) - Constructor for class javax.swing. Popup
创建 Popup为组件 owner包含Component contents 。
POPUP - java.awt. Window.Type
表示一个 弹出窗口。
POPUP_LAYER - Static variable in class javax.swing. JLayeredPane
定义Popup图层的便利对象。
POPUP_MENU - Static variable in class javax.accessibility. AccessibleRole
通常用于向用户提供选项列表的临时窗口，然后在用户选择其中一个选项时隐藏。
POPUP_MENU - Static variable in class javax.swing.plaf.synth. Region
PopupMenu区域。
POPUP_MENU_SEPARATOR - Static variable in class javax.swing.plaf.synth. Region
PopupMenuSeparator区域。
PopupControl - Class in javafx.scene.control
PopupWindow的扩展，允许CSS样式。
PopupControl() - Constructor for class javafx.scene.control. PopupControl
创建一个新的空PopupControl。
PopupControl.CSSBridge - Class in javafx.scene.control
弹出窗口和场景图之间的链接。
PopupFactory - Class in javax.swing
PopupFactory ，顾名思义，用于获取 Popup s的实例。
PopupFactory() - Constructor for class javax.swing. PopupFactory
PopupFeatures - Class in javafx.scene.web
此类描述了由JavaScript window.open功能指定的Web弹出窗口的功能。
PopupFeatures(boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.web. PopupFeatures
创建一个新的实例。
popupKeyListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
KeyListener聆听事件。
popupListener - Variable in class javax.swing. JMenu
弹出窗口关闭侦听器。
popupMenu - Variable in class javax.swing.plaf.basic. BasicPopupMenuUI
实例 JPopupMenu 。
PopupMenu - Class in java.awt
一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
PopupMenu() - Constructor for class java.awt. PopupMenu
创建一个空名称的新的弹出菜单。
PopupMenu(String) - Constructor for class java.awt. PopupMenu
创建一个具有指定名称的新弹出菜单。
POPUPMENU - Static variable in class com.sun.java.accessibility.util. EventID
映射到Swing PopupMenu支持（即PopupMenuListener和PopupMenuEvent）
PopupMenu.AccessibleAWTPopupMenu - Class in java.awt
PopupMenu的内部类用于提供对辅助功能的默认支持。
PopupMenuBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.PopupMenuBorder
popupMenuCanceled(PopupMenuEvent) - Method in interface javax.swing.event. PopupMenuListener
弹出菜单取消时调用此方法
PopupMenuEvent - Class in javax.swing.event
PopupMenuEvent仅包含发送事件的JPopupMenu事件的源
PopupMenuEvent(Object) - Constructor for class javax.swing.event. PopupMenuEvent
构造一个PopupMenuEvent对象。
PopupMenuListener - Interface in javax.swing.event
弹出菜单侦听器
PopupMenuUI - Class in javax.swing.plaf
JPopupMenu可插拔的外观和界面。
PopupMenuUI() - Constructor for class javax.swing.plaf. PopupMenuUI
popupMenuWillBecomeInvisible(PopupMenuEvent) - Method in interface javax.swing.event. PopupMenuListener
弹出菜单变为不可见之前调用此方法请注意，JPopupMenu可以随时变为不可见
popupMenuWillBecomeVisible(PopupMenuEvent) - Method in interface javax.swing.event. PopupMenuListener
在弹出菜单变为可见之前调用此方法
popupMouseListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
MouseListener倾听事件。
popupMouseMotionListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
MouseMotionListener聆听事件。
popupSideProperty() - Method in class javafx.scene.control. MenuButton
表示ContextMenu应该在哪一边打开与MenuButton相关的方面。
PopupWindow - Class in javafx.stage
PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip和ContextMenu 。
PopupWindow() - Constructor for class javafx.stage. PopupWindow
PopupWindow.AnchorLocation - Enum in javafx.stage
锚定点选择的锚位置常数。
port - Variable in class java.net. SocketImpl
此套接字连接到的远程主机上的端口号。
Port - Interface in javax.sound.sampled
端口是用于输入或输出音频到音频设备的简单线。
Port.Info - Class in javax.sound.sampled
Port.Info类扩展了 Line.Info ，其中包括端口的附加信息，包括端口的名称以及它是混合器的源还是目标。
PortableRemoteObject - Class in javax.rmi
服务器实现对象可以从javax.rmi.PortableRemoteObject继承，也可以实现远程接口，然后使用exportObject方法将自身注册为服务对象。
PortableRemoteObject() - Constructor for class javax.rmi. PortableRemoteObject
通过调用 exportObject(this)初始化对象。
PortableRemoteObjectDelegate - Interface in javax.rmi.CORBA
支持PortableRemoteObject中的方法实现的委派 。
PortInfo - Interface in javax.xml.ws.handler
PortInfo接口由 HandlerResolver用于查询有关要求其创建处理程序链的端口的信息。
PORTRAIT - javafx.print. PageOrientation
可打印区域的起点位于纸张的左上方。
PORTRAIT - Static variable in class java.awt. PageAttributes.OrientationRequestedType
用于指定纵向方向的OrientationRequestedType实例。
PORTRAIT - Static variable in class java.awt.print. PageFormat
原点位于纸张的左上角，x向右移动，y向下移动纸张。
PORTRAIT - Static variable in class javax.print.attribute.standard. OrientationRequested
内容将在介质的短边成像。
PortUnreachableException - Exception in java.net
指示在连接的数据报上收到了ICMP端口不可达消息。
PortUnreachableException() - Constructor for exception java.net. PortUnreachableException
构造一个新的 PortUnreachableException没有详细的消息。
PortUnreachableException(String) - Constructor for exception java.net. PortUnreachableException
构造一个新的 PortUnreachableException与详细的消息。
pos - Variable in class java.io. BufferedInputStream
缓冲区中的当前位置。
pos - Variable in class java.io. ByteArrayInputStream
从输入流缓冲区读取的下一个字符的索引。
pos - Variable in class java.io. CharArrayReader
当前的缓冲位置。
pos - Variable in class java.io. PushbackInputStream
推回缓冲区中的位置，从该位置读取下一个字节。
pos - Variable in class java.io. StringBufferInputStream
已过时。
从输入流缓冲区读取的下一个字符的索引。
Pos - Enum in javafx.geometry
一组用于描述垂直和水平定位和对齐的值。
position() - Method in interface com.sun.javadoc. Doc
已过时。
返回相应声明的第一行的源位置，如果没有位置可用，则返回null。
position() - Method in interface com.sun.javadoc. Tag
已过时。
返回此标签的源位置。
position() - Method in class java.nio. Buffer
返回此缓冲区的位置。
position() - Method in class java.nio.channels. FileChannel
返回此频道的文件位置。
position() - Method in class java.nio.channels. FileLock
返回锁定区域的第一个字节的文件中的位置。
position() - Method in interface java.nio.channels. SeekableByteChannel
返回此频道的位置。
position(byte[], long) - Method in interface java.sql. Blob
检索指定字节数组 pattern在该 Blob对象表示的 BLOB值内开始的字节位置。
position(byte[], long) - Method in class javax.sql.rowset.serial. SerialBlob
返回此 SerialBlob对象中给定字节模式开始的位置，开始在指定位置的搜索。
position(int) - Method in class java.nio. Buffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. ByteBuffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. CharBuffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. DoubleBuffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. FloatBuffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. IntBuffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. LongBuffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. MappedByteBuffer
设置这个缓冲区的位置。
position(int) - Method in class java.nio. ShortBuffer
设置这个缓冲区的位置。
position(long) - Method in class java.nio.channels. FileChannel
设置此通道的文件位置。
position(long) - Method in interface java.nio.channels. SeekableByteChannel
设置此频道的位置。
position(String, long) - Method in interface java.sql. Clob
检索由此 Clob对象表示的SQL CLOB指定的子字符串 searchstr出现的字符位置。
position(String, long) - Method in class javax.sql.rowset.serial. SerialClob
返回此 SerialClob对象中的位置，其中给定的 String对象开始，开始在指定位置的搜索。
position(Blob, long) - Method in interface java.sql. Blob
检索在该字节位置 BLOB通过该指定值 Blob对象在该 pattern开始。
position(Blob, long) - Method in class javax.sql.rowset.serial. SerialBlob
返回此 SerialBlob对象中的位置，其中给定的 Blob对象开始，开始在指定位置的搜索。
position(Clob, long) - Method in interface java.sql. Clob
检索此 Clob对象中指定的 Clob对象 searchstr的字符位置。
position(Clob, long) - Method in class javax.sql.rowset.serial. SerialClob
返回此 SerialClob对象中的位置，其中给定的 Clob签名开始，在指定位置开始搜索。
Position - Interface in javax.swing.text
表示文档中的位置。
Position.Bias - Class in javax.swing.text
一种类型安全的枚举，用于指示模型中位置的偏差。
positionCaret(int) - Method in class javafx.scene.control. TextInputControl
将插入符号 pos指示的位置。
positionCaret(MouseEvent) - Method in class javax.swing.text. DefaultCaret
尝试使用viewToModel（）从鼠标事件的坐标设置插入符号的位置。
positionCaret(HitInfo, boolean) - Method in class javafx.scene.control.skin. TextAreaSkin
将插入符号移动到指定的位置。
positionCaret(HitInfo, boolean) - Method in class javafx.scene.control.skin. TextFieldSkin
将插入符号移动到指定的位置。
positionForMouseEvent(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DragController
返回基于MouseEvent中传递的分隔符的新位置。
positionForMouseEvent(MouseEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.VerticalDragController
返回基于MouseEvent中传递的分隔符的新位置。
positionInArea(Node, double, double, double, double, double, HPos, VPos) - Method in class javafx.scene.control. SkinBase
通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
positionInArea(Node, double, double, double, double, double, HPos, VPos) - Method in class javafx.scene.layout. Region
通过定义哪个位置该区域的区域内的子工具方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
positionInArea(Node, double, double, double, double, double, Insets, HPos, VPos) - Method in class javafx.scene.control. SkinBase
通过定义哪个位置此皮肤区域中的子项实用方法 areaX ， areaY ， areaWidth X areaHeight ，与基线偏移相对于该区域。
positionInArea(Node, double, double, double, double, double, Insets, HPos, VPos, boolean) - Static method in class javafx.scene.layout. Region
该方法将儿童定位在由 areaWidth x areaHeight定义的 areaX areaY ，相对于该区域具有基线偏移。
positionProperty() - Method in class javafx.scene.chart. Axis.TickMark
沿轴的显示位置以轴原点为单位
positionProperty() - Method in class javafx.scene.control.skin. VirtualFlow
VirtualFlow在其单元格列表中的位置。
positionProperty() - Method in class javafx.scene.control. SplitPane.Divider
代表分隔符理想位置的位置，介于0.0和1.0（含）之间。 0.0表示最左侧或最上方，1.0表示右下角（取决于水平属性）。
positionToElement(int) - Method in class javax.swing.text. AbstractDocument.BranchElement
获取包含给定模型位置的子元素。
POSITIVE_INFINITY - Static variable in class java.lang. Double
持有 double型的正无穷大的 double 。
POSITIVE_INFINITY - Static variable in class java.lang. Float
持有 float类型的正无穷大的 float 。
POSITIVE_SCROLL - Static variable in class javax.swing.plaf.basic. BasicSliderUI
正滚动
PosixFileAttributes - Interface in java.nio.file.attribute
与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件相关联的文件属性。
PosixFileAttributeView - Interface in java.nio.file.attribute
文件属性视图，提供通常与实现便携式操作系统接口（POSIX）系列标准的操作系统使用的文件系统上的文件关联的文件属性视图。
PosixFilePermission - Enum in java.nio.file.attribute
定义与 permissions属性一起使用的位。
PosixFilePermissions - Class in java.nio.file.attribute
该类只包含对PosixFilePermission对象进行操作的静态方法。
POST - javax.swing.text.html. FormSubmitEvent.MethodType
POST对应于POST方法
POST(HttpRequest.BodyProcessor) - Method in class jdk.incubator.http. HttpRequest.Builder
将此构建器的请求方法设置为POST，并将其请求体处理器设置为给定值。
post_init(ORBInitInfo) - Method in interface org.omg.PortableInterceptor. ORBInitializerOperations
在ORB初始化期间调用。
postActionEvent() - Method in class javax.swing. JTextField
通过将这些事件发送到任何已注册的 ActionListener对象来处理在此文本域上发生的操作事件。
postClosingEvent(JInternalFrame) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
将一个类似WINDOW_CLOSING的事件发布到框架中，这样就可以像普通的 Frame那样 Frame 。
PostConstruct - Annotation Type in javax.annotation
PostConstruct注释用于需要执行相关性注入后执行任何初始化的方法。
postDeregister() - Method in class javax.management.loading. MLet
允许m-let在MBean服务器中取消注册后执行所需的操作。
postDeregister() - Method in interface javax.management. MBeanRegistration
允许MBean在MBean服务器中取消注册后执行所需的任何操作。
postDeregister() - Method in class javax.management.modelmbean. RequiredModelMBean
允许MBean在MBean服务器中取消注册后执行所需的任何操作。
postDeregister() - Method in class javax.management.monitor. Monitor
允许监视器MBean在MBean服务器取消注册之后执行所需的任何操作。
postDeregister() - Method in class javax.management.relation. RelationService
postDeregister() - Method in class javax.management.relation. RelationSupport
postDeregister() - Method in class javax.management.remote. JMXConnectorServer
postDeregister() - Method in class javax.management. StandardMBean
允许MBean在MBean服务器中取消注册后执行所需的任何操作。
postDeregister() - Method in class javax.management.timer. Timer
允许计时器MBean在MBean服务器取消注册之后执行所需的任何操作。
postEdit(UndoableEdit) - Method in class javax.swing.undo. UndoableEditSupport
死锁警告：调用此方法可能会在所有侦听器中调用 undoableEditHappened 。
postEvent(AWTEvent) - Method in class java.awt. EventQueue
将一个1.1风格的事件发布到 EventQueue 。
postEvent(Event) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由dispatchEvent（AWTEvent）替换。
postEvent(Event) - Method in class java.awt. MenuComponent
已过时。
从JDK 1.1版开始，替换为dispatchEvent 。
postEvent(Event) - Method in interface java.awt. MenuContainer
已过时。
由JDK版本1.1替换为dispatchEvent（AWTEvent）。
postEvent(Event) - Method in class java.awt. Window
已过时。
从JDK版本1.1替换为dispatchEvent(AWTEvent) 。
POSTFIX_DECREMENT - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表后缀减量操作-- 。
POSTFIX_DECREMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表后缀减量操作-- 。
POSTFIX_INCREMENT - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表后缀增量运算++ 。
POSTFIX_INCREMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表后缀增量运算++ 。
postinvoke(byte[], POA, String, Object, Servant) - Method in class org.omg.PortableServer. _ServantLocatorStub
在服务器完成请求时调用此操作。
postinvoke(byte[], POA, String, Object, Servant) - Method in interface org.omg.PortableServer. ServantLocatorOperations
在服务器完成请求时调用此操作。
postorderEnumeration() - Method in class javax.swing.tree. DefaultMutableTreeNode
创建并返回在postorder中遍历此节点的子树的枚举。
postProcessKeyEvent(KeyEvent) - Method in class java.awt. DefaultKeyboardFocusManager
此方法将由 dispatchKeyEvent 。
postProcessKeyEvent(KeyEvent) - Method in class java.awt. KeyboardFocusManager
此方法将由 dispatchKeyEvent 。
postProcessKeyEvent(KeyEvent) - Method in interface java.awt. KeyEventPostProcessor
该方法由当前的KeyboardFocusManager调用，请求该KeyEventPostProcessor执行任何必要的后处理，该后处理应该是KeyEvent的最终解决方案的一部分。
postRegister(Boolean) - Method in class javax.management.loading. MLet
允许m-let在MBean服务器中注册或注册失败后执行所需的操作。
postRegister(Boolean) - Method in interface javax.management. MBeanRegistration
允许MBean在MBean服务器中注册或注册失败后执行所需的操作。
postRegister(Boolean) - Method in class javax.management.modelmbean. RequiredModelMBean
允许MBean在MBean服务器中注册或注册失败后执行所需的操作。
postRegister(Boolean) - Method in class javax.management.monitor. Monitor
允许监视器MBean在MBean服务器中注册或注册失败后执行所需的操作。
postRegister(Boolean) - Method in class javax.management.relation. RelationService
postRegister(Boolean) - Method in class javax.management.relation. RelationSupport
postRegister(Boolean) - Method in class javax.management.remote. JMXConnectorServer
postRegister(Boolean) - Method in class javax.management. StandardMBean
允许MBean在MBean服务器中注册或注册失败后执行所需的操作。
postRegister(Boolean) - Method in class javax.management.timer. Timer
允许定时器MBean在MBean服务器中注册或注册失败后执行所需的任何操作。
postRemoveUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text. AbstractDocument
由于删除文字而更新任何文档结构。
POSTSCRIPT - Static variable in class javax.print. DocFlavor.BYTE_ARRAY
Doc风格与MIME类型= "application/postscript" ，打印数据表示类名= "[B" （字节数组）。
POSTSCRIPT - Static variable in class javax.print. DocFlavor.INPUT_STREAM
具有MIME类型的文档风格= "application/postscript" ，打印数据表示类名= "java.io.InputStream" （字节流）。
POSTSCRIPT - Static variable in class javax.print. DocFlavor.URL
Doc风格与MIME类型= "application/postscript" ，打印数据表示类名= "java.net.URL" 。
postState - Variable in class javax.swing.undo. StateEdit
编辑后的状态信息
POSTURE - Static variable in class java.awt.font. TextAttribute
字体姿势的属性键。
POSTURE_OBLIQUE - Static variable in class java.awt.font. TextAttribute
标准斜体姿势。
POSTURE_REGULAR - Static variable in class java.awt.font. TextAttribute
标准姿势，直立。
postVisitDirectory(T, IOException) - Method in interface java.nio.file. FileVisitor
在目录中的条目之后调用目录，并且已经访问了所有的后代。
postVisitDirectory(T, IOException) - Method in class java.nio.file. SimpleFileVisitor
在目录中的条目之后调用目录，并且已经访问了所有的后代。
POUND - javafx.scene.input. KeyCode
常数为 Pound键。
pow(double, double) - Static method in class java.lang. Math
将第一个参数的值返回到第二个参数的幂。
pow(double, double) - Static method in class java.lang. StrictMath
将第一个参数的值返回到第二个参数的幂。
pow(int) - Method in class java.math. BigDecimal
返回一个 BigDecimal ，值为 (thisn) ，功率计算精确到无限精度。
pow(int) - Method in class java.math. BigInteger
返回值为 (thisexponent)的BigInteger。
pow(int, MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (thisn) 。
POWDERBLUE - Static variable in class javafx.scene.paint. Color
彩色蓝色，RGB值为＃B0E0E6
POWER - javafx.scene.input. KeyCode
常数为 Power键。
PPQ - Static variable in class javax.sound.midi. Sequence
基于节拍的时间类型，其分辨率以每四分之一音符的脉冲（刻度）表示。
PR_AND_RESEED - java.security. DrbgParameters.Capability
预测抵抗和重新种植。
PRC - Static variable in class java.util. Locale
对国家有用的常数。
pre() - Method in class java.lang. Runtime.Version
返回可选的 pre-release信息。
PRE - Static variable in class javax.swing.text.html. HTML.Tag
标签<pre>
pre_init(ORBInitInfo) - Method in interface org.omg.PortableInterceptor. ORBInitializerOperations
在ORB初始化期间调用。
PreAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.PreAction
preceding(int) - Method in class java.text. BreakIterator
返回指定字符偏移量之前的最后一个边界。
precision() - Method in class java.math. BigDecimal
返回此 BigDecimal的 精度 。
precision() - Static method in class java.time.temporal. TemporalQueries
对最小支持单位的查询。
preConcatenate(AffineTransform) - Method in class java.awt.geom. AffineTransform
串接的 AffineTransform Tx本 AffineTransform CX在一个不常用的方式，使得 Tx坐标变换相对于绝对像素空间而不是相对于现有的用户空间修改。
preConcatenateTransform(AffineTransform) - Method in class java.awt.image.renderable. RenderContext
通过前置另一个变换来修改当前的用户到设备的变换。
preConcetenateTransform(AffineTransform) - Method in class java.awt.image.renderable. RenderContext
已过时。
替换为preConcatenateTransform(AffineTransform) 。
preContent(char[]) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
添加在PRE元素中遇到的给定内容。
predefined - Static variable in class java.awt. Cursor
已过时。
从JDK 1.7版开始，应该使用Cursor.getPredefinedCursor(int)方法。
preDeregister() - Method in class javax.management.loading. MLet
允许m-let在MBean服务器取消注册之前执行所需的任何操作。
preDeregister() - Method in interface javax.management. MBeanRegistration
允许MBean在MBean服务器取消注册之前执行所需的任何操作。
preDeregister() - Method in class javax.management.modelmbean. RequiredModelMBean
允许MBean在MBean服务器取消注册之前执行所需的任何操作。
preDeregister() - Method in class javax.management.monitor. Monitor
允许监视器MBean在MBean服务器取消注册之前执行所需的任何操作。
preDeregister() - Method in class javax.management.relation. RelationService
preDeregister() - Method in class javax.management.relation. RelationSupport
preDeregister() - Method in class javax.management.remote. JMXConnectorServer
当该连接器服务器从该MBean服务器取消注册时，由MBean服务器调用。
preDeregister() - Method in class javax.management. StandardMBean
允许MBean在MBean服务器取消注册之前执行所需的任何操作。
preDeregister() - Method in class javax.management.timer. Timer
允许计时器MBean在MBean服务器取消注册之前执行所需的任何操作。
PreDestroy - Annotation Type in javax.annotation
PreDestroy注释在方法上用作回调通知，表明实例正在被容器移除。
Predicate< T> - Interface in java.util.function
表示一个参数的谓词（布尔值函数）。
Predicate - Interface in javax.sql.rowset
为所有 FilteredRowSet对象提供框架来描述其过滤器的标准接口。
predicateProperty() - Method in class javafx.collections.transformation. FilteredList
该谓词将匹配此FilteredList中的元素。
PREDICTOR_HORIZONTAL_DIFFERENCING - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Predictor”标签一起使用的值。
PREDICTOR_NONE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“Predictor”标签一起使用的值。
prefColumnCountProperty() - Method in class javafx.scene.control. TextArea
文本列的首选数量。
prefColumnCountProperty() - Method in class javafx.scene.control. TextField
文本列的首选数量。
prefColumnsProperty() - Method in class javafx.scene.layout. TilePane
水平瓦片的首选列数。
PREFER - javax.xml.catalog. CatalogFeatures.Feature
目录功能表 PREFER中描述的 javax.xml.catalog.prefer属性。
PREFER_CRLS - java.security.cert. PKIXRevocationChecker.Option
喜欢CRCP到OSCP。
preferenceChange(PreferenceChangeEvent) - Method in interface java.util.prefs. PreferenceChangeListener
当添加，删除首选项或更改其值时，将调用此方法。
preferenceChanged(boolean, boolean) - Method in class javax.swing.text. AsyncBoxView.ChildState
此孩子的标记偏好已更改。
preferenceChanged(View, boolean, boolean) - Method in class javax.swing.text. AsyncBoxView
子视图可以在父项上调用，以表明偏好已更改，应重新考虑布局。
preferenceChanged(View, boolean, boolean) - Method in class javax.swing.text. BoxView
这是由一个孩子调用来指示其首选跨度已更改。
preferenceChanged(View, boolean, boolean) - Method in class javax.swing.text. View
子视图可以在父项上调用，以表明偏好已更改，应重新考虑布局。
PreferenceChangeEvent - Class in java.util.prefs
由 Preferences节点发出的一个事件，表明偏好已被添加，删除或已更改其值。
PreferenceChangeEvent(Preferences, String, String) - Constructor for class java.util.prefs. PreferenceChangeEvent
构造一个新的 PreferenceChangeEvent实例。
PreferenceChangeListener - Interface in java.util.prefs
用于接收偏好更改事件的侦听器。
Preferences - Class in java.util.prefs
优先级数据的分层收集中的节点。
Preferences() - Constructor for class java.util.prefs. Preferences
唯一的构造函数。
PreferencesEvent - Class in java.awt.desktop
当请求应用程序打开其首选项窗口时发送事件。
PreferencesEvent() - Constructor for class java.awt.desktop. PreferencesEvent
构造一个 PreferencesEvent
PreferencesFactory - Interface in java.util.prefs
生成首选项对象的工厂对象。
PreferencesHandler - Interface in java.awt.desktop
当应用程序被要求显示其首选项UI时，会通知实施者。
preferLocaleFonts() - Method in class java.awt. GraphicsEnvironment
表示对逻辑字体映射到物理字体的区域设置特定字体的偏好。
preferProportionalFonts() - Method in class java.awt. GraphicsEnvironment
表示比例超过非比例的偏好（例如
preferred - Variable in class javax.swing. SizeRequirements
优选（自然）尺寸。
PREFERRED - Static variable in class java.awt. GraphicsConfigTemplate
用于“Enum”（整数）类型的值。
PREFERRED_SIZE - Static variable in class javax.swing. GroupLayout
表示组件或间隙的首选尺寸应用于特定范围值。
preferredLayoutSize(Container) - Method in class java.awt. BorderLayout
根据容器中的组件确定使用此布局管理器的 target容器的首选大小。
preferredLayoutSize(Container) - Method in class java.awt. CardLayout
使用此卡布局确定容器参数的首选大小。
preferredLayoutSize(Container) - Method in class java.awt. FlowLayout
给定指定目标容器中 可见组件的返回值。
preferredLayoutSize(Container) - Method in class java.awt. GridBagLayout
使用此网格包布局确定 parent容器的首选大小。
preferredLayoutSize(Container) - Method in class java.awt. GridLayout
使用此网格布局确定容器参数的首选大小。
preferredLayoutSize(Container) - Method in interface java.awt. LayoutManager
计算指定容器的首选大小尺寸，给定其包含的组件。
preferredLayoutSize(Container) - Method in class javax.swing. BoxLayout
给定指定目标容器中的组件，返回此布局的首选尺寸。
preferredLayoutSize(Container) - Method in class javax.swing. GroupLayout
返回指定容器的首选大小。
preferredLayoutSize(Container) - Method in class javax.swing. JRootPane.RootLayout
返回布局想要的空间量。
preferredLayoutSize(Container) - Method in class javax.swing. JSpinner.DefaultEditor
返回首个（而且仅）子项的首选大小加上父母插入的大小。
preferredLayoutSize(Container) - Method in class javax.swing. OverlayLayout
给定指定目标容器中的组件，返回此布局的首选尺寸。
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ComboBoxLayoutManager
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.TitlePaneLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFrameLayout
计算指定容器的首选大小尺寸，给定其包含的组件。
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DividerLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
返回包含子项所需的首选大小。
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic. DefaultMenuLayout
preferredLayoutSize(Container) - Method in class javax.swing. ScrollPaneLayout
ScrollPane的首选大小是插图的大小，加上视口的首选大小，加上可见标题的首选大小，以及给定当前视图和当前滚动条displayPolicies的滚动条的首选大小。
preferredLayoutSize(Container) - Method in class javax.swing. SpringLayout
preferredLayoutSize(Container) - Method in class javax.swing. ViewportLayout
给定指定目标容器中的组件，返回此布局的首选尺寸。
preferredMinSize - Variable in class javax.swing.plaf.basic. BasicTreeUI
最小尺寸。
preferredSize - Variable in class javax.swing.plaf.basic. BasicTreeUI
完全显示所有节点所需的大小。
preferredSize() - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，替换为getPreferredSize() 。
preferredSize() - Method in class java.awt. Container
已过时。
从JDK 1.1版开始，替换为getPreferredSize() 。
preferredSize() - Method in class java.awt. List
已过时。
从JDK 1.1版起，由getPreferredSize()取代。
preferredSize() - Method in class java.awt. TextArea
已过时。
截至JDK 1.1版，由getPreferredSize()取代。
preferredSize() - Method in class java.awt. TextField
已过时。
从JDK 1.1版开始，由getPreferredSize()替换。
preferredSize(int) - Method in class java.awt. List
已过时。
从JDK 1.1版开始，由getPreferredSize(int)替换。
preferredSize(int) - Method in class java.awt. TextField
已过时。
从JDK 1.1版开始，替换为getPreferredSize(int) 。
preferredSize(int, int) - Method in class java.awt. TextArea
已过时。
从JDK 1.1版开始，由getPreferredSize(int, int)替代。
PREFERREDSIZE - Static variable in class java.awt. GridBagLayout
可以通过网格布局布局的首选网格尺寸。
preferredTabAreaHeight(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
返回首选标签区域高度。
preferredTabAreaWidth(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
返回首选标签区域宽度。
preferredTileSizes - Variable in class javax.imageio. ImageWriteParam
一组优选的瓷砖尺寸范围对。
preferredViewportSize - Variable in class javax.swing. JTable
由 Scrollable接口用于确定初始可见区域。
prefHeight(double) - Method in class javafx.embed.swing. SwingNode
返回用于布局计算的 SwingNode的首选高度。
prefHeight(double) - Method in class javafx.scene.control. PopupControl
在布局期间调用以确定此节点的首选高度。
prefHeight(double) - Method in class javafx.scene. Group
组定义优选高度只是其布局界限的高度，反过来只是其所有子项的位置和高度的总和。
prefHeight(double) - Method in class javafx.scene.layout. Region
在布局期间调用以确定此节点的首选高度。
prefHeight(double) - Method in class javafx.scene. Node
返回节点的首选高度，用于布局计算。
prefHeight(double) - Method in class javafx.scene. Parent
prefHeight(double) - Method in class javafx.scene.web. WebView
在布局期间调用以确定此节点的首选高度。
prefHeightProperty() - Method in class javafx.scene.control. PopupControl
用于覆盖控件计算的首选高度的属性。
prefHeightProperty() - Method in class javafx.scene.layout. Region
覆盖该地区计算的首选高度的属性。
prefHeightProperty() - Method in class javafx.scene.layout. RowConstraints
行的首选高度。
prefHeightProperty() - Method in class javafx.scene.web. WebView
首选高度属性。
PREFIX_DECREMENT - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表前缀减量操作-- 。
PREFIX_DECREMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表前缀减量操作-- 。
PREFIX_INCREMENT - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表前缀增量运算++ 。
PREFIX_INCREMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表前缀增量运算++ 。
prefRowCountProperty() - Method in class javafx.scene.control. TextArea
文本行的首选数量。
prefRowsProperty() - Method in class javafx.scene.layout. TilePane
垂直瓦片的首选行数。
prefTileHeightProperty() - Method in class javafx.scene.layout. TilePane
每个瓷砖的首选高度。
prefTileWidthProperty() - Method in class javafx.scene.layout. TilePane
每个瓷砖的首选宽度。
prefViewportHeightProperty() - Method in class javafx.scene.control. ScrollPane
指定ScrollPane视口的首选高度。
prefViewportWidthProperty() - Method in class javafx.scene.control. ScrollPane
指定ScrollPane视口的首选宽度。
prefWidth(double) - Method in class javafx.embed.swing. SwingNode
返回用于布局计算的 SwingNode的首选宽度。
prefWidth(double) - Method in class javafx.scene.control. PopupControl
在布局期间调用以确定此节点的首选宽度。
prefWidth(double) - Method in class javafx.scene. Group
组将首选宽度定义为其布局边界的宽度，而宽度又是其所有子项的位置和宽度之和。
prefWidth(double) - Method in class javafx.scene.layout. Region
在布局期间调用以确定此节点的首选宽度。
prefWidth(double) - Method in class javafx.scene. Node
返回节点在布局计算中使用的首选宽度。
prefWidth(double) - Method in class javafx.scene. Parent
prefWidth(double) - Method in class javafx.scene.web. WebView
在布局期间调用以确定此节点的首选宽度。
prefWidthProperty() - Method in class javafx.scene.control. PopupControl
覆盖控件计算的首选宽度的属性。
prefWidthProperty() - Method in class javafx.scene.control. TableColumnBase
TableColumn的首选宽度。
prefWidthProperty() - Method in class javafx.scene.layout. ColumnConstraints
列的首选宽度。
prefWidthProperty() - Method in class javafx.scene.layout. Region
覆盖该地区计算的首选宽度的属性。
prefWidthProperty() - Method in class javafx.scene.web. WebView
首选宽度属性。
prefWrapLengthProperty() - Method in class javafx.scene.layout. FlowPane
其中内容应包装在水平花式板中的优选宽度或其中内容应包装在垂直透光板中的优选高度。
preinvoke(byte[], POA, String, CookieHolder) - Method in class org.omg.PortableServer. _ServantLocatorStub
此操作用于获取将用于处理引起preinvoke调用的请求的servant。
preinvoke(byte[], POA, String, CookieHolder) - Method in interface org.omg.PortableServer. ServantLocatorOperations
此操作用于获取将用于处理引起preinvoke调用的请求的servant。
Preloader - Class in javafx.application
扩展定义JavaFX应用程序的可选预加载器的类。
Preloader() - Constructor for class javafx.application. Preloader
Preloader.ErrorNotification - Class in javafx.application
报告错误的预加载程序通知。
Preloader.PreloaderNotification - Interface in javafx.application
所有Preloader通知的标记界面。
Preloader.ProgressNotification - Class in javafx.application
报告进度的预加载程序通知。
Preloader.StateChangeNotification - Class in javafx.application
发出申明状态更改的通知。
Preloader.StateChangeNotification.Type - Enum in javafx.application
枚举，定义与此通知相关联的更改类型
preorderEnumeration() - Method in class javax.swing.tree. DefaultMutableTreeNode
创建并返回以预订方式遍历此节点的子树的枚举。
prepare(Xid) - Method in interface javax.transaction.xa. XAResource
请求资源管理器准备xid中指定的事务的事务提交。
prepareCall(String) - Method in interface java.sql. Connection
创建一个 CallableStatement对象来调用数据库存储过程。
prepareCall(String, int, int) - Method in interface java.sql. Connection
创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
prepareCall(String, int, int, int) - Method in interface java.sql. Connection
创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
PreparedStatement - Interface in java.sql
表示预编译的SQL语句的对象。
prepareEditor(TableCellEditor, int, int) - Method in class javax.swing. JTable
准备通过在查询的单元格的值和选择状态数据模型中的编辑器 row ， column 。
prepareForDragging() - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider
消息准备拖动。
prepareForEditing() - Method in class javax.swing.tree. DefaultTreeCellEditor
在编辑之前调用即可开始。
prepareForUIInstall() - Method in class javax.swing.plaf.basic. BasicTreeUI
在设置了 tree实例变量之后，但在安装任何默认值/侦听器之前调用。
prepareForUIUninstall() - Method in class javax.swing.plaf.basic. BasicTreeUI
在安装UI之前调用。
prepareImage(Image, int, int, ImageObserver) - Method in class java.awt. Component
准备一个图像，以指定的宽度和高度在此组件上渲染。
prepareImage(Image, int, int, ImageObserver) - Method in class java.awt. Toolkit
准备渲染图像。
prepareImage(Image, ImageObserver) - Method in class java.awt. Component
准备用于在此组件上呈现的图像。
prepareInsertEmpty(int, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - Method in class javax.imageio. ImageWriter
开始将未定义像素值的新图像插入到现有图像流中。
prepareRenderer(TableCellRenderer, int, int) - Method in class javax.swing. JTable
通过在查询的单元格的值和选择状态的数据模型来准备渲染器 row ， column 。
prepareReplacePixels(int, Rectangle) - Method in class javax.imageio. ImageWriter
准备作者处理一系列对 replacePixels方法的调用。
prepareStatement(String) - Method in interface java.sql. Connection
创建一个 PreparedStatement对象，用于将参数化的SQL语句发送到数据库。
prepareStatement(String, int) - Method in interface java.sql. Connection
创建一个默认的 PreparedStatement对象，该对象可以检索自动生成的密钥。
prepareStatement(String, int[]) - Method in interface java.sql. Connection
创建一个默认的 PreparedStatement对象，能够返回给定数组指定的自动生成的键。
prepareStatement(String, int, int) - Method in interface java.sql. Connection
创建一个 PreparedStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。
prepareStatement(String, int, int, int) - Method in interface java.sql. Connection
创建一个 PreparedStatement对象，该对象将生成具有给定类型，并发和 ResultSet对象。
prepareStatement(String, String[]) - Method in interface java.sql. Connection
创建一个默认的 PreparedStatement对象，能够返回给定数组指定的自动生成的键。
prepareWriteEmpty(IIOMetadata, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - Method in class javax.imageio. ImageWriter
开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
prepareWriteSequence(IIOMetadata) - Method in class javax.imageio. ImageWriter
使用提供的流元数据对象准备流以接受一系列后续的 writeToSequence调用。
prepend(double[], MatrixType, int) - Method in class javafx.scene.transform. Affine
将数组指定的变换预置到此实例。
prepend(double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
将由元素值指定的2D变换预置到此实例。
prepend(double, double, double, double, double, double, double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
将由元素值指定的变换预置到此实例。
prepend(EventDispatcher) - Method in interface javafx.event. EventDispatchChain
为此链条预先指定了 EventDispatcher 。
prepend(Transform) - Method in class javafx.scene.transform. Affine
将指定的变换预置到此实例。
prependRotation(double) - Method in class javafx.scene.transform. Affine
将2D旋转预置到此实例。
prependRotation(double, double, double) - Method in class javafx.scene.transform. Affine
使用枢轴将2D旋转预加到此实例。
prependRotation(double, double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
预先轮换到这个实例。
prependRotation(double, double, double, double, Point3D) - Method in class javafx.scene.transform. Affine
预先轮换到这个实例。
prependRotation(double, Point2D) - Method in class javafx.scene.transform. Affine
使用枢轴将2D旋转预加到此实例。
prependRotation(double, Point3D, Point3D) - Method in class javafx.scene.transform. Affine
预先轮换到这个实例。
prependScale(double, double) - Method in class javafx.scene.transform. Affine
将2D刻度放在这个实例上。
prependScale(double, double, double) - Method in class javafx.scene.transform. Affine
为这个例子准备了比例。
prependScale(double, double, double, double) - Method in class javafx.scene.transform. Affine
使用这个实例的枢轴来预处理二维刻度。
prependScale(double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine
使用这个实例的pivot来预览缩放比例。
prependScale(double, double, double, Point3D) - Method in class javafx.scene.transform. Affine
使用这个实例的pivot来预览缩放比例。
prependScale(double, double, Point2D) - Method in class javafx.scene.transform. Affine
使用这个实例的枢轴来预处理二维刻度。
prependShear(double, double) - Method in class javafx.scene.transform. Affine
为这个例子预先剪切。
prependShear(double, double, double, double) - Method in class javafx.scene.transform. Affine
在这种情况下用枢轴预先剪切。
prependShear(double, double, Point2D) - Method in class javafx.scene.transform. Affine
在这种情况下用枢轴预先剪切。
prependTranslation(double, double) - Method in class javafx.scene.transform. Affine
将2D翻译准备到此实例。
prependTranslation(double, double, double) - Method in class javafx.scene.transform. Affine
准备翻译到这个实例。
preRegister(MBeanServer, ObjectName) - Method in class javax.management.loading. MLet
允许m-let在MBean服务器注册之前执行所需的任何操作。
preRegister(MBeanServer, ObjectName) - Method in interface javax.management. MBeanRegistration
允许MBean在MBean服务器注册之前执行所需的任何操作。
preRegister(MBeanServer, ObjectName) - Method in class javax.management.modelmbean. RequiredModelMBean
允许MBean在MBean服务器注册之前执行所需的任何操作。
preRegister(MBeanServer, ObjectName) - Method in class javax.management.monitor. Monitor
允许监视器MBean在MBean服务器中注册之前执行所需的任何操作。
preRegister(MBeanServer, ObjectName) - Method in class javax.management.relation. RelationService
preRegister(MBeanServer, ObjectName) - Method in class javax.management.relation. RelationSupport
preRegister(MBeanServer, ObjectName) - Method in class javax.management.remote. JMXConnectorServer
当该连接器服务器在该MBean服务器中注册时，由MBean服务器调用。
preRegister(MBeanServer, ObjectName) - Method in class javax.management. StandardMBean
允许MBean在MBean服务器注册之前执行所需的任何操作。
preRegister(MBeanServer, ObjectName) - Method in class javax.management.timer. Timer
允许计时器MBean在MBean服务器中注册之前执行所需的任何操作。
PresentationDirection - Class in javax.print.attribute.standard
类PresentationDirection是打印属性类，枚举，与NumberUp属性结合使用，以指示多个打印流页面在所选介质的实例的单侧上施加的布局。
preserveRatioProperty() - Method in class javafx.scene.image. ImageView
指示当缩放以适应拟合边界框内的图像时是否保留源图像的宽高比。
preserveRatioProperty() - Method in class javafx.scene.media. MediaView
是否在将其缩放以适应节点时保留介质的宽高比（宽/高）。
PRESSED - javafx.scene.input. TouchPoint.State
触摸点刚刚被按下（第一次触摸）
PRESSED - Static variable in class javax.accessibility. AccessibleState
表示此对象当前按下。
PRESSED - Static variable in class javax.swing. DefaultButtonModel
标识位掩码中的“已按”位，表示该按钮被按下。
PRESSED - Static variable in interface javax.swing.plaf.synth. SynthConstants
表示该区域的主状态处于按压状态。
PRESSED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按下按钮时使用的图标的更改。
pressedProperty() - Method in class javafx.scene. Node
是否按 Node 。
prestartAllCoreThreads() - Method in class java.util.concurrent. ThreadPoolExecutor
启动所有核心线程，导致他们等待工作。
prestartCoreThread() - Method in class java.util.concurrent. ThreadPoolExecutor
启动核心线程，使其无法等待工作。
preState - Variable in class javax.swing.undo. StateEdit
编辑前的状态信息
preventDefault() - Method in interface org.w3c.dom.events. Event
如果事件是可取消的，则使用 preventDefault方法来表示事件将被取消，这意味着由于事件而导致的实现中通常采取的任何默认操作都不会发生。
preventExtensions() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
将此脚本对象标记为不可扩展
PREVIEW_PANEL_PROPERTY - Static variable in class javax.swing. JColorChooser
预览面板属性名称。
previewListener - Variable in class javax.swing.plaf.basic. BasicColorChooserUI
实例 ChangeListener 。
previous() - Method in interface java.sql. ResultSet
将光标移动到此 ResultSet对象中的上一行。
previous() - Method in class java.text. BreakIterator
返回当前边界之前的边界。
previous() - Method in interface java.text. CharacterIterator
将迭代器的索引减1，并返回新索引处的字符。
previous() - Method in class java.text. CollationElementIterator
获取字符串中的以前的排序规则元素。
previous() - Method in class java.text. StringCharacterIterator
为String实现CharacterIterator.previous（）。
previous() - Method in interface java.util. ListIterator
返回列表中的上一个元素，并向后移动光标位置。
previous() - Method in class javax.swing.text. ElementIterator
获取上一个元素。
previous() - Method in class javax.swing.text. Segment
将迭代器的索引减1，并返回新索引处的字符。
previous(Container) - Method in class java.awt. CardLayout
翻转到指定容器的前一张卡片。
previous(DayOfWeek) - Static method in class java.time.temporal. TemporalAdjusters
返回上一个星期的调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现。
PREVIOUS - Static variable in class javafx.scene.control. ButtonType
预先定义的ButtonType显示“上一个”，并具有ButtonBar.ButtonData的ButtonBar.ButtonData.BACK_PREVIOUS 。
PREVIOUS - Static variable in interface javax.swing. SwingConstants
标识序列中的上一个方向。
PREVIOUS_CANDIDATE - javafx.scene.input. KeyCode
上一个候选功能键的常数。
previousClearBit(int) - Method in class java.util. BitSet
返回在指定的起始索引上或之前发生的最近位的索引，设置为 false 。
previousConflict() - Method in interface javax.sql.rowset.spi. SyncResolver
将光标从当前位置向上移动到此 SyncResolver对象中的上一个冲突行。
previousDouble(double) - Static method in class java.text. ChoiceFormat
发现最大的双倍小于 d 。
previousIndex() - Method in interface java.util. ListIterator
返回由后续调用 ListIterator.previous()返回的元素的索引。
previousNode() - Method in interface org.w3c.dom.traversal. NodeIterator
返回集合中的上一个节点，并将集合中的 NodeIterator的位置向后移动。
previousNode() - Method in interface org.w3c.dom.traversal. TreeWalker
以相对于当前节点的文档顺序将 TreeWalker移动到上一个可见节点，并返回新节点。
previousOrSame(DayOfWeek) - Static method in class java.time.temporal. TemporalAdjusters
返回之前或相同的日期调整器，该调整器将日期调整为在调整日期之前的指定日期的第一次出现，除非已在当天返回相同的对象。
previousPage() - Method in interface javax.sql.rowset. CachedRowSet
减少当前页面的 CachedRowSet 。
previousSetBit(int) - Method in class java.util. BitSet
返回在指定的起始索引上或之前发生的最近位的索引，设置为 true 。
previousSibling() - Method in class javafx.scene.control. TreeItem
返回TreeItem的以前的同级。
previousSibling() - Method in interface org.w3c.dom.traversal. TreeWalker
将 TreeWalker移动到当前节点的上一个同级，并返回新节点。
previousSibling(TreeItem<T>) - Method in class javafx.scene.control. TreeItem
返回给定节点之前的同级。
previousStatus() - Method in class jdk.jshell. SnippetEvent
过渡前的状况
previousTransition(Instant) - Method in class java.time.zone. ZoneRules
获取指定时刻之前的转换。
previousWord() - Method in class javafx.scene.control. TextInputControl
将插入符号移动到上一个单词的开头。
previousWordAction - Static variable in class javax.swing.text. DefaultEditorKit
Action名称，用于将插入符号移动到上一个单词的开头。
preVisitDirectory(T, BasicFileAttributes) - Method in interface java.nio.file. FileVisitor
在目录中的条目被访问之前调用一个目录。
preVisitDirectory(T, BasicFileAttributes) - Method in class java.nio.file. SimpleFileVisitor
在目录中的条目被访问之前调用一个目录。
PRIMARY - javafx.scene.input. MouseButton
代表主要（按钮1，通常是左）鼠标按钮。
PRIMARY - Static variable in class java.text. Collator
整理器强度值。
primaryOrder(int) - Static method in class java.text. CollationElementIterator
返回排序规则元素的主要组件。
PRIMITIVE_TYPE - com.sun.source.tree. Tree.Kind
用于PrimitiveTypeTree的实例。
PrimitiveIterator< T, T_CONS> - Interface in java.util
Iterator基本专长的基本类型。
PrimitiveIterator.OfDouble - Interface in java.util
一个专门针对 double值的迭代器。
PrimitiveIterator.OfInt - Interface in java.util
一个专门针对 int值的迭代器。
PrimitiveIterator.OfLong - Interface in java.util
一个专门针对 long值的迭代器。
PrimitiveType - Interface in com.sun.jdi
与目标VM中的非对象值相关联的类型。
PrimitiveType - Interface in javax.lang.model.type
表示原始类型。
PrimitiveTypeTree - Interface in com.sun.source.tree
一个原始类型的树节点。
PrimitiveValue - Interface in com.sun.jdi
分配给目标VM中的原始类型的字段或变量的值。
principal() - Method in class java.nio.file.attribute. AclEntry
返回主成分。
Principal - Class in org.omg.CORBA
已过时。
被CORBA弃用2.2。
Principal - Interface in java.security
该接口表示主体的抽象概念，可用于表示任何实体，例如个人，公司和登录ID。
Principal() - Constructor for class org.omg.CORBA. Principal
已过时。
PrincipalComparator - Interface in com.sun.security.auth
实现 java.security.Principal接口的对象通常还实现了该接口，以提供将该对象与指定的 Subject进行比较的 Subject 。
PrincipalHolder - Class in org.omg.CORBA
已过时。
被CORBA弃用2.2。
PrincipalHolder() - Constructor for class org.omg.CORBA. PrincipalHolder
已过时。
构造一个新的 PrincipalHolder对象，其 value字段初始化为 null 。
PrincipalHolder(Principal) - Constructor for class org.omg.CORBA. PrincipalHolder
已过时。
构造一个新的 PrincipalHolder对象，其 value字段初始化为给定的 Principal对象。
print() - Method in class java.awt.print. PrinterJob
打印一组页面。
print() - Method in class javax.swing. JTable
显示打印对话框的方便方法，然后打印 JTable模式 PrintMode.FIT_WIDTH ，没有页眉或页脚文本。
print() - Method in class javax.swing.text. JTextComponent
一种方便的打印方法，显示打印对话框，然后打印 JTextComponent在 交互式模式，没有页眉或页脚文本。
print(boolean) - Method in class java.io. PrintStream
打印布尔值。
print(boolean) - Method in class java.io. PrintWriter
打印布尔值。
print(char) - Method in class java.io. PrintStream
打印一个字符
print(char) - Method in class java.io. PrintWriter
打印一个字符
print(char[]) - Method in class java.io. PrintStream
打印字符数组。
print(char[]) - Method in class java.io. PrintWriter
打印字符数组。
print(double) - Method in class java.io. PrintStream
打印双精度浮点数。
print(double) - Method in class java.io. PrintWriter
打印双精度浮点数。
print(float) - Method in class java.io. PrintStream
打印浮点数。
print(float) - Method in class java.io. PrintWriter
打印浮点数。
print(int) - Method in class java.io. PrintStream
打印一个整数。
print(int) - Method in class java.io. PrintWriter
打印一个整数。
print(long) - Method in class java.io. PrintStream
打印一个长整数。
print(long) - Method in class java.io. PrintWriter
打印一个长整数。
print(Graphics) - Method in class java.awt. Component
打印此组件。
print(Graphics) - Method in class java.awt. Container
打印容器。
print(Graphics) - Method in class javax.swing. JComponent
调用此方法将组件打印到指定的 Graphics 。
print(Graphics, PageFormat, int) - Method in interface java.awt.print. Printable
以指定的格式将指定索引的页面打印到指定的Graphics上下文中。
print(Pageable) - Method in interface javax.jnlp. PrintService
使用给定的 Pageable对象打印文档
print(Printable) - Method in interface javax.jnlp. PrintService
使用给定的 Printable对象打印文档
print(File) - Method in class java.awt. Desktop
使用相关应用程序的打印命令打印本机桌面打印设备的文件。
print(Object) - Method in class java.io. PrintStream
打印一个对象。
print(Object) - Method in class java.io. PrintWriter
打印一个对象。
print(String) - Method in class java.io. PrintStream
打印字符串。
print(String) - Method in class java.io. PrintWriter
打印字符串。
print(MessageFormat, MessageFormat) - Method in class javax.swing.text. JTextComponent
显示打印对话框的便捷打印方法，然后以指定的页眉和页脚文本的 交互模式打印此 JTextComponent 。
print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean) - Method in class javax.swing.text. JTextComponent
打印 JTextComponent的内容。
print(PrinterJob) - Method in class javafx.scene.web. HTMLEditor
使用给定的打印机作业打印编辑器的内容。
print(PrinterJob) - Method in class javafx.scene.web. WebEngine
使用给定的打印机作业打印当前网页。
print(PrintRequestAttributeSet) - Method in class java.awt.print. PrinterJob
使用属性集中的设置打印一组页面。
print(Doc, PrintRequestAttributeSet) - Method in interface javax.print. DocPrintJob
打印具有指定作业属性的文档。
print(MultiDoc, PrintRequestAttributeSet) - Method in interface javax.print. MultiDocPrintJob
打印具有指定作业属性的MultiDoc。
print(JTable.PrintMode) - Method in class javax.swing. JTable
显示打印对话框的方便方法，然后在给定的打印模式下打印 JTable ，没有页眉或页脚文本。
print(JTable.PrintMode, MessageFormat, MessageFormat) - Method in class javax.swing. JTable
显示打印对话框的方便方法，然后以给定的打印模式打印 JTable ，并使用指定的页眉和页脚文本。
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean) - Method in class javax.swing. JTable
按照功能全面的 print方法指定打印此表，默认打印机指定为打印服务。
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService) - Method in class javax.swing. JTable
打印 JTable 。
print(Diagnostic.Kind, DocTreePath, String) - Method in interface jdk.javadoc.doclet. Reporter
打印错误消息并增加错误计数。
print(Diagnostic.Kind, String) - Method in interface jdk.javadoc.doclet. Reporter
打印错误消息和增量错误计数。
print(Diagnostic.Kind, Element, String) - Method in interface jdk.javadoc.doclet. Reporter
打印错误消息并增加错误计数。
PRINT - java.awt. Desktop.Action
表示“打印”动作。
PRINT_SCREEN - Static variable in class java.awt. Event
已过时。
打印屏幕键，非ASCII操作键。
Printable - Interface in java.awt.print
Printable接口由当前页面画家的 print方法实现，该方法由打印系统调用以呈现页面。
PRINTABLE - Static variable in class java.awt. PageAttributes.OriginType
用于指定可打印原点的OriginType实例。
PRINTABLE - Static variable in class javax.print. DocFlavor.SERVICE_FORMATTED
服务格式化打印数据doc风格与打印数据表示类名= "java.awt.print.Printable" （可打印对象）。
printAll(Graphics) - Method in class java.awt. Component
打印此组件及其所有子组件。
printAll(Graphics) - Method in class javax.swing. JComponent
调用此方法打印组件。
printAnySimpleType(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串值转换为字符串。
printAnySimpleType(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串值转换为字符串。
printBase64Binary(byte[]) - Static method in class javax.xml.bind. DatatypeConverter
将字节数组转换为字符串。
printBase64Binary(byte[]) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字节数组转换为字符串。
printBoolean(boolean) - Static method in class javax.xml.bind. DatatypeConverter
将布尔值转换为字符串。
printBoolean(boolean) - Method in interface javax.xml.bind. DatatypeConverterInterface
将布尔值转换为字符串。
printBorder(Graphics) - Method in class javax.swing. JComponent
打印组件的边框。
printByte(byte) - Static method in class javax.xml.bind. DatatypeConverter
将字节值转换为字符串。
printByte(byte) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字节值转换为字符串。
printChildren(Graphics) - Method in class javax.swing. JComponent
打印此组件的子项。
PrintColor - Enum in javafx.print
描述打印是单色还是彩色的类。
printColorProperty() - Method in class javafx.print. JobSettings
代表 PrintColor一个实例的 PrintColor 。
printComponent(Graphics) - Method in class javax.swing. JComponent
这在打印操作期间被调用。
printComponents(Graphics) - Method in class java.awt. Container
打印此容器中的每个组件。
printComponents(Graphics) - Method in class java.awt. ScrollPane
在此滚动窗格中打印组件。
PrintConversionEvent - Interface in javax.xml.bind
此事件表示在将数据从Java内容树转换为其词法表示时遇到问题。
PrintConversionEventImpl - Class in javax.xml.bind.helpers
PrintConversionEvent接口的默认实现。
PrintConversionEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers. PrintConversionEventImpl
创建一个新的PrintConversionEventImpl。
PrintConversionEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers. PrintConversionEventImpl
创建一个新的PrintConversionEventImpl。
printDataTransferCompleted(PrintJobEvent) - Method in class javax.print.event. PrintJobAdapter
被要求通知客户端数据已成功传输到打印服务，客户端可以释放分配给该数据的本地资源。
printDataTransferCompleted(PrintJobEvent) - Method in interface javax.print.event. PrintJobListener
被要求通知客户端数据已成功传输到打印服务，客户端可以释放分配给该数据的本地资源。
printDate(Calendar) - Static method in class javax.xml.bind. DatatypeConverter
将日历值转换为字符串。
printDate(Calendar) - Method in interface javax.xml.bind. DatatypeConverterInterface
将日历值转换为字符串。
printDateTime(Calendar) - Static method in class javax.xml.bind. DatatypeConverter
将日历值转换为字符串。
printDateTime(Calendar) - Method in interface javax.xml.bind. DatatypeConverterInterface
将日历值转换为字符串。
printDecimal(BigDecimal) - Static method in class javax.xml.bind. DatatypeConverter
将BigDecimal值转换为字符串。
printDecimal(BigDecimal) - Method in interface javax.xml.bind. DatatypeConverterInterface
将BigDecimal值转换为字符串。
printDialog() - Method in class java.awt.print. PrinterJob
向用户呈现一个对话框，用于更改打印作业的属性。
printDialog(GraphicsConfiguration, int, int, PrintService[], PrintService, DocFlavor, PrintRequestAttributeSet) - Static method in class javax.print. ServiceUI
向用户呈现一个对话框，用于选择打印服务（打印机）。
printDialog(PrintRequestAttributeSet) - Method in class java.awt.print. PrinterJob
一种方便的方法，显示可以使用 Pageable界面打印2D图形的所有服务的跨平台打印对话框。
printDouble(double) - Static method in class javax.xml.bind. DatatypeConverter
将double值转换为字符串。
printDouble(double) - Method in interface javax.xml.bind. DatatypeConverterInterface
将double值转换为字符串。
printElements(Writer, Element...) - Method in interface javax.lang.model.util. Elements
以指定的顺序将元素的表示打印到给定的作者。
Printer - Class in javafx.print
打印机实例表示打印作业的目的地。
PRINTER - Static variable in class java.awt. JobAttributes.DestinationType
用于指定打印机打印的 DestinationType实例。
PRINTER_STOPPED - Static variable in class javax.print.attribute.standard. JobStateReason
打印机的值为PrinterState属性ia STOPPED。
PRINTER_STOPPED_PARTLY - Static variable in class javax.print.attribute.standard. JobStateReason
打印机的PrinterStateReasons属性的值包含一个PrinterStateReason的STOPPED_PARTLY值。
Printer.MarginType - Enum in javafx.print
MarginType用于确定PageLayout的可打印区域。
PrinterAbortException - Exception in java.awt.print
所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。
PrinterAbortException() - Constructor for exception java.awt.print. PrinterAbortException
构造一个新的 PrinterAbortException ，没有详细信息。
PrinterAbortException(String) - Constructor for exception java.awt.print. PrinterAbortException
构造一个新的 PrinterAbortException具有指定的详细消息。
PrinterAttributes - Class in javafx.print
该类封装了与其作业打印功能和其他属性相关的打印机的属性。
PrinterException - Exception in java.awt.print
PrinterException类及其子类用于指示在打印系统中发生异常情况。
PrinterException() - Constructor for exception java.awt.print. PrinterException
构造一个新的 PrinterException对象，没有详细消息。
PrinterException(String) - Constructor for exception java.awt.print. PrinterException
构造具有指定详细消息的新的 PrinterException对象。
PrinterGraphics - Interface in java.awt.print
PrinterGraphics接口由Graphics对象实现，传递给Printable对象以呈现页面。
PrinterInfo - Class in javax.print.attribute.standard
PrinterInfo类是一个打印属性类，一个文本属性，它提供有关打印机的描述信息。
PrinterInfo(String, Locale) - Constructor for class javax.print.attribute.standard. PrinterInfo
使用给定的信息字符串和语言环境构造新的打印机信息属性。
PrinterIOException - Exception in java.awt.print
该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。
PrinterIOException(IOException) - Constructor for exception java.awt.print. PrinterIOException
构造一个新的PrinterIOException与指定的IOException的字符串表示形式 。
PrinterIsAcceptingJobs - Class in javax.print.attribute.standard
PrinterIsAcceptingJobs类是打印属性类，枚举，指示打印机当前是否能够接受作业。
PrinterIsAcceptingJobs(int) - Constructor for class javax.print.attribute.standard. PrinterIsAcceptingJobs
构造新的打印机正在接受具有给定整数值的作业枚举值。
PrinterJob - Class in java.awt.print
PrinterJob类是控制打印的主要类。
PrinterJob - Class in javafx.print
PrinterJob是JavaFX场景打印的起点。
PrinterJob() - Constructor for class java.awt.print. PrinterJob
应使用静态的 getPrinterJob方法创建一个 PrinterJob对象。
PrinterJob.JobStatus - Enum in javafx.print
用于报告打印作业状态的枚举类。
PrinterLocation - Class in javax.print.attribute.standard
PrinterLocation类是打印属性类，一个文本属性，用于标识设备的位置。
PrinterLocation(String, Locale) - Constructor for class javax.print.attribute.standard. PrinterLocation
构造具有给定位置和区域设置的新的打印机位置属性。
PrinterMakeAndModel - Class in javax.print.attribute.standard
PrinterMakeAndModel类是打印属性类，文本属性，即打印机的制造商和型号。
PrinterMakeAndModel(String, Locale) - Constructor for class javax.print.attribute.standard. PrinterMakeAndModel
使用给定的make和model字符串和locale构造一个新的打印机make和model属性。
PrinterMessageFromOperator - Class in javax.print.attribute.standard
PrinterMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示打印机的信息或状态，例如为什么不可用或何时预计可用。
PrinterMessageFromOperator(String, Locale) - Constructor for class javax.print.attribute.standard. PrinterMessageFromOperator
使用给定的消息和区域设置构造来自operator属性的新打印机消息。
PrinterMoreInfo - Class in javax.print.attribute.standard
PrinterMoreInfo类是打印属性类（URI），用于获取有关此特定打印机的更多信息。
PrinterMoreInfo(URI) - Constructor for class javax.print.attribute.standard. PrinterMoreInfo
使用指定的URI构造一个新的打印机more info属性。
PrinterMoreInfoManufacturer - Class in javax.print.attribute.standard
PrinterMoreInfoManufacturer类是打印属性类（URI），用于获取有关此类设备的更多信息。
PrinterMoreInfoManufacturer(URI) - Constructor for class javax.print.attribute.standard. PrinterMoreInfoManufacturer
使用指定的URI构造新的打印机更多信息制造商属性。
PrinterName - Class in javax.print.attribute.standard
PrinterName类是一个打印属性类，一个指定打印机名称的文本属性。
PrinterName(String, Locale) - Constructor for class javax.print.attribute.standard. PrinterName
构造具有给定名称和区域设置的新的打印机名称属性。
printerProperty() - Method in class javafx.print. PrinterJob
代表此职位的 Printer财产。
PrinterResolution - Class in javax.print.attribute.standard
PrinterResolution类是一个打印属性类，它指定打印机支持的准确分辨率或用于打印作业。
PrinterResolution(int, int, int) - Constructor for class javax.print.attribute.standard. PrinterResolution
从给定项目构建新的打印机分辨率属性。
printError(SourcePosition, String) - Method in interface com.sun.javadoc. DocErrorReporter
已过时。
打印错误消息并增加错误计数。
printError(String) - Method in interface com.sun.javadoc. DocErrorReporter
已过时。
打印错误消息和增量错误计数。
PrinterState - Class in javax.print.attribute.standard
PrinterState类是打印属性类，枚举，用于标识打印机的当前状态。
PrinterState(int) - Constructor for class javax.print.attribute.standard. PrinterState
使用给定的整数值构造新的打印机状态枚举值。
PrinterStateReason - Class in javax.print.attribute.standard
PrinterStateReason类是一个打印属性类，枚举，提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
PrinterStateReason(int) - Constructor for class javax.print.attribute.standard. PrinterStateReason
使用给定的整数值构造新的打印机状态原因枚举值。
PrinterStateReasons - Class in javax.print.attribute.standard
PrinterStateReasons类是打印属性类，一组枚举值，它们提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
PrinterStateReasons() - Constructor for class javax.print.attribute.standard. PrinterStateReasons
构造一个新的，空的打印机状态原因属性; 底层哈希映射具有默认的初始容量和负载因子。
PrinterStateReasons(int) - Constructor for class javax.print.attribute.standard. PrinterStateReasons
超级新的，空的打印机状态原因属性; 底层哈希映射具有给定的初始容量和默认负载因子。
PrinterStateReasons(int, float) - Constructor for class javax.print.attribute.standard. PrinterStateReasons
构造一个新的，空的打印机状态原因属性; 底层哈希映射具有给定的初始容量和负载因子。
PrinterStateReasons(Map<PrinterStateReason, Severity>) - Constructor for class javax.print.attribute.standard. PrinterStateReasons
构造新的打印机状态原因属性，其中包含与给定地图相同的PrinterStateReason -to-Severity映射。
printerStateReasonSet(Severity) - Method in class javax.print.attribute.standard. PrinterStateReasons
在此PrinterStateReasons属性中，以给定的严重级别获取不可修改的打印机状态原因属性的集合视图。
PrinterURI - Class in javax.print.attribute.standard
PrinterURI类是一个打印属性类，一个URI，它指定打印机的全局唯一名称。
PrinterURI(URI) - Constructor for class javax.print.attribute.standard. PrinterURI
使用指定的URI构造一个新的PrinterURI属性。
PrintEvent - Class in javax.print.event
PrintEvent类是所有Print Service API事件的超类。
PrintEvent(Object) - Constructor for class javax.print.event. PrintEvent
构造一个PrintEvent对象。
PrintException - Exception in javax.print
PrintException类封装了在使用Print Service实例时发生的与打印相关的错误条件。
PrintException() - Constructor for exception javax.print. PrintException
构造没有详细消息的打印异常。
PrintException(Exception) - Constructor for exception javax.print. PrintException
构造打印异常链接提供的异常。
PrintException(String) - Constructor for exception javax.print. PrintException
使用给定的详细信息构造打印例外。
PrintException(String, Exception) - Constructor for exception javax.print. PrintException
使用给定的详细消息和链接异常构造打印异常。
printf(String, Object...) - Method in class java.io. Console
使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流的便利方法。
printf(String, Object...) - Method in class java.io. PrintStream
使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。
printf(String, Object...) - Method in class java.io. PrintWriter
使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。
printf(Locale, String, Object...) - Method in class java.io. PrintStream
使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。
printf(Locale, String, Object...) - Method in class java.io. PrintWriter
使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。
printFiles(PrintFilesEvent) - Method in interface java.awt.desktop. PrintFilesHandler
当应用程序被要求打印文件列表时调用。
PrintFilesEvent - Class in java.awt.desktop
当应用程序被要求打印文件列表时发送事件。
PrintFilesEvent(List<File>) - Constructor for class java.awt.desktop. PrintFilesEvent
构造一个 PrintFilesEvent
PrintFilesHandler - Interface in java.awt.desktop
实施者可以响应打印应用程序注册处理的文档的请求。
printFloat(float) - Static method in class javax.xml.bind. DatatypeConverter
将float值转换为字符串。
printFloat(float) - Method in interface javax.xml.bind. DatatypeConverterInterface
将float值转换为字符串。
PrintGraphics - Interface in java.awt
一个为页面提供打印图形上下文的抽象类。
printHexBinary(byte[]) - Static method in class javax.xml.bind. DatatypeConverter
将字节数组转换为字符串。
printHexBinary(byte[]) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字节数组转换为字符串。
PRINTING - javafx.print. PrinterJob.JobStatus
该作业已经要求打印至少一个页面，并且还没有终止打印。
printInt(int) - Static method in class javax.xml.bind. DatatypeConverter
将int值转换为字符串。
printInt(int) - Method in interface javax.xml.bind. DatatypeConverterInterface
将int值转换为字符串。
printInteger(BigInteger) - Static method in class javax.xml.bind. DatatypeConverter
将BigInteger值转换为字符串。
printInteger(BigInteger) - Method in interface javax.xml.bind. DatatypeConverterInterface
将BigInteger值转换为字符串。
PrintJob - Class in java.awt
一个启动和执行打印作业的抽象类。
PrintJob() - Constructor for class java.awt. PrintJob
PrintJobAdapter - Class in javax.print.event
用于接收打印作业事件的抽象适配器类。
PrintJobAdapter() - Constructor for class javax.print.event. PrintJobAdapter
PrintJobAttribute - Interface in javax.print.attribute
PrintJobAttribute是打印属性类实现的标记界面，用于指示属性描述打印作业的状态或打印作业的其他一些特性。
PrintJobAttributeEvent - Class in javax.print.event
PrintJobAttributeEvent类封装PrintService报告的事件，让客户端知道PrintJob的一个或多个打印属性已更改。
PrintJobAttributeEvent(DocPrintJob, PrintJobAttributeSet) - Constructor for class javax.print.event. PrintJobAttributeEvent
构造一个PrintJobAttributeEvent对象。
PrintJobAttributeListener - Interface in javax.print.event
该接口的实现被附加到DocPrintJob以监视与打印作业相关联的属性改变的状态。
PrintJobAttributeSet - Interface in javax.print.attribute
界面PrintJobAttributeSet指定一组打印作业属性的接口，即打印实现接口PrintJobAttribute的属性。
printJobCanceled(PrintJobEvent) - Method in class javax.print.event. PrintJobAdapter
被要求通知客户该作业被用户或程序取消。
printJobCanceled(PrintJobEvent) - Method in interface javax.print.event. PrintJobListener
被要求通知客户该作业被用户或程序取消。
printJobCompleted(PrintJobEvent) - Method in class javax.print.event. PrintJobAdapter
被要求通知客户该作业成功完成。
printJobCompleted(PrintJobEvent) - Method in interface javax.print.event. PrintJobListener
被要求通知客户该作业成功完成。
PrintJobEvent - Class in javax.print.event
PrintJobEvent类封装了打印作业报告的常见事件，让听众知道处理DocPrintJob的进度 。
PrintJobEvent(DocPrintJob, int) - Constructor for class javax.print.event. PrintJobEvent
构造一个 PrintJobEvent对象。
printJobFailed(PrintJobEvent) - Method in class javax.print.event. PrintJobAdapter
被要求通知客户该作业未成功完成，必须重新提交。
printJobFailed(PrintJobEvent) - Method in interface javax.print.event. PrintJobListener
被要求通知客户该作业未成功完成，必须重新提交。
PrintJobListener - Interface in javax.print.event
此监听器接口的实现应附加到DocPrintJob以监视打印机作业的状态。
printJobNoMoreEvents(PrintJobEvent) - Method in class javax.print.event. PrintJobAdapter
被要求通知客户不会再发送任何事件。
printJobNoMoreEvents(PrintJobEvent) - Method in interface javax.print.event. PrintJobListener
被要求通知客户不会再发送任何事件。
printJobRequiresAttention(PrintJobEvent) - Method in class javax.print.event. PrintJobAdapter
被要求通知客户某些可能出现用户纠正的问题（例如打印机缺纸）。
printJobRequiresAttention(PrintJobEvent) - Method in interface javax.print.event. PrintJobListener
调用通知客户端发生了用户可能修复的错误。
println() - Method in class java.io. PrintStream
通过写入行分隔符字符串来终止当前行。
println() - Method in class java.io. PrintWriter
通过写入行分隔符字符串来终止当前行。
println(boolean) - Method in class java.io. PrintStream
打印一个布尔值，然后终止该行。
println(boolean) - Method in class java.io. PrintWriter
打印一个布尔值，然后终止该行。
println(char) - Method in class java.io. PrintStream
打印一个字符，然后终止该行。
println(char) - Method in class java.io. PrintWriter
打印一个字符，然后终止该行。
println(char[]) - Method in class java.io. PrintStream
打印一个字符数组，然后终止该行。
println(char[]) - Method in class java.io. PrintWriter
打印字符数组，然后终止行。
println(double) - Method in class java.io. PrintStream
打印一次，然后终止行。
println(double) - Method in class java.io. PrintWriter
打印双精度浮点数，然后终止行。
println(float) - Method in class java.io. PrintStream
打印一个浮点数，然后终止该行。
println(float) - Method in class java.io. PrintWriter
打印一个浮点数，然后终止该行。
println(int) - Method in class java.io. PrintStream
打印一个整数，然后终止行。
println(int) - Method in class java.io. PrintWriter
打印一个整数，然后终止该行。
println(long) - Method in class java.io. PrintStream
打印很长时间，然后终止行。
println(long) - Method in class java.io. PrintWriter
打印一个长整型，然后终止行。
println(Object) - Method in class java.io. PrintStream
打印一个对象，然后终止该行。
println(Object) - Method in class java.io. PrintWriter
打印一个对象，然后终止该行。
println(String) - Method in class java.io. PrintStream
打印一个字符串，然后终止行。
println(String) - Method in class java.io. PrintWriter
打印一个字符串，然后终止行。
println(String) - Static method in class java.sql. DriverManager
打印到当前JDBC日志流的消息。
printLong(long) - Static method in class javax.xml.bind. DatatypeConverter
将长整型值转换为字符串。
printLong(long) - Method in interface javax.xml.bind. DatatypeConverterInterface
将一个长的值转换成一个字符串。
printMessage(Diagnostic.Kind, CharSequence) - Method in interface javax.annotation.processing. Messager
打印指定类型的消息。
printMessage(Diagnostic.Kind, CharSequence, DocTree, DocCommentTree, CompilationUnitTree) - Method in class com.sun.source.util. DocTrees
在提供的编译单元中的树的位置打印指定类型的消息
printMessage(Diagnostic.Kind, CharSequence, Tree, CompilationUnitTree) - Method in class com.sun.source.util. Trees
在提供的编译单元中的树的位置打印指定类型的消息
printMessage(Diagnostic.Kind, CharSequence, Element) - Method in interface javax.annotation.processing. Messager
在元素的位置打印指定类型的消息。
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror) - Method in interface javax.annotation.processing. Messager
在注释元素的注释镜像的位置打印指定类型的消息。
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror, AnnotationValue) - Method in interface javax.annotation.processing. Messager
在注释元素的注释镜像内的注释值的位置打印指定类型的消息。
printNotice(SourcePosition, String) - Method in interface com.sun.javadoc. DocErrorReporter
已过时。
打印信息。
printNotice(String) - Method in interface com.sun.javadoc. DocErrorReporter
已过时。
打印信息。
printPage(PageLayout, Node) - Method in class javafx.print. PrinterJob
使用指定的页面布局打印指定的节点。
printPage(Node) - Method in class javafx.print. PrinterJob
打印指定的节点。
printQName(QName, NamespaceContext) - Static method in class javax.xml.bind. DatatypeConverter
将QName实例转换为字符串。
printQName(QName, NamespaceContext) - Method in interface javax.xml.bind. DatatypeConverterInterface
将QName实例转换为字符串。
PrintQuality - Class in javax.print.attribute.standard
PrintQuality类是打印属性类（枚举），用于指定打印机用于作业的打印质量。
PrintQuality - Enum in javafx.print
分类打印质量设置。
PrintQuality(int) - Constructor for class javax.print.attribute.standard. PrintQuality
使用给定的整数值构造新的打印质量枚举值。
printQualityProperty() - Method in class javafx.print. JobSettings
属性代表 PrintQuality的实例。
PrintRequestAttribute - Interface in javax.print.attribute
接口PrintRequestAttribute是打印属性类实现的标记接口，用于指示属性表示打印作业的请求设置。
PrintRequestAttributeSet - Interface in javax.print.attribute
Interface PrintRequestAttributeSet指定一组打印请求属性的接口，即打印实现PrintRequestAttribute接口的属性 。
PrintResolution - Class in javafx.print
类别表示打印机在进给和交叉进给方向上的支持的设备分辨率，单位英寸（DPI）。
printResolutionProperty() - Method in class javafx.print. JobSettings
代表 PrintResolution的实例的 PrintResolution 。
PRINTSCREEN - javafx.scene.input. KeyCode
常数为 Print Screen键。
PrintService - Interface in javax.jnlp
PrintService提供了访问打印功能的方法，即使是在不受信任的执行环境中运行的应用程序。
PrintService - Interface in javax.print
Interface PrintService是DocPrintJob的工厂。
PrintServiceAttribute - Interface in javax.print.attribute
接口PrintServiceAttribute是打印属性类实现的标记接口，用于指示属性描述打印服务的状态或打印服务的其他特性。
PrintServiceAttributeEvent - Class in javax.print.event
PrintServiceAttributeEvent类封装Print Service实例报告的事件，让客户端了解打印服务状态的变化。
PrintServiceAttributeEvent(PrintService, PrintServiceAttributeSet) - Constructor for class javax.print.event. PrintServiceAttributeEvent
构造一个PrintServiceAttributeEvent对象。
PrintServiceAttributeListener - Interface in javax.print.event
此监听器接口的实现被附加到PrintService以监视打印服务的状态。
PrintServiceAttributeSet - Interface in javax.print.attribute
接口PrintServiceAttributeSet指定一组打印作业属性的接口，即打印实现接口PrintServiceAttribute的属性。
PrintServiceLookup - Class in javax.print
该类的实现为特定类型的打印服务（通常相当于打印机）提供查找服务。
PrintServiceLookup() - Constructor for class javax.print. PrintServiceLookup
printShort(short) - Static method in class javax.xml.bind. DatatypeConverter
将一个简短的值转换成一个字符串。
printShort(short) - Method in interface javax.xml.bind. DatatypeConverterInterface
将一个简短的值转换成一个字符串。
PrintSides - Enum in javafx.print
列举可能的双面（双面）打印模式的类。
printSidesProperty() - Method in class javafx.print. JobSettings
代表 PrintSides的实例的 PrintSides 。
printStackTrace() - Method in class java.lang. Throwable
将此throwable和其追溯打印到标准错误流。
printStackTrace() - Method in exception javax.xml.bind. JAXBException
将此JAXBException及其堆栈跟踪（包括linkedException的堆栈跟踪（如果非空）） System.err到 System.err 。
printStackTrace() - Method in exception javax.xml.bind. TypeConstraintException
将此TypeConstraintException及其堆栈跟踪（包括linkedException的堆栈跟踪（如果非空）） System.err到 System.err 。
printStackTrace() - Method in exception javax.xml.crypto.dsig. TransformException
打印 TransformException ，其回溯和原因的回溯到标准错误流。
printStackTrace() - Method in exception javax.xml.crypto.dsig. XMLSignatureException
打印 XMLSignatureException ，其回溯和原因回溯到标准错误流。
printStackTrace() - Method in exception javax.xml.crypto. KeySelectorException
打印 KeySelectorException ，其回溯和原因回溯到标准错误流。
printStackTrace() - Method in exception javax.xml.crypto. MarshalException
打印 MarshalException ，其回溯和原因回溯到标准错误流。
printStackTrace() - Method in exception javax.xml.crypto. NoSuchMechanismException
打印这个 NoSuchMechanismException ，它的回溯和原因的回溯到标准错误流。
printStackTrace() - Method in exception javax.xml.crypto. URIReferenceException
打印 URIReferenceException ，其回溯和原因回溯到标准错误流。
printStackTrace() - Method in exception javax.xml.transform. TransformerException
从出现错误的地方打印出痕迹的方法。
printStackTrace() - Method in exception javax.xml.xpath. XPathException
打印堆栈跟踪到 System.err 。
printStackTrace(PrintStream) - Method in class java.lang. Throwable
将此throwable和其追溯打印到指定的打印流。
printStackTrace(PrintStream) - Method in exception javax.xml.bind. JAXBException
打印此JAXBException及其堆栈跟踪（包括链接异常的堆栈跟踪（如果非空））到PrintStream。
printStackTrace(PrintStream) - Method in exception javax.xml.bind. TypeConstraintException
将PrintCryptException及其堆栈跟踪（包括linkedException的堆栈跟踪（如果非空））打印到PrintStream。
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.dsig. TransformException
打印 TransformException ，其回溯和原因回溯到指定的打印流。
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.dsig. XMLSignatureException
打印 XMLSignatureException ，其回溯和原因回溯到指定的打印流。
printStackTrace(PrintStream) - Method in exception javax.xml.crypto. KeySelectorException
打印 KeySelectorException ，其回溯和原因回溯到指定的打印流。
printStackTrace(PrintStream) - Method in exception javax.xml.crypto. MarshalException
打印 MarshalException ，其回溯和原因回溯到指定的打印流。
printStackTrace(PrintStream) - Method in exception javax.xml.crypto. NoSuchMechanismException
打印 NoSuchMechanismException ，其回溯和原因回溯到指定的打印流。
printStackTrace(PrintStream) - Method in exception javax.xml.crypto. URIReferenceException
打印 URIReferenceException ，其回溯和原因回溯到指定的打印流。
printStackTrace(PrintStream) - Method in exception javax.xml.transform. TransformerException
从出现错误的地方打印出痕迹的方法。
printStackTrace(PrintStream) - Method in exception javax.xml.xpath. XPathException
打印堆栈跟踪到指定的 PrintStream 。
printStackTrace(PrintWriter) - Method in class java.lang. Throwable
将此throwable和其追溯打印到指定的打印作者。
printStackTrace(PrintWriter) - Method in exception javax.xml.bind. JAXBException
打印此JAXBException及其堆栈跟踪（包括链接异常的堆栈跟踪（如果非空））到PrintWriter。
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.dsig. TransformException
打印 TransformException ，其回溯和原因回溯到指定的打印作者。
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.dsig. XMLSignatureException
打印 XMLSignatureException ，其回溯和原因回溯到指定的打印作者。
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto. KeySelectorException
打印 KeySelectorException ，其回溯和原因的回溯到指定的打印作者。
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto. MarshalException
打印 MarshalException ，它的回溯和原因的回溯到指定的打印作者。
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto. NoSuchMechanismException
打印 NoSuchMechanismException ，其回溯和原因回溯到指定的打印作者。
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto. URIReferenceException
打印 URIReferenceException ，其回溯和原因回溯到指定的打印作者。
printStackTrace(PrintWriter) - Method in exception javax.xml.transform. TransformerException
从出现错误的地方打印出痕迹的方法。
printStackTrace(PrintWriter) - Method in exception javax.xml.xpath. XPathException
打印堆栈跟踪指定为 PrintWriter 。
PrintStream - Class in java.io
A PrintStream向另一个输出流添加功能，即方便地打印各种数据值的表示的能力。
PrintStream(File) - Constructor for class java.io. PrintStream
使用指定的文件创建一个新的打印流，而不需要自动换行。
PrintStream(File, String) - Constructor for class java.io. PrintStream
使用指定的文件和字符集创建新的打印流，而不需要自动换行。
PrintStream(OutputStream) - Constructor for class java.io. PrintStream
创建一个新的打印流。
PrintStream(OutputStream, boolean) - Constructor for class java.io. PrintStream
创建一个新的打印流。
PrintStream(OutputStream, boolean, String) - Constructor for class java.io. PrintStream
创建一个新的打印流。
PrintStream(String) - Constructor for class java.io. PrintStream
使用指定的文件名创建新的打印流，无需自动换行。
PrintStream(String, String) - Constructor for class java.io. PrintStream
创建一个新的打印流，不需要自动换行，具有指定的文件名和字符集。
printString(String) - Static method in class javax.xml.bind. DatatypeConverter
将字符串参数转换为字符串。
printString(String) - Method in interface javax.xml.bind. DatatypeConverterInterface
将字符串参数转换为字符串。
printTime(Calendar) - Static method in class javax.xml.bind. DatatypeConverter
将日历值转换为字符串。
printTime(Calendar) - Method in interface javax.xml.bind. DatatypeConverterInterface
将日历值转换为字符串。
printUnsignedInt(long) - Static method in class javax.xml.bind. DatatypeConverter
将一个长的值转换成一个字符串。
printUnsignedInt(long) - Method in interface javax.xml.bind. DatatypeConverterInterface
将一个长的值转换成一个字符串。
printUnsignedShort(int) - Static method in class javax.xml.bind. DatatypeConverter
将int值转换为字符串。
printUnsignedShort(int) - Method in interface javax.xml.bind. DatatypeConverterInterface
将int值转换为字符串。
printWarning(SourcePosition, String) - Method in interface com.sun.javadoc. DocErrorReporter
已过时。
打印警告信息并增加警告计数。
printWarning(String) - Method in interface com.sun.javadoc. DocErrorReporter
已过时。
打印警告信息并增加警告计数。
PrintWriter - Class in java.io
将对象的格式表示打印到文本输出流。
PrintWriter(File) - Constructor for class java.io. PrintWriter
使用指定的文件创建一个新的PrintWriter，而不需要自动的线路刷新。
PrintWriter(File, String) - Constructor for class java.io. PrintWriter
使用指定的文件和字符集创建一个新的PrintWriter，而不需要自动进行线条刷新。
PrintWriter(OutputStream) - Constructor for class java.io. PrintWriter
从现有的OutputStream创建一个新的PrintWriter，而不需要自动线路刷新。
PrintWriter(OutputStream, boolean) - Constructor for class java.io. PrintWriter
从现有的OutputStream创建一个新的PrintWriter。
PrintWriter(Writer) - Constructor for class java.io. PrintWriter
创建一个新的PrintWriter，没有自动线冲洗。
PrintWriter(Writer, boolean) - Constructor for class java.io. PrintWriter
创建一个新的PrintWriter。
PrintWriter(String) - Constructor for class java.io. PrintWriter
使用指定的文件名创建一个新的PrintWriter，而不需要自动执行行刷新。
PrintWriter(String, String) - Constructor for class java.io. PrintWriter
使用指定的文件名和字符集创建一个新的PrintWriter，而不需要自动线路刷新。
PRIOR - Static variable in class java.awt. BufferCapabilities.FlipContents
当翻转内容为 PRIOR ，后台缓冲区的内容是前缓冲区的前一个内容（真正的页面翻页）。
priority() - Method in class jdk.net. SocketFlow
返回此SocketFlow的优先级。
priority(int) - Method in class jdk.incubator.http. HttpClient.Builder
设置从此客户端发送的任何HTTP / 2请求的默认优先级。
priority(int) - Method in class jdk.net. SocketFlow
设置这个SocketFlow的优先级。
Priority - Enum in javafx.scene.layout
用于确定给定节点的布局区域在其区域具有更多（或更少）空间可用并且多个节点竞争该空间时的增长（或收缩）优先级的枚举。
PRIORITY_INTERCHAR - Static variable in class java.awt.font. GlyphJustificationInfo
第二低的理由优先。
PRIORITY_KASHIDA - Static variable in class java.awt.font. GlyphJustificationInfo
最高的理由优先。
PRIORITY_NONE - Static variable in class java.awt.font. GlyphJustificationInfo
最低的理由优先。
PRIORITY_WHITESPACE - Static variable in class java.awt.font. GlyphJustificationInfo
第二高的理由优先。
PriorityBlockingQueue< E> - Class in java.util.concurrent
无限blocking queue使用与类别PriorityQueue相同的排序规则，并提供阻止检索操作。
PriorityBlockingQueue() - Constructor for class java.util.concurrent. PriorityBlockingQueue
创建一个PriorityBlockingQueue ，其默认初始容量（11）根据其natural ordering对其元素进行排序 。
PriorityBlockingQueue(int) - Constructor for class java.util.concurrent. PriorityBlockingQueue
创建一个PriorityBlockingQueue具有指定的初始容量，根据它们的natural ordering对其元素进行排序 。
PriorityBlockingQueue(int, Comparator<? super E>) - Constructor for class java.util.concurrent. PriorityBlockingQueue
创建具有指定初始容量的 PriorityBlockingQueue ，根据指定的比较器对其元素进行排序。
PriorityBlockingQueue(Collection<? extends E>) - Constructor for class java.util.concurrent. PriorityBlockingQueue
创建一个 PriorityBlockingQueue其中包含指定集合中的元素。
priorityProperty() - Method in class javafx.scene.media. AudioClip
剪辑相对于其他剪辑的相对优先级。
PriorityQueue< E> - Class in java.util
基于优先级堆的无限优先级queue 。
PriorityQueue() - Constructor for class java.util. PriorityQueue
创建一个PriorityQueue ，默认的初始容量（11），根据它们的natural ordering对其元素进行排序 。
PriorityQueue(int) - Constructor for class java.util. PriorityQueue
创建具有指定的初始容量的PriorityQueue ，根据它们的natural ordering对其元素进行排序 。
PriorityQueue(int, Comparator<? super E>) - Constructor for class java.util. PriorityQueue
创建具有指定初始容量的 PriorityQueue ，根据指定的比较器对其元素进行排序。
PriorityQueue(Collection<? extends E>) - Constructor for class java.util. PriorityQueue
创建一个包含指定集合中的元素的 PriorityQueue 。
PriorityQueue(Comparator<? super E>) - Constructor for class java.util. PriorityQueue
创建具有默认初始容量的 PriorityQueue ，并根据指定的比较器对其元素进行排序。
PriorityQueue(PriorityQueue<? extends E>) - Constructor for class java.util. PriorityQueue
创建包含指定优先级队列中的元素的 PriorityQueue 。
PriorityQueue(SortedSet<? extends E>) - Constructor for class java.util. PriorityQueue
创建包含指定排序集中的元素的 PriorityQueue 。
PRIVATE - java.security. KeyRep.Type
键入私钥。
PRIVATE - javax.lang.model.element. Modifier
修饰词 private
PRIVATE - Static variable in class java.lang.invoke. MethodHandles.Lookup
代表 private访问的单位掩码，可能有助于 lookupModes的结果。
PRIVATE - Static variable in class java.lang.reflect. Modifier
int值代表 private修饰符。
PRIVATE - Static variable in class java.nio.channels. FileChannel.MapMode
私有（写时复制）映射模式。
PRIVATE_KEY - Static variable in class javax.crypto. Cipher
用于指示要解除密钥的常数是“私钥”。
PRIVATE_MEMBER - Interface in org.omg.CORBA
在 ValueMember类中定义私有成员的 ValueMember 。
PRIVATE_USE - Static variable in class java.lang. Character
Unicode规范中的一般类别“Co”。
PRIVATE_USE_AREA - Static variable in class java.lang. Character.UnicodeBlock
“私用区域”Unicode字符块的常量。
PRIVATE_USE_EXTENSION - Static variable in class java.util. Locale
私人使用扩展（'x'）的关键。
PrivateClassLoader - Interface in javax.management.loading
标记界面指示不应将ClassLoader添加到ClassLoaderRepository 。
PrivateCredentialPermission - Class in javax.security.auth
此类用于保护对属于特定 Subject私有凭据的访问。
PrivateCredentialPermission(String, String) - Constructor for class javax.security.auth. PrivateCredentialPermission
创建一个新的 PrivateCredentialPermission与指定的 name 。
PrivateKey - Interface in java.security
私钥。
PrivateKeyEntry(PrivateKey, Certificate[]) - Constructor for class java.security. KeyStore.PrivateKeyEntry
构建一个 PrivateKeyEntry与 PrivateKey和相应的证书链。
PrivateKeyEntry(PrivateKey, Certificate[], Set<KeyStore.Entry.Attribute>) - Constructor for class java.security. KeyStore.PrivateKeyEntry
构造一个具有 PrivateKeyEntry的 PrivateKey及相应的证书链和相关的条目属性。
privateLookupIn(Class<?>, MethodHandles.Lookup) - Static method in class java.lang.invoke. MethodHandles
返回一个lookup object，具有完整功能，可以模拟目标类上的所有支持的字节码行为，包括private access 。
PrivateMLet - Class in javax.management.loading
未添加到ClassLoaderRepository的MLet。
PrivateMLet(URL[], boolean) - Constructor for class javax.management.loading. PrivateMLet
使用默认的委派父类ClassLoader构造一个新的指定URL的PrivateMLet。
PrivateMLet(URL[], ClassLoader, boolean) - Constructor for class javax.management.loading. PrivateMLet
为给定的URL构造一个新的PrivateMLet。
PrivateMLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - Constructor for class javax.management.loading. PrivateMLet
为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的PrivateMLet。
PRIVILEGE_WITHDRAWN - java.security.cert. CRLReason
这个原因表明授予证书主体的特权已被撤回。
PrivilegedAction< T> - Interface in java.security
要启用权限执行的计算。
PrivilegedActionException - Exception in java.security
doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)抛出此异常，以指示正在执行的操作会抛出已检查的异常。
PrivilegedActionException(Exception) - Constructor for exception java.security. PrivilegedActionException
构造一个新的PrivilegedActionException“包装”特定的异常。
privilegedCallable(Callable<T>) - Static method in class java.util.concurrent. Executors
返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable 。
privilegedCallableUsingCurrentClassLoader(Callable<T>) - Static method in class java.util.concurrent. Executors
返回一个Callable对象，当被调用时，将在当前访问控制上下文中执行给定的callable ，当前上下文类加载器作为上下文类加载器。
PrivilegedExceptionAction< T> - Interface in java.security
要启用权限执行的计算，会抛出一个或多个已检查的异常。
privilegedThreadFactory() - Static method in class java.util.concurrent. Executors
返回一个用于创建与当前线程具有相同权限的新线程的线程工厂。
probableKind() - Method in class jdk.jshell. ErroneousSnippet
在这个错误的片段中返回看起来是什么样的类型。
probablePrime(int, Random) - Static method in class java.math. BigInteger
返回一个正的BigInteger，它可能是素数，具有指定的位长度。
probeContentType(Path) - Static method in class java.nio.file. Files
探测文件的内容类型。
probeContentType(Path) - Method in class java.nio.file.spi. FileTypeDetector
探测给定的文件来猜测其内容类型。
procedureColumnIn - Static variable in interface java.sql. DatabaseMetaData
表示列存储IN参数。
procedureColumnInOut - Static variable in interface java.sql. DatabaseMetaData
表示列存储INOUT参数。
procedureColumnOut - Static variable in interface java.sql. DatabaseMetaData
表示列存储OUT参数。
procedureColumnResult - Static variable in interface java.sql. DatabaseMetaData
表示列存储结果。
procedureColumnReturn - Static variable in interface java.sql. DatabaseMetaData
表示列存储返回值。
procedureColumnUnknown - Static variable in interface java.sql. DatabaseMetaData
表示列的类型未知。
procedureNoNulls - Static variable in interface java.sql. DatabaseMetaData
表示不允许使用 NULL值。
procedureNoResult - Static variable in interface java.sql. DatabaseMetaData
表示该过程不返回结果。
procedureNullable - Static variable in interface java.sql. DatabaseMetaData
表示允许使用 NULL值。
procedureNullableUnknown - Static variable in interface java.sql. DatabaseMetaData
表示是否允许 NULL值是未知的。
procedureResultUnknown - Static variable in interface java.sql. DatabaseMetaData
表示不知道过程是否返回结果。
procedureReturnsResult - Static variable in interface java.sql. DatabaseMetaData
表示该过程返回结果。
process() - Method in exception com.sun.jdi.connect. VMStartException
process() - Method in interface com.sun.jdi. VirtualMachine
如果由LaunchingConnector启动，则返回此虚拟机的Process对象
process() - Method in class jdk.jshell.execution. JdiInitiator
返回启动的进程。
process(String, List<String>) - Method in interface jdk.javadoc.doclet. Doclet.Option
根据需要处理选项和参数。
process(List<V>) - Method in class javax.swing. SwingWorker
从 事件分派线程异步接收 publish方法的数据块。
process(Set<? extends TypeElement>, RoundEnvironment) - Method in class javax.annotation.processing. AbstractProcessor
对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。
process(Set<? extends TypeElement>, RoundEnvironment) - Method in interface javax.annotation.processing. Processor
对来自前一轮的类型元素处理一组注释类型，并返回此处理器是否声明这些注释类型。
Process - Class in java.lang
Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。
Process() - Constructor for class java.lang. Process
Process的默认构造函数。
processActionEvent(ActionEvent) - Method in class java.awt. Button
通过将此按钮发送到任何已注册的 ActionListener对象来处理此按钮上发生的操作事件。
processActionEvent(ActionEvent) - Method in class java.awt. List
通过将此组件发送到任何已注册的 ActionListener对象来处理此组件上发生的操作事件。
processActionEvent(ActionEvent) - Method in class java.awt. MenuItem
处理此菜单项上发生的动作事件，将其发送到任何已注册的 ActionListener对象。
processActionEvent(ActionEvent) - Method in class java.awt. TextField
通过 ActionListener到任何已注册的 ActionListener对象来处理在此文本字段上发生的操作事件。
processAdjustmentEvent(AdjustmentEvent) - Method in class java.awt. Scrollbar
通过将调度事件发送到任何已注册的 AdjustmentListener对象来处理此滚动条上发生的调整事件。
ProcessBuilder - Class in java.lang
此类用于创建操作系统进程。
ProcessBuilder(String...) - Constructor for class java.lang. ProcessBuilder
构造具有指定操作系统程序和参数的进程构建器。
ProcessBuilder(List<String>) - Constructor for class java.lang. ProcessBuilder
构造具有指定操作系统程序和参数的进程构建器。
ProcessBuilder.Redirect - Class in java.lang
表示子进程输入的源或子进程输出的目的地。
ProcessBuilder.Redirect.Type - Enum in java.lang
类型为ProcessBuilder.Redirect 。
processComponentEvent(ComponentEvent) - Method in class java.awt. Component
通过将组件事件发送到任何已注册的 ComponentListener对象来处理此组件上发生的组件事件。
processComponentEvent(ComponentEvent) - Method in class javafx.embed.swing. JFXPanel
覆盖 Component.processComponentEvent(ComponentEvent)方法将 ComponentEvent.COMPONENT_RESIZED事件分发到附加到此 JFXPanel的JavaFX场景。
processComponentEvent(ComponentEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理在JLayer或其任何子组件上发生的组件事件。
processComponentKeyEvent(KeyEvent) - Method in class javax.swing. JComponent
处理组件本身识别的任何关键事件。
processContainerEvent(ContainerEvent) - Method in class java.awt. Container
通过将容器事件发送到任何已注册的ContainerListener对象来处理容器事件。
processEvent(AWTEvent) - Method in class java.awt. Button
处理此按钮上的事件。
processEvent(AWTEvent) - Method in class java.awt. Checkbox
处理此复选框上的事件。
processEvent(AWTEvent) - Method in class java.awt. CheckboxMenuItem
处理此复选框菜单项上的事件。
processEvent(AWTEvent) - Method in class java.awt. Choice
处理此选择的事件。
processEvent(AWTEvent) - Method in class java.awt. Component
处理在此组件上发生的事件。
processEvent(AWTEvent) - Method in class java.awt. Container
处理此容器上的事件。
processEvent(AWTEvent) - Method in class java.awt. List
在此滚动列表中处理事件。
processEvent(AWTEvent) - Method in class java.awt. MenuComponent
处理在此菜单组件上发生的事件。
processEvent(AWTEvent) - Method in class java.awt. MenuItem
处理此菜单项上的事件。
processEvent(AWTEvent) - Method in class java.awt. Scrollbar
处理此滚动条上的事件。
processEvent(AWTEvent) - Method in class java.awt. TextComponent
处理此文本组件上的事件。
processEvent(AWTEvent) - Method in class java.awt. TextField
处理此文本字段上的事件。
processEvent(AWTEvent) - Method in class java.awt. Window
在此窗口处理事件。
processFocusEvent(FocusEvent) - Method in class java.awt. Component
通过将这些事件发送到任何注册的 FocusListener对象来处理在此组件上发生的焦点事件。
processFocusEvent(FocusEvent) - Method in class javafx.embed.swing. JFXPanel
覆盖 Component.processFocusEvent(FocusEvent)方法来将焦点事件分配给连接到此 JFXPanel的JavaFX场景。
processFocusEvent(FocusEvent) - Method in class javax.swing. JFormattedTextField
处理任何焦点事件，如 FocusEvent.FOCUS_GAINED或 FocusEvent.FOCUS_LOST 。
processFocusEvent(FocusEvent) - Method in class javax.swing. JPopupMenu
processFocusEvent(FocusEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理发生在JLayer或其任何子组件上的焦点事件。
ProcessHandle - Interface in java.lang
ProcessHandle识别并提供对本机进程的控制。
ProcessHandle.Info - Interface in java.lang
关于流程的信息快照。
processHierarchyBoundsEvent(HierarchyEvent) - Method in class java.awt. Component
进程层次结构通过将这些事件发送到任何注册的 HierarchyBoundsListener对象来限制发生在该组件上的事件。
processHierarchyBoundsEvent(HierarchyEvent) - Method in class javafx.embed.swing. JFXPanel
覆盖 Component.processHierarchyBoundsEvent(HierarchyEvent)方法来处理 HierarchyEvent.ANCESTOR_MOVED事件，并更新JavaFX场景位置以匹配屏幕上的 JFXPanel位置。
processHierarchyBoundsEvent(HierarchyEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
进程层次结构限制事件发生在JLayer或其任何子组件上。
processHierarchyEvent(HierarchyEvent) - Method in class java.awt. Component
通过 HierarchyListener到任何已注册的 HierarchyListener对象来处理在此组件上发生的层次结构事件。
processHierarchyEvent(HierarchyEvent) - Method in class javafx.embed.swing. JFXPanel
processHierarchyEvent(HierarchyEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理在JLayer或其任何子组件上发生的层次结构事件。
processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent) - Method in class javax.swing.text.html. HTMLDocument
由HTML框架中的文档生成的进程 HyperlinkEvents 。
processImageComplete() - Method in class javax.imageio. ImageReader
通过调用它们的 imageComplete方法将所读取的图像的完成广播到所有注册的 IIOReadProgressListener 。
processImageComplete() - Method in class javax.imageio. ImageWriter
通过调用其 imageComplete方法，广播完成对所有注册的 IIOWriteProgressListener的图像的写入。
processImageProgress(float) - Method in class javax.imageio. ImageReader
通过调用其 imageProgress方法，将目前的图像完成百分比广播到所有注册的 IIOReadProgressListener 。
processImageProgress(float) - Method in class javax.imageio. ImageWriter
通过调用其 imageProgress方法，将所有注册的 IIOWriteProgressListener的图像完成的当前百分比广播。
processImageStarted(int) - Method in class javax.imageio. ImageReader
通过调用 imageStarted方法将所读取的图像的开始广播到所有注册的 IIOReadProgressListener 。
processImageStarted(int) - Method in class javax.imageio. ImageWriter
通过调用它们的 imageStarted方法，将所有注册的 IIOWriteProgressListener s的图像写入的开始广播。
processImageUpdate(BufferedImage, int, int, int, int, int, int, int[]) - Method in class javax.imageio. ImageReader
通过调用其 imageUpdate方法将一组样本的更新广播到所有注册的 IIOReadUpdateListener 。
PROCESSING - Static variable in class javax.print.attribute.standard. JobState
工作正在处理中。
PROCESSING - Static variable in class javax.print.attribute.standard. PrinterState
表示作业正在处理中 新工作将在处理之前等待。
PROCESSING_INSTRUCTION - Static variable in interface javax.xml.stream. XMLStreamConstants
表示事件是处理指令
PROCESSING_INSTRUCTION_NODE - Static variable in interface org.w3c.dom. Node
该节点是一个 ProcessingInstruction 。
PROCESSING_STOPPED - Static variable in class javax.print.attribute.standard. JobState
该工作由于任何原因处理而停止，并将在原因不再存在的情况下返回到PROCESSING状态。
PROCESSING_TO_STOP_POINT - Static variable in class javax.print.attribute.standard. JobStateReason
请求者取消了该作业，或打印机已中止作业，但是打印机仍然在作业中执行某些操作，直到发生指定的停止点或作业终止/清除完成。
processingEnv - Variable in class javax.annotation.processing. AbstractProcessor
由工具框架提供的处理环境。
ProcessingEnvironment - Interface in javax.annotation.processing
注释处理工具框架将由 provide an annotation processor with an object implementing this interface进行处理，因此处理器可以使用框架提供的工具来编写新文件，报告错误消息和查找其他工具。
processingInstruction(String, String) - Method in interface org.xml.sax. ContentHandler
接收处理指令的通知。
processingInstruction(String, String) - Method in interface org.xml.sax. DocumentHandler
已过时。
接收处理指令的通知。
processingInstruction(String, String) - Method in class org.xml.sax. HandlerBase
已过时。
接收处理指令的通知。
processingInstruction(String, String) - Method in class org.xml.sax.helpers. DefaultHandler
接收处理指令的通知。
processingInstruction(String, String) - Method in class org.xml.sax.helpers. ParserAdapter
适配器实现方法; 不要打电话。
processingInstruction(String, String) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤处理指令事件。
processingInstruction(String, String) - Method in class org.xml.sax.helpers. XMLReaderAdapter
修改SAX2处理指令事件。
ProcessingInstruction - Interface in javax.xml.stream.events
描述处理指令中找到的数据的界面
ProcessingInstruction - Interface in org.w3c.dom
ProcessingInstruction接口表示一个“处理指令”，用于XML，作为将处理器特定信息保存在文档文本中的一种方式。
processingOver() - Method in interface javax.annotation.processing. RoundEnvironment
返回true如果由此轮生成的类型不会受到后续轮注的处理; 否则返回false 。
processInputMethodEvent(InputMethodEvent) - Method in class java.awt. Component
通过将此组件发送到任何已注册的 InputMethodListener对象来处理在此组件上发生的输入法事件。
processInputMethodEvent(InputMethodEvent) - Method in class javafx.embed.swing. JFXPanel
processInputMethodEvent(InputMethodEvent) - Method in class javax.swing. JFormattedTextField
处理任何输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED或 InputMethodEvent.CARET_POSITION_CHANGED 。
processInputMethodEvent(InputMethodEvent) - Method in class javax.swing.text. JTextComponent
processInputMethodEvent(InputMethodEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理在JLayer或其任何子组件上发生的输入事件。
processItemEvent(ItemEvent) - Method in class java.awt. Checkbox
通过将此复选框发送到任何已注册的 ItemListener对象来处理在此复选框上发生的项目事件。
processItemEvent(ItemEvent) - Method in class java.awt. CheckboxMenuItem
通过将此复选框菜单项发送到任何已注册的 ItemListener对象来处理项目事件。
processItemEvent(ItemEvent) - Method in class java.awt. Choice
通过将其发送到任何已注册的 ItemListener对象来处理此 Choice菜单上的项目事件。
processItemEvent(ItemEvent) - Method in class java.awt. List
通过将其发送到任何已注册的 ItemListener对象来处理此列表上发生的项目事件。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - Method in class javax.swing. JComboBox
调用以处理键绑定为 ks作为的结果 KeyEvent e 。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - Method in class javax.swing. JComponent
作为 KeyEvent e的结果，调用处理 ks的键绑定。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - Method in class javax.swing. JMenuBar
子类检查所有的子菜单。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - Method in class javax.swing. JTable
processKeyBindings(KeyEvent) - Static method in class javax.swing. SwingUtilities
处理用于在所述键绑定 Component关联 event 。
processKeyEvent(Component, KeyEvent) - Method in class java.awt. DefaultKeyboardFocusManager
当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。
processKeyEvent(Component, KeyEvent) - Method in class java.awt. KeyboardFocusManager
当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。
processKeyEvent(KeyEvent) - Method in class java.awt. Component
通过将这些事件发送到任何已注册的 KeyListener对象来处理此组件上发生的关键事件。
processKeyEvent(KeyEvent) - Method in class javafx.embed.swing. JFXPanel
覆盖 Component.processKeyEvent(KeyEvent)方法将键事件发送到附加到此 JFXPanel的JavaFX场景。
processKeyEvent(KeyEvent) - Method in class javax.swing. JComboBox
处理 KeyEvent s，寻找Tab键。
processKeyEvent(KeyEvent) - Method in class javax.swing. JComponent
覆盖 processKeyEvent以处理事件。
processKeyEvent(KeyEvent) - Method in class javax.swing. JMenu
处理关键笔划事件，如助记符和加速器。
processKeyEvent(KeyEvent) - Method in class javax.swing. JPopupMenu
处理关键笔划事件，如助记符和加速器。
processKeyEvent(KeyEvent) - Method in class javax.swing. MenuSelectionManager
当MenuElement从KeyListener接收到一个事件时，它不应该直接处理该事件。
processKeyEvent(KeyEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理JLayer或其任何子组件发生的关键事件。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing. JMenuBar
实现成为一个 MenuElement - 什么也没做。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing. JMenuItem
处理从 MenuSelectionManager转发的密钥事件，并根据需要通过使用 MenuSelectionManager的API更改菜单选项。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing. JPopupMenu
处理从 MenuSelectionManager转发的密钥事件，并根据需要更改菜单选项，使用 MenuSelectionManager的API。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in interface javax.swing. MenuElement
处理关键事件。
processKeyEvent(KeyEvent) - Method in class javafx.scene. Scene
processMenuDragMouseEvent(MenuDragMouseEvent) - Method in class javax.swing. JMenuItem
在菜单中处理鼠标拖动。
processMenuKeyEvent(MenuKeyEvent) - Method in class javax.swing. JMenuItem
在菜单中处理按键。
processMouseEvent(MouseEvent) - Method in class java.awt. Component
通过将此组件分派到任何已注册的 MouseListener对象来处理发生在此组件上的鼠标事件。
processMouseEvent(MouseEvent) - Method in class javafx.embed.swing. JFXPanel
覆盖 Component.processMouseEvent(MouseEvent)方法将鼠标事件发送到连接到此 JFXPanel的JavaFX场景。
processMouseEvent(MouseEvent) - Method in class javax.swing. JComponent
通过将此组件发送到任何注册的 MouseListener对象来处理此组件上发生的鼠标事件，有关此方法的完整说明，请参阅 Component.processMouseEvent(MouseEvent) 。
processMouseEvent(MouseEvent) - Method in class javax.swing. MenuSelectionManager
当MenuElement从MouseListener接收到一个事件时，它不应该直接处理该事件。
processMouseEvent(MouseEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理发生在JLayer或其任何子组件上的鼠标事件。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing. JMenuBar
实现成为一个 MenuElement - 什么也没做。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing. JMenuItem
处理从 MenuSelectionManager转发的鼠标事件，并根据需要更改菜单选项，方法是使用 MenuSelectionManager的API。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing. JPopupMenu
这种方法需要符合 MenuElement接口，但是没有实现。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in interface javax.swing. MenuElement
处理鼠标事件。
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.plaf.basic. BasicCheckBoxMenuItemUI
当鼠标事件发生时调用。
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.plaf.basic. BasicRadioButtonMenuItemUI
当鼠标事件发生时调用。
processMouseMotionEvent(MouseEvent) - Method in class java.awt. Component
处理由他们指派到任何注册组件上发生的鼠标移动事件 MouseMotionListener对象。
processMouseMotionEvent(MouseEvent) - Method in class javafx.embed.swing. JFXPanel
覆盖 Component.processMouseMotionEvent(MouseEvent)方法将鼠标移动事件发送到连接到此 JFXPanel的JavaFX场景。
processMouseMotionEvent(MouseEvent) - Method in class javax.swing. JComponent
处理鼠标运动事件，如MouseEvent.MOUSE_DRAGGED。
processMouseMotionEvent(MouseEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理JLayer或其任何子组件发生的鼠标运动事件。
processMouseWheelEvent(MouseWheelEvent) - Method in class java.awt. Component
通过将鼠标滚轮事件发送到任何已注册的 MouseWheelListener对象来处理鼠标滚轮事件。
processMouseWheelEvent(MouseWheelEvent) - Method in class java.awt. ScrollPane
通过滚动适当的量来处理传递给此 ScrollPane的鼠标滚轮事件。
processMouseWheelEvent(MouseWheelEvent) - Method in class javafx.embed.swing. JFXPanel
覆盖 Component.processMouseWheelEvent(MouseWheelEvent)方法将鼠标滚轮事件发送到连接到此 JFXPanel的JavaFX场景。
processMouseWheelEvent(MouseWheelEvent, JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
处理JLayer或其任何子组件发生的鼠标滚轮事件。
processName(String, String[], boolean) - Method in class org.xml.sax.helpers. NamespaceSupport
处理原始XML限定名称，在当前上下文中的所有声明都由 declarePrefix()处理 之后 。
Processor - Interface in javax.annotation.processing
注释处理器的界面。
processPassComplete(BufferedImage) - Method in class javax.imageio. ImageReader
通过打电话给他们的 passComplete方法，将所有注册的 IIOReadUpdateListener传送到所有注册的 IIOReadUpdateListener 。
processPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - Method in class javax.imageio. ImageReader
通过调用他们的 passStarted方法，将所有注册的 IIOReadUpdateListener传送给所有注册的 IIOReadUpdateListener 。
processReadAborted() - Method in class javax.imageio. ImageReader
通过调用它们的 readAborted方法来广播已读取已被中止到所有注册的 IIOReadProgressListener 。
processSequenceComplete() - Method in class javax.imageio. ImageReader
通过调用 sequenceComplete方法，将所有注册的 IIOReadProgressListener的图像读取顺序广播完毕。
processSequenceStarted(int) - Method in class javax.imageio. ImageReader
通过调用 sequenceStarted方法，将所有注册的 IIOReadProgressListener的图像读取序列的开始广播。
processTextEvent(TextEvent) - Method in class java.awt. TextComponent
通过将文本事件发送到任何已注册的 TextListener对象来处理在此文本组件上发生的文本事件。
processThumbnailComplete() - Method in class javax.imageio. ImageReader
通过调用 thumbnailComplete方法，将所有注册的 IIOReadProgressListener的缩略图读取完成。
processThumbnailComplete() - Method in class javax.imageio. ImageWriter
通过调用 thumbnailComplete方法广播完成对所有注册的 IIOWriteProgressListener的缩略图写入。
processThumbnailPassComplete(BufferedImage) - Method in class javax.imageio. ImageReader
通过调用其 thumbnailPassComplete方法，将所有注册的 IIOReadUpdateListener s的缩略图遍历传递结束广播。
processThumbnailPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - Method in class javax.imageio. ImageReader
通过调用 thumbnailPassStarted方法，将所有注册的 IIOReadUpdateListener s的缩略图逐行传递的开始广播。
processThumbnailProgress(float) - Method in class javax.imageio. ImageReader
通过调用其 thumbnailProgress方法将所有已注册的 IIOReadProgressListener的缩略图完成的当前百分比广播。
processThumbnailProgress(float) - Method in class javax.imageio. ImageWriter
通过调用其 thumbnailProgress方法将所有已注册的 IIOWriteProgressListener的缩略图完成的当前百分比广播。
processThumbnailStarted(int, int) - Method in class javax.imageio. ImageReader
通过调用 thumbnailStarted方法，将所有注册的 IIOReadProgressListener的缩略图读取的开始广播。
processThumbnailStarted(int, int) - Method in class javax.imageio. ImageWriter
通过调用 thumbnailStarted方法，将所有注册的 IIOWriteProgressListener s的缩略图写入的开始广播。
processThumbnailUpdate(BufferedImage, int, int, int, int, int, int, int[]) - Method in class javax.imageio. ImageReader
通过调用 thumbnailUpdate方法，将缩略图中的一组样本的更新广播到所有注册的 IIOReadUpdateListener 。
processWarningOccurred(int, String) - Method in class javax.imageio. ImageWriter
通过调用其 warningOccurred方法向所有注册的 IIOWriteWarningListener发送警告消息。
processWarningOccurred(int, String, String) - Method in class javax.imageio. ImageWriter
通过使用从 ResourceBundle获取的字符串调用其 warningOccurred方法向所有注册的 IIOWriteWarningListener广播本地化警告消息。
processWarningOccurred(String) - Method in class javax.imageio. ImageReader
通过调用其 warningOccurred方法向所有已注册的 IIOReadWarningListener发送警告消息。
processWarningOccurred(String, String) - Method in class javax.imageio. ImageReader
通过使用从 ResourceBundle获取的字符串调用其 warningOccurred方法向所有注册的 IIOReadWarningListener广播本地化警告消息。
processWindowEvent(WindowEvent) - Method in class java.awt. Window
通过将窗口事件分派到任何注册的WindowListener对象来处理窗口事件。
processWindowEvent(WindowEvent) - Method in class javax.swing. JDialog
根据 defaultCloseOperation属性的状态处理窗口事件。
processWindowEvent(WindowEvent) - Method in class javax.swing. JFrame
处理在此组件上发生的窗口事件。
processWindowFocusEvent(WindowEvent) - Method in class java.awt. Window
通过将窗口焦点事件分派到任何已注册的WindowFocusListener对象来处理窗口焦点事件。
processWindowStateEvent(WindowEvent) - Method in class java.awt. Window
通过将窗口状态事件发送到任何已注册的 WindowStateListener对象来处理窗口状态事件。
processWriteAborted() - Method in class javax.imageio. ImageWriter
通过调用其 writeAborted方法广播已经中止所有注册的所有注册的 IIOWriteProgressListener 。
profile_data - Variable in class org.omg.IOP. TaggedProfile
相关的配置文件数据。
ProfileDataException - Exception in java.awt.color
在访问或处理ICC_Profile对象时发生错误时抛出此异常。
ProfileDataException(String) - Constructor for exception java.awt.color. ProfileDataException
构造具有指定详细消息的ProfileDataException。
ProfileIdHelper - Class in org.omg.IOP
个人资料ID
ProfileIdHelper() - Constructor for class org.omg.IOP. ProfileIdHelper
profiles - Variable in class org.omg.IOP. IOR
与此对象引用相关联的已标记配置文件的数组。
program - Variable in class javax.sound.midi. VoiceStatus
该声音当前正在使用的乐器的节目编号。
PROGRAM_CHANGE - Static variable in class javax.sound.midi. ShortMessage
程序更改消息的指令值（0xC0或192）。
programChange(int) - Method in interface javax.sound.midi. MidiChannel
更改程序（补丁）。
programChange(int, int) - Method in interface javax.sound.midi. MidiChannel
使用银行和程序（补丁）号码更改程序。
ProgramElementDoc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
progress(URL, String, long, long, int) - Method in interface javax.jnlp. DownloadServiceListener
JNLP客户端的 DownloadService实现应该在下载过程中多次调用此方法。
PROGRESS - Static variable in interface java.util.jar. Pack200.Packer
封隔器的进度为百分比，由封隔器定期更新。
PROGRESS - Static variable in interface java.util.jar. Pack200.Unpacker
解包器的进度占百分比，由打包机定期更新。
PROGRESS_BAR - Static variable in class javax.accessibility. AccessibleRole
用于指示任务已完成多少的对象。
PROGRESS_BAR - Static variable in class javax.swing.plaf.synth. Region
ProgressBar区域。
PROGRESS_INDICATOR - javafx.scene. AccessibleRole
进度指标的作用
PROGRESS_MONITOR - Static variable in class javax.accessibility. AccessibleRole
指示对象的角色监视某些操作的进度。
PROGRESS_STATE_WINDOW - java.awt. Taskbar.Feature
表示指定窗口的进度状态特征。
PROGRESS_VALUE - java.awt. Taskbar.Feature
表示进度值特征。
PROGRESS_VALUE_WINDOW - java.awt. Taskbar.Feature
表示指定窗口的进度值特征。
progressBar - Variable in class javax.swing.plaf.basic. BasicProgressBarUI
实例 JProgressBar 。
ProgressBar - Class in javafx.scene.control
ProgressIndator的专业化表示为横杠。
ProgressBar() - Constructor for class javafx.scene.control. ProgressBar
创建一个新的不确定ProgressBar。
ProgressBar(double) - Constructor for class javafx.scene.control. ProgressBar
用给定的进度值创建一个新的ProgressBar。
ProgressBarSkin - Class in javafx.scene.control.skin
默认皮肤实现为ProgressBar控件。
ProgressBarSkin(ProgressBar) - Constructor for class javafx.scene.control.skin. ProgressBarSkin
创建一个新的ProgressBarSkin实例，将必要的子节点安装到控件 children列表中。
ProgressBarTableCell< S> - Class in javafx.scene.control.cell
一个包含TableCell实现的类，在该单元格内绘制一个27046349495656节点。
ProgressBarTableCell() - Constructor for class javafx.scene.control.cell. ProgressBarTableCell
创建默认的ProgressBarTableCell实例
ProgressBarTreeTableCell< S> - Class in javafx.scene.control.cell
一个包含一个TreeTableCell实现的类，它在单元格中绘制一个ProgressBar节点。
ProgressBarTreeTableCell() - Constructor for class javafx.scene.control.cell. ProgressBarTreeTableCell
创建默认的ProgressBarTreeTableCell实例
ProgressBarUI - Class in javax.swing.plaf
JProgressBar可插拔的外观和界面。
ProgressBarUI() - Constructor for class javax.swing.plaf. ProgressBarUI
ProgressIndicator - Class in javafx.scene.control
用于指示进度的循环控制，无限（也称为不确定）或有限。
ProgressIndicator() - Constructor for class javafx.scene.control. ProgressIndicator
创建一个新的不确定的ProgressIndicator。
ProgressIndicator(double) - Constructor for class javafx.scene.control. ProgressIndicator
使用给定的进度值创建一个新的ProgressIndicator。
ProgressIndicatorSkin - Class in javafx.scene.control.skin
ProgressIndicator控件的默认皮肤实现。
ProgressIndicatorSkin(ProgressIndicator) - Constructor for class javafx.scene.control.skin. ProgressIndicatorSkin
创建一个新的ProgressIndicatorSkin实例，将必需的子节点安装到控件 children列表中。
progressiveMode - Variable in class javax.imageio. ImageWriteParam
控制渐进编码的模式，必须设置为四个 MODE_*值之一，除了 MODE_EXPLICIT 。
progressListeners - Variable in class javax.imageio. ImageReader
A List当前注册的 IIOReadProgressListener s，默认初始化为 null ，这是一个空的 List同义词。
progressListeners - Variable in class javax.imageio. ImageWriter
A List目前注册的 IIOWriteProgressListener ，默认情况下初始化为 null ，这是一个空的 List同义词。
ProgressMonitor - Class in javax.swing
一类监视某些操作的进度。
ProgressMonitor(Component, Object, String, int, int) - Constructor for class javax.swing. ProgressMonitor
构造一个显示进度的图形对象，通常通过填充矩形栏来完成过程。
ProgressMonitor.AccessibleProgressMonitor - Class in javax.swing
AccessibleProgressMonitor实现 ProgressMonitor类的可访问性支持。
ProgressMonitorInputStream - Class in javax.swing
监视从一些InputStream读取进度。
ProgressMonitorInputStream(Component, Object, InputStream) - Constructor for class javax.swing. ProgressMonitorInputStream
构造一个对象来监视输入流的进度。
ProgressNotification(double) - Constructor for class javafx.application. Preloader.ProgressNotification
构建进度通知。
progressProperty() - Method in class javafx.concurrent. Service
progressProperty() - Method in class javafx.concurrent. Task
progressProperty() - Method in interface javafx.concurrent. Worker
获取表示进度的ReadOnlyDoubleProperty。
progressProperty() - Method in class javafx.scene.control. ProgressIndicator
ProgressIndicator的实际进展。
progressProperty() - Method in class javafx.scene.image. Image
已完成图像加载的大致百分比。
progressString - Variable in class javax.swing. JProgressBar
可以在进度条上显示的可选字符串。
PROLEPTIC_MONTH - java.time.temporal. ChronoField
以月份为基础，从0年起连续数月。
prolepticYear(Era, int) - Method in interface java.time.chrono. Chronology
计算年龄和年龄的幼年时期。
prolepticYear(Era, int) - Method in class java.time.chrono. HijrahChronology
prolepticYear(Era, int) - Method in class java.time.chrono. IsoChronology
prolepticYear(Era, int) - Method in class java.time.chrono. JapaneseChronology
prolepticYear(Era, int) - Method in class java.time.chrono. MinguoChronology
prolepticYear(Era, int) - Method in class java.time.chrono. ThaiBuddhistChronology
PROMPT - Static variable in class javax.swing.text.html. HTML.Attribute
属性“提示”
promptCapture(boolean) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
设置为启用命令捕获提示覆盖。
PromptData - Class in javafx.scene.web
这个类封装了传递给JavaScript prompt()函数的数据：一个消息和一个默认值。
PromptData(String, String) - Constructor for class javafx.scene.web. PromptData
创建一个新的实例。
promptHandlerProperty() - Method in class javafx.scene.web. WebEngine
JavaScript prompt处理程序属性。
promptTextFillProperty() - Method in class javafx.scene.control.skin. TextInputControlSkin
promptTextProperty() - Method in class javafx.scene.control. ComboBoxBase
ComboBox提示文本显示，如果没有显示提示文本， null 。
promptTextProperty() - Method in class javafx.scene.control. Spinner
在 Spinner显示的提示文本，如果没有显示提示文本，则显示 null 。
promptTextProperty() - Method in class javafx.scene.control. TextInputControl
提示文字显示在 TextInputControl 。
propagateCompletion() - Method in class java.util.concurrent. CountedCompleter
相当于CountedCompleter.tryComplete()但不会在完成路径中调用CountedCompleter.onCompletion(CountedCompleter) ：如果挂起的计数为非零，则递减计数; 否则，同样尝试完成此任务的完成，如果存在，否则将此任务标记为完成。
propagatedFrom - Variable in class java.beans.beancontext. BeanContextEvent
传播此事件的 BeanContext
properties() - Method in interface java.util.jar. Pack200.Packer
获取此引擎的属性集。
properties() - Method in interface java.util.jar. Pack200.Unpacker
获取此引擎的属性集。
properties() - Method in class javax.sound.midi. MidiFileFormat
获取不可修改的属性地图。
properties() - Method in class javax.sound.sampled. AudioFileFormat
获取不可修改的属性地图。
properties() - Method in class javax.sound.sampled. AudioFormat
获取不可修改的属性地图。
Properties - Class in java.util
Properties类表示一组持久的属性。
Properties() - Constructor for class java.util. Properties
创建一个没有默认值的空属性列表。
Properties(Properties) - Constructor for class java.util. Properties
创建具有指定默认值的空属性列表。
PROPERTIES - Static variable in interface java.awt.image. ImageObserver
imageUpdate的infoflags参数中的此标志表示图像的属性现在可用。
Property< T> - Interface in javafx.beans.property
通用接口，定义所有（可写）属性共有的方法，与其类型无关。
PROPERTY - javax.xml.bind.annotation. XmlAccessType
JAXB绑定类中的每个getter / setter对都将自动绑定到XML，除非由XmlTransient注释。
PROPERTY - jdk.dynalink. StandardNamespace
对象属性的标准命名空间。
PROPERTY - jdk.nashorn.api.tree. Tree.Kind
用于PropertyTree的实例。
PROPERTY - Static variable in class org.w3c.dom.bootstrap. DOMImplementationRegistry
系统属性指定DOMImplementationSource类名。
propertyChange(PropertyChangeEvent) - Method in class java.beans.beancontext. BeanContextSupport
子类可以包围以监视子属性更改。
propertyChange(PropertyChangeEvent) - Method in interface java.beans. PropertyChangeListener
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class java.beans. PropertyChangeListenerProxy
将属性更改事件转发给侦听器代理。
propertyChange(PropertyChangeEvent) - Method in class javax.swing. JLayer
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing. JList.AccessibleJList
属性更改侦听器更改方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing. JPopupMenu.AccessibleJPopupMenu
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing. JScrollPane.AccessibleJScrollPane
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing. JSpinner.DefaultEditor
称为 JFormattedTextField PropertyChangeListener 。
propertyChange(PropertyChangeEvent) - Method in class javax.swing. JTable.AccessibleJTable
跟踪选择模型，列模型等的更改，以便能够将侦听器重新放置在那些上，以便将信息传递到辅助功能PropertyChange机制
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicColorChooserUI.PropertyHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicDirectoryModel
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicEditorPaneUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFramePropertyChangeListener
从JInternalFrame中检测状态的变化并处理动作。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicLabelUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicListUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.PropertyChangeHandler
如果PropertyChangeEvent e的来源等于optionPane，并且是ICON_PROPERTY，MESSAGE_PROPERTY，OPTIONS_PROPERTY或INITIAL_VALUE_PROPERTY之一，则调用validateComponent。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicRootPaneUI
在根窗格上更改属性时调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.PropertyChangeHandler
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI.PropertyChangeHandler
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.PropertyChangeHandler
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider
属性更改事件（可能来自JSplitPane）将在必要时发送updateOrientation消息。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.PropertyHandler
从 JSplitPane消息接收器中包含。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicTextAreaUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicTextPaneUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicTextUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.PropertyListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.SelectionModelPropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal. MetalComboBoxUI.MetalPropertyChangeListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxModel
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal. MetalRootPaneUI
当属性更改时调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal. MetalSliderUI.MetalPropertyListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal. MetalTextFieldUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthButtonUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthColorChooserUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthComboBoxUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthDesktopIconUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthEditorPaneUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthLabelUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthListUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthMenuBarUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthMenuItemUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthMenuUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthOptionPaneUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthPanelUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthPopupMenuUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthProgressBarUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthRootPaneUI
在根窗格上更改属性时调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthScrollBarUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthSliderUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthSpinnerUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthTableUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthTextAreaUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthTextFieldUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthTextPaneUI
当在关联的JTextComponent上更改bound属性时，将调用此方法。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthToolBarUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthToolTipUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthTreeUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthViewportUI
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor
当绑定属性更改时，此方法将被调用。
propertyChange(PropertyChangeEvent) - Method in class javax.swing.table. DefaultTableColumnModel
属性更改侦听器更改方法。
PROPERTYCHANGE - Static variable in class com.sun.java.accessibility.util. EventID
映射到Bean PropertyChange支持（即PropertyChangeListener和PropertyChangeEvent）
PropertyChangeEvent - Class in java.beans
只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
PropertyChangeEvent(Object, String, Object, Object) - Constructor for class java.beans. PropertyChangeEvent
构造新的 PropertyChangeEvent 。
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicComboBoxUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicComboPopup.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicListUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicOptionPaneUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicScrollBarUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicScrollPaneUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicSliderUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicTabbedPaneUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.PropertyChangeHandler
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicColorChooserUI
实例 PropertyChangeListener 。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicComboBoxUI
此保护字段是实现特定的。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicComboPopup
此保护字段是实现特定的。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
一个 PropertyChangeListener 。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI
属性更改侦听器
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicListUI
PropertyChangeListener ，附于 JList 。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicMenuItemUI
PropertyChangeListener从 createPropertyChangeListener返回。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI
实例 PropertyChangeListener 。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicScrollBarUI
属性更改侦听器
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicSliderUI
属性chane监听器
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
此JSplitPane的PropertyChangeListener的实例。
propertyChangeListener - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
属性更改侦听器
PropertyChangeListener - Interface in java.beans
一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
PropertyChangeListenerProxy - Class in java.beans
一个类扩展了 EventListenerProxy专门用于添加一个“bound”属性的 PropertyChangeListener 。
PropertyChangeListenerProxy(String, PropertyChangeListener) - Constructor for class java.beans. PropertyChangeListenerProxy
构造函数将 PropertyChangeListener绑定到特定属性。
PropertyChangeSupport - Class in java.beans
这是一个可以由支持绑定属性的bean使用的实用程序类。
PropertyChangeSupport(Object) - Constructor for class java.beans. PropertyChangeSupport
构造一个 PropertyChangeSupport对象。
PropertyDescriptor - Class in java.beans
PropertyDescriptor描述了Java Bean通过一对访问器方法导出的一个属性。
PropertyDescriptor(String, Class<?>) - Constructor for class java.beans. PropertyDescriptor
通过使用getFoo和setFoo访问器方法，为遵循标准Java约定的属性构造PropertyDescriptor。
PropertyDescriptor(String, Class<?>, String, String) - Constructor for class java.beans. PropertyDescriptor
该构造函数使用简单属性的名称，以及读取和写入属性的方法名称。
PropertyDescriptor(String, Method, Method) - Constructor for class java.beans. PropertyDescriptor
此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
PropertyEditor - Interface in java.beans
PropertyEditor类提供对允许用户编辑给定类型的属性值的GUI的支持。
PropertyEditorManager - Class in java.beans
PropertyEditorManager可用于查找任何给定类型名称的属性编辑器。
PropertyEditorManager() - Constructor for class java.beans. PropertyEditorManager
PropertyEditorSupport - Class in java.beans
这是一个帮助构建属性编辑器的支持类。
PropertyEditorSupport() - Constructor for class java.beans. PropertyEditorSupport
构造一个 PropertyEditorSupport对象。
PropertyEditorSupport(Object) - Constructor for class java.beans. PropertyEditorSupport
构造一个 PropertyEditorSupport对象。
PropertyException - Exception in javax.xml.bind
此异常表示获取或设置属性时遇到错误。
PropertyException(String) - Constructor for exception javax.xml.bind. PropertyException
使用指定的详细消息构造PropertyException。
PropertyException(String, Object) - Constructor for exception javax.xml.bind. PropertyException
构造一个PropertyException，其消息字段是基于属性的名称和value.toString（）来设置的。
PropertyException(String, String) - Constructor for exception javax.xml.bind. PropertyException
构造具有指定的详细消息和供应商特定的错误代码的PropertyException。
PropertyException(String, String, Throwable) - Constructor for exception javax.xml.bind. PropertyException
使用指定的详细消息，供应商特定的错误代码和linkedException构造PropertyException。
PropertyException(String, Throwable) - Constructor for exception javax.xml.bind. PropertyException
使用指定的详细消息和linkedException构造PropertyException。
PropertyException(Throwable) - Constructor for exception javax.xml.bind. PropertyException
使用linkedException构造PropertyException。
PropertyHandler() - Constructor for class javax.swing.plaf.basic. BasicColorChooserUI.PropertyHandler
PropertyHandler() - Constructor for class javax.swing.plaf.basic. BasicSplitPaneUI.PropertyHandler
propertyKey - Static variable in class javax.swing.plaf.basic. BasicHTML
作为JComponent的客户端属性存储时，用于html渲染器的键。
propertyListener - Variable in class javax.swing.plaf.basic. BasicToolBarUI
一个 PropertyChangeListener的实例。
PropertyListener() - Constructor for class javax.swing.plaf.basic. BasicToolBarUI.PropertyListener
PROPERTYNAME - Static variable in interface java.beans. DesignMode
从BeanContext或PropertyChangeEvents的其他来源触发的propertyName的标准值。
propertyNames() - Method in class java.util. Properties
返回此属性列表中所有键的枚举，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。
PropertyPermission - Class in java.util
此类用于属性权限。
PropertyPermission(String, String) - Constructor for class java.util. PropertyPermission
创建一个具有指定名称的新PropertyPermission对象。
PropertyResourceBundle - Class in java.util
PropertyResourceBundle是的具体子类 ResourceBundle管理资源使用一组属性文件中的静态字符串的语言环境。
PropertyResourceBundle(InputStream) - Constructor for class java.util. PropertyResourceBundle
从InputStream创建属性资源包。
PropertyResourceBundle(Reader) - Constructor for class java.util. PropertyResourceBundle
从一个Reader创建一个属性资源束。
PropertySetError(CssMetaData, Styleable, String) - Constructor for class javafx.css. CssParser.ParseError.PropertySetError
PropertyTree - Interface in jdk.nashorn.api.tree
表示对象文字树中的属性设置。
PropertyValueFactory< S, T> - Class in javafx.scene.control.cell
Callback界面的方便实现，专为TableColumn cell value factory使用而设计。
PropertyValueFactory(String) - Constructor for class javafx.scene.control.cell. PropertyValueFactory
创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。
PropertyVetoException - Exception in java.beans
当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
PropertyVetoException(String, PropertyChangeEvent) - Constructor for exception java.beans. PropertyVetoException
构造一个 PropertyVetoException的详细消息。
PROPS - javafx.scene.input. KeyCode
常数为 Properties键。
PROTECTED - javax.lang.model.element. Modifier
修饰词 protected
PROTECTED - Static variable in class java.lang.invoke. MethodHandles.Lookup
代表 protected访问的单位掩码，可能有助于 lookupModes的结果。
PROTECTED - Static variable in class java.lang.reflect. Modifier
int值代表 protected修饰符。
ProtectionDomain - Class in java.security
ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。
ProtectionDomain(CodeSource, PermissionCollection) - Constructor for class java.security. ProtectionDomain
使用给定的CodeSource和权限创建一个新的ProtectionDomain。
ProtectionDomain(CodeSource, PermissionCollection, ClassLoader, Principal[]) - Constructor for class java.security. ProtectionDomain
创建一个由给定的CodeSource，Permissions，ClassLoader和Principals数组限定的新的ProtectionDomain。
PROTOCOL_PROVIDER_CLASS_LOADER - Static variable in class javax.management.remote. JMXConnectorFactory
指定加载协议提供程序的类加载器的属性的名称。
PROTOCOL_PROVIDER_CLASS_LOADER - Static variable in class javax.management.remote. JMXConnectorServerFactory
指定加载协议提供程序的类加载器的属性的名称。
PROTOCOL_PROVIDER_PACKAGES - Static variable in class javax.management.remote. JMXConnectorFactory
指定在查找协议的处理程序时查询的提供程序包的属性的名称。
PROTOCOL_PROVIDER_PACKAGES - Static variable in class javax.management.remote. JMXConnectorServerFactory
指定在查找协议的处理程序时查询的提供程序包的属性的名称。
PROTOCOL_VERSION_1 - Static variable in interface java.io. ObjectStreamConstants
流协议版本。
PROTOCOL_VERSION_2 - Static variable in interface java.io. ObjectStreamConstants
流协议版本。
ProtocolException - Exception in java.net
抛出以表示底层协议有错误，如TCP错误。
ProtocolException - Exception in javax.xml.ws
ProtocolException类是与特定协议绑定相关的异常的基类。
ProtocolException() - Constructor for exception java.net. ProtocolException
构造一个新的 ProtocolException ，没有详细的消息。
ProtocolException() - Constructor for exception javax.xml.ws. ProtocolException
构造新的协议异常， null的详细信息为 null 。
ProtocolException(String) - Constructor for exception java.net. ProtocolException
构造一个新的 ProtocolException具有指定的详细信息。
ProtocolException(String) - Constructor for exception javax.xml.ws. ProtocolException
使用指定的详细消息构造新的协议异常。
ProtocolException(String, Throwable) - Constructor for exception javax.xml.ws. ProtocolException
构造一个新的运行时异常与指定的详细信息和原因。
ProtocolException(Throwable) - Constructor for exception javax.xml.ws. ProtocolException
构造一个新的运行时异常，其中包含指定的原因和详细消息（通常包含原因的类和详细消息）的详细消息（ (cause==null ? null : cause.toString()) ）。
ProtocolFamily - Interface in java.net
代表一系列通信协议。
prototypeCellValueChanged - Static variable in class javax.swing.plaf.basic. BasicListUI
该位与原型单元格值更改属性有关。
provideErrorFeedback(Component) - Method in class javax.swing. LookAndFeel
当用户尝试无效操作时调用，例如粘贴到具有焦点的不可编辑的 JTextField中。
provideErrorFeedback(Component) - Method in class javax.swing.plaf.metal. MetalLookAndFeel
当用户尝试无效操作时调用，例如粘贴到具有焦点的不可编辑的 JTextField中。
provider() - Static method in class com.sun.net.httpserver.spi. HttpServerProvider
返回用于Java虚拟机的此调用的系统范围默认的HttpServerProvider。
provider() - Method in class com.sun.tools.attach. VirtualMachine
返回创建此虚拟机的提供程序。
provider() - Method in class com.sun.tools.attach. VirtualMachineDescriptor
返回此描述符引用的 AttachProvider 。
provider() - Method in class java.nio.channels. AsynchronousChannelGroup
返回创建此通道组的提供程序。
provider() - Method in class java.nio.channels. AsynchronousServerSocketChannel
返回创建此通道的提供程序。
provider() - Method in class java.nio.channels. AsynchronousSocketChannel
返回创建此通道的提供程序。
provider() - Method in class java.nio.channels. SelectableChannel
返回创建此通道的提供程序。
provider() - Method in class java.nio.channels. Selector
返回创建此通道的提供程序。
provider() - Method in class java.nio.channels.spi. AbstractSelectableChannel
返回创建此通道的提供程序。
provider() - Method in class java.nio.channels.spi. AbstractSelector
返回创建此通道的提供程序。
provider() - Static method in class java.nio.channels.spi. AsynchronousChannelProvider
返回用于Java虚拟机调用的系统级默认异步通道提供程序。
provider() - Static method in class java.nio.channels.spi. SelectorProvider
返回用于Java虚拟机的此调用的系统级默认选择器提供程序。
provider() - Method in class java.nio.file. FileSystem
返回创建此文件系统的提供程序。
provider() - Static method in class javax.xml.ws.spi. Provider
创建一个新的提供者对象。
Provider - Class in java.security
该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
Provider - Class in javax.xml.ws.spi
ServiceDelegate和 Endpoint对象的服务提供商。
Provider< T> - Interface in javax.xml.ws
服务端点可以实现 Provider接口作为SEI的动态替代。
Provider() - Constructor for class javax.xml.ws.spi. Provider
创建一个新的Provider实例
Provider(String, double, String) - Constructor for class java.security. Provider
已过时。
使用Provider(String, String, String)代替。
Provider(String, String, String) - Constructor for class java.security. Provider
构造具有指定名称，版本字符串和信息的提供程序。
PROVIDER_URL - Static variable in interface javax.naming. Context
包含用于指定服务提供商要使用的配置信息的环境属性的名称的常量。
Provider.Service - Class in java.security
安全服务的描述。
provideRefresh() - Method in class java.time.zone. ZoneRulesProvider
SPI方法从底层数据提供者刷新规则。
ProviderException - Exception in java.security
提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。
ProviderException() - Constructor for exception java.security. ProviderException
构造一个没有详细消息的ProviderException。
ProviderException(String) - Constructor for exception java.security. ProviderException
构造具有指定详细消息的ProviderException。
ProviderException(String, Throwable) - Constructor for exception java.security. ProviderException
创建一个具有指定的详细信息和原因的 ProviderException 。
ProviderException(Throwable) - Constructor for exception java.security. ProviderException
创建 ProviderException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
ProviderMismatchException - Exception in java.nio.file
当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。
ProviderMismatchException() - Constructor for exception java.nio.file. ProviderMismatchException
构造这个类的一个实例。
ProviderMismatchException(String) - Constructor for exception java.nio.file. ProviderMismatchException
构造这个类的一个实例。
ProviderNotFoundException - Exception in java.nio.file
无法找到所需类型的提供者时抛出的运行时异常。
ProviderNotFoundException() - Constructor for exception java.nio.file. ProviderNotFoundException
构造这个类的一个实例。
ProviderNotFoundException(String) - Constructor for exception java.nio.file. ProviderNotFoundException
构造这个类的一个实例。
providers() - Static method in class com.sun.tools.attach.spi. AttachProvider
返回已安装附件提供商的列表。
providers() - Method in class java.lang.module. ModuleDescriptor.Provides
返回提供商或提供者工厂的完全限定类名的列表。
provideRules(String, boolean) - Method in class java.time.zone. ZoneRulesProvider
SPI方法获取区域ID的规则。
provides() - Method in class java.lang.module. ModuleDescriptor
返回表示模块提供的服务的 Provides对象集。
provides(ModuleDescriptor.Provides) - Method in class java.lang.module. ModuleDescriptor.Builder
为一个或多个实现提供服务。
provides(String, List<String>) - Method in class java.lang.module. ModuleDescriptor.Builder
提供服务的实现。
PROVIDES - com.sun.source.doctree. DocTree.Kind
用于表示@provides标记的ProvidesTree的实例。
PROVIDES - com.sun.source.tree. Tree.Kind
用于代表在模块声明中提供指令的ProvidesTree的实例。
PROVIDES - javax.lang.model.element. ModuleElement.DirectiveKind
A“提供service-name with implementation-name”指令。
providesIn(Iterable<? extends ModuleElement.Directive>) - Static method in class javax.lang.model.util. ElementFilter
返回列表 provides的指令 directives 。
ProvidesTree - Interface in com.sun.source.doctree
@provides块标记的树节点。
ProvidesTree - Interface in com.sun.source.tree
模块声明中“提供”指令的树节点。
provideVersions(String) - Method in class java.time.zone. ZoneRulesProvider
SPI方法获取区域ID的规则历史。
provideZoneIds() - Method in class java.time.zone. ZoneRulesProvider
SPI方法获取可用的区域ID。
proxy - Variable in class java.beans.beancontext. BeanContextServicesSupport
代表 BeanContextServiceProvider 。
proxy() - Method in class jdk.incubator.http. HttpClient
返回一个 Optional其中包含此客户端的 ProxySelector 。
proxy(ProxySelector) - Method in class jdk.incubator.http. HttpClient.Builder
为此客户设置一个ProxySelector 。
Proxy - Class in java.lang.reflect
Proxy提供静态方法，用于创建类似于接口实例的对象，但允许自定义的方法调用。
Proxy - Class in java.net
此类表示代理设置，通常是类型（http，socks）和套接字地址。
Proxy(InvocationHandler) - Constructor for class java.lang.reflect. Proxy
从一个子类（通常是一个动态代理类）构造一个新的 Proxy实例，并为其调用处理程序指定了一个值。
Proxy(Proxy.Type, SocketAddress) - Constructor for class java.net. Proxy
创建一个表示PROXY连接的条目。
PROXY - java.net. Authenticator.RequestorType
请求身份验证的实体是HTTP代理服务器。
Proxy.Type - Enum in java.net
代表代理类型。
ProxyLazyValue(String) - Constructor for class javax.swing. UIDefaults.ProxyLazyValue
创建一个 LazyValue ，这将在询问时构造一个实例。
ProxyLazyValue(String, Object[]) - Constructor for class javax.swing. UIDefaults.ProxyLazyValue
创建一个 LazyValue ，这将在询问时构建一个实例。
ProxyLazyValue(String, String) - Constructor for class javax.swing. UIDefaults.ProxyLazyValue
创建一个 LazyValue ，这将在被询问时构造一个实例。
ProxyLazyValue(String, String, Object[]) - Constructor for class javax.swing. UIDefaults.ProxyLazyValue
创建一个 LazyValue ，这将在询问时构建一个实例。
ProxySelector - Class in java.net
选择在连接到URL引用的网络资源时使用的代理服务器（如果有）。
ProxySelector() - Constructor for class java.net. ProxySelector
PSALTER_PAHLAVI - java.lang. Character.UnicodeScript
Unicode脚本“Psalter Pahlavi”。
PSALTER_PAHLAVI - Static variable in class java.lang. Character.UnicodeBlock
“Psalter Pahlavi”Unicode字符块的常数。
PseudoClass - Class in javafx.css
伪类代表一个唯一的伪类状态。
PseudoClass() - Constructor for class javafx.css. PseudoClass
pseudoClassStateChanged(PseudoClass, boolean) - Method in class javafx.scene.control. PopupControl
pseudoClassStateChanged(PseudoClass, boolean) - Method in class javafx.scene.control. SkinBase
用于指定此节点的伪类已更改。
pseudoClassStateChanged(PseudoClass, boolean) - Method in class javafx.scene. Node
用于指定此节点的伪类已更改。
PseudoColumnUsage - Enum in java.sql
伪/隐藏列使用枚举。
PSource - Class in javax.crypto.spec
该类指定了在OAEP填充中编码输入P的源，如 PKCS #1标准中所定义。
PSource(String) - Constructor for class javax.crypto.spec. PSource
使用指定的PSource算法构建PKCS＃1标准中定义的OAEP填充的编码输入P的源。
PSource.PSpecified - Class in javax.crypto.spec
该类用于在OAEP填充中明确指定编码输入P的值。
PSpecified(byte[]) - Constructor for class javax.crypto.spec. PSource.PSpecified
使用指定值 p显式构建源作为编码输入P.
PSSParameterSpec - Class in java.security.spec
该类为 PKCS#1 v2.1标准中定义的RSA-PSS签名方案指定参数规范。
PSSParameterSpec(int) - Constructor for class java.security.spec. PSSParameterSpec
使用指定的盐长度和PKCS＃1中定义的其他默认值创建一个新的 PSSParameterSpec 。
PSSParameterSpec(String, String, AlgorithmParameterSpec, int, int) - Constructor for class java.security.spec. PSSParameterSpec
使用指定的消息摘要，掩码生成功能，掩码生成功能参数，盐长度和尾部字段值创建PKCS＃1标准中定义的新的 PSSParameterSpec 。
PT - javafx.css. SizeUnits
ptLineDist(double, double) - Method in class java.awt.geom. Line2D
返回从点到此行的距离。
ptLineDist(double, double, double, double, double, double) - Static method in class java.awt.geom. Line2D
返回从点到行的距离。
ptLineDist(Point2D) - Method in class java.awt.geom. Line2D
返回从 Point2D到此行的距离。
ptLineDistSq(double, double) - Method in class java.awt.geom. Line2D
返回从点到此行的距离的平方。
ptLineDistSq(double, double, double, double, double, double) - Static method in class java.awt.geom. Line2D
返回从点到行的距离的平方。
ptLineDistSq(Point2D) - Method in class java.awt.geom. Line2D
返回从指定的 Point2D到该行的距离的平方。
ptSegDist(double, double) - Method in class java.awt.geom. Line2D
返回从点到此线段的距离。
ptSegDist(double, double, double, double, double, double) - Static method in class java.awt.geom. Line2D
返回从点到线段的距离。
ptSegDist(Point2D) - Method in class java.awt.geom. Line2D
返回从 Point2D到此线段的距离。
ptSegDistSq(double, double) - Method in class java.awt.geom. Line2D
返回从点到该线段的距离的平方。
ptSegDistSq(double, double, double, double, double, double) - Static method in class java.awt.geom. Line2D
返回从点到线段的距离的平方。
ptSegDistSq(Point2D) - Method in class java.awt.geom. Line2D
返回从 Point2D到此线段的距离的平方。
PUBLIC - java.security. KeyRep.Type
输入公钥。
PUBLIC - javax.lang.model.element. Modifier
修饰词 public
PUBLIC - Static variable in class java.lang.invoke. MethodHandles.Lookup
代表 public访问的单位掩码，这可能有助于 lookupModes的结果。
PUBLIC - Static variable in interface java.lang.reflect. Member
标识类或接口的所有公共成员的集合，包括继承的成员。
PUBLIC - Static variable in class java.lang.reflect. Modifier
int值代表 public修饰符。
PUBLIC - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于PUBLIC
PUBLIC - Static variable in class jdk.dynalink.linker.support. Lookup
一个包含 MethodHandles.publicLookup()的规范Lookup对象。
PUBLIC_KEY - Static variable in class javax.crypto. Cipher
用于指示待解除密钥的常数是“公钥”。
PUBLIC_KEY_ENCRYPTION - java.security. CryptoPrimitive
不对称原语：公钥加密
PUBLIC_MEMBER - javax.xml.bind.annotation. XmlAccessType
除非由XmlTransient注释，否则每个公共getter / setter对和每个公共字段将被自动绑定到XML。
PUBLIC_MEMBER - Interface in org.omg.CORBA
在 ValueMember课程中定义公共成员的 ValueMember 。
PUBLIC_XML_SCHEMA - Static variable in interface javax.sql.rowset. WebRowSet
用于定义XML标签的XML模式定义的公共标识符及其对于 WebRowSet实现的 WebRowSet 。
PublicKey - Interface in java.security
公钥
publicLookup() - Static method in class java.lang.invoke. MethodHandles
返回lookup object ，这是最低信任的。
publish(Object) - Method in class javax.xml.ws. Endpoint
在提供的服务器上下文中发布此端点。
publish(String) - Method in class javax.xml.ws. Endpoint
在给定地址发布此端点。
publish(String, Object) - Static method in class javax.xml.ws. Endpoint
在给定的地址创建并发布指定的实现者对象的端点。
publish(String, Object, WebServiceFeature...) - Static method in class javax.xml.ws. Endpoint
在给定的地址创建并发布指定的实现者对象的端点。
publish(LogRecord) - Method in class java.util.logging. ConsoleHandler
发表 LogRecord 。
publish(LogRecord) - Method in class java.util.logging. FileHandler
格式化并发布一个 LogRecord 。
publish(LogRecord) - Method in class java.util.logging. Handler
发表 LogRecord 。
publish(LogRecord) - Method in class java.util.logging. MemoryHandler
将 LogRecord存储在内部缓冲区中。
publish(LogRecord) - Method in class java.util.logging. SocketHandler
格式化并发布一个 LogRecord 。
publish(LogRecord) - Method in class java.util.logging. StreamHandler
格式化并发布 LogRecord 。
publish(HttpContext) - Method in class javax.xml.ws. Endpoint
在提供的服务器上下文中发布此端点。
publish(V...) - Method in class javax.swing. SwingWorker
将数据块发送到 SwingWorker.process(java.util.List<V>)方法。
purge() - Method in class java.util.concurrent. ThreadPoolExecutor
尝试从工作队列中删除已取消的所有Future任务。
purge() - Method in class java.util. Timer
从该计时器的任务队列中删除所有取消的任务。
purgeRelations() - Method in class javax.management.relation. RelationService
清除关系。
purgeRelations() - Method in interface javax.management.relation. RelationServiceMBean
清除关系。
PURPLE - Static variable in class javafx.scene.paint. Color
颜色为紫色，RGB值为＃800080
push() - Method in class java.util.logging. MemoryHandler
将任何缓冲输出推送到目标 Handler 。
push(E) - Method in class java.util. ArrayDeque
将元素推送到由此deque表示的堆栈上。
push(E) - Method in interface java.util.concurrent. BlockingDeque
将元素推送到由此deque表示的堆栈（换句话说，在该deque的头部），如果可以立即执行此操作而不违反容量限制，则抛出 IllegalStateException如果当前没有可用空间）。
push(E) - Method in class java.util.concurrent. ConcurrentLinkedDeque
push(E) - Method in class java.util.concurrent. LinkedBlockingDeque
push(E) - Method in interface java.util. Deque
将元素推送到由此deque表示的堆栈（换句话说，在此deque的头部），如果可以立即执行此操作而不违反容量限制，则抛出 IllegalStateException如果当前没有可用空间）。
push(E) - Method in class java.util. LinkedList
将元素推送到由此列表表示的堆栈上。
push(E) - Method in class java.util. Stack
将项目推送到此堆栈的顶部。
push(EventQueue) - Method in class java.awt. EventQueue
用指定的替换现有的 EventQueue 。
PUSH_BUTTON - Static variable in class javax.accessibility. AccessibleRole
用户可以操纵的对象来告诉应用程序做某事。
pushBack() - Method in class java.io. StreamTokenizer
导致下一次调用此标记器的 nextToken方法以返回 ttype字段中的当前值，而不修改 nval或 sval字段中的值。
PushbackInputStream - Class in java.io
A PushbackInputStream通过将推回的字节存储在内部缓冲区中，为另一个输入流添加功能，即“推回”或“未读”字节的功能。
PushbackInputStream(InputStream) - Constructor for class java.io. PushbackInputStream
创建一个带有1个字节的推回缓冲区的 PushbackInputStream ，并保存其参数，输入流 in供以后使用。
PushbackInputStream(InputStream, int) - Constructor for class java.io. PushbackInputStream
使用指定的 size的推回缓冲区创建一个 PushbackInputStream ，并保存其参数，输入流 in供以后使用。
PushbackReader - Class in java.io
一个字符流读取器，允许将字符推回到流中。
PushbackReader(Reader) - Constructor for class java.io. PushbackReader
用一个字符的后置缓冲区创建一个新的推回阅读器。
PushbackReader(Reader, int) - Constructor for class java.io. PushbackReader
使用给定大小的推回缓冲区创建一个新的推回阅读器。
pushCharacterStyle() - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
在堆栈中推送当前字符样式，以准备形成新的嵌套字符样式。
pushContext() - Method in class org.xml.sax.helpers. NamespaceSupport
启动一个新的命名空间上下文。
put(byte) - Method in class java.nio. ByteBuffer
相对 放置法 （可选操作） 。
put(byte[]) - Method in class java.nio. ByteBuffer
相对大容量 put方法 （可选操作） 。
put(byte[], int, int) - Method in class java.nio. ByteBuffer
相对大容量 put方法 （可选操作） 。
put(char) - Method in class java.nio. CharBuffer
相对 放置法 （可选操作） 。
put(char[]) - Method in class java.nio. CharBuffer
相对大容量 put方法 （可选操作） 。
put(char[], int, int) - Method in class java.nio. CharBuffer
相对大容量 put方法 （可选操作） 。
put(double) - Method in class java.nio. DoubleBuffer
相对 放置法 （可选操作） 。
put(double[]) - Method in class java.nio. DoubleBuffer
相对大容量 put方法 （可选操作） 。
put(double[], int, int) - Method in class java.nio. DoubleBuffer
相对大容量 put方法 （可选操作） 。
put(float) - Method in class java.nio. FloatBuffer
相对 放置法 （可选操作） 。
put(float[]) - Method in class java.nio. FloatBuffer
相对大容量 put方法 （可选操作） 。
put(float[], int, int) - Method in class java.nio. FloatBuffer
相对大容量 put方法 （可选操作） 。
put(int) - Method in class java.nio. IntBuffer
相对 放置法 （可选操作） 。
put(int[]) - Method in class java.nio. IntBuffer
相对大容量 put方法 （可选操作） 。
put(int[], int, int) - Method in class java.nio. IntBuffer
相对大容量 put方法 （可选操作） 。
put(int, byte) - Method in class java.nio. ByteBuffer
绝对 put方法 （可选操作） 。
put(int, char) - Method in class java.nio. CharBuffer
绝对 put方法 （可选操作） 。
put(int, double) - Method in class java.nio. DoubleBuffer
绝对 put方法 （可选操作） 。
put(int, float) - Method in class java.nio. FloatBuffer
绝对 put方法 （可选操作） 。
put(int, int) - Method in class java.nio. IntBuffer
绝对 put方法 （可选操作） 。
put(int, long) - Method in class java.nio. LongBuffer
绝对 put方法 （可选操作） 。
put(int, short) - Method in class java.nio. ShortBuffer
绝对 put方法 （可选操作） 。
put(long) - Method in class java.nio. LongBuffer
相对 放置法 （可选操作） 。
put(long[]) - Method in class java.nio. LongBuffer
相对大容量 put方法 （可选操作） 。
put(long[], int, int) - Method in class java.nio. LongBuffer
相对大容量 put方法 （可选操作） 。
put(short) - Method in class java.nio. ShortBuffer
相对 放置法 （可选操作） 。
put(short[]) - Method in class java.nio. ShortBuffer
相对大容量 put方法 （可选操作） 。
put(short[], int, int) - Method in class java.nio. ShortBuffer
相对大容量 put方法 （可选操作） 。
put(E) - Method in class java.util.concurrent. ArrayBlockingQueue
在该队列的尾部插入指定的元素，如果队列已满，则等待空间变为可用。
put(E) - Method in interface java.util.concurrent. BlockingDeque
将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），等待空格变为可用时。
put(E) - Method in interface java.util.concurrent. BlockingQueue
将指定的元素插入到此队列中，等待空格可用。
put(E) - Method in class java.util.concurrent. DelayQueue
将指定的元素插入到此延迟队列中。
put(E) - Method in class java.util.concurrent. LinkedBlockingDeque
put(E) - Method in class java.util.concurrent. LinkedBlockingQueue
在该队列的尾部插入指定的元素，如果需要，等待空格变为可用。
put(E) - Method in class java.util.concurrent. LinkedTransferQueue
在该队列的尾部插入指定的元素。
put(E) - Method in class java.util.concurrent. PriorityBlockingQueue
将指定的元素插入到此优先级队列中。
put(E) - Method in class java.util.concurrent. SynchronousQueue
将指定的元素添加到此队列，等待另一个线程接收它。
put(Object, Object) - Method in class java.awt. RenderingHints
将指定的 key映射到此 RenderingHints对象中指定的 value 。
put(Object, Object) - Method in class java.security. Provider
将 key属性设置为具有指定的 value 。
put(Object, Object) - Method in class java.util.jar. Attributes
将指定的值与此Map中的指定属性名称（键）相关联。
put(Object, Object) - Method in class java.util. Properties
put(Object, Object) - Method in class javax.management.openmbean. TabularDataSupport
该方法简单地调用 put((CompositeData) value) ，因此忽略其 关键参数，可以是 null 。
put(Object, Object) - Method in class javax.swing. UIDefaults
将所有区域设置的值为 key设置为 value 。
put(Object, Object) - Static method in class javax.swing. UIManager
在开发人员默认值中存储一个对象。
put(Object, Object) - Method in class javax.xml.crypto.dom. DOMCryptoContext
此实现使用内部的HashMap将密钥映射到指定的对象。
put(Object, Object) - Method in interface javax.xml.crypto. XMLCryptoContext
将指定的值与此上下文中的指定关键字相关联。
put(Object, Action) - Method in class javax.swing. ActionMap
为 key添加一个绑定到 action 。
put(String) - Method in class java.nio. CharBuffer
相对大容量 put方法 （可选操作） 。
put(String, boolean) - Method in class java.io. ObjectOutputStream.PutField
将命名布尔字段的值放入持久字段。
put(String, byte) - Method in class java.io. ObjectOutputStream.PutField
将命名字节字段的值放入持久字段。
put(String, char) - Method in class java.io. ObjectOutputStream.PutField
将命名的char字段的值放入持久字段。
put(String, double) - Method in class java.io. ObjectOutputStream.PutField
将命名的双字段的值放入持久字段。
put(String, float) - Method in class java.io. ObjectOutputStream.PutField
将命名的浮动字段的值放入持久字段。
put(String, int) - Method in class java.io. ObjectOutputStream.PutField
将命名的int字段的值放入持久字段。
put(String, int, int) - Method in class java.nio. CharBuffer
相对大容量 put方法 （可选操作） 。
put(String, long) - Method in class java.io. ObjectOutputStream.PutField
将命名的长字段的值放入持久字段。
put(String, short) - Method in class java.io. ObjectOutputStream.PutField
将命名的短字段的值放入持久字段。
put(String, Object) - Method in class java.io. ObjectOutputStream.PutField
将命名的对象字段的值放入持久字段。
put(String, Object) - Method in interface javax.naming.directory. Attributes
向属性集添加一个新属性。
put(String, Object) - Method in class javax.naming.directory. BasicAttributes
put(String, Object) - Method in class javax.script. AbstractScriptEngine
使用受保护的 context字段的 ENGINE_SCOPE Bindings中的指定键设置指定的值。
put(String, Object) - Method in interface javax.script. Bindings
设置一个命名值。
put(String, Object) - Method in interface javax.script. ScriptEngine
在ScriptEngine的状态下设置一个键/值对，可以创建一个Java语言绑定，以便在执行脚本时使用，或者以其他方式使用，具体取决于该键是否被保留。
put(String, Object) - Method in class javax.script. ScriptEngineManager
在全局范围中设置指定的键/值对。
put(String, Object) - Method in class javax.script. SimpleBindings
设置底层 map字段中指定的键/值。
put(String, Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
put(String, String) - Method in class java.util.prefs. AbstractPreferences
实现 put方法按照在本说明书中 Preferences.put(String,String) 。
put(String, String) - Method in class java.util.prefs. Preferences
将指定的值与此首选项节点中的指定键相关联。
put(String, List<String>) - Method in class com.sun.net.httpserver. Headers
put(URI, URLConnection) - Method in class java.net. ResponseCache
协议处理程序在检索到资源后调用此方法，ResponseCache必须决定是否将资源存储在其缓存中。
put(URI, Map<String, List<String>>) - Method in class java.net. CookieHandler
设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
put(URI, Map<String, List<String>>) - Method in class java.net. CookieManager
put(ByteBuffer) - Method in class java.nio. ByteBuffer
相对大容量 put方法 （可选操作） 。
put(CharBuffer) - Method in class java.nio. CharBuffer
相对大容量 put方法 （可选操作） 。
put(DoubleBuffer) - Method in class java.nio. DoubleBuffer
相对大容量 put方法 （可选操作） 。
put(FloatBuffer) - Method in class java.nio. FloatBuffer
相对大容量 put方法 （可选操作） 。
put(IntBuffer) - Method in class java.nio. IntBuffer
相对大容量 put方法 （可选操作） 。
put(LongBuffer) - Method in class java.nio. LongBuffer
相对大容量 put方法 （可选操作） 。
put(ShortBuffer) - Method in class java.nio. ShortBuffer
相对大容量 put方法 （可选操作） 。
put(CompositeData) - Method in interface javax.management.openmbean. TabularData
将 值添加到此 TabularData实例。
put(CompositeData) - Method in class javax.management.openmbean. TabularDataSupport
put(Attribute) - Method in interface javax.naming.directory. Attributes
向属性集添加一个新属性。
put(Attribute) - Method in class javax.naming.directory. BasicAttributes
put(PrinterStateReason, Severity) - Method in class javax.print.attribute.standard. PrinterStateReasons
将给定的打印机状态原因添加到此打印机状态原因属性，将其与给定的严重性级别相关联。
put(KeyStroke, Object) - Method in class javax.swing. ComponentInputMap
为 keyStroke添加一个绑定到 actionMapKey 。
put(KeyStroke, Object) - Method in class javax.swing. InputMap
为 keyStroke添加一个绑定到 actionMapKey 。
put(HttpRequest, CompletableFuture<HttpResponse<V>>) - Method in class jdk.incubator.http. MultiMapResult
put(K, V) - Method in class java.util. AbstractMap
将指定的值与该映射中的指定键相关联（可选操作）。
put(K, V) - Method in class java.util.concurrent. ConcurrentHashMap
将指定的键映射到此表中的指定值。
put(K, V) - Method in class java.util.concurrent. ConcurrentSkipListMap
将指定的值与此映射中的指定键相关联。
put(K, V) - Method in class java.util. Dictionary
将指定的 key到该字典中指定的 value 。
put(K, V) - Method in class java.util. EnumMap
将指定的值与此映射中的指定键相关联。
put(K, V) - Method in class java.util. HashMap
将指定的值与此映射中的指定键相关联。
put(K, V) - Method in class java.util. Hashtable
将指定的 key映射到此散列表中指定的 value 。
put(K, V) - Method in class java.util. IdentityHashMap
将指定的值与此标识哈希映射中的指定键相关联。
put(K, V) - Method in interface java.util. Map
将指定的值与该映射中的指定键相关联（可选操作）。
put(K, V) - Method in class java.util. TreeMap
将指定的值与此映射中的指定键相关联。
put(K, V) - Method in class java.util. WeakHashMap
将指定的值与此映射中的指定键相关联。
put(K, V) - Method in class javafx.beans.binding. MapExpression
PUT(HttpRequest.BodyProcessor) - Method in class jdk.incubator.http. HttpRequest.Builder
将此构建器的请求方法设置为PUT，并将其请求体处理器设置为给定值。
putAll(Map<?, ?>) - Method in class java.awt. RenderingHints
将所有映射从指定的 Map到此 RenderingHints 。
putAll(Map<?, ?>) - Method in class java.security. Provider
将指定地图中的所有映射复制到此提供程序。
putAll(Map<?, ?>) - Method in class java.util.jar. Attributes
将所有属性名称 - 值映射从指定的属性复制到此映射。
putAll(Map<?, ?>) - Method in class java.util. Properties
putAll(Map<?, ?>) - Method in class javax.management.openmbean. TabularDataSupport
将指定映射 t中包含的所有值添加到此 TabularData实例。
putAll(Map<? extends String, ? extends Object>) - Method in interface javax.script. Bindings
将给定的 Map中的所有映射添加到此 Bindings 。
putAll(Map<? extends String, ? extends Object>) - Method in class javax.script. SimpleBindings
putAll使用 Map.putAll实现。
putAll(Map<? extends String, ? extends Object>) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
putAll(Map<? extends String, ? extends List<String>>) - Method in class com.sun.net.httpserver. Headers
putAll(Map<? extends HttpRequest, ? extends CompletableFuture<HttpResponse<V>>>) - Method in class jdk.incubator.http. MultiMapResult
putAll(Map<? extends K, ? extends V>) - Method in class java.util. AbstractMap
将指定地图的所有映射复制到此映射（可选操作）。
putAll(Map<? extends K, ? extends V>) - Method in class java.util.concurrent. ConcurrentHashMap
将指定地图的所有映射复制到此映射。
putAll(Map<? extends K, ? extends V>) - Method in class java.util. EnumMap
将指定地图的所有映射复制到此地图。
putAll(Map<? extends K, ? extends V>) - Method in class java.util. HashMap
将指定地图的所有映射复制到此地图。
putAll(Map<? extends K, ? extends V>) - Method in class java.util. Hashtable
将所有从指定地图的映射复制到此散列表。
putAll(Map<? extends K, ? extends V>) - Method in class java.util. IdentityHashMap
将指定地图的所有映射复制到此地图。
putAll(Map<? extends K, ? extends V>) - Method in interface java.util. Map
将指定地图的所有映射复制到此映射（可选操作）。
putAll(Map<? extends K, ? extends V>) - Method in class java.util. TreeMap
将指定地图的所有映射复制到此地图。
putAll(Map<? extends K, ? extends V>) - Method in class java.util. WeakHashMap
将指定地图的所有映射复制到此地图。
putAll(Map<? extends K, ? extends V>) - Method in class javafx.beans.binding. MapExpression
putAll(CompositeData[]) - Method in interface javax.management.openmbean. TabularData
将 值中的所有元素添加到此 TabularData实例中。
putAll(CompositeData[]) - Method in class javax.management.openmbean. TabularDataSupport
将 值中的所有元素添加到此 TabularData实例。
putBoolean(String, boolean) - Method in class java.util.prefs. AbstractPreferences
实现 putBoolean方法按照在本说明书中 Preferences.putBoolean(String,boolean) 。
putBoolean(String, boolean) - Method in class java.util.prefs. Preferences
将表示指定布尔值的字符串与此首选项节点中指定的键相关联。
putByteArray(String, byte[]) - Method in class java.util.prefs. AbstractPreferences
实现 putByteArray方法按照在本说明书中 Preferences.putByteArray(String,byte[]) 。
putByteArray(String, byte[]) - Method in class java.util.prefs. Preferences
将表示指定字节数组的字符串与此首选项节点中指定的键相关联。
putChar(char) - Method in class java.nio. ByteBuffer
写入char值的相对 put方法 （可选操作） 。
putChar(int, char) - Method in class java.nio. ByteBuffer
用于写入char值的绝对 put方法 （可选操作） 。
putClientProperty(Object, Object) - Method in class javax.swing. JComponent
向此组件添加任意键/值“客户端属性”。
putConstraint(String, Component, int, String, Component) - Method in class javax.swing. SpringLayout
链接边缘 e1组分 c1到边缘 e2组分 c2 ，边与边之间的距离固定。
putConstraint(String, Component, Spring, String, Component) - Method in class javax.swing. SpringLayout
链接边缘 e1组分 c1到边缘 e2组分 c2 。
putDefaults(Object[]) - Method in class javax.swing. UIDefaults
将所有键/值对放在数据库中，无条件生成一个 PropertyChangeEvent 。
putDouble(double) - Method in class java.nio. ByteBuffer
写入double值的相对 put方法 （可选操作） 。
putDouble(int, double) - Method in class java.nio. ByteBuffer
用于写入双精度值的绝对 put方法 （可选操作） 。
putDouble(String, double) - Method in class java.util.prefs. AbstractPreferences
实现 putDouble方法按照在本说明书中 Preferences.putDouble(String,double) 。
putDouble(String, double) - Method in class java.util.prefs. Preferences
将表示指定双重值的字符串与此首选项节点中指定的键相关联。
putDTDHash(String, DTD) - Static method in class javax.swing.text.html.parser. DTD
将名称和适当的DTD放在散列表中。
PutField() - Constructor for class java.io. ObjectOutputStream.PutField
putFields() - Method in class java.io. ObjectOutputStream
检索用于缓冲要写入流的持久性字段的对象。
putFiles(List<File>) - Method in class javafx.scene.input. ClipboardContent
将文件列表放入 ClipboardContent 。
putFilesByPath(List<String>) - Method in class javafx.scene.input. ClipboardContent
根据文件路径将文件列表放入 ClipboardContent 。
putFirst(E) - Method in interface java.util.concurrent. BlockingDeque
在此deque的前面插入指定的元素，如有必要，等待空格变为可用。
putFirst(E) - Method in class java.util.concurrent. LinkedBlockingDeque
putFloat(float) - Method in class java.nio. ByteBuffer
编写浮点值的相对 put方法 （可选操作） 。
putFloat(int, float) - Method in class java.nio. ByteBuffer
用于写入浮点值的绝对 put方法 （可选操作） 。
putFloat(String, float) - Method in class java.util.prefs. AbstractPreferences
实现 putFloat方法按照在本说明书中 Preferences.putFloat(String,float) 。
putFloat(String, float) - Method in class java.util.prefs. Preferences
将表示指定浮点值的字符串与此首选项节点中指定的键相关联。
putHtml(String) - Method in class javafx.scene.input. ClipboardContent
将一个HTML字符串放入 ClipboardContent 。
putIfAbsent(Object, Object) - Method in class java.security. Provider
如果指定的键尚未与值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。
putIfAbsent(Object, Object) - Method in class java.util. Properties
putIfAbsent(K, V) - Method in class java.util.concurrent. ConcurrentHashMap
如果指定的键尚未与值相关联，则将其与给定值相关联。
putIfAbsent(K, V) - Method in interface java.util.concurrent. ConcurrentMap
如果指定的键尚未与值相关联，则将其与给定值相关联。
putIfAbsent(K, V) - Method in class java.util.concurrent. ConcurrentSkipListMap
如果指定的键尚未与值相关联，则将其与给定值相关联。
putIfAbsent(K, V) - Method in class java.util. HashMap
putIfAbsent(K, V) - Method in class java.util. Hashtable
putIfAbsent(K, V) - Method in interface java.util. Map
如果指定的键尚未与值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。
putImage(Image) - Method in class javafx.scene.input. ClipboardContent
将图像放入 ClipboardContent 。
putInt(int) - Method in class java.nio. ByteBuffer
编写int值的相对 put方法 （可选操作） 。
putInt(int, int) - Method in class java.nio. ByteBuffer
用于写入int值的绝对 put方法 （可选操作） 。
putInt(String, int) - Method in class java.util.prefs. AbstractPreferences
实现 putInt方法按照在本说明书中 Preferences.putInt(String,int) 。
putInt(String, int) - Method in class java.util.prefs. Preferences
将表示指定int值的字符串与此首选项节点中的指定键相关联。
putLast(E) - Method in interface java.util.concurrent. BlockingDeque
在此deque的末尾插入指定的元素，如有必要，等待空格变为可用。
putLast(E) - Method in class java.util.concurrent. LinkedBlockingDeque
putLayer(JComponent, int) - Static method in class javax.swing. JLayeredPane
设置JComponent上的layer属性。
putLong(int, long) - Method in class java.nio. ByteBuffer
绝对 put方法写入一个长的值 （可选操作） 。
putLong(long) - Method in class java.nio. ByteBuffer
写入长值的相对 put方法 （可选操作） 。
putLong(String, long) - Method in class java.util.prefs. AbstractPreferences
实现 putLong方法按照在本说明书中 Preferences.putLong(String,long) 。
putLong(String, long) - Method in class java.util.prefs. Preferences
将表示指定长值的字符串与此首选项节点中指定的键相关联。
putNamespacePrefix(String, String) - Method in class javax.xml.crypto.dom. DOMCryptoContext
此实现使用内部HashMap将URI映射到指定的前缀。
putNamespacePrefix(String, String) - Method in interface javax.xml.crypto. XMLCryptoContext
将指定的命名空间URI映射到指定的前缀。
putNextEntry(ZipEntry) - Method in class java.util.jar. JarOutputStream
开始编写一个新的JAR文件条目，并将流定位到入口数据的开头。
putNextEntry(ZipEntry) - Method in class java.util.zip. ZipOutputStream
开始编写新的ZIP文件条目，并将流定位到条目数据的开头。
putProperty(Object, Object) - Method in interface com.sun.jdi.request. EventRequest
向此请求添加任意键/值“属性”。
putProperty(Object, Object) - Method in class javax.swing.text. AbstractDocument
用于存储属性值的便利方法。
putProperty(Object, Object) - Method in interface javax.swing.text. Document
将属性与文档相关联。
putRtf(String) - Method in class javafx.scene.input. ClipboardContent
将一个RTF字符串放入 ClipboardContent 。
putService(Provider.Service) - Method in class java.security. Provider
添加服务。
putShort(int, short) - Method in class java.nio. ByteBuffer
绝对 put方法写入一个简短的值 （可选操作） 。
putShort(short) - Method in class java.nio. ByteBuffer
写入一个短值的相对 放置方法 （可选操作） 。
putSpi(String, String) - Method in class java.util.prefs. AbstractPreferences
将给定的键值关联放入此首选项节点。
putString(String) - Method in class javafx.scene.input. ClipboardContent
将纯文本字符串放入 ClipboardContent 。
putUrl(String) - Method in class javafx.scene.input. ClipboardContent
将一个URL字符串放入 ClipboardContent 。
putValue(String, Object) - Method in interface javax.net.ssl. SSLSession
使用给定的 name将指定的 value对象绑定到会话的应用程序层数据中。
putValue(String, Object) - Method in class javax.swing. AbstractAction
设置与指定键相关联的 Value 。
putValue(String, Object) - Method in interface javax.swing. Action
使用关联的键设置此对象的属性之一。
putValue(String, String) - Method in class java.util.jar. Attributes
将指定的值与指定的属性名称相关联，指定为String。
PX - javafx.css. SizeUnits
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Q-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Q

Q - javafx.scene.input. KeyCode
常数为 Q键。
QName - Class in javax.xml.namespace
QName表示如在XML规范中定义一个 限定名 ： XML Schema Part2: Datatypes specification ， Namespaces in XML ， Namespaces in XML Errata 。
QName(String) - Constructor for class javax.xml.namespace. QName
QName指定本地零件的构造函数。
QName(String, String) - Constructor for class javax.xml.namespace. QName
QName构造函数指定命名空间URI和本地部分。
QName(String, String, String) - Constructor for class javax.xml.namespace. QName
QName构造函数，指定命名空间URI，本地部分和前缀。
QOP - Static variable in class javax.security.sasl. Sasl
指定要使用的保护质量的属性的名称。
QuadCurve - Class in javafx.scene.shape
Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。
QuadCurve() - Constructor for class javafx.scene.shape. QuadCurve
创建一个空的QuadCurve实例。
QuadCurve(double, double, double, double, double, double) - Constructor for class javafx.scene.shape. QuadCurve
创建一个新的QuadCurve实例。
QuadCurve2D - Class in java.awt.geom
QuadCurve2D类定义了 (x,y)坐标空间中的二次参数曲线段。
QuadCurve2D() - Constructor for class java.awt.geom. QuadCurve2D
这是一个无法直接实例化的抽象类。
QuadCurve2D.Double - Class in java.awt.geom
用 double坐标指定的二次参数曲线段。
QuadCurve2D.Float - Class in java.awt.geom
用 float坐标指定的二次参数曲线段。
QuadCurveTo - Class in javafx.scene.shape
通过绘制与当前坐标和指定坐标 (x, y)相交的二次曲线曲线，使用指定点 (controlX, controlY)作为Bézier控制点，创建由两个新点定义的曲线路径元素。
QuadCurveTo() - Constructor for class javafx.scene.shape. QuadCurveTo
创建一个空的QuadCurveTo实例。
QuadCurveTo(double, double, double, double) - Constructor for class javafx.scene.shape. QuadCurveTo
创建一个新的QuadCurveTo实例。
quadrantRotate(int) - Method in class java.awt.geom. AffineTransform
使用将坐标旋转指定数量的象限的变换来连接此变换。
quadrantRotate(int, double, double) - Method in class java.awt.geom. AffineTransform
使用将坐标旋转指定锚点周围指定数量的象限的变换来连接此变换。
quadraticCurveTo(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
将段添加到当前路径以生成二次贝塞尔曲线。
quadTo(double, double, double, double) - Method in class java.awt.geom. Path2D.Double
通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
quadTo(double, double, double, double) - Method in class java.awt.geom. Path2D.Float
通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
quadTo(double, double, double, double) - Method in class java.awt.geom. Path2D
通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
quadTo(float, float, float, float) - Method in class java.awt.geom. Path2D.Float
通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
QUALIFIED - javax.xml.bind.annotation. XmlNsForm
qualifiedName() - Method in interface com.sun.javadoc. ProgramElementDoc
已过时。
获取此程序元素的完全限定名称。
QualifiedNameable - Interface in javax.lang.model.element
用于具有限定名称的元素的mixin接口。
qualifiedTypeName() - Method in interface com.sun.javadoc. Type
已过时。
返回不包括任何维度信息的类型的限定名称。
QUALITY - javafx.scene. CacheHint
告诉位图缓存机制，这个节点应该以最高的视觉质量出现在屏幕上。
QUARTER_OF_YEAR - Static variable in class java.time.temporal. IsoFields
代表季度的领域。
QUARTER_YEARS - Static variable in class java.time.temporal. IsoFields
代表四分之一年概念的单位。
QUARTO - Static variable in class java.awt. PageAttributes.MediaType
Quarto的MediaType实例，215 x 275 mm。
QUARTO - Static variable in class javax.print.attribute.standard. MediaSize.Other
指定季度大小，8.5英寸×10.83英寸。
QUARTO - Static variable in class javax.print.attribute.standard. MediaSizeName
季度大小
query(TemporalQuery<R>) - Method in interface java.time.chrono. ChronoLocalDate
使用指定的查询查询此日期。
query(TemporalQuery<R>) - Method in interface java.time.chrono. ChronoLocalDateTime
使用指定的查询查询此日期时间。
query(TemporalQuery<R>) - Method in interface java.time.chrono. ChronoZonedDateTime
使用指定的查询查询此日期时间。
query(TemporalQuery<R>) - Method in interface java.time.chrono. Era
使用指定的查询查询此时代。
query(TemporalQuery<R>) - Method in enum java.time. DayOfWeek
使用指定的查询查询此星期几。
query(TemporalQuery<R>) - Method in class java.time. Instant
使用指定的查询查询此即时。
query(TemporalQuery<R>) - Method in class java.time. LocalDate
使用指定的查询查询此日期。
query(TemporalQuery<R>) - Method in class java.time. LocalDateTime
使用指定的查询查询此日期时间。
query(TemporalQuery<R>) - Method in class java.time. LocalTime
此时使用指定的查询进行查询。
query(TemporalQuery<R>) - Method in enum java.time. Month
使用指定的查询查询此月份的一年。
query(TemporalQuery<R>) - Method in class java.time. MonthDay
使用指定的查询查询此月日。
query(TemporalQuery<R>) - Method in class java.time. OffsetDateTime
使用指定的查询查询此日期时间。
query(TemporalQuery<R>) - Method in class java.time. OffsetTime
此时使用指定的查询进行查询。
query(TemporalQuery<R>) - Method in interface java.time.temporal. TemporalAccessor
查询此日期时间。
query(TemporalQuery<R>) - Method in class java.time. Year
今年查询使用指定的查询。
query(TemporalQuery<R>) - Method in class java.time. YearMonth
使用指定的查询查询今年。
query(TemporalQuery<R>) - Method in class java.time. ZonedDateTime
使用指定的查询查询此日期时间。
query(TemporalQuery<R>) - Method in class java.time. ZoneOffset
使用指定的查询查询此偏移量。
Query - Class in javax.management
构造查询对象约束。
Query() - Constructor for class javax.management. Query
基本构造函数
QUERY_STRING - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：请求的查询字符串。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. CheckBox
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ChoiceBox
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ComboBox
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ComboBoxBase
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. Control
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. DatePicker
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. Hyperlink
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ListCell
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ListView
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. PasswordField
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ProgressBar
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ProgressIndicator
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. RadioButton
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ScrollBar
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ScrollPane
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. LabeledSkinBase
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. ListViewSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. MenuBarSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. MenuButtonSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. PaginationSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. ScrollPaneSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TableColumnHeader
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TableRowSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TableViewSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TableViewSkinBase
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TabPaneSkin
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TextAreaSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TextFieldSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. ToolBarSkin
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TreeTableRowSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TreeTableViewSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control.skin. TreeViewSkin
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. SkinBase
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. Slider
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. Spinner
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. SplitMenuButton
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TableCell
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TableRow
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TableView
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TextInputControl
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TitledPane
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. ToggleButton
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TreeCell
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TreeTableCell
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TreeTableRow
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TreeTableView
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.control. TreeView
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene. Node
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene. Parent
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.text. Text
该方法由辅助技术调用以请求属性的值。
queryAccessibleAttribute(AccessibleAttribute, Object...) - Method in class javafx.scene.text. TextFlow
该方法由辅助技术调用以请求属性的值。
QueryEval - Class in javax.management
允许在特定MBean服务器的上下文中执行查询。
QueryEval() - Constructor for class javax.management. QueryEval
QueryExp - Interface in javax.management
表示与数据库查询“where子句”类似的关系约束。
queryFrom(TemporalAccessor) - Method in interface java.time.temporal. TemporalQuery
查询指定的时间对象。
queryMBeans(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi. RMIConnection
处理方法 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 。
queryMBeans(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
queryMBeans(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl
queryMBeans(ObjectName, QueryExp) - Method in interface javax.management. MBeanServer
获取由MBean服务器控制的MBean。
queryMBeans(ObjectName, QueryExp) - Method in interface javax.management. MBeanServerConnection
获取由MBean服务器控制的MBean。
queryNames(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi. RMIConnection
处理方法 MBeanServerConnection.queryNames(ObjectName, QueryExp) 。
queryNames(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
queryNames(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl
queryNames(ObjectName, QueryExp) - Method in interface javax.management. MBeanServer
获取由MBean服务器控制的MBean的名称。
queryNames(ObjectName, QueryExp) - Method in interface javax.management. MBeanServerConnection
获取由MBean服务器控制的MBean的名称。
QUESTION_DIALOG - Static variable in class javax.swing. JRootPane
用于windowDecorationStyle属性的常量。
QUESTION_MESSAGE - Static variable in class javax.swing. JOptionPane
用于问题。
Queue< E> - Interface in java.util
设计用于在处理之前保留元素的集合。
QUEUED_IN_DEVICE - Static variable in class javax.print.attribute.standard. JobStateReason
该作业已被转发到无法发回状态的设备或打印系统。
QueuedJobCount - Class in javax.print.attribute.standard
Class QueuedJobCount是一个整数值打印属性，表示打印机中的作业数量，其中JobState为PENDING，PENDING_HELD，PROCESSING或PROCESSING_STOPPED。
QueuedJobCount(int) - Constructor for class javax.print.attribute.standard. QueuedJobCount
使用给定的整数值构造新的排队作业计数属性。
quietlyComplete() - Method in class java.util.concurrent. ForkJoinTask
正常完成此任务而不设置值。
quietlyCompleteRoot() - Method in class java.util.concurrent. CountedCompleter
相当于 getRoot().quietlyComplete() 。
quietlyInvoke() - Method in class java.util.concurrent. ForkJoinTask
执行此任务并等待其完成（如有必要），而不返回其结果或抛出异常。
quietlyJoin() - Method in class java.util.concurrent. ForkJoinTask
加入此任务，不返回其结果或抛出异常。
QuitEvent - Class in java.awt.desktop
当应用程序被要求退出时发送事件。
QuitEvent() - Constructor for class java.awt.desktop. QuitEvent
构造一个 QuitEvent
QuitHandler - Interface in java.awt.desktop
执行者确定是否应该继续或取消退出此应用程序的请求。
QuitResponse - Interface in java.awt.desktop
用于响应退出应用程序的请求。
QuitStrategy - Enum in java.awt.desktop
如果未启用“突发终止”，则用于关闭应用程序的策略。
quote(String) - Static method in class java.util.regex. Pattern
返回面值模式 String指定的 String 。
quote(String) - Static method in class javax.management. ObjectName
返回给定String的引用形式，适合包含在ObjectName中。
QUOTE - javafx.scene.input. KeyCode
常数为 Quote键。
quoteChar(int) - Method in class java.io. StreamTokenizer
指定此字符串的匹配对在此分段器中分隔字符串常量。
QUOTEDBL - javafx.scene.input. KeyCode
常数为 Double Quote键。
quoteReplacement(String) - Static method in class java.util.regex. Matcher
返回面值替换 String指定的 String 。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


R-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

R

R - javafx.scene.input. KeyCode
常数为 R键。
RAD - javafx.css. SizeUnits
RadialGradient - Class in javafx.scene.paint
RadialGradient类提供了一种填充圆形径向颜色渐变图案的形状的方法。
RadialGradient(double, double, double, double, double, boolean, CycleMethod, List<Stop>) - Constructor for class javafx.scene.paint. RadialGradient
创建一个新的RadialGradient实例。
RadialGradient(double, double, double, double, double, boolean, CycleMethod, Stop...) - Constructor for class javafx.scene.paint. RadialGradient
创建一个新的RadialGradient实例。
RadialGradientPaint - Class in java.awt
RadialGradientPaint类提供了一种填充圆形径向颜色渐变图案的形状的方法。
RadialGradientPaint(float, float, float, float[], Color[]) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
RadialGradientPaint(float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint ，使用默认的 SRGB颜色空间，以中心为焦点。
RadialGradientPaint(float, float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint ，默认为 SRGB颜色空间。
RadialGradientPaint(Point2D, float, float[], Color[]) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
RadialGradientPaint(Point2D, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint ，使用默认的 SRGB颜色空间，以中心为焦点。
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint ，具有默认的 SRGB颜色空间。
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint 。
RadialGradientPaint(Rectangle2D, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt. RadialGradientPaint
构造一个 RadialGradientPaint ，默认为 SRGB颜色空间。
RADIO_BUTTON - javafx.scene. AccessibleRole
单选按钮角色。
RADIO_BUTTON - Static variable in class javax.accessibility. AccessibleRole
一个专门的复选框将导致同一组中的其他单选按钮在选中时被取消选中。
RADIO_BUTTON - Static variable in class javax.swing.plaf.synth. Region
RadioButton地区。
RADIO_BUTTON_MENU_ITEM - Static variable in class javax.swing.plaf.synth. Region
RegionButtonMenuItem区域。
RADIO_MENU_ITEM - javafx.scene. AccessibleRole
收音机菜单项目角色。
RadioButton - Class in javafx.scene.control
RadioButtons创建一系列只能选择一个项目的项目。
RadioButton() - Constructor for class javafx.scene.control. RadioButton
为其标签创建一个空字符串的单选按钮。
RadioButton(String) - Constructor for class javafx.scene.control. RadioButton
创建具有指定文本的单选按钮作为其标签。
RadioButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic. BasicBorders.RadioButtonBorder
构造一个新的实例 RadioButtonBorder 。
RadioButtonSkin - Class in javafx.scene.control.skin
默认皮肤实现为RadioButton控件。
RadioButtonSkin(RadioButton) - Constructor for class javafx.scene.control.skin. RadioButtonSkin
创建一个新的RadioButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。
RadioMenuItem - Class in javafx.scene.control
一个RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。
RadioMenuItem() - Constructor for class javafx.scene.control. RadioMenuItem
构造一个没有显示文本的RadioMenuItem。
RadioMenuItem(String) - Constructor for class javafx.scene.control. RadioMenuItem
构造一个RadioMenuItem并设置指定文本的显示文本。
RadioMenuItem(String, Node) - Constructor for class javafx.scene.control. RadioMenuItem
构造一个RadioMenuItem并设置具有指定文本的显示文本，并将图形Node设置为给定节点。
radiusProperty() - Method in class javafx.scene.effect. DropShadow
阴影模糊内核的半径。
radiusProperty() - Method in class javafx.scene.effect. GaussianBlur
模糊内核的半径。
radiusProperty() - Method in class javafx.scene.effect. InnerShadow
阴影模糊内核的半径。
radiusProperty() - Method in class javafx.scene.effect. MotionBlur
模糊内核的半径。
radiusProperty() - Method in class javafx.scene.effect. Shadow
阴影模糊内核的半径。
radiusProperty() - Method in class javafx.scene.shape. Circle
定义圆的半径，以像素为单位。
radiusProperty() - Method in class javafx.scene.shape. Cylinder
定义圆柱体Z平面中的半径。
radiusProperty() - Method in class javafx.scene.shape. Sphere
定义球体的半径。
radiusXProperty() - Method in class javafx.scene.shape. Arc
定义整个椭圆的整体宽度（水平半径），其中该弧是部分截面。
radiusXProperty() - Method in class javafx.scene.shape. ArcTo
用于电弧的水平半径。
radiusXProperty() - Method in class javafx.scene.shape. Ellipse
定义椭圆的宽度（以像素为单位）。
radiusYProperty() - Method in class javafx.scene.shape. Arc
定义整个椭圆的整体高度（垂直半径），其中该弧是部分截面。
radiusYProperty() - Method in class javafx.scene.shape. ArcTo
用于电弧的垂直半径。
radiusYProperty() - Method in class javafx.scene.shape. Ellipse
以像素为单位定义椭圆的高度。
radix() - Method in class java.util. Scanner
返回此扫描仪的默认基数。
RAISED - Static variable in class javax.swing.border. BevelBorder
凸出斜角型。
RAISED - Static variable in class javax.swing.border. EtchedBorder
凸版蚀刻型。
random() - Static method in class java.lang. Math
返回值为 double的正值，大于等于 0.0 ，小于 1.0 。
random() - Static method in class java.lang. StrictMath
返回值为 double值为正号，大于等于 0.0 ，小于 1.0 。
Random - Class in java.util
该类的实例用于生成伪随机数的流。
Random() - Constructor for class java.util. Random
创建一个新的随机数生成器。
Random(long) - Constructor for class java.util. Random
使用单个 long种子创建一个新的随机数生成器。
RandomAccess - Interface in java.util
标记接口由 List实现使用，以表明它们支持快速（通常为恒定时间）随机访问。
RandomAccessFile - Class in java.io
该类的实例支持读取和写入随机访问文件。
RandomAccessFile(File, String) - Constructor for class java.io. RandomAccessFile
创建一个随机访问文件流，从File参数指定的文件中读取并可选地写入。
RandomAccessFile(String, String) - Constructor for class java.io. RandomAccessFile
创建随机访问文件流，以从中指定名称的文件读取，并可选择写入文件。
RANDOMPIXELORDER - Static variable in interface java.awt.image. ImageConsumer
像素将以随机顺序递送。
randomUUID() - Static method in class java.util. UUID
静态工厂检索一个类型4（伪随机生成）的UUID。
range() - Method in enum java.time.temporal. ChronoField
获取字段的有效值的范围。
range() - Method in interface java.time.temporal. TemporalField
获取字段的有效值的范围。
range(int, int) - Static method in interface java.util.stream. IntStream
返回有序的顺序 IntStream从 startInclusive （含）至 endExclusive由增量步骤（独家） 1 。
range(long, long) - Static method in interface java.util.stream. LongStream
通过 startInclusive的增量步骤将 1 （含）的序列 LongStream返回到 endExclusive （排除）。
range(E, E) - Static method in class java.util. EnumSet
创建最初包含由两个指定端点定义的范围内的所有元素的枚举集。
range(ChronoField) - Method in interface java.time.chrono. Chronology
获取指定字段的有效值的范围。
range(ChronoField) - Method in class java.time.chrono. HijrahChronology
range(ChronoField) - Method in class java.time.chrono. IsoChronology
range(ChronoField) - Method in class java.time.chrono. JapaneseChronology
range(ChronoField) - Method in class java.time.chrono. MinguoChronology
range(ChronoField) - Method in class java.time.chrono. ThaiBuddhistChronology
range(TemporalField) - Method in interface java.time.chrono. ChronoZonedDateTime
range(TemporalField) - Method in interface java.time.chrono. Era
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time.chrono. HijrahDate
range(TemporalField) - Method in enum java.time.chrono. HijrahEra
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time.chrono. JapaneseDate
range(TemporalField) - Method in class java.time.chrono. JapaneseEra
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time.chrono. MinguoDate
range(TemporalField) - Method in class java.time.chrono. ThaiBuddhistDate
range(TemporalField) - Method in enum java.time. DayOfWeek
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. Instant
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. LocalDate
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. LocalDateTime
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. LocalTime
获取指定字段的有效值的范围。
range(TemporalField) - Method in enum java.time. Month
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. MonthDay
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. OffsetDateTime
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. OffsetTime
获取指定字段的有效值的范围。
range(TemporalField) - Method in interface java.time.temporal. TemporalAccessor
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. Year
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. YearMonth
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. ZonedDateTime
获取指定字段的有效值的范围。
range(TemporalField) - Method in class java.time. ZoneOffset
获取指定字段的有效值的范围。
Range - Interface in org.w3c.dom.ranges
另见 Document Object Model (DOM) Level 2 Traversal and Range Specification 。
RANGE - Static variable in class java.awt. JobAttributes.DefaultSelectionType
用于指定应打印作业范围的 DefaultSelectionType实例。
rangeClosed(int, int) - Static method in interface java.util.stream. IntStream
将 startInclusive （含）的序列 IntStream返回到 endInclusive （含），增量为 1 。
rangeClosed(long, long) - Static method in interface java.util.stream. LongStream
从 startInclusive （含）的顺序排列 LongStream返回 endInclusive （含），增量为 1 。
RangeException - Exception in org.w3c.dom.ranges
范围操作可能会抛出其方法说明中指定的 RangeException 。
RangeException(short, String) - Constructor for exception org.w3c.dom.ranges. RangeException
rangeRefinedBy(TemporalAccessor) - Method in enum java.time.temporal. ChronoField
rangeRefinedBy(TemporalAccessor) - Method in interface java.time.temporal. TemporalField
使用时间对象获取此字段的有效值的范围以优化结果。
rangeShape(int, int) - Method in class javafx.scene.text. Text
返回局部坐标中文本范围的形状。
rangeShape(int, int) - Method in class javafx.scene.text. TextFlow
返回局部坐标中文本范围的形状。
raster - Variable in class javax.imageio. IIOImage
Raster被引用。
Raster - Class in java.awt.image
表示矩形像素阵列的类。
Raster(SampleModel, DataBuffer, Point) - Constructor for class java.awt.image. Raster
使用给定的SampleModel和DataBuffer构造光栅。
Raster(SampleModel, DataBuffer, Rectangle, Point, Raster) - Constructor for class java.awt.image. Raster
使用给定的SampleModel，DataBuffer和父构造栅格。
Raster(SampleModel, Point) - Constructor for class java.awt.image. Raster
使用给定的SampleModel构造光栅。
RasterFormatException - Exception in java.awt.image
如果RasterFormatException中有无效的布局信息，则抛出RasterFormatException 。
RasterFormatException(String) - Constructor for exception java.awt.image. RasterFormatException
构造一个新的 RasterFormatException与指定的消息。
RasterOp - Interface in java.awt.image
该界面介绍了对栅格对象执行的单输入/单输出操作。
RATA_DIE - Static variable in class java.time.temporal. JulianFields
拉塔死场。
rateProperty() - Method in class javafx.animation. Animation
定义 Animation预计播放的方向/速度。
rateProperty() - Method in class javafx.scene.media. AudioClip
剪辑播放的相对速率。
rateProperty() - Method in class javafx.scene.media. MediaPlayer
要播放媒体的速度。
RAW_SEND_SIZE - Static variable in class javax.security.sasl. Sasl
它指定的字节初始发送缓冲区的最大大小的属性的名称 SaslClient / SaslServer 。
RAW_TEXT - Static variable in class java.awt.im. InputMethodHighlight
原始文本状态不变。
RAW_X509_CERTIFICATE_TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo. X509Data
标识二进制文件的URI（ASN.1 DER）X.509证书KeyInfo类型：http://www.w3.org/2000/09/xmldsig#rawX509证书。
rawCompiledVersion() - Method in class java.lang.module. ModuleDescriptor.Requires
如果在编译时记录，则返回具有可能不可粗体版本的模块的字符串。
rawVersion() - Method in class java.lang.module. ModuleDescriptor
返回具有可能不可粗体版本的模块的字符串
RC2ParameterSpec - Class in javax.crypto.spec
该类指定与 RC2算法一起使用的参数。
RC2ParameterSpec(int) - Constructor for class javax.crypto.spec. RC2ParameterSpec
根据给定的有效密钥大小（以位为单位）构建RC2的参数集。
RC2ParameterSpec(int, byte[]) - Constructor for class javax.crypto.spec. RC2ParameterSpec
从给定的有效密钥大小（以比特）和8字节的IV构造一个RC2参数集。
RC2ParameterSpec(int, byte[], int) - Constructor for class javax.crypto.spec. RC2ParameterSpec
从给定的有效密钥大小（以位）和IV构造一个RC2参数集。
RC5ParameterSpec - Class in javax.crypto.spec
此类指定与 RC5算法一起使用的参数。
RC5ParameterSpec(int, int, int) - Constructor for class javax.crypto.spec. RC5ParameterSpec
从给定版本，圆数和字大小（以位为单位）构造RC5的参数集。
RC5ParameterSpec(int, int, int, byte[]) - Constructor for class javax.crypto.spec. RC5ParameterSpec
从给定版本，回合数，字大小（以位为单位）和IV构造RC5的参数集。
RC5ParameterSpec(int, int, int, byte[], int) - Constructor for class javax.crypto.spec. RC5ParameterSpec
从给定版本，回合数，字大小（以位为单位）和IV构造RC5的参数集。
RCDATA - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于RCDATA
RCSID - Static variable in class javax.swing.undo. StateEdit
过时的RCS版本身份。
RCSID - Static variable in interface javax.swing.undo. StateEditable
此类的资源ID。
Rdn - Class in javax.naming.ldap
该类表示相对可分辨名称或RDN，它是由 RFC 2253指定的专有名称的组成部分。
Rdn(String) - Constructor for class javax.naming.ldap. Rdn
从给定的字符串构造一个Rdn。
Rdn(String, Object) - Constructor for class javax.naming.ldap. Rdn
从给定的属性类型和值构造一个Rdn。
Rdn(Attributes) - Constructor for class javax.naming.ldap. Rdn
从给定的属性集构造一个Rdn。
Rdn(Rdn) - Constructor for class javax.naming.ldap. Rdn
从给定的 rdn构造一个Rdn。
reachabilityFence(Object) - Static method in class java.lang.ref. Reference
确保给定引用引用的对象仍然是strongly reachable ，而不管程序的任何先前的操作可能会导致对象变得不可访问; 因此，至少在调用此方法之后，引用的对象不能通过垃圾回收来回收。
read() - Method in class java.io. BufferedInputStream
见 read法 InputStream的一般合同。
read() - Method in class java.io. BufferedReader
读一个字符
read() - Method in class java.io. ByteArrayInputStream
从该输入流读取下一个数据字节。
read() - Method in class java.io. CharArrayReader
读一个字符
read() - Method in class java.io. FileInputStream
从该输入流读取一个字节的数据。
read() - Method in class java.io. FilterInputStream
从该输入流读取下一个数据字节。
read() - Method in class java.io. FilterReader
读一个字符
read() - Method in class java.io. InputStream
从输入流读取数据的下一个字节。
read() - Method in class java.io. InputStreamReader
读一个字符
read() - Method in class java.io. LineNumberInputStream
已过时。
从该输入流读取下一个数据字节。
read() - Method in class java.io. LineNumberReader
读一个字符
read() - Method in interface java.io. ObjectInput
读取一个字节的数据。
read() - Method in class java.io. ObjectInputStream
读取一个字节的数据。
read() - Method in class java.io. PipedInputStream
从这个管道输入流读取数据的下一个字节。
read() - Method in class java.io. PipedReader
从这个管道流读取下一个数据字符。
read() - Method in class java.io. PushbackInputStream
从该输入流读取下一个数据字节。
read() - Method in class java.io. PushbackReader
读一个字符
read() - Method in class java.io. RandomAccessFile
从该文件读取一个字节的数据。
read() - Method in class java.io. Reader
读一个字符
read() - Method in class java.io. SequenceInputStream
从该输入流读取下一个数据字节。
read() - Method in class java.io. StringBufferInputStream
已过时。
从该输入流读取下一个数据字节。
read() - Method in class java.io. StringReader
读一个字符
read() - Method in class java.security. DigestInputStream
读取一个字节，并更新消息摘要（如果摘要功能打开）。
read() - Method in class java.util.zip. CheckedInputStream
读一个字节。
read() - Method in class java.util.zip. DeflaterInputStream
从输入流读取一个字节的压缩数据。
read() - Method in class java.util.zip. InflaterInputStream
读取一个字节的未压缩数据。
read() - Method in class javax.crypto. CipherInputStream
从该输入流读取下一个数据字节。
read() - Method in class javax.imageio.stream. FileCacheImageInputStream
read() - Method in class javax.imageio.stream. FileCacheImageOutputStream
read() - Method in class javax.imageio.stream. FileImageInputStream
read() - Method in class javax.imageio.stream. FileImageOutputStream
read() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取一个字节，并将其作为0到255之间的整数返回。
read() - Method in class javax.imageio.stream. ImageInputStreamImpl
从流中读取一个字节，并将其作为 int返回0到255之间。
read() - Method in class javax.imageio.stream. MemoryCacheImageInputStream
read() - Method in class javax.imageio.stream. MemoryCacheImageOutputStream
read() - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件读取一个字节的数据。
read() - Method in class javax.sound.sampled. AudioInputStream
从音频输入流读取数据的下一个字节。
read() - Method in class javax.swing. ProgressMonitorInputStream
覆盖 FilterInputStream.read以便在读取后更新进度监视器。
read() - Method in class org.omg.CORBA.portable. InputStream
read(byte[]) - Method in class java.io. DataInputStream
从包含的输入流中读取一些字节数，并将它们存储到缓冲区数组 b 。
read(byte[]) - Method in class java.io. FileInputStream
从该输入流读取最多 b.length个字节的数据到字节数组。
read(byte[]) - Method in class java.io. FilterInputStream
从该输入流读取最多 b.length字节的数据为字节数组。
read(byte[]) - Method in class java.io. InputStream
从输入流中读取一些字节数，并将它们存储到缓冲区 b 。
read(byte[]) - Method in interface java.io. ObjectInput
读入一个字节数组。
read(byte[]) - Method in class java.io. RandomAccessFile
从该文件读取最多 b.length个字节的数据到一个字节数组。
read(byte[]) - Method in class javax.crypto. CipherInputStream
从这个输入流读取最多 b.length个字节的数据到字节数组。
read(byte[]) - Method in interface javax.imageio.stream. ImageInputStream
从流中读取最多 b.length个字节，并将其从索引0开始存储到 b 。
read(byte[]) - Method in class javax.imageio.stream. ImageInputStreamImpl
一个方便的方法，调用 read(b, 0, b.length) 。
read(byte[]) - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件读取最多 b.length个字节的数据到字节数组。
read(byte[]) - Method in class javax.sound.sampled. AudioInputStream
从音频输入流读取一些字节数，并将它们存储到缓冲器阵列 b 。
read(byte[]) - Method in class javax.swing. ProgressMonitorInputStream
覆盖 FilterInputStream.read以便在读取后更新进度监视器。
read(byte[], int, int) - Method in class java.io. BufferedInputStream
从给定的偏移开始，将字节输入流中的字节读入指定的字节数组。
read(byte[], int, int) - Method in class java.io. ByteArrayInputStream
从此输入流读取最多 len字节的数据到字节数组。
read(byte[], int, int) - Method in class java.io. DataInputStream
从包含的输入流读取最多 len个字节的数据为字节数组。
read(byte[], int, int) - Method in class java.io. FileInputStream
从该输入流读取最多 len字节的数据到字节数组。
read(byte[], int, int) - Method in class java.io. FilterInputStream
从该输入流读取最多 len个字节的数据到字节数组。
read(byte[], int, int) - Method in class java.io. InputStream
从输入流读取最多 len个字节的数据到字节数组。
read(byte[], int, int) - Method in class java.io. LineNumberInputStream
已过时。
从该输入流读取最多 len个字节的数据到一个字节数组。
read(byte[], int, int) - Method in interface java.io. ObjectInput
读入一个字节数组。
read(byte[], int, int) - Method in class java.io. ObjectInputStream
读入一个字节数组。
read(byte[], int, int) - Method in class java.io. PipedInputStream
从这个管道输入流读取最多 len个字节的数据到字节数组。
read(byte[], int, int) - Method in class java.io. PushbackInputStream
从该输入流读取最多 len字节的数据到字节数组。
read(byte[], int, int) - Method in class java.io. RandomAccessFile
从该文件读取最多 len字节的数据到一个字节数组。
read(byte[], int, int) - Method in class java.io. SequenceInputStream
从此输入流读取最多 len个字节的数据到字节数组。
read(byte[], int, int) - Method in class java.io. StringBufferInputStream
已过时。
从该输入流读取最多 len个字节的数据到一个字节数组。
read(byte[], int, int) - Method in class java.security. DigestInputStream
读取一个字节数组，并更新消息摘要（如果摘要功能打开）。
read(byte[], int, int) - Method in class java.util.jar. JarInputStream
从当前的JAR文件条目读入一个字节数组。
read(byte[], int, int) - Method in class java.util.zip. CheckedInputStream
读入一个字节数组。
read(byte[], int, int) - Method in class java.util.zip. DeflaterInputStream
将压缩数据读入字节数组。
read(byte[], int, int) - Method in class java.util.zip. GZIPInputStream
将未压缩的数据读入字节数组。
read(byte[], int, int) - Method in class java.util.zip. InflaterInputStream
将未压缩的数据读入字节数组。
read(byte[], int, int) - Method in class java.util.zip. ZipInputStream
从当前ZIP条目读取到字节数组。
read(byte[], int, int) - Method in class javax.crypto. CipherInputStream
从该输入流读取最多 len个字节的数据为字节数组。
read(byte[], int, int) - Method in class javax.imageio.stream. FileCacheImageInputStream
read(byte[], int, int) - Method in class javax.imageio.stream. FileCacheImageOutputStream
read(byte[], int, int) - Method in class javax.imageio.stream. FileImageInputStream
read(byte[], int, int) - Method in class javax.imageio.stream. FileImageOutputStream
read(byte[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
读取到 len从流字节，并将其存储到 b开始于索引 off 。
read(byte[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
读取到 len从流字节，并将其存储到 b开始于索引 off 。
read(byte[], int, int) - Method in class javax.imageio.stream. MemoryCacheImageInputStream
read(byte[], int, int) - Method in class javax.imageio.stream. MemoryCacheImageOutputStream
read(byte[], int, int) - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件读取最多 len个字节的数据到字节数组。
read(byte[], int, int) - Method in class javax.sound.sampled. AudioInputStream
从音频流读取指定的最大数据字节数，将它们放入给定的字节数组。
read(byte[], int, int) - Method in interface javax.sound.sampled. TargetDataLine
从数据线的输入缓冲区读取音频数据。
read(byte[], int, int) - Method in class javax.swing. ProgressMonitorInputStream
覆盖 FilterInputStream.read以便在读取后更新进度监视器。
read(char[]) - Method in class java.io. Reader
将字符读入数组。
read(char[], int, int) - Method in class java.io. BufferedReader
将字符读入数组的一部分。
read(char[], int, int) - Method in class java.io. CharArrayReader
将字符读入数组的一部分。
read(char[], int, int) - Method in class java.io. FilterReader
将字符读入数组的一部分。
read(char[], int, int) - Method in class java.io. InputStreamReader
将字符读入数组的一部分。
read(char[], int, int) - Method in class java.io. LineNumberReader
将字符读入数组的一部分。
read(char[], int, int) - Method in class java.io. PipedReader
从此管道流读取最多 len字符的字符数组。
read(char[], int, int) - Method in class java.io. PushbackReader
将字符读入数组的一部分。
read(char[], int, int) - Method in class java.io. Reader
将字符读入数组的一部分。
read(char[], int, int) - Method in class java.io. StringReader
将字符读入数组的一部分。
read(char[], int, int) - Method in class jdk.nashorn.api.scripting. URLReader
read(int) - Method in class javax.imageio. ImageReader
读取由 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用默认值 ImageReadParam 。
read(int, ImageReadParam) - Method in class javax.imageio. ImageReader
读取由 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用附带的 ImageReadParam 。
read(DataInput) - Static method in class java.rmi.server. UID
构造并返回一个新的 UID实例，通过从 DataInput实例解组二进制表示。
read(DataInputStream) - Method in class javax.swing.text.html.parser. DTD
从归档格式重新创建DTD。
read(File) - Static method in class javax.imageio. ImageIO
作为对所提供的 File进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
read(InputStream) - Static method in class java.lang.module. ModuleDescriptor
从输入流读取模块声明的二进制形式作为模块描述符。
read(InputStream) - Method in class java.util.jar. Manifest
从指定的InputStream读取清单。
read(InputStream) - Static method in class javax.imageio. ImageIO
作为对所提供的 InputStream进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
read(InputStream, Object) - Method in class javax.swing. JEditorPane
此方法从流初始化。
read(InputStream, Supplier<Set<String>>) - Static method in class java.lang.module. ModuleDescriptor
从输入流读取模块声明的二进制形式作为模块描述符。
read(InputStream, Document, int) - Method in class javax.swing.text. DefaultEditorKit
插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
read(InputStream, Document, int) - Method in class javax.swing.text. EditorKit
插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
read(InputStream, Document, int) - Method in class javax.swing.text.rtf. RTFEditorKit
从给定的流中插入内容，该内容预期为适合此类内容处理程序的格式。
read(ObjectInput) - Static method in class java.rmi.server. ObjID
构造并返回一个新 ObjID通过从解组二进制表示实例 ObjectInput实例。
read(Reader, Object) - Method in class javax.swing.text. JTextComponent
从流初始化。
read(Reader, Document, int) - Method in class javax.swing.text. DefaultEditorKit
插入来自给定流的内容，将被视为纯文本。
read(Reader, Document, int) - Method in class javax.swing.text. EditorKit
插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
read(Reader, Document, int) - Method in class javax.swing.text.html. HTMLEditorKit
从给定的流插入内容。
read(Reader, Document, int) - Method in class javax.swing.text.rtf. RTFEditorKit
从给定的流中插入内容，将被视为纯文本。
read(String) - Method in interface java.lang.module. ModuleReader
读取资源，返回一个具有资源内容的字节缓冲区。
read(String, ByteBuffer) - Method in interface java.nio.file.attribute. UserDefinedFileAttributeView
将用户定义属性的值读入缓冲区。
read(URL) - Static method in class javax.imageio. ImageIO
作为对所提供的 URL进行解码的结果，返回 BufferedImage ，其中自动从当前注册的 ImageReader选择。
read(ByteBuffer) - Static method in class java.lang.module. ModuleDescriptor
从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
read(ByteBuffer) - Method in interface java.nio.channels. AsynchronousByteChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer) - Method in class java.nio.channels. AsynchronousSocketChannel
read(ByteBuffer) - Method in class java.nio.channels. DatagramChannel
从此频道读取数据报。
read(ByteBuffer) - Method in class java.nio.channels. FileChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer) - Method in interface java.nio.channels. ReadableByteChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer) - Method in interface java.nio.channels. SeekableByteChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer) - Method in class java.nio.channels. SocketChannel
read(ByteBuffer[]) - Method in class java.nio.channels. DatagramChannel
从此频道读取数据报。
read(ByteBuffer[]) - Method in class java.nio.channels. FileChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer[]) - Method in interface java.nio.channels. ScatteringByteChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer[]) - Method in class java.nio.channels. SocketChannel
read(ByteBuffer[], int, int) - Method in class java.nio.channels. DatagramChannel
从此频道读取数据报。
read(ByteBuffer[], int, int) - Method in class java.nio.channels. FileChannel
从该通道读取字节序列到给定缓冲区的子序列中。
read(ByteBuffer[], int, int) - Method in interface java.nio.channels. ScatteringByteChannel
从该通道读取字节序列到给定缓冲区的子序列中。
read(ByteBuffer[], int, int) - Method in class java.nio.channels. SocketChannel
read(ByteBuffer[], int, int, long, TimeUnit, A, CompletionHandler<Long, ? super A>) - Method in class java.nio.channels. AsynchronousSocketChannel
从该通道读取字节序列到给定缓冲区的子序列中。
read(ByteBuffer, long) - Method in class java.nio.channels. AsynchronousFileChannel
从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
read(ByteBuffer, long) - Method in class java.nio.channels. FileChannel
从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
read(ByteBuffer, long, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels. AsynchronousFileChannel
从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
read(ByteBuffer, long, TimeUnit, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels. AsynchronousSocketChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in interface java.nio.channels. AsynchronousByteChannel
从该通道读取到给定缓冲区的字节序列。
read(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels. AsynchronousSocketChannel
read(ByteBuffer, Supplier<Set<String>>) - Static method in class java.lang.module. ModuleDescriptor
从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
read(CharBuffer) - Method in class java.io. Reader
尝试将字符读入指定的字符缓冲区。
read(CharBuffer) - Method in interface java.lang. Readable
尝试将字符读入指定的字符缓冲区。
read(CharBuffer) - Method in class java.nio. CharBuffer
尝试将字符读入指定的字符缓冲区。
read(ImageInputStream) - Static method in class javax.imageio. ImageIO
作为对所提供的 ImageInputStream进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
read(InputStream) - Static method in class org.omg.CORBA. AnySeqHelper
read(InputStream) - Static method in class org.omg.CORBA. BooleanSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. BoundsHelper
read(InputStream) - Static method in class org.omg.CORBA. CharSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. CompletionStatusHelper
read(InputStream) - Static method in class org.omg.CORBA. CurrentHelper
read(InputStream) - Static method in class org.omg.CORBA. DefinitionKindHelper
read(InputStream) - Static method in class org.omg.CORBA. DoubleSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. FieldNameHelper
read(InputStream) - Static method in class org.omg.CORBA. FloatSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. IdentifierHelper
read(InputStream) - Static method in class org.omg.CORBA. IDLTypeHelper
read(InputStream) - Static method in class org.omg.CORBA. LongLongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. LongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. NameValuePairHelper
read(InputStream) - Static method in class org.omg.CORBA. ObjectHelper
read(InputStream) - Static method in class org.omg.CORBA. OctetSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.ORBPackage. InvalidNameHelper
read(InputStream) - Static method in class org.omg.CORBA. ParameterModeHelper
read(InputStream) - Static method in class org.omg.CORBA. PolicyErrorCodeHelper
read(InputStream) - Static method in class org.omg.CORBA. PolicyErrorHelper
read(InputStream) - Static method in class org.omg.CORBA. PolicyHelper
read(InputStream) - Static method in class org.omg.CORBA. PolicyListHelper
read(InputStream) - Static method in class org.omg.CORBA. PolicyTypeHelper
read(InputStream) - Static method in class org.omg.CORBA. RepositoryIdHelper
read(InputStream) - Static method in class org.omg.CORBA. ServiceDetailHelper
read(InputStream) - Static method in class org.omg.CORBA. ServiceInformationHelper
read(InputStream) - Static method in class org.omg.CORBA. SetOverrideTypeHelper
read(InputStream) - Static method in class org.omg.CORBA. ShortSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. StringSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. StringValueHelper
read(InputStream) - Static method in class org.omg.CORBA. StructMemberHelper
read(InputStream) - Static method in class org.omg.CORBA.TypeCodePackage. BadKindHelper
read(InputStream) - Static method in class org.omg.CORBA.TypeCodePackage. BoundsHelper
read(InputStream) - Static method in class org.omg.CORBA. ULongLongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. ULongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. UnionMemberHelper
read(InputStream) - Static method in class org.omg.CORBA. UnknownUserExceptionHelper
read(InputStream) - Static method in class org.omg.CORBA. UShortSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. ValueBaseHelper
read(InputStream) - Static method in class org.omg.CORBA. ValueMemberHelper
read(InputStream) - Static method in class org.omg.CORBA. VersionSpecHelper
read(InputStream) - Static method in class org.omg.CORBA. VisibilityHelper
read(InputStream) - Static method in class org.omg.CORBA. WCharSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. WrongTransactionHelper
read(InputStream) - Static method in class org.omg.CORBA. WStringSeqHelper
read(InputStream) - Static method in class org.omg.CORBA. WStringValueHelper
read(InputStream) - Static method in class org.omg.CosNaming. BindingHelper
read(InputStream) - Static method in class org.omg.CosNaming. BindingIteratorHelper
read(InputStream) - Static method in class org.omg.CosNaming. BindingListHelper
read(InputStream) - Static method in class org.omg.CosNaming. BindingTypeHelper
read(InputStream) - Static method in class org.omg.CosNaming. IstringHelper
read(InputStream) - Static method in class org.omg.CosNaming. NameComponentHelper
read(InputStream) - Static method in class org.omg.CosNaming. NameHelper
read(InputStream) - Static method in class org.omg.CosNaming. NamingContextExtHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage. AddressHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage. StringNameHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage. URLStringHelper
read(InputStream) - Static method in class org.omg.CosNaming. NamingContextHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHelper
read(InputStream) - Static method in class org.omg.DynamicAny. AnySeqHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCodeHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynAnyHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyPackage. InvalidValueHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyPackage. TypeMismatchHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynAnySeqHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynArrayHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynEnumHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynFixedHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynSequenceHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynStructHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynUnionHelper
read(InputStream) - Static method in class org.omg.DynamicAny. DynValueHelper
read(InputStream) - Static method in class org.omg.DynamicAny. FieldNameHelper
read(InputStream) - Static method in class org.omg.DynamicAny. NameDynAnyPairHelper
read(InputStream) - Static method in class org.omg.DynamicAny. NameDynAnyPairSeqHelper
read(InputStream) - Static method in class org.omg.DynamicAny. NameValuePairHelper
read(InputStream) - Static method in class org.omg.DynamicAny. NameValuePairSeqHelper
read(InputStream) - Static method in class org.omg.IOP. CodecFactoryHelper
read(InputStream) - Static method in class org.omg.IOP.CodecFactoryPackage. UnknownEncodingHelper
read(InputStream) - Static method in class org.omg.IOP.CodecPackage. FormatMismatchHelper
read(InputStream) - Static method in class org.omg.IOP.CodecPackage. InvalidTypeForEncodingHelper
read(InputStream) - Static method in class org.omg.IOP.CodecPackage. TypeMismatchHelper
read(InputStream) - Static method in class org.omg.IOP. ComponentIdHelper
read(InputStream) - Static method in class org.omg.IOP. IORHelper
read(InputStream) - Static method in class org.omg.IOP. MultipleComponentProfileHelper
read(InputStream) - Static method in class org.omg.IOP. ProfileIdHelper
read(InputStream) - Static method in class org.omg.IOP. ServiceContextHelper
read(InputStream) - Static method in class org.omg.IOP. ServiceContextListHelper
read(InputStream) - Static method in class org.omg.IOP. ServiceIdHelper
read(InputStream) - Static method in class org.omg.IOP. TaggedComponentHelper
read(InputStream) - Static method in class org.omg.IOP. TaggedProfileHelper
read(InputStream) - Static method in class org.omg.Messaging. SyncScopeHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. AdapterManagerIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. AdapterNameHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. AdapterStateHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. CurrentHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. ForwardRequestHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. InvalidSlotHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper
read(InputStream) - Static method in class org.omg.PortableInterceptor. ObjectIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. ORBIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateNameHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidNameHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. ObjectIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor. ServerIdHelper
read(InputStream) - Static method in class org.omg.PortableServer. CurrentHelper
read(InputStream) - Static method in class org.omg.PortableServer.CurrentPackage. NoContextHelper
read(InputStream) - Static method in class org.omg.PortableServer. ForwardRequestHelper
read(InputStream) - Static method in class org.omg.PortableServer. POAHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAManagerPackage. AdapterInactiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. AdapterAlreadyExistsHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. AdapterNonExistentHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. InvalidPolicyHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. NoServantHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. ObjectAlreadyActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. ObjectNotActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. ServantAlreadyActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. ServantNotActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. WrongAdapterHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage. WrongPolicyHelper
read(InputStream) - Static method in class org.omg.PortableServer. ServantActivatorHelper
read(InputStream) - Static method in class org.omg.PortableServer. ServantLocatorHelper
READ - java.lang. ProcessBuilder.Redirect.Type
从 Redirect.from(File)返回的重定向类型。
READ - java.nio.file. AccessMode
测试读取访问。
READ - java.nio.file. StandardOpenOption
打开阅读权限。
read_Abstract() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL抽象界面。
read_abstract_interface() - Method in class org.omg.CORBA_2_3.portable. InputStream
解组数值对象或合适的存根对象。
read_abstract_interface(Class) - Method in class org.omg.CORBA_2_3.portable. InputStream
解组对应于传递类型的类对象或存根类。
READ_ACL - java.nio.file.attribute. AclEntryPermission
读取ACL属性的权限。
read_any() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL Any值。
read_any() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取任何一个。
read_any_array(AnySeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流的长度元素的偏移量读取IDL Anys的数组。
READ_ATTRIBUTES - java.nio.file.attribute. AclEntryPermission
读取（非acl）文件属性的能力。
read_boolean() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL布尔值。
read_boolean() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取布尔值。
read_boolean_array(boolean[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一组布尔值。
read_boolean_array(BooleanSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流的长度元素的偏移量读取IDL布尔数组。
read_char() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL字符值。
read_char() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个字符值。
read_char_array(char[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从这个输入流读取一个字符数组。
read_char_array(CharSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流的长度元素的偏移量读取IDL字符数组。
read_Context() - Method in class org.omg.CORBA.portable. InputStream
从流中读取CORBA上下文。
READ_DATA - java.nio.file.attribute. AclEntryPermission
读取文件数据的权限。
read_double() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL double。
read_double() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个双重值。
read_double_array(double[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一组双精度数据。
read_double_array(DoubleSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流读取长度元素的偏移量的IDL二进制数组。
read_fixed() - Method in class org.omg.CORBA.portable. InputStream
读取一个BigDecimal数字。
read_float() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL浮点数。
read_float() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取浮点值。
read_float_array(float[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一组浮点数。
read_float_array(FloatSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流中读取长度元素的偏移量的IDL浮点数组。
read_long() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL长。
read_long() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个CORBA长（即Java int）值。
read_long_array(int[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从该输入流读取一个CORBA longs（即Java int）数组。
read_long_array(LongSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流的长度元素的偏移量读取IDL长整数。
read_longlong() - Method in interface org.omg.CORBA. DataInputStream
从输入流中读取IDL长。
read_longlong() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个CORBA longlong（即Java long）值。
read_longlong_array(long[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一系列CORBA longlong（即Java longs）。
read_longlong_array(LongLongSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流读取长度元素的偏移量的IDL长整型数组。
READ_NAMED_ATTRS - java.nio.file.attribute. AclEntryPermission
读取文件的命名属性的权限。
read_Object() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL CORBA :: Object。
read_Object() - Method in class org.omg.CORBA.portable. InputStream
从该输入流读取CORBA对象。
read_Object(Class) - Method in class org.omg.CORBA.portable. InputStream
解组合对象并返回CORBA对象，该对象是作为参数传递的类的实例。
read_octet() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL八位字节值。
read_octet() - Method in class org.omg.CORBA.portable. InputStream
从该输入流读取一个八位字节（即一个字节）值。
read_octet_array(byte[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个八位字节数组（即字节）。
read_octet_array(OctetSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流读取长度元素的偏移量的IDL八位字节数组。
READ_ONLY - Static variable in class java.nio.channels. FileChannel.MapMode
只读映射的模式。
read_Principal() - Method in class org.omg.CORBA.portable. InputStream
已过时。
被CORBA弃用2.2。
read_short() - Method in interface org.omg.CORBA. DataInputStream
从输入流中读取IDL短。
read_short() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个较短的值。
read_short_array(short[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一组短裤。
read_short_array(ShortSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流读取长度元素的偏移量的IDL短路数组。
read_string() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL字符串。
read_string() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取字符串值。
read_TypeCode() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL类型代码。
read_TypeCode() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个 TypeCode 。
read_ulong() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL unsigned long。
read_ulong() - Method in class org.omg.CORBA.portable. InputStream
从该输入流读取一个无符号CORBA long（即Java int）值。
read_ulong_array(int[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个无符号CORBA longs（即Java ints）数组。
read_ulong_array(ULongSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流中读取长度元素的偏移量的IDL无符号长整数的数组。
read_ulonglong() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取长度为无符号的IDL。
read_ulonglong() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取CORBA无符号long long（即Java long）值。
read_ulonglong_array(long[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一系列无符号CORBA longlong（即Java longs）。
read_ulonglong_array(ULongLongSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流读取长度元素的偏移量的IDL无符号长整型数组。
read_ushort() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL无符号短。
read_ushort() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取无符号的短值。
read_ushort_array(short[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取无符号短整数组。
read_ushort_array(UShortSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流读取长度元素的偏移量的IDL无符号短整型数组。
read_value() - Method in class org.omg.CORBA_2_3.portable. InputStream
从输入流解组值类型。
read_value(Serializable) - Method in class org.omg.CORBA_2_3.portable. InputStream
从输入流解组值类型。
read_value(Class) - Method in class org.omg.CORBA_2_3.portable. InputStream
从输入流解组值类型。
read_value(String) - Method in class org.omg.CORBA_2_3.portable. InputStream
从输入流解组值类型。
read_value(InputStream) - Method in interface org.omg.CORBA.portable. ValueFactory
在解组数值类型的过程中，由ORB运行时调用。
read_value(BoxedValueHelper) - Method in class org.omg.CORBA_2_3.portable. InputStream
从输入流解组值类型。
read_value(InputStream) - Method in interface org.omg.CORBA.portable. BoxedValueHelper
read_value(InputStream) - Method in class org.omg.CORBA. StringValueHelper
read_value(InputStream) - Method in class org.omg.CORBA. WStringValueHelper
read_value(InputStream, TypeCode) - Method in class org.omg.CORBA. Any
使用给定的类型代码从给定的输入流中读取（解组）一个 Any对象的值。
read_Value() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL值类型。
read_wchar() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL宽字符值。
read_wchar() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个宽的char值。
read_wchar_array(char[], int, int) - Method in class org.omg.CORBA.portable. InputStream
从这个输入流读取一个宽字符数组。
read_wchar_array(WCharSeqHolder, int, int) - Method in interface org.omg.CORBA. DataInputStream
从输入流的长度元素的偏移量读取IDL宽字符的数组。
READ_WRITE - Static variable in class java.nio.channels. FileChannel.MapMode
读/写映射模式。
read_wstring() - Method in interface org.omg.CORBA. DataInputStream
从输入流读取IDL宽字符串。
read_wstring() - Method in class org.omg.CORBA.portable. InputStream
从此输入流读取一个宽字符串值。
Readable - Interface in java.lang
A Readable是字符源。
ReadableByteChannel - Interface in java.nio.channels
一个可以读取字节的通道。
readAborted(ImageReader) - Method in interface javax.imageio.event. IIOReadProgressListener
通过阅读器的 abort方法报告读取已被中止。
readAll(int, ImageReadParam) - Method in class javax.imageio. ImageReader
读取由索引的图像 imageIndex并返回一个 IIOImage包含图像，缩略图和相关联的图像元数据，使用所提供的 ImageReadParam 。
readAll(Iterator<? extends ImageReadParam>) - Method in class javax.imageio. ImageReader
返回 Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在 getMinIndex ，从形式的输入源 IIOImage对象。
readAllBytes() - Method in class java.io. InputStream
从输入流读取所有剩余字节。
readAllBytes(Path) - Static method in class java.nio.file. Files
读取文件中的所有字节。
readAllLines(Path) - Static method in class java.nio.file. Files
从文件中读取所有行。
readAllLines(Path, Charset) - Static method in class java.nio.file. Files
从文件中读取所有行。
readAny(InputStream) - Static method in class javax.rmi.CORBA. Util
将java.lang.Object读取为任何CORBA。
readAny(InputStream) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.readAny(org.omg.CORBA.portable.InputStream) 。
readArray() - Method in interface java.sql. SQLInput
从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
readArray() - Method in class javax.sql.rowset.serial. SQLInputImpl
从流中读取SQL ARRAY值，并将其作为Java编程语言中的 Array对象返回。
readAsciiStream() - Method in interface java.sql. SQLInput
读取流中的下一个属性并将其作为ASCII字符流返回。
readAsciiStream() - Method in class javax.sql.rowset.serial. SQLInputImpl
将此 SQLInputImpl对象中的下一个属性作为ASCII字符流返回。
readAsRenderedImage(int, ImageReadParam) - Method in class javax.imageio. ImageReader
返回一个 RenderedImage对象，其中包含由 imageIndex索引的图像的内容。
readAttributes() - Method in interface java.nio.file.attribute. BasicFileAttributeView
读取大量操作的基本文件属性。
readAttributes() - Method in interface java.nio.file.attribute. DosFileAttributeView
readAttributes() - Method in interface java.nio.file.attribute. PosixFileAttributeView
readAttributes(ObjectInputStream, MutableAttributeSet) - Method in class javax.swing.text. StyleContext
属性中阅读的上下文特定处理
readAttributes(Path, Class<A>, LinkOption...) - Static method in class java.nio.file. Files
读取文件的属性作为批量操作。
readAttributes(Path, Class<A>, LinkOption...) - Method in class java.nio.file.spi. FileSystemProvider
读取文件的属性作为批量操作。
readAttributes(Path, String, LinkOption...) - Static method in class java.nio.file. Files
读取一组文件属性作为批量操作。
readAttributes(Path, String, LinkOption...) - Method in class java.nio.file.spi. FileSystemProvider
读取一组文件属性作为批量操作。
readAttributeSet(ObjectInputStream, MutableAttributeSet) - Static method in class javax.swing.text. StyleContext
从给定的对象输入流读取一组属性，这些属性先前已经用 writeAttributeSet 。
readBigDecimal() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的一个 java.math.BigDecimal对象返回。
readBigDecimal() - Method in class javax.sql.rowset.serial. SQLInputImpl
检索 SQLInputImpl对象中的下一个属性为 java.math.BigDecimal 。
readBinary(DataInputStream) - Static method in class javafx.css. StyleConverter.StringStore
readBinary(DataInputStream, String[]) - Static method in class javafx.css.converter. EnumConverter
readBinary(DataInputStream, String[]) - Static method in class javafx.css. StyleConverter
读取二进制数据流。
readBinaryStream() - Method in interface java.sql. SQLInput
读取流中的下一个属性并将其作为未解释的字节流返回。
readBinaryStream() - Method in class javax.sql.rowset.serial. SQLInputImpl
将此 SQLInputImpl对象中的下一个属性返回为未解释的字节流。
readBit() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取一位，并将其作为 int返回，值为 0或 1 。
readBit() - Method in class javax.imageio.stream. ImageInputStreamImpl
readBits(int) - Method in interface javax.imageio.stream. ImageInputStream
从流读取一个bitstring，并将其作为 long返回，第一位读取成为输出的最高有效位。
readBits(int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readBlob() - Method in interface java.sql. SQLInput
从流中读取SQL BLOB值，并将其作为Java编程语言中的 Blob对象返回。
readBlob() - Method in class javax.sql.rowset.serial. SQLInputImpl
以 SQLInputImpl对象作为Java编程语言中的一个 Blob对象 BLOB值。
readBoolean() - Method in interface java.io. DataInput
读取一个输入字节，并返回 true如果该字节不为零， false如果该字节是零。
readBoolean() - Method in class java.io. DataInputStream
见 readBoolean方法的一般合同 DataInput 。
readBoolean() - Method in class java.io. ObjectInputStream
读取布尔值。
readBoolean() - Method in class java.io. RandomAccessFile
从此文件读取一个 boolean 。
readBoolean() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 boolean返回。
readBoolean() - Method in interface javax.imageio.stream. ImageInputStream
从该流读取一个字节，并返回一个 boolean的值 true ，如果它是非零， false ，如果它是零。
readBoolean() - Method in class javax.imageio.stream. ImageInputStreamImpl
readBoolean() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件读取一个 boolean 。
readBoolean() - Method in class javax.sql.rowset.serial. SQLInputImpl
获取此的下一个属性 SQLInputImpl对象为 boolean的Java编程语言。
readByte() - Method in interface java.io. DataInput
读取并返回一个输入字节。
readByte() - Method in class java.io. DataInputStream
见的总承包 readByte的方法 DataInput 。
readByte() - Method in class java.io. ObjectInputStream
读取一个8位字节。
readByte() - Method in class java.io. RandomAccessFile
从此文件中读取一个带符号的八位值。
readByte() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 byte返回。
readByte() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取一个字节，并将其作为 byte值返回。
readByte() - Method in class javax.imageio.stream. ImageInputStreamImpl
readByte() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件中读取一个带符号的八位值。
readByte() - Method in class javax.sql.rowset.serial. SQLInputImpl
将这个 SQLInputImpl对象中的下一个属性作为Java编程语言中的一个 byte进行检索。
readBytes() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的字节数组返回。
readBytes() - Method in class javax.sql.rowset.serial. SQLInputImpl
将此 SQLInputImpl对象中的下一个属性作为字节数组检索。
readBytes(IIOByteBuffer, int) - Method in interface javax.imageio.stream. ImageInputStream
从流中读取最多 len个字节，并修改提供的 IIOByteBuffer以指示可能找到数据的字节数组，偏移量和长度。
readBytes(IIOByteBuffer, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readChar() - Method in interface java.io. DataInput
读取两个输入字节并返回一个 char值。
readChar() - Method in class java.io. DataInputStream
见 readChar方法的一般合同 DataInput 。
readChar() - Method in class java.io. ObjectInputStream
读一个16位字符。
readChar() - Method in class java.io. RandomAccessFile
从此文件中读取一个字符。
readChar() - Method in interface javax.imageio.stream. ImageInputStream
相当于 readUnsignedShort ，除了使用 char数据类型返回结果。
readChar() - Method in class javax.imageio.stream. ImageInputStreamImpl
readChar() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件中读取Unicode字符。
readCharacterStream() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Unicode字符流返回。
readCharacterStream() - Method in class javax.sql.rowset.serial. SQLInputImpl
将此 SQLInputImpl对象中的下一个属性作为Unicode字符流检索。
readChildren(ObjectInputStream) - Method in class java.beans.beancontext. BeanContextSupport
当这个类的实例被用作实现BeanContext协议（及其子协议）的委托时，在反序列化期间存在一个'鸡和蛋'问题
readClassDescriptor() - Method in class java.io. ObjectInputStream
从序列化流读取类描述符。
readClob() - Method in interface java.sql. SQLInput
从流中读取SQL CLOB值，并将其作为Java编程语言中的 Clob对象返回。
readClob() - Method in class javax.sql.rowset.serial. SQLInputImpl
以这种 SQLInputImpl对象作为 Clob对象的Java编程语言 CLOB值。
readComment(String) - Method in interface javafx.fxml. LoadListener
当加载程序读取注释时调用。
readConfiguration() - Method in class java.util.logging. LogManager
读取并初始化日志记录配置。
readConfiguration(InputStream) - Method in class java.util.logging. LogManager
从给定的输入流读取和初始化日志记录配置。
readData(RowSetInternal) - Method in interface javax.sql. RowSetReader
读取调用 RowSet对象的新内容。
readDate() - Method in interface java.sql. SQLInput
读取流中的下一个属性并将其作为 java.sql.Date对象返回。
readDate() - Method in class javax.sql.rowset.serial. SQLInputImpl
检索此 SQLInputImpl的下一个属性为 java.sql.Date对象。
readDouble() - Method in interface java.io. DataInput
读取八个输入字节并返回一个 double值。
readDouble() - Method in class java.io. DataInputStream
见 readDouble法 DataInput的一般合同。
readDouble() - Method in class java.io. ObjectInputStream
读64位双倍。
readDouble() - Method in class java.io. RandomAccessFile
从此文件读取一个 double 。
readDouble() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 double返回。
readDouble() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 double返回。
readDouble() - Method in class javax.imageio.stream. ImageInputStreamImpl
readDouble() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件读取一个 double 。
readDouble() - Method in class javax.sql.rowset.serial. SQLInputImpl
检索此 SQLInputImpl对象中的下一个属性，作为Java编程语言中的一个 double 。
readEndpointReference(Source) - Method in class javax.xml.ws.spi. Provider
从 eprInfoset包含的信息集读取一个EndpointReference。
reader - Variable in class javax.script. SimpleScriptContext
这是用于从脚本输入的读者。
reader() - Method in class java.io. Console
检索与此控制台关联的唯一的Reader对象。
Reader - Class in java.io
用于读取字符流的抽象类。
Reader() - Constructor for class java.io. Reader
创建一个新的字符流阅读器，其关键部分将在阅读器本身上同步。
Reader(Object) - Constructor for class java.io. Reader
创建一个新的字符流阅读器，其关键部分将在给定对象上同步。
READER(String) - Constructor for class javax.print. DocFlavor.READER
使用给定的MIME类型和打印数据表示类名称\ * "java.io.Reader" （字符流）构造新的文档风格。
readerSpiNames - Variable in class javax.imageio.spi. ImageWriterSpi
要从 getImageReaderSpiNames返回的字符串数组，最初为 null 。
readerSupportsThumbnails() - Method in class javax.imageio. ImageReader
如果此阅读器理解的图像格式支持与其关联的缩略图预览图像，则返回 true 。
readEventHandlerAttribute(String, String) - Method in interface javafx.fxml. LoadListener
当加载程序读取事件处理程序属性时调用。
readExternal(ObjectInput) - Method in class java.awt.datatransfer. DataFlavor
从序列化状态恢复此 DataFlavor 。
readExternal(ObjectInput) - Method in interface java.io. Externalizable
该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。
readExternal(ObjectInput) - Method in class javax.activation. MimeType
该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。
readExternal(ObjectInput) - Method in class javax.management.loading. MLet
从给定的ObjectInput恢复此MLet的内容。
readFields() - Method in class java.io. ObjectInputStream
从流中读取持久性字段，并通过名称使其可用。
readFloat() - Method in interface java.io. DataInput
读取四个输入字节并返回一个 float值。
readFloat() - Method in class java.io. DataInputStream
见 readFloat法 DataInput的一般合同。
readFloat() - Method in class java.io. ObjectInputStream
读32位浮点数。
readFloat() - Method in class java.io. RandomAccessFile
从此文件读取一个 float 。
readFloat() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 float返回。
readFloat() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 float返回。
readFloat() - Method in class javax.imageio.stream. ImageInputStreamImpl
readFloat() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件读取一个 float 。
readFloat() - Method in class javax.sql.rowset.serial. SQLInputImpl
获取此的下一个属性 SQLInputImpl对象为 float的Java编程语言。
readFrom(Source) - Static method in class javax.xml.ws. EndpointReference
从 eprInfoset包含的信息集读取EndpointReference的工厂方法。
readFully(byte[]) - Method in interface java.io. DataInput
从输入流读取一些字节，并将它们存储到缓冲区 b 。
readFully(byte[]) - Method in class java.io. DataInputStream
见 readFully方法 DataInput的一般合同。
readFully(byte[]) - Method in class java.io. ObjectInputStream
读取字节，阻塞直到读取所有字节。
readFully(byte[]) - Method in class java.io. RandomAccessFile
从该文件读取 b.length个字节到字节数组，从当前文件指针开始。
readFully(byte[]) - Method in interface javax.imageio.stream. ImageInputStream
从流中读取 b.length个字节，并将其从索引 0为 b开始存储到 0 。
readFully(byte[]) - Method in class javax.imageio.stream. ImageInputStreamImpl
readFully(byte[]) - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件读取 b.length个字节到字节数组，从当前文件指针开始。
readFully(byte[], int, int) - Method in interface java.io. DataInput
从输入流读取 len个字节。
readFully(byte[], int, int) - Method in class java.io. DataInputStream
见 readFully方法的一般合同 DataInput 。
readFully(byte[], int, int) - Method in class java.io. ObjectInputStream
读取字节，阻塞直到读取所有字节。
readFully(byte[], int, int) - Method in class java.io. RandomAccessFile
从当前文件指针开始，从该文件读取完整的 len个字节到字节数组中。
readFully(byte[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
读取 len从流字节，并将其存储到 b开始于索引 off 。
readFully(byte[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readFully(byte[], int, int) - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件读取完整的 len字节到字节数组，从当前文件指针开始。
readFully(char[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
读取 len从根据当前字节顺序的流字符（无符号的16位整数），并将其存储到 c开始于索引 off 。
readFully(char[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readFully(double[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
读取 len根据当前字节顺序从流中双精度（64位IEEE双精度浮点数），并将其从索引 off为 d开始存储到 off 。
readFully(double[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readFully(float[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
读取 len根据当前字节顺序从流浮标（32位IEEE单精度浮点值），并且将它们存储到 f开始于索引 off 。
readFully(float[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readFully(int[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
根据当前字节顺序从流中读取 len int（带符号的32位整数），并从索引 off为 i开始存储到 off 。
readFully(int[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readFully(long[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
读取 len从根据当前字节顺序的流long（有符号的64位整数），并将其存储到 l开始于索引 off 。
readFully(long[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readFully(short[], int, int) - Method in interface javax.imageio.stream. ImageInputStream
读取 len从根据当前字节顺序的流短裤（带符号的16位整数），并将其存储到 s开始于索引 off 。
readFully(short[], int, int) - Method in class javax.imageio.stream. ImageInputStreamImpl
readImportProcessingInstruction(String) - Method in interface javafx.fxml. LoadListener
当加载程序读取导入处理指令时调用。
READING - Static variable in class java.text. AttributedCharacterIterator.Attribute
用于阅读某些文本的属性键。
readInt() - Method in interface java.io. DataInput
读取四个输入字节并返回一个 int值。
readInt() - Method in class java.io. DataInputStream
见 readInt法 DataInput的一般合同。
readInt() - Method in class java.io. ObjectInputStream
读取一个32位int。
readInt() - Method in class java.io. RandomAccessFile
从该文件读取一个带符号的32位整数。
readInt() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 int返回。
readInt() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 int返回。
readInt() - Method in class javax.imageio.stream. ImageInputStreamImpl
readInt() - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件读取一个带符号的32位整数。
readInt() - Method in class javax.sql.rowset.serial. SQLInputImpl
将这个 SQLInputImpl对象中的下一个属性作为Java编程语言中的一个 int检索。
readInternalAttribute(String, String) - Method in interface javafx.fxml. LoadListener
加载程序读取内部属性时调用。
readLanguageProcessingInstruction(String) - Method in interface javafx.fxml. LoadListener
当加载程序读取语言处理指令时调用。
readLine() - Method in class java.io. BufferedReader
读一行文字。
readLine() - Method in class java.io. Console
从控制台读取一行文本。
readLine() - Method in interface java.io. DataInput
从输入流读取下一行文本。
readLine() - Method in class java.io. DataInputStream
已过时。
此方法无法将字节正确转换为字符。 从JDK 1.1开始，读取文本行的首选方式是通过BufferedReader.readLine()方法。 使用DataInputStream类读取行的程序可以转换为使用BufferedReader类替换以下形式的代码：
     DataInputStream d = new DataInputStream(in);
有：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
readLine() - Method in class java.io. LineNumberReader
读一行文字。
readLine() - Method in class java.io. ObjectInputStream
已过时。
此方法无法将字节正确转换为字符。 有关详细信息和替代方案，请参阅DataInputStream。
readLine() - Method in class java.io. RandomAccessFile
从此文件中读取下一行文本。
readLine() - Method in interface javax.imageio.stream. ImageInputStream
从输入流读取下一行文本。
readLine() - Method in class javax.imageio.stream. ImageInputStreamImpl
readLine() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件中读取下一行文本。
readLine(String, Object...) - Method in class java.io. Console
提供一个格式化的提示，然后从控制台读取一行文本。
readLock() - Method in interface java.util.concurrent.locks. ReadWriteLock
返回用于阅读的锁。
readLock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock
readLock() - Method in class java.util.concurrent.locks. StampedLock
不排他地获取锁定，如有必要，阻塞。
readLock() - Method in class javax.swing.text. AbstractDocument
获取一个锁，从文档开始读取一些状态。
ReadLock(ReentrantReadWriteLock) - Constructor for class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock
子类使用的构造方法。
readLockInterruptibly() - Method in class java.util.concurrent.locks. StampedLock
非排他性地获取锁定，如有必要，阻塞，直到可用或当前线程中断。
readLong() - Method in interface java.io. DataInput
读取八个输入字节并返回一个 long值。
readLong() - Method in class java.io. DataInputStream
见 readLong法 DataInput的一般合同。
readLong() - Method in class java.io. ObjectInputStream
读64位长。
readLong() - Method in class java.io. RandomAccessFile
从该文件中读取一个带符号的64位整数。
readLong() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 long返回。
readLong() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取8个字节，（概念上）根据当前字节顺序连接它们，并将结果作为 long返回。
readLong() - Method in class javax.imageio.stream. ImageInputStreamImpl
readLong() - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件中读取一个带符号的64位整数。
readLong() - Method in class javax.sql.rowset.serial. SQLInputImpl
获取此的下一个属性 SQLInputImpl对象为 long的Java编程语言。
readNBytes(byte[], int, int) - Method in class java.io. InputStream
将所请求的字节数从输入流读入给定的字节数组。
readNClob() - Method in interface java.sql. SQLInput
从流中读取SQL NCLOB值，并将其作为Java编程语言中的 NClob对象返回。
readNClob() - Method in class javax.sql.rowset.serial. SQLInputImpl
从流中读取SQL NCLOB值，并将其作为Java编程语言中的 Clob对象返回。
readNString() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 String返回。
readNString() - Method in class javax.sql.rowset.serial. SQLInputImpl
读取流中的下一个属性，并将其作为Java编程语言中的 String返回。
readObject() - Method in class java.beans. XMLDecoder
从底层输入流读取下一个对象。
readObject() - Method in interface java.io. ObjectInput
读取并返回一个对象。
readObject() - Method in class java.io. ObjectInputStream
从ObjectInputStream读取一个对象。
readObject() - Method in interface java.sql. SQLInput
读取流头的数据，并以Java编程语言中的 Object返回。
readObject() - Method in class javax.sql.rowset.serial. SQLInputImpl
以 Object的Java编程语言 Object此 SQLInputImpl对象头部的值。
readObject(Class<T>) - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 Object返回。
readObject(Stub, ObjectInputStream) - Method in interface javax.rmi.CORBA. StubDelegate
代表团要求 Stub.readObject(java.io.ObjectInputStream) 。
readObjectOverride() - Method in class java.io. ObjectInputStream
此方法由ObjectOutputStream的受信任子类调用，该子类使用受保护的无参构造函数构造ObjectOutputStream。
readOnlyAction - Static variable in class javax.swing.text. DefaultEditorKit
将编辑器设置为只读模式的操作名称。
readOnlyBooleanProperty(ReadOnlyProperty<Boolean>) - Static method in class javafx.beans.property. ReadOnlyBooleanProperty
返回一个ReadOnlyBooleanProperty ，其中包含一个ReadOnlyProperty 。
ReadOnlyBooleanProperty - Class in javafx.beans.property
超类为所有只读属性包装一个 boolean 。
ReadOnlyBooleanProperty() - Constructor for class javafx.beans.property. ReadOnlyBooleanProperty
构造函数为 ReadOnlyBooleanProperty 。
ReadOnlyBooleanPropertyBase - Class in javafx.beans.property
所有只读属性的基类包装一个 boolean 。
ReadOnlyBooleanPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyBooleanPropertyBase
ReadOnlyBooleanWrapper - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyBooleanWrapper() - Constructor for class javafx.beans.property. ReadOnlyBooleanWrapper
构造函数为 ReadOnlyBooleanWrapper
ReadOnlyBooleanWrapper(boolean) - Constructor for class javafx.beans.property. ReadOnlyBooleanWrapper
构造函数为 ReadOnlyBooleanWrapper
ReadOnlyBooleanWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyBooleanWrapper
构造函数为 ReadOnlyBooleanWrapper
ReadOnlyBooleanWrapper(Object, String, boolean) - Constructor for class javafx.beans.property. ReadOnlyBooleanWrapper
构造函数为 ReadOnlyBooleanWrapper
ReadOnlyBufferException - Exception in java.nio
在只读缓冲区上调用诸如 put或 compact类的内容突变方法时抛出未经检查的异常。
ReadOnlyBufferException() - Constructor for exception java.nio. ReadOnlyBufferException
构造这个类的一个实例。
readOnlyDoubleProperty(ReadOnlyProperty<T>) - Static method in class javafx.beans.property. ReadOnlyDoubleProperty
返回一个ReadOnlyDoubleProperty ，其中包含一个ReadOnlyProperty 。
ReadOnlyDoubleProperty - Class in javafx.beans.property
超类为所有只读属性包装一个 double 。
ReadOnlyDoubleProperty() - Constructor for class javafx.beans.property. ReadOnlyDoubleProperty
构造函数为 ReadOnlyDoubleProperty 。
ReadOnlyDoublePropertyBase - Class in javafx.beans.property
所有只读属性的基类包装一个 double 。
ReadOnlyDoublePropertyBase() - Constructor for class javafx.beans.property. ReadOnlyDoublePropertyBase
ReadOnlyDoubleWrapper - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyDoubleWrapper() - Constructor for class javafx.beans.property. ReadOnlyDoubleWrapper
构造函数为 ReadOnlyDoubleWrapper
ReadOnlyDoubleWrapper(double) - Constructor for class javafx.beans.property. ReadOnlyDoubleWrapper
构造函数为 ReadOnlyDoubleWrapper
ReadOnlyDoubleWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyDoubleWrapper
构造函数为 ReadOnlyDoubleWrapper
ReadOnlyDoubleWrapper(Object, String, double) - Constructor for class javafx.beans.property. ReadOnlyDoubleWrapper
构造函数为 ReadOnlyDoubleWrapper
ReadOnlyFileSystemException - Exception in java.nio.file
尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。
ReadOnlyFileSystemException() - Constructor for exception java.nio.file. ReadOnlyFileSystemException
构造这个类的一个实例。
readOnlyFloatProperty(ReadOnlyProperty<T>) - Static method in class javafx.beans.property. ReadOnlyFloatProperty
返回一个ReadOnlyFloatProperty的ReadOnlyFloatProperty 。
ReadOnlyFloatProperty - Class in javafx.beans.property
超类为所有只读属性包装一个 float 。
ReadOnlyFloatProperty() - Constructor for class javafx.beans.property. ReadOnlyFloatProperty
构造函数为 ReadOnlyFloatProperty 。
ReadOnlyFloatPropertyBase - Class in javafx.beans.property
所有只读属性的基类包装一个 float 。
ReadOnlyFloatPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyFloatPropertyBase
ReadOnlyFloatWrapper - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyFloatWrapper() - Constructor for class javafx.beans.property. ReadOnlyFloatWrapper
构造函数为 ReadOnlyFloatWrapper
ReadOnlyFloatWrapper(float) - Constructor for class javafx.beans.property. ReadOnlyFloatWrapper
构造函数为 ReadOnlyFloatWrapper
ReadOnlyFloatWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyFloatWrapper
构造函数为 ReadOnlyFloatWrapper
ReadOnlyFloatWrapper(Object, String, float) - Constructor for class javafx.beans.property. ReadOnlyFloatWrapper
构造函数为 ReadOnlyFloatWrapper
readOnlyIntegerProperty(ReadOnlyProperty<T>) - Static method in class javafx.beans.property. ReadOnlyIntegerProperty
返回一个ReadOnlyIntegerProperty的ReadOnlyIntegerProperty 。
ReadOnlyIntegerProperty - Class in javafx.beans.property
超类为所有只读属性包装一个 int 。
ReadOnlyIntegerProperty() - Constructor for class javafx.beans.property. ReadOnlyIntegerProperty
构造函数为 ReadOnlyIntegerProperty 。
ReadOnlyIntegerPropertyBase - Class in javafx.beans.property
所有只读属性的基类包装一个 int 。
ReadOnlyIntegerPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyIntegerPropertyBase
ReadOnlyIntegerWrapper - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyIntegerWrapper() - Constructor for class javafx.beans.property. ReadOnlyIntegerWrapper
构造函数为 ReadOnlyIntegerWrapper
ReadOnlyIntegerWrapper(int) - Constructor for class javafx.beans.property. ReadOnlyIntegerWrapper
构造函数为 ReadOnlyIntegerWrapper
ReadOnlyIntegerWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyIntegerWrapper
构造函数为 ReadOnlyIntegerWrapper
ReadOnlyIntegerWrapper(Object, String, int) - Constructor for class javafx.beans.property. ReadOnlyIntegerWrapper
构造函数为 ReadOnlyIntegerWrapper
ReadOnlyJavaBeanBooleanProperty - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanBooleanProperty在 boolean或 Boolean之间的常规只读Java Bean属性和JavaFX ReadOnlyBooleanProperty提供了一个适配器。
ReadOnlyJavaBeanBooleanPropertyBuilder - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanBooleanPropertyBuilder可用于创建ReadOnlyJavaBeanBooleanProperties 。
ReadOnlyJavaBeanBooleanPropertyBuilder() - Constructor for class javafx.beans.property.adapter. ReadOnlyJavaBeanBooleanPropertyBuilder
ReadOnlyJavaBeanDoubleProperty - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanDoubleProperty在 double或 Double之间的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty提供了一个适配器。
ReadOnlyJavaBeanDoublePropertyBuilder - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanDoublePropertyBuilder可以用来创建ReadOnlyJavaBeanDoubleProperties 。
ReadOnlyJavaBeanDoublePropertyBuilder() - Constructor for class javafx.beans.property.adapter. ReadOnlyJavaBeanDoublePropertyBuilder
ReadOnlyJavaBeanFloatProperty - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanFloatProperty在常规的只读Java Bean属性类型为 float或 Float和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。
ReadOnlyJavaBeanFloatPropertyBuilder - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanFloatPropertyBuilder可以用来创建ReadOnlyJavaBeanFloatProperties 。
ReadOnlyJavaBeanFloatPropertyBuilder() - Constructor for class javafx.beans.property.adapter. ReadOnlyJavaBeanFloatPropertyBuilder
ReadOnlyJavaBeanIntegerProperty - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanIntegerProperty在 int或 Integer之间的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty提供了一个适配器。
ReadOnlyJavaBeanIntegerPropertyBuilder - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanIntegerPropertyBuilder可以用来创建ReadOnlyJavaBeanIntegerProperties 。
ReadOnlyJavaBeanIntegerPropertyBuilder() - Constructor for class javafx.beans.property.adapter. ReadOnlyJavaBeanIntegerPropertyBuilder
ReadOnlyJavaBeanLongProperty - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanLongProperty在类型为 long或 Long的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty之间提供了一个适配器。
ReadOnlyJavaBeanLongPropertyBuilder - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanLongPropertyBuilder可以用来创建ReadOnlyJavaBeanLongProperties 。
ReadOnlyJavaBeanLongPropertyBuilder() - Constructor for class javafx.beans.property.adapter. ReadOnlyJavaBeanLongPropertyBuilder
ReadOnlyJavaBeanObjectProperty< T> - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanObjectProperty提供了常规的只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间的适配器。
ReadOnlyJavaBeanObjectPropertyBuilder< T> - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanObjectPropertyBuilder可以用来创建ReadOnlyJavaBeanObjectProperties 。
ReadOnlyJavaBeanObjectPropertyBuilder() - Constructor for class javafx.beans.property.adapter. ReadOnlyJavaBeanObjectPropertyBuilder
ReadOnlyJavaBeanProperty< T> - Interface in javafx.beans.property.adapter
JavaBeanProperty是只读Java Bean属性和JavaFX属性之间的所有适配器的超级接口。
ReadOnlyJavaBeanStringProperty - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanStringProperty在类型为 String的常规只读Java Bean属性和JavaFX ReadOnlyStringProperty之间提供了一个适配器。
ReadOnlyJavaBeanStringPropertyBuilder - Class in javafx.beans.property.adapter
A ReadOnlyJavaBeanStringPropertyBuilder可用于创建ReadOnlyJavaBeanStringProperties 。
ReadOnlyJavaBeanStringPropertyBuilder() - Constructor for class javafx.beans.property.adapter. ReadOnlyJavaBeanStringPropertyBuilder
ReadOnlyListProperty< E> - Class in javafx.beans.property
超类为所有只读属性包装一个ObservableList 。
ReadOnlyListProperty() - Constructor for class javafx.beans.property. ReadOnlyListProperty
构造函数为 ReadOnlyListProperty 。
ReadOnlyListPropertyBase< E> - Class in javafx.beans.property
所有只读属性的基类包装一个ObservableList 。
ReadOnlyListPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyListPropertyBase
ReadOnlyListWrapper< E> - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyListWrapper() - Constructor for class javafx.beans.property. ReadOnlyListWrapper
构造函数为 ReadOnlyListWrapper
ReadOnlyListWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyListWrapper
构造函数为 ReadOnlyListWrapper
ReadOnlyListWrapper(Object, String, ObservableList<E>) - Constructor for class javafx.beans.property. ReadOnlyListWrapper
构造函数为 ReadOnlyListWrapper
ReadOnlyListWrapper(ObservableList<E>) - Constructor for class javafx.beans.property. ReadOnlyListWrapper
构造函数为 ReadOnlyListWrapper
readOnlyLongProperty(ReadOnlyProperty<T>) - Static method in class javafx.beans.property. ReadOnlyLongProperty
返回一个ReadOnlyLongProperty的ReadOnlyLongProperty 。
ReadOnlyLongProperty - Class in javafx.beans.property
超类为所有只读属性包装一个 long 。
ReadOnlyLongProperty() - Constructor for class javafx.beans.property. ReadOnlyLongProperty
构造函数为 ReadOnlyLongProperty 。
ReadOnlyLongPropertyBase - Class in javafx.beans.property
所有只读属性的基类包装一个 long 。
ReadOnlyLongPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyLongPropertyBase
ReadOnlyLongWrapper - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyLongWrapper() - Constructor for class javafx.beans.property. ReadOnlyLongWrapper
构造函数为 ReadOnlyLongWrapper
ReadOnlyLongWrapper(long) - Constructor for class javafx.beans.property. ReadOnlyLongWrapper
构造函数为 ReadOnlyLongWrapper
ReadOnlyLongWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyLongWrapper
构造函数为 ReadOnlyLongWrapper
ReadOnlyLongWrapper(Object, String, long) - Constructor for class javafx.beans.property. ReadOnlyLongWrapper
构造函数为 ReadOnlyLongWrapper
ReadOnlyMapProperty< K, V> - Class in javafx.beans.property
超类为所有只读属性包装一个ObservableMap 。
ReadOnlyMapProperty() - Constructor for class javafx.beans.property. ReadOnlyMapProperty
构造函数为 ReadOnlyMapProperty 。
ReadOnlyMapPropertyBase< K, V> - Class in javafx.beans.property
所有只读属性的基类包装一个ObservableMap 。
ReadOnlyMapPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyMapPropertyBase
ReadOnlyMapWrapper< K, V> - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyMapWrapper() - Constructor for class javafx.beans.property. ReadOnlyMapWrapper
构造函数为 ReadOnlyMapWrapper
ReadOnlyMapWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyMapWrapper
构造函数为 ReadOnlyMapWrapper
ReadOnlyMapWrapper(Object, String, ObservableMap<K, V>) - Constructor for class javafx.beans.property. ReadOnlyMapWrapper
构造函数为 ReadOnlyMapWrapper
ReadOnlyMapWrapper(ObservableMap<K, V>) - Constructor for class javafx.beans.property. ReadOnlyMapWrapper
构造函数为 ReadOnlyMapWrapper
ReadOnlyObjectProperty< T> - Class in javafx.beans.property
超类为所有只读属性包装任意 Object 。
ReadOnlyObjectProperty() - Constructor for class javafx.beans.property. ReadOnlyObjectProperty
构造函数为 ReadOnlyObjectProperty 。
ReadOnlyObjectPropertyBase< T> - Class in javafx.beans.property
所有只读属性的基类包装任意 Object 。
ReadOnlyObjectPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyObjectPropertyBase
ReadOnlyObjectWrapper< T> - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyObjectWrapper() - Constructor for class javafx.beans.property. ReadOnlyObjectWrapper
构造函数为 ReadOnlyObjectWrapper
ReadOnlyObjectWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyObjectWrapper
构造函数为 ReadOnlyObjectWrapper
ReadOnlyObjectWrapper(Object, String, T) - Constructor for class javafx.beans.property. ReadOnlyObjectWrapper
构造函数为 ReadOnlyObjectWrapper
ReadOnlyObjectWrapper(T) - Constructor for class javafx.beans.property. ReadOnlyObjectWrapper
构造函数为 ReadOnlyObjectWrapper
ReadOnlyProperty< T> - Interface in javafx.beans.property
通用接口，用于定义独立于其类型的所有可读属性通用的方法。
ReadOnlySetProperty< E> - Class in javafx.beans.property
超类为所有只读属性包装一个ObservableSet 。
ReadOnlySetProperty() - Constructor for class javafx.beans.property. ReadOnlySetProperty
构造函数为 ReadOnlySetProperty 。
ReadOnlySetPropertyBase< E> - Class in javafx.beans.property
所有只读属性的基类包装一个ObservableSet 。
ReadOnlySetPropertyBase() - Constructor for class javafx.beans.property. ReadOnlySetPropertyBase
ReadOnlySetWrapper< E> - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlySetWrapper() - Constructor for class javafx.beans.property. ReadOnlySetWrapper
构造函数为 ReadOnlySetWrapper
ReadOnlySetWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlySetWrapper
构造函数为 ReadOnlySetWrapper
ReadOnlySetWrapper(Object, String, ObservableSet<E>) - Constructor for class javafx.beans.property. ReadOnlySetWrapper
构造函数为 ReadOnlySetWrapper
ReadOnlySetWrapper(ObservableSet<E>) - Constructor for class javafx.beans.property. ReadOnlySetWrapper
构造函数为 ReadOnlySetWrapper
ReadOnlyStringProperty - Class in javafx.beans.property
超类为所有只读属性包装一个 String 。
ReadOnlyStringProperty() - Constructor for class javafx.beans.property. ReadOnlyStringProperty
构造函数为 ReadOnlyStringProperty 。
ReadOnlyStringPropertyBase - Class in javafx.beans.property
所有只读属性的基类包装一个 String 。
ReadOnlyStringPropertyBase() - Constructor for class javafx.beans.property. ReadOnlyStringPropertyBase
ReadOnlyStringWrapper - Class in javafx.beans.property
该类提供了一个方便的类来定义只读属性。
ReadOnlyStringWrapper() - Constructor for class javafx.beans.property. ReadOnlyStringWrapper
构造函数为 ReadOnlyStringWrapper
ReadOnlyStringWrapper(Object, String) - Constructor for class javafx.beans.property. ReadOnlyStringWrapper
构造函数为 ReadOnlyStringWrapper
ReadOnlyStringWrapper(Object, String, String) - Constructor for class javafx.beans.property. ReadOnlyStringWrapper
构造函数为 ReadOnlyStringWrapper
ReadOnlyStringWrapper(String) - Constructor for class javafx.beans.property. ReadOnlyStringWrapper
构造函数为 ReadOnlyStringWrapper
readPacket() - Method in class com.sun.jdi.connect.spi. Connection
从目标虚拟机读取数据包。
readPassword() - Method in class java.io. Console
从禁用回音的控制台读取密码或密码
readPassword(String, Object...) - Method in class java.io. Console
提供一个格式化的提示，然后从禁用回显的控制台读取密码或密码。
ReadPendingException - Exception in java.nio.channels
尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
ReadPendingException() - Constructor for exception java.nio.channels. ReadPendingException
构造这个类的一个实例。
readPropertyAttribute(String, Class<?>, String) - Method in interface javafx.fxml. LoadListener
加载程序读取属性属性时调用。
readRaster(int, ImageReadParam) - Method in class javax.imageio. ImageReader
返回包含来自图像流的原始像素数据的新的 Raster对象，而不应用任何颜色转换。
readRef() - Method in interface java.sql. SQLInput
从流中读取SQL REF值，并将其作为Java编程语言中的 Ref对象返回。
readRef() - Method in class javax.sql.rowset.serial. SQLInputImpl
以Java编程语言中的 Ref对象获取该 SQLInputImpl对象的头部的值。
readResolve() - Method in class java.awt. AWTKeyStroke
返回的缓存实例 AWTKeyStroke （或子类 AWTKeyStroke ），这是此实例相等。
readResolve() - Method in class java.awt.color. ICC_Profile
将被反序列化的实例解析为使用CMM注册的实例。
readResolve() - Method in class java.awt.font. TextAttribute
解析反序列化为预定义常量的实例。
readResolve() - Method in class java.security.cert. Certificate.CertificateRep
解决证书对象。
readResolve() - Method in class java.security.cert. CertPath.CertPathRep
返回从类型和数据构造的 CertPath 。
readResolve() - Method in class java.security. KeyRep
解决Key对象。
readResolve() - Method in class java.text. AttributedCharacterIterator.Attribute
解析反序列化为预定义常量的实例。
readResolve() - Method in class java.text. DateFormat.Field
解析反序列化为预定义常量的实例。
readResolve() - Method in class java.text. MessageFormat.Field
解析反序列化为预定义常量的实例。
readResolve() - Method in class java.text. NumberFormat.Field
解析反序列化为预定义常量的实例。
readResolve() - Method in class javax.management.openmbean. SimpleType
使用该值的唯一实例替换从ObjectInputStream读取的对象。
readResolve() - Method in class javax.print.attribute. EnumSyntax
在对象输入期间，将此反序列化枚举实例转换为枚举属性类中定义的适当枚举值。
readRowId() - Method in interface java.sql. SQLInput
从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
readRowId() - Method in class javax.sql.rowset.serial. SQLInputImpl
从流中读取SQL ROWID值，并将其作为Java编程语言中的 RowId对象返回。
reads() - Method in class java.lang.module. ResolvedModule
返回已解析模块读取的已解析模块集。
readShort() - Method in interface java.io. DataInput
读取两个输入字节并返回一个 short值。
readShort() - Method in class java.io. DataInputStream
见 readShort方法的一般合同 DataInput 。
readShort() - Method in class java.io. ObjectInputStream
读取16位短。
readShort() - Method in class java.io. RandomAccessFile
从此文件中读取一个已签名的16位数字。
readShort() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 short返回。
readShort() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取两个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 short值返回。
readShort() - Method in class javax.imageio.stream. ImageInputStreamImpl
readShort() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件中读取一个已签名的16位数字。
readShort() - Method in class javax.sql.rowset.serial. SQLInputImpl
获取此的下一个属性 SQLInputImpl对象为 short的Java编程语言。
readSQL(SQLInput, String) - Method in interface java.sql. SQLData
使用从数据库读取的数据填充此对象。
readSQLXML() - Method in interface java.sql. SQLInput
从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
readSQLXML() - Method in class javax.sql.rowset.serial. SQLInputImpl
从流中读取SQL XML值，并将其作为Java编程语言中的 SQLXML对象返回。
readStreamHeader() - Method in class java.io. ObjectInputStream
提供了readStreamHeader方法来允许子类读取和验证自己的流标题。
readString() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为Java编程语言中的 String返回。
readString() - Method in class javax.sql.rowset.serial. SQLInputImpl
将这个 SQLInputImpl对象中的下一个属性作为Java编程语言中的一个 String检索。
readSymbolicLink(Path) - Static method in class java.nio.file. Files
读取符号链接的目标 （可选操作） 。
readSymbolicLink(Path) - Method in class java.nio.file.spi. FileSystemProvider
读取符号链接的目标。
readThumbnail(int, int) - Method in class javax.imageio. ImageReader
返回 thumbnailIndex索引的缩略图预览图像，与 ImageIndex索引的图像相关联，为 BufferedImage 。
readTile(int, int, int) - Method in class javax.imageio. ImageReader
读取由 tileX和 tileY参数指示的 tileX ，将其作为 BufferedImage返回。
readTileRaster(int, int, int) - Method in class javax.imageio. ImageReader
返回一个包含来自图块的原始像素数据的新的 Raster对象，而不应用任何颜色转换。
readTime() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为 java.sql.Time对象返回。
readTime() - Method in class javax.sql.rowset.serial. SQLInputImpl
检索此 SQLInputImpl对象中的下一个属性为 java.sql.Time对象。
readTimestamp() - Method in interface java.sql. SQLInput
读取流中的下一个属性，并将其作为 java.sql.Timestamp对象返回。
readTimestamp() - Method in class javax.sql.rowset.serial. SQLInputImpl
将此 SQLInputImpl对象中的下一个属性检索为 java.sql.Timestamp对象。
readUnknownStaticPropertyAttribute(String, String) - Method in interface javafx.fxml. LoadListener
当加载程序读取未知的静态属性属性时调用。
readUnlock() - Method in class javax.swing.text. AbstractDocument
读取解锁
readUnshared() - Method in class java.io. ObjectInputStream
从ObjectInputStream读取一个“非共享”对象。
readUnsignedByte() - Method in interface java.io. DataInput
读取一个输入字节，将其扩展到类型 int ，并返回结果，因此在 0到 255 。
readUnsignedByte() - Method in class java.io. DataInputStream
见 readUnsignedByte法 DataInput的一般合同。
readUnsignedByte() - Method in class java.io. ObjectInputStream
读取一个无符号的8位字节。
readUnsignedByte() - Method in class java.io. RandomAccessFile
从此文件中读取一个无符号的八位数字。
readUnsignedByte() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取一个字节，并在概念 0xff其转换为int，使用 0xff屏蔽它，以便剥离任何符号扩展位，并将其作为 byte值返回。
readUnsignedByte() - Method in class javax.imageio.stream. ImageInputStreamImpl
readUnsignedByte() - Method in interface javax.jnlp. JNLPRandomAccessFile
从此文件中读取一个无符号的八位数字。
readUnsignedInt() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，将结果转换为长，将其用 0xffffffffL ，以便剥离任何符号扩展位，并将结果作为无符号的 long返回值。
readUnsignedInt() - Method in class javax.imageio.stream. ImageInputStreamImpl
readUnsignedShort() - Method in interface java.io. DataInput
读取两个输入字节，并返回一个 int范围值 0通过 65535 。
readUnsignedShort() - Method in class java.io. DataInputStream
见 readUnsignedShort法 DataInput的一般合同。
readUnsignedShort() - Method in class java.io. ObjectInputStream
读取无符号16位短。
readUnsignedShort() - Method in class java.io. RandomAccessFile
从该文件中读取一个无符号的16位数字。
readUnsignedShort() - Method in interface javax.imageio.stream. ImageInputStream
从流中读取两个字节，并且（在概念上）根据当前字节顺序连接它们，将结果值转换为 int ，使用 0xffff对其进行 0xffff ，以便剥离任何符号扩展名，并将结果作为无符号返回价值 int 。
readUnsignedShort() - Method in class javax.imageio.stream. ImageInputStreamImpl
readUnsignedShort() - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件中读取一个无符号的16位数字。
readURL() - Method in interface java.sql. SQLInput
从流中读取SQL DATALINK值，并将其作为Java编程语言中的 java.net.URL对象返回。
readURL() - Method in class javax.sql.rowset.serial. SQLInputImpl
从流中读取SQL DATALINK值，并将其作为Java编程语言中的 URL对象返回。
readUTF() - Method in interface java.io. DataInput
读取已使用 modified UTF-8格式编码的字符串。
readUTF() - Method in class java.io. DataInputStream
参见 readUTF法 DataInput的一般合同。
readUTF() - Method in class java.io. ObjectInputStream
以 modified UTF-8格式读取字符串。
readUTF() - Method in class java.io. RandomAccessFile
从该文件读取字符串。
readUTF() - Method in interface javax.imageio.stream. ImageInputStream
读取已使用 modified UTF-8格式编码的字符串。
readUTF() - Method in class javax.imageio.stream. ImageInputStreamImpl
readUTF() - Method in interface javax.jnlp. JNLPRandomAccessFile
从该文件读取字符串。
readUTF(DataInput) - Static method in class java.io. DataInputStream
从流in读取以modified UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为一个String返回。
readValue(InputStream, int, Class, String, RunTime) - Method in interface javax.rmi.CORBA. ValueHandler
使用Java语义从流读取值。
ReadWriteLock - Interface in java.util.concurrent.locks
A ReadWriteLock维护一对相关的locks ，一个用于只读操作，一个用于写入。
readXml(InputStream) - Method in interface javax.sql.rowset. WebRowSet
读取基于流的XML输入来填充此 WebRowSet对象。
readXml(Reader) - Method in interface javax.sql.rowset. WebRowSet
读取 WebRowSet在从给定的XML格式对象 Reader对象。
readXML(WebRowSet, Reader) - Method in interface javax.sql.rowset.spi. XmlReader
从XML格式的给定输入流中读取和解析给定的 WebRowSet对象。
ready() - Method in class java.io. BufferedReader
告诉这个流是否准备好被读取。
ready() - Method in class java.io. CharArrayReader
告诉这个流是否准备好被读取。
ready() - Method in class java.io. FilterReader
告诉这个流是否准备好被读取。
ready() - Method in class java.io. InputStreamReader
告诉这个流是否准备好被读取。
ready() - Method in class java.io. PipedReader
告诉这个流是否准备好阅读。
ready() - Method in class java.io. PushbackReader
告诉这个流是否准备好被读取。
ready() - Method in class java.io. Reader
告诉这个流是否准备好被读取。
ready() - Method in class java.io. StringReader
告诉这个流是否准备好被读取。
ready() - Method in class javafx.concurrent. Service
对于子类的受保护的便利方法，在服务状态已转换到READY状态时调用。
READY - javafx.concurrent. Worker.State
表示Worker尚未被执行并准备执行，或者已被重新初始化。
READY - javafx.scene.media. MediaPlayer.Status
玩家的状态一旦准备好玩。
readyOps() - Method in class java.nio.channels. SelectionKey
检索此密钥的即用操作集。
REAL - java.sql. JDBCType
标识通用SQL类型 REAL 。
REAL - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REAL 。
realEditor - Variable in class javax.swing.tree. DefaultTreeCellEditor
编辑器处理编辑。
realm - Variable in class com.sun.net.httpserver. BasicAuthenticator
RealmCallback - Class in javax.security.sasl
此回调由 SaslClient和 SaslServer用于检索领域信息。
RealmCallback(String) - Constructor for class javax.security.sasl. RealmCallback
构造一个带有提示的 RealmCallback 。
RealmCallback(String, String) - Constructor for class javax.security.sasl. RealmCallback
构造一个带有提示和默认领域信息的 RealmCallback 。
RealmChoiceCallback - Class in javax.security.sasl
这个回调由 SaslClient和 SaslServer使用，以获得一个领域列表的选择。
RealmChoiceCallback(String, String[], int, boolean) - Constructor for class javax.security.sasl. RealmChoiceCallback
构造一个 RealmChoiceCallback的提示，一个选项列表和一个默认选项。
realSource - Variable in class javax.swing.undo. UndoableEditSupport
真正的来源。
reason - Variable in exception org.omg.CORBA. PolicyError
抛出 PolicyError异常的原因。
REASON_UNKNOWN - java.sql. ClientInfoStatus
由于某些未知原因，客户端信息属性无法设置
REASON_UNKNOWN_PROPERTY - java.sql. ClientInfoStatus
指定的客户端信息属性名称不是公认的属性名称。
REASON_VALUE_INVALID - java.sql. ClientInfoStatus
为客户端info属性指定的值无效。
REASON_VALUE_TRUNCATED - java.sql. ClientInfoStatus
为客户端信息属性指定的值太大。
rebind(String, Object) - Method in interface javax.naming. Context
将名称绑定到对象，覆盖任何现有绑定。
rebind(String, Object) - Method in class javax.naming. InitialContext
rebind(String, Object, Attributes) - Method in interface javax.naming.directory. DirContext
将名称绑定到对象以及关联的属性，覆盖任何现有绑定。
rebind(String, Object, Attributes) - Method in class javax.naming.directory. InitialDirContext
rebind(String, Remote) - Static method in class java.rmi. Naming
将指定的名称重新绑定到一个新的远程对象。
rebind(String, Remote) - Method in interface java.rmi.registry. Registry
使用提供的远程引用替换此注册表中指定的 name的绑定。
rebind(Name, Object) - Method in interface javax.naming. Context
将名称绑定到对象，覆盖任何现有绑定。
rebind(Name, Object) - Method in class javax.naming. InitialContext
rebind(Name, Object, Attributes) - Method in interface javax.naming.directory. DirContext
将名称绑定到对象以及关联的属性，覆盖任何现有绑定。
rebind(Name, Object, Attributes) - Method in class javax.naming.directory. InitialDirContext
rebind(NameComponent[], Object) - Method in class org.omg.CosNaming. _NamingContextExtStub
即使名称已经在上下文中绑定，也可以在命名上下文中创建名称和对象的绑定。
rebind(NameComponent[], Object) - Method in class org.omg.CosNaming. _NamingContextStub
即使名称已经在上下文中绑定，也可以在命名上下文中创建名称和对象的绑定。
rebind(NameComponent[], Object) - Method in interface org.omg.CosNaming. NamingContextOperations
即使名称已经在上下文中绑定，也可以在命名上下文中创建名称和对象的绑定。
REBIND - Exception in org.omg.CORBA
REBIND上升时电流有效RebindPolicy，具有NO_REBIND或NO_RECONNECT的值和上一个绑定的对象引用在消息LocateReply具有状态OBJECT_FORWARD或状态为LOCATION_FORWARD一个应答消息的调用。
REBIND() - Constructor for exception org.omg.CORBA. REBIND
构造一个 REBIND异常，次要代码设置为0，CompletionStatus设置为COMPLETED_NO。
REBIND(int, CompletionStatus) - Constructor for exception org.omg.CORBA. REBIND
构造具有指定的次要代码和完成状态的 REBIND异常。
REBIND(String) - Constructor for exception org.omg.CORBA. REBIND
使用指定的消息构造一个 REBIND异常。
REBIND(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. REBIND
构造具有指定消息，次要代码和完成状态的 REBIND异常。
rebind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming. _NamingContextExtStub
在命名上下文中创建名称和命名上下文的绑定，即使名称已经在上下文中绑定了。
rebind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming. _NamingContextStub
在命名上下文中创建名称和命名上下文的绑定，即使名称已经在上下文中绑定了。
rebind_context(NameComponent[], NamingContext) - Method in interface org.omg.CosNaming. NamingContextOperations
在命名上下文中创建名称和命名上下文的绑定，即使名称已经在上下文中绑定了。
recalculateIfInsetsChanged() - Method in class javax.swing.plaf.basic. BasicSliderUI
如果插图已更改，请重新计算。
recalculateIfInsetsChanged() - Method in class javax.swing.plaf.synth. SynthSliderUI
如果插图已更改，请重新计算。
recalculateIfOrientationChanged() - Method in class javax.swing.plaf.basic. BasicSliderUI
重新计算方向是否改变。
recalcWidthCache() - Method in class javax.swing.table. DefaultTableColumnModel
重新计算所有列的总合并宽度。
receive(int) - Method in class java.io. PipedInputStream
接收一个字节的数据。
receive(DatagramPacket) - Method in class java.net. DatagramSocket
从此套接字接收数据报包。
receive(DatagramPacket) - Method in class java.net. DatagramSocketImpl
接收数据报包。
receive(ByteBuffer) - Method in class java.nio.channels. DatagramChannel
通过该频道接收数据报。
receive(ByteBuffer, T, NotificationHandler<T>) - Method in class com.sun.nio.sctp. SctpChannel
在给定的缓冲区中接收消息和/或处理通知。
receive(ByteBuffer, T, NotificationHandler<T>) - Method in class com.sun.nio.sctp. SctpMultiChannel
接收消息和/或通过此频道处理通知。
receive_exception(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor. ClientRequestInterceptorOperations
向拦截器指示发生异常。
receive_other(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor. ClientRequestInterceptorOperations
允许拦截器在请求导致除了正常回复或异常之外的其他内容时查询可用的信息。
receive_reply(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor. ClientRequestInterceptorOperations
允许拦截器在从服务器返回并在将控制权返回给客户端之前查询答复上的信息。
receive_request(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor. ServerRequestInterceptorOperations
允许拦截器在所有信息（包括操作参数）可用之后查询请求信息。
receive_request_service_contexts(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor. ServerRequestInterceptorOperations
允许拦截器处理服务上下文信息。
received_exception() - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations
返回任何包含要返回给客户端的异常。
received_exception_id() - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations
返回要返回给客户端的异常的存储库ID。
Receiver - Interface in javax.sound.midi
A Receiver接收MidiEvent个对象，通常会做出有用的响应，例如解释它们生成声音或原始MIDI输出。
receiverType() - Method in interface com.sun.javadoc. ExecutableMemberDoc
已过时。
获取此可执行元素的接收器类型。
reclaim(AttributeSet) - Method in interface javax.swing.text. AbstractDocument.AttributeContext
回收一个属性集。
reclaim(AttributeSet) - Method in class javax.swing.text. StyleContext
返回MutableAttributeSet实现不再需要的集合。
reconnect(Control[]) - Method in class javax.naming.ldap. InitialLdapContext
reconnect(Control[]) - Method in interface javax.naming.ldap. LdapContext
使用提供的控件和此上下文的环境重新连接到LDAP服务器。
reconvert() - Method in class java.awt.im. InputContext
请求当前输入法从当前客户端组件重新转换文本。
reconvert() - Method in interface java.awt.im.spi. InputMethod
开始重新转换操作。
RECORD - javafx.scene.input. KeyCode
常数为 Record键。
recordDisable(Track) - Method in interface javax.sound.midi. Sequencer
禁用记录到指定的轨道。
recordEnable(Track, int) - Method in interface javax.sound.midi. Sequencer
准备指定的轨道，用于记录在特定频道上收到的事件。
recover(int) - Method in interface javax.transaction.xa. XAResource
从资源管理器获取准备的事务分支列表。
RECOVERABLE_DEFINED - jdk.jshell. Snippet.Status
该片段是一个声明片段，具有潜在可恢复的未解析引用或其身体其他问题（在当前的 JShell状态的上下文中）。
RECOVERABLE_NOT_DEFINED - jdk.jshell. Snippet.Status
该片段是具有潜在可恢复的未解决引用或其他问题的声明片段（在当前的 JShell状态的上下文中）。
rect(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext
将路径元素添加到当前路径以创建一个矩形。
Rect - Interface in org.w3c.dom.css
Rect接口用于表示任何rect值。
Rectangle - Class in java.awt
A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的区域，其坐标空间，宽度及其高度。
Rectangle - Class in javafx.scene.shape
Rectangle类定义了一个具有指定大小和位置的矩形。
Rectangle() - Constructor for class java.awt. Rectangle
构造新的 Rectangle其左上角在坐标空间中为（0,0），宽度和高度都为零。
Rectangle() - Constructor for class javafx.scene.shape. Rectangle
创建一个空的Rectangle实例。
Rectangle(double, double) - Constructor for class javafx.scene.shape. Rectangle
用给定的大小创建一个新的Rectangle实例。
Rectangle(double, double, double, double) - Constructor for class javafx.scene.shape. Rectangle
用给定的位置和大小创建一个新的Rectangle实例。
Rectangle(double, double, Paint) - Constructor for class javafx.scene.shape. Rectangle
用给定的大小和填充创建一个新的Rectangle实例。
Rectangle(int, int) - Constructor for class java.awt. Rectangle
构造一个新的 Rectangle其左上角在坐标空间中为（0,0），其宽度和高度由同名参数指定。
Rectangle(int, int, int, int) - Constructor for class java.awt. Rectangle
构造一个新的 Rectangle其左上角被指定为 (x,y) ，其宽度和高度由相同名称的参数指定。
Rectangle(Dimension) - Constructor for class java.awt. Rectangle
构造一个新的 Rectangle其左上角为（0,0），其宽度和高度由 Dimension参数指定。
Rectangle(Point) - Constructor for class java.awt. Rectangle
构造一个新的 Rectangle其左上角是指定的 Point ，其宽度和高度均为零。
Rectangle(Point, Dimension) - Constructor for class java.awt. Rectangle
构造一个新的Rectangle其左上角由Point参数指定，其宽度和高度由Dimension参数指定。
Rectangle(Rectangle) - Constructor for class java.awt. Rectangle
构造一个新的 Rectangle ，初始化为匹配指定的 Rectangle 。
Rectangle2D - Class in java.awt.geom
Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
Rectangle2D - Class in javafx.geometry
用于描述对象边界的2D矩形。
Rectangle2D() - Constructor for class java.awt.geom. Rectangle2D
这是一个无法直接实例化的抽象类。
Rectangle2D(double, double, double, double) - Constructor for class javafx.geometry. Rectangle2D
创建一个新的实例 Rectangle2D 。
Rectangle2D.Double - Class in java.awt.geom
Double类定义了一个以双坐标指定的矩形。
Rectangle2D.Float - Class in java.awt.geom
Float类定义了一个以浮点坐标指定的矩形。
rectangleForCurrentValue() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
返回保留用于绘制当前选定项目的区域。
RectangularShape - Class in java.awt.geom
RectangularShape是几何由矩形框架定义的Shape对象的基类。
RectangularShape() - Constructor for class java.awt.geom. RectangularShape
这是一个无法直接实例化的抽象类。
rects - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
标签
RecursiveAction - Class in java.util.concurrent
一个递归结果ForkJoinTask 。
RecursiveAction() - Constructor for class java.util.concurrent. RecursiveAction
RecursiveTask< V> - Class in java.util.concurrent
递归结果ForkJoinTask 。
RecursiveTask() - Constructor for class java.util.concurrent. RecursiveTask
recycleNode() - Method in interface javax.xml.soap. Node
通知应用程序不再使用此 Node对象的实现，并且该实现可以自由地将此对象重用于稍后可能创建的节点。
red - Static variable in class java.awt. Color
颜色红色。
RED - javafx.scene.effect. BlendMode
底部输入的红色分量被顶部输入的红色分量代替; 其他颜色成分不受影响。
RED - Static variable in class java.awt. Color
颜色红色。
RED - Static variable in class javafx.scene.paint. Color
颜色红色，RGB值为＃FF0000
REDCOMPONENT - Static variable in class java.awt.color. ICC_ProfileRGB
用于获得红色分量的伽马值或TRC。
redefine(ExecutionControl.ClassBytecodes[]) - Method in class jdk.jshell.execution. DirectExecutionControl
redefine(ExecutionControl.ClassBytecodes[]) - Method in class jdk.jshell.execution. JdiExecutionControl
重新定义指定的类。
redefine(ExecutionControl.ClassBytecodes[]) - Method in class jdk.jshell.execution. RemoteExecutionControl
远程重新定义处理只用于注册重新定义的类
redefine(ExecutionControl.ClassBytecodes[]) - Method in class jdk.jshell.execution. StreamingExecutionControl
redefine(ExecutionControl.ClassBytecodes[]) - Method in interface jdk.jshell.spi. ExecutionControl
尝试重新定义以前加载的类。
redefineClasses(ClassDefinition...) - Method in interface java.lang.instrument. Instrumentation
使用提供的类文件重新定义提供的一组类。
redefineClasses(Map<? extends ReferenceType, byte[]>) - Method in interface com.sun.jdi. VirtualMachine
根据提供的定义重新定义所有给定的类。
redefineModule(Module, Set<Module>, Map<String, Set<Module>>, Map<String, Set<Module>>, Set<Class<?>>, Map<Class<?>, List<Class<?>>>) - Method in interface java.lang.instrument. Instrumentation
重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。
redirectError() - Method in class java.lang. ProcessBuilder
返回此流程构建器的标准错误目标。
redirectError(File) - Method in class java.lang. ProcessBuilder
将此流程构建器的标准错误目标设置为文件。
redirectError(ProcessBuilder.Redirect) - Method in class java.lang. ProcessBuilder
设置此流程构建器的标准错误目标。
redirectErrorStream() - Method in class java.lang. ProcessBuilder
告诉这个进程构建器是否合并标准错误和标准输出。
redirectErrorStream(boolean) - Method in class java.lang. ProcessBuilder
设置此过程构建器的 redirectErrorStream属性。
redirectInput() - Method in class java.lang. ProcessBuilder
返回此流程构建器的标准输入源。
redirectInput(File) - Method in class java.lang. ProcessBuilder
将此流程构建器的标准输入源设置为文件。
redirectInput(ProcessBuilder.Redirect) - Method in class java.lang. ProcessBuilder
设置此流程构建器的标准输入源。
redirectOutput() - Method in class java.lang. ProcessBuilder
返回此流程构建器的标准输出目标。
redirectOutput(File) - Method in class java.lang. ProcessBuilder
将此流程构建器的标准输出目标设置为文件。
redirectOutput(ProcessBuilder.Redirect) - Method in class java.lang. ProcessBuilder
设置此流程构建器的标准输出目标。
redispatchEvent(Component, AWTEvent) - Method in class java.awt. KeyboardFocusManager
重新分配AWTEvent，AWT事件调度程序将不会递归地请求KeyboardFocusManager或任何已安装的KeyEventDispatchers再次发送事件。
redo() - Method in class javafx.scene.control. TextInputControl
如果可能，重做最后一次修改。
redo() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent
重做一个变化。
redo() - Method in class javax.swing.text. AbstractDocument.ElementEdit
重做一个变化。
redo() - Method in class javax.swing.text. DefaultStyledDocument.AttributeUndoableEdit
重做一个变化。
redo() - Method in class javax.swing.undo. AbstractUndoableEdit
如果 canRedo返回false，则抛出 CannotRedoException 。
redo() - Method in class javax.swing.undo. CompoundEdit
发送 redo到所有包含 UndoableEdit s的添加顺序。
redo() - Method in class javax.swing.undo. StateEdit
告知编辑对象在编辑后应用状态
redo() - Method in interface javax.swing.undo. UndoableEdit
重新应用编辑。
redo() - Method in class javax.swing.undo. UndoManager
重新进行适当的编辑。
REDO - javafx.scene.web. HTMLEditorSkin.Command
redoableProperty() - Method in class javafx.scene.control. TextInputControl
该属性描述如果现在可以重做已撤销的内容的最新更改。
RedoName - Static variable in class javax.swing.undo. AbstractUndoableEdit
字符串返回getRedoPresentationName ; 从Java 2平台v1.3.1开始，此字段不再使用。
redoTo(UndoableEdit) - Method in class javax.swing.undo. UndoManager
将下一次编辑索引的所有更改重新设置为 edit ，适当更新下一次编辑的索引。
reduce(double, DoubleBinaryOperator) - Method in interface java.util.stream. DoubleStream
对该流的元素执行 reduction ，使用提供的身份值和 associative累积函数，并返回减小的值。
reduce(int, IntBinaryOperator) - Method in interface java.util.stream. IntStream
使用提供的身份值和 associative累积功能对此流的元素执行 reduction ，并返回减小的值。
reduce(long, BiFunction<? super K, ? super V, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer将所有（key，value）对的给定变换累加到组合值的结果，如果没有则返回null。
reduce(long, LongBinaryOperator) - Method in interface java.util.stream. LongStream
对该流的元素执行 reduction ，使用提供的身份值和 associative累积函数，并返回减小的值。
reduce(BinaryOperator<T>) - Method in interface java.util.stream. Stream
对此流的元素执行 reduction ，使用 associative累加函数，并返回描述减小值（如果有）的 Optional 。
reduce(DoubleBinaryOperator) - Method in interface java.util.stream. DoubleStream
使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值的 OptionalDouble （如果有）。
reduce(IntBinaryOperator) - Method in interface java.util.stream. IntStream
使用 associative累积功能对此流的元素执行 reduction ，并返回描述减小值（如果有）的 OptionalInt 。
reduce(LongBinaryOperator) - Method in interface java.util.stream. LongStream
使用 associative累积函数对此流的元素执行 reduction ，并返回描述减小值（如果有的话）的 OptionalLong 。
reduce(R, R) - Method in class com.sun.source.util. DocTreeScanner
将两个结果减少为一个组合的结果。
reduce(R, R) - Method in class com.sun.source.util. TreeScanner
将两个结果减少为一个组合的结果。
reduce(T, BinaryOperator<T>) - Method in interface java.util.stream. Stream
对该流的元素执行 reduction ，使用提供的身份值和 associative累积函数，并返回减小的值。
reduce(U, BiFunction<U, ? super T, U>, BinaryOperator<U>) - Method in interface java.util.stream. Stream
使用提供的身份，积累和组合功能，对此流的元素执行 reduction 。
reduceEntries(long, BiFunction<Map.Entry<K, V>, Map.Entry<K, V>, ? extends Map.Entry<K, V>>) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有条目的结果，以组合值，如果没有则返回null。
reduceEntries(long, Function<Map.Entry<K, V>, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer将所有条目的给定变换累加到组合值的结果，否则返回null。
reduceEntriesToDouble(long, ToDoubleFunction<Map.Entry<K, V>>, double, DoubleBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
reduceEntriesToInt(long, ToIntFunction<Map.Entry<K, V>>, int, IntBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
reduceEntriesToLong(long, ToLongFunction<Map.Entry<K, V>>, long, LongBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加给定变换的结果，以组合值，给定基础作为一个标识值。
reduceKeys(long, BiFunction<? super K, ? super K, ? extends K>) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有键的结果，以组合值，如果没有则返回null。
reduceKeys(long, Function<? super K, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer将所有键的给定变换累加到组合值的结果，否则返回null。
reduceKeysToDouble(long, ToDoubleFunction<? super K>, double, DoubleBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
reduceKeysToInt(long, ToIntFunction<? super K>, int, IntBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
reduceKeysToLong(long, ToLongFunction<? super K>, long, LongBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有键的给定变换的结果，以组合值，给定基础作为标识值。
reducePermits(int) - Method in class java.util.concurrent. Semaphore
缩小可用许可证的数量。
reduceToDouble(long, ToDoubleBiFunction<? super K, ? super V>, double, DoubleBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
reduceToInt(long, ToIntBiFunction<? super K, ? super V>, int, IntBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
reduceToLong(long, ToLongBiFunction<? super K, ? super V>, long, LongBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer将所有（key，value）对的给定变换累加到结合值的结果，给定基础作为标识值。
reduceValues(long, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有值的结果，以组合值，如果没有则返回null。
reduceValues(long, Function<? super V, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有值的给定变换以组合值的结果，否则返回null。
reduceValuesToDouble(long, ToDoubleFunction<? super V>, double, DoubleBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
reduceValuesToInt(long, ToIntFunction<? super V>, int, IntBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
reduceValuesToLong(long, ToLongFunction<? super V>, long, LongBinaryOperator) - Method in class java.util.concurrent. ConcurrentHashMap
返回使用给定的reducer累加所有值的给定变换的结果，以组合值，给定基础作为标识值。
reducing(BinaryOperator<T>) - Static method in class java.util.stream. Collectors
返回一个 Collector ，它在指定的 BinaryOperator下执行其输入元素的减少。
reducing(T, BinaryOperator<T>) - Static method in class java.util.stream. Collectors
返回一个 Collector ，它使用提供的身份在指定的 BinaryOperator下执行其输入元素的减少。
reducing(U, Function<? super T, ? extends U>, BinaryOperator<U>) - Static method in class java.util.stream. Collectors
返回一个 Collector ，它在指定的映射函数和 BinaryOperator下执行其输入元素的减少。
ReentrantLock - Class in java.util.concurrent.locks
具有与使用synchronized方法和语句访问的隐式监视锁相同的基本行为和语义的可重入互斥Lock ，但具有扩展功能。
ReentrantLock() - Constructor for class java.util.concurrent.locks. ReentrantLock
创建一个 ReentrantLock的实例。
ReentrantLock(boolean) - Constructor for class java.util.concurrent.locks. ReentrantLock
使用给定的公平政策创建一个 ReentrantLock的实例。
ReentrantReadWriteLock - Class in java.util.concurrent.locks
一个ReadWriteLock的实现支持类似的语义到ReentrantLock 。
ReentrantReadWriteLock() - Constructor for class java.util.concurrent.locks. ReentrantReadWriteLock
创建一个新的 ReentrantReadWriteLock与默认（非空）订购属性。
ReentrantReadWriteLock(boolean) - Constructor for class java.util.concurrent.locks. ReentrantReadWriteLock
创建一个新的 ReentrantReadWriteLock与给定的公平政策。
ReentrantReadWriteLock.ReadLock - Class in java.util.concurrent.locks
方法 ReentrantReadWriteLock.readLock()返回的锁。
ReentrantReadWriteLock.WriteLock - Class in java.util.concurrent.locks
该锁由方法 ReentrantReadWriteLock.writeLock()返回。
ref - Variable in class java.rmi.server. RemoteObject
对象的远程引用。
Ref - Interface in java.sql
SQL编程语言中的映射SQL REF值，它是对数据库中SQL结构化类型值的引用。
REF - java.sql. JDBCType
标识通用SQL类型 REF 。
REF - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REF 。
REF_CURSOR - java.sql. JDBCType
标识通用SQL类型 REF_CURSOR 。
REF_CURSOR - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 REF CURSOR 。
REF_getField - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_getStatic - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_invokeInterface - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_invokeSpecial - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_invokeStatic - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_invokeVirtual - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_MBEAN_NOT_REGISTERED - Static variable in class javax.management.relation. RoleStatus
尝试设置角色值时出现问题类型，包括MBean服务器中未注册的MBean的ObjectName。
REF_MBEAN_OF_INCORRECT_CLASS - Static variable in class javax.management.relation. RoleStatus
尝试设置角色值时出现问题类型，其中包含不是该角色所期望类别的MBean的ObjectName。
REF_newInvokeSpecial - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_putField - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
REF_putStatic - Static variable in interface java.lang.invoke. MethodHandleInfo
一个直接方法句柄参考类，如 table above所定义。
RefAddr - Class in javax.naming
该类表示通信端点的地址。
RefAddr(String) - Constructor for class javax.naming. RefAddr
使用其地址类型构造一个新的RefAddr实例。
reference() - Method in class java.lang.module. ResolvedModule
返回对模块内容的引用。
Reference< T> - Class in java.lang.ref
参考对象的抽象基类。
Reference - Class in javax.naming
此类表示对在命名/目录系统外部找到的对象的引用。
Reference - Interface in javax.xml.crypto.dsig
Reference中定义的 Reference元素的 表示 。
Reference(String) - Constructor for class javax.naming. Reference
为类名为“className”的对象构造一个新的引用。
Reference(String, String, String) - Constructor for class javax.naming. Reference
为类名为“className”的对象以及对象工厂的类名和位置构造一个新引用。
Reference(String, RefAddr) - Constructor for class javax.naming. Reference
为类名为“className”的对象和地址构造一个新引用。
Reference(String, RefAddr, String, String) - Constructor for class javax.naming. Reference
为类名为“className”的对象，对象工厂的类名和位置以及对象的地址构造一个新引用。
REFERENCE - com.sun.source.doctree. DocTree.Kind
用于表示对Java编程语言中的元素的引用的ReferenceTree的实例。
REFERENCE_PARAMETERS - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：WS寻址参考参数。
REFERENCE_SOURCE_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader
<fx：reference>'source'属性。
REFERENCE_TAG - Static variable in class javafx.fxml. FXMLLoader
标签名称为<fx：reference>。
reference_to_id(Object) - Method in interface org.omg.PortableServer. POAOperations
此操作返回由指定引用封装的对象Id值。
reference_to_servant(Object) - Method in interface org.omg.PortableServer. POAOperations
如果POA具有RETAIN策略并且活动对象映射中存在指定的对象，则此操作将返回与活动对象映射中该对象关联的servant。
Referenceable - Interface in javax.naming
该接口由可以为其自身提供引用的对象实现。
referencedClass() - Method in interface com.sun.javadoc. SeeTag
已过时。
获取由@see的类名称引用的类文档。
referencedClassName() - Method in interface com.sun.javadoc. SeeTag
已过时。
获取 @see参考的类或接口名称。
referencedMember() - Method in interface com.sun.javadoc. SeeTag
已过时。
获取 @see引用的字段，构造函数或方法的成员文档。
referencedMemberName() - Method in interface com.sun.javadoc. SeeTag
已过时。
获取 @see参考的字段，构造函数或方法子字符串。
referencedPackage() - Method in interface com.sun.javadoc. SeeTag
已过时。
当 @see仅引用包时，获取包文档。
referenceKindToString(int) - Static method in interface java.lang.invoke. MethodHandleInfo
返回给定参考类型的描述性名称，如 table above中所定义。
referenceParameter(Element) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
将 referenceParameter添加到 W3CEndpointReference实例 wsa:ReferenceParameters元素。
ReferenceQueue< T> - Class in java.lang.ref
在检测到适当的可达性更改后，引用队列被垃圾收集器附加到哪个已注册的参考对象。
ReferenceQueue() - Constructor for class java.lang.ref. ReferenceQueue
构造一个新的引用对象队列。
references() - Method in interface java.io. ObjectInputFilter.FilterInfo
当前对象引用的数量。
ReferenceTree - Interface in com.sun.source.doctree
用于引用Java语言元素的树节点。
referenceType() - Method in interface com.sun.jdi.event. ClassPrepareEvent
返回生成此事件的引用类型。
referenceType() - Method in interface com.sun.jdi. ObjectReference
获取镜像该对象的类型的ReferenceType 。
referenceType(VirtualMachine, String) - Method in class jdk.jshell.execution. JdiExecutionControl
返回对应于指定类名的JDI ReferenceType 。
ReferenceType - Interface in com.sun.jdi
目标虚拟机中对象的类型。
ReferenceType - Interface in javax.lang.model.type
表示参考类型。
ReferenceUriSchemesSupported - Class in javax.print.attribute.standard
Class ReferenceUriSchemesSupported是打印属性类，表示打印机可用于检索存储在URI位置的打印数据的“URI方案”（例如“http：”或“ftp：”）的枚举。
ReferenceUriSchemesSupported(int) - Constructor for class javax.print.attribute.standard. ReferenceUriSchemesSupported
使用给定的整数值构造新的引用URI方案枚举值。
REFERRAL - Static variable in interface javax.naming. Context
持有用于指定如何处理服务提供商遇到的引用的环境属性的名称的常量。
ReferralException - Exception in javax.naming
此抽象类用于表示引用异常，该引用异常是响应于LDAP v3服务器返回的 引用而生成的。
ReferralException() - Constructor for exception javax.naming. ReferralException
构造一个新的ReferralException实例。
ReferralException(String) - Constructor for exception javax.naming. ReferralException
使用提供的说明构造一个新的ReferralException实例。
referringObjects(long) - Method in interface com.sun.jdi. ObjectReference
返回直接引用此对象的对象。
REFLECT - java.awt. MultipleGradientPaint.CycleMethod
循环渐变颜色从头到尾，结束开始填充剩余的区域。
REFLECT - javafx.scene.paint. CycleMethod
定义反映渐变颜色的循环方法，从头到尾，从头到尾，填充剩余的区域。
reflectAs(Class<T>, MethodHandle) - Static method in class java.lang.invoke. MethodHandles
执行 direct method handle的未经检查的“裂纹”。
reflectAs(Class<T>, MethodHandles.Lookup) - Method in interface java.lang.invoke. MethodHandleInfo
将基础成员反映为方法，构造函数或字段对象。
reflectedType() - Method in interface com.sun.jdi. ClassObjectReference
返回与此类对象相对应的ReferenceType 。
Reflection - Class in javafx.scene.effect
将输入的反映版本呈现在实际输入内容之下的效果。
Reflection() - Constructor for class javafx.scene.effect. Reflection
使用默认参数创建一个新的Reflection实例。
Reflection(double, double, double, double) - Constructor for class javafx.scene.effect. Reflection
使用指定的topOffset，fraction，topOpacity和bottomOpacity创建一个新的Reflection实例。
ReflectionException - Exception in javax.management
表示在使用java.lang.reflect类调用MBean方法时，MBean服务器中抛出的异常。
ReflectionException(Exception) - Constructor for exception javax.management. ReflectionException
创建一个 ReflectionException包裹实际的 java.lang.Exception 。
ReflectionException(Exception, String) - Constructor for exception javax.management. ReflectionException
创建一个 ReflectionException ，其中包含实际的 java.lang.Exception和详细消息。
ReflectiveOperationException - Exception in java.lang
核心反射中的反射操作抛出的异常的常见超类。
ReflectiveOperationException() - Constructor for exception java.lang. ReflectiveOperationException
构造一个新的异常，以 null作为其详细消息。
ReflectiveOperationException(String) - Constructor for exception java.lang. ReflectiveOperationException
使用指定的详细消息构造新的异常。
ReflectiveOperationException(String, Throwable) - Constructor for exception java.lang. ReflectiveOperationException
构造一个新的异常与指定的详细信息和原因。
ReflectiveOperationException(Throwable) - Constructor for exception java.lang. ReflectiveOperationException
构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
ReflectPermission - Class in java.lang.reflect
反思操作的权限类。
ReflectPermission(String) - Constructor for class java.lang.reflect. ReflectPermission
构造具有指定名称的ReflectPermission。
ReflectPermission(String, String) - Constructor for class java.lang.reflect. ReflectPermission
构造具有指定名称和操作的ReflectPermission。
refresh() - Method in class com.sun.security.auth.login. ConfigFile
通过重新读取所有登录配置来刷新并重新加载 Configuration 。
refresh() - Method in class com.sun.security.auth. PolicyFile
已过时。
通过重新读取所有策略文件来刷新策略对象。
refresh() - Method in class java.security. Policy
刷新/重新加载策略配置。
refresh() - Static method in class java.time.zone. ZoneRulesProvider
刷新基础数据提供者的规则。
refresh() - Method in class javafx.scene.control. ListView
调用 refresh()强制ListView控件重新创建并重新填充填充控件的可视边界所需的单元格。
refresh() - Method in class javafx.scene.control. TableView
调用 refresh()强制TableView控件重新创建并重新填充填充控件的可视边界所需的单元格。
refresh() - Method in class javafx.scene.control. TreeTableView
调用 refresh()强制TreeTableView控件重新创建并重新填充填充控件的可视边界所需的单元格。
refresh() - Method in class javafx.scene.control. TreeView
调用 refresh()强制TreeView控件重新创建并重新填充填充控件的可视边界所需的单元格。
refresh() - Method in class javax.security.auth.kerberos. KerberosTicket
延长此票的有效期。
refresh() - Method in class javax.security.auth.login. Configuration
刷新并重新加载配置。
refresh() - Method in class javax.security.auth. Policy
已过时。
刷新并重新加载策略。
refresh() - Method in interface javax.security.auth. Refreshable
更新或延长此 Object的有效期。
REFRESH_RATE_UNKNOWN - Static variable in class java.awt. DisplayMode
如果不知道刷新率的值。
Refreshable - Interface in javax.security.auth
诸如凭证的对象可以可选地实现该接口以提供刷新自身的能力。
RefreshFailedException - Exception in javax.security.auth
表示 refresh操作失败。
RefreshFailedException() - Constructor for exception javax.security.auth. RefreshFailedException
构造一个没有详细消息的RefreshFailedException。
RefreshFailedException(String) - Constructor for exception javax.security.auth. RefreshFailedException
构造具有指定详细消息的RefreshFailedException。
refreshRow() - Method in interface java.sql. ResultSet
用数据库中最新的值刷新当前行。
regexFilter(String, int...) - Static method in class javax.swing. RowFilter
返回一个 RowFilter ，它使用正则表达式来确定要包括哪些条目。
REGEXP_LITERAL - jdk.nashorn.api.tree. Tree.Kind
用于RegExpLiteralTree的实例。
RegExpLiteralTree - Interface in jdk.nashorn.api.tree
代表源代码中的正则表达式文字。
region(int, int) - Method in class java.util.regex. Matcher
设置该匹配器区域的限制。
Region - Class in javafx.scene.layout
Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。
Region - Class in javax.swing.plaf.synth
一个不同的渲染区域的Swing组件。
Region() - Constructor for class javafx.scene.layout. Region
创建一个空的背景和空的Border的新区域。
Region(String, String, boolean) - Constructor for class javax.swing.plaf.synth. Region
创建具有指定名称的区域。
regionEnd() - Method in class java.util.regex. Matcher
报告该匹配器区域的最终索引（排他）。
regionMatches(boolean, int, String, int, int) - Method in class java.lang. String
测试两个字符串区域是否相等。
regionMatches(int, String, int, int) - Method in class java.lang. String
测试两个字符串区域是否相等。
regionStart() - Method in class java.util.regex. Matcher
报告该匹配器区域的开始索引。
register() - Method in class java.util.concurrent. Phaser
添加一个新的unririved派对这个移相器。
register(Object, Runnable) - Method in class java.lang.ref. Cleaner
注册一个对象和一个清理动作，以便在对象变为幻像时可以运行。
register(Selector, int) - Method in class java.nio.channels. SelectableChannel
使用给定的选择器注册此频道，返回一个选择键。
register(Selector, int, Object) - Method in class java.nio.channels. SelectableChannel
使用给定的选择器注册此频道，返回一个选择键。
register(Selector, int, Object) - Method in class java.nio.channels.spi. AbstractSelectableChannel
使用给定的选择器注册此频道，返回一个选择键。
register(AbstractSelectableChannel, int, Object) - Method in class java.nio.channels.spi. AbstractSelector
使用此选择器注册给定通道。
register(WatchService, WatchEvent.Kind<?>...) - Method in interface java.nio.file. Path
使用手表服务注册此路径所在的文件。
register(WatchService, WatchEvent.Kind<?>...) - Method in interface java.nio.file. Watchable
用手表服务注册一个对象。
register(WatchService, WatchEvent.Kind<?>[], WatchEvent.Modifier...) - Method in interface java.nio.file. Path
使用手表服务注册此路径所在的文件。
register(WatchService, WatchEvent.Kind<?>[], WatchEvent.Modifier...) - Method in interface java.nio.file. Watchable
用手表服务注册一个对象。
register(ActivationDesc) - Static method in class java.rmi.activation. Activatable
注册可激活的远程对象的对象描述符，以便可以按需激活。
register(Region, String) - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel
使用NimbusLookAndFeel注册第三方组件。
register_initial_reference(String, Object) - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
与 ORB.register_initial_reference相同。
register_policy_factory(int, PolicyFactory) - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
注册一个 PolicyFactory对于给定 PolicyType 。
register_value_factory(String, ValueFactory) - Method in class org.omg.CORBA_2_3. ORB
RegisterableService - Interface in javax.imageio.spi
一个可以由服务提供商对象提供的可以使用 ServiceRegistry注册的 ServiceRegistry 。
registerApplicationClasspathSpis() - Method in class javax.imageio.spi. IIORegistry
注册应用程序类路径中找到的所有可用服务提供商，使用默认值 ClassLoader 。
registerAsParallelCapable() - Static method in class java.lang. ClassLoader
注册呼叫者为 parallel capable 。
registerChangeListener(ObservableValue<?>, Consumer<ObservableValue<?>>) - Method in class javafx.scene.control. SkinBase
子类可以调用此方法来注册他们想要监听给定属性的属性更改事件。
registerComponent(JComponent) - Method in class javax.swing. ToolTipManager
注册一个用于工具提示管理的组件。
registerDriver(Driver) - Static method in class java.sql. DriverManager
使用 DriverManager注册给定的驱动程序。
registerDriver(Driver, DriverAction) - Static method in class java.sql. DriverManager
使用 DriverManager注册给定的驱动程序。
registerEditor(Class<?>, Class<?>) - Static method in class java.beans. PropertyEditorManager
注册编辑器类来编辑给定目标类的值。
registerEditorKitForContentType(String, String) - Static method in class javax.swing. JEditorPane
建立 type的默认绑定为 classname 。
registerEditorKitForContentType(String, String, ClassLoader) - Static method in class javax.swing. JEditorPane
建立 type的默认绑定为 classname 。
registerEngineExtension(String, ScriptEngineFactory) - Method in class javax.script. ScriptEngineManager
注册一个 ScriptEngineFactory来处理扩展。
registerEngineMimeType(String, ScriptEngineFactory) - Method in class javax.script. ScriptEngineManager
注册一个 ScriptEngineFactory来处理一个MIME类型。
registerEngineName(String, ScriptEngineFactory) - Method in class javax.script. ScriptEngineManager
注册一个 ScriptEngineFactory来处理一个语言名称。
registerFont(Font) - Method in class java.awt. GraphicsEnvironment
注册一个 创建 Font在这个 GraphicsEnvironment 。
registerGroup(ActivationGroupDesc) - Method in interface java.rmi.activation. ActivationSystem
注册激活组。
registerKeyboardAction(ActionListener, String, KeyStroke, int) - Method in class javax.swing. JComponent
此方法现已过时，请使用 getActionMap()和 getInputMap()的组合进行类似的操作。
registerKeyboardAction(ActionListener, KeyStroke, int) - Method in class javax.swing. JComponent
此方法现已过时，请使用 getActionMap()和 getInputMap()的组合进行类似的操作。
registerKeyboardActions() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
注册键盘操作。
registerListeners() - Method in class java.awt.dnd. DragGestureRecognizer
注册该DragGestureRecognizer的Listeners与Component子类必须覆盖此方法
registerListeners() - Method in class java.awt.dnd. MouseDragGestureRecognizer
使用组件注册此DragGestureRecognizer的侦听器
registerMBean(Object, ObjectName) - Method in interface javax.management. MBeanServer
使用MBean服务器将一个预先存在的对象注册为MBean。
registerObject(ActivationDesc) - Method in interface java.rmi.activation. ActivationSystem
registerObject方法用于注册激活描述符 desc ，并获得可激活远程对象的激活标识符。
registerOutParameter(int, int) - Method in interface java.sql. CallableStatement
将序号 parameterIndex的OUT参数注册到JDBC类型 sqlType 。
registerOutParameter(int, int, int) - Method in interface java.sql. CallableStatement
将序号 parameterIndex的参数注册为JDBC类型 sqlType 。
registerOutParameter(int, int, String) - Method in interface java.sql. CallableStatement
注册指定的输出参数。
registerOutParameter(int, SQLType) - Method in interface java.sql. CallableStatement
将序号 parameterIndex的OUT参数注册到JDBC类型 sqlType 。
registerOutParameter(int, SQLType, int) - Method in interface java.sql. CallableStatement
将序号 parameterIndex的参数注册为JDBC类型 sqlType 。
registerOutParameter(int, SQLType, String) - Method in interface java.sql. CallableStatement
注册指定的输出参数。
registerOutParameter(String, int) - Method in interface java.sql. CallableStatement
将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。
registerOutParameter(String, int, int) - Method in interface java.sql. CallableStatement
将名称为 parameterName的参数注册为JDBC类型 sqlType 。
registerOutParameter(String, int, String) - Method in interface java.sql. CallableStatement
注册指定的输出参数。
registerOutParameter(String, SQLType) - Method in interface java.sql. CallableStatement
将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。
registerOutParameter(String, SQLType, int) - Method in interface java.sql. CallableStatement
将名称为 parameterName的参数注册为JDBC类型 sqlType 。
registerOutParameter(String, SQLType, String) - Method in interface java.sql. CallableStatement
注册指定的输出参数。
registerProvider(String) - Static method in class javax.sql.rowset.spi. SyncFactory
将给定的同步提供程序添加到工厂注册表。
registerProvider(ZoneRulesProvider) - Static method in class java.time.zone. ZoneRulesProvider
注册一个区域规则提供者。
registerService(PrintService) - Static method in class javax.print. PrintServiceLookup
允许应用程序直接注册实现打印服务的类的实例。
registerServiceProvider(Object) - Method in class javax.imageio.spi. ServiceRegistry
将服务提供者对象添加到注册表。
registerServiceProvider(PrintServiceLookup) - Static method in class javax.print. PrintServiceLookup
允许应用程序显式注册实现查找服务的类。
registerServiceProvider(T, Class<T>) - Method in class javax.imageio.spi. ServiceRegistry
将服务提供者对象添加到注册表。
registerServiceProviders(Iterator<?>) - Method in class javax.imageio.spi. ServiceRegistry
添加一组服务提供者对象，从一个 Iterator到注册表。
registerStaticAttributeKey(Object) - Static method in class javax.swing.text. StyleContext
将对象注册为作为属性集中的键的静态对象。
registerSubclass(Class<?>) - Static method in class java.awt. AWTKeyStroke
已过时。
registerTag(HTML.Tag, HTMLDocument.HTMLReader.TagAction) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader
注册给定标签的处理程序。
registerTarget(Tie, Remote) - Static method in class javax.rmi.CORBA. Util
注册一个领带的目标。
registerTarget(Tie, Remote) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 。
registerValidation(ObjectInputValidation, int) - Method in class java.io. ObjectInputStream
在返回图之前注册要验证的对象。
REGISTRATION_NOTIFICATION - Static variable in class javax.management. MBeanServerNotification
通知类型表示MBean已被注册。
Registry - Interface in java.rmi.registry
Registry是一个简单的远程对象注册表的远程接口，提供用于存储和检索与任意字符串名称绑定的远程对象引用的方法。
REGISTRY_ID - Static variable in class java.rmi.server. ObjID
对象编号为着名的 ObjID注册表。
REGISTRY_PORT - Static variable in interface java.rmi.registry. Registry
众所周知的注册端口。
RegistryHandler - Interface in java.rmi.registry
已过时。
没有替换
registryImpl(int) - Method in interface java.rmi.registry. RegistryHandler
已过时。
没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler来获取注册表的实现。
registryStub(String, int) - Method in interface java.rmi.registry. RegistryHandler
已过时。
没有替换。 从Java 2平台v1.2起，RMI不再使用RegistryHandler获取注册表的存根。
REGULAR - javafx.scene.text. FontPosture
代表常规。
rehash() - Method in class java.util. Hashtable
增加这个散列表的内部重组能力，从而更有效地适应和访问其条目。
rehash() - Method in class java.util. Properties
reinitialize() - Method in class java.util.concurrent. ForkJoinTask
重置此任务的内部簿记状态，允许随后的 fork 。
REJANG - java.lang. Character.UnicodeScript
Unicode脚本“Rejang”。
REJANG - Static variable in class java.lang. Character.UnicodeBlock
“Rejang”Unicode字符块的常量。
REJECT_EXTENDED_RANGES - java.util. Locale.FilteringMode
指定基本过滤：如果任何扩展语言范围包含在给定的语言优先级列表中，列表将被拒绝，过滤方法将抛出IllegalArgumentException 。
rejectDrag() - Method in class java.awt.dnd. DropTargetContext
拒绝拖动。
rejectDrag() - Method in class java.awt.dnd. DropTargetDragEvent
由于检查了 dropAction或可用的 DataFlavor类型，因此拒绝拖动。
rejectDrop() - Method in class java.awt.dnd. DropTargetContext
呼吁说这个下降是不能接受的。
rejectDrop() - Method in class java.awt.dnd. DropTargetDropEvent
拒绝掉落。
REJECTED - java.io. ObjectInputFilter.Status
状态被拒绝。
REJECTED - jdk.jshell. Snippet.Status
代码片段无效，因为初始评估时编译失败，并且无法进一步更改JShell状态。
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in interface java.util.concurrent. RejectedExecutionHandler
ThreadPoolExecutor当execute无法接受任务时可能调用的方法。
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent. ThreadPoolExecutor.AbortPolicy
总是抛出RejectedExecutionException。
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent. ThreadPoolExecutor.CallerRunsPolicy
执行调用者线程中的任务r，除非执行程序已经被关闭，否则任务被丢弃。
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent. ThreadPoolExecutor.DiscardOldestPolicy
获取并忽略执行者否则将执行的下一个任务，如果一个可以立即可用，然后重试任务r的执行，除非执行程序关闭，否则任务r被替换为丢弃。
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent. ThreadPoolExecutor.DiscardPolicy
什么也没有，具有丢弃任务r的效果。
RejectedExecutionException - Exception in java.util.concurrent
当一个任务不能接受执行时，由一个Executor抛出的异常。
RejectedExecutionException() - Constructor for exception java.util.concurrent. RejectedExecutionException
构造一个没有详细消息的 RejectedExecutionException 。
RejectedExecutionException(String) - Constructor for exception java.util.concurrent. RejectedExecutionException
构造具有指定详细消息的 RejectedExecutionException 。
RejectedExecutionException(String, Throwable) - Constructor for exception java.util.concurrent. RejectedExecutionException
构造一个具有指定的详细信息和原因的 RejectedExecutionException 。
RejectedExecutionException(Throwable) - Constructor for exception java.util.concurrent. RejectedExecutionException
构造具有指定原因的 RejectedExecutionException 。
RejectedExecutionHandler - Interface in java.util.concurrent
一个ThreadPoolExecutor无法执行的任务的处理程序。
rejectedSetBCOnce - Variable in class java.beans.beancontext. BeanContextChildSupport
指示为尝试的setBeanContext操作抛出至少一个 PropertyChangeVetoException的标志。
REL - Static variable in class javax.swing.text.html. HTML.Attribute
属性“rel”
RELATED - javax.swing. LayoutStyle.ComponentPlacement
指示两个组件的枚举值在视觉上相关，并将放置在同一个父项中。
Relation - Interface in javax.management.relation
该接口必须由任何MBean类实现，期望代表使用关系服务管理的关系。
RELATION_BASIC_CREATION - Static variable in class javax.management.relation. RelationNotification
键入用于创建内部关系。
RELATION_BASIC_REMOVAL - Static variable in class javax.management.relation. RelationNotification
从关系服务中删除内部关系的类型。
RELATION_BASIC_UPDATE - Static variable in class javax.management.relation. RelationNotification
输入内部关系的更新。
RELATION_MBEAN_CREATION - Static variable in class javax.management.relation. RelationNotification
键入添加到关系服务中的MBean关系。
RELATION_MBEAN_REMOVAL - Static variable in class javax.management.relation. RelationNotification
键入从关系MBean的关系服务中删除。
RELATION_MBEAN_UPDATE - Static variable in class javax.management.relation. RelationNotification
键入更新关系MBean。
RelationException - Exception in javax.management.relation
这个类是在关系管理期间可以提出的任何异常的超类。
RelationException() - Constructor for exception javax.management.relation. RelationException
默认构造函数，没有消息放在异常中。
RelationException(String) - Constructor for exception javax.management.relation. RelationException
具有给定消息的构造方法放在异常中。
RelationNotFoundException - Exception in javax.management.relation
当关系服务中的给定关系ID没有关系时，会引发此异常。
RelationNotFoundException() - Constructor for exception javax.management.relation. RelationNotFoundException
默认构造函数，没有消息放在异常中。
RelationNotFoundException(String) - Constructor for exception javax.management.relation. RelationNotFoundException
具有给定消息的构造方法放在异常中。
RelationNotification - Class in javax.management.relation
关系服务变更通知。
RelationNotification(String, Object, long, long, String, String, String, ObjectName, String, List<ObjectName>, List<ObjectName>) - Constructor for class javax.management.relation. RelationNotification
为关系中的角色更新创建通知。
RelationNotification(String, Object, long, long, String, String, String, ObjectName, List<ObjectName>) - Constructor for class javax.management.relation. RelationNotification
创建关系创建（RelationSupport对象在关系服务内部创建的，或作为关系添加的MBean）或关系删除关系服务的通知。
relations - Variable in class javax.accessibility. AccessibleRelationSet
Vector每个条目代表一个 AccessibleRelation 。
RelationService - Class in javax.management.relation
关系服务负责创建和删除关系类型和关系，处理一致性和提供查询机制。
RelationService(boolean) - Constructor for class javax.management.relation. RelationService
构造函数。
RelationServiceMBean - Interface in javax.management.relation
关系服务负责创建和删除关系类型和关系，处理一致性和提供查询机制。
RelationServiceNotRegisteredException - Exception in javax.management.relation
当对关系服务进行访问并且没有注册时，会引发此异常。
RelationServiceNotRegisteredException() - Constructor for exception javax.management.relation. RelationServiceNotRegisteredException
默认构造函数，没有消息放在异常中。
RelationServiceNotRegisteredException(String) - Constructor for exception javax.management.relation. RelationServiceNotRegisteredException
具有给定消息的构造方法放在异常中。
RelationSupport - Class in javax.management.relation
RelationSupport对象由Relation Service内部使用，用于表示任意关系类型的简单关系（仅角色，无属性或方法）以及无限数量的角色。
RelationSupport(String, ObjectName, String, RoleList) - Constructor for class javax.management.relation. RelationSupport
创建一个 RelationSupport对象。
RelationSupport(String, ObjectName, MBeanServer, String, RoleList) - Constructor for class javax.management.relation. RelationSupport
创建一个 RelationSupport对象。
RelationSupportMBean - Interface in javax.management.relation
RelationSupport对象由Relation Service内部使用，用于表示任意关系类型的简单关系（仅角色，无属性或方法）以及无限数量的角色。
RelationType - Interface in javax.management.relation
RelationType接口必须由预期表示关系类型的任何类来实现。
RelationTypeNotFoundException - Exception in javax.management.relation
当在关系服务中没有给定名称的关系类型时，引发异常。
RelationTypeNotFoundException() - Constructor for exception javax.management.relation. RelationTypeNotFoundException
默认构造函数，没有消息放在异常中。
RelationTypeNotFoundException(String) - Constructor for exception javax.management.relation. RelationTypeNotFoundException
具有给定消息的构造方法放在异常中。
RelationTypeSupport - Class in javax.management.relation
RelationTypeSupport对象实现RelationType接口。
RelationTypeSupport(String) - Constructor for class javax.management.relation. RelationTypeSupport
构造器用于子类。
RelationTypeSupport(String, RoleInfo[]) - Constructor for class javax.management.relation. RelationTypeSupport
所有角色定义都被动态创建并作为参数传递的构造方法。
relative(int) - Method in interface java.sql. ResultSet
将光标移动到正或负的相对行数。
RELATIVE - Static variable in class java.awt. GridBagConstraints
指定此组件是下一个到最后一个组件在其行或列（ gridwidth ， gridheight ），或者该组分被旁边的以前添加的组件（放置 gridx ， gridy ）。
RELATIVE_PATH_PREFIX - Static variable in class javafx.fxml. FXMLLoader
前缀相对位置解析。
relativeCCW(double, double) - Method in class java.awt.geom. Line2D
返回指定点 (px,py)相对于该线段所在的位置的 (px,py) 。
relativeCCW(double, double, double, double, double, double) - Static method in class java.awt.geom. Line2D
返回指定点 (px,py)相对于从 (x1,y1)到 (x2,y2)线段的 (x1,y1)的 (x2,y2) 。
relativeCCW(Point2D) - Method in class java.awt.geom. Line2D
返回相对于该线段指定 Point2D所在位置的指示符。
relativize(URI) - Method in class java.net. URI
相对于此URI的给定URI。
relativize(Path) - Method in interface java.nio.file. Path
构造此路径和给定路径之间的相对路径。
RELAXNG_NS_URI - Static variable in class javax.xml. XMLConstants
RELAX NG命名空间URI。
release() - Method in class java.nio.channels. FileLock
释放这个锁
release() - Method in class java.util.concurrent. Semaphore
释放许可证，将其返回到信号量。
release() - Method in interface javax.sql.rowset. CachedRowSet
发布此 CachedRowSet对象的当前内容，并向所有注册的监听器发送一个 rowSetChanged事件。
release(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
以专属模式发布。
release(int) - Method in class java.util.concurrent. Semaphore
释放给定数量的许可证，将其返回到信号量。
release(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
以专属模式发布。
release(ByteBuffer) - Method in interface java.lang.module. ModuleReader
释放一个字节缓冲区。
release(Object) - Method in class org.omg.CORBA.portable. Delegate
释放与提供的对象引用相关联的资源。
RELEASE_0 - javax.lang.model. SourceVersion
原版。
RELEASE_1 - javax.lang.model. SourceVersion
Java Platform 1.1认可的版本。
RELEASE_2 - javax.lang.model. SourceVersion
由Java 2 Platform，Standard Edition v 1.2认可的版本。
RELEASE_3 - javax.lang.model. SourceVersion
由Java 2 Platform，Standard Edition，v 1.3认可的版本。
RELEASE_4 - javax.lang.model. SourceVersion
由Java 2 Platform，Standard Edition v 1.4认可的版本。
RELEASE_5 - javax.lang.model. SourceVersion
由Java 2 Platform，Standard Edition 5.0认可的版本。
RELEASE_6 - javax.lang.model. SourceVersion
Java Platform，Standard Edition 6认可的版本。
RELEASE_7 - javax.lang.model. SourceVersion
由Java Platform标准版7认可的版本。
RELEASE_8 - javax.lang.model. SourceVersion
Java Platform标准版8认可的版本。
RELEASE_9 - javax.lang.model. SourceVersion
Java Platform，Standard Edition 9认可的版本。
releaseBeanContextResources() - Method in class java.beans.beancontext. BeanContextChildSupport
这个方法可能被子类覆盖，以提供自己的释放行为。
releaseBeanContextResources() - Method in class java.beans.beancontext. BeanContextServicesSupport
从setBeanContext调用，以通知BeanContextChild释放从嵌套BeanContext获取的资源。
RELEASED - javafx.scene.input. TouchPoint.State
接触点已被释放
releaseFence() - Static method in class java.lang.invoke. VarHandle
确保栅栏之前的货物和商店在栅栏后不会与商店重新排序。
releaseInputStream() - Method in interface java.rmi.server. RemoteCall
已过时。
没有替换
releaseMBeanServer(MBeanServer) - Static method in class javax.management. MBeanServerFactory
删除对创建的MBeanServer的内部MBeanServerFactory引用。
releaseOutputStream() - Method in interface java.rmi.server. RemoteCall
已过时。
没有替换
releaseReply(Object, InputStream) - Method in class org.omg.CORBA.portable. Delegate
releaseReply可以可选地被存根调用以在解组合完成时将回复流释放回ORB。
releaseSavepoint(Savepoint) - Method in interface java.sql. Connection
从当前事务中删除指定的 Savepoint和后续的 Savepoint对象。
releaseService(BeanContextChild, Object, Object) - Method in interface java.beans.beancontext. BeanContextServices
通过调用底层 BeanContextServiceProvider上的releaseService（），释放一个 BeanContextChild （或任何与BeanContextChild关联的任意对象）对指定服务的 BeanContextServiceProvider 。
releaseService(BeanContextChild, Object, Object) - Method in class java.beans.beancontext. BeanContextServicesSupport
发布服务
releaseService(BeanContextServices, Object, Object) - Method in interface java.beans.beancontext. BeanContextServiceProvider
该方法由 BeanContextServices调用，释放嵌套的 BeanContextChild （或任何与 BeanContextChild相关联的任意对象）对指定服务的引用。
releaseService(BeanContextServices, Object, Object) - Method in class java.beans.beancontext. BeanContextServicesSupport.BCSSProxyServiceProvider
releaseShared(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer
以共享模式发布。
releaseShared(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer
以共享模式发布。
releaseWritableTile(int, int) - Method in class java.awt.image. BufferedImage
放弃写入瓦片的权限。
releaseWritableTile(int, int) - Method in interface java.awt.image. WritableRenderedImage
放弃写入瓦片的权利。
relink(GuardedInvocation, MethodHandle) - Method in interface jdk.dynalink. RelinkableCallSite
每次调用站点重新链接时，动态链接器都会调用此方法（但是有关异常，请参阅 RelinkableCallSite.resetAndRelink(GuardedInvocation, MethodHandle) ）。
relink(GuardedInvocation, MethodHandle) - Method in class jdk.dynalink.support. ChainedCallSite
relink(GuardedInvocation, MethodHandle) - Method in class jdk.dynalink.support. SimpleRelinkableCallSite
RelinkableCallSite - Interface in jdk.dynalink
由DynamicLinker管理的呼叫站点接口。
reload() - Method in class java.util. ServiceLoader
清除此加载程序的提供程序缓存，以便所有提供程序都将被重新加载。
reload() - Method in class javafx.scene.web. WebEngine
重新加载当前页面，无论是从URL加载还是直接从 loadContent方法中的一个字符串加载。
reload() - Method in class javax.swing.tree. DefaultTreeModel
如果您修改了该型号所依赖的 TreeNode秒，则调用此方法。
reload(TreeNode) - Method in class javax.swing.tree. DefaultTreeModel
如果您修改了该型号所依赖的 TreeNode则调用此方法。
relocate(double, double) - Method in class javafx.scene. Node
设置节点的layoutX和layoutY转换属性，以便将该节点重定位到父节点的x，y位置。
remainder(BigDecimal) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this % divisor) 。
remainder(BigDecimal, MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal ，其值是 (this % divisor) ，根据上下文设置进行舍入。
remainder(BigInteger) - Method in class java.math. BigInteger
返回值为 (this % val)的BigInteger。
REMAINDER - com.sun.source.tree. Tree.Kind
用于表示剩余部分%的BinaryTree的实例。
REMAINDER - jdk.nashorn.api.tree. Tree.Kind
用于代表%的BinaryTree的实例。
REMAINDER - Static variable in class java.awt. GridBagConstraints
指定此组件是其列或行中的最后一个组件。
REMAINDER_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于表示剩余分配%=的CompoundAssignmentTree的实例。
REMAINDER_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于表示剩余分配%=的CompoundAssignmentTree的实例。
remainderUnsigned(int, int) - Static method in class java.lang. Integer
返回无符号余数，将第一个参数除以秒，其中每个参数和结果被解释为无符号值。
remainderUnsigned(long, long) - Static method in class java.lang. Long
返回无符号余数，将第一个参数除以秒，其中每个参数和结果被解释为无符号值。
remaining() - Method in class java.nio. Buffer
返回当前位置和限制之间的元素数。
remaining() - Method in interface jdk.jshell. SourceCodeAnalysis.CompletionInfo
完整部分源后输入剩余。
REMAINING - Static variable in class javafx.scene.layout. GridPane
可以在子行的行/列跨度约束上设置Sentinel值，以指示它应该跨剩余的行/列。
remainingCapacity() - Method in class java.util.concurrent. ArrayBlockingQueue
返回此队列可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。
remainingCapacity() - Method in interface java.util.concurrent. BlockingQueue
返回此队列可以理想地（在没有内存或资源约束的情况下）接受而不阻止的附加元素数，如果没有内在限制则 Integer.MAX_VALUE 。
remainingCapacity() - Method in class java.util.concurrent. DelayQueue
始终返回 Integer.MAX_VALUE因为 DelayQueue不受容量限制。
remainingCapacity() - Method in class java.util.concurrent. LinkedBlockingDeque
返回此deque可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。
remainingCapacity() - Method in class java.util.concurrent. LinkedBlockingQueue
返回此队列可以理想地（在没有内存或资源限制）的情况下接受而不阻止的附加元素数。
remainingCapacity() - Method in class java.util.concurrent. LinkedTransferQueue
始终返回 Integer.MAX_VALUE因为 LinkedTransferQueue不受容量限制。
remainingCapacity() - Method in class java.util.concurrent. PriorityBlockingQueue
始终返回 Integer.MAX_VALUE因为 PriorityBlockingQueue不受容量限制。
remainingCapacity() - Method in class java.util.concurrent. SynchronousQueue
始终返回零。
remainingName - Variable in exception javax.naming. NamingException
包含尚未解决的剩余名称。
remainingName - Variable in class javax.naming.spi. ResolveResult
包含剩余名称的字段尚待解决。
remainingNewName - Variable in exception javax.naming. CannotProceedException
包含Context.rename（）的第二个“name”参数的剩余未解决部分。
remapInstrument(Instrument, Instrument) - Method in interface javax.sound.midi. Synthesizer
重新配置仪器。
RemarshalException - Exception in org.omg.CORBA.portable
该类用于将向前的异常和对象前向GIOP消息定位回ORB。
RemarshalException() - Constructor for exception org.omg.CORBA.portable. RemarshalException
构造RemarshalException。
Remote - Interface in java.rmi
Remote接口用于标识可以从非本地虚拟机调用其方法的接口。
REMOTE - java.awt.desktop. UserSessionEvent.Reason
会话已连接/断开连接到远程终端。
RemoteCall - Interface in java.rmi.server
已过时。
没有替换。
remoteEquals(RemoteRef) - Method in interface java.rmi.server. RemoteRef
比较两个远程对象的相等性。
RemoteException - Exception in java.rmi
A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
RemoteException() - Constructor for exception java.rmi. RemoteException
构造一个 RemoteException 。
RemoteException(String) - Constructor for exception java.rmi. RemoteException
构造具有指定详细消息的 RemoteException 。
RemoteException(String, Throwable) - Constructor for exception java.rmi. RemoteException
构造一个具有指定的详细信息和原因的 RemoteException 。
RemoteExecutionControl - Class in jdk.jshell.execution
远程代理在执行过程中运行（与主JShell进程分开）。
RemoteExecutionControl() - Constructor for class jdk.jshell.execution. RemoteExecutionControl
使用默认的类加载创建一个实例。
RemoteExecutionControl(LoaderDelegate) - Constructor for class jdk.jshell.execution. RemoteExecutionControl
创建一个实例，将加载器操作委派给指定的委托。
remoteHashCode() - Method in interface java.rmi.server. RemoteRef
返回一个远程对象的哈希码。
remoteInputOutput(InputStream, OutputStream, Map<String, OutputStream>, Map<String, InputStream>, BiFunction<ObjectInput, ObjectOutput, ExecutionControl>) - Static method in class jdk.jshell.execution. Util
为给定的分组化输入和输出创建一个ExecutionControl。
RemoteObject - Class in java.rmi.server
RemoteObject类实现了远程对象的 java.lang.Object行为。
RemoteObject() - Constructor for class java.rmi.server. RemoteObject
创建一个远程对象。
RemoteObject(RemoteRef) - Constructor for class java.rmi.server. RemoteObject
创建一个远程对象，使用指定的远程引用进行初始化。
RemoteObjectInvocationHandler - Class in java.rmi.server
用于Java Remote Method Invocation（Java RMI）的 InvocationHandler接口的实现。
RemoteObjectInvocationHandler(RemoteRef) - Constructor for class java.rmi.server. RemoteObjectInvocationHandler
创建一个新的 RemoteObjectInvocationHandler构造与指定的 RemoteRef 。
RemoteRef - Interface in java.rmi.server
RemoteRef表示远程对象的句柄。
RemoteServer - Class in java.rmi.server
RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。
RemoteServer() - Constructor for class java.rmi.server. RemoteServer
构造一个 RemoteServer 。
RemoteServer(RemoteRef) - Constructor for class java.rmi.server. RemoteServer
构造具有给定参考类型的 RemoteServer 。
RemoteStub - Class in java.rmi.server
已过时。
静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
RemoteStub() - Constructor for class java.rmi.server. RemoteStub
已过时。
构造一个 RemoteStub 。
RemoteStub(RemoteRef) - Constructor for class java.rmi.server. RemoteStub
已过时。
使用指定的远程引用构造一个 RemoteStub 。
remoteToString() - Method in interface java.rmi.server. RemoteRef
返回一个表示此远程对象引用的字符串。
remoteVMOptions(String...) - Method in class jdk.jshell. JShell.Builder
设置启动VM的其他VM选项。
REMOVAL - Static variable in interface org.w3c.dom.events. MutationEvent
Attr刚刚被删除。
remove() - Method in interface com.sun.jdi.event. EventQueue
等待下一个可用的事件永远。
remove() - Method in class java.beans.beancontext. BeanContextSupport.BCSIterator
remove() - Method in class java.lang.ref. ReferenceQueue
删除此队列中的下一个参考对象，阻塞直到可用。
remove() - Method in class java.lang. ThreadLocal
删除此线程局部变量的当前线程的值。
remove() - Method in class java.util. AbstractQueue
检索并删除此队列的头。
remove() - Method in class java.util. ArrayDeque
检索并删除由此deque表示的队列的头部。
remove() - Method in interface java.util.concurrent. BlockingDeque
检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
remove() - Method in class java.util.concurrent. ConcurrentLinkedDeque
remove() - Method in class java.util.concurrent. LinkedBlockingDeque
检索并删除由此deque表示的队列的头部。
remove() - Method in interface java.util. Deque
检索并删除由此deque表示的队列的头部（换句话说，该deque的第一个元素）。
remove() - Method in interface java.util. Iterator
从底层集合中删除此迭代器返回的最后一个元素（可选操作）。
remove() - Method in class java.util. LinkedList
检索并删除此列表的头（第一个元素）。
remove() - Method in interface java.util. ListIterator
从列表中删除 ListIterator.next()或 ListIterator.previous()返回的最后一个元素（可选操作）。
remove() - Method in interface java.util. Queue
检索并删除此队列的头。
remove() - Method in class java.util. Scanner
Iterator的此实现不支持删除操作。
remove() - Method in class javax.xml.stream.util. EventReaderDelegate
remove(int) - Method in class java.awt. Choice
从指定位置的选择菜单中删除一个项目。
remove(int) - Method in class java.awt. Container
从此容器中删除由 index指定的组件。
remove(int) - Method in class java.awt. List
从此滚动列表中移除指定位置的项目。
remove(int) - Method in class java.awt. Menu
从此菜单中删除指定索引处的菜单项。
remove(int) - Method in class java.awt. MenuBar
从此菜单栏中删除位于指定索引处的菜单。
remove(int) - Method in class java.util. AbstractList
删除该列表中指定位置的元素（可选操作）。
remove(int) - Method in class java.util. AbstractSequentialList
删除该列表中指定位置的元素（可选操作）。
remove(int) - Method in class java.util. ArrayList
删除该列表中指定位置的元素。
remove(int) - Method in class java.util.concurrent. CopyOnWriteArrayList
删除该列表中指定位置的元素。
remove(int) - Method in class java.util. LinkedList
删除该列表中指定位置的元素。
remove(int) - Method in interface java.util. List
删除该列表中指定位置的元素（可选操作）。
remove(int) - Method in class java.util. Vector
删除此向量中指定位置的元素。
remove(int) - Method in class javafx.beans.binding. ListExpression
remove(int) - Method in class javafx.collections. ModifiableObservableListBase
remove(int) - Method in class javax.naming. CompositeName
从此复合名称中删除组件。
remove(int) - Method in class javax.naming. CompoundName
从此化合物名称中删除组件。
remove(int) - Method in interface javax.naming.directory. Attribute
从有序的属性值列表中删除属性值。
remove(int) - Method in class javax.naming.directory. BasicAttribute
remove(int) - Method in class javax.naming.ldap. LdapName
从此LDAP名称中删除组件。
remove(int) - Method in interface javax.naming. Name
从此名称中删除组件。
remove(int) - Method in class javax.naming. Reference
从地址列表中删除索引posn上的地址。
remove(int) - Method in class javax.swing. DefaultListModel
删除该列表中指定位置的元素。
remove(int) - Method in class javax.swing. JDesktopPane
从此窗格中删除索引的组件。
remove(int) - Method in class javax.swing. JLayeredPane
从此窗格中删除索引的组件。
remove(int) - Method in class javax.swing. JMenu
从此菜单中删除指定索引处的菜单项。
remove(int) - Method in class javax.swing. JPopupMenu
从该弹出菜单中删除指定索引处的组件。
remove(int) - Method in class javax.swing. JSplitPane
删除指定索引的 Component 。
remove(int) - Method in class javax.swing. JTabbedPane
删除与指定索引对应的选项卡和组件。
remove(int) - Method in class javax.swing.text. View
移除给定位置上的一个孩子。
remove(int) - Method in class javax.swing.tree. DefaultMutableTreeNode
从该节点的子节点删除指定索引处的子节点，并将该节点的父节点设置为null。
remove(int) - Method in interface javax.swing.tree. MutableTreeNode
从接收器中删除 index的孩子。
remove(int) - Method in class org.omg.CORBA. ContextList
删除给定索引处的 String对象。
remove(int) - Method in class org.omg.CORBA. ExceptionList
删除给定索引处的 TypeCode对象。
remove(int) - Method in class org.omg.CORBA. NVList
删除给定索引处的 NamedValue对象。
remove(int) - Method in interface org.w3c.dom.html. HTMLSelectElement
从这个 SELECT的 OPTION元素的集合中删除一个元素。
remove(int, int) - Method in class javafx.beans.binding. ListExpression
remove(int, int) - Method in interface javafx.collections. ObservableList
一种调用 sublist(from, to).clear()简化方法。
remove(int, int) - Method in class javafx.collections. ObservableListBase
remove(int, int) - Method in interface javax.swing.text. AbstractDocument.Content
删除序列的一部分。
remove(int, int) - Method in class javax.swing.text. AbstractDocument
从文档中删除一些内容。
remove(int, int) - Method in interface javax.swing.text. Document
删除文档内容的一部分。
remove(int, int) - Method in class javax.swing.text. DocumentFilter.FilterBypass
删除指定的文本区域，绕过DocumentFilter。
remove(int, int) - Method in class javax.swing.text. GapContent
删除部分内容。
remove(int, int) - Method in class javax.swing.text. StringContent
删除部分内容。
remove(int, int, AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer
删除内容
remove(long) - Method in interface com.sun.jdi.event. EventQueue
等待下一个可用事件的指定时间。
remove(long) - Method in class java.lang.ref. ReferenceQueue
删除此队列中的下一个参考对象，阻塞，直到任何一个可用或给定的超时期限到期。
remove(Component) - Method in class java.awt. Container
从此容器中删除指定的组件。
remove(Component) - Method in class javax.swing. JApplet
已过时。
从容器中删除指定的组件。
remove(Component) - Method in class javax.swing. JDesktopPane
从此容器中删除指定的组件。
remove(Component) - Method in class javax.swing. JDialog
从容器中删除指定的组件。
remove(Component) - Method in class javax.swing. JFrame
从容器中删除指定的组件。
remove(Component) - Method in class javax.swing. JInternalFrame
从容器中删除指定的组件。
remove(Component) - Method in class javax.swing. JLayer
从此容器中删除指定的组件。
remove(Component) - Method in class javax.swing. JMenu
从此菜单中删除组件 c 。
remove(Component) - Method in class javax.swing. JSplitPane
从窗格中删除子组件 component 。
remove(Component) - Method in class javax.swing. JTabbedPane
删除指定 Component从 JTabbedPane 。
remove(Component) - Method in class javax.swing. JViewport
删除 Viewport的一个轻量级的孩子。
remove(Component) - Method in class javax.swing. JWindow
从容器中删除指定的组件。
remove(ActionListener, ActionListener) - Static method in class java.awt. AWTEventMulticaster
从action-listener-l中删除旧的action-listener，并返回生成的组播侦听器。
remove(AdjustmentListener, AdjustmentListener) - Static method in class java.awt. AWTEventMulticaster
从调整监听器l中删除旧的调整监听器，并返回结果组播监听器。
remove(ComponentListener, ComponentListener) - Static method in class java.awt. AWTEventMulticaster
从component-listener-l中删除旧的组件侦听器，并返回生成的组播侦听器。
remove(ContainerListener, ContainerListener) - Static method in class java.awt. AWTEventMulticaster
从container-listener-l中删除旧容器监听器，并返回生成的组播侦听器。
remove(FocusListener, FocusListener) - Static method in class java.awt. AWTEventMulticaster
从focus-listener-l中删除旧的focus-listener，并返回生成的组播监听器。
remove(HierarchyBoundsListener, HierarchyBoundsListener) - Static method in class java.awt. AWTEventMulticaster
从hierarchy-bounds-listener-l中删除旧的hierarchy-bounds-listener，并返回生成的组播监听器。
remove(HierarchyListener, HierarchyListener) - Static method in class java.awt. AWTEventMulticaster
从hierarchy-listener-l中删除旧的层次结构监听器，并返回结果组播监听器。
remove(InputMethodListener, InputMethodListener) - Static method in class java.awt. AWTEventMulticaster
从input-method-listener-l中删除旧的输入法侦听器，并返回生成的组播侦听器。
remove(ItemListener, ItemListener) - Static method in class java.awt. AWTEventMulticaster
从item-listener-l中删除旧的项目监听器，并返回生成的组播侦听器。
remove(KeyListener, KeyListener) - Static method in class java.awt. AWTEventMulticaster
从key-listener-l中删除旧的密钥监听器，并返回生成的组播侦听器。
remove(MouseListener, MouseListener) - Static method in class java.awt. AWTEventMulticaster
从mouse-listener-l中删除旧的鼠标监听器，并返回生成的组播侦听器。
remove(MouseMotionListener, MouseMotionListener) - Static method in class java.awt. AWTEventMulticaster
从mouse-motion-listener-l中删除旧的鼠标移动监听器，并返回生成的组播侦听器。
remove(MouseWheelListener, MouseWheelListener) - Static method in class java.awt. AWTEventMulticaster
从mouse-wheel-listener-l中删除旧的鼠标滚轮监听器，并返回生成的组播侦听器。
remove(TextListener, TextListener) - Static method in class java.awt. AWTEventMulticaster
从text-listener-l中删除旧的文本侦听器，并返回生成的组播侦听器。
remove(WindowFocusListener, WindowFocusListener) - Static method in class java.awt. AWTEventMulticaster
从window-focus-listener-l中删除旧的window-focus-listener，并返回结果组播监听器。
remove(WindowListener, WindowListener) - Static method in class java.awt. AWTEventMulticaster
从window-listener-l中删除旧的window-listener，并返回结果组播监听器。
remove(WindowStateListener, WindowStateListener) - Static method in class java.awt. AWTEventMulticaster
从window-state-listener-l中删除旧的window-state-listener，并返回结果组播监听器。
remove(MenuComponent) - Method in class java.awt. Component
从组件中删除指定的弹出菜单。
remove(MenuComponent) - Method in class java.awt. Frame
从此框架中删除指定的菜单栏。
remove(MenuComponent) - Method in class java.awt. Menu
从此菜单中删除指定的菜单项。
remove(MenuComponent) - Method in class java.awt. MenuBar
从此菜单栏中删除指定的菜单组件。
remove(MenuComponent) - Method in interface java.awt. MenuContainer
从菜单中删除指定的菜单组件。
remove(TrayIcon) - Method in class java.awt. SystemTray
删除指定 TrayIcon从 SystemTray 。
remove(Class<?>) - Method in class java.lang. ClassValue
删除给定类的关联值。
remove(Class<?>) - Method in interface javax.print.attribute. AttributeSet
从此属性集中删除此类别的任何属性（如果存在）。
remove(Class<?>) - Method in class javax.print.attribute. HashAttributeSet
从此属性集中删除此类别的任何属性（如果存在）。
remove(Class<? extends EventListener>, EventListener) - Method in class com.sun.java.accessibility.util. AccessibilityListenerList
将侦听器作为指定类型的侦听器删除。
remove(Class<T>, T) - Method in class javax.swing.event. EventListenerList
将侦听器作为指定类型的侦听器删除。
remove(Object) - Method in class com.sun.net.httpserver. Headers
remove(Object) - Method in class java.awt. RenderingHints
从这个 RenderingHints对象中删除键及其对应的值。
remove(Object) - Method in class java.beans.beancontext. BeanContextSupport
从此BeanContext中删除一个小孩。
remove(Object) - Method in class java.beans. Encoder
删除此实例的条目，返回旧条目。
remove(Object) - Method in class java.security. Provider
删除 key属性（及其对应的 value ）。
remove(Object) - Method in class java.util. AbstractCollection
从该集合中删除指定元素的单个实例（如果存在）（可选操作）。
remove(Object) - Method in class java.util. AbstractMap
如果存在（从可选的操作），从该地图中删除一个键的映射。
remove(Object) - Method in class java.util. ArrayDeque
从此deque中删除指定元素的单个实例。
remove(Object) - Method in class java.util. ArrayList
从列表中删除指定元素的第一个出现（如果存在）。
remove(Object) - Method in interface java.util. Collection
从该集合中删除指定元素的单个实例（如果存在）（可选操作）。
remove(Object) - Method in class java.util.concurrent. ArrayBlockingQueue
从该队列中删除指定元素的单个实例（如果存在）。
remove(Object) - Method in interface java.util.concurrent. BlockingDeque
从此deque中删除指定元素的第一个出现。
remove(Object) - Method in interface java.util.concurrent. BlockingQueue
从该队列中删除指定元素的单个实例（如果存在）。
remove(Object) - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView
从该地图视图中删除键，方法是从支持地图中删除该键（及其对应的值）。
remove(Object) - Method in class java.util.concurrent. ConcurrentHashMap
从该地图中删除键（及其对应的值）。
remove(Object) - Method in class java.util.concurrent. ConcurrentLinkedDeque
从此deque中删除指定元素的第一个出现。
remove(Object) - Method in class java.util.concurrent. ConcurrentLinkedQueue
从该队列中删除指定元素的单个实例（如果存在）。
remove(Object) - Method in class java.util.concurrent. ConcurrentSkipListMap
从该地图中删除指定键的映射（如果存在）。
remove(Object) - Method in class java.util.concurrent. ConcurrentSkipListSet
如果存在，则从该集合中删除指定的元素。
remove(Object) - Method in class java.util.concurrent. CopyOnWriteArrayList
从列表中删除指定元素的第一个出现（如果存在）。
remove(Object) - Method in class java.util.concurrent. CopyOnWriteArraySet
如果存在，则从该集合中删除指定的元素。
remove(Object) - Method in class java.util.concurrent. DelayQueue
从该队列中移除指定元素的单个实例（如果存在），无论其是否已过期。
remove(Object) - Method in class java.util.concurrent. LinkedBlockingDeque
从此deque中删除指定元素的第一个出现。
remove(Object) - Method in class java.util.concurrent. LinkedBlockingQueue
从该队列中删除指定元素的单个实例（如果存在）。
remove(Object) - Method in class java.util.concurrent. LinkedTransferQueue
从该队列中删除指定元素的单个实例（如果存在）。
remove(Object) - Method in class java.util.concurrent. PriorityBlockingQueue
从该队列中删除指定元素的单个实例（如果存在）。
remove(Object) - Method in class java.util.concurrent. SynchronousQueue
始终返回 false 。
remove(Object) - Method in interface java.util. Deque
从此deque中删除指定元素的第一个出现。
remove(Object) - Method in class java.util. Dictionary
从该字典中删除 key （及其对应的 value ）。
remove(Object) - Method in class java.util. EnumMap
从该地图中删除此密钥的映射（如果存在）。
remove(Object) - Method in class java.util. HashMap
从该地图中删除指定键的映射（如果存在）。
remove(Object) - Method in class java.util. HashSet
如果存在，则从该集合中删除指定的元素。
remove(Object) - Method in class java.util. Hashtable
从此散列表中删除键（及其对应的值）。
remove(Object) - Method in class java.util. IdentityHashMap
从该地图中删除此密钥的映射（如果存在）。
remove(Object) - Method in class java.util.jar. Attributes
从此Map中删除具有指定名称（键）的属性。
remove(Object) - Method in class java.util. LinkedList
从列表中删除指定元素的第一个出现（如果存在）。
remove(Object) - Method in interface java.util. List
从列表中删除指定元素的第一个出现（如果存在）（可选操作）。
remove(Object) - Method in interface java.util. Map
如果存在（从可选的操作），从该地图中删除一个键的映射。
remove(Object) - Method in class java.util. PriorityQueue
从该队列中删除指定元素的单个实例（如果存在）。
remove(Object) - Method in class java.util. Properties
remove(Object) - Method in interface java.util. Set
如果存在，则从该集合中删除指定的元素（可选操作）。
remove(Object) - Method in class java.util. TreeMap
从此TreeMap中删除此键的映射（如果存在）。
remove(Object) - Method in class java.util. TreeSet
如果存在，则从该集合中删除指定的元素。
remove(Object) - Method in class java.util. Vector
删除此向量中指定元素的第一个出现如果Vector不包含元素，则它不会更改。
remove(Object) - Method in class java.util. WeakHashMap
如果存在，则从该弱散列映射中删除密钥的映射。
remove(Object) - Method in class javafx.beans.binding. ListExpression
remove(Object) - Method in class javafx.beans.binding. MapExpression
remove(Object) - Method in class javafx.beans.binding. SetExpression
remove(Object) - Method in class javafx.collections. ModifiableObservableListBase
remove(Object) - Method in class javax.management.openmbean. TabularDataSupport
这个方法只需调用 remove((Object[]) key) 。
remove(Object) - Method in interface javax.naming.directory. Attribute
从属性中删除指定的值。
remove(Object) - Method in class javax.naming.directory. BasicAttribute
从此属性中删除指定的值。
remove(Object) - Method in interface javax.script. Bindings
如果存在该地图，则从该地图中删除该密钥的映射（可选操作）。
remove(Object) - Method in class javax.script. SimpleBindings
如果存在该地图，则从该地图中删除该密钥的映射（可选操作）。
remove(Object) - Method in class javax.swing. ActionMap
从这个 ActionMap删除 key的绑定。
remove(Object) - Method in class jdk.incubator.http. MultiMapResult
remove(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
remove(Object[]) - Method in interface javax.management.openmbean. TabularData
从 TabularData实例中删除索引为 key的 CompositeData值，并返回已删除的值，如果没有索引为 key的值，则返回 null 。
remove(Object[]) - Method in class javax.management.openmbean. TabularDataSupport
删除 CompositeData值，其指数是从这个 关键 TabularData实例，并返回被移除的值，或返回 null如果没有价值，其指数是 关键 。
remove(Object, boolean) - Method in class java.beans.beancontext. BeanContextSupport
内部删除使用时，由意外的 setBeanContext或 remove()调用引起。
remove(Object, Object) - Method in class java.security. Provider
仅当指定的密钥当前映射到指定的值时删除该条目。
remove(Object, Object) - Method in class java.util.concurrent. ConcurrentHashMap
仅当当前映射到给定值时才删除密钥的条目。
remove(Object, Object) - Method in interface java.util.concurrent. ConcurrentMap
仅当当前映射到给定值时才删除密钥的条目。
remove(Object, Object) - Method in class java.util.concurrent. ConcurrentSkipListMap
仅当当前映射到给定值时才删除密钥的条目。
remove(Object, Object) - Method in class java.util. HashMap
remove(Object, Object) - Method in class java.util. Hashtable
remove(Object, Object) - Method in interface java.util. Map
仅当指定的密钥当前映射到指定的值时删除该条目。
remove(Object, Object) - Method in class java.util. Properties
remove(Runnable) - Method in class java.util.concurrent. ThreadPoolExecutor
如果此任务存在，则从执行程序的内部队列中删除此任务，从而导致该任务尚未运行。
remove(String) - Method in class java.awt. Choice
从 Choice菜单中删除 item的第一次出现。
remove(String) - Method in class java.awt. List
从列表中删除项目的第一次出现。
remove(String) - Method in class java.util.prefs. AbstractPreferences
实现 remove(String)方法按照在本说明书中 Preferences.remove(String) 。
remove(String) - Method in class java.util.prefs. Preferences
删除与此首选项节点中指定键相关联的值（如果有）。
remove(String) - Method in class javax.activation. MimeTypeParameterList
删除与给定名称相关联的任何值。
remove(String) - Method in interface javax.naming.directory. Attributes
从属性集中删除属性id“attrID”的属性。
remove(String) - Method in class javax.naming.directory. BasicAttributes
remove(URI, HttpCookie) - Method in interface java.net. CookieStore
从商店中删除一个cookie。
remove(EventListener) - Method in class java.awt. AWTEventMulticaster
从这个多维数据删除一个监听器。
remove(AccessibleRelation) - Method in class javax.accessibility. AccessibleRelationSet
从当前关系集中删除关系。
remove(AccessibleState) - Method in class javax.accessibility. AccessibleStateSet
从当前状态集中删除状态。
remove(Attribute) - Method in interface javax.print.attribute. AttributeSet
从该属性集中删除指定的属性（如果存在）。
remove(Attribute) - Method in class javax.print.attribute. HashAttributeSet
从该属性集中删除指定的属性（如果存在）。
remove(MidiEvent) - Method in class javax.sound.midi. Track
从轨道中删除指定的事件。
remove(AbstractButton) - Method in class javax.swing. ButtonGroup
从组中删除按钮。
remove(JMenuItem) - Method in class javax.swing. JMenu
从此菜单中删除指定的菜单项。
remove(KeyStroke) - Method in class javax.swing. ComponentInputMap
从此对象中移除 key的绑定。
remove(KeyStroke) - Method in class javax.swing. InputMap
从这个 InputMap删除 key的绑定。
remove(DocumentFilter.FilterBypass, int, int) - Method in class javax.swing.text. DocumentFilter
在删除指定文档中的指定区域之前调用。
remove(MutableTreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode
从此节点的子数组中删除 aChild ，给它一个空父。
remove(MutableTreeNode) - Method in interface javax.swing.tree. MutableTreeNode
从接收器中删除 node 。
REMOVE - Static variable in class javax.swing.event. DocumentEvent.EventType
删除类型。
REMOVE_ATTRIBUTE - Static variable in interface javax.naming.directory. DirContext
该常量指定从属性中删除指定的属性值。
REMOVE_FROM_CRL - java.security.cert. CRLReason
这个原因表明证书以前被暂停，应该从CRL中删除。
removeAccessibleSelection(int) - Method in class java.awt. List.AccessibleAWTList
从对象的选择中删除对象中指定的选定项目。
removeAccessibleSelection(int) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent
从对象的选择中删除对象的指定子对象。
removeAccessibleSelection(int) - Method in interface javax.accessibility. AccessibleSelection
从对象的选择中删除对象的指定子对象。
removeAccessibleSelection(int) - Method in class javax.swing. JComboBox.AccessibleJComboBox
从对象的选择中删除对象的指定子对象。
removeAccessibleSelection(int) - Method in class javax.swing. JList.AccessibleJList
从对象的选择中删除对象中指定的选定项目。
removeAccessibleSelection(int) - Method in class javax.swing. JMenu.AccessibleJMenu
从选择中删除第n个项目。
removeAccessibleSelection(int) - Method in class javax.swing. JMenuBar.AccessibleJMenuBar
从对象的选择中删除对象中第n个选定的项目。
removeAccessibleSelection(int) - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane
removeAccessibleSelection(int) - Method in class javax.swing. JTable.AccessibleJTable
从对象的选择中删除对象的指定子对象。
removeAccessibleSelection(int) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
从对象的选择中删除对象中指定的选定项目。
removeAccessibleSelection(int) - Method in class javax.swing. JTree.AccessibleJTree
从对象的选择中删除对象中指定的选定项目。
removeActionListener(ActionListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
移除指定的侦听器，使其不再接收 ACTION个事件。
removeActionListener(ActionListener) - Method in class java.awt. Button
删除指定的动作侦听器，使其不再从此按钮接收到动作事件。
removeActionListener(ActionListener) - Method in class java.awt. List
删除指定的动作侦听器，使其不再从此列表中接收到动作事件。
removeActionListener(ActionListener) - Method in class java.awt. MenuItem
删除指定的动作监听器，使其不再从此菜单项接收动作事件。
removeActionListener(ActionListener) - Method in class java.awt. TextField
删除指定的动作侦听器，使其不再从此文本字段接收到动作事件。
removeActionListener(ActionListener) - Method in class java.awt. TrayIcon
删除指定的动作侦听器。
removeActionListener(ActionListener) - Method in class javax.swing. AbstractButton
从按钮中删除 ActionListener 。
removeActionListener(ActionListener) - Method in interface javax.swing. ButtonModel
从模型中移除 ActionListener 。
removeActionListener(ActionListener) - Method in interface javax.swing. ComboBoxEditor
删除一个ActionListener
removeActionListener(ActionListener) - Method in class javax.swing. DefaultButtonModel
从模型中移除 ActionListener 。
removeActionListener(ActionListener) - Method in class javax.swing. JComboBox
删除一个 ActionListener 。
removeActionListener(ActionListener) - Method in class javax.swing. JFileChooser
从文件选择器中删除 ActionListener 。
removeActionListener(ActionListener) - Method in class javax.swing. JTextField
删除指定的动作监听器，使其不再从此文本字段接收动作事件。
removeActionListener(ActionListener) - Method in class javax.swing.plaf.basic. BasicComboBoxEditor
removeActionListener(ActionListener) - Method in class javax.swing. Timer
从 Timer删除指定的动作侦听 Timer 。
removeAdjustmentListener(AdjustmentListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
删除指定的侦听器，使其不再接收 ADJUSTMENT事件。
removeAdjustmentListener(AdjustmentListener) - Method in interface java.awt. Adjustable
删除调整监听器。
removeAdjustmentListener(AdjustmentListener) - Method in class java.awt. Scrollbar
删除指定的调整监听器，使其不再从此滚动条接收 AdjustmentEvent实例。
removeAdjustmentListener(AdjustmentListener) - Method in class java.awt. ScrollPaneAdjustable
删除指定的调整监听器，使其不再从此 ScrollPaneAdjustable接收调整事件。
removeAdjustmentListener(AdjustmentListener) - Method in class javax.swing. JScrollBar
删除AdjustmentEvent侦听器。
removeAll() - Method in class java.awt. Choice
从选择菜单中删除所有项目。
removeAll() - Method in class java.awt. Container
从此容器中删除所有组件。
removeAll() - Method in class java.awt. List
从此列表中删除所有项目。
removeAll() - Method in class java.awt. Menu
从此菜单中删除所有项目。
removeAll() - Method in interface java.net. CookieStore
删除此Cookie商店中的所有Cookie。
removeAll() - Method in class javax.swing. JDesktopPane
从此容器中删除所有组件。
removeAll() - Method in class javax.swing. JLayer
从此容器中删除所有组件。
removeAll() - Method in class javax.swing. JLayeredPane
从此容器中删除所有组件。
removeAll() - Method in class javax.swing. JMenu
从此菜单中删除所有菜单项。
removeAll() - Method in class javax.swing. JSplitPane
从拆分窗格中删除所有子组件。
removeAll() - Method in class javax.swing. JTabbedPane
从 tabbedpane删除所有选项卡及其对应的组件。
removeAll() - Method in class javax.swing.text. View
删除所有的孩子。
removeAll(E...) - Method in class javafx.beans.binding. ListExpression
removeAll(E...) - Method in interface javafx.collections. ObservableList
一种方便的方法，用于var-arg使用的 removeAll方法。
removeAll(E...) - Method in class javafx.collections. ObservableListBase
removeAll(Collection) - Method in class java.beans.beancontext. BeanContextSupport
删除所有指定的子（不支持）实现必须在层次结构锁和“children”保护字段上同步
removeAll(Collection<?>) - Method in class java.util. AbstractCollection
删除指定集合中包含的所有此集合的元素（可选操作）。
removeAll(Collection<?>) - Method in class java.util. AbstractSet
从此集合中删除指定集合中包含的所有元素（可选操作）。
removeAll(Collection<?>) - Method in class java.util. ArrayDeque
removeAll(Collection<?>) - Method in class java.util. ArrayList
从此列表中删除指定集合中包含的所有元素。
removeAll(Collection<?>) - Method in interface java.util. Collection
删除指定集合中包含的所有此集合的元素（可选操作）。
removeAll(Collection<?>) - Method in class java.util.concurrent. ArrayBlockingQueue
removeAll(Collection<?>) - Method in class java.util.concurrent. ConcurrentLinkedDeque
removeAll(Collection<?>) - Method in class java.util.concurrent. ConcurrentLinkedQueue
removeAll(Collection<?>) - Method in class java.util.concurrent. ConcurrentSkipListSet
从此集合中删除指定集合中包含的所有元素。
removeAll(Collection<?>) - Method in class java.util.concurrent. CopyOnWriteArrayList
从此列表中删除指定集合中包含的所有元素。
removeAll(Collection<?>) - Method in class java.util.concurrent. CopyOnWriteArraySet
从此集合中删除指定集合中包含的所有元素。
removeAll(Collection<?>) - Method in class java.util.concurrent. LinkedBlockingDeque
removeAll(Collection<?>) - Method in class java.util.concurrent. LinkedBlockingQueue
removeAll(Collection<?>) - Method in class java.util.concurrent. LinkedTransferQueue
removeAll(Collection<?>) - Method in class java.util.concurrent. SynchronousQueue
始终返回 false 。
removeAll(Collection<?>) - Method in interface java.util. List
从此列表中删除包含在指定集合中的所有元素（可选操作）。
removeAll(Collection<?>) - Method in interface java.util. Set
从此集合中删除指定集合中包含的所有元素（可选操作）。
removeAll(Collection<?>) - Method in class java.util. Vector
从此Vector中删除指定集合中包含的所有元素。
removeAll(Collection<?>) - Method in class javafx.beans.binding. ListExpression
removeAll(Collection<?>) - Method in class javafx.beans.binding. SetExpression
removeAll(Collection<?>) - Method in class javafx.collections. ModifiableObservableListBase
removeAllAttachments() - Method in class javax.xml.soap. SOAPMessage
删除所有 AttachmentPart已经加入到这一对象 SOAPMessage对象。
removeAllChildren() - Method in class javax.swing.tree. DefaultMutableTreeNode
删除所有这个节点的孩子，将他们的父母设置为null。
removeAllElements() - Method in class java.util. Vector
从该向量中删除所有组件，并将其大小设置为零。
removeAllElements() - Method in class javax.swing. DefaultComboBoxModel
清空清单。
removeAllElements() - Method in class javax.swing. DefaultListModel
从此列表中删除所有组件，并将其大小设置为零。
removeAllFaultSubcodes() - Method in interface javax.xml.soap. SOAPFault
删除SOAPFault可能包含的 SOAPFault 。
removeAllHeaders() - Method in class javax.xml.soap. MimeHeaders
从此 MimeHeaders对象中删除所有标题条目。
removeAllHighlights() - Method in class javax.swing.text. DefaultHighlighter
删除所有亮点。
removeAllHighlights() - Method in interface javax.swing.text. Highlighter
删除此荧光笔负责的所有亮点。
removeAllIIOReadProgressListeners() - Method in class javax.imageio. ImageReader
删除所有当前注册的 IIOReadProgressListener对象。
removeAllIIOReadUpdateListeners() - Method in class javax.imageio. ImageReader
删除所有当前注册的 IIOReadUpdateListener对象。
removeAllIIOReadWarningListeners() - Method in class javax.imageio. ImageReader
删除所有当前注册的 IIOReadWarningListener对象。
removeAllIIOWriteProgressListeners() - Method in class javax.imageio. ImageWriter
删除所有当前注册的 IIOWriteProgressListener对象。
removeAllIIOWriteWarningListeners() - Method in class javax.imageio. ImageWriter
删除所有当前注册的 IIOWriteWarningListener对象。
removeAllItems() - Method in class javax.swing. JComboBox
从项目列表中删除所有项目。
removeAllMimeHeaders() - Method in class javax.xml.soap. AttachmentPart
删除所有的MIME标题条目。
removeAllMimeHeaders() - Method in class javax.xml.soap. SOAPPart
删除 MimeHeader对象的所有 SOAPEnvelope对象。
removeAllNotifications() - Method in class javax.management.timer. Timer
从通知列表中删除所有定时器通知，并重置用于更新计时器通知标识符的计数器。
removeAllNotifications() - Method in interface javax.management.timer. TimerMBean
从通知列表中删除所有定时器通知，并重置用于更新计时器通知标识符的计数器。
removeAllowedTagSet(TIFFTagSet) - Method in class javax.imageio.plugins.tiff. TIFFImageReadParam
从允许的标签集列表中删除一个 TIFFTagSet对象。
removeAncestorListener(AncestorListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 ANCESTOR事件。
removeAncestorListener(AncestorListener) - Method in class javax.swing. JComponent
取消注册 listener ，使其不再接收 AncestorEvents 。
removeAppEventListener(SystemEventListener) - Method in class java.awt. Desktop
删除SystemEventListener的子类型以侦听本机系统的通知。
removeAssociation(String, String[]) - Method in interface javax.jnlp. IntegrationService
删除此应用程序的关联作为指定的mimetype的处理程序。
removeAttachments(MimeHeaders) - Method in class javax.xml.soap. SOAPMessage
删除所有具有与指定标题匹配的标题条目的 AttachmentPart对象。
removeAttribute(int) - Method in class org.xml.sax.ext. Attributes2Impl
removeAttribute(int) - Method in class org.xml.sax.helpers. AttributesImpl
从列表中删除一个属性。
removeAttribute(Object) - Method in class javax.swing.text. AbstractDocument.AbstractElement
从集合中删除属性。
removeAttribute(Object) - Method in interface javax.swing.text. MutableAttributeSet
删除给定的属性 name 。
removeAttribute(Object) - Method in class javax.swing.text. SimpleAttributeSet
从列表中删除一个属性。
removeAttribute(Object) - Method in class javax.swing.text. StyleContext.NamedStyle
从集合中删除属性。
removeAttribute(String) - Method in class javax.imageio.metadata. IIOMetadataNode
removeAttribute(String) - Method in interface org.w3c.dom. Element
按名称删除属性。
removeAttribute(String) - Method in class org.xml.sax.helpers. AttributeListImpl
已过时。
从列表中删除一个属性。
removeAttribute(String, int) - Method in interface javax.script. ScriptContext
删除给定范围内的属性。
removeAttribute(String, int) - Method in class javax.script. SimpleScriptContext
删除给定范围内的属性。
removeAttribute(String, String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
从先前定义的元素中删除一个属性。
removeAttribute(AttributeSet, Object) - Method in interface javax.swing.text. AbstractDocument.AttributeContext
从集合中删除属性。
removeAttribute(AttributeSet, Object) - Method in class javax.swing.text.html. StyleSheet
从集合中删除属性。
removeAttribute(AttributeSet, Object) - Method in class javax.swing.text. StyleContext
从集合中删除属性。
removeAttribute(QName) - Method in interface javax.xml.soap. SOAPElement
使用指定的qname删除属性。
removeAttribute(Name) - Method in interface javax.xml.soap. SOAPElement
删除具有指定名称的属性。
removeAttributeChangeNotificationListener(NotificationListener, String) - Method in interface javax.management.modelmbean. ModelMBeanNotificationBroadcaster
从RequiredModelMBean中删除attributeChangeNotifications的侦听器。
removeAttributeChangeNotificationListener(NotificationListener, String) - Method in class javax.management.modelmbean. RequiredModelMBean
removeAttributeNode(Attr) - Method in class javax.imageio.metadata. IIOMetadataNode
removeAttributeNode(Attr) - Method in interface org.w3c.dom. Element
删除指定的属性节点。
removeAttributeNS(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode
相当于 removeAttribute(localName) 。
removeAttributeNS(String, String) - Method in interface org.w3c.dom. Element
通过本地名称和命名空间URI删除属性。
removeAttributes(Enumeration<?>) - Method in class javax.swing.text. AbstractDocument.AbstractElement
删除元素的一组属性。
removeAttributes(Enumeration<?>) - Method in interface javax.swing.text. MutableAttributeSet
删除给定的属性集 names 。
removeAttributes(Enumeration<?>) - Method in class javax.swing.text. SimpleAttributeSet
从列表中删除一组属性。
removeAttributes(Enumeration<?>) - Method in class javax.swing.text. StyleContext.NamedStyle
删除元素的一组属性。
removeAttributes(AttributeSet) - Method in class javax.swing.text. AbstractDocument.AbstractElement
删除元素的一组属性。
removeAttributes(AttributeSet) - Method in interface javax.swing.text. MutableAttributeSet
使用给定的 name删除一组属性。
removeAttributes(AttributeSet) - Method in class javax.swing.text. SimpleAttributeSet
从列表中删除一组属性。
removeAttributes(AttributeSet) - Method in class javax.swing.text. StyleContext.NamedStyle
删除元素的一组属性。
removeAttributes(AttributeSet, Enumeration<?>) - Method in interface javax.swing.text. AbstractDocument.AttributeContext
删除元素的一组属性。
removeAttributes(AttributeSet, Enumeration<?>) - Method in class javax.swing.text.html. StyleSheet
删除元素的一组属性。
removeAttributes(AttributeSet, Enumeration<?>) - Method in class javax.swing.text. StyleContext
删除元素的一组属性。
removeAttributes(AttributeSet, AttributeSet) - Method in interface javax.swing.text. AbstractDocument.AttributeContext
删除元素的一组属性。
removeAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.html. StyleSheet
删除一组属性。
removeAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text. StyleContext
删除元素的一组属性。
removeAuxiliaryLookAndFeel(LookAndFeel) - Static method in class javax.swing. UIManager
从辅助外观和感觉列表中删除 LookAndFeel 。
removeAWTEventListener(AWTEventListener) - Method in class java.awt. Toolkit
从接收发送的AWTEvent中删除AWTEventListener。
removeBeanContextMembershipListener(BeanContextMembershipListener) - Method in interface java.beans.beancontext. BeanContext
删除指定的 BeanContextMembershipListener以便在添加或删除子代 Component时不再接收 BeanContextMembershipEvent 。
removeBeanContextMembershipListener(BeanContextMembershipListener) - Method in class java.beans.beancontext. BeanContextSupport
删除一个BeanContextMembershipListener
removeBeanContextServicesListener(BeanContextServicesListener) - Method in interface java.beans.beancontext. BeanContextServices
删除一个 BeanContextServicesListener从这个 BeanContext
removeBeanContextServicesListener(BeanContextServicesListener) - Method in class java.beans.beancontext. BeanContextServicesSupport
删除一个BeanContextServicesListener
removeBindings() - Method in interface javax.swing.text. Keymap
删除键盘映射中的所有绑定。
removeCaretListener(CaretListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收事件时发生 CARET事件。
removeCaretListener(CaretListener) - Method in class javax.swing.text. JTextComponent
删除插入符号侦听器。
removeCellEditorListener(CellEditorListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 CELLEDITOR事件。
removeCellEditorListener(CellEditorListener) - Method in class javax.swing. AbstractCellEditor
从侦听器列表中删除 CellEditorListener 。
removeCellEditorListener(CellEditorListener) - Method in interface javax.swing. CellEditor
从通知列表中移除侦听器
removeCellEditorListener(CellEditorListener) - Method in class javax.swing.tree. DefaultTreeCellEditor
删除以前添加的 CellEditorListener 。
removeCertificate(Certificate) - Method in class java.security. Identity
已过时。
从此身份中删除证书。
removeChangeListener(ChangeListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 CHANGE事件。
removeChangeListener(ChangeListener) - Method in class javax.swing. AbstractButton
从按钮中删除一个ChangeListener。
removeChangeListener(ChangeListener) - Method in class javax.swing. AbstractSpinnerModel
从模型的监听器列表中删除一个ChangeListener。
removeChangeListener(ChangeListener) - Method in interface javax.swing. BoundedRangeModel
从模型的监听器列表中删除一个ChangeListener。
removeChangeListener(ChangeListener) - Method in interface javax.swing. ButtonModel
从模型中删除一个 ChangeListener 。
removeChangeListener(ChangeListener) - Method in interface javax.swing.colorchooser. ColorSelectionModel
作为监听器删除 listener以更改模型。
removeChangeListener(ChangeListener) - Method in class javax.swing.colorchooser. DefaultColorSelectionModel
从模型中移除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. DefaultBoundedRangeModel
删除一个 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. DefaultButtonModel
从模型中移除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. DefaultSingleSelectionModel
从按钮中删除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. JProgressBar
从进度条中删除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. JSlider
从滑块中删除一个ChangeListener。
removeChangeListener(ChangeListener) - Method in class javax.swing. JSpinner
从此微调器中移除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. JTabbedPane
ChangeListener窗格中移除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. JViewport
每次视图大小，位置或视口 ChangeListener大小更改时， ChangeListener从列表中删除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in class javax.swing. MenuSelectionManager
从按钮中删除一个ChangeListener。
removeChangeListener(ChangeListener) - Method in interface javax.swing. SingleSelectionModel
将 侦听器作为监听器删除以更改模型。
removeChangeListener(ChangeListener) - Method in interface javax.swing. SpinnerModel
从模型的侦听器列表中删除 ChangeListener 。
removeChangeListener(ChangeListener) - Method in interface javax.swing.text. Caret
删除正在跟踪插入符位置更改的侦听器。
removeChangeListener(ChangeListener) - Method in class javax.swing.text. DefaultCaret
删除正在跟踪插入符位置更改的侦听器。
removeChangeListener(ChangeListener) - Method in interface javax.swing.text. Style
删除跟踪属性更改的侦听器。
removeChangeListener(ChangeListener) - Method in class javax.swing.text. StyleContext.NamedStyle
删除更改侦听器。
removeChangeListener(ChangeListener) - Method in class javax.swing.text. StyleContext
删除正在添加或删除的跟踪样式的侦听器。
removeChild(Node) - Method in class javax.imageio.metadata. IIOMetadataNode
从子列表中删除由 oldChild指示的子节点，并返回。
removeChild(Node) - Method in interface org.w3c.dom. Node
从子列表中删除由 oldChild指示的子节点，并返回。
removeChoosableFileFilter(FileFilter) - Method in class javax.swing. JFileChooser
从用户可选择的文件过滤器列表中删除一个过滤器。
removeChooserPanel(AbstractColorChooserPanel) - Method in class javax.swing. JColorChooser
删除指定的颜色面板。
removeColumn(TableColumn) - Method in class javax.swing. JTable
从这个 JTable的列数组中删除 aColumn 。
removeColumn(TableColumn) - Method in class javax.swing.table. DefaultTableColumnModel
删除 column从 tableColumns阵列。
removeColumn(TableColumn) - Method in interface javax.swing.table. TableColumnModel
从 tableColumns数组中删除 TableColumn column 。
removeColumnModelListener(TableColumnModelListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
移除指定的侦听器，使其不再接收 COLUMNMODEL事件。
removeColumnModelListener(TableColumnModelListener) - Method in class javax.swing.table. DefaultTableColumnModel
删除表列模型事件的侦听器。
removeColumnModelListener(TableColumnModelListener) - Method in interface javax.swing.table. TableColumnModel
删除表列模型事件的侦听器。
removeColumnSelectionInterval(int, int) - Method in class javax.swing. JTable
取消选择从 index0到 index1 （含）的列。
removeComponentListener(ComponentListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
移除指定的侦听器，使其不再接收 COMPONENT事件。
removeComponentListener(ComponentListener) - Method in class java.awt. Component
删除指定的组件侦听器，使其不再从此组件接收组件事件。
removeConfigurationListener(Runnable) - Method in class java.util.logging. LogManager
删除以前注册的配置监听器。
removeConnectionEventListener(ConnectionEventListener) - Method in interface javax.sql. PooledConnection
从在 PooledConnection对象发生事件时将被通知的组件列表中删除给定的事件侦听器。
removeConnectionNotificationListener(NotificationListener) - Method in interface javax.management.remote. JMXConnector
从列表中删除一个监听器以通知状态更改。
removeConnectionNotificationListener(NotificationListener) - Method in class javax.management.remote.rmi. RMIConnector
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.remote. JMXConnector
从列表中删除一个监听器以通知状态更改。
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.remote.rmi. RMIConnector
removeConsumer(ImageConsumer) - Method in class java.awt.image. FilteredImageSource
从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
removeConsumer(ImageConsumer) - Method in interface java.awt.image. ImageProducer
从当前注册的消费者列表中删除指定的 ImageConsumer对象以接收图像数据。
removeConsumer(ImageConsumer) - Method in class java.awt.image. MemoryImageSource
从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
removeConsumer(ImageConsumer) - Method in class java.awt.image.renderable. RenderableImageProducer
从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
removeContainerListener(ContainerListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
删除指定的侦听器，使其不再接收 CONTAINER事件。
removeContainerListener(ContainerListener) - Method in class java.awt. Container
删除指定的容器侦听器，使其不再从此容器接收容器事件。
removeContents() - Method in interface javax.xml.soap. SOAPElement
分离这个 SOAPElement所有孩子。
removeContext(HttpContext) - Method in class com.sun.net.httpserver. HttpServer
从服务器中删除给定的上下文。
removeContext(String) - Method in class com.sun.net.httpserver. HttpServer
从服务器中删除由给定路径标识的上下文。
removeContextPropertyChangeListener(PropertyChangeListener) - Method in class com.sun.tools.jconsole. JConsolePlugin
从此插件的JConsoleContext对象的侦听器列表中删除PropertyChangeListener 。
removeControlButtons() - Method in class javax.swing.plaf.metal. MetalFileChooserUI
从底部面板移除控制按钮。
removeControllerEventListener(ControllerEventListener, int[]) - Method in interface javax.sound.midi. Sequencer
删除控制器事件侦听器对一种或多种类型的控制器事件的兴趣。
removeDataItemFromDisplay(XYChart.Series<X, Y>, XYChart.Data<X, Y>) - Method in class javafx.scene.chart. XYChart
当您完成从图表中删除该项目的任何动画后，应从dataItemRemoved（）中调用此方法。
removeDescendantSelectedPaths(TreePath, boolean) - Method in class javax.swing. JTree
删除选择中任何作为后代的路径为 path 。
removeDescendantToggledPaths(Enumeration<TreePath>) - Method in class javax.swing. JTree
删除已扩展的 TreePaths中的 toRemove任何后代。
removeDocumentListener(DocumentListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其在发生事件时不再接收 DOCUMENT事件。
removeDocumentListener(DocumentListener) - Method in class javax.swing.text. AbstractDocument
删除文档监听器。
removeDocumentListener(DocumentListener) - Method in class javax.swing.text. DefaultStyledDocument
删除文档监听器。
removeDocumentListener(DocumentListener) - Method in interface javax.swing.text. Document
从通知列表中注销给定的观察者，因此它将不再接收更改更新。
removeDragGestureListener(DragGestureListener) - Method in class java.awt.dnd. DragGestureRecognizer
取消注册当前的DragGestureListener
removeDragSourceListener(DragSourceListener) - Method in class java.awt.dnd. DragSource
删除指定 DragSourceListener从这个 DragSource 。
removeDragSourceListener(DragSourceListener) - Method in class java.awt.dnd. DragSourceContext
删除指定 DragSourceListener从这个 DragSourceContext 。
removeDragSourceMotionListener(DragSourceMotionListener) - Method in class java.awt.dnd. DragSource
删除指定 DragSourceMotionListener从这个 DragSource 。
removeDropTargetListener(DropTargetListener) - Method in class java.awt.dnd. DropTarget
删除当前的 DropTargetListener （UNICAST SOURCE）。
removeEditor() - Method in class javax.swing. JTable
丢弃编辑器对象，并释放用于单元格渲染的空间。
removeEditor() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
这种公共方法是实现具体的，应该是私有的。
removeEldestEntry(Map.Entry<K, V>) - Method in class java.util. LinkedHashMap
如果此地图应删除其最老的条目，则返回 true 。
removeElement(Object) - Method in class java.util. Vector
从此向量中删除参数的第一个（最低索引）出现次数。
removeElement(Object) - Method in class javax.swing. DefaultComboBoxModel
removeElement(Object) - Method in class javax.swing. DefaultListModel
从此列表中删除参数的第一个（最低索引）出现次数。
removeElement(Object) - Method in interface javax.swing. MutableComboBoxModel
从模型中删除一个项目。
removeElement(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
从格式中移除元素。
removeElement(Element) - Method in class javax.swing.text. DefaultStyledDocument
从此文档中删除元素。
removeElementAt(int) - Method in class java.util. Vector
删除指定索引处的组件。
removeElementAt(int) - Method in class javax.swing. DefaultComboBoxModel
removeElementAt(int) - Method in class javax.swing. DefaultListModel
删除指定索引处的组件。
removeElementAt(int) - Method in interface javax.swing. MutableComboBoxModel
删除特定索引处的项目。
removeEntries(int, int) - Method in class javax.swing. SizeSequence
从这个 SizeSequence删除一组连续的条目。
removeEntry(Principal, AclEntry) - Method in interface java.security.acl. Acl
已过时。
从此ACL中删除ACL条目。
removeEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Service
从此任务中注销先前注册的事件过滤器。
removeEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Task
从此任务中注销先前注册的事件过滤器。
removeEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Node
从此节点注销先前注册的事件过滤器。
removeEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Scene
从此场景注销先前注册的事件过滤器。
removeEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene.transform. Transform
从此转换中注销先前注册的事件过滤器。
removeEventFilter(EventType<T>, EventHandler<? super T>) - Method in class javafx.stage. Window
从此节点注销先前注册的事件过滤器。
removeEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. Menu
从此MenuItem中注销先前注册的事件处理程序。
removeEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. MenuItem
从此MenuItem中注销先前注册的事件处理程序。
removeEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. TableColumnBase
从此表列中注销先前注册的事件处理程序。
removeEventHandler(EventType<E>, EventHandler<E>) - Method in class javafx.scene.control. TreeItem
从此TreeItem中注销先前注册的事件处理程序。
removeEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Service
从此任务中注销先前注册的事件处理程序。
removeEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Task
从此任务中注销先前注册的事件处理程序。
removeEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Node
从此节点注销先前注册的事件处理程序。
removeEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Scene
从此场景注销先前注册的事件处理程序。
removeEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene.transform. Transform
从此转换中注销先前注册的事件处理程序。
removeEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.stage. Window
从此节点注销先前注册的事件处理程序。
removeEventListener(String, EventListener, boolean) - Method in interface org.w3c.dom.events. EventTarget
此方法允许从事件目标中删除事件侦听器。
removeExtensionPart(URL, String, String) - Method in interface javax.jnlp. DownloadService
如果在应用程序的JNLP文件中提到了部分和扩展名，则从缓存中删除给定扩展的给定部分。
removeExtensionPart(URL, String, String[]) - Method in interface javax.jnlp. DownloadService
如果在应用程序的JNLP文件中提到了部件和扩展名，则从缓存中删除给定扩展的给定部分。
removeField(String) - Method in interface javax.management. Descriptor
从描述符中删除一个字段。
removeField(String) - Method in class javax.management. ImmutableDescriptor
从描述符中删除一个字段。
removeField(String) - Method in class javax.management.modelmbean. DescriptorSupport
removeFirst() - Method in class java.util. ArrayDeque
removeFirst() - Method in class java.util.concurrent. ConcurrentLinkedDeque
removeFirst() - Method in class java.util.concurrent. LinkedBlockingDeque
removeFirst() - Method in interface java.util. Deque
检索并删除此deque的第一个元素。
removeFirst() - Method in class java.util. LinkedList
从此列表中删除并返回第一个元素。
removeFirstOccurrence(Object) - Method in class java.util. ArrayDeque
删除此deque中指定元素的第一个出现（从头到尾遍历deque时）。
removeFirstOccurrence(Object) - Method in interface java.util.concurrent. BlockingDeque
从此deque中删除指定元素的第一个出现。
removeFirstOccurrence(Object) - Method in class java.util.concurrent. ConcurrentLinkedDeque
从此deque中删除指定元素的第一个出现。
removeFirstOccurrence(Object) - Method in class java.util.concurrent. LinkedBlockingDeque
removeFirstOccurrence(Object) - Method in interface java.util. Deque
从此deque中删除指定元素的第一个出现。
removeFirstOccurrence(Object) - Method in class java.util. LinkedList
删除此列表中指定元素的第一个出现（从头到尾遍历列表时）。
removeFlavorListener(FlavorListener) - Method in class java.awt.datatransfer. Clipboard
删除指定的 FlavorListener ，使其不再从此 Clipboard接收 FlavorEvent s。
removeFocusListener(FocusListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
移除指定的侦听器，使其在发生事件时不再接收 FOCUS事件。
removeFocusListener(FocusListener) - Method in class com.sun.java.accessibility.util. Translator
删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - Method in class java.awt. Component.AccessibleAWTComponent
删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - Method in class java.awt. Component
删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild
删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent
删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - Method in interface javax.accessibility. AccessibleComponent
删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild
removeFocusListener(FocusListener) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell
removeFocusListener(FocusListener) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
removeFocusListener(FocusListener) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
removeFromEnvironment(String) - Method in interface javax.naming. Context
从环境环境中删除环境属性。
removeFromEnvironment(String) - Method in class javax.naming. InitialContext
removeFromParent() - Method in class javax.swing.tree. DefaultMutableTreeNode
从树中除去根节点的子树，给这个节点一个空父。
removeFromParent() - Method in interface javax.swing.tree. MutableTreeNode
从其父母中删除接收者。
removeFromSource() - Method in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler
从源中删除事件。
removeGUIInitializedListener(GUIInitializedListener) - Static method in class com.sun.java.accessibility.util. EventQueueMonitor
删除指定的监听器以在GUI子系统初始化时通知。
removeHandler(Handler) - Method in class java.util.logging. Logger
删除日志处理程序。
removeHandshakeCompletedListener(HandshakeCompletedListener) - Method in class javax.net.ssl. SSLSocket
删除以前注册的握手完成侦听器。
removeHeader(String) - Method in class javax.xml.soap. MimeHeaders
删除名称与给定名称匹配的所有 MimeHeader对象。
removeHierarchyBoundsListener(HierarchyBoundsListener) - Method in class java.awt. Component
删除指定的层次结构边界监听器，使其不再从此组件接收层次结构限制事件。
removeHierarchyListener(HierarchyListener) - Method in class java.awt. Component
删除指定的层次监听器，使其不再从此组件接收层次结构更改的事件。
removeHighlight(Object) - Method in class javax.swing.text. DefaultHighlighter
从视图中移除高亮。
removeHighlight(Object) - Method in interface javax.swing.text. Highlighter
从视图中移除高亮。
removeHighlight(List<? extends Node>) - Method in class javafx.scene.control.skin. TextAreaSkin
从Input Method中删除组合文本的高亮。
removeHighlight(List<? extends Node>) - Method in class javafx.scene.control.skin. TextFieldSkin
从Input Method中删除组合文本的高亮。
removeHighlight(List<? extends Node>) - Method in class javafx.scene.control.skin. TextInputControlSkin
从Input Method中删除组合文本的高亮。
removeHyperlinkListener(HyperlinkListener) - Method in class javax.swing. JEditorPane
删除超链接侦听器。
removeIconFor(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
方便的方法来去除 f的desktopIcon的是必要的。
removeIdentity(Identity) - Method in class java.security. IdentityScope
已过时。
从此身份范围中删除身份。
removeIf(Predicate<? super E>) - Method in class java.util. ArrayDeque
removeIf(Predicate<? super E>) - Method in class java.util. ArrayList
removeIf(Predicate<? super E>) - Method in interface java.util. Collection
删除满足给定谓词的此集合的所有元素。
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. ArrayBlockingQueue
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. ConcurrentLinkedDeque
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. ConcurrentLinkedQueue
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. CopyOnWriteArrayList
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. CopyOnWriteArraySet
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. LinkedBlockingDeque
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. LinkedBlockingQueue
removeIf(Predicate<? super E>) - Method in class java.util.concurrent. LinkedTransferQueue
removeIf(Predicate<? super E>) - Method in class java.util. Vector
removeIIOReadProgressListener(IIOReadProgressListener) - Method in class javax.imageio. ImageReader
从注册进度侦听器列表中删除 IIOReadProgressListener 。
removeIIOReadUpdateListener(IIOReadUpdateListener) - Method in class javax.imageio. ImageReader
从注册的更新监听器列表中删除一个 IIOReadUpdateListener 。
removeIIOReadWarningListener(IIOReadWarningListener) - Method in class javax.imageio. ImageReader
从注册的错误侦听器列表中删除 IIOReadWarningListener 。
removeIIOWriteProgressListener(IIOWriteProgressListener) - Method in class javax.imageio. ImageWriter
从注册进度侦听器列表中删除 IIOWriteProgressListener 。
removeIIOWriteWarningListener(IIOWriteWarningListener) - Method in class javax.imageio. ImageWriter
从注册的警告侦听器列表中删除一个 IIOWriteWarningListener 。
removeImage(int) - Method in class javax.imageio. ImageWriter
从流中删除图像。
removeImage(Image) - Method in class java.awt. MediaTracker
从此媒体跟踪器中删除指定的图像。
removeImage(Image, int) - Method in class java.awt. MediaTracker
从该媒体跟踪器的指定跟踪ID中删除指定的图像。
removeImage(Image, int, int, int) - Method in class java.awt. MediaTracker
从此媒体跟踪器中删除指定的宽度，高度和ID的指定图像。
removeIndexInterval(int, int) - Method in class javax.swing. DefaultListSelectionModel
从选择模型中删除间隔index0，index1（包括）中的索引。
removeIndexInterval(int, int) - Method in interface javax.swing. ListSelectionModel
从选择模型中删除间隔 index0,index1 （含）的索引。
removeInputMethodListener(InputMethodListener) - Method in class java.awt. Component
删除指定的输入法侦听器，使其不再从此组件接收输入法事件。
removeInternal(EventListener, EventListener) - Static method in class java.awt. AWTEventMulticaster
从listener-l中删除旧的侦听器后，返回生成的多播侦听器。
removeInternalFrameListener(InternalFrameListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 INTERNALFRAME事件。
removeInternalFrameListener(InternalFrameListener) - Method in class javax.swing. JInternalFrame
删除指定的内部帧监听器，使其不再从该内部帧接收内部帧事件。
removeInvalidComponent(JComponent) - Method in class javax.swing. RepaintManager
从无效组件列表中删除组件。
removeItem(Object) - Method in class javax.swing. JComboBox
从项目列表中删除一个项目。
removeItemAt(int) - Method in class javax.swing. JComboBox
删除该项目 anIndex该方法仅在 JComboBox使用可变数据模型时有效。
removeItemListener(ItemListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
删除指定的侦听器，使其在发生事件时不再接收 27046361913901事件。
removeItemListener(ItemListener) - Method in class java.awt. Checkbox
删除指定的项目监听器，以使项目监听器不再从此复选框接收项目事件。
removeItemListener(ItemListener) - Method in class java.awt. CheckboxMenuItem
删除指定的项目监听器，使其不再从此复选框菜单项目接收项目事件。
removeItemListener(ItemListener) - Method in class java.awt. Choice
删除指定的项目监听器，使其不再从此 Choice菜单中接收项目事件。
removeItemListener(ItemListener) - Method in interface java.awt. ItemSelectable
删除项目侦听器。
removeItemListener(ItemListener) - Method in class java.awt. List
删除指定的项目监听器，使其不再从此列表中接收项目事件。
removeItemListener(ItemListener) - Method in class javax.swing. AbstractButton
从按钮中删除 ItemListener 。
removeItemListener(ItemListener) - Method in interface javax.swing. ButtonModel
从模型中删除一个 ItemListener 。
removeItemListener(ItemListener) - Method in class javax.swing. DefaultButtonModel
从模型中移除 ItemListener 。
removeItemListener(ItemListener) - Method in class javax.swing. JComboBox
删除一个 ItemListener 。
removeKeyEventDispatcher(KeyEventDispatcher) - Method in class java.awt. KeyboardFocusManager
删除之前添加到此KeyboardFocusManager调度程序链的KeyEventDispatcher。
removeKeyEventPostProcessor(KeyEventPostProcessor) - Method in class java.awt. KeyboardFocusManager
从此KeyboardFocusManager的后处理器链中删除以前添加的KeyEventPostProcessor。
removeKeyListener(KeyListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
删除指定的侦听器，使其不再接收事件时发生 KEY事件。
removeKeyListener(KeyListener) - Method in class java.awt. Component
删除指定的密钥侦听器，使其不再从此组件接收密钥事件。
removeKeymap(String) - Static method in class javax.swing.text. JTextComponent
删除以前添加到文档的命名键盘映射。
removeKeyStrokeBinding(KeyStroke) - Method in interface javax.swing.text. Keymap
从键盘图中移除一个绑定。
removeLast() - Method in class java.util. ArrayDeque
removeLast() - Method in class java.util.concurrent. ConcurrentLinkedDeque
removeLast() - Method in class java.util.concurrent. LinkedBlockingDeque
removeLast() - Method in interface java.util. Deque
检索并删除此deque的最后一个元素。
removeLast() - Method in class java.util. LinkedList
从此列表中删除并返回最后一个元素。
removeLastOccurrence(Object) - Method in class java.util. ArrayDeque
删除此deque中指定元素的最后一次（从头到尾遍历deque时）。
removeLastOccurrence(Object) - Method in interface java.util.concurrent. BlockingDeque
从此deque中删除指定元素的最后一次出现。
removeLastOccurrence(Object) - Method in class java.util.concurrent. ConcurrentLinkedDeque
从此deque中删除指定元素的最后一次出现。
removeLastOccurrence(Object) - Method in class java.util.concurrent. LinkedBlockingDeque
removeLastOccurrence(Object) - Method in interface java.util. Deque
从此deque中删除指定元素的最后一次出现。
removeLastOccurrence(Object) - Method in class java.util. LinkedList
删除此列表中指定元素的最后一次出现（从头到尾遍历列表时）。
removeLayoutComponent(Component) - Method in class java.awt. BorderLayout
从此边框布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class java.awt. CardLayout
从布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class java.awt. FlowLayout
从布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class java.awt. GridBagLayout
从此布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class java.awt. GridLayout
从布局中删除指定的组件。
removeLayoutComponent(Component) - Method in interface java.awt. LayoutManager
从布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class javax.swing. BoxLayout
本课不使用
removeLayoutComponent(Component) - Method in class javax.swing. GroupLayout
通知一个 Component已从父容器中删除。
removeLayoutComponent(Component) - Method in class javax.swing. JRootPane.RootLayout
removeLayoutComponent(Component) - Method in class javax.swing. JSpinner.DefaultEditor
这个 LayoutManager方法什么都不做。
removeLayoutComponent(Component) - Method in class javax.swing. OverlayLayout
从布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicComboBoxUI.ComboBoxLayoutManager
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.TitlePaneLayout
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI.InternalFrameLayout
从布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider.DividerLayout
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
从我们的知识中删除指定的组件。
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
removeLayoutComponent(Component) - Method in class javax.swing. ScrollPaneLayout
从布局中删除指定的组件。
removeLayoutComponent(Component) - Method in class javax.swing. SpringLayout
删除与指定组件关联的约束。
removeLayoutComponent(Component) - Method in class javax.swing. ViewportLayout
从布局中删除指定的组件。
removeLineListener(LineListener) - Method in interface javax.sound.sampled. Line
从此行的侦听器列表中删除指定的侦听器。
removeListDataListener(ListDataListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的监听器，使其不再接收 LISTDATA事件。
removeListDataListener(ListDataListener) - Method in class javax.swing. AbstractListModel
从每次发生数据模型更改时通知的列表中移除侦听器。
removeListDataListener(ListDataListener) - Method in interface javax.swing. ListModel
从每次发生数据模型更改时通知的列表中移除侦听器。
removeListener(InvalidationListener) - Method in class javafx.beans.binding. BooleanBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. DoubleBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. FloatBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. IntegerBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. ListBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. LongBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. MapBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. ObjectBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. SetBinding
removeListener(InvalidationListener) - Method in class javafx.beans.binding. StringBinding
removeListener(InvalidationListener) - Method in interface javafx.beans. Observable
从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
从监听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
从监听器列表中删除给定的监听器，每当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
从监听器列表中删除给定的监听器，每当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
从监听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
从监听器列表中删除给定的监听器，当 Observable的值变为无效时，它们将被通知。
removeListener(InvalidationListener) - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
从监听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.beans.property. BooleanPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. DoublePropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. FloatPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. IntegerPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ListPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. LongPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. MapPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ObjectPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyBooleanPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyDoublePropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyFloatPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyIntegerPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyListPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyLongPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyObjectPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlySetPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. ReadOnlyStringPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. SetPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.property. StringPropertyBase
removeListener(InvalidationListener) - Method in class javafx.beans.value. ObservableValueBase
从监听器列表中删除给定的监听器，每当 Observable的值变为无效时通知 Observable 。
removeListener(InvalidationListener) - Method in class javafx.collections. ObservableArrayBase
removeListener(InvalidationListener) - Method in class javafx.collections. ObservableListBase
removeListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.binding. BooleanBinding
removeListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.property. BooleanPropertyBase
removeListener(ChangeListener<? super Boolean>) - Method in class javafx.beans.property. ReadOnlyBooleanPropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. DoubleBinding
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. FloatBinding
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. IntegerBinding
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.binding. LongBinding
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. DoublePropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. FloatPropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. IntegerPropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. LongPropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyDoublePropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyFloatPropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyIntegerPropertyBase
removeListener(ChangeListener<? super Number>) - Method in class javafx.beans.property. ReadOnlyLongPropertyBase
removeListener(ChangeListener<? super String>) - Method in class javafx.beans.binding. StringBinding
removeListener(ChangeListener<? super String>) - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super String>) - Method in class javafx.beans.property. ReadOnlyStringPropertyBase
removeListener(ChangeListener<? super String>) - Method in class javafx.beans.property. StringPropertyBase
removeListener(ChangeListener<? super ObservableList<E>>) - Method in class javafx.beans.binding. ListBinding
removeListener(ChangeListener<? super ObservableList<E>>) - Method in class javafx.beans.property. ListPropertyBase
removeListener(ChangeListener<? super ObservableList<E>>) - Method in class javafx.beans.property. ReadOnlyListPropertyBase
removeListener(ChangeListener<? super ObservableMap<K, V>>) - Method in class javafx.beans.binding. MapBinding
removeListener(ChangeListener<? super ObservableMap<K, V>>) - Method in class javafx.beans.property. MapPropertyBase
removeListener(ChangeListener<? super ObservableMap<K, V>>) - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
removeListener(ChangeListener<? super ObservableSet<E>>) - Method in class javafx.beans.binding. SetBinding
removeListener(ChangeListener<? super ObservableSet<E>>) - Method in class javafx.beans.property. ReadOnlySetPropertyBase
removeListener(ChangeListener<? super ObservableSet<E>>) - Method in class javafx.beans.property. SetPropertyBase
removeListener(ChangeListener<? super T>) - Method in class javafx.beans.binding. ObjectBinding
removeListener(ChangeListener<? super T>) - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super T>) - Method in class javafx.beans.property. ObjectPropertyBase
removeListener(ChangeListener<? super T>) - Method in class javafx.beans.property. ReadOnlyObjectPropertyBase
removeListener(ChangeListener<? super T>) - Method in interface javafx.beans.value. ObservableValue
从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
removeListener(ChangeListener<? super T>) - Method in class javafx.beans.value. ObservableValueBase
从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知该 ObservableValue 。
removeListener(ArrayChangeListener<T>) - Method in interface javafx.collections. ObservableArray
尝试从这个可观察数组中删除一个监听器。
removeListener(ArrayChangeListener<T>) - Method in class javafx.collections. ObservableArrayBase
removeListener(ListChangeListener<? super E>) - Method in class javafx.beans.binding. ListBinding
removeListener(ListChangeListener<? super E>) - Method in class javafx.beans.property. ListPropertyBase
removeListener(ListChangeListener<? super E>) - Method in class javafx.beans.property. ReadOnlyListPropertyBase
removeListener(ListChangeListener<? super E>) - Method in interface javafx.collections. ObservableList
尝试从此可观察列表中删除侦听器。
removeListener(ListChangeListener<? super E>) - Method in class javafx.collections. ObservableListBase
removeListener(MapChangeListener<? super K, ? super V>) - Method in class javafx.beans.binding. MapBinding
removeListener(MapChangeListener<? super K, ? super V>) - Method in class javafx.beans.property. MapPropertyBase
removeListener(MapChangeListener<? super K, ? super V>) - Method in class javafx.beans.property. ReadOnlyMapPropertyBase
removeListener(MapChangeListener<? super K, ? super V>) - Method in interface javafx.collections. ObservableMap
试图从这个可观察的地图中删除一个听众。
removeListener(SetChangeListener<? super E>) - Method in class javafx.beans.binding. SetBinding
removeListener(SetChangeListener<? super E>) - Method in class javafx.beans.property. ReadOnlySetPropertyBase
removeListener(SetChangeListener<? super E>) - Method in class javafx.beans.property. SetPropertyBase
removeListener(SetChangeListener<? super E>) - Method in interface javafx.collections. ObservableSet
试图从这个可观察的集合中删除一个监听器。
removeListeners() - Method in class javax.swing.plaf.metal. MetalComboBoxUI
已过时。
从Java 2平台v1.4开始。
removeListSelectionListener(ListSelectionListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 LISTSELECTION事件。
removeListSelectionListener(ListSelectionListener) - Method in class javax.swing. DefaultListSelectionModel
从列表中删除一个侦听器，每次发生更改时都会通知该侦听器。
removeListSelectionListener(ListSelectionListener) - Method in class javax.swing. JList
从列表中删除选择侦听器。
removeListSelectionListener(ListSelectionListener) - Method in interface javax.swing. ListSelectionModel
从列表中删除一个侦听器，每次发生更改时都会通知该侦听器。
removeMember(String) - Method in class jdk.nashorn.api.scripting. AbstractJSObject
removeMember(String) - Method in interface jdk.nashorn.api.scripting. JSObject
从此JavaScript对象中删除一个已命名的成员
removeMember(String) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
removeMember(String) - Method in class netscape.javascript. JSObject
删除一个JavaScript对象的命名成员。
removeMember(Principal) - Method in interface java.security.acl. Group
已过时。
从组中删除指定的成员。
removeMenuDragMouseListener(MenuDragMouseListener) - Method in class javax.swing. JMenuItem
从菜单项中删除 MenuDragMouseListener 。
removeMenuKeyListener(MenuKeyListener) - Method in class javax.swing. JMenuItem
从菜单项中删除 MenuKeyListener 。
removeMenuKeyListener(MenuKeyListener) - Method in class javax.swing. JPopupMenu
从弹出菜单中删除 MenuKeyListener 。
removeMenuListener(MenuListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 MENU事件。
removeMenuListener(MenuListener) - Method in class javax.swing. JMenu
删除菜单事件的监听器。
removeMetaEventListener(MetaEventListener) - Method in interface javax.sound.midi. Sequencer
如果实际上是监听器被注册，则从该定序器的注册监听器列表中移除指定的元事件监听器。
removeMimeHeader(String) - Method in class javax.xml.soap. AttachmentPart
删除与给定名称相匹配的所有MIME标头。
removeMimeHeader(String) - Method in class javax.xml.soap. SOAPPart
删除与给定名称相匹配的所有MIME标头。
removeMnemonic(Mnemonic) - Method in class javafx.scene. Scene
取消注册指定的助记符。
removeMouseListener(MouseListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
删除指定的侦听器，使其不再接收 MOUSE事件。
removeMouseListener(MouseListener) - Method in class java.awt. Component
删除指定的鼠标监听器，使其不再从此组件接收鼠标事件。
removeMouseListener(MouseListener) - Method in class java.awt. TrayIcon
删除指定的鼠标监听器。
removeMouseMotionListener(MouseMotionListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
删除指定的侦听器，使其不再接收 MOTION个事件。
removeMouseMotionListener(MouseMotionListener) - Method in class java.awt. Component
删除指定的鼠标移动侦听器，使其不再从此组件接收鼠标移动事件。
removeMouseMotionListener(MouseMotionListener) - Method in class java.awt. TrayIcon
删除指定的鼠标移动侦听器。
removeMouseWheelListener(MouseWheelListener) - Method in class java.awt. Component
删除指定的鼠标滚轮侦听器，使其不再从此组件接收鼠标滚轮事件。
removeNamedItem(String) - Method in interface org.w3c.dom. NamedNodeMap
删除由name指定的节点。
removeNamedItemNS(String, String) - Method in interface org.w3c.dom. NamedNodeMap
删除由本地名称和命名空间URI指定的节点。
removeNamespaceDeclaration(String) - Method in interface javax.xml.soap. SOAPElement
删除与给定前缀相对应的命名空间声明。
removeNamingListener(NamingListener) - Method in interface javax.naming.event. EventContext
从接收到 EventContext触发的命名事件中移除侦听 EventContext 。
removeNode() - Method in class java.util.prefs. AbstractPreferences
新新 removeNode() 200新新200新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新新200新新新评名200
removeNode() - Method in class java.util.prefs. Preferences
删除此首选项节点及其所有后代，使包含在已删除节点中的任何首选项无效。
removeNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs. AbstractPreferences
removeNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs. Preferences
删除指定的 NodeChangeListener ，所以它不再收到更改事件。
removeNodeFromParent(MutableTreeNode) - Method in class javax.swing.tree. DefaultTreeModel
消息此消息从其父节点删除节点。
removeNodeSpi() - Method in class java.util.prefs. AbstractPreferences
删除此首选项节点，使其无效及其包含的任何首选项。
removeNotification(Integer) - Method in class javax.management.timer. Timer
从通知列表中删除与指定标识符相对应的定时器通知。
removeNotification(Integer) - Method in interface javax.management.timer. TimerMBean
从通知列表中删除与指定标识符相对应的定时器通知。
removeNotificationListener(NotificationListener) - Method in class javax.management. MBeanServerDelegate
removeNotificationListener(NotificationListener) - Method in class javax.management.modelmbean. RequiredModelMBean
从RequiredModelMBean中删除通知的侦听器。
removeNotificationListener(NotificationListener) - Method in interface javax.management. NotificationBroadcaster
从这个MBean中删除一个监听器。
removeNotificationListener(NotificationListener) - Method in class javax.management. NotificationBroadcasterSupport
removeNotificationListener(NotificationListener) - Method in class javax.management. StandardEmitterMBean
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management. MBeanServerDelegate
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.modelmbean. RequiredModelMBean
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management. NotificationBroadcasterSupport
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management. NotificationEmitter
从这个MBean中删除一个监听器。
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management. StandardEmitterMBean
removeNotificationListener(ObjectName, NotificationListener) - Method in interface javax.management. MBeanServer
removeNotificationListener(ObjectName, NotificationListener) - Method in interface javax.management. MBeanServerConnection
从注册的MBean中删除一个监听器。
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management. MBeanServer
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management. MBeanServerConnection
从注册的MBean中删除一个监听器。
removeNotificationListener(ObjectName, ObjectName) - Method in interface javax.management. MBeanServer
removeNotificationListener(ObjectName, ObjectName) - Method in interface javax.management. MBeanServerConnection
从注册的MBean中删除一个监听器。
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi. RMIConnection
处理方法 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 。
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management. MBeanServer
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management. MBeanServerConnection
从注册的MBean中删除一个监听器。
removeNotificationListener(ObjectName, ObjectName, Subject) - Method in interface javax.management.remote.rmi. RMIConnection
处理方法 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 。
removeNotificationListener(ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
removeNotificationListener(ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl
removeNotificationListeners(ObjectName, Integer[], Subject) - Method in interface javax.management.remote.rmi. RMIConnection
处理 removeNotificationListener(ObjectName, NotificationListener)和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)方法。
removeNotificationListeners(ObjectName, Integer[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
removeNotificationListeners(ObjectName, Integer[], Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl
removeNotifications(String) - Method in class javax.management.timer. Timer
从通知列表中删除与指定类型对应的所有定时器通知。
removeNotifications(String) - Method in interface javax.management.timer. TimerMBean
从通知列表中删除与指定类型对应的所有定时器通知。
removeNotify() - Method in class java.awt. Component
使这个 Component通过破坏它本机屏幕资源而不可显示。
removeNotify() - Method in class java.awt. Container
通过删除其与其本机屏幕资源的连接，使此容器不可显示。
removeNotify() - Method in class java.awt.dnd. DropTarget
通知从组件中取消关联的DropTarget此方法通常从与此DropTarget关联的组件的java.awt.Component.removeNotify（）中调用，以通知DropTarget ComponentPeer已与该组件取消关联。
removeNotify() - Method in class java.awt. Frame
通过删除其与其本机屏幕资源的连接，使此框架不可显示。
removeNotify() - Method in interface java.awt.im.spi. InputMethod
通知输入方法，客户端组件已从其包含层次结构中删除，或该组件已禁用输入法支持。
removeNotify() - Method in class java.awt. List
删除此列表的对等体。
removeNotify() - Method in class java.awt. Menu
删除菜单的对等体。
removeNotify() - Method in class java.awt. MenuBar
删除菜单栏的对等体。
removeNotify() - Method in class java.awt. MenuComponent
删除菜单组件的对等体。
removeNotify() - Method in class java.awt. TextComponent
删除 TextComponent的对等体。
removeNotify() - Method in class java.awt. Window
通过删除其与其本机屏幕资源的连接，使此容器不可显示。
removeNotify() - Method in class javafx.embed.swing. JFXPanel
通知此组件它不再具有父组件。
removeNotify() - Method in class javax.swing. AbstractButton
通知此组件它不再具有父组件。
removeNotify() - Method in class javax.swing. JButton
覆盖 JComponent.removeNotify以检查此按钮当前是否设置为 RootPane上的默认按钮，如果是，则将 RootPane的默认按钮设置为 null以确保 RootPane不会保持无效的按钮参考。
removeNotify() - Method in class javax.swing. JComponent
通知此组件它不再具有父组件。
removeNotify() - Method in class javax.swing. JLayer
通知此组件它不再具有父组件。
removeNotify() - Method in class javax.swing. JMenuBar
覆盖 JComponent.removeNotify以使用当前的键盘管理器取消注册此菜单栏。
removeNotify() - Method in class javax.swing. JRootPane
通知此组件它不再具有父组件。
removeNotify() - Method in class javax.swing. JTable
调用 unconfigureEnclosingScrollPane方法。
removeNotify() - Method in class javax.swing.text. JTextComponent
removeNotify(Component) - Method in class java.awt.im. InputContext
通知输入上下文，客户端组件已从其包含层次结构中删除，或该组件已禁用输入法支持。
removeObjectValue(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl
不允许将 Object引用存储在实现命名元素的节点中。
removeObservedObject(ObjectName) - Method in class javax.management.monitor. Monitor
从一组观察到的MBean中删除指定的对象。
removeObservedObject(ObjectName) - Method in interface javax.management.monitor. MonitorMBean
从一组观察到的MBean中删除指定的对象。
removeParameter(String) - Method in class javax.activation. MimeType
删除与给定名称相关联的任何值。
removeParameters() - Method in class java.awt.image.renderable. ParameterBlock
清除参数列表。
removePart(String) - Method in interface javax.jnlp. DownloadService
如果在应用程序的JNLP文件中提到了该部分，则从缓存中删除给定的部分。
removePart(String[]) - Method in interface javax.jnlp. DownloadService
如果在应用程序的JNLP文件中提到了这些部分，则从缓存中删除给定的部分。
removePermission(Permission) - Method in interface java.security.acl. AclEntry
已过时。
从此ACL条目中删除指定的权限。
removePopupMenuListener(PopupMenuListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 POPUPMENU事件。
removePopupMenuListener(PopupMenuListener) - Method in class javax.swing. JComboBox
删除一个 PopupMenuListener 。
removePopupMenuListener(PopupMenuListener) - Method in class javax.swing. JPopupMenu
删除一个 PopupMenu监听器。
removePostLayoutPulseListener(Runnable) - Method in class javafx.scene. Scene
从这个场景中的脉冲中删除先前注册的场景布局脉冲侦听器。
removePreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs. AbstractPreferences
removePreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs. Preferences
删除指定的首选项更改侦听器，因此它不再接收首选项更改事件。
removePreLayoutPulseListener(Runnable) - Method in class javafx.scene. Scene
从此场景中的脉冲中删除先前注册的场景预布置脉冲侦听器。
removePrintJobAttributeListener(PrintJobAttributeListener) - Method in interface javax.print. DocPrintJob
从此打印作业中移除属性侦听器。
removePrintJobListener(PrintJobListener) - Method in interface javax.print. DocPrintJob
从此打印作业中移除侦听器。
removePrintServiceAttributeListener(PrintServiceAttributeListener) - Method in interface javax.print. PrintService
从此打印服务中删除打印服务侦听器。
removeProperty(String) - Method in interface org.w3c.dom.css. CSSStyleDeclaration
用于删除CSS属性（如果在该声明块中已经显式设置）。
removePropertyChangeListener(PropertyChangeListener) - Static method in class com.sun.java.accessibility.util. AccessibilityEventMonitor
删除指定的监听器，使其在发生时不再接收PropertyChange事件。
removePropertyChangeListener(PropertyChangeListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 PROPERTYCHANGE事件。
removePropertyChangeListener(PropertyChangeListener) - Method in class com.sun.java.accessibility.util. Translator
从侦听器列表中删除 PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Method in interface com.sun.tools.jconsole. JConsoleContext
从侦听器列表中删除PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Component.AccessibleAWTComponent
从侦听器列表中删除一个PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Component
从侦听器列表中移除PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt. Container.AccessibleAWTContainer
从侦听器列表中删除一个PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt. KeyboardFocusManager
从侦听器列表中移除PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in interface java.beans. Customizer
删除PropertyChange事件的侦听器。
removePropertyChangeListener(PropertyChangeListener) - Method in class java.beans. PropertyChangeSupport
从侦听器列表中删除一个PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in interface java.beans. PropertyEditor
删除值更改的侦听器。
removePropertyChangeListener(PropertyChangeListener) - Method in class java.beans. PropertyEditorSupport
删除值更改的侦听器。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.accessibility. AccessibleContext
从侦听器列表中移除 PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. AbstractAction
从侦听器列表中删除 PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing. Action
删除一个 PropertyChange监听器。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JComponent.AccessibleJComponent
从侦听器列表中移除PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell
从侦听器列表中删除 PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
从侦听器列表中删除一个PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. JTree.EmptySelectionModel
这样做是无效的 EmptySelectionModel不允许选择。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.basic. BasicDirectoryModel
从侦听器列表中移除PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf. LayerUI
从侦听器列表中移除PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. SwingWorker
从侦听器列表中删除 PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table. TableColumn
从侦听器列表中删除 PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.tree. DefaultTreeSelectionModel
从侦听器列表中移除PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.tree. TreeSelectionModel
从侦听器列表中移除PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing. UIDefaults
从侦听器列表中删除 PropertyChangeListener 。
removePropertyChangeListener(PropertyChangeListener) - Static method in class javax.swing. UIManager
从侦听器列表中删除 PropertyChangeListener 。
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. Component
从侦听器列表中删除特定属性的 PropertyChangeListener 。
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. KeyboardFocusManager
从侦听器列表中为特定属性移除PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. SystemTray
从侦听器列表中删除特定属性的 PropertyChangeListener 。
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt. Toolkit
为指定的桌面属性移除指定的属性更改侦听器。
removePropertyChangeListener(String, PropertyChangeListener) - Method in interface java.beans.beancontext. BeanContextChild
从此 BeanContextChild删除 PropertyChangeListener ，以便在指定的属性更改时不再接收 PropertyChangeEvents 。
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.beancontext. BeanContextChildSupport
删除特定属性的PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans. PropertyChangeSupport
删除特定属性的PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - Method in class javax.swing.plaf. LayerUI
从侦听器列表中删除特定属性的 PropertyChangeListener 。
removeProvider(String) - Static method in class java.security. Security
删除具有指定名称的提供程序。
removeRange(int, int) - Method in class java.util. AbstractList
从此列表中删除所有索引为 fromIndex （含）和 toIndex之间的元素。
removeRange(int, int) - Method in class java.util. ArrayList
从此列表中删除所有索引为 fromIndex （含）和 toIndex之间的元素。
removeRange(int, int) - Method in class java.util. Vector
从此列表中删除所有索引为 fromIndex （含）和 toIndex之间的元素。
removeRange(int, int) - Method in class javafx.collections. ModifiableObservableListBase
removeRange(int, int) - Method in class javax.swing. DefaultListModel
删除指定范围的索引中的组件。
removeRedundantState() - Method in class javax.swing.undo. StateEdit
删除状态哈希表中的冗余密钥/值。
removeRelation(String) - Method in class javax.management.relation. RelationService
从关系服务中删除给定的关系。
removeRelation(String) - Method in interface javax.management.relation. RelationServiceMBean
从关系服务中删除给定的关系。
removeRelationType(String) - Method in class javax.management.relation. RelationService
从关系服务中删除给定的关系类型。
removeRelationType(String) - Method in interface javax.management.relation. RelationServiceMBean
从关系服务中删除给定的关系类型。
removeResource(URL, String) - Method in interface javax.jnlp. DownloadService
如果在调用应用程序JNLP文件中提到资源，则从缓存中删除给定的资源，在调用的应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
removeResourceBundle(String) - Method in class javax.swing. UIDefaults
从查找本地化默认值的资源束列表中删除资源包。
removeRow(int) - Method in class javax.swing.table. DefaultTableModel
从模型中删除 row的行。
removeRowSelectionInterval(int, int) - Method in class javax.swing. JTable
取消选择从 index0到 index1 （含）的行。
removeRowSetListener(RowSetListener) - Method in class javax.sql.rowset. BaseRowSet
从这个 RowSet对象的监听器列表中删除指定的对象。
removeRowSetListener(RowSetListener) - Method in interface javax.sql. RowSet
从在 RowSet对象发生事件时将被通知的组件列表中删除指定的侦听器。
removeRowSorterListener(RowSorterListener) - Method in class javax.swing. RowSorter
删除一个 RowSorterListener 。
removeSelectionInterval(int, int) - Method in class javax.swing. DefaultListSelectionModel
将选择更改为当前选择的设置差异和 index0与 index1含）之间的指数。
removeSelectionInterval(int, int) - Method in class javax.swing. JList
将选择设置为指定间隔和当前选择的设置差。
removeSelectionInterval(int, int) - Method in class javax.swing. JTree
从选择中删除指定的行（包括）。
removeSelectionInterval(int, int) - Method in interface javax.swing. ListSelectionModel
将选择更改为当前选择的设置差异和 index0与 index1之间的指数。
removeSelectionPath(TreePath) - Method in class javax.swing. JTree
从当前选择中删除由指定路径标识的节点。
removeSelectionPath(TreePath) - Method in class javax.swing.tree. DefaultTreeSelectionModel
从选择中删除路径。
removeSelectionPath(TreePath) - Method in interface javax.swing.tree. TreeSelectionModel
从选择中删除路径。
removeSelectionPaths(TreePath[]) - Method in class javax.swing. JTree.EmptySelectionModel
这样做是无效的 EmptySelectionModel不允许进行选择。
removeSelectionPaths(TreePath[]) - Method in class javax.swing. JTree
从当前选择中删除由指定路径标识的节点。
removeSelectionPaths(TreePath[]) - Method in class javax.swing.tree. DefaultTreeSelectionModel
从选择中删除路径。
removeSelectionPaths(TreePath[]) - Method in interface javax.swing.tree. TreeSelectionModel
从选择中删除路径。
removeSelectionRow(int) - Method in class javax.swing. JTree
从当前选择中删除索引号为 row的行。
removeSelectionRows(int[]) - Method in class javax.swing. JTree
删除在每个指定行中选择的行。
removeSeriesFromDisplay(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. XYChart
当您完成从图表中删除该系列的任何动画后，应从serialRemoved（）中调用这个。
removeService(Provider.Service) - Method in class java.security. Provider
删除以前使用 putService()添加的服务。
removeShortcuts() - Method in interface javax.jnlp. IntegrationService
请求删除应用程序的所有快捷方式。
removeShutdownHook(Thread) - Method in class java.lang. Runtime
取消注册以前注册的虚拟机关闭挂接。
removeSingleInstanceListener(SingleInstanceListener) - Method in interface javax.jnlp. SingleInstanceService
删除指定的SingleInstanceListener。
removeSources() - Method in class java.awt.image.renderable. ParameterBlock
清除源图像列表。
removeSpi(String) - Method in class java.util.prefs. AbstractPreferences
删除此首选项节点上指定键的关联（如果有）。
removeStatementEventListener(StatementEventListener) - Method in interface javax.sql. PooledConnection
从驱动程序检测到某个 PreparedStatement已关闭或无效时将通知的组件列表中删除指定的 StatementEventListener 。
removeStyle(String) - Method in class javax.swing. JTextPane
删除以前添加到文档的命名非 null样式。
removeStyle(String) - Method in class javax.swing.text. DefaultStyledDocument
删除之前添加到文档的命名样式。
removeStyle(String) - Method in class javax.swing.text.html. StyleSheet
删除之前添加到文档的命名样式。
removeStyle(String) - Method in class javax.swing.text. StyleContext
删除之前添加到文档的命名样式。
removeStyle(String) - Method in interface javax.swing.text. StyledDocument
删除之前添加到文档的命名样式。
removeStyleSheet(StyleSheet) - Method in class javax.swing.text.html. StyleSheet
从接收器中删除StyleSheet ss 。
removeTabAt(int) - Method in class javax.swing. JTabbedPane
删除标签 index 。
removeTableModelListener(TableModelListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 TABLEMODEL个事件。
removeTableModelListener(TableModelListener) - Method in class javax.swing.table. AbstractTableModel
从每次发生数据模型更改时通知的列表中移除侦听器。
removeTableModelListener(TableModelListener) - Method in interface javax.swing.table. TableModel
从每次发生数据模型更改时通知的列表中删除一个侦听器。
removeTagSet(TIFFTagSet) - Method in class javax.imageio.plugins.tiff. TIFFDirectory
从该目录知道的组中的一个TIFFTagSet组中删除一个元素。
removeTaskListener(TaskListener) - Method in class com.sun.source.util. JavacTask
删除指定的侦听器，使其不再收到描述此编译任务进度的事件的通知。
removeTextListener(TextListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
移除指定的侦听器，使其不再接收 TEXT事件。
removeTextListener(TextListener) - Method in class java.awt. TextComponent
删除指定的文本事件侦听器，使其不再从此文本组件接收文本事件。如果 l为 null ，则不会抛出异常，也不会执行任何操作。
removeTIFFField(int) - Method in class javax.imageio.plugins.tiff. TIFFDirectory
从目录中删除TIFF字段。
removeTIFFFields() - Method in class javax.imageio.plugins.tiff. TIFFDirectory
从目录中删除所有TIFF字段。
removeTileObserver(TileObserver) - Method in class java.awt.image. BufferedImage
移除瓦片观察者。
removeTileObserver(TileObserver) - Method in interface java.awt.image. WritableRenderedImage
删除观察者
removeTopLevelWindowListener(TopLevelWindowListener) - Static method in class com.sun.java.accessibility.util. EventQueueMonitor
删除指定的侦听器，以便在创建或销毁顶级窗口时通知该侦听器。
removeTransformer(ClassFileTransformer) - Method in interface java.lang.instrument. Instrumentation
注销提供的变压器。
removeTreeExpansionListener(TreeExpansionListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 TREEEXPANSION事件。
removeTreeExpansionListener(TreeExpansionListener) - Method in class javax.swing. JTree
移除 TreeExpansion事件的侦听 TreeExpansion 。
removeTreeModelListener(TreeModelListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 TREEMODEL事件。
removeTreeModelListener(TreeModelListener) - Method in class javax.swing.tree. DefaultTreeModel
删除之前使用 addTreeModelListener（）添加的监听器。
removeTreeModelListener(TreeModelListener) - Method in interface javax.swing.tree. TreeModel
删除以前添加的一个监听器 addTreeModelListener 。
removeTreeSelectionListener(TreeSelectionListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 TREESELECTION事件。
removeTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing. JTree.EmptySelectionModel
这样做是无效的 EmptySelectionModel不允许进行选择。
removeTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing. JTree
删除一个 TreeSelection监听器。
removeTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.tree. DefaultTreeSelectionModel
从每次所选树形路径组更改时通知的侦听器列表中删除x。
removeTreeSelectionListener(TreeSelectionListener) - Method in interface javax.swing.tree. TreeSelectionModel
从每次所选树形路径组更改时通知的侦听器列表中删除x。
removeTreeWillExpandListener(TreeWillExpandListener) - Method in class javax.swing. JTree
移除 TreeWillExpand事件的侦听 TreeWillExpand 。
removeUndoableEditListener(UndoableEditListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
删除指定的侦听器，使其不再接收 UNDOABLEEDIT事件。
removeUndoableEditListener(UndoableEditListener) - Method in class javax.swing.text. AbstractDocument
删除撤消侦听器。
removeUndoableEditListener(UndoableEditListener) - Method in interface javax.swing.text. Document
从通知列表中注销给定的观察者，因此它将不再接收更新。
removeUndoableEditListener(UndoableEditListener) - Method in class javax.swing.undo. UndoableEditSupport
删除一个 UndoableEditListener 。
removeUnicodeLocaleAttribute(String) - Method in class java.util. Locale.Builder
删除unicode区域设置属性（如果存在），否则不起作用。
removeUpdate() - Method in class javax.swing.text. DefaultStyledDocument.ElementBuffer
更新元素结构以响应从文档中相关序列的删除。
removeUpdate(DocumentEvent) - Method in interface javax.swing.event. DocumentListener
通知文档的一部分已被删除。
removeUpdate(DocumentEvent) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent
处理文档删除（触发适当的属性更改事件，即AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. FieldView
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. FlowView
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. GlyphView
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html. InlineView
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. PlainView
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. View
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. WrappedPlainView
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. ZoneView
在该视图负责的位置发出文档中已删除某些内容的通知。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text. AbstractDocument
由于删除文字而更新任何文档结构。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text. DefaultStyledDocument
由于删除文本而更新文档结构。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text. PlainDocument
由于删除文字而更新任何文档结构。
removeUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text. FlowView.FlowStrategy
在给定流程视图负责的位置发出文档中已删除某些内容的通知。
removeValue(String) - Method in interface javax.net.ssl. SSLSession
删除在会话的应用层数据中绑定到给定名称的对象。
removeVetoableChangeListener(VetoableChangeListener) - Static method in class com.sun.java.accessibility.util. SwingEventMonitor
移除指定的侦听器，使其不再接收 VETOABLECHANGE事件。
removeVetoableChangeListener(VetoableChangeListener) - Method in class java.awt. KeyboardFocusManager
从侦听器列表中删除VetoableChangeListener。
removeVetoableChangeListener(VetoableChangeListener) - Method in class java.beans. VetoableChangeSupport
从侦听器列表中删除VetoableChangeListener。
removeVetoableChangeListener(VetoableChangeListener) - Method in class javax.swing. JComponent
从侦听器列表中删除 VetoableChangeListener 。
removeVetoableChangeListener(String, VetoableChangeListener) - Method in class java.awt. KeyboardFocusManager
从侦听器列表中为特定属性删除VetoableChangeListener。
removeVetoableChangeListener(String, VetoableChangeListener) - Method in interface java.beans.beancontext. BeanContextChild
从此 BeanContextChild删除 VetoableChangeListener ，以便在指定的属性更改时不再收到事件。
removeVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.beancontext. BeanContextChildSupport
删除一个 VetoableChangeListener 。
removeVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans. VetoableChangeSupport
删除特定属性的VetoableChangeListener。
removeWindowFocusListener(WindowFocusListener) - Method in class java.awt. Window
删除指定的窗口焦点侦听器，使其不再从此窗口接收窗口事件。
removeWindowListener(WindowListener) - Static method in class com.sun.java.accessibility.util. AWTEventMonitor
移除指定的侦听器，使其在发生事件时不再接收 WINDOW事件。
removeWindowListener(WindowListener) - Method in class java.awt. Window
删除指定的窗口监听器，使其不再从此窗口接收窗口事件。
removeWindowStateListener(WindowStateListener) - Method in class java.awt. Window
删除指定的窗口状态监听器，使其不再从此窗口接收窗口事件。
rename(String, String) - Method in interface javax.naming. Context
将绑定到旧名称的对象绑定一个新名称，并取消绑定旧名称。
rename(String, String) - Method in class javax.naming. InitialContext
rename(Name, Name) - Method in interface javax.naming. Context
将绑定到旧名称的对象绑定一个新名称，并取消绑定旧名称。
rename(Name, Name) - Method in class javax.naming. InitialContext
renameFile(File, File) - Method in class javax.swing.plaf.basic. BasicDirectoryModel
重命名底层文件系统中的文件。
renameNode(Node, String, String) - Method in interface org.w3c.dom. Document
重命名类型为 ELEMENT_NODE或 ATTRIBUTE_NODE的现有节点。
renameTo(File) - Method in class java.io. File
重命名由此抽象路径名表示的文件。
render(Runnable) - Method in class javax.swing.text. AbstractDocument
如果模型支持异步更新，则可以在存在货币的情况下安全地呈现模型。
render(Runnable) - Method in interface javax.swing.text. Document
如果模型支持异步更新，则允许在存在并发性的情况下安全地呈现模型。
RENDERABLE_IMAGE - Static variable in class javax.print. DocFlavor.SERVICE_FORMATTED
服务格式化打印数据doc风格与打印数据表示类名= "java.awt.image.renderable.RenderableImage" （可渲染图像对象）。
RenderableImage - Interface in java.awt.image.renderable
RenderableImage是渲染无关的图像的通用接口（包含分辨率独立性的概念）。
RenderableImageOp - Class in java.awt.image.renderable
此类通过其关联的ContextualRenderedImageFactory实例的帮助来处理操作的可渲染方面。
RenderableImageOp(ContextualRenderedImageFactory, ParameterBlock) - Constructor for class java.awt.image.renderable. RenderableImageOp
构造一个RenderedImageOp给定一个ContextualRenderedImageFactory对象，以及一个包含RenderableImage源和其他参数的ParameterBlock。
RenderableImageProducer - Class in java.awt.image.renderable
一个实现ImageProducer以允许异步生成RenderableImage的适配器类。
RenderableImageProducer(RenderableImage, RenderContext) - Constructor for class java.awt.image.renderable. RenderableImageProducer
从RenderableImage和RenderContext构造一个新的RenderableImageProducer。
RenderContext - Class in java.awt.image.renderable
RenderContext封装了从RenderableImage生成特定渲染所需的信息。
RenderContext(AffineTransform) - Constructor for class java.awt.image.renderable. RenderContext
构造具有给定变换的RenderContext。
RenderContext(AffineTransform, RenderingHints) - Constructor for class java.awt.image.renderable. RenderContext
构造一个具有给定变换和渲染提示的RenderContext。
RenderContext(AffineTransform, Shape) - Constructor for class java.awt.image.renderable. RenderContext
构造一个具有给定变换和感兴趣区域的RenderContext。
RenderContext(AffineTransform, Shape, RenderingHints) - Constructor for class java.awt.image.renderable. RenderContext
构造具有给定变换的RenderContext。
RenderedImage - Interface in java.awt.image
RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。
RenderedImageFactory - Interface in java.awt.image.renderable
RenderedImageFactory接口（通常缩写为RIF）旨在由希望充当工厂来生成不同渲染的类实现，例如通过在一组源上执行一系列BufferedImageOps，具体取决于特定的一组参数，属性，并提供提示。
renderer - Variable in class javax.swing. JComboBox
此保护字段是实现特定的。
renderer - Variable in class javax.swing.tree. DefaultTreeCellEditor
渲染器用于获取边框和偏移量。
Renderer - Interface in javax.swing
定义负责“渲染”（显示）值的对象的要求。
rendererPane - Variable in class javax.swing.plaf.basic. BasicListUI
实例 CellRendererPane 。
rendererPane - Variable in class javax.swing.plaf.basic. BasicTableHeaderUI
实例 CellRendererPane 。
rendererPane - Variable in class javax.swing.plaf.basic. BasicTableUI
实例 CellRendererPane 。
rendererPane - Variable in class javax.swing.plaf.basic. BasicTreeUI
用于绘制TreeCellRenderer。
rendererPane - Variable in class javax.swing.plaf.metal. MetalComboBoxButton
实例 CellRendererPane 。
RenderingHints - Class in java.awt
RenderingHints类定义和管理密钥和关联值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。
RenderingHints(RenderingHints.Key, Object) - Constructor for class java.awt. RenderingHints
使用指定的键/值对构造新对象。
RenderingHints(Map<RenderingHints.Key, ?>) - Constructor for class java.awt. RenderingHints
构造一个新对象，该对象具有从指定的Map对象初始化的键和值，该对象可能为null。
RenderingHints.Key - Class in java.awt
定义与RenderingHints类一起使用的所有键的基本类型，以控制渲染和成像管道中的各种算法选择。
renderScaleXProperty() - Method in class javafx.stage. Window
水平尺度的 Window渲染它的时候会使用 Scene到绘制缓冲。
renderScaleYProperty() - Method in class javafx.stage. Window
垂直刻度的 Window渲染它的时候会使用 Scene到绘制缓冲。
reorderableProperty() - Method in class javafx.scene.control. TableColumnBase
用于打开和关闭此列的“可重新排序”的布尔属性（通过修改适当的 columns列表进行拖放 - 重新排序）始终是允许的）。
reorderingAllowed - Variable in class javax.swing.table. JTableHeader
如果为true，用户可以重新排列列; 默认值为true。
reorderVisually(byte[], int, Object[], int, int) - Static method in class java.text. Bidi
将数组中的对象根据其级别重新排序为可视化顺序。
repaint() - Method in class java.awt. Component
重新编辑这个组件。
repaint() - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
repaint() - Method in class javax.swing.table. DefaultTableCellRenderer
由于性能原因而被覆盖。
repaint() - Method in class javax.swing.text. DefaultCaret
导致插入符号被画。
repaint() - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
repaint(int, int, int, int) - Method in class java.awt. Component
重新绘制该组件的指定矩形。
repaint(long) - Method in class java.awt. Component
重写组件。
repaint(long, int, int, int, int) - Method in class java.awt. Component
在 tm毫秒内重新绘制该组件的指定矩形。
repaint(long, int, int, int, int) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
repaint(long, int, int, int, int) - Method in class javax.swing. JApplet
已过时。
在 time毫秒内重新绘制此组件的指定矩形。
repaint(long, int, int, int, int) - Method in class javax.swing. JComponent
如果组件显示，则将指定的区域添加到脏区列表。
repaint(long, int, int, int, int) - Method in class javax.swing. JDialog
在 time毫秒内重新绘制该组件的指定矩形。
repaint(long, int, int, int, int) - Method in class javax.swing. JFrame
在 time毫秒内重新绘制该组件的指定矩形。
repaint(long, int, int, int, int) - Method in class javax.swing. JViewport
始终在父母坐标系中重画，以确保只有一个油漆由 RepaintManager执行。
repaint(long, int, int, int, int) - Method in class javax.swing. JWindow
在 time毫秒内重新绘制该组件的指定矩形。
repaint(long, int, int, int, int) - Method in class javax.swing.table. DefaultTableCellRenderer
由于性能原因而被覆盖。
repaint(long, int, int, int, int) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
repaint(Rectangle) - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
repaint(Rectangle) - Method in class javax.swing. JComponent
如果组件显示，则将指定的区域添加到脏区列表。
repaint(Rectangle) - Method in class javax.swing.table. DefaultTableCellRenderer
由于性能原因而被覆盖。
repaint(Rectangle) - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
repaintCellFocus() - Method in class javax.swing.plaf.basic. BasicListUI.FocusHandler
重新聚焦细胞。
RepaintManager - Class in javax.swing
此类管理重绘请求，允许重绘的数量最小化，例如通过将多个请求压缩为组件树成员的单个重绘。
RepaintManager() - Constructor for class javax.swing. RepaintManager
创建一个新的RepaintManager实例。
REPEAT - java.awt. MultipleGradientPaint.CycleMethod
以渐变颜色从头到尾循环，从头到尾填充剩余的区域。
REPEAT - javafx.scene.layout. BackgroundRepeat
根据需要经常重复图像以覆盖该区域。
REPEAT - javafx.scene.layout. BorderRepeat
图像被平铺（重复）填补该区域。
REPEAT - javafx.scene.paint. CycleMethod
定义重复渐变颜色以填充剩余区域的循环方法。
Repeatable - Annotation Type in java.lang.annotation
注释类型 java.lang.annotation.Repeatable用于指示其（meta-）注释声明的注释类型是 可重复的 。
repeatKeyAction - Variable in class javax.swing.plaf.basic. BasicTreeUI.KeyHandler
正在生成的关键代码。
replace(char, char) - Method in class java.lang. String
返回从替换所有出现的导致一个字符串 oldChar ，在这个字符串 newChar 。
replace(int, int, String) - Method in class java.lang. StringBuffer
replace(int, int, String) - Method in class java.lang. StringBuilder
replace(int, int, String, AttributeSet) - Method in class javax.swing.text. AbstractDocument
将文本区域从 offset删除到 offset + length ，并将其替换为 text 。
replace(int, int, String, AttributeSet) - Method in class javax.swing.text. DocumentFilter.FilterBypass
将文本区域从 offset删除到 offset + length ，并将其替换为 text 。
replace(int, int, Element[]) - Method in class javax.swing.text. AbstractDocument.BranchElement
用新的元素集替换内容。
replace(int, int, View[]) - Method in class javax.swing.text. AsyncBoxView
调用超类更新子视图，并更新子节点的状态记录。
replace(int, int, View[]) - Method in class javax.swing.text. BoxView
使布局无效，并调整请求/分配缓存的大小。
replace(int, int, View[]) - Method in class javax.swing.text. CompositeView
代替子视图。
replace(int, int, View[]) - Method in class javax.swing.text. TableView
更改子视图。
replace(int, int, View[]) - Method in class javax.swing.text. TableView.TableRow
更改子视图。
replace(int, int, View[]) - Method in class javax.swing.text. View
代替子视图。
replace(Component, Component) - Method in class javax.swing. GroupLayout
用新的组件代替现有组件。
replace(CharSequence, CharSequence) - Method in class java.lang. String
将与字面目标序列匹配的字符串的每个子字符串替换为指定的文字替换序列。
replace(Object, Object) - Method in class java.security. Provider
只有当目标映射到某个值时，才能替换指定键的条目。
replace(Object, Object) - Method in class java.util. Properties
replace(Object, Object, Object) - Method in class java.security. Provider
仅当当前映射到指定的值时，才能替换指定键的条目。
replace(DocumentFilter.FilterBypass, int, int, String, AttributeSet) - Method in class javax.swing.text. DocumentFilter
在替换指定文档中的文本区域之前调用。
replace(K, V) - Method in class java.util.concurrent. ConcurrentHashMap
仅当当前映射到某个值时才替换该项的条目。
replace(K, V) - Method in interface java.util.concurrent. ConcurrentMap
仅当当前映射到某个值时才替换该项的条目。
replace(K, V) - Method in class java.util.concurrent. ConcurrentSkipListMap
仅当当前映射到某个值时才替换该项的条目。
replace(K, V) - Method in class java.util. HashMap
replace(K, V) - Method in class java.util. Hashtable
replace(K, V) - Method in interface java.util. Map
只有当目标映射到某个值时，才能替换指定键的条目。
replace(K, V) - Method in class java.util. TreeMap
replace(K, V, V) - Method in class java.util.concurrent. ConcurrentHashMap
仅当当前映射到给定值时才替换密钥的条目。
replace(K, V, V) - Method in interface java.util.concurrent. ConcurrentMap
仅当当前映射到给定值时才替换密钥的条目。
replace(K, V, V) - Method in class java.util.concurrent. ConcurrentSkipListMap
仅当当前映射到给定值时才替换密钥的条目。
replace(K, V, V) - Method in class java.util. HashMap
replace(K, V, V) - Method in class java.util. Hashtable
replace(K, V, V) - Method in interface java.util. Map
仅当当前映射到指定的值时，才能替换指定键的条目。
replace(K, V, V) - Method in class java.util. TreeMap
REPLACE - Static variable in class java.nio.charset. CodingErrorAction
指示通过丢弃错误输入来处理编码错误的动作，将编码器的替换值附加到输出缓冲器，并恢复编码操作。
REPLACE_ATTRIBUTE - Static variable in interface javax.naming.directory. DirContext
该常数指定用指定值替换属性。
REPLACE_EXISTING - java.nio.file. StandardCopyOption
替换现有文件（如果存在）。
replaceAll(String) - Method in class java.util.regex. Matcher
将与模式匹配的输入序列的每个子序列替换为给定的替换字符串。
replaceAll(String, String) - Method in class java.lang. String
用给定的替换替换与给定的 regular expression匹配的此字符串的每个子字符串。
replaceAll(BiFunction<? super Object, ? super Object, ?>) - Method in class java.util. Properties
replaceAll(BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security. Provider
用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentHashMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.concurrent. ConcurrentMap
将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent. ConcurrentSkipListMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. HashMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. Hashtable
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. IdentityHashMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. LinkedHashMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util. Map
将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. TreeMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util. WeakHashMap
replaceAll(Function<MatchResult, String>) - Method in class java.util.regex. Matcher
将与模式匹配的输入序列的每个子序列替换为将给定的替换器函数应用于与该子序列相对应的匹配器的匹配结果的结果。
replaceAll(UnaryOperator<E>) - Method in class java.util. ArrayList
replaceAll(UnaryOperator<E>) - Method in class java.util.concurrent. CopyOnWriteArrayList
replaceAll(UnaryOperator<E>) - Method in interface java.util. List
将该列表的每个元素替换为将该运算符应用于该元素的结果。
replaceAll(UnaryOperator<E>) - Method in class java.util. Vector
replaceAll(List<T>, T, T) - Static method in class java.util. Collections
将列表中一个指定值的所有出现替换为另一个。
replaceAll(ObservableList<T>, T, T) - Static method in class javafx.collections. FXCollections
用newVal元素替换列表中的所有oldVal元素。
replaceArguments(CallSiteDescriptor, Object...) - Method in interface jdk.dynalink.linker. LinkRequest
返回与此调用站点描述符相同的请求，并使用指定的参数替换参数。
replaceArguments(CallSiteDescriptor, Object...) - Method in class jdk.dynalink.linker.support. SimpleLinkRequest
replaceChild(Node, Node) - Method in class javax.imageio.metadata. IIOMetadataNode
替换子节点 oldChild与 newChild儿童的名单，并返回 oldChild节点。
replaceChild(Node, Node) - Method in interface org.w3c.dom. Node
替换子节点 oldChild与 newChild儿童的名单，并返回 oldChild节点。
replaceData(int, int, String) - Method in interface org.w3c.dom. CharacterData
用指定的字符串替换从指定的16位单位偏移开始的字符。
replaceEdit(UndoableEdit) - Method in class javax.swing.undo. AbstractUndoableEdit
此默认实现返回false。
replaceEdit(UndoableEdit) - Method in interface javax.swing.undo. UndoableEdit
如果这个 UndoableEdit应该替换 anEdit则返回true。
replaceEditor(JComponent, JComponent) - Method in class javax.swing.plaf.basic. BasicSpinnerUI
由被叫 PropertyChangeListener当 JSpinner编辑属性更改。
replaceEditor(JComponent, JComponent) - Method in class javax.swing.plaf.synth. SynthSpinnerUI
由 PropertyChangeListener当 JSpinner编辑器属性更改时调用。
replaceFirst(String) - Method in class java.util.regex. Matcher
将与模式匹配的输入序列的第一个子序列替换为给定的替换字符串。
replaceFirst(String, String) - Method in class java.lang. String
用给定的替换替换与给定的 regular expression匹配的此字符串的第一个子字符串。
replaceFirst(Function<MatchResult, String>) - Method in class java.util.regex. Matcher
将与模式匹配的输入序列的第一个子序列替换为将给定的替换器函数应用于与该子序列对应的匹配器的匹配结果的结果。
replaceImageMetadata(int, IIOMetadata) - Method in class javax.imageio. ImageWriter
替换与现有图像相关联的图像元数据。
replaceItem(String, int) - Method in class java.awt. List
使用新的字符串替换滚动列表中指定索引处的项目。
replacement() - Method in class java.nio.charset. CharsetDecoder
返回此解码器的替换值。
replacement() - Method in class java.nio.charset. CharsetEncoder
返回此编码器的替换值。
replaceMethods(MethodHandle, MethodHandle) - Method in class jdk.dynalink.linker. GuardedInvocation
用不同的方法创建一个新的守卫调用，保留切换点。
replaceObject(Object) - Method in class java.io. ObjectOutputStream
该方法将允许ObjectOutputStream的可信子类在序列化期间将一个对象替换为另一个对象。
replacePane(JComponent, JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
在 newPane上安装必要的鼠标处理程序，并将其添加到框架中。
replacePixels(Raster, ImageWriteParam) - Method in class javax.imageio. ImageWriter
用给定的 Raster的一部分替换已经存在于输出中的图像的一部分。
replacePixels(RenderedImage, ImageWriteParam) - Method in class javax.imageio. ImageWriter
用给定图像的一部分替换已经存在于输出中的图像的一部分。
replaceRange(String, int, int) - Method in class java.awt. TextArea
将指定的开始和结束位置之间的文本替换为指定的替换文本。
replaceRange(String, int, int) - Method in class javax.swing. JTextArea
用指定的新文本替换指定的开始到结束位置的文本。
replaceSelection(String) - Method in class javafx.scene.control. TextInputControl
用给定的替换字符串替换选择。
replaceSelection(String) - Method in class javax.swing. JEditorPane
用给定字符串表示的新内容替换当前所选内容。
replaceSelection(String) - Method in class javax.swing. JTextPane
用给定字符串表示的新内容替换当前所选内容。
replaceSelection(String) - Method in class javax.swing.text. JTextComponent
用给定字符串表示的新内容替换当前所选内容。
replaceStreamMetadata(IIOMetadata) - Method in class javax.imageio. ImageWriter
用新信息替换输出中的流元数据。
replaceText(int, int, String) - Method in class javafx.scene.control.skin. TextFieldSkin
用给定的文本替换一系列的字符。
replaceText(int, int, String) - Method in class javafx.scene.control. TextInputControl
用给定的文本替换一系列的字符。
replaceText(int, int, String) - Method in interface javax.accessibility. AccessibleEditableText
用指定的字符串替换两个索引之间的文本。
replaceText(int, int, String) - Method in class javax.swing. JSpinner.AccessibleJSpinner
用指定的字符串替换两个索引之间的文本。
replaceText(int, int, String) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent
用指定的字符串替换两个索引之间的文本。
replaceText(String, int, int) - Method in class java.awt. TextArea
已过时。
从JDK 1.1版开始，由replaceRange(String, int, int)代替。
replaceText(IndexRange, String) - Method in class javafx.scene.control. TextInputControl
用给定的文本替换一系列的字符。
replaceUIActionMap(JComponent, ActionMap) - Static method in class javax.swing. SwingUtilities
方便的方法来改变UI ActionMap为 component到 uiActionMap 。
replaceUIInputMap(JComponent, int, InputMap) - Static method in class javax.swing. SwingUtilities
方便的方法将UI InputMap为 component为 uiInputMap 。
replaceWholeText(String) - Method in interface org.w3c.dom. Text
用指定的文本替换当前节点和所有逻辑上相邻的文本节点的文本。
replaceWith(byte[]) - Method in class java.nio.charset. CharsetEncoder
更改此编码器的替换值。
replaceWith(String) - Method in class java.nio.charset. CharsetDecoder
更改此解码器的替换值。
ReplicateScaleFilter - Class in java.awt.image
一个ImageFilter类，用于使用最简单的算法缩放图像。
ReplicateScaleFilter(int, int) - Constructor for class java.awt.image. ReplicateScaleFilter
构造一个ReplicateScaleFilter，可以根据width和height参数指定的其像素的像素进行缩放。
reply_status() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
描述操作调用结果的状态。
report(String, String, Object, Location) - Method in interface javax.xml.stream. XMLReporter
以应用程序特定格式报告所需的消息。
report(Diagnostic<? extends S>) - Method in class javax.tools. DiagnosticCollector
report(Diagnostic<? extends S>) - Method in interface javax.tools. DiagnosticListener
当发现问题时调用。
report(Diagnostic) - Method in interface jdk.nashorn.api.tree. DiagnosticListener
每当发现解析问题时调用。
REPORT - Static variable in class java.nio.charset. CodingErrorAction
通过返回CoderResult对象或抛出一个CharacterCodingException （以适用于实现编码过程的方法为准）来报告编码错误的动作。
REPORT - Static variable in class javax.print.attribute.standard. Severity
表示PrinterStateReason是“报告”（最不严重）。
Reporter - Interface in jdk.javadoc.doclet
此界面提供错误，警告和通知报告。
REPORTER - Static variable in class javax.xml.stream. XMLInputFactory
该属性用于设置/获取XMLReporter接口的实现
reportError(String, Exception, int) - Method in class java.util.logging. Handler
受保护的方便方法来向此处理程序的ErrorManager报告错误。
RepositoryIdHelper - Class in org.omg.CORBA
助手 RepositoryId 。
RepositoryIdHelper() - Constructor for class org.omg.CORBA. RepositoryIdHelper
request() - Method in interface com.sun.jdi.event. Event
request() - Method in class jdk.incubator.http. HttpResponse
返回启动交换的初始值HttpRequest 。
request(long) - Method in interface java.util.concurrent. Flow.Subscription
将给定数 n项目为这个订阅目前未实现的需求。
request(long) - Method in interface jdk.incubator.http. WebSocket
允许n更多的消息由Listener接收。
request(Object, String) - Method in class org.omg.CORBA.portable. Delegate
创建一个要在动态调用接口中使用的请求实例。
request(Object, String, boolean) - Method in class org.omg.CORBA.portable. Delegate
请求被stub调用以获取用于封送参数的OutputStream。
Request - Class in org.omg.CORBA
包含调用方法所需信息的对象。
Request() - Constructor for class org.omg.CORBA. Request
REQUEST_CIPHER_SUITE - Static variable in class javax.xml.ws.spi.http. HttpExchange
标准属性：通过HTTPS接收请求时的密码套件值
REQUEST_FOCUS - javafx.scene. AccessibleAction
请求节点采取焦点。
request_id() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
返回唯一标识活动请求/回复序列的ID。
REQUEST_KEY_SIZE - Static variable in class javax.xml.ws.spi.http. HttpExchange
标准属性：通过HTTPS接收请求时算法的位大小
REQUEST_PROCESSING_POLICY_ID - Interface in org.omg.PortableServer
org / omg / PortableServer / REQUEST_PROCESSING_POLICY_ID.java。
REQUEST_X509CERTIFICATE - Static variable in class javax.xml.ws.spi.http. HttpExchange
标准属性：与请求相关联的SSL证书（如果有）
requestAnonymity(boolean) - Method in interface org.ietf.jgss. GSSContext
要求发起人的身份不被披露给受理人。
requestAssociation(String, String[]) - Method in interface javax.jnlp. IntegrationService
请求将此应用程序注册为指定的MIME类型和文件扩展名的处理程序。
requestAxisLayout() - Method in class javafx.scene.chart. Axis
请求轴在下一个布局通过中布局。
requestChartLayout() - Method in class javafx.scene.chart. Chart
当你知道某些事情发生了变化，需要将图表转发出来时，就会调用它。
requestConf(boolean) - Method in interface org.ietf.jgss. GSSContext
要求对 wrap方法启用数据机密性。
requestCredDeleg(boolean) - Method in interface org.ietf.jgss. GSSContext
请求在上下文建立期间将启动器的凭据委托给接受者。
requestDefaultFocus() - Method in class javax.swing. JComponent
已过时。
截至1.4，由FocusTraversalPolicy.getDefaultComponent(Container).requestFocus()替代
requestDelegPolicy(boolean) - Method in interface com.sun.security.jgss. ExtendedGSSContext
要求尊重授权政策。
requestFocus() - Method in class com.sun.java.accessibility.util. Translator
请求关注此对象。
requestFocus() - Method in class java.awt. Component.AccessibleAWTComponent
请求关注此对象。
requestFocus() - Method in class java.awt. Component
请求此组件获取输入焦点，并且该组件的顶级祖先成为关注的窗口。
requestFocus() - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild
请求关注此对象。
requestFocus() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent
请求关注此对象。
requestFocus() - Method in class javafx.scene. Node
要求这个 Node得到输入焦点，而这个 Node的顶级祖先成为焦点窗口。
requestFocus() - Method in class javafx.stage. Window
要求这个 Window得到输入焦点。
requestFocus() - Method in interface javax.accessibility. AccessibleComponent
请求关注此对象。
requestFocus() - Method in class javax.swing. JComponent
请求这个 Component获取输入焦点。
requestFocus() - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild
requestFocus() - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell
requestFocus() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode
requestFocus() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane.SystemMenuBar
requestFocus() - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
requestFocus(boolean) - Method in class java.awt. Component
要求这个 Component得到输入焦点，而这个 Component的顶级祖先成为焦点 Window 。
requestFocus(boolean) - Method in class javax.swing. JComponent
请求这个 Component获取输入焦点。
requestFocus(boolean, FocusEvent.Cause) - Method in class java.awt. Component
要求由 cause这个 Component得到输入的焦点，而这个 Component的顶级祖先成为焦点 Window 。
requestFocus(FocusEvent.Cause) - Method in class java.awt. Component
请求由 cause这个组件得到输入焦点，并且该组件的顶级祖先成为关注的窗口。
requestFocus(FocusEvent.Cause) - Method in class javax.swing. JToggleButton
如果此切换按钮是ButtonGroup的成员，该另一个切换按钮被选中，并且可以是焦点所有者，并且焦点原因参数表示任何方向的窗口激活或焦点遍历操作，则方法执行的结果与在组中选择的切换按钮上调用Component.requestFocus(FocusEvent.Cause) 。
requestFocusInWindow() - Method in class java.awt. Component
要求此组件获取输入焦点，如果此组件的顶级祖先已经是关注的窗口。
requestFocusInWindow() - Method in class javax.swing. JComponent
请求这个 Component得到输入焦点。
requestFocusInWindow(boolean) - Method in class java.awt. Component
要求这个 Component得到输入焦点，如果这个 Component的顶级祖先已经是焦点 Window 。
requestFocusInWindow(boolean) - Method in class javax.swing. JComponent
要求这个 Component得到输入焦点。
requestFocusInWindow(FocusEvent.Cause) - Method in class java.awt. Component
由于 cause请求，该组件获得输入焦点，如果此组件的顶级祖先已经是聚焦的窗口。
requestFocusInWindow(FocusEvent.Cause) - Method in class javax.swing. JToggleButton
如果此切换按钮是ButtonGroup的成员，该另一个切换按钮被选中并且可以是焦点所有者，并且焦点原因参数表示任何方向的窗口激活或焦点遍历操作，则方法执行的结果与在组中选择的切换按钮上调用Component.requestFocusInWindow(FocusEvent.Cause) 。
requestForeground(boolean) - Method in class java.awt. Desktop
请求此应用程序移动到前台。
RequestInfo - Interface in org.omg.PortableInterceptor
请求信息，拦截器可访问。
RequestInfoOperations - Interface in org.omg.PortableInterceptor
请求信息，拦截器可访问。
RequestingUserName - Class in javax.print.attribute.standard
Class RequestingUserName是一个打印属性类，一个文本属性，指定提交打印作业的最终用户的名称。
RequestingUserName(String, Locale) - Constructor for class javax.print.attribute.standard. RequestingUserName
使用给定的用户名和区域设置构造一个新的请求用户名属性。
requestInteg(boolean) - Method in interface org.ietf.jgss. GSSContext
要求对 wrap和 getMIC方法启用数据完整性。
requestLayout() - Method in class javafx.scene.chart. Axis
我们通过不做任何事情来抑制requestLayout（）调用，因为我们不希望更改我们的孩子来导致布局。
requestLayout() - Method in class javafx.scene.control. Accordion
请求在渲染下一个场景之前执行布局传递。
requestLayout() - Method in class javafx.scene.control. PopupControl.CSSBridge
请求在渲染下一个场景之前执行布局传递。
requestLayout() - Method in class javafx.scene.control.skin. VirtualFlow
被覆盖来实现更有效地支持布局。
requestLayout() - Method in class javafx.scene.layout. ConstraintsBase
在与此约束对象相关联的布局父项上调用requestLayout。
requestLayout() - Method in class javafx.scene.layout. FlowPane
requestLayout() - Method in class javafx.scene.layout. GridPane
requestLayout() - Method in class javafx.scene.layout. HBox
requestLayout() - Method in class javafx.scene.layout. StackPane
requestLayout() - Method in class javafx.scene.layout. TilePane
requestLayout() - Method in class javafx.scene.layout. VBox
requestLayout() - Method in class javafx.scene. Parent
请求在渲染下一个场景之前执行布局传递。
requestLayout() - Method in class javafx.scene.text. TextFlow
requestLifetime(int) - Method in interface org.ietf.jgss. GSSContext
为上下文请求一秒钟的生命周期。
requestMutualAuth(boolean) - Method in interface org.ietf.jgss. GSSContext
要求在上下文建立期间进行相互验证。
requestNextPulse() - Static method in class javafx.application. Platform
请求Java运行时执行脉冲。
requestParentLayout() - Method in class javafx.scene. Parent
请求在呈现下一个场景之前执行的父级的布局传递。
requestPasswordAuthentication(String, InetAddress, int, String, String, String) - Static method in class java.net. Authenticator
请向系统注册的验证者询问密码。
requestPasswordAuthentication(String, InetAddress, int, String, String, String, URL, Authenticator.RequestorType) - Static method in class java.net. Authenticator
请向系统注册的验证者询问密码。
requestPasswordAuthentication(Authenticator, String, InetAddress, int, String, String, String, URL, Authenticator.RequestorType) - Static method in class java.net. Authenticator
询问给定的 authenticator密码。
requestPasswordAuthentication(InetAddress, int, String, String, String) - Static method in class java.net. Authenticator
请向系统注册的验证者询问密码。
requestPasswordAuthenticationInstance(String, InetAddress, int, String, String, String, URL, Authenticator.RequestorType) - Method in class java.net. Authenticator
向该验证者询问密码。
RequestProcessingPolicy - Interface in org.omg.PortableServer
此策略指定创建的POA如何处理请求。
RequestProcessingPolicyOperations - Interface in org.omg.PortableServer
此策略指定创建的POA如何处理请求。
RequestProcessingPolicyValue - Class in org.omg.PortableServer
RequestProcessingPolicyValue可以具有以下值。
RequestProcessingPolicyValue(int) - Constructor for class org.omg.PortableServer. RequestProcessingPolicyValue
requestReplayDet(boolean) - Method in interface org.ietf.jgss. GSSContext
在上下文建立之后，请求对每个消息安全服务启用重播检测。
requestSequenceDet(boolean) - Method in interface org.ietf.jgss. GSSContext
请求在上下文建立后为每个消息安全服务启用序列检查。
requestShortcut(boolean, boolean, String) - Method in interface javax.jnlp. IntegrationService
请求为此应用程序创建快捷方式。
requestTopDownLeftRightResend(ImageConsumer) - Method in class java.awt.image. FilteredImageSource
请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
requestTopDownLeftRightResend(ImageConsumer) - Method in interface java.awt.image. ImageProducer
请求，代表的 ImageConsumer ，该 ImageProducer尝试重新发送图像数据的一个更多的时间在TOPDOWNLEFTRIGHT顺序，以便依赖于按顺序接收像素更高质量的变换算法可以用于产生图像的更好的输出的版本。
requestTopDownLeftRightResend(ImageConsumer) - Method in class java.awt.image. MemoryImageSource
请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
requestTopDownLeftRightResend(ImageConsumer) - Method in class java.awt.image.renderable. RenderableImageProducer
请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
requestUserAttention(boolean, boolean) - Method in class java.awt. Taskbar
请求用户注意此应用程序。
requestWindowUserAttention(Window) - Method in class java.awt. Taskbar
请求用户注意指定的窗口。
RequestWrapper - Annotation Type in javax.xml.ws
用于使用要在运行时使用的请求包装器bean来注释服务端点接口中的方法。
require(int, String, String) - Method in class javax.xml.stream.util. StreamReaderDelegate
require(int, String, String) - Method in interface javax.xml.stream. XMLStreamReader
测试当前事件是否为给定类型，如果命名空间和名称与当前命名空间和当前事件的名称相匹配。
required - Variable in class java.sql. DriverPropertyInfo
如果在 Driver.connect和 false必须为此属性提供值，则 required字段为 true 。
required - Variable in class javax.xml.ws.soap. AddressingFeature
如果启用寻址，则此属性确定端点是否需要WS-Addressing。
REQUIRED - Static variable in class java.awt. GraphicsConfigTemplate
用于“Enum”（整数）类型的值。
REQUIRED - Static variable in class javax.security.auth.login. AppConfigurationEntry.LoginModuleControlFlag
需要 LoginModule 。
REQUIRED - Static variable in interface javax.swing.text.html.parser. DTDConstants
DTD常数对应于REQUIRED
RequiredModelMBean - Class in javax.management.modelmbean
这个类是一个ModelMBean的实现。
RequiredModelMBean() - Constructor for class javax.management.modelmbean. RequiredModelMBean
构造一个空的ModelMBeanInfo的 RequiredModelMBean 。
RequiredModelMBean(ModelMBeanInfo) - Constructor for class javax.management.modelmbean. RequiredModelMBean
使用传入的ModelMBeanInfo构造一个RequiredModelMBean对象。
requireEnd() - Method in class java.util.regex. Matcher
如果更多输入可以将正匹配更改为否定，则返回true。
requireNonNull(T) - Static method in class java.util. Objects
检查指定的对象引用不是 null 。
requireNonNull(T, String) - Static method in class java.util. Objects
检查指定的对象引用不是null并抛出一个自定义的NullPointerException（如果是）。
requireNonNull(T, Supplier<String>) - Static method in class java.util. Objects
检查指定的对象引用不是null并抛出一个自定义的NullPointerException（如果是）。
requireNonNullElse(T, T) - Static method in class java.util. Objects
如果第二个参数为非 null ，则返回第二个参数，否则返回非参数 null 。
requireNonNullElseGet(T, Supplier<? extends T>) - Static method in class java.util. Objects
如果它不是 null ，则返回第一个参数，否则返回非 null值为 supplier.get() 。
requires() - Method in class java.lang.module. ModuleDescriptor
返回表示模块依赖关系的一组 Requires对象。
requires(ModuleDescriptor.Requires) - Method in class java.lang.module. ModuleDescriptor.Builder
增加对模块的依赖。
requires(String) - Method in class java.lang.module. ModuleDescriptor.Builder
使用一组空白的修饰符添加对模块的依赖。
requires(Set<ModuleDescriptor.Requires.Modifier>, String) - Method in class java.lang.module. ModuleDescriptor.Builder
使用给定（可能为空）的修饰符集添加对模块的依赖。
requires(Set<ModuleDescriptor.Requires.Modifier>, String, ModuleDescriptor.Version) - Method in class java.lang.module. ModuleDescriptor.Builder
使用给定（可能为空）的修饰符集添加对模块的依赖。
REQUIRES - com.sun.source.tree. Tree.Kind
用于表示需要在模块声明中指令的RequiresTree的实例。
REQUIRES - javax.lang.model.element. ModuleElement.DirectiveKind
一个“require（static | transitive）* module-name”指令。
REQUIRES_ATTENTION - Static variable in class javax.print.event. PrintJobEvent
打印服务表示在打印服务可以继续之前，可能需要外部干预。
requiresBidi(char[], int, int) - Static method in class java.text. Bidi
如果指定的文本需要双向分析，则返回true。
requiresIn(Iterable<? extends ModuleElement.Directive>) - Static method in class javax.lang.model.util. ElementFilter
在 directives返回 requires指令的列表。
RequiresTree - Interface in com.sun.source.tree
模块声明中“require”指令的树结点。
REQUISITE - Static variable in class javax.security.auth.login. AppConfigurationEntry.LoginModuleControlFlag
必需品 LoginModule 。
RescaleOp - Class in java.awt.image
该类通过将每个像素的采样值乘以比例因子然后添加偏移来执行源图像中的数据的逐像素重新缩放。
RescaleOp(float[], float[], RenderingHints) - Constructor for class java.awt.image. RescaleOp
构建一个具有所需比例因子和偏移量的新RescaleOp。
RescaleOp(float, float, RenderingHints) - Constructor for class java.awt.image. RescaleOp
构造一个具有所需比例因子和偏移量的新RescaleOp。
rescanCurrentDirectory() - Method in class javax.swing. JFileChooser
告诉用户界面从当前目录重新扫描其文件列表。
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
重新扫描当前目录。
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf. FileChooserUI
重新扫描当前目录。
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf.multi. MultiFileChooserUI
在此对象处理的每个UI上调用 rescanCurrentDirectory方法。
reseed() - Method in class java.security. SecureRandom
使用从其熵源读取的熵输入来确定此 SecureRandom 。
reseed(boolean, byte[]) - Static method in class java.security. DrbgParameters
生成一个DrbgParameters.Reseed对象。
reseed(SecureRandomParameters) - Method in class java.security. SecureRandom
重新采用这种 SecureRandom ，其熵输入从其熵源读取附加参数。
RESEED_ONLY - java.security. DrbgParameters.Capability
重新设计，但没有预测阻力。
resendTopDownLeftRight(ImageProducer) - Method in class java.awt.image. ImageFilter
响应一个按TopDownLeftRight（TDLR）的请求顺序将像素数据重新发送从 ImageConsumer 。
RESERVED_ID_MAX - Static variable in class java.awt. AWTEvent
保留的AWT事件ID的最大值。
RESERVED_UIROLE - Static variable in class javax.print. ServiceUIFactory
不是有效的角色，但角色ID大于此可能用于服务支持的私有角色。
reset() - Method in class java.awt.geom. Area
从这个 Area删除所有几何图形并将其还原到一个空白区域。
reset() - Method in class java.awt.geom. Path2D
将路径重置为空。
reset() - Method in class java.awt. Polygon
将此 Polygon对象重置为空多边形。
reset() - Method in class java.io. BufferedInputStream
见 reset方法的一般合同 InputStream 。
reset() - Method in class java.io. BufferedReader
将流重置为最近的标记。
reset() - Method in class java.io. ByteArrayInputStream
将缓冲区重置为标记位置。
reset() - Method in class java.io. ByteArrayOutputStream
将此字节数组输出流的 count字段重置为零，以便丢弃输出流中当前累积的所有输出。
reset() - Method in class java.io. CharArrayReader
将流重新设置为最近的标记，或将其重新设置为从未被标记的开始。
reset() - Method in class java.io. CharArrayWriter
重置缓冲区，以便您可以再次使用它，而不会丢弃已经分配的缓冲区。
reset() - Method in class java.io. FilterInputStream
将此流重新定位到最后在此输入流上调用 mark方法时的位置。
reset() - Method in class java.io. FilterReader
重置流。
reset() - Method in class java.io. InputStream
将此流重新定位到最后在此输入流上调用 mark方法时的位置。
reset() - Method in class java.io. LineNumberInputStream
已过时。
将此流重新定位到最后在此输入流上调用 mark方法时的位置。
reset() - Method in class java.io. LineNumberReader
将流重新设置为最近的标记。
reset() - Method in class java.io. ObjectOutputStream
复位将忽略已写入流的任何对象的状态。
reset() - Method in class java.io. PushbackInputStream
将此流重新定位到最后在此输入流上调用 mark方法时的位置。
reset() - Method in class java.io. PushbackReader
重置流。
reset() - Method in class java.io. Reader
重置流。
reset() - Method in class java.io. StringBufferInputStream
已过时。
重置输入流以开始从该输入流的底层缓冲区的第一个字符读取。
reset() - Method in class java.io. StringReader
将流重新设置为最近的标记，如果从未被标记，则将其重置到字符串的开头。
reset() - Method in class java.nio. Buffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.nio. ByteBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.nio. CharBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.nio.charset. CharsetDecoder
复位该解码器，清除任何内部状态。
reset() - Method in class java.nio.charset. CharsetEncoder
复位该编码器，清除任何内部状态。
reset() - Method in class java.nio. DoubleBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in interface java.nio.file. WatchKey
重置此手表键。
reset() - Method in class java.nio. FloatBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.nio. IntBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.nio. LongBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.nio. MappedByteBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.nio. ShortBuffer
将此缓冲区的位置重置为先前标记的位置。
reset() - Method in class java.security. MessageDigest
重置摘要以供进一步使用。
reset() - Method in class java.text. CollationElementIterator
将光标重置为字符串的开头。
reset() - Method in class java.util.concurrent.atomic. DoubleAccumulator
重置维持更新到标识值的变量。
reset() - Method in class java.util.concurrent.atomic. DoubleAdder
将保持总和的变量重置为零。
reset() - Method in class java.util.concurrent.atomic. LongAccumulator
重置维持更新到标识值的变量。
reset() - Method in class java.util.concurrent.atomic. LongAdder
将保持总和的变量重置为零。
reset() - Method in class java.util.concurrent. CyclicBarrier
将屏障重置为初始状态。
reset() - Method in class java.util.logging. LogManager
重置日志配置。
reset() - Method in class java.util.regex. Matcher
重设此匹配器。
reset() - Method in class java.util. Scanner
重设此扫描仪。
reset() - Method in class java.util.zip. Adler32
将校验和重置为初始值。
reset() - Method in interface java.util.zip. Checksum
将校验和重置为初始值。
reset() - Method in class java.util.zip. CRC32
将CRC-32复位为初始值。
reset() - Method in class java.util.zip. CRC32C
将CRC-32C复位为初始值。
reset() - Method in class java.util.zip. Deflater
重置deflater，以便可以处理一组新的输入数据。
reset() - Method in class java.util.zip. DeflaterInputStream
不支持此操作 。
reset() - Method in class java.util.zip. Inflater
重新设置充气器，以便可以处理一组新的输入数据。
reset() - Method in class java.util.zip. InflaterInputStream
将此流重新定位到上次在此输入流上调用 mark方法时的位置。
reset() - Method in class javafx.collections. ListChangeListener.Change
重置到初始阶段。
reset() - Method in class javafx.concurrent. ScheduledService
重置服务。
reset() - Method in class javafx.concurrent. Service
重置服务。
reset() - Method in class javax.crypto. Mac
重置此 Mac对象。
reset() - Method in class javax.imageio. ImageReader
将 ImageReader恢复到初始状态。
reset() - Method in class javax.imageio. ImageWriter
将 ImageWriter恢复到初始状态。
reset() - Method in class javax.imageio.metadata. IIOMetadata
将此对象中存储的所有数据重置为默认值，通常是在构建后立即处于该对象的状态，尽管精确的语义是插件特定的。
reset() - Method in interface javax.imageio.stream. ImageInputStream
在最近不匹配的调用时返回到前一个位置的流指针，包括位偏移量，为 mark 。
reset() - Method in class javax.imageio.stream. ImageInputStreamImpl
从标记位置的堆栈中重置当前流字节和位位置。
reset() - Method in class javax.sound.sampled. AudioInputStream
将此音频输入流重新定位到上次调用其 mark方法时的位置。
reset() - Method in class javax.swing. ProgressMonitorInputStream
覆盖 FilterInputStream.reset以重置进度监视器以及流。
reset() - Method in class javax.xml.bind.util. ValidationEventCollector
清除所有收集的错误和警告。
reset() - Method in class javax.xml.datatype. XMLGregorianCalendar
将这个 XMLGregorianCalendar重置为原始值。
reset() - Method in class javax.xml.parsers. DocumentBuilder
将此 DocumentBuilder重置为原始配置。
reset() - Method in class javax.xml.parsers. SAXParser
将此 SAXParser重置为原始配置。
reset() - Method in class javax.xml.transform. Transformer
将此 Transformer重置为原始配置。
reset() - Method in class javax.xml.validation. Validator
将此 Validator重置为原始配置。
reset() - Method in interface javax.xml.xpath. XPath
将此 XPath重置为原始配置。
reset() - Method in interface org.w3c.dom.html. HTMLFormElement
恢复表单元素的默认值。
reset() - Method in class org.xml.sax.helpers. NamespaceSupport
重置此Namespace支持对象以供重用。
reset(CharSequence) - Method in class java.util.regex. Matcher
使用新的输入序列重置此匹配器。
RESET - Static variable in class javax.swing.text.html. FormView
已过时。
从1.3开始，值来自UIManager UIManager属性FormView.resetButtonText
RESET_FLAGS_ALREADY_NOTIFIED - Static variable in class javax.management.monitor. Monitor
此标志用于重置 alreadyNotifieds监视器属性。
resetAllControllers() - Method in interface javax.sound.midi. MidiChannel
将所有实现的控制器重置为其默认值。
resetAndRelink(GuardedInvocation, MethodHandle) - Method in interface jdk.dynalink. RelinkableCallSite
每次调用站点重新链接时，动态链接器将调用此方法 ，并且链接器希望调用站点丢弃任何先前的链接状态（即它与 RelinkableCallSite.relink(GuardedInvocation, MethodHandle)的区别 ）。
resetAndRelink(GuardedInvocation, MethodHandle) - Method in class jdk.dynalink.support. ChainedCallSite
resetAndRelink(GuardedInvocation, MethodHandle) - Method in class jdk.dynalink.support. SimpleRelinkableCallSite
resetChoosableFileFilters() - Method in class javax.swing. JFileChooser
将可选择的文件过滤器列表重置为其启动状态。
resetInputValue() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
在选项窗格中设置输入值，接收器根据inputComponent中的值提供外观。
resetKeyboardActions() - Method in class javax.swing. JComponent
取消注册第一层 InputMaps和 ActionMap中的所有绑定。
resetLayoutManager() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
根据方向重新设置布局管理器，并使用invalidateLayout将其发送消息以拉入相应的组件。
resetMarksAtZero() - Method in class javax.swing.text. GapContent
将偏移量为0的所有标记重置为索引为零。
resetPeakThreadCount() - Method in interface java.lang.management. ThreadMXBean
将峰值线程计数重置为当前线程数。
resetPeakUsage() - Method in interface java.lang.management. MemoryPoolMXBean
将此内存池的高峰内存使用率统计信息重置为当前内存使用情况。
resetRecognizer() - Method in class java.awt.dnd. DragGestureRecognizer
重置识别器，如果其当前识别手势，则忽略它。
resetRowSelection() - Method in class javax.swing.tree. DefaultTreeSelectionModel
将此对象的映射从TreePath更新为行。
resetRowSelection() - Method in interface javax.swing.tree. TreeSelectionModel
将此对象的映射从TreePath更新为行。
resetSizeAt(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
在传入的位置重置组件的大小。
resetSyntax() - Method in class java.io. StreamTokenizer
重置这个tokenizer的语法表，使所有的字符都是“普通的”。
resetToPreferredSizes() - Method in class javax.swing. JSplitPane
基于儿童组件的首选大小，排出 JSplitPane布局。
resetToPreferredSizes() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
标记接收器，以便下次此实例布局时，它会要求首选的大小。
resetToPreferredSizes(JSplitPane) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
消失以重置首选尺寸。
resetToPreferredSizes(JSplitPane) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI
在此对象处理的每个UI上调用 resetToPreferredSizes方法。
resetToPreferredSizes(JSplitPane) - Method in class javax.swing.plaf. SplitPaneUI
基于子组件的首选大小消息传递JSplitPane。
resetViewPort() - Method in class javax.swing. JScrollPane.AccessibleJScrollPane
重置视口ChangeListener和PropertyChangeListener
reshape(int, int, int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
reshape(int, int, int, int) - Method in class java.awt. Rectangle
已过时。
从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
reshape(int, int, int, int) - Method in class java.awt. Window
已过时。
从JDK 1.1版开始，替换为setBounds(int, int, int, int) 。
reshape(int, int, int, int) - Method in class javax.swing. JComponent
已过时。
截至JDK 5，由Component.setBounds(int, int, int, int)替代。

移动并调整此组件的大小。

reshape(int, int, int, int) - Method in class javax.swing. JInternalFrame
移动并调整此组件的大小。
reshape(int, int, int, int) - Method in class javax.swing. JViewport
设置此视口的边界。
resizable - Variable in class javax.swing. JInternalFrame
框架的尺寸可以更改。
RESIZABLE - Static variable in class javax.accessibility. AccessibleState
表示此对象的大小不固定。
resizableProperty() - Method in class javafx.scene.control. Dialog
表示对话框是否可调整大小。
resizableProperty() - Method in class javafx.scene.control. TableColumnBase
用于指示此列的宽度是否可以更改。
resizableProperty() - Method in class javafx.stage. Stage
定义用户是否可以调整 Stage的大小。
resize(double, double) - Method in class javafx.embed.swing. SwingNode
由 SwingNode的父母在布局期间调用 SwingNode的宽度和高度。
resize(double, double) - Method in class javafx.scene.layout. Region
在布局期间由区域的父项调用以设置区域的宽度和高度。
resize(double, double) - Method in class javafx.scene. Node
如果节点可调整大小，将其布局边界设置为指定的宽度和高度。
resize(double, double) - Method in class javafx.scene.web. WebView
resize(int) - Method in interface javafx.collections. ObservableArray
在此数组中设置新的数据长度。
resize(int, int) - Method in class java.applet. Applet
已过时。
请求这个小程序调整大小。
resize(int, int) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，由setSize(int, int)代替。
resize(int, int) - Method in class java.awt. Rectangle
已过时。
从JDK 1.1版开始，由setSize(int, int)替代。
resize(Dimension) - Method in class java.applet. Applet
已过时。
请求这个小程序调整大小。
resize(Dimension) - Method in class java.awt. Component
已过时。
从JDK 1.1版开始，替换为setSize(Dimension) 。
RESIZE_NONE - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI.BorderListener
调整大小
RESIZE_WEIGHT_PROPERTY - Static variable in class javax.swing. JSplitPane
重量限制属性。
resizeAndRepaint() - Method in class javax.swing. JTable
相当于 revalidate其次是 repaint 。
resizeAndRepaint() - Method in class javax.swing.table. JTableHeader
标题的大小并将其标记为需要显示。
resizeColumn(TableColumn<S, ?>, double) - Method in class javafx.scene.control. TableView
根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
resizeColumn(TreeTableColumn<S, ?>, double) - Method in class javafx.scene.control. TreeTableView
根据给定的列应用当前安装的大小调整策略，根据提供的增量值调整其大小。
RESIZED - Static variable in class javafx.scene.web. WebEvent
当脚本更改JavaScript window对象的位置时，会发生此事件。
resizedPostingDisableCount - Variable in class javax.swing.table. TableColumn
已过时。
从Java 2平台v1.3开始
ResizeFeatures(TableView<S>, TableColumn<S, ?>, Double) - Constructor for class javafx.scene.control. TableView.ResizeFeatures
创建此类的实例，提供的TableView，TableColumn和delta值被设置并存储在此不可变实例中。
ResizeFeatures(TreeTableView<S>, TreeTableColumn<S, ?>, Double) - Constructor for class javafx.scene.control. TreeTableView.ResizeFeatures
创建此类的实例，提供的TreeTableView，TreeTableColumn和delta值被设置并存储在此不可变实例中。
ResizeFeaturesBase< S> - Class in javafx.scene.control
列使用的不可变包装类可调整由控件（如TableView）和TreeTableView提供的策略大小。
ResizeFeaturesBase(TableColumnBase<S, ?>, Double) - Constructor for class javafx.scene.control. ResizeFeaturesBase
创建此类的实例，其中提供的TableColumnBase和delta值被设置并存储在此不可变实例中。
resizeFrame(JComponent, int, int, int, int) - Method in class javax.swing. DefaultDesktopManager
通过新值呼叫 setBoundsForFrame 。
resizeFrame(JComponent, int, int, int, int) - Method in interface javax.swing. DesktopManager
用户已调整组件的大小。
resizeRelocate(double, double, double, double) - Method in class javafx.scene. Node
如果节点可调整大小，将其布局边界设置为指定的宽度和高度。
resizingAllowed - Variable in class javax.swing.table. JTableHeader
如果为true，则用户可以允许调整列大小; 默认值为true。
resizingColumn - Variable in class javax.swing.table. JTableHeader
列的索引已调整大小。
resolution - Variable in class javax.sound.midi. MidiFileFormat
MIDI文件的时间分辨率。
resolution - Variable in class javax.sound.midi. Sequence
序列的时序分辨率。
RESOLUTION_UNIT_CENTIMETER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“ResolutionUnit”标签一起使用的值。
RESOLUTION_UNIT_INCH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“ResolutionUnit”标签一起使用的值。
RESOLUTION_UNIT_NONE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“ResolutionUnit”标签一起使用的值。
ResolutionException - Exception in java.lang.module
在解析一组模块或解析一组具有服务绑定的模块时抛出失败。
ResolutionException() - Constructor for exception java.lang.module. ResolutionException
构造一个 ResolutionException ，没有详细信息。
ResolutionException(int, StackTraceElement[]) - Constructor for exception jdk.jshell.spi. ExecutionControl.ResolutionException
构造一个异常，指示已遇到具有未解析引用的 DeclarationSnippet 。
ResolutionException(String) - Constructor for exception java.lang.module. ResolutionException
构造具有给定详细信息的 ResolutionException 。
ResolutionException(String, Throwable) - Constructor for exception java.lang.module. ResolutionException
构造一个 ResolutionException与给定的详细信息和原因。
ResolutionException(Throwable) - Constructor for exception java.lang.module. ResolutionException
使用给定的原因构造此异常的实例。
ResolutionSyntax - Class in javax.print.attribute
Class ResolutionSyntax是一个抽象基类，提供表示打印机分辨率的所有属性的常见实现。
ResolutionSyntax(int, int, int) - Constructor for class javax.print.attribute. ResolutionSyntax
从给定的项目构造一个新的分辨率属性。
resolve(ModuleFinder, ModuleFinder, Collection<String>) - Method in class java.lang.module. Configuration
解决一个根模块的集合，以此配置为其父级，以创建新的配置。
resolve(ModuleFinder, List<Configuration>, ModuleFinder, Collection<String>) - Static method in class java.lang.module. Configuration
解析根模块的集合以创建配置。
resolve(String) - Method in class java.net. URI
通过解析给定的字符串构造一个新的URI，然后根据此URI进行解析。
resolve(String) - Method in interface java.nio.file. Path
一个给定的路径字符串转换为 Path并解析它针对此 Path在完全按规定的方式 resolve方法。
resolve(String, String) - Method in interface javax.xml.catalog. CatalogResolver
实施URIRsolver。
resolve(String, String) - Method in interface javax.xml.transform. URIResolver
处理器遇到xsl：include，xsl：import或document（）函数时调用。
resolve(URI) - Method in class java.net. URI
根据此URI解析给定的URI。
resolve(Path) - Method in interface java.nio.file. Path
根据这条路径解决给定的路径。
resolve(Map<TemporalField, Long>, TemporalAccessor, ResolverStyle) - Method in interface java.time.temporal. TemporalField
解决此字段以提供更简单的替代或日期。
resolve(NameComponent[]) - Method in class org.omg.CosNaming. _NamingContextExtStub
解析操作是在给定上下文中检索绑定到名称的对象的过程。
resolve(NameComponent[]) - Method in class org.omg.CosNaming. _NamingContextStub
解析操作是在给定上下文中检索绑定到名称的对象的过程。
resolve(NameComponent[]) - Method in interface org.omg.CosNaming. NamingContextOperations
解析操作是在给定上下文中检索绑定到名称的对象的过程。
RESOLVE - javax.xml.catalog. CatalogFeatures.Feature
javax.xml.catalog.resolve属性，如“目录功能”表中的项目 RESOLVE所述。
resolve_initial_references(String) - Method in class org.omg.CORBA. ORB
从可用的初始服务名称集中解析特定的对象引用。
resolve_initial_references(String) - Method in interface org.omg.PortableInterceptor. ORBInitInfoOperations
与 ORB.resolve_initial_references相同。
resolve_str(String) - Method in class org.omg.CosNaming. _NamingContextExtStub
此操作将Stringified名称解析为对象引用。
resolve_str(String) - Method in interface org.omg.CosNaming. NamingContextExtOperations
此操作将Stringified名称解析为对象引用。
resolveAndBind(ModuleFinder, ModuleFinder, Collection<String>) - Method in class java.lang.module. Configuration
解决一系列根模块，具有服务绑定，并将此配置作为其父配置来创建新配置。
resolveAndBind(ModuleFinder, List<Configuration>, ModuleFinder, Collection<String>) - Static method in class java.lang.module. Configuration
解决一系列根模块，具有服务绑定功能，以创建配置。
ResolveAttribute - Static variable in interface javax.swing.text. AttributeSet
用于标识解析父属性属性的属性名称（如果已定义）。
ResolveAttribute - Static variable in class javax.swing.text. StyleConstants
用于标识解析父属性属性的属性名称（如果已定义）。
resolveClass(ObjectStreamClass) - Method in class java.io. ObjectInputStream
加载本地类等效的指定流类描述。
resolveClass(Class<?>) - Method in class java.lang. ClassLoader
链接指定的类。
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono. AbstractChronology
解析解析中的 ChronoField值到解析中的日期。
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in interface java.time.chrono. Chronology
解析解析 ChronoField值到一个日期。
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono. HijrahChronology
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono. IsoChronology
解析解析中的日期为 ChronoField 。
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono. JapaneseChronology
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono. MinguoChronology
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono. ThaiBuddhistChronology
ResolvedModule - Class in java.lang.module
解析模块图中的 模块 。
resolvedName - Variable in exception javax.naming. NamingException
包含成功解决的部分名称。
resolvedObj - Variable in exception javax.naming. NamingException
包含名称部分的解析成功的对象。
resolvedObj - Variable in class javax.naming.spi. ResolveResult
包含已成功解析的对象的字段。
resolveEntity(String, String) - Method in interface javax.xml.catalog. CatalogResolver
实现EntityResolver 。
resolveEntity(String, String) - Method in interface org.xml.sax. EntityResolver
允许应用程序解析外部实体。
resolveEntity(String, String) - Method in class org.xml.sax.ext. DefaultHandler2
使用空实体名称和基本URI调用 EntityResolver2.resolveEntity() 。
resolveEntity(String, String) - Method in class org.xml.sax. HandlerBase
已过时。
解决外部实体。
resolveEntity(String, String) - Method in class org.xml.sax.helpers. DefaultHandler
解决外部实体。
resolveEntity(String, String) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤外部实体分辨率。
resolveEntity(String, String, String, String) - Method in interface javax.xml.catalog. CatalogResolver
实现XMLResolver 。
resolveEntity(String, String, String, String) - Method in interface javax.xml.stream. XMLResolver
检索资源。
resolveEntity(String, String, String, String) - Method in class org.xml.sax.ext. DefaultHandler2
告诉解析器根据baseURI解析systemId，并从该结果的绝对URI中读取实体文本。
resolveEntity(String, String, String, String) - Method in interface org.xml.sax.ext. EntityResolver2
允许应用程序将对外部实体的引用映射到输入源中，或者告诉解析器它应该使用传统的URI解析。
resolveFunction(QName, int) - Method in interface javax.xml.xpath. XPathFunctionResolver
在一组可用函数中查找一个函数。
resolveObject(Object) - Method in class java.io. ObjectInputStream
此方法将允许ObjectInputStream的受信任子类在反序列化期间将一个对象替换为另一个对象。
resolveProxyClass(String[]) - Method in class java.io. ObjectInputStream
返回一个代理类，它实现代理类描述符中命名的接口; 子类可以实现此方法从流中读取自定义数据以及动态代理类的描述符，从而允许它们为接口和代理类使用备用加载机制。
Resolver - Interface in javax.naming.spi
此接口表示名称解析的“中间上下文”。
RESOLVER - Static variable in class javax.xml.stream. XMLInputFactory
该属性用于设置/获取XMLResolver的实现
resolveResource(String, String, String, String, String) - Method in interface javax.xml.catalog. CatalogResolver
实现LSResourceResolver 。
resolveResource(String, String, String, String, String) - Method in interface org.w3c.dom.ls. LSResourceResolver
允许应用程序解决外部资源。
ResolveResult - Class in javax.naming.spi
该类代表解析名称的结果。
ResolveResult() - Constructor for class javax.naming.spi. ResolveResult
构造一个ResolveResult的实例，其中已解析的对象和剩余的名称都初始化为null。
ResolveResult(Object, String) - Constructor for class javax.naming.spi. ResolveResult
构造由解析的对象和剩余的未解析组件组成的ResolveResult的新实例。
ResolveResult(Object, Name) - Constructor for class javax.naming.spi. ResolveResult
构造由解析的对象和剩余名称组成的ResolveResult的新实例。
ResolverStyle - Enum in java.time.format
列举不同的方式来解决日期和时间。
resolveSibling(String) - Method in interface java.nio.file. Path
将给定的路径字符串转换为 Path并按照 resolveSibling方法指定的方式将其解析为该路径的 parent路径。
resolveSibling(Path) - Method in interface java.nio.file. Path
根据此路径的 parent路径解决给定的路径。
resolveToClass(String, Class<? extends Context>) - Method in interface javax.naming.spi. Resolver
部分解决名称。
resolveToClass(Name, Class<? extends Context>) - Method in interface javax.naming.spi. Resolver
部分解决名称。
resolveURI(String, String) - Method in class javafx.application. HostServices
根据基本URI解析指定的相对URI并返回已解析的URI。
resolveVariable(QName) - Method in interface javax.xml.xpath. XPathVariableResolver
在可用变量集中找到一个变量。
Resource - Annotation Type in javax.annotation
资源注释标记应用程序需要的资源。
RESOURCE_KEY_PREFIX - Static variable in class javafx.fxml. FXMLLoader
前缀用于资源解析。
RESOURCE_VARIABLE - javax.lang.model.element. ElementKind
资源变量。
Resource.AuthenticationType - Enum in javax.annotation
资源的两种可能的认证类型。
ResourceBundle - Class in java.util
资源束包含区域特定的对象。
ResourceBundle() - Constructor for class java.util. ResourceBundle
唯一的构造函数。
ResourceBundle.Control - Class in java.util
ResourceBundle.Control定义了在捆绑包加载过程中由 ResourceBundle.getBundle工厂方法调用的一组回调方法。
ResourceBundleControlProvider - Interface in java.util.spi
提供ResourceBundle.Control实现的服务提供商的接口。
ResourceBundleProvider - Interface in java.util.spi
ResourceBundleProvider是一个提供者接口，用于加载命名模块的资源束。
resources(String) - Method in class java.lang. ClassLoader
返回一个流，其元素是具有给定名称的所有资源的URL。
Resources - Annotation Type in javax.annotation
此类用于允许多个资源声明。
RESOURCES_ARE_NOT_READY - Static variable in class javax.print.attribute.standard. JobStateReason
作业所需的至少一个资源（如媒体，字体，资源对象等）在作业是候选人的任何物理打印机上尚未准备就绪。
RESOURCES_KEY - Static variable in class javafx.fxml. FXMLLoader
ResourceBundle在命名空间映射中的关键。
ResourceSpec(String, String, int) - Constructor for class javax.jnlp. DownloadService2.ResourceSpec
创建一个新的ResourceSpec实例。
RespectBinding - Annotation Type in javax.xml.ws
此功能说明了JAX-WS运行时中使用的 wsdl:binding 。
RespectBindingFeature - Class in javax.xml.ws
该功能说明了JAX-WS运行时中使用的 wsdl:binding 。
RespectBindingFeature() - Constructor for class javax.xml.ws. RespectBindingFeature
创建一个 RespectBindingFeature 。
RespectBindingFeature(boolean) - Constructor for class javax.xml.ws. RespectBindingFeature
创建一个RespectBindingFeature
Response< T> - Interface in javax.xml.ws
Response接口提供了用于获取响应于操作调用发送的消息的有效载荷和上下文的方法。
response_expected() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
指示是否预期响应。
ResponseAPDU - Class in javax.smartcardio
符合ISO / IEC 7816-4规定的响应APDU。
ResponseAPDU(byte[]) - Constructor for class javax.smartcardio. ResponseAPDU
从包含完整的APDU内容（条件体和尾迹）的字节数组构造一个ResponseAPDU。
ResponseCache - Class in java.net
表示URLConnection缓存的实现。
ResponseCache() - Constructor for class java.net. ResponseCache
responseCode - Variable in class java.net. HttpURLConnection
一个 int代表三位数的HTTP状态码。
responseCode() - Method in exception java.net. HttpRetryException
返回http响应代码
ResponseHandler - Interface in org.omg.CORBA.portable
该接口在调用时由ORB提供给仆人，并允许仆人稍后检索一个OutputStream以返回调用结果。
responseMessage - Variable in class java.net. HttpURLConnection
HTTP响应消息。
ResponseWrapper - Annotation Type in javax.xml.ws
用于使用要在运行时使用的响应包装器bean来注释服务端点接口中的方法。
rest_of_name - Variable in exception org.omg.CosNaming.NamingContextPackage. CannotProceed
rest_of_name - Variable in exception org.omg.CosNaming.NamingContextPackage. NotFound
restart() - Method in class javafx.concurrent. Service
取消任何当前正在运行的任务（如果有），并重新启动此服务。
restart() - Method in class javax.swing. Timer
重新启动 Timer ，取消任何未决的发射，并使其以其初始延迟触发。
RESTART - com.sun.nio.sctp. AssociationChangeNotification.AssocChangeEvent
SCTP检测到对等体重新启动。
restartOnFailureProperty() - Method in class javafx.concurrent. ScheduledService
指示在Task中出现故障时，ScheduledService是否应自动重新启动。
restore() - Method in class javafx.scene.canvas. GraphicsContext
将状态从堆栈中弹出，将以下属性设置为将该状态推送到堆栈时的值。
RESTORE_CMD - Static variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
还原按钮文本属性。
restoreAction - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
一个 RestoreAction的实例。
RestoreAction() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.RestoreAction
构造一个新的实例 RestoreAction 。
restoreComposedText() - Method in class javax.swing.text. JTextComponent
恢复由以前保存的组合文本 saveComposedText 。
restoreOriginal() - Method in interface javax.sql.rowset. CachedRowSet
将此 CachedRowSet对象恢复为其原始值，即其最后一组更改前的值。
restoreState(Hashtable<?, ?>) - Method in interface javax.swing.undo. StateEditable
收到该消息后，接收方应将任何相关状态提取出 状态 。
restoreSubcomponentFocus() - Method in class javax.swing. JInternalFrame
请求内部框架将焦点恢复到具有焦点的最后一个子组件。
result() - Method in class org.omg.CORBA. Request
检索包含该方法的返回值的 NamedValue对象。
result() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations
返回一个包含操作调用结果的值。
result(Any) - Method in class org.omg.CORBA. ServerRequest
已过时。
使用方法set_result
Result - Interface in javax.xml.transform
实现此接口的对象包含构建转换结果树所需的信息。
Result() - Constructor for class com.sun.net.httpserver. Authenticator.Result
Result(Object, Attributes) - Constructor for class javax.naming.spi. DirStateFactory.Result
构造一个Result的实例。
resultConverterProperty() - Method in class javafx.scene.control. Dialog
API将用户点击的ButtonType转换为可以通过result属性返回的结果。
resultProperty() - Method in class javafx.scene.control. Dialog
表示从对话框返回的属性的属性。
results() - Method in class java.util.regex. Matcher
返回与模式匹配的输入序列的每个子序列的匹配结果流。
ResultSet - Interface in java.sql
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
ResultSetMetaData - Interface in java.sql
可用于获取有关 ResultSet对象中列的类型和属性的信息的对象。
resume() - Method in interface com.sun.jdi.event. EventSet
恢复此事件集挂起的线程。
resume() - Method in interface com.sun.jdi. ThreadGroupReference
恢复此线程组中的所有线程。
resume() - Method in interface com.sun.jdi. ThreadReference
恢复此线程。
resume() - Method in interface com.sun.jdi. VirtualMachine
继续执行在该虚拟机中运行的应用程序。
resume() - Method in class java.lang. Thread
已过时。
该方法仅供Thread.suspend()使用，由于它是易死的 ，因此已被弃用。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
resume() - Method in class java.lang. ThreadGroup
已过时。
该方法仅与Thread.suspend和ThreadGroup.suspend结合使用，这两种都已被弃用，因为它们本身就是死锁的。 详见Thread.suspend() 。
RETAIN - Static variable in class org.omg.PortableServer. ServantRetentionPolicyValue
RETAIN_CLASS_REFERENCE - java.lang. StackWalker.Option
保留 Class对象在 StackFrame s走过这个 StackWalker 。
retainAll(E...) - Method in class javafx.beans.binding. ListExpression
retainAll(E...) - Method in interface javafx.collections. ObservableList
一个方便的方法，用于var-arg使用的 retainAll方法。
retainAll(E...) - Method in class javafx.collections. ObservableListBase
retainAll(Collection) - Method in class java.beans.beancontext. BeanContextSupport
只保留指定的子级（不支持）实现必须在层次结构锁和“children”保护字段上同步
retainAll(Collection<?>) - Method in class java.util. AbstractCollection
仅保留此集合中包含在指定集合中的元素（可选操作）。
retainAll(Collection<?>) - Method in class java.util. ArrayDeque
retainAll(Collection<?>) - Method in class java.util. ArrayList
仅保留此列表中包含在指定集合中的元素。
retainAll(Collection<?>) - Method in interface java.util. Collection
仅保留此集合中包含在指定集合中的元素（可选操作）。
retainAll(Collection<?>) - Method in class java.util.concurrent. ArrayBlockingQueue
retainAll(Collection<?>) - Method in class java.util.concurrent. ConcurrentLinkedDeque
retainAll(Collection<?>) - Method in class java.util.concurrent. ConcurrentLinkedQueue
retainAll(Collection<?>) - Method in class java.util.concurrent. CopyOnWriteArrayList
仅保留此列表中包含在指定集合中的元素。
retainAll(Collection<?>) - Method in class java.util.concurrent. CopyOnWriteArraySet
仅保留该集合中包含在指定集合中的元素。
retainAll(Collection<?>) - Method in class java.util.concurrent. LinkedBlockingDeque
retainAll(Collection<?>) - Method in class java.util.concurrent. LinkedBlockingQueue
retainAll(Collection<?>) - Method in class java.util.concurrent. LinkedTransferQueue
retainAll(Collection<?>) - Method in class java.util.concurrent. SynchronousQueue
始终返回 false 。
retainAll(Collection<?>) - Method in interface java.util. List
仅保留此列表中包含在指定集合中的元素（可选操作）。
retainAll(Collection<?>) - Method in interface java.util. Set
仅保留该集合中包含在指定集合中的元素（可选操作）。
retainAll(Collection<?>) - Method in class java.util. Vector
仅保留此向量中包含在指定集合中的元素。
retainAll(Collection<?>) - Method in class javafx.beans.binding. ListExpression
retainAll(Collection<?>) - Method in class javafx.beans.binding. SetExpression
retainAll(Collection<?>) - Method in class javafx.collections. ModifiableObservableListBase
Retention - Annotation Type in java.lang.annotation
指示要注释具有注释类型的注释的保留时间。
RetentionPolicy - Enum in java.lang.annotation
注释保留政策。
retransformClasses(Class<?>...) - Method in interface java.lang.instrument. Instrumentation
重新转换提供的一组类。
RetrievalMethod - Interface in javax.xml.crypto.dsig.keyinfo
在 RetrievalMethod中定义的XML RetrievalMethod元素的 表示 。
retrieveAllRoles() - Method in interface javax.management.relation. Relation
返回关系中的所有角色，而不检查读取模式。
retrieveAllRoles() - Method in class javax.management.relation. RelationSupport
返回关系中的所有角色，而不检查读取模式。
Retry(int) - Constructor for class com.sun.net.httpserver. Authenticator.Retry
retryReferral() - Method in exception javax.naming. ReferralException
重试目前正在处理的推介。
RETURN - com.sun.nio.sctp. HandlerResult
返回而不尝试再接收任何数据。
RETURN - com.sun.source.doctree. DocTree.Kind
用于表示一个@return标签的ReturnTree的实例。
RETURN - com.sun.source.tree. Tree.Kind
用于ReturnTree的实例。
RETURN - jdk.nashorn.api.tree. Tree.Kind
用于ReturnTree的实例。
RETURN_GENERATED_KEYS - Static variable in interface java.sql. Statement
常数表示生成的密钥应该可用于检索。
return_value() - Method in class org.omg.CORBA. Request
返回包含方法结果值的 Any对象。
ReturnTree - Interface in com.sun.source.doctree
一个@return块标记的树节点。
ReturnTree - Interface in com.sun.source.tree
一个 return语句的树节点。
ReturnTree - Interface in jdk.nashorn.api.tree
“返回”语句的树结点。
returnType() - Method in interface com.sun.javadoc. MethodDoc
已过时。
获取返回类型。
returnType() - Method in interface com.sun.jdi. 方法
返回返回类型，如该方法的声明所指定。
returnType() - Method in class java.lang.invoke. MethodType
返回此方法类型的返回类型。
returnTypeName() - Method in interface com.sun.jdi. 方法
返回返回类型的文本表示形式，如该方法的声明所指定。
returnValue() - Method in interface com.sun.jdi.event. MethodExitEvent
返回该方法将返回的值。
returnValue() - Method in exception com.sun.tools.attach. AgentInitializationException
如果使用代理程序 Agent_OnAttach函数的返回值创建了异常，则返回该值，否则返回 0 。
REUSE - Static variable in class javax.security.sasl. Sasl
指定是否重新使用以前验证的会话信息的属性的名称。
REV - Static variable in class javax.swing.text.html. HTML.Attribute
属性“rev”
revalidate() - Method in class java.awt. Component.BltBufferStrategy
如果绘图缓冲区丢失，则还原它
revalidate() - Method in class java.awt. Component.FlipBufferStrategy
如果绘图缓冲区丢失，则还原它
revalidate() - Method in class java.awt. Component
将组件层次结构重新验证为最接近的验证根。
revalidate() - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
revalidate() - Method in class javax.swing. JComponent
支持延迟自动布局。
revalidate() - Method in class javax.swing.table. DefaultTableCellRenderer
由于性能原因而被覆盖。
revalidate() - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
revealDirect(MethodHandle) - Method in class java.lang.invoke. MethodHandles.Lookup
破解由此查找对象或类似的对象创建的一个 direct method handle 。
REVERB - Static variable in class javax.sound.sampled. EnumControl.Type
表示控制一组可能的混响设置。
REVERB_RETURN - Static variable in class javax.sound.sampled. FloatControl.Type
表示对一条线上的混响后增益的控制。
REVERB_SEND - Static variable in class javax.sound.sampled. FloatControl.Type
表示对一条线上的混响前增益的控制。
ReverbType - Class in javax.sound.sampled
ReverbType课程提供了访问要应用于音频信号的各种混响设置的方法。
ReverbType(String, int, float, int, float, int) - Constructor for class javax.sound.sampled. ReverbType
构造具有指定混响参数值的新混响类型。
reverse() - Method in class java.lang. StringBuffer
reverse() - Method in class java.lang. StringBuilder
reverse(int) - Static method in class java.lang. Integer
返回通过反转指定的 int值的二进制补码二进制表示中的位的顺序获得的值。
reverse(long) - Static method in class java.lang. Long
返回通过反转指定的 long值的二进制补码二进制表示中的位的顺序获得的值。
reverse(List<?>) - Static method in class java.util. Collections
反转指定列表中元素的顺序。
reverse(ObservableList) - Static method in class javafx.collections. FXCollections
反转列表中的顺序列表中仅发送 一个更改通知。
REVERSE_LANDSCAPE - javafx.print. PageOrientation
可打印区域的起点位于纸张的右上方。
REVERSE_LANDSCAPE - Static variable in class java.awt.print. PageFormat
原点在纸张的右上角，x从上到下运行，y从右到左运行。
REVERSE_LANDSCAPE - Static variable in class javax.print.attribute.standard. OrientationRequested
这些内容将以介质的长边成像，但与风景相反。
REVERSE_PORTRAIT - javafx.print. PageOrientation
可打印区域的起点位于纸张的右下方。
REVERSE_PORTRAIT - Static variable in class javax.print.attribute.standard. OrientationRequested
内容将在介质的短边成像，但是与纵向相反。
reverseBytes(char) - Static method in class java.lang. Character
返回通过反转指定的 char值中的字节顺序获得的值。
reverseBytes(int) - Static method in class java.lang. Integer
返回通过反转指定的 int值的二进制补码表示中的字节顺序获得的值。
reverseBytes(long) - Static method in class java.lang. Long
返回通过反转指定的 long值的二进制补码表示中的字节顺序获得的值。
reverseBytes(short) - Static method in class java.lang. Short
返回通过反转指定的 short值的二进制补码表示中的字节顺序获得的值。
reversed() - Method in interface java.util. Comparator
返回一个比较器，强制该比较器的相反顺序。
reverseOrder() - Static method in class java.util. Collections
返回一个对实现 Comparable接口的对象集合的 自然排序相反的比较器。
reverseOrder() - Static method in interface java.util. Comparator
返回一个与 自然排序相反的比较器。
reverseOrder(Comparator<T>) - Static method in class java.util. Collections
返回一个比较器，它强制指定比较器的反向排序。
REVERT - Static variable in class javax.swing. JFormattedTextField
常数确定当焦点丢失时，编辑值应恢复为 JFormattedTextField上设置的当前值。
REVOKED - java.security.cert. CertPathValidatorException.BasicReason
证书被撤销。
revokeService(Class<?>, BeanContextServiceProvider, boolean) - Method in interface java.beans.beancontext. BeanContextServices
希望从此上下文中删除当前注册的服务的BeanContextServiceProviders可以通过调用此方法来实现。
revokeService(Class<?>, BeanContextServiceProvider, boolean) - Method in class java.beans.beancontext. BeanContextServicesSupport
删除服务
rewind() - Method in class java.nio. Buffer
倒带这个缓冲区。
rewind() - Method in class java.nio. ByteBuffer
倒带这个缓冲区。
rewind() - Method in class java.nio. CharBuffer
倒带这个缓冲区。
rewind() - Method in class java.nio. DoubleBuffer
倒带这个缓冲区。
rewind() - Method in class java.nio. FloatBuffer
倒带这个缓冲区。
rewind() - Method in class java.nio. IntBuffer
倒带这个缓冲区。
rewind() - Method in class java.nio. LongBuffer
倒带这个缓冲区。
rewind() - Method in class java.nio. MappedByteBuffer
倒带这个缓冲区。
rewind() - Method in class java.nio. ShortBuffer
倒带这个缓冲区。
rewind() - Method in interface org.omg.CORBA. DynAny
已过时。
将内部指针移动到第一个组件。
rewind() - Method in class org.omg.DynamicAny. _DynAnyStub
相当于seek（0）。
rewind() - Method in class org.omg.DynamicAny. _DynArrayStub
相当于seek（0）。
rewind() - Method in class org.omg.DynamicAny. _DynEnumStub
相当于seek（0）。
rewind() - Method in class org.omg.DynamicAny. _DynFixedStub
相当于seek（0）。
rewind() - Method in class org.omg.DynamicAny. _DynSequenceStub
相当于seek（0）。
rewind() - Method in class org.omg.DynamicAny. _DynStructStub
相当于seek（0）。
rewind() - Method in class org.omg.DynamicAny. _DynUnionStub
相当于seek（0）。
rewind() - Method in class org.omg.DynamicAny. _DynValueStub
相当于seek（0）。
rewind() - Method in interface org.omg.DynamicAny. DynAnyOperations
相当于seek（0）。
REWIND - javafx.scene.input. KeyCode
常数为 Rewind键。
RFC_1123_DATE_TIME - Static variable in class java.time.format. DateTimeFormatter
RFC-1123日期格式化程序，如“星期二，2008年6月3日11:05:30 GMT”。
RFC1779 - Static variable in class javax.security.auth.x500. X500Principal
RFC 1779可分辨名称的字符串格式。
RFC2253 - Static variable in class javax.security.auth.x500. X500Principal
RFC 2253可分辨名称的字符串格式。
rgb(int, int, int) - Static method in class javafx.scene.paint. Color
使用指定的RGB值创建不透明的sRGB颜色，范围为 0-255 。
rgb(int, int, int, double) - Static method in class javafx.scene.paint. Color
使用指定的RGB值创建sRGB颜色，范围为 0-255 ，给定的不透明度。
RGBColor - Interface in org.w3c.dom.css
RGBColor接口用于表示任何RGB颜色值。
RGBImageFilter - Class in java.awt.image
该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。
RGBImageFilter() - Constructor for class java.awt.image. RGBImageFilter
RGBtoHSB(int, int, int, float[]) - Static method in class java.awt. Color
将默认RGB模型指定的颜色组件转换为HSB模型的三个组件的色相，饱和度和亮度的等效值。
right - Variable in class java.awt. Insets
从右边插入。
right - Variable in class javax.swing.border. EmptyBorder
边界的正确插图。
RIGHT - javafx.geometry. HorizontalDirection
向右的方向
RIGHT - javafx.geometry. HPos
表示正确的水平位置。
RIGHT - javafx.geometry. Side
表示矩形的右侧。
RIGHT - javafx.scene.control. ButtonBar.ButtonData
带有此样式标签的按钮将静态地位于条的右端。
RIGHT - javafx.scene.control. ContentDisplay
内容将放在标签的右侧。
RIGHT - javafx.scene.control.skin. TextInputControlSkin.Direction
RIGHT - javafx.scene.input. KeyCode
常数为非numpad 右箭头键。
RIGHT - javafx.scene.text. TextAlignment
表示右侧的文本对齐方式（右对齐，左对齐）。
RIGHT - Static variable in class java.awt. Event
已过时。
右箭头键，非ASCII操作键。
RIGHT - Static variable in class java.awt. FlowLayout
该值表示组件的每一行都应该是右对齐的。
RIGHT - Static variable in class java.awt. Label
表示标签应该是正确的。
RIGHT - Static variable in class javax.swing.border. TitledBorder
在边界线右侧放置标题文本。
RIGHT - Static variable in class javax.swing. JSplitPane
用于将添加 Component其他权 Component 。
RIGHT - Static variable in interface javax.swing. SwingConstants
方框常数用于指定框的右侧。
RIGHT_ALIGNMENT - Static variable in class java.awt. Component
易于使用的常数为 getAlignmentX 。
RIGHT_OUTER_JOIN - Static variable in interface javax.sql.rowset. JoinRowSet
ANSI样式的 JOIN提供两个表之间的右外连接。
RIGHT_PARENTHESIS - javafx.scene.input. KeyCode
常数为“）”键。
RIGHT_SHIFT - com.sun.source.tree. Tree.Kind
用于代表右移>>的BinaryTree的实例。
RIGHT_SHIFT - jdk.nashorn.api.tree. Tree.Kind
用于代表右移>>的BinaryTree的实例。
RIGHT_SHIFT_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于实例CompoundAssignmentTree表示右移分配>>= 。
RIGHT_SHIFT_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例CompoundAssignmentTree表示右移分配>>= 。
RIGHT_TO_LEFT - javafx.geometry. NodeOrientation
表示节点从右到左绘制。
RIGHT_TO_LEFT - Static variable in class java.awt. ComponentOrientation
项目从右到左运行，线条从上到下实例：阿拉伯语，希伯来文。
rightButton - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider
按钮快速切换正确的组件。
rightChildIndent - Variable in class javax.swing.plaf.basic. BasicTreeUI
添加到leftChildIndent以确定单元格内容将被绘制的距离。
rightComponent - Variable in class javax.swing. JSplitPane
右侧或底部组件。
RightIndent - Static variable in class javax.swing.text. StyleConstants
缩小段落右侧的数量。
rightKey - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
rightKey - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
已过时。
从Java 2平台v1.3开始。
rightKey - Variable in class javax.swing.plaf.basic. BasicToolBarUI
已过时。
从Java 2平台v1.3开始。
rightProperty() - Method in class javafx.scene.layout. BorderPane
放置在该边框窗格右边缘的节点。
rint(double) - Static method in class java.lang. Math
返回值与参数最接近的值为 double ，并且等于数学整数。
rint(double) - Static method in class java.lang. StrictMath
返回与参数最接近值的 double值，并且等于数学整数。
RIPEMD160 - Static variable in interface javax.xml.crypto.dsig. DigestMethod
RIPEMD-160摘要方法算法URI。
RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE - Static variable in class javax.management.remote.rmi. RMIConnectorServer
为与此连接器一起创建的RMI对象指定了RMIClientSocketFactory的属性的名称。
RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE - Static variable in class javax.management.remote.rmi. RMIConnectorServer
为与此连接器一起创建的RMI对象指定RMIServerSocketFactory的属性名称。
RMIClassLoader - Class in java.rmi.server
RMIClassLoader包含使用RMI支持动态类加载的静态方法。
RMIClassLoaderSpi - Class in java.rmi.server
RMIClassLoaderSpi是服务提供者接口 RMIClassLoader 。
RMIClassLoaderSpi() - Constructor for class java.rmi.server. RMIClassLoaderSpi
RMIClientSocketFactory - Interface in java.rmi.server
RMI运行时使用一个 RMIClientSocketFactory实例，以获取RMI调用的客户端套接字。
RMIConnection - Interface in javax.management.remote.rmi
用于将MBeanServer请求从客户端转发到其在服务器端的MBeanServer实现的RMI对象。
RMIConnectionImpl - Class in javax.management.remote.rmi
实现RMIConnection接口。
RMIConnectionImpl(RMIServerImpl, String, ClassLoader, Subject, Map<String, ?>) - Constructor for class javax.management.remote.rmi. RMIConnectionImpl
构造新的RMIConnection 。
RMIConnectionImpl_Stub - Class in javax.management.remote.rmi
RMIConnectionImpl_Stub(RemoteRef) - Constructor for class javax.management.remote.rmi. RMIConnectionImpl_Stub
RMIConnector - Class in javax.management.remote.rmi
与远程RMI连接器的连接。
RMIConnector(JMXServiceURL, Map<String, ?>) - Constructor for class javax.management.remote.rmi. RMIConnector
构造一个将连接RMI连接器服务器与给定地址的 RMIConnector 。
RMIConnector(RMIServer, Map<String, ?>) - Constructor for class javax.management.remote.rmi. RMIConnector
使用给定的RMI存根构造一个 RMIConnector 。
RMIConnectorServer - Class in javax.management.remote.rmi
从远程客户端创建基于RMI的连接的JMX API连接器服务器。
RMIConnectorServer(JMXServiceURL, Map<String, ?>) - Constructor for class javax.management.remote.rmi. RMIConnectorServer
做一个 RMIConnectorServer 。
RMIConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - Constructor for class javax.management.remote.rmi. RMIConnectorServer
为给定的MBean服务器创建一个 RMIConnectorServer 。
RMIConnectorServer(JMXServiceURL, Map<String, ?>, RMIServerImpl, MBeanServer) - Constructor for class javax.management.remote.rmi. RMIConnectorServer
为给定的MBean服务器创建一个 RMIConnectorServer 。
RMICustomMaxStreamFormat - Interface in org.omg.IOP
org / omg / IOP / RMICustomMaxStreamFormat.java。
RMIFailureHandler - Interface in java.rmi.server
一个 RMIFailureHandler可以通过 RMISocketFactory.setFailureHandler电话注册。
RMIIIOPServerImpl - Class in javax.management.remote.rmi
已过时。
此运输已不再受支持。
RMIIIOPServerImpl(Map<String, ?>) - Constructor for class javax.management.remote.rmi. RMIIIOPServerImpl
已过时。
投掷UnsupportedOperationException
RMIJRMPServerImpl - Class in javax.management.remote.rmi
一个RMIServer通过JRMP导出的对象，并将客户端连接创建为通过JRMP导出的RMI对象。
RMIJRMPServerImpl(int, RMIClientSocketFactory, RMIServerSocketFactory, Map<String, ?>) - Constructor for class javax.management.remote.rmi. RMIJRMPServerImpl
创建一个新的RMIServer对象，该对象将使用给定的套接字工厂在给定端口上导出。
RMISecurityException - Exception in java.rmi
已过时。
改用SecurityException 。 应用程式代码不应该直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。
RMISecurityException(String) - Constructor for exception java.rmi. RMISecurityException
已过时。
没有替换
RMISecurityException(String, String) - Constructor for exception java.rmi. RMISecurityException
已过时。
没有替换
RMISecurityManager - Class in java.rmi
已过时。
改用SecurityManager 。
RMISecurityManager() - Constructor for class java.rmi. RMISecurityManager
已过时。
构造新的 RMISecurityManager 。
RMIServer - Interface in javax.management.remote.rmi
用于建立与RMI连接器的连接的RMI对象。
RMIServerImpl - Class in javax.management.remote.rmi
表示连接器服务器的RMI对象。
RMIServerImpl(Map<String, ?>) - Constructor for class javax.management.remote.rmi. RMIServerImpl
构造新的 RMIServerImpl 。
RMIServerImpl_Stub - Class in javax.management.remote.rmi
RMIServerImpl_Stub(RemoteRef) - Constructor for class javax.management.remote.rmi. RMIServerImpl_Stub
RMIServerSocketFactory - Interface in java.rmi.server
RMI运行时使用 RMIServerSocketFactory实例来获取RMI调用的服务器套接字。
RMISocketFactory - Class in java.rmi.server
RMI运行时使用一个 RMISocketFactory实例，以获取RMI调用的客户端和服务器套接字。
RMISocketFactory() - Constructor for class java.rmi.server. RMISocketFactory
构造一个 RMISocketFactory 。
Robot - Class in java.awt
此类用于生成本机系统输入事件，用于测试自动化，自动运行演示和需要鼠标和键盘控制的其他应用程序。
Robot() - Constructor for class java.awt. Robot
在主屏幕的坐标系中构造一个Robot对象。
Robot(GraphicsDevice) - Constructor for class java.awt. Robot
为给定的屏幕设备创建一个机器人。
ROC - java.time.chrono. MinguoEra
当前时代的单身人士例子，“中华民国时代”，其数值为1。
Role - Class in javax.management.relation
表示角色：包括角色名称和引用的MBean（通过其ObjectNames）。
Role(String, List<ObjectName>) - Constructor for class javax.management.relation. Role
创建一个新的角色对象。
ROLE - javafx.scene. AccessibleAttribute
返回节点的角色。
ROLE_CARDINALITY_INFINITY - Static variable in class javax.management.relation. RoleInfo
指定无限的基数。
ROLE_DESCRIPTION - javafx.scene. AccessibleAttribute
返回节点的角色描述。
ROLE_NOT_READABLE - Static variable in class javax.management.relation. RoleStatus
尝试读取不可读属性时出现问题类型。
ROLE_NOT_WRITABLE - Static variable in class javax.management.relation. RoleStatus
尝试更新不可写属性时出现问题类型。
RoleInfo - Class in javax.management.relation
RoleInfo对象总结了关系类型中的角色。
RoleInfo(String, String) - Constructor for class javax.management.relation. RoleInfo
构造函数。
RoleInfo(String, String, boolean, boolean) - Constructor for class javax.management.relation. RoleInfo
构造函数。
RoleInfo(String, String, boolean, boolean, int, int, String) - Constructor for class javax.management.relation. RoleInfo
构造函数。
RoleInfo(RoleInfo) - Constructor for class javax.management.relation. RoleInfo
复制构造函数。
RoleInfoNotFoundException - Exception in javax.management.relation
当给定的关系类型中没有给定名称的角色信息时，会引发此异常。
RoleInfoNotFoundException() - Constructor for exception javax.management.relation. RoleInfoNotFoundException
默认构造函数，没有消息放在异常中。
RoleInfoNotFoundException(String) - Constructor for exception javax.management.relation. RoleInfoNotFoundException
具有给定消息的构造方法放在异常中。
RoleList - Class in javax.management.relation
RoleList表示角色列表（Role对象）。
RoleList() - Constructor for class javax.management.relation. RoleList
构造一个空的RoleList。
RoleList(int) - Constructor for class javax.management.relation. RoleList
构造一个空的RoleList，并指定初始容量。
RoleList(List<Role>) - Constructor for class javax.management.relation. RoleList
构造一个 RoleList其中包含 List指定的元素，按照它们由 List的迭代器返回的 List 。
RoleNotFoundException - Exception in javax.management.relation
当关系中的角色不存在或不可读或不可设置时，引发此异常。
RoleNotFoundException() - Constructor for exception javax.management.relation. RoleNotFoundException
默认构造函数，没有消息放在异常中。
RoleNotFoundException(String) - Constructor for exception javax.management.relation. RoleNotFoundException
具有给定消息的构造方法放在异常中。
RoleResult - Class in javax.management.relation
表示多次访问关系的几个角色（用于阅读或写入）的结果。
RoleResult(RoleList, RoleUnresolvedList) - Constructor for class javax.management.relation. RoleResult
构造函数。
RoleStatus - Class in javax.management.relation
此类描述访问角色时可能遇到的各种问题。
RoleStatus() - Constructor for class javax.management.relation. RoleStatus
RoleUnresolved - Class in javax.management.relation
代表一个未解决的角色：由于问题而无法从关系中检索到的角色。
RoleUnresolved(String, List<ObjectName>, int) - Constructor for class javax.management.relation. RoleUnresolved
构造函数。
RoleUnresolvedList - Class in javax.management.relation
RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。
RoleUnresolvedList() - Constructor for class javax.management.relation. RoleUnresolvedList
构造一个空的RoleUnresolvedList。
RoleUnresolvedList(int) - Constructor for class javax.management.relation. RoleUnresolvedList
构造一个空的RoleUnresolvedList，并指定初始容量。
RoleUnresolvedList(List<RoleUnresolved>) - Constructor for class javax.management.relation. RoleUnresolvedList
构造一个 RoleUnresolvedList含有的元素 List指定，在其中它们被返回的顺序 List的迭代器。
rmiregistry - Search tag in java.rmi
rmiregistry tool
rmid - Search tag in java.rmi
rmid tool
rmic - Search tag in jdk.rmic
rmic
roleValueToString(List<ObjectName>) - Static method in class javax.management.relation. Role
返回给定角色值的字符串。
roll(int, boolean) - Method in class java.util. Calendar
在给定时间字段上添加或减少单个时间单位，而不改变较大的字段。
roll(int, boolean) - Method in class java.util. GregorianCalendar
在给定时间字段上添加或减少单个时间单位，而不改变较大的字段。
roll(int, int) - Method in class java.util. Calendar
将指定（签名）金额添加到指定的日历字段，而不更改较大的字段。
roll(int, int) - Method in class java.util. GregorianCalendar
向指定的日历字段添加签名金额，而不更改较大的字段。
rollback() - Method in interface java.sql. Connection
撤消在当前事务中所做的所有更改，并释放此 Connection对象当前持有的任何数据库锁。
rollback() - Method in interface javax.sql.rowset. CachedRowSet
每个 CachedRowSet对象的 SyncProvider包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。
rollback() - Method in interface javax.sql.rowset. JdbcRowSet
每个 JdbcRowSet包含一个 Connection对象，从原来的 ResultSet或JDBC属性传递给它。
rollback() - Method in interface javax.sql.rowset.spi. TransactionalWriter
撤消在当前事务中所做的所有更改。
rollback(Savepoint) - Method in interface java.sql. Connection
撤消在给定的 Savepoint对象设置后进行的所有更改。
rollback(Savepoint) - Method in interface javax.sql.rowset. CachedRowSet
每个 CachedRowSet对象的 SyncProvider包含一个 Connection对象，从原始的 ResultSet或传递给它的JDBC属性。
rollback(Savepoint) - Method in interface javax.sql.rowset. JdbcRowSet
每个 JdbcRowSet包含 Connection对象从原始的 ResultSet或传递给它的JDBC属性。
rollback(Savepoint) - Method in interface javax.sql.rowset.spi. TransactionalWriter
撤消在给定的 Savepoint对象之前进行的当前交易中所做的所有更改。
rollback(Xid) - Method in interface javax.transaction.xa. XAResource
通知资源管理器代表交易分支回滚完成的工作。
ROLLBACK - java.awt.event. FocusEvent.Cause
焦点请求之后恢复焦点已被拒绝。
ROLLOVER - Static variable in class javax.swing. DefaultButtonModel
标识位掩码中的“翻转”位，表示鼠标在按钮上方。
ROLLOVER_ENABLED_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识从翻转启用的禁用或恢复启用的更改。
ROLLOVER_ICON_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识当光标在按钮上方使用的图标的更改。
ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识当光标在按钮上方并且已被选择时使用的图标的更改。
RolloverButtonBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.RolloverButtonBorder
RolloverButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic. BasicBorders.RolloverButtonBorder
构造一个新的实例 RolloverButtonBorder 。
rolloverColumnUpdated(int, int) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI
每当更新表头中的翻转列时，将调用此方法。
rolloverColumnUpdated(int, int) - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
每当更新表头中的翻转列时，将调用此方法。
rolloverListener - Variable in class javax.swing.plaf.metal. MetalToolBarUI
此保护字段是实现特定的。
ROMAN_BASELINE - Static variable in class java.awt.font. GraphicAttribute
将图形的起点与罗马线的基线对齐。
ROMAN_BASELINE - Static variable in class java.awt. Font
大多数罗马脚本在布局文本时使用的基线。
ROMAN_CHARACTERS - javafx.scene.input. KeyCode
罗马字符功能键的常数。
root - Variable in class javax.swing.tree. DefaultTreeModel
树的根。
ROOT - Static variable in class java.util. Locale
根区域的常用常数。
ROOT - Static variable in class javafx.event. EventType
根事件类型。
ROOT_PANE - Static variable in class javax.accessibility. AccessibleRole
具有玻璃窗格和分层窗格作为其子项的专用窗格。
ROOT_PANE - Static variable in class javax.swing.plaf.synth. Region
RootPane区域。
ROOT_PANE_PROPERTY - Static variable in class javax.swing. JInternalFrame
绑定属性名称。
ROOT_TAG - Static variable in class javafx.fxml. FXMLLoader
标签名称为<fx：root>。
ROOT_TYPE_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader
<fx：root>'type'属性。
ROOT_VISIBLE_PROPERTY - Static variable in class javax.swing. JTree
绑定属性名称为 rootVisible 。
RootDoc - Interface in com.sun.javadoc
已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
rootException - Variable in exception javax.naming. NamingException
包含导致此NamingException被抛出的原始异常。
RootLayout() - Constructor for class javax.swing. JRootPane.RootLayout
rootPane - Variable in class javax.swing. JApplet
已过时。
rootPane - Variable in class javax.swing. JDialog
rootPane - Variable in class javax.swing. JFrame
JRootPane实例管理 contentPane和可选的 menuBar为这个框架，以及 glassPane 。
rootPane - Variable in class javax.swing. JInternalFrame
管理内部窗格的 JRootPane实例以及该内部框架的可选菜单栏以及玻璃窗格。
rootPane - Variable in class javax.swing. JWindow
JRootPane实例管理 contentPane和可选的 menuBar为这个框架，以及 glassPane 。
rootPaneCheckingEnabled - Variable in class javax.swing. JApplet
已过时。
如果为true，那么拨打 add和 setLayout电话将被转发到 contentPane 。
rootPaneCheckingEnabled - Variable in class javax.swing. JDialog
如果为真，则拨打 add和 setLayout将转发到 contentPane 。
rootPaneCheckingEnabled - Variable in class javax.swing. JFrame
如果是，那么拨打 add和 setLayout电话将被转发到 contentPane 。
rootPaneCheckingEnabled - Variable in class javax.swing. JInternalFrame
如果为真，则拨打 add和 setLayout将转发到 contentPane 。
rootPaneCheckingEnabled - Variable in class javax.swing. JWindow
如果为真，则拨打 add和 setLayout将转发到 contentPane 。
RootPaneContainer - Interface in javax.swing
该接口由具有单个JRootPane子组件的组件实现：JDialog，JFrame，JWindow，JApplet，JInternalFrame。
RootPaneUI - Class in javax.swing.plaf
JRootPane可插拔的外观和界面。
RootPaneUI() - Constructor for class javax.swing.plaf. RootPaneUI
rootProperty() - Method in class javafx.scene.control. TreeTableView
表示TreeTableView根节点的属性。
rootProperty() - Method in class javafx.scene.control. TreeView
表示TreeView根节点的属性。
rootProperty() - Method in class javafx.scene. Scene
定义场景图的根 Node 。
rootProperty() - Method in class javafx.scene. SubScene
定义 SubScene场景图的根 Node 。
rootVisible - Variable in class javax.swing. JTree
如果显示根节点，则为真，如果子节点是最高可见节点，则为false。
rootVisible - Variable in class javax.swing.tree. AbstractLayoutCache
如果显示根节点，则为真，如果子节点是最高可见节点，则为false。
ROSYBROWN - Static variable in class javafx.scene.paint. Color
颜色玫瑰色棕色，RGB值为＃BC8F8F
rotate(double) - Method in class java.awt.geom. AffineTransform
使用旋转变换连接此变换。
rotate(double) - Method in class java.awt. Graphics2D
使用旋转变换连接当前的 Graphics2D Transform 。
rotate(double) - Method in class javafx.scene.canvas. GraphicsContext
以度为单位旋转当前变换。
rotate(double, double) - Method in class java.awt.geom. AffineTransform
使用根据旋转矢量旋转坐标的变换来连接此变换。
rotate(double, double, double) - Method in class java.awt.geom. AffineTransform
将此变换与使锚点附近旋转坐标的变换相连。
rotate(double, double, double) - Method in class java.awt. Graphics2D
使用转换的旋转变换连接当前的 Graphics2D Transform 。
rotate(double, double, double) - Static method in class javafx.scene.transform. Transform
返回一个 Rotate对象，旋转枢轴点周围的坐标。
rotate(double, double, double, double) - Method in class java.awt.geom. AffineTransform
使用根据旋转矢量围绕锚点旋转坐标的变换来连接此变换。
rotate(List<?>, int) - Static method in class java.util. Collections
将指定列表中的元素旋转指定的距离。
rotate(ObservableList, int) - Static method in class javafx.collections. FXCollections
按距离旋转列表。
Rotate - Class in javafx.scene.transform
该类表示一个 Affine对象，它绕坐标点旋转坐标。
Rotate() - Constructor for class javafx.scene.transform. Rotate
创建默认的旋转变换（标识）。
Rotate(double) - Constructor for class javafx.scene.transform. Rotate
创建二维旋转变换。
Rotate(double, double, double) - Constructor for class javafx.scene.transform. Rotate
用枢轴创建二维旋转变换。
Rotate(double, double, double, double) - Constructor for class javafx.scene.transform. Rotate
创建一个简单的旋转变换与三维枢轴。
Rotate(double, double, double, double, Point3D) - Constructor for class javafx.scene.transform. Rotate
用枢轴创建三维旋转变换。
Rotate(double, Point3D) - Constructor for class javafx.scene.transform. Rotate
创建一个三维旋转变换。
ROTATE - javafx.scene. CacheHint
提示说明位图缓存机制，如果节点被旋转，可以通过旋转缓存的位图（而不是重新渲染节点）来绘制它。
ROTATE - Static variable in class javafx.scene.input. RotateEvent
当用户执行旋转手势（例如将两个手指彼此拖动时）发生此事件。
RotateEvent - Class in javafx.scene.input
旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
RotateEvent(Object, EventTarget, EventType<RotateEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, double, double, PickResult) - Constructor for class javafx.scene.input. RotateEvent
构造新的RotateEvent事件。
RotateEvent(EventType<RotateEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, double, double, PickResult) - Constructor for class javafx.scene.input. RotateEvent
构造具有null源和目标的新的RotateEvent事件
rotateGraphicProperty() - Method in class javafx.scene.control. TabPane
TabPane中选项卡的rotateGraphic状态。
rotateInsets(Insets, Insets, int) - Static method in class javax.swing.plaf.basic. BasicTabbedPaneUI
旋转插图。
rotateLeft(int, int) - Static method in class java.lang. Integer
返回通过将指定的 int值的二进制补码二进制表示旋转指定的 int值。
rotateLeft(long, int) - Static method in class java.lang. Long
返回通过将指定的 long值的二进制补码二进制表示旋转指定的 long值。
rotateProperty() - Method in class javafx.scene. Node
定义关于 Node的中心的旋转角度，以度为单位。
rotateRight(int, int) - Static method in class java.lang. Integer
返回通过将指定的 int值的二进制补码二进制表达式右 int指定的位数而 int值。
rotateRight(long, int) - Static method in class java.lang. Long
返回通过将指定的 long值的二进制补码二进制表达式右 long指定的位数而 long值。
rotateTabRuns(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout
旋转运行索引数组，以便运行选定的运行[0]。
rotateTabRuns(int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI.TabbedPaneLayout
RotateTransition - Class in javafx.animation
这个 Transition创建了一个旋转动画，跨越其 duration 。
RotateTransition() - Constructor for class javafx.animation. RotateTransition
构造函数为 RotateTransition
RotateTransition(Duration) - Constructor for class javafx.animation. RotateTransition
构造函数为 RotateTransition
RotateTransition(Duration, Node) - Constructor for class javafx.animation. RotateTransition
构造函数为 RotateTransition
ROTATION_FINISHED - Static variable in class javafx.scene.input. RotateEvent
当旋转手势结束时，会发生此事件。
ROTATION_STARTED - Static variable in class javafx.scene.input. RotateEvent
当检测到旋转手势时，会发生此事件。
rotationAxisProperty() - Method in class javafx.scene. Node
定义 Node的旋转轴。
round(double) - Static method in class java.lang. Math
返回参数中最接近的 long ，其中 long四舍五入到正无穷大。
round(double) - Static method in class java.lang. StrictMath
返回参数中最接近的 long ，其中 long四舍五入为正无穷大。
round(float) - Static method in class java.lang. Math
返回参数最接近的 int ，其中 int四舍五入为正无穷大。
round(float) - Static method in class java.lang. StrictMath
返回最接近 int的参数，其中 int四舍五入为正无穷大。
round(MathContext) - Method in class java.math. BigDecimal
返回 BigDecimal根据四舍五入 MathContext设置。
ROUND - javafx.scene.layout. BackgroundRepeat
经常重复图像将适合该区域内。
ROUND - javafx.scene.layout. BorderRepeat
图像被平铺（重复）并重新缩放（如果需要），以填充整个区域的区域。
ROUND - javafx.scene.shape. ArcType
通过将直线段从弧段开始到完全椭圆的中心并从该点到弧段的末端将闭合类型关闭。
ROUND - javafx.scene.shape. StrokeLineCap
用圆形装饰结束未封闭的子路径和划线段，半圆形的半径等于笔宽的一半。
ROUND - javafx.scene.shape. StrokeLineJoin
通过以半角宽度的半径舍入角落来连接路径段。
ROUND_CEILING - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.CEILING 。
ROUND_DOWN - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.DOWN 。
ROUND_FLOOR - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.FLOOR 。
ROUND_HALF_DOWN - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.HALF_DOWN 。
ROUND_HALF_EVEN - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.HALF_EVEN 。
ROUND_HALF_UP - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.HALF_UP 。
ROUND_UNNECESSARY - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.UNNECESSARY 。
ROUND_UP - Static variable in class java.math. BigDecimal
已过时。
改用RoundingMode.UP 。
roundedCorners - Variable in class javax.swing.border. LineBorder
边界是否有圆角。
RoundEnvironment - Interface in javax.annotation.processing
注释处理工具框架将为 provide an annotation processor with an object implementing this interface ，使得处理器可以查询关于一轮注释处理的信息。
RoundingMode - Enum in java.math
指定能够丢弃精度的数值运算的 舍入行为 。
RoundRectangle2D - Class in java.awt.geom
RoundRectangle2D类定义了一个矩形，其圆角由位置 (x,y)定义，尺寸为 (w x h) ，以及 (w x h)的宽度和高度。
RoundRectangle2D() - Constructor for class java.awt.geom. RoundRectangle2D
这是一个无法直接实例化的抽象类。
RoundRectangle2D.Double - Class in java.awt.geom
Double类定义了一个带有圆角的矩形，全部在 double指定。
RoundRectangle2D.Float - Class in java.awt.geom
Float类定义了一个具有圆角的矩形，全部在 float坐标中指定。
row(MatrixType, int) - Method in class javafx.scene.transform. Transform
返回一个包含转换矩阵行的数组。
row(MatrixType, int, double[]) - Method in class javafx.scene.transform. Transform
返回一个包含转换矩阵行的数组。
ROW_AT_INDEX - javafx.scene. AccessibleAttribute
返回给定索引处的行。
ROW_COUNT - javafx.scene. AccessibleAttribute
返回节点的行数。
ROW_HEADER - Static variable in class javax.accessibility. AccessibleRole
一行数据的标题。
ROW_HEADER - Static variable in interface javax.swing. ScrollPaneConstants
识别左上角和左下角之间的视口左侧的区域。
ROW_HEIGHT_PROPERTY - Static variable in class javax.swing. JTree
绑定属性名称为 rowHeight 。
ROW_INDEX - javafx.scene. AccessibleAttribute
返回节点的行索引。
rowAtPoint(Point) - Method in class javax.swing. JTable
返回 point所在行的索引，如果结果不在[ getRowCount() -1]范围内，则 getRowCount() -1。
rowChanged(RowSetEvent) - Method in interface javax.sql. RowSetListener
通知已注册的侦听器，一个 RowSet对象在其一行中发生了更改。
RowConstraints - Class in javafx.scene.layout
为GridPane中的行定义可选布局约束。
RowConstraints() - Constructor for class javafx.scene.layout. RowConstraints
创建没有设置属性的行约束对象。
RowConstraints(double) - Constructor for class javafx.scene.layout. RowConstraints
创建具有固定高度的行约束对象。
RowConstraints(double, double, double) - Constructor for class javafx.scene.layout. RowConstraints
创建具有固定大小范围的行约束对象。
RowConstraints(double, double, double, Priority, VPos, boolean) - Constructor for class javafx.scene.layout. RowConstraints
创建具有固定大小范围，垂直增长优先级，垂直对齐和垂直填充行为的行约束对象。
rowDeleted() - Method in interface java.sql. ResultSet
检索行是否被删除。
rowFactoryProperty() - Method in class javafx.scene.control. TableView
一个产生TableRow的函数。
rowFactoryProperty() - Method in class javafx.scene.control. TreeTableView
一个生成TreeTableRow的函数。
RowFilter< M, I> - Class in javax.swing
RowFilter用于过滤模型中的条目，以便它们不会在视图中显示。
RowFilter() - Constructor for class javax.swing. RowFilter
RowFilter.ComparisonType - Enum in javax.swing
枚举一些默认的 RowFilter s支持的可能比较值。
RowFilter.Entry< M, I> - Class in javax.swing
一个 Entry对象传递给 RowFilter实例，允许过滤器获取条目数据的值，从而确定是否应该显示条目。
rowHead - Variable in class javax.swing. ScrollPaneLayout
行标题子。
rowHeader - Variable in class javax.swing. JScrollPane
行标题子。
rowHeight - Variable in class javax.swing. JTable
表中每行的像素高度。
rowHeight - Variable in class javax.swing. JTree
每个显示行使用的高度。
rowHeight - Variable in class javax.swing.tree. AbstractLayoutCache
每行要使用的高度。
rowHeights - Variable in class java.awt. GridBagLayout
此字段将覆盖行的最小高度。
RowId - Interface in java.sql
SQL编程语言中的表示（映射）SQL ROWID值。
ROWID - java.sql. JDBCType
标识SQL类型 ROWID 。
ROWID - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 ROWID
ROWID_UNSUPPORTED - java.sql. RowIdLifetime
表示此数据源不支持ROWID类型。
ROWID_VALID_FOREVER - java.sql. RowIdLifetime
表示来自该数据源的RowId的生存期实际上是无限制的。
ROWID_VALID_OTHER - java.sql. RowIdLifetime
表示来自此数据源的RowId的生命周期是不确定的; 但不是ROWID_VALID_TRANSACTION，ROWID_VALID_SESSION或ROWID_VALID_FOREVER之一。
ROWID_VALID_SESSION - java.sql. RowIdLifetime
表示来自此数据源的RowId的生命周期至少为包含会话。
ROWID_VALID_TRANSACTION - java.sql. RowIdLifetime
表示来自此数据源的RowId的生命周期至少为包含事务。
RowIdLifetime - Enum in java.sql
RowId寿命值的枚举。
rowInserted() - Method in interface java.sql. ResultSet
检索当前行是否有插入。
rowMapper - Variable in class javax.swing.tree. DefaultTreeSelectionModel
为给定的路径提供一行。
RowMapper - Interface in javax.swing.tree
定义将树中的路径转换为显示行的对象的要求。
rowMargin - Variable in class javax.swing. JTable
每行单元格之间的边距的像素高度。
rows() - Method in enum javafx.scene.transform. MatrixType
返回此类型的矩阵中的行数。
ROWS - Static variable in class javax.swing.text.html. HTML.Attribute
属性“行”
rowsDeleted(int, int) - Method in class javax.swing. DefaultRowSorter
当从指定范围（含）的底层模型中删除行时调用。
rowsDeleted(int, int) - Method in class javax.swing. RowSorter
当从指定范围（含）的底层模型中删除行时调用。
rowSelectionAllowed - Variable in class javax.swing. JTable
如果此表中允许行选择，则为真。
RowSet - Interface in javax.sql
该接口为JavaBeans组件模型的JDBC API添加了支持。
ROWSET_SYNC_PROVIDER - Static variable in class javax.sql.rowset.spi. SyncFactory
同步提供程序实现名称的标准属性ID。
ROWSET_SYNC_PROVIDER_VERSION - Static variable in class javax.sql.rowset.spi. SyncFactory
同步提供程序实现版本标记的标准属性ID。
ROWSET_SYNC_VENDOR - Static variable in class javax.sql.rowset.spi. SyncFactory
同步提供程序实现供应商名称的标准属性ID。
rowSetChanged(RowSetEvent) - Method in interface javax.sql. RowSetListener
通知注册的听众，给定的 RowSet对象中的一个 RowSetEvent对象已更改其全部内容。
RowSetEvent - Class in javax.sql
当 Event对象发生事件时生成一个 RowSet对象。
RowSetEvent(RowSet) - Constructor for class javax.sql. RowSetEvent
构造一个使用给定的 RowSetEvent对象初始化的 RowSet对象。
RowSetFactory - Interface in javax.sql.rowset
一个定义工厂实现的接口，用于获取不同类型的 RowSet实现。
RowSetInternal - Interface in javax.sql
RowSet对象实现的接口，以便向 RowSetReader或 RowSetWriter对象呈现自身。
RowSetListener - Interface in javax.sql
一个接口，必须由一个组件实现，当一个重大事件发生在 RowSet对象的生命中时，该组件希望被通知。
RowSetMetaData - Interface in javax.sql
包含有关 RowSet对象中的列的 RowSet对象。
RowSetMetaDataImpl - Class in javax.sql.rowset
提供有关设置和获取有关 RowSet对象列的元数据信息的方法的实现。
RowSetMetaDataImpl() - Constructor for class javax.sql.rowset. RowSetMetaDataImpl
rowSetPopulated(RowSetEvent, int) - Method in interface javax.sql.rowset. CachedRowSet
通知已注册的侦听器给定的RowSetEvent对象中的RowSet对象已经填充了许多其他行。
RowSetProvider - Class in javax.sql.rowset
工厂API，使应用程序能够获得 RowSetFactory实现，可将用于产生不同类型的 RowSet实现。
RowSetProvider() - Constructor for class javax.sql.rowset. RowSetProvider
RowSetProvider构造函数
RowSetReader - Interface in javax.sql
断开连接的 RowSet对象调用的工具将自己填充数据行。
RowSetWarning - Exception in javax.sql.rowset
SQLException的扩展名，它提供了有关在 RowSet对象上设置的数据库警告的信息。
RowSetWarning() - Constructor for exception javax.sql.rowset. RowSetWarning
构造一个默认的 RowSetWarning对象。
RowSetWarning(String) - Constructor for exception javax.sql.rowset. RowSetWarning
构造一个具有给定值的RowSetWarning对象的原因; SQLState默认为null，vendorCode默认为0。
RowSetWarning(String, String) - Constructor for exception javax.sql.rowset. RowSetWarning
构造一个 RowSetWarning对象，该对象由于原因和SQLState由给定值初始化。
RowSetWarning(String, String, int) - Constructor for exception javax.sql.rowset. RowSetWarning
构造一个完全指定的 RowSetWarning对象，该对象使用给定值初始化，原因为SQLState和vendorCode。
RowSetWriter - Interface in javax.sql
一个实现 RowSetWriter接口的对象，称为 写入器 。
rowsInserted(int, int) - Method in class javax.swing. DefaultRowSorter
当行已经在指定范围（包括）中插入到底层模型中时调用。
rowsInserted(int, int) - Method in class javax.swing. RowSorter
当行已经在指定范围（包括）中插入到底层模型中时调用。
RowSorter< M> - Class in javax.swing
RowSorter为排序和筛选提供依据。
RowSorter() - Constructor for class javax.swing. RowSorter
创建一个 RowSorter 。
RowSorter.SortKey - Class in javax.swing
SortKey描述特定列的排序顺序。
RowSorterEvent - Class in javax.swing.event
RowSorterEvent提供改变到的通知 RowSorter 。
RowSorterEvent(RowSorter<?>) - Constructor for class javax.swing.event. RowSorterEvent
创建 RowSorterEvent类型 SORT_ORDER_CHANGED 。
RowSorterEvent(RowSorter<?>, RowSorterEvent.Type, int[]) - Constructor for class javax.swing.event. RowSorterEvent
创建一个 RowSorterEvent 。
RowSorterEvent.Type - Enum in javax.swing.event
枚举类型 RowSorterEvent s。
RowSorterListener - Interface in javax.swing.event
RowSorterListener被通知更改为 RowSorter 。
ROWSPAN - Static variable in class javax.swing.text.html. HTML.Attribute
属性“rowspan”
rowsRemoved(TableModelEvent) - Method in class javax.swing.table. DefaultTableModel
相当于 fireTableChanged 。
rowsUpdated(int, int) - Method in class javax.swing. DefaultRowSorter
在基础模型中在指定范围（包括）之间更改行时调用。
rowsUpdated(int, int) - Method in class javax.swing. RowSorter
在基础模型中在指定范围（包括）之间更改行时调用。
rowsUpdated(int, int, int) - Method in class javax.swing. DefaultRowSorter
当行中的列在指定范围内的底层模型中更新时调用。
rowsUpdated(int, int, int) - Method in class javax.swing. RowSorter
当行中的列在指定范围内的底层模型中更新时调用。
rowUpdated() - Method in interface java.sql. ResultSet
检索当前行是否已更新。
rowValignmentProperty() - Method in class javafx.scene.layout. FlowPane
水平流花线每行内的节点垂直对齐。
rowWeights - Variable in class java.awt. GridBagLayout
此字段保留对行权重的覆盖。
ROYALBLUE - Static variable in class javafx.scene.paint. Color
颜色为皇家蓝色，RGB值为＃4169E1
RPC - javax.jws.soap. SOAPBinding.Style
RSA_SHA1 - Static variable in interface javax.xml.crypto.dsig. SignatureMethod
RSAwithSHA1 （PKCS＃1）签名方法算法URI。
RSA_TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo. KeyValue
标识RSA KeyValue KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。
RSAKey - Interface in java.security.interfaces
与RSA公钥或私钥的接口。
RSAKeyGenParameterSpec - Class in java.security.spec
此类指定用于生成RSA密钥对的参数集。
RSAKeyGenParameterSpec(int, BigInteger) - Constructor for class java.security.spec. RSAKeyGenParameterSpec
从给定的keysize和public-exponent值构造一个新的 RSAParameterSpec对象。
RSAMultiPrimePrivateCrtKey - Interface in java.security.interfaces
与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
RSAMultiPrimePrivateCrtKeySpec - Class in java.security.spec
该类指定PKCS＃1 v2.1中定义的RSA多权限私钥，使用中文余数定理（CRT）信息值进行效率。
RSAMultiPrimePrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, RSAOtherPrimeInfo[]) - Constructor for class java.security.spec. RSAMultiPrimePrivateCrtKeySpec
创建一个新的 RSAMultiPrimePrivateCrtKeySpec给定在PKCS＃1 v2.1中定义的模数publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ，crtCoefficient和otherPrimeInfo。
RSAOtherPrimeInfo - Class in java.security.spec
该类表示RSA的OtherPrimeInfo结构中的三元组（素数，指数和系数），如PKCS＃1 v2.1中定义的。
RSAOtherPrimeInfo(BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec. RSAOtherPrimeInfo
创建一个新的 RSAOtherPrimeInfo给定在PKCS＃1中定义的素数，primeExponent和crtCoefficient。
RSAPrivateCrtKey - Interface in java.security.interfaces
使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
RSAPrivateCrtKeySpec - Class in java.security.spec
该类指定PKCS＃1标准中定义的RSA私钥，使用中文余数定理（CRT）信息值进行效率。
RSAPrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec. RSAPrivateCrtKeySpec
创建一个新的 RSAPrivateCrtKeySpec给定在PKCS＃1中定义的模数，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ和crtCoefficient。
RSAPrivateKey - Interface in java.security.interfaces
RSA私钥的接口。
RSAPrivateKeySpec - Class in java.security.spec
此类指定一个RSA私钥。
RSAPrivateKeySpec(BigInteger, BigInteger) - Constructor for class java.security.spec. RSAPrivateKeySpec
创建一个新的RSAPrivateKeySpec。
RSAPublicKey - Interface in java.security.interfaces
与RSA公钥的接口。
RSAPublicKeySpec - Class in java.security.spec
此类指定一个RSA公钥。
RSAPublicKeySpec(BigInteger, BigInteger) - Constructor for class java.security.spec. RSAPublicKeySpec
创建一个新的RSAPublicKeySpec。
RTF - Static variable in class javafx.scene.input. DataFormat
表示RTF格式的字符串
RTFEditorKit - Class in javax.swing.text.rtf
这是RTF编辑功能的默认实现。
RTFEditorKit() - Constructor for class javax.swing.text.rtf. RTFEditorKit
构造一个RTFEditorKit。
Rule - Class in javafx.css
RuleBasedCollator - Class in java.text
所述 RuleBasedCollator类是的具体子类 Collator ，提供了一个简单的，数据驱动的表collator。
RuleBasedCollator(String) - Constructor for class java.text. RuleBasedCollator
RuleBasedCollator构造函数。
RULER - Static variable in class javax.accessibility. AccessibleRole
标尺是用于测量距离的对象。
RUMI_NUMERAL_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
常数为“Rumi数字符号”Unicode字符块。
run() - Method in class java.awt.image.renderable. RenderableImageProducer
这个类的runnable方法。
run() - Method in interface java.lang. Runnable
当使用实现接口 Runnable的对象来创建线程时，启动线程将导致在该单独执行的线程中调用对象的 run方法。
run() - Method in class java.lang. Thread
如果使用单独的Runnable运行对象构建此线程，则Runnable对象的run对象的run方法; 否则，此方法不执行任何操作并返回。
run() - Method in interface java.security. PrivilegedAction
执行计算。
run() - Method in interface java.security. PrivilegedExceptionAction
执行计算。
run() - Method in class java.util.concurrent. ForkJoinWorkerThread
这种方法是公开的，但不应该被明确地调用。
run() - Method in class java.util.concurrent. FutureTask
run() - Method in interface java.util.concurrent. RunnableFuture
将此未来设置为其计算结果，除非已被取消。
run() - Method in class java.util. TimerTask
该定时器任务要执行的操作。
run() - Method in class javax.swing. SwingWorker
将此 Future设置为计算结果，除非已被取消。
run() - Method in class javax.swing.text. AsyncBoxView.ChildState
更新子状态。
run() - Method in class org.omg.CORBA. ORB
此操作阻止当前线程，直到ORB完成关闭进程，当某个线程调用 shutdown时启动。
run(InputStream, OutputStream, OutputStream, String...) - Method in interface javax.tools. Tool
使用给定的I / O通道和参数运行该工具。
run(PrintStream, PrintStream, String...) - Method in interface java.util.spi. ToolProvider
运行该工具的实例，返回零以成功运行。
run(PrintWriter, PrintWriter, String...) - Method in interface java.util.spi. ToolProvider
运行该工具的实例，返回零以成功运行。
run(String...) - Method in interface jdk.jshell.tool. JavaShellToolBuilder
运行该接口中其他方法配置的Java Shell工具实例。
run(DocletEnvironment) - Method in interface jdk.javadoc.doclet. Doclet
doclet的入口点。
run(DocletEnvironment) - Method in class jdk.javadoc.doclet. StandardDoclet
RUN_DIRECTION - Static variable in class java.awt.font. TextAttribute
行的运行方向的属性键。
RUN_DIRECTION_LTR - Static variable in class java.awt.font. TextAttribute
从左到右的运行方向。
RUN_DIRECTION_RTL - Static variable in class java.awt.font. TextAttribute
从右到左的运行方向。
runAfterBoth(CompletionStage<?>, Runnable) - Method in class java.util.concurrent. CompletableFuture
runAfterBoth(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。
runAfterBothAsync(CompletionStage<?>, Runnable) - Method in class java.util.concurrent. CompletableFuture
runAfterBothAsync(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
runAfterBothAsync(CompletionStage<?>, Runnable, Executor) - Method in class java.util.concurrent. CompletableFuture
runAfterBothAsync(CompletionStage<?>, Runnable, Executor) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
runAfterEither(CompletionStage<?>, Runnable) - Method in class java.util.concurrent. CompletableFuture
runAfterEither(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。
runAfterEitherAsync(CompletionStage<?>, Runnable) - Method in class java.util.concurrent. CompletableFuture
runAfterEitherAsync(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
runAfterEitherAsync(CompletionStage<?>, Runnable, Executor) - Method in class java.util.concurrent. CompletableFuture
runAfterEitherAsync(CompletionStage<?>, Runnable, Executor) - Method in interface java.util.concurrent. CompletionStage
返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
runAndReset() - Method in class java.util.concurrent. FutureTask
执行计算而不设置其结果，然后将此将来重置为初始状态，如果计算遇到异常或被取消，则不执行此操作。
runAsync(Runnable) - Static method in class java.util.concurrent. CompletableFuture
返回一个新的CompletableFuture，它在运行给定操作后由运行在 ForkJoinPool.commonPool()中的任务异步完成。
runAsync(Runnable, Executor) - Static method in class java.util.concurrent. CompletableFuture
返回一个新的CompletableFuture，它在运行给定操作之后由在给定执行程序中运行的任务异步完成。
runCount - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
运行计数
RunElement(Element, AttributeSet, int, int) - Constructor for class javax.swing.text.html. HTMLDocument.RunElement
构造一个表示文档内容（没有子项）的元素。
runFinalization() - Method in class java.lang. Runtime
运行任何对象等待定稿的最终化方法。
runFinalization() - Static method in class java.lang. System
运行任何对象等待定稿的最终化方法。
runFinalizersOnExit(boolean) - Static method in class java.lang. Runtime
不推荐用于删除：此API元素将在以后的版本中被删除。
这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
runFinalizersOnExit(boolean) - Static method in class java.lang. System
不推荐用于删除：此API元素将在以后的版本中被删除。
这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
RUNIC - java.lang. Character.UnicodeScript
Unicode脚本“符文”。
RUNIC - Static variable in class java.lang. Character.UnicodeBlock
“Runic”Unicode字符块的常量。
runLater(Runnable) - Static method in class javafx.application. Platform
在将来某些未指定的时间运行JavaFX应用程序线程上指定的Runnable。
runnable - Variable in class java.awt.event. InvocationEvent
Runnable的run（）方法将被调用。
Runnable - Interface in java.lang
Runnable接口应由任何类实现，其实例将由线程执行。
RUNNABLE - java.lang. Thread.State
可运行线程的线程状态。
RunnableFuture< V> - Interface in java.util.concurrent
A Future那是Runnable 。
RunnableScheduledFuture< V> - Interface in java.util.concurrent
A ScheduledFuture那是Runnable 。
running() - Method in class javafx.concurrent. Service
每当该服务的状态已经转换到RUNNING状态时，调用子类的受保护的便利方法。
running() - Method in class javafx.concurrent. Task
每当任务的状态已经转换到RUNNING状态时调用的子类的受保护的便利方法。
RUNNING - javafx.animation. Animation.Status
运行状态。
RUNNING - javafx.concurrent. Worker.State
表示此Worker正在运行。
runningProperty() - Method in class javafx.concurrent. Service
runningProperty() - Method in class javafx.concurrent. Task
runningProperty() - Method in interface javafx.concurrent. Worker
获取表示Worker正在运行的ReadOnlyBooleanProperty。
Runtime - Class in java.lang
每个Java应用程序都有一个 Runtime类的 Runtime ，允许应用程序与运行应用程序的环境进行接口。
RunTime - Interface in org.omg.SendingContext
定义表示请求的发送上下文的基类。
RUNTIME - java.lang.annotation. RetentionPolicy
注释将由编译器记录在类文件中，并由VM在运行时保留，因此可以反射读取。
RUNTIME_ERROR - Static variable in class javax.management.monitor. MonitorNotification
指示在尝试获取观察属性的值时发生非预定义错误类型的通知类型。
RUNTIME_ERROR_NOTIFIED - Static variable in class javax.management.monitor. Monitor
表示在更改观察到的对象或观察到的属性之后发生通知。
RUNTIME_MXBEAN_NAME - Static variable in class java.lang.management. ManagementFactory
ObjectName字符串表示为RuntimeMXBean 。
Runtime.Version - Class in java.lang
用于实现Java SE平台的版本字符串的表示。
RuntimeErrorException - Exception in javax.management
当一个 java.lang.Error发生在代理中时，它应该被捕获并重新抛出为 RuntimeErrorException 。
RuntimeErrorException(Error) - Constructor for exception javax.management. RuntimeErrorException
默认构造函数。
RuntimeErrorException(Error, String) - Constructor for exception javax.management. RuntimeErrorException
允许指定特定错误消息的构造方法。
RuntimeException - Exception in java.lang
RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
RuntimeException() - Constructor for exception java.lang. RuntimeException
构造新的运行时异常， null的详细信息为 null 。
RuntimeException(String) - Constructor for exception java.lang. RuntimeException
使用指定的详细消息构造新的运行时异常。
RuntimeException(String, Throwable) - Constructor for exception java.lang. RuntimeException
构造一个新的运行时异常与指定的详细信息和原因。
RuntimeException(String, Throwable, boolean, boolean) - Constructor for exception java.lang. RuntimeException
构造一个新的运行时异常，其中包含指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
RuntimeException(Throwable) - Constructor for exception java.lang. RuntimeException
构造一个新的运行时异常，其中指定的原因和详细消息为 (cause==null ? null : cause.toString()) （通常包含类和详细消息为 cause ）。
RuntimeMBeanException - Exception in javax.management
表示代理中MBean方法抛出的运行时异常。
RuntimeMBeanException(RuntimeException) - Constructor for exception javax.management. RuntimeMBeanException
创建一个 RuntimeMBeanException包裹实际的 java.lang.RuntimeException 。
RuntimeMBeanException(RuntimeException, String) - Constructor for exception javax.management. RuntimeMBeanException
创建一个 RuntimeMBeanException ，其中包含实际的 java.lang.RuntimeException详细消息。
RuntimeMXBean - Interface in java.lang.management
Java虚拟机的运行时系统的管理界面。
RunTimeOperations - Interface in org.omg.SendingContext
定义表示请求的发送上下文的基类的操作。
RuntimeOperationsException - Exception in javax.management
表示在对MBean执行操作时在代理中抛出的运行时异常。
RuntimeOperationsException(RuntimeException) - Constructor for exception javax.management. RuntimeOperationsException
创建一个 RuntimeOperationsException包裹实际的 java.lang.RuntimeException 。
RuntimeOperationsException(RuntimeException, String) - Constructor for exception javax.management. RuntimeOperationsException
创建一个 RuntimeOperationsException ，其中包含实际的 java.lang.RuntimeException详细消息。
RuntimePermission - Class in java.lang
此类用于运行时权限。
RuntimePermission(String) - Constructor for class java.lang. RuntimePermission
创建一个新的具有指定名称的RuntimePermission。
RuntimePermission(String, String) - Constructor for class java.lang. RuntimePermission
创建一个具有指定名称的新RuntimePermission对象。
runtimeVersion() - Static method in class java.util.jar. JarFile
Returns the version that represents the effective runtime versioned configuration of a multi-release jar file.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


S-Index (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

SEARCH:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
S

S - javafx.css. SizeUnits

S - javafx.scene.input. KeyCode

常数为 S键。

S - Static variable in class javax.swing.text.html. HTML.Tag

标签<s>

S_RESIZE - Static variable in class javafx.scene. Cursor

调整大小的光标类型。

S_RESIZE_CURSOR - Static variable in class java.awt. Cursor

调整大小的光标类型。

S_RESIZE_CURSOR - Static variable in class java.awt. Frame

已过时。
替换为Cursor.S_RESIZE_CURSOR 。

SAAJMetaFactory - Class in javax.xml.soap

在SAAJ API中定义的工厂的实现类的接入点。

SAAJMetaFactory() - Constructor for class javax.xml.soap. SAAJMetaFactory

SAAJResult - Class in javax.xml.soap

作为SAAJ树形式的JAXP转换或JAXB编组的结果的持有者。

SAAJResult() - Constructor for class javax.xml.soap. SAAJResult

创建一个 SAAJResult ，它将以支持默认（SOAP 1.1）协议的SAAJ树的形式呈现结果。

SAAJResult(String) - Constructor for class javax.xml.soap. SAAJResult

创建一个 SAAJResult ，它将以支持指定协议的SAAJ树的形式呈现结果。

SAAJResult(SOAPElement) - Constructor for class javax.xml.soap. SAAJResult

创建一个 SAAJResult ，它将结果写入指定的 SOAPElement的子节点。

SAAJResult(SOAPMessage) - Constructor for class javax.xml.soap. SAAJResult

创建一个 SAAJResult ，将结果写入到 SOAPPart所提供的 SOAPMessage 。

SADDLE_STITCH - Static variable in class javax.print.attribute.standard. Finishings

用一个或多个订书钉（线缝）沿着中间折叠处捆绑文档。

SADDLEBROWN - Static variable in class javafx.scene.paint. Color

颜色马鞍棕色，RGB值为＃8B4513

SafeVarargs - Annotation Type in java.lang

程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。

SALMON - Static variable in class javafx.scene.paint. Color

颜色三文鱼的RGB值为＃FA8072

SAMARITAN - java.lang. Character.UnicodeScript

Unicode脚本“撒玛利亚人”。

SAMARITAN - Static variable in class java.lang. Character.UnicodeBlock

“Samaritan”Unicode字符块的常数。

SAME_PROTOCOL - jdk.incubator.http. HttpClient.Redirect

仅重定向到同一协议。

sameFile(URL) - Method in class java.net. URL

比较两个URL，不包括片段组件。

sameFile(URL, URL) - Method in class java.net. URLStreamHandler

比较两个URL以查看它们是否引用相同的文件，即具有相同的协议，主机，端口和路径。

SAMP - Static variable in class javax.swing.text.html. HTML.Tag

标签<samp>

SAMPLE_FORMAT_FLOATING_POINT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“SampleFormat”标签一起使用的值。

SAMPLE_FORMAT_SIGNED_INTEGER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“SampleFormat”标签一起使用的值。

SAMPLE_FORMAT_UNDEFINED - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“SampleFormat”标签一起使用的值。

SAMPLE_FORMAT_UNSIGNED_INTEGER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“SampleFormat”标签一起使用的值。

SAMPLE_RATE - Static variable in class javax.sound.sampled. FloatControl.Type

表示改变音频播放的采样率的控件。

sampleModel - Variable in class java.awt.image. Raster

SampleModel描述了这个栅格的像素如何存储在DataBuffer中。

sampleModel - Variable in class javax.imageio. ImageTypeSpecifier

A SampleModel用作原型。

SampleModel - Class in java.awt.image

这个抽象类定义了一个用于提取图像中像素样本的接口。

SampleModel(int, int, int, int) - Constructor for class java.awt.image. SampleModel

使用指定的参数构造一个SampleModel。

sampleModelTranslateX - Variable in class java.awt.image. Raster

从Raster的SampleModel的坐标空间到光栅的X平移。

sampleModelTranslateY - Variable in class java.awt.image. Raster

从Raster的SampleModel的坐标空间到栅格的坐标空间的Y翻译。

sampleRate - Variable in class javax.sound.sampled. AudioFormat

每秒播放或录制的样本数，具有这种格式的声音。

sampleSizeInBits - Variable in class javax.sound.sampled. AudioFormat

具有此格式的声音的每个样本中的位数。

SANDYBROWN - Static variable in class javafx.scene.paint. Color

颜色沙棕色，RGB值为＃F4A460

SANS_SERIF - Static variable in class java.awt. Font

逻辑字体“SansSerif”的规范系列名称的字符串常量。

Sasl - Class in javax.security.sasl

用于创建SASL客户端和服务器的静态类。

SaslClient - Interface in javax.security.sasl

执行SASL身份验证作为客户端。

SaslClientFactory - Interface in javax.security.sasl

用于创建 SaslClient实例的 SaslClient 。

SaslException - Exception in javax.security.sasl

此类表示使用SASL时发生的错误。

SaslException() - Constructor for exception javax.security.sasl. SaslException

构造一个新的实例 SaslException 。

SaslException(String) - Constructor for exception javax.security.sasl. SaslException

构造一个新的实例 SaslException与详细的消息。

SaslException(String, Throwable) - Constructor for exception javax.security.sasl. SaslException

构造一个新的实例 SaslException其中包含详细的消息和根异常。

SaslServer - Interface in javax.security.sasl

执行SASL身份验证作为服务器。

SaslServerFactory - Interface in javax.security.sasl

用于创建 SaslServer实例的 SaslServer 。

saturate() - Method in class javafx.scene.paint. Color

创建一个这个颜色的更饱和版本的新颜色。

SATURATION_HIGH - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

新新200的X- 200 X- 200 200 X- 200 200：

SATURATION_LOW - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

新新200的X- 200 X- 200 200 X- 200 200：

SATURATION_NORMAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

新新200的X- 200 X- 200 200 X- 200 200：

saturationProperty() - Method in class javafx.scene.effect. ColorAdjust

饱和度调整值。

SATURDAY - java.time. DayOfWeek

星期六的单日例子。

SATURDAY - Static variable in class java.util. Calendar

Calendar.DAY_OF_WEEK字段的值表示星期六。

SAURASHTRA - java.awt.font. NumericShaper.Range

Saurashtra系列与Saurashtra数字。

SAURASHTRA - java.lang. Character.UnicodeScript

Unicode脚本“Saurashtra”。

SAURASHTRA - Static variable in class java.lang. Character.UnicodeBlock

“Saurashtra”Unicode字符块的常量。

save() - Method in class javafx.scene.canvas. GraphicsContext

将以下属性保存到堆栈中。

save(ObjectOutputStream, String, EventListener) - Static method in class java.awt. AWTEventMulticaster

将可序列化的监听器链保存到序列化流。

save(OutputStream, String) - Method in class java.util. Properties

已过时。
如果在保存属性列表时发生I / O错误，此方法不会抛出IOException。 保存属性列表的首选方法是通过store(OutputStream out, String comments)方法或storeToXML(OutputStream os, String comment)方法。

SAVE - Static variable in class java.awt. FileDialog

该常量值表示文件对话窗口的目的是找到要写入的文件。

SAVE_DIALOG - Static variable in class javax.swing. JFileChooser

键入值，表示 JFileChooser支持“保存”文件操作。

SAVE_FILE - Static variable in class java.awt. Event

已过时。

文件保存事件。

saveAsFileDialog(String, String[], FileContents) - Method in interface javax.jnlp. FileSaveService

要求用户保存文件。

saveButtonMnemonic - Variable in class javax.swing.plaf.basic. BasicFileChooserUI

保存按钮助记符

saveButtonText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI

保存按钮文字

saveButtonToolTipText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI

保存按钮工具提示文本

saveChanges() - Method in class javax.xml.soap. SOAPMessage

更新此 SOAPMessage对象，并对其进行了所有更改。

saveComposedText(int) - Method in class javax.swing.text. JTextComponent

将文字保存在指定的位置周围。

saveFileDialog(String, String[], InputStream, String) - Method in interface javax.jnlp. FileSaveService

要求用户保存文件。

saveInternal(ObjectOutputStream, String) - Method in class java.awt. AWTEventMulticaster

序列化支持。

Savepoint - Interface in java.sql

保存点的表示，它是当前事务中可以从 Connection.rollback方法引用的一个点。

saveRequired() - Method in class javax.xml.soap. SOAPMessage

指示这个 SOAPMessage对象是否需要调用方法 saveChanges 。

SAXException - Exception in org.xml.sax

封装一般的SAX错误或警告。

SAXException() - Constructor for exception org.xml.sax. SAXException

创建一个新的SAXException。

SAXException(Exception) - Constructor for exception org.xml.sax. SAXException

创建一个包含现有异常的新SAXException。

SAXException(String) - Constructor for exception org.xml.sax. SAXException

创建一个新的SAXException。

SAXException(String, Exception) - Constructor for exception org.xml.sax. SAXException

从现有异常创建新的SAXException。

SAXNotRecognizedException - Exception in org.xml.sax

无法识别的标识符的异常类。

SAXNotRecognizedException() - Constructor for exception org.xml.sax. SAXNotRecognizedException

默认构造函数。

SAXNotRecognizedException(String) - Constructor for exception org.xml.sax. SAXNotRecognizedException

使用给定的消息构造一个新的异常。

SAXNotSupportedException - Exception in org.xml.sax

不受支持的操作的异常类。

SAXNotSupportedException() - Constructor for exception org.xml.sax. SAXNotSupportedException

构造一个没有消息的新异常。

SAXNotSupportedException(String) - Constructor for exception org.xml.sax. SAXNotSupportedException

使用给定的消息构造一个新的异常。

SAXParseException - Exception in org.xml.sax

封装XML解析错误或警告。

SAXParseException(String, String, String, int, int) - Constructor for exception org.xml.sax. SAXParseException

创建一个新的SAXParseException。

SAXParseException(String, String, String, int, int, Exception) - Constructor for exception org.xml.sax. SAXParseException

创建一个新的SAXParseException与嵌入式异常。

SAXParseException(String, Locator) - Constructor for exception org.xml.sax. SAXParseException

从消息和定位器创建新的SAXParseException。

SAXParseException(String, Locator, Exception) - Constructor for exception org.xml.sax. SAXParseException

在SAXParseException中包装一个现有的异常。

SAXParser - Class in javax.xml.parsers

定义包装XMLReader实现类的API。

SAXParser() - Constructor for class javax.xml.parsers. SAXParser

受保护的构造函数以防止实例化。

SAXParserFactory - Class in javax.xml.parsers

定义工厂API，使应用程序能够配置和获取基于SAX的解析器来解析XML文档。

SAXParserFactory() - Constructor for class javax.xml.parsers. SAXParserFactory

受保护的构造函数强制使用 SAXParserFactory.newInstance() 。

SAXResult - Class in javax.xml.transform.sax

作为转型结果的持有人。

SAXResult() - Constructor for class javax.xml.transform.sax. SAXResult

零参数默认构造函数。

SAXResult(ContentHandler) - Constructor for class javax.xml.transform.sax. SAXResult

创建一个针对SAX2的SAXResult ContentHandler 。

SAXSource - Class in javax.xml.transform.sax

作为SAX风格来源的持有人。

SAXSource() - Constructor for class javax.xml.transform.sax. SAXSource

零参数默认构造函数。

SAXSource(InputSource) - Constructor for class javax.xml.transform.sax. SAXSource

创建一个 SAXSource ，使用SAX InputSource 。

SAXSource(XMLReader, InputSource) - Constructor for class javax.xml.transform.sax. SAXSource

创建一个SAXSource ，使用一个XMLReader和一个SAX InputSource。

SAXTransformerFactory - Class in javax.xml.transform.sax

此类扩展TransformerFactory以提供SAX特定的工厂方法。

SAXTransformerFactory() - Constructor for class javax.xml.transform.sax. SAXTransformerFactory

默认构造函数是有意保护的。

SC_BLOCK_DATA - Static variable in interface java.io. ObjectStreamConstants

ObjectStreamClass标志的位掩码。

SC_ENUM - Static variable in interface java.io. ObjectStreamConstants

ObjectStreamClass标志的位掩码。

SC_EXTERNALIZABLE - Static variable in interface java.io. ObjectStreamConstants

ObjectStreamClass标志的位掩码。

SC_SERIALIZABLE - Static variable in interface java.io. ObjectStreamConstants

ObjectStreamClass标志的位掩码。

SC_WRITE_METHOD - Static variable in interface java.io. ObjectStreamConstants

ObjectStreamClass标志的位掩码。

scalb(double, int) - Static method in class java.lang. Math

返回 d 2 scaleFactor舍入，如同通过单个正确四舍五入的浮点乘以双重值集合的成员执行的。

scalb(double, int) - Static method in class java.lang. StrictMath

返回 d 2 scaleFactor舍入，如同由一个正确四舍五入的浮点数乘以双重值集合的成员一样。

scalb(float, int) - Static method in class java.lang. Math

返回 f 2 scaleFactor舍入，如同由一个正确四舍五入的浮点数乘以浮点值集合的成员执行的。

scalb(float, int) - Static method in class java.lang. StrictMath

返回 f 2 scaleFactor四舍五入，就像一个正确圆形的浮点数乘以浮点值集合的成员一样。

scale() - Method in class java.math. BigDecimal

返回此 BigDecimal的 比例 。

scale(double, double) - Method in class java.awt.geom. AffineTransform

使用缩放变换连接此变换。

scale(double, double) - Method in class java.awt. Graphics2D

使用缩放变换连接当前的 Graphics2D Transform根据指定的缩放因子相对于之前的缩放比例调整后续渲染的大小。

scale(double, double) - Method in class javafx.scene.canvas. GraphicsContext

通过x，y来缩放当前的变换。

scale(double, double) - Static method in class javafx.scene.transform. Transform

返回表示缩放变换的 Scale对象。

scale(double, double, double, double) - Static method in class javafx.scene.transform. Transform

返回表示缩放变换的 Scale对象。

scale(Spring, float) - Static method in class javax.swing. Spring

返回一个弹簧，其 最小值 ， 优选 值 ， 最大值和 值属性是参数spring的属性的倍数， s 。

Scale - Class in javafx.scene.transform

该类表示一个 Affine对象，该对象根据指定的因素缩放坐标。

Scale() - Constructor for class javafx.scene.transform. Scale

创建一个默认的Scale（标识）。

Scale(double, double) - Constructor for class javafx.scene.transform. Scale

创建二维刻度。

Scale(double, double, double) - Constructor for class javafx.scene.transform. Scale

创建一个三维刻度。

Scale(double, double, double, double) - Constructor for class javafx.scene.transform. Scale

用枢轴创建二维刻度。

Scale(double, double, double, double, double, double) - Constructor for class javafx.scene.transform. Scale

用枢轴创建三维刻度。

SCALE - javafx.scene. CacheHint

提示说明位图缓存机制，如果节点放大或缩小，可以通过缩放缓存的位图（而不是重新渲染节点）来绘制它。

SCALE_AND_ROTATE - javafx.scene. CacheHint

提示说明位图缓存机制，如果节点被缩放和/或旋转，可以通过缩放和/或旋转缓存的位图（而不是重新渲染节点）来绘制它。

SCALE_AREA_AVERAGING - Static variable in class java.awt. Image

使用区域平均图像缩放算法。

SCALE_DEFAULT - Static variable in class java.awt. Image

使用默认的图像缩放算法。

SCALE_FAST - Static variable in class java.awt. Image

选择一种图像缩放算法，比缩放图像的平滑度更高优先级。

SCALE_REPLICATE - Static variable in class java.awt. Image

使用 ReplicateScaleFilter类中体现的图像缩放算法。

SCALE_SMOOTH - Static variable in class java.awt. Image

选择一种图像缩放算法，其优先级高于图像平滑度，而不是缩放速度。

scaleByPowerOfTen(int) - Method in class java.math. BigDecimal

返回一个BigDecimal，其数值等于（ this * 10 n ）。

scaleProperty() - Method in class javafx.scene.chart. ValueAxis

从数据单位到视觉单位的比例因子

scaleShapeProperty() - Method in class javafx.scene.layout. Region

指定是否将形状（如果已定义）缩放以匹配“区域”的大小。

ScaleTransition - Class in javafx.animation

这个 Transition创建了一个尺度动画，涵盖其 ScaleTransition.duration 。

ScaleTransition() - Constructor for class javafx.animation. ScaleTransition

构造函数为 ScaleTransition

ScaleTransition(Duration) - Constructor for class javafx.animation. ScaleTransition

构造函数为 ScaleTransition

ScaleTransition(Duration, Node) - Constructor for class javafx.animation. ScaleTransition

构造函数为 ScaleTransition

scaleXProperty() - Method in class javafx.scene.effect. DisplacementMap

FloatMap中所有x坐标偏移值的比例因子相乘。

scaleXProperty() - Method in class javafx.scene. Node

定义坐标按照该 Node沿着X轴的对象中心进行缩放的因子。

scaleYProperty() - Method in class javafx.scene.effect. DisplacementMap

FloatMap中所有y坐标偏移值的比例因子相乘。

scaleYProperty() - Method in class javafx.scene. Node

定义坐标按照该 Node的Y轴对象对象中心进行比例的因子。

scaleZProperty() - Method in class javafx.scene. Node

定义坐标按照该 Node的Z轴的对象中心进行缩放的因子。

scan(DocTree, P) - Method in class com.sun.source.util. DocTreePathScanner

扫描单个节点。

scan(DocTree, P) - Method in class com.sun.source.util. DocTreeScanner

扫描单个节点。

scan(Tree, P) - Method in class com.sun.source.util. TreePathScanner

扫描单个节点。

scan(Tree, P) - Method in class com.sun.source.util. TreeScanner

扫描单个节点。

scan(DocTreePath, P) - Method in class com.sun.source.util. DocTreePathScanner

从树路径识别的位置扫描树。

scan(TreePath, P) - Method in class com.sun.source.util. TreePathScanner

从树路径识别的位置扫描树。

scan(Iterable<? extends DocTree>, P) - Method in class com.sun.source.util. DocTreeScanner

扫描一系列节点。

scan(Iterable<? extends Tree>, P) - Method in class com.sun.source.util. TreeScanner

扫描一系列节点。

scan(Iterable<? extends Element>, P) - Method in class javax.lang.model.util. ElementScanner6

迭代给定元素并调用每个元素 scan(Element, P) 。

scan(Element) - Method in class javax.lang.model.util. ElementScanner6

方便方法相当于 v.scan(e, null) 。

scan(Element, P) - Method in class javax.lang.model.util. ElementScanner6

通过调用e.accept(this, p)处理元素; 此方法可能被子类覆盖。

scanForPlugins() - Static method in class javax.imageio. ImageIO

扫描应用程序类路径上的插件，加载其服务提供者类，并为每个发现的服务提供者实例注册 IIORegistry 。

scanlineStride - Variable in class java.awt.image. ComponentSampleModel

由该ComponentSampleModel描述的图像数据区域的线条（在数据数组元素中）。

Scanner - Class in java.util

一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。

Scanner(File) - Constructor for class java.util. Scanner

构造新的 Scanner ，产生从指定文件扫描的值。

Scanner(File, String) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定文件扫描的值。

Scanner(InputStream) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定的输入流扫描的值。

Scanner(InputStream, String) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定的输入流扫描的值。

Scanner(Readable) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定源扫描的值。

Scanner(String) - Constructor for class java.util. Scanner

构造新的 Scanner ，产生从指定字符串扫描的值。

Scanner(ReadableByteChannel) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定通道扫描的值。

Scanner(ReadableByteChannel, String) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定通道扫描的值。

Scanner(Path) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定文件扫描的值。

Scanner(Path, String) - Constructor for class java.util. Scanner

构造一个新的 Scanner ，产生从指定文件扫描的值。

ScatterChart< X, Y> - Class in javafx.scene.chart

绘制一系列数据点符号的图表类型。

ScatterChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. ScatterChart

使用给定的轴和数据构造新的ScatterChart。

ScatterChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>) - Constructor for class javafx.scene.chart. ScatterChart

使用给定的轴和数据构造新的ScatterChart。

ScatteringByteChannel - Interface in java.nio.channels

可以将字节读入缓冲区序列的通道。

Scene - Class in javafx.scene

JavaFX Scene类是场景图中所有内容的容器。

Scene(Parent) - Constructor for class javafx.scene. Scene

为特定根节点创建场景。

Scene(Parent, double, double) - Constructor for class javafx.scene. Scene

为特定大小的特定根节点创建场景。

Scene(Parent, double, double, boolean) - Constructor for class javafx.scene. Scene

构造一个由根组成的场景，宽度和高度的尺寸，并指定是否为此场景创建深度缓冲区。

Scene(Parent, double, double, boolean, SceneAntialiasing) - Constructor for class javafx.scene. Scene

构造由根组成的场景，宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。

Scene(Parent, double, double, Paint) - Constructor for class javafx.scene. Scene

创建具有特定大小和填充的特定根节点的场景。

Scene(Parent, Paint) - Constructor for class javafx.scene. Scene

为具有填充的特定根节点创建场景。

SCENE - javafx.scene. AccessibleAttribute

返回节点的场景。

SCENE_CAPTURE_TYPE_LANDSCAPE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“SceneCaptureType”标签一起使用的值。

SCENE_CAPTURE_TYPE_NIGHT_SCENE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“SceneCaptureType”标签一起使用的值。

SCENE_CAPTURE_TYPE_PORTRAIT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“SceneCaptureType”标签一起使用的值。

SCENE_CAPTURE_TYPE_STANDARD - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“SceneCaptureType”标签一起使用的值。

SCENE_TYPE_DSC - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

要与“SceneType”标签一起使用的值。

SCENE3D - javafx.application. ConditionalFeature

表示3D在平台上可用。

SceneAntialiasing - Class in javafx.scene

JavaFX SceneAntialiasing类指定所需的抗锯齿级别。

sceneProperty() - Method in class javafx.scene. Node

这Node是这个Node的一部分。

sceneProperty() - Method in class javafx.stage. Window

Scene要呈现在这个 Window 。

sceneToLocal(double, double) - Method in class javafx.scene. Node

将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。

sceneToLocal(double, double, boolean) - Method in class javafx.scene. Node

将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。

sceneToLocal(double, double, double) - Method in class javafx.scene. Node

将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。

sceneToLocal(Bounds) - Method in class javafx.scene. Node

将矩形从场景的坐标空间转换为本地坐标空间 Node 。

sceneToLocal(Bounds, boolean) - Method in class javafx.scene. Node

将场景的坐标空间的边界转换成这个 Node的局部坐标空间。

sceneToLocal(Point2D) - Method in class javafx.scene. Node

将一个点从场景的坐标空间转换为该 Node的局部坐标空间。

sceneToLocal(Point2D, boolean) - Method in class javafx.scene. Node

将一个点从场景的坐标空间转换为该 Node的局部坐标空间。

sceneToLocal(Point3D) - Method in class javafx.scene. Node

将一个点从场景的坐标空间转换为这个 Node的局部坐标空间。

schedule(Runnable, long, TimeUnit) - Method in interface java.util.concurrent. ScheduledExecutorService

创建并执行在给定延迟后启用的单次操作。

schedule(Runnable, long, TimeUnit) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

schedule(Callable<V>, long, TimeUnit) - Method in interface java.util.concurrent. ScheduledExecutorService

创建并执行在给定延迟后启用的ScheduledFuture。

schedule(Callable<V>, long, TimeUnit) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

schedule(TimerTask, long) - Method in class java.util. Timer

在指定的延迟之后安排指定的任务执行。

schedule(TimerTask, long, long) - Method in class java.util. Timer

在指定 的延迟之后开始，重新 执行固定延迟执行的指定任务。

schedule(TimerTask, Date) - Method in class java.util. Timer

在指定的时间安排指定的任务执行。

schedule(TimerTask, Date, long) - Method in class java.util. Timer

从指定的时间开始，对指定的任务执行重复的 固定延迟执行 。

scheduleAtFixedRate(Runnable, long, long, TimeUnit) - Method in interface java.util.concurrent. ScheduledExecutorService

创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 也就是说，执行将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。

scheduleAtFixedRate(Runnable, long, long, TimeUnit) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

scheduleAtFixedRate(TimerTask, long, long) - Method in class java.util. Timer

在指定的延迟之后开始，重新 执行固定速率的指定任务。

scheduleAtFixedRate(TimerTask, Date, long) - Method in class java.util. Timer

从指定的时间开始，对指定的任务执行重复的 固定速率执行 。

scheduled() - Method in class javafx.concurrent. Service

每当该服务的状态已转换到SCHEDULED状态时调用的子类的受保护的便利方法。

scheduled() - Method in class javafx.concurrent. Task

每当任务的状态已经转换到SCHEDULED状态时调用的子类的受保护的便利方法。

SCHEDULED - javafx.concurrent. Worker.State

表示工作人员已被安排执行，但它当前没有运行。

scheduledExecutionTime() - Method in class java.util. TimerTask

返回此任务最近 实际执行的 预定执行时间。

ScheduledExecutorService - Interface in java.util.concurrent

一个ExecutorService ，可以调度命令在给定的延迟之后运行，或定期执行。

ScheduledFuture< V> - Interface in java.util.concurrent

可以取消延迟结果的行动。

ScheduledService< V> - Class in javafx.concurrent

ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下，即使发生故障也将重新启动。

ScheduledService() - Constructor for class javafx.concurrent. ScheduledService

ScheduledThreadPoolExecutor - Class in java.util.concurrent

A ThreadPoolExecutor可以额外地调度命令在给定的延迟之后运行或定期执行。

ScheduledThreadPoolExecutor(int) - Constructor for class java.util.concurrent. ScheduledThreadPoolExecutor

创建一个新的 ScheduledThreadPoolExecutor与给定的核心池大小。

ScheduledThreadPoolExecutor(int, RejectedExecutionHandler) - Constructor for class java.util.concurrent. ScheduledThreadPoolExecutor

用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。

ScheduledThreadPoolExecutor(int, ThreadFactory) - Constructor for class java.util.concurrent. ScheduledThreadPoolExecutor

使用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。

ScheduledThreadPoolExecutor(int, ThreadFactory, RejectedExecutionHandler) - Constructor for class java.util.concurrent. ScheduledThreadPoolExecutor

用给定的初始参数创建一个新的 ScheduledThreadPoolExecutor 。

scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - Method in interface java.util.concurrent. ScheduledExecutorService

创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。

scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

Schema - Class in javax.xml.validation

不可变的内存中的语法表示。

Schema() - Constructor for class javax.xml.validation. Schema

派生类的构造方法

SCHEMA_SYSTEM_ID - Static variable in interface javax.sql.rowset. WebRowSet

用于定义XML标签的XML模式定义文件的URL及其对于 WebRowSet实现的 WebRowSet 。

SchemaFactory - Class in javax.xml.validation

工厂创建Schema个对象。

SchemaFactory() - Constructor for class javax.xml.validation. SchemaFactory

派生类的构造方法

SchemaFactoryConfigurationError - Error in javax.xml.validation

当存在具有Schema工厂的配置问题时抛出。

SchemaFactoryConfigurationError() - Constructor for error javax.xml.validation. SchemaFactoryConfigurationError

创建一个新的 SchemaFactoryConfigurationError没有详细消息。

SchemaFactoryConfigurationError(String) - Constructor for error javax.xml.validation. SchemaFactoryConfigurationError

创建一个新的 SchemaFactoryConfigurationError ，其中 String指定为错误消息。

SchemaFactoryConfigurationError(String, Throwable) - Constructor for error javax.xml.validation. SchemaFactoryConfigurationError

创建一个新的 SchemaFactoryConfigurationError与给定的 Throwable基本原因和详细信息。

SchemaFactoryConfigurationError(Throwable) - Constructor for error javax.xml.validation. SchemaFactoryConfigurationError

创建一个新的 SchemaFactoryConfigurationError与给定的 Throwable基础原因。

SchemaFactoryLoader - Class in javax.xml.validation

工厂创建SchemaFactory 。

SchemaFactoryLoader() - Constructor for class javax.xml.validation. SchemaFactoryLoader

一个do-nothing构造函数。

SchemaOutputResolver - Class in javax.xml.bind

控制JAXB实现放置生成架构文件的位置。

SchemaOutputResolver() - Constructor for class javax.xml.bind. SchemaOutputResolver

SchemaViolationException - Exception in javax.naming.directory

当某种方法违反模式时，抛出此异常。

SchemaViolationException() - Constructor for exception javax.naming.directory. SchemaViolationException

构造一个新的SchemaViolationException实例。

SchemaViolationException(String) - Constructor for exception javax.naming.directory. SchemaViolationException

使用提供的说明构造一个新的SchemaViolationException实例。

SCIENTIFIC - java.util. Formatter.BigDecimalLayoutForm

格式化计算机科学符号 BigDecimal 。

scope - Variable in class javax.xml.bind. JAXBElement

表示此xml元素实例的xml元素声明的范围。

Scope - Interface in com.sun.source.tree

用于确定本地可用的程序元素的接口，如局部变量和导入。

Screen - Class in javafx.stage

描述诸如监视器之类的图形目的地的特征。

SCREEN - javafx.scene.effect. BlendMode

来自两个输入的颜色分量被反转，彼此相乘，并且该结果再次被反转以产生所得到的颜色。

screenAboutToSleep(ScreenSleepEvent) - Method in interface java.awt.desktop. ScreenSleepListener

当系统显示进入省电睡眠时调用。

screenAwoke(ScreenSleepEvent) - Method in interface java.awt.desktop. ScreenSleepListener

当系统显示已经从省电睡眠唤醒时调用。

ScreenSleepEvent - Class in java.awt.desktop

当系统显示器进入并退出省电睡眠时发送事件。

ScreenSleepEvent() - Constructor for class java.awt.desktop. ScreenSleepEvent

构造一个ScreenSleepEvent

ScreenSleepListener - Interface in java.awt.desktop

当连接到系统的显示器进入省电睡眠时，实施者会收到通知。

screenToLocal(double, double) - Method in class javafx.scene. Node

将来自该坐标空间中的点Screen这个局部坐标空间Node 。

screenToLocal(Bounds) - Method in class javafx.scene. Node

将矩形从Screen的坐标空间转换为此Node的本地坐标空间。

screenToLocal(Point2D) - Method in class javafx.scene. Node

将来自该坐标空间中的点Screen这个局部坐标空间Node 。

SCRIPT - Static variable in class javax.swing.text.html. HTML.Tag

标记<script>

SCRIPT_CHARSET_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader

<fx：script>'charset'属性。

SCRIPT_SOURCE_ATTRIBUTE - Static variable in class javafx.fxml. FXMLLoader

<fx：script>'source'属性。

SCRIPT_TAG - Static variable in class javafx.fxml. FXMLLoader

标签名称为<fx：script>。

ScriptContext - Interface in javax.script

该接口的实现类用于将脚本引擎与对象（如作用域绑定）连接在托管应用程序中。

ScriptEngine - Interface in javax.script

ScriptEngine是基本接口，其方法必须在本规范的每个实现中都具有完整的功能。

ScriptEngineFactory - Interface in javax.script

ScriptEngineFactory用于描述和实例化 ScriptEngines 。

ScriptEngineManager - Class in javax.script

ScriptEngineManager实现了一个 ScriptEngine类的发现和实例化机制，并且还维护一组存储由管理器创建的所有引擎共享的状态的键/值对。

ScriptEngineManager() - Constructor for class javax.script. ScriptEngineManager

调用此构造函数的效果与调用 ScriptEngineManager(Thread.currentThread().getContextClassLoader())相同。

ScriptEngineManager(ClassLoader) - Constructor for class javax.script. ScriptEngineManager

这个构造函数加载的实现ScriptEngineFactory可见给定ClassLoader ，以业务提供机制。

如果装载机为null ，则会加载与平台捆绑在一起的脚本引擎工厂。

ScriptException - Exception in javax.script

脚本API的通用 异常类。

ScriptException(Exception) - Constructor for exception javax.script. ScriptException

创建一个 ScriptException包装底层解释器抛出的一个 异常 。

ScriptException(String) - Constructor for exception javax.script. ScriptException

创建一个要在其消息中使用的字符串的 ScriptException 。

ScriptException(String, String, int) - Constructor for exception javax.script. ScriptException

创建一个 ScriptException其中包含消息，文件名和 ScriptException以用于错误消息。

ScriptException(String, String, int, int) - Constructor for exception javax.script. ScriptException

ScriptException构造函数指定消息，文件名，行号和列号。

ScriptObjectMirror - Class in jdk.nashorn.api.scripting

包含给定Nashorn Script对象的镜像对象。

ScriptUtils - Class in jdk.nashorn.api.scripting

要从脚本代码调用的实用程序。

SCROLL - Static variable in class javafx.scene.input. ScrollEvent

当用户执行滚动操作（例如旋转鼠标滚轮或在触摸屏上拖动手指）时，会发生此事件。

SCROLL_ABSOLUTE - Static variable in class java.awt. Event

已过时。

用户已将气泡（拇指）移动到滚动条中，移动到“绝对”位置，而不是从最后位置偏移。

SCROLL_BAR - javafx.scene. AccessibleRole

滚动栏角色。

SCROLL_BAR - Static variable in class javax.accessibility. AccessibleRole

通常用于允许用户递增地查看大量数据的对象。

SCROLL_BAR - Static variable in class javax.swing.plaf.synth. Region

ScrollBar区域。

SCROLL_BAR_THUMB - Static variable in class javax.swing.plaf.synth. Region

ScrollBar的拇指。

SCROLL_BAR_TRACK - Static variable in class javax.swing.plaf.synth. Region

TrackBar的轨迹。

SCROLL_BEGIN - Static variable in class java.awt. Event

已过时。

滚动开始事件。

SCROLL_DOWN - Static variable in class javax.swing.plaf.basic. BasicComboPopup

向下滚动的方向

SCROLL_END - Static variable in class java.awt. Event

已过时。

滚动结束事件。

SCROLL_FINISHED - Static variable in class javafx.scene.input. ScrollEvent

当滚动手势结束时，会发生此事件。

SCROLL_LINE_DOWN - Static variable in class java.awt. Event

已过时。

用户已经激活了一个滚动条的 下拉区域。

SCROLL_LINE_UP - Static variable in class java.awt. Event

已过时。

用户激活了滚动条的 排列区域。

SCROLL_LOCK - javafx.scene.input. KeyCode

常数为 Scroll Lock键。

SCROLL_LOCK - Static variable in class java.awt. Event

已过时。

滚动锁定键，非ASCII操作键。

SCROLL_PAGE_DOWN - Static variable in class java.awt. Event

已过时。

用户激活滚动条的 向下翻页区域。

SCROLL_PAGE_UP - Static variable in class java.awt. Event

已过时。

用户已经激活了滚动条的 页面向上区域。

SCROLL_PANE - javafx.scene. AccessibleRole

滚动窗格角色。

SCROLL_PANE - Static variable in class javax.accessibility. AccessibleRole

允许用户逐步查看大量信息的对象。

SCROLL_PANE - Static variable in class javax.swing.plaf.synth. Region

ScrollPane区域。

SCROLL_STARTED - Static variable in class javafx.scene.input. ScrollEvent

当检测到滚动手势时，会发生此事件。

SCROLL_TAB_LAYOUT - Static variable in class javax.swing. JTabbedPane

选项卡布局策略，用于在所有选项卡不适合单个运行时提供可用选项卡的子集。

SCROLL_UP - Static variable in class javax.swing.plaf.basic. BasicComboPopup

滚动方向。

Scrollable - Interface in javax.swing

向JScrollPane等滚动容器提供信息的界面。

scrollbar - Static variable in class java.awt. SystemColor

呈现为滚动条背景的颜色。

scrollbar - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

滚动条

scrollBar - Variable in class javax.swing.plaf.basic. BasicTreeUI.ComponentHandler

正在调整的ScrollBar。

Scrollbar - Class in java.awt

Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。

Scrollbar() - Constructor for class java.awt. Scrollbar

构造一个新的垂直滚动条。

Scrollbar(int) - Constructor for class java.awt. Scrollbar

构造具有指定方向的新滚动条。

Scrollbar(int, int, int, int, int) - Constructor for class java.awt. Scrollbar

构造具有指定方向，初始值，可见量以及最小值和最大值的新滚动条。

ScrollBar - Class in javafx.scene.control

具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。

ScrollBar() - Constructor for class javafx.scene.control. ScrollBar

创建一个新的水平ScrollBar（即getOrientation（）== Orientation.HORIZONTAL）。

ScrollBar(int) - Constructor for class javax.swing. JScrollPane.ScrollBar

用指定的方向创建一个滚动条。

SCROLLBAR - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.scrollbar系统颜色。

Scrollbar.AccessibleAWTScrollBar - Class in java.awt

该类为 Scrollbar类实现可访问性支持。

SCROLLBARS_ALWAYS - Static variable in class java.awt. ScrollPane

指定水平/垂直滚动条应始终显示，而不管滚动条和子对象的大小如何。

SCROLLBARS_AS_NEEDED - Static variable in class java.awt. ScrollPane

指定仅当小孩的大小超过水平/垂直维度中滚动窗口的大小时才应显示水平/垂直滚动条。

SCROLLBARS_BOTH - Static variable in class java.awt. TextArea

创建并显示垂直和水平滚动条。

SCROLLBARS_HORIZONTAL_ONLY - Static variable in class java.awt. TextArea

仅创建并显示水平滚动条。

SCROLLBARS_NEVER - Static variable in class java.awt. ScrollPane

指定水平/垂直滚动条不应该显示，而不管滚动条和子的相应大小。

SCROLLBARS_NONE - Static variable in class java.awt. TextArea

不要为文本区域创建或显示任何滚动条。

SCROLLBARS_VERTICAL_ONLY - Static variable in class java.awt. TextArea

仅创建并显示垂直滚动条。

ScrollBarSkin - Class in javafx.scene.control.skin

默认皮肤实现为ScrollBar控件。

ScrollBarSkin(ScrollBar) - Constructor for class javafx.scene.control.skin. ScrollBarSkin

创建一个新的ScrollBarSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

ScrollBarUI - Class in javax.swing.plaf

JScrollBar可插拔的外观和界面。

ScrollBarUI() - Constructor for class javax.swing.plaf. ScrollBarUI

scrollBarWidth - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

提示什么宽度（垂直）或高度（水平时）应该是什么。

scrollBarWidth - Variable in class javax.swing.plaf.metal. MetalScrollBarUI

滚动条的宽度。

scrollByBlock(int) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

逐块滚动

scrollByBlock(int) - Method in class javax.swing.plaf.basic. BasicSliderUI

逐块滚动

scrollByUnit(int) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

按单位滚动

scrollByUnit(int) - Method in class javax.swing.plaf.basic. BasicSliderUI

按单位滚动

scrollCharacterToVisible(int) - Method in class javafx.scene.control.skin. TextAreaSkin

确保给定索引处的字符是可见的。

scrollCharacterToVisible(int) - Method in class javafx.scene.control.skin. TextInputControlSkin

确保给定索引处的字符是可见的。

scrollDirection - Variable in class javax.swing.plaf.basic. BasicComboPopup

滚动方向。

scrollDueToClickInTrack(int) - Method in class javax.swing.plaf.basic. BasicSliderUI

当在轨道中检测到mousePressed时，而不是在缩略图中调用此函数。

scrollDueToClickInTrack(int) - Method in class javax.swing.plaf.metal. MetalSliderUI

scroller - Variable in class javax.swing.plaf.basic. BasicComboPopup

此保护字段是实现特定的。

ScrollEvent - Class in javafx.scene.input

滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。

ScrollEvent(Object, EventTarget, EventType<ScrollEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, double, double, double, double, ScrollEvent.HorizontalTextScrollUnits, double, ScrollEvent.VerticalTextScrollUnits, double, int, PickResult) - Constructor for class javafx.scene.input. ScrollEvent

构造新的ScrollEvent事件。

ScrollEvent(EventType<ScrollEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, double, double, double, double, double, double, ScrollEvent.HorizontalTextScrollUnits, double, ScrollEvent.VerticalTextScrollUnits, double, int, PickResult) - Constructor for class javafx.scene.input. ScrollEvent

构造具有null源和目标的新的ScrollEvent事件

ScrollEvent(EventType<ScrollEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, double, double, double, double, ScrollEvent.HorizontalTextScrollUnits, double, ScrollEvent.VerticalTextScrollUnits, double, int, PickResult) - Constructor for class javafx.scene.input. ScrollEvent

构造具有null源和目标的新的ScrollEvent事件

ScrollEvent.HorizontalTextScrollUnits - Enum in javafx.scene.input

水平文本滚动单元。

ScrollEvent.VerticalTextScrollUnits - Enum in javafx.scene.input

垂直的基于文本的滚动单元。

SCROLLING - Static variable in class javax.swing.text.html. HTML.Attribute

属性“滚动”

scrollLeftProperty() - Method in class javafx.scene.control. TextArea

内容水平滚动的像素数。

scrollListener - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

滚动侦听器

scrollListener - Variable in class javax.swing.plaf.basic. BasicSliderUI

滚动侦听器

ScrollListener() - Constructor for class javax.swing.plaf.basic. BasicScrollBarUI.ScrollListener

构造一个 ScrollListener 。

ScrollListener() - Constructor for class javax.swing.plaf.basic. BasicSliderUI.ScrollListener

构造一个 ScrollListener

ScrollListener(int, boolean) - Constructor for class javax.swing.plaf.basic. BasicScrollBarUI.ScrollListener

构造一个 ScrollListener 。

ScrollListener(int, boolean) - Constructor for class javax.swing.plaf.basic. BasicSliderUI.ScrollListener

构造一个 ScrollListener

scrollpane - Variable in class javax.swing.plaf.basic. BasicScrollPaneUI

实例 JScrollPane 。

ScrollPane - Class in java.awt

一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。

ScrollPane - Class in javafx.scene.control

提供其内容的滚动，剪切视口的控件。

ScrollPane() - Constructor for class java.awt. ScrollPane

创建一个滚动条显示策略为“根据需要”的新的滚动容器。

ScrollPane() - Constructor for class javafx.scene.control. ScrollPane

创建一个新的ScrollPane。

ScrollPane(int) - Constructor for class java.awt. ScrollPane

创建一个新的scrollpane容器。

ScrollPane(Node) - Constructor for class javafx.scene.control. ScrollPane

创建一个新的ScrollPane。

ScrollPane.AccessibleAWTScrollPane - Class in java.awt

这个类实现 ScrollPane类的可访问性支持。

ScrollPane.ScrollBarPolicy - Enum in javafx.scene.control

表示可滚动控件在决定是否显示滚动条时使用的策略的枚举。

ScrollPaneAdjustable - Class in java.awt

该类表示 ScrollPane的水平或垂直滚动条的 ScrollPane 。

ScrollPaneBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.ScrollPaneBorder

ScrollPaneConstants - Interface in javax.swing

与JScrollPane组件一起使用的常量。

ScrollPaneLayout - Class in javax.swing

由 JScrollPane使用的布局管理器。

ScrollPaneLayout() - Constructor for class javax.swing. ScrollPaneLayout

ScrollPaneLayout.UIResource - Class in javax.swing

UI资源版本为 ScrollPaneLayout 。

ScrollPaneSkin - Class in javafx.scene.control.skin

默认皮肤实现为ScrollPane控件。

ScrollPaneSkin(ScrollPane) - Constructor for class javafx.scene.control.skin. ScrollPaneSkin

创建一个新的ScrollPaneSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

ScrollPaneUI - Class in javax.swing.plaf

JScrollPane可插拔的外观和界面。

ScrollPaneUI() - Constructor for class javax.swing.plaf. ScrollPaneUI

scrollPathToVisible(TreePath) - Method in class javax.swing. JTree

确保路径中的所有路径组件都已扩展（除了最后一个路径组件）并滚动，以便显示由路径标识的节点。

scrollPixels(double) - Method in class javafx.scene.control.skin. VirtualFlow

给定一个代表像素数的增量值，该方法试图在给定的方向上移动VirtualFlow（正向下/向右，负向上/向左）给定的像素数。

scrollRectToVisible(Rectangle) - Method in class javax.swing. JComponent

向 JComponent的父母转发 scrollRectToVisible()消息。

scrollRectToVisible(Rectangle) - Method in class javax.swing. JTextField

向左或向右滚动字段。

scrollRectToVisible(Rectangle) - Method in class javax.swing. JViewport

滚动视图，使视图内的 Rectangle变得可见。

scrollRowToVisible(int) - Method in class javax.swing. JTree

滚动由行标识的项目，直到显示。

SCROLLS_ON_EXPAND_PROPERTY - Static variable in class javax.swing. JTree

绑定属性名称为 scrollsOnExpand 。

scrollsOnExpand - Variable in class javax.swing. JTree

如果为true，当节点被展开时，许多后代被滚动以便可见。

scrollTimer - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

滚动定时器

scrollTimer - Variable in class javax.swing.plaf.basic. BasicSliderUI

滚动定时器

scrollTo(int) - Method in class javafx.scene.control. ListView

滚动ListView，使给定索引中的项目对最终用户可见。

scrollTo(int) - Method in class javafx.scene.control.skin. VirtualFlow

调整单元格，使给定索引中的单元格在视口中完全可见。

scrollTo(int) - Method in class javafx.scene.control. TableView

滚动TableView，使给定索引在视口内可见。

scrollTo(int) - Method in class javafx.scene.control. TreeTableView

滚动TreeTableView，使给定索引中的项目对最终用户可见。

scrollTo(int) - Method in class javafx.scene.control. TreeView

滚动TreeView，使给定索引中的项目对最终用户可见。

scrollTo(S) - Method in class javafx.scene.control. TableView

滚动TableView，使给定对象在视口内可见。

scrollTo(T) - Method in class javafx.scene.control. ListView

滚动ListView，使给定对象在视口内可见。

scrollTo(T) - Method in class javafx.scene.control.skin. VirtualFlow

调整单元格，使所选单元格在视口中完全可见（但仅仅）。

scrollToBottom(T) - Method in class javafx.scene.control.skin. VirtualFlow

调整单元格的位置，使指定的单元格位于视口的末端。

scrollToColumn() - Static method in class javafx.scene.control. ScrollToEvent

如果用户请求滚动一个TableColumnBase （即

scrollToColumn(TableColumn<S, ?>) - Method in class javafx.scene.control. TableView

滚动TableView，使给定的列在视口内可见。

scrollToColumn(TreeTableColumn<S, ?>) - Method in class javafx.scene.control. TreeTableView

滚动TreeTableView，使给定的列在视口内可见。

scrollToColumnIndex(int) - Method in class javafx.scene.control. TableView

滚动TableView，使给定索引在视口内可见。

scrollToColumnIndex(int) - Method in class javafx.scene.control. TreeTableView

滚动TreeTableView，使给定的索引在视口内可见。

ScrollToEvent< T> - Class in javafx.scene.control

事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。

ScrollToEvent(Object, EventTarget, EventType<ScrollToEvent<T>>, T) - Constructor for class javafx.scene.control. ScrollToEvent

使用指定的事件源，目标和类型构造新的 Event 。

scrollTopProperty() - Method in class javafx.scene.control. TextArea

垂直滚动内容的像素数。

scrollToReference(String) - Method in class javax.swing. JEditorPane

将视图滚动到给定的参考位置（即，正在显示的URL的 URL.getRef方法返回的值）。

scrollToTop(int) - Method in class javafx.scene.control.skin. VirtualFlow

调整单元格，使给定索引中的单元格在视口中完全可见，并位于视口的最顶端。

scrollToTop(T) - Method in class javafx.scene.control.skin. VirtualFlow

调整单元格的位置，使指定的单元格位于视口的开头。

scrollToTopIndex() - Static method in class javafx.scene.control. ScrollToEvent

如果用户请求将给定索引滚动到视图中，则会发生此事件。

scrollUnderway - Variable in class javax.swing. JViewport

scrollUnderway标志用于 JList等 JList 。

SCTP_DISABLE_FRAGMENTS - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

启用或禁用消息碎片。

SCTP_EXPLICIT_COMPLETE - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

启用或禁用显式消息完成。

SCTP_FRAGMENT_INTERLEAVE - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

分段交错控制消息接收器的消息呈现方式。

SCTP_INIT_MAXSTREAMS - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

关联初始化期间本地端点请求的最大流数。

SCTP_NODELAY - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

启用或禁用类似Nagle的算法。

SCTP_PRIMARY_ADDR - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

请求本地SCTP堆栈使用给定对等体地址作为关联主节点。

SCTP_SET_PEER_PRIMARY_ADDR - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

请求对等方将附带的地址标记为关联主。

SctpChannel - Class in com.sun.nio.sctp

用于面向消息的连接SCTP套接字的可选通道。

SctpChannel(SelectorProvider) - Constructor for class com.sun.nio.sctp. SctpChannel

初始化此类的新实例。

SctpMultiChannel - Class in com.sun.nio.sctp

用于面向消息的SCTP套接字的可选通道。

SctpMultiChannel(SelectorProvider) - Constructor for class com.sun.nio.sctp. SctpMultiChannel

初始化此类的新实例。

SctpServerChannel - Class in com.sun.nio.sctp

用于面向消息的侦听SCTP插座的可选通道。

SctpServerChannel(SelectorProvider) - Constructor for class com.sun.nio.sctp. SctpServerChannel

初始化此类的新实例。

SctpSocketOption< T> - Interface in com.sun.nio.sctp

与SCTP通道相关联的插座选项。

SctpStandardSocketOptions - Class in com.sun.nio.sctp

SCTP通道支持此类定义的套接字选项（以及特定通道类中列出的套接字选项），并且可以支持额外的实现特定套接字选项。

SctpStandardSocketOptions.InitMaxStreams - Class in com.sun.nio.sctp

此类用于设置关联初始化期间本地端点使用的入站/出站流的最大数量。

SDATA - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于SDATA

SE_RESIZE - Static variable in class javafx.scene. Cursor

东南大小的光标类型。

SE_RESIZE_CURSOR - Static variable in class java.awt. Cursor

东南大小的光标类型。

SE_RESIZE_CURSOR - Static variable in class java.awt. Frame

已过时。
替换为Cursor.SE_RESIZE_CURSOR 。

SEAGREEN - Static variable in class javafx.scene.paint. Color

颜色海绿色，RGB值为＃2E8B57

seal() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

ECMAScript 15.2.3.8 - 密封执行

SEALED - Static variable in class java.util.jar. Attributes.Name

Name对象为 Sealed用于密封的manifest属性。

SealedObject - Class in javax.crypto

该类使程序员能够使用加密算法创建对象并保护其机密性。

SealedObject(Serializable, Cipher) - Constructor for class javax.crypto. SealedObject

从任何可序列化对象构造一个SealedObject。

SealedObject(SealedObject) - Constructor for class javax.crypto. SealedObject

从传入的SealedObject构造一个SealedObject对象。

search(long, BiFunction<? super K, ? super V, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap

通过在每个（键，值）上应用给定的搜索函数返回非空结果，如果没有则返回null。

search(Object) - Method in class java.util. Stack

返回一个对象在此堆栈上的基于1的位置。

search(String, String, Object[], SearchControls) - Method in interface javax.naming.directory. DirContext

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

search(String, String, Object[], SearchControls) - Method in class javax.naming.directory. InitialDirContext

search(String, String, SearchControls) - Method in interface javax.naming.directory. DirContext

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

search(String, String, SearchControls) - Method in class javax.naming.directory. InitialDirContext

search(String, Attributes) - Method in interface javax.naming.directory. DirContext

在单个上下文中搜索包含指定属性集的对象。

search(String, Attributes) - Method in class javax.naming.directory. InitialDirContext

search(String, Attributes, String[]) - Method in interface javax.naming.directory. DirContext

在单个上下文中搜索包含指定属性集的对象，并检索所选属性。

search(String, Attributes, String[]) - Method in class javax.naming.directory. InitialDirContext

search(Name, String, Object[], SearchControls) - Method in interface javax.naming.directory. DirContext

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

search(Name, String, Object[], SearchControls) - Method in class javax.naming.directory. InitialDirContext

search(Name, String, SearchControls) - Method in interface javax.naming.directory. DirContext

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

search(Name, String, SearchControls) - Method in class javax.naming.directory. InitialDirContext

search(Name, Attributes) - Method in interface javax.naming.directory. DirContext

在单个上下文中搜索包含指定属性集的对象。

search(Name, Attributes) - Method in class javax.naming.directory. InitialDirContext

search(Name, Attributes, String[]) - Method in interface javax.naming.directory. DirContext

在单个上下文中搜索包含指定属性集的对象，并检索所选属性。

search(Name, Attributes, String[]) - Method in class javax.naming.directory. InitialDirContext

SearchControls - Class in javax.naming.directory

该类封装了确定搜索范围和搜索结果返回的因素。

SearchControls() - Constructor for class javax.naming.directory. SearchControls

使用默认值构造搜索约束。

SearchControls(int, long, int, String[], boolean, boolean) - Constructor for class javax.naming.directory. SearchControls

使用参数构造搜索约束。

searchEntries(long, Function<Map.Entry<K, V>, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap

返回一个非空结果，从每个条目应用给定的搜索函数，如果没有，则返回null。

searchKeys(long, Function<? super K, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap

返回一个非空结果，在每个键上应用给定的搜索功能，如果没有，返回null。

SearchResult - Class in javax.naming.directory

该类表示由DirContext.search（）方法返回的NamingEnumeration中的一个项目。

SearchResult(String, Object, Attributes) - Constructor for class javax.naming.directory. SearchResult

使用结果的名称，其绑定对象及其属性构造搜索结果。

SearchResult(String, Object, Attributes, boolean) - Constructor for class javax.naming.directory. SearchResult

使用结果的名称，其绑定对象及其属性构建搜索结果，以及该名称是否相对。

SearchResult(String, String, Object, Attributes) - Constructor for class javax.naming.directory. SearchResult

使用结果的名称，其类名称，其绑定对象及其属性构造搜索结果。

SearchResult(String, String, Object, Attributes, boolean) - Constructor for class javax.naming.directory. SearchResult

使用结果的名称，其类名称，其绑定对象，其属性以及名称是否相对构造搜索结果。

searchValues(long, Function<? super V, ? extends U>) - Method in class java.util.concurrent. ConcurrentHashMap

返回一个非空结果，对每个值应用给定的搜索函数，如果没有，返回null。

SEASHELL - Static variable in class javafx.scene.paint. Color

颜色海壳，RGB值为＃FFF5EE

SECOND - Static variable in class java.text. DateFormat.Field

常数识别第二个字段。

SECOND - Static variable in class java.util. Calendar

get字段编号和 set表示分钟内的第二个。

SECOND_FIELD - Static variable in class java.text. DateFormat

有用的常数用于SECOND场对齐。

SECOND_OF_DAY - java.time.temporal. ChronoField

第二天。

SECOND_OF_MINUTE - java.time.temporal. ChronoField

第二分钟。

SECONDARY - javafx.scene.input. MouseButton

代表第二（按钮3，通常是右）鼠标按钮。

SECONDARY - Static variable in class java.text. Collator

整理器强度值。

SecondaryLoop - Interface in java.awt

一个辅助接口来运行嵌套事件循环。

secondaryOrder(int) - Static method in class java.text. CollationElementIterator

返回排序规则元素的次要组件。

seconds(double) - Static method in class javafx.util. Duration

返回一个表示指定秒数的Duration实例的Factory方法。

SECONDS - java.time.temporal. ChronoUnit

代表第二个概念的单位。

SECONDS - java.util.concurrent. TimeUnit

时间单位代表一秒。

SECONDS - Static variable in class javax.xml.datatype. DatatypeConstants

表示秒字段的常数。

SECRET - java.security. KeyRep.Type

键入密钥。

SECRET_KEY - Static variable in class javax.crypto. Cipher

用于指示要解开的密钥的常数是“密钥”。

SecretKey - Interface in javax.crypto

一个秘密（对称）键。

SecretKeyEntry(SecretKey) - Constructor for class java.security. KeyStore.SecretKeyEntry

构造一个 SecretKeyEntry与 SecretKey 。

SecretKeyEntry(SecretKey, Set<KeyStore.Entry.Attribute>) - Constructor for class java.security. KeyStore.SecretKeyEntry

构造一个 SecretKeyEntry与 SecretKey及相关条目中的属性。

SecretKeyFactory - Class in javax.crypto

这个类代表一个秘密密钥的工厂。

SecretKeyFactory(SecretKeyFactorySpi, Provider, String) - Constructor for class javax.crypto. SecretKeyFactory

创建一个SecretKeyFactory对象。

SecretKeyFactorySpi - Class in javax.crypto

该类定义了 SecretKeyFactory类的 （ SPI ）。

SecretKeyFactorySpi() - Constructor for class javax.crypto. SecretKeyFactorySpi

SecretKeySpec - Class in javax.crypto.spec

该类以独立于提供商的方式指定密钥。

SecretKeySpec(byte[], int, int, String) - Constructor for class javax.crypto.spec. SecretKeySpec

根据给定的字节数组的秘密密钥，使用所述第一 len的字节 key ，起始于 offset以下。

SecretKeySpec(byte[], String) - Constructor for class javax.crypto.spec. SecretKeySpec

从给定的字节数组构造一个秘密密钥。

SectionElement() - Constructor for class javax.swing.text. DefaultStyledDocument.SectionElement

创建一个新的SectionElement。

SectionElementName - Static variable in class javax.swing.text. AbstractDocument

用于保存部分的元素名称（行/段落）。

SECURE - jdk.incubator.http. HttpClient.Redirect

始终除HTTPS网址以外的HTTP URL重定向。

SECURE_RANDOM - java.security. CryptoPrimitive

加密随机数发生器

SecureCacheResponse - Class in java.net

表示最初通过安全手段（例如TLS）检索的缓存响应。

SecureCacheResponse() - Constructor for class java.net. SecureCacheResponse

SecureClassLoader - Class in java.security

此类扩展了ClassLoader，其额外支持用于定义具有相关代码源和权限的类，默认情况下系统策略将检索该类。

SecureClassLoader() - Constructor for class java.security. SecureClassLoader

使用默认的父类加载器创建一个新的SecureClassLoader进行委派。

SecureClassLoader(ClassLoader) - Constructor for class java.security. SecureClassLoader

使用指定的父类加载器创建新的SecureClassLoader进行委派。

SecureClassLoader(String, ClassLoader) - Constructor for class java.security. SecureClassLoader

创建一个新的指定名称的 SecureClassLoader ，并使用指定的父类加载器进行委派。

SecureDirectoryStream< T> - Interface in java.nio.file

A DirectoryStream定义了相对于打开目录定位的文件的操作。

SecureLookupSupplier - Class in jdk.dynalink

提供安全检查访问 MethodHandles.Lookup对象。

SecureLookupSupplier(MethodHandles.Lookup) - Constructor for class jdk.dynalink. SecureLookupSupplier

创建一个新的安全查找供应商，确保传递的查找。

SecureRandom - Class in java.security

这个类提供了一个密码强的随机数生成器（RNG）。

SecureRandom() - Constructor for class java.security. SecureRandom

构造一个实现默认随机数算法的安全随机数生成器（RNG）。

SecureRandom(byte[]) - Constructor for class java.security. SecureRandom

构造一个实现默认随机数算法的安全随机数生成器（RNG）。

SecureRandom(SecureRandomSpi, Provider) - Constructor for class java.security. SecureRandom

创建一个 SecureRandom对象。

SecureRandomParameters - Interface in java.security

用于各种 SecureRandom方法中使用的参数的标记界面。

SecureRandomSpi - Class in java.security

该类定义了SecureRandom类的 （ SPI ）。

SecureRandomSpi() - Constructor for class java.security. SecureRandomSpi

没有参数的构造函数。

SecureRandomSpi(SecureRandomParameters) - Constructor for class java.security. SecureRandomSpi

具有参数的构造方法

security() - Method in class java.lang. Runtime.Version

如果未设置，则返回 security版本号或为零。

Security - Class in java.security

此类集中所有安全属性和常见的安全方法。

SECURITY_AUTHENTICATION - Static variable in interface javax.naming. Context

持有用于指定要使用的安全级别的环境属性的名称的常量。

SECURITY_CREDENTIALS - Static variable in interface javax.naming. Context

包含用于指定用于验证呼叫者到服务的主体的凭据的环境属性的名称的常量。

SECURITY_PRINCIPAL - Static variable in interface javax.naming. Context

持有用于指定主体的身份的环境属性的常量，用于验证对该服务的呼叫者。

SECURITY_PROTOCOL - Static variable in interface javax.naming. Context

用于指定要使用的安全协议的环境属性的名称的常量。

SecurityException - Exception in java.lang

由安全管理员抛出，表示安全违规。

SecurityException() - Constructor for exception java.lang. SecurityException

构造一个没有详细消息的 SecurityException 。

SecurityException(String) - Constructor for exception java.lang. SecurityException

构造具有指定详细消息的 SecurityException 。

SecurityException(String, Throwable) - Constructor for exception java.lang. SecurityException

创建一个具有指定的详细信息和原因的 SecurityException 。

SecurityException(Throwable) - Constructor for exception java.lang. SecurityException

创建 SecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

SecurityManager - Class in java.lang

安全管理器是允许应用程序实施安全策略的类。

SecurityManager() - Constructor for class java.lang. SecurityManager

构造新的 SecurityManager 。

SecurityPermission - Class in java.security

此类用于安全权限。

SecurityPermission(String) - Constructor for class java.security. SecurityPermission

创建一个新的具有指定名称的SecurityPermission。

SecurityPermission(String, String) - Constructor for class java.security. SecurityPermission

创建一个新的具有指定名称的SecurityPermission对象。

SEE - com.sun.source.doctree. DocTree.Kind

用于表示@see标签的SeeTree的实例。

seek(int) - Method in interface org.omg.CORBA. DynAny

已过时。

将内部指针移动到给定的索引。

seek(int) - Method in class org.omg.DynamicAny. _DynAnyStub

将当前位置设置为索引。

seek(int) - Method in class org.omg.DynamicAny. _DynArrayStub

将当前位置设置为索引。

seek(int) - Method in class org.omg.DynamicAny. _DynEnumStub

将当前位置设置为索引。

seek(int) - Method in class org.omg.DynamicAny. _DynFixedStub

将当前位置设置为索引。

seek(int) - Method in class org.omg.DynamicAny. _DynSequenceStub

将当前位置设置为索引。

seek(int) - Method in class org.omg.DynamicAny. _DynStructStub

将当前位置设置为索引。

seek(int) - Method in class org.omg.DynamicAny. _DynUnionStub

将当前位置设置为索引。

seek(int) - Method in class org.omg.DynamicAny. _DynValueStub

将当前位置设置为索引。

seek(int) - Method in interface org.omg.DynamicAny. DynAnyOperations

将当前位置设置为索引。

seek(long) - Method in class java.io. RandomAccessFile

设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。

seek(long) - Method in class javax.imageio.stream. FileCacheImageOutputStream

设置当前流位置，并将位偏移重置为0。

seek(long) - Method in class javax.imageio.stream. FileImageInputStream

seek(long) - Method in class javax.imageio.stream. FileImageOutputStream

设置当前流位置，并将位偏移重置为0。

seek(long) - Method in interface javax.imageio.stream. ImageInputStream

将当前流位置设置为所需位置。

seek(long) - Method in class javax.imageio.stream. ImageInputStreamImpl

seek(long) - Method in interface javax.jnlp. JNLPRandomAccessFile

设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。

seek(Duration) - Method in class javafx.scene.media. MediaPlayer

寻找播放器一个新的播放时间。

SeekableByteChannel - Interface in java.nio.channels

保持当前 位置并允许更改 位置的字节通道。

seekForwardOnly - Variable in class javax.imageio. ImageReader

true如果当前的输入源已被标记为允许仅通过 setInput前向寻找。

SeeTag - Interface in com.sun.javadoc

已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

seeTags() - Method in interface com.sun.javadoc. Doc

已过时。

返回此文件中的参见标签。

SeeTree - Interface in com.sun.source.doctree

@see块标记的树节点。

SEG_CLOSE - Static variable in interface java.awt.geom. PathIterator

通过将线段追加到与最近的SEG_MOVETO对应的点来指定应该关闭前一子路径的段类型常量。

SEG_CUBICTO - Static variable in interface java.awt.geom. PathIterator

指定要从最近指定点绘制的三次参数曲线的3个点集合的段类型常数。

SEG_LINETO - Static variable in interface java.awt.geom. PathIterator

指定要从最近指定点绘制的行的终点的点的段类型常量。

SEG_MOVETO - Static variable in interface java.awt.geom. PathIterator

指定新子路径起始位置的点的段类型常量。

SEG_QUADTO - Static variable in interface java.awt.geom. PathIterator

指定从最近指定点绘制的二次参数曲线的一对点的段类型常数。

Segment - Class in javax.swing.text

表示文本片段的字符数组的段。

Segment() - Constructor for class javax.swing.text. Segment

创建一个新的细分。

Segment(char[], int, int) - Constructor for class javax.swing.text. Segment

创建一个引用现有数组的新段。

SEGMENT_LIMIT - Static variable in interface java.util.jar. Pack200.Packer

该属性是给出每个归档段的估计目标大小N（以字节为单位）的数字。

select() - Method in class java.nio.channels. Selector

选择一组其相应通道准备好进行I / O操作的键。

select() - Method in interface org.w3c.dom.html. HTMLInputElement

选择文本区域的内容。

select() - Method in interface org.w3c.dom.html. HTMLTextAreaElement

选择 TEXTAREA的内容。

select(int) - Method in class java.awt. Choice

将此 Choice菜单中的选定项目设置为指定位置的项目。

select(int) - Method in class java.awt. List

在滚动列表中选择指定索引处的项目。

select(int) - Method in class javafx.scene.control. SelectionModel

这将在选择模型中选择给定的索引，假设索引在有效范围内（即大于或等于零，并且小于底层数据模型中的项目总数）。

select(int) - Method in class javafx.scene.control. SingleSelectionModel

选择给定的索引。

select(int, int) - Method in class java.awt. TextComponent

选择指定的开始和结束位置之间的文本。

select(int, int) - Method in class javax.swing.text. JTextComponent

选择指定的开始和结束位置之间的文本。

select(int, TableColumn<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

选择给定的行/列交叉点的单元格。

select(int, TableColumnBase<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

选择给定的行/列交叉点的单元格。

select(int, TableColumnBase<T, ?>) - Method in class javafx.scene.control. TableSelectionModel

选择给定的行/列交叉点的单元格。

select(long) - Method in class java.nio.channels. Selector

选择一组其相应通道准备好进行I / O操作的键。

select(Object, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

select(String) - Method in class java.awt. Choice

将此 Choice菜单中的选定项目设置为名称等于指定字符串的项目。

select(URI) - Method in class java.net. ProxySelector

根据访问资源的协议选择所有适用的代理以及访问资源的目标地址。

select(ObservableValue<?>, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

select(KeyInfo, KeySelector.Purpose, AlgorithmMethod, XMLCryptoContext) - Method in class javax.xml.crypto. KeySelector

尝试找到满足指定约束的键。

select(T) - Method in class javafx.scene.control. SelectionModel

此方法将尝试选择包含给定对象的索引。

select(T) - Method in class javafx.scene.control. SingleSelectionModel

选择基础数据模型中给定对象的第一个实例的索引。

SELECT - Static variable in class javax.swing.text.html. HTML.Tag

标签<select>

SELECT_LIST_ONLY - java.sql. PseudoColumnUsage

伪/隐藏列只能在SELECT列表中使用。

SELECTABLE - Static variable in class javax.accessibility. AccessibleState

表示此对象是允许其子项被选中的对象的子对象，并且该子对象是可选择的其中一个子对象。

SelectableChannel - Class in java.nio.channels

可通过Selector复用的通道 。

SelectableChannel() - Constructor for class java.nio.channels. SelectableChannel

初始化此类的新实例。

selectAboveCell() - Method in class javafx.scene.control. TableSelectionModel

选择当前所选单元格正上方的单元格。

selectAdjacentRunTab(int, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

选择相邻的选项卡。

selectAll() - Method in class java.awt. TextComponent

选择此文本组件中的所有文本。

selectAll() - Method in class javafx.scene.control. MultipleSelectionModel

方便的方法来选择所有可用的索引。

selectAll() - Method in class javafx.scene.control. TextInputControl

选择文本输入中的所有文本。

selectAll() - Method in interface javax.swing. ComboBoxEditor

请编辑开始编辑并选择所有内容

selectAll() - Method in class javax.swing. JTable

选择表中的所有行，列和单元格。

selectAll() - Method in class javax.swing.plaf.basic. BasicComboBoxEditor

selectAll() - Method in class javax.swing.text. JTextComponent

选择 TextComponent中的所有文本。

selectAllAccessibleSelection() - Method in class java.awt. List.AccessibleAWTList

如果对象支持多个选择，则导致要选择的对象中的每个选定项目。

selectAllAccessibleSelection() - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

如果对象支持多个选择，则导致选择对象的每个子对象。

selectAllAccessibleSelection() - Method in interface javax.accessibility. AccessibleSelection

如果对象支持多个选择，则导致选择对象的每个子对象。

selectAllAccessibleSelection() - Method in class javax.swing. JComboBox.AccessibleJComboBox

如果对象支持多个选择，则导致选择对象的每个子对象。

selectAllAccessibleSelection() - Method in class javax.swing. JList.AccessibleJList

如果对象支持多个选择，则导致要选择的对象中的每个选定项目。

selectAllAccessibleSelection() - Method in class javax.swing. JMenu.AccessibleJMenu

如果对象支持多个选择，通常会导致选择对象中的每个选定项目。

selectAllAccessibleSelection() - Method in class javax.swing. JMenuBar.AccessibleJMenuBar

如果对象支持多个选择，通常会导致选择对象中的每个选定项目。

selectAllAccessibleSelection() - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

selectAllAccessibleSelection() - Method in class javax.swing. JTable.AccessibleJTable

导致要选择对象的每个子对象，但仅当 JTable支持多个选择，并且启用单个单元格选择时。

selectAllAccessibleSelection() - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

如果对象支持多个选择，则导致要选择的对象中的每个选定项目。

selectAllAccessibleSelection() - Method in class javax.swing. JTree.AccessibleJTree

如果对象支持多个选择，则导致要选择的对象中的每个选定项目。

selectAllAction - Static variable in class javax.swing.text. DefaultEditorKit

用于选择整个文档的操作的名称

selectBackward() - Method in class javafx.scene.control. TextInputControl

在文本中向后移动选择一个字符。

selectBelowCell() - Method in class javafx.scene.control. TableSelectionModel

选择当前选定单元格正下方的单元格。

selectBestTextFlavor(DataFlavor[]) - Static method in class java.awt.datatransfer. DataFlavor

选择最好的文本 DataFlavor从数组 DataFlavor秒。

selectBoolean(Object, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectBoolean(ObservableValue<?>, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectColor - Variable in class javax.swing.plaf.metal. MetalButtonUI

所选按钮的颜色。

selectColor - Variable in class javax.swing.plaf.metal. MetalRadioButtonUI

所选单选按钮的颜色。

selectColor - Variable in class javax.swing.plaf.metal. MetalTabbedPaneUI

所选窗格的颜色。

selectColor - Variable in class javax.swing.plaf.metal. MetalToggleButtonUI

所选按钮的颜色。

selectContent(AttributeSet) - Method in class javax.swing.text.html. HTMLWriter

写出SELECT表单元素的内容。

selectDouble(Object, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectDouble(ObservableValue<?>, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selected - Variable in class javax.swing.tree. DefaultTreeCellRenderer

是当前值。

SELECTED - javafx.scene. AccessibleAttribute

如果选择了节点，则返回true，否则返回false。

SELECTED - Static variable in class java.awt.event. ItemEvent

此状态变化值表示已选择项目。

SELECTED - Static variable in class javax.accessibility. AccessibleState

表示此对象是允许其子项被选中的对象的子对象，并且该子对象是已选择的其中一个子对象。

SELECTED - Static variable in class javax.swing. DefaultButtonModel

标识位掩码中的“选定”位，表示该按钮已被选中。

SELECTED - Static variable in interface javax.swing.plaf.synth. SynthConstants

表示已选择区域。

SELECTED - Static variable in class javax.swing.text.html. HTML.Attribute

属性“已选”

SELECTED_CONVERTED - javafx.scene.input. InputMethodHighlight

用于所选转换输入法文本的突出显示

SELECTED_CONVERTED_TEXT_HIGHLIGHT - Static variable in class java.awt.im. InputMethodHighlight

所选转换文本的默认高亮度的常数。

SELECTED_FILE_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser

标识用户单文件选择的变化。

SELECTED_FILES_CHANGED_PROPERTY - Static variable in class javax.swing. JFileChooser

标识用户多文件选择的变化。

SELECTED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton

标识在选择按钮时使用的图标的更改。

SELECTED_ITEMS - javafx.scene. AccessibleAttribute

返回节点的选定项目列表。

SELECTED_KEY - Static variable in interface javax.swing. Action

用于存储对应于所选状态的 Boolean的密钥。

SELECTED_RAW - javafx.scene.input. InputMethodHighlight

用于所选原始输入法文本的突出显示

SELECTED_RAW_TEXT_HIGHLIGHT - Static variable in class java.awt.im. InputMethodHighlight

所选原始文本的默认突出显示的常数。

SELECTED_TAB - javafx.scene.control. TabPane.TabClosingPolicy

只有当前选中的选项卡可以选择关闭，并显示标签文本旁边的图形。

selectedExtensionFilterProperty() - Method in class javafx.stage. FileChooser

此属性用于为下一个显示的对话框预先选择扩展过滤器，并从被忽略的对话框中读取用户选择的扩展过滤器。

selectedIndexProperty() - Method in class javafx.scene.control. SelectionModel

指所选索引属性，用于指示选择模型中当前选定的索引值。

selectedItemChanged() - Method in class javax.swing. JComboBox

此保护方法是具体实现。

selectedItemProperty() - Method in class javafx.scene.control. ChoiceDialog

返回表示对话框中当前选定项目的属性。

selectedItemProperty() - Method in class javafx.scene.control. SelectionModel

指所选项目属性，用于指示选择模型中当前选定的项目。

selectedItemReminder - Variable in class javax.swing. JComboBox

此保护字段是实现特定的。

selectedKeys() - Method in class java.nio.channels. Selector

返回此选择器的选择键集。

selectedProperty() - Method in class javafx.scene.control. Cell

指示此单元格是否已被选中。

selectedProperty() - Method in class javafx.scene.control. CheckBox

指示是否选中此复选框。

selectedProperty() - Method in class javafx.scene.control. CheckBoxTreeItem

A BooleanProperty用于表示此CheckBoxTreeItem的选定状态。

selectedProperty() - Method in class javafx.scene.control. CheckMenuItem

表示此CheckMenuItem的当前状态。

selectedProperty() - Method in class javafx.scene.control. RadioMenuItem

selectedProperty() - Method in class javafx.scene.control. Tab

当前选中的选项卡。

selectedProperty() - Method in interface javafx.scene.control. Toggle

选择状态为这个 Toggle 。

selectedProperty() - Method in class javafx.scene.control. ToggleButton

指示是否选择此切换按钮。

selectedRun - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

选择运行

selectedStateCallbackProperty() - Method in class javafx.scene.control.cell. CheckBoxListCell

属性表示由屏幕上显示的复选框绑定的Callback 。

selectedStateCallbackProperty() - Method in class javafx.scene.control.cell. CheckBoxTableCell

属性表示由屏幕上显示的复选框绑定的Callback 。

selectedStateCallbackProperty() - Method in class javafx.scene.control.cell. CheckBoxTreeCell

属性表示由屏幕上显示的复选框绑定的Callback 。

selectedStateCallbackProperty() - Method in class javafx.scene.control.cell. CheckBoxTreeTableCell

属性表示由屏幕上显示的复选框绑定的Callback 。

selectedTabPadInsets - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

所选标签插入

selectedTextColor - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

所选文字的颜色。

selectedTextProperty() - Method in class javafx.scene.control. TextInputControl

定义所选文本输入控件中的字符

selectedTitleColor - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

所选标题的颜色。

selectedToggleProperty() - Method in class javafx.scene.control. ToggleGroup

所选的切换。

selectEnd() - Method in class javafx.scene.control. TextInputControl

将插入符移动到文本的最后一个字符之后。

selectEndOfNextWord() - Method in class javafx.scene.control. TextInputControl

将插入符移动到下一个单词的末尾。

selectFirst() - Method in class javafx.scene.control. MultipleSelectionModel

该方法将尝试选择控件中的第一个索引。

selectFirst() - Method in class javafx.scene.control. SelectionModel

该方法将尝试选择控件中的第一个索引。

selectFirst() - Method in class javafx.scene.control. SingleSelectionModel

选择第一个索引。

selectFloat(Object, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectFloat(ObservableValue<?>, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectForward() - Method in class javafx.scene.control. TextInputControl

将选项向前移动文本中的一个字符。

selectFrame(boolean) - Method in class javax.swing. JDesktopPane

在此桌面窗格中选择下一个 JInternalFrame 。

selectHighlight - Variable in class javax.swing.plaf.metal. MetalTabbedPaneUI

亮点的颜色。

selectHome() - Method in class javafx.scene.control. TextInputControl

将插入符移动到文本的第一个字符之前。

selectIndices(int, int...) - Method in class javafx.scene.control. MultipleSelectionModel

该方法允许同时设置一个或多个选择。

selectInitialValue() - Method in class javax.swing. JOptionPane

请求选择初始值，将其设置为初始值。

selectInitialValue(JOptionPane) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI

如果inputComponent为非空值，那么请求焦点，否则请求关注默认值

selectInitialValue(JOptionPane) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI

在此对象处理的每个UI上调用 selectInitialValue方法。

selectInitialValue(JOptionPane) - Method in class javax.swing.plaf. OptionPaneUI

请求表示默认值的组件具有焦点。

selectInputMethod(Locale) - Method in class java.awt.im. InputContext

尝试选择支持给定区域设置的输入法或键盘布局，并返回一个值，该值指示是否已成功选择此类输入法或键盘布局。

selectInteger(Object, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectInteger(ObservableValue<?>, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selection - Variable in class javax.swing.tree. DefaultTreeSelectionModel

当前选择的路径。

SELECTION - Static variable in class java.awt. JobAttributes.DefaultSelectionType

用于指定应打印当前选择的 DefaultSelectionType实例。

SELECTION_CHANGED_EVENT - Static variable in class javafx.scene.control. Tab

当选项卡被选中或未选择时调用。

SELECTION_END - javafx.scene. AccessibleAttribute

返回节点的文本选择结束偏移量。

SELECTION_MODE_PROPERTY - Static variable in class javax.swing.tree. DefaultTreeSelectionModel

selectionMode的属性名称。

SELECTION_MODEL_PROPERTY - Static variable in class javax.swing. JColorChooser

选择模型属性名称。

SELECTION_MODEL_PROPERTY - Static variable in class javax.swing. JTree

选择模型的绑定属性名称。

SELECTION_START - javafx.scene. AccessibleAttribute

返回节点的文本选择开始偏移量。

SELECTION_VALUES_PROPERTY - Static variable in class javax.swing. JOptionPane

绑定属性名称为 selectionValues 。

selectionBackground - Variable in class javax.swing. JTable

所选单元格的背景颜色。

selectionBackground - Variable in class javax.swing.plaf.basic. BasicMenuItemUI

选择背景的颜色。

selectionBackwardAction - Static variable in class javax.swing.text. DefaultEditorKit

通过将插入符逻辑地向后移动一个位置来扩展选择的动作的名称。

selectionBeginAction - Static variable in class javax.swing.text. DefaultEditorKit

Action名称，用于将插入符号移动到文档的开头。

selectionBeginLineAction - Static variable in class javax.swing.text. DefaultEditorKit

Action名称，用于将插入符号移动到行的开头，扩展选择。

selectionBeginParagraphAction - Static variable in class javax.swing.text. DefaultEditorKit

将插入符号移动到段落开头的 Action名称，扩展选择。

selectionBeginWordAction - Static variable in class javax.swing.text. DefaultEditorKit

Action名称，用于将插入符号移动到单词的开头，扩展选择。

selectionDownAction - Static variable in class javax.swing.text. DefaultEditorKit

将插入符号向下移动一个位置的操作的名称，扩展选择。

selectionEndAction - Static variable in class javax.swing.text. DefaultEditorKit

将插入符移动到文档末尾的Action的名称。

selectionEndLineAction - Static variable in class javax.swing.text. DefaultEditorKit

Action名称，用于将插入符号移动到行尾，扩展选择。

selectionEndParagraphAction - Static variable in class javax.swing.text. DefaultEditorKit

Action名称，用于将插入符号移动到段落的末尾，扩展选择。

selectionEndProperty() - Method in class javafx.scene.text. Text

selectionEndWordAction - Static variable in class javax.swing.text. DefaultEditorKit

将插入符号移动到单词结尾的Action的名称，扩展选择。

selectionFillProperty() - Method in class javafx.scene.text. Text

所选文字的填充颜色。

selectionForeground - Variable in class javax.swing. JTable

所选单元格的前景色。

selectionForeground - Variable in class javax.swing.plaf.basic. BasicMenuItemUI

选择前景的颜色。

selectionForKey(char, ComboBoxModel<?>) - Method in interface javax.swing. JComboBox.KeySelectionManager

给定 aKey和模型，返回应该被选择的行。

selectionForwardAction - Static variable in class javax.swing.text. DefaultEditorKit

通过将插入符逻辑地向前移动一个位置来扩展选择的动作的名称。

selectionHtmlFlavor - Static variable in class java.awt.datatransfer. DataFlavor

代表一个HTML标记。

SelectionKey - Class in java.nio.channels

一个代表SelectableChannel与Selector注册的令牌。

SelectionKey() - Constructor for class java.nio.channels. SelectionKey

构造这个类的一个实例。

SelectionListener() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.SelectionListener

selectionMode - Variable in class javax.swing.tree. DefaultTreeSelectionModel

选择的模式将是SINGLE_TREE_SELECTION，CONTIGUOUS_TREE_SELECTION或DISCONTIGUOUS_TREE_SELECTION。

SelectionMode - Enum in javafx.scene.control

用于指定可以在MultipleSelectionModel中选择多少项的枚举 。

selectionModel - Variable in class javax.swing. JTable

表中的 ListSelectionModel ，用于跟踪行选择。

selectionModel - Variable in class javax.swing. JTree

模拟此树中所选节点的集合。

selectionModel - Variable in class javax.swing.table. DefaultTableColumnModel

跟踪列选择的模型

SelectionModel< T> - Class in javafx.scene.control

SelectionModel是UI控件用来提供一致的API来维护选择的抽象类。

SelectionModel() - Constructor for class javafx.scene.control. SelectionModel

创建一个默认的SelectionModel实例。

selectionModelChanged - Static variable in class javax.swing.plaf.basic. BasicListUI

该位与选择模型更改属性有关。

selectionModelProperty() - Method in class javafx.scene.control. ChoiceBox

ChoiceBox的选择模型。

selectionModelProperty() - Method in class javafx.scene.control. ComboBox

ComboBox的选择模型。

selectionModelProperty() - Method in class javafx.scene.control. ListView

SelectionModel提供了可以在ListView中选择单个或多个项目的API，以及检查用户选择了哪些项目。

selectionModelProperty() - Method in class javafx.scene.control. TableView

SelectionModel提供了可以在TableView中选择单个或多个项目的API，以及检查用户选择了哪些项目。

selectionModelProperty() - Method in class javafx.scene.control. TabPane

用于选择标签的选择模型。

selectionModelProperty() - Method in class javafx.scene.control. TreeTableView

SelectionModel提供了可以在TreeTableView中选择单个或多个项目的API，以及检查用户选择了哪些行。

selectionModelProperty() - Method in class javafx.scene.control. TreeView

SelectionModel提供了可以在TreeView中选择单个或多个项目的API，以及检查用户选择了哪些行。

SelectionModelPropertyChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.SelectionModelPropertyChangeHandler

selectionModeProperty() - Method in class javafx.scene.control. MultipleSelectionModel

指定在此选择模型中使用的选择模式。

selectionNextWordAction - Static variable in class javax.swing.text. DefaultEditorKit

Action名称，用于将选择移动到下一个单词的开头，扩展选择。

selectionPreviousWordAction - Static variable in class javax.swing.text. DefaultEditorKit

用于将选择移动到上一个单词开头的 Action名称，扩展选择。

selectionProperty() - Method in class javafx.scene.control. TextInputControl

当前选择。

selectionRedirector - Variable in class javax.swing. JTree

创建一个新的事件并将其从 selectionListeners 。

selectionShapeProperty() - Method in class javafx.scene.text. Text

selectionStartProperty() - Method in class javafx.scene.text. Text

selectionUpAction - Static variable in class javax.swing.text. DefaultEditorKit

将插入符号向上移动一个位置的操作的名称，扩展选择。

selectionValues - Variable in class javax.swing. JOptionPane

用户可以选择的数组数组。

selectLast() - Method in class javafx.scene.control. MultipleSelectionModel

此方法将尝试选择控件中的最后一个索引。

selectLast() - Method in class javafx.scene.control. SelectionModel

此方法将尝试选择控件中的最后一个索引。

selectLast() - Method in class javafx.scene.control. SingleSelectionModel

选择最后一个索引。

selectLeftCell() - Method in class javafx.scene.control. TableSelectionModel

选择当前所选单元格左侧的单元格。

selectLineAction - Static variable in class javax.swing.text. DefaultEditorKit

用于在插入符号周围选择一行的动作名称。

selectLong(Object, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectLong(ObservableValue<?>, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectNext() - Method in class javafx.scene.control. SelectionModel

此方法将尝试在当前焦点索引之后直接选择索引。

selectNext() - Method in class javafx.scene.control. SingleSelectionModel

选择下一个索引。

selectNextIndex() - Method in class javax.swing.plaf.basic. BasicListUI

选择上一行并强制它可见。

selectNextPossibleValue() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

选择列表中的下一个项目。

selectNextTab(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

选择下一个选项卡。

selectNextTabInRun(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

选择运行中的下一个选项卡。

selectNextWord() - Method in class javafx.scene.control. TextInputControl

将插入符号移到下一个字的开头。

selectNode(Node) - Method in interface org.w3c.dom.ranges. Range

选择节点及其内容

selectNodeContents(Node) - Method in interface org.w3c.dom.ranges. Range

选择节点内的内容

selectNow() - Method in class java.nio.channels. Selector

选择一组其相应通道准备好进行I / O操作的键。

selector() - Method in class java.nio.channels. SelectionKey

返回创建此键的选择器。

Selector - Class in java.nio.channels

SelectableChannel对象的多路复用器。

Selector - Class in javafx.css

由CSSRule用于确定选择器是否适用于给定的对象。

Selector() - Constructor for class java.nio.channels. Selector

初始化此类的新实例。

Selector() - Constructor for class javafx.css. Selector

SelectorProvider - Class in java.nio.channels.spi

选择器和可选择通道的服务提供者类。

SelectorProvider() - Constructor for class java.nio.channels.spi. SelectorProvider

初始化此类的新实例。

selectParagraphAction - Static variable in class javax.swing.text. DefaultEditorKit

用于在插入符号周围选择一个段落的Action的名称。

selectPathForEvent(TreePath, MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI

通过特定行来更新基于 MouseEvent的选择。

selectPositionCaret(int) - Method in class javafx.scene.control. TextInputControl

将插入符号插入 pos所示的位置，并扩展选择（如果有）。

selectPrevious() - Method in class javafx.scene.control. SelectionModel

此方法将尝试直接在当前聚焦索引之前选择索引。

selectPrevious() - Method in class javafx.scene.control. SingleSelectionModel

选择上一个索引。

selectPreviousIndex() - Method in class javax.swing.plaf.basic. BasicListUI

选择上一行并强制它可见。

selectPreviousPossibleValue() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

选择列表中的上一个项目。

selectPreviousTab(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

选择上一个选项卡。

selectPreviousTabInRun(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

选择运行中的上一个选项卡。

selectPreviousWord() - Method in class javafx.scene.control. TextInputControl

将插入符号移动到上一个单词的开头。

selectRange(int, int) - Method in class javafx.scene.control. MultipleSelectionModel

从给定的开始索引中选择所有索引到给定的结束索引之前的项目。

selectRange(int, int) - Method in class javafx.scene.control. TextFormatter.Change

设置选择。

selectRange(int, int) - Method in class javafx.scene.control. TextInputControl

定位锚和caretPosition明确。

selectRange(int, TableColumnBase<TreeItem<S>, ?>, int, TableColumnBase<TreeItem<S>, ?>) - Method in class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel

选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。

selectRange(int, TableColumnBase<S, ?>, int, TableColumnBase<S, ?>) - Method in class javafx.scene.control. TableView.TableViewSelectionModel

选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。

selectRange(int, TableColumnBase<T, ?>, int, TableColumnBase<T, ?>) - Method in class javafx.scene.control. TableSelectionModel

选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。

selectRightCell() - Method in class javafx.scene.control. TableSelectionModel

选择当前所选单元格右侧的单元格。

selectString(Object, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectString(ObservableValue<?>, String...) - Static method in class javafx.beans.binding. Bindings

创建用于获取成员的绑定，如 a.b.c 。

selectText(int, int) - Method in interface javax.accessibility. AccessibleEditableText

选择两个索引之间的文本。

selectText(int, int) - Method in class javax.swing. JSpinner.AccessibleJSpinner

选择两个索引之间的文本。

selectText(int, int) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

选择两个索引之间的文本。

selectToggle(Toggle) - Method in class javafx.scene.control. ToggleGroup

选择切换。

selectWithKeyChar(char) - Method in class javax.swing. JComboBox

选择与指定键盘字符相对应的列表项，如果存在与该字符相对应的项，则返回true。

selectWordAction - Static variable in class javax.swing.text. DefaultEditorKit

在插入符号周围选择一个单词的动作名称。

selfIlluminationMapProperty() - Method in class javafx.scene.paint. PhongMaterial

这个自拍照片 PhongMaterial 。

Semaphore - Class in java.util.concurrent

一个计数信号量。

Semaphore(int) - Constructor for class java.util.concurrent. Semaphore

创建一个 Semaphore与给定数量的许可证和非公平公平设置。

Semaphore(int, boolean) - Constructor for class java.util.concurrent. Semaphore

创建一个 Semaphore与给定数量的许可证和给定的公平设置。

SEMI_BOLD - javafx.scene.text. FontWeight

代表“Demi Bold”字体重量（600）。

SEMICOLON - javafx.scene.input. KeyCode

常数为分号键，“;”

send(DatagramPacket) - Method in class java.net. DatagramSocket

从此套接字发送数据报包。

send(DatagramPacket) - Method in class java.net. DatagramSocketImpl

发送数据报包。

send(DatagramPacket, byte) - Method in class java.net. MulticastSocket

已过时。
使用以下代码或其等价物：...... int ttl = mcastSocket.getTimeToLive（）; mcastSocket.setTimeToLive（newttl）; mcastSocket.send（P）; mcastSocket.setTimeToLive（TTL）; ......

send(ByteBuffer, MessageInfo) - Method in class com.sun.nio.sctp. SctpChannel

通过此频道发送消息。

send(ByteBuffer, MessageInfo) - Method in class com.sun.nio.sctp. SctpMultiChannel

通过此频道发送消息。

send(ByteBuffer, SocketAddress) - Method in class java.nio.channels. DatagramChannel

通过此频道发送数据报。

send(MidiMessage, long) - Method in interface javax.sound.midi. Receiver

向此接收器发送MIDI消息和时间戳。

send(HttpRequest, HttpResponse.BodyHandler<T>) - Method in class jdk.incubator.http. HttpClient

使用此客户端发送给定的请求，如有必要，阻止获取响应。

send_deferred() - Method in class org.omg.CORBA. Request

对请求进行异步调用。

send_exception(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor. ServerRequestInterceptorOperations

允许拦截器查询异常信息，并在异常抛出到客户端之前修改回复服务上下文。

send_multiple_requests_deferred(Request[]) - Method in class org.omg.CORBA. ORB

以异步方式发送多个动态（DII）请求。

send_multiple_requests_oneway(Request[]) - Method in class org.omg.CORBA. ORB

以异步方式发送多个动态（DII）请求，而不需要任何响应。

send_oneway() - Method in class org.omg.CORBA. Request

根据请求进行单向调用。

send_other(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor. ServerRequestInterceptorOperations

允许拦截器在请求导致除了正常回复或异常之外的其他内容时查询可用的信息。

send_poll(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor. ClientRequestInterceptorOperations

允许拦截器在时间无关调用（TII）轮询获取回复序列期间查询信息。

send_reply(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor. ServerRequestInterceptorOperations

允许拦截器在调用目标操作之后以及在将响应返回给客户端之前查询回复信息并修改回复服务上下文。

send_request(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor. ClientRequestInterceptorOperations

允许拦截器在请求发送到服务器之前查询请求信息并修改服务上下文。

sendAsync(HttpRequest, HttpResponse.BodyHandler<T>) - Method in class jdk.incubator.http. HttpClient

使用此客户端和给定的响应处理程序异步发送给定的请求。

sendAsync(HttpRequest, HttpResponse.MultiProcessor<U, T>) - Method in class jdk.incubator.http. HttpClient

使用此客户端和给定的多响应处理程序异步发送给定的请求。

sendAttributeChangeNotification(AttributeChangeNotification) - Method in interface javax.management.modelmbean. ModelMBeanNotificationBroadcaster

发送一个attributeChangeNotification，该属性传递给ModelMBean上注册的attributeChangeNotification侦听器。

sendAttributeChangeNotification(AttributeChangeNotification) - Method in class javax.management.modelmbean. RequiredModelMBean

sendAttributeChangeNotification(Attribute, Attribute) - Method in interface javax.management.modelmbean. ModelMBeanNotificationBroadcaster

发送一个attributeChangeNotification，其中包含该属性的旧值和新值到ModelMBean上注册的AttributeChangeNotification侦听器。

sendAttributeChangeNotification(Attribute, Attribute) - Method in class javax.management.modelmbean. RequiredModelMBean

sendBinary(ByteBuffer, boolean) - Method in interface jdk.incubator.http. WebSocket

从给定的 ByteBuffer发送带有字节的二进制消息。

sendClose(int, String) - Method in interface jdk.incubator.http. WebSocket

发送关闭消息与给定的状态代码和原因。

SendFailedNotification - Class in com.sun.nio.sctp

收到发送失败通知时发出的通知。

SendFailedNotification() - Constructor for class com.sun.nio.sctp. SendFailedNotification

初始化此类的新实例。

sending_exception() - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations

返回任何包含要返回给客户端的异常。

sendNotification(String) - Method in interface javax.management.modelmbean. ModelMBeanNotificationBroadcaster

发送一个通知，其中包含传递给ModelMBean上注册的通知侦听器的文本字符串。

sendNotification(String) - Method in class javax.management.modelmbean. RequiredModelMBean

sendNotification(Notification) - Method in class javax.management. MBeanServerDelegate

启用MBean服务器发送通知。

sendNotification(Notification) - Method in interface javax.management.modelmbean. ModelMBeanNotificationBroadcaster

发送通知，该通知将作为jmx.modelmbean.generic通知传递给ModelMBean上的注册通知侦听器。

sendNotification(Notification) - Method in class javax.management.modelmbean. RequiredModelMBean

sendNotification(Notification) - Method in class javax.management. NotificationBroadcasterSupport

发送通知。

sendNotification(Notification) - Method in class javax.management. StandardEmitterMBean

发送通知。

sendPing(ByteBuffer) - Method in interface jdk.incubator.http. WebSocket

从给定的ByteBuffer发送带有字节的Ping消息。

sendPong(ByteBuffer) - Method in interface jdk.incubator.http. WebSocket

从给定的ByteBuffer发送带有字节的Pong消息。

sendRelationCreationNotification(String) - Method in class javax.management.relation. RelationService

发送关系创建的通知（RelationNotification）。

sendRelationCreationNotification(String) - Method in interface javax.management.relation. RelationServiceMBean

发送关系创建的通知（RelationNotification）。

sendRelationRemovalNotification(String, List<ObjectName>) - Method in class javax.management.relation. RelationService

发送通知（RelationNotification）用于删除关系。

sendRelationRemovalNotification(String, List<ObjectName>) - Method in interface javax.management.relation. RelationServiceMBean

发送通知（RelationNotification）用于删除关系。

sendResponseHeaders(int, long) - Method in class com.sun.net.httpserver. HttpExchange

开始使用本方法中指定的当前响应头和数字响应代码将响应发送回客户端。

sendRoleUpdateNotification(String, Role, List<ObjectName>) - Method in class javax.management.relation. RelationService

发送给定关系中角色更新的通知（RelationNotification）。

sendRoleUpdateNotification(String, Role, List<ObjectName>) - Method in interface javax.management.relation. RelationServiceMBean

发送给定关系中角色更新的通知（RelationNotification）。

sendText(CharSequence, boolean) - Method in interface jdk.incubator.http. WebSocket

发送带有来自给定的 CharSequence字符的 CharSequence 。

sendUrgentData(int) - Method in class java.net. Socket

在套接字上发送一个字节的紧急数据。

sendUrgentData(int) - Method in class java.net. SocketImpl

在套接字上发送一个字节的紧急数据。

SENSING_METHOD_COLOR_SEQUENTIAL_AREA_SENSOR - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SensingMethod”标签一起使用的值。

SENSING_METHOD_COLOR_SEQUENTIAL_LINEAR_SENSOR - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SensingMethod”标签一起使用的值。

SENSING_METHOD_NOT_DEFINED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SensingMethod”标签一起使用的值。

SENSING_METHOD_ONE_CHIP_COLOR_AREA_SENSOR - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SensingMethod”标签一起使用的值。

SENSING_METHOD_THREE_CHIP_COLOR_AREA_SENSOR - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SensingMethod”标签一起使用的值。

SENSING_METHOD_TRILINEAR_SENSOR - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SensingMethod”标签一起使用的值。

SENSING_METHOD_TWO_CHIP_COLOR_AREA_SENSOR - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SensingMethod”标签一起使用的值。

SENTENCE - Static variable in interface javax.accessibility. AccessibleText

常数用于表示应检索的部分文本是一个句子。

SEPARATE_DOCUMENTS_COLLATED_COPIES - Static variable in class java.awt. JobAttributes.MultipleDocumentHandlingType

MultipleDocumentHandlingType实例用于指定作业应分为单独的整理副本。

SEPARATE_DOCUMENTS_COLLATED_COPIES - Static variable in class javax.print.attribute.standard. MultipleDocumentHandling

单独的文件整理副本 - 见上文 further information 。

SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - Static variable in class java.awt. JobAttributes.MultipleDocumentHandlingType

MultipleDocumentHandlingType实例用于指定作业应分为单独的未分类的副本。

SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - Static variable in class javax.print.attribute.standard. MultipleDocumentHandling

单独的文件未复印件 - 见上文 further information 。

separator - Static variable in class java.io. File

与系统相关的默认名称 - 分隔符字符，以方便的方式表示为字符串。

Separator - Class in javafx.scene.control

水平或垂直分隔线。

Separator() - Constructor for class javafx.scene.control. Separator

创建一个新的水平分隔符，其中的对齐和对齐设置为它们各自的CENTER值。

Separator() - Constructor for class javax.swing. JPopupMenu.Separator

构造一个弹出菜单特定的分隔符。

Separator() - Constructor for class javax.swing. JToolBar.Separator

创建一个新的工具栏分隔符，其默认大小由当前的外观所定义。

Separator(Dimension) - Constructor for class javax.swing. JToolBar.Separator

创建一个具有指定大小的新工具栏分隔符。

Separator(Orientation) - Constructor for class javafx.scene.control. Separator

创建一个新的分隔符，其中的对齐和赋值设置为它们各自的CENTER值。

SEPARATOR - javafx.scene.input. KeyCode

Numpad Separator键的常数。

SEPARATOR - Static variable in class javax.accessibility. AccessibleRole

通常包含在菜单中的对象以提供菜单中的内容的视觉和逻辑分离。

SEPARATOR - Static variable in class javax.swing.plaf.synth. Region

分隔区。

separatorChar - Static variable in class java.io. File

与系统相关的默认名称分隔符。

SeparatorMenuItem - Class in javafx.scene.control

A MenuItem ，如名称所示，允许在其中嵌入一个水平分隔符，通过将Separator分配给content属性CustomMenuItem，这是为了方便起见而提供的，可以通过分隔符分隔menuitems 。

SeparatorMenuItem() - Constructor for class javafx.scene.control. SeparatorMenuItem

创建一个默认的SeparatorMenuItem实例。

SeparatorSkin - Class in javafx.scene.control.skin

默认皮肤实现为Separator控件。

SeparatorSkin(Separator) - Constructor for class javafx.scene.control.skin. SeparatorSkin

创建一个新的SeparatorSkin实例，将必需的子节点安装到控件 children列表中。

SeparatorUI - Class in javax.swing.plaf

JSeparator可插拔的外观和界面。

SeparatorUI() - Constructor for class javax.swing.plaf. SeparatorUI

SepiaTone - Class in javafx.scene.effect

一个过滤器，产生棕褐色调效果，类似于古董照片。

SepiaTone() - Constructor for class javafx.scene.effect. SepiaTone

使用默认参数创建一个新的SepiaTone实例。

SepiaTone(double) - Constructor for class javafx.scene.effect. SepiaTone

以指定级别创建一个新的SepiaTone实例。

SEPTEMBER - java.time. Month

9月份的单身实例，30天。

SEPTEMBER - Static variable in class java.util. Calendar

Calendar.MONTH字段的值代表了公历和朱利安日历中的第九个月。

SEPTEMBER - Static variable in class javax.xml.datatype. DatatypeConstants

一年的第九个月的价值

Sequence - Class in javax.sound.midi

A Sequence是包含可由Sequencer对象重放的音乐信息（通常是整个歌曲或作曲）的数据结构。

Sequence(float, int) - Constructor for class javax.sound.midi. Sequence

构造具有指定的时序分割类型和时序分辨率的新MIDI序列。

Sequence(float, int, int) - Constructor for class javax.sound.midi. Sequence

构造一个具有指定的时序分割类型，时序分辨率和轨道数的新MIDI序列。

sequenceComplete(ImageReader) - Method in interface javax.imageio.event. IIOReadProgressListener

报告一系列读取操作已完成。

SequenceInputStream - Class in java.io

A SequenceInputStream表示其他输入流的逻辑级联。

SequenceInputStream(InputStream, InputStream) - Constructor for class java.io. SequenceInputStream

通过记住两个参数来初始化新创建的 SequenceInputStream ，这两个参数将按顺序读取，第一个是 s1 ，然后是 s2 ，以提供从这个 SequenceInputStream读取的字节。

SequenceInputStream(Enumeration<? extends InputStream>) - Constructor for class java.io. SequenceInputStream

初始化新创建 SequenceInputStream通过记住参数，它必须是一个 Enumeration产生对象，它们的运行时类型是 InputStream 。

sequenceNumber() - Method in class javax.net.ssl. SSLEngineResult

返回生成或消费的SSL / TLS / DTLS记录的序列号（可选操作）。

Sequencer - Interface in javax.sound.midi

播放MIDI sequence的硬件或软件设备被称为音序器 。

Sequencer.SyncMode - Class in javax.sound.midi

一个 SyncMode对象表示MIDI音序器的时间概念可以与主设备或从设备同步的方式之一。

sequenceStarted(ImageReader, int) - Method in interface javax.imageio.event. IIOReadProgressListener

报告一系列读操作开始。

sequential() - Method in interface java.util.stream. BaseStream

返回顺序的等效流。

sequential() - Method in interface java.util.stream. DoubleStream

sequential() - Method in interface java.util.stream. IntStream

sequential() - Method in interface java.util.stream. LongStream

SequentialTransition - Class in javafx.animation

这Transition剧目Animations顺序排列。

SequentialTransition() - Constructor for class javafx.animation. SequentialTransition

构造函数为 SequentialTransition 。

SequentialTransition(Animation...) - Constructor for class javafx.animation. SequentialTransition

构造函数为 SequentialTransition 。

SequentialTransition(Node) - Constructor for class javafx.animation. SequentialTransition

构造函数为 SequentialTransition 。

SequentialTransition(Node, Animation...) - Constructor for class javafx.animation. SequentialTransition

构造函数为 SequentialTransition 。

SERIAL - com.sun.source.doctree. DocTree.Kind

用于实例SerialTree表示@serial标签。

SERIAL_DATA - com.sun.source.doctree. DocTree.Kind

用于实例SerialDataTree表示@serialData标签。

SERIAL_FIELD - com.sun.source.doctree. DocTree.Kind

用于表示@serialField标记的SerialFieldTree的实例。

SERIAL_FILTER_PERMISSION - Static variable in interface java.io. ObjectStreamConstants

启用设置过程范围的串行过滤器。

SerialArray - Class in javax.sql.rowset.serial

Array对象的序列化版本，它是Java编程语言中的一个SQL ARRAY值的映射。

SerialArray(Array) - Constructor for class javax.sql.rowset.serial. SerialArray

构造一个新 SerialArray从给定对象 Array对象。

SerialArray(Array, Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial. SerialArray

从给定的 Array对象构造一个新的 SerialArray对象，当元素为SQL UDT时，使用给定的类型映射来定制每个元素的映射。

SerialBlob - Class in javax.sql.rowset.serial

一个序列化映射的Java编程语言中的一个SQL BLOB值。

SerialBlob(byte[]) - Constructor for class javax.sql.rowset.serial. SerialBlob

构造一个 SerialBlob对象，它是给定的 byte数组的序列化版本。

SerialBlob(Blob) - Constructor for class javax.sql.rowset.serial. SerialBlob

构造一个 SerialBlob对象，它是给定的 Blob对象的序列化版本。

serialClass() - Method in interface java.io. ObjectInputFilter.FilterInfo

被反序列化的对象的类。

SerialClob - Class in javax.sql.rowset.serial

一个序列化的映射在Java编程语言中的一个SQL CLOB值。

SerialClob(char[]) - Constructor for class javax.sql.rowset.serial. SerialClob

构造一个 SerialClob对象，它是给定的 char数组的序列化版本。

SerialClob(Clob) - Constructor for class javax.sql.rowset.serial. SerialClob

构造一个 SerialClob对象，它是给定的 Clob对象的序列化版本。

SerialDatalink - Class in javax.sql.rowset.serial

在Java编程语言中的序列化映射的SQL DATALINK值。

SerialDatalink(URL) - Constructor for class javax.sql.rowset.serial. SerialDatalink

构造一个新 SerialDatalink从给定对象 java.net.URL对象。

SerialDataTree - Interface in com.sun.source.doctree

@serialData块标记的树节点。

SerialException - Exception in javax.sql.rowset.serial

指示和错误的序列化或 BLOB, CLOB, STRUCT or ARRAY序列化的SQL类型，如 BLOB, CLOB, STRUCT or ARRAY除了SQL类型，如 DATALINK and JAVAOBJECT

SerialException() - Constructor for exception javax.sql.rowset.serial. SerialException

创建一个新的 SerialException没有消息。

SerialException(String) - Constructor for exception javax.sql.rowset.serial. SerialException

创建一个新的 SerialException与指定的消息。

SerialFieldTag - Interface in com.sun.javadoc

已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

serialFieldTags() - Method in interface com.sun.javadoc. FieldDoc

已过时。

返回此FieldDoc项中的serialField标记。

SerialFieldTree - Interface in com.sun.source.doctree

@serialData块标记的树节点。

serializable - Variable in class java.beans.beancontext. BeanContextServicesSupport

可串行化的数量 BeanContextServceProvider 。

Serializable - Interface in java.io

类的序列化由实现java.io.Serializable接口的类启用。

serializableFields() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回此类或接口的Serializable字段。

SerializablePermission - Class in java.io

这个类用于Serializable权限。

SerializablePermission(String) - Constructor for class java.io. SerializablePermission

创建一个具有指定名称的新SerializablePermission。

SerializablePermission(String, String) - Constructor for class java.io. SerializablePermission

创建一个具有指定名称的新SerializablePermission对象。

serializationMethods() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回此类或接口的序列化方法。

serialize(ObjectOutputStream, Collection<?>) - Method in class java.beans.beancontext. BeanContextSupport

由writeObject用于序列化集合。

SERIALIZE_ERR - Static variable in exception org.w3c.dom.ls. LSException

如果试图序列化 Node使用 LSSerializer和处理已经停止。

SerializedLambda - Class in java.lang.invoke

lambda表达式的序列化形式。

SerializedLambda(Class<?>, String, String, String, int, String, String, String, String, Object[]) - Constructor for class java.lang.invoke. SerializedLambda

从lambda工厂现场的低级信息中创建一个 SerializedLambda 。

SerialJavaObject - Class in javax.sql.rowset.serial

在Java编程语言中的可序列化映射的SQL JAVA_OBJECT值。

SerialJavaObject(Object) - Constructor for class javax.sql.rowset.serial. SerialJavaObject

SerialJavaObject助手类的构造方法。

SerialRef - Class in javax.sql.rowset.serial

一个 Ref对象的序列化映射，它是Java编程语言中的一个SQL REF值的映射。

SerialRef(Ref) - Constructor for class javax.sql.rowset.serial. SerialRef

构造一个 SerialRef从给定对象 Ref对象。

SerialStruct - Class in javax.sql.rowset.serial

SQL编程语言中的SQL结构化类型的序列化映射。

SerialStruct(SQLData, Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial. SerialStruct

从给定的 SQLData对象构造一个 SerialStruct对象，使用给定的类型映射将其定制到Java编程语言中的类。

SerialStruct(Struct, Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial. SerialStruct

从给定的 Struct对象构造一个 SerialStruct对象，使用给定的 java.util.Map对象来自定义映射SQL结构类型或其任何属性是SQL结构化类型。

SerialTree - Interface in com.sun.source.doctree

@serial块标记的树节点。

serialVersionUID - Static variable in interface java.rmi.server. RemoteRef

表示与JDK 1.1.x版本的类的兼容性。

serialVersionUID - Static variable in interface java.rmi.server. ServerRef

已过时。

表示与JDK 1.1.x版本的类的兼容性。

serialVersionUID - Static variable in interface java.security.interfaces. DSAPrivateKey

类指纹被设置为指示与以前版本的类的序列化兼容性。

serialVersionUID - Static variable in interface java.security.interfaces. DSAPublicKey

类指纹被设置为指示与以前版本的类的序列化兼容性。

serialVersionUID - Static variable in interface java.security.interfaces. ECPrivateKey

设置为指示序列化兼容性的类指纹。

serialVersionUID - Static variable in interface java.security.interfaces. ECPublicKey

设置为指示序列化兼容性的类指纹。

serialVersionUID - Static variable in interface java.security.interfaces. RSAMultiPrimePrivateCrtKey

类型指纹被设置为指示与以前版本的类型的序列化兼容性。

serialVersionUID - Static variable in interface java.security.interfaces. RSAPrivateCrtKey

类型指纹被设置为指示与以前版本的类型的序列化兼容性。

serialVersionUID - Static variable in interface java.security.interfaces. RSAPrivateKey

类型指纹被设置为指示与以前版本的类型的序列化兼容性。

serialVersionUID - Static variable in interface java.security.interfaces. RSAPublicKey

类型指纹被设置为指示与以前版本的类型的序列化兼容性。

serialVersionUID - Static variable in interface java.security. Key

类指纹被设置为指示与以前版本的类的序列化兼容性。

serialVersionUID - Static variable in interface java.security. PrivateKey

类指纹被设置为指示与以前版本的类的序列化兼容性。

serialVersionUID - Static variable in interface java.security. PublicKey

类指纹被设置为指示与以前版本的类的序列化兼容性。

serialVersionUID - Static variable in interface javax.crypto.interfaces. DHPrivateKey

从J2SE 1.4起设置为指示序列化兼容性的类指纹。

serialVersionUID - Static variable in interface javax.crypto.interfaces. DHPublicKey

从J2SE 1.4起设置为指示序列化兼容性的类指纹。

serialVersionUID - Static variable in interface javax.crypto.interfaces. PBEKey

从J2SE 1.4起设置为指示序列化兼容性的类指纹。

serialVersionUID - Static variable in interface javax.crypto. SecretKey

从J2SE 1.4起设置为指示序列化兼容性的类指纹。

serialVersionUID - Static variable in interface javax.naming.directory. Attribute

使用JNDI 1.1.1的serialVersionUID进行互操作。

serialVersionUID - Static variable in interface javax.naming. Name

类指纹被设置为指示与以前版本的类的序列化兼容性。

Series() - Constructor for class javafx.scene.chart. XYChart.Series

构建一个空的系列

Series(String, ObservableList<XYChart.Data<X, Y>>) - Constructor for class javafx.scene.chart. XYChart.Series

构造一个命名的系列，并使用给定的ObservableList数据填充它。

Series(ObservableList<XYChart.Data<X, Y>>) - Constructor for class javafx.scene.chart. XYChart.Series

构造一个系列，并使用给定的ObservableList数据填充它。

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. AreaChart

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. BarChart

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. BubbleChart

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. LineChart

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. ScatterChart

一系列已经添加到图表数据模型中。

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. StackedAreaChart

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. StackedBarChart

一系列已经添加到图表数据模型中。

seriesAdded(XYChart.Series<X, Y>, int) - Method in class javafx.scene.chart. XYChart

一系列已经添加到图表数据模型中。

seriesChanged(ListChangeListener.Change<? extends XYChart.Series>) - Method in class javafx.scene.chart. AreaChart

seriesChanged(ListChangeListener.Change<? extends XYChart.Series>) - Method in class javafx.scene.chart. BarChart

seriesChanged(ListChangeListener.Change<? extends XYChart.Series>) - Method in class javafx.scene.chart. LineChart

seriesChanged(ListChangeListener.Change<? extends XYChart.Series>) - Method in class javafx.scene.chart. StackedAreaChart

seriesChanged(ListChangeListener.Change<? extends XYChart.Series>) - Method in class javafx.scene.chart. StackedBarChart

seriesChanged(ListChangeListener.Change<? extends XYChart.Series>) - Method in class javafx.scene.chart. XYChart

当将每个原子更改作为此图表的系列列表时调用

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. AreaChart

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. BarChart

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. BubbleChart

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. LineChart

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. ScatterChart

数据模型中已经删除了一个系列，但它仍然可以在图表上显示。

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. StackedAreaChart

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. StackedBarChart

seriesRemoved(XYChart.Series<X, Y>) - Method in class javafx.scene.chart. XYChart

数据模型中已经删除了一个系列，但它仍然可以在图表上显示。

SERIF - Static variable in class java.awt. Font

逻辑字体“Serif”的规范系列名称的字符串常量。

servant - Variable in class org.omg.CORBA.portable. ServantObject

真正的仆人。

Servant - Class in org.omg.PortableServer

定义本机 Servant类型。

Servant() - Constructor for class org.omg.PortableServer. Servant

servant_postinvoke(Object, ServantObject) - Method in class org.omg.CORBA.portable. Delegate

在本地服务器上调用操作后，本地存根调用servant_postinvoke（）。

servant_preinvoke(Object, String, Class) - Method in class org.omg.CORBA.portable. Delegate

返回应用于此请求的servant的Java引用。 servant_preinvoke（）由本地存根调用。

SERVANT_RETENTION_POLICY_ID - Interface in org.omg.PortableServer

org / omg / PortableServer / SERVANT_RETENTION_POLICY_ID.java。

servant_to_id(Servant) - Method in interface org.omg.PortableServer. POAOperations

此操作有四种可能的行为。 1。

servant_to_reference(Servant) - Method in interface org.omg.PortableServer. POAOperations

此操作需要RETAIN策略，如果在此POA发出的操作的上下文中被调用，则需要UNIQUE_ID或IMPLICIT_ACTIVATION策略。

ServantActivator - Interface in org.omg.PortableServer

当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。

ServantActivatorHelper - Class in org.omg.PortableServer

当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。

ServantActivatorHelper() - Constructor for class org.omg.PortableServer. ServantActivatorHelper

ServantActivatorOperations - Interface in org.omg.PortableServer

当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。

ServantActivatorPOA - Class in org.omg.PortableServer

当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。

ServantActivatorPOA() - Constructor for class org.omg.PortableServer. ServantActivatorPOA

ServantAlreadyActive - Exception in org.omg.PortableServer.POAPackage

org / omg / PortableServer / POAPackage / ServantAlreadyActive.java。

ServantAlreadyActive() - Constructor for exception org.omg.PortableServer.POAPackage. ServantAlreadyActive

ServantAlreadyActive(String) - Constructor for exception org.omg.PortableServer.POAPackage. ServantAlreadyActive

ServantAlreadyActiveHelper - Class in org.omg.PortableServer.POAPackage

org / omg / PortableServer / POAPackage / ServantAlreadyActiveHelper.java。

ServantAlreadyActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage. ServantAlreadyActiveHelper

ServantLocator - Interface in org.omg.PortableServer

当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。

ServantLocatorHelper - Class in org.omg.PortableServer

当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。

ServantLocatorHelper() - Constructor for class org.omg.PortableServer. ServantLocatorHelper

ServantLocatorOperations - Interface in org.omg.PortableServer

当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。

ServantLocatorPOA - Class in org.omg.PortableServer

当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。

ServantLocatorPOA() - Constructor for class org.omg.PortableServer. ServantLocatorPOA

ServantManager - Interface in org.omg.PortableServer

当POA接收到针对非活动对象的请求时，仆人经理为POA提供激活对象的能力。

ServantManagerOperations - Interface in org.omg.PortableServer

当POA接收到针对非活动对象的请求时，仆人经理为POA提供激活对象的能力。

ServantNotActive - Exception in org.omg.PortableServer.POAPackage

org / omg / PortableServer / POAPackage / ServantNotActive.java。

ServantNotActive() - Constructor for exception org.omg.PortableServer.POAPackage. ServantNotActive

ServantNotActive(String) - Constructor for exception org.omg.PortableServer.POAPackage. ServantNotActive

ServantNotActiveHelper - Class in org.omg.PortableServer.POAPackage

org / omg / PortableServer / POAPackage / ServantNotActiveHelper.java。

ServantNotActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage. ServantNotActiveHelper

ServantObject - Class in org.omg.CORBA.portable

该类是本地存根API的一部分，其目的是为并置的客户端和服务器（即驻留在同一Java VM中的客户端和服务器）提供高性能调用。

ServantObject() - Constructor for class org.omg.CORBA.portable. ServantObject

ServantRetentionPolicy - Interface in org.omg.PortableServer

此策略指定创建的POA是否在活动对象映射中保留活动服务器。

ServantRetentionPolicyOperations - Interface in org.omg.PortableServer

此策略指定创建的POA是否在活动对象映射中保留活动服务器。

ServantRetentionPolicyValue - Class in org.omg.PortableServer

ServantRetentionPolicyValue可以具有以下值。

ServantRetentionPolicyValue(int) - Constructor for class org.omg.PortableServer. ServantRetentionPolicyValue

server - Variable in class javax.management.monitor. Monitor

引用MBean服务器。

SERVER - java.net. Authenticator.RequestorType

请求身份验证的实体是HTTP源服务器。

SERVER_AUTH - Static variable in class javax.security.sasl. Sasl

指定服务器是否必须向客户端进行身份验证的属性的名称。

server_id() - Method in interface org.omg.PortableInterceptor. ObjectReferenceTemplate

server_id() - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations

返回使用-ORBServerId参数在ORB :: init上指定的服务器ID。

ServerCloneException - Exception in java.rmi.server

甲 ServerCloneException如果一个的克隆过程中发生远程抛出异常 UnicastRemoteObject 。

ServerCloneException(String) - Constructor for exception java.rmi.server. ServerCloneException

构造具有指定详细消息的 ServerCloneException 。

ServerCloneException(String, Exception) - Constructor for exception java.rmi.server. ServerCloneException

构造一个具有指定的详细信息和原因的 ServerCloneException 。

ServerError - Exception in java.rmi

甲 ServerError被抛出作为远程方法调用的结果，当一个 Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。

ServerError(String, Error) - Constructor for exception java.rmi. ServerError

构造具有指定的详细消息和嵌套错误的 ServerError 。

ServerException - Exception in java.rmi

当处理在服务器上的调用时抛出一个 RemoteException ，或者在解组参数或执行远程方法本身时，抛出 ServerException作为远程方法调用的结果。

ServerException(String) - Constructor for exception java.rmi. ServerException

构造具有指定详细消息的 ServerException 。

ServerException(String, Exception) - Constructor for exception java.rmi. ServerException

构造具有指定的详细消息和嵌套异常的 ServerException 。

ServerIdHelper - Class in org.omg.PortableInterceptor

org / omg / PortableInterceptor / ServerIdHelper.java。

ServerIdHelper() - Constructor for class org.omg.PortableInterceptor. ServerIdHelper

ServerNotActiveException - Exception in java.rmi.server

如果在服务远程方法调用之外调用getClientHost方法，那么 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。

ServerNotActiveException() - Constructor for exception java.rmi.server. ServerNotActiveException

构造一个没有指定详细消息的 ServerNotActiveException 。

ServerNotActiveException(String) - Constructor for exception java.rmi.server. ServerNotActiveException

构造具有指定详细消息的 ServerNotActiveException 。

ServerRef - Interface in java.rmi.server

已过时。
没有替换 此接口未使用，已过时。

ServerRequest - Class in org.omg.CORBA

捕获动态骨架接口（DSI）请求的显式状态的对象。

ServerRequest() - Constructor for class org.omg.CORBA. ServerRequest

ServerRequestInfo - Interface in org.omg.PortableInterceptor

请求信息，可由服务器端请求拦截器访问。

ServerRequestInfoOperations - Interface in org.omg.PortableInterceptor

请求信息，可由服务器端请求拦截器访问。

ServerRequestInterceptor - Interface in org.omg.PortableInterceptor

服务器端请求拦截器。

ServerRequestInterceptorOperations - Interface in org.omg.PortableInterceptor

服务器端请求拦截器。

ServerRuntimeException - Exception in java.rmi

已过时。
没有替换

ServerRuntimeException(String, Exception) - Constructor for exception java.rmi. ServerRuntimeException

已过时。
没有替换

ServerSocket - Class in java.net

这个类实现了服务器套接字。

ServerSocket() - Constructor for class java.net. ServerSocket

创建未绑定的服务器套接字。

ServerSocket(int) - Constructor for class java.net. ServerSocket

创建绑定到指定端口的服务器套接字。

ServerSocket(int, int) - Constructor for class java.net. ServerSocket

创建服务器套接字并将其绑定到指定的本地端口号，并指定了积压。

ServerSocket(int, int, InetAddress) - Constructor for class java.net. ServerSocket

创建一个具有指定端口的服务器，侦听backlog和本地IP地址绑定。

ServerSocketChannel - Class in java.nio.channels

用于面向流的侦听套接字的可选通道。

ServerSocketChannel(SelectorProvider) - Constructor for class java.nio.channels. ServerSocketChannel

初始化此类的新实例。

ServerSocketFactory - Class in javax.net

此类创建服务器套接字。

ServerSocketFactory() - Constructor for class javax.net. ServerSocketFactory

创建服务器插座工厂。

service() - Method in class java.lang.module. ModuleDescriptor.Provides

返回服务类型的完全限定类名。

Service< V> - Class in javafx.concurrent

服务是一个非可视化组件，封装了在一个或多个后台线程上执行某些工作所需的信息。

Service - Class in javax.xml.ws

Service对象提供Web服务的客户端视图。

Service() - Constructor for class javafx.concurrent. Service

创建一个新的服务。

Service(URL, QName) - Constructor for class javax.xml.ws. Service

创建一个 Service 。

Service(URL, QName, WebServiceFeature...) - Constructor for class javax.xml.ws. Service

创建一个 Service 。

Service(Provider, String, String, String, List<String>, Map<String, String>) - Constructor for class java.security. Provider.Service

构建新服务

service_detail - Variable in class org.omg.CORBA. ServiceDetail

描述该 ServiceDetail对象所代表的ORB服务的数据。

service_detail_type - Variable in class org.omg.CORBA. ServiceDetail

此 ServiceDetail对象表示的ORB服务的类型。

service_details - Variable in class org.omg.CORBA. ServiceInformation

ServiceDetails数组，提供有关该服务的更多细节。

SERVICE_FORMATTED(String) - Constructor for class javax.print. DocFlavor.SERVICE_FORMATTED

构造一个新的文档风格，MIME类型为 "application/x-java-jvm-local-objectref"表示服务格式化的打印数据和给定的打印数据表示类名。

SERVICE_OFF_LINE - Static variable in class javax.print.attribute.standard. JobStateReason

打印机是离线的，不接受任务。

service_options - Variable in class org.omg.CORBA. ServiceInformation

表示服务选项的int数组。

Service.Mode - Enum in javax.xml.ws

动态客户端或服务的方向。

serviceAvailable(BeanContextServiceAvailableEvent) - Method in class java.beans.beancontext. BeanContextChildSupport

嵌套BeanContext提供了新的服务。

serviceAvailable(BeanContextServiceAvailableEvent) - Method in interface java.beans.beancontext. BeanContextServicesListener

已命名的服务已注册。 此服务的getService请求现在可以进行。

serviceAvailable(BeanContextServiceAvailableEvent) - Method in class java.beans.beancontext. BeanContextServicesSupport

BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。

serviceClass - Variable in class java.beans.beancontext. BeanContextServiceAvailableEvent

A Class对新提供的服务的引用

serviceClass - Variable in class java.beans.beancontext. BeanContextServiceRevokedEvent

A Class对正在撤销的服务的引用。

ServiceConfigurationError - Error in java.util

在查找，加载或实例化服务提供商时发生错误时发生错误。

ServiceConfigurationError(String) - Constructor for error java.util. ServiceConfigurationError

使用指定的消息构造新的实例。

ServiceConfigurationError(String, Throwable) - Constructor for error java.util. ServiceConfigurationError

构造具有指定消息和原因的新实例。

ServiceContext - Class in org.omg.IOP

org / omg / IOP / ServiceContext.java。

ServiceContext() - Constructor for class org.omg.IOP. ServiceContext

ServiceContext(int, byte[]) - Constructor for class org.omg.IOP. ServiceContext

ServiceContextHelper - Class in org.omg.IOP

org / omg / IOP / ServiceContextHelper.java。

ServiceContextHelper() - Constructor for class org.omg.IOP. ServiceContextHelper

ServiceContextHolder - Class in org.omg.IOP

org / omg / IOP / ServiceContextHolder.java。

ServiceContextHolder() - Constructor for class org.omg.IOP. ServiceContextHolder

ServiceContextHolder(ServiceContext) - Constructor for class org.omg.IOP. ServiceContextHolder

ServiceContextListHelper - Class in org.omg.IOP

一组服务上下文，形成一个服务上下文列表。

ServiceContextListHelper() - Constructor for class org.omg.IOP. ServiceContextListHelper

ServiceContextListHolder - Class in org.omg.IOP

一组服务上下文，形成一个服务上下文列表。

ServiceContextListHolder() - Constructor for class org.omg.IOP. ServiceContextListHolder

ServiceContextListHolder(ServiceContext[]) - Constructor for class org.omg.IOP. ServiceContextListHolder

ServiceDelegate - Class in javax.xml.ws.spi

服务代表在内部由 Service对象使用，以允许JAX-WS实现的可插拔性。

ServiceDelegate() - Constructor for class javax.xml.ws.spi. ServiceDelegate

默认构造函数。

ServiceDetail - Class in org.omg.CORBA

表示ORB服务的对象：其 service_detail_type字段包含ORB服务的类型，其 service_detail字段包含ORB服务的描述。

ServiceDetail() - Constructor for class org.omg.CORBA. ServiceDetail

构造一个 ServiceDetail对象，其中0表示ORB服务的类型和一个空说明。

ServiceDetail(int, byte[]) - Constructor for class org.omg.CORBA. ServiceDetail

使用给定的ORB服务类型和给定的描述构造一个 ServiceDetail对象。

ServiceDetailHelper - Class in org.omg.CORBA

ServiceDetailHelper() - Constructor for class org.omg.CORBA. ServiceDetailHelper

ServiceIdHelper - Class in org.omg.IOP

一个服务ID，表示为int

ServiceIdHelper() - Constructor for class org.omg.IOP. ServiceIdHelper

ServiceInformation - Class in org.omg.CORBA

CORBA模块中的IDL结构，用于存储有关ORB实现中可用的CORBA服务的信息，并从 ORB.get_service_information方法获取。

ServiceInformation() - Constructor for class org.omg.CORBA. ServiceInformation

构造具有空的service_options和service_details的ServiceInformation对象。

ServiceInformation(int[], ServiceDetail[]) - Constructor for class org.omg.CORBA. ServiceInformation

使用给定的service_options和service_details构造一个ServiceInformation对象。

ServiceInformationHelper - Class in org.omg.CORBA

ServiceInformationHelper() - Constructor for class org.omg.CORBA. ServiceInformationHelper

ServiceInformationHolder - Class in org.omg.CORBA

持有人 ServiceInformation 。

ServiceInformationHolder() - Constructor for class org.omg.CORBA. ServiceInformationHolder

构造一个新的 ServiceInformationHolder对象，其 value字段初始化为null。

ServiceInformationHolder(ServiceInformation) - Constructor for class org.omg.CORBA. ServiceInformationHolder

构造一个新的 ServiceInformationHolder对象，其 value字段初始化为给定的 ServiceInformation对象。

ServiceLoader< S> - Class in java.util

一种加载服务实现的工具。

ServiceLoader.Provider< S> - Interface in java.util

代表由 ServiceLoader位于的服务提供商。

ServiceManager - Class in javax.jnlp

ServiceManager提供了查找JNLP服务的静态方法。

ServiceManagerStub - Interface in javax.jnlp

一个 ServiceManagerStub对象实现JNLP客户端对JNLP服务的特定查找。

ServiceMode - Annotation Type in javax.xml.ws

用于指示Provider实现是否希望使用整个协议消息或仅使用协议消息有效载荷。

serviceName(QName) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder

将 serviceName设置为 wsam:ServiceName元素中的 wsa:Metadata元素。

ServiceNotFoundException - Exception in javax.management

表示不支持请求的服务时引发的异常。

ServiceNotFoundException() - Constructor for exception javax.management. ServiceNotFoundException

默认构造函数。

ServiceNotFoundException(String) - Constructor for exception javax.management. ServiceNotFoundException

允许指定特定错误消息的构造方法。

ServicePermission - Class in javax.security.auth.kerberos

此类用于保护Kerberos服务和访问这些服务所必需的凭据。

ServicePermission(String, String) - Constructor for class javax.security.auth.kerberos. ServicePermission

创建一个新的 ServicePermission与指定的 servicePrincipal和 action 。

serviceProvider - Variable in class java.beans.beancontext. BeanContextServicesSupport.BCSSServiceProvider

服务提供商。

ServiceRegistry - Class in javax.imageio.spi

服务提供商实例的注册表。

ServiceRegistry(Iterator<Class<?>>) - Constructor for class javax.imageio.spi. ServiceRegistry

构造一个 ServiceRegistry实例，其中包含从 categories参数获取的一组类别。

ServiceRegistry.Filter - Interface in javax.imageio.spi

ServiceRegistry.getServiceProviders使用的简单过滤器接口来选择与任意标准匹配的提供者。

serviceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext. BeanContextChildSupport

嵌套BeanContext提供的服务已被撤销。

serviceRevoked(BeanContextServiceRevokedEvent) - Method in interface java.beans.beancontext. BeanContextServiceRevokedListener

已命名的服务已被撤销。 此服务的getService请求将不再满足。

serviceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext. BeanContextServicesSupport.BCSSProxyServiceProvider

serviceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext. BeanContextServicesSupport

BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。

services - Variable in class java.beans.beancontext. BeanContextServicesSupport

protected transient HashMap services字段的所有访问应该在该对象上同步

ServiceUI - Class in javax.print

该类是UI便利方法的集合，其提供用于浏览通过Java Print Service API查找的打印服务的图形用户对话框。

ServiceUI() - Constructor for class javax.print. ServiceUI

ServiceUIFactory - Class in javax.print

服务可以可选地提供UI，其允许不同角色的不同风格的交互。

ServiceUIFactory() - Constructor for class javax.print. ServiceUIFactory

ServiceUnavailableException - Exception in javax.naming

尝试与目录或命名服务通信并且该服务不可用时，会抛出此异常。

ServiceUnavailableException() - Constructor for exception javax.naming. ServiceUnavailableException

构造一个新的ServiceUnavailableException实例。

ServiceUnavailableException(String) - Constructor for exception javax.naming. ServiceUnavailableException

使用解释构造一个新的ServiceUnavailableException实例。

SERVLET_CONTEXT - Static variable in interface javax.xml.ws.handler. MessageContext

标准属性：servlet上下文对象。

SERVLET_REQUEST - Static variable in interface javax.xml.ws.handler. MessageContext

标准属性：servlet请求对象。

SERVLET_RESPONSE - Static variable in interface javax.xml.ws.handler. MessageContext

标准属性：servlet响应对象。

SESSION_MAINTAIN_PROPERTY - Static variable in interface javax.xml.ws. BindingProvider

标准属性：此布尔属性由服务客户端用于指示是否要参与与服务端点的会话。

set(boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。

set(boolean) - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty

设置包装的值。

set(boolean) - Method in class javafx.beans.property. BooleanPropertyBase

设置包装的值。

set(boolean) - Method in interface javafx.beans.value. WritableBooleanValue

设置包装的值。

set(boolean) - Method in class javafx.css. StyleableBooleanProperty

设置包装的值。

set(byte, int) - Method in class java.awt.image.renderable. ParameterBlock

使用字节替换参数列表中的对象。

set(char, int) - Method in class java.awt.image.renderable. ParameterBlock

用Character替换参数列表中的Object。

set(double) - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty

设置包装的值。

set(double) - Method in class javafx.beans.property. DoublePropertyBase

设置包装的值。

set(double) - Method in interface javafx.beans.value. WritableDoubleValue

设置包装的值。

set(double) - Method in class javafx.css. StyleableDoubleProperty

设置包装的值。

set(double, int) - Method in class java.awt.image.renderable. ParameterBlock

用Double替换参数列表中的对象。

set(float) - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty

设置包装的值。

set(float) - Method in class javafx.beans.property. FloatPropertyBase

设置包装的值。

set(float) - Method in interface javafx.beans.value. WritableFloatValue

设置包装的值。

set(float) - Method in class javafx.css. StyleableFloatProperty

设置包装的值。

set(float, int) - Method in class java.awt.image.renderable. ParameterBlock

用Float替换参数列表中的对象。

set(int) - Method in class java.util. BitSet

将指定索引处的位设置为 true 。

set(int) - Method in class java.util.concurrent.atomic. AtomicInteger

将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。

set(int) - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty

设置包装的值。

set(int) - Method in class javafx.beans.property. IntegerPropertyBase

设置包装的值。

set(int) - Method in interface javafx.beans.value. WritableIntegerValue

设置包装的值。

set(int) - Method in class javafx.css. StyleableIntegerProperty

设置包装的值。

set(int, boolean) - Method in class java.util. BitSet

将指定索引处的位设置为指定值。

set(int, float) - Method in interface javafx.collections. ObservableFloatArray

在数组中设置单个值。

set(int, float[], int, int) - Method in interface javafx.collections. ObservableFloatArray

将指定数组的一部分复制到此observable数组中。

set(int, int) - Method in class java.awt.image.renderable. ParameterBlock

用Integer替换参数列表中的Object。

set(int, int) - Method in class java.util. BitSet

将指定的 fromIndex （含）的位设置为 toIndex （排他）到 true 。

set(int, int) - Method in class java.util. Calendar.Builder

将 field参数设置为给定的 value 。

set(int, int) - Method in class java.util. Calendar

将给定的日历字段设置为给定的值。

set(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。

set(int, int) - Method in interface javafx.collections. ObservableIntegerArray

在数组中设置单个值。

set(int, int[], int, int) - Method in interface javafx.collections. ObservableIntegerArray

将指定数组的一部分复制到此observable数组中。

set(int, int, boolean) - Method in class java.util. BitSet

将指定的 fromIndex （含）的位设置为指定的 fromIndex toIndex （排除）。

set(int, int, int) - Method in class java.util. Calendar

设置日历字段的值 YEAR ， MONTH ，并 DAY_OF_MONTH 。

set(int, int, int, int) - Method in class java.awt. Insets

将顶部，左侧，底部和右侧设置为指定的值

set(int, int, int, int, int) - Method in class java.util. Calendar

设置日历字段的值 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR_OF_DAY ，并 MINUTE 。

set(int, int, int, int, int, int) - Method in class java.util. Calendar

设置字段中的值 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR_OF_DAY ， MINUTE ，并 SECOND 。

set(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。

set(int, E) - Method in class java.util. AbstractList

用指定的元素（可选操作）替换此列表中指定位置的元素。

set(int, E) - Method in class java.util. AbstractSequentialList

用指定的元素（可选操作）替换此列表中指定位置的元素。

set(int, E) - Method in class java.util. ArrayList

用指定的元素替换此列表中指定位置的元素。

set(int, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。

set(int, E) - Method in class java.util.concurrent. CopyOnWriteArrayList

用指定的元素替换此列表中指定位置的元素。

set(int, E) - Method in class java.util. LinkedList

用指定的元素替换此列表中指定位置的元素。

set(int, E) - Method in interface java.util. List

用指定的元素（可选操作）替换此列表中指定位置的元素。

set(int, E) - Method in class java.util. Vector

用指定的元素替换此Vector中指定位置的元素。

set(int, E) - Method in class javafx.beans.binding. ListExpression

set(int, E) - Method in class javafx.collections. ModifiableObservableListBase

set(int, E) - Method in class javax.swing. DefaultListModel

用指定的元素替换此列表中指定位置的元素。

set(int, Object) - Method in class javax.management. AttributeList

用指定的元素替换此列表中指定位置的元素。

set(int, Object) - Method in class javax.management.relation. RoleList

set(int, Object) - Method in class javax.management.relation. RoleUnresolvedList

set(int, Object) - Method in interface javax.naming.directory. Attribute

在属性值的有序列表中设置属性值。

set(int, Object) - Method in class javax.naming.directory. BasicAttribute

set(int, ObservableFloatArray, int, int) - Method in interface javafx.collections. ObservableFloatArray

将指定的可观察数组的一部分复制到此可观察数组中。

set(int, ObservableIntegerArray, int, int) - Method in interface javafx.collections. ObservableIntegerArray

将指定的可观察数组的一部分复制到此可观察数组中。

set(int, Attribute) - Method in class javax.management. AttributeList

将元素设置为指定的属性。

set(int, Role) - Method in class javax.management.relation. RoleList

将元素设置为指定的角色。

set(int, RoleUnresolved) - Method in class javax.management.relation. RoleUnresolvedList

将元素指定为指定的未解决角色。

set(long) - Method in class java.util.concurrent.atomic. AtomicLong

将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。

set(long) - Method in class javafx.beans.property.adapter. JavaBeanLongProperty

设置包装的值。

set(long) - Method in class javafx.beans.property. LongPropertyBase

设置包装的值。

set(long) - Method in interface javafx.beans.value. WritableLongValue

设置包装的值。

set(long) - Method in class javafx.css. StyleableLongProperty

设置包装的值。

set(long, int) - Method in class java.awt.image.renderable. ParameterBlock

用Long替换参数列表中的对象。

set(short, int) - Method in class java.awt.image.renderable. ParameterBlock

用Short替换参数列表中的对象。

set(E) - Method in interface java.util. ListIterator

将 ListIterator.next()或 ListIterator.previous()返回的最后一个元素替换为指定的元素（可选操作）。

set(JobAttributes) - Method in class java.awt. JobAttributes

将此 JobAttributes所有属性设置为与obj的属性相同的值。

set(PageAttributes) - Method in class java.awt. PageAttributes

将此PageAttributes的所有属性设置为与obj的属性相同的值。

set(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。

set(Object, int) - Method in class java.awt.image.renderable. ParameterBlock

替换参数列表中的对象。

set(Object, int, Object) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的新值。

set(Object, Object) - Method in class java.lang.reflect. Field

将指定对象参数上的此 Field对象表示的字段设置为指定的新值。

set(String) - Method in class javafx.beans.property.adapter. JavaBeanStringProperty

设置包装的值。

set(String) - Method in class javafx.beans.property. StringPropertyBase

设置包装的值。

set(String) - Method in class javafx.css. StyleableStringProperty

设置包装的值。

set(String, String) - Method in class com.sun.net.httpserver. Headers

将给定值设置为给定键的唯一标题值。

set(String, String) - Method in class javax.activation. MimeTypeParameterList

设置与给定名称相关联的值，替换任何先前的关联。

set(ObservableList<E>) - Method in class javafx.beans.property. ListPropertyBase

set(ObservableMap<K, V>) - Method in class javafx.beans.property. MapPropertyBase

set(ObservableSet<E>) - Method in class javafx.beans.property. SetPropertyBase

set(S, V, StyleOrigin) - Method in class javafx.css. CssMetaData

已过时。
此方法不再从CSS代码调用。 使用StyleableProperty.applyStyle(javafx.css.StyleOrigin, java.lang.Object)

set(T) - Method in class java.lang. ThreadLocal

将当前线程的此线程局部变量的副本设置为指定的值。

set(T) - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty

设置包装的值。

set(T) - Method in class javafx.beans.property. ObjectPropertyBase

设置包装的值。

set(T) - Method in interface javafx.beans.value. WritableObjectValue

设置包装的值。

set(T) - Method in class javafx.css. StyleableObjectProperty

设置包装的值。

set(T, int) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater

将由此更新程序管理的给定对象的字段设置为给定的更新值。

set(T, long) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater

将由此更新程序管理的给定对象的字段设置为给定的更新值。

set(T, V) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater

将由此更新程序管理的给定对象的字段设置为给定的更新值。

set(V) - Method in class java.util.concurrent.atomic. AtomicReference

将值设置为 newValue ，具有 VarHandle.setVolatile(java.lang.Object...)指定的内存效果。

set(V) - Method in class java.util.concurrent. FutureTask

将此未来的结果设置为给定值，除非此未来已被设置或已被取消。

set(V, boolean) - Method in class java.util.concurrent.atomic. AtomicMarkableReference

无条件地设置引用和标记的值。

set(V, int) - Method in class java.util.concurrent.atomic. AtomicStampedReference

无条件地设置引用和戳记的值。

Set< E> - Interface in java.util

不包含重复元素的集合。

SET - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.set指定

SET - jdk.dynalink. StandardOperation

将值设置在对象上定义的命名空间中。

set_as_default() - Method in interface org.omg.CORBA. DynUnion

已过时。

确定与此联合关联的鉴别器是否已分配有效的默认值。

set_as_default(boolean) - Method in interface org.omg.CORBA. DynUnion

已过时。

确定与此联合关联的鉴别器是否被分配有效的默认值。

set_as_string(String) - Method in class org.omg.DynamicAny. _DynEnumStub

将DynEnum的值设置为在值参数中传递IDL标识符的枚举值。

set_as_string(String) - Method in interface org.omg.DynamicAny. DynEnumOperations

将DynEnum的值设置为在值参数中传递IDL标识符的枚举值。

set_as_ulong(int) - Method in class org.omg.DynamicAny. _DynEnumStub

将DynEnum的值设置为枚举值的序数值。

set_as_ulong(int) - Method in interface org.omg.DynamicAny. DynEnumOperations

将DynEnum的值设置为枚举值的序数值。

set_boxed_value(Any) - Method in interface org.omg.DynamicAny. DynValueBoxOperations

用指定的值替换boxed值。

set_boxed_value_as_dyn_any(DynAny) - Method in interface org.omg.DynamicAny. DynValueBoxOperations

用包含在参数中的值替换boxed值。

set_delegate(Object) - Method in class org.omg.CORBA_2_3. ORB

set_discriminator(DynAny) - Method in class org.omg.DynamicAny. _DynUnionStub

将DynUnion的鉴别器设置为指定的值。

set_discriminator(DynAny) - Method in interface org.omg.DynamicAny. DynUnionOperations

将DynUnion的鉴别器设置为指定的值。

set_elements(Any[]) - Method in interface org.omg.CORBA. DynArray

已过时。

将此 DynArray对象的值设置为给定的数组。

set_elements(Any[]) - Method in interface org.omg.CORBA. DynSequence

已过时。

使用给定的数组设置此序列中所有元素的值。

set_elements(Any[]) - Method in class org.omg.DynamicAny. _DynArrayStub

将DynArray设置为包含传递的元素。

set_elements(Any[]) - Method in class org.omg.DynamicAny. _DynSequenceStub

设置序列的元素。

set_elements(Any[]) - Method in interface org.omg.DynamicAny. DynArrayOperations

将DynArray设置为包含传递的元素。

set_elements(Any[]) - Method in interface org.omg.DynamicAny. DynSequenceOperations

设置序列的元素。

set_elements_as_dyn_any(DynAny[]) - Method in class org.omg.DynamicAny. _DynArrayStub

将DynArray设置为包含传递的元素。

set_elements_as_dyn_any(DynAny[]) - Method in class org.omg.DynamicAny. _DynSequenceStub

使用DynAnys设置序列的元素。

set_elements_as_dyn_any(DynAny[]) - Method in interface org.omg.DynamicAny. DynArrayOperations

将DynArray设置为包含传递的元素。

set_elements_as_dyn_any(DynAny[]) - Method in interface org.omg.DynamicAny. DynSequenceOperations

使用DynAnys设置序列的元素。

set_exception(Any) - Method in class org.omg.CORBA. ServerRequest

抛出一个 org.omg.CORBA.NO_IMPLEMENT例外。

set_length(int) - Method in class org.omg.DynamicAny. _DynSequenceStub

设置序列的长度。

set_length(int) - Method in interface org.omg.DynamicAny. DynSequenceOperations

设置序列的长度。

set_members(NameValuePair[]) - Method in interface org.omg.CORBA. DynStruct

已过时。

设置结构体的成员。

set_members(NameValuePair[]) - Method in interface org.omg.CORBA. DynValue

已过时。

将 DynValue对象所代表的值对象的成员设置为给定的 NameValuePair对象数组。

set_members(NameValuePair[]) - Method in class org.omg.DynamicAny. _DynStructStub

从NameValuePairs序列中初始化与DynStruct对象关联的结构数据值。

set_members(NameValuePair[]) - Method in class org.omg.DynamicAny. _DynValueStub

从NameValuePairs序列初始化值类型的成员。

set_members(NameValuePair[]) - Method in interface org.omg.DynamicAny. DynStructOperations

从NameValuePairs序列中初始化与DynStruct对象关联的结构数据值。

set_members(NameValuePair[]) - Method in interface org.omg.DynamicAny. DynValueOperations

从NameValuePairs序列初始化值类型的成员。

set_members_as_dyn_any(NameDynAnyPair[]) - Method in class org.omg.DynamicAny. _DynStructStub

从NameDynAnyPairs序列中初始化与DynStruct对象关联的结构数据值。

set_members_as_dyn_any(NameDynAnyPair[]) - Method in class org.omg.DynamicAny. _DynValueStub

从NameDynAnyPairs序列初始化值类型的成员。

set_members_as_dyn_any(NameDynAnyPair[]) - Method in interface org.omg.DynamicAny. DynStructOperations

从NameDynAnyPairs序列中初始化与DynStruct对象关联的结构数据值。

set_members_as_dyn_any(NameDynAnyPair[]) - Method in interface org.omg.DynamicAny. DynValueOperations

从NameDynAnyPairs序列初始化值类型的成员。

set_one_value(String, Any) - Method in class org.omg.CORBA. Context

创建一个 NamedValue对象，并将其添加到此 Context对象。

SET_OPAQUE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.setOpaque指定

SET_OVERRIDE - Static variable in class org.omg.CORBA. SetOverrideType

SetOverrideType常量为枚举值SET_OVERRIDE。

set_parameters(Applet, Properties) - Method in class org.omg.CORBA. ORB

允许使用给定的小程序和参数初始化ORB实现。

set_parameters(String[], Properties) - Method in class org.omg.CORBA. ORB

允许使用给定的参数和属性初始化ORB实现。

set_policy_override(Object, Policy[], SetOverrideType) - Method in class org.omg.CORBA.portable. Delegate

将传递的策略与返回的新创建的对象引用相关联。

SET_RELEASE - java.lang.invoke. VarHandle.AccessMode

访问模式，其访问由相应的方法 VarHandle.setRelease指定

set_result(Any) - Method in class org.omg.CORBA. ServerRequest

抛出一个 org.omg.CORBA.NO_IMPLEMENT例外。

set_return_type(TypeCode) - Method in class org.omg.CORBA. Request

设置方法的返回值的类型代码。

SET_SELECTED_ITEMS - javafx.scene. AccessibleAction

请求节点将选择设置为项目列表。

set_servant(Servant) - Method in interface org.omg.PortableServer. POAOperations

此操作将指定的仆人作为默认仆人注册POA。

set_servant_manager(ServantManager) - Method in interface org.omg.PortableServer. POAOperations

此操作设置与POA关联的默认servant管理器。

set_slot(int, Any) - Method in interface org.omg.PortableInterceptor. CurrentOperations

在一个插槽中设置数据。

set_slot(int, Any) - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations

允许拦截器在请求范围内的 PortableInterceptor.Current中设置一个插槽。

SET_TEXT - javafx.scene. AccessibleAction

请求节点设置当前文本。

SET_TEXT_SELECTION - javafx.scene. AccessibleAction

请求节点将选择设置为文本范围。

set_to_default_member() - Method in class org.omg.DynamicAny. _DynUnionStub

将标识符设置为与联合的默认大小写的值一致的值。

set_to_default_member() - Method in interface org.omg.DynamicAny. DynUnionOperations

将标识符设置为与联合的默认大小写的值一致的值。

set_to_no_active_member() - Method in class org.omg.DynamicAny. _DynUnionStub

将鉴别器设置为不与任何联合案例标签对应的值。

set_to_no_active_member() - Method in interface org.omg.DynamicAny. DynUnionOperations

将鉴别器设置为不与任何联合案例标签对应的值。

set_to_null() - Method in class org.omg.DynamicAny. _DynValueStub

将DynValueCommon的表示形式更改为空值类型。

set_to_null() - Method in interface org.omg.DynamicAny. DynValueCommonOperations

将DynValueCommon的表示形式更改为空值类型。

set_to_value() - Method in class org.omg.DynamicAny. _DynValueStub

用新构造的值替换空值类型。

set_to_value() - Method in interface org.omg.DynamicAny. DynValueCommonOperations

用新构造的值替换空值类型。

set_value(byte[]) - Method in interface org.omg.CORBA. DynFixed

已过时。

将给定的固定类型实例设置为此 DynFixed对象的值。

set_value(String) - Method in class org.omg.DynamicAny. _DynFixedStub

设置DynFixed的值。

set_value(String) - Method in interface org.omg.DynamicAny. DynFixedOperations

设置DynFixed的值。

SET_VALUE - javafx.scene. AccessibleAction

请求节点设置当前值。

set_values(NVList) - Method in class org.omg.CORBA. Context

我在此 Context对象中设置一个或多个属性值。

SET_VOLATILE - java.lang.invoke. VarHandle.AccessMode

访问模式的访问由相应的方法 VarHandle.setVolatile指定

set2DigitYearStart(Date) - Method in class java.text. SimpleDateFormat

设置100年期间，两位数年份将被解释为在用户指定的日期开始。

setAbbr(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setAboutHandler(AboutHandler) - Method in class java.awt. Desktop

安装一个处理程序来显示应用程序的自定义关于窗口。

setAbsolute(boolean) - Method in class javafx.scene.shape. PathElement

设置属性的值绝对值。

setAccelerationPriority(float) - Method in class java.awt. Image

为此图像设置一个关于加速度有多重要的提示。

setAccelerator(KeyCombination) - Method in class javafx.scene.control. MenuItem

设置属性加速器的值。

setAccelerator(KeyStroke) - Method in class javax.swing. JMenu

setAccelerator没有为 JMenu定义。

setAccelerator(KeyStroke) - Method in class javax.swing. JMenuItem

设置在不导航菜单层次结构的情况下调用菜单项的动作侦听器的组合键。

setAccept(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setAcceptAllFileFilterUsed(boolean) - Method in class javax.swing. JFileChooser

确定 AcceptAll FileFilter是否用作可选择筛选器列表中的可用选项。

setAcceptCharset(String) - Method in interface org.w3c.dom.html. HTMLFormElement

setAccessible(boolean) - Method in class java.lang.reflect. AccessibleObject

将此反射对象的 accessible标志设置为指示的布尔值。

setAccessible(boolean) - Method in class java.lang.reflect. Constructor

将此反射对象的 accessible标志设置为指示的布尔值。

setAccessible(boolean) - Method in class java.lang.reflect. Field

setAccessible(boolean) - Method in class java.lang.reflect. 方法

setAccessible(AccessibleObject[], boolean) - Static method in class java.lang.reflect. AccessibleObject

方便的方法来设置 accessible标志的反射对象的数组，并进行一次安全检查（效率）。

setAccessibleCaption(Accessible) - Method in interface javax.accessibility. AccessibleTable

设置表格的标题。

setAccessibleCaption(Accessible) - Method in class javax.swing. JTable.AccessibleJTable

设置表格的标题。

setAccessibleColumnDescription(int, Accessible) - Method in interface javax.accessibility. AccessibleTable

设置表中指定列的描述文本。

setAccessibleColumnDescription(int, Accessible) - Method in class javax.swing. JTable.AccessibleJTable

设置表的指定列的描述文本。

setAccessibleColumnHeader(AccessibleTable) - Method in interface javax.accessibility. AccessibleTable

设置列标题。

setAccessibleColumnHeader(AccessibleTable) - Method in class javax.swing. JTable.AccessibleJTable

将列标题设置为 AccessibleTable 。

setAccessibleDescription(String) - Method in class com.sun.java.accessibility.util. Translator

设置此对象的可访问性描述。

setAccessibleDescription(String) - Method in class javax.accessibility. AccessibleContext

设置此对象的可访问描述。

setAccessibleDescription(String) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setAccessibleDescription(String) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置此对象的可访问描述。

setAccessibleDescription(String) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

设置此对象的可访问性描述。

setAccessibleDescription(String) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setAccessibleHelp(String) - Method in class javafx.scene. Node

设置属性accessibleHelp的值。

setAccessibleIconDescription(String) - Method in interface javax.accessibility. AccessibleIcon

设置图标的描述。

setAccessibleIconDescription(String) - Method in class javax.swing. ImageIcon.AccessibleImageIcon

设置图标的描述。

setAccessibleName(String) - Method in class com.sun.java.accessibility.util. Translator

设置此对象的名称。

setAccessibleName(String) - Method in class javax.accessibility. AccessibleContext

设置此对象的本地化可访问名称。

setAccessibleName(String) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setAccessibleName(String) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置此对象的本地化可访问名称。

setAccessibleName(String) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

设置此对象的本地化可访问名称。

setAccessibleName(String) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setAccessibleParent(Accessible) - Method in class javax.accessibility. AccessibleContext

设置此对象的 Accessible父对象。

setAccessibleRole(AccessibleRole) - Method in class javafx.scene. Node

设置属性accessibilityRole的值。

setAccessibleRoleDescription(String) - Method in class javafx.scene. Node

设置属性accessibilityRoleDescription的值。

setAccessibleRowDescription(int, Accessible) - Method in interface javax.accessibility. AccessibleTable

设置表的指定行的描述文本。

setAccessibleRowDescription(int, Accessible) - Method in class javax.swing. JTable.AccessibleJTable

设置表的指定行的描述文本。

setAccessibleRowHeader(AccessibleTable) - Method in interface javax.accessibility. AccessibleTable

设置行标题。

setAccessibleRowHeader(AccessibleTable) - Method in class javax.swing. JTable.AccessibleJTable

将行标题设置为 AccessibleTable 。

setAccessibleSummary(Accessible) - Method in interface javax.accessibility. AccessibleTable

设置表的摘要说明。

setAccessibleSummary(Accessible) - Method in class javax.swing. JTable.AccessibleJTable

设置表的摘要说明。

setAccessibleText(String) - Method in class javafx.scene. Node

设置属性accessibleText的值。

setAccessKey(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setAccessKey(String) - Method in interface org.w3c.dom.html. HTMLAreaElement

setAccessKey(String) - Method in interface org.w3c.dom.html. HTMLButtonElement

setAccessKey(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setAccessKey(String) - Method in interface org.w3c.dom.html. HTMLLabelElement

setAccessKey(String) - Method in interface org.w3c.dom.html. HTMLLegendElement

setAccessKey(String) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setAccessory(JComponent) - Method in class javax.swing. JFileChooser

设置附件组件。

setAcl(List<AclEntry>) - Method in interface java.nio.file.attribute. AclFileAttributeView

更新（替换）访问控制列表。

setAction(String) - Method in interface org.w3c.dom.html. HTMLFormElement

setAction(Action) - Method in class javax.swing. AbstractButton

设置 Action 。

setAction(Action) - Method in class javax.swing. JComboBox

设置 Action为 ActionEvent源。

setAction(Action) - Method in class javax.swing. JTextField

设置 Action为 ActionEvent源。

setActionCommand(String) - Method in class java.awt. Button

设置此按钮触发的操作事件的命令名称。

setActionCommand(String) - Method in class java.awt. MenuItem

设置此菜单项触发的操作事件的命令名称。

setActionCommand(String) - Method in class java.awt. TrayIcon

设置此托盘图标触发的操作事件的命令名称。

setActionCommand(String) - Method in class javax.swing. AbstractButton

设置此按钮的动作命令。

setActionCommand(String) - Method in interface javax.swing. ButtonModel

设置当触发按钮时作为 ActionEvent一部分发送的动作命令字符串。

setActionCommand(String) - Method in class javax.swing. DefaultButtonModel

设置当触发按钮时作为 ActionEvent一部分发送的动作命令字符串。

setActionCommand(String) - Method in class javax.swing. JComboBox

设置应该包含在发送到action监听器的事件中的action命令。

setActionCommand(String) - Method in class javax.swing. JTextField

设置用于操作事件的命令字符串。

setActionCommand(String) - Method in class javax.swing. Timer

将此定时器触发的 ActionEvent s中的动作命令设置为要传递的字符串。

setActionMap(ActionMap) - Method in class javax.swing. JComponent

将 ActionMap设为 am 。

setActivationDesc(ActivationID, ActivationDesc) - Method in interface java.rmi.activation. ActivationSystem

使用激活标识符 desc为对象设置激活描述符 id 。

setActivationGroupDesc(ActivationGroupID, ActivationGroupDesc) - Method in interface java.rmi.activation. ActivationSystem

设置激活组描述符， desc用于与激活组标识符，对象 id 。

setActive(boolean) - Method in class java.awt.dnd. DropTarget

将DropTarget设置为激活，如果为 true ，如果为 true ，则 false 。

setActor(String) - Method in interface javax.xml.soap. SOAPHeaderElement

将与此 SOAPHeaderElement对象关联的actor设置为指定的actor。

setAdapter(Class<A>, A) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

setAdapter(Class<A>, A) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

setAdapter(Class<A>, A) - Method in interface javax.xml.bind. Marshaller

将配置的XmlAdapter实例与此编组相关联。

setAdapter(Class<A>, A) - Method in interface javax.xml.bind. Unmarshaller

将配置的XmlAdapter实例与此解组器相关联。

setAdapter(XmlAdapter) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

setAdapter(XmlAdapter) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

setAdapter(XmlAdapter) - Method in interface javax.xml.bind. Marshaller

将配置的XmlAdapter实例与此编组相关联。

setAdapter(XmlAdapter) - Method in interface javax.xml.bind. Unmarshaller

将配置的XmlAdapter实例与此解组器相关联。

setAddress(InetAddress) - Method in class java.net. DatagramPacket

设置该数据报发送到的机器的IP地址。

setAlertType(Alert.AlertType) - Method in class javafx.scene.control. Alert

设置属性alertType的值。

setAlgorithmConstraints(AlgorithmConstraints) - Method in class javax.net.ssl. SSLParameters

设置加密算法约束，除了由运行时环境配置的任何约束之外，它将被使用。

setAlign(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLDivElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLHeadingElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLHRElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLLegendElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLParagraphElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLTableCaptionElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLTableColElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLTableRowElement

setAlign(String) - Method in interface org.w3c.dom.html. HTMLTableSectionElement

setAlignment(int) - Method in class java.awt. FlowLayout

设置此布局的对齐方式。

setAlignment(int) - Method in class java.awt. Label

将此标签的对齐方式设置为指定的对齐方式。

setAlignment(Pos) - Method in class javafx.scene.control. Labeled

设置属性对齐的值。

setAlignment(Pos) - Method in class javafx.scene.control. TextField

设置属性对齐的值。

setAlignment(Pos) - Method in class javafx.scene.layout. FlowPane

设置属性对齐的值。

setAlignment(Pos) - Method in class javafx.scene.layout. GridPane

设置属性对齐的值。

setAlignment(Pos) - Method in class javafx.scene.layout. HBox

设置属性对齐的值。

setAlignment(Pos) - Method in class javafx.scene.layout. StackPane

设置属性对齐的值。

setAlignment(Pos) - Method in class javafx.scene.layout. TilePane

设置属性对齐的值。

setAlignment(Pos) - Method in class javafx.scene.layout. VBox

设置属性对齐的值。

setAlignment(Node, Pos) - Static method in class javafx.scene.layout. BorderPane

设置边框窗格中包含的子对象。

setAlignment(Node, Pos) - Static method in class javafx.scene.layout. StackPane

设置子堆栈的对齐方式。

setAlignment(Node, Pos) - Static method in class javafx.scene.layout. TilePane

设置小屋的对齐方式，包含在tilepane中。

setAlignment(MutableAttributeSet, int) - Static method in class javax.swing.text. StyleConstants

设置对齐。

setAlignmentX(float) - Method in class javax.swing. JComponent

设置水平对齐。

setAlignmentY(float) - Method in class javax.swing. JComponent

设置垂直对齐。

setAlignOnBaseline(boolean) - Method in class java.awt. FlowLayout

组件是否应沿其基线垂直排列。

setALink(String) - Method in interface org.w3c.dom.html. HTMLBodyElement

setAll(double[], IntToDoubleFunction) - Static method in class java.util. Arrays

使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

setAll(float...) - Method in interface javafx.collections. ObservableFloatArray

用给定的元素替换这个可观察的数组内容。

setAll(float[], int, int) - Method in interface javafx.collections. ObservableFloatArray

用给定数组的一部分的副本替换这个可观察的数组内容。

setAll(int...) - Method in interface javafx.collections. ObservableIntegerArray

用给定的元素替换这个可观察的数组内容。

setAll(int[], int, int) - Method in interface javafx.collections. ObservableIntegerArray

用给定数组的一部分的副本替换这个可观察的数组内容。

setAll(int[], IntUnaryOperator) - Static method in class java.util. Arrays

使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

setAll(long[], IntToLongFunction) - Static method in class java.util. Arrays

使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

setAll(E...) - Method in class javafx.beans.binding. ListExpression

setAll(E...) - Method in interface javafx.collections. ObservableList

清除ObservableList并添加所有传递给var-args的元素。

setAll(E...) - Method in class javafx.collections. ObservableListBase

setAll(Collection<? extends E>) - Method in class javafx.beans.binding. ListExpression

setAll(Collection<? extends E>) - Method in class javafx.collections. ModifiableObservableListBase

setAll(Collection<? extends E>) - Method in interface javafx.collections. ObservableList

清除ObservableList并添加集合中的所有元素。

setAll(Collection<? extends E>) - Method in class javafx.collections. ObservableListBase

setAll(ObservableFloatArray) - Method in interface javafx.collections. ObservableFloatArray

用给定的observable数组的副本替换这个可观察的数组内容。

setAll(ObservableFloatArray, int, int) - Method in interface javafx.collections. ObservableFloatArray

用给定的observable数组的一部分替换这个可观察的数组内容。

setAll(ObservableIntegerArray) - Method in interface javafx.collections. ObservableIntegerArray

用给定的observable数组的副本替换这个可观察的数组内容。

setAll(ObservableIntegerArray, int, int) - Method in interface javafx.collections. ObservableIntegerArray

用给定的observable数组的一部分替换这个可观察的数组内容。

setAll(T[], IntFunction<? extends T>) - Static method in class java.util. Arrays

使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

setAllocation(Shape) - Method in class javax.swing.text. AsyncBoxView.ChildLocator

将当前分配的形状复制到用于存储当前分配的Rectangle中。

setAllowIndeterminate(boolean) - Method in class javafx.scene.control. CheckBox

设置属性allowIndeterminate的值。

setAllowsChildren(boolean) - Method in class javax.swing.tree. DefaultMutableTreeNode

确定此节点是否允许有子节点。

setAllowsInvalid(boolean) - Method in class javax.swing.text. DefaultFormatter

设置一段时间内是否允许编辑的值无效（即 stringToValue抛出一个 ParseException ）。

setAllowUserInteraction(boolean) - Method in class java.net. URLConnection

设置此 allowUserInteraction字段的 URLConnection 。

setAlt(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setAlt(String) - Method in interface org.w3c.dom.html. HTMLAreaElement

setAlt(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setAlt(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setAlternativeColumnFillVisible(boolean) - Method in class javafx.scene.chart. XYChart

设置propertyColumnFillVisible属性的值。

setAlternativeRowFillVisible(boolean) - Method in class javafx.scene.chart. XYChart

设置属性alternativeRowFillVisible的值。

setAltName(Name) - Method in exception javax.naming. CannotProceedException

设置此异常的 altName字段。

setAltNameCtx(Context) - Method in exception javax.naming. CannotProceedException

设置此异常的 altNameCtx字段。

setAlwaysOnTop(boolean) - Method in class java.awt. Window

设置此窗口是否应始终高于其他窗口。

setAlwaysOnTop(boolean) - Method in class javafx.stage. Stage

设置属性alwaysOnTop的值。

setAmountToStepBy(double) - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory

设置属性amountToStepBy的值。

setAmountToStepBy(int) - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

设置属性amountToStepBy的值。

setAmPmStrings(String[]) - Method in class java.text. DateFormatSymbols

设置ampm字符串。

setAnchor(int) - Method in class javafx.scene.control. TextFormatter.Change

设置锚点。

setAnchorLocation(PopupWindow.AnchorLocation) - Method in class javafx.stage. PopupWindow

设置属性anchorLocation的值。

setAnchorSelectionIndex(int) - Method in class javax.swing. DefaultListSelectionModel

设置锚选择索引，使所有选择值保持不变。

setAnchorSelectionIndex(int) - Method in interface javax.swing. ListSelectionModel

设置锚选择索引。

setAnchorSelectionPath(TreePath) - Method in class javax.swing. JTree

设置标识为锚点的路径。

setAnchorX(double) - Method in class javafx.stage. PopupWindow

设置属性anchorX的值。

setAnchorY(double) - Method in class javafx.stage. PopupWindow

设置属性anchorY的值。

setAngle(double) - Method in class javafx.scene.effect. MotionBlur

设置属性角度的值。

setAngle(double) - Method in class javafx.scene.transform. Rotate

设置属性角度的值。

setAngleExtent(double) - Method in class java.awt.geom. Arc2D.Double

将此弧的角度范围设置为指定的双精度值。

setAngleExtent(double) - Method in class java.awt.geom. Arc2D.Float

将此弧的角度范围设置为指定的双精度值。

setAngleExtent(double) - Method in class java.awt.geom. Arc2D

将此弧的角度范围设置为指定的双精度值。

setAngles(double, double, double, double) - Method in class java.awt.geom. Arc2D

使用两组坐标设置该弧的起始角度和角度范围。

setAngles(Point2D, Point2D) - Method in class java.awt.geom. Arc2D

使用两点设置此弧的起始角度和角度范围。

setAngleStart(double) - Method in class java.awt.geom. Arc2D.Double

将此弧的起始角度设置为指定的双精度值。

setAngleStart(double) - Method in class java.awt.geom. Arc2D.Float

将此弧的起始角度设置为指定的双精度值。

setAngleStart(double) - Method in class java.awt.geom. Arc2D

将此弧的起始角度设置为指定的双精度值。

setAngleStart(Point2D) - Method in class java.awt.geom. Arc2D

将该弧的起始角度设置为指定点相对于该弧的中心定义的角度。

setAnimated(boolean) - Method in class java.awt.image. MemoryImageSource

根据动画参数，将此内存图像更改为多帧动画或单帧静态图像。

setAnimated(boolean) - Method in class javafx.scene.chart. Axis

设置动画属性的值。

setAnimated(boolean) - Method in class javafx.scene.chart. Chart

设置动画属性的值。

setAnimated(boolean) - Method in class javafx.scene.control. TitledPane

指定TitledPane应如何打开和关闭。

setAnimationIndex(int) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

将当前动画帧的索引设置为指定的值，并请求重绘进度条。

setAnimationIndex(int) - Method in class javax.swing.plaf.synth. SynthProgressBarUI

将当前动画帧的索引设置为指定的值，并请求重绘进度条。

setAnyPolicyInhibited(boolean) - Method in class java.security.cert. PKIXParameters

设置状态以确定是否应将任何策略OID包含在证书中进行处理。

setApplicationProtocols(String[]) - Method in class javax.net.ssl. SSLParameters

设置可以通过SSL / TLS / DTLS协议协商的应用层协议名称的优先级数组。

setApproveButtonMnemonic(char) - Method in class javax.swing. JFileChooser

使用字符设置批准按钮的助记符。

setApproveButtonMnemonic(int) - Method in class javax.swing. JFileChooser

使用数字键码设置批准按钮的助记符。

setApproveButtonText(String) - Method in class javax.swing. JFileChooser

设置在使用的文本 ApproveButton在 FileChooserUI 。

setApproveButtonToolTipText(String) - Method in class javax.swing. JFileChooser

设置在 ApproveButton使用的工具提示文本。

setArc(double, double, double, double, double, double, int) - Method in class java.awt.geom. Arc2D.Double

将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。

setArc(double, double, double, double, double, double, int) - Method in class java.awt.geom. Arc2D.Float

将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。

setArc(double, double, double, double, double, double, int) - Method in class java.awt.geom. Arc2D

将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。

setArc(Arc2D) - Method in class java.awt.geom. Arc2D

将此弧设置为与指定弧相同。

setArc(Point2D, Dimension2D, double, double, int) - Method in class java.awt.geom. Arc2D

将该弧的位置，大小，角度范围和闭合类型设置为指定的值。

setArc(Rectangle2D, double, double, int) - Method in class java.awt.geom. Arc2D

将该弧的位置，大小，角度范围和闭合类型设置为指定的值。

setArcByCenter(double, double, double, double, double, int) - Method in class java.awt.geom. Arc2D

将此弧的位置，边界，角度范围和闭合类型设置为指定的值。

setArcByTangent(Point2D, Point2D, Point2D, double) - Method in class java.awt.geom. Arc2D

将该弧的位置，边界和角度范围设置为指定的值。

setArcHeight(double) - Method in class javafx.scene.shape. Rectangle

设置属性arcHeight的值。

setArchive(boolean) - Method in interface java.nio.file.attribute. DosFileAttributeView

更新归档属性的值。

setArchive(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setArchive(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setArcType(int) - Method in class java.awt.geom. Arc2D

将此弧为指定值的闭合类型： OPEN ， CHORD ，或 PIE 。

setArcWidth(double) - Method in class javafx.scene.shape. Rectangle

设置属性arcWidth的值。

setAreaOfInterest(Shape) - Method in class java.awt.image.renderable. RenderContext

设置当前感兴趣的区域。

setArgb(int, int, int) - Method in interface javafx.scene.image. PixelWriter

将颜色的像素数据存储到表面的指定坐标。

setArgb(T, int, int, int, int) - Method in class javafx.scene.image. WritablePixelFormat

在指定的坐标处存储表示指定的32位整数表示的适当像素数据在缓冲区中的颜色。

setArmed(boolean) - Method in interface javax.swing. ButtonModel

将按钮标记为武装或非武装。

setArmed(boolean) - Method in class javax.swing. DefaultButtonModel

将按钮标记为武装或非武装。

setArmed(boolean) - Method in class javax.swing. JMenuItem

将菜单项标识为“布防”。

setArray(int, Array) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.sql.Array对象。

setArray(int, Array) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中的一个 Array对象。

setArray(int, Array) - Method in interface javax.sql. RowSet

使用给定的 Array值在此 RowSet对象的命令中设置指定的参数。

setAsciiStream(int, InputStream) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的输入流。

setAsciiStream(int, InputStream) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的命令中的指定参数设置为给定的输入流。

setAsciiStream(int, InputStream) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的输入流。

setAsciiStream(int, InputStream, int) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setAsciiStream(int, InputStream, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.io.InputStream对象，该对象将具有指定的字节数。

setAsciiStream(int, InputStream, int) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 java.io.InputStream值。

setAsciiStream(int, InputStream, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setAsciiStream(long) - Method in interface java.sql. Clob

检索要用于将Ascii字符写入 Clob对象表示的 CLOB值的流，从位置 pos开始。

setAsciiStream(long) - Method in class javax.sql.rowset.serial. SerialClob

检索流用于写入ASCII字符的 CLOB值，这 SerialClob对象表示，起始于位置 pos 。

setAsciiStream(String, InputStream) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的输入流。

setAsciiStream(String, InputStream) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的输入流。

setAsciiStream(String, InputStream) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的输入流。

setAsciiStream(String, InputStream, int) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setAsciiStream(String, InputStream, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setAsciiStream(String, InputStream, int) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setAsciiStream(String, InputStream, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setAsksAllowsChildren(boolean) - Method in class javax.swing.tree. DefaultTreeModel

设置是否通过向TreeNodes请求getAllowsChildren（）或isLeaf（）来测试叶片性。

setAsText(String) - Method in interface java.beans. PropertyEditor

通过解析给定的字符串来设置属性值。

setAsText(String) - Method in class java.beans. PropertyEditorSupport

通过解析给定的字符串来设置属性值。

setAsynchronousLoadPriority(int) - Method in class javax.swing.text. AbstractDocument

设置异步加载优先级。

setAttachmentMarshaller(AttachmentMarshaller) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

setAttachmentMarshaller(AttachmentMarshaller) - Method in interface javax.xml.bind. Marshaller

关联使XML文档中的二进制数据能够以XML二进制优化的附件传输的上下文。

setAttachmentUnmarshaller(AttachmentUnmarshaller) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

setAttachmentUnmarshaller(AttachmentUnmarshaller) - Method in interface javax.xml.bind. Unmarshaller

将解析cid，content-id URI的上下文关联到作为附件传递的二进制数据。

setAttribute(int, String, String, String, String, String) - Method in class org.xml.sax.helpers. AttributesImpl

在列表中设置一个属性。

setAttribute(String, Object) - Method in class com.sun.net.httpserver. HttpExchange

过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。

setAttribute(String, Object) - Method in class javax.xml.parsers. DocumentBuilderFactory

允许用户在底层实现上设置特定属性。

setAttribute(String, Object) - Method in class javax.xml.transform. TransformerFactory

允许用户在底层实现上设置特定属性。

setAttribute(String, Object, int) - Method in interface javax.script. ScriptContext

设置给定范围内的属性值。

setAttribute(String, Object, int) - Method in class javax.script. SimpleScriptContext

设置给定范围内的属性值。

setAttribute(String, String) - Method in class javax.imageio.metadata. IIOMetadataNode

setAttribute(String, String) - Method in interface org.w3c.dom. Element

添加一个新属性。

setAttribute(Path, String, Object, LinkOption...) - Static method in class java.nio.file. Files

设置文件属性的值。

setAttribute(Path, String, Object, LinkOption...) - Method in class java.nio.file.spi. FileSystemProvider

设置文件属性的值。

setAttribute(Attribute) - Method in interface javax.management. DynamicMBean

设置动态MBean的特定属性的值。

setAttribute(Attribute) - Method in class javax.management.modelmbean. RequiredModelMBean

设置命名的ModelMBean的特定属性的值。

setAttribute(Attribute) - Method in class javax.management. StandardMBean

setAttribute(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.setAttribute(ObjectName, Attribute) 。

setAttribute(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

setAttribute(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

setAttribute(ObjectName, Attribute) - Method in interface javax.management. MBeanServer

setAttribute(ObjectName, Attribute) - Method in interface javax.management. MBeanServerConnection

设置命名MBean的特定属性的值。

setAttributeList(AttributeList) - Method in class org.xml.sax.helpers. AttributeListImpl

已过时。

设置属性列表，舍弃以前的内容。

setAttributeNode(Attr) - Method in class javax.imageio.metadata. IIOMetadataNode

setAttributeNode(Attr) - Method in interface org.w3c.dom. Element

添加一个新的属性节点。

setAttributeNodeNS(Attr) - Method in class javax.imageio.metadata. IIOMetadataNode

相当于 setAttributeNode(newAttr) 。

setAttributeNodeNS(Attr) - Method in interface org.w3c.dom. Element

添加一个新属性。

setAttributeNS(String, String, String) - Method in class javax.imageio.metadata. IIOMetadataNode

相当于 setAttribute(qualifiedName, value) 。

setAttributeNS(String, String, String) - Method in interface org.w3c.dom. Element

添加一个新属性。

setAttributes(int, int, AttributeSet) - Method in interface javax.accessibility. AccessibleEditableText

为两个索引之间的文本设置属性。

setAttributes(int, int, AttributeSet) - Method in class javax.swing. JSpinner.AccessibleJSpinner

为两个索引之间的文本设置属性。

setAttributes(int, int, AttributeSet) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

为两个索引之间的文本设置属性。

setAttributes(AttributeList) - Method in interface javax.management. DynamicMBean

设置动态MBean的几个属性的值。

setAttributes(AttributeList) - Method in class javax.management.modelmbean. RequiredModelMBean

设置此ModelBean的属性数组的值。

setAttributes(AttributeList) - Method in class javax.management. StandardMBean

setAttributes(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi. RMIConnection

处理方法 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 。

setAttributes(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub

setAttributes(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl

setAttributes(ObjectName, AttributeList) - Method in interface javax.management. MBeanServer

setAttributes(ObjectName, AttributeList) - Method in interface javax.management. MBeanServerConnection

设置一个命名MBean的几个属性的值。

setAttributes(Attributes) - Method in class javax.naming.directory. SearchResult

将此搜索结果的属性设置为 attrs 。

setAttributes(Attributes) - Method in class org.xml.sax.ext. Attributes2Impl

复制整个Attributes对象。

setAttributes(Attributes) - Method in class org.xml.sax.helpers. AttributesImpl

复制整个Attributes对象。

setAudioSpectrumInterval(double) - Method in class javafx.scene.media. MediaPlayer

设置音频频谱通知间隔的值，单位为秒。

setAudioSpectrumListener(AudioSpectrumListener) - Method in class javafx.scene.media. MediaPlayer

设置音频频谱的听众。

setAudioSpectrumNumBands(int) - Method in class javafx.scene.media. MediaPlayer

设置音频频谱中的频带数。

setAudioSpectrumThreshold(int) - Method in class javafx.scene.media. MediaPlayer

以分贝设置音频频谱阈值。

setAuthenticator(Authenticator) - Method in class com.sun.net.httpserver. HttpContext

设置此HttpContext的Authenticator。

setAuthenticator(Authenticator) - Method in class java.net. HttpURLConnection

提供一个Authenticator ，以通过HTTP协议请求此HttpURLConnection 。

setAuthorityKeyIdentifier(byte[]) - Method in class java.security.cert. X509CertSelector

设置authorityKeyIdentifier标准。

setAuthorized(boolean) - Method in class javax.security.sasl. AuthorizeCallback

设置是否允许授权。

setAuthorizedID(String) - Method in class javax.security.sasl. AuthorizeCallback

设置授权实体的ID。

setAutoCommit(boolean) - Method in interface java.sql. Connection

将此连接的自动提交模式设置为给定状态。

setAutoCommit(boolean) - Method in interface javax.sql.rowset. JdbcRowSet

每个 JdbcRowSet包含一个 Connection对象，从原来的 ResultSet或传递给它的JDBC属性。

setAutoConversionStrategy(MethodTypeConversionStrategy) - Method in class jdk.dynalink. DynamicLinkerFactory

设置一个表示自动类型转换的转换策略的对象。

setAutoCreateColumnsFromModel(boolean) - Method in class javax.swing. JTable

设置此表的 autoCreateColumnsFromModel标志。

setAutoCreateContainerGaps(boolean) - Method in class javax.swing. GroupLayout

设置是否自动创建容器和组件之间接触容器边界的间隙。

setAutoCreateGaps(boolean) - Method in class javax.swing. GroupLayout

设置是否自动创建组件之间的间隙。

setAutoCreateRowSorter(boolean) - Method in class javax.swing. JTable

指定是否应为表格创建 RowSorter ，只要其模型发生更改。

setAutoDelay(int) - Method in class java.awt. Robot

设置机器人在生成事件后睡眠的毫秒数。

setAutoFix(boolean) - Method in class javafx.stage. PopupWindow

设置属性autoFix的值。

setAutoFormSubmission(boolean) - Method in class javax.swing.text.html. HTMLEditorKit

指定是否自动处理html表单提交或仅 FormSubmitEvent 。

setAutoHide(boolean) - Method in class javafx.stage. PopupWindow

设置属性autoHide的值。

setAutoIncrement(int, boolean) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置指定列是否自动编号，因此只读为给定的 boolean值。

setAutoIncrement(int, boolean) - Method in interface javax.sql. RowSetMetaData

设置指定列是否自动编号，默认值为 RowSet对象的列不会自动编号。

setAutoPlay(boolean) - Method in class javafx.scene.media. MediaPlayer

设置 autoPlay属性值。

setAutoRanging(boolean) - Method in class javafx.scene.chart. Axis

设置属性autoRanging的值。

setAutoRequestFocus(boolean) - Method in class java.awt. Window

设置此窗口是否应该随后显示焦点（调用 setVisible(true) ）或被移动到前面（调用 Window.toFront() ）。

setAutoResizeMode(int) - Method in class javax.swing. JTable

当表被调整大小时，设置表的自动调整大小模式。

setAutoReverse(boolean) - Method in class javafx.animation. Animation

设置属性autoReverse的值。

setAutoscrolls(boolean) - Method in class javax.swing. JComponent

设置 autoscrolls属性。

setAutoSizeChildren(boolean) - Method in class javafx.scene. Group

设置属性autoSizeChildren的值。

setAutoWaitForIdle(boolean) - Method in class java.awt. Robot

设置此机器人是否在生成事件后自动调用 waitForIdle 。

setAxis(int) - Method in class javax.swing.text. BoxView

设置瓦片轴属性。

setAxis(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setAxis(Point3D) - Method in class javafx.animation. RotateTransition

设置属性轴的值。

setAxis(Point3D) - Method in class javafx.scene.transform. Rotate

设置属性轴的值。

setAxisSortingPolicy(LineChart.SortingPolicy) - Method in class javafx.scene.chart. LineChart

设置属性axisSortingPolicy的值。

setAzimuth(double) - Method in class javafx.scene.effect. Light.Distant

设置属性方位角的值。

setAzimuth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的方位属性定义。

setBackground(Color) - Method in class com.sun.java.accessibility.util. Translator

设置此对象的背景 Color 。

setBackground(Color) - Method in class java.awt. Component.AccessibleAWTComponent

设置此对象的背景颜色。

setBackground(Color) - Method in class java.awt. Component

设置此组件的背景颜色。

setBackground(Color) - Method in class java.awt. Dialog

设置此窗口的背景颜色。

setBackground(Color) - Method in class java.awt. Frame

设置此窗口的背景颜色。

setBackground(Color) - Method in class java.awt. Graphics2D

设置 Graphics2D上下文的背景颜色。

setBackground(Color) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

设置此对象的背景颜色。

setBackground(Color) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

设置此对象的背景颜色。

setBackground(Color) - Method in class java.awt. TextComponent

设置此文本组件的背景颜色。

setBackground(Color) - Method in class java.awt. Window

设置此窗口的背景颜色。

setBackground(Color) - Method in interface javax.accessibility. AccessibleComponent

设置此对象的背景颜色。

setBackground(Color) - Method in class javax.swing. JComponent

设置此组件的背景颜色。

setBackground(Color) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setBackground(Color) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置此对象的背景颜色。

setBackground(Color) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

设置此对象的背景颜色。

setBackground(Color) - Method in class javax.swing.table. DefaultTableCellRenderer

覆盖 JComponent.setBackground以将未选择的背景颜色分配给指定的颜色。

setBackground(Color) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setBackground(Color) - Method in class javax.swing.text. LabelView

设置视图的背景颜色。

setBackground(Color) - Method in class javax.swing.tree. DefaultTreeCellRenderer

Subclassed将其映射到空值为 ColorUIResource 。

setBackground(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background属性定义。

setBackground(String) - Method in interface org.w3c.dom.html. HTMLBodyElement

setBackground(Background) - Method in class javafx.scene.layout. Region

设置属性背景的值。

setBackground(MutableAttributeSet, Color) - Static method in class javax.swing.text. StyleConstants

设置背景颜色。

setBackgroundAt(int, Color) - Method in class javax.swing. JTabbedPane

将背景颜色设置为 index至 background ，可以是 null ，在这种情况下，选项卡的背景颜色将默认为 tabbedpane的背景颜色。

setBackgroundAttachment(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-attachment属性定义。

setBackgroundColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-color属性定义。

setBackgroundImage(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-image属性定义。

setBackgroundNonSelectionColor(Color) - Method in class javax.swing.tree. DefaultTreeCellRenderer

设置要用于非选定节点的背景颜色。

setBackgroundPosition(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-position属性定义。

setBackgroundRepeat(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的background-repeat属性定义。

setBackgroundSelectionColor(Color) - Method in class javax.swing.tree. DefaultTreeCellRenderer

如果选择了节点，则设置用于背景的颜色。

setBackingStoreEnabled(boolean) - Method in class javax.swing. JViewport

已过时。
从Java 2平台v1.3开始，由setScrollMode()代替。

setBackoffStrategy(Callback<ScheduledService<?>, Duration>) - Method in class javafx.concurrent. ScheduledService

设置属性backoffStrategy的值。

setBalance(double) - Method in class javafx.scene.media. AudioClip

设置默认平衡级别。

setBalance(double) - Method in class javafx.scene.media. MediaPlayer

设置音频平衡。

setBandwidth(double) - Method in class javafx.scene.media. EqualizerBand

设置频带的带宽为赫兹。

setBarGap(double) - Method in class javafx.scene.chart. BarChart

设置属性barGap的值。

setBase(URL) - Method in class javax.swing.text.html. HTMLDocument

设置解析相对URL的位置。

setBase(URL) - Method in class javax.swing.text.html. StyleSheet

设置基数。

setBase64Content(InputStream, String) - Method in class javax.xml.soap. AttachmentPart

将此附件部分从所述的Base64源的内容 InputStream和设置的值 Content-Type头中包含的值 contentType ，此方法将首先解码的base64输入并写入到附接所得的原始字节。

setBaseFontSize(int) - Method in class javax.swing.text.html. StyleSheet

设置基本字体大小，有效值介于1和7之间。

setBaseFontSize(String) - Method in class javax.swing.text.html. StyleSheet

从String中传递的基本字体大小设置。

setBaseURI(String) - Method in class javax.xml.crypto.dom. DOMCryptoContext

setBaseURI(String) - Method in interface javax.xml.crypto. XMLCryptoContext

设置基本URI。

setBaseURI(String) - Method in interface org.w3c.dom.ls. LSInput

要使用的基址URI（见[ IETF RFC 2396 ]中的5.1.4），用于将相对的 systemId解析为绝对URI。

setBasicConstraints(int) - Method in class java.security.cert. X509CertSelector

设置基本约束约束。

setBasicSplitPaneUI(BasicSplitPaneUI) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

设置使用接收器的 SplitPaneUI 。

setBeanContext(BeanContext) - Method in interface java.beans.beancontext. BeanContextChild

实现此接口的对象将触发java.beans.PropertyChangeEvent，其参数为：propertyName“beanContext”，oldValue（以前的嵌套 BeanContext实例或 null ），newValue（当前嵌套的 BeanContext实例或 null ）。

setBeanContext(BeanContext) - Method in class java.beans.beancontext. BeanContextChildSupport

设置 BeanContext为这 BeanContextChildSupport 。

setBeanInfoSearchPath(String[]) - Static method in class java.beans. Introspector

更改将用于查找BeanInfo类的包名称列表。

setBeginIndex(int) - Method in class java.text. FieldPosition

设置开始索引。

setBgColor(String) - Method in interface org.w3c.dom.html. HTMLBodyElement

setBgColor(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setBgColor(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setBgColor(String) - Method in interface org.w3c.dom.html. HTMLTableRowElement

setBidiLevel(MutableAttributeSet, int) - Static method in class javax.swing.text. StyleConstants

设置BidiLevel。

setBigDecimal(int, BigDecimal) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.math.BigDecimal值。

setBigDecimal(int, BigDecimal) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.lang.BigDecimal值。

setBigDecimal(int, BigDecimal) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 java.math.BigDecimal值。

setBigDecimal(String, BigDecimal) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.math.BigDecimal值。

setBigDecimal(String, BigDecimal) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.math.BigDecimal值。

setBigDecimal(String, BigDecimal) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.math.BigDecimal值。

setBinaryStream() - Method in interface java.sql. SQLXML

检索可用于编写此SQLXML实例所代表的XML值的流。

setBinaryStream(int, InputStream) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的输入流。

setBinaryStream(int, InputStream) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的命令中的指定参数设置为给定的输入流。

setBinaryStream(int, InputStream) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的输入流。

setBinaryStream(int, InputStream, int) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setBinaryStream(int, InputStream, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.io.InputStream对象，该对象将具有指定的字节数。

setBinaryStream(int, InputStream, int) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 java.io.InputStream值。

setBinaryStream(int, InputStream, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setBinaryStream(long) - Method in interface java.sql. Blob

检索可用于写入 Blob对象所代表的值的 BLOB值。

setBinaryStream(long) - Method in class javax.sql.rowset.serial. SerialBlob

检索可用于写入此 Blob对象所代表的值的 BLOB的流。

setBinaryStream(String, InputStream) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的输入流。

setBinaryStream(String, InputStream) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的输入流。

setBinaryStream(String, InputStream) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的输入流。

setBinaryStream(String, InputStream, int) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setBinaryStream(String, InputStream, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setBinaryStream(String, InputStream, int) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的输入流，它将具有指定的字节数。

setBinaryStream(String, InputStream, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的输入流，它将具有指定的字节数。

SetBinding< E> - Class in javafx.beans.binding

提供实现ObservableSet的Binding所需的大部分功能的基类。

SetBinding() - Constructor for class javafx.beans.binding. SetBinding

setBindings(Bindings) - Method in class javax.script. ScriptEngineManager

setBindings存储指定 Bindings在 globalScope领域。

setBindings(Bindings, int) - Method in class javax.script. AbstractScriptEngine

设置 Bindings与在相应的范围值 context字段。

setBindings(Bindings, int) - Method in interface javax.script. ScriptContext

将 Bindings实例与此 ScriptContext的特定范围相关 ScriptContext 。

setBindings(Bindings, int) - Method in interface javax.script. ScriptEngine

设置脚本使用的命名值的范围。

setBindings(Bindings, int) - Method in class javax.script. SimpleScriptContext

为给定的范围设置一个 Bindings的属性。

setBit(int) - Method in class java.math. BigInteger

返回一个BigInteger，其值等于具有指定位集合的BigInteger。

setBitOffset(int) - Method in interface javax.imageio.stream. ImageInputStream

将位偏移设置为0到7之间的整数，包括0和7。

setBitOffset(int) - Method in class javax.imageio.stream. ImageInputStreamImpl

setBlendMode(BlendMode) - Method in class javafx.scene. Node

设置blendMode属性的值。

setBlinkRate(int) - Method in interface javax.swing.text. Caret

设置插入符号的闪烁速率。

setBlinkRate(int) - Method in class javax.swing.text. DefaultCaret

设置插入眨眼速率。

setBlob(int, InputStream) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 InputStream对象。

setBlob(int, InputStream) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 InputStream对象。

setBlob(int, InputStream) - Method in interface javax.sql. RowSet

将指定的参数设置为 InputStream对象。

setBlob(int, InputStream, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 InputStream对象。

setBlob(int, InputStream, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 InputStream对象。

setBlob(int, InputStream, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 InputStream对象。

setBlob(int, Blob) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.sql.Blob对象。

setBlob(int, Blob) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中给定的 Blob对象。

setBlob(int, Blob) - Method in interface javax.sql. RowSet

使用给定的 Blob值在此 RowSet对象的命令中设置指定的参数。

setBlob(String, InputStream) - Method in interface java.sql. CallableStatement

将指定的参数设置为 InputStream对象。

setBlob(String, InputStream) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 InputStream对象。

setBlob(String, InputStream) - Method in interface javax.sql. RowSet

将指定的参数设置为 InputStream对象。

setBlob(String, InputStream, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为 InputStream对象。

setBlob(String, InputStream, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 InputStream对象。

setBlob(String, InputStream, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 InputStream对象。

setBlob(String, Blob) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.sql.Blob对象。

setBlob(String, Blob) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Blob对象。

setBlob(String, Blob) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.Blob对象。

setBlockIncrement(double) - Method in class javafx.scene.control. ScrollBar

设置属性blockIncrement的值。

setBlockIncrement(double) - Method in class javafx.scene.control. Slider

设置属性blockIncrement的值。

setBlockIncrement(int) - Method in interface java.awt. Adjustable

设置可调整对象的块值增量。

setBlockIncrement(int) - Method in class java.awt. Scrollbar

设置此滚动条的块增量。

setBlockIncrement(int) - Method in class java.awt. ScrollPaneAdjustable

setBlockIncrement(int) - Method in class javax.swing. JScrollBar

设置blockIncrement属性。

setBlockIncrement(int) - Method in class javax.swing. JScrollPane.ScrollBar

消息超级设置值，并将 blockIncrementSet实例变量重置为true。

setBlurType(BlurType) - Method in class javafx.scene.effect. DropShadow

设置属性blurType的值。

setBlurType(BlurType) - Method in class javafx.scene.effect. InnerShadow

设置属性blurType的值。

setBlurType(BlurType) - Method in class javafx.scene.effect. Shadow

设置属性blurType的值。

setBody(HTMLElement) - Method in interface org.w3c.dom.html. HTMLDocument

setBold(MutableAttributeSet, boolean) - Static method in class javax.swing.text. StyleConstants

设置粗体属性。

setBoolean(int, boolean) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java boolean值。

setBoolean(int, boolean) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中的给定的 boolean 。

setBoolean(int, boolean) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java boolean值。

setBoolean(Object, boolean) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 boolean 。

setBoolean(Object, int, boolean) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的 boolean值。

setBoolean(String, boolean) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java boolean值。

setBoolean(String, boolean) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java boolean值。

setBoolean(String, boolean) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java boolean值。

setBorder(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border属性定义。

setBorder(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setBorder(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setBorder(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setBorder(Border) - Method in class javafx.scene.layout. Region

设置属性边框的值。

setBorder(Border) - Method in class javax.swing.border. TitledBorder

设置标题边框的边框。

setBorder(Border) - Method in class javax.swing. JComponent

设置此组件的边框。

setBorder(Border) - Method in class javax.swing. JLayer

将其功能委托给 getView().setBorder(Border)方法，如果视图组件是 javax.swing.JComponent的实例，否则此方法是无操作的。

setBorder(Border) - Method in class javax.swing. JViewport

视口通过正常的父/子剪辑（通常视图沿滚动的相反方向移动）“滚动”其孩子（称为“视图”）。

setBorder(Border) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

设置此组件的边框。

setBorder(Border) - Method in class javax.swing.tree. DefaultTreeCellEditor.DefaultTextField

设置此组件的边框。

setBorderBottom(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom属性定义。

setBorderBottomColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom-color属性定义。

setBorderBottomStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom-style属性定义。

setBorderBottomWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-bottom-width属性定义。

setBorderCollapse(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-collapse属性定义。

setBorderColor(Color) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow

设置边框颜色。

setBorderColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-color属性定义。

setBorderLeft(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left属性定义。

setBorderLeftColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left-color属性定义。

setBorderLeftStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left-style属性定义。

setBorderLeftWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-left-width属性定义。

setBorderPainted(boolean) - Method in class javax.swing. AbstractButton

设置 borderPainted属性。

setBorderPainted(boolean) - Method in class javax.swing. JMenuBar

设置是否应绘制边框。

setBorderPainted(boolean) - Method in class javax.swing. JPopupMenu

设置是否应绘制边框。

setBorderPainted(boolean) - Method in class javax.swing. JProgressBar

设置 borderPainted属性，如果进度条应该绘制其边框，则为 true 。

setBorderPainted(boolean) - Method in class javax.swing. JToolBar

设置 borderPainted属性，如果边框应该绘制，则为 true 。

setBorderPaintedFlat(boolean) - Method in class javax.swing. JCheckBox

设置 borderPaintedFlat属性，它提供了对复选框边框外观的看法和感觉。

setBorderRight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right属性定义。

setBorderRightColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right-color属性定义。

setBorderRightStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right-style属性定义。

setBorderRightWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-right-width属性定义。

setBorderSelectionColor(Color) - Method in class javax.swing.tree. DefaultTreeCellEditor

设置要用于边框的颜色。

setBorderSelectionColor(Color) - Method in class javax.swing.tree. DefaultTreeCellRenderer

设置要用于边框的颜色。

setBorderSpacing(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-spacing属性定义。

setBorderStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-style属性定义。

setBorderToNonRollover(Component) - Method in class javax.swing.plaf.basic. BasicToolBarUI

将组件的边框设置为具有由 BasicToolBarUI.createNonRolloverBorder()方法创建的非滚动边框。

setBorderToNonRollover(Component) - Method in class javax.swing.plaf.metal. MetalToolBarUI

setBorderToNonRollover(Component) - Method in class javax.swing.plaf.synth. SynthToolBarUI

这个实现什么都不做，因为 JToolBar类的 rollover属性没有用在Synth Look and Feel中。

setBorderToNormal(Component) - Method in class javax.swing.plaf.basic. BasicToolBarUI

将组件的边框设置为具有正常边框。

setBorderToNormal(Component) - Method in class javax.swing.plaf.synth. SynthToolBarUI

这个实现什么都不做，因为 JToolBar类的 rollover属性在Synth Look和Feel中没有使用。

setBorderTop(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top属性定义。

setBorderTopColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top-color属性定义。

setBorderTopStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top-style属性定义。

setBorderTopWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-top-width属性定义。

setBorderToRollover(Component) - Method in class javax.swing.plaf.basic. BasicToolBarUI

将组件的边框设置为具有由 BasicToolBarUI.createRolloverBorder()方法创建的翻转边框。

setBorderToRollover(Component) - Method in class javax.swing.plaf.synth. SynthToolBarUI

这个实现什么都不做，因为 JToolBar类的 rollover属性没有在Synth Look和Feel中使用。

setBorderWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的border-width属性定义。

setBottom(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的底层属性定义。

setBottom(Node) - Method in class javafx.scene.layout. BorderPane

设置属性值的底部。

setBottomAnchor(Node, Double) - Static method in class javafx.scene.layout. AnchorPane

设置锚定窗格包含的小孩的底部锚点。

setBottomComponent(Component) - Method in class javax.swing. JSplitPane

设置下面的分量，或分配器的右侧。

setBottomInput(Effect) - Method in class javafx.scene.effect. Blend

设置属性bottomInput的值。

setBottomInset(float) - Method in class javax.swing.text. AsyncBoxView

将边缘的底部部分设置在视图周围。

setBottomOpacity(double) - Method in class javafx.scene.effect. Reflection

设置属性bottomOpacity的值。

setBound(boolean) - Method in class java.beans. PropertyDescriptor

对“绑定”属性的更新将导致在属性更改时触发“PropertyChange”事件。

setBounds(int, int, int, int) - Method in class java.awt. Component

移动并调整此组件的大小。

setBounds(int, int, int, int) - Method in class java.awt. Rectangle

设置边界 Rectangle如此 Rectangle到指定 x ， y ， width ，并 height 。

setBounds(int, int, int, int) - Method in class java.awt. Window

移动并调整此组件的大小。

setBounds(Rectangle) - Method in class com.sun.java.accessibility.util. Translator

设置此对象的当前边界。

setBounds(Rectangle) - Method in class java.awt. Component.AccessibleAWTComponent

以 Rectangle对象的形式设置此对象的边界。

setBounds(Rectangle) - Method in class java.awt. Component

移动并调整此组件的大小以符合新的边界矩形 r 。

setBounds(Rectangle) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

以Rectangle对象的形式设置此对象的边界。

setBounds(Rectangle) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

以 Rectangle对象的形式设置此对象的边界。

setBounds(Rectangle) - Method in class java.awt. Rectangle

设置此 Rectangle的边界 Rectangle以匹配指定的 Rectangle 。

setBounds(Rectangle) - Method in class java.awt. Window

移动并调整此组件的大小以符合新的边界矩形 r 。

setBounds(Rectangle) - Method in interface javax.accessibility. AccessibleComponent

以 Rectangle对象的形式设置此对象的边界。

setBounds(Rectangle) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setBounds(Rectangle) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

setBounds(Rectangle) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setBounds(Rectangle) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setBoundsForFrame(JComponent, int, int, int, int) - Method in class javax.swing. DefaultDesktopManager

这使得 JComponent和损坏的地区被重绘。

setBoundsForFrame(JComponent, int, int, int, int) - Method in interface javax.swing. DesktopManager

这是一个原始的重塑方法。

setBoundsType(TextBoundsType) - Method in class javafx.scene.text. Text

设置属性boundsType的值。

setBreakIterator(BreakIterator) - Method in class com.sun.source.util. DocTrees

设置break迭代器来计算文档注释的第一个句子。

setBrightness(double) - Method in class javafx.scene.effect. ColorAdjust

设置属性亮度的值。

setBroadcast(boolean) - Method in class java.net. DatagramSocket

启用/禁用SO_BROADCAST。

setBuilder(DocumentBuilder) - Method in class javax.xml.bind.annotation. W3CDomHandler

setBuilderFactory(BuilderFactory) - Method in class javafx.fxml. FXMLLoader

设置此装载器使用的构建器工厂。

setBumpInput(Effect) - Method in class javafx.scene.effect. Lighting

设置属性bumpInput的值。

setBumpMap(Image) - Method in class javafx.scene.paint. PhongMaterial

设置属性bumpMap的值。

setButtonCell(ListCell<T>) - Method in class javafx.scene.control. ComboBox

设置属性buttonCell的值。

setButtonData(Node, ButtonBar.ButtonData) - Static method in class javafx.scene.control. ButtonBar

在给定的按钮上设置给定的ButtonData。

setButtonIcons() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

设置按钮图标。

setButtonMinWidth(double) - Method in class javafx.scene.control. ButtonBar

设置放置在此按钮栏中的所有按钮的最小宽度。

setButtonOrder(String) - Method in class javafx.scene.control. ButtonBar

设置 button order

setButtonUniformSize(Node, boolean) - Static method in class javafx.scene.control. ButtonBar

默认情况下，所有按钮在ButtonBar中均匀的大小，这意味着所有按钮都占据最宽按钮的宽度。

setByAngle(double) - Method in class javafx.animation. RotateTransition

设置属性的值byAngle。

setByte(int, byte) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java byte值。

setByte(int, byte) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中给定的 byte 。

setByte(int, byte) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java byte值。

setByte(Object, byte) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 byte 。

setByte(Object, int, byte) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的 byte值。

setByte(String, byte) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java byte值。

setByte(String, byte) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java byte值。

setByte(String, byte) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java byte值。

setByteOrder(ByteOrder) - Method in interface javax.imageio.stream. ImageInputStream

设置用于将来从该流读取数据值的字节顺序。

setByteOrder(ByteOrder) - Method in class javax.imageio.stream. ImageInputStreamImpl

setBytes(int, byte[]) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java字节数组。

setBytes(int, byte[]) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的字节数组。

setBytes(int, byte[]) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 byte值的Java数组。

setBytes(long, byte[]) - Method in interface java.sql. Blob

将给定的字节数组写入 Blob对象表示的 BLOB值，从位置 pos开始，并返回写入的字节数。

setBytes(long, byte[]) - Method in class javax.sql.rowset.serial. SerialBlob

将给定的字节数组写入 Blob对象表示的 BLOB值，从位置 pos开始，并返回写入的字节数。

setBytes(long, byte[], int, int) - Method in interface java.sql. Blob

将所有或部分给定的 byte数组写入 Blob对象所表示的 BLOB值，并返回写入的字节数。

setBytes(long, byte[], int, int) - Method in class javax.sql.rowset.serial. SerialBlob

将所有或部分给定的 byte数组写入 Blob对象所表示的 BLOB值，并返回写入的字节数。

setBytes(String, byte[]) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java字节数组。

setBytes(String, byte[]) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java字节数组。

setBytes(String, byte[]) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java字节数组。

setByteStream(InputStream) - Method in interface org.w3c.dom.ls. LSInput

表示字节流的语言和绑定依赖类型的属性。

setByteStream(InputStream) - Method in class org.xml.sax. InputSource

设置此输入源的字节流。

setByteStream(OutputStream) - Method in interface org.w3c.dom.ls. LSOutput

表示可写入字节流的语言和绑定依赖类型的属性。

setByValue(double) - Method in class javafx.animation. FadeTransition

通过值设置属性的值。

setByX(double) - Method in class javafx.animation. ScaleTransition

设置属性的值byX。

setByX(double) - Method in class javafx.animation. TranslateTransition

设置属性的值byX。

setByY(double) - Method in class javafx.animation. ScaleTransition

设置属性的值byY。

setByY(double) - Method in class javafx.animation. TranslateTransition

设置属性的值byY。

setByZ(double) - Method in class javafx.animation. ScaleTransition

设置属性的值byZ。

setByZ(double) - Method in class javafx.animation. TranslateTransition

设置属性的值byZ。

setCache(boolean) - Method in class javafx.scene. Node

设置属性缓存的值。

setCacheDirectory(File) - Static method in class javax.imageio. ImageIO

设置要创建缓存文件的目录。

setCacheHint(CacheHint) - Method in class javafx.scene. Node

设置属性cacheHint的值。

setCacheShape(boolean) - Method in class javafx.scene.layout. Region

设置属性cacheShape的值。

setCalendar(Calendar) - Method in class java.text. DateFormat

将日历设置为使用此日期格式。

setCalendarField(int) - Method in class javax.swing. SpinnerDateModel

更改由 nextValue和 previousValue方法计算的日期值更改的大小。

setCalendarType(String) - Method in class java.util. Calendar.Builder

将日历类型参数设置为给定的 type 。

setCallbackHandler(CallbackHandler) - Method in class java.security. AuthProvider

设置一个 CallbackHandler 。

setCamera(Camera) - Method in class javafx.scene. Scene

设置属性摄像机的值。

setCamera(Camera) - Method in class javafx.scene. SnapshotParameters

将相机设置为指定值。

setCamera(Camera) - Method in class javafx.scene. SubScene

设置属性摄像机的值。

setCancelButton(boolean) - Method in class javafx.scene.control. Button

设置属性cancelButton的值。

setCanWrapLines(boolean) - Method in class javax.swing.text. AbstractWriter

设置是否可以包装线。

setCaption(HTMLTableCaptionElement) - Method in interface org.w3c.dom.html. HTMLTableElement

setCaptionSide(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的标题侧属性定义。

setCaret(Caret) - Method in class javax.swing.text. JTextComponent

设置要使用的插入符号。

setCaretAnimating(boolean) - Method in class javafx.scene.control.skin. TextInputControlSkin

启动或停止插入符号闪烁。

setCaretBias(boolean) - Method in class javafx.scene.text. Text

插入偏见的内容。

setCaretColor(Color) - Method in class javax.swing.text. JTextComponent

设置用于渲染插入符号的当前颜色。

setCaretPosition(int) - Method in class java.awt. TextComponent

设置文本插入插入符的位置。

setCaretPosition(int) - Method in class javafx.scene.control. TextFormatter.Change

设置插入位置。

setCaretPosition(int) - Method in class javafx.scene.text. Text

插入索引的内容。

setCaretPosition(int) - Method in class javax.swing.text. JTextComponent

设置 TextComponent的文本插入插入符的 TextComponent 。

setCaseSensitive(int, boolean) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置指定列的名称是否对给定的 boolean区分大小写。

setCaseSensitive(int, boolean) - Method in interface javax.sql. RowSetMetaData

设置指定列是否区分大小写。

setCatalog(String) - Method in interface java.sql. Connection

设置给定的目录名称，以便选择要在其中运行的 Connection对象的数据库的子空间。

setCatalogName(int, String) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将派生指定列的表的目录名称设置为 catalogName 。

setCatalogName(int, String) - Method in interface javax.sql. RowSetMetaData

将指定列的表的目录名称（如果有）设置为给定的 String 。

setCategories(ObservableList<String>) - Method in class javafx.scene.chart. CategoryAxis

在此轴上绘制的类别的有序列表。

setCategoryGap(double) - Method in class javafx.scene.chart. BarChart

设置属性categoryGap的值。

setCategoryGap(double) - Method in class javafx.scene.chart. StackedBarChart

设置属性categoryGap的值。

setCellCount(int) - Method in class javafx.scene.control.skin. VirtualFlow

设置属性cellCount的值。

setCellEditor(TableCellEditor) - Method in class javax.swing. JTable

设置活动单元格编辑器。

setCellEditor(TableCellEditor) - Method in class javax.swing.table. TableColumn

设置编辑此列中的单元格时使用的编辑器。

setCellEditor(TreeCellEditor) - Method in class javax.swing. JTree

设置单元格编辑器。

setCellEditor(TreeCellEditor) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置单元格编辑器。

setCellFactory(Callback<ListView<T>, ListCell<T>>) - Method in class javafx.scene.control. ComboBox

设置属性cellFactory的值。

setCellFactory(Callback<ListView<T>, ListCell<T>>) - Method in class javafx.scene.control. ListView

设置要在ListView中使用的新单元格工厂。

setCellFactory(Callback<VirtualFlow<T>, T>) - Method in class javafx.scene.control.skin. VirtualFlow

设置要在VirtualFlow中使用的新单元格工厂。

setCellFactory(Callback<TableColumn<S, T>, TableCell<S, T>>) - Method in class javafx.scene.control. TableColumn

设置属性cellFactory的值。

setCellFactory(Callback<TreeTableColumn<S, T>, TreeTableCell<S, T>>) - Method in class javafx.scene.control. TreeTableColumn

设置属性cellFactory的值。

setCellFactory(Callback<TreeView<T>, TreeCell<T>>) - Method in class javafx.scene.control. TreeView

设置将用于创建TreeCells的单元格工厂，用于表示TreeView中的项目。

setCellIndex(T, int) - Method in class javafx.scene.control.skin. VirtualFlow

VirtualFlow使用此方法设置单元 格索引（而不是直接调用 IndexedCell.updateIndex(int) ），因此如果感兴趣，它是子类覆盖的完美场所。

setCellLength(int) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

设置单元格长度。

setCellPadding(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setCellRenderer(ListCellRenderer<? super E>) - Method in class javax.swing. JList

设置用于绘制列表中每个单元格的委托。

setCellRenderer(TableCellRenderer) - Method in class javax.swing.table. TableColumn

设置 TableCellRenderer使用的 JTable来绘制此列的各个值。

setCellRenderer(TreeCellRenderer) - Method in class javax.swing. JTree

设置将用于绘制每个单元格的 TreeCellRenderer 。

setCellRenderer(TreeCellRenderer) - Method in class javax.swing.plaf.basic. BasicTreeUI

将 TreeCellRenderer设为 tcr 。

setCellSelectionEnabled(boolean) - Method in class javafx.scene.control. TableSelectionModel

设置属性cellSelectionEnabled的值。

setCellSelectionEnabled(boolean) - Method in class javax.swing. JTable

设置此表是否同时允许列选择和行选择。

setCellSpacing(int) - Method in class javax.swing.plaf.basic. BasicProgressBarUI

设置单元格间距。

setCellSpacing(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setCellValueFactory(Callback<TableColumn.CellDataFeatures<S, T>, ObservableValue<T>>) - Method in class javafx.scene.control. TableColumn

设置属性cellValueFactory的值。

setCellValueFactory(Callback<TreeTableColumn.CellDataFeatures<S, T>, ObservableValue<T>>) - Method in class javafx.scene.control. TreeTableColumn

设置属性cellValueFactory的值。

setCenter(Node) - Method in class javafx.scene.layout. BorderPane

设置物业中心的价值。

setCenterFrequency(double) - Method in class javafx.scene.media. EqualizerBand

设定赫兹频带上的中心频率。

setCentersChildren(boolean) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

设置是否应该使用中心儿童。

setCenterShape(boolean) - Method in class javafx.scene.layout. Region

设置属性centerShape的值。

setCenterX(double) - Method in class javafx.scene.shape. Arc

设置属性centerX的值。

setCenterX(double) - Method in class javafx.scene.shape. Circle

设置属性centerX的值。

setCenterX(double) - Method in class javafx.scene.shape. Ellipse

设置属性centerX的值。

setCenterY(double) - Method in class javafx.scene.shape. Arc

设置属性centerY的值。

setCenterY(double) - Method in class javafx.scene.shape. Circle

设置属性centerY的值。

setCenterY(double) - Method in class javafx.scene.shape. Ellipse

设置属性centerY的值。

setCertificate(X509Certificate) - Method in class java.security.cert. X509CertSelector

设置certificateEquals标准。

setCertificateChecking(X509Certificate) - Method in class java.security.cert. X509CRLSelector

设置正在检查的证书。

setCertificateEntry(String, Certificate) - Method in class java.security. KeyStore

将给定的可信证书分配给给定的别名。

setCertificateValid(Date) - Method in class java.security.cert. X509CertSelector

设置certificateValid标准。

setCertifiedText(boolean) - Method in interface org.w3c.dom.ls. LSInput

如果设置为true，则假设在解析[ XML 1.1 ]时输入已被认证（参见[ XML 1.1 ]中的2.13部分）。

setCertPathCheckers(List<PKIXCertPathChecker>) - Method in class java.security.cert. PKIXParameters

设置一个额外的认证路径检查器 List 。

setCertStores(List<CertStore>) - Method in class java.security.cert. PKIXParameters

设置用于查找证书和CRL的 CertStore的列表。

setCh(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setCh(String) - Method in interface org.w3c.dom.html. HTMLTableColElement

setCh(String) - Method in interface org.w3c.dom.html. HTMLTableRowElement

setCh(String) - Method in interface org.w3c.dom.html. HTMLTableSectionElement

setChanged() - Method in class java.util. Observable

已过时。

将此Observable对象标记为已更改; hasChanged方法现在将返回true 。

SetChangeListener< E> - Interface in javafx.collections

接收ObservableSet更改通知的接口。

SetChangeListener.Change< E> - Class in javafx.collections

对ObservableSet进行基本更改。

setChannelBinding(ChannelBinding) - Method in interface org.ietf.jgss. GSSContext

设置在上下文建立期间要使用的通道绑定。

setChannelPressure(int) - Method in interface javax.sound.midi. MidiChannel

反应键盘压力的变化。

setChar(Object, char) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 char 。

setChar(Object, int, char) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的 char值。

setCharacterAttributes(int, int, AttributeSet, boolean) - Method in class javax.swing.text. DefaultStyledDocument

设置文档某些部分的属性。

setCharacterAttributes(int, int, AttributeSet, boolean) - Method in interface javax.swing.text. StyledDocument

更改用于文档中现有内容的给定范围的内容元素属性。

setCharacterAttributes(JEditorPane, AttributeSet, boolean) - Method in class javax.swing.text. StyledEditorKit.StyledTextAction

将给定的属性应用于字符内容。

setCharacterAttributes(AttributeSet, boolean) - Method in class javax.swing. JTextPane

将给定的属性应用于字符内容。

setCharacterStream() - Method in interface java.sql. SQLXML

检索要用于写入此SQLXML实例所代表的XML值的流。

setCharacterStream(int, Reader) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 Reader对象。

setCharacterStream(int, Reader) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的命令中的指定参数设置为给定的 Reader对象。

setCharacterStream(int, Reader) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中指定的参数设置为给定的 Reader对象。

setCharacterStream(int, Reader, int) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

setCharacterStream(int, Reader, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.io.Reader对象，该对象将具有指定的字符数。

setCharacterStream(int, Reader, int) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 java.io.Reader值。

setCharacterStream(int, Reader, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

setCharacterStream(long) - Method in interface java.sql. Clob

检索流用于写入的Unicode字符流的 CLOB值，这 Clob对象表示，在位置 pos 。

setCharacterStream(long) - Method in class javax.sql.rowset.serial. SerialClob

检索要用于将Unicode字符流写入 SerialClob对象所代表的值为 CLOB的流，位置为 pos 。

setCharacterStream(Reader) - Method in interface org.w3c.dom.ls. LSInput

一种表示16位单位流的语言和绑定依赖类型的属性。

setCharacterStream(Reader) - Method in class org.xml.sax. InputSource

设置此输入源的字符流。

setCharacterStream(Writer) - Method in interface org.w3c.dom.ls. LSOutput

表示可输出16位单位的可写入流的语言和绑定依赖类型的属性。

setCharacterStream(String, Reader) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 Reader对象。

setCharacterStream(String, Reader) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 Reader对象。

setCharacterStream(String, Reader) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 Reader对象。

setCharacterStream(String, Reader, int) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

setCharacterStream(String, Reader, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

setCharacterStream(String, Reader, int) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

setCharacterStream(String, Reader, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

setCharacterSubsets(Character.Subset[]) - Method in class java.awt.im. InputContext

设置输入上下文输入方法的Unicode字符集的子集。

setCharacterSubsets(Character.Subset[]) - Method in interface java.awt.im.spi. InputMethod

设置该输入法允许输入的Unicode字符集的子集。

setCharAt(int, char) - Method in class java.lang. StringBuffer

setCharset(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setCharset(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setCharset(String) - Method in interface org.w3c.dom.html. HTMLScriptElement

setCharset(Charset) - Method in class javafx.fxml. FXMLLoader

设置此装载器使用的字符集。

setCheckboxGroup(CheckboxGroup) - Method in class java.awt. Checkbox

将此复选框的组设置为指定的复选框组。

setChecked(boolean) - Method in interface org.w3c.dom.html. HTMLInputElement

setChOff(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setChOff(String) - Method in interface org.w3c.dom.html. HTMLTableColElement

setChOff(String) - Method in interface org.w3c.dom.html. HTMLTableRowElement

setChOff(String) - Method in interface org.w3c.dom.html. HTMLTableSectionElement

setChoices(double[], String[]) - Method in class java.text. ChoiceFormat

设置要在格式化中使用的选项。

setChoke(double) - Method in class javafx.scene.effect. InnerShadow

设置属性阻塞的值。

setChooserPanels(AbstractColorChooserPanel[]) - Method in class javax.swing. JColorChooser

指定用于选择颜色值的颜色面板。

setChronology(Chronology) - Method in class javafx.scene.control. DatePicker

设置属性年表的值。

setChunkedStreamingMode(int) - Method in class java.net. HttpURLConnection

当内容长度 未提前知道时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。

setCipherSuites(String[]) - Method in class com.sun.net.httpserver. HttpsParameters

设置密码组数组。

setCipherSuites(String[]) - Method in class javax.net.ssl. SSLParameters

设置密码组数组。

setCite(String) - Method in interface org.w3c.dom.html. HTMLModElement

setCite(String) - Method in interface org.w3c.dom.html. HTMLQuoteElement

setClassAssertionStatus(String, boolean) - Method in class java.lang. ClassLoader

为此类加载器中指定的顶级类和其中包含的任何嵌套类设置所需的断言状态。

setClassLoader(ClassLoader) - Method in class javafx.fxml. FXMLLoader

设置此装载器使用的类加载器，并清除任何现有的导入。

setClassLoader(ClassLoader) - Method in class jdk.dynalink. DynamicLinkerFactory

设置用于自动发现可用的保护动态链接器的类加载器。

setClassName(String) - Method in class javax.naming. NameClassPair

设置此绑定的类名。

setClassName(String) - Method in interface org.w3c.dom.html. HTMLElement

setClear(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的清除属性定义。

setClear(String) - Method in interface org.w3c.dom.html. HTMLBRElement

setClickCountToStart(int) - Method in class javax.swing. DefaultCellEditor

指定开始编辑所需的点击次数。

setClientInfo(String, String) - Method in interface java.sql. Connection

将由name指定的客户端信息属性的值设置为由值指定的值。

setClientInfo(Properties) - Method in interface java.sql. Connection

设置连接的客户端信息属性的值。

setClip(int, int, int, int) - Method in class java.awt. Graphics

将当前剪辑设置为由给定坐标指定的矩形。

setClip(int, int, int, int) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.setClip 。

setClip(Shape) - Method in class java.awt. Graphics

将当前剪辑区域设置为任意剪辑形状。

setClip(Shape) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.setClip 。

setClip(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的剪辑属性定义。

setClip(Node) - Method in class javafx.scene. Node

设置属性剪辑的值。

setClob(int, Reader) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 Reader对象。

setClob(int, Reader) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setClob(int, Reader) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setClob(int, Reader, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 Reader对象。

setClob(int, Reader, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setClob(int, Reader, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setClob(int, Clob) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.sql.Clob对象。

setClob(int, Clob) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中给定的 Clob对象。

setClob(int, Clob) - Method in interface javax.sql. RowSet

使用给定的 Clob值在此 RowSet对象的命令中设置指定的参数。

setClob(String, Reader) - Method in interface java.sql. CallableStatement

将指定的参数设置为 Reader对象。

setClob(String, Reader) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setClob(String, Reader) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setClob(String, Reader, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为 Reader对象。

setClob(String, Reader, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setClob(String, Reader, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setClob(String, Clob) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.sql.Clob对象。

setClob(String, Clob) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Clob对象。

setClob(String, Clob) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.Clob对象。

setClockwise(boolean) - Method in class javafx.scene.chart. PieChart

顺时针设置属性的值。

setClosable(boolean) - Method in class javafx.scene.control. Tab

如果选项卡是可关闭的，请设置 true 。

setClosable(boolean) - Method in class javax.swing. JInternalFrame

设置这个 JInternalFrame是否可以通过某些用户操作关闭。

setClosed(boolean) - Method in class javax.swing. JInternalFrame

如果参数为 true则关闭此内部框架。

setClosedIcon(Icon) - Method in class javax.swing.tree. DefaultTreeCellRenderer

设置用于表示未展开的非叶节点的图标。

setCoalesce(boolean) - Method in class javax.swing. Timer

设置 Timer是否合并多个待处理的 ActionEvent启动。

setCoalescing(boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

指定此代码生成的解析器将CDATA节点转换为文本节点并将其附加到相邻（如果有的话）文本节点。

setCode(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setCode(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setCodeBase(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setCodeBase(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setCodeType(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setCollapsedIcon(Icon) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置折叠图标。

setCollapsible(boolean) - Method in class javafx.scene.control. TitledPane

指定TitledPane是否可以折叠。

setCollation(Collation) - Method in class javafx.print. JobSettings

设置 Collation属性。

setCollectionUsageThreshold(long) - Method in interface java.lang.management. MemoryPoolMXBean

将此内存池的集合使用阈值设置为给定的 threshold值。

setColor(int) - Method in class javax.swing. JColorChooser

将颜色选择器的当前颜色设置为指定的颜色。

setColor(int, int, int) - Method in class javax.swing. JColorChooser

将颜色选择器的当前颜色设置为指定的RGB颜色。

setColor(int, int, Color) - Method in interface javafx.scene.image. PixelWriter

将Color的像素数据存储到表面的指定坐标中。

setColor(Color) - Method in class java.awt. Graphics

将此图形上下文的当前颜色设置为指定的颜色。

setColor(Color) - Method in class javax.swing. DebugGraphics

设置用于绘制和填充线条和形状的颜色。

setColor(Color) - Method in class javax.swing. JColorChooser

将颜色选择器的当前颜色设置为指定的颜色。

setColor(PageAttributes.ColorType) - Method in class java.awt. PageAttributes

指定使用这些属性的页面是否以彩色或单色呈现。

setColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的颜色属性定义。

setColor(String) - Method in interface org.w3c.dom.html. HTMLBaseFontElement

setColor(String) - Method in interface org.w3c.dom.html. HTMLFontElement

setColor(Color) - Method in class javafx.scene.effect. DropShadow

设置属性颜色的值。

setColor(Color) - Method in class javafx.scene.effect. InnerShadow

设置属性颜色的值。

setColor(Color) - Method in class javafx.scene.effect. Light

设置属性颜色的值。

setColor(Color) - Method in class javafx.scene.effect. Shadow

设置属性颜色的值。

setColor(Color) - Method in class javafx.scene. LightBase

设置属性颜色的值。

setColorModel(ColorModel) - Method in class java.awt.image. BufferedImageFilter

对 ImageConsumer接口的 setColorModel方法中提供的信息进行过滤。

setColorModel(ColorModel) - Method in interface java.awt.image. ImageConsumer

设置使用setPixels方法调用报告的大多数像素使用的ColorModel对象。

setColorModel(ColorModel) - Method in class java.awt.image. ImageFilter

过滤ImageConsumer界面的setColorModel方法中提供的信息。

setColorModel(ColorModel) - Method in class java.awt.image. PixelGrabber

setColorModel方法是ImageConsumer API的一部分，该类必须实现此方法来检索像素。

setColorModel(ColorModel) - Method in class java.awt.image. RGBImageFilter

如果ColorModel是IndexColorModel，并且子类将canFilterIndexColorModel标志设置为true，则在此处替换颜色模型的过滤版本，并将原始ColorModel对象出现在setPixels方法中。

setColorTransparencySelectionEnabled(boolean) - Method in class javax.swing.colorchooser. AbstractColorChooserPanel

设置颜色选择器面板是否允许选择颜色的透明度（alpha值）。

setCols(int) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setCols(String) - Method in interface org.w3c.dom.html. HTMLFrameSetElement

setColSpan(int) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setColumnCount(int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置为给定数量的列数 RowSet针对此对象 RowSetMetaDataImpl创建对象。

setColumnCount(int) - Method in interface javax.sql. RowSetMetaData

将 RowSet对象中的列数设置为给定的数字。

setColumnCount(int) - Method in class javax.swing.table. DefaultTableModel

设置模型中的列数。

setColumnDisplaySize(int, int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将指定列中正常的最大字符数设置为给定的数字。

setColumnDisplaySize(int, int) - Method in interface javax.sql. RowSetMetaData

将指定列的正常最大宽度设置为给定的 int 。

setColumnHalignment(HPos) - Method in class javafx.scene.layout. FlowPane

设置属性columnHalignment的值。

setColumnHeader(JViewport) - Method in class javax.swing. JScrollPane

删除旧的columnHeader（如果存在） 如果新的columnHeader不是null ，则将其viewPosition的x坐标与视口（如果有的话）同步，然后将其添加到滚动窗格。

setColumnHeaderView(Component) - Method in class javax.swing. JScrollPane

如果需要，创建列标题视口，设置其视图，然后将列标题视口添加到滚动页面。

setColumnIdentifiers(Object[]) - Method in class javax.swing.table. DefaultTableModel

替换模型中的列标识符。

setColumnIdentifiers(Vector<?>) - Method in class javax.swing.table. DefaultTableModel

替换模型中的列标识符。

setColumnIndex(Node, Integer) - Static method in class javafx.scene.layout. GridPane

设置子窗格的列索引，当窗格包含时，它将从网格窗的该列开始定位。

setColumnLabel(int, String) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置建议的列标签，用于打印输出和显示（如果有） 标签 。

setColumnLabel(int, String) - Method in interface javax.sql. RowSetMetaData

设置建议的列标题用于打印输出和显示（如果有的话）给给定的 String 。

setColumnMargin(int) - Method in class javax.swing.table. DefaultTableColumnModel

将列边距设置为 newMargin 。

setColumnMargin(int) - Method in interface javax.swing.table. TableColumnModel

将 TableColumn的列边距设置为 newMargin 。

setColumnModel(TableColumnModel) - Method in class javax.swing. JTable

将此表的列模型设置为 columnModel并从新列模型注册侦听器通知。

setColumnModel(TableColumnModel) - Method in class javax.swing.table. JTableHeader

将此表的列模型设置为 newModel并从新列模型注册监听器通知。

setColumnName(int, String) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将指定列的列名称设置为给定的名称。

setColumnName(int, String) - Method in interface javax.sql. RowSetMetaData

将指定列的名称设置为给定的 String 。

setColumnNumber(int) - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

设置此事件定位器上的columnNumber字段。

setColumnNumber(int) - Method in exception jdk.nashorn.api.scripting. NashornException

设置这个 NashornException的列

setColumnNumber(int) - Method in class org.xml.sax.helpers. LocatorImpl

设置此定位器的列号（基于1）。

setColumnResizePolicy(Callback<TableView.ResizeFeatures, Boolean>) - Method in class javafx.scene.control. TableView

设置属性columnResizePolicy的值。

setColumnResizePolicy(Callback<TreeTableView.ResizeFeatures, Boolean>) - Method in class javafx.scene.control. TreeTableView

设置属性columnResizePolicy的值。

setColumns(int) - Method in class java.awt. GridLayout

将此布局中的列数设置为指定的值。

setColumns(int) - Method in class java.awt. TextArea

设置此文本区域的列数。

setColumns(int) - Method in class java.awt. TextField

设置此文本字段中的列数。

setColumns(int) - Method in class javax.swing. JTextArea

设置此TextArea的列数。

setColumns(int) - Method in class javax.swing. JTextField

设置此 TextField的列数，然后使布局无效。

setColumnSelectionAllowed(boolean) - Method in class javax.swing. JTable

设置是否可以选择此模型中的列。

setColumnSelectionAllowed(boolean) - Method in class javax.swing.table. DefaultTableColumnModel

设置是否允许列选择。

setColumnSelectionAllowed(boolean) - Method in interface javax.swing.table. TableColumnModel

设置是否可以选择此模型中的列。

setColumnSelectionInterval(int, int) - Method in class javax.swing. JTable

选择从 index0到 index1 （包括）的列。

setColumnSpan(Node, Integer) - Static method in class javafx.scene.layout. GridPane

设置子窗格包含的网格窗格的列跨度，以便它横跨该列数列。

setColumnType(int, int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将存储在指定列中的值的SQL类型代码设置为来自类 java.sql.Types的给定类型代码。

setColumnType(int, int) - Method in interface javax.sql. RowSetMetaData

将指定列的SQL类型设置为给定的列。

setColumnTypeName(int, String) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将存储在指定列中的值的数据源使用的类型名称设置为给定的类型名称。

setColumnTypeName(int, String) - Method in interface javax.sql. RowSetMetaData

将指定列的类型名称（如果有的话）设置为给定的 String 。

setComboBox(JComboBox<Object>) - Method in class javax.swing.plaf.metal. MetalComboBoxButton

设置 JComboBox 。

setComboBoxEditable(boolean) - Method in class javafx.scene.control.cell. ComboBoxListCell

将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。

setComboBoxEditable(boolean) - Method in class javafx.scene.control.cell. ComboBoxTableCell

将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。

setComboBoxEditable(boolean) - Method in class javafx.scene.control.cell. ComboBoxTreeCell

将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。

setComboBoxEditable(boolean) - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

将ComboBox配置为可编辑（允许用户输入超出下拉列表中提供的选项）。

setComboIcon(Icon) - Method in class javax.swing.plaf.metal. MetalComboBoxButton

设置 JComboBox的图标。

setCommand(String) - Method in class javax.sql.rowset. BaseRowSet

将该 RowSet对象的 command属性设置为给定的 String对象，并清除为先前命令设置的参数（如果有）。

setCommand(String) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令属性设置为给定的SQL查询。

setCommandContext(String, DataHandler) - Method in interface javax.activation. CommandObject

使用要处理的动词来初始化命令，以及描述将要操作的数据的DataHandler。

setCommandMap(CommandMap) - Method in class javax.activation. DataHandler

设置CommandMap以供DataHandler使用。

setComment(String) - Method in class java.net. HttpCookie

指定描述Cookie目的的注释。

setComment(String) - Method in class java.util.zip. ZipEntry

设置条目的可选注释字符串。

setComment(String) - Method in class java.util.zip. ZipOutputStream

设置ZIP文件注释。

setCommentURL(String) - Method in class java.net. HttpCookie

指定描述Cookie目的的注释URL。

setCommitsOnValidEdit(boolean) - Method in class javax.swing.text. DefaultFormatter

编辑编辑时设置为 JFormattedTextField 。

setCompact(boolean) - Method in interface org.w3c.dom.html. HTMLDirectoryElement

setCompact(boolean) - Method in interface org.w3c.dom.html. HTMLDListElement

setCompact(boolean) - Method in interface org.w3c.dom.html. HTMLMenuElement

setCompact(boolean) - Method in interface org.w3c.dom.html. HTMLOListElement

setCompact(boolean) - Method in interface org.w3c.dom.html. HTMLUListElement

setComparator(int, Comparator<?>) - Method in class javax.swing. DefaultRowSorter

设置要在排序指定的列时使用的 Comparator 。

setComparator(Comparator<? super E>) - Method in class javafx.collections.transformation. SortedList

设置属性比较器的值。

setComparator(Comparator<? super Component>) - Method in class javax.swing. SortingFocusTraversalPolicy

设置在焦点遍历周期中用于对组件进行排序的比较器。

setComparator(Comparator<T>) - Method in class javafx.scene.control. TableColumnBase

设置属性比较器的值。

setComponent(Component) - Method in class java.awt.dnd. DragGestureRecognizer

将DragGestureRecognizer与registerListeners（）和unregisterListeners（）相关联的组件设置为适当的副作用。

setComponent(Component) - Method in class java.awt.dnd. DropTarget

注意：此接口需要允许以两种方式之一安全地将DropTarget与组件关联： component.setDropTarget(droptarget);或 droptarget.setComponent(component);

setComponent(JComponent) - Method in class javax.swing. JToolTip

指定工具提示描述的组件。

setComponent(MutableAttributeSet, Component) - Static method in class javax.swing.text. StyleConstants

设置组件属性。

setComponentAt(int, Component) - Method in class javax.swing. JTabbedPane

将组件设置为 index至 component 。

setComponentOrientation(ComponentOrientation) - Method in class java.awt. Component

设置用于对该组件中的元素或文本进行排序的语言敏感方向。

setComponentOrientation(ComponentOrientation) - Method in class javax.swing. JMenu

setComponentOrientation(ComponentOrientation) - Method in class javax.swing. JScrollPane

设置由 ComponentOrientation参数确定的垂直和水平滚动条的方向。

setComponentOrientation(ComponentOrientation) - Method in class javax.swing. JSpinner.NumberEditor

设置用于对该组件中的元素或文本进行排序的语言敏感方向。

setComponentOrientation(ComponentOrientation) - Method in class javax.swing.text. JTextComponent

setComponentPopupMenu(JPopupMenu) - Method in class javax.swing. JComponent

设置 JPopupMenu为这 JComponent 。

setComponentToSize(Component, int, int, Insets, Dimension) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

将组件 c的宽度设置为 size ，将其x位置设置为 location ，将y设置为 insets.top并将高度设置为 containerSize.height减少顶部和底部插入。

setComponentZOrder(Component, int) - Method in class java.awt. Container

将指定的组件移动到容器中指定的z顺序索引。

setComponentZOrder(Component, int) - Method in class javax.swing. JDesktopPane

将指定的组件移动到容器中指定的z顺序索引。

setComposite(Composite) - Method in class java.awt. Graphics2D

设置 Composite为 Graphics2D的上下文。

setCompositionEnabled(boolean) - Method in class java.awt.im. InputContext

根据参数 enable的值，启用或禁用当前的组合输入方法。

setCompositionEnabled(boolean) - Method in interface java.awt.im.spi. InputMethod

根据参数 enable的值启用或禁用此输入法。

setCompressedSize(long) - Method in class java.util.zip. ZipEntry

设置压缩条目数据的大小。

setCompressionMode(int) - Method in class javax.imageio. ImageWriteParam

指定是否执行压缩，如果需要确定压缩参数。

setCompressionQuality(float) - Method in class javax.imageio. ImageWriteParam

将压缩质量设置为 0和 1之间的值。

setCompressionType(String) - Method in class javax.imageio. ImageWriteParam

将压缩类型设置为 getCompressionTypes指示的值 getCompressionTypes 。

setConcurrency(int) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的并发设置为指定的并发。

setConcurrency(int) - Method in interface javax.sql. RowSet

将此 RowSet对象的并发设置为给定的并发级别。

setConfiguration(Configuration) - Static method in class javax.security.auth.login. Configuration

设置登录 Configuration 。

setConfirmHandler(Callback<String, Boolean>) - Method in class javafx.scene.web. WebEngine

设置属性confirmHandler的值。

setConnectTimeout(int) - Method in class java.net. URLConnection

设置打开与此URLConnection引用的资源的通信链接时使用的指定超时值（以毫秒为单位）。

setConstrained(boolean) - Method in class java.beans. PropertyDescriptor

尝试更新“受限制”属性将导致在属性更改时触发“VetoableChange”事件。

setConstraint(String, Spring) - Method in class javax.swing. SpringLayout.Constraints

设置弹簧控制指定的边缘。

setConstraints(Component, GridBagConstraints) - Method in class java.awt. GridBagLayout

设置此布局中指定组件的约束。

setConstraints(Node, int, int) - Static method in class javafx.scene.layout. GridPane

设置子窗格中包含的列，行排列。

setConstraints(Node, int, int, int, int) - Static method in class javafx.scene.layout. GridPane

设置子网格中包含的列，列，列跨度和行跨度值。

setConstraints(Node, int, int, int, int, HPos, VPos) - Static method in class javafx.scene.layout. GridPane

设置网格位置，跨度和子对齐方式。

setConstraints(Node, int, int, int, int, HPos, VPos, Priority, Priority) - Static method in class javafx.scene.layout. GridPane

设置网格位置，跨度和子对齐方式。

setConstraints(Node, int, int, int, int, HPos, VPos, Priority, Priority, Insets) - Static method in class javafx.scene.layout. GridPane

设置网格位置，跨度，对齐方式，增加优先级，以及子窗格包含在网格中时的边距。

setConsumeAutoHidingEvents(boolean) - Method in class javafx.stage. PopupWindow

设置属性consumeAutoHidingEvents的值。

setContainerAlignment(Pos) - Method in class javafx.scene.control.skin. MenuBarSkin

设置属性containerAlignment的值。

setContent(Object, String) - Method in class javax.xml.soap. AttachmentPart

将此附件部分的内容设置为给定的 Object的内容，并将 Content-Type标头的值设置为给定类型。

setContent(String) - Method in class javafx.scene.shape. SVGPath

设置属性内容的值。

setContent(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的content属性定义。

setContent(String) - Method in interface org.w3c.dom.html. HTMLMetaElement

setContent(Map<DataFormat, Object>) - Method in class javafx.scene.input. Clipboard

将内容放在剪贴板上。

setContent(Node) - Method in class javafx.scene.control. CustomMenuItem

设置属性内容的值。

setContent(Node) - Method in class javafx.scene.control. DialogPane

分配对话框内容。

setContent(Node) - Method in class javafx.scene.control. ScrollPane

设置属性内容的值。

setContent(Node) - Method in class javafx.scene.control. Tab

内容显示在主TabPane区域内。

setContent(Node) - Method in class javafx.scene.control. TitledPane

TitlePane的内容可以是任何节点，如UI控件或添加到布局容器的节点组。

setContent(JComponent) - Method in class javafx.embed.swing. SwingNode

在这个 SwingNode附加一个 JComponent实例。

setContent(Source) - Method in class javax.xml.soap. SOAPPart

使用给定的 Source对象的数据设置 SOAPEnvelope对象的内容。

setContentAreaFilled(boolean) - Method in class javax.swing. AbstractButton

设置 contentAreaFilled属性。

setContentDescription(String) - Method in class javax.xml.soap. SOAPMessage

使用给定的说明设置此 SOAPMessage对象的内容的描述。

setContentDisplay(ContentDisplay) - Method in class javafx.scene.control. Labeled

设置属性contentDisplay的值。

setContentDisplay(ContentDisplay) - Method in class javafx.scene.control. Tooltip

设置属性contentDisplay的值。

setContentHandler(ContentHandler) - Method in class javax.xml.validation. ValidatorHandler

设置接收增强验证结果的ContentHandler 。

setContentHandler(ContentHandler) - Method in class org.xml.sax.helpers. ParserAdapter

设置内容处理程序。

setContentHandler(ContentHandler) - Method in class org.xml.sax.helpers. XMLFilterImpl

设置内容事件处理程序。

setContentHandler(ContentHandler) - Method in interface org.xml.sax. XMLReader

允许应用程序注册内容事件处理程序。

setContentHandlerFactory(ContentHandlerFactory) - Static method in class java.net. URLConnection

设置应用程序的 ContentHandlerFactory 。

setContentId(String) - Method in class javax.xml.soap. AttachmentPart

使用给定值设置名称为“Content-ID”的MIME标头。

setContentId(String) - Method in class javax.xml.soap. SOAPPart

将名为“Content-Id”的MIME头的值设置为给定的 String 。

setContentInput(Effect) - Method in class javafx.scene.effect. Lighting

设置属性contentInput的值。

setContentLocation(String) - Method in class javax.xml.soap. AttachmentPart

使用给定值设置名称为“Content-Location”的MIME头。

setContentLocation(String) - Method in class javax.xml.soap. SOAPPart

将MIME标题“Content-Location”的值设置为给定的 String 。

setContentPane(Container) - Method in class javax.swing. JApplet

已过时。

设置contentPane属性。

setContentPane(Container) - Method in class javax.swing. JDialog

设置 contentPane属性。

setContentPane(Container) - Method in class javax.swing. JFrame

设置 contentPane属性。

setContentPane(Container) - Method in class javax.swing. JInternalFrame

设置这个 JInternalFrame的 contentPane属性。

setContentPane(Container) - Method in class javax.swing. JRootPane

设置内容窗格 - 保存由根窗格加载的组件的容器。

setContentPane(Container) - Method in class javax.swing. JWindow

设置此窗口的 contentPane属性。

setContentPane(Container) - Method in interface javax.swing. RootPaneContainer

“contentPane”是应用程序特定组件的主容器。

setContents(Transferable) - Method in interface javax.jnlp. ClipboardService

将剪贴板的当前内容设置为指定的 Transferable对象。

setContents(Transferable, ClipboardOwner) - Method in class java.awt.datatransfer. Clipboard

将剪贴板的当前内容设置为指定的可转移对象，并将指定的剪贴板所有者注册为新内容的所有者。

setContentText(String) - Method in class javafx.scene.control. Dialog

设置在对话框内容区域显示的字符串。

setContentText(String) - Method in class javafx.scene.control. DialogPane

设置在对话框内容区域显示的字符串。

setContentType(String) - Method in class javax.swing. JEditorPane

设置此编辑器处理的内容类型。

setContentType(String) - Method in class javax.xml.soap. AttachmentPart

使用给定值设置名称为“Content-Type”的MIME头。

setContext(JConsoleContext) - Method in class com.sun.tools.jconsole. JConsolePlugin

设置表示与应用程序的连接的JConsoleContext对象。

setContext(ScriptContext) - Method in class javax.script. AbstractScriptEngine

将受保护的 context字段的值设置为指定的 ScriptContext 。

setContext(ScriptContext) - Method in interface javax.script. ScriptEngine

设置当未指定 ScriptContext时，其绑定，读取器和作者用于脚本执行的 ScriptEngine的默认值 ScriptContext 。

setContextClassLoader(ClassLoader) - Method in class java.lang. Thread

设置此线程的上下文ClassLoader。

setContextMenu(ContextMenu) - Method in class javafx.scene.control. Control

设置属性contextMenu的值。

setContextMenu(ContextMenu) - Method in class javafx.scene.control. Tab

指定上下文菜单，以显示用户在选项卡上的右键单击。

setContextMenu(ContextMenu) - Method in class javafx.scene.control. TableColumnBase

设置属性contextMenu的值。

setContextMenuEnabled(boolean) - Method in class javafx.scene.web. WebView

设置属性contextMenuEnabled的值。

setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

设置关于是否继续执行现有周期性任务的策略，即使该执行者已经是 shutdown 。

setContinuousLayout(boolean) - Method in class javax.swing. JSplitPane

设置 continuousLayout属性的值，该属性必须为 true以便在用户干预期间不断重新显示和布局子组件。

setContinuousLayout(boolean) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

打开/关闭连续布局。

setContrast(double) - Method in class javafx.scene.effect. ColorAdjust

设置属性对比度的值。

setControlButtonsAreShown(boolean) - Method in class javax.swing. JFileChooser

设置指示 批准和 取消按钮是否显示在文件选择器中的属性。

setController(Object) - Method in class javafx.fxml. FXMLLoader

设置与根对象关联的控制器。

setController(IIOParamController) - Method in class javax.imageio. IIOParam

设置 IIOParamController用于在调用 activateController方法时为此 IIOParam对象提供设置，覆盖任何默认控制器。

setController(IIOMetadataController) - Method in class javax.imageio.metadata. IIOMetadata

设置 IIOMetadataController用于在调用 activateController方法时为该 IIOMetadata对象提供设置，覆盖任何默认控制器。

setControllerFactory(Callback<Class<?>, Object>) - Method in class javafx.fxml. FXMLLoader

设置此装载机使用的控制器工厂。

setControlX(double) - Method in class javafx.scene.shape. QuadCurve

设置属性controlX的值。

setControlX(double) - Method in class javafx.scene.shape. QuadCurveTo

设置属性controlX的值。

setControlX1(double) - Method in class javafx.scene.shape. CubicCurve

设置属性controlX1的值。

setControlX1(double) - Method in class javafx.scene.shape. CubicCurveTo

设置属性controlX1的值。

setControlX2(double) - Method in class javafx.scene.shape. CubicCurve

设置属性controlX2的值。

setControlX2(double) - Method in class javafx.scene.shape. CubicCurveTo

设置属性controlX2的值。

setControlY(double) - Method in class javafx.scene.shape. QuadCurve

设置属性controlY的值。

setControlY(double) - Method in class javafx.scene.shape. QuadCurveTo

设置属性controlY的值。

setControlY1(double) - Method in class javafx.scene.shape. CubicCurve

设置属性controlY1的值。

setControlY1(double) - Method in class javafx.scene.shape. CubicCurveTo

设置属性controlY1的值。

setControlY2(double) - Method in class javafx.scene.shape. CubicCurve

设置属性controlY2的值。

setControlY2(double) - Method in class javafx.scene.shape. CubicCurveTo

设置属性controlY2的值。

setConverter(StringConverter<LocalDate>) - Method in class javafx.scene.control. DatePicker

设置属性转换器的值。

setConverter(StringConverter<TreeItem<T>>) - Method in class javafx.scene.control.cell. CheckBoxTreeCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. CheckBoxListCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. CheckBoxTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. CheckBoxTreeTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ChoiceBoxListCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ChoiceBoxTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ChoiceBoxTreeCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ComboBoxListCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ComboBoxTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ComboBoxTreeCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. TextFieldListCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. TextFieldTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. TextFieldTreeCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control.cell. TextFieldTreeTableCell

设置要在此单元格中使用的StringConverter 。

setConverter(StringConverter<T>) - Method in class javafx.scene.control. ChoiceBox

设置属性转换器的值。

setConverter(StringConverter<T>) - Method in class javafx.scene.control. ComboBox

设置属性转换器的值。

setConverter(StringConverter<T>) - Method in class javafx.scene.control. SpinnerValueFactory

设置属性转换器的值。

setCookie(String) - Method in interface org.w3c.dom.html. HTMLDocument

setCookiePolicy(CookiePolicy) - Method in class java.net. CookieManager

设置此Cookie管理器的Cookie策略。

setCoords(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setCoords(String) - Method in interface org.w3c.dom.html. HTMLAreaElement

setCopies(int) - Method in class java.awt. JobAttributes

指定应用程序应使用这些属性为作业呈现的副本数。

setCopies(int) - Method in class java.awt.print. PrinterJob

设置要打印的份数。

setCopies(int) - Method in class javafx.print. JobSettings

设置要打印的份数。

setCopiesToDefault() - Method in class java.awt. JobAttributes

设置应用程序应将这些属性的作业呈现给默认的副本数。

setCorePoolSize(int) - Method in class java.util.concurrent. ThreadPoolExecutor

设置核心线程数。

setCorner(String, Component) - Method in class javax.swing. JScrollPane

添加一个孩子，出现在一个滚动窗格的角落，如果有空间。

setCounterIncrement(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的counter-increment属性定义。

setCounterReset(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的counter-reset属性定义。

setCountLimit(long) - Method in class javax.naming.directory. SearchControls

设置搜索结果返回的最大条目数。

setCrc(long) - Method in class java.util.zip. ZipEntry

设置未压缩条目数据的CRC-32校验和。

setCreatePopupHandler(Callback<PopupFeatures, WebEngine>) - Method in class javafx.scene.web. WebEngine

设置属性createPopupHandler的值。

setCreateSymbols(boolean) - Method in class javafx.scene.chart. AreaChart

设置属性createSymbols的值。

setCreateSymbols(boolean) - Method in class javafx.scene.chart. LineChart

设置属性createSymbols的值。

setCreateSymbols(boolean) - Method in class javafx.scene.chart. StackedAreaChart

设置属性createSymbols的值。

setCreationTime(FileTime) - Method in class java.util.zip. ZipEntry

设置条目的创建时间。

setCssFloat(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的float属性定义。

setCssText(String) - Method in interface org.w3c.dom.css. CSSRule

规则的可理解的文本表示。

setCssText(String) - Method in interface org.w3c.dom.css. CSSStyleDeclaration

声明块的可解释文本表示（不包括周围的花括号）。

setCssText(String) - Method in interface org.w3c.dom.css. CSSValue

当前值的字符串表示形式。

setCue(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cue属性定义。

setCueAfter(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cue-after属性定义。

setCueBefore(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cue-before属性定义。

setCullFace(CullFace) - Method in class javafx.scene.shape. Shape3D

设置属性cullFace的值。

setCurrency(int, boolean) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置存储在指定列中的值是否为给定的 boolean的现金值。

setCurrency(int, boolean) - Method in interface javax.sql. RowSetMetaData

设置指定列是否为现金值。

setCurrency(Currency) - Method in class java.text. DecimalFormat

设置格式化货币值时此数字格式使用的货币。

setCurrency(Currency) - Method in class java.text. DecimalFormatSymbols

设置这些DecimalFormatSymbols的货币。

setCurrency(Currency) - Method in class java.text. NumberFormat

设置格式化货币值时此数字格式使用的货币。

setCurrencySymbol(String) - Method in class java.text. DecimalFormatSymbols

在其区域设置中设置这些DecimalFormatSymbols的货币的货币符号。

setCurrent(Checkbox) - Method in class java.awt. CheckboxGroup

已过时。
从JDK 1.1版开始，由setSelectedCheckbox(Checkbox)替代。

setCurrentAccessibleValue(Number) - Method in class java.awt. Button.AccessibleAWTButton

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class java.awt. Checkbox.AccessibleAWTCheckbox

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class java.awt. CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class java.awt. MenuItem.AccessibleAWTMenuItem

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class java.awt. Scrollbar.AccessibleAWTScrollBar

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in interface javax.accessibility. AccessibleValue

将此对象的值设置为 Number 。

setCurrentAccessibleValue(Number) - Method in class javax.swing. AbstractButton.AccessibleAbstractButton

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class javax.swing. JInternalFrame.AccessibleJInternalFrame

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class javax.swing. JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

将此对象的值设置为 Number 。

setCurrentAccessibleValue(Number) - Method in class javax.swing. JProgressBar.AccessibleJProgressBar

将该对象的值设置为 Number 。

setCurrentAccessibleValue(Number) - Method in class javax.swing. JScrollBar.AccessibleJScrollBar

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class javax.swing. JSlider.AccessibleJSlider

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class javax.swing. JSpinner.AccessibleJSpinner

将此对象的值设置为数字。

setCurrentAccessibleValue(Number) - Method in class javax.swing. JSplitPane.AccessibleJSplitPane

将此对象的值设置为数字。

setCurrentDirectory(File) - Method in class javax.swing. JFileChooser

设置当前目录。

setCurrentDisplayedExtraValue(XYChart.Data<X, Y>, Object) - Method in class javafx.scene.chart. XYChart

设置当前显示的数据额外值。

setCurrentDisplayedXValue(XYChart.Data<X, Y>, X) - Method in class javafx.scene.chart. XYChart

设置在X轴上绘制的当前显示数据值。

setCurrentDisplayedYValue(XYChart.Data<X, Y>, Y) - Method in class javafx.scene.chart. XYChart

设置在Y轴上绘制的当前显示数据值。

setCurrentKeyboardFocusManager(KeyboardFocusManager) - Static method in class java.awt. KeyboardFocusManager

为调用线程的上下文设置当前的KeyboardFocusManager实例。

setCurrentLineLength(int) - Method in class javax.swing.text. AbstractWriter

设置当前行长度。

setCurrentManager(FocusManager) - Static method in class javax.swing. FocusManager

为调用线程的上下文设置当前的 KeyboardFocusManager实例。

setCurrentManager(RepaintManager) - Static method in class javax.swing. RepaintManager

设置应该用于调用线程的RepaintManager。

setCurrentNode(Node) - Method in interface org.w3c.dom.traversal. TreeWalker

TreeWalker当前位于的节点。

setCurrentPageIndex(int) - Method in class javafx.scene.control. Pagination

设置当前页面索引。

setCurrentTheme(MetalTheme) - Static method in class javax.swing.plaf.metal. MetalLookAndFeel

设置 MetalLookAndFeel使用的主题。

setCursor(int) - Method in class java.awt. Frame

已过时。
从JDK 1.1版开始，由Component.setCursor(Cursor)替代。

setCursor(Cursor) - Method in class com.sun.java.accessibility.util. Translator

设置这个对象的 Cursor 。

setCursor(Cursor) - Method in class java.awt. Component.AccessibleAWTComponent

设置此对象的 Cursor 。

setCursor(Cursor) - Method in class java.awt. Component

将光标图像设置为指定的光标。

setCursor(Cursor) - Method in class java.awt.dnd. DragSourceContext

将此拖动操作的自定义光标设置为指定的 Cursor 。

setCursor(Cursor) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

设置此对象的Cursor。

setCursor(Cursor) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

设置此对象的 Cursor 。

setCursor(Cursor) - Method in class java.awt. Window

将光标图像设置为指定的光标。

setCursor(Cursor) - Method in interface javax.accessibility. AccessibleComponent

设置此对象的光标。

setCursor(Cursor) - Method in class javax.swing. JInternalFrame

将光标图像设置为指定的光标。

setCursor(Cursor) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setCursor(Cursor) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置此对象的 Cursor 。

setCursor(Cursor) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setCursor(Cursor) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setCursor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的cursor属性定义。

setCursor(Cursor) - Method in class javafx.scene. Node

设置属性游标的值。

setCursor(Cursor) - Method in class javafx.scene. Scene

设置属性游标的值。

setCursorName(String) - Method in interface java.sql. Statement

将SQL游标名称设置为给定的 String ，后者将被 Statement对象使用 execute方法。

setCurve(double[], int) - Method in class java.awt.geom. CubicCurve2D

将该曲线的终点和控制点的位置设置为指定数组中指定偏移处的双坐标。

setCurve(double[], int) - Method in class java.awt.geom. QuadCurve2D

将此 QuadCurve2D的终点和控制点的位置设置为指定数组中指定偏移量的 double坐标。

setCurve(double, double, double, double, double, double) - Method in class java.awt.geom. QuadCurve2D.Double

将该曲线的终点和控制点的位置设置为指定的 double坐标。

setCurve(double, double, double, double, double, double) - Method in class java.awt.geom. QuadCurve2D.Float

将该曲线的终点和控制点的位置设置为指定的 double坐标。

setCurve(double, double, double, double, double, double) - Method in class java.awt.geom. QuadCurve2D

将该曲线的终点和控制点的位置设置为指定的 double坐标。

setCurve(double, double, double, double, double, double, double, double) - Method in class java.awt.geom. CubicCurve2D.Double

将该曲线的终点和控制点的位置设置为指定的双坐标。

setCurve(double, double, double, double, double, double, double, double) - Method in class java.awt.geom. CubicCurve2D.Float

将该曲线的终点和控制点的位置设置为指定的双坐标。

setCurve(double, double, double, double, double, double, double, double) - Method in class java.awt.geom. CubicCurve2D

将该曲线的终点和控制点的位置设置为指定的双坐标。

setCurve(float, float, float, float, float, float) - Method in class java.awt.geom. QuadCurve2D.Float

将该曲线的终点和控制点的位置设置为指定的 float坐标。

setCurve(float, float, float, float, float, float, float, float) - Method in class java.awt.geom. CubicCurve2D.Float

将该曲线的终点和控制点的位置设置为指定的 float坐标。

setCurve(CubicCurve2D) - Method in class java.awt.geom. CubicCurve2D

将该曲线的终点和控制点的位置设置为与指定的 CubicCurve2D 。

setCurve(Point2D[], int) - Method in class java.awt.geom. CubicCurve2D

将该曲线的终点和控制点的位置设置为指定数组中指定偏移量处的 Point2D对象的坐标。

setCurve(Point2D[], int) - Method in class java.awt.geom. QuadCurve2D

将此 QuadCurve2D的终点和控制点的位置设置为指定数组中指定偏移量处的 Point2D对象的坐标。

setCurve(Point2D, Point2D, Point2D) - Method in class java.awt.geom. QuadCurve2D

将此 QuadCurve2D的终点和控制点的位置设置为指定的 Point2D坐标。

setCurve(Point2D, Point2D, Point2D, Point2D) - Method in class java.awt.geom. CubicCurve2D

将该曲线的终点和控制点的位置设置为指定的 Point2D坐标。

setCurve(QuadCurve2D) - Method in class java.awt.geom. QuadCurve2D

将此 QuadCurve2D的终点和控制点的位置设置为与指定的 QuadCurve2D 。

setCycleCount(int) - Method in class javafx.animation. Animation

设置属性cycleCount的值。

setCycleCount(int) - Method in class javafx.scene.media. AudioClip

设置默认循环计数。

setCycleCount(int) - Method in class javafx.scene.media. MediaPlayer

设置周期数。

setCycleDuration(Duration) - Method in class javafx.animation. Animation

设置属性cycleDuration的值。

setDaemon(boolean) - Method in class java.lang. Thread

将此线程标记为 daemon线程或用户线程。

setDaemon(boolean) - Method in class java.lang. ThreadGroup

更改此线程组的守护程序状态。

setData(byte[]) - Method in class java.net. DatagramPacket

设置此数据包的数据缓冲区。

setData(byte[]) - Method in class javax.imageio.stream. IIOByteBuffer

更新将通过后续调用 getData方法返回的数组引用。

setData(byte[], int, int) - Method in class java.net. DatagramPacket

设置此数据包的数据缓冲区。

setData(int, byte[]) - Method in class java.awt.color. ICC_Profile

从一个字节数组中设置一个特定的标记数据元素。

setData(Raster) - Method in class java.awt.image. BufferedImage

将图像的矩形区域设置为指定的 Raster r的内容，假定它与 BufferedImage位于相同的坐标空间。

setData(Raster) - Method in interface java.awt.image. WritableRenderedImage

将图像的矩形设置为Raster r的内容，该Raster r假定为与WritableRenderedImage在同一坐标空间。

setData(String) - Method in interface org.w3c.dom. CharacterData

实现此接口的节点的字符数据。

setData(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setData(String) - Method in interface org.w3c.dom. ProcessingInstruction

该处理指令的内容。

setData(ObservableList<PieChart.Data>) - Method in class javafx.scene.chart. PieChart

设置属性数据的值。

setData(ObservableList<XYChart.Data<X, Y>>) - Method in class javafx.scene.chart. XYChart.Series

设置属性数据的值。

setData(ObservableList<XYChart.Series<X, Y>>) - Method in class javafx.scene.chart. XYChart

设置属性数据的值。

setDataContentHandlerFactory(DataContentHandlerFactory) - Static method in class javax.activation. DataHandler

设置DataContentHandlerFactory。

setDataElements(int, int, int, int, Object) - Method in class java.awt.image. WritableRaster

从TransferType类型的原始数组中设置一个像素矩形的数据。

setDataElements(int, int, int, int, Object, DataBuffer) - Method in class java.awt.image. SampleModel

从TransferType类型的原始数组中设置指定DataBuffer中像素矩形的数据。

setDataElements(int, int, Raster) - Method in class java.awt.image. WritableRaster

从输入光栅设置像素矩形的数据。

setDataElements(int, int, Object) - Method in class java.awt.image. WritableRaster

从TransferType类型的原始数组中设置单个像素的数据。

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. BandedSampleModel

从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

设置在指定的一个单个像素的数据 DataBuffer从类型的基本数组 TransferType 。

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. MultiPixelPackedSampleModel

从TransferType类型的原始数组中设置指定的 DataBuffer单个像素的数据。

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. SampleModel

从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。

setDatagramSocketImplFactory(DatagramSocketImplFactory) - Static method in class java.net. DatagramSocket

设置应用程序的数据报套接字实现工厂。

setDataHandler(DataHandler) - Method in class javax.xml.soap. AttachmentPart

将给定 DataHandler对象作为此数据处理程序 AttachmentPart对象。

setDataSourceLock(int) - Method in class javax.sql.rowset.spi. SyncProvider

在 datasource_lock指示的级别设置底层数据源上的锁定。

setDataSourceName(String) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的 DataSource名称属性设置为给定的逻辑名称，并将此 RowSet对象的Url属性设置为 null 。

setDataSourceName(String) - Method in interface javax.sql. RowSet

将此 RowSet对象的数据源名称属性设置为给定的 String 。

setDatatypeConverter(DatatypeConverterInterface) - Static method in class javax.xml.bind. DatatypeConverter

此方法仅供JAXB提供者使用。

setDataVector(Object[][], Object[]) - Method in class javax.swing.table. DefaultTableModel

取代了的值 dataVector与阵列中的值的实例变量 dataVector 。

setDataVector(Vector<? extends Vector>, Vector<?>) - Method in class javax.swing.table. DefaultTableModel

用新的 Vector行替换当前的 dataVector实例变量， dataVector 。

setDate(int) - Method in class java.sql. Time

已过时。

setDate(int) - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.set(Calendar.DAY_OF_MONTH, int date)替换。

setDate(int, int, int) - Method in class java.util. Calendar.Builder

将日期字段参数设置 year month和 dayOfMonth给出的值。

setDate(int, Date) - Method in interface java.sql. PreparedStatement

使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。

setDate(int, Date) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Date值。

setDate(int, Date) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Date值。

setDate(int, Date, Calendar) - Method in interface java.sql. PreparedStatement

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

setDate(int, Date, Calendar) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Date对象。

setDate(int, Date, Calendar) - Method in interface javax.sql. RowSet

使用给定的 java.sql.Date值在此 RowSet对象的命令中设置指定的参数。

setDate(String, Date) - Method in interface java.sql. CallableStatement

使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。

setDate(String, Date) - Method in class javax.sql.rowset. BaseRowSet

使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。

setDate(String, Date) - Method in interface javax.sql. RowSet

使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。

setDate(String, Date, Calendar) - Method in interface java.sql. CallableStatement

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

setDate(String, Date, Calendar) - Method in class javax.sql.rowset. BaseRowSet

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

setDate(String, Date, Calendar) - Method in interface javax.sql. RowSet

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

setDate(Date) - Method in class java.security.cert. PKIXParameters

设置认证路径的有效性应该被确定的时间。

setDateAndTime(Date) - Method in class java.security.cert. X509CRLSelector

设置dateAndTime标准。

setDateFormatSymbols(DateFormatSymbols) - Method in class java.text. SimpleDateFormat

设置此日期格式的日期和时间格式符号。

setDateTime(String) - Method in interface org.w3c.dom.html. HTMLModElement

setDay(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设定月份的天数。

setDayCellFactory(Callback<DatePicker, DateCell>) - Method in class javafx.scene.control. DatePicker

设置属性dayCellFactory的值。

setDebugGraphicsOptions(int) - Method in class javax.swing. JComponent

启用或禁用有关组件或其子项之间执行的每个图形操作的诊断信息。

setDebugOptions(int) - Method in class javax.swing. DebugGraphics

启用/禁用有关每个图形操作的诊断信息。

setDebugTraceMode(int) - Method in interface com.sun.jdi. VirtualMachine

跟踪由com.sun.jdi实现执行的活动。

setDecimalFormatSymbols(DecimalFormatSymbols) - Method in class java.text. DecimalFormat

设置十进制格式符号，通常程序员或用户不会更改。

setDecimalSeparator(char) - Method in class java.text. DecimalFormatSymbols

设置用于十进制符号的字符。

setDecimalSeparatorAlwaysShown(boolean) - Method in class java.text. DecimalFormat

允许您使用整数设置小数分隔符的行为。

setDeclare(boolean) - Method in interface org.w3c.dom.html. HTMLObjectElement

setDeclared(int, boolean) - Method in class org.xml.sax.ext. Attributes2Impl

将值分配给特定属性的“声明”标志。

setDecodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - Method in class javax.imageio.plugins.jpeg. JPEGImageReadParam

设置用于解码缩写流的量化和霍夫曼表。

setDecomposition(int) - Method in class java.text. Collator

设置此Collator的分解模式。

setDefault(Authenticator) - Static method in class java.net. Authenticator

设置代理或HTTP服务器要求进行身份验证时由网络代码使用的身份验证器。

setDefault(CookieHandler) - Static method in class java.net. CookieHandler

设置（或取消）系统范围的Cookie处理程序。

setDefault(ProxySelector) - Static method in class java.net. ProxySelector

设置（或取消）系统范围的代理选择器。

setDefault(ResponseCache) - Static method in class java.net. ResponseCache

设置（或取消）系统级缓存。

setDefault(Locale) - Static method in class java.util. Locale

设置Java虚拟机的此实例的默认语言环境。

setDefault(Locale.Category, Locale) - Static method in class java.util. Locale

为Java虚拟机的此实例设置指定类别的默认语言环境。

setDefault(TimeZone) - Static method in class java.util. TimeZone

设置 TimeZone由返回 getDefault方法。

setDefault(SSLContext) - Static method in class javax.net.ssl. SSLContext

设置默认的SSL上下文。

setDefaultAction(Action) - Method in interface javax.swing.text. Keymap

如果键入键，则将默认操作设置为触发。

setDefaultActions(int) - Method in class java.awt.dnd. DropTarget

设置此 DropTarget的默认可接受操作

setDefaultAllowUserInteraction(boolean) - Static method in class java.net. URLConnection

将所有将来的 URLConnection对象的 allowUserInteraction字段的默认值设置为指定的值。

setDefaultAssertionStatus(boolean) - Method in class java.lang. ClassLoader

设置此类加载器的默认断言状态。

setDefaultButton(boolean) - Method in class javafx.scene.control. Button

设置属性defaultButton的值。

setDefaultButton(JButton) - Method in class javax.swing. JRootPane

设置 defaultButton属性，该属性确定此 JRootPane的当前默认按钮。

setDefaultCapable(boolean) - Method in class javax.swing. JButton

设置 defaultCapable属性，该属性确定此按钮是否可以作为其根窗格的默认按钮。

setDefaultChecked(boolean) - Method in interface org.w3c.dom.html. HTMLInputElement

setDefaultClassLoader(ClassLoader) - Static method in class javafx.fxml. FXMLLoader

设置默认的类加载器。

setDefaultClassLoader(ClassLoader) - Method in class javax.management.remote.rmi. RMIServerImpl

设置此连接器服务器的默认 ClassLoader 。

setDefaultCloseOperation(int) - Method in class javax.swing. JDialog

设置用户在此对话框上启动“关闭”时默认执行的操作。

setDefaultCloseOperation(int) - Method in class javax.swing. JFrame

设置用户在此框架上启动“关闭”时默认执行的操作。

setDefaultCloseOperation(int) - Method in class javax.swing. JInternalFrame

设置用户在此内部框架上启动“关闭”时默认执行的操作。

setDefaultCommandMap(CommandMap) - Static method in class javax.activation. CommandMap

设置默认的CommandMap。

setDefaultCursor(Cursor) - Method in class javax.swing.text.html. HTMLEditorKit

设置默认光标。

setDefaultDTD() - Static method in class javax.swing.text.html.parser. ParserDelegator

设置默认DTD。

setDefaultEditor(Class<?>, TableCellEditor) - Method in class javax.swing. JTable

如果在 TableColumn没有设置编辑器，则设置要使用的默认单元格编辑器。

setDefaultFileTypeMap(FileTypeMap) - Static method in class javax.activation. FileTypeMap

设置系统的默认FileTypeMap。

setDefaultFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class java.awt. KeyboardFocusManager

设置给定遍历操作的默认焦点遍历键。

setDefaultFocusTraversalPolicy(FocusTraversalPolicy) - Method in class java.awt. KeyboardFocusManager

设置默认的FocusTraversalPolicy。

setDefaultFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text. DefaultFormatterFactory

设置 JFormattedTextField.AbstractFormatter作为最后的手段，例如，如果未指定显示，编辑或空值 JFormattedTextField.AbstractFormatter 。

setDefaultHostnameVerifier(HostnameVerifier) - Static method in class javax.net.ssl. HttpsURLConnection

设置由此类的新实例继承的默认值 HostnameVerifier 。

setDefaultLightWeightPopupEnabled(boolean) - Static method in class javax.swing. JPopupMenu

设置 lightWeightPopupEnabled属性的默认值。

setDefaultLocale(Locale) - Static method in class javax.swing. JComponent

设置用于在创建时初始化每个JComponent的区域设置属性的默认区域设置。

setDefaultLocale(Locale) - Method in class javax.swing. UIDefaults

设置默认语言环境。

setDefaultLookAndFeelDecorated(boolean) - Static method in class javax.swing. JDialog

提供关于新创建的 JDialog是否应该具有由当前外观提供的窗口装饰（例如边框，窗口小部件以关闭窗口，标题...）的提示。

setDefaultLookAndFeelDecorated(boolean) - Static method in class javax.swing. JFrame

提供关于新创建的 JFrame是否应该具有由当前外观提供的窗口装饰（例如边框，关闭窗口的小部件，标题...）的提示。

setDefaultMenuBar(JMenuBar) - Method in class java.awt. Desktop

设置当没有活动帧时使用的默认菜单栏。

setDefaultNamespace(String) - Method in interface javax.xml.stream. XMLEventWriter

将URI绑定到默认命名空间此URI绑定在当前START_ELEMENT / END_ELEMENT对的范围内。

setDefaultNamespace(String) - Method in interface javax.xml.stream. XMLStreamWriter

将URI绑定到默认命名空间此URI绑定在当前START_ELEMENT / END_ELEMENT对的范围内。

setDefaultNamespacePrefix(String) - Method in class javax.xml.crypto.dom. DOMCryptoContext

setDefaultNamespacePrefix(String) - Method in interface javax.xml.crypto. XMLCryptoContext

设置默认名称空间前缀。

setDefaultQueue(LayoutQueue) - Static method in class javax.swing.text. LayoutQueue

设置默认布局队列。

setDefaultRenderer(Class<?>, TableCellRenderer) - Method in class javax.swing. JTable

如果在 TableColumn没有设置渲染器，则设置要使用的默认单元格渲染器。

setDefaultRenderer(TableCellRenderer) - Method in class javax.swing.table. JTableHeader

设置当 headerRenderer由 TableColumn定义时使用的默认渲染器。

setDefaultRequestProperty(String, String) - Static method in class java.net. URLConnection

已过时。
在获得适当的URLConnection实例之后，应该使用实例特定的setRequestProperty方法。 调用此方法将不起作用。

setDefaultSelected(boolean) - Method in interface org.w3c.dom.html. HTMLOptionElement

setDefaultSelection(JobAttributes.DefaultSelectionType) - Method in class java.awt. JobAttributes

指定对于使用这些属性的作业，应用程序是否应打印所有页面，返回值为 getPageRanges指定的范围，或当前选择。

setDefaultSSLSocketFactory(SSLSocketFactory) - Static method in class javax.net.ssl. HttpsURLConnection

设置由 SSLSocketFactory的新实例继承的默认值 SSLSocketFactory 。

setDefaultStratum(String) - Method in interface com.sun.jdi. VirtualMachine

设置此虚拟机的默认层次（有关层次的讨论，请参阅Location ）。

setDefaultStream(PrintStream) - Static method in class java.rmi.server. LogStream

已过时。
没有替换

setDefaultSystemMenuBar(MenuBar) - Static method in class javafx.scene.control.skin. MenuBarSkin

设置默认的系统菜单栏。

setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - Static method in class java.lang. Thread

设置当线程由于未捕获的异常突然终止而调用的默认处理程序，并且没有为该线程定义其他处理程序。

setDefaultUseCaches(boolean) - Method in class java.net. URLConnection

将 useCaches字段的默认值设置为指定值。

setDefaultUseCaches(String, boolean) - Static method in class java.net. URLConnection

将命名协议的 useCaches字段的默认值设置为给定值。

setDefaultValue(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setDefaultValue(String) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setDefer(boolean) - Method in interface org.w3c.dom.html. HTMLScriptElement

setDelay(int) - Method in class javax.swing. JMenu

在菜单的 PopupMenu弹出或关闭之前设置建议的延迟。

setDelay(int) - Method in class javax.swing. Timer

设置 Timer的事件间延迟，连续动作事件之间的毫秒数。

setDelay(Duration) - Method in class javafx.animation. Animation

设置属性延迟的值。

setDelay(Duration) - Method in class javafx.concurrent. ScheduledService

设置属性延迟的值。

setDepth(double) - Method in class javafx.scene.shape. Box

设置属性深度的值。

setDepthBuffer(boolean) - Method in class javafx.scene. SnapshotParameters

将depthBuffer标志设置为指定的值。

setDepthTest(DepthTest) - Method in class javafx.scene. Node

设置属性depthTest的值。

setDerefLinkFlag(boolean) - Method in class javax.naming.directory. SearchControls

在搜索期间启用/禁用链接解除引用。

setDescription(String) - Method in class javax.swing. ImageIcon

设置图像的描述。

setDescriptor(Descriptor) - Method in interface javax.management. DescriptorAccess

设置描述符（全替换）。

setDescriptor(Descriptor) - Method in class javax.management.modelmbean. ModelMBeanAttributeInfo

为ModelMBeanAttributeDescriptor设置关联的描述符（完全替换）。

setDescriptor(Descriptor) - Method in class javax.management.modelmbean. ModelMBeanConstructorInfo

设置ModelMBeanConstructorInfo的关联描述符（完全替换）。

setDescriptor(Descriptor) - Method in class javax.management.modelmbean. ModelMBeanNotificationInfo

为ModelMBeanNotificationInfo设置相关的描述符（完全替换）如果新的描述符为空，则相关的描述符将恢复为默认描述符。

setDescriptor(Descriptor) - Method in class javax.management.modelmbean. ModelMBeanOperationInfo

为ModelMBeanOperationInfo设置关联的描述符（完全替换）如果新的描述符为空，则相关的描述符将恢复为默认描述符。

setDescriptor(Descriptor, String) - Method in interface javax.management.modelmbean. ModelMBeanInfo

在ModelMBean的类型为inDescriptorType的info数组中设置描述符。

setDescriptor(Descriptor, String) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

setDescriptors(Descriptor[]) - Method in interface javax.management.modelmbean. ModelMBeanInfo

在ModelMBeanInfo中添加或替换描述符。

setDescriptors(Descriptor[]) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

setDesignTime(boolean) - Method in class java.beans.beancontext. BeanContextSupport

设置这个 BeanContext的新设计时间值。

setDesignTime(boolean) - Static method in class java.beans. Beans

用于指示我们是否在应用程序构建器环境中运行。

setDesignTime(boolean) - Method in interface java.beans. DesignMode

设置“designTime”属性的“值”。

setDesktopIcon(JInternalFrame.JDesktopIcon) - Method in class javax.swing. JInternalFrame

设置 JDesktopIcon与此相关 JInternalFrame 。

setDesktopManager(DesktopManager) - Method in class javax.swing. JDesktopPane

设置将处理桌面专用UI操作的 DesktopManger 。

setDesktopProperty(String, Object) - Method in class java.awt. Toolkit

将指定的桌面属性设置为指定的值，并触发属性更改事件以通知任何侦听器该值已更改。

setDestination(BufferedImage) - Method in class javax.imageio. ImageReadParam

提供 BufferedImage作为解码像素数据的目的地。

setDestination(JobAttributes.DestinationType) - Method in class java.awt. JobAttributes

指定输出将是打印机还是使用这些属性的作业文件。

setDestinationBands(int[]) - Method in class javax.imageio. ImageReadParam

设置要放置数据的目标频带的索引。

setDestinationOffset(Point) - Method in class javax.imageio. IIOParam

指定目标图像中的未来解码像素的偏移量，读取时或写入区域的位置。

setDestinationType(ImageTypeSpecifier) - Method in class javax.imageio. IIOParam

使用 ImageTypeSpecifier设置目标图像所需的图像类型。

setDestinationType(ImageTypeSpecifier) - Method in class javax.imageio. ImageReadParam

setDialog(JobAttributes.DialogType) - Method in class java.awt. JobAttributes

指定对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。

setDialogPane(DialogPane) - Method in class javafx.scene.control. Dialog

设置属性dialogPane的值。

setDialogTitle(String) - Method in class javax.swing. JFileChooser

设置 JFileChooser窗口标题栏中的字符串。

setDialogType(int) - Method in class javax.swing. JFileChooser

设置此对话框的类型。

setDictionary(byte[]) - Method in class java.util.zip. Deflater

设置压缩预设字典。

setDictionary(byte[]) - Method in class java.util.zip. Inflater

将预设字典设置为给定的字节数组。

setDictionary(byte[], int, int) - Method in class java.util.zip. Deflater

设置压缩预设字典。

setDictionary(byte[], int, int) - Method in class java.util.zip. Inflater

将预设字典设置为给定的字节数组。

setDifferenceMode(boolean) - Method in class javax.management.monitor. CounterMonitor

设置所有观察到的MBean共有的差异模式标志值。

setDifferenceMode(boolean) - Method in interface javax.management.monitor. CounterMonitorMBean

设置差模态标志值。

setDifferenceMode(boolean) - Method in class javax.management.monitor. GaugeMonitor

设置所有观察到的MBean共有的差异模式标志值。

setDifferenceMode(boolean) - Method in interface javax.management.monitor. GaugeMonitorMBean

设置差模态标志值。

setDiffuseColor(Color) - Method in class javafx.scene.paint. PhongMaterial

设置属性diffuseColor的值。

setDiffuseConstant(double) - Method in class javafx.scene.effect. Lighting

设置属性diffuseConstant的值。

setDiffuseMap(Image) - Method in class javafx.scene.paint. PhongMaterial

设置propertyMap属性的值。

setDigit(char) - Method in class java.text. DecimalFormatSymbols

设置模式中用于数字的字符。

setDimensions(int, int) - Method in class java.awt.image. BufferedImageFilter

过滤ImageConsumer接口setDimensions 方法中提供的信息。

setDimensions(int, int) - Method in class java.awt.image. CropImageFilter

覆盖源图像的尺寸，并将矩形裁剪区域的尺寸传递给ImageConsumer。

setDimensions(int, int) - Method in interface java.awt.image. ImageConsumer

使用setDimensions方法调用来报告源图像的尺寸。

setDimensions(int, int) - Method in class java.awt.image. ImageFilter

过滤ImageConsumer接口的setDimensions方法中提供的信息。

setDimensions(int, int) - Method in class java.awt.image. PixelGrabber

setDimensions方法是ImageConsumer API的一部分，该类必须实现这个API来检索像素。

setDimensions(int, int) - Method in class java.awt.image. ReplicateScaleFilter

覆盖源图像的尺寸，并将新的缩放尺寸的尺寸传递给ImageConsumer。

setDir(String) - Method in interface org.w3c.dom.html. HTMLElement

setDirection(int) - Method in class javax.swing.plaf.basic. BasicArrowButton

设置箭头的方向。

setDirection(int) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.ScrollListener

设置方向。

setDirection(int) - Method in class javax.swing.plaf.basic. BasicSliderUI.ScrollListener

设置方向。

setDirection(short) - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

设置方向。

setDirection(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的方向属性定义。

setDirectory(File) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

要记住UI中当前选择的目录的属性。

setDirectory(String) - Method in class java.awt. FileDialog

将此文件对话框窗口的目录设置为指定的目录。

setDirectoryName(String) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

设置目录名称。

setDirectoryName(String) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

设置目录名称。

setDirectorySelected(boolean) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

要记住当前是否在UI中选择了一个目录的属性。

setDirectorySelected(boolean) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

要记住当前是否在UI中选择了一个目录的属性。

setDisable(boolean) - Method in class javafx.scene.control. MenuItem

设置属性的值禁用。

setDisable(boolean) - Method in class javafx.scene.control. Tab

设置此选项卡的禁用状态。

setDisable(boolean) - Method in class javafx.scene. Node

设置属性的值禁用。

setDisabled(boolean) - Method in class javafx.scene. Node

设置禁用属性的值。

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLButtonElement

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLInputElement

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLLinkElement

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLOptGroupElement

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLOptionElement

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLSelectElement

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLStyleElement

setDisabled(boolean) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setDisabled(boolean) - Method in interface org.w3c.dom.stylesheets. StyleSheet

false如果样式表应用于文档。

setDisabledIcon(Icon) - Method in class javax.swing. AbstractButton

设置按钮的禁用图标。

setDisabledIcon(Icon) - Method in class javax.swing. JLabel

如果此JLabel为“禁用”（JLabel.setEnabled（false）），请设置要显示的图标。

setDisabledIconAt(int, Icon) - Method in class javax.swing. JTabbedPane

将禁用图标设置为 index至 icon ，可以是 null 。

setDisabledSelectedIcon(Icon) - Method in class javax.swing. AbstractButton

设置按钮的禁用选择图标。

setDisabledTextColor(Color) - Method in class javax.swing.text. JTextComponent

设置用于呈现禁用的文本的当前颜色。

setDiscard(boolean) - Method in class java.net. HttpCookie

指定用户代理是否无条件丢弃该cookie。

setDisclosureNode(Node) - Method in class javafx.scene.control. TreeCell

用作“披露”三角形的节点，或用于展开和折叠项目的切换。

setDisclosureNode(Node) - Method in class javafx.scene.control. TreeTableRow

用作“披露”三角形的节点，或用于展开和折叠项目的切换。

setDismissDelay(int) - Method in class javax.swing. ToolTipManager

指定解雇延迟值。

setDisplay(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的显示属性定义。

setDisplayedMnemonic(char) - Method in class javax.swing. JLabel

指定显示的助记符为char值。

setDisplayedMnemonic(int) - Method in class javax.swing. JLabel

指定一个指示助记键的键码。

setDisplayedMnemonicIndex(int) - Method in class javax.swing. AbstractButton

提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。

setDisplayedMnemonicIndex(int) - Method in class javax.swing. JLabel

提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。

setDisplayedMnemonicIndexAt(int, int) - Method in class javax.swing. JTabbedPane

提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。

setDisplayFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text. DefaultFormatterFactory

设置 JFormattedTextField.AbstractFormatter ，如果使用 JFormattedTextField未被编辑和任一的值不是空，或该值为空和null formatter的尚未指定。

setDisplayMode(DisplayMode) - Method in class java.awt. GraphicsDevice

设置此图形设备的显示模式。

setDisplayName(String) - Method in class java.beans. FeatureDescriptor

设置此功能的本地化显示名称。

setDividerLocation(double) - Method in class javax.swing. JSplitPane

将分隔符位置设置为 JSplitPane的大小的百分比。

setDividerLocation(int) - Method in class javax.swing. JSplitPane

设置分频器的位置。

setDividerLocation(JSplitPane, int) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

将分隔线的位置设置为位置。

setDividerLocation(JSplitPane, int) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI

在此对象处理的每个UI上调用 setDividerLocation方法。

setDividerLocation(JSplitPane, int) - Method in class javax.swing.plaf. SplitPaneUI

将分隔线的位置设置为位置。

setDividerPosition(int, double) - Method in class javafx.scene.control. SplitPane

以指定的分频器指数设置分频器的位置。

setDividerPositions(double...) - Method in class javafx.scene.control. SplitPane

设置分频器的位置

setDividerSize(int) - Method in class javax.swing. JSplitPane

设置分频器的大小。

setDividerSize(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

将分频器的大小设置为 newSize 。

setDockingColor(Color) - Method in class javax.swing.plaf.basic. BasicToolBarUI

设置在停靠区域上显示的颜色

setDocument(Document) - Method in class javax.swing. JFormattedTextField

将编辑器与文本文档相关联。

setDocument(Document) - Method in class javax.swing. JTextField

将编辑器与文本文档相关联。

setDocument(Document) - Method in class javax.swing. JTextPane

将编辑器与文本文档相关联。

setDocument(Document) - Method in class javax.swing.text. JTextComponent

将编辑器与文本文档相关联。

setDocumentFilter(DocumentFilter) - Method in class javax.swing.text. AbstractDocument

设置 DocumentFilter 。

setDocumentHandler(DocumentHandler) - Method in class org.xml.sax.helpers. XMLReaderAdapter

注册SAX1文档事件处理程序。

setDocumentHandler(DocumentHandler) - Method in interface org.xml.sax. Parser

已过时。

允许应用程序注册文档事件处理程序。

setDocumentLocator(Locator) - Method in interface org.xml.sax. ContentHandler

接收一个查找SAX文档事件的起源的对象。

setDocumentLocator(Locator) - Method in interface org.xml.sax. DocumentHandler

已过时。

接收一个查找SAX文档事件的起源的对象。

setDocumentLocator(Locator) - Method in class org.xml.sax. HandlerBase

已过时。

接收文档事件的Locator对象。

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers. DefaultHandler

接收文档事件的Locator对象。

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers. ParserAdapter

适配器实现方法; 不要打电话。

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers. XMLFilterImpl

过滤新的文档定位器事件。

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers. XMLReaderAdapter

设置文档定位器。

setDocumentProperties(Dictionary<Object, Object>) - Method in class javax.swing.text. AbstractDocument

替换此文档的文档属性字典。

setDocumentURI(String) - Method in interface org.w3c.dom. Document

文件的位置或 null如果未定义，或者如果 Document是使用 DOMImplementation.createDocument创建的。

setDoInput(boolean) - Method in class java.net. URLConnection

将此 URLConnection的 doInput字段的值设置为指定值。

setDomain(String) - Method in class java.net. HttpCookie

指定应显示此Cookie的域。

setDoOutput(boolean) - Method in class java.net. URLConnection

设置的值 doOutput领域本 URLConnection指定值。

setDot(int) - Method in interface javax.swing.text. Caret

将插入符位置设置到某个位置。

setDot(int) - Method in class javax.swing.text. DefaultCaret

设置插入符号位置并标记到指定的位置，并具有正向偏置。

setDot(int, Position.Bias) - Method in class javax.swing.text. DefaultCaret

设置插入符号位置并标记到指定的位置，并具有指定的偏置。

setDot(int, Position.Bias) - Method in class javax.swing.text. NavigationFilter.FilterBypass

设置插入符号位置，绕过NavigationFilter。

setDot(NavigationFilter.FilterBypass, int, Position.Bias) - Method in class javax.swing.text. NavigationFilter

在插入点设置点之前调用。

setDouble(int, double) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java double值。

setDouble(int, double) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中给定的 double 。

setDouble(int, double) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java double值。

setDouble(Object, double) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 double 。

setDouble(Object, int, double) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的 double值。

setDouble(String, double) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java double值。

setDouble(String, double) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java double值。

setDouble(String, double) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java double值。

setDoubleBuffered(boolean) - Method in class javax.swing. JComponent

设置此组件是否应该使用缓冲区来绘制。

setDoubleBuffered(boolean) - Method in class javax.swing. JRootPane

设置此组件是否应该使用缓冲区来绘制。

setDoubleBufferingEnabled(boolean) - Method in class javax.swing. RepaintManager

在此RepaintManager中启用或禁用双缓冲。

setDoubleBufferMaximumSize(Dimension) - Method in class javax.swing. RepaintManager

设置最大双缓冲区大小。

setDragDetect(boolean) - Method in class javafx.scene.input. MouseEvent

增强拖动检测行为。

setDragEnabled(boolean) - Method in class javax.swing. JColorChooser

设置 dragEnabled属性，该属性必须为 true以启用此组件上的自动拖放处理（第一部分拖放）。

setDragEnabled(boolean) - Method in class javax.swing. JFileChooser

设置 dragEnabled属性，该属性必须为 true以启用此组件上的自动拖放处理（第一部分拖放）。

setDragEnabled(boolean) - Method in class javax.swing. JList

打开或关闭自动拖动处理。

setDragEnabled(boolean) - Method in class javax.swing. JTable

打开或关闭自动拖动处理。

setDragEnabled(boolean) - Method in class javax.swing. JTree

打开或关闭自动拖动处理。

setDragEnabled(boolean) - Method in class javax.swing.text. JTextComponent

打开或关闭自动拖动处理。

setDraggedColumn(TableColumn) - Method in class javax.swing.table. JTableHeader

将标题的 draggedColumn设置为 aColumn 。

setDraggedDistance(int) - Method in class javax.swing.table. JTableHeader

将标题的 draggedDistance设置为 distance 。

setDragImage(Image) - Method in class javax.swing. TransferHandler

设置拖动图像参数。

setDragImageOffset(Point) - Method in class javax.swing. TransferHandler

设置要拖动的图像的锚点偏移量。

setDragMode(int) - Method in class javax.swing. JDesktopPane

设置桌面窗格使用的“拖动样式”。

setDragOffset(Point) - Method in class javax.swing.plaf.metal. MetalToolBarUI

设置鼠标光标在DragWindow内的偏移量。

setDragView(Image) - Method in class javafx.scene.input. Dragboard

设置拖放手势中传输的数据的视觉表示。

setDragView(Image, double, double) - Method in class javafx.scene.input. Dragboard

设置拖放手势中传输的数据的视觉表示。

setDragViewOffsetX(double) - Method in class javafx.scene.input. Dragboard

设置拖动视图图像光标的x位置。

setDragViewOffsetY(double) - Method in class javafx.scene.input. Dragboard

设置拖动视图图像光标的y位置。

setDrawMode(DrawMode) - Method in class javafx.scene.shape. Shape3D

设置属性drawMode的值。

setDrawsLayeredHighlights(boolean) - Method in class javax.swing.text. DefaultHighlighter

如果为true，则在视图绘制文本时绘制亮点。

setDropAction(int) - Method in class javax.swing. TransferHandler.TransferSupport

将传输的放置操作设置为给定操作，而不是默认的用户放置操作。

setDropCompleted(boolean) - Method in class javafx.scene.input. DragEvent

表示在 DRAG_DROPPED事件处理程序中， DragEvent传输处理已成功完成。

setDropMode(DropMode) - Method in class javax.swing. JList

设置此组件的下拉模式。

setDropMode(DropMode) - Method in class javax.swing. JTable

设置此组件的下拉模式。

setDropMode(DropMode) - Method in class javax.swing. JTree

设置此组件的下拉模式。

setDropMode(DropMode) - Method in class javax.swing.text. JTextComponent

设置此组件的下拉模式。

setDropTarget(DropTarget) - Method in class java.awt. Component

关联一个 DropTarget与此组件。

setDSTSavings(int) - Method in class java.util. SimpleTimeZone

设置时钟在夏令时期间提前的时间（以毫秒为单位）。

setDTDHandler(DTDHandler) - Method in class org.xml.sax.helpers. ParserAdapter

设置DTD处理程序。

setDTDHandler(DTDHandler) - Method in class org.xml.sax.helpers. XMLFilterImpl

设置DTD事件处理程序。

setDTDHandler(DTDHandler) - Method in class org.xml.sax.helpers. XMLReaderAdapter

注册DTD事件处理程序。

setDTDHandler(DTDHandler) - Method in interface org.xml.sax. Parser

已过时。

允许应用程序注册DTD事件处理程序。

setDTDHandler(DTDHandler) - Method in interface org.xml.sax. XMLReader

允许应用程序注册DTD事件处理程序。

setDuration(Duration) - Method in class javafx.animation. FadeTransition

设置属性持续时间的值。

setDuration(Duration) - Method in class javafx.animation. FillTransition

设置属性持续时间的值。

setDuration(Duration) - Method in class javafx.animation. PathTransition

设置属性持续时间的值。

setDuration(Duration) - Method in class javafx.animation. PauseTransition

设置属性持续时间的值。

setDuration(Duration) - Method in class javafx.animation. RotateTransition

设置属性持续时间的值。

setDuration(Duration) - Method in class javafx.animation. ScaleTransition

设置属性持续时间的值。

setDuration(Duration) - Method in class javafx.animation. StrokeTransition

设置属性持续时间的值。

setDuration(Duration) - Method in class javafx.animation. TranslateTransition

设置属性持续时间的值。

setDynamicLayout(boolean) - Method in class java.awt. Toolkit

控制容器的布局在调整大小期间是否动态地进行验证，或者在调整大小之后静态地进行。

setEastPane(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置东窗格。

setEchoChar(char) - Method in class java.awt. TextField

设置此文本字段的回音字符。

setEchoChar(char) - Method in class javax.swing. JPasswordField

设置这个 JPasswordField的回波字符。

setEchoCharacter(char) - Method in class java.awt. TextField

已过时。
截至JDK 1.1版，由setEchoChar(char)替代。

setEcmaError(Object) - Method in exception jdk.nashorn.api.scripting. NashornException

返回底层的ECMA错误对象（如果可用）。

setEditable(boolean) - Method in class java.awt. TextComponent

设置确定此文本组件是否可编辑的标志。

setEditable(boolean) - Method in class javafx.scene.control. Cell

允许某些单元格无法编辑。

setEditable(boolean) - Method in class javafx.scene.control. ComboBoxBase

设置属性可编辑的值。

setEditable(boolean) - Method in class javafx.scene.control. ListView

设置属性可编辑的值。

setEditable(boolean) - Method in class javafx.scene.control. Spinner

设置属性可编辑的值。

setEditable(boolean) - Method in class javafx.scene.control. TableColumnBase

设置属性可编辑的值。

setEditable(boolean) - Method in class javafx.scene.control. TableView

设置属性可编辑的值。

setEditable(boolean) - Method in class javafx.scene.control. TextInputControl

设置属性可编辑的值。

setEditable(boolean) - Method in class javafx.scene.control. TreeTableView

设置属性可编辑的值。

setEditable(boolean) - Method in class javafx.scene.control. TreeView

设置属性可编辑的值。

setEditable(boolean) - Method in class javax.swing. JComboBox

确定 JComboBox字段是否可编辑。

setEditable(boolean) - Method in class javax.swing. JTree

确定树是否可编辑。

setEditable(boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI

将接收器配置为允许或不允许编辑。

setEditable(boolean) - Method in class javax.swing.text. JTextComponent

设置指定的布尔值以指示此 TextComponent是否可编辑。

setEditFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text. DefaultFormatterFactory

设置 JFormattedTextField.AbstractFormatter ，如果使用 JFormattedTextField正在编辑和任一的值不是空，或该值为空和null formatter的尚未指定。

setEditingColumn(int) - Method in class javax.swing. JTable

设置 editingColumn变量。

setEditingRow(int) - Method in class javax.swing. JTable

设置 editingRow变量。

setEditor(ComboBoxEditor) - Method in class javax.swing. JComboBox

设置用于在 JComboBox字段中绘制和编辑所选项目的编辑器。

setEditor(JComponent) - Method in class javax.swing. JSpinner

更改显示 JComponent的当前值的 SpinnerModel 。

setEditorKit(EditorKit) - Method in class javax.swing. JEditorPane

设置当前安装的工具包来处理内容。

setEditorKit(EditorKit) - Method in class javax.swing. JTextPane

设置当前安装的工具包来处理内容。

setEditorKitForContentType(String, EditorKit) - Method in class javax.swing. JEditorPane

直接设置用于给定类型的编辑器工具包。

setEditorSearchPath(String[]) - Static method in class java.beans. PropertyEditorManager

更改将用于查找属性编辑器的包名称列表。

setEditValid(boolean) - Method in class javax.swing. JFormattedTextField.AbstractFormatter

调用此更新 editValid的财产 JFormattedTextField 。

setEffect(Effect) - Method in class javafx.scene.canvas. GraphicsContext

设置在下一次绘图调用后应用的效果，或设置为禁用效果的效果。

setEffect(Effect) - Method in class javafx.scene. Node

设置属性效果的值。

setElem(int, int) - Method in class java.awt.image. DataBuffer

从给定的整数设置第一个（默认）库中的请求的数据数组元素。

setElem(int, int) - Method in class java.awt.image. DataBufferByte

将第一个（默认）库中的请求的数据数组元素设置为指定的值。

setElem(int, int) - Method in class java.awt.image. DataBufferDouble

将第一个（默认）库中的请求的数据数组元素设置为给定的 int 。

setElem(int, int) - Method in class java.awt.image. DataBufferFloat

将第一个（默认）库中的请求的数据数组元素设置为给定的 int 。

setElem(int, int) - Method in class java.awt.image. DataBufferInt

将第一个（默认）库中的请求的数据数组元素设置为指定的值。

setElem(int, int) - Method in class java.awt.image. DataBufferShort

将第一个（默认）库中的请求的数据数组元素设置为指定的值。

setElem(int, int) - Method in class java.awt.image. DataBufferUShort

将第一个（默认）库中的请求的数据数组元素设置为指定的值。

setElem(int, int, int) - Method in class java.awt.image. DataBuffer

从给定的整数设置指定库中的请求的数据数组元素。

setElem(int, int, int) - Method in class java.awt.image. DataBufferByte

从给定的整数设置指定库中的请求的数据数组元素。

setElem(int, int, int) - Method in class java.awt.image. DataBufferDouble

将指定库中的请求数据数组元素设置为给定的 int 。

setElem(int, int, int) - Method in class java.awt.image. DataBufferFloat

将指定库中的请求数据数组元素设置为给定的 int 。

setElem(int, int, int) - Method in class java.awt.image. DataBufferInt

将指定库中的请求的数据数组元素设置为整数值 i 。

setElem(int, int, int) - Method in class java.awt.image. DataBufferShort

从给定的整数设置指定库中的请求的数据数组元素。

setElem(int, int, int) - Method in class java.awt.image. DataBufferUShort

从给定的整数设置指定库中的请求的数据数组元素。

setElemDouble(int, double) - Method in class java.awt.image. DataBuffer

从给定的双数设置第一个（默认）库中的请求的数据数组元素。

setElemDouble(int, double) - Method in class java.awt.image. DataBufferDouble

将所请求的数据数组元素设置在给定的第二个（默认）存储区中的 double 。

setElemDouble(int, double) - Method in class java.awt.image. DataBufferFloat

将第一个（默认）库中的请求的数据数组元素设置为给定的 double 。

setElemDouble(int, int, double) - Method in class java.awt.image. DataBuffer

从给定的双精度设置指定库中的请求数据数组元素。

setElemDouble(int, int, double) - Method in class java.awt.image. DataBufferDouble

将指定库中的请求的数据数组元素设置为给定的 double 。

setElemDouble(int, int, double) - Method in class java.awt.image. DataBufferFloat

将指定库中的请求的数据数组元素设置为给定的 double 。

setElement(MatrixType, int, int, double) - Method in class javafx.scene.transform. Affine

设置变换矩阵的指定元素。

setElementAt(E, int) - Method in class java.util. Vector

将该向量的指定的 index的组件设置为指定的对象。

setElementAt(E, int) - Method in class javax.swing. DefaultListModel

将此列表中指定的 index的组件设置为指定的元素。

setElementQName(QName) - Method in interface javax.xml.soap. SOAPElement

如果可能，将该 Element的名称更改为 newName 。

setElemFloat(int, float) - Method in class java.awt.image. DataBuffer

从给定的浮点数在第一个（默认）库中设置所请求的数据数组元素。

setElemFloat(int, float) - Method in class java.awt.image. DataBufferDouble

将第一个（默认）库中的请求的数据数组元素设置为给定的 float 。

setElemFloat(int, float) - Method in class java.awt.image. DataBufferFloat

将所请求的数据数组元素设置在第一个（默认）存储区中，给定为 float 。

setElemFloat(int, int, float) - Method in class java.awt.image. DataBuffer

从给定的浮点数设置指定库中的请求数据数组元素。

setElemFloat(int, int, float) - Method in class java.awt.image. DataBufferDouble

将指定库中的请求的数据数组元素设置为给定的 float 。

setElemFloat(int, int, float) - Method in class java.awt.image. DataBufferFloat

将指定库中的请求数据数组元素设置为给定的 float 。

setElevation(double) - Method in class javafx.scene.effect. Light.Distant

设置属性高程的值。

setElevation(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的elevation属性定义。

setEllipsisString(String) - Method in class javafx.scene.control. Labeled

设置属性ellipsisString的值。

setEmptyCells(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的empty-cells属性定义。

setEmptyValue(CharSequence) - Method in class java.util. StringJoiner

设置在确定此 StringJoiner的字符串表示时使用的字符序列，并且尚未添加任何元素，即当它为空时。

setEnabled(boolean) - Method in class com.sun.java.accessibility.util. Translator

设置对象的已启用状态。

setEnabled(boolean) - Method in interface com.sun.jdi.request. EventRequest

启用或禁用此事件请求。

setEnabled(boolean) - Method in class java.awt. Component.AccessibleAWTComponent

设置对象的已启用状态。

setEnabled(boolean) - Method in class java.awt. Component

根据参数 b的值启用或禁用此组件。

setEnabled(boolean) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

设置对象的已启用状态。

setEnabled(boolean) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

设置对象的已启用状态。

setEnabled(boolean) - Method in class java.awt. MenuItem

设置是否可以选择此菜单项。

setEnabled(boolean) - Method in class javafx.scene.media. AudioEqualizer

设置启用属性的值。

setEnabled(boolean) - Method in interface javax.accessibility. AccessibleComponent

设置对象的已启用状态。

setEnabled(boolean) - Method in class javax.swing. AbstractAction

设置是否启用了 Action 。

setEnabled(boolean) - Method in class javax.swing. AbstractButton

启用（或禁用）按钮。

setEnabled(boolean) - Method in interface javax.swing. Action

设置启用状态为 Action 。

setEnabled(boolean) - Method in interface javax.swing. ButtonModel

启用或禁用按钮。

setEnabled(boolean) - Method in class javax.swing. DefaultButtonModel

启用或禁用按钮。

setEnabled(boolean) - Method in class javax.swing. JComboBox

启用组合框，以便可以选择项目。

setEnabled(boolean) - Method in class javax.swing. JComponent

设置是否启用此组件。

setEnabled(boolean) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setEnabled(boolean) - Method in class javax.swing. JMenuItem

启用或禁用菜单项。

setEnabled(boolean) - Method in class javax.swing. JScrollBar

启用组件，以便可以更改旋钮位置。

setEnabled(boolean) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置对象的已启用状态。

setEnabled(boolean) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setEnabled(boolean) - Method in class javax.swing.plaf.metal. MetalComboBoxButton

setEnabled(boolean) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setEnabled(boolean) - Method in class javax.swing. ToolTipManager

启用或禁用工具提示。

setEnabledAt(int, boolean) - Method in class javax.swing. JTabbedPane

设置是否启用了 index的选项卡。

setEnabledCipherSuites(String[]) - Method in class javax.naming.ldap. StartTlsResponse

覆盖在TLS连接上启用的密码套件的默认列表。

setEnabledCipherSuites(String[]) - Method in class javax.net.ssl. SSLEngine

设置启用此引擎使用的密码套件。

setEnabledCipherSuites(String[]) - Method in class javax.net.ssl. SSLServerSocket

设置允许接受连接使用的密码套件。

setEnabledCipherSuites(String[]) - Method in class javax.net.ssl. SSLSocket

设置启用此连接的密码套件。

setEnabledProtocols(String[]) - Method in class javax.net.ssl. SSLEngine

设置允许在此引擎上使用的协议版本。

setEnabledProtocols(String[]) - Method in class javax.net.ssl. SSLServerSocket

控制哪些特定协议被接受的连接启用。

setEnabledProtocols(String[]) - Method in class javax.net.ssl. SSLSocket

设置允许在此连接上使用的协议版本。

setEnableRetransmissions(boolean) - Method in class javax.net.ssl. SSLParameters

设置是否启用DTLS握手重传。

setEnableSessionCreation(boolean) - Method in class javax.net.ssl. SSLEngine

控制此引擎是否可以建立新的SSL会话。

setEnableSessionCreation(boolean) - Method in class javax.net.ssl. SSLServerSocket

控制是否可以由从此服务器套接字创建的套接字建立新的SSL会话。

setEnableSessionCreation(boolean) - Method in class javax.net.ssl. SSLSocket

控制此套接字是否可以建立新的SSL会话。

setEncodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

设置用于编码缩写流的量化和霍夫曼表。

setEncoding(String) - Method in class java.util.logging. Handler

设置此 Handler使用的字符编码。

setEncoding(String) - Method in class java.util.logging. StreamHandler

设置（或更改）此 Handler使用的字符编码。

setEncoding(String) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

设置输出编码的方便方法。

setEncoding(String) - Method in interface org.w3c.dom.css. CSSCharsetRule

该 @charset规则中使用的编码信息。

setEncoding(String) - Method in interface org.w3c.dom.ls. LSInput

字符编码，如果知道。

setEncoding(String) - Method in interface org.w3c.dom.ls. LSOutput

用于输出的字符编码。

setEncoding(String) - Method in class org.xml.sax.ext. Locator2Impl

分配编码属性的当前值。

setEncoding(String) - Method in class org.xml.sax. InputSource

设置字符编码，如果已知。

setEncodingStyle(String) - Method in interface javax.xml.soap. SOAPElement

将此 SOAPElement对象的编码样式设置为一个指定的。

setEnctype(String) - Method in interface org.w3c.dom.html. HTMLFormElement

setEnd(Comparable<Date>) - Method in class javax.swing. SpinnerDateModel

按此顺序更改 Date的上限。

setEnd(Node, int) - Method in interface org.w3c.dom.ranges. Range

设置描述范围结束的属性。

setEndAfter(Node) - Method in interface org.w3c.dom.ranges. Range

将范围的结束设置为节点之后

setEndBefore(Node) - Method in interface org.w3c.dom.ranges. Range

将结束位置设置为节点之前。

setEndIndex(int) - Method in class java.text. FieldPosition

设置结束索引。

setEndMargin(double) - Method in class javafx.scene.chart. CategoryAxis

设置属性endMargin的值。

setEndpointContext(EndpointContext) - Method in class javax.xml.ws. Endpoint

通过设置一个 EndpointContext ，JAX-WS运行时知道应用程序中其他端点的地址。

setEndpointIdentificationAlgorithm(String) - Method in class javax.net.ssl. SSLParameters

设置端点识别算法。

setEndRule(int, int, int) - Method in class java.util. SimpleTimeZone

将夏令时结束规则设置为一个月内的固定日期。

setEndRule(int, int, int, int) - Method in class java.util. SimpleTimeZone

设置夏令时结束规则。

setEndRule(int, int, int, int, boolean) - Method in class java.util. SimpleTimeZone

将夏令时结束规则设置为在一个月内的给定日期之前或之后的工作日，例如第8个或之后的第一个星期一。

setEndX(double) - Method in class javafx.scene.shape. CubicCurve

设置属性endX的值。

setEndX(double) - Method in class javafx.scene.shape. Line

设置属性endX的值。

setEndX(double) - Method in class javafx.scene.shape. QuadCurve

设置属性endX的值。

setEndY(double) - Method in class javafx.scene.shape. CubicCurve

设置属性endY的值。

setEndY(double) - Method in class javafx.scene.shape. Line

设置属性endY的值。

setEndY(double) - Method in class javafx.scene.shape. QuadCurve

设置属性endY的值。

setEntityResolver(EntityResolver) - Method in class javax.xml.parsers. DocumentBuilder

指定要用于解析要解析的XML文档中存在的实体的EntityResolver 。

setEntityResolver(EntityResolver) - Method in class org.xml.sax.helpers. ParserAdapter

设置实体解析器。

setEntityResolver(EntityResolver) - Method in class org.xml.sax.helpers. XMLFilterImpl

设置实体解析器。

setEntityResolver(EntityResolver) - Method in class org.xml.sax.helpers. XMLReaderAdapter

注册实体解析器。

setEntityResolver(EntityResolver) - Method in interface org.xml.sax. Parser

已过时。

允许应用程序注册自定义实体解析器。

setEntityResolver(EntityResolver) - Method in interface org.xml.sax. XMLReader

允许应用程序注册一个实体解析器。

setEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - Method in class java.security. KeyStore

在指定的别名下保存密钥库 Entry 。

setEnvironment(Hashtable<?, ?>) - Method in exception javax.naming. CannotProceedException

设置调用getEnvironment（）时将返回的环境。

setEras(String[]) - Method in class java.text. DateFormatSymbols

设置时代字符串。

setErr(PrintStream) - Static method in class java.lang. System

重新分配“标准”错误输出流。

setError() - Method in class java.io. PrintStream

将流的错误状态设置为 true 。

setError() - Method in class java.io. PrintWriter

表示发生错误。

setErrorHandler(ErrorHandler) - Method in class javax.xml.parsers. DocumentBuilder

指定解析器使用的ErrorHandler 。

setErrorHandler(ErrorHandler) - Method in class javax.xml.validation. SchemaFactory

设置ErrorHandler以接收在newSchema方法调用期间遇到的错误。

setErrorHandler(ErrorHandler) - Method in class javax.xml.validation. Validator

设置ErrorHandler以接收validate方法调用期间遇到的错误。

setErrorHandler(ErrorHandler) - Method in class javax.xml.validation. ValidatorHandler

设置ErrorHandler以接收验证期间遇到的错误。

setErrorHandler(ErrorHandler) - Method in class org.xml.sax.helpers. ParserAdapter

设置错误处理程序。

setErrorHandler(ErrorHandler) - Method in class org.xml.sax.helpers. XMLFilterImpl

设置错误事件处理程序。

setErrorHandler(ErrorHandler) - Method in class org.xml.sax.helpers. XMLReaderAdapter

注册错误事件处理程序。

setErrorHandler(ErrorHandler) - Method in interface org.xml.sax. Parser

已过时。

允许应用程序注册错误事件处理程序。

setErrorHandler(ErrorHandler) - Method in interface org.xml.sax. XMLReader

允许应用程序注册错误事件处理程序。

setErrorIndex(int) - Method in class java.text. ParsePosition

设置发生解析错误的索引。

setErrorListener(ErrorListener) - Method in class javax.xml.transform. Transformer

设置变量生效的错误事件侦听器。

setErrorListener(ErrorListener) - Method in class javax.xml.transform. TransformerFactory

设置TransformerFactory的错误事件侦听器，它用于处理转换指令，而不是转换本身。

setErrorManager(ErrorManager) - Method in class java.util.logging. Handler

为此处理程序定义一个ErrorManager。

setErrorWriter(Writer) - Method in interface javax.script. ScriptContext

设置 Writer用于显示错误输出。

setErrorWriter(Writer) - Method in class javax.script. SimpleScriptContext

设置 Writer用于显示错误输出。

setEscapeProcessing(boolean) - Method in interface java.sql. Statement

设置逃脱处理打开或关闭。

setEscapeProcessing(boolean) - Method in class javax.sql.rowset. BaseRowSet

设置给给定的 boolean驱动程序是否将扫描转义语法，并在将SQL语句发送到数据库之前执行转义替换。

setEscapeProcessing(boolean) - Method in interface javax.sql. RowSet

设置此 RowSet对象的转义处理开启或关闭。

setEstimatedMajorSpan(boolean) - Method in class javax.swing.text. AsyncBoxView

设置估计的主要属性，以确定主要跨度是否应被视为估计。

setEvent(String) - Method in interface org.w3c.dom.html. HTMLScriptElement

setEventAllocator(XMLEventAllocator) - Method in class javax.xml.stream. XMLInputFactory

为事件设置用户定义的事件分配器

setEventDispatcher(EventDispatcher) - Method in class javafx.scene. Node

设置属性eventDispatcher的值。

setEventDispatcher(EventDispatcher) - Method in class javafx.scene. Scene

设置属性eventDispatcher的值。

setEventDispatcher(EventDispatcher) - Method in class javafx.stage. Window

设置属性eventDispatcher的值。

setEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Service

设置要用于此事件类型的处理程序。

setEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.concurrent. Task

设置要用于此事件类型的处理程序。

setEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Node

设置要用于此事件类型的处理程序。

setEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.scene. Scene

设置要用于此事件类型的处理程序。

setEventHandler(EventType<T>, EventHandler<? super T>) - Method in class javafx.stage. Window

设置要用于此事件类型的处理程序。

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind. Binder

允许申请注册一个 ValidationEventHandler 。

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

允许应用程序注册验证事件处理程序。

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind. Marshaller

允许应用程序注册验证事件处理程序。

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind. Unmarshaller

允许申请注册一个 ValidationEventHandler 。

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind. Validator

已过时。
自JAXB2.0起

setException(Throwable) - Method in class java.util.concurrent. FutureTask

导致这个未来报告一个ExecutionException与给定的可抛弃的原因，除非这个未来已经被设置或被取消。

setExceptionListener(ExceptionListener) - Method in class java.beans. Encoder

将此流的异常处理程序设置为 exceptionListener 。

setExceptionListener(ExceptionListener) - Method in class java.beans. XMLDecoder

将此流的异常处理程序设置为 exceptionListener 。

setExclusiveOwnerThread(Thread) - Method in class java.util.concurrent.locks. AbstractOwnableSynchronizer

设置当前拥有独占访问权限的线程。

setExecutable(boolean) - Method in class java.io. File

为此抽象路径名设置所有者的执行权限的便利方法。

setExecutable(boolean, boolean) - Method in class java.io. File

设置该抽象路径名的所有者或每个人的执行权限。

setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

设置是否执行现有延迟任务的策略，即使该执行者已经是 shutdown 。

setExecutor(Executor) - Method in class com.sun.net.httpserver. HttpServer

设置此服务器的Executor对象。

setExecutor(Executor) - Method in class javafx.concurrent. Service

设置属性执行器的值。

setExecutor(Executor) - Method in class javax.xml.ws. Endpoint

设置这个 Endpoint实例的执行器。

setExecutor(Executor) - Method in class javax.xml.ws. Service

设置这个 Service实例的执行器。

setExecutor(Executor) - Method in class javax.xml.ws.spi. ServiceDelegate

设置这个 Service实例的执行器。

setExpandableContent(Node) - Method in class javafx.scene.control. DialogPane

设置对话框可扩展内容节点，如果不显示可扩展内容，则设置为null。

setExpanded(boolean) - Method in class javafx.scene.control. DialogPane

设置dialogPane是否展开。

setExpanded(boolean) - Method in class javafx.scene.control. TitledPane

设置TitledPane的展开状态。

setExpanded(boolean) - Method in class javafx.scene.control. TreeItem

设置此TreeItem的展开状态。

setExpandedIcon(Icon) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置展开的图标。

setExpandedPane(TitledPane) - Method in class javafx.scene.control. Accordion

目前可见的扩展TitledPane 。

setExpandedState(TreePath, boolean) - Method in class javax.swing. JTree

设置这个 JTree的扩展状态。

setExpandedState(TreePath, boolean) - Method in class javax.swing.tree. AbstractLayoutCache

标记路径 path展开状态为 isExpanded 。

setExpandedState(TreePath, boolean) - Method in class javax.swing.tree. FixedHeightLayoutCache

标记路径 path扩展状态为 isExpanded 。

setExpandedState(TreePath, boolean) - Method in class javax.swing.tree. VariableHeightLayoutCache

标记路径 path扩展状态为 isExpanded 。

setExpandEntityReferences(boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

指定此代码生成的解析器将扩展实体引用节点。

setExpandsSelectedPaths(boolean) - Method in class javax.swing. JTree

配置 expandsSelectedPaths属性。

setExpert(boolean) - Method in class java.beans. FeatureDescriptor

“专家”标志用于将针对专家用户的功能与旨在用于普通用户的功能区分开来。

setExplicitPolicyRequired(boolean) - Method in class java.security.cert. PKIXParameters

设置ExplicitPolicyRequired标志。

setExponentSeparator(String) - Method in class java.text. DecimalFormatSymbols

设置用于将尾数与指数分开的字符串。

setExpression(ObservableSetValue<E>) - Static method in class javafx.beans.binding. SetExpression

返回一个SetExpression的SetExpression 。

SetExpression< E> - Class in javafx.beans.binding

SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。

SetExpression() - Constructor for class javafx.beans.binding. SetExpression

setExtendedKeyUsage(Set<String>) - Method in class java.security.cert. X509CertSelector

设置extendedKeyUsage标准。

setExtendedState(int) - Method in class java.awt. Frame

设置此帧的状态。

setExtension(char, String) - Method in class java.util. Locale.Builder

设置给定键的扩展名。

setExtent(int) - Method in interface javax.swing. BoundedRangeModel

设置模型的范围。

setExtent(int) - Method in class javax.swing. DefaultBoundedRangeModel

在确定 n大于或等于零之后将范围设置为 n ，并且落在模型的约束内：

setExtent(int) - Method in class javax.swing. JSlider

通过旋钮设置“覆盖”范围的大小。

setExtentSize(Dimension) - Method in class javax.swing. JViewport

使用视图坐标设置视图的可见部分的大小。

setExtra(byte[]) - Method in class java.util.zip. ZipEntry

为条目设置可选的额外字段数据。

setExtraValue(Object) - Method in class javafx.scene.chart. XYChart.Data

设置属性extraValue的值。

setFace(String) - Method in interface org.w3c.dom.html. HTMLBaseFontElement

setFace(String) - Method in interface org.w3c.dom.html. HTMLFontElement

setFailureHandler(RMIFailureHandler) - Static method in class java.rmi.server. RMISocketFactory

如果服务器套接字创建失败，则设置由RMI运行时调用的故障处理程序。

setFallbackLinkers(List<? extends GuardingDynamicLinker>) - Method in class jdk.dynalink. DynamicLinkerFactory

设置后备守护动态链接器。

setFallbackLinkers(GuardingDynamicLinker...) - Method in class jdk.dynalink. DynamicLinkerFactory

设置后备守护动态链接器。

setFarClip(double) - Method in class javafx.scene. Camera

设置属性farClip的值。

setFaultActor(String) - Method in interface javax.xml.soap. SOAPFault

使用给定的故障演员设置此 SOAPFault对象。

setFaultCode(String) - Method in interface javax.xml.soap. SOAPFault

使用给定故障代码设置此 SOAPFault对象。

setFaultCode(QName) - Method in interface javax.xml.soap. SOAPFault

使用给定的故障代码设置此 SOAPFault对象。

setFaultCode(Name) - Method in interface javax.xml.soap. SOAPFault

使用给定的故障代码设置此 SOAPFault对象。

setFaultNode(String) - Method in interface javax.xml.soap. SOAPFault

创建或替换此 SOAPFault对象的任何现有Node元素值。

setFaultRole(String) - Method in interface javax.xml.soap. SOAPFault

创建或替换此 SOAPFault对象的任何现有Role元素值。

setFaultString(String) - Method in interface javax.xml.soap. SOAPFault

将此 SOAPFault对象的故障字符串设置为给定的字符串。

setFaultString(String, Locale) - Method in interface javax.xml.soap. SOAPFault

将此 SOAPFault对象的故障字符串设置为给定的字符串，并将其定位到给定的区域设置。

setFeature(String, boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

为此工厂创建的 DocumentBuilderFactory和 DocumentBuilder设置了一个功能。

setFeature(String, boolean) - Method in class javax.xml.parsers. SAXParserFactory

设置org.xml.sax.XMLReader的底层实现中的特殊功能。

setFeature(String, boolean) - Method in class javax.xml.transform. TransformerFactory

设置此工厂创建的 TransformerFactory和 Transformer s或 Template的功能。

setFeature(String, boolean) - Method in class javax.xml.validation. SchemaFactory

设置了一个功能，这个SchemaFactory ， Schema个此工厂创建S，推而广之， Validator个 S和ValidatorHandler那些创建小号Schema秒。

setFeature(String, boolean) - Method in class javax.xml.validation. Validator

设置特征标志的值。

setFeature(String, boolean) - Method in class javax.xml.validation. ValidatorHandler

为此设置一个功能 ValidatorHandler 。

setFeature(String, boolean) - Method in class javax.xml.xpath. XPathFactory

设置此工厂创建的 XPathFactory和 XPath的功能。

setFeature(String, boolean) - Method in class org.xml.sax.helpers. ParserAdapter

为解析器设置功能标志。

setFeature(String, boolean) - Method in class org.xml.sax.helpers. XMLFilterImpl

设置功能的值。

setFeature(String, boolean) - Method in interface org.xml.sax. XMLReader

设置特征标志的值。

setFetchDirection(int) - Method in interface java.sql. ResultSet

给出这个 ResultSet对象中的行将被处理的方向的提示。

setFetchDirection(int) - Method in interface java.sql. Statement

向驱动程序提供关于使用此 Statement对象创建的对象中的 ResultSet在 ResultSet处理的方向的提示。

setFetchDirection(int) - Method in class javax.sql.rowset. BaseRowSet

向驱动程序提供关于将处理此 RowSet对象中的行的方向的性能提示。

setFetchSize(int) - Method in interface java.sql. ResultSet

给JDBC驱动程序一个提示，当这个 ResultSet对象需要更多行时，应该从数据库中获取的行数。

setFetchSize(int) - Method in interface java.sql. Statement

给JDBC驱动程序提供一个关于应该从数据库中获取的行数，当需要 ResultSet对象由 Statement生成的 ResultSet对象时需要更多行。

setFetchSize(int) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的提取大小设置为给定行数。

setField(String, Object) - Method in interface javax.management. Descriptor

设置特定字段名称的值。

setField(String, Object) - Method in class javax.management. ImmutableDescriptor

此操作不受支持，因为此类是不可变的。

setField(String, Object) - Method in class javax.management.modelmbean. DescriptorSupport

setFieldOfView(double) - Method in class javafx.scene. PerspectiveCamera

设置属性fieldOfView的值。

setFields(int...) - Method in class java.util. Calendar.Builder

将字段参数设置为 fieldValuePairs给出的值，它们是字段对及其值。

setFields(String[], Object[]) - Method in interface javax.management. Descriptor

将字段名称数组中的所有字段设置为字段值数组中具有相同索引的新值。

setFields(String[], Object[]) - Method in class javax.management. ImmutableDescriptor

此操作不受支持，因为此类是不可变的。

setFields(String[], Object[]) - Method in class javax.management.modelmbean. DescriptorSupport

setFile(String) - Method in class java.awt. FileDialog

将此文件对话框窗口的选定文件设置为指定的文件。

setFileFilter(FileFilter) - Method in class javax.swing. JFileChooser

设置当前文件过滤器。

setFileHidingEnabled(boolean) - Method in class javax.swing. JFileChooser

设置文件隐藏打开或关闭。

setFileName(String) - Method in class java.awt. JobAttributes

指定使用这些属性的作业的输出文件的文件名。

setFileName(String) - Method in class javax.swing.plaf.basic. BasicFileChooserUI

设置文件名。

setFileName(String) - Method in class javax.swing.plaf.metal. MetalFileChooserUI

setFileName(String) - Method in exception jdk.nashorn.api.scripting. NashornException

设置这个 NashornException的源文件名

setFilenameFilter(FilenameFilter) - Method in class java.awt. FileDialog

将此文件对话窗口的文件名过滤器设置为指定的过滤器。

setFileNameMap(FileNameMap) - Static method in class java.net. URLConnection

设置FileNameMap。

setFileSelectionMode(int) - Method in class javax.swing. JFileChooser

设置 JFileChooser以允许用户选择文件，只需选择目录，或选择文件和目录。

setFileSystemView(FileSystemView) - Method in class javax.swing. JFileChooser

设置 JFileChooser用于访问和创建文件系统资源的文件系统视图，例如找到软盘驱动器并获取根驱动器列表。

setFileTypeMap(FileTypeMap) - Method in class javax.activation. FileDataSource

将FileTypeMap设置为与此FileDataSource一起使用

setFileView(FileView) - Method in class javax.swing. JFileChooser

设置用于检索UI信息的文件视图，例如表示文件的图标或文件的类型说明。

setFill(Paint) - Method in class javafx.scene.canvas. GraphicsContext

设置当前填充绘图属性。

setFill(Paint) - Method in class javafx.scene. Scene

设置属性填充的值。

setFill(Paint) - Method in class javafx.scene.shape. Shape

设置属性填充的值。

setFill(Paint) - Method in class javafx.scene. SnapshotParameters

将填充设置为指定的值。

setFill(Paint) - Method in class javafx.scene. SubScene

设置属性填充的值。

setFillHeight(boolean) - Method in class javafx.scene.layout. HBox

设置属性fillHeight的值。

setFillHeight(boolean) - Method in class javafx.scene.layout. RowConstraints

设置属性fillHeight的值。

setFillHeight(Node, Boolean) - Static method in class javafx.scene.layout. GridPane

设置子窗格包含的窗格的垂直填充策略。

setFillRule(FillRule) - Method in class javafx.scene.canvas. GraphicsContext

设置填充规则属性以确定填充或剪辑操作中路径的内部。

setFillRule(FillRule) - Method in class javafx.scene.shape. Path

设置属性fillRule的值。

setFillRule(FillRule) - Method in class javafx.scene.shape. SVGPath

设置属性fillRule的值。

setFillsViewportHeight(boolean) - Method in class javax.swing. JTable

设置此表是否总是足够大以填充封闭视口的高度。

setFillWidth(boolean) - Method in class javafx.scene.layout. ColumnConstraints

设置属性fillWidth的值。

setFillWidth(boolean) - Method in class javafx.scene.layout. VBox

设置属性fillWidth的值。

setFillWidth(Node, Boolean) - Static method in class javafx.scene.layout. GridPane

设置子窗格的水平填充策略。

setFilter(Filter) - Method in class java.util.logging. Handler

设置一个 Filter来控制这个 Handler输出。

setFilter(Filter) - Method in class java.util.logging. Logger

设置一个过滤器来控制此记录器的输出。

setFilter(Predicate) - Method in interface javax.sql.rowset. FilteredRowSet

将给定的 Predicate对象应用于此 FilteredRowSet对象。

setFilter(LSParserFilter) - Method in interface org.w3c.dom.ls. LSParser

当提供过滤器时，在构建DOM树结构时，实现将调用过滤器。

setFilter(LSSerializerFilter) - Method in interface org.w3c.dom.ls. LSSerializer

当应用程序提供过滤器时，序列化程序将在序列化每个节点之前调用过滤器。

setFirstDayOfWeek(int) - Method in class java.util. Calendar

设置一周的第一天是什么？ 例如， SUNDAY在美国， MONDAY在法国。

setFirstLineIndent(float) - Method in class javax.swing.text. ParagraphView

设置第一行的缩进。

setFirstLineIndent(MutableAttributeSet, float) - Static method in class javax.swing.text. StyleConstants

设置第一行缩进。

setFitHeight(double) - Method in class javafx.scene.image. ImageView

设置属性fitHeight的值。

setFitHeight(double) - Method in class javafx.scene.media. MediaView

设置调整大小的介质的边界框的高度。

setFitToHeight(boolean) - Method in class javafx.scene.control. ScrollPane

设置属性fitToHeight的值。

setFitToWidth(boolean) - Method in class javafx.scene.control. ScrollPane

设置属性fitToWidth的值。

setFitWidth(double) - Method in class javafx.scene.image. ImageView

设置属性fitWidth的值。

setFitWidth(double) - Method in class javafx.scene.media. MediaView

设置调整大小的介质的边界框的宽度。

setFixedCellHeight(int) - Method in class javax.swing. JList

设置要用于列表中每个单元格的高度的固定值。

setFixedCellSize(double) - Method in class javafx.scene.control. ListView

设置此控件的新固定单元格大小。

setFixedCellSize(double) - Method in class javafx.scene.control.skin. VirtualFlow

设置属性fixedCellSize的值。

setFixedCellSize(double) - Method in class javafx.scene.control. TableView

设置此控件的新固定单元格大小。

setFixedCellSize(double) - Method in class javafx.scene.control. TreeTableView

设置此控件的新固定单元格大小。

setFixedCellSize(double) - Method in class javafx.scene.control. TreeView

设置此控件的新固定单元格大小。

setFixedCellWidth(int) - Method in class javax.swing. JList

设置要用于列表中每个单元格宽度的固定值。

setFixedLengthStreamingMode(int) - Method in class java.net. HttpURLConnection

当预先知道内容长度时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。

setFixedLengthStreamingMode(long) - Method in class java.net. HttpURLConnection

当预先知道内容长度时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。

setFlags(AclEntryFlag...) - Method in class java.nio.file.attribute. AclEntry.Builder

设置此构建器的标志组件。

setFlags(Set<AclEntryFlag>) - Method in class java.nio.file.attribute. AclEntry.Builder

设置此构建器的标志组件。

setFlashColor(Color) - Static method in class javax.swing. DebugGraphics

设置用于闪光绘图操作的颜色。

setFlashCount(int) - Static method in class javax.swing. DebugGraphics

设置绘图操作将闪烁的次数。

setFlashTime(int) - Static method in class javax.swing. DebugGraphics

设置绘图操作闪烁的时间延迟。

setFlavorMap(FlavorMap) - Method in class java.awt.dnd. DropTarget

设置 FlavorMap与此相关 DropTarget 。

setFlavorsForNative(String, DataFlavor[]) - Method in class java.awt.datatransfer. SystemFlavorMap

放弃指定的当前映射 String人，并创建新的映射到指定 DataFlavor秒。

setFloat(int, float) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java float值。

setFloat(int, float) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中给定的 float 。

setFloat(int, float) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java float值。

setFloat(Object, float) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 float 。

setFloat(Object, int, float) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的 float值。

setFloat(String, float) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java float值。

setFloat(String, float) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java float值。

setFloat(String, float) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java float值。

setFloatable(boolean) - Method in class javax.swing. JToolBar

设置 floatable属性，必须为 true才能使用户移动工具栏。

setFloating(boolean, Point) - Method in class javax.swing.plaf.basic. BasicToolBarUI

设置浮动属性。

setFloatingColor(Color) - Method in class javax.swing.plaf.basic. BasicToolBarUI

设置在浮动区域上显示的颜色

setFloatingLocation(int, int) - Method in class javax.swing.plaf.basic. BasicToolBarUI

设置浮动位置。

setFloatValue(short, float) - Method in interface org.w3c.dom.css. CSSPrimitiveValue

用指定单位设置浮点值的方法。

setFocusable(boolean) - Method in class java.awt. Component

将此组件的可聚焦状态设置为指定的值。

setFocusableWindowState(boolean) - Method in class java.awt. Window

设置此窗口是否可以成为关注窗口，如果它符合 isFocusableWindow概述的其他要求。

setFocusAccelerator(char) - Method in class javax.swing.text. JTextComponent

设置将导致接收文本组件获得焦点的关键加速器。

setFocusCycleRoot(boolean) - Method in class java.awt. Container

设置此容器是否是焦点遍历循环的根。

setFocusCycleRoot(boolean) - Method in class java.awt. Window

没有因为Windows必须始终是焦点遍历循环的根源。

setFocusCycleRoot(boolean) - Method in class javax.swing. JInternalFrame

JInternalFrame因为 JInternalFrame必须始终是焦点遍历循环的根。

setFocused(boolean) - Method in class javafx.scene. Node

设置集中的属性的值。

setFocusLostBehavior(int) - Method in class javax.swing. JFormattedTextField

设置焦点丢失时的行为。

setFocusModel(FocusModel<TreeItem<T>>) - Method in class javafx.scene.control. TreeView

设置要在TreeView中使用的FocusModel 。

setFocusModel(FocusModel<T>) - Method in class javafx.scene.control. ListView

设置要在ListView中使用的FocusModel 。

setFocusModel(TableView.TableViewFocusModel<S>) - Method in class javafx.scene.control. TableView

设置属性focusModel的值。

setFocusModel(TreeTableView.TreeTableViewFocusModel<S>) - Method in class javafx.scene.control. TreeTableView

设置要在TreeTableView中使用的FocusModel 。

setFocusPainted(boolean) - Method in class javax.swing. AbstractButton

设置 paintFocus属性，对于要绘制的焦点状态，属性必须为 true 。

setFocusTraversable(boolean) - Method in class javafx.scene. Node

设置focusTraversable属性的值。

setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class java.awt. Component

设置此组件给定遍历操作的焦点遍历键。

setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class java.awt. Container

设置此容器的给定遍历操作的焦点遍历键。

setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class javax.swing. JComponent

设置此组件给定遍历操作的焦点遍历键。

setFocusTraversalKeysEnabled(boolean) - Method in class java.awt. Component

设置是否为此组件启用对焦遍历键。

setFocusTraversalPolicy(FocusTraversalPolicy) - Method in class java.awt. Container

设置焦点遍历策略，将管理此Container的子项的键盘遍历，如果此Container是焦点循环根。

setFocusTraversalPolicyProvider(boolean) - Method in class java.awt. Container

设置此容器是否将用于提供焦点遍历策略。

setFollowRedirects(boolean) - Static method in class java.net. HttpURLConnection

设置HTTP重定向（具有响应代码3xx的请求）是否应该在该类之后自动跟随。

setFont(Font) - Method in class com.sun.java.accessibility.util. Translator

设置此对象的 Font 。

setFont(Font) - Method in class java.awt. Component.AccessibleAWTComponent

设置该对象的 Font 。

setFont(Font) - Method in class java.awt. Component

设置此组件的字体。

setFont(Font) - Method in class java.awt. Container

设置此容器的字体。

setFont(Font) - Method in class java.awt. Graphics

将此图形上下文的字体设置为指定的字体。

setFont(Font) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

设置此对象的Font。

setFont(Font) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

设置此对象的 Font 。

setFont(Font) - Method in class java.awt. MenuComponent

将此菜单组件使用的字体设置为指定的字体。

setFont(Font) - Method in interface javax.accessibility. AccessibleComponent

设置此对象的字体。

setFont(Font) - Method in class javax.swing. DebugGraphics

设置用于文本绘图操作的字体。

setFont(Font) - Method in class javax.swing. JComponent

设置此组件的字体。

setFont(Font) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setFont(Font) - Method in class javax.swing. JSlider

设置此组件的字体。

setFont(Font) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置此对象的 Font 。

setFont(Font) - Method in class javax.swing. JTextArea

设置当前字体。

setFont(Font) - Method in class javax.swing. JTextField

设置当前字体。

setFont(Font) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setFont(Font) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setFont(Font) - Method in class javax.swing.tree. DefaultTreeCellEditor

设置要编辑的字体。

setFont(Font) - Method in class javax.swing.tree. DefaultTreeCellRenderer

Subclassed将图 FontUIResource s映射为null。

setFont(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font属性定义。

setFont(Font) - Method in class javafx.scene.canvas. GraphicsContext

设置当前字体。

setFont(Font) - Method in class javafx.scene.control. Labeled

设置属性字体的值。

setFont(Font) - Method in class javafx.scene.control. TextInputControl

设置属性字体的值。

setFont(Font) - Method in class javafx.scene.control. Tooltip

设置属性字体的值。

setFont(Font) - Method in class javafx.scene.text. Text

设置属性字体的值。

setFontFamily(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-family属性定义。

setFontFamily(MutableAttributeSet, String) - Static method in class javax.swing.text. StyleConstants

设置字体属性。

setFontScale(double) - Method in class javafx.scene.web. WebView

设置属性fontScale的值。

setFontSize(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-size属性定义。

setFontSize(MutableAttributeSet, int) - Static method in class javax.swing.text. StyleConstants

设置字体大小属性。

setFontSizeAdjust(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-size-adjust属性定义。

setFontSmoothingType(FontSmoothingType) - Method in class javafx.scene.canvas. GraphicsContext

设置当前的字体平滑类型。

setFontSmoothingType(FontSmoothingType) - Method in class javafx.scene.text. Text

设置属性fontSmoothingType的值。

setFontSmoothingType(FontSmoothingType) - Method in class javafx.scene.web. WebView

设置属性fontSmoothingType的值。

setFontStretch(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-stretch属性定义。

setFontStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-style属性定义。

setFontVariant(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-variant属性定义。

setFontWeight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的font-weight属性定义。

setForceIntegerRenderScale(boolean) - Method in class javafx.stage. Window

设置属性forceIntegerRenderScale的值。

setForceZeroInRange(boolean) - Method in class javafx.scene.chart. NumberAxis

设置属性forceZeroInRange的值。

setForeground(Color) - Method in class com.sun.java.accessibility.util. Translator

设置该对象的前台 Color 。

setForeground(Color) - Method in class java.awt. Component.AccessibleAWTComponent

设置此对象的前景色。

setForeground(Color) - Method in class java.awt. Component

设置此组件的前景颜色。

setForeground(Color) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

设置此对象的前景色。

setForeground(Color) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

设置此对象的前景色。

setForeground(Color) - Method in interface javax.accessibility. AccessibleComponent

设置此对象的前景色。

setForeground(Color) - Method in class javax.swing. JComponent

设置此组件的前景颜色。

setForeground(Color) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setForeground(Color) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置此对象的前景色。

setForeground(Color) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setForeground(Color) - Method in class javax.swing.table. DefaultTableCellRenderer

覆盖 JComponent.setForeground以将未选择的前景颜色分配给指定的颜色。

setForeground(Color) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setForeground(MutableAttributeSet, Color) - Static method in class javax.swing.text. StyleConstants

设置前景色。

setForegroundAt(int, Color) - Method in class javax.swing. JTabbedPane

将前景颜色设置为 index至 foreground ，其中可以是 null ，在这种情况下，选项卡的前景色将默认为此 tabbedpane的前景色。

setForkJoinTaskTag(short) - Method in class java.util.concurrent. ForkJoinTask

原子地设置此任务的标签值并返回旧值。

setFormat(int, Format) - Method in class java.text. MessageFormat

设置在先前设置的模式字符串中使用具有给定格式元素索引的格式元素的格式。

setFormat(DateFormat) - Method in class javax.swing.text. DateFormatter

设置指定可编辑和显示的合法值的格式。

setFormat(Format) - Method in class javax.swing.text. InternationalFormatter

设置指定可编辑和显示的合法值的格式。

setFormat(Format) - Method in class javax.swing.text. NumberFormatter

设置指定可编辑和显示的合法值的格式。

setFormatByArgumentIndex(int, Format) - Method in class java.text. MessageFormat

设置使用给定参数索引的先前设置的模式字符串中的格式元素的格式。

setFormats(Format[]) - Method in class java.text. MessageFormat

设置用于先前设置的模式字符串中的格式元素的格式。

setFormatsByArgumentIndex(Format[]) - Method in class java.text. MessageFormat

设置用于传递给 format方法或从 parse方法返回的值的格式。

setFormattedOutput(boolean) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

设置格式化输出标志的便利方法。

setFormatter(Formatter) - Method in class java.util.logging. Handler

设置一个 Formatter 。

setFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing. JFormattedTextField

设置当前的 AbstractFormatter 。

setFormatterFactory(JFormattedTextField.AbstractFormatterFactory) - Method in class javax.swing. JFormattedTextField

设置 AbstractFormatterFactory 。

setForwardBias(boolean) - Method in class javafx.scene.control.skin. TextInputControlSkin

设置属性forwardBias的值。

setFraction(double) - Method in class javafx.scene.effect. Reflection

设置属性分数的值。

setFractionalSecond(BigDecimal) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置小数秒。

setFragment(boolean) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

设置片段标志的便利方法。

setFrame(double, double, double, double) - Method in class java.awt.geom. Arc2D

将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

setFrame(double, double, double, double) - Method in class java.awt.geom. Ellipse2D.Double

将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

setFrame(double, double, double, double) - Method in class java.awt.geom. Ellipse2D.Float

将此 Shape的框架矩形的位置和大小设置为指定的矩形值。

setFrame(double, double, double, double) - Method in class java.awt.geom. Rectangle2D

将此 Rectangle2D的外部边界的位置和大小设置为指定的矩形值。

setFrame(double, double, double, double) - Method in class java.awt.geom. RectangularShape

将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

setFrame(double, double, double, double) - Method in class java.awt.geom. RoundRectangle2D

将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

setFrame(float, float, float, float) - Method in class java.awt.geom. Ellipse2D.Float

将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

setFrame(Point2D, Dimension2D) - Method in class java.awt.geom. RectangularShape

将此Shape的成帧矩形的位置和大小分别设置为Point2D和Dimension2D 。

setFrame(Rectangle2D) - Method in class java.awt.geom. RectangularShape

将此 Shape的框架矩形设置为指定的 Rectangle2D 。

setFrame(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setFrameBorder(String) - Method in interface org.w3c.dom.html. HTMLFrameElement

setFrameBorder(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setFrameFromCenter(double, double, double, double) - Method in class java.awt.geom. RectangularShape

根据指定的中心点坐标和角点坐标设置此 Shape的框架矩形。

setFrameFromCenter(Point2D, Point2D) - Method in class java.awt.geom. RectangularShape

根据指定的中心 Point2D和角 Point2D设置此 Shape的框架矩形。

setFrameFromDiagonal(double, double, double, double) - Method in class java.awt.geom. RectangularShape

基于两个指定的坐标设置此 Shape框架矩形的对角线。

setFrameFromDiagonal(Point2D, Point2D) - Method in class java.awt.geom. RectangularShape

基于两个指定的 Point2D对象设置此 Shape框架矩形的对角线。

setFrameIcon(Icon) - Method in class javax.swing. JInternalFrame

设置要显示在该内部框架的标题栏中的图像（通常位于左上角）。

setFramePosition(int) - Method in interface javax.sound.sampled. Clip

设置采样帧中的介质位置。

setFreeStanding(boolean) - Method in class javax.swing.plaf.metal. MetalScrollButton

设置独立的价值。

setFromAngle(double) - Method in class javafx.animation. RotateTransition

设置属性fromAngle的值。

setFromPage(int) - Method in class java.awt. JobAttributes

对于要使用这些属性的作业，如果要打印一系列页面，则指定要打印的第一页。

setFromTree(String, Node) - Method in class javax.imageio.metadata. IIOMetadata

从XML DOM Node的树中设置此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。

setFromValue(double) - Method in class javafx.animation. FadeTransition

设置属性fromValue的值。

setFromValue(Color) - Method in class javafx.animation. FillTransition

设置属性fromValue的值。

setFromValue(Color) - Method in class javafx.animation. StrokeTransition

设置属性fromValue的值。

setFromX(double) - Method in class javafx.animation. ScaleTransition

设置属性fromX的值。

setFromX(double) - Method in class javafx.animation. TranslateTransition

设置属性fromX的值。

setFromY(double) - Method in class javafx.animation. ScaleTransition

设置属性fromY的值。

setFromY(double) - Method in class javafx.animation. TranslateTransition

设置属性fromY的值。

setFromZ(double) - Method in class javafx.animation. ScaleTransition

设置属性的值Z。

setFromZ(double) - Method in class javafx.animation. TranslateTransition

设置属性的值Z。

setFullBufferUpdates(boolean) - Method in class java.awt.image. MemoryImageSource

指定是否应始终通过发送像素的完整缓冲区来更新此动画内存映像。

setFullScreen(boolean) - Method in class javafx.stage. Stage

设置属性fullScreen的值。

setFullScreenExitHint(String) - Method in class javafx.stage. Stage

指定用户进入全屏模式时显示的文字，通常用于指示用户从全屏模式退出的方式。

setFullScreenExitKeyCombination(KeyCombination) - Method in class javafx.stage. Stage

指定将允许用户退出全屏模式的KeyCombination。

setFullScreenWindow(Window) - Method in class java.awt. GraphicsDevice

进入全屏模式，或返回窗口模式。

setGain(double) - Method in class javafx.scene.media. EqualizerBand

以dB为单位设置频带的增益。

setGapStartAndEnd(boolean) - Method in class javafx.scene.chart. CategoryAxis

设置属性gapStartAndEnd的值。

setGlassPane(Component) - Method in class javax.swing. JApplet

已过时。

设置glassPane属性。

setGlassPane(Component) - Method in class javax.swing. JDialog

设置 glassPane属性。

setGlassPane(Component) - Method in class javax.swing. JFrame

设置 glassPane属性。

setGlassPane(Component) - Method in class javax.swing. JInternalFrame

设置这个 JInternalFrame的 glassPane属性。

setGlassPane(Component) - Method in class javax.swing. JRootPane

将指定的 Component设置为此根窗格的玻璃窗格。

setGlassPane(Component) - Method in class javax.swing. JWindow

设置 glassPane属性。

setGlassPane(Component) - Method in interface javax.swing. RootPaneContainer

glassPane始终是rootPane的第一个孩子，rootPane布局管理器确保它始终与rootPane一样大。

setGlassPane(JPanel) - Method in class javax.swing. JLayer

设置 JLayer的glassPane组件，可以是 null 。

setGlobalActiveWindow(Window) - Method in class java.awt. KeyboardFocusManager

设置活动窗口。

setGlobalAlpha(double) - Method in class javafx.scene.canvas. GraphicsContext

设置当前状态的全局alpha。

setGlobalBlendMode(BlendMode) - Method in class javafx.scene.canvas. GraphicsContext

设置全局混合模式。

setGlobalCurrentFocusCycleRoot(Container) - Method in class java.awt. KeyboardFocusManager

设置当前焦点循环根。

setGlobalFocusedWindow(Window) - Method in class java.awt. KeyboardFocusManager

设置聚焦窗口。

setGlobalFocusOwner(Component) - Method in class java.awt. KeyboardFocusManager

设置焦点所有者。

setGlobalPermanentFocusOwner(Component) - Method in class java.awt. KeyboardFocusManager

设置永久焦点所有者。

setGlyphPainter(GlyphView.GlyphPainter) - Method in class javax.swing.text. GlyphView

设置用于渲染字形的画家。

setGlyphPosition(int, Point2D) - Method in class java.awt.font. GlyphVector

设置此 GlyphVector指定字形的位置。

setGlyphTransform(int, AffineTransform) - Method in class java.awt.font. GlyphVector

设置此 GlyphVector指定字形的变换。

setGranularityPeriod(long) - Method in class javax.management.monitor. Monitor

设置粒度周期（以毫秒为单位）。

setGranularityPeriod(long) - Method in interface javax.management.monitor. MonitorMBean

设置粒度周期（以毫秒为单位）。

setGraphic(Node) - Method in class javafx.scene.control. Dialog

设置对话框图形，将显示在标题中，如果显示，或 content的左侧。

setGraphic(Node) - Method in class javafx.scene.control. DialogPane

设置对话框图形，将显示在标题中，如果显示，或 content的左侧。

setGraphic(Node) - Method in class javafx.scene.control. Labeled

设置属性图形的值。

setGraphic(Node) - Method in class javafx.scene.control. MenuItem

设置属性图形的值。

setGraphic(Node) - Method in class javafx.scene.control. Tab

将图形设置为在标签中显示，以允许用户区分每个选项卡的功能。

setGraphic(Node) - Method in class javafx.scene.control. TableColumnBase

设置属性图形的值。

setGraphic(Node) - Method in class javafx.scene.control. Tooltip

设置属性图形的值。

setGraphic(Node) - Method in class javafx.scene.control. TreeItem

设置通常显示在value属性左侧的节点。

setGraphicTextGap(double) - Method in class javafx.scene.control. Labeled

设置属性graphicTextGap的值。

setGraphicTextGap(double) - Method in class javafx.scene.control. Tooltip

设置属性graphicTextGap的值。

setGregorianChange(Date) - Method in class java.util. GregorianCalendar

设置 GregorianCalendar更改日期。

setGridColor(Color) - Method in class javax.swing. JTable

将用于绘制网格线的颜色设置为 gridColor并重新显示。

setGridLinesVisible(boolean) - Method in class javafx.scene.layout. GridPane

设置属性gridLinesVisible的值。

setGridLocation(int, int) - Method in class javax.swing.text. TableView.TableCell

已过时。

设置网格位置。

setGroup(GroupPrincipal) - Method in interface java.nio.file.attribute. PosixFileAttributeView

更新文件组所有者。

setGroup(ButtonGroup) - Method in interface javax.swing. ButtonModel

标识按钮所属的组 - 单选按钮所需的组，它们在组内是相互排斥的。

setGroup(ButtonGroup) - Method in class javax.swing. DefaultButtonModel

标识按钮所属的组 - 单选按钮所需的组，它们在组内是相互排斥的。

setGroupingSeparator(char) - Method in class java.text. DecimalFormatSymbols

设置用于千位分隔符的字符。

setGroupingSize(int) - Method in class java.text. DecimalFormat

设置分组大小。

setGroupingUsed(boolean) - Method in class java.text. DecimalFormat

设置是否以此格式使用分组。

setGroupingUsed(boolean) - Method in class java.text. NumberFormat

设置是否以此格式使用分组。

setGuiAvailable(boolean) - Static method in class java.beans. Beans

用于指示我们是否在可以进行GUI交互的环境中运行。

setHalignment(HPos) - Method in class javafx.scene.control. Separator

设置属性暂停的值。

setHalignment(HPos) - Method in class javafx.scene.layout. ColumnConstraints

设置属性暂停的值。

setHalignment(Node, HPos) - Static method in class javafx.scene.layout. GridPane

设置子窗格的水平对齐方式。

setHandler(HttpHandler) - Method in class com.sun.net.httpserver. HttpContext

设置此上下文的处理程序（如果尚未设置）。

setHandler(HttpHandler) - Method in class javax.xml.ws.spi.http. HttpContext

JAX-WS运行时在 Endpoint.publish(HttpContext)中设置其处理程序来处理此上下文的HTTP请求。

setHandler(ContentHandler) - Method in class javax.xml.transform.sax. SAXResult

将目标设定为SAX2 ContentHandler 。

setHandlerChain(List<Handler>) - Method in interface javax.xml.ws. Binding

设置协议绑定实例的处理程序链。

setHandlerResolver(HandlerResolver) - Method in class javax.xml.ws. Service

设置 HandlerResolver此 Service实例。

setHandlerResolver(HandlerResolver) - Method in class javax.xml.ws.spi. ServiceDelegate

设置 HandlerResolver此 Service实例。

setHandshakeApplicationProtocolSelector(BiFunction<SSLEngine, List<String>, String>) - Method in class javax.net.ssl. SSLEngine

注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。

setHandshakeApplicationProtocolSelector(BiFunction<SSLSocket, List<String>, String>) - Method in class javax.net.ssl. SSLSocket

注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。

setHashColor(Color) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置散列颜色。

setHbarPolicy(ScrollPane.ScrollBarPolicy) - Method in class javafx.scene.control. ScrollPane

设置属性hbarPolicy的值。

setHeader(String, String) - Method in class javax.xml.soap. MimeHeaders

将名称与给定名称匹配的第一个标题条目的当前值替换为给定值，如果没有现有的标题名称匹配，则添加一个新标题。

setHeader(String, String) - Method in class jdk.incubator.http. HttpRequest.Builder

将给定的名称值对设置为此请求的标题集。

setHeader(Node) - Method in class javafx.scene.control. DialogPane

分配对话窗格标题。

setHeaderRenderer(TableCellRenderer) - Method in class javax.swing.table. TableColumn

设置 TableCellRenderer用于绘制 TableColumn的标题到 headerRenderer 。

setHeaders(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setHeaderText(String) - Method in class javafx.scene.control. Dialog

设置在对话框头部区域显示的字符串。

setHeaderText(String) - Method in class javafx.scene.control. DialogPane

设置在对话框头部区域显示的字符串。

setHeaderValue(Object) - Method in class javax.swing.table. TableColumn

将 Object的字符串表示形式用作 headerRenderer的值。

setHeading(String) - Method in interface javax.jnlp. ExtensionInstallerService

更新进度窗口的标题文本。

setHeight(double) - Method in class javafx.scene.canvas. Canvas

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.control. Dialog

设置对话框的高度。

setHeight(double) - Method in class javafx.scene.control.skin. VirtualFlow

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.effect. BoxBlur

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.effect. ColorInput

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.effect. DropShadow

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.effect. InnerShadow

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.effect. Shadow

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.layout. Region

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.shape. Box

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.shape. Cylinder

设置属性高度的值。

setHeight(double) - Method in class javafx.scene.shape. Rectangle

设置属性高度的值。

setHeight(double) - Method in class javafx.scene. SubScene

设置属性高度的值。

setHeight(double) - Method in class javafx.stage. Window

设置属性高度的值。

setHeight(int) - Method in class javafx.scene.effect. FloatMap

设置属性高度的值。

setHeight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的height属性定义。

setHeight(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setHeight(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setHeight(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setHeight(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setHeight(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setHeight(Spring) - Method in class javax.swing. SpringLayout.Constraints

设置 height属性，它控制组件的高度。

setHelpMenu(Menu) - Method in class java.awt. MenuBar

将指定的菜单设置为此菜单栏的帮助菜单。

setHelpMenu(JMenu) - Method in class javax.swing. JMenuBar

设置用户在菜单栏中选择“帮助”选项时出现的帮助菜单。

setHgap(double) - Method in class javafx.scene.layout. FlowPane

设置属性hgap的值。

setHgap(double) - Method in class javafx.scene.layout. GridPane

设置属性hgap的值。

setHgap(double) - Method in class javafx.scene.layout. TilePane

设置属性hgap的值。

setHgap(int) - Method in class java.awt. BorderLayout

设置组件之间的水平间距。

setHgap(int) - Method in class java.awt. CardLayout

设置组件之间的水平间距。

setHgap(int) - Method in class java.awt. FlowLayout

设置组件之间以及组件之间的水平间隙和 Container的边框。

setHgap(int) - Method in class java.awt. GridLayout

将组件之间的水平间距设置为指定值。

setHgrow(Priority) - Method in class javafx.scene.layout. ColumnConstraints

设置属性hgrow的值。

setHgrow(Node, Priority) - Static method in class javafx.scene.layout. GridPane

设置子格中包含的网格的水平增长优先级。

setHgrow(Node, Priority) - Static method in class javafx.scene.layout. HBox

设置由hbox包含的小孩的横向增长优先级。

setHidden(boolean) - Method in class java.beans. FeatureDescriptor

“隐藏”标志用于识别仅用于工具使用的功能，不应该暴露于人类。

setHidden(boolean) - Method in interface java.nio.file.attribute. DosFileAttributeView

更新隐藏属性的值。

setHideActionText(boolean) - Method in class javax.swing. AbstractButton

设置 hideActionText属性，它决定按钮是否显示来自 Action文本。

setHideDelay(Duration) - Method in class javafx.scene.control. Tooltip

设置属性hideDelay的值。

setHideOnClick(boolean) - Method in class javafx.scene.control. CustomMenuItem

设置属性hideOnClick的值。

setHideOnClick(boolean) - Method in class javafx.scene.control.skin. ComboBoxListViewSkin

设置属性hideOnClick的值。

setHideOnEscape(boolean) - Method in class javafx.stage. PopupWindow

设置属性hideOnEscape的值。

setHighlighter(Highlighter) - Method in class javax.swing.text. JTextComponent

设置要使用的荧光笔。

setHighlightFill(Paint) - Method in class javafx.scene.control.skin. TextInputControlSkin

填充 Paint用于所选文本的背景。

setHighlightTextFill(Paint) - Method in class javafx.scene.control.skin. TextInputControlSkin

填充 Paint用于所选文本的前景。

setHints(int) - Method in class java.awt.image. AreaAveragingScaleFilter

检测数据是否具有必要的提示，以允许平均算法执行其工作。

setHints(int) - Method in interface java.awt.image. ImageConsumer

设置ImageConsumer用于处理ImageProducer传递的像素的提示。

setHints(int) - Method in class java.awt.image. ImageFilter

过滤ImageConsumer界面的setHints方法中提供的信息。

setHints(int) - Method in class java.awt.image. PixelGrabber

setHints方法是ImageConsumer API的一部分，该类必须实现这个API来检索像素。

setHmax(double) - Method in class javafx.scene.control. ScrollPane

设置属性hmax的值。

setHmin(double) - Method in class javafx.scene.control. ScrollPane

设置属性hmin的值。

setHoldability(int) - Method in interface java.sql. Connection

将使用此 Connection对象创建的对象的默认可 ResultSet更改为给定的可保存性。

setHonorsVisibility(boolean) - Method in class javax.swing. GroupLayout

设置在组件尺寸和定位时是否考虑组件可见性。

setHonorsVisibility(Component, Boolean) - Method in class javax.swing. GroupLayout

设置组件的可见性是否考虑到尺寸和定位。

setHorizontalAlignment(int) - Method in class javax.swing. AbstractButton

设置图标和文字的水平对齐方式。

setHorizontalAlignment(int) - Method in class javax.swing. JLabel

设置标签内容沿X轴的对齐方式。

setHorizontalAlignment(int) - Method in class javax.swing. JTextField

设置文本的水平对齐方式。

setHorizontalGridLinesVisible(boolean) - Method in class javafx.scene.chart. XYChart

设置属性horizontalGridLinesVisible的值。

setHorizontalGroup(GroupLayout.Group) - Method in class javax.swing. GroupLayout

设置 Group位置和尺寸分量沿水平轴。

setHorizontalScrollBar(JScrollBar) - Method in class javax.swing. JScrollPane

将控制视口的水平视图位置的滚动条添加到滚动条。

setHorizontalScrollBarPolicy(int) - Method in class javax.swing. JScrollPane

确定水平滚动条何时出现在滚动条中。

setHorizontalScrollBarPolicy(int) - Method in class javax.swing. ScrollPaneLayout

设置水平滚动条显示策略。

setHorizontalTextPosition(int) - Method in class javax.swing. AbstractButton

设置文本相对于图标的水平位置。

setHorizontalTextPosition(int) - Method in class javax.swing. JLabel

设置标签文本相对于其图像的水平位置。

setHorizontalZeroLineVisible(boolean) - Method in class javafx.scene.chart. XYChart

设置属性horizontalZeroLineVisible的值。

setHostnameVerifier(HostnameVerifier) - Method in class javax.naming.ldap. StartTlsResponse

在TLS握手完成并且默认主机名验证失败后，设置由 negotiate()使用的主机名验证程序。

setHostnameVerifier(HostnameVerifier) - Method in class javax.net.ssl. HttpsURLConnection

为此实例设置 HostnameVerifier 。

setHour(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置小时

setHours(int) - Method in class java.sql. Date

已过时。

setHours(int) - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.set(Calendar.HOUR_OF_DAY, int hours)替代。

setHover(boolean) - Method in class javafx.scene. Node

设置属性悬停的值。

setHref(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setHref(String) - Method in interface org.w3c.dom.html. HTMLAreaElement

setHref(String) - Method in interface org.w3c.dom.html. HTMLBaseElement

setHref(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setHreflang(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setHreflang(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setHspace(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setHspace(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setHspace(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setHtmlFor(String) - Method in interface org.w3c.dom.html. HTMLLabelElement

setHtmlFor(String) - Method in interface org.w3c.dom.html. HTMLScriptElement

setHtmlText(String) - Method in class javafx.scene.web. HTMLEditor

设置编辑器的HTML内容。

setHttpEquiv(String) - Method in interface org.w3c.dom.html. HTMLMetaElement

setHttpOnly(boolean) - Method in class java.net. HttpCookie

指示Cookie是否应被视为仅HTTP。

setHttpsConfigurator(HttpsConfigurator) - Method in class com.sun.net.httpserver. HttpsServer

设置此服务器的HttpsConfigurator对象。

setHue(double) - Method in class javafx.scene.effect. ColorAdjust

设置属性色调的值。

setHumanPresentableName(String) - Method in class java.awt.datatransfer. DataFlavor

为 DataFlavor表示的数据格式设置人类可呈现的名称。

setHumanPresentableName(String) - Method in class javax.activation. ActivationDataFlavor

设置人性化的名称。

setHvalue(double) - Method in class javafx.scene.control. ScrollPane

设置属性hvalue的值。

setIcon(boolean) - Method in class javax.swing. JInternalFrame

如果外观和感觉支持图标化，则可以对该内部框架进行图标化或去图标化。

setIcon(Icon) - Method in class javax.swing. AbstractButton

设置按钮的默认图标。

setIcon(Icon) - Method in class javax.swing. JLabel

定义该组件将显示的图标。

setIcon(Icon) - Method in class javax.swing. JOptionPane

设置要显示的图标。

setIcon(MutableAttributeSet, Icon) - Static method in class javax.swing.text. StyleConstants

设置图标属性。

setIconAt(int, Icon) - Method in class javax.swing. JTabbedPane

将图标设置为 index至 icon ，可以是 null 。

setIconBadge(String) - Method in class java.awt. Taskbar

在该应用程序的图标上贴上一个小系统提供的徽章。

setIconifiable(boolean) - Method in class javax.swing. JInternalFrame

设置 iconable属性，该属性必须是 true ，以便用户能够使 JInternalFrame成为一个图标。

setIconified(boolean) - Method in class javafx.stage. Stage

设置图标属性的值。

setIconImage(Image) - Method in class java.awt. Frame

将要显示的图像设置为此窗口的图标。

setIconImage(Image) - Method in class java.awt. Taskbar

将此应用程序的图标更改为提供的图像。

setIconImage(Image) - Method in class java.awt. Window

将要显示的图像设置为此窗口的图标。

setIconImage(Image) - Method in class javax.swing. JFrame

将要显示的图像设置为此窗口的图标。

setIconImages(List<? extends Image>) - Method in class java.awt. Window

设置要显示为该窗口的图标的图像序列。

setIconOnly(boolean) - Method in class javax.swing.plaf.metal. MetalComboBoxButton

如果 isIconOnly是 true那么只有图标被画。

setIconTextGap(int) - Method in class javax.swing. AbstractButton

如果设置了图标和文本属性，则此属性定义它们之间的空格。

setIconTextGap(int) - Method in class javax.swing. JLabel

如果设置了图标和文本属性，则此属性定义它们之间的空格。

setId(String) - Method in class javafx.scene.control. MenuItem

设置属性id的值。

setId(String) - Method in class javafx.scene.control. PopupControl

设置这个 PopupControl的id。

setId(String) - Method in class javafx.scene.control. Tab

设置此选项卡的ID。

setId(String) - Method in class javafx.scene.control. TableColumnBase

设置属性id的值。

setId(String) - Method in class javafx.scene. Node

设置属性id的值。

setId(String) - Method in interface org.w3c.dom.html. HTMLElement

setID(String) - Method in class java.util. TimeZone

设置时区ID。

setIdAttribute(String, boolean) - Method in class javax.imageio.metadata. IIOMetadataNode

IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

setIdAttribute(String, boolean) - Method in interface org.w3c.dom. Element

如果参数 isId为 true ，则此方法将指定的属性声明为用户确定的ID属性。

setIdAttributeNode(Attr, boolean) - Method in class javax.imageio.metadata. IIOMetadataNode

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

setIdAttributeNode(Attr, boolean) - Method in interface org.w3c.dom. Element

如果参数 isId为 true ，则此方法将指定的属性声明为用户确定的ID属性。

setIdAttributeNS(String, String, boolean) - Method in class javax.imageio.metadata. IIOMetadataNode

IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

setIdAttributeNS(String, String, boolean) - Method in interface org.w3c.dom. Element

如果参数 isId为 true ，则此方法将指定的属性声明为用户确定的ID属性。

setIdAttributeNS(Element, String, String) - Method in class javax.xml.crypto.dom. DOMCryptoContext

将名称空间URI和本地名称指定的元素的属性注册为类型ID。

setIdentifier(Object) - Method in class javax.swing.table. TableColumn

将 TableColumn的标识设置为 anIdentifier 。

setIfModifiedSince(long) - Method in class java.net. URLConnection

将此 URLConnection的 ifModifiedSince字段的值设置为指定值。

setIgnoreRepaint(boolean) - Method in class java.awt. Component

设置是否忽略从操作系统接收的画面消息。

setIgnoringComments(boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

指定此代码生成的解析器将忽略注释。

setIgnoringElementContentWhitespace(boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

指定此工厂创建的解析器必须在解析XML文档时消除元素内容中的空格（有时称为“可忽略的空白”）（请参阅XML Rec 2.10）。

setImage(Image) - Method in class java.awt. TrayIcon

设置 TrayIcon的图像。

setImage(Image) - Method in class javax.swing. ImageIcon

设置此图标显示的图像。

setImage(Image) - Method in class javafx.scene.image. ImageView

设置属性图像的值。

setImageableArea(double, double, double, double) - Method in class java.awt.print. Paper

设置 Paper的可成像区域。

setImageAutoSize(boolean) - Method in class java.awt. TrayIcon

设置自动大小属性。

setImageObserver(ImageObserver) - Method in class javax.swing. ImageIcon

设置图像的图像观察者。

setImageURL(URL) - Method in class java.awt. SplashScreen

更改启动屏幕图像。

setImplementation(Object) - Method in class javax.management. StandardMBean

替换包含在该对象中的实现对象。

setImplicitDownCycleTraversal(boolean) - Method in class java.awt. ContainerOrderFocusTraversalPolicy

设置此ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行周期。

setImplicitDownCycleTraversal(boolean) - Method in class javax.swing. SortingFocusTraversalPolicy

设置此SortingFocusTraversalPolicy是否隐式转移焦点下行周期。

setImplicitExit(boolean) - Static method in class javafx.application. Platform

将implicitExit属性设置为指定的值。

setIn(InputStream) - Static method in class java.lang. System

重新分配“标准”输入流。

setInDefaultEventSet(boolean) - Method in class java.beans. EventSetDescriptor

将事件设置为“默认”集（或不是）。

setIndent(double) - Method in class javafx.scene.control.skin. TreeCellSkin

设置属性缩进的值。

setIndent(double) - Method in class javafx.scene.control.skin. TreeTableRowSkin

设置属性缩进的值。

setIndentSpace(int) - Method in class javax.swing.text. AbstractWriter

启用子类来指定缩进映射到的空格。

setIndependent(boolean) - Method in class javafx.scene.control. CheckBoxTreeItem

设置属性的值独立。

setIndeterminate(boolean) - Method in class javafx.scene.control. CheckBox

设置属性的值不确定。

setIndeterminate(boolean) - Method in class javafx.scene.control. CheckBoxTreeItem

设置此CheckBoxTreeItem的不确定状态。

setIndeterminate(boolean) - Method in class javax.swing. JProgressBar

设置进度条的 indeterminate属性，该属性决定进度条是确定还是不确定模式。

setIndex(int) - Method in interface java.text. CharacterIterator

将位置设置为文本中的指定位置，并返回该字符。

setIndex(int) - Method in class java.text. ParsePosition

设置当前解析位置。

setIndex(int) - Method in class java.text. StringCharacterIterator

为String实现CharacterIterator.setIndex（）。

setIndex(int) - Method in class javax.swing.text. Segment

将位置设置为文本中的指定位置，并返回该字符。

setIndexedPropertiesToExternalArrayData(ByteBuffer) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

Nashorn扩展名：setIndexedPropertiesToExternalArrayData。

setIndexedReadMethod(Method) - Method in class java.beans. IndexedPropertyDescriptor

设置应用于读取索引属性值的方法。

setIndexedWriteMethod(Method) - Method in class java.beans. IndexedPropertyDescriptor

设置应用于编写索引属性值的方法。

setInfinity(String) - Method in class java.text. DecimalFormatSymbols

设置用于表示无穷大的字符串。

setInfo(String) - Method in class java.security. Identity

已过时。

指定此标识的常规信息字符串。

setInheritsPopupMenu(boolean) - Method in class javax.swing. JComponent

设置 getComponentPopupMenu是否应该委托给父，如果该组件没有分配给它的 JPopupMenu 。

setInitialContextFactoryBuilder(InitialContextFactoryBuilder) - Static method in class javax.naming.spi. NamingManager

将InitialContextFactory构建器设置为构建器。

setInitialDelay(int) - Method in class javax.swing. Timer

设置 Timer的初始延迟，在触发第一个事件之前，定时器启动后等待的时间（以毫秒为单位）。

setInitialDelay(int) - Method in class javax.swing. ToolTipManager

指定初始延迟值。

setInitialDirectory(File) - Method in class javafx.stage. DirectoryChooser

设置属性initialDirectory的值。

setInitialDirectory(File) - Method in class javafx.stage. FileChooser

设置属性initialDirectory的值。

setInitialFileName(String) - Method in class javafx.stage. FileChooser

设置属性initialFileName的值。

setInitialPolicies(Set<String>) - Method in class java.security.cert. PKIXParameters

设置初始策略标识符（OID字符串）的 Set ，指示证书用户为了认证路径处理的目的而可以接受这些策略中的任何一个。

setInitialSelectionValue(Object) - Method in class javax.swing. JOptionPane

将最初显示为选定的输入值设置为用户。

setInitialValue(Object) - Method in class javax.swing. JOptionPane

设置要启用的初始值 - 初始显示窗格时具有焦点的 Component 。

setInitThreshold(Number) - Method in class javax.management.monitor. CounterMonitor

设置所有观察对象共同的初始阈值。

setInitThreshold(Number) - Method in interface javax.management.monitor. CounterMonitorMBean

设置所有观察到的MBean公用的初始阈值。

setInnerHTML(Element, String) - Method in class javax.swing.text.html. HTMLDocument

用指定为HTML字符串的内容替换给定元素的子元素。

setInput(byte[]) - Method in class java.util.zip. Deflater

设置压缩输入数据。

setInput(byte[]) - Method in class java.util.zip. Inflater

设置解压缩的输入数据。

setInput(byte[], int, int) - Method in class java.util.zip. Deflater

设置压缩输入数据。

setInput(byte[], int, int) - Method in class java.util.zip. Inflater

设置解压缩的输入数据。

setInput(Object) - Method in class javax.imageio. ImageReader

将输入源设置为给定的 ImageInputStream或其他 Object 。

setInput(Object, boolean) - Method in class javax.imageio. ImageReader

设置要用于给定的 ImageInputStream或其他 Object的输入源。

setInput(Object, boolean, boolean) - Method in class javax.imageio. ImageReader

设置要用于给定的 ImageInputStream或其他 Object的输入源。

setInput(Effect) - Method in class javafx.scene.effect. Bloom

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. BoxBlur

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. ColorAdjust

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. DisplacementMap

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. DropShadow

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. GaussianBlur

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. Glow

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. InnerShadow

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. MotionBlur

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. Reflection

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. SepiaTone

设置属性输入的值。

setInput(Effect) - Method in class javafx.scene.effect. Shadow

设置属性输入的值。

setInputMap(int, InputMap) - Method in class javax.swing. JComponent

将 InputMap设置为使用条件 condition至 map 。

setInputMethodContext(InputMethodContext) - Method in interface java.awt.im.spi. InputMethod

设置输入法上下文，用于将输入法事件分派给客户端组件，并从客户端组件请求信息。

setInputMethodRequests(InputMethodRequests) - Method in class javafx.scene. Node

设置属性inputMethodRequests的值。

setInputSource(InputSource) - Method in class javax.xml.transform.sax. SAXSource

设置要用于源的SAX InputSource。

setInputStream(InputStream) - Method in class javax.xml.transform.stream. StreamSource

设置要用作输入的字节流。

setInputValue(Object) - Method in class javax.swing. JOptionPane

设置用户选择或输入的输入值。

setInputVerifier(InputVerifier) - Method in class javax.swing. JComponent

设置此组件的输入验证器。

setInsets(short, short, short, short) - Method in class javax.swing.text. CompositeView

设置视图的插值。

setInstalledLookAndFeels(UIManager.LookAndFeelInfo[]) - Static method in class javax.swing. UIManager

设置一组可用的外观和感觉。

setInstance(LayoutStyle) - Static method in class javax.swing. LayoutStyle

设置共享实例为 LayoutStyle 。

setInstanceFollowRedirects(boolean) - Method in class java.net. HttpURLConnection

设置HTTP重定向（具有响应代码3xx的请求）是否应该由该 HttpURLConnection实例自动跟随。

setInstant(long) - Method in class java.util. Calendar.Builder

设置即时参数给定 instant值是一毫秒的偏移 the Epoch 。

setInstant(Instant) - Method in class java.util.logging. LogRecord

设置事件发生的时刻。

setInstant(Date) - Method in class java.util. Calendar.Builder

设置即时参数设置为instant由给定值Date 。

setInt(int, int) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java int值。

setInt(int, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中的 int 。

setInt(int, int) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java int值。

setInt(Object, int) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 int 。

setInt(Object, int, int) - Static method in class java.lang.reflect. Array

将指定的数组对象的索引组件的值设置为指定的 int值。

setInt(String, int) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java int值。

setInt(String, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java int值。

setInt(String, int) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java int值。

setIntercellSpacing(Dimension) - Method in class javax.swing. JTable

设置 rowMargin和 columnMargin （单元格之间的空间的高度和宽度）为 intercellSpacing 。

setInterface(InetAddress) - Method in class java.net. MulticastSocket

设置由行为受网络接口值影响的方法使用的组播网络接口。

setInternalFrame(JInternalFrame) - Method in class javax.swing. JInternalFrame.JDesktopIcon

设置 JInternalFrame与之相关联的 DesktopIcon 。

setInternalObjectsFilter(MethodHandleTransformer) - Method in class jdk.dynalink. DynamicLinkerFactory

设置一个方法句柄变换器，该 变量应该用作为此工厂创建的动态链接器的链接器服务的实现 LinkerServices.filterInternalObjects(MethodHandle) 。

setInternationalCurrencySymbol(String) - Method in class java.text. DecimalFormatSymbols

设置这些DecimalFormatSymbols的货币的ISO 4217货币代码。

setInterpolator(Interpolator) - Method in class javafx.animation. Transition

设置属性interpolator的值。

setInvalidCharacters(String) - Method in class javax.swing.text. MaskFormatter

允许进一步限制可以输入的字符。

setInverted(boolean) - Method in class javax.swing. JSlider

指定true以反转滑块所显示的值范围，并将false设置为正常顺序的值范围。

setInvoker(Component) - Method in class javax.swing. JPopupMenu

设置此弹出菜单的调用者 - 要显示弹出菜单菜单的组件。

setInvokesStopCellEditing(boolean) - Method in class javax.swing. JTree

确定通过在树中选择另一个节点，树的数据更改或其他方法中断编辑时会发生什么。

setIsMap(boolean) - Method in interface org.w3c.dom.html. HTMLImageElement

setIssuer(byte[]) - Method in class java.security.cert. X509CertSelector

设定发行人标准。

setIssuer(String) - Method in class java.security.cert. X509CertSelector

诋毁 ，使用 X509CertSelector.setIssuer(X500Principal)或者 X509CertSelector.setIssuer(byte[])代替。

setIssuer(X500Principal) - Method in class java.security.cert. X509CertSelector

设定发行人标准。

setIssuerNames(Collection<?>) - Method in class java.security.cert. X509CRLSelector

注意：使用 X509CRLSelector.setIssuers(Collection)或使用此方法时，仅指定专有名称的字节数组形式。

setIssuers(Collection<X500Principal>) - Method in class java.security.cert. X509CRLSelector

设置issuerNames条件。

setItalic(MutableAttributeSet, boolean) - Static method in class javax.swing.text. StyleConstants

设置斜体属性。

setItem(Object) - Method in interface javax.swing. ComboBoxEditor

设置应编辑的项目。

setItem(Object) - Method in class javax.swing.plaf.basic. BasicComboBoxEditor

设置应编辑的项目。

setItem(T) - Method in class javafx.scene.control. Cell

将项目设置为给定的值 - 不应该直接调用该项目由虚拟化控件管理。

setItems(ObservableList<S>) - Method in class javafx.scene.control. TableView

设置属性项的值。

setItems(ObservableList<T>) - Method in class javafx.scene.control. ChoiceBox

设置属性项的值。

setItems(ObservableList<T>) - Method in class javafx.scene.control. ComboBox

设置属性项的值。

setItems(ObservableList<T>) - Method in class javafx.scene.control. ListView

设置ListView的底层数据模型。

setItems(ObservableList<T>) - Method in class javafx.scene.control. SpinnerValueFactory.ListSpinnerValueFactory

设置ListSpinnerValueFactory的底层数据模型。

setIterations(int) - Method in class javafx.scene.effect. BoxBlur

设置属性迭代的值。

setJavaScriptEnabled(boolean) - Method in class javafx.scene.web. WebEngine

设置属性javaScriptEnabled的值。

setJMenuBar(JMenuBar) - Method in class javax.swing. JApplet

已过时。

设置这个applet的菜单。

setJMenuBar(JMenuBar) - Method in class javax.swing. JDialog

设置此对话框的菜单栏。

setJMenuBar(JMenuBar) - Method in class javax.swing. JFrame

设置此帧的菜单栏。

setJMenuBar(JMenuBar) - Method in class javax.swing. JInternalFrame

为此 JInternalFrame设置 menuBar属性。

setJMenuBar(JMenuBar) - Method in class javax.swing. JRootPane

添加或更改分层窗格中使用的菜单栏。

setJNDIContext(Context) - Static method in class javax.sql.rowset.spi. SyncFactory

设置可以从JNDI命名空间中检索SyncProvider实现的初始JNDI上下文

setJobName(String) - Method in class java.awt.print. PrinterJob

设置要打印的文档的名称。

setJobName(String) - Method in class javafx.print. JobSettings

设置工作的名称。

setJoinType(int) - Method in interface javax.sql.rowset. JoinRowSet

允许应用程序调整 JOIN在JoinRowSet对象实例中的表的类型 JOIN 。

setJREInfo(String, String) - Method in interface javax.jnlp. ExtensionInstallerService

通知JNLP客户端JRE的可执行文件的路径，如果这是JRE的安装程序，以及该JRE实现的平台版本。

setJustification(int) - Method in class javax.swing.text. ParagraphView

设置对齐的类型。

setKeepAlive(boolean) - Method in class java.net. Socket

启用/禁用 SO_KEEPALIVE 。

setKeepAliveTime(long, TimeUnit) - Method in class java.util.concurrent. ThreadPoolExecutor

设置线程保持活动时间，这是线程在终止之前可能保持空闲的时间量。

setKeyBindingActive(boolean) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置键绑定活动。

setKeyBindingRegistered(boolean) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置密钥绑定注册。

setKeyChar(char) - Method in class java.awt.event. KeyEvent

设置keyChar值以指示逻辑字符。

setKeyCode(int) - Method in class java.awt.event. KeyEvent

设置keyCode值以指示物理键。

setKeyColumns(int[]) - Method in interface javax.sql.rowset. CachedRowSet

使用给定的列号数组来设置此 CachedRowSet对象的 keyCols字段，这个字段形成了用于唯一标识此 CachedRowSet对象行的键。

setKeyCombination(KeyCombination) - Method in class javafx.scene.input. Mnemonic

设置KeyCombination

setKeyEntry(String, byte[], Certificate[]) - Method in class java.security. KeyStore

将给定的密钥（已经被保护）分配给给定的别名。

setKeyEntry(String, Key, char[], Certificate[]) - Method in class java.security. KeyStore

将给定的密钥分配给给定的别名，并使用给定的密码进行保护。

setKeymap(Keymap) - Method in class javax.swing.text. JTextComponent

设置用于将事件绑定到操作的键盘映射。

setKeyPair(KeyPair) - Method in class java.security. Signer

已过时。

设置此签名者的密钥对（公钥和私钥）。

setKeySelectionManager(JComboBox.KeySelectionManager) - Method in class javax.swing. JComboBox

设置将键盘字符转换为列表选择的对象。

setKeySelector(KeySelector) - Method in class javax.xml.crypto.dom. DOMCryptoContext

setKeySelector(KeySelector) - Method in interface javax.xml.crypto. XMLCryptoContext

设置用于查找键的键选择器。

setKeyUsage(boolean[]) - Method in class java.security.cert. X509CertSelector

设置keyUsage标准。

setLabel(String) - Method in class java.awt. Button

将按钮的标签设置为指定的字符串。

setLabel(String) - Method in class java.awt. Checkbox

将此复选框的标签设置为字符串参数。

setLabel(String) - Method in class java.awt. MenuItem

将此菜单项的标签设置为指定的标签。

setLabel(String) - Method in class javafx.scene.chart. Axis

设置属性标签的值。

setLabel(String) - Method in class javafx.scene.chart. Axis.TickMark

设置属性标签的值。

setLabel(String) - Method in class javax.swing. AbstractButton

已过时。
- 替换为setText(text)

setLabel(String) - Method in class javax.swing. JPopupMenu

设置弹出菜单的标签。

setLabel(String) - Method in class javax.swing.text.html. Option

设置要用于该选项的标签。

setLabel(String) - Method in interface org.w3c.dom.html. HTMLOptGroupElement

setLabel(String) - Method in interface org.w3c.dom.html. HTMLOptionElement

setLabelFor(Component) - Method in class javax.swing. JLabel

设置标签的组件。

setLabelFor(Node) - Method in class javafx.scene.control. Label

设置属性labelFor的值。

setLabelFormatter(StringConverter<Double>) - Method in class javafx.scene.control. Slider

设置属性labelFormatter的值。

setLabelLineLength(double) - Method in class javafx.scene.chart. PieChart

设置属性labelLineLength的值。

setLabelsVisible(boolean) - Method in class javafx.scene.chart. PieChart

设置属性labelsVisible的值。

setLabelTable(Dictionary) - Method in class javax.swing. JSlider

用于指定在任何给定值下绘制什么标签。

setLang(String) - Method in interface org.w3c.dom.html. HTMLElement

setLanguage(String) - Method in class java.util. Locale.Builder

设置语言。

setLanguageTag(String) - Method in class java.util. Locale.Builder

重置生成器以匹配提供的IETF BCP 47语言标记。

setLargeArcFlag(boolean) - Method in class javafx.scene.shape. ArcTo

设置属性largeArcFlag的值。

setLargeMaxRows(long) - Method in interface java.sql. Statement

设置由此 ResultSet对象生成的 Statement对象可以包含给给定数量的最大行数的限制。

setLargeModel(boolean) - Method in class javax.swing. JTree

指定UI是否应该使用大型模型。

setLargeModel(boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI

如果需要，更新componentListener。

setLastAccessTime(FileTime) - Method in class java.util.zip. ZipEntry

设置条目的最后访问时间。

setLastDividerLocation(int) - Method in class javax.swing. JSplitPane

设置分隔符的最后一个位置为 newLastLocation 。

setLastDragLocation(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

设置 JSplitPane的最后一个拖动位置。

setLastModified(long) - Method in class java.io. File

设置由此抽象路径名命名的文件或目录的最后修改时间。

setLastModifiedTime(FileTime) - Method in class java.util.zip. ZipEntry

设置条目的最后修改时间。

setLastModifiedTime(Path, FileTime) - Static method in class java.nio.file. Files

更新文件上次修改的时间属性。

setLayer(int) - Method in class javax.swing. JInternalFrame

设置此组件的图层属性的便利方法。

setLayer(Component, int) - Method in class javax.swing. JLayeredPane

设置指定组件上的图层属性，使其成为该图层中最底层的组件。

setLayer(Component, int, int) - Method in class javax.swing. JLayeredPane

设置指定组件的层属性，并设置其在该层中的位置。

setLayer(Integer) - Method in class javax.swing. JInternalFrame

设置此组件的图层属性的便利方法。

setLayeredPane(JLayeredPane) - Method in class javax.swing. JApplet

已过时。

设置layeredPane属性。

setLayeredPane(JLayeredPane) - Method in class javax.swing. JDialog

设置 layeredPane属性。

setLayeredPane(JLayeredPane) - Method in class javax.swing. JFrame

设置 layeredPane属性。

setLayeredPane(JLayeredPane) - Method in class javax.swing. JInternalFrame

设置这个 JInternalFrame的 layeredPane属性。

setLayeredPane(JLayeredPane) - Method in class javax.swing. JRootPane

设置根窗格的分层窗格。

setLayeredPane(JLayeredPane) - Method in class javax.swing. JWindow

设置 layeredPane属性。

setLayeredPane(JLayeredPane) - Method in interface javax.swing. RootPaneContainer

管理contentPane的容器，在某些情况下是一个菜单栏。

setLayerEventMask(long) - Method in class javax.swing. JLayer

启用来自JLayer的事件 及其由指定的事件掩码参数定义的 所有后代 ，以传递给 LayerUI.eventDispatched(AWTEvent, JLayer)方法。

setLayout(LayoutManager) - Method in class java.awt. Container

设置此容器的布局管理器。

setLayout(LayoutManager) - Method in class java.awt. ScrollPane

设置此容器的布局管理器。

setLayout(LayoutManager) - Method in class javax.swing. AbstractButton

设置此容器的布局管理器，有关此方法的完整说明，请参阅 Container.setLayout(LayoutManager) 。

setLayout(LayoutManager) - Method in class javax.swing. Box

抛出AWTError，因为Box只能使用BoxLayout。

setLayout(LayoutManager) - Method in class javax.swing. JApplet

已过时。

设置 LayoutManager 。

setLayout(LayoutManager) - Method in class javax.swing. JDialog

设置 LayoutManager 。

setLayout(LayoutManager) - Method in class javax.swing. JFrame

设置 LayoutManager 。

setLayout(LayoutManager) - Method in class javax.swing. JInternalFrame

确保默认情况下，无法设置此组件的布局。

setLayout(LayoutManager) - Method in class javax.swing. JLayer

设置此容器的布局管理器。

setLayout(LayoutManager) - Method in class javax.swing. JScrollPane

设置这个 JScrollPane的布局管理器。

setLayout(LayoutManager) - Method in class javax.swing. JToolBar

setLayout(LayoutManager) - Method in class javax.swing. JWindow

设置 LayoutManager 。

setLayoutOrientation(int) - Method in class javax.swing. JList

定义列表单元格的布局方式。

setLayoutStyle(LayoutStyle) - Method in class javax.swing. GroupLayout

设置用于计算组件之间的首选间隙的 LayoutStyle 。

setLayoutX(double) - Method in class javafx.scene. Node

设置属性layoutX的值。

setLayoutY(double) - Method in class javafx.scene. Node

设置属性layoutY的值。

setLeadAnchorNotificationEnabled(boolean) - Method in class javax.swing. DefaultListSelectionModel

设置leadAnchorNotificationEnabled标志的值。

setLeadSelectionIndex(int) - Method in class javax.swing. DefaultListSelectionModel

设置引导选择索引，确保锚和新引线之间的值全部被选中或全部被取消选择。

setLeadSelectionIndex(int) - Method in interface javax.swing. ListSelectionModel

设置主导选择指标。

setLeadSelectionPath(TreePath) - Method in class javax.swing. JTree

将路径标识为引导。

setLeafIcon(Icon) - Method in class javax.swing.tree. DefaultTreeCellRenderer

设置用于表示叶节点的图标。

setLeft(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的左侧属性定义。

setLeft(Node) - Method in class javafx.scene.layout. BorderPane

设置剩余属性的值。

setLeftAnchor(Node, Double) - Static method in class javafx.scene.layout. AnchorPane

设置锚定窗格所包含的小孩的左侧锚点。

setLeftChildIndent(int) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置左子缩进。

setLeftComponent(Component) - Method in class javax.swing. JSplitPane

将组件设置在左边（或更高）分隔线。

setLeftIndent(MutableAttributeSet, float) - Static method in class javax.swing.text. StyleConstants

设置左缩进

setLeftInset(float) - Method in class javax.swing.text. AsyncBoxView

设置边缘左边的视图。

setLegend(Node) - Method in class javafx.scene.chart. Chart

设置属性图例的值。

setLegendSide(Side) - Method in class javafx.scene.chart. Chart

设置属性legendSide的值。

setLegendVisible(boolean) - Method in class javafx.scene.chart. Chart

设置属性legendVisible的值。

setLength(double) - Method in class javafx.scene.shape. Arc

设置属性长度的值。

setLength(int) - Method in class java.lang. StringBuffer

setLength(int) - Method in class java.net. DatagramPacket

设置此数据包的长度。

setLength(int) - Method in class javax.imageio.stream. IIOByteBuffer

更新后续调用 getLength方法返回的值。

setLength(long) - Method in class java.io. RandomAccessFile

设置此文件的长度。

setLength(long) - Method in interface javax.jnlp. JNLPRandomAccessFile

设置此文件的长度。

setLenient(boolean) - Method in class java.text. DateFormat

指定日期/时间解析是否宽松。

setLenient(boolean) - Method in class java.util. Calendar.Builder

将宽松模式参数设置为由 lenient给出的值。

setLenient(boolean) - Method in class java.util. Calendar

指定日期/时间解释是否宽松。

setLetterSpacing(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的letter-spacing属性定义。

setLevel(double) - Method in class javafx.scene.effect. Glow

设置属性级别的值。

setLevel(double) - Method in class javafx.scene.effect. SepiaTone

设置属性级别的值。

setLevel(int) - Method in class java.util.zip. Deflater

将压缩级别设置为指定的值。

setLevel(int) - Method in class java.util.zip. ZipOutputStream

设置DEFLATED的后续条目的压缩级别。

setLevel(Level) - Method in class java.util.logging. Handler

设置日志级别，指定 Handler记录哪些消息级别。

setLevel(Level) - Method in class java.util.logging. Logger

设置日志级别，指定该记录器将记录哪些消息级别。

setLevel(Level) - Method in class java.util.logging. LogRecord

设置日志消息级别，例如Level.SEVERE。

setLexicalHandler(LexicalHandler) - Method in class javax.xml.transform.sax. SAXResult

为输出设置SAX2 LexicalHandler 。

setLibraryDirectory(String) - Method in class javax.management.loading. MLet

设置用于存储本机库的库加载器使用的目录，然后将其加载到内存中。

setLibraryDirectory(String) - Method in interface javax.management.loading. MLetMBean

设置用于存储本机库的库加载器使用的目录，然后将其加载到内存中。

setLight(Light) - Method in class javafx.scene.effect. Lighting

设置属性灯的值。

setLightOn(boolean) - Method in class javafx.scene. LightBase

设置属性lightOn的值。

setLightWeightPopupEnabled(boolean) - Method in class javax.swing. JComboBox

设置 lightWeightPopupEnabled属性，其中提供了一个提示是否应使用轻量级 Component来包含 JComboBox ，而重量级 Component （如 Panel或 Window 。

setLightWeightPopupEnabled(boolean) - Method in class javax.swing. JPopupMenu

设置 lightWeightPopupEnabled属性的值，默认值为 true 。

setLightWeightPopupEnabled(boolean) - Method in class javax.swing. ToolTipManager

当显示 JToolTip ， ToolTipManager选择使用轻巧的 JPanel如果它适合。

setLimit(int) - Method in class javax.swing.undo. UndoManager

设置 UndoManager保留的最大编辑次数。

setLine(double, double, double, double) - Method in class java.awt.geom. Line2D.Double

将此 Line2D的终点的位置设置为指定的双坐标。

setLine(double, double, double, double) - Method in class java.awt.geom. Line2D.Float

将此 Line2D的终点的位置设置为指定的双坐标。

setLine(double, double, double, double) - Method in class java.awt.geom. Line2D

将此 Line2D的终点的位置设置为指定的双坐标。

setLine(float, float, float, float) - Method in class java.awt.geom. Line2D.Float

将此 Line2D的终点的位置设置为指定的浮点坐标。

setLine(Line2D) - Method in class java.awt.geom. Line2D

将此 Line2D的终点的位置设置为与指定的 Line2D终点相同。

setLine(Point2D, Point2D) - Method in class java.awt.geom. Line2D

将此 Line2D的终点位置设置为指定的 Point2D坐标。

setLineCap(StrokeLineCap) - Method in class javafx.scene.canvas. GraphicsContext

设置当前行程行上限。

setLineDashes(double...) - Method in class javafx.scene.canvas. GraphicsContext

将当前笔划线划线模式设置为参数的归一化副本。

setLineDashOffset(double) - Method in class javafx.scene.canvas. GraphicsContext

设置线破折号偏移。

setLineHeight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的line-height属性定义。

setLineIncrement(int) - Method in class java.awt. Scrollbar

已过时。
从JDK 1.1版开始，由setUnitIncrement(int)替代。

setLineJoin(StrokeLineJoin) - Method in class javafx.scene.canvas. GraphicsContext

设置当前笔画行连接。

setLineLength(int) - Method in class javax.swing.text. AbstractWriter

启用子类来设置每行要写入的字符数。

setLineNumber(int) - Method in class java.io. LineNumberInputStream

已过时。

将行号设置为指定的参数。

setLineNumber(int) - Method in class java.io. LineNumberReader

设置当前行号。

setLineNumber(int) - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

在此事件定位器上设置lineNumber字段。

setLineNumber(int) - Method in exception jdk.nashorn.api.scripting. NashornException

设置这个 NashornException的行号

setLineNumber(int) - Method in class org.xml.sax.helpers. LocatorImpl

设置此定位器的行号（基于1）。

setLineSeparator(String) - Method in class javax.swing.text. AbstractWriter

设置用于表示换行符的字符串。

setLineSpacing(double) - Method in class javafx.scene.control. Labeled

设置属性lineSpacing的值。

setLineSpacing(double) - Method in class javafx.scene.text. Text

设置属性lineSpacing的值。

setLineSpacing(double) - Method in class javafx.scene.text. TextFlow

设置属性lineSpacing的值。

setLineSpacing(float) - Method in class javax.swing.text. ParagraphView

设置行距。

setLineSpacing(MutableAttributeSet, float) - Static method in class javax.swing.text. StyleConstants

设置行距。

setLineWidth(double) - Method in class javafx.scene.canvas. GraphicsContext

设置当前行宽。

setLineWrap(boolean) - Method in class javax.swing. JTextArea

设置文本区域的换行策略。

setLink(String) - Method in interface org.w3c.dom.html. HTMLBodyElement

setLinkCursor(Cursor) - Method in class javax.swing.text.html. HTMLEditorKit

将光标设置为使用链接。

setLinkedException(Throwable) - Method in class javax.xml.bind.helpers. ValidationEventImpl

设置此事件的链接异常字段。

setLinkedException(Throwable) - Method in exception javax.xml.bind. JAXBException

添加链接异常。

setLinkedException(Throwable) - Method in exception javax.xml.bind. TypeConstraintException

添加链接异常。

setLinkExplanation(String) - Method in exception javax.naming. LinkException

设置解决链接时遇到的问题的解释。

setLinkRemainingName(Name) - Method in exception javax.naming. LinkException

设置此异常的剩余链接名称字段。

setLinkResolvedName(Name) - Method in exception javax.naming. LinkException

设置此异常的解决的链接名称字段。

setLinkResolvedObj(Object) - Method in exception javax.naming. LinkException

设置此异常的链接解析对象字段。

setList(List<?>) - Method in class javax.swing. SpinnerListModel

更改定义此序列的列表，并将模型 value的索引重置为零。

setListData(E[]) - Method in class javax.swing. JList

从一系列项目构造一个只读的 ListModel ，并使用此模型调用 setModel 。

setListData(Vector<? extends E>) - Method in class javax.swing. JList

从 Vector构造只读 ListModel ，并使用此型号调用 setModel 。

setListener(Marshaller.Listener) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

setListener(Marshaller.Listener) - Method in interface javax.xml.bind. Marshaller

注册编组事件回调Marshaller.Listener这个Marshaller 。

setListener(Unmarshaller.Listener) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

setListener(Unmarshaller.Listener) - Method in interface javax.xml.bind. Unmarshaller

注册unmarshal事件回调Unmarshaller.Listener与这Unmarshaller 。

setListStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style属性定义。

setListStyleImage(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style-image属性定义。

setListStylePosition(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style-position属性定义。

setListStyleType(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的list-style-type属性定义。

setLlx(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性llx的值。

setLly(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性lly的值。

setLoadListener(LoadListener) - Method in class javafx.fxml. FXMLLoader

设置此加载器的负载侦听器。

setLoadsSynchronously(boolean) - Method in class javax.swing.text.html. ImageView

设置图像的加载方式。

setLocale(Locale) - Method in class java.awt. Component

设置此组件的区域设置。

setLocale(Locale) - Method in interface java.awt.im.spi. InputMethod

尝试设置输入区域设置。

setLocale(Locale) - Method in class java.beans.beancontext. BeanContextSupport

设置此BeanContext的区域设置。

setLocale(Locale) - Method in class java.text. MessageFormat

设置创建或比较子格式时要使用的区域设置。

setLocale(Locale) - Method in class java.util. Calendar.Builder

将locale参数设置为给定的 locale 。

setLocale(Locale) - Method in class java.util. Locale.Builder

重置 Builder以匹配提供的 locale 。

setLocale(Locale) - Method in class javax.imageio. ImageReader

将此 ImageReader的当前 Locale设置为给定值。

setLocale(Locale) - Method in class javax.imageio. ImageWriter

将此 ImageWriter的当前 Locale设置为给定值。

setLocale(Locale) - Method in class javax.security.auth.callback. LanguageCallback

设置检索到的 Locale 。

setLocale(Locale) - Method in interface javax.tools. DocumentationTool.DocumentationTask

设置在格式化诊断和其他本地化数据时应用的区域设置。

setLocale(Locale) - Method in interface javax.tools. JavaCompiler.CompilationTask

设置在格式化诊断和其他本地化数据时应用的区域设置。

setLocale(Locale) - Method in class org.xml.sax.helpers. XMLReaderAdapter

设置错误报告的区域设置。

setLocale(Locale) - Method in interface org.xml.sax. Parser

已过时。

允许应用程序请求区域设置错误和警告。

setLocalName(int, String) - Method in class org.xml.sax.helpers. AttributesImpl

设置特定属性的本地名称。

setLocalPatternChars(String) - Method in class java.text. DateFormatSymbols

设置本地化的日期时间模式字符。

setLocation(double, double) - Method in class java.awt.geom. Point2D.Double

将此 Point2D的位置设置为指定的 double坐标。

setLocation(double, double) - Method in class java.awt.geom. Point2D.Float

将此 Point2D的位置设置为指定的 double坐标。

setLocation(double, double) - Method in class java.awt.geom. Point2D

将此 Point2D的位置设置为指定的 double坐标。

setLocation(double, double) - Method in class java.awt. Point

将此点的位置设置为指定的双坐标。

setLocation(float, float) - Method in class java.awt.geom. Point2D.Float

将此 Point2D的位置设置为指定的 float坐标。

setLocation(int, int) - Method in class java.awt. Component

将此组件移动到新位置。

setLocation(int, int) - Method in class java.awt. Point

更改要具有指定位置的点。

setLocation(int, int) - Method in class java.awt. Rectangle

将此 Rectangle移动到指定的位置。

setLocation(int, int) - Method in class java.awt. Window

将此组件移动到新位置。

setLocation(int, int) - Method in class javax.swing. JPopupMenu

使用x，y坐标设置弹出菜单左上角的位置。

setLocation(Point2D) - Method in class java.awt.geom. Point2D

将此 Point2D的位置设置为与指定的 Point2D对象相同的坐标。

setLocation(Point) - Method in class com.sun.java.accessibility.util. Translator

设置对象相对于父对象的位置。

setLocation(Point) - Method in class java.awt. Component.AccessibleAWTComponent

设置对象相对于父对象的位置。

setLocation(Point) - Method in class java.awt. Component

将此组件移动到新位置。

setLocation(Point) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

设置对象相对于父对象的位置。

setLocation(Point) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

设置对象相对于父对象的位置。

setLocation(Point) - Method in class java.awt. Point

将点的位置设置为指定的位置。

setLocation(Point) - Method in class java.awt. Rectangle

将此 Rectangle移动到指定的位置。

setLocation(Point) - Method in class java.awt. Window

将此组件移动到新位置。

setLocation(Point) - Method in interface javax.accessibility. AccessibleComponent

设置对象相对于父对象的位置。

setLocation(Point) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setLocation(Point) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置对象相对于父对象的位置。

setLocation(Point) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setLocation(Point) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setLocation(URL) - Method in class javafx.fxml. FXMLLoader

设置用于解析相对路径属性值的位置。

setLocation(JavaFileManager.Location, Iterable<? extends File>) - Method in interface javax.tools. StandardJavaFileManager

将给定的搜索路径与给定位置相关联。

setLocation(Location) - Method in class javax.xml.stream. XMLEventFactory

该方法允许在由此工厂创建的每个事件上设置位置。

setLocationByPlatform(boolean) - Method in class java.awt. Window

设置此窗口是否应显示在本机窗口系统的默认位置或当前位置（由 getLocation返回）下一次窗口可见时。

setLocationForModule(JavaFileManager.Location, String, Collection<? extends Path>) - Method in interface javax.tools. StandardJavaFileManager

将给定的搜索路径与给定的模块和位置相关联，该模块和位置必须是面向模块或输出位置。

setLocationFromPaths(JavaFileManager.Location, Collection<? extends Path>) - Method in interface javax.tools. StandardJavaFileManager

将给定的搜索路径与给定位置相关联。

setLocationRelativeTo(Component) - Method in class java.awt. Window

根据以下情况设置窗口相对于指定组件的位置。

setLocator(ValidationEventLocator) - Method in class javax.xml.bind.helpers. ValidationEventImpl

设置此事件的定位器对象。

setLocator(SourceLocator) - Method in exception javax.xml.transform. TransformerException

方法setLocator设置一个SourceLocator对象的实例，该对象指定发生错误的位置。

setLockingKeyState(int, boolean) - Method in class java.awt. Toolkit

设置键盘上给定锁定键的状态。

setLog(OutputStream) - Static method in class java.rmi.server. RemoteServer

将RMI调用记录到输出流 out 。

setLogger(Logger) - Static method in class javax.sql.rowset.spi. SyncFactory

设置由所使用的日志对象 SyncProvider由提供的实现 SyncFactory 。

setLogger(Logger, Level) - Static method in class javax.sql.rowset.spi. SyncFactory

设置由 SyncFactory SPI提供的 SyncProvider实现使用的记录对象。

setLoggerLevel(String, String) - Method in interface java.lang.management. PlatformLoggingMXBean

将指定的记录器设置为指定的新的 level 。

setLoggerLevel(String, String) - Method in interface java.util.logging. LoggingMXBean

已过时。

将指定的记录器设置为指定的新级别。

setLoggerName(String) - Method in class java.util.logging. LogRecord

设置源记录器的名称。

setLogicalStyle(int, Style) - Method in class javax.swing.text. DefaultStyledDocument

设置用于给定位置的段落的逻辑样式。

setLogicalStyle(int, Style) - Method in interface javax.swing.text. StyledDocument

设置用于给定位置的段落的逻辑样式。

setLogicalStyle(Style) - Method in class javax.swing. JTextPane

设置用于当前插入符位置的段落的逻辑样式。

setLoginTimeout(int) - Static method in class java.sql. DriverManager

设置驱动程序在识别驱动程序后尝试连接到数据库时等待的最长时间（秒）。

setLoginTimeout(int) - Method in interface javax.sql. CommonDataSource

设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。

setLoginTimeout(int) - Method in interface javax.sql. ConnectionPoolDataSource

设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。

setLoginTimeout(int) - Method in interface javax.sql. DataSource

设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。

setLoginTimeout(int) - Method in interface javax.sql. XADataSource

设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。

setLogStream(PrintStream) - Static method in class java.sql. DriverManager

已过时。
使用setLogWriter

setLogStream(PrintStream) - Static method in class javax.swing. DebugGraphics

设置DebugGraphics记录绘图操作的流。

setLogTimers(boolean) - Static method in class javax.swing. Timer

启用或禁用定时器日志。

setLogWriter(PrintWriter) - Static method in class java.sql. DriverManager

设置 DriverManager和所有驱动程序使用的日志/跟踪 PrintWriter对象。

setLogWriter(PrintWriter) - Method in interface javax.sql. CommonDataSource

将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。

setLogWriter(PrintWriter) - Method in interface javax.sql. ConnectionPoolDataSource

将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。

setLogWriter(PrintWriter) - Method in interface javax.sql. DataSource

将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。

setLogWriter(PrintWriter) - Method in interface javax.sql. XADataSource

将此 DataSource对象的日志记录器设置为给定的 java.io.PrintWriter对象。

setLong(int, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java long值。

setLong(int, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中给定的 long 。

setLong(int, long) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java long值。

setLong(Object, int, long) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的 long值。

setLong(Object, long) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 long 。

setLong(String, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java long值。

setLong(String, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java long值。

setLong(String, long) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java long值。

setLongDesc(String) - Method in interface org.w3c.dom.html. HTMLFrameElement

setLongDesc(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setLongDesc(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setLookAndFeel(String) - Static method in class javax.swing. UIManager

使用当前线程的上下文类加载器加载由给定类名指定的 LookAndFeel ，并将其传递给 setLookAndFeel(LookAndFeel) 。

setLookAndFeel(LookAndFeel) - Static method in class javax.swing. UIManager

将当前的外观设置为 newLookAndFeel 。

setLoopbackMode(boolean) - Method in class java.net. MulticastSocket

禁用/启用组播数据报的本地环回该选项由平台的网络代码用作设置组播数据是否将环回到本地套接字的提示。

setLoopCount(int) - Method in interface javax.sound.midi. Sequencer

设置循环播放次数。

setLoopEndPoint(long) - Method in interface javax.sound.midi. Sequencer

设置将在循环中播放的最后一个MIDI刻度。

setLoopPoints(int, int) - Method in interface javax.sound.sampled. Clip

设置将在循环中播放的第一个和最后一个采样帧。

setLoopStartPoint(long) - Method in interface javax.sound.midi. Sequencer

设置将在循环中播放的第一个MIDI刻度。

setLowerBound(double) - Method in class javafx.scene.chart. ValueAxis

设置属性lowerBound的值。

setLowSrc(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setLrx(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性lrx的值。

setLry(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性lry的值。

setMagicCaretPosition(Point) - Method in interface javax.swing.text. Caret

设置当前插入符的视觉位置。

setMagicCaretPosition(Point) - Method in class javax.swing.text. DefaultCaret

保存当前插入位置。

setMajorOffset(float) - Method in class javax.swing.text. AsyncBoxView.ChildState

该方法只能由ChildLocator调用，它只是一个方便的地方来保存缓存的位置。

setMajorTickSpacing(int) - Method in class javax.swing. JSlider

此方法设置主要的刻度间距。

setMajorTickUnit(double) - Method in class javafx.scene.control. Slider

设置属性majorTickUnit的值。

setManaged(boolean) - Method in class javafx.scene. Node

设置管理的属性的值。

setManagedResource(Object, String) - Method in interface javax.management.modelmbean. ModelMBean

设置要在此ModelMBean管理界面（MBeanInfo和Descriptors）中执行所有方法的对象的实例句柄。

setManagedResource(Object, String) - Method in class javax.management.modelmbean. RequiredModelMBean

设置要在此ModelMBean管理界面（MBeanInfo和Descriptors）中执行所有方法的对象的实例句柄。

setMapData(FloatMap) - Method in class javafx.scene.effect. DisplacementMap

设置属性mapData的值。

setMargin(Insets) - Method in class javax.swing. AbstractButton

在按钮的边框和标签之间设置边距空间。

setMargin(Insets) - Method in class javax.swing. JMenuBar

设置菜单边界和菜单之间的边距。

setMargin(Insets) - Method in class javax.swing. JToolBar

X- 200 X- 200 200 X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X-

setMargin(Insets) - Method in class javax.swing.text. JTextComponent

在文本组件的边框和文本之间设置边距空间。

setMargin(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin属性定义。

setMargin(Node, Insets) - Static method in class javafx.scene.layout. BorderPane

设置由边框窗格包含的小孩的边距。

setMargin(Node, Insets) - Static method in class javafx.scene.layout. FlowPane

设置一个flowpane包含的孩子的边距。

setMargin(Node, Insets) - Static method in class javafx.scene.layout. GridPane

设置子窗格包含的格子的边距。

setMargin(Node, Insets) - Static method in class javafx.scene.layout. HBox

设置hbox包含的小孩的边距。

setMargin(Node, Insets) - Static method in class javafx.scene.layout. StackPane

设置一个堆栈包含的小孩的边距。

setMargin(Node, Insets) - Static method in class javafx.scene.layout. TilePane

设置小孩的边框，当包含一个瓦楞纸板时。

setMargin(Node, Insets) - Static method in class javafx.scene.layout. VBox

设置由vbox包含的小孩的边距。

setMarginBottom(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-bottom属性定义。

setMarginHeight(String) - Method in interface org.w3c.dom.html. HTMLFrameElement

setMarginHeight(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setMarginLeft(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-left属性定义。

setMarginRight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-right属性定义。

setMarginTop(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的margin-top属性定义。

setMarginWidth(String) - Method in interface org.w3c.dom.html. HTMLFrameElement

setMarginWidth(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setMarkerOffset(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的marker-offset属性定义。

setMarks(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的标记属性定义。

setMask(String) - Method in class javax.swing.text. MaskFormatter

设置掩码规定合法字符。

setMasterSyncMode(Sequencer.SyncMode) - Method in interface javax.sound.midi. Sequencer

设置此音序器使用的定时信息的来源。

setMatchAllSubjectAltNames(boolean) - Method in class java.security.cert. X509CertSelector

启用/禁用匹配 setSubjectAlternativeNames或 addSubjectAlternativeName方法中指定的所有 subjectAlternativeNames 。

setMatchColumn(int) - Method in interface javax.sql.rowset. Joinable

将指定列设置为此 RowSet对象的匹配列。

setMatchColumn(int[]) - Method in interface javax.sql.rowset. Joinable

将指定列设置为此 RowSet对象的匹配列。

setMatchColumn(String) - Method in interface javax.sql.rowset. Joinable

将指定列设置为此 RowSet对象的匹配列。

setMatchColumn(String[]) - Method in interface javax.sql.rowset. Joinable

将指定的列设置为此 RowSet对象的匹配列。

setMaterial(Material) - Method in class javafx.scene.shape. Shape3D

设置属性材质的值。

setMax(double) - Method in class javafx.scene.control. ScrollBar

设置属性max的值。

setMax(double) - Method in class javafx.scene.control. Slider

设置属性max的值。

setMax(double) - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory

设置属性max的值。

setMax(int) - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

设置属性max的值。

setMaxAge(long) - Method in class java.net. HttpCookie

设置cookie的最大年龄（秒）。

setMaxCRLNumber(BigInteger) - Method in class java.security.cert. X509CRLSelector

设置maxCRLNumber标准。

setMaxFieldSize(int) - Method in interface java.sql. Statement

ResultSet对象生成的 Statement对象中的字符和二进制列值的最大字节数设置限制。

setMaxFieldSize(int) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象中的列值的最大字节数设置为给定的数字。

setMaxFieldSize(int) - Method in interface javax.sql. RowSet

将列值返回的最大字节数设置为给定的字节数。

setMaxHeight(double) - Method in class javafx.scene.control. PopupControl

覆盖控制计算最大高度的属性。

setMaxHeight(double) - Method in class javafx.scene.layout. Region

设置属性maxHeight的值。

setMaxHeight(double) - Method in class javafx.scene.layout. RowConstraints

设置属性maxHeight的值。

setMaxHeight(double) - Method in class javafx.scene.web. WebView

设置属性maxHeight的值。

setMaxHeight(double) - Method in class javafx.stage. Stage

设置属性maxHeight的值。

setMaxHeight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的max-height属性定义。

setMaximizable(boolean) - Method in class javax.swing. JInternalFrame

设置 maximizable属性，它决定是否可以通过某些用户操作最大化 JInternalFrame 。

setMaximized(boolean) - Method in class javafx.stage. Stage

设置最大化的属性的值。

setMaximizedBounds(Rectangle) - Method in class java.awt. Frame

设置此框架的最大化边界。

setMaximum(boolean) - Method in class javax.swing. JInternalFrame

最大化和恢复这个内部框架。

setMaximum(int) - Method in interface java.awt. Adjustable

设置可调整对象的最大值。

setMaximum(int) - Method in class java.awt. Scrollbar

设置此滚动条的最大值。

setMaximum(int) - Method in class java.awt. ScrollPaneAdjustable

此方法 不应由用户代码调用。

setMaximum(int) - Method in interface javax.swing. BoundedRangeModel

将模型的最大值设置为 newMaximum 。

setMaximum(int) - Method in class javax.swing. DefaultBoundedRangeModel

在确定 n其他三个属性遵守模型的约束之后，将最大值设置为 n ：

setMaximum(int) - Method in class javax.swing. JProgressBar

将进度条的最大值（存储在进度条的数据模型中）设置为 n 。

setMaximum(int) - Method in class javax.swing. JScrollBar

设置模型的最大属性。

setMaximum(int) - Method in class javax.swing. JSlider

将滑块的最大值设置为 maximum 。

setMaximum(int) - Method in class javax.swing. ProgressMonitor

指定最大值。

setMaximum(Comparable<?>) - Method in class javax.swing. SpinnerNumberModel

更改此序列中数字的上限。

setMaximum(Comparable<?>) - Method in class javax.swing.text. InternationalFormatter

设置最大允许值。

setMaximumCumulativePeriod(Duration) - Method in class javafx.concurrent. ScheduledService

设置属性maximumCumulativePeriod的值。

setMaximumFailureCount(int) - Method in class javafx.concurrent. ScheduledService

设置属性maximumFailureCount的值。

setMaximumFractionDigits(int) - Method in class java.text. DecimalFormat

设置数字小数部分允许的最大位数。

setMaximumFractionDigits(int) - Method in class java.text. NumberFormat

设置数字小数部分允许的最大位数。 maximumFractionDigits必须为〜最小FractionDigits。

setMaximumIntegerDigits(int) - Method in class java.text. DecimalFormat

设置数字的整数部分允许的最大位数。

setMaximumIntegerDigits(int) - Method in class java.text. NumberFormat

设置数字的整数部分允许的最大位数。 maximumIntegerDigits必须为≤最小值。

setMaximumPacketSize(int) - Method in class javax.net.ssl. SSLParameters

设置SSL / TLS / DTLS记录的最大预期网络数据包大小（以字节为单位）。

setMaximumPoolSize(int) - Method in class java.util.concurrent. ThreadPoolExecutor

设置允许的最大线程数。

setMaximumRowCount(int) - Method in class javax.swing. JComboBox

设置 JComboBox显示的最大行数。

setMaximumSize(Dimension) - Method in class java.awt. Component

将此组件的最大大小设置为常量值。

setMaximumSize(Dimension) - Method in class javax.swing. JComponent

将此组件的最大大小设置为常量值。

setMaximumZoneSize(int) - Method in class javax.swing.text. ZoneView

设置所需的最大区域大小。

setMaxLength(int) - Method in interface org.w3c.dom.html. HTMLInputElement

setMaxLength(long) - Method in interface javax.jnlp. FileContents

设置文件的最大文件长度。

setMaxPage(int) - Method in class java.awt. JobAttributes

指定用户可以指定的最大值作为使用这些属性的作业打印的最后一页。

setMaxPageIndicatorCount(int) - Method in class javafx.scene.control. Pagination

设置页面指示器的最大数量。

setMaxPathLength(int) - Method in class java.security.cert. PKIXBuilderParameters

设置认证路径中可能存在的非自发中间证书的最大数量的值。

setMaxPriority(int) - Method in class java.lang. ThreadGroup

设置组的最大优先级。

setMaxRows(int) - Method in interface java.sql. Statement

设置的任何行的最大数目的极限 ResultSet由此生成的对象 Statement对象可以包含给定数目。

setMaxRows(int) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的最大行数设置为给定的数字。

setMaxRows(int) - Method in interface javax.sql. RowSet

将此 RowSet对象的最大行数设置为指定的数字。

setMaxSize(double, double) - Method in class javafx.scene.control. PopupControl

用于覆盖控件计算的最大宽度和高度的便捷方法。

setMaxSize(double, double) - Method in class javafx.scene.layout. Region

覆盖区域计算的最大宽度和高度的便捷方法。

setMaxSize(double, double) - Method in class javafx.scene.web. WebView

设置最大宽度和高度的便利方法。

setMaxSize(int) - Method in class javafx.scene.web. WebHistory

设置属性maxSize的值。

setMaxSortKeys(int) - Method in class javax.swing. DefaultRowSorter

设置最大排序键数。

setMaxWidth(double) - Method in class javafx.scene.control. PopupControl

覆盖控件计算出的最大宽度的属性。

setMaxWidth(double) - Method in class javafx.scene.control. TableColumnBase

设置属性maxWidth的值。

setMaxWidth(double) - Method in class javafx.scene.layout. ColumnConstraints

设置属性maxWidth的值。

setMaxWidth(double) - Method in class javafx.scene.layout. Region

设置属性maxWidth的值。

setMaxWidth(double) - Method in class javafx.scene.web. WebView

设置属性maxWidth的值。

setMaxWidth(double) - Method in class javafx.stage. Stage

设置属性maxWidth的值。

setMaxWidth(int) - Method in class javax.swing.table. TableColumn

将 TableColumn的最大宽度设置为 maxWidth或者如果 maxWidth小于最小宽度，则设置为最小宽度。

setMaxWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的max-width属性定义。

setMaxZonesLoaded(int) - Method in class javax.swing.text. ZoneView

设置允许同时加载的区域数量的当前设置。

setMBeanDescriptor(Descriptor) - Method in interface javax.management.modelmbean. ModelMBeanInfo

设置ModelMBean的描述符。

setMBeanDescriptor(Descriptor) - Method in class javax.management.modelmbean. ModelMBeanInfoSupport

setMBeanServer(MBeanServer) - Method in class javax.management. AttributeValueExp

已过时。
此方法无效。 用于获取属性值的MBean服务器为QueryEval.getMBeanServer() 。

setMBeanServer(MBeanServer) - Method in class javax.management. ObjectName

setMBeanServer(MBeanServer) - Method in class javax.management. QueryEval

设置要执行查询的MBean服务器。

setMBeanServer(MBeanServer) - Method in interface javax.management. QueryExp

设置要执行查询的MBean服务器。

setMBeanServer(MBeanServer) - Method in interface javax.management.remote. MBeanServerForwarder

设置此对象处理后请求将转发到的MBeanServer对象。

setMBeanServer(MBeanServer) - Method in class javax.management.remote.rmi. RMIServerImpl

设置此连接器服务器所连接的 MBeanServer 。

setMBeanServer(MBeanServer) - Method in class javax.management. StringValueExp

已过时。

setMBeanServer(MBeanServer) - Method in interface javax.management. ValueExp

已过时。
不需要此方法，因为ValueExp可以访问使用QueryEval.getMBeanServer()进行评估的MBean服务器。

setMBeanServerForwarder(MBeanServerForwarder) - Method in class javax.management.remote. JMXConnectorServer

setMBeanServerForwarder(MBeanServerForwarder) - Method in interface javax.management.remote. JMXConnectorServerMBean

插入一个对象，拦截通过此连接器服务器到达的MBean服务器的请求。

setMBeanServerForwarder(MBeanServerForwarder) - Method in class javax.management.remote.rmi. RMIConnectorServer

setMedia(PageAttributes.MediaType) - Method in class java.awt. PageAttributes

使用这些属性为页面指定所需的纸张尺寸。

setMedia(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setMedia(String) - Method in interface org.w3c.dom.html. HTMLStyleElement

setMediaPlayer(MediaPlayer) - Method in class javafx.scene.media. MediaView

设置 MediaPlayer的输出将由此视图处理。

setMediaText(String) - Method in interface org.w3c.dom.stylesheets. MediaList

媒体列表的可解析文本表示。

setMediaToDefault() - Method in class java.awt. PageAttributes

将使用这些属性的页面的纸张大小设置为默认语言环境的默认大小。

setMember(String, Object) - Method in class jdk.nashorn.api.scripting. AbstractJSObject

setMember(String, Object) - Method in interface jdk.nashorn.api.scripting. JSObject

在此JavaScript对象中设置一个命名成员

setMember(String, Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

setMember(String, Object) - Method in class netscape.javascript. JSObject

设置一个JavaScript对象的命名成员。

setMenu(PopupMenu) - Method in class java.awt. Taskbar

将提供的PopupMenu的内容附加到任务区域中的应用程序图标。

setMenuBar(MenuBar) - Method in class java.awt. Frame

将此框架的菜单栏设置为指定的菜单栏。

setMenuBar(JMenuBar) - Method in class javax.swing. JInternalFrame

已过时。
从Swing版本1.0.3替换为setJMenuBar(JMenuBar m) 。

setMenuBar(JMenuBar) - Method in class javax.swing. JRootPane

已过时。
从Swing版本1.0.3替换为setJMenuBar(JMenuBar menu) 。

setMenuLocation(int, int) - Method in class javax.swing. JMenu

设置弹出组件的位置。

setMesh(Mesh) - Method in class javafx.scene.shape. MeshView

设置属性网格的值。

setMessage(byte[], int) - Method in class javax.sound.midi. MidiMessage

设置MIDI信息的数据。

setMessage(byte[], int) - Method in class javax.sound.midi. SysexMessage

设置系统专用消息的数据。

setMessage(int) - Method in class javax.sound.midi. ShortMessage

设置不含数据字节的MIDI消息的参数。

setMessage(int, byte[], int) - Method in class javax.sound.midi. MetaMessage

设置 MetaMessage的消息参数。

setMessage(int, byte[], int) - Method in class javax.sound.midi. SysexMessage

设置系统专用消息的数据。

setMessage(int, int, int) - Method in class javax.sound.midi. ShortMessage

设置一个需要一个或两个数据字节的MIDI消息的参数。

setMessage(int, int, int, int) - Method in class javax.sound.midi. ShortMessage

设置通道消息的短消息参数，最多可以包含两个数据字节。

setMessage(Object) - Method in class javax.swing. JOptionPane

设置选项窗格的消息对象。

setMessage(String) - Method in class java.util.logging. LogRecord

在本地化或格式化之前设置“原始”日志消息。

setMessage(String) - Method in class javax.xml.bind.helpers. ValidationEventImpl

设置此事件的消息字段。

setMessage(SOAPMessage) - Method in interface javax.xml.ws.handler.soap. SOAPMessageContext

在此消息上下文中设置SOAPMessage

setMessageDigest(MessageDigest) - Method in class java.security. DigestInputStream

将指定的消息摘要与此流相关联。

setMessageDigest(MessageDigest) - Method in class java.security. DigestOutputStream

将指定的消息摘要与此流相关联。

setMessageType(int) - Method in class javax.swing. JOptionPane

设置选项窗格的消息类型。

setMetadata(List<Source>) - Method in class javax.xml.ws. Endpoint

设置此端点的元数据。

setMetadata(IIOMetadata) - Method in class javax.imageio. IIOImage

将 IIOMetadata设置为新对象，或 null 。

setMetaData(RowSetMetaData) - Method in interface javax.sql.rowset. CachedRowSet

使用给定的 RowSetMetaData对象设置此 CachedRowSet对象的元数据。

setMetaData(RowSetMetaData) - Method in interface javax.sql. RowSetInternal

将给定的 RowSetMetaData对象设置为 RowSetMetaData对象的 RowSet对象。

setMethod(int) - Method in class java.util.zip. ZipEntry

设置条目的压缩方法。

setMethod(int) - Method in class java.util.zip. ZipOutputStream

设置后续条目的默认压缩方法。

setMethod(String) - Method in interface org.w3c.dom.html. HTMLFormElement

setMicrosecondPosition(long) - Method in interface javax.sound.midi. Sequencer

设置序列中的当前位置，以微秒表示。

setMicrosecondPosition(long) - Method in interface javax.sound.sampled. Clip

以微秒设置媒体位置。

setMillis(long) - Method in class java.util.logging. LogRecord

已过时。
LogRecord使用Instant值维持纳秒分辨率的时间戳。 出于这个原因， setInstant()应优先用于setMillis() 。

setMillisecond(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置毫秒。

setMillisToDecideToPopup(int) - Method in class javax.swing. ProgressMonitor

指定在决定是否弹出进度监视器之前等待的时间。

setMillisToPopup(int) - Method in class javax.swing. ProgressMonitor

指定弹出窗口所需的时间。

setMimeHeader(String, String) - Method in class javax.xml.soap. AttachmentPart

将与给定名称匹配的第一个标题条目更改为给定值，如果没有现有标题匹配，则添加一个新标题。

setMimeHeader(String, String) - Method in class javax.xml.soap. SOAPPart

更改与给定标题名称匹配的第一个标题条目，以使其值为给定值，如果没有现有标题匹配，则添加具有给定名称和值的新标题。

setMin(double) - Method in class javafx.scene.control. ScrollBar

设置属性的值min。

setMin(double) - Method in class javafx.scene.control. Slider

设置属性的值min。

setMin(double) - Method in class javafx.scene.control. SpinnerValueFactory.DoubleSpinnerValueFactory

设置属性的值min。

setMin(int) - Method in class javafx.scene.control. SpinnerValueFactory.IntegerSpinnerValueFactory

设置属性的值min。

setMinCRLNumber(BigInteger) - Method in class java.security.cert. X509CRLSelector

设置minCRLNumber标准。

setMinHeight(double) - Method in class javafx.scene.control. PopupControl

超越控制计算的最小高度的属性。

setMinHeight(double) - Method in class javafx.scene.layout. Region

设置属性minHeight的值。

setMinHeight(double) - Method in class javafx.scene.layout. RowConstraints

设置属性minHeight的值。

setMinHeight(double) - Method in class javafx.scene.web. WebView

设置属性minHeight的值。

setMinHeight(double) - Method in class javafx.stage. Stage

设置属性minHeight的值。

setMinHeight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的min-height属性定义。

setMinimalDaysInFirstWeek(int) - Method in class java.util. Calendar

设定一年中第一个星期所需的最短时间是多少？ 例如，如果第一周被定义为包含一年中第一个月的第一天的第一周，请调用此值为1的方法。

setMinimum(int) - Method in interface java.awt. Adjustable

设置可调整对象的最小值。

setMinimum(int) - Method in class java.awt. Scrollbar

设置此滚动条的最小值。

setMinimum(int) - Method in class java.awt. ScrollPaneAdjustable

此方法 不应由用户代码调用。

setMinimum(int) - Method in interface javax.swing. BoundedRangeModel

将模型的最小值设置为 newMinimum 。

setMinimum(int) - Method in class javax.swing. DefaultBoundedRangeModel

在确定 n其他三个属性遵守模型的约束之后，将最小值设置为 n ：

setMinimum(int) - Method in class javax.swing. JProgressBar

将进度条的最小值（存储在进度条的数据模型中）设置为 n 。

setMinimum(int) - Method in class javax.swing. JScrollBar

设置模型的最小属性。

setMinimum(int) - Method in class javax.swing. JSlider

将滑块的最小值设置为 minimum 。

setMinimum(int) - Method in class javax.swing. ProgressMonitor

指定最小值。

setMinimum(Comparable<?>) - Method in class javax.swing. SpinnerNumberModel

更改此序列中数字的下限。

setMinimum(Comparable<?>) - Method in class javax.swing.text. InternationalFormatter

设置最小允许值。

setMinimumFractionDigits(int) - Method in class java.text. DecimalFormat

设置数字小数部分允许的最小位数。

setMinimumFractionDigits(int) - Method in class java.text. NumberFormat

设置数字小数部分允许的最小位数。 minimumFractionDigits必须是最大值。

setMinimumIntegerDigits(int) - Method in class java.text. DecimalFormat

设置数字的整数部分允许的最小位数。

setMinimumIntegerDigits(int) - Method in class java.text. NumberFormat

设置数字的整数部分允许的最小位数。 minimumIntegerDigits必须是最大值。

setMinimumSize(Dimension) - Method in class java.awt. Component

将此组件的最小大小设置为常量值。

setMinimumSize(Dimension) - Method in class java.awt. Window

将此窗口的最小大小设置为常量值。

setMinimumSize(Dimension) - Method in class javax.swing. JComponent

将此组件的最小大小设置为常量值。

setMinor(int, String) - Method in exception org.ietf.jgss. GSSException

由异常thrower用于设置机制级别的小错误代码及其字符串说明。

setMinorTickCount(int) - Method in class javafx.scene.chart. ValueAxis

设置属性minorTickCount的值。

setMinorTickCount(int) - Method in class javafx.scene.control. Slider

设置属性minorTickCount的值。

setMinorTickLength(double) - Method in class javafx.scene.chart. ValueAxis

设置属性minorTickLength的值。

setMinorTickSpacing(int) - Method in class javax.swing. JSlider

此方法设置较小的刻度间距。

setMinorTickVisible(boolean) - Method in class javafx.scene.chart. ValueAxis

设置属性minorTickVisible的值。

setMinPage(int) - Method in class java.awt. JobAttributes

指定用户可以指定的最小值作为使用这些属性的作业打印的第一页。

setMinSize(double, double) - Method in class javafx.scene.control. PopupControl

用于覆盖控制计算的最小宽度和高度的便捷方法。

setMinSize(double, double) - Method in class javafx.scene.layout. Region

覆盖区域计算的最小宽度和高度的便利方法。

setMinSize(double, double) - Method in class javafx.scene.web. WebView

设置最小宽度和高度的方便方法。

setMinusSign(char) - Method in class java.text. DecimalFormatSymbols

设置用于表示减号的字符。

setMinute(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置分钟。

setMinutes(int) - Method in class java.sql. Date

已过时。

setMinutes(int) - Method in class java.util. Date

已过时。
截至JDK 1.1版，由Calendar.set(Calendar.MINUTE, int minutes)替代。

setMinViewportHeight(double) - Method in class javafx.scene.control. ScrollPane

设置属性minViewportHeight的值。

setMinViewportWidth(double) - Method in class javafx.scene.control. ScrollPane

设置属性minViewportWidth的值。

setMinWidth(double) - Method in class javafx.scene.control. PopupControl

覆盖控制计算最小宽度的属性。

setMinWidth(double) - Method in class javafx.scene.control. TableColumnBase

设置属性minWidth的值。

setMinWidth(double) - Method in class javafx.scene.layout. ColumnConstraints

设置属性minWidth的值。

setMinWidth(double) - Method in class javafx.scene.layout. Region

设置属性minWidth的值。

setMinWidth(double) - Method in class javafx.scene.web. WebView

设置属性minWidth的值。

setMinWidth(double) - Method in class javafx.stage. Stage

设置属性minWidth的值。

setMinWidth(int) - Method in class javax.swing.table. TableColumn

将 TableColumn的最小宽度设置为 minWidth ，如有必要，调整新的最小宽度，以确保0 <= minWidth <= maxWidth 。

setMinWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的min-width属性定义。

setMiterLimit(double) - Method in class javafx.scene.canvas. GraphicsContext

设定当前的斜度限制。

setMixingCutoutShape(Shape) - Method in class java.awt. Component

为此轻型组件设置“混合切割”形状。

setMnemonic(char) - Method in class javax.swing. AbstractButton

这种方法现在已经过时了，请使用 setMnemonic(int)设置一个按钮的助记符。

setMnemonic(int) - Method in class javax.swing. AbstractButton

在当前型号上设置键盘助记符。

setMnemonic(int) - Method in interface javax.swing. ButtonModel

设置按钮的键盘助记符（快捷键或加速键）。

setMnemonic(int) - Method in class javax.swing. DefaultButtonModel

设置按钮的键盘助记符（快捷键或加速键）。

setMnemonicAt(int, int) - Method in class javax.swing. JTabbedPane

设置用于访问指定选项卡的键盘助记符。

setMnemonicParsing(boolean) - Method in class javafx.scene.control. Labeled

设置属性mnemonicParsing的值。

setMnemonicParsing(boolean) - Method in class javafx.scene.control. MenuItem

设置属性mnemonicParsing的值。

setModal(boolean) - Method in class java.awt. Dialog

指定此对话框是否应该是模态的。

setModalExclusionType(Dialog.ModalExclusionType) - Method in class java.awt. Window

指定此窗口的模态排除类型。

setModalityType(Dialog.ModalityType) - Method in class java.awt. Dialog

设置此对话框的模态类型。

setMode(int) - Method in class java.awt. FileDialog

设置文件对话框的模式。

setMode(BlendMode) - Method in class javafx.scene.effect. Blend

设置属性模式的值。

setModel(BoundedRangeModel) - Method in class javax.swing. JProgressBar

设置 JProgressBar使用的数据模型。

setModel(BoundedRangeModel) - Method in class javax.swing. JScrollBar

设置处理滚动条的四个基本属性的模型：minimum，maximum，value，extent。

setModel(BoundedRangeModel) - Method in class javax.swing. JSlider

设置 BoundedRangeModel处理滑块的三个基本属性：最小值，最大值，值。

setModel(ButtonModel) - Method in class javax.swing. AbstractButton

设置此按钮所代表的模型。

setModel(ButtonModel) - Method in class javax.swing. JMenu

设置“菜单按钮”的数据模型 - 用户点击打开或关闭菜单的标签。

setModel(ButtonModel) - Method in class javax.swing. JMenuItem

设置此按钮所代表的模型。

setModel(ComboBoxModel<E>) - Method in class javax.swing. JComboBox

设置 JComboBox用于获取项目列表的数据模型。

setModel(ListModel<E>) - Method in class javax.swing. JList

设置表示列表的内容或“值”的模型，通知属性更改侦听器，然后清除列表的选择。

setModel(SingleSelectionModel) - Method in class javax.swing. JTabbedPane

设置要与此选项卡窗格一起使用的模型。

setModel(SpinnerModel) - Method in class javax.swing. JSpinner

更改表示此微调器值的模型。

setModel(TableModel) - Method in class javax.swing. JTable

将此表的数据模型设置为 dataModel并将其注册为新数据模型的侦听器通知。

setModel(TreeModel) - Method in class javax.swing. JTree

设置将提供数据的 TreeModel 。

setModel(TreeModel) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置 TreeModel 。

setModel(TreeModel) - Method in class javax.swing.tree. AbstractLayoutCache

设置将提供数据的 TreeModel 。

setModel(TreeModel) - Method in class javax.swing.tree. FixedHeightLayoutCache

设置将提供数据的TreeModel。

setModel(TreeModel) - Method in class javax.swing.tree. VariableHeightLayoutCache

设置将提供数据的 TreeModel 。

setModel(M) - Method in class javax.swing.table. TableRowSorter

设置 TableModel ，以作为该底层模型使用 TableRowSorter 。

setModelIndex(int) - Method in class javax.swing.table. TableColumn

设置此列的模型索引。

setModelMBeanInfo(ModelMBeanInfo) - Method in interface javax.management.modelmbean. ModelMBean

使用传入的ModelMBeanInfo初始化一个ModelMBean对象。

setModelMBeanInfo(ModelMBeanInfo) - Method in class javax.management.modelmbean. RequiredModelMBean

使用传入的ModelMBeanInfo初始化一个ModelMBean对象。

setModelWrapper(DefaultRowSorter.ModelWrapper<M, I>) - Method in class javax.swing. DefaultRowSorter

设置提供正在排序和过滤的数据的模型包装器。

setModifiers(int) - Method in class java.awt.event. KeyEvent

已过时。
截至JDK1.1.4

setModulus(Number) - Method in class javax.management.monitor. CounterMonitor

设置所有观察到的MBean共有的模数值。

setModulus(Number) - Method in interface javax.management.monitor. CounterMonitorMBean

设置模数值。

setMonetaryDecimalSeparator(char) - Method in class java.text. DecimalFormatSymbols

设置货币十进制分隔符。

setMono(boolean) - Method in interface javax.sound.midi. MidiChannel

打开或关闭单声道模式。

setMonth(int) - Method in class java.sql. Time

已过时。

setMonth(int) - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.set(Calendar.MONTH, int month)替代。

setMonth(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置月份。

setMonths(String[]) - Method in class java.text. DateFormatSymbols

设置月份字符串。

setMouseOver(boolean) - Method in class javax.swing.plaf.basic. BasicSplitPaneDivider

设置鼠标是否在分隔线上。

setMouseTransparent(boolean) - Method in class javafx.scene. Node

设置属性mouseTransparent的值。

setMTOMEnabled(boolean) - Method in interface javax.xml.ws.soap. SOAPBinding

启用或禁用MTOM的使用。

setMultiClickThreshhold(long) - Method in class javax.swing. AbstractButton

设置鼠标按下事件之间所需的时间量（以毫秒为单位），用于生成相应的动作事件。

setMultiple(boolean) - Method in interface org.w3c.dom.html. HTMLSelectElement

setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType) - Method in class java.awt. JobAttributes

指定对使用这些属性的作业处理多个副本（包括排序规则）。

setMultipleDocumentHandlingToDefault() - Method in class java.awt. JobAttributes

将使用这些属性的作业的多个副本（包括排序规则）的处理设置为默认值。

setMultipleMode(boolean) - Method in class java.awt. FileDialog

启用或禁用文件对话框的多个文件选择。

setMultipleMode(boolean) - Method in class java.awt. List

设置确定此列表是否允许多个选择的标志。

setMultipleSelections(boolean) - Method in class java.awt. List

已过时。
从JDK 1.1版开始，由setMultipleMode(boolean)替代。

setMultiplier(int) - Method in class java.text. DecimalFormat

设置以百分比，每mille和类似格式使用的乘数。

setMultiSelectionEnabled(boolean) - Method in class javax.swing. JFileChooser

设置文件选择器以允许多个文件选择。

setMustUnderstand(boolean) - Method in interface javax.xml.soap. SOAPHeaderElement

将此 SOAPHeaderElement对象的mustUnderstand属性设置为true或false。

setMute(boolean) - Method in class javafx.scene.media. MediaPlayer

设置值为 MediaPlayer.muteProperty() 。

setMute(boolean) - Method in interface javax.sound.midi. MidiChannel

设置此通道的静音状态。

setMxx(double) - Method in class javafx.scene.transform. Affine

设置属性mxx的值。

setMxy(double) - Method in class javafx.scene.transform. Affine

设置属性mxy的值。

setMxz(double) - Method in class javafx.scene.transform. Affine

设置属性mxz的值。

setMyx(double) - Method in class javafx.scene.transform. Affine

设置属性myx的值。

setMyy(double) - Method in class javafx.scene.transform. Affine

设置属性myy的值。

setMyz(double) - Method in class javafx.scene.transform. Affine

设置属性myz的值。

setMzx(double) - Method in class javafx.scene.transform. Affine

设置属性mzx的值。

setMzy(double) - Method in class javafx.scene.transform. Affine

设置属性mzy的值。

setMzz(double) - Method in class javafx.scene.transform. Affine

设置属性mzz的值。

setName(String) - Method in class java.awt. Component

将组件的名称设置为指定的字符串。

setName(String) - Method in class java.awt. MenuComponent

将组件的名称设置为指定的字符串。

setName(String) - Method in class java.beans. FeatureDescriptor

设置此功能的编程名称。

setName(String) - Method in class java.lang. Thread

将此线程的名称更改为等于参数 name 。

setName(String) - Method in class javafx.scene.chart. PieChart.Data

设置属性名称的值。

setName(String) - Method in class javafx.scene.chart. XYChart.Series

设置属性名称的值。

setName(String) - Method in class javax.naming. NameClassPair

设置此绑定的名称。

setName(String) - Method in class javax.security.auth.callback. NameCallback

设置检索到的名称。

setName(String) - Method in class javax.swing.text. StyleContext.NamedStyle

更改样式的名称。

setName(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setName(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setName(String) - Method in interface org.w3c.dom.html. HTMLButtonElement

setName(String) - Method in interface org.w3c.dom.html. HTMLFormElement

setName(String) - Method in interface org.w3c.dom.html. HTMLFrameElement

setName(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setName(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setName(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setName(String) - Method in interface org.w3c.dom.html. HTMLMapElement

setName(String) - Method in interface org.w3c.dom.html. HTMLMetaElement

setName(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setName(String) - Method in interface org.w3c.dom.html. HTMLParamElement

setName(String) - Method in interface org.w3c.dom.html. HTMLSelectElement

setName(String) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setName(Principal, String) - Method in interface java.security.acl. Acl

已过时。

设置此ACL的名称。

setNameConstraints(byte[]) - Method in class java.security.cert. X509CertSelector

设置名称约束条件。

setNamedItem(Node) - Method in interface org.w3c.dom. NamedNodeMap

使用其 nodeName属性添加节点。

setNamedItemNS(Node) - Method in interface org.w3c.dom. NamedNodeMap

使用其 namespaceURI和 localName添加一个节点。

setNameInNamespace(String) - Method in class javax.naming. NameClassPair

设置此绑定的全名。

setNamespaceAware(boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

指定此代码生成的解析器将为XML命名空间提供支持。

setNamespaceAware(boolean) - Method in class javax.xml.parsers. SAXParserFactory

指定此代码生成的解析器将为XML命名空间提供支持。

setNamespaceContext(NamespaceContext) - Method in interface javax.xml.stream. XMLEventWriter

设置前缀和uri绑定的当前命名空间上下文。

setNamespaceContext(NamespaceContext) - Method in interface javax.xml.stream. XMLStreamWriter

设置前缀和uri绑定的当前命名空间上下文。

setNamespaceContext(NamespaceContext) - Method in interface javax.xml.xpath. XPath

建立命名空间上下文。

setNamespaceDeclUris(boolean) - Method in class org.xml.sax.helpers. NamespaceSupport

控制命名空间声明属性是否被放置在 NSDECL命名空间中，由 processName() 。

setNaN(String) - Method in class java.text. DecimalFormatSymbols

设置用于表示“不是数字”的字符串。

setNanos(int) - Method in class java.sql. Timestamp

将此 Timestamp对象的 nanos字段设置为给定值。

setNativeLibraryInfo(String) - Method in interface javax.jnlp. ExtensionInstallerService

通知JNLP客户端应搜索本机库的目录。

setNativeMethodPrefix(ClassFileTransformer, String) - Method in interface java.lang.instrument. Instrumentation

此方法通过允许使用应用于名称的前缀进行重试来修改本机方法解析的故障处理。

setNativesForFlavor(DataFlavor, String[]) - Method in class java.awt.datatransfer. SystemFlavorMap

放弃指定的当前映射 DataFlavor ，所有 DataFlavor能胜任指定 DataFlavor ，并创建新的映射到指定 String当地人。

setNavigationFilter(NavigationFilter) - Method in class javax.swing.text. JTextComponent

设置 NavigationFilter 。

setNCharacterStream(int, Reader) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 Reader对象。

setNCharacterStream(int, Reader) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的命令中的指定参数设置为 Reader对象。

setNCharacterStream(int, Reader) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为 Reader对象。

setNCharacterStream(int, Reader, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 Reader对象。

setNCharacterStream(int, Reader, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setNCharacterStream(int, Reader, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setNCharacterStream(String, Reader) - Method in interface java.sql. CallableStatement

将指定的参数设置为 Reader对象。

setNCharacterStream(String, Reader) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setNCharacterStream(String, Reader) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setNCharacterStream(String, Reader, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为 Reader对象。

setNCharacterStream(String, Reader, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setNCharacterStream(String, Reader, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setNClob(int, Reader) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 Reader对象。

setNClob(int, Reader) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setNClob(int, Reader) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setNClob(int, Reader, long) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 Reader对象。

setNClob(int, Reader, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setNClob(int, Reader, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setNClob(int, NClob) - Method in interface java.sql. PreparedStatement

将指定的参数设置为 java.sql.NClob对象。

setNClob(int, NClob) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 java.sql.NClob对象。

setNClob(int, NClob) - Method in interface javax.sql. RowSet

将指定的参数设置为 java.sql.NClob对象。

setNClob(String, Reader) - Method in interface java.sql. CallableStatement

将指定的参数设置为 Reader对象。

setNClob(String, Reader) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setNClob(String, Reader) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setNClob(String, Reader, long) - Method in interface java.sql. CallableStatement

将指定的参数设置为 Reader对象。

setNClob(String, Reader, long) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 Reader对象。

setNClob(String, Reader, long) - Method in interface javax.sql. RowSet

将指定的参数设置为 Reader对象。

setNClob(String, NClob) - Method in interface java.sql. CallableStatement

将指定的参数设置为 java.sql.NClob对象。

setNClob(String, NClob) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为 java.sql.NClob对象。

setNClob(String, NClob) - Method in interface javax.sql. RowSet

将指定的参数设置为 java.sql.NClob对象。

setNearClip(double) - Method in class javafx.scene. Camera

设置属性nearClip的值。

setNeedClientAuth(boolean) - Method in class com.sun.net.httpserver. HttpsParameters

设置是否需要客户端认证。

setNeedClientAuth(boolean) - Method in class javax.net.ssl. SSLEngine

配置引擎 要求客户端认证。

setNeedClientAuth(boolean) - Method in class javax.net.ssl. SSLParameters

设置是否需要客户端认证。

setNeedClientAuth(boolean) - Method in class javax.net.ssl. SSLServerSocket

控制是否最初配置 accept ed服务器模式 SSLSockets以 要求客户端认证。

setNeedClientAuth(boolean) - Method in class javax.net.ssl. SSLSocket

配置套接字以 要求客户端认证。

setNeedsLayout(boolean) - Method in class javafx.scene. Parent

设置propertyLayout属性的值。

setNegativePermissions() - Method in interface java.security.acl. AclEntry

已过时。

将此ACL条目设置为负数。

setNegativePrefix(String) - Method in class java.text. DecimalFormat

设置负前缀。

setNegativeSuffix(String) - Method in class java.text. DecimalFormat

设置负后缀。

setNetworkInterface(NetworkInterface) - Method in class java.net. MulticastSocket

指定在此套接字上发送的出站组播数据报的网络接口。

setNetworkTimeout(Executor, int) - Method in interface java.sql. Connection

设置最大周期a Connection或从 Connection创建的 Connection将等待数据库回复任何一个请求。

setNewLine(String) - Method in interface org.w3c.dom.ls. LSSerializer

要在XML中使用的字符的行尾序列被写出。

setNextException(SQLException) - Method in exception java.sql. SQLException

在链的末尾添加一个 SQLException对象。

setNextFocusableComponent(Component) - Method in class javax.swing. JComponent

已过时。
截至1.4，由FocusTraversalPolicy代替

setNextSibling(Node) - Method in class javax.xml.crypto.dsig.dom. DOMSignContext

设置下一个兄弟节点。

setNextSibling(Node) - Method in class javax.xml.transform.dom. DOMResult

设置子节点，之后插入结果节点。

setNextWarning(SQLWarning) - Method in exception java.sql. SQLWarning

将 SQLWarning对象添加到链的末尾。

setNextWarning(RowSetWarning) - Method in exception javax.sql.rowset. RowSetWarning

将 警告设置为下一个警告，即链接到此 RowSetWarning对象的警告。

setNil(boolean) - Method in class javax.xml.bind. JAXBElement

设置此元素是否具有零含量。

setNode(Node) - Method in class javafx.animation. FadeTransition

设置属性节点的值。

setNode(Node) - Method in class javafx.animation. ParallelTransition

设置属性节点的值。

setNode(Node) - Method in class javafx.animation. PathTransition

设置属性节点的值。

setNode(Node) - Method in class javafx.animation. RotateTransition

设置属性节点的值。

setNode(Node) - Method in class javafx.animation. ScaleTransition

设置属性节点的值。

setNode(Node) - Method in class javafx.animation. SequentialTransition

设置属性节点的值。

setNode(Node) - Method in class javafx.animation. TranslateTransition

设置属性节点的值。

setNode(Node) - Method in class javafx.scene.chart. XYChart.Data

设置属性节点的值。

setNode(Node) - Method in class javafx.scene.chart. XYChart.Series

设置属性节点的值。

setNode(Node) - Method in class javafx.scene.input. Mnemonic

设置Node

setNode(Node) - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

设置此事件定位器上的“节点”字段。

setNode(Node) - Method in class javax.xml.crypto.dsig.dom. DOMValidateContext

设置节点。

setNode(Node) - Method in class javax.xml.transform.dom. DOMResult

设置将包含结果DOM树的节点。

setNode(Node) - Method in class javax.xml.transform.dom. DOMSource

设置将代表源DOM树的节点。

setNodeDimensions(AbstractLayoutCache.NodeDimensions) - Method in class javax.swing.tree. AbstractLayoutCache

设置负责绘制树中节点的渲染器，因此负责计算各个节点的维度。

setNodeDimensions(AbstractLayoutCache.NodeDimensions) - Method in class javax.swing.tree. VariableHeightLayoutCache

设置负责在树中绘制节点的渲染器。

setNodeOrientation(NodeOrientation) - Method in class javafx.scene. Node

设置属性nodeOrientation的值。

setNodeOrientation(NodeOrientation) - Method in class javafx.scene. Scene

设置属性nodeOrientation的值。

setNodeValue(String) - Method in class javax.imageio.metadata. IIOMetadataNode

设置与此节点关联的值为 String 。

setNodeValue(String) - Method in interface org.w3c.dom. Node

该节点的值取决于其类型; 见上表。

setNoHref(boolean) - Method in interface org.w3c.dom.html. HTMLAreaElement

setNonContinuousLayoutDivider(Component) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

设置当 JSplitPane配置为不连续布局时使用的分隔符。

setNonContinuousLayoutDivider(Component, boolean) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

设置要使用的分隔符。

setNoNSSchemaLocation(String) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

设置noNamespaceSchemaLocation的便利方法。

setNoResize(boolean) - Method in interface org.w3c.dom.html. HTMLFrameElement

setNormalBounds(Rectangle) - Method in class javax.swing. JInternalFrame

设置此内部框架的正常范围，该内部框架将从其最大化状态恢复到的边界。

setNorthPane(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置北面。

setNoShade(boolean) - Method in interface org.w3c.dom.html. HTMLHRElement

setNote(String) - Method in class javax.swing. ProgressMonitor

指定与进度消息一起显示的附加注释。

setNotify(boolean) - Method in class javax.management.monitor. CounterMonitor

设置通知的所有观察到的MBean通用的开/关开关值。

setNotify(boolean) - Method in interface javax.management.monitor. CounterMonitorMBean

设置通知的开/关开关值。

setNotifyDiffer(boolean) - Method in class javax.management.monitor. StringMonitor

设置所有观察到的MBean通用的不同通知的开/关开关值。

setNotifyDiffer(boolean) - Method in interface javax.management.monitor. StringMonitorMBean

设置不同通知的开/关开关值。

setNotifyHigh(boolean) - Method in class javax.management.monitor. GaugeMonitor

设置所有观察到的MBean通用的高通知开/关切换值。

setNotifyHigh(boolean) - Method in interface javax.management.monitor. GaugeMonitorMBean

设置高通知的开/关开关值。

setNotifyLow(boolean) - Method in class javax.management.monitor. GaugeMonitor

设置所有观察到的MBean通用的低通知开/关切换值。

setNotifyLow(boolean) - Method in interface javax.management.monitor. GaugeMonitorMBean

设置低通知的开/关开关值。

setNotifyMatch(boolean) - Method in class javax.management.monitor. StringMonitor

设置匹配通知的所有观察到的MBean通用的开/关开关值。

setNotifyMatch(boolean) - Method in interface javax.management.monitor. StringMonitorMBean

设置匹配通知的开/关开关值。

setNoWrap(boolean) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setNString(int, String) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 String对象。

setNString(int, String) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 String对象。

setNString(int, String) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 String对象。

setNString(String, String) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 String对象。

setNString(String, String) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 String对象。

setNString(String, String) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 String对象。

setNull(int, int) - Method in interface java.sql. PreparedStatement

将指定的参数设置为SQL NULL 。

setNull(int, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为SQL NULL 。

setNull(int, int) - Method in interface javax.sql. RowSet

将此 RowSet对象的SQL命令中的指定参数设置为SQL NULL 。

setNull(int, int, String) - Method in interface java.sql. PreparedStatement

将指定的参数设置为SQL NULL 。

setNull(int, int, String) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为SQL NULL 。

setNull(int, int, String) - Method in interface javax.sql. RowSet

将此 RowSet对象的SQL命令中的指定参数设置为SQL NULL 。

setNull(String, int) - Method in interface java.sql. CallableStatement

将指定的参数设置为SQL NULL 。

setNull(String, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为SQL NULL 。

setNull(String, int) - Method in interface javax.sql. RowSet

将指定的参数设置为SQL NULL 。

setNull(String, int, String) - Method in interface java.sql. CallableStatement

将指定的参数设置为SQL NULL 。

setNull(String, int, String) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为SQL NULL 。

setNull(String, int, String) - Method in interface javax.sql. RowSet

将指定的参数设置为SQL NULL 。

setNullable(int, int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置是否存储在指定列中的值可以被设置为 NULL从界面到给定的常量 ResultSetMetaData 。

setNullable(int, int) - Method in interface javax.sql. RowSetMetaData

设置指定列的值是否可以设置为 NULL 。

setNullFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text. DefaultFormatterFactory

如果JFormattedTextField的值为空，则将格式化程序设置为使用。

setNumberFormat(NumberFormat) - Method in class java.text. DateFormat

允许您设置数字格式化程序。

setNumRows(int) - Method in class javax.swing.table. DefaultTableModel

作为Java 2平台v1.3的过时。

setObject(int, Object) - Method in interface java.sql. PreparedStatement

使用给定对象设置指定参数的值。

setObject(int, Object) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中的 Object 。

setObject(int, Object) - Method in interface javax.sql. RowSet

使用Java Object在此 RowSet对象的命令中设置指定的参数。

setObject(int, Object, int) - Method in interface java.sql. PreparedStatement

使用给定对象设置指定参数的值。

setObject(int, Object, int) - Method in class javax.sql.rowset. BaseRowSet

使用给定的 Object值设置指定参数的值。

setObject(int, Object, int) - Method in interface javax.sql. RowSet

使用Java Object在此 RowSet对象的命令中设置指定的参数。

setObject(int, Object, int, int) - Method in interface java.sql. PreparedStatement

使用给定对象设置指定参数的值。

setObject(int, Object, int, int) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中的 Object 。

setObject(int, Object, int, int) - Method in interface javax.sql. RowSet

使用给定的Java Object在此 RowSet对象的命令中设置指定的参数。

setObject(int, Object, SQLType) - Method in interface java.sql. PreparedStatement

使用给定对象设置指定参数的值。

setObject(int, Object, SQLType, int) - Method in interface java.sql. PreparedStatement

使用给定对象设置指定参数的值。

setObject(Object) - Method in interface java.beans. Customizer

设置要定制的对象。

setObject(Object) - Method in interface java.sql. Ref

将此 Ref对象引用到给定实例的结构类型值设置为 Object 。

setObject(Object) - Method in class javax.naming. Binding

设置与此绑定关联的对象。

setObject(Object) - Method in class javax.sql.rowset.serial. SerialRef

将此 SerialRef对象引用的SQL结构类型设置为给定的 Object对象。

setObject(Object) - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

设置此事件定位器上的对象字段。

setObject(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setObject(String, Object) - Method in interface java.sql. CallableStatement

使用给定对象设置指定参数的值。

setObject(String, Object) - Method in class javax.sql.rowset. BaseRowSet

使用给定对象设置指定参数的值。

setObject(String, Object) - Method in interface javax.sql. RowSet

使用给定对象设置指定参数的值。

setObject(String, Object, int) - Method in interface java.sql. CallableStatement

使用给定对象设置指定参数的值。

setObject(String, Object, int) - Method in class javax.sql.rowset. BaseRowSet

使用给定对象设置指定参数的值。

setObject(String, Object, int) - Method in interface javax.sql. RowSet

使用给定对象设置指定参数的值。

setObject(String, Object, int, int) - Method in interface java.sql. CallableStatement

使用给定对象设置指定参数的值。

setObject(String, Object, int, int) - Method in class javax.sql.rowset. BaseRowSet

使用给定对象设置指定参数的值。

setObject(String, Object, int, int) - Method in interface javax.sql. RowSet

使用给定对象设置指定参数的值。

setObject(String, Object, SQLType) - Method in interface java.sql. CallableStatement

使用给定对象设置指定参数的值。

setObject(String, Object, SQLType, int) - Method in interface java.sql. CallableStatement

使用给定对象设置指定参数的值。

setObjectFactoryBuilder(ObjectFactoryBuilder) - Static method in class javax.naming.spi. NamingManager

ObjectFactoryBuilder确定在尝试加载对象工厂时使用的策略。

setObjectInputFilter(ObjectInputFilter) - Method in class java.io. ObjectInputStream

为流设置序列化过滤器。

setObservedAttribute(String) - Method in class javax.management.monitor. Monitor

设置要观察的属性。

setObservedAttribute(String) - Method in interface javax.management.monitor. MonitorMBean

设置要观察的属性。

setObservedObject(ObjectName) - Method in class javax.management.monitor. Monitor

已过时。
截至JMX 1.2，由Monitor.addObservedObject(javax.management.ObjectName)替代

setObservedObject(ObjectName) - Method in interface javax.management.monitor. MonitorMBean

已过时。
截至JMX 1.2，由MonitorMBean.addObservedObject(javax.management.ObjectName)替代

setOcspExtensions(List<Extension>) - Method in class java.security.cert. PKIXRevocationChecker

设置可选的OCSP请求扩展。

setOcspResponder(URI) - Method in class java.security.cert. PKIXRevocationChecker

设置标识OCSP响应器位置的URI。

setOcspResponderCert(X509Certificate) - Method in class java.security.cert. PKIXRevocationChecker

设置OCSP响应者的证书。

setOcspResponses(Map<X509Certificate, byte[]>) - Method in class java.security.cert. PKIXRevocationChecker

设置OCSP响应。

setOffset(int) - Method in class java.io. ObjectStreamField

实例数据偏移。

setOffset(int) - Method in class java.text. CollationElementIterator

将迭代器设置为指向与指定字符对应的排序规则元素（参数是原始字符串中的CHARACTER偏移量，而不是其对应的排序规则元素序列中的偏移量）。

setOffset(int) - Method in class javax.imageio.stream. IIOByteBuffer

更新后续调用 getOffset方法返回的值。

setOffset(int) - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

设置此事件定位器上的偏移量字段。

setOffset(Point) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow

设置偏移量。

setOffset(Number) - Method in class javax.management.monitor. CounterMonitor

设置所有观察到的MBean公用的偏移值。

setOffset(Number) - Method in interface javax.management.monitor. CounterMonitorMBean

设置偏移值。

setOffsetX(double) - Method in class javafx.scene.effect. DisplacementMap

设置属性offsetX的值。

setOffsetX(double) - Method in class javafx.scene.effect. DropShadow

设置属性offsetX的值。

setOffsetX(double) - Method in class javafx.scene.effect. InnerShadow

设置属性offsetX的值。

setOffsetY(double) - Method in class javafx.scene.effect. DisplacementMap

设置属性offsetY的值。

setOffsetY(double) - Method in class javafx.scene.effect. DropShadow

设置属性offsetY的值。

setOffsetY(double) - Method in class javafx.scene.effect. InnerShadow

设置属性offsetY的值。

SetOfIntegerSyntax - Class in javax.print.attribute

类SetOfIntegerSyntax是一个抽象基类，提供了所有属性的常见实现，其值是一组非负整数。

SetOfIntegerSyntax(int) - Constructor for class javax.print.attribute. SetOfIntegerSyntax

构造一个包含一个整数的新的整数整数属性。

SetOfIntegerSyntax(int[][]) - Constructor for class javax.print.attribute. SetOfIntegerSyntax

使用数组形式的给定成员构造一个新的整数整型属性。

SetOfIntegerSyntax(int, int) - Constructor for class javax.print.attribute. SetOfIntegerSyntax

构造一个包含单个整数范围的新的整数整数属性。

SetOfIntegerSyntax(String) - Constructor for class javax.print.attribute. SetOfIntegerSyntax

使用字符串形式的给定成员构造一个新的整数整型属性。

setOmni(boolean) - Method in interface javax.sound.midi. MidiChannel

打开或关闭全向模式。

setOnAction(EventHandler<ActionEvent>) - Method in class javafx.scene.control. ButtonBase

设置属性onAction的值。

setOnAction(EventHandler<ActionEvent>) - Method in class javafx.scene.control. ChoiceBox

设置属性onAction的值。

setOnAction(EventHandler<ActionEvent>) - Method in class javafx.scene.control. ComboBoxBase

设置属性onAction的值。

setOnAction(EventHandler<ActionEvent>) - Method in class javafx.scene.control. ContextMenu

设置属性onAction的值。

setOnAction(EventHandler<ActionEvent>) - Method in class javafx.scene.control. MenuItem

设置属性onAction的值。

setOnAction(EventHandler<ActionEvent>) - Method in class javafx.scene.control. TextField

设置属性onAction的值。

setOnAlert(EventHandler<WebEvent<String>>) - Method in class javafx.scene.web. WebEngine

设置属性onAlert的值。

setOnAutoHide(EventHandler<Event>) - Method in class javafx.stage. PopupWindow

设置属性onAtotoHide的值。

setOnCancelled(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Service

每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。

setOnCancelled(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Task

每当任务状态转换到CANCELED状态时，都会调用onCancelled事件处理程序。

setOnClosed(EventHandler<Event>) - Method in class javafx.scene.control. Tab

定义标签关闭时要调用的函数。

setOnCloseRequest(EventHandler<Event>) - Method in class javafx.scene.control. Tab

设置属性onCloseRequest的值。

setOnCloseRequest(EventHandler<DialogEvent>) - Method in class javafx.scene.control. Dialog

设置属性onCloseRequest的值。

setOnCloseRequest(EventHandler<WindowEvent>) - Method in class javafx.stage. Window

设置属性onCloseRequest的值。

setOnContextMenuRequested(EventHandler<? super ContextMenuEvent>) - Method in class javafx.scene. Node

设置属性onContextMenuRequested的值。

setOnContextMenuRequested(EventHandler<? super ContextMenuEvent>) - Method in class javafx.scene. Scene

设置属性onContextMenuRequested的值。

setOnDragDetected(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onDragDetected的值。

setOnDragDetected(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onDragDetected的值。

setOnDragDone(EventHandler<? super DragEvent>) - Method in class javafx.scene. Node

设置属性onDragDone的值。

setOnDragDone(EventHandler<? super DragEvent>) - Method in class javafx.scene. Scene

设置属性onDragDone的值。

setOnDragDropped(EventHandler<? super DragEvent>) - Method in class javafx.scene. Node

设置属性onDragDropped的值。

setOnDragDropped(EventHandler<? super DragEvent>) - Method in class javafx.scene. Scene

设置属性onDragDropped的值。

setOnDragEntered(EventHandler<? super DragEvent>) - Method in class javafx.scene. Node

设置属性onDragEntered的值。

setOnDragEntered(EventHandler<? super DragEvent>) - Method in class javafx.scene. Scene

设置属性onDragEntered的值。

setOnDragExited(EventHandler<? super DragEvent>) - Method in class javafx.scene. Node

设置属性onDragExited的值。

setOnDragExited(EventHandler<? super DragEvent>) - Method in class javafx.scene. Scene

设置属性onDragExited的值。

setOnDragOver(EventHandler<? super DragEvent>) - Method in class javafx.scene. Node

设置属性onDragOver的值。

setOnDragOver(EventHandler<? super DragEvent>) - Method in class javafx.scene. Scene

设置属性onDragOver的值。

setOnEditCancel(EventHandler<ListView.EditEvent<T>>) - Method in class javafx.scene.control. ListView

设置当用户取消编辑时将被调用的EventHandler 。

setOnEditCancel(EventHandler<TableColumn.CellEditEvent<S, T>>) - Method in class javafx.scene.control. TableColumn

设置属性onEditCancel的值。

setOnEditCancel(EventHandler<TreeTableColumn.CellEditEvent<S, T>>) - Method in class javafx.scene.control. TreeTableColumn

设置属性onEditCancel的值。

setOnEditCancel(EventHandler<TreeView.EditEvent<T>>) - Method in class javafx.scene.control. TreeView

设置当用户取消编辑时将被调用的EventHandler 。

setOnEditCommit(EventHandler<ListView.EditEvent<T>>) - Method in class javafx.scene.control. ListView

设置当用户完成编辑时将被调用的EventHandler 。

setOnEditCommit(EventHandler<TableColumn.CellEditEvent<S, T>>) - Method in class javafx.scene.control. TableColumn

设置属性onEditCommit的值。

setOnEditCommit(EventHandler<TreeTableColumn.CellEditEvent<S, T>>) - Method in class javafx.scene.control. TreeTableColumn

设置属性onEditCommit的值。

setOnEditCommit(EventHandler<TreeView.EditEvent<T>>) - Method in class javafx.scene.control. TreeView

设置当用户提交编辑时将被调用的EventHandler 。

setOnEditStart(EventHandler<ListView.EditEvent<T>>) - Method in class javafx.scene.control. ListView

设置当用户开始编辑时将被调用的EventHandler 。

setOnEditStart(EventHandler<TableColumn.CellEditEvent<S, T>>) - Method in class javafx.scene.control. TableColumn

设置属性onEditStart的值。

setOnEditStart(EventHandler<TreeTableColumn.CellEditEvent<S, T>>) - Method in class javafx.scene.control. TreeTableColumn

设置属性onEditStart的值。

setOnEditStart(EventHandler<TreeView.EditEvent<T>>) - Method in class javafx.scene.control. TreeView

设置当用户开始编辑时将被调用的EventHandler 。

setOnEndOfMedia(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置媒体事件处理程序的结束。

setOnError(Runnable) - Method in class javafx.scene.media. Media

设置发生错误时调用的事件处理程序。

setOnError(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置发生错误时调用的事件处理程序。

setOnError(EventHandler<MediaErrorEvent>) - Method in class javafx.scene.media. MediaView

设置错误事件处理程序。

setOnError(EventHandler<WebErrorEvent>) - Method in class javafx.scene.web. WebEngine

设置属性onError的值。

setOneTouchExpandable(boolean) - Method in class javax.swing. JSplitPane

设置的值 oneTouchExpandable属性，它必须是 true为 JSplitPane提供对分频器快速展开/折叠分隔一个UI控件。

setOnFailed(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Service

每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。

setOnFailed(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Task

每当任务状态转换到FAILED状态时，都会调用onFailed事件处理程序。

setOnFinished(EventHandler<ActionEvent>) - Method in class javafx.animation. Animation

设置属性onFinished的值。

setOnHalted(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置 MediaPlayer.Status.HALTED事件处理程序。

setOnHidden(EventHandler<Event>) - Method in class javafx.scene.control. ChoiceBox

设置属性onHidden的值。

setOnHidden(EventHandler<Event>) - Method in class javafx.scene.control. ComboBoxBase

设置属性onHidden的值。

setOnHidden(EventHandler<Event>) - Method in class javafx.scene.control. Menu

设置属性onHidden的值。

setOnHidden(EventHandler<DialogEvent>) - Method in class javafx.scene.control. Dialog

设置属性onHidden的值。

setOnHidden(EventHandler<WindowEvent>) - Method in class javafx.stage. Window

设置属性onHidden的值。

setOnHiding(EventHandler<Event>) - Method in class javafx.scene.control. ChoiceBox

设置属性onHiding的值。

setOnHiding(EventHandler<Event>) - Method in class javafx.scene.control. ComboBoxBase

设置属性onHiding的值。

setOnHiding(EventHandler<Event>) - Method in class javafx.scene.control. Menu

设置属性onHiding的值。

setOnHiding(EventHandler<DialogEvent>) - Method in class javafx.scene.control. Dialog

设置属性onHiding的值。

setOnHiding(EventHandler<WindowEvent>) - Method in class javafx.stage. Window

设置属性onHiding的值。

setOnInputMethodTextChanged(EventHandler<? super InputMethodEvent>) - Method in class javafx.scene. Node

设置属性onInputMethodTextChanged的值。

setOnInputMethodTextChanged(EventHandler<? super InputMethodEvent>) - Method in class javafx.scene. Scene

设置属性onInputMethodTextChanged的值。

setOnKeyPressed(EventHandler<? super KeyEvent>) - Method in class javafx.scene. Node

设置属性onKeyPressed的值。

setOnKeyPressed(EventHandler<? super KeyEvent>) - Method in class javafx.scene. Scene

设置属性onKeyPressed的值。

setOnKeyReleased(EventHandler<? super KeyEvent>) - Method in class javafx.scene. Node

设置属性onKeyReleased的值。

setOnKeyReleased(EventHandler<? super KeyEvent>) - Method in class javafx.scene. Scene

设置属性onKeyReleased的值。

setOnKeyTyped(EventHandler<? super KeyEvent>) - Method in class javafx.scene. Node

设置属性onKeyTyped的值。

setOnKeyTyped(EventHandler<? super KeyEvent>) - Method in class javafx.scene. Scene

设置属性onKeyTyped的值。

setOnMarker(EventHandler<MediaMarkerEvent>) - Method in class javafx.scene.media. MediaPlayer

设置标记事件处理程序。

setOnMenuValidation(EventHandler<Event>) - Method in class javafx.scene.control. MenuItem

设置属性onMenuValidation的值。

setOnMouseClicked(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onMouseClicked的值。

setOnMouseClicked(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onMouseClicked的值。

setOnMouseDragEntered(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Node

设置属性onMouseDragEntered的值。

setOnMouseDragEntered(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Scene

设置属性onMouseDragEntered的值。

setOnMouseDragExited(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Node

设置属性onMouseDragExited的值。

setOnMouseDragExited(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Scene

设置属性onMouseDragExited的值。

setOnMouseDragged(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onMouseDragged的值。

setOnMouseDragged(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onMouseDragged的值。

setOnMouseDragOver(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Node

设置属性onMouseDragOver的值。

setOnMouseDragOver(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Scene

设置属性onMouseDragOver的值。

setOnMouseDragReleased(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Node

设置属性onMouseDragReleased的值。

setOnMouseDragReleased(EventHandler<? super MouseDragEvent>) - Method in class javafx.scene. Scene

设置属性onMouseDragReleased的值。

setOnMouseEntered(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onMouseEntered的值。

setOnMouseEntered(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onMouseEntered的值。

setOnMouseExited(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onMouseExited的值。

setOnMouseExited(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onMouseExited的值。

setOnMouseMoved(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onMouseMoved的值。

setOnMouseMoved(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onMouseMoved的值。

setOnMousePressed(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onMousePressed的值。

setOnMousePressed(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onMousePressed的值。

setOnMouseReleased(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Node

设置属性onMouseReleased的值。

setOnMouseReleased(EventHandler<? super MouseEvent>) - Method in class javafx.scene. Scene

设置属性onMouseReleased的值。

setOnPaused(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置 MediaPlayer.Status.PAUSED事件处理程序。

setOnPlaying(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置 MediaPlayer.Status.PLAYING事件处理程序。

setOnReady(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置 MediaPlayer.Status.READY事件处理程序。

setOnReady(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Service

每当任务状态转换到READY状态时，都会调用onReady事件处理程序。

setOnRepeat(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置重复事件处理程序。

setOnResized(EventHandler<WebEvent<Rectangle2D>>) - Method in class javafx.scene.web. WebEngine

设置属性onResized的值。

setOnRotate(EventHandler<? super RotateEvent>) - Method in class javafx.scene. Node

设置属性onRotate的值。

setOnRotate(EventHandler<? super RotateEvent>) - Method in class javafx.scene. Scene

设置属性onRotate的值。

setOnRotationFinished(EventHandler<? super RotateEvent>) - Method in class javafx.scene. Node

设置属性onRotationFinished的值。

setOnRotationFinished(EventHandler<? super RotateEvent>) - Method in class javafx.scene. Scene

设置属性onRotationFinished的值。

setOnRotationStarted(EventHandler<? super RotateEvent>) - Method in class javafx.scene. Node

设置属性onRotationStarted的值。

setOnRotationStarted(EventHandler<? super RotateEvent>) - Method in class javafx.scene. Scene

设置属性onRotationStarted的值。

setOnRunning(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Service

每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。

setOnRunning(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Task

每当任务状态转换到RUNNING状态时，都会调用onRunning事件处理程序。

setOnScheduled(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Service

每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。

setOnScheduled(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Task

每当任务状态转换到SCHEDULED状态时，调用onSchedule事件处理程序。

setOnScroll(EventHandler<? super ScrollEvent>) - Method in class javafx.scene. Node

设置属性onScroll的值。

setOnScroll(EventHandler<? super ScrollEvent>) - Method in class javafx.scene. Scene

设置属性onScroll的值。

setOnScrollFinished(EventHandler<? super ScrollEvent>) - Method in class javafx.scene. Node

设置属性onScrollFinished的值。

setOnScrollFinished(EventHandler<? super ScrollEvent>) - Method in class javafx.scene. Scene

设置属性onScrollFinished的值。

setOnScrollStarted(EventHandler<? super ScrollEvent>) - Method in class javafx.scene. Node

设置属性onScrollStarted的值。

setOnScrollStarted(EventHandler<? super ScrollEvent>) - Method in class javafx.scene. Scene

设置属性onScrollStarted的值。

setOnScrollTo(EventHandler<ScrollToEvent<Integer>>) - Method in class javafx.scene.control. ListView

设置属性onScrollTo的值。

setOnScrollTo(EventHandler<ScrollToEvent<Integer>>) - Method in class javafx.scene.control. TableView

设置属性onScrollTo的值。

setOnScrollTo(EventHandler<ScrollToEvent<Integer>>) - Method in class javafx.scene.control. TreeTableView

设置属性onScrollTo的值。

setOnScrollTo(EventHandler<ScrollToEvent<Integer>>) - Method in class javafx.scene.control. TreeView

设置属性onScrollTo的值。

setOnScrollToColumn(EventHandler<ScrollToEvent<TableColumn<S, ?>>>) - Method in class javafx.scene.control. TableView

设置属性onScrollToColumn的值。

setOnScrollToColumn(EventHandler<ScrollToEvent<TreeTableColumn<S, ?>>>) - Method in class javafx.scene.control. TreeTableView

设置属性onScrollToColumn的值。

setOnSelectionChanged(EventHandler<Event>) - Method in class javafx.scene.control. Tab

定义在选项卡上发生选择更改时要调用的函数。

setOnShowing(EventHandler<Event>) - Method in class javafx.scene.control. ChoiceBox

设置属性onShowing的值。

setOnShowing(EventHandler<Event>) - Method in class javafx.scene.control. ComboBoxBase

设置属性onShowing的值。

setOnShowing(EventHandler<Event>) - Method in class javafx.scene.control. Menu

设置属性onShowing的值。

setOnShowing(EventHandler<DialogEvent>) - Method in class javafx.scene.control. Dialog

设置属性onShowing的值。

setOnShowing(EventHandler<WindowEvent>) - Method in class javafx.stage. Window

设置属性onShowing的值。

setOnShown(EventHandler<Event>) - Method in class javafx.scene.control. ChoiceBox

设置属性onShown的值。

setOnShown(EventHandler<Event>) - Method in class javafx.scene.control. ComboBoxBase

设置属性onShown的值。

setOnShown(EventHandler<Event>) - Method in class javafx.scene.control. Menu

设置属性onShown的值。

setOnShown(EventHandler<DialogEvent>) - Method in class javafx.scene.control. Dialog

设置属性onShown的值。

setOnShown(EventHandler<WindowEvent>) - Method in class javafx.stage. Window

设置属性onShown的值。

setOnSort(EventHandler<SortEvent<TableView<S>>>) - Method in class javafx.scene.control. TableView

设置属性onSort的值。

setOnSort(EventHandler<SortEvent<TreeTableView<S>>>) - Method in class javafx.scene.control. TreeTableView

设置属性onSort的值。

setOnStalled(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置 MediaPlayer.Status.STALLED事件处理程序。

setOnStatusChanged(EventHandler<WebEvent<String>>) - Method in class javafx.scene.web. WebEngine

设置属性onStatusChanged的值。

setOnStopped(Runnable) - Method in class javafx.scene.media. MediaPlayer

设置 MediaPlayer.Status.STOPPED事件处理程序。

setOnSucceeded(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Service

每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。

setOnSucceeded(EventHandler<WorkerStateEvent>) - Method in class javafx.concurrent. Task

每当任务状态转换到SUCCEEDED状态时，调用onSucceeded事件处理程序。

setOnSwipeDown(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Node

设置属性onSwipeDown的值。

setOnSwipeDown(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Scene

设置属性onSwipeDown的值。

setOnSwipeLeft(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Node

设置属性onSwipeLeft的值。

setOnSwipeLeft(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Scene

设置属性onSwipeLeft的值。

setOnSwipeRight(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Node

设置属性onSwipeRight的值。

setOnSwipeRight(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Scene

设置属性onSwipeRight的值。

setOnSwipeUp(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Node

设置属性onSwipeUp的值。

setOnSwipeUp(EventHandler<? super SwipeEvent>) - Method in class javafx.scene. Scene

设置属性onSwipeUp的值。

setOnTouchMoved(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Node

设置属性onTouchMoved的值。

setOnTouchMoved(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Scene

设置属性onTouchMoved的值。

setOnTouchPressed(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Node

设置属性onTouchPressed的值。

setOnTouchPressed(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Scene

设置属性onTouchPressed的值。

setOnTouchReleased(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Node

设置属性onTouchReleased的值。

setOnTouchReleased(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Scene

设置属性onTouchReleased的值。

setOnTouchStationary(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Node

设置属性onTouchStationary的值。

setOnTouchStationary(EventHandler<? super TouchEvent>) - Method in class javafx.scene. Scene

设置属性onTouchStationary的值。

setOnTransformChanged(EventHandler<? super TransformChangedEvent>) - Method in class javafx.scene.transform. Transform

设置onTransformChanged事件处理程序，当变换改变其任何参数时，调用它。

setOnVisibilityChanged(EventHandler<WebEvent<Boolean>>) - Method in class javafx.scene.web. WebEngine

设置属性onVisibilityChanged的值。

setOnZoom(EventHandler<? super ZoomEvent>) - Method in class javafx.scene. Node

设置Zoom上的属性值。

setOnZoom(EventHandler<? super ZoomEvent>) - Method in class javafx.scene. Scene

设置Zoom上的属性值。

setOnZoomFinished(EventHandler<? super ZoomEvent>) - Method in class javafx.scene. Node

设置属性onZoomFinished的值。

setOnZoomFinished(EventHandler<? super ZoomEvent>) - Method in class javafx.scene. Scene

设置属性onZoomFinished的值。

setOnZoomStarted(EventHandler<? super ZoomEvent>) - Method in class javafx.scene. Node

设置属性onZoomStarted的值。

setOnZoomStarted(EventHandler<? super ZoomEvent>) - Method in class javafx.scene. Scene

设置属性onZoomStarted的值。

setOOBInline(boolean) - Method in class java.net. Socket

启用/禁用 SO_OOBINLINE （接收TCP紧急数据）默认情况下，此选项被禁用，并且在套接字上接收的TCP紧急数据被静默地丢弃。

setOpacity(double) - Method in class javafx.scene.effect. Blend

设置属性不透明度的值。

setOpacity(double) - Method in class javafx.scene. Node

设置属性不透明度的值。

setOpacity(double) - Method in class javafx.stage. Window

设置属性不透明度的值。

setOpacity(float) - Method in class java.awt. Dialog

设置窗口的不透明度。

setOpacity(float) - Method in class java.awt. Frame

设置窗口的不透明度。

setOpacity(float) - Method in class java.awt. Window

设置窗口的不透明度。

setOpaque(boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。

setOpaque(boolean) - Method in class javafx.embed.swing. JFXPanel

JFXPanel的不透明度由该组件中显示的JavaFX内容控制，因此此方法将覆盖 JComponent.setOpaque(boolean)以仅接受 false值。

setOpaque(boolean) - Method in class javax.swing. JComponent

如果为真，组件将绘制其边界内的每个像素。

setOpaque(int) - Method in class java.util.concurrent.atomic. AtomicInteger

将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。

setOpaque(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。

setOpaque(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

将索引 i为 newValue的元素设置为 newValue ，具有由 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。

setOpaque(int, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。

setOpaque(long) - Method in class java.util.concurrent.atomic. AtomicLong

将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。

setOpaque(Object...) - Method in class java.lang.invoke. VarHandle

以程序顺序将变量的值设置为 newValue ，但不能保证相对于其他线程的内存排序效果。

setOpaque(V) - Method in class java.util.concurrent.atomic. AtomicReference

将值设置为 newValue ，具有 VarHandle.setOpaque(java.lang.Object...)指定的内存效果。

setOpaqueInsets(Insets) - Method in class javafx.scene.layout. Region

设置属性opaqueInsets的值。

setOpenFileHandler(OpenFilesHandler) - Method in class java.awt. Desktop

安装在应用程序被要求打开文件列表时通知的处理程序。

setOpenIcon(Icon) - Method in class javax.swing.tree. DefaultTreeCellRenderer

设置用于表示展开的非叶节点的图标。

setOpenURIHandler(OpenURIHandler) - Method in class java.awt. Desktop

安装在请求应用程序打开URL时通知的处理程序。

setOptimizeHuffmanTables(boolean) - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam

告诉作者为写入过程的一部分，为图像生成优化的霍夫曼表。

setOption(int, Object) - Method in interface java.net. SocketOptions

启用/禁用 optID指定的选项。

setOption(SctpSocketOption<T>, T) - Method in class com.sun.nio.sctp. SctpChannel

设置套接字选项的值。

setOption(SctpSocketOption<T>, T) - Method in class com.sun.nio.sctp. SctpServerChannel

设置套接字选项的值。

setOption(SctpSocketOption<T>, T, Association) - Method in class com.sun.nio.sctp. SctpMultiChannel

设置套接字选项的值。

setOption(DatagramSocket, SocketOption<T>, T) - Static method in class jdk.net. Sockets

在DatagramSocket或MulticastSocket上设置套接字选项的值

setOption(ServerSocket, SocketOption<T>, T) - Static method in class jdk.net. Sockets

在ServerSocket上设置套接字选项的值

setOption(SocketOption<T>, T) - Method in class java.net. DatagramSocket

设置套接字选项的值。

setOption(SocketOption<T>, T) - Method in class java.net. DatagramSocketImpl

调用设置套接字选项。

setOption(SocketOption<T>, T) - Method in class java.net. ServerSocket

设置套接字选项的值。

setOption(SocketOption<T>, T) - Method in class java.net. Socket

设置套接字选项的值。

setOption(SocketOption<T>, T) - Method in class java.net. SocketImpl

调用设置套接字选项。

setOption(SocketOption<T>, T) - Method in class java.nio.channels. AsynchronousServerSocketChannel

setOption(SocketOption<T>, T) - Method in class java.nio.channels. AsynchronousSocketChannel

setOption(SocketOption<T>, T) - Method in class java.nio.channels. DatagramChannel

setOption(SocketOption<T>, T) - Method in interface java.nio.channels. NetworkChannel

设置套接字选项的值。

setOption(SocketOption<T>, T) - Method in class java.nio.channels. ServerSocketChannel

setOption(SocketOption<T>, T) - Method in class java.nio.channels. SocketChannel

setOption(Socket, SocketOption<T>, T) - Static method in class jdk.net. Sockets

在Socket上设置套接字选项的值

setOptions(Object[]) - Method in class javax.swing. JOptionPane

设置该窗格显示的选项。

setOptions(Set<PKIXRevocationChecker.Option>) - Method in class java.security.cert. PKIXRevocationChecker

设置撤销选项。

setOptionType(int) - Method in class javax.swing. JOptionPane

设置要显示的选项。

setOrdering(Class<T>, T, T) - Method in class javax.imageio.spi. ServiceRegistry

在给定类别中的两个服务提供者对象之间设置成对排序。

setOrdinal(int) - Method in class javafx.css. Selector

setOrientation(int) - Method in class java.awt.print. PageFormat

设置页面方向。

setOrientation(int) - Method in class java.awt. Scrollbar

设置此滚动条的方向。

setOrientation(int) - Method in class javax.swing. JProgressBar

将进度条的方向设置为 newOrientation ，它必须是 SwingConstants.VERTICAL或 SwingConstants.HORIZONTAL 。

setOrientation(int) - Method in class javax.swing. JScrollBar

将滚动条的方向设置为VERTICAL或HORIZONTAL。

setOrientation(int) - Method in class javax.swing. JSeparator

设置分隔符的方向。

setOrientation(int) - Method in class javax.swing. JSlider

将滑块的方向设置为 SwingConstants.VERTICAL或 SwingConstants.HORIZONTAL 。

setOrientation(int) - Method in class javax.swing. JSplitPane

设置方向，或分离器的分割方式。

setOrientation(int) - Method in class javax.swing. JToolBar

设置工具栏的方向。

setOrientation(int) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

设置方向为 JSplitPane 。

setOrientation(int) - Method in class javax.swing.plaf.basic. BasicToolBarUI.DragWindow

设置方向。

setOrientation(int) - Method in class javax.swing.plaf.basic. BasicToolBarUI

设置工具栏的方向。

setOrientation(PathTransition.OrientationType) - Method in class javafx.animation. PathTransition

设置属性方向的值。

setOrientation(Orientation) - Method in class javafx.scene.control. ListView

设置ListView的方向，它决定它是垂直滚动还是水平滚动。

setOrientation(Orientation) - Method in class javafx.scene.control. ScrollBar

设置属性方向的值。

setOrientation(Orientation) - Method in class javafx.scene.control. Separator

设置属性方向的值。

setOrientation(Orientation) - Method in class javafx.scene.control. Slider

设置属性方向的值。

setOrientation(Orientation) - Method in class javafx.scene.control. SplitPane

此属性控制如何向用户显示SplitPane。

setOrientation(Orientation) - Method in class javafx.scene.control. ToolBar

设置属性方向的值。

setOrientation(Orientation) - Method in class javafx.scene.layout. FlowPane

设置属性方向的值。

setOrientation(Orientation) - Method in class javafx.scene.layout. TilePane

设置属性方向的值。

setOrientationRequested(int) - Method in class java.awt. PageAttributes

指定使用这些属性的页面的打印方向。

setOrientationRequested(PageAttributes.OrientationRequestedType) - Method in class java.awt. PageAttributes

指定使用这些属性的页面的打印方向。

setOrientationRequestedToDefault() - Method in class java.awt. PageAttributes

将使用这些属性的页面的打印方向设置为默认值。

setOrigin(PageAttributes.OriginType) - Method in class java.awt. PageAttributes

指定使用这些属性绘制（0，0）到页面是否绘制在物理页面的左上角或可打印区域的左上角。

setOrigin(StyleOrigin) - Method in class javafx.css. Stylesheet

setOriginalRow() - Method in interface javax.sql.rowset. CachedRowSet

将此 CachedRowSet对象中的当前行设置为原始行。

setOrphans(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的孤儿属性定义。

setOut(PrintStream) - Static method in class java.lang. System

重新分配“标准”输出流。

setOuterHTML(Element, String) - Method in class javax.swing.text.html. HTMLDocument

用指定为HTML字符串的内容替换父项中的给定元素。

setOutline(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的大纲属性定义。

setOutlineColor(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的outline-color属性定义。

setOutlineStyle(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的outline-style属性定义。

setOutlineWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的outline-width属性定义。

setOutput(Object) - Method in class javax.imageio. ImageWriter

将目的地设置为给定的 ImageOutputStream或其他 Object 。

setOutputProperties(Properties) - Method in class javax.xml.transform. Transformer

设置转换的输出属性。

setOutputProperty(String, String) - Method in class javax.xml.transform. Transformer

设置一个对转换有效的输出属性。

setOutputStream(OutputStream) - Method in class java.rmi.server. LogStream

已过时。
没有替换

setOutputStream(OutputStream) - Method in class java.util.logging. StreamHandler

更改输出流。

setOutputStream(OutputStream) - Method in class javax.xml.transform.stream. StreamResult

设置要写入的ByteStream。

setOverflow(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的overflow属性定义。

SetOverrideType - Class in org.omg.CORBA

CORBA 枚举标记 SET_OVERRIDE和 ADD_OVERRIDE ，其指示策略是否应替换 Object的现有策略或添加到它们。

SetOverrideType(int) - Constructor for class org.omg.CORBA. SetOverrideType

从一个 int构造一个 SetOverrideType实例。

SetOverrideTypeHelper - Class in org.omg.CORBA

助手 SetOverrideType 。

SetOverrideTypeHelper() - Constructor for class org.omg.CORBA. SetOverrideTypeHelper

setOverwriteMode(boolean) - Method in class javax.swing.text. DefaultFormatter

配置插入字符时的行为。

setOwner(Object) - Method in class java.beans. XMLDecoder

将此解码器的所有者设置为 owner 。

setOwner(Object) - Method in class java.beans. XMLEncoder

将该编码器的所有者设置为 owner 。

setOwner(UserPrincipal) - Method in interface java.nio.file.attribute. FileOwnerAttributeView

更新文件所有者。

setOwner(Path, UserPrincipal) - Static method in class java.nio.file. Files

更新文件所有者。

setPackageAssertionStatus(String, boolean) - Method in class java.lang. ClassLoader

设置命名包的包默认断言状态。

setPadding(int) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

设置填充值。

setPadding(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding属性定义。

setPadding(Insets) - Method in class javafx.scene.layout. Region

设置属性填充的值。

setPaddingBottom(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-bottom属性定义。

setPaddingLeft(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-left属性定义。

setPaddingRight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-right属性定义。

setPaddingTop(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的padding-top属性定义。

setPage(int, Printable, PageFormat) - Method in class java.awt.print. Book

为指定的页码设置 PageFormat和 Painter 。

setPage(String) - Method in class javax.swing. JEditorPane

设置显示的当前URL。

setPage(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的页面属性定义。

setPage(URL) - Method in class javax.swing. JEditorPane

设置显示的当前URL。

setPageable(Pageable) - Method in class java.awt.print. PrinterJob

查询 document的页数和 PageFormat和 Printable为 Pageable实例中 Printable的每个页面， document 。

setPageBreakAfter(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的page-break-after属性定义。

setPageBreakBefore(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的page-break-before属性定义。

setPageBreakInside(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的page-break-inside属性定义。

setPageCount(int) - Method in class javafx.scene.control. Pagination

设置页数。

setPageFactory(Callback<Integer, Node>) - Method in class javafx.scene.control. Pagination

设置页面工厂回调函数。

setPageIncrement(int) - Method in class java.awt. Scrollbar

已过时。
从JDK 1.1版开始，由setBlockIncrement()替代。

setPageLayout(PageLayout) - Method in class javafx.print. JobSettings

将PageLayout设置为使用。

setPageRanges(int[][]) - Method in class java.awt. JobAttributes

对于使用这些属性的作业，指定要打印的页面范围，如果要打印的页面范围。

setPageRanges(PageRange...) - Method in class javafx.print. JobSettings

要打印为PageRange数组的页面范围。

setPageSize(int) - Method in interface javax.sql.rowset. CachedRowSet

设置 CachedRowSet对象的页面大小。

setPaint(Paint) - Method in class java.awt. Graphics2D

为 Graphics2D上下文设置 Paint属性。

setPaint(Paint) - Method in class javafx.scene.effect. ColorInput

设置属性paint的值。

setPaintLabels(boolean) - Method in class javax.swing. JSlider

确定标签是否涂在滑块上。

setPaintMode() - Method in class java.awt. Graphics

设置此图形上下文的绘制模式，以使用此图形上下文的当前颜色覆盖目标。

setPaintMode() - Method in class javax.swing. DebugGraphics

覆盖 Graphics.setPaintMode 。

setPaintTicks(boolean) - Method in class javax.swing. JSlider

确定刻印标记是否在滑块上绘制。

setPaintTrack(boolean) - Method in class javax.swing. JSlider

确定轨迹是否在滑块上绘制。

setPalette(boolean) - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane

如果 b是 true ，设置调色板图标。

setPalette(boolean) - Method in class javax.swing.plaf.metal. MetalInternalFrameUI

如果 isPalette是 true ，设置调色板边框和标题

setPan(double) - Method in class javafx.scene.media. AudioClip

设置默认的平移值。

setPannable(boolean) - Method in class javafx.scene.control. ScrollPane

设置pannable属性的值。

setPannable(boolean) - Method in class javafx.scene.control.skin. VirtualFlow

设置pannable属性的值。

setPaper(Paper) - Method in class java.awt.print. PageFormat

为此 PageFormat设置 Paper对象。

setPaperSource(PaperSource) - Method in class javafx.print. JobSettings

设置属性paperSource的值。

setParagraphAttributes(int, int, AttributeSet, boolean) - Method in class javax.swing.text. DefaultStyledDocument

设置段落的属性。

setParagraphAttributes(int, int, AttributeSet, boolean) - Method in class javax.swing.text.html. HTMLDocument

设置段落的属性。

setParagraphAttributes(int, int, AttributeSet, boolean) - Method in interface javax.swing.text. StyledDocument

设置段落属性。

setParagraphAttributes(JEditorPane, AttributeSet, boolean) - Method in class javax.swing.text. StyledEditorKit.StyledTextAction

将给定的属性应用于段落。

setParagraphAttributes(AttributeSet, boolean) - Method in class javax.swing. JTextPane

将给定的属性应用于段落。

setParagraphInsets(AttributeSet) - Method in class javax.swing.text. CompositeView

从给定属性中指定的段落属性设置插值。

setParameter(String, Object) - Method in class java.security. Signature

已过时。
使用setParameter 。

setParameter(String, Object) - Method in class javax.xml.transform. Transformer

添加转换参数。

setParameter(String, Object) - Method in interface org.w3c.dom. DOMConfiguration

设置参数的值。

setParameter(String, String) - Method in class javax.activation. MimeType

设置与给定名称相关联的值，替换任何先前的关联。

setParameter(AlgorithmParameterSpec) - Method in class java.security. Signature

使用指定的参数集初始化此签名引擎。

setParameterBlock(ParameterBlock) - Method in class java.awt.image.renderable. RenderableImageOp

更改操作的当前ParameterBlock，允许编辑图像渲染链。

setParameters(Object[]) - Method in class java.util.logging. LogRecord

将参数设置为日志消息。

setParameters(Vector<Object>) - Method in class java.awt.image.renderable. ParameterBlock

将参数的整个Vector设置为给定的Vector。

setParent(Logger) - Method in class java.util.logging. Logger

设置此记录器的父级。

setParent(ResourceBundle) - Method in class java.util. ResourceBundle

设置此捆绑包的父捆绑包。

setParent(ActionMap) - Method in class javax.swing. ActionMap

设置这个 ActionMap的父母。

setParent(InputMap) - Method in class javax.swing. ComponentInputMap

设置父，它必须是一个 ComponentInputMap具有相同的成分作为此相关 ComponentInputMap 。

setParent(InputMap) - Method in class javax.swing. InputMap

设置这个 InputMap的父母。

setParent(View) - Method in class javax.swing.text. AsyncBoxView

设置视图的父级。

setParent(View) - Method in class javax.swing.text. ComponentView

设置子视图的父级。

setParent(View) - Method in class javax.swing.text. CompositeView

设置视图的父级。

setParent(View) - Method in class javax.swing.text. FlowView

设置视图的父级。

setParent(View) - Method in class javax.swing.text.html. BlockView

建立此视图的父视图。

setParent(View) - Method in class javax.swing.text.html. ImageView

建立此视图的父视图。

setParent(View) - Method in class javax.swing.text.html. ParagraphView

建立此视图的父视图。

setParent(View) - Method in class javax.swing.text. View

建立此视图的父视图。

setParent(MutableTreeNode) - Method in class javax.swing.tree. DefaultMutableTreeNode

将此节点的父节点设置为 newParent但不会更改父节点的子数组。

setParent(MutableTreeNode) - Method in interface javax.swing.tree. MutableTreeNode

将接收者的父节点设置为 newParent 。

setParent(XMLEventReader) - Method in class javax.xml.stream.util. EventReaderDelegate

设置此实例的父级。

setParent(XMLStreamReader) - Method in class javax.xml.stream.util. StreamReaderDelegate

设置此实例的父级。

setParent(Node) - Method in class javax.xml.crypto.dsig.dom. DOMSignContext

设置父节点。

setParent(XMLReader) - Method in class org.xml.sax.helpers. XMLFilterImpl

设置父级阅读器。

setParent(XMLReader) - Method in interface org.xml.sax. XMLFilter

设置父级阅读器。

setParentElement(SOAPElement) - Method in interface javax.xml.soap. Node

将此 Node对象的父对象设置为给定的 SOAPElement对象。

setParentMenu(Menu) - Method in class javafx.scene.control. MenuItem

设置属性parentMenu的值。

setParentPopup(ContextMenu) - Method in class javafx.scene.control. MenuItem

设置属性parentPopup的值。

setParseBigDecimal(boolean) - Method in class java.text. DecimalFormat

设置 DecimalFormat.parse(java.lang.String, java.text.ParsePosition)方法是否返回 BigDecimal 。

setParseIntegerOnly(boolean) - Method in class java.text. NumberFormat

设置是否仅将数字解析为整数。

setParser(HTMLEditorKit.Parser) - Method in class javax.swing.text.html. HTMLDocument

将插入html的方法使用的解析器设置为现有文档，如 setInnerHTML和 setOuterHTML 。

setPartialReturn(boolean) - Method in class javax.swing.text. Segment

标记表示部分退货有效。

setPassword(char[]) - Method in class javax.security.auth.callback. PasswordCallback

设置检索到的密码。

setPassword(String) - Method in class javax.sql.rowset. BaseRowSet

设置用于为给定的 String对象的此 RowSet对象创建数据库连接的密码。

setPassword(String) - Method in interface javax.sql. RowSet

将此 RowSet对象的数据库密码设置为给定的 String 。

setPath(String) - Method in class java.net. HttpCookie

指定客户端应该返回cookie的cookie的路径。

setPath(Shape) - Method in class javafx.animation. PathTransition

设置属性路径的值。

setPathFactory(StandardJavaFileManager.PathFactory) - Method in interface javax.tools. StandardJavaFileManager

指定可用于从字符串或一系列字符串生成路径的工厂。

setPathToNames(Collection<List<?>>) - Method in class java.security.cert. X509CertSelector

设置pathToNames条件。

setPatternSeparator(char) - Method in class java.text. DecimalFormatSymbols

设置用于在模式中分离正和负子模式的字符。

setPause(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的pause属性定义。

setPauseAfter(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的pause-after属性定义。

setPauseBefore(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的pause-before属性定义。

setPayload(Object, JAXBContext) - Method in interface javax.xml.ws. LogicalMessage

设置消息有效载荷

setPayload(Source) - Method in interface javax.xml.ws. LogicalMessage

设置消息有效载荷

setPendingCount(int) - Method in class java.util.concurrent. CountedCompleter

将待处理计数设置为给定值。

setPercent(char) - Method in class java.text. DecimalFormatSymbols

设置用于百分号的字符。

setPercentHeight(double) - Method in class javafx.scene.layout. RowConstraints

设置属性percentHeight的值。

setPercentWidth(double) - Method in class javafx.scene.layout. ColumnConstraints

设置属性percentWidth的值。

setPerformancePreferences(int, int, int) - Method in class java.net. ServerSocket

设置此ServerSocket的性能首选项。

setPerformancePreferences(int, int, int) - Method in class java.net. Socket

设置此套接字的性能首选项。

setPerformancePreferences(int, int, int) - Method in class java.net. SocketImpl

设置此套接字的性能首选项。

setPeriod(Duration) - Method in class javafx.concurrent. ScheduledService

设置属性周期的值。

setPerMill(char) - Method in class java.text. DecimalFormatSymbols

设置每个mille标志使用的字符。

setPermissions(AclEntryPermission...) - Method in class java.nio.file.attribute. AclEntry.Builder

设置此构建器的权限组件。

setPermissions(Set<AclEntryPermission>) - Method in class java.nio.file.attribute. AclEntry.Builder

设置此构建器的权限组件。

setPermissions(Set<PosixFilePermission>) - Method in interface java.nio.file.attribute. PosixFileAttributeView

更新文件权限。

setPersistenceDelegate(Class<?>, PersistenceDelegate) - Method in class java.beans. Encoder

将指定的持久性委托与给定类型关联。

setPickOnBounds(boolean) - Method in class javafx.scene. Node

设置属性pickOnBounds的值。

setPieValue(double) - Method in class javafx.scene.chart. PieChart.Data

设置属性pieValue的值。

setPitch(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的音高属性定义。

setPitchBend(int) - Method in interface javax.sound.midi. MidiChannel

更改此通道上所有音符的音高偏移量。

setPitchRange(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的音高范围属性定义。

setPivotX(double) - Method in class javafx.scene.transform. Rotate

设置属性pivotX的值。

setPivotX(double) - Method in class javafx.scene.transform. Scale

设置属性pivotX的值。

setPivotX(double) - Method in class javafx.scene.transform. Shear

设置属性pivotX的值。

setPivotY(double) - Method in class javafx.scene.transform. Rotate

设置属性pivotY的值。

setPivotY(double) - Method in class javafx.scene.transform. Scale

设置属性pivotY的值。

setPivotY(double) - Method in class javafx.scene.transform. Shear

设置属性pivotY的值。

setPivotZ(double) - Method in class javafx.scene.transform. Rotate

设置属性pivotZ的值。

setPivotZ(double) - Method in class javafx.scene.transform. Scale

设置属性pivotZ的值。

setPixel(int, int, double[]) - Method in class java.awt.image. WritableRaster

在DataBuffer中使用双重样本数组来设置像素。

setPixel(int, int, double[], DataBuffer) - Method in class java.awt.image. SampleModel

在DataBuffer中使用双重样本数组来设置像素。

setPixel(int, int, float[]) - Method in class java.awt.image. WritableRaster

使用用于输入的样本的浮点数组来设置DataBuffer中的像素。

setPixel(int, int, float[], DataBuffer) - Method in class java.awt.image. SampleModel

使用用于输入的样本的浮点数组来设置DataBuffer中的像素。

setPixel(int, int, int[]) - Method in class java.awt.image. WritableRaster

使用int数组的样本数据来设置DataBuffer中的一个像素。

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. BandedSampleModel

使用int数组的样本数据来设置DataBuffer中的一个像素。

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. ComponentSampleModel

在 DataBuffer使用int数组的样本设置输入的像素。

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. MultiPixelPackedSampleModel

使用 int数组设置 DataBuffer的像素进行输入。

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. SampleModel

使用int数组的样本数据来设置DataBuffer中的一个像素。

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

使用int数组的样本数据来设置DataBuffer中的一个像素。

setPixels(int, int, int, int, double[]) - Method in class java.awt.image. WritableRaster

从包含每个数组元素一个样本的双数组中设置一个像素矩形的所有样本。

setPixels(int, int, int, int, double[], DataBuffer) - Method in class java.awt.image. SampleModel

从包含每个数组元素一个样本的双数组中设置一个像素矩形的所有样本。

setPixels(int, int, int, int, float[]) - Method in class java.awt.image. WritableRaster

从包含每个数组元素一个样本的浮点数组设置一个像素矩形的所有样本。

setPixels(int, int, int, int, float[], DataBuffer) - Method in class java.awt.image. SampleModel

从包含每个数组元素一个样本的浮点数组设置一个像素矩形的所有样本。

setPixels(int, int, int, int, int[]) - Method in class java.awt.image. WritableRaster

从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. BandedSampleModel

从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. ComponentSampleModel

从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SampleModel

从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image. AreaAveragingScaleFilter

将传送的字节像素的组件合并到累加数组中，并发送完整像素行的任何平均数据。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image. BufferedImageFilter

过滤 ImageConsumer接口中提供的 setPixels方法中提供的信息，该接口采用字节数组。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image. CropImageFilter

确定所传送的字节像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in interface java.awt.image. ImageConsumer

通过一次或多次调用该方法来提供图像的像素。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image. ImageFilter

过滤ImageConsumer接口的setPixels方法中提供的信息，该接口采用字节数组。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image. PixelGrabber

setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image. ReplicateScaleFilter

选择目标缩放图像所需的传送字节像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image. RGBImageFilter

如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image. AreaAveragingScaleFilter

将传递的int像素的组件合并到累积数组中，并发送完整像素行的任何平均数据。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image. BufferedImageFilter

过滤器在所提供的信息 setPixels所述的方法 ImageConsumer接口这需要一个整数数组。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image. CropImageFilter

确定所传递的int像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in interface java.awt.image. ImageConsumer

使用对setPixels方法的一个或多个调用来传送图像的像素。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image. ImageFilter

对ImageConsumer接口的setPixels方法中提供的信息进行过滤，该接口采用整数数组。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image. PixelGrabber

setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image. ReplicateScaleFilter

选择目标缩放图像需要交付的int像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image. RGBImageFilter

如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递，否则将整数像素的缓冲区转换为默认的RGB ColorModel，并将转换后的缓冲区传递给filterRGBPixels方法进行转换一个

setPixels(int, int, int, int, PixelFormat<ByteBuffer>, byte[], int, int) - Method in interface javafx.scene.image. PixelWriter

将来自字节数组的像素数据存储到表面的矩形区域中。

setPixels(int, int, int, int, PixelFormat<IntBuffer>, int[], int, int) - Method in interface javafx.scene.image. PixelWriter

将来自int数组的像素数据存储到表面的矩形区域中。

setPixels(int, int, int, int, PixelFormat<T>, T, int) - Method in interface javafx.scene.image. PixelWriter

将像素数据从缓冲区存储到表面的矩形区域。

setPixels(int, int, int, int, PixelReader, int, int) - Method in interface javafx.scene.image. PixelWriter

将从 PixelReader实例检索的像素数据存储到表面的矩形区域中。

setPlaceholder(String) - Method in class javax.swing.text. MaskFormatter

如果值未完全填写掩码，则设置要使用的字符串。

setPlaceholder(Node) - Method in class javafx.scene.control. ComboBox

设置属性占位符的值。

setPlaceholder(Node) - Method in class javafx.scene.control. ListView

设置属性占位符的值。

setPlaceholder(Node) - Method in class javafx.scene.control. TableView

设置属性占位符的值。

setPlaceholder(Node) - Method in class javafx.scene.control. TreeTableView

设置属性占位符的值。

setPlaceholderCharacter(char) - Method in class javax.swing.text. MaskFormatter

设置要使用的字符代替值中不存在的字符，即用户必须填写它们。

setPlain(boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

将值设置为 newValue ，具有设置的内存语义，就像该变量被声明为非 volatile和非 final 。

setPlain(int) - Method in class java.util.concurrent.atomic. AtomicInteger

将值设置为 newValue ，具有设置的内存语义，就好像变量被声明为非 volatile final 。

setPlain(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。

setPlain(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile final 。

setPlain(int, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

将索引 i为 newValue的元素设置为 newValue ，其内存语义设置为该变量被声明为非 volatile和非 final 。

setPlain(long) - Method in class java.util.concurrent.atomic. AtomicLong

将值设置为 newValue ，具有设置的内存语义，就像该变量被声明为非 volatile和非 final 。

setPlain(V) - Method in class java.util.concurrent.atomic. AtomicReference

将值设置为 newValue ，具有设置的内存语义，就像该变量被声明为非 volatile和非 final 。

setPlayDuring(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的play-during属性定义。

setPointsAtX(double) - Method in class javafx.scene.effect. Light.Spot

设置属性pointsAtX的值。

setPointsAtY(double) - Method in class javafx.scene.effect. Light.Spot

设置属性点的值。

setPointsAtZ(double) - Method in class javafx.scene.effect. Light.Spot

设置属性点AtZ的值。

setPolicy(Policy) - Static method in class java.security. Policy

设置系统范围的Policy对象。

setPolicy(Set<String>) - Method in class java.security.cert. X509CertSelector

设置策略约束。

setPolicy(Policy) - Static method in class javax.security.auth. Policy

已过时。

设置系统范围的Policy对象。

setPolicyMappingInhibited(boolean) - Method in class java.security.cert. PKIXParameters

设置PolicyMappingInhibited标志。

setPolicyQualifiersRejected(boolean) - Method in class java.security.cert. PKIXParameters

设置PolicyQualifiersRejected标志。

setPolyPressure(int, int) - Method in interface javax.sound.midi. MidiChannel

反映指定笔记的关键压力的变化。

setPoolable(boolean) - Method in interface java.sql. Statement

请求汇集或不汇集 Statement 。

setPopupMenu(PopupMenu) - Method in class java.awt. TrayIcon

设置这个 TrayIcon的弹出菜单。

setPopupMenuVisible(boolean) - Method in class javax.swing. JMenu

设置菜单弹出窗口的可见性。

setPopupSide(Side) - Method in class javafx.scene.control. MenuButton

设置属性popupSide的值。

setPopupSize(int, int) - Method in class javax.swing. JPopupMenu

将Popup窗口的大小设置为指定的宽度和高度。

setPopupSize(Dimension) - Method in class javax.swing. JPopupMenu

使用 Dimension对象设置弹出窗口的大小。

setPopupVisible(boolean) - Method in class javax.swing. JComboBox

设置弹出窗口的可见性。

setPopupVisible(JComboBox<?>, boolean) - Method in class javax.swing.plaf.basic. BasicComboBoxUI

隐藏弹出窗口。

setPopupVisible(JComboBox<?>, boolean) - Method in class javax.swing.plaf. ComboBoxUI

设置弹出窗口的可见性

setPopupVisible(JComboBox<?>, boolean) - Method in class javax.swing.plaf.multi. MultiComboBoxUI

在此对象处理的每个UI上调用 setPopupVisible方法。

setPort(int) - Method in class java.net. DatagramPacket

设置发送此数据报的远程主机上的端口号。

setPortlist(String) - Method in class java.net. HttpCookie

指定cookie的端口列表，该端口列表限制Cookie可以在Cookie头中发回的端口。

setPosition(double) - Method in class javafx.scene.chart. Axis.TickMark

设置属性位置的值。

setPosition(double) - Method in class javafx.scene.control.skin. VirtualFlow

设置属性位置的值。

setPosition(double) - Method in class javafx.scene.control. SplitPane.Divider

设置属性位置的值。

setPosition(int) - Method in class java.awt.font. LineBreakMeasurer

设置这个 LineBreakMeasurer的当前位置。

setPosition(Component, int) - Method in class javax.swing. JLayeredPane

将组件移动到其当前层中的 position ，其中0是层内的最高位置，-1是最底层的位置。

setPosition(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的position属性定义。

setPositivePrefix(String) - Method in class java.text. DecimalFormat

设置正前缀。

setPositiveSuffix(String) - Method in class java.text. DecimalFormat

设置正后缀。

setPosixFilePermissions(Path, Set<PosixFilePermission>) - Static method in class java.nio.file. Files

设置文件的POSIX权限。

setPrecision(int, int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将存储在指定列中的值中的十进制数字的总数设置为给定的数字。

setPrecision(int, int) - Method in interface javax.sql. RowSetMetaData

将指定列的十进制数字数设置为给定的 int 。

setPredicate(Predicate<? super E>) - Method in class javafx.collections.transformation. FilteredList

设置属性谓词的值。

setPrefColumnCount(int) - Method in class javafx.scene.control. TextArea

设置属性prefColumnCount的值。

setPrefColumnCount(int) - Method in class javafx.scene.control. TextField

设置属性prefColumnCount的值。

setPrefColumns(int) - Method in class javafx.scene.layout. TilePane

设置属性prefColumns的值。

setPreferencesHandler(PreferencesHandler) - Method in class java.awt. Desktop

安装一个处理程序来显示应用程序的自定义首选项窗口。

setPreferred(boolean) - Method in class java.beans. FeatureDescriptor

“首选”标志用于识别对人类呈现特别重要的特征。

setPreferredMinSize(Dimension) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置首选的最小尺寸。

setPreferredScrollableViewportSize(Dimension) - Method in class javax.swing. JTable

设置此表的视口的首选大小。

setPreferredSize(Dimension) - Method in class java.awt. Component

将此组件的首选大小设置为常量值。

setPreferredSize(Dimension) - Method in class javax.swing. JComponent

设置此组件的首选大小。

setPreferredWidth(int) - Method in class javax.swing.table. TableColumn

将此列的首选宽度设置为 preferredWidth 。

setPrefHeight(double) - Method in class javafx.scene.control. PopupControl

用于覆盖控件计算的首选高度的属性。

setPrefHeight(double) - Method in class javafx.scene.layout. Region

设置属性prefHeight的值。

setPrefHeight(double) - Method in class javafx.scene.layout. RowConstraints

设置属性prefHeight的值。

setPrefHeight(double) - Method in class javafx.scene.web. WebView

设置属性prefHeight的值。

setPrefix(String) - Method in class javax.imageio.metadata. IIOMetadataNode

不支持命名空间，

setPrefix(String) - Method in interface org.w3c.dom. Node

该节点的命名空间前缀，如果未指定， null 。

setPrefix(String, String) - Method in interface javax.xml.stream. XMLEventWriter

设置uri所绑定的前缀。

setPrefix(String, String) - Method in interface javax.xml.stream. XMLStreamWriter

设置uri所绑定的前缀。

setPrefRowCount(int) - Method in class javafx.scene.control. TextArea

设置属性prefRowCount的值。

setPrefRows(int) - Method in class javafx.scene.layout. TilePane

设置属性prefRows的值。

setPrefSize(double, double) - Method in class javafx.scene.control. PopupControl

用于覆盖控件计算的首选宽度和高度的便捷方法。

setPrefSize(double, double) - Method in class javafx.scene.layout. Region

覆盖区域计算的首选宽度和高度的便捷方法。

setPrefSize(double, double) - Method in class javafx.scene.web. WebView

设置首选宽度和高度的便利方法。

setPrefTileHeight(double) - Method in class javafx.scene.layout. TilePane

设置属性prefTileHeight的值。

setPrefTileWidth(double) - Method in class javafx.scene.layout. TilePane

设置属性prefTileWidth的值。

setPrefViewportHeight(double) - Method in class javafx.scene.control. ScrollPane

设置属性prefViewportHeight的值。

setPrefViewportWidth(double) - Method in class javafx.scene.control. ScrollPane

设置属性prefViewportWidth的值。

setPrefWidth(double) - Method in class javafx.scene.control. PopupControl

覆盖控件计算的首选宽度的属性。

setPrefWidth(double) - Method in class javafx.scene.control. TableColumnBase

设置属性prefWidth的值。

setPrefWidth(double) - Method in class javafx.scene.layout. ColumnConstraints

设置属性prefWidth的值。

setPrefWidth(double) - Method in class javafx.scene.layout. Region

设置属性prefWidth的值。

setPrefWidth(double) - Method in class javafx.scene.web. WebView

设置属性prefWidth的值。

setPrefWrapLength(double) - Method in class javafx.scene.layout. FlowPane

设置属性prefWrapLength的值。

setPrelinkTransformer(GuardedInvocationTransformer) - Method in class jdk.dynalink. DynamicLinkerFactory

设置预连接变压器。

setPreserveRatio(boolean) - Method in class javafx.scene.image. ImageView

设置属性preserveRatio的值。

setPreserveRatio(boolean) - Method in class javafx.scene.media. MediaView

设置缩放时是否保留媒体宽高比。

setPreservesUnknownTags(boolean) - Method in class javax.swing.text.html. HTMLDocument

确定解析器如何处理未知标签。

setPressed(boolean) - Method in class javafx.scene. Node

设置按下的属性的值。

setPressed(boolean) - Method in interface javax.swing. ButtonModel

将按钮设置为按下或未按下。

setPressed(boolean) - Method in class javax.swing. DefaultButtonModel

将按钮设置为按下或未按下。

setPressed(boolean) - Method in class javax.swing. JToggleButton.ToggleButtonModel

设置切换按钮的按下状态。

setPressedIcon(Icon) - Method in class javax.swing. AbstractButton

设置按钮的按下图标。

setPreviewPanel(JComponent) - Method in class javax.swing. JColorChooser

设置当前预览面板。

setPreviousBounds(JInternalFrame, Rectangle) - Method in class javax.swing. DefaultDesktopManager

在最大化调用之前存储组件的边界。

setPrimaryType(String) - Method in class javax.activation. MimeType

将此对象的主要类型设置为给定的String。

setPrincipal(UserPrincipal) - Method in class java.nio.file.attribute. AclEntry.Builder

设置此构建器的主要组件。

setPrincipal(Principal) - Method in interface java.security.acl. AclEntry

已过时。

指定此ACL条目授予或拒绝权限的主体。

setPrintable(Printable) - Method in class java.awt.print. PrinterJob

致电 painter以呈现页面。

setPrintable(Printable, PageFormat) - Method in class java.awt.print. PrinterJob

致电 painter以指定 format的页面。

setPrintColor(PrintColor) - Method in class javafx.print. JobSettings

设置 PrintColor属性。

setPrinter(String) - Method in class java.awt. JobAttributes

使用这些属性指定作业的目标打印机。

setPrinter(Printer) - Method in class javafx.print. PrinterJob

更改此作业的打印机。

setPrinterResolution(int) - Method in class java.awt. PageAttributes

使用这些属性为页面指定所需的交叉进给和每英寸点数的进纸打印分辨率。

setPrinterResolution(int[]) - Method in class java.awt. PageAttributes

使用这些属性为页面指定所需的打印分辨率。

setPrinterResolutionToDefault() - Method in class java.awt. PageAttributes

将使用这些属性的页面的打印机分辨率设置为默认值。

setPrintFileHandler(PrintFilesHandler) - Method in class java.awt. Desktop

安装在应用程序被要求打印文件列表时通知的处理程序。

setPrintQuality(int) - Method in class java.awt. PageAttributes

使用这些属性指定页面的打印质量。

setPrintQuality(PageAttributes.PrintQualityType) - Method in class java.awt. PageAttributes

使用这些属性指定页面的打印质量。

setPrintQuality(PrintQuality) - Method in class javafx.print. JobSettings

设置 PrintQuality属性。

setPrintQualityToDefault() - Method in class java.awt. PageAttributes

将使用这些属性的页面的打印质量设置为默认值。

setPrintResolution(PrintResolution) - Method in class javafx.print. JobSettings

设置 PrintResolution属性。

setPrintService(PrintService) - Method in class java.awt.print. PrinterJob

将此PrinterJob与新的PrintService相关联。

setPrintSides(PrintSides) - Method in class javafx.print. JobSettings

设置控制双面打印的 PrintSides属性。

setPrioritizedLinker(GuardingDynamicLinker) - Method in class jdk.dynalink. DynamicLinkerFactory

设置单个优先级链接器。

setPrioritizedLinkers(List<? extends GuardingDynamicLinker>) - Method in class jdk.dynalink. DynamicLinkerFactory

设置优先级的守护动态链接器。

setPrioritizedLinkers(GuardingDynamicLinker...) - Method in class jdk.dynalink. DynamicLinkerFactory

设置优先级的守护动态链接器。

setPriority(int) - Method in class java.lang. Thread

更改此线程的优先级。

setPriority(int) - Method in class javafx.scene.media. AudioClip

设置默认播放优先级。

setPrivacy(boolean) - Method in class org.ietf.jgss. MessageProp

设置隐私状态。

setPrivateKeyValid(Date) - Method in class java.security.cert. X509CertSelector

设置privateKeyValid条件。

setProblemType(int) - Method in class javax.management.relation. RoleUnresolved

设置问题类型。

setProcessors(Iterable<? extends Processor>) - Method in interface javax.tools. JavaCompiler.CompilationTask

设置处理器（用于注释处理）。

setProfile(String) - Method in interface org.w3c.dom.html. HTMLHeadElement

setProgress(double) - Method in class javafx.scene.control. ProgressIndicator

设置属性进度的值。

setProgress(int) - Method in class javax.swing. ProgressMonitor

指示正在监控的操作进度。

setProgress(int) - Method in class javax.swing. SwingWorker

设置 progress绑定属性。

setProgressiveMode(int) - Method in class javax.imageio. ImageWriteParam

指定写入器将以逐行模式写入图像，以使流包含一系列增加质量的扫描。

setProgressValue(int) - Method in class java.awt. Taskbar

在该应用程序的图标上贴上一个小系统提供的进度条。

setPrompt(String) - Method in interface org.w3c.dom.html. HTMLIsIndexElement

setPromptHandler(Callback<PromptData, String>) - Method in class javafx.scene.web. WebEngine

设置属性promptHandler的值。

setPromptText(String) - Method in class javafx.scene.control. ComboBoxBase

设置属性promptText的值。

setPromptText(String) - Method in class javafx.scene.control. Spinner

设置属性promptText的值。

setPromptText(String) - Method in class javafx.scene.control. TextInputControl

设置属性promptText的值。

setPromptTextFill(Paint) - Method in class javafx.scene.control.skin. TextInputControlSkin

填充 Paint用于前景提示文字颜色。

setPropagatedFrom(BeanContext) - Method in class java.beans.beancontext. BeanContextEvent

设置传播此事件的 BeanContext 。

setPropagationId(Object) - Method in class java.beans. PropertyChangeEvent

设置事件的propagationId对象。

setProperties(Hashtable<?, ?>) - Method in class java.awt.image. CropImageFilter

在添加指定裁剪区域的属性后，沿着源对象的属性传递。

setProperties(Hashtable<?, ?>) - Method in interface java.awt.image. ImageConsumer

设置与此映像关联的属性的可扩展列表。

setProperties(Hashtable<?, ?>) - Method in class java.awt.image. ImageFilter

在添加一个指示已经运行的过滤器流的属性之后，从源对象传递属性。

setProperties(Hashtable<?, ?>) - Method in class java.awt.image. PixelGrabber

setProperties方法是ImageConsumer API的一部分，该类必须实现以检索像素。

setProperties(Hashtable<?, ?>) - Method in class java.awt.image. ReplicateScaleFilter

在添加指示应用比例的属性后，沿着属性从源对象传递。

setProperties(Map<String, Object>) - Method in class javax.xml.ws. Endpoint

设置此 Endpoint实例的属性包。

setProperties(Properties) - Static method in class java.lang. System

将系统属性设置为 Properties参数。

setPropertiesFromAttributes() - Method in class javax.swing.text.html. BlockView

更新来自属性的任何缓存值。

setPropertiesFromAttributes() - Method in class javax.swing.text.html. ImageView

更新来自属性的任何缓存值。

setPropertiesFromAttributes() - Method in class javax.swing.text.html. InlineView

从属性设置缓存的属性。

setPropertiesFromAttributes() - Method in class javax.swing.text.html. ListView

setPropertiesFromAttributes() - Method in class javax.swing.text.html. ParagraphView

从css属性设置段落，而不是在StyleConstants中找到的值（即超类使用的值）。

setPropertiesFromAttributes() - Method in class javax.swing.text. LabelView

从属性设置缓存的属性。

setPropertiesFromAttributes() - Method in class javax.swing.text. ParagraphView

从属性设置缓存的属性。

setProperty(String, Object) - Method in class javax.xml.bind. Binder

在底层实现中设置特定属性 Binder 。

setProperty(String, Object) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

setProperty方法的默认实现处理Marshaller中四个定义的属性。

setProperty(String, Object) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

setProperty方法的默认实现总是抛出PropertyException，因为没有必需的属性。

setProperty(String, Object) - Method in interface javax.xml.bind. Marshaller

在底层实现中设置特定属性 Marshaller 。

setProperty(String, Object) - Method in interface javax.xml.bind. Unmarshaller

在底层实现中设置特定属性 Unmarshaller 。

setProperty(String, Object) - Method in interface javax.xml.bind. Validator

已过时。
自JAXB2.0起

setProperty(String, Object) - Method in class javax.xml.crypto.dom. DOMCryptoContext

此实现使用内部HashMap将名称映射到指定的对象。

setProperty(String, Object) - Method in interface javax.xml.crypto. XMLCryptoContext

设置指定的属性。

setProperty(String, Object) - Method in class javax.xml.parsers. SAXParser

设置底层实现中的特定属性XMLReader 。

setProperty(String, Object) - Method in class javax.xml.soap. SOAPMessage

将指定的值与指定的属性相关联。

setProperty(String, Object) - Method in class javax.xml.stream. XMLInputFactory

允许用户在底层实现上设置特定的功能/属性。

setProperty(String, Object) - Method in class javax.xml.stream. XMLOutputFactory

允许用户在底层实现上设置特定的功能/属性。

setProperty(String, Object) - Method in class javax.xml.validation. SchemaFactory

设置属性的值。

setProperty(String, Object) - Method in class javax.xml.validation. Validator

设置属性的值。

setProperty(String, Object) - Method in class javax.xml.validation. ValidatorHandler

设置属性的值。

setProperty(String, Object) - Method in class org.xml.sax.helpers. ParserAdapter

设置解析器属性。

setProperty(String, Object) - Method in class org.xml.sax.helpers. XMLFilterImpl

设置属性的值。

setProperty(String, Object) - Method in interface org.xml.sax. XMLReader

设置属性的值。

setProperty(String, String) - Static method in class java.lang. System

设置由指定键指示的系统属性。

setProperty(String, String) - Static method in class java.security. Security

设置安全属性值。

setProperty(String, String) - Method in class java.util. Properties

调用 Hashtable方法 put 。

setProperty(String, String) - Method in class jdk.security.jarsigner. JarSigner.Builder

设置由指定键指示的附加实现特定属性。

setProperty(String, String, String) - Method in interface org.w3c.dom.css. CSSStyleDeclaration

用于在此声明块中设置属性值和优先级。

SetProperty< E> - Class in javafx.beans.property

这个类提供了一个Property的全面实现，包装了一个ObservableSet 。

SetProperty() - Constructor for class javafx.beans.property. SetProperty

SetPropertyBase< E> - Class in javafx.beans.property

类SetPropertyBase是包含一个ObservableSet的属性的基类。

SetPropertyBase() - Constructor for class javafx.beans.property. SetPropertyBase

构造函数 SetPropertyBase

SetPropertyBase(ObservableSet<E>) - Constructor for class javafx.beans.property. SetPropertyBase

SetPropertyBase的构造 SetPropertyBase 。

setPropertyEditorClass(Class<?>) - Method in class java.beans. PropertyDescriptor

通常使用PropertyEditorManager可以找到PropertyEditors。

setProto(Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

设置此对象的__proto__。

setProtocols(String[]) - Method in class com.sun.net.httpserver. HttpsParameters

设置协议数组。

setProtocols(String[]) - Method in class javax.net.ssl. SSLParameters

设置协议数组。

setPrototypeCellValue(E) - Method in class javax.swing. JList

设置 prototypeCellValue属性，然后（如果新值为 non-null ），则通过从单元格渲染器请求单元格渲染器组件给定值（和索引0），并使用该组件的首选大小来计算 fixedCellWidth和 fixedCellHeight属性。

setPrototypeDisplayValue(E) - Method in class javax.swing. JComboBox

设置用于计算UI部分显示大小的原型显示值。

setPublicId(String) - Method in class javax.xml.transform.stream. StreamSource

设置此源的公共标识符。

setPublicId(String) - Method in interface org.w3c.dom.ls. LSInput

该输入源的公共标识符。

setPublicId(String) - Method in class org.xml.sax.helpers. LocatorImpl

设置此定位器的公共标识符。

setPublicId(String) - Method in class org.xml.sax. InputSource

设置此输入源的公共标识符。

setPublicKey(PublicKey) - Method in class java.security. Identity

已过时。

设置此身份的公钥。

setPurgeFlag(boolean) - Method in class javax.management.relation. RelationService

设置标志以指示是否在关系中引用的MBean注销的通知被接收，如果必须立即执行关系的“清除”（寻找关系不再有效），或者如果将只有当purgeRelations方法被显式调用时才执行。

setPurgeFlag(boolean) - Method in interface javax.management.relation. RelationServiceMBean

设置标志以指示是否在关系中引用的MBean注销的通知被接收，如果必须立即执行关系的“清除”（寻找关系不再有效），或者如果将仅当显式调用purgeRelations方法时执行。

setPushLevel(Level) - Method in class java.util.logging. MemoryHandler

设置 pushLevel 。

setQName(int, String) - Method in class org.xml.sax.helpers. AttributesImpl

设置特定属性的限定名称。

setQOP(int) - Method in class org.ietf.jgss. MessageProp

设置QOP值。

setQueryTimeout(int) - Method in interface java.sql. Statement

设置驱动程序等待 Statement对象执行到给定秒数的秒数。

setQueryTimeout(int) - Method in class javax.sql.rowset. BaseRowSet

将给定的数字设置为驱动程序等待查询执行的最大秒数。

setQueryTimeout(int) - Method in interface javax.sql. RowSet

设置驱动程序等待语句执行到给定秒数的最长时间。

setQuitHandler(QuitHandler) - Method in class java.awt. Desktop

安装处理程序，确定应用程序是否应该退出。

setQuitStrategy(QuitStrategy) - Method in class java.awt. Desktop

设置用于退出此应用程序的默认策略。

setQuotes(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的引号属性定义。

setRadius(double) - Method in class javafx.scene.effect. DropShadow

设置属性半径的值。

setRadius(double) - Method in class javafx.scene.effect. GaussianBlur

设置属性半径的值。

setRadius(double) - Method in class javafx.scene.effect. InnerShadow

设置属性半径的值。

setRadius(double) - Method in class javafx.scene.effect. MotionBlur

设置属性半径的值。

setRadius(double) - Method in class javafx.scene.effect. Shadow

设置属性半径的值。

setRadius(double) - Method in class javafx.scene.shape. Circle

设置属性半径的值。

setRadius(double) - Method in class javafx.scene.shape. Cylinder

设置属性半径的值。

setRadius(double) - Method in class javafx.scene.shape. Sphere

设置属性半径的值。

setRadiusX(double) - Method in class javafx.scene.shape. Arc

设置属性radiusX的值。

setRadiusX(double) - Method in class javafx.scene.shape. ArcTo

设置属性radiusX的值。

setRadiusX(double) - Method in class javafx.scene.shape. Ellipse

设置属性radiusX的值。

setRadiusY(double) - Method in class javafx.scene.shape. Arc

设置属性radiusY的值。

setRadiusY(double) - Method in class javafx.scene.shape. ArcTo

设置属性radiusY的值。

setRadiusY(double) - Method in class javafx.scene.shape. Ellipse

设置属性radiusY的值。

setRange(int, int) - Method in class javafx.scene.control. TextFormatter.Change

一种将起始值和结束值分配在一起的方法，以确保它们相对于彼此有效。

setRange(Object, boolean) - Method in class javafx.scene.chart. Axis

调用将当前轴范围设置为给定范围。

setRange(Object, boolean) - Method in class javafx.scene.chart. CategoryAxis

调用将当前轴范围设置为给定范围。

setRange(Object, boolean) - Method in class javafx.scene.chart. NumberAxis

调用将当前轴范围设置为给定范围。

setRangeProperties(int, int, int, int, boolean) - Method in interface javax.swing. BoundedRangeModel

该方法通过单个方法调用来设置所有模型的数据。

setRangeProperties(int, int, int, int, boolean) - Method in class javax.swing. DefaultBoundedRangeModel

在强制参数遵循通常的约束之后，设置所有 BoundedRangeModel属性：

setRaster(Raster) - Method in class javax.imageio. IIOImage

设置当前的 Raster 。

setRate(double) - Method in class javafx.animation. Animation

设置属性率的值。

setRate(double) - Method in class javafx.scene.media. AudioClip

设置默认回放速率。

setRate(double) - Method in class javafx.scene.media. MediaPlayer

将播放速度设置为提供的值。

setRawCommentText(String) - Method in interface com.sun.javadoc. Doc

已过时。

设置注释的完整未处理文本。

setRawContent(InputStream, String) - Method in class javax.xml.soap. AttachmentPart

将此附件部分以使得由包含的内容 InputStream content并设定的值 Content-Type头中所包含的值 contentType 。

setRawContentBytes(byte[], int, int, String) - Method in class javax.xml.soap. AttachmentPart

将此附件部分以使得由包含的内容 byte[]阵列 content并设置的值 Content-Type头中所包含的值 contentType 。

setRawOffset(int) - Method in class java.util. SimpleTimeZone

将基准时区偏移设置为GMT。

setRawOffset(int) - Method in class java.util. TimeZone

将基准时区偏移设置为GMT。

setRawResult(Void) - Method in class java.util.concurrent. RecursiveAction

需要空完成值。

setRawResult(T) - Method in class java.util.concurrent. CountedCompleter

带有CountedCompleters结果的方法可以可选地用于帮助维护结果数据。

setRawResult(V) - Method in class java.util.concurrent. ForkJoinTask

强制给定的值作为结果返回。

setRawResult(V) - Method in class java.util.concurrent. RecursiveTask

setReadable(boolean) - Method in class java.io. File

一种方便的方法来设置所有者对此抽象路径名的读取权限。

setReadable(boolean, boolean) - Method in class java.io. File

设置此抽象路径名的所有者或每个人的读取权限。

setReader(Reader) - Method in interface javax.script. ScriptContext

为脚本设置 Reader以读取输入。

setReader(Reader) - Method in class javax.script. SimpleScriptContext

设置脚本的 Reader以读取输入。

setReader(Reader) - Method in class javax.xml.transform.stream. StreamSource

将输入设置为字符读取器。

setReadMethod(Method) - Method in class java.beans. PropertyDescriptor

设置应用于读取属性值的方法。

setReadOnly() - Method in class java.io. File

标记由此抽象路径名命名的文件或目录，以便只允许读取操作。

setReadOnly() - Method in class java.security. PermissionCollection

将此PermissionCollection对象标记为“只读”。

setReadOnly() - Method in class javax.security.auth. Subject

将此 Subject设置为只读。

setReadOnly(boolean) - Method in interface java.nio.file.attribute. DosFileAttributeView

更新只读属性的值。

setReadOnly(boolean) - Method in interface java.sql. Connection

将此连接设置为只读模式，作为驱动程序的提示以启用数据库优化。

setReadOnly(boolean) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的readOnly属性设置为给定的 boolean 。

setReadOnly(boolean) - Method in interface javax.sql. RowSet

设置此 RowSet对象是否为只读给定的 boolean 。

setReadOnly(boolean) - Method in interface org.w3c.dom.html. HTMLInputElement

setReadOnly(boolean) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setReadTimeout(int) - Method in class java.net. URLConnection

将读取超时设置为指定的超时时间，以毫秒为单位。

setReadUnknownTags(boolean) - Method in class javax.imageio.plugins.tiff. TIFFImageReadParam

设置是否读取对应于 TIFFTag的字段不在允许的 TIFFTagSet 。

setReceiveBufferSize(int) - Method in class java.net. DatagramSocket

将SO_RCVBUF选项设置为此 DatagramSocket的指定值。

setReceiveBufferSize(int) - Method in class java.net. ServerSocket

设置从这个 ServerSocket接受的套接字的 SO_RCVBUF选项的默认建议值。

setReceiveBufferSize(int) - Method in class java.net. Socket

设置 SO_RCVBUF选项，此规定值 Socket 。

setReceiver(Receiver) - Method in interface javax.sound.midi. Transmitter

设置发送器将传送MIDI信息的接收器。

setRect(double, double, double, double) - Method in class java.awt.geom. Rectangle2D.Double

将此 Rectangle2D的位置和大小设置为指定的 double值。

setRect(double, double, double, double) - Method in class java.awt.geom. Rectangle2D.Float

将此 Rectangle2D的位置和大小设置为指定的 double值。

setRect(double, double, double, double) - Method in class java.awt.geom. Rectangle2D

将此 Rectangle2D的位置和大小设置为指定的 double值。

setRect(double, double, double, double) - Method in class java.awt. Rectangle

设置此的边界 Rectangle为整数范围，其包含指定的 x ， y ， width ，和 height 。

setRect(float, float, float, float) - Method in class java.awt.geom. Rectangle2D.Float

将此 Rectangle2D的位置和大小设置为指定的 float值。

setRect(int, int, Raster) - Method in class java.awt.image. WritableRaster

将像素从Raster srcRaster复制到WritableRaster。

setRect(Rectangle2D) - Method in class java.awt.geom. Rectangle2D.Double

将此 Rectangle2D设置为与指定的 Rectangle2D相同。

setRect(Rectangle2D) - Method in class java.awt.geom. Rectangle2D.Float

将此 Rectangle2D设置为与指定的 Rectangle2D相同。

setRect(Rectangle2D) - Method in class java.awt.geom. Rectangle2D

将此 Rectangle2D设置为与指定的 Rectangle2D相同。

setRect(Raster) - Method in class java.awt.image. WritableRaster

将像素从Raster srcRaster复制到WritableRaster。

setRef(int, Ref) - Method in interface java.sql. PreparedStatement

将指定参数设置为给定的 REF(<structured-type>)值。

setRef(int, Ref) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中给定的 Ref对象。

setRef(int, Ref) - Method in interface javax.sql. RowSet

使用给定的 Ref值在此 RowSet对象的命令中设置指定的参数。

setRef(RemoteStub, RemoteRef) - Static method in class java.rmi.server. RemoteStub

已过时。
没有替换 setRef方法用于设置远程存根的远程引用。 这是不必要的，因为RemoteStub可以创建和通过使用的远程引用初始化小号RemoteStub(RemoteRef)构造。

setRegion(String) - Method in class java.util. Locale.Builder

设置区域。

setRejectedExecutionHandler(RejectedExecutionHandler) - Method in class java.util.concurrent. ThreadPoolExecutor

为不可执行的任务设置一个新的处理程序。

setRel(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setRel(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setRelationServiceManagementFlag(Boolean) - Method in class javax.management.relation. RelationSupport

setRelationServiceManagementFlag(Boolean) - Method in interface javax.management.relation. RelationSupportMBean

指定该关系是否由关系服务处理。

setRelative(boolean) - Method in class javax.naming. NameClassPair

设置此绑定的名称是否相对于目标上下文（由 list()方法的第一个参数命名）。

setRelay(boolean) - Method in interface javax.xml.soap. SOAPHeaderElement

将此 SOAPHeaderElement的 中继属性设置为true或false。

setRelease(boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean

将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。

setRelease(int) - Method in class java.util.concurrent.atomic. AtomicInteger

将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。

setRelease(int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray

将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。

setRelease(int, long) - Method in class java.util.concurrent.atomic. AtomicLongArray

将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。

setRelease(int, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray

将索引 i为 newValue的元素设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。

setRelease(long) - Method in class java.util.concurrent.atomic. AtomicLong

将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。

setRelease(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值设置为 newValue ，并确保先前的加载和存储在此访问后不重新排序。

setRelease(V) - Method in class java.util.concurrent.atomic. AtomicReference

将值设置为 newValue ，具有 VarHandle.setRelease(java.lang.Object...)指定的内存效果。

setRemainingName(Name) - Method in exception javax.naming. NamingException

设置此异常的剩余名称字段。

setRemainingName(Name) - Method in class javax.naming.spi. ResolveResult

将此结果的剩余名称字段设置为名称。

setRemainingNewName(Name) - Method in exception javax.naming. CannotProceedException

设置此异常的“剩余新名称”字段。

setRemoveOnCancelPolicy(boolean) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

设置取消时取消任务是否应立即从工作队列中删除的策略。

setRenderContext(RenderContext) - Method in class java.awt.image.renderable. RenderableImageProducer

设置一个新的RenderContext用于下一个startProduction（）调用。

setRenderedImage(RenderedImage) - Method in class javax.imageio. IIOImage

设置当前的 RenderedImage 。

setRenderer(ListCellRenderer<? super E>) - Method in class javax.swing. JComboBox

设置绘制列表项目的渲染器和从JComboBox字段中的列表中选择的项目。

setRenderingHint(RenderingHints.Key, Object) - Method in class java.awt. Graphics2D

为渲染算法设置单个首选项的值。

setRenderingHints(RenderingHints) - Method in class java.awt.image.renderable. RenderContext

设置这个 RenderContext的渲染提示。

setRenderingHints(Map<?, ?>) - Method in class java.awt. Graphics2D

用指定的 hints替换渲染算法的所有首选项的值。

setRenderScaleX(double) - Method in class javafx.stage. Window

设置属性renderScaleX的值。

setRenderScaleY(double) - Method in class javafx.stage. Window

设置属性renderScaleY的值。

setReorderable(boolean) - Method in class javafx.scene.control. TableColumnBase

设置属性可重新排序的值。

setReorderingAllowed(boolean) - Method in class javax.swing.table. JTableHeader

设置用户是否可以拖动列标题来重新排列列。

setRepeats(boolean) - Method in class javax.swing. Timer

如果 flag为 false ，则指示 Timer仅向其侦听器发送一个操作事件。

setRequestControls(Control[]) - Method in class javax.naming.ldap. InitialLdapContext

setRequestControls(Control[]) - Method in interface javax.naming.ldap. LdapContext

设置随后在此上下文中调用的方法的请求控件。

setRequestFocusEnabled(boolean) - Method in class javax.swing. JComponent

提供这个 JComponent是否应该获得关注的提示。

setRequestMethod(String) - Method in class java.net. HttpURLConnection

设置URL请求的方法，其中之一是：GET POST HEAD OPTIONS PUT DELETE TRACE是符合协议限制的合法的。

setRequestProperty(String, String) - Method in class java.net. URLConnection

设置一般请求属性。

setReshowDelay(int) - Method in class javax.swing. ToolTipManager

用于指定用户在显示工具提示之前必须等待 initialDelay毫秒的时间量。

setResizable(boolean) - Method in class java.awt. Dialog

设置用户是否可以调整此对话框的大小。

setResizable(boolean) - Method in class java.awt. Frame

设置该框架是否可以由用户调整大小。

setResizable(boolean) - Method in class javafx.scene.control. Dialog

设置对话框是否可以由用户调整大小。

setResizable(boolean) - Method in class javafx.scene.control. TableColumnBase

设置属性可调整大小的值。

setResizable(boolean) - Method in class javafx.stage. Stage

设置属性可调整大小的值。

setResizable(boolean) - Method in class javax.swing. JInternalFrame

设置 JInternalFrame是否可以通过某些用户操作调整大小。

setResizable(boolean) - Method in class javax.swing.table. TableColumn

设置是否可以调整此列的大小。

setResizableWithParent(Node, Boolean) - Static method in class javafx.scene.control. SplitPane

在SplitPane调整大小时，将SplitPane中的节点设置为可调整大小。

setResizeWeight(double) - Method in class javax.swing. JSplitPane

指定当拆分窗格的大小更改时如何分配额外的空间。

setResizingAllowed(boolean) - Method in class javax.swing.table. JTableHeader

设置用户是否可以通过在标题之间拖动来调整列的大小。

setResizingColumn(TableColumn) - Method in class javax.swing.table. JTableHeader

将标题的 resizingColumn设置为 aColumn 。

setResolvedName(Name) - Method in exception javax.naming. NamingException

设置此异常的已解析名称字段。

setResolvedObj(Object) - Method in exception javax.naming. NamingException

设置此异常的已解析对象字段。

setResolvedObj(Object) - Method in class javax.naming.spi. ResolveResult

将此结果的已解析对象字段设置为obj。

setResolvedValue(int, Object) - Method in interface javax.sql.rowset.spi. SyncResolver

将 obj设置为正在同步的 RowSet对象的当前行中的列 索引中的值。

setResolvedValue(String, Object) - Method in interface javax.sql.rowset.spi. SyncResolver

将 obj设置为正在同步的 RowSet对象的当前行中的列 columnName中的值。

setResolveParent(AttributeSet) - Method in class javax.swing.text. AbstractDocument.AbstractElement

设置解析父项。

setResolveParent(AttributeSet) - Method in interface javax.swing.text. MutableAttributeSet

设置解析父项。

setResolveParent(AttributeSet) - Method in class javax.swing.text. SimpleAttributeSet

设置解析父项。

setResolveParent(AttributeSet) - Method in class javax.swing.text. StyleContext.NamedStyle

设置解析父项。

setResolveParent(Keymap) - Method in interface javax.swing.text. Keymap

设置父密钥映射，将用于解析密钥绑定。

setResourceBaseName(String) - Method in class javax.imageio.metadata. IIOMetadataFormatImpl

设置一个新的基本名称，用于定位包含此格式的元素和属性说明的 ResourceBundle 。

setResourceBundle(ResourceBundle) - Method in class java.util.logging. Logger

在此记录器上设置资源包。

setResourceBundle(ResourceBundle) - Method in class java.util.logging. LogRecord

设置本地化资源包。

setResourceBundleName(String) - Method in class java.util.logging. LogRecord

设置本地化资源包名称。

setResourceResolver(LSResourceResolver) - Method in class javax.xml.validation. SchemaFactory

设置LSResourceResolver以在解析模式时自定义资源分辨率。

setResourceResolver(LSResourceResolver) - Method in class javax.xml.validation. Validator

设置LSResourceResolver以在验证集中定制资源分辨率。

setResourceResolver(LSResourceResolver) - Method in class javax.xml.validation. ValidatorHandler

设置LSResourceResolver以在验证集中定制资源分辨率。

setResources(ResourceBundle) - Method in class javafx.fxml. FXMLLoader

设置用于解析资源密钥属性值的资源。

setRestartOnFailure(boolean) - Method in class javafx.concurrent. ScheduledService

设置属性restartOnFailure的值。

setResult(Class<T>) - Method in interface java.sql. SQLXML

返回一个用于设置此SQLXML实例指定的XML值的结果。

setResult(Result) - Method in interface javax.xml.transform.sax. TransformerHandler

设置与此 Result关联的 TransformerHandler用于转换。

setResult(R) - Method in class javafx.scene.control. Dialog

设置属性结果的值。

setResultConverter(Callback<ButtonType, R>) - Method in class javafx.scene.control. Dialog

设置属性resultConverter的值。

setReturningAttributes(String[]) - Method in class javax.naming.directory. SearchControls

指定将作为搜索的一部分返回的属性。

setReturningObjFlag(boolean) - Method in class javax.naming.directory. SearchControls

启用/禁用作为结果一部分返回的返回对象。

setReuseAddress(boolean) - Method in class java.net. DatagramSocket

启用/禁用SO_REUSEADDR套接字选项。

setReuseAddress(boolean) - Method in class java.net. ServerSocket

启用/禁用 SO_REUSEADDR套接字选项。

setReuseAddress(boolean) - Method in class java.net. Socket

启用/禁用 SO_REUSEADDR套接字选项。

setRev(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setRev(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setRevocationEnabled(boolean) - Method in class java.security.cert. PKIXParameters

设置RevocationEnabled标志。

setRGB(int, int, int) - Method in class java.awt.image. BufferedImage

将此 BufferedImage的像素设置为指定的RGB值。

setRGB(int, int, int, int, int[], int, int) - Method in class java.awt.image. BufferedImage

将默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素数组设置为图像数据的一部分。

setRichness(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的richness属性定义。

setRight(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的正确的属性定义。

setRight(Node) - Method in class javafx.scene.layout. BorderPane

设置属性的值。

setRightAnchor(Node, Double) - Static method in class javafx.scene.layout. AnchorPane

为锚定窗格包含的小孩设置正确的锚点。

setRightChildIndent(int) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置正确的子项缩进。

setRightComponent(Component) - Method in class javax.swing. JSplitPane

将组件设置在右侧（或更低）分隔线。

setRightIndent(MutableAttributeSet, float) - Static method in class javax.swing.text. StyleConstants

设置正确的缩进。

setRightInset(float) - Method in class javax.swing.text. AsyncBoxView

在视图周围设置边框的正确部分。

setRole(String) - Method in interface javax.xml.soap. SOAPHeaderElement

将与此 SOAPHeaderElement对象关联的 Role设置为指定的 Role 。

setRole(String, Role) - Method in class javax.management.relation. RelationService

在给定的关系中设定给定的角色。

setRole(String, Role) - Method in interface javax.management.relation. RelationServiceMBean

在给定的关系中设定给定的角色。

setRole(Role) - Method in interface javax.management.relation. Relation

设置给定的角色。

setRole(Role) - Method in class javax.management.relation. RelationSupport

设置给定的角色。

setRoleName(String) - Method in class javax.management.relation. Role

设置角色名称。

setRoleName(String) - Method in class javax.management.relation. RoleUnresolved

设置角色名称。

setRoles(String, RoleList) - Method in class javax.management.relation. RelationService

在给定的关系中设定给定的角色。

setRoles(String, RoleList) - Method in interface javax.management.relation. RelationServiceMBean

在给定的关系中设定给定的角色。

setRoles(Set<String>) - Method in interface javax.xml.ws.soap. SOAPBinding

设置SOAP绑定实例扮演的角色。

setRoles(RoleList) - Method in interface javax.management.relation. Relation

设置给定的角色。

setRoles(RoleList) - Method in class javax.management.relation. RelationSupport

设置给定的角色。

setRoles(RoleList) - Method in class javax.management.relation. RoleResult

设置成功访问的角色列表。

setRolesUnresolved(RoleUnresolvedList) - Method in class javax.management.relation. RoleResult

设置未成功访问的角色列表。

setRoleValue(List<ObjectName>) - Method in class javax.management.relation. Role

设置角色值。

setRoleValue(List<ObjectName>) - Method in class javax.management.relation. RoleUnresolved

设置角色值。

setRollover(boolean) - Method in interface javax.swing. ButtonModel

设置或清除按钮的翻转状态

setRollover(boolean) - Method in class javax.swing. DefaultButtonModel

设置或清除按钮的翻转状态

setRollover(boolean) - Method in class javax.swing. JToolBar

设置此工具栏的翻转状态。

setRolloverBorders(boolean) - Method in class javax.swing.plaf.basic. BasicToolBarUI

设置在工具栏上启用滚动边框的标志，并且还将根据标志的状态安装适当的边框。

setRolloverEnabled(boolean) - Method in class javax.swing. AbstractButton

设置 rolloverEnabled属性，必须是 true才能发生翻转效果。

setRolloverIcon(Icon) - Method in class javax.swing. AbstractButton

设置按钮的翻转图标。

setRolloverSelectedIcon(Icon) - Method in class javax.swing. AbstractButton

设置按钮的滚动选择图标。

setRolloverTab(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

将鼠标目前的标签设置为 index 。

setRolloverTab(int) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI

将鼠标目前的标签设置为 index 。

setRoot(Object) - Method in class javafx.fxml. FXMLLoader

设置对象层次结构的根。

setRoot(TreeItem<S>) - Method in class javafx.scene.control. TreeTableView

设置此TreeTableView中的根节点。

setRoot(TreeItem<T>) - Method in class javafx.scene.control. TreeView

设置此TreeView中的根节点。

setRoot(Parent) - Method in class javafx.scene. Scene

设置属性根的值。

setRoot(Parent) - Method in class javafx.scene. SubScene

设置属性根的值。

setRoot(TreeNode) - Method in class javax.swing.tree. DefaultTreeModel

将根设置为 root 。

setRootCause(Throwable) - Method in exception javax.naming. NamingException

记录此NamingException的根本原因。

setRootFrame(Frame) - Static method in class javax.swing. JOptionPane

将框架设置为不提供框架的类方法。

setRootPane(JRootPane) - Method in class javax.swing. JApplet

已过时。

设置rootPane属性。

setRootPane(JRootPane) - Method in class javax.swing. JDialog

设置 rootPane属性。

setRootPane(JRootPane) - Method in class javax.swing. JFrame

设置 rootPane属性。

setRootPane(JRootPane) - Method in class javax.swing. JInternalFrame

为此 JInternalFrame设置 rootPane属性。

setRootPane(JRootPane) - Method in class javax.swing. JWindow

为此窗口设置新的 rootPane对象。

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing. JApplet

已过时。

设置是否将呼叫 add和 setLayout转发到 contentPane 。

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing. JDialog

设置是否向 add转发到 add和 setLayout的 contentPane 。

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing. JFrame

设置是否向 add转发到 add和 setLayout的 contentPane 。

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing. JInternalFrame

设置是否将呼叫 add和 setLayout转发到 contentPane 。

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing. JWindow

设置是否向 add转发到 add和 setLayout的 contentPane 。

setRootVisible(boolean) - Method in class javax.swing. JTree

确定来自 TreeModel是否可见。

setRootVisible(boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI

将根设置为可见。

setRootVisible(boolean) - Method in class javax.swing.tree. AbstractLayoutCache

确定来自 TreeModel是否可见。

setRootVisible(boolean) - Method in class javax.swing.tree. FixedHeightLayoutCache

确定TreeModel中的根节点是否可见。

setRootVisible(boolean) - Method in class javax.swing.tree. VariableHeightLayoutCache

确定来自 TreeModel是否可见。

setRotate(double) - Method in class javafx.scene. Node

设置属性rotate的值。

setRotateGraphic(boolean) - Method in class javafx.scene.control. TabPane

指定Tab中的图形是否旋转，使其始终是直立的，或者以与Tab文本相同的方式旋转。

setRotationAxis(Point3D) - Method in class javafx.scene. Node

设置属性rotateAxis的值。

setRoundingMode(RoundingMode) - Method in class java.text. DecimalFormat

设置此DecimalFormat中使用的RoundingMode 。

setRoundingMode(RoundingMode) - Method in class java.text. NumberFormat

设置此NumberFormat中使用的RoundingMode 。

setRoundRect(double, double, double, double, double, double) - Method in class java.awt.geom. RoundRectangle2D.Double

将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。

setRoundRect(double, double, double, double, double, double) - Method in class java.awt.geom. RoundRectangle2D.Float

将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。

setRoundRect(double, double, double, double, double, double) - Method in class java.awt.geom. RoundRectangle2D

将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。

setRoundRect(float, float, float, float, float, float) - Method in class java.awt.geom. RoundRectangle2D.Float

将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 float值。

setRoundRect(RoundRectangle2D) - Method in class java.awt.geom. RoundRectangle2D.Double

将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。

setRoundRect(RoundRectangle2D) - Method in class java.awt.geom. RoundRectangle2D.Float

将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。

setRoundRect(RoundRectangle2D) - Method in class java.awt.geom. RoundRectangle2D

将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。

setRowCount(int) - Method in class javax.swing.table. DefaultTableModel

设置模型中的行数。

setRowFactory(Callback<TableView<S>, TableRow<S>>) - Method in class javafx.scene.control. TableView

设置属性rowFactory的值。

setRowFactory(Callback<TreeTableView<S>, TreeTableRow<S>>) - Method in class javafx.scene.control. TreeTableView

设置属性rowFactory的值。

setRowFilter(RowFilter<? super M, ? super I>) - Method in class javax.swing. DefaultRowSorter

设置过滤器，确定哪些行（如果有）应从视图中隐藏。

setRowHeader(JViewport) - Method in class javax.swing. JScrollPane

删除旧的行阅读器（如果存在） 如果新的rowHeader不是null ，则将其viewPosition的y坐标与视口同步（如果有），然后将其添加到滚动窗格。

setRowHeaderView(Component) - Method in class javax.swing. JScrollPane

如果需要，创建行标题视口，设置其视图，然后将行标题视口添加到滚动条。

setRowHeight(int) - Method in class javax.swing. JTable

将所有单元格的高度（以像素为单位）设置为 rowHeight ，重新验证和重新绘制。

setRowHeight(int) - Method in class javax.swing. JTree

设置每个单元格的高度（以像素为单位）。

setRowHeight(int) - Method in class javax.swing.plaf.basic. BasicTreeUI

设置行高，将其转发到treeState。

setRowHeight(int) - Method in class javax.swing.tree. AbstractLayoutCache

设置每个单元格的高度。

setRowHeight(int) - Method in class javax.swing.tree. FixedHeightLayoutCache

设置每个单元格的高度。

setRowHeight(int) - Method in class javax.swing.tree. VariableHeightLayoutCache

设置每个单元格的高度。

setRowHeight(int, int) - Method in class javax.swing. JTable

将 row的高度设置为 rowHeight ，重新验证和重新绘制。

setRowId(int, RowId) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.sql.RowId对象。

setRowId(int, RowId) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.RowId对象。

setRowId(int, RowId) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.RowId对象。

setRowId(String, RowId) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.sql.RowId对象。

setRowId(String, RowId) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.RowId对象。

setRowId(String, RowId) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.RowId对象。

setRowIndex(Node, Integer) - Static method in class javafx.scene.layout. GridPane

设置子窗格的行索引，当窗格包含时，它将从网格的该行开始定位。

setRowMapper(RowMapper) - Method in class javax.swing. JTree.EmptySelectionModel

这样做是无效的 EmptySelectionModel不允许进行选择。

setRowMapper(RowMapper) - Method in class javax.swing.tree. DefaultTreeSelectionModel

设置RowMapper实例。

setRowMapper(RowMapper) - Method in interface javax.swing.tree. TreeSelectionModel

设置RowMapper实例。

setRowMargin(int) - Method in class javax.swing. JTable

设置相邻行中的单元格之间的空白空间量。

setRows(int) - Method in class java.awt. GridLayout

将此布局中的行数设置为指定的值。

setRows(int) - Method in class java.awt. TextArea

设置此文本区域的行数。

setRows(int) - Method in class javax.swing. JTextArea

设置此TextArea的行数。

setRows(int) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setRows(String) - Method in interface org.w3c.dom.html. HTMLFrameSetElement

setRowSelectionAllowed(boolean) - Method in class javax.swing. JTable

设置是否可以选择此模型中的行。

setRowSelectionInterval(int, int) - Method in class javax.swing. JTable

选择从 index0到 index1 （包括）的行。

setRowSorter(RowSorter<? extends TableModel>) - Method in class javax.swing. JTable

设置 RowSorter 。

setRowSpan(int) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setRowSpan(Node, Integer) - Static method in class javafx.scene.layout. GridPane

设置子窗格包含的格子行的行跨度，以便它垂直跨越该行数。

setRowValignment(VPos) - Method in class javafx.scene.layout. FlowPane

设置属性rowValignment的值。

setRules(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setSample(int, int, int, double) - Method in class java.awt.image. WritableRaster

对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。

setSample(int, int, int, double, DataBuffer) - Method in class java.awt.image. BandedSampleModel

对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。

setSample(int, int, int, double, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

对于位于 DataBuffer中（x，y）处的像素的指定带中的 DataBuffer使用双倍的输入。

setSample(int, int, int, double, DataBuffer) - Method in class java.awt.image. SampleModel

对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。

setSample(int, int, int, float) - Method in class java.awt.image. WritableRaster

使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。

setSample(int, int, int, float) - Method in class javafx.scene.effect. FloatMap

在给定（x，y）位置设置特定频段的样本。

setSample(int, int, int, float, DataBuffer) - Method in class java.awt.image. BandedSampleModel

使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。

setSample(int, int, int, float, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

为 DataBuffer位于（x，y）处的像素的指定波段设置采样，使用浮点输入。

setSample(int, int, int, float, DataBuffer) - Method in class java.awt.image. SampleModel

使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。

setSample(int, int, int, int) - Method in class java.awt.image. WritableRaster

使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image. BandedSampleModel

使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image. ComponentSampleModel

在 DataBuffer中的位置（x，y）处的像素的指定频带中设置一个样本，使用int作为输入。

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image. MultiPixelPackedSampleModel

在 DataBuffer使用 int设置位于（x，y）处的像素的指定频带中的样本。

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image. SampleModel

使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。

setSamples(int, int, float) - Method in class javafx.scene.effect. FloatMap

在给定（x，y）位置设置第一个频带的样本。

setSamples(int, int, float, float) - Method in class javafx.scene.effect. FloatMap

在给定（x，y）位置设置前两个频带的样本。

setSamples(int, int, float, float, float) - Method in class javafx.scene.effect. FloatMap

在给定（x，y）位置设置前三个频带的样本。

setSamples(int, int, float, float, float, float) - Method in class javafx.scene.effect. FloatMap

在给定（x，y）位置设置四个频带中的每个频带的样本。

setSamples(int, int, int, int, int, double[]) - Method in class java.awt.image. WritableRaster

从包含每个数组元素一个样本的双阵列的像素的指定矩形中设置样本。

setSamples(int, int, int, int, int, double[], DataBuffer) - Method in class java.awt.image. SampleModel

从包含每个数组元素一个样本的双阵列的像素的指定矩形中设置样本。

setSamples(int, int, int, int, int, float[]) - Method in class java.awt.image. WritableRaster

从包含每个数组元素一个样本的浮点数组中为指定的像素矩形设置指定带中的样本。

setSamples(int, int, int, int, int, float[], DataBuffer) - Method in class java.awt.image. SampleModel

从包含每个数组元素一个样本的浮点数组中为指定的像素矩形设置指定带中的样本。

setSamples(int, int, int, int, int, int[]) - Method in class java.awt.image. WritableRaster

从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. BandedSampleModel

从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. ComponentSampleModel

从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SampleModel

从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image. SinglePixelPackedSampleModel

从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。

setSaturation(double) - Method in class javafx.scene.effect. ColorAdjust

设置属性饱和度的值。

setSavepoint() - Method in interface java.sql. Connection

在当前事务中创建一个未命名的保存点，并返回代表它的新的 Savepoint对象。

setSavepoint(String) - Method in interface java.sql. Connection

在当前事务中创建具有给定名称的保存点，并返回表示它的新的 Savepoint对象。

setScale(double) - Method in class javafx.scene.chart. ValueAxis

设置属性比例的值。

setScale(int) - Method in class java.math. BigDecimal

返回一个 BigDecimal其缩放比例是指定值，其值在数字上等于 BigDecimal 。

setScale(int, int) - Method in class java.math. BigDecimal

已过时。
应该优先使用方法BigDecimal.setScale(int, RoundingMode) 。

setScale(int, int) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将存储在指定列中的值中的小数点右边的位数设置为给定的数字。

setScale(int, int) - Method in interface javax.sql. RowSetMetaData

将指定列的小数点右侧的位数设置为给定的 int 。

setScale(int, RoundingMode) - Method in class java.math. BigDecimal

返回一个 BigDecimal其尺度是指定值，其缩放值通过将该 BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。

setScaleShape(boolean) - Method in class javafx.scene.layout. Region

设置属性scaleShape的值。

setScaleX(double) - Method in class javafx.scene.effect. DisplacementMap

设置属性scaleX的值。

setScaleX(double) - Method in class javafx.scene. Node

设置属性scaleX的值。

setScaleY(double) - Method in class javafx.scene.effect. DisplacementMap

设置属性scaleY的值。

setScaleY(double) - Method in class javafx.scene. Node

设置属性scaleY的值。

setScaleZ(double) - Method in class javafx.scene. Node

设置属性scaleZ的值。

setScene(Scene) - Method in class javafx.embed.swing. JFXPanel

附加一个 Scene对象显示在这个 JFXPanel 。

setScene(Scene) - Method in class javafx.stage. PopupWindow

注意子类：PopupWindow使用的场景是非常具体由PopupWindow管理的。

setScene(Scene) - Method in class javafx.stage. Stage

指定此舞台上要使用的场景。

setScene(Scene) - Method in class javafx.stage. Window

设置属性场景的值。

setSchema(String) - Method in interface java.sql. Connection

设置要访问的给定模式名称。

setSchema(Schema) - Method in class javax.xml.bind. Binder

指定marshal，unmarshal和update方法是否对其XML内容执行验证。

setSchema(Schema) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

setSchema(Schema) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

setSchema(Schema) - Method in interface javax.xml.bind. Marshaller

指定应用于验证后续元组操作的JAXP 1.3 Schema对象。

setSchema(Schema) - Method in interface javax.xml.bind. Unmarshaller

指定应用于验证后续解组操作的JAXP 1.3 Schema对象。

setSchema(Schema) - Method in class javax.xml.parsers. DocumentBuilderFactory

将Schema设置为由此工厂创建的解析器使用。

setSchema(Schema) - Method in class javax.xml.parsers. SAXParserFactory

将Schema设置为由此工厂创建的解析器使用。

setSchemaLocation(String) - Method in class javax.xml.bind.helpers. AbstractMarshallerImpl

设置schemaLocation的便利方法。

setSchemaName(int, String) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将指定列的表的模式名称（如果有）设置为 schemaName 。

setSchemaName(int, String) - Method in interface javax.sql. RowSetMetaData

将指定列的表的模式（如果有）的名称设置为给定的 String 。

setScheme(String) - Method in interface org.w3c.dom.html. HTMLMetaElement

setScope(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setScope(String, MessageContext.Scope) - Method in interface javax.xml.ws.handler. MessageContext

设置属性的范围。

setScript(String) - Method in class java.util. Locale.Builder

设置脚本。

setScrollByBlock(boolean) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.ScrollListener

设置按块滚动

setScrollByBlock(boolean) - Method in class javax.swing.plaf.basic. BasicSliderUI.ScrollListener

按块滚动

setScrolling(String) - Method in interface org.w3c.dom.html. HTMLFrameElement

setScrolling(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setScrollLeft(double) - Method in class javafx.scene.control. TextArea

设置属性scrollLeft的值。

setScrollMode(int) - Method in class javax.swing. JViewport

用于控制滚动视口内容的方法。

setScrollOffset(int) - Method in class javax.swing. JTextField

设置滚动偏移量，以像素为单位。

setScrollPosition(int, int) - Method in class java.awt. ScrollPane

滚动到子组件中的指定位置。

setScrollPosition(Point) - Method in class java.awt. ScrollPane

滚动到子组件中的指定位置。

setScrollsOnExpand(boolean) - Method in class javax.swing. JTree

设置 scrollsOnExpand属性，它决定树可能滚动以显示以前隐藏的子项。

setScrollTop(double) - Method in class javafx.scene.control. TextArea

设置属性scrollTop的值。

setSearchable(int, boolean) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置在给定的 boolean值的 WHERE子句中是否可以使用存储在指定列中的值。

setSearchable(int, boolean) - Method in interface javax.sql. RowSetMetaData

设置指定的列是否可以在where子句中使用。

setSearchScope(int) - Method in class javax.naming.directory. SearchControls

将搜索范围设置为以下之一：OBJECT_SCOPE，ONELEVEL_SCOPE，SUBTREE_SCOPE。

setSecond(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置秒

setSeconds(int) - Method in class java.sql. Date

已过时。

setSeconds(int) - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.set(Calendar.SECOND, int seconds)替代。

setSecure(boolean) - Method in class java.net. HttpCookie

指示Cookie是否应仅使用安全协议（如HTTPS或SSL）发送。

setSecurityManager(SecurityManager) - Static method in class java.lang. System

设置系统安全性。

setSeed(byte[]) - Method in class java.security. SecureRandom

用给定的种子重新设定这个随机对象。

setSeed(long) - Method in class java.security. SecureRandom

使用给定的 long seed包含的八个字节来重新设置此随机对象。

setSeed(long) - Method in class java.util.concurrent. ThreadLocalRandom

投掷 UnsupportedOperationException 。

setSeed(long) - Method in class java.util. Random

使用单个 long种子设置该随机数生成器的种子。

setSelected(boolean) - Method in class javafx.scene.control. CheckBox

设置所选属性的值。

setSelected(boolean) - Method in class javafx.scene.control. CheckBoxTreeItem

设置此CheckBoxTreeItem的选定状态。

setSelected(boolean) - Method in class javafx.scene.control. CheckMenuItem

设置所选属性的值。

setSelected(boolean) - Method in class javafx.scene.control. RadioMenuItem

设置所选属性的值。

setSelected(boolean) - Method in interface javafx.scene.control. Toggle

将此 Toggle设置为选定或未选择。

setSelected(boolean) - Method in class javafx.scene.control. ToggleButton

设置所选属性的值。

setSelected(boolean) - Method in class javax.swing. AbstractButton

设置按钮的状态。

setSelected(boolean) - Method in interface javax.swing. ButtonModel

选择或取消选择按钮。

setSelected(boolean) - Method in class javax.swing. DefaultButtonModel

选择或取消选择按钮。

setSelected(boolean) - Method in class javax.swing. JInternalFrame

如果显示内部框架，请选择或取消选择。

setSelected(boolean) - Method in class javax.swing. JMenu

设置菜单的选择状态。

setSelected(boolean) - Method in class javax.swing. JToggleButton.ToggleButtonModel

设置按钮的选定状态。

setSelected(boolean) - Method in interface org.w3c.dom.html. HTMLOptionElement

setSelected(Component) - Method in class javax.swing. JMenuBar

设置当前选择的组件，产生对选择模型的更改。

setSelected(Component) - Method in class javax.swing. JPopupMenu

设置当前选择的组件，这将导致选择模型的更改。

setSelected(ButtonModel, boolean) - Method in class javax.swing. ButtonGroup

设置 ButtonModel的选定值。

setSelectedCheckbox(Checkbox) - Method in class java.awt. CheckboxGroup

将此组中当前选中的复选框设置为指定的复选框。

setSelectedColor(Color) - Method in interface javax.swing.colorchooser. ColorSelectionModel

将所选颜色设置为 color 。

setSelectedColor(Color) - Method in class javax.swing.colorchooser. DefaultColorSelectionModel

将所选颜色设置为 color 。

setSelectedComponent(Component) - Method in class javax.swing. JTabbedPane

设置此选项卡窗格的选定组件。

setSelectedExtensionFilter(FileChooser.ExtensionFilter) - Method in class javafx.stage. FileChooser

设置属性selectedExtensionFilter的值。

setSelectedFile(File) - Method in class javax.swing. JFileChooser

设置所选文件。

setSelectedFiles(File[]) - Method in class javax.swing. JFileChooser

如果文件选择器设置为允许多个选择，则设置所选文件的列表。

setSelectedFrame(JInternalFrame) - Method in class javax.swing. JDesktopPane

设置当前激活的 JInternalFrame在这个 JDesktopPane 。

setSelectedIcon(Icon) - Method in class javax.swing. AbstractButton

设置按钮的选定图标。

setSelectedIndex(int) - Method in class javafx.scene.control. SelectionModel

设置属性selectedIndex的值。

setSelectedIndex(int) - Method in class javax.security.auth.callback. ChoiceCallback

设置所选择的选项。

setSelectedIndex(int) - Method in class javax.security.auth.callback. ConfirmationCallback

设置所选确认选项。

setSelectedIndex(int) - Method in class javax.swing. DefaultSingleSelectionModel

将模型的所选索引设置为 索引 。

setSelectedIndex(int) - Method in class javax.swing. JComboBox

选择索引号为 anIndex的项目。

setSelectedIndex(int) - Method in class javax.swing. JList

选择单个单元格。

setSelectedIndex(int) - Method in class javax.swing. JTabbedPane

设置此选项卡窗格的所选索引。

setSelectedIndex(int) - Method in interface javax.swing. SingleSelectionModel

将模型的所选索引设置为 索引 。

setSelectedIndex(int) - Method in interface org.w3c.dom.html. HTMLSelectElement

setSelectedIndexes(int[]) - Method in class javax.security.auth.callback. ChoiceCallback

设置所选择的选项。

setSelectedIndices(int[]) - Method in class javax.swing. JList

将选择更改为给定数组指定的索引集。

setSelectedItem(Object) - Method in interface javax.swing. ComboBoxModel

设置所选项目。

setSelectedItem(Object) - Method in class javax.swing. DefaultComboBoxModel

设置所选项目的值。

setSelectedItem(Object) - Method in class javax.swing. JComboBox

将组合框显示区域中的选定项目设置为参数中的对象。

setSelectedItem(Object) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.DirectoryComboBoxModel

setSelectedItem(Object) - Method in class javax.swing.plaf.metal. MetalFileChooserUI.FilterComboBoxModel

setSelectedItem(T) - Method in class javafx.scene.control. ChoiceDialog

设置对话框中当前选定的项目。

setSelectedItem(T) - Method in class javafx.scene.control. SelectionModel

设置属性selectedItem的值。

setSelectedPath(MenuElement[]) - Method in class javax.swing. MenuSelectionManager

更改菜单层次结构中的选择。

setSelectedStateCallback(Callback<Integer, ObservableValue<Boolean>>) - Method in class javafx.scene.control.cell. CheckBoxTableCell

设置由屏幕上显示的复选框绑定的Callback 。

setSelectedStateCallback(Callback<Integer, ObservableValue<Boolean>>) - Method in class javafx.scene.control.cell. CheckBoxTreeTableCell

设置由屏幕上显示的复选框绑定的Callback 。

setSelectedStateCallback(Callback<TreeItem<T>, ObservableValue<Boolean>>) - Method in class javafx.scene.control.cell. CheckBoxTreeCell

设置由屏幕上显示的复选框绑定的Callback 。

setSelectedStateCallback(Callback<T, ObservableValue<Boolean>>) - Method in class javafx.scene.control.cell. CheckBoxListCell

设置由屏幕上显示的复选框绑定的Callback 。

setSelectedTextColor(Color) - Method in class javax.swing.text. JTextComponent

设置用于渲染所选文本的当前颜色。

setSelectedValue(Object, boolean) - Method in class javax.swing. JList

从列表中选择指定的对象。

setSelection(boolean) - Method in class javax.swing.text.html. Option

设置所选状态。

setSelectionBackground(Color) - Method in class javax.swing. JList

设置用于绘制所选项目背景的颜色，哪些单元格渲染器可以使用填充所选单元格。

setSelectionBackground(Color) - Method in class javax.swing. JTable

设置所选单元格的背景颜色。

setSelectionColor(Color) - Method in class javax.swing.text. JTextComponent

设置用于渲染选择的当前颜色。

setSelectionEnd(int) - Method in class java.awt. TextComponent

将此文本组件的选择结束设置为指定位置。

setSelectionEnd(int) - Method in class javafx.scene.text. Text

选择内容中的最终索引。

setSelectionEnd(int) - Method in class javax.swing.text. JTextComponent

将选择结束设置为指定位置。

setSelectionFill(Paint) - Method in class javafx.scene.text. Text

设置属性selectionFill的值。

setSelectionForeground(Color) - Method in class javax.swing. JList

设置用于绘制所选项目的前景的颜色，哪些单元格渲染器可用于渲染文本和图形。

setSelectionForeground(Color) - Method in class javax.swing. JTable

设置所选单元格的前景色。

setSelectionInterval(int, int) - Method in class javax.swing. DefaultListSelectionModel

将选择更改为 index0和 index1包括）。

setSelectionInterval(int, int) - Method in class javax.swing. JList

选择指定的间隔。

setSelectionInterval(int, int) - Method in class javax.swing. JTree

选择指定间隔的行（含）。

setSelectionInterval(int, int) - Method in interface javax.swing. ListSelectionModel

将选择更改为 index0和 index1之间。

setSelectionMode(int) - Method in class javax.swing. DefaultListSelectionModel

设置选择模式。

setSelectionMode(int) - Method in class javax.swing. JList

设置列表的选择模式。

setSelectionMode(int) - Method in class javax.swing. JTable

将表的选择模式设置为仅允许单个选择，单个连续间隔或多个间隔。

setSelectionMode(int) - Method in class javax.swing. JTree.EmptySelectionModel

这样做是无效的 EmptySelectionModel不允许进行选择。

setSelectionMode(int) - Method in interface javax.swing. ListSelectionModel

设置选择模式。

setSelectionMode(int) - Method in class javax.swing.tree. DefaultTreeSelectionModel

设置选择模型，它必须是SINGLE_TREE_SELECTION，CONTIGUOUS_TREE_SELECTION或DISCONTIGUOUS_TREE_SELECTION之一。

setSelectionMode(int) - Method in interface javax.swing.tree. TreeSelectionModel

设置选择模型，它必须是SINGLE_TREE_SELECTION，CONTIGUOUS_TREE_SELECTION或DISCONTIGUOUS_TREE_SELECTION之一。

setSelectionMode(SelectionMode) - Method in class javafx.scene.control. MultipleSelectionModel

设置属性selectionMode的值。

setSelectionModel(MultipleSelectionModel<TreeItem<T>>) - Method in class javafx.scene.control. TreeView

设置要在TreeView中使用的MultipleSelectionModel 。

setSelectionModel(MultipleSelectionModel<T>) - Method in class javafx.scene.control. ListView

设置要在ListView中使用的MultipleSelectionModel 。

setSelectionModel(SingleSelectionModel<Tab>) - Method in class javafx.scene.control. TabPane

设置用于选项卡选择的模型。

setSelectionModel(SingleSelectionModel<T>) - Method in class javafx.scene.control. ChoiceBox

设置属性selectionModel的值。

setSelectionModel(SingleSelectionModel<T>) - Method in class javafx.scene.control. ComboBox

设置属性selectionModel的值。

setSelectionModel(TableView.TableViewSelectionModel<S>) - Method in class javafx.scene.control. TableView

设置属性selectionModel的值。

setSelectionModel(TreeTableView.TreeTableViewSelectionModel<S>) - Method in class javafx.scene.control. TreeTableView

设置要在TreeTableView中使用的MultipleSelectionModel 。

setSelectionModel(ColorSelectionModel) - Method in class javax.swing. JColorChooser

设置包含所选颜色的模型。

setSelectionModel(ListSelectionModel) - Method in class javax.swing. JList

将该列表的 selectionModel设置为非 null ListSelectionModel实现。

setSelectionModel(ListSelectionModel) - Method in class javax.swing. JTable

将此表的行选择模型设置为 selectionModel并从新选择模型注册侦听器通知。

setSelectionModel(ListSelectionModel) - Method in class javax.swing.table. DefaultTableColumnModel

设置此选择模型 TableColumnModel至 newModel并注册为来自新选择模型的通知。

setSelectionModel(ListSelectionModel) - Method in interface javax.swing.table. TableColumnModel

设置选择模型。

setSelectionModel(SingleSelectionModel) - Method in class javax.swing. JMenuBar

设置模型对象以处理单个选择。

setSelectionModel(SingleSelectionModel) - Method in class javax.swing. JPopupMenu

设置模型对象以处理单个选择。

setSelectionModel(TreeSelectionModel) - Method in class javax.swing. JTree

设置树的选择模型。

setSelectionModel(TreeSelectionModel) - Method in class javax.swing.plaf.basic. BasicTreeUI

重置选择模型。

setSelectionModel(TreeSelectionModel) - Method in class javax.swing.tree. AbstractLayoutCache

将用于管理选择的 TreeSelectionModel设置为新的LSM。

setSelectionPath(TreePath) - Method in class javax.swing. JTree

选择由指定路径标识的节点。

setSelectionPath(TreePath) - Method in class javax.swing.tree. DefaultTreeSelectionModel

将选择设置为路径。

setSelectionPath(TreePath) - Method in interface javax.swing.tree. TreeSelectionModel

将选择设置为路径。

setSelectionPaths(TreePath[]) - Method in class javax.swing. JTree.EmptySelectionModel

这样做是无效的 EmptySelectionModel不允许进行选择。

setSelectionPaths(TreePath[]) - Method in class javax.swing. JTree

选择由指定的路径数组标识的节点。

setSelectionPaths(TreePath[]) - Method in class javax.swing.tree. DefaultTreeSelectionModel

设置选择。

setSelectionPaths(TreePath[]) - Method in interface javax.swing.tree. TreeSelectionModel

将选择设置为路径。

setSelectionRow(int) - Method in class javax.swing. JTree

选择显示中指定行的节点。

setSelectionRows(int[]) - Method in class javax.swing. JTree

选择与显示中每个指定行对应的节点。

setSelectionStart(int) - Method in class java.awt. TextComponent

将此文本组件的选择开始设置为指定位置。

setSelectionStart(int) - Method in class javafx.scene.text. Text

选择开始索引的内容。

setSelectionStart(int) - Method in class javax.swing.text. JTextComponent

将选择开始设置为指定位置。

setSelectionValues(Object[]) - Method in class javax.swing. JOptionPane

设置为用户提供可供选择的项目列表的窗格的输入选择值。

setSelectionVisible(boolean) - Method in interface javax.swing.text. Caret

设置选择的可见性

setSelectionVisible(boolean) - Method in class javax.swing.text. DefaultCaret

更改选择的可见性。

setSelectorText(String) - Method in interface org.w3c.dom.css. CSSPageRule

规则的页面选择器的可解析文本表示。

setSelectorText(String) - Method in interface org.w3c.dom.css. CSSStyleRule

规则集的选择器的文本表示。

setSelfIlluminationMap(Image) - Method in class javafx.scene.paint. PhongMaterial

设置属性selfIlluminationMap的值。

setSendBufferSize(int) - Method in class java.net. DatagramSocket

将SO_SNDBUF选项设置为此 DatagramSocket的指定值。

setSendBufferSize(int) - Method in class java.net. Socket

设置 SO_SNDBUF选项，此规定值 Socket 。

setSendPastNotifications(boolean) - Method in class javax.management.timer. Timer

设置指示定时器是否发送过去通知的标志。

setSendPastNotifications(boolean) - Method in interface javax.management.timer. TimerMBean

设置指示定时器是否发送过去通知的标志。

setSeparatorSize(Dimension) - Method in class javax.swing. JToolBar.Separator

设置分隔符的大小。

setSequence(InputStream) - Method in interface javax.sound.midi. Sequencer

设置序列发生器工作的当前序列。

setSequence(Sequence) - Method in interface javax.sound.midi. Sequencer

设置序列发生器工作的当前序列。

setSequenceNumber(long) - Method in class java.util.logging. LogRecord

设置序列号。

setSequenceNumber(long) - Method in class javax.management. Notification

设置通知序列号。

setSerialFilter(ObjectInputFilter) - Static method in class java.io. ObjectInputFilter.Config

如果尚未配置或设置过程范围过滤器，请设置该过滤器。

setSerialNumber(BigInteger) - Method in class java.security.cert. X509CertSelector

设置serialNumber标准。

setServerNames(List<SNIServerName>) - Method in class javax.net.ssl. SSLParameters

设置服务器名称指示（SNI）参数所需的SNIServerName 。

setServiceManagerStub(ServiceManagerStub) - Static method in class javax.jnlp. ServiceManager

设置所有 lookup和 getServiceNames请求的委托对象。

setSessionCacheSize(int) - Method in interface javax.net.ssl. SSLSessionContext

设置用于存储 SSLSession对象的高速缓存的大小，分组在此 SSLSessionContext 。

setSessionTimeout(int) - Method in interface javax.net.ssl. SSLSessionContext

设置超时限制 SSLSession级这个组合的对象 SSLSessionContext 。

setSeverity(int) - Method in class javax.xml.bind.helpers. ValidationEventImpl

设置此事件的严重性字段。

setShape(Shape) - Method in class java.awt. Dialog

设置窗口的形状。

setShape(Shape) - Method in class java.awt. Frame

设置窗口的形状。

setShape(Shape) - Method in class java.awt. Window

设置窗口的形状。

setShape(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setShape(String) - Method in interface org.w3c.dom.html. HTMLAreaElement

setShape(Shape) - Method in class javafx.animation. FillTransition

设置属性形状的值。

setShape(Shape) - Method in class javafx.animation. StrokeTransition

设置属性形状的值。

setShape(Shape) - Method in class javafx.scene.layout. Region

设置属性形状的值。

setShardingKey(ShardingKey) - Method in interface java.sql. Connection

指定与此Connection一起使用的shardingKey

setShardingKey(ShardingKey, ShardingKey) - Method in interface java.sql. Connection

指定与此连接一起使用的shardingKey和superShardingKey

setShardingKeyIfValid(ShardingKey, int) - Method in interface java.sql. Connection

设置并验证此连接的分片密钥。

setShardingKeyIfValid(ShardingKey, ShardingKey, int) - Method in interface java.sql. Connection

设置并验证此连接的分片密钥。

setSharedInstance(PopupFactory) - Static method in class javax.swing. PopupFactory

设置 PopupFactory将被用于获取 Popup秒。

setShort(int, short) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java short值。

setShort(int, short) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为Java编程语言中的给定的 short 。

setShort(int, short) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java short值。

setShort(Object, int, short) - Static method in class java.lang.reflect. Array

将指定数组对象的索引组件的值设置为指定的 short值。

setShort(Object, short) - Method in class java.lang.reflect. Field

将字段的值设置为指定对象上的 short 。

setShort(String, short) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java short值。

setShort(String, short) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java short值。

setShort(String, short) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java short值。

setShortcut(MenuShortcut) - Method in class java.awt. MenuItem

设置与 MenuShortcut相关联的 MenuShortcut对象。

setShortDescription(String) - Method in class java.beans. FeatureDescriptor

您可以将简短描述性字符串与功能相关联。

setShortMonths(String[]) - Method in class java.text. DateFormatSymbols

设置短的月份字符串。

setShortWeekdays(String[]) - Method in class java.text. DateFormatSymbols

设置短周日字符串。

setShowDelay(Duration) - Method in class javafx.scene.control. Tooltip

设置属性showDelay的值。

setShowDeleted(boolean) - Method in class javax.sql.rowset. BaseRowSet

将属性 showDeleted设置为给定的 boolean值，该值确定标记为删除的行是否显示在当前行的集合中。

setShowDeleted(boolean) - Method in interface javax.sql.rowset. CachedRowSet

将属性 showDeleted设置为给定的 boolean值，该值确定标记为删除的行是否显示在当前行的集合中。

setShowDeleted(boolean) - Method in interface javax.sql.rowset. JdbcRowSet

将属性 showDeleted设置为给定的 boolean值。

setShowDropLocation(boolean) - Method in class javax.swing. TransferHandler.TransferSupport

设置丢弃位置是否应在视觉上指定用于传输 - 这必须代表一个丢弃。

setShowDuration(Duration) - Method in class javafx.scene.control. Tooltip

设置属性showDuration的值。

setShowGrid(boolean) - Method in class javax.swing. JTable

设置表格是否在单元格周围绘制网格线。

setShowHorizontalLines(boolean) - Method in class javax.swing. JTable

设置表格是否在单元格之间绘制水平线。

setShowRoot(boolean) - Method in class javafx.scene.control. TreeTableView

指定是否应在此TreeTableView中显示根 TreeItem根。

setShowRoot(boolean) - Method in class javafx.scene.control. TreeView

指定是否应在此TreeView中显示根 TreeItem根。

setShowsRootHandles(boolean) - Method in class javax.swing. JTree

设置 showsRootHandles属性的值，该属性指定是否显示节点句柄。

setShowsRootHandles(boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI

确定是否显示节点句柄。

setShowTickLabels(boolean) - Method in class javafx.scene.control. Slider

设置属性showTickLabels的值。

setShowTickMarks(boolean) - Method in class javafx.scene.control. Slider

设置属性showTickMarks的值。

setShowVerticalLines(boolean) - Method in class javax.swing. JTable

设置表格是否在单元格之间绘制垂直线。

setShowWeekNumbers(boolean) - Method in class javafx.scene.control. DatePicker

设置属性showWeekNumbers的值。

setSide(Side) - Method in class javafx.scene.chart. Axis

设置属性侧的值。

setSide(Side) - Method in class javafx.scene.control. TabPane

将标签放置在此TabPane中的位置。

setSides(JobAttributes.SidesType) - Method in class java.awt. JobAttributes

指定在使用这些属性的作业的打印介质的两侧应如何施加连续的页面。

setSidesToDefault() - Method in class java.awt. JobAttributes

设置如何使用这些属性将打印介质的两侧的连续页面施加到默认页面。

setSigned(int, boolean) - Method in class javax.sql.rowset. RowSetMetaDataImpl

设置存储在指定列中的值是否为给定的 boolean 。

setSigned(int, boolean) - Method in interface javax.sql. RowSetMetaData

设置指定的列是否是有符号的数字。

setSigners(Class<?>, Object[]) - Method in class java.lang. ClassLoader

设置一个类的签名者。

setSigProvider(String) - Method in class java.security.cert. PKIXParameters

设置签名提供者的名称。

setSize(double, double) - Method in class java.awt. Dimension

将此 Dimension对象的大小设置为双精度的指定宽度和高度。

setSize(double, double) - Method in class java.awt.geom. Dimension2D

将此 Dimension对象的大小设置为指定的宽度和高度。

setSize(double, double) - Method in class java.awt.print. Paper

设置此 Paper对象的宽度和高度，该对象表示发生打印的页面的属性。

setSize(float, float) - Method in class javax.swing.text. AsyncBoxView

设置视图的大小。

setSize(float, float) - Method in class javax.swing.text. BoxView

设置视图的大小。

setSize(float, float) - Method in class javax.swing.text.html. ImageView

设置视图的大小。

setSize(float, float) - Method in class javax.swing.text. PlainView

设置视图的大小。

setSize(float, float) - Method in class javax.swing.text. View

设置视图的大小。

setSize(float, float) - Method in class javax.swing.text. WrappedPlainView

设置视图的大小。

setSize(int) - Method in class java.util. Vector

设置此向量的大小。

setSize(int) - Method in class javax.swing. DefaultListModel

设置此列表的大小。

setSize(int) - Method in interface org.w3c.dom.html. HTMLSelectElement

setSize(int, int) - Method in class java.awt. Component

调整此组件的大小，使其宽度为 width ，高度为 height 。

setSize(int, int) - Method in class java.awt. Dimension

将此 Dimension对象的大小设置为指定的宽度和高度。

setSize(int, int) - Method in class java.awt. Rectangle

将此 Rectangle的大小设置为指定的宽度和高度。

setSize(int, int) - Method in class java.awt. Window

调整此组件的大小，使其宽度为 width ，高度为 height 。

setSize(int, int) - Method in class javax.swing. SizeSequence

设置指定条目的大小。

setSize(long) - Method in class java.util.zip. ZipEntry

设置条目数据的未压缩大小。

setSize(Dimension) - Method in class com.sun.java.accessibility.util. Translator

设置此对象的当前大小。

setSize(Dimension) - Method in class java.awt. Component.AccessibleAWTComponent

调整此对象的大小，使其具有宽度和高度。

setSize(Dimension) - Method in class java.awt. Component

调整此组件的大小，使其宽度为 d.width ，高度为 d.height 。

setSize(Dimension) - Method in class java.awt. Dimension

将此 Dimension对象的大小设置为指定的大小。

setSize(Dimension) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

调整此对象的大小，使其具有宽度和高度。

setSize(Dimension) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

调整此对象的大小。

setSize(Dimension) - Method in class java.awt. Rectangle

设置这个 Rectangle的大小以匹配指定的 Dimension 。

setSize(Dimension) - Method in class java.awt. Window

调整此组件的大小，使其宽度为 d.width ，高度为 d.height 。

setSize(Dimension) - Method in interface javax.accessibility. AccessibleComponent

调整此对象的大小，使其具有宽度和高度。

setSize(Dimension) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setSize(Dimension) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

setSize(Dimension) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setSize(Dimension) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setSize(Dimension2D) - Method in class java.awt.geom. Dimension2D

设置此 Dimension2D对象的大小以匹配指定的大小。

setSize(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的size属性定义。

setSize(String) - Method in interface org.w3c.dom.html. HTMLBaseFontElement

setSize(String) - Method in interface org.w3c.dom.html. HTMLFontElement

setSize(String) - Method in interface org.w3c.dom.html. HTMLHRElement

setSize(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setSizes(int[]) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

将大小设置为 newSizes 。

setSizes(int[]) - Method in class javax.swing. SizeSequence

使用 sizes参数中的数据重置此 SizeSequence对象。

setSkin(Skin<?>) - Method in class javafx.scene.control. Control

设置属性皮肤的值。

setSkin(Skin<?>) - Method in class javafx.scene.control. PopupControl

设置属性皮肤的值。

setSkin(Skin<?>) - Method in interface javafx.scene.control. Skinnable

设置将呈现Control的皮肤

setSlaveSyncMode(Sequencer.SyncMode) - Method in interface javax.sound.midi. Sequencer

设置定序器的从同步模式。

setSlot(int, Object) - Method in class jdk.nashorn.api.scripting. AbstractJSObject

setSlot(int, Object) - Method in interface jdk.nashorn.api.scripting. JSObject

在此JavaScript对象中设置索引成员

setSlot(int, Object) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

setSlot(int, Object) - Method in class netscape.javascript. JSObject

设置JavaScript对象的索引成员。

setSmooth(boolean) - Method in class javafx.scene.image. ImageView

设置属性的值平滑。

setSmooth(boolean) - Method in class javafx.scene.media. MediaView

设置缩放时是否平滑媒体。

setSmooth(boolean) - Method in class javafx.scene.shape. Shape

设置属性的值平滑。

setSnapToPixel(boolean) - Method in class javafx.scene.layout. Region

设置属性snapToPixel的值。

setSnapToTicks(boolean) - Method in class javafx.scene.control. Slider

设置属性snapToTicks的值。

setSnapToTicks(boolean) - Method in class javax.swing. JSlider

指定true使旋钮（及其代表的数据值）解析为用户放置旋钮位置的最近刻度。

setSNIMatchers(Collection<SNIMatcher>) - Method in class javax.net.ssl. SSLParameters

设置服务器名称指示（SNI）参数的SNIMatcher 。

setSocketAddress(SocketAddress) - Method in class java.net. DatagramPacket

设置该数据报发送到的远程主机的SocketAddress（通常是IP地址+端口号）。

setSocketFactory(SocketImplFactory) - Static method in class java.net. ServerSocket

设置应用程序的服务器套接字实现工厂。

setSocketFactory(RMISocketFactory) - Static method in class java.rmi.server. RMISocketFactory

设置RMI获取套接字的全局套接字工厂（如果远程对象与特定客户端和/或服务器套接字工厂没有关联）。

setSocketImplFactory(SocketImplFactory) - Static method in class java.net. Socket

设置应用程序的客户端套接字实现工厂。

setSoLinger(boolean, int) - Method in class java.net. Socket

启用/禁用 SO_LINGER指定的逗留时间（以秒为单位）。

setSolo(boolean) - Method in interface javax.sound.midi. MidiChannel

设置此频道的独奏状态。

setSortable(boolean) - Method in class javafx.scene.control. TableColumnBase

设置属性可分类的值。

setSortable(int, boolean) - Method in class javax.swing. DefaultRowSorter

设置指定列是否可排序。

setSortKeys(List<? extends RowSorter.SortKey>) - Method in class javax.swing. DefaultRowSorter

设置排序键。

setSortKeys(List<? extends RowSorter.SortKey>) - Method in class javax.swing. RowSorter

设置当前的排序键。

setSortMode(TreeSortMode) - Method in class javafx.scene.control. TreeTableView

设置属性sortMode的值。

setSortNode(Node) - Method in class javafx.scene.control. TableColumnBase

设置属性sortNode的值。

setSortPolicy(Callback<TableView<S>, Boolean>) - Method in class javafx.scene.control. TableView

设置属性sortPolicy的值。

setSortPolicy(Callback<TreeTableView<S>, Boolean>) - Method in class javafx.scene.control. TreeTableView

设置属性sortPolicy的值。

setSortsOnUpdates(boolean) - Method in class javax.swing. DefaultRowSorter

如果为true，则指定更新底层模型时应进行排序（调用 rowsUpdated ）。

setSortType(TableColumn.SortType) - Method in class javafx.scene.control. TableColumn

设置属性sortType的值。

setSortType(TreeTableColumn.SortType) - Method in class javafx.scene.control. TreeTableColumn

设置属性sortType的值。

setSoTimeout(int) - Method in class java.net. DatagramSocket

以指定的超时（以毫秒为单位）启用/禁用SO_TIMEOUT。

setSoTimeout(int) - Method in class java.net. ServerSocket

启用/禁用指定超时的 SO_TIMEOUT （以毫秒为单位）。

setSoTimeout(int) - Method in class java.net. Socket

以指定的超时时间（以毫秒为单位）启用/禁用 SO_TIMEOUT 。

setSource(Object) - Method in class com.sun.java.accessibility.util. Translator

设置源对象为 Translator 。

setSource(Object) - Method in class java.awt. AWTEvent

将事件重新定位到新的来源。

setSource(Object) - Method in class java.beans. PropertyEditorSupport

设置源bean。

setSource(Object) - Method in class javax.management. Notification

设置源。

setSource(Object, int) - Method in class java.awt.image.renderable. ParameterBlock

用源代替源列表中的条目。

setSource(Image) - Method in class javafx.scene.effect. ImageInput

设置属性源的值。

setSourceActions(int) - Method in class java.awt.dnd. DragGestureRecognizer

此方法为此拖放操作设置允许的源拖动操作。

setSourceBands(int[]) - Method in class javax.imageio. IIOParam

设置要使用的源频带的索引。

setSourceClassName(String) - Method in class java.util.logging. LogRecord

设置（据称）发出日志记录请求的类的名称。

setSourceMethodName(String) - Method in class java.util.logging. LogRecord

设置（据称）发出日志记录请求的方法的名称。

setSourceProgressivePasses(int, int) - Method in class javax.imageio. ImageReadParam

设置将被解码的渐进道次的范围。

setSourceRegion(Rectangle) - Method in class javax.imageio. IIOParam

设置感兴趣的源区域。

setSourceRenderSize(Dimension) - Method in class javax.imageio. ImageReadParam

如果图像能够以任意大小呈现，请将源宽度和高度设置为提供的值。

setSources(Vector<Object>) - Method in class java.awt.image.renderable. ParameterBlock

将整个Vector矢量设置为给定的Vector。

setSourceSubsampling(int, int, int, int) - Method in class javax.imageio. IIOParam

指定抽取次采样以应用于I / O。

setSouthPane(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置南面。

setSpaceAbove(MutableAttributeSet, float) - Static method in class javax.swing.text. StyleConstants

设置上面的空间。

setSpaceBelow(MutableAttributeSet, float) - Static method in class javax.swing.text. StyleConstants

设置下面的空格。

setSpacing(double) - Method in class javafx.scene.control.skin. MenuBarSkin

设置属性间距的值。

setSpacing(double) - Method in class javafx.scene.layout. HBox

设置属性间距的值。

setSpacing(double) - Method in class javafx.scene.layout. VBox

设置属性间距的值。

setSpan(int) - Method in interface org.w3c.dom.html. HTMLTableColElement

setSpeak(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的说话属性定义。

setSpeakHeader(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的speak-header属性定义。

setSpeakNumeral(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的speak-numbers属性定义。

setSpeakPunctuation(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的说话标点属性定义。

setSpecified(int, boolean) - Method in class org.xml.sax.ext. Attributes2Impl

将值分配给特定属性的“指定”标志。

setSpecularColor(Color) - Method in class javafx.scene.paint. PhongMaterial

设置属性specularColor的值。

setSpecularConstant(double) - Method in class javafx.scene.effect. Lighting

设置属性specularConstant的值。

setSpecularExponent(double) - Method in class javafx.scene.effect. Light.Spot

设置属性specularExponent的值。

setSpecularExponent(double) - Method in class javafx.scene.effect. Lighting

设置属性specularExponent的值。

setSpecularMap(Image) - Method in class javafx.scene.paint. PhongMaterial

设置属性specularMap的值。

setSpecularPower(double) - Method in class javafx.scene.paint. PhongMaterial

设置属性specularPower的值。

setSpeechRate(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的语速率属性定义。

setSpread(double) - Method in class javafx.scene.effect. DropShadow

设置属性扩展的值。

setSQLXML(int, SQLXML) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.sql.SQLXML对象。

setSQLXML(int, SQLXML) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.SQLXML对象。

setSQLXML(int, SQLXML) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.SQLXML对象。

setSQLXML(String, SQLXML) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.sql.SQLXML对象。

setSQLXML(String, SQLXML) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.SQLXML对象。

setSQLXML(String, SQLXML) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.SQLXML对象。

setSrc(String) - Method in interface org.w3c.dom.html. HTMLFrameElement

setSrc(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setSrc(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setSrc(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setSrc(String) - Method in interface org.w3c.dom.html. HTMLScriptElement

setSSLParameters(SSLParameters) - Method in class com.sun.net.httpserver. HttpsParameters

设置用于此HttpsParameters的SSLParameters。

setSSLParameters(SSLParameters) - Method in class javax.net.ssl. SSLEngine

将SSLParameters应用于此引擎。

setSSLParameters(SSLParameters) - Method in class javax.net.ssl. SSLServerSocket

将SSLParameters应用于新接受的连接。

setSSLParameters(SSLParameters) - Method in class javax.net.ssl. SSLSocket

将SSLParameters应用于此套接字。

setSSLSocketFactory(SSLSocketFactory) - Method in class javax.net.ssl. HttpsURLConnection

设置当此实例为安全的https URL连接创建套接字时要使用的 SSLSocketFactory 。

setStackTrace(StackTraceElement[]) - Method in class java.lang. Throwable

设置将被返回的堆栈微量元素 Throwable.getStackTrace()和由印刷 Throwable.printStackTrace()和相关方法。

setStandby(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setStart(int) - Method in interface org.w3c.dom.html. HTMLOListElement

setStart(Comparable<Date>) - Method in class javax.swing. SpinnerDateModel

更改此顺序中日期的下限。

setStart(Node, int) - Method in interface org.w3c.dom.ranges. Range

设置描述范围开始的属性。

setStartAfter(Node) - Method in interface org.w3c.dom.ranges. Range

将开始位置设置为节点之后

setStartAngle(double) - Method in class javafx.scene.chart. PieChart

设置属性startAngle的值。

setStartAngle(double) - Method in class javafx.scene.shape. Arc

设置属性startAngle的值。

setStartBefore(Node) - Method in interface org.w3c.dom.ranges. Range

将起始位置设置为节点之前

setStartMargin(double) - Method in class javafx.scene.chart. CategoryAxis

设置属性startMargin的值。

setStartRule(int, int, int) - Method in class java.util. SimpleTimeZone

将夏令时开始规则设置为一个月内的固定日期。

setStartRule(int, int, int, int) - Method in class java.util. SimpleTimeZone

设置夏令时启动规则。

setStartRule(int, int, int, int, boolean) - Method in class java.util. SimpleTimeZone

将夏令时开始规则设置为一个月内给定日期之前或之后的工作日，例如第8个或之后的第一个星期一。

setStartTime(Duration) - Method in class javafx.scene.media. MediaPlayer

设置开始时间。

setStartX(double) - Method in class javafx.scene.shape. CubicCurve

设置属性startX的值。

setStartX(double) - Method in class javafx.scene.shape. Line

设置属性startX的值。

setStartX(double) - Method in class javafx.scene.shape. QuadCurve

设置属性startX的值。

setStartY(double) - Method in class javafx.scene.shape. CubicCurve

设置属性startY的值。

setStartY(double) - Method in class javafx.scene.shape. Line

设置属性startY的值。

setStartY(double) - Method in class javafx.scene.shape. QuadCurve

设置属性startY的值。

setStartYear(int) - Method in class java.util. SimpleTimeZone

设置夏令时起始年份。

setState(boolean) - Method in class java.awt. Checkbox

将此复选框的状态设置为指定的状态。

setState(boolean) - Method in class java.awt. CheckboxMenuItem

将此复选框菜单项设置为指定的状态。

setState(boolean) - Method in class javax.swing. JCheckBoxMenuItem

设置项目的选择状态。

setState(int) - Method in class java.awt. Frame

设置此框架的状态（已过时）。

setState(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

设置同步状态的值。

setState(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

设置同步状态的值。

setStatus(int) - Method in class javax.xml.ws.spi.http. HttpExchange

设置响应的HTTP状态代码。

setStatus(String) - Method in interface javax.jnlp. ExtensionInstallerService

更新进度窗口的状态文本。

setStatus(Animation.Status) - Method in class javafx.animation. Animation

设置属性状态的值。

setStepSize(Number) - Method in class javax.swing. SpinnerNumberModel

更改由 getNextValue和 getPreviousValue方法计算的值更改的大小。

setStopTime(Duration) - Method in class javafx.scene.media. MediaPlayer

设置停止时间。

setStrategy(int) - Method in class java.util.zip. Deflater

将压缩策略设置为指定值。

setStream(String, InputStream) - Method in interface java.applet. AppletContext

已过时。

将指定的流与此applet上下文中的指定关键字相关联。

setStreams(InputStream, OutputStream) - Method in class com.sun.net.httpserver. HttpExchange

过滤器使用该包交换器的InputStream和OutputStream（或两者）与给定的过滤流，以便后续调用HttpExchange.getRequestBody()将返回给定的InputStream ，并且调用HttpExchange.getResponseBody()将返回给定的OutputStream 。

setStrength(int) - Method in class java.text. Collator

设置此Collator的强度属性。

setStress(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的stress属性定义。

setStrictErrorChecking(boolean) - Method in interface org.w3c.dom. Document

指定是否强制执行错误检查的属性。

setStrikethrough(boolean) - Method in class javafx.scene.text. Text

设置属性删除线的值。

setStrikeThrough(boolean) - Method in class javax.swing.text. LabelView

设置视图是否具有打击/线条。

setStrikeThrough(MutableAttributeSet, boolean) - Static method in class javax.swing.text. StyleConstants

设置删除线属性。

setString(int, String) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的Java String值。

setString(int, String) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 String值。

setString(int, String) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的Java String值。

setString(long, String) - Method in interface java.sql. Clob

写入给定的Java String到 CLOB值，这 Clob对象表示在该位置 pos 。

setString(long, String) - Method in class javax.sql.rowset.serial. SerialClob

将给定的Java String写入 SerialClob对象表示的 CLOB值，位置 pos 。

setString(long, String, int, int) - Method in interface java.sql. Clob

写入 len的字符 str ，起始于字符 offset到 CLOB值，这 Clob表示。

setString(long, String, int, int) - Method in class javax.sql.rowset.serial. SerialClob

写入 len的字符 str ，起始于字符 offset到 CLOB值，这 Clob表示。

setString(String) - Method in interface java.sql. SQLXML

将此SQLXML实例指定的XML值设置为给定的String表示形式。

setString(String) - Method in class javax.swing. JProgressBar

设置进度字符串的值。

setString(String, String) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的Java String值。

setString(String, String) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的Java String值。

setString(String, String) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的Java String值。

setStringConverter(TableStringConverter) - Method in class javax.swing.table. TableRowSorter

设置负责将值从模型转换为字符串的对象。

setStringData(String) - Method in interface org.w3c.dom.ls. LSInput

要解析的字符串数据。

setStringPainted(boolean) - Method in class javax.swing. JProgressBar

设置 stringPainted属性的值，它决定进度条是否应该呈现进度字符串。

setStringToCompare(String) - Method in class javax.management.monitor. StringMonitor

将字符串设置为与所有观察到的MBean共有的观察属性进行比较。

setStringToCompare(String) - Method in interface javax.management.monitor. StringMonitorMBean

设置与所观察属性进行比较的字符串。

setStringValue(short, String) - Method in interface org.w3c.dom.css. CSSPrimitiveValue

用指定单位设置字符串值的方法。

setStroke(Stroke) - Method in class java.awt. Graphics2D

设置 Stroke为 Graphics2D的上下文。

setStroke(Paint) - Method in class javafx.scene.canvas. GraphicsContext

设置当前笔画paint属性。

setStroke(Paint) - Method in class javafx.scene.shape. Shape

设置属性笔画的值。

setStrokeDashOffset(double) - Method in class javafx.scene.shape. Shape

设置属性strokeDashOffset的值。

setStrokeLineCap(StrokeLineCap) - Method in class javafx.scene.shape. Shape

设置属性strokeLineCap的值。

setStrokeLineJoin(StrokeLineJoin) - Method in class javafx.scene.shape. Shape

设置属性strokeLineJoin的值。

setStrokeMiterLimit(double) - Method in class javafx.scene.shape. Shape

设置属性strokeMiterLimit的值。

setStrokeType(StrokeType) - Method in class javafx.scene.shape. Shape

设置属性strokeType的值。

setStrokeWidth(double) - Method in class javafx.scene.shape. Shape

设置属性strokeWidth的值。

setStub(AppletStub) - Method in class java.applet. Applet

已过时。

设置这个小程序的存根。

setStyle(String) - Method in class javafx.scene.control. MenuItem

设置属性样式的值。

setStyle(String) - Method in class javafx.scene.control. PopupControl

与此特定 PopupControl相关联的CSS样式的字符串表示 PopupControl 。

setStyle(String) - Method in class javafx.scene.control. Tab

与此选项卡相关联的CSS样式的字符串表示形式。

setStyle(String) - Method in class javafx.scene.control. TableColumnBase

设置属性样式的值。

setStyle(String) - Method in class javafx.scene. Node

与此特定的 Node相关联的CSS样式的字符串表示 Node 。

setStyledDocument(StyledDocument) - Method in class javax.swing. JTextPane

将编辑器与文本文档相关联。

setStyleFactory(SynthStyleFactory) - Static method in class javax.swing.plaf.synth. SynthLookAndFeel

设置SynthStyleFactory，合成器提供的UI类将用于获取SynthStyle。

setStyleSheet(StyleSheet) - Method in class javax.swing.text.html. HTMLEditorKit

设置用于渲染各种HTML元素的样式集。

setSubject(byte[]) - Method in class java.security.cert. X509CertSelector

设置主题标准。

setSubject(String) - Method in class java.security.cert. X509CertSelector

诋毁 ，使用 X509CertSelector.setSubject(X500Principal)或者 X509CertSelector.setSubject(byte[])代替。

setSubject(X500Principal) - Method in class java.security.cert. X509CertSelector

设置主题标准。

setSubjectAlternativeNames(Collection<List<?>>) - Method in class java.security.cert. X509CertSelector

设置subjectAlternativeNames标准。

setSubjectKeyIdentifier(byte[]) - Method in class java.security.cert. X509CertSelector

设置subjectKeyIdentifier标准。

setSubjectPublicKey(byte[]) - Method in class java.security.cert. X509CertSelector

设置subjectPublicKey标准。

setSubjectPublicKey(PublicKey) - Method in class java.security.cert. X509CertSelector

设置subjectPublicKey标准。

setSubjectPublicKeyAlgID(String) - Method in class java.security.cert. X509CertSelector

设置subjectPublicKeyAlgID标准。

setSubscript(boolean) - Method in class javax.swing.text. LabelView

设置视图是否表示下标。

setSubscript(MutableAttributeSet, boolean) - Static method in class javax.swing.text. StyleConstants

设置下标属性。

setSubType(String) - Method in class javax.activation. MimeType

将此对象的子类型设置为给定的String。

setSummary(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setSuperscript(boolean) - Method in class javax.swing.text. LabelView

设置视图是否代表上标。

setSuperscript(MutableAttributeSet, boolean) - Static method in class javax.swing.text. StyleConstants

设置上标属性。

setSupplementaryStates(boolean, boolean, boolean, boolean, int, String) - Method in class org.ietf.jgss. MessageProp

该方法设置补充信息标志的状态和MessageProp中的次要状态。

setSurfaceScale(double) - Method in class javafx.scene.effect. Lighting

设置属性surfaceScale的值。

setSurrendersFocusOnKeystroke(boolean) - Method in class javax.swing. JTable

设置当由于单元格的JTable转发键盘事件而激活编辑器时，此JTable中的编辑器是否获得键盘焦点。

setSuspendPolicy(int) - Method in interface com.sun.jdi.request. EventRequest

确定在目标VM中发生请求的事件时挂起的线程。

setSweepFlag(boolean) - Method in class javafx.scene.shape. ArcTo

设置属性sweepFlag的值。

setSyncAllWidths(boolean) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

设置子节点的宽度是否应该同步。

setSyncOnRelink(boolean) - Method in class jdk.dynalink. DynamicLinkerFactory

设置此工厂创建的动态链接是否在调用站点重新链接后调用 MutableCallSite.syncAll(MutableCallSite[]) 。

setSyncProvider(String) - Method in interface javax.sql.rowset. CachedRowSet

将此 CachedRowSet对象的 SyncProvider对象设置为指定的对象。

setSyncResolver(SyncResolver) - Method in exception javax.sql.rowset.spi. SyncProviderException

设置 SyncResolver此对象 SyncProviderException对象提供的一个。

setSystem(boolean) - Method in interface java.nio.file.attribute. DosFileAttributeView

更新系统属性的值。

setSystem(ActivationSystem) - Static method in class java.rmi.activation. ActivationGroup

设置VM的激活系统。

setSystemId(File) - Method in class javax.xml.transform.stream. StreamResult

从 File参考设置系统ID。

setSystemId(File) - Method in class javax.xml.transform.stream. StreamSource

从文件引用设置系统ID。

setSystemId(String) - Method in class javax.xml.transform.dom. DOMResult

设置可能与节点关联使用的systemId。

setSystemId(String) - Method in class javax.xml.transform.dom. DOMSource

设置基址（URL或系统ID）从哪里解决URL。

setSystemId(String) - Method in interface javax.xml.transform. Result

设置此结果的系统标识符。

setSystemId(String) - Method in class javax.xml.transform.sax. SAXResult

方法setSystemId设置可能与ContentHandler相关联使用的systemID 。

setSystemId(String) - Method in class javax.xml.transform.sax. SAXSource

设置此源的系统标识符。

setSystemId(String) - Method in interface javax.xml.transform.sax. TemplatesHandler

设置由此构建器创建的Templates对象的基本ID（URI或系统ID）。

setSystemId(String) - Method in interface javax.xml.transform.sax. TransformerHandler

设置相对URL将被解析的基本ID（URI或系统ID）。

setSystemId(String) - Method in interface javax.xml.transform. Source

设置此源的系统标识符。

setSystemId(String) - Method in class javax.xml.transform.stax. StAXResult

在 StAXResult的上下文中，明确设置系统标识符是不合适的。

setSystemId(String) - Method in class javax.xml.transform.stax. StAXSource

在 StAXSource的上下文中，显式设置系统标识符是不合适的。

setSystemId(String) - Method in class javax.xml.transform.stream. StreamResult

设置可以与字节或字符流相关联使用的systemID，或者如果两者都不设置，则将该值用作可写URI（可能是文件名）。

setSystemId(String) - Method in class javax.xml.transform.stream. StreamSource

设置此源的系统标识符。

setSystemId(String) - Method in interface org.w3c.dom.ls. LSInput

系统标识符，一个URI参考[ IETF RFC 2396 ]，用于此输入源。

setSystemId(String) - Method in interface org.w3c.dom.ls. LSOutput

该输出目的地的系统标识符，URI引用[ IETF RFC 2396 ]。

setSystemId(String) - Method in class org.xml.sax.helpers. LocatorImpl

设置此定位器的系统标识符。

setSystemId(String) - Method in class org.xml.sax. InputSource

设置此输入源的系统标识符。

setSystemScope(IdentityScope) - Static method in class java.security. IdentityScope

已过时。

设置系统的身份范围。

setTabClosingPolicy(TabPane.TabClosingPolicy) - Method in class javafx.scene.control. TabPane

指定TabPane如何从最终用户角度处理标签关闭。

setTabComponentAt(int, Component) - Method in class javax.swing. JTabbedPane

设置负责渲染指定选项卡的标题的组件。

setTabIndex(int) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setTabIndex(int) - Method in interface org.w3c.dom.html. HTMLAreaElement

setTabIndex(int) - Method in interface org.w3c.dom.html. HTMLButtonElement

setTabIndex(int) - Method in interface org.w3c.dom.html. HTMLInputElement

setTabIndex(int) - Method in interface org.w3c.dom.html. HTMLObjectElement

setTabIndex(int) - Method in interface org.w3c.dom.html. HTMLSelectElement

setTabIndex(int) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setTabLayoutPolicy(int) - Method in class javax.swing. JTabbedPane

设置当所有选项卡不适合单个运行时，选项卡窗格将用于布局选项卡的策略。

setTable(JTable) - Method in class javax.swing.table. JTableHeader

设置与此标题关联的表。

setTableHeader(JTableHeader) - Method in class javax.swing. JTable

设置 tableHeader使用这个 JTable到 newHeader 。

setTableLayout(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的table-layout属性定义。

setTableMenuButtonVisible(boolean) - Method in class javafx.scene.control. TableView

设置属性tableMenuButtonVisible的值。

setTableMenuButtonVisible(boolean) - Method in class javafx.scene.control. TreeTableView

设置属性tableMenuButtonVisible的值。

setTableName(int, String) - Method in class javax.sql.rowset. RowSetMetaDataImpl

将派生指定列的表的名称设置为给定的表名。

setTableName(int, String) - Method in interface javax.sql. RowSetMetaData

将指定列的表名称（如果有）设置为给定的 String 。

setTableName(String) - Method in interface javax.sql.rowset. CachedRowSet

将此派生的 CachedRowSet对象的表的标识符设置为给定的表名。

setTabMaxHeight(double) - Method in class javafx.scene.control. TabPane

设置属性tabMaxHeight的值。

setTabMaxWidth(double) - Method in class javafx.scene.control. TabPane

设置属性tabMaxWidth的值。

setTabMinHeight(double) - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最小高度。

setTabMinWidth(double) - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最小宽度。

setTabPlacement(int) - Method in class javax.swing. JTabbedPane

设置此标签页窗格的标签位置。

setTabSet(MutableAttributeSet, TabSet) - Static method in class javax.swing.text. StyleConstants

设置TabSet。

setTabSize(int) - Method in class javax.swing. JTextArea

设置扩展标签的字符数。

setTag(URL, int) - Method in interface javax.jnlp. PersistenceService

使用给定的标签值标记与给定URL相关联的持久数据存储条目。

setTarget(MethodHandle) - Method in class java.lang.invoke. CallSite

根据此呼叫站点的特定类定义的行为，更新此呼叫站点的目标方法。

setTarget(MethodHandle) - Method in class java.lang.invoke. ConstantCallSite

总是抛出一个UnsupportedOperationException 。

setTarget(MethodHandle) - Method in class java.lang.invoke. MutableCallSite

将此呼叫站点的目标方法更新为常规变量。

setTarget(MethodHandle) - Method in class java.lang.invoke. VolatileCallSite

将此调用站点的目标方法更新为volatile变量。

setTarget(Object) - Method in class javax.accessibility. AccessibleRelation

设置此关系的目标对象。

setTarget(Object[]) - Method in class javax.accessibility. AccessibleRelation

设置此关系的目标对象。

setTarget(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setTarget(String) - Method in interface org.w3c.dom.html. HTMLAreaElement

setTarget(String) - Method in interface org.w3c.dom.html. HTMLBaseElement

setTarget(String) - Method in interface org.w3c.dom.html. HTMLFormElement

setTarget(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setTarget(Remote) - Method in interface javax.rmi.CORBA. Tie

调用 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote)设定目标为此领带。

setTargetActions(int) - Method in class java.awt.dnd. DropTargetContext

此方法设置此 DropTarget可接受的当前操作。

setTargetCertConstraints(CertSelector) - Method in class java.security.cert. PKIXParameters

设置目标证书所需的约束。

setTaskListener(TaskListener) - Method in class com.sun.source.util. JavacTask

设置指定的侦听器以接收描述此编译任务进度的事件的通知。

setTcpNoDelay(boolean) - Method in class java.net. Socket

启用/禁用 TCP_NODELAY （禁用/启用Nagle的算法）。

setTempoFactor(float) - Method in interface javax.sound.midi. Sequencer

按照提供的因素来调整音序器的实际播放速度。

setTempoInBPM(float) - Method in interface javax.sound.midi. Sequencer

设置每分钟节拍的速度。

setTempoInMPQ(float) - Method in interface javax.sound.midi. Sequencer

设置每四分之一音符的微秒速度。

setter(Method) - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder

直接设置setter方法。

setter(Method) - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder

直接设置setter方法。

setter(Method) - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder

直接设置setter方法。

setter(Method) - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder

直接设置setter方法。

setter(Method) - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder

直接设置setter方法。

setter(Method) - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder

直接设置setter方法。

setter(Method) - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder

直接设置setter方法。

setter(String) - Method in class javafx.beans.property.adapter. JavaBeanBooleanPropertyBuilder

为设定者设置一个替代名称。

setter(String) - Method in class javafx.beans.property.adapter. JavaBeanDoublePropertyBuilder

为设定者设置一个替代名称。

setter(String) - Method in class javafx.beans.property.adapter. JavaBeanFloatPropertyBuilder

为设定者设置一个替代名称。

setter(String) - Method in class javafx.beans.property.adapter. JavaBeanIntegerPropertyBuilder

为设定者设置一个替代名称。

setter(String) - Method in class javafx.beans.property.adapter. JavaBeanLongPropertyBuilder

为设定者设置一个替代名称。

setter(String) - Method in class javafx.beans.property.adapter. JavaBeanObjectPropertyBuilder

为设定者设置一个替代名称。

setter(String) - Method in class javafx.beans.property.adapter. JavaBeanStringPropertyBuilder

为设定者设置一个替代名称。

setText(String) - Method in class java.awt. Label

将此标签的文本设置为指定的文本。

setText(String) - Method in class java.awt. TextComponent

将此文本组件呈现的文本设置为指定的文本。

setText(String) - Method in class java.awt. TextField

将此文本组件呈现的文本设置为指定的文本。

setText(String) - Method in class java.text. BreakIterator

设置要扫描的新文本字符串。

setText(String) - Method in class java.text. CollationElementIterator

设置要迭代的新字符串。

setText(String) - Method in class java.text. StringCharacterIterator

重置这个迭代器以指向一个新的字符串。

setText(String) - Method in class javafx.scene.control. Labeled

设置属性文本的值。

setText(String) - Method in class javafx.scene.control. MenuItem

设置属性文本的值。

setText(String) - Method in class javafx.scene.control. Tab

将选项卡中显示的文本设置为允许用户区分每个选项卡的功能。

setText(String) - Method in class javafx.scene.control. TableColumnBase

设置属性文本的值。

setText(String) - Method in class javafx.scene.control. TextFormatter.Change

设置在此更改中使用的文本。

setText(String) - Method in class javafx.scene.control. TextInputControl

设置属性文本的值。

setText(String) - Method in class javafx.scene.control. Tooltip

设置属性文本的值。

setText(String) - Method in class javafx.scene.text. Text

设置属性文本的值。

setText(String) - Method in class javax.security.auth.callback. TextInputCallback

设置检索到的文本。

setText(String) - Method in class javax.swing. AbstractButton

设置按钮的文本。

setText(String) - Method in class javax.swing. JEditorPane

将此 TextComponent的文本设置为指定的内容，预期其格式为此编辑器的内容类型。

setText(String) - Method in class javax.swing. JLabel

定义该组件将显示的单行文本。

setText(String) - Method in class javax.swing.text. JTextComponent

将此 TextComponent的文本设置为指定的文本。

setText(String) - Method in interface org.w3c.dom.html. HTMLBodyElement

setText(String) - Method in interface org.w3c.dom.html. HTMLScriptElement

setText(String) - Method in interface org.w3c.dom.html. HTMLTitleElement

setText(CharacterIterator) - Method in class java.text. BreakIterator

设置一个新文本进行扫描。

setText(CharacterIterator) - Method in class java.text. CollationElementIterator

设置要迭代的新字符串。

setTextAlign(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-align属性定义。

setTextAlign(TextAlignment) - Method in class javafx.scene.canvas. GraphicsContext

定义水平文本对齐方式，相对于文本 x来源。

setTextAlignment(TextAlignment) - Method in class javafx.scene.control. Labeled

设置textAlignment属性的值。

setTextAlignment(TextAlignment) - Method in class javafx.scene.control. Tooltip

设置textAlignment属性的值。

setTextAlignment(TextAlignment) - Method in class javafx.scene.text. Text

设置textAlignment属性的值。

setTextAlignment(TextAlignment) - Method in class javafx.scene.text. TextFlow

设置textAlignment属性的值。

setTextBaseline(VPos) - Method in class javafx.scene.canvas. GraphicsContext

设置当前的文本基线。

setTextContent(String) - Method in class javax.imageio.metadata. IIOMetadataNode

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

setTextContent(String) - Method in interface org.w3c.dom. Node

此属性返回此节点及其后代的文本内容。

setTextContents(String) - Method in interface javax.accessibility. AccessibleEditableText

将文本内容设置为指定的字符串。

setTextContents(String) - Method in class javax.swing. JSpinner.AccessibleJSpinner

将文本内容设置为指定的字符串。

setTextContents(String) - Method in class javax.swing.text. JTextComponent.AccessibleJTextComponent

将文本内容设置为指定的字符串。

setTextDecoration(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-decoration属性定义。

setTextFill(Paint) - Method in class javafx.scene.control. Labeled

设置属性textFill的值。

setTextFill(Paint) - Method in class javafx.scene.control.skin. TextInputControlSkin

填充 Paint用于前景文字颜色。

setTextFormatter(TextFormatter<?>) - Method in class javafx.scene.control. TextInputControl

设置属性textFormatter的值。

setTextIndent(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-indent属性定义。

setTextNonSelectionColor(Color) - Method in class javax.swing.tree. DefaultTreeCellRenderer

当没有选择节点时，设置文本绘制的颜色。

setTextOrigin(VPos) - Method in class javafx.scene.text. Text

设置属性textOrigin的值。

setTextOverrun(OverrunStyle) - Method in class javafx.scene.control. Labeled

设置textOverrun属性的值。

setTextOverrun(OverrunStyle) - Method in class javafx.scene.control. Tooltip

设置textOverrun属性的值。

setTextSelectionColor(Color) - Method in class javax.swing.tree. DefaultTreeCellRenderer

设置当选择节点时绘制文本的颜色。

setTextShadow(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-shadow属性定义。

setTextShiftOffset() - Method in class javax.swing.plaf.basic. BasicButtonUI

设置文本的偏移量。

setTextTransform(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的text-transform属性定义。

setTextVisible(boolean) - Method in class javafx.scene.chart. Axis.TickMark

指定是否显示此刻度标签标签文本。

setTFoot(HTMLTableSectionElement) - Method in interface org.w3c.dom.html. HTMLTableElement

setTHead(HTMLTableSectionElement) - Method in interface org.w3c.dom.html. HTMLTableElement

setThreadAllocatedMemoryEnabled(boolean) - Method in interface com.sun.management. ThreadMXBean

启用或禁用线程内存分配测量。

setThreadContentionMonitoringEnabled(boolean) - Method in interface java.lang.management. ThreadMXBean

启用或禁用线程争用监控。

setThreadCpuTimeEnabled(boolean) - Method in interface java.lang.management. ThreadMXBean

启用或禁用线程CPU时间测量。

setThreadFactory(ThreadFactory) - Method in class java.util.concurrent. ThreadPoolExecutor

设置用于创建新线程的线程工厂。

setThreadID(int) - Method in class java.util.logging. LogRecord

设置消息始发线程的标识符。

setThreshold(double) - Method in class javafx.scene.effect. Bloom

设置属性阈值的值。

setThreshold(Number) - Method in class javax.management.monitor. CounterMonitor

已过时。
截至JMX 1.2，由CounterMonitor.setInitThreshold(java.lang.Number)替代

setThreshold(Number) - Method in interface javax.management.monitor. CounterMonitorMBean

已过时。
截至JMX 1.2，由CounterMonitorMBean.setInitThreshold(java.lang.Number)取代

setThresholds(Number, Number) - Method in class javax.management.monitor. GaugeMonitor

设置所有观察到的MBean共有的高和低阈值。

setThresholds(Number, Number) - Method in interface javax.management.monitor. GaugeMonitorMBean

设置高和低阈值。

setThrown(Throwable) - Method in class java.util.logging. LogRecord

设置与日志事件相关联的可抛出。

setThumbBounds(int, int, int, int) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

设置拇指的边界，并强制包含旧的thumbBounds和新的thumbBounds的重绘。

setThumbBounds(int, int, int, int) - Method in class javax.swing.plaf.metal. MetalScrollBarUI

这被覆盖只是为了增加无效区域。

setThumbLocation(int, int) - Method in class javax.swing.plaf.basic. BasicSliderUI

设置拇指位置。

setThumbLocation(int, int) - Method in class javax.swing.plaf.synth. SynthSliderUI

设置拇指位置。

setThumbnails(List<? extends BufferedImage>) - Method in class javax.imageio. IIOImage

将缩略图到一个新的列表 List的 BufferedImage S，或 null 。

setThumbRollover(boolean) - Method in class javax.swing.plaf.basic. BasicScrollBarUI

设置鼠标是否当前在拇指上。

setThumbRollover(boolean) - Method in class javax.swing.plaf.synth. SynthScrollBarUI

设置鼠标是否当前在拇指上。

setTick(long) - Method in class javax.sound.midi. MidiEvent

以MIDI刻度设置事件的时间戳。

setTickLabelFill(Paint) - Method in class javafx.scene.chart. Axis

设置属性tickLabelFill的值。

setTickLabelFont(Font) - Method in class javafx.scene.chart. Axis

设置属性tickLabelFont的值。

setTickLabelFormatter(StringConverter<T>) - Method in class javafx.scene.chart. ValueAxis

设置属性tickLabelFormatter的值。

setTickLabelGap(double) - Method in class javafx.scene.chart. Axis

设置属性tickLabelGap的值。

setTickLabelRotation(double) - Method in class javafx.scene.chart. Axis

设置属性tickLabelRotation的值。

setTickLabelsVisible(boolean) - Method in class javafx.scene.chart. Axis

设置属性tickLabelsVisible的值。

setTickLength(double) - Method in class javafx.scene.chart. Axis

设置属性tickLength的值。

setTickMarkVisible(boolean) - Method in class javafx.scene.chart. Axis

设置属性tickMarkVisible的值。

setTickPosition(long) - Method in interface javax.sound.midi. Sequencer

以MIDI刻度设置当前音序器的位置。

setTickUnit(double) - Method in class javafx.scene.chart. NumberAxis

设置属性tickUnit的值。

setTileAlignment(Pos) - Method in class javafx.scene.layout. TilePane

设置属性tileAlignment的值。

setTiling(int, int, int, int) - Method in class javax.imageio. ImageWriteParam

指定图像应该平铺在输出流中。

setTilingMode(int) - Method in class javax.imageio. ImageWriteParam

确定图像是否将平铺在输出流中，如果是，将确定平铺参数的确定方式。

setTime(int, int, int) - Method in class javax.xml.datatype. XMLGregorianCalendar

将时间设为一个单位。

setTime(int, int, int, int) - Method in class javax.xml.datatype. XMLGregorianCalendar

将时间设置为一个单位，包括可选的毫秒数。

setTime(int, int, int, BigDecimal) - Method in class javax.xml.datatype. XMLGregorianCalendar

将时间设置为一个单位，包括可选的无限精度小数秒。

setTime(int, Time) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.sql.Time值。

setTime(int, Time) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Time值。

setTime(int, Time) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Time值。

setTime(int, Time, Calendar) - Method in interface java.sql. PreparedStatement

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。

setTime(int, Time, Calendar) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Time对象。

setTime(int, Time, Calendar) - Method in interface javax.sql. RowSet

使用给定的 java.sql.Time值在此 RowSet对象的命令中设置指定的参数。

setTime(long) - Method in class java.sql. Date

使用给定的毫秒时间值设置现有的 Date对象。

setTime(long) - Method in class java.sql. Time

使用毫秒时间值设置 Time对象。

setTime(long) - Method in class java.sql. Timestamp

将此 Timestamp对象设置为1970年1月1日00:00:00 GMT后的 time毫秒的时间点。

setTime(long) - Method in class java.util. Date

将此 Date对象设置为1970年1月1日00:00:00 GMT后的 time毫秒的时间点。

setTime(long) - Method in class java.util.zip. ZipEntry

设置条目的最后修改时间。

setTime(String, Time) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.sql.Time值。

setTime(String, Time) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Time值。

setTime(String, Time) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.Time值。

setTime(String, Time, Calendar) - Method in interface java.sql. CallableStatement

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。

setTime(String, Time, Calendar) - Method in class javax.sql.rowset. BaseRowSet

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。

setTime(String, Time, Calendar) - Method in interface javax.sql. RowSet

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。

setTime(Date) - Method in class java.util. Calendar

使用给定的 Date设置此日历的时间。

setTimeInMillis(long) - Method in class java.util. Calendar

从给定的长值设置此日历的当前时间。

setTimeLimit(int) - Method in class javax.naming.directory. SearchControls

以毫秒为单位设置这些SearchControl的时间限制。

setTimeLocal(LocalDateTime) - Method in class java.util.zip. ZipEntry

设置本地日期时间的条目的最后修改时间。

setTimeOfDay(int, int, int) - Method in class java.util. Calendar.Builder

将时间字段参数设置 hourOfDay minute和 second给出的值。

setTimeOfDay(int, int, int, int) - Method in class java.util. Calendar.Builder

设置由给定的一天领域参数值时 hourOfDay ， minute ， second ，并 millis 。

setTimes(FileTime, FileTime, FileTime) - Method in interface java.nio.file.attribute. BasicFileAttributeView

更新文件的最后修改时间，上次访问时间和创建时间属性的任何或全部。

setTimestamp(int, Timestamp) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(int, Timestamp) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(int, Timestamp) - Method in interface javax.sql. RowSet

将此 RowSet对象的命令中的指定参数设置为给定的 java.sql.Timestamp值。

setTimestamp(int, Timestamp, Calendar) - Method in interface java.sql. PreparedStatement

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(int, Timestamp, Calendar) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Timestamp对象。

setTimestamp(int, Timestamp, Calendar) - Method in interface javax.sql. RowSet

使用给定的 java.sql.Timestamp值在此 RowSet对象的命令中设置指定的参数。

setTimestamp(String, Timestamp) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(String, Timestamp) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(String, Timestamp) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(String, Timestamp, Calendar) - Method in interface java.sql. CallableStatement

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(String, Timestamp, Calendar) - Method in class javax.sql.rowset. BaseRowSet

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

setTimestamp(String, Timestamp, Calendar) - Method in interface javax.sql. RowSet

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

setTimeStamp(long) - Method in class javax.management. Notification

设置通知时间戳。

setTimeToLive(int) - Method in class java.net. DatagramSocketImpl

设置TTL（生存时间）选项。

setTimeToLive(int) - Method in class java.net. MulticastSocket

为此 MulticastSocket发送的组播数据包的默认生存时间为了控制组播的范围。

setTimezone(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置时区偏移的分钟数。

setTimeZone(TimeZone) - Method in class java.text. DateFormat

设置 DateFormat对象的日历的时区。

setTimeZone(TimeZone) - Method in class java.util. Calendar.Builder

将时区参数设置为给定的 zone 。

setTimeZone(TimeZone) - Method in class java.util. Calendar

以给定的时区值设置时区。

setTimeZone(TimeZone) - Method in class java.util. GregorianCalendar

setTipText(String) - Method in class javax.swing. JToolTip

设置显示工具提示时显示的文本。

setTitle(String) - Method in class java.awt. Dialog

设置对话框的标题。

setTitle(String) - Method in class java.awt. FileDialog

设置对话框的标题。

setTitle(String) - Method in class java.awt. Frame

将此框架的标题设置为指定的字符串。

setTitle(String) - Method in class javafx.scene.chart. Chart

设置属性标题的值。

setTitle(String) - Method in class javafx.scene.control. Dialog

更改对话框的标题。

setTitle(String) - Method in class javafx.stage. DirectoryChooser

设置属性标题的值。

setTitle(String) - Method in class javafx.stage. FileChooser

设置属性标题的值。

setTitle(String) - Method in class javafx.stage. Stage

设置属性标题的值。

setTitle(String) - Method in class javax.swing.border. TitledBorder

设置标题边框的标题。

setTitle(String) - Method in class javax.swing. JInternalFrame

设置 JInternalFrame标题。

setTitle(String) - Method in interface org.w3c.dom.html. HTMLDocument

setTitle(String) - Method in interface org.w3c.dom.html. HTMLElement

setTitleAt(int, String) - Method in class javax.swing. JTabbedPane

将标题设置为 index至 title ，可以是 null 。

setTitleColor(Color) - Method in class javax.swing.border. TitledBorder

设置标题边框的标题颜色。

setTitleFont(Font) - Method in class javax.swing.border. TitledBorder

设置标题边框的标题字体。

setTitleJustification(int) - Method in class javax.swing.border. TitledBorder

设置标题边框的标题对齐。

setTitlePosition(int) - Method in class javax.swing.border. TitledBorder

设置标题边框的标题位置。

setTitleSide(Side) - Method in class javafx.scene.chart. Chart

设置属性titleSide的值。

setToAngle(double) - Method in class javafx.animation. RotateTransition

将属性的值设置为Agle。

setToggleClickCount(int) - Method in class javax.swing. JTree

设置节点将展开或关闭之前的鼠标点击次数。

setToggleGroup(ToggleGroup) - Method in class javafx.scene.control. RadioMenuItem

设置属性toggleGroup的值。

setToggleGroup(ToggleGroup) - Method in interface javafx.scene.control. Toggle

设置ToggleGroup到这个Toggle所属。

setToggleGroup(ToggleGroup) - Method in class javafx.scene.control. ToggleButton

设置属性toggleGroup的值。

setToIdentity() - Method in class java.awt.geom. AffineTransform

将此转换重置为Identity变换。

setToIdentity() - Method in class javafx.scene.transform. Affine

将此转换重置为身份转换。

setTokenThreshold(int) - Method in class javax.swing.text.html. HTMLDocument

在尝试更新文档元素结构之前，设置要缓冲的令牌数。

setTooltip(Tooltip) - Method in class javafx.scene.control. Control

设置属性工具提示的值。

setTooltip(Tooltip) - Method in class javafx.scene.control. Tab

指定工具提示，以显示用户何时悬停在选项卡上。

setToolTip(String) - Method in class java.awt. TrayIcon

设置此 TrayIcon的工具提示字符串。

setToolTipText(String) - Method in class javax.swing. JComponent

注册文本以显示在工具提示。

setToolTipTextAt(int, String) - Method in class javax.swing. JTabbedPane

将工具提示文本设置为 index至 toolTipText ，可以是 null 。

setTop(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的顶层属性定义。

setTop(Node) - Method in class javafx.scene.layout. BorderPane

设置属性顶部的值。

setToPage(int) - Method in class java.awt. JobAttributes

对于要使用这些属性的作业，如果要打印的页面范围，则指定要打印的最后一页（含）。

setTopAnchor(Node, Double) - Static method in class javafx.scene.layout. AnchorPane

设置锚定窗格包含的小孩的顶部锚点。

setTopComponent(Component) - Method in class javax.swing. JSplitPane

设置上面的分量，或分隔线的左边。

setTopDown(boolean) - Method in class javax.imageio.plugins.bmp. BMPImageWriteParam

如果设置，数据将以自上而下的方式写出，第一条扫描线首先写入。

setTopInput(Effect) - Method in class javafx.scene.effect. Blend

设置属性topInput的值。

setTopInset(float) - Method in class javax.swing.text. AsyncBoxView

围绕视图设置边距的顶部。

setTopOffset(double) - Method in class javafx.scene.effect. Reflection

设置属性topOffset的值。

setTopOpacity(double) - Method in class javafx.scene.effect. Reflection

设置属性topOpacity的值。

setToQuadrantRotation(int) - Method in class java.awt.geom. AffineTransform

将此变换设置为将坐标旋转指定数量的象限的旋转变换。

setToQuadrantRotation(int, double, double) - Method in class java.awt.geom. AffineTransform

将此转换设置为转换的旋转变换，该转换将坐标指定指定锚点周围的指定数量的象限旋转。

setToRotation(double) - Method in class java.awt.geom. AffineTransform

将此变换设置为旋转变换。

setToRotation(double, double) - Method in class java.awt.geom. AffineTransform

将此变换设置为根据旋转矢量旋转坐标的旋转变换。

setToRotation(double, double, double) - Method in class java.awt.geom. AffineTransform

将此转换设置为转换的旋转变换。

setToRotation(double, double, double, double) - Method in class java.awt.geom. AffineTransform

将此变换设置为根据旋转向量旋转锚点周围的坐标的旋转变换。

setToScale(double, double) - Method in class java.awt.geom. AffineTransform

将此变换设置为缩放变换。

setToShear(double, double) - Method in class java.awt.geom. AffineTransform

将此变换设置为剪切变换。

setToTransform(double[], MatrixType, int) - Method in class javafx.scene.transform. Affine

将此实例的值设置为由数组指定的转换矩阵。

setToTransform(double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine

将此实例的值设置为由元素值指定的2D变换。

setToTransform(double, double, double, double, double, double, double, double, double, double, double, double) - Method in class javafx.scene.transform. Affine

将此实例的值设置为由元素值指定的变换。

setToTransform(Transform) - Method in class javafx.scene.transform. Affine

将此实例的值设置为指定转换提供的值。

setToTranslation(double, double) - Method in class java.awt.geom. AffineTransform

将此变换设置为转换变换。

setToValue(double) - Method in class javafx.animation. FadeTransition

将属性的值设置为Value。

setToValue(Color) - Method in class javafx.animation. FillTransition

将属性的值设置为Value。

setToValue(Color) - Method in class javafx.animation. StrokeTransition

将属性的值设置为Value。

setToX(double) - Method in class javafx.animation. ScaleTransition

将属性的值设置为X。

setToX(double) - Method in class javafx.animation. TranslateTransition

将属性的值设置为X。

setToY(double) - Method in class javafx.animation. ScaleTransition

将属性的值设置为Y。

setToY(double) - Method in class javafx.animation. TranslateTransition

将属性的值设置为Y。

setToZ(double) - Method in class javafx.animation. ScaleTransition

将属性的值设置为Z。

setToZ(double) - Method in class javafx.animation. TranslateTransition

将属性的值设置为Z。

setTrackMute(int, boolean) - Method in interface javax.sound.midi. Sequencer

设置轨道的静音状态。

setTrackSolo(int, boolean) - Method in interface javax.sound.midi. Sequencer

设置轨道的独奏状态。

setTrafficClass(int) - Method in class java.net. DatagramSocket

在从该DatagramSocket发送的数据报的IP数据报头中设置流量类别或服务类型的八位字节。

setTrafficClass(int) - Method in class java.net. Socket

在从此Socket发送的数据包的IP头中设置流量类或服务类型字节。

setTransactionIsolation(int) - Method in interface java.sql. Connection

尝试将此 Connection对象的事务隔离级别更改为给定的对象。

setTransactionIsolation(int) - Method in class javax.sql.rowset. BaseRowSet

将此JDBC RowSet对象的事务隔离属性设置为给定常量。

setTransactionIsolation(int) - Method in interface javax.sql. RowSet

设置此 RowSet对象的事务隔离级别。

setTransactionTimeout(int) - Method in interface javax.transaction.xa. XAResource

设置此 XAResource实例的当前事务超时值。

setTransferHandler(TransferHandler) - Method in class javax.swing. JApplet

已过时。

设置 transferHandler属性，这是一种支持将数据传输到此组件的机制。

setTransferHandler(TransferHandler) - Method in class javax.swing. JComponent

设置 TransferHandler ，它支持通过剪切/复制/粘贴和拖放将数据传入和传出该组件。

setTransferHandler(TransferHandler) - Method in class javax.swing. JDialog

设置 transferHandler属性，这是一种支持将数据传输到此组件的机制。

setTransferHandler(TransferHandler) - Method in class javax.swing. JFrame

设置 transferHandler属性，这是一种支持将数据传输到此组件的机制。

setTransferHandler(TransferHandler) - Method in class javax.swing. JWindow

设置 transferHandler属性，这是一种支持将数据传输到此组件的机制。

setTransform(double, double, double, double, double, double) - Method in class java.awt.geom. AffineTransform

将此变换设置为由6个双精度值指定的矩阵。

setTransform(double, double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

设置当前变换。

setTransform(AffineTransform) - Method in class java.awt.geom. AffineTransform

将此变换设置为指定的 AffineTransform对象中的变换副本。

setTransform(AffineTransform) - Method in class java.awt. Graphics2D

覆盖 Graphics2D上下文中的变换。

setTransform(AffineTransform) - Method in class java.awt.image.renderable. RenderContext

将RenderContext中包含的当前用户到设备的AffineTransform设置为给定的转换。

setTransform(Affine) - Method in class javafx.scene.canvas. GraphicsContext

设置当前变换。

setTransform(Transform) - Method in class javafx.scene. SnapshotParameters

将转换设置为指定的值。

setTranslateX(double) - Method in class javafx.scene. Node

设置属性translateX的值。

setTranslateY(double) - Method in class javafx.scene. Node

设置属性translateY的值。

setTranslateZ(double) - Method in class javafx.scene. Node

设置属性translateZ的值。

setTree(JTree) - Method in class javax.swing.tree. DefaultTreeCellEditor

设置当前编辑的树。

setTreeColumn(TreeTableColumn<S, ?>) - Method in class javafx.scene.control. TreeTableView

设置属性treeColumn的值。

setTrustAnchors(Set<TrustAnchor>) - Method in class java.security.cert. PKIXParameters

设置 Set最受信任的CA。

setTTL(byte) - Method in class java.net. DatagramSocketImpl

已过时。
使用setTimeToLive代替。

setTTL(byte) - Method in class java.net. MulticastSocket

已过时。
使用setTimeToLive方法，它使用int而不是byte作为ttl的类型。

setTx(double) - Method in class javafx.scene.transform. Affine

设置属性tx的值。

setTy(double) - Method in class javafx.scene.transform. Affine

设置属性ty的值。

setType(int) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的类型设置为指定的类型。

setType(int) - Method in interface javax.sql. RowSet

将此 RowSet对象的类型设置为给定类型。

setType(int, String) - Method in class org.xml.sax.helpers. AttributesImpl

设置特定属性的类型。

setType(short) - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

设置元素类型。

setType(Window.Type) - Method in class java.awt. Window

设置窗口的类型。

setType(String) - Method in interface org.w3c.dom.html. HTMLAnchorElement

setType(String) - Method in interface org.w3c.dom.html. HTMLLIElement

setType(String) - Method in interface org.w3c.dom.html. HTMLLinkElement

setType(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setType(String) - Method in interface org.w3c.dom.html. HTMLOListElement

setType(String) - Method in interface org.w3c.dom.html. HTMLParamElement

setType(String) - Method in interface org.w3c.dom.html. HTMLScriptElement

setType(String) - Method in interface org.w3c.dom.html. HTMLStyleElement

setType(String) - Method in interface org.w3c.dom.html. HTMLUListElement

setType(AclEntryType) - Method in class java.nio.file.attribute. AclEntry.Builder

设置此构建器的类型组件。

setType(ArcType) - Method in class javafx.scene.shape. Arc

设置属性类型的值。

setTypeMap(Map<String, Class<?>>) - Method in interface java.sql. Connection

安装给定的 TypeMap对象作为此 Connection对象的类型映射。

setTypeMap(Map<String, Class<?>>) - Method in class javax.sql.rowset. BaseRowSet

安装给定 java.util.Map对象作为与相关联的类型映射 Connection对象此 RowSet对象。

setTypeMap(Map<String, Class<?>>) - Method in interface javax.sql. RowSet

安装给定 java.util.Map对象的默认类型映射此 RowSet对象。

setTz(double) - Method in class javafx.scene.transform. Affine

设置属性tz的值。

setUI(ButtonUI) - Method in class javax.swing. AbstractButton

设置渲染此组件的L＆F对象。

setUI(ColorChooserUI) - Method in class javax.swing. JColorChooser

设置渲染此组件的L＆F对象。

setUI(ComboBoxUI) - Method in class javax.swing. JComboBox

设置渲染此组件的L＆F对象。

setUI(ComponentUI) - Method in class javax.swing. JComponent

设置该组件的外观和感觉委托。

setUI(DesktopIconUI) - Method in class javax.swing. JInternalFrame.JDesktopIcon

设置渲染此组件的外观和对象。

setUI(DesktopPaneUI) - Method in class javax.swing. JDesktopPane

设置渲染此组件的L＆F对象。

setUI(InternalFrameUI) - Method in class javax.swing. JInternalFrame

设置这个 JInternalFrame的UI JInternalFrame 。

setUI(LabelUI) - Method in class javax.swing. JLabel

设置渲染此组件的L＆F对象。

setUI(LayerUI<? super V>) - Method in class javax.swing. JLayer

设置LayerUI ，它将执行绘画和接收JLayer输入事件。

setUI(ListUI) - Method in class javax.swing. JList

设置 ListUI ，呈现此组件的外观和感觉对象。

setUI(MenuBarUI) - Method in class javax.swing. JMenuBar

设置渲染此组件的L＆F对象。

setUI(MenuItemUI) - Method in class javax.swing. JMenuItem

设置呈现此组件的外观和对象。

setUI(OptionPaneUI) - Method in class javax.swing. JOptionPane

设置实现该组件的L＆F的UI对象。

setUI(PanelUI) - Method in class javax.swing. JPanel

设置渲染此组件的外观和感觉（L＆F）对象。

setUI(PopupMenuUI) - Method in class javax.swing. JPopupMenu

设置渲染此组件的L＆F对象。

setUI(ProgressBarUI) - Method in class javax.swing. JProgressBar

设置渲染此组件的外观和对象。

setUI(RootPaneUI) - Method in class javax.swing. JRootPane

设置渲染此组件的L＆F对象。

setUI(ScrollBarUI) - Method in class javax.swing. JScrollBar

设置渲染此组件的L＆F对象。

setUI(ScrollPaneUI) - Method in class javax.swing. JScrollPane

设置为该 ScrollPaneUI提供外观（L＆F）的 ScrollPaneUI对象。

setUI(SeparatorUI) - Method in class javax.swing. JSeparator

设置渲染此组件的L＆F对象。

setUI(SliderUI) - Method in class javax.swing. JSlider

设置实现该组件的L＆F的UI对象。

setUI(SpinnerUI) - Method in class javax.swing. JSpinner

设置渲染此组件的外观和感觉（L＆F）对象。

setUI(SplitPaneUI) - Method in class javax.swing. JSplitPane

设置渲染此组件的L＆F对象。

setUI(TabbedPaneUI) - Method in class javax.swing. JTabbedPane

设置实现该组件的L＆F的UI对象。

setUI(TableHeaderUI) - Method in class javax.swing.table. JTableHeader

设置渲染此组件的外观和感觉（L＆F）对象。

setUI(TableUI) - Method in class javax.swing. JTable

设置渲染此组件并重新绘制的L＆F对象。

setUI(TextUI) - Method in class javax.swing.text. JTextComponent

为这个面向文本的编辑器设置用户界面工厂。

setUI(ToolBarUI) - Method in class javax.swing. JToolBar

设置渲染此组件的L＆F对象。

setUI(TreeUI) - Method in class javax.swing. JTree

设置渲染此组件的L＆F对象。

setUI(ViewportUI) - Method in class javax.swing. JViewport

设置渲染此组件的L＆F对象。

setUlx(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性ulx的值。

setUly(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性uly的值。

setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - Method in class java.lang. Thread

设置当该线程由于未捕获的异常而突然终止时调用的处理程序。

setUndecorated(boolean) - Method in class java.awt. Dialog

禁用或启用此对话框的装饰。

setUndecorated(boolean) - Method in class java.awt. Frame

禁用或启用此框架的装饰。

setUnderline(boolean) - Method in class javafx.scene.control. Labeled

设置属性下划线的值。

setUnderline(boolean) - Method in class javafx.scene.text. Text

设置属性下划线的值。

setUnderline(boolean) - Method in class javax.swing.text. LabelView

设置视图是否加下划线。

setUnderline(MutableAttributeSet, boolean) - Static method in class javax.swing.text. StyleConstants

设置下划线属性。

setUnexecutedModifications(ModificationItem[]) - Method in exception javax.naming.directory. AttributeModificationException

将未执行的修改列表设置为e。

setUnicast(boolean) - Method in class java.beans. EventSetDescriptor

将事件设置为单播（或不）。

setUnicodeBidi(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的unicode-bidi属性定义。

setUnicodeLocaleKeyword(String, String) - Method in class java.util. Locale.Builder

设置给定键的Unicode区域设置关键字类型。

setUnicodeStream(int, InputStream, int) - Method in interface java.sql. PreparedStatement

已过时。
使用setCharacterStream

setUnicodeStream(int, InputStream, int) - Method in class javax.sql.rowset. BaseRowSet

已过时。
getCharacterStream应该用于它的位置

setUnitIncrement(double) - Method in class javafx.scene.control. ScrollBar

设置属性unitIncrement的值。

setUnitIncrement(int) - Method in interface java.awt. Adjustable

设置可调整对象的单位值增量。

setUnitIncrement(int) - Method in class java.awt. Scrollbar

设置此滚动条的单位增量。

setUnitIncrement(int) - Method in class java.awt. ScrollPaneAdjustable

setUnitIncrement(int) - Method in class javax.swing. JScrollBar

设置unitIncrement属性。

setUnitIncrement(int) - Method in class javax.swing. JScrollPane.ScrollBar

消息超级设置值，并将 unitIncrementSet实例变量重置为true。

setUnstableRelinkThreshold(int) - Method in class jdk.dynalink. DynamicLinkerFactory

设置不稳定的重新链接阈值; 呼叫站点重新链接的次数将被认为是不稳定的，随后的链接请求将指示这一点。

setup(FileSystemView) - Method in class javax.swing. JFileChooser

执行常见的构造函数初始化和设置。

setUpdatePolicy(int) - Method in class javax.swing.text. DefaultCaret

在文档更新中设置插入符号移动策略。

setUpdateRect(Rectangle) - Method in class java.awt.event. PaintEvent

设置表示需要重新绘制的区域的矩形以响应此事件。

setUpdateSelectionOnSort(boolean) - Method in class javax.swing. JTable

指定选择是否应在排序后更新。

setUpdateTableInRealTime(boolean) - Method in class javax.swing.table. JTableHeader

作为Java 2平台v1.3的过时。

setupMenuCloseKey() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置菜单关闭键。

setupMenuOpenKey() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置菜单打开键。

setUpperBound(double) - Method in class javafx.scene.chart. ValueAxis

设置属性upperBound的值。

setupPostTimer(JMenu) - Method in class javax.swing.plaf.basic. BasicMenuUI

将定时器设置为 menu 。

setURI(int, String) - Method in class org.xml.sax.helpers. AttributesImpl

设置特定属性的命名空间URI。

setURIDereferencer(URIDereferencer) - Method in class javax.xml.crypto.dom. DOMCryptoContext

setURIDereferencer(URIDereferencer) - Method in interface javax.xml.crypto. XMLCryptoContext

设置一个URIDereferencer ，用于取消引用URIReference s。

setURIResolver(URIResolver) - Method in class javax.xml.transform. Transformer

设置一个用于解析document（）中使用的URI的对象。

setURIResolver(URIResolver) - Method in class javax.xml.transform. TransformerFactory

设置在转换期间默认使用的对象，以解析document（），xsl：import或xsl：include中使用的URI。

setUrl(String) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的Url属性设置为给定的 String对象，并将dataSource名称属性设置为 null 。

setUrl(String) - Method in interface javax.sql. RowSet

设置 RowSet对象在使用 DriverManager创建连接时将使用的URL。

setURL(int, URL) - Method in interface java.sql. PreparedStatement

将指定的参数设置为给定的 java.net.URL值。

setURL(int, URL) - Method in class javax.sql.rowset. BaseRowSet

将指定的参数设置为给定的 java.net.URL值。

setURL(int, URL) - Method in interface javax.sql. RowSet

将指定的参数设置为给定的 java.net.URL值。

setURL(String, URL) - Method in interface java.sql. CallableStatement

将指定的参数设置为给定的 java.net.URL对象。

setURL(URL) - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

设置此事件定位器上的URL字段。

setURL(URL, String, String, int, String, String) - Method in class java.net. URLStreamHandler

已过时。
使用setURL（URL，String，String，int，String，String，String，String）;

setURL(URL, String, String, int, String, String, String, String, String) - Method in class java.net. URLStreamHandler

将 URL参数的字段设置为指示的值。

setURLStreamHandlerFactory(URLStreamHandlerFactory) - Static method in class java.net. URL

设置应用程序的 URLStreamHandlerFactory 。

setUrx(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性urx的值。

setUry(double) - Method in class javafx.scene.effect. PerspectiveTransform

设置属性的值。

setUsageThreshold(long) - Method in interface java.lang.management. MemoryPoolMXBean

如果此内存池支持使用阈值，则将此内存池的阈值设置为给定的 threshold值。

setUseCache(boolean) - Static method in class javax.imageio. ImageIO

设置一个标志，指示在创建 ImageInputStream s和 ImageOutputStream时是否应使用基于磁盘的缓存文件。

setUseCaches(boolean) - Method in class java.net. URLConnection

将此 URLConnection的 useCaches字段的值设置为指定值。

setUseCipherSuitesOrder(boolean) - Method in class javax.net.ssl. SSLParameters

设置本地密码套件的优先级是否应该被兑现。

setUseClientMode(boolean) - Method in class javax.net.ssl. SSLEngine

配置引擎在握手时使用客户端（或服务器）模式。

setUseClientMode(boolean) - Method in class javax.net.ssl. SSLServerSocket

控制接受的连接是否处于（默认）SSL服务器模式或SSL客户端模式。

setUseClientMode(boolean) - Method in class javax.net.ssl. SSLSocket

在握手时，将套接字配置为使用客户端（或服务器）模式。

setUseMap(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setUseMap(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setUseMap(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setUseParentHandlers(boolean) - Method in class java.util.logging. Logger

指定此记录器是否应将其输出发送到其父记录器。

setUserAgent(String) - Method in class javafx.scene.web. WebEngine

设置属性userAgent的值。

setUserAgentStylesheet(String) - Static method in class javafx.application. Application

设置整个应用程序使用的用户代理样式表。

setUserAgentStylesheet(String) - Method in class javafx.scene. Scene

设置此场景将使用的用户代理样式表的URL，而不是platform-default用户代理样式表。

setUserAgentStylesheet(String) - Method in class javafx.scene. SubScene

设置此SubScene将使用的用户代理样式表的URL代替platform-default用户代理样式表。

setUserData(Object) - Method in class javafx.scene.control. MenuItem

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in class javafx.scene.control. Tab

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in class javafx.scene.control. TableColumnBase

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in interface javafx.scene.control. Toggle

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in class javafx.scene.control. ToggleGroup

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in class javafx.scene. Node

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in class javafx.scene. Scene

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in class javafx.stage. Window

用于设置可以在以后检索的单个Object属性的便利方法。

setUserData(Object) - Method in class javax.management. Notification

设置用户数据。

setUserData(String, Object, UserDataHandler) - Method in class javax.imageio.metadata. IIOMetadataNode

IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

setUserData(String, Object, UserDataHandler) - Method in interface org.w3c.dom. Node

将对象与此节点上的键相关联。

setUserDataDirectory(File) - Method in class javafx.scene.web. WebEngine

设置属性userDataDirectory的值。

setUserJVMOptions(Map<String, String>) - Method in interface jdk.packager.services. UserJvmOptionsService

将传入的选项设置为UserJVMOptions。

setUsername(String) - Method in class javax.sql.rowset. BaseRowSet

将此 RowSet对象的用户名属性设置为给定的用户名。

setUsername(String) - Method in interface javax.sql. RowSet

将此 RowSet对象的用户名属性设置为给定的 String 。

setUserObject(Object) - Method in class javax.imageio.metadata. IIOMetadataNode

设置与该节点关联的值。

setUserObject(Object) - Method in class javax.swing.tree. DefaultMutableTreeNode

将此节点的用户对象设置为 userObject 。

setUserObject(Object) - Method in interface javax.swing.tree. MutableTreeNode

将接收者的用户对象重置为 object 。

setUserStyleSheetLocation(String) - Method in class javafx.scene.web. WebEngine

设置属性userStyleSheetLocation的值。

setUseSystemMenuBar(boolean) - Method in class javafx.scene.control. MenuBar

设置属性useSystemMenuBar的值。

setValidating(boolean) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl

指定Unmarshaller是否在解组操作期间进行验证。

setValidating(boolean) - Method in interface javax.xml.bind. Unmarshaller

已过时。
由于JAXB2.0 ，请参阅Unmarshaller.setSchema(javax.xml.validation.Schema)

setValidating(boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

指定此代码生成的解析器将在文档解析时验证文档。

setValidating(boolean) - Method in class javax.xml.parsers. SAXParserFactory

指定此代码生成的解析器将在文档解析时验证文档。

setValidCharacters(String) - Method in class javax.swing.text. MaskFormatter

允许进一步限制可以输入的字符。

setVAlign(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setVAlign(String) - Method in interface org.w3c.dom.html. HTMLTableColElement

setVAlign(String) - Method in interface org.w3c.dom.html. HTMLTableRowElement

setVAlign(String) - Method in interface org.w3c.dom.html. HTMLTableSectionElement

setValignment(VPos) - Method in class javafx.scene.control. Separator

设置属性对齐的值。

setValignment(VPos) - Method in class javafx.scene.layout. RowConstraints

设置属性对齐的值。

setValignment(Node, VPos) - Static method in class javafx.scene.layout. GridPane

设置子窗格的垂直对齐方式。

setValue(boolean) - Method in interface com.sun.jdi.connect. Connector.BooleanArgument

设置参数的值。

setValue(boolean) - Method in class javax.sound.sampled. BooleanControl

设置控件的当前值。

setValue(double) - Method in class javafx.scene.control. ScrollBar

设置属性值的值。

setValue(double) - Method in class javafx.scene.control. Slider

设置属性值的值。

setValue(float) - Method in class javax.sound.sampled. FloatControl

设置控件的当前值。

setValue(int) - Method in interface com.sun.jdi.connect. Connector.IntegerArgument

设置参数的值。

setValue(int) - Method in interface java.awt. Adjustable

设置可调对象的当前值。

setValue(int) - Method in class java.awt. Scrollbar

将此滚动条的值设置为指定的值。

setValue(int) - Method in class java.awt. ScrollPaneAdjustable

将此滚动条的值设置为指定的值。

setValue(int) - Method in interface javax.swing. BoundedRangeModel

如果 newValue满足模型的约束， newValue模型的当前值设置为 newValue 。

setValue(int) - Method in class javax.swing. DefaultBoundedRangeModel

设置模型的当前值。

setValue(int) - Method in class javax.swing. JProgressBar

将进度条的当前值设置为 n 。

setValue(int) - Method in class javax.swing. JScrollBar

设置滚动条的值。

setValue(int) - Method in class javax.swing. JSlider

将滑块的当前值设置为 n 。

setValue(int) - Method in class javax.swing. Spring

将此 Spring的当前 值设置为 value 。

setValue(int) - Method in interface org.w3c.dom.html. HTMLLIElement

setValue(int, Value) - Method in interface com.sun.jdi. ArrayReference

用另一个值替换数组组件。

setValue(int, String) - Method in class org.xml.sax.helpers. AttributesImpl

设置特定属性的值。

setValue(Field, Value) - Method in interface com.sun.jdi. ClassType

为静态字段分配一个值。

setValue(Field, Value) - Method in interface com.sun.jdi. ObjectReference

设置此对象中给定实例或静态字段的值。

setValue(LocalVariable, Value) - Method in interface com.sun.jdi. StackFrame

在此框架中设置LocalVariable的Value 。

setValue(Boolean) - Method in class javafx.beans.property. BooleanProperty

设置包装的值。

setValue(Boolean) - Method in interface javafx.beans.value. WritableBooleanValue

设置包装的值。

setValue(Number) - Method in class javafx.beans.property. DoubleProperty

设置包装的值。

setValue(Number) - Method in class javafx.beans.property. FloatProperty

设置包装的值。

setValue(Number) - Method in class javafx.beans.property. IntegerProperty

设置包装的值。

setValue(Number) - Method in class javafx.beans.property. LongProperty

设置包装的值。

setValue(Number) - Method in interface javafx.beans.value. WritableDoubleValue

设置包装的值。

setValue(Number) - Method in interface javafx.beans.value. WritableFloatValue

设置包装的值。

setValue(Number) - Method in interface javafx.beans.value. WritableIntegerValue

设置包装的值。

setValue(Number) - Method in interface javafx.beans.value. WritableLongValue

设置包装的值。

setValue(Object) - Method in class java.beans. Expression

将此表达式的值设置为 value 。

setValue(Object) - Method in interface java.beans. PropertyEditor

设置（或更改）要编辑的对象。

setValue(Object) - Method in class java.beans. PropertyEditorSupport

设置（或更改）要编辑的对象。

setValue(Object) - Method in class javax.sound.sampled. EnumControl

设置控件的当前值。

setValue(Object) - Method in class javax.swing. DefaultCellEditor.EditorDelegate

设置此单元格的值。

setValue(Object) - Method in class javax.swing. JFormattedTextField

设置将通过被格式化的值 AbstractFormatter从当前获得的 AbstractFormatterFactory 。

setValue(Object) - Method in class javax.swing. JOptionPane

设置用户选择的值。

setValue(Object) - Method in class javax.swing. JSpinner

更改模型的当前值，通常这个值由 editor显示。

setValue(Object) - Method in class javax.swing. SpinnerDateModel

设置此序列的当前 Date 。

setValue(Object) - Method in class javax.swing. SpinnerListModel

更改序列的当前元素并通知 ChangeListeners 。

setValue(Object) - Method in interface javax.swing. SpinnerModel

更改模型的当前值，通常这个值由 editor部分显示 JSpinner 。

setValue(Object) - Method in class javax.swing. SpinnerNumberModel

设置此序列的当前值。

setValue(Object) - Method in class javax.swing.table. DefaultTableCellRenderer

将要呈现的单元格的 String对象设置为 value 。

setValue(Object, boolean) - Method in interface javax.swing. Renderer

指定要显示的值以及该值是否应被描述为“当前选择”。

setValue(String) - Method in interface com.sun.jdi.connect. Connector.Argument

设置参数的值。

setValue(String) - Method in class java.net. HttpCookie

在创建cookie之后为cookie分配一个新值。

setValue(String) - Method in class javafx.beans.property. StringProperty

设置包装的值。

setValue(String) - Method in interface javax.xml.soap. Node

如果这是一个Text节点，那么这个方法将设置它的值，否则它设置该节点的immediate（Text）子节点的值。

setValue(String) - Method in interface org.w3c.dom. Attr

在检索时，属性的值作为字符串返回。

setValue(String) - Method in interface org.w3c.dom.html. HTMLButtonElement

setValue(String) - Method in interface org.w3c.dom.html. HTMLInputElement

setValue(String) - Method in interface org.w3c.dom.html. HTMLOptionElement

setValue(String) - Method in interface org.w3c.dom.html. HTMLParamElement

setValue(String) - Method in interface org.w3c.dom.html. HTMLSelectElement

setValue(String) - Method in interface org.w3c.dom.html. HTMLTextAreaElement

setValue(String, Object) - Method in class java.beans. FeatureDescriptor

将命名属性与此功能相关联。

setValue(ObservableList<E>) - Method in class javafx.beans.property. ListProperty

设置包装的值。

setValue(ObservableMap<K, V>) - Method in class javafx.beans.property. MapProperty

设置包装的值。

setValue(ObservableSet<E>) - Method in class javafx.beans.property. SetProperty

设置包装的值。

setValue(T) - Method in class javafx.beans.property. ObjectProperty

设置包装的值。

setValue(T) - Method in interface javafx.beans.value. WritableValue

设置包装的值。

setValue(T) - Method in class javafx.scene.chart. Axis.TickMark

设置属性值的值。

setValue(T) - Method in class javafx.scene.control. ChoiceBox

设置属性值的值。

setValue(T) - Method in class javafx.scene.control. ComboBoxBase

设置属性值的值。

setValue(T) - Method in class javafx.scene.control. SpinnerValueFactory

设置属性值的值。

setValue(T) - Method in class javafx.scene.control. TreeItem

设置此TreeItem表示的应用程序特定数据。

setValue(T) - Method in class javax.xml.bind. JAXBElement

设置这个xml元素的内容模型和属性。

setValue(V) - Method in class java.util. AbstractMap.SimpleEntry

用指定的值替换与该条目相对应的值。

setValue(V) - Method in class java.util. AbstractMap.SimpleImmutableEntry

用指定的值替换与该条目相对应的值（可选操作）。

setValue(V) - Method in interface java.util. Map.Entry

用指定的值替换与该条目相对应的值（可选操作）。

setValue(V) - Method in class javafx.scene.control. TextFormatter

设置属性值的值。

setValueAt(Object, int, int) - Method in class javax.swing. JTable

设置表模型中单元格的值为 row和 column 。

setValueAt(Object, int, int) - Method in class javax.swing.table. AbstractTableModel

这个空的实现被提供，所以如果用户的数据模型是不可编辑的，用户就不需要实现这个方法。

setValueAt(Object, int, int) - Method in class javax.swing.table. DefaultTableModel

设置单元格的对象值为 column和 row 。

setValueAt(Object, int, int) - Method in interface javax.swing.table. TableModel

将单元格中的值设置为 columnIndex并将 rowIndex为 aValue 。

setValueChanging(boolean) - Method in class javafx.scene.control. Slider

设置属性valueChanging的值。

setValueClass(Class<?>) - Method in class javax.swing.text. DefaultFormatter

设置用于创建新对象的类。

setValueContainsLiteralCharacters(boolean) - Method in class javax.swing.text. MaskFormatter

如果为true，则返回的值和设置值也将包含掩码中的文字字符。

setValueFactory(SpinnerValueFactory<T>) - Method in class javafx.scene.control. Spinner

设置属性valueFactory的值。

setValueIsAdjusting(boolean) - Method in class java.awt. Scrollbar

设置 valueIsAdjusting属性。

setValueIsAdjusting(boolean) - Method in class java.awt. ScrollPaneAdjustable

设置 valueIsAdjusting属性。

setValueIsAdjusting(boolean) - Method in interface javax.swing. BoundedRangeModel

该属性表示任何即将到来的对模型值的更改都应被视为单个事件。

setValueIsAdjusting(boolean) - Method in class javax.swing. DefaultBoundedRangeModel

设置 valueIsAdjusting属性。

setValueIsAdjusting(boolean) - Method in class javax.swing. DefaultListSelectionModel

设置 valueIsAdjusting属性，其指示即将到来的选择更改是否应被视为单个更改的一部分。

setValueIsAdjusting(boolean) - Method in class javax.swing. JList

设置选择模型的 valueIsAdjusting属性。

setValueIsAdjusting(boolean) - Method in class javax.swing. JScrollBar

设置模型的valueIsAdjusting属性。

setValueIsAdjusting(boolean) - Method in class javax.swing. JSlider

设置型号的 valueIsAdjusting属性。

setValueIsAdjusting(boolean) - Method in interface javax.swing. ListSelectionModel

设置 valueIsAdjusting属性，其指示即将进行的选择更改是否应被视为单个更改的一部分。

setValues(int, int, int, int) - Method in class java.awt. Scrollbar

设置的四个属性此滚动条的值： value ， visibleAmount ， minimum ，并 maximum 。

setValues(int, int, int, int) - Method in class javax.swing. JScrollBar

强制参数遵循通常的约束，设置四个BoundedRangeModel属性：

setValues(int, List<? extends Value>, int, int) - Method in interface com.sun.jdi. ArrayReference

用其他值替换一系列阵列组件。

setValues(List<? extends Value>) - Method in interface com.sun.jdi. ArrayReference

用其他值替换所有数组组件。

setValueType(String) - Method in interface org.w3c.dom.html. HTMLParamElement

setVariant(String) - Method in class java.util. Locale.Builder

设置变体。

setVbarPolicy(ScrollPane.ScrollBarPolicy) - Method in class javafx.scene.control. ScrollPane

设置属性vbarPolicy的值。

setVerbose(boolean) - Method in interface java.lang.management. ClassLoadingMXBean

启用或禁用类加载系统的详细输出。

setVerbose(boolean) - Method in interface java.lang.management. MemoryMXBean

启用或禁用内存系统的详细输出。

setVerifyInputWhenFocusTarget(boolean) - Method in class javax.swing. JComponent

设置该值以指示在此组件请求焦点之前是否调用当前焦点所有者的输入验证器。

setVersion(int) - Method in class java.net. HttpCookie

设置cookie符合的cookie协议的版本。

setVersion(String) - Method in interface org.w3c.dom.html. HTMLHtmlElement

setVertexFormat(VertexFormat) - Method in class javafx.scene.shape. TriangleMesh

设置属性vertexFormat的值。

setVertical(boolean) - Method in class javafx.scene.control.skin. VirtualFlow

设置属性垂直的值。

setVerticalAlign(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的vertical-align属性定义。

setVerticalAlignment(int) - Method in class javax.swing. AbstractButton

设置图标和文本的垂直对齐方式。

setVerticalAlignment(int) - Method in class javax.swing. JLabel

设置标签内容沿着Y轴的对齐方式。

setVerticalFieldOfView(boolean) - Method in class javafx.scene. PerspectiveCamera

设置属性verticalFieldOfView的值。

setVerticalGridLinesVisible(boolean) - Method in class javafx.scene.chart. XYChart

设置属性verticalGridLinesVisible的值。

setVerticalGroup(GroupLayout.Group) - Method in class javax.swing. GroupLayout

设置 Group位置和尺寸沿垂直轴的组件。

setVerticalScrollBar(JScrollBar) - Method in class javax.swing. JScrollPane

将控制视口垂直视图位置的滚动条添加到滚动条。

setVerticalScrollBarPolicy(int) - Method in class javax.swing. JScrollPane

确定滚动条中何时出现垂直滚动条。

setVerticalScrollBarPolicy(int) - Method in class javax.swing. ScrollPaneLayout

设置垂直滚动条显示策略。

setVerticalTextPosition(int) - Method in class javax.swing. AbstractButton

设置文本相对于图标的垂直位置。

setVerticalTextPosition(int) - Method in class javax.swing. JLabel

设置标签文本相对于其图像的垂直位置。

setVerticalZeroLineVisible(boolean) - Method in class javafx.scene.chart. XYChart

设置属性verticalZeroLineVisible的值。

setVgap(double) - Method in class javafx.scene.layout. FlowPane

设置属性vgap的值。

setVgap(double) - Method in class javafx.scene.layout. GridPane

设置属性vgap的值。

setVgap(double) - Method in class javafx.scene.layout. TilePane

设置属性vgap的值。

setVgap(int) - Method in class java.awt. BorderLayout

设置组件之间的垂直间距。

setVgap(int) - Method in class java.awt. CardLayout

设置组件之间的垂直间距。

setVgap(int) - Method in class java.awt. FlowLayout

设置组件之间以及组件与 Container的边框之间的垂直间距。

setVgap(int) - Method in class java.awt. GridLayout

将组件之间的垂直间距设置为指定值。

setVgrow(Priority) - Method in class javafx.scene.layout. RowConstraints

设置属性vgrow的值。

setVgrow(Node, Priority) - Static method in class javafx.scene.layout. GridPane

设置子格中包含的网格的垂直成长优先级。

setVgrow(Node, Priority) - Static method in class javafx.scene.layout. VBox

设置由vbox包含的小孩的垂直成长优先级。

setView(Component) - Method in class javax.swing. JViewport

设置 JViewport的一个轻量级的小孩（ view ），可以是 null 。

setView(View) - Method in class javax.swing.plaf.basic. BasicTextUI

设置视图层次结构的当前根，并调用invalidate（）。

setView(V) - Method in class javax.swing. JLayer

设置 JLayer的视图组件，可以是 null 。

setViewOrder(double) - Method in class javafx.scene. Node

设置属性viewOrder的值。

setViewport(Rectangle2D) - Method in class javafx.scene.image. ImageView

设置属性视口的值。

setViewport(Rectangle2D) - Method in class javafx.scene.media. MediaView

将矩形视口设置到媒体框架中。

setViewport(Rectangle2D) - Method in class javafx.scene. SnapshotParameters

设置用于渲染的视口。

setViewport(JViewport) - Method in class javax.swing. JScrollPane

删除旧的视口（如果有的话）; 迫使新视口的观点位于+ x，+ y象限中; 使用新的视口同步行和列标题（如果有的话）; 最后使用新的视口同步滚动条和标题。

setViewportBorder(Border) - Method in class javax.swing. JScrollPane

在视口周围添加一个边框。

setViewportBounds(Bounds) - Method in class javafx.scene.control. ScrollPane

设置属性viewportBounds的值。

setViewportView(Component) - Method in class javax.swing. JScrollPane

如果需要，创建一个视口，然后设置它的视图。

setViewPosition(Point) - Method in class javax.swing. JViewport

设置出现在视口左上角的视图坐标，如果没有视图，则不执行任何操作。

setViewSize(Dimension) - Method in class javax.swing. JViewport

设置视图的大小。

setVisibility(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的visibility属性定义。

setVisible(boolean) - Method in class com.sun.java.accessibility.util. Translator

设置对象的可见状态。

setVisible(boolean) - Method in class java.awt. Component.AccessibleAWTComponent

设置对象的可见状态。

setVisible(boolean) - Method in class java.awt. Component

根据参数 b的值显示或隐藏此组件。

setVisible(boolean) - Method in class java.awt. Dialog

显示或隐藏此 Dialog取决于参数的值 b 。

setVisible(boolean) - Method in class java.awt. List.AccessibleAWTList.AccessibleAWTListChild

设置对象的可见状态。

setVisible(boolean) - Method in class java.awt. MenuComponent.AccessibleAWTMenuComponent

设置对象的可见状态。

setVisible(boolean) - Method in class java.awt. Window

显示或隐藏此 Window取决于参数的值 b 。

setVisible(boolean) - Method in class javafx.scene.control. MenuItem

设置属性的值可见。

setVisible(boolean) - Method in class javafx.scene.control. TableColumnBase

设置属性的值可见。

setVisible(boolean) - Method in class javafx.scene. Node

设置属性的值可见。

setVisible(boolean) - Method in interface javax.accessibility. AccessibleComponent

设置对象的可见状态。

setVisible(boolean) - Method in class javax.swing. JComponent

使组件可见或不可见。

setVisible(boolean) - Method in class javax.swing. JList.AccessibleJList.AccessibleJListChild

setVisible(boolean) - Method in class javax.swing. JPopupMenu

设置弹出菜单的可见性。

setVisible(boolean) - Method in class javax.swing. JTable.AccessibleJTable.AccessibleJTableCell

设置对象的可见状态。

setVisible(boolean) - Method in class javax.swing. JTree.AccessibleJTree.AccessibleJTreeNode

setVisible(boolean) - Method in class javax.swing.table. JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setVisible(boolean) - Method in interface javax.swing.text. Caret

设置插入符号的可见性。

setVisible(boolean) - Method in class javax.swing.text. DefaultCaret

设置插入符的可见性，并重新绘制插入符号。

setVisibleAmount(double) - Method in class javafx.scene.control. ScrollBar

设置属性visibleAmount的值。

setVisibleAmount(int) - Method in interface java.awt. Adjustable

设置可调整对象的比例指示器的长度。

setVisibleAmount(int) - Method in class java.awt. Scrollbar

设置此滚动条的可见数量。

setVisibleAmount(int) - Method in class java.awt. ScrollPaneAdjustable

此方法 不应由用户代码调用。

setVisibleAmount(int) - Method in class javax.swing. JScrollBar

设置模型的扩展属性。

setVisibleComponent(Component) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

设置可见组件。

setVisibleRowCount(int) - Method in class javafx.scene.control. ComboBox

设置属性visibleRowCount的值。

setVisibleRowCount(int) - Method in class javax.swing. JList

根据布局方向设置visibleRowCount属性，具有不同的含义：对于VERTICAL布局方向，这将设置要显示的首选行数，而不需要滚动; 对于其他取向，它影响细胞的包裹。

setVisibleRowCount(int) - Method in class javax.swing. JTree

设置要显示的行数。

setVisited(boolean) - Method in class javafx.scene.control. Hyperlink

设置访问的属性的值。

setVLink(String) - Method in interface org.w3c.dom.html. HTMLBodyElement

setVmax(double) - Method in class javafx.scene.control. ScrollPane

设置属性vmax的值。

setVmin(double) - Method in class javafx.scene.control. ScrollPane

设置属性vmin的值。

setVMOption(String, String) - Method in interface com.sun.management. HotSpotDiagnosticMXBean

将给定名称的VM选项设置为指定的值。

setVoiceFamily(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的voice-family属性定义。

setVolatile(Object...) - Method in class java.lang.invoke. VarHandle

将变量的值设置为 newValue ，其内存语义设置为声明为变量的 volatile 。

setVolume(double) - Method in class javafx.scene.media. AudioClip

设置默认音量级别。

setVolume(double) - Method in class javafx.scene.media. MediaPlayer

设置音频播放音量。

setVolume(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的卷属性定义。

setVspace(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setVspace(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setVspace(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setVvalue(double) - Method in class javafx.scene.control. ScrollPane

设置属性vvalue的值。

setWantClientAuth(boolean) - Method in class com.sun.net.httpserver. HttpsParameters

设置是否请求客户端身份验证。

setWantClientAuth(boolean) - Method in class javax.net.ssl. SSLEngine

配置引擎以 请求客户端身份验证。

setWantClientAuth(boolean) - Method in class javax.net.ssl. SSLParameters

设置是否请求客户端身份验证。

setWantClientAuth(boolean) - Method in class javax.net.ssl. SSLServerSocket

控制是否最初配置 accept ed服务器模式 SSLSockets以 请求客户端身份验证。

setWantClientAuth(boolean) - Method in class javax.net.ssl. SSLSocket

配置套接字以 请求客户端认证。

setWantsInput(boolean) - Method in class javax.swing. JOptionPane

设置 wantsInput属性。

setWasIcon(JInternalFrame, Boolean) - Method in class javax.swing. DefaultDesktopManager

设置组件已被图标化，并且 desktopIcon的边界是有效的。

setWeekDate(int, int, int) - Method in class java.util. Calendar.Builder

将基于周的日期参数设置为给定日期说明符 - 周年，年周和星期几的值。

setWeekDate(int, int, int) - Method in class java.util. Calendar

使用给定的日期说明符 - 周年，年份和星期几设置此 Calendar的日期。

setWeekDate(int, int, int) - Method in class java.util. GregorianCalendar

设置此 GregorianCalendar由日期符给出的日期- weekYear ， weekOfYear ，并 dayOfWeek 。

setWeekdays(String[]) - Method in class java.text. DateFormatSymbols

设置工作日字符串

setWeekDefinition(int, int) - Method in class java.util. Calendar.Builder

将 firstDayOfWeek参数设置为 firstDayOfWeek和 minimalDaysInFirstWeek给出的值，用于确定一年中的 first week 。

setWestPane(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI

设置西窗格。

setWheelScrollingEnabled(boolean) - Method in class java.awt. ScrollPane

启用/禁用滚动以响应鼠标滚轮的移动。

setWheelScrollingEnabled(boolean) - Method in class javax.swing. JScrollPane

启用/禁用滚动以响应鼠标滚轮的移动。

setWhiteSpace(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的空格属性定义。

setWidows(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的widows属性定义。

setWidth(double) - Method in class javafx.scene.canvas. Canvas

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.control. Dialog

设置对话框的宽度。

setWidth(double) - Method in class javafx.scene.control.skin. VirtualFlow

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.effect. BoxBlur

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.effect. ColorInput

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.effect. DropShadow

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.effect. InnerShadow

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.effect. Shadow

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.layout. Region

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.shape. Box

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.shape. Rectangle

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene. SubScene

设置属性宽度的值。

setWidth(double) - Method in class javafx.scene.text. TextFlow

setWidth(double) - Method in class javafx.stage. Window

设置属性宽度的值。

setWidth(int) - Method in class javafx.scene.effect. FloatMap

设置属性宽度的值。

setWidth(int) - Method in class javax.swing.table. TableColumn

该方法不应用于设置 JTable的列的宽度，而是使用 setPreferredWidth 。

setWidth(int) - Method in interface org.w3c.dom.html. HTMLPreElement

setWidth(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的width属性定义。

setWidth(String) - Method in interface org.w3c.dom.html. HTMLAppletElement

setWidth(String) - Method in interface org.w3c.dom.html. HTMLHRElement

setWidth(String) - Method in interface org.w3c.dom.html. HTMLIFrameElement

setWidth(String) - Method in interface org.w3c.dom.html. HTMLImageElement

setWidth(String) - Method in interface org.w3c.dom.html. HTMLObjectElement

setWidth(String) - Method in interface org.w3c.dom.html. HTMLTableCellElement

setWidth(String) - Method in interface org.w3c.dom.html. HTMLTableColElement

setWidth(String) - Method in interface org.w3c.dom.html. HTMLTableElement

setWidth(Spring) - Method in class javax.swing. SpringLayout.Constraints

设置 width属性，它控制组件的宽度。

setWindingRule(int) - Method in class java.awt.geom. Path2D

将此路径的绕组规则设置为指定值。

setWindowDecorationStyle(int) - Method in class javax.swing. JRootPane

设置 JRootPane应该提供的窗口装饰类型（如边框，关闭窗口的小部件，标题...）。

setWindowIconBadge(Window, Image) - Method in class java.awt. Taskbar

在指定窗口的任务区域中贴上小应用程序的图标。

setWindowProgressState(Window, Taskbar.State) - Method in class java.awt. Taskbar

设置指定窗口的进度状态。

setWindowProgressValue(Window, int) - Method in class java.awt. Taskbar

在指定窗口的任务区域中显示确定的进度条。

setWordSpacing(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的word-spacing属性定义。

setWrap(boolean) - Method in class javafx.scene.effect. DisplacementMap

设置属性包装的值。

setWrapAround(boolean) - Method in class javafx.scene.control. SpinnerValueFactory

设置属性wrapAround的值。

setWrappingWidth(double) - Method in class javafx.scene.text. Text

设置wrapWidth属性的值。

setWrapStyleWord(boolean) - Method in class javax.swing. JTextArea

如果文本区域是包装线，则设置使用的包装样式。

setWrapText(boolean) - Method in class javafx.scene.control. Labeled

设置属性wrapText的值。

setWrapText(boolean) - Method in class javafx.scene.control. TextArea

设置属性wrapText的值。

setWrapText(boolean) - Method in class javafx.scene.control. Tooltip

设置属性wrapText的值。

setWritable(boolean) - Method in class java.io. File

一种方便的方法来设置所有者对此抽象路径名的写入权限。

setWritable(boolean, boolean) - Method in class java.io. File

设置此抽象路径名的所有者或每个人的写入权限。

setWriteMethod(Method) - Method in class java.beans. PropertyDescriptor

设置应用于写入属性值的方法。

setWriter(Writer) - Method in interface javax.script. ScriptContext

设置 Writer用于显示输出时使用的脚本。

setWriter(Writer) - Method in class javax.script. SimpleScriptContext

设置显示输出时要使用的脚本的 Writer 。

setWriter(Writer) - Method in class javax.xml.transform.stream. StreamResult

设置要接收结果的作者。

setX(double) - Method in class javafx.scene.control. Dialog

设置属性x的值。

setX(double) - Method in class javafx.scene.effect. ColorInput

设置属性x的值。

setX(double) - Method in class javafx.scene.effect. ImageInput

设置属性x的值。

setX(double) - Method in class javafx.scene.effect. Light.Point

设置属性x的值。

setX(double) - Method in class javafx.scene.image. ImageView

设置属性x的值。

setX(double) - Method in class javafx.scene.media. MediaView

设置 MediaView原点的x坐标。

setX(double) - Method in class javafx.scene.shape. ArcTo

设置属性x的值。

setX(double) - Method in class javafx.scene.shape. CubicCurveTo

设置属性x的值。

setX(double) - Method in class javafx.scene.shape. HLineTo

设置属性x的值。

setX(double) - Method in class javafx.scene.shape. LineTo

设置属性x的值。

setX(double) - Method in class javafx.scene.shape. MoveTo

设置属性x的值。

setX(double) - Method in class javafx.scene.shape. QuadCurveTo

设置属性x的值。

setX(double) - Method in class javafx.scene.shape. Rectangle

设置属性x的值。

setX(double) - Method in class javafx.scene.text. Text

设置属性x的值。

setX(double) - Method in class javafx.scene.transform. Scale

设置属性x的值。

setX(double) - Method in class javafx.scene.transform. Shear

设置属性x的值。

setX(double) - Method in class javafx.scene.transform. Translate

设置属性x的值。

setX(double) - Method in class javafx.stage. Window

设置属性x的值。

setX(Spring) - Method in class javax.swing. SpringLayout.Constraints

设置 x属性，它控制组件位置的值为 x 。

setXAxisRotation(double) - Method in class javafx.scene.shape. ArcTo

以度为单位设置x轴旋转。

setXIncludeAware(boolean) - Method in class javax.xml.parsers. DocumentBuilderFactory

设置XInclude处理的状态。

setXIncludeAware(boolean) - Method in class javax.xml.parsers. SAXParserFactory

设置XInclude处理的状态。

setXMLReader(XMLReader) - Method in class javax.xml.transform.sax. SAXSource

设置要用于源的XMLReader。

setXMLReporter(XMLReporter) - Method in class javax.xml.stream. XMLInputFactory

该记者会设置在由此工厂实例创建的任何XMLStreamReader或XMLEventReader上。

setXMLResolver(XMLResolver) - Method in class javax.xml.stream. XMLInputFactory

将在此工厂实例创建的任何XMLStreamReader或XMLEventReader上设置的解析器。

setXmlStandalone(boolean) - Method in interface org.w3c.dom. Document

作为 XML declaration的一部分，属性指定此文档是否是独立的。

setXmlVersion(String) - Method in interface org.w3c.dom. Document

作为 XML declaration的一部分的属性，指定此文档的版本号。

setXMLVersion(String) - Method in class org.xml.sax.ext. Locator2Impl

分配版本属性的当前值。

setXORMode(Color) - Method in class java.awt. Graphics

设置此图形上下文的绘制模式，以在此图形上下文的当前颜色和新的指定颜色之间交替显示。

setXORMode(Color) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.setXORMode 。

setXPathFunctionResolver(XPathFunctionResolver) - Method in interface javax.xml.xpath. XPath

建立一个函数解析器。

setXPathFunctionResolver(XPathFunctionResolver) - Method in class javax.xml.xpath. XPathFactory

建立默认函数解析器。

setXPathVariableResolver(XPathVariableResolver) - Method in interface javax.xml.xpath. XPath

建立变量解析器。

setXPathVariableResolver(XPathVariableResolver) - Method in class javax.xml.xpath. XPathFactory

建立一个默认变量解析器。

setXValue(X) - Method in class javafx.scene.chart. XYChart.Data

设置在X轴上绘制的通用数据值。

setY(double) - Method in class javafx.scene.control. Dialog

设置属性y的值。

setY(double) - Method in class javafx.scene.effect. ColorInput

设置属性y的值。

setY(double) - Method in class javafx.scene.effect. ImageInput

设置属性y的值。

setY(double) - Method in class javafx.scene.effect. Light.Point

设置属性y的值。

setY(double) - Method in class javafx.scene.image. ImageView

设置属性y的值。

setY(double) - Method in class javafx.scene.media. MediaView

设置 MediaView原点的y坐标。

setY(double) - Method in class javafx.scene.shape. ArcTo

设置属性y的值。

setY(double) - Method in class javafx.scene.shape. CubicCurveTo

设置属性y的值。

setY(double) - Method in class javafx.scene.shape. LineTo

设置属性y的值。

setY(double) - Method in class javafx.scene.shape. MoveTo

设置属性y的值。

setY(double) - Method in class javafx.scene.shape. QuadCurveTo

设置属性y的值。

setY(double) - Method in class javafx.scene.shape. Rectangle

设置属性y的值。

setY(double) - Method in class javafx.scene.shape. VLineTo

设置属性y的值。

setY(double) - Method in class javafx.scene.text. Text

设置属性y的值。

setY(double) - Method in class javafx.scene.transform. Scale

设置属性y的值。

setY(double) - Method in class javafx.scene.transform. Shear

设置属性y的值。

setY(double) - Method in class javafx.scene.transform. Translate

设置属性y的值。

setY(double) - Method in class javafx.stage. Window

设置属性y的值。

setY(Spring) - Method in class javax.swing. SpringLayout.Constraints

设置 y属性，它控制组件位置的 y值。

setYear(int) - Method in class java.sql. Time

已过时。

setYear(int) - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由Calendar.set(Calendar.YEAR, year + 1900)替代。

setYear(int) - Method in class javax.xml.datatype. XMLGregorianCalendar

设定年度XSD dateTime年期。

setYear(BigInteger) - Method in class javax.xml.datatype. XMLGregorianCalendar

设置XSD dateTime年期的低阶和高阶分量。

setYValue(Y) - Method in class javafx.scene.chart. XYChart.Data

设置在Y轴上绘制的通用数据值。

setZ(double) - Method in class javafx.scene.effect. Light.Point

设置属性z的值。

setZ(double) - Method in class javafx.scene.transform. Scale

设置属性z的值。

setZ(double) - Method in class javafx.scene.transform. Translate

设置属性z的值。

setZeroDigit(char) - Method in class java.text. DecimalFormatSymbols

设置用于零的字符。

setZIndex(String) - Method in interface org.w3c.dom.css. CSS2Properties

请参阅CSS2中的z-index属性定义。

setZoneStrings(String[][]) - Method in class java.text. DateFormatSymbols

设置时区字符串。

setZoom(double) - Method in class javafx.scene.web. WebView

设置属性缩放的值。

severe(String) - Method in class java.util.logging. Logger

记录一个SEVERE消息。

severe(Supplier<String>) - Method in class java.util.logging. Logger

记录一个SEVERE消息，只有当记录级别实际上记录该消息时，才会构建一个SEVERE消息。

SEVERE - Static variable in class java.util.logging. Level

SEVERE是指示严重故障的消息级别。

Severity - Class in javax.print.attribute.standard

Class Severity是一个打印属性类，枚举，表示PrinterStateReason属性的严重性。

Severity(int) - Constructor for class javax.print.attribute.standard. Severity

使用给定的整数值构造新的严重性枚举值。

SEVERITY_ERROR - Static variable in interface org.w3c.dom. DOMError

DOMError描述的错误的 DOMError是错误的。

SEVERITY_FATAL_ERROR - Static variable in interface org.w3c.dom. DOMError

DOMError描述的错误的 DOMError是致命的错误。

SEVERITY_WARNING - Static variable in interface org.w3c.dom. DOMError

DOMError描述的错误的 DOMError是警告。

SHA1 - Static variable in class java.security.spec. MGF1ParameterSpec

使用“SHA-1”消息摘要的MGF1ParameterSpec。

SHA1 - Static variable in interface javax.xml.crypto.dsig. DigestMethod

SHA1摘要方法算法URI。

SHA224 - Static variable in class java.security.spec. MGF1ParameterSpec

使用“SHA-224”消息摘要的MGF1ParameterSpec。

SHA256 - Static variable in class java.security.spec. MGF1ParameterSpec

使用“SHA-256”消息摘要的MGF1ParameterSpec。

SHA256 - Static variable in interface javax.xml.crypto.dsig. DigestMethod

SHA256摘要方法算法URI。

SHA384 - Static variable in class java.security.spec. MGF1ParameterSpec

使用“SHA-384”消息摘要的MGF1ParameterSpec。

SHA512 - Static variable in class java.security.spec. MGF1ParameterSpec

使用SHA-512消息摘要的MGF1ParameterSpec。

SHA512 - Static variable in interface javax.xml.crypto.dsig. DigestMethod

SHA512摘要方法算法URI。

shadow - Variable in class javax.swing.border. EtchedBorder

用于蚀刻阴影的颜色。

shadow - Variable in class javax.swing.plaf.basic. BasicBorders.ButtonBorder

阴影的颜色

shadow - Variable in class javax.swing.plaf.basic. BasicBorders.FieldBorder

阴影的颜色

shadow - Variable in class javax.swing.plaf.basic. BasicBorders.SplitPaneBorder

阴影的颜色

shadow - Variable in class javax.swing.plaf.basic. BasicSeparatorUI

阴影的颜色。

shadow - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

阴影颜色

Shadow - Class in javafx.scene.effect

产生具有模糊边缘的输入的单色副本的效果。

Shadow() - Constructor for class javafx.scene.effect. Shadow

使用默认参数创建一个新的Shadow实例。

Shadow(double, Color) - Constructor for class javafx.scene.effect. Shadow

用指定的半径和颜色创建一个新的Shadow实例。

Shadow(BlurType, Color, double) - Constructor for class javafx.scene.effect. Shadow

用指定的blurType，color，radius创建一个新的Shadow实例。

shadowInner - Variable in class javax.swing.border. BevelBorder

用于斜面内阴影的颜色。

shadowOuter - Variable in class javax.swing.border. BevelBorder

用于斜面外阴的颜色

shallowClone() - Method in class java.awt.image.renderable. ParameterBlock

创建一个 ParameterBlock的浅拷贝。

shape(char[], int, int) - Method in class java.awt.font. NumericShaper

转换在start和start + count之间发生的文本中的数字。

shape(char[], int, int, int) - Method in class java.awt.font. NumericShaper

使用提供的上下文转换在start和start + count之间发生的文本中的数字。

shape(char[], int, int, NumericShaper.Range) - Method in class java.awt.font. NumericShaper

使用提供的 context转换 start和 start + count之间的文本中的数字。

Shape - Class in javafx.scene.shape

Shape类为表示某种形式的几何形状的对象提供了常用属性的定义。

Shape - Interface in java.awt

Shape接口为表示某种形式的几何形状的对象提供了定义。

Shape() - Constructor for class javafx.scene.shape. Shape

创建一个空的Shape实例。

SHAPE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“形”

SHAPE_CLIP - javafx.application. ConditionalFeature

表示在平台上可以使用任意形状的剪辑。

Shape3D - Class in javafx.scene.shape

Shape3D基类为表示某种形式的3D几何形状的对象提供了常见属性的定义。

Shape3D() - Constructor for class javafx.scene.shape. Shape3D

ShapeConverter - Class in javafx.css.converter

将SVG形状字符串转换为Shape对象。

ShapeConverter() - Constructor for class javafx.css.converter. ShapeConverter

ShapeGraphicAttribute - Class in java.awt.font

该ShapeGraphicAttribute类的实现GraphicAttribute绘制形状在TextLayout 。

ShapeGraphicAttribute(Shape, int, boolean) - Constructor for class java.awt.font. ShapeGraphicAttribute

构造一个ShapeGraphicAttribute为指定Shape 。

shapeProperty() - Method in class javafx.animation. FillTransition

目标形状为 FillTransition 。

shapeProperty() - Method in class javafx.animation. StrokeTransition

目标形状为 StrokeTransition 。

shapeProperty() - Method in class javafx.scene.layout. Region

指定时， Shape将导致该区域被渲染为指定的形状而不是圆角矩形。

SHAPES - Static variable in class javax.swing.text.html. HTML.Attribute

属性“形状”

SHARADA - java.lang. Character.UnicodeScript

Unicode脚本“Sharada”。

SHARADA - Static variable in class java.lang. Character.UnicodeBlock

“Sharada”Unicode字符块的常数。

shardingKey(ShardingKey) - Method in interface java.sql. ConnectionBuilder

指定在创建连接时使用的 shardingKey

shardingKey(ShardingKey) - Method in interface javax.sql. PooledConnectionBuilder

指定创建连接时要使用的 shardingKey

shardingKey(ShardingKey) - Method in interface javax.sql. XAConnectionBuilder

指定在创建连接时使用的 shardingKey

ShardingKey - Interface in java.sql

用于指示此对象表示Sharding键的接口。

ShardingKeyBuilder - Interface in java.sql

从DataSource或XADataSource对象创建的构建器，用于创建具有支持的数据类型的子键的ShardingKey 。

sharedInstance - Static variable in class javax.swing. JTree.EmptySelectionModel

单实例 EmptySelectionModel 。

sharedInstance() - Static method in class javax.swing. JTree.EmptySelectionModel

返回单个实例 EmptySelectionModel 。

sharedInstance() - Static method in class javax.swing. ToolTipManager

返回共享的 ToolTipManager实例。

SHARPNESS_HARD - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“Sharpness”标签一起使用的值。

SHARPNESS_NORMAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“Sharpness”标签一起使用的值。

SHARPNESS_SOFT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“Sharpness”标签一起使用的值。

SHAVIAN - java.lang. Character.UnicodeScript

Unicode脚本“Shavian”。

SHAVIAN - Static variable in class java.lang. Character.UnicodeBlock

“Shavian”Unicode字符块的常量。

shear(double, double) - Method in class java.awt.geom. AffineTransform

将此变换与剪切变换相结合。

shear(double, double) - Method in class java.awt. Graphics2D

使用剪切变换连接当前的 Graphics2D Transform 。

shear(double, double) - Static method in class javafx.scene.transform. Transform

返回表示剪切变换的 Shear对象。

shear(double, double, double, double) - Static method in class javafx.scene.transform. Transform

返回表示剪切变换的 Shear对象。

Shear - Class in javafx.scene.transform

此类表示一个 Affine对象，该对象通过指定的乘数剪切坐标。

Shear() - Constructor for class javafx.scene.transform. Shear

创建默认剪切（身份）。

Shear(double, double) - Constructor for class javafx.scene.transform. Shear

创建一个新的剪切实例。

Shear(double, double, double, double) - Constructor for class javafx.scene.transform. Shear

用枢轴创建一个新的剪切实例。

SheetCollate - Class in javax.print.attribute.standard

SheetCollate是一个打印属性类，一个枚举，用于指定当Copies属性指定文档的多个副本时，作业中每个打印文档的每个副本的介质页是否依次排列。

SheetCollate(int) - Constructor for class javax.print.attribute.standard. SheetCollate

使用给定的整数值构造新的表格整理枚举值。

shift(float, float, int) - Method in class javax.sound.sampled. FloatControl

在指定的时间段内将控制值从初始值线性改变为最终值，以微秒为单位。

SHIFT - javafx.scene.input. KeyCode

常数为 Shift键。

SHIFT_ANY - Static variable in class javafx.scene.input. KeyCombination

修饰符指定 shift键可以是向上还是向下。

SHIFT_DOWN - Static variable in class javafx.scene.input. KeyCombination

修饰符指定 shift键必须关闭。

SHIFT_DOWN_MASK - Static variable in class java.awt.event. InputEvent

Shift键扩展修饰符常数。

SHIFT_MASK - Static variable in class java.awt.event. ActionEvent

班次修改。

SHIFT_MASK - Static variable in class java.awt.event. InputEvent

已过时。
建议使用SHIFT_DOWN_MASK和InputEvent.getModifiersEx()

SHIFT_MASK - Static variable in class java.awt. Event

已过时。

该标志表示事件发生时Shift键已关闭。

shiftDown() - Method in class java.awt. Event

已过时。

注意： Event类已过时，仅适用于向后兼容性。

shiftEnd(int) - Method in class javax.swing.text. GapContent

使差距更大，移动任何必要的数据并更新适当的标记

shiftGap(int) - Method in class javax.swing.text. GapContent

将差距的开始移动到新位置，而不改变间隙的大小。

shiftGapEndUp(int) - Method in class javax.swing.text. GapContent

将间隙向上调整。

shiftGapStartDown(int) - Method in class javax.swing.text. GapContent

将间隙端向下调整。

shiftLeft(int) - Method in class java.math. BigInteger

返回值为 (this << n)的BigInteger。

shiftRight(int) - Method in class java.math. BigInteger

返回值为 (this >> n)的BigInteger。

Short - Class in java.lang

Short类包装一个对象中的原始类型为 short的值。

Short(short) - Constructor for class java.lang. Short

已过时。
很少使用这个构造函数。 静态工厂Short.valueOf(short)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。

Short(String) - Constructor for class java.lang. Short

已过时。
很少使用这个构造函数。 使用Short.parseShort(String)将字符串转换为short原语，或使用Short.valueOf(String)将字符串转换为Short对象。

SHORT - java.time.format. FormatStyle

短文本样式，通常为数字。

SHORT - java.time.format. TextStyle

短文，通常是缩写。

SHORT - javax.lang.model.type. TypeKind

原始类型 short 。

SHORT - Static variable in class java.text. DateFormat

恒定的短款式。

SHORT - Static variable in class java.util. Calendar

一个样式说明符 getDisplayName和 getDisplayNames相当于 Calendar.SHORT_FORMAT 。

SHORT - Static variable in class java.util. TimeZone

getDisplayName()的样式说明符，表示短名称，如“PST”。

SHORT - Static variable in class javax.management.openmbean. SimpleType

描述Java类名称为 java.lang.Short值的 SimpleType实例。

SHORT_DESCRIPTION - Static variable in interface javax.swing. Action

用于存储一个短的关键 String描述的动作中，用于工具提示文本。

SHORT_FORMAT - Static variable in class java.util. Calendar

getDisplayName和 getDisplayNames的样式说明 符 ，表示用于格式的短名称。

SHORT_IDS - Static variable in class java.time. ZoneId

区域覆盖的映射，以启用短时区名称。

SHORT_STANDALONE - java.time.format. TextStyle

用于独立使用的简短文本，通常为缩写。

SHORT_STANDALONE - Static variable in class java.util. Calendar

一个 getDisplayName和 getDisplayNames的样式说明 符 ，表示一个简单的名称，例如一个月缩写作为日历头。

ShortBuffer - Class in java.nio

一个短暂的缓冲。

ShortBufferException - Exception in javax.crypto

当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。

ShortBufferException() - Constructor for exception javax.crypto. ShortBufferException

构造一个没有详细消息的ShortBufferException。

ShortBufferException(String) - Constructor for exception javax.crypto. ShortBufferException

构造具有指定详细消息的ShortBufferException。

SHORTCUT - javafx.scene.input. KeyCode

常数为 Shortcut键。

SHORTCUT_ANY - Static variable in class javafx.scene.input. KeyCombination

指定 shortcut键的 shortcut可以是向上还是向下。

SHORTCUT_DOWN - Static variable in class javafx.scene.input. KeyCombination

指定 shortcut键的 shortcut必须关闭。

shortcuts() - Method in class java.awt. MenuBar

获取此菜单栏正在管理的所有菜单快捷方式的枚举。

SHORTHAND_FORMAT_CONTROLS - Static variable in class java.lang. Character.UnicodeBlock

“速写格式控件”Unicode字符块的常量。

ShortHolder - Class in org.omg.CORBA

持有人 Short 。

ShortHolder() - Constructor for class org.omg.CORBA. ShortHolder

构造一个新的 ShortHolder对象，其 value字段初始化为 0 。

ShortHolder(short) - Constructor for class org.omg.CORBA. ShortHolder

构造一个新的 ShortHolder对象，其 value字段初始化为给定的 short 。

ShortLookupTable - Class in java.awt.image

这个类定义了一个查找表对象。

ShortLookupTable(int, short[]) - Constructor for class java.awt.image. ShortLookupTable

构造一个ShortLookupTable对象从一个短数组，表示每个频段的查找表。

ShortLookupTable(int, short[][]) - Constructor for class java.awt.image. ShortLookupTable

从表示每个频段的查找表的短数组数组构造一个ShortLookupTable对象。

ShortMessage - Class in javax.sound.midi

A ShortMessage包含一个MIDI消息，其状态字节后面最多有两个数据字节。

ShortMessage() - Constructor for class javax.sound.midi. ShortMessage

构造新的 ShortMessage 。

ShortMessage(byte[]) - Constructor for class javax.sound.midi. ShortMessage

构造一个新的 ShortMessage 。

ShortMessage(int) - Constructor for class javax.sound.midi. ShortMessage

构造一个新的 ShortMessage ，它代表一个没有数据字节的MIDI消息。

ShortMessage(int, int, int) - Constructor for class javax.sound.midi. ShortMessage

构造一个新的 ShortMessage ，它代表一个最多可以容纳两个数据字节的MIDI消息。

ShortMessage(int, int, int, int) - Constructor for class javax.sound.midi. ShortMessage

构造一个新的 ShortMessage ，它表示一个通道MIDI消息，最多可以包含两个数据字节。

ShortSeqHelper - Class in org.omg.CORBA

助手 ShortSeqHelper 。

ShortSeqHelper() - Constructor for class org.omg.CORBA. ShortSeqHelper

ShortSeqHolder - Class in org.omg.CORBA

持有人 ShortSeq 。

ShortSeqHolder() - Constructor for class org.omg.CORBA. ShortSeqHolder

ShortSeqHolder(short[]) - Constructor for class org.omg.CORBA. ShortSeqHolder

ShortStringConverter - Class in javafx.util.converter

StringConverter实现Short值。

ShortStringConverter() - Constructor for class javafx.util.converter. ShortStringConverter

ShortType - Interface in com.sun.jdi

在目标VM中访问的所有原语 short值的类型。

shortValue() - Method in interface com.sun.jdi. PrimitiveValue

将此值转换为ShortValue，并将结果作为简写返回。

shortValue() - Method in class java.lang. Byte

在扩展原始转换后，返回 Byte的值作为 short 。

shortValue() - Method in class java.lang. Double

在缩小原始转换后，返回 Double的值作为 short 。

shortValue() - Method in class java.lang. Float

返回此值 Float为 short的基本收缩转换后。

shortValue() - Method in class java.lang. Integer

返回此值 Integer为 short的基本收缩转换后。

shortValue() - Method in class java.lang. Long

在缩小原始转换后，返回 Long的值作为 short 。

shortValue() - Method in class java.lang. Number

返回指定数字的值作为 short 。

shortValue() - Method in class java.lang. Short

返回 Short的值作为 short 。

ShortValue - Interface in com.sun.jdi

提供对目标虚拟机中原始的 short值的访问。

shortValueExact() - Method in class java.math. BigDecimal

将此 BigDecimal转换为 short ，检查丢失的信息。

shortValueExact() - Method in class java.math. BigInteger

将此 BigInteger转换为 short ，检查丢失的信息。

shouldAccept(URI, HttpCookie) - Method in interface java.net. CookiePolicy

将被调用来查看是否应该接受该cookie。

shouldAnimate() - Method in class javafx.scene.chart. Axis

这是用来检查任何给定的动画是否应该运行。

shouldAnimate() - Method in class javafx.scene.chart. Chart

这是用来检查任何给定的动画是否应该运行。

shouldFillGap(int, int, int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

返回 true如果差距应该填补。

shouldPadTabRun(int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回是否应填充选项卡运行。

shouldPadTabRun(int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

shouldPaintExpandControl(TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic. BasicTreeUI

如果要为指定的行绘制展开（toggle）控件，则返回 true 。

shouldRotateTabRuns(int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回是否应该旋转选项卡运行。

shouldRotateTabRuns(int, int) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI

如果选项卡运行应该旋转，则返回 true 。

shouldScroll(int) - Method in class javax.swing.plaf.basic. BasicSliderUI.TrackListener

如果滚动应该发生返回

shouldSelectCell(EventObject) - Method in class javax.swing. AbstractCellEditor

返回true。

shouldSelectCell(EventObject) - Method in interface javax.swing. CellEditor

如果选择编辑单元格，则返回true，否则返回false。

shouldSelectCell(EventObject) - Method in class javax.swing. DefaultCellEditor.EditorDelegate

返回true表示可以选择编辑单元格。

shouldSelectCell(EventObject) - Method in class javax.swing. DefaultCellEditor

将消息从 CellEditor转发到 delegate 。

shouldSelectCell(EventObject) - Method in class javax.swing.tree. DefaultTreeCellEditor

消息 realEditor的返回值。

shouldStartEditingTimer(EventObject) - Method in class javax.swing.tree. DefaultTreeCellEditor

如果 event为 MouseEvent且点击次数为1，则返回true。

shouldUpdateStyleOnAncestorChanged() - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

返回当 SynthStyleFactory的祖先发生变化时，UI是否应从 SynthStyles更新 JComponent 。

shouldUpdateStyleOnAncestorChanged() - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回当 SynthStyleFactory的祖先发生变化时，UI是否应从 SynthStyles更新 JComponent 。

shouldUpdateStyleOnEvent(PropertyChangeEvent) - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel

返回在特定事件发生时，UI是否应更新其样式。

shouldUpdateStyleOnEvent(PropertyChangeEvent) - Method in class javax.swing.plaf.synth. SynthLookAndFeel

返回在特定事件发生时，UI是否应更新其样式。

shouldYieldFocus(JComponent) - Method in class javax.swing. InputVerifier

已过时。
改用InputVerifier.shouldYieldFocus(JComponent, JComponent) 。

shouldYieldFocus(JComponent, JComponent) - Method in class javax.swing. InputVerifier

如果将此 InputVerifier分配给 source Swing组件来检查是否允许从 source到 target请求的焦点传输， source Swing target 。

show() - Method in class java.awt. Component.BltBufferStrategy

使下一个可用缓冲区可见。

show() - Method in class java.awt. Component.FlipBufferStrategy

使下一个可用的缓冲区可以被blitting或flipping看到。

show() - Method in class java.awt. Component

已过时。
从JDK 1.1版开始，由setVisible(boolean)替代。

show() - Method in class java.awt. Dialog

已过时。
从JDK版本1.5开始，替换为setVisible(boolean) 。

show() - Method in class java.awt.image. BufferStrategy

通过复制内存（blitting）或更改显示指针（翻转），使下一个可用的缓冲区可见。

show() - Method in class java.awt. Window

已过时。
从JDK版本1.5开始，由Window.setVisible(boolean)替代。

show() - Method in class javafx.scene.control. ChoiceBox

打开选择列表。

show() - Method in class javafx.scene.control. ComboBoxBase

请求ComboBox显示用户界面的弹出窗口。

show() - Method in class javafx.scene.control. Dialog

显示对话框，但不等待用户响应（换句话说，这会打开一个非阻塞对话框）。

show() - Method in class javafx.scene.control. Menu

如果菜单没有被禁用，并且ContextMenu尚未显示，那么这将导致显示ContextMenu 。

show() - Method in class javafx.scene.control. MenuButton

显示ContextMenu ，假设该MenuButton未被禁用。

show() - Method in class javafx.scene.control.skin. ColorPickerSkin

当显示ComboBox弹出窗口时，将调用此方法。

show() - Method in class javafx.scene.control.skin. ComboBoxBaseSkin

当显示ComboBox弹出窗口时，将调用此方法。

show() - Method in class javafx.scene.control.skin. ComboBoxPopupControl

当显示ComboBox弹出窗口时，将调用此方法。

show() - Method in class javafx.scene.control.skin. DatePickerSkin

当显示ComboBox弹出窗口时，将调用此方法。

show() - Method in class javafx.stage. Stage

尝试通过将可见性设置为true来显示此窗口

show() - Method in class javafx.stage. Window

尝试通过将可见性设置为true来显示此窗口

show() - Method in class javax.swing. JInternalFrame

如果内部框架不可见，将内部框架放在前面，使其可见，并尝试选择它。

show() - Method in class javax.swing.plaf.basic. BasicComboPopup

实现ComboPopup.show（）。

show() - Method in interface javax.swing.plaf.basic. ComboPopup

显示弹出窗口

show() - Method in class javax.swing. Popup

使 Popup可见。

show(boolean) - Method in class java.awt. Component

已过时。
从JDK 1.1版开始，由setVisible(boolean)替代。

show(Component, int, int) - Method in class java.awt. PopupMenu

在相对于原始组件的x，y位置显示弹出式菜单。

show(Component, int, int) - Method in class javax.swing. JPopupMenu

在组件调用者的坐标空间中的位置x，y处显示弹出式菜单。

show(Container, String) - Method in class java.awt. CardLayout

使用指定的 name ，使用 addLayoutComponent翻转到添加到此布局的组件。

show(Node, double, double) - Method in class javafx.scene.control. ContextMenu

在指定的屏幕坐标处显示 ContextMenu 。

show(Node, double, double) - Method in class javafx.stage. PopupWindow

显示屏幕上指定位置的弹出窗口。

show(Node, Side, double, double) - Method in class javafx.scene.control. ContextMenu

示出了 ContextMenu相对于给定锚节点，在由指定的侧 hpos个 vpos参数，并且由给定的偏移 dx倍 dy分别用于x轴和y轴，的值。

show(Window) - Method in class javafx.stage. PopupWindow

显示弹出窗口。

show(Window, double, double) - Method in class javafx.stage. PopupWindow

显示屏幕上指定位置的弹出窗口。

SHOW_ALL - Static variable in interface org.w3c.dom.traversal. NodeFilter

全部显示 Nodes 。

SHOW_ATTRIBUTE - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 Attr节点。

SHOW_CDATA_SECTION - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 CDATASection节点。

SHOW_COMMENT - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 Comment节点。

SHOW_DOCUMENT - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 Document节点。

SHOW_DOCUMENT_FRAGMENT - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 DocumentFragment节点。

SHOW_DOCUMENT_TYPE - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 DocumentType节点。

SHOW_ELEMENT - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 Element节点。

SHOW_ENTITY - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 Entity节点。

SHOW_ENTITY_REFERENCE - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 EntityReference节点。

SHOW_HIDDEN_FRAMES - java.lang. StackWalker.Option

显示所有隐藏的帧。

SHOW_ITEM - javafx.scene. AccessibleAction

请求节点显示一个项目，如果需要，滚动。

SHOW_MENU - javafx.scene. AccessibleAction

请求节点显示菜单。

SHOW_NOTATION - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 Notation节点。

SHOW_PROCESSING_INSTRUCTION - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 ProcessingInstruction节点。

SHOW_REFLECT_FRAMES - java.lang. StackWalker.Option

显示所有反射帧。

SHOW_TEXT - Static variable in interface org.w3c.dom.traversal. NodeFilter

显示 Text节点。

SHOW_TEXT_RANGE - javafx.scene. AccessibleAction

请求节点显示文本范围，如果需要，滚动。

SHOWA - Static variable in class java.time.chrono. JapaneseEra

“昭和”时代（1926-12-25 - 1989-01-07）的单身实例，价值1。

showAndWait() - Method in class javafx.scene.control. Dialog

显示对话框并等待用户响应（换句话说，显示阻止对话框，用户输入的返回值）。

showAndWait() - Method in class javafx.stage. Stage

显示此阶段，并等待它在返回给调用者之前被隐藏（关闭）。

showConfirmDialog(Component, Object) - Static method in class javax.swing. JOptionPane

启动对话框，选择是 ， 否和取消 ; 标题为“ 选择选项” 。

showConfirmDialog(Component, Object, String, int) - Static method in class javax.swing. JOptionPane

提出一个对话框，其中选择次数由 optionType参数决定。

showConfirmDialog(Component, Object, String, int, int) - Static method in class javax.swing. JOptionPane

调出其中的选项的数目由所确定的一个对话框 optionType参数，其中，所述 messageType参数确定要显示的图标。

showConfirmDialog(Component, Object, String, int, int, Icon) - Static method in class javax.swing. JOptionPane

启动一个带有指定图标的对话框，其中选择的数量由 optionType参数确定。

showDelayProperty() - Method in class javafx.scene.control. Tooltip

进入悬停节点的鼠标与相关联的工具提示之间的延迟将显示给用户。

showDialog(Component, String) - Method in class javax.swing. JFileChooser

使用自定义批准按钮弹出自定义文件选择器对话框。

showDialog(Component, String, Color) - Static method in class javax.swing. JColorChooser

显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。

showDialog(Component, String, Color, boolean) - Static method in class javax.swing. JColorChooser

显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。

showDialog(Window) - Method in class javafx.stage. DirectoryChooser

显示新的目录选择对话框。

showDocument(String) - Method in class javafx.application. HostServices

在新的浏览器窗口或选项卡中打开指定的URI。

showDocument(URL) - Method in interface java.applet. AppletContext

已过时。

请求浏览器或小程序查看器显示由 url参数指示的 url 。

showDocument(URL) - Method in interface javax.jnlp. BasicService

指导客户端上的浏览器显示给定的URL。

showDocument(URL, String) - Method in interface java.applet. AppletContext

已过时。

请求浏览器或小程序查看器显示由 url参数指示的 url 。

showDurationProperty() - Method in class javafx.scene.control. Tooltip

工具提示应保持显示的持续时间，直到用户不再可见。

showHorizontalLines - Variable in class javax.swing. JTable

如果 showHorizontalLines为真，表格会在单元格之间绘制水平线。

SHOWING - Static variable in class javax.accessibility. AccessibleState

表示此对象，对象的父对象，父对象的父对象等都可见。

SHOWING_CHANGED - Static variable in class java.awt.event. HierarchyEvent

更改标志表示由于显示状态的层次结构的改变而产生了 HIERARCHY_CHANGED事件。

showingProperty() - Method in class javafx.scene.control. ChoiceBox

指示下拉列表是否向用户显示选择列表。

showingProperty() - Method in class javafx.scene.control. ComboBoxBase

表示ComboBox弹出窗口的当前状态，以及当前是否在屏幕上可见（尽管可能隐藏在其他窗口后面）。

showingProperty() - Method in class javafx.scene.control. Dialog

表示对话框当前是否显示。

showingProperty() - Method in class javafx.scene.control. Menu

指示当前是否可以看到ContextMenu 。

showingProperty() - Method in class javafx.scene.control. MenuButton

指示ContextMenu当前是否可见。

showingProperty() - Method in class javafx.stage. Window

这是否显示 Window （即在用户的系统上打开）。

showInputDialog(Component, Object) - Static method in class javax.swing. JOptionPane

显示一个问题消息对话框，要求从父母的用户输入 parentComponent 。

showInputDialog(Component, Object, Object) - Static method in class javax.swing. JOptionPane

显示一个问题消息对话框，要求从用户输入并父母为 parentComponent 。

showInputDialog(Component, Object, String, int) - Static method in class javax.swing. JOptionPane

显示一个对话框，请求从用户父母输入的对象 parentComponent ，对话框具有标题 title和消息类型 messageType 。

showInputDialog(Component, Object, String, int, Icon, Object[], Object) - Static method in class javax.swing. JOptionPane

在阻止对话框中提示用户输入，可以指定初始选择，可能的选择和所有其他选项。

showInputDialog(Object) - Static method in class javax.swing. JOptionPane

显示一个请求用户输入的问题消息对话框。

showInputDialog(Object, Object) - Static method in class javax.swing. JOptionPane

显示询问消息对话框，请求用户输入，输入值初始化为 initialSelectionValue 。

showInternalConfirmDialog(Component, Object) - Static method in class javax.swing. JOptionPane

启动一个内部对话面板，选择是 ， 否和取消 ; 标题为“ 选择选项” 。

showInternalConfirmDialog(Component, Object, String, int) - Static method in class javax.swing. JOptionPane

启动内部对话面板，其中选择次数由 optionType参数决定。

showInternalConfirmDialog(Component, Object, String, int, int) - Static method in class javax.swing. JOptionPane

调出其中的选项数由所确定的内部对话框面板 optionType参数，其中，所述 messageType参数确定要显示的图标。

showInternalConfirmDialog(Component, Object, String, int, int, Icon) - Static method in class javax.swing. JOptionPane

启动具有指定图标的内部对话面板，其中选择次数由 optionType参数确定。

showInternalInputDialog(Component, Object) - Static method in class javax.swing. JOptionPane

显示一个内部问题消息对话框，要求从父母为 parentComponent的用户输入。

showInternalInputDialog(Component, Object, String, int) - Static method in class javax.swing. JOptionPane

显示一个内部对话框，请求从 parentComponent的用户输入的对话框，标题为 title ，消息类型为 messageType 。

showInternalInputDialog(Component, Object, String, int, Icon, Object[], Object) - Static method in class javax.swing. JOptionPane

在阻止内部对话框中提示输入用户，可以指定初始选择，可能的选择和所有其他选项。

showInternalMessageDialog(Component, Object) - Static method in class javax.swing. JOptionPane

启动内部确认对话框面板。

showInternalMessageDialog(Component, Object, String, int) - Static method in class javax.swing. JOptionPane

启动内部对话面板，使用由 messageType参数确定的默认图标显示消息。

showInternalMessageDialog(Component, Object, String, int, Icon) - Static method in class javax.swing. JOptionPane

启动一个显示消息的内部对话框面板，指定所有参数。

showInternalOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - Static method in class javax.swing. JOptionPane

启动具有指定图标的内部对话面板，其中初始选择由 initialValue参数确定，选择数由 optionType参数确定。

showMessageDialog(Component, Object) - Static method in class javax.swing. JOptionPane

提供一个名为“消息”的信息消息对话框。

showMessageDialog(Component, Object, String, int) - Static method in class javax.swing. JOptionPane

使用由 messageType参数确定的默认图标显示消息的对话框。

showMessageDialog(Component, Object, String, int, Icon) - Static method in class javax.swing. JOptionPane

显示一个显示消息的对话框，指定所有参数。

showOpenDialog(Component) - Method in class javax.swing. JFileChooser

弹出一个“打开文件”文件选择器对话框。

showOpenDialog(Window) - Method in class javafx.stage. FileChooser

显示一个新的文件打开对话框。

showOpenMultipleDialog(Window) - Method in class javafx.stage. FileChooser

显示一个新的文件打开对话框，其中可以选择多个文件。

showOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - Static method in class javax.swing. JOptionPane

启动具有指定图标的对话框，其中初始选择由 initialValue参数确定，选择次数由 optionType参数确定。

showPageFormatDialog(PageFormat) - Method in interface javax.jnlp. PrintService

显示允许修改 PageFormat实例的对话框。

showPageSetupDialog(Window) - Method in class javafx.print. PrinterJob

显示页面设置对话框。

showPopup() - Method in class javax.swing. JComboBox

导致组合框显示其弹出窗口。

showPrintDialog(Window) - Method in class javafx.print. PrinterJob

显示打印对话框。

showRootProperty() - Method in class javafx.scene.control. TreeTableView

表示TreeTableView根节点是否可见的属性。

showRootProperty() - Method in class javafx.scene.control. TreeView

表示TreeView根节点是否可见的属性。

SHOWS_ROOT_HANDLES_PROPERTY - Static variable in class javax.swing. JTree

绑定属性名称为 showsRootHandles 。

showSaveDialog(Component) - Method in class javax.swing. JFileChooser

弹出“保存文件”文件选择器对话框。

showSaveDialog(Window) - Method in class javafx.stage. FileChooser

显示一个新的文件保存对话框。

showsRootHandles - Variable in class javax.swing. JTree

如果句柄显示在树的最上层，则为true。

showStatus(String) - Method in class java.applet. Applet

已过时。

请求参数字符串显示在“状态窗口”中。

showStatus(String) - Method in interface java.applet. AppletContext

已过时。

请求参数字符串显示在“状态窗口”中。

showSystemMenu() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

显示系统菜单。

showSystemMenu() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane

覆盖父方法，不做任何操作。

showTickLabelsProperty() - Method in class javafx.scene.control. Slider

表示应该显示刻度线的标签。

showTickMarksProperty() - Method in class javafx.scene.control. Slider

指定Skin实现是否应显示刻度线。

showVerticalLines - Variable in class javax.swing. JTable

如果 showVerticalLines为真，表格将在单元格之间绘制垂直线。

showWeekNumbersProperty() - Method in class javafx.scene.control. DatePicker

DatePicker弹出窗口是否应显示显示周数的列。

shrinkAbsorb - Variable in class java.awt.font. GlyphJustificationInfo

如果是 true ，这个字形在收缩时吸收在这个和较低优先级的所有剩余收缩。

shrinkLeftLimit - Variable in class java.awt.font. GlyphJustificationInfo

这个字形左侧的最大值可以缩小（正数）。

shrinkPriority - Variable in class java.awt.font. GlyphJustificationInfo

这个字形的优先级正在缩小。

shrinkRightLimit - Variable in class java.awt.font. GlyphJustificationInfo

这个字形右侧的最大数量可以缩小（正数）。

shuffle(List<?>) - Static method in class java.util. Collections

使用默认的随机源随机排列指定的列表。

shuffle(List<?>, Random) - Static method in class java.util. Collections

使用指定的随机源随机排列指定的列表。

shuffle(ObservableList<?>) - Static method in class javafx.collections. FXCollections

随机播放可观察列表中的所有元素。

shuffle(ObservableList, Random) - Static method in class javafx.collections. FXCollections

随机播放可观察列表中的所有元素。

shutdown() - Method in class com.sun.nio.sctp. SctpChannel

关闭连接而不关闭通道。

shutdown() - Method in class java.nio.channels. AsynchronousChannelGroup

启动组的有序关闭。

shutdown() - Method in interface java.rmi.activation. ActivationSystem

关闭激活系统。

shutdown() - Method in interface java.util.concurrent. ExecutorService

启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。

shutdown() - Method in class java.util.concurrent. ForkJoinPool

可能启动有序关闭，其中先前提交的任务被执行，但不会接受新的任务。

shutdown() - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。

shutdown() - Method in class java.util.concurrent. ThreadPoolExecutor

启动有序关闭，其中先前提交的任务将被执行，但不会接受任何新任务。

shutdown(boolean) - Method in class org.omg.CORBA. ORB

指示ORB关闭，这导致所有对象适配器关闭，以备破坏。
如果wait_for_completion参数为真，则此操作将阻塞，直到所有ORB处理（包括当前正在执行的请求，对象停用和其他对象适配器操作的处理）都已完成。

shutdown(Association) - Method in class com.sun.nio.sctp. SctpMultiChannel

关闭关联而不关闭通道。

SHUTDOWN - com.sun.nio.sctp. AssociationChangeNotification.AssocChangeEvent

该协会已优雅关闭。

SHUTDOWN - Static variable in class javax.print.attribute.standard. PrinterStateReason

有人已将打印机从服务中删除，并且设备可能已关闭电源或实际移除。

ShutdownChannelGroupException - Exception in java.nio.channels

当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。

ShutdownChannelGroupException() - Constructor for exception java.nio.channels. ShutdownChannelGroupException

构造这个类的一个实例。

shutdownInput() - Method in class java.net. Socket

将此套接字的输入流放置在“流的末尾”。

shutdownInput() - Method in class java.net. SocketImpl

将此套接字的输入流放置在“流的末尾”。

shutdownInput() - Method in class java.nio.channels. AsynchronousSocketChannel

关闭连接进行阅读，不关闭频道。

shutdownInput() - Method in class java.nio.channels. SocketChannel

关闭连接进行阅读，不关闭频道。

ShutdownNotification - Class in com.sun.nio.sctp

当对等体关闭关联时发出的通知。

ShutdownNotification() - Constructor for class com.sun.nio.sctp. ShutdownNotification

初始化此类的新实例。

shutdownNow() - Method in class java.nio.channels. AsynchronousChannelGroup

关闭组并关闭组中的所有打开的通道。

shutdownNow() - Method in interface java.util.concurrent. ExecutorService

尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。

shutdownNow() - Method in class java.util.concurrent. ForkJoinPool

可能尝试取消和/或停止所有任务，并拒绝所有后续提交的任务。

shutdownNow() - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。

shutdownNow() - Method in class java.util.concurrent. ThreadPoolExecutor

尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。

shutdownOutput() - Method in class java.net. Socket

禁用此套接字的输出流。

shutdownOutput() - Method in class java.net. SocketImpl

禁用此套接字的输出流。

shutdownOutput() - Method in class java.nio.channels. AsynchronousSocketChannel

关闭连接以进行写入，而不关闭通道。

shutdownOutput() - Method in class java.nio.channels. SocketChannel

关闭连接以进行写入，而不关闭通道。

SIDDHAM - java.lang. Character.UnicodeScript

Unicode脚本“Siddham”。

SIDDHAM - Static variable in class java.lang. Character.UnicodeBlock

常数为“Siddham”Unicode字符块。

Side - Enum in javafx.geometry

枚举哪个方面应该是一个矩形。

SIDE - Static variable in class javafx.print. PaperSource

指定选择SIDE托盘。

SIDE - Static variable in class javax.print.attribute.standard. MediaTray

侧面进纸盘。

sideProperty() - Method in class javafx.scene.chart. Axis

该轴正在绘制的曲线的一侧

sideProperty() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的位置。

Sides - Class in javax.print.attribute.standard

Class Sides是一个打印属性类，一个枚举，它指定打印流页面如何被施加到所选介质实例的侧面，即一个印象。

Sides(int) - Constructor for class javax.print.attribute.standard. Sides

使用给定的整数值构造新的边界枚举值。

SIENNA - Static variable in class javafx.scene.paint. Color

颜色赭色，RGB值为＃A0522D

sign() - Method in class java.security. Signature

返回所有更新的数据的签名字节。

sign(byte[], int, int) - Method in class java.security. Signature

完成签名操作并将生成的签名字节存储在提供的缓冲器 outbuf ，从 offset开始。

sign(ZipFile, OutputStream) - Method in class jdk.security.jarsigner. JarSigner

将文件标记为OutputStream 。

sign(XMLSignContext) - Method in interface javax.xml.crypto.dsig. XMLSignature

标志这 XMLSignature 。

SIGN - Static variable in class java.security. Signature

可能的值为 Signature.state ，表示此签名对象已初始化以进行签名。

SIGN - Static variable in class java.text. NumberFormat.Field

常量识别符号字段。

SIGN - Static variable in class javax.xml.crypto. KeySelector.Purpose

签名的关键。

signal() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject

将最长等待的线程（如果存在）从等待队列移动到拥有锁的等待队列。

signal() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject

将最长等待的线程（如果存在）从等待队列移动到拥有锁的等待队列。

signal() - Method in interface java.util.concurrent.locks. Condition

唤醒一个等待线程。

signalAll() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer.ConditionObject

将所有线程从这个条件的等待队列移动到拥有锁的等待队列。

signalAll() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer.ConditionObject

将所有线程从这个条件的等待队列移动到拥有锁的等待队列。

signalAll() - Method in interface java.util.concurrent.locks. Condition

唤醒所有等待线程。

signature() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

签名。

signature() - Method in interface com.sun.jdi. LocalVariable

获取局部变量的JNI签名。

signature() - Method in interface com.sun.jdi. Type

返回此类型的JNI样式签名。

signature() - Method in interface com.sun.jdi. TypeComponent

获取此类型组件的JNI样式签名。

signature() - Method in class jdk.jshell. MethodSnippet

方法的完整类型签名，包括返回类型。

signature() - Method in interface jdk.jshell. SourceCodeAnalysis.Documentation

给定元素的签名。

Signature - Class in java.security

Signature类用于向应用程序提供数字签名算法的功能。

Signature(String) - Constructor for class java.security. Signature

为指定的算法创建一个Signature对象。

SIGNATURE - java.security. CryptoPrimitive

不对称原语：签名方案

SIGNATURE_VERSION - Static variable in class java.util.jar. Attributes.Name

Name对象为 Signature-Version签署JAR文件时使用的manifest属性。

signatureAlgorithm(String) - Method in class jdk.security.jarsigner. JarSigner.Builder

设置签名算法。

signatureAlgorithm(String, Provider) - Method in class jdk.security.jarsigner. JarSigner.Builder

从指定的提供者设置签名算法。

SignatureException - Exception in java.security

这是一般的签名异常。

SignatureException() - Constructor for exception java.security. SignatureException

构造一个没有详细消息的SignatureException。

SignatureException(String) - Constructor for exception java.security. SignatureException

构造具有指定详细消息的SignatureException。

SignatureException(String, Throwable) - Constructor for exception java.security. SignatureException

创建一个具有指定的详细信息和原因的 SignatureException 。

SignatureException(Throwable) - Constructor for exception java.security. SignatureException

创建 SignatureException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

SignatureMethod - Interface in javax.xml.crypto.dsig

在 SignatureMethod中定义的XML SignatureMethod元素的 表示 。

SignatureMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec

XML SignatureMethod算法的算法参数说明 。

SignatureProperties - Interface in javax.xml.crypto.dsig

SignatureProperties中定义的XML SignatureProperties元素的 表示 。

SignatureProperty - Interface in javax.xml.crypto.dsig

在 SignatureProperty中定义的XML SignatureProperty元素的 表示 。

SignatureSpi - Class in java.security

该类定义了 Signature类的 （ SPI ），用于提供数字签名算法的功能。

SignatureSpi() - Constructor for class java.security. SignatureSpi

SignedInfo - Interface in javax.xml.crypto.dsig

在 SignedInfo中定义的XML SignedInfo元素的 表示 。

SignedObject - Class in java.security

SignedObject是一个类，用于创建可靠的运行时对象，其完整性不会受到威胁，而不会被检测到。

SignedObject(Serializable, PrivateKey, Signature) - Constructor for class java.security. SignedObject

从任何可序列化对象构造一个SignedObject。

Signer - Class in java.security

已过时。
此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

Signer() - Constructor for class java.security. Signer

已过时。

创建一个签名者

Signer(String) - Constructor for class java.security. Signer

已过时。

创建具有指定身份名称的签名者。

Signer(String, IdentityScope) - Constructor for class java.security. Signer

已过时。

创建具有指定身份名称和范围的签名者。

signerName(String) - Method in class jdk.security.jarsigner. JarSigner.Builder

设置签名者名称。

SignStyle - Enum in java.time.format

列举处理正/负号的方法。

signum() - Method in class java.math. BigDecimal

返回这个 BigDecimal的signum函数。

signum() - Method in class java.math. BigInteger

返回此BigInteger的signum函数。

signum(double) - Static method in class java.lang. Math

返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0，如果参数小于零，则为-1.0。

signum(double) - Static method in class java.lang. StrictMath

返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0，如果参数小于零，则为-1.0。

signum(float) - Static method in class java.lang. Math

返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0f，如果参数小于零，则为-1.0f。

signum(float) - Static method in class java.lang. StrictMath

返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0f，如果参数小于零，则为-1.0f。

signum(int) - Static method in class java.lang. Integer

返回指定的 int值的signum函数。

signum(long) - Static method in class java.lang. Long

返回指定的 long值的signum函数。

SIGNWRITING - java.lang. Character.UnicodeScript

Unicode脚本“SignWriting”。

SILENT - Static variable in class java.rmi.server. LogStream

已过时。

日志级别常量（无日志记录）。

SILVER - Static variable in class javafx.scene.paint. Color

颜色银，RGB值为＃C0C0C0

similarTo(Transform, Bounds, double) - Method in class javafx.scene.transform. Transform

检查这个变换是否类似于指定的变换。

SIMPLE_SCROLL_MODE - Static variable in class javax.swing. JViewport

此模式使用非常简单的方式，每次滚动时重新绘制滚动窗格的全部内容。

SimpleAnnotationValueVisitor6< R, P> - Class in javax.lang.model.util

注释值的简单访问者，默认行为适用于 RELEASE_6源版本。

SimpleAnnotationValueVisitor6() - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

SimpleAnnotationValueVisitor6(R) - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

SimpleAnnotationValueVisitor7< R, P> - Class in javax.lang.model.util

注释值的简单访问者，默认行为适用于 RELEASE_7源版本。

SimpleAnnotationValueVisitor7() - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor7

具体子类的构造方法 使用null作为默认值。

SimpleAnnotationValueVisitor7(R) - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor7

具体子类的构造方法 使用参数作为默认值。

SimpleAnnotationValueVisitor8< R, P> - Class in javax.lang.model.util

注释值的简单访问者，默认行为适用于 RELEASE_8源版本。

SimpleAnnotationValueVisitor8() - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor8

具体子类的构造方法 使用null作为默认值。

SimpleAnnotationValueVisitor8(R) - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor8

具体子类的构造方法 使用参数作为默认值。

SimpleAnnotationValueVisitor9< R, P> - Class in javax.lang.model.util

注释值的简单访问者，默认行为适用于 RELEASE_9源版本。

SimpleAnnotationValueVisitor9() - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor9

具体子类的构造方法 使用null作为默认值。

SimpleAnnotationValueVisitor9(R) - Constructor for class javax.lang.model.util. SimpleAnnotationValueVisitor9

具体子类的构造方法 使用参数作为默认值。

SimpleAttributeSet - Class in javax.swing.text

使用哈希表直接实现MutableAttributeSet。

SimpleAttributeSet() - Constructor for class javax.swing.text. SimpleAttributeSet

创建一个新的属性集。

SimpleAttributeSet(AttributeSet) - Constructor for class javax.swing.text. SimpleAttributeSet

根据提供的一组属性创建一个新的属性集。

SimpleBeanInfo - Class in java.beans

这是一个支持类，使人们更容易提供BeanInfo类。

SimpleBeanInfo() - Constructor for class java.beans. SimpleBeanInfo

SimpleBindings - Class in javax.script

一个简单的绑定实现，由一个 HashMap或其他一些指定的 Map 。

SimpleBindings() - Constructor for class javax.script. SimpleBindings

默认构造函数使用 HashMap 。

SimpleBindings(Map<String, Object>) - Constructor for class javax.script. SimpleBindings

构造函数使用现有的 Map存储值。

SimpleBooleanProperty - Class in javafx.beans.property

该类提供了一个包含 boolean值的Property的完整实现。

SimpleBooleanProperty() - Constructor for class javafx.beans.property. SimpleBooleanProperty

构造函数为 BooleanProperty

SimpleBooleanProperty(boolean) - Constructor for class javafx.beans.property. SimpleBooleanProperty

构造函数为 BooleanProperty

SimpleBooleanProperty(Object, String) - Constructor for class javafx.beans.property. SimpleBooleanProperty

构造函数为 BooleanProperty

SimpleBooleanProperty(Object, String, boolean) - Constructor for class javafx.beans.property. SimpleBooleanProperty

构造函数为 BooleanProperty

SimpleDateFormat - Class in java.text

SimpleDateFormat是一个具体的类，用于以区域设置敏感的方式格式化和解析日期。

SimpleDateFormat() - Constructor for class java.text. SimpleDateFormat

构造一个 SimpleDateFormat使用默认的模式和日期格式符号进行默认的 FORMAT语言环境。

SimpleDateFormat(String) - Constructor for class java.text. SimpleDateFormat

使用给定模式构建一个 SimpleDateFormat ，默认日期格式符号为默认的 FORMAT区域设置。

SimpleDateFormat(String, DateFormatSymbols) - Constructor for class java.text. SimpleDateFormat

使用给定的模式和日期格式符号构造一个 SimpleDateFormat 。

SimpleDateFormat(String, Locale) - Constructor for class java.text. SimpleDateFormat

使用给定的模式构建一个 SimpleDateFormat ，并为给定的区域设置默认的日期格式符号。

SimpleDoc - Class in javax.print

该类是可以在许多常见打印请求中使用的接口 Doc的实现。

SimpleDoc(Object, DocFlavor, DocAttributeSet) - Constructor for class javax.print. SimpleDoc

构造具有指定打印数据的 SimpleDoc ，doc风格和doc属性集。

SimpleDocTreeVisitor< R, P> - Class in com.sun.source.util

树节点的简单访问者。

SimpleDocTreeVisitor() - Constructor for class com.sun.source.util. SimpleDocTreeVisitor

创建访问者，DEFAULT_VALUE为 null 。

SimpleDocTreeVisitor(R) - Constructor for class com.sun.source.util. SimpleDocTreeVisitor

创建一个具有指定DEFAULT_VALUE的访问者。

SimpleDoubleProperty - Class in javafx.beans.property

该类提供了一个包含 double值的Property的完整实现。

SimpleDoubleProperty() - Constructor for class javafx.beans.property. SimpleDoubleProperty

构造函数为 DoubleProperty

SimpleDoubleProperty(double) - Constructor for class javafx.beans.property. SimpleDoubleProperty

构造函数为 DoubleProperty

SimpleDoubleProperty(Object, String) - Constructor for class javafx.beans.property. SimpleDoubleProperty

构造函数为 DoubleProperty

SimpleDoubleProperty(Object, String, double) - Constructor for class javafx.beans.property. SimpleDoubleProperty

构造函数为 DoubleProperty

SimpleElementVisitor6< R, P> - Class in javax.lang.model.util

一个简单的访问程序元素的默认行为适用于 RELEASE_6源版本。

SimpleElementVisitor6() - Constructor for class javax.lang.model.util. SimpleElementVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

SimpleElementVisitor6(R) - Constructor for class javax.lang.model.util. SimpleElementVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

SimpleElementVisitor7< R, P> - Class in javax.lang.model.util

程序元素的简单访问者，默认行为适用于 RELEASE_7源版本。

SimpleElementVisitor7() - Constructor for class javax.lang.model.util. SimpleElementVisitor7

具体子类的构造方法 使用null作为默认值。

SimpleElementVisitor7(R) - Constructor for class javax.lang.model.util. SimpleElementVisitor7

具体子类的构造方法 使用参数作为默认值。

SimpleElementVisitor8< R, P> - Class in javax.lang.model.util

程序元素的简单访问者，默认行为适用于 RELEASE_8源版本。

SimpleElementVisitor8() - Constructor for class javax.lang.model.util. SimpleElementVisitor8

具体子类的构造方法 使用默认值null 。

SimpleElementVisitor8(R) - Constructor for class javax.lang.model.util. SimpleElementVisitor8

具体子类的构造方法 使用参数作为默认值。

SimpleElementVisitor9< R, P> - Class in javax.lang.model.util

一个简单的访问程序元素的默认行为适用于 RELEASE_9源版本。

SimpleElementVisitor9() - Constructor for class javax.lang.model.util. SimpleElementVisitor9

具体子类的构造方法 使用null作为默认值。

SimpleElementVisitor9(R) - Constructor for class javax.lang.model.util. SimpleElementVisitor9

具体子类的构造方法 使用参数作为默认值。

SimpleEntry(Map.Entry<? extends K, ? extends V>) - Constructor for class java.util. AbstractMap.SimpleEntry

创建表示与指定条目相同的映射的条目。

SimpleEntry(K, V) - Constructor for class java.util. AbstractMap.SimpleEntry

创建表示从指定键到指定值的映射的条目。

SimpleFileVisitor< T> - Class in java.nio.file

具有默认行为的简单文件访问者访问所有文件并重新抛出I / O错误。

SimpleFileVisitor() - Constructor for class java.nio.file. SimpleFileVisitor

初始化此类的新实例。

SimpleFloatProperty - Class in javafx.beans.property

该类提供了一个包含 float值的Property的完整实现。

SimpleFloatProperty() - Constructor for class javafx.beans.property. SimpleFloatProperty

构造函数为 FloatProperty

SimpleFloatProperty(float) - Constructor for class javafx.beans.property. SimpleFloatProperty

构造函数为 FloatProperty

SimpleFloatProperty(Object, String) - Constructor for class javafx.beans.property. SimpleFloatProperty

构造函数为 FloatProperty

SimpleFloatProperty(Object, String, float) - Constructor for class javafx.beans.property. SimpleFloatProperty

构造函数为 FloatProperty

SimpleFormatter - Class in java.util.logging

以人类可读格式打印 LogRecord的简要摘要。

SimpleFormatter() - Constructor for class java.util.logging. SimpleFormatter

SimpleImmutableEntry(Map.Entry<? extends K, ? extends V>) - Constructor for class java.util. AbstractMap.SimpleImmutableEntry

创建表示与指定条目相同的映射的条目。

SimpleImmutableEntry(K, V) - Constructor for class java.util. AbstractMap.SimpleImmutableEntry

创建表示从指定键到指定值的映射的条目。

SimpleIntegerProperty - Class in javafx.beans.property

该类提供了一个包含 int值的Property的完整实现。

SimpleIntegerProperty() - Constructor for class javafx.beans.property. SimpleIntegerProperty

构造函数为 IntegerProperty

SimpleIntegerProperty(int) - Constructor for class javafx.beans.property. SimpleIntegerProperty

构造函数为 IntegerProperty

SimpleIntegerProperty(Object, String) - Constructor for class javafx.beans.property. SimpleIntegerProperty

构造函数为 IntegerProperty

SimpleIntegerProperty(Object, String, int) - Constructor for class javafx.beans.property. SimpleIntegerProperty

构造函数为 IntegerProperty

SimpleJavaFileObject - Class in javax.tools

为JavaFileObject中的大多数方法提供简单的实现。

SimpleJavaFileObject(URI, JavaFileObject.Kind) - Constructor for class javax.tools. SimpleJavaFileObject

构造给定类型的SimpleJavaFileObject和给定的URI。

SimpleLinkRequest - Class in jdk.dynalink.linker.support

默认简单实现LinkRequest 。

SimpleLinkRequest(CallSiteDescriptor, boolean, Object...) - Constructor for class jdk.dynalink.linker.support. SimpleLinkRequest

创建一个新的链接请求。

SimpleListProperty< E> - Class in javafx.beans.property

这个类提供了一个包含ObservableList的ObservableList的完整实现。

SimpleListProperty() - Constructor for class javafx.beans.property. SimpleListProperty

构造函数为 SimpleListProperty

SimpleListProperty(Object, String) - Constructor for class javafx.beans.property. SimpleListProperty

构造函数为 SimpleListProperty

SimpleListProperty(Object, String, ObservableList<E>) - Constructor for class javafx.beans.property. SimpleListProperty

构造函数 SimpleListProperty

SimpleListProperty(ObservableList<E>) - Constructor for class javafx.beans.property. SimpleListProperty

构造函数为 SimpleListProperty

SimpleLongProperty - Class in javafx.beans.property

这个类提供了一个包含 long值的Property的完整实现。

SimpleLongProperty() - Constructor for class javafx.beans.property. SimpleLongProperty

构造函数为 LongProperty

SimpleLongProperty(long) - Constructor for class javafx.beans.property. SimpleLongProperty

构造函数为 LongProperty

SimpleLongProperty(Object, String) - Constructor for class javafx.beans.property. SimpleLongProperty

构造函数为 LongProperty

SimpleLongProperty(Object, String, long) - Constructor for class javafx.beans.property. SimpleLongProperty

构造函数为 LongProperty

SimpleMapProperty< K, V> - Class in javafx.beans.property

这个类提供了一个Property包装一个ObservableMap的全面实现。

SimpleMapProperty() - Constructor for class javafx.beans.property. SimpleMapProperty

构造函数为 SimpleMapProperty

SimpleMapProperty(Object, String) - Constructor for class javafx.beans.property. SimpleMapProperty

构造函数为 SimpleMapProperty

SimpleMapProperty(Object, String, ObservableMap<K, V>) - Constructor for class javafx.beans.property. SimpleMapProperty

构造函数为 SimpleMapProperty

SimpleMapProperty(ObservableMap<K, V>) - Constructor for class javafx.beans.property. SimpleMapProperty

构造函数为 SimpleMapProperty

SimpleObjectProperty< T> - Class in javafx.beans.property

这个类提供了一个完全实现一个Property包装任意的Object 。

SimpleObjectProperty() - Constructor for class javafx.beans.property. SimpleObjectProperty

构造函数 ObjectProperty

SimpleObjectProperty(Object, String) - Constructor for class javafx.beans.property. SimpleObjectProperty

构造函数为 ObjectProperty

SimpleObjectProperty(Object, String, T) - Constructor for class javafx.beans.property. SimpleObjectProperty

构造函数为 ObjectProperty

SimpleObjectProperty(T) - Constructor for class javafx.beans.property. SimpleObjectProperty

构造函数为 ObjectProperty

SimpleRelinkableCallSite - Class in jdk.dynalink.support

一个可重新链接的调用站点，实现单态内联缓存策略，只能在任何给定的时间链接到单个GuardedInvocation 。

SimpleRelinkableCallSite(CallSiteDescriptor) - Constructor for class jdk.dynalink.support. SimpleRelinkableCallSite

创建一个具有单一内联缓存策略的新呼叫站点。

SimpleScriptContext - Class in javax.script

简单实现ScriptContext。

SimpleScriptContext() - Constructor for class javax.script. SimpleScriptContext

创建一个 SimpleScriptContext 。

SimpleSelector - Class in javafx.css

一个根据CSS标准行事的简单选择器。

SimpleSetProperty< E> - Class in javafx.beans.property

这个类提供了一个Property包装一个ObservableSet的完整实现。

SimpleSetProperty() - Constructor for class javafx.beans.property. SimpleSetProperty

构造函数为 SimpleSetProperty

SimpleSetProperty(Object, String) - Constructor for class javafx.beans.property. SimpleSetProperty

构造函数为 SimpleSetProperty

SimpleSetProperty(Object, String, ObservableSet<E>) - Constructor for class javafx.beans.property. SimpleSetProperty

构造函数为 SimpleSetProperty

SimpleSetProperty(ObservableSet<E>) - Constructor for class javafx.beans.property. SimpleSetProperty

构造函数为 SimpleSetProperty

SimpleStringProperty - Class in javafx.beans.property

该类提供了一个包含 String值的Property的完整实现。

SimpleStringProperty() - Constructor for class javafx.beans.property. SimpleStringProperty

构造函数为 StringProperty

SimpleStringProperty(Object, String) - Constructor for class javafx.beans.property. SimpleStringProperty

构造函数为 StringProperty

SimpleStringProperty(Object, String, String) - Constructor for class javafx.beans.property. SimpleStringProperty

构造函数为 StringProperty

SimpleStringProperty(String) - Constructor for class javafx.beans.property. SimpleStringProperty

构造函数为 StringProperty

SimpleStyleableBooleanProperty - Class in javafx.css

这个类扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。

SimpleStyleableBooleanProperty(CssMetaData<? extends Styleable, Boolean>) - Constructor for class javafx.css. SimpleStyleableBooleanProperty

的构造函数为 SimpleStyleableBooleanProperty 。

SimpleStyleableBooleanProperty(CssMetaData<? extends Styleable, Boolean>, boolean) - Constructor for class javafx.css. SimpleStyleableBooleanProperty

SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。

SimpleStyleableBooleanProperty(CssMetaData<? extends Styleable, Boolean>, Object, String) - Constructor for class javafx.css. SimpleStyleableBooleanProperty

SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。

SimpleStyleableBooleanProperty(CssMetaData<? extends Styleable, Boolean>, Object, String, boolean) - Constructor for class javafx.css. SimpleStyleableBooleanProperty

的构造函数为 SimpleStyleableBooleanProperty 。

SimpleStyleableDoubleProperty - Class in javafx.css

这个类扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。

SimpleStyleableDoubleProperty(CssMetaData<? extends Styleable, Number>) - Constructor for class javafx.css. SimpleStyleableDoubleProperty

SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

SimpleStyleableDoubleProperty(CssMetaData<? extends Styleable, Number>, Double) - Constructor for class javafx.css. SimpleStyleableDoubleProperty

SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

SimpleStyleableDoubleProperty(CssMetaData<? extends Styleable, Number>, Object, String) - Constructor for class javafx.css. SimpleStyleableDoubleProperty

SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

SimpleStyleableDoubleProperty(CssMetaData<? extends Styleable, Number>, Object, String, Double) - Constructor for class javafx.css. SimpleStyleableDoubleProperty

SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

SimpleStyleableFloatProperty - Class in javafx.css

这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。

SimpleStyleableFloatProperty(CssMetaData<? extends Styleable, Number>) - Constructor for class javafx.css. SimpleStyleableFloatProperty

SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。

SimpleStyleableFloatProperty(CssMetaData<? extends Styleable, Number>, Float) - Constructor for class javafx.css. SimpleStyleableFloatProperty

的构造函数为 SimpleStyleableFloatProperty 。

SimpleStyleableFloatProperty(CssMetaData<? extends Styleable, Number>, Object, String) - Constructor for class javafx.css. SimpleStyleableFloatProperty

的构造函数 SimpleStyleableFloatProperty 。

SimpleStyleableFloatProperty(CssMetaData<? extends Styleable, Number>, Object, String, Float) - Constructor for class javafx.css. SimpleStyleableFloatProperty

的构造函数为 SimpleStyleableFloatProperty 。

SimpleStyleableIntegerProperty - Class in javafx.css

该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。

SimpleStyleableIntegerProperty(CssMetaData<? extends Styleable, Number>) - Constructor for class javafx.css. SimpleStyleableIntegerProperty

的构造函数为 SimpleStyleableIntegerProperty 。

SimpleStyleableIntegerProperty(CssMetaData<? extends Styleable, Number>, Integer) - Constructor for class javafx.css. SimpleStyleableIntegerProperty

的构造函数为 SimpleStyleableIntegerProperty 。

SimpleStyleableIntegerProperty(CssMetaData<? extends Styleable, Number>, Object, String) - Constructor for class javafx.css. SimpleStyleableIntegerProperty

SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。

SimpleStyleableIntegerProperty(CssMetaData<? extends Styleable, Number>, Object, String, Integer) - Constructor for class javafx.css. SimpleStyleableIntegerProperty

的构造函数为 SimpleStyleableIntegerProperty 。

SimpleStyleableLongProperty - Class in javafx.css

这个类扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。

SimpleStyleableLongProperty(CssMetaData<? extends Styleable, Number>) - Constructor for class javafx.css. SimpleStyleableLongProperty

的构造函数为 SimpleStyleableLongProperty 。

SimpleStyleableLongProperty(CssMetaData<? extends Styleable, Number>, Long) - Constructor for class javafx.css. SimpleStyleableLongProperty

的构造函数为 SimpleStyleableLongProperty 。

SimpleStyleableLongProperty(CssMetaData<? extends Styleable, Number>, Object, String) - Constructor for class javafx.css. SimpleStyleableLongProperty

的构造函数为 SimpleStyleableLongProperty 。

SimpleStyleableLongProperty(CssMetaData<? extends Styleable, Number>, Object, String, Long) - Constructor for class javafx.css. SimpleStyleableLongProperty

的构造函数 SimpleStyleableLongProperty 。

SimpleStyleableObjectProperty< T> - Class in javafx.css

这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。

SimpleStyleableObjectProperty(CssMetaData<? extends Styleable, T>) - Constructor for class javafx.css. SimpleStyleableObjectProperty

的构造函数 SimpleStyleableObjectProperty 。

SimpleStyleableObjectProperty(CssMetaData<? extends Styleable, T>, Object, String) - Constructor for class javafx.css. SimpleStyleableObjectProperty

的构造函数为 SimpleStyleableObjectProperty 。

SimpleStyleableObjectProperty(CssMetaData<? extends Styleable, T>, Object, String, T) - Constructor for class javafx.css. SimpleStyleableObjectProperty

SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。

SimpleStyleableObjectProperty(CssMetaData<? extends Styleable, T>, T) - Constructor for class javafx.css. SimpleStyleableObjectProperty

SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。

SimpleStyleableStringProperty - Class in javafx.css

这个类扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。

SimpleStyleableStringProperty(CssMetaData<? extends Styleable, String>) - Constructor for class javafx.css. SimpleStyleableStringProperty

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty(CssMetaData<? extends Styleable, String>, Object, String) - Constructor for class javafx.css. SimpleStyleableStringProperty

的构造函数为 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty(CssMetaData<? extends Styleable, String>, Object, String, String) - Constructor for class javafx.css. SimpleStyleableStringProperty

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty(CssMetaData<? extends Styleable, String>, String) - Constructor for class javafx.css. SimpleStyleableStringProperty

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleTimeZone - Class in java.util

SimpleTimeZone是一个具体子类 TimeZone ，表示一个使用格里高利历的时区。

SimpleTimeZone(int, String) - Constructor for class java.util. SimpleTimeZone

构造一个SimpleTimeZone，其给定的基准时区偏离GMT和时区ID，而没有夏令时。

SimpleTimeZone(int, String, int, int, int, int, int, int, int, int) - Constructor for class java.util. SimpleTimeZone

构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。

SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int) - Constructor for class java.util. SimpleTimeZone

构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。

SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int, int, int) - Constructor for class java.util. SimpleTimeZone

构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。

SimpleTreeVisitor< R, P> - Class in com.sun.source.util

树节点的简单访问者。

SimpleTreeVisitor() - Constructor for class com.sun.source.util. SimpleTreeVisitor

创建访问者，DEFAULT_VALUE为 null 。

SimpleTreeVisitor(R) - Constructor for class com.sun.source.util. SimpleTreeVisitor

创建一个具有指定DEFAULT_VALUE的访问者。

SimpleTreeVisitorES5_1< R, P> - Class in jdk.nashorn.api.tree

用于ECMAScript版本5.1的TreeVisitor的简单实现。

SimpleTreeVisitorES5_1() - Constructor for class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1

SimpleTreeVisitorES6< R, P> - Class in jdk.nashorn.api.tree

对于ECMAScript版本6的TreeVisitor的简单实现。

SimpleTreeVisitorES6() - Constructor for class jdk.nashorn.api.tree. SimpleTreeVisitorES6

SimpleType< T> - Class in javax.management.openmbean

SimpleType类是开放类型的类，其实例描述了不是数组的所有打开的数据值，也不包含CompositeData值，也不包含TabularData值。

simpleTypeName() - Method in interface com.sun.javadoc. Type

已过时。

返回此类型的简单名称，不包括任何维度信息。

SimpleTypeVisitor6< R, P> - Class in javax.lang.model.util

类型的简单访问者，默认行为适用于 RELEASE_6源版本。

SimpleTypeVisitor6() - Constructor for class javax.lang.model.util. SimpleTypeVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

SimpleTypeVisitor6(R) - Constructor for class javax.lang.model.util. SimpleTypeVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

SimpleTypeVisitor7< R, P> - Class in javax.lang.model.util

类型的简单访问者，默认行为适合 RELEASE_7源版本。

SimpleTypeVisitor7() - Constructor for class javax.lang.model.util. SimpleTypeVisitor7

具体子类的构造方法 使用null作为默认值。

SimpleTypeVisitor7(R) - Constructor for class javax.lang.model.util. SimpleTypeVisitor7

具体子类的构造方法 使用参数作为默认值。

SimpleTypeVisitor8< R, P> - Class in javax.lang.model.util

类型的简单访问者，默认行为适用于 RELEASE_8源版本。

SimpleTypeVisitor8() - Constructor for class javax.lang.model.util. SimpleTypeVisitor8

具体子类的构造方法 使用null作为默认值。

SimpleTypeVisitor8(R) - Constructor for class javax.lang.model.util. SimpleTypeVisitor8

具体子类的构造方法 使用参数作为默认值。

SimpleTypeVisitor9< R, P> - Class in javax.lang.model.util

类型的简单访问者，默认行为适用于 RELEASE_9源版本。

SimpleTypeVisitor9() - Constructor for class javax.lang.model.util. SimpleTypeVisitor9

具体子类的构造方法 使用默认值null 。

SimpleTypeVisitor9(R) - Constructor for class javax.lang.model.util. SimpleTypeVisitor9

具体子类的构造方法 使用参数作为默认值。

SIMPLIFIED_CHINESE - Static variable in class java.util. Locale

有用的语言常数

SIMPLIFIED_HANZI - Static variable in class java.awt.im. InputSubset

所有用于汉语汉字的常数为简体中文，包括CJK统一表意文字的一小部分以及可能被定义为替代字符的简体中文汉字。

sin(double) - Static method in class java.lang. Math

返回角度的三角正弦。

sin(double) - Static method in class java.lang. StrictMath

返回角度的三角正弦。

SINCE - com.sun.source.doctree. DocTree.Kind

用于实例SinceTree表示@Since标签。

SinceTree - Interface in com.sun.source.doctree

@since块标记的树节点。

SINGLE - com.sun.source.doctree. AttributeTree.ValueKind

属性值用单引号括起来。

SINGLE - javafx.scene.control. SelectionMode

一次只能选择一个项目。

SINGLE_DOCUMENT - Static variable in class javax.print.attribute.standard. MultipleDocumentHandling

单一文件 - 见上文 further information 。

SINGLE_DOCUMENT_NEW_SHEET - Static variable in class javax.print.attribute.standard. MultipleDocumentHandling

单文件新单 - 见上文 further information 。

SINGLE_INTERVAL_SELECTION - Static variable in interface javax.swing. ListSelectionModel

selectionMode属性的值：一次选择一个连续的索引范围。

SINGLE_LINE - Static variable in class javax.accessibility. AccessibleState

表示此（文本）对象只能包含一行文本。

SINGLE_SELECTION - Static variable in interface javax.swing. ListSelectionModel

selectionMode属性的值：一次选择一个列表索引。

SINGLE_STATIC_IMPORT_SUBKIND - jdk.jshell. Snippet.SubKind

单静态导入声明。

SINGLE_THREAD_MODEL - Static variable in class org.omg.PortableServer. ThreadPolicyValue

SINGLE_TREE_SELECTION - Static variable in interface javax.swing.tree. TreeSelectionModel

选择一次只能包含一个路径。

SINGLE_TYPE_IMPORT_SUBKIND - jdk.jshell. Snippet.SubKind

单一进口报关单。

SingleClickListener(JList<?>) - Constructor for class javax.swing.plaf.metal. MetalFileChooserUI.SingleClickListener

已过时。

构造一个 SingleClickListener的实例。

SINGLEFRAME - Static variable in interface java.awt.image. ImageConsumer

该图像包含一个静态图像。

SINGLEFRAMEDONE - Static variable in interface java.awt.image. ImageConsumer

图像的一帧是完整的，但是有更多的帧被传送。

SingleInstanceListener - Interface in javax.jnlp

SingleInstanceListener是一个接口，如果他们希望支持单实例行为，应该由JNLP应用程序实现。

SingleInstanceService - Interface in javax.jnlp

SingleInstanceService允许在Java Web Start下启动的应用程序将其自身注册为单例，并在用户尝试启动新的实例时传递新的参数集。

SINGLEPASS - Static variable in interface java.awt.image. ImageConsumer

像素将以单次传递方式传送。

SinglePixelPackedSampleModel - Class in java.awt.image

该类表示打包的像素数据，使得构成单个像素的N个采样被存储在单个数据阵列元素中，并且每个数据数据阵列元素仅保存一个像素的采样。

SinglePixelPackedSampleModel(int, int, int, int[]) - Constructor for class java.awt.image. SinglePixelPackedSampleModel

构造一个具有bitMasks.length带的SinglePixelPackedSampleModel。

SinglePixelPackedSampleModel(int, int, int, int, int[]) - Constructor for class java.awt.image. SinglePixelPackedSampleModel

构造一个SinglePixelPackedSampleModel，其bitMasks.length带和扫描线步长等于scanlineStride数据数组元素。

SingleSelectionModel< T> - Class in javafx.scene.control

一个SelectionModel，它强制要求在任何给定的时间只选择一个索引。

SingleSelectionModel - Interface in javax.swing

支持最多一个索引选择的模型。

SingleSelectionModel() - Constructor for class javafx.scene.control. SingleSelectionModel

创建一个默认的SingleSelectionModel实例。

singleton(T) - Static method in class java.util. Collections

返回一个只包含指定对象的不可变组。

singletonKeySelector(Key) - Static method in class javax.xml.crypto. KeySelector

返回一个 KeySelector ，它总是选择指定的键，而不管传递给它的是 KeyInfo 。

singletonList(T) - Static method in class java.util. Collections

返回一个只包含指定对象的不可变列表。

singletonMap(K, V) - Static method in class java.util. Collections

返回一个不可变的地图，只将指定的键映射到指定的值。

singletonObservableList(E) - Static method in class javafx.collections. FXCollections

使用单个元素创建一个不可修改的可观察列表。

sinh(double) - Static method in class java.lang. Math

返回一个 double的双曲正弦值。

sinh(double) - Static method in class java.lang. StrictMath

返回 double值的双曲正弦值。

SINHALA - java.awt.font. NumericShaper.Range

僧伽罗语范围与僧伽罗数字。

SINHALA - java.lang. Character.UnicodeScript

Unicode脚本“僧伽罗”。

SINHALA - Static variable in class java.lang. Character.UnicodeBlock

“Sinhala”Unicode字符块的常量。

SINHALA_ARCHAIC_NUMBERS - Static variable in class java.lang. Character.UnicodeBlock

常数为“僧伽罗古代数字”Unicode字符块。

sink() - Method in class java.nio.channels. Pipe

返回此管道的接收通道。

SinkChannel(SelectorProvider) - Constructor for class java.nio.channels. Pipe.SinkChannel

初始化此类的新实例。

size - Variable in class java.awt. Font

该点的大小为 Font ，四舍五入为整数。

size - Variable in class java.awt.image. DataBuffer

所有银行的可用规模。

size() - Method in interface com.sun.jdi.request. StepRequest

size() - Method in class com.sun.net.httpserver. Headers

size() - Method in class java.awt. Component

已过时。
从JDK 1.1版开始，由getSize()替代。

size() - Method in class java.awt. RenderingHints

返回 RenderingHints键值映射的 RenderingHints 。

size() - Method in class java.beans.beancontext. BeanContextMembershipEvent

获取受通知影响的孩子数量。

size() - Method in class java.beans.beancontext. BeanContextSupport

获取当前嵌套在此BeanContext中的子节点数。

size() - Method in class java.io. ByteArrayOutputStream

返回缓冲区的当前大小。

size() - Method in class java.io. CharArrayWriter

返回缓冲区的当前大小。

size() - Method in class java.io. DataOutputStream

返回计数器的当前值 written ，到目前为止写入此数据输出流的字节数。

size() - Method in class java.nio.channels. AsynchronousFileChannel

返回此通道文件的当前大小。

size() - Method in class java.nio.channels. FileChannel

返回此通道文件的当前大小。

size() - Method in class java.nio.channels. FileLock

以字节为单位返回锁定区域的大小。

size() - Method in interface java.nio.channels. SeekableByteChannel

返回此通道连接到的实体的当前大小。

size() - Method in interface java.nio.file.attribute. BasicFileAttributes

返回文件的大小（以字节为单位）。

size() - Method in class java.security. IdentityScope

已过时。

返回此身份范围内的身份数。

size() - Method in class java.security. KeyStore

检索此密钥库中的条目数。

size() - Method in class java.util. AbstractCollection

size() - Method in class java.util. AbstractMap

返回此地图中键值映射的数量。

size() - Method in class java.util. ArrayDeque

返回此deque中的元素数。

size() - Method in class java.util. ArrayList

返回此列表中的元素数。

size() - Method in class java.util. BitSet

返回此 BitSet实际使用的空间位数，以表示位值。

size() - Method in interface java.util. Collection

返回此集合中的元素数。

size() - Method in class java.util.concurrent. ArrayBlockingQueue

返回此队列中的元素数。

size() - Method in interface java.util.concurrent. BlockingDeque

返回此deque中的元素数。

size() - Method in class java.util.concurrent. ConcurrentHashMap

返回此地图中键值映射的数量。

size() - Method in class java.util.concurrent. ConcurrentLinkedDeque

返回此deque中的元素数。

size() - Method in class java.util.concurrent. ConcurrentLinkedQueue

返回此队列中的元素数。

size() - Method in class java.util.concurrent. ConcurrentSkipListMap

返回此地图中键值映射的数量。

size() - Method in class java.util.concurrent. ConcurrentSkipListSet

返回此集合中的元素数。

size() - Method in class java.util.concurrent. CopyOnWriteArrayList

返回此列表中的元素数。

size() - Method in class java.util.concurrent. CopyOnWriteArraySet

返回此集合中的元素数。

size() - Method in class java.util.concurrent. DelayQueue

size() - Method in class java.util.concurrent. LinkedBlockingDeque

返回此deque中的元素数。

size() - Method in class java.util.concurrent. LinkedBlockingQueue

返回此队列中的元素数。

size() - Method in class java.util.concurrent. LinkedTransferQueue

返回此队列中的元素数。

size() - Method in class java.util.concurrent. PriorityBlockingQueue

size() - Method in class java.util.concurrent. SynchronousQueue

始终返回零。

size() - Method in interface java.util. Deque

返回此deque中的元素数。

size() - Method in class java.util. Dictionary

返回此字典中的条目数（不同的键）。

size() - Method in class java.util. EnumMap

返回此地图中键值映射的数量。

size() - Method in class java.util. HashMap

返回此地图中键值映射的数量。

size() - Method in class java.util. HashSet

返回此集合中的元素数（其基数）。

size() - Method in class java.util. Hashtable

返回此哈希表中的键数。

size() - Method in class java.util. IdentityHashMap

返回此标识哈希映射中的键值映射的数量。

size() - Method in class java.util.jar. Attributes

返回此Map中的属性数。

size() - Method in class java.util. LinkedList

返回此列表中的元素数。

size() - Method in interface java.util. List

返回此列表中的元素数。

size() - Method in interface java.util. Map

返回此地图中键值映射的数量。

size() - Method in class java.util. PriorityQueue

size() - Method in class java.util. Properties

size() - Method in interface java.util. Set

返回此集合中的元素数（其基数）。

size() - Method in class java.util. TreeMap

返回此地图中键值映射的数量。

size() - Method in class java.util. TreeSet

返回此集合中的元素数（其基数）。

size() - Method in class java.util. Vector

返回此向量中的组件数。

size() - Method in class java.util. WeakHashMap

返回此地图中键值映射的数量。

size() - Method in class java.util.zip. ZipFile

返回ZIP文件中的条目数。

size() - Method in class javafx.beans.binding. ListExpression

size() - Method in class javafx.beans.binding. MapExpression

size() - Method in class javafx.beans.binding. SetExpression

size() - Method in class javafx.collections. ModifiableObservableListBase

size() - Method in interface javafx.collections. ObservableArray

检索此数组中的数据长度。

size() - Method in class javafx.collections.transformation. FilteredList

返回此列表中的元素数。

size() - Method in class javafx.collections.transformation. SortedList

返回此列表中的元素数。

size() - Method in class javax.accessibility. AccessibleRelationSet

返回关系集中的关系数。

size() - Method in class javax.activation. MimeTypeParameterList

返回此列表中的名称/值对数。

size() - Method in interface javax.management.openmbean. TabularData

返回 TabularData实例中包含的 CompositeData值（即行数）。

size() - Method in class javax.management.openmbean. TabularDataSupport

返回此 TabularDataSupport实例中的行数。

size() - Method in class javax.naming. CompositeName

检索此组合名称中的组件数。

size() - Method in class javax.naming. CompoundName

检索此化合物名称中的组件数。

size() - Method in interface javax.naming.directory. Attribute

检索此属性中的值的数量。

size() - Method in interface javax.naming.directory. Attributes

检索属性集中的属性数。

size() - Method in class javax.naming.directory. BasicAttribute

size() - Method in class javax.naming.directory. BasicAttributes

size() - Method in class javax.naming.ldap. LdapName

检索此LDAP名称中的组件数。

size() - Method in class javax.naming.ldap. Rdn

检索此Rdn中的属性类型/值对数。

size() - Method in interface javax.naming. Name

返回此名称中的组件数。

size() - Method in class javax.naming. Reference

检索此引用中的地址数。

size() - Method in interface javax.print.attribute. AttributeSet

返回此属性集中的属性数。

size() - Method in class javax.print.attribute. HashAttributeSet

返回此属性集中的属性数。

size() - Method in class javax.script. SimpleBindings

返回此地图中键值映射的数量。

size() - Method in class javax.sound.midi. Track

获取此轨道中的事件数。

size() - Method in interface javax.sql.rowset. CachedRowSet

返回此 CachedRowSet对象中的行数。

size() - Method in class javax.swing. ActionMap

返回此 ActionMap的绑定数。

size() - Method in class javax.swing. DefaultListModel

返回此列表中的组件数。

size() - Method in class javax.swing. InputMap

返回 KeyStroke绑定的数量。

size() - Method in interface javax.xml.xpath. XPathNodes

返回结果中的项目数

size() - Method in class jdk.incubator.http. MultiMapResult

size() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

size(String) - Method in interface java.nio.file.attribute. UserDefinedFileAttributeView

返回用户定义属性值的大小。

size(Path) - Static method in class java.nio.file. Files

返回文件的大小（以字节为单位）。

size(ObservableArray) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其大小为ObservableArray 。

size(ObservableList<E>) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其大小为ObservableList 。

size(ObservableMap<K, V>) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其大小为ObservableMap 。

size(ObservableSet<E>) - Static method in class javafx.beans.binding. Bindings

创建一个新的IntegerBinding ，其大小为ObservableSet 。

Size - Class in javafx.css

表示特定单位中指定的大小，例如14px或0.2em。

Size - Static variable in class javax.swing.text. StyleConstants

字体大小的名称。

Size(double, SizeUnits) - Constructor for class javafx.css. Size

SIZE - Static variable in class java.awt.font. TextAttribute

字体大小的属性键。

SIZE - Static variable in class java.lang. Byte

用于表示二进制补码二进制形式的 byte值的位数。

SIZE - Static variable in class java.lang. Character

用于以无符号二进制形式表示 char值的位数，常数为 16 。

SIZE - Static variable in class java.lang. Double

用于表示 double值的位数。

SIZE - Static variable in class java.lang. Float

用于表示 float值的位数。

SIZE - Static variable in class java.lang. Integer

用于表示二进制补码二进制形式的 int值的位数。

SIZE - Static variable in class java.lang. Long

用于表示二进制补码二进制形式的 long值的位数。

SIZE - Static variable in class java.lang. Short

用于表示二进制补码二进制形式的 short值的位数。

SIZE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“大小”

SIZE_CMD - Static variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

大小按钮文本属性。

Size2DSyntax - Class in javax.print.attribute

Class Size2DSyntax是一个抽象基类，提供表示二维大小的所有属性的常见实现。

Size2DSyntax(float, float, int) - Constructor for class javax.print.attribute. Size2DSyntax

从给定的浮点值构造新的二维大小属性。

Size2DSyntax(int, int, int) - Constructor for class javax.print.attribute. Size2DSyntax

从给定的整数值构造一个新的二维大小属性。

sizeAction - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane

一个 SizeAction的实例。

SizeAction() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.SizeAction

构造一个新的实例 SizeAction 。

sizeColumnsToFit(boolean) - Method in class javax.swing. JTable

已过时。
截至Swing 1.0.3版本，由doLayout()替换。

sizeColumnsToFit(int) - Method in class javax.swing. JTable

作为Java 2平台v1.4的过时。

SizeConverter - Class in javafx.css.converter

将大小转换为数字

SizeConverter.SequenceConverter - Class in javafx.css.converter

SIZED - Static variable in interface java.util. Spliterator

表示在遍历或分割之前从 estimateSize()返回的值的特征值表示在没有结构源修改的情况下表示完全遍历将遇到的元素数量的精确计数的有限大小。

SizeLimitExceededException - Exception in javax.naming

当方法产生超过大小相关限制的结果时，抛出此异常。

SizeLimitExceededException() - Constructor for exception javax.naming. SizeLimitExceededException

构造一个新的SizeLimitExceededException实例。

SizeLimitExceededException(String) - Constructor for exception javax.naming. SizeLimitExceededException

使用说明构造一个新的SizeLimitExceededException实例。

sizeProperty() - Method in class javafx.beans.binding. ListBinding

sizeProperty() - Method in class javafx.beans.binding. ListExpression

表示列表大小的整数属性。

sizeProperty() - Method in class javafx.beans.binding. MapBinding

sizeProperty() - Method in class javafx.beans.binding. MapExpression

表示地图大小的整数属性。

sizeProperty() - Method in class javafx.beans.binding. SetBinding

sizeProperty() - Method in class javafx.beans.binding. SetExpression

表示集合大小的整数属性。

sizeProperty() - Method in class javafx.beans.property. ListPropertyBase

sizeProperty() - Method in class javafx.beans.property. MapPropertyBase

sizeProperty() - Method in class javafx.beans.property. SetPropertyBase

SizeRequirements - Class in javax.swing

为了方便布局管理器，计算有关组件的大小和位置的信息。

SizeRequirements() - Constructor for class javax.swing. SizeRequirements

创建一个SizeRequirements对象，其最小，首选和最大大小设置为零，对齐值为0.5（居中）。

SizeRequirements(int, int, int, float) - Constructor for class javax.swing. SizeRequirements

创建一个SizeRequirements对象，具有指定的最小，首选和最大大小以及指定的对齐方式。

sizes - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager

组件的大小。

SizeSequence - Class in javax.swing

A SizeSequence对象有效地维护有序的大小和相应位置的列表。

SizeSequence() - Constructor for class javax.swing. SizeSequence

创建一个不包含条目的新的 SizeSequence对象。

SizeSequence(int) - Constructor for class javax.swing. SizeSequence

创建一个新的 SizeSequence对象，其中包含指定数量的条目，全部初始化为具有大小0。

SizeSequence(int[]) - Constructor for class javax.swing. SizeSequence

创建一个包含指定大小的新的 SizeSequence对象。

SizeSequence(int, int) - Constructor for class javax.swing. SizeSequence

创建一个新的 SizeSequence对象，其中包含指定数量的条目，全部初始化为具有 value大小。

sizeToScene() - Method in class javafx.stage. Window

设置此窗口的宽度和高度以匹配此窗口场景的内容大小。

SizeUnits - Enum in javafx.css

表示特定单位中指定的大小，例如14px或0.2em。

sizeWidthToFit() - Method in class javax.swing.table. TableColumn

调整 TableColumn以适应其标题单元格的宽度。

Skeleton - Interface in java.rmi.server

已过时。
没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

SkeletonMismatchException - Exception in java.rmi.server

已过时。
没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

SkeletonMismatchException(String) - Constructor for exception java.rmi.server. SkeletonMismatchException

已过时。
没有替换

SkeletonNotFoundException - Exception in java.rmi.server

已过时。
没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

SkeletonNotFoundException(String) - Constructor for exception java.rmi.server. SkeletonNotFoundException

已过时。

构造具有指定详细消息的 SkeletonNotFoundException 。

SkeletonNotFoundException(String, Exception) - Constructor for exception java.rmi.server. SkeletonNotFoundException

已过时。

构造具有指定的详细消息和嵌套异常的 SkeletonNotFoundException 。

Skin< C extends Skinnable> - Interface in javafx.scene.control

基类通过定义节点的场景图来定义用户界面控件的视觉表示，以表示皮肤。

SkinBase< C extends Control> - Class in javafx.scene.control

基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视化表示，以表示skin 。

SkinBase(C) - Constructor for class javafx.scene.control. SkinBase

所有SkinBase实例的构造方法。

Skinnable - Interface in javafx.scene.control

Skinnable接口由Control类实现，因此由所有Control实现实现。

skinProperty() - Method in class javafx.scene.control. Control

皮肤负责渲染这个 Control 。

skinProperty() - Method in class javafx.scene.control. PopupControl

皮肤负责渲染这个 PopupControl 。

skinProperty() - Method in interface javafx.scene.control. Skinnable

皮肤负责渲染这个 Control 。

skip(long) - Method in class java.io. BufferedInputStream

见 skip法 InputStream的一般合同。

skip(long) - Method in class java.io. BufferedReader

跳过字符

skip(long) - Method in class java.io. ByteArrayInputStream

从此输入流跳过 n个字节的输入。

skip(long) - Method in class java.io. CharArrayReader

跳过字符

skip(long) - Method in class java.io. FileInputStream

跳过并从输入流中丢弃 n个字节的数据。

skip(long) - Method in class java.io. FilterInputStream

跳过并从输入流中丢弃 n个字节的数据。

skip(long) - Method in class java.io. FilterReader

跳过字符

skip(long) - Method in class java.io. InputStream

跳过并从该输入流中丢弃 n个字节的数据。

skip(long) - Method in class java.io. LineNumberInputStream

已过时。

跳过并丢弃来自此输入流的 n字节数据。

skip(long) - Method in class java.io. LineNumberReader

跳过字符

skip(long) - Method in interface java.io. ObjectInput

跳过n个字节的输入。

skip(long) - Method in class java.io. PushbackInputStream

跳过并丢弃来自此输入流的 n字节的数据。

skip(long) - Method in class java.io. PushbackReader

跳过字符

skip(long) - Method in class java.io. Reader

跳过字符

skip(long) - Method in class java.io. StringBufferInputStream

已过时。

从此输入流跳过 n个字节的输入。

skip(long) - Method in class java.io. StringReader

跳过流中指定数量的字符。

skip(long) - Method in interface java.util.stream. DoubleStream

在丢弃流的第一个 n元素后，返回由该流的其余元素组成的流。

skip(long) - Method in interface java.util.stream. IntStream

在丢弃流的第一个 n元素后，返回由流的其余元素组成的流。

skip(long) - Method in interface java.util.stream. LongStream

在丢弃流的第一个 n元素后，返回由该流的剩余元素组成的流。

skip(long) - Method in interface java.util.stream. Stream

在丢弃流的第一个 n元素之后，返回由该流的剩余元素组成的流。

skip(long) - Method in class java.util.zip. CheckedInputStream

跳过指定的输入字节数。

skip(long) - Method in class java.util.zip. DeflaterInputStream

跳过并丢弃输入流中的数据。

skip(long) - Method in class java.util.zip. InflaterInputStream

跳过未压缩数据的指定字节数。

skip(long) - Method in class java.util.zip. ZipInputStream

跳过当前ZIP条目中指定的字节数。

skip(long) - Method in class javax.crypto. CipherInputStream

从可从该输入流读取的字节中跳过 n个字节的字节，而不阻塞。

skip(long) - Method in class javax.sound.sampled. AudioInputStream

跳过并丢弃该音频输入流中指定数量的字节。

skip(long) - Method in class javax.swing. ProgressMonitorInputStream

覆盖 FilterInputStream.skip以在跳过后更新进度监视器。

skip(String) - Method in class java.util. Scanner

跳过与指定字符串构成的模式匹配的输入。

skip(Pattern) - Method in class java.util. Scanner

跳过与指定模式匹配的输入，忽略分隔符。

SKIP_SIBLINGS - java.nio.file. FileVisitResult

继续，不要访问此文件或目录的 兄弟姐妹 。

SKIP_SUBTREE - java.nio.file. FileVisitResult

继续访问此目录中的条目。

skipBytes(int) - Method in interface java.io. DataInput

尝试从输入流中跳过 n个字节的数据，丢弃跳过的字节。

skipBytes(int) - Method in class java.io. DataInputStream

见 skipBytes法 DataInput的一般合同。

skipBytes(int) - Method in class java.io. ObjectInputStream

跳过字节。

skipBytes(int) - Method in class java.io. RandomAccessFile

尝试跳过超过 n字节的输入丢弃跳过的字节。

skipBytes(int) - Method in interface javax.imageio.stream. ImageInputStream

将流位置向前移动给定的字节数。

skipBytes(int) - Method in class javax.imageio.stream. ImageInputStreamImpl

通过致电 seek(getStreamPosition() + n)当前的流位置。

skipBytes(int) - Method in interface javax.jnlp. JNLPRandomAccessFile

尝试跳过超过 n字节的输入丢弃跳过的字节。

skipBytes(long) - Method in interface javax.imageio.stream. ImageInputStream

将流位置向前移动给定的字节数。

skipBytes(long) - Method in class javax.imageio.stream. ImageInputStreamImpl

通过致电 seek(getStreamPosition() + n)提高当前的流位置。

skippedEntity(String) - Method in interface org.xml.sax. ContentHandler

接收跳过实体的通知。

skippedEntity(String) - Method in class org.xml.sax.helpers. DefaultHandler

接收跳过实体的通知。

skippedEntity(String) - Method in class org.xml.sax.helpers. XMLFilterImpl

过滤跳过的实体事件。

skippedEntity(String) - Method in class org.xml.sax.helpers. XMLReaderAdapter

修改SAX2跳过的实体事件。

skipReferral() - Method in exception javax.naming. ReferralException

丢弃有待处理的转介。

SKYBLUE - Static variable in class javafx.scene.paint. Color

颜色天蓝色，RGB值为＃87CEEB

SLASH - javafx.scene.input. KeyCode

正斜杠的常数为“/”

slashSlashComments(boolean) - Method in class java.io. StreamTokenizer

确定tokenizer是否识别C ++风格的注释。

slashStarComments(boolean) - Method in class java.io. StreamTokenizer

确定标记器是否识别C风格的注释。

SLATEBLUE - Static variable in class javafx.scene.paint. Color

颜色为蓝色，RGB值为＃6A5ACD

SLATEGRAY - Static variable in class javafx.scene.paint. Color

颜色为灰色，RGB值为＃708090

SLATEGREY - Static variable in class javafx.scene.paint. Color

颜色为灰色，RGB值为＃708090

sleep(long) - Static method in class java.lang. Thread

使当前正在执行的线程停留（暂停执行）指定的毫秒数，这取决于系统定时器和调度程序的精度和准确性。

sleep(long) - Method in enum java.util.concurrent. TimeUnit

使用此时间单位执行 Thread.sleep 。

sleep(long, int) - Static method in class java.lang. Thread

导致正在执行的线程以指定的毫秒数加上指定的纳秒数来暂停（临时停止执行），这取决于系统定时器和调度器的精度和准确性。

slice() - Method in class java.nio. Buffer

创建一个新的缓冲区，其内容是此缓冲区内容的共享子序列。

slice() - Method in class java.nio. ByteBuffer

创建一个新的字节缓冲区，其内容是此缓冲区内容的共享子序列。

slice() - Method in class java.nio. CharBuffer

创建一个新的char缓冲区，其内容是此缓冲区内容的共享子序列。

slice() - Method in class java.nio. DoubleBuffer

创建一个新的双缓冲区，其内容是此缓冲区内容的共享子序列。

slice() - Method in class java.nio. FloatBuffer

创建一个新的浮动缓冲区，其内容是此缓冲区内容的共享子序列。

slice() - Method in class java.nio. IntBuffer

创建一个新的int缓冲区，其内容是此缓冲区内容的共享子序列。

slice() - Method in class java.nio. LongBuffer

创建一个新的长缓冲区，其内容是此缓冲区内容的共享子序列。

slice() - Method in class java.nio. ShortBuffer

创建一个新的短缓冲区，其内容是此缓冲区内容的共享子序列。

slider - Variable in class javax.swing.plaf.basic. BasicSliderUI

滑块

Slider - Class in javafx.scene.control

滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。

Slider() - Constructor for class javafx.scene.control. Slider

创建一个默认的Slider实例。

Slider(double, double, double) - Constructor for class javafx.scene.control. Slider

使用指定的滑块最小值，最大值和当前值值构造滑块控件。

SLIDER - javafx.scene. AccessibleRole

滑块角色。

SLIDER - Static variable in class javax.accessibility. AccessibleRole

允许用户从有界范围内进行选择的对象。

SLIDER - Static variable in class javax.swing.plaf.synth. Region

滑块区域。

SLIDER_FILL - Variable in class javax.swing.plaf.metal. MetalSliderUI

物业 JSlider.isFilled 。

SLIDER_THUMB - Static variable in class javax.swing.plaf.synth. Region

滑块的拇指。

SLIDER_TRACK - Static variable in class javax.swing.plaf.synth. Region

轨道滑块。

sliderModel - Variable in class javax.swing. JSlider

处理滑块的数字最大值，最小值和当前位置值的数据模型。

SliderSkin - Class in javafx.scene.control.skin

默认皮肤实现为Slider控件。

SliderSkin(Slider) - Constructor for class javafx.scene.control.skin. SliderSkin

创建一个新的SliderSkin实例，将必要的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

SliderUI - Class in javax.swing.plaf

JSlider可插拔的外观和界面。

SliderUI() - Constructor for class javax.swing.plaf. SliderUI

SMALL - Static variable in class javax.swing.text.html. HTML.Tag

标签<small>

SMALL_FORM_VARIANTS - Static variable in class java.lang. Character.UnicodeBlock

常量为“小型变体”Unicode字符块。

SMALL_GAP - javafx.scene.control. ButtonBar.ButtonData

一个“无关”的差距。

SMALL_ICON - Static variable in interface javax.swing. Action

该键用于存储一个小型的 Icon ，如 ImageIcon 。

SMALL_KEY - Static variable in class javax.swing.plaf.nimbus. NimbusStyle

小钥匙

SMALL_SCALE - Static variable in class javax.swing.plaf.nimbus. NimbusStyle

小规模

SmallAttributeSet(Object[]) - Constructor for class javax.swing.text. StyleContext.SmallAttributeSet

构造一个SmallAttributeSet。

SmallAttributeSet(AttributeSet) - Constructor for class javax.swing.text. StyleContext.SmallAttributeSet

构造一个SmallAttributeSet。

SMALLINT - java.sql. JDBCType

标识通用SQL类型 SMALLINT 。

SMALLINT - Static variable in class java.sql. Types

Java编程语言中的常量（有时称为类型代码），用于标识通用SQL类型 SMALLINT 。

SMART - java.time.format. ResolverStyle

风格以智能或智能的方式解决日期和时间。

SMOOTH_DEFAULT - Static variable in class javafx.scene.image. ImageView

平台相关的默认值为 smooth属性。

smoothProperty() - Method in class javafx.scene.image. ImageView

指示当转换或缩放源图像以适应 fitWidth和 fitHeight提供的边界框内时是否使用更好的质量过滤算法或更快的过滤算法。

smoothProperty() - Method in class javafx.scene.media. MediaView

如果设置为 true则将缩放此视频以适应 fitWidth和 fitHeight提供的边框或转换时将使用更好的质量过滤算法。

smoothProperty() - Method in class javafx.scene.shape. Shape

定义是否使用抗锯齿提示 Shape 。

SMPTE_24 - Static variable in class javax.sound.midi. Sequence

基于SMPTE的定时类型，每秒24帧（分辨率以帧为单位表示）。

SMPTE_25 - Static variable in class javax.sound.midi. Sequence

基于SMPTE的定时类型，每秒25帧（分辨率以帧为单位表示）。

SMPTE_30 - Static variable in class javax.sound.midi. Sequence

基于SMPTE的定时类型，每秒30帧（分辨率以帧为单位表示）。

SMPTE_30DROP - Static variable in class javax.sound.midi. Sequence

基于SMPTE的定时类型，每秒29.97帧（分辨率以帧为单位表示）。

snappedBottomInset() - Method in class javafx.scene.control.skin. MenuBarSkin

获取底部插图的实用方法，其中包括填充和边框插入。

snappedBottomInset() - Method in class javafx.scene.control. SkinBase

获取底部插图的实用方法，其中包括填充和边框插入。

snappedBottomInset() - Method in class javafx.scene.layout. Region

获取底部插图的实用方法，其中包括填充和边框插入。

snappedLeftInset() - Method in class javafx.scene.control.skin. MenuBarSkin

获取包含填充和边框插入的左边插图的实用方法。

snappedLeftInset() - Method in class javafx.scene.control. SkinBase

获取包含填充和边框插入的左边插图的实用方法。

snappedLeftInset() - Method in class javafx.scene.layout. Region

获取包含填充和边框插入的左边插图的实用方法。

snappedRightInset() - Method in class javafx.scene.control.skin. MenuBarSkin

获取正确的插图的实用方法，包括填充和边框插入。

snappedRightInset() - Method in class javafx.scene.control. SkinBase

获取正确的插图的实用方法，包括填充和边框插入。

snappedRightInset() - Method in class javafx.scene.layout. Region

获取正确的插图的实用方法，包括填充和边框插入。

snappedTopInset() - Method in class javafx.scene.control.skin. MenuBarSkin

获取包含填充和边框插入的顶层插图的实用方法。

snappedTopInset() - Method in class javafx.scene.control. SkinBase

获取包含填充和边框插入的顶层插图的实用方法。

snappedTopInset() - Method in class javafx.scene.layout. Region

获取包含填充和边框插入的顶层插图的实用方法。

snapPosition(double) - Method in class javafx.scene.control. SkinBase

已过时。
替换为snapPositionX()和snapPositionY()

snapPosition(double) - Method in class javafx.scene.layout. Region

已过时。
替换为snapPositionX()和snapPositionY()

snapPositionX(double) - Method in class javafx.scene.control. SkinBase

方便的方法访问 snapPositionX()方法在 skinnable 。

snapPositionX(double) - Method in class javafx.scene.layout. Region

如果此区域的snapToPixel属性为true，则返回一个舍入为水平方向最近像素的值，否则返回相同的值。

snapPositionY(double) - Method in class javafx.scene.control. SkinBase

在方便的方法访问 snapPositionY()方法在 skinnable 。

snapPositionY(double) - Method in class javafx.scene.layout. Region

如果该区域的snapToPixel属性为true，则返回一个四舍五入到垂直方向上最近的像素的值，否则返回相同的值。

snapshot(WritableImage) - Method in class javafx.scene. Scene

拍摄此场景的快照，并在渲染图像准备就绪时返回。

snapshot(SnapshotParameters, WritableImage) - Method in class javafx.scene. Node

获取该节点的快照，并在渲染图像准备就绪时返回。

snapshot(Callback<SnapshotResult, Void>, WritableImage) - Method in class javafx.scene. Scene

在下一帧拍摄此场景的快照，并在图像准备就绪时调用指定的回调方法。

snapshot(Callback<SnapshotResult, Void>, SnapshotParameters, WritableImage) - Method in class javafx.scene. Node

在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。

snapshotItem(int) - Method in interface org.w3c.dom.xpath. XPathResult

返回快照集合中的 index项目。

SnapshotParameters - Class in javafx.scene

用于指定节点快照的渲染属性的参数。

SnapshotParameters() - Constructor for class javafx.scene. SnapshotParameters

构造一个新的SnapshotParameters对象，具有所有渲染属性的默认值。

SnapshotResult - Class in javafx.scene

此类保存快照操作的结果。

snapSize(double) - Method in class javafx.scene.control. SkinBase

已过时。
替换为snapSizeX()和snapSizeY()

snapSize(double) - Method in class javafx.scene.layout. Region

已过时。
代之以snapSizeX()和snapSizeY()

snapSizeX(double) - Method in class javafx.scene.control. SkinBase

方便的方法访问 snapSizeX()方法在 skinnable 。

snapSizeX(double) - Method in class javafx.scene.layout. Region

如果此区域的snapToPixel属性为true，则返回一个值，该值将被忽略到水平方向上最近的像素，否则返回相同的值。

snapSizeY(double) - Method in class javafx.scene.control. SkinBase

方便的方法访问 snapSizeY()方法在 skinnable 。

snapSizeY(double) - Method in class javafx.scene.layout. Region

如果此区域的snapToPixel属性为true，则返回一个值，该值将被忽略到垂直方向上最近的像素，否则返回相同的值。

snapSpace(double) - Method in class javafx.scene.control. SkinBase

已过时。
替换为snapSpaceX()和snapSpaceY()

snapSpace(double) - Method in class javafx.scene.layout. Region

已过时。
替换为snapSpaceX()和snapSpaceY()

snapSpaceX(double) - Method in class javafx.scene.control. SkinBase

方便的方法访问 snapSpaceX()方法的 skinnable 。

snapSpaceX(double) - Method in class javafx.scene.layout. Region

如果此区域的snapToPixel属性为true，则返回一个舍入为水平方向最近像素的值，否则返回相同的值。

snapSpaceY(double) - Method in class javafx.scene.control. SkinBase

方便的方法访问 snapSpaceY()方法在 skinnable 。

snapSpaceY(double) - Method in class javafx.scene.layout. Region

如果该区域的snapToPixel属性为true，则返回一个四舍五入到垂直方向上最近的像素的值，否则返回相同的值。

snapToPixelProperty() - Method in class javafx.scene.layout. Region

定义此区域是否将其子项的位置，间距和大小值调整为像素边界。

snapToTicks - Variable in class javax.swing. JSlider

如果为真，则旋钮（及其表示的数据值）将解析为用户放置旋钮的最靠近的刻度线。

snapToTicksProperty() - Method in class javafx.scene.control. Slider

指示 Slider的 Slider应始终与刻度线对齐。

SND - Static variable in class javax.sound.sampled. AudioFileFormat.Type

指定SND文件。

SNI_HOST_NAME - Static variable in class javax.net.ssl. StandardConstants

代表服务器名称指示（SNI）扩展名中的DNS主机名（见SNIHostName ）的“host_name”类型。

SNIHostName - Class in javax.net.ssl

此类的实例表示服务器名称指示（SNI）扩展中的类型为 host_name的服务器名称。

SNIHostName(byte[]) - Constructor for class javax.net.ssl. SNIHostName

使用指定的编码值创建 SNIHostName 。

SNIHostName(String) - Constructor for class javax.net.ssl. SNIHostName

使用指定的主机名创建一个 SNIHostName 。

SNIMatcher - Class in javax.net.ssl

此类的实例表示在SNIServerName实例上执行匹配操作的匹配器。

SNIMatcher(int) - Constructor for class javax.net.ssl. SNIMatcher

使用指定的服务器名称类型创建 SNIMatcher 。

snippet() - Method in class jdk.jshell. SnippetEvent

代码段已更改

Snippet - Class in jdk.jshell

代码片段代表传递给 JShell.eval的Java源代码片段。

Snippet.Kind - Enum in jdk.jshell

描述一般的片段。

Snippet.Status - Enum in jdk.jshell

描述代码段的当前状态。

Snippet.SubKind - Enum in jdk.jshell

一个片段的详细种类。

SnippetEvent - Class in jdk.jshell

对代码段的更改的描述。

snippets() - Method in class jdk.jshell. JShell

返回所有片段。

SNIServerName - Class in javax.net.ssl

此类的实例表示服务器名称指示（SNI）扩展中的服务器名称。

SNIServerName(int, byte[]) - Constructor for class javax.net.ssl. SNIServerName

使用指定的名称类型和编码值创建 SNIServerName 。

SNOW - Static variable in class javafx.scene.paint. Color

RGB值为#FFFAFA的彩色雪

SO_BINDADDR - Static variable in interface java.net. SocketOptions

获取套接字的本地地址绑定（此选项不能仅“设置”，因为套接字在创建时绑定，因此本地绑定的地址不能被更改）。

SO_BROADCAST - Static variable in interface java.net. SocketOptions

为套接字设置SO_BROADCAST。

SO_BROADCAST - Static variable in class java.net. StandardSocketOptions

允许传输广播数据报。

SO_FLOW_SLA - Static variable in class jdk.net. ExtendedSocketOptions

服务级属性。

SO_KEEPALIVE - Static variable in interface java.net. SocketOptions

当为TCP套接字设置keepalive选项，并且没有数据在两个方向上通过套接字交换2小时（注意：实际值取决于实现），TCP自动向对等体发送keepalive探测。

SO_KEEPALIVE - Static variable in class java.net. StandardSocketOptions

保持连接活着。

SO_LINGER - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

如果数据存在，则关闭。

SO_LINGER - Static variable in interface java.net. SocketOptions

指定一个随叫随到的超时时间。

SO_LINGER - Static variable in class java.net. StandardSocketOptions

如果数据存在，则关闭。

SO_OOBINLINE - Static variable in interface java.net. SocketOptions

当设置OOBINLINE选项时，将通过套接字输入流接收在套接字上接收的任何TCP紧急数据。

SO_RCVBUF - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

套接字的大小接收缓冲区。

SO_RCVBUF - Static variable in interface java.net. SocketOptions

设置平台为传入网络I / O使用的底层缓冲区的大小。

SO_RCVBUF - Static variable in class java.net. StandardSocketOptions

套接字的大小接收缓冲区。

SO_REUSEADDR - Static variable in interface java.net. SocketOptions

为套接字设置SO_REUSEADDR。

SO_REUSEADDR - Static variable in class java.net. StandardSocketOptions

重用地址。

SO_REUSEPORT - Static variable in interface java.net. SocketOptions

为套接字设置SO_REUSEPORT。

SO_REUSEPORT - Static variable in class java.net. StandardSocketOptions

重新使用端口。

SO_SNDBUF - Static variable in class com.sun.nio.sctp. SctpStandardSocketOptions

套接字发送缓冲区的大小。

SO_SNDBUF - Static variable in interface java.net. SocketOptions

设置平台用于传出网络I / O的底层缓冲区的大小。

SO_SNDBUF - Static variable in class java.net. StandardSocketOptions

套接字发送缓冲区的大小。

SO_TIMEOUT - Static variable in interface java.net. SocketOptions

在阻塞Socket操作上设置一个超时：

SOAP_1_1_CONTENT_TYPE - Static variable in interface javax.xml.soap. SOAPConstants

SOAP 1.1中的 Content-Type MIME头的媒体类型。

SOAP_1_1_PROTOCOL - Static variable in interface javax.xml.soap. SOAPConstants

用于创建 MessageFactory实例，创建其行为支持SOAP 1.1规范的 SOAPMessages 。

SOAP_1_2_CONTENT_TYPE - Static variable in interface javax.xml.soap. SOAPConstants

SOAP 1.2中的 Content-Type MIME头的媒体类型。

SOAP_1_2_PROTOCOL - Static variable in interface javax.xml.soap. SOAPConstants

用于创建 MessageFactory实例，创建其行为支持SOAP 1.2规范的 SOAPMessages

SOAP_DATAENCODINGUNKNOWN_FAULT - Static variable in interface javax.xml.soap. SOAPConstants

SOAP 1.2 DataEncodingUnknown Fault

SOAP_ENV_PREFIX - Static variable in interface javax.xml.soap. SOAPConstants

http://www.w3.org/2003/05/soap-envelope的默认命名空间前缀

SOAP_MUSTUNDERSTAND_FAULT - Static variable in interface javax.xml.soap. SOAPConstants

SOAP 1.2 MustUnderstand故障

SOAP_RECEIVER_FAULT - Static variable in interface javax.xml.soap. SOAPConstants

SOAP 1.2接收器故障

SOAP_SENDER_FAULT - Static variable in interface javax.xml.soap. SOAPConstants

SOAP 1.2发送者故障

SOAP_VERSIONMISMATCH_FAULT - Static variable in interface javax.xml.soap. SOAPConstants

SOAP 1.2版本不匹配故障

SOAP11HTTP_BINDING - Static variable in interface javax.xml.ws.soap. SOAPBinding

表示SOAP 1.1通过HTTP绑定的身份的常量。

SOAP11HTTP_MTOM_BINDING - Static variable in interface javax.xml.ws.soap. SOAPBinding

默认情况下，表示使用MTOM的HTTP 1.1绑定的SOAP 1.1的身份的常量。

SOAP12HTTP_BINDING - Static variable in interface javax.xml.ws.soap. SOAPBinding

一个表示SOAP 1.2通过HTTP绑定的身份的常量。

SOAP12HTTP_MTOM_BINDING - Static variable in interface javax.xml.ws.soap. SOAPBinding

默认情况下，表示通过HTTP绑定的SOAP 1.2身份的常量，MTOM启用。

SOAPACTION_URI_PROPERTY - Static variable in interface javax.xml.ws. BindingProvider

SOAPAction的标准属性。

SOAPACTION_USE_PROPERTY - Static variable in interface javax.xml.ws. BindingProvider

SOAPAction的标准属性。

SOAPBinding - Interface in javax.xml.ws.soap

SOAPBinding接口是SOAP绑定的抽象。

SOAPBinding - Annotation Type in javax.jws.soap

SOAPBinding.ParameterStyle - Enum in javax.jws.soap

SOAPBinding.Style - Enum in javax.jws.soap

SOAPBinding.Use - Enum in javax.jws.soap

SOAPBody - Interface in javax.xml.soap

表示SOAP消息中SOAP主体元素内容的对象。

SOAPBodyElement - Interface in javax.xml.soap

甲 SOAPBodyElement对象表示内容 SOAPBody对象。

SOAPConnection - Class in javax.xml.soap

客户端可以将消息直接发送到远程方（例如由URL表示）的点对点连接。

SOAPConnection() - Constructor for class javax.xml.soap. SOAPConnection

SOAPConnectionFactory - Class in javax.xml.soap

创建 SOAPConnection对象的工厂。

SOAPConnectionFactory() - Constructor for class javax.xml.soap. SOAPConnectionFactory

SOAPConstants - Interface in javax.xml.soap

关于SOAP协议的常量定义。

SOAPElement - Interface in javax.xml.soap

表示SOAP消息的元素的对象，SOAP消息被允许但不是由SOAP规范特别规定。

SOAPElementFactory - Class in javax.xml.soap

已过时。
- 使用javax.xml.soap.SOAPFactory创建SOAPElements。

SOAPEnvelope - Interface in javax.xml.soap

用于SOAPHeader的容器和SOAPBody部分的一个 SOAPPart对象。

SOAPException - Exception in javax.xml.soap

发生SOAP异常发生的异常。

SOAPException() - Constructor for exception javax.xml.soap. SOAPException

构造一个无原因的 SOAPException对象，或嵌入 Throwable对象。

SOAPException(String) - Constructor for exception javax.xml.soap. SOAPException

构造一个 SOAPException对象与给定的 String作为抛出异常的原因。

SOAPException(String, Throwable) - Constructor for exception javax.xml.soap. SOAPException

使用给定的 String构造一个 SOAPException对象作为引发异常的原因，给定的 Throwable对象作为嵌入式异常。

SOAPException(Throwable) - Constructor for exception javax.xml.soap. SOAPException

构造一个用给定的 SOAPException对象初始化的 Throwable对象。

SOAPFactory - Class in javax.xml.soap

SOAPFactory是用于创建SOAP XML树中存在的各种对象的工厂。

SOAPFactory() - Constructor for class javax.xml.soap. SOAPFactory

SOAPFault - Interface in javax.xml.soap

SOAPBody对象中包含错误和/或状态信息的元素。

SOAPFaultElement - Interface in javax.xml.soap

内容在 SOAPFault对象中的表示。

SOAPFaultException - Exception in javax.xml.ws.soap

SOAPFaultException异常表示SOAP 1.1或1.2故障。

SOAPFaultException(SOAPFault) - Constructor for exception javax.xml.ws.soap. SOAPFaultException

SOAPFaultException的构造方法

SOAPHandler< T extends SOAPMessageContext> - Interface in javax.xml.ws.handler.soap

SOAPHandler类扩展了 Handler以提供消息上下文参数的类型安全性，并添加一种方法来获取对可能由处理程序处理的头部的访问。

SOAPHeader - Interface in javax.xml.soap

SOAP头元素的表示。

SOAPHeaderElement - Interface in javax.xml.soap

表示SOAP信封SOAP头部分内容的对象。

SOAPMessage - Class in javax.xml.soap

所有SOAP消息的根类。

SOAPMessage() - Constructor for class javax.xml.soap. SOAPMessage

SOAPMessageContext - Interface in javax.xml.ws.handler.soap

接口 SOAPMessageContext为RPC请求或响应提供对SOAP消息的访问。

SOAPMessageHandler - Annotation Type in javax.jws.soap

已过时。

SOAPMessageHandlers - Annotation Type in javax.jws.soap

已过时。

SOAPPart - Class in javax.xml.soap

SOAPMessage对象的SOAP特定部分的 SOAPMessage 。

SOAPPart() - Constructor for class javax.xml.soap. SOAPPart

socket() - Method in class java.nio.channels. DatagramChannel

检索与此通道相关联的数据报套接字。

socket() - Method in class java.nio.channels. ServerSocketChannel

检索与此通道关联的服务器套接字。

socket() - Method in class java.nio.channels. SocketChannel

检索与此通道相关联的套接字。

Socket - Class in java.net

该类实现客户端套接字（也称为“套接字”）。

Socket() - Constructor for class java.net. Socket

创建一个未连接的套接字，并使用系统默认类型的SocketImpl。

Socket(String, int) - Constructor for class java.net. Socket

创建流套接字并将其连接到指定主机上的指定端口号。

Socket(String, int, boolean) - Constructor for class java.net. Socket

已过时。
使用DatagramSocket代替UDP传输。

Socket(String, int, InetAddress, int) - Constructor for class java.net. Socket

创建套接字并将其连接到指定远程端口上的指定远程主机。

Socket(InetAddress, int) - Constructor for class java.net. Socket

创建流套接字并将其连接到指定IP地址的指定端口号。

Socket(InetAddress, int, boolean) - Constructor for class java.net. Socket

已过时。
使用DatagramSocket代替UDP传输。

Socket(InetAddress, int, InetAddress, int) - Constructor for class java.net. Socket

创建套接字并将其连接到指定的远程端口上指定的远程地址。

Socket(Proxy) - Constructor for class java.net. Socket

创建一个未连接的套接字，指定应该使用的代理类型（如果有的话），无论其他任何设置如何。

Socket(SocketImpl) - Constructor for class java.net. Socket

使用用户指定的SocketImpl创建一个未连接的Socket。

SocketAddress - Class in java.net

这个类代表一个没有协议附件的Socket地址。

SocketAddress() - Constructor for class java.net. SocketAddress

SocketChannel - Class in java.nio.channels

用于面向流的连接插座的可选通道。

SocketChannel(SelectorProvider) - Constructor for class java.nio.channels. SocketChannel

初始化此类的新实例。

SocketException - Exception in java.net

抛出以表示创建或访问Socket时出错。

SocketException() - Constructor for exception java.net. SocketException

构造一个新的 SocketException ，没有详细的消息。

SocketException(String) - Constructor for exception java.net. SocketException

构造一个新的 SocketException与指定的详细信息。

SocketFactory - Class in javax.net

这个类创建套接字。

SocketFactory() - Constructor for class javax.net. SocketFactory

创建一个 SocketFactory 。

SocketFlow - Class in jdk.net

表示平台特定套接字选项 ExtendedSocketOptions.SO_FLOW_SLA的服务级别属性。

SocketFlow.Status - Enum in jdk.net

从SO_FLOW_SLA套接字选项枚举返回值。

SocketHandler - Class in java.util.logging

简单网络记录 Handler 。

SocketHandler() - Constructor for class java.util.logging. SocketHandler

创建一个 SocketHandler ，仅使用 LogManager属性（或其默认值）。

SocketHandler(String, int) - Constructor for class java.util.logging. SocketHandler

使用指定的主机和端口构造 SocketHandler 。

SocketImpl - Class in java.net

抽象类 SocketImpl是实际实现套接字的所有类的公共超类。

SocketImpl() - Constructor for class java.net. SocketImpl

SocketImplFactory - Interface in java.net

该接口定义了一个工厂用于套接字实现。

SocketOption< T> - Interface in java.net

与套接字关联的套接字选项。

SocketOptions - Interface in java.net

获取/设置套接字选项的方法的接口。

SocketPermission - Class in java.net

此类表示通过套接字访问网络。

SocketPermission(String, String) - Constructor for class java.net. SocketPermission

使用指定的操作创建一个新的SocketPermission对象。

Sockets - Class in jdk.net

定义静态方法来设置和获取由SocketOption界面定义的套接字选项。

SocketSecurityException - Exception in java.rmi.server

已过时。
这个班已经过时了 改用ExportException 。

SocketSecurityException(String) - Constructor for exception java.rmi.server. SocketSecurityException

已过时。

构造具有指定详细消息的 SocketSecurityException 。

SocketSecurityException(String, Exception) - Constructor for exception java.rmi.server. SocketSecurityException

已过时。

构造一个具有指定的详细消息和嵌套异常的 SocketSecurityException 。

SocketTimeoutException - Exception in java.net

指示在套接字上发生超时时读取或接受。

SocketTimeoutException() - Constructor for exception java.net. SocketTimeoutException

构造一个新的SocketTimeoutException，没有详细的消息。

SocketTimeoutException(String) - Constructor for exception java.net. SocketTimeoutException

构造一个带有详细消息的新SocketTimeoutException。

SOCKS - java.net. Proxy.Type

代表SOCKS（V4或V5）代理。

SOFT_FAIL - java.security.cert. PKIXRevocationChecker.Option

如果由于以下原因之一而无法确定吊销状态，允许撤销检查成功：由于网络错误，无法获取CRL或OCSP响应。

SOFT_LIGHT - javafx.scene.effect. BlendMode

根据顶部输入颜色，输入颜色分量要么变暗，要么变暗。

SoftBevelBorder - Class in javax.swing.border

实现具有软化拐角的凸起或降低的斜面的课程。

SoftBevelBorder(int) - Constructor for class javax.swing.border. SoftBevelBorder

创建具有指定类型的斜角边框，其颜色将从传递到paintBorder方法的组件的背景颜色派生。

SoftBevelBorder(int, Color, Color) - Constructor for class javax.swing.border. SoftBevelBorder

创建具有指定类型，高亮和阴影颜色的斜角边框。

SoftBevelBorder(int, Color, Color, Color, Color) - Constructor for class javax.swing.border. SoftBevelBorder

创建具有指定类型的斜角边框，突出显示阴影颜色。

SOFTKEY_0 - javafx.scene.input. KeyCode

常数为 Softkey 0键。

SOFTKEY_1 - javafx.scene.input. KeyCode

常数为 Softkey 1键。

SOFTKEY_2 - javafx.scene.input. KeyCode

常数为 Softkey 2键。

SOFTKEY_3 - javafx.scene.input. KeyCode

常数为 Softkey 3键。

SOFTKEY_4 - javafx.scene.input. KeyCode

常数为 Softkey 4键。

SOFTKEY_5 - javafx.scene.input. KeyCode

常数为 Softkey 5键。

SOFTKEY_6 - javafx.scene.input. KeyCode

常数为 Softkey 6键。

SOFTKEY_7 - javafx.scene.input. KeyCode

常数为 Softkey 7键。

SOFTKEY_8 - javafx.scene.input. KeyCode

常数为 Softkey 8键。

SOFTKEY_9 - javafx.scene.input. KeyCode

常数为 Softkey 9键。

SoftReference< T> - Class in java.lang.ref

软参考对象，由垃圾收集器根据内存需求自行清除。

SoftReference(T) - Constructor for class java.lang.ref. SoftReference

创建引用给定对象的新的软引用。

SoftReference(T, ReferenceQueue<? super T>) - Constructor for class java.lang.ref. SoftReference

创建引用给定对象并在给定队列中注册的新软引用。

SolarisLoginModule - Class in com.sun.security.auth.module

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK1.4，由com.sun.security.auth.module.UnixLoginModule替换。 这个LoginModule已经完全被废弃了，这里允许平滑过渡到新的UnixLoginModule。 此类可能在将来的Java SE版本中被删除。

SolarisLoginModule() - Constructor for class com.sun.security.auth.module. SolarisLoginModule

已过时。

SolarisNumericGroupPrincipal - Class in com.sun.security.auth

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由UnixNumericGroupPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

SolarisNumericGroupPrincipal(long, boolean) - Constructor for class com.sun.security.auth. SolarisNumericGroupPrincipal

已过时。

使用用户组标识号（GID）的长表示创建 SolarisNumericGroupPrincipal 。

SolarisNumericGroupPrincipal(String, boolean) - Constructor for class com.sun.security.auth. SolarisNumericGroupPrincipal

已过时。

使用 String表示用户的组标识号（GID）创建 SolarisNumericGroupPrincipal 。

SolarisNumericUserPrincipal - Class in com.sun.security.auth

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由UnixNumericUserPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

SolarisNumericUserPrincipal(long) - Constructor for class com.sun.security.auth. SolarisNumericUserPrincipal

已过时。

使用用户标识号（UID）的长表示创建 SolarisNumericUserPrincipal 。

SolarisNumericUserPrincipal(String) - Constructor for class com.sun.security.auth. SolarisNumericUserPrincipal

已过时。

创建 SolarisNumericUserPrincipal使用 String用户的标识号（UID）的表示。

SolarisPrincipal - Class in com.sun.security.auth

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由UnixPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

SolarisPrincipal(String) - Constructor for class com.sun.security.auth. SolarisPrincipal

已过时。

使用Solaris用户名创建SolarisPrincipal。

SolarisSystem - Class in com.sun.security.auth.module

不推荐用于删除：此API元素将在以后的版本中被删除。
替换为UnixSystem 。 此类可能在将来的Java SE版本中被删除。

SolarisSystem() - Constructor for class com.sun.security.auth.module. SolarisSystem

已过时。

实例化一个 SolarisSystem并加载本机库以访问底层系统信息。

SOLID - Static variable in class javafx.scene.layout. BorderStrokeStyle

用于抚摸的预定义实线

solveCubic(double[]) - Static method in class java.awt.geom. CubicCurve2D

eqn其系数在 eqn数组中的 eqn ，并将非复数根返回到同一个数组中，返回根数。

solveCubic(double[], double[]) - Static method in class java.awt.geom. CubicCurve2D

求解其系数在 eqn数组中的 eqn ，并将非复数根放入 res数组中，返回根数。

solveQuadratic(double[]) - Static method in class java.awt.geom. QuadCurve2D

eqn其系数在 eqn数组中，并将非复数根返回到同一个数组中，返回根数。

solveQuadratic(double[], double[]) - Static method in class java.awt.geom. QuadCurve2D

eqn其系数在 eqn数组中，并将非复数根放入 res数组中，返回根数。

SOMEBITS - Static variable in interface java.awt.image. ImageObserver

imageUpdate的infoflags参数中的此标志表示绘制图像缩放变体所需的更多像素可用。

SOMETIMES - javafx.scene.layout. Priority

如果没有其他布局区域随着增长（或缩小）设置为始终，或者这些布局区域没有吸收所有增加（或减少）空间，则将与其他布局区域的空间分配空间的增加（或减小）有时。

SONG_POSITION_POINTER - Static variable in class javax.sound.midi. ShortMessage

歌曲位置指针讯息的状态字节（0xF2或242）。

SONG_SELECT - Static variable in class javax.sound.midi. ShortMessage

MIDI乐曲的状态字节选择信息（0xF3或243）。

SORA_SOMPENG - java.lang. Character.UnicodeScript

Unicode脚本“Sora Sompeng”。

SORA_SOMPENG - Static variable in class java.lang. Character.UnicodeBlock

常数为“Sora Sompeng”Unicode字符块。

sort() - Method in class javafx.scene.control. TableView

排序方法强制TableView重新运行其排序算法。

sort() - Method in class javafx.scene.control. TreeTableView

排序方法强制TreeTableView重新运行其排序算法。

sort() - Method in class javax.swing. DefaultRowSorter

根据当前正在排序的列的排序键和与此排序器关联的过滤器（如果有），对视图中的行进行排序和过滤。

sort(byte[]) - Static method in class java.util. Arrays

按照数字顺序排列指定的数组。

sort(byte[], int, int) - Static method in class java.util. Arrays

按升序排列数组的指定范围。

sort(char[]) - Static method in class java.util. Arrays

按照数字顺序排列指定的数组。

sort(char[], int, int) - Static method in class java.util. Arrays

按升序排列数组的指定范围。

sort(double[]) - Static method in class java.util. Arrays

按照数字顺序排列指定的数组。

sort(double[], int, int) - Static method in class java.util. Arrays

按升序排列数组的指定范围。

sort(float[]) - Static method in class java.util. Arrays

按照数字顺序排列指定的数组。

sort(float[], int, int) - Static method in class java.util. Arrays

按升序排列数组的指定范围。

sort(int[]) - Static method in class java.util. Arrays

按照数字顺序排列指定的数组。

sort(int[], int, int) - Static method in class java.util. Arrays

按升序排列数组的指定范围。

sort(long[]) - Static method in class java.util. Arrays

按照数字顺序排列指定的数组。

sort(long[], int, int) - Static method in class java.util. Arrays

按升序排列数组的指定范围。

sort(short[]) - Static method in class java.util. Arrays

按照数字顺序排列指定的数组。

sort(short[], int, int) - Static method in class java.util. Arrays

按升序排列数组的指定范围。

sort(Object[]) - Static method in class java.util. Arrays

根据其元素的natural ordering按照升序排列指定的对象数组。

sort(Object[], int, int) - Static method in class java.util. Arrays

根据其元素的natural ordering按照升序排列指定数组对象的指定范围。

sort(Comparator<? super E>) - Method in class java.util. ArrayList

sort(Comparator<? super E>) - Method in class java.util.concurrent. CopyOnWriteArrayList

sort(Comparator<? super E>) - Method in interface java.util. List

根据指定的Comparator引发的顺序排列此列表。

sort(Comparator<? super E>) - Method in class java.util. Vector

sort(List<T>) - Static method in class java.util. Collections

根据其元素的natural ordering按照升序排列指定的列表。

sort(List<T>, Comparator<? super T>) - Static method in class java.util. Collections

根据指定的比较器引起的顺序对指定的列表进行排序。

sort(Vector<? extends File>) - Method in class javax.swing.plaf.basic. BasicDirectoryModel

排序文件列表。

sort(ObservableList<T>) - Static method in class javafx.collections. FXCollections

对提供的可观察列表进行排序。

sort(ObservableList<T>, Comparator<? super T>) - Static method in class javafx.collections. FXCollections

使用c比较器对提供的可观察列表进行排序。

sort(T[], int, int, Comparator<? super T>) - Static method in class java.util. Arrays

根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。

sort(T[], Comparator<? super T>) - Static method in class java.util. Arrays

根据指定的比较器引发的顺序对指定的对象数组进行排序。

SORT_ORDER_CHANGED - javax.swing.event. RowSorterEvent.Type

表示排序顺序已更改。

sortableProperty() - Method in class javafx.scene.control. TableColumnBase

用于打开和关闭此列的“可排序性”的布尔属性。

SortControl - Class in javax.naming.ldap

请求在返回之前由LDAP服务器对搜索操作的结果进行排序。

SortControl(String[], boolean) - Constructor for class javax.naming.ldap. SortControl

构造一个控件以按升序对属性列表进行排序。

SortControl(String, boolean) - Constructor for class javax.naming.ldap. SortControl

构造一个控件以按升序对单个属性进行排序。

SortControl(SortKey[], boolean) - Constructor for class javax.naming.ldap. SortControl

构造一个控件以对排序键列表进行排序。

sorted() - Method in interface java.util.stream. DoubleStream

以排序顺序返回由该流的元素组成的流。

sorted() - Method in interface java.util.stream. IntStream

以排序顺序返回由该流的元素组成的流。

sorted() - Method in interface java.util.stream. LongStream

以排序顺序返回由该流的元素组成的流。

sorted() - Method in interface java.util.stream. Stream

返回由此流的元素组成的流，根据自然顺序排序。

sorted() - Method in interface javafx.collections. ObservableList

使用自然排序创建此列表的SortedList包装。

sorted(Comparator<? super T>) - Method in interface java.util.stream. Stream

返回由该流的元素组成的流，根据提供的 Comparator进行排序。

sorted(Comparator<E>) - Method in interface javafx.collections. ObservableList

使用指定的比较器创建此列表的SortedList包装器。

SORTED - javax.swing.event. RowSorterEvent.Type

表示内容已经以某种方式进行了新的排序或转换。

SORTED - Static variable in interface java.util. Spliterator

特征值表示遇到的顺序遵循定义的排序顺序。

SortedList< E> - Class in javafx.collections.transformation

包装一个ObservableList并对其内容进行排序。

SortedList(ObservableList<? extends E>) - Constructor for class javafx.collections.transformation. SortedList

在源列表周围构造一个新的无序SortedList包装器。

SortedList(ObservableList<? extends E>, Comparator<? super E>) - Constructor for class javafx.collections.transformation. SortedList

创建一个围绕源列表的新SortedList。

SortedMap< K, V> - Interface in java.util

A Map进一步提供其键上的总排序 。

SortedSet< E> - Interface in java.util

A Set进一步提供了其元素的总排序 。

sorterChanged(RowSorterEvent) - Method in interface javax.swing.event. RowSorterListener

通知 RowSorter已更改。

sorterChanged(RowSorterEvent) - Method in class javax.swing. JTable

RowSorterListener通知， RowSorter已经改变了某种方式。

sortEvent() - Static method in class javafx.scene.control. SortEvent

SortEvent< C> - Class in javafx.scene.control

事件涉及TableView和TreeTableView排序。

SortEvent(C, EventTarget) - Constructor for class javafx.scene.control. SortEvent

SortingFocusTraversalPolicy - Class in javax.swing

FocusTraversalPolicy通过基于给定的比较器对焦点遍历周期的组件进行排序来确定遍历顺序。

SortingFocusTraversalPolicy() - Constructor for class javax.swing. SortingFocusTraversalPolicy

构造一个没有比较器的SortingFocusTraversalPolicy。

SortingFocusTraversalPolicy(Comparator<? super Component>) - Constructor for class javax.swing. SortingFocusTraversalPolicy

使用指定的比较器构造SortingFocusTraversalPolicy。

SortKey - Class in javax.naming.ldap

排序键及其相关的排序参数。

SortKey(int, SortOrder) - Constructor for class javax.swing. RowSorter.SortKey

使用指定的排序顺序为指定的列创建一个 SortKey 。

SortKey(String) - Constructor for class javax.naming.ldap. SortKey

创建属性的默认排序键。

SortKey(String, boolean, String) - Constructor for class javax.naming.ldap. SortKey

为属性创建排序键。

sortModeProperty() - Method in class javafx.scene.control. TreeTableView

指定在排序此TreeTableView的内容时使用的排序模式，如果在 sort order列表中指定任何列。

sortNodeProperty() - Method in class javafx.scene.control. TableColumnBase

用作“排序箭头”的节点，在表列是排序顺序的一部分的情况下向用户显示。

SortOrder - Enum in javax.swing

SortOrder是可能的排序顺序的枚举。

sortPolicyProperty() - Method in class javafx.scene.control. TableView

排序策略指定如何执行此TableView中的排序。

sortPolicyProperty() - Method in class javafx.scene.control. TreeTableView

排序策略指定如何执行此TreeTableView中的排序。

SortResponseControl - Class in javax.naming.ldap

指示所请求的搜索结果是否成功。

SortResponseControl(String, boolean, byte[]) - Constructor for class javax.naming.ldap. SortResponseControl

构造一个控件来指示排序请求的结果。

sortTypeProperty() - Method in class javafx.scene.control. TableColumn

用于说明该列是否是排序顺序的一部分（更多详细信息，请参阅 TableView.getSortOrder() ），应按升序或降序进行排序。

sortTypeProperty() - Method in class javafx.scene.control. TreeTableColumn

用于说明该列是否是排序顺序的一部分（更多详细信息，请参阅 TreeTableView.getSortOrder() ），应按升序或降序进行排序。

Soundbank - Interface in javax.sound.midi

一个 Soundbank包含一组 Instruments可以加载到 Synthesizer 。

SoundbankReader - Class in javax.sound.midi.spi

A SoundbankReader提供 SoundbankReader文件阅读服务。

SoundbankReader() - Constructor for class javax.sound.midi.spi. SoundbankReader

SoundbankResource - Class in javax.sound.midi

A SoundbankResource表示存储在Soundbank中的任何音频资源。

SoundbankResource(Soundbank, String, Class<?>) - Constructor for class javax.sound.midi. SoundbankResource

从给定的声音库和波表指数构建一个新的 SoundbankResource 。

source - Variable in class com.sun.java.accessibility.util. Translator

源对象需要翻译。

source - Variable in class java.util. EventObject

事件最初发生的对象。

source - Variable in class javax.management. Notification

该字段隐藏父类中的 EventObject.source字段，使其成为非瞬态，因此是序列化形式的一部分。

source - Variable in class javax.swing.plaf.basic. BasicTreeUI.MouseInputHandler

来源于事件来自。

source() - Method in class java.lang.module. ModuleDescriptor.Exports

返回包名称。

source() - Method in class java.lang.module. ModuleDescriptor.Opens

返回包名称。

source() - Method in class java.nio.channels. Pipe

返回此管道的源通道。

source() - Method in class jdk.jshell. Snippet

返回代码段的源代码。

source() - Method in interface jdk.jshell. SourceCodeAnalysis.CompletionInfo

第一个代码片段的源代码输入。

source() - Method in interface jdk.jshell. SourceCodeAnalysis.SnippetWrapper

返回包装的输入。

Source - Interface in javax.xml.transform

实现此接口的对象包含充当源输入（XML源或转换指令）所需的信息。

SOURCE - java.lang.annotation. RetentionPolicy

注释将被编译器丢弃。

SOURCE - javax.tools. JavaFileObject.Kind

以Java编程语言编写的源文件。

SOURCE_OUTPUT - javax.tools. StandardLocation

新的源文件的位置。

SOURCE_PATH - javax.tools. StandardLocation

搜索现有源文件的位置。

sourceActions - Variable in class java.awt.dnd. DragGestureRecognizer

一个表示此拖放操作中使用的操作类型的 int 。

sourceAddress() - Method in class java.nio.channels. MembershipKey

如果此成员资格密钥是源特定的，则返回源地址，如果此成员资格不是源特定的，则返回 null 。

sourceBands - Variable in class javax.imageio. IIOParam

int的阵列，表示将使用哪些源频段，或 null 。

sourceChanged(ListChangeListener.Change<? extends E>) - Method in class javafx.collections.transformation. FilteredList

sourceChanged(ListChangeListener.Change<? extends E>) - Method in class javafx.collections.transformation. SortedList

sourceChanged(ListChangeListener.Change<? extends F>) - Method in class javafx.collections.transformation. TransformationList

当来自源的更改被触发时调用。

SourceChannel(SelectorProvider) - Constructor for class java.nio.channels. Pipe.SourceChannel

构造一个这个类的新实例。

sourceCodeAnalysis() - Method in class jdk.jshell. JShell

访问源代码分析功能。

SourceCodeAnalysis - Class in jdk.jshell

提供源代码输入的分析实用程序。

SourceCodeAnalysis.Completeness - Enum in jdk.jshell

描述给定输入的完整性。

SourceCodeAnalysis.CompletionInfo - Interface in jdk.jshell

结果 analyzeCompletion(String input) 。

SourceCodeAnalysis.Documentation - Interface in jdk.jshell

用于继续给定用户输入的候选人的文档。

SourceCodeAnalysis.QualifiedNames - Class in jdk.jshell

可能的合格名称列表。

SourceCodeAnalysis.SnippetWrapper - Interface in jdk.jshell

将Java源代码片段包装到有效的顶级Java源代码中。

SourceCodeAnalysis.Suggestion - Interface in jdk.jshell

用于继续给定用户输入的候选者。

SourceDataLine - Interface in javax.sound.sampled

源数据线是可以写入数据的数据线。

sourceDebugExtension() - Method in interface com.sun.jdi. ReferenceType

获取此类型的源调试扩展。

SourceLocator - Interface in javax.xml.transform

此接口主要用于报告XML源或转换指令中发生错误的目的。

sourceName() - Method in interface com.sun.jdi. Location

获取与此位置相对应的源的标识名称。

sourceName() - Method in interface com.sun.jdi. ReferenceType

获取与此类型的声明相对应的源的识别名称。

sourceName(String) - Method in interface com.sun.jdi. Location

获取与此位置相对应的源的标识名称。

sourceNames(String) - Method in interface com.sun.jdi. ReferenceType

获取与此类型的声明对应的所有源的识别名称。

sourcePath() - Method in interface com.sun.jdi. Location

获取与此位置相对应的源的路径。

sourcePath(String) - Method in interface com.sun.jdi. Location

获取与此位置相对应的源的路径。

sourcePaths(String) - Method in interface com.sun.jdi. ReferenceType

获取与此类型的声明对应的源的路径。

SourcePosition - Interface in com.sun.javadoc

已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

SourcePositions - Interface in com.sun.source.util

提供在CompilationUnit中获取树的位置的方法。

sourceProperty() - Method in class javafx.scene.effect. ImageInput

来源 Image 。

sourceRegion - Variable in class javax.imageio. IIOParam

源区域，在 null如果没有设置。

sourceRenderSize - Variable in class javax.imageio. ImageReadParam

源的所需渲染宽度和高度，如果 canSetSourceRenderSize为 true或 null 。

sources - Variable in class java.awt.image.renderable. ParameterBlock

源的矢量，存储为任意对象。

sourceToInputSource(Source) - Static method in class javax.xml.transform.sax. SAXSource

尝试从Source对象获取SAX InputSource对象。

sourceToWrappedPosition(int) - Method in interface jdk.jshell. SourceCodeAnalysis.SnippetWrapper

将字符位置在源文件中包含的字符位置。

SourceVersion - Enum in javax.lang.model

源代码版本的Java编程语言。

sourceXSubsampling - Variable in class javax.imageio. IIOParam

在水平方向应用抽取次采样。

sourceYSubsampling - Variable in class javax.imageio. IIOParam

在垂直方向应用抽取次采样。

SOUTH - Static variable in class java.awt. BorderLayout

南布局约束（容器底部）。

SOUTH - Static variable in class java.awt. GridBagConstraints

将组件放在其显示区域的底部，水平居中。

SOUTH - Static variable in class javax.swing. SpringLayout

指定组件边界矩形的下边缘。

SOUTH - Static variable in interface javax.swing. SwingConstants

指南方向南（向下）。

SOUTH_EAST - Static variable in interface javax.swing. SwingConstants

指南针方向东南（右下）。

SOUTH_WEST - Static variable in interface javax.swing. SwingConstants

罗盘方向西南（左下）。

SOUTHEAST - Static variable in class java.awt. GridBagConstraints

将组件放在其显示区域的右下角。

southPane - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI

南窗格

SOUTHWEST - Static variable in class java.awt. GridBagConstraints

将组件放在其显示区域的左下角。

SPACE - javafx.scene.input. KeyCode

常数为 Space键。

SPACE - javafx.scene.layout. BackgroundRepeat

经常重复图像，以适合该区域内而不被剪裁，然后将图像间隔开以填充该区域。

SPACE - javafx.scene.layout. BorderRepeat

图像被平铺（重复）以填充整个区域的瓷砖，并且任何额外的空间分布在瓷砖周围。

SPACE - Static variable in interface javax.xml.stream. XMLStreamConstants

字符是空格（参见[XML]，2.10“空白处理”）。

SPACE_SEPARATOR - Static variable in class java.lang. Character

Unicode规范中的一般类别“Zs”。

SpaceAbove - Static variable in class javax.swing.text. StyleConstants

段落上方的空间量。

SpaceBelow - Static variable in class javax.swing.text. StyleConstants

段落以下的空间量。

SPACING_MODIFIER_LETTERS - Static variable in class java.lang. Character.UnicodeBlock

“间隔修饰符字母”的常量Unicode字符块。

spacingProperty() - Method in class javafx.scene.control.skin. MenuBarSkin

指定MenuBar上的菜单按钮之间的间距。

spacingProperty() - Method in class javafx.scene.layout. HBox

hbox中每个孩子之间的水平空间量。

spacingProperty() - Method in class javafx.scene.layout. VBox

vbox中每个孩子之间的垂直空间量。

SPAN - Static variable in class javax.swing.text.html. HTML.Tag

标记<span>

SPARSE - java.nio.file. StandardOpenOption

稀疏文件

SPEAKER - Static variable in class javax.sound.sampled. Port.Info

一种将音频发送到内置扬声器或扬声器插孔的端口。

SPECIAL_SYSTEM_EXCLUSIVE - Static variable in class javax.sound.midi. SysexMessage

特殊系统专用消息（0xF7或247）的状态字节，用于MIDI文件。

SpecialAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.SpecialAction

SPECIALS - Static variable in class java.lang. Character.UnicodeBlock

“特殊”Unicode字符块的常数。

SPECIFICATION_TITLE - Static variable in class java.util.jar. Attributes.Name

Name对象为 Specification-Title用于包版本控制的清单属性。

SPECIFICATION_VENDOR - Static variable in class java.util.jar. Attributes.Name

Name对象为 Specification-Vendor用于包版本控制的manifest属性。

SPECIFICATION_VERSION - Static variable in class java.util.jar. Attributes.Name

Name对象用于包版本控制的 Specification-Version清单属性。

specifiedClasses() - Method in interface com.sun.javadoc. RootDoc

已过时。

在命令行上返回类和接口 specified作为源文件名。

specifiedPackages() - Method in interface com.sun.javadoc. RootDoc

已过时。

在命令行上返回包 specified 。

spectrumDataUpdate(double, double, float[], float[]) - Method in interface javafx.scene.media. AudioSpectrumListener

向观察者通知可用于音频频谱的新数据。

specularColorProperty() - Method in class javafx.scene.paint. PhongMaterial

这个镜面颜色 PhongMaterial 。

specularConstantProperty() - Method in class javafx.scene.effect. Lighting

镜面常数。

specularExponentProperty() - Method in class javafx.scene.effect. Light.Spot

镜面指数，控制这个光源的焦点。

specularExponentProperty() - Method in class javafx.scene.effect. Lighting

镜面指数。

specularMapProperty() - Method in class javafx.scene.paint. PhongMaterial

这个 PhongMaterial的镜面图。

specularPowerProperty() - Method in class javafx.scene.paint. PhongMaterial

这镜子的力量这个 PhongMaterial 。

SPEED - javafx.scene. CacheHint

告诉位图缓存机制，这个节点是动画，并应该从位图缓存中绘制，以尽可能保持平滑的动画。

SPEED_REF_KILOMETERS_PER_HOUR - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

与“GPSSpeedRef”标签一起使用的值。

SPEED_REF_KNOTS - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

与“GPSSpeedRef”标签一起使用的值。

SPEED_REF_MILES_PER_HOUR - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

与“GPSSpeedRef”标签一起使用的值。

Sphere - Class in javafx.scene.shape

Sphere类定义了具有指定大小的三维球体。

Sphere() - Constructor for class javafx.scene.shape. Sphere

创建半径为1.0的新实例 Sphere 。

Sphere(double) - Constructor for class javafx.scene.shape. Sphere

创建一个具有给定半径的新实例 Sphere 。

Sphere(double, int) - Constructor for class javafx.scene.shape. Sphere

创建一个具有给定半径和分割数的新实例 Sphere 。

SPIN_BOX - Static variable in class javax.accessibility. AccessibleRole

A SPIN_BOX是一个简单的微调组件，其主要用途是简单的数字。

spinner - Variable in class javax.swing.plaf.basic. BasicSpinnerUI

我们是一个UI委托的微调器。

Spinner< T> - Class in javafx.scene.control

单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。

Spinner() - Constructor for class javafx.scene.control. Spinner

构造一个默认的Spinner实例，使用默认的“spinner”样式类和不可编辑的编辑器。

Spinner(double, double, double) - Constructor for class javafx.scene.control. Spinner

创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。

Spinner(double, double, double, double) - Constructor for class javafx.scene.control. Spinner

创建一个微调实例与value factory设置为实例SpinnerValueFactory.DoubleSpinnerValueFactory 。

Spinner(int, int, int) - Constructor for class javafx.scene.control. Spinner

创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。

Spinner(int, int, int, int) - Constructor for class javafx.scene.control. Spinner

创建一个微调实例与value factory设置为实例SpinnerValueFactory.IntegerSpinnerValueFactory 。

Spinner(ObservableList<T>) - Constructor for class javafx.scene.control. Spinner

创建一个微调实例与value factory设置为实例SpinnerValueFactory.ListSpinnerValueFactory 。

Spinner(SpinnerValueFactory<T>) - Constructor for class javafx.scene.control. Spinner

使用给定值出厂设置创建一个Spinner实例。

SPINNER - javafx.scene. AccessibleRole

旋转角色。

SPINNER - Static variable in class javax.swing.plaf.synth. Region

旋转区域。

SpinnerDateModel - Class in javax.swing

A SpinnerModel ，序列 Date s。

SpinnerDateModel() - Constructor for class javax.swing. SpinnerDateModel

构造一个 SpinnerDateModel ，其初始 value是当前日期， calendarField等于 Calendar.DAY_OF_MONTH ，以及用于其中有没有 start / end限制。

SpinnerDateModel(Date, Comparable<Date>, Comparable<Date>, int) - Constructor for class javax.swing. SpinnerDateModel

创建一个 SpinnerDateModel ，代表 start和 end之间的日期序列。

SpinnerListModel - Class in javax.swing

SpinnerModel的简单实现，其值由数组或 List定义。

SpinnerListModel() - Constructor for class javax.swing. SpinnerListModel

构造一个有效的空 SpinnerListModel 。

SpinnerListModel(Object[]) - Constructor for class javax.swing. SpinnerListModel

构造一个 SpinnerModel其值序列由指定的数组定义。

SpinnerListModel(List<?>) - Constructor for class javax.swing. SpinnerListModel

构造一个 SpinnerModel其值序列由指定的 List定义。

SpinnerModel - Interface in javax.swing

一个可能无限制的对象值序列的模型。

SpinnerNumberModel - Class in javax.swing

A SpinnerModel用于数字序列。

SpinnerNumberModel() - Constructor for class javax.swing. SpinnerNumberModel

构造一个 SpinnerNumberModel其中没有 minimum或 maximum值， stepSize等于1，初始值为零。

SpinnerNumberModel(double, double, double, double) - Constructor for class javax.swing. SpinnerNumberModel

构造一个 SpinnerNumberModel具有指定 value ， minimum / maximum界限， stepSize 。

SpinnerNumberModel(int, int, int, int) - Constructor for class javax.swing. SpinnerNumberModel

构造一个 SpinnerNumberModel具有指定 value ， minimum / maximum界限， stepSize 。

SpinnerNumberModel(Number, Comparable<?>, Comparable<?>, Number) - Constructor for class javax.swing. SpinnerNumberModel

构造一个 SpinnerModel ，表示从 minimum到 maximum的封闭序列。

SpinnerSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为Spinner控件。

SpinnerSkin(Spinner<T>) - Constructor for class javafx.scene.control.skin. SpinnerSkin

创建一个新的SpinnerSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

SpinnerUI - Class in javax.swing.plaf

JSpinner可插拔的外观和界面

SpinnerUI() - Constructor for class javax.swing.plaf. SpinnerUI

SpinnerValueFactory< T> - Class in javafx.scene.control

SpinnerValueFactory是JavaFX Spinner control背后的模型 - 没有值出厂安装的Spinner不可用。

SpinnerValueFactory() - Constructor for class javafx.scene.control. SpinnerValueFactory

SpinnerValueFactory.DoubleSpinnerValueFactory - Class in javafx.scene.control

一个SpinnerValueFactory实现，旨在迭代双重值。

SpinnerValueFactory.IntegerSpinnerValueFactory - Class in javafx.scene.control

一个SpinnerValueFactory实现，旨在遍历整数值。

SpinnerValueFactory.ListSpinnerValueFactory< T> - Class in javafx.scene.control

一个SpinnerValueFactory实现，旨在迭代一个值列表。

SPIResolutionException - Exception in jdk.jshell.spi

该异常的构造和抛出嵌入在JShell核心实现中生成的代码中，以便在执行 RECOVERABLE_DEFINED用户方法时抛出此异常。

SPIResolutionException(int) - Constructor for exception jdk.jshell.spi. SPIResolutionException

构造一个SPI层异常，指示已遇到具有未解析引用的 DeclarationSnippet 。

SplashScreen - Class in java.awt

在Java虚拟机（JVM）启动之前，启动屏幕可以在应用程序启动时显示。

SPLINE(double, double, double, double) - Static method in class javafx.animation. Interpolator

创建一个 Interpolator ，其 curve()使用由（定义样条控制点状 x1 ， y1 ）和（ x2 ， y2 ）。

split() - Method in class java.util. SplittableRandom

构造并返回一个新的SplittableRandom实例，与该实例共享不可变状态。

split(CharSequence) - Method in class java.util.regex. Pattern

将给定的输入序列分成这个模式的匹配。

split(CharSequence, int) - Method in class java.util.regex. Pattern

将给定的输入序列分成这个模式的匹配。

split(String) - Method in class java.lang. String

将此字符串拆分为给定的匹配 regular expression 。

split(String, int) - Method in class java.lang. String

将此字符串拆分为给定的 regular expression的匹配 项 。

SPLIT_MENU_BUTTON - javafx.scene. AccessibleRole

拆分菜单按钮角色。

SPLIT_PANE - Static variable in class javax.accessibility. AccessibleRole

同时提供另外两个面板的专门面板。

SPLIT_PANE - Static variable in class javax.swing.plaf.synth. Region

拆分区域。

SPLIT_PANE_DIVIDER - Static variable in class javax.swing.plaf.synth. Region

拆分板的分隔线。

splitAsStream(CharSequence) - Method in class java.util.regex. Pattern

根据给定的输入序列创建一个流，该流与该模式匹配。

spliterator() - Method in interface java.lang. Iterable

在Iterable描述的元素上创建一个Iterable 。

spliterator() - Method in class java.util. ArrayDeque

在此deque中的元素上创建一个late-binding和失败快速的 Spliterator 。

spliterator() - Method in class java.util. ArrayList

在此列表中的元素上创建late-binding和故障快速 Spliterator 。

spliterator() - Method in interface java.util. Collection

在此集合中的元素上创建一个Spliterator 。

spliterator() - Method in class java.util.concurrent. ArrayBlockingQueue

返回此队列中的元素Spliterator 。

spliterator() - Method in class java.util.concurrent. ConcurrentHashMap.KeySetView

spliterator() - Method in class java.util.concurrent. ConcurrentLinkedDeque

在此deque中的元素上返回Spliterator 。

spliterator() - Method in class java.util.concurrent. ConcurrentLinkedQueue

返回此队列中的元素Spliterator 。

spliterator() - Method in class java.util.concurrent. ConcurrentSkipListSet

返回此集合中的元素Spliterator 。

spliterator() - Method in class java.util.concurrent. CopyOnWriteArrayList

在此列表中的元素上返回一个Spliterator 。

spliterator() - Method in class java.util.concurrent. CopyOnWriteArraySet

以这些元素的添加顺序返回此集合中的元素Spliterator 。

spliterator() - Method in class java.util.concurrent. LinkedBlockingDeque

在此deque中的元素上返回一个Spliterator 。

spliterator() - Method in class java.util.concurrent. LinkedBlockingQueue

在此队列中的元素上返回一个Spliterator 。

spliterator() - Method in class java.util.concurrent. LinkedTransferQueue

返回此队列中的元素Spliterator 。

spliterator() - Method in class java.util.concurrent. PriorityBlockingQueue

在此队列中的元素上返回一个Spliterator 。

spliterator() - Method in class java.util.concurrent. SynchronousQueue

返回一个空的分配器，其中对 Spliterator.trySplit()的调用总是返回 null 。

spliterator() - Method in class java.util. HashSet

在此集合中的元素上创建late-binding和故障快速 Spliterator 。

spliterator() - Method in class java.util. LinkedHashSet

在此集合中的元素上创建 late-binding和 故障快速 Spliterator 。

spliterator() - Method in class java.util. LinkedList

在此列表中的元素上创建late-binding和故障快速 Spliterator 。

spliterator() - Method in interface java.util. List

在此列表中的元素上创建一个Spliterator 。

spliterator() - Method in class java.util. PriorityQueue

在此队列中的元素上创建late-binding和故障快速 Spliterator 。

spliterator() - Method in interface java.util. Set

在此集合中的元素上创建一个 Spliterator 。

spliterator() - Method in interface java.util. SortedSet

在此排序集中的元素上创建一个 Spliterator 。

spliterator() - Method in interface java.util.stream. BaseStream

返回此流的元素的拼接器。

spliterator() - Method in interface java.util.stream. DoubleStream

spliterator() - Method in interface java.util.stream. IntStream

spliterator() - Method in interface java.util.stream. LongStream

spliterator() - Method in class java.util. TreeSet

在此集合中的元素上创建late-binding和故障快速 Spliterator 。

spliterator() - Method in class java.util. Vector

在此列表中的元素上创建late-binding和故障快速 Spliterator 。

spliterator(double[]) - Static method in class java.util. Arrays

返回覆盖所有指定数组的Spliterator.OfDouble 。

spliterator(double[], int) - Static method in class java.util. Spliterators

创建一个覆盖给定数组元素的 Spliterator.OfDouble ，使用一组自定义的分割器特征。

spliterator(double[], int, int) - Static method in class java.util. Arrays

返回覆盖指定数组的指定范围的Spliterator.OfDouble 。

spliterator(double[], int, int, int) - Static method in class java.util. Spliterators

创建一个 Spliterator.OfDouble涵盖给定数组的一系列元素，使用一组自定义的拼接器特征。

spliterator(int[]) - Static method in class java.util. Arrays

返回一个涵盖所有指定数组的Spliterator.OfInt 。

spliterator(int[], int) - Static method in class java.util. Spliterators

创建一个覆盖给定数组的元素的 Spliterator.OfInt ，使用一组自定义的拼接器特征。

spliterator(int[], int, int) - Static method in class java.util. Arrays

返回覆盖指定数组的指定范围的Spliterator.OfInt 。

spliterator(int[], int, int, int) - Static method in class java.util. Spliterators

创建一个 Spliterator.OfInt涵盖了一组给定阵列的元素，使用了一组自定义的拼接器特征。

spliterator(long[]) - Static method in class java.util. Arrays

返回一个涵盖所有指定数组的Spliterator.OfLong 。

spliterator(long[], int) - Static method in class java.util. Spliterators

创建一个 Spliterator.OfLong ，使用定制的一组拼接器特征来覆盖给定阵列的元素。

spliterator(long[], int, int) - Static method in class java.util. Arrays

返回覆盖指定数组的指定范围的Spliterator.OfLong 。

spliterator(long[], int, int, int) - Static method in class java.util. Spliterators

创建一个 Spliterator.OfLong ，使用定制的一组拼接器特征来覆盖给定阵列的一系列元素。

spliterator(Object[], int) - Static method in class java.util. Spliterators

创建一个 Spliterator覆盖给定数组的元素，使用一组自定义的分割器特征。

spliterator(Object[], int, int, int) - Static method in class java.util. Spliterators

创建一个 Spliterator ，使用一组自定义的拼接器特征来覆盖给定阵列的一系列元素。

spliterator(Collection<? extends T>, int) - Static method in class java.util. Spliterators

使用给定集合的 Collection.iterator()作为元素的来源创建 Spliterator ，并报告其 Collection.size()作为其初始大小。

spliterator(Iterator<? extends T>, long, int) - Static method in class java.util. Spliterators

创建一个 Spliterator使用给定的 Iterator作为元素的来源，并给出最初报告的大小。

spliterator(PrimitiveIterator.OfDouble, long, int) - Static method in class java.util. Spliterators

使用给定的 DoubleStream.DoubleIterator作为元素的来源创建一个 Spliterator.OfDouble ，并使用给定的最初报告的大小。

spliterator(PrimitiveIterator.OfInt, long, int) - Static method in class java.util. Spliterators

创建一个 Spliterator.OfInt使用给定的 IntStream.IntIterator作为元素的来源，并给出最初报告的大小。

spliterator(PrimitiveIterator.OfLong, long, int) - Static method in class java.util. Spliterators

使用给定的 LongStream.LongIterator作为元素的来源创建一个 Spliterator.OfLong ，并使用给定的最初报告的大小。

spliterator(T[]) - Static method in class java.util. Arrays

返回一个涵盖所有指定数组的Spliterator 。

spliterator(T[], int, int) - Static method in class java.util. Arrays

返回一个覆盖指定数组的指定范围的Spliterator 。

Spliterator< T> - Interface in java.util

用于遍历和分割源的元素的对象。

Spliterator.OfDouble - Interface in java.util

一个专门针对 double值的 double 。

Spliterator.OfInt - Interface in java.util

一个专门为 int值的 int 。

Spliterator.OfLong - Interface in java.util

A Spliterator专门为 long值。

Spliterator.OfPrimitive< T, T_CONS, T_SPLITR extends Spliterator.OfPrimitive< T, T_CONS, T_SPLITR>> - Interface in java.util

专门针对原始价值观的Spliterator。

Spliterators - Class in java.util

静态类和用于上操作或创建的实例的方法Spliterator及其原始特Spliterator.OfInt ， Spliterator.OfLong ，和Spliterator.OfDouble 。

Spliterators.AbstractDoubleSpliterator - Class in java.util

摘要 Spliterator.OfDouble实现了 trySplit以允许有限的并行性。

Spliterators.AbstractIntSpliterator - Class in java.util

摘要 Spliterator.OfInt实现了 trySplit以允许有限的并行性。

Spliterators.AbstractLongSpliterator - Class in java.util

摘要 Spliterator.OfLong实现了 trySplit以允许有限的并行性。

Spliterators.AbstractSpliterator< T> - Class in java.util

摘要 Spliterator实现了 trySplit以允许有限的并行性。

spliteratorUnknownSize(Iterator<? extends T>, int) - Static method in class java.util. Spliterators

创建一个 Spliterator使用给定的 Iterator作为元素的来源，没有初始大小估计。

spliteratorUnknownSize(PrimitiveIterator.OfDouble, int) - Static method in class java.util. Spliterators

创建一个 Spliterator.OfDouble使用给定的 DoubleStream.DoubleIterator作为元素的来源，没有初始大小估计。

spliteratorUnknownSize(PrimitiveIterator.OfInt, int) - Static method in class java.util. Spliterators

使用给定的 IntStream.IntIterator作为元素的来源创建一个 Spliterator.OfInt ，没有初始大小估计。

spliteratorUnknownSize(PrimitiveIterator.OfLong, int) - Static method in class java.util. Spliterators

创建一个 Spliterator.OfLong使用给定的 LongStream.LongIterator作为元素的来源，没有初始大小估计。

SplitMenuButton - Class in javafx.scene.control

SplitMenuButton与MenuButton一样，与从菜单中选择MenuItem的概念密切相关。

SplitMenuButton() - Constructor for class javafx.scene.control. SplitMenuButton

创建一个新的空拆分菜单按钮。

SplitMenuButton(MenuItem...) - Constructor for class javafx.scene.control. SplitMenuButton

使用给定的菜单项列表创建一个新的拆分菜单按钮。

SplitMenuButtonSkin - Class in javafx.scene.control.skin

默认皮肤实现为SplitMenuButton控件。

SplitMenuButtonSkin(SplitMenuButton) - Constructor for class javafx.scene.control.skin. SplitMenuButtonSkin

创建一个新的SplitMenuButtonSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

splitPane - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider

JSplitPane包含接收器。

splitPane - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI

这个实例的JSplitPane实例提供了外观和感觉。

SplitPane - Class in javafx.scene.control

具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。

SplitPane() - Constructor for class javafx.scene.control. SplitPane

创建一个没有内容的新SplitPane。

SplitPane(Node...) - Constructor for class javafx.scene.control. SplitPane

创建一个新的SplitPane，其中给定的项目设置为在一个或多个分频器之间分割的内容。

SplitPane.Divider - Class in javafx.scene.control

在SplitPane中代表一个分隔符。

SplitPaneBorder(Color, Color) - Constructor for class javax.swing.plaf.basic. BasicBorders.SplitPaneBorder

构造一个新的实例 SplitPaneBorder 。

SplitPaneSkin - Class in javafx.scene.control.skin

默认皮肤实现为SplitPane控件。

SplitPaneSkin(SplitPane) - Constructor for class javafx.scene.control.skin. SplitPaneSkin

创建一个新的SplitPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

splitPaneUI - Variable in class javax.swing.plaf.basic. BasicSplitPaneDivider

这个实例是从这个UI创建的。

SplitPaneUI - Class in javax.swing.plaf

JSplitPane可插拔的外观和界面。

SplitPaneUI() - Constructor for class javax.swing.plaf. SplitPaneUI

SplittableRandom - Class in java.util

适用于（在其他上下文中）使用可能产生子任务的孤立并行计算的均匀伪随机值的生成器。

SplittableRandom() - Constructor for class java.util. SplittableRandom

创建一个新的SplittableRandom实例，可能会生成与当前程序中任何其他实例统计上独立的值序列; 并且通常可以在程序调用中变化。

SplittableRandom(long) - Constructor for class java.util. SplittableRandom

使用指定的初始种子创建一个新的SplittableRandom实例。

splitText(int) - Method in interface org.w3c.dom. Text

将该节点分解为指定的 offset两个节点，将树中的两个节点都作为兄弟节点。

SPOOL_AREA_FULL - Static variable in class javax.print.attribute.standard. PrinterStateReason

分配给假脱机的持久存储器的限制已经达到。

Spot() - Constructor for class javafx.scene.effect. Light.Spot

使用默认参数创建一个新的Spotlight实例。

Spot(double, double, double, double, Color) - Constructor for class javafx.scene.effect. Light.Spot

使用指定的x，y，z，specularExponent和color创建一个新的Spotlight实例。

spPropertyChangeListener - Variable in class javax.swing.plaf.basic. BasicScrollPaneUI

PropertyChangeListener安装在滚动窗格上。

SPREAD - jdk.nashorn.api.tree. Tree.Kind

用于表示数组和函数调用参数的扩展“运算符”的SpreadTree的实例。

spreadInvoker(MethodType, int) - Static method in class java.lang.invoke. MethodHandles

产生一个方法句柄，它将调用给定的 type任何方法句柄，给定数量的尾随参数被单个尾随的 Object[]数组替换。

spreadProperty() - Method in class javafx.scene.effect. DropShadow

阴影的传播。

SpreadTree - Interface in jdk.nashorn.api.tree

数组元素中的扩展运算符的树节点，函数调用参数。

Spring - Class in javax.swing

Spring类的一个实例具有表征其行为的三个属性： 最小值 ， 首选值和 最大值 。

Spring() - Constructor for class javax.swing. Spring

用工厂方法用来创建一个 Spring 。

SPRINGGREEN - Static variable in class javafx.scene.paint. Color

颜色为绿色，RGB值为＃00FF7F

SpringLayout - Class in javax.swing

A SpringLayout根据一组约束来 SpringLayout其关联容器的子项。

SpringLayout() - Constructor for class javax.swing. SpringLayout

构造新的 SpringLayout 。

SpringLayout.Constraints - Class in javax.swing

一个 Constraints对象保存了控制由一个 SpringLayout控制的容器中组件的大小和位置变化方式的 SpringLayout 。

SQLClientInfoException - Exception in java.sql

当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。

SQLClientInfoException() - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException对象。

SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， vendorCode和 failedProperties 。

SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。

SQLClientInfoException(String, String, Map<String, ClientInfoStatus>) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState和 failedProperties 。

SQLClientInfoException(String, String, Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause和 failedProperties 。

SQLClientInfoException(String, Map<String, ClientInfoStatus>) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException对象，初始化为给定的 reason和 failedProperties 。

SQLClientInfoException(String, Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， cause和 failedProperties 。

SQLClientInfoException(Map<String, ClientInfoStatus>) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException对象，该对象使用给定的 failedProperties初始化。

SQLClientInfoException(Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql. SQLClientInfoException

构造一个 SQLClientInfoException对象，该对象使用给定的 cause和 failedProperties初始化。

SQLData - Interface in java.sql

用于将SQL用户定义类型（UDT）自定义映射到Java编程语言中的类的接口。

SQLDataException - Exception in java.sql

当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。

SQLDataException() - Constructor for exception java.sql. SQLDataException

构造一个 SQLDataException对象。

SQLDataException(String) - Constructor for exception java.sql. SQLDataException

构造一个 SQLDataException对象与给定的 reason 。

SQLDataException(String, String) - Constructor for exception java.sql. SQLDataException

使用给定的 reason和 SQLState构造一个 SQLDataException对象。

SQLDataException(String, String, int) - Constructor for exception java.sql. SQLDataException

构造一个 SQLDataException与给定对象 reason ， SQLState和 vendorCode 。

SQLDataException(String, String, int, Throwable) - Constructor for exception java.sql. SQLDataException

构造一个 SQLDataException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLDataException(String, String, Throwable) - Constructor for exception java.sql. SQLDataException

构造一个 SQLDataException与给定对象 reason ， SQLState和 cause 。

SQLDataException(String, Throwable) - Constructor for exception java.sql. SQLDataException

构造一个 SQLDataException对象与一个给定的 reason和 cause 。

SQLDataException(Throwable) - Constructor for exception java.sql. SQLDataException

使用给定的 cause构造一个 SQLDataException对象。

SQLException - Exception in java.sql

提供有关数据库访问错误或其他错误的信息的异常。

SQLException() - Constructor for exception java.sql. SQLException

构造一个 SQLException对象。

SQLException(String) - Constructor for exception java.sql. SQLException

构造一个 SQLException对象与给定的 reason 。

SQLException(String, String) - Constructor for exception java.sql. SQLException

构造一个 SQLException对象与给定的 reason和 SQLState 。

SQLException(String, String, int) - Constructor for exception java.sql. SQLException

构造一个 SQLException与给定对象 reason ， SQLState和 vendorCode 。

SQLException(String, String, int, Throwable) - Constructor for exception java.sql. SQLException

构造一个 SQLException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLException(String, String, Throwable) - Constructor for exception java.sql. SQLException

构造一个 SQLException与给定对象 reason ， SQLState和 cause 。

SQLException(String, Throwable) - Constructor for exception java.sql. SQLException

使用给定的 reason和 cause构造一个 SQLException对象。

SQLException(Throwable) - Constructor for exception java.sql. SQLException

使用给定的 cause构造一个 SQLException对象。

SQLFeatureNotSupportedException - Exception in java.sql

当SQLState类的值为' 0A '（值为'零'A）时抛出的子类为SQLException 。

SQLFeatureNotSupportedException() - Constructor for exception java.sql. SQLFeatureNotSupportedException

构造一个 SQLFeatureNotSupportedException对象。

SQLFeatureNotSupportedException(String) - Constructor for exception java.sql. SQLFeatureNotSupportedException

使用给定的 reason构造一个 SQLFeatureNotSupportedException对象。

SQLFeatureNotSupportedException(String, String) - Constructor for exception java.sql. SQLFeatureNotSupportedException

使用给定的 reason和 SQLState构造一个 SQLFeatureNotSupportedException对象。

SQLFeatureNotSupportedException(String, String, int) - Constructor for exception java.sql. SQLFeatureNotSupportedException

构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState和 vendorCode 。

SQLFeatureNotSupportedException(String, String, int, Throwable) - Constructor for exception java.sql. SQLFeatureNotSupportedException

构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLFeatureNotSupportedException(String, String, Throwable) - Constructor for exception java.sql. SQLFeatureNotSupportedException

构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState和 cause 。

SQLFeatureNotSupportedException(String, Throwable) - Constructor for exception java.sql. SQLFeatureNotSupportedException

使用给定的 reason和 cause构造一个 SQLFeatureNotSupportedException对象。

SQLFeatureNotSupportedException(Throwable) - Constructor for exception java.sql. SQLFeatureNotSupportedException

构造一个 SQLFeatureNotSupportedException对象与给定的 cause 。

SQLInput - Interface in java.sql

包含表示SQL结构化类型或SQL不同类型实例的值的流的输入流。

SQLInputImpl - Class in javax.sql.rowset.serial

用于自定义映射用户定义类型（UDT）的输入流。

SQLInputImpl(Object[], Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial. SQLInputImpl

创建一个 SQLInputImpl对象，该对象使用给定的属性数组和给定的类型映射进行初始化。

SQLIntegrityConstraintViolationException - Exception in java.sql

当SQLState类的值为“ 23 ”时，或在供应商指定的条件下，抛出SQLException的子类。

SQLIntegrityConstraintViolationException() - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

构造一个 SQLIntegrityConstraintViolationException对象。

SQLIntegrityConstraintViolationException(String) - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

构造一个 SQLIntegrityConstraintViolationException与给定的 reason 。

SQLIntegrityConstraintViolationException(String, String) - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

使用给定的 reason和 SQLState构造一个 SQLIntegrityConstraintViolationException对象。

SQLIntegrityConstraintViolationException(String, String, int) - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState和 vendorCode 。

SQLIntegrityConstraintViolationException(String, String, int, Throwable) - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLIntegrityConstraintViolationException(String, String, Throwable) - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState和 cause 。

SQLIntegrityConstraintViolationException(String, Throwable) - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

使用给定的 reason和 cause构造一个 SQLIntegrityConstraintViolationException对象。

SQLIntegrityConstraintViolationException(Throwable) - Constructor for exception java.sql. SQLIntegrityConstraintViolationException

使用给定的 cause构造一个 SQLIntegrityConstraintViolationException对象。

SQLInvalidAuthorizationSpecException - Exception in java.sql

当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出的子类为SQLException 。

SQLInvalidAuthorizationSpecException() - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

构造一个 SQLInvalidAuthorizationSpecException对象。

SQLInvalidAuthorizationSpecException(String) - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

构造一个 SQLInvalidAuthorizationSpecException对象与给定的 reason 。

SQLInvalidAuthorizationSpecException(String, String) - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

使用给定的 reason和 SQLState构造一个 SQLInvalidAuthorizationSpecException对象。

SQLInvalidAuthorizationSpecException(String, String, int) - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState和 vendorCode 。

SQLInvalidAuthorizationSpecException(String, String, int, Throwable) - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLInvalidAuthorizationSpecException(String, String, Throwable) - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState和 cause 。

SQLInvalidAuthorizationSpecException(String, Throwable) - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

使用给定的 reason和 cause构造一个 SQLInvalidAuthorizationSpecException对象。

SQLInvalidAuthorizationSpecException(Throwable) - Constructor for exception java.sql. SQLInvalidAuthorizationSpecException

构造一个 SQLInvalidAuthorizationSpecException对象与给定的 cause 。

SQLNonTransientConnectionException - Exception in java.sql

SQLException的子类抛出SQLState类值“ 08 ”，或者在供应商指定的条件下。

SQLNonTransientConnectionException() - Constructor for exception java.sql. SQLNonTransientConnectionException

构造一个 SQLNonTransientConnectionException对象。

SQLNonTransientConnectionException(String) - Constructor for exception java.sql. SQLNonTransientConnectionException

构造一个 SQLNonTransientConnectionException对象与给定的 reason 。

SQLNonTransientConnectionException(String, String) - Constructor for exception java.sql. SQLNonTransientConnectionException

使用给定的 reason和 SQLState构造一个 SQLNonTransientConnectionException对象。

SQLNonTransientConnectionException(String, String, int) - Constructor for exception java.sql. SQLNonTransientConnectionException

构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState和 vendorCode 。

SQLNonTransientConnectionException(String, String, int, Throwable) - Constructor for exception java.sql. SQLNonTransientConnectionException

构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLNonTransientConnectionException(String, String, Throwable) - Constructor for exception java.sql. SQLNonTransientConnectionException

构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState和 cause 。

SQLNonTransientConnectionException(String, Throwable) - Constructor for exception java.sql. SQLNonTransientConnectionException

构造具有给定的 reason和 cause的 SQLTransientException对象。

SQLNonTransientConnectionException(Throwable) - Constructor for exception java.sql. SQLNonTransientConnectionException

构造一个 SQLNonTransientConnectionException对象与给定的 cause 。

SQLNonTransientException - Exception in java.sql

当一个重试相同操作的实例将失败的情况下抛出SQLException的子类，除非修正了原因SQLException 。

SQLNonTransientException() - Constructor for exception java.sql. SQLNonTransientException

构造一个 SQLNonTransientException对象。

SQLNonTransientException(String) - Constructor for exception java.sql. SQLNonTransientException

构造一个 SQLNonTransientException对象与给定的 reason 。

SQLNonTransientException(String, String) - Constructor for exception java.sql. SQLNonTransientException

使用给定的 reason和 SQLState构造一个 SQLNonTransientException对象。

SQLNonTransientException(String, String, int) - Constructor for exception java.sql. SQLNonTransientException

构造一个 SQLNonTransientException与给定对象 reason ， SQLState和 vendorCode 。

SQLNonTransientException(String, String, int, Throwable) - Constructor for exception java.sql. SQLNonTransientException

构造一个 SQLNonTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLNonTransientException(String, String, Throwable) - Constructor for exception java.sql. SQLNonTransientException

构造一个 SQLNonTransientException与给定对象 reason ， SQLState和 cause 。

SQLNonTransientException(String, Throwable) - Constructor for exception java.sql. SQLNonTransientException

使用给定的 reason和 cause构造一个 SQLTransientException对象。

SQLNonTransientException(Throwable) - Constructor for exception java.sql. SQLNonTransientException

构造一个 SQLNonTransientException对象与给定的 cause 。

SQLOutput - Interface in java.sql

用于将用户定义类型的属性写入数据库的输出流。

SQLOutputImpl - Class in javax.sql.rowset.serial

用于将自定义映射的用户定义类型（UDT）的属性写入数据库的输出流。

SQLOutputImpl(Vector<?>, Map<String, ?>) - Constructor for class javax.sql.rowset.serial. SQLOutputImpl

创建一个新的 SQLOutputImpl对象，使用给定的属性向量进行初始化，并输入map。

SQLPermission - Class in java.sql

的量，许可 SecurityManager将检查当运行用的应用程序代码 SecurityManager启用，调用 DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （不建议使用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或 Connection.abort方法。

SQLPermission(String) - Constructor for class java.sql. SQLPermission

使用指定的名称创建一个新的 SQLPermission对象。

SQLPermission(String, String) - Constructor for class java.sql. SQLPermission

创建具有指定名称的新的 SQLPermission对象。

SQLRecoverableException - Exception in java.sql

如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，以前发生故障的操作可能能够成功的子类， 则抛出SQLException 。

SQLRecoverableException() - Constructor for exception java.sql. SQLRecoverableException

构造一个 SQLRecoverableException对象。

SQLRecoverableException(String) - Constructor for exception java.sql. SQLRecoverableException

构造一个 SQLRecoverableException对象与给定的 reason 。

SQLRecoverableException(String, String) - Constructor for exception java.sql. SQLRecoverableException

使用给定的 reason和 SQLState构造一个 SQLRecoverableException对象。

SQLRecoverableException(String, String, int) - Constructor for exception java.sql. SQLRecoverableException

构造一个 SQLRecoverableException与给定对象 reason ， SQLState和 vendorCode 。

SQLRecoverableException(String, String, int, Throwable) - Constructor for exception java.sql. SQLRecoverableException

构造一个 SQLRecoverableException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLRecoverableException(String, String, Throwable) - Constructor for exception java.sql. SQLRecoverableException

构造一个 SQLRecoverableException与给定对象 reason ， SQLState和 cause 。

SQLRecoverableException(String, Throwable) - Constructor for exception java.sql. SQLRecoverableException

使用给定的 reason和 cause构造一个 SQLRecoverableException对象。

SQLRecoverableException(Throwable) - Constructor for exception java.sql. SQLRecoverableException

构造一个 SQLRecoverableException对象与给定的 cause 。

sqlStateSQL - Static variable in interface java.sql. DatabaseMetaData

该方法一个可能的返回值 DatabaseMetaData.getSQLStateType这是用来指示由方法返回的值是否 SQLException.getSQLState是SQLSTATE值。

sqlStateSQL99 - Static variable in interface java.sql. DatabaseMetaData

该方法一个可能的返回值 DatabaseMetaData.getSQLStateType这是用来指示由方法返回的值是否 SQLException.getSQLState是一个SQL99 SQLSTATE值。

sqlStateXOpen - Static variable in interface java.sql. DatabaseMetaData

该方法一个可能的返回值 DatabaseMetaData.getSQLStateType这是用来指示由方法返回的值是否 SQLException.getSQLState是X /打开（现在知道的公开组）SQL CLI SQLSTATE值。

SQLSyntaxErrorException - Exception in java.sql

当SQLState类值为' 42 '时，或在供应商指定的条件下，抛出SQLException的子类。

SQLSyntaxErrorException() - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException对象。

SQLSyntaxErrorException(String) - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException对象与给定的 reason 。

SQLSyntaxErrorException(String, String) - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException对象与给定的 reason和 SQLState 。

SQLSyntaxErrorException(String, String, int) - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState和 vendorCode 。

SQLSyntaxErrorException(String, String, int, Throwable) - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLSyntaxErrorException(String, String, Throwable) - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState和 cause 。

SQLSyntaxErrorException(String, Throwable) - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException对象与给定的 reason和 cause 。

SQLSyntaxErrorException(Throwable) - Constructor for exception java.sql. SQLSyntaxErrorException

构造一个 SQLSyntaxErrorException对象与给定的 cause 。

SQLTimeoutException - Exception in java.sql

的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。

SQLTimeoutException() - Constructor for exception java.sql. SQLTimeoutException

构造一个 SQLTimeoutException对象。

SQLTimeoutException(String) - Constructor for exception java.sql. SQLTimeoutException

构造一个 SQLTimeoutException对象与给定的 reason 。

SQLTimeoutException(String, String) - Constructor for exception java.sql. SQLTimeoutException

使用给定的 reason和 SQLState构造一个 SQLTimeoutException对象。

SQLTimeoutException(String, String, int) - Constructor for exception java.sql. SQLTimeoutException

构造一个 SQLTimeoutException与给定对象 reason ， SQLState和 vendorCode 。

SQLTimeoutException(String, String, int, Throwable) - Constructor for exception java.sql. SQLTimeoutException

构造一个 SQLTimeoutException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTimeoutException(String, String, Throwable) - Constructor for exception java.sql. SQLTimeoutException

构造一个 SQLTimeoutException与给定对象 reason ， SQLState和 cause 。

SQLTimeoutException(String, Throwable) - Constructor for exception java.sql. SQLTimeoutException

使用给定的 reason和 cause构造一个 SQLTimeoutException对象。

SQLTimeoutException(Throwable) - Constructor for exception java.sql. SQLTimeoutException

使用给定的 cause构造一个 SQLTimeoutException对象。

SQLTransactionRollbackException - Exception in java.sql

当SQLState类值为“ 40 ”时，或在供应商指定的条件下，抛出SQLException的子类。

SQLTransactionRollbackException() - Constructor for exception java.sql. SQLTransactionRollbackException

构造一个 SQLTransactionRollbackException对象。

SQLTransactionRollbackException(String) - Constructor for exception java.sql. SQLTransactionRollbackException

构造一个 SQLTransactionRollbackException对象与给定的 reason 。

SQLTransactionRollbackException(String, String) - Constructor for exception java.sql. SQLTransactionRollbackException

构造一个 SQLTransactionRollbackException对象与给定的 reason和 SQLState 。

SQLTransactionRollbackException(String, String, int) - Constructor for exception java.sql. SQLTransactionRollbackException

构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState和 vendorCode 。

SQLTransactionRollbackException(String, String, int, Throwable) - Constructor for exception java.sql. SQLTransactionRollbackException

构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTransactionRollbackException(String, String, Throwable) - Constructor for exception java.sql. SQLTransactionRollbackException

构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState和 cause 。

SQLTransactionRollbackException(String, Throwable) - Constructor for exception java.sql. SQLTransactionRollbackException

使用给定的 reason和 cause构造一个 SQLTransactionRollbackException对象。

SQLTransactionRollbackException(Throwable) - Constructor for exception java.sql. SQLTransactionRollbackException

构造一个 SQLTransactionRollbackException对象与给定的 cause 。

SQLTransientConnectionException - Exception in java.sql

SQLState类值为' 08 '的子类为SQLException ，或供应商指定的条件。

SQLTransientConnectionException() - Constructor for exception java.sql. SQLTransientConnectionException

构造一个 SQLTransientConnectionException对象。

SQLTransientConnectionException(String) - Constructor for exception java.sql. SQLTransientConnectionException

使用给定的 reason构造一个 SQLTransientConnectionException对象。

SQLTransientConnectionException(String, String) - Constructor for exception java.sql. SQLTransientConnectionException

构造一个 SQLTransientConnectionException对象与给定的 reason和 SQLState 。

SQLTransientConnectionException(String, String, int) - Constructor for exception java.sql. SQLTransientConnectionException

构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState和 vendorCode 。

SQLTransientConnectionException(String, String, int, Throwable) - Constructor for exception java.sql. SQLTransientConnectionException

构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTransientConnectionException(String, String, Throwable) - Constructor for exception java.sql. SQLTransientConnectionException

构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState和 cause 。

SQLTransientConnectionException(String, Throwable) - Constructor for exception java.sql. SQLTransientConnectionException

构造一个 SQLTransientConnectionException对象与给定的 reason和 cause 。

SQLTransientConnectionException(Throwable) - Constructor for exception java.sql. SQLTransientConnectionException

构造一个 SQLTransientConnectionException对象与给定的 cause 。

SQLTransientException - Exception in java.sql

SQLException的子类在以前失败的操作可能能够在没有应用程序级别功能的任何干预的情况下重试操作时能够成功的情况下抛出。

SQLTransientException() - Constructor for exception java.sql. SQLTransientException

构造一个 SQLTransientException对象。

SQLTransientException(String) - Constructor for exception java.sql. SQLTransientException

使用给定的 reason构造一个 SQLTransientException对象。

SQLTransientException(String, String) - Constructor for exception java.sql. SQLTransientException

使用给定的 reason和 SQLState构造一个 SQLTransientException对象。

SQLTransientException(String, String, int) - Constructor for exception java.sql. SQLTransientException

构造一个 SQLTransientException与给定对象 reason ， SQLState和 vendorCode 。

SQLTransientException(String, String, int, Throwable) - Constructor for exception java.sql. SQLTransientException

构造一个 SQLTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTransientException(String, String, Throwable) - Constructor for exception java.sql. SQLTransientException

构造一个 SQLTransientException与给定对象 reason ， SQLState和 cause 。

SQLTransientException(String, Throwable) - Constructor for exception java.sql. SQLTransientException

构造一个 SQLTransientException对象与给定的 reason和 cause 。

SQLTransientException(Throwable) - Constructor for exception java.sql. SQLTransientException

构造一个 SQLTransientException对象与给定的 cause 。

SQLType - Interface in java.sql

用于标识通用SQL类型（称为JDBC类型或供应商特定数据类型）的对象。

SQLWarning - Exception in java.sql

提供有关数据库访问警告的信息的异常。

SQLWarning() - Constructor for exception java.sql. SQLWarning

构造一个 SQLWarning对象。

SQLWarning(String) - Constructor for exception java.sql. SQLWarning

使用给定的 reason构造一个 SQLWarning对象。

SQLWarning(String, String) - Constructor for exception java.sql. SQLWarning

构造一个 SQLWarning对象与给定的 reason和 SQLState 。

SQLWarning(String, String, int) - Constructor for exception java.sql. SQLWarning

构造一个 SQLWarning与给定对象 reason ， SQLState和 vendorCode 。

SQLWarning(String, String, int, Throwable) - Constructor for exception java.sql. SQLWarning

构造一个 SQLWarning与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLWarning(String, String, Throwable) - Constructor for exception java.sql. SQLWarning

构造一个 SQLWarning与给定对象 reason ， SQLState和 cause 。

SQLWarning(String, Throwable) - Constructor for exception java.sql. SQLWarning

构造一个 SQLWarning对象与给定的 reason和 cause 。

SQLWarning(Throwable) - Constructor for exception java.sql. SQLWarning

构造一个 SQLWarning对象与给定的 cause 。

SQLXML - java.sql. JDBCType

标识通用SQL类型 SQLXML 。

SQLXML - Interface in java.sql

用于SQL XML类型的JavaTM编程语言中的映射。

SQLXML - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 XML 。

sqrt() - Method in class java.math. BigInteger

返回此BigInteger的整数平方根。

sqrt(double) - Static method in class java.lang. Math

返回 double值的正确舍入的正平方根。

sqrt(double) - Static method in class java.lang. StrictMath

返回 double值的正确舍入的正平方根。

sqrt(MathContext) - Method in class java.math. BigDecimal

根据上下文设置返回近似值为 this平方根。

sqrtAndRemainder() - Method in class java.math. BigInteger

返回两个BigIntegers的数组，它们分别包含 s的整数平方根 this及其余数 this - s*s 。

SQUARE - javafx.scene.shape. StrokeLineCap

结束未封闭的子路径和划线段，其中方块投影延伸超出段的末端至等于线宽一半的距离。

squareButton - Variable in class javax.swing.plaf.basic. BasicComboBoxUI

指示组合框按钮是否应该是正方形。

Src - Static variable in class java.awt. AlphaComposite

AlphaComposite实现不透明SRC规则的对象，其alpha为1.0f。

SRC - Static variable in class java.awt. AlphaComposite

源被复制到目的地（Porter-Duff源规则）。

SRC - Static variable in class javax.swing.text.html. HTML.Attribute

属性“src”

SRC_ATOP - javafx.scene.effect. BlendMode

位于底部输入内部的顶部输入的部分与底部输入混合。

SRC_ATOP - Static variable in class java.awt. AlphaComposite

位于目的地内部的源的部分被合成到目的地（Porter-Duff Source Atop Destination rule）上。

SRC_IN - Static variable in class java.awt. AlphaComposite

位于目的地内部的源的部分替换目的地（目的地规则中的波特 - 达夫源）。

SRC_OUT - Static variable in class java.awt. AlphaComposite

位于目的地外部的源的部分取代了目的地（Porter-Duff Source Held Out By Destination规则）。

SRC_OVER - javafx.scene.effect. BlendMode

顶部输入通过底部输入混合。

SRC_OVER - Static variable in class java.awt. AlphaComposite

源在目的地（Porter-Duff Source Over Destination规则）上合成。

SrcAtop - Static variable in class java.awt. AlphaComposite

AlphaComposite对象实现了一个alphaf为1.0f的不透明SRC_ATOP规则。

srccols - Variable in class java.awt.image. ReplicateScaleFilter

一个包含有关像素列的信息的 int数组。

srcHeight - Variable in class java.awt.image. ReplicateScaleFilter

源图像的高度。

SrcIn - Static variable in class java.awt. AlphaComposite

AlphaComposite对象实现的alpha值为1.0f的不透明的SRC_IN规则。

SrcOut - Static variable in class java.awt. AlphaComposite

AlphaComposite对象实现不透明的SRC_OUT规则，alpha为1.0f。

SrcOver - Static variable in class java.awt. AlphaComposite

AlphaComposite对象实现不透明的SRC_OVER规则，alpha为1.0f。

srcrows - Variable in class java.awt.image. ReplicateScaleFilter

一个包含有关像素行的信息的 int数组。

srcWidth - Variable in class java.awt.image. ReplicateScaleFilter

源图像的宽度。

SRGB - java.awt. MultipleGradientPaint.ColorSpaceType

表示颜色插值应发生在sRGB空间中。

sslContext() - Method in class jdk.incubator.http. HttpClient

返回 SSLContext （如果在此客户端上设置了一个）。

sslContext(SSLContext) - Method in class jdk.incubator.http. HttpClient.Builder

设置一个 SSLContext 。

SSLContext - Class in javax.net.ssl

这个类的实例代表一个安全的套接字协议实现，作为安全套接字工厂的工厂，或 SSLEngine 。

SSLContext(SSLContextSpi, Provider, String) - Constructor for class javax.net.ssl. SSLContext

创建一个SSLContext对象。

SSLContextSpi - Class in javax.net.ssl

此类定义了 SSLContext类的 （ SPI ）。

SSLContextSpi() - Constructor for class javax.net.ssl. SSLContextSpi

SSLEngine - Class in javax.net.ssl

一种使用诸如安全套接字层（SSL）或 IETF RFC 2246 "Transport Layer Security" (TLS)协议之类的协议实现安全通信的类，但是是独立于传输的。

SSLEngine() - Constructor for class javax.net.ssl. SSLEngine

SSLEngine构造方法不提供内部会话重用策略的提示。

SSLEngine(String, int) - Constructor for class javax.net.ssl. SSLEngine

构造函数为 SSLEngine 。

SSLEngineResult - Class in javax.net.ssl

由 SSLEngine I / O调用产生的结果状态的封装。

SSLEngineResult(SSLEngineResult.Status, SSLEngineResult.HandshakeStatus, int, int) - Constructor for class javax.net.ssl. SSLEngineResult

初始化此类的新实例。

SSLEngineResult(SSLEngineResult.Status, SSLEngineResult.HandshakeStatus, int, int, long) - Constructor for class javax.net.ssl. SSLEngineResult

初始化此类的新实例。

SSLEngineResult.HandshakeStatus - Enum in javax.net.ssl

一个 SSLEngineResult枚举描述了这个 SSLEngine的当前握手状态。

SSLEngineResult.Status - Enum in javax.net.ssl

一个 SSLEngineResult枚举描述了 SSLEngine操作的总体结果。

SSLException - Exception in javax.net.ssl

表示由SSL子系统检测到的某种错误。

SSLException(String) - Constructor for exception javax.net.ssl. SSLException

构造一个异常报告SSL子系统发现的错误。

SSLException(String, Throwable) - Constructor for exception javax.net.ssl. SSLException

创建一个具有指定的详细信息和原因的 SSLException 。

SSLException(Throwable) - Constructor for exception javax.net.ssl. SSLException

创建 SSLException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

SSLHandshakeException - Exception in javax.net.ssl

表示客户端和服务器无法协商所需的安全级别。

SSLHandshakeException(String) - Constructor for exception javax.net.ssl. SSLHandshakeException

在握手期间构造一个异常报告SSL子系统发现的错误。

SSLKeyException - Exception in javax.net.ssl

报告错误的SSL密钥。

SSLKeyException(String) - Constructor for exception javax.net.ssl. SSLKeyException

构造一个异常报告SSL子系统发现的密钥管理错误。

sslParameters() - Method in class jdk.incubator.http. HttpClient

返回一个Optional其中包含该客户端上的SSLParameters集。

sslParameters() - Method in class jdk.incubator.http. HttpResponse

返回此响应有效的SSLParameters 。

sslParameters(SSLParameters) - Method in class jdk.incubator.http. HttpClient.Builder

设置一个 SSLParameters 。

SSLParameters - Class in javax.net.ssl

封装SSL / TLS / DTLS连接的参数。

SSLParameters() - Constructor for class javax.net.ssl. SSLParameters

构造SSLParameters。

SSLParameters(String[]) - Constructor for class javax.net.ssl. SSLParameters

从指定的密码子数组构造SSLParameters。

SSLParameters(String[], String[]) - Constructor for class javax.net.ssl. SSLParameters

从指定的密码和协议数组构造SSLParameters。

SSLPeerUnverifiedException - Exception in javax.net.ssl

表示对等体的身份尚未验证。

SSLPeerUnverifiedException(String) - Constructor for exception javax.net.ssl. SSLPeerUnverifiedException

构造一个异常，报告SSL对等体的身份未被验证。

SSLPermission - Class in javax.net.ssl

此类用于各种网络权限。

SSLPermission(String) - Constructor for class javax.net.ssl. SSLPermission

创建一个具有指定名称的新SSLPermission。

SSLPermission(String, String) - Constructor for class javax.net.ssl. SSLPermission

创建一个具有指定名称的新SSLPermission对象。

SSLProtocolException - Exception in javax.net.ssl

报告SSL协议操作中的错误。

SSLProtocolException(String) - Constructor for exception javax.net.ssl. SSLProtocolException

构造一个异常报告由SSL子系统检测到的SSL协议错误。

SslRMIClientSocketFactory - Class in javax.rmi.ssl

RMI运行时使用 SslRMIClientSocketFactory实例，以便通过SSL获取RMI调用的客户端套接字。

SslRMIClientSocketFactory() - Constructor for class javax.rmi.ssl. SslRMIClientSocketFactory

创建一个新的 SslRMIClientSocketFactory 。

SslRMIServerSocketFactory - Class in javax.rmi.ssl

一个 SslRMIServerSocketFactory实例由RMI运行时使用，以便通过SSL获得用于RMI调用的服务器套接字。

SslRMIServerSocketFactory() - Constructor for class javax.rmi.ssl. SslRMIServerSocketFactory

创建一个新的 SslRMIServerSocketFactory与默认SSL套接字配置。

SslRMIServerSocketFactory(String[], String[], boolean) - Constructor for class javax.rmi.ssl. SslRMIServerSocketFactory

使用指定的SSL套接字配置创建一个新的 SslRMIServerSocketFactory 。

SslRMIServerSocketFactory(SSLContext, String[], String[], boolean) - Constructor for class javax.rmi.ssl. SslRMIServerSocketFactory

创建一个新的 SslRMIServerSocketFactory与指定的 SSLContext和SSL套接字配置。

SSLServerSocket - Class in javax.net.ssl

该类扩展了 ServerSocket并使用诸如安全套接层（SSL）或传输层安全（TLS）协议之类的协议来提供安全的服务器套接字。

SSLServerSocket() - Constructor for class javax.net.ssl. SSLServerSocket

仅由子类使用。

SSLServerSocket(int) - Constructor for class javax.net.ssl. SSLServerSocket

仅由子类使用。

SSLServerSocket(int, int) - Constructor for class javax.net.ssl. SSLServerSocket

仅由子类使用。

SSLServerSocket(int, int, InetAddress) - Constructor for class javax.net.ssl. SSLServerSocket

仅由子类使用。

SSLServerSocketFactory - Class in javax.net.ssl

SSLServerSocketFactory s创建 SSLServerSocket s。

SSLServerSocketFactory() - Constructor for class javax.net.ssl. SSLServerSocketFactory

构造方法仅由子类使用。

SSLSession - Interface in javax.net.ssl

在SSL中，会话用于描述两个实体之间持续的关系。

SSLSessionBindingEvent - Class in javax.net.ssl

此事件传播到SSLSessionBindingListener。

SSLSessionBindingEvent(SSLSession, String) - Constructor for class javax.net.ssl. SSLSessionBindingEvent

构造一个新的SSLSessionBindingEvent。

SSLSessionBindingListener - Interface in javax.net.ssl

该接口由想要知道何时被绑定或从SSLSession绑定的对象来实现。

SSLSessionContext - Interface in javax.net.ssl

A SSLSessionContext表示与单个实体相关联的一组 SSLSession 。

SSLSocket - Class in javax.net.ssl

此类扩展了 Socket s，并使用诸如“安全套接字层”（SSL）或IETF“传输层安全”（TLS）协议之类的协议来提供安全套接字。

SSLSocket() - Constructor for class javax.net.ssl. SSLSocket

仅由子类使用。

SSLSocket(String, int) - Constructor for class javax.net.ssl. SSLSocket

仅由子类使用。

SSLSocket(String, int, InetAddress, int) - Constructor for class javax.net.ssl. SSLSocket

仅由子类使用。

SSLSocket(InetAddress, int) - Constructor for class javax.net.ssl. SSLSocket

仅由子类使用。

SSLSocket(InetAddress, int, InetAddress, int) - Constructor for class javax.net.ssl. SSLSocket

仅由子类使用。

SSLSocketFactory - Class in javax.net.ssl

SSLSocketFactory s创建 SSLSocket s。

SSLSocketFactory() - Constructor for class javax.net.ssl. SSLSocketFactory

构造方法仅由子类使用。

Stack< E> - Class in java.util

Stack类代表一个先进先出（LIFO）的对象堆栈。

Stack() - Constructor for class java.util. Stack

创建一个空堆栈。

stackDepth() - Method in interface com.sun.jdi. MonitorInfo

返回该拥有线程获取该监视器的堆栈深度。

StackedAreaChart< X, Y> - Class in javafx.scene.chart

StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。

StackedAreaChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. StackedAreaChart

用给定轴构建新的区域图

StackedAreaChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>) - Constructor for class javafx.scene.chart. StackedAreaChart

使用给定的轴和数据构建新的区域图。

StackedBarChart< X, Y> - Class in javafx.scene.chart

StackedBarChart是一个变化BarChart ，它绘制一个指示类别的数据值的条。

StackedBarChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. StackedBarChart

使用给定的轴构建一个新的StackedBarChart。

StackedBarChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>) - Constructor for class javafx.scene.chart. StackedBarChart

使用给定的轴和数据构造一个新的StackedBarChart。

StackedBarChart(Axis<X>, Axis<Y>, ObservableList<XYChart.Series<X, Y>>, double) - Constructor for class javafx.scene.chart. StackedBarChart

使用给定的轴和数据构造一个新的StackedBarChart。

StackFrame - Interface in com.sun.jdi

线程调用堆栈上的一种方法调用的状态。

StackOverflowError - Error in java.lang

当堆栈溢出发生时抛出一个应用程序递归太深。

StackOverflowError() - Constructor for error java.lang. StackOverflowError

构造一个没有详细消息的 StackOverflowError 。

StackOverflowError(String) - Constructor for error java.lang. StackOverflowError

构造具有指定详细消息的 StackOverflowError 。

StackPane - Class in javafx.scene.layout

StackPane将它的孩子放在一个靠前的堆叠中。

StackPane() - Constructor for class javafx.scene.layout. StackPane

使用默认CENTER对齐方式创建StackPane布局。

StackPane(Node...) - Constructor for class javafx.scene.layout. StackPane

使用默认CENTER对齐方式创建StackPane布局。

StackTraceElement - Class in java.lang

堆栈跟踪中的元素，由 Throwable.getStackTrace()返回。

StackTraceElement(String, String, String, int) - Constructor for class java.lang. StackTraceElement

创建表示指定执行点的堆栈跟踪元素。

StackTraceElement(String, String, String, String, String, String, int) - Constructor for class java.lang. StackTraceElement

创建表示指定执行点的堆栈跟踪元素。

StackWalker - Class in java.lang

堆栈步行者。

StackWalker.Option - Enum in java.lang

堆栈步行选项配置stack frame获取的信息由一个StackWalker 。

StackWalker.StackFrame - Interface in java.lang

一个StackFrame对象表示由StackWalker返回的方法调用。

Stage - Class in javafx.stage

JavaFX Stage类是顶级的JavaFX容器。

Stage() - Constructor for class javafx.stage. Stage

创建一个新的装饰实例 Stage 。

Stage(StageStyle) - Constructor for class javafx.stage. Stage

创建一个新的实例 Stage 。

StageStyle - Enum in javafx.stage

该枚举定义了 Stage的可能样式。

STALLED - javafx.scene.media. MediaPlayer.Status

数据进入缓冲区的播放器的状态已经放慢或停止，并且播放缓冲区没有足够的数据来继续播放。

StampedLock - Class in java.util.concurrent.locks

一种基于能力的锁，具有三种模式用于控制读/写访问。

StampedLock() - Constructor for class java.util.concurrent.locks. StampedLock

创建一个新的锁，最初处于未锁定状态。

STANDALONE - Static variable in class javax.xml.transform. OutputKeys

standalone =“yes”| “没有”。

standaloneSet() - Method in interface javax.xml.stream.events. StartDocument

如果在文档的编码声明中设置了独立属性，则返回true。

standaloneSet() - Method in class javax.xml.stream.util. StreamReaderDelegate

standaloneSet() - Method in interface javax.xml.stream. XMLStreamReader

检查文档中是否设置了独立的

Standard - Class in com.sun.tools.doclets.standard

不推荐用于删除：此API元素将在以后的版本中被删除。
该文件已被替换， StandardDoclet取代。

Standard() - Constructor for class com.sun.tools.doclets.standard. Standard

已过时。

STANDARD - java.time.zone. ZoneOffsetTransitionRule.TimeDefinition

本地日期时间以标准偏移量表示。

STANDARD - jdk.javadoc.doclet. Doclet.Option.Kind

一个标准选项

STANDARD - Static variable in class java.awt.font. GlyphMetrics

表示表示单个标准字符的字形。

STANDARD - Static variable in class java.time.format. DecimalStyle

非本地化十进制风格符号的标准集。

STANDARD - Static variable in class javax.print.attribute.standard. JobSheets

打印一个或多个站点特定的标准作业单。 例如，打印单个起始页，或者打印起始和结束纸张。

STANDARD_INPUT_TYPE - Static variable in class javax.imageio.spi. ImageReaderSpi

已过时。
而不是使用这个字段，直接创建等效的数组{ ImageInputStream.class } 。

STANDARD_OUTPUT_TYPE - Static variable in class javax.imageio.spi. ImageWriterSpi

已过时。
而不是使用这个字段，直接创建等效的数组{ ImageOutputStream.class } 。

STANDARD_TIME - Static variable in class java.util. SimpleTimeZone

作为标准时间指定的开始或结束时间模式的常数。

StandardCharsets - Class in java.nio.charset

常规定义的标准Charsets 。

StandardConstants - Class in javax.net.ssl

标准常数定义

StandardCopyOption - Enum in java.nio.file

定义标准复制选项。

StandardDoclet - Class in jdk.javadoc.doclet

该doclet为指定的模块，包和类型生成HTML格式的文档。

StandardDoclet() - Constructor for class jdk.javadoc.doclet. StandardDoclet

StandardEmitterMBean - Class in javax.management

一个MBean，其管理接口由Java接口上的反射决定，并发出通知。

StandardEmitterMBean(Class<?>, boolean, NotificationEmitter) - Constructor for class javax.management. StandardEmitterMBean

制作一个MBean，其管理界面由 mbeanInterface指定，通知由给定的 NotificationEmitter处理。

StandardEmitterMBean(Class<?>, NotificationEmitter) - Constructor for class javax.management. StandardEmitterMBean

制作一个MBean，其管理界面由 mbeanInterface指定，通知由给定的 NotificationEmitter处理。

StandardEmitterMBean(T, Class<T>, boolean, NotificationEmitter) - Constructor for class javax.management. StandardEmitterMBean

制作一个MBean，其管理界面由 mbeanInterface指定，给定的实现和通知由给定的 NotificationEmitter处理。

StandardEmitterMBean(T, Class<T>, NotificationEmitter) - Constructor for class javax.management. StandardEmitterMBean

制作一个MBean，其管理界面由 mbeanInterface指定，给定的实现和通知由给定的 NotificationEmitter处理。

standardFormatSupported - Variable in class javax.imageio.metadata. IIOMetadata

一个布尔值，指示具体子类是否支持通过构造函数设置的标准元数据格式。

StandardJavaFileManager - Interface in javax.tools

文件管理器基于java.io.File和java.nio.file.Path 。

StandardJavaFileManager.PathFactory - Interface in javax.tools

从字符串创建 Path对象的工厂。

StandardLocation - Enum in javax.tools

文件对象的标准位置。

StandardMBean - Class in javax.management

一个MBean，其管理界面由Java接口上的反射决定。

StandardMBean(Class<?>) - Constructor for class javax.management. StandardMBean

做一个DynamicMBean的出 这一点 ，使用指定的 mbeanInterface类。

StandardMBean(Class<?>, boolean) - Constructor for class javax.management. StandardMBean

做一个DynamicMBean的出 这一点 ，使用指定的 mbeanInterface类，并选择所产生的MBean是一个MXBean。

StandardMBean(T, Class<T>) - Constructor for class javax.management. StandardMBean

使用指定的 mbeanInterface类，从对象 实现中创建一个DynamicMBean。

StandardMBean(T, Class<T>, boolean) - Constructor for class javax.management. StandardMBean

使用指定的 mbeanInterface类，并选择生成的MBean是否为MXBean，从对象 实现中创建一个DynamicMBean。

standardMetadataFormatName - Static variable in class javax.imageio.metadata. IIOMetadataFormatImpl

A String常量包含标准格式名称， "javax_imageio_1.0" 。

StandardNamespace - Enum in jdk.dynalink

Dynalink定义的标准命名空间的枚举。

StandardOpenOption - Enum in java.nio.file

定义标准的开放选项。

StandardOperation - Enum in jdk.dynalink

定义标准动态操作。

StandardProtocolFamily - Enum in java.net

定义通信协议的标准系列。

StandardSocketOptions - Class in java.net

定义 标准套接字选项。

StandardWatchEventKinds - Class in java.nio.file

定义 标准事件种类。

STANDBY - Static variable in class javax.swing.text.html. HTML.Attribute

属性“待机”

STAPLE - Static variable in class javax.print.attribute.standard. Finishings

用一个或多个订书钉将文档绑定。

STAPLE_BOTTOM_LEFT - Static variable in class javax.print.attribute.standard. Finishings

用左下角的一个或多个钉书钉文档。

STAPLE_BOTTOM_RIGHT - Static variable in class javax.print.attribute.standard. Finishings

用一个或多个订书钉将文档绑定在右下角。

STAPLE_DUAL_BOTTOM - Static variable in class javax.print.attribute.standard. Finishings

假设有一个肖像文件（见上文），沿着底部边缘的两个订书钉（线迹）绑定文档。

STAPLE_DUAL_LEFT - Static variable in class javax.print.attribute.standard. Finishings

假设有一个肖像文件（见上文），沿着左边缘的两个订书钉（线迹）绑定文档。

STAPLE_DUAL_RIGHT - Static variable in class javax.print.attribute.standard. Finishings

假设有肖像文件（见上文），沿着右边缘的两个订书钉（线迹）绑定文档。

STAPLE_DUAL_TOP - Static variable in class javax.print.attribute.standard. Finishings

假设有一个肖像文件（见上文），沿着上边缘的两个订书钉（线迹）绑定文档。

STAPLE_TOP_LEFT - Static variable in class javax.print.attribute.standard. Finishings

用左上角的一个或多个钉书钉文档。

STAPLE_TOP_RIGHT - Static variable in class javax.print.attribute.standard. Finishings

用一个或多个钉在右上角绑定文档。

STAR - javafx.scene.input. KeyCode

常数为 Star键。

start - Variable in class java.awt.geom. Arc2D.Double

电弧的起始角度以度为单位。

start - Variable in class java.awt.geom. Arc2D.Float

电弧的起始角度以度为单位。

start() - Method in class com.sun.net.httpserver. HttpServer

在新的后台线程中启动此服务器。

start() - Method in class java.applet. Applet

已过时。

由浏览器或小程序查看器调用，通知该小程序应该开始执行。

start() - Method in class java.lang. ProcessBuilder

使用此流程构建器的属性启动新进程。

start() - Method in class java.lang. Thread

导致此线程开始执行; Java虚拟机调用此线程的run方法。

start() - Method in class java.util.regex. Matcher

返回上一个匹配的起始索引。

start() - Method in interface java.util.regex. MatchResult

返回匹配的起始索引。

start() - Method in class javafx.animation. AnimationTimer

开始 AnimationTimer 。

start() - Method in class javafx.concurrent. Service

启动此服务。

start() - Method in class javax.management.monitor. CounterMonitor

启动计数器显示器。

start() - Method in class javax.management.monitor. GaugeMonitor

启动量规监视器。

start() - Method in class javax.management.monitor. Monitor

启动显示器。

start() - Method in interface javax.management.monitor. MonitorMBean

启动显示器。

start() - Method in class javax.management.monitor. StringMonitor

启动字符串监视器。

start() - Method in interface javax.management.remote. JMXConnectorServerMBean

激活连接器服务器，即开始侦听客户端连接。

start() - Method in class javax.management.remote.rmi. RMIConnectorServer

激活连接器服务器，即开始侦听客户端连接。

start() - Method in class javax.management.timer. Timer

启动计时器。

start() - Method in interface javax.management.timer. TimerMBean

启动计时器。

start() - Method in interface javax.sound.midi. Sequencer

在当前加载的序列中开始播放MIDI数据。

start() - Method in interface javax.sound.sampled. DataLine

允许线路从事数据I / O。

start() - Method in class javax.swing. Timer

启动 Timer ，使其开始向其监听器发送动作事件。

start(int) - Method in class java.util.regex. Matcher

返回给定组在上一个匹配操作期间捕获的子序列的开始索引。

start(int) - Method in interface java.util.regex. MatchResult

返回在此匹配期间由给定组捕获的子序列的开始索引。

start(RootDoc) - Static method in class com.sun.javadoc. Doclet

已过时。

在此生成文档。

start(RootDoc) - Static method in class com.sun.tools.doclets.standard. Standard

已过时。

start(String) - Method in class java.util.regex. Matcher

返回在上一次匹配操作期间由给定的 named-capturing group捕获的子序列的开始索引。

start(Stage) - Method in class javafx.application. Application

所有JavaFX应用程序的主要入口点。

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.BlockAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.CharacterAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.FormAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.HiddenAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.IsindexAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.ParagraphAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.PreAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.SpecialAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader.TagAction

当此动作被注册的标签类型看到开始标签时调用。

start(Xid, int) - Method in interface javax.transaction.xa. XAResource

代表 xid指定的事务处理开始工作。

START - Static variable in class javax.sound.midi. ShortMessage

开始消息的状态字节（0xFA或250）。

START - Static variable in class javax.sound.sampled. LineEvent.Type

当线路开始进行音频数据的有效输入或输出以响应 start请求时发送的事件类型。

START - Static variable in class javax.swing.text.html. HTML.Attribute

属性“开始”

START_DOCUMENT - Static variable in interface javax.xml.stream. XMLStreamConstants

表示事件是一个起始文件

START_ELEMENT - com.sun.source.doctree. DocTree.Kind

用于表示HTML元素开始的EndElementTree的实例。

START_ELEMENT - Static variable in interface javax.xml.stream. XMLStreamConstants

表示事件是一个起始元素

START_PUNCTUATION - Static variable in class java.lang. Character

Unicode规范中的一般类别“Ps”。

START_TO_END - Static variable in interface org.w3c.dom.ranges. Range

比较开始的边界点 sourceRange结束对哪个范围的边界点 compareBoundaryPoints被调用。

START_TO_START - Static variable in interface org.w3c.dom.ranges. Range

比较起始边界 sourceRange开始调用 compareBoundaryPoints的范围的边界点。

start_value() - Method in interface org.omg.CORBA.portable. ValueInputStream

start_value方法读取嵌套自定义值类型的值类型头，并增加值类型嵌套深度。

start_value(String) - Method in interface org.omg.CORBA.portable. ValueOutputStream

start_value方法结束任何当前打开的块，为嵌套的自定义值类型（具有空代码库和指定的存储库ID）写入值类型头，并增加值类型嵌套深度。

startAngleProperty() - Method in class javafx.scene.chart. PieChart

开始第一个饼切片的角度

startAngleProperty() - Method in class javafx.scene.shape. Arc

以弧度定义圆弧的起始角度。

startAnimationTimer() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

启动动画线程，必要时创建和初始化它。

startAutoScrolling(int) - Method in class javax.swing.plaf.basic. BasicComboPopup

此受保护方法是实现特定的，应该是私有的。

startCDATA() - Method in class org.xml.sax.ext. DefaultHandler2

startCDATA() - Method in interface org.xml.sax.ext. LexicalHandler

报告CDATA部分的开始。

startCellEditing(EventObject) - Method in class javax.swing. DefaultCellEditor.EditorDelegate

返回true表示编辑已经开始。

startDocument() - Method in interface org.xml.sax. ContentHandler

接收文件开头的通知。

startDocument() - Method in interface org.xml.sax. DocumentHandler

已过时。

接收文件开头的通知。

startDocument() - Method in class org.xml.sax. HandlerBase

已过时。

接收文件开头的通知。

startDocument() - Method in class org.xml.sax.helpers. DefaultHandler

接收文件开头的通知。

startDocument() - Method in class org.xml.sax.helpers. ParserAdapter

适配器实现方法; 不要打电话。

startDocument() - Method in class org.xml.sax.helpers. XMLFilterImpl

过滤开始文档事件。

startDocument() - Method in class org.xml.sax.helpers. XMLReaderAdapter

开始文件事件。

StartDocument - Interface in javax.xml.stream.events

开始文档事件的界面

startDrag(Cursor, Transferable) - Method in class java.awt.dnd. DragGestureEvent

开始拖动操作，给出 Cursor这个拖动操作，而 Transferable表示这个拖动操作的源数据。

startDrag(Cursor, Transferable, DragSourceListener) - Method in class java.awt.dnd. DragGestureEvent

开始拖动给出初始的 Cursor显示， Transferable对象和 DragSourceListener使用。

startDrag(Cursor, Image, Point, Transferable, DragSourceListener) - Method in class java.awt.dnd. DragGestureEvent

启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。

startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener) - Method in class java.awt.dnd. DragSource

开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。

startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener, FlavorMap) - Method in class java.awt.dnd. DragSource

开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。

startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Method in class java.awt.dnd. DragSource

开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。

startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener, FlavorMap) - Method in class java.awt.dnd. DragSource

开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。

startDragAndDrop(TransferMode...) - Method in class javafx.scene. Node

确认一个潜在的拖放手势，在这 Node被承认。

startDragAndDrop(TransferMode...) - Method in class javafx.scene. Scene

确认一个潜在的拖放手势，在这个 Scene被认可。

startDragging() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI

在拖动会话开始之前应该被消息，重置lastDragLocation和dividerSize。

startDTD(String, String, String) - Method in class org.xml.sax.ext. DefaultHandler2

startDTD(String, String, String) - Method in interface org.xml.sax.ext. LexicalHandler

报告DTD声明的开始，如果有的话。

started(TaskEvent) - Method in interface com.sun.source.util. TaskListener

事件开始时调用。

STARTED - javax.swing. SwingWorker.StateValue

SwingWorker为 STARTED调用之前 doInBackground 。

startEdit() - Method in class javafx.scene.control.cell. ChoiceBoxListCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. ChoiceBoxTableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. ChoiceBoxTreeCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. ComboBoxListCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. ComboBoxTableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. ComboBoxTreeCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control. Cell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. TextFieldListCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. TextFieldTableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. TextFieldTreeCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control.cell. TextFieldTreeTableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control. ListCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control. TableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control. TreeCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control. TreeTableCell

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEdit() - Method in class javafx.scene.control. TreeTableRow

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

startEditing(TreePath, MouseEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI

如果有 cellEditor和 shouldSelectCell返回 true将开始编辑节点。

startEditingAtPath(JTree, TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI

选择路径中的最后一个项目并尝试编辑它。

startEditingAtPath(JTree, TreePath) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 startEditingAtPath方法。

startEditingAtPath(JTree, TreePath) - Method in class javax.swing.plaf. TreeUI

选择路径中的最后一个项目并尝试编辑它。

startEditingAtPath(TreePath) - Method in class javax.swing. JTree

选择由指定路径标识的节点，并启动编辑。

startEditingTimer() - Method in class javax.swing.tree. DefaultTreeCellEditor

启动编辑定时器。

startElement(String, String, String, Attributes) - Method in interface org.xml.sax. ContentHandler

接收元素开头的通知。

startElement(String, String, String, Attributes) - Method in class org.xml.sax.helpers. DefaultHandler

接收元素开始的通知。

startElement(String, String, String, Attributes) - Method in class org.xml.sax.helpers. XMLFilterImpl

过滤起始元素事件。

startElement(String, String, String, Attributes) - Method in class org.xml.sax.helpers. XMLReaderAdapter

修改SAX2启动元素事件。

startElement(String, AttributeList) - Method in interface org.xml.sax. DocumentHandler

已过时。

接收元素开头的通知。

startElement(String, AttributeList) - Method in class org.xml.sax. HandlerBase

已过时。

接收元素开始的通知。

startElement(String, AttributeList) - Method in class org.xml.sax.helpers. ParserAdapter

适配器实现方法; 不要打电话。

startElement(Element) - Method in interface org.w3c.dom.ls. LSParserFilter

每个 Element起始标签已被扫描，但处理 Element的其余部分之前，解析器将调用此方法。

StartElement - Interface in javax.xml.stream.events

StartElement接口提供了有关起始元素的信息的访问。

StartElementTree - Interface in com.sun.source.doctree

用于开始HTML元素的树节点。

startEntity(String) - Method in class org.xml.sax.ext. DefaultHandler2

startEntity(String) - Method in interface org.xml.sax.ext. LexicalHandler

报告一些内部和外部XML实体的开始。

startFontTag(String) - Method in class javax.swing.text.html. MinimalHTMLWriter

这不再使用，而是会写出<span>。

startFullDrag() - Method in class javafx.scene. Node

开始一个完整的按下 - 拖动释放手势与该节点作为手势源。

startFullDrag() - Method in class javafx.scene. Scene

开始一个完整的按下 - 拖动释放手势与这个场景作为手势源。

startGrabbing() - Method in class java.awt.image. PixelGrabber

请求PixelGrabber开始获取像素。

startHandshake() - Method in class javax.net.ssl. SSLSocket

在此连接上启动SSL握手。

startIndex - Variable in class javax.accessibility. AccessibleAttributeSequence

文本序列的起始索引。

startIndex - Variable in class javax.accessibility. AccessibleTextSequence

文本序列的起始索引。

startInstant() - Method in interface java.lang. ProcessHandle.Info

返回进程的开始时间。

startListening() - Method in class com.sun.jdi.connect.spi. TransportService

侦听由运输服务选择的地址。

startListening(String) - Method in class com.sun.jdi.connect.spi. TransportService

侦听入站连接的指定地址。

startListening(Map<String, ? extends Connector.Argument>) - Method in interface com.sun.jdi.connect. ListeningConnector

侦听由目标虚拟机发起的一个或多个连接。

startLocalManagementAgent() - Method in class com.sun.tools.attach. VirtualMachine

启动目标虚拟机中的本地JMX管理代理。

startManagementAgent(Properties) - Method in class com.sun.tools.attach. VirtualMachine

启动目标虚拟机中的JMX管理代理。

startMarginProperty() - Method in class javafx.scene.chart. CategoryAxis

轴开始和第一个刻度线之间的余量

startPageProperty() - Method in class javafx.print. PageRange

IntegerProperty表示范围的起始页码。

startPipeline(List<ProcessBuilder>) - Static method in class java.lang. ProcessBuilder

为每个ProcessBuilder启动流程，创建一个由其标准输出流和标准输入流链接的流程。

startPrefixMapping(String, String) - Method in interface org.xml.sax. ContentHandler

开始一个prefix-URI命名空间映射的范围。

startPrefixMapping(String, String) - Method in class org.xml.sax.helpers. DefaultHandler

接收命名空间映射开始的通知。

startPrefixMapping(String, String) - Method in class org.xml.sax.helpers. XMLFilterImpl

过滤起始命名空间前缀映射事件。

startPrefixMapping(String, String) - Method in class org.xml.sax.helpers. XMLReaderAdapter

修改SAX2启动前缀映射事件。

startProduction(ImageConsumer) - Method in class java.awt.image. FilteredImageSource

开始生成已过滤的图像。

startProduction(ImageConsumer) - Method in interface java.awt.image. ImageProducer

将指定的 ImageConsumer对象注册为消费者，并开始立即重建图像数据，然后将其传送给可能已经向生产者注册的消费者和任何其他消费者。

startProduction(ImageConsumer) - Method in class java.awt.image. MemoryImageSource

将ImageConsumer添加到对该图像的数据感兴趣的用户列表中，并通过ImageConsumer界面立即开始传送图像数据。

startProduction(ImageConsumer) - Method in class java.awt.image.renderable. RenderableImageProducer

将ImageConsumer添加到对该图像的数据感兴趣的消费者列表中，并通过ImageConsumer界面立即开始传送图像数据。

startRecording() - Method in interface javax.sound.midi. Sequencer

开始录制和播放MIDI数据。

startsWith(String) - Method in class java.lang. String

测试此字符串是否以指定的前缀开头。

startsWith(String) - Method in interface java.nio.file. Path

测试此路径是否以 Path ，通过转换给定的路径字符串，完全由 startsWith(Path)方法指定的方式 构建 。

startsWith(String, int) - Method in class java.lang. String

测试在指定索引处开始的此字符串的子字符串是否以指定的前缀开头。

startsWith(Path) - Method in interface java.nio.file. Path

测试此路径是否以给定的路径开始。

startsWith(List<Rdn>) - Method in class javax.naming.ldap. LdapName

确定指定的RDN序列是否形成此LDAP名称的前缀。

startsWith(Name) - Method in class javax.naming. CompositeName

确定复合名称是否是此复合名称的前缀。

startsWith(Name) - Method in class javax.naming. CompoundName

确定化合物名称是否是此化合物名称的前缀。

startsWith(Name) - Method in class javax.naming.ldap. LdapName

确定此LDAP名称是否以指定的LDAP名称前缀开头。

startsWith(Name) - Method in interface javax.naming. Name

确定此名称是否以指定的前缀开头。

startTag(Element) - Method in class javax.swing.text.html. HTMLWriter

写出元素的开始标签。

startTag(TagElement) - Method in class javax.swing.text.html.parser. Parser

处理起始标签。

STARTTAG - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于STARTTAG

StartTagType - Static variable in class javax.swing.text. DefaultStyledDocument.ElementSpec

getType的可能值。

startTimeProperty() - Method in class javafx.scene.media. MediaPlayer

媒体应该开始播放的时间偏移，或重复播放时重新启动。

startTimer() - Method in class javax.swing.plaf.basic. BasicTreeUI.ComponentHandler

创建，如果需要，并启动一个计时器，以检查是否需要调整边界大小。

StartTlsRequest - Class in javax.naming.ldap

此类实现了针对StartTLS的LDAPv3扩展请求，如 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security中定义的 。StartTLS的对象标识符为1.3.6.1.4.1.1466.20037，未定义扩展请求值。

StartTlsRequest() - Constructor for class javax.naming.ldap. StartTlsRequest

构建一个StartTLS扩展请求。

StartTlsResponse - Class in javax.naming.ldap

此类实现了针对StartTLS的LDAPv3扩展响应，如 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security所定义 。StartTLS的对象标识符为1.3.6.1.4.1.1466.20037，并且未定义扩展响应值。

StartTlsResponse() - Constructor for class javax.naming.ldap. StartTlsResponse

构建一个StartTLS扩展响应。

startup(Runnable) - Static method in class javafx.application. Platform

此方法启动JavaFX运行时。

startXProperty() - Method in class javafx.scene.shape. CubicCurve

定义三次曲线段起始点的X坐标。

startXProperty() - Method in class javafx.scene.shape. Line

线段起始点的X坐标。

startXProperty() - Method in class javafx.scene.shape. QuadCurve

定义二次曲线段起始点的X坐标。

startYProperty() - Method in class javafx.scene.shape. CubicCurve

定义三次曲线段起始点的Y坐标。

startYProperty() - Method in class javafx.scene.shape. Line

线段起始点的Y坐标。

startYProperty() - Method in class javafx.scene.shape. QuadCurve

定义二次曲线段起始点的Y坐标。

state - Variable in class java.security. Signature

此签名对象的当前状态。

state() - Method in interface org.omg.PortableInterceptor. IORInfoOperations

返回刚刚创建的对象适配器的适配器状态，并正在运行IOR拦截器。

State< T extends JComponent> - Class in javax.swing.plaf.nimbus

代表Nimbus内置或定制的状态。

State - Class in org.omg.PortableServer.POAManagerPackage

指定POAManager的状态

State(int) - Constructor for class org.omg.PortableServer.POAManagerPackage. State

State(String) - Constructor for class javax.swing.plaf.nimbus. State

创建一个新的自定义状态。

STATE_FACTORIES - Static variable in interface javax.naming. Context

用于指定要使用的状态工厂列表的环境属性的名称的常量。

stateChanged(ChangeEvent) - Method in class javax.swing. AbstractButton.ButtonChangeListener

stateChanged(ChangeEvent) - Method in interface javax.swing.event. ChangeListener

当侦听器的目标已更改其状态时调用。

stateChanged(ChangeEvent) - Method in class javax.swing. JMenuItem.AccessibleJMenuItem

支持更改侦听器界面并触发属性更改。

stateChanged(ChangeEvent) - Method in class javax.swing. JScrollPane.AccessibleJScrollPane

当侦听器的目标已更改其状态时调用。

stateChanged(ChangeEvent) - Method in class javax.swing. JSpinner.AccessibleJSpinner

当侦听器的目标已更改其状态时调用。

stateChanged(ChangeEvent) - Method in class javax.swing. JSpinner.DefaultEditor

当微调框的模型状态发生变化时，将调用此方法。

stateChanged(ChangeEvent) - Method in class javax.swing. JTabbedPane.AccessibleJTabbedPane

stateChanged(ChangeEvent) - Method in class javax.swing. JTabbedPane.ModelListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicButtonListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicMenuUI.ChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI.ChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI.ModelListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI.HSBChangeListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI.ViewportChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI.VSBChangeListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicSliderUI.ChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI.TabSelectionHandler

stateChanged(ChangeEvent) - Method in class javax.swing. ProgressMonitor.AccessibleProgressMonitor

当侦听器的目标已更改其状态时调用。

StateChangeNotification(Preloader.StateChangeNotification.Type) - Constructor for class javafx.application. Preloader.StateChangeNotification

构造指定类型的StateChangeNotification。

StateChangeNotification(Preloader.StateChangeNotification.Type, Application) - Constructor for class javafx.application. Preloader.StateChangeNotification

为指定的应用程序构造指定类型的StateChangeNotification。

StateEdit - Class in javax.swing.undo

StateEdit是更改状态的对象的一般编辑。

StateEdit(StateEditable) - Constructor for class javax.swing.undo. StateEdit

创建并返回一个新的StateEdit。

StateEdit(StateEditable, String) - Constructor for class javax.swing.undo. StateEdit

创建并返回一个新的StateEdit与演示名称。

StateEditable - Interface in javax.swing.undo

StateEditable定义了可以通过StateEdit使其状态撤消/重做的对象的接口。

StateFactory - Interface in javax.naming.spi

该接口表示用于获取绑定对象的状态的工厂。

stateMask - Variable in class javax.swing. DefaultButtonModel

该位掩码用于存储按钮的状态。

stateMatches(Styleable, Set<PseudoClass>) - Method in class javafx.css. CompoundSelector

stateMatches(Styleable, Set<PseudoClass>) - Method in class javafx.css. Selector

确定节点及其父节点的当前状态是否与此选择器定义的伪类（如果有）匹配。

stateMatches(Styleable, Set<PseudoClass>) - Method in class javafx.css. SimpleSelector

Statement - Class in java.beans

一个 Statement对象表示一个原始语句，其中单个方法应用于目标和一组参数 - 如 "a.setFoo(b)" 。

Statement - Interface in java.sql

用于执行静态SQL语句并返回其生成的结果的对象。

Statement(Object, String, Object[]) - Constructor for class java.beans. Statement

为指定的目标对象创建一个新的Statement对象，以调用由名称和参数数组指定的方法。

STATEMENT - com.sun.source.tree. LambdaExpressionTree.BodyKind

枚举常数用于语句lambdas

STATEMENT - jdk.jshell. Snippet.Kind

一份声明。

STATEMENT - Static variable in class java.awt. PageAttributes.MediaType

INVOICE的别名。

STATEMENT_SUBKIND - jdk.jshell. Snippet.SubKind

一份声明。

statementClosed(StatementEvent) - Method in interface javax.sql. StatementEventListener

当驱动程序检测到某个 PreparedStatement已关闭时，驱动程序会在连接上注册的所有 StatementEventListener s上调用此方法。

statementErrorOccurred(StatementEvent) - Method in interface javax.sql. StatementEventListener

驱动程序在连接上注册的所有 StatementEventListener都调用此方法，当它检测到 PreparedStatement无效时。

StatementEvent - Class in javax.sql

A StatementEvent发送到所有 StatementEventListener ，其中注册了一个 PooledConnection 。

StatementEvent(PooledConnection, PreparedStatement) - Constructor for class javax.sql. StatementEvent

构造一个 StatementEvent与指定的 PooledConnection和 PreparedStatement 。

StatementEvent(PooledConnection, PreparedStatement, SQLException) - Constructor for class javax.sql. StatementEvent

构造一个 StatementEvent具有指定 PooledConnection ， PreparedStatement和 SQLException

StatementEventListener - Interface in javax.sql

注册在“声明”池中的PreparedStatements上发生的事件的通知对象。

StatementSnippet - Class in jdk.jshell

一段语句的片段

StatementTree - Interface in com.sun.source.tree

用作不同类型语句的基类的树节点。

StatementTree - Interface in jdk.nashorn.api.tree

用作不同类型语句的基类的树节点。

stateProperty() - Method in class javafx.concurrent. Service

stateProperty() - Method in class javafx.concurrent. Task

stateProperty() - Method in interface javafx.concurrent. Worker

获取表示当前状态的ReadOnlyObjectProperty。

states - Variable in class javax.accessibility. AccessibleStateSet

Vector每个条目代表 AccessibleState 。

STATIC - java.lang.module. ModuleDescriptor.Requires.Modifier

在编译期间，依赖关系在静态阶段是强制性的，但在执行期间在动态阶段是可选的。

STATIC - javax.lang.model.element. Modifier

修饰词 static

STATIC - Static variable in class java.lang.reflect. Modifier

int值代表 static修饰符。

STATIC_IMPORT_ON_DEMAND_SUBKIND - jdk.jshell. Snippet.SubKind

静态导入点播声明。

STATIC_INIT - javax.lang.model.element. ElementKind

静态初始化程序。

StaticClass - Class in jdk.dynalink.beans

允许访问类的静态成员（其静态方法，属性和字段）的对象，以及使用 StandardOperation.NEW操作构建实例的 对象 。

STATICIMAGEDONE - Static variable in interface java.awt.image. ImageConsumer

图像是完整的，没有更多的像素或帧要交付。

staticPermissionsOnly() - Method in class java.security. ProtectionDomain

如果此域仅包含静态权限，并且在许可检查时不检查当前的 Policy ，则返回true。

STATIONARY - javafx.scene.input. TouchPoint.State

触摸点保持按压并静止（不移动）

status() - Method in interface com.sun.jdi. ThreadReference

返回线程的状态。

status() - Method in class java.awt.image. PixelGrabber

返回像素的状态。

status() - Method in class jdk.jshell. SnippetEvent

后状态。

status() - Method in class jdk.net. SocketFlow

返回此SocketFlow的Status值。

status(Snippet) - Method in class jdk.jshell. JShell

返回该片段的状态。

STATUS_BAR - Static variable in class javax.accessibility. AccessibleRole

A STATUS_BAR是可以向用户包含多个状态信息标签的简单组件。

STATUS_CHANGED - Static variable in class javafx.scene.web. WebEvent

当脚本更改状态行文本时，会发生此事件。

STATUS_MEASUREMENT_IN_PROGRESS - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

200：200454545“

STATUS_MEASUREMENT_INTEROPERABILITY - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

200：200454545“

statusAll(boolean) - Method in class java.awt. MediaTracker

计算并返回此媒体跟踪器跟踪的所有媒体状态的按位包含 OR 。

statusCode() - Method in class jdk.incubator.http. HttpResponse

返回此响应的状态代码。

statusID(int, boolean) - Method in class java.awt. MediaTracker

使用该媒体跟踪器跟踪的指定标识符计算并返回所有媒体状态的按位包含 OR 。

statusProperty() - Method in class javafx.animation. Animation

状态为 Animation 。

statusProperty() - Method in class javafx.scene.media. MediaPlayer

MediaPlayer的当前状态。

StAXResult - Class in javax.xml.transform.stax

作为一个持有的XML Result以StAX作家的形式，即

StAXResult(XMLEventWriter) - Constructor for class javax.xml.transform.stax. StAXResult

通过提供XMLEventWriter创建一个新的StAXResult实例。

StAXResult(XMLStreamWriter) - Constructor for class javax.xml.transform.stax. StAXResult

通过提供一个XMLStreamWriter创建一个新的StAXResult实例。

StAXSource - Class in javax.xml.transform.stax

作为StAX读者形式的XML Source的持有人，即

StAXSource(XMLEventReader) - Constructor for class javax.xml.transform.stax. StAXSource

通过提供XMLEventReader创建一个新的StAXSource实例。

StAXSource(XMLStreamReader) - Constructor for class javax.xml.transform.stax. StAXSource

通过提供XMLStreamReader创建一个新的StAXSource实例。

StdACChrominance - Static variable in class javax.imageio.plugins.jpeg. JPEGHuffmanTable

标准AC色度霍夫曼表。

StdACLuminance - Static variable in class javax.imageio.plugins.jpeg. JPEGHuffmanTable

标准AC亮度霍夫曼表。

StdDCChrominance - Static variable in class javax.imageio.plugins.jpeg. JPEGHuffmanTable

标准直流色度霍夫曼表。

StdDCLuminance - Static variable in class javax.imageio.plugins.jpeg. JPEGHuffmanTable

标准直流亮度霍夫曼表。

STEELBLUE - Static variable in class javafx.scene.paint. Color

颜色钢蓝色，RGB值为＃4682B4

STEP_INTO - Static variable in interface com.sun.jdi.request. StepRequest

进入任何新推的帧

STEP_LINE - Static variable in interface com.sun.jdi.request. StepRequest

一步到另一行的下一个位置

STEP_MIN - Static variable in interface com.sun.jdi.request. StepRequest

步骤到下一个可用的位置

STEP_OUT - Static variable in interface com.sun.jdi.request. StepRequest

走出当前框架

STEP_OVER - Static variable in interface com.sun.jdi.request. StepRequest

跨越任何新推的帧

StepEvent - Interface in com.sun.jdi.event

通知目标VM中的步骤完成。

StepRequest - Interface in com.sun.jdi.request

在目标虚拟机中发生步骤时请求通知。

stepRequests() - Method in interface com.sun.jdi.request. EventRequestManager

返回启用和禁用的步骤请求的不可修改的列表。

stillInsideTimerAction() - Constructor for class javax.swing. ToolTipManager.stillInsideTimerAction

stop() - Method in class java.applet. Applet

已过时。

由浏览器或小程序查看器调用，通知该小程序应该停止其执行。

stop() - Method in interface java.applet. AudioClip

已过时。

停止播放此音频剪辑。

stop() - Method in class java.awt.dnd. DropTarget.DropTargetAutoScroller

导致自动滚动停止

stop() - Method in class java.lang. Thread

已过时。
这种方法本质上是不安全的。 使用Thread.stop停止线程会使其解锁所有已锁定的监视器（作为未经检查的ThreadDeath异常在堆栈上传播的自然结果）。 如果先前受这些监视器保护的任何对象处于不一致的状态，则损坏的对象将变得对其他线程可见，可能导致任意行为。 stop许多用途应该由代码替代，只需修改一些变量来指示目标线程应该停止运行。 目标线程应该定期检查此变量，如果变量表示要停止运行，则以有序方式从其运行方法返回。 如果目标线程长时间等待（例如，在条件变量上），则应使用interrupt方法来中断等待。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。

stop() - Method in class java.lang. ThreadGroup

已过时。
这种方法本质上是不安全的。 详见Thread.stop() 。

stop() - Method in class javafx.animation. Animation

停止动画并将播放头重置到其初始位置。

stop() - Method in class javafx.animation. AnimationTimer

停止 AnimationTimer 。

stop() - Method in class javafx.animation. Timeline

停止动画并将播放头重置到其初始位置。

stop() - Method in class javafx.application. Application

当应用程序停止时，调用此方法，并为应用程序退出和销毁资源提供了便利的场所。

stop() - Method in class javafx.scene.media. AudioClip

立即停止这个 AudioClip所有播放。

stop() - Method in class javafx.scene.media. MediaPlayer

停止播放媒体。

stop() - Method in class javax.management.monitor. CounterMonitor

停止计数器显示器。

stop() - Method in class javax.management.monitor. GaugeMonitor

停止仪表监视器。

stop() - Method in class javax.management.monitor. Monitor

停止显示器

stop() - Method in interface javax.management.monitor. MonitorMBean

停止显示器

stop() - Method in class javax.management.monitor. StringMonitor

停止字符串监视器。

stop() - Method in interface javax.management.remote. JMXConnectorServerMBean

停用连接器服务器，即停止侦听客户端连接。

stop() - Method in class javax.management.remote.rmi. RMIConnectorServer

停用连接器服务器，即停止侦听客户端连接。

stop() - Method in class javax.management.timer. Timer

停止定时器

stop() - Method in interface javax.management.timer. TimerMBean

停止定时器

stop() - Method in interface javax.sound.midi. Sequencer

停止录制，如果有效，并播放当前加载的序列（如果有）。

stop() - Method in interface javax.sound.sampled. DataLine

停止线。

stop() - Method in class javax.swing. Timer

停止 Timer ，导致它停止向其监听器发送操作事件。

stop() - Method in class javax.xml.ws. Endpoint

停止发布此端点。

stop() - Method in class jdk.jshell.execution. DirectExecutionControl

中断一个正在运行的调用。

stop() - Method in class jdk.jshell.execution. JdiDefaultExecutionControl

通过操作远程变量并通过JDI发送停止来中断正在运行的远程调用。

stop() - Method in class jdk.jshell.execution. LocalExecutionControl

stop() - Method in class jdk.jshell.execution. RemoteExecutionControl

stop() - Method in class jdk.jshell.execution. StreamingExecutionControl

stop() - Method in class jdk.jshell. JShell

尝试停止当前运行的评估。

stop() - Method in interface jdk.jshell.spi. ExecutionControl

中断一个正在运行的调用。

stop(int) - Method in class com.sun.net.httpserver. HttpServer

通过关闭监听套接字来停止此服务器，并禁止任何新的交换机被处理。

stop(ObjectReference) - Method in interface com.sun.jdi. ThreadReference

停止此线程与异步异常。

stop(Throwable) - Method in class java.lang. Thread

不推荐用于删除：此API元素将在以后的版本中被删除。
该方法最初是为了强制线程停止并抛出一个给定的Throwable作为例外。 它本质上是不安全的（详见Thread.stop() ），此外还可用于生成目标线程未准备处理的异常。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。

Stop - Class in javafx.scene.paint

定义渐变颜色斜坡的一个元素。

Stop(double, Color) - Constructor for class javafx.scene.paint. Stop

创建一个新的Stop实例。

STOP - javafx.scene.input. KeyCode

常数为 Stop键。

STOP - Static variable in class javax.sound.midi. ShortMessage

停止消息的状态字节（0xFC或252）。

STOP - Static variable in class javax.sound.sampled. LineEvent.Type

当线路停止响应于 stop请求的有效输入或输出音频数据时发送的事件类型，或由于媒体的结束已达到时发送。

stopAnimationTimer() - Method in class javax.swing.plaf.basic. BasicProgressBarUI

停止动画线程。

stopAutoScrolling() - Method in class javax.swing.plaf.basic. BasicComboPopup

此受保护方法是实现特定的，应该是私有的。

stopCellEditing() - Method in class javax.swing. AbstractCellEditor

调用 fireEditingStopped并返回true。

stopCellEditing() - Method in interface javax.swing. CellEditor

告诉编辑器停止编辑并接受任何部分编辑的值作为编辑器的值。

stopCellEditing() - Method in class javax.swing. DefaultCellEditor.EditorDelegate

停止编辑并返回true表示编辑已停止。

stopCellEditing() - Method in class javax.swing. DefaultCellEditor

将消息从 CellEditor转发到 delegate 。

stopCellEditing() - Method in class javax.swing.tree. DefaultTreeCellEditor

如果 realEditor允许编辑停止，则 realEditor被删除，并返回true，否则返回false。

StopConverter - Class in javafx.css.converter

从一个大小和一个颜色转换一个停止

stopEditing() - Method in class javax.swing. JTree

结束当前编辑会话。

stopEditing(JTree) - Method in class javax.swing.plaf.basic. BasicTreeUI

停止当前编辑会话。

stopEditing(JTree) - Method in class javax.swing.plaf.multi. MultiTreeUI

在此对象处理的每个UI上调用 stopEditing方法。

stopEditing(JTree) - Method in class javax.swing.plaf. TreeUI

停止当前编辑会话。

stopEditingInCompleteEditing - Variable in class javax.swing.plaf.basic. BasicTreeUI

编辑时设置为false，shouldSelectCell（）返回true表示在编辑之前应选择节点，用于completeEditing。

stopListening(TransportService.ListenKey) - Method in class com.sun.jdi.connect.spi. TransportService

停止监听入站连接。

stopListening(Map<String, ? extends Connector.Argument>) - Method in interface com.sun.jdi.connect. ListeningConnector

取消侦听连接。

STOPPED - javafx.animation. Animation.Status

停止状态。

STOPPED - javafx.scene.media. MediaPlayer.Status

播放停止时播放器的状态。

STOPPED - Static variable in class javax.print.attribute.standard. PrinterState

表示无法处理作业，需要进行干预。

STOPPED_PARTLY - Static variable in class javax.print.attribute.standard. PrinterStateReason

当打印机控制多个输出设备时，这个原因表示一个或多个输出设备被停止。

StoppedException() - Constructor for exception jdk.jshell.spi. ExecutionControl.StoppedException

STOPPING - Static variable in class javax.print.attribute.standard. PrinterStateReason

打印机正在停止设备，并在一段时间内停止。

stopPropagation() - Method in interface org.w3c.dom.events. Event

使用 stopPropagation方法可防止在事件流期间进一步传播事件。

stopRecording() - Method in interface javax.sound.midi. Sequencer

停止录制，如果活动。

stopTimeProperty() - Method in class javafx.scene.media. MediaPlayer

重播时媒体应停止播放或重新启动的时间偏移。

store() - Method in class javax.management.modelmbean. RequiredModelMBean

捕获此MBean实例的当前状态并将其写入持久存储。

store() - Method in interface javax.management. PersistentMBean

捕获此MBean实例的当前状态并将其写入持久存储。

store(OutputStream, char[]) - Method in class java.security. KeyStore

将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。

store(OutputStream, String) - Method in class java.util. Properties

将此属性列表（键和元素对）写入此 Properties表中的格式，以适合于使用 load(InputStream)方法加载到 Properties表中的格式输出流。

store(Writer, String) - Method in class java.util. Properties

将此属性列表（键和元素对）写入此 Properties表格中，以适合使用 load(Reader)方法的格式将输出字符流 写入 。

store(KeyStore.LoadStoreParameter) - Method in class java.security. KeyStore

使用给定的 LoadStoreParameter存储此密钥库。

STORED - Static variable in class java.util.zip. ZipEntry

未压缩条目的压缩方法。

STORED - Static variable in class java.util.zip. ZipOutputStream

未压缩（STORED）条目的压缩方法。

storesLowerCaseIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并将其存储为小写。

storesLowerCaseQuotedIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以小写形式存储。

storesMixedCaseIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以混合大小写存储。

storesMixedCaseQuotedIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写的SQL标识符视为不区分大小写，并以混合大小写存储。

storeState(Hashtable<Object, Object>) - Method in interface javax.swing.undo. StateEditable

收到该消息后，接收方应将任何相关状态置于 状态 。

storeStoreFence() - Static method in class java.lang.invoke. VarHandle

确保栅栏之前的商店在栅栏后不会与商店重新排列。

storesUpperCaseIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写无引号SQL标识符视为不区分大小写，并以大写形式存储。

storesUpperCaseQuotedIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写引用的SQL标识符视为不区分大小写，并以大写形式存储。

storeToXML(OutputStream, String) - Method in class java.util. Properties

发出表示此表中包含的所有属性的XML文档。

storeToXML(OutputStream, String, String) - Method in class java.util. Properties

使用指定的编码发出表示此表中包含的所有属性的XML文档。

strategy - Variable in class javax.swing.text. FlowView

保持流程更新的行为。

stream() - Method in class java.util. BitSet

返回一个索引流，其中 BitSet包含处于置位状态的位。

stream() - Method in interface java.util. Collection

返回一个序列 Stream与此集合作为其来源。

stream() - Method in class java.util.jar. JarFile

返回一个有序的 Stream超过jar文件条目。

stream() - Method in class java.util. Optional

如果存在值，则返回仅包含该值的顺序Stream ，否则返回一个空的Stream 。

stream() - Method in class java.util. OptionalDouble

如果存在值，则返回仅包含该值的顺序DoubleStream ，否则返回空DoubleStream 。

stream() - Method in class java.util. OptionalInt

如果存在值，则返回仅包含该值的顺序IntStream ，否则返回空IntStream 。

stream() - Method in class java.util. OptionalLong

如果存在值，则返回仅包含该值的顺序LongStream ，否则返回空LongStream 。

stream() - Method in class java.util. ServiceLoader

返回一个流，以延迟加载此加载程序服务的可用提供程序。

stream() - Method in class java.util.zip. ZipFile

在ZIP文件条目上返回有序的 Stream 。

stream(double[]) - Static method in class java.util. Arrays

返回具有指定数组的序列DoubleStream作为其源。

stream(double[], int, int) - Static method in class java.util. Arrays

返回指定数组的指定范围作为源的顺序DoubleStream 。

stream(int[]) - Static method in class java.util. Arrays

返回具有指定数组作为源的顺序IntStream 。

stream(int[], int, int) - Static method in class java.util. Arrays

返回指定数组的指定范围作为源的顺序IntStream 。

stream(long[]) - Static method in class java.util. Arrays

返回具有指定数组的序列LongStream作为其源。

stream(long[], int, int) - Static method in class java.util. Arrays

返回指定数组的指定范围作为源的顺序LongStream 。

stream(Supplier<? extends Spliterator<T>>, int, boolean) - Static method in class java.util.stream. StreamSupport

创建一个新的顺序或并行 Stream从 Supplier的 Spliterator 。

stream(Spliterator<T>, boolean) - Static method in class java.util.stream. StreamSupport

创建一个新的串行或并行 Stream从 Spliterator 。

stream(T[]) - Static method in class java.util. Arrays

返回具有指定数组的序列Stream作为其源。

stream(T[], int, int) - Static method in class java.util. Arrays

返回指定数组的指定范围作为源的顺序Stream 。

Stream< T> - Interface in java.util.stream

支持顺序和并行聚合操作的一系列元素。

STREAM_CIPHER - java.security. CryptoPrimitive

对称原语：流密码

STREAM_MAGIC - Static variable in interface java.io. ObjectStreamConstants

写入流标题的魔数。

STREAM_VERSION - Static variable in interface java.io. ObjectStreamConstants

写入流标题的版本号。

Stream.Builder< T> - Interface in java.util.stream

一个可变的构建器为 Stream 。

Streamable - Interface in org.omg.CORBA.portable

所有复杂IDL类型的持有者类的基类。

StreamableValue - Interface in org.omg.CORBA.portable

定义不是自定义封送的所有非盒装IDL值类型的基本类型。

streamBytes() - Method in interface java.io. ObjectInputFilter.FilterInfo

当前消耗的字节数。

StreamCorruptedException - Exception in java.io

当从对象流读取的控制信息违反内部一致性检查时抛出。

StreamCorruptedException() - Constructor for exception java.io. StreamCorruptedException

创建一个StreamCorruptedException并列出抛出的原因。

StreamCorruptedException(String) - Constructor for exception java.io. StreamCorruptedException

创建一个StreamCorruptedException并列出抛出的原因。

StreamDescriptionProperty - Static variable in interface javax.swing.text. Document

用于初始化文档的流的描述的属性名称。

StreamFilter - Interface in javax.xml.stream

此接口声明可以创建过滤XMLStreamReaders的简单过滤器接口

StreamHandler - Class in java.util.logging

基于流的日志记录 Handler 。

StreamHandler() - Constructor for class java.util.logging. StreamHandler

创建一个 StreamHandler ，没有当前的输出流。

StreamHandler(OutputStream, Formatter) - Constructor for class java.util.logging. StreamHandler

创建一个 StreamHandler与给定的 Formatter和输出流。

StreamingExecutionControl - Class in jdk.jshell.execution

ExecutionControl执行引擎SPI的实现， 它将请求传送到执行发生的远程代理。

StreamingExecutionControl(ObjectOutput, ObjectInput) - Constructor for class jdk.jshell.execution. StreamingExecutionControl

创建一个实例。

streamNumber() - Method in class com.sun.nio.sctp. MessageInfo

如果已经接收到消息，则返回接收到消息的流号，否则返回该消息要发送的流号。

streamNumber() - Method in class com.sun.nio.sctp. SendFailedNotification

返回消息传送的流号。

streamNumber(int) - Method in class com.sun.nio.sctp. MessageInfo

设置要发送消息的流号。

streamPos - Variable in class javax.imageio.stream. ImageInputStreamImpl

流内当前读取的位置。

StreamPrintService - Class in javax.print

该类扩展了PrintService ，代表一种以不同格式将数据打印到客户端提供的输出流的打印服务。

StreamPrintService(OutputStream) - Constructor for class javax.print. StreamPrintService

构造一个StreamPrintService对象。

StreamPrintServiceFactory - Class in javax.print

A StreamPrintServiceFactory是StreamPrintService实例的工厂，可以以描述为MIME类型的特定文档格式打印到输出流。

StreamPrintServiceFactory() - Constructor for class javax.print. StreamPrintServiceFactory

StreamReaderDelegate - Class in javax.xml.stream.util

这是派生XMLStreamReader过滤器的基础类此类设计为位于XMLStreamReader和应用程序的XMLStreamReader之间。

StreamReaderDelegate() - Constructor for class javax.xml.stream.util. StreamReaderDelegate

构造一个没有父进程的空过滤器。

StreamReaderDelegate(XMLStreamReader) - Constructor for class javax.xml.stream.util. StreamReaderDelegate

使用指定的父构造一个过滤器。

StreamResult - Class in javax.xml.transform.stream

作为转换结果的持有人，可以是XML，纯文本，HTML或其他形式的标记。

StreamResult() - Constructor for class javax.xml.transform.stream. StreamResult

零参数默认构造函数。

StreamResult(File) - Constructor for class javax.xml.transform.stream. StreamResult

从文件构造一个StreamResult。

StreamResult(OutputStream) - Constructor for class javax.xml.transform.stream. StreamResult

从字节流构造一个StreamResult。

StreamResult(Writer) - Constructor for class javax.xml.transform.stream. StreamResult

从字符流构造一个StreamResult。

StreamResult(String) - Constructor for class javax.xml.transform.stream. StreamResult

从URL构造一个StreamResult。

StreamSource - Class in javax.xml.transform.stream

作为转换的持有人以XML标记流的形式来源。

StreamSource() - Constructor for class javax.xml.transform.stream. StreamSource

零参数默认构造函数。

StreamSource(File) - Constructor for class javax.xml.transform.stream. StreamSource

从文件构造一个StreamSource。

StreamSource(InputStream) - Constructor for class javax.xml.transform.stream. StreamSource

从字节流构造一个StreamSource。

StreamSource(InputStream, String) - Constructor for class javax.xml.transform.stream. StreamSource

从字节流构造一个StreamSource。

StreamSource(Reader) - Constructor for class javax.xml.transform.stream. StreamSource

从字符读取器构造一个StreamSource。

StreamSource(Reader, String) - Constructor for class javax.xml.transform.stream. StreamSource

从字符读取器构造一个StreamSource。

StreamSource(String) - Constructor for class javax.xml.transform.stream. StreamSource

从URL构造一个StreamSource。

StreamSupport - Class in java.util.stream

用于创建和操纵流的低级实用程序方法。

StreamTokenizer - Class in java.io

StreamTokenizer类接收输入流并将其解析为“令牌”，允许一次读取一个令牌。

StreamTokenizer(InputStream) - Constructor for class java.io. StreamTokenizer

已过时。
从JDK版本1.1开始，将输入流标记化的首选方法是将其转换为字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
StreamTokenizer(Reader) - Constructor for class java.io. StreamTokenizer

创建一个解析给定字符流的tokenizer。

STRENGTH - Static variable in class javax.security.sasl. Sasl

指定要使用的密码强度的属性的名称。

STRETCH - javafx.scene.layout. BorderRepeat

图像被拉伸以填满该区域。

strict - Variable in class javax.swing.text.html.parser. Parser

此标志确定解析器是否将严格执行SGML兼容性。

STRICT - java.time.format. ResolverStyle

风格严格地解决日期和时间。

STRICT - Static variable in class java.lang.reflect. Modifier

代表 strictfp修改 int值。

STRICT_EQUAL_TO - jdk.nashorn.api.tree. Tree.Kind

用于实例BinaryTree代表等于至=== 。

STRICT_NOT_EQUAL_TO - jdk.nashorn.api.tree. Tree.Kind

用于实例BinaryTree代表不等于对!== 。

STRICTFP - javax.lang.model.element. Modifier

修饰词 strictfp

StrictMath - Class in java.lang

类 StrictMath包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。

STRIKE - Static variable in class javax.swing.text.html. HTML.Tag

标记<strike>

StrikeThrough - Static variable in class javax.swing.text. StyleConstants

删除线属性的名称。

STRIKETHROUGH - javafx.scene.web. HTMLEditorSkin.Command

STRIKETHROUGH - Static variable in class java.awt.font. TextAttribute

删除线的属性键。

STRIKETHROUGH_ON - Static variable in class java.awt.font. TextAttribute

一个删除线。

strikethroughProperty() - Method in class javafx.scene.text. Text

定义每行文本是否应该有一行。

String - Class in java.lang

String类代表字符串。

String() - Constructor for class java.lang. String

初始化新创建的 String对象，以便它代表一个空字符序列。

String(byte[]) - Constructor for class java.lang. String

通过使用平台的默认字符集解码指定的字节数组来构造新的 String 。

String(byte[], int) - Constructor for class java.lang. String

已过时。
此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过使用Charset ，字符集名称的String构造函数，或者使用平台的默认字符集。

String(byte[], int, int) - Constructor for class java.lang. String

通过使用平台的默认字符集解码指定的字节子阵列来构造新的 String 。

String(byte[], int, int, int) - Constructor for class java.lang. String

已过时。
此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过String构造函数，它们使用Charset ，字符集名称，或者使用平台的默认字符集。

String(byte[], int, int, String) - Constructor for class java.lang. String

通过使用指定的字符集对指定的字节 String进行解码来构造新的 String 。

String(byte[], int, int, Charset) - Constructor for class java.lang. String

构造一个新的String通过使用指定的指定字节子阵列解码charset 。

String(byte[], String) - Constructor for class java.lang. String

构造一个新的String由指定用指定的字节的数组解码charset 。

String(byte[], Charset) - Constructor for class java.lang. String

构造一个新的String由指定用指定的字节的数组解码charset 。

String(char[]) - Constructor for class java.lang. String

分配一个新的 String以便它代表当前包含在字符数组参数中的字符序列。

String(char[], int, int) - Constructor for class java.lang. String

分配一个新的 String ，其中包含字符数组参数的子阵列中的字符。

String(int[], int, int) - Constructor for class java.lang. String

分配一个新的 String ，其中包含 Unicode code point数组参数的子阵列中的 字符 。

String(String) - Constructor for class java.lang. String

初始化新创建的String对象，使其表示与参数相同的字符序列; 换句话说，新创建的字符串是参数字符串的副本。

String(StringBuffer) - Constructor for class java.lang. String

分配一个新的字符串，其中包含当前包含在字符串缓冲区参数中的字符序列。

String(StringBuilder) - Constructor for class java.lang. String

分配一个新的字符串，其中包含当前包含在字符串构建器参数中的字符序列。

STRING - javax.xml.xpath. XPathEvaluationResult.XPathResultType

XPath 1.0字符串数据类型。

STRING - Static variable in class javax.management.openmbean. SimpleType

描述Java类名称为 java.lang.String值的 SimpleType实例。

STRING - Static variable in class javax.xml.xpath. XPathConstants

XPath 1.0字符串数据类型。

STRING(String) - Constructor for class javax.print. DocFlavor.STRING

构造具有给定MIME类型和打印数据表示类名称为 "java.lang.String"的新文档风格。

STRING_LITERAL - com.sun.source.tree. Tree.Kind

用于表示String类型的字符串文字表达式的LiteralTree的实例 。

STRING_LITERAL - jdk.nashorn.api.tree. Tree.Kind

用于表示String类型的字符串文字表达式的LiteralTree的实例 。

STRING_TO_COMPARE_VALUE_DIFFERED - Static variable in class javax.management.monitor. MonitorNotification

通知类型表示观察到的属性与“字符串比较”值不同。

STRING_TO_COMPARE_VALUE_MATCHED - Static variable in class javax.management.monitor. MonitorNotification

通知类型表示观察到的属性与“string to compare”值匹配。

string_to_object(String) - Method in class org.omg.CORBA. ORB

将由方法 object_to_string生成的字符串转换回CORBA对象引用。

STRING_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult

结果是一个字符串定义。

StringBinding - Class in javafx.beans.binding

提供实现27046427923812的String所需的大部分功能的基类。

StringBinding() - Constructor for class javafx.beans.binding. StringBinding

StringBuffer - Class in java.lang

线程安全，可变的字符序列。

StringBuffer() - Constructor for class java.lang. StringBuffer

构造一个没有字符的字符串缓冲区，初始容量为16个字符。

StringBuffer(int) - Constructor for class java.lang. StringBuffer

构造一个没有字符的字符串缓冲区和指定的初始容量。

StringBuffer(CharSequence) - Constructor for class java.lang. StringBuffer

构造一个包含与指定的相同字符的字符串缓冲区 CharSequence 。

StringBuffer(String) - Constructor for class java.lang. StringBuffer

构造一个初始化为指定字符串内容的字符串缓冲区。

StringBufferInputStream - Class in java.io

已过时。
此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。

StringBufferInputStream(String) - Constructor for class java.io. StringBufferInputStream

已过时。

创建一个字符串输入流，以从指定的字符串读取数据。

StringBuilder - Class in java.lang

一个可变的字符序列。

StringBuilder() - Constructor for class java.lang. StringBuilder

构造一个没有字符的字符串构建器，初始容量为16个字符。

StringBuilder(int) - Constructor for class java.lang. StringBuilder

构造一个没有字符的字符串构建器，以及由 capacity参数指定的初始容量。

StringBuilder(CharSequence) - Constructor for class java.lang. StringBuilder

构造一个字符串构建器，其中包含与指定的 CharSequence相同的字符。

StringBuilder(String) - Constructor for class java.lang. StringBuilder

构造一个初始化为指定字符串内容的字符串构建器。

StringCharacterIterator - Class in java.text

StringCharacterIterator实现 CharacterIterator协议为 String 。

StringCharacterIterator(String) - Constructor for class java.text. StringCharacterIterator

构造一个初始索引为0的迭代器。

StringCharacterIterator(String, int) - Constructor for class java.text. StringCharacterIterator

构造具有指定初始索引的迭代器。

StringCharacterIterator(String, int, int, int) - Constructor for class java.text. StringCharacterIterator

在给定字符串的给定范围内构造迭代器，索引设置在指定的位置。

StringConcatException - Exception in java.lang.invoke

当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。

StringConcatException(String) - Constructor for exception java.lang.invoke. StringConcatException

使用消息构造异常

StringConcatException(String, Throwable) - Constructor for exception java.lang.invoke. StringConcatException

使用消息和链接的throwable构造异常

StringConcatFactory - Class in java.lang.invoke

有助于创建String连接方法的方法，可用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。

StringContent - Class in javax.swing.text

AbstractDocument.Content接口的实现是一种强大的强制实现，对于较小的文档和/或调试很有用。

StringContent() - Constructor for class javax.swing.text. StringContent

创建一个新的StringContent对象。

StringContent(int) - Constructor for class javax.swing.text. StringContent

创建一个新的StringContent对象，并指定初始大小。

StringConverter - Class in javafx.css.converter

字符串类型转换嵌入式unicode字符

StringConverter< T> - Class in javafx.util

Converter定义了字符串和对象之间的转换行为。

StringConverter() - Constructor for class javafx.util. StringConverter

StringConverter.SequenceConverter - Class in javafx.css.converter

stringExpression(ObservableValue<?>) - Static method in class javafx.beans.binding. StringExpression

返回一个StringExpression的StringExpression 。

StringExpression - Class in javafx.beans.binding

StringExpression是一个ObservableStringValue，另外还有一个方便的方法来生成流畅的绑定。

StringExpression() - Constructor for class javafx.beans.binding. StringExpression

stringFlavor - Static variable in class java.awt.datatransfer. DataFlavor

代表Java Unicode String类的 DataFlavor ，其中：

StringHolder - Class in org.omg.CORBA

持有人 String 。

StringHolder() - Constructor for class org.omg.CORBA. StringHolder

构造一个新的 StringHolder对象，其 value字段初始化为 null 。

StringHolder(String) - Constructor for class org.omg.CORBA. StringHolder

构造一个新的 StringHolder对象，其 value字段初始化为给定的 String 。

StringIndexOutOfBoundsException - Exception in java.lang

抛出 String方法以指示索引为负或大于字符串的大小。

StringIndexOutOfBoundsException() - Constructor for exception java.lang. StringIndexOutOfBoundsException

构造一个 StringIndexOutOfBoundsException ，没有详细信息。

StringIndexOutOfBoundsException(int) - Constructor for exception java.lang. StringIndexOutOfBoundsException

构造一个新的 StringIndexOutOfBoundsException类，其中包含指示非法索引的参数。

StringIndexOutOfBoundsException(String) - Constructor for exception java.lang. StringIndexOutOfBoundsException

构造具有指定详细消息的 StringIndexOutOfBoundsException 。

StringJoiner - Class in java.util

StringJoiner用于构造由分隔符分隔的字符序列，并且可选地从提供的前缀开始，并以提供的后缀结尾。

StringJoiner(CharSequence) - Constructor for class java.util. StringJoiner

构造一个没有字符的 StringJoiner ，其中没有 prefix或 suffix ，以及所提供的 delimiter的副本。

StringJoiner(CharSequence, CharSequence, CharSequence) - Constructor for class java.util. StringJoiner

构造一个 StringJoiner其中没有字符，使用所提供的 prefix delimiter和 suffix 。

StringMonitor - Class in javax.management.monitor

定义一个监视器MBean，用于观察字符串属性的值。

StringMonitor() - Constructor for class javax.management.monitor. StringMonitor

默认构造函数。

StringMonitorMBean - Interface in javax.management.monitor

暴露字符串监视器MBean的远程管理界面。

StringNameHelper - Class in org.omg.CosNaming.NamingContextExtPackage

StringName是字符串名称，名称组件的数组表示为字符串。

StringNameHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage. StringNameHelper

StringProperty - Class in javafx.beans.property

该类提供了一个包含 String值的Property的完整实现。

StringProperty() - Constructor for class javafx.beans.property. StringProperty

StringPropertyBase - Class in javafx.beans.property

类 StringPropertyBase是包含 String值的属性的基类。

StringPropertyBase() - Constructor for class javafx.beans.property. StringPropertyBase

的构造函数为 StringPropertyBase 。

StringPropertyBase(String) - Constructor for class javafx.beans.property. StringPropertyBase

的构造函数为 StringPropertyBase 。

stringPropertyNames() - Method in class java.util. Properties

从该属性列表中返回一个不可修改的键集，其中键及其对应的值是字符串，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。

StringReader - Class in java.io

一个字符流，其源是一个字符串。

StringReader(String) - Constructor for class java.io. StringReader

创建一个新的字符串阅读器。

StringRefAddr - Class in javax.naming

此类表示通信端点的地址的字符串形式。

StringRefAddr(String, String) - Constructor for class javax.naming. StringRefAddr

使用其地址类型和内容构造一个新的StringRefAddr实例。

StringReference - Interface in com.sun.jdi

来自目标VM的字符串对象。

strings - Variable in class javafx.css. StyleConverter.StringStore

StringSelection - Class in java.awt.datatransfer

A Transferable ，其实现传送 String所需的能力。

StringSelection(String) - Constructor for class java.awt.datatransfer. StringSelection

创建 Transferable能够传送所述指定的 String 。

StringSeqHelper - Class in org.omg.CORBA

一串字符串

StringSeqHelper() - Constructor for class org.omg.CORBA. StringSeqHelper

StringSeqHolder - Class in org.omg.CORBA

一串字符串

StringSeqHolder() - Constructor for class org.omg.CORBA. StringSeqHolder

StringSeqHolder(String[]) - Constructor for class org.omg.CORBA. StringSeqHolder

StringStore() - Constructor for class javafx.css. StyleConverter.StringStore

stringToColor(String) - Method in class javax.swing.text.html. StyleSheet

将颜色串（例如“RED”或“#NNNNNN”）转换为颜色。

StringTokenizer - Class in java.util

字符串tokenizer类允许应用程序将字符串拆分成令牌。

StringTokenizer(String) - Constructor for class java.util. StringTokenizer

为指定的字符串构造一个字符串tokenizer。

StringTokenizer(String, String) - Constructor for class java.util. StringTokenizer

为指定的字符串构造一个字符串tokenizer。

StringTokenizer(String, String, boolean) - Constructor for class java.util. StringTokenizer

为指定的字符串构造一个字符串tokenizer。

stringToValue(String) - Method in class javax.swing. JFormattedTextField.AbstractFormatter

解析 text返回任意的对象。

stringToValue(String) - Method in class javax.swing.text. DefaultFormatter

通过使用String参数的构造函数将String中的传递转换为 getValueClass的实例。

stringToValue(String) - Method in class javax.swing.text. InternationalFormatter

返回 Object的表示 String text 。

stringToValue(String) - Method in class javax.swing.text. MaskFormatter

解析文本，返回字符串 value的相应对象表示 value 。

stringValueAt(ObservableList<String>, int) - Static method in class javafx.beans.binding. Bindings

创建一个新的StringBinding ，其中包含ObservableList在指定位置的元素。

stringValueAt(ObservableList<String>, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的StringBinding ，其中包含指定位置的ObservableList的元素。

stringValueAt(ObservableList<String>, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的StringBinding ，其中包含指定位置的元素ObservableList 。

stringValueAt(ObservableMap<K, String>, ObservableValue<? extends K>) - Static method in class javafx.beans.binding. Bindings

创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。

stringValueAt(ObservableMap<K, String>, K) - Static method in class javafx.beans.binding. Bindings

创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。

StringValueExp - Class in javax.management

表示作为关系约束的参数的字符串。

StringValueExp() - Constructor for class javax.management. StringValueExp

基本构造函数

StringValueExp(String) - Constructor for class javax.management. StringValueExp

创建一个新的 StringValueExp表示给定的字符串。

StringValueHelper - Class in org.omg.CORBA

助手 StringValue 。

StringValueHelper() - Constructor for class org.omg.CORBA. StringValueHelper

stringValueOf(boolean) - Method in interface com.sun.jdi.connect. Connector.BooleanArgument

返回 value参数的字符串表示形式。

stringValueOf(int) - Method in interface com.sun.jdi.connect. Connector.IntegerArgument

返回 value参数的字符串表示形式。

stringWidth(String) - Method in class java.awt. FontMetrics

返回在此 Font显示指定的 String的总进位宽度。

StringWriter - Class in java.io

在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。

StringWriter() - Constructor for class java.io. StringWriter

使用默认的初始字符串缓冲区大小创建一个新的字符串写入器。

StringWriter(int) - Constructor for class java.io. StringWriter

使用指定的初始字符串缓冲区大小创建一个新的字符串写入器。

STRIP - Static variable in interface java.util.jar. Pack200.Packer

字符串“strip”，某些属性的可能值。

stripExtensions() - Method in class java.util. Locale

返回此 Locale的副本，不包括 extensions 。

stripTrailingZeros() - Method in class java.math. BigDecimal

返回一个 BigDecimal ，它在数字上等于此，但从表示中删除任何尾随的零。

stroke() - Method in class javafx.scene.canvas. GraphicsContext

用当前行程画笔来描绘路径。

Stroke - Interface in java.awt

Stroke接口允许一个Graphics2D对象获得Shape的装饰轮廓或轮廓的风格表示的Shape 。

STROKE - Static variable in class java.awt.font. ShapeGraphicAttribute

一个指示形状的键应该用1像素宽的笔划来抚摸。

strokeArc(double, double, double, double, double, double, ArcType) - Method in class javafx.scene.canvas. GraphicsContext

使用当前笔画绘制弧。

StrokeBorder - Class in javax.swing.border

实现任意笔画边框的课程。

StrokeBorder(BasicStroke) - Constructor for class javax.swing.border. StrokeBorder

创建指定的边框 stroke 。

StrokeBorder(BasicStroke, Paint) - Constructor for class javax.swing.border. StrokeBorder

创建指定的 stroke和 paint 。

strokeDashOffsetProperty() - Method in class javafx.scene.shape. Shape

定义在用户坐标中指定的距离，该距离代表破折号模式的偏移量。

strokeLine(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

使用当前笔画绘制线条。

StrokeLineCap - Enum in javafx.scene.shape

定义 Shape的端帽样式。

strokeLineCapProperty() - Method in class javafx.scene.shape. Shape

如此端盖风格 Shape为确定可能端盖风格以下值之一： StrokeLineCap.BUTT ， StrokeLineCap.ROUND ，并 StrokeLineCap.SQUARE 。

StrokeLineJoin - Enum in javafx.scene.shape

定义一个 Shape的线连接样式。

strokeLineJoinProperty() - Method in class javafx.scene.shape. Shape

定义路径段相遇时应用的装饰。

strokeMiterLimitProperty() - Method in class javafx.scene.shape. Shape

定义 StrokeLineJoin.MITER行连接样式的限制。

strokeOval(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

使用当前的行程画笔绘制椭圆形。

strokePolygon(double[], double[], int) - Method in class javafx.scene.canvas. GraphicsContext

使用当前设置的笔画绘制使用给定点绘制多边形。

strokePolyline(double[], double[], int) - Method in class javafx.scene.canvas. GraphicsContext

使用当前设置的stroke paint属性来绘制具有给定点的折线。

strokeProperty() - Method in class javafx.scene.shape. Shape

使用指定的 Paint的设置定义绘制在 Shape轮廓周围的笔画的参数。

strokeRect(double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

使用当前笔画绘制矩形。

strokeRoundRect(double, double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

使用当前笔画绘制一个圆角矩形。

strokeText(String, double, double) - Method in class javafx.scene.canvas. GraphicsContext

使用当前笔画paint属性绘制位置x，y处的给定文本字符串。

strokeText(String, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

用笔画绘制文本，并包含字符串的最大宽度。

StrokeTransition - Class in javafx.animation

这个 Transition创建一个动画，可以改变 duration中的形状的笔触颜色。

StrokeTransition() - Constructor for class javafx.animation. StrokeTransition

构造函数为 StrokeTransition

StrokeTransition(Duration) - Constructor for class javafx.animation. StrokeTransition

构造函数为 StrokeTransition

StrokeTransition(Duration, Color, Color) - Constructor for class javafx.animation. StrokeTransition

构造函数为 StrokeTransition

StrokeTransition(Duration, Shape) - Constructor for class javafx.animation. StrokeTransition

构造函数为 StrokeTransition

StrokeTransition(Duration, Shape, Color, Color) - Constructor for class javafx.animation. StrokeTransition

构造函数为 StrokeTransition

StrokeType - Enum in javafx.scene.shape

定义在Shape节点的边界周围画画的位置。

strokeTypeProperty() - Method in class javafx.scene.shape. Shape

定义将strokeWidth应用于形状边界的方向（内部，中心或外部）。

strokeWidthProperty() - Method in class javafx.scene.shape. Shape

定义方形笔线宽度。

STRONG - com.sun.source.tree. ModuleTree.ModuleKind

强大的模块

STRONG - Static variable in class javax.swing.text.html. HTML.Tag

标签<strong>

Struct - Interface in java.sql

用于SQL结构化类型的Java编程语言中的标准映射。

STRUCT - java.sql. JDBCType

标识通用SQL类型 STRUCT 。

STRUCT - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 STRUCT 。

StructMember - Class in org.omg.CORBA

描述了一种IDL的成员 struct在接口库，包括名称 struct构件，所述的类型 struct构件，和表示的IDL类型的typedef struct构件描述的 struct成员对象。

StructMember() - Constructor for class org.omg.CORBA. StructMember

构造一个默认的 StructMember对象。

StructMember(String, TypeCode, IDLType) - Constructor for class org.omg.CORBA. StructMember

构造一个使用给定值初始化的 StructMember对象。

StructMemberHelper - Class in org.omg.CORBA

助手 StructMember 。

StructMemberHelper() - Constructor for class org.omg.CORBA. StructMemberHelper

Stub - Class in javax.rmi.CORBA

所有RMI-IIOP存根都必须从其继承的基类。

Stub() - Constructor for class javax.rmi.CORBA. Stub

StubDelegate - Interface in javax.rmi.CORBA

支持Stub中的方法实现的委派 。

StubNotFoundException - Exception in java.rmi

如果远程对象导出时无法找到有效的存根类，则抛出 StubNotFoundException 。

StubNotFoundException(String) - Constructor for exception java.rmi. StubNotFoundException

构造具有指定详细消息的 StubNotFoundException 。

StubNotFoundException(String, Exception) - Constructor for exception java.rmi. StubNotFoundException

构造具有指定的详细消息和嵌套异常的 StubNotFoundException 。

style - Variable in class java.awt. Font

这种 Font的样式，传递给构造函数。

Style - Class in javafx.css

风格只是一个规则的选择器和声明。

Style - Interface in javax.swing.text

与文档中元素关联的属性集合。

Style(Selector, Declaration) - Constructor for class javafx.css. Style

STYLE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“风格”

STYLE - Static variable in class javax.swing.text.html. HTML.Tag

标签<style>

STYLE_CLASS_ARROWS_ON_LEFT_HORIZONTAL - Static variable in class javafx.scene.control. Spinner

箭头放置在Spinner的左侧，水平（即左右）指向。

STYLE_CLASS_ARROWS_ON_LEFT_VERTICAL - Static variable in class javafx.scene.control. Spinner

箭头放置在旋钮的左侧，垂直指向（即上下）。

STYLE_CLASS_ARROWS_ON_RIGHT_HORIZONTAL - Static variable in class javafx.scene.control. Spinner

箭头放置在Spinner的右侧，水平（即左右）指向。

STYLE_CLASS_BULLET - Static variable in class javafx.scene.control. Pagination

将类型的数字页面指示符更改为子弹指示器。

STYLE_CLASS_BUTTON - Static variable in class javafx.scene.control. ColorPicker

指定一个Button的样式类就像ColorPicker控件的外观。

STYLE_CLASS_FLOATING - Static variable in class javafx.scene.control. TabPane

TabPane模式将被更改为浮动，允许TabPane与其他控件一起放置。

STYLE_CLASS_SPLIT_ARROWS_HORIZONTAL - Static variable in class javafx.scene.control. Spinner

减量箭头位于微调器的左侧，右侧的增量。

STYLE_CLASS_SPLIT_ARROWS_VERTICAL - Static variable in class javafx.scene.control. Spinner

将箭头放置在旋转器的上方和下方，拉伸以占据整个宽度。

STYLE_CLASS_SPLIT_BUTTON - Static variable in class javafx.scene.control. ColorPicker

指定SplitMenuButton的样式类，如ColorPicker控件的外观。

STYLE_RULE - Static variable in interface org.w3c.dom.css. CSSRule

规则是 CSSStyleRule 。

Styleable - Interface in javafx.css

Styleable包含对象被CSS样式所需的最小界面。

StyleableBooleanProperty - Class in javafx.css

这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。

StyleableBooleanProperty() - Constructor for class javafx.css. StyleableBooleanProperty

的构造函数为 StyleableBooleanProperty 。

StyleableBooleanProperty(boolean) - Constructor for class javafx.css. StyleableBooleanProperty

StyleableBooleanProperty的构造 StyleableBooleanProperty 。

StyleableDoubleProperty - Class in javafx.css

这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。

StyleableDoubleProperty() - Constructor for class javafx.css. StyleableDoubleProperty

StyleableDoubleProperty的构造 StyleableDoubleProperty 。

StyleableDoubleProperty(double) - Constructor for class javafx.css. StyleableDoubleProperty

StyleableDoubleProperty的构造 StyleableDoubleProperty 。

StyleableFloatProperty - Class in javafx.css

这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。

StyleableFloatProperty() - Constructor for class javafx.css. StyleableFloatProperty

的构造函数 StyleableFloatProperty 。

StyleableFloatProperty(float) - Constructor for class javafx.css. StyleableFloatProperty

的构造函数为 StyleableFloatProperty 。

StyleableIntegerProperty - Class in javafx.css

这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。

StyleableIntegerProperty() - Constructor for class javafx.css. StyleableIntegerProperty

的构造函数为 StyleableIntegerProperty 。

StyleableIntegerProperty(int) - Constructor for class javafx.css. StyleableIntegerProperty

的构造函数为 StyleableIntegerProperty 。

StyleableLongProperty - Class in javafx.css

这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。

StyleableLongProperty() - Constructor for class javafx.css. StyleableLongProperty

的构造函数为 StyleableLongProperty 。

StyleableLongProperty(long) - Constructor for class javafx.css. StyleableLongProperty

的构造函数为 StyleableLongProperty 。

StyleableObjectProperty< T> - Class in javafx.css

这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。

StyleableObjectProperty() - Constructor for class javafx.css. StyleableObjectProperty

的构造函数为 StyleableObjectProperty 。

StyleableObjectProperty(T) - Constructor for class javafx.css. StyleableObjectProperty

的构造函数为 StyleableObjectProperty 。

StyleableProperty< T> - Interface in javafx.css

StyleableProperty允许从CSS格式化一个 javafx.beans.property 。

StyleablePropertyFactory< S extends Styleable> - Class in javafx.css

使用相应的CssMetaData创建StyleableProperty实例的方法。

StyleablePropertyFactory(List<CssMetaData<? extends Styleable, ?>>) - Constructor for class javafx.css. StyleablePropertyFactory

构造函数通过父类的父类CssMetaData传递，通常是调用父类的静态方法 getClassCssMetaData() 。

StyleableStringProperty - Class in javafx.css

这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

StyleableStringProperty() - Constructor for class javafx.css. StyleableStringProperty

StyleableStringProperty的构造 StyleableStringProperty 。

StyleableStringProperty(String) - Constructor for class javafx.css. StyleableStringProperty

的构造函数为 StyleableStringProperty 。

styleChanged(Style) - Method in class javax.swing.text. DefaultStyledDocument

当本文档的任何样式发生变化时调用。

StyleClass - Class in javafx.css

StyleClass(String, int) - Constructor for class javafx.css. StyleClass

StyleConstants - Class in javax.swing.text

用于应用于AttributeSet或MutableAttributeSet的 众所周知或常用属性键和方法的集合，以类型安全的方式获取/设置属性。

StyleConstants.CharacterConstants - Class in javax.swing.text

这是有助于字符风格 的众所周知的属性的类型安全枚举。

StyleConstants.ColorConstants - Class in javax.swing.text

这是有助于颜色 的众所周知的属性的类型安全枚举。

StyleConstants.FontConstants - Class in javax.swing.text

这是有助于字体 的众所周知的属性的类型安全枚举。

StyleConstants.ParagraphConstants - Class in javax.swing.text

这是对段落样式有贡献 的众所周知的属性的类型安全枚举。

StyleContext - Class in javax.swing.text

一组风格及其相关资源。

StyleContext() - Constructor for class javax.swing.text. StyleContext

创建一个新的StyleContext对象。

StyleContext.NamedStyle - Class in javax.swing.text

属性集合，通常用于表示字符和段落样式。

StyleContext.SmallAttributeSet - Class in javax.swing.text

该类在数组中保存少量属性。

StyleConverter< F, T> - Class in javafx.css

StyleConverter转换 ParsedValue<F,T>从类型 F键入 T 。

StyleConverter() - Constructor for class javafx.css. StyleConverter

StyleConverter.StringStore - Class in javafx.css

StringStore类

StyledDocument - Interface in javax.swing.text

通用样式文档的界面。

StyledEditorKit - Class in javax.swing.text

这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。

StyledEditorKit() - Constructor for class javax.swing.text. StyledEditorKit

创建用于样式文档的新EditorKit。

StyledEditorKit.AlignmentAction - Class in javax.swing.text

设置段落对齐的动作。

StyledEditorKit.BoldAction - Class in javax.swing.text

用于切换粗体属性的操作。

StyledEditorKit.FontFamilyAction - Class in javax.swing.text

在关联的JEditorPane中设置字体系列的操作。

StyledEditorKit.FontSizeAction - Class in javax.swing.text

在关联的JEditorPane中设置字体大小的操作。

StyledEditorKit.ForegroundAction - Class in javax.swing.text

设置前景色的动作。

StyledEditorKit.ItalicAction - Class in javax.swing.text

切换斜体属性的动作。

StyledEditorKit.StyledTextAction - Class in javax.swing.text

一个假定它被安装在一个带有StyledEditorKit（或子类）的JEditorPane上被触发的动作。

StyledEditorKit.UnderlineAction - Class in javax.swing.text

切换下划线属性的动作。

StyledTextAction(String) - Constructor for class javax.swing.text. StyledEditorKit.StyledTextAction

从字符串操作名称创建一个新的StyledTextAction。

StyleOrigin - Enum in javafx.css

枚举样式表和样式的可能来源或来源。

styleProperty() - Method in class javafx.scene.control. MenuItem

与此特定MenuItem相关联的CSS样式的字符串表示形式。

styleProperty() - Method in class javafx.scene.control. PopupControl

styleProperty() - Method in class javafx.scene.control. Tab

与此选项卡关联的CSS样式字符串。

styleProperty() - Method in class javafx.scene.control. TableColumnBase

与此TableColumnBase实例相关联的CSS样式的字符串表示形式。

styleProperty() - Method in class javafx.scene. Node

与此特定 Node相关联的CSS样式的字符串表示 Node 。

Stylesheet - Class in javafx.css

可以将属性应用于对象树的样式表。

StyleSheet - Class in javax.swing.text.html

支持定义正在渲染的HTML视图的视觉特征。

StyleSheet - Interface in org.w3c.dom.stylesheets

StyleSheet接口是任何类型样式表的抽象基础接口。

StyleSheet() - Constructor for class javax.swing.text.html. StyleSheet

构建样式表

STYLESHEET_CASPIAN - Static variable in class javafx.application. Application

用于“Caspian”主题的用户代理样式表的常量。

STYLESHEET_MODENA - Static variable in class javafx.application. Application

用于“Modena”主题的用户代理样式表的常量。

StyleSheet.BoxPainter - Class in javax.swing.text.html

课程执行CSS格式的一些职责。

StyleSheet.ListPainter - Class in javax.swing.text.html

课程执行CSS列表格式的一些职责。

StyleSheetList - Interface in org.w3c.dom.stylesheets

StyleSheetList接口提供了样式表的有序集合的抽象。

SUB - Static variable in class javax.swing.text.html. HTML.Tag

标签<sub>

SUBCLASS_IMPLEMENTATION_PERMISSION - Static variable in interface java.io. ObjectStreamConstants

启用覆盖readObject和writeObject。

subclasses() - Method in interface com.sun.jdi. ClassType

获取此类的当前加载的直接子类。

subclassOf(ClassDoc) - Method in interface com.sun.javadoc. ClassDoc

已过时。

测试这个类是否是指定类的子类。

subdivide(double[], int, double[], int, double[], int) - Static method in class java.awt.geom. CubicCurve2D

通过（ srcoff + 7）细分由存储在 src阵列中的坐标指定的三次曲线，索引号为 srcoff ，并将所得到的两个细分曲线存储在相应索引处的两个结果数组中。

subdivide(double[], int, double[], int, double[], int) - Static method in class java.awt.geom. QuadCurve2D

将存储在 src数组中的坐标指定的二次曲线细分为索引 srcoff至 srcoff + 5，并将所得到的两个细分曲线存储在相应索引处的两个结果数组中。

subdivide(CubicCurve2D, CubicCurve2D) - Method in class java.awt.geom. CubicCurve2D

细分此三次曲线并将所得到的两个细分曲线存储在左曲线和右曲线参数中。

subdivide(CubicCurve2D, CubicCurve2D, CubicCurve2D) - Static method in class java.awt.geom. CubicCurve2D

细分由 src参数指定的三次曲线，并将生成的两个细分曲线存储到 left和 right曲线参数中。

subdivide(QuadCurve2D, QuadCurve2D) - Method in class java.awt.geom. QuadCurve2D

细分此 QuadCurve2D并将所得的两条细分曲线存储到 left和 right曲线参数中。

subdivide(QuadCurve2D, QuadCurve2D, QuadCurve2D) - Static method in class java.awt.geom. QuadCurve2D

细分由 src参数指定的二次曲线，并将所得到的两条细分曲线存储到 left和 right曲线参数中。

SUBFILE_TYPE_FULL_RESOLUTION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“SubfileType”标签一起使用的值。

SUBFILE_TYPE_REDUCED_RESOLUTION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“SubfileType”标签一起使用的值。

SUBFILE_TYPE_SINGLE_PAGE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“SubfileType”标签一起使用的值。

subinterfaces() - Method in interface com.sun.jdi. InterfaceType

获取当前准备的接口，直接扩展该接口。

subInterfaces() - Method in class java.net. NetworkInterface

获取附加到此网络接口的所有子接口（也称为虚拟接口）的流。

Subject - Class in javax.security.auth

A Subject表示单个实体（例如人）的相关信息的分组。

Subject() - Constructor for class javax.security.auth. Subject

创建一个实例 Subject一个空 Set校长以及公共和私有证书的空集。

Subject(boolean, Set<? extends Principal>, Set<?>, Set<?>) - Constructor for class javax.security.auth. Subject

使用Principals和凭据创建一个 Subject的实例。

SUBJECT_DISTANCE_RANGE_CLOSE_VIEW - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SubjectDistanceRange”标签一起使用的值。

SUBJECT_DISTANCE_RANGE_DISTANT_VIEW - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SubjectDistanceRange”标签一起使用的值。

SUBJECT_DISTANCE_RANGE_MACRO - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SubjectDistanceRange”标签一起使用的值。

SUBJECT_DISTANCE_RANGE_UNKNOWN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

与“SubjectDistanceRange”标签一起使用的值。

SubjectDelegationPermission - Class in javax.management.remote

认证身份所需的权限代表授权身份执行操作。

SubjectDelegationPermission(String) - Constructor for class javax.management.remote. SubjectDelegationPermission

创建一个新的具有指定名称的SubjectDelegationPermission。

SubjectDelegationPermission(String, String) - Constructor for class javax.management.remote. SubjectDelegationPermission

创建一个具有指定名称的新的SubjectDelegationPermission对象。

SubjectDomainCombiner - Class in javax.security.auth

一个 SubjectDomainCombiner与校长更新的ProtectionDomains从 Subject与此相关 SubjectDomainCombiner 。

SubjectDomainCombiner(Subject) - Constructor for class javax.security.auth. SubjectDomainCombiner

将所提供的 Subject与此 SubjectDomainCombiner 。

subkey(Object, SQLType) - Method in interface java.sql. ShardingKeyBuilder

将调用此方法将子项添加到正在构建的Sharding Key对象中。

subKind() - Method in class jdk.jshell. Snippet

返回Snippet.SubKind的片段。

subList(int, int) - Method in class java.util. AbstractList

返回指定的 fromIndex （包括）和 toIndex之间的列表部分的视图。

subList(int, int) - Method in class java.util. ArrayList

返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。

subList(int, int) - Method in class java.util.concurrent. CopyOnWriteArrayList

返回 fromIndex （含）和 toIndex之间的该列表部分的视图。

subList(int, int) - Method in interface java.util. List

返回指定的 fromIndex （含）和 toIndex之间的列表部分的视图。

subList(int, int) - Method in class java.util. Vector

返回此列表之间的fromIndex（包括）和toIndex之间的独占视图。

subList(int, int) - Method in class javafx.beans.binding. ListExpression

subList(int, int) - Method in class javafx.collections. ModifiableObservableListBase

subMap(K, boolean, K, boolean) - Method in interface java.util.concurrent. ConcurrentNavigableMap

subMap(K, boolean, K, boolean) - Method in class java.util.concurrent. ConcurrentSkipListMap

subMap(K, boolean, K, boolean) - Method in interface java.util. NavigableMap

返回此地图部分的视图，其视图范围从 fromKey到 toKey 。

subMap(K, boolean, K, boolean) - Method in class java.util. TreeMap

subMap(K, K) - Method in interface java.util.concurrent. ConcurrentNavigableMap

subMap(K, K) - Method in class java.util.concurrent. ConcurrentSkipListMap

subMap(K, K) - Method in interface java.util. NavigableMap

返回此地图部分的视图，其关键字范围从 fromKey （含）到 toKey ，独占。

subMap(K, K) - Method in interface java.util. SortedMap

返回此地图部分的视图，其关键字范围为 fromKey （含），不包括 toKey 。

subMap(K, K) - Method in class java.util. TreeMap

SUBMENU - javafx.scene. AccessibleAttribute

返回节点的子菜单。

SUBMISSION_INTERRUPTED - Static variable in class javax.print.attribute.standard. JobStateReason

这项工作不是因为一些不可预见的原因而完全提交的。

SubmissionPublisher< T> - Class in java.util.concurrent

A Flow.Publisher ，它向当前订阅者异步发出提交的（非空）项目，直到关闭。

SubmissionPublisher() - Constructor for class java.util.concurrent. SubmissionPublisher

创建一个新的SubmissionPublisher，使用 ForkJoinPool.commonPool()进行异步传递给用户（除非它不支持至少两个并行级别，在这种情况下，创建一个新线程来运行每个任务），最大缓冲容量为 Flow.defaultBufferSize() ，否则方法 onNext中订阅者异常的处理程序。

SubmissionPublisher(Executor, int) - Constructor for class java.util.concurrent. SubmissionPublisher

使用给定的Executor创建一个新的SubmissionPublisher，以便为订户提供异步传递，给定每个订户的最大缓冲区大小，方法 onNext中没有用于订阅者异常的处理程序。

SubmissionPublisher(Executor, int, BiConsumer<? super Flow.Subscriber<? super T>, ? super Throwable>) - Constructor for class java.util.concurrent. SubmissionPublisher

使用给定的Executor创建一个新的SubmissionPublisher，为订户提供异步传递，给定每个订户的最大缓冲区大小，如果非空，则在任何订阅者在方法 onNext中引发异常时调用给定的处理程序。

submit() - Method in interface org.w3c.dom.html. HTMLFormElement

提交表单。

submit(Runnable) - Method in class java.util.concurrent. AbstractExecutorService

submit(Runnable) - Method in interface java.util.concurrent. ExecutorService

提交一个可运行的任务执行，并返回一个表示该任务的未来。

submit(Runnable) - Method in class java.util.concurrent. ForkJoinPool

submit(Runnable) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

submit(Runnable, T) - Method in class java.util.concurrent. AbstractExecutorService

submit(Runnable, T) - Method in interface java.util.concurrent. ExecutorService

提交一个可运行的任务执行，并返回一个表示该任务的未来。

submit(Runnable, T) - Method in class java.util.concurrent. ForkJoinPool

submit(Runnable, T) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

submit(Runnable, V) - Method in interface java.util.concurrent. CompletionService

提交一个可运行的任务执行，并返回一个表示该任务的未来。

submit(Runnable, V) - Method in class java.util.concurrent. ExecutorCompletionService

submit(Callable<T>) - Method in class java.util.concurrent. AbstractExecutorService

submit(Callable<T>) - Method in interface java.util.concurrent. ExecutorService

提交值返回任务以执行，并返回代表任务待处理结果的Future。

submit(Callable<T>) - Method in class java.util.concurrent. ForkJoinPool

submit(Callable<T>) - Method in class java.util.concurrent. ScheduledThreadPoolExecutor

submit(Callable<V>) - Method in interface java.util.concurrent. CompletionService

提交值返回任务以执行，并返回代表任务待处理结果的Future。

submit(Callable<V>) - Method in class java.util.concurrent. ExecutorCompletionService

submit(ForkJoinTask<T>) - Method in class java.util.concurrent. ForkJoinPool

提交一个ForkJoinTask来执行。

submit(T) - Method in class java.util.concurrent. SubmissionPublisher

通过异步调用其 onNext方法将给定项目发布给每个当前用户，阻止不间断，而任何用户的资源不可用。

SUBMIT - Static variable in class javax.swing.text.html. FormView

已过时。
从1.3起，现在的值来自UIManager属性FormView.submitButtonText

submitData(String) - Method in class javax.swing.text.html. FormView

此方法负责提交表单数据。

subpath(int, int) - Method in interface java.nio.file. Path

返回一个相对的 Path ，它是该路径的名称元素的子序列。

subprotocols(String, String...) - Method in interface jdk.incubator.http. WebSocket.Builder

在开放握手期间包括给定子协议的请求。

subsamplingXOffset - Variable in class javax.imageio. IIOParam

在采样之前应用于子采样网格的水平偏移。

subsamplingYOffset - Variable in class javax.imageio. IIOParam

在二次采样之前应用于子采样网格的垂直偏移。

SubScene - Class in javafx.scene

SubScene类是场景图中内容的容器。

SubScene(Parent, double, double) - Constructor for class javafx.scene. SubScene

为特定大小的特定根节点创建一个 SubScene 。

SubScene(Parent, double, double, boolean, SceneAntialiasing) - Constructor for class javafx.scene. SubScene

构造一个由根组成的 SubScene ，其宽度和高度的尺寸指定是否为此场景创建深度缓冲区，并指定是否请求场景抗锯齿。

subscribe(Flow.Subscriber<? super T>) - Method in interface java.util.concurrent. Flow.Publisher

如果可能，添加给定的订阅者。

subscribe(Flow.Subscriber<? super T>) - Method in class java.util.concurrent. SubmissionPublisher

添加给定订阅者，除非已经订阅。

Subscript - Static variable in class javax.swing.text. StyleConstants

下标属性的名称。

subSequence(int, int) - Method in interface java.lang. CharSequence

返回一个 CharSequence ，这是这个序列的一个子序列。

subSequence(int, int) - Method in class java.lang. String

返回一个字符序列，该序列是该序列的子序列。

subSequence(int, int) - Method in class java.lang. StringBuffer

subSequence(int, int) - Method in class java.nio. CharBuffer

创建一个新的字符缓冲区，代表该缓冲区相对于当前位置的指定子序列。

subSequence(int, int) - Method in class javax.swing.text. Segment

返回一个 CharSequence ，这是这个序列的一个子序列。

subSet(E, boolean, E, boolean) - Method in class java.util.concurrent. ConcurrentSkipListSet

subSet(E, boolean, E, boolean) - Method in interface java.util. NavigableSet

返回该集合的部分的视图，其元素的范围从 fromElement到 toElement 。

subSet(E, boolean, E, boolean) - Method in class java.util. TreeSet

subSet(E, E) - Method in class java.util.concurrent. ConcurrentSkipListSet

subSet(E, E) - Method in interface java.util. NavigableSet

返回该集合的部分的视图，其元素的范围从 fromElement （含）到 toElement ，独占。

subSet(E, E) - Method in interface java.util. SortedSet

返回此集合的部分的视图，其元素的范围从 fromElement （包括）到 toElement ，排他。

subSet(E, E) - Method in class java.util. TreeSet

Subset(String) - Constructor for class java.lang. Character.Subset

构造一个新的 Subset实例。

SUBSIZED - Static variable in interface java.util. Spliterator

特征值这标志着从产生的所有Spliterators trySplit()将是既 Spliterator.SIZED和 Spliterator.SUBSIZED 。

substituteColorModel(ColorModel, ColorModel) - Method in class java.awt.image. RGBImageFilter

注册两个ColorModel对象进行替换。

SUBSTITUTION_PERMISSION - Static variable in interface java.io. ObjectStreamConstants

在序列化/反序列化期间可以使一个对象替换为另一个对象。

substring(int) - Method in class java.lang. String

返回一个字符串，该字符串是此字符串的子字符串。

substring(int) - Method in class java.lang. StringBuffer

substring(int, int) - Method in class java.lang. String

返回一个字符串，该字符串是此字符串的子字符串。

substring(int, int) - Method in class java.lang. StringBuffer

substringData(int, int) - Method in interface org.w3c.dom. CharacterData

从节点中提取一系列数据。

SubtitleTrack - Class in javafx.scene.media

A Track包含要覆盖视频轨道的副标题或字幕数据。

subtract(double) - Method in class javafx.beans.binding. DoubleExpression

subtract(double) - Method in class javafx.beans.binding. FloatExpression

subtract(double) - Method in class javafx.beans.binding. IntegerExpression

subtract(double) - Method in class javafx.beans.binding. LongExpression

subtract(double) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的差异。

subtract(double, double) - Method in class javafx.geometry. Point2D

从该点的坐标中减去指定坐标的点。

subtract(double, double, double) - Method in class javafx.geometry. Point3D

从该点的坐标中减去指定坐标的点。

subtract(double, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的DoubleBinding ，计算常数值和ObservableNumberValue的值的差值 。

subtract(float) - Method in class javafx.beans.binding. DoubleExpression

subtract(float) - Method in class javafx.beans.binding. FloatExpression

subtract(float) - Method in class javafx.beans.binding. IntegerExpression

subtract(float) - Method in class javafx.beans.binding. LongExpression

subtract(float) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的NumberBinding ，计算这个NumberExpression和一个恒定值的差异。

subtract(float, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的NumberBinding ，计算一个常数值和ObservableNumberValue的值的差异 。

subtract(int) - Method in class javafx.beans.binding. DoubleExpression

subtract(int) - Method in class javafx.beans.binding. FloatExpression

subtract(int) - Method in class javafx.beans.binding. IntegerExpression

subtract(int) - Method in class javafx.beans.binding. LongExpression

subtract(int) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。

subtract(int, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的NumberBinding ，计算一个常数值和一个ObservableNumberValue的值的差异 。

subtract(long) - Method in class javafx.beans.binding. DoubleExpression

subtract(long) - Method in class javafx.beans.binding. FloatExpression

subtract(long) - Method in class javafx.beans.binding. IntegerExpression

subtract(long) - Method in class javafx.beans.binding. LongExpression

subtract(long) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的NumberBinding ，计算这个NumberExpression的差异和恒定值。

subtract(long, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的NumberBinding ，计算一个常数值和一个ObservableNumberValue的值的差异 。

subtract(Area) - Method in class java.awt.geom. Area

从这个 Area的形状中减去指定的 Area的形状。

subtract(BigDecimal) - Method in class java.math. BigDecimal

返回 BigDecimal ，其值是 (this - subtrahend) ，其标为 max(this.scale(), subtrahend.scale()) 。

subtract(BigDecimal, MathContext) - Method in class java.math. BigDecimal

返回 BigDecimal ，其值是 (this - subtrahend) ，根据上下文设置进行舍入。

subtract(BigInteger) - Method in class java.math. BigInteger

返回值为 (this - val)的BigInteger。

subtract(ObservableNumberValue) - Method in class javafx.beans.binding. DoubleExpression

subtract(ObservableNumberValue) - Method in interface javafx.beans.binding. NumberExpression

创建一个新的NumberBinding ，计算这个NumberExpression和另一个ObservableNumberValue的差异 。

subtract(ObservableNumberValue) - Method in class javafx.beans.binding. NumberExpressionBase

subtract(ObservableNumberValue, double) - Static method in class javafx.beans.binding. Bindings

创建一个新的DoubleBinding ，计算一个ObservableNumberValue的值和一个恒定值的差值。

subtract(ObservableNumberValue, float) - Static method in class javafx.beans.binding. Bindings

创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。

subtract(ObservableNumberValue, int) - Static method in class javafx.beans.binding. Bindings

创建一个新的NumberBinding ，用于计算的值的差异ObservableNumberValue和恒定值。

subtract(ObservableNumberValue, long) - Static method in class javafx.beans.binding. Bindings

创建一个新的NumberBinding ，计算一个ObservableNumberValue的值和一个恒定值的差值。

subtract(ObservableNumberValue, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings

创建一个新的NumberBinding ，计算两个实例的值的差异ObservableNumberValue 。

subtract(Point2D) - Method in class javafx.geometry. Point2D

返回从该点的坐标中减去指定点的坐标的点。

subtract(Point3D) - Method in class javafx.geometry. Point3D

返回从该点的坐标中减去指定点的坐标的点。

subtract(Shape, Shape) - Static method in class javafx.scene.shape. Shape

返回一个新的 Shape ，它是通过从第一个形状中减去指定的第二个形状而创建的。

subtract(Duration) - Method in class javafx.util. Duration

从此实例中减去其他Duration实例以返回一个新的Duration实例。

subtract(Duration) - Method in class javax.xml.datatype. Duration

计算值为 this-rhs的新持续时间。

SUBTRACT - javafx.scene.input. KeyCode

常数为 Subtract键。

SUBTRACT - Static variable in class javax.xml.crypto.dsig.spec. XPathType.Filter

减法滤波操作。

subtractExact(int, int) - Static method in class java.lang. Math

返回参数的差异，如果结果溢出一个 int ，则抛出异常。

subtractExact(int, int) - Static method in class java.lang. StrictMath

返回参数的差异，如果结果溢出一个 int ，则抛出异常。

subtractExact(long, long) - Static method in class java.lang. Math

返回参数的差异，如果结果溢出一个 long ，则抛出异常。

subtractExact(long, long) - Static method in class java.lang. StrictMath

返回参数的差异，如果结果溢出一个 long ，则抛出异常。

subtractFrom(Temporal) - Method in interface java.time.chrono. ChronoPeriod

从指定的时间对象中减去这个时间段。

subtractFrom(Temporal) - Method in class java.time. Duration

从指定的时间对象中减去此持续时间。

subtractFrom(Temporal) - Method in class java.time. Period

从指定的时间对象中减去这个时间段。

subtractFrom(Temporal) - Method in interface java.time.temporal. TemporalAmount

从指定的时间对象中减去此对象。

SUBTREE_SCOPE - Static variable in class javax.naming.directory. SearchControls

搜索根据命名对象的整个子树。

SUBTREE_SCOPE - Static variable in interface javax.naming.event. EventContext

用于表示对由目标命名的对象的子树中的对象的事件感兴趣的常数，包括由目标命名的对象。

SUBWINDOW_OF - Static variable in class javax.accessibility. AccessibleRelation

表示对象是一个或多个对象的子窗口。

SUBWINDOW_OF_PROPERTY - Static variable in class javax.accessibility. AccessibleRelation

表示两个或多个对象之间的 SUBWINDOW_OF关系已更改。

succeeded() - Method in class javafx.concurrent. ScheduledService

对于子类的受保护的便利方法，当服务状态已转换到SUCCEEDED状态时调用。

succeeded() - Method in class javafx.concurrent. Service

对于子类的受保护的便利方法，当服务状态已转换到SUCCEEDED状态时调用。

succeeded() - Method in class javafx.concurrent. Task

每当任务的状态已经转换到SUCCEEDED状态时调用的子类的受保护的便利方法。

SUCCEEDED - javafx.concurrent. Worker.State

表示此Worker已成功完成，并且有一个有效的结果准备从 value属性读取。

Success(HttpPrincipal) - Constructor for class com.sun.net.httpserver. Authenticator.Success

SUCCESS_NO_INFO - Static variable in interface java.sql. Statement

指示批处理语句执行成功但不影响其行数的常量可用的常量。

SUCCESSFUL - Interface in org.omg.PortableInterceptor

org / omg / PortableInterceptor / SUCCESSFUL.java。

SUFFICIENT - Static variable in class javax.security.auth.login. AppConfigurationEntry.LoginModuleControlFlag

足够 LoginModule 。

suffixes - Variable in class javax.imageio.spi. ImageReaderWriterSpi

要从 getFileSuffixes返回的字符串数组，最初为 null 。

sum() - Method in class java.util.concurrent.atomic. DoubleAdder

返回当前总和。

sum() - Method in class java.util.concurrent.atomic. LongAdder

返回当前总和。

sum() - Method in interface java.util.stream. DoubleStream

返回此流中元素的总和。

sum() - Method in interface java.util.stream. IntStream

返回此流中元素的总和。

sum() - Method in interface java.util.stream. LongStream

返回此流中元素的总和。

sum(double, double) - Static method in class java.lang. Double

根据+运算符，将两个 double值一起添加。

sum(float, float) - Static method in class java.lang. Float

根据+运算符，将两个 float值一起添加。

sum(int, int) - Static method in class java.lang. Integer

根据+运算符将两个整数相加。

sum(long, long) - Static method in class java.lang. Long

根据+运算符，将两个 long值一起添加。

sum(Spring, Spring) - Static method in class javax.swing. Spring

返回 s1+s2 ：一个春天，代表 s1和 s2系列。

summarizingDouble(ToDoubleFunction<? super T>) - Static method in class java.util.stream. Collectors

返回一个 Collector ， double生产映射函数应用于每个输入元素，并返回结果值的汇总统计信息。

summarizingInt(ToIntFunction<? super T>) - Static method in class java.util.stream. Collectors

返回一个 Collector ， int映射函数应用于每个输入元素，并返回结果值的汇总统计信息。

summarizingLong(ToLongFunction<? super T>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，它为每个输入元素应用 long生产映射函数，并返回结果值的汇总统计信息。

summaryStatistics() - Method in interface java.util.stream. DoubleStream

返回一个 DoubleSummaryStatistics描述有关此流的元素的各种摘要数据。

summaryStatistics() - Method in interface java.util.stream. IntStream

返回描述有关此流的元素的各种摘要数据的 IntSummaryStatistics 。

summaryStatistics() - Method in interface java.util.stream. LongStream

返回一个描述关于此流的元素的各种摘要数据的 LongSummaryStatistics 。

summingDouble(ToDoubleFunction<? super T>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，产生应用于输入元素的双值函数的和。

summingInt(ToIntFunction<? super T>) - Static method in class java.util.stream. Collectors

返回一个产生应用于输入元素的整数值函数之和的 Collector 。

summingLong(ToLongFunction<? super T>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，它产生应用于输入元素的长值函数的和。

sumThenReset() - Method in class java.util.concurrent.atomic. DoubleAdder

相当于 DoubleAdder.sum()，其次是 DoubleAdder.reset() 。

sumThenReset() - Method in class java.util.concurrent.atomic. LongAdder

相当于 LongAdder.sum()，其次是 LongAdder.reset() 。

SUNDANESE - java.awt.font. NumericShaper.Range

Sundㄧese Sund Sund Sund Sund。。。

SUNDANESE - java.lang. Character.UnicodeScript

Unicode脚本“Sundanese”。

SUNDANESE - Static variable in class java.lang. Character.UnicodeBlock

“Sundanese”Unicode字符块的常数。

SUNDANESE_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock

“Sundanese Supplement”Unicode字符块的常数。

SUNDAY - java.time. DayOfWeek

星期天的星期几的单身人士例子。

SUNDAY - Static variable in class java.util. Calendar

Calendar.DAY_OF_WEEK字段的值表示星期日。

SUNDAY_START - Static variable in class java.time.temporal. WeekFields

从周日和第一周开始的一周的常见定义至少为1天。

SUP - Static variable in class javax.swing.text.html. HTML.Tag

标签<sup>

SUPER_WILDCARD - com.sun.source.tree. Tree.Kind

用于表示超级有界通配符类型参数的WildcardTree的实例。

superBounds() - Method in interface com.sun.javadoc. WildcardType

已过时。

返回由 超级子句给出的此通配符类型参数的下限。

superclass() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回此类的超类。

superclass() - Method in interface com.sun.jdi. ClassType

获取此类的超类。

superclassType() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回此类的超类。

superclassType() - Method in interface com.sun.javadoc. ParameterizedType

已过时。

返回该类的直接超类型。

superinterfaces() - Method in interface com.sun.jdi. InterfaceType

获取此接口直接扩展的接口。

superLayout(Container) - Method in class javax.swing.plaf.metal. MetalComboBoxUI.MetalComboBoxLayoutManager

放出父容器。

Superscript - Static variable in class javax.swing.text. StyleConstants

上标属性的名称。

SUPERSCRIPT - Static variable in class java.awt.font. TextAttribute

上标和下标的属性键。

SUPERSCRIPT_SUB - Static variable in class java.awt.font. TextAttribute

标准下标。

SUPERSCRIPT_SUPER - Static variable in class java.awt.font. TextAttribute

标准上标。

SUPERSCRIPTS_AND_SUBSCRIPTS - Static variable in class java.lang. Character.UnicodeBlock

常数为“上标和下标”Unicode字符块。

SUPERSEDED - java.security.cert. CRLReason

这个原因表明证书已被取代。

superShardingKey(ShardingKey) - Method in interface java.sql. ConnectionBuilder

指定在创建连接时使用的 superShardingKey

superShardingKey(ShardingKey) - Method in interface javax.sql. PooledConnectionBuilder

指定创建连接时要使用的 superShardingKey

superShardingKey(ShardingKey) - Method in interface javax.sql. XAConnectionBuilder

指定创建连接时要使用的 superShardingKey

SUPPLEMENTAL_ARROWS_A - Static variable in class java.lang. Character.UnicodeBlock

“补充箭头A”Unicode字符块的常量。

SUPPLEMENTAL_ARROWS_B - Static variable in class java.lang. Character.UnicodeBlock

“补充箭头B”Unicode字符块的常数。

SUPPLEMENTAL_ARROWS_C - Static variable in class java.lang. Character.UnicodeBlock

“补充箭头-C”Unicode字符块的常量。

SUPPLEMENTAL_MATHEMATICAL_OPERATORS - Static variable in class java.lang. Character.UnicodeBlock

常数为“补充数学运算符”Unicode字符块。

SUPPLEMENTAL_PUNCTUATION - Static variable in class java.lang. Character.UnicodeBlock

“补充标点符号”Unicode字符块的常量。

SUPPLEMENTAL_SYMBOLS_AND_PICTOGRAPHS - Static variable in class java.lang. Character.UnicodeBlock

“补充符号和象形图”Unicode字符块的常数。

SUPPLEMENTARY_PRIVATE_USE_AREA_A - Static variable in class java.lang. Character.UnicodeBlock

“补充私用区域A”Unicode字符块的常量。

SUPPLEMENTARY_PRIVATE_USE_AREA_B - Static variable in class java.lang. Character.UnicodeBlock

“补充私用区域B”Unicode字符块的常量。

supplier() - Method in interface java.util.stream. Collector

一个创建并返回一个新的可变结果容器的函数。

Supplier< T> - Interface in java.util.function

代表结果供应商。

supplyAsync(Supplier<U>) - Static method in class java.util.concurrent. CompletableFuture

返回由在 ForkJoinPool.commonPool()中运行的任务异步完成的新的CompletableFuture，通过调用给定的供应商获得的值。

supplyAsync(Supplier<U>, Executor) - Static method in class java.util.concurrent. CompletableFuture

返回一个新的CompletableFuture，由给定执行器中运行的任务异步完成，并通过调用给定的供应商获得的值。

SUPPORT_DTD - Static variable in class javax.xml.stream. XMLInputFactory

需要解析器支持DTD的属性

SUPPORTED - Static variable in class javax.print.attribute.standard. ColorSupported

打印机能够进行某种类型的彩色打印，例如高亮颜色或全过程颜色。

SupportedAnnotationTypes - Annotation Type in javax.annotation.processing

用于指示注释处理器支持的注释类型的注释。

supportedFileAttributeViews() - Method in class java.nio.file. FileSystem

返回 FileSystem支持的文件属性视图的一组 FileSystem 。

supportedOptions() - Method in class com.sun.nio.sctp. SctpChannel

返回此通道支持的一组套接字选项。

supportedOptions() - Method in class com.sun.nio.sctp. SctpMultiChannel

返回此通道支持的一组套接字选项。

supportedOptions() - Method in class com.sun.nio.sctp. SctpServerChannel

返回此通道支持的一组套接字选项。

supportedOptions() - Method in class java.net. DatagramSocket

返回此套接字支持的一组套接字选项。

supportedOptions() - Method in class java.net. DatagramSocketImpl

返回一个由此impl和该impl的套接字（DatagramSocket或MulticastSocket）支持的SocketOptions，

supportedOptions() - Method in class java.net. MulticastSocket

supportedOptions() - Method in class java.net. ServerSocket

返回此服务器套接字支持的一组套接字选项。

supportedOptions() - Method in class java.net. Socket

返回此套接字支持的一组套接字选项。

supportedOptions() - Method in class java.net. SocketImpl

返回一个由此impl和该impl的套接字支持的SocketOptions（Socket或ServerSocket）

supportedOptions() - Method in interface java.nio.channels. NetworkChannel

返回此通道支持的一组套接字选项。

supportedOptions(Class<?>) - Static method in class jdk.net. Sockets

返回给定套接字类型支持的一组SocketOption s。

SupportedOptions - Annotation Type in javax.annotation.processing

用于指示注释处理器支持哪些选项的注释。

SupportedSourceVersion - Annotation Type in javax.annotation.processing

用于指示注释处理器支持的最新源版本的注释。

SupportedValuesAttribute - Interface in javax.print.attribute

Interface SupportedValuesAttribute是打印属性类实现的标记接口，用于指示属性描述了另一个属性的支持值。

supportsAcceptTimeout() - Method in class com.sun.jdi.connect.spi. TransportService.Capabilities

在等待目标虚拟机连接时，告知此传输服务是否支持超时。

supportsAlterTableWithAddColumn() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持带有添加列的 ALTER TABLE 。

supportsAlterTableWithDropColumn() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持具有删除列的 ALTER TABLE 。

supportsANSI92EntryLevelSQL() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持ANSI92入门级SQL语法。

supportsANSI92FullSQL() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持支持的ANSI92完整SQL语法。

supportsANSI92IntermediateSQL() - Method in interface java.sql. DatabaseMetaData

检索该数据库是否支持ANSI92中间SQL语法。

supportsAttachTimeout() - Method in class com.sun.jdi.connect.spi. TransportService.Capabilities

在连接到目标虚拟机时，请告知此传输服务是否支持超时。

supportsBatchUpdates() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持批量更新。

supportsCatalogsInDataManipulation() - Method in interface java.sql. DatabaseMetaData

检索数据操作语句中是否可以使用目录名称。

supportsCatalogsInIndexDefinitions() - Method in interface java.sql. DatabaseMetaData

检索是否可以在索引定义语句中使用目录名称。

supportsCatalogsInPrivilegeDefinitions() - Method in interface java.sql. DatabaseMetaData

检索是否可以在特权定义语句中使用目录名称。

supportsCatalogsInProcedureCalls() - Method in interface java.sql. DatabaseMetaData

检索是否可以在过程调用语句中使用目录名称。

supportsCatalogsInTableDefinitions() - Method in interface java.sql. DatabaseMetaData

检索表定义语句中是否可以使用目录名称。

supportsColumnAliasing() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持列别名。

supportsConvert() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持JDBC标量函数 CONVERT用于将一种JDBC类型转换为另一种JDBC类型。

supportsConvert(int, int) - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持JDBC标量函数 CONVERT用于JDBC类型 fromType和 toType之间的转换。

supportsCoreSQLGrammar() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持ODBC Core SQL语法。

supportsCorrelatedSubqueries() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持相关的子查询。

supportsCrossJoin() - Method in interface javax.sql.rowset. JoinRowSet

指示CROSS_JOIN是否由JoinRowSet实现支持

supportsCustomEditor() - Method in interface java.beans. PropertyEditor

确定此属性编辑器是否支持自定义编辑器。

supportsCustomEditor() - Method in class java.beans. PropertyEditorSupport

确定propertyEditor是否可以提供自定义编辑器。

supportsDataDefinitionAndDataManipulationTransactions() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持事务中的数据定义和数据操作语句。

supportsDataManipulationTransactionsOnly() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否仅支持事务中的数据操作语句。

supportsDifferentTableCorrelationNames() - Method in interface java.sql. DatabaseMetaData

检索是否支持表相关名称，它们被限制为与表的名称不同。

supportsExpressionsInOrderBy() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持 ORDER BY列表中的表达式。

supportsExtendedSQLGrammar() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持ODBC扩展SQL语法。

supportsFileAttributeView(Class<? extends FileAttributeView>) - Method in class java.nio.file. FileStore

告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。

supportsFileAttributeView(String) - Method in class java.nio.file. FileStore

告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。

supportsFullJoin() - Method in interface javax.sql.rowset. JoinRowSet

指示JoinRowSet实现是否支持FULL_JOIN

supportsFullOuterJoins() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持完全嵌套的外连接。

supportsGetGeneratedKeys() - Method in interface java.sql. DatabaseMetaData

检索在执行语句后是否可以检索自动生成的键

supportsGroupBy() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持某种形式的 GROUP BY子句。

supportsGroupByBeyondSelect() - Method in interface java.sql. DatabaseMetaData

获取此数据库是否支持使用不包含在列 SELECT在一份声明中 GROUP BY条款规定，所有在列 SELECT声明都包含在在 GROUP BY条款。

supportsGroupByUnrelated() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持在 GROUP BY子句中使用 GROUP BY SELECT语句中的 GROUP BY 。

supportsHandshakeTimeout() - Method in class com.sun.jdi.connect.spi. TransportService.Capabilities

告知当与目标虚拟机进行握手时，此传输服务是否支持超时。

supportsInnerJoin() - Method in interface javax.sql.rowset. JoinRowSet

指示JoinRowSet实现是否支持INNER_JOIN

supportsIntegrityEnhancementFacility() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持SQL完整性增强工具。

supportsLeftOuterJoin() - Method in interface javax.sql.rowset. JoinRowSet

指示JoinRowSet实现是否支持LEFT_OUTER_JOIN

supportsLikeEscapeClause() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持指定一个 LIKE转义子句。

supportsLimitedOuterJoins() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否为外连接提供有限的支持。

supportsMinimumSQLGrammar() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持ODBC最低SQL语法。

supportsMixedCaseIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写不引用的SQL标识符视为区分大小写，并将结果存储在混合大小写中。

supportsMixedCaseQuotedIdentifiers() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否将混合大小写的SQL标识符视为区分大小写，并将结果存储在混合大小写中。

supportsMulticast() - Method in class java.net. NetworkInterface

返回网络接口是否支持多播。

supportsMultipleConnections() - Method in interface com.sun.jdi.connect. ListeningConnector

指示此侦听连接器是否支持单个参数映射的多个连接。

supportsMultipleConnections() - Method in class com.sun.jdi.connect.spi. TransportService.Capabilities

告诉这个传输服务是否可以支持与正在监听的单个地址的多个并发连接。

supportsMultipleOpenResults() - Method in interface java.sql. DatabaseMetaData

检索是否有可能具有多个 ResultSet从返回的对象 CallableStatement对象同时进行。

supportsMultipleResultSets() - Method in interface java.sql. DatabaseMetaData

检索该数据库是否支持从方法 execute的单一调用中获取多个 ResultSet对象。

supportsMultipleTransactions() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否允许同时打开多个事务（在不同的连接上）。

supportsNamedParameters() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持可调用语句的命名参数。

supportsNonNullableColumns() - Method in interface java.sql. DatabaseMetaData

检索此数据库中的列是否可以被定义为不可为空。

supportsNormalTermination() - Method in class java.lang. Process

返回 true如果执行 Process.destroy()是正常终止进程，返回 false如果执行 destroy强制立即终止进程。

supportsNormalTermination() - Method in interface java.lang. ProcessHandle

返回 true如果执行 ProcessHandle.destroy()正常终止进程。

supportsOpenCursorsAcrossCommit() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持保持游标在提交之间打开。

supportsOpenCursorsAcrossRollback() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持在回滚之间保持光标打开。

supportsOpenStatementsAcrossCommit() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持在提交之间保留语句。

supportsOpenStatementsAcrossRollback() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持在回滚期间保持语句打开。

supportsOrderByUnrelated() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持在 ORDER BY子句中使用 ORDER BY SELECT语句中的 ORDER BY 。

supportsOuterJoins() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持某种形式的外连接。

supportsPageRanges() - Method in class javafx.print. PrinterAttributes

报告是否支持页面范围。

supportsParameter(Object) - Method in class java.security. Provider.Service

测试此服务是否可以使用指定的参数。

supportsPositionedDelete() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持定位 DELETE语句。

supportsPositionedUpdate() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持定位的 UPDATE语句。

supportsPredictionResistance() - Method in enum java.security. DrbgParameters.Capability

返回此功能是否支持预测阻力。

supportsRefCursors() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持REF CURSOR。

supportsReseeding() - Method in enum java.security. DrbgParameters.Capability

返回此功能是否支持重新加载。

supportsResultSetConcurrency(int, int) - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持给定的并发类型与给定的结果集类型的组合。

supportsResultSetHoldability(int) - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持给定的结果集保持性。

supportsResultSetType(int) - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持给定的结果集类型。

supportsRightOuterJoin() - Method in interface javax.sql.rowset. JoinRowSet

指示JoinRowSet实现是否支持RIGHT_OUTER_JOIN

supportsSavepoints() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持保存点。

supportsSchemasInDataManipulation() - Method in interface java.sql. DatabaseMetaData

检索是否可以在数据操作语句中使用模式名称。

supportsSchemasInIndexDefinitions() - Method in interface java.sql. DatabaseMetaData

检索是否可以在索引定义语句中使用模式名称。

supportsSchemasInPrivilegeDefinitions() - Method in interface java.sql. DatabaseMetaData

检索是否可以在特权定义语句中使用模式名称。

supportsSchemasInProcedureCalls() - Method in interface java.sql. DatabaseMetaData

检索是否可以在过程调用语句中使用模式名称。

supportsSchemasInTableDefinitions() - Method in interface java.sql. DatabaseMetaData

检索表定义语句中是否可以使用模式名称。

supportsSelectForUpdate() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持 SELECT FOR UPDATE语句。

supportsSharding() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持分片。

supportsStandardImageMetadataFormat - Variable in class javax.imageio.spi. ImageReaderWriterSpi

一个布尔值，表示该插件是否支持图像元数据的标准元数据格式，最初为 false 。

supportsStandardStreamMetadataFormat - Variable in class javax.imageio.spi. ImageReaderWriterSpi

一个布尔值，表示此插件是否支持流元数据的标准元数据格式，最初为 false 。

supportsStatementPooling() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持语句池。

supportsStoredFunctionsUsingCallSyntax() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持使用存储过程转义语法调用用户定义或供应商功能。

supportsStoredProcedures() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持使用存储过程转义语法的存储过程调用。

supportsSubqueriesInComparisons() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持比较表达式中的子查询。

supportsSubqueriesInExists() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持 EXISTS表达式中的子查询。

supportsSubqueriesInIns() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持 IN表达式中的子查询。

supportsSubqueriesInQuantifieds() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持量化表达式中的子查询。

supportsTableCorrelationNames() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持表相关名称。

supportsTransactionIsolationLevel(int) - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持给定的事务隔离级别。

supportsTransactions() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持事务。

supportsUnion() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持SQL UNION 。

supportsUnionAll() - Method in interface java.sql. DatabaseMetaData

检索此数据库是否支持SQL UNION ALL 。

supportsUpdatableView() - Method in class javax.sql.rowset.spi. SyncProvider

返回此 SyncProvider实现是否可以在 RowSet对象与 RowSet对象获取其数据的数据源中的SQL VIEW之间执行同步。

supportsUrgentData() - Method in class java.net. SocketImpl

返回SocketImpl是否支持发送紧急数据。

SuppressWarnings - Annotation Type in java.lang

表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。

surfaceScaleProperty() - Method in class javafx.scene.effect. Lighting

表面比例因子。

SURROGATE - Static variable in class java.lang. Character

Unicode规范中的常规类别“Cs”。

SURROGATES_AREA - Static variable in class java.lang. Character.UnicodeBlock

已过时。
取而代之的SURROGATES_AREA ，使用Character.UnicodeBlock.HIGH_SURROGATES ， Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES ，并Character.UnicodeBlock.LOW_SURROGATES 。 这些常量符合Unicode标准的块定义。 Character.UnicodeBlock.of(char)和Character.UnicodeBlock.of(int)方法返回标准常量。

surroundContents(Node) - Method in interface org.w3c.dom.ranges. Range

将Range的内容重新指定给给定节点，并将节点插入到Range的起始位置。

suspend() - Method in interface com.sun.jdi. ThreadGroupReference

暂停此线程组中的所有线程。

suspend() - Method in interface com.sun.jdi. ThreadReference

暂停这个线程。

suspend() - Method in interface com.sun.jdi. VirtualMachine

暂停在该虚拟机中运行的应用程序的执行。

suspend() - Method in class java.lang. Thread

已过时。
这种方法已被弃用，因为它本身就是死锁的。 如果目标线程在挂起时保护关键系统资源的监视器上的锁定，则在目标线程恢复之前，线程不能访问该资源。 如果要恢复目标线程的线程尝试在调用resume之前锁定此监视器， resume导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。

suspend() - Method in class java.lang. ThreadGroup

已过时。
这种方法本质上是死锁的。 详见Thread.suspend() 。

SUSPEND_ALL - Static variable in interface com.sun.jdi.request. EventRequest

发生事件时暂停所有线程

SUSPEND_EVENT_THREAD - Static variable in interface com.sun.jdi.request. EventRequest

当事件发生时，只挂起生成事件的线程

SUSPEND_NONE - Static variable in interface com.sun.jdi.request. EventRequest

事件发生时暂停线程

suspendCount() - Method in interface com.sun.jdi. ThreadReference

返回此线程的待处理挂起数。

suspendPolicy() - Method in interface com.sun.jdi.event. EventSet

返回用于挂起该事件集的目标虚拟机中的线程的策略。

suspendPolicy() - Method in interface com.sun.jdi.request. EventRequest

返回一个值，该值描述在目标VM中发生请求的事件时挂起的线程。

SUTTON_SIGNWRITING - Static variable in class java.lang. Character.UnicodeBlock

“Sutton SignWriting”Unicode字符块的常量。

sval - Variable in class java.io. StreamTokenizer

如果当前令牌是一个单词标记，则该字段包含一个字符串，给出单词令牌的字符。

SVGPath - Class in javafx.scene.shape

SVGPath类表示通过从String解析SVG路径数据构建的简单形状。

SVGPath() - Constructor for class javafx.scene.shape. SVGPath

创建一个空的SVGPath实例。

SW_RESIZE - Static variable in class javafx.scene. Cursor

西南大小的光标类型。

SW_RESIZE_CURSOR - Static variable in class java.awt. Cursor

西南大小的光标类型。

SW_RESIZE_CURSOR - Static variable in class java.awt. Frame

已过时。
替换为Cursor.SW_RESIZE_CURSOR 。

swap(List<?>, int, int) - Static method in class java.util. Collections

交换指定列表中指定位置的元素。

SWAP_COLORS - Static variable in class java.awt.font. TextAttribute

用于交换前景和背景的属性键 Paints 。

SWAP_COLORS_ON - Static variable in class java.awt.font. TextAttribute

交换前景和背景。

sweepFlagProperty() - Method in class javafx.scene.shape. ArcTo

扫旗

SWING - javafx.application. ConditionalFeature

表示Swing库存在于Java运行时环境中，并且Swing与JavaFX的集成在该平台上可用。

SWING_COMPONENT - Static variable in class javax.accessibility. AccessibleRole

一个Swing组件，但没有其他的知道它。

SwingConstants - Interface in javax.swing

通常用于在屏幕上定位和定向组件的常数的集合。

SwingContainer - Annotation Type in javax.swing

用于为自动生成的 BeanInfo类指定一些与swing相关的信息的注释。

SwingEventMonitor - Class in com.sun.java.accessibility.util

SwingEventMonitor通过在Java虚拟机中的每个Swing组件实例上添加一些有条件地安装的监听SwingEventMonitor扩展AWTEventMonitor 。

SwingEventMonitor() - Constructor for class com.sun.java.accessibility.util. SwingEventMonitor

SwingFXUtils - Class in javafx.embed.swing

该类提供了用于在Swing / AWT和JavaFX格式之间转换数据类型的实用方法。

SwingNode - Class in javafx.embed.swing

此类用于将Swing内容嵌入到JavaFX应用程序中。

SwingNode() - Constructor for class javafx.embed.swing. SwingNode

构造一个新的实例 SwingNode 。

SwingPropertyChangeSupport - Class in javax.swing.event

java.beans.PropertyChangeSupport这个子类功能几乎相同。

SwingPropertyChangeSupport(Object) - Constructor for class javax.swing.event. SwingPropertyChangeSupport

构造一个SwingPropertyChangeSupport对象。

SwingPropertyChangeSupport(Object, boolean) - Constructor for class javax.swing.event. SwingPropertyChangeSupport

构造一个SwingPropertyChangeSupport对象。

SwingUtilities - Class in javax.swing

Swing的一个实用方法的集合。

SwingWorker< T, V> - Class in javax.swing

在后台线程中执行冗长的GUI交互任务的抽象类。

SwingWorker() - Constructor for class javax.swing. SwingWorker

构造这个 SwingWorker 。

SwingWorker.StateValue - Enum in javax.swing

state绑定属性的值。

SWIPE_DOWN - Static variable in class javafx.scene.input. SwipeEvent

当用户执行向下滑动手势时，会发生此事件。

SWIPE_LEFT - Static variable in class javafx.scene.input. SwipeEvent

当用户执行向左滑动手势时，会发生此事件。

SWIPE_RIGHT - Static variable in class javafx.scene.input. SwipeEvent

当用户执行向右滑动手势时，会发生此事件。

SWIPE_UP - Static variable in class javafx.scene.input. SwipeEvent

当用户执行向上滑动手势时，会发生此事件。

SwipeEvent - Class in javafx.scene.input

滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。

SwipeEvent(Object, EventTarget, EventType<SwipeEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, int, PickResult) - Constructor for class javafx.scene.input. SwipeEvent

构造新的SwipeEvent事件。

SwipeEvent(EventType<SwipeEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, int, PickResult) - Constructor for class javafx.scene.input. SwipeEvent

构造具有null源和目标的新的SwipeEvent事件。

SWITCH - com.sun.source.tree. Tree.Kind

用于SwitchTree的实例。

SWITCH - jdk.nashorn.api.tree. Tree.Kind

用于SwitchTree的实例。

SwitchPoint - Class in java.lang.invoke

A SwitchPoint是可以将状态转换发布到其他线程的对象。

SwitchPoint() - Constructor for class java.lang.invoke. SwitchPoint

创建一个新的切换点。

SwitchTree - Interface in com.sun.source.tree

一个 switch语句的树结点。

SwitchTree - Interface in jdk.nashorn.api.tree

“switch”语句的树结点。

SWT - javafx.application. ConditionalFeature

表示SWT集成在平台上可用。

SYLOTI_NAGRI - java.lang. Character.UnicodeScript

Unicode脚本“Syloti_Nagri”。

SYLOTI_NAGRI - Static variable in class java.lang. Character.UnicodeBlock

“Syloti Nagri”Unicode字符块的常量。

sync() - Method in class java.awt. Toolkit

同步该工具包的图形状态。

sync() - Method in class java.io. FileDescriptor

强制所有系统缓冲区与底层设备同步。

sync() - Method in class java.util.prefs. AbstractPreferences

实现 sync方法按照在本说明书中 Preferences.sync() 。

sync() - Method in class java.util.prefs. Preferences

确保从该偏好节点及其后代的未来读取反映在 sync调用之前提交给永久存储（来自任何VM）的任何更改。

SYNC - java.nio.file. StandardOpenOption

要求将文件内容或元数据的每次更新都同步写入底层存储设备。

SYNC_FLUSH - Static variable in class java.util.zip. Deflater

压缩冲洗模式用于清除所有挂起的输出; 可能会降低某些压缩算法的压缩率。

sync_scope() - Method in interface org.omg.PortableInterceptor. RequestInfoOperations

定义在将控制权返回给客户端之前请求的进展程度。

SYNC_WITH_TRANSPORT - Interface in org.omg.Messaging

org / omg / Messaging / SYNC_WITH_TRANSPORT.java。

syncAll(MutableCallSite[]) - Static method in class java.lang.invoke. MutableCallSite

在给定数组中的每个调用站点上执行同步操作，强制所有其他线程丢弃先前从任何呼叫站点的目标加载的缓存值。

syncAllWidths - Variable in class javax.swing.plaf.basic. BasicOptionPaneUI.ButtonAreaLayout

该值表示如果子节点的宽度应同步。

SyncFactory - Class in javax.sql.rowset.spi

服务提供程序接口（SPI）机制，生成 SyncProvider实例，由断开的 RowSet对象使用。

SyncFactoryException - Exception in javax.sql.rowset.spi

表示错误 SyncFactory机制。

SyncFactoryException() - Constructor for exception javax.sql.rowset.spi. SyncFactoryException

创建新的 SyncFactoryException没有详细信息。

SyncFactoryException(String) - Constructor for exception javax.sql.rowset.spi. SyncFactoryException

构造具有指定详细消息的 SyncFactoryException 。

SyncFailedException - Exception in java.io

发出同步操作失败的信号。

SyncFailedException(String) - Constructor for exception java.io. SyncFailedException

构造具有详细消息的SyncFailedException。

synchronize(Line[], boolean) - Method in interface javax.sound.sampled. Mixer

同步两条或更多条线。

SYNCHRONIZE - java.nio.file.attribute. AclEntryPermission

通过同步读写在本地访问服务器的权限。

SYNCHRONIZED - com.sun.source.tree. Tree.Kind

用于SynchronizedTree的实例。

SYNCHRONIZED - javax.lang.model.element. Modifier

修饰词 synchronized

SYNCHRONIZED - Static variable in class java.lang.reflect. Modifier

int值代表 synchronized修饰符。

synchronizedCollection(Collection<T>) - Static method in class java.util. Collections

返回由指定集合支持的同步（线程安全）集合。

synchronizedList(List<T>) - Static method in class java.util. Collections

返回由指定列表支持的同步（线程安全）列表。

synchronizedMap(Map<K, V>) - Static method in class java.util. Collections

返回由指定地图支持的同步（线程安全）映射。

synchronizedNavigableMap(NavigableMap<K, V>) - Static method in class java.util. Collections

返回由指定的可导航地图支持的同步（线程安全）可导航地图。

synchronizedNavigableSet(NavigableSet<T>) - Static method in class java.util. Collections

返回由指定的可导航集支持的同步（线程安全）可导航集。

synchronizedObservableList(ObservableList<E>) - Static method in class javafx.collections. FXCollections

在提供的可观察列表之上创建并返回一个同步的包装器。

synchronizedObservableMap(ObservableMap<K, V>) - Static method in class javafx.collections. FXCollections

在提供的可观察地图的顶部创建并返回同步的包装器。

synchronizedObservableSet(ObservableSet<E>) - Static method in class javafx.collections. FXCollections

在提供的可观察集合之上创建并返回同步的包装器。

synchronizedSet(Set<T>) - Static method in class java.util. Collections

返回由指定集合支持的同步（线程安全）集。

synchronizedSortedMap(SortedMap<K, V>) - Static method in class java.util. Collections

返回由指定的排序映射支持的同步（线程安全）排序映射。

synchronizedSortedSet(SortedSet<T>) - Static method in class java.util. Collections

返回由指定的排序集支持的同步（线程安全）排序集。

SynchronizedTree - Interface in com.sun.source.tree

一个用于 synchronized语句的树节点。

synchronizedView(AttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities

创建给定属性集的同步视图。

synchronizedView(DocAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities

创建给定doc属性集的同步视图。

synchronizedView(PrintJobAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities

创建给定打印作业属性集的同步视图。

synchronizedView(PrintRequestAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities

创建给定打印请求属性集的同步视图。

synchronizedView(PrintServiceAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities

创建给定打印服务属性集的同步视图。

SynchronousQueue< E> - Class in java.util.concurrent

A blocking queue其中每个插入操作必须等待另一个线程相应的删除操作，反之亦然。

SynchronousQueue() - Constructor for class java.util.concurrent. SynchronousQueue

创建一个 SynchronousQueue与非访问策略。

SynchronousQueue(boolean) - Constructor for class java.util.concurrent. SynchronousQueue

创建一个具有指定公平政策的 SynchronousQueue 。

SyncMode(String) - Constructor for class javax.sound.midi. Sequencer.SyncMode

构造同步模式。

SyncProvider - Class in javax.sql.rowset.spi

同步机制，为断开连接的 RowSet对象提供读写器功能。

SyncProvider() - Constructor for class javax.sql.rowset.spi. SyncProvider

创建默认的 SyncProvider对象。

SyncProviderException - Exception in javax.sql.rowset.spi

表示 SyncProvider机制出现错误。

SyncProviderException() - Constructor for exception javax.sql.rowset.spi. SyncProviderException

创建一个新的 SyncProviderException对象，没有详细消息。

SyncProviderException(String) - Constructor for exception javax.sql.rowset.spi. SyncProviderException

构造具有指定详细消息的 SyncProviderException对象。

SyncProviderException(SyncResolver) - Constructor for exception javax.sql.rowset.spi. SyncProviderException

使用指定的 SyncResolver实例构造一个 SyncProviderException对象。

SyncResolver - Interface in javax.sql.rowset.spi

定义一个框架，允许应用程序使用手动决策树来决定在发生同步冲突时应该做什么。

SyncScopeHelper - Class in org.omg.Messaging

同步范围

SyncScopeHelper() - Constructor for class org.omg.Messaging. SyncScopeHelper

syncScrollPaneWithViewport() - Method in class javax.swing.plaf.basic. BasicScrollPaneUI

同步 JScrollPane与 Viewport 。

syncSpi() - Method in class java.util.prefs. AbstractPreferences

此方法在此节点锁定时被调用。

syncWithScrollPane(JScrollPane) - Method in class javax.swing. ScrollPaneLayout

在将ScrollPaneLayout设置为 JScrollPane的LayoutManager后，将调用此方法。

SYNTAX_ERR - Static variable in exception org.w3c.dom. DOMException

如果指定了无效或非法的字符串。

SynthButtonUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JButton 。

SynthButtonUI() - Constructor for class javax.swing.plaf.synth. SynthButtonUI

SynthCheckBoxMenuItemUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JCheckBoxMenuItem 。

SynthCheckBoxMenuItemUI() - Constructor for class javax.swing.plaf.synth. SynthCheckBoxMenuItemUI

SynthCheckBoxUI - Class in javax.swing.plaf.synth

为JCheckBox提供Synth L＆F UI代表。

SynthCheckBoxUI() - Constructor for class javax.swing.plaf.synth. SynthCheckBoxUI

SynthColorChooserUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JColorChooser 。

SynthColorChooserUI() - Constructor for class javax.swing.plaf.synth. SynthColorChooserUI

SynthComboBoxUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JComboBox 。

SynthComboBoxUI() - Constructor for class javax.swing.plaf.synth. SynthComboBoxUI

SynthConstants - Interface in javax.swing.plaf.synth

Synth使用的常数。

SynthContext - Class in javax.swing.plaf.synth

包含关于 Region上下文信息的不可变临时对象。

SynthContext(JComponent, Region, SynthStyle, int) - Constructor for class javax.swing.plaf.synth. SynthContext

创建具有指定值的SynthContext。

SynthDesktopIconUI - Class in javax.swing.plaf.synth

为桌面上最小化的内部框架提供Synth L＆F UI代理。

SynthDesktopIconUI() - Constructor for class javax.swing.plaf.synth. SynthDesktopIconUI

SynthDesktopPaneUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JDesktopPane 。

SynthDesktopPaneUI() - Constructor for class javax.swing.plaf.synth. SynthDesktopPaneUI

SynthEditorPaneUI - Class in javax.swing.plaf.synth

为JEditorPane提供Synth L＆F UI代表。

SynthEditorPaneUI() - Constructor for class javax.swing.plaf.synth. SynthEditorPaneUI

synthesizedElement(Element) - Method in class javax.swing.text.html. HTMLWriter

如果元素是合成元素，则返回 true 。

Synthesizer - Interface in javax.sound.midi

A Synthesizer产生声音。

SYNTHETIC - java.lang.module. ModuleDescriptor.Exports.Modifier

导出未在模块声明的来源中明确或隐含地声明。

SYNTHETIC - java.lang.module. ModuleDescriptor.Modifier

该模块未被明确或隐含地声明。

SYNTHETIC - java.lang.module. ModuleDescriptor.Opens.Modifier

开放包未在模块声明的来源中明确或隐式声明。

SYNTHETIC - java.lang.module. ModuleDescriptor.Requires.Modifier

依赖性没有在模块声明的来源中明确或隐含地声明。

SYNTHETIC - javax.lang.model.util. Elements.Origin

一个合成的构造是在源代码中既不是隐式的也不是明确声明的。

SynthFormattedTextFieldUI - Class in javax.swing.plaf.synth

为JFormattedTextField提供Synth L＆F UI代表。

SynthFormattedTextFieldUI() - Constructor for class javax.swing.plaf.synth. SynthFormattedTextFieldUI

SynthGraphicsUtils - Class in javax.swing.plaf.synth

原始图形调用的包装器。

SynthGraphicsUtils() - Constructor for class javax.swing.plaf.synth. SynthGraphicsUtils

创建一个 SynthGraphicsUtils 。

SynthIcon - Interface in javax.swing.plaf.synth

一个图标通过一个 SynthContext 。

SynthInternalFrameUI - Class in javax.swing.plaf.synth

为JInternalFrame提供Synth L＆F UI代表。

SynthInternalFrameUI(JInternalFrame) - Constructor for class javax.swing.plaf.synth. SynthInternalFrameUI

构造一个 SynthInternalFrameUI 。

SynthLabelUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JLabel 。

SynthLabelUI() - Constructor for class javax.swing.plaf.synth. SynthLabelUI

SynthListUI - Class in javax.swing.plaf.synth

为JList提供Synth L＆F UI代表。

SynthListUI() - Constructor for class javax.swing.plaf.synth. SynthListUI

SynthLookAndFeel - Class in javax.swing.plaf.synth

SynthLookAndFeel提供了创建自定义外观的基础。

SynthLookAndFeel() - Constructor for class javax.swing.plaf.synth. SynthLookAndFeel

创建SynthLookAndFeel。

SynthMenuBarUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JMenuBar 。

SynthMenuBarUI() - Constructor for class javax.swing.plaf.synth. SynthMenuBarUI

SynthMenuItemUI - Class in javax.swing.plaf.synth

为Synology L＆F UI代表提供JMenuItem 。

SynthMenuItemUI() - Constructor for class javax.swing.plaf.synth. SynthMenuItemUI

SynthMenuUI - Class in javax.swing.plaf.synth

为JMenu提供Synth L＆F UI代表。

SynthMenuUI() - Constructor for class javax.swing.plaf.synth. SynthMenuUI

SynthOptionPaneUI - Class in javax.swing.plaf.synth

为JOptionPane提供Synth L＆F UI代表。

SynthOptionPaneUI() - Constructor for class javax.swing.plaf.synth. SynthOptionPaneUI

SynthPainter - Class in javax.swing.plaf.synth

SynthPainter用于绘制 JComponent的部分。

SynthPainter() - Constructor for class javax.swing.plaf.synth. SynthPainter

SynthPanelUI - Class in javax.swing.plaf.synth

为JPanel提供Synth L＆F UI代表。

SynthPanelUI() - Constructor for class javax.swing.plaf.synth. SynthPanelUI

SynthPasswordFieldUI - Class in javax.swing.plaf.synth

为JPasswordField提供Synth L＆F UI代表。

SynthPasswordFieldUI() - Constructor for class javax.swing.plaf.synth. SynthPasswordFieldUI

SynthPopupMenuUI - Class in javax.swing.plaf.synth

为JPopupMenu提供Synth L＆F UI代表。

SynthPopupMenuUI() - Constructor for class javax.swing.plaf.synth. SynthPopupMenuUI

SynthProgressBarUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JProgressBar 。

SynthProgressBarUI() - Constructor for class javax.swing.plaf.synth. SynthProgressBarUI

SynthRadioButtonMenuItemUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JRadioButtonMenuItem 。

SynthRadioButtonMenuItemUI() - Constructor for class javax.swing.plaf.synth. SynthRadioButtonMenuItemUI

SynthRadioButtonUI - Class in javax.swing.plaf.synth

为JRadioButton提供Synth L＆F UI代表。

SynthRadioButtonUI() - Constructor for class javax.swing.plaf.synth. SynthRadioButtonUI

SynthRootPaneUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JRootPane 。

SynthRootPaneUI() - Constructor for class javax.swing.plaf.synth. SynthRootPaneUI

SynthScrollBarUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JScrollBar 。

SynthScrollBarUI() - Constructor for class javax.swing.plaf.synth. SynthScrollBarUI

SynthScrollPaneUI - Class in javax.swing.plaf.synth

为Synology L＆F UI代表提供JScrollPane 。

SynthScrollPaneUI() - Constructor for class javax.swing.plaf.synth. SynthScrollPaneUI

SynthSeparatorUI - Class in javax.swing.plaf.synth

为JSeparator提供Synth L＆F UI代表。

SynthSeparatorUI() - Constructor for class javax.swing.plaf.synth. SynthSeparatorUI

SynthSliderUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JSlider 。

SynthSliderUI(JSlider) - Constructor for class javax.swing.plaf.synth. SynthSliderUI

构造一个 SynthSliderUI 。

SynthSpinnerUI - Class in javax.swing.plaf.synth

为JSpinner提供Synth L＆F UI代表。

SynthSpinnerUI() - Constructor for class javax.swing.plaf.synth. SynthSpinnerUI

SynthSplitPaneUI - Class in javax.swing.plaf.synth

为JSplitPane提供Synth L＆F UI代表。

SynthSplitPaneUI() - Constructor for class javax.swing.plaf.synth. SynthSplitPaneUI

SynthStyle - Class in javax.swing.plaf.synth

SynthStyle是一套风格属性。

SynthStyle() - Constructor for class javax.swing.plaf.synth. SynthStyle

构造SynthStyle。

SynthStyleFactory - Class in javax.swing.plaf.synth

工厂用于获得 SynthStyle s。

SynthStyleFactory() - Constructor for class javax.swing.plaf.synth. SynthStyleFactory

创建一个 SynthStyleFactory 。

SynthTabbedPaneUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JTabbedPane 。

SynthTabbedPaneUI() - Constructor for class javax.swing.plaf.synth. SynthTabbedPaneUI

SynthTableHeaderUI - Class in javax.swing.plaf.synth

为Synology L＆F UI代表提供JTableHeader 。

SynthTableHeaderUI() - Constructor for class javax.swing.plaf.synth. SynthTableHeaderUI

SynthTableUI - Class in javax.swing.plaf.synth

为JTable提供Synth L＆F UI代表。

SynthTableUI() - Constructor for class javax.swing.plaf.synth. SynthTableUI

SynthTextAreaUI - Class in javax.swing.plaf.synth

为Synth的外观和感觉提供纯文本编辑器的外观和感觉。

SynthTextAreaUI() - Constructor for class javax.swing.plaf.synth. SynthTextAreaUI

SynthTextFieldUI - Class in javax.swing.plaf.synth

为Synology L＆F UI代表提供JTextField 。

SynthTextFieldUI() - Constructor for class javax.swing.plaf.synth. SynthTextFieldUI

SynthTextPaneUI - Class in javax.swing.plaf.synth

为Synth外观和风格的样式文本编辑器提供外观和感觉。

SynthTextPaneUI() - Constructor for class javax.swing.plaf.synth. SynthTextPaneUI

SynthToggleButtonUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JToggleButton 。

SynthToggleButtonUI() - Constructor for class javax.swing.plaf.synth. SynthToggleButtonUI

SynthToolBarUI - Class in javax.swing.plaf.synth

提供Synth L＆F UI代表JToolBar 。

SynthToolBarUI() - Constructor for class javax.swing.plaf.synth. SynthToolBarUI

SynthToolTipUI - Class in javax.swing.plaf.synth

为Synology L＆F UI代表提供JToolTip 。

SynthToolTipUI() - Constructor for class javax.swing.plaf.synth. SynthToolTipUI

SynthTreeUI - Class in javax.swing.plaf.synth

为JTree提供Synth L＆F UI代表。

SynthTreeUI() - Constructor for class javax.swing.plaf.synth. SynthTreeUI

SynthUI - Interface in javax.swing.plaf.synth

SynthUI用于获取特定组件的SynthContext。

SynthViewportUI - Class in javax.swing.plaf.synth

为JViewport提供Synth L＆F UI代表。

SynthViewportUI() - Constructor for class javax.swing.plaf.synth. SynthViewportUI

SYRIAC - java.lang. Character.UnicodeScript

Unicode脚本“Syriac”。

SYRIAC - Static variable in class java.lang. Character.UnicodeBlock

“Syriac”Unicode字符块的常数。

SysexMessage - Class in javax.sound.midi

SysexMessage对象表示MIDI系统专用消息。

SysexMessage() - Constructor for class javax.sound.midi. SysexMessage

构造新的 SysexMessage 。

SysexMessage(byte[]) - Constructor for class javax.sound.midi. SysexMessage

构造新的 SysexMessage 。

SysexMessage(byte[], int) - Constructor for class javax.sound.midi. SysexMessage

构造新的 SysexMessage并设置消息的数据。

SysexMessage(int, byte[], int) - Constructor for class javax.sound.midi. SysexMessage

构造新的 SysexMessage并设置消息的数据。

system(ZoneId) - Static method in class java.time. Clock

获取使用最佳可用系统时钟返回当前即时的时钟。

System - Class in java.lang

System类包含几个有用的类字段和方法。

SYSTEM - Static variable in interface javax.swing.text.html.parser. DTDConstants

DTD常数对应于SYSTEM

SYSTEM_EXCEPTION - Interface in org.omg.PortableInterceptor

org / omg / PortableInterceptor / SYSTEM_EXCEPTION.java。

SYSTEM_EXCLUSIVE - Static variable in class javax.sound.midi. SysexMessage

系统独占消息（0xF0或240）的状态字节。

SYSTEM_ID - Static variable in class org.omg.PortableServer. IdAssignmentPolicyValue

SYSTEM_MODULES - javax.tools. StandardLocation

搜索系统模块的位置。

SYSTEM_PORT - Static variable in interface java.rmi.activation. ActivationSystem

查找激活系统的端口。

SYSTEM_RESET - Static variable in class javax.sound.midi. ShortMessage

系统复位消息的状态字节（0xFF或255）。

System.Logger - Interface in java.lang

System.Logger实例日志消息将路由到底层日志框架LoggerFinder使用。

System.Logger.Level - Enum in java.lang

系统loggers级别。

System.LoggerFinder - Class in java.lang

LoggerFinder服务负责创建，管理和配置记录器到其使用的基础框架。

systemAboutToSleep(SystemSleepEvent) - Method in interface java.awt.desktop. SystemSleepListener

当系统即将睡觉时调用。

systemAwoke(SystemSleepEvent) - Method in interface java.awt.desktop. SystemSleepListener

系统唤醒后唤醒睡眠。

SystemColor - Class in java.awt

封装代表系统上本地GUI对象颜色的符号颜色的类。

systemDefault() - Static method in class java.time. ZoneId

获取系统默认时区。

systemDefaultZone() - Static method in class java.time. Clock

获取使用最佳可用系统时钟返回当前即时的时钟，使用默认时区转换为日期和时间。

SystemEventListener - Interface in java.awt.desktop

所有事件监听器子类的公共接口。

SystemException - Exception in org.omg.CORBA

所有CORBA标准异常的根类。

SystemException(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. SystemException

构造具有指定的详细消息，次要代码和完成状态的 SystemException异常。

SystemFlavorMap - Class in java.awt.datatransfer

SystemFlavorMap是与“平台”特定的数据格式相对应的“本地”（Stratives）和与平台无关的MIME类型对应的“风格”（DataFlavors）之间的可配置映射。

SystemMenuBar() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.SystemMenuBar

systemNodeForPackage(Class<?>) - Static method in class java.util.prefs. Preferences

从与指定类的包关联（按照约定）的系统首选项树返回首选项节点。

systemRoot() - Static method in class java.util.prefs. Preferences

返回系统的根首选项节点。

systemRoot() - Method in interface java.util.prefs. PreferencesFactory

返回系统根首选项节点。

SystemSleepEvent - Class in java.awt.desktop

系统进入和退出省电休眠时发送的事件。

SystemSleepEvent() - Constructor for class java.awt.desktop. SystemSleepEvent

构造一个SystemSleepEvent

SystemSleepListener - Interface in java.awt.desktop

当系统进入睡眠状态，系统唤醒后，实施者会收到通知。

SystemTray - Class in java.awt

SystemTray类表示桌面的系统托盘。

systemUTC() - Static method in class java.time. Clock

获取使用最佳可用系统时钟返回当前即时的时钟，使用UTC时区转换为日期和时间。

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

Report a bug or suggest an enhancement


T-Index (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

SEARCH:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
T

T - javafx.scene.input. KeyCode

常数为 T键。

T4_OPTIONS_2D_CODING - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“T4Options”标签一起使用的面具。

T4_OPTIONS_EOL_BYTE_ALIGNED - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“T4Options”标签一起使用的面具。

T4_OPTIONS_UNCOMPRESSED - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“T4Options”标签一起使用的面具。

T6_OPTIONS_UNCOMPRESSED - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“T6Options”标签一起使用的面具。

Tab - Class in javafx.scene.control

标签放置在TabPane中 ，其中每个标签代表单个“页面”。

Tab() - Constructor for class javafx.scene.control. Tab

创建没有标题的选项卡。

Tab(String) - Constructor for class javafx.scene.control. Tab

创建一个带有文本标题的选项卡。

Tab(String, Node) - Constructor for class javafx.scene.control. Tab

创建一个带有文本标题和指定内容节点的选项卡。

TAB - javafx.scene.input. KeyCode

常数为 Tab键。

TAB - Static variable in class java.awt. Event

已过时。

Tab键。

TAB_CLOSE_REQUEST_EVENT - Static variable in class javafx.scene.control. Tab

当有外部请求关闭这个 Tab 。

TAB_ITEM - javafx.scene. AccessibleRole

选项卡项目角色。

TAB_PANE - javafx.scene. AccessibleRole

Tab窗格角色。

TabableView - Interface in javax.swing.text

接口为 View s，具有取决于选项卡的大小。

tabAreaBackground - Variable in class javax.swing.plaf.metal. MetalTabbedPaneUI

标签背景的颜色。

tabAreaInsets - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

标签区域插入

TABBED_PANE - Static variable in class javax.swing.plaf.synth. Region

TabbedPane区域。

TABBED_PANE_CONTENT - Static variable in class javax.swing.plaf.synth. Region

包含内容的TabbedPane的区域。

TABBED_PANE_TAB - Static variable in class javax.swing.plaf.synth. Region

一个选项卡的TabbedPane的区域。

TABBED_PANE_TAB_AREA - Static variable in class javax.swing.plaf.synth. Region

包含选项卡的TabbedPane的区域。

TabbedPaneLayout() - Constructor for class javax.swing.plaf.basic. BasicTabbedPaneUI.TabbedPaneLayout

TabbedPaneLayout() - Constructor for class javax.swing.plaf.metal. MetalTabbedPaneUI.TabbedPaneLayout

构造 TabbedPaneLayout 。

TabbedPaneUI - Class in javax.swing.plaf

JTabbedPane可插拔的外观和界面。

TabbedPaneUI() - Constructor for class javax.swing.plaf. TabbedPaneUI

tabChangeListener - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

标签更改侦听器

tabClosingPolicyProperty() - Method in class javafx.scene.control. TabPane

选项卡的关闭策略。

TabExpander - Interface in javax.swing.text

简单的界面，允许不同类型的标签扩展实现。

tabForCoordinate(JTabbedPane, int, int) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI

返回与JTabbedPane坐标空间中指定点相交的选项卡索引。

tabForCoordinate(JTabbedPane, int, int) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI

在此对象处理的每个UI上调用 tabForCoordinate方法。

tabForCoordinate(JTabbedPane, int, int) - Method in class javax.swing.plaf. TabbedPaneUI

返回坐标的选项卡。

tabInsets - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

标签插入

table - Variable in class javax.swing.plaf.basic. BasicTableUI

实例 JTable 。

table - Variable in class javax.swing.table. JTableHeader

这个对象是头的表; 默认为null 。

TABLE - Static variable in class javax.accessibility. AccessibleRole

用于根据行和列提供信息的对象。

TABLE - Static variable in class javax.swing.plaf.synth. Region

表格区域。

TABLE - Static variable in class javax.swing.text.html. HTML.Tag

标签<table>

TABLE_CELL - javafx.scene. AccessibleRole

表单元格角色。

TABLE_COLUMN - javafx.scene. AccessibleRole

表列角色。

TABLE_HEADER - Static variable in class javax.swing.plaf.synth. Region

TableHeader区域。

TABLE_ROW - javafx.scene. AccessibleRole

表行角色。

TABLE_VIEW - javafx.scene. AccessibleRole

表视图角色。

TableCell< S, T> - Class in javafx.scene.control

在TableView中表示单行/列交集。

TableCell() - Constructor for class javafx.scene.control. TableCell

构造一个默认的TableCell实例，其样式类为“table-cell”

TableCell(Element) - Constructor for class javax.swing.text. TableView.TableCell

已过时。

为给定元素构造一个TableCell。

TableCellEditor - Interface in javax.swing.table

该接口定义的方法，其希望成为值的部件，例如一个编辑器的任何对象 JListBox ， JComboBox ， JTree ，或 JTable需要实现。

TableCellRenderer - Interface in javax.swing.table

该界面定义了任何希望作为 JTable单元格的渲染器的对象所需的方法。

TableCellSkin< S, T> - Class in javafx.scene.control.skin

默认皮肤实现为TableCell控件。

TableCellSkin(TableCell<S, T>) - Constructor for class javafx.scene.control.skin. TableCellSkin

创建一个新的TableCellSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

TableCellSkinBase< S, T, C extends IndexedCell< T>> - Class in javafx.scene.control.skin

表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。

TableCellSkinBase(C) - Constructor for class javafx.scene.control.skin. TableCellSkinBase

创建一个新的TableCellSkinBase实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

tableChanged(TableModelEvent) - Method in interface javax.swing.event. TableModelListener

这个细粒度通知告诉侦听器更改的单元格，行或列的精确范围。

tableChanged(TableModelEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪表内容的更改

tableChanged(TableModelEvent) - Method in class javax.swing. JTable

当此表的 TableModel生成一个 TableModelEvent时调用。

TableColumn< S, T> - Class in javafx.scene.control

A TableView由多个TableColumn实例组成。

TableColumn - Class in javax.swing.table

甲 TableColumn表示在所述列的所有属性 JTable ，诸如宽度，可调整大小，最小和最大宽度。

TableColumn() - Constructor for class javafx.scene.control. TableColumn

使用默认单元格工厂，比较器和onEditCommit实现创建默认的TableColumn。

TableColumn() - Constructor for class javax.swing.table. TableColumn

Cover方法，使用默认模型索引为0，默认宽度为75，一个 null渲染器和一个 null编辑器。

TableColumn(int) - Constructor for class javax.swing.table. TableColumn

Cover方法，使用默认宽度为75，一个 null渲染器和一个 null编辑器。

TableColumn(int, int) - Constructor for class javax.swing.table. TableColumn

封面方法，使用 null渲染器和一个 null编辑器。

TableColumn(int, int, TableCellRenderer, TableCellEditor) - Constructor for class javax.swing.table. TableColumn

使用指定的模型索引，宽度，单元格渲染器和单元格编辑器创建和初始化一个TableColumn的实例; 所有TableColumn构造函数都委托给这个。

TableColumn(String) - Constructor for class javafx.scene.control. TableColumn

创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

TableColumn.CellDataFeatures< S, T> - Class in javafx.scene.control

在TableColumn中使用的支持类作为包装器类，为特定的Cell提供所有必要的信息。

TableColumn.CellEditEvent< S, T> - Class in javafx.scene.control

用户在表单元格上执行编辑时触发的事件。

TableColumn.SortType - Enum in javafx.scene.control

枚举，指定应用于特定列的排序类型。

TableColumnBase< S, T> - Class in javafx.scene.control

表类控件（如TableView和TreeTableView ）由零个或多个具体TableColumnBase子类（ TableColumn和TreeTableColumn ）的实例组成。

TableColumnBase() - Constructor for class javafx.scene.control. TableColumnBase

使用默认单元格工厂，比较器和onEditCommit实现创建默认的TableColumn。

TableColumnBase(String) - Constructor for class javafx.scene.control. TableColumnBase

创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

TableColumnHeader - Class in javafx.scene.control.skin

负责绘制单列标题的区域。

TableColumnHeader(TableColumnBase) - Constructor for class javafx.scene.control.skin. TableColumnHeader

创建一个新的TableColumnHeader实例来可视化地表示给定的TableColumnBase实例。

TableColumnModel - Interface in javax.swing.table

定义适用于 JTable的表列模型对象的要求。

TableColumnModelEvent - Class in javax.swing.event

TableColumnModelEvent用于通知侦听器表列模型已更改，例如添加，删除或移动列。

TableColumnModelEvent(TableColumnModel, int, int) - Constructor for class javax.swing.event. TableColumnModelEvent

构造一个 TableColumnModelEvent对象。

TableColumnModelListener - Interface in javax.swing.event

TableColumnModelListener定义了一个监听TableColumnModel中更改的对象的接口。

tableColumnProperty() - Method in class javafx.scene.control.skin. TableCellSkin

负责此单元格的TableColumnBase实例。

tableColumnProperty() - Method in class javafx.scene.control.skin. TableCellSkinBase

负责此单元格的TableColumnBase实例。

tableColumnProperty() - Method in class javafx.scene.control.skin. TableColumnHeader

引用此标题在视觉上表示的TableColumnBase实例的属性。

tableColumnProperty() - Method in class javafx.scene.control.skin. TreeTableCellSkin

负责此单元格的TableColumnBase实例。

tableColumnProperty() - Method in class javafx.scene.control. TableCell

支持此TableCell的TableColumn实例。

tableColumnProperty() - Method in class javafx.scene.control. TreeTableCell

tableColumns - Variable in class javax.swing.table. DefaultTableColumnModel

此模型中的TableColumn对象数组

TableFocusModel< T, TC extends TableColumnBase< T,?>> - Class in javafx.scene.control

FocusModel实现的抽象基类，用于表类控件中（最着名的是TableView和TreeTableView） 。

TableFocusModel() - Constructor for class javafx.scene.control. TableFocusModel

tableHeader - Variable in class javax.swing. JTable

TableHeader使用表。

TableHeaderBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.TableHeaderBorder

TableHeaderRow - Class in javafx.scene.control.skin

负责绘制整列列标题的区域。

TableHeaderRow(TableViewSkinBase) - Constructor for class javafx.scene.control.skin. TableHeaderRow

创建一个新的TableHeaderRow实例来可视化地表示控件的列标题区域，如TableView和TreeTableView 。

TableHeaderUI - Class in javax.swing.plaf

JTableHeader的可插拔外观界面。

TableHeaderUI() - Constructor for class javax.swing.plaf. TableHeaderUI

tableIndexClustered - Static variable in interface java.sql. DatabaseMetaData

表示此表索引是聚簇索引。

tableIndexHashed - Static variable in interface java.sql. DatabaseMetaData

表示此索引是散列索引。

tableIndexOther - Static variable in interface java.sql. DatabaseMetaData

表示此表索引不是聚簇索引，散列索引或表统计信息; 这是其他的东西。

tableIndexStatistic - Static variable in interface java.sql. DatabaseMetaData

表示此列包含与表的索引描述一起返回的表统计信息。

tableMenuButtonVisibleProperty() - Method in class javafx.scene.control. TableView

当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TableColumn的无线菜单项。

tableMenuButtonVisibleProperty() - Method in class javafx.scene.control. TreeTableView

当用户单击TableView中的指定空间时，这可以控制菜单按钮是否可用，其中是该表中每个TreeTableColumn的无线菜单项。

TableModel - Interface in javax.swing.table

TableModel接口指定 JTable将用于查询表格数据模型的方法。

TABLEMODEL - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing TableModel支持（即TableModelListener和TableModelEvent）

TableModelEvent - Class in javax.swing.event

TableModelEvent用于通知侦听器表模型已更改。

TableModelEvent(TableModel) - Constructor for class javax.swing.event. TableModelEvent

表中的所有行数据已更改，侦听器应丢弃基于行的任何状态，并重新查询 TableModel以获取新行计数和所有适当值。

TableModelEvent(TableModel, int) - Constructor for class javax.swing.event. TableModelEvent

此行数据已更新。

TableModelEvent(TableModel, int, int) - Constructor for class javax.swing.event. TableModelEvent

行[ firstRow ， lastRow ]中的数据已更新。

TableModelEvent(TableModel, int, int, int) - Constructor for class javax.swing.event. TableModelEvent

范围[ firstRow ， lastRow ]中列 列中的 单元格已更新。

TableModelEvent(TableModel, int, int, int, int) - Constructor for class javax.swing.event. TableModelEvent

（firstRow，column）到（lastRow，column）的单元格已更改。

TableModelListener - Interface in javax.swing.event

TableModelListener定义了一个监听TableModel中更改的对象的接口。

TablePosition< S, T> - Class in javafx.scene.control

此类用于表示TableView中的单个行/列/单元格。

TablePosition(TableView<S>, int, TableColumn<S, T>) - Constructor for class javafx.scene.control. TablePosition

构造一个TablePosition实例来表示给定TableView实例中给定的行/列位置。

TablePositionBase< TC extends TableColumnBase> - Class in javafx.scene.control

此类用于表示表中的单个行/列/单元格。

TablePositionBase(int, TC) - Constructor for class javafx.scene.control. TablePositionBase

构造一个TablePositionBase实例来表示底层表实例中的给定行/列位置（它不是抽象TablePositionBase类的一部分，而是属于具体子类的一部分，如TablePosition和TreeTablePosition ）。

TableRow< T> - Class in javafx.scene.control

TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。

TableRow() - Constructor for class javafx.scene.control. TableRow

构造一个具有“table-row-cell”样式类的默认TableRow实例

TableRow(Element) - Constructor for class javax.swing.text. TableView.TableRow

为给定元素构造TableView。

tableRowProperty() - Method in class javafx.scene.control. TableCell

该TableCow目前发现自己位于的TableRow。

tableRowProperty() - Method in class javafx.scene.control. TreeTableCell

tableRowsDeleted(TableModelEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪表内容的更改（行删除）

tableRowsInserted(TableModelEvent) - Method in class javax.swing. JTable.AccessibleJTable

跟踪表内容的更改（行插入）

TableRowSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为TableRow控件。

TableRowSkin(TableRow<T>) - Constructor for class javafx.scene.control.skin. TableRowSkin

创建一个新的TableRowSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

TableRowSkinBase< T, C extends IndexedCell, R extends IndexedCell> - Class in javafx.scene.control.skin

TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。

TableRowSkinBase(C) - Constructor for class javafx.scene.control.skin. TableRowSkinBase

创建一个新的TableRowSkinBase实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。

TableRowSorter< M extends TableModel> - Class in javax.swing.table

RowSorter一个实现，它使用 TableModel提供排序和过滤。

TableRowSorter() - Constructor for class javax.swing.table. TableRowSorter

创建一个空的模型 TableRowSorter 。

TableRowSorter(M) - Constructor for class javax.swing.table. TableRowSorter

创建 TableRowSorter使用 model作为底层的 TableModel 。

TableSelectionModel< T> - Class in javafx.scene.control

在表类控件中使用的MultipleSelectionModel实现的抽象基类（最着名的是TableView和TreeTableView） 。

TableSelectionModel() - Constructor for class javafx.scene.control. TableSelectionModel

TableStringConverter - Class in javax.swing.table

TableStringConverter用于将模型中的对象转换为字符串。

TableStringConverter() - Constructor for class javax.swing.table. TableStringConverter

TableUI - Class in javax.swing.plaf

JTable可插拔的外观和界面。

TableUI() - Constructor for class javax.swing.plaf. TableUI

TableView< S> - Class in javafx.scene.control

TableView控件旨在可视化无限数量的数据行，分为列。

TableView - Class in javax.swing.text

实现一个表的视图界面，它由元素结构组成，该视图的元素的子元素负责表示行，行元素的子元素是单元格。

TableView() - Constructor for class javafx.scene.control. TableView

创建一个没有内容的默认TableView控件。

TableView(ObservableList<S>) - Constructor for class javafx.scene.control. TableView

使用ObservableList项中提供的内容创建TableView。

TableView(Element) - Constructor for class javax.swing.text. TableView

为给定元素构造TableView。

TableView.ResizeFeatures< S> - Class in javafx.scene.control

用于TableView column resize功能的不可变包装类。

TableView.TableCell - Class in javax.swing.text

已过时。
一个表单元格现在可以是任何View实现。

TableView.TableRow - Class in javax.swing.text

以行为中心的表格中的行的视图。

TableView.TableViewFocusModel< S> - Class in javafx.scene.control

A FocusModel具有附加功能以支持TableView控件的要求。

TableView.TableViewSelectionModel< S> - Class in javafx.scene.control

SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。

TableViewFocusModel(TableView<S>) - Constructor for class javafx.scene.control. TableView.TableViewFocusModel

创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。

tableViewProperty() - Method in class javafx.scene.control. TableCell

TableView与此TableCell关联。

tableViewProperty() - Method in class javafx.scene.control. TableColumn

TableView这个TableColumn属于。

tableViewProperty() - Method in class javafx.scene.control. TableRow

与此Cell关联的TableView。

TableViewSelectionModel(TableView<S>) - Constructor for class javafx.scene.control. TableView.TableViewSelectionModel

使用提供的TableView构建默认的TableViewSelectionModel实例。

TableViewSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为TableView控件。

TableViewSkin(TableView<T>) - Constructor for class javafx.scene.control.skin. TableViewSkin

创建一个新的TableViewSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

TableViewSkinBase< M, S, C extends Control, I extends IndexedCell< M>, TC extends TableColumnBase< S,?>> - Class in javafx.scene.control.skin

TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。

TableViewSkinBase(C) - Constructor for class javafx.scene.control.skin. TableViewSkinBase

TABLOID - Static variable in class java.awt. PageAttributes.MediaType

LEDGER的别名。

TABLOID - Static variable in class javafx.print. Paper

指定小时大小，11英寸×17英寸。

TABLOID - Static variable in class javax.print.attribute.standard. MediaSize.Other

指定小时大小，11英寸×17英寸。

TABLOID - Static variable in class javax.print.attribute.standard. MediaSizeName

小报大小。

tabMaxHeightProperty() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最大高度。

tabMaxWidthProperty() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最大宽度。

tabMinHeightProperty() - Method in class javafx.scene.control. TabPane

标签的最小高度。

tabMinWidthProperty() - Method in class javafx.scene.control. TabPane

TabPane中选项卡的最小宽度。

tabPane - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

选项卡窗格

TabPane - Class in javafx.scene.control

允许在一组Tabs之间切换的控件 。

TabPane() - Constructor for class javafx.scene.control. TabPane

构造一个新的TabPane。

TabPane(Tab...) - Constructor for class javafx.scene.control. TabPane

构造一个新的TabPane，其中给定的选项卡设置为显示。

TabPane.TabClosingPolicy - Enum in javafx.scene.control

这指定了TabPane如何处理从最终用户角度看待标签关闭。

tabPaneProperty() - Method in class javafx.scene.control. Tab

包含此选项卡的TabPane。

TabPaneSkin - Class in javafx.scene.control.skin

默认皮肤实现为TabPane控件。

TabPaneSkin(TabPane) - Constructor for class javafx.scene.control.skin. TabPaneSkin

创建一个新的TabPaneSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

tabPlacement - Variable in class javax.swing. JTabbedPane

放置标签的位置

tabRunOverlay - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

标签运行叠加

tabRuns - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

标签运行

TabSelectionHandler() - Constructor for class javax.swing.plaf.basic. BasicTabbedPaneUI.TabSelectionHandler

TabSet - Class in javax.swing.text

TabSet由许多TabStops组成。

TabSet - Static variable in class javax.swing.text. StyleConstants

该类型为TabSet的类型为TabStops。

TabSet(TabStop[]) - Constructor for class javax.swing.text. TabSet

创建并返回TabSet的实例。

tabSizeAttribute - Static variable in class javax.swing.text. PlainDocument

指定内容中包含的标签的标签大小的属性名称。

TabStop - Class in javax.swing.text

这个类封装了一个制表符停止（基本上就是标签停止被RTF认为）。

TabStop(float) - Constructor for class javax.swing.text. TabStop

在位置 pos创建一个选项卡，其中包含默认对齐方式和默认值。

TabStop(float, int, int) - Constructor for class javax.swing.text. TabStop

创建具有指定位置的选项卡 pos ，对齐 align和 leader 。

TabularData - Interface in javax.management.openmbean

TabularData接口指定表示 表格数据结构的特定类型的复杂 开放数据对象的行为。

TabularDataSupport - Class in javax.management.openmbean

TabularDataSupport类是 开放数据类，它实现 TabularData和 Map接口，内部是基于哈希映射数据结构的。

TabularDataSupport(TabularType) - Constructor for class javax.management.openmbean. TabularDataSupport

创建一个空的 TabularDataSupport实例，其open-type是 tabularType ，底层的 HashMap具有默认初始容量（101）和默认负载因子（0.75）。

TabularDataSupport(TabularType, int, float) - Constructor for class javax.management.openmbean. TabularDataSupport

创建一个空的 TabularDataSupport实例，其open-type是 tabularType ，其底层 HashMap具有指定的初始容量和负载因子。

TabularType - Class in javax.management.openmbean

TabularType类是开放类，其实例描述了TabularData的类型。

TabularType(String, String, CompositeType, String[]) - Constructor for class javax.management.openmbean. TabularType

构造一个 TabularType实例，检查给定参数的有效性。

tag - Variable in class org.omg.IOP. TaggedComponent

标签，表示为组件ID。

tag - Variable in class org.omg.IOP. TaggedProfile

标签，表示为配置文件ID。

Tag - Interface in com.sun.javadoc

已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

Tag() - Constructor for class javax.swing.text.html. HTML.Tag

Tag(String) - Constructor for class javax.swing.text.html. HTML.Tag

创建一个新的 Tag与指定的 id ，并与 causesBreak和 isBlock设置为 false 。

Tag(String, boolean, boolean) - Constructor for class javax.swing.text.html. HTML.Tag

创建一个新的Tag与指定的id ; causesBreak和isBlock由用户定义。

TAG_ACNT - Static variable in interface java.awt.font. OpenType

重音附件。

TAG_ALTERNATE_IIOP_ADDRESS - Interface in org.omg.IOP

org / omg / IOP / TAG_ALTERNATE_IIOP_ADDRESS.java。

TAG_APERTURE_VALUE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示镜头光圈的标签（类型RATIONAL）。

TAG_ARTIST - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“艺术家”标签的常数。

TAG_AVAR - Static variable in interface java.awt.font. OpenType

轴变化。

TAG_BAD_FAX_LINES - Static variable in class javax.imageio.plugins.tiff. FaxTIFFTagSet

指示不良传真线路数量的标签（类型为短或长）。

TAG_BASE - Static variable in interface java.awt.font. OpenType

基准数据

TAG_BDAT - Static variable in interface java.awt.font. OpenType

位图数据。

TAG_BITS_PER_SAMPLE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“BitsPerSample”标记的常量。

TAG_BLOC - Static variable in interface java.awt.font. OpenType

位图位置。

TAG_BRIGHTNESS_VALUE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示亮度值的标签（类型SRATIONAL）。

TAG_BSLN - Static variable in interface java.awt.font. OpenType

基线表。

TAG_CELL_LENGTH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“cell_length”标签的常量。

TAG_CELL_WIDTH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Cell_Width”标签的常量。

TAG_CFA_PATTERN - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示当使用单芯片彩色区域传感器（类型UNDEFINED）时图像传感器的滤色器阵列几何图案的标签。

TAG_CFF - Static variable in interface java.awt.font. OpenType

紧凑字体格式（Type1字体）。

TAG_CLEAN_FAX_DATA - Static variable in class javax.imageio.plugins.tiff. FaxTIFFTagSet

标签表示干净传真数据的行数（类型为SHORT）。

TAG_CMAP - Static variable in interface java.awt.font. OpenType

字符到字形映射。

TAG_CODE_SETS - Interface in org.omg.IOP

org / omg / IOP / TAG_CODE_SETS.java。

TAG_COLOR_MAP - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“ColorMap”标签。

TAG_COLOR_SPACE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示颜色空间信息的标签（类型为SHORT）。

TAG_COMPONENTS_CONFIGURATION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

包含组件配置信息（类型UNDEFINED，count = 4）的标签。

TAG_COMPRESSED_BITS_PER_PIXEL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示每像素的压缩比特数的标签（类型RATIONAL）。

TAG_COMPRESSION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“压缩”标签的常量。

TAG_CONSECUTIVE_BAD_LINES - Static variable in class javax.imageio.plugins.tiff. FaxTIFFTagSet

指示连续不良行的数量的标签（类型为SHORT或LONG）。

TAG_CONTRAST - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示拍摄图像时由相机应用的对比度处理方向的标签。

TAG_COPYRIGHT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“版权”标签的常数。

TAG_CUSTOM_RENDERED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示对图像数据使用特殊处理的标签，例如用于输出的渲染。

TAG_CVAR - Static variable in interface java.awt.font. OpenType

CVT变化。

TAG_CVT - Static variable in interface java.awt.font. OpenType

控制值表。

TAG_DATE_TIME - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“DateTime”标签。

TAG_DATE_TIME_DIGITIZED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示图像作为数字数据存储的日期和时间的标签（ASCII类型）。

TAG_DATE_TIME_ORIGINAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示生成原始图像的日期和时间的标签（ASCII码）。

TAG_DEVICE_SETTING_DESCRIPTION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示特定相机模型的拍摄条件的信息的标签。

TAG_DIGITAL_ZOOM_RATIO - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示拍摄图像时的数码变焦比的标签。

TAG_DOCUMENT_NAME - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“document_name”标签的常量。

TAG_DOT_RANGE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“DotRange”标签。

TAG_DSIG - Static variable in interface java.awt.font. OpenType

电子签名。

TAG_EBDT - Static variable in interface java.awt.font. OpenType

嵌入式位图数据。

TAG_EBLC - Static variable in interface java.awt.font. OpenType

嵌入式位图位置。

TAG_EBSC - Static variable in interface java.awt.font. OpenType

嵌入式位图缩放。

TAG_EXIF_IFD_POINTER - Static variable in class javax.imageio.plugins.tiff. ExifParentTIFFTagSet

标签指向Exif IFD（类型LONG）。

TAG_EXIF_VERSION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

包含Exif版本号（类型UNDEFINED，count = 4）的标签。

TAG_EXPOSURE_BIAS_VALUE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示曝光偏差的标签（类型SRATIONAL）。

TAG_EXPOSURE_INDEX - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示在拍摄图像时在相机或输入设备上选择的曝光指数的标签（类型为RATIONAL）的标签。

TAG_EXPOSURE_MODE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示拍摄图像时设置的曝光模式的标签。

TAG_EXPOSURE_PROGRAM - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示拍摄照片时用于设置曝光的节目类别的标签（类型为SHORT）。

TAG_EXPOSURE_TIME - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示曝光时间的标签（以秒为单位）（类型为RATIONAL）。

TAG_EXTRA_SAMPLES - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“ExtraSamples”标签的常量。

TAG_F_NUMBER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示F数字的标签（类型RATIONAL）。

TAG_FDSC - Static variable in interface java.awt.font. OpenType

字体描述符。

TAG_FEAT - Static variable in interface java.awt.font. OpenType

功能名称

TAG_FILE_SOURCE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示图像源（类型UNDEFINED）的标签。

TAG_FILL_ORDER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“fill_order”标签。

TAG_FLASH - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示闪光灯闪光状态和闪光灯返回状态的标签（类型为SHORT）。

TAG_FLASH_ENERGY - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示拍摄图像时的频闪能量的标签，如“光束功率秒（BCPS）”（类型RATIONAL）所测量。

TAG_FLASHPIX_VERSION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示FlashPix版本号（类型UNDEFINED，count = 4）的标签。

TAG_FMTX - Static variable in interface java.awt.font. OpenType

字体指标。

TAG_FOCAL_LENGTH - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示透镜实际焦距的标签，单位为毫米（类型为RATIONAL）。

TAG_FOCAL_LENGTH_IN_35MM_FILM - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

一个标签表示等效焦距，假设为35mm胶片相机，单位为毫米。

TAG_FOCAL_PLANE_RESOLUTION_UNIT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

表示测量FocalPlaneXResolution和FocalPlaneYResolution（键入SHORT）的单位。

TAG_FOCAL_PLANE_X_RESOLUTION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示相机焦平面上的每个FocalPlaneResolutionUnit的图像宽度（X）方向上的像素数（类型为RATIONAL）。

TAG_FOCAL_PLANE_Y_RESOLUTION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示相机焦平面上的每个FocalPlaneResolutionUnit的图像高度（Y）方向上的像素数（类型为RATIONAL）。

TAG_FPGM - Static variable in interface java.awt.font. OpenType

字体程序。

TAG_FREE_BYTE_COUNTS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“FreeByteCounts”标签。

TAG_FREE_OFFSETS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“FreeOffset”标签。

TAG_FVAR - Static variable in interface java.awt.font. OpenType

字体变体。

TAG_GAIN_CONTROL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示整体图像增益调整程度的标签。

TAG_GASP - Static variable in interface java.awt.font. OpenType

网格拟合和扫描转换程序。

TAG_GDEF - Static variable in interface java.awt.font. OpenType

字形定义。

TAG_GEO_ASCII_PARAMS - Static variable in class javax.imageio.plugins.tiff. GeoTIFFTagSet

用于存储所有ASCII值的 标签GeoKey s的标签。

TAG_GEO_DOUBLE_PARAMS - Static variable in class javax.imageio.plugins.tiff. GeoTIFFTagSet

用于存储所有 double GeoKey s的标签。

TAG_GEO_KEY_DIRECTORY - Static variable in class javax.imageio.plugins.tiff. GeoTIFFTagSet

用于存储 GeoKey目录的标签。

TAG_GLYF - Static variable in interface java.awt.font. OpenType

字形数据。

TAG_GPOS - Static variable in interface java.awt.font. OpenType

字形定位

TAG_GPS_ALTITUDE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示海拔高度（RATIONAL，count = 1）的标签。

TAG_GPS_ALTITUDE_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示高度参考的标签（类型BYTE，count = 1）;

TAG_GPS_AREA_INFORMATION - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS区域名称的标签（类型UNDEFINED）。

TAG_GPS_DATE_STAMP - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS日期的标签（类型ASCII，计数11）。

TAG_GPS_DEST_BEARING - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示目的地轴承的标签（类型为RATIONAL，count = 1）。

TAG_GPS_DEST_BEARING_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示目的地的轴承参考的标签（ASCII，count = 2）。

TAG_GPS_DEST_DISTANCE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示与目的地的距离（类型为RATIONAL，count = 1）的标签。

TAG_GPS_DEST_DISTANCE_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示距离目的地的参考的标签（ASCII，count = 2）。

TAG_GPS_DEST_LATITUDE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示目的地纬度的标签（类型为RATIONAL，count = 3）。

TAG_GPS_DEST_LATITUDE_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示目的地纬度参考的标签（ASCII，count = 2）。

TAG_GPS_DEST_LONGITUDE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示目的地经度的标签（类型为RATIONAL，count = 3）。

TAG_GPS_DEST_LONGITUDE_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示目的地经度参考的标签（ASCII，count = 2）。

TAG_GPS_DIFFERENTIAL - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS差分校正的标签（类型SHORT，计数= 1）。

TAG_GPS_DOP - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示测量精度的标签（类型RATIONAL，count = 1）。

TAG_GPS_IMG_DIRECTION - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示图像方向的标签（类型为RATIONAL，count = 1）。

TAG_GPS_IMG_DIRECTION_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示图像方向参考的标签（ASCII，count = 2）。

TAG_GPS_INFO_IFD_POINTER - Static variable in class javax.imageio.plugins.tiff. ExifParentTIFFTagSet

标签指向GPS信息IFD（类型LONG）。

TAG_GPS_INFO_IFD_POINTER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指向GPS信息IFD（类型LONG）的标签。

TAG_GPS_LATITUDE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示纬度（RATIONAL，count = 3）的标签。

TAG_GPS_LATITUDE_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示北纬或南纬的标签（ASCII，count = 2）。

TAG_GPS_LONGITUDE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示经度的标签（类型为RATIONAL，count = 3）。

TAG_GPS_LONGITUDE_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

表示东经或西经的标签（ASCII，count = 2）。

TAG_GPS_MAP_DATUM - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示使用大地测量数据的标签（ASCII码）。

TAG_GPS_MEASURE_MODE - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS测量模式的标签（ASCII，count = 2）。

TAG_GPS_PROCESSING_METHOD - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS处理方法名称的标签（类型UNDEFINED）。

TAG_GPS_SATELLITES - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示用于测量的GPS卫星的标签（ASCII码）。

TAG_GPS_SPEED - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS接收机速度的标签（类型为RATIONAL，count = 1）。

TAG_GPS_SPEED_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示速度单位的标签（ASCII，count = 2）。

TAG_GPS_STATUS - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS接收器状态的标签（ASCII，count = 2）。

TAG_GPS_TIME_STAMP - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS时间（原子钟）（RATIONAL，count = 3）的标签。

TAG_GPS_TRACK - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示移动方向的标签（类型为RATIONAL，count = 1）。

TAG_GPS_TRACK_REF - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示移动方向参考的标签（ASCII，count = 2）。

TAG_GPS_VERSION_ID - Static variable in class javax.imageio.plugins.tiff. ExifGPSTagSet

指示GPS标签版本的标签（类型BYTE，计数= 4）。

TAG_GRAY_RESPONSE_CURVE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“GrayResponseCurve”标签的常量。

TAG_GRAY_RESPONSE_UNIT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“GrayResponseUnit”标签的常量。

TAG_GSUB - Static variable in interface java.awt.font. OpenType

雕文取代

TAG_GVAR - Static variable in interface java.awt.font. OpenType

字形变异。

TAG_HALFTONE_HINTS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“HalftoneHints”标签的常量。

TAG_HDMX - Static variable in interface java.awt.font. OpenType

水平设备指标。

TAG_HEAD - Static variable in interface java.awt.font. OpenType

字体标题

TAG_HHEA - Static variable in interface java.awt.font. OpenType

水平度量标题。

TAG_HMTX - Static variable in interface java.awt.font. OpenType

水平指标。

TAG_HOST_COMPUTER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“HostComputer”标签的常量。

TAG_ICC_PROFILE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“ICC配置文件”标签的常量。

TAG_IMAGE_DESCRIPTION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Image_description”标签的常量。

TAG_IMAGE_LENGTH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“ImageLength”标签。

TAG_IMAGE_UNIQUE_ID - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示为每个图像唯一地分配的标识符的标签。

TAG_IMAGE_WIDTH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“ImageWidth”标签的常量。

TAG_INK_NAMES - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“InkNames”标签的常量。

TAG_INK_SET - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“InkSet”标签。

TAG_INTERNET_IOP - Interface in org.omg.IOP

org / omg / IOP / TAG_INTERNET_IOP.java。

TAG_INTEROPERABILITY_IFD_POINTER - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指向互操作性IFD（类型LONG）的标签。

TAG_INTEROPERABILITY_INDEX - Static variable in class javax.imageio.plugins.tiff. ExifInteroperabilityTagSet

指示互操作性规则（ASCII类型）的标识的标签。

TAG_ISO_SPEED_RATINGS - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示ISO 12232 xiv （类型SHORT）中规定的相机或输入设备的ISO感光度和ISO纬度的标签。

TAG_JAVA_CODEBASE - Interface in org.omg.IOP

org / omg / IOP / TAG_JAVA_CODEBASE.java。

TAG_JPEG_AC_TABLES - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“JPEGACTables”标签的常量。

TAG_JPEG_DC_TABLES - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“JPEGDCTables”标签。

TAG_JPEG_INTERCHANGE_FORMAT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“JPEGInterchangeFormat”标签的常量。

TAG_JPEG_INTERCHANGE_FORMAT_LENGTH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“JPEGInterchangeFormatLength”标签。

TAG_JPEG_LOSSLESS_PREDICTORS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“JPEGLosslessPredictors”标签的常量。

TAG_JPEG_POINT_TRANSFORMS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“JPEGPointTransforms”标签。

TAG_JPEG_PROC - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“JPEGProc”标签。

TAG_JPEG_Q_TABLES - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“JPEGQTables”标签的常量。

TAG_JPEG_RESTART_INTERVAL - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“JPEGRestartInterval”标记的常量。

TAG_JPEG_TABLES - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“JPEGTables”标签。

TAG_JSTF - Static variable in interface java.awt.font. OpenType

理由。

TAG_JUST - Static variable in interface java.awt.font. OpenType

理由。

TAG_KERN - Static variable in interface java.awt.font. OpenType

字距。

TAG_LCAR - Static variable in interface java.awt.font. OpenType

特征插入符号。

TAG_LIGHT_SOURCE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示光源类型的标签（类型为SHORT）。

TAG_LOCA - Static variable in interface java.awt.font. OpenType

位置索引

TAG_LTSH - Static variable in interface java.awt.font. OpenType

线性阈值。

TAG_MAKE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Make”标签的常量。

TAG_MAKER_NOTE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示制造商定义的制造商注释（类型UNDEFINED）的标签。

TAG_MARKER_NOTE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示制造商定义的标记笔记（类型UNDEFINED）的标签。

TAG_MAX_APERTURE_VALUE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示镜头最小F数的标签（类型RATIONAL）。

TAG_MAX_SAMPLE_VALUE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Max_sample_value”标记的常量。

TAG_MAXP - Static variable in interface java.awt.font. OpenType

最大配置文件

TAG_METERING_MODE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示测光模式的标签（类型为SHORT）。

TAG_MIN_SAMPLE_VALUE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Min_sample_value”标签的常量。

TAG_MMFX - Static variable in interface java.awt.font. OpenType

多个主字体指标。

TAG_MMSD - Static variable in interface java.awt.font. OpenType

多个主要补充数据。

TAG_MODEL - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“模型”标签。

TAG_MODEL_PIXEL_SCALE - Static variable in class javax.imageio.plugins.tiff. GeoTIFFTagSet

用于在模型空间单位中指定栅格像素间距的大小的标签。

TAG_MODEL_TIE_POINT - Static variable in class javax.imageio.plugins.tiff. GeoTIFFTagSet

用于存储光栅到模型tiepoint对的标签。

TAG_MODEL_TRANSFORMATION - Static variable in class javax.imageio.plugins.tiff. GeoTIFFTagSet

用于指定光栅空间和模型空间之间的转换矩阵的标记。

TAG_MORT - Static variable in interface java.awt.font. OpenType

雕文变态

TAG_MULTIPLE_COMPONENTS - Interface in org.omg.IOP

org / omg / IOP / TAG_MULTIPLE_COMPONENTS.java。

TAG_NAME - Static variable in interface java.awt.font. OpenType

命名表。

TAG_NEW_SUBFILE_TYPE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“NewSubfileType”标签。

TAG_NUMBER_OF_INKS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“NumberOfInks”标签。

TAG_OECF - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示ISO 14254 xv （类型UNDEFINED）中规定的光电转换功能的标签。

TAG_OPBD - Static variable in interface java.awt.font. OpenType

光学界限。

TAG_ORB_TYPE - Interface in org.omg.IOP

org / omg / IOP / TAG_ORB_TYPE.java。

TAG_ORIENTATION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“方向”标签。

TAG_OS2 - Static variable in interface java.awt.font. OpenType

OS / 2和Windows特定指标。

TAG_PAGE_NAME - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“PageName”标签。

TAG_PAGE_NUMBER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“PageNumber”标签的常量。

TAG_PCLT - Static variable in interface java.awt.font. OpenType

PCL 5数据。

TAG_PHOTOMETRIC_INTERPRETATION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“光度测量解释”标签的常数。

TAG_PIXEL_X_DIMENSION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示像素X尺寸的标签（类型为SHORT或LONG）。

TAG_PIXEL_Y_DIMENSION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示像素Y尺寸的标签（类型为SHORT或LONG）。

TAG_PLANAR_CONFIGURATION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“PlanarConfiguration”标签。

TAG_POLICIES - Interface in org.omg.IOP

org / omg / IOP / TAG_POLICIES.java。

TAG_POST - Static variable in interface java.awt.font. OpenType

PostScript信息。

TAG_PREDICTOR - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Predictor”标签的常量。

TAG_PREP - Static variable in interface java.awt.font. OpenType

CVT预制程序。

TAG_PRIMARY_CHROMATICITES - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“PrimaryChromaticites”标签。

TAG_PROP - Static variable in interface java.awt.font. OpenType

雕文属性。

TAG_REFERENCE_BLACK_WHITE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“ReferenceBlackWhite”标签的常量。

TAG_RELATED_SOUND_FILE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示相关声音文件名称的标签（类型为ASCII）。

TAG_RESOLUTION_UNIT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“ResolutionUnit”标签的常量。

TAG_RMI_CUSTOM_MAX_STREAM_FORMAT - Interface in org.omg.IOP

org / omg / IOP / TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java。

TAG_ROWS_PER_STRIP - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Rows_per_strip”标签的常量。

TAG_S_MAX_SAMPLE_VALUE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“SMaxSampleValue”标签的常量。

TAG_S_MIN_SAMPLE_VALUE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“SMinSampleValue”标签的常量。

TAG_SAMPLE_FORMAT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“SampleFormat”标签。

TAG_SAMPLES_PER_PIXEL - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Samples_per_pixel”标签的常量。

TAG_SATURATION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示拍摄图像时照相机应用的饱和度处理方向的标签。

TAG_SCENE_CAPTURE_TYPE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示被拍摄的场景的类型的标签。

TAG_SCENE_TYPE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示场景类型的标签（UNDEFINED类型）。

TAG_SENSING_METHOD - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示相机或输入设备上传感器类型的标签（类型为SHORT）。

TAG_SHARPNESS - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示当拍摄图像时由照相机应用的清晰度处理的方向的标签。

TAG_SHUTTER_SPEED_VALUE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示快门速度的标签（类型SRATIONAL）。

TAG_SOFTWARE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“软件”标签。

TAG_SPATIAL_FREQUENCY_RESPONSE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

根据ISO 12233 xvi （类型UNDEFINED）中指定的指示照相机或输入设备空间频率表和图像宽度，图像高度和对角线方向方向上的SFR值的标签。

TAG_SPECTRAL_SENSITIVITY - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示所使用的相机的每个通道的光谱灵敏度的标签（类型ASCII）。

TAG_STRIP_BYTE_COUNTS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Strip_byte_counts”标签的常量。

TAG_STRIP_OFFSETS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“Strip_offsets”标签的常量。

TAG_SUB_SEC_TIME - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

用于记录“DateTime”标签（ASCII类型）的秒数的标签。

TAG_SUB_SEC_TIME_DIGITIZED - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

用于记录“DateTimeDigitized”标签（ASCII类型）的秒数的标签。

TAG_SUB_SEC_TIME_ORIGINAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

用于记录“DateTimeOriginal”标记（ASCII类型）的秒数的标签。

TAG_SUBFILE_TYPE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“SubfileType”标签的常量。

TAG_SUBJECT_AREA - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示整个场景中主要被摄体的位置和面积的标签。

TAG_SUBJECT_DISTANCE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示与被摄体距离的标签，以米为单位（类型为RATIONAL）。

TAG_SUBJECT_DISTANCE_RANGE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示与被摄体距离的标签。

TAG_SUBJECT_LOCATION - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示场景中主要被摄体的中心像素的列和行的标签（类型SHORT，count = 2）。

TAG_T4_OPTIONS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“T4Options”标签。

TAG_T6_OPTIONS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“T6Options”标签。

TAG_TARGET_PRINTER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“TargetPrinter”标签的常量。

TAG_THRESHHOLDING - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“阈值”标签的常数。

TAG_TILE_BYTE_COUNTS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“TileByteCounts”标签。

TAG_TILE_LENGTH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“TileLength”标签。

TAG_TILE_OFFSETS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“TileOffset”标签。

TAG_TILE_WIDTH - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“TileWidth”标签。

TAG_TRAK - Static variable in interface java.awt.font. OpenType

跟踪。

TAG_TRANSFER_FUNCTION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“TransferFunction”标签的常量。

TAG_TRANSFER_RANGE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“TransferRange”标签的常量。

TAG_TYP1 - Static variable in interface java.awt.font. OpenType

Adobe Type 1字体数据。

TAG_USER_COMMENT - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示用户评论的标签（类型UNDEFINED）。

TAG_VDMX - Static variable in interface java.awt.font. OpenType

垂直设备指标。

TAG_VHEA - Static variable in interface java.awt.font. OpenType

垂直度量标题。

TAG_VMTX - Static variable in interface java.awt.font. OpenType

垂直指标。

TAG_WHITE_BALANCE - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet

指示拍摄图像时设置的白平衡模式的标签。

TAG_WHITE_POINT - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“白点”标签。

TAG_X_POSITION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“XPosition”标签的常量。

TAG_X_RESOLUTION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“XResolution”标签。

TAG_Y_CB_CR_COEFFICIENTS - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“YCbCrCoefficients”标签的常量。

TAG_Y_CB_CR_POSITIONING - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“YCbCrPositioning”标签。

TAG_Y_CB_CR_SUBSAMPLING - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“YCbCrSubsampling”标签的常量。

TAG_Y_POSITION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

常量指定“YPosition”标签。

TAG_Y_RESOLUTION - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

指定“YResolution”标签的常量。

TagAction() - Constructor for class javax.swing.text.html. HTMLDocument.HTMLReader.TagAction

TAGALOG - java.lang. Character.UnicodeScript

Unicode脚本“他加禄语”。

TAGALOG - Static variable in class java.lang. Character.UnicodeBlock

“Tagalog”Unicode字符块的常量。

TAGBANWA - java.lang. Character.UnicodeScript

Unicode脚本“Tagbanwa”。

TAGBANWA - Static variable in class java.lang. Character.UnicodeBlock

“Tagbanwa”Unicode字符块的常量。

TagElement - Class in javax.swing.text.html.parser

通用的HTML TagElement类。

TagElement(Element) - Constructor for class javax.swing.text.html.parser. TagElement

创建一个通用的HTML TagElement类，其中 fictional等于 false 。

TagElement(Element, boolean) - Constructor for class javax.swing.text.html.parser. TagElement

创建一个通用的HTML TagElement类。

TaggedComponent - Class in org.omg.IOP

org / omg / IOP / TaggedComponent.java。

TaggedComponent() - Constructor for class org.omg.IOP. TaggedComponent

TaggedComponent(int, byte[]) - Constructor for class org.omg.IOP. TaggedComponent

TaggedComponentHelper - Class in org.omg.IOP

org / omg / IOP / TaggedComponentHelper.java。

TaggedComponentHelper() - Constructor for class org.omg.IOP. TaggedComponentHelper

TaggedComponentHolder - Class in org.omg.IOP

org / omg / IOP / TaggedComponentHolder.java。

TaggedComponentHolder() - Constructor for class org.omg.IOP. TaggedComponentHolder

TaggedComponentHolder(TaggedComponent) - Constructor for class org.omg.IOP. TaggedComponentHolder

TaggedProfile - Class in org.omg.IOP

org / omg / IOP / TaggedProfile.java。

TaggedProfile() - Constructor for class org.omg.IOP. TaggedProfile

TaggedProfile(int, byte[]) - Constructor for class org.omg.IOP. TaggedProfile

TaggedProfileHelper - Class in org.omg.IOP

org / omg / IOP / TaggedProfileHelper.java。

TaggedProfileHelper() - Constructor for class org.omg.IOP. TaggedProfileHelper

TaggedProfileHolder - Class in org.omg.IOP

org / omg / IOP / TaggedProfileHolder.java。

TaggedProfileHolder() - Constructor for class org.omg.IOP. TaggedProfileHolder

TaggedProfileHolder(TaggedProfile) - Constructor for class org.omg.IOP. TaggedProfileHolder

Taglet - Interface in com.sun.tools.doclets

已过时。
此接口已被替换， Taglet取代。

Taglet - Interface in jdk.javadoc.doclet

由doclet支持的自定义标签的界面，如standard doclet 。

TAGLET_PATH - javax.tools. DocumentationTool.Location

搜索标签的位置。

Taglet.Location - Enum in jdk.javadoc.doclet

可以使用标签的位置。

tagName - Variable in enum com.sun.source.doctree. DocTree.Kind

与此类节点相关联的标记名称（如果有）。

tags() - Method in interface com.sun.javadoc. Doc

已过时。

返回此文件中的所有标签。

tags(String) - Method in interface com.sun.javadoc. Doc

已过时。

返回本文档中指定的 kind的标签。

TAGS - Static variable in class java.lang. Character.UnicodeBlock

常量为“标签”Unicode字符块。

TAI_LE - java.lang. Character.UnicodeScript

Unicode脚本“Tai_Le”。

TAI_LE - Static variable in class java.lang. Character.UnicodeBlock

常数为“大乐”Unicode字符块。

TAI_THAM - java.lang. Character.UnicodeScript

Unicode脚本“Tai_Tham”。

TAI_THAM - Static variable in class java.lang. Character.UnicodeBlock

“泰泰”Unicode字符块的常数。

TAI_THAM_HORA - java.awt.font. NumericShaper.Range

泰泰霍亚（Tai Tham Hora）系列与泰泰尔（Tai Tham Hora）数位。

TAI_THAM_THAM - java.awt.font. NumericShaper.Range

泰晤士报泰山系列与泰泰泰姆数位。

TAI_VIET - java.lang. Character.UnicodeScript

Unicode脚本“Tai_Viet”。

TAI_VIET - Static variable in class java.lang. Character.UnicodeBlock

常数为“Tai Viet”的Unicode字符块。

TAI_XUAN_JING_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock

常数为“大选京符号”Unicode字符块。

tailMap(K) - Method in interface java.util.concurrent. ConcurrentNavigableMap

tailMap(K) - Method in class java.util.concurrent. ConcurrentSkipListMap

tailMap(K) - Method in interface java.util. NavigableMap

返回此地图部分的视图，其键大于或等于 fromKey 。

tailMap(K) - Method in interface java.util. SortedMap

返回此地图部分的视图，其键大于或等于 fromKey 。

tailMap(K) - Method in class java.util. TreeMap

tailMap(K, boolean) - Method in interface java.util.concurrent. ConcurrentNavigableMap

tailMap(K, boolean) - Method in class java.util.concurrent. ConcurrentSkipListMap

tailMap(K, boolean) - Method in interface java.util. NavigableMap

返回此地图部分的视图，其键大于（或等于，如果 inclusive为真） fromKey 。

tailMap(K, boolean) - Method in class java.util. TreeMap

tailSet(E) - Method in class java.util.concurrent. ConcurrentSkipListSet

tailSet(E) - Method in interface java.util. NavigableSet

返回此集合的部分的视图，该部分的元素大于或等于 fromElement 。

tailSet(E) - Method in interface java.util. SortedSet

返回该集合的元素大于或等于 fromElement的部分的视图。

tailSet(E) - Method in class java.util. TreeSet

tailSet(E, boolean) - Method in class java.util.concurrent. ConcurrentSkipListSet

tailSet(E, boolean) - Method in interface java.util. NavigableSet

返回该组的部分的视图，其元素大于（或等于，如果 inclusive为真） fromElement 。

tailSet(E, boolean) - Method in class java.util. TreeSet

TAISHO - Static variable in class java.time.chrono. JapaneseEra

“大正”时代（1912-07-30 - 1926-12-24）的单身人士的例子为0。

TAIWAN - Static variable in class java.util. Locale

对国家有用的常数。

take() - Method in interface java.nio.file. WatchService

检索并删除下一个Watch键，等待是否还没有。

take() - Method in class java.util.concurrent. ArrayBlockingQueue

take() - Method in interface java.util.concurrent. BlockingDeque

检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，如果需要，等待，直到元素可用。

take() - Method in interface java.util.concurrent. BlockingQueue

检索并删除此队列的头，如有必要，等待元素可用。

take() - Method in interface java.util.concurrent. CompletionService

检索并删除代表下一个完成任务的未来，等待是否还没有任务。

take() - Method in class java.util.concurrent. DelayQueue

检索并删除此队列的头部，如果需要，等待有一个延迟到期的元素在此队列上可用。

take() - Method in class java.util.concurrent. ExecutorCompletionService

take() - Method in class java.util.concurrent. LinkedBlockingDeque

take() - Method in class java.util.concurrent. LinkedBlockingQueue

take() - Method in class java.util.concurrent. LinkedTransferQueue

take() - Method in class java.util.concurrent. PriorityBlockingQueue

take() - Method in class java.util.concurrent. SynchronousQueue

检索并删除此队列的头，等待另一个线程插入它。

takeFirst() - Method in interface java.util.concurrent. BlockingDeque

检索并删除此deque的第一个元素，如有必要等待，直到元素可用。

takeFirst() - Method in class java.util.concurrent. LinkedBlockingDeque

takeLast() - Method in interface java.util.concurrent. BlockingDeque

检索并删除此deque的最后一个元素，如有必要等待，直到元素可用。

takeLast() - Method in class java.util.concurrent. LinkedBlockingDeque

takeWhile(DoublePredicate) - Method in interface java.util.stream. DoubleStream

如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。

takeWhile(IntPredicate) - Method in interface java.util.stream. IntStream

如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。

takeWhile(LongPredicate) - Method in interface java.util.stream. LongStream

如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。

takeWhile(Predicate<? super T>) - Method in interface java.util.stream. Stream

如果此流被排序，则返回一个流，该流由与此给定谓词匹配的从该流获取的元素的最长前缀组成。

TAKRI - java.lang. Character.UnicodeScript

Unicode脚本“Takri”。

TAKRI - Static variable in class java.lang. Character.UnicodeBlock

“Takri”Unicode字符块的常量。

TAMIL - java.awt.font. NumericShaper.Range

泰米尔语范围与泰米尔数字。

TAMIL - java.lang. Character.UnicodeScript

Unicode脚本“Tamil”。

TAMIL - Static variable in class java.awt.font. NumericShaper

标识TAMIL范围和十进制基数。

TAMIL - Static variable in class java.lang. Character.UnicodeBlock

“泰米尔语”Unicode字符块的常量。

tan(double) - Static method in class java.lang. Math

返回角度的三角正切。

tan(double) - Static method in class java.lang. StrictMath

返回角度的三角正切。

TAN - Static variable in class javafx.scene.paint. Color

颜色为棕褐色，RGB值为＃D2B48C

TANGENT(Duration, double) - Static method in class javafx.animation. Interpolator

创建切线内插器，切线和切线相同。

TANGENT(Duration, double, Duration, double) - Static method in class javafx.animation. Interpolator

创建切线插值器。

tanh(double) - Static method in class java.lang. Math

返回 double值的双曲正切值。

tanh(double) - Static method in class java.lang. StrictMath

返回 double值的双曲正切值。

target - Variable in class java.awt. Event

已过时。

目标组件。

target - Variable in class javafx.event. Event

事件目标定义事件在发布时将通过的路径。

target() - Method in class org.omg.CORBA. Request

检索目标对象引用。

target() - Method in interface org.omg.PortableInterceptor. ClientRequestInfoOperations

返回客户端调用以执行操作的对象。

Target - Annotation Type in java.lang.annotation

指示注释类型适用的上下文。

TARGET - Static variable in class javax.swing.text.html. HTML.Attribute

属性“目标”

target_is_a(String) - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations

如果servant是给定的存储库id，则返回true，否则返回false。

target_most_derived_interface() - Method in interface org.omg.PortableInterceptor. ServerRequestInfoOperations

返回servant最传导接口的存储库ID。

TargetDataLine - Interface in javax.sound.sampled

目标数据线是可从其读取音频数据的类型DataLine 。

TargetedNotification - Class in javax.management.remote

A（通知，听众ID）对。

TargetedNotification(Notification, Integer) - Constructor for class javax.management.remote. TargetedNotification

构造一个 TargetedNotification对象。

targetMustExist() - Method in interface javax.naming.event. EventContext

确定侦听器是否可以注册不存在的目标的兴趣。

targets() - Method in class java.lang.module. ModuleDescriptor.Exports

对于合格的导出，返回导出包的模块名称的非空和不可变的集合。

targets() - Method in class java.lang.module. ModuleDescriptor.Opens

对于合格的打开，返回打包该包的模块名称的非空和不可变的集合。

Task< V> - Class in javafx.concurrent

一个完全可以观察到的一个FutureTask的实现。

Task() - Constructor for class javafx.concurrent. Task

创建一个新的任务。

Taskbar - Class in java.awt

Taskbar类允许Java应用程序与系统任务区（任务栏，Dock等）进行交互。

Taskbar.Feature - Enum in java.awt

提供功能列表

Taskbar.State - Enum in java.awt

可用窗口进度的种类状态。

TaskEvent - Class in com.sun.source.util

提供有关JDK Java Compiler（javac）完成的工作的详细信息。

TaskEvent(TaskEvent.Kind) - Constructor for class com.sun.source.util. TaskEvent

为特定类型创建任务事件。

TaskEvent(TaskEvent.Kind, CompilationUnitTree) - Constructor for class com.sun.source.util. TaskEvent

为给定类型和编译单元创建任务事件。

TaskEvent(TaskEvent.Kind, CompilationUnitTree, TypeElement) - Constructor for class com.sun.source.util. TaskEvent

为给定类型，编译单位和类型元素创建任务事件。

TaskEvent(TaskEvent.Kind, JavaFileObject) - Constructor for class com.sun.source.util. TaskEvent

为给定种类和源文件创建任务事件。

TaskEvent.Kind - Enum in com.sun.source.util

种类的任务事件。

TaskListener - Interface in com.sun.source.util

提供监听器来监视JDK Java编译器javac的活动。

TC_ARRAY - Static variable in interface java.io. ObjectStreamConstants

新数组。

TC_BASE - Static variable in interface java.io. ObjectStreamConstants

第一个标签值。

TC_BLOCKDATA - Static variable in interface java.io. ObjectStreamConstants

阻止可选数据。

TC_BLOCKDATALONG - Static variable in interface java.io. ObjectStreamConstants

长块数据。

TC_CLASS - Static variable in interface java.io. ObjectStreamConstants

参考类。

TC_CLASSDESC - Static variable in interface java.io. ObjectStreamConstants

新的类描述符。

TC_ENDBLOCKDATA - Static variable in interface java.io. ObjectStreamConstants

结束对象的可选块数据块。

TC_ENUM - Static variable in interface java.io. ObjectStreamConstants

新的枚举常数。

TC_EXCEPTION - Static variable in interface java.io. ObjectStreamConstants

写入时异常。

TC_LONGSTRING - Static variable in interface java.io. ObjectStreamConstants

长串

TC_MAX - Static variable in interface java.io. ObjectStreamConstants

最后一个标签值。

TC_NULL - Static variable in interface java.io. ObjectStreamConstants

空对象引用。

TC_OBJECT - Static variable in interface java.io. ObjectStreamConstants

新对象。

TC_PROXYCLASSDESC - Static variable in interface java.io. ObjectStreamConstants

新的代理类描述符。

TC_REFERENCE - Static variable in interface java.io. ObjectStreamConstants

引用已写入流的对象。

TC_RESET - Static variable in interface java.io. ObjectStreamConstants

重新设置流上下文

TC_STRING - Static variable in interface java.io. ObjectStreamConstants

新的字符串。

TCKind - Class in org.omg.CORBA

IDL枚举的Java映射 TCKind ，它指定了一个 TypeCode对象的种类。

TCKind(int) - Constructor for class org.omg.CORBA. TCKind

已过时。
不要使用这个构造函数，因为这个方法应该根据OMG规范是私有的。 改用TCKind.from_int(int) 。

TCP_NODELAY - Static variable in interface java.net. SocketOptions

禁用Nagle的这个连接的算法。

TCP_NODELAY - Static variable in class java.net. StandardSocketOptions

禁用Nagle算法。

TD - Static variable in class javax.swing.text.html. HTML.Tag

标签<td>

TEAL - Static variable in class javafx.scene.paint. Color

颜色深蓝色，RGB值为＃008080

TELUGU - java.awt.font. NumericShaper.Range

具有泰卢固语数字的泰卢固语范围。

TELUGU - java.lang. Character.UnicodeScript

Unicode脚本“泰卢固语”。

TELUGU - Static variable in class java.awt.font. NumericShaper

标识TELUGU范围和十进制基数。

TELUGU - Static variable in class java.lang. Character.UnicodeBlock

常数为“泰卢固语”Unicode字符块。

TEMP_VAR_EXPRESSION_SUBKIND - jdk.jshell. Snippet.SubKind

其值已存储在临时变量中的表达式。

TEMPLATE_LITERAL - jdk.nashorn.api.tree. Tree.Kind

用于TemplateLiteralTree的实例。

TemplateLiteralTree - Interface in jdk.nashorn.api.tree

一个树节点为 template literal strings 。

Templates - Interface in javax.xml.transform

实现此接口的对象是已处理的转换指令的运行时代表。

TemplatesHandler - Interface in javax.xml.transform.sax

可用于将SAX解析事件（解析变换指令）转换为“模板”对象的SAX ContentHandler。

Temporal - Interface in java.time.temporal

定义对时间对象的读写访问的框架级接口，例如日期，时间，偏移或这些的一些组合。

TemporalAccessor - Interface in java.time.temporal

框架级接口定义对时间对象的只读访问，例如日期，时间，偏移或这些的某些组合。

TemporalAdjuster - Interface in java.time.temporal

调整时间对象的策略。

TemporalAdjusters - Class in java.time.temporal

常用和有用的TemporalAdjusters。

TemporalAmount - Interface in java.time.temporal

定义一段时间的框架级界面，如“6小时”，“8天”或“2年3个月”。

TemporalField - Interface in java.time.temporal

日期时间的字段，如月份或小时。

TemporalQueries - Class in java.time.temporal

通用实现 TemporalQuery 。

TemporalQuery< R> - Interface in java.time.temporal

查询时间对象的策略。

TemporalUnit - Interface in java.time.temporal

日期时间单位，如天数或小时数。

TEMPORARY - Static variable in interface javax.jnlp. PersistenceService

tempVariableNameGenerator(Supplier<String>) - Method in class jdk.jshell. JShell.Builder

为VarSnippet设置Snippet.SubKind.TEMP_VAR_EXPRESSION_SUBKIND的临时变量名称生成器。

TEN - Static variable in class java.math. BigDecimal

值为10，标度为0。

TEN - Static variable in class java.math. BigInteger

BigInteger常数十。

TerminalFactory - Class in javax.smartcardio

CardTerminal对象工厂。

TerminalFactorySpi - Class in javax.smartcardio

TerminalFactorySpi类定义服务提供者接口。

TerminalFactorySpi() - Constructor for class javax.smartcardio. TerminalFactorySpi

构造一个新的TerminalFactorySpi对象。

terminals() - Method in class javax.smartcardio. TerminalFactory

返回封装本工厂支持的终端的新CardTerminals对象。

TERMINATE - java.nio.file. FileVisitResult

终止。

terminated() - Method in class java.util.concurrent. ThreadPoolExecutor

执行程序已终止时调用方法。

TERMINATED - java.lang. Thread.State

终止线程的线程状态。

TERTIARY - Static variable in class java.text. Collator

整理器强度值。

tertiaryOrder(int) - Static method in class java.text. CollationElementIterator

返回排序规则元素的三级分量。

test(double) - Method in interface java.util.function. DoublePredicate

在给定的参数上评估这个谓词。

test(int) - Method in interface java.util.function. IntPredicate

在给定的参数上评估这个谓词。

test(long) - Method in interface java.util.function. LongPredicate

在给定的参数上评估这个谓词。

test(T) - Method in interface java.util.function. Predicate

在给定的参数上评估这个谓词。

test(T, U) - Method in interface java.util.function. BiPredicate

根据给定的参数来评估这个谓词。

testBit(int) - Method in class java.math. BigInteger

返回 true当且仅当指定的位被设置。

text - Static variable in class java.awt. SystemColor

为文本控件对象（如文本框和组合框）的背景渲染的颜色。

text - Variable in class javax.accessibility. AccessibleTextSequence

文本。

text() - Method in interface com.sun.javadoc. Tag

已过时。

返回此标签的文本，即超出标签名称的部分。

text(Element) - Method in class javax.swing.text. AbstractWriter

写出文字。

text(Element) - Method in class javax.swing.text.html. HTMLWriter

写出文字。

text(Element) - Method in class javax.swing.text.html. MinimalHTMLWriter

写出文字。

Text - Class in javafx.scene.text

Text类定义了一个显示文本的节点。

Text - Interface in javax.xml.soap

值为文本的节点的表示。

Text - Interface in org.w3c.dom

Text接口继承自 CharacterData ，代表 Element或 Attr的文本内容（称为 character data ，XML）。

Text() - Constructor for class javafx.scene.text. Text

创建一个空的文本实例。

Text(double, double, String) - Constructor for class javafx.scene.text. Text

在包含给定字符串的给定坐标上创建一个Text实例。

Text(String) - Constructor for class javafx.scene.text. Text

创建一个包含给定字符串的文本的实例。

TEXT - com.sun.source.doctree. DocTree.Kind

用于表示一些文档文本的TextTree的实例。

TEXT - javafx.scene. AccessibleAttribute

返回节点的文本。

TEXT - javafx.scene. AccessibleRole

文字角色。

TEXT - Static variable in class com.sun.java.accessibility.util. EventID

映射到AWT文本支持（即TextListener和TextEvent）

TEXT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.text系统颜色。

TEXT - Static variable in class javafx.scene. Cursor

文本光标类型。

TEXT - Static variable in class javax.accessibility. AccessibleRole

向用户显示文本的对象。

TEXT - Static variable in class javax.swing.text.html. HTML.Attribute

属性“文字”

TEXT_ALIGN - Static variable in class javax.swing.text.html. CSS.Attribute

CSS属性“text-align”。

TEXT_AREA - javafx.scene. AccessibleRole

文本区角色。

TEXT_AREA - Static variable in class javax.swing.plaf.synth. Region

TextArea区域。

TEXT_BACKGROUND - Static variable in class javax.swing.plaf.synth. ColorType

ColorType为区域的背景。

TEXT_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton

标识按钮文本中的更改。

TEXT_CURSOR - Static variable in class java.awt. Cursor

文本光标类型。

TEXT_CURSOR - Static variable in class java.awt. Frame

已过时。
替换为Cursor.TEXT_CURSOR 。

TEXT_DECORATION - Static variable in class javax.swing.text.html. CSS.Attribute

CSS属性“text-decoration”。

TEXT_EVENT_MASK - Static variable in class java.awt. AWTEvent

用于选择文本事件的事件掩码。

TEXT_FIELD - javafx.scene. AccessibleRole

文本字段角色。

TEXT_FIELD - Static variable in class javax.swing.plaf.synth. Region

TextField区域。

TEXT_FIRST - Static variable in class java.awt.event. TextEvent

用于文本事件的ids范围中的第一个数字。

TEXT_FOREGROUND - Static variable in class javax.swing.plaf.synth. ColorType

ColorType为区域的前景。

TEXT_HIGHLIGHT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.textHighlight系统颜色。

TEXT_HIGHLIGHT_TEXT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.textHighlightText系统颜色。

TEXT_HTML - Static variable in class javax.print. DocFlavor.CHAR_ARRAY

具有MIME类型的文档风味= "text/html; charset=utf-16" ，打印数据表示类名= "[C" （字符数组）。

TEXT_HTML - Static variable in class javax.print. DocFlavor.READER

文件风味与MIME类型= "text/html; charset=utf-16" ，打印数据表示类名= "java.io.Reader" （字符流）。

TEXT_HTML - Static variable in class javax.print. DocFlavor.STRING

具有MIME类型的文档风味= "text/html; charset=utf-16" ，打印数据表示类名= "java.lang.String" 。

TEXT_HTML_HOST - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "text/html" ，编码在主机平台编码。

TEXT_HTML_HOST - Static variable in class javax.print. DocFlavor.INPUT_STREAM

Doc风格与MIME类型= "text/html" ，编码在主机平台编码。

TEXT_HTML_HOST - Static variable in class javax.print. DocFlavor.URL

Doc风格与MIME类型= "text/html" ，编码在主机平台编码。

TEXT_HTML_US_ASCII - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "text/html; charset=us-ascii" ，打印数据表示类名= "[B" （字节数组）。

TEXT_HTML_US_ASCII - Static variable in class javax.print. DocFlavor.INPUT_STREAM

文件风味与MIME类型= "text/html; charset=us-ascii" ，打印数据表示类名= "java.io.InputStream" （字节流）。

TEXT_HTML_US_ASCII - Static variable in class javax.print. DocFlavor.URL

具有MIME类型的文档风格= "text/html; charset=us-ascii" ，打印数据表示类名称= "java.net.URL" （字节流）。

TEXT_HTML_UTF_16 - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "text/html; charset=utf-16" ，打印数据表示类名= "[B" （字节数组）。

TEXT_HTML_UTF_16 - Static variable in class javax.print. DocFlavor.INPUT_STREAM

文件风味与MIME类型= "text/html; charset=utf-16" ，打印数据表示类名= "java.io.InputStream" （字节流）。

TEXT_HTML_UTF_16 - Static variable in class javax.print. DocFlavor.URL

Doc风格与MIME类型= "text/html; charset=utf-16" ，打印数据表示类名= "java.net.URL" （字节流）。

TEXT_HTML_UTF_16BE - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

具有MIME类型的文档风格= "text/html; charset=utf-16be" （大端字节排序），打印数据表示类名称= "[B" （字节数组）。

TEXT_HTML_UTF_16BE - Static variable in class javax.print. DocFlavor.INPUT_STREAM

具有MIME类型的文档风格= "text/html; charset=utf-16be" （大字节排序），打印数据表示类名称= "java.io.InputStream" （字节流）。

TEXT_HTML_UTF_16BE - Static variable in class javax.print. DocFlavor.URL

具有MIME类型的文档风格= "text/html; charset=utf-16be" （大尾数字节排序），打印数据表示类名称= "java.net.URL" （字节流）。

TEXT_HTML_UTF_16LE - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

具有MIME类型的文档风格= "text/html; charset=utf-16le" （小端字节排序），打印数据表示类名称= "[B" （字节数组）。

TEXT_HTML_UTF_16LE - Static variable in class javax.print. DocFlavor.INPUT_STREAM

具有MIME类型的文档风格= "text/html; charset=utf-16le" （小尾数字节排序），打印数据表示类名称= "java.io.InputStream" （字节流）。

TEXT_HTML_UTF_16LE - Static variable in class javax.print. DocFlavor.URL

具有MIME类型的文档风格= "text/html; charset=utf-16le" （小尾数字节排序），打印数据表示类名称= "java.net.URL" （字节流）。

TEXT_HTML_UTF_8 - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "text/html; charset=utf-8" ，打印数据表示类名= "[B" （字节数组）。

TEXT_HTML_UTF_8 - Static variable in class javax.print. DocFlavor.INPUT_STREAM

文件风味与MIME类型= "text/html; charset=utf-8" ，打印数据表示类名= "java.io.InputStream" （字节流）。

TEXT_HTML_UTF_8 - Static variable in class javax.print. DocFlavor.URL

Doc风格与MIME类型= "text/html; charset=utf-8" ，打印数据表示类名= "java.net.URL" （字节流）。

TEXT_INACTIVE_TEXT - Static variable in class java.awt. SystemColor

阵列索引为 SystemColor.textInactiveText系统颜色。

TEXT_INDENT - Static variable in class javax.swing.text.html. CSS.Attribute

CSS属性“text-indent”。

TEXT_INSET_H - Static variable in class javax.swing.border. TitledBorder

左或右对齐文本的水平插图

TEXT_LAST - Static variable in class java.awt.event. TextEvent

用于文本事件的ids范围中的最后一个数字。

TEXT_NODE - Static variable in interface org.w3c.dom. Node

节点是一个 Text节点。

TEXT_ONLY - javafx.scene.control. ContentDisplay

只显示标签的文字。

TEXT_PANE - Static variable in class javax.swing.plaf.synth. Region

TextPane区域。

TEXT_PLAIN - Static variable in class javax.print. DocFlavor.CHAR_ARRAY

文件风味与MIME类型= "text/plain; charset=utf-16" ，打印数据表示类名= "[C" （字符数组）。

TEXT_PLAIN - Static variable in class javax.print. DocFlavor.READER

具有MIME类型的文档风格= "text/plain; charset=utf-16" ，打印数据表示类名= "java.io.Reader" （字符流）。

TEXT_PLAIN - Static variable in class javax.print. DocFlavor.STRING

MIME风格的MIME类型= "text/plain; charset=utf-16" ，打印数据表示类名= "java.lang.String" 。

TEXT_PLAIN_HOST - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "text/plain" ，编码在主机平台编码。

TEXT_PLAIN_HOST - Static variable in class javax.print. DocFlavor.INPUT_STREAM

Doc风味与MIME类型= "text/plain" ，编码在主机平台编码。

TEXT_PLAIN_HOST - Static variable in class javax.print. DocFlavor.URL

Doc风格与MIME类型= "text/plain" ，编码在主机平台编码。

TEXT_PLAIN_US_ASCII - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

文件风味与MIME类型= "text/plain; charset=us-ascii" ，打印数据表示类名= "[B" （字节数组）。

TEXT_PLAIN_US_ASCII - Static variable in class javax.print. DocFlavor.INPUT_STREAM

文件风味与MIME类型= "text/plain; charset=us-ascii" ，打印数据表示类名= "java.io.InputStream" （字节流）。

TEXT_PLAIN_US_ASCII - Static variable in class javax.print. DocFlavor.URL

Doc风格与MIME类型= "text/plain; charset=us-ascii" ，打印数据表示类名= "java.net.URL" （字节流）。

TEXT_PLAIN_UTF_16 - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "text/plain; charset=utf-16" ，打印数据表示类名= "[B" （字节数组）。

TEXT_PLAIN_UTF_16 - Static variable in class javax.print. DocFlavor.INPUT_STREAM

文件风味与MIME类型= "text/plain; charset=utf-16" ，打印数据表示类名= "java.io.InputStream" （字节流）。

TEXT_PLAIN_UTF_16 - Static variable in class javax.print. DocFlavor.URL

Doc风格与MIME类型= "text/plain; charset=utf-16" ，打印数据表示类名称= java.net.URL"" （字节流）。

TEXT_PLAIN_UTF_16BE - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

文件风味与MIME类型= "text/plain; charset=utf-16be" （大字节排序），打印数据表示类名称= "[B" （字节数组）。

TEXT_PLAIN_UTF_16BE - Static variable in class javax.print. DocFlavor.INPUT_STREAM

具有MIME类型的文档风格= "text/plain; charset=utf-16be" （大端字节排序），打印数据表示类名称= "java.io.InputStream" （字节流）。

TEXT_PLAIN_UTF_16BE - Static variable in class javax.print. DocFlavor.URL

具有MIME类型的文档风格= "text/plain; charset=utf-16be" （大字节排序），打印数据表示类名称= "java.net.URL" （字节流）。

TEXT_PLAIN_UTF_16LE - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

具有MIME类型的文档风格= "text/plain; charset=utf-16le" （小端字节排序），打印数据表示类名称= "[B" （字节数组）。

TEXT_PLAIN_UTF_16LE - Static variable in class javax.print. DocFlavor.INPUT_STREAM

具有MIME类型的文档风格= "text/plain; charset=utf-16le" （小尾数字节排序），打印数据表示类名称= "java.io.InputStream" （字节流）。

TEXT_PLAIN_UTF_16LE - Static variable in class javax.print. DocFlavor.URL

具有MIME类型的文档风格= "text/plain; charset=utf-16le" （小端字节排序），打印数据表示类名称= "java.net.URL" （字节流）。

TEXT_PLAIN_UTF_8 - Static variable in class javax.print. DocFlavor.BYTE_ARRAY

Doc风格与MIME类型= "text/plain; charset=utf-8" ，打印数据表示类名称= "[B" （字节数组）。

TEXT_PLAIN_UTF_8 - Static variable in class javax.print. DocFlavor.INPUT_STREAM

文件风格与MIME类型= "text/plain; charset=utf-8" ，打印数据表示类名= "java.io.InputStream" （字节流）。

TEXT_PLAIN_UTF_8 - Static variable in class javax.print. DocFlavor.URL

文件风味与MIME类型= "text/plain; charset=utf-8" ，打印数据表示类名= "java.net.URL" （字节流）。

TEXT_SPACING - Static variable in class javax.swing.border. TitledBorder

边框和文字之间的空格

TEXT_TEXT - Static variable in class java.awt. SystemColor

SystemColor.textText系统颜色的数组索引。

TEXT_TRANSFORM - Static variable in class javax.swing.text.html. CSS.Attribute

CSS属性“text-transform”。

TEXT_VALUE_CHANGED - Static variable in class java.awt.event. TextEvent

此事件id表示对象的文本已更改。

TextAction - Class in javax.swing.text

对于跨多个不同文本组件共享的键绑定的Action实现。

TextAction(String) - Constructor for class javax.swing.text. TextAction

创建一个新的JTextAction对象。

TextAlignment - Enum in javafx.scene.text

TextAlignment枚举代表水平文本对齐。

textAlignmentProperty() - Method in class javafx.scene.control. Labeled

指定 文本行多行的文本 行与 Labeled.contentDisplayProperty()影响图形和文本的行为，此设置仅影响文本边界的多行文本。

textAlignmentProperty() - Method in class javafx.scene.control. Tooltip

指定 文本行多行时的行为。

textAlignmentProperty() - Method in class javafx.scene.text. Text

在边界框中定义水平文本对齐。

textAlignmentProperty() - Method in class javafx.scene.text. TextFlow

定义水平文本对齐。

TextArea - Class in java.awt

一个 TextArea对象是一个显示文本的多行区域。

TextArea - Class in javafx.scene.control

文本输入组件，允许用户输入多行纯文本。

TextArea() - Constructor for class java.awt. TextArea

构造一个新的文本区域，空字符串作为文本。

TextArea() - Constructor for class javafx.scene.control. TextArea

创建一个 TextArea与空文本内容。

TextArea(int, int) - Constructor for class java.awt. TextArea

构造具有指定行数和列数的新文本区域，空字符串作为文本。

TextArea(String) - Constructor for class java.awt. TextArea

构造具有指定文本的新文本区域。

TextArea(String) - Constructor for class javafx.scene.control. TextArea

创建一个 TextArea的初始文本内容。

TextArea(String, int, int) - Constructor for class java.awt. TextArea

构造具有指定文本的新文本区域，并具有指定的行数和列数。

TextArea(String, int, int, int) - Constructor for class java.awt. TextArea

构造具有指定文本的新文本区域，并按照指定的行，列和滚动条可见性构造。

TEXTAREA - Static variable in class javax.swing.text.html. HTML.Tag

标签<textarea>

TextArea.AccessibleAWTTextArea - Class in java.awt

这个类实现 TextArea类的辅助功能支持。

textAreaContent(char[]) - Method in class javax.swing.text.html. HTMLDocument.HTMLReader

将给定的内容添加到textarea文档。

textAreaContent(AttributeSet) - Method in class javax.swing.text.html. HTMLWriter

写出TEXTAREA表单元素中包含的文本。

TextAreaSkin - Class in javafx.scene.control.skin

默认皮肤实现为TextArea控件。

TextAreaSkin(TextArea) - Constructor for class javafx.scene.control.skin. TextAreaSkin

创建一个新的TextAreaSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

TextAttribute - Class in java.awt.font

TextAttribute类定义用于文本呈现的属性键和属性值。

TextAttribute(String) - Constructor for class java.awt.font. TextAttribute

构造具有指定名称的 TextAttribute 。

TextBoundsType - Enum in javafx.scene.text

指定由 Text节点报告的边界的行为。

TextCallbackHandler - Class in com.sun.security.auth.callback

从命令行提示并读取认证问题的答案。

TextCallbackHandler() - Constructor for class com.sun.security.auth.callback. TextCallbackHandler

创建一个回调处理程序，它提示并从命令行读取认证问题的答案。

TextComponent - Class in java.awt

TextComponent类是允许编辑某些文本的任何组件的超类。

TextComponent.AccessibleAWTTextComponent - Class in java.awt

这个类实现 TextComponent类的可访问性支持。

TextEvent - Class in java.awt.event

表示对象的文本改变的语义事件。

TextEvent(Object, int) - Constructor for class java.awt.event. TextEvent

构造一个 TextEvent对象。

TextField - Class in java.awt

TextField对象是允许编辑单行文本的文本组件。

TextField - Class in javafx.scene.control

文本输入组件，允许用户输入一行未格式化的文本。

TextField() - Constructor for class java.awt. TextField

构造一个新的文本字段。

TextField() - Constructor for class javafx.scene.control. TextField

创建一个 TextField与空的文本内容。

TextField(int) - Constructor for class java.awt. TextField

构造具有指定列数的新的空文本字段。

TextField(String) - Constructor for class java.awt. TextField

构造一个使用指定文本初始化的新文本字段。

TextField(String) - Constructor for class javafx.scene.control. TextField

创建一个 TextField与初始文本内容。

TextField(String, int) - Constructor for class java.awt. TextField

构造一个新的文本字段，并使用指定的文本进行初始化，以便显示，并且足够宽以容纳指定的列数。

TextField.AccessibleAWTTextField - Class in java.awt

该类实现 TextField类的辅助功能支持。

TextFieldBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.TextFieldBorder

TextFieldListCell< T> - Class in javafx.scene.control.cell

一个包含ListCell实现的类，在该单元格内绘制一个TextField节点。

TextFieldListCell() - Constructor for class javafx.scene.control.cell. TextFieldListCell

使用零转换器创建默认的TextFieldListCell。

TextFieldListCell(StringConverter<T>) - Constructor for class javafx.scene.control.cell. TextFieldListCell

创建一个TextFieldListCell，当进入允许编辑单元格内容的编辑模式时，它将提供一个TextField 。

TextFieldSkin - Class in javafx.scene.control.skin

默认皮肤实现为TextField控件。

TextFieldSkin(TextField) - Constructor for class javafx.scene.control.skin. TextFieldSkin

创建一个新的TextFieldSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

TextFieldTableCell< S, T> - Class in javafx.scene.control.cell

一个包含一个TableCell实现的类，它在单元格中绘制一个TextField节点。

TextFieldTableCell() - Constructor for class javafx.scene.control.cell. TextFieldTableCell

使用零转换器创建默认的TextFieldTableCell。

TextFieldTableCell(StringConverter<T>) - Constructor for class javafx.scene.control.cell. TextFieldTableCell

创建一个TextFieldTableCell，当进入编辑模式时，可以编辑TextField ，以便编辑单元格内容。

TextFieldTreeCell< T> - Class in javafx.scene.control.cell

一个包含TreeCell实现的类，在该单元格内绘制一个TextField节点。

TextFieldTreeCell() - Constructor for class javafx.scene.control.cell. TextFieldTreeCell

使用空转换器创建默认的TextFieldTreeCell。

TextFieldTreeCell(StringConverter<T>) - Constructor for class javafx.scene.control.cell. TextFieldTreeCell

创建一个TextFieldTreeCell，当进入编辑模式时，可以编辑TextField单元格内容。

TextFieldTreeTableCell< S, T> - Class in javafx.scene.control.cell

一个包含TableCell实现的类，在该单元格内绘制一个TextField节点。

TextFieldTreeTableCell() - Constructor for class javafx.scene.control.cell. TextFieldTreeTableCell

使用零转换器创建默认的TextFieldTreeTableCell。

TextFieldTreeTableCell(StringConverter<T>) - Constructor for class javafx.scene.control.cell. TextFieldTreeTableCell

创建一个TextFieldTreeTableCell，它在编辑模式时提供TextField ，允许编辑单元格内容。

textFillProperty() - Method in class javafx.scene.control. Labeled

Paint用于填写文字。

textFillProperty() - Method in class javafx.scene.control.skin. TextInputControlSkin

在正常条件下用于文本的填充

TextFlow - Class in javafx.scene.text

TextFlow是设计用于布置富文本的特殊布局。

TextFlow() - Constructor for class javafx.scene.text. TextFlow

创建一个空TextFlow布局。

TextFlow(Node...) - Constructor for class javafx.scene.text. TextFlow

使用给定的子项创建TextFlow布局。

TextFormatter< V> - Class in javafx.scene.control

格式化器通过使用两种不同的机制来描述 TextInputControl文本的格式：可以拦截和修改用户输入的过滤器（ TextFormatter.getFilter() ）。

TextFormatter(UnaryOperator<TextFormatter.Change>) - Constructor for class javafx.scene.control. TextFormatter

使用提供的过滤器创建一个新的Formatter。

TextFormatter(StringConverter<V>) - Constructor for class javafx.scene.control. TextFormatter

使用提供的值转换器创建一个新的格式化器。

TextFormatter(StringConverter<V>, V) - Constructor for class javafx.scene.control. TextFormatter

使用提供的值转换器和默认值创建一个新的格式化器。

TextFormatter(StringConverter<V>, V, UnaryOperator<TextFormatter.Change>) - Constructor for class javafx.scene.control. TextFormatter

使用提供的过滤器，值转换器和默认值创建一个新的格式化器。

TextFormatter.Change - Class in javafx.scene.control

包含表示TextInputControl的内容或选择更改的状态。

textFormatterProperty() - Method in class javafx.scene.control. TextInputControl

该物业包含目前附件TextFormatter 。

textHighlight - Static variable in class java.awt. SystemColor

为所选项目的背景渲染的颜色，如菜单，组合框和文本。

textHighlightText - Static variable in class java.awt. SystemColor

为所选项目的文本呈现的颜色，如菜单，组合框和文本。

TextHitInfo - Class in java.awt.font

TextHitInfo类表示文本模型中的字符位置，以及字符的 偏差或“侧”。

textIconGap - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI

文字图标差距

textInactiveText - Static variable in class java.awt. SystemColor

为非活动项目的文本呈现的颜色，如菜单中。

TextInputCallback - Class in javax.security.auth.callback

基础安全服务实例，并通过一个 TextInputCallback至 handle一个方法 CallbackHandler检索普通的文本信息。

TextInputCallback(String) - Constructor for class javax.security.auth.callback. TextInputCallback

构造一个 TextInputCallback与提示。

TextInputCallback(String, String) - Constructor for class javax.security.auth.callback. TextInputCallback

构造一个带有提示和默认输入值的 TextInputCallback 。

TextInputControl - Class in javafx.scene.control

文本输入控件的抽象基类。

TextInputControl(TextInputControl.Content) - Constructor for class javafx.scene.control. TextInputControl

创建一个新的TextInputControl。

TextInputControl.Content - Interface in javafx.scene.control

界面表示文本输入的内容。

TextInputControlSkin< T extends TextInputControl> - Class in javafx.scene.control.skin

文本输入皮肤的抽象基类。

TextInputControlSkin(T) - Constructor for class javafx.scene.control.skin. TextInputControlSkin

创建一个新的TextInputControlSkin实例，虽然注意到这个实例不处理任何行为/输入映射 - 这需要由子类适当地处理。

TextInputControlSkin.Direction - Enum in javafx.scene.control.skin

方向名称用于插入符号移动。

TextInputControlSkin.TextUnit - Enum in javafx.scene.control.skin

照相机运动的单位名称。

TextInputDialog - Class in javafx.scene.control

显示给用户的文本输入控件的对话框。

TextInputDialog() - Constructor for class javafx.scene.control. TextInputDialog

创建一个新的TextInputDialog，而不会在对话框TextField中输入默认值。

TextInputDialog(String) - Constructor for class javafx.scene.control. TextInputDialog

创建一个新的TextInputDialog，默认值输入到对话框TextField中 。

TextLayout - Class in java.awt.font

TextLayout是风格字符数据的不可变图形表示。

TextLayout(String, Font, FontRenderContext) - Constructor for class java.awt.font. TextLayout

构造一个TextLayout从String和Font 。

TextLayout(String, Map<? extends AttributedCharacterIterator.Attribute, ?>, FontRenderContext) - Constructor for class java.awt.font. TextLayout

从 String构建一个 TextLayout和一个属性集。

TextLayout(AttributedCharacterIterator, FontRenderContext) - Constructor for class java.awt.font. TextLayout

从迭代器构造一个 TextLayout的样式文本。

TextLayout.CaretPolicy - Class in java.awt.font

定义确定强插插位置的策略。

textListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor

不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。

textListener - Variable in class java.awt. TextComponent

将从此对象接收事件的侦听器列表。

TextListener - Interface in java.awt.event

用于接收文本事件的侦听器界面。

TextMeasurer - Class in java.awt.font

TextMeasurer类提供换行所需的原始操作：测量一个给定的提前，确定一系列字符的提前，并为一系列字符生成一个 TextLayout 。

TextMeasurer(AttributedCharacterIterator, FontRenderContext) - Constructor for class java.awt.font. TextMeasurer

从源文本构造一个 TextMeasurer 。

textNonSelectionColor - Variable in class javax.swing.tree. DefaultTreeCellRenderer

用于未选择节点前景的颜色。

textOriginProperty() - Method in class javafx.scene.text. Text

以局部坐标定义文本坐标系的起点。

TextOutputCallback - Class in javax.security.auth.callback

基础安全服务实例，并通过一个 TextOutputCallback至 handle一个方法 CallbackHandler ，以显示信息消息，警告消息和错误消息。

TextOutputCallback(int, String) - Constructor for class javax.security.auth.callback. TextOutputCallback

构造一个TextOutputCallback，并显示消息类型和消息。

textOverrunProperty() - Method in class javafx.scene.control. Labeled

指定 Labeled的文本超过可用空间进行渲染时使用的行为。

textOverrunProperty() - Method in class javafx.scene.control. Tooltip

指定 Tooltip的文本超过可用空间进行渲染时使用的行为。

textProperty() - Method in class javafx.scene.control. Labeled

要在标签中显示的文字。

textProperty() - Method in class javafx.scene.control. MenuItem

文字显示在 MenuItem 。

textProperty() - Method in class javafx.scene.control. Tab

选项卡中显示的文本。

textProperty() - Method in class javafx.scene.control. TableColumnBase

这是此列的标题中显示的文本。

textProperty() - Method in class javafx.scene.control. TextInputControl

TextInputControl的文本内容。

textProperty() - Method in class javafx.scene.control. Tooltip

要在工具提示中显示的文字。

textProperty() - Method in class javafx.scene.text. Text

定义要显示的文本字符串。

textRequiresLayout(char[], int, int) - Static method in class java.awt. Font

如果指定文本的任何部分来自复杂脚本，则实现将需要调用布局处理以便在使用 drawString(String,int,int)和其他文本呈现方法时正确呈现，则返回true。

textSelectionColor - Variable in class javax.swing.tree. DefaultTreeCellRenderer

用于所选节点前景的颜色。

TextStyle - Enum in java.time.format

枚举文本格式和解析的风格。

TextSyntax - Class in javax.print.attribute

Class TextSyntax是一个抽象基类，提供了值为字符串的所有属性的常见实现。

TextSyntax(String, Locale) - Constructor for class javax.print.attribute. TextSyntax

构造具有指定字符串和语言环境的TextAttribute。

textText - Static variable in class java.awt. SystemColor

为文本控件对象（如文本框和组合框）的文本呈现的颜色。

TextTree - Interface in com.sun.source.doctree

纯文本的树节点。

TextUI - Class in javax.swing.plaf

文本编辑器用户界面

TextUI() - Constructor for class javax.swing.plaf. TextUI

TexturePaint - Class in java.awt

TexturePaint类提供了一种方法来填充一个Shape ，其纹理指定为BufferedImage 。

TexturePaint(BufferedImage, Rectangle2D) - Constructor for class java.awt. TexturePaint

构造一个 TexturePaint对象。

textValueChanged(TextEvent) - Method in class java.awt. AWTEventMulticaster

textValueChanged(TextEvent) - Method in interface java.awt.event. TextListener

当文本的值已更改时调用。

textValueChanged(TextEvent) - Method in class java.awt. TextComponent.AccessibleAWTTextComponent

TextListener通知文本值更改。

TH - Static variable in class javax.swing.text.html. HTML.Tag

标签<th>

THAANA - java.lang. Character.UnicodeScript

Unicode脚本“Thaana”。

THAANA - Static variable in class java.lang. Character.UnicodeBlock

“Thaana”Unicode字符块的常量。

THAI - java.awt.font. NumericShaper.Range

泰国范围与泰国数字。

THAI - java.lang. Character.UnicodeScript

Unicode脚本“泰语”。

THAI - Static variable in class java.awt.font. NumericShaper

标识THAI范围和十进制基数。

THAI - Static variable in class java.lang. Character.UnicodeBlock

“泰语”Unicode字符块的常量。

ThaiBuddhistChronology - Class in java.time.chrono

泰国佛教日历系统。

ThaiBuddhistDate - Class in java.time.chrono

在泰国佛教日历系统的日期。

ThaiBuddhistEra - Enum in java.time.chrono

泰国佛教日历系统的时代。

the_activator() - Method in interface org.omg.PortableServer. POAOperations

此属性标识与POA相关联的适配器激活器。

the_activator(AdapterActivator) - Method in interface org.omg.PortableServer. POAOperations

此属性标识与POA相关联的适配器激活器。

the_children() - Method in interface org.omg.PortableServer. POAOperations

此属性标识当前POA所有子POA的集合。

the_name() - Method in interface org.omg.PortableServer. POAOperations

此属性标识相对于其父项的POA。

the_parent() - Method in interface org.omg.PortableServer. POAOperations

此属性标识POA的父项。

the_POAManager() - Method in interface org.omg.PortableServer. POAOperations

该属性标识与POA相关联的POA管理器。

then(boolean) - Method in class javafx.beans.binding. When

定义三元表达式的常量值，如果条件为 true则返回。

then(double) - Method in class javafx.beans.binding. When

定义三元表达式的常量值，如果条件为 true则返回。

then(float) - Method in class javafx.beans.binding. When

定义三元表达式的常量值，如果条件为 true ，则返回该 true 。

then(int) - Method in class javafx.beans.binding. When

定义三元表达式的常量值，如果条件为 true ，则返回该 true 。

then(long) - Method in class javafx.beans.binding. When

定义三元表达式的常量值，如果条件为 true ，则返回该 true 。

then(String) - Method in class javafx.beans.binding. When

定义三元表达式的常量值，如果条件为 true则返回。

then(ObservableBooleanValue) - Method in class javafx.beans.binding. When

定义ObservableBooleanValue如果条件为true则由三元表达式返回哪个值。

then(ObservableNumberValue) - Method in class javafx.beans.binding. When

定义ObservableNumberValue如果条件为true则由三元表达式返回哪个值。

then(ObservableObjectValue<T>) - Method in class javafx.beans.binding. When

定义ObservableObjectValue如果条件为true则由三元表达式返回哪个值。

then(ObservableStringValue) - Method in class javafx.beans.binding. When

定义ObservableStringValue如果条件为true则由三元表达式返回该值。

then(T) - Method in class javafx.beans.binding. When

定义三元表达式的常量值，如果条件为 true则返回。

thenAccept(Consumer<? super T>) - Method in class java.util.concurrent. CompletableFuture

thenAccept(Consumer<? super T>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。

thenAcceptAsync(Consumer<? super T>) - Method in class java.util.concurrent. CompletableFuture

thenAcceptAsync(Consumer<? super T>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。

thenAcceptAsync(Consumer<? super T>, Executor) - Method in class java.util.concurrent. CompletableFuture

thenAcceptAsync(Consumer<? super T>, Executor) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。

thenAcceptBoth(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in class java.util.concurrent. CompletableFuture

thenAcceptBoth(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。

thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in class java.util.concurrent. CompletableFuture

thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。

thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>, Executor) - Method in class java.util.concurrent. CompletableFuture

thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>, Executor) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。

thenApply(Function<? super T, ? extends U>) - Method in class java.util.concurrent. CompletableFuture

thenApply(Function<? super T, ? extends U>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，将以该阶段的结果作为所提供函数的参数执行。

thenApplyAsync(Function<? super T, ? extends U>) - Method in class java.util.concurrent. CompletableFuture

thenApplyAsync(Function<? super T, ? extends U>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当该阶段正常完成时，将使用此阶段的默认异步执行工具执行此阶段的结果作为所提供函数的参数。

thenApplyAsync(Function<? super T, ? extends U>, Executor) - Method in class java.util.concurrent. CompletableFuture

thenApplyAsync(Function<? super T, ? extends U>, Executor) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供函数的参数。

thenCombine(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in class java.util.concurrent. CompletableFuture

thenCombine(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供函数的参数执行。

thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in class java.util.concurrent. CompletableFuture

thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供函数的参数。

thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>, Executor) - Method in class java.util.concurrent. CompletableFuture

thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>, Executor) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行，其中两个结果作为提供的函数的参数。

thenComparing(Comparator<? super T>) - Method in interface java.util. Comparator

用另一个比较器返回一个字典顺序比较器。

thenComparing(Function<? super T, ? extends U>) - Method in interface java.util. Comparator

返回具有提取 Comparable排序键的功能的字典顺序比较器。

thenComparing(Function<? super T, ? extends U>, Comparator<? super U>) - Method in interface java.util. Comparator

返回具有提取要与给定的 Comparator进行比较的键的功能的字典顺序比较器。

thenComparingDouble(ToDoubleFunction<? super T>) - Method in interface java.util. Comparator

返回具有提取 double排序键的功能的字典顺序比较器。

thenComparingInt(ToIntFunction<? super T>) - Method in interface java.util. Comparator

返回具有提取 int排序键的功能的字典顺序比较器。

thenComparingLong(ToLongFunction<? super T>) - Method in interface java.util. Comparator

返回具有提取 long排序键的功能的字典顺序比较器。

thenCompose(Function<? super T, ? extends CompletionStage<U>>) - Method in class java.util.concurrent. CompletableFuture

thenCompose(Function<? super T, ? extends CompletionStage<U>>) - Method in interface java.util.concurrent. CompletionStage

返回一个完成的新的CompletionStage，其值与给定函数返回的CompletionStage相同。

thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>) - Method in class java.util.concurrent. CompletableFuture

thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用该阶段的默认异步执行工具执行。

thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>, Executor) - Method in class java.util.concurrent. CompletableFuture

thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>, Executor) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，其完成值与给定函数返回的CompletionStage值相同，并使用提供的Executor执行。

thenRun(Runnable) - Method in class java.util.concurrent. CompletableFuture

thenRun(Runnable) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。

thenRunAsync(Runnable) - Method in class java.util.concurrent. CompletableFuture

thenRunAsync(Runnable) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。

thenRunAsync(Runnable, Executor) - Method in class java.util.concurrent. CompletableFuture

thenRunAsync(Runnable, Executor) - Method in interface java.util.concurrent. CompletionStage

返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。

THICK - Static variable in class javafx.scene.layout. BorderStroke

指定“thick”时的默认值

thickness - Variable in class javax.swing.border. LineBorder

边界厚度

THIN - javafx.scene.text. FontWeight

代表瘦体重（100）。

THIN - Static variable in class javafx.scene.layout. BorderStroke

指定“thin”时的默认插入。

this_object(Servant) - Method in interface org.omg.PortableServer.portable. Delegate

这允许servant获取它为该请求所体现的目标CORBA对象的对象引用。

thisObject() - Method in interface com.sun.jdi. StackFrame

返回当前帧的“this”值。

thisObject() - Method in interface javax.rmi.CORBA. Tie

返回由此tie表示的目标对象的对象引用。

THISTLE - Static variable in class javafx.scene.paint. Color

颜色蓟，RGB值为＃D8BFD8

thread() - Method in interface com.sun.jdi.event. ClassPrepareEvent

返回发生此事件的线程。

thread() - Method in interface com.sun.jdi.event. LocatableEvent

返回发生此事件的线程。

thread() - Method in interface com.sun.jdi.event. MonitorContendedEnteredEvent

返回发生此事件的线程。

thread() - Method in interface com.sun.jdi.event. MonitorContendedEnterEvent

返回发生此事件的线程。

thread() - Method in interface com.sun.jdi.event. MonitorWaitedEvent

返回发生此事件的线程。

thread() - Method in interface com.sun.jdi.event. MonitorWaitEvent

返回发生监视等待事件的线程。

thread() - Method in interface com.sun.jdi.event. ThreadDeathEvent

返回正在终止的线程。

thread() - Method in interface com.sun.jdi.event. ThreadStartEvent

返回已经启动的线程。

thread() - Method in interface com.sun.jdi.event. VMStartEvent

返回已启动的VM的初始线程。

thread() - Method in interface com.sun.jdi. MonitorInfo

为拥有该监视器的线程返回一个ThreadReference对象。

thread() - Method in interface com.sun.jdi.request. StepRequest

thread() - Method in interface com.sun.jdi. StackFrame

返回运行此框架的方法的线程。

Thread - Class in java.lang

线程是程序中执行的线程。

Thread() - Constructor for class java.lang. Thread

分配一个新的 Thread对象。

Thread(Runnable) - Constructor for class java.lang. Thread

分配一个新的 Thread对象。

Thread(Runnable, String) - Constructor for class java.lang. Thread

分配一个新的 Thread对象。

Thread(String) - Constructor for class java.lang. Thread

分配一个新的 Thread对象。

Thread(ThreadGroup, Runnable) - Constructor for class java.lang. Thread

分配一个新的 Thread对象。

Thread(ThreadGroup, Runnable, String) - Constructor for class java.lang. Thread

分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于由 group引用的线程组。

Thread(ThreadGroup, Runnable, String, long) - Constructor for class java.lang. Thread

分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于由 group引用的线程组，并具有指定的 堆栈大小 。

Thread(ThreadGroup, Runnable, String, long, boolean) - Constructor for class java.lang. Thread

分配一个新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于由group引用的线程组，具有指定的stackSize ，如果inheritThreadLocals为true ，则继承2704595125193737变量的初始值。

Thread(ThreadGroup, String) - Constructor for class java.lang. Thread

分配一个新的 Thread对象。

THREAD_MXBEAN_NAME - Static variable in class java.lang.management. ManagementFactory

字符串表示的ObjectName为ThreadMXBean 。

THREAD_POLICY_ID - Interface in org.omg.PortableServer

org / omg / PortableServer / THREAD_POLICY_ID.java。

THREAD_STATUS_MONITOR - Static variable in interface com.sun.jdi. ThreadReference

线程正在等待一个java监视器

THREAD_STATUS_NOT_STARTED - Static variable in interface com.sun.jdi. ThreadReference

线程尚未启动

THREAD_STATUS_RUNNING - Static variable in interface com.sun.jdi. ThreadReference

线程是可运行的

THREAD_STATUS_SLEEPING - Static variable in interface com.sun.jdi. ThreadReference

线程正在睡眠 - Thread.sleep（）或JVM_Sleep（）被调用

THREAD_STATUS_UNKNOWN - Static variable in interface com.sun.jdi. ThreadReference

线程状态未知

THREAD_STATUS_WAIT - Static variable in interface com.sun.jdi. ThreadReference

线程正在等待 - Object.wait（）或JVM_MonitorWait（）被调用

THREAD_STATUS_ZOMBIE - Static variable in interface com.sun.jdi. ThreadReference

线程已完成执行

Thread.State - Enum in java.lang

线程状态。

Thread.UncaughtExceptionHandler - Interface in java.lang

当 Thread由于未捕获的异常突然终止而调用处理程序的接口。

ThreadDeath - Error in java.lang

当调用（弃用）的 Thread.stop()方法时， ThreadDeath的实例将被抛出在受害者线程中。

ThreadDeath() - Constructor for error java.lang. ThreadDeath

ThreadDeathEvent - Interface in com.sun.jdi.event

在目标虚拟机中通知已完成的线程。

ThreadDeathRequest - Interface in com.sun.jdi.request

线程在目标虚拟机中终止时请求通知。

threadDeathRequests() - Method in interface com.sun.jdi.request. EventRequestManager

返回启用和禁用的线程死亡请求的不可修改的列表。

ThreadFactory - Interface in java.util.concurrent

根据需要创建新线程的对象。

threadGroup() - Method in interface com.sun.jdi. ThreadReference

返回此线程的线程组。

ThreadGroup - Class in java.lang

线程组代表一组线程。

ThreadGroup(String) - Constructor for class java.lang. ThreadGroup

构造一个新的线程组。

ThreadGroup(ThreadGroup, String) - Constructor for class java.lang. ThreadGroup

创建一个新的线程组。

ThreadGroupReference - Interface in com.sun.jdi

来自目标VM的线程组对象。

threadGroups() - Method in interface com.sun.jdi. ThreadGroupReference

返回一个包含此线程组中每个活动ThreadGroupReference的列表。

ThreadInfo - Class in java.lang.management

线程信息。

ThreadLocal< T> - Class in java.lang

这个类提供线程局部变量。

ThreadLocal() - Constructor for class java.lang. ThreadLocal

创建线程局部变量。

ThreadLocalRandom - Class in java.util.concurrent

与当前线程隔离的随机数生成器。

ThreadMXBean - Interface in com.sun.management

针对Java虚拟机线程系统的平台特定管理界面。

ThreadMXBean - Interface in java.lang.management

Java虚拟机线程系统的管理界面。

ThreadPolicy - Interface in org.omg.PortableServer

ThreadPolicy指定与创建的POA一起使用的线程模型。

ThreadPolicyOperations - Interface in org.omg.PortableServer

ThreadPolicy指定与创建的POA一起使用的线程模型。

ThreadPolicyValue - Class in org.omg.PortableServer

ThreadPolicyValue可以具有以下值。

ThreadPolicyValue(int) - Constructor for class org.omg.PortableServer. ThreadPolicyValue

ThreadPoolExecutor - Class in java.util.concurrent

一个ExecutorService ，它使用可能的几个合并的线程执行每个提交的任务，通常使用Executors工厂方法配置。

ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>) - Constructor for class java.util.concurrent. ThreadPoolExecutor

创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂和拒绝的执行处理程序。

ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, RejectedExecutionHandler) - Constructor for class java.util.concurrent. ThreadPoolExecutor

创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂。

ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory) - Constructor for class java.util.concurrent. ThreadPoolExecutor

创建一个新的 ThreadPoolExecutor与给定的初始参数和默认拒绝执行处理程序。

ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory, RejectedExecutionHandler) - Constructor for class java.util.concurrent. ThreadPoolExecutor

使用给定的初始参数创建一个新的 ThreadPoolExecutor 。

ThreadPoolExecutor.AbortPolicy - Class in java.util.concurrent

一个抛出 RejectedExecutionException被拒绝任务的处理程序。

ThreadPoolExecutor.CallerRunsPolicy - Class in java.util.concurrent

被拒绝的任务的处理程序直接在 execute方法的调用线程中运行被拒绝的任务，除非执行程序已经被关闭，否则这个任务被丢弃。

ThreadPoolExecutor.DiscardOldestPolicy - Class in java.util.concurrent

被拒绝的任务的处理程序，丢弃最旧的未处理请求，然后重试 execute ，除非执行程序被关闭，否则任务被丢弃。

ThreadPoolExecutor.DiscardPolicy - Class in java.util.concurrent

被拒绝的任务的处理程序静默地丢弃被拒绝的任务。

ThreadReference - Interface in com.sun.jdi

来自目标VM的线程对象。

threads() - Method in interface com.sun.jdi. ThreadGroupReference

返回一个包含此线程组中每个线程的ThreadReference的列表。

ThreadStartEvent - Interface in com.sun.jdi.event

在目标虚拟机中通知新运行的线程。

ThreadStartRequest - Interface in com.sun.jdi.request

线程在目标虚拟机中启动执行时请求通知。

threadStartRequests() - Method in interface com.sun.jdi.request. EventRequestManager

返回启用和禁用的线程启动请求的不可修改的列表。

THREE_PASS_BOX - javafx.scene.effect. BlurType

使用三次通过盒式滤波器来模糊阴影，其效果几乎与高斯滤波器一样平滑。

THRESHHOLDING_NONE - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“阈值”标签一起使用的值。

THRESHHOLDING_ORDERED_DITHER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“阈值”标签一起使用的值。

THRESHHOLDING_RANDOMIZED_DITHER - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet

与“阈值”标签一起使用的值。

threshold - Variable in class javax.xml.ws.soap. MTOMFeature

MTOM阈值属性。

THRESHOLD_ERROR - Static variable in class javax.management.monitor. MonitorNotification

通知类型表示阈值类型，偏移量或模数不正确。

THRESHOLD_HIGH_VALUE_EXCEEDED - Static variable in class javax.management.monitor. MonitorNotification

通知类型表示观察属性已超过阈值高值。

THRESHOLD_LOW_VALUE_EXCEEDED - Static variable in class javax.management.monitor. MonitorNotification

通知类型表示观察属性已超过阈值低值。

THRESHOLD_VALUE_EXCEEDED - Static variable in class javax.management.monitor. MonitorNotification

表示观察属性达到阈值的通知类型。

thresholdProperty() - Method in class javafx.scene.effect. Bloom

阈值控制将被发光的像素的最小亮度值。

THROW - com.sun.source.tree. Tree.Kind

用于ThrowTree的实例。

THROW - jdk.nashorn.api.tree. Tree.Kind

用于ThrowTree的实例。

Throwable - Class in java.lang

Throwable类是Java语言中所有错误和异常的超类。

Throwable() - Constructor for class java.lang. Throwable

构造一个新的可抛出的 null作为其详细信息。

Throwable(String) - Constructor for class java.lang. Throwable

构造一个具有指定的详细消息的新的throwable。

Throwable(String, Throwable) - Constructor for class java.lang. Throwable

构造一个新的可抛出指定的详细信息和原因。

Throwable(String, Throwable, boolean, boolean) - Constructor for class java.lang. Throwable

构造一个具有指定的详细信息的新的throwable，导致启用或禁用 suppression ，并启用或禁用可写栈跟踪。

Throwable(Throwable) - Constructor for class java.lang. Throwable

构造一个新的可抛出指定的原因和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。

throwConvertedInvocationException(Throwable) - Method in class jdk.jshell.execution. DirectExecutionControl

将用户代码中的传入异常转换为ExecutionControl.ExecutionControlException的子类型，并抛出转换的异常。

throwConvertedInvocationException(Throwable) - Method in class jdk.jshell.execution. RemoteExecutionControl

throwConvertedOtherException(Throwable) - Method in class jdk.jshell.execution. DirectExecutionControl

将代理代码中的传入异常转换为ExecutionControl.ExecutionControlException的子类型的实例，并抛出转换的异常。

throwConvertedOtherException(Throwable) - Method in class jdk.jshell.execution. RemoteExecutionControl

throwException() - Method in class java.nio.charset. CoderResult

抛出与此对象描述的结果相适应的异常。

throwException(Class<?>, Class<? extends Throwable>) - Static method in class java.lang.invoke. MethodHandles

产生一个方法句柄，它将抛出给定的 exType异常。

throwing(String, String, Throwable) - Method in class java.util.logging. Logger

日志抛出异常。

thrownExceptions() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

返回此方法或构造函数抛出的异常。

thrownExceptionTypes() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

返回此方法或构造函数抛出的异常。

THROWS - com.sun.source.doctree. DocTree.Kind

用于表示@throws标签的ThrowsTree的实例。

ThrowsTag - Interface in com.sun.javadoc

已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

throwsTags() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

在此方法中返回throws标签。

ThrowsTree - Interface in com.sun.source.doctree

@exception或@throws块标记的树节点。

ThrowTree - Interface in com.sun.source.tree

一个 throw语句的树节点。

ThrowTree - Interface in jdk.nashorn.api.tree

“throw”语句的树结点。

THUMB - javafx.scene. AccessibleRole

拇指角色。

thumbColor - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

拇指颜色

thumbColor - Static variable in class javax.swing.plaf.metal. MetalSliderUI

拇指的颜色

thumbDarkShadowColor - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

拇指暗影色

thumbHighlightColor - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

拇指高亮颜色

thumbLightShadowColor - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

拇指光阴影色

thumbnailComplete(ImageReader) - Method in interface javax.imageio.event. IIOReadProgressListener

报告缩略图读取操作已完成。

thumbnailComplete(ImageWriter) - Method in interface javax.imageio.event. IIOWriteProgressListener

报告缩略图写入操作已完成。

thumbnailPassComplete(ImageReader, BufferedImage) - Method in interface javax.imageio.event. IIOReadUpdateListener

报告当前缩略图读取操作已经完成了逐行通过。

thumbnailPassStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event. IIOReadUpdateListener

报告当前的缩略图读取操作即将开始逐行传递。

thumbnailProgress(ImageReader, float) - Method in interface javax.imageio.event. IIOReadProgressListener

报告相关 ImageReader当前 getThumbnail电话的大致完成程度。

thumbnailProgress(ImageWriter, float) - Method in interface javax.imageio.event. IIOWriteProgressListener

报告相关联的 ImageWriter内当前缩略图的大致完成程度。

thumbnails - Variable in class javax.imageio. IIOImage

A List的 BufferedImage缩略图，或 null 。

thumbnailStarted(ImageReader, int, int) - Method in interface javax.imageio.event. IIOReadProgressListener

报告缩略图读取操作开始。

thumbnailStarted(ImageWriter, int, int) - Method in interface javax.imageio.event. IIOWriteProgressListener

报告缩略图写入操作开始。

thumbnailUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event. IIOReadUpdateListener

报告缩略图的给定区域已更新。

thumbRect - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

拇指矩形

thumbRect - Variable in class javax.swing.plaf.basic. BasicSliderUI

拇指矩形

THURSDAY - java.time. DayOfWeek

星期四的单日例子。

THURSDAY - Static variable in class java.util. Calendar

Calendar.DAY_OF_WEEK字段的值表示星期四。

TIBETAN - java.awt.font. NumericShaper.Range

藏族数字与西藏数字。

TIBETAN - java.lang. Character.UnicodeScript

Unicode脚本“藏族”。

TIBETAN - Static variable in class java.awt.font. NumericShaper

标识TIBETAN范围和十进制基数。

TIBETAN - Static variable in class java.lang. Character.UnicodeBlock

“西藏”Unicode字符块的常数。

tick(Clock, Duration) - Static method in class java.time. Clock

获取时钟，将时钟从指定的时钟截断返回到指定持续时间的最近出现。

TICK_BUFFER - Variable in class javax.swing.plaf.metal. MetalSliderUI

一个勾号的缓冲区。

tickLabelFillProperty() - Method in class javafx.scene.chart. Axis

填写所有刻度标签

tickLabelFontProperty() - Method in class javafx.scene.chart. Axis

所有刻度标签的字体

tickLabelFormatterProperty() - Method in class javafx.scene.chart. ValueAxis

StringConverter用于格式化刻度线标签。

tickLabelGapProperty() - Method in class javafx.scene.chart. Axis

刻度标签和刻度线之间的差距

tickLabelRotationProperty() - Method in class javafx.scene.chart. Axis

刻度标记以其正常水平旋转。

tickLabelsVisibleProperty() - Method in class javafx.scene.chart. Axis

如果显示标记标签，则为true

tickLength - Static variable in class javax.swing.plaf.metal. MetalSliderUI

刻度的长度。

tickLengthProperty() - Method in class javafx.scene.chart. Axis

刻度线的长度

TickMark() - Constructor for class javafx.scene.chart. Axis.TickMark

创建并初始化TickMark的一个实例。

tickMarksUpdated() - Method in class javafx.scene.chart. Axis

如果已经更新了标记，则在布局期间调用，允许子类在反应中执行所需的任何操作。

tickMarksUpdated() - Method in class javafx.scene.chart. ValueAxis

如果已经更新了标记，则在布局期间调用，允许子类在反应中执行所需的任何操作。

tickMarkVisibleProperty() - Method in class javafx.scene.chart. Axis

如果显示刻度线，则为真

tickMillis(ZoneId) - Static method in class java.time. Clock

获取时钟，使用最佳可用系统时钟返回当前瞬间滴答整数毫秒。

tickMinutes(ZoneId) - Static method in class java.time. Clock

获取时钟，使用最佳可用系统时钟在一分钟内返回当前瞬间滴答。

tickRect - Variable in class javax.swing.plaf.basic. BasicSliderUI

勾选矩形

ticks() - Method in class javax.sound.midi. Track

获取轨道的长度，以MIDI刻度表示。

tickSeconds(ZoneId) - Static method in class java.time. Clock

获取时钟，使用最佳可用系统时钟在一秒钟内返回当前瞬间滴答作响。

tickUnitProperty() - Method in class javafx.scene.chart. NumberAxis

数据单位中每个主要刻度线之间的值。

Tie - Interface in javax.rmi.CORBA

定义所有RMI-IIOP服务器端绑定必须实现的方法。

TIFF_ASCII - Static variable in class javax.imageio.plugins.tiff. TIFFTag

标记为空终止的ASCII字符串。

TIFF_BYTE - Static variable in class javax.imageio.plugins.tiff. TIFFTag

8位无符号整数的标志。

TIFF_DOUBLE - Static variable in class javax.imageio.plugins.tiff. TIFFTag

标志为64位IEEE双精度。

TIFF_FLOAT - Static variable in class javax.imageio.plugins.tiff. TIFFTag

32位IEEE浮标的标志。

TIFF_IFD_POINTER - Static variable in class javax.imageio.plugins.tiff. TIFFTag

TIFF技术说明1中TIFF技术说明1中定义的IFD指针标志。

TIFF_LONG - Static variable in class javax.imageio.plugins.tiff. TIFFTag

32位无符号整数的标志。

TIFF_RATIONAL - Static variable in class javax.imageio.plugins.tiff. TIFFTag

32位无符号整数的标志。

TIFF_SBYTE - Static variable in class javax.imageio.plugins.tiff. TIFFTag

8位有符号整数的标志。

TIFF_SHORT - Static variable in class javax.imageio.plugins.tiff. TIFFTag

标志为16位无符号整数。

TIFF_SLONG - Static variable in class javax.imageio.plugins.tiff. TIFFTag

32位有符号整数的标志。

TIFF_SRATIONAL - Static variable in class javax.imageio.plugins.tiff. TIFFTag

32位有符号整数的标志。

TIFF_SSHORT - Static variable in class javax.imageio.plugins.tiff. TIFFTag

标志为16位有符号整数。

TIFF_UNDEFINED - Static variable in class javax.imageio.plugins.tiff. TIFFTag

8位未解释字节的标志。

TIFFDirectory - Class in javax.imageio.plugins.tiff

简化与TIFF本地图像元数据交互的便利类。

TIFFDirectory(TIFFTagSet[], TIFFTag) - Constructor for class javax.imageio.plugins.tiff. TIFFDirectory

构造一个TIFFDirectory ，它意识到给定的一组TIFFTagSet s。

TIFFField - Class in javax.imageio.plugins.tiff

表示TIFF 6.0图像文件目录中的字段的类。

TIFFField(TIFFTag, int, int) - Constructor for class javax.imageio.plugins.tiff. TIFFField

使用 createArrayForType()构造数据数组，并使用提供的参数和创建的数组调用 TIFFField(TIFFTag,int,int,Object) 。

TIFFField(TIFFTag, int, int, Object) - Constructor for class javax.imageio.plugins.tiff. TIFFField

构造具有任意数据的 TIFFField 。

TIFFField(TIFFTag, int, long, TIFFDirectory) - Constructor for class javax.imageio.plugins.tiff. TIFFField

构造一个具有IFD偏移量和内容的 TIFFField 。

TIFFField(TIFFTag, long) - Constructor for class javax.imageio.plugins.tiff. TIFFField

构造具有单个非负整数值的 TIFFField 。

TIFFImageReadParam - Class in javax.imageio.plugins.tiff

ImageReadParam的子类允许控制TIFF读取过程。

TIFFImageReadParam() - Constructor for class javax.imageio.plugins.tiff. TIFFImageReadParam

构造一个 TIFFImageReadParam 。

TIFFTag - Class in javax.imageio.plugins.tiff

定义TIFF标签概念的类。

TIFFTag(String, int, int) - Constructor for class javax.imageio.plugins.tiff. TIFFTag

构造具有给定名称，标签号和法定数据类型集的 TIFFTag 。

TIFFTag(String, int, int, int) - Constructor for class javax.imageio.plugins.tiff. TIFFTag

构造具有给定名称，标签号，法定数据类型集合和值计数的 TIFFTag 。

TIFFTag(String, int, TIFFTagSet) - Constructor for class javax.imageio.plugins.tiff. TIFFTag

构造一个 TIFFTag ，给定名称，标签号和 TIFFTagSet 。

TIFFTagSet - Class in javax.imageio.plugins.tiff

代表一组TIFF标签的类。

TIFFTagSet(List<TIFFTag>) - Constructor for class javax.imageio.plugins.tiff. TIFFTagSet

构造一个 TIFFTagSet ，给出 List的 TIFFTag对象。

TIFINAGH - java.lang. Character.UnicodeScript

Unicode脚本“Tifinagh”。

TIFINAGH - Static variable in class java.lang. Character.UnicodeBlock

“Tifinagh”Unicode字符块的常数。

tileAlignmentProperty() - Method in class javafx.scene.layout. TilePane

每个孩子在其图块中的默认对齐方式。

tileGridXOffset - Variable in class javax.imageio. ImageWriteParam

如果已经设置了平铺，则瓦片网格原点应从图像原点水平偏移，否则为0。

tileGridYOffset - Variable in class javax.imageio. ImageWriteParam

如果平铺已设置，则瓦片网格原点应与图像原点垂直偏移，否则为0。

tileHeight - Variable in class javax.imageio. ImageWriteParam

每个瓦片的高度如果平铺已设置，否则为0。

tileHeightProperty() - Method in class javafx.scene.layout. TilePane

每个瓷砖的实际高度。

tileIcon - Variable in class javax.swing.border. MatteBorder

用于平铺边框的图标。

TileObserver - Interface in java.awt.image

一个对象的界面，希望在WritableRenderedImage的图块被一些作者通过调用getWritableTile以及当通过最后一次调用releaseWritableTile变得不可修改时被通知。

TilePane - Class in javafx.scene.layout

TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。

TilePane() - Constructor for class javafx.scene.layout. TilePane

创建一个水平的TilePane布局，其中prefColumn = 5和hgap / vgap = 0。

TilePane(double, double) - Constructor for class javafx.scene.layout. TilePane

创建一个水平的TilePane布局，其中prefColumn = 5和指定的hgap / vgap。

TilePane(double, double, Node...) - Constructor for class javafx.scene.layout. TilePane

创建一个水平的TilePane布局，其中prefColumn = 5和指定的hgap / vgap。

TilePane(Orientation) - Constructor for class javafx.scene.layout. TilePane

创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。

TilePane(Orientation, double, double) - Constructor for class javafx.scene.layout. TilePane

使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。

TilePane(Orientation, double, double, Node...) - Constructor for class javafx.scene.layout. TilePane

使用指定的方向hgap / vgap和prefRows / prefColumns = 5创建TilePane布局。

TilePane(Orientation, Node...) - Constructor for class javafx.scene.layout. TilePane

创建具有指定方向的TilePane布局，prefColumn / prefRows = 5和hgap / vgap = 0。

TilePane(Node...) - Constructor for class javafx.scene.layout. TilePane

创建一个水平的TilePane布局，其中prefColumn = 5和hgap / vgap = 0。

tileUpdate(WritableRenderedImage, int, int, boolean) - Method in interface java.awt.image. TileObserver

瓦片即将更新（即将要被书写，或正在从写作中释放）。

tileWidth - Variable in class javax.imageio. ImageWriteParam

每个瓦片的宽度如果已经设置了平铺，否则为0。

tileWidthProperty() - Method in class javafx.scene.layout. TilePane

每个瓷砖的实际宽度。

tilingMode - Variable in class javax.imageio. ImageWriteParam

模式控制平铺设置，其中必须设置为四个 MODE_*值。

tilingSet - Variable in class javax.imageio. ImageWriteParam

A boolean如果已经指定了平铺参数，则为 true 。

time - Variable in class java.util. Calendar

这个日历的当前设定时间，以1970年1月1日，格林尼治标准时间0:00:00之后的毫秒表示。

Time - Class in java.sql

围绕 java.util.Date类的薄包装器，允许JDBC API将其标识为SQL TIME值。

Time(int, int, int) - Constructor for class java.sql. Time

已过时。
使用构造函数，该构造函数需要一个毫秒值来代替此构造函数

Time(long) - Constructor for class java.sql. Time

使用毫秒时间值构造一个 Time对象。

TIME - java.sql. JDBCType

标识通用SQL类型 TIME 。

TIME - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIME 。

TIME - Static variable in class javax.xml.datatype. DatatypeConstants

W3C XML Schema 1.0数据类型 time完全限定名称。

TIME_WITH_TIMEZONE - java.sql. JDBCType

标识通用SQL类型 TIME_WITH_TIMEZONE 。

TIME_WITH_TIMEZONE - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIME WITH TIMEZONE 。

TIME_ZONE - Static variable in class java.text. DateFormat.Field

不断识别时区字段。

TIMED_OUT - Static variable in class javax.print.attribute.standard. PrinterStateReason

服务器能够连接到输出设备（或始终连接），但无法从输出设备获取响应。

TIMED_WAITING - java.lang. Thread.State

具有指定等待时间的等待线程的线程状态。

timedJoin(Thread, long) - Method in enum java.util.concurrent. TimeUnit

使用此时间单位执行定时 Thread.join 。

timedout() - Method in interface com.sun.jdi.event. MonitorWaitedEvent

返回等待是否超时或中断。

timedWait(Object, long) - Method in enum java.util.concurrent. TimeUnit

使用此时间单位执行定时 Object.wait 。

TimeLimitExceededException - Exception in javax.naming

当方法不在指定的时间限制内终止时，抛出此异常。

TimeLimitExceededException() - Constructor for exception javax.naming. TimeLimitExceededException

构造一个新的TimeLimitExceededException实例。

TimeLimitExceededException(String) - Constructor for exception javax.naming. TimeLimitExceededException

使用提供的参数构造一个新的TimeLimitExceededException实例。

Timeline - Class in javafx.animation

A Timeline可用于定义任何WritableValue的自由格式动画，例如，全部为JavaFX Properties 。

Timeline() - Constructor for class javafx.animation. Timeline

构造函数为 Timeline 。

Timeline(double) - Constructor for class javafx.animation. Timeline

构造函数为 Timeline 。

Timeline(double, KeyFrame...) - Constructor for class javafx.animation. Timeline

构造函数为 Timeline 。

Timeline(KeyFrame...) - Constructor for class javafx.animation. Timeline

构造函数为 Timeline 。

timeLineOrder() - Static method in interface java.time.chrono. ChronoLocalDate

获取一个比较器，比较 ChronoLocalDate的时间顺序，忽略年表。

timeLineOrder() - Static method in interface java.time.chrono. ChronoLocalDateTime

获取一个比较器，比较 ChronoLocalDateTime的时间顺序，忽略年表。

timeLineOrder() - Static method in interface java.time.chrono. ChronoZonedDateTime

获取一个比较器，比较 ChronoZonedDateTime的时间顺序忽略年表。

timeLineOrder() - Static method in class java.time. OffsetDateTime

获取一个比较器，只比较两个 OffsetDateTime实例。

timeout() - Method in interface com.sun.jdi.event. MonitorWaitEvent

返回线程等待的毫秒数。

timeout(Duration) - Method in class jdk.incubator.http. HttpRequest.Builder

设置此请求的超时。

TIMEOUT - Exception in org.omg.CORBA

TIMEOUT在没有交货和超过规定的生存时间时被提出。

TIMEOUT() - Constructor for exception org.omg.CORBA. TIMEOUT

构造一个 TIMEOUT异常，次要代码设置为0，CompletionStatus设置为COMPLETED_NO。

TIMEOUT(int, CompletionStatus) - Constructor for exception org.omg.CORBA. TIMEOUT

构造具有指定的次要代码和完成状态的 TIMEOUT异常。

TIMEOUT(String) - Constructor for exception org.omg.CORBA. TIMEOUT

构造具有指定消息的 TIMEOUT异常。

TIMEOUT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. TIMEOUT

构造具有指定消息，次要代码和完成状态的 TIMEOUT异常。

TimeoutException - Exception in java.util.concurrent

阻塞操作超时时抛出异常。

TimeoutException() - Constructor for exception java.util.concurrent. TimeoutException

构造一个没有指定详细消息的 TimeoutException 。

TimeoutException(String) - Constructor for exception java.util.concurrent. TimeoutException

构造具有指定详细消息的 TimeoutException 。

timer - Variable in class javax.swing.plaf.basic. BasicTreeUI.ComponentHandler

定时器用于滚动滚动条中，滚动条正在调整。

timer - Variable in class javax.swing.tree. DefaultTreeCellEditor

在开始编辑会话之前使用。

Timer - Class in java.util

线程调度任务以供将来在后台线程中执行的功能。

Timer - Class in javax.management.timer

提供定时器MBean的实现。

Timer - Class in javax.swing

以指定的间隔触发一个或多个 ActionEvent s。

Timer() - Constructor for class java.util. Timer

创建一个新的计时器。

Timer() - Constructor for class javax.management.timer. Timer

默认构造函数。

Timer(boolean) - Constructor for class java.util. Timer

创建一个新的定时器，其相关线程可以指定为 run as a daemon 。

Timer(int, ActionListener) - Constructor for class javax.swing. Timer

创建一个 Timer ，并将初始延迟和事件间延迟初始化为 delay毫秒。

Timer(String) - Constructor for class java.util. Timer

创建一个新的定时器，其相关线程具有指定的名称。

Timer(String, boolean) - Constructor for class java.util. Timer

创建一个新的定时器，其相关线程具有指定的名称，可以指定为 run as a daemon 。

TimerMBean - Interface in javax.management.timer

暴露计时器MBean的管理界面。

TimerNotification - Class in javax.management.timer

此类提供了定时器MBeans发送的通知的定义。

TimerNotification(String, Object, long, long, String, Integer) - Constructor for class javax.management.timer. TimerNotification

创建定时器通知对象。

TimerTask - Class in java.util

可以由Timer进行一次性或重复执行的任务 。

TimerTask() - Constructor for class java.util. TimerTask

创建一个新的计时器任务。

times(ValueExp, ValueExp) - Static method in class javax.management. Query

返回表示两个数值的乘积的二进制表达式。

TIMES - Static variable in class javax.management. Query

代表 Query.times(javax.management.ValueExp, javax.management.ValueExp)表达式的代码。

timestamp() - Method in class java.util. UUID

与此UUID相关联的时间戳值。

Timestamp - Class in java.security

此类封装了有关已签名时间戳的信息。

Timestamp - Class in java.sql

java.util.Date周围的薄型封装，允许JDBC API将其标识为SQL TIMESTAMP值。

Timestamp(int, int, int, int, int, int, int) - Constructor for class java.sql. Timestamp

已过时。
而是使用构造函数Timestamp(long millis)

Timestamp(long) - Constructor for class java.sql. Timestamp

使用毫秒时间值构造一个 Timestamp对象。

Timestamp(Date, CertPath) - Constructor for class java.security. Timestamp

构建时间戳

TIMESTAMP - java.sql. JDBCType

标识通用SQL类型 TIMESTAMP 。

TIMESTAMP - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIMESTAMP 。

TIMESTAMP_WITH_TIMEZONE - java.sql. JDBCType

标识通用SQL类型 TIMESTAMP_WITH_TIMEZONE 。

TIMESTAMP_WITH_TIMEZONE - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TIMESTAMP WITH TIMEZONE 。

TimeStringConverter - Class in javafx.util.converter

StringConverter代表时间的Date值的实现。

TimeStringConverter() - Constructor for class javafx.util.converter. TimeStringConverter

创建一个StringConverter的Date值，使用DateFormat.DEFAULT时间风格。

TimeStringConverter(int) - Constructor for class javafx.util.converter. TimeStringConverter

创建一个StringConverter的Date值，使用指定的DateFormat时间风格。

TimeStringConverter(String) - Constructor for class javafx.util.converter. TimeStringConverter

创建StringConverter为Date值，使用指定的模式。

TimeStringConverter(DateFormat) - Constructor for class javafx.util.converter. TimeStringConverter

使用DateFormat格式化程序为Date创建一个StringConverter值。

TimeStringConverter(Locale) - Constructor for class javafx.util.converter. TimeStringConverter

使用指定的区域设置和DateFormat.DEFAULT时间样式为Date创建一个StringConverter值。

TimeStringConverter(Locale, int) - Constructor for class javafx.util.converter. TimeStringConverter

使用指定的区域设置和DateFormat时间样式为Date创建一个StringConverter值。

TimeStringConverter(Locale, String) - Constructor for class javafx.util.converter. TimeStringConverter

使用指定的区域设置和模式为Date创建一个StringConverter值。

timeStyle - Variable in class javafx.util.converter. DateTimeStringConverter

timeToLive() - Method in class com.sun.nio.sctp. MessageInfo

如果尚未发送消息，发送端可能会过期的时间段，或 0表示不会发生超时。

timeToLive(long) - Method in class com.sun.nio.sctp. MessageInfo

设置发送方如果尚未发送消息的时间段。

TimeUnit - Enum in java.util.concurrent

A TimeUnit表示给定的粒度单位的持续时间，并提供了跨单位转换的实用方法，并在这些单元中执行定时和延迟操作。

TimeZone - Class in java.util

TimeZone代表时区偏移量，也可以计算出夏令时。

TimeZone() - Constructor for class java.util. TimeZone

唯一的构造函数。

TIMEZONE_FIELD - Static variable in class java.text. DateFormat

TIMEZONE字段对齐的常用常数。

TimeZoneNameProvider - Class in java.util.spi

为TimeZone类提供本地化时区名称的服务提供商的抽象类。

TimeZoneNameProvider() - Constructor for class java.util.spi. TimeZoneNameProvider

唯一的构造函数。

TIMING_CLOCK - Static variable in class javax.sound.midi. ShortMessage

定时时钟消息的状态字节（0xF8或248）。

TINYINT - java.sql. JDBCType

标识通用SQL类型 TINYINT 。

TINYINT - Static variable in class java.sql. Types

Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 TINYINT 。

TIRHUTA - java.lang. Character.UnicodeScript

Unicode脚本“Tirhuta”。

TIRHUTA - Static variable in class java.lang. Character.UnicodeBlock

“Tirhuta”Unicode字符块的常量。

title - Variable in class javax.swing.border. TitledBorder

边界应该显示的标题。

title - Variable in class javax.swing. JInternalFrame

标题显示在此内部框架的标题栏中。

title - Variable in class javax.swing.text.html.parser. DTD

与标题对应的元素。

TITLE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“标题”

TITLE - Static variable in class javax.swing.text.html. HTML.Tag

标签<title>

TITLE_PROPERTY - Static variable in class javax.swing. JInternalFrame

绑定属性名称。

TITLECASE_LETTER - Static variable in class java.lang. Character

Unicode规范中的常规类别“Lt”。

titleColor - Variable in class javax.swing.border. TitledBorder

标题的颜色。

TITLED_PANE - javafx.scene. AccessibleRole

标题窗格角色。

TitledBorder - Class in javax.swing.border

一个实现一个任意边框的类，在一个指定的位置添加一个String标题和对齐。

TitledBorder(String) - Constructor for class javax.swing.border. TitledBorder

创建一个TitledBorder实例。

TitledBorder(Border) - Constructor for class javax.swing.border. TitledBorder

创建带有指定边框和空标题的TitledBorder实例。

TitledBorder(Border, String) - Constructor for class javax.swing.border. TitledBorder

创建带有指定边框和标题的TitledBorder实例。

TitledBorder(Border, String, int, int) - Constructor for class javax.swing.border. TitledBorder

创建一个带有指定边框，标题，标题对齐和标题位置的TitledBorder实例。

TitledBorder(Border, String, int, int, Font) - Constructor for class javax.swing.border. TitledBorder

创建带有指定边框，标题，标题对齐，标题位置和标题字体的TitledBorder实例。

TitledBorder(Border, String, int, int, Font, Color) - Constructor for class javax.swing.border. TitledBorder

创建带有指定边框，标题，标题对齐，标题位置，标题字体和标题颜色的TitledBorder实例。

TitledBorderUIResource(String) - Constructor for class javax.swing.plaf. BorderUIResource.TitledBorderUIResource

构造一个 TitledBorderUIResource 。

TitledBorderUIResource(Border) - Constructor for class javax.swing.plaf. BorderUIResource.TitledBorderUIResource

构造一个 TitledBorderUIResource 。

TitledBorderUIResource(Border, String) - Constructor for class javax.swing.plaf. BorderUIResource.TitledBorderUIResource

构造一个 TitledBorderUIResource 。

TitledBorderUIResource(Border, String, int, int) - Constructor for class javax.swing.plaf. BorderUIResource.TitledBorderUIResource

构造一个 TitledBorderUIResource 。

TitledBorderUIResource(Border, String, int, int, Font) - Constructor for class javax.swing.plaf. BorderUIResource.TitledBorderUIResource

构造一个 TitledBorderUIResource 。

TitledBorderUIResource(Border, String, int, int, Font, Color) - Constructor for class javax.swing.plaf. BorderUIResource.TitledBorderUIResource

构造一个 TitledBorderUIResource 。

TitledPane - Class in javafx.scene.control

TitledPane是一个可以打开和关闭的标题的面板。

TitledPane() - Constructor for class javafx.scene.control. TitledPane

创建一个没有标题或内容的新TitledPane。

TitledPane(String, Node) - Constructor for class javafx.scene.control. TitledPane

创建一个标题和内容的新TitledPane。

TitledPaneSkin - Class in javafx.scene.control.skin

默认皮肤实现为TitledPane控件。

TitledPaneSkin(TitledPane) - Constructor for class javafx.scene.control.skin. TitledPaneSkin

创建一个新的TitledPaneSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

titleFont - Variable in class javax.swing.border. TitledBorder

用于呈现标题的字体。

titleJustification - Variable in class javax.swing.border. TitledBorder

标题的理由。

titlePane - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI

标题窗格

TitlePaneLayout() - Constructor for class javax.swing.plaf.basic. BasicInternalFrameTitlePane.TitlePaneLayout

titlePosition - Variable in class javax.swing.border. TitledBorder

标题的位置。

titleProperty() - Method in class javafx.concurrent. Service

titleProperty() - Method in class javafx.concurrent. Task

titleProperty() - Method in interface javafx.concurrent. Worker

获取表示标题的ReadOnlyStringProperty。

titleProperty() - Method in class javafx.scene.chart. Chart

图表标题

titleProperty() - Method in class javafx.scene.control. Dialog

返回对话框的titleProperty。

titleProperty() - Method in class javafx.scene.web. WebEngine

当前网页的标题。

titleProperty() - Method in class javafx.scene.web. WebHistory.Entry

定义页面的标题。

titleProperty() - Method in class javafx.stage. DirectoryChooser

显示对话框的标题。

titleProperty() - Method in class javafx.stage. FileChooser

显示文件对话框的标题。

titleProperty() - Method in class javafx.stage. Stage

定义 Stage的标题。

TitleProperty - Static variable in interface javax.swing.text. Document

文件标题的属性名称，如果有的话。

titleSideProperty() - Method in class javafx.scene.chart. Chart

显示标题的图表侧

tk_abstract_interface - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_alias - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_any - Static variable in class org.omg.CORBA. TCKind

其 TCKind常量的 value字段用 TCKind.初始化

tk_array - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_boolean - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_char - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_double - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_enum - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_except - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_fixed - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_float - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_long - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_longdouble - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_longlong - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_native - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_null - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_objref - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_octet - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_Principal - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_sequence - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_short - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_string - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_struct - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_TypeCode - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_ulong - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_ulonglong - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_union - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_ushort - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_value - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_value_box - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_void - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

tk_wchar - Static variable in class org.omg.CORBA. TCKind

TCKind常数，其 value字段用 TCKind.初始化

tk_wstring - Static variable in class org.omg.CORBA. TCKind

TCKind常量，其 value字段用 TCKind.初始化

TMENDRSCAN - Static variable in interface javax.transaction.xa. XAResource

结束恢复扫描。

TMFAIL - Static variable in interface javax.transaction.xa. XAResource

将呼叫方解除关联，并标记事务分支回滚。

TMJOIN - Static variable in interface javax.transaction.xa. XAResource

来电者正在加入现有的交易分支。

TMNOFLAGS - Static variable in interface javax.transaction.xa. XAResource

使用TMNOFLAGS表示没有选择标志值。

TMONEPHASE - Static variable in interface javax.transaction.xa. XAResource

来电者正在使用单相优化。

TMRESUME - Static variable in interface javax.transaction.xa. XAResource

来电者正在恢复与暂停的交易分支的关联。

TMSTARTRSCAN - Static variable in interface javax.transaction.xa. XAResource

启动恢复扫描。

TMSUCCESS - Static variable in interface javax.transaction.xa. XAResource

从一个事务分支解除呼叫者。

TMSUSPEND - Static variable in interface javax.transaction.xa. XAResource

来电者暂停（不结束）其与交易分支的关联。

to(File) - Static method in class java.lang. ProcessBuilder.Redirect

返回写入指定文件的重定向。

to(Class<T>) - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

将此脚本对象转换为给定类型的实用程序。

to(TimeUnit) - Method in class java.nio.file.attribute. FileTime

返回给定的粒度单位的值。

to_any() - Method in interface org.omg.CORBA. DynAny

已过时。

将 DynAny对象转换为 Any对象。

to_any() - Method in class org.omg.DynamicAny. _DynAnyStub

从DynAny对象创建任何值。

to_any() - Method in class org.omg.DynamicAny. _DynArrayStub

从DynAny对象创建任何值。

to_any() - Method in class org.omg.DynamicAny. _DynEnumStub

从DynAny对象创建任何值。

to_any() - Method in class org.omg.DynamicAny. _DynFixedStub

从DynAny对象创建任何值。

to_any() - Method in class org.omg.DynamicAny. _DynSequenceStub

从DynAny对象创建任何值。

to_any() - Method in class org.omg.DynamicAny. _DynStructStub

从DynAny对象创建任何值。

to_any() - Method in class org.omg.DynamicAny. _DynUnionStub

从DynAny对象创建任何值。

to_any() - Method in class org.omg.DynamicAny. _DynValueStub

从DynAny对象创建任何值。

to_any() - Method in interface org.omg.DynamicAny. DynAnyOperations

从DynAny对象创建任何值。

to_name(String) - Method in class org.omg.CosNaming. _NamingContextExtStub

此操作将字符串名称转换为等效的名称组件数组。

to_name(String) - Method in interface org.omg.CosNaming. NamingContextExtOperations

此操作将字符串名称转换为等效的名称组件数组。

to_string(NameComponent[]) - Method in class org.omg.CosNaming. _NamingContextExtStub

此操作从名称组件数组中创建一个带字符串的名称。

to_string(NameComponent[]) - Method in interface org.omg.CosNaming. NamingContextExtOperations

此操作从名称组件数组中创建一个带字符串的名称。

to_url(String, String) - Method in class org.omg.CosNaming. _NamingContextExtStub

此操作将从对象的Stringified Name创建一个基于URL的“iiopname：//”格式名称。

to_url(String, String) - Method in interface org.omg.CosNaming. NamingContextExtOperations

此操作将从对象的Stringified Name创建一个基于URL的“iiopname：//”格式名称。

toAbsolutePath() - Method in interface java.nio.file. Path

返回表示此路径的绝对路径的 Path对象。

toAngleProperty() - Method in class javafx.animation. RotateTransition

指定此 RotateTransition的停止角度值。

toArray() - Method in class java.awt.dnd. DragGestureEvent

返回包含拖动手势的事件的 Object数组。

toArray() - Method in class java.beans.beancontext. BeanContextMembershipEvent

获取受此事件影响的子项数组。

toArray() - Method in class java.beans.beancontext. BeanContextSupport

获取当前嵌套在此BeanContext中的所有JavaBean或 BeanContext实例。

toArray() - Method in class java.util. AbstractCollection

返回一个包含此集合中所有元素的数组。

toArray() - Method in class java.util. ArrayDeque

以适当的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）。

toArray() - Method in class java.util. ArrayList

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

toArray() - Method in interface java.util. Collection

返回一个包含此集合中所有元素的数组。

toArray() - Method in class java.util.concurrent. ArrayBlockingQueue

以适当的顺序返回一个包含此队列中所有元素的数组。

toArray() - Method in class java.util.concurrent. ConcurrentLinkedDeque

以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。

toArray() - Method in class java.util.concurrent. ConcurrentLinkedQueue

以适当的顺序返回一个包含此队列中所有元素的数组。

toArray() - Method in class java.util.concurrent. CopyOnWriteArrayList

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

toArray() - Method in class java.util.concurrent. CopyOnWriteArraySet

返回一个包含此集合中所有元素的数组。

toArray() - Method in class java.util.concurrent. DelayQueue

返回一个包含此队列中所有元素的数组。

toArray() - Method in class java.util.concurrent. LinkedBlockingDeque

以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。

toArray() - Method in class java.util.concurrent. LinkedBlockingQueue

以适当的顺序返回一个包含此队列中所有元素的数组。

toArray() - Method in class java.util.concurrent. LinkedTransferQueue

以适当的顺序返回一个包含此队列中所有元素的数组。

toArray() - Method in class java.util.concurrent. PriorityBlockingQueue

返回一个包含此队列中所有元素的数组。

toArray() - Method in class java.util.concurrent. SynchronousQueue

返回零长度数组。

toArray() - Method in class java.util. LinkedList

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

toArray() - Method in interface java.util. List

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

toArray() - Method in class java.util. PriorityQueue

返回一个包含此队列中所有元素的数组。

toArray() - Method in interface java.util. Set

返回一个包含此集合中所有元素的数组。

toArray() - Method in interface java.util.stream. DoubleStream

返回一个包含此流的元素的数组。

toArray() - Method in interface java.util.stream. IntStream

返回一个包含此流的元素的数组。

toArray() - Method in interface java.util.stream. LongStream

返回一个包含此流的元素的数组。

toArray() - Method in interface java.util.stream. Stream

返回一个包含此流的元素的数组。

toArray() - Method in class java.util. Vector

以正确的顺序返回一个包含此Vector中所有元素的数组。

toArray() - Method in class javafx.beans.binding. ListExpression

toArray() - Method in class javafx.beans.binding. SetExpression

toArray() - Method in class javax.accessibility. AccessibleRelationSet

将当前关系集返回为 AccessibleRelation的数组。

toArray() - Method in class javax.accessibility. AccessibleStateSet

将当前状态设置为 AccessibleState的数组。

toArray() - Method in interface javax.print.attribute. AttributeSet

返回此集合中包含的属性的数组。

toArray() - Method in class javax.print.attribute. HashAttributeSet

toArray() - Method in class javax.swing. DefaultListModel

以正确的顺序返回包含此列表中所有元素的数组。

toArray(float[]) - Method in interface javafx.collections. ObservableFloatArray

返回包含observable数组的副本的数组。

toArray(int[]) - Method in interface javafx.collections. ObservableIntegerArray

返回包含observable数组的副本的数组。

toArray(int, float[], int) - Method in interface javafx.collections. ObservableFloatArray

返回包含observable数组的指定部分的数组的数组。

toArray(int, int[], int) - Method in interface javafx.collections. ObservableIntegerArray

返回包含observable数组的指定部分的数组的数组。

toArray(Object[]) - Method in class java.awt.dnd. DragGestureEvent

返回包含拖动手势的事件数组。

toArray(Object[]) - Method in class java.beans.beancontext. BeanContextSupport

获取一个包含此 BeanContext所有子项的数组，该数组与 BeanContext中包含的类型相匹配。

toArray(IntFunction<A[]>) - Method in interface java.util.stream. Stream

使用提供的 generator函数返回一个包含此流的元素的数组，以分配返回的数组，以及分区执行或调整大小可能需要的任何其他数组。

toArray(MatrixType) - Method in class javafx.scene.transform. Transform

返回一个包含展平变换矩阵的数组。

toArray(MatrixType, double[]) - Method in class javafx.scene.transform. Transform

返回一个包含展平变换矩阵的数组。

toArray(T[]) - Method in class java.util. AbstractCollection

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util. ArrayDeque

以正确的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util. ArrayList

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in interface java.util. Collection

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. ArrayBlockingQueue

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. ConcurrentLinkedDeque

以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. ConcurrentLinkedQueue

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. CopyOnWriteArrayList

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. CopyOnWriteArraySet

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. DelayQueue

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. LinkedBlockingDeque

以适当的顺序返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. LinkedBlockingQueue

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. LinkedTransferQueue

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. PriorityBlockingQueue

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util.concurrent. SynchronousQueue

将指定数组的第零个元素设置为 null （如果数组具有非零长度）并返回。

toArray(T[]) - Method in class java.util. LinkedList

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in interface java.util. List

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util. PriorityQueue

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in interface java.util. Set

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class java.util. Vector

以正确的顺序返回一个包含此Vector中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

toArray(T[]) - Method in class javafx.beans.binding. ListExpression

toArray(T[]) - Method in class javafx.beans.binding. SetExpression

toASCII(String) - Static method in class java.net. IDN

将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。

toASCII(String, int) - Static method in class java.net. IDN

将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。

toASCIIString() - Method in class java.net. URI

将此URI的内容作为US-ASCII字符串返回。

toAttributes() - Method in class javax.naming.ldap. Rdn

检索此Rdn中包含的类型/值映射的Attributes视图。

toBack() - Method in class java.awt. Dialog

如果此窗口可见，则将此窗口发送到后面，如果该窗口是聚焦窗口或活动窗口，则可能导致其失去焦点或激活。

toBack() - Method in class java.awt. Window

如果此窗口可见，则将此窗口发送到后面，如果该窗口是聚焦窗口或活动窗口，则可能导致其失去焦点或激活。

toBack() - Method in class javafx.scene. Node

将这个 Node移动到其兄弟节点的背面，这是z顺序的。

toBack() - Method in class javafx.stage. Stage

发送 Window到背景。

toBack() - Method in class javax.swing. JInternalFrame

将这个内部框架发送到后面。

toBigInteger() - Method in class java.math. BigDecimal

将此 BigDecimal转换为 BigInteger 。

toBigIntegerExact() - Method in class java.math. BigDecimal

将此 BigDecimal转换为 BigInteger ，检查丢失的信息。

toBinaryString(int) - Static method in class java.lang. Integer

在基数2中返回整数参数的字符串表示形式为无符号整数。

toBinaryString(long) - Static method in class java.lang. Long

将 long参数的字符串表示形式返回为基数2中的无符号整数。

TOBOTTOM_TOLEFT - Static variable in class javax.print.attribute.standard. PresentationDirection

页面从右上方列出，从左到右。

TOBOTTOM_TORIGHT - Static variable in class javax.print.attribute.standard. PresentationDirection

页面从左上方开始列出，向下和向右移动。

toBundleName(String, Locale) - Method in class java.util. ResourceBundle.Control

将给定的 baseName和 locale转换为包名称。

toBundleName(String, Locale) - Method in class java.util.spi. AbstractResourceBundleProvider

返回此提供程序提供的给定 baseName和 locale的软件包名称。

toByteArray() - Method in class java.io. ByteArrayOutputStream

创建一个新分配的字节数组。

toByteArray() - Method in class java.math. BigInteger

返回一个包含此BigInteger的二进制补码表示的字节数组。

toByteArray() - Method in class java.text. CollationKey

将CollationKey转换为位序列。

toByteArray() - Method in class java.util. BitSet

返回一个包含该位集中所有位的新字节数组。

toCachedRowSet() - Method in interface javax.sql.rowset. JoinRowSet

创建一个新的 CachedRowSet包含此数据对象 JoinRowSet对象，它可以保存到使用数据源 SyncProvider对象为 CachedRowSet对象。

toCharArray() - Method in class java.io. CharArrayWriter

返回输入数据的副本。

toCharArray() - Method in class java.lang. String

将此字符串转换为新的字符数组。

toChars(int) - Static method in class java.lang. Character

将指定的字符（Unicode代码点）转换为存储在 char数组中的UTF-16表示形式。

toChars(int, char[], int) - Static method in class java.lang. Character

将指定的字符（Unicode代码点）转换为其UTF-16表示形式。

toChronoUnit() - Method in enum java.util.concurrent. TimeUnit

将此 TimeUnit转换为等效的 ChronoUnit 。

toCIEXYZ(float[]) - Method in class java.awt.color. ColorSpace

将此ColorSpace中假定为的颜色值转换为CS_CIEXYZ转换颜色空间。

toCIEXYZ(float[]) - Method in class java.awt.color. ICC_ColorSpace

将此ColorSpace中假定为的颜色值转换为CS_CIEXYZ转换颜色空间。

toCodePoint(char, char) - Static method in class java.lang. Character

将指定的代理对转换为其补充代码点值。

toCollection() - Method in interface javax.sql.rowset. CachedRowSet

这个转换 CachedRowSet对象为 Collection包含所有这一切的目的 CachedRowSet对象的数据。

toCollection(int) - Method in interface javax.sql.rowset. CachedRowSet

将此 CachedRowSet对象中的指定列转换为 Collection对象。

toCollection(String) - Method in interface javax.sql.rowset. CachedRowSet

将此 CachedRowSet对象中的指定列转换为 Collection对象。

toCollection(Supplier<C>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，按照遇到的顺序将输入元素累加到新的 Collection中。

toCompletableFuture() - Method in class java.util.concurrent. CompletableFuture

返回此CompletableFuture。

toCompletableFuture() - Method in interface java.util.concurrent. CompletionStage

返回一个CompletableFuture维持与这个阶段相同的完成属性。

toCompositeData(CompositeType) - Method in class com.sun.management. GarbageCollectionNotificationInfo

toCompositeData(CompositeType) - Method in class com.sun.management. GcInfo

返回 CompositeData如此表示 GcInfo ，包括任何具体的GC-属性。

toCompositeData(CompositeType) - Method in interface javax.management.openmbean. CompositeDataView

返回对应于此对象中的值的 CompositeData 。

toConcurrentMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>) - Static method in class java.util.stream. Collectors

返回一个并发的 Collector ，它将元素累加到 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。

toConcurrentMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>) - Static method in class java.util.stream. Collectors

返回一个并发的 Collector ，它将元素累加到一个 ConcurrentMap其键和值是将提供的映射函数应用于输入元素的结果。

toConcurrentMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>, Supplier<M>) - Static method in class java.util.stream. Collectors

返回一个并发的 Collector ，它将元素累加到一个 ConcurrentMap其键和值是将所提供的映射函数应用于输入元素的结果。

toDays() - Method in class java.time. Duration

获取此持续时间的天数。

toDays(long) - Method in enum java.util.concurrent. TimeUnit

相当于 DAYS.convert(duration, this) 。

toDaysPart() - Method in class java.time. Duration

提取持续时间的天数。

toDegrees(double) - Static method in class java.lang. Math

将以弧度测量的角度转换为以度为单位的近似等效角度。

toDegrees(double) - Static method in class java.lang. StrictMath

将以弧度测量的角度转换为以度为单位的近似等效角度。

toDisplayString() - Method in class javax.accessibility. AccessibleBundle

使用默认语言环境获取描述密钥的本地化字符串。

toDisplayString(String, Locale) - Method in class javax.accessibility. AccessibleBundle

获取密钥作为本地化字符串。

toDisplayString(Locale) - Method in class javax.accessibility. AccessibleBundle

获取密钥作为本地化字符串。

ToDoubleBiFunction< T, U> - Interface in java.util.function

表示接受两个参数并产生双值结果的函数。

ToDoubleFunction< T> - Interface in java.util.function

表示产生双值结果的函数。

toEngineeringString() - Method in class java.math. BigDecimal

如果需要指数，则使用工程符号返回此 BigDecimal的字符串表示形式。

toEpochDay() - Method in interface java.time.chrono. ChronoLocalDate

将此日期转换为大纪元日。

toEpochDay() - Method in class java.time.chrono. HijrahDate

toEpochDay() - Method in class java.time.chrono. JapaneseDate

toEpochDay() - Method in class java.time.chrono. MinguoDate

toEpochDay() - Method in class java.time.chrono. ThaiBuddhistDate

toEpochDay() - Method in class java.time. LocalDate

toEpochMilli() - Method in class java.time. Instant

将此瞬间转换为1970-01-01T00：00：00Z的时期的毫秒数。

toEpochSecond() - Method in interface java.time.chrono. ChronoZonedDateTime

将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。

toEpochSecond() - Method in class java.time. OffsetDateTime

将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。

toEpochSecond() - Method in class java.time.zone. ZoneOffsetTransition

将转换瞬间作为第二纪。

toEpochSecond(LocalDate) - Method in class java.time. OffsetTime

将此 OffsetTime转换为从1970-01-01T00：00：00Z开始的秒数。

toEpochSecond(LocalDate, ZoneOffset) - Method in class java.time. LocalTime

将此 LocalTime转换为1970-01-01T00：00：00Z的时代以来的秒数。

toEpochSecond(LocalTime, ZoneOffset) - Method in class java.time. LocalDate

将此 LocalDate转换为1970-01-01T00：00：00Z以来的秒数。

toEpochSecond(ZoneOffset) - Method in interface java.time.chrono. ChronoLocalDateTime

将此日期时间转换为从1970-01-01T00：00：00Z的时期开始的秒数。

toExternalForm() - Method in class java.net. URL

构造一个 URL的字符串表示 URL 。

toExternalForm(URL) - Method in class java.net. URLStreamHandler

一个转换 URL特定协议到的 String 。

toFile() - Method in interface java.nio.file. Path

返回表示此路径的File对象。

toFormat() - Method in class java.time.format. DateTimeFormatter

作为 java.text.Format实例返回此格式化程序。

toFormat(TemporalQuery<?>) - Method in class java.time.format. DateTimeFormatter

将此格式化程序作为 java.text.Format实例返回，使用指定的查询进行解析。

toFormatter() - Method in class java.time.format. DateTimeFormatterBuilder

通过使用默认语言环境创建 DateTimeFormatter来完成此构建器。

toFormatter(Locale) - Method in class java.time.format. DateTimeFormatterBuilder

通过使用指定的区域设置创建 DateTimeFormatter来完成此构建器。

toFront() - Method in class java.awt. Window

如果此窗口可见，将此窗口放在前面，并可能使其成为聚焦窗口。

toFront() - Method in class javafx.scene. Node

将这个 Node按照z顺序移动到其兄弟节点的前面。

toFront() - Method in class javafx.stage. Stage

把 Window带到前台。

toFront() - Method in class javax.swing. JInternalFrame

将这个内部框架放在前面。

toFXImage(BufferedImage, WritableImage) - Static method in class javafx.embed.swing. SwingFXUtils

快照指定的BufferedImage并将其像素的副本存储到JavaFX Image对象中，如果需要，创建一个新对象。

toGenericString() - Method in class java.lang. Class

返回描述此 Class的字符串，包括有关修饰符和类型参数的信息。

toGenericString() - Method in class java.lang.reflect. Constructor

返回描述此 Constructor的字符串，包括类型参数。

toGenericString() - Method in class java.lang.reflect. Executable

返回描述此 Executable的字符串，包括任何类型的参数。

toGenericString() - Method in class java.lang.reflect. Field

返回描述此 Field的字符串，包括其泛型类型。

toGenericString() - Method in class java.lang.reflect. 方法

返回描述此 方法的字符串，包括类型参数。

Toggle - Interface in javafx.scene.control

表示可以在选定状态和未选择状态之间切换的控件。

TOGGLE_BUTTON - javafx.scene. AccessibleRole

切换按钮角色。

TOGGLE_BUTTON - Static variable in class javax.accessibility. AccessibleRole

可以检查或取消选中的专用按钮，但不提供当前状态的单独指示器。

TOGGLE_BUTTON - Static variable in class javax.swing.plaf.synth. Region

ToggleButton区域。

TOGGLE_CLICK_COUNT_PROPERTY - Static variable in class javax.swing. JTree

绑定属性名称为 toggleClickCount 。

TOGGLE_EXPAND - Static variable in interface javax.accessibility. AccessibleAction

如果展开并导致树状节点折叠的动作，如果已折叠则展开。

TOGGLE_POPUP - Static variable in interface javax.accessibility. AccessibleAction

一个弹出窗口在隐藏并隐藏（如果可见）时变得可见的操作。

ToggleButton - Class in javafx.scene.control

A ToggleButton是具有选择能力的专业控制。

ToggleButton() - Constructor for class javafx.scene.control. ToggleButton

为其标签创建一个空字符串的切换按钮。

ToggleButton(String) - Constructor for class javafx.scene.control. ToggleButton

创建具有指定文本的切换按钮作为其标签。

ToggleButton(String, Node) - Constructor for class javafx.scene.control. ToggleButton

创建一个切换按钮，其标签具有指定的文本和图标。

ToggleButtonBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.ToggleButtonBorder

ToggleButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic. BasicBorders.ToggleButtonBorder

构造一个新的实例 ToggleButtonBorder 。

ToggleButtonModel() - Constructor for class javax.swing. JToggleButton.ToggleButtonModel

创建一个新的ToggleButton模型

ToggleButtonSkin - Class in javafx.scene.control.skin

默认皮肤实现为ToggleButton控件。

ToggleButtonSkin(ToggleButton) - Constructor for class javafx.scene.control.skin. ToggleButtonSkin

创建一个新的ToggleButtonSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

toggleClickCount - Variable in class javax.swing. JTree

节点扩展前的鼠标点击次数

toggleExpandState(TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI

如果路径未展开，则展开路径，如果扩展则折叠行。

ToggleGroup - Class in javafx.scene.control

它包含所有的引用的类 Toggles其 selected变量应该被管理，使得仅仅单个 Toggle的内 ToggleGroup可以在任一周时间来选择。

ToggleGroup() - Constructor for class javafx.scene.control. ToggleGroup

创建一个默认的ToggleGroup实例。

toggleGroupProperty() - Method in class javafx.scene.control. RadioMenuItem

表示此RadioMenuItem所属的ToggleGroup 。

toggleGroupProperty() - Method in interface javafx.scene.control. Toggle

该ToggleGroup到这个Toggle所属。

toggleGroupProperty() - Method in class javafx.scene.control. ToggleButton

该ToggleGroup到这个ToggleButton所属。

toggleOpenClose() - Method in class javax.swing.plaf.basic. BasicComboBoxUI

隐藏弹出窗口，如果它正在显示，并显示弹出窗口，如果它是隐藏的。

togglePopup() - Method in class javax.swing.plaf.basic. BasicComboPopup

使弹出窗口可见，如果它是隐藏的，并使其隐藏，如果它是可见的。

toggleSortOrder(int) - Method in class javax.swing. DefaultRowSorter

如果指定的列已经是主排序列，则将排序顺序从升序到降序（或降序升序）反转; 否则，使指定的列成为主排序列，具有升序的排序顺序。

toggleSortOrder(int) - Method in class javax.swing. RowSorter

反转指定列的排序顺序。

toGMTString() - Method in class java.util. Date

已过时。
从JDK 1.1版起，用DateFormat.format(Date date)替换，使用GMT TimeZone 。

toGregorianCalendar() - Method in class javax.xml.datatype. XMLGregorianCalendar

将此XMLGregorianCalendar转换为GregorianCalendar 。

toGregorianCalendar(TimeZone, Locale, XMLGregorianCalendar) - Method in class javax.xml.datatype. XMLGregorianCalendar

将此XMLGregorianCalendar与提供的参数一起转换为GregorianCalendar实例。

toHandle() - Method in class java.lang. Process

返回进程的ProcessHandle。

toHexString(double) - Static method in class java.lang. Double

返回 double参数的十六进制字符串表示形式。

toHexString(float) - Static method in class java.lang. Float

返回 float参数的十六进制字符串表示形式。

toHexString(int) - Static method in class java.lang. Integer

返回整数参数的字符串表示形式，作为16位中的无符号整数。

toHexString(long) - Static method in class java.lang. Long

返回 long参数的字符串表示形式，作为16位中的无符号整数。

toHours() - Method in class java.time. Duration

获取此持续时间内的小时数。

toHours() - Method in class javafx.util. Duration

返回此期间的小时数，如果期间为INDEFINITE，则为Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。

toHours(long) - Method in enum java.util.concurrent. TimeUnit

相当于 HOURS.convert(duration, this) 。

toHoursPart() - Method in class java.time. Duration

提取持续时间部分的小时数。

toIndex - Variable in class javax.swing.event. TableColumnModelEvent

列的索引移动或添加到的位置

toInstant() - Method in class java.nio.file.attribute. FileTime

将此 FileTime对象转换为 Instant 。

toInstant() - Method in class java.sql. Date

此方法总是引发UnsupportedOperationException，因为SQL Date值没有时间组件，因此不应该使用它。

toInstant() - Method in class java.sql. Time

此方法总是引发UnsupportedOperationException，因为SQL Time值不具有日期组件，因此不应该使用此方法。

toInstant() - Method in class java.sql. Timestamp

将此 Timestamp对象转换为 Instant 。

toInstant() - Method in interface java.time.chrono. ChronoZonedDateTime

将此日期时间转换为 Instant 。

toInstant() - Method in class java.time. OffsetDateTime

将此日期时间转换为 Instant 。

toInstant() - Method in class java.util. Calendar

将此对象转换为Instant 。

toInstant() - Method in class java.util. Date

将此 Date对象转换为 Instant 。

toInstant(ZoneOffset) - Method in interface java.time.chrono. ChronoLocalDateTime

将此日期时间转换为 Instant 。

ToIntBiFunction< T, U> - Interface in java.util.function

表示一个接受两个参数并产生一个int值结果的函数。

toIntExact(long) - Static method in class java.lang. Math

返回值为long参数; 如果值溢出int则抛出异常。

toIntExact(long) - Static method in class java.lang. StrictMath

返回值为long参数; 如果值溢出int则抛出异常。

ToIntFunction< T> - Interface in java.util.function

表示产生一个int值结果的函数。

toJMXConnector(Map<String, ?>) - Method in class javax.management.remote. JMXConnectorServer

返回此连接器服务器的客户端存根。

toJMXConnector(Map<String, ?>) - Method in interface javax.management.remote. JMXConnectorServerMBean

返回此连接器服务器的客户端存根。

toJMXConnector(Map<String, ?>) - Method in class javax.management.remote.rmi. RMIConnectorServer

返回此连接器服务器的客户端存根。

tokens() - Method in class java.util. Scanner

从此扫描仪返回一个分隔符的分隔符号流。

toLanguageTag() - Method in class java.util. Locale

返回一个格式正确的IETF BCP 47语言标签，代表这个区域。

TOLEFT_TOBOTTOM - Static variable in class javax.print.attribute.standard. PresentationDirection

页面从右上角开始排列，向左和向下移动。

TOLEFT_TOTOP - Static variable in class javax.print.attribute.standard. PresentationDirection

页面从右下方开始排列，向左和向上移动。

toList() - Static method in class java.util.stream. Collectors

返回一个 Collector ，将输入元素累加到一个新的 List 。

toLocalDate() - Method in class java.sql. Date

使用这个 Date对象的年，月和日创建一个 LocalDate实例。

toLocalDate() - Method in interface java.time.chrono. ChronoLocalDateTime

获取此日期时间的本地日期部分。

toLocalDate() - Method in interface java.time.chrono. ChronoZonedDateTime

获取此日期时间的本地日期部分。

toLocalDate() - Method in class java.time. LocalDateTime

获得这个日期时间的 LocalDate部分。

toLocalDate() - Method in class java.time. OffsetDateTime

获取此日期时间的 LocalDate部分。

toLocalDate() - Method in class java.time. ZonedDateTime

获得这个日期时间的 LocalDate部分。

toLocalDateTime() - Method in class java.sql. Timestamp

将此 Timestamp对象转换为 LocalDateTime 。

toLocalDateTime() - Method in interface java.time.chrono. ChronoZonedDateTime

获取此日期时间的本地日期时间部分。

toLocalDateTime() - Method in class java.time. OffsetDateTime

获得这个日期时间的 LocalDateTime部分。

toLocalDateTime() - Method in class java.time. ZonedDateTime

获取此日期时间的 LocalDateTime部分。

toLocaleString() - Method in class java.util. Date

已过时。
从JDK 1.1版开始，由DateFormat.format(Date date)替代。

toLocalizedPattern() - Method in class java.text. DecimalFormat

合成表示此Format对象的当前状态的本地化模式字符串。

toLocalizedPattern() - Method in class java.text. SimpleDateFormat

返回描述此日期格式的本地化模式字符串。

toLocalTime() - Method in class java.sql. Time

将此 Time对象转换为 LocalTime 。

toLocalTime() - Method in interface java.time.chrono. ChronoLocalDateTime

获取此日期时间的当地时间部分。

toLocalTime() - Method in interface java.time.chrono. ChronoZonedDateTime

获取此日期时间的当地时间部分。

toLocalTime() - Method in class java.time. LocalDateTime

获得这个日期时间的 LocalTime部分。

toLocalTime() - Method in class java.time. OffsetDateTime

获得这个日期时间的 LocalTime部分。

toLocalTime() - Method in class java.time. OffsetTime

获取此日期时间的 LocalTime部分。

toLocalTime() - Method in class java.time. ZonedDateTime

获得这个日期时间的 LocalTime部分。

toLongArray() - Method in class java.util. BitSet

返回一个包含该位集合中所有位的新长数组。

ToLongBiFunction< T, U> - Interface in java.util.function

表示接受两个参数并产生长效结果的函数。

ToLongFunction< T> - Interface in java.util.function

表示产生长期效果的函数。

toLowerCase() - Method in class java.lang. String

使用默认语言环境的规则将此 String所有字符转换为小写。

toLowerCase(char) - Static method in class java.lang. Character

使用UnicodeData文件中的大小写映射信息将字符参数转换为小写。

toLowerCase(int) - Static method in class java.lang. Character

使用UnicodeData文件中的大小写映射信息将字符（Unicode代码点）参数转换为小写。

toLowerCase(Locale) - Method in class java.lang. String

将此 String所有字符转换为小写，使用给定的 Locale的规则。

toMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，它将元素累加到一个 Map其键和值是将所提供的映射函数应用于输入元素的结果。

toMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，它将元素累加到一个 Map其键和值是将提供的映射函数应用于输入元素的结果。

toMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>, Supplier<M>) - Static method in class java.util.stream. Collectors

返回一个 Collector ，它将元素累加到一个 Map其键和值是将提供的映射函数应用于输入元素的结果。

toMatchResult() - Method in class java.util.regex. Matcher

返回此匹配器的匹配状态为MatchResult 。

TOMATO - Static variable in class javafx.scene.paint. Color

颜色番茄，RGB值为＃FF6347

toMethodDescriptorString() - Method in class java.lang.invoke. MethodType

生成方法类型的字节码描述符表示。

toMethodHandle(VarHandle.AccessMode) - Method in class java.lang.invoke. VarHandle

获取绑定到此VarHandle和给定访问模式的方法句柄。

toMicros(long) - Method in enum java.util.concurrent. TimeUnit

相当于 MICROSECONDS.convert(duration, this) 。

toMillis() - Method in class java.nio.file.attribute. FileTime

返回以毫秒为单位的值。

toMillis() - Method in class java.time. Duration

将此持续时间转换为总长度（以毫秒为单位）。

toMillis() - Method in class javafx.util. Duration

返回此期间的毫秒数或Double.POSITIVE_INFINITY，如果期间为INDEFINITE，则返回NaN（如果期间为UNKNOWN）。

toMillis(long) - Method in enum java.util.concurrent. TimeUnit

相当于 MILLISECONDS.convert(duration, this) 。

toMillisPart() - Method in class java.time. Duration

提取持续时间部分的毫秒数。

toMinutes() - Method in class java.time. Duration

获取此持续时间的分钟数。

toMinutes() - Method in class javafx.util. Duration

如果期间为INDEFINITE，则返回此期间的分钟数或Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。

toMinutes(long) - Method in enum java.util.concurrent. TimeUnit

相当于 MINUTES.convert(duration, this) 。

toMinutesPart() - Method in class java.time. Duration

提取持续时间部分的分钟数。

toNameAndVersion() - Method in class java.lang.module. ModuleDescriptor

返回一个包含模块名称的字符串，如果存在，则显示其版本。

toNanoOfDay() - Method in class java.time. LocalTime

提取时间为天数，从 0到 24 * 60 * 60 * 1,000,000,000 - 1 。

toNanos() - Method in class java.time. Duration

将此持续时间转换为总长度，单位为纳秒，表示为 long 。

toNanos(long) - Method in enum java.util.concurrent. TimeUnit

相当于 NANOSECONDS.convert(duration, this) 。

toNanosPart() - Method in class java.time. Duration

在持续时间的几秒钟内获取纳秒部分。

TONER_EMPTY - Static variable in class javax.print.attribute.standard. PrinterStateReason

设备的墨粉不足。

TONER_LOW - Static variable in class javax.print.attribute.standard. PrinterStateReason

设备墨粉不足。

toNumber() - Method in class jdk.nashorn.api.scripting. AbstractJSObject

已过时。
使用JSObject.getDefaultValue(Class)与Number提示相反。

toNumber() - Method in interface jdk.nashorn.api.scripting. JSObject

已过时。
使用JSObject.getDefaultValue(Class)与Number提示相反。

toNumber() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

已过时。

toNumericValue(String) - Method in class javafx.scene.chart. CategoryAxis

所有轴值必须由某些数值表示。

toNumericValue(T) - Method in class javafx.scene.chart. Axis

所有轴值必须由某些数值表示。

toNumericValue(T) - Method in class javafx.scene.chart. ValueAxis

所有轴值必须由某些数值表示。

toOctalString(int) - Static method in class java.lang. Integer

在基数8中返回整数参数的字符串表示形式为无符号整数。

toOctalString(long) - Static method in class java.lang. Long

在基数8中返回 long参数的字符串表示形式为无符号整数。

toOffsetDateTime() - Method in class java.time. ZonedDateTime

将此日期时间转换为 OffsetDateTime 。

toOffsetTime() - Method in class java.time. OffsetDateTime

将此日期时间转换为 OffsetTime 。

Tool - Interface in javax.tools

可以从程序调用的工具的通用界面。

TOOL_BAR - javafx.scene. AccessibleRole

工具栏角色。

TOOL_BAR - Static variable in class javax.accessibility. AccessibleRole

通常由按钮或切换按钮组成的酒吧或调色板。

TOOL_BAR - Static variable in class javax.swing.plaf.synth. Region

工具栏区域。

TOOL_BAR_CONTENT - Static variable in class javax.swing.plaf.synth. Region

包含内容的ToolBar区域。

TOOL_BAR_DRAG_WINDOW - Static variable in class javax.swing.plaf.synth. Region

包含工具栏的窗口区域。

TOOL_BAR_SEPARATOR - Static variable in class javax.swing.plaf.synth. Region

工具栏分隔区。

TOOL_TIP - Static variable in class javax.accessibility. AccessibleRole

提供有关另一个对象的信息的对象。

TOOL_TIP - Static variable in class javax.swing.plaf.synth. Region

工具提示区域。

TOOL_TIP_TEXT_KEY - Static variable in class javax.swing. JComponent

当光标在组件上方时显示的注释，也称为“值提示”，“天桥帮助”或“飞越标签”。

toolBar - Variable in class javax.swing.plaf.basic. BasicToolBarUI.DockingListener

实例 JToolBar 。

toolBar - Variable in class javax.swing.plaf.basic. BasicToolBarUI

实例 JToolBar 。

ToolBar - Class in javafx.scene.control

ToolBar是一个可以水平或垂直显示项目的控件。

ToolBar() - Constructor for class javafx.scene.control. ToolBar

创建一个空的工具栏。

ToolBar(Node...) - Constructor for class javafx.scene.control. ToolBar

创建一个填充指定节点的工具栏。

ToolBarBorder() - Constructor for class javax.swing.plaf.metal. MetalBorders.ToolBarBorder

toolBarContListener - Variable in class javax.swing.plaf.basic. BasicToolBarUI

一个 ContainerListener的实例。

ToolBarContListener() - Constructor for class javax.swing.plaf.basic. BasicToolBarUI.ToolBarContListener

toolBarFocusListener - Variable in class javax.swing.plaf.basic. BasicToolBarUI

一个 FocusListener 。

ToolBarFocusListener() - Constructor for class javax.swing.plaf.basic. BasicToolBarUI.ToolBarFocusListener

ToolBarSkin - Class in javafx.scene.control.skin

默认皮肤实现为ToolBar控件。

ToolBarSkin(ToolBar) - Constructor for class javafx.scene.control.skin. ToolBarSkin

创建一个新的ToolBarSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

ToolBarUI - Class in javax.swing.plaf

JToolBar可插拔的外观和界面。

ToolBarUI() - Constructor for class javax.swing.plaf. ToolBarUI

Toolkit - Class in java.awt

这个类是抽象窗口工具包的所有实际实现的抽象超类。

Toolkit() - Constructor for class java.awt. Toolkit

TOOLKIT_EXCLUDE - java.awt. Dialog.ModalExclusionType

TOOLKIT_EXCLUDE表示顶级窗口不会被应用程序模式或工具箱模式对话框阻止。

TOOLKIT_MODAL - java.awt. Dialog.ModalityType

A TOOLKIT_MODAL对话框阻止所有从同一工具包运行的顶级窗口，除了自己的子层次结构。

ToolProvider - Class in javax.tools

提供定位工具提供者的方法，例如编译器的提供者。

ToolProvider - Interface in java.util.spi

一个用于命令行工具的界面，用于提供一种无需启动新VM即可调用的方法。

ToolProvider() - Constructor for class javax.tools. ToolProvider

Tooltip - Class in javafx.scene.control

工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。

Tooltip() - Constructor for class javafx.scene.control. Tooltip

为其文本创建一个带有空字符串的工具提示。

Tooltip(String) - Constructor for class javafx.scene.control. Tooltip

用指定的文本创建一个工具提示。

TOOLTIP - javafx.scene. AccessibleRole

工具提示角色。

ToolTipManager - Class in javax.swing

管理系统中的所有 ToolTips 。

ToolTipManager.insideTimerAction - Class in javax.swing

内部定时器动作。

ToolTipManager.outsideTimerAction - Class in javax.swing

外部定时器动作。

ToolTipManager.stillInsideTimerAction - Class in javax.swing

仍然在定时器动作。

tooltipProperty() - Method in class javafx.scene.control. Control

用于此控件的工具提示。

tooltipProperty() - Method in class javafx.scene.control. Tab

与此选项卡关联的工具提示。

TooltipSkin - Class in javafx.scene.control.skin

基于CSS的皮肤为Tooltip。

TooltipSkin(Tooltip) - Constructor for class javafx.scene.control.skin. TooltipSkin

为给定的Tooltip创建一个新的TooltipSkin实例。

ToolTipUI - Class in javax.swing.plaf

JToolTip可插拔的外观和界面。

ToolTipUI() - Constructor for class javax.swing.plaf. ToolTipUI

TooManyListenersException - Exception in java.util

TooManyListenersException异常被用作Java事件模型的一部分，以注释和实现组播事件源的单播特殊情况。

TooManyListenersException() - Constructor for exception java.util. TooManyListenersException

构造一个没有详细消息的TooManyListenersException。

TooManyListenersException(String) - Constructor for exception java.util. TooManyListenersException

构造具有指定详细消息的TooManyListenersException。

top - Variable in class java.awt. Insets

从顶部的插图。

top - Variable in class javax.swing.border. EmptyBorder

边界的顶端插图。

TOP - javafx.geometry. Side

代表矩形的顶端。

TOP - javafx.geometry. VPos

表示垂直位置。

TOP - javafx.scene.control. ContentDisplay

内容将被放置在标签的顶部。

TOP - Static variable in class javafx.print. PaperSource

指定选择TOP托盘。

TOP - Static variable in class javax.print.attribute.standard. MediaTray

打印机中的顶部进纸盒。

TOP - Static variable in class javax.swing.border. TitledBorder

将标题放在边框顶部的中间。

TOP - Static variable in class javax.swing. JSplitPane

用于添加 Component以上的其他 Component 。

TOP - Static variable in interface javax.swing. SwingConstants

方框常数用于指定框的顶部。

TOP_ALIGNMENT - Static variable in class java.awt. Component

易于使用的常数为 getAlignmentY() 。

TOP_ALIGNMENT - Static variable in class java.awt.font. GraphicAttribute

将图形顶部与顶部对齐。

TOP_CENTER - javafx.geometry. Pos

水平定位在垂直方向和中心位置。

TOP_LEFT - javafx.geometry. Pos

表示垂直和左上水平定位。

TOP_LEVEL - javax.lang.model.element. NestingKind

顶级类型，不包含在其他类型中。

TOP_RIGHT - javafx.geometry. Pos

表示垂直和右侧水平位置。

toPath() - Method in class java.io. File

返回从此抽象路径构造的一个java.nio.file.Path对象。

toPattern() - Method in class java.text. ChoiceFormat

获得模式。

toPattern() - Method in class java.text. DecimalFormat

合成表示此Format对象的当前状态的模式字符串。

toPattern() - Method in class java.text. MessageFormat

返回表示消息格式的当前状态的模式。

toPattern() - Method in class java.text. SimpleDateFormat

返回描述此日期格式的模式字符串。

TOPDOWNLEFTRIGHT - Static variable in interface java.awt.image. ImageConsumer

像素将以自上而下的从左到右的顺序传递。

topInputProperty() - Method in class javafx.scene.effect. Blend

这个 Blend操作的顶部输入。

toPlainString() - Method in class java.math. BigDecimal

返回没有指数字段的 BigDecimal的字符串表示形式。

topLevelThreadGroups() - Method in interface com.sun.jdi. VirtualMachine

返回没有父级的每个线程组。

topLevelWindowCreated(Window) - Method in interface com.sun.java.accessibility.util. TopLevelWindowListener

当创建新的顶级窗口时调用。

topLevelWindowDestroyed(Window) - Method in interface com.sun.java.accessibility.util. TopLevelWindowListener

当顶级窗口被销毁时调用。

TopLevelWindowListener - Interface in com.sun.java.accessibility.util

TopLevelWindowListener接口由EventQueueMonitor类用于在Java虚拟机中创建或销毁顶级窗口时通知感兴趣方。

topOffsetProperty() - Method in class javafx.scene.effect. Reflection

顶部偏移调整，即输入底部与反射顶部之间的距离。

topOpacityProperty() - Method in class javafx.scene.effect. Reflection

最高的不透明度值是反射在其顶端极端的不透明度。

topProperty() - Method in class javafx.scene.layout. BorderPane

节点放置在此边框的顶部边缘。

toRadians(double) - Static method in class java.lang. Math

将以度为单位的角度转换为以弧度测量的大致相等的角度。

toRadians(double) - Static method in class java.lang. StrictMath

将以度为单位的角度转换为以弧度测量的大致相等的角度。

toRealPath(LinkOption...) - Method in interface java.nio.file. Path

返回现有文件的 真实路径。

toRealValue(double) - Method in class javafx.scene.chart. Axis

所有轴值必须由某些数值表示。

toRealValue(double) - Method in class javafx.scene.chart. CategoryAxis

所有轴值必须由某些数值表示。

toRealValue(double) - Method in class javafx.scene.chart. ValueAxis

所有轴值必须由某些数值表示。

toResourceName(String, String) - Method in class java.util. ResourceBundle.Control

将给定的 bundleName转换为 ClassLoader.getResource方法所需的 格式 ，替换所有出现的 '.'

toRGB(float[]) - Method in class java.awt.color. ColorSpace

将假定在此ColorSpace中的颜色值转换为默认CS_sRGB颜色空间中的值。

toRGB(float[]) - Method in class java.awt.color. ICC_ColorSpace

将假定在此ColorSpace中的颜色值转换为默认CS_sRGB颜色空间中的值。

TORIGHT_TOBOTTOM - Static variable in class javax.print.attribute.standard. PresentationDirection

页面从左上方排列成行，向右和向下移动。

TORIGHT_TOTOP - Static variable in class javax.print.attribute.standard. PresentationDirection

页面从左下角开始排列，向右和向上移动。

toSecondOfDay() - Method in class java.time. LocalTime

提取时间为一天的秒数，从 0到 24 * 60 * 60 - 1 。

toSeconds() - Method in class java.time. Duration

获取此持续时间内的秒数。

toSeconds() - Method in class javafx.util. Duration

返回此期间的秒数，如果期间为INDEFINITE，则返回Double.POSITIVE_INFINITY，如果期间为UNKNOWN，则返回NaN。

toSeconds(long) - Method in enum java.util.concurrent. TimeUnit

相当于 SECONDS.convert(duration, this) 。

toSecondsPart() - Method in class java.time. Duration

提取持续时间中的秒数。

toSet() - Static method in class java.util.stream. Collectors

返回一个 Collector ，将输入元素累加到一个新的 Set 。

toStackTraceElement() - Method in interface java.lang. StackWalker.StackFrame

获取此堆栈帧的 StackTraceElement 。

toString() - Method in class com.sun.java.accessibility.util. AccessibilityListenerList

返回一个字符串表示的 AccessibilityListenerList 。

toString() - Method in interface com.sun.javadoc. AnnotationValue

已过时。

返回值的字符串表示形式。

toString() - Method in interface com.sun.javadoc. Parameter

已过时。

返回参数的字符串表示形式。

toString() - Method in interface com.sun.javadoc. SourcePosition

已过时。

将源位置转换为“Filename：line”形式。

toString() - Method in interface com.sun.javadoc. Tag

已过时。

将此对象转换为字符串。

toString() - Method in interface com.sun.javadoc. Type

已过时。

返回类型的字符串表示形式。

toString() - Method in interface com.sun.jdi. Mirror

返回描述此镜像的String

toString() - Method in class com.sun.management. GcInfo

toString() - Method in class com.sun.management. VMOption

toString() - Method in class com.sun.net.httpserver. HttpPrincipal

返回与getName（）相同的字符串

toString() - Method in class com.sun.nio.sctp. SctpStandardSocketOptions.InitMaxStreams

返回此init最大流的字符串表示形式，包括最大输入和输出绑定流。

toString() - Method in class com.sun.security.auth. LdapPrincipal

以 RFC 2253定义的格式创建此主体名称的字符串表示形式。

toString() - Method in class com.sun.security.auth. NTDomainPrincipal

返回此 NTDomainPrincipal的字符串表示 NTDomainPrincipal 。

toString() - Method in class com.sun.security.auth. NTNumericCredential

返回此 NTNumericCredential的字符串表示 NTNumericCredential 。

toString() - Method in class com.sun.security.auth. NTSid

返回此 NTSid的字符串表示 NTSid 。

toString() - Method in class com.sun.security.auth. NTSidDomainPrincipal

返回此 NTSidDomainPrincipal的字符串表示 NTSidDomainPrincipal 。

toString() - Method in class com.sun.security.auth. NTSidGroupPrincipal

返回此 NTSidGroupPrincipal的字符串表示 NTSidGroupPrincipal 。

toString() - Method in class com.sun.security.auth. NTSidPrimaryGroupPrincipal

返回此 NTSidPrimaryGroupPrincipal的字符串表示 NTSidPrimaryGroupPrincipal 。

toString() - Method in class com.sun.security.auth. NTSidUserPrincipal

返回此 NTSidUserPrincipal的字符串表示 NTSidUserPrincipal 。

toString() - Method in class com.sun.security.auth. NTUserPrincipal

返回此 NTPrincipal的字符串表示 NTPrincipal 。

toString() - Method in class com.sun.security.auth. SolarisNumericGroupPrincipal

已过时。

返回此 SolarisNumericGroupPrincipal的字符串表示 SolarisNumericGroupPrincipal 。

toString() - Method in class com.sun.security.auth. SolarisNumericUserPrincipal

已过时。

返回此 SolarisNumericUserPrincipal的字符串表示 SolarisNumericUserPrincipal 。

toString() - Method in class com.sun.security.auth. SolarisPrincipal

已过时。

返回此 SolarisPrincipal的字符串表示 SolarisPrincipal 。

toString() - Method in class com.sun.security.auth. UnixNumericGroupPrincipal

返回此 UnixNumericGroupPrincipal的字符串表示 UnixNumericGroupPrincipal 。

toString() - Method in class com.sun.security.auth. UnixNumericUserPrincipal

返回这个 UnixNumericUserPrincipal的字符串表示。

toString() - Method in class com.sun.security.auth. UnixPrincipal

返回此 UnixPrincipal的字符串表示 UnixPrincipal 。

toString() - Method in class com.sun.security.auth. UserPrincipal

返回此主体的字符串表示形式。

toString() - Method in class com.sun.security.auth. X500Principal

已过时。

返回此 X500Principal的字符串表示 X500Principal 。

toString() - Method in class com.sun.security.jgss. AuthorizationDataEntry

toString() - Method in class com.sun.source.util. TaskEvent

toString() - Method in class com.sun.tools.attach. VirtualMachine

返回 VirtualMachine的字符串表示 VirtualMachine 。

toString() - Method in class com.sun.tools.attach. VirtualMachineDescriptor

返回 VirtualMachineDescriptor的字符串表示 VirtualMachineDescriptor 。

toString() - Method in class java.awt. AWTEvent

返回此对象的String表示形式。

toString() - Method in class java.awt. AWTKeyStroke

返回显示和标识此对象属性的字符串。

toString() - Method in class java.awt. BorderLayout

返回此边框布局状态的字符串表示形式。

toString() - Method in class java.awt. CardLayout

返回此卡布局状态的字符串表示形式。

toString() - Method in class java.awt. CheckboxGroup

返回此复选框组的字符串表示形式，包括其当前选择的值。

toString() - Method in class java.awt. Color

返回此 Color的字符串表示 Color 。

toString() - Method in class java.awt. Component

返回此组件及其值的字符串表示形式。

toString() - Method in class java.awt. Cursor

返回此游标的字符串表示形式。

toString() - Method in class java.awt.datatransfer. DataFlavor

这个 DataFlavor字符串表示及其参数。

toString() - Method in class java.awt. Dimension

返回此 Dimension对象的 height和 width字段的值的字符串表示形式。

toString() - Method in class java.awt. DisplayMode

返回对象的字符串表示形式。

toString() - Method in class java.awt. Event

已过时。

注意： Event类已过时，仅适用于向后兼容性。

toString() - Method in class java.awt. FlowLayout

返回此 FlowLayout对象及其值的字符串表示形式。

toString() - Method in class java.awt.font. NumericShaper

返回描述此整形器的 String 。

toString() - Method in class java.awt.font. TextHitInfo

返回一个 String表示仅用于调试的命中。

toString() - Method in class java.awt.font. TextLayout

返回此 TextLayout调试信息。

toString() - Method in class java.awt. Font

将此 Font对象转换为 String表示。

toString() - Method in class java.awt. FontMetrics

返回此 FontMetrics对象的值作为 String 。

toString() - Method in class java.awt.geom. AffineTransform

返回一个表示String的值的String 。

toString() - Method in class java.awt.geom. Point2D.Double

返回一个表示 String的值的 Point2D 。

toString() - Method in class java.awt.geom. Point2D.Float

返回一个表示 String的值的 Point2D 。

toString() - Method in class java.awt.geom. Rectangle2D.Double

返回 String如此表示 Rectangle2D 。

toString() - Method in class java.awt.geom. Rectangle2D.Float

返回此 Rectangle2D的 String表示。

toString() - Method in class java.awt. Graphics

返回 String表示此对象 Graphics对象的值。

toString() - Method in class java.awt. GridBagLayout

返回此网格包布局值的字符串表示形式。

toString() - Method in class java.awt. GridLayout

返回此网格布局值的字符串表示形式。

toString() - Method in class java.awt.image. BufferedImage

返回此 BufferedImage对象及其值的 String表示。

toString() - Method in class java.awt.image. ColorModel

返回此 ColorModel对象的内容的 String表示。

toString() - Method in class java.awt.image. DirectColorModel

返回一个 String ，代表这个 DirectColorModel 。

toString() - Method in class java.awt.image. IndexColorModel

返回 ColorModel对象的内容的 String表示。

toString() - Method in class java.awt. Insets

返回此 Insets对象的字符串表示形式。

toString() - Method in class java.awt. JobAttributes

返回此JobAttributes的字符串表示形式。

toString() - Method in class java.awt. MenuComponent

以字符串形式返回此菜单组件的表示。

toString() - Method in class java.awt. MenuShortcut

返回MenuShortcut的国际化描述。

toString() - Method in class java.awt. PageAttributes

返回此PageAttributes的字符串表示形式。

toString() - Method in class java.awt. Point

在 (x,y)坐标空间中返回此点及其位置的字符串表示形式。

toString() - Method in class java.awt. Rectangle

返回一个 String代表这个 Rectangle及其值。

toString() - Method in class java.awt. RenderingHints

返回hashmap的相当长的字符串表示形式，其中包含键值与该 RenderingHints对象的值的映射。

toString() - Method in class java.awt. Robot

返回此Robot的字符串表示形式。

toString() - Method in class java.awt. ScrollPaneAdjustable

返回此滚动条及其值的字符串表示形式。

toString() - Method in class java.awt. SystemColor

返回此 Color的值的字符串表示形式。

toString() - Method in class java.beans. Expression

使用Java风格的语法打印此表达式的值。

toString() - Method in class java.beans. FeatureDescriptor

返回对象的字符串表示形式。

toString() - Method in class java.beans. PropertyChangeEvent

返回对象的字符串表示形式。

toString() - Method in class java.beans. Statement

使用Java风格的语法打印此语句的值。

toString() - Method in class java.io. ByteArrayOutputStream

使用平台的默认字符集将缓冲区内容转换为字符串解码字节。

toString() - Method in class java.io. CharArrayWriter

将输入数据转换为字符串。

toString() - Method in class java.io. File

返回此抽象路径名的路径名字符串。

toString() - Method in class java.io. ObjectStreamClass

返回描述此ObjectStreamClass的字符串。

toString() - Method in class java.io. ObjectStreamField

返回描述此字段的字符串。

toString() - Method in class java.io. StreamTokenizer

返回当前流令牌的字符串表示形式及其发生的行号。

toString() - Method in class java.io. StringWriter

以缓冲区的当前值作为字符串返回。

toString() - Method in interface java.lang.annotation. Annotation

返回此注释的字符串表示形式。

toString() - Method in class java.lang. Boolean

返回表示此布尔值的 String对象。

toString() - Method in class java.lang. Byte

返回一个表示 Byte的值的 String对象。

toString() - Method in class java.lang. Character.Subset

返回此子集的名称。

toString() - Method in class java.lang. Character

返回一个表示 Character的值的 String对象。

toString() - Method in interface java.lang. CharSequence

以与此顺序相同的顺序返回包含此序列中的字符的字符串。

toString() - Method in class java.lang. Class

将对象转换为字符串。

toString() - Method in class java.lang. Double

返回此 Double对象的字符串表示形式。

toString() - Method in class java.lang. Enum

返回声明中包含的此枚举常量的名称。

toString() - Method in class java.lang. Float

返回此 Float对象的字符串表示形式。

toString() - Method in class java.lang. Integer

返回一个表示 Integer的值的 String对象。

toString() - Method in class java.lang.invoke. MethodHandle

返回方法句柄的字符串表示形式，从字符串 "MethodHandle"开始，以方法句柄类型的字符串表示结束。

toString() - Method in class java.lang.invoke. MethodHandles.Lookup

显示要从中进行查找的类的名称。

toString() - Method in class java.lang.invoke. MethodType

返回方法类型的字符串表示形式，格式为 "(PT0,PT1...)RT" 。

toString() - Method in class java.lang.invoke. SerializedLambda

toString() - Method in class java.lang. Long

返回一个表示 Long的值的 String对象。

toString() - Method in class java.lang.management. LockInfo

返回一个锁的字符串表示形式。

toString() - Method in enum java.lang.management. MemoryType

返回此 MemoryType的字符串表示 MemoryType 。

toString() - Method in class java.lang.management. MemoryUsage

返回此内存使用情况的描述性表示。

toString() - Method in class java.lang.management. ThreadInfo

返回此线程信息的字符串表示形式。

toString() - Method in class java.lang.module. Configuration

返回描述此配置的字符串。

toString() - Method in class java.lang.module. ModuleDescriptor.Exports

返回描述导出包的字符串。

toString() - Method in class java.lang.module. ModuleDescriptor.Opens

返回描述打开包的字符串。

toString() - Method in class java.lang.module. ModuleDescriptor.Provides

返回描述此提供的字符串。

toString() - Method in class java.lang.module. ModuleDescriptor.Requires

返回描述此模块依赖关系的字符串。

toString() - Method in class java.lang.module. ModuleDescriptor

返回描述模块的字符串。

toString() - Method in class java.lang.module. ModuleDescriptor.Version

返回解析此版本的字符串。

toString() - Method in class java.lang.module. ResolvedModule

返回描述此已解析模块的字符串。

toString() - Method in class java.lang. Module

返回此模块的字符串表示形式。

toString() - Method in class java.lang. ModuleLayer

返回描述此模块层的字符串。

toString() - Method in class java.lang. Object

返回对象的字符串表示形式。

toString() - Method in class java.lang. 软件包

返回此包的字符串表示形式。

toString() - Method in class java.lang.reflect. Constructor

返回一个描述这个 Constructor的字符串。

toString() - Method in class java.lang.reflect. Field

返回一个描述这个 Field的字符串。

toString() - Method in class java.lang.reflect. 方法

返回一个描述这个 方法的字符串。

toString() - Method in class java.lang.reflect. Parameter

返回描述此参数的字符串。

toString() - Method in class java.lang. Runtime.Version

返回此版本的字符串表示形式。

toString() - Method in class java.lang. Short

返回一个表示 Short的值的 String对象。

toString() - Method in class java.lang. StackTraceElement

返回此堆栈跟踪元素的字符串表示形式。

toString() - Method in class java.lang. String

这个对象（已经是一个字符串！）

toString() - Method in class java.lang. StringBuffer

toString() - Method in class java.lang. StringBuilder

toString() - Method in class java.lang. Thread

返回此线程的字符串表示，包括线程的名称，优先级和线程组。

toString() - Method in class java.lang. ThreadGroup

返回此Thread组的字符串表示形式。

toString() - Method in class java.lang. Throwable

返回此可抛出的简短描述。

toString() - Method in class java.math. BigDecimal

返回此 BigDecimal的字符串表示 BigDecimal ，如果需要指数则使用科学记数法。

toString() - Method in class java.math. BigInteger

返回此BigInteger的十进制字符串表示形式。

toString() - Method in class java.math. MathContext

返回此 MathContext的字符串表示 MathContext 。

toString() - Method in class java.net. HttpCookie

构造此Cookie的Cookie标题字符串表示形式，其格式为相应Cookie规范定义的格式，但不包含前导“Cookie：”标记。

toString() - Method in class java.net. InetAddress

将此IP地址转换为 String 。

toString() - Method in class java.net. InetSocketAddress

构造此InetSocketAddress的字符串表示形式。

toString() - Method in class java.net. InterfaceAddress

将此接口地址转换为 String 。

toString() - Method in class java.net. NetworkInterface

toString() - Method in class java.net. Proxy

构造此代理的字符串表示形式。

toString() - Method in class java.net. ServerSocket

将该套接字的实现地址和实现端口作为 String 。

toString() - Method in class java.net. Socket

将此套接字转换为 String 。

toString() - Method in class java.net. SocketImpl

以 String返回此套接字的地址和端口。

toString() - Method in class java.net. URI

以字符串形式返回此URI的内容。

toString() - Method in class java.net. URL

构造一个 URL的字符串表示 URL 。

toString() - Method in class java.net. URLConnection

返回此URL连接的 String表示。

toString() - Method in class java.nio. ByteBuffer

返回一个汇总此缓冲区状态的字符串。

toString() - Method in class java.nio. ByteOrder

构造描述此对象的字符串。

toString() - Method in class java.nio.channels. FileChannel.MapMode

返回描述此文件映射模式的字符串。

toString() - Method in class java.nio.channels. FileLock

返回描述此锁的范围，类型和有效性的字符串。

toString() - Method in class java.nio. CharBuffer

返回一个包含此缓冲区中字符的字符串。

toString() - Method in class java.nio.charset. Charset

返回描述此字符集的字符串。

toString() - Method in class java.nio.charset. CoderResult

返回描述此编码器结果的字符串。

toString() - Method in class java.nio.charset. CodingErrorAction

返回描述此操作的字符串。

toString() - Method in class java.nio. DoubleBuffer

返回一个汇总此缓冲区状态的字符串。

toString() - Method in class java.nio.file.attribute. AclEntry

返回此ACL条目的字符串表示形式。

toString() - Method in class java.nio.file.attribute. FileTime

返回此 FileTime的字符串表示 FileTime 。

toString() - Method in interface java.nio.file. Path

返回此路径的字符串表示形式。

toString() - Method in class java.nio. FloatBuffer

返回一个汇总此缓冲区状态的字符串。

toString() - Method in class java.nio. IntBuffer

返回一个汇总此缓冲区状态的字符串。

toString() - Method in class java.nio. LongBuffer

返回一个汇总此缓冲区状态的字符串。

toString() - Method in class java.nio. ShortBuffer

返回一个汇总此缓冲区状态的字符串。

toString() - Method in class java.rmi.dgc. VMID

返回此VMID的字符串表示形式。

toString() - Method in class java.rmi.server. LogStream

已过时。
没有替换

toString() - Method in class java.rmi.server. ObjID

返回此对象标识符的字符串表示形式。

toString() - Method in class java.rmi.server. Operation

已过时。
没有替换

toString() - Method in class java.rmi.server. RemoteObject

返回一个表示该远程对象的值的字符串。

toString() - Method in class java.rmi.server. UID

返回此 UID的字符串表示 UID 。

toString() - Method in interface java.security.acl. Acl

已过时。

返回ACL内容的字符串表示形式。

toString() - Method in interface java.security.acl. AclEntry

已过时。

返回此ACL条目内容的字符串表示形式。

toString() - Method in interface java.security.acl. Permission

已过时。

打印此权限的字符串表示形式。

toString() - Method in class java.security. AlgorithmParameters

返回描述参数的格式化字符串。

toString() - Method in class java.security.cert. Certificate

返回此证书的字符串表示形式。

toString() - Method in class java.security.cert. CertPath

返回此认证路径的字符串表示形式。

toString() - Method in class java.security.cert. CollectionCertStoreParameters

返回描述参数的格式化字符串。

toString() - Method in class java.security.cert. CRL

返回此CRL的字符串表示形式。

toString() - Method in class java.security.cert. LDAPCertStoreParameters

返回描述参数的格式化字符串。

toString() - Method in class java.security.cert. PKIXBuilderParameters

返回描述参数的格式化字符串。

toString() - Method in class java.security.cert. PKIXCertPathBuilderResult

返回此 PKIXCertPathBuilderResult的可打印的表示。

toString() - Method in class java.security.cert. PKIXCertPathValidatorResult

返回此 PKIXCertPathValidatorResult的可打印的表示。

toString() - Method in class java.security.cert. PKIXParameters

返回描述参数的格式化字符串。

toString() - Method in class java.security.cert. PolicyQualifierInfo

返回此 PolicyQualifierInfo的可打印的表示。

toString() - Method in class java.security.cert. TrustAnchor

返回描述 TrustAnchor的格式化字符串。

toString() - Method in class java.security.cert. URICertStoreParameters

返回描述包含用于构造此对象的URI的参数的格式化字符串。

toString() - Method in class java.security.cert. X509CertSelector

返回 CertSelector的可打印表示。

toString() - Method in class java.security.cert. X509CRLEntry

返回此CRL条目的字符串表示形式。

toString() - Method in class java.security.cert. X509CRLSelector

返回 X509CRLSelector的可打印表示。

toString() - Method in class java.security. CodeSigner

返回描述此代码签名者的字符串。

toString() - Method in class java.security. CodeSource

返回描述此CodeSource的字符串，告知其URL和证书。

toString() - Method in class java.security. DigestInputStream

打印此摘要输入流及其相关消息摘要对象的字符串表示形式。

toString() - Method in class java.security. DigestOutputStream

打印此摘要输出流及其相关消息摘要对象的字符串表示形式。

toString() - Method in enum java.security. DrbgParameters.Capability

toString() - Method in class java.security. DrbgParameters.Instantiation

返回此 Instantiation的人类可读字符串表示 Instantiation 。

toString() - Method in class java.security. Identity

已过时。

返回一个描述此身份的短字符串，告诉其名称及其范围（如果有）。

toString() - Method in class java.security. IdentityScope

已过时。

返回此标识范围的字符串表示形式，包括其名称，其范围名称和此身份范围中的身份数。

toString() - Method in class java.security. KeyStore.PrivateKeyEntry

返回此PrivateKeyEntry的字符串表示形式。

toString() - Method in class java.security. KeyStore.SecretKeyEntry

返回此SecretKeyEntry的字符串表示形式。

toString() - Method in class java.security. KeyStore.TrustedCertificateEntry

返回此TrustedCertificateEntry的字符串表示形式。

toString() - Method in class java.security. MessageDigest

返回此消息摘要对象的字符串表示形式。

toString() - Method in class java.security. Permission

返回描述此权限的字符串。

toString() - Method in class java.security. PermissionCollection

返回描述此PermissionCollection对象的字符串，提供有关其所包含的所有权限的信息。

toString() - Method in class java.security. PKCS12Attribute

返回此 PKCS12Attribute的字符串表示 PKCS12Attribute 。

toString() - Method in interface java.security. Principal

返回此主体的字符串表示形式。

toString() - Method in exception java.security. PrivilegedActionException

toString() - Method in class java.security. ProtectionDomain

将ProtectionDomain转换为字符串。

toString() - Method in class java.security. Provider.Service

返回此服务的字符串表示形式。

toString() - Method in class java.security. Provider

返回一个带有该提供者的名称和版本字符串的字符串。

toString() - Method in class java.security. SecureRandom

返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

toString() - Method in class java.security. SecureRandomSpi

返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

toString() - Method in class java.security. Signature

返回此签名对象的字符串表示形式，提供包含对象状态和所使用算法名称的信息。

toString() - Method in class java.security. Signer

已过时。

返回一个关于签名者的信息字符串。

toString() - Method in class java.security. Timestamp

返回描述此时间戳的字符串。

toString() - Method in class java.security. UnresolvedPermission

返回描述此UnresolvedPermission的字符串。

toString() - Method in class java.sql. Date

格式化日期转义格式yyyy-mm-dd。

toString() - Method in interface java.sql. RowId

返回一个表示此 java.sql.RowId对象指定的SQL ROWID值的字符串。

toString() - Method in class java.sql. Time

以JDBC时间转义格式格式化。

toString() - Method in class java.sql. Timestamp

以JDBC时间戳转义格式格式化时间戳。

toString() - Method in class java.text. Annotation

返回此注释的String表示形式。

toString() - Method in class java.text. AttributedCharacterIterator.Attribute

返回对象的字符串表示形式。

toString() - Method in class java.text. Bidi

显示调试中使用的双向内部状态。

toString() - Method in class java.text. FieldPosition

返回此FieldPosition的字符串表示形式。

toString() - Method in class java.text. ParsePosition

返回此ParsePosition的字符串表示形式。

toString() - Method in class java.time.chrono. AbstractChronology

输出这个时间顺序为 String ，使用年表ID。

toString() - Method in interface java.time.chrono. ChronoLocalDate

将此日期输出为 String 。

toString() - Method in interface java.time.chrono. ChronoLocalDateTime

将此日期时间输出为 String 。

toString() - Method in interface java.time.chrono. Chronology

输出这个年表为 String 。

toString() - Method in interface java.time.chrono. ChronoPeriod

输出此期间为 String 。

toString() - Method in interface java.time.chrono. ChronoZonedDateTime

将此日期时间输出为 String 。

toString() - Method in class java.time.chrono. JapaneseEra

toString() - Method in class java.time. Duration

使用ISO-8601秒表示形式显示此持续时间的字符串表示，如 PT8H6M12.345S 。

toString() - Method in class java.time.format. DateTimeFormatter

返回底层格式化程序的描述。

toString() - Method in class java.time.format. DecimalStyle

返回描述此DecimalStyle的字符串。

toString() - Method in class java.time. Instant

此瞬间使用ISO-8601表示形式的字符串表示形式。

toString() - Method in class java.time. LocalDate

将此日期输出为 String ，如 2007-12-03 。

toString() - Method in class java.time. LocalDateTime

将此日期时间输出为 String ，如 2007-12-03T10:15:30 。

toString() - Method in class java.time. LocalTime

此时输出为 String ，如 10:15 。

toString() - Method in class java.time. MonthDay

以 String （如 --12-03输出这个月的日子。

toString() - Method in class java.time. OffsetDateTime

将此日期时间输出为 String ，如 2007-12-03T10:15:30+01:00 。

toString() - Method in class java.time. OffsetTime

此时输出为 String ，如 10:15:30+01:00 。

toString() - Method in class java.time. Period

将此期间输出为 String ，如 P6Y3M1D 。

toString() - Method in enum java.time.temporal. ChronoField

toString() - Method in enum java.time.temporal. ChronoUnit

toString() - Method in interface java.time.temporal. TemporalField

获取字段的描述性名称。

toString() - Method in interface java.time.temporal. TemporalUnit

获取单位的描述性名称。

toString() - Method in class java.time.temporal. ValueRange

将此范围输出为 String 。

toString() - Method in class java.time.temporal. WeekFields

这个 WeekFields实例的字符串表示形式。

toString() - Method in class java.time. Year

今年产量为 String 。

toString() - Method in class java.time. YearMonth

今年产量为 String ，如 2007-12 。

toString() - Method in class java.time.zone. ZoneOffsetTransition

返回描述此对象的字符串。

toString() - Method in class java.time.zone. ZoneOffsetTransitionRule

返回描述此对象的字符串。

toString() - Method in class java.time.zone. ZoneRules

返回描述此对象的字符串。

toString() - Method in class java.time. ZonedDateTime

将此日期时间输出为 String ，如 2007-12-03T10:15:30+01:00[Europe/Paris] 。

toString() - Method in class java.time. ZoneId

使用ID将该区域输出为 String 。

toString() - Method in class java.time. ZoneOffset

使用归一化ID将此偏移量输出为 String 。

toString() - Method in class java.util. AbstractCollection

返回此集合的字符串表示形式。

toString() - Method in class java.util. AbstractMap.SimpleEntry

返回此映射条目的字符串表示形式。

toString() - Method in class java.util. AbstractMap.SimpleImmutableEntry

返回此映射条目的字符串表示形式。

toString() - Method in class java.util. AbstractMap

返回此地图的字符串表示形式。

toString() - Method in class java.util. BitSet

返回此位集的字符串表示形式。

toString() - Method in class java.util. Calendar

返回此日历的字符串表示形式。

toString() - Method in class java.util.concurrent. ArrayBlockingQueue

toString() - Method in class java.util.concurrent.atomic. AtomicBoolean

返回当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. AtomicInteger

返回当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. AtomicIntegerArray

返回数组的当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. AtomicLong

返回当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. AtomicLongArray

返回数组的当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. AtomicReference

返回当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. AtomicReferenceArray

返回数组的当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. DoubleAccumulator

返回当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. DoubleAdder

返回 DoubleAdder.sum()的String表示 形式 。

toString() - Method in class java.util.concurrent.atomic. LongAccumulator

返回当前值的String表示形式。

toString() - Method in class java.util.concurrent.atomic. LongAdder

返回 LongAdder.sum()的String表示 形式 。

toString() - Method in class java.util.concurrent. CompletableFuture

返回一个标识此CompletableFuture的字符串及其完成状态。

toString() - Method in class java.util.concurrent. ConcurrentHashMap

返回此地图的字符串表示形式。

toString() - Method in class java.util.concurrent. ConcurrentLinkedDeque

toString() - Method in class java.util.concurrent. ConcurrentLinkedQueue

toString() - Method in class java.util.concurrent. CopyOnWriteArrayList

返回此列表的字符串表示形式。

toString() - Method in class java.util.concurrent. CountDownLatch

返回一个标识此锁存器的字符串及其状态。

toString() - Method in class java.util.concurrent. ForkJoinPool

返回一个标识此池的字符串，以及它的状态，包括运行状态，并行级和工作和任务计数的指示。

toString() - Method in class java.util.concurrent. LinkedBlockingDeque

toString() - Method in class java.util.concurrent. LinkedBlockingQueue

toString() - Method in class java.util.concurrent. LinkedTransferQueue

toString() - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

返回一个标识此同步器的字符串及其状态。

toString() - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

返回一个标识此同步器的字符串及其状态。

toString() - Method in class java.util.concurrent.locks. ReentrantLock

返回一个标识此锁的字符串以及其锁定状态。

toString() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock

返回一个标识此锁的字符串以及其锁定状态。

toString() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock

返回一个标识此锁的字符串以及其锁定状态。

toString() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock

返回一个标识此锁的字符串以及其锁定状态。

toString() - Method in class java.util.concurrent.locks. StampedLock

返回一个标识此锁的字符串以及其锁定状态。

toString() - Method in class java.util.concurrent. Phaser

返回一个标识此移相器的字符串及其状态。

toString() - Method in class java.util.concurrent. PriorityBlockingQueue

toString() - Method in class java.util.concurrent. Semaphore

返回一个标识此信号量的字符串及其状态。

toString() - Method in class java.util.concurrent. SynchronousQueue

始终返回 "[]" 。

toString() - Method in class java.util.concurrent. ThreadPoolExecutor

返回标识此池的字符串及其状态，包括运行状态和估计的工作人员和任务计数的指示。

toString() - Method in class java.util. Currency

返回此货币的ISO 4217货币代码。

toString() - Method in class java.util. Date

将此 Date对象转换为 String的形式：

toString() - Method in class java.util. DoubleSummaryStatistics

返回适用于调试的此对象的非空字符串表示形式。

toString() - Method in class java.util. EventObject

返回此EventObject的String表示形式。

toString() - Method in class java.util. Formatter

返回在输出的目的地上调用 toString()的结果。

toString() - Method in class java.util. Hashtable

以一组条目的形式返回此 Hashtable对象的字符串表示形式，其中括起来并以ASCII字符“ ,  ”（逗号和空格）分隔。

toString() - Method in class java.util. IntSummaryStatistics

返回适用于调试的此对象的非空字符串表示形式。

toString() - Method in class java.util.jar. Attributes.Name

返回属性名称作为字符串。

toString() - Method in class java.util. Locale.LanguageRange

返回此 LanguageRange对象的信息字符串表示形式，如果范围被加权且重量小于最大权重， LanguageRange语言范围和权重组成。

toString() - Method in class java.util. Locale

返回此 Locale对象的字符串表示形式，由语言，国家/地区，变体，脚本和扩展名组成，如下所示：language +“_”+ country +“_”+（variant +“_＃”|“＃”）+ script +“_”+扩展语言总是小写，国家总是大写，脚本总是标题大小写，而扩展名总是小写。

toString() - Method in class java.util.logging. Level

返回此级别的字符串表示形式。

toString() - Method in class java.util. LongSummaryStatistics

返回适用于调试的此对象的非空字符串表示形式。

toString() - Method in class java.util. Optional

返回适用于调试的 Optional的非空字符串表示形式。

toString() - Method in class java.util. OptionalDouble

返回适用于调试的 OptionalDouble的非空字符串表示形式。

toString() - Method in class java.util. OptionalInt

返回适用于调试的 OptionalInt的非空字符串表示形式。

toString() - Method in class java.util. OptionalLong

返回适用于调试的 OptionalLong的非空字符串表示形式。

toString() - Method in class java.util.prefs. AbstractPreferences

返回此首选项节点的绝对路径名。

toString() - Method in class java.util.prefs. Preferences

返回此首选项节点的字符串表示形式，如以下表达式计算： (this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 。

toString() - Method in class java.util. Properties

toString() - Method in class java.util.regex. Matcher

返回此匹配器的字符串表示形式。

toString() - Method in class java.util.regex. Pattern

返回此模式的字符串表示形式。

toString() - Method in class java.util. Scanner

返回此 Scanner的字符串表示 Scanner 。

toString() - Method in class java.util. ServiceLoader

返回描述此服务的字符串。

toString() - Method in class java.util. SimpleTimeZone

返回此时区的字符串表示形式。

toString() - Method in class java.util. StringJoiner

返回当前值，由的 prefix ，值加入迄今由分离 delimiter和 suffix ，除非没有元素已经在这种情况下，被添加 prefix + suffix或 emptyValue返回字符。

toString() - Method in class java.util. UUID

返回一个表示 UUID的 String对象。

toString() - Method in class java.util. Vector

返回此Vector的字符串表示形式，其中包含每个元素的String表示形式。

toString() - Method in class java.util.zip. ZipEntry

返回ZIP条目的字符串表示形式。

toString() - Method in class javafx.animation. KeyFrame

返回此 KeyFrame对象的字符串表示形式。

toString() - Method in class javafx.animation. KeyValue

返回此 KeyValue对象的字符串表示形式。

toString() - Method in class javafx.application. Preloader.ErrorNotification

返回此 ErrorNotification对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. BooleanBinding

返回此 BooleanBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. DoubleBinding

返回此 DoubleBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. FloatBinding

返回此 FloatBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. IntegerBinding

返回此 IntegerBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. ListBinding

返回此 ListBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. LongBinding

返回此 LongBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. MapBinding

返回此 MapBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. ObjectBinding

返回此 ObjectBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. SetBinding

返回此 SetBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.binding. StringBinding

返回此 StringBinding对象的字符串表示形式。

toString() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty

返回此 JavaBeanBooleanProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty

返回此 JavaBeanDoubleProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty

返回此 JavaBeanFloatProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty

返回此 JavaBeanIntegerProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty

返回此 JavaBeanLongProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty

返回此 JavaBeanObjectProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. BooleanProperty

返回此 BooleanProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. BooleanPropertyBase

返回此 BooleanPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. DoubleProperty

返回此 DoubleProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. DoublePropertyBase

返回此 DoublePropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. FloatProperty

返回此 FloatProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. FloatPropertyBase

返回此 FloatPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. IntegerProperty

返回此 IntegerProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. IntegerPropertyBase

返回此 IntegerPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ListProperty

返回此 ListProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ListPropertyBase

返回此 ListPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. LongProperty

返回此 LongProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. LongPropertyBase

返回此 LongPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. MapProperty

返回此 MapProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. MapPropertyBase

返回此 MapPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ObjectProperty

返回此 ObjectProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ObjectPropertyBase

返回此 ObjectPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyBooleanProperty

返回此 ReadOnlyBooleanProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyDoubleProperty

返回此 ReadOnlyDoubleProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyFloatProperty

返回此 ReadOnlyFloatProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyIntegerProperty

返回此 ReadOnlyIntegerProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyListProperty

返回此 ReadOnlyListProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyLongProperty

返回此 ReadOnlyLongProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyMapProperty

返回此 ReadOnlyMapProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyObjectProperty

返回此 ReadOnlyObjectProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlySetProperty

返回此 ReadOnlySetProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. ReadOnlyStringProperty

返回此 ReadOnlyStringProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. SetProperty

返回此 SetProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. SetPropertyBase

返回此 SetPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.beans.property. StringProperty

返回此 StringProperty对象的字符串表示形式。

toString() - Method in class javafx.beans.property. StringPropertyBase

返回此 StringPropertyBase对象的字符串表示形式。

toString() - Method in class javafx.css. CompoundSelector

toString() - Method in class javafx.css.converter. BooleanConverter

toString() - Method in class javafx.css.converter. ColorConverter

toString() - Method in class javafx.css.converter. CursorConverter

toString() - Method in class javafx.css.converter. DeriveColorConverter

toString() - Method in class javafx.css.converter. DeriveSizeConverter

toString() - Method in class javafx.css.converter. DurationConverter

toString() - Method in class javafx.css.converter. EffectConverter.DropShadowConverter

toString() - Method in class javafx.css.converter. EffectConverter.InnerShadowConverter

toString() - Method in class javafx.css.converter. EffectConverter

toString() - Method in class javafx.css.converter. EnumConverter

toString() - Method in class javafx.css.converter. FontConverter.FontSizeConverter

toString() - Method in class javafx.css.converter. FontConverter.FontStyleConverter

toString() - Method in class javafx.css.converter. FontConverter.FontWeightConverter

toString() - Method in class javafx.css.converter. FontConverter

toString() - Method in class javafx.css.converter. InsetsConverter.SequenceConverter

toString() - Method in class javafx.css.converter. InsetsConverter

toString() - Method in class javafx.css.converter. LadderConverter

toString() - Method in class javafx.css.converter. PaintConverter.ImagePatternConverter

toString() - Method in class javafx.css.converter. PaintConverter.LinearGradientConverter

toString() - Method in class javafx.css.converter. PaintConverter.RadialGradientConverter

toString() - Method in class javafx.css.converter. PaintConverter.RepeatingImagePatternConverter

toString() - Method in class javafx.css.converter. PaintConverter.SequenceConverter

toString() - Method in class javafx.css.converter. PaintConverter

toString() - Method in class javafx.css.converter. SizeConverter.SequenceConverter

toString() - Method in class javafx.css.converter. SizeConverter

toString() - Method in class javafx.css.converter. StopConverter

toString() - Method in class javafx.css.converter. StringConverter.SequenceConverter

toString() - Method in class javafx.css.converter. StringConverter

toString() - Method in class javafx.css.converter. URLConverter.SequenceConverter

toString() - Method in class javafx.css.converter. URLConverter

toString() - Method in class javafx.css. CssMetaData

toString() - Method in class javafx.css. CssParser.ParseError.InlineStyleParsingError

toString() - Method in class javafx.css. CssParser.ParseError.PropertySetError

toString() - Method in class javafx.css. CssParser.ParseError.StringParsingError

toString() - Method in class javafx.css. CssParser.ParseError.StylesheetParsingError

toString() - Method in class javafx.css. CssParser.ParseError

toString() - Method in class javafx.css. Declaration

toString() - Method in class javafx.css. Rule

将此对象转换为字符串。

toString() - Method in class javafx.css. SimpleSelector

将此对象转换为字符串。

toString() - Method in class javafx.css. Size

toString() - Method in class javafx.css. Style

toString() - Method in class javafx.css. StyleClass

toString() - Method in class javafx.css. Stylesheet

返回此对象的字符串表示形式。

toString() - Method in class javafx.event. EventType

返回此 EventType对象的字符串表示形式。

toString() - Method in class javafx.geometry. BoundingBox

返回此 BoundingBox的字符串表示 BoundingBox 。

toString() - Method in class javafx.geometry. Dimension2D

返回此 Dimension2D的字符串表示 Dimension2D 。

toString() - Method in class javafx.geometry. Insets

返回插值的字符串表示形式。

toString() - Method in class javafx.geometry. Point2D

返回此 Point2D的字符串表示 Point2D 。

toString() - Method in class javafx.geometry. Point3D

返回此 Point3D的字符串表示 Point3D 。

toString() - Method in class javafx.geometry. Rectangle2D

返回此 Rectangle2D的字符串表示 Rectangle2D 。

toString() - Method in class javafx.print. JobSettings

toString() - Method in class javafx.print. PageLayout

toString() - Method in class javafx.print. Paper

toString() - Method in class javafx.print. PaperSource

toString() - Method in class javafx.print. Printer

toString() - Method in class javafx.print. PrinterJob

toString() - Method in class javafx.print. PrintResolution

toString() - Method in class javafx.scene.chart. Axis.TickMark

返回此 TickMark对象的字符串表示形式。

toString() - Method in class javafx.scene.chart. PieChart.Data

返回此 Data对象的字符串表示形式。

toString() - Method in class javafx.scene.chart. XYChart.Data

返回此 Data对象的字符串表示形式。

toString() - Method in class javafx.scene.chart. XYChart.Series

返回此 Series对象的字符串表示形式。

toString() - Method in class javafx.scene.control. ButtonType

返回对象的字符串表示形式。

toString() - Method in class javafx.scene.control. DialogEvent

返回此 DialogEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.control. IndexRange

返回此 Range对象的字符串表示形式。

toString() - Method in class javafx.scene.control. Labeled

toString() - Method in class javafx.scene.control. ListView.EditEvent

返回此 EditEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.control. MenuItem

toString() - Method in class javafx.scene.control. TablePosition

返回此 TablePosition对象的字符串表示形式。

toString() - Method in class javafx.scene.control. TextFormatter.Change

toString() - Method in class javafx.scene.control. TreeItem

返回此 TreeItem对象的字符串表示形式。

toString() - Method in class javafx.scene. Cursor

返回游标的字符串表示形式。

toString() - Method in class javafx.scene.input. ContextMenuEvent

返回此 ContextMenuEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. DataFormat

返回此 DataFormat对象的字符串表示形式。

toString() - Method in class javafx.scene.input. GestureEvent

返回此 GestureEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. InputMethodEvent

返回此 InputMethodEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. InputMethodTextRun

返回此 InputMethodTextRun对象的字符串表示形式。

toString() - Method in class javafx.scene.input. KeyCombination.Modifier

返回修饰符的字符串表示形式。

toString() - Method in class javafx.scene.input. KeyCombination

返回此对象的字符串表示形式。

toString() - Method in class javafx.scene.input. KeyEvent

返回此 KeyEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. MouseDragEvent

返回此 MouseDragEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. MouseEvent

返回此 MouseEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. PickResult

toString() - Method in class javafx.scene.input. RotateEvent

返回此 RotateEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. ScrollEvent

返回此 ScrollEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. SwipeEvent

返回此 SwipeEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. TouchEvent

返回此 TouchEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.input. TouchPoint

返回此 TouchPoint对象的字符串表示形式。

toString() - Method in class javafx.scene.input. ZoomEvent

返回此 ZoomEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.layout. BorderStrokeStyle

返回对象的字符串表示形式。

toString() - Method in class javafx.scene.layout. ColumnConstraints

返回此 ColumnConstraints对象的字符串表示形式。

toString() - Method in class javafx.scene.layout. CornerRadii

toString() - Method in class javafx.scene.layout. GridPane

返回此 GridPane对象的字符串表示形式。

toString() - Method in class javafx.scene.layout. RowConstraints

返回此 RowConstraints对象的字符串表示形式。

toString() - Method in class javafx.scene.media. MediaErrorEvent

检索事件的 String表示。

toString() - Method in exception javafx.scene.media. MediaException

返回此 MediaException对象的字符串表示形式。

toString() - Method in class javafx.scene.media. Track

toString() - Method in class javafx.scene. Node

返回对象的字符串表示形式。

toString() - Method in class javafx.scene.paint. Color

返回此 Color的字符串表示 Color 。

toString() - Method in class javafx.scene.paint. LinearGradient

返回此 LinearGradient对象的字符串表示形式。

toString() - Method in class javafx.scene.paint. PhongMaterial

toString() - Method in class javafx.scene.paint. RadialGradient

返回此 RadialGradient对象的字符串表示形式。

toString() - Method in class javafx.scene.paint. Stop

返回此 Stop对象的字符串表示形式。

toString() - Method in class javafx.scene. SceneAntialiasing

toString() - Method in class javafx.scene.shape. Arc

返回此 Arc对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. ArcTo

返回此 ArcTo对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. Circle

返回此 Circle对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. ClosePath

返回此 ArcTo对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. CubicCurve

返回此 CubicCurve对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. CubicCurveTo

返回此 CubicCurveTo对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. Ellipse

返回此 Ellipse对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. HLineTo

返回此 HLineTo对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. Line

返回此 Line对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. LineTo

返回此 LineTo对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. MoveTo

返回此 MoveTo对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. Path

返回此 Path对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. Polygon

返回此 Polygon对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. Polyline

返回此 Polyline对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. QuadCurve

返回此 QuadCurve对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. QuadCurveTo

返回此 CubicCurveTo对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. Rectangle

返回此 Rectangle对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. SVGPath

返回此 SVGPath对象的字符串表示形式。

toString() - Method in class javafx.scene.shape. VertexFormat

toString() - Method in class javafx.scene.shape. VLineTo

返回此 VLineTo对象的字符串表示形式。

toString() - Method in class javafx.scene.text. Font

将此 Font对象转换为 String表示。

toString() - Method in class javafx.scene.text. HitInfo

toString() - Method in class javafx.scene.text. Text

返回此 Text对象的字符串表示形式。

toString() - Method in class javafx.scene.transform. Affine

返回此 Affine对象的字符串表示形式。

toString() - Method in class javafx.scene.transform. Rotate

返回此 Rotate对象的字符串表示形式。

toString() - Method in class javafx.scene.transform. Scale

返回此 Scale对象的字符串表示形式。

toString() - Method in class javafx.scene.transform. Shear

返回此 Shear对象的字符串表示形式。

toString() - Method in class javafx.scene.transform. Translate

返回此 Translate对象的字符串表示形式。

toString() - Method in class javafx.scene.web. WebErrorEvent

返回此EventObject的String表示形式。

toString() - Method in class javafx.scene.web. WebEvent

返回此 WebEvent对象的字符串表示形式。

toString() - Method in class javafx.scene.web. WebHistory.Entry

toString() - Method in class javafx.stage. Screen

返回此 Screen对象的字符串表示形式。

toString() - Method in class javafx.stage. WindowEvent

返回此 WindowEvent对象的字符串表示形式。

toString() - Method in class javafx.util. Duration

返回此 Duration对象的字符串表示形式。

toString() - Method in class javafx.util. Pair

String这个 Pair代表。

toString() - Method in class javax.accessibility. AccessibleBundle

使用默认语言环境获取描述密钥的本地化字符串。

toString() - Method in class javax.accessibility. AccessibleRelationSet

使用默认语言环境创建表示集合中所有关系的本地化字符串。

toString() - Method in class javax.accessibility. AccessibleStateSet

使用默认语言环境创建表示集合中所有状态的本地化字符串。

toString() - Method in class javax.activation. MimeType

返回此对象的String表示。

toString() - Method in class javax.activation. MimeTypeParameterList

返回此对象的字符串表示形式。

toString() - Method in class javax.imageio.plugins.jpeg. JPEGHuffmanTable

返回代表这个霍夫曼表的 String 。

toString() - Method in class javax.imageio.plugins.jpeg. JPEGQTable

返回表示该量化表的 String 。

toString() - Method in interface javax.lang.model.element. AnnotationValue

返回此值的字符串表示形式。

toString() - Method in enum javax.lang.model.element. Modifier

以小写形式返回此修饰符的名称。

toString() - Method in interface javax.lang.model.type. TypeMirror

返回此类型的内容丰富的字符串表示形式。

toString() - Method in class javax.management. Attribute

返回表示此Attribute值的String对象。

toString() - Method in class javax.management. AttributeValueExp

返回表示其值的字符串。

toString() - Method in exception javax.management. BadAttributeValueExpException

返回表示对象的字符串。

toString() - Method in exception javax.management. BadBinaryOpValueExpException

返回表示对象的字符串。

toString() - Method in exception javax.management. BadStringOperationException

返回表示对象的字符串。

toString() - Method in class javax.management. ImmutableDescriptor

toString() - Method in class javax.management. MBeanAttributeInfo

toString() - Method in class javax.management. MBeanConstructorInfo

toString() - Method in class javax.management. MBeanInfo

toString() - Method in class javax.management. MBeanNotificationInfo

toString() - Method in class javax.management. MBeanOperationInfo

toString() - Method in class javax.management. MBeanParameterInfo

toString() - Method in class javax.management. MBeanServerNotification

toString() - Method in class javax.management.modelmbean. DescriptorSupport

返回表示描述符的人类可读字符串。

toString() - Method in class javax.management.modelmbean. ModelMBeanAttributeInfo

返回一个可读的ModelMBeanAttributeInfo实例版本。

toString() - Method in class javax.management.modelmbean. ModelMBeanConstructorInfo

返回一个包含ModelMBeanConstructorInfo的全部内容的字符串，以人类可读的形式显示。

toString() - Method in class javax.management.modelmbean. ModelMBeanNotificationInfo

返回一个包含ModelMBeanNotificationInfo的可读字符串。

toString() - Method in class javax.management.modelmbean. ModelMBeanOperationInfo

返回一个包含以可读的形式显示的ModelMBeanOperationInfo的全部内容的字符串。

toString() - Method in class javax.management. Notification

返回此通知的String表示形式。

toString() - Method in class javax.management. ObjectInstance

返回表示此ObjectInstance对象的字符串。

toString() - Method in class javax.management. ObjectName

返回对象名称的字符串表示形式。

toString() - Method in class javax.management.openmbean. ArrayType

返回此 ArrayType实例的字符串表示形式。

toString() - Method in interface javax.management.openmbean. CompositeData

返回此 CompositeData实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. CompositeDataSupport

返回此 CompositeDataSupport实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. CompositeType

返回此 CompositeType实例的字符串表示形式。

toString() - Method in interface javax.management.openmbean. OpenMBeanAttributeInfo

返回此 OpenMBeanAttributeInfo实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. OpenMBeanAttributeInfoSupport

返回此 OpenMBeanAttributeInfoSupport实例的字符串表示形式。

toString() - Method in interface javax.management.openmbean. OpenMBeanConstructorInfo

返回此 OpenMBeanConstructorInfo实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. OpenMBeanConstructorInfoSupport

返回此 OpenMBeanConstructorInfoSupport实例的字符串表示形式。

toString() - Method in interface javax.management.openmbean. OpenMBeanInfo

返回此 OpenMBeanInfo实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. OpenMBeanInfoSupport

返回此 OpenMBeanInfoSupport实例的字符串表示形式。

toString() - Method in interface javax.management.openmbean. OpenMBeanOperationInfo

返回此 OpenMBeanOperationInfo实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. OpenMBeanOperationInfoSupport

返回此 OpenMBeanOperationInfoSupport实例的字符串表示形式。

toString() - Method in interface javax.management.openmbean. OpenMBeanParameterInfo

返回此 OpenMBeanParameterInfo实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. OpenMBeanParameterInfoSupport

返回此 OpenMBeanParameterInfoSupport实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. OpenType

返回此打开类型实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. SimpleType

返回此 SimpleType实例的字符串表示形式。

toString() - Method in interface javax.management.openmbean. TabularData

返回此 TabularData实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. TabularDataSupport

返回此 TabularDataSupport实例的字符串表示形式。

toString() - Method in class javax.management.openmbean. TabularType

返回此 TabularType实例的字符串表示形式。

toString() - Method in class javax.management.relation. Role

返回描述角色的字符串。

toString() - Method in class javax.management.relation. RoleInfo

返回描述角色信息的字符串。

toString() - Method in class javax.management.relation. RoleUnresolved

返回描述此对象的字符串。

toString() - Method in class javax.management.remote. JMXPrincipal

返回此 JMXPrincipal的字符串表示 JMXPrincipal 。

toString() - Method in class javax.management.remote. JMXServiceURL

此服务网址的字符串表示形式。

toString() - Method in class javax.management.remote. NotificationResult

返回对象的字符串表示形式。

toString() - Method in class javax.management.remote.rmi. RMIConnectionImpl

返回此对象的字符串表示形式。

toString() - Method in class javax.management.remote.rmi. RMIConnector

返回此对象的字符串表示形式。

toString() - Method in class javax.management.remote. TargetedNotification

返回此定向通知的文本表示。

toString() - Method in class javax.management. StringValueExp

返回表示对象的字符串。

toString() - Method in class javax.naming. BinaryRefAddr

生成此地址的字符串表示形式。

toString() - Method in class javax.naming. Binding

生成此绑定的字符串表示形式。

toString() - Method in class javax.naming. CompositeName

生成此复合名称的字符串表示形式。

toString() - Method in class javax.naming. CompoundName

使用复合名称的语法规则生成此化合物名称的字符串表示形式。

toString() - Method in exception javax.naming.directory. AttributeModificationException

此异常的字符串表示形式包含有关错误发生位置的信息和第一个未执行的修改。

toString() - Method in class javax.naming.directory. BasicAttribute

生成此属性的字符串表示形式。

toString() - Method in class javax.naming.directory. BasicAttributes

生成此属性集的字符串表示形式。

toString() - Method in class javax.naming.directory. ModificationItem

生成此修改项的字符串表示形式，由修改操作及其相关属性组成。

toString() - Method in class javax.naming.directory. SearchResult

生成此SearchResult的字符串表示形式。

toString() - Method in class javax.naming.ldap. LdapName

以 RFC 2253定义的格式返回此LDAP名称的字符串表示形式，并在类描述中描述。

toString() - Method in class javax.naming.ldap. Rdn

返回此Rdn如在由定义的格式表示的字符串RFC 2253和在类描述用于描述LdapName 。

toString() - Method in exception javax.naming. LinkException

生成此异常的字符串表示形式。

toString() - Method in class javax.naming. NameClassPair

生成此名称/类对的字符串表示形式。

toString() - Method in exception javax.naming. NamingException

生成此异常的字符串表示形式。

toString() - Method in class javax.naming. RefAddr

生成此地址的字符串表示形式。

toString() - Method in class javax.naming. Reference

生成此引用的字符串表示形式。

toString() - Method in class javax.net.ssl. SNIHostName

返回对象的字符串表示形式，包括此 SNIHostName对象中的DNS主机名。

toString() - Method in class javax.net.ssl. SNIServerName

返回此服务器名称的字符串表示形式，包括此 SNIServerName对象中的服务器名称类型和编码服务器名称值。

toString() - Method in class javax.net.ssl. SSLEngineResult

返回此对象的String表示形式。

toString() - Method in class javax.print.attribute. DateTimeSyntax

返回与此date-time属性对应的字符串值。

toString() - Method in class javax.print.attribute. EnumSyntax

返回与此枚举值对应的字符串值。

toString() - Method in class javax.print.attribute. IntegerSyntax

返回与该整数属性对应的字符串值。

toString() - Method in class javax.print.attribute. ResolutionSyntax

返回此分辨率属性的字符串版本。

toString() - Method in class javax.print.attribute. SetOfIntegerSyntax

返回与该set-of-integer属性对应的字符串值。

toString() - Method in class javax.print.attribute. Size2DSyntax

返回此二维大小属性的字符串版本。

toString() - Method in class javax.print.attribute.standard. MediaPrintableArea

返回以mm为单位的矩形大小属性的字符串版本。

toString() - Method in class javax.print.attribute. TextSyntax

返回一个标识此文本属性的字符串。

toString() - Method in class javax.print.attribute. URISyntax

返回一个标识此URI属性的字符串。

toString() - Method in class javax.print. DocFlavor

将此 DocFlavor转换为字符串。

toString() - Method in class javax.print.event. PrintEvent

toString() - Method in class javax.rmi.CORBA. Stub

返回此存根的字符串表示形式。

toString() - Method in class javax.security.auth.kerberos. EncryptionKey

返回此 EncryptionKey的内容丰富的文字表示。

toString() - Method in class javax.security.auth.kerberos. KerberosCredMessage

返回此 KerberosCredMessage的内容丰富的文字表示。

toString() - Method in class javax.security.auth.kerberos. KerberosKey

返回此 KerberosKey的内容丰富的文字表示。

toString() - Method in class javax.security.auth.kerberos. KerberosPrincipal

返回此 KerberosPrincipal的内容丰富的文字表示。

toString() - Method in class javax.security.auth.kerberos. KerberosTicket

返回此 KerberosTicket的内容丰富的文字表示。

toString() - Method in class javax.security.auth.kerberos. KeyTab

返回此 KeyTab的内容丰富的文字表示。

toString() - Method in class javax.security.auth.login. AppConfigurationEntry.LoginModuleControlFlag

返回此controlFlag的String表示形式。

toString() - Method in class javax.security.auth. Subject

返回此 Subject的字符串表示 Subject 。

toString() - Method in class javax.security.auth.x500. X500Principal

返回这个 X500Principal的用户友好的字符串表示。

toString() - Method in class javax.security.cert. Certificate

已过时。

返回此证书的字符串表示形式。

toString() - Method in exception javax.security.sasl. SaslException

返回此异常的字符串表示形式。

toString() - Method in class javax.smartcardio. ATR

返回此ATR的字符串表示形式。

toString() - Method in class javax.smartcardio. CommandAPDU

返回此命令APDU的字符串表示形式。

toString() - Method in class javax.smartcardio. ResponseAPDU

返回此响应APDU的字符串表示形式。

toString() - Method in class javax.smartcardio. TerminalFactory

返回此TerminalFactory的字符串表示形式。

toString() - Method in class javax.sound.midi. MidiDevice.Info

提供设备信息的字符串表示。

toString() - Method in class javax.sound.midi. Sequencer.SyncMode

提供此同步模式的名称作为模式的字符串表示形式。

toString() - Method in class javax.sound.sampled. AudioFileFormat

提供文件格式的字符串表示形式。

toString() - Method in class javax.sound.sampled. AudioFileFormat.Type

提供文件类型的名称作为文件类型的 String表示。

toString() - Method in class javax.sound.sampled. AudioFormat.Encoding

提供编码的 String表示。

toString() - Method in class javax.sound.sampled. AudioFormat

返回描述格式的字符串，如：“PCM SIGNED 22050 Hz 16 bit mono big-endian”。

toString() - Method in class javax.sound.sampled. BooleanControl

提供控件的字符串表示形式。

toString() - Method in class javax.sound.sampled. CompoundControl

提供控件的字符串表示形式。

toString() - Method in class javax.sound.sampled. Control

获取描述控件类型及其当前状态的字符串。

toString() - Method in class javax.sound.sampled. Control.Type

提供 String表示的控件类型。

toString() - Method in class javax.sound.sampled. DataLine.Info

获取数据行信息的文本描述。

toString() - Method in class javax.sound.sampled. EnumControl

提供控件的字符串表示形式。

toString() - Method in class javax.sound.sampled. FloatControl

提供控件的字符串表示形式。

toString() - Method in class javax.sound.sampled. Line.Info

获取行信息的文本描述。

toString() - Method in class javax.sound.sampled. LineEvent

获取事件的字符串表示形式。

toString() - Method in class javax.sound.sampled. LineEvent.Type

返回类型名称作为字符串表示形式。

toString() - Method in class javax.sound.sampled. Mixer.Info

提供混音器信息的字符串表示。

toString() - Method in class javax.sound.sampled. Port.Info

提供端口的 String表示。

toString() - Method in class javax.sound.sampled. ReverbType

提供混响类型的 String表示，包括其名称及其参数设置。

toString() - Method in class javax.swing. DefaultBoundedRangeModel

返回显示所有 BoundedRangeModel属性的字符串。

toString() - Method in class javax.swing. DefaultListModel

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing. DefaultListSelectionModel

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.event. DocumentEvent.EventType

将类型转换为字符串。

toString() - Method in class javax.swing.event. EventListenerList

返回EventListenerList的字符串表示形式。

toString() - Method in class javax.swing.event. HyperlinkEvent.EventType

将类型转换为字符串。

toString() - Method in class javax.swing.event. ListDataEvent

返回此ListDataEvent的字符串表示形式。

toString() - Method in class javax.swing.event. ListSelectionEvent

返回一个 String ，显示和标识此对象的属性。

toString() - Method in class javax.swing.event. TreeModelEvent

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.filechooser. FileNameExtensionFilter

返回 FileNameExtensionFilter的字符串表示 FileNameExtensionFilter 。

toString() - Method in class javax.swing. GroupLayout

返回此 GroupLayout的字符串表示 GroupLayout 。

toString() - Method in class javax.swing. ImageIcon

返回此图像的字符串表示形式。

toString() - Method in class javax.swing. JList.DropLocation

返回此放置位置的字符串表示形式。

toString() - Method in class javax.swing. JTable.DropLocation

返回此放置位置的字符串表示形式。

toString() - Method in class javax.swing. JTree.DropLocation

返回此放置位置的字符串表示形式。

toString() - Method in class javax.swing. LookAndFeel

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.plaf.nimbus. State

toString() - Method in class javax.swing.plaf.synth. ColorType

返回此 ColorType的文字描述。

toString() - Method in class javax.swing.plaf.synth. Region

返回Region的名称。

toString() - Method in class javax.swing. RepaintManager

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing. SizeRequirements

返回描述最小，首选和最大大小要求的字符串以及对齐方式。

toString() - Method in class javax.swing.text. AbstractDocument.BranchElement

将元素转换为字符串。

toString() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent

返回更改事件的字符串描述。

toString() - Method in class javax.swing.text. AbstractDocument.LeafElement

将元素转换为字符串。

toString() - Method in class javax.swing.text. DefaultCaret

toString() - Method in class javax.swing.text. DefaultStyledDocument.ElementSpec

将元素转换为字符串。

toString() - Method in class javax.swing.text.html. CSS.Attribute

属性的字符串表示形式。

toString() - Method in class javax.swing.text.html. HTML.Attribute

返回此属性的字符串表示形式。

toString() - Method in class javax.swing.text.html. HTML.Tag

返回标签的字符串表示形式。

toString() - Method in class javax.swing.text.html. Option

字符串表示是标签。

toString() - Method in class javax.swing.text.html.parser. AttributeList

toString() - Method in class javax.swing.text.html.parser. ContentModel

转换成字符串。

toString() - Method in class javax.swing.text.html.parser. DTD

返回此DTD的字符串表示形式。

toString() - Method in class javax.swing.text.html.parser. Element

转换成字符串。

toString() - Method in class javax.swing.text. JTextComponent.DropLocation

返回此放置位置的字符串表示形式。

toString() - Method in class javax.swing.text. Position.Bias

字符串表示

toString() - Method in class javax.swing.text. Segment

将段转换为字符串。

toString() - Method in class javax.swing.text. SimpleAttributeSet

将属性集转换为字符串。

toString() - Method in class javax.swing.text. StyleConstants

返回字符串表示形式。

toString() - Method in class javax.swing.text. StyleContext.NamedStyle

将样式转换为字符串。

toString() - Method in class javax.swing.text. StyleContext.SmallAttributeSet

返回一个显示键/值对的字符串。

toString() - Method in class javax.swing.text. StyleContext

将StyleContext转换为字符串。

toString() - Method in class javax.swing.text. TabSet

返回一组选项卡的字符串表示形式。

toString() - Method in class javax.swing.text. TabStop

toString() - Method in class javax.swing. TransferHandler.DropLocation

返回此放置位置的字符串表示形式。

toString() - Method in class javax.swing.tree. DefaultMutableTreeNode

返回向该节点的用户对象发送 toString()的结果，如果节点没有用户对象，则返回空字符串。

toString() - Method in class javax.swing.tree. DefaultTreeSelectionModel

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.tree. TreePath

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing. UIManager.LookAndFeelInfo

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.undo. AbstractUndoableEdit

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.undo. CompoundEdit

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.undo. UndoableEditSupport

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.swing.undo. UndoManager

返回显示和标识此对象属性的字符串。

toString() - Method in class javax.tools. SimpleJavaFileObject

toString() - Method in class javax.xml.bind.helpers. ValidationEventImpl

以有助于调试的格式返回此对象的字符串表示形式。

toString() - Method in class javax.xml.bind.helpers. ValidationEventLocatorImpl

以有助于调试的格式返回此对象的字符串表示形式。

toString() - Method in exception javax.xml.bind. JAXBException

返回此JAXBException的简短描述。

toString() - Method in exception javax.xml.bind. TypeConstraintException

返回此TypeConstraintException的简短描述。

toString() - Method in class javax.xml.crypto.dsig.spec. XPathType.Filter

返回操作的字符串形式。

toString() - Method in class javax.xml.crypto. KeySelector.Purpose

返回此目的的字符串表示（“sign”，“verify”，“encrypt”或“decrypt”）。

toString() - Method in class javax.xml.datatype. DatatypeConstants.Field

返回英文字段名称。

toString() - Method in class javax.xml.datatype. Duration

返回 String这个 Duration Object表示。

toString() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回此 XMLGregorianCalendar Object的 String表示。

toString() - Method in class javax.xml.namespace. QName

String这个 QName表示。

toString() - Method in class javax.xml.ws. EndpointReference

显示EPR信息，方便调试。

toString() - Method in class jdk.dynalink.beans. StaticClass

toString() - Method in class jdk.dynalink. CallSiteDescriptor

返回此调用站点描述符的字符串表示形式，格式为 name(parameterTypes)returnType@lookup 。

toString() - Method in class jdk.dynalink. NamedOperation

返回此命名操作的字符串表示形式。

toString() - Method in class jdk.dynalink. NamespaceOperation

返回此命名空间操作的字符串表示形式。

toString() - Method in class jdk.jshell. MethodSnippet

toString() - Method in class jdk.jshell. Snippet

toString() - Method in class jdk.jshell. SnippetEvent

返回事件的字符串表示形式

toString() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror

toString() - Method in class jdk.net. SocketFlow

toString() - Method in exception org.ietf.jgss. GSSException

返回主要和次要状态代码的文本表示。

toString() - Method in interface org.ietf.jgss. GSSName

返回 GSSName对象的文本表示。

toString() - Method in class org.ietf.jgss. Oid

以点分隔的符号返回oid的整数分量的字符串表示形式。

toString() - Method in class org.omg.CORBA.portable. ObjectImpl

返回 String对象，它表示此 ObjectImpl对象。

toString() - Method in exception org.omg.CORBA. SystemException

将此异常转换为代表字符串。

toString() - Method in interface org.w3c.dom.ranges. Range

以Range作为字符串返回Range的内容。

toString() - Method in exception org.xml.sax. SAXException

覆盖toString以接收任何嵌入式异常。

toString() - Method in exception org.xml.sax. SAXParseException

覆盖toString以提供更详细的错误消息。

toString(boolean) - Static method in class java.lang. Boolean

返回表示指定布尔值的 String对象。

toString(boolean) - Method in interface java.security. Certificate

已过时。

返回一个表示证书内容的字符串。

toString(boolean) - Method in class java.security. Identity

已过时。

返回此标识的字符串表示形式，可选择更多的细节，不包括没有任何参数的 toString方法。

toString(boolean) - Method in exception javax.naming. LinkException

生成此异常的字符串表示形式。

toString(boolean) - Method in exception javax.naming. NamingException

更详细地生成字符串表示。

toString(boolean[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(byte) - Static method in class java.lang. Byte

返回一个新的 String对象，代表指定的 byte 。

toString(byte[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(char) - Static method in class java.lang. Character

返回 String表示指定对象 char 。

toString(char[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(double) - Static method in class java.lang. Double

返回 double参数的字符串表示形式。

toString(double[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(float) - Static method in class java.lang. Float

返回 float参数的字符串表示形式。

toString(float[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(int) - Method in class java.io. ByteArrayOutputStream

已过时。
此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过toString(String enc)方法，该方法采用encoding-name参数，或toString()方法，该方法使用平台的默认字符编码。

toString(int) - Static method in class java.lang. Integer

返回表示指定整数的 String对象。

toString(int) - Static method in class java.lang.reflect. Modifier

返回描述指定修饰符中的访问修饰符标志的字符串。

toString(int) - Method in class java.math. BigInteger

返回给定基数中BigInteger的String表示形式。

toString(int[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(int, int) - Static method in class java.lang. Integer

返回由第二个参数指定的基数中的第一个参数的字符串表示形式。

toString(int, Class<?>, String, MethodType) - Static method in interface java.lang.invoke. MethodHandleInfo

给出 MethodHandleInfo的字符串表示，给出其符号引用的四个部分。

toString(int, String) - Method in class javax.print.attribute. ResolutionSyntax

以给定的单位返回此分辨率属性的字符串版本。

toString(int, String) - Method in class javax.print.attribute. Size2DSyntax

以给定单位返回此二维尺寸属性的字符串版本。

toString(int, String) - Method in class javax.print.attribute.standard. MediaPrintableArea

返回给定单位的此矩形大小属性的字符串版本。

toString(long) - Static method in class java.lang. Long

返回 String表示指定对象 long 。

toString(long[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(long, int) - Static method in class java.lang. Long

返回由第二个参数指定的基数中的第一个参数的字符串表示形式。

toString(short) - Static method in class java.lang. Short

返回一个新的 String对象，表示指定的 short 。

toString(short[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(Tag) - Method in interface com.sun.tools.doclets. Taglet

已过时。

给定此自定义标签的 Tag表示，返回其字符串表示形式，将其输出到生成的页面。

toString(Tag[]) - Method in interface com.sun.tools.doclets. Taglet

已过时。

给定一个表示此自定义标签的 Tag s的数组，返回其字符串表示形式，将其输出到生成的页面。

toString(Boolean) - Method in class javafx.util.converter. BooleanStringConverter

将提供的对象转换为其字符串形式。

toString(Byte) - Method in class javafx.util.converter. ByteStringConverter

将提供的对象转换为其字符串形式。

toString(Character) - Method in class javafx.util.converter. CharacterStringConverter

将提供的对象转换为其字符串形式。

toString(Double) - Method in class javafx.util.converter. DoubleStringConverter

将提供的对象转换为其字符串形式。

toString(Float) - Method in class javafx.util.converter. FloatStringConverter

将提供的对象转换为其字符串形式。

toString(Integer) - Method in class javafx.util.converter. IntegerStringConverter

将提供的对象转换为其字符串形式。

toString(Long) - Method in class javafx.util.converter. LongStringConverter

将提供的对象转换为其字符串形式。

toString(Number) - Method in class javafx.scene.chart. NumberAxis.DefaultFormatter

将提供的对象转换为其字符串形式。

toString(Number) - Method in class javafx.util.converter. NumberStringConverter

将提供的对象转换为其字符串形式。

toString(Object) - Static method in class java.util. Objects

返回调用的结果 toString的非 null参数， "null"为 null的说法。

toString(Object[]) - Static method in class java.util. Arrays

返回指定数组的内容的字符串表示形式。

toString(Object, String) - Static method in class java.util. Objects

如果第一个参数不是 null并返回第二个参数，则返回对第一个参数调用 toString的结果。

toString(Short) - Method in class javafx.util.converter. ShortStringConverter

将提供的对象转换为其字符串形式。

toString(String) - Method in class java.io. ByteArrayOutputStream

通过使用命名的charset解码字节将缓冲区的内容转换为字符串。

toString(String) - Method in class javafx.util.converter. DefaultStringConverter

将提供的对象转换为其字符串形式。

toString(BigDecimal) - Method in class javafx.util.converter. BigDecimalStringConverter

将提供的对象转换为其字符串形式。

toString(BigInteger) - Method in class javafx.util.converter. BigIntegerStringConverter

将提供的对象转换为其字符串形式。

toString(LocalDate) - Method in class javafx.util.converter. LocalDateStringConverter

将提供的对象转换为其字符串形式。

toString(LocalDateTime) - Method in class javafx.util.converter. LocalDateTimeStringConverter

将提供的对象转换为其字符串形式。

toString(LocalTime) - Method in class javafx.util.converter. LocalTimeStringConverter

将提供的对象转换为其字符串形式。

toString(Date) - Method in class javafx.util.converter. DateTimeStringConverter

将提供的对象转换为其字符串形式。

toString(List<? extends DocTree>, Element) - Method in interface jdk.javadoc.doclet. Taglet

返回要包含在生成的输出中的该标签的一系列实例的字符串表示形式。

toString(Set<PosixFilePermission>) - Static method in class java.nio.file.attribute. PosixFilePermissions

返回一组权限的 String表示。

toString(Stub) - Method in interface javax.rmi.CORBA. StubDelegate

代表团要求 Stub.toString() 。

toString(TableModel, int, int) - Method in class javax.swing.table. TableStringConverter

返回指定位置的值的字符串表示形式。

toString(Object) - Method in class org.omg.CORBA.portable. Delegate

提供实现来覆盖委托CORBA对象的toString（）方法。

toString(T) - Method in class javafx.util.converter. FormatStringConverter

将提供的对象转换为其字符串形式。

toString(T) - Method in class javafx.util. StringConverter

将提供的对象转换为其字符串形式。

toStub() - Method in class javax.management.remote.rmi. RMIIIOPServerImpl

已过时。

toStub() - Method in class javax.management.remote.rmi. RMIJRMPServerImpl

返回此RMIServer对象的可序列存根。

toStub() - Method in class javax.management.remote.rmi. RMIServerImpl

返回此服务器对象的远程存根。

toStub(Remote) - Static method in class java.rmi.server. RemoteObject

返回作为参数传递的远程对象 obj的存根。

toStub(Remote) - Method in interface javax.rmi.CORBA. PortableRemoteObjectDelegate

代表团要求 PortableRemoteObject.toStub(java.rmi.Remote) 。

toStub(Remote) - Static method in class javax.rmi. PortableRemoteObject

返回给定服务器对象的存根。

totalChildIndent - Variable in class javax.swing.plaf.basic. BasicTreeUI

将缩进的总距离。

totalColumnWidth - Variable in class javax.swing.table. DefaultTableColumnModel

所有列的组合宽度的本地缓存

totalCpuDuration() - Method in interface java.lang. ProcessHandle.Info

返回进程累积的总计。

totalDurationProperty() - Method in class javafx.animation. Animation

只读变量，用于指示此 Animation的总持续时间，包括重复。

totalDurationProperty() - Method in class javafx.scene.media. MediaPlayer

播放时间的总量，如果允许玩，直到完成。

totalMemory() - Method in class java.lang. Runtime

返回Java虚拟机中的内存总量。

totalWorkProperty() - Method in class javafx.concurrent. Service

totalWorkProperty() - Method in class javafx.concurrent. Task

totalWorkProperty() - Method in interface javafx.concurrent. Worker

获取ReadOnlyDoubleProperty代表需要完成的最大工作量。

toTitleCase(char) - Static method in class java.lang. Character

使用UnicodeData文件中的案例映射信息将字符参数转换为titlecase。

toTitleCase(int) - Static method in class java.lang. Character

使用UnicodeData文件中的案例映射信息将字符（Unicode代码点）参数转换为titlecase。

TOTOP_TOLEFT - Static variable in class javax.print.attribute.standard. PresentationDirection

页面从右下方开始列出，向上和向左移动。

TOTOP_TORIGHT - Static variable in class javax.print.attribute.standard. PresentationDirection

页面按照从左下角开始的列进行排列，向上和向右移动。

toTotalMonths() - Method in class java.time. Period

获得此期间的总月数。

TOUCH_MOVED - Static variable in class javafx.scene.input. TouchEvent

触摸点移动时会发生此事件。

TOUCH_PRESSED - Static variable in class javafx.scene.input. TouchEvent

当按下触摸点（第一次触摸）时，会发生此事件。

TOUCH_RELEASED - Static variable in class javafx.scene.input. TouchEvent

当触发点被释放时，会发生此事件。

TOUCH_STATIONARY - Static variable in class javafx.scene.input. TouchEvent

当按住触摸点并静止（不移动）时，会发生此事件。

TouchEvent - Class in javafx.scene.input

触摸事件表示触摸屏操作。

TouchEvent(Object, EventTarget, EventType<TouchEvent>, TouchPoint, List<TouchPoint>, int, boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.input. TouchEvent

构建新的TouchEvent事件。

TouchEvent(EventType<TouchEvent>, TouchPoint, List<TouchPoint>, int, boolean, boolean, boolean, boolean) - Constructor for class javafx.scene.input. TouchEvent

构造具有null源和目标的新的TouchEvent事件。

TouchPoint - Class in javafx.scene.input

触摸点表示多点触摸动作的单个点，通常一个手指触摸屏幕。

TouchPoint(int, TouchPoint.State, double, double, double, double, EventTarget, PickResult) - Constructor for class javafx.scene.input. TouchPoint

创建TouchPoint的新实例。

TouchPoint.State - Enum in javafx.scene.input

表示触摸点的当前状态

toUnicode(String) - Static method in class java.net. IDN

将字符串从ASCII兼容编码（ACE）转换为Unicode，由ToUnicode操作定义为 RFC 3490 。

toUnicode(String, int) - Static method in class java.net. IDN

将字符串从ASCII兼容编码（ACE）转换为Unicode，由ToUnicode操作 RFC 3490定义。

toUnsignedInt(byte) - Static method in class java.lang. Byte

通过无符号转换将参数转换为 int 。

toUnsignedInt(short) - Static method in class java.lang. Short

通过无符号转换将参数转换为 int 。

toUnsignedLong(byte) - Static method in class java.lang. Byte

通过无符号转换将参数转换为 long 。

toUnsignedLong(int) - Static method in class java.lang. Integer

通过无符号转换将参数转换为 long 。

toUnsignedLong(short) - Static method in class java.lang. Short

通过无符号转换将参数转换为 long 。

toUnsignedString(int) - Static method in class java.lang. Integer

将参数的字符串表示形式返回为无符号十进制值。

toUnsignedString(int, int) - Static method in class java.lang. Integer

以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。

toUnsignedString(long) - Static method in class java.lang. Long

将参数的字符串表示形式返回为无符号十进制值。

toUnsignedString(long, int) - Static method in class java.lang. Long

以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。

toUpperCase() - Method in class java.lang. String

使用默认语言环境的规则将此 String所有字符转换为大写。

toUpperCase(char) - Static method in class java.lang. Character

使用UnicodeData文件中的案例映射信息将字符参数转换为大写。

toUpperCase(int) - Static method in class java.lang. Character

使用UnicodeData文件中的案例映射信息将字符（Unicode代码点）参数转换为大写。

toUpperCase(Locale) - Method in class java.lang. String

将此 String所有字符转换为大写，使用给定的 Locale的规则。

toUri() - Method in interface java.nio.file. Path

返回一个URI来表示此路径。

toUri() - Method in interface javax.tools. FileObject

返回标识此文件对象的URI。

toUri() - Method in class javax.tools. ForwardingFileObject

toUri() - Method in class javax.tools. SimpleJavaFileObject

toURI() - Method in class java.io. File

构造一个表示此抽象路径名的 file: URI。

toURI() - Method in class java.net. URL

返回相当于此URL的URI 。

toURL() - Method in class java.io. File

已过时。
此方法不会自动转义URL中非法的字符。 建议在新的代码转换的抽象路径到URL通过先转换成URI，经由toURI方法，然后经由转换URI为URL URI.toURL方法。

toURL() - Method in class java.net. URI

从此URI构造一个URL。

toValueProperty() - Method in class javafx.animation. FadeTransition

指定此 FadeTransition的停止不透明度值。

toValueProperty() - Method in class javafx.animation. FillTransition

指定此 FillTransition的停止颜色值。

toValueProperty() - Method in class javafx.animation. StrokeTransition

指定此 StrokeTransition的停止颜色值。

toViewCoordinates(Dimension) - Method in class javax.swing. JViewport

转换像素坐标中的大小以查看坐标。

toViewCoordinates(Point) - Method in class javax.swing. JViewport

转换像素坐标中的点以查看坐标。

toXMLFormat() - Method in class javax.xml.datatype. XMLGregorianCalendar

返回 this实例的词汇表示。

toXMLString() - Method in class javax.management.modelmbean. DescriptorSupport

返回表示描述符的XML字符串。

toXProperty() - Method in class javafx.animation. ScaleTransition

指定此 ScaleTransition的停止X比例值。

toXProperty() - Method in class javafx.animation. TranslateTransition

指定此 TranslateTransition的停止X坐标值。

toYProperty() - Method in class javafx.animation. ScaleTransition

这个停止Y刻度值这个 ScaleTransition 。

toYProperty() - Method in class javafx.animation. TranslateTransition

指定此 TranslateTransition的停止Y坐标值。

toZonedDateTime() - Method in class java.time. OffsetDateTime

将此日期时间转换为 ZonedDateTime使用偏移量作为区域ID。

toZonedDateTime() - Method in class java.util. GregorianCalendar

将此对象转换为 ZonedDateTime ，表示与此 GregorianCalendar相同的时间点。

toZoneId() - Method in class java.util. TimeZone

将此 TimeZone对象转换为 ZoneId 。

toZProperty() - Method in class javafx.animation. ScaleTransition

停止Z刻度值这个 ScaleTransition 。

toZProperty() - Method in class javafx.animation. TranslateTransition

指定此 TranslateTransition的停止Z坐标值。

TR - Static variable in class javax.swing.text.html. HTML.Tag

标签<tr>

TRACE - java.lang. System.Logger.Level

TRACE级别：通常用于记录诊断信息。

TRACE_ALL - Static variable in interface com.sun.jdi. VirtualMachine

所有跟踪都启用

TRACE_EVENTS - Static variable in interface com.sun.jdi. VirtualMachine

跟踪启用内部事件处理。

TRACE_NONE - Static variable in interface com.sun.jdi. VirtualMachine

所有跟踪都被禁用。

TRACE_OBJREFS - Static variable in interface com.sun.jdi. VirtualMachine

跟踪启用对象引用的内部管理。

TRACE_RECEIVES - Static variable in interface com.sun.jdi. VirtualMachine

从目标VM接收的JDWP数据包启用跟踪。

TRACE_REFTYPES - Static variable in interface com.sun.jdi. VirtualMachine

跟踪启用了引用类型的内部管理。

TRACE_SENDS - Static variable in interface com.sun.jdi. VirtualMachine

为发送到目标VM的JDWP数据包启用跟踪。

traceInstructions(boolean) - Method in class java.lang. Runtime

不推荐用于删除：此API元素将在以后的版本中被删除。
该方法旨在控制指令跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。

traceMethodCalls(boolean) - Method in class java.lang. Runtime

不推荐用于删除：此API元素将在以后的版本中被删除。
此方法旨在控制方法调用跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。

Track - Class in javafx.scene.media

表示媒体资源中包含的曲目的类。

Track - Class in javax.sound.midi

MIDI轨道是独立的MIDI事件流（时间戳的MIDI数据），可以与标准MIDI文件中的其他轨道一起存储。

TRACK - Static variable in class java.awt.event. AdjustmentEvent

绝对跟踪调整类型。

TRACK_NEXT - javafx.scene.input. KeyCode

常数为 Next Track键。

TRACK_PREV - javafx.scene.input. KeyCode

常数为 Previous Track键。

trackBuffer - Variable in class javax.swing.plaf.basic. BasicSliderUI

轨道距控制器一侧的距离

trackColor - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

跟踪颜色

tracker - Static variable in class javax.swing. ImageIcon

已过时。
自1.8

trackHighlight - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

追踪亮点

trackHighlightColor - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

跟踪高亮颜色

TRACKING - Static variable in class java.awt.font. TextAttribute

属性键控制跟踪。

TRACKING_LOOSE - Static variable in class java.awt.font. TextAttribute

执行松动跟踪。

TRACKING_TIGHT - Static variable in class java.awt.font. TextAttribute

执行紧跟踪。

trackListener - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

跟踪听众

trackListener - Variable in class javax.swing.plaf.basic. BasicSliderUI

跟踪听众

TrackListener() - Constructor for class javax.swing.plaf.basic. BasicScrollBarUI.TrackListener

TrackListener() - Constructor for class javax.swing.plaf.basic. BasicSliderUI.TrackListener

trackRect - Variable in class javax.swing.plaf.basic. BasicScrollBarUI

跟踪矩形

trackRect - Variable in class javax.swing.plaf.basic. BasicSliderUI

跟踪矩形

tracks - Variable in class javax.sound.midi. Sequence

MIDI序列中的MIDI轨迹。

trackWidth - Static variable in class javax.swing.plaf.metal. MetalSliderUI

轨道的宽度。

TRADITIONAL_CHINESE - Static variable in class java.util. Locale

有用的语言常数

TRADITIONAL_HANZI - Static variable in class java.awt.im. InputSubset

所有汉字使用的汉字常数繁体中文，包括CJK统一表意文字的一部分以及可能被定义为替代字符的繁体中文汉字。

trailers() - Method in class jdk.incubator.http. HttpResponse

返回接收到的响应预告片（如果有），当它们可用时。

trailing(int) - Static method in class java.awt.font. TextHitInfo

在指定的 charIndex处创建字符后端的命中。

TRAILING - javax.swing. GroupLayout.Alignment

表示元素应与区域的末尾对齐。

TRAILING - Static variable in class java.awt. FlowLayout

该值表示组件的每一行应该对齐到容器方向的后端，例如从左到右的方向向右。

TRAILING - Static variable in class javax.swing.border. TitledBorder

将边框线右侧的标题文本从左到右定位，位于边界线的左侧，从右到左定位。

TRAILING - Static variable in interface javax.swing. SwingConstants

标识用于从左到右和从右到左的语言的文本的后端。

TRANSACTION_MODE - Exception in org.omg.CORBA

如果检测到IOR中的InvocationPolicy与所选择的调用路径（即，直接或路由调用）之间的不匹配，则客户端ORB抛出CORBA TRANSACTION_MODE异常。

TRANSACTION_MODE() - Constructor for exception org.omg.CORBA. TRANSACTION_MODE

构造一个 TRANSACTION_MODE异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。

TRANSACTION_MODE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_MODE

构造具有指定的次要代码和完成状态的 TRANSACTION_MODE异常。

TRANSACTION_MODE(String) - Constructor for exception org.omg.CORBA. TRANSACTION_MODE

构造一个 TRANSACTION_MODE异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_MODE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_MODE

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_MODE异常。

TRANSACTION_NONE - Static variable in interface java.sql. Connection

指示不支持事务的常量。

TRANSACTION_READ_COMMITTED - Static variable in interface java.sql. Connection

一个常数表示防止脏读; 可能会发生不可重复的读取和幻像读取。

TRANSACTION_READ_UNCOMMITTED - Static variable in interface java.sql. Connection

一个常量表示可能会发生脏读，不可重复读和幻读。

TRANSACTION_REPEATABLE_READ - Static variable in interface java.sql. Connection

一个常量表示防止了脏读和不可重复读; 可以发生幻影读取。

TRANSACTION_REQUIRED - Exception in org.omg.CORBA

异常表示请求携带一个空事务上下文，但需要一个活动事务。

TRANSACTION_REQUIRED() - Constructor for exception org.omg.CORBA. TRANSACTION_REQUIRED

构造一个 TRANSACTION_REQUIRED异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。

TRANSACTION_REQUIRED(int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_REQUIRED

构造具有指定的次要代码和完成状态的 TRANSACTION_REQUIRED异常。

TRANSACTION_REQUIRED(String) - Constructor for exception org.omg.CORBA. TRANSACTION_REQUIRED

构造一个 TRANSACTION_REQUIRED异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_REQUIRED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_REQUIRED

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_REQUIRED异常。

TRANSACTION_ROLLEDBACK - Exception in org.omg.CORBA

与请求相关联的事务已经回滚或标记回滚时抛出异常。

TRANSACTION_ROLLEDBACK() - Constructor for exception org.omg.CORBA. TRANSACTION_ROLLEDBACK

构造一个 TRANSACTION_ROLLEDBACK异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。

TRANSACTION_ROLLEDBACK(int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_ROLLEDBACK

构造具有指定的次要代码和完成状态的 TRANSACTION_ROLLEDBACK异常。

TRANSACTION_ROLLEDBACK(String) - Constructor for exception org.omg.CORBA. TRANSACTION_ROLLEDBACK

构造一个 TRANSACTION_ROLLEDBACK异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_ROLLEDBACK(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_ROLLEDBACK

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_ROLLEDBACK异常。

TRANSACTION_SERIALIZABLE - Static variable in interface java.sql. Connection

一个常数表示防止脏读，不可重复读和幻影读。

TRANSACTION_UNAVAILABLE - Exception in org.omg.CORBA

由于ORB与事务服务的连接异常终止，所以ORB无法处理事务服务上下文时抛出CORBA TRANSACTION_UNAVAILABLE异常。

TRANSACTION_UNAVAILABLE() - Constructor for exception org.omg.CORBA. TRANSACTION_UNAVAILABLE

构造一个 TRANSACTION_UNAVAILABLE异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO和一个空描述。

TRANSACTION_UNAVAILABLE(int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_UNAVAILABLE

构造具有指定的次要代码和完成状态的 TRANSACTION_UNAVAILABLE异常。

TRANSACTION_UNAVAILABLE(String) - Constructor for exception org.omg.CORBA. TRANSACTION_UNAVAILABLE

构造一个 TRANSACTION_UNAVAILABLE异常，其中包含指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_UNAVAILABLE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSACTION_UNAVAILABLE

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_UNAVAILABLE异常。

TransactionalWriter - Interface in javax.sql.rowset.spi

一个专门的界面，有助于扩展标准的 SyncProvider抽象类，使其具有更细粒度的事务控制。

TransactionRequiredException - Exception in javax.transaction

此异常指示请求携带空事务上下文，但目标对象需要激活事务。

TransactionRequiredException() - Constructor for exception javax.transaction. TransactionRequiredException

构造一个 TransactionRequiredException 。

TransactionRequiredException(String) - Constructor for exception javax.transaction. TransactionRequiredException

构造一个 TransactionRequiredException 。

TransactionRolledbackException - Exception in javax.transaction

此异常表示与请求的处理关联的事务已回滚，或标记为回滚。

TransactionRolledbackException() - Constructor for exception javax.transaction. TransactionRolledbackException

构造一个 TransactionRolledbackException 。

TransactionRolledbackException(String) - Constructor for exception javax.transaction. TransactionRolledbackException

构造一个 TransactionRolledbackException 。

TransactionService - Interface in org.omg.IOP

org / omg / IOP / TransactionService.java。

transfer(E) - Method in class java.util.concurrent. LinkedTransferQueue

将元素转移给消费者，如有必要，等待。

transfer(E) - Method in interface java.util.concurrent. TransferQueue

将元素转移给消费者，如有必要，等待。

transferable - Variable in class java.awt.dnd. DropTargetContext.TransferableProxy

封装的 Transferable对象。

Transferable - Interface in java.awt.datatransfer

定义可用于为传输操作提供数据的类的接口。

transferablesFlavorsChanged() - Method in class java.awt.dnd. DragSourceContext

通知对等方 Transferable的 DataFlavor已更改。

transferFocus() - Method in class java.awt. Component

将焦点转移到下一个组件，就像这个组件是焦点所有者一样。

transferFocusBackward() - Method in class java.awt. Component

将焦点转移到以前的组件，就像这个组件是焦点所有者一样。

transferFocusDownCycle() - Method in class java.awt. Container

将焦点转移到一个焦点遍历周期。

transferFocusUpCycle() - Method in class java.awt. Component

将焦点转移到一个焦点遍历周期。

transferFrom(ReadableByteChannel, long, long) - Method in class java.nio.channels. FileChannel

从给定的可读字节通道将字节传输到该通道的文件中。

TransferHandler - Class in javax.swing

这个类用于处理从Swing组件 Transferable 。

TransferHandler() - Constructor for class javax.swing. TransferHandler

子类的便利构造函数。

TransferHandler(String) - Constructor for class javax.swing. TransferHandler

构造一个可以通过剪贴板或拖放操作将Java Bean属性从一个组件传输到另一个组件的传输处理程序。

TransferHandler.DropLocation - Class in javax.swing

表示应插入丢弃数据的位置。

TransferHandler.TransferSupport - Class in javax.swing

该类封装了剪贴板的所有相关细节或拖放传输，还允许自定义拖放体验的方面。

TransferMode - Enum in javafx.scene.input

描述了相对于拖放手势的数据传输模式。

TransferQueue< E> - Interface in java.util.concurrent

A BlockingQueue ，其中生产者可能等待消费者接收元素。

TransferSupport(Component, Transferable) - Constructor for class javax.swing. TransferHandler.TransferSupport

为给定的组件创建一个 TransferSupport ， isDrop() false为 Transferable和 Transferable 。

transferTo(long, long, WritableByteChannel) - Method in class java.nio.channels. FileChannel

将该通道文件的字节传输到给定的可写字节通道。

transferTo(OutputStream) - Method in class java.io. InputStream

从该输入流中读取所有字节，并按读取的顺序将字节写入给定的输出流。

transferType - Variable in class java.awt.image. ColorModel

用于表示像素值的数组的数据类型。

transform(double[], int, double[], int, int) - Method in class java.awt.geom. AffineTransform

通过此转换来转换双精度坐标数组。

transform(double[], int, float[], int, int) - Method in class java.awt.geom. AffineTransform

通过此转换来转换双精度坐标数组，并将结果存储到浮点数组中。

transform(double, double) - Method in class javafx.scene.transform. Affine

transform(double, double) - Method in class javafx.scene.transform. Rotate

transform(double, double) - Method in class javafx.scene.transform. Scale

transform(double, double) - Method in class javafx.scene.transform. Shear

transform(double, double) - Method in class javafx.scene.transform. Transform

通过此转换来转换指定的点。

transform(double, double) - Method in class javafx.scene.transform. Translate

transform(double, double, double) - Method in class javafx.scene.transform. Affine

transform(double, double, double) - Method in class javafx.scene.transform. Rotate

transform(double, double, double) - Method in class javafx.scene.transform. Scale

transform(double, double, double) - Method in class javafx.scene.transform. Shear

transform(double, double, double) - Method in class javafx.scene.transform. Transform

通过此转换来转换指定的点。

transform(double, double, double) - Method in class javafx.scene.transform. Translate

transform(double, double, double, double, double, double) - Method in class javafx.scene.canvas. GraphicsContext

将输入与当前变换相连。

transform(float[], int, double[], int, int) - Method in class java.awt.geom. AffineTransform

通过此转换来转换浮点坐标数组，并将结果存储到双精度数组中。

transform(float[], int, float[], int, int) - Method in class java.awt.geom. AffineTransform

通过此变换来转换浮点坐标数组。

transform(AffineTransform) - Method in class java.awt.geom. Area

使用指定的AffineTransform转换Area的几何。

transform(AffineTransform) - Method in class java.awt.geom. Path2D.Double

使用指定的AffineTransform转换此路径的几何。

transform(AffineTransform) - Method in class java.awt.geom. Path2D.Float

使用指定的AffineTransform转换此路径的几何。

transform(AffineTransform) - Method in class java.awt.geom. Path2D

使用指定的AffineTransform转换此路径的几何。

transform(AffineTransform) - Method in class java.awt. Graphics2D

根据最后指定的第一个应用规则，组合 AffineTransform对象，其中 Transform为 Graphics2D 。

transform(Point2D[], int, Point2D[], int, int) - Method in class java.awt.geom. AffineTransform

通过此转换来转换点对象数组。

transform(Point2D, Point2D) - Method in class java.awt.geom. AffineTransform

转换指定的 ptSrc并将结果存储在 ptDst 。

transform(ClassLoader, String, Class<?>, ProtectionDomain, byte[]) - Method in interface java.lang.instrument. ClassFileTransformer

转换给定的类文件并返回一个新的替换类文件。

transform(MethodHandle) - Method in interface jdk.dynalink.linker. MethodHandleTransformer

转换方法句柄。

transform(MethodHandle) - Method in class jdk.dynalink.linker.support. DefaultInternalObjectFilter

transform(Module, ClassLoader, String, Class<?>, ProtectionDomain, byte[]) - Method in interface java.lang.instrument. ClassFileTransformer

转换给定的类文件并返回一个新的替换类文件。

transform(Bounds) - Method in class javafx.scene.transform. Transform

通过此转换转换指定的边界。

transform(Point2D) - Method in class javafx.scene.transform. Transform

通过此转换来转换指定的点。

transform(Point3D) - Method in class javafx.scene.transform. Transform

通过此转换来转换指定的点。

transform(Affine) - Method in class javafx.scene.canvas. GraphicsContext

将输入与当前变换相连。

transform(Data, XMLCryptoContext) - Method in interface javax.xml.crypto.dsig. Transform

使用底层变换算法转换指定的数据。

transform(Data, XMLCryptoContext, OutputStream) - Method in interface javax.xml.crypto.dsig. Transform

使用底层变换算法转换指定的数据。

transform(Source, Result) - Method in class javax.xml.transform. Transformer

将XML Source转换为 Result 。

Transform - Class in javafx.scene.transform

这个类是不同仿射变换的基类。

Transform - Interface in javax.xml.crypto.dsig

在 Transform中定义的XML Transform元素的 表示 。

Transform() - Constructor for class javafx.scene.transform. Transform

TRANSFORM - Static variable in class java.awt.font. TextAttribute

用于转换字体的属性键。

TRANSFORM_CHANGED - Static variable in class javafx.scene.transform. TransformChangedEvent

TransformChangedEvent唯一有效的EventType。

transform2DPoints(double[], int, double[], int, int) - Method in class javafx.scene.transform. Transform

通过此转换来转换坐标数组。

transform3DPoints(double[], int, double[], int, int) - Method in class javafx.scene.transform. Transform

通过此变换来转换浮点坐标数组。

TransformationList< E, F> - Class in javafx.collections.transformation

所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

TransformationList(ObservableList<? extends F>) - Constructor for class javafx.collections.transformation. TransformationList

创建一个围绕源列表的新的Transformation列表。

TransformAttribute - Class in java.awt.font

TransformAttribute类为变换提供了一个不可变的包装器，以便作为属性使用是安全的。

TransformAttribute(AffineTransform) - Constructor for class java.awt.font. TransformAttribute

包装指定的变换。

transformChanged() - Method in class javafx.scene.transform. Rotate

transformChanged() - Method in class javafx.scene.transform. Transform

每当任何一个参数发生变化时，所有转换都必须调用此方法。

TransformChangedEvent - Class in javafx.scene.transform

当它的任何属性发生变化时，这个事件被触发。

TransformChangedEvent() - Constructor for class javafx.scene.transform. TransformChangedEvent

创建一个新的 TransformChangedEvent ，事件类型为 TRANSFORM_CHANGED 。

TransformChangedEvent(Object, EventTarget) - Constructor for class javafx.scene.transform. TransformChangedEvent

构造一个新的 TransformChangedEvent与指定的事件源和目标。

Transformer - Class in javax.xml.transform

这个抽象类的一个实例可以将一个源代码树转换成一个结果树。

Transformer() - Constructor for class javax.xml.transform. Transformer

默认构造函数是有意保护的。

TransformerConfigurationException - Exception in javax.xml.transform

表示严重的配置错误。

TransformerConfigurationException() - Constructor for exception javax.xml.transform. TransformerConfigurationException

创建一个新的 TransformerConfigurationException没有详细消息。

TransformerConfigurationException(String) - Constructor for exception javax.xml.transform. TransformerConfigurationException

创建一个新的 TransformerConfigurationException ，其中 String指定为错误消息。

TransformerConfigurationException(String, Throwable) - Constructor for exception javax.xml.transform. TransformerConfigurationException

创建一个新的 TransformerConfigurationException与给定的 异常基本原因和详细信息。

TransformerConfigurationException(String, SourceLocator) - Constructor for exception javax.xml.transform. TransformerConfigurationException

从消息和定位器创建一个新的TransformerConfigurationException。

TransformerConfigurationException(String, SourceLocator, Throwable) - Constructor for exception javax.xml.transform. TransformerConfigurationException

在TransformerConfigurationException中包装一个现有的异常。

TransformerConfigurationException(Throwable) - Constructor for exception javax.xml.transform. TransformerConfigurationException

创建一个新的 TransformerConfigurationException与给定的 异常基本原因的错误。

TransformerException - Exception in javax.xml.transform

此类指定在转换过程中发生的异常情况。

TransformerException(String) - Constructor for exception javax.xml.transform. TransformerException

创建一个新的TransformerException。

TransformerException(String, Throwable) - Constructor for exception javax.xml.transform. TransformerException

在TransformerException中包含一个现有的异常。

TransformerException(String, SourceLocator) - Constructor for exception javax.xml.transform. TransformerException

从消息和定位器创建一个新的TransformerException。

TransformerException(String, SourceLocator, Throwable) - Constructor for exception javax.xml.transform. TransformerException

在TransformerException中包含一个现有的异常。

TransformerException(Throwable) - Constructor for exception javax.xml.transform. TransformerException

创建一个包含现有异常的新TransformerException。

TransformerFactory - Class in javax.xml.transform

TransformerFactory实例可用于创建Transformer和Templates对象。

TransformerFactory() - Constructor for class javax.xml.transform. TransformerFactory

默认构造函数是有意保护的。

TransformerFactoryConfigurationError - Error in javax.xml.transform

当Transformer工厂存在配置问题时抛出。

TransformerFactoryConfigurationError() - Constructor for error javax.xml.transform. TransformerFactoryConfigurationError

创建一个新的 TransformerFactoryConfigurationError没有详细消息。

TransformerFactoryConfigurationError(Exception) - Constructor for error javax.xml.transform. TransformerFactoryConfigurationError

创建一个新的 TransformerFactoryConfigurationError与给定的 异常错误的基本原因。

TransformerFactoryConfigurationError(Exception, String) - Constructor for error javax.xml.transform. TransformerFactoryConfigurationError

创建一个新的 TransformerFactoryConfigurationError与给定的 异常基本原因和详细信息。

TransformerFactoryConfigurationError(String) - Constructor for error javax.xml.transform. TransformerFactoryConfigurationError

创建一个新的 TransformerFactoryConfigurationError ，其中 String指定为错误消息。

TransformerHandler - Interface in javax.xml.transform.sax

TransformerHandler侦听SAX ContentHandler解析事件并将其转换为Result。

TransformException - Exception in javax.xml.crypto.dsig

表示执行变换算法时发生的异常情况。

TransformException() - Constructor for exception javax.xml.crypto.dsig. TransformException

构造一个新的 TransformException与 null作为其详细信息。

TransformException(String) - Constructor for exception javax.xml.crypto.dsig. TransformException

构造具有指定详细信息的新的 TransformException 。

TransformException(String, Throwable) - Constructor for exception javax.xml.crypto.dsig. TransformException

构造一个新的 TransformException与指定的详细信息和原因。

TransformException(Throwable) - Constructor for exception javax.xml.crypto.dsig. TransformException

构造一个新的 TransformException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

TransformParameterSpec - Interface in javax.xml.crypto.dsig.spec

一个Transform算法的算法参数说明 。

TransformService - Class in javax.xml.crypto.dsig

用于变换和规范化算法的服务提供程序接口。

TransformService() - Constructor for class javax.xml.crypto.dsig. TransformService

默认构造函数，用于由子类调用。

Transient - Annotation Type in java.beans

表示当Introspector构造与注释的代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明称为“transient”的属性。

TRANSIENT - Exception in org.omg.CORBA

当ORB尝试到达对象并失败时抛出异常。

TRANSIENT - javax.lang.model.element. Modifier

修饰词 transient

TRANSIENT - Static variable in class java.lang.reflect. Modifier

int值代表 transient修饰符。

TRANSIENT - Static variable in class javax.accessibility. AccessibleState

表示此对象是短暂的。

TRANSIENT - Static variable in class org.omg.PortableServer. LifespanPolicyValue

TRANSIENT() - Constructor for exception org.omg.CORBA. TRANSIENT

构造一个 TRANSIENT异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。

TRANSIENT(int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSIENT

构造具有指定的次要代码和完成状态的 TRANSIENT异常。

TRANSIENT(String) - Constructor for exception org.omg.CORBA. TRANSIENT

构造一个 TRANSIENT异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSIENT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. TRANSIENT

构造具有指定的描述消息，次要代码和完成状态的 TRANSIENT异常。

Transition - Class in javafx.animation

一个抽象类，其中包含所有基于Transition的动画所需的基本功能，如PathTransition和RotateTransition 。

Transition() - Constructor for class javafx.animation. Transition

构造函数为 Transition 。

Transition(double) - Constructor for class javafx.animation. Transition

构造函数为 Transition 。

TRANSITIVE - java.lang.module. ModuleDescriptor.Requires.Modifier

依赖性导致任何依赖于 当前模块的模块对由 Requires命名的模块进行隐式声明的依赖。

translate(double, double) - Method in class java.awt.geom. AffineTransform

将此转换与转换变换相结合。

translate(double, double) - Method in class java.awt. Graphics2D

将当前的 Graphics2D Transform与平移变换相结合。

translate(double, double) - Method in class javafx.scene.canvas. GraphicsContext

将当前变换转换为x，y。

translate(double, double) - Static method in class javafx.scene.transform. Transform

返回表示转换变换的 Translate对象。

translate(int, int) - Method in class java.awt. Event

已过时。

注意： Event类已过时，仅适用于向后兼容性。

translate(int, int) - Method in class java.awt. Graphics

将图形上下文的原点转换为当前坐标系中的点（ x ， y ）。

translate(int, int) - Method in class java.awt. Graphics2D

将 Graphics2D上下文的原点转换为当前坐标系中的点（ x ， y ）。

translate(int, int) - Method in class java.awt. Point

转换这一点上，在位置 (x,y) ，通过 dx沿 x轴和 dy沿 y轴线，使得其现在代表点 (x+dx,y+dy) 。

translate(int, int) - Method in class java.awt. Polygon

平移的顶点 Polygon由 deltaX沿x轴和由 deltaY沿y轴。

translate(int, int) - Method in class java.awt. Rectangle

将这个 Rectangle的指示距离沿着X坐标轴向右移动，并沿着Y坐标轴向下翻译。

translate(int, int) - Method in class javax.swing. DebugGraphics

覆盖 Graphics.translate 。

Translate - Class in javafx.scene.transform

该类表示一个 Affine对象，它根据指定的因素转换坐标。

Translate() - Constructor for class javafx.scene.transform. Translate

创建默认的Translate（identity）。

Translate(double, double) - Constructor for class javafx.scene.transform. Translate

创建一个二维的翻译。

Translate(double, double, double) - Constructor for class javafx.scene.transform. Translate

创建一个三维翻译。

translateHTMLToCSS(AttributeSet) - Method in class javax.swing.text.html. StyleSheet

将一组HTML属性转换为等效的CSS属性集。

translateKey(Key) - Method in class java.security. KeyFactory

将其提供者可能未知或潜在不受信任的关键对象转换为该关键工厂的相应关键对象。

translateKey(SecretKey) - Method in class javax.crypto. SecretKeyFactory

将其提供者可能未知或可能不受信任的关键对象转换为该秘密密钥工厂的相应密钥对象。

translatePoint(int, int) - Method in class java.awt.event. MouseEvent

通过添加指定的 x （水平）和 y （垂直）偏移量将事件的坐标转换为新位置。

TranslateTransition - Class in javafx.animation

这 Transition创建一个移动/翻译动画，跨越其 TranslateTransition.duration 。

TranslateTransition() - Constructor for class javafx.animation. TranslateTransition

构造函数为 TranslateTransition

TranslateTransition(Duration) - Constructor for class javafx.animation. TranslateTransition

构造函数为 TranslateTransition

TranslateTransition(Duration, Node) - Constructor for class javafx.animation. TranslateTransition

构造函数为 TranslateTransition

translateXProperty() - Method in class javafx.scene. Node

定义添加到此 Node的转换中的转换的x坐标。

translateYProperty() - Method in class javafx.scene. Node

定义添加到此 Node的转换的转换的y坐标。

translateZProperty() - Method in class javafx.scene. Node

定义添加到此 Node的转换坐标的转换的Z坐标。

Translator - Class in com.sun.java.accessibility.util

Translator类为不实现接口Accessible对象提供了一个到接口Accessible的翻译。

Translator() - Constructor for class com.sun.java.accessibility.util. Translator

创建一个新的 Translator 。

Translator(Object) - Constructor for class com.sun.java.accessibility.util. Translator

创建一个新的 Translator与源对象o。

TRANSLUCENT - java.awt. GraphicsDevice.WindowTranslucency

表示在底层系统中对Windows的支持，其所有像素具有相同的α值，包括0.0和1.0之间。

TRANSLUCENT - Static variable in interface java.awt. Transparency

表示包含或可能包含0.0和1.0之间的任意α值的图像数据。

transmit(ByteBuffer, ByteBuffer) - Method in class javax.smartcardio. CardChannel

发送存储在命令ByteBuffer中的命令APDU，并在响应ByteBuffer中接收响应APDU。

transmit(CommandAPDU) - Method in class javax.smartcardio. CardChannel

将指定的命令APDU发送到智能卡，并返回响应APDU。

transmitControlCommand(int, byte[]) - Method in class javax.smartcardio. Card

向终端设备发送控制命令。

Transmitter - Interface in javax.sound.midi

A Transmitter将MidiEvent对象发送到一个或多个Receivers 。

transparency - Variable in class java.awt.image. VolatileImage

创建此图像的透明度值。

Transparency - Interface in java.awt

Transparency接口定义了实现类的通用透明度模式。

TRANSPARENCY_ENABLED_PROPERTY - Static variable in class javax.swing.colorchooser. AbstractColorChooserPanel

标识可以选择颜色的透明度（alpha值）

TRANSPARENT - javafx.stage. StageStyle

定义 Stage风格，透明背景，无装饰。

TRANSPARENT - Static variable in class javafx.scene.paint. Color

ARGB值为＃00000000的完全透明的颜色。

TRANSPARENT_WINDOW - javafx.application. ConditionalFeature

表示系统支持完整的窗口透明度。

transport() - Method in interface com.sun.jdi.connect. Connector

返回此连接器用于建立与目标VM的连接的传输机制。

Transport - Interface in com.sun.jdi.connect

调试器和目标VM之间的通信方法。

TRANSPORT_AND_MAP_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock

Unicode字符块的“传输和映射符号”的常量。

TRANSPORT_RETRY - Interface in org.omg.PortableInterceptor

org / omg / PortableInterceptor / TRANSPORT_RETRY.java。

TransportService - Class in com.sun.jdi.connect.spi

用于调试器和目标VM之间连接的传输服务。

TransportService() - Constructor for class com.sun.jdi.connect.spi. TransportService

TransportService.Capabilities - Class in com.sun.jdi.connect.spi

运输服务能力。

TransportService.ListenKey - Class in com.sun.jdi.connect.spi

听密钥 。

TransportTimeoutException - Exception in com.sun.jdi.connect

当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。

TransportTimeoutException() - Constructor for exception com.sun.jdi.connect. TransportTimeoutException

构造一个 TransportTimeoutException ，没有详细信息。

TransportTimeoutException(String) - Constructor for exception com.sun.jdi.connect. TransportTimeoutException

构造具有指定详细消息的 TransportTimeoutException 。

TRAVERSAL - java.awt.event. FocusEvent.Cause

具有未指定方向的焦点遍历动作。

TRAVERSAL_BACKWARD - java.awt.event. FocusEvent.Cause

反向聚焦遍历动作。

TRAVERSAL_DOWN - java.awt.event. FocusEvent.Cause

下循环焦点遍历动作。

TRAVERSAL_FORWARD - java.awt.event. FocusEvent.Cause

前向焦点遍历动作。

TRAVERSAL_UP - java.awt.event. FocusEvent.Cause

循环重点遍历动作。

TrayIcon - Class in java.awt

A TrayIcon对象表示可以添加到system tray的托盘图标。

TrayIcon(Image) - Constructor for class java.awt. TrayIcon

创建一个 TrayIcon与指定的图像。

TrayIcon(Image, String) - Constructor for class java.awt. TrayIcon

创建一个具有指定图像和工具提示文本的 TrayIcon 。

TrayIcon(Image, String, PopupMenu) - Constructor for class java.awt. TrayIcon

使用指定的图像，工具提示和弹出菜单创建一个 TrayIcon 。

TrayIcon.MessageType - Enum in java.awt

消息类型确定在消息的标题中将显示哪个图标，以及在显示时消息可能产生的可能的系统声音。

tree - Variable in class javax.swing.plaf.basic. BasicTreeUI

我们将要绘制的组件。

tree - Variable in class javax.swing.tree. DefaultTreeCellEditor

JTree实例监听。

树 - Interface in com.sun.source.tree

抽象语法树中所有节点的公共接口。

树 - Interface in jdk.nashorn.api.tree

抽象语法树中所有节点的公共接口。

TREE - Static variable in class javax.accessibility. AccessibleRole

用于向用户呈现分层信息的对象。

TREE - Static variable in class javax.swing.plaf.synth. Region

树地区。

TREE_CELL - Static variable in class javax.swing.plaf.synth. Region

一个单元格的树的区域。

TREE_ITEM - javafx.scene. AccessibleRole

树项目角色。

TREE_ITEM_AT_INDEX - javafx.scene. AccessibleAttribute

返回相对于其TREE_ITEM_PARENT的给定索引的树项。

TREE_ITEM_COUNT - javafx.scene. AccessibleAttribute

返回该节点相对于其TREE_ITEM_PARENT的树项计数。

TREE_ITEM_PARENT - javafx.scene. AccessibleAttribute

返回项的父项，如果该项是根，则返回null。

TREE_MODEL_PROPERTY - Static variable in class javax.swing. JTree

绑定属性名称为 treeModel 。

TREE_TABLE_CELL - javafx.scene. AccessibleRole

树表单元角色。

TREE_TABLE_ROW - javafx.scene. AccessibleRole

树表行角色。

TREE_TABLE_VIEW - javafx.scene. AccessibleRole

树表视图角色。

TREE_VIEW - javafx.scene. AccessibleRole

树视图角色。

Tree.Kind - Enum in com.sun.source.tree

列举各种树木。

Tree.Kind - Enum in jdk.nashorn.api.tree

列举各种树木。

TreeCancelEditingAction(String) - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeCancelEditingAction

构造一个新的实例 TreeCancelEditingAction 。

TreeCell< T> - Class in javafx.scene.control

Cell类型与TreeView控件一起使用。

TreeCell() - Constructor for class javafx.scene.control. TreeCell

创建一个默认的TreeCell实例。

TreeCellEditor - Interface in javax.swing.tree

添加到CellEditor在树中配置编辑器所需的扩展。

TreeCellRenderer - Interface in javax.swing.tree

定义显示树节点的对象的要求。

TreeCellSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为TreeCell控件。

TreeCellSkin(TreeCell<T>) - Constructor for class javafx.scene.control.skin. TreeCellSkin

创建一个新的TreeCellSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

treeCollapsed(TreeExpansionEvent) - Method in interface javax.swing.event. TreeExpansionListener

当树中的项目已折叠时调用。

treeCollapsed(TreeExpansionEvent) - Method in class javax.swing. JTree.AccessibleJTree

树折叠通知。

treeCollapsed(TreeExpansionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeExpansionHandler

当树中的项目已折叠时调用。

treeColumnProperty() - Method in class javafx.scene.control. TreeTableView

表示哪个列应该在其中显示披露节点的属性（即带有箭头的列）。

TreeControlIcon(boolean) - Constructor for class javax.swing.plaf.metal. MetalIconFactory.TreeControlIcon

构造一个 TreeControlIcon的实例。

treeDidChange() - Method in class javax.swing. JTree

当树已经发生变化时，我们需要调整边界大小，但还不够，我们需要删除扩展节点集（例如，节点被扩展或折叠，或节点被插入到树中）。

treeExpanded(TreeExpansionEvent) - Method in interface javax.swing.event. TreeExpansionListener

当树中的项目已被扩展时调用。

treeExpanded(TreeExpansionEvent) - Method in class javax.swing. JTree.AccessibleJTree

树模型扩展通知。

treeExpanded(TreeExpansionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeExpansionHandler

当树中的项目已被扩展时调用。

TREEEXPANSION - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing TreeExpansion支持（即TreeExpansionListener和TreeExpansionEvent）

TreeExpansionEvent - Class in javax.swing.event

用于标识树中单个路径的事件。

TreeExpansionEvent(Object, TreePath) - Constructor for class javax.swing.event. TreeExpansionEvent

构造一个TreeExpansionEvent对象。

TreeExpansionHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeExpansionHandler

TreeExpansionListener - Interface in javax.swing.event

当树展开或折叠节点时通知的侦听器。

TreeFolderIcon() - Constructor for class javax.swing.plaf.metal. MetalIconFactory.TreeFolderIcon

TreeHomeAction(int, String) - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeHomeAction

构造一个新的实例 TreeHomeAction 。

TreeIncrementAction(int, String) - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeIncrementAction

构造一个新的实例 TreeIncrementAction 。

TreeItem< T> - Class in javafx.scene.control

单个节点的模型为诸如TreeView之类的控件提供值的层次结构。

TreeItem() - Constructor for class javafx.scene.control. TreeItem

创建一个空TreeItem。

TreeItem(T) - Constructor for class javafx.scene.control. TreeItem

创建一个TreeItem，其value属性设置为提供的对象。

TreeItem(T, Node) - Constructor for class javafx.scene.control. TreeItem

创建一个TreeItem，其value属性设置为提供的对象，图形设置为提供的节点。

TreeItem.TreeModificationEvent< T> - Class in javafx.scene.control

一个Event ，其中包含所有形式的TreeItem修改的相关信息。

treeItemProperty() - Method in class javafx.scene.control. TreeCell

每个TreeCell最多代表一个TreeItem ，由该属性表示。

treeItemProperty() - Method in class javafx.scene.control. TreeTableRow

每个TreeTableCell最多代表一个TreeItem ，由该属性表示。

TreeItemPropertyValueFactory< S, T> - Class in javafx.scene.control.cell

Callback界面的方便实现，专为TreeTableColumn cell value factory使用而设计。

TreeItemPropertyValueFactory(String) - Constructor for class javafx.scene.control.cell. TreeItemPropertyValueFactory

创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。

TreeLeafIcon() - Constructor for class javax.swing.plaf.metal. MetalIconFactory.TreeLeafIcon

TreeMap< K, V> - Class in java.util

一个基于红黑树的NavigableMap实现。

TreeMap() - Constructor for class java.util. TreeMap

使用其键的自然排序构造一个新的空树状图。

TreeMap(Comparator<? super K>) - Constructor for class java.util. TreeMap

构造一个新的，空的树图，按照给定的比较器排序。

TreeMap(Map<? extends K, ? extends V>) - Constructor for class java.util. TreeMap

构造一个新的树状图，其中包含与给定地图相同的映射，根据其键的 自然顺序进行排序 。

TreeMap(SortedMap<K, ? extends V>) - Constructor for class java.util. TreeMap

构造一个包含相同映射并使用与指定排序映射相同顺序的新树映射。

treeModel - Variable in class javax.swing. JTree

定义由该对象显示的树的模型。

treeModel - Variable in class javax.swing.plaf.basic. BasicTreeUI

用于确定要显示的内容。

treeModel - Variable in class javax.swing.tree. AbstractLayoutCache

模型提供信息。

TreeModel - Interface in javax.swing.tree

该型号由 JTree 。

TREEMODEL - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing TreeModel支持（即TreeModelListener和TreeModelEvent）

TreeModelEvent - Class in javax.swing.event

将描述更改的信息封装到树模型，并用于通知树型模型侦听器的更改。

TreeModelEvent(Object, Object[]) - Constructor for class javax.swing.event. TreeModelEvent

用于在节点结构以某种方式更改时创建事件，将修改后的子树的根目录的路径标识为对象数组。

TreeModelEvent(Object, Object[], int[], Object[]) - Constructor for class javax.swing.event. TreeModelEvent

用于在更改，插入或删除节点时创建事件，将修改后的项目的父项路径标识为对象数组。

TreeModelEvent(Object, TreePath) - Constructor for class javax.swing.event. TreeModelEvent

用于在节点结构以某种方式更改时创建事件，将修改后的子树的根路径标识为TreePath对象。

TreeModelEvent(Object, TreePath, int[], Object[]) - Constructor for class javax.swing.event. TreeModelEvent

用于在更改，插入或删除节点时创建事件，将修改后的项目的父项路径标识为TreePath对象。

TreeModelHandler() - Constructor for class javax.swing. JTree.TreeModelHandler

TreeModelHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeModelHandler

treeModelListener - Variable in class javax.swing. JTree

更新 expandedState 。

TreeModelListener - Interface in javax.swing.event

定义侦听TreeModel中更改的对象的接口。

TreeModificationEvent(EventType<? extends Event>, CheckBoxTreeItem<T>, boolean) - Constructor for class javafx.scene.control. CheckBoxTreeItem.TreeModificationEvent

创建一个默认的TreeModificationEvent实例来表示给定的CheckBoxTreeItem实例的选择/不确定状态的变化。

TreeModificationEvent(EventType<? extends Event>, TreeItem<T>) - Constructor for class javafx.scene.control. TreeItem.TreeModificationEvent

构建一个基本的TreeModificationEvent - 这在树项目没有收到新值，扩展/折叠状态之间没有变化，并且其子项没有更改的情况下很有用。

TreeModificationEvent(EventType<? extends Event>, TreeItem<T>, boolean) - Constructor for class javafx.scene.control. TreeItem.TreeModificationEvent

构建一个TreeModificationEvent，当TreeItem已经改变了它的 TreeItem.expandedProperty()时 。

TreeModificationEvent(EventType<? extends Event>, TreeItem<T>, List<? extends TreeItem<T>>, List<? extends TreeItem<T>>) - Constructor for class javafx.scene.control. TreeItem.TreeModificationEvent

构造一个TreeModificationEvent，当TreeItem的子项列表更改时。

TreeModificationEvent(EventType<? extends Event>, TreeItem<T>, T) - Constructor for class javafx.scene.control. TreeItem.TreeModificationEvent

构建一个TreeModificationEvent，当TreeItem已经改变了它的 TreeItem.valueProperty()时 。

TreeNode - Interface in javax.swing.tree

定义可以用作JTree中的树节点的对象的要求。

treeNodesChanged(TreeModelEvent) - Method in interface javax.swing.event. TreeModelListener

节点（或一组兄弟节点）以某种方式更改后调用。

treeNodesChanged(TreeModelEvent) - Method in class javax.swing. JTree.AccessibleJTree

树型节点更改通知。

treeNodesChanged(TreeModelEvent) - Method in class javax.swing. JTree.TreeModelHandler

treeNodesChanged(TreeModelEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeModelHandler

treeNodesChanged(TreeModelEvent) - Method in class javax.swing.tree. AbstractLayoutCache

节点（或一组兄弟节点）以某种方式更改后调用。

treeNodesChanged(TreeModelEvent) - Method in class javax.swing.tree. FixedHeightLayoutCache

节点（或一组兄弟节点）以某种方式更改后调用。

treeNodesChanged(TreeModelEvent) - Method in class javax.swing.tree. VariableHeightLayoutCache

节点（或一组兄弟节点）以某种方式更改后调用。

treeNodesInserted(TreeModelEvent) - Method in interface javax.swing.event. TreeModelListener

在节点插入到树中之后调用。

treeNodesInserted(TreeModelEvent) - Method in class javax.swing. JTree.AccessibleJTree

树型节点更改通知。

treeNodesInserted(TreeModelEvent) - Method in class javax.swing. JTree.TreeModelHandler

treeNodesInserted(TreeModelEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeModelHandler

treeNodesInserted(TreeModelEvent) - Method in class javax.swing.tree. AbstractLayoutCache

在节点插入到树中之后调用。

treeNodesInserted(TreeModelEvent) - Method in class javax.swing.tree. FixedHeightLayoutCache

在节点插入到树中之后调用。

treeNodesInserted(TreeModelEvent) - Method in class javax.swing.tree. VariableHeightLayoutCache

在节点插入到树中之后调用。

treeNodesRemoved(TreeModelEvent) - Method in interface javax.swing.event. TreeModelListener

从树中删除节点后调用。

treeNodesRemoved(TreeModelEvent) - Method in class javax.swing. JTree.AccessibleJTree

树型节点更改通知。

treeNodesRemoved(TreeModelEvent) - Method in class javax.swing. JTree.TreeModelHandler

treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeModelHandler

treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.tree. AbstractLayoutCache

从树中删除节点后调用。

treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.tree. FixedHeightLayoutCache

从树中删除节点后调用。

treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.tree. VariableHeightLayoutCache

从树中删除节点后调用。

treeNotificationEvent() - Static method in class javafx.scene.control. TreeItem

用于指示事件在TreeItem中发生的基本EventType。

TreePageAction(int, String) - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreePageAction

构造一个新的实例 TreePageAction 。

TreePath - Class in com.sun.source.util

树节点的路径，通常用于表示树节点的祖先节点的序列，直到顶层的CompilationUnitTree节点。

TreePath - Class in javax.swing.tree

TreePath表示唯一标识树中节点的路径的对象数组。

TreePath() - Constructor for class javax.swing.tree. TreePath

创建一个空的 TreePath 。

TreePath(CompilationUnitTree) - Constructor for class com.sun.source.util. TreePath

为根节点创建一个TreePath。

TreePath(TreePath, Tree) - Constructor for class com.sun.source.util. TreePath

为子节点创建一个TreePath。

TreePath(Object) - Constructor for class javax.swing.tree. TreePath

创建一个包含单个元素的 TreePath 。

TreePath(Object[]) - Constructor for class javax.swing.tree. TreePath

从数组中创建一个 TreePath 。

TreePath(Object[], int) - Constructor for class javax.swing.tree. TreePath

从数组中创建一个 TreePath 。

TreePath(TreePath, Object) - Constructor for class javax.swing.tree. TreePath

使用指定的父元素和元素创建一个 TreePath 。

TreePathScanner< R, P> - Class in com.sun.source.util

一个访问所有子树节点的TreeVisitor，并为维护父节点的路径提供支持。

TreePathScanner() - Constructor for class com.sun.source.util. TreePathScanner

Trees - Class in com.sun.source.util

Bridges JSR 199，JSR 269和Tree API。

Trees() - Constructor for class com.sun.source.util. Trees

TreeScanner< R, P> - Class in com.sun.source.util

访问所有子树节点的TreeVisitor。

TreeScanner() - Constructor for class com.sun.source.util. TreeScanner

TREESELECTION - Static variable in class com.sun.java.accessibility.util. EventID

映射到Swing TreeSelection支持（即TreeSelectionListener和TreeSelectionEvent）

TreeSelectionEvent - Class in javax.swing.event

表示当前选择的变化的事件。

TreeSelectionEvent(Object, TreePath[], boolean[], TreePath, TreePath) - Constructor for class javax.swing.event. TreeSelectionEvent

代表一个 TreeSelectionModel的选择的 TreeSelectionModel 。

TreeSelectionEvent(Object, TreePath, boolean, TreePath, TreePath) - Constructor for class javax.swing.event. TreeSelectionEvent

代表一个 TreeSelectionModel的选择的 TreeSelectionModel 。

TreeSelectionHandler() - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeSelectionHandler

TreeSelectionListener - Interface in javax.swing.event

当TreeSelectionModel中的选择更改时通知的侦听器。

treeSelectionModel - Variable in class javax.swing.plaf.basic. BasicTreeUI

型号维护选择。

treeSelectionModel - Variable in class javax.swing.tree. AbstractLayoutCache

选择模式。

TreeSelectionModel - Interface in javax.swing.tree

此接口表示树组件选择的当前状态。

TreeSelectionRedirector() - Constructor for class javax.swing. JTree.TreeSelectionRedirector

TreeSet< E> - Class in java.util

A NavigableSet实现基于TreeMap 。

TreeSet() - Constructor for class java.util. TreeSet

构造一个新的，空的树组，根据其元素的自然排序进行排序。

TreeSet(Collection<? extends E>) - Constructor for class java.util. TreeSet

构造一个包含指定集合中的元素的新树集，根据其元素的 自然排序进行排序 。

TreeSet(Comparator<? super E>) - Constructor for class java.util. TreeSet

构造一个新的，空的树集，根据指定的比较器进行排序。

TreeSet(SortedSet<E>) - Constructor for class java.util. TreeSet

构造一个包含相同元素的新树，并使用与指定排序集相同的顺序。

TreeSortMode - Enum in javafx.scene.control

指定如何对树状UI控件中的树项进行排序。

treeState - Variable in class javax.swing.plaf.basic. BasicTreeUI

负责处理大小和扩展问题的对象。

treeStructureChanged(TreeModelEvent) - Method in interface javax.swing.event. TreeModelListener

在树已经从给定节点大幅度改变结构之后调用。

treeStructureChanged(TreeModelEvent) - Method in class javax.swing. JTree.AccessibleJTree

树模型结构变更通知。

treeStructureChanged(TreeModelEvent) - Method in class javax.swing. JTree.TreeModelHandler

treeStructureChanged(TreeModelEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeModelHandler

treeStructureChanged(TreeModelEvent) - Method in class javax.swing.tree. AbstractLayoutCache

在树已经从给定节点大幅度改变结构之后调用。

treeStructureChanged(TreeModelEvent) - Method in class javax.swing.tree. FixedHeightLayoutCache

在树已经从给定节点大幅度改变结构之后调用。

treeStructureChanged(TreeModelEvent) - Method in class javax.swing.tree. VariableHeightLayoutCache

在树已经从给定节点大幅度改变结构之后调用。

TreeTableCell< S, T> - Class in javafx.scene.control

在TreeTableView中表示单行/列交集。

TreeTableCell() - Constructor for class javafx.scene.control. TreeTableCell

构造一个具有“tree-table-cell”样式类的默认TreeTableCell实例。

TreeTableCellSkin< S, T> - Class in javafx.scene.control.skin

默认皮肤实现为TreeTableCell控件。

TreeTableCellSkin(TreeTableCell<S, T>) - Constructor for class javafx.scene.control.skin. TreeTableCellSkin

创建一个新的TreeTableCellSkin实例，将必需的子节点安装到控件 children列表中，以及处理密钥，鼠标等事件的必要输入映射。

TreeTableColumn< S, T> - Class in javafx.scene.control

A TreeTableView由多个TreeTableColumn实例组成。

TreeTableColumn() - Constructor for class javafx.scene.control. TreeTableColumn

使用默认单元格工厂，比较器和onEditCommit实现创建默认的TreeTableColumn。

TreeTableColumn(String) - Constructor for class javafx.scene.control. TreeTableColumn

创建一个TreeTableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

TreeTableColumn.CellDataFeatures< S, T> - Class in javafx.scene.control

在TreeTableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。

TreeTableColumn.CellEditEvent< S, T> - Class in javafx.scene.control

用户在表单元格上执行编辑时触发的事件。

TreeTableColumn.SortType - Enum in javafx.scene.control

枚举，指定应用于特定列的排序类型。

TreeTablePosition< S, T> - Class in javafx.scene.control

此类用于在TreeTableView中表示单个行/列/单元格。

TreeTablePosition(TreeTableView<S>, int, TreeTableColumn<S, T>) - Constructor for class javafx.scene.control. TreeTablePosition

构造一个TreeTablePosition实例来表示给定TreeTableView实例中给定的行/列位置。

TreeTableRow< T> - Class in javafx.scene.control

TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。

TreeTableRow() - Constructor for class javafx.scene.control. TreeTableRow

创建一个默认的TreeTableRow实例。

TreeTableRowSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为TreeTableRow控件。

TreeTableRowSkin(TreeTableRow<T>) - Constructor for class javafx.scene.control.skin. TreeTableRowSkin

创建一个新的TreeTableRowSkin实例，将必需的子节点安装到Control children列表中，以及处理键，鼠标等事件的必要输入映射。

TreeTableView< S> - Class in javafx.scene.control

TreeTableView控件旨在可视化无限数量的数据行，分为列。

TreeTableView() - Constructor for class javafx.scene.control. TreeTableView

创建一个空TreeTableView。

TreeTableView(TreeItem<S>) - Constructor for class javafx.scene.control. TreeTableView

使用提供的根节点创建TreeTableView。

TreeTableView.EditEvent< S> - Class in javafx.scene.control

一个Event在TreeTableView中专门用于表示编辑相关事件的子类。

TreeTableView.ResizeFeatures< S> - Class in javafx.scene.control

一个用于TableView column resize功能的不可变包装类。

TreeTableView.TreeTableViewFocusModel< S> - Class in javafx.scene.control

A FocusModel具有附加功能，可支持TableView控件的要求。

TreeTableView.TreeTableViewSelectionModel< S> - Class in javafx.scene.control

SelectionModel抽象类的简单扩展，允许对TreeTableView控件的特殊支持。

TreeTableViewFocusModel(TreeTableView<S>) - Constructor for class javafx.scene.control. TreeTableView.TreeTableViewFocusModel

创建一个默认的TableViewFocusModel实例，用于管理提供的TableView控件的焦点。

treeTableViewProperty() - Method in class javafx.scene.control. TreeTableCell

与此TreeTableCell关联的TreeTableView。

treeTableViewProperty() - Method in class javafx.scene.control. TreeTableColumn

TreeTableColumn属于的TreeTableView。

treeTableViewProperty() - Method in class javafx.scene.control. TreeTableRow

TreeTableCell显式链接到一个TreeTableView实例，由该属性表示。

TreeTableViewSelectionModel(TreeTableView<S>) - Constructor for class javafx.scene.control. TreeTableView.TreeTableViewSelectionModel

使用提供的TreeTableView构建一个默认的TreeTableViewSelectionModel实例。

TreeTableViewSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为TreeTableView控件。

TreeTableViewSkin(TreeTableView<T>) - Constructor for class javafx.scene.control.skin. TreeTableViewSkin

创建一个新的TreeTableViewSkin实例，将必需的子节点安装到控件 children列表中，以及处理键，鼠标等事件的必要输入映射。

TreeToggleAction(String) - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeToggleAction

构造一个新的实例 TreeToggleAction 。

TreeTraverseAction(int, String) - Constructor for class javax.swing.plaf.basic. BasicTreeUI.TreeTraverseAction

构造一个新的实例 TreeTraverseAction 。

TreeUI - Class in javax.swing.plaf

JTree可插拔的外观和界面。

TreeUI() - Constructor for class javax.swing.plaf. TreeUI

TreeView< T> - Class in javafx.scene.control

TreeView控件提供了一个树根视图（类型为TreeItem ）。

TreeView() - Constructor for class javafx.scene.control. TreeView

创建一个空TreeView。

TreeView(TreeItem<T>) - Constructor for class javafx.scene.control. TreeView

使用提供的根节点创建TreeView。

TreeView.EditEvent< T> - Class in javafx.scene.control

一个Event在TreeView中专门用于表示编辑相关事件的子类。

treeViewProperty() - Method in class javafx.scene.control. TreeCell

TreeCell显式链接到由该属性表示的单个TreeView实例。

TreeViewSkin< T> - Class in javafx.scene.control.skin

默认皮肤实现为TreeView控件。

TreeViewSkin(TreeView) - Constructor for class javafx.scene.control.skin. TreeViewSkin

创建一个新的TreeViewSkin实例，将必需的子节点安装到Control children列表中，以及处理密钥，鼠标等事件的必要输入映射。

TreeVisitor< R, P> - Interface in com.sun.source.tree

树木的访客，以访客设计模式的风格。

TreeVisitor< R, P> - Interface in jdk.nashorn.api.tree

树木的访客，以访客设计模式的风格。

TreeWalker - Interface in org.w3c.dom.traversal

TreeWalker对象用于使用由其 whatToShow标志定义的文档的视图来浏览文档树或子树，并过滤（如果有）。

treeWillCollapse(TreeExpansionEvent) - Method in interface javax.swing.event. TreeWillExpandListener

每当树中的节点即将被折叠时调用。

treeWillExpand(TreeExpansionEvent) - Method in interface javax.swing.event. TreeWillExpandListener

每当树中的节点即将被扩展时调用。

TreeWillExpandListener - Interface in javax.swing.event

当树展开或折叠节点时通知的侦听器。

TriangleMesh - Class in javafx.scene.shape

定义一个三角形三角形网格，由其相关联的 VertexFormat和一组独立的顶点组件阵列组成，例如点，法线，纹理坐标和定义网格的各个三角形的面阵列。

TriangleMesh() - Constructor for class javafx.scene.shape. TriangleMesh

创建 TriangleMesh类的新实例，默认为 VertexFormat.POINT_TEXCOORD类型。

TriangleMesh(VertexFormat) - Constructor for class javafx.scene.shape. TriangleMesh

使用指定的 VertexFormat创建一个新的 TriangleMesh类的实例。

trim() - Method in class java.lang. String

返回一个字符串，其值为此字符串，并删除任何前导和尾随空格。

trimEdits(int, int) - Method in class javax.swing.undo. UndoManager

删除指定范围内的编辑。

trimForLimit() - Method in class javax.swing.undo. UndoManager

将排队的编辑数减少到大小限制的范围，以下一个编辑的索引为中心。

trimToSize() - Method in class java.lang. StringBuffer

trimToSize() - Method in class java.util. ArrayList

修改此 ArrayList实例的容量成为列表当前大小。

trimToSize() - Method in class java.util. Vector

修改该向量的容量成为向量的当前大小。

trimToSize() - Method in interface javafx.collections. ObservableArray

缩小阵列中当前数据大小的容量。

trimToSize() - Method in class javax.swing. DefaultListModel

将此列表的容量修改为列表的当前大小。

TRUE - Static variable in class java.lang. Boolean

Boolean对象对应于原始值 true 。

TRUE - Static variable in interface java.util.jar. Pack200.Packer

字符串“true”是某些属性的可能值。

TRUE - Static variable in interface java.util.jar. Pack200.Unpacker

字符串“true”是某些属性的可能值。

TRUETYPE_FONT - Static variable in class java.awt. Font

识别TRUETYPE类型的字体资源。

truncate(long) - Method in class java.nio.channels. AsynchronousFileChannel

将此频道的文件截断为给定大小。

truncate(long) - Method in class java.nio.channels. FileChannel

将此频道的文件截断为给定大小。

truncate(long) - Method in interface java.nio.channels. SeekableByteChannel

将连接此通道的实体截断为给定的大小。

truncate(long) - Method in interface java.sql. Blob

截断 Blob对象表示的长度为 len字节的 BLOB值。

truncate(long) - Method in interface java.sql. Clob

截断该 Clob指定的长度为 len字符的 CLOB值。

truncate(long) - Method in class javax.sql.rowset.serial. SerialBlob

截断 BLOB值，这 Blob对象表示为 len字节长度。

truncate(long) - Method in class javax.sql.rowset.serial. SerialClob

截断 SerialClob对象所代表的 CLOB值，使其长度为 len字符。

TRUNCATE_EXISTING - java.nio.file. StandardOpenOption

如果文件已经存在，并且打开 StandardOpenOption.WRITE访问，则其长度将被截断为0。

TRUNCATED - Static variable in class javax.accessibility. AccessibleState

指示文本被边框矩形截断并且某些文本不显示在屏幕上的状态。

truncatedTo(TemporalUnit) - Method in class java.time. Duration

将此 Duration的副本返回给指定的单位。

truncatedTo(TemporalUnit) - Method in class java.time. Instant

将此 Instant的副本截回到指定的单位。

truncatedTo(TemporalUnit) - Method in class java.time. LocalDateTime

返回此 LocalDateTime的副本，截断时间。

truncatedTo(TemporalUnit) - Method in class java.time. LocalTime

返回此 LocalTime的副本，截断时间。

truncatedTo(TemporalUnit) - Method in class java.time. OffsetDateTime

返回此 OffsetDateTime的副本，截断时间。

truncatedTo(TemporalUnit) - Method in class java.time. OffsetTime

返回此 OffsetTime的副本，截断时间。

truncatedTo(TemporalUnit) - Method in class java.time. ZonedDateTime

返回此 ZonedDateTime的副本，截断时间。

TrustAnchor - Class in java.security.cert

信任锚或最受信任的证书颁发机构（CA）。

TrustAnchor(String, PublicKey, byte[]) - Constructor for class java.security.cert. TrustAnchor

创建一个 TrustAnchor的实例，其中最受信任的CA被指定为可分辨名称和公钥。

TrustAnchor(X509Certificate, byte[]) - Constructor for class java.security.cert. TrustAnchor

创建具有指定的 X509Certificate和可选名称约束的 TrustAnchor实例，这些约束用于在验证X.509认证路径时用作其他约束。

TrustAnchor(X500Principal, PublicKey, byte[]) - Constructor for class java.security.cert. TrustAnchor

创建一个 TrustAnchor的实例，其中最受信任的CA被指定为X500Principal和公钥。

TrustedCertificateEntry(Certificate) - Constructor for class java.security. KeyStore.TrustedCertificateEntry

构造一个 TrustedCertificateEntry与一个值得信赖的 Certificate 。

TrustedCertificateEntry(Certificate, Set<KeyStore.Entry.Attribute>) - Constructor for class java.security. KeyStore.TrustedCertificateEntry

构造一个 TrustedCertificateEntry具有可信任的 Certificate和相关联的条目属性。

TrustManager - Interface in javax.net.ssl

这是JSSE信托管理器的基础接口。

TrustManagerFactory - Class in javax.net.ssl

该类作为基于信任资料来源的信托经理的工厂。

TrustManagerFactory(TrustManagerFactorySpi, Provider, String) - Constructor for class javax.net.ssl. TrustManagerFactory

创建一个TrustManagerFactory对象。

TrustManagerFactorySpi - Class in javax.net.ssl

该类定义了 TrustManagerFactory类的 （ SPI ）。

TrustManagerFactorySpi() - Constructor for class javax.net.ssl. TrustManagerFactorySpi

TRY - com.sun.source.tree. Tree.Kind

用于TryTree的实例。

TRY - jdk.nashorn.api.tree. Tree.Kind

用于TryTree的实例。

tryAcquire() - Method in class java.util.concurrent. Semaphore

从这个信号量获得许可证，只有在调用时可以使用该许可证。

tryAcquire(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

尝试以独占模式获取。

tryAcquire(int) - Method in class java.util.concurrent. Semaphore

从这个信号量获取给定数量的许可证，只有在调用时全部可用。

tryAcquire(int, long, TimeUnit) - Method in class java.util.concurrent. Semaphore

从该信号量获取给定数量的许可证，如果在给定的等待时间内全部可用，并且当前线程尚未 interrupted 。

tryAcquire(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

尝试以独占模式获取。

tryAcquire(long, TimeUnit) - Method in class java.util.concurrent. Semaphore

如果在给定的等待时间内可用，并且当前线程尚未被 interrupted从该信号量获取许可证。

tryAcquireNanos(int, long) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。

tryAcquireNanos(long, long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。

tryAcquireShared(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

尝试以共享模式获取。

tryAcquireShared(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

尝试以共享模式获取。

tryAcquireSharedNanos(int, long) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。

tryAcquireSharedNanos(long, long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。

tryAdvance(Consumer<? super Double>) - Method in interface java.util. Spliterator.OfDouble

如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。

tryAdvance(Consumer<? super Integer>) - Method in interface java.util. Spliterator.OfInt

如果剩余的元素存在，执行给定的操作，返回true ; 否则返回false 。

tryAdvance(Consumer<? super Long>) - Method in interface java.util. Spliterator.OfLong

如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。

tryAdvance(Consumer<? super T>) - Method in interface java.util. Spliterator

如果剩余的元素存在，执行给定的操作，返回true ; 否则返回false 。

tryAdvance(DoubleConsumer) - Method in interface java.util. Spliterator.OfDouble

tryAdvance(IntConsumer) - Method in interface java.util. Spliterator.OfInt

tryAdvance(LongConsumer) - Method in interface java.util. Spliterator.OfLong

tryAdvance(T_CONS) - Method in interface java.util. Spliterator.OfPrimitive

如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。

tryComplete() - Method in class java.util.concurrent. CountedCompleter

如果挂起的计数不为零，则减去计数; 否则调用CountedCompleter.onCompletion(CountedCompleter) ，然后同样尝试完成此任务的完成，如果存在，否则将此任务标记为完成。

tryConvertToOptimisticRead(long) - Method in class java.util.concurrent.locks. StampedLock

如果锁定状态与给定的印记相匹配，则原子地，如果印记表示持有锁定，则释放它并返回观察印记。

tryConvertToReadLock(long) - Method in class java.util.concurrent.locks. StampedLock

如果锁定状态与给定的标记匹配，则原子地执行以下操作之一。

tryConvertToWriteLock(long) - Method in class java.util.concurrent.locks. StampedLock

如果锁定状态与给定的标记匹配，则原子地执行以下操作之一。

tryFinally(MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles

创建一个方法句柄，通过将其包装在一个 try-finally块中来适应 target方法句柄。

tryLock() - Method in class java.nio.channels. AsynchronousFileChannel

尝试获取此频道文件的排他锁。

tryLock() - Method in class java.nio.channels. FileChannel

尝试获取此频道文件的排他锁。

tryLock() - Method in interface java.util.concurrent.locks. Lock

只有在调用时才可以获得锁。

tryLock() - Method in class java.util.concurrent.locks. ReentrantLock

只有在调用时它不被另一个线程占用才能获取锁。

tryLock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock

只有在调用时写锁定不被其他线程占用才能获取读锁。

tryLock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock

只有在调用时没有被另一个线程占用才能获取写入锁。

tryLock(long, long, boolean) - Method in class java.nio.channels. AsynchronousFileChannel

尝试获取此通道文件的给定区域的锁定。

tryLock(long, long, boolean) - Method in class java.nio.channels. FileChannel

尝试获取此通道文件的给定区域的锁定。

tryLock(long, TimeUnit) - Method in interface java.util.concurrent.locks. Lock

如果在给定的等待时间内是空闲的，并且当前线程尚未被 interrupted获取该锁。

tryLock(long, TimeUnit) - Method in class java.util.concurrent.locks. ReentrantLock

如果在给定的等待时间内没有被另一个线程 占用 ，并且当前线程尚未被 interrupted获取该锁。

tryLock(long, TimeUnit) - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock

如果写锁定在给定等待时间内未被另一个线程 占用 ，并且当前线程尚未被 interrupted，则获取读取锁定。

tryLock(long, TimeUnit) - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock

如果在给定的等待时间内未被另一个线程 占用 ，并且当前线程尚未被 interrupted获取写入锁定。

tryOptimisticRead() - Method in class java.util.concurrent.locks. StampedLock

返回可以稍后验证的印记，如果专门锁定则返回零。

tryReadLock() - Method in class java.util.concurrent.locks. StampedLock

非专门获取锁，如果它立即可用。

tryReadLock(long, TimeUnit) - Method in class java.util.concurrent.locks. StampedLock

如果在给定时间内可用，并且当前线程未被中断，则非排他性地获取锁。

tryRelease(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

尝试设置状态以独占模式反映释放。

tryRelease(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

尝试设置状态以独占模式反映释放。

tryReleaseShared(int) - Method in class java.util.concurrent.locks. AbstractQueuedSynchronizer

尝试将状态设置为以共享模式反映发布。

tryReleaseShared(long) - Method in class java.util.concurrent.locks. AbstractQueuedLongSynchronizer

尝试将状态设置为以共享模式反映发布。

trySetAccessible() - Method in class java.lang.reflect. AccessibleObject

设置 accessible标志这反映了反对 true如果可能的话。

trySplit() - Method in interface java.util. Spliterator.OfDouble

trySplit() - Method in interface java.util. Spliterator.OfInt

trySplit() - Method in interface java.util. Spliterator.OfLong

trySplit() - Method in interface java.util. Spliterator.OfPrimitive

trySplit() - Method in interface java.util. Spliterator

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

trySplit() - Method in class java.util. Spliterators.AbstractDoubleSpliterator

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

trySplit() - Method in class java.util. Spliterators.AbstractIntSpliterator

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

trySplit() - Method in class java.util. Spliterators.AbstractLongSpliterator

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

trySplit() - Method in class java.util. Spliterators.AbstractSpliterator

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

tryToLoadClass(String, ClassLoader) - Static method in class java.awt.datatransfer. DataFlavor

尝试加载一个类：引导加载程序，系统加载程序，上下文加载程序（如果存在），最后指定加载程序。

tryTransfer(E) - Method in class java.util.concurrent. LinkedTransferQueue

如果可能的话，将元件立即转移给等待的消费者。

tryTransfer(E) - Method in interface java.util.concurrent. TransferQueue

如果可能的话，将元件立即转移给等待的消费者。

tryTransfer(E, long, TimeUnit) - Method in class java.util.concurrent. LinkedTransferQueue

如果可以在超时过程之前将元素传送给消费者。

tryTransfer(E, long, TimeUnit) - Method in interface java.util.concurrent. TransferQueue

如果可以在超时过程之前将元素传送给消费者。

TryTree - Interface in com.sun.source.tree

一个用于 try语句的树节点。

TryTree - Interface in jdk.nashorn.api.tree

“try”语句的树结点。

tryUnfork() - Method in class java.util.concurrent. ForkJoinTask

尝试取消执行此任务。

tryUnlockRead() - Method in class java.util.concurrent.locks. StampedLock

释放读锁定的一个保持位，如果保持，而不需要戳记值。

tryUnlockWrite() - Method in class java.util.concurrent.locks. StampedLock

释放写入锁定，如果被保留，而不需要标记值。

tryWriteLock() - Method in class java.util.concurrent.locks. StampedLock

专门获取锁，如果它立即可用。

tryWriteLock(long, TimeUnit) - Method in class java.util.concurrent.locks. StampedLock

如果在给定时间内可用，并且当前线程未被中断，则专门获取该锁。

tsa(URI) - Method in class jdk.security.jarsigner. JarSigner.Builder

设置时间戳局（TSA）的URI。

TT - Static variable in class javax.swing.text.html. HTML.Tag

标签<tt>

TT_EOF - Static variable in class java.io. StreamTokenizer

指示流的末尾已被读取的常量。

TT_EOL - Static variable in class java.io. StreamTokenizer

一个常量，指示行的末尾已被读取。

TT_NUMBER - Static variable in class java.io. StreamTokenizer

指示已读取数字令牌的常量。

TT_WORD - Static variable in class java.io. StreamTokenizer

一个表示已经读取了单词标记的常量。

TTL_DONT_CACHE - Static variable in class java.util. ResourceBundle.Control

不缓存加载的资源束实例的生存时间常数。

TTL_NO_EXPIRATION_CONTROL - Static variable in class java.util. ResourceBundle.Control

用于禁用高速缓存中加载的资源束实例的到期控制的生存时间常数。

ttype - Variable in class java.io. StreamTokenizer

在调用 nextToken方法后，此字段包含刚刚读取的令牌的类型。

TUESDAY - java.time. DayOfWeek

星期二星期几的单身人士例子。

TUESDAY - Static variable in class java.util. Calendar

价值 Calendar.DAY_OF_WEEK字段表示星期二。

TUMBLE - javafx.print. PrintSides

双面打印，纸张的水平边缘将用于装订，如记事本。

TUMBLE - Static variable in class javax.print.attribute.standard. Sides

“双面短边”的别名（见 TWO_SIDED_SHORT_EDGE ）。

TUNE_REQUEST - Static variable in class javax.sound.midi. ShortMessage

Tune请求消息的状态字节（0xF6或246）。

TURN - javafx.css. SizeUnits

TURQUOISE - Static variable in class javafx.scene.paint. Color

颜色绿松石，RGB值为＃40E0D0

TWO - Static variable in class java.math. BigInteger

BigInteger常数二。

TWO_LEVEL_FOCUS - javafx.application. ConditionalFeature

指示控件是否应使用两级焦点。

TWO_PASS_BOX - javafx.scene.effect. BlurType

盒式过滤器的两次通过用于模糊阴影以获得稍微平滑的效果。

TWO_SIDED_LONG_EDGE - Static variable in class java.awt. JobAttributes.SidesType

用于指定连续作业页面的 SidesType实例应打印在连续介质页的前侧和后侧，以便介质上每对页面的方向对于读取器来说将是正确的，就像在长边上进行装订。

TWO_SIDED_LONG_EDGE - Static variable in class javax.print.attribute.standard. Sides

将连续的打印流页面的每个连续的一对打印页面设置在连续的介质纸张的前侧和后面，使得介质上的每对打印流页面的取向对于读取器将是正确的，如同在长边缘上的装订一样。

TWO_SIDED_SHORT_EDGE - Static variable in class java.awt. JobAttributes.SidesType

用于指定连续作业页面的 SidesType实例应该打印在连续介质页的前侧和后侧，以便介质上每对页面的方向对于读取器来说将是正确的，就像在短边装订一样。

TWO_SIDED_SHORT_EDGE - Static variable in class javax.print.attribute.standard. Sides

将连续的打印流页面的每个连续的一对打印页面设置在连续介质页的前侧和后侧，使得介质上的每对打印流页面的方向对于读取器将是正确的，如同用于在短边缘上装订一样。

txProperty() - Method in class javafx.scene.transform. Affine

定义3x4矩阵的X坐标转换元素。

type - Variable in class javax.naming.event. NamingEvent

包含此事件的类型。

type - Variable in class javax.sound.midi. MidiFileFormat

MIDI文件的类型。

type - Variable in class javax.swing.event. TableModelEvent

事件的类型。

type - Variable in class javax.swing. JTable.AccessibleJTable.AccessibleJTableModelChange

方式

type - Variable in class javax.swing.text.html.parser. AttributeList

属性类型

type - Variable in class javax.swing.text.html.parser. ContentModel

类型。

type - Variable in class javax.swing.text.html.parser. Element

元素类型

type - Variable in class javax.swing.text.html.parser. Entity

实体的类型。

type - Variable in class org.omg.CORBA. StructMember

由该 StructMember对象描述的结构体成员的类型。

type - Variable in class org.omg.CORBA. UnionMember

由该 UnionMember对象描述的联盟成员的类型。

type - Variable in class org.omg.CORBA. ValueMember

该类型的 value会员。

type() - Method in interface com.sun.javadoc. FieldDoc

已过时。

获取此字段的类型。

type() - Method in interface com.sun.javadoc. Parameter

已过时。

获取此参数的类型。

type() - Method in interface com.sun.jdi. Field

返回此字段的类型。

type() - Method in interface com.sun.jdi. LocalVariable

返回此变量的类型。

type() - Method in interface com.sun.jdi. Value

返回此值的运行时类型。

type() - Method in class com.sun.tools.attach.spi. AttachProvider

返回此提供商的类型。

type() - Method in class java.lang.invoke. CallSite

返回此呼叫站点目标的类型。

type() - Method in class java.lang.invoke. MethodHandle

报告此方法句柄的类型。

type() - Method in class java.lang. ProcessBuilder.Redirect

返回此 Redirect的类型。

type() - Method in class java.net. Proxy

返回代理类型。

type() - Method in interface java.net. SocketOption

返回套接字选项值的类型。

type() - Method in class java.nio.file.attribute. AclEntry

返回ACL条目类型。

type() - Method in class java.nio.file. FileStore

返回此文件存储的 类型 。

type() - Method in interface java.nio.file. WatchEvent.Kind

返回 context的值的类型。

type() - Method in interface java.util. ServiceLoader.Provider

返回提供者类型。

type() - Method in interface javax.xml.xpath. XPathEvaluationResult

将结果类型作为由 XPathResultType指定的枚举 XPathResultType

type() - Method in class org.omg.CORBA. _IDLTypeStub

type() - Method in class org.omg.CORBA. Any

返回此 Any对象中包含的元素的类型信息。

type() - Static method in class org.omg.CORBA. AnySeqHelper

type() - Static method in class org.omg.CORBA. BooleanSeqHelper

type() - Static method in class org.omg.CORBA. BoundsHelper

type() - Static method in class org.omg.CORBA. CharSeqHelper

type() - Static method in class org.omg.CORBA. CompletionStatusHelper

type() - Static method in class org.omg.CORBA. CurrentHelper

type() - Static method in class org.omg.CORBA. DefinitionKindHelper

type() - Static method in class org.omg.CORBA. DoubleSeqHelper

type() - Method in interface org.omg.CORBA. DynAny

已过时。

返回 TypeCode的对象插入到这个 DynAny 。

type() - Static method in class org.omg.CORBA. FieldNameHelper

type() - Static method in class org.omg.CORBA. FloatSeqHelper

type() - Static method in class org.omg.CORBA. IdentifierHelper

type() - Static method in class org.omg.CORBA. IDLTypeHelper

type() - Method in interface org.omg.CORBA. IDLTypeOperations

type属性描述由从 IDLType派生的对象定义的类型。

type() - Static method in class org.omg.CORBA. LongLongSeqHelper

type() - Static method in class org.omg.CORBA. LongSeqHelper

type() - Static method in class org.omg.CORBA. NameValuePairHelper

type() - Static method in class org.omg.CORBA. ObjectHelper

type() - Static method in class org.omg.CORBA. OctetSeqHelper

type() - Static method in class org.omg.CORBA.ORBPackage. InvalidNameHelper

type() - Static method in class org.omg.CORBA. ParameterModeHelper

type() - Static method in class org.omg.CORBA. PolicyErrorCodeHelper

type() - Static method in class org.omg.CORBA. PolicyErrorHelper

type() - Static method in class org.omg.CORBA. PolicyHelper

type() - Static method in class org.omg.CORBA. PolicyListHelper

type() - Static method in class org.omg.CORBA. PolicyTypeHelper

type() - Static method in class org.omg.CORBA. RepositoryIdHelper

type() - Static method in class org.omg.CORBA. ServiceDetailHelper

type() - Static method in class org.omg.CORBA. ServiceInformationHelper

type() - Static method in class org.omg.CORBA. SetOverrideTypeHelper

type() - Static method in class org.omg.CORBA. ShortSeqHelper

type() - Static method in class org.omg.CORBA. StringSeqHelper

type() - Static method in class org.omg.CORBA. StringValueHelper

type() - Static method in class org.omg.CORBA. StructMemberHelper

type() - Static method in class org.omg.CORBA.TypeCodePackage. BadKindHelper

type() - Static method in class org.omg.CORBA.TypeCodePackage. BoundsHelper

type() - Static method in class org.omg.CORBA. ULongLongSeqHelper

type() - Static method in class org.omg.CORBA. ULongSeqHelper

type() - Static method in class org.omg.CORBA. UnionMemberHelper

type() - Static method in class org.omg.CORBA. UnknownUserExceptionHelper

type() - Static method in class org.omg.CORBA. UShortSeqHelper

type() - Static method in class org.omg.CORBA. ValueBaseHelper

type() - Static method in class org.omg.CORBA. ValueMemberHelper

type() - Static method in class org.omg.CORBA. VersionSpecHelper

type() - Static method in class org.omg.CORBA. VisibilityHelper

type() - Static method in class org.omg.CORBA. WCharSeqHelper

type() - Static method in class org.omg.CORBA. WrongTransactionHelper

type() - Static method in class org.omg.CORBA. WStringSeqHelper

type() - Static method in class org.omg.CORBA. WStringValueHelper

type() - Static method in class org.omg.CosNaming. BindingHelper

type() - Static method in class org.omg.CosNaming. BindingIteratorHelper

type() - Static method in class org.omg.CosNaming. BindingListHelper

type() - Static method in class org.omg.CosNaming. BindingTypeHelper

type() - Static method in class org.omg.CosNaming. IstringHelper

type() - Static method in class org.omg.CosNaming. NameComponentHelper

type() - Static method in class org.omg.CosNaming. NameHelper

type() - Static method in class org.omg.CosNaming. NamingContextExtHelper

type() - Static method in class org.omg.CosNaming.NamingContextExtPackage. AddressHelper

type() - Static method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHelper

type() - Static method in class org.omg.CosNaming.NamingContextExtPackage. StringNameHelper

type() - Static method in class org.omg.CosNaming.NamingContextExtPackage. URLStringHelper

type() - Static method in class org.omg.CosNaming. NamingContextHelper

type() - Static method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHelper

type() - Static method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHelper

type() - Static method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHelper

type() - Static method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHelper

type() - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundHelper

type() - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHelper

type() - Method in class org.omg.DynamicAny. _DynAnyStub

返回与此DynAny对象关联的TypeCode。

type() - Method in class org.omg.DynamicAny. _DynArrayStub

返回与此DynAny对象关联的TypeCode。

type() - Method in class org.omg.DynamicAny. _DynEnumStub

返回与此DynAny对象关联的TypeCode。

type() - Method in class org.omg.DynamicAny. _DynFixedStub

返回与此DynAny对象关联的TypeCode。

type() - Method in class org.omg.DynamicAny. _DynSequenceStub

返回与此DynAny对象关联的TypeCode。

type() - Method in class org.omg.DynamicAny. _DynStructStub

返回与此DynAny对象关联的TypeCode。

type() - Method in class org.omg.DynamicAny. _DynUnionStub

返回与此DynAny对象关联的TypeCode。

type() - Method in class org.omg.DynamicAny. _DynValueStub

返回与此DynAny对象关联的TypeCode。

type() - Static method in class org.omg.DynamicAny. AnySeqHelper

type() - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper

type() - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCodeHelper

type() - Static method in class org.omg.DynamicAny. DynAnyHelper

type() - Method in interface org.omg.DynamicAny. DynAnyOperations

返回与此DynAny对象关联的TypeCode。

type() - Static method in class org.omg.DynamicAny.DynAnyPackage. InvalidValueHelper

type() - Static method in class org.omg.DynamicAny.DynAnyPackage. TypeMismatchHelper

type() - Static method in class org.omg.DynamicAny. DynAnySeqHelper

type() - Static method in class org.omg.DynamicAny. DynArrayHelper

type() - Static method in class org.omg.DynamicAny. DynEnumHelper

type() - Static method in class org.omg.DynamicAny. DynFixedHelper

type() - Static method in class org.omg.DynamicAny. DynSequenceHelper

type() - Static method in class org.omg.DynamicAny. DynStructHelper

type() - Static method in class org.omg.DynamicAny. DynUnionHelper

type() - Static method in class org.omg.DynamicAny. DynValueHelper

type() - Static method in class org.omg.DynamicAny. FieldNameHelper

type() - Static method in class org.omg.DynamicAny. NameDynAnyPairHelper

type() - Static method in class org.omg.DynamicAny. NameDynAnyPairSeqHelper

type() - Static method in class org.omg.DynamicAny. NameValuePairHelper

type() - Static method in class org.omg.DynamicAny. NameValuePairSeqHelper

type() - Static method in class org.omg.IOP. CodecFactoryHelper

type() - Static method in class org.omg.IOP.CodecFactoryPackage. UnknownEncodingHelper

type() - Static method in class org.omg.IOP.CodecPackage. FormatMismatchHelper

type() - Static method in class org.omg.IOP.CodecPackage. InvalidTypeForEncodingHelper

type() - Static method in class org.omg.IOP.CodecPackage. TypeMismatchHelper

type() - Static method in class org.omg.IOP. ComponentIdHelper

type() - Static method in class org.omg.IOP. IORHelper

type() - Static method in class org.omg.IOP. MultipleComponentProfileHelper

type() - Static method in class org.omg.IOP. ProfileIdHelper

type() - Static method in class org.omg.IOP. ServiceContextHelper

type() - Static method in class org.omg.IOP. ServiceContextListHelper

type() - Static method in class org.omg.IOP. ServiceIdHelper

type() - Static method in class org.omg.IOP. TaggedComponentHelper

type() - Static method in class org.omg.IOP. TaggedProfileHelper

type() - Static method in class org.omg.Messaging. SyncScopeHelper

type() - Static method in class org.omg.PortableInterceptor. AdapterManagerIdHelper

type() - Static method in class org.omg.PortableInterceptor. AdapterNameHelper

type() - Static method in class org.omg.PortableInterceptor. AdapterStateHelper

type() - Static method in class org.omg.PortableInterceptor. CurrentHelper

type() - Static method in class org.omg.PortableInterceptor. ForwardRequestHelper

type() - Static method in class org.omg.PortableInterceptor. InvalidSlotHelper

type() - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper

type() - Static method in class org.omg.PortableInterceptor. ObjectIdHelper

type() - Static method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHelper

type() - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHelper

type() - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHelper

type() - Static method in class org.omg.PortableInterceptor. ORBIdHelper

type() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateNameHelper

type() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidNameHelper

type() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. ObjectIdHelper

type() - Static method in class org.omg.PortableInterceptor. ServerIdHelper

type() - Static method in class org.omg.PortableServer. CurrentHelper

type() - Static method in class org.omg.PortableServer.CurrentPackage. NoContextHelper

type() - Static method in class org.omg.PortableServer. ForwardRequestHelper

type() - Static method in class org.omg.PortableServer. POAHelper

type() - Static method in class org.omg.PortableServer.POAManagerPackage. AdapterInactiveHelper

type() - Static method in class org.omg.PortableServer.POAPackage. AdapterAlreadyExistsHelper

type() - Static method in class org.omg.PortableServer.POAPackage. AdapterNonExistentHelper

type() - Static method in class org.omg.PortableServer.POAPackage. InvalidPolicyHelper

type() - Static method in class org.omg.PortableServer.POAPackage. NoServantHelper

type() - Static method in class org.omg.PortableServer.POAPackage. ObjectAlreadyActiveHelper

type() - Static method in class org.omg.PortableServer.POAPackage. ObjectNotActiveHelper

type() - Static method in class org.omg.PortableServer.POAPackage. ServantAlreadyActiveHelper

type() - Static method in class org.omg.PortableServer.POAPackage. ServantNotActiveHelper

type() - Static method in class org.omg.PortableServer.POAPackage. WrongAdapterHelper

type() - Static method in class org.omg.PortableServer.POAPackage. WrongPolicyHelper

type() - Static method in class org.omg.PortableServer. ServantActivatorHelper

type() - Static method in class org.omg.PortableServer. ServantLocatorHelper

type(TypeCode) - Method in class org.omg.CORBA. Any

将此 Any对象的 type字段设置为给定的 TypeCode对象，并清除其值。

Type - Interface in com.sun.javadoc

已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

Type - Interface in com.sun.jdi

目标VM中类型的镜像。

Type - Interface in java.lang.reflect

Type是Java编程语言中所有类型的通用超级接口。

Type(String) - Constructor for class javax.sound.sampled. BooleanControl.Type

构造一个新的布尔控件类型。

Type(String) - Constructor for class javax.sound.sampled. CompoundControl.Type

构建新的复合控制类型。

Type(String) - Constructor for class javax.sound.sampled. Control.Type

构造具有指定名称的新控件类型。

Type(String) - Constructor for class javax.sound.sampled. EnumControl.Type

构造一个新的枚举控件类型。

Type(String) - Constructor for class javax.sound.sampled. FloatControl.Type

构造一个新的浮动控件类型。

Type(String) - Constructor for class javax.sound.sampled. LineEvent.Type

构造一个新的事件类型。

Type(String, String) - Constructor for class javax.sound.sampled. AudioFileFormat.Type

构造文件类型。

TYPE - java.lang.annotation. ElementType

类，接口（包括注释类型）或枚举声明

TYPE - jdk.javadoc.doclet. Taglet.Location

在类，界面或枚举的文档中。

TYPE - Static variable in class java.lang. Boolean

表示原始类型的类对象布尔值。

TYPE - Static variable in class java.lang. Byte

Class实例代表原始类型 byte 。

TYPE - Static variable in class java.lang. Character

Class实例代表原始类型 char 。

TYPE - Static variable in class java.lang. Double

Class实例代表原始类型 double 。

TYPE - Static variable in class java.lang. Float

Class表示原始类型 float实例。

TYPE - Static variable in class java.lang. Integer

表示 int原始类型的 Class实例。

TYPE - Static variable in class java.lang. Long

所述 Class实例表示基本类型 long 。

TYPE - Static variable in class java.lang. Short

所述 Class实例表示基本类型 short 。

TYPE - Static variable in class java.lang. Void

Class对象表示对应于关键字 void的伪类型。

TYPE - Static variable in class javax.swing.text.html. HTML.Attribute

属性“类型”

TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo. PGPData

标识PGPData KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#PGPData。

TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo. X509Data

标识X509Data KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#X509Data。

TYPE - Static variable in interface javax.xml.crypto.dsig. Manifest

标识Manifest元素的URI（可以指定为Reference类的type参数的值，以确定指示物的类型）。

TYPE - Static variable in interface javax.xml.crypto.dsig. SignatureProperties

标识SignatureProperties元素的URI（可以指定为Reference类的type参数的值，以标识指示物的类型）。

TYPE - Static variable in interface javax.xml.crypto.dsig. XMLObject

标识Object元素的URI（可以指定为Reference类的type参数的值，以确定指示物的类型）。

TYPE_1_BETTER - jdk.dynalink.linker. ConversionComparator.Comparison

第一次转换比第二次更好。

TYPE_2_BETTER - jdk.dynalink.linker. ConversionComparator.Comparison

第二次转换比第一次更好。

TYPE_2CLR - Static variable in class java.awt.color. ColorSpace

通用2分量颜色空间。

TYPE_3BYTE_BGR - Static variable in class java.awt.image. BufferedImage

表示具有8位RGB颜色分量的图像，对应于Windows风格的BGR颜色模型），蓝色，绿色和红色以3个字节存储。

TYPE_3CLR - Static variable in class java.awt.color. ColorSpace

通用3组件颜色空间。

TYPE_4BYTE_ABGR - Static variable in class java.awt.image. BufferedImage

表示具有蓝色，绿色和红色的8位RGBA颜色分量的图像，存储在3个字节和1个字节的alpha中。

TYPE_4BYTE_ABGR_PRE - Static variable in class java.awt.image. BufferedImage

表示具有蓝色，绿色和红色的8位RGBA颜色分量的图像，存储在3个字节和1个字节的alpha中。

TYPE_4CLR - Static variable in class java.awt.color. ColorSpace

通用4组分颜色空间。

TYPE_5CLR - Static variable in class java.awt.color. ColorSpace

通用5组件颜色空间。

TYPE_6CLR - Static variable in class java.awt.color. ColorSpace

通用6组件颜色空间。

TYPE_7CLR - Static variable in class java.awt.color. ColorSpace

通用7组件颜色空间。

TYPE_8CLR - Static variable in class java.awt.color. ColorSpace

通用8分量颜色空间。

TYPE_9CLR - Static variable in class java.awt.color. ColorSpace

通用9组件颜色空间。

TYPE_ACLR - Static variable in class java.awt.color. ColorSpace

通用10组分色彩空间。

TYPE_ANNOTATION - com.sun.source.tree. Tree.Kind

用于表示类型注释的AnnotationTree的实例。

TYPE_BCLR - Static variable in class java.awt.color. ColorSpace

通用11组件颜色空间。

TYPE_BICUBIC - Static variable in class java.awt.image. AffineTransformOp

双三次插补类型。

TYPE_BILINEAR - Static variable in class java.awt.image. AffineTransformOp

双线性插值类型。

TYPE_BYTE - Static variable in class java.awt.image. DataBuffer

标记无符号字节数据。

TYPE_BYTE_BINARY - Static variable in class java.awt.image. BufferedImage

表示不透明的字节打包的1,2或4位图像。

TYPE_BYTE_GRAY - Static variable in class java.awt.image. BufferedImage

表示无符号字节灰度图像，无索引。

TYPE_BYTE_INDEXED - Static variable in class java.awt.image. BufferedImage

表示索引的字节图像。

TYPE_CAST - com.sun.source.tree. Tree.Kind

用于TypeCastTree的实例。

TYPE_CCLR - Static variable in class java.awt.color. ColorSpace

通用12组件颜色空间。

TYPE_CMY - Static variable in class java.awt.color. ColorSpace

任何一个家庭的CMY色彩空间。

TYPE_CMYK - Static variable in class java.awt.color. ColorSpace

任何一个CMYK色彩空间的家庭。

TYPE_CUSTOM - Static variable in class java.awt.image. BufferedImage

图像类型无法识别，因此它必须是自定义图像。

TYPE_DCLR - Static variable in class java.awt.color. ColorSpace

通用13组件颜色空间。

TYPE_DECL - jdk.jshell. Snippet.Kind

类型声明。

type_def - Variable in class org.omg.CORBA. StructMember

typedef表示由此 StructMember对象描述的结构成员的IDL类型。

type_def - Variable in class org.omg.CORBA. UnionMember

表示此 UnionMember对象描述的联盟成员的IDL类型的typedef。

type_def - Variable in class org.omg.CORBA. ValueMember

表示此 ValueMember对象描述的 value成员的IDL类型的typedef。

TYPE_DOUBLE - Static variable in class java.awt.image. DataBuffer

标记为双数据。

TYPE_ECLR - Static variable in class java.awt.color. ColorSpace

通用14组件颜色空间。

TYPE_ERR - Static variable in exception org.w3c.dom.xpath. XPathException

如果表达式无法转换返回指定的类型。

TYPE_FCLR - Static variable in class java.awt.color. ColorSpace

通用15组件颜色空间。

TYPE_FLIP - Static variable in class java.awt.geom. AffineTransform

该标志位指示由该对象定义的变换除了由其他标志位指示的转换之外还执行关于某个轴的镜像翻转，该轴将常规右手坐标系改变为左手系统。

TYPE_FLOAT - Static variable in class java.awt.image. DataBuffer

标签浮点数据。

TYPE_FORWARD_ONLY - Static variable in interface java.sql. ResultSet

指示其光标可以向前移动的 ResultSet对象的类型的常量。

TYPE_GENERAL_ROTATION - Static variable in class java.awt.geom. AffineTransform

该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行任意角度的旋转。

TYPE_GENERAL_SCALE - Static variable in class java.awt.geom. AffineTransform

该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行一般尺度。

TYPE_GENERAL_TRANSFORM - Static variable in class java.awt.geom. AffineTransform

该常数表示由该对象定义的变换执行输入坐标的任意转换。

TYPE_GRAY - Static variable in class java.awt.color. ColorSpace

任何一个灰色家庭的颜色空间。

TYPE_HLS - Static variable in class java.awt.color. ColorSpace

任何家庭的HLS颜色空间。

TYPE_HSV - Static variable in class java.awt.color. ColorSpace

任何家庭的HSV色彩空间。

type_id - Variable in class org.omg.IOP. IOR

类型id，表示为字符串。

TYPE_IDENTITY - Static variable in class java.awt.geom. AffineTransform

该常数表示由该对象定义的变换是一个身份变换。

TYPE_IMAGE_BUFFER - Static variable in class java.awt. GraphicsDevice

设备是一个图像缓冲区。

TYPE_IMPORT_ON_DEMAND_SUBKIND - jdk.jshell. Snippet.SubKind

Type-Import-on-Demand宣言。

TYPE_INT - Static variable in class java.awt.image. DataBuffer

标签为int数据。

TYPE_INT_ARGB - Static variable in class java.awt.image. BufferedImage

表示具有8位RGBA颜色成分的整数像素的图像。

TYPE_INT_ARGB_PRE - Static variable in class java.awt.image. BufferedImage

表示具有8位RGBA颜色成分的整数像素的图像。

TYPE_INT_BGR - Static variable in class java.awt.image. BufferedImage

表示具有8位RGB颜色分量的图像，对应于Windows或Solaris样式的BGR颜色模型，蓝色，绿色和红色颜色打包成整数像素。

TYPE_INT_RGB - Static variable in class java.awt.image. BufferedImage

表示具有8位RGB颜色分量的整数像素的图像。

TYPE_Lab - Static variable in class java.awt.color. ColorSpace

任何一个Lab颜色空间的家庭。

TYPE_Luv - Static variable in class java.awt.color. ColorSpace

任何Luv色彩空间的家庭。

TYPE_MASK_ROTATION - Static variable in class java.awt.geom. AffineTransform

该常数是任何旋转标志位的位掩码。

TYPE_MASK_SCALE - Static variable in class java.awt.geom. AffineTransform

该常数是任何刻度标志位的位掩码。

TYPE_MISMATCH_ERR - Static variable in exception org.w3c.dom. DOMException

如果对象的类型与与对象关联的参数的预期类型不兼容。

type_modifier() - Method in class org.omg.CORBA. TypeCode

返回一个常量，表示此 TypeCode对象描述的值类型的修饰符。

TYPE_NEAREST_NEIGHBOR - Static variable in class java.awt.image. AffineTransformOp

最近邻插值类型。

TYPE_PARAMETER - com.sun.source.tree. Tree.Kind

用于TypeParameterTree的实例。

TYPE_PARAMETER - java.lang.annotation. ElementType

键入参数声明

TYPE_PARAMETER - javax.lang.model.element. ElementKind

一个类型参数。

TYPE_PRINTER - Static variable in class java.awt. GraphicsDevice

设备是打印机。

TYPE_QUADRANT_ROTATION - Static variable in class java.awt.geom. AffineTransform

该标志位表示除了由其他标志位指示的转换之外，由该对象定义的变换执行了90度的几倍的象限旋转。

TYPE_RASTER_SCREEN - Static variable in class java.awt. GraphicsDevice

设备是光栅画面。

TYPE_RGB - Static variable in class java.awt.color. ColorSpace

任何RGB色彩空间的家庭。

TYPE_SCROLL_INSENSITIVE - Static variable in interface java.sql. ResultSet

该常量指示 ResultSet对象的类型，该对象是可滚动的，但通常不会对基于 ResultSet的数据的更改敏感。

TYPE_SCROLL_SENSITIVE - Static variable in interface java.sql. ResultSet

该常量指示可滚动的 ResultSet对象的类型，并且对 ResultSet基础的数据的更改通常很敏感。

TYPE_SHORT - Static variable in class java.awt.image. DataBuffer

标记签名的短数据。

TYPE_TRANSLATION - Static variable in class java.awt.geom. AffineTransform

该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行转换。

TYPE_UNDEFINED - Static variable in class java.awt.image. DataBuffer

标记未定义的数据。

TYPE_UNIFORM_SCALE - Static variable in class java.awt.geom. AffineTransform

该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行统一的标度。

TYPE_USE - java.lang.annotation. ElementType

使用类型

TYPE_USHORT - Static variable in class java.awt.image. DataBuffer

无符号短数据标签。

TYPE_USHORT_555_RGB - Static variable in class java.awt.image. BufferedImage

表示5-5-5 RGB颜色分量（5位红色，5位绿色，5位蓝色）的图像，无alpha。

TYPE_USHORT_565_RGB - Static variable in class java.awt.image. BufferedImage

表示具有5-6-5 RGB颜色分量（5位红色，6位绿色，5位蓝色），无alpha的图像。

TYPE_USHORT_GRAY - Static variable in class java.awt.image. BufferedImage

表示无符号短灰度图像，非索引）。

TYPE_XYZ - Static variable in class java.awt.color. ColorSpace

任何家庭的XYZ色彩空间。

TYPE_YCbCr - Static variable in class java.awt.color. ColorSpace

任何YCbCr色彩空间的家庭。

TYPE_Yxy - Static variable in class java.awt.color. ColorSpace

任何家庭的Yxy颜色空间。

TYPE1_FONT - Static variable in class java.awt. Font

识别类型TYPE1的字体资源。

type2DProperty() - Method in class javafx.scene.transform. Transform

确定这是否是2D变换。

type2name(int) - Static method in class javax.swing.text.html.parser. AttributeList

将类型转换为属性名称

typeArguments() - Method in interface com.sun.javadoc. ParameterizedType

已过时。

返回此类型的实际类型参数。

TypeBasedGuardingDynamicLinker - Interface in jdk.dynalink.linker

一个保护动态链接器，可以确定是否可以根据链接调用时间的第一个参数的类型单独链接调用站点。

TypeCastTree - Interface in com.sun.source.tree

类型转换表达式的树节点。

TypeCode - Class in org.omg.CORBA

有关特定CORBA数据类型的信息的容器。

TypeCode() - Constructor for class org.omg.CORBA. TypeCode

TypeCodeHolder - Class in org.omg.CORBA

持有人 TypeCode 。

TypeCodeHolder() - Constructor for class org.omg.CORBA. TypeCodeHolder

构造一个新的 TypeCodeHolder对象，其 value字段初始化为 null 。

TypeCodeHolder(TypeCode) - Constructor for class org.omg.CORBA. TypeCodeHolder

构造一个新的 TypeCodeHolder对象，其 value字段初始化为给定的 TypeCode对象。

TypeComponent - Interface in com.sun.jdi

在用户定义的类型（类或接口）内声明的实体。

TypeConstraintException - Exception in javax.xml.bind

此异常表示检测到违反动态检查的类型约束。

TypeConstraintException(String) - Constructor for exception javax.xml.bind. TypeConstraintException

使用指定的详细消息构造TypeConstraintException。

TypeConstraintException(String, String) - Constructor for exception javax.xml.bind. TypeConstraintException

构造具有指定的详细消息和供应商特定的错误代码的TypeConstraintException。

TypeConstraintException(String, String, Throwable) - Constructor for exception javax.xml.bind. TypeConstraintException

构造具有指定的详细消息，供应商特定的错误代码和linkedException的TypeConstraintException。

TypeConstraintException(String, Throwable) - Constructor for exception javax.xml.bind. TypeConstraintException

使用指定的详细消息和linkedException构造TypeConstraintException。

TypeConstraintException(Throwable) - Constructor for exception javax.xml.bind. TypeConstraintException

构造一个带有LinkedException的TypeConstraintException。

TypeDeclSnippet - Class in jdk.jshell

类型定义的代码段（类，接口，枚举或注释接口定义）。

TypeElement - Interface in javax.lang.model.element

表示一个类或接口程序元素。

TypeInfo - Interface in org.w3c.dom

TypeInfo接口表示从与文档关联的模式中指定的 Element或 Attr节点引用的类型。

TypeInfoProvider - Class in javax.xml.validation

该类提供对由ValidatorHandler确定的类型信息的访问 。

TypeInfoProvider() - Constructor for class javax.xml.validation. TypeInfoProvider

派生类的构造方法

TypeKind - Enum in javax.lang.model.type

一种类型的镜子。

TypeKindVisitor6< R, P> - Class in javax.lang.model.util

基于他们的kind类型的访问者的默认行为适合RELEASE_6源版本。

TypeKindVisitor6() - Constructor for class javax.lang.model.util. TypeKindVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

TypeKindVisitor6(R) - Constructor for class javax.lang.model.util. TypeKindVisitor6

已过时。
第6版已经过时了 更新到访问者较新的版本级别。

TypeKindVisitor7< R, P> - Class in javax.lang.model.util

基于他们的kind类型的访问者的默认行为适合RELEASE_7源版本。

TypeKindVisitor7() - Constructor for class javax.lang.model.util. TypeKindVisitor7

具体子类调用的构造方法 使用null作为默认值。

TypeKindVisitor7(R) - Constructor for class javax.lang.model.util. TypeKindVisitor7

具体子类调用的构造方法 使用参数作为默认值。

TypeKindVisitor8< R, P> - Class in javax.lang.model.util

基于他们的kind类型的访问者的默认行为适合RELEASE_8源版本。

TypeKindVisitor8() - Constructor for class javax.lang.model.util. TypeKindVisitor8

具体子类调用的构造方法 使用null作为默认值。

TypeKindVisitor8(R) - Constructor for class javax.lang.model.util. TypeKindVisitor8

具体子类调用的构造方法 使用参数作为默认值。

TypeKindVisitor9< R, P> - Class in javax.lang.model.util

基于他们的kind类型的访问者的默认行为适合RELEASE_9源版本。

TypeKindVisitor9() - Constructor for class javax.lang.model.util. TypeKindVisitor9

具体子类调用的构造方法 对于默认值使用null 。

TypeKindVisitor9(R) - Constructor for class javax.lang.model.util. TypeKindVisitor9

具体子类调用的构造方法 使用参数作为默认值。

TypeMirror - Interface in javax.lang.model.type

表示Java编程语言中的一种类型。

TypeMismatch - Exception in org.omg.CORBA.DynAnyPackage

当实际内容的类型与尝试访问的内容不匹配时，TypeMismatch将被动态的任何访问器方法抛出。

TypeMismatch - Exception in org.omg.DynamicAny.DynAnyPackage

org / omg / DynamicAny / DynAnyPackage / TypeMismatch.java。

TypeMismatch - Exception in org.omg.IOP.CodecPackage

org / omg / IOP / CodecPackage / TypeMismatch.java。

TypeMismatch() - Constructor for exception org.omg.CORBA.DynAnyPackage. TypeMismatch

构造一个 TypeMismatch对象。

TypeMismatch() - Constructor for exception org.omg.DynamicAny.DynAnyPackage. TypeMismatch

TypeMismatch() - Constructor for exception org.omg.IOP.CodecPackage. TypeMismatch

TypeMismatch(String) - Constructor for exception org.omg.CORBA.DynAnyPackage. TypeMismatch

构造一个 TypeMismatch对象。

TypeMismatch(String) - Constructor for exception org.omg.DynamicAny.DynAnyPackage. TypeMismatch

TypeMismatch(String) - Constructor for exception org.omg.IOP.CodecPackage. TypeMismatch

TypeMismatchHelper - Class in org.omg.DynamicAny.DynAnyPackage

org / omg / DynamicAny / DynAnyPackage / TypeMismatchHelper.java。

TypeMismatchHelper - Class in org.omg.IOP.CodecPackage

org / omg / IOP / CodecPackage / TypeMismatchHelper.java。

TypeMismatchHelper() - Constructor for class org.omg.DynamicAny.DynAnyPackage. TypeMismatchHelper

TypeMismatchHelper() - Constructor for class org.omg.IOP.CodecPackage. TypeMismatchHelper

typeName() - Method in interface com.sun.javadoc. Parameter

已过时。

获取此参数的类型名称。

typeName() - Method in interface com.sun.javadoc. Type

已过时。

返回类型的不合格的名称，不包括任何维度信息。

typeName() - Method in interface com.sun.jdi. Field

返回此字段类型的文本表示。

typeName() - Method in interface com.sun.jdi. LocalVariable

返回此变量类型的文本表示形式。

typeName() - Method in exception java.lang. TypeNotPresentException

返回不可用类型的完全限定名称。

typeName() - Method in class jdk.jshell. ExpressionSnippet

表达式的类型

typeName() - Method in class jdk.jshell. VarSnippet

变量类型的字符串表示形式。

typeNoNulls - Static variable in interface java.sql. DatabaseMetaData

表示此数据类型不允许使用 NULL值。

TypeNotPresentException - Exception in java.lang

当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。

TypeNotPresentException(String, Throwable) - Constructor for exception java.lang. TypeNotPresentException

构造具有指定原因的命名类型的 TypeNotPresentException 。

typeNullable - Static variable in interface java.sql. DatabaseMetaData

表示允许此数据类型的值为 NULL 。

typeNullableUnknown - Static variable in interface java.sql. DatabaseMetaData

表示不知道该数据类型是否允许 NULL值。

TYPEOF - jdk.nashorn.api.tree. Tree.Kind

用于实例UnaryTree代表逻辑typeof操作typeof 。

TypeParameterElement - Interface in javax.lang.model.element

表示通用类，接口，方法或构造函数元素的正式类型参数。

typeParameters() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回此类或接口的形式类型参数。

typeParameters() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

返回此方法或构造函数的形式类型参数。

TypeParameterTree - Interface in com.sun.source.tree

类型参数的树节点。

typeParamTags() - Method in interface com.sun.javadoc. ClassDoc

已过时。

返回此类或接口的类型参数标签。

typeParamTags() - Method in interface com.sun.javadoc. ExecutableMemberDoc

已过时。

在此方法中返回类型参数标签。

typePredBasic - Static variable in interface java.sql. DatabaseMetaData

表示数据类型只能在不使用 LIKE谓词的 WHERE搜索条款中使用。

typePredChar - Static variable in interface java.sql. DatabaseMetaData

表示数据类型只能在使用 LIKE谓词的 WHERE搜索条款中使用。

typePredNone - Static variable in interface java.sql. DatabaseMetaData

表示此类型不支持 WHERE搜索条款。

typeProperty() - Method in class javafx.scene.shape. Arc

定义闭合类型弧： ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND 。

types() - Method in class jdk.jshell. JShell

返回活动类型声明（类，接口，注释类型和枚举）片段。

Types - Class in java.sql

定义用于标识通用SQL类型的常量的类，称为JDBC类型。

Types - Interface in javax.lang.model.util

用于操作类型的实用方法。

typeSearchable - Static variable in interface java.sql. DatabaseMetaData

表示所有 WHERE搜索子句都可以基于此类型。

typesIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter

返回 elements中的类型列表。

typesIn(Set<? extends Element>) - Static method in class javax.lang.model.util. ElementFilter

在 elements返回一组类型。

TypeUtilities - Class in jdk.dynalink.linker.support

用于处理Java类型的各种静态实用程序方法。

TYPEVAR - javax.lang.model.type. TypeKind

一个类型变量。

TypeVariable - Interface in com.sun.javadoc

已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

TypeVariable< D extends GenericDeclaration> - Interface in java.lang.reflect

TypeVariable是类型变量的常用超级接口。

TypeVariable - Interface in javax.lang.model.type

表示一个类型变量。

TypeVisitor< R, P> - Interface in javax.lang.model.type

类型的访客，以访客设计模式的风格。

tyProperty() - Method in class javafx.scene.transform. Affine

定义3x4矩阵的Y坐标转换元素。

tzProperty() - Method in class javafx.scene.transform. Affine

定义3x4矩阵的Z坐标转换元素。

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev Letter

Next Letter

框架

无框架

所有类

Report a bug or suggest an enhancement


U-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

U

U - javafx.scene.input. KeyCode
常数为 U键。
U - Static variable in class javax.swing.text.html. HTML.Tag
标签<u>
UGARITIC - java.lang. Character.UnicodeScript
Unicode脚本“Ugaritic”。
UGARITIC - Static variable in class java.lang. Character.UnicodeBlock
“Ugaritic”Unicode字符块的常数。
ui - Variable in class javax.swing. JComponent
该组件的外观和感觉委托。
ui - Variable in class javax.swing.plaf.basic. BasicMenuUI.ChangeHandler
实例 BasicMenuUI 。
UIClientPropertyKey - Interface in javax.swing
此接口仅用于为 JComponent设置的 JComponent客户端属性标记密钥，需要在L＆F更改和序列化时清除。
uid - Variable in class com.sun.security.auth.module. SolarisSystem
已过时。
uid - Variable in class com.sun.security.auth.module. UnixSystem
UID - Class in java.rmi.server
A UID表示相对于其在其上生成的主机或者 UID 个 “已知”标识符之一的时间而言是唯一的标识符。
UID() - Constructor for class java.rmi.server. UID
生成一个 UID ，它相对于生成的 UID而言是独一无二的。
UID(short) - Constructor for class java.rmi.server. UID
创建了“知名” UID 。
UIDefaults - Class in javax.swing
Swing组件的默认表。
UIDefaults() - Constructor for class javax.swing. UIDefaults
创建一个空默认表。
UIDefaults(int, float) - Constructor for class javax.swing. UIDefaults
创建具有指定的初始容量和负载因子的空默认表。
UIDefaults(Object[]) - Constructor for class javax.swing. UIDefaults
创建使用指定的键/值对初始化的默认值表。
UIDefaults.ActiveValue - Interface in javax.swing
此类可以在每次查询 getXXX(key)方法之一时构建的默认表中存储一个条目。
UIDefaults.LazyInputMap - Class in javax.swing
LazyInputMap将在其 createValue方法中创建一个 InputMap 。
UIDefaults.LazyValue - Interface in javax.swing
此类可以在缺省表中存储一个条目，直到第一次使用其中一个 getXXX(key)方法查找时 getXXX(key) 。
UIDefaults.ProxyLazyValue - Class in javax.swing
该类提供了一个 LazyValue的实现，可以用于延迟加载要创建的实例的Class。
UIEvent - Interface in org.w3c.dom.events
UIEvent接口提供与用户界面事件相关联的特定上下文信息。
UIManager - Class in javax.swing
UIManager管理当外观和感觉变化，外观和感觉默认值以及获得各种默认值的便利方法时通知的当前外观和感觉（ PropertyChangeListeners 。
UIManager() - Constructor for class javax.swing. UIManager
UIManager.LookAndFeelInfo - Class in javax.swing
提供有关安装的 LookAndFeel的一些信息，以配置菜单或初始应用程序设置。
UIResource - Interface in javax.swing.plaf
此接口用于标记由ComponentUI委托创建的对象。
UIResource() - Constructor for class javax.swing. DefaultListCellRenderer.UIResource
UIResource() - Constructor for class javax.swing.plaf.basic. BasicComboBoxEditor.UIResource
UIResource() - Constructor for class javax.swing.plaf.basic. BasicComboBoxRenderer.UIResource
UIResource() - Constructor for class javax.swing.plaf.metal. MetalComboBoxEditor.UIResource
UIResource() - Constructor for class javax.swing. ScrollPaneLayout.UIResource
UIResource() - Constructor for class javax.swing.table. DefaultTableCellRenderer.UIResource
uis - Variable in class javax.swing.plaf.multi. MultiButtonUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiColorChooserUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiComboBoxUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiDesktopIconUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiDesktopPaneUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiFileChooserUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiInternalFrameUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiLabelUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiListUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiMenuBarUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiMenuItemUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiOptionPaneUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiPanelUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiPopupMenuUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiProgressBarUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiRootPaneUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiScrollBarUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiScrollPaneUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiSeparatorUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiSliderUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiSpinnerUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiSplitPaneUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiTabbedPaneUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiTableHeaderUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiTableUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiTextUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiToolBarUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiToolTipUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiTreeUI
包含真实UI的矢量。
uis - Variable in class javax.swing.plaf.multi. MultiViewportUI
包含真实UI的矢量。
uisToArray(Vector<? extends ComponentUI>) - Static method in class javax.swing.plaf.multi. MultiLookAndFeel
创建一个数组，并从传入的向量中填充UI对象，并返回数组。
UK - Static variable in class java.util. Locale
对国家有用的常数。
UL - Static variable in class javax.swing.text.html. HTML.Tag
标记<ul>
ULAW - Static variable in class javax.sound.sampled. AudioFormat.Encoding
指定u律编码数据。
ULongLongSeqHelper - Class in org.omg.CORBA
助手 ULongLongSeq 。
ULongLongSeqHelper() - Constructor for class org.omg.CORBA. ULongLongSeqHelper
ULongLongSeqHolder - Class in org.omg.CORBA
持有人 ULongLongSeq 。
ULongLongSeqHolder() - Constructor for class org.omg.CORBA. ULongLongSeqHolder
ULongLongSeqHolder(long[]) - Constructor for class org.omg.CORBA. ULongLongSeqHolder
ULongSeqHelper - Class in org.omg.CORBA
助手 ULongSeq 。
ULongSeqHelper() - Constructor for class org.omg.CORBA. ULongSeqHelper
ULongSeqHolder - Class in org.omg.CORBA
持有人 ULongSeq 。
ULongSeqHolder() - Constructor for class org.omg.CORBA. ULongSeqHolder
ULongSeqHolder(int[]) - Constructor for class org.omg.CORBA. ULongSeqHolder
ulp() - Method in class java.math. BigDecimal
返回此 BigDecimal的最后一个单位的ulp的大小。
ulp(double) - Static method in class java.lang. Math
返回参数的ulp的大小。
ulp(double) - Static method in class java.lang. StrictMath
返回参数的ulp的大小。
ulp(float) - Static method in class java.lang. Math
返回参数的ulp的大小。
ulp(float) - Static method in class java.lang. StrictMath
返回参数的ulp的大小。
ulxProperty() - Method in class javafx.scene.effect. PerspectiveTransform
源的左上角映射到的输出位置的x坐标。
ulyProperty() - Method in class javafx.scene.effect. PerspectiveTransform
源的左上角映射到的输出位置的y坐标。
UNARY_MINUS - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表元减运算符- 。
UNARY_MINUS - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表元减运算符- 。
UNARY_PLUS - com.sun.source.tree. Tree.Kind
用于实例UnaryTree代表一元加号+ 。
UNARY_PLUS - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表一元加号+ 。
UnaryOperator< T> - Interface in java.util.function
表示对单个操作数产生与其操作数相同类型的结果的操作。
UnaryTree - Interface in com.sun.source.tree
用于后缀和一元表达式的树节点。
UnaryTree - Interface in jdk.nashorn.api.tree
用于后缀和一元表达式的树节点。
UNASSIGNED - Static variable in class java.lang. Character
Unicode规范中的一般类别“Cn”。
UNAUTHORIZED - Static variable in exception org.ietf.jgss. GSSException
操作未经授权
UNAVAILABLE - javafx.scene.control. TabPane.TabClosingPolicy
选项卡不能被用户关闭。
UNAVAILABLE - Static variable in exception org.ietf.jgss. GSSException
操作不可用
UnavailableServiceException - Exception in javax.jnlp
当 UnavailableServiceException不存在或不可用的服务时， UnavailableServiceException抛出 ServiceManager 。
UnavailableServiceException() - Constructor for exception javax.jnlp. UnavailableServiceException
构造一个 UnavailableServiceException其中 null作为其错误详细消息。
UnavailableServiceException(String) - Constructor for exception javax.jnlp. UnavailableServiceException
构造具有指定详细消息的 UnavailableServiceException 。
unbind() - Method in class javafx.beans.property.adapter. JavaBeanBooleanProperty
删除此 Property的单向绑定。
unbind() - Method in class javafx.beans.property.adapter. JavaBeanDoubleProperty
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property.adapter. JavaBeanFloatProperty
删除此 Property的单向绑定。
unbind() - Method in class javafx.beans.property.adapter. JavaBeanIntegerProperty
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property.adapter. JavaBeanLongProperty
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property.adapter. JavaBeanObjectProperty
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property.adapter. JavaBeanStringProperty
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property. BooleanPropertyBase
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property. DoublePropertyBase
删除此 Property的单向绑定。
unbind() - Method in class javafx.beans.property. FloatPropertyBase
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property. IntegerPropertyBase
删除此 Property的单向绑定。
unbind() - Method in class javafx.beans.property. ListPropertyBase
unbind() - Method in class javafx.beans.property. LongPropertyBase
删除此 Property的单向绑定。
unbind() - Method in class javafx.beans.property. MapPropertyBase
unbind() - Method in class javafx.beans.property. ObjectPropertyBase
删除这个 Property的单向绑定。
unbind() - Method in interface javafx.beans.property. Property
删除这个 Property的单向绑定。
unbind() - Method in class javafx.beans.property. SetPropertyBase
unbind() - Method in class javafx.beans.property. StringPropertyBase
删除此 Property的单向绑定。
unbind(String) - Static method in class java.rmi. Naming
销毁与远程对象关联的指定名称的绑定。
unbind(String) - Method in interface java.rmi.registry. Registry
删除此注册表中指定的 name的绑定。
unbind(String) - Method in interface javax.naming. Context
取消绑定命名对象。
unbind(String) - Method in class javax.naming. InitialContext
unbind(Observable...) - Method in class javafx.beans.binding. BooleanBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. DoubleBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. FloatBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. IntegerBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. ListBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. LongBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. MapBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. ObjectBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. SetBinding
停止观察更改的依赖关系。
unbind(Observable...) - Method in class javafx.beans.binding. StringBinding
停止观察更改的依赖关系。
unbind(Name) - Method in interface javax.naming. Context
取消绑定命名对象。
unbind(Name) - Method in class javax.naming. InitialContext
unbind(NameComponent[]) - Method in class org.omg.CosNaming. _NamingContextExtStub
解除绑定操作会从上下文中删除名称绑定。
unbind(NameComponent[]) - Method in class org.omg.CosNaming. _NamingContextStub
解除绑定操作会从上下文中删除名称绑定。
unbind(NameComponent[]) - Method in interface org.omg.CosNaming. NamingContextOperations
解除绑定操作会从上下文中删除名称绑定。
unbindAddress(InetAddress) - Method in class com.sun.nio.sctp. SctpChannel
从通道的套接字的绑定地址中删除给定的地址。
unbindAddress(InetAddress) - Method in class com.sun.nio.sctp. SctpMultiChannel
从通道的套接字的绑定地址中删除给定的地址。
unbindAddress(InetAddress) - Method in class com.sun.nio.sctp. SctpServerChannel
从通道的套接字的绑定地址中删除给定的地址。
unbindBidirectional(Object) - Method in class javafx.beans.property. StringProperty
删除这个 Property和另一个之间的双向绑定。
unbindBidirectional(Object, Object) - Static method in class javafx.beans.binding. Bindings
删除先前使用 Bindings.bindBidirectional(Property, Property)或 Bindings.bindBidirectional(javafx.beans.property.Property, javafx.beans.property.Property, java.text.Format)定义的双向绑定。
unbindBidirectional(Property<Boolean>) - Method in class javafx.beans.property. BooleanProperty
删除这个 Property和另一个之间的双向绑定。
unbindBidirectional(Property<Number>) - Method in class javafx.beans.property. DoubleProperty
删除此 Property和另一个之间的双向绑定。
unbindBidirectional(Property<Number>) - Method in class javafx.beans.property. FloatProperty
删除这个 Property和另一个之间的双向绑定。
unbindBidirectional(Property<Number>) - Method in class javafx.beans.property. IntegerProperty
删除此 Property与另一个之间的双向绑定。
unbindBidirectional(Property<Number>) - Method in class javafx.beans.property. LongProperty
删除此 Property与另一个之间的双向绑定。
unbindBidirectional(Property<String>) - Method in class javafx.beans.property. StringProperty
删除此 Property和另一个之间的双向绑定。
unbindBidirectional(Property<ObservableList<E>>) - Method in class javafx.beans.property. ListProperty
删除此 Property和另一个之间的双向绑定。
unbindBidirectional(Property<ObservableMap<K, V>>) - Method in class javafx.beans.property. MapProperty
删除这个 Property和另一个之间的双向绑定。
unbindBidirectional(Property<ObservableSet<E>>) - Method in class javafx.beans.property. SetProperty
删除这个 Property和另一个之间的双向绑定。
unbindBidirectional(Property<T>) - Method in class javafx.beans.property. ObjectProperty
删除此 Property之间的双向绑定。
unbindBidirectional(Property<T>) - Method in interface javafx.beans.property. Property
删除此 Property和另一个之间的双向绑定。
unbindBidirectional(Property<T>, Property<T>) - Static method in class javafx.beans.binding. Bindings
删除先前使用 Bindings.bindBidirectional(Property, Property)定义的双向绑定。
unbindContent(Object) - Method in class javafx.beans.property. ReadOnlyListProperty
删除ObservableList之间的内容绑定，即包装在这个ReadOnlyListProperty ，另外Object 。
unbindContent(Object) - Method in class javafx.beans.property. ReadOnlyMapProperty
删除ObservableMap之间的内容绑定，即包含在这个ReadOnlyMapProperty ，另外Object 。
unbindContent(Object) - Method in class javafx.beans.property. ReadOnlySetProperty
删除ObservableSet之间的内容绑定，即包含在这个ReadOnlySetProperty和另一个Object 。
unbindContent(Object, Object) - Static method in class javafx.beans.binding. Bindings
删除内容绑定。
unbindContentBidirectional(Object) - Method in class javafx.beans.property. ReadOnlyListProperty
删除ObservableList之间的双向内容绑定，即包裹在此ReadOnlyListProperty和另一个Object 。
unbindContentBidirectional(Object) - Method in class javafx.beans.property. ReadOnlyMapProperty
删除ObservableMap之间的双向内容绑定，即包含在此ReadOnlyMapProperty和另一个Object 。
unbindContentBidirectional(Object) - Method in class javafx.beans.property. ReadOnlySetProperty
删除ObservableSet之间的双向内容绑定，即包装在这个ReadOnlySetProperty ，另外Object 。
unbindContentBidirectional(Object, Object) - Static method in class javafx.beans.binding. Bindings
删除双向内容绑定。
unblock(InetAddress) - Method in class java.nio.channels. MembershipKey
从以前使用 block方法阻止的给定源地址中解除阻塞多播数据报。
UNBOUNDED_WILDCARD - com.sun.source.tree. Tree.Kind
用于表示无界通配符类型参数的WildcardTree的实例。
unboxedType(TypeMirror) - Method in interface javax.lang.model.util. Types
返回给定类型的未装箱值的类型（原始类型）。
uncaughtException(Thread, Throwable) - Method in interface java.lang. Thread.UncaughtExceptionHandler
当给定的线程由于给定的未捕获异常而终止时调用方法。
uncaughtException(Thread, Throwable) - Method in class java.lang. ThreadGroup
当该线程组中的线程由于未捕获的异常而停止时，由Java虚拟机调用，并且线程没有安装特定的Thread.UncaughtExceptionHandler 。
unchecked_narrow(Object) - Static method in class org.omg.CosNaming. BindingIteratorHelper
unchecked_narrow(Object) - Static method in class org.omg.CosNaming. NamingContextExtHelper
unchecked_narrow(Object) - Static method in class org.omg.CosNaming. NamingContextHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynAnyHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynArrayHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynEnumHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynFixedHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynSequenceHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynStructHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynUnionHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny. DynValueHelper
unchecked_narrow(Object) - Static method in class org.omg.IOP. CodecFactoryHelper
unchecked_narrow(Object) - Static method in class org.omg.PortableInterceptor. CurrentHelper
unchecked_narrow(Object) - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper
unchecked_narrow(Object) - Static method in class org.omg.PortableServer. ServantActivatorHelper
unchecked_narrow(Object) - Static method in class org.omg.PortableServer. ServantLocatorHelper
UncheckedIOException - Exception in java.io
包装一个IOException与未检查的异常。
UncheckedIOException(IOException) - Constructor for exception java.io. UncheckedIOException
构造这个类的一个实例。
UncheckedIOException(String, IOException) - Constructor for exception java.io. UncheckedIOException
构造这个类的一个实例。
UNCOLLATED - javafx.print. Collation
相同编号的页面在输出中是连续的，例如：打印2页的2页的文件：第1页，第1页，第2页，第2页。
UNCOLLATED - Static variable in class javax.print.attribute.standard. SheetCollate
当打印出多份副本时，文档中的表格将以未分类的顺序显示。
UNCONDITIONAL - Static variable in class java.lang.invoke. MethodHandles.Lookup
代表 unconditional访问的单位掩码可能有助于 lookupModes的结果。
unconfigurableExecutorService(ExecutorService) - Static method in class java.util.concurrent. Executors
返回一个将所有定义的ExecutorService方法委托给给定执行程序的对象，但不能以其他方式使用转换方式访问。
unconfigurableScheduledExecutorService(ScheduledExecutorService) - Static method in class java.util.concurrent. Executors
返回一个将所有定义的ScheduledExecutorService方法委托给给定执行程序的对象，但不能以任何其他可能使用转换方式访问的方法。
unconfigureArrowButton() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
这种公共方法是实现具体的，应该是私有的。
unconfigureEditor() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
此受保护方法是实现特定的，应该是私有的。
unconfigureEditor() - Method in class javax.swing.plaf.metal. MetalComboBoxUI
unconfigureEnclosingScrollPane() - Method in class javax.swing. JTable
逆转的效果 configureEnclosingScrollPane通过更换 columnHeaderView与封闭滚动窗格 null 。
UNCONSTRAINED_RESIZE_POLICY - Static variable in class javafx.scene.control. TableView
非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
UNCONSTRAINED_RESIZE_POLICY - Static variable in class javafx.scene.control. TreeTableView
非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
UNDECIDED - java.io. ObjectInputFilter.Status
状态未定，不允许，不予拒绝。
UNDECIMBER - Static variable in class java.util. Calendar
Calendar.MONTH字段的值表示一年的第十三个月。
UndeclaredThrowableException - Exception in java.lang.reflect
通过方法调用代理实例时抛出的调用处理程序的 invoke方法抛出检查异常（一 Throwable不是分配给 RuntimeException或者 Error ）是不能分配给任何中声明的异常类型 throws方法的条款，在代理实例上调用并分派到调用处理程序。
UndeclaredThrowableException(Throwable) - Constructor for exception java.lang.reflect. UndeclaredThrowableException
构造一个 UndeclaredThrowableException与指定的 Throwable 。
UndeclaredThrowableException(Throwable, String) - Constructor for exception java.lang.reflect. UndeclaredThrowableException
构造一个 UndeclaredThrowableException与指定的 Throwable和一个详细信息。
UNDECORATED - javafx.stage. StageStyle
定义一个 Stage风格与纯白色背景，没有装饰。
UNDEFINED - javafx.scene.input. KeyCode
该值用于表示keyCode未知。
UNDEFINED - javax.xml.bind.annotation. XmlAccessOrder
类中的字段和属性的顺序是未定义的。
UNDEFINED - Static variable in class java.awt. BufferCapabilities.FlipContents
当翻转内容为 UNDEFINED ，后缓冲区的内容在翻转后未定义。
UNDEFINED_CONDITION - Static variable in class javax.swing. JComponent
一些API使用的常量意味着没有定义任何条件。
UndefinedProperty - Static variable in class java.awt. Image
每当为特定图像未定义的属性被提取时，应返回 UndefinedProperty对象。
UNDERFLOW - Static variable in class java.nio.charset. CoderResult
指示下溢的结果对象，意味着输入缓冲区已经完全消耗，或者如果输入缓冲区尚未为空，则需要额外的输入。
Underline - Static variable in class javax.swing.text. StyleConstants
下划线属性的名称。
UNDERLINE - javafx.scene.web. HTMLEditorSkin.Command
UNDERLINE - Static variable in class java.awt.font. TextAttribute
下划线的属性键。
UNDERLINE_LOW_DASHED - Static variable in class java.awt.font. TextAttribute
单像素虚线低下划线。
UNDERLINE_LOW_DOTTED - Static variable in class java.awt.font. TextAttribute
单像素点下划线。
UNDERLINE_LOW_GRAY - Static variable in class java.awt.font. TextAttribute
双像素灰色低下划线。
UNDERLINE_LOW_ONE_PIXEL - Static variable in class java.awt.font. TextAttribute
单像素固体低下划线。
UNDERLINE_LOW_TWO_PIXEL - Static variable in class java.awt.font. TextAttribute
双像素固体低下划线。
UNDERLINE_ON - Static variable in class java.awt.font. TextAttribute
标准下划线。
UnderlineAction() - Constructor for class javax.swing.text. StyledEditorKit.UnderlineAction
构造一个新的UnderlineAction。
underlineProperty() - Method in class javafx.scene.control. Labeled
是否所有文本都应加下划线。
underlineProperty() - Method in class javafx.scene.text. Text
定义每行文本是否应在其下方有一行。
underlineShape(int, int) - Method in class javafx.scene.text. Text
返回局部坐标下划线的形状。
underlyingType() - Method in interface com.sun.javadoc. AnnotatedType
已过时。
返回底层类型。
UNDERSCORE - javafx.scene.input. KeyCode
常量为“_”键。
UNDETERMINED_REVOCATION_STATUS - java.security.cert. CertPathValidatorException.BasicReason
证书的撤销状态无法确定。
undo() - Method in class javafx.scene.control. TextInputControl
如果可能，撤销最后修改。
undo() - Method in class javax.swing.text. AbstractDocument.DefaultDocumentEvent
撤消更改。
undo() - Method in class javax.swing.text. AbstractDocument.ElementEdit
撤消更改。
undo() - Method in class javax.swing.text. DefaultStyledDocument.AttributeUndoableEdit
撤消更改。
undo() - Method in class javax.swing.undo. AbstractUndoableEdit
抛出 CannotUndoException如果 canUndo返回 false 。
undo() - Method in class javax.swing.undo. CompoundEdit
发送 undo全部包含 UndoableEdits ，与添加顺序相反。
undo() - Method in class javax.swing.undo. StateEdit
告知编辑对象在编辑之前应用状态
undo() - Method in interface javax.swing.undo. UndoableEdit
撤消编辑。
undo() - Method in class javax.swing.undo. UndoManager
撤消相应的编辑。
UNDO - javafx.scene.input. KeyCode
常数为 Undo键。
UNDO - javafx.scene.web. HTMLEditorSkin.Command
UndoableEdit - Interface in javax.swing.undo
一个 UndoableEdit代表一个编辑。
UNDOABLEEDIT - Static variable in class com.sun.java.accessibility.util. EventID
映射到Swing UndoableEdit支持（即UndoableEditListener和UndoableEditEvent）
UndoableEditEvent - Class in javax.swing.event
发生可以撤消的操作的事件。
UndoableEditEvent(Object, UndoableEdit) - Constructor for class javax.swing.event. UndoableEditEvent
构造一个UndoableEditEvent对象。
undoableEditHappened(UndoableEditEvent) - Method in interface javax.swing.event. UndoableEditListener
发生可撤销的修改
undoableEditHappened(UndoableEditEvent) - Method in class javax.swing.undo. UndoManager
一个 UndoableEditListener方法。
UndoableEditListener - Interface in javax.swing.event
接口由有兴趣听取关于可撤销操作的类实现。
UndoableEditSupport - Class in javax.swing.undo
用于管理 UndoableEdit听众的支持类。
UndoableEditSupport() - Constructor for class javax.swing.undo. UndoableEditSupport
构造一个 UndoableEditSupport对象。
UndoableEditSupport(Object) - Constructor for class javax.swing.undo. UndoableEditSupport
构造一个 UndoableEditSupport对象。
undoableProperty() - Method in class javafx.scene.control. TextInputControl
该属性描述如果目前可以撤消已完成的内容的最新更改。
undoDelete() - Method in interface javax.sql.rowset. CachedRowSet
取消删除当前行并通知侦听器行已更改。
undoInsert() - Method in interface javax.sql.rowset. CachedRowSet
如果已经插入该行，则立即从该 CachedRowSet对象中删除当前行，并通知侦听器行已更改。
UndoManager - Class in javax.swing.undo
UndoManager管理列表 UndoableEdits ，提供了一种方法来撤消或恢复适当的编辑。
UndoManager() - Constructor for class javax.swing.undo. UndoManager
创建一个新的 UndoManager 。
UndoName - Static variable in class javax.swing.undo. AbstractUndoableEdit
字符串返回getUndoPresentationName ; 从Java 2平台v1.3.1开始，此字段不再使用。
undoOrRedo() - Method in class javax.swing.undo. UndoManager
调用 undo或 redo之一的方便方法。
undoRedoName - Variable in class javax.swing.undo. StateEdit
撤消/重做演示文稿名称
undoTo(UndoableEdit) - Method in class javax.swing.undo. UndoManager
将下一次编辑的索引中的所有更改从 edit ，更新下一次编辑的索引。
undoUpdate() - Method in interface javax.sql.rowset. CachedRowSet
如果该行已被修改，立即反转最后一次更新操作。
unescapeValue(String) - Static method in class javax.naming.ldap. Rdn
给定根据 RFC 2253中规定的规则格式化的属性值字符串，返回未格式化的值。
UNEXPECTED - java.awt.event. FocusEvent.Cause
导致意外焦点更改的系统操作。
UnexpectedException - Exception in java.rmi
如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口的方法的 throws子句中声明的检查的异常类型中。
UnexpectedException(String) - Constructor for exception java.rmi. UnexpectedException
构造具有指定详细消息的 UnexpectedException 。
UnexpectedException(String, Exception) - Constructor for exception java.rmi. UnexpectedException
构造具有指定的详细消息和嵌套异常的 UnexpectedException 。
unexportObject(Remote) - Method in interface javax.rmi.CORBA. PortableRemoteObjectDelegate
代表团要求 PortableRemoteObject.unexportObject(java.rmi.Remote) 。
unexportObject(Remote) - Static method in class javax.rmi.CORBA. Util
从内部表中删除相关联的绑定，并调用 Tie.deactivate()以停用该对象。
unexportObject(Remote) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.unexportObject(java.rmi.Remote) 。
unexportObject(Remote) - Static method in class javax.rmi. PortableRemoteObject
从运行时取消注册服务器对象，允许对象可用于垃圾回收。
unexportObject(Remote, boolean) - Static method in class java.rmi.activation. Activatable
从RMI运行时中删除远程对象obj。
unexportObject(Remote, boolean) - Static method in class java.rmi.server. UnicastRemoteObject
从RMI运行时中删除远程对象obj。
ungrab() - Method in class javafx.scene.input. TouchPoint
从目标中解开这个接触点。
UnicastRemoteObject - Class in java.rmi.server
用于使用JRMP导出远程对象并获取与远程对象通信的存根。
UnicastRemoteObject() - Constructor for class java.rmi.server. UnicastRemoteObject
使用匿名端口创建并导出新的UnicastRemoteObject对象。
UnicastRemoteObject(int) - Constructor for class java.rmi.server. UnicastRemoteObject
使用特定提供的端口创建并导出新的UnicastRemoteObject对象。
UnicastRemoteObject(int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.server. UnicastRemoteObject
使用特定提供的端口和套接字工厂创建并导出新的UnicastRemoteObject对象。
UNICODE_CASE - Static variable in class java.util.regex. Pattern
启用Unicode感知案例折叠。
UNICODE_CHARACTER_CLASS - Static variable in class java.util.regex. Pattern
启用Unicode版本的 预定义字符类和 POSIX字符类 。
UNICODE_LOCALE_EXTENSION - Static variable in class java.util. Locale
Unicode区域扩展（'u'）的关键。
UNICODE_STREAM_PARAM - Static variable in class javax.sql.rowset. BaseRowSet
一个常量，指示一个给定参数是Unicode流的一个 RowSetReaderImpl对象。
unicodeStream - Variable in class javax.sql.rowset. BaseRowSet
InputStream对象将通过方法 getUnicodeStream返回，这是在 ResultSet接口中指定的。
UNIFIED - javafx.stage. StageStyle
定义 Stage风格的平台装饰，并消除客户区域和装饰品之间的边界。
UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS - Static variable in class java.lang. Character.UnicodeBlock
统一的“统一加拿大原住民音节”Unicode字符块。
UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED - Static variable in class java.lang. Character.UnicodeBlock
统一的“统一加拿大原住民音节扩展”Unicode字符块。
UNIFIED_WINDOW - javafx.application. ConditionalFeature
表示系统支持 StageStyle.UNIFIED
uninitialize() - Method in class javax.swing. LookAndFeel
初始化外观和感觉。
uninitialize() - Method in class javax.swing.plaf.basic. BasicLookAndFeel
初始化外观和感觉。
uninitialize() - Method in class javax.swing.plaf.nimbus. NimbusLookAndFeel
当这个外观和感觉被卸载时，由UIManager打电话。
uninitialize() - Method in class javax.swing.plaf.synth. SynthLookAndFeel
当这个外观和感觉被卸载时，由UIManager打电话。
UNINITIALIZED - Static variable in class java.security. Signature
可能的值为 Signature.state ，表示此签名对象尚未初始化。
UNINITIALIZED_VALUE - Static variable in class javax.swing. JOptionPane
表示用户尚未选择值。
uninstall() - Method in class javax.swing. JFormattedTextField.AbstractFormatter
卸载任何状态 AbstractFormatter可能对安装 JFormattedTextField 。
uninstall(Node, Tooltip) - Static method in class javafx.scene.control. Tooltip
删除给定的Tooltip在指定的Node的关联 。
uninstallBorder(JComponent) - Static method in class javax.swing. LookAndFeel
方便卸载边框的方法。
uninstallChooserPanel(JColorChooser) - Method in class javax.swing.colorchooser. AbstractColorChooserPanel
当面板从选择器中移除时调用。
uninstallComboBoxModelListeners(ComboBoxModel<?>) - Method in class javax.swing.plaf.basic. BasicComboPopup
从组合框模型中删除侦听器
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
构成组合框的集合组件未注册并未初始化。
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI
取消注册组件。
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
卸载组件。
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
取消注册组件。
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicScrollBarUI
卸载组件。
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
从JTabbedPane中删除任何已安装的子组件。
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicToolBarUI
取消注册组件。
uninstallComponents() - Method in class javax.swing.plaf.basic. BasicTreeUI
卸载渲染器窗格。
uninstallComponents() - Method in class javax.swing.plaf.metal. MetalDesktopIconUI
uninstallComponents() - Method in class javax.swing.plaf.metal. MetalInternalFrameUI
uninstallComponents() - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
卸载组件。
uninstallComponents() - Method in class javax.swing.plaf.synth. SynthToolBarUI
取消注册组件。
uninstallComponents(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
卸载组件。
uninstallComponents(JFileChooser) - Method in class javax.swing.plaf.metal. MetalFileChooserUI
uninstallComponents(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI
取消注册组件。
uninstallComponents(JMenuItem) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
取消注册组件。
uninstallComponents(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI
取消注册组件。
uninstallDefaultChoosers() - Method in class javax.swing.plaf.basic. BasicColorChooserUI
卸载默认颜色选择器。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicColorChooserUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
从组合框中卸载默认颜色，默认字体，默认渲染器和默认编辑器。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
卸载默认值。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicListUI
将尚未被明确覆盖的列表属性设置为 null 。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicMenuBarUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicMenuItemUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicMenuUI
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicPopupMenuUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicProgressBarUI
Unintalls默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicScrollBarUI
卸载默认值。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicSpinnerUI
将 JSpinner's布局管理器设置为null。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
卸载UI默认值。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
卸载默认值。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI
卸载默认属性
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicTableUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicTextUI
将尚未被明确覆盖的组件属性设置为 null 。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicToolBarUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.basic. BasicTreeUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.metal. MetalInternalFrameTitlePane
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthColorChooserUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthComboBoxUI
从组合框中卸载默认颜色，默认字体，默认渲染器和默认编辑器。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthDesktopIconUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthEditorPaneUI
将未明确覆盖的组件属性设置为 null 。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
卸载默认值。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthListUI
将尚未被明确覆盖的列表属性设置为 null 。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthMenuBarUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthMenuItemUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthMenuUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthPopupMenuUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthProgressBarUI
Unintalls默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthScrollBarUI
卸载默认值。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthSpinnerUI
将 JSpinner's布局管理器设置为null。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
卸载UI默认值。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
卸载默认值。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
卸载默认属性
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthTableUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthTextAreaUI
将未明确覆盖的组件属性设置为 null 。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthTextFieldUI
将未明确覆盖的组件属性设置为 null 。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthToolBarUI
卸载默认属性。
uninstallDefaults() - Method in class javax.swing.plaf.synth. SynthTreeUI
卸载默认属性。
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI
卸载默认属性。
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.basic. BasicRadioButtonUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalButtonUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalCheckBoxUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalRadioButtonUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal. MetalToggleButtonUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.synth. SynthButtonUI
卸载默认属性。
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI
卸载默认属性。
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.basic. BasicViewportUI
卸载视图端口属性。
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI
卸载默认属性。
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI
从视口卸载默认值。
uninstallDefaults(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
卸载默认值。
uninstallDefaults(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI
卸载默认属性。
uninstallDefaults(JLabel) - Method in class javax.swing.plaf.synth. SynthLabelUI
卸载默认属性。
uninstallDefaults(JPanel) - Method in class javax.swing.plaf.basic. BasicPanelUI
卸载面板属性的方法。
uninstallDefaults(JPanel) - Method in class javax.swing.plaf.synth. SynthPanelUI
卸载面板属性的方法。
uninstallDefaults(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI
卸载默认属性。
uninstallDefaults(JRootPane) - Method in class javax.swing.plaf.synth. SynthRootPaneUI
卸载默认属性。
uninstallDefaults(JScrollPane) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
卸载默认属性。
uninstallDefaults(JScrollPane) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI
卸载默认属性。
uninstallDefaults(JSeparator) - Method in class javax.swing.plaf.basic. BasicSeparatorUI
卸载默认属性。
uninstallDefaults(JSeparator) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
卸载默认设置。
uninstallDefaults(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI
卸载默认值。
uninstallDefaults(JSlider) - Method in class javax.swing.plaf.synth. SynthSliderUI
卸载默认设置。
uninstallDefaults(SynthContext) - Method in class javax.swing.plaf.synth. SynthStyle
从 context卸载 JComponent上安装的任何状态。
uninstallDesktopManager() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
卸载桌面管理器。
uninstallDesktopManager() - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
卸载桌面管理器。
uninstallIcons(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
卸载图标。
uninstallingUI() - Method in class javax.swing.plaf.basic. BasicComboPopup
当UI卸载时调用。
uninstallingUI() - Method in interface javax.swing.plaf.basic. ComboPopup
调用通知ComboPopup用户界面正在卸载。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
删除焦点InputMap和ActionMap。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicComboPopup
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
卸载键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicListUI
取消注册从 installKeyboardActions安装的键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicMenuBarUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicMenuItemUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicMenuUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicPopupMenuUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicScrollBarUI
卸载键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
卸载UI的键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
卸载键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI
取消注册默认键操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTableUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTextUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicToolBarUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic. BasicTreeUI
取消注册键盘操作。
uninstallKeyboardActions() - Method in class javax.swing.plaf.metal. MetalInternalFrameUI
uninstallKeyboardActions(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI
取消注册键盘操作。
uninstallKeyboardActions(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonListener
取消注册默认键操作。
uninstallKeyboardActions(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI
取消注册键盘操作。
uninstallKeyboardActions(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI
取消注册键盘操作。
uninstallKeyboardActions(JScrollPane) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
取消注册键盘操作。
uninstallKeyboardActions(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI
卸载键盘操作。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicColorChooserUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicComboBoxUI
从组合框及其模型中删除已安装的监听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicDesktopIconUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
从 createPropertyChangeListener卸载 PropertyChangeListener返回的 JDesktopPane 。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
卸载侦听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicListUI
从JList，其模型及其selectionModel中移除侦听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicMenuBarUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicMenuItemUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicMenuUI
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicPopupMenuUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicProgressBarUI
删除此对象安装的所有侦听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicScrollBarUI
卸载侦听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicSpinnerUI
删除由 PropertyChangeListener添加的PropertyChangeListener。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
卸载UI的事件侦听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
卸载侦听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicTableHeaderUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicTableUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicTextUI
卸载UI的监听器。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicToolBarUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.basic. BasicTreeUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.metal. MetalDesktopIconUI
uninstallListeners() - Method in class javax.swing.plaf.metal. MetalInternalFrameUI
uninstallListeners() - Method in class javax.swing.plaf.metal. MetalToolBarUI
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthColorChooserUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthComboBoxUI
从组合框及其模型中删除已安装的监听器。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthDesktopIconUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
卸载 PropertyChangeListener从返回 createPropertyChangeListener从 JDesktopPane 。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
卸载侦听器。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthListUI
从JList，其模型及其selectionModel中移除侦听器。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthMenuBarUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthMenuItemUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthMenuUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthOptionPaneUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthPopupMenuUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthProgressBarUI
删除此对象安装的所有侦听器。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthScrollBarUI
卸载侦听器。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthSpinnerUI
删除由 PropertyChangeListener添加的PropertyChangeListener。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
从UI中卸载事件侦听器。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
卸载侦听器。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthTableUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthToolBarUI
取消注册听众。
uninstallListeners() - Method in class javax.swing.plaf.synth. SynthTreeUI
取消注册听众。
uninstallListeners(AbstractButton) - Method in class javax.swing.plaf.basic. BasicButtonUI
取消注册听众。
uninstallListeners(AbstractButton) - Method in class javax.swing.plaf.basic. BasicRadioButtonUI
uninstallListeners(AbstractButton) - Method in class javax.swing.plaf.synth. SynthButtonUI
取消注册听众。
uninstallListeners(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
取消注册听众。
uninstallListeners(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI
取消注册听众。
uninstallListeners(JComponent) - Method in class javax.swing.plaf.metal. MetalScrollPaneUI
取消注册听众。
uninstallListeners(JComponent) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI
取消注册听众。
uninstallListeners(JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI
取消注册听众。
uninstallListeners(JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI
从视口卸载侦听器。
uninstallListeners(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
卸载侦听器。
uninstallListeners(JLabel) - Method in class javax.swing.plaf.basic. BasicLabelUI
取消注册听众。
uninstallListeners(JPanel) - Method in class javax.swing.plaf.synth. SynthPanelUI
从面板卸载侦听器。
uninstallListeners(JRootPane) - Method in class javax.swing.plaf.basic. BasicRootPaneUI
取消注册听众。
uninstallListeners(JScrollPane) - Method in class javax.swing.plaf.metal. MetalScrollPaneUI
已过时。
- 替换为MetalScrollPaneUI.uninstallListeners(JComponent)
uninstallListeners(JSeparator) - Method in class javax.swing.plaf.basic. BasicSeparatorUI
取消注册听众。
uninstallListeners(JSeparator) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
卸载侦听器。
uninstallListeners(JSlider) - Method in class javax.swing.plaf.basic. BasicSliderUI
卸载侦听器。
uninstallListeners(JSlider) - Method in class javax.swing.plaf.synth. SynthSliderUI
卸载侦听器。
uninstallPreviewPanel() - Method in class javax.swing.plaf.basic. BasicColorChooserUI
从UI代理中删除已安装的预览面板。
uninstallStrings(JFileChooser) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
卸载字符串。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicButtonUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicColorChooserUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicComboBoxUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopIconUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicEditorPaneUI
卸载组件的UI。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI
卸载UI。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicInternalFrameUI
卸载UI。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicLabelUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicListUI
 取消初始化
this.list致电
uninstallListeners() ，
uninstallKeyboardActions() ，并
uninstallDefaults()秩序。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicOptionPaneUI
从分离窗格中传递的L＆F控制器中删除接收者。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicPanelUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicPopupMenuUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicProgressBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicRootPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollBarUI
卸载UI。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSeparatorUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSliderUI
卸载用户界面
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSpinnerUI
电话 uninstallDefaults ， uninstallListeners ，然后删除所有的纺纱孩子。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicSplitPaneUI
卸载UI。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTabbedPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTableHeaderUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTableUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTextUI
卸载组件的UI。
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicToolBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicToolTipUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicTreeUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic. BasicViewportUI
uninstallUI(JComponent) - Method in class javax.swing.plaf. ComponentUI
在 installUI反转在指定组件上完成的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf. LayerUI
反转以前在 LayerUI.installUI(JComponent)中设置的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalInternalFrameUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalMenuBarUI
在 installUI反转在指定组件上完成的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalRootPaneUI
调用supers实现来卸载其任何状态。
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalScrollPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalToolBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalToolTipUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal. MetalTreeUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiListUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI
在此对象处理的每个UI上调用 uninstallUI方法。
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth. SynthComboBoxUI
在 installUI反转在指定组件上完成的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth. SynthMenuItemUI
在 installUI反转在指定组件上完成的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth. SynthMenuUI
在 installUI反转在指定组件上完成的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth. SynthPanelUI
在 installUI反转在指定组件上完成的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
在 installUI反转在指定组件上完成的配置。
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI
在 installUI反转在指定组件上完成的配置。
union(Rectangle2D, Rectangle2D, Rectangle2D) - Static method in class java.awt.geom. Rectangle2D
使用一对源 Rectangle2D对象并将结果放入指定的目的地 Rectangle2D对象。
union(Rectangle) - Method in class java.awt. Rectangle
计算该 Rectangle与指定的 Rectangle 。
union(Shape, Shape) - Static method in class javafx.scene.shape. Shape
返回一个新的 Shape ，它被创建为指定输入形状的并集。
union(Descriptor...) - Static method in class javax.management. ImmutableDescriptor
返回一个 ImmutableDescriptor其内容是给定描述符的并集。
UNION - javax.lang.model.type. TypeKind
联合类型。
UNION - Static variable in class javax.xml.crypto.dsig.spec. XPathType.Filter
联合过滤操作。
UNION_TYPE - com.sun.source.tree. Tree.Kind
用于UnionTypeTree的实例。
UnionMember - Class in org.omg.CORBA
IDL联盟成员的Interface Repository中的描述。
UnionMember() - Constructor for class org.omg.CORBA. UnionMember
构造一个新的 UnionMember对象，其字段初始化为null。
UnionMember(String, Any, TypeCode, IDLType) - Constructor for class org.omg.CORBA. UnionMember
构造一个新的 UnionMember对象，其字段初始化为给定值。
UnionMemberHelper - Class in org.omg.CORBA
助手 UnionMember 。
UnionMemberHelper() - Constructor for class org.omg.CORBA. UnionMemberHelper
UnionType - Interface in javax.lang.model.type
表示联合类型。
UnionTypeTree - Interface in com.sun.source.tree
多重变量声明中的联合类型表达式的树节点。
UNIQUE_ID - Static variable in class org.omg.PortableServer. IdUniquenessPolicyValue
uniqueID() - Method in interface com.sun.jdi. ObjectReference
返回此ObjectReference的唯一标识符。
UNIT_DECREMENT - Static variable in class java.awt.event. AdjustmentEvent
单位减量调整类型。
UNIT_INCREMENT - Static variable in class java.awt.event. AdjustmentEvent
单位增量调整类型。
unitIncrement - Variable in class javax.swing. JScrollBar
unitIncrementProperty() - Method in class javafx.scene.control. ScrollBar
当 调用increment或 decrement方法时调整ScrollBar的量。
UNIX_LINES - Static variable in class java.util.regex. Pattern
启用Unix行模式。
UnixLoginModule - Class in com.sun.security.auth.module
这 LoginModule导入用户的Unix Principal信息（ UnixPrincipal ， UnixNumericUserPrincipal ，并 UnixNumericGroupPrincipal ），并与当前的关联 Subject 。
UnixLoginModule() - Constructor for class com.sun.security.auth.module. UnixLoginModule
UnixNumericGroupPrincipal - Class in com.sun.security.auth
该类实现了 Principal接口，代表用户的Unix组标识号（GID）。
UnixNumericGroupPrincipal(long, boolean) - Constructor for class com.sun.security.auth. UnixNumericGroupPrincipal
使用用户组标识号（GID）的长表示形成 UnixNumericGroupPrincipal 。
UnixNumericGroupPrincipal(String, boolean) - Constructor for class com.sun.security.auth. UnixNumericGroupPrincipal
使用 String表示用户组标识号（GID）创建一个 UnixNumericGroupPrincipal 。
UnixNumericUserPrincipal - Class in com.sun.security.auth
该类实现了 Principal接口，代表用户的Unix标识号（UID）。
UnixNumericUserPrincipal(long) - Constructor for class com.sun.security.auth. UnixNumericUserPrincipal
使用用户标识号（UID）的长表示形成 UnixNumericUserPrincipal 。
UnixNumericUserPrincipal(String) - Constructor for class com.sun.security.auth. UnixNumericUserPrincipal
使用用户标识号（UID）的 String表示创建一个 UnixNumericUserPrincipal 。
UnixOperatingSystemMXBean - Interface in com.sun.management
适用于运行Java虚拟机的Unix操作系统的平台特定管理界面。
UnixPrincipal - Class in com.sun.security.auth
该类实现了 Principal接口，代表了Unix用户。
UnixPrincipal(String) - Constructor for class com.sun.security.auth. UnixPrincipal
用Unix用户名创建一个UnixPrincipal。
UnixSystem - Class in com.sun.security.auth.module
此类实现检索并提供当前用户的Unix UID / GID /组信息。
UnixSystem() - Constructor for class com.sun.security.auth.module. UnixSystem
实例化一个 UnixSystem并加载本机库以访问底层系统信息。
UNKNOWN - Exception in org.omg.CORBA
如果操作实现抛出非CORBA异常（例如特定于实现的编程语言的异常），或者操作引发不在操作的引用表达式中出现的用户异常，则会引发此异常。
UNKNOWN - java.awt.event. FocusEvent.Cause
默认值。
UNKNOWN - java.lang. Character.UnicodeScript
Unicode脚本“未知”。
UNKNOWN - javafx.scene.media. MediaException.Type
表示由于未知原因而发生错误。
UNKNOWN - javafx.scene.media. MediaPlayer.Status
播放器立即创建后的状态。
UNKNOWN - jdk.jshell. SourceCodeAnalysis.Completeness
输入的完整性无法确定，因为它包含错误。
UNKNOWN - Interface in org.omg.PortableInterceptor
org / omg / PortableInterceptor / UNKNOWN.java。
UNKNOWN - Static variable in class java.awt. ComponentOrientation
表示组件的方向尚未设置。
UNKNOWN - Static variable in class javafx.util. Duration
一段时间的未知数量。
UNKNOWN - Static variable in class javax.accessibility. AccessibleRole
该对象包含一些 Accessible信息，但其作用不明。
UNKNOWN - Static variable in class javax.management. MBeanOperationInfo
表示操作的影响是未知的或不能使用其他值之一来表达。
UNKNOWN - Static variable in class javax.print.attribute.standard. JobState
工作状态是未知的。
UNKNOWN - Static variable in class javax.print.attribute.standard. PrinterState
打印机状态未知。
UNKNOWN() - Constructor for exception org.omg.CORBA. UNKNOWN
构造一个 UNKNOWN异常，默认次要代码为0，完成状态为CompletionStatus.COMPLETED_NO，并且为空描述。
UNKNOWN(int, CompletionStatus) - Constructor for exception org.omg.CORBA. UNKNOWN
构造具有指定的次要代码和完成状态的 UNKNOWN异常。
UNKNOWN(String) - Constructor for exception org.omg.CORBA. UNKNOWN
构造一个 UNKNOWN异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。
UNKNOWN(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA. UNKNOWN
构造具有指定的描述消息，次要代码和完成状态的 UNKNOWN异常。
unknown_adapter(POA, String) - Method in interface org.omg.PortableServer. AdapterActivatorOperations
当ORB接收到用于标识不存在的目标POA的对象引用的请求时，调用此操作。
UNKNOWN_ATTRIBUTE - Static variable in interface java.util.jar. Pack200.Packer
指示遇到包含未知属性的类文件时要执行的操作。
UNKNOWN_BLOCK_TAG - com.sun.source.doctree. DocTree.Kind
用于表示未知块标记的UnknownBlockTagTree的实例。
UNKNOWN_INLINE_TAG - com.sun.source.doctree. DocTree.Kind
用于表示未知内联标签的UnknownInlineTagTree的实例。
UNKNOWN_LENGTH - Static variable in class javax.sound.midi. MidiFileFormat
代表未知长度。
UNKNOWN_NUMBER_OF_PAGES - Static variable in interface java.awt.print. Pageable
如果 Pageable实现不知道其集合中的页数，则该常数从 getNumberOfPages方法返回。
UNKNOWN_RULE - Static variable in interface org.w3c.dom.css. CSSRule
规则是一个 CSSUnknownRule 。
UNKNOWN_SUBKIND - jdk.jshell. Snippet.SubKind
一个不可知的片段。
UNKNOWN_TAG_NAME - Static variable in class javax.imageio.plugins.tiff. TIFFTag
分配给具有未知标签号的标签的名称。
UnknownAnnotationValueException - Exception in javax.lang.model.element
表示遇到未知类型的注释值。
UnknownAnnotationValueException(AnnotationValue, Object) - Constructor for exception javax.lang.model.element. UnknownAnnotationValueException
创建一个新的 UnknownAnnotationValueException 。
UnknownBlockTagTree - Interface in com.sun.source.doctree
用于无法识别的内联标签的树节点。
UnknownDirectiveException - Exception in javax.lang.model.element
表示遇到未知类型的模块指令。
UnknownDirectiveException(ModuleElement.Directive, Object) - Constructor for exception javax.lang.model.element. UnknownDirectiveException
创建一个新的 UnknownElementException 。
UnknownElementException - Exception in javax.lang.model.element
表示遇到未知类型的元素。
UnknownElementException(Element, Object) - Constructor for exception javax.lang.model.element. UnknownElementException
创建一个新的 UnknownElementException 。
UnknownEncoding - Exception in org.omg.IOP.CodecFactoryPackage
org / omg / IOP / CodecFactoryPackage / UnknownEncoding.java。
UnknownEncoding() - Constructor for exception org.omg.IOP.CodecFactoryPackage. UnknownEncoding
UnknownEncoding(String) - Constructor for exception org.omg.IOP.CodecFactoryPackage. UnknownEncoding
UnknownEncodingHelper - Class in org.omg.IOP.CodecFactoryPackage
org / omg / IOP / CodecFactoryPackage / UnknownEncodingHelper.java。
UnknownEncodingHelper() - Constructor for class org.omg.IOP.CodecFactoryPackage. UnknownEncodingHelper
UnknownEntityException - Exception in javax.lang.model
例外的超类，表示遇到一个未知类型的实体。
UnknownEntityException(String) - Constructor for exception javax.lang.model. UnknownEntityException
创建一个新的 UnknownEntityException具有指定的详细消息。
UnknownError - Error in java.lang
当Java虚拟机中出现未知但严重的异常时抛出。
UnknownError() - Constructor for error java.lang. UnknownError
构造一个 UnknownError ，没有详细信息。
UnknownError(String) - Constructor for error java.lang. UnknownError
构造具有指定详细消息的 UnknownError 。
UnknownException - Exception in org.omg.CORBA.portable
org.omg.CORBA.portable.UnknownException用于报告关系和ORB之间以及ORB和存根之间的未知异常。
UnknownException(Throwable) - Constructor for exception org.omg.CORBA.portable. UnknownException
构造一个UnknownException对象。
UnknownFormatConversionException - Exception in java.util
给出未知转换时抛出未检查的异常。
UnknownFormatConversionException(String) - Constructor for exception java.util. UnknownFormatConversionException
构造具有未知转换的此类的实例。
UnknownFormatFlagsException - Exception in java.util
给定未知标志时抛出未检查的异常。
UnknownFormatFlagsException(String) - Constructor for exception java.util. UnknownFormatFlagsException
使用指定的标志构造此类的实例。
UnknownGroupException - Exception in java.rmi.activation
一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。
UnknownGroupException(String) - Constructor for exception java.rmi.activation. UnknownGroupException
构造具有指定详细消息的 UnknownGroupException 。
UnknownHostException - Exception in java.net
抛出以表示无法确定主机的IP地址。
UnknownHostException - Exception in java.rmi
如果在远程方法调用创建与远程主机的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
UnknownHostException() - Constructor for exception java.net. UnknownHostException
构造一个新的 UnknownHostException ，没有详细信息。
UnknownHostException(String) - Constructor for exception java.net. UnknownHostException
构造一个新的 UnknownHostException具有指定的详细信息。
UnknownHostException(String) - Constructor for exception java.rmi. UnknownHostException
构造一个具有指定详细消息的 UnknownHostException 。
UnknownHostException(String, Exception) - Constructor for exception java.rmi. UnknownHostException
构造一个具有指定的详细消息和嵌套异常的 UnknownHostException 。
UnknownInlineTagTree - Interface in com.sun.source.doctree
用于无法识别的内联标签的树节点。
UnknownObjectException - Exception in java.rmi.activation
当方法的 ActivationID参数被确定为无效时，通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。
UnknownObjectException(String) - Constructor for exception java.rmi.activation. UnknownObjectException
构造一个具有指定详细消息的 UnknownObjectException 。
UnknownServiceException - Exception in java.net
抛出以表示发生未知服务异常。
UnknownServiceException() - Constructor for exception java.net. UnknownServiceException
构造一个新的 UnknownServiceException ，没有详细信息。
UnknownServiceException(String) - Constructor for exception java.net. UnknownServiceException
构造一个新的 UnknownServiceException具有指定的详细消息。
UnknownTag(String) - Constructor for class javax.swing.text.html. HTML.UnknownTag
创建一个新的 UnknownTag与指定的 id 。
UnknownTreeException - Exception in jdk.nashorn.api.tree
表示遇到了一种未知类型的树。
UnknownTreeException(Tree, Object) - Constructor for exception jdk.nashorn.api.tree. UnknownTreeException
创建一个新的 UnknownTreeException 。
UnknownTypeException - Exception in javax.lang.model.type
表示遇到未知类型的类型。
UnknownTypeException(TypeMirror, Object) - Constructor for exception javax.lang.model.type. UnknownTypeException
创建一个新的UnknownTypeException可以使用p参数传递附加参数，其中包含遇到未知类型的上下文的信息; 例如， TypeVisitor的访问方式可能会传入其附加参数。
UnknownUserException - Exception in org.omg.CORBA
包含服务器返回的用户异常的类。
UnknownUserException() - Constructor for exception org.omg.CORBA. UnknownUserException
构造一个 UnknownUserException对象。
UnknownUserException(Any) - Constructor for exception org.omg.CORBA. UnknownUserException
构造一个 UnknownUserException对象包含给定 Any对象。
UnknownUserExceptionHelper - Class in org.omg.CORBA
助手 UnknownUserException 。
UnknownUserExceptionHelper() - Constructor for class org.omg.CORBA. UnknownUserExceptionHelper
UnknownUserExceptionHolder - Class in org.omg.CORBA
持有人 UnknownUserException 。
UnknownUserExceptionHolder() - Constructor for class org.omg.CORBA. UnknownUserExceptionHolder
UnknownUserExceptionHolder(UnknownUserException) - Constructor for class org.omg.CORBA. UnknownUserExceptionHolder
UNLIMITED - Static variable in class java.math. MathContext
一个 MathContext对象，其设置具有无限精度算术所需的值。
unloadAllInstruments(Soundbank) - Method in interface javax.sound.midi. Synthesizer
卸载指定的所有仪器 Soundbank 。
unloadInstrument(Instrument) - Method in interface javax.sound.midi. Synthesizer
卸载特定的仪器。
unloadInstruments(Soundbank, Patch[]) - Method in interface javax.sound.midi. Synthesizer
从指定的MIDI声音库中卸载指定补丁引用的乐器。
unloadZone(View) - Method in class javax.swing.text. ZoneView
卸载区域（将区域转换为其内存保存状态）。
unlock() - Method in interface java.util.concurrent.locks. Lock
释放锁。
unlock() - Method in class java.util.concurrent.locks. ReentrantLock
尝试释放此锁。
unlock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.ReadLock
尝试释放此锁。
unlock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock
尝试释放此锁。
unlock(long) - Method in class java.util.concurrent.locks. StampedLock
如果锁定状态与给定的标记匹配，则释放相应的锁定模式。
unlockRead(long) - Method in class java.util.concurrent.locks. StampedLock
如果锁定状态与给定的标记匹配，则释放非排他锁。
unlockWrite(long) - Method in class java.util.concurrent.locks. StampedLock
如果锁定状态与给定的邮票相匹配，则释放排他锁。
unmappableCharacterAction() - Method in class java.nio.charset. CharsetDecoder
返回此解码器当前的不可映射字符错误的操作。
unmappableCharacterAction() - Method in class java.nio.charset. CharsetEncoder
返回此编码器当前对不可映射字符错误的操作。
UnmappableCharacterException - Exception in java.nio.charset
输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。
UnmappableCharacterException(int) - Constructor for exception java.nio.charset. UnmappableCharacterException
构造一个给定长度的 UnmappableCharacterException 。
unmappableForLength(int) - Static method in class java.nio.charset. CoderResult
静态工厂方法返回描述给定长度的不可映射字符错误的唯一结果对象。
unmarshal(File) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(File) - Method in interface javax.xml.bind. Unmarshaller
从指定的文件解组XML数据并返回生成的内容树。
unmarshal(File, Class<T>) - Static method in class javax.xml.bind. JAXB
从给定的XML输入中读取Java对象树。
unmarshal(InputStream) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(InputStream) - Method in interface javax.xml.bind. Unmarshaller
从指定的InputStream中解组XML数据，并返回生成的内容树。
unmarshal(InputStream, Class<T>) - Static method in class javax.xml.bind. JAXB
从给定的XML输入中读取Java对象树。
unmarshal(Reader) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(Reader) - Method in interface javax.xml.bind. Unmarshaller
从指定的Reader中解组XML数据并返回生成的内容树。
unmarshal(Reader, Class<T>) - Static method in class javax.xml.bind. JAXB
从给定的XML输入中读取Java对象树。
unmarshal(String) - Method in class javax.xml.bind.annotation.adapters. CollapsedStringAdapter
删除作为参数给出的字符串的前导和尾随空格，然后通过单个空格字符“'截断任何标签，CR，LF和SP序列。
unmarshal(String) - Method in class javax.xml.bind.annotation.adapters. HexBinaryAdapter
unmarshal(String) - Method in class javax.xml.bind.annotation.adapters. NormalizedStringAdapter
按照 the whitespace facet 'replace'中的规定，将任何标签，CR和LF替换为空格字符“'
unmarshal(String, Class<T>) - Static method in class javax.xml.bind. JAXB
从给定的XML输入中读取Java对象树。
unmarshal(URI, Class<T>) - Static method in class javax.xml.bind. JAXB
从给定的XML输入中读取Java对象树。
unmarshal(URL) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(URL) - Method in interface javax.xml.bind. Unmarshaller
从指定的URL解组XML数据并返回生成的内容树。
unmarshal(URL, Class<T>) - Static method in class javax.xml.bind. JAXB
从给定的XML输入中读取Java对象树。
unmarshal(XMLEventReader) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(XMLEventReader) - Method in interface javax.xml.bind. Unmarshaller
从指定的解析器解组XML数据并返回生成的内容树。
unmarshal(XMLEventReader, Class<T>) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(XMLEventReader, Class<T>) - Method in interface javax.xml.bind. Unmarshaller
将根元素解组到JAXB映射 declaredType并返回生成的内容树。
unmarshal(XMLStreamReader) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(XMLStreamReader) - Method in interface javax.xml.bind. Unmarshaller
从指定的解析器解组XML数据并返回生成的内容树。
unmarshal(XMLStreamReader, Class<T>) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(XMLStreamReader, Class<T>) - Method in interface javax.xml.bind. Unmarshaller
将根元素解组到JAXB映射 declaredType并返回生成的内容树。
unmarshal(Source) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(Source) - Method in interface javax.xml.bind. Unmarshaller
从指定的XML Source中解组XML数据并返回生成的内容树。
unmarshal(Source, Class<T>) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(Source, Class<T>) - Static method in class javax.xml.bind. JAXB
从给定的XML输入中读取Java对象树。
unmarshal(Source, Class<T>) - Method in interface javax.xml.bind. Unmarshaller
将 declaredType的指定XML源中的XML数据解组并返回结果内容树。
unmarshal(DataInputStream) - Method in interface org.omg.CORBA. CustomMarshal
Unmarshal方法必须由Customized Marshal类实现。
unmarshal(Node) - Method in interface javax.xml.bind. Unmarshaller
从指定的DOM树中解组全局XML数据，并返回生成的内容树。
unmarshal(Node, Class<T>) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(Node, Class<T>) - Method in interface javax.xml.bind. Unmarshaller
通过JAXB映射 declaredType解组XML数据，并返回结果内容树。
unmarshal(InputSource) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
unmarshal(InputSource) - Method in interface javax.xml.bind. Unmarshaller
从指定的SAX InputSource解组XML数据并返回结果内容树。
unmarshal(XMLReader, InputSource) - Method in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
使用指定的XMLReader和InputSource解组合对象。
unmarshal(ValueType) - Method in class javax.xml.bind.annotation.adapters. XmlAdapter
将值类型转换为绑定类型。
unmarshal(XmlNode) - Method in class javax.xml.bind. Binder
将XML信息集视图解组到JAXB对象树。
unmarshal(XmlNode, Class<T>) - Method in class javax.xml.bind. Binder
通过向JAXB对象树提供 declaredType解组XML根元素。
UnmarshalException - Exception in java.rmi
如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出一个 UnmarshalException ：如果发生异常时 java.io.IOException调用头，如果返回值的协议如果 java.io.IOException发生解组参数（on服务器端）或返回值（在客户端）。
UnmarshalException - Exception in javax.xml.bind
此异常表示执行卸载操作时发生错误，阻止JAXB提供程序完成操作。
UnmarshalException(String) - Constructor for exception java.rmi. UnmarshalException
构造具有指定详细消息的 UnmarshalException 。
UnmarshalException(String) - Constructor for exception javax.xml.bind. UnmarshalException
使用指定的详细消息构造UnmarshalException。
UnmarshalException(String, Exception) - Constructor for exception java.rmi. UnmarshalException
构造具有指定的详细消息和嵌套异常的 UnmarshalException 。
UnmarshalException(String, String) - Constructor for exception javax.xml.bind. UnmarshalException
使用指定的详细消息和供应商特定的错误代码构造UnmarshalException。
UnmarshalException(String, String, Throwable) - Constructor for exception javax.xml.bind. UnmarshalException
构造具有指定的详细消息，供应商特定的错误代码和linkedException的UnmarshalException。
UnmarshalException(String, Throwable) - Constructor for exception javax.xml.bind. UnmarshalException
使用指定的详细消息和linkedException构造UnmarshalException。
UnmarshalException(Throwable) - Constructor for exception javax.xml.bind. UnmarshalException
使用linkedException构造UnmarshalException。
unmarshalKeyInfo(XMLStructure) - Method in class javax.xml.crypto.dsig.keyinfo. KeyInfoFactory
从机制特定的XMLStructure （例如： DOMStructure ）实例解组新的KeyInfo实例。
Unmarshaller - Interface in javax.xml.bind
Unmarshaller类控制将XML数据反序列化为新创建的Java内容树的过程，可选地在未编组的情况下验证XML数据。
Unmarshaller.Listener - Class in javax.xml.bind
使用Unmarshaller注册此类实现的实例，以外部侦听未散布的事件。
UnmarshallerHandler - Interface in javax.xml.bind
Unmarshaller实现为SAX ContentHandler。
unmarshalXMLSignature(XMLValidateContext) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
解组新的 XMLSignature从特定于机制的实例 XMLValidateContext实例。
unmarshalXMLSignature(XMLStructure) - Method in class javax.xml.crypto.dsig. XMLSignatureFactory
解组新的 XMLSignature从特定于机制的实例 XMLStructure实例。
UnmodifiableClassException - Exception in java.lang.instrument
当其中一个指定的类不能修改时，通过实现 Instrumentation.redefineClasses抛出。
UnmodifiableClassException() - Constructor for exception java.lang.instrument. UnmodifiableClassException
构造一个 UnmodifiableClassException ，没有详细信息。
UnmodifiableClassException(String) - Constructor for exception java.lang.instrument. UnmodifiableClassException
构造具有指定详细消息的 UnmodifiableClassException 。
unmodifiableCollection(Collection<? extends T>) - Static method in class java.util. Collections
返回指定集合的不可修改视图。
unmodifiableList(List<? extends T>) - Static method in class java.util. Collections
返回指定列表的不可修改视图。
unmodifiableMap(Map<? extends K, ? extends V>) - Static method in class java.util. Collections
返回指定地图的不可修改视图。
UnmodifiableModuleException - Exception in java.lang.instrument
抛出以表示模块无法修改。
UnmodifiableModuleException() - Constructor for exception java.lang.instrument. UnmodifiableModuleException
构造一个 UnmodifiableModuleException ，没有详细信息。
UnmodifiableModuleException(String) - Constructor for exception java.lang.instrument. UnmodifiableModuleException
构造具有指定详细消息的 UnmodifiableModuleException 。
unmodifiableNavigableMap(NavigableMap<K, ? extends V>) - Static method in class java.util. Collections
返回指定可导航地图的不可修改视图。
unmodifiableNavigableSet(NavigableSet<T>) - Static method in class java.util. Collections
返回指定的可导航集合的不可修改的视图。
unmodifiableObservableList(ObservableList<E>) - Static method in class javafx.collections. FXCollections
在提供的可观察列表之上创建并返回不可修改的包装器列表。
unmodifiableObservableMap(ObservableMap<K, V>) - Static method in class javafx.collections. FXCollections
构造一个只读接口到指定的ObservableMap。
unmodifiableObservableSet(ObservableSet<E>) - Static method in class javafx.collections. FXCollections
在提供的可观察集合之上创建并返回不可修改的包装器。
unmodifiableSet(Set<? extends T>) - Static method in class java.util. Collections
返回指定集合的不可修改视图。
UnmodifiableSetException - Exception in javax.print.attribute
抛出以表示所请求的操作无法执行，因为该集合是不可修改的。
UnmodifiableSetException() - Constructor for exception javax.print.attribute. UnmodifiableSetException
构造一个没有详细消息的UnsupportedOperationException。
UnmodifiableSetException(String) - Constructor for exception javax.print.attribute. UnmodifiableSetException
构造具有指定详细消息的UnmodifiableSetException。
unmodifiableSortedMap(SortedMap<K, ? extends V>) - Static method in class java.util. Collections
返回指定排序映射的不可修改视图。
unmodifiableSortedSet(SortedSet<T>) - Static method in class java.util. Collections
返回指定排序集的不可修改视图。
unmodifiableView(AttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities
创建给定属性集的不可修改的视图。
unmodifiableView(DocAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities
创建给定doc属性集的不可修改的视图。
unmodifiableView(PrintJobAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities
创建给定打印作业属性集的不可修改的视图。
unmodifiableView(PrintRequestAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities
创建给定打印请求属性集的不可修改的视图。
unmodifiableView(PrintServiceAttributeSet) - Static method in class javax.print.attribute. AttributeSetUtilities
创建给定打印服务属性集的不可修改的视图。
UNNECESSARY - java.math. RoundingMode
舍入模式来确定所请求的操作具有精确的结果，因此不需要舍入。
UNNECESSARY - Static variable in class java.awt. GraphicsConfigTemplate
用于“Enum”（整数）类型的值。
unordered() - Method in interface java.util.stream. BaseStream
返回等效的流，即 unordered 。
unordered(boolean) - Method in class com.sun.nio.sctp. MessageInfo
设置消息是否无序。
UNORDERED - java.util.stream. Collector.Characteristics
表示收集操作不承诺保留输入元素的遇到顺序。
UNORDERED_NODE_ITERATOR_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是由定义的节点集将被迭代地访问，这可能不以特定顺序产生节点。
UNORDERED_NODE_SNAPSHOT_TYPE - Static variable in interface org.w3c.dom.xpath. XPathResult
结果是由其定义的节点集将作为可能不是特定顺序的节点的快照列表被访问。
unpack(File, JarOutputStream) - Method in interface java.util.jar. Pack200.Unpacker
读取Pack200存档，并将编码的JAR写入JarOutputStream。
unpack(InputStream, JarOutputStream) - Method in interface java.util.jar. Pack200.Unpacker
读取Pack200存档，并将编码的JAR写入JarOutputStream。
unpack200 - Search tag in jdk.pack
unpack200 tool
unpark(Thread) - Static method in class java.util.concurrent.locks. LockSupport
为给定的线程提供许可证（如果尚未提供）。
unparsedEntityDecl(String, String, String, String) - Method in interface org.xml.sax. DTDHandler
接收未解析的实体声明事件的通知。
unparsedEntityDecl(String, String, String, String) - Method in class org.xml.sax. HandlerBase
已过时。
收到未分类实体声明的通知。
unparsedEntityDecl(String, String, String, String) - Method in class org.xml.sax.helpers. DefaultHandler
收到未分类实体声明的通知。
unparsedEntityDecl(String, String, String, String) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤未解析的实体声明事件。
UNQUALIFIED - javax.xml.bind.annotation. XmlNsForm
unquote(String) - Static method in class javax.management. ObjectName
返回给定String的无引号形式。
UNQUOTED - com.sun.source.doctree. AttributeTree.ValueKind
属性值不包含在引号中。
unread(byte[]) - Method in class java.io. PushbackInputStream
将一个字节数组复制回推回缓冲区的前端。
unread(byte[], int, int) - Method in class java.io. PushbackInputStream
通过将字节数组复制到推回缓冲区的前端来推回一部分数组。
unread(char[]) - Method in class java.io. PushbackReader
将一个字符数组复制回推回缓冲区的前端。
unread(char[], int, int) - Method in class java.io. PushbackReader
通过将一部分字符复制到推回缓冲区的前端来推回。
unread(int) - Method in class java.io. PushbackInputStream
通过将其复制到推回缓冲区的前端来推回一个字节。
unread(int) - Method in class java.io. PushbackReader
将单个字符复制回推回缓冲区的前端。
UNRECOGNIZED_CRIT_EXT - java.security.cert. PKIXReason
证书包含一个或多个无法识别的关键扩展。
UnrecoverableEntryException - Exception in java.security
如果密钥库中的条目无法恢复，则抛出此异常。
UnrecoverableEntryException() - Constructor for exception java.security. UnrecoverableEntryException
构造一个不可恢复的EntryException，没有详细的消息。
UnrecoverableEntryException(String) - Constructor for exception java.security. UnrecoverableEntryException
构造具有指定的详细消息的UnrecoverableEntryException，它提供了有关为什么抛出此异常的更多信息。
UnrecoverableKeyException - Exception in java.security
如果密钥存储库中的密钥无法恢复，则抛出此异常。
UnrecoverableKeyException() - Constructor for exception java.security. UnrecoverableKeyException
构造不可恢复的KeyException，没有详细消息。
UnrecoverableKeyException(String) - Constructor for exception java.security. UnrecoverableKeyException
构造一个具有指定的详细信息的UnrecoverableKeyException，它提供了有关为什么抛出此异常的更多信息。
unreferenced() - Method in interface java.rmi.server. Unreferenced
运行时确定引用列表（引用远程对象的客户端列表）变为空时，由RMI运行时调用。
unreferenced() - Method in class javax.management.remote.rmi. RMIConnectionImpl
Unreferenced - Interface in java.rmi.server
当没有更多的客户端引用该远程对象时，远程对象实现应实现 Unreferenced接口以接收通知。
unreflect(MethodHandles.Lookup, Method) - Static method in class jdk.dynalink.linker.support. Lookup
执行MethodHandles.Lookup.unreflect(Method) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
unreflect(Method) - Method in class java.lang.invoke. MethodHandles.Lookup
如果查找类具有权限，则创建一个 direct method handle的 m 。
unreflect(Method) - Method in class jdk.dynalink.linker.support. Lookup
执行MethodHandles.Lookup.unreflect(Method) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
unreflectConstructor(MethodHandles.Lookup, Constructor<?>) - Static method in class jdk.dynalink.linker.support. Lookup
执行MethodHandles.Lookup.unreflectConstructor(Constructor) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
unreflectConstructor(Constructor<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
为反射的构造函数生成方法句柄。
unreflectConstructor(Constructor<?>) - Method in class jdk.dynalink.linker.support. Lookup
执行MethodHandles.Lookup.unreflectConstructor(Constructor) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
unreflectGetter(Field) - Method in class java.lang.invoke. MethodHandles.Lookup
产生方法句柄，给予反映字段的读访问权限。
unreflectGetter(Field) - Method in class jdk.dynalink.linker.support. Lookup
执行MethodHandles.Lookup.unreflectGetter(Field) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
unreflectSetter(Field) - Method in class java.lang.invoke. MethodHandles.Lookup
产生一个方法句柄，给一个反射的字段写权限。
unreflectSetter(Field) - Method in class jdk.dynalink.linker.support. Lookup
执行MethodHandles.Lookup.unreflectSetter(Field) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
unreflectSpecial(Method, Class<?>) - Method in class java.lang.invoke. MethodHandles.Lookup
为反映的方法生成方法句柄。
unreflectVarHandle(Field) - Method in class java.lang.invoke. MethodHandles.Lookup
产生一个VarHandle，可访问 f类中声明的类型为 T的反射字段 R 。
unregister(ActivationID) - Static method in class java.rmi.activation. Activatable
id与 id相关联的激活描述符的先前注册。
unregister_value_factory(String) - Method in class org.omg.CORBA_2_3. ORB
unregisterChangeListeners(ObservableValue<?>) - Method in class javafx.scene.control. SkinBase
取消注册已使用 SkinBase.registerChangeListener(ObservableValue, Consumer)为给定属性注册的所有更改侦听器。
unregisterComponent(JComponent) - Method in class javax.swing. ToolTipManager
从工具提示控件中删除组件。
unregisterGroup(ActivationGroupID) - Method in interface java.rmi.activation. ActivationSystem
删除激活组。
unregisterKeyboardAction(KeyStroke) - Method in class javax.swing. JComponent
这种方法现在已经过时了。
unregisterKeyboardActions() - Method in class javax.swing.plaf.basic. BasicDesktopPaneUI
取消注册键盘操作。
unregisterListeners() - Method in class java.awt.dnd. DragGestureRecognizer
使用Component子类取消注册此DragGestureRecognizer的侦听器必须覆盖此方法
unregisterListeners() - Method in class java.awt.dnd. MouseDragGestureRecognizer
使用Component子类取消注册此DragGestureRecognizer的侦听器必须覆盖此方法
unregisterMBean(ObjectName) - Method in interface javax.management. MBeanServer
从MBean服务器取消注册MBean。
unregisterMBean(ObjectName) - Method in interface javax.management. MBeanServerConnection
从MBean服务器取消注册MBean。
unregisterMBean(ObjectName, Subject) - Method in interface javax.management.remote.rmi. RMIConnection
处理方法 MBeanServerConnection.unregisterMBean(ObjectName) 。
unregisterMBean(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl_Stub
unregisterMBean(ObjectName, Subject) - Method in class javax.management.remote.rmi. RMIConnectionImpl
unregisterObject(ActivationID) - Method in interface java.rmi.activation. ActivationSystem
删除以前注册的激活ID和关联的描述ActivationSystem ; 该对象不能再通过对象的激活标识被激活。
unregisterProvider(String) - Static method in class javax.sql.rowset.spi. SyncFactory
从工厂SPI寄存器中删除指定的当前注册的同步提供程序。
UNREGISTRATION_NOTIFICATION - Static variable in class javax.management. MBeanServerNotification
通知类型表示MBean已被注销。
UNRELATED - javax.swing. LayoutStyle.ComponentPlacement
指示两个组件的枚举值在视觉上不相关，并将放置在同一个父项中。
UnresolvedAddressException - Exception in java.nio.channels
尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
UnresolvedAddressException() - Constructor for exception java.nio.channels. UnresolvedAddressException
构造这个类的一个实例。
unresolvedDependencies(DeclarationSnippet) - Method in class jdk.jshell. JShell
对于 RECOVERABLE_DEFINED或 RECOVERABLE_NOT_DEFINED声明，代码段的当前未解析的依赖关系的名称。
UnresolvedPermission - Class in java.security
UnresolvedPermission类用于保存初始化策略时“未解决”的权限。
UnresolvedPermission(String, String, String, Certificate[]) - Constructor for class java.security. UnresolvedPermission
创建一个新的UnresolvedPermission，当权限解决时，包含稍后实际创建指定类的权限所需的权限信息。
UnresolvedReferenceException - Exception in jdk.jshell
在尝试执行 RECOVERABLE_DEFINED代码段时报告异常。
UnsatisfiedLinkError - Error in java.lang
如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。
UnsatisfiedLinkError() - Constructor for error java.lang. UnsatisfiedLinkError
构造一个 UnsatisfiedLinkError ，没有详细信息。
UnsatisfiedLinkError(String) - Constructor for error java.lang. UnsatisfiedLinkError
构造具有指定详细消息的 UnsatisfiedLinkError 。
unscaledValue() - Method in class java.math. BigDecimal
返回一个 BigInteger其值是此 BigDecimal的非 标度值 。
UNSELECTED_CONVERTED - javafx.scene.input. InputMethodHighlight
用于未选择的转换输入法文本的突出显示
UNSELECTED_CONVERTED_TEXT_HIGHLIGHT - Static variable in class java.awt.im. InputMethodHighlight
未选择转换文本的默认高亮的常数。
UNSELECTED_RAW - javafx.scene.input. InputMethodHighlight
用于未选择的原始输入法文本的突出显示
UNSELECTED_RAW_TEXT_HIGHLIGHT - Static variable in class java.awt.im. InputMethodHighlight
未选择的原始文本的默认突出显示的常数。
UNSEQ_TOKEN - Static variable in exception org.ietf.jgss. GSSException
后来的令牌已被处理。
UNSET - javax.xml.bind.annotation. XmlNsForm
UNSET - Static variable in class javax.swing. Spring
表示属性值尚未计算的整数值。
UNSET - Static variable in class jdk.net. SocketFlow
unsetCompression() - Method in class javax.imageio. ImageWriteParam
删除任何以前的压缩类型和质量设置。
unsetCompression() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam
删除任何以前的压缩质量设置。
unsetDecodeTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageReadParam
删除当前设置的任何量化和霍夫曼表。
unsetEncodeTables() - Method in class javax.imageio.plugins.jpeg. JPEGImageWriteParam
删除当前设置的任何量化和霍夫曼表。
unsetMatchColumn(int) - Method in interface javax.sql.rowset. Joinable
将指定的列 RowSet为此 RowSet对象的匹配列。
unsetMatchColumn(int[]) - Method in interface javax.sql.rowset. Joinable
将指定的列 RowSet为此 RowSet对象的匹配列。
unsetMatchColumn(String) - Method in interface javax.sql.rowset. Joinable
将指定的列 RowSet为该 RowSet对象的匹配列。
unsetMatchColumn(String[]) - Method in interface javax.sql.rowset. Joinable
将指定的列 RowSet为此 RowSet对象的匹配列。
unsetOrdering(Class<T>, T, T) - Method in class javax.imageio.spi. ServiceRegistry
在给定类别中的两个服务提供者对象之间设置成对排序。
unsetTiling() - Method in class javax.imageio. ImageWriteParam
删除通过调用 setTiling指定的任何以前的瓦片网格参数。
UNSIGNED_RIGHT_SHIFT - com.sun.source.tree. Tree.Kind
用于实例BinaryTree表示无符号右移>>> 。
UNSIGNED_RIGHT_SHIFT - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree表示无符号右移>>> 。
UNSIGNED_RIGHT_SHIFT_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于实例CompoundAssignmentTree表示无符号右移分配>>>= 。
UNSIGNED_RIGHT_SHIFT_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例CompoundAssignmentTree表示无符号右移分配>>>= 。
UnsolicitedNotification - Interface in javax.naming.ldap
该接口表示 RFC 2251中定义的非请求通知。
UnsolicitedNotificationEvent - Class in javax.naming.ldap
此类表示响应LDAP服务器发送的未经请求的通知触发的事件。
UnsolicitedNotificationEvent(Object, UnsolicitedNotification) - Constructor for class javax.naming.ldap. UnsolicitedNotificationEvent
构造一个新的实例 UnsolicitedNotificationEvent 。
UnsolicitedNotificationListener - Interface in javax.naming.ldap
此接口用于处理 UnsolicitedNotificationEvent 。
UNSORTED - javax.swing. SortOrder
指示项目的枚举值无序。
UNSPECIFIED - java.awt.desktop. UserSessionEvent.Reason
系统不提供会话更改的原因。
UNSPECIFIED - java.security.cert. CertPathValidatorException.BasicReason
不明原因
UNSPECIFIED - java.security.cert. CRLReason
这个原因表明，为什么证书被撤销是不明确的。
UNSPECIFIED_EVENT_TYPE_ERR - Static variable in exception org.w3c.dom.events. EventException
如果 Event的类型没有通过在方法被调用之前初始化事件来指定。
UNSPECIFIED_OPTION - Static variable in class javax.security.auth.callback. ConfirmationCallback
未指定的选项类型。
unsubscribe(JShell.Subscription) - Method in class jdk.jshell. JShell
取消回拨订阅。
UNSUPPORTED_COMPRESSION - Static variable in class javax.print.attribute.standard. JobStateReason
该作业被系统中止，因为打印机在尝试解压缩文档数据时确定压缩实际上不在打印机支持的那些之间。
UNSUPPORTED_DOCUMENT_FORMAT - Static variable in class javax.print.attribute.standard. JobStateReason
该作业被系统中止，因为文档数据的文档格式（doc flavor）不在打印机支持的文档格式之中。
UNSUPPORTED_EMPTY_COLLECTION - Static variable in class java.security. Policy
只读空PermissionCollection实例。
UNSUPPORTED_POLICY - Interface in org.omg.CORBA
其中的 PolicyErrorCode S的将被填补，如果被请求 Policy了解由ORB认为是有效的，但目前还不支持。
UNSUPPORTED_POLICY_VALUE - Interface in org.omg.CORBA
A PolicyErrorCode ，如果为 Policy请求的值为有效类型且在该类型的有效范围内，则将填充该值，但此当前不支持此有效值。
UnsupportedAddressTypeException - Exception in java.nio.channels
尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。
UnsupportedAddressTypeException() - Constructor for exception java.nio.channels. UnsupportedAddressTypeException
构造这个类的一个实例。
UnsupportedAudioFileException - Exception in javax.sound.sampled
一个 UnsupportedAudioFileException是一个例外，指出一个操作失败，因为一个文件没有包含一个被识别的文件类型和格式的有效数据。
UnsupportedAudioFileException() - Constructor for exception javax.sound.sampled. UnsupportedAudioFileException
构造一个 UnsupportedAudioFileException ，其中有 null作为其错误详细消息。
UnsupportedAudioFileException(String) - Constructor for exception javax.sound.sampled. UnsupportedAudioFileException
构造一个具有指定详细消息的 UnsupportedAudioFileException 。
UnsupportedCallbackException - Exception in javax.security.auth.callback
信号一个 CallbackHandler不识别一个特定的 Callback 。
UnsupportedCallbackException(Callback) - Constructor for exception javax.security.auth.callback. UnsupportedCallbackException
构造一个 UnsupportedCallbackException ，没有详细消息。
UnsupportedCallbackException(Callback, String) - Constructor for exception javax.security.auth.callback. UnsupportedCallbackException
构造具有指定详细消息的UnsupportedCallbackException。
UnsupportedCharsetException - Exception in java.nio.charset
对于请求的字符集，当没有可用的支持时抛出未检查的异常。
UnsupportedCharsetException(String) - Constructor for exception java.nio.charset. UnsupportedCharsetException
构造这个类的一个实例。
UnsupportedClassVersionError - Error in java.lang
当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
UnsupportedClassVersionError() - Constructor for error java.lang. UnsupportedClassVersionError
构造一个 UnsupportedClassVersionError ，没有详细信息。
UnsupportedClassVersionError(String) - Constructor for error java.lang. UnsupportedClassVersionError
构造具有指定详细消息的 UnsupportedClassVersionError 。
UnsupportedDataTypeException - Exception in javax.activation
表示请求的操作不支持请求的数据类型。
UnsupportedDataTypeException() - Constructor for exception javax.activation. UnsupportedDataTypeException
构造一个UnsupportedDataTypeException，没有详细消息。
UnsupportedDataTypeException(String) - Constructor for exception javax.activation. UnsupportedDataTypeException
构造具有指定消息的UnsupportedDataTypeException。
UnsupportedEncodingException - Exception in java.io
字符编码不支持。
UnsupportedEncodingException() - Constructor for exception java.io. UnsupportedEncodingException
构造一个UnsupportedEncodingException而不显示详细消息。
UnsupportedEncodingException(String) - Constructor for exception java.io. UnsupportedEncodingException
构造具有详细消息的UnsupportedEncodingException。
UnsupportedFlavorException - Exception in java.awt.datatransfer
表示在此风格中不支持请求的数据。
UnsupportedFlavorException(DataFlavor) - Constructor for exception java.awt.datatransfer. UnsupportedFlavorException
构造一个UnsupportedFlavorException。
UnsupportedLookAndFeelException - Exception in javax.swing
表示所请求的外观和感觉管理类的异常不在用户系统上。
UnsupportedLookAndFeelException(String) - Constructor for exception javax.swing. UnsupportedLookAndFeelException
构造一个UnsupportedLookAndFeelException对象。
UnsupportedOperationException - Exception in java.lang
抛出以表示不支持请求的操作。
UnsupportedOperationException() - Constructor for exception java.lang. UnsupportedOperationException
构造一个没有详细消息的UnsupportedOperationException。
UnsupportedOperationException(String) - Constructor for exception java.lang. UnsupportedOperationException
构造具有指定详细消息的UnsupportedOperationException。
UnsupportedOperationException(String, Throwable) - Constructor for exception java.lang. UnsupportedOperationException
构造一个新的异常与指定的详细信息和原因。
UnsupportedOperationException(Throwable) - Constructor for exception java.lang. UnsupportedOperationException
构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
UnsupportedTemporalTypeException - Exception in java.time.temporal
UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。
UnsupportedTemporalTypeException(String) - Constructor for exception java.time.temporal. UnsupportedTemporalTypeException
使用指定的消息构造一个新的UnsupportedTemporalTypeException。
UnsupportedTemporalTypeException(String, Throwable) - Constructor for exception java.time.temporal. UnsupportedTemporalTypeException
构造一个新的UnsupportedTemporalTypeException与指定的消息和原因。
unsynchronize(Line[]) - Method in interface javax.sound.sampled. Mixer
释放指定行的同步。
until(ChronoLocalDate) - Method in interface java.time.chrono. ChronoLocalDate
计算此日期和另一个日期之间的期间为 ChronoPeriod 。
until(ChronoLocalDate) - Method in class java.time.chrono. HijrahDate
until(ChronoLocalDate) - Method in class java.time.chrono. JapaneseDate
until(ChronoLocalDate) - Method in class java.time.chrono. MinguoDate
until(ChronoLocalDate) - Method in class java.time.chrono. ThaiBuddhistDate
until(ChronoLocalDate) - Method in class java.time. LocalDate
将此日期和其他日期之间的期间计算为 Period 。
until(Temporal, TemporalUnit) - Method in interface java.time.chrono. ChronoLocalDate
根据指定的单位计算直到另一个日期的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. Instant
根据指定单位计算直到另一瞬间的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. LocalDate
根据指定的单位计算直到另一个日期的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. LocalDateTime
根据指定的单位计算到另一个日期时间的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. LocalTime
根据指定的单位计算直到另一次的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. OffsetDateTime
根据指定的单位计算到另一个日期时间的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. OffsetTime
根据指定的单位计算直到另一次的时间量。
until(Temporal, TemporalUnit) - Method in interface java.time.temporal. Temporal
根据指定的单位计算直到另一个时间的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. Year
根据指定单位计算直到另一年的时间。
until(Temporal, TemporalUnit) - Method in class java.time. YearMonth
根据指定单位计算直到另一个一个月的时间量。
until(Temporal, TemporalUnit) - Method in class java.time. ZonedDateTime
根据指定的单位计算到另一个日期时间的时间量。
UNUSED - java.security.cert. CRLReason
没用的原因
unwrap() - Method in class java.lang.invoke. MethodType
将所有包装类型转换为相应的原始类型。
unwrap(byte[], int, int) - Method in interface javax.security.sasl. SaslClient
解开从服务器接收的字节数组。
unwrap(byte[], int, int) - Method in interface javax.security.sasl. SaslServer
展开从客户端接收的字节数组。
unwrap(byte[], int, int, MessageProp) - Method in interface org.ietf.jgss. GSSContext
用于在上下文的另一边处理由 wrap方法生成的令牌。
unwrap(byte[], String, int) - Method in class javax.crypto. Cipher
打开以前包装的钥匙。
unwrap(InputStream, OutputStream, MessageProp) - Method in interface org.ietf.jgss. GSSContext
在上下文的另一边使用流处理由 wrap方法生成的令牌。
unwrap(Class<T>) - Method in interface java.sql. Wrapper
返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。
unwrap(Class<T>) - Method in class javax.sql.rowset. RowSetMetaDataImpl
返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。
unwrap(Object) - Static method in class jdk.nashorn.api.scripting. ScriptUtils
如果需要，可以解开脚本对象镜像。
unwrap(Object, Object) - Static method in class jdk.nashorn.api.scripting. ScriptObjectMirror
如果需要，可以解开脚本对象镜像。
unwrap(ByteBuffer, ByteBuffer) - Method in class javax.net.ssl. SSLEngine
尝试将SSL / TLS / DTLS网络数据解码为明文应用数据缓冲区。
unwrap(ByteBuffer, ByteBuffer[]) - Method in class javax.net.ssl. SSLEngine
尝试将SSL / TLS / DTLS网络数据解码为一系列明文应用程序数据缓冲区。
unwrap(ByteBuffer, ByteBuffer[], int, int) - Method in class javax.net.ssl. SSLEngine
尝试将SSL / TLS / DTLS网络数据解码为明文应用程序数据缓冲区的子序列。
UNWRAP_MODE - Static variable in class javax.crypto. Cipher
常数用于将密码初始化为密钥解包模式。
unwrapArray(Object[]) - Static method in class jdk.nashorn.api.scripting. ScriptUtils
如果需要，展开一组脚本对象镜像。
unwrapArray(Object[], Object) - Static method in class jdk.nashorn.api.scripting. ScriptObjectMirror
如果需要，展开一组脚本对象镜像。
UP - java.math. RoundingMode
舍入模式从零开始。
UP - javafx.geometry. VerticalDirection
向上的方向
UP - javafx.scene.control.skin. TextInputControlSkin.Direction
UP - javafx.scene.input. KeyCode
常数为非numpad 向上箭头键。
UP - javafx.scene.input. KeyCombination.ModifierValue
表示修饰符键必须为常数的常数。
UP - Static variable in class java.awt. Event
已过时。
向上箭头键，非ASCII操作键。
UP_CYCLE_TRAVERSAL_KEYS - Static variable in class java.awt. KeyboardFocusManager
上传周期聚焦遍历键的标识符。
upAction - Static variable in class javax.swing.text. DefaultEditorKit
将插入符号向上移动一个位置的操作名称。
UPDATABLE_VIEW_SYNC - Static variable in class javax.sql.rowset.spi. SyncProvider
表示 SyncProvider实现支持 RowSet对象与用于填充对象的SQL VIEW之间的同步。
update() - Method in class java.awt. SplashScreen
使用覆盖图像的当前内容更新启动窗口。
update(byte) - Method in class java.security. MessageDigest
使用指定的字节更新摘要。
update(byte) - Method in class java.security. Signature
更新要由一个字节签名或验证的数据。
update(byte) - Method in class javax.crypto. Mac
处理给定的字节。
update(byte[]) - Method in class java.security. MessageDigest
使用指定的字节数组更新摘要。
update(byte[]) - Method in class java.security. Signature
使用指定的字节数组更新要签名或验证的数据。
update(byte[]) - Method in interface java.util.zip. Checksum
使用指定的字节数组更新当前的校验和。
update(byte[]) - Method in class javax.crypto. Cipher
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
update(byte[]) - Method in class javax.crypto. Mac
处理给定的字节数组。
update(byte[], int, int) - Method in class java.security. MessageDigest
使用指定的字节数组从指定的偏移量开始更新摘要。
update(byte[], int, int) - Method in class java.security. Signature
使用指定的字节数组从指定的偏移量更新要签名或验证的数据。
update(byte[], int, int) - Method in class java.util.zip. Adler32
用指定的字节数组更新校验和。
update(byte[], int, int) - Method in interface java.util.zip. Checksum
使用指定的字节数组更新当前的校验和。
update(byte[], int, int) - Method in class java.util.zip. CRC32
用指定的字节数组更新CRC-32校验和。
update(byte[], int, int) - Method in class java.util.zip. CRC32C
用指定的字节数组更新CRC-32C校验和。
update(byte[], int, int) - Method in class javax.crypto. Cipher
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
update(byte[], int, int) - Method in class javax.crypto. Mac
在 input处理第 len个字节，从 offset开始。
update(byte[], int, int, byte[]) - Method in class javax.crypto. Cipher
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
update(byte[], int, int, byte[], int) - Method in class javax.crypto. Cipher
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
update(int) - Method in class java.util.zip. Adler32
用指定的字节更新校验和（参数b的低8位）。
update(int) - Method in interface java.util.zip. Checksum
用指定的字节更新当前的校验和。
update(int) - Method in class java.util.zip. CRC32
用指定的字节（参数b的低8位）更新CRC-32校验和。
update(int) - Method in class java.util.zip. CRC32C
用指定的字节（参数b的低8位）更新CRC-32C校验和。
update(Graphics) - Method in class java.awt. Canvas
更新此画布。
update(Graphics) - Method in class java.awt. Component
更新此组件。
update(Graphics) - Method in class java.awt. Container
更新容器。
update(Graphics) - Method in class javax.swing. CellRendererPane
不应该叫
update(Graphics) - Method in class javax.swing. JApplet
已过时。
只需拨打 paint(g) 。
update(Graphics) - Method in class javax.swing. JComponent
致电 paint 。
update(Graphics) - Method in class javax.swing. JDialog
致电 paint(g) 。
update(Graphics) - Method in class javax.swing. JFrame
只需拨打 paint(g) 。
update(Graphics) - Method in class javax.swing. JWindow
致电 paint(g) 。
update(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicMenuItemUI
我们在paintMenuItem（）中绘制背景，因此覆盖更新（默认填写不透明组件的背景）来调用paint（）。
update(Graphics, JComponent) - Method in class javax.swing.plaf.basic. BasicTextUI
Superclass以不可控制的方式绘制背景（即可能需要将图像平铺到背景中）。
update(Graphics, JComponent) - Method in class javax.swing.plaf. ComponentUI
通知这个UI委托是时候绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalButtonUI
如果需要涂抹组件的背景，然后调用 paint 。
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalMenuBarUI
如果需要涂抹组件的背景，然后调用 paint 。
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalTabbedPaneUI
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalToggleButtonUI
如果需要涂抹组件的背景，然后调用 paint 。
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal. MetalToolBarUI
如果需要涂抹组件的背景，然后调用 paint 。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiButtonUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiColorChooserUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiComboBoxUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopIconUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiDesktopPaneUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiFileChooserUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiInternalFrameUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiLabelUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiListUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiMenuBarUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiMenuItemUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiOptionPaneUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiPanelUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiPopupMenuUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiProgressBarUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiRootPaneUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiScrollBarUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiScrollPaneUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSeparatorUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSliderUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSpinnerUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiSplitPaneUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTabbedPaneUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTableHeaderUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTableUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTextUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiToolBarUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiToolTipUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiTreeUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi. MultiViewportUI
在此对象处理的每个UI上调用 update方法。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthButtonUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthColorChooserUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthComboBoxUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthDesktopIconUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthDesktopPaneUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthEditorPaneUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthInternalFrameUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthLabelUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthListUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthMenuBarUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthMenuItemUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthMenuUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthOptionPaneUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthPanelUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthPopupMenuUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthProgressBarUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthRootPaneUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthScrollBarUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthScrollPaneUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSeparatorUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSliderUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSpinnerUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthSplitPaneUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTabbedPaneUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTableHeaderUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTableUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTextAreaUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTextFieldUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthToolBarUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthToolTipUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthTreeUI
通知此UI代理重新绘制指定的组件。
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth. SynthViewportUI
通知此UI代理重新绘制指定的组件。
update(ByteBuffer) - Method in class java.security. MessageDigest
使用指定的ByteBuffer更新摘要。
update(ByteBuffer) - Method in class java.security. Signature
使用指定的ByteBuffer更新要签名或验证的数据。
update(ByteBuffer) - Method in class java.util.zip. Adler32
使用指定缓冲区的字节更新校验和。
update(ByteBuffer) - Method in interface java.util.zip. Checksum
使用指定缓冲区的字节更新当前校验和。
update(ByteBuffer) - Method in class java.util.zip. CRC32
用指定缓冲区的字节更新CRC-32校验和。
update(ByteBuffer) - Method in class java.util.zip. CRC32C
用指定缓冲区的字节更新CRC-32C校验和。
update(ByteBuffer) - Method in class javax.crypto. Mac
处理 input.remaining()字节的ByteBuffer input ，从 input.position()开始。
update(ByteBuffer, ByteBuffer) - Method in class javax.crypto. Cipher
继续进行多部分加密或解密操作（取决于如何初始化该密码），处理另一个数据部分。
update(Observable, Object) - Method in interface java.util. Observer
已过时。
每当观察到的对象发生变化时，都会调用此方法。
update(LineEvent) - Method in interface javax.sound.sampled. LineListener
通知侦听器一行的状态已更改。
UPDATE - Static variable in class java.awt.event. PaintEvent
更新事件类型。
UPDATE - Static variable in interface javax.accessibility. AccessibleTableModelChange
标识对现有数据的更改。
UPDATE - Static variable in class javax.swing.event. TableModelEvent
标识对现有数据的更改。
UPDATE_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi. SyncResolver
表示当 RowSet对象尝试更新数据源中的行时发生冲突。
UPDATE_WHEN_ON_EDT - Static variable in class javax.swing.text. DefaultCaret
表示只有在事件调度线程上执行文档更改时，才会更新插入位置。
updateAAD(byte[]) - Method in class javax.crypto. Cipher
继续进行附加认证数据（AAD）的多部分更新。
updateAAD(byte[], int, int) - Method in class javax.crypto. Cipher
使用所提供的缓冲区的子集，继续进行附加认证数据（AAD）的多部分更新。
updateAAD(ByteBuffer) - Method in class javax.crypto. Cipher
继续进行附加认证数据（AAD）的多部分更新。
UpdateAction() - Constructor for class javax.swing.plaf.basic. BasicFileChooserUI.UpdateAction
updateAndGet(int, IntUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素与应用给定函数的结果，返回更新的值。
updateAndGet(int, LongUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongArray
使用索引 i的元素与应用给定函数的结果进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
updateAndGet(int, UnaryOperator<E>) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）索引号为 i的元素与应用给定函数的结果，返回更新的值。
updateAndGet(IntUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicInteger
使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
updateAndGet(LongUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicLong
使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果），返回更新的值。
updateAndGet(UnaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReference
使用给定函数的结果对当前值进行原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的存储器效果），返回更新的值。
updateAndGet(T, IntUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
通过应用给定函数的结果，原子更新（由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，返回更新的值。
updateAndGet(T, LongUnaryOperator) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater
原子更新（具有 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段与应用给定函数的结果，返回更新的值。
updateAndGet(T, UnaryOperator<V>) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater
通过应用给定函数的结果，原子更新（具有由 VarHandle.compareAndSet(java.lang.Object...)指定的内存效果）由此更新程序管理的给定对象的字段，返回更新的值。
updateArray(int, Array) - Method in interface java.sql. ResultSet
使用 java.sql.Array值更新指定的列。
updateArray(String, Array) - Method in interface java.sql. ResultSet
使用 java.sql.Array值更新指定的列。
updateAsciiStream(int, InputStream) - Method in interface java.sql. ResultSet
使用ascii流值更新指定的列。
updateAsciiStream(int, InputStream, int) - Method in interface java.sql. ResultSet
使用ascii流值更新指定的列，该值将具有指定的字节数。
updateAsciiStream(int, InputStream, long) - Method in interface java.sql. ResultSet
使用ascii流值更新指定的列，该值将具有指定的字节数。
updateAsciiStream(String, InputStream) - Method in interface java.sql. ResultSet
使用ascii流值更新指定的列。
updateAsciiStream(String, InputStream, int) - Method in interface java.sql. ResultSet
使用ascii流值更新指定的列，该值将具有指定的字节数。
updateAsciiStream(String, InputStream, long) - Method in interface java.sql. ResultSet
使用ascii流值更新指定的列，该值将具有指定的字节数。
updateAutoscroll(Point) - Method in class java.awt.dnd. DropTarget
更新当前光标位置的自动滚动
updateAxisRange() - Method in class javafx.scene.chart. AreaChart
当范围已经无效并且我们需要更新时，这被称为。
updateAxisRange() - Method in class javafx.scene.chart. BubbleChart
当范围已经无效并且我们需要更新时，这被称为。
updateAxisRange() - Method in class javafx.scene.chart. LineChart
当范围已经无效并且我们需要更新时，这被称为。
updateAxisRange() - Method in class javafx.scene.chart. StackedAreaChart
当范围已经无效并且我们需要更新时，这被称为。
updateAxisRange() - Method in class javafx.scene.chart. StackedBarChart
当范围已经无效并且我们需要更新时，这被称为。
updateAxisRange() - Method in class javafx.scene.chart. XYChart
当范围已经无效并且我们需要更新时，这被称为。
updateBigDecimal(int, BigDecimal) - Method in interface java.sql. ResultSet
使用 java.math.BigDecimal值更新指定的列。
updateBigDecimal(String, BigDecimal) - Method in interface java.sql. ResultSet
使用 java.sql.BigDecimal值更新指定的列。
updateBinaryStream(int, InputStream) - Method in interface java.sql. ResultSet
使用二进制流值更新指定的列。
updateBinaryStream(int, InputStream, int) - Method in interface java.sql. ResultSet
使用二进制流值更新指定的列，该值将具有指定的字节数。
updateBinaryStream(int, InputStream, long) - Method in interface java.sql. ResultSet
使用二进制流值更新指定的列，该值将具有指定的字节数。
updateBinaryStream(String, InputStream) - Method in interface java.sql. ResultSet
使用二进制流值更新指定的列。
updateBinaryStream(String, InputStream, int) - Method in interface java.sql. ResultSet
使用二进制流值更新指定的列，该值将具有指定的字节数。
updateBinaryStream(String, InputStream, long) - Method in interface java.sql. ResultSet
使用二进制流值更新指定的列，该值将具有指定的字节数。
updateBlob(int, InputStream) - Method in interface java.sql. ResultSet
使用给定的输入流更新指定的列。
updateBlob(int, InputStream, long) - Method in interface java.sql. ResultSet
使用给定的输入流更新指定列，该输入流将具有指定的字节数。
updateBlob(int, Blob) - Method in interface java.sql. ResultSet
使用 java.sql.Blob值更新指定的列。
updateBlob(String, InputStream) - Method in interface java.sql. ResultSet
使用给定的输入流更新指定的列。
updateBlob(String, InputStream, long) - Method in interface java.sql. ResultSet
使用给定的输入流更新指定列，该输入流将具有指定的字节数。
updateBlob(String, Blob) - Method in interface java.sql. ResultSet
使用 java.sql.Blob值更新指定的列。
updateBoolean(int, boolean) - Method in interface java.sql. ResultSet
使用 boolean值更新指定的列。
updateBoolean(String, boolean) - Method in interface java.sql. ResultSet
使用 boolean值更新指定的列。
updateBounds() - Method in class javafx.scene. Parent
updateButtonMnemonic - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
更新按钮助记符
updateButtonText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
更新按钮文本
updateButtonToolTipText - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
更新按钮工具提示文本
updateByte(int, byte) - Method in interface java.sql. ResultSet
使用 byte值更新指定的列。
updateByte(String, byte) - Method in interface java.sql. ResultSet
使用 byte值更新指定的列。
updateBytes(int, byte[]) - Method in interface java.sql. ResultSet
使用 byte数组值更新指定的列。
updateBytes(String, byte[]) - Method in interface java.sql. ResultSet
使用字节数组值更新指定的列。
updateCachedPreferredSize() - Method in class javax.swing.plaf.basic. BasicTreeUI
更新 preferredSize实例变量，从 getPreferredSize()返回。
updateCell(TableCell<T, ?>, TableRow<T>) - Method in class javafx.scene.control.skin. TableRowSkin
允许给定单元格被告知它是给定行的成员的方法。
updateCell(TreeTableCell<T, ?>, TreeTableRow<T>) - Method in class javafx.scene.control.skin. TreeTableRowSkin
允许给定单元格被告知它是给定行的成员的方法。
updateCell(R, C) - Method in class javafx.scene.control.skin. TableRowSkinBase
允许给定单元格被告知它是给定行的成员的方法。
updateCellEditor() - Method in class javax.swing.plaf.basic. BasicTreeUI
基于我们包含的JTree的可编辑性，更新cellEditor。
updateCharacterStream(int, Reader) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列。
updateCharacterStream(int, Reader, int) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列，该值将具有指定的字节数。
updateCharacterStream(int, Reader, long) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列，该值将具有指定的字节数。
updateCharacterStream(String, Reader) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列。
updateCharacterStream(String, Reader, int) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列，该值将具有指定的字节数。
updateCharacterStream(String, Reader, long) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列，该值将具有指定的字节数。
updateChildren() - Method in class javafx.scene.control.skin. CheckBoxSkin
更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。
updateChildren() - Method in class javafx.scene.control.skin. DateCellSkin
更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。
updateChildren() - Method in class javafx.scene.control.skin. LabeledSkinBase
更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。
updateChildren() - Method in class javafx.scene.control.skin. RadioButtonSkin
更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。
updateChildren() - Method in class javafx.scene.control.skin. TitledPaneSkin
更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。
updateChildren() - Method in class javafx.scene.control.skin. TreeCellSkin
更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。
updateChildren() - Method in class javafx.scene.control.skin. TreeTableRowSkin
更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - Method in class javax.swing.text. View
更新子视图以响应接收到模型更改的通知，并且此视图负责的元素有更改记录。
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - Method in class javax.swing.text. ZoneView
超类行为将尝试更新在这种情况下不希望的子视图，因为这些子节点是区域，而不是直接受关联元素的更改影响。
updateChooser() - Method in class javax.swing.colorchooser. AbstractColorChooserPanel
模型状态更改时自动调用。
updateClob(int, Reader) - Method in interface java.sql. ResultSet
使用给定的 Reader对象更新指定的列。
updateClob(int, Reader, long) - Method in interface java.sql. ResultSet
使用给定的 Reader对象更新指定的列，这是给定的字符长度。
updateClob(int, Clob) - Method in interface java.sql. ResultSet
使用 java.sql.Clob值更新指定的列。
updateClob(String, Reader) - Method in interface java.sql. ResultSet
使用给定的 Reader对象更新指定的列。
updateClob(String, Reader, long) - Method in interface java.sql. ResultSet
使用给定的 Reader对象更新指定的列，这是给定的字符数。
updateClob(String, Clob) - Method in interface java.sql. ResultSet
使用 java.sql.Clob值更新指定的列。
updateColumnHeader(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
更新列标题。
updateComponents() - Method in class javax.swing.plaf.basic. BasicSplitPaneUI.BasicHorizontalLayoutManager
确定组件。
updateComponentTreeUI(Component) - Static method in class javax.swing. SwingUtilities
一个简单的头脑的感觉变化：请问树中的每个节点是否是 updateUI() - 也就是用当前的外观来初始化它的UI属性。
updateConfiguration(InputStream, Function<String, BiFunction<String, String, String>>) - Method in class java.util.logging. LogManager
更新日志记录配置。
updateConfiguration(Function<String, BiFunction<String, String, String>>) - Method in class java.util.logging. LogManager
更新日志记录配置。
updateCurrentCursor(int, int, int) - Method in class java.awt.dnd. DragSourceContext
如果默认拖动光标行为处于活动状态，则此方法将为拖动源支持的指定操作，放置目标操作和状态设置默认拖动光标，否则此方法不执行任何操作。
updateDamage(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text. PlainView
重印给定文件事件所涉及的变化区域。
updateDate(int, Date) - Method in interface java.sql. ResultSet
使用 java.sql.Date值更新指定的列。
updateDate(String, Date) - Method in interface java.sql. ResultSet
使用 java.sql.Date值更新指定的列。
updateDepthOffset() - Method in class javax.swing.plaf.basic. BasicTreeUI
更新每个深度应该被抵消多少。
updateDouble(int, double) - Method in interface java.sql. ResultSet
使用 double值更新指定的列。
updateDouble(String, double) - Method in interface java.sql. ResultSet
使用 double值更新指定的列。
updateExpandedDescendants(TreePath) - Method in class javax.swing.plaf.basic. BasicTreeUI
通过从树中获取扩展的后代并转发到树状态来更新 path的所有后代的扩展状态。
updateFloat(int, float) - Method in interface java.sql. ResultSet
使用 float值更新指定的列。
updateFloat(String, float) - Method in interface java.sql. ResultSet
使用 float值更新指定的列。
updateHighlightFill() - Method in class javafx.scene.control.skin. TextAreaSkin
当highlightFill属性更改时调用。
updateHighlightFill() - Method in class javafx.scene.control.skin. TextInputControlSkin
当highlightFill属性更改时调用。
updateHighlightTextFill() - Method in class javafx.scene.control.skin. TextInputControlSkin
当highlightTextFill属性更改时调用。
updateIndex(int) - Method in class javafx.scene.control. IndexedCell
更新与此IndexedCell相关联的索引。
updateInt(int, int) - Method in interface java.sql. ResultSet
使用 int值更新指定的列。
updateInt(String, int) - Method in interface java.sql. ResultSet
使用 int值更新指定的列。
updateItem(Double, boolean) - Method in class javafx.scene.control.cell. ProgressBarTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(Double, boolean) - Method in class javafx.scene.control.cell. ProgressBarTreeTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(LocalDate, boolean) - Method in class javafx.scene.control. DateCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. CheckBoxListCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. CheckBoxTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. CheckBoxTreeCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. CheckBoxTreeTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ChoiceBoxListCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ChoiceBoxTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ChoiceBoxTreeCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ChoiceBoxTreeTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ComboBoxListCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ComboBoxTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ComboBoxTreeCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. ComboBoxTreeTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. TextFieldListCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. TextFieldTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. TextFieldTreeCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control.cell. TextFieldTreeTableCell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItem(T, boolean) - Method in class javafx.scene.control. Cell
updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
updateItemCount() - Method in class javafx.scene.control.skin. ListViewSkin
当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。
updateItemCount() - Method in class javafx.scene.control.skin. TableViewSkinBase
当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。
updateItemCount() - Method in class javafx.scene.control.skin. TreeTableViewSkin
当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。
updateItemCount() - Method in class javafx.scene.control.skin. TreeViewSkin
当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。
updateItemCount() - Method in class javafx.scene.control.skin. VirtualContainerBase
当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。
updateJAXB(XmlNode) - Method in class javax.xml.bind. Binder
获取一个XML节点并更新其关联的JAXB对象及其后代。
updateLabelUIs() - Method in class javax.swing. JSlider
通过调用每个标签上的 updateUI来更新标签表中的标签的UI。
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - Method in class javax.swing.text. AsyncBoxView
响应于从模型接收到更改的通知更新布局。
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - Method in class javax.swing.text. View
响应于从模型接收到更改的通知更新布局。
updateLayoutCacheExpandedNodes() - Method in class javax.swing.plaf.basic. BasicTreeUI
使JTree中扩展的所有节点在LayoutCache中扩展。
updateLayoutState() - Method in class javax.swing.plaf.basic. BasicListUI
根据当前字体和fixedCellWidth，fixedCellHeight和prototypeCellValue的当前值重新计算cellHeight或cellHeights和cellWidth的值。
updateLayoutStateNeeded - Variable in class javax.swing.plaf.basic. BasicListUI
该值表示更改为 JList型号。
updateLeadIndex() - Method in class javax.swing.tree. DefaultTreeSelectionModel
更新leadIndex实例变量。
updateLeadSelectionRow() - Method in class javax.swing.plaf.basic. BasicTreeUI
更新选择的首行。
updateLegend() - Method in class javafx.scene.chart. XYChart
每当添加或删除一个系列并且需要更新图例时，就会调用这一点
updateLevel - Variable in class javax.swing.undo. UndoableEditSupport
更新级别。
updateListBoxSelectionForEvent(MouseEvent, boolean) - Method in class javax.swing.plaf.basic. BasicComboPopup
事件侦听器使用的实用方法。
updateListeners - Variable in class javax.imageio. ImageReader
A List目前注册的 IIOReadUpdateListener s，默认初始化为 null ，这是一个空的 List同义词。
updateListView(ListView<T>) - Method in class javafx.scene.control. ListCell
更新与此单元格关联的ListView。
updateLocation(Point) - Method in class java.awt.dnd. DropTarget.DropTargetAutoScroller
导致自动滚屏发生
updateLong(int, long) - Method in interface java.sql. ResultSet
使用 long值更新指定的列。
updateLong(String, long) - Method in interface java.sql. ResultSet
使用 long值更新指定的列。
updateMessage(String) - Method in class javafx.concurrent. Task
更新 message属性。
updateMetrics() - Method in class javax.swing.text. PlainView
检查字体指标和最长行是否是最新的。
updateNCharacterStream(int, Reader) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列。
updateNCharacterStream(int, Reader, long) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列，该值将具有指定的字节数。
updateNCharacterStream(String, Reader) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列。
updateNCharacterStream(String, Reader, long) - Method in interface java.sql. ResultSet
使用字符流值更新指定的列，该值将具有指定的字节数。
updateNClob(int, Reader) - Method in interface java.sql. ResultSet
使用给定的 Reader更新指定的列。根据需要从数据流中读取数据，直到达到流出端。
updateNClob(int, Reader, long) - Method in interface java.sql. ResultSet
使用给定的 Reader对象更新指定的列，这是给定的字符数。
updateNClob(int, NClob) - Method in interface java.sql. ResultSet
使用 java.sql.NClob值更新指定的列。
updateNClob(String, Reader) - Method in interface java.sql. ResultSet
使用给定的 Reader对象更新指定的列。
updateNClob(String, Reader, long) - Method in interface java.sql. ResultSet
使用给定的 Reader对象更新指定的列，这是给定的字符长度。
updateNClob(String, NClob) - Method in interface java.sql. ResultSet
使用 java.sql.NClob值更新指定的列。
updateNString(int, String) - Method in interface java.sql. ResultSet
使用 String值更新指定的列。
updateNString(String, String) - Method in interface java.sql. ResultSet
使用 String值更新指定的列。
updateNull(int) - Method in interface java.sql. ResultSet
使用 null值更新指定的列。
updateNull(String) - Method in interface java.sql. ResultSet
使用 null值更新指定的列。
updateObject(int, Object) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateObject(int, Object, int) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateObject(int, Object, SQLType) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateObject(int, Object, SQLType, int) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateObject(String, Object) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateObject(String, Object, int) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateObject(String, Object, SQLType) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateObject(String, Object, SQLType, int) - Method in interface java.sql. ResultSet
使用 Object值更新指定的列。
updateProgress(double, double) - Method in class javafx.concurrent. Task
更新 workDone ， totalWork ，并 progress性能。
updateProgress(int) - Method in interface javax.jnlp. ExtensionInstallerService
更新进度条。
updateProgress(long, long) - Method in class javafx.concurrent. Task
更新 workDone ， totalWork ，并 progress性能。
updateRef(int, Ref) - Method in interface java.sql. ResultSet
使用 java.sql.Ref值更新指定的列。
updateRef(String, Ref) - Method in interface java.sql. ResultSet
使用 java.sql.Ref值更新指定的列。
updateRenderer() - Method in class javax.swing.plaf.basic. BasicTreeUI
当渲染器发生变化时，我们从树中消失。
updateRenderer(JComponent, String) - Static method in class javax.swing.plaf.basic. BasicHTML
将给定文本的HTML渲染存储到给定JComponent的客户端属性中。
updateRoleMap(String, Role, List<ObjectName>) - Method in class javax.management.relation. RelationService
处理关系服务角色图更新给定关系中给定角色的更新。
updateRoleMap(String, Role, List<ObjectName>) - Method in interface javax.management.relation. RelationServiceMBean
处理关系服务角色图更新给定关系中给定角色的更新。
updateRow() - Method in interface java.sql. ResultSet
使用此 ResultSet对象的当前行的新内容更新底层数据库。
updateRowHeader(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
更新行标题。
updateRowId(int, RowId) - Method in interface java.sql. ResultSet
使用 RowId值更新指定的列。
updateRowId(String, RowId) - Method in interface java.sql. ResultSet
使用 RowId值更新指定的列。
updatesAreDetected(int) - Method in interface java.sql. DatabaseMetaData
检索是否可以通过调用方法 ResultSet.rowUpdated检测到可见行更新。
updateScrollBarDisplayPolicy(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
更新滚动条显示策略。
updateSelected(boolean) - Method in class javafx.scene.control. Cell
更新此单元格是否处于选定状态。
updateSelected(boolean) - Method in class javafx.scene.control. TableCell
更新此单元格是否处于选定状态。
updateSelected(boolean) - Method in class javafx.scene.control. TreeTableCell
更新此单元格是否处于选定状态。
updateShort(int, short) - Method in interface java.sql. ResultSet
使用 short值更新指定的列。
updateShort(String, short) - Method in interface java.sql. ResultSet
使用 short值更新指定的列。
updateSize() - Method in class javax.swing.plaf.basic. BasicTreeUI
将缓存大小标记为无效，并用 treeDidChange发送树。
updateSQLXML(int, SQLXML) - Method in interface java.sql. ResultSet
使用 java.sql.SQLXML值更新指定的列。
updateSQLXML(String, SQLXML) - Method in interface java.sql. ResultSet
使用 java.sql.SQLXML值更新指定的列。
updateString(int, String) - Method in interface java.sql. ResultSet
使用 String值更新指定的列。
updateString(String, String) - Method in interface java.sql. ResultSet
使用 String值更新指定的列。
updateStyles(Component) - Static method in class javax.swing.plaf.synth. SynthLookAndFeel
更新与 c及其所有子项相关联的样式。
updateTableColumn(TableColumn) - Method in class javafx.scene.control. TableCell
更新与此TableCell关联的TableColumn。
updateTableInRealTime - Variable in class javax.swing.table. JTableHeader
作为Java 2平台v1.3的过时。
updateTableRow(TableRow) - Method in class javafx.scene.control. TableCell
更新与此TableCell关联的TableRow。
updateTableView(TableView) - Method in class javafx.scene.control. TableCell
更新与TableCell相关联的TableView。
updateTableView(TableView<T>) - Method in class javafx.scene.control. TableRow
更新与TableCell相关联的TableView。
updateTextFill() - Method in class javafx.scene.control.skin. TextInputControlSkin
当textFill属性更改时调用。
updateTime(int, Time) - Method in interface java.sql. ResultSet
使用 java.sql.Time值更新指定的列。
updateTime(String, Time) - Method in interface java.sql. ResultSet
使用 java.sql.Time值更新指定的列。
updateTimestamp(int, Timestamp) - Method in interface java.sql. ResultSet
使用 java.sql.Timestamp值更新指定的列。
updateTimestamp(String, Timestamp) - Method in interface java.sql. ResultSet
使用 java.sql.Timestamp值更新指定的列。
updateTitle(String) - Method in class javafx.concurrent. Task
更新 title属性。
updateTreeItem(TreeItem<T>) - Method in class javafx.scene.control. TreeCell
更新与TreeCell关联的TreeItem。
updateTreeItem(TreeItem<T>) - Method in class javafx.scene.control. TreeTableRow
更新与此TreeTableCell关联的TreeItem。
updateTreeTableColumn(TreeTableColumn<S, T>) - Method in class javafx.scene.control. TreeTableCell
更新与此TreeTableCell关联的TreeTableColumn。
updateTreeTableRow(TreeTableRow<S>) - Method in class javafx.scene.control. TreeTableCell
更新与此TreeTableCell关联的TreeTableRow。
updateTreeTableView(TreeTableView<S>) - Method in class javafx.scene.control. TreeTableCell
更新与此TreeTableCell关联的TreeTableView。
updateTreeTableView(TreeTableView<T>) - Method in class javafx.scene.control. TreeTableRow
更新与此TreeTableCell关联的TreeTableView。
updateTreeView(TreeView<T>) - Method in class javafx.scene.control. TreeCell
更新与TreeCell相关联的TreeView。
updateUI() - Method in class javax.swing. AbstractButton
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JButton
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JCheckBox
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JColorChooser
来自 UIManager通知，L＆F已经改变了。
updateUI() - Method in class javax.swing. JComboBox
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JComponent
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JDesktopPane
通知从 UIManager ，L＆F已经改变了。
updateUI() - Method in class javax.swing. JFileChooser
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JInternalFrame.JDesktopIcon
通知从 UIManager的外观和感觉已经改变。
updateUI() - Method in class javax.swing. JInternalFrame
通知从 UIManager的外观和感觉已经改变。
updateUI() - Method in class javax.swing. JLabel
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JLayer
将其功能委托给 LayerUI.updateUI(JLayer)方法，如果设置了 LayerUI 。
updateUI() - Method in class javax.swing. JList
将 ListUI属性重新设置为当前外观所提供的值。
updateUI() - Method in class javax.swing. JMenu
将UI属性重新设置为来自当前外观的值。
updateUI() - Method in class javax.swing. JMenuBar
将UI属性重新设置为来自当前外观的值。
updateUI() - Method in class javax.swing. JMenuItem
将UI属性重新设置为来自当前外观的值。
updateUI() - Method in class javax.swing. JOptionPane
来自 UIManager通知说L＆F已经改变了。
updateUI() - Method in class javax.swing. JPanel
将UI属性重新设置为来自当前外观的值。
updateUI() - Method in class javax.swing. JPasswordField
重新加载可插拔的UI。
updateUI() - Method in class javax.swing. JPopupMenu
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JProgressBar
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JRadioButton
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JRootPane
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JScrollBar
覆盖 JComponent.updateUI 。
updateUI() - Method in class javax.swing. JScrollPane
将当前的 ScrollPaneUI对象替换为当前默认外观的版本。
updateUI() - Method in class javax.swing. JSeparator
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JSlider
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JSpinner
使用当前外观的值重置UI属性。
updateUI() - Method in class javax.swing. JSplitPane
来自 UIManager通知表明L＆F已经改变了。
updateUI() - Method in class javax.swing. JTabbedPane
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JTable
来自 UIManager通知，L＆F已经改变了。
updateUI() - Method in class javax.swing. JToggleButton
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JToolBar
来自 UIFactory通知说L＆F已经改变了。
updateUI() - Method in class javax.swing. JToolTip
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing. JTree
来自 UIManager通知，L＆F已经改变了。
updateUI() - Method in class javax.swing. JViewport
将UI属性重置为当前外观的值。
updateUI() - Method in class javax.swing.table. DefaultTableCellRenderer
通知从 UIManager的外观和感觉[L＆F]已经改变。
updateUI() - Method in class javax.swing.table. JTableHeader
通知从 UIManager的外观和感觉（L＆F）已经改变。
updateUI() - Method in class javax.swing.text. JTextComponent
重新加载可插拔的UI。
updateUI() - Method in class javax.swing.tree. DefaultTreeCellRenderer
将UI属性重置为当前外观的值。
updateUI(JLayer<? extends V>) - Method in class javax.swing.plaf. LayerUI
调用时 JLayer.updateUI()被称为 JLayer这个 LayerUI设置为。
updateUndoPositions(Vector) - Method in class javax.swing.text. StringContent
重置 positions所有UndoPosRef实例的 positions 。
updateUndoPositions(Vector, int, int) - Method in class javax.swing.text. GapContent
重置 positions所有UndoPosRef实例的 positions 。
updateValue(V) - Method in class javafx.concurrent. Task
更新 value属性。
updateViewport(PropertyChangeEvent) - Method in class javax.swing.plaf.basic. BasicScrollPaneUI
更新视口。
updateXML(Object) - Method in class javax.xml.bind. Binder
获取JAXB对象并更新其关联的XML节点及其后代。
updateXML(Object, XmlNode) - Method in class javax.xml.bind. Binder
在其关联的XML解析树中更新JAXB对象树中的更改。
upFocusCycle() - Method in class java.awt. KeyboardFocusManager
将焦点移动到当前焦点所有者的一个焦点遍历周期。
upFocusCycle(Component) - Method in class java.awt. DefaultKeyboardFocusManager
将焦点移动到一个焦点遍历周期。
upFocusCycle(Component) - Method in class java.awt. KeyboardFocusManager
将焦点移动到一个焦点遍历周期。
upFolderIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
向上文件夹图标
UPGRADE_MODULE_PATH - javax.tools. StandardLocation
搜索可升级系统模块的位置。
upgradingArchive(URL, String, int, int) - Method in interface javax.jnlp. DownloadServiceListener
JNLP客户端的 DownloadService实现应该在缓存资源中应用增量更新时至少应该调用此方法。
upKey - Variable in class javax.swing.plaf.basic. BasicSplitPaneUI
已过时。
从Java 2平台v1.3开始。
upKey - Variable in class javax.swing.plaf.basic. BasicTabbedPaneUI
已过时。
从Java 2平台v1.3开始。
upKey - Variable in class javax.swing.plaf.basic. BasicToolBarUI
已过时。
从Java 2平台v1.3开始。
UPPER_LEADING_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口的上前缘角。
UPPER_LEFT_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口的左上角。
UPPER_RIGHT_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口右上角。
UPPER_TRAILING_CORNER - Static variable in interface javax.swing. ScrollPaneConstants
标识视口的上后缘角。
upperBoundProperty() - Method in class javafx.scene.chart. ValueAxis
该轴上限值（最大值）。
UPPERCASE - Static variable in class java.util. FormattableFlags
根据在formatTo()方法的formatter参数创建时给出的locale的规则将输出转换为大写。
UPPERCASE_LETTER - Static variable in class java.lang. Character
Unicode规范中的一般类别“Lu”。
upperLeft - Variable in class javax.swing. JScrollPane
组件显示在左上角。
upperLeft - Variable in class javax.swing. ScrollPaneLayout
组件显示在左上角。
upperRight - Variable in class javax.swing. JScrollPane
组件显示在右上角。
upperRight - Variable in class javax.swing. ScrollPaneLayout
组件显示在右上角。
uri - Variable in class javax.tools. SimpleJavaFileObject
此文件对象的URI。
uri() - Method in class jdk.incubator.http. HttpRequest
返回此请求的请求 URI 。
uri() - Method in class jdk.incubator.http. HttpResponse
返回收到的响应的 URI 。
uri(URI) - Method in class jdk.incubator.http. HttpRequest.Builder
设置 HttpRequest的请求 URI 。
URI - Class in java.net
表示统一资源标识符（URI）参考。
URI(String) - Constructor for class java.net. URI
通过解析给定的字符串构造一个URI。
URI(String, String, String) - Constructor for class java.net. URI
从给定的组件构造一个URI。
URI(String, String, String, int, String, String, String) - Constructor for class java.net. URI
从给定的组件构造一个分层URI。
URI(String, String, String, String) - Constructor for class java.net. URI
从给定的组件构造一个分层URI。
URI(String, String, String, String, String) - Constructor for class java.net. URI
从给定的组件构造一个分层URI。
URI_NS_SOAP_1_1_ENVELOPE - Static variable in interface javax.xml.soap. SOAPConstants
SOAP 1.1信封的命名空间标识符。
URI_NS_SOAP_1_2_ENCODING - Static variable in interface javax.xml.soap. SOAPConstants
SOAP 1.2编码的命名空间标识符。
URI_NS_SOAP_1_2_ENVELOPE - Static variable in interface javax.xml.soap. SOAPConstants
SOAP 1.2信封的命名空间标识符。
URI_NS_SOAP_ENCODING - Static variable in interface javax.xml.soap. SOAPConstants
SOAP 1.1编码的命名空间标识符。
URI_NS_SOAP_ENVELOPE - Static variable in interface javax.xml.soap. SOAPConstants
SOAP 1.1包络的命名空间标识符，此命名空间中的所有SOAPElements由SOAP 1.1规范定义。
URI_SOAP_1_2_ROLE_NEXT - Static variable in interface javax.xml.soap. SOAPConstants
标识下一个处理SOAP请求的应用程序的URI作为SOAP 1.2标题条目的预期角色（参见SOAP 1.2规范的第1部分的第2.2节）。
URI_SOAP_1_2_ROLE_NONE - Static variable in interface javax.xml.soap. SOAPConstants
SOAP 1.2中指定角色无的URI。
URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER - Static variable in interface javax.xml.soap. SOAPConstants
标识SOAP 1.2消息的最终接收者的URI。
URI_SOAP_ACTOR_NEXT - Static variable in interface javax.xml.soap. SOAPConstants
URI标识下一个处理SOAP请求的应用程序作为SOAP 1.1标头条目的预期actor（参见SOAP 1.1规范的第4.2.2节）。
URICertStoreParameters - Class in java.security.cert
用作 CertStore算法的参数的参数，其使用URI中包含的信息来检索证书和CRL。
URICertStoreParameters(URI) - Constructor for class java.security.cert. URICertStoreParameters
使用指定的URI创建一个 URICertStoreParameters的实例。
URIDereferencer - Interface in javax.xml.crypto
取消参考的URIReference s。
URIException - Interface in javax.print
接口URIException是一个mixin接口，可以实现PrintException的子类来报告涉及URI地址的错误条件。
URIInaccessible - Static variable in interface javax.print. URIException
表示打印机无法访问URI地址。
URIOtherProblem - Static variable in interface javax.print. URIException
表示其他原因未明确确定的任何问题。
URIParameter - Class in java.security
包含指向PolicySpi或ConfigurationSpi实现的数据的URI的参数。
URIParameter(URI) - Constructor for class java.security. URIParameter
构造URIParameter，URI指向用于SPI实现的数据。
URIReference - Interface in javax.xml.crypto
通过URI-Reference标识数据对象，由 RFC 2396指定。
URIReferenceException - Exception in javax.xml.crypto
表示在解除引用URIReference时抛出异常情况。
URIReferenceException() - Constructor for exception javax.xml.crypto. URIReferenceException
构造一个新的 URIReferenceException作为其详细信息 null 。
URIReferenceException(String) - Constructor for exception javax.xml.crypto. URIReferenceException
构造一个新的 URIReferenceException具有指定的详细消息。
URIReferenceException(String, Throwable) - Constructor for exception javax.xml.crypto. URIReferenceException
构造一个新的 URIReferenceException具有指定的详细信息和原因。
URIReferenceException(String, Throwable, URIReference) - Constructor for exception javax.xml.crypto. URIReferenceException
构造一个新的 URIReferenceException与指定的详细信息，原因和 URIReference 。
URIReferenceException(Throwable) - Constructor for exception javax.xml.crypto. URIReferenceException
构造一个新的 URIReferenceException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
URIResolver - Interface in javax.xml.transform
实现此接口的对象，可由处理器调用，将document（），xsl：import或xsl：include中使用的URI转换为Source对象。
URISchemeNotSupported - Static variable in interface javax.print. URIException
表示打印机不支持URI地址中的URI方案（“http”，“ftp”等）。
URISyntax - Class in javax.print.attribute
类URISyntax是一个抽象基类，提供其值为统一资源标识符（URI）的所有属性的常见实现。
URISyntax(URI) - Constructor for class javax.print.attribute. URISyntax
构造具有指定URI的URI属性。
URISyntaxException - Exception in java.net
检查的异常抛出以指示不能将字符串解析为URI引用。
URISyntaxException(String, String) - Constructor for exception java.net. URISyntaxException
从给定的输入字符串构造一个实例和原因。
URISyntaxException(String, String, int) - Constructor for exception java.net. URISyntaxException
从给定的输入字符串，原因和错误索引构造一个实例。
url - Variable in class java.net. URLConnection
URL表示打开此连接的万维网上的远程对象。
URL - Class in java.net
URL类表示统一资源定位符，指向万维网上“资源”的指针。
URL - Static variable in class javafx.scene.input. DataFormat
表示一个编码为String的URL
URL(String) - Constructor for class java.net. URL
从 String表示中创建一个 URL对象。
URL(String) - Constructor for class javax.print. DocFlavor.URL
构造具有给定MIME类型和打印数据表示类名称为 "java.net.URL"的新文档风格。
URL(String, String, int, String) - Constructor for class java.net. URL
创建 URL从指定对象 protocol ， host ， port号码，和 file 。
URL(String, String, int, String, URLStreamHandler) - Constructor for class java.net. URL
创建 URL从指定对象 protocol ， host ， port号码， file ，和 handler 。
URL(String, String, String) - Constructor for class java.net. URL
从指定的 protocol名称， host名称和 file名称创建一个URL。
URL(URL, String) - Constructor for class java.net. URL
通过在指定的上下文中解析给定的规范来创建一个URL。
URL(URL, String, URLStreamHandler) - Constructor for class java.net. URL
通过在指定上下文中使用指定的处理程序解析给定规范来创建URL。
URL_PKG_PREFIXES - Static variable in interface javax.naming. Context
持有环境属性名称的常量，用于指定在URL上下文工厂中加载时使用的包前缀列表。
URLClassLoader - Class in java.net
此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。
URLClassLoader(String, URL[], ClassLoader) - Constructor for class java.net. URLClassLoader
为指定的URL构造一个新的命名为 URLClassLoader 。
URLClassLoader(String, URL[], ClassLoader, URLStreamHandlerFactory) - Constructor for class java.net. URLClassLoader
为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的命名为 URLClassLoader 。
URLClassLoader(URL[]) - Constructor for class java.net. URLClassLoader
使用默认委托父母 ClassLoader为指定的URL构造一个新的URLClassLoader。
URLClassLoader(URL[], ClassLoader) - Constructor for class java.net. URLClassLoader
为给定的URL构造一个新的URLClassLoader。
URLClassLoader(URL[], ClassLoader, URLStreamHandlerFactory) - Constructor for class java.net. URLClassLoader
为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的URLClassLoader。
URLConnection - Class in java.net
抽象类 URLConnection是表示应用程序和URL之间的通信链接的所有类的超类。
URLConnection(URL) - Constructor for class java.net. URLConnection
构造与指定URL的URL连接。
URLConverter - Class in javafx.css.converter
将表示URL的解析值转换为相对于样式表位置解析的URL字符串。
URLConverter.SequenceConverter - Class in javafx.css.converter
URLDataSource - Class in javax.activation
URLDataSource类提供了一个在DataSource接口中包装一个 URL对象的对象。
URLDataSource(URL) - Constructor for class javax.activation. URLDataSource
URLDataSource构造函数。
URLDecoder - Class in java.net
HTML表单解码的实用类。
URLDecoder() - Constructor for class java.net. URLDecoder
URLEncoder - Class in java.net
HTML表单编码的实用类。
URLPermission - Class in java.net
表示访问由给定网址定义的资源或资源集的权限，以及给定的一组用户可设置的请求方法和请求标头。
URLPermission(String) - Constructor for class java.net. URLPermission
使用给定的url字符串和无限制的方法创建一个URLPermission，并通过调用两个参数构造函数来请求头，如下所示：URLPermission（url，“*：*”）
URLPermission(String, String) - Constructor for class java.net. URLPermission
从url字符串创建一个新的URLPermission，并允许给定的请求方法和用户可设置的请求头。
URLReader - Class in jdk.nashorn.api.scripting
从URL读取的读者。
URLReader(URL) - Constructor for class jdk.nashorn.api.scripting. URLReader
构造函数
URLReader(URL, String) - Constructor for class jdk.nashorn.api.scripting. URLReader
构造函数
URLReader(URL, Charset) - Constructor for class jdk.nashorn.api.scripting. URLReader
构造函数
URLStreamHandler - Class in java.net
抽象类 URLStreamHandler是所有流协议处理程序的通用超类。
URLStreamHandler() - Constructor for class java.net. URLStreamHandler
URLStreamHandlerFactory - Interface in java.net
该接口为 URL流协议处理程序定义了一个工厂。
URLStreamHandlerProvider - Class in java.net.spi
URL流处理程序服务提供程序类。
URLStreamHandlerProvider() - Constructor for class java.net.spi. URLStreamHandlerProvider
初始化一个新的URL流处理程序提供程序。
URLStringHelper - Class in org.omg.CosNaming.NamingContextExtPackage
URLString是以String形式表示的URL地址（corbaloc：或corbaname :)。
URLStringHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage. URLStringHelper
urxProperty() - Method in class javafx.scene.effect. PerspectiveTransform
源映射到其右上角的输出位置的x坐标。
uryProperty() - Method in class javafx.scene.effect. PerspectiveTransform
映射源的右上角的输出位置的y坐标。
US - Static variable in class java.util. Locale
对国家有用的常数。
US_ASCII - Static variable in class java.nio.charset. StandardCharsets
七位ASCII，又名
USAGE_UNKNOWN - java.sql. PseudoColumnUsage
伪/隐藏列的使用无法确定。
USE_ACTIVE_OBJECT_MAP_ONLY - Static variable in class org.omg.PortableServer. RequestProcessingPolicyValue
USE_ALL_BEANINFO - Static variable in class java.beans. Introspector
用来表示使用所有beaninfo的标志。
USE_CATALOG - Static variable in class javax.xml. XMLConstants
功能：useCatalog
USE_COMPUTED_SIZE - Static variable in class javafx.scene.control. PopupControl
Sentinel值可以传递给控件的setMinWidth（），setMinHeight（），setPrefWidth（），setPrefHeight（），setMaxWidth（），setMaxHeight（）方法将控件的大小约束重新设置为由computeMinWidth（）返回的内在大小， computeMinHeight（），computePrefWidth（），computePrefHeight（），computeMaxWidth（）或computeMaxHeight（）。
USE_COMPUTED_SIZE - Static variable in class javafx.scene.layout. Region
这可以传递给一个地区的哨兵值 setMinWidth ， setMinHeight ， setPrefWidth ， setPrefHeight ， setMaxWidth ， setMaxHeight种方法重置区域的大小限制回到它的内在的大小由归国 computeMinWidth ， computeMinHeight ， computePrefWidth ， computePrefHeight ， computeMaxWidth ，或 computeMaxHeight 。
USE_DEFAULT_SERVANT - Static variable in class org.omg.PortableServer. RequestProcessingPolicyValue
USE_PREF_SIZE - Static variable in class javafx.scene.control. PopupControl
可以传递给控件的setMinWidth（），setMinHeight（），setMaxWidth（）或setMaxHeight（）方法的Sentinel值，以指示应该使用该最大和/或最小约束的首选维度。
USE_PREF_SIZE - Static variable in class javafx.scene.layout. Region
其可以被传递给一个地区的定点值 setMinWidth ， setMinHeight ， setMaxWidth或 setMaxHeight方法，以指示优选的尺寸应该用于该最大和/或最小约束。
USE_SELECTION - javax.swing. DropMode
应该使用组件自身的内部选择机制（或文本组件的插入符号）来跟踪放置位置。
USE_SERVANT_MANAGER - Static variable in class org.omg.PortableServer. RequestProcessingPolicyValue
USE_STD3_ASCII_RULES - Static variable in class java.net. IDN
标志打开对STD-3 ASCII规则的检查
useAnchoringBounds(boolean) - Method in class java.util.regex. Matcher
设置该匹配器的区域边界的锚定。
useCaches - Variable in class java.net. URLConnection
如果是 true ，则允许协议使用缓存。
useDaylightTime() - Method in class java.util. SimpleTimeZone
查询此时区是否使用夏令时。
useDaylightTime() - Method in class java.util. TimeZone
查询 TimeZone使用夏令时。
useDelimiter(String) - Method in class java.util. Scanner
将此扫描仪的划分模式设置为从指定的 String构造的模式。
useDelimiter(Pattern) - Method in class java.util. Scanner
将此扫描仪的分隔模式设置为指定的模式。
useLocale(Locale) - Method in class java.util. Scanner
将此扫描仪的区域设置设置为指定的区域设置。
USEMAP - Static variable in class javax.swing.text.html. HTML.Attribute
属性“usemap”
usePattern(Pattern) - Method in class java.util.regex. Matcher
更改 Pattern ，这个 Matcher用于查找匹配。
useProtocolVersion(int) - Method in class java.io. ObjectOutputStream
指定在编写流时使用的流协议版本。
user() - Method in interface java.lang. ProcessHandle.Info
返回进程的用户。
user(String) - Method in interface java.sql. ConnectionBuilder
指定创建连接时要使用的用户名
user(String) - Method in interface javax.sql. PooledConnectionBuilder
指定创建连接时要使用的用户名
user(String) - Method in interface javax.sql. XAConnectionBuilder
指定创建连接时要使用的用户名
USER - javafx.css. StyleOrigin
属性的值由用户通过调用set方法设置
USER_AGENT - javafx.css. StyleOrigin
样式表是用户代理样式表
USER_ATTENTION - java.awt. Taskbar.Feature
表示用户注意请求功能。
USER_ATTENTION_WINDOW - java.awt. Taskbar.Feature
表示指定窗口的用户注意请求功能。
USER_DATA_DIRECTORY_ALREADY_IN_USE - Static variable in class javafx.scene.web. WebErrorEvent
当WebEngine检测到其用户数据目录WebEngine不同VM中运行的WebEngine使用时，会发生此事件。
USER_DATA_DIRECTORY_IO_ERROR - Static variable in class javafx.scene.web. WebErrorEvent
当WebEngine在尝试创建或访问用户数据目录时遇到I / O错误时，会发生此事件。
USER_DATA_DIRECTORY_SECURITY_ERROR - Static variable in class javafx.scene.web. WebErrorEvent
当WebEngine在尝试创建或访问用户数据目录时遇到安全错误时，会发生此事件。
USER_EXCEPTION - Interface in org.omg.PortableInterceptor
org / omg / PortableInterceptor / USER_EXCEPTION.java。
USER_ID - Static variable in class org.omg.PortableServer. IdAssignmentPolicyValue
USER_PROVIDER - Variable in class com.sun.security.auth.module. JndiLoginModule
JNDI提供商
useRadix(int) - Method in class java.util. Scanner
将此扫描仪的默认基数设置为指定的基数。
userAgentProperty() - Method in class javafx.scene.web. WebEngine
指定用户代理ID字符串。
userAgentStylesheetProperty() - Method in class javafx.scene. Scene
userAgentStylesheetProperty() - Method in class javafx.scene. SubScene
userDataDirectoryProperty() - Method in class javafx.scene.web. WebEngine
指定此 WebEngine用于存储本地用户数据的目录。
UserDataHandler - Interface in org.w3c.dom
当使用 Node.setUserData()将对象与节点上的密钥相关联时，应用程序可以提供一个处理程序，当对象被关联到的节点被克隆，导入或重命名时，该处理程序将被调用。
UserDefinedFileAttributeView - Interface in java.nio.file.attribute
文件属性视图，提供文件的用户定义属性（有时称为 扩展属性）的视图。
userErr() - Method in interface jdk.jshell.spi. ExecutionEnv
返回用户的错误流。
UserException - Exception in org.omg.CORBA
CORBA IDL定义用户异常的根类。
UserException() - Constructor for exception org.omg.CORBA. UserException
构造一个 UserException对象。
UserException(String) - Constructor for exception org.omg.CORBA. UserException
构造具有详细消息的 UserException对象。
UserException(String, String, StackTraceElement[]) - Constructor for exception jdk.jshell.spi. ExecutionControl.UserException
userIn() - Method in interface jdk.jshell.spi. ExecutionEnv
返回用户的输入流。
UserJvmOptionsService - Interface in jdk.packager.services
运行时访问UserJVMOptions。
username - Variable in class com.sun.security.auth.module. SolarisSystem
已过时。
username - Variable in class com.sun.security.auth.module. UnixSystem
USERNAME_PROPERTY - Static variable in interface javax.xml.ws. BindingProvider
标准属性：认证用户名。
userNodeForPackage(Class<?>) - Static method in class java.util.prefs. Preferences
从调用用户的偏好树中返回偏好节点，该树通过指定的类的包（与约定）相关联。
userObject - Variable in class javax.swing.tree. DefaultMutableTreeNode
可选的用户对象
userOut() - Method in interface jdk.jshell.spi. ExecutionEnv
返回用户的输出流。
UserPrincipal - Class in com.sun.security.auth
由用户名或帐户名称标识的用户主体。
UserPrincipal - Interface in java.nio.file.attribute
A Principal表示用于确定对文件系统中的对象的访问权限的身份。
UserPrincipal(String) - Constructor for class com.sun.security.auth. UserPrincipal
创建校长
UserPrincipalLookupService - Class in java.nio.file.attribute
按名称查找用户和组主体的对象。
UserPrincipalLookupService() - Constructor for class java.nio.file.attribute. UserPrincipalLookupService
初始化此类的新实例。
UserPrincipalNotFoundException - Exception in java.nio.file.attribute
当查询UserPrincipal失败，因为主体不存在时抛出的检查异常。
UserPrincipalNotFoundException(String) - Constructor for exception java.nio.file.attribute. UserPrincipalNotFoundException
构造这个类的一个实例。
userRoot() - Static method in class java.util.prefs. Preferences
返回主叫用户的根优先级节点。
userRoot() - Method in interface java.util.prefs. PreferencesFactory
返回与主叫用户对应的用户根优先级节点。
userSessionActivated(UserSessionEvent) - Method in interface java.awt.desktop. UserSessionListener
当用户会话切换到时被调用。
userSessionDeactivated(UserSessionEvent) - Method in interface java.awt.desktop. UserSessionListener
当用户会话被关闭时调用。
UserSessionEvent - Class in java.awt.desktop
用户会话更改时发送的事件。
UserSessionEvent(UserSessionEvent.Reason) - Constructor for class java.awt.desktop. UserSessionEvent
构造一个 UserSessionEvent
UserSessionEvent.Reason - Enum in java.awt.desktop
用户会话更改的可能原因的种类。
UserSessionListener - Interface in java.awt.desktop
当用户会话更改时，实现者会收到通知。
userStyleSheetLocationProperty() - Method in class javafx.scene.web. WebEngine
用户样式表的位置为字符串URL。
uses() - Method in class java.lang.module. ModuleDescriptor
返回一组服务依赖关系。
uses(String) - Method in class java.lang.module. ModuleDescriptor.Builder
增加服务依赖性。
USES - com.sun.source.doctree. DocTree.Kind
用于实例UsesTree表示@uses标签。
USES - com.sun.source.tree. Tree.Kind
用于表示模块声明中使用指令的UsesTree的实例。
USES - javax.lang.model.element. ModuleElement.DirectiveKind
A“使用service-name”指令。
usesFractionalMetrics() - Method in class java.awt.font. FontRenderContext
返回一个布尔值，此 FontRenderContext是否使用文本分数度量模式。
usesIn(Iterable<? extends ModuleElement.Directive>) - Static method in class javax.lang.model.util. ElementFilter
在 directives返回 uses指令的列表。
usesLocalFilePerTable() - Method in interface java.sql. DatabaseMetaData
检索此数据库是否为每个表使用一个文件。
usesLocalFiles() - Method in interface java.sql. DatabaseMetaData
检索此数据库是否将表存储在本地文件中。
usesMirroring() - Method in class javafx.scene. Node
确定当节点方向是从右到左时是否应该镜像节点。
usesMirroring() - Method in class javafx.scene.text. Text
usesMirroring() - Method in class javafx.scene.text. TextFlow
usesShiftModifier() - Method in class java.awt. MenuShortcut
返回是否必须使用SHIFT键调用该MenuShortcut。
UsesTree - Interface in com.sun.source.doctree
用于@uses块标记的树节点。
UsesTree - Interface in com.sun.source.tree
模块声明中的'uses'指令的树节点。
useSystemMenuBarProperty() - Method in class javafx.scene.control. MenuBar
如果当前平台支持，请使用系统菜单栏。
useToString(int) - Method in class javax.swing. DefaultRowSorter
返回在进行排序比较之前是否将该值转换为字符串。
useToString(int) - Method in class javax.swing.table. TableRowSorter
返回在进行排序比较之前是否将该值转换为字符串。
useTransparentBounds(boolean) - Method in class java.util.regex. Matcher
设置此匹配器的区域边界的透明度。
UShortSeqHelper - Class in org.omg.CORBA
助手 UShortSeq 。
UShortSeqHelper() - Constructor for class org.omg.CORBA. UShortSeqHelper
UShortSeqHolder - Class in org.omg.CORBA
持有人 UShortSeq 。
UShortSeqHolder() - Constructor for class org.omg.CORBA. UShortSeqHolder
UShortSeqHolder(short[]) - Constructor for class org.omg.CORBA. UShortSeqHolder
usingProxy() - Method in class java.net. HttpURLConnection
指示连接正在通过代理。
UTC - java.time.zone. ZoneOffsetTransitionRule.TimeDefinition
本地日期时间以UTC偏移量表示。
UTC - Static variable in class java.time. ZoneOffset
UTC的时区偏移量，ID为“Z”。
UTC(int, int, int, int, int, int) - Static method in class java.util. Date
已过时。
从JDK 1.1版开始，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec) ，使用UTC TimeZone ，其次是Calendar.getTime().getTime() 。
UTC_TIME - Static variable in class java.util. SimpleTimeZone
指定为UTC的开始或结束时间模式的常数。
UTF_16 - Static variable in class java.nio.charset. StandardCharsets
十六位UCS转换格式，由可选字节顺序标记标识的字节顺序
UTF_16BE - Static variable in class java.nio.charset. StandardCharsets
十六位UCS转换格式，大字节顺序
UTF_16LE - Static variable in class java.nio.charset. StandardCharsets
十六位UCS转换格式，小端字节顺序
UTF_8 - Static variable in class java.nio.charset. StandardCharsets
八位UCS转换格式
UTFDataFormatException - Exception in java.io
表示 modified UTF-8格式的格式不正确的字符串已被读入数据输入流或实现数据输入接口的任何类。
UTFDataFormatException() - Constructor for exception java.io. UTFDataFormatException
构造一个 UTFDataFormatException其中 null作为其错误详细消息。
UTFDataFormatException(String) - Constructor for exception java.io. UTFDataFormatException
构造具有指定详细消息的 UTFDataFormatException 。
Util - Class in javax.rmi.CORBA
提供可由桩和关系使用的实用方法来执行常见操作。
Util - Class in jdk.jshell.execution
用于设置实现的其他实用方法ExecutionControl 。
UtilDelegate - Interface in javax.rmi.CORBA
支持Util中的方法实现的委派 。
Utilities - Class in javax.swing.text
一系列处理各种文字相关活动的方法。
Utilities() - Constructor for class javax.swing.text. Utilities
UTILITY - java.awt. Window.Type
表示 实用程序窗口。
UTILITY - javafx.stage. StageStyle
定义一个 Stage样式，具有纯白色背景和用于实用工具窗口的最小平台装饰。
UUID - Class in java.util
一个表示不可变的通用唯一标识符（UUID）的类。
UUID(long, long) - Constructor for class java.util. UUID
使用指定的数据构造一个新的 UUID 。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


V-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

V

V - javafx.scene.input. KeyCode
常数为 V键。
V_RESIZE - Static variable in class javafx.scene. Cursor
垂直光标类型。
VAI - java.awt.font. NumericShaper.Range
Vai范围与Vai数字。
VAI - java.lang. Character.UnicodeScript
Unicode脚本“Vai”。
VAI - Static variable in class java.lang. Character.UnicodeBlock
“Vai”Unicode字符块的常量。
valid() - Method in class java.io. FileDescriptor
测试此文件描述符对象是否有效。
VALID - jdk.jshell. Snippet.Status
该片段是有效的片段（在当前的 JShell状态的上下文中）。
validate() - Method in class java.awt. Component
验证此组件。
validate() - Method in class java.awt. Container
验证此容器及其所有子组件。
validate() - Method in class javax.swing. DefaultListCellRenderer
由于性能原因而被覆盖。
validate() - Method in class javax.swing.table. DefaultTableCellRenderer
由于性能原因而被覆盖。
validate() - Method in class javax.swing.tree. DefaultTreeCellRenderer
由于性能原因而被覆盖。
validate(long) - Method in class java.util.concurrent.locks. StampedLock
如果从发布给定邮票以来没有专门获取锁，则返回true。
validate(GraphicsConfiguration) - Method in class java.awt.image. VolatileImage
如果表面自上一次 validate调用以来丢失，则尝试恢复图像的绘图面。
validate(Object) - Method in interface javax.xml.bind. Validator
已过时。
自JAXB2.0起
validate(CertPath, CertPathParameters) - Method in class java.security.cert. CertPathValidator
使用指定的算法参数集验证指定的认证路径。
validate(XMLValidateContext) - Method in interface javax.xml.crypto.dsig. Reference
验证此引用。
validate(XMLValidateContext) - Method in interface javax.xml.crypto.dsig. XMLSignature.SignatureValue
验证签名值。
validate(XMLValidateContext) - Method in interface javax.xml.crypto.dsig. XMLSignature
根据 core validation processing rules验证签名。
validate(Source) - Method in class javax.xml.validation. Validator
验证指定的输入。
validate(Source, Result) - Method in class javax.xml.validation. Validator
验证指定的输入并将增强的验证结果发送到指定的输出。
validate_connection() - Method in class org.omg.CORBA. LocalObject
使用消息“这是一个局部约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
validatedContents - Variable in class java.awt. Component.BltBufferStrategy
绘图缓冲区是否最近从丢失状态恢复。
validatedContents - Variable in class java.awt. Component.FlipBufferStrategy
绘图缓冲区是否最近从丢失状态恢复。
validateFileCache() - Method in class javax.swing.plaf.basic. BasicDirectoryModel
验证文件缓存的内容。
validateInvalidComponents() - Method in class javax.swing. RepaintManager
验证已标记为无效的所有组件。
validateObject() - Method in interface java.io. ObjectInputValidation
验证对象。
validatePage(PageFormat) - Method in class java.awt.print. PrinterJob
返回 page的克隆，其设置被调整为与此 PrinterJob的当前打印机兼容。
validatePendingAdd(Object) - Method in class java.beans.beancontext. BeanContextSupport
此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在添加到BeanContext之前立即检查子对象。
validatePendingRemove(Object) - Method in class java.beans.beancontext. BeanContextSupport
此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在BeanContext从BeanContext中删除之前立即检查子对象。
validatePendingSetBeanContext(BeanContext) - Method in class java.beans.beancontext. BeanContextChildSupport
从setBeanContext调用以验证（或以其他方式）嵌套BeanContext属性值中的挂起更改。
validateRoot(Object) - Method in interface javax.xml.bind. Validator
已过时。
自JAXB2.0起
validateTree() - Method in class java.awt. Container
递归地下降容器树，并重新计算标记为需要的任何子树（标记为无效的）的布局。
validating - Variable in class javax.xml.bind.helpers. AbstractUnmarshallerImpl
解密者是否验证
validating(URL, String, long, long, int) - Method in interface javax.jnlp. DownloadServiceListener
在验证下载过程中，JNLP客户端的 DownloadService实现应至少调用此方法。
VALIDATION_ERR - Static variable in exception org.w3c.dom. DOMException
如果对 insertBefore或 removeChild等方法的调用将使 Node对“部分有效性”无效，则此异常将被提升，并且操作将不会执行。
ValidationEvent - Interface in javax.xml.bind
此事件表示在解密操作期间验证传入的XML数据时遇到问题，同时执行Java内容树的按需验证，或将Java内容树编组回XML数据。
ValidationEventCollector - Class in javax.xml.bind.util
ValidationEventHandler收集所有事件的实现。
ValidationEventCollector() - Constructor for class javax.xml.bind.util. ValidationEventCollector
ValidationEventHandler - Interface in javax.xml.bind
用于验证错误的基本事件处理程序接口。
ValidationEventImpl - Class in javax.xml.bind.helpers
ValidationEvent接口的默认实现。
ValidationEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers. ValidationEventImpl
创建一个新的ValidationEventImpl。
ValidationEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers. ValidationEventImpl
创建一个新的ValidationEventImpl。
ValidationEventLocator - Interface in javax.xml.bind
封装ValidationEvent的位置。
ValidationEventLocatorImpl - Class in javax.xml.bind.helpers
ValidationEventLocator接口的默认实现。
ValidationEventLocatorImpl() - Constructor for class javax.xml.bind.helpers. ValidationEventLocatorImpl
创建一个所有字段不可用的对象。
ValidationEventLocatorImpl(Object) - Constructor for class javax.xml.bind.helpers. ValidationEventLocatorImpl
构造指向JAXB内容对象的对象。
ValidationEventLocatorImpl(Node) - Constructor for class javax.xml.bind.helpers. ValidationEventLocatorImpl
构造指向DOM节点的对象。
ValidationEventLocatorImpl(Locator) - Constructor for class javax.xml.bind.helpers. ValidationEventLocatorImpl
从org.xml.sax.Locator构造一个对象。
ValidationEventLocatorImpl(SAXParseException) - Constructor for class javax.xml.bind.helpers. ValidationEventLocatorImpl
根据SAXParseException的位置信息构造一个对象。
ValidationException - Exception in javax.xml.bind
此异常表示执行验证操作时发生错误。
ValidationException(String) - Constructor for exception javax.xml.bind. ValidationException
构造具有指定详细消息的ValidationException。
ValidationException(String, String) - Constructor for exception javax.xml.bind. ValidationException
使用指定的详细消息和供应商特定的错误代码构造ValidationException。
ValidationException(String, String, Throwable) - Constructor for exception javax.xml.bind. ValidationException
使用指定的详细消息，供应商特定的错误代码和linkedException构造ValidationException。
ValidationException(String, Throwable) - Constructor for exception javax.xml.bind. ValidationException
使用指定的详细消息和linkedException构造ValidationException。
ValidationException(Throwable) - Constructor for exception javax.xml.bind. ValidationException
使用linkedException构造ValidationException。
Validator - Class in javax.xml.validation
一个检查XML文档的处理器，反对Schema 。
Validator - Interface in javax.xml.bind
已过时。
自JAXB 2.0起
Validator() - Constructor for class javax.xml.validation. Validator
派生类的构造方法
ValidatorHandler - Class in javax.xml.validation
流式验证器，适用于SAX流。
ValidatorHandler() - Constructor for class javax.xml.validation. ValidatorHandler
派生类的构造方法
validCachedPreferredSize - Variable in class javax.swing.plaf.basic. BasicTreeUI
preferredSize是否有效？
validOps() - Method in class com.sun.nio.sctp. SctpChannel
返回确定此频道支持的操作的操作集。
validOps() - Method in class com.sun.nio.sctp. SctpMultiChannel
返回确定此频道支持的操作的操作集。
validOps() - Method in class com.sun.nio.sctp. SctpServerChannel
返回确定此频道支持的操作的操作集。
validOps() - Method in class java.nio.channels. DatagramChannel
返回确定此频道支持的操作的操作集。
validOps() - Method in class java.nio.channels. Pipe.SinkChannel
返回确定此频道支持的操作的操作集。
validOps() - Method in class java.nio.channels. Pipe.SourceChannel
返回确定此频道支持的操作的操作集。
validOps() - Method in class java.nio.channels. SelectableChannel
返回一个 operation set标识该频道支持的操作。
validOps() - Method in class java.nio.channels. ServerSocketChannel
返回确定此频道支持的操作的操作集。
validOps() - Method in class java.nio.channels. SocketChannel
返回确定此频道支持的操作的操作集。
validOptions(String[][], DocErrorReporter) - Static method in class com.sun.javadoc. Doclet
已过时。
检查选项是否具有正确的参数。
validOptions(String[][], DocErrorReporter) - Static method in class com.sun.tools.doclets.standard. Standard
已过时。
VALIGN - Static variable in class javax.swing.text.html. HTML.Attribute
属性“valign”
valignmentProperty() - Method in class javafx.scene.control. Separator
对于水平分隔符，指定分隔符控件空间内的分隔线的垂直对齐方式。
valignmentProperty() - Method in class javafx.scene.layout. RowConstraints
行的垂直对齐方式。
value - Variable in class java.sql. DriverPropertyInfo
基于提供给方法 getPropertyInfo的信息，Java环境和驱动程序提供的默认值， value字段指定了属性的当前值。
value - Variable in class javafx.css. ParsedValue
由解析器创建的CSS属性值。
value - Variable in class javax.naming.ldap. BasicControl
控制器的ASN.1 BER编码值。
value - Variable in class javax.swing. DefaultCellEditor.EditorDelegate
这个单元格的值。
value - Variable in class javax.swing. JOptionPane
当前所选值，将是有效选项，或 UNINITIALIZED_VALUE或 null 。
value - Variable in class javax.swing.text.html.parser. AttributeList
默认属性值
value - Variable in class javax.xml.bind. JAXBElement
xml元素值。
value - Variable in class javax.xml.ws. Holder
包含在持有人的价值。
value - Variable in class org.omg.CORBA. AnyHolder
由 AnyHolder对象持有的 Any价值。
value - Variable in class org.omg.CORBA. AnySeqHolder
value - Static variable in interface org.omg.CORBA. ARG_IN
指示输入参数的值。
value - Static variable in interface org.omg.CORBA. ARG_INOUT
指示用于输入和输出的参数的常量值。
value - Static variable in interface org.omg.CORBA. ARG_OUT
指示输出参数的常量值。
value - Static variable in interface org.omg.CORBA. BAD_POLICY_TYPE
PolicyError异常中的错误代码。
value - Static variable in interface org.omg.CORBA. BAD_POLICY_VALUE
用于表示 PolicyError异常中不良策略值错误的值。
value - Static variable in interface org.omg.CORBA. BAD_POLICY
PolicyError异常中的错误代码。
value - Variable in class org.omg.CORBA. BooleanHolder
这个 BooleanHolder对象持有的 boolean值。
value - Variable in class org.omg.CORBA. BooleanSeqHolder
value - Variable in class org.omg.CORBA. ByteHolder
由 ByteHolder对象持有的 byte值。
value - Variable in class org.omg.CORBA. CharHolder
这个 CharHolder对象持有的 char价值。
value - Variable in class org.omg.CORBA. CharSeqHolder
value - Static variable in interface org.omg.CORBA. CTX_RESTRICT_SCOPE
该字段包含一个 CTX_RESTRICT_SCOPE标志的 int值。
value - Variable in class org.omg.CORBA. CurrentHolder
value - Variable in class org.omg.CORBA. DoubleHolder
由 DoubleHolder对象持有的 double值。
value - Variable in class org.omg.CORBA. DoubleSeqHolder
value - Variable in class org.omg.CORBA. FixedHolder
FixedHolder持有的值
value - Variable in class org.omg.CORBA. FloatHolder
由 FloatHolder对象持有的 float值。
value - Variable in class org.omg.CORBA. FloatSeqHolder
value - Variable in class org.omg.CORBA. IntHolder
这个 IntHolder对象在其 value字段中持有的 int值。
value - Variable in class org.omg.CORBA. LongHolder
由 LongHolder对象持有的 long价值。
value - Variable in class org.omg.CORBA. LongLongSeqHolder
value - Variable in class org.omg.CORBA. LongSeqHolder
value - Variable in class org.omg.CORBA. NameValuePair
与该 NameValuePair对象的名称相关联的值。
value - Variable in class org.omg.CORBA. ObjectHolder
由 ObjectHolder对象持有的 Object价值。
value - Variable in class org.omg.CORBA. OctetSeqHolder
value - Static variable in interface org.omg.CORBA. OMGVMCID
为OMG保留的供应商次要代码ID。
value - Variable in class org.omg.CORBA. ParameterModeHolder
value - Variable in class org.omg.CORBA. PolicyErrorHolder
value - Variable in class org.omg.CORBA. PolicyHolder
value - Variable in class org.omg.CORBA. PolicyListHolder
value - Variable in class org.omg.CORBA. PrincipalHolder
已过时。
由 PrincipalHolder对象持有的 Principal值。
value - Static variable in interface org.omg.CORBA. PRIVATE_MEMBER
value - Static variable in interface org.omg.CORBA. PUBLIC_MEMBER
value - Variable in class org.omg.CORBA. ServiceInformationHolder
该 ServiceInformation值由该 ServiceInformationHolder对象在其 value字段中 value 。
value - Variable in class org.omg.CORBA. ShortHolder
由 ShortHolder对象持有的 short值。
value - Variable in class org.omg.CORBA. ShortSeqHolder
value - Variable in class org.omg.CORBA. StringHolder
该 String持有的价值 StringHolder对象。
value - Variable in class org.omg.CORBA. StringSeqHolder
value - Variable in class org.omg.CORBA. TypeCodeHolder
该 TypeCode持有的价值 TypeCodeHolder对象。
value - Variable in class org.omg.CORBA. ULongLongSeqHolder
value - Variable in class org.omg.CORBA. ULongSeqHolder
value - Variable in class org.omg.CORBA. UnknownUserExceptionHolder
value - Static variable in interface org.omg.CORBA. UNSUPPORTED_POLICY_VALUE
PolicyError异常的错误代码。
value - Static variable in interface org.omg.CORBA. UNSUPPORTED_POLICY
PolicyError异常的错误代码。
value - Variable in class org.omg.CORBA. UShortSeqHolder
value - Variable in class org.omg.CORBA. ValueBaseHolder
由 ValueBaseHolder对象持有的 java.io.Serializable值。
value - Static variable in interface org.omg.CORBA. VM_ABSTRACT
该值表示类型代码中的抽象接口值类型。
value - Static variable in interface org.omg.CORBA. VM_CUSTOM
表示类型代码中自定义编组值类型的值。
value - Static variable in interface org.omg.CORBA. VM_NONE
根据CORBA 2.3规范，表示类型代码中的值类型的值。
value - Static variable in interface org.omg.CORBA. VM_TRUNCATABLE
该值表示类型代码中的可截断值类型。
value - Variable in class org.omg.CORBA. WCharSeqHolder
value - Variable in class org.omg.CORBA. WrongTransactionHolder
value - Variable in class org.omg.CORBA. WStringSeqHolder
value - Variable in class org.omg.CosNaming. BindingHolder
value - Variable in class org.omg.CosNaming. BindingIteratorHolder
value - Variable in class org.omg.CosNaming. BindingListHolder
value - Variable in class org.omg.CosNaming. BindingTypeHolder
value - Variable in class org.omg.CosNaming. NameComponentHolder
value - Variable in class org.omg.CosNaming. NameHolder
value - Variable in class org.omg.CosNaming. NamingContextExtHolder
value - Variable in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHolder
value - Variable in class org.omg.CosNaming. NamingContextHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage. CannotProceedHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage. InvalidNameHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage. NotEmptyHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage. NotFoundHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHolder
value - Variable in class org.omg.DynamicAny. NameDynAnyPair
与名称相关联的DynAny值。
value - Variable in class org.omg.DynamicAny. NameValuePair
与该名称相关联的任何值。
value - Static variable in interface org.omg.IOP. CodeSets
标识第13.10.2.5节“GIOP代码集服务上下文”（第13-43页）中定义的 CONV_FRAME.CodeSetContext的CDR封装。
value - Static variable in interface org.omg.IOP. ENCODING_CDR_ENCAPS
CDR封装编码。
value - Static variable in interface org.omg.IOP. ExceptionDetailMessage
CORBA form / 02-06-01：13.7.1：ExceptionDetailMessage标识一个wstring的CDR封装，使用GIOP 1.2编码，并带有UTF-16的TCS-W。
value - Variable in class org.omg.IOP. IORHolder
value - Variable in class org.omg.IOP. MultipleComponentProfileHolder
value - Static variable in interface org.omg.IOP. RMICustomMaxStreamFormat
标识RMICustomMaxStreamFormat服务上下文的CDR封装，其中包含指定客户端的最大RMI-IIOP流格式版本的单个字节。
value - Variable in class org.omg.IOP. ServiceContextHolder
value - Variable in class org.omg.IOP. ServiceContextListHolder
value - Static variable in interface org.omg.IOP. TAG_ALTERNATE_IIOP_ADDRESS
在同一个对象密钥用于多个互联网位置的情况下，下列标准IOR组件被定义为IIOP 1.2版中的支持。
value - Static variable in interface org.omg.IOP. TAG_CODE_SETS
IOR多组件配置文件结构的代码集组件包含：服务器的本机char代码集和转换代码集，以及服务器的本机wchar代码集和转换代码集。 char和wchar转换代码集都按优先级顺序列出。
value - Static variable in interface org.omg.IOP. TAG_INTERNET_IOP
标识支持Internet Inter-ORB协议的配置文件。
value - Static variable in interface org.omg.IOP. TAG_JAVA_CODEBASE
桩，关系，价值观和价值助手支持类下载。
value - Static variable in interface org.omg.IOP. TAG_MULTIPLE_COMPONENTS
表示封装的值为 MultipleComponentProfile类型。
value - Static variable in interface org.omg.IOP. TAG_ORB_TYPE
在现实世界中，能够识别对象引用来自ORB的特定类型，解决该特定ORB的问题，或者利用共享的效率，这在现实世界中通常是有用的。
value - Static variable in interface org.omg.IOP. TAG_POLICIES
配置文件组件，其中包含由对象适配器与对象引用一起导出的QoS策略序列。
value - Static variable in interface org.omg.IOP. TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
RMI-IIOP具有多个流格式版本。
value - Variable in class org.omg.IOP. TaggedComponentHolder
value - Variable in class org.omg.IOP. TaggedProfileHolder
value - Static variable in interface org.omg.IOP. TransactionService
标识的CDR封装 CosTSInteroperation.PropogationContext在 CORBAservices定义 ：公共对象服务规范。
value - Static variable in interface org.omg.Messaging. SYNC_WITH_TRANSPORT
在Messaging规范中定义的常量定义了在将控制权返回给客户端之前，请求的进展程度。
value - Static variable in interface org.omg.PortableInterceptor. ACTIVE
指示正常请求处理的对象适配器状态。
value - Static variable in interface org.omg.PortableInterceptor. DISCARDING
导致所有请求被丢弃的对象适配器状态。
value - Static variable in interface org.omg.PortableInterceptor. HOLDING
对象适配器状态暂时保存，直到状态更改为止。
value - Static variable in interface org.omg.PortableInterceptor. INACTIVE
导致所有请求被丢弃的对象适配器状态。
value - Variable in class org.omg.PortableInterceptor. IORInterceptor_3_0Holder
value - Static variable in interface org.omg.PortableInterceptor. LOCATION_FORWARD
表示LocationForward回复状态。
value - Static variable in interface org.omg.PortableInterceptor. NON_EXISTENT
指示适配器已被销毁的对象适配器状态。
value - Variable in class org.omg.PortableInterceptor. ObjectReferenceFactoryHolder
value - Variable in class org.omg.PortableInterceptor. ObjectReferenceTemplateHolder
value - Variable in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHolder
value - Static variable in interface org.omg.PortableInterceptor. SUCCESSFUL
表示成功回复状态。
value - Static variable in interface org.omg.PortableInterceptor. SYSTEM_EXCEPTION
表示SystemException回复状态。
value - Static variable in interface org.omg.PortableInterceptor. TRANSPORT_RETRY
表示传输重试应答状态。
value - Static variable in interface org.omg.PortableInterceptor. UNKNOWN
XXX
value - Static variable in interface org.omg.PortableInterceptor. USER_EXCEPTION
表示UserException回复状态。
value - Static variable in interface org.omg.PortableServer. ID_ASSIGNMENT_POLICY_ID
代表ID_ASSIGNMENT_POLICY_ID的值。
value - Static variable in interface org.omg.PortableServer. ID_UNIQUENESS_POLICY_ID
代表ID_UNIQUENESS_POLICY_ID的值。
value - Static variable in interface org.omg.PortableServer. IMPLICIT_ACTIVATION_POLICY_ID
该值代表IMPLICIT_ACTIVATION_POLICY_ID。
value - Static variable in interface org.omg.PortableServer. LIFESPAN_POLICY_ID
代表LIFESPAN_POLICY_ID的值。
value - Static variable in interface org.omg.PortableServer. REQUEST_PROCESSING_POLICY_ID
表示REQUEST_PROCESSING_POLICY_ID的值。
value - Static variable in interface org.omg.PortableServer. SERVANT_RETENTION_POLICY_ID
表示SERVANT_RETENTION_POLICY_ID的值。
value - Variable in class org.omg.PortableServer.ServantLocatorPackage. CookieHolder
value - Static variable in interface org.omg.PortableServer. THREAD_POLICY_ID
代表THREAD_POLICY_ID的值。
value() - Method in interface com.sun.javadoc. AnnotationDesc.ElementValuePair
已过时。
返回与注释类型元素关联的值。
value() - Method in interface com.sun.javadoc. AnnotationValue
已过时。
返回值。
value() - Method in interface com.sun.jdi. BooleanValue
将BooleanValue返回为布尔值。
value() - Method in interface com.sun.jdi. ByteValue
将此ByteValue返回为 byte 。
value() - Method in interface com.sun.jdi. CharValue
将此CharValue返回为 char 。
value() - Method in interface com.sun.jdi.connect. Connector.Argument
返回参数的当前值。
value() - Method in interface com.sun.jdi. DoubleValue
将此DoubleValue返回为 double 。
value() - Method in interface com.sun.jdi. FloatValue
将此FloatValue返回为浮点数。
value() - Method in interface com.sun.jdi. IntegerValue
将此IntegerValue返回为int。
value() - Method in interface com.sun.jdi. LongValue
返回此LongValue为长。
value() - Method in interface com.sun.jdi. ShortValue
返回此ShortValue作为一个短。
value() - Method in interface com.sun.jdi. StringReference
以字符串形式返回StringReference。
value() - Method in interface java.nio.file.attribute. FileAttribute
返回属性值。
value() - Method in interface javax.xml.xpath. XPathEvaluationResult
返回结果的值，为类指定的类型为 <T> 。
value() - Method in class jdk.jshell. SnippetEvent
成功运行的结果值。
value() - Method in class org.omg.CORBA. CompletionStatus
检索此 CompletionStatus对象的值。
value() - Method in class org.omg.CORBA. DefinitionKind
返回标识IR对象类型的 int常数。
value() - Method in class org.omg.CORBA. NamedValue
检索此 NamedValue对象的值。
value() - Method in class org.omg.CORBA. ParameterMode
value() - Method in class org.omg.CORBA. SetOverrideType
检索此 SetOverrideType实例的值。
value() - Method in class org.omg.CORBA. TCKind
检索此 TCKind实例的值。
value() - Method in class org.omg.CosNaming. BindingType
value() - Method in class org.omg.CosNaming.NamingContextPackage. NotFoundReason
value() - Method in interface org.omg.PortableServer. IdAssignmentPolicyOperations
指定策略值
value() - Method in class org.omg.PortableServer. IdAssignmentPolicyValue
value() - Method in interface org.omg.PortableServer. IdUniquenessPolicyOperations
指定策略值
value() - Method in class org.omg.PortableServer. IdUniquenessPolicyValue
value() - Method in interface org.omg.PortableServer. ImplicitActivationPolicyOperations
指定策略值
value() - Method in class org.omg.PortableServer. ImplicitActivationPolicyValue
value() - Method in interface org.omg.PortableServer. LifespanPolicyOperations
指定策略值
value() - Method in class org.omg.PortableServer. LifespanPolicyValue
value() - Method in class org.omg.PortableServer.POAManagerPackage. State
value() - Method in interface org.omg.PortableServer. RequestProcessingPolicyOperations
指定策略值
value() - Method in class org.omg.PortableServer. RequestProcessingPolicyValue
value() - Method in interface org.omg.PortableServer. ServantRetentionPolicyOperations
指定策略值
value() - Method in class org.omg.PortableServer. ServantRetentionPolicyValue
value() - Method in interface org.omg.PortableServer. ThreadPolicyOperations
指定策略值
value() - Method in class org.omg.PortableServer. ThreadPolicyValue
value(boolean) - Static method in class javax.management. Query
返回一个布尔值表达式，可以在任何期望ValueExp的Query调用中使用。
value(double) - Static method in class javax.management. Query
返回一个数值表达式，可以在任何期望使用ValueExp的Query调用中使用。
value(float) - Static method in class javax.management. Query
返回一个数值表达式，可以在任何期望使用ValueExp的Query调用中使用。
value(int) - Static method in class javax.management. Query
返回一个数值表达式，可以在任何期望使用ValueExp的Query调用中使用。
value(long) - Static method in class javax.management. Query
返回一个数值表达式，可以在任何期望使用ValueExp的Query调用中使用。
value(Number) - Static method in class javax.management. Query
返回一个数值表达式，可以在任何期望使用ValueExp的Query调用中使用。
value(String) - Static method in class javax.management. Query
返回新的字符串表达式。
Value - Interface in com.sun.jdi
目标VM中的值的镜像。
VALUE - com.sun.source.doctree. DocTree.Kind
用于表示@value标签的ValueTree的实例。
VALUE - javafx.scene. AccessibleAttribute
返回节点的值。
VALUE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“值”
VALUE_ALPHA_INTERPOLATION_DEFAULT - Static variable in class java.awt. RenderingHints
Alpha插值提示值 - alpha混合算法由实现选择，以实现性能与质量的良好折衷。
VALUE_ALPHA_INTERPOLATION_QUALITY - Static variable in class java.awt. RenderingHints
选择Alpha插值提示值 - alpha混合算法，偏好精度和视觉质量。
VALUE_ALPHA_INTERPOLATION_SPEED - Static variable in class java.awt. RenderingHints
选择Alpha插值提示值 - alpha混合算法，优先于计算速度。
VALUE_ANTIALIAS_DEFAULT - Static variable in class java.awt. RenderingHints
抗锯齿提示值 - 使用实现选择的默认抗锯齿模式进行渲染。
VALUE_ANTIALIAS_OFF - Static variable in class java.awt. RenderingHints
抗锯齿提示值 - 渲染完成时没有抗锯齿。
VALUE_ANTIALIAS_ON - Static variable in class java.awt. RenderingHints
抗混叠提示值 - 使用抗锯齿来实现渲染。
VALUE_ARBITRARY - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
由 getAttributeValueType和 getObjectValueType返回的常数表示属性或用户对象可以设置为单个任意值。
value_as_string() - Method in interface org.omg.CORBA. DynEnum
已过时。
将此 DynEnum存储的IDL枚举的值作为字符串返回。
value_as_string(String) - Method in interface org.omg.CORBA. DynEnum
已过时。
在这个 DynEnum设置一个特定的枚举。
value_as_ulong() - Method in interface org.omg.CORBA. DynEnum
已过时。
将IDL枚举的值作为Java int返回。
value_as_ulong(int) - Method in interface org.omg.CORBA. DynEnum
已过时。
设置IDL枚举的值。
VALUE_COLOR_RENDER_DEFAULT - Static variable in class java.awt. RenderingHints
显色渲染提示值 - 执行颜色转换计算，以表示性能和精度之间的最佳可用权衡。
VALUE_COLOR_RENDER_QUALITY - Static variable in class java.awt. RenderingHints
显色提示值 - 以最高的精度和视觉质量执行颜色转换计算。
VALUE_COLOR_RENDER_SPEED - Static variable in class java.awt. RenderingHints
显色提示值 - 执行最快的颜色转换为输出设备的格式。
VALUE_DELIMITER - Static variable in class javafx.scene.control. IndexRange
索引范围值分隔符。
VALUE_DITHER_DEFAULT - Static variable in class java.awt. RenderingHints
抖动提示值 - 使用实现选择的抖动的默认值。
VALUE_DITHER_DISABLE - Static variable in class java.awt. RenderingHints
抖动提示值 - 渲染几何时不要抖动。
VALUE_DITHER_ENABLE - Static variable in class java.awt. RenderingHints
抖动提示值 - 如果需要，渲染几何时，抖动。
VALUE_ENUMERATION - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为多个枚举值之一。
VALUE_FRACTIONALMETRICS_DEFAULT - Static variable in class java.awt. RenderingHints
字体分数度量提示值 - 字符字形按照实现选择的精度进行定位。
VALUE_FRACTIONALMETRICS_OFF - Static variable in class java.awt. RenderingHints
字体分数度量提示值 - 字符字形以先进宽度定位，四舍五入到像素边界。
VALUE_FRACTIONALMETRICS_ON - Static variable in class java.awt. RenderingHints
字体分数度量提示值 - 字符字形以子像素精度定位。
VALUE_INTERPOLATION_BICUBIC - Static variable in class java.awt. RenderingHints
插值提示值 - 使用 X和 Y的三次函数对图像中9个附近整数坐标样本的颜色样本进行插值，以生成颜色样本。
VALUE_INTERPOLATION_BILINEAR - Static variable in class java.awt. RenderingHints
插值提示值 - 图像中最近邻近4个整数坐标样本的颜色样本被线性内插以产生颜色样本。
VALUE_INTERPOLATION_NEAREST_NEIGHBOR - Static variable in class java.awt. RenderingHints
插值提示值 - 使用图像中最近的相邻整数坐标样本的颜色样本。
VALUE_LIST - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
由 getAttributeValueType和 getObjectValueType返回的 getAttributeValueType ，以指示属性或用户对象可以设置为列表或数组。
VALUE_NONE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getObjectValueType返回的 getObjectValueType ，表示没有用户对象。
VALUE_PROPERTY - Static variable in class javax.swing. JOptionPane
绑定属性名称为 value 。
VALUE_RANGE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
由 getAttributeValueType和 getObjectValueType返回的常数表示可以将属性或用户对象设置为值范围。
VALUE_RANGE_MAX_INCLUSIVE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getAttributeValueType和 getObjectValueType返回的 getAttributeValueType ，用于指示属性或用户对象可能被设置为一个值范围。
VALUE_RANGE_MAX_INCLUSIVE_MASK - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个可以用 VALUE_RANGE或以 VALUE_RANGE获得的 VALUE_RANGE_MAX_INCLUSIVE ，并用 VALUE_RANGE_MIN_INCLUSIVE获得 VALUE_RANGE_MIN_MAX_INCLUSIVE 。
VALUE_RANGE_MIN_INCLUSIVE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getAttributeValueType和 getObjectValueType返回的 getAttributeValueType ，以表示可以将属性或用户对象设置为一个值范围。
VALUE_RANGE_MIN_INCLUSIVE_MASK - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
可与被或运算的值 VALUE_RANGE得到 VALUE_RANGE_MIN_INCLUSIVE ，并用 VALUE_RANGE_MAX_INCLUSIVE得到 VALUE_RANGE_MIN_MAX_INCLUSIVE 。
VALUE_RANGE_MIN_MAX_INCLUSIVE - Static variable in interface javax.imageio.metadata. IIOMetadataFormat
一个由 getAttributeValueType和 getObjectValueType返回的 getAttributeValueType ，以表示可以将属性或用户对象设置为一个值范围。
VALUE_RENDER_DEFAULT - Static variable in class java.awt. RenderingHints
渲染提示值 - 渲染算法由实现选择，以实现性能与质量的良好折衷。
VALUE_RENDER_QUALITY - Static variable in class java.awt. RenderingHints
渲染提示值 - 选择渲染算法以优化输出质量。
VALUE_RENDER_SPEED - Static variable in class java.awt. RenderingHints
渲染提示值 - 选择渲染算法以优先输出速度。
VALUE_RESOLUTION_VARIANT_BASE - Static variable in class java.awt. RenderingHints
图像分辨率变体提示值 - 始终使用图像的标准分辨率。
VALUE_RESOLUTION_VARIANT_DEFAULT - Static variable in class java.awt. RenderingHints
图像分辨率变体提示值 - 基于可能依赖于平台策略的默认启发式来选择图像分辨率变体
VALUE_RESOLUTION_VARIANT_DPI_FIT - Static variable in class java.awt. RenderingHints
图像分辨率变体提示值 - 仅基于屏幕的DPI选择图像分辨率变体。
VALUE_RESOLUTION_VARIANT_SIZE_FIT - Static variable in class java.awt. RenderingHints
图像分辨率变体提示值 - 基于屏幕的DPI和Graphics2D上下文中的变换来选择图像分辨率变体。
VALUE_STROKE_DEFAULT - Static variable in class java.awt. RenderingHints
笔画归一化控制提示值 - 几何可能被修改或者保留为纯粹，取决于给定实现中的权衡。
VALUE_STROKE_NORMALIZE - Static variable in class java.awt. RenderingHints
笔画归一化控制提示值 - 几何应归一化，以提高线条的均匀性或间距以及整体美感。
VALUE_STROKE_PURE - Static variable in class java.awt. RenderingHints
笔画归一化控制提示值 - 几何应保持未修改，并以亚像素精度呈现。
VALUE_TEXT_ANTIALIAS_DEFAULT - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 文本渲染是根据 RenderingHints.KEY_ANTIALIASING提示或实现选择的默认方式完成的。
VALUE_TEXT_ANTIALIAS_GASP - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 请求文本呈现以使用字体资源中的信息，为每个点大小指定是否应用 RenderingHints.VALUE_TEXT_ANTIALIAS_ON或 RenderingHints.VALUE_TEXT_ANTIALIAS_OFF 。
VALUE_TEXT_ANTIALIAS_LCD_HBGR - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照B，G，R的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HBGR）的三倍， 。
VALUE_TEXT_ANTIALIAS_LCD_HRGB - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照R，G，B的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HRGB）的三倍， 。
VALUE_TEXT_ANTIALIAS_LCD_VBGR - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 要求显示的文本被优化为具有从B，G，R的显示器顶部到底部的子像素组织的LCD显示，使得垂直子像素分辨率是全像素垂直分辨率（VBGR）的三倍。
VALUE_TEXT_ANTIALIAS_LCD_VRGB - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 要求文本显示优化为具有子像素组织的液晶显示器，从R，G，B的显示顶部到底部，使得垂直子像素分辨率是全像素垂直分辨率（VRGB）的三倍。
VALUE_TEXT_ANTIALIAS_OFF - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 文本呈现没有任何形式的抗锯齿。
VALUE_TEXT_ANTIALIAS_ON - Static variable in class java.awt. RenderingHints
文本抗锯齿提示值 - 文本渲染是通过某种形式的抗锯齿来完成的。
valueAt(int) - Method in class javafx.beans.binding. ListExpression
创建一个新的ObjectBinding ，其中包含指定位置的元素。
valueAt(ObservableIntegerValue) - Method in class javafx.beans.binding. ListExpression
创建一个新的ObjectBinding ，其中包含指定位置的元素。
valueAt(ObservableValue<K>) - Method in class javafx.beans.binding. MapExpression
创建一个包含指定键的映射的新的ObjectBinding 。
valueAt(ObservableList<E>, int) - Static method in class javafx.beans.binding. Bindings
创建一个新的ObjectBinding ，其中包含指定位置的ObservableList元素。
valueAt(ObservableList<E>, ObservableIntegerValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的ObjectBinding ，其中包含指定位置的ObservableList的元素。
valueAt(ObservableList<E>, ObservableNumberValue) - Static method in class javafx.beans.binding. Bindings
创建一个新的ObjectBinding ，其中包含指定位置的ObservableList的元素。
valueAt(ObservableMap<K, V>, ObservableValue<? extends K>) - Static method in class javafx.beans.binding. Bindings
创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
valueAt(ObservableMap<K, V>, K) - Static method in class javafx.beans.binding. Bindings
创建一个新的ObjectBinding ，其中包含ObservableMap中特定键的映射 。
valueAt(K) - Method in class javafx.beans.binding. MapExpression
创建一个包含指定键的映射的新的ObjectBinding 。
ValueAxis< T extends Number> - Class in javafx.scene.chart
数据定义为数字的轴。
ValueAxis() - Constructor for class javafx.scene.chart. ValueAxis
创建自动范围的ValueAxis。
ValueAxis(double, double) - Constructor for class javafx.scene.chart. ValueAxis
用给定的下限和上限创建一个非自动范围的ValueAxis。
ValueBase - Interface in org.omg.CORBA.portable
对应于类型IDL类型的生成的Java类实现此接口。
ValueBaseHelper - Class in org.omg.CORBA
ValueBaseHelper() - Constructor for class org.omg.CORBA. ValueBaseHelper
ValueBaseHolder - Class in org.omg.CORBA
持有人 ValueBase 。
ValueBaseHolder() - Constructor for class org.omg.CORBA. ValueBaseHolder
构造一个新的 ValueBaseHolder对象，其 value字段初始化为 0 。
ValueBaseHolder(Serializable) - Constructor for class org.omg.CORBA. ValueBaseHolder
构造一个新的 ValueBaseHolder对象，其 value字段初始化为给定的 java.io.Serializable 。
valueBound(SSLSessionBindingEvent) - Method in interface javax.net.ssl. SSLSessionBindingListener
这被称为通知侦听器它被绑定到SSLSession中。
valueChanged(ListSelectionEvent) - Method in interface javax.swing.event. ListSelectionListener
每当选择的值更改时调用。
valueChanged(ListSelectionEvent) - Method in class javax.swing. JList.AccessibleJList
列表选择侦听器值更改方法。
valueChanged(ListSelectionEvent) - Method in class javax.swing. JTable.AccessibleJTable
跟踪表格单元格选择的更改
valueChanged(ListSelectionEvent) - Method in class javax.swing. JTable
当行选择更改时调用 - 重绘以显示新选择。
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.basic. BasicComboPopup.ListSelectionHandler
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.basic. BasicFileChooserUI.SelectionListener
每当选择的值更改时调用。
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.basic. BasicListUI.ListSelectionHandler
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.metal. MetalFileChooserUI
发生 ListSelectionEvent时调用。
valueChanged(ListSelectionEvent) - Method in class javax.swing.table. DefaultTableColumnModel
A ListSelectionListener ，当有列选择更改时，转发 ListSelectionEvents 。
valueChanged(TreeSelectionEvent) - Method in interface javax.swing.event. TreeSelectionListener
每当选择的值更改时调用。
valueChanged(TreeSelectionEvent) - Method in class javax.swing. JTree.AccessibleJTree
树选择侦听器值更改方法。
valueChanged(TreeSelectionEvent) - Method in class javax.swing. JTree.TreeSelectionRedirector
由 TreeSelectionModel调用时选择更改。
valueChanged(TreeSelectionEvent) - Method in class javax.swing.plaf.basic. BasicTreeUI.TreeSelectionHandler
当我们显示的树中的选择发生变化时，会消失。
valueChanged(TreeSelectionEvent) - Method in class javax.swing.tree. DefaultTreeCellEditor
复位 lastPath 。
valueChangedEvent() - Static method in class javafx.scene.control. TreeItem
当TreeItem接收到对其value属性的修改时使用的EventType。
valueChangingProperty() - Method in class javafx.scene.control. Slider
当为true时，表示此滑块的当前值正在更改。
valueCurrent() - Method in interface com.sun.jdi.event. WatchpointEvent
现场值。
ValueExp - Interface in javax.management
表示可以作为参数传递给关系表达式的值。
ValueFactory - Interface in org.omg.CORBA.portable
ValueFactory接口是IDL类型CORBA :: ValueFactory的本机映射。
valueFactoryProperty() - Method in class javafx.scene.control. Spinner
价值工厂是JavaFX Spinner控件背后的模型 - 没有工厂安装的Spinner不可用的值。
valueForPathChanged(TreePath, Object) - Method in class javax.swing.tree. DefaultTreeModel
这设置由路径标识的TreeNode的用户对象，并发布一个节点更改。
valueForPathChanged(TreePath, Object) - Method in interface javax.swing.tree. TreeModel
当用户已经改变了由确定的项的值传递消息 path至 newValue 。
valueForXPosition(int) - Method in class javax.swing.plaf.basic. BasicSliderUI
返回x位置的值。
valueForXPosition(int) - Method in class javax.swing.plaf.synth. SynthSliderUI
返回x位置的值。
valueForYPosition(int) - Method in class javax.swing.plaf.basic. BasicSliderUI
返回y位置的值。
valueForYPosition(int) - Method in class javax.swing.plaf.synth. SynthSliderUI
返回y位置的值。
valueFromMethodName(String) - Static method in enum java.lang.invoke. VarHandle.AccessMode
返回与指定的 VarHandle签名 - 多态方法名称相关联的 AccessMode值。
ValueHandler - Interface in javax.rmi.CORBA
定义允许将Java对象与GIOP流串行化的方法。
ValueHandlerMultiFormat - Interface in javax.rmi.CORBA
Java to IDL ptc 02-01-12 1.5.1.5
ValueInputStream - Interface in org.omg.CORBA.portable
Java到IDL ptc 02-01-12 1.5.1.4 ValueInputStream用于实现RMI-IIOP流格式版本2。
valueIsAdjusting - Variable in class javax.swing.plaf.basic. BasicComboPopup
从Java 2平台v1.4起，这个以前未记录的字段已不再使用了。
ValueMember - Class in org.omg.CORBA
value对象的成员的Interface Repository中的描述。
ValueMember() - Constructor for class org.omg.CORBA. ValueMember
构造一个默认的 ValueMember对象。
ValueMember(String, String, String, String, TypeCode, IDLType, short) - Constructor for class org.omg.CORBA. ValueMember
构造一个使用给定值初始化的 ValueMember对象。
ValueMemberHelper - Class in org.omg.CORBA
助手 ValueMember 。
ValueMemberHelper() - Constructor for class org.omg.CORBA. ValueMemberHelper
valueOf(boolean) - Static method in class java.lang. Boolean
返回表示指定的 boolean值的 Boolean实例。
valueOf(boolean) - Static method in class java.lang. String
返回 boolean参数的字符串表示形式。
valueOf(byte) - Static method in class java.lang. Byte
返回表示指定的 byte值的 Byte实例。
valueOf(byte[]) - Static method in class java.util. BitSet
返回包含给定字节数组中所有位的新位集合。
valueOf(char) - Static method in class java.lang. Character
返回表示指定的 char值的 Character实例。
valueOf(char) - Static method in class java.lang. String
返回 char参数的字符串表示形式。
valueOf(char[]) - Static method in class java.lang. String
返回 char数组参数的字符串表示形式。
valueOf(char[], int, int) - Static method in class java.lang. String
返回 char数组参数的特定子阵列的字符串表示形式。
valueOf(double) - Static method in class java.lang. Double
返回表示指定的 double值的 Double实例。
valueOf(double) - Static method in class java.lang. String
返回 double参数的字符串表示形式。
valueOf(double) - Static method in class java.math. BigDecimal
转换一个 double成 BigDecimal ，使用 double通过所提供的规范的字符串表示 Double.toString(double)方法。
valueOf(float) - Static method in class java.lang. Float
返回表示指定的 float值的 Float实例。
valueOf(float) - Static method in class java.lang. String
返回 float参数的字符串表示形式。
valueOf(int) - Static method in class java.lang. Integer
返回表示 int值的 Integer实例。
valueOf(int) - Static method in class java.lang. String
返回 int参数的字符串表示形式。
valueOf(int) - Static method in enum java.math. RoundingMode
返回对应于RoundingMode中的遗留整数舍入模式常量的RoundingMode对象 。
valueOf(int) - Static method in enum java.sql. JDBCType
返回 JDBCType对应于指定 Types值
valueOf(long) - Static method in class java.lang. Long
返回表示指定的 long值的 Long实例。
valueOf(long) - Static method in class java.lang. String
返回 long参数的字符串表示形式。
valueOf(long) - Static method in class java.math. BigDecimal
将 long值转换为 BigDecimal ，其大小为零。
valueOf(long) - Static method in class java.math. BigInteger
返回一个BigInteger，其值等于指定的 long 。
valueOf(long[]) - Static method in class java.util. BitSet
返回包含给定长数组中所有位的新位集。
valueOf(long, int) - Static method in class java.math. BigDecimal
将 long值和 int标度转换为 BigDecimal 。
valueOf(short) - Static method in class java.lang. Short
返回表示指定的 short值的 Short实例。
valueOf(Class<T>, String) - Static method in class java.lang. Enum
返回具有指定名称的指定枚举类型的枚举常量。
valueOf(Object) - Static method in class java.lang. String
返回 Object参数的字符串表示形式。
valueOf(String) - Static method in enum com.sun.javadoc. LanguageVersion
已过时。
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.management. VMOption.Origin
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.nio.sctp. AssociationChangeNotification.AssocChangeEvent
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.nio.sctp. HandlerResult
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.security.jgss. InquireType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.source.doctree. AttributeTree.ValueKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.source.doctree. DocTree.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.source.tree. LambdaExpressionTree.BodyKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.source.tree. MemberReferenceTree.ReferenceMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.source.tree. ModuleTree.ModuleKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.source.tree. Tree.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.source.util. TaskEvent.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum com.sun.tools.jconsole. JConsoleContext.ConnectionState
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. Component.BaselineResizeBehavior
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. Desktop.Action
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt.desktop. QuitStrategy
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt.desktop. UserSessionEvent.Reason
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. Dialog.ModalExclusionType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. Dialog.ModalityType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt.event. FocusEvent.Cause
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt.font. NumericShaper.Range
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. GraphicsDevice.WindowTranslucency
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. MultipleGradientPaint.ColorSpaceType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. MultipleGradientPaint.CycleMethod
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. Taskbar.Feature
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. Taskbar.State
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. TrayIcon.MessageType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.awt. Window.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.io. ObjectInputFilter.Status
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang.annotation. ElementType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang.annotation. RetentionPolicy
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class java.lang. Boolean
返回一个 Boolean ，其值由指定的字符串表示。
valueOf(String) - Static method in class java.lang. Byte
返回一个 Byte对象，保存由指定的 String给出的值。
valueOf(String) - Static method in enum java.lang. Character.UnicodeScript
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class java.lang. Double
返回一个 Double对象，该对象保存由参数字符串 s表示的 double值。
valueOf(String) - Static method in class java.lang. Float
返回一个 Float对象，保存由参数字符串 s表示的 float值。
valueOf(String) - Static method in class java.lang. Integer
返回一个 Integer对象，保存指定的值为 String 。
valueOf(String) - Static method in enum java.lang.invoke. VarHandle.AccessMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class java.lang. Long
返回一个 Long对象，保存指定的值为 String 。
valueOf(String) - Static method in enum java.lang.management. MemoryType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang.module. ModuleDescriptor.Exports.Modifier
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang.module. ModuleDescriptor.Modifier
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang.module. ModuleDescriptor.Opens.Modifier
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang.module. ModuleDescriptor.Requires.Modifier
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang. ProcessBuilder.Redirect.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class java.lang. Short
返回一个 Short对象，保存由指定的 String给出的值。
valueOf(String) - Static method in enum java.lang. StackWalker.Option
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang. System.Logger.Level
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.lang. Thread.State
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.math. RoundingMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.net. Authenticator.RequestorType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.net. Proxy.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.net. StandardProtocolFamily
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file. AccessMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file.attribute. AclEntryFlag
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file.attribute. AclEntryPermission
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file.attribute. AclEntryType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file.attribute. PosixFilePermission
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file. FileVisitOption
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file. FileVisitResult
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file. LinkOption
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file. StandardCopyOption
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.nio.file. StandardOpenOption
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.security.cert. CertPathValidatorException.BasicReason
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.security.cert. CRLReason
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.security.cert. PKIXReason
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.security.cert. PKIXRevocationChecker.Option
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.security. CryptoPrimitive
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.security. DrbgParameters.Capability
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.security. KeyRep.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.sql. ClientInfoStatus
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class java.sql. Date
将JDBC日期转义格式的字符串转换为 Date值。
valueOf(String) - Static method in enum java.sql. JDBCType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.sql. PseudoColumnUsage
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.sql. RowIdLifetime
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class java.sql. Time
将JDBC时间转义格式的字符串转换为 Time值。
valueOf(String) - Static method in class java.sql. Timestamp
将JDBC时间戳转换格式的 String对象转换为 Timestamp值。
valueOf(String) - Static method in enum java.text. Normalizer.Form
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.chrono. HijrahEra
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.chrono. IsoEra
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class java.time.chrono. JapaneseEra
返回名称为 JapaneseEra 。
valueOf(String) - Static method in enum java.time.chrono. MinguoEra
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.chrono. ThaiBuddhistEra
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time. DayOfWeek
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.format. FormatStyle
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.format. ResolverStyle
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.format. SignStyle
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.format. TextStyle
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time. Month
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.temporal. ChronoField
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.temporal. ChronoUnit
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.time.zone. ZoneOffsetTransitionRule.TimeDefinition
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.util.concurrent. TimeUnit
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.util. Formatter.BigDecimalLayoutForm
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.util. Locale.Category
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.util. Locale.FilteringMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.util. Locale.IsoCountryCode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum java.util.stream. Collector.Characteristics
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.animation. Animation.Status
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.animation. PathTransition.OrientationType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.application. ConditionalFeature
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.application. Preloader.StateChangeNotification.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.concurrent. Worker.State
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.css. SizeUnits
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.css. StyleOrigin
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. HorizontalDirection
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. HPos
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. NodeOrientation
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. Orientation
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. Pos
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. Side
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. VerticalDirection
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.geometry. VPos
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.print. Collation
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.print. PageOrientation
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.print. PrintColor
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.print. Printer.MarginType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.print. PrinterJob.JobStatus
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.print. PrintQuality
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.print. PrintSides
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene. AccessibleAction
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene. AccessibleAttribute
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene. AccessibleRole
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene. CacheHint
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.chart. LineChart.SortingPolicy
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. Alert.AlertType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. ButtonBar.ButtonData
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. ContentDisplay
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class javafx.scene.control. IndexRange
在“2,6”形式的字符串中解析的方便方法，它将创建一个起始值为2的IndexRange实例，最终值为6。
valueOf(String) - Static method in enum javafx.scene.control. OverrunStyle
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. ScrollPane.ScrollBarPolicy
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. SelectionMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control.skin. TextInputControlSkin.Direction
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control.skin. TextInputControlSkin.TextUnit
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. TableColumn.SortType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. TabPane.TabClosingPolicy
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. TreeSortMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.control. TreeTableColumn.SortType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene. DepthTest
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.effect. BlendMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.effect. BlurType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.image. PixelFormat.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.input. InputMethodHighlight
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.input. KeyCode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.input. KeyCombination.ModifierValue
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class javafx.scene.input. KeyCombination
从指定的字符串构造一个新的 KeyCombination 。
valueOf(String) - Static method in enum javafx.scene.input. MouseButton
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.input. ScrollEvent.HorizontalTextScrollUnits
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.input. ScrollEvent.VerticalTextScrollUnits
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.input. TouchPoint.State
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.input. TransferMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.layout. BackgroundRepeat
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.layout. BorderRepeat
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.layout. Priority
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.media. MediaException.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.media. MediaPlayer.Status
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class javafx.scene.paint. Color
从字符串表示形式创建颜色值。
valueOf(String) - Static method in enum javafx.scene.paint. CycleMethod
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class javafx.scene.paint. LinearGradient
从字符串表示形成线性渐变值。
valueOf(String) - Static method in class javafx.scene.paint. Paint
从字符串表示形式创建一个绘制值。
valueOf(String) - Static method in class javafx.scene.paint. RadialGradient
从字符串表示形成径向渐变值。
valueOf(String) - Static method in enum javafx.scene.shape. ArcType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.shape. CullFace
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.shape. DrawMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.shape. FillRule
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.shape. StrokeLineCap
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.shape. StrokeLineJoin
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.shape. StrokeType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.text. FontPosture
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.text. FontSmoothingType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.text. FontWeight
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.text. TextAlignment
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.text. TextBoundsType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.transform. MatrixType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.scene.web. HTMLEditorSkin.Command
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.stage. Modality
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.stage. PopupWindow.AnchorLocation
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javafx.stage. StageStyle
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class javafx.util. Duration
在一段指定时间内返回一个Duration实例的Factory方法。
valueOf(String) - Static method in enum javax.annotation. Resource.AuthenticationType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.jws.soap. SOAPBinding.ParameterStyle
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.jws.soap. SOAPBinding.Style
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.jws.soap. SOAPBinding.Use
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.jws. WebParam.Mode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.lang.model.element. ElementKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.lang.model.element. Modifier
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.lang.model.element. ModuleElement.DirectiveKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.lang.model.element. NestingKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.lang.model. SourceVersion
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.lang.model.type. TypeKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.lang.model.util. Elements.Origin
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.net.ssl. SSLEngineResult.HandshakeStatus
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.net.ssl. SSLEngineResult.Status
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.smartcardio. CardTerminals.State
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing. DropMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing.event. RowSorterEvent.Type
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing. GroupLayout.Alignment
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing. JTable.PrintMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing. LayoutStyle.ComponentPlacement
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing.plaf.nimbus. AbstractRegionPainter.PaintContext.CacheMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing. RowFilter.ComparisonType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing. SortOrder
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing. SwingWorker.StateValue
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.swing.text.html. FormSubmitEvent.MethodType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.tools. Diagnostic.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.tools. DocumentationTool.Location
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.tools. JavaFileObject.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.tools. StandardLocation
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.xml.bind.annotation. XmlAccessOrder
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.xml.bind.annotation. XmlAccessType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.xml.bind.annotation. XmlNsForm
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.xml.catalog. CatalogFeatures.Feature
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in class javax.xml.namespace. QName
QName派生自解析格式化的 String 。
valueOf(String) - Static method in enum javax.xml.ws.handler. MessageContext.Scope
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.xml.ws. Service.Mode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.xml.ws.soap. AddressingFeature.Responses
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum javax.xml.xpath. XPathEvaluationResult.XPathResultType
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.dynalink.linker. ConversionComparator.Comparison
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.dynalink. StandardNamespace
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.dynalink. StandardOperation
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.incubator.http. HttpClient.Redirect
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.incubator.http. HttpClient.Version
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.incubator.http. WebSocket.MessagePart
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.javadoc.doclet. Doclet.Option.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.javadoc.doclet. DocletEnvironment.ModuleMode
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.javadoc.doclet. Taglet.Location
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.jshell. Snippet.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.jshell. Snippet.Status
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.jshell. Snippet.SubKind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.jshell. SourceCodeAnalysis.Completeness
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.nashorn.api.tree. Diagnostic.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.nashorn.api.tree. Tree.Kind
以指定的名称返回此类型的枚举常量。
valueOf(String) - Static method in enum jdk.net. SocketFlow.Status
以指定的名称返回此类型的枚举常量。
valueOf(String, int) - Static method in class java.lang. Byte
返回一个 Byte对象，该对象保存从指定的 String提取的值，并用第二个参数给出的基数进行解析。
valueOf(String, int) - Static method in class java.lang. Integer
返回一个 Integer对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
valueOf(String, int) - Static method in class java.lang. Long
返回一个 Long对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
valueOf(String, int) - Static method in class java.lang. Short
返回一个 Short对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
valueOf(ByteBuffer) - Static method in class java.util. BitSet
返回一个包含给定字节缓冲区中所有位在其位置和极限之间的新位集合。
valueOf(LongBuffer) - Static method in class java.util. BitSet
返回包含给定长缓冲区中其位置和极限之间的所有位的新位集合。
valueOf(LocalDate) - Static method in class java.sql. Date
从一个LocalDate对象获取一个Date的实例，该对象与给定的LocalDate具有相同的年，月和日的值。
valueOf(LocalDateTime) - Static method in class java.sql. Timestamp
获取的实例 Timestamp从 LocalDateTime对象，以相同的年，月，月日，时，分，秒和毫微秒日期时间值作为提供 LocalDateTime 。
valueOf(LocalTime) - Static method in class java.sql. Time
从LocalTime对象获取Time的实例，具有与给定的LocalTime相同的小时，分钟和秒值。
ValueOutputStream - Interface in org.omg.CORBA.portable
Java到IDL ptc 02-01-12 1.5.1.3 ValueOutputStream用于实现RMI-IIOP流格式版本2。
valueProperty() - Method in class javafx.concurrent. Service
valueProperty() - Method in class javafx.concurrent. Task
valueProperty() - Method in interface javafx.concurrent. Worker
获取表示值的ReadOnlyObjectProperty。
valueProperty() - Method in class javafx.scene.chart. Axis.TickMark
数据单位中该刻度线的值
valueProperty() - Method in class javafx.scene.control. ChoiceBox
此ChoiceBox的值被定义为ChoiceBox选择模型中选定的项目。
valueProperty() - Method in class javafx.scene.control. ComboBoxBase
如果输入不可编辑，或者如果可编辑，则该组合框的值被定义为所选项，最近的用户操作：用户输入的值或最后选择的项。
valueProperty() - Method in class javafx.scene.control. ScrollBar
当前值由此 ScrollBar表示。
valueProperty() - Method in class javafx.scene.control. Slider
由此滑块表示的当前值。
valueProperty() - Method in class javafx.scene.control. Spinner
Spinner上的value属性是只读属性，因为它绑定到SpinnerValueFactory value property 。
valueProperty() - Method in class javafx.scene.control. SpinnerValueFactory
表示SpinnerValueFactory的当前值，如果未设置值，则为null。
valueProperty() - Method in class javafx.scene.control. TextFormatter
该格式化程序的当前值。
valueProperty() - Method in class javafx.scene.control. TreeItem
表示此TreeItem中包含的特定于应用程序的数据的属性。
ValueRange - Class in java.time.temporal
日期时间字段的有效值的范围。
values - Variable in class javax.naming.directory. BasicAttribute
保留属性的值。
values - Variable in class javax.swing.text.html.parser. AttributeList
可能的属性值
values() - Static method in enum com.sun.javadoc. LanguageVersion
已过时。
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class com.sun.management. GcInfo
values() - Static method in enum com.sun.management. VMOption.Origin
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class com.sun.net.httpserver. Headers
values() - Static method in enum com.sun.nio.sctp. AssociationChangeNotification.AssocChangeEvent
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.nio.sctp. HandlerResult
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.nio.sctp. PeerAddressChangeNotification.AddressChangeEvent
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.security.jgss. InquireType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.source.doctree. AttributeTree.ValueKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.source.doctree. DocTree.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.source.tree. LambdaExpressionTree.BodyKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.source.tree. MemberReferenceTree.ReferenceMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.source.tree. ModuleTree.ModuleKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.source.tree. Tree.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.source.util. TaskEvent.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum com.sun.tools.jconsole. JConsoleContext.ConnectionState
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. Component.BaselineResizeBehavior
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. Desktop.Action
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt.desktop. QuitStrategy
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt.desktop. UserSessionEvent.Reason
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. Dialog.ModalExclusionType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. Dialog.ModalityType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt.event. FocusEvent.Cause
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt.font. NumericShaper.Range
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. GraphicsDevice.WindowTranslucency
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. MultipleGradientPaint.ColorSpaceType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. MultipleGradientPaint.CycleMethod
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class java.awt. RenderingHints
返回 Collection视图包含在这个值的 RenderingHints 。
values() - Static method in enum java.awt. Taskbar.Feature
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. Taskbar.State
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. TrayIcon.MessageType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.awt. Window.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.io. ObjectInputFilter.Status
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.annotation. ElementType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.annotation. RetentionPolicy
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang. Character.UnicodeScript
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.invoke. VarHandle.AccessMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.management. MemoryType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.module. ModuleDescriptor.Exports.Modifier
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.module. ModuleDescriptor.Modifier
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.module. ModuleDescriptor.Opens.Modifier
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang.module. ModuleDescriptor.Requires.Modifier
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang. ProcessBuilder.Redirect.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang. StackWalker.Option
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang. System.Logger.Level
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.lang. Thread.State
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.math. RoundingMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.net. Authenticator.RequestorType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.net. Proxy.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.net. StandardProtocolFamily
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file. AccessMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file.attribute. AclEntryFlag
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file.attribute. AclEntryPermission
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file.attribute. AclEntryType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file.attribute. PosixFilePermission
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file. FileVisitOption
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file. FileVisitResult
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file. LinkOption
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file. StandardCopyOption
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.nio.file. StandardOpenOption
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.security.cert. CertPathValidatorException.BasicReason
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.security.cert. CRLReason
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.security.cert. PKIXReason
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.security.cert. PKIXRevocationChecker.Option
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.security. CryptoPrimitive
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.security. DrbgParameters.Capability
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.security. KeyRep.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class java.security. Provider
返回此提供程序中包含的属性值的不可修改的集合视图。
values() - Static method in enum java.sql. ClientInfoStatus
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.sql. JDBCType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.sql. PseudoColumnUsage
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.sql. RowIdLifetime
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.text. Normalizer.Form
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.chrono. HijrahEra
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.chrono. IsoEra
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in class java.time.chrono. JapaneseEra
返回一个JapaneseEras数组。
values() - Static method in enum java.time.chrono. MinguoEra
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.chrono. ThaiBuddhistEra
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time. DayOfWeek
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.format. FormatStyle
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.format. ResolverStyle
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.format. SignStyle
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.format. TextStyle
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time. Month
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.temporal. ChronoField
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.temporal. ChronoUnit
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.time.zone. ZoneOffsetTransitionRule.TimeDefinition
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class java.util. AbstractMap
返回此地图中包含的值的Collection视图。
values() - Method in class java.util.concurrent. ConcurrentHashMap
返回此地图中包含的值的Collection视图。
values() - Method in class java.util.concurrent. ConcurrentSkipListMap
返回此地图中包含的值的Collection视图。
values() - Static method in enum java.util.concurrent. TimeUnit
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class java.util. EnumMap
返回此地图中包含的值的Collection视图。
values() - Static method in enum java.util. Formatter.BigDecimalLayoutForm
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class java.util. HashMap
返回此地图中包含的值的Collection视图。
values() - Method in class java.util. Hashtable
返回此地图中包含的值的Collection视图。
values() - Method in class java.util. IdentityHashMap
返回此地图中包含的值的Collection视图。
values() - Method in class java.util.jar. Attributes
返回此Map中包含的属性值的集合视图。
values() - Method in class java.util. LinkedHashMap
返回此地图中包含的值的Collection视图。
values() - Static method in enum java.util. Locale.Category
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.util. Locale.FilteringMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum java.util. Locale.IsoCountryCode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in interface java.util. Map
返回此地图中包含的值的Collection视图。
values() - Method in class java.util. Properties
values() - Method in interface java.util. SortedMap
返回此地图中包含的值的Collection视图。
values() - Static method in enum java.util.stream. Collector.Characteristics
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class java.util. TreeMap
返回此地图中包含的值的Collection视图。
values() - Method in class java.util. WeakHashMap
返回此地图中包含的值的Collection视图。
values() - Static method in enum javafx.animation. Animation.Status
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.animation. PathTransition.OrientationType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.application. ConditionalFeature
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.application. Preloader.StateChangeNotification.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class javafx.beans.binding. MapExpression
values() - Static method in enum javafx.concurrent. Worker.State
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.css. SizeUnits
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.css. StyleOrigin
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. HorizontalDirection
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. HPos
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. NodeOrientation
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. Orientation
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. Pos
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. Side
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. VerticalDirection
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.geometry. VPos
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.print. Collation
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.print. PageOrientation
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.print. PrintColor
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.print. Printer.MarginType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.print. PrinterJob.JobStatus
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.print. PrintQuality
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.print. PrintSides
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene. AccessibleAction
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene. AccessibleAttribute
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene. AccessibleRole
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene. CacheHint
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.chart. LineChart.SortingPolicy
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. Alert.AlertType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. ButtonBar.ButtonData
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. ContentDisplay
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. OverrunStyle
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. ScrollPane.ScrollBarPolicy
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. SelectionMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control.skin. TextInputControlSkin.Direction
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control.skin. TextInputControlSkin.TextUnit
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. TableColumn.SortType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. TabPane.TabClosingPolicy
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. TreeSortMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.control. TreeTableColumn.SortType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene. DepthTest
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.effect. BlendMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.effect. BlurType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.image. PixelFormat.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. InputMethodHighlight
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. KeyCode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. KeyCombination.ModifierValue
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. MouseButton
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. ScrollEvent.HorizontalTextScrollUnits
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. ScrollEvent.VerticalTextScrollUnits
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. TouchPoint.State
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.input. TransferMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.layout. BackgroundRepeat
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.layout. BorderRepeat
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.layout. Priority
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.media. MediaException.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.media. MediaPlayer.Status
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.paint. CycleMethod
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.shape. ArcType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.shape. CullFace
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.shape. DrawMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.shape. FillRule
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.shape. StrokeLineCap
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.shape. StrokeLineJoin
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.shape. StrokeType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.text. FontPosture
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.text. FontSmoothingType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.text. FontWeight
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.text. TextAlignment
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.text. TextBoundsType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.transform. MatrixType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.scene.web. HTMLEditorSkin.Command
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.stage. Modality
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.stage. PopupWindow.AnchorLocation
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javafx.stage. StageStyle
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.annotation. Resource.AuthenticationType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.jws.soap. SOAPBinding.ParameterStyle
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.jws.soap. SOAPBinding.Style
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.jws.soap. SOAPBinding.Use
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.jws. WebParam.Mode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.lang.model.element. ElementKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.lang.model.element. Modifier
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.lang.model.element. ModuleElement.DirectiveKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.lang.model.element. NestingKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.lang.model. SourceVersion
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.lang.model.type. TypeKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.lang.model.util. Elements.Origin
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in interface javax.management.openmbean. CompositeData
返回此 CompositeData实例中包含的项目值的不可修改的集合视图。
values() - Method in class javax.management.openmbean. CompositeDataSupport
返回此 CompositeData实例中包含的项目值的不可修改的集合视图。
values() - Method in interface javax.management.openmbean. TabularData
返回 TabularData实例中包含的 CompositeData值（即行）的集合视图。
values() - Method in class javax.management.openmbean. TabularDataSupport
返回此 TabularDataSupport实例中包含的行的集合视图。
values() - Static method in enum javax.net.ssl. SSLEngineResult.HandshakeStatus
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.net.ssl. SSLEngineResult.Status
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class javax.script. SimpleBindings
返回此地图中包含的值的Collection视图。
values() - Static method in enum javax.smartcardio. CardTerminals.State
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing. DropMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing.event. RowSorterEvent.Type
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing. GroupLayout.Alignment
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing. JTable.PrintMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing. LayoutStyle.ComponentPlacement
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing.plaf.nimbus. AbstractRegionPainter.PaintContext.CacheMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing. RowFilter.ComparisonType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing. SortOrder
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing. SwingWorker.StateValue
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.swing.text.html. FormSubmitEvent.MethodType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.tools. Diagnostic.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.tools. DocumentationTool.Location
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.tools. JavaFileObject.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.tools. StandardLocation
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.bind.annotation. XmlAccessOrder
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.bind.annotation. XmlAccessType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.bind.annotation. XmlNsForm
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.catalog. CatalogFeatures.Feature
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.ws.handler. MessageContext.Scope
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.ws. Service.Mode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.ws.soap. AddressingFeature.Responses
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum javax.xml.xpath. XPathEvaluationResult.XPathResultType
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.dynalink.linker. ConversionComparator.Comparison
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.dynalink. StandardNamespace
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.dynalink. StandardOperation
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.incubator.http. HttpClient.Redirect
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.incubator.http. HttpClient.Version
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class jdk.incubator.http. MultiMapResult
values() - Static method in enum jdk.incubator.http. WebSocket.MessagePart
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.javadoc.doclet. Doclet.Option.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.javadoc.doclet. DocletEnvironment.ModuleMode
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.javadoc.doclet. Taglet.Location
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.jshell. Snippet.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.jshell. Snippet.Status
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.jshell. Snippet.SubKind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.jshell. SourceCodeAnalysis.Completeness
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Method in class jdk.nashorn.api.scripting. AbstractJSObject
values() - Method in interface jdk.nashorn.api.scripting. JSObject
返回此对象的所有属性值的集合。
values() - Method in class jdk.nashorn.api.scripting. ScriptObjectMirror
values() - Static method in enum jdk.nashorn.api.tree. Diagnostic.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.nashorn.api.tree. Tree.Kind
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
values() - Static method in enum jdk.net. SocketFlow.Status
按照它们声明的顺序返回一个包含此枚举类型常量的数组。
valueString(Object) - Static method in class jdk.jshell.execution. DirectExecutionControl
将 Object值从 ExecutionControl.invoke(String, String)或 ExecutionControl.varValue(String, String)转换为 String 。
valueToBe() - Method in interface com.sun.jdi.event. ModificationWatchpointEvent
当指令完成时将分配给该字段的值。
valueToString(Object) - Method in class javax.swing. JFormattedTextField.AbstractFormatter
返回要显示的字符串值为 value 。
valueToString(Object) - Method in class javax.swing.text. DefaultFormatter
通过 toString方法将Object中传递的对象转换为字符串。
valueToString(Object) - Method in class javax.swing.text. InternationalFormatter
返回Object value的String表示 value 。
valueToString(Object) - Method in class javax.swing.text. MaskFormatter
基于掩码返回对象 value的字符串表示形式。
ValueTree - Interface in com.sun.source.doctree
@value内联标记的树形节点。
VALUETYPE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“值类型”
valueUnbound(SSLSessionBindingEvent) - Method in interface javax.net.ssl. SSLSessionBindingListener
这被称为通知侦听器它正在从SSLSession绑定。
VAR - jdk.jshell. Snippet.Kind
一个变量声明。
VAR - Static variable in class javax.swing.text.html. HTML.Tag
标签<var>
VAR_DECLARATION_SUBKIND - jdk.jshell. Snippet.SubKind
没有初始化器的变量声明。
VAR_DECLARATION_WITH_INITIALIZER_SUBKIND - jdk.jshell. Snippet.SubKind
具有初始化器表达式的变量声明。
VAR_VALUE_SUBKIND - jdk.jshell. Snippet.SubKind
一个简单的变量引用表达式
VARBINARY - java.sql. JDBCType
标识通用SQL类型 VARBINARY 。
VARBINARY - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 VARBINARY 。
VARCHAR - java.sql. JDBCType
标识通用SQL类型 VARCHAR 。
VARCHAR - Static variable in class java.sql. Types
Java编程语言中的常量，有时称为类型代码，用于标识通用SQL类型 VARCHAR 。
VarHandle - Class in java.lang.invoke
VarHandle是对变量或参数定义的变量系列的动态强类型引用，包括静态字段，非静态字段，数组元素或非堆组数据结构的组件。
VarHandle.AccessMode - Enum in java.lang.invoke
指定如何访问由VarHandle引用的变量的访问模式集。
varHandleExactInvoker(VarHandle.AccessMode, MethodType) - Static method in class java.lang.invoke. MethodHandles
产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
varHandleInvoker(VarHandle.AccessMode, MethodType) - Static method in class java.lang.invoke. MethodHandles
产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
VARIABLE - com.sun.source.tree. Tree.Kind
用于VariableTree的实例。
VARIABLE - jdk.nashorn.api.tree. Tree.Kind
用于VariableTree的实例。
VariableElement - Interface in javax.lang.model.element
表示一个字段， 枚举常量，方法或构造函数参数，局部变量，资源变量或异常参数。
VariableHeightLayoutCache - Class in javax.swing.tree
注意：在将来的版本中这将变得更加开放。
VariableHeightLayoutCache() - Constructor for class javax.swing.tree. VariableHeightLayoutCache
构造一个 VariableHeightLayoutCache 。
variables() - Method in interface com.sun.jdi. 方法
返回包含此方法中声明的每个LocalVariable的列表。
variables() - Method in class jdk.jshell. JShell
返回活动变量片段。
variablesByName(String) - Method in interface com.sun.jdi. 方法
在此方法中返回包含给定名称的每个LocalVariable的列表。
VariableTree - Interface in com.sun.source.tree
用于变量声明的树节点。
VariableTree - Interface in jdk.nashorn.api.tree
一个树节点为 variable declaration statement 。
variant() - Method in class java.util. UUID
与此 UUID相关联的变式号。
VARIATION_SELECTORS - Static variable in class java.lang. Character.UnicodeBlock
“变异选择器”Unicode字符块的常量。
VARIATION_SELECTORS_SUPPLEMENT - Static variable in class java.lang. Character.UnicodeBlock
“变体选择器补充”Unicode字符块的常数。
VarSnippet - Class in jdk.jshell
变量定义的代码段。
varType() - Method in class java.lang.invoke. VarHandle
返回此VarHandle引用的变量的变量类型。
varValue(String, String) - Method in class jdk.jshell.execution. DirectExecutionControl
varValue(String, String) - Method in class jdk.jshell.execution. RemoteExecutionControl
varValue(String, String) - Method in class jdk.jshell.execution. StreamingExecutionControl
varValue(String, String) - Method in interface jdk.jshell.spi. ExecutionControl
返回变量的值。
varValue(VarSnippet) - Method in class jdk.jshell. JShell
获取变量的当前值。
vbarPolicyProperty() - Method in class javafx.scene.control. ScrollPane
指定显示垂直滚动条的策略。
VBox - Class in javafx.scene.layout
VBox把孩子放在一个垂直的立柱上。
VBox() - Constructor for class javafx.scene.layout. VBox
创建一个间距= 0并在TOP_LEFT对齐的VBox布局。
VBox(double) - Constructor for class javafx.scene.layout. VBox
创建一个VBox布局，并指定子间间距。
VBox(double, Node...) - Constructor for class javafx.scene.layout. VBox
创建一个VBox布局，其间指定间隔。
VBox(Node...) - Constructor for class javafx.scene.layout. VBox
创建一个间距= 0的VBox布局。
vcSupport - Variable in class java.beans.beancontext. BeanContextChildSupport
该 VetoableChangeSupport与此 BeanContextChildSupport相关联。
Vector< E> - Class in java.util
Vector类实现了可扩展的对象数组。
Vector() - Constructor for class java.util. Vector
构造一个空向量，使其内部数据数组的大小为 10 ，其标准容量增量为零。
Vector(int) - Constructor for class java.util. Vector
构造具有指定初始容量并且其容量增量等于零的空向量。
Vector(int, int) - Constructor for class java.util. Vector
构造具有指定的初始容量和容量增量的空向量。
Vector(Collection<? extends E>) - Constructor for class java.util. Vector
构造一个包含指定集合元素的向量，按照集合的迭代器返回的顺序。
VEDIC_EXTENSIONS - Static variable in class java.lang. Character.UnicodeBlock
“Vedic Extensions”Unicode字符块的常量。
vendorName - Variable in class javax.imageio.spi. IIOServiceProvider
A String由 getVendorName ，最初为 null 。
VERBOSE - Static variable in class java.rmi.server. LogStream
已过时。
日志级别常量（详细日志记录）。
verify(byte[]) - Method in class java.security. Signature
验证传入签名。
verify(byte[], int, int) - Method in class java.security. Signature
以指定的偏移量开始，以指定的字节数组验证传入签名。
verify(String, SSLSession) - Method in interface javax.net.ssl. HostnameVerifier
验证主机名是否与服务器认证方案可接受的匹配。
verify(PublicKey) - Method in class java.security.cert. Certificate
使用与指定公钥对应的私钥验证此证书是否已经签名。
verify(PublicKey) - Method in class java.security.cert. X509CRL
验证此CRL是否使用与给定公钥对应的私钥进行签名。
verify(PublicKey) - Method in class javax.security.cert. Certificate
已过时。
使用与指定公钥对应的私钥验证此证书是否已经签名。
verify(PublicKey, String) - Method in class java.security.cert. Certificate
使用与指定公钥对应的私钥验证此证书是否已经签名。
verify(PublicKey, String) - Method in class java.security.cert. X509CRL
验证此CRL是否使用与给定公钥对应的私钥进行签名。
verify(PublicKey, String) - Method in class javax.security.cert. Certificate
已过时。
使用与指定公钥对应的私钥验证此证书是否已经签名。
verify(PublicKey, Provider) - Method in class java.security.cert. Certificate
使用与指定公钥对应的私钥验证此证书是否已经签名。
verify(PublicKey, Provider) - Method in class java.security.cert. X509Certificate
使用与指定公钥对应的私钥验证此证书是否已经签名。
verify(PublicKey, Provider) - Method in class java.security.cert. X509CRL
验证此CRL是否使用与给定公钥对应的私钥进行签名。
verify(PublicKey, Signature) - Method in class java.security. SignedObject
验证此SignedObject中的签名是使用指定的验证引擎使用给定的验证密钥存储在其中的对象的有效签名。
verify(JComponent) - Method in class javax.swing. InputVerifier
检查JComponent的输入是否有效。
VERIFY - Static variable in class java.security. Signature
可能的值为 Signature.state ，表示此签名对象已初始化以进行验证。
VERIFY - Static variable in class javax.xml.crypto. KeySelector.Purpose
验证的关键
verifyAttributeCategory(Object, Class<?>) - Static method in class javax.print.attribute. AttributeSetUtilities
验证给定对象是否实现给定接口的Class ，该接口假定为接口Attribute或其子接口。
verifyAttributeValue(Object, Class<?>) - Static method in class javax.print.attribute. AttributeSetUtilities
验证给定的对象是给定接口的一个实例，它被假定为接口Attribute或其子接口。
verifyCategoryForValue(Class<?>, Attribute) - Static method in class javax.print.attribute. AttributeSetUtilities
验证给定的属性类别对象是否等于给定属性值对象的类别。
VerifyError - Error in java.lang
当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。
VerifyError() - Constructor for error java.lang. VerifyError
构造一个没有详细消息的 VerifyError 。
VerifyError(String) - Constructor for error java.lang. VerifyError
构造具有指定详细消息的 VerifyError 。
verifyMIC(byte[], int, int, byte[], int, int, MessageProp) - Method in interface org.ietf.jgss. GSSContext
通过提供的消息验证令牌参数中包含的密码MIC。
verifyMIC(InputStream, InputStream, MessageProp) - Method in interface org.ietf.jgss. GSSContext
通过提供的消息使用流来验证包含在令牌参数中的加密MIC。
verifyTarget(JComponent) - Method in class javax.swing. InputVerifier
检查将接收焦点的目标JComponent是否已准备好接受。
version - Variable in class javax.imageio.spi. IIOServiceProvider
A String从 getVersion返回，最初为null。
version - Variable in class org.omg.CORBA. ValueMember
该成员定义的版本为 value 。
version() - Method in interface com.sun.jdi. VirtualMachine
返回由属性 java.version报告的目标虚拟机中的Java运行时环境的版本。
version() - Method in class java.lang.module. ModuleDescriptor
返回模块版本。
version() - Static method in class java.lang. Runtime
以Runtime.Version返回Java运行时环境的版本 。
version() - Method in class java.lang. Runtime.Version
返回version number中包含的整数的不可修改的List 。
version() - Method in class java.util. UUID
与此 UUID相关联的版本号。
version() - Method in class jdk.incubator.http. HttpClient
返回此客户端请求的HTTP协议版本。
version() - Method in class jdk.incubator.http. HttpRequest
返回一个 Optional其中包含将要为此 HttpRequest请求的HTTP协议版本。
version() - Method in class jdk.incubator.http. HttpResponse
返回用于此响应的HTTP协议版本。
version(ModuleDescriptor.Version) - Method in class java.lang.module. ModuleDescriptor.Builder
设置模块版本。
version(String) - Method in class java.lang.module. ModuleDescriptor.Builder
设置模块版本。
version(HttpClient.Version) - Method in class jdk.incubator.http. HttpClient.Builder
在可能的情况下请求特定的HTTP协议版本。
version(HttpClient.Version) - Method in class jdk.incubator.http. HttpRequest.Builder
为此请求设置首选的HttpClient.Version 。
VERSION - com.sun.source.doctree. DocTree.Kind
用于表示@version标签的VersionTree的实例。
VERSION - Static variable in class javax.swing.text.html. HTML.Attribute
属性“版本”
VERSION - Static variable in class javax.xml.transform. OutputKeys
version = nmtoken 。
versionColumnNotPseudo - Static variable in interface java.sql. DatabaseMetaData
表示此版本列不是伪列。
versionColumnPseudo - Static variable in interface java.sql. DatabaseMetaData
表示此版本列是伪列。
versionColumnUnknown - Static variable in interface java.sql. DatabaseMetaData
表示此版本列可能是也可能不是伪列。
VersionSpecHelper - Class in org.omg.CORBA
助手 VersionSpec 。
VersionSpecHelper() - Constructor for class org.omg.CORBA. VersionSpecHelper
VersionTree - Interface in com.sun.source.doctree
用于@version块标记的树节点。
VertexFormat - Class in javafx.scene.shape
定义网格中顶点的格式。
vertexFormatProperty() - Method in class javafx.scene.shape. TriangleMesh
指定 TriangleMesh的顶点格式， VertexFormat.POINT_TEXCOORD或 VertexFormat.POINT_NORMAL_TEXCOORD 。
VERTICAL - javafx.geometry. Orientation
垂直（顶部< - >底部）方向
VERTICAL - Static variable in interface java.awt. Adjustable
表示 Adjustable具有垂直方向。
VERTICAL - Static variable in class java.awt. GridBagConstraints
垂直调整组件大小但不水平调整。
VERTICAL - Static variable in class java.awt. Scrollbar
一个常量，表示垂直滚动条。
VERTICAL - Static variable in class javax.accessibility. AccessibleState
表示此对象的方向是垂直的。
VERTICAL - Static variable in class javax.swing. JList
表示单个列中的单元格的垂直布局; 默认布局。
VERTICAL - Static variable in interface javax.swing. SwingConstants
垂直方向。
VERTICAL_ALIGN - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“vertical-align”。
VERTICAL_ALIGNMENT_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按钮垂直对齐方式的变化。
VERTICAL_CENTER - Static variable in class javax.swing. SpringLayout
指定组件的边界矩形的垂直中心。
VERTICAL_FORMS - Static variable in class java.lang. Character.UnicodeBlock
“垂直格式”Unicode字符块的常量。
VERTICAL_SCROLLBAR - javafx.scene. AccessibleAttribute
返回节点的垂直滚动条。
VERTICAL_SCROLLBAR - Static variable in interface javax.swing. ScrollPaneConstants
标识垂直滚动条。
VERTICAL_SCROLLBAR_ALWAYS - Static variable in interface javax.swing. ScrollPaneConstants
用于设置垂直滚动条策略，以便始终显示垂直滚动条。
VERTICAL_SCROLLBAR_AS_NEEDED - Static variable in interface javax.swing. ScrollPaneConstants
用于设置垂直滚动条策略，以便只在需要时显示垂直滚动条。
VERTICAL_SCROLLBAR_NEVER - Static variable in interface javax.swing. ScrollPaneConstants
用于设置垂直滚动条策略，从而不会显示垂直滚动条。
VERTICAL_SCROLLBAR_POLICY - Static variable in interface javax.swing. ScrollPaneConstants
标识垂直滚动条策略属性。
VERTICAL_SPLIT - Static variable in class javax.swing. JSplitPane
垂直分割表示 Component s沿y轴分割。
VERTICAL_TEXT_POSITION_CHANGED_PROPERTY - Static variable in class javax.swing. AbstractButton
标识按钮垂直文本位置的变化。
VERTICAL_WRAP - Static variable in class javax.swing. JList
表示“报纸风格”布局，单元格横向垂直流动。
VerticalDirection - Enum in javafx.geometry
表示垂直方向的枚举。
VerticalDragController(MouseEvent) - Constructor for class javax.swing.plaf.basic. BasicSplitPaneDivider.VerticalDragController
构造一个新的实例 VerticalDragController 。
verticalFieldOfViewProperty() - Method in class javafx.scene. PerspectiveCamera
定义 fieldOfView属性是否适用于投影的垂直维度。
verticalGridLinesVisibleProperty() - Method in class javafx.scene.chart. XYChart
如果绘制垂直网格线，则为真
verticalProperty() - Method in class javafx.scene.control.skin. VirtualFlow
表明虚拟化的主要方向。
verticalScrollBar - Variable in class javax.swing. JScrollPane
滚动盘的垂直滚动条小孩。
verticalScrollBarPolicy - Variable in class javax.swing. JScrollPane
垂直滚动条的显示策略。
verticalZeroLineVisibleProperty() - Method in class javafx.scene.chart. XYChart
如果这是真的并且垂直轴具有正值和负值，则在零点处将绘制另外的轴线
vertThumbIcon - Static variable in class javax.swing.plaf.metal. MetalSliderUI
默认垂直拇指 Icon 。
vetoableChange(PropertyChangeEvent) - Method in class java.beans.beancontext. BeanContextSupport
子类可以包围以监视否决权子变化。
vetoableChange(PropertyChangeEvent) - Method in interface java.beans. VetoableChangeListener
当更改约束属性时调用此方法。
vetoableChange(PropertyChangeEvent) - Method in class java.beans. VetoableChangeListenerProxy
将属性更改事件转发给侦听器代理。
VETOABLECHANGE - Static variable in class com.sun.java.accessibility.util. EventID
Maps to Beans VetoableChange支持（即VetoableChangeListener和VetoableChangeEvent）
VetoableChangeListener - Interface in java.beans
当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
VetoableChangeListenerProxy - Class in java.beans
一个类扩展了 EventListenerProxy专门用于添加一个“约束”属性的 VetoableChangeListener 。
VetoableChangeListenerProxy(String, VetoableChangeListener) - Constructor for class java.beans. VetoableChangeListenerProxy
将 VetoableChangeListener绑定到特定属性的构造方法。
VetoableChangeSupport - Class in java.beans
这是一个可以由支持约束属性的bean使用的实用程序类。
VetoableChangeSupport(Object) - Constructor for class java.beans. VetoableChangeSupport
构造一个 VetoableChangeSupport对象。
vgapProperty() - Method in class javafx.scene.layout. FlowPane
垂直花式板中每个节点之间的垂直空间量或水平流动叶片中的行间距。
vgapProperty() - Method in class javafx.scene.layout. GridPane
行之间的垂直间隙的高度。
vgapProperty() - Method in class javafx.scene.layout. TilePane
列中每个图块之间的垂直空间量。
vgrowProperty() - Method in class javafx.scene.layout. RowConstraints
该行的垂直成长优先级。
VideoTrack - Class in javafx.scene.media
描述视频轨道的Track 。
View - Class in javax.swing.text
文本包中非常重要的一部分是 View课。
View(Element) - Constructor for class javax.swing.text. View
创建一个新的 View对象。
ViewCSS - Interface in org.w3c.dom.css
此接口表示CSS视图。
ViewFactory - Interface in javax.swing.text
一个工厂创建一部分文件主题的视图。
ViewListener() - Constructor for class javax.swing. JViewport.ViewListener
viewMenuIcon - Variable in class javax.swing.plaf.basic. BasicFileChooserUI
查看菜单图标
viewOrderProperty() - Method in class javafx.scene. Node
定义其父母中的 Node的呈现和拣选顺序。
viewport - Variable in class javax.swing. JScrollPane
滚动窗口的视口小孩。
viewport - Variable in class javax.swing. ScrollPaneLayout
滚动窗口的视口小孩。
viewPort - Variable in class javax.swing. JScrollPane.AccessibleJScrollPane
这 JScrollPane的当前 JViewport
VIEWPORT - Static variable in class javax.accessibility. AccessibleRole
通常在滚动窗格中使用的对象。
VIEWPORT - Static variable in class javax.swing.plaf.synth. Region
视口区域。
VIEWPORT - Static variable in interface javax.swing. ScrollPaneConstants
标识“视口”或显示区域，滚动内容可以在其中显示。
viewportBoundsProperty() - Method in class javafx.scene.control. ScrollPane
ScrollPane视口的实际边界。
ViewportChangeHandler() - Constructor for class javax.swing.plaf.basic. BasicScrollPaneUI.ViewportChangeHandler
viewportChangeListener - Variable in class javax.swing.plaf.basic. BasicScrollPaneUI
ChangeListener安装在视口上。
ViewportLayout - Class in javax.swing
默认布局管理器为 JViewport 。
ViewportLayout() - Constructor for class javax.swing. ViewportLayout
viewportProperty() - Method in class javafx.scene.image. ImageView
矩形视口进入图像。
viewportProperty() - Method in class javafx.scene.media. MediaView
指定一个矩形视口到媒体框架。
ViewportUI - Class in javax.swing.plaf
JViewport可插拔的外观和界面。
ViewportUI() - Constructor for class javax.swing.plaf. ViewportUI
viewToModel(float, float, Shape) - Method in class javax.swing.text. View
已过时。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. AsyncBoxView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. BoxView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. ComponentView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. CompositeView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. FieldView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. GlyphView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.html. ImageView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. IconView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. PasswordView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. PlainView
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. View
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(Point) - Method in class javax.swing.text. JTextComponent
已过时。
替换为JTextComponent.viewToModel2D(Point2D)
viewToModel(GlyphView, float, float, Shape, Position.Bias[]) - Method in class javax.swing.text. GlyphView.GlyphPainter
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(JTextComponent, Point) - Method in class javax.swing.plaf.basic. BasicTextUI
已过时。
代之以BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
viewToModel(JTextComponent, Point) - Method in class javax.swing.plaf.multi. MultiTextUI
已过时。
viewToModel(JTextComponent, Point) - Method in class javax.swing.plaf. TextUI
已过时。
取代TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
viewToModel(JTextComponent, Point, Position.Bias[]) - Method in class javax.swing.plaf.basic. BasicTextUI
已过时。
替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
viewToModel(JTextComponent, Point, Position.Bias[]) - Method in class javax.swing.plaf.multi. MultiTextUI
已过时。
viewToModel(JTextComponent, Point, Position.Bias[]) - Method in class javax.swing.plaf. TextUI
已过时。
替换为TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
viewToModel2D(Point2D) - Method in class javax.swing.text. JTextComponent
将视图坐标系中的给定位置转换为模型中最近的代表位置。
viewToModel2D(JTextComponent, Point2D, Position.Bias[]) - Method in class javax.swing.plaf.basic. BasicTextUI
viewToModel2D(JTextComponent, Point2D, Position.Bias[]) - Method in class javax.swing.plaf.multi. MultiTextUI
viewToModel2D(JTextComponent, Point2D, Position.Bias[]) - Method in class javax.swing.plaf. TextUI
提供从视图坐标空间到模型的逻辑坐标空间的映射。
VIOLET - Static variable in class javafx.scene.paint. Color
颜色紫色，RGB值为＃EE82EE
VIRTUAL_KEYBOARD - javafx.application. ConditionalFeature
指示是否使用屏幕上的虚拟键盘进行文本输入。
VirtualContainerBase< C extends Control, I extends IndexedCell> - Class in javafx.scene.control.skin
父类控制其内容虚拟化和可滚动的外观。
VirtualContainerBase(C) - Constructor for class javafx.scene.control.skin. VirtualContainerBase
VirtualFlow< T extends IndexedCell> - Class in javafx.scene.control.skin
使用基于单元的机制实现虚拟化容器。
VirtualFlow() - Constructor for class javafx.scene.control.skin. VirtualFlow
创建一个新的VirtualFlow实例。
virtualMachine() - Method in interface com.sun.jdi. Mirror
获取此镜像所属的VirtualMachine。
VirtualMachine - Class in com.sun.tools.attach
Java虚拟机。
VirtualMachine - Interface in com.sun.jdi
用于调试的虚拟机。
VirtualMachine(AttachProvider, String) - Constructor for class com.sun.tools.attach. VirtualMachine
初始化此类的新实例。
VirtualMachineDescriptor - Class in com.sun.tools.attach
描述一个Java虚拟机。
VirtualMachineDescriptor(AttachProvider, String) - Constructor for class com.sun.tools.attach. VirtualMachineDescriptor
从给定的组件创建一个虚拟机描述符。
VirtualMachineDescriptor(AttachProvider, String, String) - Constructor for class com.sun.tools.attach. VirtualMachineDescriptor
从给定的组件创建一个虚拟机描述符。
VirtualMachineError - Error in java.lang
抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。
VirtualMachineError() - Constructor for error java.lang. VirtualMachineError
构造一个 VirtualMachineError ，没有详细消息。
VirtualMachineError(String) - Constructor for error java.lang. VirtualMachineError
构造具有指定详细消息的 VirtualMachineError 。
VirtualMachineError(String, Throwable) - Constructor for error java.lang. VirtualMachineError
构造一个 VirtualMachineError具有指定的详细信息和原因。
VirtualMachineError(Throwable) - Constructor for error java.lang. VirtualMachineError
构造一个一个 VirtualMachineError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
virtualMachineManager() - Static method in class com.sun.jdi. Bootstrap
返回虚拟机管理器。
VirtualMachineManager - Interface in com.sun.jdi
目标虚拟机的连接经理。
Visibility - Interface in java.beans
在某些情况下，可能在GUI不可用的服务器上运行bean。
VISIBILITY_CHANGED - Static variable in class javafx.scene.web. WebEvent
当脚本更改JavaScript window对象的可见性时，会发生此事件。
VisibilityHelper - Class in org.omg.CORBA
助手 Visibility 。
VisibilityHelper() - Constructor for class org.omg.CORBA. VisibilityHelper
VISIBLE - javafx.scene. AccessibleAttribute
如果节点可见，则返回true，否则返回false。
VISIBLE - Static variable in class javax.accessibility. AccessibleState
表示此对象可见。
VISIBLE_ROW_COUNT_PROPERTY - Static variable in class javax.swing. JTree
绑定属性名称为 visibleRowCount 。
visibleAmountProperty() - Method in class javafx.scene.control. ScrollBar
滚动条的范围可见，通常由滚动条的大小表示。
visibleClasses() - Method in interface com.sun.jdi. ClassLoaderReference
返回此类加载器已被记录为目标VM中的启动加载程序的所有类的列表。
visibleFields() - Method in interface com.sun.jdi. ReferenceType
返回一个包含这种类型的每个不隐藏和明确的Field的列表。
visibleMethods() - Method in interface com.sun.jdi. ReferenceType
返回包含此类型声明或继承的每个方法的列表。
visibleProperty() - Method in class javafx.scene.control. MenuItem
指定此MenuItem是否应呈现为场景图的一部分。
visibleProperty() - Method in class javafx.scene.control. TableColumnBase
切换此项将立即切换此列和所有子列的可见性。
visibleProperty() - Method in class javafx.scene. Node
指定此 Node和任何子节点是否应呈现为场景图的一部分。
visibleRowCount - Variable in class javax.swing. JTree
一次可见的行数。
visibleRowCountProperty() - Method in class javafx.scene.control. ComboBox
ComboBox弹出窗口中显示的最大行数。
visibleVariableByName(String) - Method in interface com.sun.jdi. StackFrame
找到匹配给定名称的LocalVariable ，并在当前帧位置可见。
visibleVariables() - Method in interface com.sun.jdi. StackFrame
返回一个包含可以从此框架的位置访问的每个LocalVariable的列表。
visit(DocTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
调用特定于节点类型的适当访问方式。
visit(Tree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
调用特定于节点类型的适当访问方式。
visit(Iterable<? extends DocTree>, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
在每个节点序列上调用适当的访问方法。
visit(Iterable<? extends Tree>, P) - Method in class com.sun.source.util. SimpleTreeVisitor
在每个节点序列上调用适当的访问方法。
visit(AnnotationValue) - Method in interface javax.lang.model.element. AnnotationValueVisitor
方便的方法相当于 visit(av, null) 。
visit(AnnotationValue) - Method in class javax.lang.model.util. AbstractAnnotationValueVisitor6
访问注释值，就像将自身传递给该值的 accept方法，通过 null的附加参数。
visit(AnnotationValue, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释值。
visit(AnnotationValue, P) - Method in class javax.lang.model.util. AbstractAnnotationValueVisitor6
访问任何注释值，就像将其自身传递给该值的 accept一样 。
visit(Element) - Method in interface javax.lang.model.element. ElementVisitor
方便的方法相当于 visit(e, null) 。
visit(Element) - Method in class javax.lang.model.util. AbstractElementVisitor6
访问任何程序元素，就像将其自身传递给该元素的 accept方法一样，并通过其他参数传递 null 。
visit(Element, P) - Method in interface javax.lang.model.element. ElementVisitor
访问元素
visit(Element, P) - Method in class javax.lang.model.util. AbstractElementVisitor6
访问任何程序元素，就像将其自身传递给该元素的 accept方法一样。
visit(ModuleElement.Directive) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问任何指令，就好像通过传递该指令的 accept方法并传递 null附加参数。
visit(ModuleElement.Directive, P) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问任何指令，好像通过传递自己的指令的 accept方法。
visit(TypeMirror) - Method in interface javax.lang.model.type. TypeVisitor
方便的方法相当于 visit(t, null) 。
visit(TypeMirror) - Method in class javax.lang.model.util. AbstractTypeVisitor6
访问任何类型的镜像，就像将自身传递给该镜像的 accept方法一样，并通过其他参数传递 null 。
visit(TypeMirror, P) - Method in interface javax.lang.model.type. TypeVisitor
访问类型。
visit(TypeMirror, P) - Method in class javax.lang.model.util. AbstractTypeVisitor6
访问任何类型的镜像，就像将自身传递给该镜像的 accept方法一样。
visitAnnotatedType(AnnotatedTypeTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问AnnotatedTypeTree节点。
visitAnnotatedType(AnnotatedTypeTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问AnnotatedTypeTree节点。
visitAnnotatedType(AnnotatedTypeTree, P) - Method in class com.sun.source.util. TreeScanner
访问AnnotatedTypeTree节点。
visitAnnotation(AnnotationTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问AnnotatedTree节点。
visitAnnotation(AnnotationTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问AnnotatedTree节点。
visitAnnotation(AnnotationTree, P) - Method in class com.sun.source.util. TreeScanner
访问AnnotatedTree节点。
visitAnnotation(AnnotationMirror, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的注释值。
visitAnnotation(AnnotationMirror, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的注释值。
visitArray(List<? extends AnnotationValue>, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的数组值。
visitArray(List<? extends AnnotationValue>, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的数组值。
visitArray(ArrayType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问数组类型。
visitArray(ArrayType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问数组类型。
visitArrayAccess(ArrayAccessTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ArrayAccessTree节点。
visitArrayAccess(ArrayAccessTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ArrayAccessTree节点。
visitArrayAccess(ArrayAccessTree, P) - Method in class com.sun.source.util. TreeScanner
访问ArrayAccessTree节点。
visitArrayAccess(ArrayAccessTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitArrayAccess(ArrayAccessTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问数组访问表达式树。
visitArrayLiteral(ArrayLiteralTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitArrayLiteral(ArrayLiteralTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问数组文字表达式树。
visitArrayType(ArrayTypeTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ArrayTypeTree节点。
visitArrayType(ArrayTypeTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ArrayTypeTree节点。
visitArrayType(ArrayTypeTree, P) - Method in class com.sun.source.util. TreeScanner
访问ArrayTypeTree节点。
visitAssert(AssertTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问AssertTree节点。
visitAssert(AssertTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问AssertTree节点。
visitAssert(AssertTree, P) - Method in class com.sun.source.util. TreeScanner
访问AssertTree节点。
visitAssignment(AssignmentTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问AssignmentTree节点。
visitAssignment(AssignmentTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问AssignmentTree节点。
visitAssignment(AssignmentTree, P) - Method in class com.sun.source.util. TreeScanner
访问AssignmentTree节点。
visitAssignment(AssignmentTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitAssignment(AssignmentTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问作业树。
visitAttribute(AttributeTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问AttributeTree节点。
visitAttribute(AttributeTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问AttributeTree节点。
visitAttribute(AttributeTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问AttributeTree节点。
visitAuthor(AuthorTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问AuthorTree节点。
visitAuthor(AuthorTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问AuthorTree节点。
visitAuthor(AuthorTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问AuthorTree节点。
visitBinary(BinaryTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问二进制流节点。
visitBinary(BinaryTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问二进制流节点。
visitBinary(BinaryTree, P) - Method in class com.sun.source.util. TreeScanner
访问二进制流节点。
visitBinary(BinaryTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitBinary(BinaryTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问二进制表达式树。
visitBlock(BlockTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问BlockTree节点。
visitBlock(BlockTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问BlockTree节点。
visitBlock(BlockTree, P) - Method in class com.sun.source.util. TreeScanner
访问BlockTree节点。
visitBlock(BlockTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitBlock(BlockTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问块语句树。
visitBoolean(boolean, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
在注释中访问 boolean值。
visitBoolean(boolean, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的一个 boolean值。
visitBreak(BreakTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问BreakTree节点。
visitBreak(BreakTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问BreakTree节点。
visitBreak(BreakTree, P) - Method in class com.sun.source.util. TreeScanner
访问BreakTree节点。
visitBreak(BreakTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitBreak(BreakTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问break语句树。
visitByte(byte, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的 byte值。
visitByte(byte, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的 byte值。
visitCase(CaseTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问CaseTree节点。
visitCase(CaseTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问CaseTree节点。
visitCase(CaseTree, P) - Method in class com.sun.source.util. TreeScanner
访问CaseTree节点。
visitCase(CaseTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitCase(CaseTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问case语句树。
visitCatch(CatchTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问CatchTree节点。
visitCatch(CatchTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问CatchTree节点。
visitCatch(CatchTree, P) - Method in class com.sun.source.util. TreeScanner
访问CatchTree节点。
visitCatch(CatchTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitCatch(CatchTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问catch块语句树。
visitChar(char, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
在注释中访问 char值。
visitChar(char, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的一个 char值。
visitClass(ClassTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ClassTree节点。
visitClass(ClassTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ClassTree节点。
visitClass(ClassTree, P) - Method in class com.sun.source.util. TreeScanner
访问ClassTree节点。
visitClassDeclaration(ClassDeclarationTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
通过致电 visitUnknown访问一个 ClassDeclarationTree树。
visitClassDeclaration(ClassDeclarationTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问类语句树。
visitClassDeclaration(ClassDeclarationTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问类语句树。
visitClassExpression(ClassExpressionTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
通过致电 visitUnknown访问 ClassExpressionTree树。
visitClassExpression(ClassExpressionTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问类表达式树。
visitClassExpression(ClassExpressionTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问类表达式树。
visitComment(CommentTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问CommentTree节点。
visitComment(CommentTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问CommentTree节点。
visitComment(CommentTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问CommentTree节点。
visitCompilationUnit(CompilationUnitTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问CompilationUnitTree节点。
visitCompilationUnit(CompilationUnitTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问CompilationUnitTree节点。
visitCompilationUnit(CompilationUnitTree, P) - Method in class com.sun.source.util. TreeScanner
访问CompilationUnitTree节点。
visitCompilationUnit(CompilationUnitTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitCompilationUnit(CompilationUnitTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
visitCompilationUnit(CompilationUnitTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问编译单元树。
visitCompoundAssignment(CompoundAssignmentTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问一个CompoundAssignmentTree节点。
visitCompoundAssignment(CompoundAssignmentTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问一个CompoundAssignmentTree节点。
visitCompoundAssignment(CompoundAssignmentTree, P) - Method in class com.sun.source.util. TreeScanner
访问一个CompoundAssignmentTree节点。
visitCompoundAssignment(CompoundAssignmentTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitCompoundAssignment(CompoundAssignmentTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问复合分配树。
visitConditionalExpression(ConditionalExpressionTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问一个ConditionalExpressionTree节点。
visitConditionalExpression(ConditionalExpressionTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问一个ConditionalExpressionTree节点。
visitConditionalExpression(ConditionalExpressionTree, P) - Method in class com.sun.source.util. TreeScanner
访问一个ConditionalExpressionTree节点。
visitConditionalExpression(ConditionalExpressionTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitConditionalExpression(ConditionalExpressionTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问条件表达式树。
visitContinue(ContinueTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ContinueTree节点。
visitContinue(ContinueTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ContinueTree节点。
visitContinue(ContinueTree, P) - Method in class com.sun.source.util. TreeScanner
访问ContinueTree节点。
visitContinue(ContinueTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitContinue(ContinueTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问continue语句树。
visitDebugger(DebuggerTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitDebugger(DebuggerTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问调试器语句树。
visitDeclared(DeclaredType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问已声明的类型。
visitDeclared(DeclaredType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问已声明的类型。
visitDeprecated(DeprecatedTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问DeprecatedTree节点。
visitDeprecated(DeprecatedTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问DeprecatedTree节点。
visitDeprecated(DeprecatedTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问DeprecatedTree节点。
visitDocComment(DocCommentTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问DocCommentTree节点。
visitDocComment(DocCommentTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问DocCommentTree节点。
visitDocComment(DocCommentTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问DocCommentTree节点。
visitDocRoot(DocRootTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问DocRootTree节点。
visitDocRoot(DocRootTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问DocRootTree节点。
visitDocRoot(DocRootTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问DocRootTree节点。
visitDouble(double, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的 double值。
visitDouble(double, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的 double值。
visitDoWhileLoop(DoWhileLoopTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问DoWhileTree节点。
visitDoWhileLoop(DoWhileLoopTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问DoWhileTree节点。
visitDoWhileLoop(DoWhileLoopTree, P) - Method in class com.sun.source.util. TreeScanner
访问DoWhileTree节点。
visitDoWhileLoop(DoWhileLoopTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitDoWhileLoop(DoWhileLoopTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问do-while语句树。
VISITED - javafx.scene. AccessibleAttribute
如果节点被访问，返回true，否则返回false。
visitedProperty() - Method in class javafx.scene.control. Hyperlink
指示此链接是否已被“访问”。
visitEmptyStatement(EmptyStatementTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问一个EmptyStatementTree节点。
visitEmptyStatement(EmptyStatementTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问一个EmptyStatementTree节点。
visitEmptyStatement(EmptyStatementTree, P) - Method in class com.sun.source.util. TreeScanner
访问一个EmptyStatementTree节点。
visitEmptyStatement(EmptyStatementTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitEmptyStatement(EmptyStatementTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问一个空的语句树。
visitEndElement(EndElementTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问EndElementTree节点。
visitEndElement(EndElementTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问EndElementTree节点。
visitEndElement(EndElementTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问EndElementTree节点。
visitEnhancedForLoop(EnhancedForLoopTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问EnhancedForLoopTree节点。
visitEnhancedForLoop(EnhancedForLoopTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问EnhancedForLoopTree节点。
visitEnhancedForLoop(EnhancedForLoopTree, P) - Method in class com.sun.source.util. TreeScanner
访问EnhancedForLoopTree节点。
visitEntity(EntityTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问EntityTree节点。
visitEntity(EntityTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问EntityTree节点。
visitEntity(EntityTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问EntityTree节点。
visitEnumConstant(VariableElement, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
在注释中访问 枚举值。
visitEnumConstant(VariableElement, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
在注释中访问 枚举值。
visitErroneous(ErroneousTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问ErroneousTree节点。
visitErroneous(ErroneousTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问ErroneousTree节点。
visitErroneous(ErroneousTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问ErroneousTree节点。
visitErroneous(ErroneousTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ErroneousTree节点。
visitErroneous(ErroneousTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
visitErroneous(ErroneousTree, P) - Method in class com.sun.source.util. TreeScanner
访问ErroneousTree节点。
visitErroneous(ErroneousTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitErroneous(ErroneousTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问错误表达式树。
visitError(ErrorType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问错误类型。
visitError(ErrorType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问错误类型。
visitExecutable(ExecutableElement, P) - Method in interface javax.lang.model.element. ElementVisitor
访问可执行元素。
visitExecutable(ExecutableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
访问的可执行元件，指派给该访问方法用于特定kind可执行的CONSTRUCTOR ， INSTANCE_INIT ， METHOD ，或STATIC_INIT 。
visitExecutable(ExecutableElement, P) - Method in class javax.lang.model.util. ElementScanner6
访问可执行元素。
visitExecutable(ExecutableElement, P) - Method in class javax.lang.model.util. SimpleElementVisitor6
访问可执行元素。
visitExecutable(ExecutableType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问可执行文件类型。
visitExecutable(ExecutableType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问可执行文件类型。
visitExecutableAsConstructor(ExecutableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 CONSTRUCTOR可执行元素。
visitExecutableAsInstanceInit(ExecutableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 INSTANCE_INIT可执行元素。
visitExecutableAsMethod(ExecutableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 METHOD可执行元素。
visitExecutableAsStaticInit(ExecutableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 STATIC_INIT可执行元素。
visitExportEntry(ExportEntryTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
致电 visitUnknown ExportEntryTree树。
visitExportEntry(ExportEntryTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问模块ExportEntry树。
visitExportEntry(ExportEntryTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问模块ExportEntry树。
visitExports(ExportsTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ExportsTree节点。
visitExports(ExportsTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
visitExports(ExportsTree, P) - Method in class com.sun.source.util. TreeScanner
visitExports(ModuleElement.ExportsDirective, P) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问 exports指令。
visitExpressionStatement(ExpressionStatementTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ExpressionStatementTree节点。
visitExpressionStatement(ExpressionStatementTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ExpressionStatementTree节点。
visitExpressionStatement(ExpressionStatementTree, P) - Method in class com.sun.source.util. TreeScanner
访问ExpressionStatementTree节点。
visitExpressionStatement(ExpressionStatementTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitExpressionStatement(ExpressionStatementTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问表达式语句树。
visitFile(T, BasicFileAttributes) - Method in interface java.nio.file. FileVisitor
为目录中的文件调用。
visitFile(T, BasicFileAttributes) - Method in class java.nio.file. SimpleFileVisitor
为目录中的文件调用。
visitFileFailed(T, IOException) - Method in interface java.nio.file. FileVisitor
为无法访问的文件调用。
visitFileFailed(T, IOException) - Method in class java.nio.file. SimpleFileVisitor
为无法访问的文件调用。
visitFloat(float, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的一个 float值。
visitFloat(float, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的一个 float值。
visitForInLoop(ForInLoopTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitForInLoop(ForInLoopTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问for语句树。
visitForLoop(ForLoopTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ForLoopTree节点。
visitForLoop(ForLoopTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ForLoopTree节点。
visitForLoop(ForLoopTree, P) - Method in class com.sun.source.util. TreeScanner
访问ForLoopTree节点。
visitForLoop(ForLoopTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitForLoop(ForLoopTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问'for'语句树。
visitForOfLoop(ForOfLoopTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
通过致电 visitUnknown访问 ForOfLoopTree树。
visitForOfLoop(ForOfLoopTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问声明树。
visitForOfLoop(ForOfLoopTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问声明树。
visitFunctionCall(FunctionCallTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitFunctionCall(FunctionCallTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问函数调用表达式树。
visitFunctionDeclaration(FunctionDeclarationTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitFunctionDeclaration(FunctionDeclarationTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问函数声明树。
visitFunctionExpression(FunctionExpressionTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitFunctionExpression(FunctionExpressionTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问函数表达式树。
visitHidden(HiddenTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问HiddenTree节点。
visitHidden(HiddenTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问HiddenTree节点。
visitHidden(HiddenTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问HiddenTree节点。
visitIdentifier(IdentifierTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问IdentifierTree节点。
visitIdentifier(IdentifierTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问IdentifierTree节点。
visitIdentifier(IdentifierTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问IdentifierTree节点。
visitIdentifier(IdentifierTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问IdentifierTree节点。
visitIdentifier(IdentifierTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问IdentifierTree节点。
visitIdentifier(IdentifierTree, P) - Method in class com.sun.source.util. TreeScanner
访问IdentifierTree节点。
visitIdentifier(IdentifierTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitIdentifier(IdentifierTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问标识符树。
visitIf(IfTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问IfTree节点。
visitIf(IfTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问IfTree节点。
visitIf(IfTree, P) - Method in class com.sun.source.util. TreeScanner
访问IfTree节点。
visitIf(IfTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitIf(IfTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问'if'语句树。
visitImport(ImportTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ImportTree节点。
visitImport(ImportTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ImportTree节点。
visitImport(ImportTree, P) - Method in class com.sun.source.util. TreeScanner
访问ImportTree节点。
visitImportEntry(ImportEntryTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
通过致电 visitUnknown访问一个 ImportEntryTree树。
visitImportEntry(ImportEntryTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问模块ImportEntry树。
visitImportEntry(ImportEntryTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问模块ImportEntry树。
visitIndex(IndexTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问IndexTree节点。
visitIndex(IndexTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问IndexTree节点。
visitIndex(IndexTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问IndexTree节点。
visitInheritDoc(InheritDocTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问InheritDocTree节点。
visitInheritDoc(InheritDocTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问InheritDocTree节点。
visitInheritDoc(InheritDocTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问InheritDocTree节点。
visitInstanceOf(InstanceOfTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问InstanceOfTree节点。
visitInstanceOf(InstanceOfTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问InstanceOfTree节点。
visitInstanceOf(InstanceOfTree, P) - Method in class com.sun.source.util. TreeScanner
访问InstanceOfTree节点。
visitInstanceOf(InstanceOfTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitInstanceOf(InstanceOfTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问“instanceof”表达式树。
visitInt(int, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的一个 int值。
visitInt(int, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的 int值。
visitIntersection(IntersectionType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问交叉路口类型。
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util. AbstractTypeVisitor6
访问交叉路口类型。
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util. AbstractTypeVisitor8
以一个子类定义的方式访问一个 IntersectionType 。
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor8
此实现访问的 IntersectionType致电 defaultAction 。
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util. TypeKindVisitor8
此实现访问的 IntersectionType致电 defaultAction 。
visitIntersectionType(IntersectionTypeTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问一个IntersectionTypeTree节点。
visitIntersectionType(IntersectionTypeTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问一个IntersectionTypeTree节点。
visitIntersectionType(IntersectionTypeTree, P) - Method in class com.sun.source.util. TreeScanner
访问一个IntersectionTypeTree节点。
visitLabeledStatement(LabeledStatementTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问LabeledStatementTree节点。
visitLabeledStatement(LabeledStatementTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问LabeledStatementTree节点。
visitLabeledStatement(LabeledStatementTree, P) - Method in class com.sun.source.util. TreeScanner
访问LabeledStatementTree节点。
visitLabeledStatement(LabeledStatementTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitLabeledStatement(LabeledStatementTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问标签语句树。
visitLambdaExpression(LambdaExpressionTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问LambdaExpressionTree节点。
visitLambdaExpression(LambdaExpressionTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问LambdaExpressionTree节点。
visitLambdaExpression(LambdaExpressionTree, P) - Method in class com.sun.source.util. TreeScanner
访问LambdaExpressionTree节点。
visitLink(LinkTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问LinkTree节点。
visitLink(LinkTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问LinkTree节点。
visitLink(LinkTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问LinkTree节点。
visitLiteral(LiteralTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问LiteralTree节点。
visitLiteral(LiteralTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问LiteralTree节点。
visitLiteral(LiteralTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问LiteralTree节点。
visitLiteral(LiteralTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问LiteralTree节点。
visitLiteral(LiteralTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问LiteralTree节点。
visitLiteral(LiteralTree, P) - Method in class com.sun.source.util. TreeScanner
访问LiteralTree节点。
visitLiteral(LiteralTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitLiteral(LiteralTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问文字表达式树。
visitLong(long, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的 long值。
visitLong(long, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的 long值。
visitMemberReference(MemberReferenceTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问MemberReferenceTree节点。
visitMemberReference(MemberReferenceTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问MemberReferenceTree节点。
visitMemberReference(MemberReferenceTree, P) - Method in class com.sun.source.util. TreeScanner
访问MemberReferenceTree节点。
visitMemberSelect(MemberSelectTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问MemberSelectTree节点。
visitMemberSelect(MemberSelectTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问MemberSelectTree节点。
visitMemberSelect(MemberSelectTree, P) - Method in class com.sun.source.util. TreeScanner
访问MemberSelectTree节点。
visitMemberSelect(MemberSelectTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitMemberSelect(MemberSelectTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问成员选择表达式树。
visitMethod(MethodTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问MethodTree节点。
visitMethod(MethodTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问MethodTree节点。
visitMethod(MethodTree, P) - Method in class com.sun.source.util. TreeScanner
访问MethodTree节点。
visitMethodInvocation(MethodInvocationTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问MethodInvocationTree节点。
visitMethodInvocation(MethodInvocationTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问MethodInvocationTree节点。
visitMethodInvocation(MethodInvocationTree, P) - Method in class com.sun.source.util. TreeScanner
访问MethodInvocationTree节点。
visitModifiers(ModifiersTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问修饰符Tree节点。
visitModifiers(ModifiersTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问修饰符Tree节点。
visitModifiers(ModifiersTree, P) - Method in class com.sun.source.util. TreeScanner
访问修饰符Tree节点。
visitModule(ModuleTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ModuleTree节点。
visitModule(ModuleTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
visitModule(ModuleTree, P) - Method in class com.sun.source.util. TreeScanner
visitModule(ModuleElement, P) - Method in interface javax.lang.model.element. ElementVisitor
访问模块元素。
visitModule(ModuleElement, P) - Method in class javax.lang.model.util. AbstractElementVisitor6
访问模块元素。
visitModule(ModuleElement, P) - Method in class javax.lang.model.util. AbstractElementVisitor9
以一个子类定义的方式访问一个 ModuleElement 。
visitModule(ModuleElement, P) - Method in class javax.lang.model.util. ElementKindVisitor9
访问一个 ModuleElement致电 defaultAction 。
visitModule(ModuleElement, P) - Method in class javax.lang.model.util. ElementScanner9
通过扫描包含的元素访问 ModuleElement 。
visitModule(ModuleElement, P) - Method in class javax.lang.model.util. SimpleElementVisitor9
访问一个 ModuleElement致电 defaultAction 。
visitModule(ModuleTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
通过致电 visitUnknown访问 ModuleTree树。
visitModule(ModuleTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问模块树。
visitModule(ModuleTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问模块树。
visitNew(NewTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitNew(NewTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问“新”表达式树。
visitNewArray(NewArrayTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问NewArrayTree节点。
visitNewArray(NewArrayTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问NewArrayTree节点。
visitNewArray(NewArrayTree, P) - Method in class com.sun.source.util. TreeScanner
访问NewArrayTree节点。
visitNewClass(NewClassTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问NewClassTree节点。
visitNewClass(NewClassTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问NewClassTree节点。
visitNewClass(NewClassTree, P) - Method in class com.sun.source.util. TreeScanner
访问NewClassTree节点。
visitNoType(NoType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问NoType实例。
visitNoType(NoType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问一个NoType实例。
visitNoType(NoType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
访问一个NoType实例，指派给访问方法的具体kind伪类型： VOID ， PACKAGE ，或NONE 。
visitNoTypeAsNone(NoType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问一个 NONE伪类型。
visitNoTypeAsPackage(NoType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问一个 PACKAGE伪类型。
visitNoTypeAsVoid(NoType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问一个 VOID伪类型。
visitNull(NullType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问空类型。
visitNull(NullType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问空类型。
visitObjectLiteral(ObjectLiteralTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitObjectLiteral(ObjectLiteralTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问对象文字树。
visitOpens(OpensTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问OpensTree节点。
visitOpens(OpensTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
visitOpens(OpensTree, P) - Method in class com.sun.source.util. TreeScanner
visitOpens(ModuleElement.OpensDirective, P) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问 opens指令。
visitOther(DocTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问未知类型的DocTree节点。
visitOther(DocTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问未知类型的DocTree节点。
visitOther(DocTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问未知类型的DocTree节点。
visitOther(Tree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问未知类型的树节点。
visitOther(Tree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问未知类型的树节点。
visitOther(Tree, P) - Method in class com.sun.source.util. TreeScanner
访问未知类型的树节点。
visitPackage(PackageTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问PackageTree节点。
visitPackage(PackageTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问PackageTree节点。
visitPackage(PackageTree, P) - Method in class com.sun.source.util. TreeScanner
访问PackageTree节点。
visitPackage(PackageElement, P) - Method in interface javax.lang.model.element. ElementVisitor
访问包元素。
visitPackage(PackageElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
访问包元素。
visitPackage(PackageElement, P) - Method in class javax.lang.model.util. ElementScanner6
访问包元素。
visitPackage(PackageElement, P) - Method in class javax.lang.model.util. SimpleElementVisitor6
访问包元素。
visitParam(ParamTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问ParamTree节点。
visitParam(ParamTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问ParamTree节点。
visitParam(ParamTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问ParamTree节点。
visitParameterizedType(ParameterizedTypeTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ParameterizedTypeTree节点。
visitParameterizedType(ParameterizedTypeTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ParameterizedTypeTree节点。
visitParameterizedType(ParameterizedTypeTree, P) - Method in class com.sun.source.util. TreeScanner
访问ParameterizedTypeTree节点。
visitParenthesized(ParenthesizedTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ParenthesizedTree节点。
visitParenthesized(ParenthesizedTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ParenthesizedTree节点。
visitParenthesized(ParenthesizedTree, P) - Method in class com.sun.source.util. TreeScanner
访问ParenthesizedTree节点。
visitParenthesized(ParenthesizedTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitParenthesized(ParenthesizedTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问括号表达式树。
visitPrimitive(PrimitiveType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问原始类型。
visitPrimitive(PrimitiveType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问原始类型。
visitPrimitive(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
访问基本类型，指派给该访问方法用于特定kind基本类型： BOOLEAN ， BYTE等
visitPrimitiveAsBoolean(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 BOOLEAN原始类型。
visitPrimitiveAsByte(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 BYTE原始类型。
visitPrimitiveAsChar(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 CHAR原始类型。
visitPrimitiveAsDouble(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 DOUBLE原始类型。
visitPrimitiveAsFloat(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 FLOAT原始类型。
visitPrimitiveAsInt(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 INT原始类型。
visitPrimitiveAsLong(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 LONG原始类型。
visitPrimitiveAsShort(PrimitiveType, P) - Method in class javax.lang.model.util. TypeKindVisitor6
通过调用 defaultAction访问 SHORT原始类型。
visitPrimitiveType(PrimitiveTypeTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问PrimitiveTypeTree节点。
visitPrimitiveType(PrimitiveTypeTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问PrimitiveTypeTree节点。
visitPrimitiveType(PrimitiveTypeTree, P) - Method in class com.sun.source.util. TreeScanner
访问PrimitiveTypeTree节点。
visitProperty(PropertyTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitProperty(PropertyTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问对象文字表达式树的属性。
visitProvides(ProvidesTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问ProvideTree节点。
visitProvides(ProvidesTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问ProvideTree节点。
visitProvides(ProvidesTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问ProvideTree节点。
visitProvides(ProvidesTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ProvideTree节点。
visitProvides(ProvidesTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
visitProvides(ProvidesTree, P) - Method in class com.sun.source.util. TreeScanner
visitProvides(ModuleElement.ProvidesDirective, P) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问 provides指令。
visitReference(ReferenceTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问一个ReferenceTree节点。
visitReference(ReferenceTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问一个ReferenceTree节点。
visitReference(ReferenceTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问一个ReferenceTree节点。
visitRegExpLiteral(RegExpLiteralTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitRegExpLiteral(RegExpLiteralTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问正则表达式文字树。
visitRequires(RequiresTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问RequiresTree节点。
visitRequires(RequiresTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
visitRequires(RequiresTree, P) - Method in class com.sun.source.util. TreeScanner
visitRequires(ModuleElement.RequiresDirective, P) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问 requires指令。
visitReturn(ReturnTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问ReturnTree节点。
visitReturn(ReturnTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问ReturnTree节点。
visitReturn(ReturnTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问ReturnTree节点。
visitReturn(ReturnTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ReturnTree节点。
visitReturn(ReturnTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ReturnTree节点。
visitReturn(ReturnTree, P) - Method in class com.sun.source.util. TreeScanner
访问ReturnTree节点。
visitReturn(ReturnTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitReturn(ReturnTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问return语句树。
visitSee(SeeTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问SeeTree节点。
visitSee(SeeTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问SeeTree节点。
visitSee(SeeTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问SeeTree节点。
visitSerial(SerialTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问SerialTree节点。
visitSerial(SerialTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问SerialTree节点。
visitSerial(SerialTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问SerialTree节点。
visitSerialData(SerialDataTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问一个SerialDataTree节点。
visitSerialData(SerialDataTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问一个SerialDataTree节点。
visitSerialData(SerialDataTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问一个SerialDataTree节点。
visitSerialField(SerialFieldTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问SerialFieldTree节点。
visitSerialField(SerialFieldTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问SerialFieldTree节点。
visitSerialField(SerialFieldTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问SerialFieldTree节点。
visitShort(short, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的一个 short值。
visitShort(short, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的一个 short值。
visitSince(SinceTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问SinceTree节点。
visitSince(SinceTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问SinceTree节点。
visitSince(SinceTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问SinceTree节点。
visitSpread(SpreadTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
通过致电 visitUnknown访问一个 SpreadTree树。
visitSpread(SpreadTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问“传播”表达式树。
visitSpread(SpreadTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问“传播”表达式树。
visitStartElement(StartElementTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问StartElementTree节点。
visitStartElement(StartElementTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问StartElementTree节点。
visitStartElement(StartElementTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问StartElementTree节点。
visitString(String, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的字符串值。
visitString(String, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的字符串值。
visitSwitch(SwitchTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问SwitchTree节点。
visitSwitch(SwitchTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问SwitchTree节点。
visitSwitch(SwitchTree, P) - Method in class com.sun.source.util. TreeScanner
访问SwitchTree节点。
visitSwitch(SwitchTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitSwitch(SwitchTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问'switch'语句树。
visitSynchronized(SynchronizedTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问SynchronizedTree节点。
visitSynchronized(SynchronizedTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问SynchronizedTree节点。
visitSynchronized(SynchronizedTree, P) - Method in class com.sun.source.util. TreeScanner
访问SynchronizedTree节点。
visitTemplateLiteral(TemplateLiteralTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
访问 TemplateLiteralTree树通过调用 visitUnknown 。
visitTemplateLiteral(TemplateLiteralTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问模板文字树。
visitTemplateLiteral(TemplateLiteralTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问模板文字树。
visitText(TextTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问TextTree节点。
visitText(TextTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问TextTree节点。
visitText(TextTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问TextTree节点。
visitThrow(ThrowTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问ThrowTree节点
visitThrow(ThrowTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问ThrowTree节点
visitThrow(ThrowTree, P) - Method in class com.sun.source.util. TreeScanner
访问ThrowTree节点
visitThrow(ThrowTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitThrow(ThrowTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问'throw'表达式树。
visitThrows(ThrowsTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问ThrowsTree节点。
visitThrows(ThrowsTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问ThrowsTree节点。
visitThrows(ThrowsTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问ThrowsTree节点。
visitTry(TryTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问TryTree节点。
visitTry(TryTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问TryTree节点。
visitTry(TryTree, P) - Method in class com.sun.source.util. TreeScanner
访问TryTree节点。
visitTry(TryTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitTry(TryTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问'try'语句树。
visitType(TypeElement, P) - Method in interface javax.lang.model.element. ElementVisitor
访问类型元素。
visitType(TypeElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
访问类型元素，指派给该访问方法用于特定kind类型， ANNOTATION_TYPE ， CLASS ， ENUM ，或INTERFACE 。
visitType(TypeElement, P) - Method in class javax.lang.model.util. ElementScanner6
访问类型元素。
visitType(TypeElement, P) - Method in class javax.lang.model.util. SimpleElementVisitor6
访问类型元素。
visitType(TypeMirror, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问注释中的类型值。
visitType(TypeMirror, P) - Method in class javax.lang.model.util. SimpleAnnotationValueVisitor6
访问注释中的类型值。
visitTypeAsAnnotationType(TypeElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问 ANNOTATION_TYPE类型的元素。
visitTypeAsClass(TypeElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 CLASS类型的元素。
visitTypeAsEnum(TypeElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 ENUM类型的元素。
visitTypeAsInterface(TypeElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用defaultAction访问INTERFACE类型的元素。 。
visitTypeCast(TypeCastTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问TypeCastTree节点。
visitTypeCast(TypeCastTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问TypeCastTree节点。
visitTypeCast(TypeCastTree, P) - Method in class com.sun.source.util. TreeScanner
访问TypeCastTree节点。
visitTypeParameter(TypeParameterTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问TypeParameterTree节点。
visitTypeParameter(TypeParameterTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问TypeParameterTree节点。
visitTypeParameter(TypeParameterTree, P) - Method in class com.sun.source.util. TreeScanner
访问TypeParameterTree节点。
visitTypeParameter(TypeParameterElement, P) - Method in interface javax.lang.model.element. ElementVisitor
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - Method in class javax.lang.model.util. ElementScanner6
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - Method in class javax.lang.model.util. SimpleElementVisitor6
访问类型参数元素。
visitTypeVariable(TypeVariable, P) - Method in interface javax.lang.model.type. TypeVisitor
访问类型变量。
visitTypeVariable(TypeVariable, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问类型变量。
visitUnary(UnaryTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问UnaryTree节点。
visitUnary(UnaryTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问UnaryTree节点。
visitUnary(UnaryTree, P) - Method in class com.sun.source.util. TreeScanner
访问UnaryTree节点。
visitUnary(UnaryTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitUnary(UnaryTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问一元表达式树。
visitUnion(UnionType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问联合类型。
visitUnion(UnionType, P) - Method in class javax.lang.model.util. AbstractTypeVisitor6
访问联合类型。
visitUnion(UnionType, P) - Method in class javax.lang.model.util. AbstractTypeVisitor7
以一个子类定义的方式访问一个 UnionType 。
visitUnion(UnionType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor7
此实现访问一个 UnionType致电 defaultAction 。
visitUnion(UnionType, P) - Method in class javax.lang.model.util. TypeKindVisitor7
此实现访问一个 UnionType致电 defaultAction 。
visitUnionType(UnionTypeTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问UnionTypeTree节点。
visitUnionType(UnionTypeTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问UnionTypeTree节点。
visitUnionType(UnionTypeTree, P) - Method in class com.sun.source.util. TreeScanner
访问UnionTypeTree节点。
visitUnknown(AnnotationValue, P) - Method in interface javax.lang.model.element. AnnotationValueVisitor
访问未知类型的注释值。
visitUnknown(AnnotationValue, P) - Method in class javax.lang.model.util. AbstractAnnotationValueVisitor6
访问未知类型的注释值。
visitUnknown(Element, P) - Method in interface javax.lang.model.element. ElementVisitor
访问一种未知的元素。
visitUnknown(Element, P) - Method in class javax.lang.model.util. AbstractElementVisitor6
访问一种未知的元素。
visitUnknown(ModuleElement.Directive, P) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问未知的指令。
visitUnknown(TypeMirror, P) - Method in interface javax.lang.model.type. TypeVisitor
访问未知类型的类型。
visitUnknown(TypeMirror, P) - Method in class javax.lang.model.util. AbstractTypeVisitor6
访问未知类型的类型。
visitUnknown(Tree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
访问未知表达式/语句树。
visitUnknown(Tree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问未知表达式/语句树。
visitUnknownBlockTag(UnknownBlockTagTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问UnknownBlockTagTree节点。
visitUnknownBlockTag(UnknownBlockTagTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问UnknownBlockTagTree节点。
visitUnknownBlockTag(UnknownBlockTagTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问UnknownBlockTagTree节点。
visitUnknownInlineTag(UnknownInlineTagTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问UnknownInlineTagTree节点。
visitUnknownInlineTag(UnknownInlineTagTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问UnknownInlineTagTree节点。
visitUnknownInlineTag(UnknownInlineTagTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问UnknownInlineTagTree节点。
visitUses(UsesTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问UsesTree节点。
visitUses(UsesTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问UsesTree节点。
visitUses(UsesTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问UsesTree节点。
visitUses(UsesTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问UsesTree节点。
visitUses(UsesTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
visitUses(UsesTree, P) - Method in class com.sun.source.util. TreeScanner
visitUses(ModuleElement.UsesDirective, P) - Method in interface javax.lang.model.element. ModuleElement.DirectiveVisitor
访问 uses指令。
visitValue(ValueTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问ValueTree节点。
visitValue(ValueTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问ValueTree节点。
visitValue(ValueTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问ValueTree节点。
visitVariable(VariableTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问VariableTree节点。
visitVariable(VariableTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问VariableTree节点。
visitVariable(VariableTree, P) - Method in class com.sun.source.util. TreeScanner
访问VariableTree节点。
visitVariable(VariableElement, P) - Method in interface javax.lang.model.element. ElementVisitor
访问可变元素。
visitVariable(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
访问一个变量元素，指派给访问方法用于特定kind变量，的ENUM_CONSTANT ， EXCEPTION_PARAMETER ， 字段 ， LOCAL_VARIABLE ， PARAMETER ，或RESOURCE_VARIABLE 。
visitVariable(VariableElement, P) - Method in class javax.lang.model.util. ElementScanner6
访问可变元素。
visitVariable(VariableElement, P) - Method in class javax.lang.model.util. ElementScanner7
此实现扫描包含的元素。
visitVariable(VariableElement, P) - Method in class javax.lang.model.util. SimpleElementVisitor6
访问可变元素。
visitVariable(VariableElement, P) - Method in class javax.lang.model.util. SimpleElementVisitor7
此实现调用 defaultAction 。
visitVariable(VariableTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitVariable(VariableTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
visitVariable(VariableTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问变量声明树。
visitVariableAsEnumConstant(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 ENUM_CONSTANT变量元素。
visitVariableAsExceptionParameter(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 EXCEPTION_PARAMETER变量元素。
visitVariableAsField(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 字段变量元素。
visitVariableAsLocalVariable(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 LOCAL_VARIABLE变量元素。
visitVariableAsParameter(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 defaultAction访问一个 PARAMETER变量元素。
visitVariableAsResourceVariable(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor6
通过调用 visitUnknown访问一个 RESOURCE_VARIABLE变量元素。
visitVariableAsResourceVariable(VariableElement, P) - Method in class javax.lang.model.util. ElementKindVisitor7
通过调用 defaultAction访问一个 RESOURCE_VARIABLE变量元素。
visitVersion(VersionTree, P) - Method in interface com.sun.source.doctree. DocTreeVisitor
访问VersionTreeTree节点。
visitVersion(VersionTree, P) - Method in class com.sun.source.util. DocTreeScanner
访问VersionTreeTree节点。
visitVersion(VersionTree, P) - Method in class com.sun.source.util. SimpleDocTreeVisitor
访问VersionTreeTree节点。
visitWhileLoop(WhileLoopTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问WhileLoopTree节点。
visitWhileLoop(WhileLoopTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问WhileLoopTree节点。
visitWhileLoop(WhileLoopTree, P) - Method in class com.sun.source.util. TreeScanner
访问WhileLoopTree节点。
visitWhileLoop(WhileLoopTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitWhileLoop(WhileLoopTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问'while'语句树。
visitWildcard(WildcardTree, P) - Method in interface com.sun.source.tree. TreeVisitor
访问WildcardTypeTree节点。
visitWildcard(WildcardTree, P) - Method in class com.sun.source.util. SimpleTreeVisitor
访问WildcardTypeTree节点。
visitWildcard(WildcardTree, P) - Method in class com.sun.source.util. TreeScanner
访问WildcardTypeTree节点。
visitWildcard(WildcardType, P) - Method in interface javax.lang.model.type. TypeVisitor
访问通配符类型。
visitWildcard(WildcardType, P) - Method in class javax.lang.model.util. SimpleTypeVisitor6
访问通配符类型。
visitWith(WithTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
visitWith(WithTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问'with'语句树。
visitYield(YieldTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES5_1
通过致电 visitUnknown访问一个 YieldTree树。
visitYield(YieldTree, P) - Method in class jdk.nashorn.api.tree. SimpleTreeVisitorES6
访问“yield”表达式树。
visitYield(YieldTree, P) - Method in interface jdk.nashorn.api.tree. TreeVisitor
访问“yield”表达式树。
VISUAL - javafx.scene.text. TextBoundsType
使用可视边界作为计算边界的依据。
VK_0 - Static variable in class java.awt.event. KeyEvent
常数为“0”键。
VK_1 - Static variable in class java.awt.event. KeyEvent
常数为“1”键。
VK_2 - Static variable in class java.awt.event. KeyEvent
常数为“2”键。
VK_3 - Static variable in class java.awt.event. KeyEvent
常数为“3”键。
VK_4 - Static variable in class java.awt.event. KeyEvent
常数为“4”键。
VK_5 - Static variable in class java.awt.event. KeyEvent
常数为“5”键。
VK_6 - Static variable in class java.awt.event. KeyEvent
常数为“6”键。
VK_7 - Static variable in class java.awt.event. KeyEvent
常数为“7”键。
VK_8 - Static variable in class java.awt.event. KeyEvent
常数为“8”键。
VK_9 - Static variable in class java.awt.event. KeyEvent
常数为“9”键。
VK_A - Static variable in class java.awt.event. KeyEvent
常数为“A”键。
VK_ACCEPT - Static variable in class java.awt.event. KeyEvent
接受或提交功能键的常数。
VK_ADD - Static variable in class java.awt.event. KeyEvent
常数为数字键添加键。
VK_AGAIN - Static variable in class java.awt.event. KeyEvent
VK_ALL_CANDIDATES - Static variable in class java.awt.event. KeyEvent
所有候选人的常数功能键。
VK_ALPHANUMERIC - Static variable in class java.awt.event. KeyEvent
字母数字功能键的常数。
VK_ALT - Static variable in class java.awt.event. KeyEvent
ALT虚拟键的常数。
VK_ALT_GRAPH - Static variable in class java.awt.event. KeyEvent
AltGraph功能键的常数。
VK_AMPERSAND - Static variable in class java.awt.event. KeyEvent
VK_ASTERISK - Static variable in class java.awt.event. KeyEvent
VK_AT - Static variable in class java.awt.event. KeyEvent
“@”键的常数。
VK_B - Static variable in class java.awt.event. KeyEvent
常数为“B”键。
VK_BACK_QUOTE - Static variable in class java.awt.event. KeyEvent
常量为BACK_QUOTE键。
VK_BACK_SLASH - Static variable in class java.awt.event. KeyEvent
常数为斜杠，“\”
VK_BACK_SPACE - Static variable in class java.awt.event. KeyEvent
常量为BACK_SPACE虚拟键。
VK_BEGIN - Static variable in class java.awt.event. KeyEvent
常数为开始键。
VK_BRACELEFT - Static variable in class java.awt.event. KeyEvent
VK_BRACERIGHT - Static variable in class java.awt.event. KeyEvent
VK_C - Static variable in class java.awt.event. KeyEvent
常数为“C”键。
VK_CANCEL - Static variable in class java.awt.event. KeyEvent
CANCEL虚拟键的常数。
VK_CAPS_LOCK - Static variable in class java.awt.event. KeyEvent
CAPS_LOCK虚拟键的常数。
VK_CIRCUMFLEX - Static variable in class java.awt.event. KeyEvent
常数为“^”键。
VK_CLEAR - Static variable in class java.awt.event. KeyEvent
CLEAR虚拟键的常数。
VK_CLOSE_BRACKET - Static variable in class java.awt.event. KeyEvent
关闭括号键的常数，“]”
VK_CODE_INPUT - Static variable in class java.awt.event. KeyEvent
代码输入功能键的常数。
VK_COLON - Static variable in class java.awt.event. KeyEvent
“：”键的常数。
VK_COMMA - Static variable in class java.awt.event. KeyEvent
常数为逗号键“，”
VK_COMPOSE - Static variable in class java.awt.event. KeyEvent
编写功能键的常数。
VK_CONTEXT_MENU - Static variable in class java.awt.event. KeyEvent
Microsoft Windows上下文菜单键的常数。
VK_CONTROL - Static variable in class java.awt.event. KeyEvent
CONTROL虚拟键的常数。
VK_CONVERT - Static variable in class java.awt.event. KeyEvent
转换功能键的常数。
VK_COPY - Static variable in class java.awt.event. KeyEvent
VK_CUT - Static variable in class java.awt.event. KeyEvent
VK_D - Static variable in class java.awt.event. KeyEvent
常数为“D”键。
VK_DEAD_ABOVEDOT - Static variable in class java.awt.event. KeyEvent
VK_DEAD_ABOVERING - Static variable in class java.awt.event. KeyEvent
VK_DEAD_ACUTE - Static variable in class java.awt.event. KeyEvent
VK_DEAD_BREVE - Static variable in class java.awt.event. KeyEvent
VK_DEAD_CARON - Static variable in class java.awt.event. KeyEvent
VK_DEAD_CEDILLA - Static variable in class java.awt.event. KeyEvent
VK_DEAD_CIRCUMFLEX - Static variable in class java.awt.event. KeyEvent
VK_DEAD_DIAERESIS - Static variable in class java.awt.event. KeyEvent
VK_DEAD_DOUBLEACUTE - Static variable in class java.awt.event. KeyEvent
VK_DEAD_GRAVE - Static variable in class java.awt.event. KeyEvent
VK_DEAD_IOTA - Static variable in class java.awt.event. KeyEvent
VK_DEAD_MACRON - Static variable in class java.awt.event. KeyEvent
VK_DEAD_OGONEK - Static variable in class java.awt.event. KeyEvent
VK_DEAD_SEMIVOICED_SOUND - Static variable in class java.awt.event. KeyEvent
VK_DEAD_TILDE - Static variable in class java.awt.event. KeyEvent
VK_DEAD_VOICED_SOUND - Static variable in class java.awt.event. KeyEvent
VK_DECIMAL - Static variable in class java.awt.event. KeyEvent
数字小数点键的常数。
VK_DELETE - Static variable in class java.awt.event. KeyEvent
常数为删除键。
VK_DIVIDE - Static variable in class java.awt.event. KeyEvent
数字键分割键的常数。
VK_DOLLAR - Static variable in class java.awt.event. KeyEvent
“$”键的常数。
VK_DOWN - Static variable in class java.awt.event. KeyEvent
常数为非numpad 向下箭头键。
VK_E - Static variable in class java.awt.event. KeyEvent
常数为“E”键。
VK_END - Static variable in class java.awt.event. KeyEvent
END虚拟键的常数。
VK_ENTER - Static variable in class java.awt.event. KeyEvent
ENTER虚拟键的常数。
VK_EQUALS - Static variable in class java.awt.event. KeyEvent
等于键的常数，“=”
VK_ESCAPE - Static variable in class java.awt.event. KeyEvent
ESCAPE虚拟键的常数。
VK_EURO_SIGN - Static variable in class java.awt.event. KeyEvent
欧元货币符号键的常数。
VK_EXCLAMATION_MARK - Static variable in class java.awt.event. KeyEvent
常数为“！”
VK_F - Static variable in class java.awt.event. KeyEvent
常数为“F”键。
VK_F1 - Static variable in class java.awt.event. KeyEvent
常数为F1功能键。
VK_F10 - Static variable in class java.awt.event. KeyEvent
常数为F10功能键。
VK_F11 - Static variable in class java.awt.event. KeyEvent
常数为F11功能键。
VK_F12 - Static variable in class java.awt.event. KeyEvent
F12功能键的常数。
VK_F13 - Static variable in class java.awt.event. KeyEvent
F13功能键的常数。
VK_F14 - Static variable in class java.awt.event. KeyEvent
F14功能键的常数。
VK_F15 - Static variable in class java.awt.event. KeyEvent
F15功能键的常数。
VK_F16 - Static variable in class java.awt.event. KeyEvent
F16功能键的常数。
VK_F17 - Static variable in class java.awt.event. KeyEvent
F17功能键的常数。
VK_F18 - Static variable in class java.awt.event. KeyEvent
F18功能键的常数。
VK_F19 - Static variable in class java.awt.event. KeyEvent
F19功能键的常数。
VK_F2 - Static variable in class java.awt.event. KeyEvent
F2功能键的常数。
VK_F20 - Static variable in class java.awt.event. KeyEvent
F20功能键的常数。
VK_F21 - Static variable in class java.awt.event. KeyEvent
F21功能键的常数。
VK_F22 - Static variable in class java.awt.event. KeyEvent
F22功能键的常数。
VK_F23 - Static variable in class java.awt.event. KeyEvent
F23功能键的常数。
VK_F24 - Static variable in class java.awt.event. KeyEvent
F24功能键的常数。
VK_F3 - Static variable in class java.awt.event. KeyEvent
F3功能键的常数。
VK_F4 - Static variable in class java.awt.event. KeyEvent
F4功能键的常数。
VK_F5 - Static variable in class java.awt.event. KeyEvent
F5功能键的常数。
VK_F6 - Static variable in class java.awt.event. KeyEvent
常数为F6功能键。
VK_F7 - Static variable in class java.awt.event. KeyEvent
F7功能键的常数。
VK_F8 - Static variable in class java.awt.event. KeyEvent
F8功能键的常数。
VK_F9 - Static variable in class java.awt.event. KeyEvent
常数为F9功能键。
VK_FINAL - Static variable in class java.awt.event. KeyEvent
FINAL键的常数。
VK_FIND - Static variable in class java.awt.event. KeyEvent
VK_FULL_WIDTH - Static variable in class java.awt.event. KeyEvent
全角字符的常量功能键。
VK_G - Static variable in class java.awt.event. KeyEvent
常数为“G”键。
VK_GREATER - Static variable in class java.awt.event. KeyEvent
VK_H - Static variable in class java.awt.event. KeyEvent
恒定为“H”键。
VK_HALF_WIDTH - Static variable in class java.awt.event. KeyEvent
半角字符功能键的常数。
VK_HELP - Static variable in class java.awt.event. KeyEvent
常用于帮助键。
VK_HIRAGANA - Static variable in class java.awt.event. KeyEvent
平假名功能键的常数。
VK_HOME - Static variable in class java.awt.event. KeyEvent
HOME虚拟键的常数。
VK_I - Static variable in class java.awt.event. KeyEvent
常数为“I”键。
VK_INPUT_METHOD_ON_OFF - Static variable in class java.awt.event. KeyEvent
输入法/常规键的常数。
VK_INSERT - Static variable in class java.awt.event. KeyEvent
INSERT键的常数。
VK_INVERTED_EXCLAMATION_MARK - Static variable in class java.awt.event. KeyEvent
反转感叹号的常数。
VK_J - Static variable in class java.awt.event. KeyEvent
常数为“J”键。
VK_JAPANESE_HIRAGANA - Static variable in class java.awt.event. KeyEvent
日文 - 平假名功能键的常数。
VK_JAPANESE_KATAKANA - Static variable in class java.awt.event. KeyEvent
日本片假名功能键的常数。
VK_JAPANESE_ROMAN - Static variable in class java.awt.event. KeyEvent
日常罗马功能键的常数。
VK_K - Static variable in class java.awt.event. KeyEvent
常数为“K”键。
VK_KANA - Static variable in class java.awt.event. KeyEvent
KANA锁定键的常数。
VK_KANA_LOCK - Static variable in class java.awt.event. KeyEvent
锁定假名功能键的常数。
VK_KANJI - Static variable in class java.awt.event. KeyEvent
康乃馨
VK_KATAKANA - Static variable in class java.awt.event. KeyEvent
片假名功能键的常数。
VK_KP_DOWN - Static variable in class java.awt.event. KeyEvent
常数为数字键盘 向下箭头键。
VK_KP_LEFT - Static variable in class java.awt.event. KeyEvent
常数为数字键盘 左箭头键。
VK_KP_RIGHT - Static variable in class java.awt.event. KeyEvent
数字键盘 右箭头键的常数。
VK_KP_UP - Static variable in class java.awt.event. KeyEvent
常数为数字键盘 向上箭头键。
VK_L - Static variable in class java.awt.event. KeyEvent
常数为“L”键。
VK_LEFT - Static variable in class java.awt.event. KeyEvent
常数为非numpad 左箭头键。
VK_LEFT_PARENTHESIS - Static variable in class java.awt.event. KeyEvent
常数为“（”键。
VK_LESS - Static variable in class java.awt.event. KeyEvent
VK_M - Static variable in class java.awt.event. KeyEvent
常数为“M”键。
VK_META - Static variable in class java.awt.event. KeyEvent
常数为META密钥。
VK_MINUS - Static variable in class java.awt.event. KeyEvent
常数为减号，“ - ”
VK_MODECHANGE - Static variable in class java.awt.event. KeyEvent
MODECHANGE键的常数。
VK_MULTIPLY - Static variable in class java.awt.event. KeyEvent
数字键的常数乘法键。
VK_N - Static variable in class java.awt.event. KeyEvent
常数为“N”键。
VK_NONCONVERT - Static variable in class java.awt.event. KeyEvent
不转换功能键的常数。
VK_NUM_LOCK - Static variable in class java.awt.event. KeyEvent
常数为NUM_LOCK键。
VK_NUMBER_SIGN - Static variable in class java.awt.event. KeyEvent
“＃”键的常数。
VK_NUMPAD0 - Static variable in class java.awt.event. KeyEvent
数字键“0”键的常数。
VK_NUMPAD1 - Static variable in class java.awt.event. KeyEvent
数字键“1”键的常数。
VK_NUMPAD2 - Static variable in class java.awt.event. KeyEvent
数字键“2”键的常数。
VK_NUMPAD3 - Static variable in class java.awt.event. KeyEvent
数字键“3”键的常数。
VK_NUMPAD4 - Static variable in class java.awt.event. KeyEvent
数字键“4”键的常数。
VK_NUMPAD5 - Static variable in class java.awt.event. KeyEvent
数字键“5”键的常数。
VK_NUMPAD6 - Static variable in class java.awt.event. KeyEvent
数字键“6”键的常数。
VK_NUMPAD7 - Static variable in class java.awt.event. KeyEvent
数字键“7”键的常数。
VK_NUMPAD8 - Static variable in class java.awt.event. KeyEvent
数字键“8”键的常数。
VK_NUMPAD9 - Static variable in class java.awt.event. KeyEvent
数字键“9”键的常数。
VK_O - Static variable in class java.awt.event. KeyEvent
常数为“O”键。
VK_OPEN_BRACKET - Static variable in class java.awt.event. KeyEvent
常数为打开括号的键，“[”
VK_P - Static variable in class java.awt.event. KeyEvent
“P”键的常数。
VK_PAGE_DOWN - Static variable in class java.awt.event. KeyEvent
PAGE_DOWN虚拟键的常数。
VK_PAGE_UP - Static variable in class java.awt.event. KeyEvent
PAGE_UP虚拟键的常数。
VK_PASTE - Static variable in class java.awt.event. KeyEvent
VK_PAUSE - Static variable in class java.awt.event. KeyEvent
PAUSE虚拟键的常数。
VK_PERIOD - Static variable in class java.awt.event. KeyEvent
期间关键的常数“”。
VK_PLUS - Static variable in class java.awt.event. KeyEvent
常数为“+”键。
VK_PREVIOUS_CANDIDATE - Static variable in class java.awt.event. KeyEvent
上一个候选功能键的常数。
VK_PRINTSCREEN - Static variable in class java.awt.event. KeyEvent
PRINTSCREEN键的常数。
VK_PROPS - Static variable in class java.awt.event. KeyEvent
VK_Q - Static variable in class java.awt.event. KeyEvent
常数为“Q”键。
VK_QUOTE - Static variable in class java.awt.event. KeyEvent
QUOTE键的常数。
VK_QUOTEDBL - Static variable in class java.awt.event. KeyEvent
VK_R - Static variable in class java.awt.event. KeyEvent
常数为“R”键。
VK_RIGHT - Static variable in class java.awt.event. KeyEvent
常数为非numpad 右箭头键。
VK_RIGHT_PARENTHESIS - Static variable in class java.awt.event. KeyEvent
常数为“）”键。
VK_ROMAN_CHARACTERS - Static variable in class java.awt.event. KeyEvent
罗马字符功能键的常数。
VK_S - Static variable in class java.awt.event. KeyEvent
常数为“S”键。
VK_SCROLL_LOCK - Static variable in class java.awt.event. KeyEvent
SCROLL_LOCK键的常数。
VK_SEMICOLON - Static variable in class java.awt.event. KeyEvent
常数为分号键，“;”
VK_SEPARATER - Static variable in class java.awt.event. KeyEvent
此常数已过时，仅用于向后兼容。
VK_SEPARATOR - Static variable in class java.awt.event. KeyEvent
Numpad Separator键的常数。
VK_SHIFT - Static variable in class java.awt.event. KeyEvent
SHIFT虚拟键的常数。
VK_SLASH - Static variable in class java.awt.event. KeyEvent
正斜杠的常数为“/”
VK_SPACE - Static variable in class java.awt.event. KeyEvent
SPACE虚拟键的常数。
VK_STOP - Static variable in class java.awt.event. KeyEvent
VK_SUBTRACT - Static variable in class java.awt.event. KeyEvent
数字键的常数减去键。
VK_T - Static variable in class java.awt.event. KeyEvent
常数为“T”键。
VK_TAB - Static variable in class java.awt.event. KeyEvent
TAB虚拟键的常数。
VK_U - Static variable in class java.awt.event. KeyEvent
常数为“U”键。
VK_UNDEFINED - Static variable in class java.awt.event. KeyEvent
该值用于表示keyCode未知。
VK_UNDERSCORE - Static variable in class java.awt.event. KeyEvent
常量为“_”键。
VK_UNDO - Static variable in class java.awt.event. KeyEvent
VK_UP - Static variable in class java.awt.event. KeyEvent
常数为非numpad 向上箭头键。
VK_V - Static variable in class java.awt.event. KeyEvent
“V”键的常数。
VK_W - Static variable in class java.awt.event. KeyEvent
常数为“W”键。
VK_WINDOWS - Static variable in class java.awt.event. KeyEvent
Microsoft Windows“Windows”键的常数。
VK_X - Static variable in class java.awt.event. KeyEvent
常数为“X”键。
VK_Y - Static variable in class java.awt.event. KeyEvent
常数为“Y”键。
VK_Z - Static variable in class java.awt.event. KeyEvent
常数为“Z”键。
VLineTo - Class in javafx.scene.shape
创建从当前点到y的垂直线路元素。
VLineTo() - Constructor for class javafx.scene.shape. VLineTo
创建一个空的VLineTo实例。
VLineTo(double) - Constructor for class javafx.scene.shape. VLineTo
创建一个VLineTo的实例。
VLINK - Static variable in class javax.swing.text.html. HTML.Attribute
属性“vlink”
vm() - Method in class jdk.jshell.execution. JdiDefaultExecutionControl
vm() - Method in class jdk.jshell.execution. JdiExecutionControl
返回JDI VirtualMachine实例。
vm() - Method in class jdk.jshell.execution. JdiInitiator
返回产生的 VirtualMachine实例。
VM_ABSTRACT - Interface in org.omg.CORBA
定义用于在类型代码中表示抽象接口的代码。
VM_CREATION - com.sun.management. VMOption.Origin
VM选项设置为VM创建时间，通常作为启动器的命令行参数或传递给使用JNI调用接口创建的VM的参数。
VM_CUSTOM - Interface in org.omg.CORBA
定义用于在类型代码中表示自定义编组值类型的代码。
VM_NONE - Interface in org.omg.CORBA
定义用于表示类型代码中值类型值的代码。
VM_TRUNCATABLE - Interface in org.omg.CORBA
定义用于在类型代码中表示可截断值类型的代码。
vmaxProperty() - Method in class javafx.scene.control. ScrollPane
此ScrollPane的最大允许 数为 vvalue 。
VMCannotBeModifiedException - Exception in com.sun.jdi
抛出以表示操作无效，因为它会修改VM，VM是只读的。
VMCannotBeModifiedException() - Constructor for exception com.sun.jdi. VMCannotBeModifiedException
VMCannotBeModifiedException(String) - Constructor for exception com.sun.jdi. VMCannotBeModifiedException
VMDeathEvent - Interface in com.sun.jdi.event
目标VM终止通知。
VMDeathRequest - Interface in com.sun.jdi.request
当目标VM终止时请求通知。
vmDeathRequests() - Method in interface com.sun.jdi.request. EventRequestManager
返回启用和禁用的VM死亡请求的不可修改的列表。
VMDisconnectedException - Exception in com.sun.jdi
抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。
VMDisconnectedException() - Constructor for exception com.sun.jdi. VMDisconnectedException
VMDisconnectedException(String) - Constructor for exception com.sun.jdi. VMDisconnectedException
VMDisconnectEvent - Interface in com.sun.jdi.event
断开目标VM的通知。
VMID - Class in java.rmi.dgc
VMID是所有Java虚拟机中唯一的标识符。
VMID() - Constructor for class java.rmi.dgc. VMID
创建一个新的VMID。
vminProperty() - Method in class javafx.scene.control. ScrollPane
此ScrollPane的最小允许 数为 vvalue 。
VMMismatchException - Exception in com.sun.jdi
抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。
VMMismatchException() - Constructor for exception com.sun.jdi. VMMismatchException
VMMismatchException(String) - Constructor for exception com.sun.jdi. VMMismatchException
VMOption - Class in com.sun.management
有关VM选项的信息，包括其值，值来自哪里被称为其origin 。
VMOption(String, String, boolean, VMOption.Origin) - Constructor for class com.sun.management. VMOption
构造一个 VMOption 。
VMOption.Origin - Enum in com.sun.management
VM选项的值的起源。
VMOutOfMemoryException - Exception in com.sun.jdi
抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。
VMOutOfMemoryException() - Constructor for exception com.sun.jdi. VMOutOfMemoryException
VMOutOfMemoryException(String) - Constructor for exception com.sun.jdi. VMOutOfMemoryException
VMStartEvent - Interface in com.sun.jdi.event
通知初始化目标虚拟机。
VMStartException - Exception in com.sun.jdi.connect
目标VM已成功启动，但在建立连接之前会发生错误。
VMStartException(Process) - Constructor for exception com.sun.jdi.connect. VMStartException
VMStartException(String, Process) - Constructor for exception com.sun.jdi.connect. VMStartException
VoiceStatus - Class in javax.sound.midi
A VoiceStatus对象包含有关由Synthesizer生成的其中一个语音的当前状态的信息。
VoiceStatus() - Constructor for class javax.sound.midi. VoiceStatus
Void - Class in java.lang
Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
VOID - javax.lang.model.type. TypeKind
伪类型对应于关键字 void 。
VOID - jdk.nashorn.api.tree. Tree.Kind
用于实例UnaryTree代表逻辑void运算符void 。
VOID - Static variable in class javax.management.openmbean. SimpleType
描述Java类名称为 java.lang.Void值的 SimpleType实例。
VoidType - Interface in com.sun.jdi
在目标虚拟机中访问的所有原语的类型 void 。
VoidValue - Interface in com.sun.jdi
提供对目标虚拟机 void语 void值的访问。
VOLATILE - javax.lang.model.element. Modifier
修饰词 volatile
VOLATILE - Static variable in class java.lang.reflect. Modifier
int值代表 volatile修饰符。
VolatileCallSite - Class in java.lang.invoke
A VolatileCallSite是一个CallSite，其目标像一个volatile变量。
VolatileCallSite(MethodHandle) - Constructor for class java.lang.invoke. VolatileCallSite
创建一个具有对其目标的易失性绑定的调用站点。
VolatileCallSite(MethodType) - Constructor for class java.lang.invoke. VolatileCallSite
创建一个具有对其目标的易失性绑定的调用站点。
VolatileImage - Class in java.awt.image
VolatileImage是由于超出应用程序控制的情况（例如由操作系统或其他应用程序引起的情况），可能随时丢失其内容的映像。
VolatileImage() - Constructor for class java.awt.image. VolatileImage
volume - Variable in class javax.sound.midi. VoiceStatus
当前MIDI音量级别的声音。
VOLUME - Static variable in class javax.sound.sampled. FloatControl.Type
表示对一行的音量的控制。
VOLUME_DOWN - javafx.scene.input. KeyCode
常数为 Volume Down键。
VOLUME_UP - javafx.scene.input. KeyCode
常数为 Volume Up键。
volumeProperty() - Method in class javafx.scene.media. AudioClip
剪辑播放的相对音量级别。
volumeProperty() - Method in class javafx.scene.media. MediaPlayer
要播放媒体的音量。
VPos - Enum in javafx.geometry
一组用于描述垂直定位和对齐的值。
vsb - Variable in class javax.swing. ScrollPaneLayout
滚动盘的垂直滚动条小孩。
vsbChangeListener - Variable in class javax.swing.plaf.basic. BasicScrollPaneUI
ChangeListener安装在垂直滚动条上。
VSBChangeListener() - Constructor for class javax.swing.plaf.basic. BasicScrollPaneUI.VSBChangeListener
vsbPolicy - Variable in class javax.swing. ScrollPaneLayout
垂直滚动条的显示策略。
VSPACE - Static variable in class javax.swing.text.html. HTML.Attribute
属性“vspace”
vvalueProperty() - Method in class javafx.scene.control. ScrollPane
ScrollPane的当前垂直滚动位置。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


W-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

W

W - javafx.scene.input. KeyCode
常数为 W键。
W_RESIZE - Static variable in class javafx.scene. Cursor
西调整游标类型。
W_RESIZE_CURSOR - Static variable in class java.awt. Cursor
西调整游标类型。
W_RESIZE_CURSOR - Static variable in class java.awt. Frame
已过时。
替换为Cursor.W_RESIZE_CURSOR 。
W3C_LENGTH_UNITS - Static variable in class javax.swing. JEditorPane
用于指示是否将 w3c compliant长度单位用于html呈现的客户端属性的键。
W3C_XML_SCHEMA_INSTANCE_NS_URI - Static variable in class javax.xml. XMLConstants
W3C XML Schema实例命名空间URI。
W3C_XML_SCHEMA_NS_URI - Static variable in class javax.xml. XMLConstants
W3C XML Schema命名空间URI。
W3C_XPATH_DATATYPE_NS_URI - Static variable in class javax.xml. XMLConstants
W3C XPath数据类型命名空间URI。
W3CDomHandler - Class in javax.xml.bind.annotation
DomHandler W3C DOM实现（ org.w3c.dom包）
W3CDomHandler() - Constructor for class javax.xml.bind.annotation. W3CDomHandler
默认构造函数。
W3CDomHandler(DocumentBuilder) - Constructor for class javax.xml.bind.annotation. W3CDomHandler
构造函数，允许应用程序指定要使用的DOM实现。
W3CEndpointReference - Class in javax.xml.ws.wsaddressing
此类表示W3C寻址端点引用，它是支持W3C WS-Addressing 1.0 - 核心推荐的Web服务端点的远程引用。
W3CEndpointReference() - Constructor for class javax.xml.ws.wsaddressing. W3CEndpointReference
默认构造函数。
W3CEndpointReference(Source) - Constructor for class javax.xml.ws.wsaddressing. W3CEndpointReference
从信息集表示形成EPR
W3CEndpointReferenceBuilder - Class in javax.xml.ws.wsaddressing
此类用于构建 W3CEndpointReference实例。
W3CEndpointReferenceBuilder() - Constructor for class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
创建一个新的 W3CEndpointReferenceBuilder实例。
WAIS - Static variable in class javax.print.attribute.standard. ReferenceUriSchemesSupported
广域信息服务器（WAIS）协议。
wait() - Method in class java.lang. Object
导致当前线程等待，直到另一个线程调用该对象的 Object.notify()方法或 Object.notifyAll()方法。
wait(long) - Method in class java.lang. Object
导致当前线程等待，直到另一个线程调用此对象的 Object.notify()方法或 Object.notifyAll()方法，或指定的时间已过。
wait(long, int) - Method in class java.lang. Object
导致当前线程等待，直到另一个线程调用 Object.notify()方法或 Object.notifyAll()方法为此对象，或其他一些线程中断当前线程，或一定量的实时已过。
WAIT - Static variable in class javafx.scene. Cursor
等待光标类型。
WAIT_CURSOR - Static variable in class java.awt. Cursor
等待光标类型。
WAIT_CURSOR - Static variable in class java.awt. Frame
已过时。
换成Cursor.WAIT_CURSOR 。
waitFor() - Method in class java.lang. Process
导致当前线程等待，如有必要，直到此 Process对象表示的进程已终止。
waitFor(long, TimeUnit) - Method in class java.lang. Process
导致当前线程等待，如果需要，直到由此 Process对象表示的进程已终止，或指定的等待时间过去。
waitForAll() - Method in class java.awt. MediaTracker
开始加载此媒体跟踪器跟踪的所有图像。
waitForAll(long) - Method in class java.awt. MediaTracker
开始加载此媒体跟踪器跟踪的所有图像。
waitForCardAbsent(long) - Method in class javax.smartcardio. CardTerminal
等待直到该终端的卡不存在或超时到期。
waitForCardPresent(long) - Method in class javax.smartcardio. CardTerminal
等待直到某个卡存在于此终端或超时到期。
waitForChange() - Method in class javax.smartcardio. CardTerminals
等待在该对象的任何终端中插入或删除卡。
waitForChange(long) - Method in class javax.smartcardio. CardTerminals
等待在该对象的任何终端中插入或删除卡，或者超时到期。
waitForID(int) - Method in class java.awt. MediaTracker
开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。
waitForID(int, long) - Method in class java.awt. MediaTracker
开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。
waitForIdle() - Method in class java.awt. Robot
等待直到事件队列上的所有事件都处理完毕。
waitForWork() - Method in class javax.swing.text. LayoutQueue
由工作线程用来获取一个新的任务来执行。
WAITING - java.lang. Thread.State
等待线程的线程状态
waitingThreads() - Method in interface com.sun.jdi. ObjectReference
返回一个列表，其中包含当前正在等待此对象的显示器的每个线程的ThreadReference 。
wakeup() - Method in class java.nio.channels. Selector
导致尚未返回的第一个选择操作立即返回。
walk(Path, int, FileVisitOption...) - Static method in class java.nio.file. Files
返回一个 Stream ，它通过走在一个给定的起始文件的根文件树上， Path 。
walk(Path, FileVisitOption...) - Static method in class java.nio.file. Files
返回一个 Stream ，它是通过走在一个给定的起始文件的文件树上，这是惰性地填充了 Path 。
walk(Function<? super Stream<StackWalker.StackFrame>, ? extends T>) - Method in class java.lang. StackWalker
将给定的函数应用于当前线程的 StackFrame的流，从堆栈的顶部框架遍历，这是调用此 walk方法的方法。
walkFileTree(Path, FileVisitor<? super Path>) - Static method in class java.nio.file. Files
走一个文件树。
walkFileTree(Path, Set<FileVisitOption>, int, FileVisitor<? super Path>) - Static method in class java.nio.file. Files
走一个文件树。
WALL - java.time.zone. ZoneOffsetTransitionRule.TimeDefinition
当地的日期时间用墙壁偏移量表示。
WALL_TIME - Static variable in class java.util. SimpleTimeZone
指定为挂钟时间的开始或结束时间模式的常数。
WANTS_INPUT_PROPERTY - Static variable in class javax.swing. JOptionPane
绑定属性名称为 wantsInput 。
wantsInput - Variable in class javax.swing. JOptionPane
如果为true，将向用户提供UI小部件以获取输入。
WARANG_CITI - java.lang. Character.UnicodeScript
Unicode脚本“Warang花旗”。
WARANG_CITI - Static variable in class java.lang. Character.UnicodeBlock
常数为“Warang Citi”Unicode字符块。
warning(String) - Method in class java.util.logging. Logger
记录警告消息。
warning(Supplier<String>) - Method in class java.util.logging. Logger
记录一条警告消息，只有当记录级别实际上记录消息时，才能构建一条警告消息。
warning(TransformerException) - Method in interface javax.xml.transform. ErrorListener
接收警告通知。
warning(SAXParseException) - Method in interface org.xml.sax. ErrorHandler
接收警告通知。
warning(SAXParseException) - Method in class org.xml.sax. HandlerBase
已过时。
接收解析器警告的通知。
warning(SAXParseException) - Method in class org.xml.sax.helpers. DefaultHandler
接收解析器警告的通知。
warning(SAXParseException) - Method in class org.xml.sax.helpers. XMLFilterImpl
过滤警告事件。
WARNING - java.awt. TrayIcon.MessageType
一条警告信息
WARNING - java.lang. System.Logger.Level
WARNING级别：通常用于记录警告消息。
WARNING - javafx.scene.control. Alert.AlertType
“警告”警告类型将“警报”对话框配置为以提示对话框的内容向用户警告某些事实或操作的方式显示。
WARNING - javax.tools. Diagnostic.Kind
通常不会阻止工具正常完成的问题。
WARNING - jdk.nashorn.api.tree. Diagnostic.Kind
通常不会阻止工具正常完成的问题。
WARNING - Static variable in class java.util.logging. Level
警告是指示潜在问题的消息级别。
WARNING - Static variable in class javax.print.attribute.standard. Severity
表示PrinterStateReason是“警告”。
WARNING - Static variable in class javax.security.auth.callback. ConfirmationCallback
警告消息类型。
WARNING - Static variable in class javax.security.auth.callback. TextOutputCallback
警告信息。
WARNING - Static variable in interface javax.xml.bind. ValidationEvent
不符合XML 1.0建议定义的错误或致命错误的条件
WARNING_DIALOG - Static variable in class javax.swing. JRootPane
用于windowDecorationStyle属性的常量。
WARNING_MESSAGE - Static variable in class javax.swing. JOptionPane
用于警告消息。
warningListeners - Variable in class javax.imageio. ImageReader
A List当前注册的 IIOReadWarningListener s，默认初始化为 null ，这是一个空的 List同义词。
warningListeners - Variable in class javax.imageio. ImageWriter
A List当前注册的 IIOWriteWarningListener s，默认初始化为 null ，这是一个空的 List同义词。
warningLocales - Variable in class javax.imageio. ImageReader
一个 List的 Locale与每个当前注册的 IIOReadWarningListener相关联，默认初始化为 null ，这是空的 List同义词。
warningLocales - Variable in class javax.imageio. ImageWriter
甲 List的 Locale S，一个用于的每个元素 warningListeners ，默认情况下初始化 null ，它与空同义 List 。
warningOccurred(ImageReader, String) - Method in interface javax.imageio.event. IIOReadWarningListener
报告解码中出现非致命错误。
warningOccurred(ImageWriter, int, String) - Method in interface javax.imageio.event. IIOWriteWarningListener
报告编码中出现非致命错误。
wasAdded() - Method in class javafx.collections. ListChangeListener.Change
指示在此更改期间是否添加元素
wasAdded() - Method in class javafx.collections. MapChangeListener.Change
如果此更改是添加操作的结果。
wasAdded() - Method in class javafx.collections. SetChangeListener.Change
如果此更改是添加操作的结果。
wasAdded() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent
如果此事件表示添加了子树项目的TreeItem事件，则返回true。
wasCollapsed() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent
如果此事件表示TreeItem collapse事件，则返回true，如果TreeItem未折叠，则返回false。
wasExpanded() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent
如果此事件表示TreeItem展开事件，则返回true，如果TreeItem未展开则返回false。
wasFocused - Variable in class javax.swing.plaf.basic. BasicMenuUI.ChangeHandler
集中的组件。
wasGarbageCollected() - Method in class javafx.beans.value. WeakChangeListener
如果链接的侦听器被垃圾回收，则返回 true 。
wasGarbageCollected() - Method in class javafx.beans. WeakInvalidationListener
如果链接的侦听器被垃圾回收，则返回 true 。
wasGarbageCollected() - Method in interface javafx.beans. WeakListener
如果链接的侦听器被垃圾回收，则返回 true 。
wasGarbageCollected() - Method in class javafx.collections. WeakListChangeListener
如果链接的监听器被垃圾回收，则返回 true 。
wasGarbageCollected() - Method in class javafx.collections. WeakMapChangeListener
如果链接的侦听器被垃圾回收，则返回 true 。
wasGarbageCollected() - Method in class javafx.collections. WeakSetChangeListener
如果链接的侦听器被垃圾回收，则返回 true 。
wasGarbageCollected() - Method in class javafx.event. WeakEventHandler
指示关联的事件处理程序是否已被垃圾回收。
wasIcon(JInternalFrame) - Method in class javax.swing. DefaultDesktopManager
返回 true如果组件已被图标化和的边界 desktopIcon是有效的，否则返回 false 。
wasIndeterminateChanged() - Method in class javafx.scene.control. CheckBoxTreeItem.TreeModificationEvent
表示此事件的原因是CheckBoxTreeItem中的不确定状态发生了变化（而不是被选择或未选择）。
wasNull() - Method in interface java.sql. CallableStatement
检索读取的最后一个OUT参数是否为SQL NULL的值。
wasNull() - Method in interface java.sql. ResultSet
报告最后一列读取的值是否为SQL NULL 。
wasNull() - Method in interface java.sql. SQLInput
检索最后读取的值是否为SQL NULL 。
wasNull() - Method in class javax.sql.rowset.serial. SQLInputImpl
确定从此 SQLInputImpl对象读取的最后一个值是否为 null 。
wasPermutated() - Method in class javafx.collections. ListChangeListener.Change
指示更改是否只是一个排列。
wasPermutated() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent
如果TreeItem子列表的顺序已更改，但没有添加或删除，则返回true。
wasRemoved() - Method in class javafx.collections. ListChangeListener.Change
表示在此更改期间元素是否被删除。
wasRemoved() - Method in class javafx.collections. MapChangeListener.Change
如果此更改是删除操作的结果。
wasRemoved() - Method in class javafx.collections. SetChangeListener.Change
如果此更改是删除操作的结果。
wasRemoved() - Method in class javafx.scene.control. TreeItem.TreeModificationEvent
如果此事件表示删除了子树项目的TreeItem事件，则返回true。
wasReplaced() - Method in class javafx.collections. ListChangeListener.Change
表示在此更改期间是否更换了元素。
wasSelectionChanged() - Method in class javafx.scene.control. CheckBoxTreeItem.TreeModificationEvent
表示此事件的原因是CheckBoxTreeItem上的选择已更改（与其变为不确定）相反。
wasUpdated() - Method in class javafx.collections. ListChangeListener.Change
表示getFrom（）（包括）到getTo（）的独占元素已更改。
watchable() - Method in interface java.nio.file. WatchKey
返回创建该观察键的对象。
Watchable - Interface in java.nio.file
可以注册到手表服务的对象，以便可以 观看更改和事件。
WatchEvent< T> - Interface in java.nio.file
一个事件或一个对象的重复事件，注册了一个WatchService 。
WatchEvent.Kind< T> - Interface in java.nio.file
一种事件类型，用于识别。
WatchEvent.Modifier - Interface in java.nio.file
一个事件修饰符，符合Watchable如何注册WatchService 。
WatchKey - Interface in java.nio.file
一个表示watchable对象注册的令牌，代码为WatchService 。
WatchpointEvent - Interface in com.sun.jdi.event
通知目标VM中线程遇到的字段触发事件。
WatchpointRequest - Interface in com.sun.jdi.request
标识正在观看的目标虚拟机中的Field 。
WatchService - Interface in java.nio.file
手表服务， 手表已注册的对象的变化和事件。
WAVE - Static variable in class javax.sound.sampled. AudioFileFormat.Type
指定WAVE文件。
WCharSeqHelper - Class in org.omg.CORBA
助手 WCharSeq 。
WCharSeqHelper() - Constructor for class org.omg.CORBA. WCharSeqHelper
WCharSeqHolder - Class in org.omg.CORBA
持有人 WCharSeq 。
WCharSeqHolder() - Constructor for class org.omg.CORBA. WCharSeqHolder
WCharSeqHolder(char[]) - Constructor for class org.omg.CORBA. WCharSeqHolder
WEAK_COMPARE_AND_SET - java.lang.invoke. VarHandle.AccessMode
访问模式，其访问由相应的方法 VarHandle.weakCompareAndSet指定
WEAK_COMPARE_AND_SET_ACQUIRE - java.lang.invoke. VarHandle.AccessMode
访问模式的访问由相应的方法 VarHandle.weakCompareAndSetAcquire指定
WEAK_COMPARE_AND_SET_PLAIN - java.lang.invoke. VarHandle.AccessMode
访问模式的访问由相应的方法 VarHandle.weakCompareAndSetPlain指定
WEAK_COMPARE_AND_SET_RELEASE - java.lang.invoke. VarHandle.AccessMode
访问模式的访问由相应的方法 VarHandle.weakCompareAndSetRelease指定
WeakChangeListener< T> - Class in javafx.beans.value
A WeakChangeListener可以使用，如果一个ObservableValue应该只保留一个对监听器的弱引用。
WeakChangeListener(ChangeListener<T>) - Constructor for class javafx.beans.value. WeakChangeListener
构造函数为 WeakChangeListener 。
weakCompareAndSet(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean
已过时。
该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见AtomicBoolean.compareAndExchange(boolean, boolean)和AtomicBoolean.compareAndSet(boolean, boolean)等方法）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicBoolean.weakCompareAndSetPlain(boolean, boolean) 。
weakCompareAndSet(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger
已过时。
该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicInteger.compareAndExchange(int, int)和AtomicInteger.compareAndSet(int, int) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法AtomicInteger.weakCompareAndSetPlain(int, int) 。
weakCompareAndSet(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
已过时。
该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicIntegerArray.compareAndExchange(int, int, int)和AtomicIntegerArray.compareAndSet(int, int, int) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicIntegerArray.weakCompareAndSetPlain(int, int, int) 。
weakCompareAndSet(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray
已过时。
该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicLongArray.compareAndExchange(int, long, long)和AtomicLongArray.compareAndSet(int, long, long) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicLongArray.weakCompareAndSetPlain(int, long, long) 。
weakCompareAndSet(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
已过时。
该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicReferenceArray.compareAndExchange(int, E, E)和AtomicReferenceArray.compareAndSet(int, E, E) ）。 为了避免在简单或易失性记忆效应上的混淆，建议使用方法AtomicReferenceArray.weakCompareAndSetPlain(int, E, E) 。
weakCompareAndSet(long, long) - Method in class java.util.concurrent.atomic. AtomicLong
已过时。
该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见AtomicLong.compareAndExchange(long, long)和AtomicLong.compareAndSet(long, long)等方法）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicLong.weakCompareAndSetPlain(long, long) 。
weakCompareAndSet(Object...) - Method in class java.lang.invoke. VarHandle
可能原子将变量到值 newValue用的存储器语义 VarHandle.setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getVolatile(java.lang.Object...) 。
weakCompareAndSet(T, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerFieldUpdater
如果当前值为 == ，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。
weakCompareAndSet(T, long, long) - Method in class java.util.concurrent.atomic. AtomicLongFieldUpdater
如果当前值 ==为预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。
weakCompareAndSet(T, V, V) - Method in class java.util.concurrent.atomic. AtomicReferenceFieldUpdater
如果当前值 ==为预期值，则将由此更新程序管理的给定对象的字段原子设置为给定的更新值。
weakCompareAndSet(V, V) - Method in class java.util.concurrent.atomic. AtomicReference
已过时。
该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicReference.compareAndExchange(V, V)和AtomicReference.compareAndSet(V, V) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicReference.weakCompareAndSetPlain(V, V) 。
weakCompareAndSet(V, V, boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicMarkableReference
如果当前引用为预期引用的 == ，并且当前标记等于预期标记，则将引用和标记的值原子设置为给定更新值。
weakCompareAndSet(V, V, int, int) - Method in class java.util.concurrent.atomic. AtomicStampedReference
如果当前参考值为预期参考值的 == ，并且当前印记等于预期的印记，则将引用和标记的值原子设置为给定的更新值。
weakCompareAndSetAcquire(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
weakCompareAndSetAcquire(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
weakCompareAndSetAcquire(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
weakCompareAndSetAcquire(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray
可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
weakCompareAndSetAcquire(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
weakCompareAndSetAcquire(long, long) - Method in class java.util.concurrent.atomic. AtomicLong
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
weakCompareAndSetAcquire(Object...) - Method in class java.lang.invoke. VarHandle
可能原子将变量到值 newValue用的语义 VarHandle.set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getAcquire(java.lang.Object...) 。
weakCompareAndSetAcquire(V, V) - Method in class java.util.concurrent.atomic. AtomicReference
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetAcquire(java.lang.Object...) 。
weakCompareAndSetPlain(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
weakCompareAndSetPlain(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
weakCompareAndSetPlain(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
weakCompareAndSetPlain(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray
如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetPlain(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
weakCompareAndSetPlain(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
weakCompareAndSetPlain(long, long) - Method in class java.util.concurrent.atomic. AtomicLong
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
weakCompareAndSetPlain(Object...) - Method in class java.lang.invoke. VarHandle
可能原子将变量到值 newValue用的语义 VarHandle.set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.get(java.lang.Object...) 。
weakCompareAndSetPlain(V, V) - Method in class java.util.concurrent.atomic. AtomicReference
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetPlain(java.lang.Object...) 。
weakCompareAndSetRelease(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
weakCompareAndSetRelease(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
weakCompareAndSetRelease(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
weakCompareAndSetRelease(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray
如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetRelease(java.lang.Object...)指定的内存效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
weakCompareAndSetRelease(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
如果元素的当前值为 == expectedValue ，具有由 VarHandle.weakCompareAndSetRelease(java.lang.Object...)指定的记忆效应，则可以将索引 i为 newValue的元素原子设置为 newValue 。
weakCompareAndSetRelease(long, long) - Method in class java.util.concurrent.atomic. AtomicLong
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
weakCompareAndSetRelease(Object...) - Method in class java.lang.invoke. VarHandle
可能原子将变量到值 newValue用的语义 VarHandle.setRelease(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.get(java.lang.Object...) 。
weakCompareAndSetRelease(V, V) - Method in class java.util.concurrent.atomic. AtomicReference
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSetRelease(java.lang.Object...) 。
weakCompareAndSetVolatile(boolean, boolean) - Method in class java.util.concurrent.atomic. AtomicBoolean
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
weakCompareAndSetVolatile(int, int) - Method in class java.util.concurrent.atomic. AtomicInteger
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
weakCompareAndSetVolatile(int, int, int) - Method in class java.util.concurrent.atomic. AtomicIntegerArray
可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
weakCompareAndSetVolatile(int, long, long) - Method in class java.util.concurrent.atomic. AtomicLongArray
如果元素的当前值为 == expectedValue ，可以将索引 i为 newValue的元素设置为 == expectedValue ，具有由 VarHandle.weakCompareAndSet(java.lang.Object...)指定的内存效果。
weakCompareAndSetVolatile(int, E, E) - Method in class java.util.concurrent.atomic. AtomicReferenceArray
可能以原子方式设置在索引元件 i到 newValue如果该元素的当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
weakCompareAndSetVolatile(long, long) - Method in class java.util.concurrent.atomic. AtomicLong
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
weakCompareAndSetVolatile(V, V) - Method in class java.util.concurrent.atomic. AtomicReference
可能原子将值设置为 newValue如果当前值 == expectedValue如通过指定，记忆效应 VarHandle.weakCompareAndSet(java.lang.Object...) 。
WeakEventHandler< T extends Event> - Class in javafx.event
用于事件处理程序注册代替其关联的事件处理程序。
WeakEventHandler(EventHandler<T>) - Constructor for class javafx.event. WeakEventHandler
创建一个新的实例 WeakEventHandler 。
WeakHashMap< K, V> - Class in java.util
基于哈希表的实现 Map接口，具有 弱键 。
WeakHashMap() - Constructor for class java.util. WeakHashMap
构造一个新的，空的 WeakHashMap ，默认的初始容量（16）和负载系数（0.75）。
WeakHashMap(int) - Constructor for class java.util. WeakHashMap
构造一个新的，空的 WeakHashMap具有给定的初始容量和默认负载因子（0.75）。
WeakHashMap(int, float) - Constructor for class java.util. WeakHashMap
构造一个新的，空的 WeakHashMap与给定的初始容量和给定的负载因子。
WeakHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util. WeakHashMap
构造一个新的 WeakHashMap与指定的地图相同的映射。
WeakInvalidationListener - Class in javafx.beans
A WeakInvalidationListener可以使用，如果一个Observable应该只保留一个对监听器的弱引用。
WeakInvalidationListener(InvalidationListener) - Constructor for class javafx.beans. WeakInvalidationListener
构造函数为 WeakInvalidationListener 。
WeakListChangeListener< E> - Class in javafx.collections
A WeakListChangeListener可以使用，如果一个ObservableList应该只保留对该监听器的弱引用。
WeakListChangeListener(ListChangeListener<E>) - Constructor for class javafx.collections. WeakListChangeListener
构造函数为 WeakListChangeListener 。
WeakListener - Interface in javafx.beans
WeakListener是JavaFX API中所有弱监听器实现的超级界面。
WeakMapChangeListener< K, V> - Class in javafx.collections
A WeakMapChangeListener可以使用，如果一个ObservableMap应该只保留一个对监听器的弱引用。
WeakMapChangeListener(MapChangeListener<K, V>) - Constructor for class javafx.collections. WeakMapChangeListener
构造函数为 WeakMapChangeListener 。
WeakReference< T> - Class in java.lang.ref
弱参考对象，不会阻止其指定对象的最终确定，最终确定，然后被回收。
WeakReference(T) - Constructor for class java.lang.ref. WeakReference
创建引用给定对象的新的弱引用。
WeakReference(T, ReferenceQueue<? super T>) - Constructor for class java.lang.ref. WeakReference
创建引用给定对象并在给定队列中注册的新的弱引用。
WeakSetChangeListener< E> - Class in javafx.collections
A WeakSetChangeListener可以使用，如果一个ObservableSet应该只保留对监听器的弱引用。
WeakSetChangeListener(SetChangeListener<E>) - Constructor for class javafx.collections. WeakSetChangeListener
构造函数为 WeakSetChangeListener 。
web(String) - Static method in class javafx.scene.paint. Color
创建使用HTML或CSS属性字符串指定的RGB颜色。
web(String, double) - Static method in class javafx.scene.paint. Color
创建使用HTML或CSS属性字符串指定的RGB颜色。
WEB - javafx.application. ConditionalFeature
表示此平台上可用的javafx.scene.web软件包。
WebEndpoint - Annotation Type in javax.xml.ws
用于注释生成的服务接口的 getPortName()方法。
WebEngine - Class in javafx.scene.web
WebEngine是一个能够一次管理一个网页的非视觉对象。
WebEngine() - Constructor for class javafx.scene.web. WebEngine
创建一个新的引擎。
WebEngine(String) - Constructor for class javafx.scene.web. WebEngine
创建一个新的引擎并加载一个网页。
WebErrorEvent - Class in javafx.scene.web
一个事件指示WebEngine错误。
WebErrorEvent(Object, EventType<WebErrorEvent>, String, Throwable) - Constructor for class javafx.scene.web. WebErrorEvent
创建一个新的 WebErrorEvent 。
WebEvent< T> - Class in javafx.scene.web
WebEvent实例被传递到EventHandler ，注册小号WebEngine由JavaScript的网页上运行。
WebEvent(Object, EventType<WebEvent>, T) - Constructor for class javafx.scene.web. WebEvent
创建一个新的事件对象。
WebFault - Annotation Type in javax.xml.ws
用于注释特定于服务的异常类，以定制到故障元素的本地和命名空间名称以及故障bean的名称。
WebHistory - Class in javafx.scene.web
WebHistory类表示与WebEngine实例相关联的会话历史。
WebHistory.Entry - Class in javafx.scene.web
Entry类代表会话历史中的单个条目。
WebMethod - Annotation Type in javax.jws
WebParam - Annotation Type in javax.jws
WebParam.Mode - Enum in javax.jws
WebResult - Annotation Type in javax.jws
WebRowSet - Interface in javax.sql.rowset
WebRowSet必须实现的所有实现的标准接口。
WebService - Annotation Type in javax.jws
WebServiceClient - Annotation Type in javax.xml.ws
用于注释生成的服务接口。
WebServiceContext - Interface in javax.xml.ws
A WebServiceContext使Web服务端点实现类可以相对于正在服务的请求访问消息上下文和安全信息。
WebServiceException - Exception in javax.xml.ws
WebServiceException类是所有JAX-WS API运行时异常的基础异常类。
WebServiceException() - Constructor for exception javax.xml.ws. WebServiceException
构造一个新的异常，以 null作为其详细消息。
WebServiceException(String) - Constructor for exception javax.xml.ws. WebServiceException
使用指定的详细消息构造新的异常。
WebServiceException(String, Throwable) - Constructor for exception javax.xml.ws. WebServiceException
构造一个新的异常与指定的详细信息和原因。
WebServiceException(Throwable) - Constructor for exception javax.xml.ws. WebServiceException
构造具有指定cause和详细消息的新WebServiceException (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
WebServiceFeature - Class in javax.xml.ws
WebServiceFeature用于表示可以为Web服务启用或禁用的功能。
WebServiceFeature() - Constructor for class javax.xml.ws. WebServiceFeature
默认构造函数。
WebServiceFeatureAnnotation - Annotation Type in javax.xml.ws.spi
用于将其他注释识别为 WebServiceFeature注释。
WebServicePermission - Class in javax.xml.ws
此类定义Web服务权限。
WebServicePermission(String) - Constructor for class javax.xml.ws. WebServicePermission
创建具有指定名称的新权限。
WebServicePermission(String, String) - Constructor for class javax.xml.ws. WebServicePermission
创建具有指定名称和操作的新权限。
WebServiceProvider - Annotation Type in javax.xml.ws
用于注释Provider实现类。
WebServiceRef - Annotation Type in javax.xml.ws
WebServiceRef注释用于定义对Web服务的引用以及（可选）为其注入目标。
WebServiceRefs - Annotation Type in javax.xml.ws
WebServiceRefs注释允许在类级别声明多个Web服务引用。
WebSocket - Interface in jdk.incubator.http
符合RFC 6455的WebSocket客户端。
WebSocket.Builder - Interface in jdk.incubator.http
用于创建 WebSocket实例的构建器。
WebSocket.Listener - Interface in jdk.incubator.http
一个 WebSocket事件和消息的 WebSocket 。
WebSocket.MessagePart - Enum in jdk.incubator.http
WebSocket.Listener在可能收到部分消息的情况下使用的标记。
WebSocketHandshakeException - Exception in jdk.incubator.http
用于表示开启握手的异常失败。
WebSocketHandshakeException(HttpResponse<?>) - Constructor for exception jdk.incubator.http. WebSocketHandshakeException
WebView - Class in javafx.scene.web
WebView是一个Node ，管理一个WebEngine并显示其内容。
WebView() - Constructor for class javafx.scene.web. WebView
创建一个 WebView对象。
WEDNESDAY - java.time. DayOfWeek
星期三的星期几的单身人士例子。
WEDNESDAY - Static variable in class java.util. Calendar
价值 Calendar.DAY_OF_WEEK字段显示周三。
WEEK_BASED_YEAR - Static variable in class java.time.temporal. IsoFields
代表周年的领域。
WEEK_BASED_YEARS - Static variable in class java.time.temporal. IsoFields
以加法和减法为目的的以星期为单位的单位。
WEEK_BASED_YEARS - Static variable in class java.time.temporal. WeekFields
以加法和减法为目的的以星期为单位的单位。
WEEK_OF_MONTH - Static variable in class java.text. DateFormat.Field
不断识别月份字段。
WEEK_OF_MONTH - Static variable in class java.util. Calendar
get字段编号和 set表示 set的周数。
WEEK_OF_MONTH_FIELD - Static variable in class java.text. DateFormat
WEEK_OF_MONTH字段对齐的常用常数。
WEEK_OF_WEEK_BASED_YEAR - Static variable in class java.time.temporal. IsoFields
代表周周的一年的领域。
WEEK_OF_YEAR - Static variable in class java.text. DateFormat.Field
常年识别一周的字段。
WEEK_OF_YEAR - Static variable in class java.util. Calendar
get字段编号和 set表示 set的周数。
WEEK_OF_YEAR_FIELD - Static variable in class java.text. DateFormat
WEEK_OF_YEAR字段对齐的常用常数。
weekBasedYear() - Method in class java.time.temporal. WeekFields
根据这个 WeekFields返回一个字段以访问一周的年份。
WeekFields - Class in java.time.temporal
星期几，星期周和周末字段的本地化定义。
weekOfMonth() - Method in class java.time.temporal. WeekFields
根据这个 WeekFields返回一个字段以访问一个月。
weekOfWeekBasedYear() - Method in class java.time.temporal. WeekFields
根据这个 WeekFields返回一个字段以访问一周的周。
weekOfYear() - Method in class java.time.temporal. WeekFields
根据这个 WeekFields返回一个字段以访问一周中的一周。
WEEKS - java.time.temporal. ChronoUnit
代表一周概念的单位。
weight - Variable in class java.awt.font. GlyphJustificationInfo
这个字形的重量。
WEIGHT - Static variable in class java.awt.font. TextAttribute
字体重量的属性键。
WEIGHT_BOLD - Static variable in class java.awt.font. TextAttribute
标准大胆的体重。
WEIGHT_DEMIBOLD - Static variable in class java.awt.font. TextAttribute
中等重量比 WEIGHT_BOLD轻。
WEIGHT_DEMILIGHT - Static variable in class java.awt.font. TextAttribute
中间重量在 WEIGHT_LIGHT和 WEIGHT_STANDARD之间。
WEIGHT_EXTRA_LIGHT - Static variable in class java.awt.font. TextAttribute
最轻的预定义重量。
WEIGHT_EXTRABOLD - Static variable in class java.awt.font. TextAttribute
重量过重
WEIGHT_HEAVY - Static variable in class java.awt.font. TextAttribute
重量比 WEIGHT_BOLD中等重。
WEIGHT_LIGHT - Static variable in class java.awt.font. TextAttribute
标准重量轻。
WEIGHT_MEDIUM - Static variable in class java.awt.font. TextAttribute
中间重量在 WEIGHT_REGULAR和 WEIGHT_BOLD之间。
WEIGHT_REGULAR - Static variable in class java.awt.font. TextAttribute
标准重量。
WEIGHT_SEMIBOLD - Static variable in class java.awt.font. TextAttribute
比 WEIGHT_REGULAR中等重。
WEIGHT_ULTRABOLD - Static variable in class java.awt.font. TextAttribute
最重的预定义重量。
weightx - Variable in class java.awt. GridBagConstraints
指定如何分配额外的水平空间。
weighty - Variable in class java.awt. GridBagConstraints
指定如何分配额外的垂直空间。
WEST - Static variable in class java.awt. BorderLayout
西布局限制（容器左侧）。
WEST - Static variable in class java.awt. GridBagConstraints
将组件放置在其显示区域的左侧，垂直居中。
WEST - Static variable in class javax.swing. SpringLayout
指定组件的边界矩形的左边缘。
WEST - Static variable in interface javax.swing. SwingConstants
指南针方向西（左）。
westPane - Variable in class javax.swing.plaf.basic. BasicInternalFrameUI
西面
WHEAT - Static variable in class javafx.scene.paint. Color
RGB值为＃F5DEB3的彩色小麦
WHEEL_BLOCK_SCROLL - Static variable in class java.awt.event. MouseWheelEvent
表示通过“块”滚动的常量（如滚动页面向下，向下翻页键）
WHEEL_UNIT_SCROLL - Static variable in class java.awt.event. MouseWheelEvent
表示以“单位”滚动的常量（如用箭头键滚动）
when - Variable in class java.awt. Event
已过时。
时间戳
when(ObservableBooleanValue) - Static method in class javafx.beans.binding. Bindings
创建一个计算三元表达式结果的绑定。
When - Class in javafx.beans.binding
计算三元表达式的绑定的起始点。
When(ObservableBooleanValue) - Constructor for class javafx.beans.binding. When
构造函数为 When 。
WHEN_ANCESTOR_OF_FOCUSED_COMPONENT - Static variable in class javax.swing. JComponent
常量用于 registerKeyboardAction ，这意味着当接收组件是聚焦组件的祖先或本身是关注组件时，应调用该命令。
WHEN_FOCUSED - Static variable in class javax.swing. JComponent
常量用于 registerKeyboardAction ，这意味着当组件具有焦点时应该调用该命令。
WHEN_IN_FOCUSED_WINDOW - Static variable in class javax.swing. JComponent
用于 registerKeyboardAction常量，这意味着当接收组件在具有焦点的窗口中或者本身是聚焦组件时，应该调用该命令。
When.BooleanConditionBuilder - Class in javafx.beans.binding
组装三元表达时需要一个中间类。
When.NumberConditionBuilder - Class in javafx.beans.binding
if-then-else表达式返回一个数字。
When.ObjectConditionBuilder< T> - Class in javafx.beans.binding
组装三元表达时需要一个中间类。
When.StringConditionBuilder - Class in javafx.beans.binding
组装三元表达时需要一个中间类。
whenComplete(BiConsumer<? super T, ? super Throwable>) - Method in class java.util.concurrent. CompletableFuture
whenComplete(BiConsumer<? super T, ? super Throwable>) - Method in interface java.util.concurrent. CompletionStage
返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>) - Method in class java.util.concurrent. CompletableFuture
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>) - Method in interface java.util.concurrent. CompletionStage
返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>, Executor) - Method in class java.util.concurrent. CompletableFuture
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>, Executor) - Method in interface java.util.concurrent. CompletionStage
返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。
WHERE_CLAUSE_ONLY - java.sql. PseudoColumnUsage
伪/隐藏列只能在WHERE子句中使用。
WHILE_LOOP - com.sun.source.tree. Tree.Kind
用于WhileLoopTree的实例。
WHILE_LOOP - jdk.nashorn.api.tree. Tree.Kind
用于WhileLoopTree的实例。
whileLoop(MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke. MethodHandles
从初始化器，身体和谓词构造一个 while循环。
WhileLoopTree - Interface in com.sun.source.tree
一个用于 while循环语句的树节点。
WhileLoopTree - Interface in jdk.nashorn.api.tree
循环语句的“while”树结点。
white - Static variable in class java.awt. Color
颜色白色。
WHITE - Static variable in class java.awt. Color
颜色白色。
WHITE - Static variable in class javafx.scene.paint. Color
颜色为白色，RGB值为#FFFFFF
WHITE_BALANCE_AUTO - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
要与“WhiteBalance”标签一起使用的值。
WHITE_BALANCE_MANUAL - Static variable in class javax.imageio.plugins.tiff. ExifTIFFTagSet
要与“WhiteBalance”标签一起使用的值。
WHITE_SPACE - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“空格”。
WHITESMOKE - Static variable in class javafx.scene.paint. Color
彩色白色烟雾，RGB值为＃F5F5F5
WHITESPACE - Static variable in class java.awt.font. GlyphMetrics
表示没有视觉表示的字形。
whitespaceChars(int, int) - Method in class java.io. StreamTokenizer
指定 low <= c <= high范围内的所有字符 c都是空白字符。
WHOLE - jdk.incubator.http. WebSocket.MessagePart
一个由单一部分组成的消息。
why - Variable in exception org.omg.CosNaming.NamingContextPackage. NotFound
width - Variable in class java.awt. Component.BltBufferStrategy
后缓冲区的宽度
width - Variable in class java.awt. Dimension
宽度尺寸; 可以使用负值。
width - Variable in class java.awt.geom. Arc2D.Double
整个椭圆的整个宽度，其圆弧是部分截面（不考虑角度范围）。
width - Variable in class java.awt.geom. Arc2D.Float
整个椭圆的整个宽度，其圆弧是部分截面（不考虑角度范围）。
width - Variable in class java.awt.geom. Ellipse2D.Double
这个 Ellipse2D的整体宽度。
width - Variable in class java.awt.geom. Ellipse2D.Float
这个 Ellipse2D的整体宽度。
width - Variable in class java.awt.geom. Rectangle2D.Double
该宽度为 Rectangle2D 。
width - Variable in class java.awt.geom. Rectangle2D.Float
这个宽度 Rectangle2D 。
width - Variable in class java.awt.geom. RoundRectangle2D.Double
这个宽度 RoundRectangle2D 。
width - Variable in class java.awt.geom. RoundRectangle2D.Float
该宽度为 RoundRectangle2D 。
width - Variable in class java.awt.image. Raster
这个光栅的宽度。
width - Variable in class java.awt.image. SampleModel
此SampleModel描述的图像数据区域的宽度（以像素为单位）。
width - Variable in class java.awt. Rectangle
宽度为 Rectangle 。
width - Variable in class javax.swing.table. TableColumn
列的宽度。
width(Component) - Static method in class javax.swing. Spring
返回一个弹簧，其 最小值 ， 首选 值 ， 最大值和 值属性由所提供组件的 minimumSize ， preferredSize ， maximumSize和 size属性的宽度定义。
WIDTH - Static variable in class java.awt.font. TextAttribute
字体宽度的属性键。
WIDTH - Static variable in interface java.awt.image. ImageObserver
imageUpdate的infoflags参数中的此标志表示基本图像的宽度现在可用，可以从imageUpdate回调方法的width参数中获取。
WIDTH - Static variable in class javax.swing. SpringLayout
指定组件边界矩形的宽度。
WIDTH - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“width”。
WIDTH - Static variable in class javax.swing.text.html. HTML.Attribute
属性“width”
WIDTH_CONDENSED - Static variable in class java.awt.font. TextAttribute
最浓缩的预定宽度。
WIDTH_EXTENDED - Static variable in class java.awt.font. TextAttribute
最大的预定宽度。
WIDTH_REGULAR - Static variable in class java.awt.font. TextAttribute
标准宽度。
WIDTH_SEMI_CONDENSED - Static variable in class java.awt.font. TextAttribute
中等浓度的宽度。
WIDTH_SEMI_EXTENDED - Static variable in class java.awt.font. TextAttribute
中等宽度的宽度。
widthProperty() - Method in class javafx.scene.canvas. Canvas
定义画布的宽度。
widthProperty() - Method in class javafx.scene.control. Dialog
表示对话框宽度的属性。
widthProperty() - Method in class javafx.scene.control. TableColumnBase
此列的宽度。
widthProperty() - Method in class javafx.scene.effect. BoxBlur
模糊效果的水平维度。
widthProperty() - Method in class javafx.scene.effect. ColorInput
相对于内容 Node的局部坐标空间设置要淹没的区域的宽度。
widthProperty() - Method in class javafx.scene.effect. DropShadow
阴影模糊内核的水平尺寸。
widthProperty() - Method in class javafx.scene.effect. FloatMap
地图的宽度，以像素为单位。
widthProperty() - Method in class javafx.scene.effect. InnerShadow
阴影模糊内核的水平尺寸。
widthProperty() - Method in class javafx.scene.effect. Shadow
阴影模糊内核的水平尺寸。
widthProperty() - Method in class javafx.scene.image. Image
图像宽度或 0如果图像加载失败。
widthProperty() - Method in class javafx.scene.layout. Region
这个可调节大小的节点的宽度。
widthProperty() - Method in class javafx.scene.media. Media
源媒体的像素宽度。
widthProperty() - Method in class javafx.scene. Scene
这个宽度 Scene
widthProperty() - Method in class javafx.scene.shape. Box
定义Box的宽度或X尺寸。
widthProperty() - Method in class javafx.scene.shape. Rectangle
定义矩形的宽度。
widthProperty() - Method in class javafx.scene. SubScene
定义此 SubScene的宽度
widthProperty() - Method in class javafx.scene.web. WebView
此宽度 WebView 。
widthProperty() - Method in class javafx.stage. Window
这个宽度 Window 。
WILDCARD - javax.lang.model.type. TypeKind
通配符类型参数。
WILDCARD - Static variable in class javax.management. ObjectName
定义通配符“*：*”ObjectName。
WildcardTree - Interface in com.sun.source.tree
用于通配符类型参数的树节点。
WildcardType - Interface in com.sun.javadoc
已过时。
该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
WildcardType - Interface in java.lang.reflect
WildcardType表示一个通配符型表达，如 ? ， ? extends Number ，或 ? super Integer 。
WildcardType - Interface in javax.lang.model.type
表示通配符类型参数。
WIND_EVEN_ODD - Static variable in class java.awt.geom. Path2D
用于确定路径内部的偶数绕组规则。
WIND_EVEN_ODD - Static variable in interface java.awt.geom. PathIterator
用于指定用于确定路径内部的偶数奇数规则的绕组规则常数。
WIND_NON_ZERO - Static variable in class java.awt.geom. Path2D
用于确定路径内部的非零绕组规则。
WIND_NON_ZERO - Static variable in interface java.awt.geom. PathIterator
用于指定用于确定路径内部的非零规则的卷绕规则常数。
window - Static variable in class java.awt. SystemColor
为Windows内部区域背景渲染的颜色。
Window - Class in java.awt
一个 Window对象是没有边框的顶级窗口，没有菜单。
Window - Class in javafx.stage
托管场景的顶层窗口，用户与之交互的顶级窗口。
Window() - Constructor for class javafx.stage. Window
Window(Frame) - Constructor for class java.awt. Window
构造一个新的，最初不可见的窗口，其中指定的是 Frame作为其所有者。
Window(Window) - Constructor for class java.awt. Window
构造一个新的，最初不可见的窗口，其中指定的是 Window作为其所有者。
Window(Window, GraphicsConfiguration) - Constructor for class java.awt. Window
构造一个新的，最初不可见的窗口，其中指定的所有者为 Window和屏幕设备的 GraphicsConfiguration 。
WINDOW - Static variable in class com.sun.java.accessibility.util. EventID
映射到AWT窗口支持（即WindowListener和WindowEvent）
WINDOW - Static variable in class java.awt. SystemColor
SystemColor.window系统颜色的数组索引。
WINDOW - Static variable in class javax.accessibility. AccessibleRole
没有标题或边框的顶级窗口。
WINDOW_ACTIVATED - Static variable in class java.awt.event. WindowEvent
窗口激活的事件类型。
WINDOW_BORDER - Static variable in class java.awt. SystemColor
阵列索引为 SystemColor.windowBorder系统颜色。
WINDOW_BOTTOM_LEFT - javafx.stage. PopupWindow.AnchorLocation
代表左下角的角落。
WINDOW_BOTTOM_RIGHT - javafx.stage. PopupWindow.AnchorLocation
表示右下角的角落。
WINDOW_CLOSE_REQUEST - Static variable in class javafx.stage. WindowEvent
当有外部请求关闭该窗口时，此事件将传递到窗口。
WINDOW_CLOSED - Static variable in class java.awt.event. WindowEvent
窗户关闭事件。
WINDOW_CLOSING - Static variable in class java.awt.event. WindowEvent
“窗口正在关闭”事件。
WINDOW_DEACTIVATED - Static variable in class java.awt.event. WindowEvent
窗口停用事件类型。
WINDOW_DEICONIFIED - Static variable in class java.awt.event. WindowEvent
窗口deiconified事件类型。
WINDOW_DEICONIFY - Static variable in class java.awt. Event
已过时。
用户已经要求窗口管理器去除图标化窗口。
WINDOW_DESTROY - Static variable in class java.awt. Event
已过时。
用户已经要求窗口管理器杀死窗口。
WINDOW_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择窗口事件的事件掩码。
WINDOW_EXPOSE - Static variable in class java.awt. Event
已过时。
用户已经要求窗口管理器公开窗口。
WINDOW_FIRST - Static variable in class java.awt.event. WindowEvent
用于窗口事件的ids范围中的第一个数字。
WINDOW_FOCUS_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择窗口焦点事件的事件掩码。
WINDOW_GAINED_FOCUS - Static variable in class java.awt.event. WindowEvent
窗口获取焦点事件类型。
WINDOW_HIDDEN - Static variable in class javafx.stage. WindowEvent
此事件发生在隐藏后的窗口上。
WINDOW_HIDING - Static variable in class javafx.stage. WindowEvent
此事件发生在隐藏之前的窗口上。
WINDOW_ICONIFIED - Static variable in class java.awt.event. WindowEvent
窗口图标化事件。
WINDOW_ICONIFY - Static variable in class java.awt. Event
已过时。
用户已经要求窗口管理器图标化窗口。
WINDOW_LAST - Static variable in class java.awt.event. WindowEvent
用于窗口事件的ID的范围中的最后一个数字。
WINDOW_LOST_FOCUS - Static variable in class java.awt.event. WindowEvent
窗口丢失焦点事件类型。
WINDOW_MODAL - javafx.stage. Modality
定义一个模态窗口，阻止事件传递到其整个所有者窗口层次结构。
WINDOW_MOVED - Static variable in class java.awt. Event
已过时。
用户已经要求窗口管理器移动窗口。
WINDOW_OPENED - Static variable in class java.awt.event. WindowEvent
窗户打开事件。
WINDOW_SHOWING - Static variable in class javafx.stage. WindowEvent
此事件发生在显示之前的窗口上。
WINDOW_SHOWN - Static variable in class javafx.stage. WindowEvent
此事件发生在显示之后的窗口上。
WINDOW_STATE_CHANGED - Static variable in class java.awt.event. WindowEvent
窗口状态更改的事件类型。
WINDOW_STATE_EVENT_MASK - Static variable in class java.awt. AWTEvent
用于选择窗口状态事件的事件掩码。
WINDOW_TEXT - Static variable in class java.awt. SystemColor
阵列索引为 SystemColor.windowText系统颜色。
WINDOW_TOP_LEFT - javafx.stage. PopupWindow.AnchorLocation
代表左上角的角落。
WINDOW_TOP_RIGHT - javafx.stage. PopupWindow.AnchorLocation
代表右上角的角落。
Window.AccessibleAWTWindow - Class in java.awt
这个类实现 Window类的可访问性支持。
Window.Type - Enum in java.awt
枚举可用的 窗口类型 。
windowActivated(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowActivated方法来处理windowActivated事件。
windowActivated(WindowEvent) - Method in class java.awt.event. WindowAdapter
激活窗口时调用。
windowActivated(WindowEvent) - Method in interface java.awt.event. WindowListener
当窗口设置为活动窗口时调用。
WindowAdapter - Class in java.awt.event
用于接收窗口事件的抽象适配器类。
WindowAdapter() - Constructor for class java.awt.event. WindowAdapter
windowBorder - Static variable in class java.awt. SystemColor
为窗户内部区域的边界呈现的颜色。
windowClosed(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowClosed方法来处理windowClosed事件。
windowClosed(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口关闭时调用。
windowClosed(WindowEvent) - Method in interface java.awt.event. WindowListener
当窗口关闭时调用窗口调用处理结果时调用。
windowClosing(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowClosing方法处理windowClosing事件。
windowClosing(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口处于关闭状态时调用。
windowClosing(WindowEvent) - Method in interface java.awt.event. WindowListener
当用户尝试从窗口的系统菜单中关闭窗口时调用。
windowClosing(WindowEvent) - Method in class javax.swing. JMenu.WinListener
弹出窗口从外部关闭时取消选择菜单。
windowClosing(WindowEvent) - Method in class javax.swing.plaf.basic. BasicToolBarUI.FrameListener
WindowConstants - Interface in javax.swing
用于控制窗口关闭操作的常量。
windowDeactivated(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowDeactivated方法来处理windowDeactivated事件。
windowDeactivated(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口被禁用时调用。
windowDeactivated(WindowEvent) - Method in interface java.awt.event. WindowListener
当窗口不再是活动窗口时调用。
windowDeiconified(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowDeiconified方法来处理windowDeiconified事件。
windowDeiconified(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口被去图标化时调用。
windowDeiconified(WindowEvent) - Method in interface java.awt.event. WindowListener
当窗口从最小化更改为正常状态时调用。
WindowEvent - Class in java.awt.event
指示窗口已更改其状态的低级别事件。
WindowEvent - Class in javafx.stage
与窗口显示/隐藏操作相关的事件。
WindowEvent(Window, int) - Constructor for class java.awt.event. WindowEvent
构造一个 WindowEvent对象。
WindowEvent(Window, int, int, int) - Constructor for class java.awt.event. WindowEvent
构造具有指定的上一个和新的窗口状态的一个 WindowEvent对象。
WindowEvent(Window, int, Window) - Constructor for class java.awt.event. WindowEvent
构造一个 WindowEvent对象，其指定的对面为 Window 。
WindowEvent(Window, int, Window, int, int) - Constructor for class java.awt.event. WindowEvent
构造一个 WindowEvent对象。
WindowEvent(Window, EventType<? extends Event>) - Constructor for class javafx.stage. WindowEvent
使用指定的事件源，目标和类型构造新的 Event 。
WindowFocusListener - Interface in java.awt.event
收听界面接收 WindowEvents ，其中包括 WINDOW_GAINED_FOCUS和 WINDOW_LOST_FOCUS事件。
windowForComponent(Component) - Static method in class javax.swing. SwingUtilities
返回第 Window祖先 c ，或 null如果 c未包含在里面 Window 。
windowGainedFocus(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowGainedFocus方法来处理windowGainedFocus事件。
windowGainedFocus(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
windowGainedFocus(WindowEvent) - Method in interface java.awt.event. WindowFocusListener
当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
windowIconified(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowIconified方法来处理windowIconified事件。
windowIconified(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口被图标化时调用。
windowIconified(WindowEvent) - Method in interface java.awt.event. WindowListener
当窗口从正常状态更改为最小化状态时调用。
windowInit() - Method in class javax.swing. JWindow
由构造函数调用，正确启动 JWindow 。
windowListener - Static variable in class com.sun.java.accessibility.util. AWTEventMonitor
不推荐用于删除：此API元素将在以后的版本中被删除。
此字段未使用。
WindowListener - Interface in java.awt.event
用于接收窗口事件的侦听器界面。
windowLostFocus(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowLostFocus方法来处理windowLostFocus事件。
windowLostFocus(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。
windowLostFocus(WindowEvent) - Method in interface java.awt.event. WindowFocusListener
当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。
windowMenu - Variable in class javax.swing.plaf.basic. BasicInternalFrameTitlePane
实例 JMenu 。
windowOpened(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowOpened方法处理windowOpened事件。
windowOpened(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口打开时调用。
windowOpened(WindowEvent) - Method in interface java.awt.event. WindowListener
第一次调用窗口可见。
windowProperty() - Method in class javafx.scene. Scene
该 Window为这 Scene
WINDOWS - javafx.scene.input. KeyCode
Microsoft Windows“Windows”键的常数。
windowStateChanged(WindowEvent) - Method in class java.awt. AWTEventMulticaster
通过调用listener-a和listener-b上的windowStateChanged方法来处理windowStateChanged事件。
windowStateChanged(WindowEvent) - Method in class java.awt.event. WindowAdapter
当窗口状态改变时调用。
windowStateChanged(WindowEvent) - Method in interface java.awt.event. WindowStateListener
窗口状态改变时调用。
WindowStateListener - Interface in java.awt.event
用于接收窗口状态事件的侦听器接口。
windowText - Static variable in class java.awt. SystemColor
为窗口内部区域的文字渲染的颜色。
WinListener(JPopupMenu) - Constructor for class javax.swing. JMenu.WinListener
为指定的弹出窗口创建窗口侦听器。
with(Month) - Method in class java.time. MonthDay
返回这个 MonthDay的副本， MonthDay更改月份。
with(TemporalAdjuster) - Method in interface java.time.chrono. ChronoLocalDate
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in interface java.time.chrono. ChronoLocalDateTime
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in interface java.time.chrono. ChronoZonedDateTime
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in class java.time.chrono. HijrahDate
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in class java.time.chrono. JapaneseDate
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in class java.time.chrono. MinguoDate
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in class java.time.chrono. ThaiBuddhistDate
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in class java.time. Instant
返回此瞬间的调整副本。
with(TemporalAdjuster) - Method in class java.time. LocalDate
返回此日期的调整副本。
with(TemporalAdjuster) - Method in class java.time. LocalDateTime
返回此日期时间的调整副本。
with(TemporalAdjuster) - Method in class java.time. LocalTime
返回此次调整后的副本。
with(TemporalAdjuster) - Method in class java.time. OffsetDateTime
返回此日期时间的调整副本。
with(TemporalAdjuster) - Method in class java.time. OffsetTime
返回此次调整后的副本。
with(TemporalAdjuster) - Method in interface java.time.temporal. Temporal
通过进行调整，返回与该对象相同类型的调整对象。
with(TemporalAdjuster) - Method in class java.time. Year
返回今年的调整副本。
with(TemporalAdjuster) - Method in class java.time. YearMonth
返回今年的调整副本。
with(TemporalAdjuster) - Method in class java.time. ZonedDateTime
返回此日期时间的调整副本。
with(TemporalField, long) - Method in interface java.time.chrono. ChronoLocalDate
返回与该对象具有相同类型的对象，并更改指定的字段。
with(TemporalField, long) - Method in interface java.time.chrono. ChronoLocalDateTime
返回与该对象具有相同类型的对象，并更改指定的字段。
with(TemporalField, long) - Method in interface java.time.chrono. ChronoZonedDateTime
返回与该对象具有相同类型的对象，并更改指定的字段。
with(TemporalField, long) - Method in class java.time.chrono. HijrahDate
with(TemporalField, long) - Method in class java.time.chrono. JapaneseDate
with(TemporalField, long) - Method in class java.time.chrono. MinguoDate
with(TemporalField, long) - Method in class java.time.chrono. ThaiBuddhistDate
with(TemporalField, long) - Method in class java.time. Instant
将指定的字段设置为新值返回此瞬间的副本。
with(TemporalField, long) - Method in class java.time. LocalDate
返回此日期的副本，并将指定的字段设置为新值。
with(TemporalField, long) - Method in class java.time. LocalDateTime
返回此日期时间的副本，并将指定的字段设置为新值。
with(TemporalField, long) - Method in class java.time. LocalTime
返回此时间的副本，并将指定的字段设置为新值。
with(TemporalField, long) - Method in class java.time. OffsetDateTime
返回此日期时间的副本，并将指定的字段设置为新值。
with(TemporalField, long) - Method in class java.time. OffsetTime
返回此时间的副本，并将指定的字段设置为新值。
with(TemporalField, long) - Method in interface java.time.temporal. Temporal
返回与该对象具有相同类型的对象，并更改指定的字段。
with(TemporalField, long) - Method in class java.time. Year
返回今年的副本，并将指定的字段设置为新值。
with(TemporalField, long) - Method in class java.time. YearMonth
返回此年月份的副本，并将指定的字段设置为新值。
with(TemporalField, long) - Method in class java.time. ZonedDateTime
返回此日期时间的副本，并将指定的字段设置为新值。
with(CatalogFeatures.Feature, String) - Method in class javax.xml.catalog. CatalogFeatures.Builder
将值设置为指定的要素。
WITH - jdk.nashorn.api.tree. Tree.Kind
用于WithTree的实例。
withCachedThreadPool(ExecutorService, int) - Static method in class java.nio.channels. AsynchronousChannelGroup
创建具有给定线程池的异步通道组，根据需要创建新线程。
withChronology(Chronology) - Method in class java.time.format. DateTimeFormatter
使用新的覆盖年表返回此格式化程序的副本。
withDayOfMonth(int) - Method in class java.time. LocalDate
返回 LocalDate的副本，并更改日期。
withDayOfMonth(int) - Method in class java.time. LocalDateTime
返回 LocalDateTime的副本，并更改日期。
withDayOfMonth(int) - Method in class java.time. MonthDay
返回此 MonthDay的副本，并更改日期。
withDayOfMonth(int) - Method in class java.time. OffsetDateTime
返回 OffsetDateTime的副本，并更改日期。
withDayOfMonth(int) - Method in class java.time. ZonedDateTime
返回 ZonedDateTime的副本，并更改日期。
withDayOfYear(int) - Method in class java.time. LocalDate
返回此 LocalDate更改的 LocalDate的副本。
withDayOfYear(int) - Method in class java.time. LocalDateTime
返回此 LocalDateTime更改的 LocalDateTime的副本。
withDayOfYear(int) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime更改的 OffsetDateTime的副本。
withDayOfYear(int) - Method in class java.time. ZonedDateTime
返回该日期更改的 ZonedDateTime的副本。
withDays(int) - Method in class java.time. Period
以指定的天数返回此期间的副本。
withDecimalSeparator(char) - Method in class java.time.format. DecimalStyle
使用代表小数点的新字符返回信息的副本。
withDecimalStyle(DecimalStyle) - Method in class java.time.format. DateTimeFormatter
使用新的DecimalStyle返回此格式化程序的副本。
withEarlierOffsetAtOverlap() - Method in interface java.time.chrono. ChronoZonedDateTime
返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。
withEarlierOffsetAtOverlap() - Method in class java.time. ZonedDateTime
返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。
withFixedOffsetZone() - Method in class java.time. ZonedDateTime
返回此日期时间的副本，区域ID设置为偏移量。
withFixedThreadPool(int, ThreadFactory) - Static method in class java.nio.channels. AsynchronousChannelGroup
创建具有固定线程池的异步通道组。
withHour(int) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并更改日期。
withHour(int) - Method in class java.time. LocalTime
返回 LocalTime的副本，并更改日期。
withHour(int) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，并更改日期。
withHour(int) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并更改日期。
withHour(int) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并更改日期。
withInitial(Supplier<? extends S>) - Static method in class java.lang. ThreadLocal
创建线程局部变量。
withLaterOffsetAtOverlap() - Method in interface java.time.chrono. ChronoZonedDateTime
返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。
withLaterOffsetAtOverlap() - Method in class java.time. ZonedDateTime
返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。
withLocale(Locale) - Method in class java.time.format. DateTimeFormatter
使用新的语言环境返回此格式化程序的副本。
withMinute(int) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，小时改变。
withMinute(int) - Method in class java.time. LocalTime
返回 LocalTime的副本，小时改变。
withMinute(int) - Method in class java.time. OffsetDateTime
返回此 OffsetDateTime的副本，小时改变。
withMinute(int) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，小时改变。
withMinute(int) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，小时改变。
withMonth(int) - Method in class java.time. LocalDate
返回这个 LocalDate的副本， LocalDate更改月份。
withMonth(int) - Method in class java.time. LocalDateTime
返回这个 LocalDateTime的副本，并更改月份。
withMonth(int) - Method in class java.time. MonthDay
返回这个 MonthDay的副本， MonthDay更改月份。
withMonth(int) - Method in class java.time. OffsetDateTime
返回这个 OffsetDateTime的副本， OffsetDateTime更改月份。
withMonth(int) - Method in class java.time. YearMonth
返回这个 YearMonth的副本， YearMonth更改月份。
withMonth(int) - Method in class java.time. ZonedDateTime
返回这个 ZonedDateTime的副本， ZonedDateTime日更改。
withMonths(int) - Method in class java.time. Period
以指定的月数返回此期间的副本。
withNamespace(Namespace) - Method in interface jdk.dynalink. Operation
以此操作为基础返回一个NamespaceOperation 。
withNamespaces(Namespace...) - Method in interface jdk.dynalink. Operation
以此操作为基础返回NamespaceOperation 。
withNano(int) - Method in class java.time. LocalDateTime
返回这个 LocalDateTime的副本， LocalDateTime改变了。
withNano(int) - Method in class java.time. LocalTime
返回这个 LocalTime的副本，并修改了纳秒。
withNano(int) - Method in class java.time. OffsetDateTime
返回这个 OffsetDateTime的副本， OffsetDateTime改变了。
withNano(int) - Method in class java.time. OffsetTime
返回这个 OffsetTime的副本，并修改了纳秒。
withNano(int) - Method in class java.time. ZonedDateTime
返回这个 ZonedDateTime的副本， ZonedDateTime改变了。
withNanos(int) - Method in class java.time. Duration
以指定的纳秒为单位返回此持续时间的副本。
withNegativeSign(char) - Method in class java.time.format. DecimalStyle
以一个新的字符返回信息的副本，表示负号。
withOffsetSameInstant(ZoneOffset) - Method in class java.time. OffsetDateTime
以指定的偏移量返回此 OffsetDateTime的副本，确保结果处于同一时刻。
withOffsetSameInstant(ZoneOffset) - Method in class java.time. OffsetTime
以指定的偏移量返回此 OffsetTime的副本，确保结果在隐含日期处于同一时刻。
withOffsetSameLocal(ZoneOffset) - Method in class java.time. OffsetDateTime
返回具有指定偏移量的 OffsetDateTime的副本，确保结果具有相同的本地日期时间。
withOffsetSameLocal(ZoneOffset) - Method in class java.time. OffsetTime
以指定的偏移量返回此 OffsetTime的副本，确保结果具有相同的本地时间。
withoutPadding() - Method in class java.util. Base64.Encoder
返回一个编码器实例，编码器等效于此编码器实例，但不会在编码字节数据的末尾添加任何填充字符。
withPositiveSign(char) - Method in class java.time.format. DecimalStyle
返回信息的副本，并显示一个表示正号的新字符。
withResolverFields(TemporalField...) - Method in class java.time.format. DateTimeFormatter
使用一组新的解析器字段返回此格式化程序的副本。
withResolverFields(Set<TemporalField>) - Method in class java.time.format. DateTimeFormatter
使用一组新的解析器字段返回此格式化程序的副本。
withResolverStyle(ResolverStyle) - Method in class java.time.format. DateTimeFormatter
使用新的解析器样式返回此格式化程序的副本。
withSecond(int) - Method in class java.time. LocalDateTime
返回此 LocalDateTime的副本，并更改了第二分钟。
withSecond(int) - Method in class java.time. LocalTime
返回此 LocalTime的副本，其中第二分钟更改。
withSecond(int) - Method in class java.time. OffsetDateTime
返回这个 OffsetDateTime的副本，第二分钟更改。
withSecond(int) - Method in class java.time. OffsetTime
返回此 OffsetTime的副本，并更改了第二分钟。
withSecond(int) - Method in class java.time. ZonedDateTime
返回此 ZonedDateTime的副本，并更改了第二分钟。
withSeconds(long) - Method in class java.time. Duration
以指定的秒数返回此持续时间的副本。
withThreadPool(ExecutorService) - Static method in class java.nio.channels. AsynchronousChannelGroup
使用给定的线程池创建异步通道组。
WithTree - Interface in jdk.nashorn.api.tree
“with”语句的树结点。
withVarargs(boolean) - Method in class java.lang.invoke. MethodHandle
如果布尔标志为真，则将此方法句柄改为 variable arity ，否则为 fixed arity 。
withVariant(HijrahChronology) - Method in class java.time.chrono. HijrahDate
返回一个 HijrahDate与时间表请求。
withYear(int) - Method in class java.time. LocalDate
返回此年份变更的 LocalDate的副本。
withYear(int) - Method in class java.time. LocalDateTime
返回该 LocalDateTime的副本。
withYear(int) - Method in class java.time. OffsetDateTime
返回该 OffsetDateTime的副本。
withYear(int) - Method in class java.time. YearMonth
返回该 YearMonth的副本。
withYear(int) - Method in class java.time. ZonedDateTime
返回该 ZonedDateTime的副本。
withYears(int) - Method in class java.time. Period
以指定的年数返回此期间的副本。
withZeroDigit(char) - Method in class java.time.format. DecimalStyle
返回信息的副本，其中新的字符表示零。
withZone(ZoneId) - Method in class java.time. Clock
以不同的时区返回此时钟的副本。
withZone(ZoneId) - Method in class java.time.format. DateTimeFormatter
使用新的覆盖区域返回此格式化程序的副本。
withZoneSameInstant(ZoneId) - Method in interface java.time.chrono. ChronoZonedDateTime
使用不同的时区返回此日期时间的副本，保留即时。
withZoneSameInstant(ZoneId) - Method in class java.time. ZonedDateTime
使用不同的时区返回此日期时间的副本，保留即时。
withZoneSameLocal(ZoneId) - Method in interface java.time.chrono. ChronoZonedDateTime
使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。
withZoneSameLocal(ZoneId) - Method in class java.time. ZonedDateTime
使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。
WORD - javafx.scene.control.skin. TextInputControlSkin.TextUnit
WORD - Static variable in interface javax.accessibility. AccessibleText
常数用于表示应检索的文本部分是一个单词。
WORD_ELLIPSIS - javafx.scene.control. OverrunStyle
与ELLIPSIS相同，但首先删除标签边界上的任何部分单词，然后应用省略号。
WORD_SPACING - Static variable in class javax.swing.text.html. CSS.Attribute
CSS属性“字间距”。
wordChars(int, int) - Method in class java.io. StreamTokenizer
指定 low <= c <= high范围内的所有字符 c都是字组成。
work_pending() - Method in class org.omg.CORBA. ORB
返回 true如果ORB需要主线程来执行某些工作，并 false如果ORB不需要主线程。
workDoneProperty() - Method in class javafx.concurrent. Service
workDoneProperty() - Method in class javafx.concurrent. Task
workDoneProperty() - Method in interface javafx.concurrent. Worker
获取表示当前进度的ReadOnlyDoubleProperty。
Worker< V> - Interface in javafx.concurrent
工作者是在一个或多个后台线程中执行某些工作的对象，其状态是可观察的并且可用于JavaFX应用程序，并且可从主JavaFX应用程序线程中使用。
WORKER_STATE_CANCELLED - Static variable in class javafx.concurrent. WorkerStateEvent
当Worker实现的状态转换到CANCELED状态时，会发生此事件。
WORKER_STATE_FAILED - Static variable in class javafx.concurrent. WorkerStateEvent
当Worker实现的状态已转换到FAILED状态时，会发生此事件。
WORKER_STATE_READY - Static variable in class javafx.concurrent. WorkerStateEvent
当Worker实现的状态已转换到READY状态时，会发生此事件。
WORKER_STATE_RUNNING - Static variable in class javafx.concurrent. WorkerStateEvent
当Worker实现的状态已转换到RUNNING状态时，会发生此事件。
WORKER_STATE_SCHEDULED - Static variable in class javafx.concurrent. WorkerStateEvent
当Worker实现的状态已转换到SCHEDULED状态时，会发生此事件。
WORKER_STATE_SUCCEEDED - Static variable in class javafx.concurrent. WorkerStateEvent
当Worker实现的状态已转换到SUCCEEDED状态时，会发生此事件。
Worker.State - Enum in javafx.concurrent
工人的状态。
WorkerStateEvent - Class in javafx.concurrent
当一个工人状态发生变化时发生的事件。
WorkerStateEvent(Worker, EventType<? extends WorkerStateEvent>) - Constructor for class javafx.concurrent. WorkerStateEvent
创建一个新的WorkerStateEvent。
wrap() - Method in class java.lang.invoke. MethodType
将所有原始类型转换为相应的包装类型。
wrap(byte[]) - Static method in class java.nio. ByteBuffer
将一个字节数组包装到缓冲区中。
wrap(byte[], int, int) - Static method in class java.nio. ByteBuffer
将一个字节数组包装到缓冲区中。
wrap(byte[], int, int) - Method in interface javax.security.sasl. SaslClient
包装要发送到服务器的字节数组。
wrap(byte[], int, int) - Method in interface javax.security.sasl. SaslServer
包装要发送给客户端的字节数组。
wrap(byte[], int, int, MessageProp) - Method in interface org.ietf.jgss. GSSContext
在已建立的安全上下文中应用每消息安全服务。
wrap(char[]) - Static method in class java.nio. CharBuffer
将一个char数组包装到缓冲区中。
wrap(char[], int, int) - Static method in class java.nio. CharBuffer
将一个char数组包装到缓冲区中。
wrap(double[]) - Static method in class java.nio. DoubleBuffer
将双阵列包装到缓冲区中。
wrap(double[], int, int) - Static method in class java.nio. DoubleBuffer
将双阵列包装到缓冲区中。
wrap(float[]) - Static method in class java.nio. FloatBuffer
将一个浮点数组放入缓冲区。
wrap(float[], int, int) - Static method in class java.nio. FloatBuffer
将一个浮点数组放入缓冲区。
wrap(int[]) - Static method in class java.nio. IntBuffer
将int数组包装到缓冲区中。
wrap(int[], int, int) - Static method in class java.nio. IntBuffer
将int数组包装到缓冲区中。
wrap(long[]) - Static method in class java.nio. LongBuffer
将长阵列包装到缓冲区中。
wrap(long[], int, int) - Static method in class java.nio. LongBuffer
将长阵列包装到缓冲区中。
wrap(short[]) - Static method in class java.nio. ShortBuffer
将一个短阵列包装到缓冲区中。
wrap(short[], int, int) - Static method in class java.nio. ShortBuffer
将一个短阵列包装到缓冲区中。
wrap(InputStream) - Method in class java.util. Base64.Decoder
返回用于解码Base64编码字节流的输入流。
wrap(InputStream, OutputStream, MessageProp) - Method in interface org.ietf.jgss. GSSContext
使用流在已建立的安全上下文中应用每消息安全服务。
wrap(OutputStream) - Method in class java.util. Base64.Encoder
使用Base64编码方案包装用于编码字节数据的输出流。
wrap(CharSequence) - Static method in class java.nio. CharBuffer
将字符序列包装到缓冲区中。
wrap(CharSequence, int, int) - Static method in class java.nio. CharBuffer
将字符序列包装到缓冲区中。
wrap(Object) - Static method in class jdk.nashorn.api.scripting. ScriptUtils
如果需要，在给定对象上做一个脚本对象镜像。
wrap(Object, Object) - Static method in class jdk.nashorn.api.scripting. ScriptObjectMirror
如果需要，在给定对象上做一个脚本对象镜像。
wrap(ByteBuffer[], int, int, ByteBuffer) - Method in class javax.net.ssl. SSLEngine
尝试将明文字节从数据缓冲区的子序列编码为SSL / TLS / DTLS网络数据。
wrap(ByteBuffer[], ByteBuffer) - Method in class javax.net.ssl. SSLEngine
尝试将明文字节从一系列数据缓冲区编码为SSL / TLS / DTLS网络数据。
wrap(ByteBuffer, ByteBuffer) - Method in class javax.net.ssl. SSLEngine
尝试将明文应用程序数据的缓冲区编码到SSL / TLS / DTLS网络数据中。
wrap(Key) - Method in class javax.crypto. Cipher
包裹钥匙
WRAP_MODE - Static variable in class javax.crypto. Cipher
常数用于将密码初始化为密钥包装模式。
WRAP_TAB_LAYOUT - Static variable in class javax.swing. JTabbedPane
当所有选项卡不适合单个运行时，用于在多个运行中包装选项卡的选项卡布局策略。
wrapAroundProperty() - Method in class javafx.scene.control. SpinnerValueFactory
wrapAround属性用于指定值factory是圆形的。
wrapArray(Object[]) - Static method in class jdk.nashorn.api.scripting. ScriptUtils
如果需要，将对象数组包装到脚本对象镜像中。
wrapArray(Object[], Object) - Static method in class jdk.nashorn.api.scripting. ScriptObjectMirror
如果需要，将对象数组包装到脚本对象镜像中。
wrapAsJSONCompatible(Object, Object) - Static method in class jdk.nashorn.api.scripting. ScriptObjectMirror
如果需要，在给定对象上做一个脚本对象镜像。
wrapException(Throwable) - Static method in class javax.rmi.CORBA. Util
包装一个实现方法抛出的异常。
wrapException(Throwable) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.wrapException(java.lang.Throwable) 。
wrapped() - Method in interface jdk.jshell. SourceCodeAnalysis.SnippetWrapper
返回一个包含 SourceCodeAnalysis.SnippetWrapper.source()的Java类定义，或者导入导入源。
WRAPPED - javax.jws.soap. SOAPBinding.ParameterStyle
WrappedPlainView - Class in javax.swing.text
查看纯文本（只有一种字体和颜色的文本），进行换行。
WrappedPlainView(Element) - Constructor for class javax.swing.text. WrappedPlainView
创建一个新的WrappedPlainView。
WrappedPlainView(Element, boolean) - Constructor for class javax.swing.text. WrappedPlainView
创建一个新的WrappedPlainView。
wrappedToSourcePosition(int) - Method in interface jdk.jshell. SourceCodeAnalysis.SnippetWrapper
将字符位置映射到源中的字符位置。
wrapper(Snippet) - Method in class jdk.jshell. SourceCodeAnalysis
返回 Snippet的包装信息。
Wrapper - Interface in java.sql
提供在有问题的实例实际上是一个代理类时能够检索委托实例的JDBC类的接口。
wrapperInstanceTarget(Object) - Static method in class java.lang.invoke. MethodHandleProxies
产生或恢复目标方法句柄，其行为上等同于此包装器实例的唯一方法。
wrapperInstanceType(Object) - Static method in class java.lang.invoke. MethodHandleProxies
恢复创建此包装器实例的唯一的单一方法接口类型。
wrappers(String) - Method in class jdk.jshell. SourceCodeAnalysis
返回输入源字符串中代码段的包装器信息。
wrappingWidthProperty() - Method in class javafx.scene.text. Text
定义用户空间坐标中文本的宽度约束，例如像素，而不是字形或字符数。
wrapProperty() - Method in class javafx.scene.effect. DisplacementMap
是否定义从地图边缘外部获取的值是否“绕回”。
wrapTextProperty() - Method in class javafx.scene.control. Labeled
如果文本运行超过了标签的宽度，则该变量指示文本是否应该包装到另一行。
wrapTextProperty() - Method in class javafx.scene.control. TextArea
如果文本的运行超出了 TextArea的宽度，则该变量指示文本是否应该 TextArea另一行。
wrapTextProperty() - Method in class javafx.scene.control. Tooltip
如果文本运行超过工具提示的宽度，则该变量指示文本是否应该包装到另一行。
writableAction - Static variable in class javax.swing.text. DefaultEditorKit
将编辑器设置为可写模式的操作名称。
WritableBooleanValue - Interface in javafx.beans.value
一个可写布尔值。
WritableByteChannel - Interface in java.nio.channels
一个可以写字节的通道。
WritableDoubleValue - Interface in javafx.beans.value
一个可写的双重值。
WritableFloatValue - Interface in javafx.beans.value
可写浮点值。
WritableImage - Class in javafx.scene.image
WritableImage类表示由应用程序提供的像素构建的自定义图形图像，可能来自任何数量来源的 PixelReader对象，包括从文件或URL读取的图像。
WritableImage(int, int) - Constructor for class javafx.scene.image. WritableImage
构造指定尺寸的空图像。
WritableImage(PixelReader, int, int) - Constructor for class javafx.scene.image. WritableImage
构造指定尺寸的图像，从指定的PixelReader初始化。
WritableImage(PixelReader, int, int, int, int) - Constructor for class javafx.scene.image. WritableImage
构造指定尺寸的图像，从PixelReader的指定区域初始化。
WritableIntegerValue - Interface in javafx.beans.value
一个可写的int值。
WritableListValue< E> - Interface in javafx.beans.value
可写参考一个ObservableList 。
WritableLongValue - Interface in javafx.beans.value
一个可写的长期价值。
WritableMapValue< K, V> - Interface in javafx.beans.value
可写参考一个ObservableMap 。
WritableNumberValue - Interface in javafx.beans.value
标记接口，用于标记包含数字的所有子接口WritableValue 。
WritableObjectValue< T> - Interface in javafx.beans.value
可写类型值。
WritablePixelFormat< T extends Buffer> - Class in javafx.scene.image
表示可以存储全色的像素格式的物体PixelFormat可以用作从任意图像写入像素数据的目的地格式。
WritableRaster - Class in java.awt.image
该类扩展了Raster，以提供像素写入功能。
WritableRaster(SampleModel, DataBuffer, Point) - Constructor for class java.awt.image. WritableRaster
使用给定的SampleModel和DataBuffer构造WritableRaster。
WritableRaster(SampleModel, DataBuffer, Rectangle, Point, WritableRaster) - Constructor for class java.awt.image. WritableRaster
使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。
WritableRaster(SampleModel, Point) - Constructor for class java.awt.image. WritableRaster
使用给定的SampleModel构造WritableRaster。
WritableRenderedImage - Interface in java.awt.image
WritableRenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口，可以修改和/或写入。
WritableSetValue< E> - Interface in javafx.beans.value
可写参考ObservableSet 。
WritableStringValue - Interface in javafx.beans.value
一个可写的字符串。
WritableValue< T> - Interface in javafx.beans.value
A WritableValue是一个包含可读取和设置的值的实体。
write() - Method in class javax.swing.text. AbstractWriter
这个抽象方法需要由子类实现。
write() - Method in class javax.swing.text.html. HTMLWriter
迭代元素树，并控制所有标签及其属性的写入。
write() - Method in class javax.swing.text.html. MinimalHTMLWriter
从StyledDocument生成HTML输出。
write(byte[]) - Method in interface java.io. DataOutput
将输出流写入数组 b所有字节。
write(byte[]) - Method in class java.io. FileOutputStream
将 b.length字节从指定的字节数组写入此文件输出流。
write(byte[]) - Method in class java.io. FilterOutputStream
向此输出流写入 b.length个字节。
write(byte[]) - Method in interface java.io. ObjectOutput
写入一个字节数组。
write(byte[]) - Method in class java.io. ObjectOutputStream
写入一个字节数组。
write(byte[]) - Method in class java.io. OutputStream
将 b.length字节从指定的字节数组写入此输出流。
write(byte[]) - Method in class java.io. RandomAccessFile
从指定的字节数组写入 b.length字节到该文件，从当前文件指针开始。
write(byte[]) - Method in class javax.crypto. CipherOutputStream
将 b.length字节从指定的字节数组写入此输出流。
write(byte[]) - Method in interface javax.imageio.stream. ImageOutputStream
在当前位置写入一串字节。
write(byte[]) - Method in class javax.imageio.stream. ImageOutputStreamImpl
write(byte[]) - Method in interface javax.jnlp. JNLPRandomAccessFile
从指定的字节数组写入 b.length字节到该文件，从当前文件指针开始。
write(byte[], int, int) - Method in class java.io. BufferedOutputStream
从指定的字节数组写入 len个字节，从偏移 off开始，输出到缓冲的输出流。
write(byte[], int, int) - Method in class java.io. ByteArrayOutputStream
从指定的字节数组写入 len字节，从偏移量 off开始， off到该字节数组输出流。
write(byte[], int, int) - Method in interface java.io. DataOutput
从阵列 b写入 len字节，以输出流。
write(byte[], int, int) - Method in class java.io. DataOutputStream
从指定的字节数组写入 len个字节，从偏移 off开始到底层输出流。
write(byte[], int, int) - Method in class java.io. FileOutputStream
从指定的字节数组写入 len个字节，从偏移量 off开始到该文件输出流。
write(byte[], int, int) - Method in class java.io. FilterOutputStream
从指定的 byte阵列写入 len个字节，从偏移量 off开始输出到此输出流。
write(byte[], int, int) - Method in interface java.io. ObjectOutput
写入一个子字节数组。
write(byte[], int, int) - Method in class java.io. ObjectOutputStream
写入一个子字节数组。
write(byte[], int, int) - Method in class java.io. OutputStream
从指定的字节数组写入 len字节，从偏移量 off开始输出到此输出流。
write(byte[], int, int) - Method in class java.io. PipedOutputStream
从指定的字节数组写入 len字节，从偏移量 off开始， off到这个管道输出流。
write(byte[], int, int) - Method in class java.io. PrintStream
从指定的字节数组写入 len字节，从偏移量 off开始写入此流。
write(byte[], int, int) - Method in class java.io. RandomAccessFile
从指定的字节数组写入 len字节，从偏移量 off开始到该文件。
write(byte[], int, int) - Method in class java.rmi.server. LogStream
已过时。
没有替换
write(byte[], int, int) - Method in class java.security. DigestOutputStream
使用指定的子阵列更新消息摘要（如果摘要功能打开），并且无论如何将子阵列写入输出流。
write(byte[], int, int) - Method in class java.util.zip. CheckedOutputStream
写入一个字节数组。
write(byte[], int, int) - Method in class java.util.zip. DeflaterOutputStream
将一个字节数组写入压缩的输出流。
write(byte[], int, int) - Method in class java.util.zip. GZIPOutputStream
将字节数组写入压缩输出流。
write(byte[], int, int) - Method in class java.util.zip. InflaterOutputStream
将一组字节写入未压缩的输出流。
write(byte[], int, int) - Method in class java.util.zip. ZipOutputStream
将一个字节数组写入当前的ZIP条目数据。
write(byte[], int, int) - Method in class javax.crypto. CipherOutputStream
从偏移量 off开始的指定字节数组写入 len个字节到此输出流。
write(byte[], int, int) - Method in class javax.imageio.stream. FileCacheImageOutputStream
write(byte[], int, int) - Method in class javax.imageio.stream. FileImageOutputStream
write(byte[], int, int) - Method in interface javax.imageio.stream. ImageOutputStream
在当前位置写入一串字节。
write(byte[], int, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
write(byte[], int, int) - Method in class javax.imageio.stream. MemoryCacheImageOutputStream
write(byte[], int, int) - Method in interface javax.jnlp. JNLPRandomAccessFile
从指定的字节数组写入 len字节，从偏移量 off开始写入此文件。
write(byte[], int, int) - Method in interface javax.sound.sampled. SourceDataLine
通过该源数据线将音频数据写入混频器。
write(char) - Method in class javax.swing.text. AbstractWriter
写出一个字符
write(char[]) - Method in class java.io. PrintWriter
写入一个字符数组。
write(char[]) - Method in class java.io. Writer
写入一个字符数组。
write(char[], int, int) - Method in class java.io. BufferedWriter
写入字符数组的一部分。
write(char[], int, int) - Method in class java.io. CharArrayWriter
将字符写入缓冲区。
write(char[], int, int) - Method in class java.io. FilterWriter
写入字符数组的一部分。
write(char[], int, int) - Method in class java.io. OutputStreamWriter
写入字符数组的一部分。
write(char[], int, int) - Method in class java.io. PipedWriter
从指定的字符数组写入 len字符，从偏移量 off开始 off到这个管道输出流。
write(char[], int, int) - Method in class java.io. PrintWriter
写一个字符数组的一部分。
write(char[], int, int) - Method in class java.io. StringWriter
写一个字符数组的一部分。
write(char[], int, int) - Method in class java.io. Writer
写入字符数组的一部分。
write(char[], int, int) - Method in class javax.swing.text. AbstractWriter
所有写入方法都调用到这一个中。
write(int) - Method in class java.io. BufferedOutputStream
将指定的字节写入缓冲的输出流。
write(int) - Method in class java.io. BufferedWriter
写一个字符
write(int) - Method in class java.io. ByteArrayOutputStream
将指定的字节写入此字节数组输出流。
write(int) - Method in class java.io. CharArrayWriter
将一个字符写入缓冲区。
write(int) - Method in interface java.io. DataOutput
向输出流写入参数 b的八个低位。
write(int) - Method in class java.io. DataOutputStream
将指定的字节（参数 b的低8位）写入底层输出流。
write(int) - Method in class java.io. FileOutputStream
将指定的字节写入此文件输出流。
write(int) - Method in class java.io. FilterOutputStream
将指定的 byte写入此输出流。
write(int) - Method in class java.io. FilterWriter
写一个字符
write(int) - Method in interface java.io. ObjectOutput
写一个字节。
write(int) - Method in class java.io. ObjectOutputStream
写一个字节。
write(int) - Method in class java.io. OutputStream
将指定的字节写入此输出流。
write(int) - Method in class java.io. OutputStreamWriter
写一个字符
write(int) - Method in class java.io. PipedOutputStream
将指定的 byte写入管道输出流。
write(int) - Method in class java.io. PipedWriter
将指定的 char写入管道输出流。
write(int) - Method in class java.io. PrintStream
将指定的字节写入此流。
write(int) - Method in class java.io. PrintWriter
写一个字符
write(int) - Method in class java.io. RandomAccessFile
将指定的字节写入此文件。
write(int) - Method in class java.io. StringWriter
写一个字符
write(int) - Method in class java.io. Writer
写一个字符
write(int) - Method in class java.rmi.server. LogStream
已过时。
没有替换
write(int) - Method in class java.security. DigestOutputStream
使用指定的字节更新消息摘要（如果摘要功能打开），并且无论如何将该字节写入输出流。
write(int) - Method in class java.util.zip. CheckedOutputStream
写一个字节。
write(int) - Method in class java.util.zip. DeflaterOutputStream
将一个字节写入压缩的输出流。
write(int) - Method in class java.util.zip. InflaterOutputStream
将一个字节写入未压缩的输出流。
write(int) - Method in class javax.crypto. CipherOutputStream
将指定的字节写入此输出流。
write(int) - Method in class javax.imageio.stream. FileCacheImageOutputStream
write(int) - Method in class javax.imageio.stream. FileImageOutputStream
write(int) - Method in interface javax.imageio.stream. ImageOutputStream
将当前位置的单个字节写入流。
write(int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
write(int) - Method in class javax.imageio.stream. MemoryCacheImageOutputStream
write(int) - Method in interface javax.jnlp. JNLPRandomAccessFile
将指定的字节写入此文件。
write(int) - Method in class org.omg.CORBA.portable. OutputStream
将一个整数（数组长度）写入此流。
write(RenderedImage) - Method in class javax.imageio. ImageWriter
将包含单个图像的完整图像流附加到输出的默认元数据和缩略图。
write(RenderedImage, String, File) - Static method in class javax.imageio. ImageIO
使用支持给定格式的任意 ImageWriter写入图像到 File 。
write(RenderedImage, String, OutputStream) - Static method in class javax.imageio. ImageIO
使用支持给定格式的任意 ImageWriter写入图像到 OutputStream 。
write(RenderedImage, String, ImageOutputStream) - Static method in class javax.imageio. ImageIO
使用支持给定格式的任意 ImageWriter写入图像到 ImageOutputStream 。
write(DataOutput) - Method in class java.rmi.server. UID
将 UID的二进制表示法 UID交给 DataOutput实例。
write(ObjectOutput) - Method in class java.io. ObjectOutputStream.PutField
已过时。
此方法不会以适当的格式写入此PutField对象所包含的值，并可能导致序列化流的损坏。 写PutField数据的正确方法是通过调用ObjectOutputStream.writeFields()方法。
write(ObjectOutput) - Method in class java.rmi.server. ObjID
将此 ObjID的二进制表示法 ObjID交给 ObjectOutput实例。
write(OutputStream) - Method in class java.awt.color. ICC_Profile
将此ICC_Profile写入OutputStream。
write(OutputStream) - Method in class java.util.jar. Manifest
将清单写入指定的OutputStream。
write(OutputStream, Document, int, int) - Method in class javax.swing.text. DefaultEditorKit
以适合此类内容处理程序的格式将内容从文档写入给定流。
write(OutputStream, Document, int, int) - Method in class javax.swing.text. EditorKit
以适合此类内容处理程序的格式将内容从文档写入给定流。
write(OutputStream, Document, int, int) - Method in class javax.swing.text.rtf. RTFEditorKit
将内容从文档以适合此类内容处理程序的格式写入给定流。
write(Writer) - Method in class javax.swing.text. JTextComponent
将模型的内容存储到给定的流中。
write(Writer, Document, int, int) - Method in class javax.swing.text. DefaultEditorKit
将内容从文档写入给定的流作为纯文本。
write(Writer, Document, int, int) - Method in class javax.swing.text. EditorKit
以适合此类内容处理程序的格式将内容从文档写入给定流。
write(Writer, Document, int, int) - Method in class javax.swing.text.html. HTMLEditorKit
将内容从文档以适合此类内容处理程序的格式写入给定流。
write(Writer, Document, int, int) - Method in class javax.swing.text.rtf. RTFEditorKit
将内容从文档写入给定流作为纯文本。
write(String) - Method in class java.awt.color. ICC_Profile
将此ICC_Profile写入文件。
write(String) - Method in class java.io. PrintWriter
写一个字符串
write(String) - Method in class java.io. StringWriter
写一个字符串
write(String) - Method in class java.io. Writer
写一个字符串
write(String) - Method in class javax.swing.text. AbstractWriter
写出一个字符串。
write(String) - Method in interface org.w3c.dom.html. HTMLDocument
将一串文本写入由 open()打开的文档流。
write(String, int, int) - Method in class java.io. BufferedWriter
写一个字符串的一部分。
write(String, int, int) - Method in class java.io. CharArrayWriter
将一部分字符串写入缓冲区。
write(String, int, int) - Method in class java.io. FilterWriter
写一个字符串的一部分。
write(String, int, int) - Method in class java.io. OutputStreamWriter
写一个字符串的一部分。
write(String, int, int) - Method in class java.io. PrintWriter
写一个字符串的一部分。
write(String, int, int) - Method in class java.io. StringWriter
写一个字符串的一部分
write(String, int, int) - Method in class java.io. Writer
写一个字符串的一部分。
write(String, ByteBuffer) - Method in interface java.nio.file.attribute. UserDefinedFileAttributeView
从缓冲区写入用户定义属性的值。
write(ByteBuffer) - Method in interface java.nio.channels. AsynchronousByteChannel
从给定的缓冲区向该通道写入一个字节序列。
write(ByteBuffer) - Method in class java.nio.channels. AsynchronousSocketChannel
write(ByteBuffer) - Method in class java.nio.channels. DatagramChannel
将数据报写入此通道。
write(ByteBuffer) - Method in class java.nio.channels. FileChannel
从给定的缓冲区向该通道写入一个字节序列。
write(ByteBuffer) - Method in interface java.nio.channels. SeekableByteChannel
从给定的缓冲区向该通道写入一个字节序列。
write(ByteBuffer) - Method in class java.nio.channels. SocketChannel
write(ByteBuffer) - Method in interface java.nio.channels. WritableByteChannel
从给定的缓冲区向该通道写入一个字节序列。
write(ByteBuffer[]) - Method in class java.nio.channels. DatagramChannel
将数据报写入此通道。
write(ByteBuffer[]) - Method in class java.nio.channels. FileChannel
从给定的缓冲区向该通道写入一系列字节。
write(ByteBuffer[]) - Method in interface java.nio.channels. GatheringByteChannel
从给定的缓冲区向该通道写入一系列字节。
write(ByteBuffer[]) - Method in class java.nio.channels. SocketChannel
write(ByteBuffer[], int, int) - Method in class java.nio.channels. DatagramChannel
将数据报写入此通道。
write(ByteBuffer[], int, int) - Method in class java.nio.channels. FileChannel
从给定缓冲区的子序列将一个字节序列写入该通道。
write(ByteBuffer[], int, int) - Method in interface java.nio.channels. GatheringByteChannel
从给定缓冲区的子序列将一个字节序列写入该通道。
write(ByteBuffer[], int, int) - Method in class java.nio.channels. SocketChannel
write(ByteBuffer[], int, int, long, TimeUnit, A, CompletionHandler<Long, ? super A>) - Method in class java.nio.channels. AsynchronousSocketChannel
从给定缓冲区的子序列将一个字节序列写入该通道。
write(ByteBuffer, long) - Method in class java.nio.channels. AsynchronousFileChannel
从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
write(ByteBuffer, long) - Method in class java.nio.channels. FileChannel
从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
write(ByteBuffer, long, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels. AsynchronousFileChannel
从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
write(ByteBuffer, long, TimeUnit, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels. AsynchronousSocketChannel
从给定的缓冲区向该通道写入一个字节序列。
write(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in interface java.nio.channels. AsynchronousByteChannel
从给定的缓冲区向该通道写入一个字节序列。
write(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels. AsynchronousSocketChannel
write(Path, byte[], OpenOption...) - Static method in class java.nio.file. Files
将字节写入文件。
write(Path, Iterable<? extends CharSequence>, Charset, OpenOption...) - Static method in class java.nio.file. Files
将文本行写入文件。
write(Path, Iterable<? extends CharSequence>, OpenOption...) - Static method in class java.nio.file. Files
将文本行写入文件。
write(IIOImage) - Method in class javax.imageio. ImageWriter
将含有默认元数据和缩略图的单个图像的完整图像流附加到输出。
write(IIOMetadata, IIOImage, ImageWriteParam) - Method in class javax.imageio. ImageWriter
将包含单个图像和关联流以及图像元数据和缩略图的完整图像流附加到输出。
write(Sequence, int, File) - Static method in class javax.sound.midi. MidiSystem
写入表示所提供外部文件的MIDI文件类型的文件的字节流。
write(Sequence, int, File) - Method in class javax.sound.midi.spi. MidiFileWriter
写入表示所提供外部文件的文件类型的MIDI文件的字节流。
write(Sequence, int, OutputStream) - Static method in class javax.sound.midi. MidiSystem
写入表示所提供的输出流的MIDI文件类型的文件的字节流。
write(Sequence, int, OutputStream) - Method in class javax.sound.midi.spi. MidiFileWriter
写入表示所提供的输出流的文件类型的MIDI文件的字节流。
write(AudioInputStream, AudioFileFormat.Type, File) - Static method in class javax.sound.sampled. AudioSystem
将指定文件类型的音频文件的字节流写入提供的外部文件。
write(AudioInputStream, AudioFileFormat.Type, File) - Method in class javax.sound.sampled.spi. AudioFileWriter
将表示所提供的外部文件的文件格式的音频文件的字节流写入。
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - Static method in class javax.sound.sampled. AudioSystem
将指定文件类型的音频文件的字节流写入提供的输出流。
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - Method in class javax.sound.sampled.spi. AudioFileWriter
写入表示所提供的输出流的文件类型的音频文件的字节流。
write(OutputStream, boolean[]) - Static method in class org.omg.CORBA. BooleanSeqHelper
write(OutputStream, byte[]) - Static method in class org.omg.CORBA. OctetSeqHelper
write(OutputStream, byte[]) - Static method in class org.omg.PortableInterceptor. ObjectIdHelper
write(OutputStream, char[]) - Static method in class org.omg.CORBA. CharSeqHelper
write(OutputStream, char[]) - Static method in class org.omg.CORBA. WCharSeqHelper
write(OutputStream, double[]) - Static method in class org.omg.CORBA. DoubleSeqHelper
write(OutputStream, float[]) - Static method in class org.omg.CORBA. FloatSeqHelper
write(OutputStream, int) - Static method in class org.omg.CORBA. PolicyTypeHelper
write(OutputStream, int) - Static method in class org.omg.IOP. ComponentIdHelper
write(OutputStream, int) - Static method in class org.omg.IOP. ProfileIdHelper
write(OutputStream, int) - Static method in class org.omg.IOP. ServiceIdHelper
write(OutputStream, int) - Static method in class org.omg.PortableInterceptor. AdapterManagerIdHelper
write(OutputStream, int[]) - Static method in class org.omg.CORBA. LongSeqHelper
write(OutputStream, int[]) - Static method in class org.omg.CORBA. ULongSeqHelper
write(OutputStream, long[]) - Static method in class org.omg.CORBA. LongLongSeqHelper
write(OutputStream, long[]) - Static method in class org.omg.CORBA. ULongLongSeqHelper
write(OutputStream, short) - Static method in class org.omg.CORBA. PolicyErrorCodeHelper
write(OutputStream, short) - Static method in class org.omg.CORBA. VisibilityHelper
write(OutputStream, short) - Static method in class org.omg.Messaging. SyncScopeHelper
write(OutputStream, short) - Static method in class org.omg.PortableInterceptor. AdapterStateHelper
write(OutputStream, short[]) - Static method in class org.omg.CORBA. ShortSeqHelper
write(OutputStream, short[]) - Static method in class org.omg.CORBA. UShortSeqHelper
write(OutputStream, Serializable) - Static method in class org.omg.CORBA. ValueBaseHelper
write(OutputStream, String) - Static method in class org.omg.CORBA. FieldNameHelper
write(OutputStream, String) - Static method in class org.omg.CORBA. IdentifierHelper
write(OutputStream, String) - Static method in class org.omg.CORBA. RepositoryIdHelper
write(OutputStream, String) - Static method in class org.omg.CORBA. StringValueHelper
write(OutputStream, String) - Static method in class org.omg.CORBA. VersionSpecHelper
write(OutputStream, String) - Static method in class org.omg.CORBA. WStringValueHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming. IstringHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage. AddressHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage. StringNameHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage. URLStringHelper
write(OutputStream, String) - Static method in class org.omg.DynamicAny. FieldNameHelper
write(OutputStream, String) - Static method in class org.omg.PortableInterceptor. ORBIdHelper
write(OutputStream, String) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. ObjectIdHelper
write(OutputStream, String) - Static method in class org.omg.PortableInterceptor. ServerIdHelper
write(OutputStream, String[]) - Static method in class org.omg.CORBA. StringSeqHelper
write(OutputStream, String[]) - Static method in class org.omg.CORBA. WStringSeqHelper
write(OutputStream, String[]) - Static method in class org.omg.PortableInterceptor. AdapterNameHelper
write(OutputStream, Any[]) - Static method in class org.omg.CORBA. AnySeqHelper
write(OutputStream, Any[]) - Static method in class org.omg.DynamicAny. AnySeqHelper
write(OutputStream, Bounds) - Static method in class org.omg.CORBA. BoundsHelper
write(OutputStream, CompletionStatus) - Static method in class org.omg.CORBA. CompletionStatusHelper
write(OutputStream, Current) - Static method in class org.omg.CORBA. CurrentHelper
write(OutputStream, DefinitionKind) - Static method in class org.omg.CORBA. DefinitionKindHelper
write(OutputStream, IDLType) - Static method in class org.omg.CORBA. IDLTypeHelper
write(OutputStream, NameValuePair) - Static method in class org.omg.CORBA. NameValuePairHelper
write(OutputStream, Object) - Static method in class org.omg.CORBA. ObjectHelper
write(OutputStream, InvalidName) - Static method in class org.omg.CORBA.ORBPackage. InvalidNameHelper
write(OutputStream, ParameterMode) - Static method in class org.omg.CORBA. ParameterModeHelper
write(OutputStream, Policy) - Static method in class org.omg.CORBA. PolicyHelper
write(OutputStream, Policy[]) - Static method in class org.omg.CORBA. PolicyListHelper
write(OutputStream, PolicyError) - Static method in class org.omg.CORBA. PolicyErrorHelper
write(OutputStream, ServiceDetail) - Static method in class org.omg.CORBA. ServiceDetailHelper
write(OutputStream, ServiceInformation) - Static method in class org.omg.CORBA. ServiceInformationHelper
write(OutputStream, SetOverrideType) - Static method in class org.omg.CORBA. SetOverrideTypeHelper
write(OutputStream, StructMember) - Static method in class org.omg.CORBA. StructMemberHelper
write(OutputStream, BadKind) - Static method in class org.omg.CORBA.TypeCodePackage. BadKindHelper
write(OutputStream, Bounds) - Static method in class org.omg.CORBA.TypeCodePackage. BoundsHelper
write(OutputStream, UnionMember) - Static method in class org.omg.CORBA. UnionMemberHelper
write(OutputStream, UnknownUserException) - Static method in class org.omg.CORBA. UnknownUserExceptionHelper
write(OutputStream, ValueMember) - Static method in class org.omg.CORBA. ValueMemberHelper
write(OutputStream, WrongTransaction) - Static method in class org.omg.CORBA. WrongTransactionHelper
write(OutputStream, Binding) - Static method in class org.omg.CosNaming. BindingHelper
write(OutputStream, Binding[]) - Static method in class org.omg.CosNaming. BindingListHelper
write(OutputStream, BindingIterator) - Static method in class org.omg.CosNaming. BindingIteratorHelper
write(OutputStream, BindingType) - Static method in class org.omg.CosNaming. BindingTypeHelper
write(OutputStream, NameComponent) - Static method in class org.omg.CosNaming. NameComponentHelper
write(OutputStream, NameComponent[]) - Static method in class org.omg.CosNaming. NameHelper
write(OutputStream, NamingContext) - Static method in class org.omg.CosNaming. NamingContextHelper
write(OutputStream, NamingContextExt) - Static method in class org.omg.CosNaming. NamingContextExtHelper
write(OutputStream, InvalidAddress) - Static method in class org.omg.CosNaming.NamingContextExtPackage. InvalidAddressHelper
write(OutputStream, AlreadyBound) - Static method in class org.omg.CosNaming.NamingContextPackage. AlreadyBoundHelper
write(OutputStream, CannotProceed) - Static method in class org.omg.CosNaming.NamingContextPackage. CannotProceedHelper
write(OutputStream, InvalidName) - Static method in class org.omg.CosNaming.NamingContextPackage. InvalidNameHelper
write(OutputStream, NotEmpty) - Static method in class org.omg.CosNaming.NamingContextPackage. NotEmptyHelper
write(OutputStream, NotFound) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundHelper
write(OutputStream, NotFoundReason) - Static method in class org.omg.CosNaming.NamingContextPackage. NotFoundReasonHelper
write(OutputStream, DynAny) - Static method in class org.omg.DynamicAny. DynAnyHelper
write(OutputStream, DynAny[]) - Static method in class org.omg.DynamicAny. DynAnySeqHelper
write(OutputStream, DynAnyFactory) - Static method in class org.omg.DynamicAny. DynAnyFactoryHelper
write(OutputStream, InconsistentTypeCode) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage. InconsistentTypeCodeHelper
write(OutputStream, InvalidValue) - Static method in class org.omg.DynamicAny.DynAnyPackage. InvalidValueHelper
write(OutputStream, TypeMismatch) - Static method in class org.omg.DynamicAny.DynAnyPackage. TypeMismatchHelper
write(OutputStream, DynArray) - Static method in class org.omg.DynamicAny. DynArrayHelper
write(OutputStream, DynEnum) - Static method in class org.omg.DynamicAny. DynEnumHelper
write(OutputStream, DynFixed) - Static method in class org.omg.DynamicAny. DynFixedHelper
write(OutputStream, DynSequence) - Static method in class org.omg.DynamicAny. DynSequenceHelper
write(OutputStream, DynStruct) - Static method in class org.omg.DynamicAny. DynStructHelper
write(OutputStream, DynUnion) - Static method in class org.omg.DynamicAny. DynUnionHelper
write(OutputStream, DynValue) - Static method in class org.omg.DynamicAny. DynValueHelper
write(OutputStream, NameDynAnyPair) - Static method in class org.omg.DynamicAny. NameDynAnyPairHelper
write(OutputStream, NameDynAnyPair[]) - Static method in class org.omg.DynamicAny. NameDynAnyPairSeqHelper
write(OutputStream, NameValuePair) - Static method in class org.omg.DynamicAny. NameValuePairHelper
write(OutputStream, NameValuePair[]) - Static method in class org.omg.DynamicAny. NameValuePairSeqHelper
write(OutputStream, CodecFactory) - Static method in class org.omg.IOP. CodecFactoryHelper
write(OutputStream, UnknownEncoding) - Static method in class org.omg.IOP.CodecFactoryPackage. UnknownEncodingHelper
write(OutputStream, FormatMismatch) - Static method in class org.omg.IOP.CodecPackage. FormatMismatchHelper
write(OutputStream, InvalidTypeForEncoding) - Static method in class org.omg.IOP.CodecPackage. InvalidTypeForEncodingHelper
write(OutputStream, TypeMismatch) - Static method in class org.omg.IOP.CodecPackage. TypeMismatchHelper
write(OutputStream, IOR) - Static method in class org.omg.IOP. IORHelper
write(OutputStream, ServiceContext) - Static method in class org.omg.IOP. ServiceContextHelper
write(OutputStream, ServiceContext[]) - Static method in class org.omg.IOP. ServiceContextListHelper
write(OutputStream, TaggedComponent) - Static method in class org.omg.IOP. TaggedComponentHelper
write(OutputStream, TaggedComponent[]) - Static method in class org.omg.IOP. MultipleComponentProfileHelper
write(OutputStream, TaggedProfile) - Static method in class org.omg.IOP. TaggedProfileHelper
write(OutputStream, Current) - Static method in class org.omg.PortableInterceptor. CurrentHelper
write(OutputStream, ForwardRequest) - Static method in class org.omg.PortableInterceptor. ForwardRequestHelper
write(OutputStream, InvalidSlot) - Static method in class org.omg.PortableInterceptor. InvalidSlotHelper
write(OutputStream, IORInterceptor_3_0) - Static method in class org.omg.PortableInterceptor. IORInterceptor_3_0Helper
write(OutputStream, ObjectReferenceFactory) - Static method in class org.omg.PortableInterceptor. ObjectReferenceFactoryHelper
write(OutputStream, ObjectReferenceTemplate) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateHelper
write(OutputStream, ObjectReferenceTemplate[]) - Static method in class org.omg.PortableInterceptor. ObjectReferenceTemplateSeqHelper
write(OutputStream, DuplicateName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. DuplicateNameHelper
write(OutputStream, InvalidName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage. InvalidNameHelper
write(OutputStream, Current) - Static method in class org.omg.PortableServer. CurrentHelper
write(OutputStream, NoContext) - Static method in class org.omg.PortableServer.CurrentPackage. NoContextHelper
write(OutputStream, ForwardRequest) - Static method in class org.omg.PortableServer. ForwardRequestHelper
write(OutputStream, POA) - Static method in class org.omg.PortableServer. POAHelper
write(OutputStream, AdapterInactive) - Static method in class org.omg.PortableServer.POAManagerPackage. AdapterInactiveHelper
write(OutputStream, AdapterAlreadyExists) - Static method in class org.omg.PortableServer.POAPackage. AdapterAlreadyExistsHelper
write(OutputStream, AdapterNonExistent) - Static method in class org.omg.PortableServer.POAPackage. AdapterNonExistentHelper
write(OutputStream, InvalidPolicy) - Static method in class org.omg.PortableServer.POAPackage. InvalidPolicyHelper
write(OutputStream, NoServant) - Static method in class org.omg.PortableServer.POAPackage. NoServantHelper
write(OutputStream, ObjectAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage. ObjectAlreadyActiveHelper
write(OutputStream, ObjectNotActive) - Static method in class org.omg.PortableServer.POAPackage. ObjectNotActiveHelper
write(OutputStream, ServantAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage. ServantAlreadyActiveHelper
write(OutputStream, ServantNotActive) - Static method in class org.omg.PortableServer.POAPackage. ServantNotActiveHelper
write(OutputStream, WrongAdapter) - Static method in class org.omg.PortableServer.POAPackage. WrongAdapterHelper
write(OutputStream, WrongPolicy) - Static method in class org.omg.PortableServer.POAPackage. WrongPolicyHelper
write(OutputStream, ServantActivator) - Static method in class org.omg.PortableServer. ServantActivatorHelper
write(OutputStream, ServantLocator) - Static method in class org.omg.PortableServer. ServantLocatorHelper
write(Node, LSOutput) - Method in interface org.w3c.dom.ls. LSSerializer
按照 LSSerializer接口的一般说明中所述将指定节点序列化。
WRITE - java.lang. ProcessBuilder.Redirect.Type
从 Redirect.to(File)返回的重定向类型。
WRITE - java.nio.file. AccessMode
测试写入权限
WRITE - java.nio.file. StandardOpenOption
打开以进行写入。
write_Abstract(Object) - Method in interface org.omg.CORBA. DataOutputStream
将IDL抽象接口类型写入输出流。
write_abstract_interface(Object) - Method in class org.omg.CORBA_2_3.portable. OutputStream
汇总值对象或存根对象。
WRITE_ACL - java.nio.file.attribute. AclEntryPermission
编写ACL属性的权限。
write_any(Any) - Method in interface org.omg.CORBA. DataOutputStream
将Any值写入输出流。
write_any(Any) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入Any。
write_any_array(Any[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL Anys的数组从offset的长度元素写入输出流。
WRITE_ATTRIBUTES - java.nio.file.attribute. AclEntryPermission
写入（非acl）文件属性的能力。
write_boolean(boolean) - Method in interface org.omg.CORBA. DataOutputStream
将布尔值写入输出流。
write_boolean(boolean) - Method in class org.omg.CORBA.portable. OutputStream
向此流写入一个布尔值。
write_boolean_array(boolean[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL布尔数组从offset的长度元素写入输出流。
write_boolean_array(boolean[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一组布尔值。
write_char(char) - Method in interface org.omg.CORBA. DataOutputStream
将IDL字符值写入输出流。
write_char(char) - Method in class org.omg.CORBA.portable. OutputStream
将char值写入此流。
write_char_array(char[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL字符数组从offset的长度元素写入输出流。
write_char_array(char[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一个字符数组。
write_Context(Context, ContextList) - Method in class org.omg.CORBA.portable. OutputStream
在此流上写入CORBA上下文。
WRITE_DATA - java.nio.file.attribute. AclEntryPermission
许可修改文件的数据。
write_double(double) - Method in interface org.omg.CORBA. DataOutputStream
将IDL double值写入输出流。
write_double(double) - Method in class org.omg.CORBA.portable. OutputStream
为此流写入一个双重值。
write_double_array(double[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL双精度数组从长度元素的偏移量写入输出流。
write_double_array(double[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一组双精度数组。
WRITE_FAILURE - Static variable in class java.util.logging. ErrorManager
写输出流失败时使用WRITE_FAILURE。
write_fixed(BigDecimal) - Method in class org.omg.CORBA.portable. OutputStream
写入一个BigDecimal数字。
write_float(float) - Method in interface org.omg.CORBA. DataOutputStream
将IDL浮点值写入输出流。
write_float(float) - Method in class org.omg.CORBA.portable. OutputStream
向此流写入一个浮点值。
write_float_array(float[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL浮点数从offset的长度元素写入输出流。
write_float_array(float[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一组浮点数。
write_long(int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL long值（表示为Java int）写入输出流。
write_long(int) - Method in class org.omg.CORBA.portable. OutputStream
写一个CORBA很长（即
write_long_array(int[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL longs的数组从offset的长度元素写入输出流。
write_long_array(int[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
写一个数组的CORBA longs（即
write_longlong(long) - Method in interface org.omg.CORBA. DataOutputStream
将IDL long long值（表示为Java long）写入输出流。
write_longlong(long) - Method in class org.omg.CORBA.portable. OutputStream
写一个CORBA longlong（即
write_longlong_array(long[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL长整数的数组从length元素的偏移量写入输出流。
write_longlong_array(long[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
写入一系列的CORBA longlongs（即
WRITE_NAMED_ATTRS - java.nio.file.attribute. AclEntryPermission
写入文件的命名属性的权限。
write_Object(Object) - Method in interface org.omg.CORBA. DataOutputStream
将IDL CORBA :: Object值写入输出流。
write_Object(Object) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一个CORBA对象。
write_octet(byte) - Method in interface org.omg.CORBA. DataOutputStream
将IDL八位字节值（表示为Java字节）写入输出流。
write_octet(byte) - Method in class org.omg.CORBA.portable. OutputStream
将CORBA八位字节（即字节）值写入此流。
write_octet_array(byte[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL八位字节数组从offset的长度元素写入输出流。
write_octet_array(byte[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一组CORBA八位字节（字节）。
WRITE_OWNER - java.nio.file.attribute. AclEntryPermission
允许更改所有者。
write_Principal(Principal) - Method in class org.omg.CORBA.portable. OutputStream
已过时。
被CORBA弃用2.2。
write_short(short) - Method in interface org.omg.CORBA. DataOutputStream
将IDL的短值写入输出流。
write_short(short) - Method in class org.omg.CORBA.portable. OutputStream
为此流写入一个简短的值。
write_short_array(short[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL短片阵列从长度元素的偏移量写入输出流。
write_short_array(short[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一组短裤。
write_string(String) - Method in interface org.omg.CORBA. DataOutputStream
将IDL字符串值写入输出流。
write_string(String) - Method in class org.omg.CORBA.portable. OutputStream
将字符串值写入此流。
write_TypeCode(TypeCode) - Method in interface org.omg.CORBA. DataOutputStream
将类型代码写入输出流。
write_TypeCode(TypeCode) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一个TypeCode。
write_ulong(int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL unsigned long值（表示为Java int）写入输出流。
write_ulong(int) - Method in class org.omg.CORBA.portable. OutputStream
写一个无符号的CORBA长（即
write_ulong_array(int[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL unsigned long（以Java ints表示）的数组从offset的长度元素写入输出流。
write_ulong_array(int[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
写入一组无符号CORBA longs（即
write_ulonglong(long) - Method in interface org.omg.CORBA. DataOutputStream
将IDL unsigned long long值（表示为Java long）写入输出流。
write_ulonglong(long) - Method in class org.omg.CORBA.portable. OutputStream
写一个无符号的CORBA longlong（即
write_ulonglong_array(long[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL unsigned long longs（表示为Java longs）的数组从length元素的偏移量写入输出流。
write_ulonglong_array(long[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
写一个无符号CORBA longlongs（即
write_ushort(short) - Method in interface org.omg.CORBA. DataOutputStream
将IDL无符号短值（表示为Java短值）写入输出流。
write_ushort(short) - Method in class org.omg.CORBA.portable. OutputStream
将无符号短值写入此流。
write_ushort_array(short[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL无符号短整型数组（表示为Java shorts）从长度元素的偏移量写入输出流。
write_ushort_array(short[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一组无符号短语。
write_value(Serializable) - Method in class org.omg.CORBA_2_3.portable. OutputStream
为输出流调度值类型。
write_value(Serializable, Class) - Method in class org.omg.CORBA_2_3.portable. OutputStream
为输出流调度值类型。
write_value(Serializable, String) - Method in class org.omg.CORBA_2_3.portable. OutputStream
为输出流调度值类型。
write_value(Serializable, BoxedValueHelper) - Method in class org.omg.CORBA_2_3.portable. OutputStream
为输出流调度值类型。
write_value(OutputStream) - Method in class org.omg.CORBA. Any
将此 Any对象的值写入给定的输出流。
write_value(OutputStream, Serializable) - Method in interface org.omg.CORBA.portable. BoxedValueHelper
write_value(OutputStream, Serializable) - Method in class org.omg.CORBA. StringValueHelper
write_value(OutputStream, Serializable) - Method in class org.omg.CORBA. WStringValueHelper
write_Value(Serializable) - Method in interface org.omg.CORBA. DataOutputStream
将IDL值类型值写入输出流。
write_wchar(char) - Method in interface org.omg.CORBA. DataOutputStream
将IDL宽字符值写入输出流。
write_wchar(char) - Method in class org.omg.CORBA.portable. OutputStream
向此流写入宽字符值。
write_wchar_array(char[], int, int) - Method in interface org.omg.CORBA. DataOutputStream
将IDL宽字符数组从偏移量的长度元素写入输出流。
write_wchar_array(char[], int, int) - Method in class org.omg.CORBA.portable. OutputStream
在此输出流上写入一个宽字符数组。
write_wstring(String) - Method in interface org.omg.CORBA. DataOutputStream
将IDL宽字符串值（表示为Java字符串）写入输出流。
write_wstring(String) - Method in class org.omg.CORBA.portable. OutputStream
为此流写入一个宽字符串值。
WRITE_XML_DECLARATION - Static variable in class javax.xml.soap. SOAPMessage
指定SOAP消息发送时是否包含XML声明。
writeAborted(ImageWriter) - Method in interface javax.imageio.event. IIOWriteProgressListener
报告写入已经通过作者的 abort方法中止。
WriteAbortedException - Exception in java.io
指示在写入操作期间抛出ObjectStreamExceptions之一。
WriteAbortedException(String, Exception) - Constructor for exception java.io. WriteAbortedException
构造一个WriteAbortedException，其中包含一个描述异常的字符串，异常导致中止。
writeAbstractObject(OutputStream, Object) - Static method in class javax.rmi.CORBA. Util
将java.lang.Object写入值或CORBA对象。
writeAbstractObject(OutputStream, Object) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 。
writeAny(OutputStream, Object) - Static method in class javax.rmi.CORBA. Util
将任何java.lang.Object写为任何CORBA。
writeAny(OutputStream, Object) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 。
writeArray(Array) - Method in interface java.sql. SQLOutput
将SQL ARRAY值写入流。
writeArray(Array) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 Array对象写入此 SQLOutputImpl对象。
writeAsciiStream(InputStream) - Method in interface java.sql. SQLOutput
将下一个属性作为ASCII字符串写入流。
writeAsciiStream(InputStream) - Method in class javax.sql.rowset.serial. SQLOutputImpl
向这个 SQLOutputImpl对象写入一串ASCII字符。
writeAsEncodedUnicode(Writer) - Method in interface javax.xml.stream.events. XMLEvent
该方法将按照XML 1.0规范将XMLEvent写为Unicode字符。
writeAttribute(String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将不带前缀的属性写入输出流。
writeAttribute(String, String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将一个属性写入输出流
writeAttribute(String, String, String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将一个属性写入输出流
writeAttributes(ObjectOutputStream, AttributeSet) - Method in class javax.swing.text. StyleContext
编写属性的上下文特定处理
writeAttributes(AttributeSet) - Method in class javax.swing.text. AbstractWriter
将属性集写入“<name> = <value>”对。
writeAttributes(AttributeSet) - Method in class javax.swing.text.html. HTMLWriter
写出属性集。
writeAttributes(AttributeSet) - Method in class javax.swing.text.html. MinimalHTMLWriter
写出以下类型的所有属性：StyleConstants.ParagraphConstants，StyleConstants.CharacterConstants，StyleConstants.FontConstants，StyleConstants.ColorConstants。
writeAttributeSet(ObjectOutputStream, AttributeSet) - Static method in class javax.swing.text. StyleContext
将一组属性写入给定的对象流以进行序列化。
writeBigDecimal(BigDecimal) - Method in interface java.sql. SQLOutput
将下一个属性作为java.math.BigDecimal对象写入流。
writeBigDecimal(BigDecimal) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 java.math.BigDecimal对象写入此 SQLOutputImpl对象。
writeBinary(DataOutputStream) - Method in class javafx.css. StyleConverter.StringStore
writeBinary(DataOutputStream, StyleConverter.StringStore) - Method in class javafx.css. CompoundSelector
writeBinary(DataOutputStream, StyleConverter.StringStore) - Method in class javafx.css.converter. EnumConverter
writeBinary(DataOutputStream, StyleConverter.StringStore) - Method in class javafx.css. Selector
writeBinary(DataOutputStream, StyleConverter.StringStore) - Method in class javafx.css. SimpleSelector
writeBinary(DataOutputStream, StyleConverter.StringStore) - Method in class javafx.css. StyleConverter
写二进制数据。
writeBinaryStream(InputStream) - Method in interface java.sql. SQLOutput
将下一个属性写入流作为未解释字节流。
writeBinaryStream(InputStream) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将一串未解释的字节写入此 SQLOutputImpl对象。
writeBit(int) - Method in interface javax.imageio.stream. ImageOutputStream
将由参数的最低有效位给出的单个位写入当前字节位置中当前位偏移量的流。
writeBit(int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeBits(long, int) - Method in interface javax.imageio.stream. ImageOutputStream
将 numBits的 bits参数的最低有效位（ bits的顺序）给出的位序列写入当前字节位置当前位偏移量的流。
writeBits(long, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeBlob(Blob) - Method in interface java.sql. SQLOutput
写入一个SQL BLOB值到流。
writeBlob(Blob) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 Blob对象写入此 SQLOutputImpl对象。
writeBody() - Method in class javax.swing.text.html. MinimalHTMLWriter
迭代文档中的元素，并基于它们是分支元素还是叶元素来处理元素。
writeBoolean(boolean) - Method in interface java.io. DataOutput
向此输出流写入一个 boolean值。
writeBoolean(boolean) - Method in class java.io. DataOutputStream
将底层输出流写入 boolean作为1字节值。
writeBoolean(boolean) - Method in class java.io. ObjectOutputStream
写一个布尔值。
writeBoolean(boolean) - Method in class java.io. RandomAccessFile
将 boolean写入文件作为一个字节值。
writeBoolean(boolean) - Method in interface java.sql. SQLOutput
将下一个属性作为Java布尔值写入流。
writeBoolean(boolean) - Method in interface javax.imageio.stream. ImageOutputStream
向流中写入一个 boolean值。
writeBoolean(boolean) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeBoolean(boolean) - Method in interface javax.jnlp. JNLPRandomAccessFile
将 boolean写入文件作为一个字节值。
writeBoolean(boolean) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 boolean写入此 SQLOutputImpl对象。
writeByte(byte) - Method in interface java.sql. SQLOutput
将下一个属性作为Java字节写入流。
writeByte(byte) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 byte写入此 SQLOutputImpl对象。
writeByte(int) - Method in interface java.io. DataOutput
向输出流写入参数 v的八个低位位。
writeByte(int) - Method in class java.io. DataOutputStream
将底层输出流中的 byte写入1字节值。
writeByte(int) - Method in class java.io. ObjectOutputStream
写入一个8位字节。
writeByte(int) - Method in class java.io. RandomAccessFile
将 byte写入文件作为一个字节值。
writeByte(int) - Method in interface javax.imageio.stream. ImageOutputStream
将 v的8位低位写入流。
writeByte(int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeByte(int) - Method in interface javax.jnlp. JNLPRandomAccessFile
以文件形式写入 byte作为单字节值。
writeBytes(byte[]) - Method in interface java.sql. SQLOutput
将下一个属性写入流作为字节数组。
writeBytes(byte[]) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将 bytes的Java编程语言的数组写入此 SQLOutputImpl对象。
writeBytes(String) - Method in interface java.io. DataOutput
将一个字符串写入输出流。
writeBytes(String) - Method in class java.io. DataOutputStream
将字符串作为字节序列写入基础输出流。
writeBytes(String) - Method in class java.io. ObjectOutputStream
写一个字符串作为字节序列。
writeBytes(String) - Method in class java.io. RandomAccessFile
将字符串作为字节序列写入文件。
writeBytes(String) - Method in interface javax.imageio.stream. ImageOutputStream
将一个字符串写入输出流。
writeBytes(String) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeBytes(String) - Method in interface javax.jnlp. JNLPRandomAccessFile
将字符串作为字节序列写入文件。
writeCData(String) - Method in interface javax.xml.stream. XMLStreamWriter
写一个CData部分
writeChar(int) - Method in interface java.io. DataOutput
向输出流写入一个由两个字节组成的 char值。
writeChar(int) - Method in class java.io. DataOutputStream
将底层输出流写入 char作为2字节值，高字节优先。
writeChar(int) - Method in class java.io. ObjectOutputStream
写一个16位的字符。
writeChar(int) - Method in class java.io. RandomAccessFile
写入一个 char作为一个双字节的值，高字节的第一个文件。
writeChar(int) - Method in interface javax.imageio.stream. ImageOutputStream
该方法是 writeShort的同义词。
writeChar(int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeChar(int) - Method in interface javax.jnlp. JNLPRandomAccessFile
写入一个 char作为一个两个字节的值，高字节的第一个文件。
writeCharacters(char[], int, int) - Method in interface javax.xml.stream. XMLStreamWriter
将文本写入输出
writeCharacters(String) - Method in interface javax.xml.stream. XMLStreamWriter
将文本写入输出
writeCharacterStream(Reader) - Method in interface java.sql. SQLOutput
将下一个属性作为Unicode字符流写入流。
writeCharacterStream(Reader) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Unicode字符串写入此 SQLOutputImpl对象。
writeChars(char[], int, int) - Method in interface javax.imageio.stream. ImageOutputStream
在当前位置将一串字符写入流。
writeChars(char[], int, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeChars(String) - Method in interface java.io. DataOutput
将字符串 s中的每个字符写入输出流，按字符顺序排列两个字节。
writeChars(String) - Method in class java.io. DataOutputStream
将字符串写入底层输出流作为一系列字符。
writeChars(String) - Method in class java.io. ObjectOutputStream
写一个字符串作为一系列的字符。
writeChars(String) - Method in class java.io. RandomAccessFile
将一个字符串作为字符序列写入文件。
writeChars(String) - Method in interface javax.imageio.stream. ImageOutputStream
将一个字符串写入输出流。
writeChars(String) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeChars(String) - Method in interface javax.jnlp. JNLPRandomAccessFile
将一个字符串作为字符序列写入文件。
writeChildren(ObjectOutputStream) - Method in class java.beans.beancontext. BeanContextSupport
用于序列化这个 BeanContext所有孩子。
writeClassDescriptor(ObjectStreamClass) - Method in class java.io. ObjectOutputStream
将指定的类描述符写入ObjectOutputStream。
writeClob(Clob) - Method in interface java.sql. SQLOutput
写入一个SQL CLOB值到流。
writeClob(Clob) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 Clob对象写入此 SQLOutputImpl对象。
writeComment(String) - Method in interface javax.xml.stream. XMLStreamWriter
用附带的数据写入一个xml注释
writeComponent(Element) - Method in class javax.swing.text.html. MinimalHTMLWriter
负责处理元件; 故意未实施。
writeContent(Element, boolean) - Method in class javax.swing.text.html. MinimalHTMLWriter
以符合HTML的方式写入属性集。
writeData(RowSetInternal) - Method in interface javax.sql. RowSetWriter
将此 RowSetWriter对象的行 RowSetWriter的更改写入数据源，从中获取其数据。
writeDate(Date) - Method in interface java.sql. SQLOutput
将下一个属性作为java.sql.Date对象写入流。
writeDate(Date) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 java.sql.Date对象写入此 SQLOutputImpl对象。
writeDefaultNamespace(String) - Method in interface javax.xml.stream. XMLStreamWriter
将默认命名空间写入流
writeDouble(double) - Method in interface java.io. DataOutput
向输出流写入一个由8个字节组成的 double值。
writeDouble(double) - Method in class java.io. DataOutputStream
使用 long中的 doubleToLongBits方法将双参数转换为 Double ，然后 long值作为8字节数量，高字节优先写入底层输出流。
writeDouble(double) - Method in class java.io. ObjectOutputStream
写一个64位的双倍。
writeDouble(double) - Method in class java.io. RandomAccessFile
使用 long中的 doubleToLongBits方法将双参数转换为 Double ，然后 long值作为八字节数量，高字节优先写入文件。
writeDouble(double) - Method in interface java.sql. SQLOutput
将下一个属性作为Java double写入流。
writeDouble(double) - Method in interface javax.imageio.stream. ImageOutputStream
向输出流写入由四个字节组成的 double值。
writeDouble(double) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeDouble(double) - Method in interface javax.jnlp. JNLPRandomAccessFile
双参数传递给转换 long使用 doubleToLongBits方法在类 Double ，然后写入该 long值到该文件作为一个八字节的数量，高字节。
writeDouble(double) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 double写入此 SQLOutputImpl对象。
writeDoubles(double[], int, int) - Method in interface javax.imageio.stream. ImageOutputStream
将当前位置的一系列双精度写入流。
writeDoubles(double[], int, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeDTD(String) - Method in interface javax.xml.stream. XMLStreamWriter
写一个DTD部分。
writeEmbeddedTags(AttributeSet) - Method in class javax.swing.text.html. HTMLWriter
在AttributeSet中搜索嵌入式标签并将其写入。
writeEmptyElement(String) - Method in interface javax.xml.stream. XMLStreamWriter
将一个空的元素标签写入输出
writeEmptyElement(String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将一个空的元素标签写入输出
writeEmptyElement(String, String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将一个空的元素标签写入输出
writeEndDocument() - Method in interface javax.xml.stream. XMLStreamWriter
关闭任何起始标记并写入相应的结束标签。
writeEndElement() - Method in interface javax.xml.stream. XMLStreamWriter
根据写入器的内部状态将结束标记写入输出，以确定事件的前缀和本地名称。
writeEndParagraph() - Method in class javax.swing.text.html. MinimalHTMLWriter
发出<p>标签的结束标记。
writeEndTag(String) - Method in class javax.swing.text.html. MinimalHTMLWriter
写出一个适合缩进的结束标签。
writeEntityRef(String) - Method in interface javax.xml.stream. XMLStreamWriter
写实体引用
writeExpression(Expression) - Method in class java.beans. Encoder
该实现首先检查是否已经写入了具有该值的表达式。
writeExpression(Expression) - Method in class java.beans. XMLEncoder
记录表达式，以便当流被刷新时，编码器将产生实际的输出。
writeExternal(ObjectOutput) - Method in class java.awt.datatransfer. DataFlavor
序列化这个 DataFlavor 。
writeExternal(ObjectOutput) - Method in interface java.io. Externalizable
该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput的对象，字符串和数组的writeObject方法来保存其内容。
writeExternal(ObjectOutput) - Method in class javax.activation. MimeType
该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput对象，字符串和数组的writeObject方法来保存其内容。
writeExternal(ObjectOutput) - Method in class javax.management.loading. MLet
将此MLet的内容保存到给定的ObjectOutput 。
writeFields() - Method in class java.io. ObjectOutputStream
将缓冲的字段写入流。
writeFloat(float) - Method in interface java.io. DataOutput
向输出流写入由四个字节组成的 float值。
writeFloat(float) - Method in class java.io. DataOutputStream
使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后将 int值写入底层输出流作为4字节数量，高字节优先。
writeFloat(float) - Method in class java.io. ObjectOutputStream
写一个32位浮点数。
writeFloat(float) - Method in class java.io. RandomAccessFile
使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后 int值作为四字节数量（高字节优先）写入文件。
writeFloat(float) - Method in interface java.sql. SQLOutput
将下一个属性作为Java float写入流。
writeFloat(float) - Method in interface javax.imageio.stream. ImageOutputStream
向输出流写入由四个字节组成的 float值。
writeFloat(float) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeFloat(float) - Method in interface javax.jnlp. JNLPRandomAccessFile
使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后 int值作为四字节数量，高字节优先写入文件。
writeFloat(float) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 float写入此 SQLOutputImpl对象。
writeFloats(float[], int, int) - Method in interface javax.imageio.stream. ImageOutputStream
在当前位置将一系列浮点写入流。
writeFloats(float[], int, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeHeader() - Method in class javax.swing.text.html. MinimalHTMLWriter
写出<head>和<style>标签，然后调用writeStyles（）将所有命名样式写成<style>标签的内容。
writeHTMLTags(AttributeSet) - Method in class javax.swing.text.html. MinimalHTMLWriter
根据其属性设置为文本生成粗体<b>，斜体<i>和<u>标签。
writeImage(Element) - Method in class javax.swing.text.html. MinimalHTMLWriter
负责处理图标元素; 故意未实施。
writeInsert(int, IIOImage, ImageWriteParam) - Method in class javax.imageio. ImageWriter
将新图像插入到现有图像流中。
writeInt(int) - Method in interface java.io. DataOutput
向输出流写入由四个字节组成的 int值。
writeInt(int) - Method in class java.io. DataOutputStream
将底层输出流写入一个 int作为四字节，高位字节。
writeInt(int) - Method in class java.io. ObjectOutputStream
写一个32位int。
writeInt(int) - Method in class java.io. RandomAccessFile
向文件写入一个 int作为四个字节，高位字节。
writeInt(int) - Method in interface java.sql. SQLOutput
将下一个属性作为Java int写入流。
writeInt(int) - Method in interface javax.imageio.stream. ImageOutputStream
将 v的32位写入流。
writeInt(int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeInt(int) - Method in interface javax.jnlp. JNLPRandomAccessFile
向文件写入一个 int作为四个字节，高字节优先。
writeInt(int) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 int写入此 SQLOutputImpl对象。
writeInts(int[], int, int) - Method in interface javax.imageio.stream. ImageOutputStream
在当前位置写入流的序列。
writeInts(int[], int, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeLeaf(Element) - Method in class javax.swing.text.html. MinimalHTMLWriter
负责写出其他非文本元素。
writeLineSeparator() - Method in class javax.swing.text. AbstractWriter
写行分隔符。
writeLineSeparator() - Method in class javax.swing.text.html. HTMLWriter
写行分隔符。
writeln(String) - Method in interface org.w3c.dom.html. HTMLDocument
在 open()打开的文件流中写入一串文本，后跟换行符。
writeLock() - Method in interface java.util.concurrent.locks. ReadWriteLock
返回用于写入的锁。
writeLock() - Method in class java.util.concurrent.locks. ReentrantReadWriteLock
writeLock() - Method in class java.util.concurrent.locks. StampedLock
专门获取锁定，如有必要，阻塞。
writeLock() - Method in class javax.swing.text. AbstractDocument
获取一个锁，开始变更此锁保护的文档。
WriteLock(ReentrantReadWriteLock) - Constructor for class java.util.concurrent.locks. ReentrantReadWriteLock.WriteLock
子类使用的构造方法。
writeLockInterruptibly() - Method in class java.util.concurrent.locks. StampedLock
专门获取锁定，如有必要，阻塞，直到可用或当前线程中断。
writeLong(long) - Method in interface java.io. DataOutput
向输出流写入一个由8个字节组成的 long值。
writeLong(long) - Method in class java.io. DataOutputStream
将底层输出流写入一个 long作为八字节，高字节优先。
writeLong(long) - Method in class java.io. ObjectOutputStream
写一个64位长
writeLong(long) - Method in class java.io. RandomAccessFile
向文件写入一个 long作为八字节，高字节优先。
writeLong(long) - Method in interface java.sql. SQLOutput
将下一个属性作为Java写入流。
writeLong(long) - Method in interface javax.imageio.stream. ImageOutputStream
将 v的64位写入流。
writeLong(long) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeLong(long) - Method in interface javax.jnlp. JNLPRandomAccessFile
向文件写入一个 long作为八字节，高位字节。
writeLong(long) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 long写入此 SQLOutputImpl对象。
writeLongs(long[], int, int) - Method in interface javax.imageio.stream. ImageOutputStream
在当前位置写入流的序列。
writeLongs(long[], int, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeNamespace(String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将命名空间写入输出流如果此方法的前缀参数为空字符串“xmlns”，或为null，则此方法将委托为writeDefaultNamespace
writeNClob(NClob) - Method in interface java.sql. SQLOutput
写入一个SQL NCLOB值到流。
writeNClob(NClob) - Method in class javax.sql.rowset.serial. SQLOutputImpl
写入一个SQL NCLOB值到流。
writeNonHTMLAttributes(AttributeSet) - Method in class javax.swing.text.html. MinimalHTMLWriter
以符合HTML的方式写出剩余的字符级属性（粗体，斜体和下划线之外的属性）。
writeNString(String) - Method in interface java.sql. SQLOutput
将下一个属性作为Java编程语言中的 String写入流。
writeNString(String) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将下一个属性作为Java编程语言中的 String写入流。
writeObject(Object) - Method in class java.beans. Encoder
将指定的对象写入输出流。
writeObject(Object) - Method in class java.beans. XMLEncoder
将指定对象的XML表示形式写入输出。
writeObject(Object) - Method in interface java.io. ObjectOutput
将对象写入底层存储或流。
writeObject(Object) - Method in class java.io. ObjectOutputStream
将指定的对象写入ObjectOutputStream。
writeObject(Object, Encoder) - Method in class java.beans. PersistenceDelegate
writeObject是持久性的单个入口点，由传统的授权模式中的 Encoder使用。
writeObject(Object, SQLType) - Method in interface java.sql. SQLOutput
将包含在给定对象中的数据写入流。
writeObject(SQLData) - Method in interface java.sql. SQLOutput
向流中写入包含在给定的 SQLData对象中的数据。
writeObject(SQLData) - Method in class javax.sql.rowset.serial. SQLOutputImpl
向流中写入包含在给定的 SQLData对象中的数据。
writeObject(Stub, ObjectOutputStream) - Method in interface javax.rmi.CORBA. StubDelegate
代表团要求 Stub.writeObject(java.io.ObjectOutputStream) 。
writeObjectOverride(Object) - Method in class java.io. ObjectOutputStream
子类使用的方法来覆盖默认的writeObject方法。
writeOption(Option) - Method in class javax.swing.text.html. HTMLWriter
写出选项表单元素的内容。
writePacket(byte[]) - Method in class com.sun.jdi.connect.spi. Connection
将数据包写入目标虚拟机。
WritePendingException - Exception in java.nio.channels
尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。
WritePendingException() - Constructor for exception java.nio.channels. WritePendingException
构造这个类的一个实例。
writeProcessingInstruction(String) - Method in interface javax.xml.stream. XMLStreamWriter
写一个处理指令
writeProcessingInstruction(String, String) - Method in interface javax.xml.stream. XMLStreamWriter
写一个处理指令
writer - Variable in class javax.script. SimpleScriptContext
这是用于从脚本输出的作者。
writer() - Method in class java.io. Console
检索与此控制台关联的唯一的PrintWriter对象。
Writer - Class in java.io
用于写入字符流的抽象类。
Writer() - Constructor for class java.io. Writer
创建一个新的人物流作家，其关键部分将在作者本身上同步。
Writer(Object) - Constructor for class java.io. Writer
创建一个新的字符流写入器，其关键部分将在给定对象上进行同步。
writeRef(Ref) - Method in interface java.sql. SQLOutput
写入一个SQL REF值到流。
writeRef(Ref) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 Ref对象写入此 SQLOutputImpl对象。
writeRemoteObject(OutputStream, Object) - Static method in class javax.rmi.CORBA. Util
将java.lang.Object写入CORBA对象。
writeRemoteObject(OutputStream, Object) - Method in interface javax.rmi.CORBA. UtilDelegate
代表团要求 Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 。
writeReplace() - Method in class java.security.cert. Certificate
更换要序列化的证书。
writeReplace() - Method in class java.security.cert. CertPath
替换 CertPath以使用 CertPathRep对象进行序列化。
writeReplace(Serializable) - Method in interface javax.rmi.CORBA. ValueHandler
如果值包含一个 writeReplace方法，则返回结果。
writeRowId(RowId) - Method in interface java.sql. SQLOutput
向流写入一个SQL ROWID值。
writeRowId(RowId) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将SQL ROWID值写入流。
writerSpiNames - Variable in class javax.imageio.spi. ImageReaderSpi
要从 getImageWriterSpiNames返回的字符串数组，最初为 null 。
writeShort(int) - Method in interface java.io. DataOutput
将两个字节写入输出流以表示参数的值。
writeShort(int) - Method in class java.io. DataOutputStream
将底层输出流写入 short作为两个字节，高位字节。
writeShort(int) - Method in class java.io. ObjectOutputStream
写一个16位短。
writeShort(int) - Method in class java.io. RandomAccessFile
写入一个 short文件作为两个字节，高字节优先。
writeShort(int) - Method in interface javax.imageio.stream. ImageOutputStream
写入流的16位低位位 v 。
writeShort(int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeShort(int) - Method in interface javax.jnlp. JNLPRandomAccessFile
将 short写入文件作为两个字节，高位字节。
writeShort(short) - Method in interface java.sql. SQLOutput
将下一个属性写入流作为Java短。
writeShort(short) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 short写入此 SQLOutputImpl对象。
writeShorts(short[], int, int) - Method in interface javax.imageio.stream. ImageOutputStream
在当前位置写入流的序列。
writeShorts(short[], int, int) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeSQL(SQLOutput) - Method in interface java.sql. SQLData
将此对象写入给定的SQL数据流，将其转换回数据源中的SQL值。
writeSQLXML(SQLXML) - Method in interface java.sql. SQLOutput
写入一个SQL XML值到流。
writeSQLXML(SQLXML) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将SQL XML值写入流。
writeStartDocument() - Method in interface javax.xml.stream. XMLStreamWriter
编写XML声明
writeStartDocument(String) - Method in interface javax.xml.stream. XMLStreamWriter
编写XML声明
writeStartDocument(String, String) - Method in interface javax.xml.stream. XMLStreamWriter
编写XML声明
writeStartElement(String) - Method in interface javax.xml.stream. XMLStreamWriter
将开始标签写入输出。
writeStartElement(String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将开始标签写入输出
writeStartElement(String, String, String) - Method in interface javax.xml.stream. XMLStreamWriter
将开始标签写入输出
writeStartParagraph(Element) - Method in class javax.swing.text.html. MinimalHTMLWriter
发出段落的起始标记。
writeStartTag(String) - Method in class javax.swing.text.html. MinimalHTMLWriter
写出一个适当缩进的开始标签。
writeStatement(Statement) - Method in class java.beans. Encoder
向流写入语句 oldStm 。
writeStatement(Statement) - Method in class java.beans. XMLEncoder
记录声明，以便编码器将在流被冲洗时产生实际的输出。
writeStreamHeader() - Method in class java.io. ObjectOutputStream
提供了writeStreamHeader方法，因此子类可以在流中附加或预先添加自己的头。
writeString(String) - Method in interface java.sql. SQLOutput
将下一个属性作为Java编程语言中的 String写入流。
writeString(String) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的 String写入此 SQLOutputImpl对象。
writeStruct(Struct) - Method in interface java.sql. SQLOutput
将SQL结构化类型值写入流。
writeStruct(Struct) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 Struct对象写入此 SQLOutputImpl对象。
writeStyles() - Method in class javax.swing.text.html. MinimalHTMLWriter
将所有命名的样式写成<style>标签的内容。
writeTime(Time) - Method in interface java.sql. SQLOutput
将下一个属性作为java.sql.Time对象写入流。
writeTime(Time) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 java.sql.Time对象写入此 SQLOutputImpl对象。
writeTimestamp(Timestamp) - Method in interface java.sql. SQLOutput
将下一个属性作为java.sql.Timestamp对象写入流。
writeTimestamp(Timestamp) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 java.sql.Timestamp对象写入此 SQLOutputImpl对象。
writeTo(OutputStream) - Method in class java.io. ByteArrayOutputStream
将此字节数组输出流的完整内容写入指定的输出流参数，就像使用 out.write(buf, 0, count)调用输出流的写入方法 out.write(buf, 0, count) 。
writeTo(OutputStream) - Method in class javax.activation. DataHandler
将数据写入 OutputStream 。
writeTo(OutputStream) - Method in class javax.xml.soap. SOAPMessage
将此 SOAPMessage对象写入给定的输出流。
writeTo(Writer) - Method in class java.io. CharArrayWriter
将缓冲区的内容写入另一个字符流。
writeTo(Object, String, OutputStream) - Method in interface javax.activation. DataContentHandler
将对象转换为指定MIME类型的字节流，并将其写入输出流。
writeTo(Result) - Method in class javax.xml.ws. EndpointReference
将此 EndpointReference写入指定的信息集格式
writeTo(Result) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReference
将此 EndpointReference写入指定的信息集格式
writeToSequence(IIOImage, ImageWriteParam) - Method in class javax.imageio. ImageWriter
将单个图像和可能关联的元数据和缩略图附加到输出。
writeToString(Node) - Method in interface org.w3c.dom.ls. LSSerializer
按照 LSSerializer接口的一般说明将上述指定的节点序列化。
writeToURI(Node, String) - Method in interface org.w3c.dom.ls. LSSerializer
充当如果一种简便方法 LSSerializer.write被称为具有 LSOutput没有编码指定和 LSOutput.systemId集到 uri参数。
writeUnlock() - Method in class javax.swing.text. AbstractDocument
释放之前通过 writeLock获得的写锁定。
writeUnshared(Object) - Method in class java.io. ObjectOutputStream
将“非共享”对象写入ObjectOutputStream。
writeURL(URL) - Method in interface java.sql. SQLOutput
将SQL DATALINK值写入流。
writeURL(URL) - Method in class javax.sql.rowset.serial. SQLOutputImpl
将Java编程语言中的一个 java.sql.Type.DATALINK对象写入此 SQLOutputImpl对象。
writeUTF(String) - Method in interface java.io. DataOutput
将两个字节的长度信息写入输出流，后跟字符串 s中每个字符的 modified UTF-8表示。
writeUTF(String) - Method in class java.io. DataOutputStream
使用机器无关的方式使用 modified UTF-8编码将字符串写入基础输出流。
writeUTF(String) - Method in class java.io. ObjectOutputStream
此字符串的原始数据写入格式为 modified UTF-8 。
writeUTF(String) - Method in class java.io. RandomAccessFile
使用机器无关的方式使用 modified UTF-8编码将字符串写入文件。
writeUTF(String) - Method in interface javax.imageio.stream. ImageOutputStream
以网络字节顺序将两个字节的长度信息写入输出流，后跟字符串 s中每个字符的 modified UTF-8表示。
writeUTF(String) - Method in class javax.imageio.stream. ImageOutputStreamImpl
writeUTF(String) - Method in interface javax.jnlp. JNLPRandomAccessFile
使用UTF-8编码以机器无关方式将字符串写入文件。
writeValue(OutputStream, Serializable) - Method in interface javax.rmi.CORBA. ValueHandler
使用Java语义将值写入流。
writeValue(OutputStream, Serializable, byte) - Method in interface javax.rmi.CORBA. ValueHandlerMultiFormat
允许ORB传递RMI / IDL自定义值类型的流格式版本。
writeXml(OutputStream) - Method in interface javax.sql.rowset. WebRowSet
将此 WebRowSet对象的数据，属性和元数据以XML格式写入给定的 OutputStream对象。
writeXml(Writer) - Method in interface javax.sql.rowset. WebRowSet
将此 WebRowSet对象的数据，属性和元数据以XML格式写入给定的 Writer对象。
writeXml(ResultSet, OutputStream) - Method in interface javax.sql.rowset. WebRowSet
使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 OutputStream对象。
writeXml(ResultSet, Writer) - Method in interface javax.sql.rowset. WebRowSet
使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 Writer对象。
writeXML(WebRowSet, Writer) - Method in interface javax.sql.rowset.spi. XmlWriter
将给定的 WebRowSet对象写入指定的 java.io.Writer输出流作为XML文档。
written - Variable in class java.io. DataOutputStream
到目前为止写入数据输出流的字节数。
WRONG_DOCUMENT_ERR - Static variable in exception org.w3c.dom. DOMException
如果一个 Node在不同于其创建它的文档（不支持它）中使用。
WrongAdapter - Exception in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / WrongAdapter.java。
WrongAdapter() - Constructor for exception org.omg.PortableServer.POAPackage. WrongAdapter
WrongAdapter(String) - Constructor for exception org.omg.PortableServer.POAPackage. WrongAdapter
WrongAdapterHelper - Class in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / WrongAdapterHelper.java。
WrongAdapterHelper() - Constructor for class org.omg.PortableServer.POAPackage. WrongAdapterHelper
WrongMethodTypeException - Exception in java.lang.invoke
抛出以表示代码尝试通过错误的方法类型调用方法句柄。
WrongMethodTypeException() - Constructor for exception java.lang.invoke. WrongMethodTypeException
构造一个没有详细消息的 WrongMethodTypeException 。
WrongMethodTypeException(String) - Constructor for exception java.lang.invoke. WrongMethodTypeException
构造具有指定详细消息的 WrongMethodTypeException 。
WrongPolicy - Exception in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / WrongPolicy.java。
WrongPolicy() - Constructor for exception org.omg.PortableServer.POAPackage. WrongPolicy
WrongPolicy(String) - Constructor for exception org.omg.PortableServer.POAPackage. WrongPolicy
WrongPolicyHelper - Class in org.omg.PortableServer.POAPackage
org / omg / PortableServer / POAPackage / WrongPolicyHelper.java。
WrongPolicyHelper() - Constructor for class org.omg.PortableServer.POAPackage. WrongPolicyHelper
WrongTransaction - Exception in org.omg.CORBA
CORBA WrongTransaction用户定义的异常。
WrongTransaction() - Constructor for exception org.omg.CORBA. WrongTransaction
构造具有空详细消息的WrongTransaction对象。
WrongTransaction(String) - Constructor for exception org.omg.CORBA. WrongTransaction
构造具有给定详细消息的WrongTransaction对象。
WrongTransactionHelper - Class in org.omg.CORBA
助手 WrongTransaction 。
WrongTransactionHelper() - Constructor for class org.omg.CORBA. WrongTransactionHelper
WrongTransactionHolder - Class in org.omg.CORBA
持有人 WrongTransaction 。
WrongTransactionHolder() - Constructor for class org.omg.CORBA. WrongTransactionHolder
WrongTransactionHolder(WrongTransaction) - Constructor for class org.omg.CORBA. WrongTransactionHolder
WSDL_DESCRIPTION - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：WSDL文档的输入源。
WSDL_INTERFACE - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：wsdl接口（2.0）或端口类型（1.1）的名称。
WSDL_OPERATION - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：WSDL操作的名称。
WSDL_PORT - Static variable in class javax.xml.ws. Endpoint
标准属性：WSDL端口的名称。
WSDL_PORT - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：WSDL端口的名称。
WSDL_SERVICE - Static variable in class javax.xml.ws. Endpoint
标准属性：WSDL服务的名称。
WSDL_SERVICE - Static variable in interface javax.xml.ws.handler. MessageContext
标准属性：WSDL服务的名称。
wsdlDocumentLocation(String) - Method in class javax.xml.ws.wsaddressing. W3CEndpointReferenceBuilder
设置 wsdlDocumentLocation ，将作为被引用 wsa:Metadata/@wsdli:wsdlLocation 。
WStringSeqHelper - Class in org.omg.CORBA
一系列WStrings
WStringSeqHelper() - Constructor for class org.omg.CORBA. WStringSeqHelper
WStringSeqHolder - Class in org.omg.CORBA
一系列WStrings
WStringSeqHolder() - Constructor for class org.omg.CORBA. WStringSeqHolder
WStringSeqHolder(String[]) - Constructor for class org.omg.CORBA. WStringSeqHolder
WStringValueHelper - Class in org.omg.CORBA
org / omg / CORBA / WStringValueHelper.java由IDL到Java编译器（便携式）生成，从orb.idl版本“3.0”1999年5月31日22:27:30 GMT + 00：00类定义被修改，以符合以下OMG规范：ORB芯由CORBA 2.3.1所定义（ formal/99-10-07 ）IDL / Java语言映射中定义 ptc/00-01-08
WStringValueHelper() - Constructor for class org.omg.CORBA. WStringValueHelper
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


X-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

X

x - Variable in class java.awt. Event
已过时。
事件的 x坐标。
x - Variable in class java.awt.geom. Arc2D.Double
圆弧框架矩形左上角的X坐标。
x - Variable in class java.awt.geom. Arc2D.Float
圆弧框架矩形左上角的X坐标。
x - Variable in class java.awt.geom. Ellipse2D.Double
此 Ellipse2D框架矩形左上角的X坐标。
x - Variable in class java.awt.geom. Ellipse2D.Float
这个 Ellipse2D框架矩形左上角的X坐标。
x - Variable in class java.awt.geom. Point2D.Double
这个X坐标 Point2D 。
x - Variable in class java.awt.geom. Point2D.Float
这个X坐标 Point2D 。
x - Variable in class java.awt.geom. Rectangle2D.Double
这个 Rectangle2D的X坐标。
x - Variable in class java.awt.geom. Rectangle2D.Float
这个 Rectangle2D的X坐标。
x - Variable in class java.awt.geom. RoundRectangle2D.Double
这个 RoundRectangle2D的X坐标。
x - Variable in class java.awt.geom. RoundRectangle2D.Float
这个 RoundRectangle2D的X坐标。
x - Variable in class java.awt. Point
这个坐标的这个 Point 。
x - Variable in class java.awt. Rectangle
Rectangle左右角的X坐标为 Rectangle 。
X - javafx.scene.input. KeyCode
常数为 X键。
X_AXIS - javafx.scene.chart. LineChart.SortingPolicy
数据按x轴排序。
X_AXIS - Static variable in class javafx.scene.transform. Rotate
指定X轴作为旋转轴。
X_AXIS - Static variable in class javax.swing. BoxLayout
指定组件应从左到右布置。
X_AXIS - Static variable in class javax.swing.text. View
轴用于格式化/中断操作。
x1 - Variable in class java.awt.geom. CubicCurve2D.Double
三次曲线段起始点的X坐标。
x1 - Variable in class java.awt.geom. CubicCurve2D.Float
三次曲线段起始点的X坐标。
x1 - Variable in class java.awt.geom. Line2D.Double
线段起始点的X坐标。
x1 - Variable in class java.awt.geom. Line2D.Float
线段起始点的X坐标。
x1 - Variable in class java.awt.geom. QuadCurve2D.Double
二次曲线段起始点的X坐标。
x1 - Variable in class java.awt.geom. QuadCurve2D.Float
二次曲线段起始点的X坐标。
x2 - Variable in class java.awt.geom. CubicCurve2D.Double
三次曲线段终点的X坐标。
x2 - Variable in class java.awt.geom. CubicCurve2D.Float
三次曲线段终点的X坐标。
x2 - Variable in class java.awt.geom. Line2D.Double
线段终点的X坐标。
x2 - Variable in class java.awt.geom. Line2D.Float
线段终点的X坐标。
x2 - Variable in class java.awt.geom. QuadCurve2D.Double
二次曲线段终点的X坐标。
x2 - Variable in class java.awt.geom. QuadCurve2D.Float
二次曲线段终点的X坐标。
X500Principal - Class in com.sun.security.auth
不推荐用于删除：此API元素将在以后的版本中被删除。
Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。
X500Principal - Class in javax.security.auth.x500
这个类代表X.500 Principal 。
X500Principal(byte[]) - Constructor for class javax.security.auth.x500. X500Principal
从ASN.1 DER编码形式的专有名称创建 X500Principal 。
X500Principal(InputStream) - Constructor for class javax.security.auth.x500. X500Principal
从包含ASN.1 DER编码格式的可分辨名称的 InputStream创建一个 X500Principal 。
X500Principal(String) - Constructor for class com.sun.security.auth. X500Principal
已过时。
使用X.500名称创建X500Principal，例如“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”（RFC 1779样式）。
X500Principal(String) - Constructor for class javax.security.auth.x500. X500Principal
从X.500专有名称的字符串表示形式（例如：“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”）创建 X500Principal 。
X500Principal(String, Map<String, String>) - Constructor for class javax.security.auth.x500. X500Principal
从X.500专有名称的字符串表示形式（例如：“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”）创建一个 X500Principal 。
X500PrivateCredential - Class in javax.security.auth.x500
这个类代表一个 X500PrivateCredential 。
X500PrivateCredential(X509Certificate, PrivateKey) - Constructor for class javax.security.auth.x500. X500PrivateCredential
创建X500PrivateCredential，它将X.509证书，私钥和KeyStore别名相关联。
X500PrivateCredential(X509Certificate, PrivateKey, String) - Constructor for class javax.security.auth.x500. X500PrivateCredential
创建X500PrivateCredential，它将X.509证书，私钥和KeyStore别名相关联。
X509Certificate - Class in java.security.cert
X.509证书的抽象类。
X509Certificate - Class in javax.security.cert
已过时。
使用java.security.cert的类。
X509Certificate() - Constructor for class java.security.cert. X509Certificate
X.509证书的构造方法。
X509Certificate() - Constructor for class javax.security.cert. X509Certificate
已过时。
X509CertSelector - Class in java.security.cert
A CertSelector选择符合所有指定条件的 X509Certificates 。
X509CertSelector() - Constructor for class java.security.cert. X509CertSelector
创建一个 X509CertSelector 。
X509CRL - Class in java.security.cert
X.509证书撤销列表（CRL）的抽象类。
X509CRL() - Constructor for class java.security.cert. X509CRL
X.509 CRL的构造方法。
X509CRLEntry - Class in java.security.cert
CRL（证书撤销列表）中撤销证书的抽象类。
X509CRLEntry() - Constructor for class java.security.cert. X509CRLEntry
X509CRLSelector - Class in java.security.cert
A CRLSelector选择符合所有指定条件的 X509CRLs 。
X509CRLSelector() - Constructor for class java.security.cert. X509CRLSelector
创建一个 X509CRLSelector 。
X509Data - Interface in javax.xml.crypto.dsig.keyinfo
在 X509Data中定义的XML X509Data元素的 表示 。
X509EncodedKeySpec - Class in java.security.spec
该类表示公钥的ASN.1编码，根据ASN.1类型 SubjectPublicKeyInfo编码。
X509EncodedKeySpec(byte[]) - Constructor for class java.security.spec. X509EncodedKeySpec
使用给定的编码密钥创建一个新的 X509EncodedKeySpec 。
X509EncodedKeySpec(byte[], String) - Constructor for class java.security.spec. X509EncodedKeySpec
使用给定的编码密钥创建一个新的 X509EncodedKeySpec 。
X509ExtendedKeyManager - Class in javax.net.ssl
抽象类，用于扩展X509KeyManager接口。
X509ExtendedKeyManager() - Constructor for class javax.net.ssl. X509ExtendedKeyManager
仅由子类使用的构造方法。
X509ExtendedTrustManager - Class in javax.net.ssl
扩展到 X509TrustManager接口，支持SSL / TLS / DTLS连接敏感信任管理。
X509ExtendedTrustManager() - Constructor for class javax.net.ssl. X509ExtendedTrustManager
X509Extension - Interface in java.security.cert
X509扩展接口。
X509IssuerSerial - Interface in javax.xml.crypto.dsig.keyinfo
在 X509IssuerSerial中定义的XML X509IssuerSerial元素的 表示 。
X509KeyManager - Interface in javax.net.ssl
此接口的实例管理哪些基于X509证书的密钥对用于认证安全套接字的本地端。
X509TrustManager - Interface in javax.net.ssl
此接口的实例管理哪些X509证书可用于验证安全套接字的远程端。
XA_HEURCOM - Static variable in exception javax.transaction.xa. XAException
交易部门已经启发式地承诺了。
XA_HEURHAZ - Static variable in exception javax.transaction.xa. XAException
交易分行可能已经启发式完成。
XA_HEURMIX - Static variable in exception javax.transaction.xa. XAException
交易部门已经启发式地承诺并回滚。
XA_HEURRB - Static variable in exception javax.transaction.xa. XAException
事务处已经启发式地回滚了。
XA_NOMIGRATE - Static variable in exception javax.transaction.xa. XAException
恢复必须发生在暂停发生的地方。
XA_OK - Static variable in interface javax.transaction.xa. XAResource
交易工作已正常准备。
XA_RBBASE - Static variable in exception javax.transaction.xa. XAException
回滚代码的下划线。
XA_RBCOMMFAIL - Static variable in exception javax.transaction.xa. XAException
表示回滚是由通信故障引起的。
XA_RBDEADLOCK - Static variable in exception javax.transaction.xa. XAException
发现死锁。
XA_RBEND - Static variable in exception javax.transaction.xa. XAException
回滚错误代码的包含上限。
XA_RBINTEGRITY - Static variable in exception javax.transaction.xa. XAException
检测到违反资源完整性的条件。
XA_RBOTHER - Static variable in exception javax.transaction.xa. XAException
资源管理器回滚事务分支，原因不在此列表中。
XA_RBPROTO - Static variable in exception javax.transaction.xa. XAException
资源管理器中发生协议错误。
XA_RBROLLBACK - Static variable in exception javax.transaction.xa. XAException
表示回滚是由未指定的原因造成的。
XA_RBTIMEOUT - Static variable in exception javax.transaction.xa. XAException
交易分支花费的时间太长。
XA_RBTRANSIENT - Static variable in exception javax.transaction.xa. XAException
可以重试交易分行。
XA_RDONLY - Static variable in exception javax.transaction.xa. XAException
交易分支是只读的，已经被提交。
XA_RDONLY - Static variable in interface javax.transaction.xa. XAResource
事务分支是只读的，已经被提交。
XA_RETRY - Static variable in exception javax.transaction.xa. XAException
常规返回，没有任何效果，可能会重新发行。
XAConnection - Interface in javax.sql
为分布式事务提供支持的对象。
XAConnectionBuilder - Interface in javax.sql
从 XADataSource对象创建的构建器，用于建立与 data source对象所表示的数据库的连接。
XADataSource - Interface in javax.sql
一个用于内部使用的 XAConnection对象的工厂。
XAER_ASYNC - Static variable in exception javax.transaction.xa. XAException
有一个非常好的异步操作。
XAER_DUPID - Static variable in exception javax.transaction.xa. XAException
XID已存在。
XAER_INVAL - Static variable in exception javax.transaction.xa. XAException
给出了无效的参数。
XAER_NOTA - Static variable in exception javax.transaction.xa. XAException
XID无效。
XAER_OUTSIDE - Static variable in exception javax.transaction.xa. XAException
资源管理器正在全球交易之外开展工作。
XAER_PROTO - Static variable in exception javax.transaction.xa. XAException
例程在不合适的上下文中被调用。
XAER_RMERR - Static variable in exception javax.transaction.xa. XAException
事务分支中发生资源管理器错误。
XAER_RMFAIL - Static variable in exception javax.transaction.xa. XAException
资源管理器不可用。
XAException - Exception in javax.transaction.xa
资源管理器（RM）抛出XAException，以通知事务管理器涉及的事务遇到的错误。
XAException() - Constructor for exception javax.transaction.xa. XAException
创建一个XAException。
XAException(int) - Constructor for exception javax.transaction.xa. XAException
用给定的错误代码创建一个XAException。
XAException(String) - Constructor for exception javax.transaction.xa. XAException
用给定的字符串创建XAException。
XAResource - Interface in javax.transaction.xa
XAResource接口是基于X / Open CAE规范（分布式事务处理：XA规范）的行业标准XA接口的Java映射。
XAxisRotationProperty() - Method in class javafx.scene.shape. ArcTo
x轴旋转度。
Xid - Interface in javax.transaction.xa
Xid接口是X / Open事务标识符XID结构的Java映射。
XML_DTD_NS_URI - Static variable in class javax.xml. XMLConstants
XML文档类型声明命名空间URI为任意值。
XML_NS_PREFIX - Static variable in class javax.xml. XMLConstants
官方的XML命名空间前缀。
XML_NS_URI - Static variable in class javax.xml. XMLConstants
官方XML命名空间名称URI。
XmlAccessOrder - Enum in javax.xml.bind.annotation
由XmlAccessorOrder用于控制JAXB绑定类中的属性和字段的排序。
XmlAccessorOrder - Annotation Type in javax.xml.bind.annotation
控制类中字段和属性的顺序。
XmlAccessorType - Annotation Type in javax.xml.bind.annotation
控制字段或Javabean属性是否默认序列化。
XmlAccessType - Enum in javax.xml.bind.annotation
由XmlAccessorType用于控制字段或属性的序列化。
XmlAdapter< ValueType, BoundType> - Class in javax.xml.bind.annotation.adapters
适应Java类型进行自定义封送。
XmlAdapter() - Constructor for class javax.xml.bind.annotation.adapters. XmlAdapter
派生类的Do-nothing构造函数。
XmlAnyAttribute - Annotation Type in javax.xml.bind.annotation
将JavaBean属性映射到通配符属性的映射。
XmlAnyElement - Annotation Type in javax.xml.bind.annotation
将JavaBean属性映射到XML信息集表示和/或JAXB元素。
XmlAttachmentRef - Annotation Type in javax.xml.bind.annotation
标记一个字段/属性，它的XML表单是一个uri引用mime内容。
XmlAttribute - Annotation Type in javax.xml.bind.annotation
将JavaBean属性映射到XML属性。
XMLConstants - Class in javax.xml
包含基本XML值作为常量的实用程序类。
XMLCryptoContext - Interface in javax.xml.crypto
包含XML加密操作的常见上下文信息。
XMLDecoder - Class in java.beans
XMLDecoder类用于读取使用 XMLEncoder创建的XML文档，并且像 ObjectInputStream那样使用。
XMLDecoder(InputStream) - Constructor for class java.beans. XMLDecoder
创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
XMLDecoder(InputStream, Object) - Constructor for class java.beans. XMLDecoder
创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
XMLDecoder(InputStream, Object, ExceptionListener) - Constructor for class java.beans. XMLDecoder
创建一个新的输入流，以读取 XMLEncoder类创建的 XMLEncoder 。
XMLDecoder(InputStream, Object, ExceptionListener, ClassLoader) - Constructor for class java.beans. XMLDecoder
创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
XMLDecoder(InputSource) - Constructor for class java.beans. XMLDecoder
创建一个新的解码器来解析由 XMLEncoder类创建的XML存档。
XmlElement - Annotation Type in javax.xml.bind.annotation
将JavaBean属性映射到从属性名称派生的XML元素。
XmlElement.DEFAULT - Class in javax.xml.bind.annotation
在 XmlElement.type()中用于表示从属性的签名中推断出该类型。
XmlElementDecl - Annotation Type in javax.xml.bind.annotation
将工厂方法映射到XML元素。
XmlElementDecl.GLOBAL - Class in javax.xml.bind.annotation
用于 XmlElementDecl.scope()以表示声明在全局范围内。
XmlElementRef - Annotation Type in javax.xml.bind.annotation
将JavaBean属性映射到从属性类型派生的XML元素。
XmlElementRef.DEFAULT - Class in javax.xml.bind.annotation
在 XmlElementRef.type()中用于表示从属性的签名中推断出该类型。
XmlElementRefs - Annotation Type in javax.xml.bind.annotation
使用XmlElement或JAXBElement标记指向类的属性。
XmlElements - Annotation Type in javax.xml.bind.annotation
多个@ XmlElement注释的容器。
XmlElementWrapper - Annotation Type in javax.xml.bind.annotation
围绕XML表示生成一个包装元素。
XMLEncoder - Class in java.beans
所述 XMLEncoder类是互补替代 ObjectOutputStream ，并且可以用于产生以相同的方式，该一个 JavaBean的文本表示 ObjectOutputStream可以用来创建的二进制表示 Serializable对象。
XMLEncoder(OutputStream) - Constructor for class java.beans. XMLEncoder
创建一个新的XML编码器，以使用XML编码将 JavaBeans写入流 out 。
XMLEncoder(OutputStream, String, boolean, int) - Constructor for class java.beans. XMLEncoder
创建一个新的XML编码器 的JavaBeans写出到流 out使用给定 charset从给定的起始 indentation 。
XmlEnum - Annotation Type in javax.xml.bind.annotation
将枚举类型Enum映射到XML表示。
XmlEnumValue - Annotation Type in javax.xml.bind.annotation
将一个枚举常量映射到Enum类型到XML表示。
XMLEvent - Interface in javax.xml.stream.events
这是处理标记事件的基本事件界面。
XMLEventAllocator - Interface in javax.xml.stream.util
该界面定义了一个类，允许用户注册一种分配给定XMLStreamReader的事件的方式。
XMLEventConsumer - Interface in javax.xml.stream.util
该接口定义事件消费者接口。
XMLEventFactory - Class in javax.xml.stream
该界面定义了一个用于创建XMLEvents实例的实用程序类
XMLEventFactory() - Constructor for class javax.xml.stream. XMLEventFactory
XMLEventReader - Interface in javax.xml.stream
这是解析XML事件的顶级界面。
XMLEventWriter - Interface in javax.xml.stream
这是编写XML文档的顶级界面。
XMLFilter - Interface in org.xml.sax
XML过滤器的接口。
XMLFilterImpl - Class in org.xml.sax.helpers
用于导出XML过滤器的基类。
XMLFilterImpl() - Constructor for class org.xml.sax.helpers. XMLFilterImpl
构造一个空的XML过滤器，没有父级。
XMLFilterImpl(XMLReader) - Constructor for class org.xml.sax.helpers. XMLFilterImpl
使用指定的父构造XML筛选器。
XMLFormatter - Class in java.util.logging
将LogRecord格式化为标准XML格式。
XMLFormatter() - Constructor for class java.util.logging. XMLFormatter
创建一个新的XMLFormatter实例。
XMLGregorianCalendar - Class in javax.xml.datatype
W3C XML Schema 1.0日期/时间数据类型的表示。
XMLGregorianCalendar() - Constructor for class javax.xml.datatype. XMLGregorianCalendar
默认的无参数构造函数。
XmlID - Annotation Type in javax.xml.bind.annotation
将JavaBean属性映射到XML ID。
XmlIDREF - Annotation Type in javax.xml.bind.annotation
将JavaBean属性映射到XML IDREF。
XmlInlineBinaryData - Annotation Type in javax.xml.bind.annotation
禁用对XML绑定到base64编码的二进制数据的数据类型的XOP编码的考虑。
XMLInputFactory - Class in javax.xml.stream
定义了一个工厂的抽象实现来获取流。
XMLInputFactory() - Constructor for class javax.xml.stream. XMLInputFactory
XmlJavaTypeAdapter - Annotation Type in javax.xml.bind.annotation.adapters
使用实现XmlAdapter的适配器进行自定义封送。
XmlJavaTypeAdapter.DEFAULT - Class in javax.xml.bind.annotation.adapters
用于 XmlJavaTypeAdapter.type()以表示从字段，属性，参数或类的签名中推断出该类型。
XmlJavaTypeAdapters - Annotation Type in javax.xml.bind.annotation.adapters
多个@ XmlJavaTypeAdapter注释的容器。
XmlList - Annotation Type in javax.xml.bind.annotation
用于将属性映射到列表简单类型。
XmlMimeType - Annotation Type in javax.xml.bind.annotation
关联控制属性的XML表示形式的MIME类型。
XmlMixed - Annotation Type in javax.xml.bind.annotation
注释JavaBean多值属性以支持混合内容。
XmlNs - Annotation Type in javax.xml.bind.annotation
将命名空间前缀与XML命名空间URI相关联。
XMLNS - Static variable in interface javax.xml.crypto.dsig. XMLSignature
用于XML签名语法和处理的W3C建议书的XML命名空间URI。
XMLNS - Static variable in class org.xml.sax.helpers. NamespaceSupport
XML命名空间URI作为常量。
XMLNS_ATTRIBUTE - Static variable in class javax.xml. XMLConstants
用于指定XML命名空间声明的官方XML属性。
XMLNS_ATTRIBUTE_NS_URI - Static variable in class javax.xml. XMLConstants
用于指定XML命名空间声明的官方XML属性， XMLConstants.XMLNS_ATTRIBUTE ，命名空间名称URI。
XmlNsForm - Enum in javax.xml.bind.annotation
枚举XML Schema命名空间资格。
XMLObject - Interface in javax.xml.crypto.dsig
在 Object中定义的XML Object元素的 表示 。
XMLOutputFactory - Class in javax.xml.stream
定义用于获取XMLEventWriters和XMLStreamWrit的工厂的抽象实现。
XMLOutputFactory() - Constructor for class javax.xml.stream. XMLOutputFactory
XMLParseException - Exception in javax.management.modelmbean
当将XML格式化的字符串解析为ModelMBean对象或从ModelMBean对象创建XML格式的字符串时，将抛出此异常。
XMLParseException() - Constructor for exception javax.management.modelmbean. XMLParseException
默认构造函数。
XMLParseException(Exception, String) - Constructor for exception javax.management.modelmbean. XMLParseException
构造函数采用字符串和异常。
XMLParseException(String) - Constructor for exception javax.management.modelmbean. XMLParseException
构造函数采用字符串。
XmlReader - Interface in javax.sql.rowset.spi
一个专门的界面，有助于为面向XML的同步提供程序扩展 SyncProvider抽象类。
XMLReader - Interface in org.xml.sax
使用回调读取XML文档的界面。
XMLReaderAdapter - Class in org.xml.sax.helpers
将SAX2 XMLReader修改为SAX1解析器。
XMLReaderAdapter() - Constructor for class org.xml.sax.helpers. XMLReaderAdapter
创建一个新的适配器。
XMLReaderAdapter(XMLReader) - Constructor for class org.xml.sax.helpers. XMLReaderAdapter
创建一个新的适配器。
XMLReaderFactory - Class in org.xml.sax.helpers
已过时。
建议使用SAXParserFactory 。
XmlRegistry - Annotation Type in javax.xml.bind.annotation
标记一个有XmlElementDecl的类。
XMLReporter - Interface in javax.xml.stream
此界面用于报告非致命错误。
XMLResolver - Interface in javax.xml.stream
此接口用于在XML解析期间解析资源。
XmlRootElement - Annotation Type in javax.xml.bind.annotation
将类或枚举类型映射到XML元素。
XmlSchema - Annotation Type in javax.xml.bind.annotation
将包名称映射到XML命名空间。
XmlSchemaType - Annotation Type in javax.xml.bind.annotation
将Java类型映射到简单的模式内置类型。
XmlSchemaType.DEFAULT - Class in javax.xml.bind.annotation
用于 XmlSchemaType.type()表示从属性的签名推断出该类型。
XmlSchemaTypes - Annotation Type in javax.xml.bind.annotation
多个@ XmlSchemaType注释的容器。
XmlSeeAlso - Annotation Type in javax.xml.bind.annotation
指示JAXB在绑定此类时也绑定其他类。
XMLSignature - Interface in javax.xml.crypto.dsig
在 Signature中定义的XML Signature元素的 表示 。
XMLSignature.SignatureValue - Interface in javax.xml.crypto.dsig
在 SignatureValue中定义的XML SignatureValue元素的 表示 。
XMLSignatureException - Exception in javax.xml.crypto.dsig
表示在XML签名生成或验证过程中发生的特殊情况。
XMLSignatureException() - Constructor for exception javax.xml.crypto.dsig. XMLSignatureException
构建新的 XMLSignatureException ，其详细信息为 null 。
XMLSignatureException(String) - Constructor for exception javax.xml.crypto.dsig. XMLSignatureException
构造一个新的 XMLSignatureException与指定的详细信息。
XMLSignatureException(String, Throwable) - Constructor for exception javax.xml.crypto.dsig. XMLSignatureException
构造一个新的 XMLSignatureException具有指定的详细信息和原因。
XMLSignatureException(Throwable) - Constructor for exception javax.xml.crypto.dsig. XMLSignatureException
构造一个新的 XMLSignatureException具有指定的原因和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。
XMLSignatureFactory - Class in javax.xml.crypto.dsig
从零开始创建27045740423328个对象的工厂，或从对应的XML表示中解组XMLSignature对象。
XMLSignatureFactory() - Constructor for class javax.xml.crypto.dsig. XMLSignatureFactory
默认构造函数，用于由子类调用。
XMLSignContext - Interface in javax.xml.crypto.dsig
包含用于生成XML签名的上下文信息。
XMLStreamConstants - Interface in javax.xml.stream
此接口声明此API中使用的常量。
XMLStreamException - Exception in javax.xml.stream
基于异常的意外处理错误。
XMLStreamException() - Constructor for exception javax.xml.stream. XMLStreamException
默认构造函数
XMLStreamException(String) - Constructor for exception javax.xml.stream. XMLStreamException
使用关联的消息构造异常。
XMLStreamException(String, Throwable) - Constructor for exception javax.xml.stream. XMLStreamException
使用关联的消息和异常构造异常
XMLStreamException(String, Location) - Constructor for exception javax.xml.stream. XMLStreamException
使用关联的消息，异常和位置构造异常。
XMLStreamException(String, Location, Throwable) - Constructor for exception javax.xml.stream. XMLStreamException
使用关联的消息，异常和位置构造异常。
XMLStreamException(Throwable) - Constructor for exception javax.xml.stream. XMLStreamException
构造与异常异常的异常
XMLStreamReader - Interface in javax.xml.stream
XMLStreamReader接口允许转发，只读访问XML。
XMLStreamWriter - Interface in javax.xml.stream
XMLStreamWriter接口指定如何编写XML。
XMLStructure - Interface in javax.xml.crypto
来自任何命名空间的XML结构的表示。
XmlTransient - Annotation Type in javax.xml.bind.annotation
防止将JavaBean属性/类型映射到XML表示。
XmlType - Annotation Type in javax.xml.bind.annotation
将类或枚举类型映射到XML模式类型。
XmlType.DEFAULT - Class in javax.xml.bind.annotation
用于XmlType.factoryClass()以表示不使用工厂方法，或者它与本XmlType本课程一样 。
XMLValidateContext - Interface in javax.xml.crypto.dsig
包含验证XML签名的上下文信息。
XmlValue - Annotation Type in javax.xml.bind.annotation
使用simpleContent或XML Schema简单类型将类映射到XML模式复合类型。
XmlWriter - Interface in javax.sql.rowset.spi
一个专门的界面，有助于为面向XML的同步提供程序扩展 SyncProvider抽象类。
xor(BigInteger) - Method in class java.math. BigInteger
返回值为 (this ^ val)的BigInteger。
xor(BitSet) - Method in class java.util. BitSet
使用位设置参数执行该位的逻辑 异或 。
Xor - Static variable in class java.awt. AlphaComposite
AlphaComposite对象实现的不透明XOR规则的alpha为1.0f。
XOR - com.sun.source.tree. Tree.Kind
用于实例BinaryTree代表按位和逻辑“异或” ^ 。
XOR - jdk.nashorn.api.tree. Tree.Kind
用于实例BinaryTree代表按位和逻辑“异或” ^ 。
XOR - Static variable in class java.awt. AlphaComposite
位于目的地外部的源的部分与位于源外的目标的部分（Porter-Duff Source Xor Destination rule）组合。
XOR_ASSIGNMENT - com.sun.source.tree. Tree.Kind
用于实例CompoundAssignmentTree代表按位和逻辑“异或”分配^= 。
XOR_ASSIGNMENT - jdk.nashorn.api.tree. Tree.Kind
用于实例CompoundAssignmentTree代表按位和逻辑“异或”分配^= 。
XPath - Interface in javax.xml.xpath
XPath提供对XPath评估环境和表达式的访问。
XPATH - Static variable in interface javax.xml.crypto.dsig. Transform
XPath转换算法URI。
XPATH_NAMESPACE_NODE - Static variable in interface org.w3c.dom.xpath. XPathNamespace
该节点是一个 Namespace 。
XPATH2 - Static variable in interface javax.xml.crypto.dsig. Transform
XPath Filter 2转换算法URI。
XPathConstants - Class in javax.xml.xpath
XPath常量。
XPathEvaluationResult< T> - Interface in javax.xml.xpath
XPathEvaluationResult接口表示在特定节点的上下文中评估XPath表达式的结果。
XPathEvaluationResult.XPathResultType - Enum in javax.xml.xpath
XPathResultType表示XPath评估的可能的返回类型。
XPathEvaluator - Interface in org.w3c.dom.xpath
XPath表达式的评估由 XPathEvaluator提供。
XPathException - Exception in javax.xml.xpath
XPathException表示一个通用的XPath异常。
XPathException - Exception in org.w3c.dom.xpath
为这些XPath接口特定的异常创建了一个新的异常。
XPathException(short, String) - Constructor for exception org.w3c.dom.xpath. XPathException
XPathException(String) - Constructor for exception javax.xml.xpath. XPathException
构造一个新的 XPathException与指定的细节 message 。
XPathException(Throwable) - Constructor for exception javax.xml.xpath. XPathException
构造一个新的 XPathException与指定的 cause 。
XPathExpression - Interface in javax.xml.xpath
XPathExpression提供对编译的XPath表达式的访问。
XPathExpression - Interface in org.w3c.dom.xpath
XPathExpression接口表示解析和解析的XPath表达式。
XPathExpressionException - Exception in javax.xml.xpath
XPathExpressionException表示XPath表达式中的错误。
XPathExpressionException(String) - Constructor for exception javax.xml.xpath. XPathExpressionException
构造一个新的 XPathExpressionException与指定的细节 message 。
XPathExpressionException(Throwable) - Constructor for exception javax.xml.xpath. XPathExpressionException
构造一个新的 XPathExpressionException与指定的 cause 。
XPathFactory - Class in javax.xml.xpath
一个XPathFactory实例可以用来创建XPath对象。
XPathFactory() - Constructor for class javax.xml.xpath. XPathFactory
 应使用受保护的构造函数（
XPathFactory.newInstance()或
XPathFactory.newInstance(String uri)或
XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)）来创建一个新的
XPathFactory实例。
XPathFactoryConfigurationException - Exception in javax.xml.xpath
XPathFactoryConfigurationException表示 XPathFactory环境中的配置错误。
XPathFactoryConfigurationException(String) - Constructor for exception javax.xml.xpath. XPathFactoryConfigurationException
构造一个新的 XPathFactoryConfigurationException与指定的细节 message 。
XPathFactoryConfigurationException(Throwable) - Constructor for exception javax.xml.xpath. XPathFactoryConfigurationException
构造一个新的 XPathFactoryConfigurationException与指定的 cause 。
XPathFilter2ParameterSpec - Class in javax.xml.crypto.dsig.spec
参考W3C建议 XPath Filter 2.0 Transform Algorithm 。
XPathFilter2ParameterSpec(List<XPathType>) - Constructor for class javax.xml.crypto.dsig.spec. XPathFilter2ParameterSpec
创建一个 XPathFilter2ParameterSpec 。
XPathFilterParameterSpec - Class in javax.xml.crypto.dsig.spec
参数为 XPath Filtering Transform Algorithm 。
XPathFilterParameterSpec(String) - Constructor for class javax.xml.crypto.dsig.spec. XPathFilterParameterSpec
使用指定的XPath表达式创建一个 XPathFilterParameterSpec 。
XPathFilterParameterSpec(String, Map<String, String>) - Constructor for class javax.xml.crypto.dsig.spec. XPathFilterParameterSpec
使用指定的XPath表达式和命名空间映射创建一个 XPathFilterParameterSpec 。
XPathFunction - Interface in javax.xml.xpath
XPathFunction提供对XPath函数的访问。
XPathFunctionException - Exception in javax.xml.xpath
XPathFunctionException表示XPath函数的错误。
XPathFunctionException(String) - Constructor for exception javax.xml.xpath. XPathFunctionException
构造一个新的 XPathFunctionException与指定的细节 message 。
XPathFunctionException(Throwable) - Constructor for exception javax.xml.xpath. XPathFunctionException
构造一个新的 XPathFunctionException与指定的 cause 。
XPathFunctionResolver - Interface in javax.xml.xpath
XPathFunctionResolver提供对用户定义的一组 XPathFunction的访问。
XPathNamespace - Interface in org.w3c.dom.xpath
XPathNamespace接口由 XPathResult接口返回，以表示DOM缺少的XPath命名空间节点类型。
XPathNodes - Interface in javax.xml.xpath
XPathNodes表示由 XML Path Language (XPath) Version 1.0, 3.3 Node-sets中指定的位置路径选择的一组节点。
XPathNSResolver - Interface in org.w3c.dom.xpath
XPathNSResolver接口允许 prefix字符串中的表达式正确绑定到 namespaceURI字符串。
XPathResult - Interface in org.w3c.dom.xpath
XPathResult接口表示在特定节点的上下文中评估XPath 1.0表达式的结果。
XPathType - Class in javax.xml.crypto.dsig.spec
所述的XML架构定义 XPath如在定义元件 W3C Recommendation for XML-Signature XPath Filter 2.0 ：
XPathType(String, XPathType.Filter) - Constructor for class javax.xml.crypto.dsig.spec. XPathType
使用指定的XPath表达式和过滤器创建一个 XPathType实例。
XPathType(String, XPathType.Filter, Map<String, String>) - Constructor for class javax.xml.crypto.dsig.spec. XPathType
使用指定的XPath表达式，过滤器和命名空间映射创建一个 XPathType实例。
XPathType.Filter - Class in javax.xml.crypto.dsig.spec
表示过滤器设置操作。
XPathVariableResolver - Interface in javax.xml.xpath
XPathVariableResolver提供对用户定义的XPath变量集的访问。
xpoints - Variable in class java.awt. Polygon
X坐标数组。
xPositionForValue(int) - Method in class javax.swing.plaf.basic. BasicSliderUI
返回值的x位置。
xPositionForValue(int) - Method in class javax.swing.plaf.synth. SynthSliderUI
返回值的x位置。
xProperty() - Method in class javafx.scene.control. Dialog
这个水平位置这个 Dialog 。
xProperty() - Method in class javafx.scene.effect. ColorInput
相对于内容 Node的本地坐标空间设置要淹没区域的x位置。
xProperty() - Method in class javafx.scene.effect. ImageInput
设置源图像的x位置，相对于内容 Node的局部坐标空间。
xProperty() - Method in class javafx.scene.effect. Light.Point
光位置的x坐标。
xProperty() - Method in class javafx.scene.image. ImageView
当前的x坐标为 ImageView起源。
xProperty() - Method in class javafx.scene.media. MediaView
定义 MediaView起始点的当前x坐标。
xProperty() - Method in class javafx.scene. Scene
这个 Scene的水平位置在 Window 。
xProperty() - Method in class javafx.scene.shape. ArcTo
x坐标到弧。
xProperty() - Method in class javafx.scene.shape. CubicCurveTo
定义最终终点的X坐标。
xProperty() - Method in class javafx.scene.shape. HLineTo
定义X坐标。
xProperty() - Method in class javafx.scene.shape. LineTo
定义X坐标。
xProperty() - Method in class javafx.scene.shape. MoveTo
定义指定的X坐标。
xProperty() - Method in class javafx.scene.shape. QuadCurveTo
定义最终终点的X坐标。
xProperty() - Method in class javafx.scene.shape. Rectangle
定义矩形左上角的X坐标。
xProperty() - Method in class javafx.scene.text. Text
定义文本原点的X坐标。
xProperty() - Method in class javafx.scene.transform. Scale
定义坐标沿X轴方向缩放的因子。
xProperty() - Method in class javafx.scene.transform. Shear
定义坐标沿正X轴方向移动的乘数，作为其Y坐标系数。
xProperty() - Method in class javafx.scene.transform. Translate
定义坐标在X轴方向上平移的距离
xProperty() - Method in class javafx.stage. Window
这个水平位置的这个 Window在屏幕上。
XSLT - Static variable in interface javax.xml.crypto.dsig. Transform
XSLT转换算法URI。
XSLTTransformParameterSpec - Class in javax.xml.crypto.dsig.spec
参数为 XSLT Transform Algorithm 。
XSLTTransformParameterSpec(XMLStructure) - Constructor for class javax.xml.crypto.dsig.spec. XSLTTransformParameterSpec
使用指定的样式表创建一个 XSLTTransformParameterSpec 。
XValueProperty() - Method in class javafx.scene.chart. XYChart.Data
要在X轴上绘制的通用数据值。
XYChart< X, Y> - Class in javafx.scene.chart
所有2轴图的图表基类。
XYChart(Axis<X>, Axis<Y>) - Constructor for class javafx.scene.chart. XYChart
构造给定两个轴的XYChart。
XYChart.Data< X, Y> - Class in javafx.scene.chart
具有2轴图数据的单个数据项
XYChart.Series< X, Y> - Class in javafx.scene.chart
一系列命名的数据项
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Y-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Y

y - Variable in class java.awt. Event
已过时。
事件的 y坐标。
y - Variable in class java.awt.geom. Arc2D.Double
圆弧框架矩形左上角的Y坐标。
y - Variable in class java.awt.geom. Arc2D.Float
圆弧框架矩形左上角的Y坐标。
y - Variable in class java.awt.geom. Ellipse2D.Double
这个 Ellipse2D的框架矩形左上角的Y坐标。
y - Variable in class java.awt.geom. Ellipse2D.Float
这个 Ellipse2D框架矩形左上角的Y坐标。
y - Variable in class java.awt.geom. Point2D.Double
这个Y坐标 Point2D 。
y - Variable in class java.awt.geom. Point2D.Float
这个Y坐标 Point2D 。
y - Variable in class java.awt.geom. Rectangle2D.Double
这个Y坐标 Rectangle2D 。
y - Variable in class java.awt.geom. Rectangle2D.Float
这个Y坐标 Rectangle2D 。
y - Variable in class java.awt.geom. RoundRectangle2D.Double
这个坐标的这个 RoundRectangle2D 。
y - Variable in class java.awt.geom. RoundRectangle2D.Float
这个Y坐标 RoundRectangle2D 。
y - Variable in class java.awt. Point
这个 Point的Y坐标。
y - Variable in class java.awt. Rectangle
左上角的Y坐标为 Rectangle 。
Y - javafx.scene.input. KeyCode
常数为 Y键。
Y_AXIS - javafx.scene.chart. LineChart.SortingPolicy
数据按y轴排序。
Y_AXIS - Static variable in class javafx.scene.transform. Rotate
指定Y轴作为旋转轴。
Y_AXIS - Static variable in class javax.swing. BoxLayout
指定组件应该从上到下布置。
Y_AXIS - Static variable in class javax.swing.text. View
轴用于格式化/中断操作。
Y_CB_CR_POSITIONING_CENTERED - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“YCbCrPositioning”标签一起使用的值。
Y_CB_CR_POSITIONING_COSITED - Static variable in class javax.imageio.plugins.tiff. BaselineTIFFTagSet
与“YCbCrPositioning”标签一起使用的值。
y1 - Variable in class java.awt.geom. CubicCurve2D.Double
三次曲线段起始点的Y坐标。
y1 - Variable in class java.awt.geom. CubicCurve2D.Float
三次曲线段起始点的Y坐标。
y1 - Variable in class java.awt.geom. Line2D.Double
线段起始点的Y坐标。
y1 - Variable in class java.awt.geom. Line2D.Float
线段起始点的Y坐标。
y1 - Variable in class java.awt.geom. QuadCurve2D.Double
二次曲线段起始点的Y坐标。
y1 - Variable in class java.awt.geom. QuadCurve2D.Float
二次曲线段起始点的Y坐标。
y2 - Variable in class java.awt.geom. CubicCurve2D.Double
三次曲线段终点的Y坐标。
y2 - Variable in class java.awt.geom. CubicCurve2D.Float
三次曲线段终点的Y坐标。
y2 - Variable in class java.awt.geom. Line2D.Double
线段终点的Y坐标。
y2 - Variable in class java.awt.geom. Line2D.Float
线段终点的Y坐标。
y2 - Variable in class java.awt.geom. QuadCurve2D.Double
二次曲线段终点的Y坐标。
y2 - Variable in class java.awt.geom. QuadCurve2D.Float
二次曲线段终点的Y坐标。
Year - Class in java.time
ISO- 2007 ，如 2007 。
YEAR - java.time.temporal. ChronoField
这样的一年，如2012年。
YEAR - Static variable in class java.text. DateFormat.Field
不断识别年份字段。
YEAR - Static variable in class java.util. Calendar
字段编号为 get和 set表示年份。
YEAR_FIELD - Static variable in class java.text. DateFormat
YEAR场对齐的常用常数。
YEAR_OF_ERA - java.time.temporal. ChronoField
时代的一年。
YearMonth - Class in java.time
在ISO- 2007-12 ，如 2007-12 。
YEARS - java.time.temporal. ChronoUnit
代表一年概念的单位。
YEARS - Static variable in class javax.xml.datatype. DatatypeConstants
一个代表年份字段的常数。
yellow - Static variable in class java.awt. Color
颜色黄色。
YELLOW - Static variable in class java.awt. Color
颜色黄色。
YELLOW - Static variable in class javafx.scene.paint. Color
颜色为黄色，RGB值为＃FFFF00
YELLOWGREEN - Static variable in class javafx.scene.paint. Color
颜色黄绿色，RGB值为＃9ACD32
YES - javafx.scene.control. ButtonBar.ButtonData
“yes”按钮的标签。
YES - Static variable in class javafx.scene.control. ButtonType
预先定义的ButtonType显示“是”，并具有ButtonBar.ButtonData ButtonBar.ButtonData.YES 。
YES - Static variable in class javax.security.auth.callback. ConfirmationCallback
是选项。
YES_NO_CANCEL_OPTION - Static variable in class javax.security.auth.callback. ConfirmationCallback
YES / NO / CANCEL确认确认选项。
YES_NO_CANCEL_OPTION - Static variable in class javax.swing. JOptionPane
类型用于 showConfirmDialog 。
YES_NO_OPTION - Static variable in class javax.security.auth.callback. ConfirmationCallback
是/否确认选项。
YES_NO_OPTION - Static variable in class javax.swing. JOptionPane
类型用于 showConfirmDialog 。
YES_OPTION - Static variable in class javax.swing. JOptionPane
如果选择“是”，则从类方法返回值。
YI - java.lang. Character.UnicodeScript
Unicode脚本“彝”。
YI_RADICALS - Static variable in class java.lang. Character.UnicodeBlock
“Yi Radicals”Unicode字符块的常数。
YI_SYLLABLES - Static variable in class java.lang. Character.UnicodeBlock
“Yi Syllables”Unicode字符块的常数。
yield() - Static method in class java.lang. Thread
对调度程序的一个暗示，即当前线程愿意产生当前使用的处理器。
YIELD - jdk.nashorn.api.tree. Tree.Kind
用于实例YieldTree代表（发电机）产量表达yield expr 。
YieldTree - Interface in jdk.nashorn.api.tree
用于生成器功能的 yield expressions的树节点。
YIJING_HEXAGRAM_SYMBOLS - Static variable in class java.lang. Character.UnicodeBlock
“Yijing Hexagram符号”Unicode字符块的常数。
YOU_1 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS You（“Western”）＃1信封尺寸，120 mm×176 mm。
YOU_2 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS You（“Western”）＃2信封尺寸，114 mm x 162 mm。
YOU_3 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS You（“Western”）＃3信封尺寸，98 mm×148 mm。
YOU_4 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS You（“Western”）＃4信封尺寸，105 mm×235 mm。
YOU_5 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS You（“Western”）＃5信封尺寸，95 mm×217 mm。
YOU_6 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS You（“Western”）＃6信封尺寸，98 mm×190 mm。
YOU_7 - Static variable in class javax.print.attribute.standard. MediaSize.JIS
指定JIS You（“Western”）＃7信封尺寸，92 mm x 165 mm。
ypoints - Variable in class java.awt. Polygon
Y坐标数组。
yPositionForValue(int) - Method in class javax.swing.plaf.basic. BasicSliderUI
返回值的y位置。
yPositionForValue(int, int, int) - Method in class javax.swing.plaf.basic. BasicSliderUI
返回指定值的y位置。
yPositionForValue(int, int, int) - Method in class javax.swing.plaf.synth. SynthSliderUI
返回指定值的y位置。
yProperty() - Method in class javafx.scene.control. Dialog
这个 Dialog的垂直位置。
yProperty() - Method in class javafx.scene.effect. ColorInput
相对于内容 Node的局部坐标空间设置要淹没的区域的y位置。
yProperty() - Method in class javafx.scene.effect. ImageInput
设置源图像的y位置，相对于内容 Node的局部坐标空间。
yProperty() - Method in class javafx.scene.effect. Light.Point
光位置的y坐标。
yProperty() - Method in class javafx.scene.image. ImageView
目前的y坐标为 ImageView起源。
yProperty() - Method in class javafx.scene.media. MediaView
定义 MediaView起始点的当前y坐标。
yProperty() - Method in class javafx.scene. Scene
这个 Scene的垂直位置在 Window 。
yProperty() - Method in class javafx.scene.shape. ArcTo
y坐标到弧。
yProperty() - Method in class javafx.scene.shape. CubicCurveTo
定义最终终点的Y坐标。
yProperty() - Method in class javafx.scene.shape. LineTo
定义Y坐标。
yProperty() - Method in class javafx.scene.shape. MoveTo
定义指定的Y坐标。
yProperty() - Method in class javafx.scene.shape. QuadCurveTo
定义最终终点的Y坐标。
yProperty() - Method in class javafx.scene.shape. Rectangle
定义矩形左上角的Y坐标。
yProperty() - Method in class javafx.scene.shape. VLineTo
定义Y坐标。
yProperty() - Method in class javafx.scene.text. Text
定义文本原点的Y坐标。
yProperty() - Method in class javafx.scene.transform. Scale
定义坐标沿Y轴方向缩放的因子。
yProperty() - Method in class javafx.scene.transform. Shear
定义坐标在正Y轴的方向上作为其X坐标系数的乘数。
yProperty() - Method in class javafx.scene.transform. Translate
定义坐标在Y轴方向上平移的距离
yProperty() - Method in class javafx.stage. Window
这个 Window在屏幕上的垂直位置。
YValueProperty() - Method in class javafx.scene.chart. XYChart.Data
在Y轴上绘制的通用数据值。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Z-Index (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Z

Z - javafx.scene.input. KeyCode
常数为 Z键。
Z_AXIS - Static variable in class javafx.scene.transform. Rotate
指定Z轴作为旋转轴。
zero(Class<?>) - Static method in class java.lang.invoke. MethodHandles
生成请求的返回类型的常量方法句柄，每次调用时返回该类型的默认值。
ZERO - Static variable in class java.math. BigDecimal
值为0，标度为0。
ZERO - Static variable in class java.math. BigInteger
BigInteger常数为零。
ZERO - Static variable in class java.time. Duration
持续时间为零的常数。
ZERO - Static variable in class java.time. Period
一个常数为零。
ZERO - Static variable in class javafx.geometry. Point2D
两个坐标设置为0的点或向量。
ZERO - Static variable in class javafx.geometry. Point3D
所有三个坐标设置为0的点或向量。
ZERO - Static variable in class javafx.util. Duration
持续时间为0（无时间）。
ZipEntry - Class in java.util.zip
此类用于表示ZIP文件条目。
ZipEntry(String) - Constructor for class java.util.zip. ZipEntry
创建具有指定名称的新的zip条目。
ZipEntry(ZipEntry) - Constructor for class java.util.zip. ZipEntry
创建一个新的zip条目，其中的字段从指定的zip条目中取出。
ZipError - Error in java.util.zip
表示发生了不可恢复的错误。
ZipError(String) - Constructor for error java.util.zip. ZipError
使用给定的详细消息构造ZipError。
ZipException - Exception in java.util.zip
表示发生了某种类型的Zip异常。
ZipException() - Constructor for exception java.util.zip. ZipException
构造一个 ZipException其中包含 null作为其错误详细消息。
ZipException(String) - Constructor for exception java.util.zip. ZipException
构造具有指定详细消息的 ZipException 。
ZipFile - Class in java.util.zip
此类用于从zip文件读取条目。
ZipFile(File) - Constructor for class java.util.zip. ZipFile
打开一个ZIP文件，读取指定的File对象。
ZipFile(File, int) - Constructor for class java.util.zip. ZipFile
打开新的 ZipFile以指定的方式读取指定的 File对象。
ZipFile(File, int, Charset) - Constructor for class java.util.zip. ZipFile
打开新的 ZipFile以指定的方式读取指定的 File对象。
ZipFile(File, Charset) - Constructor for class java.util.zip. ZipFile
打开一个ZIP文件，读取指定的File对象。
ZipFile(String) - Constructor for class java.util.zip. ZipFile
打开一个zip文件进行阅读。
ZipFile(String, Charset) - Constructor for class java.util.zip. ZipFile
打开一个zip文件进行阅读。
ZipInputStream - Class in java.util.zip
该类实现了以ZIP文件格式读取文件的输入流过滤器。
ZipInputStream(InputStream) - Constructor for class java.util.zip. ZipInputStream
创建一个新的ZIP输入流。
ZipInputStream(InputStream, Charset) - Constructor for class java.util.zip. ZipInputStream
创建一个新的ZIP输入流。
ZipOutputStream - Class in java.util.zip
该类实现了以ZIP文件格式写入文件的输出流过滤器。
ZipOutputStream(OutputStream) - Constructor for class java.util.zip. ZipOutputStream
创建一个新的ZIP输出流。
ZipOutputStream(OutputStream, Charset) - Constructor for class java.util.zip. ZipOutputStream
创建一个新的ZIP输出流。
zone() - Static method in class java.time.temporal. TemporalQueries
一个宽松的查询为 ZoneId ，回落到 ZoneOffset 。
ZONE_OFFSET - Static variable in class java.util. Calendar
字段编号为 get和 set表示以毫秒为单位的GMT的原始偏移量。
zonedDateTime(Instant, ZoneId) - Method in interface java.time.chrono. Chronology
获得 ChronoZonedDateTime在从这个年表 Instant 。
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono. HijrahChronology
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono. IsoChronology
从一个 Instant获得这个时间顺序的ISO分区日期。
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono. JapaneseChronology
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono. MinguoChronology
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono. ThaiBuddhistChronology
zonedDateTime(TemporalAccessor) - Method in interface java.time.chrono. Chronology
从另一个时间对象获得这个年龄的 ChronoZonedDateTime 。
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono. HijrahChronology
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono. IsoChronology
从另一个日期时间对象获取ISO分区的日期时间。
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono. JapaneseChronology
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono. MinguoChronology
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono. ThaiBuddhistChronology
ZonedDateTime - Class in java.time
ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
zoneId() - Static method in class java.time.temporal. TemporalQueries
严格查询 ZoneId 。
ZoneId - Class in java.time
一个时区ID，如 Europe/Paris 。
ZoneOffset - Class in java.time
与格林威治/ UTC的时区偏移，如 +02:00 。
ZoneOffsetTransition - Class in java.time.zone
由本地时间线不连续性引起的两个偏移之间的转换。
ZoneOffsetTransitionRule - Class in java.time.zone
表达如何创建转换的规则。
ZoneOffsetTransitionRule.TimeDefinition - Enum in java.time.zone
本地时间可以转换为实际转换日期时间的方式的定义。
ZoneRules - Class in java.time.zone
定义区域偏移对于单个时区的变化的规则。
ZoneRulesException - Exception in java.time.zone
抛出指示时区配置的问题。
ZoneRulesException(String) - Constructor for exception java.time.zone. ZoneRulesException
使用指定的消息构造新的日期时间异常。
ZoneRulesException(String, Throwable) - Constructor for exception java.time.zone. ZoneRulesException
构造一个新的日期时间异常与指定的消息和原因。
ZoneRulesProvider - Class in java.time.zone
提供给系统的时区规则。
ZoneRulesProvider() - Constructor for class java.time.zone. ZoneRulesProvider
构造函数。
ZoneView - Class in javax.swing.text
ZoneView是一个View实现，它创建区域，为了显示或模型/视图转换，子视图未被创建或存储，直到它们被需要为止。
ZoneView(Element, int) - Constructor for class javax.swing.text. ZoneView
构造一个ZoneView。
zoneWasLoaded(View) - Method in class javax.swing.text. ZoneView
在加载时由区域调用。
ZOOM - Static variable in class javafx.scene.input. ZoomEvent
当用户执行缩放手势（例如拖动两根手指）时，会发生此事件。
ZOOM_FINISHED - Static variable in class javafx.scene.input. ZoomEvent
当缩放手势结束时，会发生此事件。
ZOOM_STARTED - Static variable in class javafx.scene.input. ZoomEvent
当检测到缩放手势时，会发生此事件。
ZoomEvent - Class in javafx.scene.input
缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。
ZoomEvent(Object, EventTarget, EventType<ZoomEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, double, double, PickResult) - Constructor for class javafx.scene.input. ZoomEvent
构造新的ZoomEvent事件。
ZoomEvent(EventType<ZoomEvent>, double, double, double, double, boolean, boolean, boolean, boolean, boolean, boolean, double, double, PickResult) - Constructor for class javafx.scene.input. ZoomEvent
构造具有null源和目标的新的ZoomEvent事件。
zoomProperty() - Method in class javafx.scene.web. WebView
当前缩放因子应用于整个页面内容。
zProperty() - Method in class javafx.scene.effect. Light.Point
光位置的z坐标。
zProperty() - Method in class javafx.scene.transform. Scale
定义坐标沿Z轴方向缩放的因子。
zProperty() - Method in class javafx.scene.transform. Translate
定义坐标在Z轴方向上平移的距离
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Applet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.applet

Class Applet

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Panel
          • java.applet.Applet
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible
    已知直接子类：
    JApplet
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    @Deprecated(since="9")
public class Applet
extends Panel
    一个小程序是一个小程序，它不想独立运行，而是嵌入到另一个应用程序中。

    Applet类必须是要嵌入网页或由Java Applet Viewer查看的任何小程序的超类。 Applet类提供了小应用程序与其环境之间的标准接口。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Applet.AccessibleApplet
      已过时。
      这个类实现 Applet类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Panel

        Panel.AccessibleAWTPanel

    • Field Summary

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Applet​()
      已过时。
      构建一个新的Applet。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void destroy​()
      已过时。
      由浏览器或小程序查看器调用以通知此小程序它正在被回收，并且它应该销毁其分配的任何资源。
      AccessibleContext getAccessibleContext​()
      已过时。
      获取与此Applet关联的AccessibleContext。
      AppletContext getAppletContext​()
      已过时。
      确定这个小程序的上下文，这允许小程序查询并影响它运行的环境。
      String getAppletInfo​()
      已过时。
      返回有关此小程序的信息。
      AudioClip getAudioClip​(URL url)
      已过时。
      返回由 URL参数指定的 AudioClip对象。
      AudioClip getAudioClip​(URL url, String name)
      已过时。
      返回由 URL和 name参数指定的 AudioClip对象。
      URL getCodeBase​()
      已过时。
      获取基本URL。
      URL getDocumentBase​()
      已过时。
      获取嵌入此小程序的文档的URL。
      Image getImage​(URL url)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      Image getImage​(URL url, String name)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      Locale getLocale​()
      已过时。
      获取小程序的区域设置。
      String getParameter​(String name)
      已过时。
      返回HTML标签中命名参数的值。
      String[][] getParameterInfo​()
      已过时。
      返回有关此applet可以理解的参数的信息。
      void init​()
      已过时。
      由浏览器或小程序查看器调用以通知此小程序已将其加载到系统中。
      boolean isActive​()
      已过时。
      确定此applet是否处于活动状态。
      boolean isValidateRoot​()
      已过时。
      指示此容器是否为验证根。
      static AudioClip newAudioClip​(URL url)
      已过时。
      从给定的URL获取音频剪辑。
      void play​(URL url)
      已过时。
      以指定的绝对URL播放音频剪辑。
      void play​(URL url, String name)
      已过时。
      播放给定URL的音频剪辑和与之相关的说明符。
      void resize​(int width, int height)
      已过时。
      请求这个小程序调整大小。
      void resize​(Dimension d)
      已过时。
      请求这个小程序调整大小。
      void setStub​(AppletStub stub)
      已过时。
      设置这个小程序的存根。
      void showStatus​(String msg)
      已过时。
      请求参数字符串显示在“状态窗口”中。
      void start​()
      已过时。
      由浏览器或小程序查看器调用，通知该小程序应该开始执行。
      void stop​()
      已过时。
      由浏览器或小程序查看器调用，通知该小程序应该停止其执行。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.Panel

        addNotify

    • 构造方法详细信息

      • Applet

        public Applet​()
       throws HeadlessException
        已过时。
        构建一个新的Applet。

        注意： java.applet.Applet许多方法只能在小程序完全构建后由applet调用; applet应避免在构造函数中调用java.applet.Applet中的方法。

        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • setStub

        public final void setStub​(AppletStub stub)
        已过时。
        设置这个小程序的存根。 这是由系统自动完成的。

        如果有一个安全管理器，它的checkPermission方法被调用具有AWTPermission("setAppletStub")权限，如果存根已经被设置。

        参数
        stub - 新的存根。
        异常
        SecurityException - 如果调用者不能设置存根

      • isActive

        public boolean isActive​()
        已过时。
        确定此applet是否处于活动状态。 在调用其start方法之前，小程序被标记为活动。 在调用其stop方法之前，它变为非活动状态。
        结果
        true如果小程序是活动的; 否则为false 。
        另请参见：
        start() ， stop()

      • getDocumentBase

        public URL getDocumentBase​()
        已过时。
        获取嵌入此小程序的文档的URL。 例如，假设一个小程序包含在文档中：
            http://www.oracle.com/technetwork/java/index.html
        文件基础是：
            http://www.oracle.com/technetwork/java/index.html
        结果
        包含该小程序的文档的URL 。
        另请参见：
        getCodeBase()

      • getCodeBase

        public URL getCodeBase​()
        已过时。
        获取基本URL。 这是包含该小程序的目录的URL。
        结果
        包含该小程序的目录的基座URL 。
        另请参见：
        getDocumentBase()

      • getParameter

        public String getParameter​(String name)
        已过时。
        返回HTML标签中命名参数的值。 例如，如果这个小程序被指定为
         <applet code="Clock" width=50 height=50>
 <param name=Color value="blue">
 </applet>

        那么拨打getParameter("Color")返回值为"blue" 。

        name参数不区分大小写。

        参数
        name - 参数名称。
        结果
        命名参数的值，如果没有设置， null 。

      • getAppletContext

        public AppletContext getAppletContext​()
        已过时。
        确定这个小程序的上下文，这允许小程序查询并影响它运行的环境。

        小程序的这个环境代表包含小程序的文档。

        结果
        小程序的上下文。

      • resize

        public void resize​(int width,
                   int height)
        已过时。
        请求这个小程序调整大小。
        重写：
        resize在 Component
        参数
        width - 小程序的新请求宽度。
        height - 小程序的新请求高度。

      • resize

        public void resize​(Dimension d)
        已过时。
        请求这个小程序调整大小。
        重写：
        resize在 Component
        参数
        d - 一个给出新的宽度和高度的对象。

      • isValidateRoot

        public boolean isValidateRoot​()
        已过时。
        指示此容器是否为验证根。

        Applet对象是验证根，因此，它们覆盖此方法以返回true 。

        重写：
        isValidateRoot在 Container
        结果
        true
        从以下版本开始：
        1.7
        另请参见：
        Container.isValidateRoot()

      • showStatus

        public void showStatus​(String msg)
        已过时。
        请求参数字符串显示在“状态窗口”中。 许多浏览器和小程序查看器提供了这样的窗口，应用程序可以向用户通知其当前状态。
        参数
        msg - 在状态窗口中显示的字符串。

      • getImage

        public Image getImage​(URL url)
        已过时。
        返回一个Image对象，然后可以在屏幕上绘制。 作为参数传递的url必须指定绝对URL。

        该方法始终立即返回，无论图像是否存在。 当该小程序尝试在屏幕上绘制图像时，将加载数据。 绘制图像的图形基元将逐渐在屏幕上绘制。

        参数
        url - 给出图像位置的绝对URL。
        结果
        指定网址上的图片。
        另请参见：
        Image

      • getImage

        public Image getImage​(URL url,
                      String name)
        已过时。
        返回一个Image对象，然后可以在屏幕上绘制。 url参数必须指定绝对URL。 name参数是一个相对于url参数的说明url 。

        该方法始终立即返回，无论图像是否存在。 当该小程序尝试在屏幕上绘制图像时，将加载数据。 绘制图像的图形基元将逐渐在屏幕上绘制。

        参数
        url - 给出图像基本位置的绝对URL。
        name - 图像的位置，相对于 url参数。
        结果
        指定网址上的图片。
        另请参见：
        Image

      • newAudioClip

        public static final AudioClip newAudioClip​(URL url)
        已过时。
        从给定的URL获取音频剪辑。
        参数
        url - 指向音频剪辑
        结果
        音频剪辑在指定的URL。
        从以下版本开始：
        1.2

      • getAudioClip

        public AudioClip getAudioClip​(URL url)
        已过时。
        返回由URL参数指定的AudioClip对象。

        无论音频剪辑是否存在，此方法始终立即返回。 当该小程序尝试播放音频剪辑时，将加载数据。

        参数
        url - 给出音频剪辑位置的绝对URL。
        结果
        音频剪辑在指定的URL。
        另请参见：
        AudioClip

      • getAudioClip

        public AudioClip getAudioClip​(URL url,
                              String name)
        已过时。
        返回由URL和name参数指定的AudioClip对象。

        无论音频剪辑是否存在，此方法始终立即返回。 当该小程序尝试播放音频剪辑时，将加载数据。

        参数
        url - 给出音频剪辑的基本位置的绝对URL。
        name - 音频剪辑的位置，相对于 url参数。
        结果
        音频剪辑在指定的URL。
        另请参见：
        AudioClip

      • getAppletInfo

        public String getAppletInfo​()
        已过时。
        返回有关此小程序的信息。 小程序应该覆盖此方法以返回包含关于小程序的作者，版本和版权的信息的String 。

        由Applet类提供的此方法的实现返回null 。

        结果
        一个字符串，包含有关该小程序的作者，版本和版权的信息。

      • getLocale

        public Locale getLocale​()
        已过时。
        获取小程序的区域设置。 它允许小程序保持与浏览器或appletviewer的区域设置分离的自己的区域设置。
        重写：
        getLocale在 Component
        结果
        小程序的区域; 如果没有设置语言环境，则返回默认语言环境。
        从以下版本开始：
        1.1
        另请参见：
        Component.setLocale(java.util.Locale)

      • getParameterInfo

        public String[][] getParameterInfo​()
        已过时。
        返回有关此applet可以理解的参数的信息。 一个applet应该覆盖这个方法来返回一个Strings描述这些参数的数组。

        该数组的每个元素应该是一组三个Strings包含名称，类型，和描述。 例如：

         String pinfo[][] = {
   {"fps",    "1-10",    "frames per second"},
   {"repeat", "boolean", "repeat image loop"},
   {"imgs",   "url",     "images directory"}
 };

        由Applet类提供的此方法的实现返回null 。

        结果
        一个描述该小程序查找的参数的数组。

      • play

        public void play​(URL url)
        已过时。
        以指定的绝对URL播放音频剪辑。 没有发现音频片段无法找到。
        参数
        url - 给出音频剪辑位置的绝对URL。

      • play

        public void play​(URL url,
                 String name)
        已过时。
        播放给定URL的音频剪辑和与之相关的说明符。 没有发现音频片段无法找到。
        参数
        url - 给出音频剪辑的基本位置的绝对URL。
        name - 音频剪辑的位置，相对于 url参数。

      • init

        public void init​()
        已过时。
        由浏览器或小程序查看器调用以通知此小程序已将其加载到系统中。 在第一次调用start方法之前总是调用它。

        Applet的子类如果具有初始化要执行， Applet应该覆盖此方法。 例如，具有线程的小程序将使用init方法来创建线程和destroy方法来杀死它们。

        由Applet类提供的这种方法的实现什么都不做。

        另请参见：
        destroy() ，
start() ，
stop()

      • start

        public void start​()
        已过时。
        由浏览器或小程序查看器调用，通知该小程序应该开始执行。 它是在init方法之后调用的，每次在网页中重新访问applet。

        如果Applet的子类在每次访问包含它的网页时都需要执行任何操作，则应重写此方法。 例如，具有动画的小程序可能想要使用start方法来恢复动画，而stop方法可能会暂停动画。

        注意：一些方法，如getLocationOnScreen ，只有在小程序显示时才能提供有意义的结果。 因为isShowing false当小程序的start被首先调用时，需要isShowing返回true应该从一个ComponentListener 。

        由Applet类提供的这种方法的实现什么都不做。

        另请参见：
        destroy() ，
init() ，
stop() ，
Component.isShowing() ，
ComponentListener.componentShown(java.awt.event.ComponentEvent)

      • stop

        public void stop​()
        已过时。
        由浏览器或小程序查看器调用，通知该小程序应该停止其执行。 当包含该小程序的网页已被另一个页面替换时，也就是在小程序被销毁之前被调用。

        Applet的子类应该覆盖此方法，如果它有任何操作，它希望执行每次包含它的网页不再可见。 例如，具有动画的小程序可能想要使用start方法来恢复动画，以及stop方法来暂停动画。

        由Applet类提供的这种方法的实现什么都不做。

        另请参见：
        destroy() ， init()

      • destroy

        public void destroy​()
        已过时。
        由浏览器或小程序查看器调用以通知此小程序它正在被回收，并且它应该销毁其分配的任何资源。 stop方法将始终在destroy之前destroy 。

        如果Applet的子类在它被破坏之前要执行任何操作，应该覆盖此方法。 例如，具有线程的小程序将使用init方法来创建线程和destroy方法来杀死它们。

        由Applet类提供的这种方法的实现什么都不做。

        另请参见：
        init() ，
start() ，
stop()

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        已过时。
        获取与此Applet关联的AccessibleContext。 对于applet，AccessibleContext采用AccessibleApplet的形式。 如有必要，将创建一个新的AccessibleApplet实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Panel
        结果
        一个AccessibleApplet，作为这个Applet的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Applet.AccessibleApplet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.applet

Class Applet.AccessibleApplet

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    已知直接子类：
    JApplet.AccessibleJApplet
    Enclosing class:
    Applet

    protected class Applet.AccessibleApplet
extends Panel.AccessibleAWTPanel
    该类实现Applet类的可访问性支持。 它提供了适用于applet用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleApplet​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, removePropertyChangeListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleApplet

        protected AccessibleApplet​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Panel.AccessibleAWTPanel
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态。
        重写：
        getAccessibleStateSet在 Component.AccessibleAWTComponent
        结果
        包含对象的当前状态集的AccessibleStateSet实例
        另请参见：
        AccessibleState
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppletContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.applet

Interface AppletContext

  • 已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    @Deprecated(since="9")
public interface AppletContext
    该接口对应于小程序的环境：文档包含同一文档中的小程序和其他小程序。

    该接口中的方法可以由小程序用于获取有关其环境的信息。

    从以下版本开始：
    1.0

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      Applet getApplet​(String name)
      已过时。
      找到并返回由该applet上下文表示的文档中的applet，该文件具有给定的名称。
      Enumeration<Applet> getApplets​()
      已过时。
      查找由该applet上下文表示的文档中的所有applet。
      AudioClip getAudioClip​(URL url)
      已过时。
      创建音频剪辑。
      Image getImage​(URL url)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      InputStream getStream​(String key)
      已过时。
      返回指定键在此applet上下文中相关联的流。
      Iterator<String> getStreamKeys​()
      已过时。
      在此applet上下文中查找流的所有键。
      void setStream​(String key, InputStream stream)
      已过时。
      将指定的流与此applet上下文中的指定关键字相关联。
      void showDocument​(URL url)
      已过时。
      请求浏览器或小程序查看器显示由 url参数指示的 url 。
      void showDocument​(URL url, String target)
      已过时。
      请求浏览器或小程序查看器显示由 url参数指示的 url 。
      void showStatus​(String status)
      已过时。
      请求参数字符串显示在“状态窗口”中。

    • 方法详细信息

      • getAudioClip

        AudioClip getAudioClip​(URL url)
        已过时。
        创建音频剪辑。
        参数
        url - 给出音频剪辑位置的绝对URL。
        结果
        音频剪辑在指定的URL。

      • getImage

        Image getImage​(URL url)
        已过时。
        返回一个Image对象，然后可以在屏幕上绘制。 作为参数传递的参数url必须指定绝对URL。

        该方法始终立即返回，无论图像是否存在。 当小程序尝试在屏幕上绘制图像时，将加载数据。 绘制图像的图形基元将逐渐在屏幕上绘制。

        参数
        url - 给出图像位置的绝对URL。
        结果
        指定网址上的图片。
        另请参见：
        Image

      • getApplet

        Applet getApplet​(String name)
        已过时。
        找到并返回由该applet上下文表示的文档中的applet，该文件具有给定的名称。 可以通过设置name属性在HTML标签中设置该name 。
        参数
        name - 一个小程序名称。
        结果
        具有给定名称的小程序，或者如果没有找到， null 。

      • getApplets

        Enumeration<Applet> getApplets​()
        已过时。
        查找由该applet上下文表示的文档中的所有applet。
        结果
        在该applet上下文中表示的文档中的所有applet的枚举。

      • showDocument

        void showDocument​(URL url)
        已过时。
        请求浏览器或小程序查看器显示由url参数指示的url 。 浏览器或小程序查看器确定显示网页的窗口或框架。 此方法可能会被不是浏览器的小程序上下文忽略。
        参数
        url - 给出文档位置的绝对URL。

      • showDocument

        void showDocument​(URL url,
                  String target)
        已过时。
        请求浏览器或小程序查看器显示由url参数指示的url 。 target参数表示要在哪个HTML框架中显示文档。 目标参数解释如下： Target arguments and their descriptions Target Argument Description "_self" Show in the window and frame that contain the applet. "_parent" Show in the applet's parent frame. If the applet's frame has no parent frame, acts the same as "_self". "_top" Show in the top-level frame of the applet's window. If the applet's frame is the top-level frame, acts the same as "_self". "_blank" Show in a new, unnamed top-level window. name Show in the frame or window named name. If a target named name does not already exist, a new top-level window with the specified name is created, and the document is shown there.

        小程序查看器或浏览器可以随意忽略showDocument 。

        参数
        url - 给出文档位置的绝对URL。
        target - 一个 String指示在哪里显示页面。

      • showStatus

        void showStatus​(String status)
        已过时。
        请求参数字符串显示在“状态窗口”中。 许多浏览器和小程序查看器提供了这样的窗口，应用程序可以向用户通知其当前状态。
        参数
        status - 在状态窗口中显示的字符串。

      • setStream

        void setStream​(String key,
               InputStream stream)
        throws IOException
        已过时。
        将指定的流与此applet上下文中的指定关键字相关联。 如果小程序上下文之前包含该键的映射，则替换旧值。

        出于安全考虑，每个代码库都存在流和键映射。 换句话说，来自一个代码库的applet无法访问由一个applet从不同的代码库创建的流

        参数
        key - 指定值与之关联的键。
        stream - 与指定键相关联的流。 如果此参数为null ，则在此Applet上下文中将删除指定的键。
        异常
        IOException - 如果流大小超过一定大小限制。 大小限制由此界面的实现者决定。
        从以下版本开始：
        1.4

      • getStream

        InputStream getStream​(String key)
        已过时。
        返回指定键在此applet上下文中相关联的流。 如果该小程序上下文不包含此密钥的流，则返回null 。

        出于安全考虑，每个代码库都存在流和键映射。 换句话说，来自一个代码库的applet无法访问由一个applet从不同的代码库创建的流

        参数
        key - 其关联流将要返回的密钥。
        结果
        该applet上下文映射关键字的流
        从以下版本开始：
        1.4

      • getStreamKeys

        Iterator<String> getStreamKeys​()
        已过时。
        在此applet上下文中查找流的所有键。

        出于安全考虑，每个代码库都存在流和键映射。 换句话说，来自一个代码库的applet无法访问由一个applet从不同的代码库创建的流

        结果
        这个applet上下文中流的所有名称的迭代器。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppletStub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.applet

Interface AppletStub

  • 已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    @Deprecated(since="9")
public interface AppletStub
    当一个小程序第一次创建时，applet存根使用小程序的setStub方法附加到它。 此存根用作应用程序正在运行的小程序和浏览器环境或小程序查看器环境之间的接口。
    从以下版本开始：
    1.0
    另请参见：
    Applet.setStub(java.applet.AppletStub)

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void appletResize​(int width, int height)
      已过时。
      当applet想要调整大小时调用。
      AppletContext getAppletContext​()
      已过时。
      返回小程序的上下文。
      URL getCodeBase​()
      已过时。
      获取基本URL。
      URL getDocumentBase​()
      已过时。
      获取嵌入小程序的文档的URL。
      String getParameter​(String name)
      已过时。
      返回HTML标签中命名参数的值。
      boolean isActive​()
      已过时。
      确定小程序是否处于活动状态。

    • 方法详细信息

      • isActive

        boolean isActive​()
        已过时。
        确定小程序是否处于活动状态。 一个小程序在其start方法被调用之前是活动的。 在它的stop方法被调用之前它变得不活动。
        结果
        true如果小程序是活动的; false否则。

      • getDocumentBase

        URL getDocumentBase​()
        已过时。
        获取嵌入小程序的文档的URL。 例如，假设一个小程序包含在文档中：
            http://www.oracle.com/technetwork/java/index.html
        文件基础是：
            http://www.oracle.com/technetwork/java/index.html
        结果
        包含该小程序的文档的URL 。
        另请参见：
        getCodeBase()

      • getCodeBase

        URL getCodeBase​()
        已过时。
        获取基本URL。 这是包含小程序的目录的URL。
        结果
        包含该小程序的目录的基座URL 。
        另请参见：
        getDocumentBase()

      • getParameter

        String getParameter​(String name)
        已过时。
        返回HTML标签中命名参数的值。 例如，如果一个小程序被指定为
         <applet code="Clock" width=50 height=50>
 <param name=Color value="blue">
 </applet>

        那么拨打getParameter("Color")返回值"blue" 。

        参数
        name - 参数名称。
        结果
        命名参数的值，如果未设置， null 。

      • getAppletContext

        AppletContext getAppletContext​()
        已过时。
        返回小程序的上下文。
        结果
        小程序的上下文。

      • appletResize

        void appletResize​(int width,
                  int height)
        已过时。
        当applet想要调整大小时调用。
        参数
        width - 小程序的新请求宽度。
        height - 小程序的新请求高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AudioClip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.applet

Interface AudioClip

  • 已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    @Deprecated(since="9")
public interface AudioClip
    AudioClip界面是播放声音剪辑的简单抽象。 多个AudioClip项目可以同时播放，并将产生的声音混合在一起以产生复合。
    从以下版本开始：
    1.0

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void loop​()
      已过时。
      开始循环播放此音频剪辑。
      void play​()
      已过时。
      开始播放此音频剪辑。
      void stop​()
      已过时。
      停止播放此音频剪辑。

    • 方法详细信息

      • play

        void play​()
        已过时。
        开始播放此音频剪辑。 每次调用此方法时，剪辑将从头开始重新启动。

      • loop

        void loop​()
        已过时。
        开始循环播放此音频剪辑。

      • stop

        void stop​()
        已过时。
        停止播放此音频剪辑。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.applet (Java SE 9 & JDK 9 )

java.applet

Interfaces

  • AppletContext
  • AppletStub
  • AudioClip

Classes

  • Applet


java.applet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.applet

提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。

小程序框架涉及两个实体： 小程序和小程序上下文 。 小程序是一个可嵌入的窗口（请参阅Panel类），其中包含一些额外的方法，该小程序上下文可用于初始化，启动和停止该小程序。

小程序上下文是负责加载和运行小程序的应用程序。 例如，小程序上下文可以是Web浏览器或小程序开发环境。

此包中的API都已弃用。 应该使用替代技术，如Java Web Start或可安装的应用程序。 有关详细信息，请参阅JEP 289和Oracle白皮书"Migrating from Java Applets to plugin-free Java technologies" 。

从以下版本开始：
1.0
  • 接口摘要
    接口 描述
    AppletContext Deprecated.
    Applet API已被弃用。
    AppletStub Deprecated.
    Applet API已被弃用。
    AudioClip Deprecated.
    Applet API已被弃用。
  • 类摘要
    Class 描述
    Applet Deprecated.
    Applet API已被弃用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.applet Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.applet

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet

Interface Hierarchy

  • java.applet.AppletContext
  • java.applet.AppletStub
  • java.applet.AudioClip
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Package java.applet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.applet

  • Packages that use java.applet
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使程序员可以将其用作全功能对象请求代理（ORB）。
  • Classes in java.applet used by java.applet
    Class 描述
    Applet
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    AppletContext
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    AppletStub
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    AudioClip
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
  • Classes in java.applet used by java.beans
    Class 描述
    Applet
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
  • Classes in java.applet used by javax.swing
    Class 描述
    Applet
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    Applet.AccessibleApplet
    已过时。
    这个类实现 Applet类的可访问性支持。
  • Classes in java.applet used by netscape.javascript
    Class 描述
    Applet
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
  • Classes in java.applet used by org.omg.CORBA
    Class 描述
    Applet
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.applet.Applet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.applet.Applet

  • Packages that use Applet
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能的对象请求代理（ORB）。

    • Uses of Applet in java.applet

      Methods in java.applet that return Applet
      Modifier and Type 方法 描述
      Applet AppletContext.getApplet​(String name)
      已过时。
      找到并返回由该applet上下文表示的文档中的applet，该文件具有给定的名称。
      Methods in java.applet that return types with arguments of type Applet
      Modifier and Type 方法 描述
      Enumeration<Applet> AppletContext.getApplets​()
      已过时。
      查找由该applet上下文表示的文档中的所有applet。

    • Uses of Applet in java.beans

      Methods in java.beans with parameters of type Applet
      Modifier and Type 方法 描述
      void AppletInitializer.activate​(Applet newApplet)
      已过时。
      激活，和/或标记Applet活动。
      void AppletInitializer.initialize​(Applet newAppletBean, BeanContext bCtxt)
      已过时。
      如果传递给java.beans.Beans.instantiate的相应变体，则将调用此方法，以便将新实例化的Applet（JavaBean）与其AppletContext，AppletStub和Container关联。

    • Uses of Applet in javax.swing

      Subclasses of Applet in javax.swing
      Modifier and Type Class 描述
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      Methods in javax.swing with parameters of type Applet
      Modifier and Type 方法 描述
      void RepaintManager.addDirtyRegion​(Applet applet, int x, int y, int w, int h)
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of Applet in netscape.javascript

      Methods in netscape.javascript with parameters of type Applet
      Modifier and Type 方法 描述
      static JSObject JSObject.getWindow​(Applet applet)
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of Applet in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type Applet
      Modifier and Type 方法 描述
      static ORB ORB.init​(Applet app, Properties props)
      为一个小程序创建一个新的 ORB实例。
      protected abstract void ORB.set_parameters​(Applet app, Properties props)
      允许使用给定的小程序和参数初始化ORB实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.applet.Applet.AccessibleApplet (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.applet.Applet.AccessibleApplet

  • Packages that use Applet.AccessibleApplet
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Applet.AccessibleApplet in javax.swing

      Subclasses of Applet.AccessibleApplet in javax.swing
      Modifier and Type Class 描述
      protected class  JApplet.AccessibleJApplet
      已过时。
      该类为 JApplet类实现可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.applet.AppletContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.applet.AppletContext

  • Packages that use AppletContext
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。

    • Uses of AppletContext in java.applet

      Methods in java.applet that return AppletContext
      Modifier and Type 方法 描述
      AppletContext Applet.getAppletContext​()
      已过时。
      确定这个小程序的上下文，这允许小程序查询并影响它运行的环境。
      AppletContext AppletStub.getAppletContext​()
      已过时。
      返回小程序的上下文。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.applet.AppletStub (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.applet.AppletStub

  • Packages that use AppletStub
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。

    • Uses of AppletStub in java.applet

      Methods in java.applet with parameters of type AppletStub
      Modifier and Type 方法 描述
      void Applet.setStub​(AppletStub stub)
      已过时。
      设置这个小程序的存根。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.applet.AudioClip (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.applet.AudioClip

  • Packages that use AudioClip
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。

    • Uses of AudioClip in java.applet

      Methods in java.applet that return AudioClip
      Modifier and Type 方法 描述
      AudioClip Applet.getAudioClip​(URL url)
      已过时。
      返回由 URL参数指定的 AudioClip对象。
      AudioClip Applet.getAudioClip​(URL url, String name)
      已过时。
      返回由 URL和 name参数指定的 AudioClip对象。
      AudioClip AppletContext.getAudioClip​(URL url)
      已过时。
      创建音频剪辑。
      static AudioClip Applet.newAudioClip​(URL url)
      已过时。
      从给定的URL获取音频剪辑。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ActiveEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface ActiveEvent

  • 所有已知实现类：
    InvocationEvent

    public interface ActiveEvent
    一个知道如何发送自己的事件的界面。 通过实现此接口，可以在事件队列上放置一个事件，并在使用EventDispatchThread分派事件时调用其dispatch()方法。

    这是避免死锁的非常有用的机制。 如果一个线程在关键部分执行（即，它已经进入一个或多个监视器），调用其他同步代码可能会导致死锁。 为了避免潜在的死锁，可以创建一个ActiveEvent以便稍后运行第二部分代码。 如果显示器上存在争用，则第二个线程将简单地阻止，直到第一个线程完成其工作并退出其监视器。

    出于安全考虑，通常希望使用ActiveEvent避免从关键线程调用不受信任的代码。 例如，对等实现可以使用此功能来避免从系统线程调用用户代码。 这样做避免了潜在的僵局和拒绝服务攻击。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dispatch​()
      将事件发送到其目标，事件源的侦听器，或执行此事件应该做的任何事情。

    • 方法详细信息

      • dispatch

        void dispatch​()
        将事件发送到其目标，事件源的侦听器，或执行此事件应该做的任何事情。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Adjustable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface Adjustable

  • 所有已知实现类：
    JScrollBar ， JScrollPane.ScrollBar ， Scrollbar ， ScrollPaneAdjustable

    public interface Adjustable
    具有可调整数值的对象的界面包含在有限范围内的值。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int HORIZONTAL
      表示 Adjustable具有水平方向。
      static int NO_ORIENTATION
      表示 Adjustable没有方向。
      static int VERTICAL
      表示 Adjustable具有垂直方向。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addAdjustmentListener​(AdjustmentListener l)
      添加一个监听器，以便在可调整对象的值更改时接收调整事件。
      int getBlockIncrement​()
      获取可调整对象的块值增量。
      int getMaximum​()
      获取可调整对象的最大值。
      int getMinimum​()
      获取可调整对象的最小值。
      int getOrientation​()
      获取可调对象的方向。
      int getUnitIncrement​()
      获取可调整对象的单位增量。
      int getValue​()
      获取可调整对象的当前值。
      int getVisibleAmount​()
      获取比例指示器的长度。
      void removeAdjustmentListener​(AdjustmentListener l)
      删除调整监听器。
      void setBlockIncrement​(int b)
      设置可调整对象的块值增量。
      void setMaximum​(int max)
      设置可调整对象的最大值。
      void setMinimum​(int min)
      设置可调整对象的最小值。
      void setUnitIncrement​(int u)
      设置可调整对象的单位值增量。
      void setValue​(int v)
      设置可调对象的当前值。
      void setVisibleAmount​(int v)
      设置可调整对象的比例指示器的长度。

    • 字段详细信息

      • HORIZONTAL

        @Native
static final int HORIZONTAL
        表示 Adjustable具有水平方向。
        另请参见：
        Constant Field Values

      • VERTICAL

        @Native
static final int VERTICAL
        表示 Adjustable具有垂直方向。
        另请参见：
        Constant Field Values

      • NO_ORIENTATION

        @Native
static final int NO_ORIENTATION
        表示 Adjustable没有方向。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getOrientation

        int getOrientation​()
        获取可调对象的方向。
        结果
        可调对象的方向; 任一HORIZONTAL ， VERTICAL ，或NO_ORIENTATION

      • setMinimum

        void setMinimum​(int min)
        设置可调整对象的最小值。
        参数
        min - 最小值

      • getMinimum

        int getMinimum​()
        获取可调整对象的最小值。
        结果
        可调整对象的最小值

      • setMaximum

        void setMaximum​(int max)
        设置可调整对象的最大值。
        参数
        max - 最大值

      • getMaximum

        int getMaximum​()
        获取可调整对象的最大值。
        结果
        可调整对象的最大值

      • setUnitIncrement

        void setUnitIncrement​(int u)
        设置可调整对象的单位值增量。
        参数
        u - 单位增量

      • getUnitIncrement

        int getUnitIncrement​()
        获取可调整对象的单位增量。
        结果
        可调整对象的单位值增量

      • setBlockIncrement

        void setBlockIncrement​(int b)
        设置可调整对象的块值增量。
        参数
        b - 块增量

      • getBlockIncrement

        int getBlockIncrement​()
        获取可调整对象的块值增量。
        结果
        可调整对象的块值增量

      • setVisibleAmount

        void setVisibleAmount​(int v)
        设置可调整对象的比例指示器的长度。
        参数
        v - 指示器的长度

      • getVisibleAmount

        int getVisibleAmount​()
        获取比例指示器的长度。
        结果
        比例指标的长度

      • setValue

        void setValue​(int v)
        设置可调对象的当前值。 如果提供的值小于minimum或大于maximum - visibleAmount ，那么根据需要替换其中一个值。

        调用此方法不会触发AdjustmentEvent 。

        参数
        v - 当前值，介于 minimum和 maximum之间 - visibleAmount

      • getValue

        int getValue​()
        获取可调整对象的当前值。
        结果
        可调整对象的当前值

      • addAdjustmentListener

        void addAdjustmentListener​(AdjustmentListener l)
        添加一个监听器，以便在可调整对象的值更改时接收调整事件。
        参数
        l - 接收事件的侦听器
        另请参见：
        AdjustmentEvent

      • removeAdjustmentListener

        void removeAdjustmentListener​(AdjustmentListener l)
        删除调整监听器。
        参数
        l - 被删除的侦听器
        另请参见：
        AdjustmentEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AlphaComposite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class AlphaComposite

  • java.lang.Object
    • java.awt.AlphaComposite
  • All Implemented Interfaces:
    Composite

    public final class AlphaComposite
extends Object
implements Composite
    AlphaComposite类实现了基本的alpha合成规则，用于组合源和目标颜色，以实现图形和图像的混合和透明效果。 该类实施的具体规则是T.Porter和T.Duff在“Compositing Digital Images”，SIGGRAPH 84,253-259中描述的12个规则的基本集合。 本文档的其余部分假定您熟悉该文章中概述的定义和概念。

    该类扩展了由波特和达夫定义的标准方程，以包括一个附加因素。 AlphaComposite类的实例可以包含一个Alpha值，用于在混合方程中使用之前修改每个源像素的不透明度或覆盖率。

    重要的是要注意，由波特和达夫纸定义的方程式都被定义为对由其对应的α分量预乘的颜色分量进行操作。 由于ColorModel和Raster类允许以预Raster或非预乘式形式存储像素数据，因此在应用方程式之前，所有输入数据必须归一化为预乘方式，并且所有结果可能需要调整回目标所需的格式在存储像素值之前。

    还要注意，这个类只定义了纯粹数学意义上的颜色和alpha值的组合方程式。 其方程的准确应用取决于数据从其来源检索并存储在其目的地的方式。 详见Implementation Caveats 。

    Porter和Duff论文中的混合方程的描述中使用了以下因素：

    Factors
    Factor | Definition
    As | the alpha component of the source pixel
    Cs | a color component of the source pixel in premultiplied form
    Ad | the alpha component of the destination pixel
    Cd | a color component of the destination pixel in premultiplied form
    Fs | the fraction of the source pixel that contributes to the output
    Fd | the fraction of the destination pixel that contributes to the output
    Ar | the alpha component of the result
    Cr | a color component of the result in premultiplied form

    使用这些因素，Porter和Duff定义了12种选择混合因子F s和F d以产生12种期望的视觉效果的方式。 用于确定F s和F d的方程式在指定视觉效果的12个静态场的描述中给出。 例如， SRC_OVER的描述规定F s = 1和F d =（1- A s ）。 一旦确定混合因子的一组方程是已知的，则可以使用以下一组方程将其应用于每个像素以产生结果：

      Fs = f(Ad)
      Fd = f(As)
      Ar = As*Fs + Ad*Fd
      Cr = Cs*Fs + Cd*Fd

    以下因素将用于讨论我们在波特和达夫论文中对混合方程的扩展：

    Factors
    Factor | Definition
    Csr | one of the raw color components of the source pixel
    Cdr | one of the raw color components of the destination pixel
    Aac | the "extra" alpha component from the AlphaComposite instance
    Asr | the raw alpha component of the source pixel
    Adr | the raw alpha component of the destination pixel
    Adf | the final alpha component stored in the destination
    Cdf | the final raw color component stored in the destination

    准备输入

    AlphaComposite类定义了应用于源alpha的附加alpha值。 应用这个值，就好像一个隐含的SRC_IN规则首先通过将原始源alpha和原始源颜色乘以AlphaComposite中的alpha来将其应用于具有指示的alpha的像素的源像素。 这导致了用于生成波特和Duff混合方程中使用的α的以下等式：

      As = Asr * Aac
    所有原始源颜色组件需要乘以AlphaComposite实例中的alpha。 另外，如果源不是预乘式形式，则颜色分量也需要乘以源alpha。 因此，用于产生Porter和Duff方程的源颜色分量的方程取决于源像素是否是预乘法的：
      Cs = Csr * Asr * Aac     (if source is not premultiplied)
      Cs = Csr * Aac           (if source is premultiplied)
    不需要对目的地alpha进行调整：
      Ad = Adr

    目的色组件只有在不是预加载形式时才需要调整：

      Cd = Cdr * Ad    (if destination is not premultiplied)
      Cd = Cdr         (if destination is premultiplied)

    应用混合方程

    调整后的A s ， A d ， C s和C d用于标准Porter和Duff方程中，以计算混合因子F s和F d ，然后计算得到的预乘分量A r和C r 。

    准备结果

    如果要将其存储回保存未预乘数据的目标缓冲区，则使用以下等式，才需要调整结果：

      Adf = Ar
      Cdf = Cr                 (if dest is premultiplied)
      Cdf = Cr / Ar            (if dest is not premultiplied)
    请注意，由于如果所得到的alpha为零，则除法是未定义的，因此省略了这种情况下的划分，以避免“除以零”，并将颜色分量保留为全零。

    绩效注意事项

    由于性能的原因，优选的是Raster传递给对象compose一个的方法CompositeContext由所创建的对象AlphaComposite类已经预乘数据。 然而，如果源Raster或目的地Raster不是预乘，则在合成操作之前和之后执行适当的转换。

    Implementation Caveats

    • 许多来源，例如BufferedImage类中列出的一些不透明图像类型，不会为其像素存储alpha值。 这些资源为其所有像素提供了一个1.0的alpha。
    • 许多目的地也没有地方存储由这个类执行的混合计算产生的alpha值。 因此，这样的目的地隐含地丢弃了该类产生的所得到的alpha值。 建议这样的目的地应将其存储的颜色值视为非预乘数，并在存储颜色值和舍弃Alpha值之前将所得到的颜色值除以所得到的alpha值。
    • 结果的准确性取决于像素在目的地中的存储方式。 每种颜色和alpha组件提供至少8位存储的图像格式至少足以用作几到十几个合成操作的序列的目的地。 在舍入误差占主导地位的情况下，每个组件的存储容量少于8位的映像格式在一个或两个合成操作中的用途有限。 不分开存储颜色分量的图像格式不是任何类型的半透明混合的好选择。 例如， BufferedImage.TYPE_BYTE_INDEXED不应该用作混合操作的目的地，因为每个操作都可能引入大的错误，因为需要从受限的调色板中选择一个像素以匹配混合方程的结果。
    • 几乎所有格式都将像素作为离散整数存储，而不是上述参考方程式中使用的浮点值。 该实现可以将整数像素值缩放到范围为0.0到1.0的浮点值，或者使用完全在整数域中操作的等式的稍微修改后的版本，并且产生与参考方程式的类似结果。

      通常，整数值与浮点值相关，使得整数0等于浮点值0.0和整数2 ^ n -1（其中n是表示中的位数）等于1.0。 对于8位表示，这意味着0x00表示0.0，0xff表示1.0。

    • 内部实现可以近似一些方程，并且还可以消除一些步骤以避免不必要的操作。 例如，考虑使用非预乘α值的离散整数图像，每个组件使用8位存储。 几乎透明的黑色红色的存储值可能是：
        (A, R, G, B) = (0x01, 0xb0, 0x00, 0x00)

      如果正在使用整数数学，并且这个值在SRC模式下被合成，没有额外的alpha，则数学将表明结果是（整数格式）：

        (A, R, G, B) = (0x01, 0x01, 0x00, 0x00)

      请注意，始终处于预乘形式的中间值只允许整数红色分量为0x00或0x01。 当我们尝试将这个结果存储回到不预乘的目的地时，除去alpha将给我们非常多的红色值的选择很少。 在这种情况下，在没有快捷方式的情况下执行整数空间的数学的实现可能最终得到以下的最终像素值：

        (A, R, G, B) = (0x01, 0xff, 0x00, 0x00)

      （请注意，0x01除以0x01给出1.0，这相当于8位存储格式的值0xff）

      或者，使用浮点数学的实现可以产生更准确的结果，并且最终返回到原始像素值，几乎没有（如果有的话）舍入误差。 或者，使用整数数学的实现可能会决定，如果在浮点空间中执行时，方程式可以转换为颜色值上的虚拟NOP，则可以将不受影响的像素传输到目标位置，并完全避免所有的数学运算。

      这些实现都试图遵循相同的方程，但是使用整数和浮点数学以及简化或全方程的不同权衡。 为了解决这种差异，最好只期望结果的预乘形式在实现和图像格式之间匹配。 在这种情况下，以预乘方式表达的两个答案将等同于：

        (A, R, G, B) = (0x01, 0x01, 0x00, 0x00)

      所以他们都会相配。

    • 由于简化计算效率的方程式的技术，当在非预乘的目的地遇到0.0的结果α值时，一些实现可能会不同。 请注意，如果分母（α）为0，则在SRC规则的情况下，通过alpha删除除法的简化在技术上是无效的。但是，由于只有在以预乘方式查看结果时，才应该预期结果是准确的， α的α基本上使得所得到的颜色成分无关紧要，因此在这种情况下不应期待确切的行为。
    另请参见：
    Composite ， CompositeContext

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static AlphaComposite Clear
      AlphaComposite对象实现不透明的CLEAR规则，其alpha为1.0f。
      static int CLEAR
      目的地的颜色和alpha都被清除（Porter-Duff Clear规则）。
      static AlphaComposite Dst
      AlphaComposite对象实现不透明的DST规则，其alpha为1.0f。
      static int DST
      目的地保持不变（Porter-Duff目的地规则）。
      static int DST_ATOP
      位于源头的目的地的一部分在源上合成，并替换目的地（Porter-Duff Destination Atop Source规则）。
      static int DST_IN
      位于源代码内的目的地部分将替换目的地（Porter-Duff Destination In Source规则）。
      static int DST_OUT
      位于源代码之外的目的地的一部分将替换目的地（Porter-Duff Destination Held Out By Source规则）。
      static int DST_OVER
      目的地在源上合成，结果将替换目的地（Porter-Duff Destination Over Source规则）。
      static AlphaComposite DstAtop
      AlphaComposite对象实现不透明的DST_ATOP规则，其alpha为1.0f。
      static AlphaComposite DstIn
      AlphaComposite对象实现不透明的DST_IN规则，其alpha为1.0f。
      static AlphaComposite DstOut
      AlphaComposite对象实现不透明的DST_OUT规则，其alpha为1.0f。
      static AlphaComposite DstOver
      AlphaComposite对象实现不透明的DST_OVER规则，alpha为1.0f。
      static AlphaComposite Src
      AlphaComposite对象实现不透明的SRC规则，其alpha为1.0f。
      static int SRC
      源被复制到目的地（Porter-Duff源规则）。
      static int SRC_ATOP
      位于目的地内部的源的部分被合成到目的地（Porter-Duff Source Atop Destination rule）上。
      static int SRC_IN
      位于目的地内部的源的部分替换目的地（目的地规则中的波特 - 达夫源）。
      static int SRC_OUT
      位于目的地外部的源的部分取代了目的地（Porter-Duff Source Held Out By Destination规则）。
      static int SRC_OVER
      源在目的地（Porter-Duff Source Over Destination规则）上合成。
      static AlphaComposite SrcAtop
      AlphaComposite对象实现的alpha值为1.0f的不透明的SRC_ATOP规则。
      static AlphaComposite SrcIn
      AlphaComposite对象实现了一个alpha为1.0f的不透明的SRC_IN规则。
      static AlphaComposite SrcOut
      AlphaComposite对象实现不透明的SRC_OUT规则，alpha为1.0f。
      static AlphaComposite SrcOver
      AlphaComposite对象实现不透明的SRC_OVER规则，alpha为1.0f。
      static AlphaComposite Xor
      AlphaComposite对象实现的不透明XOR规则的alpha为1.0f。
      static int XOR
      位于目的地外部的源的部分与位于源外的目标的部分（Porter-Duff Source Xor Destination rule）组合。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CompositeContext createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建合成操作的上下文。
      AlphaComposite derive​(float alpha)
      返回一个使用指定的alpha值的类似的 AlphaComposite对象。
      AlphaComposite derive​(int rule)
      返回类似的 AlphaComposite对象，该对象使用指定的合成规则。
      boolean equals​(Object obj)
      确定指定的对象是否等于此 AlphaComposite 。
      float getAlpha​()
      返回此 AlphaComposite的alpha值。
      static AlphaComposite getInstance​(int rule)
      使用指定的规则创建一个 AlphaComposite对象。
      static AlphaComposite getInstance​(int rule, float alpha)
      使用指定的规则创建一个 AlphaComposite对象，并将常量alpha与源的alpha进行乘法。
      int getRule​()
      返回此 AlphaComposite的合成规则。
      int hashCode​()
      返回此复合的哈希码。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • CLEAR

        @Native
public static final int CLEAR
        目的地的颜色和alpha都被清除（Porter-Duff Clear规则）。 源和目的地都不用作输入。

        F s = 0， F d = 0，因此：

          Ar = 0
  Cr = 0
        另请参见：
        Constant Field Values

      • SRC

        @Native
public static final int SRC
        源被复制到目的地（Porter-Duff源规则）。 目的地不用作输入。

        F s = 1， F d = 0，因此：

          Ar = As
  Cr = Cs
        另请参见：
        Constant Field Values

      • DST

        @Native
public static final int DST
        目的地保持不变（Porter-Duff目的地规则）。

        F s = 0且F d = 1，因此：

          Ar = Ad
  Cr = Cd
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • SRC_OVER

        @Native
public static final int SRC_OVER
        源在目的地（Porter-Duff Source Over Destination规则）上合成。

        F s = 1， F d =（1- A s ），因此：

          Ar = As + Ad*(1-As)
  Cr = Cs + Cd*(1-As)
        另请参见：
        Constant Field Values

      • DST_OVER

        @Native
public static final int DST_OVER
        目的地在源上合成，结果将替换目的地（Porter-Duff Destination Over Source规则）。

        F s =（1- A d ）和F d = 1，因此：

          Ar = As*(1-Ad) + Ad
  Cr = Cs*(1-Ad) + Cd
        另请参见：
        Constant Field Values

      • SRC_IN

        @Native
public static final int SRC_IN
        位于目的地内部的源的部分替换目的地（目的地规则中的波特 - 达夫源）。

        F s = A d ， F d = 0，因此：

          Ar = As*Ad
  Cr = Cs*Ad
        另请参见：
        Constant Field Values

      • DST_IN

        @Native
public static final int DST_IN
        位于源代码内的目的地部分将替换目的地（Porter-Duff Destination In Source规则）。

        F s = 0， F d = A s ，因此：

          Ar = Ad*As
  Cr = Cd*As
        另请参见：
        Constant Field Values

      • SRC_OUT

        @Native
public static final int SRC_OUT
        位于目的地外部的源的部分取代了目的地（Porter-Duff Source Held Out By Destination规则）。

        F s =（1- A d ）， F d = 0，因此：

          Ar = As*(1-Ad)
  Cr = Cs*(1-Ad)
        另请参见：
        Constant Field Values

      • DST_OUT

        @Native
public static final int DST_OUT
        位于源代码之外的目的地的一部分将替换目的地（Porter-Duff Destination Held Out By Source规则）。

        F s = 0， F d =（1- A s ），因此：

          Ar = Ad*(1-As)
  Cr = Cd*(1-As)
        另请参见：
        Constant Field Values

      • SRC_ATOP

        @Native
public static final int SRC_ATOP
        位于目的地内部的源的部分被合成到目的地（Porter-Duff Source Atop Destination rule）上。

        F s = A d和F d =（1- A s ），因此：

          Ar = As*Ad + Ad*(1-As) = Ad
  Cr = Cs*Ad + Cd*(1-As)
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DST_ATOP

        @Native
public static final int DST_ATOP
        位于源头的目的地的一部分在源上合成，并替换目的地（Porter-Duff Destination Atop Source规则）。

        F s =（1- A d ）， F d = A s ，因此：

          Ar = As*(1-Ad) + Ad*As = As
  Cr = Cs*(1-Ad) + Cd*As
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • XOR

        @Native
public static final int XOR
        位于目的地外部的源的部分与位于源外的目标的部分（Porter-Duff Source Xor Destination rule）组合。

        F s =（1- A d ）和F d =（1- A s ），因此：

          Ar = As*(1-Ad) + Ad*(1-As)
  Cr = Cs*(1-Ad) + Cd*(1-As)
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • Clear

        public static final AlphaComposite Clear
        AlphaComposite对象实现不透明的CLEAR规则，其alpha为1.0f。
        另请参见：
        CLEAR

      • Src

        public static final AlphaComposite Src
        AlphaComposite实现不透明SRC规则的对象，其alpha为1.0f。
        另请参见：
        SRC

      • Dst

        public static final AlphaComposite Dst
        AlphaComposite对象实现不透明的DST规则，其alpha为1.0f。
        从以下版本开始：
        1.4
        另请参见：
        DST

      • SrcOver

        public static final AlphaComposite SrcOver
        AlphaComposite实现不透明的SRC_OVER规则，其alpha为1.0f。
        另请参见：
        SRC_OVER

      • DstOver

        public static final AlphaComposite DstOver
        AlphaComposite对象实现不透明的DST_OVER规则，其alpha为1.0f。
        另请参见：
        DST_OVER

      • SrcIn

        public static final AlphaComposite SrcIn
        AlphaComposite对象实现了不透明的SRC_IN规则，其alpha为1.0f。
        另请参见：
        SRC_IN

      • DstIn

        public static final AlphaComposite DstIn
        AlphaComposite对象实现不透明的DST_IN规则，其alpha为1.0f。
        另请参见：
        DST_IN

      • SrcOut

        public static final AlphaComposite SrcOut
        AlphaComposite对象实现的alpha值为1.0f的不透明SRC_OUT规则。
        另请参见：
        SRC_OUT

      • DstOut

        public static final AlphaComposite DstOut
        AlphaComposite对象实现不透明的DST_OUT规则，alpha为1.0f。
        另请参见：
        DST_OUT

      • SrcAtop

        public static final AlphaComposite SrcAtop
        AlphaComposite对象实现的alpha值为1.0f的不透明SRC_ATOP规则。
        从以下版本开始：
        1.4
        另请参见：
        SRC_ATOP

      • DstAtop

        public static final AlphaComposite DstAtop
        AlphaComposite对象实现不透明的DST_ATOP规则，alpha为1.0f。
        从以下版本开始：
        1.4
        另请参见：
        DST_ATOP

      • Xor

        public static final AlphaComposite Xor
        AlphaComposite实现不透明XOR规则的对象，其alpha为1.0f。
        从以下版本开始：
        1.4
        另请参见：
        XOR

    • 方法详细信息

      • getInstance

        public static AlphaComposite getInstance​(int rule)
        使用指定的规则创建一个 AlphaComposite对象。
        参数
        rule - 合成规则
        结果
        创建了 AlphaComposite对象
        异常
        IllegalArgumentException -如果 rule不是以下之一： CLEAR ， SRC ， DST ， SRC_OVER ， DST_OVER ， SRC_IN ， DST_IN ， SRC_OUT ， DST_OUT ， SRC_ATOP ， DST_ATOP ，或 XOR

      • getInstance

        public static AlphaComposite getInstance​(int rule,
                                         float alpha)
        使用指定的规则创建一个AlphaComposite对象，并将常量alpha与源的alpha进行乘法。 在与目的地合成之前，源与指定的alpha相乘。
        参数
        rule - 合成规则
        alpha - 要与源的alpha相乘的常数α。 alpha必须是包含范围[ alpha中的浮点数。
        结果
        创建了 AlphaComposite对象
        异常
        IllegalArgumentException -如果 alpha大于1.0小于0.0或更大，或者如果 rule不是以下之一： CLEAR ， SRC ， DST ， SRC_OVER ， DST_OVER ， SRC_IN ， DST_IN ， SRC_OUT ， DST_OUT ， SRC_ATOP ， DST_ATOP ，或 XOR

      • createContext

        public CompositeContext createContext​(ColorModel srcColorModel,
                                      ColorModel dstColorModel,
                                      RenderingHints hints)
        创建合成操作的上下文。 上下文包含用于执行合成操作的状态。
        Specified by:
        createContext在接口 Composite
        参数
        srcColorModel - 来源的ColorModel
        dstColorModel - 目的地的 ColorModel
        hints - 上下文对象用于在渲染替代方案之间进行选择的提示
        结果
        要用于执行合成操作的 CompositeContext对象。

      • getAlpha

        public float getAlpha​()
        返回此AlphaComposite的alpha值。 如果这个AlphaComposite没有alpha值，则返回1.0。
        结果
        这个 AlphaComposite的alpha值。

      • getRule

        public int getRule​()
        返回此 AlphaComposite的合成规则。
        结果
        这个 AlphaComposite的合成规则。

      • derive

        public AlphaComposite derive​(int rule)
        返回一个使用指定的合成规则的类似的AlphaComposite对象。 如果此对象已使用指定的合成规则，则返回此对象。
        参数
        rule - 合成规则
        结果
        一个从该对象派生的 AlphaComposite对象，该对象使用指定的合成规则。
        异常
        IllegalArgumentException -如果 rule不是以下之一： CLEAR ， SRC ， DST ， SRC_OVER ， DST_OVER ， SRC_IN ， DST_IN ， SRC_OUT ， DST_OUT ， SRC_ATOP ， DST_ATOP ，或 XOR
        从以下版本开始：
        1.6

      • derive

        public AlphaComposite derive​(float alpha)
        返回一个使用指定的alpha值的类似的AlphaComposite对象。 如果此对象已经具有指定的alpha值，则返回此对象。
        参数
        alpha - 要与源的alpha相乘的常数α。 alpha必须是包含范围[ alpha中的浮点数。
        结果
        AlphaComposite对象派生的使用指定的Alpha值的对象的 AlphaComposite对象。
        异常
        IllegalArgumentException - 如果 alpha小于0.0或大于1.0
        从以下版本开始：
        1.6

      • hashCode

        public int hashCode​()
        返回此复合的哈希码。
        重写：
        hashCode在 Object
        结果
        此复合的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        确定指定的对象是否等于此AlphaComposite 。

        当且仅当参数不是null且是具有与AlphaComposite对象具有相同合成规则和alpha值的AlphaComposite对象时，结果为true 。

        重写：
        equals在 Object
        参数
        obj - Object测试相等
        结果
        true如果obj等于这AlphaComposite ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class AWTError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.awt.AWTError
  • All Implemented Interfaces:
    Serializable

    public class AWTError
extends Error
    当出现严重的抽象窗口工具包错误时抛出。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AWTError​(String msg)
      构造具有指定详细消息的 AWTError实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AWTError

        public AWTError​(String msg)
        构造具有指定详细消息的 AWTError实例。
        参数
        msg - 详细信息。
        从以下版本开始：
        1.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class AWTEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ActionEvent ， AdjustmentEvent ， AncestorEvent ， ComponentEvent ， HierarchyEvent ， InputMethodEvent ， InternalFrameEvent ， InvocationEvent ， ItemEvent ， TextEvent

    public abstract class AWTEvent
extends EventObject
    所有AWT事件的根事件类。 这个类及其子类替代了原来的java.awt.Event类。 在java.awt.event包之外定义的此AWTEvent类的子类应定义大于RESERVED_ID_MAX定义的值的事件ID值。

    使用Component.enableEvents（）选择未被注册的侦听器选择的事件类型的组件子类，需要此类中定义的事件掩码。 如果在组件上注册了一个监听器，则组件内部已经设置了相应的事件掩码。

    掩码也用于指定AWTEventListener应该侦听哪些类型的事件。 将掩码按位或并置在一起，并传递给Toolkit.addAWTEventListener。

    从以下版本开始：
    1.1
    另请参见：
    Component.enableEvents(long) ， Toolkit.addAWTEventListener(java.awt.event.AWTEventListener, long) ， ActionEvent ， AdjustmentEvent ， ComponentEvent ， ContainerEvent ， FocusEvent ， InputMethodEvent ， InvocationEvent ， ItemEvent ， HierarchyEvent ， KeyEvent ， MouseEvent ， MouseWheelEvent ， PaintEvent ， TextEvent ， WindowEvent ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static long ACTION_EVENT_MASK
      用于选择动作事件的事件掩码。
      static long ADJUSTMENT_EVENT_MASK
      用于选择调整事件的事件掩码。
      static long COMPONENT_EVENT_MASK
      用于选择组件事件的事件掩码。
      protected boolean consumed
      控制一旦源处理它，事件是否被发回到对等体 - false意味着它被发送到对等体; 真的意味着它不是。
      static long CONTAINER_EVENT_MASK
      用于选择容器事件的事件掩码。
      static long FOCUS_EVENT_MASK
      用于选择焦点事件的事件掩码。
      static long HIERARCHY_BOUNDS_EVENT_MASK
      用于选择层次结构事件的事件掩码。
      static long HIERARCHY_EVENT_MASK
      用于选择层次结构事件的事件掩码。
      protected int id
      事件的id
      static long INPUT_METHOD_EVENT_MASK
      用于选择输入法事件的事件掩码。
      static long INVOCATION_EVENT_MASK
      用于选择调用事件的事件掩码。
      static long ITEM_EVENT_MASK
      用于选择项目事件的事件掩码。
      static long KEY_EVENT_MASK
      用于选择关键事件的事件掩码。
      static long MOUSE_EVENT_MASK
      用于选择鼠标事件的事件掩码。
      static long MOUSE_MOTION_EVENT_MASK
      用于选择鼠标运动事件的事件掩码。
      static long MOUSE_WHEEL_EVENT_MASK
      用于选择鼠标滚轮事件的事件掩码。
      static long PAINT_EVENT_MASK
      用于选择油漆事件的事件掩码。
      static int RESERVED_ID_MAX
      保留的AWT事件ID的最大值。
      static long TEXT_EVENT_MASK
      用于选择文本事件的事件掩码。
      static long WINDOW_EVENT_MASK
      用于选择窗口事件的事件掩码。
      static long WINDOW_FOCUS_EVENT_MASK
      用于选择窗口焦点事件的事件掩码。
      static long WINDOW_STATE_EVENT_MASK
      用于选择窗口状态事件的事件掩码。

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      AWTEvent​(Event event)
      已过时。
      建议使用AWTEvent(Object, int)
      AWTEvent​(Object source, int id)
      构造具有指定源对象和类型的AWTEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void consume​()
      消耗这个事件，如果这个事件可以消耗。
      int getID​()
      返回事件类型。
      protected boolean isConsumed​()
      返回此事件是否已被使用。
      String paramString​()
      返回一个表示 Event状态的字符串。
      void setSource​(Object newSource)
      将事件重新定位到新的来源。
      String toString​()
      返回此对象的String表示形式。

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • id

        protected int id
        事件的id
        另请参见：
        getID() ， AWTEvent(java.lang.Object, int)

      • consumed

        protected boolean consumed
        控制一旦源处理它，事件是否被发回到对等体 - false意味着它被发送到对等体; 真的意味着它不是。 语义事件始终具有“真实”值，因为它们是由对等体响应于低级别事件生成的。
        另请参见：
        consume() ， isConsumed()

      • COMPONENT_EVENT_MASK

        public static final long COMPONENT_EVENT_MASK
        用于选择组件事件的事件掩码。
        另请参见：
        Constant Field Values

      • CONTAINER_EVENT_MASK

        public static final long CONTAINER_EVENT_MASK
        用于选择容器事件的事件掩码。
        另请参见：
        Constant Field Values

      • FOCUS_EVENT_MASK

        public static final long FOCUS_EVENT_MASK
        用于选择焦点事件的事件掩码。
        另请参见：
        Constant Field Values

      • KEY_EVENT_MASK

        public static final long KEY_EVENT_MASK
        用于选择关键事件的事件掩码。
        另请参见：
        Constant Field Values

      • MOUSE_EVENT_MASK

        public static final long MOUSE_EVENT_MASK
        用于选择鼠标事件的事件掩码。
        另请参见：
        Constant Field Values

      • MOUSE_MOTION_EVENT_MASK

        public static final long MOUSE_MOTION_EVENT_MASK
        用于选择鼠标运动事件的事件掩码。
        另请参见：
        Constant Field Values

      • WINDOW_EVENT_MASK

        public static final long WINDOW_EVENT_MASK
        用于选择窗口事件的事件掩码。
        另请参见：
        Constant Field Values

      • ACTION_EVENT_MASK

        public static final long ACTION_EVENT_MASK
        用于选择动作事件的事件掩码。
        另请参见：
        Constant Field Values

      • ADJUSTMENT_EVENT_MASK

        public static final long ADJUSTMENT_EVENT_MASK
        用于选择调整事件的事件掩码。
        另请参见：
        Constant Field Values

      • ITEM_EVENT_MASK

        public static final long ITEM_EVENT_MASK
        用于选择项目事件的事件掩码。
        另请参见：
        Constant Field Values

      • TEXT_EVENT_MASK

        public static final long TEXT_EVENT_MASK
        用于选择文本事件的事件掩码。
        另请参见：
        Constant Field Values

      • INPUT_METHOD_EVENT_MASK

        public static final long INPUT_METHOD_EVENT_MASK
        用于选择输入法事件的事件掩码。
        另请参见：
        Constant Field Values

      • PAINT_EVENT_MASK

        public static final long PAINT_EVENT_MASK
        用于选择油漆事件的事件掩码。
        另请参见：
        Constant Field Values

      • INVOCATION_EVENT_MASK

        public static final long INVOCATION_EVENT_MASK
        用于选择调用事件的事件掩码。
        另请参见：
        Constant Field Values

      • HIERARCHY_EVENT_MASK

        public static final long HIERARCHY_EVENT_MASK
        用于选择层次结构事件的事件掩码。
        另请参见：
        Constant Field Values

      • HIERARCHY_BOUNDS_EVENT_MASK

        public static final long HIERARCHY_BOUNDS_EVENT_MASK
        用于选择层次结构事件的事件掩码。
        另请参见：
        Constant Field Values

      • MOUSE_WHEEL_EVENT_MASK

        public static final long MOUSE_WHEEL_EVENT_MASK
        用于选择鼠标滚轮事件的事件掩码。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • WINDOW_STATE_EVENT_MASK

        public static final long WINDOW_STATE_EVENT_MASK
        用于选择窗口状态事件的事件掩码。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • WINDOW_FOCUS_EVENT_MASK

        public static final long WINDOW_FOCUS_EVENT_MASK
        用于选择窗口焦点事件的事件掩码。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • RESERVED_ID_MAX

        public static final int RESERVED_ID_MAX
        保留的AWT事件ID的最大值。 定义自己的事件ID的程序应该使用大于此值的ID。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • AWTEvent

        @Deprecated(since="9")
public AWTEvent​(Event event)
        已过时。 建议使用AWTEvent(Object, int)
        从1.0样式事件的参数构造一个AWTEvent对象。
        参数
        event - 旧式事件

      • AWTEvent

        public AWTEvent​(Object source,
                int id)
        构造具有指定源对象和类型的AWTEvent对象。
        参数
        source - 事件发生的对象
        id - 事件类型

    • 方法详细信息

      • setSource

        public void setSource​(Object newSource)
        将事件重新定位到新的来源。 此方法通常用于将事件重新定位到原始重磅源的轻量级子组件。

        此方法仅用于事件定位子系统，如客户端定义的KeyboardFocusManagers。 它不是一般客户使用。

        参数
        newSource - 事件应发送到的新对象
        从以下版本开始：
        1.4

      • getID

        public int getID​()
        返回事件类型。
        结果
        事件的类型ID

      • toString

        public String toString​()
        返回此对象的String表示形式。
        重写：
        toString在 EventObject
        结果
        这个EventObject的一个String表示形式。

      • paramString

        public String paramString​()
        返回一个表示Event状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        结果
        此事件的字符串表示形式

      • consume

        protected void consume​()
        消耗这个事件，如果这个事件可以消耗。 只能使用低级别的系统事件

      • isConsumed

        protected boolean isConsumed​()
        返回此事件是否已被使用。
        结果
        true如果此事件已被使用; 否则false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTEventMulticaster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class AWTEventMulticaster

  • java.lang.Object
    • java.awt.AWTEventMulticaster
  • All Implemented Interfaces:
    ActionListener ， AdjustmentListener ， ComponentListener ， ContainerListener ， FocusListener ， HierarchyBoundsListener ， HierarchyListener ， InputMethodListener ， ItemListener ， KeyListener ， MouseListener ， MouseMotionListener ， MouseWheelListener ， TextListener ， WindowFocusListener ， WindowListener ， WindowStateListener ， EventListener

    public class AWTEventMulticaster
extends Object
implements ComponentListener, ContainerListener, FocusListener, KeyListener, MouseListener, MouseMotionListener, WindowListener, WindowFocusListener, WindowStateListener, ActionListener, ItemListener, AdjustmentListener, TextListener, InputMethodListener, HierarchyListener, HierarchyBoundsListener, MouseWheelListener
    AWTEventMulticaster为java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。

    以下示例说明如何使用此类：

       public myComponent extends Component { ActionListener actionListener = null; public synchronized void addActionListener(ActionListener l) { actionListener = AWTEventMulticaster.add(actionListener, l); } public synchronized void removeActionListener(ActionListener l) { actionListener = AWTEventMulticaster.remove(actionListener, l); } public void processEvent(AWTEvent e) { // when event occurs which causes "action" semantic ActionListener listener = actionListener; if (listener != null) { listener.actionPerformed(new ActionEvent()); } } }
    要注意的重点是add和remove方法的第一个参数是维护侦听器的字段。 另外，您必须将add和remove方法的结果分配给维护侦听器的字段。

    AWTEventMulticaster实施为在建设时设置的一对EventListeners 。 AWTEventMulticaster是不可变的。 add ， add和remove方法都不会改变AWTEventMulticaster 。 如有必要，将创建一个新的AWTEventMulticaster 。 通过这种方式，可以安全地在事件调度过程中添加和删除监听器。 但是，在事件调度操作过程中添加的事件侦听器不会被通知当前正在调度的事件。

    所有add方法允许null参数。 如果第一个参数是null ，则返回第二个参数。 如果第一个参数不是null ，第二个参数是null ，则返回第一个参数。 如果两个参数都是non-null ，则使用两个参数创建新的AWTEventMulticaster并返回。

    对于采用两个参数的remove方法，将返回以下内容：

    • null ，如果第一个参数为null ，或参数相等， == 。
    • 第一个参数，如果第一个参数不是一个AWTEventMulticaster的实例。
    • 在第一个参数上调用remove(EventListener)结果，将第二个参数提供给remove(EventListener)方法。

    Swing对于类似的逻辑使用了EventListenerList 。 详情请参考

    从以下版本开始：
    1.1
    另请参见：
    EventListenerList

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected EventListener a
      事件链中的变量（listener-a）
      protected EventListener b
      事件链中的一个变量（listener-b）

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AWTEventMulticaster​(EventListener a, EventListener b)
      创建一个事件多重实例，它将listener-a与listener-b链接起来。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void actionPerformed​(ActionEvent e)
      通过调用listener-a和listener-b上的actionPerformed方法来处理actionPerformed事件。
      static ActionListener add​(ActionListener a, ActionListener b)
      添加action-listener-a与action-listener-b，并返回生成的组播侦听器。
      static AdjustmentListener add​(AdjustmentListener a, AdjustmentListener b)
      使用adjust-listener-b添加调整监听器a，并返回生成的组播侦听器。
      static ComponentListener add​(ComponentListener a, ComponentListener b)
      将component-listener-a与component-listener-b相加，并返回生成的组播侦听器。
      static ContainerListener add​(ContainerListener a, ContainerListener b)
      将container-listener-a与container-listener-b相加，并返回生成的组播侦听器。
      static FocusListener add​(FocusListener a, FocusListener b)
      将focus-listener-a与focus-listener-b相加，并返回生成的组播侦听器。
      static HierarchyBoundsListener add​(HierarchyBoundsListener a, HierarchyBoundsListener b)
      将hierarchy-bounds-listener-a与hierarchy-bounds-listener-b相加，并返回生成的组播监听器。
      static HierarchyListener add​(HierarchyListener a, HierarchyListener b)
      添加具有hierarchy-listener-b的hierarchy-listener-a并返回生成的组播侦听器。
      static InputMethodListener add​(InputMethodListener a, InputMethodListener b)
      将input-method-listener-a与input-method-listener-b相加，并返回生成的组播侦听器。
      static ItemListener add​(ItemListener a, ItemListener b)
      将item-listener-a与item-listener-b相加，并返回生成的组播监听器。
      static KeyListener add​(KeyListener a, KeyListener b)
      将key-listener-a与key-listener-b相加，并返回生成的组播侦听器。
      static MouseListener add​(MouseListener a, MouseListener b)
      添加mouse-listener-a与mouse-listener-b并返回结果组播监听器。
      static MouseMotionListener add​(MouseMotionListener a, MouseMotionListener b)
      添加mouse-motion-listener-a与mouse-motion-listener-b并返回生成的组播侦听器。
      static MouseWheelListener add​(MouseWheelListener a, MouseWheelListener b)
      添加鼠标滚轮监听器a和鼠标滚轮监听器b并返回结果组播侦听器。
      static TextListener add​(TextListener a, TextListener b)
      将text-listener-a与text-listener-b相加，并返回生成的多播侦听器。
      static WindowFocusListener add​(WindowFocusListener a, WindowFocusListener b)
      使用window-focus-listener-b添加window-focus-listener-a，并返回生成的多播侦听器。
      static WindowListener add​(WindowListener a, WindowListener b)
      添加window-listener-a与window-listener-b并返回结果组播侦听器。
      static WindowStateListener add​(WindowStateListener a, WindowStateListener b)
      将window-state-listener-a与window-state-listener-b相加，并返回结果组播监听器。
      protected static EventListener addInternal​(EventListener a, EventListener b)
      通过将listener-a和listener-b添加到一起返回生成的多播监听器。
      void adjustmentValueChanged​(AdjustmentEvent e)
      通过调用listener-a和listener-b上的adjustValueChanged方法来处理adjustValueChanged事件。
      void ancestorMoved​(HierarchyEvent e)
      通过在listener-a和listener-b上调用ancestorMoved方法来处理ancestorMoved事件。
      void ancestorResized​(HierarchyEvent e)
      通过调用listener-a和listener-b上的ancestorResized方法来处理ancestorResized事件。
      void caretPositionChanged​(InputMethodEvent e)
      通过在listener-a和listener-b上调用caretPositionChanged方法处理caretPositionChanged事件。
      void componentAdded​(ContainerEvent e)
      通过调用listener-a和listener-b上的componentAdded方法来处理componentAdded容器事件。
      void componentHidden​(ComponentEvent e)
      通过在listener-a和listener-b上调用componentHidden方法来处理componentHidden事件。
      void componentMoved​(ComponentEvent e)
      通过调用listener-a和listener-b上的componentMoved方法来处理componentMoved事件。
      void componentRemoved​(ContainerEvent e)
      通过调用listener-a和listener-b上的componentRemoved方法来处理componentRemoved容器事件。
      void componentResized​(ComponentEvent e)
      通过调用listener-a和listener-b上的componentResized方法来处理componentResized事件。
      void componentShown​(ComponentEvent e)
      通过调用listener-a和listener-b上的componentShown方法来处理componentShown事件。
      void focusGained​(FocusEvent e)
      通过在listener-a和listener-b上调用focusGained方法来处理focusGained事件。
      void focusLost​(FocusEvent e)
      通过在listener-a和listener-b上调用focusLost方法来处理focusLost事件。
      static <T extends EventListener>
      T[]             		getListeners​(EventListener l, Class<T> listenerType)
      返回链作为所有对象的数组 FooListener由该指定S java.util.EventListener 。
      void hierarchyChanged​(HierarchyEvent e)
      通过调用listener-a和listener-b上的hierarchyChanged方法来处理hierarchyChanged事件。
      void inputMethodTextChanged​(InputMethodEvent e)
      通过调用listener-a和listener-b上的inputMethodTextChanged方法来处理inputMethodTextChanged事件。
      void itemStateChanged​(ItemEvent e)
      通过调用listener-a和listener-b上的itemStateChanged方法来处理itemStateChanged事件。
      void keyPressed​(KeyEvent e)
      通过在listener-a和listener-b上调用keyPressed方法来处理keyPressed事件。
      void keyReleased​(KeyEvent e)
      通过调用listener-a和listener-b上的keyReleased方法来处理keyReleased事件。
      void keyTyped​(KeyEvent e)
      通过在listener-a和listener-b上调用keyTyped方法来处理keyTyped事件。
      void mouseClicked​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseClicked方法来处理mouseClicked事件。
      void mouseDragged​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseDragged方法来处理mouseDragged事件。
      void mouseEntered​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseEntered方法来处理mouseEntered事件。
      void mouseExited​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseExited方法来处理mouseExited事件。
      void mouseMoved​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseMoved方法来处理mouseMoved事件。
      void mousePressed​(MouseEvent e)
      通过在listener-a和listener-b上调用mousePressed方法来处理mousePressed事件。
      void mouseReleased​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseReleased方法来处理mouseReleased事件。
      void mouseWheelMoved​(MouseWheelEvent e)
      通过在listener-a和listener-b上调用mouseWheelMoved方法来处理mouseWheelMoved事件。
      static ActionListener remove​(ActionListener l, ActionListener oldl)
      从action-listener-l中删除旧的action-listener，并返回生成的组播侦听器。
      static AdjustmentListener remove​(AdjustmentListener l, AdjustmentListener oldl)
      从调整监听器l中删除旧的调整监听器，并返回结果组播监听器。
      static ComponentListener remove​(ComponentListener l, ComponentListener oldl)
      从component-listener-l中删除旧的组件侦听器，并返回生成的组播侦听器。
      static ContainerListener remove​(ContainerListener l, ContainerListener oldl)
      从container-listener-l中删除旧容器监听器，并返回生成的组播侦听器。
      static FocusListener remove​(FocusListener l, FocusListener oldl)
      从focus-listener-l中删除旧的focus-listener，并返回生成的组播监听器。
      static HierarchyBoundsListener remove​(HierarchyBoundsListener l, HierarchyBoundsListener oldl)
      从hierarchy-bounds-listener-l中删除旧的hierarchy-bounds-listener，并返回生成的组播监听器。
      static HierarchyListener remove​(HierarchyListener l, HierarchyListener oldl)
      从hierarchy-listener-l中删除旧的层次结构监听器，并返回结果组播监听器。
      static InputMethodListener remove​(InputMethodListener l, InputMethodListener oldl)
      从input-method-listener-l中删除旧的输入法侦听器，并返回生成的组播侦听器。
      static ItemListener remove​(ItemListener l, ItemListener oldl)
      从item-listener-l中删除旧的项目监听器，并返回生成的组播侦听器。
      static KeyListener remove​(KeyListener l, KeyListener oldl)
      从key-listener-l中删除旧的密钥监听器，并返回生成的组播侦听器。
      static MouseListener remove​(MouseListener l, MouseListener oldl)
      从mouse-listener-l中删除旧的鼠标监听器，并返回生成的组播侦听器。
      static MouseMotionListener remove​(MouseMotionListener l, MouseMotionListener oldl)
      从mouse-motion-listener-l中删除旧的鼠标移动监听器，并返回生成的组播侦听器。
      static MouseWheelListener remove​(MouseWheelListener l, MouseWheelListener oldl)
      从mouse-wheel-listener-l中删除旧的鼠标滚轮监听器，并返回生成的组播侦听器。
      static TextListener remove​(TextListener l, TextListener oldl)
      从text-listener-l中删除旧的文本侦听器，并返回生成的组播侦听器。
      static WindowFocusListener remove​(WindowFocusListener l, WindowFocusListener oldl)
      从window-focus-listener-l中删除旧的window-focus-listener，并返回结果组播监听器。
      static WindowListener remove​(WindowListener l, WindowListener oldl)
      从window-listener-l中删除旧的window-listener，并返回结果组播监听器。
      static WindowStateListener remove​(WindowStateListener l, WindowStateListener oldl)
      从window-state-listener-l中删除旧的window-state-listener，并返回结果组播监听器。
      protected EventListener remove​(EventListener oldl)
      从这个多维数据删除一个监听器。
      protected static EventListener removeInternal​(EventListener l, EventListener oldl)
      从listener-l中删除旧的侦听器后，返回生成的多播侦听器。
      protected static void save​(ObjectOutputStream s, String k, EventListener l)
      将可序列化的监听器链保存到序列化流。
      protected void saveInternal​(ObjectOutputStream s, String k)
      序列化支持。
      void textValueChanged​(TextEvent e)
      当文本的值已更改时调用。
      void windowActivated​(WindowEvent e)
      通过调用listener-a和listener-b上的windowActivated方法来处理windowActivated事件。
      void windowClosed​(WindowEvent e)
      通过调用listener-a和listener-b上的windowClosed方法来处理windowClosed事件。
      void windowClosing​(WindowEvent e)
      通过调用listener-a和listener-b上的windowClosing方法处理windowClosing事件。
      void windowDeactivated​(WindowEvent e)
      通过调用listener-a和listener-b上的windowDeactivated方法来处理windowDeactivated事件。
      void windowDeiconified​(WindowEvent e)
      通过调用listener-a和listener-b上的windowDeiconified方法来处理windowDeiconified事件。
      void windowGainedFocus​(WindowEvent e)
      通过调用listener-a和listener-b上的windowGainedFocus方法来处理windowGainedFocus事件。
      void windowIconified​(WindowEvent e)
      通过调用listener-a和listener-b上的windowIconified方法来处理windowIconified事件。
      void windowLostFocus​(WindowEvent e)
      通过调用listener-a和listener-b上的windowLostFocus方法来处理windowLostFocus事件。
      void windowOpened​(WindowEvent e)
      通过调用listener-a和listener-b上的windowOpened方法处理windowOpened事件。
      void windowStateChanged​(WindowEvent e)
      通过调用listener-a和listener-b上的windowStateChanged方法来处理windowStateChanged事件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • a

        protected final EventListener a
        事件链中的变量（listener-a）

      • b

        protected final EventListener b
        事件链中的一个变量（listener-b）

    • 构造方法详细信息

      • AWTEventMulticaster

        protected AWTEventMulticaster​(EventListener a,
                              EventListener b)
        创建一个事件多重实例，它将listener-a与listener-b链接起来。 输入参数a和b不应该是null ，尽管在这种情况下实现可能会有所不同，选择是否抛出NullPointerException 。
        参数
        a - 监听者a
        b - 监听者b

    • 方法详细信息

      • remove

        protected EventListener remove​(EventListener oldl)
        从这个多维数据删除一个监听器。

        返回的oldl包含此多核心中的所有侦听器，但所有出现的oldl 。 如果生成的多维数据集只包含一个常规侦听器，则可能会返回常规侦听器。 如果生成的null是空的，则可能会返回null 。

        如果oldl是null则oldl抛出异常。

        参数
        oldl - 要删除的侦听器
        结果
        导致听众

      • componentResized

        public void componentResized​(ComponentEvent e)
        通过调用listener-a和listener-b上的componentResized方法来处理componentResized事件。
        Specified by:
        componentResized在接口 ComponentListener
        参数
        e - 组件事件

      • componentMoved

        public void componentMoved​(ComponentEvent e)
        通过调用listener-a和listener-b上的componentMoved方法来处理componentMoved事件。
        Specified by:
        componentMoved在接口 ComponentListener
        参数
        e - 组件事件

      • componentShown

        public void componentShown​(ComponentEvent e)
        通过调用listener-a和listener-b上的componentShown方法来处理componentShown事件。
        Specified by:
        componentShown在接口 ComponentListener
        参数
        e - 组件事件

      • componentHidden

        public void componentHidden​(ComponentEvent e)
        通过在listener-a和listener-b上调用componentHidden方法来处理componentHidden事件。
        Specified by:
        componentHidden在接口 ComponentListener
        参数
        e - 组件事件

      • componentAdded

        public void componentAdded​(ContainerEvent e)
        通过调用listener-a和listener-b上的componentAdded方法来处理componentAdded容器事件。
        Specified by:
        componentAdded在接口 ContainerListener
        参数
        e - 组件事件

      • componentRemoved

        public void componentRemoved​(ContainerEvent e)
        通过调用listener-a和listener-b上的componentRemoved方法来处理componentRemoved容器事件。
        Specified by:
        componentRemoved在接口 ContainerListener
        参数
        e - 组件事件

      • focusGained

        public void focusGained​(FocusEvent e)
        通过在listener-a和listener-b上调用focusGained方法来处理focusGained事件。
        Specified by:
        focusGained在接口 FocusListener
        参数
        e - 焦点事件

      • focusLost

        public void focusLost​(FocusEvent e)
        通过在listener-a和listener-b上调用focusLost方法来处理focusLost事件。
        Specified by:
        focusLost在接口 FocusListener
        参数
        e - 焦点事件

      • keyTyped

        public void keyTyped​(KeyEvent e)
        通过在listener-a和listener-b上调用keyTyped方法来处理keyTyped事件。
        Specified by:
        keyTyped在接口 KeyListener
        参数
        e - 关键事件

      • keyPressed

        public void keyPressed​(KeyEvent e)
        通过在listener-a和listener-b上调用keyPressed方法来处理keyPressed事件。
        Specified by:
        keyPressed在接口 KeyListener
        参数
        e - 关键事件

      • keyReleased

        public void keyReleased​(KeyEvent e)
        通过调用listener-a和listener-b上的keyReleased方法来处理keyReleased事件。
        Specified by:
        keyReleased在接口 KeyListener
        参数
        e - 关键事件

      • mouseClicked

        public void mouseClicked​(MouseEvent e)
        通过在listener-a和listener-b上调用mouseClicked方法来处理mouseClicked事件。
        Specified by:
        mouseClicked在接口 MouseListener
        参数
        e - 鼠标事件

      • mousePressed

        public void mousePressed​(MouseEvent e)
        通过在listener-a和listener-b上调用mousePressed方法来处理mousePressed事件。
        Specified by:
        mousePressed在接口 MouseListener
        参数
        e - 鼠标事件

      • mouseReleased

        public void mouseReleased​(MouseEvent e)
        通过在listener-a和listener-b上调用mouseReleased方法来处理mouseReleased事件。
        Specified by:
        mouseReleased在接口 MouseListener
        参数
        e - 鼠标事件

      • mouseEntered

        public void mouseEntered​(MouseEvent e)
        通过在listener-a和listener-b上调用mouseEntered方法来处理mouseEntered事件。
        Specified by:
        mouseEntered在接口 MouseListener
        参数
        e - 鼠标事件

      • mouseExited

        public void mouseExited​(MouseEvent e)
        通过在listener-a和listener-b上调用mouseExited方法来处理mouseExited事件。
        Specified by:
        mouseExited在接口 MouseListener
        参数
        e - 鼠标事件

      • mouseDragged

        public void mouseDragged​(MouseEvent e)
        通过在listener-a和listener-b上调用mouseDragged方法来处理mouseDragged事件。
        Specified by:
        mouseDragged在接口 MouseMotionListener
        参数
        e - 鼠标事件

      • mouseMoved

        public void mouseMoved​(MouseEvent e)
        通过在listener-a和listener-b上调用mouseMoved方法来处理mouseMoved事件。
        Specified by:
        mouseMoved在接口 MouseMotionListener
        参数
        e - 鼠标事件

      • windowOpened

        public void windowOpened​(WindowEvent e)
        通过调用listener-a和listener-b上的windowOpened方法处理windowOpened事件。
        Specified by:
        windowOpened在接口 WindowListener
        参数
        e - 窗口事件

      • windowClosing

        public void windowClosing​(WindowEvent e)
        通过调用listener-a和listener-b上的windowClosing方法处理windowClosing事件。
        Specified by:
        windowClosing在接口 WindowListener
        参数
        e - 窗口事件

      • windowClosed

        public void windowClosed​(WindowEvent e)
        通过调用listener-a和listener-b上的windowClosed方法来处理windowClosed事件。
        Specified by:
        windowClosed在接口 WindowListener
        参数
        e - 窗口事件

      • windowIconified

        public void windowIconified​(WindowEvent e)
        通过调用listener-a和listener-b上的windowIconified方法来处理windowIconified事件。
        Specified by:
        windowIconified在接口 WindowListener
        参数
        e - 窗口事件
        另请参见：
        Frame.setIconImage(java.awt.Image)

      • windowDeiconified

        public void windowDeiconified​(WindowEvent e)
        通过调用listener-a和listener-b上的windowDeiconified方法来处理windowDeiconified事件。
        Specified by:
        windowDeiconified在接口 WindowListener
        参数
        e - 窗口事件

      • windowActivated

        public void windowActivated​(WindowEvent e)
        通过调用listener-a和listener-b上的windowActivated方法来处理windowActivated事件。
        Specified by:
        windowActivated在接口 WindowListener
        参数
        e - 窗口事件

      • windowDeactivated

        public void windowDeactivated​(WindowEvent e)
        通过调用listener-a和listener-b上的windowDeactivated方法来处理windowDeactivated事件。
        Specified by:
        windowDeactivated在接口 WindowListener
        参数
        e - 窗口事件

      • windowStateChanged

        public void windowStateChanged​(WindowEvent e)
        通过调用listener-a和listener-b上的windowStateChanged方法来处理windowStateChanged事件。
        Specified by:
        windowStateChanged在接口 WindowStateListener
        参数
        e - 窗口事件
        从以下版本开始：
        1.4

      • windowGainedFocus

        public void windowGainedFocus​(WindowEvent e)
        通过调用listener-a和listener-b上的windowGainedFocus方法来处理windowGainedFocus事件。
        Specified by:
        windowGainedFocus在接口 WindowFocusListener
        参数
        e - 窗口事件
        从以下版本开始：
        1.4

      • windowLostFocus

        public void windowLostFocus​(WindowEvent e)
        通过调用listener-a和listener-b上的windowLostFocus方法来处理windowLostFocus事件。
        Specified by:
        windowLostFocus在接口 WindowFocusListener
        参数
        e - 窗口事件
        从以下版本开始：
        1.4

      • actionPerformed

        public void actionPerformed​(ActionEvent e)
        通过调用listener-a和listener-b上的actionPerformed方法来处理actionPerformed事件。
        Specified by:
        actionPerformed在接口 ActionListener
        参数
        e - 动作事件

      • itemStateChanged

        public void itemStateChanged​(ItemEvent e)
        通过调用listener-a和listener-b上的itemStateChanged方法来处理itemStateChanged事件。
        Specified by:
        itemStateChanged在接口 ItemListener
        参数
        e - 项目事件

      • adjustmentValueChanged

        public void adjustmentValueChanged​(AdjustmentEvent e)
        通过调用listener-a和listener-b上的adjustValueChanged方法来处理adjustValueChanged事件。
        Specified by:
        adjustmentValueChanged在接口 AdjustmentListener
        参数
        e - 调整事件

      • textValueChanged

        public void textValueChanged​(TextEvent e)
        说明从界面TextListener复制
        当文本的值已更改时调用。 为此方法编写的代码执行文本更改时需要执行的操作。
        Specified by:
        textValueChanged在接口 TextListener
        参数
        e - 要处理的事件

      • inputMethodTextChanged

        public void inputMethodTextChanged​(InputMethodEvent e)
        通过调用listener-a和listener-b上的inputMethodTextChanged方法来处理inputMethodTextChanged事件。
        Specified by:
        inputMethodTextChanged在接口 InputMethodListener
        参数
        e - 项目事件

      • caretPositionChanged

        public void caretPositionChanged​(InputMethodEvent e)
        通过在listener-a和listener-b上调用caretPositionChanged方法处理caretPositionChanged事件。
        Specified by:
        caretPositionChanged在接口 InputMethodListener
        参数
        e - 项目事件

      • hierarchyChanged

        public void hierarchyChanged​(HierarchyEvent e)
        通过调用listener-a和listener-b上的hierarchyChanged方法来处理hierarchyChanged事件。
        Specified by:
        hierarchyChanged在接口 HierarchyListener
        参数
        e - 项目事件
        从以下版本开始：
        1.3
        另请参见：
        HierarchyEvent.getChangeFlags()

      • ancestorMoved

        public void ancestorMoved​(HierarchyEvent e)
        通过在listener-a和listener-b上调用ancestorMoved方法来处理ancestorMoved事件。
        Specified by:
        ancestorMoved在接口 HierarchyBoundsListener
        参数
        e - 项目事件
        从以下版本开始：
        1.3

      • ancestorResized

        public void ancestorResized​(HierarchyEvent e)
        通过调用listener-a和listener-b上的ancestorResized方法来处理ancestorResized事件。
        Specified by:
        ancestorResized在接口 HierarchyBoundsListener
        参数
        e - 项目事件
        从以下版本开始：
        1.3

      • mouseWheelMoved

        public void mouseWheelMoved​(MouseWheelEvent e)
        通过在listener-a和listener-b上调用mouseWheelMoved方法来处理mouseWheelMoved事件。
        Specified by:
        mouseWheelMoved在接口 MouseWheelListener
        参数
        e - 鼠标事件
        从以下版本开始：
        1.4
        另请参见：
        MouseWheelEvent

      • add

        public static ComponentListener add​(ComponentListener a,
                                    ComponentListener b)
        将component-listener-a与component-listener-b相加，并返回生成的组播侦听器。
        参数
        a - component-listener-a
        b - component-listener-b
        结果
        产生的听众

      • add

        public static ContainerListener add​(ContainerListener a,
                                    ContainerListener b)
        将container-listener-a与container-listener-b相加，并返回生成的组播侦听器。
        参数
        a - container-listener-a
        b - container-listener-b
        结果
        产生的听众

      • add

        public static FocusListener add​(FocusListener a,
                                FocusListener b)
        将focus-listener-a与focus-listener-b相加，并返回生成的组播侦听器。
        参数
        a - focus-listener-a
        b - focus-listener-b
        结果
        产生的听众

      • add

        public static KeyListener add​(KeyListener a,
                              KeyListener b)
        将key-listener-a与key-listener-b相加，并返回生成的组播侦听器。
        参数
        a - key-listener-a
        b - key-listener-b
        结果
        产生的听众

      • add

        public static MouseListener add​(MouseListener a,
                                MouseListener b)
        添加mouse-listener-a与mouse-listener-b并返回结果组播监听器。
        参数
        a - mouse-listener-a
        b - mouse-listener-b
        结果
        产生的听众

      • add

        public static MouseMotionListener add​(MouseMotionListener a,
                                      MouseMotionListener b)
        添加mouse-motion-listener-a与mouse-motion-listener-b并返回生成的组播侦听器。
        参数
        a - mouse-motion-listener-a
        b - mouse-motion-listener-b
        结果
        产生的听众

      • add

        public static WindowListener add​(WindowListener a,
                                 WindowListener b)
        添加window-listener-a与window-listener-b并返回结果组播侦听器。
        参数
        a - window-listener-a
        b - window-listener-b
        结果
        产生的听众

      • add

        public static WindowStateListener add​(WindowStateListener a,
                                      WindowStateListener b)
        将window-state-listener-a与window-state-listener-b相加，并返回结果组播监听器。
        参数
        a - window-state-listener-a
        b - window-state-listener-b
        结果
        产生的听众
        从以下版本开始：
        1.4

      • add

        public static WindowFocusListener add​(WindowFocusListener a,
                                      WindowFocusListener b)
        使用window-focus-listener-b添加window-focus-listener-a，并返回生成的多播侦听器。
        参数
        a - window-focus-listener-a
        b - window-focus-listener-b
        结果
        产生的听众
        从以下版本开始：
        1.4

      • add

        public static ActionListener add​(ActionListener a,
                                 ActionListener b)
        添加action-listener-a与action-listener-b，并返回生成的组播侦听器。
        参数
        a - action-listener-a
        b - action-listener-b
        结果
        产生的听众

      • add

        public static ItemListener add​(ItemListener a,
                               ItemListener b)
        将item-listener-a与item-listener-b相加，并返回生成的组播监听器。
        参数
        a - item-listener-a
        b - item-listener-b
        结果
        产生的听众

      • add

        public static AdjustmentListener add​(AdjustmentListener a,
                                     AdjustmentListener b)
        使用adjust-listener-b添加调整监听器a，并返回生成的组播侦听器。
        参数
        a - 调整监听者a
        b - 调整监听者b
        结果
        产生的听众

      • add

        public static TextListener add​(TextListener a,
                               TextListener b)
        将text-listener-a与text-listener-b相加，并返回生成的多播侦听器。
        参数
        a - text-listener-a
        b - text-listener-b
        结果
        产生的听众

      • add

        public static InputMethodListener add​(InputMethodListener a,
                                      InputMethodListener b)
        将input-method-listener-a与input-method-listener-b相加，并返回生成的组播侦听器。
        参数
        a - input-method-listener-a
        b - input-method-listener-b
        结果
        产生的听众

      • add

        public static HierarchyListener add​(HierarchyListener a,
                                    HierarchyListener b)
        添加具有hierarchy-listener-b的hierarchy-listener-a并返回生成的组播侦听器。
        参数
        a - 层次监听器a
        b - hierarchy-listener-b
        结果
        产生的听众
        从以下版本开始：
        1.3

      • add

        public static HierarchyBoundsListener add​(HierarchyBoundsListener a,
                                          HierarchyBoundsListener b)
        将hierarchy-bounds-listener-a与hierarchy-bounds-listener-b相加，并返回生成的组播监听器。
        参数
        a - hierarchy-bounds-listener-a
        b - hierarchy-bounds-listener-b
        结果
        产生的听众
        从以下版本开始：
        1.3

      • add

        public static MouseWheelListener add​(MouseWheelListener a,
                                     MouseWheelListener b)
        添加鼠标滚轮监听器a和鼠标滚轮监听器b并返回结果组播侦听器。
        参数
        a - mouse-wheel-listener-a
        b - mouse-wheel-listener-b
        结果
        产生的听众
        从以下版本开始：
        1.4

      • remove

        public static ComponentListener remove​(ComponentListener l,
                                       ComponentListener oldl)
        从component-listener-l中删除旧的组件侦听器，并返回生成的组播侦听器。
        参数
        l - component-listener-l
        oldl - 组件侦听器被删除
        结果
        产生的听众

      • remove

        public static ContainerListener remove​(ContainerListener l,
                                       ContainerListener oldl)
        从container-listener-l中删除旧容器监听器，并返回生成的组播侦听器。
        参数
        l - container-listener-l
        oldl - 正在删除的容器侦听器
        结果
        产生的听众

      • remove

        public static FocusListener remove​(FocusListener l,
                                   FocusListener oldl)
        从focus-listener-l中删除旧的focus-listener，并返回生成的组播监听器。
        参数
        l - focus-listener-l
        oldl - 正在删除焦点侦听器
        结果
        产生的听众

      • remove

        public static KeyListener remove​(KeyListener l,
                                 KeyListener oldl)
        从key-listener-l中删除旧的密钥监听器，并返回生成的组播侦听器。
        参数
        l - key-listener-l
        oldl - 正在删除的密钥监听器
        结果
        产生的听众

      • remove

        public static MouseListener remove​(MouseListener l,
                                   MouseListener oldl)
        从mouse-listener-l中删除旧的鼠标监听器，并返回生成的组播侦听器。
        参数
        l - mouse-listener-l
        oldl - 正在删除的鼠标监听器
        结果
        产生的听众

      • remove

        public static MouseMotionListener remove​(MouseMotionListener l,
                                         MouseMotionListener oldl)
        从mouse-motion-listener-l中删除旧的鼠标移动监听器，并返回生成的组播侦听器。
        参数
        l - mouse-motion-listener-l
        oldl - 正在删除的鼠标移动监听器
        结果
        产生的听众

      • remove

        public static WindowListener remove​(WindowListener l,
                                    WindowListener oldl)
        从window-listener-l中删除旧的window-listener，并返回结果组播监听器。
        参数
        l - window-listener-l
        oldl - 正在删除的窗口监听器
        结果
        产生的听众

      • remove

        public static WindowStateListener remove​(WindowStateListener l,
                                         WindowStateListener oldl)
        从window-state-listener-l中删除旧的window-state-listener，并返回结果组播监听器。
        参数
        l - window-state-listener-l
        oldl - 正在删除的窗口状态监听器
        结果
        产生的听众
        从以下版本开始：
        1.4

      • remove

        public static WindowFocusListener remove​(WindowFocusListener l,
                                         WindowFocusListener oldl)
        从window-focus-listener-l中删除旧的window-focus-listener，并返回结果组播监听器。
        参数
        l - window-focus-listener-l
        oldl - 正在删除的窗口焦点侦听器
        结果
        产生的听众
        从以下版本开始：
        1.4

      • remove

        public static ActionListener remove​(ActionListener l,
                                    ActionListener oldl)
        从action-listener-l中删除旧的action-listener，并返回生成的组播侦听器。
        参数
        l - action-listener-l
        oldl - 正在删除的动作侦听器
        结果
        产生的听众

      • remove

        public static ItemListener remove​(ItemListener l,
                                  ItemListener oldl)
        从item-listener-l中删除旧的项目监听器，并返回生成的组播侦听器。
        参数
        l - item-listener-l
        oldl - 删除的项目监听器
        结果
        产生的听众

      • remove

        public static AdjustmentListener remove​(AdjustmentListener l,
                                        AdjustmentListener oldl)
        从调整监听器l中删除旧的调整监听器，并返回结果组播监听器。
        参数
        l - 调整监听器
        oldl - 正在删除调整监听器
        结果
        产生的听众

      • remove

        public static TextListener remove​(TextListener l,
                                  TextListener oldl)
        从text-listener-l中删除旧的文本侦听器，并返回生成的组播侦听器。
        参数
        l - text-listener-l
        oldl - 正在删除的文本侦听器
        结果
        产生的听众

      • remove

        public static InputMethodListener remove​(InputMethodListener l,
                                         InputMethodListener oldl)
        从input-method-listener-l中删除旧的输入法侦听器，并返回生成的组播侦听器。
        参数
        l - input-method-listener-l
        oldl - 正在删除的输入法监听器
        结果
        产生的听众

      • remove

        public static HierarchyListener remove​(HierarchyListener l,
                                       HierarchyListener oldl)
        从hierarchy-listener-l中删除旧的层次结构监听器，并返回结果组播监听器。
        参数
        l - hierarchy-listener-l
        oldl - 已删除的层次监听器
        结果
        产生的听众
        从以下版本开始：
        1.3

      • remove

        public static HierarchyBoundsListener remove​(HierarchyBoundsListener l,
                                             HierarchyBoundsListener oldl)
        从hierarchy-bounds-listener-l中删除旧的hierarchy-bounds-listener，并返回生成的组播监听器。
        参数
        l - hierarchy-bounds-listener-l
        oldl - 已删除的层级结构侦听器
        结果
        产生的听众
        从以下版本开始：
        1.3

      • remove

        public static MouseWheelListener remove​(MouseWheelListener l,
                                        MouseWheelListener oldl)
        从mouse-wheel-listener-l中删除旧的鼠标滚轮监听器，并返回生成的组播侦听器。
        参数
        l - mouse-wheel-listener-l
        oldl - 正在删除的鼠标滚轮监听器
        结果
        产生的听众
        从以下版本开始：
        1.4

      • addInternal

        protected static EventListener addInternal​(EventListener a,
                                           EventListener b)
        通过将listener-a和listener-b添加到一起返回生成的多播监听器。 如果listener-a为null，则返回listener-b; 如果listener-b为null，则返回listener-a如果both都不为null，则创建并返回一个新的AWTEventMulticaster实例，该实例将a与b链接起来。
        参数
        a - 事件侦听器a
        b - 事件侦听器b
        结果
        产生的听众

      • removeInternal

        protected static EventListener removeInternal​(EventListener l,
                                              EventListener oldl)
        从listener-l中删除旧的侦听器后，返回生成的多播侦听器。 如果listener-l等于旧的监听器，或者listener-l为null，则返回null。 否则，如果listener-l是AWTEventMulticaster的一个实例，那么它会从中删除旧的侦听器。 否则，返回侦听器l。
        参数
        l - 从中删除的侦听器
        oldl - 被删除的侦听器
        结果
        产生的听众

      • saveInternal

        protected void saveInternal​(ObjectOutputStream s,
                            String k)
                     throws IOException
        序列化支持。 将所有可序列化侦听器保存到序列化流。
        参数
        s - 要保存的流
        k - 在每个可序列化侦听器之前放置的前缀流
        异常
        IOException - 如果序列化失败

      • save

        protected static void save​(ObjectOutputStream s,
                           String k,
                           EventListener l)
                    throws IOException
        将可序列化的监听器链保存到序列化流。
        参数
        s - 要保存的流
        k - 在每个可序列化侦听器之前放置的前缀流
        l - 监听链保存
        异常
        IOException - 如果序列化失败

      • getListeners

        public static <T extends EventListener> T[] getListeners​(EventListener l,
                                                         Class<T> listenerType)
        返回链作为所有对象的数组FooListener由该指定S java.util.EventListener 。 FooListener由AWTEventMulticaster链接使用addFooListener方法。 如果指定了一个null监听器，则此方法返回一个空数组。 如果指定的监听器不是AWTEventMulticaster的实例，则此方法返回一个仅包含指定侦听器的数组。 如果没有这样的监听器被链接，这个方法返回一个空数组。
        参数类型
        T - 侦听器类型
        参数
        l - 指定的 java.util.EventListener
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        由指定的多播侦听器链接为 FooListener的所有对象的数组，如果没有这样的侦听器被指定的多播侦听器链接，则为空数组
        异常
        NullPointerException - 如果指定的 listenertype参数为 null
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class AWTException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.AWTException
  • All Implemented Interfaces:
    Serializable

    public class AWTException
extends 异常
    表示发生抽象窗口工具包异常。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AWTException​(String msg)
      使用指定的详细消息构造一个 AWTException的实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AWTException

        public AWTException​(String msg)
        构造具有指定详细消息的AWTException实例。 详细信息是描述这个特殊异常的String一个实例。
        参数
        msg - 详细信息
        从以下版本开始：
        1.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTKeyStroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class AWTKeyStroke

  • java.lang.Object
    • java.awt.AWTKeyStroke
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    KeyStroke

    public class AWTKeyStroke
extends Object
implements Serializable
    一个AWTKeyStroke代表键盘或等效输入设备上的一个关键动作。 AWTKeyStroke可以只对应一个特定键的按下或释放，就像KEY_PRESSED和KEY_RELEASED KeyEvent一样; 或者，它们可以对应于键入特定的Java字符，就像KEY_TYPED KeyEvent一样。 在所有情况下， AWTKeyStroke可以指定在精确匹配的动作期间必须存在的修饰符（alt，shift，control，meta，altGraph或其组合）。

    AWTKeyStrokes是不可变的，意图是独一无二的。 客户端代码不应该自己创建一个AWTKeyStroke ，而应该使用getAWTKeyStroke的变体。 客户端使用这些工厂方法可以使AWTKeyStroke实现高效缓存和共享实例。

    从以下版本开始：
    1.4
    另请参见：
    getAWTKeyStroke(char) ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AWTKeyStroke​()
      构造一个具有默认值的 AWTKeyStroke 。
      protected AWTKeyStroke​(char keyChar, int keyCode, int modifiers, boolean onKeyRelease)
      构造具有指定值的 AWTKeyStroke 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean equals​(Object anObject)
      如果此对象与指定的对象相同，则返回true。
      static AWTKeyStroke getAWTKeyStroke​(char keyChar)
      返回一个 AWTKeyStroke的共享实例，表示指定字符的 KEY_TYPED事件。
      static AWTKeyStroke getAWTKeyStroke​(int keyCode, int modifiers)
      返回一个 AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符。
      static AWTKeyStroke getAWTKeyStroke​(int keyCode, int modifiers, boolean onKeyRelease)
      返回一个 AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符，指定按下或释放键是否被激活。
      static AWTKeyStroke getAWTKeyStroke​(Character keyChar, int modifiers)
      返回一个 AWTKeyStroke的共享实例，该实例表示指定的Character对象和一组修饰符的一个 KEY_TYPED事件。
      static AWTKeyStroke getAWTKeyStroke​(String s)
      解析一个字符串并返回一个 AWTKeyStroke 。
      static AWTKeyStroke getAWTKeyStrokeForEvent​(KeyEvent anEvent)
      返回一个 AWTKeyStroke ，表示生成给定的 KeyEvent 。
      char getKeyChar​()
      返回此 AWTKeyStroke的字符。
      int getKeyCode​()
      返回此 AWTKeyStroke的数字键代码。
      int getKeyEventType​()
      返回对应于此 AWTKeyStroke的 KeyEvent的类型。
      int getModifiers​()
      返回此 AWTKeyStroke的修饰键。
      int hashCode​()
      返回可能是唯一的该对象的数值，使其成为哈希表中的索引值的良好选择。
      boolean isOnKeyRelease​()
      返回这个 AWTKeyStroke是否是一个关键版本。
      protected Object readResolve​()
      返回的缓存实例 AWTKeyStroke （或子类 AWTKeyStroke ），这是此实例相等。
      protected static void registerSubclass​(Class<?> subclass)
      已过时。
      String toString​()
      返回显示和标识此对象属性的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AWTKeyStroke

        protected AWTKeyStroke​()
        构造一个具有默认值的AWTKeyStroke 。 使用的默认值为： AWTKeyStroke default values Property Default Value Key Char KeyEvent.CHAR_UNDEFINED Key Code KeyEvent.VK_UNDEFINED Modifiers none On key release? false
        AWTKeyStroke s不应由客户端代码构建。 使用变体getAWTKeyStroke代替。
        另请参见：
        getAWTKeyStroke(char)

      • AWTKeyStroke

        protected AWTKeyStroke​(char keyChar,
                       int keyCode,
                       int modifiers,
                       boolean onKeyRelease)
        构造具有指定值的AWTKeyStroke 。 AWTKeyStroke不应由客户端代码构建。 改用getAWTKeyStroke的变体。
        参数
        keyChar - 键盘键的字符值
        keyCode - 这个 AWTKeyStroke的关键代码
        modifiers - 任何修饰符的按位组合
        onKeyRelease - true如果这AWTKeyStroke对应于密钥释放; 否则为false
        另请参见：
        getAWTKeyStroke(char)

    • 方法详细信息

      • registerSubclass

        @Deprecated
protected static void registerSubclass​(Class<?> subclass)
        已过时。
        该方法没有任何效果，仅存在以避免引入二进制不兼容性。
        参数
        subclass - 工厂方法应该创建实例的新类

      • getAWTKeyStroke

        public static AWTKeyStroke getAWTKeyStroke​(char keyChar)
        返回一个 AWTKeyStroke的共享实例，表示指定字符的 KEY_TYPED事件。
        参数
        keyChar - 键盘键的字符值
        结果
        该键的一个 AWTKeyStroke对象

      • getAWTKeyStroke

        public static AWTKeyStroke getAWTKeyStroke​(Character keyChar,
                                           int modifiers)
        返回一个AWTKeyStroke的共享实例，该实例表示指定的Character对象的KEY_TYPED事件和一组修饰符。 请注意，第一个参数的类型是Character而不是char。 这是为了避免与呼叫getAWTKeyStroke(int keyCode, int modifiers)意外冲突。 修饰符由以下任意组合组成：
        • java.awt.event.InputEvent.SHIFT_DOWN_MASK
        • java.awt.event.InputEvent.CTRL_DOWN_MASK
        • java.awt.event.InputEvent.META_DOWN_MASK
        • java.awt.event.InputEvent.ALT_DOWN_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
        下面列出的旧修饰符也可以使用，但它们映射到_DOWN_修饰符。
        • java.awt.event.InputEvent.SHIFT_MASK
        • java.awt.event.InputEvent.CTRL_MASK
        • java.awt.event.InputEvent.META_MASK
        • java.awt.event.InputEvent.ALT_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_MASK
        也可以使用，但它们被映射到_DOWN_修饰符。 由于这些数字都是两个不同的幂，它们的任何组合都是整数，其中每个位表示不同的修饰符键。 使用0指定没有修饰符。
        参数
        keyChar - 键盘字符的Character对象
        modifiers - 任何修饰符的按位组合
        结果
        该键的一个 AWTKeyStroke对象
        异常
        IllegalArgumentException - 如果 keyChar是 null
        另请参见：
        InputEvent

      • getAWTKeyStroke

        public static AWTKeyStroke getAWTKeyStroke​(int keyCode,
                                           int modifiers,
                                           boolean onKeyRelease)
        返回一个AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符，指定在按下或释放该键时是否激活该键。

        可以使用java.awt.event.KeyEvent定义的“虚拟键”常量来指定密钥代码。 例如：

        • java.awt.event.KeyEvent.VK_ENTER
        • java.awt.event.KeyEvent.VK_TAB
        • java.awt.event.KeyEvent.VK_SPACE
        或者，密钥代码可以通过调用java.awt.event.KeyEvent.getExtendedKeyCodeForChar获得。 修饰符由以下任何组合组成：
        • java.awt.event.InputEvent.SHIFT_DOWN_MASK
        • java.awt.event.InputEvent.CTRL_DOWN_MASK
        • java.awt.event.InputEvent.META_DOWN_MASK
        • java.awt.event.InputEvent.ALT_DOWN_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
        旧的修饰语
        • java.awt.event.InputEvent.SHIFT_MASK
        • java.awt.event.InputEvent.CTRL_MASK
        • java.awt.event.InputEvent.META_MASK
        • java.awt.event.InputEvent.ALT_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_MASK
        也可以使用，但它们被映射到_DOWN_修饰符。 由于这些数字都是两个不同的幂，它们的任何组合都是整数，其中每个位表示不同的修饰符键。 使用0指定没有修饰符。
        参数
        keyCode - 指定键盘键的数字代码的int
        modifiers - 任何修饰符的按位组合
        onKeyRelease - true如果AWTKeyStroke应该代表一个关键版本; 否则为false
        结果
        该键的AWTKeyStroke对象
        另请参见：
        KeyEvent ， InputEvent

      • getAWTKeyStroke

        public static AWTKeyStroke getAWTKeyStroke​(int keyCode,
                                           int modifiers)
        返回一个AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符。 返回的AWTKeyStroke将对应一个按键。

        可以使用java.awt.event.KeyEvent定义的“虚拟键”常量来指定密钥代码。 例如：

        • java.awt.event.KeyEvent.VK_ENTER
        • java.awt.event.KeyEvent.VK_TAB
        • java.awt.event.KeyEvent.VK_SPACE
        修饰符由以下任何组合组成：
        • java.awt.event.InputEvent.SHIFT_DOWN_MASK
        • java.awt.event.InputEvent.CTRL_DOWN_MASK
        • java.awt.event.InputEvent.META_DOWN_MASK
        • java.awt.event.InputEvent.ALT_DOWN_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
        旧的修饰语
        • java.awt.event.InputEvent.SHIFT_MASK
        • java.awt.event.InputEvent.CTRL_MASK
        • java.awt.event.InputEvent.META_MASK
        • java.awt.event.InputEvent.ALT_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_MASK
        也可以使用，但它们被映射到_DOWN_修饰符。 由于这些数字都是两个不同的幂，它们的任何组合都是整数，其中每个位表示不同的修饰符键。 使用0指定没有修饰符。
        参数
        keyCode - 指定键盘键的数字代码的int
        modifiers - 任何修饰符的按位组合
        结果
        该键的一个 AWTKeyStroke对象
        另请参见：
        KeyEvent ， InputEvent

      • getAWTKeyStrokeForEvent

        public static AWTKeyStroke getAWTKeyStrokeForEvent​(KeyEvent anEvent)
        返回一个AWTKeyStroke ，表示生成给定的KeyEvent 。

        该方法从KeyTyped事件获取keyChar，并从KeyPressed或KeyReleased事件获取keyCode。 所有三种类型的KeyEvent都可以获得KeyEvent修饰符。

        参数
        anEvent - KeyEvent从中获取 AWTKeyStroke
        结果
        AWTKeyStroke沉淀了事件
        异常
        NullPointerException - 如果 anEvent为空

      • getAWTKeyStroke

        public static AWTKeyStroke getAWTKeyStroke​(String s)
        解析一个字符串并返回一个AWTKeyStroke 。 字符串必须具有以下语法：
          <modifiers>* (<typedID> | <pressedReleasedID>)

    modifiers := shift | control | ctrl | meta | alt | altGraph
    typedID := typed <typedKey>
    typedKey := string of length 1 giving Unicode character.
    pressedReleasedID := (pressed | released) key
    key := KeyEvent key code name, i.e. the name following "VK_".
        如果没有指定键入，按下或释放，则按下。 这里有些例子：
          "INSERT" => getAWTKeyStroke(KeyEvent.VK_INSERT, 0);
     "control DELETE" => getAWTKeyStroke(KeyEvent.VK_DELETE, InputEvent.CTRL_MASK);
     "alt shift X" => getAWTKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK);
     "alt shift released X" => getAWTKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK, true);
     "typed a" => getAWTKeyStroke('a');
        参数
        s - 一个如上所述格式化的字符串
        结果
        该字符串的一个 AWTKeyStroke对象
        异常
        IllegalArgumentException - 如果 s是 null ，或格式不正确

      • getKeyChar

        public final char getKeyChar​()
        返回此 AWTKeyStroke的字符。
        结果
        一个char值
        另请参见：
        getAWTKeyStroke(char) ， KeyEvent.getKeyChar()

      • getKeyCode

        public final int getKeyCode​()
        返回 AWTKeyStroke的数字键代码。
        结果
        一个包含键代码值的int
        另请参见：
        getAWTKeyStroke(int,int) ， KeyEvent.getKeyCode()

      • getModifiers

        public final int getModifiers​()
        返回此 AWTKeyStroke的修饰键。
        结果
        一个包含修饰符的int
        另请参见：
        getAWTKeyStroke(int,int)

      • isOnKeyRelease

        public final boolean isOnKeyRelease​()
        返回这个 AWTKeyStroke是否是一个关键版本。
        结果
        true如果这个AWTKeyStroke代表了一个关键的版本; 否则为false
        另请参见：
        getAWTKeyStroke(int,int,boolean)

      • getKeyEventType

        public final int getKeyEventType​()
        返回对应于此 AWTKeyStroke的 KeyEvent的类型。
        结果
        KeyEvent.KEY_PRESSED ， KeyEvent.KEY_TYPED ，或 KeyEvent.KEY_RELEASED
        另请参见：
        KeyEvent

      • hashCode

        public int hashCode​()
        返回可能是唯一的该对象的数值，使其成为哈希表中的索引值的良好选择。
        重写：
        hashCode在 Object
        结果
        一个表示此对象的int
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public final boolean equals​(Object anObject)
        如果此对象与指定的对象相同，则返回true。
        重写：
        equals在 Object
        参数
        anObject - 将该对象与之对比的对象
        结果
        如果对象相同，则为true
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回显示和标识此对象属性的字符串。 该String返回的String可以作为参数传递给getAWTKeyStroke(String)以产生等于此关键笔划的关键笔划。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式
        另请参见：
        getAWTKeyStroke(String)

      • readResolve

        protected Object readResolve​()
                      throws ObjectStreamException
        返回的缓存实例 AWTKeyStroke （或子类 AWTKeyStroke ），这是此实例相等。
        结果
        一个与此实例相同的缓存实例
        异常
        ObjectStreamException - 如果发生序列化问题
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class AWTPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.awt.AWTPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class AWTPermission
extends BasicPermission
    此类用于AWT权限。 一个AWTPermission包含一个目标名称，但没有动作列表; 你有指定的权限，或者你没有。

    目标名称是AWT许可的名称（见下文）。 命名约定遵循层次化属性命名约定。 此外，星号可用于表示所有AWT权限。

    下表列出了所有可能的AWTPermission目标名称，每个都提供了许可允许的描述以及授权许可的风险的讨论。

    AWTPermission target names, descriptions, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission accessClipboard Posting and retrieval of information to and from the AWT clipboard This would allow malfeasant code to share potentially sensitive or confidential information. accessEventQueue Access to the AWT event queue After retrieving the AWT event queue, malicious code may peek at and even remove existing events from its event queue, as well as post bogus events which may purposefully cause the application or applet to misbehave in an insecure manner. accessSystemTray Access to the AWT SystemTray instance This would allow malicious code to add tray icons to the system tray. First, such an icon may look like the icon of some known application (such as a firewall or anti-virus) and order a user to do something unsafe (with help of balloon messages). Second, the system tray may be glutted with tray icons so that no one could add a tray icon anymore. createRobot Create java.awt.Robot objects The java.awt.Robot object allows code to generate native-level mouse and keyboard events as well as read the screen. It could allow malicious code to control the system, run other programs, read the display, and deny mouse and keyboard access to the user. fullScreenExclusive Enter full-screen exclusive mode Entering full-screen exclusive mode allows direct access to low-level graphics card memory. This could be used to spoof the system, since the program is in direct control of rendering. Depending on the implementation, the security warning may not be shown for the windows used to enter the full-screen exclusive mode (assuming that the fullScreenExclusive permission has been granted to this application). Note that this behavior does not mean that the showWindowWithoutWarningBanner permission will be automatically granted to the application which has the fullScreenExclusive permission: non-full-screen windows will continue to be shown with the security warning. listenToAllAWTEvents Listen to all AWT events, system-wide After adding an AWT event listener, malicious code may scan all AWT events dispatched in the system, allowing it to read all user input (such as passwords). Each AWT event listener is called from within the context of that event queue's EventDispatchThread, so if the accessEventQueue permission is also enabled, malicious code could modify the contents of AWT event queues system-wide, causing the application or applet to misbehave in an insecure manner. readDisplayPixels Readback of pixels from the display screen Interfaces such as the java.awt.Composite interface or the java.awt.Robot class allow arbitrary code to examine pixels on the display enable malicious code to snoop on the activities of the user. replaceKeyboardFocusManager Sets the KeyboardFocusManager for a particular thread. When SecurityManager is installed, the invoking thread must be granted this permission in order to replace the current KeyboardFocusManager. If permission is not granted, a SecurityException will be thrown. setAppletStub Setting the stub which implements Applet container services Malicious code could set an applet's stub and result in unexpected behavior or denial of service to an applet. setWindowAlwaysOnTop Setting always-on-top property of the window: Window.setAlwaysOnTop(boolean) The malicious window might make itself look and behave like a real full desktop, so that information entered by the unsuspecting user is captured and subsequently misused showWindowWithoutWarningBanner Display of a window without also displaying a banner warning that the window was created by an applet Without this warning, an applet may pop up windows without the user knowing that they belong to an applet. Since users may make security-sensitive decisions based on whether or not the window belongs to an applet (entering a username and password into a dialog box, for example), disabling this warning banner may allow applets to trick the user into entering such information. toolkitModality Creating TOOLKIT_MODAL dialogs and setting the TOOLKIT_EXCLUDE window property. When a toolkit-modal dialog is shown from an applet, it blocks all other applets in the browser. When launching applications from Java Web Start, its windows (such as the security dialog) may also be blocked by toolkit-modal dialogs, shown from these applications. watchMousePointer Getting the information about the mouse pointer position at any time Constantly watching the mouse pointer, an applet can make guesses about what the user is doing, i.e. moving the mouse to the lower left corner of the screen most likely means that the user is about to launch an application. If a virtual keypad is used so that keyboard is emulated using the mouse, an applet may guess what is being typed.
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AWTPermission​(String name)
      用指定的名称创建一个新的 AWTPermission 。
      AWTPermission​(String name, String actions)
      使用指定的名称创建一个新的 AWTPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • AWTPermission

        public AWTPermission​(String name)
        创建一个具有指定名称的新的AWTPermission 。 该名称是AWTPermission的符号名称，例如“topLevelWindow”，“systemClipboard”等。星号可用于指示所有AWT权限。
        参数
        name - AWTPermission的名称
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • AWTPermission

        public AWTPermission​(String name,
                     String actions)
        创建具有指定名称的新的AWTPermission对象。 该名称是AWTPermission的符号名称，并且操作字符串当前未使用，应为null 。
        参数
        name - 名称为 AWTPermission
        actions - 应为 null
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BasicStroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class BasicStroke

  • java.lang.Object
    • java.awt.BasicStroke
  • All Implemented Interfaces:
    Stroke

    public class BasicStroke
extends Object
implements Stroke
    BasicStroke类为图形基元的轮廓定义了一组基本的渲染属性，这些属性用一个Graphics2D对象，其Stroke属性设置为BasicStroke 。 由BasicStroke定义的渲染属性描述了由沿着Shape的轮廓绘制的笔形成的标记的形状，以及应用于Shape的路径段的末端和连接处的Shape 。 这些呈现属性包括：
    宽度
    笔宽，垂直于钢笔轨迹测量。
    端帽
    装饰应用于未封闭的子路径和划线段的末端。 如果没有CLOSE段，则在同一点开始和结束的子路径仍然被视为未关闭。 有关CLOSE段的更多信息，请参阅SEG_CLOSE 。 三个不同的装饰是： CAP_BUTT ， CAP_ROUND ，并CAP_SQUARE 。
    线连接
    在两个路径段的交点处和在使用SEG_CLOSE关闭的子路径的端点的交点处应用的装饰。 三个不同的装饰是： JOIN_BEVEL ， JOIN_MITER ，并JOIN_ROUND 。
    斜角极限
    修剪具有JOIN_MITER装饰的线连接的限制。 当斜角长度与行程宽度的比率大于斜度值时，将修剪线连接。 斜角长度是斜角的对角线长度，它是交点的内角和外角之间的距离。 由两个线段形成的角度越小，斜角越长，交叉角越锐。 10.0f的默认miterlimit值会导致所有小于11度的角度被修剪。 修剪斜纹体将线接合的装饰转换为斜角。
    破折号属性
    定义如何通过在不透明和透明部分之间交替来制作破折号。
    指定测量值和控制返回轮廓形状的距离的所有属性都与原始的无Shape参数Shape Shape 。 当Graphics2D对象使用Stroke对象在执行其draw方法之一期间重新定义路径时，在应用Graphics2D变换属性之前， Graphics2D原始格式提供几何。 因此，诸如笔宽度的属性在Graphics2D对象的用户空间坐标系中被解释，并且受到特定Graphics2D用户空间到设备空间变换的缩放和剪切效应的影响。 例如，渲染形状的轮廓的宽度不仅由该BasicStroke的width属性BasicStroke ，而且由Graphics2D对象的transform属性确定。 考虑这个代码：

      // sets the Graphics2D object's Transform attribute
      g2d.scale(10, 10);
      // sets the Graphics2D object's Stroke attribute
      g2d.setStroke(new BasicStroke(1.5f));
    假设没有其他缩放变换添加到Graphics2D对象中，生成的行将大约为15像素宽。 如示例代码所示，浮点线提供更好的精度，特别是当使用Graphics2D对象的大型变换时。 当一条线是对角线时，确切的宽度取决于渲染管道如何选择要填充的像素，因为它跟踪了理论上的扩展轮廓。 由于抗锯齿渲染流水线可以选择对部分覆盖的像素进行颜色化，所以要打开的像素的选择受抗锯齿属性的影响。

    有关用户空间坐标系和渲染过程的更多信息，请参阅Graphics2D类注释。

    另请参见：
    Graphics2D

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CAP_BUTT
      结束未封闭的子路径和划线段，没有添加装饰。
      static int CAP_ROUND
      用圆形装饰结束未封闭的子路径和划线段，半圆形的半径等于笔宽的一半。
      static int CAP_SQUARE
      结束未封闭的子路径和划线段，其中方块投影延伸超出段的末端至等于线宽一半的距离。
      static int JOIN_BEVEL
      通过连接其广泛轮廓的外角与直线段来连接路段。
      static int JOIN_MITER
      通过延伸它们的外边缘直到它们相遇来连接路段。
      static int JOIN_ROUND
      通过以半角宽度的半径舍入角落来连接路径段。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BasicStroke​()
      构造一个新的 BasicStroke具有所有属性的默认值。
      BasicStroke​(float width)
      构造一个固定的 BasicStroke具有指定的线宽，并使用上限和连接样式的默认值。
      BasicStroke​(float width, int cap, int join)
      构造具有指定属性的固体 BasicStroke 。
      BasicStroke​(float width, int cap, int join, float miterlimit)
      构造具有指定属性的实体 BasicStroke 。
      BasicStroke​(float width, int cap, int join, float miterlimit, float[] dash, float dash_phase)
      构造具有指定属性的新的 BasicStroke 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Shape createStrokedShape​(Shape s)
      返回一个 Shape其内部定义了指定的 Shape的抚摸轮廓。
      boolean equals​(Object obj)
      测试指定的对象是否等于 BasicStroke ，首先测试是否为 BasicStroke ，然后将其宽度，连接，上限， BasicStroke限制，破折号和破折号相位属性与该 BasicStroke 。
      float[] getDashArray​()
      返回表示短划线段长度的数组。
      float getDashPhase​()
      返回当前的虚线阶段。
      int getEndCap​()
      返回端帽样式。
      int getLineJoin​()
      返回行连接样式。
      float getLineWidth​()
      返回行宽。
      float getMiterLimit​()
      返回斜角连接的极限。
      int hashCode​()
      返回此笔画的哈希码。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • JOIN_MITER

        @Native
public static final int JOIN_MITER
        通过延伸它们的外边缘直到它们相遇来连接路段。
        另请参见：
        Constant Field Values

      • JOIN_ROUND

        @Native
public static final int JOIN_ROUND
        通过以半角宽度的半径舍入角落来连接路径段。
        另请参见：
        Constant Field Values

      • JOIN_BEVEL

        @Native
public static final int JOIN_BEVEL
        通过连接其广泛轮廓的外角与直线段来连接路段。
        另请参见：
        Constant Field Values

      • CAP_BUTT

        @Native
public static final int CAP_BUTT
        结束未封闭的子路径和划线段，没有添加装饰。
        另请参见：
        Constant Field Values

      • CAP_ROUND

        @Native
public static final int CAP_ROUND
        用圆形装饰结束未封闭的子路径和划线段，半圆形的半径等于笔宽的一半。
        另请参见：
        Constant Field Values

      • CAP_SQUARE

        @Native
public static final int CAP_SQUARE
        结束未封闭的子路径和划线段，其中方块投影延伸超出段的末端至等于线宽一半的距离。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BasicStroke

        @ConstructorProperties({"lineWidth","endCap","lineJoin","miterLimit","dashArray","dashPhase"})
public BasicStroke​(float width,
                   int cap,
                   int join,
                   float miterlimit,
                   float[] dash,
                   float dash_phase)
        构造具有指定属性的新的 BasicStroke 。
        参数
        width - 这个BasicStroke的宽度。 宽度必须大于或等于0.0f。 如果width设置为0.0f，笔画将被渲染为目标设备的最薄可能的线和反锯齿提示设置。
        cap - 装饰的一端 BasicStroke
        join - 路径段相遇的装饰
        miterlimit - 修剪斜接连接的限制。 斜度必须大于或等于1.0f。
        dash - 表示 dash模式的数组
        dash_phase - 启动破折号模式的偏移量
        异常
        IllegalArgumentException - 如果 width为负数
        IllegalArgumentException - 如果 cap不是CAP_BUTT，CAP_ROUND或CAP_SQUARE
        IllegalArgumentException - 如果 miterlimit小于1，并且 join是 join
        IllegalArgumentException - 如果 join不是 join ，JOIN_BEVEL或JOIN_MITER
        IllegalArgumentException - 如果 dash_phase是负的，而 dash不是 null
        IllegalArgumentException -如果长度 dash为零
        IllegalArgumentException - 如果破折号全部为零。

      • BasicStroke

        public BasicStroke​(float width,
                   int cap,
                   int join,
                   float miterlimit)
        构造具有指定属性的实体 BasicStroke 。
        参数
        width - 宽度为 BasicStroke
        cap - 装饰的一端 BasicStroke
        join - 路径段遇到的装饰
        miterlimit - 修剪斜接连接的限制
        异常
        IllegalArgumentException - 如果 width为负数
        IllegalArgumentException - 如果 cap不是CAP_BUTT，CAP_ROUND或CAP_SQUARE
        IllegalArgumentException - 如果 miterlimit小于1，而 join是 join
        IllegalArgumentException - 如果 join不是 join ，JOIN_BEVEL或JOIN_MITER

      • BasicStroke

        public BasicStroke​(float width,
                   int cap,
                   int join)
        构造具有指定属性的实体BasicStroke 。 在允许默认值或者没有将线路连接指定为miterlimit情况下， miterlimit参数是不必要的。
        参数
        width - 宽度为 BasicStroke
        cap - 装饰的一端 BasicStroke
        join - 路径段相遇的装饰
        异常
        IllegalArgumentException - 如果 width为负数
        IllegalArgumentException - 如果 cap不是CAP_BUTT，CAP_ROUND或CAP_SQUARE
        IllegalArgumentException - 如果 join不是 join ，JOIN_BEVEL或JOIN_MITER

      • BasicStroke

        public BasicStroke​(float width)
        构造一个固定的 BasicStroke具有指定的行宽，并使用上限和连接样式的默认值。
        参数
        width - 宽度为 BasicStroke
        异常
        IllegalArgumentException - 如果 width为负数

      • BasicStroke

        public BasicStroke​()
        构造一个新的BasicStroke ，其默认BasicStroke所有属性。 默认属性是宽度为1.0的实线，CAP_SQUARE，JOIN_MITER，斜度限制为10.0。

    • 方法详细信息

      • createStrokedShape

        public Shape createStrokedShape​(Shape s)
        返回一个 Shape其内部定义了指定的 Shape的抚摸轮廓。
        Specified by:
        createStrokedShape在接口 Stroke
        参数
        s - Shape边界被抚摸
        结果
        Shape的抚摸大纲。

      • getLineWidth

        public float getLineWidth​()
        返回行宽。 线宽在用户空间中表示，这是Java 2D使用的默认坐标空间。 有关用户空间坐标系的更多信息，请参阅Graphics2D类注释。
        结果
        该线的宽度为 BasicStroke 。
        另请参见：
        Graphics2D

      • getEndCap

        public int getEndCap​()
        返回端帽样式。
        结果
        该端帽样式为 BasicStroke作为静态的 int值定义可能的端帽样式。

      • getLineJoin

        public int getLineJoin​()
        返回行连接样式。
        结果
        BasicStroke的线连接样式作为定义可能的线连接样式的静态 int值之一。

      • getMiterLimit

        public float getMiterLimit​()
        返回斜角连接的极限。
        结果
        极限连接的斜角 BasicStroke 。

      • getDashArray

        public float[] getDashArray​()
        返回表示短划线段长度的数组。 数组中的备用条目表示破折号的不透明和透明段的用户空间长度。 随着笔沿着要抚摸的Shape的轮廓移动，笔的行进的用户空间距离被累积。 距离值用于索引到仪表盘阵列中。 当笔的当前累积距离映射到仪表阵列的偶数元素时，笔是不透明的，否则为透明度。
        结果
        破折号阵列。

      • getDashPhase

        public float getDashPhase​()
        返回当前的虚线阶段。 破折号相位是用户坐标中指定的距离，表示破折号图案的偏移量。 换句话说，虚线阶段定义了冲击模式中对应于笔画开头的点。
        结果
        破折号为 float值。

      • hashCode

        public int hashCode​()
        返回此笔画的哈希码。
        重写：
        hashCode在 Object
        结果
        这个笔画的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        测试指定的对象是否等于 BasicStroke ，首先测试是否是 BasicStroke ，然后将其宽度，连接，上限， BasicStroke限制，破折号和破折号相位属性与该 BasicStroke 。
        重写：
        equals在 Object
        参数
        obj - 与此 BasicStroke进行比较的指定对象
        结果
        true如果两个对象的宽度，连接，上限， true限制，破折号和破折号相位是相同的; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BorderLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class BorderLayout

  • java.lang.Object
    • java.awt.BorderLayout
  • All Implemented Interfaces:
    LayoutManager ， LayoutManager2 ， Serializable

    public class BorderLayout
extends Object
implements LayoutManager2, Serializable
    边界布局设置了一个容器，安排和调整其组件，以适应五个区域：北，南，东，西和中心。 每个区域可以含有不超过一个部件，并且通过相应的常数确定： NORTH ， SOUTH ， EAST ， WEST ，和CENTER 。 将组件添加到具有边框布局的容器时，请使用以下五个常量之一，例如：
      Panel p = new Panel();
    p.setLayout(new BorderLayout());
    p.add(new Button("Okay"), BorderLayout.SOUTH);
    为了方便起见， BorderLayout解释了不存在与常量CENTER相同的字符串规范：
      Panel p2 = new Panel();
    p2.setLayout(new BorderLayout());
    p2.add(new TextArea());  // Same as p.add(new TextArea(), BorderLayout.CENTER);

    此外， BorderLayout支持相对定位的常数， PAGE_START ， PAGE_END ， LINE_START ，和LINE_END 。 在容器中，其ComponentOrientation设定为ComponentOrientation.LEFT_TO_RIGHT ，这些常数映射到NORTH ， SOUTH ， WEST ，和EAST分别。

    对于与以前版本的兼容性， BorderLayout还包括相对定位常数BEFORE_FIRST_LINE ， AFTER_LAST_LINE ， BEFORE_LINE_BEGINS和AFTER_LINE_ENDS 。 这些等同于PAGE_START ， PAGE_END ， LINE_START和LINE_END分别。 为了与其他组分使用的相对定位常数一致，后一个常数是优选的。

    混合绝对和相对定位常数可能导致不可预测的结果。 如果使用这两种类型，相对常数将优先。 例如，如果在方向为LEFT_TO_RIGHT的容器中使用NORTH和PAGE_START常量添加组件，则只会PAGE_START 。

    注意：目前， BorderLayout不支持垂直方向。 该isVertical在容器的设置ComponentOrientation的不尊重。

    组件根据其优选尺寸和容器尺寸的限制布置。 NORTH和SOUTH组件可以水平拉伸; EAST和WEST组件可以垂直拉伸; CENTER组件可能会水平和垂直拉伸，以填补剩余的任何空间。

    这是一个使用BorderLayout布局管理器布局的小程序中的五个按钮的示例：

    该小程序的代码如下：

     import java.awt.*;
 import java.applet.Applet;

 public class buttonDir extends Applet {
   public void init() {
     setLayout(new BorderLayout());
     add(new Button("North"), BorderLayout.NORTH);
     add(new Button("South"), BorderLayout.SOUTH);
     add(new Button("East"), BorderLayout.EAST);
     add(new Button("West"), BorderLayout.WEST);
     add(new Button("Center"), BorderLayout.CENTER);
   }
 }
    从以下版本开始：
    1.0
    另请参见：
    Container.add(String, Component) ， ComponentOrientation ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String AFTER_LAST_LINE
      PAGE_END的同义词。
      static String AFTER_LINE_ENDS
      LINE_END的同义词。
      static String BEFORE_FIRST_LINE
      PAGE_START的同义词。
      static String BEFORE_LINE_BEGINS
      LINE_START的同义词。
      static String CENTER
      中心布局约束（容器中间）。
      static String EAST
      东面布局限制（容器右侧）。
      static String LINE_END
      组件在布局的行方向的末尾。
      static String LINE_START
      组件在布局的行方向的开始处。
      static String NORTH
      北面布局约束（容器顶部）。
      static String PAGE_END
      该组件来自布局内容的最后一行。
      static String PAGE_START
      该组件位于布局内容的第一行之前。
      static String SOUTH
      南布局约束（容器底部）。
      static String WEST
      西布局限制（容器左侧）。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BorderLayout​()
      构建新的边框布局，组件间没有间隙。
      BorderLayout​(int hgap, int vgap)
      构造具有组件之间指定间隙的边框布局。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addLayoutComponent​(Component comp, Object constraints)
      使用指定的约束对象将指定的组件添加到布局。
      void addLayoutComponent​(String name, Component comp)
      已过时。
      取代addLayoutComponent(Component, Object) 。
      Object getConstraints​(Component comp)
      获取指定组件的约束
      int getHgap​()
      返回组件之间的水平间隙。
      float getLayoutAlignmentX​(Container parent)
      返回沿x轴的对齐方式。
      float getLayoutAlignmentY​(Container parent)
      返回沿着y轴的对齐。
      Component getLayoutComponent​(Container target, Object constraints)
      基于目标 Container的组件方向返回与给定约束位置相对应的组件。
      Component getLayoutComponent​(Object constraints)
      获取使用给定约束添加的组件
      int getVgap​()
      返回组件之间的垂直间距。
      void invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      void layoutContainer​(Container target)
      使用此边框布局来填充容器参数。
      Dimension maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension minimumLayoutSize​(Container target)
      使用此布局管理器确定 target容器的最小大小。
      Dimension preferredLayoutSize​(Container target)
      根据容器中的组件确定使用此布局管理器的 target容器的首选大小。
      void removeLayoutComponent​(Component comp)
      从此边框布局中删除指定的组件。
      void setHgap​(int hgap)
      设置组件之间的水平间距。
      void setVgap​(int vgap)
      设置组件之间的垂直间距。
      String toString​()
      返回此边框布局状态的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NORTH

        public static final String NORTH
        北面布局约束（容器顶部）。
        另请参见：
        Constant Field Values

      • SOUTH

        public static final String SOUTH
        南布局约束（容器底部）。
        另请参见：
        Constant Field Values

      • EAST

        public static final String EAST
        东面布局限制（容器右侧）。
        另请参见：
        Constant Field Values

      • WEST

        public static final String WEST
        西布局限制（容器左侧）。
        另请参见：
        Constant Field Values

      • CENTER

        public static final String CENTER
        中心布局约束（容器中间）。
        另请参见：
        Constant Field Values

      • BEFORE_FIRST_LINE

        public static final String BEFORE_FIRST_LINE
        PAGE_START的同义词。 存在与以前的版本兼容。 PAGE_START是首选。
        从以下版本开始：
        1.2
        另请参见：
        PAGE_START ， Constant Field Values

      • AFTER_LAST_LINE

        public static final String AFTER_LAST_LINE
        PAGE_END的同义词。 存在与以前的版本兼容。 PAGE_END是首选。
        从以下版本开始：
        1.2
        另请参见：
        PAGE_END ， Constant Field Values

      • BEFORE_LINE_BEGINS

        public static final String BEFORE_LINE_BEGINS
        LINE_START的同义词。 存在与以前的版本兼容。 LINE_START是首选。
        从以下版本开始：
        1.2
        另请参见：
        LINE_START ， Constant Field Values

      • AFTER_LINE_ENDS

        public static final String AFTER_LINE_ENDS
        LINE_END的同义词。 存在与以前的版本兼容。 首选LINE_END。
        从以下版本开始：
        1.2
        另请参见：
        LINE_END ， Constant Field Values

      • PAGE_START

        public static final String PAGE_START
        该组件位于布局内容的第一行之前。 对于西方，从左到右和从上到下的方向，这相当于NORTH。
        从以下版本开始：
        1.4
        另请参见：
        Component.getComponentOrientation() ， Constant Field Values

      • PAGE_END

        public static final String PAGE_END
        该组件来自布局内容的最后一行。 对于西方，从左到右和从上到下的方向，这相当于SOUTH。
        从以下版本开始：
        1.4
        另请参见：
        Component.getComponentOrientation() ， Constant Field Values

      • LINE_START

        public static final String LINE_START
        组件在布局的行方向的开始处。 对于西方，从左到右和从上到下的方向，这相当于WEST。
        从以下版本开始：
        1.4
        另请参见：
        Component.getComponentOrientation() ， Constant Field Values

      • LINE_END

        public static final String LINE_END
        组件在布局的行方向的末尾。 对于西方，从左到右和从上到下的方向，这相当于EAST。
        从以下版本开始：
        1.4
        另请参见：
        Component.getComponentOrientation() ， Constant Field Values

    • 构造方法详细信息

      • BorderLayout

        public BorderLayout​()
        构建新的边框布局，组件间没有间隙。

      • BorderLayout

        public BorderLayout​(int hgap,
                    int vgap)
        构造具有组件之间指定间隙的边框布局。 水平间隙由hgap指定，垂直间隙由vgap指定。
        参数
        hgap - 水平间隙。
        vgap - 垂直间隙。

    • 方法详细信息

      • getHgap

        public int getHgap​()
        返回组件之间的水平间隙。
        结果
        组件之间的水平间隙
        从以下版本开始：
        1.1

      • setHgap

        public void setHgap​(int hgap)
        设置组件之间的水平间距。
        参数
        hgap - 组件之间的水平间隙
        从以下版本开始：
        1.1

      • getVgap

        public int getVgap​()
        返回组件之间的垂直间距。
        结果
        组件之间的垂直间隙
        从以下版本开始：
        1.1

      • setVgap

        public void setVgap​(int vgap)
        设置组件之间的垂直间距。
        参数
        vgap - 组件之间的垂直间隙
        从以下版本开始：
        1.1

      • addLayoutComponent

        public void addLayoutComponent​(Component comp,
                               Object constraints)
        使用指定的约束对象将指定的组件添加到布局。 对于边界布局，约束必须是以下常量之一： NORTH ， SOUTH ， EAST ， WEST ，或CENTER 。

        大多数应用程序不直接调用此方法。 当使用相同参数类型的Container.add方法将组件添加到容器时，将调用此方法。

        Specified by:
        addLayoutComponent在接口 LayoutManager2
        参数
        comp - 要添加的组件。
        constraints - 指定组件添加到布局的方式和位置的对象。
        异常
        IllegalArgumentException - 如果约束对象不是字符串，或者如果它不是五个指定的常量之一。
        从以下版本开始：
        1.1
        另请参见：
        Container.add(java.awt.Component, java.lang.Object)

      • addLayoutComponent

        @Deprecated
public void addLayoutComponent​(String name,
                               Component comp)
        已过时。 替换为addLayoutComponent(Component, Object) 。
        说明从接口LayoutManager复制
        如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与 name指定的字符串相关联。
        Specified by:
        addLayoutComponent在接口 LayoutManager
        参数
        name - 与组件关联的字符串
        comp - 要添加的组件

      • removeLayoutComponent

        public void removeLayoutComponent​(Component comp)
        从此边框布局中删除指定的组件。 当容器调用其remove或removeAll方法时，调用removeAll方法。 大多数应用程序不直接调用此方法。
        Specified by:
        removeLayoutComponent在接口 LayoutManager
        参数
        comp - 要删除的组件。
        另请参见：
        Container.remove(java.awt.Component) ， Container.removeAll()

      • getLayoutComponent

        public Component getLayoutComponent​(Object constraints)
        获取使用给定约束添加的组件
        参数
        constraints -所需约束的一个 CENTER ， NORTH ， SOUTH ， WEST ， EAST ， PAGE_START ， PAGE_END ， LINE_START ， LINE_END
        结果
        在给定位置的组件，如果位置为空， null
        异常
        IllegalArgumentException - 如果约束对象不是九个指定常量之一
        从以下版本开始：
        1.5
        另请参见：
        addLayoutComponent(java.awt.Component, java.lang.Object)

      • getLayoutComponent

        public Component getLayoutComponent​(Container target,
                                    Object constraints)
        基于目标Container的组件方向返回与给定约束位置相对应的组件。 部件与相对约束添加PAGE_START ， PAGE_END ， LINE_START和LINE_END优先于与所述显式约束添加的组分NORTH ， SOUTH ， WEST ，和EAST 。 Container的组件方向用于确定添加的组件的位置为LINE_START和LINE_END 。
        参数
        constraints -所需的绝对位置，一个 CENTER ， NORTH ， SOUTH ， EAST ， WEST
        target -所述 Container用于获得基于目标约束位置 Container的组分的取向。
        结果
        在给定位置的组件，如果位置为空， null
        异常
        IllegalArgumentException - 如果约束对象不是五个指定常量之一
        NullPointerException - 如果目标参数为空
        从以下版本开始：
        1.5
        另请参见：
        addLayoutComponent(java.awt.Component, java.lang.Object)

      • getConstraints

        public Object getConstraints​(Component comp)
        获取指定组件的约束
        参数
        comp - 要查询的组件
        结果
        指定组件的约束，如果组件为空，或者此布局中不存在则为null
        从以下版本开始：
        1.5
        另请参见：
        addLayoutComponent(java.awt.Component, java.lang.Object)

      • minimumLayoutSize

        public Dimension minimumLayoutSize​(Container target)
        使用此布局管理器确定target容器的最小大小。

        当容器调用其getMinimumSize方法时，调用getMinimumSize方法。 大多数应用程序不直接调用此方法。

        Specified by:
        minimumLayoutSize在接口 LayoutManager
        参数
        target - 进行布局的容器。
        结果
        布置指定容器的子组件所需的最小尺寸。
        另请参见：
        Container ， preferredLayoutSize(java.awt.Container) ， Container.getMinimumSize()

      • preferredLayoutSize

        public Dimension preferredLayoutSize​(Container target)
        根据容器中的组件确定使用此布局管理器的target容器的首选大小。

        大多数应用程序不直接调用此方法。 当容器调用其getPreferredSize方法时，调用getPreferredSize方法。

        Specified by:
        preferredLayoutSize在接口 LayoutManager
        参数
        target - 进行布局的容器。
        结果
        布置指定容器的子组件的首选尺寸。
        另请参见：
        Container ， minimumLayoutSize(java.awt.Container) ， Container.getPreferredSize()

      • maximumLayoutSize

        public Dimension maximumLayoutSize​(Container target)
        给定指定目标容器中的组件的返回布局的最大尺寸。
        Specified by:
        maximumLayoutSize在接口 LayoutManager2
        参数
        target - 需要布局的组件
        结果
        容器的最大尺寸
        另请参见：
        Container ， minimumLayoutSize(java.awt.Container) ， preferredLayoutSize(java.awt.Container)

      • getLayoutAlignmentX

        public float getLayoutAlignmentX​(Container parent)
        返回沿x轴的对齐方式。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        Specified by:
        getLayoutAlignmentX在接口 LayoutManager2
        参数
        parent - 目标容器
        结果
        x轴对齐偏好

      • getLayoutAlignmentY

        public float getLayoutAlignmentY​(Container parent)
        返回沿着y轴的对齐。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        Specified by:
        getLayoutAlignmentY在接口 LayoutManager2
        参数
        parent - 目标容器
        结果
        y轴对齐偏好

      • invalidateLayout

        public void invalidateLayout​(Container target)
        使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
        Specified by:
        invalidateLayout在接口 LayoutManager2
        参数
        target - 目标容器

      • layoutContainer

        public void layoutContainer​(Container target)
        使用此边框布局来填充容器参数。

        该方法实际重新形成指定容器中的组件，以满足此BorderLayout对象的约束。 NORTH和SOUTH组件（如果有的话）分别放置在容器的顶部和底部。 然后分别将WEST和EAST组件放置在左侧和右侧。 最后， CENTER对象放置在中间的任何剩余空间中。

        大多数应用程序不直接调用此方法。 当容器调用其doLayout方法时，调用doLayout方法。

        Specified by:
        layoutContainer在接口 LayoutManager
        参数
        target - 要进行布局的容器。
        另请参见：
        Container ， Container.doLayout()

      • toString

        public String toString​()
        返回此边框布局状态的字符串表示形式。
        重写：
        toString在 Object
        结果
        a string representation of this border layout.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferCapabilities (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class BufferCapabilities

  • java.lang.Object
    • java.awt.BufferCapabilities
  • All Implemented Interfaces:
    Cloneable

    public class BufferCapabilities
extends Object
implements Cloneable
    缓冲区的功能和属性。
    从以下版本开始：
    1.4
    另请参见：
    BufferStrategy.getCapabilities() ， GraphicsConfiguration.getBufferCapabilities()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  BufferCapabilities.FlipContents
      页面翻转后可能的反向缓冲区内容的类型安全枚举

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferCapabilities​(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
      创建一个用于指定缓冲功能的新对象

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      Object clone​()
      创建并返回此对象的副本。
      ImageCapabilities getBackBufferCapabilities​()
      BufferCapabilities.FlipContents getFlipContents​()
      ImageCapabilities getFrontBufferCapabilities​()
      boolean | isFullScreenRequired​()
      boolean | isMultiBufferAvailable​()
      boolean | isPageFlipping​()

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BufferCapabilities

        public BufferCapabilities​(ImageCapabilities frontCaps,
                          ImageCapabilities backCaps,
                          BufferCapabilities.FlipContents flipContents)
        创建一个用于指定缓冲功能的新对象
        参数
        frontCaps - 前端缓冲区的功能; 不能是null
        backCaps - 后台和中间缓冲区的功能; 不能是null
        flipContents - 页面翻转后的后台缓冲区的内容，如果不使用页面翻转， null （意味着blitting）
        异常
        IllegalArgumentException - 如果frontCaps或backCaps是 null

    • 方法详细信息

      • getFrontBufferCapabilities

        public ImageCapabilities getFrontBufferCapabilities​()
        结果
        前面（显示）缓冲区的图像功能

      • getBackBufferCapabilities

        public ImageCapabilities getBackBufferCapabilities​()
        结果
        所有后缓冲区的图像功能（中间缓冲区被认为是后缓冲区）

      • isPageFlipping

        public boolean isPageFlipping​()
        结果
        缓冲策略是否使用页面翻转; 使用页面翻转的一组缓冲区可以通过切换视频指针（或通过内部复制内存）在前缓冲区和一个或多个后缓冲区之间内部交换内容。 缓冲区的非翻转组件使用blitting将内容从一个缓冲区复制到另一个缓冲区; 在这种情况下， getFlipContents返回null

      • getFlipContents

        public BufferCapabilities.FlipContents getFlipContents​()
        结果
        翻页后的后台缓冲区的结果内容。 这个值是null当isPageFlipping返回false ，这意味着false 。 它可以是一个FlipContents.UNDEFINED （假定默认值）， FlipContents.BACKGROUND ， FlipContents.PRIOR ，或FlipContents.COPIED 。
        另请参见：
        isPageFlipping() ， BufferCapabilities.FlipContents.UNDEFINED ， BufferCapabilities.FlipContents.BACKGROUND ， BufferCapabilities.FlipContents.PRIOR ， BufferCapabilities.FlipContents.COPIED

      • isFullScreenRequired

        public boolean isFullScreenRequired​()
        结果
        页面翻转是否仅在全屏模式下可用。 如果是true ，页面翻转需要全屏独占模式。
        另请参见：
        isPageFlipping() ， GraphicsDevice.setFullScreenWindow(java.awt.Window)

      • isMultiBufferAvailable

        public boolean isMultiBufferAvailable​()
        结果
        是否可以使用两个以上的缓冲器（一个或多个中间缓冲器以及前后缓冲器）执行翻页翻页。
        另请参见：
        isPageFlipping()

      • clone

        public Object clone​()
        说明从类别复制： Object
        创建并返回此对象的副本。 “复制”的精确含义可能取决于对象的类。 一般的意图是，对于任何对象x ，表达式：
         x.clone() != x
        将是真实的，而且表达：
         x.clone().getClass() == x.getClass()
        将是true ，但这些都不是绝对的要求。 通常情况是：
         x.clone().equals(x)
        将是true ，这不是一个绝对的要求。

        按照惯例，返回的对象应该通过调用super.clone获得。 如果一个类和它的所有超类（除了Object ）遵守这个惯例，那将是x.clone().getClass() == x.getClass()的情况。

        按照惯例，此方法返回的对象应该与此对象（正被克隆）无关。 为了实现这一独立性，可能需要修改super.clone返回的对象的一个或多个字段。 通常，这意味着复制构成被克隆的对象的内部“深层结构”的任何可变对象，并通过引用该副本替换对这些对象的引用。 如果一个类仅包含原始字段或对不可变对象的引用，则通常情况下，需要修改super.clone返回的对象中的字段。

        类Object的方法clone执行特定的克隆操作。 首先，如果此对象的类不实现接口Cloneable ，则抛出一个CloneNotSupportedException 。 请注意，所有阵列被认为是实现该接口Cloneable并且所述的返回类型clone数组类型的方法T[]是T[]其中T是任何引用或原始类型。 否则，该方法将创建该对象的类的新实例，并将其所有字段初始化为该对象的相应字段的内容，就像通过赋值一样。 这些字段的内容本身不被克隆。 因此，该方法执行该对象的“浅拷贝”，而不是“深度拷贝”操作。

        类Object本身并不实现接口Cloneable ，因此在类为Object的对象上调用clone方法将导致在运行时抛出异常。

        重写：
        clone在 Object
        结果
        这个BufferCapabilities对象的副本。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferCapabilities.FlipContents (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class BufferCapabilities.FlipContents

  • java.lang.Object
    • java.awt.BufferCapabilities.FlipContents
  • Enclosing class:
    BufferCapabilities

    public static final class BufferCapabilities.FlipContents
extends Object
    页面翻转后可能的反向缓冲区内容的类型安全枚举
    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static BufferCapabilities.FlipContents BACKGROUND
      当翻转内容为 BACKGROUND ，翻转后背景缓冲区的内容将被清除。
      static BufferCapabilities.FlipContents COPIED
      当翻转内容为 COPIED ，翻转时将后台缓冲区的内容复制到前端缓冲区。
      static BufferCapabilities.FlipContents PRIOR
      当翻转内容为 PRIOR ，后台缓冲区的内容是前缓冲区的前一个内容（真正的页面翻页）。
      static BufferCapabilities.FlipContents UNDEFINED
      当翻转内容为 UNDEFINED ，后缓冲区的内容在翻转后未定义。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNDEFINED

        public static final BufferCapabilities.FlipContents UNDEFINED
        翻转内容为 UNDEFINED ，翻转后的后台缓冲区的内容未定义。
        另请参见：
        BufferCapabilities.isPageFlipping() ， BufferCapabilities.getFlipContents() ， BACKGROUND ， PRIOR ， COPIED

      • BACKGROUND

        public static final BufferCapabilities.FlipContents BACKGROUND
        当翻转内容为 BACKGROUND ，翻转后的背景缓冲区的内容将被清除。
        另请参见：
        BufferCapabilities.isPageFlipping() ， BufferCapabilities.getFlipContents() ， UNDEFINED ， PRIOR ， COPIED

      • PRIOR

        public static final BufferCapabilities.FlipContents PRIOR
        当翻转内容为 PRIOR ，后台缓冲区的内容是前缓冲区的前一个内容（真正的页面翻页）。
        另请参见：
        BufferCapabilities.isPageFlipping() ， BufferCapabilities.getFlipContents() ， UNDEFINED ， BACKGROUND ， COPIED

      • COPIED

        public static final BufferCapabilities.FlipContents COPIED
        当翻转内容为 COPIED ，翻转时将后台缓冲区的内容复制到前端缓冲区。
        另请参见：
        BufferCapabilities.isPageFlipping() ， BufferCapabilities.getFlipContents() ， UNDEFINED ， BACKGROUND ， PRIOR

    • 方法详细信息

      • hashCode

        public int hashCode​()
        说明从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的一般合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中没有使用的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Button (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Button

  • java.lang.Object
    • java.awt.Component
      • java.awt.Button
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class Button
extends Component
implements Accessible
    这个类创建一个标记的按钮。 当按下按钮时，应用程序可能会导致一些动作发生。 此图像描述了Solaris操作系统下的“ Quit ”按钮的三个视图：

    第一个视图显示按钮正常显示。 第二个视图显示按钮具有输入焦点。 它的轮廓变暗，让用户知道它是一个活动对象。 第三个视图显示当用户单击鼠标在按钮上方时的按钮，从而请求执行操作。

    使用鼠标点击按钮的手势与ActionEvent一个实例相关联，当鼠标按下并释放按钮时，该实例被发送出去。 如果应用程序有兴趣知道按钮何时被按下但未被释放，作为单独的手势，它可以专门化processMouseEvent ，或者可以通过调用addMouseListener将自己注册为鼠标事件的监听addMouseListener 。 这两种方法都由Component定义，所有组件的抽象超类。

    当按下和释放按钮，AWT发送的一个实例ActionEvent到按钮，通过调用processEvent上的按钮。 按钮的processEvent方法接收按钮的所有事件; 它通过调用自己的processActionEvent方法传递一个动作事件。 后一种方法将动作事件传递给任何对该按钮生成的动作事件感兴趣的动作侦听器。

    如果应用程序想按照按下并释放的按钮执行某些操作，则应通过调用按钮的addActionListener方法来实现ActionListener并注册新的监听器以从该按钮接收事件。 应用程序可以使用按钮的动作命令作为消息传递协议。

    从以下版本开始：
    1.0
    另请参见：
    ActionEvent ， ActionListener ， Component.processMouseEvent(java.awt.event.MouseEvent) ， Component.addMouseListener(java.awt.event.MouseListener) ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Button.AccessibleAWTButton
      这个类实现 Button类的辅助功能支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Button​()
      构造一个带有标签的空字符串的按钮。
      Button​(String label)
      构造具有指定标签的按钮。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addActionListener​(ActionListener l)
      添加指定的动作侦听器以从此按钮接收动作事件。
      void addNotify​()
      创建按钮的对等体。
      AccessibleContext getAccessibleContext​()
      获取 AccessibleContext与此 Button相关联。
      String getActionCommand​()
      返回此按钮触发的操作事件的命令名称。
      ActionListener[] getActionListeners​()
      返回在此按钮上注册的所有动作侦听器的数组。
      String getLabel​()
      获取此按钮的标签。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回此 Button当前注册为 FooListener的所有对象的数组。
      protected String paramString​()
      返回一个表示 Button状态的字符串。
      protected void processActionEvent​(ActionEvent e)
      通过将此按钮分派到任何已注册的 ActionListener对象来处理此按钮上发生的操作事件。
      protected void processEvent​(AWTEvent e)
      处理此按钮上的事件。
      void removeActionListener​(ActionListener l)
      删除指定的动作侦听器，使其不再从此按钮接收到动作事件。
      void setActionCommand​(String command)
      设置此按钮触发的操作事件的命令名称。
      void setLabel​(String label)
      将按钮的标签设置为指定的字符串。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Button

        public Button​()
       throws HeadlessException
        构造一个带有标签的空字符串的按钮。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Button

        public Button​(String label)
       throws HeadlessException
        构造具有指定标签的按钮。
        参数
        label - 按钮的字符串标签，或无标签的 null
        异常
        如果GraphicsEnvironment.isHeadless（）返回true， HeadlessException
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建按钮的对等体。 按钮的对等体允许应用程序更改按钮的外观，而不会更改其功能。
        重写：
        addNotify在 Component
        另请参见：
        Component.getToolkit()

      • getLabel

        public String getLabel​()
        获取此按钮的标签。
        结果
        按钮的标签，或 null如果按钮没有标签。
        另请参见：
        setLabel(java.lang.String)

      • setLabel

        public void setLabel​(String label)
        将按钮的标签设置为指定的字符串。
        参数
        label - 新标签，或 null如果按钮没有标签。
        另请参见：
        getLabel()

      • setActionCommand

        public void setActionCommand​(String command)
        设置此按钮触发的操作事件的命令名称。 默认情况下，此操作命令设置为与按钮的标签相匹配。
        参数
        command - 用于设置按钮的动作命令的字符串。 如果字符串为null则将该命令设置为与按钮的标签相匹配。
        从以下版本开始：
        1.1
        另请参见：
        ActionEvent

      • getActionCommand

        public String getActionCommand​()
        返回此按钮触发的操作事件的命令名称。 如果命令名为null （默认），则此方法返回按钮的标签。
        结果
        该按钮的动作命令名称（或标签）

      • addActionListener

        public void addActionListener​(ActionListener l)
        添加指定的动作侦听器以从此按钮接收动作事件。 当用户按下或释放鼠标在此按钮上时，会发生动作事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器
        从以下版本开始：
        1.1
        另请参见：
        removeActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionListener

      • removeActionListener

        public void removeActionListener​(ActionListener l)
        删除指定的动作侦听器，使其不再从此按钮接收到动作事件。 当用户按下或释放鼠标在此按钮上时，会发生动作事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器
        从以下版本开始：
        1.1
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionListener

      • getActionListeners

        public ActionListener[] getActionListeners​()
        返回在此按钮上注册的所有动作侦听器的数组。
        结果
        所有这个按钮的 ActionListener s或一个空数组，如果没有动作侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， removeActionListener(java.awt.event.ActionListener) ， ActionListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册为FooListener的所有对象的数组Button 。 FooListener使用addFooListener注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询Button b其动作侦听器：

          ActionListener[] als = (ActionListener[])(b.getListeners(ActionListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners类 Component
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此按钮上注册为 FooListener的所有对象的数组，如果没有添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getActionListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此按钮上的事件。 如果事件是一个ActionEvent的实例，则此方法将调用processActionEvent方法。 否则，它将在超类上调用processEvent 。

        请注意，如果事件参数为null该行为未指定，并可能导致异常。

        重写：
        processEvent在 Component
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        ActionEvent ， processActionEvent(java.awt.event.ActionEvent)

      • processActionEvent

        protected void processActionEvent​(ActionEvent e)
        通过将此按钮发送到任何已注册的ActionListener对象来处理此按钮上发生的操作事件。

        除非为此按钮启用了操作事件，否则不会调用此方法。 当发生以下情况之一时，启用操作事件：

        • 一个ActionListener对象通过addActionListener注册。
        • 通过enableEvents启用操作事件。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 动作事件
        从以下版本开始：
        1.1
        另请参见：
        ActionListener ， addActionListener(java.awt.event.ActionListener) ， Component.enableEvents(long)

      • paramString

        protected String paramString​()
        返回表示此Button的状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Component
        结果
        该按钮的参数字符串

      • getAccessibleContext

        @BeanProperty(expert=true,
              description="The AccessibleContext associated with this Button.")
public AccessibleContext getAccessibleContext​()
        获取AccessibleContext与此Button相关联。 对于按钮， AccessibleContext需要一个的形式AccessibleAWTButton 。 如有必要，将创建一个新的AccessibleAWTButton实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个 AccessibleAWTButton ，作为这个 AccessibleContext的 Button
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Button.AccessibleAWTButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Button.AccessibleAWTButton

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Button.AccessibleAWTButton
  • All Implemented Interfaces:
    Serializable ， AccessibleAction ， AccessibleComponent ， AccessibleValue
    Enclosing class:
    Button

    protected class Button.AccessibleAWTButton
extends Component.AccessibleAWTComponent
implements AccessibleAction, AccessibleValue
    该类为Button类实现可访问性支持。 它提供了适用于按钮用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTButton​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean doAccessibleAction​(int i)
      对对象执行指定的Action
      AccessibleAction getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      int getAccessibleActionCount​()
      返回此对象中可用的操作数。
      String getAccessibleActionDescription​(int i)
      返回对象的指定操作的描述。
      String getAccessibleName​()
      获取此对象的可访问名称。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleValue getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      Number getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      boolean setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTButton

        protected AccessibleAWTButton​()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName​()
        获取此对象的可访问名称。
        重写：
        getAccessibleName在 Component.AccessibleAWTComponent
        结果
        对象的本地化名称 - 如果此对象没有名称，则可以为null
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleAction

        public AccessibleAction getAccessibleAction​()
        获取与此对象关联的AccessibleAction。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleAction接口。
        重写：
        getAccessibleAction在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleAction

      • getAccessibleValue

        public AccessibleValue getAccessibleValue​()
        获取与此对象关联的AccessibleValue。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleValue接口。
        重写：
        getAccessibleValue在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleValue

      • getAccessibleActionCount

        public int getAccessibleActionCount​()
        返回此对象中可用的操作数。 按钮的默认行为是一个动作 - 切换按钮。
        Specified by:
        getAccessibleActionCount在接口 AccessibleAction
        结果
        1，此对象中的Actions数

      • getAccessibleActionDescription

        public String getAccessibleActionDescription​(int i)
        返回对象的指定操作的描述。
        Specified by:
        getAccessibleActionDescription在接口 AccessibleAction
        参数
        i - 零操作的索引
        结果
        一个 String描述的动作
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction​(int i)
        对对象执行指定的Action
        Specified by:
        doAccessibleAction在接口 AccessibleAction
        参数
        i - 基于零的操作索引
        结果
        如果行动执行，则为真; 否则假。
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue​()
        将该对象的值作为数字获取。
        Specified by:
        getCurrentAccessibleValue在接口 AccessibleValue
        结果
        如果未选择，则为0的整数，如果选中则为整数为1。
        另请参见：
        AbstractButton.isSelected()

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue​(Number n)
        将此对象的值设置为数字。
        Specified by:
        setCurrentAccessibleValue在接口 AccessibleValue
        参数
        n - 用于值的数字
        结果
        如果设置了该值，则为真。
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue​()
        将此对象的最小值作为数字获取。
        Specified by:
        getMinimumAccessibleValue在接口 AccessibleValue
        结果
        0的整数。
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue​()
        获取该对象的最大值作为数字。
        Specified by:
        getMaximumAccessibleValue在接口 AccessibleValue
        结果
        0的整数。
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Canvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Canvas

  • java.lang.Object
    • java.awt.Component
      • java.awt.Canvas
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class Canvas
extends Component
implements Accessible
    Canvas组件表示应用程序可以在其上绘制的屏幕的空白矩形区域，或者应用程序可以从该屏幕捕获来自用户的输入事件。

    应用程序必须对Canvas类进行子类化，以获得有用的功能，例如创建自定义组件。 必须覆盖paint方法才能在画布上执行自定义图形。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Canvas.AccessibleAWTCanvas
      该类实现 Canvas类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Canvas​()
      构造一个新的画布。
      Canvas​(GraphicsConfiguration config)
      给一个GraphicsConfiguration对象构造一个新的Canvas。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addNotify​()
      创建画布的对等体。
      void createBufferStrategy​(int numBuffers)
      为此组件创建一个新的多缓冲策略。
      void createBufferStrategy​(int numBuffers, BufferCapabilities caps)
      在此组件上创建一个新策略，以实现所需的缓冲功能。
      AccessibleContext getAccessibleContext​()
      获取与此Canvas关联的AccessibleContext。
      BufferStrategy getBufferStrategy​()
      返回此组件使用的 BufferStrategy 。
      void paint​(Graphics g)
      画这幅画。
      void update​(Graphics g)
      更新此画布。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, paramString, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Canvas

        public Canvas​()
        构造一个新的画布。

      • Canvas

        public Canvas​(GraphicsConfiguration config)
        给一个GraphicsConfiguration对象构造一个新的Canvas。 如果传递null，则将使用默认的GraphicsConfiguration。
        参数
        config - 对GraphicsConfiguration对象的引用或null
        另请参见：
        GraphicsConfiguration ， Component.getGraphicsConfiguration()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建画布的对等体。 此对等体允许您更改画布的用户界面，而无需更改其功能。
        重写：
        addNotify在 Component
        另请参见：
        Component.getToolkit()

      • paint

        public void paint​(Graphics g)
        画这幅画。

        Canvas子类的大多数应用程序Canvas应该覆盖此方法，以便执行一些有用的操作（通常是自定义画布）。 默认操作只是清除画布。 覆盖此方法的应用程序不需要调用super.paint（g）。

        重写：
        paint在 Component
        参数
        g - 指定的图形上下文
        另请参见：
        update(Graphics) ， Component.paint(Graphics)

      • update

        public void update​(Graphics g)
        更新此画布。

        此方法是响应于对repaint的调用而repaint 。 画布首先通过填充背景颜色来清除，然后通过调用此画布的paint方法完全重绘。 注意：覆盖此方法的应用程序应该调用super.update（g）或将上述功能合并到自己的代码中。

        重写：
        update在 Component
        参数
        g - 指定的图形上下文
        另请参见：
        paint(Graphics) ， Component.update(Graphics)

      • createBufferStrategy

        public void createBufferStrategy​(int numBuffers)
        为此组件创建一个新的多缓冲策略。 多缓冲对于渲染性能很有用。 此方法尝试使用提供的缓冲区数量创建可用的最佳策略。 它将始终使用该数量的缓冲区创建一个BufferStrategy 。 首先尝试翻页策略，然后尝试使用加速缓冲区的策略策略。 最后，使用非加速的制动策略。

        每次调用此方法时，将丢弃此组件的现有缓冲区策略。

        参数
        numBuffers - 要创建的缓冲区数，包括前端缓冲区
        异常
        IllegalArgumentException - 如果numBuffers小于1。
        IllegalStateException - 如果组件不可显示
        从以下版本开始：
        1.4
        另请参见：
        Component.isDisplayable() ， getBufferStrategy()

      • createBufferStrategy

        public void createBufferStrategy​(int numBuffers,
                                 BufferCapabilities caps)
                          throws AWTException
        在此组件上创建一个新策略，以实现所需的缓冲功能。 这是有用的，例如，如果只需要加速内存或页面翻转（由缓冲区功能指定）。

        每次调用此方法时，将丢弃此组件的现有缓冲区策略。

        参数
        numBuffers - 要创建的缓冲区数
        caps - 创建缓冲策略所需的功能; 不能是null
        异常
        AWTException - 如果提供的功能不能被支持或满足; 这可能发生，例如，如果当前没有足够的加速内存可用，或者如果指定了页面翻转，但是不可能。
        IllegalArgumentException - 如果numBuffers小于1，或者如果cap是 null
        从以下版本开始：
        1.4
        另请参见：
        getBufferStrategy()

      • getBufferStrategy

        public BufferStrategy getBufferStrategy​()
        返回此组件使用的BufferStrategy 。 如果尚未创建或已经处理了BufferStrategy则此方法将返回null。
        结果
        该组件使用的缓冲策略
        从以下版本开始：
        1.4
        另请参见：
        createBufferStrategy(int)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此Canvas关联的AccessibleContext。 对于画布，AccessibleContext采用AccessibleAWTCanvas的形式。 如有必要，将创建一个新的AccessibleAWTCanvas实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在类 Component
        结果
        一个AccessibleAWTCanvas作为此Canvas的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Canvas.AccessibleAWTCanvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Canvas.AccessibleAWTCanvas

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Canvas.AccessibleAWTCanvas
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    Enclosing class:
    Canvas

    protected class Canvas.AccessibleAWTCanvas
extends Component.AccessibleAWTComponent
    这个类实现Canvas类的可访问性支持。 它提供了适用于画布用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTCanvas​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTCanvas

        protected AccessibleAWTCanvas​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CardLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class CardLayout

  • java.lang.Object
    • java.awt.CardLayout
  • All Implemented Interfaces:
    LayoutManager ， LayoutManager2 ， Serializable

    public class CardLayout
extends Object
implements LayoutManager2, Serializable
    一个CardLayout对象是容器的布局管理器。 它将容器中的每个组件视为一张卡。 一次只能看到一张卡片，容器就是一堆卡片。 添加到CardLayout对象的第一个组件是首次显示容器时的可见组件。

    卡片的顺序由容器自己的组件对象的内部顺序决定。 CardLayout定义了一组允许应用程序顺序翻转这些卡片或显示指定卡片的方法。 可以使用addLayoutComponent(java.awt.Component, java.lang.Object)方法将字符串标识符与给定的卡相关联，以便快速随机访问。

    从以下版本开始：
    1.0
    另请参见：
    Container ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CardLayout​()
      创建一个新的卡片布局，其大小为零。
      CardLayout​(int hgap, int vgap)
      创建具有指定的水平和垂直间隙的新卡布局。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addLayoutComponent​(Component comp, Object constraints)
      将指定的组件添加到此卡布局的内部名称表中。
      void addLayoutComponent​(String name, Component comp)
      已过时。
      替换为addLayoutComponent(Component, Object) 。
      void first​(Container parent)
      翻转到容器的第一张卡片。
      int getHgap​()
      获得组件之间的水平间隙。
      float getLayoutAlignmentX​(Container parent)
      返回沿x轴的对齐方式。
      float getLayoutAlignmentY​(Container parent)
      返回沿着y轴的对齐。
      int getVgap​()
      获取组件之间的垂直间距。
      void invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      void last​(Container parent)
      翻转到容器的最后一张卡片。
      void layoutContainer​(Container parent)
      使用此卡布局来放出指定的容器。
      Dimension maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension minimumLayoutSize​(Container parent)
      计算指定面板的最小尺寸。
      void next​(Container parent)
      翻转到指定容器的下一张卡片。
      Dimension preferredLayoutSize​(Container parent)
      使用此卡布局确定容器参数的首选大小。
      void previous​(Container parent)
      翻转到指定容器的前一张卡片。
      void removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void setHgap​(int hgap)
      设置组件之间的水平间距。
      void setVgap​(int vgap)
      设置组件之间的垂直间距。
      void show​(Container parent, String name)
      使用指定的 name ，使用 addLayoutComponent翻转到添加到此布局的组件。
      String toString​()
      返回此卡布局状态的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CardLayout

        public CardLayout​()
        创建一个新的卡片布局，其大小为零。

      • CardLayout

        public CardLayout​(int hgap,
                  int vgap)
        创建具有指定的水平和垂直间隙的新卡布局。 水平间隙放置在左右边缘。 垂直间隙位于顶部和底部边缘。
        参数
        hgap - 水平间隙。
        vgap - 垂直间隙。

    • 方法详细信息

      • getHgap

        public int getHgap​()
        获得组件之间的水平间隙。
        结果
        组件之间的水平间隙。
        从以下版本开始：
        1.1
        另请参见：
        setHgap(int) ， getVgap()

      • setHgap

        public void setHgap​(int hgap)
        设置组件之间的水平间距。
        参数
        hgap - 组件之间的水平间隙。
        从以下版本开始：
        1.1
        另请参见：
        getHgap() ， setVgap(int)

      • getVgap

        public int getVgap​()
        获取组件之间的垂直间距。
        结果
        组件之间的垂直间隙。
        另请参见：
        setVgap(int) ， getHgap()

      • setVgap

        public void setVgap​(int vgap)
        设置组件之间的垂直间距。
        参数
        vgap - 组件之间的垂直间隙。
        从以下版本开始：
        1.1
        另请参见：
        getVgap() ， setHgap(int)

      • addLayoutComponent

        public void addLayoutComponent​(Component comp,
                               Object constraints)
        将指定的组件添加到此卡布局的内部名称表中。 由constraints指定的对象必须是字符串。 卡布局将该字符串存储为可用于随机访问特定卡的键值对。 通过调用show方法，应用程序可以显示具有指定名称的组件。
        Specified by:
        addLayoutComponent在接口 LayoutManager2
        参数
        comp - 要添加的组件。
        constraints - 标识布局中特定卡片的标签。
        异常
        IllegalArgumentException - 如果约束不是字符串。
        另请参见：
        show(java.awt.Container, java.lang.String)

      • addLayoutComponent

        @Deprecated
public void addLayoutComponent​(String name,
                               Component comp)
        已过时。 替换为addLayoutComponent(Component, Object) 。
        说明从界面LayoutManager复制
        如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与由 name指定的字符串相关联。
        Specified by:
        addLayoutComponent在接口 LayoutManager
        参数
        name - 与组件关联的字符串
        comp - 要添加的组件

      • removeLayoutComponent

        public void removeLayoutComponent​(Component comp)
        从布局中删除指定的组件。 如果卡在顶部可见，则显示下面的下一张卡。
        Specified by:
        removeLayoutComponent在接口 LayoutManager
        参数
        comp - 要删除的组件。
        另请参见：
        Container.remove(java.awt.Component) ， Container.removeAll()

      • preferredLayoutSize

        public Dimension preferredLayoutSize​(Container parent)
        使用此卡布局确定容器参数的首选大小。
        Specified by:
        preferredLayoutSize在接口 LayoutManager
        参数
        parent - 要进行布局的父容器
        结果
        布置指定容器的子组件的首选尺寸
        另请参见：
        Container.getPreferredSize() ， minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize​(Container parent)
        计算指定面板的最小尺寸。
        Specified by:
        minimumLayoutSize在接口 LayoutManager
        参数
        parent - 要进行布局的父容器
        结果
        布置指定容器的子组件所需的最小尺寸
        另请参见：
        Container.doLayout() ， preferredLayoutSize(java.awt.Container)

      • maximumLayoutSize

        public Dimension maximumLayoutSize​(Container target)
        给定指定目标容器中的组件的返回布局的最大尺寸。
        Specified by:
        maximumLayoutSize在接口 LayoutManager2
        参数
        target - 需要布局的组件
        结果
        容器的最大尺寸
        另请参见：
        Container ， minimumLayoutSize(java.awt.Container) ， preferredLayoutSize(java.awt.Container)

      • getLayoutAlignmentX

        public float getLayoutAlignmentX​(Container parent)
        返回沿x轴的对齐方式。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        Specified by:
        getLayoutAlignmentX在接口 LayoutManager2
        参数
        parent - 目标容器
        结果
        x轴对齐偏好

      • getLayoutAlignmentY

        public float getLayoutAlignmentY​(Container parent)
        返回沿着y轴的对齐。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        Specified by:
        getLayoutAlignmentY在接口 LayoutManager2
        参数
        parent - 目标容器
        结果
        y轴对齐偏好

      • invalidateLayout

        public void invalidateLayout​(Container target)
        使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
        Specified by:
        invalidateLayout在接口 LayoutManager2
        参数
        target - 目标容器

      • layoutContainer

        public void layoutContainer​(Container parent)
        使用此卡布局来放出指定的容器。

        parent容器中的每个组件重新整形为容器的大小，减去周围插入空间，水平间隙和垂直间隙。

        Specified by:
        layoutContainer在接口 LayoutManager
        参数
        parent - 要进行布局的父容器
        另请参见：
        Container.doLayout()

      • first

        public void first​(Container parent)
        翻转到容器的第一张卡片。
        参数
        parent - 要进行布局的父容器
        另请参见：
        last(java.awt.Container)

      • next

        public void next​(Container parent)
        翻转到指定容器的下一张卡片。 如果当前可见的卡是最后一张卡，则此方法将在布局中翻转到第一张卡。
        参数
        parent - 要进行布局的父容器
        另请参见：
        previous(java.awt.Container)

      • previous

        public void previous​(Container parent)
        翻转到指定容器的前一张卡片。 如果当前可见的卡是第一个，则该方法将翻转到布局中的最后一张卡。
        参数
        parent - 要进行布局的父容器
        另请参见：
        next(java.awt.Container)

      • last

        public void last​(Container parent)
        翻转到容器的最后一张卡片。
        参数
        parent - 要进行布局的父容器
        另请参见：
        first(java.awt.Container)

      • show

        public void show​(Container parent,
                 String name)
        使用指定的name ，使用addLayoutComponent翻转到添加到此布局的组件。 如果不存在这样的组件，那么没有任何反应。
        参数
        parent - 要进行布局的父容器
        name - 组件名称
        另请参见：
        addLayoutComponent(java.awt.Component, java.lang.Object)

      • toString

        public String toString​()
        返回此卡布局状态的字符串表示形式。
        重写：
        toString在 Object
        结果
        该卡片布局的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Checkbox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Checkbox

  • java.lang.Object
    • java.awt.Component
      • java.awt.Checkbox
  • All Implemented Interfaces:
    ImageObserver ， ItemSelectable ， MenuContainer ， Serializable ， Accessible

    public class Checkbox
extends Component
implements ItemSelectable, Accessible
    复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。 单击复选框将其状态从“开”更改为“关”，或从“关”更改为“开”。

    以下代码示例在网格布局中创建一组复选框：

     setLayout(new GridLayout(3, 1));
 add(new Checkbox("one", null, true));
 add(new Checkbox("two"));
 add(new Checkbox("three"));

    此图像描述了由此代码示例创建的复选框和网格布局：

    标有one的按钮处于“开”状态，其他两个处于“关”状态。 在这个使用GridLayout类的示例中，三个复选框的状态是独立设置的。

    或者，使用CheckboxGroup类，可以在单个对象的控制下将多个复选框分组在一起。 在复选框组中，在任何给定时间，最多只能有一个按钮处于“开”状态。 单击一个复选框可将其打开，强制打开“关闭”状态的同一组中的任何其他复选框。

    从以下版本开始：
    1.0
    另请参见：
    GridLayout ， CheckboxGroup ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Checkbox.AccessibleAWTCheckbox
      该类为 Checkbox类实现可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Checkbox​()
      为其标签创建一个带有空字符串的复选框。
      Checkbox​(String label)
      创建一个带有指定标签的复选框。
      Checkbox​(String label, boolean state)
      创建一个带有指定标签的复选框，并设置指定的状态。
      Checkbox​(String label, boolean state, CheckboxGroup group)
      构造具有指定标签的复选框，设置为指定的状态，并在指定的复选框组中。
      Checkbox​(String label, CheckboxGroup group, boolean state)
      在指定的复选框组中创建带有指定标签的复选框，并设置为指定的状态。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addItemListener​(ItemListener l)
      添加指定的项目侦听器以从此复选框接收项目事件。
      void addNotify​()
      创建复选框的对等体。
      AccessibleContext getAccessibleContext​()
      获取与此复选框相关联的AccessibleContext。
      CheckboxGroup getCheckboxGroup​()
      确定此复选框的组。
      ItemListener[] getItemListeners​()
      返回在此复选框上注册的所有项目侦听器的数组。
      String getLabel​()
      获取此复选框的标签。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回此 Checkbox当前注册为 FooListener的所有对象的数组。
      Object[] getSelectedObjects​()
      返回一个包含复选框标签的数组（长度1），如果未选中该复选框，则返回null。
      boolean getState​()
      确定此复选框是否处于“开”或“关”状态。
      protected String paramString​()
      返回表示 Checkbox状态的字符串。
      protected void processEvent​(AWTEvent e)
      处理此复选框上的事件。
      protected void processItemEvent​(ItemEvent e)
      通过将此复选框发送到任何已注册的 ItemListener对象来处理在此复选框上发生的项目事件。
      void removeItemListener​(ItemListener l)
      删除指定的项目监听器，以使项目监听器不再从此复选框接收项目事件。
      void setCheckboxGroup​(CheckboxGroup g)
      将此复选框的组设置为指定的复选框组。
      void setLabel​(String label)
      将此复选框的标签设置为字符串参数。
      void setState​(boolean state)
      将此复选框的状态设置为指定的状态。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Checkbox

        public Checkbox​()
         throws HeadlessException
        为其标签创建一个带有空字符串的复选框。 此复选框的状态设置为“关闭”，它不是任何复选框组的一部分。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Checkbox

        public Checkbox​(String label)
         throws HeadlessException
        创建一个带有指定标签的复选框。 此复选框的状态设置为“关闭”，它不是任何复选框组的一部分。
        参数
        label - 此复选框的字符串标签，或无标签的 null 。
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回 true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Checkbox

        public Checkbox​(String label,
                boolean state)
         throws HeadlessException
        创建一个带有指定标签的复选框，并设置指定的状态。 该复选框不是任何复选框组的一部分。
        参数
        label - 此复选框的字符串标签，或无标签的 null
        state - 此复选框的初始状态
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回 true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Checkbox

        public Checkbox​(String label,
                boolean state,
                CheckboxGroup group)
         throws HeadlessException
        构造具有指定标签的复选框，设置为指定的状态，并在指定的复选框组中。
        参数
        label - 此复选框的字符串标签，或无标签的 null 。
        state - 此复选框的初始状态。
        group - 此复选框的复选框组，或无组的 null 。
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回 true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Checkbox

        public Checkbox​(String label,
                CheckboxGroup group,
                boolean state)
         throws HeadlessException
        在指定的复选框组中创建带有指定标签的复选框，并设置为指定的状态。
        参数
        label - 此复选框的字符串标签，或无标签的 null 。
        group - 此复选框的复选框组，或无组的 null 。
        state - 此复选框的初始状态。
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回 true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建复选框的对等体。 对等体允许您更改复选框的外观，而不更改其功能。
        重写：
        addNotify在 Component
        另请参见：
        Component.getToolkit()

      • getLabel

        public String getLabel​()
        获取此复选框的标签。
        结果
        该复选框的标签，或 null如果此复选框没有标签。
        另请参见：
        setLabel(String)

      • setLabel

        public void setLabel​(String label)
        将此复选框的标签设置为字符串参数。
        参数
        label - 要设置为新标签的字符串，或无标签的 null 。
        另请参见：
        getLabel()

      • getState

        public boolean getState​()
        确定此复选框是否处于“开”或“关”状态。 布尔值true表示“开”状态， false表示“关”状态。
        结果
        该复选框的状态为布尔值
        另请参见：
        setState(boolean)

      • setState

        public void setState​(boolean state)
        将此复选框的状态设置为指定的状态。 布尔值true表示“开”状态， false表示“关”状态。

        请注意，此方法主要用于初始化复选框的状态。 以编程方式设置复选框的状态不会触发ItemEvent 。 触发ItemEvent的唯一方法是通过用户交互。

        参数
        state - 复选框的布尔状态
        另请参见：
        getState()

      • getSelectedObjects

        public Object[] getSelectedObjects​()
        返回一个包含复选框标签的数组（长度1），如果未选中该复选框，则返回null。
        Specified by:
        getSelectedObjects在接口 ItemSelectable
        结果
        所选对象的列表，或 null
        另请参见：
        ItemSelectable

      • getCheckboxGroup

        public CheckboxGroup getCheckboxGroup​()
        确定此复选框的组。
        结果
        此复选框的组，或 null如果复选框不是复选框组的一部分。
        另请参见：
        setCheckboxGroup(CheckboxGroup)

      • setCheckboxGroup

        public void setCheckboxGroup​(CheckboxGroup g)
        将此复选框的组设置为指定的复选框组。 如果此复选框已在不同的复选框组中，则首先从该组中取出。

        如果此复选框的状态为true ，并且新组已选中复选框，则此复选框的状态将更改为false 。 如果此复选框的状态为true ，并且新组未选中复选框，该复选框将成为新组的选中复选框，其状态为true 。

        参数
        g - 新的复选框组，或 null从任何复选框组中删除此复选框
        另请参见：
        getCheckboxGroup()

      • addItemListener

        public void addItemListener​(ItemListener l)
        添加指定的项目侦听器以从此复选框接收项目事件。 项目事件响应于用户输入发送给侦听器，但不响应对setState（）的调用。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        addItemListener在接口 ItemSelectable
        参数
        l - 项目监听器
        从以下版本开始：
        1.1
        另请参见：
        removeItemListener(java.awt.event.ItemListener) ， getItemListeners() ， setState(boolean) ， ItemEvent ， ItemListener

      • removeItemListener

        public void removeItemListener​(ItemListener l)
        删除指定的项目监听器，以使项目监听器不再从此复选框接收项目事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        removeItemListener在接口 ItemSelectable
        参数
        l - 项目监听器
        从以下版本开始：
        1.1
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， getItemListeners() ， ItemEvent ， ItemListener

      • getItemListeners

        public ItemListener[] getItemListeners​()
        返回在此复选框上注册的所有项目侦听器的数组。
        结果
        所有这个复选框的 ItemListener s或一个空数组，如果没有项目监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， removeItemListener(java.awt.event.ItemListener) ， ItemEvent ， ItemListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册的所有对象的数组FooListener在这个S Checkbox 。 FooListener使用addFooListener方法注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询Checkbox c的项目监听器：

          ItemListener[] ils = (ItemListener[])(c.getListeners(ItemListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在类 Component
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此复选框上注册为 FooListener的所有对象的数组，如果未添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getItemListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此复选框上的事件。 如果事件是一个ItemEvent的实例，则该方法调用processItemEvent方法。 否则，它调用其超类的processEvent方法。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        重写：
        processEvent在 Component
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        ItemEvent ， processItemEvent(java.awt.event.ItemEvent)

      • processItemEvent

        protected void processItemEvent​(ItemEvent e)
        通过将此复选框发送到任何已注册的ItemListener对象来处理在此复选框上发生的项目事件。

        除非为此组件启用项目事件，否则不会调用此方法。 当以下情况发生时，项目事件被启用：

        • 一个ItemListener对象通过addItemListener注册。
        • 项目事件通过enableEvents启用。

        请注意，如果事件参数为null该行为未指定，并可能导致异常。

        参数
        e - 项目事件
        从以下版本开始：
        1.1
        另请参见：
        ItemEvent ， ItemListener ， addItemListener(java.awt.event.ItemListener) ， Component.enableEvents(long)

      • paramString

        protected String paramString​()
        返回一个表示Checkbox状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Component
        结果
        此复选框的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此复选框相关联的AccessibleContext。 对于复选框，AccessibleContext采用AccessibleAWTCheckbox的形式。 如有必要，将创建一个新的AccessibleAWTCheckbox。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个AccessibleAWTCheckbox作为此复选框的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Checkbox.AccessibleAWTCheckbox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Checkbox.AccessibleAWTCheckbox

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Checkbox.AccessibleAWTCheckbox
  • All Implemented Interfaces:
    ItemListener ， Serializable ， EventListener ， AccessibleAction ， AccessibleComponent ， AccessibleValue
    Enclosing class:
    Checkbox

    protected class Checkbox.AccessibleAWTCheckbox
extends Component.AccessibleAWTComponent
implements ItemListener, AccessibleAction, AccessibleValue
    这个类实现Checkbox类的可访问性支持。 它提供了适用于复选框用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleAWTCheckbox​()
      构造函数为 AccessibleAWTCheckbox

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean doAccessibleAction​(int i)
      对对象执行指定的Action
      AccessibleAction getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      int getAccessibleActionCount​()
      返回此对象中可用的操作数。
      String getAccessibleActionDescription​(int i)
      返回对象的指定操作的描述。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleValue getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      Number getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      void itemStateChanged​(ItemEvent e)
      当触发按钮的状态改变时，可触及的属性更改事件。
      boolean setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTCheckbox

        public AccessibleAWTCheckbox​()
        构造函数为 AccessibleAWTCheckbox

    • 方法详细信息

      • itemStateChanged

        public void itemStateChanged​(ItemEvent e)
        当触发按钮的状态改变时，可触及的属性更改事件。
        Specified by:
        itemStateChanged在接口 ItemListener
        参数
        e - 要处理的事件

      • getAccessibleAction

        public AccessibleAction getAccessibleAction​()
        获取与此对象关联的AccessibleAction。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleAction接口。
        重写：
        getAccessibleAction在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleAction

      • getAccessibleValue

        public AccessibleValue getAccessibleValue​()
        获取与此对象关联的AccessibleValue。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleValue接口。
        重写：
        getAccessibleValue在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleValue

      • getAccessibleActionCount

        public int getAccessibleActionCount​()
        返回此对象中可用的操作数。 如果有多个，第一个是“默认”动作。
        Specified by:
        getAccessibleActionCount在接口 AccessibleAction
        结果
        此对象中的操作数

      • getAccessibleActionDescription

        public String getAccessibleActionDescription​(int i)
        返回对象的指定操作的描述。
        Specified by:
        getAccessibleActionDescription在接口 AccessibleAction
        参数
        i - 零操作的索引
        结果
        一个 String描述的动作
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction​(int i)
        对对象执行指定的Action
        Specified by:
        doAccessibleAction在接口 AccessibleAction
        参数
        i - 从零开始的行动指数
        结果
        如果行动执行，则为真; 否则假。
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue​()
        将该对象的值作为数字获取。 如果未设置该值，返回值将为空。
        Specified by:
        getCurrentAccessibleValue在接口 AccessibleValue
        结果
        对象的值
        另请参见：
        setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue​(Number n)
        将此对象的值设置为数字。
        Specified by:
        setCurrentAccessibleValue在接口 AccessibleValue
        参数
        n - 用于该值的数字
        结果
        如果设置了该值，则为真; 否则假
        另请参见：
        getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue​()
        将此对象的最小值作为数字获取。
        Specified by:
        getMinimumAccessibleValue在接口 AccessibleValue
        结果
        对象的最小值; 如果此对象没有最小值，则为null
        另请参见：
        getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue​()
        获取该对象的最大值作为数字。
        Specified by:
        getMaximumAccessibleValue在接口 AccessibleValue
        结果
        对象的最大值; 如果此对象没有最大值，则为null
        另请参见：
        getMinimumAccessibleValue()

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态集。
        重写：
        getAccessibleStateSet在类 Component.AccessibleAWTComponent
        结果
        AccessibleState的一个实例包含对象的当前状态
        另请参见：
        AccessibleState
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CheckboxGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class CheckboxGroup

  • java.lang.Object
    • java.awt.CheckboxGroup
  • All Implemented Interfaces:
    Serializable

    public class CheckboxGroup
extends Object
implements Serializable
    CheckboxGroup类用于将一组Checkbox按钮组合在一起。

    在任何给定时间， CheckboxGroup一个复选框按钮可以处于“开”状态。 按任何按钮将其状态设置为“开”，并强制处于“开”状态的任何其他按钮进入“关”状态。

    以下代码示例生成一个新的复选框组，其中有三个复选框：

     setLayout(new GridLayout(3, 1));
 CheckboxGroup cbg = new CheckboxGroup();
 add(new Checkbox("one", cbg, true));
 add(new Checkbox("two", cbg, false));
 add(new Checkbox("three", cbg, false));

    此图像描述了由此示例创建的复选框组：

    从以下版本开始：
    1.0
    另请参见：
    Checkbox ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckboxGroup​()
      创建一个新的实例 CheckboxGroup 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Checkbox getCurrent​()
      已过时。
      从JDK 1.1版开始，由getSelectedCheckbox()替代。
      Checkbox getSelectedCheckbox​()
      从此复选框组获取当前选择。
      void setCurrent​(Checkbox box)
      已过时。
      从JDK 1.1版开始，由setSelectedCheckbox(Checkbox)替代。
      void setSelectedCheckbox​(Checkbox box)
      将此组中当前选中的复选框设置为指定的复选框。
      String toString​()
      返回此复选框组的字符串表示形式，包括其当前选择的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CheckboxGroup

        public CheckboxGroup​()
        创建一个新的实例 CheckboxGroup 。

    • 方法详细信息

      • getSelectedCheckbox

        public Checkbox getSelectedCheckbox​()
        从此复选框组获取当前选择。 当前的选择是此组中当前处于“开”状态的复选框，如果该组中的所有复选框都已关闭， null 。
        结果
        当前处于“开”状态的复选框，或 null 。
        从以下版本开始：
        1.1
        另请参见：
        Checkbox ， setSelectedCheckbox(java.awt.Checkbox)

      • getCurrent

        @Deprecated
public Checkbox getCurrent​()
        已过时。 自JDK 1.1版起，由getSelectedCheckbox()替代。
        如果没有选中复选框，则返回此复选框组中的当前选项或 null 。
        结果
        选中的复选框

      • setSelectedCheckbox

        public void setSelectedCheckbox​(Checkbox box)
        将此组中当前选中的复选框设置为指定的复选框。 此方法将该复选框的状态设置为“开”，并将组中的所有其他复选框设置为关闭。

        如果复选框参数为null ，则此复选框组中的所有复选框将被取消选中。 如果复选框参数属于不同的复选框组，则此方法不执行任何操作。

        参数
        box - 将 Checkbox设为当前选择。
        从以下版本开始：
        1.1
        另请参见：
        Checkbox ， getSelectedCheckbox()

      • setCurrent

        @Deprecated
public void setCurrent​(Checkbox box)
        已过时。 从JDK 1.1版开始，由setSelectedCheckbox(Checkbox)替代。
        将此组中当前选中的复选框设置为指定的复选框，并取消所有其他复选框。
        参数
        box - 将 Checkbox设为当前选择。

      • toString

        public String toString​()
        返回此复选框组的字符串表示形式，包括其当前选择的值。
        重写：
        toString在 Object
        结果
        此复选框组的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CheckboxMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class CheckboxMenuItem

  • java.lang.Object
    • java.awt.MenuComponent
      • java.awt.MenuItem
        • java.awt.CheckboxMenuItem
  • All Implemented Interfaces:
    ItemSelectable ， Serializable ， Accessible

    public class CheckboxMenuItem
extends MenuItem
implements ItemSelectable, Accessible
    此类表示可以包含在菜单中的复选框。 选择菜单中的复选框会将其状态从“开”更改为“关”，或将其从“关”更改为“开”。

    下图显示了包含CheckBoxMenuItem实例的CheckBoxMenuItem ：

    标有Check的项目显示“关闭”状态下的复选框菜单项。

    当选中一个复选框菜单项时，AWT将一个项目事件发送到该项目。 由于事件是ItemEvent一个实例，因此processEvent方法检查事件并将其传递给processItemEvent 。 后一种方法将事件重定向到已经对该菜单项生成的项目事件感兴趣的任何ItemListener对象。

    从以下版本开始：
    1.0
    另请参见：
    ItemEvent ， ItemListener ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。

      • Nested classes/interfaces inherited from class java.awt.MenuComponent

        MenuComponent.AccessibleAWTMenuComponent

      • Nested classes/interfaces inherited from class java.awt.MenuItem

        MenuItem.AccessibleAWTMenuItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      CheckboxMenuItem​()
      创建一个带有空标签的复选框菜单项。
      CheckboxMenuItem​(String label)
      创建带有指定标签的复选框菜单项。
      CheckboxMenuItem​(String label, boolean state)
      创建带有指定标签和状态的复选框菜单项。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addItemListener​(ItemListener l)
      添加指定的项目侦听器以从此复选框菜单项接收项目事件。
      void addNotify​()
      创建复选框项目的对等体。
      AccessibleContext getAccessibleContext​()
      获取与此CheckboxMenuItem关联的AccessibleContext。
      ItemListener[] getItemListeners​()
      返回在此复选框菜单上注册的所有项目侦听器的数组。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回此 CheckboxMenuItem当前注册为 FooListener的所有对象的数组。
      Object[] getSelectedObjects​()
      返回包含复选框菜单项标签的数组（长度1），如果未选中复选框，则返回null。
      boolean getState​()
      确定此复选框菜单项的状态是“开”还是“关”。
      String paramString​()
      返回一个表示 CheckBoxMenuItem状态的字符串。
      protected void processEvent​(AWTEvent e)
      处理此复选框菜单项上的事件。
      protected void processItemEvent​(ItemEvent e)
      通过将此复选框菜单项发送到任何已注册的 ItemListener对象来处理项目事件。
      void removeItemListener​(ItemListener l)
      删除指定的项目监听器，使其不再从此复选框菜单项目接收项目事件。
      void setState​(boolean b)
      将此复选框菜单项设置为指定的状态。

      • Methods inherited from class java.awt.MenuComponent

        dispatchEvent, getFont, getName, getParent, getTreeLock, postEvent, removeNotify, setFont, setName, toString

      • Methods inherited from class java.awt.MenuItem

        addActionListener, deleteShortcut, disable, disableEvents, enable, enable, enableEvents, getActionCommand, getActionListeners, getLabel, getShortcut, isEnabled, processActionEvent, removeActionListener, setActionCommand, setEnabled, setLabel, setShortcut

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CheckboxMenuItem

        public CheckboxMenuItem​()
                 throws HeadlessException
        创建一个带有空标签的复选框菜单项。 项目的状态最初设置为“关闭”。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

      • CheckboxMenuItem

        public CheckboxMenuItem​(String label)
                 throws HeadlessException
        创建带有指定标签的复选框菜单项。 项目的状态最初设置为“关闭”。
        参数
        label - 复选框菜单项的字符串标签，或未标记菜单项的 null 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • CheckboxMenuItem

        public CheckboxMenuItem​(String label,
                        boolean state)
                 throws HeadlessException
        创建带有指定标签和状态的复选框菜单项。
        参数
        label - 复选框菜单项的字符串标签，或未标记菜单项的 null 。
        state - 菜单项的初始状态，其中 true表示“开”， false表示“关闭”。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建复选框项目的对等体。 该对等体允许我们改变复选框项目的外观，而不改变其功能。 大多数应用程序不直接调用此方法。
        重写：
        addNotify在 MenuItem
        另请参见：
        Component.getToolkit()

      • getState

        public boolean getState​()
        确定此复选框菜单项的状态是“开”还是“关”。
        结果
        该复选框菜单项的状态，其中 true表示“开”，而 false表示“关”
        另请参见：
        setState(boolean)

      • setState

        public void setState​(boolean b)
        将此复选框菜单项设置为指定的状态。 布尔值true表示“开”，而false表示“关闭”。

        请注意，此方法应主要用于初始化复选框菜单项的状态。 以编程方式设置复选框菜单项的状态不会触发ItemEvent 。 触发ItemEvent的唯一方法是通过用户交互。

        参数
        b - true如果复选框菜单项为开，否则为 false
        另请参见：
        getState()

      • getSelectedObjects

        public Object[] getSelectedObjects​()
        返回包含复选框菜单项标签的数组（长度1），如果未选中复选框，则返回null。
        Specified by:
        getSelectedObjects在接口 ItemSelectable
        结果
        所选对象的列表，或 null
        另请参见：
        ItemSelectable

      • addItemListener

        public void addItemListener​(ItemListener l)
        添加指定的项目侦听器以从此复选框菜单项接收项目事件。 事件响应用户操作发送，但不响应对setState（）的调用。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        addItemListener在接口 ItemSelectable
        参数
        l - 项目监听器
        从以下版本开始：
        1.1
        另请参见：
        removeItemListener(java.awt.event.ItemListener) ， getItemListeners() ， setState(boolean) ， ItemEvent ， ItemListener

      • removeItemListener

        public void removeItemListener​(ItemListener l)
        删除指定的项目监听器，使其不再从此复选框菜单项目接收项目事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        removeItemListener在接口 ItemSelectable
        参数
        l - 项目监听器
        从以下版本开始：
        1.1
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， getItemListeners() ， ItemEvent ， ItemListener

      • getItemListeners

        public ItemListener[] getItemListeners​()
        返回在此复选框菜单上注册的所有项目侦听器的数组。
        结果
        所有这个复选框menuitem的 ItemListener s或一个空数组，如果没有项目监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， removeItemListener(java.awt.event.ItemListener) ， ItemEvent ， ItemListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回此CheckboxMenuItem当前注册为FooListener的所有对象的数组。 FooListener使用addFooListener注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询CheckboxMenuItem c其项监听器：

          ItemListener[] ils = (ItemListener[])(c.getListeners(ItemListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在类 MenuItem
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在这个复选框menuitem上注册为 FooListener的所有对象的数组，如果没有添加这样的侦听器，则是一个空数组
        异常
        ClassCastException - 如果 listenerType未指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getItemListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此复选框菜单项上的事件。 如果事件是ItemEvent的实例，则此方法调用processItemEvent方法。 如果事件不是项目事件，它将在超类上调用processEvent 。

        复选框菜单项目目前仅支持项目事件。

        请注意，如果事件参数为null该行为未指定，并可能导致异常。

        重写：
        processEvent在类 MenuItem
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        ItemEvent ， processItemEvent(java.awt.event.ItemEvent)

      • processItemEvent

        protected void processItemEvent​(ItemEvent e)
        通过将此复选框菜单项发送到任何已注册的ItemListener对象来处理项目事件。

        除非为此菜单项启用项目事件，否则不会调用此方法。 当以下情况发生时，项目事件被启用：

        • 一个ItemListener对象通过addItemListener注册。
        • 项目事件通过enableEvents启用。

        请注意，如果事件参数为null该行为是未指定的，可能会导致异常。

        参数
        e - 项目事件
        从以下版本开始：
        1.1
        另请参见：
        ItemEvent ， ItemListener ， addItemListener(java.awt.event.ItemListener) ， MenuItem.enableEvents(long)

      • paramString

        public String paramString​()
        返回一个表示CheckBoxMenuItem状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 MenuItem
        结果
        该复选框菜单项的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此CheckboxMenuItem关联的AccessibleContext。 对于复选框菜单项，AccessibleContext采用AccessibleAWTCheckboxMenuItem的形式。 如有必要，将创建一个新的AccessibleAWTCheckboxMenuItem。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 MenuItem
        结果
        一个AccessibleAWTCheckboxMenuItem，用作此CheckboxMenuItem的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.MenuComponent.AccessibleAWTMenuComponent
        • java.awt.MenuItem.AccessibleAWTMenuItem
          • java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
  • All Implemented Interfaces:
    Serializable ， AccessibleAction ， AccessibleComponent ， AccessibleSelection ， AccessibleValue
    Enclosing class:
    CheckboxMenuItem

    protected class CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
extends MenuItem.AccessibleAWTMenuItem
implements AccessibleAction, AccessibleValue
    用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。 这个类不是由应用程序开发人员直接使用的，而是意味着仅由菜单组件开发人员进行子类化。

    该类实现CheckboxMenuItem类的可访问性支持。 它提供了适用于复选框菜单项用户界面元素的Java Accessibility API的实现。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTCheckboxMenuItem​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean doAccessibleAction​(int i)
      对对象执行指定的Action
      AccessibleAction getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      int getAccessibleActionCount​()
      返回此对象中可用的操作数。
      String getAccessibleActionDescription​(int i)
      返回对象的指定操作的描述。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleValue getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      Number getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      boolean setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。

      • Methods inherited from class javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.MenuComponent.AccessibleAWTMenuComponent

        addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.MenuItem.AccessibleAWTMenuItem

        getAccessibleName

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTCheckboxMenuItem

        protected AccessibleAWTCheckboxMenuItem​()

    • 方法详细信息

      • getAccessibleAction

        public AccessibleAction getAccessibleAction​()
        获取与此对象关联的AccessibleAction。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleAction接口。
        重写：
        getAccessibleAction在 MenuItem.AccessibleAWTMenuItem
        结果
        这个对象
        另请参见：
        AccessibleAction

      • getAccessibleValue

        public AccessibleValue getAccessibleValue​()
        获取与此对象关联的AccessibleValue。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleValue接口。
        重写：
        getAccessibleValue在 MenuItem.AccessibleAWTMenuItem
        结果
        这个对象
        另请参见：
        AccessibleValue

      • getAccessibleActionCount

        public int getAccessibleActionCount​()
        返回此对象中可用的操作数。 如果有多个，第一个是“默认”动作。
        Specified by:
        getAccessibleActionCount在接口 AccessibleAction
        重写：
        getAccessibleActionCount在类 MenuItem.AccessibleAWTMenuItem
        结果
        此对象中的操作数

      • getAccessibleActionDescription

        public String getAccessibleActionDescription​(int i)
        返回对象的指定操作的描述。
        Specified by:
        getAccessibleActionDescription在接口 AccessibleAction
        重写：
        getAccessibleActionDescription在类 MenuItem.AccessibleAWTMenuItem
        参数
        i - 零操作的索引
        结果
        一个 String描述的动作
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction​(int i)
        对对象执行指定的Action
        Specified by:
        doAccessibleAction在接口 AccessibleAction
        重写：
        doAccessibleAction在 MenuItem.AccessibleAWTMenuItem
        参数
        i - 基于零的操作索引
        结果
        如果行动执行，则为真; 否则为虚假。
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue​()
        将该对象的值作为数字获取。 如果未设置该值，返回值将为空。
        Specified by:
        getCurrentAccessibleValue在接口 AccessibleValue
        重写：
        getCurrentAccessibleValue在类 MenuItem.AccessibleAWTMenuItem
        结果
        对象的值
        另请参见：
        setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue​(Number n)
        将此对象的值设置为数字。
        Specified by:
        setCurrentAccessibleValue在接口 AccessibleValue
        重写：
        setCurrentAccessibleValue在 MenuItem.AccessibleAWTMenuItem
        参数
        n - 用于该值的数字
        结果
        如果设置了该值，则为true; 否则为虚假
        另请参见：
        getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue​()
        将此对象的最小值作为数字获取。
        Specified by:
        getMinimumAccessibleValue在接口 AccessibleValue
        重写：
        getMinimumAccessibleValue在 MenuItem.AccessibleAWTMenuItem
        结果
        对象的最小值; 如果此对象没有最小值，则为null
        另请参见：
        getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue​()
        获取该对象的最大值作为数字。
        Specified by:
        getMaximumAccessibleValue在接口 AccessibleValue
        重写：
        getMaximumAccessibleValue在 MenuItem.AccessibleAWTMenuItem
        结果
        对象的最大值; 如果此对象没有最大值，则为null
        另请参见：
        getMinimumAccessibleValue()

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 MenuItem.AccessibleAWTMenuItem
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Choice (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Choice

  • java.lang.Object
    • java.awt.Component
      • java.awt.Choice
  • All Implemented Interfaces:
    ImageObserver ， ItemSelectable ， MenuContainer ， Serializable ， Accessible

    public class Choice
extends Component
implements ItemSelectable, Accessible
    Choice课程提供了一个弹出菜单的选择。 当前选项显示为菜单的标题。

    以下代码示例生成一个弹出菜单：

     Choice ColorChooser = new Choice();
 ColorChooser.add("Green");
 ColorChooser.add("Red");
 ColorChooser.add("Blue");

    将此选择菜单添加到面板后，其正常状态如下所示：

    在图片中， "Green"是目前的选择。 在对象上按下鼠标按钮会导致菜单出现，当前选项突出显示。

    一些本机平台不支持任意调整大小Choice组件和行为setSize()/getSize()由这些限制的约束。 本地GUI Choice组件的大小通常受到包含在Choice的项目的字体大小和长度等属性的Choice 。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Choice.AccessibleAWTChoice
      这个类实现 Choice类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Choice​()
      创建一个新的选择菜单。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void add​(String item)
      在 Choice菜单中添加项目。
      void addItem​(String item)
      作为Java 2平台v1.1的过时。
      void addItemListener​(ItemListener l)
      添加指定的项目监听器以从此 Choice菜单接收项目事件。
      void addNotify​()
      创建 Choice的同伴。
      int countItems​()
      已过时。
      从JDK 1.1版开始，由getItemCount()替换。
      AccessibleContext getAccessibleContext​()
      获取 AccessibleContext与此 Choice相关联。
      String getItem​(int index)
      获取此 Choice菜单中指定索引处的字符串。
      int getItemCount​()
      返回此 Choice菜单中的项目数。
      ItemListener[] getItemListeners​()
      返回在此选项上注册的所有项目侦听器的数组。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，此 Choice 。
      int getSelectedIndex​()
      返回当前所选项目的索引。
      String getSelectedItem​()
      获取当前选择的表示形式作为字符串。
      Object[] getSelectedObjects​()
      返回一个包含当前所选项目的数组（长度1）。
      void insert​(String item, int index)
      在指定位置将项目插入此选项。
      protected String paramString​()
      返回表示此 Choice菜单状态的字符串。
      protected void processEvent​(AWTEvent e)
      处理此选择的事件。
      protected void processItemEvent​(ItemEvent e)
      通过将它们发送到任何已注册的 ItemListener对象来处理在此 Choice菜单上发生的项目事件。
      void remove​(int position)
      从指定位置的选择菜单中删除一个项目。
      void remove​(String item)
      从 Choice菜单中删除 item的第一次出现。
      void removeAll​()
      从选择菜单中删除所有项目。
      void removeItemListener​(ItemListener l)
      删除指定的项目监听器，使其不再从此 Choice菜单中接收项目事件。
      void select​(int pos)
      将此 Choice菜单中的选定项目设置为指定位置的项目。
      void select​(String str)
      将此 Choice菜单中的选定项目设置为名称等于指定字符串的项目。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Choice

        public Choice​()
       throws HeadlessException
        创建一个新的选择菜单。 菜单最初没有任何项目。

        默认情况下，添加到选择菜单的第一个项目成为所选项目，直到通过调用其中一个select方法进行用户进行的其他选择。

        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless() ， select(int) ， select(java.lang.String)

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建Choice的同行。 该对等体允许我们改变Choice的外观，而不改变其功能。
        重写：
        addNotify在 Component
        另请参见：
        Component.getToolkit()

      • getItemCount

        public int getItemCount​()
        返回此 Choice菜单中的项目数。
        结果
        此 Choice菜单中的项目数
        从以下版本开始：
        1.1
        另请参见：
        getItem(int)

      • countItems

        @Deprecated
public int countItems​()
        已过时。 截至JDK 1.1版，由getItemCount()替代。
        返回此 Choice菜单中的项目数。
        结果
        此 Choice菜单中的项目数

      • getItem

        public String getItem​(int index)
        获取此 Choice菜单中指定索引处的字符串。
        参数
        index - 开始的索引
        结果
        指定索引处的项目
        另请参见：
        getItemCount()

      • add

        public void add​(String item)
        添加一个项目到这个 Choice菜单。
        参数
        item - 要添加的项目
        异常
        NullPointerException - 如果项目的值是 null
        从以下版本开始：
        1.1

      • addItem

        public void addItem​(String item)
        作为Java 2平台v1.1的过时。 请改用add方法。

        添加一个项目到这个Choice菜单。

        参数
        item - 要添加的项目
        异常
        NullPointerException - 如果项目的值等于 null

      • insert

        public void insert​(String item,
                   int index)
        在指定位置将项目插入此选项。 索引大于或等于index现有项目index移一个以适应新项目。 如果index大于或等于此选项中的项目数， item在此选项的末尾添加item 。

        如果项目是添加到选项中的第一个项目，则该项目将被选中。 否则，如果所选项目是移动的项目之一，则选择中的第一个项目将成为所选项目。 如果所选项目在移动的项目中为否，则仍保留所选项目。

        参数
        item - 要插入的非 null项目
        index - 应该插入物品的位置
        异常
        IllegalArgumentException - 如果索引小于0

      • remove

        public void remove​(String item)
        从Choice菜单中删除第一次出现的item 。 如果要删除的项目是当前选择的项目，则选择中的第一个项目将成为所选项目。 否则，当前选择的项目仍然保持选择（并且相应地更新所选择的索引）。
        参数
        item - 从这个 Choice菜单中删除的项目
        异常
        IllegalArgumentException - 如果项目不存在于选择菜单中
        从以下版本开始：
        1.1

      • remove

        public void remove​(int position)
        从指定位置的选择菜单中删除一个项目。 如果要删除的项目是当前选择的项目，则选择中的第一个项目将成为所选项目。 否则，当前选择的项目仍然保持选择（并且相应地更新所选择的索引）。
        参数
        position - 项目的位置
        异常
        IndexOutOfBoundsException - 如果指定的位置超出范围
        从以下版本开始：
        1.1

      • removeAll

        public void removeAll​()
        从选择菜单中删除所有项目。
        从以下版本开始：
        1.1
        另请参见：
        remove(java.lang.String)

      • getSelectedItem

        public String getSelectedItem​()
        获取当前选择的表示形式作为字符串。
        结果
        此选择菜单中当前选定项目的字符串表示形式
        另请参见：
        getSelectedIndex()

      • getSelectedObjects

        public Object[] getSelectedObjects​()
        返回一个包含当前所选项目的数组（长度1）。 如果此选项没有任何项目，则返回null 。
        Specified by:
        getSelectedObjects在接口 ItemSelectable
        结果
        所选对象的列表，或 null
        另请参见：
        ItemSelectable

      • getSelectedIndex

        public int getSelectedIndex​()
        返回当前所选项目的索引。 如果没有选择，返回-1。
        结果
        当前所选项目的索引，如果当前未选择任何项目，则为-1
        另请参见：
        getSelectedItem()

      • select

        public void select​(int pos)
        将此Choice菜单中的选定项目设置为指定位置的项目。

        请注意，此方法应主要用于初始选择此组件中的项目。 以编程方式调用此方法不会触发ItemEvent 。 触发ItemEvent的唯一方法是通过用户交互。

        参数
        pos - 所选项目的位置
        异常
        IllegalArgumentException - 如果指定的位置大于项目数或小于零
        另请参见：
        getSelectedItem() ， getSelectedIndex()

      • select

        public void select​(String str)
        将此Choice菜单中的选定项目设置为名称等于指定字符串的项目。 如果多个项匹配（等于）指定的字符串，则选择具有最小索引的字符串。

        请注意，此方法应主要用于初始选择此组件中的项目。 以编程方式调用此方法不会触发ItemEvent 。 触发ItemEvent的唯一方法是通过用户交互。

        参数
        str - 指定的字符串
        另请参见：
        getSelectedItem() ， getSelectedIndex()

      • addItemListener

        public void addItemListener​(ItemListener l)
        添加指定的项目侦听器以从此Choice菜单接收项目事件。 项目事件是响应于用户输入发送的，但不响应对select调用。 如果l为null ，则不会抛出异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        addItemListener在接口 ItemSelectable
        参数
        l - 项目监听器
        从以下版本开始：
        1.1
        另请参见：
        removeItemListener(java.awt.event.ItemListener) ， getItemListeners() ， select(int) ， ItemEvent ， ItemListener

      • removeItemListener

        public void removeItemListener​(ItemListener l)
        删除指定的项目监听器，使其不再从此Choice菜单中接收项目事件。 如果l为null ，则不会抛出异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        removeItemListener在接口 ItemSelectable
        参数
        l - 项目侦听器
        从以下版本开始：
        1.1
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， getItemListeners() ， ItemEvent ， ItemListener

      • getItemListeners

        public ItemListener[] getItemListeners​()
        返回在此选项上注册的所有项目侦听器的数组。
        结果
        所有这个选择的 ItemListener s或一个空数组，如果没有项目监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， removeItemListener(java.awt.event.ItemListener) ， ItemEvent ， ItemListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册为FooListener的所有对象的数组，这个Choice 。 FooListener使用addFooListener注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询Choice c的项目监听器：

          ItemListener[] ils = (ItemListener[])(c.getListeners(ItemListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在 Component
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 该参数应指定从java.util.EventListener下降的接口
        结果
        在此选项上注册为 FooListener的所有对象的数组，如果没有添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getItemListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此选择的事件。 如果事件是ItemEvent的实例，则调用processItemEvent方法。 否则，它调用其超类的processEvent方法。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        重写：
        processEvent类 Component
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        ItemEvent ， processItemEvent(java.awt.event.ItemEvent)

      • processItemEvent

        protected void processItemEvent​(ItemEvent e)
        通过将其发送到任何已注册的ItemListener对象来处理此Choice菜单上发生的项目事件。

        除非为此组件启用项目事件，否则不会调用此方法。 当以下情况发生时，项目事件被启用：

        • 通过addItemListener注册ItemListener对象。
        • 项目事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        参数
        e - 项目事件
        从以下版本开始：
        1.1
        另请参见：
        ItemEvent ， ItemListener ， addItemListener(ItemListener) ， Component.enableEvents(long)

      • paramString

        protected String paramString​()
        返回表示此Choice菜单状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Component
        结果
        这个 Choice菜单的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取AccessibleContext与此Choice相关联。 为Choice元件， AccessibleContext需要一个的形式AccessibleAWTChoice 。 如有必要，将创建一个新的AccessibleAWTChoice实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个 AccessibleAWTChoice ，作为 AccessibleContext的这个 Choice
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Choice.AccessibleAWTChoice (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Choice.AccessibleAWTChoice

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Choice.AccessibleAWTChoice
  • All Implemented Interfaces:
    Serializable ， AccessibleAction ， AccessibleComponent
    Enclosing class:
    Choice

    protected class Choice.AccessibleAWTChoice
extends Component.AccessibleAWTComponent
implements AccessibleAction
    这个类实现Choice类的可访问性支持。 它提供了适用于选择用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleAWTChoice​()
      构造函数为 AccessibleAWTChoice

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean doAccessibleAction​(int i)
      对对象执行指定的Action
      AccessibleAction getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      int getAccessibleActionCount​()
      返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。
      String getAccessibleActionDescription​(int i)
      返回对象的指定操作的描述。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTChoice

        public AccessibleAWTChoice​()
        构造函数为 AccessibleAWTChoice

    • 方法详细信息

      • getAccessibleAction

        public AccessibleAction getAccessibleAction​()
        获取与此对象关联的AccessibleAction。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleAction接口。
        重写：
        getAccessibleAction在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleAction

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleActionCount

        public int getAccessibleActionCount​()
        返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。
        Specified by:
        getAccessibleActionCount在接口 AccessibleAction
        结果
        该对象中基于零的操作数

      • getAccessibleActionDescription

        public String getAccessibleActionDescription​(int i)
        返回对象的指定操作的描述。
        Specified by:
        getAccessibleActionDescription在接口 AccessibleAction
        参数
        i - 零操作的索引
        结果
        一个字符串描述的动作
        另请参见：
        getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction​(int i)
        对对象执行指定的Action
        Specified by:
        doAccessibleAction在接口 AccessibleAction
        参数
        i - 基于零的操作索引
        结果
        如果行动执行，则为真; 否则为虚假。
        另请参见：
        getAccessibleActionCount()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Color (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Color

  • java.lang.Object
    • java.awt.Color
  • All Implemented Interfaces:
    Paint ， Transparency ， Serializable
    已知直接子类：
    ColorUIResource ， SystemColor

    public class Color
extends Object
implements Paint, Serializable
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。 每个颜色的隐含alpha值为1.0或构造函数中提供的一个显式的Alpha值。 alpha值定义了颜色的透明度，可以用范围0.0-1.0或0-255的浮点数来表示。alpha值为1.0或255表示颜色完全不透明，alpha值为0或0.0意味着颜色是完全透明的。 当构造一个Color具有显式α或得到一个的颜色/ alpha分量Color ，颜色分量决不会被预乘alpha分量。

    Java 2D（tm）API的默认颜色空间是sRGB，一种提出的标准RGB颜色空间。 有关sRGB的更多信息，请参阅http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html 。

    Version:
    1997年2月10日
    另请参见：
    ColorSpace ， AlphaComposite ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Color black
      颜色黑色。
      static Color BLACK
      颜色黑色。
      static Color blue
      颜色蓝色。
      static Color BLUE
      颜色蓝色。
      static Color cyan
      颜色青色。
      static Color CYAN
      颜色青色。
      static Color DARK_GRAY
      颜色深灰色。
      static Color darkGray
      颜色深灰色。
      static Color gray
      颜色灰色。
      static Color GRAY
      颜色灰色。
      static Color green
      颜色绿色。
      static Color GREEN
      颜色绿色。
      static Color LIGHT_GRAY
      颜色浅灰色。
      static Color lightGray
      颜色浅灰色。
      static Color magenta
      颜色洋红色。
      static Color MAGENTA
      颜色洋红色。
      static Color orange
      颜色橙色。
      static Color ORANGE
      颜色橙色。
      static Color pink
      颜色粉红色。
      static Color PINK
      颜色粉红色。
      static Color red
      颜色红色。
      static Color RED
      颜色红色。
      static Color white
      颜色白色。
      static Color WHITE
      颜色白色。
      static Color yellow
      颜色黄色。
      static Color YELLOW
      颜色黄色。

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      Color​(float r, float g, float b)
      使用范围（0.0 - 1.0）中指定的红色，绿色和蓝色值创建不透明的sRGB颜色。
      Color​(float r, float g, float b, float a)
      用范围（0.0 - 1.0）中指定的红，绿，蓝和阿尔法值创建sRGB颜色。
      Color​(int rgb)
      创建一个不透明的sRGB颜色，其中指定的组合RGB值包括位16-23中的红色分量，位8-15中的绿色分量和位0-7中的蓝色分量。
      Color​(int rgba, boolean hasalpha)
      使用指定的组合RGBA值创建sRGB颜色，RGBA值由位24-31中的alpha分量，位16-23中的红色分量，位8-15中的绿色分量和位0-7中的蓝色分量组成。
      Color​(int r, int g, int b)
      用范围（0 - 255）范围内的指定的红色，绿色和蓝色值创建不透明的sRGB颜色。
      Color​(int r, int g, int b, int a)
      在范围（0 - 255）范围内创建指定的红，绿，蓝和阿尔法值的sRGB颜色。
      Color​(ColorSpace cspace, float[] components, float alpha)
      创建指定一个颜色 ColorSpace与中指定的颜色分量 float阵列和所述指定的alpha。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Color brighter​()
      创建一个新的 Color这是一个更明亮的版本的这个 Color 。
      PaintContext createContext​(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成纯色字段模式的PaintContext 。
      Color darker​()
      创建一个新的 Color这是一个较深的版本的这个 Color 。
      static Color decode​(String nm)
      将 String转换为整数，并返回指定的不透明度 Color 。
      boolean equals​(Object obj)
      确定另一个对象是否等于此 Color 。
      int getAlpha​()
      返回0-255范围内的alpha分量。
      int getBlue​()
      返回默认sRGB空间中0-255范围内的蓝色分量。
      static Color getColor​(String nm)
      在系统属性中查找颜色。
      static Color getColor​(String nm, int v)
      在系统属性中查找颜色。
      static Color getColor​(String nm, Color v)
      在系统属性中查找颜色。
      float[] getColorComponents​(float[] compArray)
      返回一个 float阵列只包含的颜色分量 Color ，在 ColorSpace的的 Color 。
      float[] getColorComponents​(ColorSpace cspace, float[] compArray)
      返回一个 float数组，其中仅包含由 cspace参数指定的 Color中的 ColorSpace的颜色分量。
      ColorSpace getColorSpace​()
      返回此 ColorSpace的 Color 。
      float[] getComponents​(float[] compArray)
      返回一个包含 float的颜色和alpha分量的 Color ，在 ColorSpace的 Color 。
      float[] getComponents​(ColorSpace cspace, float[] compArray)
      返回一个 float阵列包含的颜色和alpha分量 Color ，在 ColorSpace由指定 cspace参数。
      int getGreen​()
      返回默认sRGB空间中的0-255范围内的绿色组件。
      static Color getHSBColor​(float h, float s, float b)
      根据HSB颜色模型的指定值创建一个 Color对象。
      int getRed​()
      返回默认sRGB空间中0-255范围内的红色分量。
      int getRGB​()
      返回表示默认sRGB ColorModel中颜色的RGB值。
      float[] getRGBColorComponents​(float[] compArray)
      返回一个 float阵列只包含的颜色分量 Color ，在默认的sRGB色彩空间。
      float[] getRGBComponents​(float[] compArray)
      返回一个包含 float的颜色和alpha组件的 Color ，如默认sRGB颜色空间所示。
      int getTransparency​()
      返回此 Color的透明度模式。
      int hashCode​()
      计算这个 Color的哈希码。
      static int HSBtoRGB​(float hue, float saturation, float brightness)
      将HSB模型指定的颜色组件转换为默认RGB模型的等效值。
      static float[] RGBtoHSB​(int r, int g, int b, float[] hsbvals)
      将默认RGB模型指定的颜色组件转换为HSB模型的三个组件的色相，饱和度和亮度的等效值。
      String toString​()
      返回此 Color的字符串表示 Color 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • white

        public static final Color white
        颜色白色。 在默认的sRGB空间。

      • WHITE

        public static final Color WHITE
        颜色白色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • lightGray

        public static final Color lightGray
        颜色浅灰色。 在默认的sRGB空间。

      • LIGHT_GRAY

        public static final Color LIGHT_GRAY
        颜色浅灰色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • gray

        public static final Color gray
        颜色灰色。 在默认的sRGB空间。

      • GRAY

        public static final Color GRAY
        颜色灰色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • darkGray

        public static final Color darkGray
        颜色深灰色。 在默认的sRGB空间。

      • DARK_GRAY

        public static final Color DARK_GRAY
        颜色深灰色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • black

        public static final Color black
        颜色黑色。 在默认的sRGB空间。

      • BLACK

        public static final Color BLACK
        颜色黑色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • red

        public static final Color red
        颜色红色。 在默认的sRGB空间。

      • RED

        public static final Color RED
        颜色红色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • pink

        public static final Color pink
        颜色粉红色。 在默认的sRGB空间。

      • PINK

        public static final Color PINK
        颜色粉红色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • orange

        public static final Color orange
        颜色橙色。 在默认的sRGB空间。

      • ORANGE

        public static final Color ORANGE
        颜色橙色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • yellow

        public static final Color yellow
        颜色黄色。 在默认的sRGB空间。

      • YELLOW

        public static final Color YELLOW
        颜色黄色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • green

        public static final Color green
        颜色绿色。 在默认的sRGB空间。

      • GREEN

        public static final Color GREEN
        颜色绿色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • magenta

        public static final Color magenta
        颜色洋红色。 在默认的sRGB空间。

      • MAGENTA

        public static final Color MAGENTA
        颜色洋红色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • cyan

        public static final Color cyan
        颜色青色。 在默认的sRGB空间。

      • CYAN

        public static final Color CYAN
        颜色青色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

      • blue

        public static final Color blue
        颜色蓝色。 在默认的sRGB空间。

      • BLUE

        public static final Color BLUE
        颜色蓝色。 在默认的sRGB空间。
        从以下版本开始：
        1.4

    • 构造方法详细信息

      • Color

        public Color​(int r,
             int g,
             int b)
        用范围（0 - 255）范围内的指定的红色，绿色和蓝色值创建不透明的sRGB颜色。 渲染中使用的实际颜色取决于给定给定输出设备可用的颜色空间的最佳匹配。 Alpha默认为255。
        参数
        r - 红色组件
        g - 绿色组件
        b - 蓝色组件
        异常
        IllegalArgumentException -如果 r ， g或 b 0到255以外的范围内的，包括
        另请参见：
        getRed() ，
getGreen() ，
getBlue() ，
getRGB()

      • Color

        @ConstructorProperties({"red","green","blue","alpha"})
public Color​(int r,
             int g,
             int b,
             int a)
        在范围（0 - 255）范围内创建指定的红，绿，蓝和阿尔法值的sRGB颜色。
        参数
        r - 红色组件
        g - 绿色组件
        b - 蓝色组件
        a - alpha组件
        异常
        IllegalArgumentException -如果 r ， g ， b或 a 0到255以外的范围内的，包括
        另请参见：
        getRed() ，
getGreen() ，
getBlue() ，
getAlpha() ，
getRGB()

      • Color

        public Color​(int rgb)
        创建一个不透明的sRGB颜色，其中指定的组合RGB值包括位16-23中的红色分量，位8-15中的绿色分量和位0-7中的蓝色分量。 渲染中使用的实际颜色取决于给定特定输出设备可用的颜色空间的最佳匹配。 Alpha默认为255。
        参数
        rgb - 组合的RGB组件
        另请参见：
        ColorModel.getRGBdefault() ，
getRed() ，
getGreen() ，
getBlue() ，
getRGB()

      • Color

        public Color​(int rgba,
             boolean hasalpha)
        使用指定的组合RGBA值创建sRGB颜色，RGBA值由位24-31中的alpha分量，位16-23中的红色分量，位8-15中的绿色分量和位0-7中的蓝色分量组成。 如果hasalpha参数为false ，则默认为255。
        参数
        rgba - 组合的RGBA组件
        hasalpha - true如果alpha位有效; 否则为false
        另请参见：
        ColorModel.getRGBdefault() ，
getRed() ，
getGreen() ，
getBlue() ，
getAlpha() ，
getRGB()

      • Color

        public Color​(float r,
             float g,
             float b)
        使用范围（0.0 - 1.0）中指定的红色，绿色和蓝色值创建不透明的sRGB颜色。 Alpha默认为1.0。 渲染中使用的实际颜色取决于给定特定输出设备可用的颜色空间的最佳匹配。
        参数
        r - 红色组件
        g - 绿色组件
        b - 蓝色组件
        异常
        IllegalArgumentException -如果 r ， g或 b是0.0〜1.0以外的范围内的，包括
        另请参见：
        getRed() ，
getGreen() ，
getBlue() ，
getRGB()

      • Color

        public Color​(float r,
             float g,
             float b,
             float a)
        用范围（0.0 - 1.0）中指定的红，绿，蓝和阿尔法值创建sRGB颜色。 渲染中使用的实际颜色取决于给定特定输出设备可用的颜色空间的最佳匹配。
        参数
        r - 红色组件
        g - 绿色组件
        b - 蓝色组件
        a - alpha组件
        异常
        IllegalArgumentException -如果 r ， g b或 a是0.0〜1.0的范围以外，含
        另请参见：
        getRed() ，
getGreen() ，
getBlue() ，
getAlpha() ，
getRGB()

      • Color

        public Color​(ColorSpace cspace,
             float[] components,
             float alpha)
        创建指定一个颜色ColorSpace与中指定的颜色分量float阵列和所述指定的alpha。 组件的数量由ColorSpace的类型ColorSpace 。 例如，RGB需要3个组件，但CMYK需要4个组件。
        参数
        cspace - 用于解释组件的 ColorSpace
        components - 与 ColorSpace兼容的任意数量的颜色分量
        alpha - alpha值
        异常
        IllegalArgumentException - 如果 components数组或 alpha中的任何值超出范围0.0到1.0
        另请参见：
        getComponents(float[]) ， getColorComponents(float[])

    • 方法详细信息

      • getRed

        public int getRed​()
        返回默认sRGB空间中0-255范围内的红色分量。
        结果
        红色组件。
        另请参见：
        getRGB()

      • getGreen

        public int getGreen​()
        返回默认sRGB空间中的0-255范围内的绿色组件。
        结果
        绿色组件。
        另请参见：
        getRGB()

      • getBlue

        public int getBlue​()
        返回默认sRGB空间中0-255范围内的蓝色分量。
        结果
        蓝色组件。
        另请参见：
        getRGB()

      • getAlpha

        public int getAlpha​()
        返回0-255范围内的alpha分量。
        结果
        alpha组件。
        另请参见：
        getRGB()

      • getRGB

        public int getRGB​()
        返回表示默认sRGB ColorModel中颜色的RGB值。 （位24-31是alpha，16-23是红色，8-15是绿色，0-7是蓝色）。
        结果
        颜色的RGB值默认为sRGB ColorModel 。
        从以下版本开始：
        1.0
        另请参见：
        ColorModel.getRGBdefault() ，
getRed() ，
getGreen() ，
getBlue()

      • brighter

        public Color brighter​()
        创建一个新的Color这是更加明亮的版本的这个Color 。

        此方法适用于以任意倍率每本的三个RGB分量Color创建此的一个亮的Color 。 保留alpha价值。 虽然brighter和darker是反向操作，但由于舍入误差，这两种方法的一系列调用的结果可能不一致。

        结果
        一个新的 Color对象是这个 Color的更明亮的版本，具有相同的 alpha值。
        从以下版本开始：
        1.0
        另请参见：
        darker()

      • darker

        public Color darker​()
        创建一个新的Color这是一个较深的版本的这个Color 。

        此方法适用于任意的比例因子到每个这种的三个RGB分量Color创建此的较暗的版本Color 。 保留alpha价值。 虽然brighter和darker是反向操作，但由于舍入误差，这两种方法的一系列调用的结果可能不一致。

        结果
        一个新的 Color对象，这是一个较深的版本，这个 Color具有相同的 alpha值。
        从以下版本开始：
        1.0
        另请参见：
        brighter()

      • hashCode

        public int hashCode​()
        计算这个 Color的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.0
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        确定另一个对象是否等于此Color 。

        结果是true当且仅当参数不是null并且是一个Color对象具有与此对象相同的红色，绿色，蓝色和alpha值。

        重写：
        equals在 Object
        参数
        obj - 要测试与 Color相等的对象
        结果
        true如果对象是相同的; 否则为false 。
        从以下版本开始：
        1.0
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回此Color的字符串表示Color 。 该方法仅用于调试目的。 返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但不能为null 。
        重写：
        toString在 Object
        结果
        这个 Color的字符串表示 Color 。

      • decode

        public static Color decode​(String nm)
                    throws NumberFormatException
        将String转换为整数，并返回指定的不透明度Color 。 此方法处理用于表示八进制和十六进制数字的字符串格式。
        参数
        nm - 表示不透明颜色为24位整数的 String
        结果
        新的 Color对象。
        异常
        NumberFormatException - 如果指定的字符串不能被解释为十进制，八进制或十六进制整数。
        从以下版本开始：
        1.1
        另请参见：
        Integer.decode(java.lang.String)

      • getColor

        public static Color getColor​(String nm)
        在系统属性中查找颜色。

        该参数被视为要获取的系统属性的名称。 然后将此属性的字符串值解释为整数，然后将其转换为Color对象。

        如果未找到指定的属性或无法将其解析为整数，则返回null 。

        参数
        nm - 颜色属性的名称
        结果
        从系统属性转换 Color 。
        从以下版本开始：
        1.0
        另请参见：
        System.getProperty(java.lang.String) ，
Integer.getInteger(java.lang.String) ，
Color(int)

      • getColor

        public static Color getColor​(String nm,
                             Color v)
        在系统属性中查找颜色。

        第一个参数被视为要获取的系统属性的名称。 然后将此属性的字符串值解释为整数，然后将其转换为Color对象。

        如果未找到指定的属性或不能将其解析为整数， Color返回由第二个参数指定的Color 。

        参数
        nm - 颜色属性的名称
        v - 默认 Color
        结果
        Color从系统属性转换，或指定 Color 。
        从以下版本开始：
        1.0
        另请参见：
        System.getProperty(java.lang.String) ，
Integer.getInteger(java.lang.String) ，
Color(int)

      • getColor

        public static Color getColor​(String nm,
                             int v)
        在系统属性中查找颜色。

        第一个参数被视为要获取的系统属性的名称。 然后将此属性的字符串值解释为整数，然后将其转换为Color对象。

        如果未找到指定的属性或不能将其解析为整数，则使用整数值v ，并将其转换为Color对象。

        参数
        nm - 颜色属性的名称
        v - 默认颜色值，为整数
        结果
        所述 Color从系统属性转换或 Color从指定的整数转换。
        从以下版本开始：
        1.0
        另请参见：
        System.getProperty(java.lang.String) ，
Integer.getInteger(java.lang.String) ，
Color(int)

      • HSBtoRGB

        public static int HSBtoRGB​(float hue,
                           float saturation,
                           float brightness)
        将HSB模型指定的颜色组件转换为默认RGB模型的等效值。

        saturation和brightness组件应为零和一之间的浮点值（数字范围为0.0-1.0）。 hue组件可以是任意浮点数。 从该数字中减去该数字的底数以创建0到1之间的分数。然后将该分数乘以360，以在HSB颜色模型中产生色调角。

        由HSBtoRGB返回的整数对与方法getRGB使用的格式相同的整数值的位0-23的颜色的值进行编码。 该整数可以作为一个参数提供给Color构造函数，该构造函数需要一个整数参数。

        参数
        hue - 颜色的色调分量
        saturation - 颜色的饱和度
        brightness - 颜色的亮度
        结果
        具有指示色调，饱和度和亮度的颜色的RGB值。
        从以下版本开始：
        1.0
        另请参见：
        getRGB() ， Color(int) ， ColorModel.getRGBdefault()

      • RGBtoHSB

        public static float[] RGBtoHSB​(int r,
                               int g,
                               int b,
                               float[] hsbvals)
        将默认RGB模型指定的颜色组件转换为HSB模型的三个组件的色相，饱和度和亮度的等效值。

        如果hsbvals参数为null ，则会分配一个新数组以返回结果。 否则，该方法返回数组hsbvals ，其值放入该数组。

        参数
        r - 颜色的红色成分
        g - 颜色的绿色成分
        b - 颜色的蓝色成分
        hsbvals - 用于返回三个HSB值的数组，或 null
        结果
        具有指示的红色，绿色和蓝色分量的颜色的三个元素的阵列，其中包含色调，饱和度和亮度（按顺序）。
        从以下版本开始：
        1.0
        另请参见：
        getRGB() ， Color(int) ， ColorModel.getRGBdefault()

      • getHSBColor

        public static Color getHSBColor​(float h,
                                float s,
                                float b)
        基于HSB颜色模型的指定值创建Color对象。

        s和b组件应为零和一之间的浮点值（数字范围为0.0-1.0）。 h组件可以是任意浮点数。 从该数字中减去该数字的底数以创建0到1之间的分数。然后将该分数乘以360，以在HSB颜色模型中产生色调角。

        参数
        h - 色相组件
        s - 颜色的饱和度
        b - 颜色的亮度
        结果
        具有指定色调，饱和度和亮度的 Color对象。
        从以下版本开始：
        1.0

      • getRGBComponents

        public float[] getRGBComponents​(float[] compArray)
        返回一个包含float的颜色和alpha组件的Color ，如默认sRGB颜色空间所示。 如果compArray为null ，则为返回值创建一个长度为4的数组。 否则， compArray必须具有4或更大的长度，并且它被填充到组件并返回。
        参数
        compArray - 这个方法填充颜色和alpha组件并返回的数组
        结果
        一个 float阵列中的RGBA组件。

      • getRGBColorComponents

        public float[] getRGBColorComponents​(float[] compArray)
        返回一个float阵列只包含的颜色分量Color ，在默认的sRGB色彩空间。 如果compArray为null ，则为返回值创建长度为3的数组。 否则， compArray必须具有3或更大的长度，并且它被填充到组件并返回。
        参数
        compArray - 此方法填充颜色分量并返回的数组
        结果
        一个 float阵列中的RGB组件。

      • getComponents

        public float[] getComponents​(float[] compArray)
        返回一个包含float的颜色和alpha分量的Color ，在ColorSpace的Color 。 如果compArray为null ，则为返回值创建一个长度等于相关ColorSpace加上一个组件数的数组。 否则， compArray必须至少具有此长度，并填充组件并返回。
        参数
        compArray - 一个数组，该方法填充了该 Color的颜色和alpha分量，其 ColorSpace并返回
        结果
        一个 float阵列中的颜色和alpha组件。

      • getColorComponents

        public float[] getColorComponents​(float[] compArray)
        返回一个float阵列只包含的颜色分量Color ，在ColorSpace的的Color 。 如果compArray为null ， ColorSpace返回值创建长度等于相关ColorSpace中组件数的数组。 否则， compArray必须至少有这个长度，并且它被填充到组件并返回。
        参数
        compArray - 该方法填充了其 Color中的 ColorSpace的颜色分量的数组，并返回
        结果
        颜色分量在 float阵列中。

      • getComponents

        public float[] getComponents​(ColorSpace cspace,
                             float[] compArray)
        返回一个包含float的颜色和alpha分量的Color ，由ColorSpace指定的cspace参数。 如果compArray为null ，则为返回值创建长度等于cspace的组件数的数组。 否则， compArray必须至少有这个长度，并且它被填充到组件并返回。
        参数
        cspace - 一个指定的 ColorSpace
        compArray -此方法与此的颜色和alpha分量填充数组 Color在指定 ColorSpace并返回
        结果
        一个 float阵列中的颜色和alpha组件。

      • getColorComponents

        public float[] getColorComponents​(ColorSpace cspace,
                                  float[] compArray)
        返回一个float数组，仅包含由cspace参数指定的Color中的ColorSpace的颜色分量。 如果compArray为null ， cspace返回值创建长度等于cspace中组件数的数组。 否则， compArray必须至少具有这个长度，并且它被填充到组件并返回。
        参数
        cspace - 一个指定的 ColorSpace
        compArray - 一个数组，该方法填充了这个 Color的颜色分量，在指定的 ColorSpace
        结果
        颜色分量在 float阵列中。

      • getColorSpace

        public ColorSpace getColorSpace​()
        返回这 ColorSpace的 Color 。
        结果
        这 Color对象的 ColorSpace 。

      • createContext

        public PaintContext createContext​(ColorModel cm,
                                  Rectangle r,
                                  Rectangle2D r2d,
                                  AffineTransform xform,
                                  RenderingHints hints)
        创建并返回一个用于生成纯色字段模式的PaintContext 。 见specification方法在Paint界面上的空参数处理信息。
        Specified by:
        createContext在接口 Paint
        参数
        cm - 首选的ColorModel ，表示呼叫者接收像素数据的最方便的格式，如果没有偏好，则表示null 。
        r - 正在渲染的图形基元的设备空间边界框。
        r2d - 呈现的图形基元的用户空间边界框。
        xform - 从用户空间到设备空间的AffineTransform 。
        hints - 上下文对象可用于在呈现替代方案之间进行选择的一组提示。
        结果
        用于生成颜色图案的 PaintContext 。
        另请参见：
        Paint ， PaintContext ， ColorModel ， Rectangle ， Rectangle2D ， AffineTransform ， RenderingHints

      • getTransparency

        public int getTransparency​()
        返回此Color的透明度模式。 这是实现Paint接口所必需的。
        Specified by:
        getTransparency在接口 Transparency
        结果
        这个 Color对象的透明度模式。
        另请参见：
        Paint, Transparency, createContext(java.awt.image.ColorModel, java.awt.Rectangle, java.awt.geom.Rectangle2D, java.awt.geom.AffineTransform, java.awt.RenderingHints)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Component (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Component

  • java.lang.Object
    • java.awt.Component
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable
    已知直接子类：
    Button ， Canvas ， Checkbox ， Choice ， Container ， Label ， List ， Scrollbar ， TextComponent

    public abstract class Component
extends Object
implements ImageObserver, MenuContainer, Serializable
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。 组件的示例是典型图形用户界面的按钮，复选框和滚动条。

    Component类是与非菜单相关的抽象窗口工具包组件的抽象超类。 Component也可以直接扩展来创建一个轻量级的组件。 轻量级组件是与本机窗口无关的组件。 相反，重量级组件与本机窗口相关联。 可以使用isLightweight()方法区分两种组件。

    轻量级和重型组件可以在单个组件层次结构中混合。 然而，为了正确操作这种混合层次结构的组件，整个层次结构必须是有效的。 当层次结构变得无效时，就像在更改组件的边界，或者向/从容器添加/删除组件之后，必须通过在层次结构的最上层的无效容器上调用的Container.validate()方法验证整个层次结构。

    序列化

    重要的是要注意，只有存储符合Serializable协议的AWT听众才能保存对象。 如果AWT对象具有未标记为可串行化的侦听器，则它们将被丢弃为writeObject 。 开发人员将一如既往地需要考虑使对象可序列化的含义。 一个值得注意的情况是这样的：
      import java.awt.*;
    import java.awt.event.*;
    import java.io.Serializable;

    class MyApp implements ActionListener, Serializable
    {
        BigObjectThatShouldNotBeSerializedWithAButton bigOne;
        Button aButton = new Button();

        MyApp()
        {
            // Oops, now aButton has a listener with a reference
            // to bigOne!
            aButton.addActionListener(this);
        }

        public void actionPerformed(ActionEvent e)
        {
            System.out.println("Hello There");
        }
    }
    在这个例子中，序列化aButton本身将导致MyApp和它所指向的序列化一切。 问题是听众可以按照巧合序列化，而不是设计。 为了分离关于MyApp和ActionListener的决定是可序列化的，可以使用嵌套类，如以下示例所示：
      import java.awt.*;
    import java.awt.event.*;
    import java.io.Serializable;

    class MyApp implements java.io.Serializable
    {
         BigObjectThatShouldNotBeSerializedWithAButton bigOne;
         Button aButton = new Button();

         static class MyActionListener implements ActionListener
         {
             public void actionPerformed(ActionEvent e)
             {
                 System.out.println("Hello There");
             }
         }

         MyApp()
         {
             aButton.addActionListener(new MyActionListener());
         }
    }

    注意 ：有关AWT和Swing使用的油漆机制的更多信息，包括如何编写最有效的油漆代码的信息，请参阅Painting in AWT and Swing 。

    有关焦点子系统的详细信息，请参阅How to Use the Focus Subsystem ，在Java教程一节，以及Focus Specification获取更多信息。

    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Component.AccessibleAWTComponent
      组件的内部类用于为辅助功能提供默认支持。
      static class  Component.BaselineResizeBehavior
      枚举组件的基准线随着大小变化而改变的常见方式。
      protected class  Component.BltBufferStrategy
      内部类别将屏幕外表面喷涂到组件上。
      protected class  Component.FlipBufferStrategy
      内部类用于在组件上翻转缓冲区。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected AccessibleContext accessibleContext
      该 AccessibleContext与此 Component相关联。
      static float BOTTOM_ALIGNMENT
      易于使用的常数为 getAlignmentY 。
      static float CENTER_ALIGNMENT
      易于使用的常数为 getAlignmentY和 getAlignmentX 。
      static float LEFT_ALIGNMENT
      易于使用的常数为 getAlignmentX 。
      static float RIGHT_ALIGNMENT
      易于使用的常数为 getAlignmentX 。
      static float TOP_ALIGNMENT
      易于使用的常数为 getAlignmentY() 。

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Component​()
      构造一个新的组件。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type | 方法 | 描述
      boolean action​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，应该在组件上注册此组件作为ActionListener，该组件将触发动作事件。
      void add​(PopupMenu popup)
      将指定的弹出菜单添加到组件。
      void addComponentListener​(ComponentListener l)
      添加指定的组件侦听器以从该组件接收组件事件。
      void addFocusListener​(FocusListener l)
      当该组件获得输入焦点时，添加指定的焦点侦听器以从该组件接收焦点事件。
      void addHierarchyBoundsListener​(HierarchyBoundsListener l)
      添加指定的层次结构边界侦听器以在此容器所属的层次结构更改时从此组件接收层次结构边界事件。
      void addHierarchyListener​(HierarchyListener l)
      添加指定的层次监听器，以便在此容器所属的层次结构更改时从此组件接收层次结构更改的事件。
      void addInputMethodListener​(InputMethodListener l)
      添加指定的输入法侦听器以从该组件接收输入法事件。
      void addKeyListener​(KeyListener l)
      添加指定的密钥侦听器以从该组件接收密钥事件。
      void addMouseListener​(MouseListener l)
      添加指定的鼠标监听器以从该组件接收鼠标事件。
      void addMouseMotionListener​(MouseMotionListener l)
      添加指定的鼠标移动侦听器以从该组件接收鼠标移动事件。
      void addMouseWheelListener​(MouseWheelListener l)
      添加指定的鼠标滚轮侦听器以从该组件接收鼠标滚轮事件。
      void addNotify​()
      将此 Component连接到本机屏幕资源。
      void addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void applyComponentOrientation​(ComponentOrientation orientation)
      设置此组件的 ComponentOrientation属性及其中包含的所有组件。
      boolean areFocusTraversalKeysSet​(int id)
      返回是否为此组件显式定义了给定焦点遍历操作的聚焦遍历键集。
      Rectangle bounds​()
      已过时。
      从JDK 1.1版开始，由getBounds()代替。
      int checkImage​(Image image, int width, int height, ImageObserver observer)
      返回构造指定图像的屏幕表示的状态。
      int checkImage​(Image image, ImageObserver observer)
      返回构造指定图像的屏幕表示的状态。
      protected AWTEvent coalesceEvents​(AWTEvent existingEvent, AWTEvent newEvent)
      潜在地合并现有事件发布的事件。
      boolean contains​(int x, int y)
      检查此组件是否“包含”指定点，其中 x和 y被定义为相对于该组件的坐标系。
      boolean contains​(Point p)
      检查此组件是否“包含”指定点，其中点的 x和 y坐标被定义为相对于该组件的坐标系。
      Image createImage​(int width, int height)
      创建一个用于双缓冲的屏幕外可绘图像。
      Image createImage​(ImageProducer producer)
      从指定的图像制作者创建图像。
      VolatileImage createVolatileImage​(int width, int height)
      创建一个用于双缓冲的易失性的屏幕外可绘图像。
      VolatileImage createVolatileImage​(int width, int height, ImageCapabilities caps)
      使用给定的功能创建一个易失的屏幕外可绘制图像。
      void deliverEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代。
      void disable​()
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替换。
      protected void disableEvents​(long eventsToDisable)
      禁用由指定事件掩码参数定义的事件传递给此组件。
      void dispatchEvent​(AWTEvent e)
      将事件分派到此组件或其一个子组件。
      void doLayout​()
      提示布局管理器布局此组件。
      void enable​()
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      void enable​(boolean b)
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)代替。
      protected void enableEvents​(long eventsToEnable)
      启用由指定的事件掩码参数定义的事件传递给此组件。
      void enableInputMethods​(boolean enable)
      启用或禁用此组件的输入法支持。
      protected void firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)
      支持报告布尔属性的绑定属性更改。
      void firePropertyChange​(String propertyName, byte oldValue, byte newValue)
      报告绑定属性更改。
      void firePropertyChange​(String propertyName, char oldValue, char newValue)
      报告绑定属性更改。
      void firePropertyChange​(String propertyName, double oldValue, double newValue)
      报告绑定属性更改。
      void firePropertyChange​(String propertyName, float oldValue, float newValue)
      报告绑定属性更改。
      protected void firePropertyChange​(String propertyName, int oldValue, int newValue)
      支持报告整数属性的绑定属性更改。
      void firePropertyChange​(String propertyName, long oldValue, long newValue)
      报告绑定属性更改。
      void firePropertyChange​(String propertyName, short oldValue, short newValue)
      报告绑定属性更改。
      protected void firePropertyChange​(String propertyName, Object oldValue, Object newValue)
      支持报告对象属性的绑定属性更改。
      AccessibleContext getAccessibleContext​()
      获取 AccessibleContext与此 Component相关联。
      float getAlignmentX​()
      返回沿x轴的对齐方式。
      float getAlignmentY​()
      返回沿着y轴的对齐。
      Color getBackground​()
      获取此组件的背景颜色。
      int getBaseline​(int width, int height)
      返回基线。
      Component.BaselineResizeBehavior getBaselineResizeBehavior​()
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Rectangle getBounds​()
      以 Rectangle对象的形式获取此组件的边界。
      Rectangle getBounds​(Rectangle rv)
      将此组件的边界存储到“返回值” rv并返回 rv 。
      ColorModel getColorModel​()
      获取用于在输出设备上显示组件的 ColorModel实例。
      Component getComponentAt​(int x, int y)
      确定此组件或其一个直接子组件是否包含（ x ， y ）位置，如果是，则返回包含的组件。
      Component getComponentAt​(Point p)
      返回包含指定点的组件或子组件。
      ComponentListener[] getComponentListeners​()
      返回在此组件上注册的所有组件侦听器的数组。
      ComponentOrientation getComponentOrientation​()
      检索用于对该组件中的元素或文本进行排序的语言敏感方向。
      Cursor getCursor​()
      获取组件中的光标集。
      DropTarget getDropTarget​()
      获取 DropTarget与此 Component相关联。
      Container getFocusCycleRootAncestor​()
      返回作为该组件焦点遍历循环的焦点循环根的容器。
      FocusListener[] getFocusListeners​()
      返回在此组件上注册的所有焦点侦听器的数组。
      Set<AWTKeyStroke> getFocusTraversalKeys​(int id)
      返回此组件的给定遍历操作的聚焦遍历键集。
      boolean getFocusTraversalKeysEnabled​()
      返回是否为此组件启用焦点遍历键。
      Font getFont​()
      获取此组件的字体。
      FontMetrics getFontMetrics​(Font font)
      获取指定字体的字体指标。
      Color getForeground​()
      获取此组件的前景色。
      Graphics getGraphics​()
      为此组件创建图形上下文。
      GraphicsConfiguration getGraphicsConfiguration​()
      获取 GraphicsConfiguration与此 Component相关联。
      int getHeight​()
      返回此组件的当前高度。
      HierarchyBoundsListener[] getHierarchyBoundsListeners​()
      返回在此组件上注册的所有层次结构边界侦听器的数组。
      HierarchyListener[] getHierarchyListeners​()
      返回在此组件上注册的所有层级监听器的数组。
      boolean | getIgnoreRepaint​()
      InputContext getInputContext​()
      获取此组件使用的输入上下文，以便在此组件中输入文本时处理与输入法的通信。
      InputMethodListener[] getInputMethodListeners​()
      返回在此组件上注册的所有输入法侦听器的数组。
      InputMethodRequests getInputMethodRequests​()
      获取支持该组件输入法的请求的输入法请求处理程序。
      KeyListener[] getKeyListeners​()
      返回在此组件上注册的所有关键侦听器的数组。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，这个 Component 。
      Locale getLocale​()
      获取此组件的区域设置。
      Point getLocation​()
      以指定组件左上角的点的形式获取此组件的位置。
      Point getLocation​(Point rv)
      将该组件的x，y原点存储到“返回值” rv并返回 rv 。
      Point getLocationOnScreen​()
      以指定组件左上角的点的形式获取此组件的位置。
      Dimension getMaximumSize​()
      获取此组件的最大大小。
      Dimension getMinimumSize​()
      获取此组件的最小大小。
      MouseListener[] getMouseListeners​()
      返回在此组件上注册的所有鼠标监听器的数组。
      MouseMotionListener[] getMouseMotionListeners​()
      返回在此组件上注册的所有鼠标移动侦听器的数组。
      Point getMousePosition​()
      如果 Component直接位于鼠标指针下，则返回鼠标指针在 Component的坐标空间中的位置，否则返回 null 。
      MouseWheelListener[] getMouseWheelListeners​()
      返回在此组件上注册的所有鼠标滚轮侦听器的数组。
      String getName​()
      获取组件的名称。
      Container getParent​()
      获取此组件的父级。
      Dimension getPreferredSize​()
      获取此组件的首选大小。
      PropertyChangeListener[] getPropertyChangeListeners​()
      返回在此组件上注册的所有属性更改侦听器的数组。
      PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      Dimension getSize​()
      以 Dimension对象的形式返回此组件的大小。
      Dimension getSize​(Dimension rv)
      将该组件的宽度/高度存储到“返回值” rv并返回 rv 。
      Toolkit getToolkit​()
      获取此组件的工具包。
      Object getTreeLock​()
      获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。
      int getWidth​()
      返回此组件的当前宽度。
      int getX​()
      返回组件原点的当前x坐标。
      int getY​()
      返回组件原点的当前y坐标。
      boolean gotFocus​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
      boolean handleEvent​(Event evt)
      已过时。
      从JDK版本1.1替换为processEvent（AWTEvent）。
      boolean hasFocus​()
      如果这个 Component是焦点所有者，则返回 true 。
      void hide​()
      已过时。
      从JDK 1.1版开始，替换为setVisible(boolean) 。
      boolean imageUpdate​(Image img, int infoflags, int x, int y, int w, int h)
      当图像发生变化时重新编辑组件。
      boolean inside​(int x, int y)
      已过时。
      从JDK 1.1版开始，由contains（int，int）替换。
      void invalidate​()
      无效此组件及其祖先。
      boolean isBackgroundSet​()
      返回是否为此组件显式设置了背景颜色。
      boolean isCursorSet​()
      返回是否已经为此组件显式设置了游标。
      boolean isDisplayable​()
      确定此组件是否可显示。
      boolean isDoubleBuffered​()
      如果此组件被绘制到稍后复制到屏幕的屏幕外图像（“缓冲区”），则返回true。
      boolean isEnabled​()
      确定是否启用此组件。
      boolean isFocusable​()
      返回是否可以对该Component进行聚焦。
      boolean isFocusCycleRoot​(Container container)
      返回指定的Container是否是此组件焦点遍历周期的焦点循环根。
      boolean isFocusOwner​()
      如果这个 Component是焦点所有者，则返回 true 。
      boolean isFocusTraversable​()
      已过时。
      截至1.4，由isFocusable()替代。
      boolean isFontSet​()
      返回是否已经为此组件显式设置了字体。
      boolean isForegroundSet​()
      返回是否为此组件显式设置了前景色。
      boolean isLightweight​()
      轻量级组件没有本机工具包对等体。
      boolean isMaximumSizeSet​()
      如果最大大小设置为非 null值，则返回true，否则返回false。
      boolean isMinimumSizeSet​()
      返回是否使用非空值调用了 setMinimumSize 。
      boolean isOpaque​()
      如果此组件完全不透明，则返回true，默认情况下返回false。
      boolean isPreferredSizeSet​()
      如果首选大小设置为非 null值，则返回true，否则返回false。
      boolean isShowing​()
      确定此组件是否在屏幕上显示。
      boolean isValid​()
      确定此组件是否有效。
      boolean isVisible​()
      确定当该组件的父级可见时是否应该可见。
      boolean keyDown​(Event evt, int key)
      已过时。
      从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
      boolean keyUp​(Event evt, int key)
      已过时。
      从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
      void layout​()
      已过时。
      从JDK 1.1版开始，由doLayout()替换。
      void list​()
      将该组件的列表打印到标准系统输出流 System.out 。
      void list​(PrintStream out)
      将此组件的列表打印到指定的输出流。
      void list​(PrintStream out, int indent)
      从指定的缩进开始列出指定的打印流的列表。
      void list​(PrintWriter out)
      将列表打印到指定的打印作者。
      void list​(PrintWriter out, int indent)
      从指定的缩进开始列出指定的打印作者的列表。
      Component locate​(int x, int y)
      已过时。
      从JDK 1.1版开始，由getComponentAt（int，int）替换。
      Point location​()
      已过时。
      从JDK 1.1版开始，由getLocation()替代。
      boolean lostFocus​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
      Dimension minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      boolean mouseDown​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean mouseDrag​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
      boolean mouseEnter​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean mouseExit​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean mouseMove​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
      boolean mouseUp​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      void move​(int x, int y)
      已过时。
      从JDK 1.1版开始，由setLocation(int, int)替代。
      void nextFocus​()
      已过时。
      从JDK 1.1版开始，由transferFocus（）替换。
      void paint​(Graphics g)
      涂抹这个组件。
      void paintAll​(Graphics g)
      绘制此组件及其所有子组件。
      protected String paramString​()
      返回表示此组件状态的字符串。
      boolean postEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent（AWTEvent）替换。
      Dimension preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()代替。
      boolean prepareImage​(Image image, int width, int height, ImageObserver observer)
      准备一个图像，以指定的宽度和高度在此组件上渲染。
      boolean prepareImage​(Image image, ImageObserver observer)
      准备用于在此组件上呈现的图像。
      void print​(Graphics g)
      打印此组件。
      void printAll​(Graphics g)
      打印此组件及其所有子组件。
      protected void processComponentEvent​(ComponentEvent e)
      通过将组件事件发送到任何已注册的 ComponentListener对象来处理此组件上发生的组件事件。
      protected void processEvent​(AWTEvent e)
      处理在此组件上发生的事件。
      protected void processFocusEvent​(FocusEvent e)
      通过将这些事件发送到任何已注册的 FocusListener对象来处理发生在该组件上的焦点事件。
      protected void processHierarchyBoundsEvent​(HierarchyEvent e)
      进程层次结构通过将这些事件发送到任何已注册的 HierarchyBoundsListener对象来限制发生在该组件上的事件。
      protected void processHierarchyEvent​(HierarchyEvent e)
      通过将此组件分派到任何已注册的 HierarchyListener对象来处理发生在此组件上的层次结构事件。
      protected void processInputMethodEvent​(InputMethodEvent e)
      处理由他们指派到任何注册组件上发生的输入方法事件 InputMethodListener对象。
      protected void processKeyEvent​(KeyEvent e)
      通过将这些事件发送到任何已注册的 KeyListener对象来处理在此组件上发生的关键事件。
      protected void processMouseEvent​(MouseEvent e)
      通过将其分配到任何已注册的 MouseListener对象来处理在此组件上发生的鼠标事件。
      protected void processMouseMotionEvent​(MouseEvent e)
      通过将这些组件调度到任何已注册的 MouseMotionListener对象来处理在此组件上发生的鼠标移动事件。
      protected void processMouseWheelEvent​(MouseWheelEvent e)
      通过将鼠标滚轮事件发送到任何已注册的 MouseWheelListener对象来处理鼠标滚轮事件。
      void remove​(MenuComponent popup)
      从组件中删除指定的弹出菜单。
      void removeComponentListener​(ComponentListener l)
      删除指定的组件侦听器，使其不再从此组件接收组件事件。
      void removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void removeHierarchyBoundsListener​(HierarchyBoundsListener l)
      删除指定的层次结构边界监听器，使其不再从此组件接收层次结构限制事件。
      void removeHierarchyListener​(HierarchyListener l)
      删除指定的层次监听器，使其不再从此组件接收层次结构更改的事件。
      void removeInputMethodListener​(InputMethodListener l)
      删除指定的输入法侦听器，使其不再从此组件接收输入法事件。
      void removeKeyListener​(KeyListener l)
      删除指定的密钥侦听器，使其不再从此组件接收密钥事件。
      void removeMouseListener​(MouseListener l)
      删除指定的鼠标监听器，使其不再从此组件接收鼠标事件。
      void removeMouseMotionListener​(MouseMotionListener l)
      删除指定的鼠标移动侦听器，使其不再从此组件接收鼠标移动事件。
      void removeMouseWheelListener​(MouseWheelListener l)
      删除指定的鼠标滚轮侦听器，使其不再从此组件接收鼠标滚轮事件。
      void removeNotify​()
      使这个 Component通过破坏它的本机屏幕资源不可显示。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
      void removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      从侦听器列表中删除特定属性的 PropertyChangeListener 。
      void repaint​()
      重新编辑这个组件。
      void repaint​(int x, int y, int width, int height)
      重新绘制该组件的指定矩形。
      void repaint​(long tm)
      重写组件。
      void repaint​(long tm, int x, int y, int width, int height)
      在 tm毫秒内重新绘制该组件的指定矩形。
      void requestFocus​()
      请求此组件获取输入焦点，并且该组件的顶级祖先成为关注的窗口。
      protected boolean requestFocus​(boolean temporary)
      要求这个 Component得到输入焦点，而这个 Component的顶级祖先成为焦点 Window 。
      protected boolean requestFocus​(boolean temporary, FocusEvent.Cause cause)
      由于 cause ，这个 Component得到了输入焦点，而这个 Component的顶级祖先成为焦点 Window 。
      void requestFocus​(FocusEvent.Cause cause)
      请求由 cause这个组件获得输入焦点，并且该组件的顶级祖先成为关注的窗口。
      boolean requestFocusInWindow​()
      要求此组件获取输入焦点，如果此组件的顶级祖先已经是关注的窗口。
      protected boolean requestFocusInWindow​(boolean temporary)
      要求这个 Component得到输入的焦点，如果这个 Component的顶级祖先已经是焦点 Window 。
      boolean requestFocusInWindow​(FocusEvent.Cause cause)
      由于 cause ，该组件获取输入焦点，如果此组件的顶级祖先已经是关注的窗口。
      void reshape​(int x, int y, int width, int height)
      已过时。
      从JDK 1.1版开始，替换为setBounds(int, int, int, int) 。
      void resize​(int width, int height)
      已过时。
      从JDK 1.1版开始，由setSize(int, int)替代。
      void resize​(Dimension d)
      已过时。
      从JDK 1.1版开始，由setSize(Dimension)取代。
      void revalidate​()
      将组件层次结构重新验证为最接近的验证根。
      void setBackground​(Color c)
      设置此组件的背景颜色。
      void setBounds​(int x, int y, int width, int height)
      移动并调整此组件的大小。
      void setBounds​(Rectangle r)
      移动并调整此组件的大小以符合新的边界矩形 r 。
      void setComponentOrientation​(ComponentOrientation o)
      设置用于对该组件中的元素或文本进行排序的语言敏感方向。
      void setCursor​(Cursor cursor)
      将光标图像设置为指定的光标。
      void setDropTarget​(DropTarget dt)
      关联一个 DropTarget与此组件。
      void setEnabled​(boolean b)
      根据参数 b的值启用或禁用此组件。
      void setFocusable​(boolean focusable)
      将此组件的可聚焦状态设置为指定的值。
      void setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此组件给定遍历操作的焦点遍历键。
      void setFocusTraversalKeysEnabled​(boolean focusTraversalKeysEnabled)
      设置是否为此组件启用对焦遍历键。
      void setFont​(Font f)
      设置此组件的字体。
      void setForeground​(Color c)
      设置此组件的前景颜色。
      void setIgnoreRepaint​(boolean ignoreRepaint)
      设置是否忽略从操作系统接收的画面消息。
      void setLocale​(Locale l)
      设置此组件的区域设置。
      void setLocation​(int x, int y)
      将此组件移动到新位置。
      void setLocation​(Point p)
      将此组件移动到新位置。
      void setMaximumSize​(Dimension maximumSize)
      将此组件的最大大小设置为常量值。
      void setMinimumSize​(Dimension minimumSize)
      将此组件的最小大小设置为常量值。
      void setMixingCutoutShape​(Shape shape)
      为此轻型组件设置“混合切割”形状。
      void setName​(String name)
      将组件的名称设置为指定的字符串。
      void setPreferredSize​(Dimension preferredSize)
      将此组件的首选大小设置为常量值。
      void setSize​(int width, int height)
      调整此组件的大小，使其具有宽度 width和高度 height 。
      void setSize​(Dimension d)
      调整此组件的大小，使其宽度为 d.width ，高度为 d.height 。
      void setVisible​(boolean b)
      根据参数 b的值显示或隐藏此组件。
      void show​()
      已过时。
      从JDK 1.1版开始，由setVisible(boolean)取代。
      void show​(boolean b)
      已过时。
      从JDK 1.1版开始，由setVisible(boolean)代替。
      Dimension size​()
      已过时。
      从JDK 1.1版开始，由getSize()代替。
      String toString​()
      返回此组件及其值的字符串表示形式。
      void transferFocus​()
      将焦点转移到下一个组件，就像这个组件是焦点所有者一样。
      void transferFocusBackward​()
      将焦点转移到以前的组件，就像这个组件是焦点所有者一样。
      void transferFocusUpCycle​()
      将焦点转移到一个焦点遍历周期。
      void update​(Graphics g)
      更新此组件。
      void validate​()
      验证此组件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TOP_ALIGNMENT

        public static final float TOP_ALIGNMENT
        易于使用的常数为getAlignmentY() 。 指定与组件顶部的对齐方式。
        另请参见：
        getAlignmentY() ， Constant Field Values

      • CENTER_ALIGNMENT

        public static final float CENTER_ALIGNMENT
        易于使用的常数为getAlignmentY和getAlignmentX 。 指定与组件中心的对齐方式
        另请参见：
        getAlignmentX() ， getAlignmentY() ， Constant Field Values

      • BOTTOM_ALIGNMENT

        public static final float BOTTOM_ALIGNMENT
        易于使用的常数为getAlignmentY 。 指定与组件底部的对齐方式。
        另请参见：
        getAlignmentY() ， Constant Field Values

      • LEFT_ALIGNMENT

        public static final float LEFT_ALIGNMENT
        易于使用的常数为getAlignmentX 。 指定组件左侧的对齐方式。
        另请参见：
        getAlignmentX() ， Constant Field Values

      • RIGHT_ALIGNMENT

        public static final float RIGHT_ALIGNMENT
        易于使用的常数为getAlignmentX 。 指定组件右侧的对齐方式。
        另请参见：
        getAlignmentX() ， Constant Field Values

      • accessibleContext

        protected AccessibleContext accessibleContext
        该 AccessibleContext与此 Component相关联。

    • 构造方法详细信息

      • Component

        protected Component​()
        构造一个新的组件。 可以直接扩展Component类，以创建不使用不透明的本机窗口的轻量级组件。 轻量级组件必须由组件树中较高的某个本地容器托管（例如，由Frame对象）。

    • 方法详细信息

      • getName

        public String getName​()
        获取组件的名称。
        结果
        这个组件的名字
        从以下版本开始：
        1.1
        另请参见：
        setName(java.lang.String)

      • setName

        public void setName​(String name)
        将组件的名称设置为指定的字符串。
        参数
        name - 作为此组件名称的字符串
        从以下版本开始：
        1.1
        另请参见：
        getName()

      • getParent

        public Container getParent​()
        获取此组件的父级。
        结果
        这个组件的父容器
        从以下版本开始：
        1.0

      • setDropTarget

        public void setDropTarget​(DropTarget dt)
        将一个DropTarget与此组件关联。 Component只有在启用时才会接收到丢弃。
        参数
        dt - DropTarget
        另请参见：
        isEnabled()

      • getDropTarget

        public DropTarget getDropTarget​()
        获取 DropTarget与此 Component相关联。
        结果
        下降目标

      • getGraphicsConfiguration

        public GraphicsConfiguration getGraphicsConfiguration​()
        获取GraphicsConfiguration与此Component相关联。 如果Component尚未分配特定GraphicsConfiguration ，该GraphicsConfiguration的的Component对象的顶级容器返回。 如果已创建Component ，但尚未添加到Container ，此方法返回null 。
        结果
        所述 GraphicsConfiguration此使用 Component或 null
        从以下版本开始：
        1.3

      • getTreeLock

        public final Object getTreeLock​()
        获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。
        结果
        这个组件的锁定对象

      • getToolkit

        public Toolkit getToolkit​()
        获取此组件的工具包。 请注意，包含组件的框架控制该组件使用哪个工具包。 因此，如果组件从一个框架移动到另一个框架，则它使用的工具包可能会更改。
        结果
        该组件的工具包
        从以下版本开始：
        1.0

      • isValid

        public boolean isValid​()
        确定此组件是否有效。 组件在其父容器中的大小和位置都正确并且其所有子项也是有效的时候是有效的。 为了解决对等体的大小要求，组件在首次显示在屏幕上之前无效。 当父容器完全实现时，其所有组件将有效。
        结果
        true如果组件有效，否则为 false
        从以下版本开始：
        1.0
        另请参见：
        validate() ， invalidate()

      • isDisplayable

        public boolean isDisplayable​()
        确定此组件是否可显示。 组件在连接到本机屏幕资源时可显示。

        当组件添加到可显示的包含层次结构中或当其包含层次结构可显示时，组件可以显示。 当其祖先窗口被打包或使其可见时，可以显示包含层次结构。

        当组件从可显示的包含层次结构中移除时，或者当其包含层次结构不可显示时，组件不可显示。 当其祖先窗口被布置时，容纳层次结构不可显示。

        结果
        true如果组件可显示，否则为 false
        从以下版本开始：
        1.2
        另请参见：
        Container.add(Component) ，
Window.pack() ，
Window.show() ，
Container.remove(Component) ，
Window.dispose()

      • isVisible

        public boolean isVisible​()
        确定当该组件的父级可见时是否应该可见。 组件最初可见，除了顶级组件，例如Frame对象。
        结果
        true如果组件可见，否则为 false
        从以下版本开始：
        1.0
        另请参见：
        setVisible(boolean)

      • getMousePosition

        public Point getMousePosition​()
                       throws HeadlessException
        如果Component直接在鼠标指针下面，则返回鼠标指针在Component的坐标空间中的位置，否则返回null 。 如果Component没有显示在屏幕上，即使鼠标指针在显示Component的区域上方，该方法返回null 。 如果Component被其他Component或本机窗口部分或完全遮挡，则该方法仅在鼠标指针位于Component的视野Component部分上方时才返回非空值。

        为Container的IT如果鼠标上述返回一个非空值Container本身或以上任一后代。 如果您需要排除儿童，请使用Container.getMousePosition(boolean) 。

        有时，确切的鼠标坐标并不重要，唯一重要的是特定的Component是否在鼠标指针下方。 如果此方法的返回值为null ，鼠标指针不在Component 。

        结果
        相对于此 Component鼠标坐标，或null
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.5
        另请参见：
        isShowing() ， Container.getMousePosition(boolean)

      • isShowing

        public boolean isShowing​()
        确定此组件是否在屏幕上显示。 这意味着组件必须可见，并且它必须在可见和显示的容器中。

        注意：有时无法检测Component是否实际上对用户可见。 这可能发生在：

        • 该组件已添加到可见的ScrollPane但Component当前不在滚动窗格的视图端口中。
        • Component被另一个Component或Container 。
        结果
        true如果组件显示， false否则
        从以下版本开始：
        1.0
        另请参见：
        setVisible(boolean)

      • isEnabled

        public boolean isEnabled​()
        确定是否启用此组件。 启用的组件可以响应用户输入并生成事件。 默认情况下，组件最初启用。 可以通过调用其setEnabled方法来启用或禁用组件。
        结果
        true如果组件已启用，否则为 false
        从以下版本开始：
        1.0
        另请参见：
        setEnabled(boolean)

      • setEnabled

        public void setEnabled​(boolean b)
        根据参数b的值启用或禁用此组件。 启用的组件可以响应用户输入并生成事件。 默认情况下，组件最初启用。

        注意：禁用轻量级组件不会阻止它接收MouseEvents。

        注意：禁用重量级容器会阻止此容器中的所有组件接收任何输入事件。 但禁用轻量级容器仅影响此容器。

        参数
        b - 如果是true ，则启用该组件; 否则该组件被禁用
        从以下版本开始：
        1.1
        另请参见：
        isEnabled() ， isLightweight()

      • enable

        @Deprecated
public void enable​()
        已过时。 从JDK 1.1版开始，由setEnabled(boolean)代替。

      • enable

        @Deprecated
public void enable​(boolean b)
        已过时。 从JDK 1.1版开始，由setEnabled(boolean)替代。
        启用或禁用此组件。
        参数
        b - true以启用此组件; 否则false

      • disable

        @Deprecated
public void disable​()
        已过时。 从JDK 1.1版开始，由setEnabled(boolean)替代。

      • isDoubleBuffered

        public boolean isDoubleBuffered​()
        如果此组件被绘制到稍后复制到屏幕的屏幕外图像（“缓冲区”），则返回true。 支持双缓冲的组件子类应该覆盖此方法，以便在启用双缓冲时返回true。
        结果
        默认为false

      • enableInputMethods

        public void enableInputMethods​(boolean enable)
        启用或禁用此组件的输入法支持。 如果启用了输入法支持，并且组件还处理关键事件，则传入事件将提供给当前输入法，并且只有在组件执行时才会被处理，或者如果输入方法不消耗它们，则调度到其监听器。 默认情况下，启用输入法支持。
        参数
        enable - true启用，false禁用
        从以下版本开始：
        1.2
        另请参见：
        processKeyEvent(java.awt.event.KeyEvent)

      • setVisible

        public void setVisible​(boolean b)
        根据参数b的值显示或隐藏此组件。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        b - 如果是true ，则显示此组件; 否则隐藏这个组件
        从以下版本开始：
        1.1
        另请参见：
        isVisible() ， invalidate()

      • show

        @Deprecated
public void show​()
        已过时。 从JDK 1.1版开始，由setVisible(boolean)代替。

      • show

        @Deprecated
public void show​(boolean b)
        已过时。 从JDK 1.1版开始，由setVisible(boolean)替代。
        使此组件可见或不可见。
        参数
        b - true以使该组件可见; 否则false

      • hide

        @Deprecated
public void hide​()
        已过时。 从JDK 1.1版开始，由setVisible(boolean)取代。

      • getForeground

        public Color getForeground​()
        获取此组件的前景色。
        结果
        这个组件的前景色; 如果此组件没有前景色，则返回其父项的前景色
        从以下版本开始：
        1.0
        另请参见：
        setForeground(java.awt.Color)

      • setForeground

        public void setForeground​(Color c)
        设置此组件的前景颜色。
        参数
        c - 成为该组件前景色的颜色; 如果此参数为null则此组件将继承其父级的前景色
        从以下版本开始：
        1.0
        另请参见：
        getForeground()

      • isForegroundSet

        public boolean isForegroundSet​()
        返回是否为此组件显式设置了前景色。 如果此方法返回false ，则此Component将从祖先继承其前景颜色。
        结果
        true如果前面的颜色已被明确设置为此组件; 否则为false 。
        从以下版本开始：
        1.4

      • getBackground

        public Color getBackground​()
        获取此组件的背景颜色。
        结果
        这个组件的背景颜色; 如果该组件没有背景颜色，则返回其父项的背景颜色
        从以下版本开始：
        1.0
        另请参见：
        setBackground(java.awt.Color)

      • setBackground

        public void setBackground​(Color c)
        设置此组件的背景颜色。

        背景颜色会不同地影响每个组件，受背景颜色影响的组件部分在操作系统之间可能不同。

        参数
        c - 成为该组件颜色的颜色; 如果此参数为null ，则此组件将继承其父级的背景颜色
        从以下版本开始：
        1.0
        另请参见：
        getBackground()

      • isBackgroundSet

        public boolean isBackgroundSet​()
        返回是否为此组件显式设置了背景颜色。 如果此方法返回false ，则此组件将从祖先继承其背景颜色。
        结果
        true如果已经为此组件显式设置了背景颜色; 否则为false 。
        从以下版本开始：
        1.4

      • getFont

        public Font getFont​()
        获取此组件的字体。
        Specified by:
        getFont在接口 MenuContainer
        结果
        这个组件的字体; 如果尚未为此组件设置字体，则返回其父代的字体
        从以下版本开始：
        1.0
        另请参见：
        setFont(java.awt.Font)

      • setFont

        public void setFont​(Font f)
        设置此组件的字体。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        f - 字体成为这个组件的字体; 如果此参数为null则此组件将继承其父级的字体
        从以下版本开始：
        1.0
        另请参见：
        getFont() ， invalidate()

      • isFontSet

        public boolean isFontSet​()
        返回是否已经为此组件显式设置了字体。 如果此方法返回false ，则此Component将从祖先继承其字体。
        结果
        true如果字体已被明确设置为此组件; 否则为false 。
        从以下版本开始：
        1.4

      • getLocale

        public Locale getLocale​()
        获取此组件的区域设置。
        结果
        这个组件的区域设置; 如果此组件没有区域设置，则返回其父级的区域设置
        异常
        IllegalComponentStateException - 如果 Component没有自己的区域设置，并且尚未添加到包含层次结构中，以便可以从包含的父项确定区域设置
        从以下版本开始：
        1.1
        另请参见：
        setLocale(java.util.Locale)

      • setLocale

        public void setLocale​(Locale l)
        设置此组件的区域设置。 这是一个绑定属性。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        l - 成为该组件区域设置的区域设置
        从以下版本开始：
        1.1
        另请参见：
        getLocale() ， invalidate()

      • getColorModel

        public ColorModel getColorModel​()
        获取用于在输出设备上显示组件的 ColorModel的实例。
        结果
        该组件使用的颜色模型
        从以下版本开始：
        1.0
        另请参见：
        ColorModel ， ComponentPeer.getColorModel() ， Toolkit.getColorModel()

      • getLocation

        public Point getLocation​()
        以指定组件左上角的点的形式获取此组件的位置。 位置将相对于父母的坐标空间。

        由于本机事件处理的异步性质，该方法可以返回过时的值（例如，在快速连续的多次调用setLocation()之后）。 因此，获取组件位置的推荐方法在java.awt.event.ComponentListener.componentMoved()内，在操作系统完成组件移动后调用。

        结果
        一个 Point的实例表示组件的父元素坐标空间中组件边界的左上角
        从以下版本开始：
        1.1
        另请参见：
        setLocation(int, int) ， getLocationOnScreen()

      • getLocationOnScreen

        public Point getLocationOnScreen​()
        以指定组件左上角的点的形式获取此组件的位置。
        结果
        表示屏幕坐标空间中组件边界左上角的 Point的实例
        异常
        IllegalComponentStateException - 如果组件没有显示在屏幕上
        另请参见：
        setLocation(int, int) ， getLocation()

      • location

        @Deprecated
public Point location​()
        已过时。 从JDK 1.1版开始，由getLocation()替代。
        返回此组件左上角的位置。
        结果
        该组件的左上角的位置

      • setLocation

        public void setLocation​(int x,
                        int y)
        将此组件移动到新位置。 新位置的左上角由此组件父项的坐标空间中的x和y参数指定。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        x - 新位置的左上角 x坐标坐标空间
        y - 父位置坐标空间中新位置左上角的 y坐标
        从以下版本开始：
        1.1
        另请参见：
        getLocation() ，
setBounds(int, int, int, int) ，
invalidate()

      • move

        @Deprecated
public void move​(int x,
                 int y)
        已过时。 从JDK 1.1版开始，由setLocation(int, int)替代。
        将此组件移动到新位置。
        参数
        x - 新位置的左上角 x坐标坐标空间
        y - 父位置坐标空间中新位置左上角的 y坐标

      • setLocation

        public void setLocation​(Point p)
        将此组件移动到新位置。 新位置的左上角由点p指定。 点p在父协调空间中给出。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        p - 定义新位置左上角的点，在该组件的父项的坐标空间中给出
        从以下版本开始：
        1.1
        另请参见：
        getLocation() ，
setBounds(int, int, int, int) ，
invalidate()

      • getSize

        public Dimension getSize​()
        以Dimension对象的形式返回此组件的大小。 Dimension对象的height字段包含此组件的高度，而Dimension对象的width字段包含此组件的宽度。
        结果
        一个 Dimension对象，指示此组件的大小
        从以下版本开始：
        1.1
        另请参见：
        setSize(int, int)

      • size

        @Deprecated
public Dimension size​()
        已过时。 截至JDK 1.1版，由getSize()替代。
        以 Dimension对象的形式返回此组件的大小。
        结果
        表示此组件大小的 Dimension对象

      • setSize

        public void setSize​(int width,
                    int height)
        调整此组件的大小，使其宽度为width ，高度为height 。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        width - 该组件的新宽度（以像素为单位）
        height - 该组件的新高度（以像素为单位）
        从以下版本开始：
        1.1
        另请参见：
        getSize() ，
setBounds(int, int, int, int) ，
invalidate()

      • resize

        @Deprecated
public void resize​(int width,
                   int height)
        已过时。 从JDK 1.1版开始，由setSize(int, int)替代。
        调整此组件的大小。
        参数
        width - 组件的新宽度
        height - 组件的新高度

      • setSize

        public void setSize​(Dimension d)
        调整此组件的大小，使其宽度为d.width ，高度为d.height 。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        d - 指定此组件的新大小的维度
        异常
        NullPointerException - 如果 d是 null
        从以下版本开始：
        1.1
        另请参见：
        setSize(int, int) ，
setBounds(int, int, int, int) ，
invalidate()

      • resize

        @Deprecated
public void resize​(Dimension d)
        已过时。 从JDK 1.1版开始，由setSize(Dimension)替代。
        调整此组件的大小，使其宽度为 d.width ，高度为 d.height 。
        参数
        d - 这个组件的新尺寸

      • getBounds

        public Rectangle getBounds​()
        以Rectangle对象的形式获取此组件的边界。 边界指定该组件相对于其父项的宽度，高度和位置。
        结果
        一个表示该组件边界的矩形
        另请参见：
        setBounds(int, int, int, int) ，
getLocation() ，
getSize()

      • bounds

        @Deprecated
public Rectangle bounds​()
        已过时。 从JDK 1.1版开始，由getBounds()替代。
        返回此组件的边界矩形。
        结果
        该组件的边界矩形

      • setBounds

        public void setBounds​(int x,
                      int y,
                      int width,
                      int height)
        移动并调整此组件的大小。 左上角的新位置由x和y指定，新大小由width和height指定。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        x - 这个组件的新 x坐标
        y - 这个组件的新 y-坐标
        width - 这个组件的新 width
        height - 这个组件的新 height
        从以下版本开始：
        1.1
        另请参见：
        getBounds() ， setLocation(int, int) ， setLocation(Point) ， setSize(int, int) ， setSize(Dimension) ， invalidate()

      • reshape

        @Deprecated
public void reshape​(int x,
                    int y,
                    int width,
                    int height)
        已过时。 从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
        重新整形这个组件的边界矩形。
        参数
        x - 矩形左上角的 x坐标
        y - 矩形左上角的 y坐标
        width - 矩形的宽度
        height - 矩形的高度

      • setBounds

        public void setBounds​(Rectangle r)
        移动并调整此组件的大小以符合新的边界矩形r 。 该组件的新位置由r.x和r.y指定，其新尺寸由r.width和r.height指定

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        r - 此组件的新的边界矩形
        异常
        NullPointerException - 如果 r是 null
        从以下版本开始：
        1.1
        另请参见：
        getBounds() ， setLocation(int, int) ， setLocation(Point) ， setSize(int, int) ， setSize(Dimension) ， invalidate()

      • getX

        public int getX​()
        返回组件原点的当前x坐标。 这种方法比component.getBounds().x或component.getLocation().x更component.getBounds().x ，因为它不会导致堆分配。
        结果
        组件原点的当前x坐标
        从以下版本开始：
        1.2

      • getY

        public int getY​()
        返回组件原点的当前y坐标。 这种方法比component.getBounds().y或component.getLocation().y更component.getBounds().y ，因为它不会导致任何堆分配。
        结果
        组件原点的当前y坐标
        从以下版本开始：
        1.2

      • getWidth

        public int getWidth​()
        返回此组件的当前宽度。 这种方法比component.getBounds().width或component.getSize().width更component.getBounds().width ，因为它不会导致任何堆分配。
        结果
        该组件的当前宽度
        从以下版本开始：
        1.2

      • getHeight

        public int getHeight​()
        返回此组件的当前高度。 这种方法比component.getBounds().height或component.getSize().height更component.getBounds().height ，因为它不会导致任何堆分配。
        结果
        该组件的当前高度
        从以下版本开始：
        1.2

      • getBounds

        public Rectangle getBounds​(Rectangle rv)
        将此组件的边界存储到“返回值” rv并返回rv 。 如果rv为null ，则新分配Rectangle 。 如果呼叫者想要避免在堆上分配新的Rectangle对象，则此版本的getBounds是非常有用的。
        参数
        rv - 返回值，修改为组件边界
        结果
        RV

      • getSize

        public Dimension getSize​(Dimension rv)
        将该组件的宽度/高度存储到“返回值” rv并返回rv 。 如果rv为null则会分配一个新的Dimension对象。 如果呼叫者想要避免在堆上分配新的Dimension对象，则此版本的getSize非常有用。
        参数
        rv - 返回值，修改为组件大小
        结果
        RV

      • getLocation

        public Point getLocation​(Point rv)
        将该组件的x，y原点存储到“返回值” rv并返回rv 。 如果rv为null ，则新分配Point 。 如果呼叫者想要避免在堆上分配新的Point对象，则此版本的getLocation非常有用。
        参数
        rv - 返回值，修改为组件位置
        结果
        RV

      • isOpaque

        public boolean isOpaque​()
        如果此组件完全不透明，则返回true，默认情况下返回false。

        不透明组件涂覆其矩形区域内的每个像素。 非不透明组件仅绘制其一些像素，允许其下方的像素“显示”。 因此，不完全绘制其像素的组件提供了一定程度的透明度。

        保证总是完全绘制内容的子类应该覆盖此方法并返回true。

        结果
        如果此组件完全不透明，则为true
        从以下版本开始：
        1.2
        另请参见：
        isLightweight()

      • isLightweight

        public boolean isLightweight​()
        轻量级组件没有本机工具包对等体。 Component和Container子Component Container ，除Button或Scrollbar这样的封装中定义的子类外。 所有的Swing组件都是轻量级的。

        如果此组件不可显示，则该方法将始终返回false ，因为无法确定不可显示组件的重量。

        结果
        如果此组件具有轻量级对等体，则为true; 如果它有一个本机对等体或没有对等体，则为false
        从以下版本开始：
        1.2
        另请参见：
        isDisplayable()

      • setPreferredSize

        public void setPreferredSize​(Dimension preferredSize)
        将此组件的首选大小设置为常量值。 后续调用getPreferredSize将始终返回此值。 将首选大小设置为null可恢复默认行为。
        参数
        preferredSize - 新的首选大小，或null
        从以下版本开始：
        1.5
        另请参见：
        getPreferredSize() ， isPreferredSizeSet()

      • isPreferredSizeSet

        public boolean isPreferredSizeSet​()
        如果首选大小设置为非 null值，则返回true，否则返回false。
        结果
        如果已经使用非空值调用了 setPreferredSize则 setPreferredSize true。
        从以下版本开始：
        1.5

      • getPreferredSize

        public Dimension getPreferredSize​()
        获取此组件的首选大小。
        结果
        指示该组件的首选尺寸的维度对象
        另请参见：
        getMinimumSize() ， LayoutManager

      • preferredSize

        @Deprecated
public Dimension preferredSize​()
        已过时。 从JDK 1.1版开始，替换为getPreferredSize() 。
        返回组件的首选大小。
        结果
        该组件的首选尺寸

      • setMinimumSize

        public void setMinimumSize​(Dimension minimumSize)
        将此组件的最小大小设置为常量值。 后续调用getMinimumSize将始终返回此值。 将最小大小设置为null可恢复默认行为。
        参数
        minimumSize - 这个组件的最小尺寸
        从以下版本开始：
        1.5
        另请参见：
        getMinimumSize() ， isMinimumSizeSet()

      • isMinimumSizeSet

        public boolean isMinimumSizeSet​()
        返回是否使用非空值调用了 setMinimumSize 。
        结果
        如果已使用非空值调用了 setMinimumSize则 setMinimumSize true。
        从以下版本开始：
        1.5

      • getMinimumSize

        public Dimension getMinimumSize​()
        获取此组件的最小大小。
        结果
        指示该组件的最小尺寸的维度对象
        另请参见：
        getPreferredSize() ， LayoutManager

      • minimumSize

        @Deprecated
public Dimension minimumSize​()
        已过时。 从JDK 1.1版开始，由getMinimumSize()替代。
        返回此组件的最小大小。
        结果
        该组件的最小尺寸

      • setMaximumSize

        public void setMaximumSize​(Dimension maximumSize)
        将此组件的最大大小设置为常量值。 后续调用getMaximumSize将始终返回此值。 将最大大小设置为null可恢复默认行为。
        参数
        maximumSize - 一个 Dimension其中包含所需的最大允许大小
        从以下版本开始：
        1.5
        另请参见：
        getMaximumSize() ， isMaximumSizeSet()

      • isMaximumSizeSet

        public boolean isMaximumSizeSet​()
        如果最大大小设置为非 null值，则返回true，否则返回false。
        结果
        如果 maximumSize为非 null ， null true，否则为false
        从以下版本开始：
        1.5

      • getMaximumSize

        public Dimension getMaximumSize​()
        获取此组件的最大大小。
        结果
        指示该组件的最大大小的维度对象
        另请参见：
        getMinimumSize() ， getPreferredSize() ， LayoutManager

      • getAlignmentX

        public float getAlignmentX​()
        返回沿x轴的对齐方式。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        结果
        该组件的水平对齐

      • getAlignmentY

        public float getAlignmentY​()
        返回沿着y轴的对齐。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        结果
        该组件的垂直对齐

      • getBaseline

        public int getBaseline​(int width,
                       int height)
        返回基线。 基线是从组件的顶部测量的。 该方法主要用于LayoutManager s，以使组件沿其基线对齐。 返回值小于0表示此组件没有合理的基线，并且LayoutManager s不应该将该组件对准其基线。

        默认实现返回-1。 支持基准的子类应适当地覆盖。 如果返回值> = 0，则组件具有任何大小的有效基准> =最小大小，而getBaselineResizeBehavior可用于确定基准如何随大小而变化。

        参数
        width - 获取基准的宽度
        height - 获取基准的高度
        结果
        基线或<0表示没有合理的基线
        异常
        IllegalArgumentException - 如果宽度或高度<0
        从以下版本开始：
        1.6
        另请参见：
        getBaselineResizeBehavior() ， FontMetrics

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior​()
        返回一个枚举，指示组件的基线如何随着大小的变化而改变。 此方法主要用于布局管理器和GUI构建器。

        默认实现返回BaselineResizeBehavior.OTHER 。 具有基线的子类应适当覆盖。 子类不应该返回null ; 如果基线不能计算返回BaselineResizeBehavior.OTHER 。 呼叫者应首先使用getBaseline询问基线，如果返回值> = 0，则使用此方法。 该方法可以返回BaselineResizeBehavior.OTHER以外的值，即使getBaseline返回小于0的值。

        结果
        一个枚举，指示基准随着组件大小的变化而改变
        从以下版本开始：
        1.6
        另请参见：
        getBaseline(int, int)

      • doLayout

        public void doLayout​()
        提示布局管理器布局此组件。 当组件（更具体地说，容器））被验证时，这通常被调用。
        另请参见：
        validate() ， LayoutManager

      • layout

        @Deprecated
public void layout​()
        已过时。 从JDK 1.1版开始，替换为doLayout() 。

      • validate

        public void validate​()
        验证此组件。

        验证术语的含义由本类的祖先定义。 详见Container.validate() 。

        从以下版本开始：
        1.0
        另请参见：
        invalidate() ， doLayout() ， LayoutManager ， Container.validate()

      • invalidate

        public void invalidate​()
        无效此组件及其祖先。

        默认情况下，到层次结构最顶层容器的组件的所有祖先被标记为无效。 如果java.awt.smartInvalidate系统属性设置为true ，则无效在该组件的最近的验证根上停止。 标记容器无效表示容器需要布置。

        当任何与布局相关的信息发生变化（例如，设置组件的界限，或将组件添加到容器中）时，将自动调用此方法。

        这种方法可能经常被调用，所以它应该能够快速运行。

        从以下版本开始：
        1.0
        另请参见：
        validate() ， doLayout() ， LayoutManager ， Container.isValidateRoot()

      • revalidate

        public void revalidate​()
        将组件层次结构重新验证为最接近的验证根。

        该方法首先使从该组件开始到最近的验证根的组件层次化。 之后，从最近的验证根开始验证组件层次结构。

        这是一种方便的方法，可以帮助应用程序开发人员避免手动查找有效的根。 基本上，这相当于首先在该组件上调用invalidate()方法，然后在最近的验证根上调用validate()方法。

        从以下版本开始：
        1.7
        另请参见：
        Container.isValidateRoot()

      • getGraphics

        public Graphics getGraphics​()
        为此组件创建图形上下文。 如果此组件当前不可显示，此方法将返回null 。
        结果
        该组件的图形上下文，如果没有， null
        从以下版本开始：
        1.0
        另请参见：
        paint(java.awt.Graphics)

      • getFontMetrics

        public FontMetrics getFontMetrics​(Font font)
        获取指定字体的字体指标。 警告：由于字体指标受到FontRenderContext的影响，并且此方法不提供此方法，它只能返回默认渲染上下文的度量标准，如果正在使用270467271938838功能，则可能与组件上呈现时使用的不一致 。 相反，可以通过在Font类中调用Graphics.getFontMetrics()或文本测量API来获取渲染时的度量。
        参数
        font - 要获取字体指标的字体
        结果
        font的字体指标
        从以下版本开始：
        1.0
        另请参见：
        getFont() ，
ComponentPeer.getFontMetrics(Font) ，
Toolkit.getFontMetrics(Font)

      • setCursor

        public void setCursor​(Cursor cursor)
        将光标图像设置为指定的光标。 当此组件的contains方法对于当前光标位置返回true时，将显示此光标图像，此组件可见，可显示和启用。 设置Container的光标导致该光标显示在所有容器的子组件中，除了具有非null光标的那些。

        如果Java平台实现和/或本地系统不支持更改鼠标光标的形状，该方法可能没有视觉效果。

        参数
        cursor - 由Cursor类定义的常量Cursor ; 如果此参数为null则此组件将继承其父项的游标
        从以下版本开始：
        1.1
        另请参见：
        isEnabled() ， isShowing() ， getCursor() ， contains(int, int) ， Toolkit.createCustomCursor(java.awt.Image, java.awt.Point, java.lang.String) ， Cursor

      • getCursor

        public Cursor getCursor​()
        获取组件中的光标集。 如果组件没有设置游标，则返回其父项的游标。 如果在整个层次结构中没有设置游标，则返回Cursor.DEFAULT_CURSOR 。
        结果
        该组件的光标
        从以下版本开始：
        1.1
        另请参见：
        setCursor(java.awt.Cursor)

      • isCursorSet

        public boolean isCursorSet​()
        返回是否已经为此组件显式设置了游标。 如果此方法返回false ，则此Component将从祖先继承其游标。
        结果
        true如果游标已为此组件显式设置; 否则为false 。
        从以下版本开始：
        1.4

      • paint

        public void paint​(Graphics g)
        涂抹这个组件。

        当组件的内容应该被绘制时，调用该方法; 例如当组件首次显示或损坏并需要修理时。 Graphics参数中的剪辑矩形设置为需要绘制的区域。 覆盖此方法的子类Component不需要调用super.paint(g) 。

        出于性能原因，零宽度或高度的Component s在首次显示时不被认为需要喷漆，也不被认为需要修理。

        注意 ：有关由AWT和Swing实现的涂漆机制的更多信息，包括有关如何编写最有效的绘画代码的信息，请参阅Painting in AWT and Swing 。

        参数
        g - 用于绘画的图形上下文
        从以下版本开始：
        1.0
        另请参见：
        update(java.awt.Graphics)

      • update

        public void update​(Graphics g)
        更新此组件。

        如果此组件不是轻量级组件，AWT会调用update方法来响应对repaint的调用。 您可以假设背景不被清除。

        该update的方法Component调用此组件的paint方法来重绘此组件。 该方法通常被需要为响应repaint的调用做额外工作的子类覆盖。 要覆盖此方法的组件子类应直接从其update方法调用super.update(g)或调用paint(g) 。

        图形上下文的原点，其（ 0 ， 0 ）坐标点，是该组件的左上角。 图形上下文的剪切区域是该组件的边界矩形。

        注意 ：有关AWT和Swing实现的绘画机制的更多信息，包括如何编写最有效的绘画代码的信息，请参阅Painting in AWT and Swing 。

        参数
        g - 用于更新的指定上下文
        从以下版本开始：
        1.0
        另请参见：
        paint(java.awt.Graphics) ， repaint()

      • paintAll

        public void paintAll​(Graphics g)
        绘制此组件及其所有子组件。

        图形上下文的原点，其（ 0 ， 0 ）坐标点，是该组件的左上角。 图形上下文的剪切区域是该组件的边界矩形。

        参数
        g - 用于绘画的图形上下文
        从以下版本开始：
        1.0
        另请参见：
        paint(java.awt.Graphics)

      • repaint

        public void repaint​()
        重新编辑这个组件。

        如果此组件是轻量级组件，则此方法将尽快调用此组件的paint方法。 否则，该方法会尽快调用此组件的update方法。

        注意 ：有关AWT和Swing实施的绘画机制的更多信息，包括有关如何编写最有效的绘画代码的信息，请参阅Painting in AWT and Swing 。

        从以下版本开始：
        1.0
        另请参见：
        update(Graphics)

      • repaint

        public void repaint​(long tm)
        重写组件。 如果此组件是轻量级组件，这将导致一个呼叫paint内tm毫秒。

        注意 ：有关AWT和Swing实施的绘画机制的更多信息，包括有关如何编写最有效的绘画代码的信息，请参阅Painting in AWT and Swing 。

        参数
        tm - 更新前的最大时间（以毫秒为单位）
        从以下版本开始：
        1.0
        另请参见：
        paint(java.awt.Graphics) ， update(Graphics)

      • repaint

        public void repaint​(int x,
                    int y,
                    int width,
                    int height)
        重新绘制该组件的指定矩形。

        如果此组件是轻量级组件，则此方法将尽快调用此组件的paint方法。 否则，该方法会尽快调用此组件的update方法。

        注意 ：有关AWT和Swing实施的绘画机制的更多信息，包括有关如何编写最有效的绘画代码的信息，请参阅Painting in AWT and Swing 。

        参数
        x - x坐标
        y - y坐标
        width - 宽度
        height - 高度
        从以下版本开始：
        1.0
        另请参见：
        update(Graphics)

      • repaint

        public void repaint​(long tm,
                    int x,
                    int y,
                    int width,
                    int height)
        在tm毫秒内重新绘制该组件的指定矩形。

        如果此组件是轻量级组件，则此方法将调用此组件的paint方法。 否则，此方法将调用此组件的update方法。

        注意 ：有关AWT和Swing实施的涂漆机制的更多信息，包括有关如何编写最有效的绘画代码的信息，请参阅Painting in AWT and Swing 。

        参数
        tm - 更新前的最大时间（毫秒）
        x - x坐标
        y - y坐标
        width - 宽度
        height - 高度
        从以下版本开始：
        1.0
        另请参见：
        update(Graphics)

      • print

        public void print​(Graphics g)
        打印此组件。 应用程序应该重写此方法，以便在打印之前必须进行特殊处理的组件，或者应该打印与绘制不同的组件。

        该方法的默认实现方法是调用paint方法。

        图形上下文的原点，其（ 0 ， 0 ）坐标点，是该组件的左上角。 图形上下文的剪切区域是该组件的边界矩形。

        参数
        g - 用于打印的图形上下文
        从以下版本开始：
        1.0
        另请参见：
        paint(Graphics)

      • printAll

        public void printAll​(Graphics g)
        打印此组件及其所有子组件。

        图形上下文的原点，其（ 0 ， 0 ）坐标点，是该组件的左上角。 图形上下文的剪切区域是该组件的边界矩形。

        参数
        g - 用于打印的图形上下文
        从以下版本开始：
        1.0
        另请参见：
        print(Graphics)

      • imageUpdate

        public boolean imageUpdate​(Image img,
                           int infoflags,
                           int x,
                           int y,
                           int w,
                           int h)
        当图像发生变化时重新编辑组件。 此imageUpdate一个的方法ImageObserver时调用关于哪些已经使用异步例程，如先前所请求的图像的详细信息drawImage的方法Graphics变得可用。 有关此方法及其参数的更多信息，请参阅imageUpdate的定义。

        imageUpdate方法在图像的更多比特可用的Component逐渐绘制组件上的图像。

        如果系统属性awt.image.incrementaldraw丢失或值为true ，则图像将逐步绘制。 如果系统属性具有任何其他值，则在完全加载映像之前，不会绘制图像。

        另外，如果增量绘图生效，则系统属性awt.image.redrawrate的值被解释为整数，以毫秒为单位给出最大重绘速率。 如果系统属性丢失或不能被解释为整数，则重绘速率是每100ms一次。

        的解释x ， y ， width ，并height参数依赖于价值infoflags说法。

        Specified by:
        imageUpdate在接口 ImageObserver
        参数
        img - 正在观察的图像
        infoflags - 有关详细信息，请参阅 imageUpdate
        x - x坐标
        y - y坐标
        w - 宽度
        h - 高度
        结果
        false如果infoflags指示图像被完全加载; 否则为true 。
        从以下版本开始：
        1.0
        另请参见：
        ImageObserver ， Graphics.drawImage(Image, int, int, Color, java.awt.image.ImageObserver) ， Graphics.drawImage(Image, int, int, java.awt.image.ImageObserver) ， Graphics.drawImage(Image, int, int, int, int, Color, java.awt.image.ImageObserver) ， Graphics.drawImage(Image, int, int, int, int, java.awt.image.ImageObserver) ， ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • createImage

        public Image createImage​(ImageProducer producer)
        从指定的图像制作者创建图像。
        参数
        producer - 图像制作者
        结果
        图像生成
        从以下版本开始：
        1.0

      • createImage

        public Image createImage​(int width,
                         int height)
        创建一个用于双缓冲的屏幕外可绘图像。
        参数
        width - 指定的宽度
        height - 指定的高度
        结果
        一个可以用于双重缓冲的屏幕外可绘图像。 null值如果组件不可显示或GraphicsEnvironment.isHeadless()返回true 。
        从以下版本开始：
        1.0
        另请参见：
        isDisplayable() ， GraphicsEnvironment.isHeadless()

      • createVolatileImage

        public VolatileImage createVolatileImage​(int width,
                                         int height)
        创建一个用于双缓冲的易失性的屏幕外可绘图像。
        参数
        width - 指定的宽度
        height - 指定的高度
        结果
        一个可以用于双重缓冲的屏幕外可绘图像。 null值如果组件不可显示或GraphicsEnvironment.isHeadless()返回true 。
        从以下版本开始：
        1.4
        另请参见：
        VolatileImage ， isDisplayable() ， GraphicsEnvironment.isHeadless()

      • createVolatileImage

        public VolatileImage createVolatileImage​(int width,
                                         int height,
                                         ImageCapabilities caps)
                                  throws AWTException
        使用给定的功能创建一个易失的屏幕外可绘制图像。 由于操作系统问题，此图像的内容可能随时丢失，因此图像必须通过VolatileImage界面进行管理。
        参数
        width - 指定的宽度
        height - 指定的高度
        caps - 图像功能
        结果
        一个VolatileImage对象，可用于管理表面内容的丢失和能力。 null值如果组件不可显示，或GraphicsEnvironment.isHeadless()返回true 。
        异常
        AWTException - 如果无法创建具有指定功能的图像
        从以下版本开始：
        1.4
        另请参见：
        VolatileImage

      • prepareImage

        public boolean prepareImage​(Image image,
                            ImageObserver observer)
        准备用于在此组件上呈现的图像。 图像数据在另一个线程中被异步地下载，并且生成图像的适当的屏幕表示。
        参数
        image - Image准备屏幕表示的 Image
        observer - 正在准备好要通知的 ImageObserver对象
        结果
        true如果图像已经完全准备好了; 否则为false
        从以下版本开始：
        1.0

      • prepareImage

        public boolean prepareImage​(Image image,
                            int width,
                            int height,
                            ImageObserver observer)
        准备一个图像，以指定的宽度和高度在此组件上渲染。

        图像数据在另一个线程中异步下载，并且生成图像的适当缩放的屏幕表示。

        参数
        image - 为其准备屏幕表示的 Image的实例
        width - 所需屏幕表示的宽度
        height - 所需屏幕表示的高度
        observer - 正在准备好要通知的 ImageObserver对象
        结果
        true如果图像已经完全准备好了; 否则为false
        从以下版本开始：
        1.0
        另请参见：
        ImageObserver

      • checkImage

        public int checkImage​(Image image,
                      ImageObserver observer)
        返回构造指定图像的屏幕表示的状态。

        此方法不会导致图像开始加载。 应用程序必须使用prepareImage方法强制加载映像。

        关于这种方法返回的标志的信息可以在ImageObserver接口的讨论中找到。

        参数
        image - 正在检查其状态的 Image对象
        observer - 当图像正在准备时要通知的 ImageObserver对象
        结果
        指示关于图像的什么信息当前可用的 ImageObserver标记的按位包含 OR
        从以下版本开始：
        1.0
        另请参见：
        prepareImage(Image, int, int, java.awt.image.ImageObserver) ， Toolkit.checkImage(Image, int, int, java.awt.image.ImageObserver) ， ImageObserver

      • checkImage

        public int checkImage​(Image image,
                      int width,
                      int height,
                      ImageObserver observer)
        返回构造指定图像的屏幕表示的状态。

        此方法不会导致图像开始加载。 应用程序必须使用prepareImage方法强制加载映像。

        该checkImage的方法Component要求其对等的checkImage方法来计算标志。 如果该组件还没有对等体，则调用组件的工具包的checkImage方法。

        关于这种方法返回的标志的信息可以在ImageObserver接口的讨论中找到。

        参数
        image - 正在检查其状态的 Image对象
        width - 要检查其状态的缩放版本的宽度
        height - 要检查其状态的缩放版本的高度
        observer - 当图像准备时要通知的 ImageObserver对象
        结果
        指示关于图像的什么信息当前可用的 ImageObserver标记的按位包含 OR
        从以下版本开始：
        1.0
        另请参见：
        prepareImage(Image, int, int, java.awt.image.ImageObserver) ， Toolkit.checkImage(Image, int, int, java.awt.image.ImageObserver) ， ImageObserver

      • setIgnoreRepaint

        public void setIgnoreRepaint​(boolean ignoreRepaint)
        设置是否忽略从操作系统接收的画面消息。 这不会影响AWT在软件中生成的油漆事件，除非它们是对操作系统级油漆消息的即时响应。

        这是有用的，例如，如果在全屏模式下运行，希望更好的性能，或者如果使用页面翻转作为缓冲策略。

        参数
        ignoreRepaint - true如果来自操作系统的paint消息应该被忽略; 否则false
        从以下版本开始：
        1.4
        另请参见：
        getIgnoreRepaint() ， Canvas.createBufferStrategy(int) ， Window.createBufferStrategy(int) ， BufferStrategy ， GraphicsDevice.setFullScreenWindow(java.awt.Window)

      • getIgnoreRepaint

        public boolean getIgnoreRepaint​()
        结果
        是否应忽略从操作系统接收的画面消息。
        从以下版本开始：
        1.4
        另请参见：
        setIgnoreRepaint(boolean)

      • contains

        public boolean contains​(int x,
                        int y)
        检查此组件是否“包含”指定点，其中 x和 y被定义为相对于该组件的坐标系。
        参数
        x - 点的 x坐标
        y - 点的 y坐标
        结果
        true如果点在组件内; 否则false
        从以下版本开始：
        1.1
        另请参见：
        getComponentAt(int, int)

      • inside

        @Deprecated
public boolean inside​(int x,
                      int y)
        已过时。 从JDK 1.1版开始，由contains（int，int）替换。
        检查点是否在该组件内。
        参数
        x - 点的 x坐标
        y - 点的 y坐标
        结果
        true如果点在组件内; 否则false

      • contains

        public boolean contains​(Point p)
        检查此组件是否“包含”指定点，其中点的 x和 y坐标被定义为相对于该组件的坐标系。
        参数
        p - 重点
        结果
        true如果点在组件内; 否则false
        异常
        NullPointerException - 如果 p是 null
        从以下版本开始：
        1.1
        另请参见：
        getComponentAt(Point)

      • getComponentAt

        public Component getComponentAt​(int x,
                                int y)
        确定此组件或其一个直接子组件是否包含（ x ， y ）位置，如果是，则返回包含的组件。 这种方法只有一层深度。 如果点（ x ， y ）位于本身具有子组件的子组件内，则不会向下查看子组件树。

        该locate的方法Component简单地返回组件本身，如果（X，Y）坐标位置是其边界框的内部， null否则。

        参数
        x - x坐标
        y - y坐标
        结果
        包含（ x ， y ）位置的组件或子组件; null如果位置在该组件之外
        从以下版本开始：
        1.0
        另请参见：
        contains(int, int)

      • locate

        @Deprecated
public Component locate​(int x,
                        int y)
        已过时。 从JDK 1.1版开始，由getComponentAt（int，int）替换。
        返回占据指定位置的组件（此组件或直接子组件，如果前两个都不占用该位置，则返回null）。
        参数
        x - 搜索组件的 x坐标
        y - 用于搜索组件的 y坐标
        结果
        指定位置的组件或 null

      • getComponentAt

        public Component getComponentAt​(Point p)
        返回包含指定点的组件或子组件。
        参数
        p - 关键
        结果
        指定位置的组件或 null
        从以下版本开始：
        1.1
        另请参见：
        contains(int, int)

      • deliverEvent

        @Deprecated
public void deliverEvent​(Event e)
        已过时。 从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代。
        参数
        e - 交付的事件

      • dispatchEvent

        public final void dispatchEvent​(AWTEvent e)
        将事件分派到此组件或其一个子组件。 致电processEvent然后返回为Component启用的1.1样式的事件。
        参数
        e - 事件

      • postEvent

        @Deprecated
public boolean postEvent​(Event e)
        已过时。 从JDK 1.1版开始，由dispatchEvent（AWTEvent）替换。
        说明从接口MenuContainer复制
        向事件发送一个事件。
        Specified by:
        postEvent在接口 MenuContainer
        参数
        e - 发送的事件
        结果
        发布事件的结果

      • addComponentListener

        public void addComponentListener​(ComponentListener l)
        添加指定的组件侦听器以从该组件接收组件事件。 如果监听器l为null ，则不会抛出异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 组件侦听器
        从以下版本开始：
        1.1
        另请参见：
        ComponentEvent ， ComponentListener ， removeComponentListener(java.awt.event.ComponentListener) ， getComponentListeners()

      • removeComponentListener

        public void removeComponentListener​(ComponentListener l)
        删除指定的组件侦听器，使其不再从此组件接收组件事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l为null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 组件侦听器
        从以下版本开始：
        1.1
        另请参见：
        ComponentEvent ， ComponentListener ， addComponentListener(java.awt.event.ComponentListener) ， getComponentListeners()

      • getComponentListeners

        public ComponentListener[] getComponentListeners​()
        返回在此组件上注册的所有组件侦听器的数组。
        结果
        所有这些组件的所有 ComponentListener s或没有组件侦听器当前注册的空数组
        从以下版本开始：
        1.4
        另请参见：
        addComponentListener(java.awt.event.ComponentListener) ， removeComponentListener(java.awt.event.ComponentListener)

      • addFocusListener

        public void addFocusListener​(FocusListener l)
        当该组件获得输入焦点时，添加指定的焦点侦听器以从该组件接收焦点事件。 如果监听器l为null ，则不会抛出异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 焦点侦听器
        从以下版本开始：
        1.1
        另请参见：
        FocusEvent ， FocusListener ， removeFocusListener(java.awt.event.FocusListener) ， getFocusListeners()

      • removeFocusListener

        public void removeFocusListener​(FocusListener l)
        删除指定的焦点侦听器，使其不再从此组件接收焦点事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l为null ，则不抛出任何异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 焦点侦听器
        从以下版本开始：
        1.1
        另请参见：
        FocusEvent ， FocusListener ， addFocusListener(java.awt.event.FocusListener) ， getFocusListeners()

      • getFocusListeners

        public FocusListener[] getFocusListeners​()
        返回在此组件上注册的所有焦点侦听器的数组。
        结果
        所有这个组件的 FocusListener s或一个空数组，如果没有组件侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addFocusListener(java.awt.event.FocusListener) ， removeFocusListener(java.awt.event.FocusListener)

      • addHierarchyListener

        public void addHierarchyListener​(HierarchyListener l)
        添加指定的层次监听器，以便在此容器所属的层次结构更改时从此组件接收层次结构更改的事件。 如果监听器l为null ，则不抛出任何异常，也不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 层次监听器
        从以下版本开始：
        1.3
        另请参见：
        HierarchyEvent ， HierarchyListener ， removeHierarchyListener(java.awt.event.HierarchyListener) ， getHierarchyListeners()

      • removeHierarchyListener

        public void removeHierarchyListener​(HierarchyListener l)
        删除指定的层次监听器，使其不再从此组件接收层次结构更改的事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l为null ，则不抛出任何异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 层次监听器
        从以下版本开始：
        1.3
        另请参见：
        HierarchyEvent ， HierarchyListener ， addHierarchyListener(java.awt.event.HierarchyListener) ， getHierarchyListeners()

      • getHierarchyListeners

        public HierarchyListener[] getHierarchyListeners​()
        返回在此组件上注册的所有层级监听器的数组。
        结果
        所有这个组件的 HierarchyListener s或一个空数组，如果没有层次结构侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addHierarchyListener(java.awt.event.HierarchyListener) ， removeHierarchyListener(java.awt.event.HierarchyListener)

      • addHierarchyBoundsListener

        public void addHierarchyBoundsListener​(HierarchyBoundsListener l)
        添加指定的层次结构边界侦听器以在此容器所属的层次结构更改时从此组件接收层次结构边界事件。 如果监听器l为null ，则不抛出任何异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 层次结构监听器
        从以下版本开始：
        1.3
        另请参见：
        HierarchyEvent ， HierarchyBoundsListener ， removeHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener) ， getHierarchyBoundsListeners()

      • removeHierarchyBoundsListener

        public void removeHierarchyBoundsListener​(HierarchyBoundsListener l)
        删除指定的层次结构边界监听器，使其不再从此组件接收层次结构限制事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l为null ，则不会抛出异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 层次结构监听器
        从以下版本开始：
        1.3
        另请参见：
        HierarchyEvent ， HierarchyBoundsListener ， addHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener) ， getHierarchyBoundsListeners()

      • getHierarchyBoundsListeners

        public HierarchyBoundsListener[] getHierarchyBoundsListeners​()
        返回在此组件上注册的所有层次结构边界侦听器的数组。
        结果
        所有这个组件的 HierarchyBoundsListener s或一个空数组，如果没有层次结构 HierarchyBoundsListener侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener) ， removeHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener)

      • addKeyListener

        public void addKeyListener​(KeyListener l)
        添加指定的密钥侦听器以从该组件接收密钥事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 关键听众。
        从以下版本开始：
        1.1
        另请参见：
        KeyEvent ， KeyListener ， removeKeyListener(java.awt.event.KeyListener) ， getKeyListeners()

      • removeKeyListener

        public void removeKeyListener​(KeyListener l)
        删除指定的密钥侦听器，使其不再从此组件接收密钥事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l为null ，则不抛出任何异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 关键听众
        从以下版本开始：
        1.1
        另请参见：
        KeyEvent ， KeyListener ， addKeyListener(java.awt.event.KeyListener) ， getKeyListeners()

      • getKeyListeners

        public KeyListener[] getKeyListeners​()
        返回在此组件上注册的所有关键侦听器的数组。
        结果
        所有这个组件的 KeyListener s或一个空数组，如果没有密钥侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addKeyListener(java.awt.event.KeyListener) ， removeKeyListener(java.awt.event.KeyListener)

      • addMouseListener

        public void addMouseListener​(MouseListener l)
        添加指定的鼠标监听器以从该组件接收鼠标事件。 如果监听器l为null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 鼠标监听器
        从以下版本开始：
        1.1
        另请参见：
        MouseEvent ， MouseListener ， removeMouseListener(java.awt.event.MouseListener) ， getMouseListeners()

      • removeMouseListener

        public void removeMouseListener​(MouseListener l)
        删除指定的鼠标监听器，使其不再从此组件接收鼠标事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l为null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 鼠标监听器
        从以下版本开始：
        1.1
        另请参见：
        MouseEvent ， MouseListener ， addMouseListener(java.awt.event.MouseListener) ， getMouseListeners()

      • getMouseListeners

        public MouseListener[] getMouseListeners​()
        返回在此组件上注册的所有鼠标监听器的数组。
        结果
        所有这个组件的 MouseListener s或一个空数组，如果没有鼠标监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addMouseListener(java.awt.event.MouseListener) ， removeMouseListener(java.awt.event.MouseListener)

      • addMouseMotionListener

        public void addMouseMotionListener​(MouseMotionListener l)
        添加指定的鼠标移动侦听器以从该组件接收鼠标移动事件。 如果监听器l为null ，则不抛出异常，不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 鼠标移动侦听器
        从以下版本开始：
        1.1
        另请参见：
        MouseEvent ， MouseMotionListener ， removeMouseMotionListener(java.awt.event.MouseMotionListener) ， getMouseMotionListeners()

      • removeMouseMotionListener

        public void removeMouseMotionListener​(MouseMotionListener l)
        删除指定的鼠标移动侦听器，使其不再从此组件接收鼠标移动事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l为null ，则不会抛出异常，并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 鼠标移动侦听器
        从以下版本开始：
        1.1
        另请参见：
        MouseEvent ， MouseMotionListener ， addMouseMotionListener(java.awt.event.MouseMotionListener) ， getMouseMotionListeners()

      • getMouseMotionListeners

        public MouseMotionListener[] getMouseMotionListeners​()
        返回在此组件上注册的所有鼠标移动侦听器的数组。
        结果
        所有这个组件的 MouseMotionListener s或一个空数组，如果没有鼠标移动侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addMouseMotionListener(java.awt.event.MouseMotionListener) ， removeMouseMotionListener(java.awt.event.MouseMotionListener)

      • addMouseWheelListener

        public void addMouseWheelListener​(MouseWheelListener l)
        添加指定的鼠标滚轮侦听器以从该组件接收鼠标滚轮事件。 容器还从子组件接收鼠标滚轮事件。

        有关如何调度鼠标滚轮事件的信息，请参阅MouseWheelEvent的类说明。

        如果l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 鼠标滚轮侦听器
        从以下版本开始：
        1.4
        另请参见：
        MouseWheelEvent ， MouseWheelListener ， removeMouseWheelListener(java.awt.event.MouseWheelListener) ， getMouseWheelListeners()

      • removeMouseWheelListener

        public void removeMouseWheelListener​(MouseWheelListener l)
        删除指定的鼠标滚轮侦听器，使其不再从此组件接收鼠标滚轮事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 鼠标滚轮侦听器。
        从以下版本开始：
        1.4
        另请参见：
        MouseWheelEvent ， MouseWheelListener ， addMouseWheelListener(java.awt.event.MouseWheelListener) ， getMouseWheelListeners()

      • getMouseWheelListeners

        public MouseWheelListener[] getMouseWheelListeners​()
        返回在此组件上注册的所有鼠标滚轮侦听器的数组。
        结果
        所有这个组件的 MouseWheelListener s或一个空数组，如果没有鼠标滚轮侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addMouseWheelListener(java.awt.event.MouseWheelListener) ， removeMouseWheelListener(java.awt.event.MouseWheelListener)

      • addInputMethodListener

        public void addInputMethodListener​(InputMethodListener l)
        添加指定的输入法侦听器以从该组件接收输入法事件。 如果一个组件还会覆盖getInputMethodRequests以返回一个InputMethodRequests实例，那么它只会从输入法接收输入法事件。 如果监听器l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 输入法侦听器
        从以下版本开始：
        1.2
        另请参见：
        InputMethodEvent ， InputMethodListener ， removeInputMethodListener(java.awt.event.InputMethodListener) ， getInputMethodListeners() ， getInputMethodRequests()

      • removeInputMethodListener

        public void removeInputMethodListener​(InputMethodListener l)
        删除指定的输入法侦听器，使其不再从此组件接收输入法事件。 如果参数指定的侦听器以前未添加到此组件中，则此方法不执行任何功能，也不会抛出异常。 如果监听器l是null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 输入法侦听器
        从以下版本开始：
        1.2
        另请参见：
        InputMethodEvent ， InputMethodListener ， addInputMethodListener(java.awt.event.InputMethodListener) ， getInputMethodListeners()

      • getInputMethodListeners

        public InputMethodListener[] getInputMethodListeners​()
        返回在此组件上注册的所有输入法侦听器的数组。
        结果
        所有这个组件的 InputMethodListener s或一个空数组，如果没有输入方法侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addInputMethodListener(java.awt.event.InputMethodListener) ， removeInputMethodListener(java.awt.event.InputMethodListener)

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册为FooListener的所有对象的数组，这个Component 。 FooListener使用addFooListener方法进行注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询Component c的鼠标监听器：

          MouseListener[] mls = (MouseListener[])(c.getListeners(MouseListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        参数类型
        T - 侦听器的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在该组件上注册为 FooListener的所有对象的数组，如果未添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType未指定实现 java.util.EventListener的类或接口
        NullPointerException - 如果 listenerType是 null
        从以下版本开始：
        1.3
        另请参见：
        getComponentListeners() ，
getFocusListeners() ，
getHierarchyListeners() ，
getHierarchyBoundsListeners() ，
getKeyListeners() ，
getMouseListeners() ，
getMouseMotionListeners() ，
getMouseWheelListeners() ，
getInputMethodListeners() ，
getPropertyChangeListeners()

      • getInputMethodRequests

        public InputMethodRequests getInputMethodRequests​()
        获取支持该组件输入法的请求的输入法请求处理程序。 支持现场文本输入的组件必须覆盖此方法以返回InputMethodRequests实例。 同时，它也必须处理输入法事件。
        结果
        该组件的输入法请求处理程序默认为 null
        从以下版本开始：
        1.2
        另请参见：
        addInputMethodListener(java.awt.event.InputMethodListener)

      • getInputContext

        public InputContext getInputContext​()
        获取此组件使用的输入上下文，以便在此组件中输入文本时处理与输入法的通信。 默认情况下，返回用于父组件的输入上下文。 组件可以覆盖此值以返回私有输入上下文。
        结果
        该组件使用的输入上下文; null如果没有上下文可以确定
        从以下版本开始：
        1.2

      • enableEvents

        protected final void enableEvents​(long eventsToEnable)
        启用由指定的事件掩码参数定义的事件传递给此组件。

        当事件类型的侦听器添加到组件时，事件类型将自动启用。

        该方法只需要由Component的子类调用，希望将指定的事件类型传递给processEvent而不管是否注册了一个监听器。

        参数
        eventsToEnable - 定义事件类型的事件掩码
        从以下版本开始：
        1.1
        另请参见：
        processEvent(java.awt.AWTEvent) ， disableEvents(long) ， AWTEvent

      • disableEvents

        protected final void disableEvents​(long eventsToDisable)
        禁用由指定事件掩码参数定义的事件传递给此组件。
        参数
        eventsToDisable - 定义事件类型的事件掩码
        从以下版本开始：
        1.1
        另请参见：
        enableEvents(long)

      • coalesceEvents

        protected AWTEvent coalesceEvents​(AWTEvent existingEvent,
                                  AWTEvent newEvent)
        潜在地合并现有事件发布的事件。 此方法由称为EventQueue.postEvent ，如果具有相同的ID为要发布的事件的事件队列中被发现（这两个事件必须具有此组件作为它们的源）。 该方法或者返回一个替换现有事件的合并事件（并且新事件被丢弃），或者null以表示不应该组合（将第二个事件添加到队列的末尾）。 任何一个事件参数都可以被修改和返回，因为另外一个被丢弃，除非返回null 。

        这个coalesceEvents实现合并了两种事件类型：鼠标移动（和拖动）事件以及绘制（和更新）事件。 对于鼠标移动事件，总是返回最后一个事件，导致中间移动被丢弃。 对于油漆事件，新事件合并成一个复杂的RepaintArea在同行。 新的AWTEvent总是返回。

        参数
        existingEvent - 事件已经在 EventQueue
        newEvent - 事件发布到 EventQueue
        结果
        合并事件，或 null表示没有合并完成

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理在此组件上发生的事件。 默认情况下，该方法为给定类的事件调用适当的process<event type>Event方法。

        请注意，如果事件参数为null该行为未指定，可能会导致异常。

        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        processComponentEvent(java.awt.event.ComponentEvent) ，
processFocusEvent(java.awt.event.FocusEvent) ，
processKeyEvent(java.awt.event.KeyEvent) ，
processMouseEvent(java.awt.event.MouseEvent) ，
processMouseMotionEvent(java.awt.event.MouseEvent) ，
processInputMethodEvent(java.awt.event.InputMethodEvent) ，
processHierarchyEvent(java.awt.event.HierarchyEvent) ，
processMouseWheelEvent(java.awt.event.MouseWheelEvent)

      • processComponentEvent

        protected void processComponentEvent​(ComponentEvent e)
        通过将组件事件发送到任何注册的ComponentListener对象来处理此组件上发生的组件事件。

        除非为此组件启用组件事件，否则不会调用此方法。 当以下情况发生时，组件事件被启用：

        • A ComponentListener对象通过addComponentListener注册。
        • 组件事件通过enableEvents启用。

        请注意，如果事件参数为null该行为是未指定的，可能会导致异常。

        参数
        e - 组件事件
        从以下版本开始：
        1.1
        另请参见：
        ComponentEvent ， ComponentListener ， addComponentListener(java.awt.event.ComponentListener) ， enableEvents(long)

      • processFocusEvent

        protected void processFocusEvent​(FocusEvent e)
        通过将这些事件发送到任何已注册的FocusListener对象来处理发生在该组件上的焦点事件。

        除非为此组件启用聚焦事件，否则不会调用此方法。 当以下情况发生时，聚焦事件将被启用：

        • A FocusListener对象通过addFocusListener注册。
        • 焦点事件通过enableEvents启用。

        如果焦点事件，启用Component ，目前KeyboardFocusManager确定焦点事件是否应该被分派到注册FocusListener对象。 如果要发送事件， KeyboardFocusManager调用Component的dispatchEvent方法，这将调用Component的processFocusEvent方法。

        如果Component启用了焦点事件， Component FocusEvent作为参数调用Component的dispatchEvent方法将导致调用Component的processFocusEvent方法，而不管当前的KeyboardFocusManager 。

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        参数
        e - 焦点事件
        从以下版本开始：
        1.1
        另请参见：
        FocusEvent ， FocusListener ， KeyboardFocusManager ， addFocusListener(java.awt.event.FocusListener) ， enableEvents(long) ， dispatchEvent(java.awt.AWTEvent)

      • processKeyEvent

        protected void processKeyEvent​(KeyEvent e)
        通过将这些事件发送到任何已注册的KeyListener对象来处理此组件上发生的关键事件。

        除非为此组件启用了关键事件，否则不会调用此方法。 如果出现以下情况之一，则启用主要事件：

        • A KeyListener对象通过addKeyListener注册。
        • 关键事件通过enableEvents启用。

        如果为Component启用了密钥事件，则当前的KeyboardFocusManager确定是否应将密钥事件分派到已注册的KeyListener对象。 DefaultKeyboardFocusManager不会将关键事件发送到不是焦点所有者或未显示的Component 。

        从J2SE 1.4起， KeyEvent被重定向到焦点所有者。 详情请参阅Focus Specification 。

        使用KeyEvent作为参数调用Component的dispatchEvent方法将导致调用Component的processKeyEvent方法，而不考虑当前的KeyboardFocusManager ，只要组件显示，聚焦和启用，并且其上启用了关键事件。

        如果事件参数是null ，行为是未指定的，可能会导致异常。

        参数
        e - 关键事件
        从以下版本开始：
        1.1
        另请参见：
        KeyEvent ， KeyListener ， KeyboardFocusManager ， DefaultKeyboardFocusManager ， processEvent(java.awt.AWTEvent) ， dispatchEvent(java.awt.AWTEvent) ， addKeyListener(java.awt.event.KeyListener) ， enableEvents(long) ， isShowing()

      • processMouseEvent

        protected void processMouseEvent​(MouseEvent e)
        通过将鼠标事件发送到任何已注册的MouseListener对象来处理此组件上发生的鼠标事件。

        除非启用此组件的鼠标事件，否则不会调用此方法。 当发生以下情况之一时，启用鼠标事件：

        • A MouseListener对象通过addMouseListener注册。
        • 鼠标事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 鼠标事件
        从以下版本开始：
        1.1
        另请参见：
        MouseEvent ， MouseListener ， addMouseListener(java.awt.event.MouseListener) ， enableEvents(long)

      • processMouseMotionEvent

        protected void processMouseMotionEvent​(MouseEvent e)
        通过将这些组件发送到任何已注册的MouseMotionListener对象来处理发生在该组件上的鼠标运动事件。

        除非为此组件启用鼠标运动事件，否则不会调用此方法。 当发生以下其中一种情况时，启动鼠标运动事件：

        • A MouseMotionListener对象通过addMouseMotionListener注册。
        • 通过enableEvents启用鼠标运动事件。

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        参数
        e - 鼠标运动事件
        从以下版本开始：
        1.1
        另请参见：
        MouseEvent ， MouseMotionListener ， addMouseMotionListener(java.awt.event.MouseMotionListener) ， enableEvents(long)

      • processMouseWheelEvent

        protected void processMouseWheelEvent​(MouseWheelEvent e)
        通过将鼠标滚轮事件发送到任何注册的MouseWheelListener对象来处理鼠标滚轮事件。

        除非为此组件启用鼠标滚轮事件，否则不会调用此方法。 当发生以下情况之一时，鼠标滚轮事件被启用：

        • A MouseWheelListener对象通过addMouseWheelListener注册。
        • 鼠标滚轮事件通过enableEvents启用。

        有关如何调度鼠标滚轮事件的信息，请参阅MouseWheelEvent的类说明。

        请注意，如果事件参数是null ，行为是未指定的，可能会导致异常。

        参数
        e - 鼠标滚轮事件
        从以下版本开始：
        1.4
        另请参见：
        MouseWheelEvent ， MouseWheelListener ， addMouseWheelListener(java.awt.event.MouseWheelListener) ， enableEvents(long)

      • processInputMethodEvent

        protected void processInputMethodEvent​(InputMethodEvent e)
        通过将此组件发送到任何已注册的InputMethodListener对象来处理在此组件上发生的输入方法事件。

        除非为此组件启用输入方法事件，否则不调用此方法。 当发生以下其中一种情况时，将启用输入法事件：

        • 一个InputMethodListener对象通过addInputMethodListener注册。
        • 通过enableEvents启用输入法事件。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 输入法事件
        从以下版本开始：
        1.2
        另请参见：
        InputMethodEvent ， InputMethodListener ， addInputMethodListener(java.awt.event.InputMethodListener) ， enableEvents(long)

      • processHierarchyEvent

        protected void processHierarchyEvent​(HierarchyEvent e)
        通过将这些组件调度到任何已注册的HierarchyListener对象来处理此组件上发生的层次结构事件。

        除非为此组件启用层次结构事件，否则不调用此方法。 当发生以下情况之一时，启用层次结构事件：

        • 通过addHierarchyListener注册一个HierarchyListener对象。
        • 层次结构事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 层次结构事件
        从以下版本开始：
        1.3
        另请参见：
        HierarchyEvent ， HierarchyListener ， addHierarchyListener(java.awt.event.HierarchyListener) ， enableEvents(long)

      • processHierarchyBoundsEvent

        protected void processHierarchyBoundsEvent​(HierarchyEvent e)
        进程层次结构通过HierarchyBoundsListener到任何已注册的HierarchyBoundsListener对象来限制发生在该组件上的事件。

        除非为该组件启用层次结构限制事件，否则不调用此方法。 当发生以下情况之一时，启用层次结构边界事件：

        • 一个HierarchyBoundsListener对象通过addHierarchyBoundsListener注册。
        • 层次enableEvents事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 层次结构事件
        从以下版本开始：
        1.3
        另请参见：
        HierarchyEvent ， HierarchyBoundsListener ， addHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener) ， enableEvents(long)

      • handleEvent

        @Deprecated
public boolean handleEvent​(Event evt)
        已过时。 从JDK版本1.1替换为processEvent（AWTEvent）。
        参数
        evt - 要处理的事件
        结果
        true如果事件处理，否则为 false

      • mouseDown

        @Deprecated
public boolean mouseDown​(Event evt,
                         int x,
                         int y)
        已过时。 从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
        参数
        evt - 要处理的事件
        x - x坐标
        y - y坐标
        结果
        false

      • mouseDrag

        @Deprecated
public boolean mouseDrag​(Event evt,
                         int x,
                         int y)
        已过时。 从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
        参数
        evt - 事件处理
        x - x坐标
        y - y坐标
        结果
        false

      • mouseUp

        @Deprecated
public boolean mouseUp​(Event evt,
                       int x,
                       int y)
        已过时。 从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
        参数
        evt - 处理事件
        x - x坐标
        y - y坐标
        结果
        false

      • mouseMove

        @Deprecated
public boolean mouseMove​(Event evt,
                         int x,
                         int y)
        已过时。 从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
        参数
        evt - 事件处理
        x - x坐标
        y - y坐标
        结果
        false

      • mouseEnter

        @Deprecated
public boolean mouseEnter​(Event evt,
                          int x,
                          int y)
        已过时。 从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
        参数
        evt - 事件处理
        x - x坐标
        y - y坐标
        结果
        false

      • mouseExit

        @Deprecated
public boolean mouseExit​(Event evt,
                         int x,
                         int y)
        已过时。 从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
        参数
        evt - 要处理的事件
        x - x坐标
        y - y坐标
        结果
        false

      • keyDown

        @Deprecated
public boolean keyDown​(Event evt,
                       int key)
        已过时。 从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
        参数
        evt - 处理事件
        key - 按键
        结果
        false

      • keyUp

        @Deprecated
public boolean keyUp​(Event evt,
                     int key)
        已过时。 从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
        参数
        evt - 事件处理
        key - 按键
        结果
        false

      • action

        @Deprecated
public boolean action​(Event evt,
                      Object what)
        已过时。 从JDK 1.1版开始，应该在组件上注册此组件作为ActionListener，该组件将触发动作事件。
        参数
        evt - 事件处理
        what - what的对象
        结果
        false

      • addNotify

        public void addNotify​()
        将此Component连接到本机屏幕资源。 该方法由工具包内部调用，不应由程序直接调用。

        该方法更改布局相关信息，因此使组件层次结构无效。

        从以下版本开始：
        1.0
        另请参见：
        isDisplayable() ，
removeNotify() ，
invalidate()

      • removeNotify

        public void removeNotify​()
        使这个Component通过破坏它的本机屏幕资源而不可显示。

        该方法在内部被工具包调用，不应该被程序直接调用。 覆盖此方法的代码应调用super.removeNotify作为覆盖方法的第一行。

        从以下版本开始：
        1.0
        另请参见：
        isDisplayable() ， addNotify()

      • gotFocus

        @Deprecated
public boolean gotFocus​(Event evt,
                        Object what)
        已过时。 从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
        参数
        evt - 处理事件
        what - 对象集中
        结果
        false

      • lostFocus

        @Deprecated
public boolean lostFocus​(Event evt,
                         Object what)
        已过时。 从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
        参数
        evt - 处理事件
        what - 对象集中
        结果
        false

      • isFocusTraversable

        @Deprecated
public boolean isFocusTraversable​()
        已过时。 截至1.4，由isFocusable()取代。
        返回这个 Component是否可以成为焦点所有者。
        结果
        true如果这个Component是可Component的; 否则为false
        从以下版本开始：
        1.1
        另请参见：
        setFocusable(boolean)

      • isFocusable

        public boolean isFocusable​()
        返回是否可以对该Component进行聚焦。
        结果
        true如果此组件可true ; 否则为false 。
        从以下版本开始：
        1.4
        另请参见：
        setFocusable(boolean)

      • setFocusable

        public void setFocusable​(boolean focusable)
        将此组件的可聚焦状态设置为指定的值。 此值覆盖组件的默认焦点。
        参数
        focusable - 指示此组件是否可 focusable
        从以下版本开始：
        1.4
        另请参见：
        isFocusable()

      • setFocusTraversalKeys

        public void setFocusTraversalKeys​(int id,
                                  Set<? extends AWTKeyStroke> keystrokes)
        设置此组件给定遍历操作的焦点遍历键。

        组件焦点遍历键的默认值与实现相关。 Sun建议特定本地平台的所有实现使用相同的默认值。 Windows和Unix的建议如下。 这些建议用于Sun AWT实现。

        Recommended default values for a Component's focus traversal keys Identifier Meaning Default KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS Normal forward keyboard traversal TAB on KEY_PRESSED, CTRL-TAB on KEY_PRESSED KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS Normal reverse keyboard traversal SHIFT-TAB on KEY_PRESSED, CTRL-SHIFT-TAB on KEY_PRESSED KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS Go up one focus traversal cycle none
        要禁用遍历键，请使用空的Set; 推荐使用Collections.EMPTY_SET。

        使用AWTKeyStroke API，客户端代码可以指定两个特定的KeyEvent，KEY_PRESSED或KEY_RELEASED中的哪一个，焦点遍历操作将发生。 然而，无论指定了哪个KeyEvent，与焦点遍历密钥相关的所有KeyEvent都将被使用，包括关联的KEY_TYPED事件，并且不会被分派到任何组件。 指定一个KEY_TYPED事件作为映射到焦点遍历操作的运行时错误，或将同一事件映射到多个默认焦点遍历操作。

        如果为Set指定了null值，则此Component将从其父项继承Set。 如果此组件的所有祖先对于Set指定了空值，则使用当前的KeyboardFocusManager的默认Set。

        这种方法可能抛出ClassCastException如有Object在keystrokes不是AWTKeyStroke 。

        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS或KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS之一
        keystrokes - 指定操作的AWTKeyStroke集
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS或KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS中的一个，或者如果键击包含null，或者如果任何键击代表KEY_TYPED事件，或者如果任何键击已经映射到此组件的另一个焦点遍历操作
        从以下版本开始：
        1.4
        另请参见：
        getFocusTraversalKeys(int) ， KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS

      • getFocusTraversalKeys

        public Set<AWTKeyStroke> getFocusTraversalKeys​(int id)
        返回此组件的给定遍历操作的聚焦遍历键集。 （有关每个键的完整说明，请参阅setFocusTraversalKeys ）

        如果尚未为此组件显式定义一组遍历键，则返回此组件的父级集。 如果没有为任何此组件的祖先显式定义Set，则返回当前的KeyboardFocusManager的默认Set。

        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS或KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS之一
        结果
        指定操作的AWTKeyStrokes集。 该集将不可修改，可能为空。 将永远不会返回null。
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS或KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS中的一个
        从以下版本开始：
        1.4
        另请参见：
        setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS

      • areFocusTraversalKeysSet

        public boolean areFocusTraversalKeysSet​(int id)
        返回是否为此组件显式定义了给定焦点遍历操作的聚焦遍历键集。 如果此方法返回false ，则此Component将从祖先继承Set，或从当前的KeyboardFocusManager继承。
        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS或KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS之一
        结果
        true如果为该组件明确定义了给定焦点遍历操作的聚焦遍历键集合; false否则。
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS或KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS中的一个
        从以下版本开始：
        1.4

      • setFocusTraversalKeysEnabled

        public void setFocusTraversalKeysEnabled​(boolean focusTraversalKeysEnabled)
        设置是否为此组件启用对焦遍历键。 禁用焦点遍历键的组件接收焦点遍历键的键事件。 启用焦点遍历键的组件不会看到这些事件; 而是将事件自动转换为遍历操作。
        参数
        focusTraversalKeysEnabled - 是否为此组件启用对焦遍历键
        从以下版本开始：
        1.4
        另请参见：
        getFocusTraversalKeysEnabled() ，
setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ，
getFocusTraversalKeys(int)

      • getFocusTraversalKeysEnabled

        public boolean getFocusTraversalKeysEnabled​()
        返回是否为此组件启用焦点遍历键。 禁用焦点遍历键的组件接收焦点遍历键的键事件。 启用焦点遍历键的组件不会看到这些事件; 而是将事件自动转换为遍历操作。
        结果
        是否为此组件启用对焦遍历键
        从以下版本开始：
        1.4
        另请参见：
        setFocusTraversalKeysEnabled(boolean) ， setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， getFocusTraversalKeys(int)

      • requestFocus

        public void requestFocus​()
        请求此组件获取输入焦点，并且该组件的顶级祖先成为关注的窗口。 该组件必须是可显示的，可聚焦的，可见的，并且所有的祖先（除了顶级窗口除外）必须对于被授予的请求可见。 将竭尽全力尊重这一要求; 然而，在某些情况下，这可能是不可能的。 开发人员绝不能假定此组件是焦点拥有者，直到本组件收到FOCUS_GAINED事件为止。 如果此请求被拒绝，因为该组件的顶级窗口不能成为关注的窗口，则请求将被记住，并且将在窗口稍后被用户关注时被授予。

        该方法无法用于将焦点所有者设置为无任何组件。 改用KeyboardFocusManager.clearGlobalFocusOwner() 。

        由于此方法的重点行为与平台有关，因此强烈建议开发人员尽可能使用requestFocusInWindow 。

        注意：并非所有的焦点传输都是通过调用此方法。 因此，组件可以接收焦点，而不调用Component的其他requestFocus方法。

        从以下版本开始：
        1.0
        另请参见：
        requestFocusInWindow() ， FocusEvent ， addFocusListener(java.awt.event.FocusListener) ， isFocusable() ， isDisplayable() ， KeyboardFocusManager.clearGlobalFocusOwner()

      • requestFocus

        public void requestFocus​(FocusEvent.Cause cause)
        由于cause ，该组件获得输入焦点，并且该组件的顶级祖先成为关注的窗口。 该组件必须是可显示的，可聚焦的，可见的，并且所有的祖先（除了顶级窗口除外）必须对于被授予的请求可见。 将竭尽全力尊重这一要求; 然而，在某些情况下，这可能是不可能的。 开发人员绝不能假定此组件是焦点拥有者，直到本组件收到FOCUS_GAINED事件为止。

        焦点请求效果还可能取决于提供的原因值。 如果该请求成功， FocusEvent生成的FocusEvent将收到指定为方法参数的原因值。 如果此请求被拒绝，因为该组件的顶级窗口不能成为关注的窗口，则请求将被记住，并且将在窗口稍后被用户关注时被授予。

        该方法无法用于将焦点所有者设置为无任何组件。 改用KeyboardFocusManager.clearGlobalFocusOwner() 。

        由于此方法的重点行为与平台有关，因此强烈建议开发人员尽可能使用requestFocusInWindow(FocusEvent.Cause) 。

        注意：并非所有的焦点传输都是通过调用此方法。 因此，组件可以接收焦点，而不会调用Component的其他requestFocus方法。

        参数
        cause - 要求焦点的原因
        从以下版本开始：
        9
        另请参见：
        FocusEvent ， FocusEvent.Cause ， requestFocusInWindow(FocusEvent.Cause) ， FocusEvent ， addFocusListener(java.awt.event.FocusListener) ， isFocusable() ， isDisplayable() ， KeyboardFocusManager.clearGlobalFocusOwner()

      • requestFocus

        protected boolean requestFocus​(boolean temporary)
        要求这个Component得到输入焦点，而这个Component的顶级祖先成为焦点Window 。 该组件必须是可显示的，可聚焦的，可见的，并且所有的祖先（除了顶级窗口除外）必须对于被授予的请求可见。 将竭尽全力尊重这一要求; 然而，在某些情况下，这可能是不可能的。 开发者绝不能假定该组件是焦点所有者，直到该组件收到FOCUS_GAINED事件为止。 如果此请求被拒绝，因为该组件的顶级窗口不能成为关注的窗口，则该请求将被记住，并且将在窗口稍后被用户关注时被授予。

        此方法返回一个布尔值。 如果返回false ，请求保证失败 。 如果返回true ，则除非被否决， 否则请求将成功， 否则在本地窗口系统授予请求之前会发生特殊事件，例如组件对等体的处理。 同样，当返回值为true表示请求可能成功时，开发人员不能假定该组件是焦点所有者，直到该组件收到FOCUS_GAINED事件为止。

        该方法无法用于将焦点所有者设置为无任何组件。 改用KeyboardFocusManager.clearGlobalFocusOwner 。

        由于此方法的重点行为与平台有关，因此强烈建议开发人员尽可能使用requestFocusInWindow 。

        将尽一切努力确保由此请求产生的FocusEvent s将具有指定的临时值。 但是，由于指定任意临时状态在所有本机窗口系统上可能无法实现，所以只有轻型Component才能保证此方法的正确行为。 此方法不适用于一般用途，而是作为轻量级组件库（如Swing）的钩子而存在。

        注意：并非所有的焦点传输都是通过调用此方法。 因此，组件可以接收焦点，而不会调用Component的其他requestFocus方法。

        参数
        temporary - 如果焦点更改是临时的，例如当窗口失去焦点时， temporary true; 有关临时焦点变化的更多信息，请参阅Focus Specification
        结果
        false如果焦点更改请求保证失败; true如果有可能成功
        从以下版本开始：
        1.4
        另请参见：
        FocusEvent ， addFocusListener(java.awt.event.FocusListener) ， isFocusable() ， isDisplayable() ， KeyboardFocusManager.clearGlobalFocusOwner()

      • requestFocus

        protected boolean requestFocus​(boolean temporary,
                               FocusEvent.Cause cause)
        由于cause ，这个Component得到了输入焦点，而这个Component的顶级祖先成为焦点Window 。 该组件必须是可显示的，可聚焦的，可见的，并且所有的祖先（除了顶级窗口除外）必须对于被授予的请求可见。 将竭尽全力尊重这一要求; 然而，在某些情况下，这可能是不可能的。 开发者绝不能假定该组件是焦点所有者，直到该组件收到FOCUS_GAINED事件为止。 如果此请求被拒绝，因为该组件的顶级窗口不能成为关注的窗口，则该请求将被记住，并且将在窗口稍后被用户关注时被授予。

        此方法返回一个布尔值。 如果返回false ，请求保证失败 。 如果返回true ， 除非被否决， 否则请求将成功， 否则会在本地窗口系统授予请求之前发生特殊事件，例如处理组件的对等体。 同样，当返回值为true表示请求可能成功时，开发人员不能假定该组件是焦点所有者，直到该组件接收到FOCUS_GAINED事件为止。

        焦点请求效果还可能取决于提供的原因值。 如果此请求成功，结果中生成的{FocusEvent}将会收到指定为该方法参数的原因值。

        该方法无法用于将焦点所有者设置为无任何组件。 改用KeyboardFocusManager.clearGlobalFocusOwner 。

        由于这种方法的重点行为是平台依赖性的，所以强烈建议开发人员尽可能使用requestFocusInWindow 。

        将尽一切努力确保由此请求产生的FocusEvent s将具有指定的临时值。 但是，由于指定任意临时状态在所有本机窗口系统上可能无法实现，所以只有轻量级的Component可以保证此方法的正确行为。 此方法不适用于一般用途，而是作为轻量级组件库（如Swing）的钩子而存在。

        注意：并非所有的焦点传输都是通过调用此方法。 因此，组件可以接收焦点，而不调用Component的其他requestFocus方法。

        参数
        temporary - 如果焦点更改是临时的，例如当窗口失去焦点时， temporary true; 有关临时焦点变化的更多信息，请参阅Focus Specification
        cause - 要求焦点的原因
        结果
        false如果焦点更改请求保证失败; true如果有可能成功
        从以下版本开始：
        9
        另请参见：
        FocusEvent ， FocusEvent.Cause ， addFocusListener(java.awt.event.FocusListener) ， isFocusable() ， isDisplayable() ， KeyboardFocusManager.clearGlobalFocusOwner()

      • requestFocusInWindow

        public boolean requestFocusInWindow​()
        要求此组件获取输入焦点，如果此组件的顶级祖先已经是关注的窗口。 该组件必须是可显示的，可聚焦的，可见的，并且所有的祖先（除了顶级窗口除外）必须对于被授予的请求可见。 将竭尽全力尊重这一要求; 然而，在某些情况下，这可能是不可能的。 开发人员绝不能假定此组件是焦点拥有者，直到本组件收到FOCUS_GAINED事件为止。

        此方法返回一个布尔值。 如果返回false ，则请求将保证失败 。 如果返回true ， 除非被否决， 否则请求将成功， 否则 ，在本地窗口系统授予请求之前，会发生特殊事件（如组件对等体的处理）。 同样，当返回值为true表示请求可能成功时，开发人员不能假定此组件是焦点所有者，直到此组件收到FOCUS_GAINED事件为止。

        该方法无法用于将焦点所有者设置为无任何组件。 改用KeyboardFocusManager.clearGlobalFocusOwner() 。

        该方法的重点行为可以跨平台统一实现，因此，强烈建议开发人员尽可能地使用此方法requestFocus 。 依赖于requestFocus代码可能会在不同平台上展示不同的焦点行为。

        注意：并非所有的焦点传输都是通过调用此方法。 因此，组件可以接收焦点，而不会调用Component的其他requestFocus方法。

        结果
        false如果焦点更改请求保证失败; true如果有可能成功
        从以下版本开始：
        1.4
        另请参见：
        requestFocus() ， FocusEvent ， addFocusListener(java.awt.event.FocusListener) ， isFocusable() ， isDisplayable() ， KeyboardFocusManager.clearGlobalFocusOwner()

      • requestFocusInWindow

        public boolean requestFocusInWindow​(FocusEvent.Cause cause)
        由于cause的原因，该组件获得输入焦点，如果此组件的顶级祖先已经是关注的窗口。 该组件必须是可显示的，可聚焦的，可见的，并且所有的祖先（除了顶级窗口除外）必须对于被授予的请求可见。 将竭尽全力尊重这一要求; 然而，在某些情况下，这可能是不可能的。 开发人员绝不能假定此组件是焦点拥有者，直到本组件收到FOCUS_GAINED事件为止。

        此方法返回一个布尔值。 如果返回false ，请求保证失败 。 如果返回true ，则除非被否决， 否则请求将成功， 否则在本地窗口系统授予请求之前，会发生特殊事件（例如组件对等体的处理）。 同样，当返回值为true表示请求可能成功时，开发人员不能假定此组件是焦点所有者，直到此组件收到FOCUS_GAINED事件为止。

        焦点请求效果还可能取决于提供的原因值。 如果该请求成功， FocusEvent生成的FocusEvent将收到指定为该方法参数的原因值。

        该方法无法用于将焦点所有者设置为无任何组件。 改用KeyboardFocusManager.clearGlobalFocusOwner() 。

        这种方法的重点行为可以跨平台实现，因此，强烈建议开发人员尽可能地使用这种方法超过requestFocus(FocusEvent.Cause) 。 依赖于requestFocus(FocusEvent.Cause)代码可能会在不同平台上展示不同的焦点行为。

        注意：并非所有的焦点传输都是通过调用此方法。 因此，组件可以接收焦点，而不会调用Component的其他requestFocus方法。

        参数
        cause - 要求焦点的原因
        结果
        false如果焦点更改请求保证失败; true如果有可能成功
        从以下版本开始：
        9
        另请参见：
        requestFocus(FocusEvent.Cause) ， FocusEvent ， FocusEvent.Cause ， FocusEvent ， addFocusListener(java.awt.event.FocusListener) ， isFocusable() ， isDisplayable() ， KeyboardFocusManager.clearGlobalFocusOwner()

      • requestFocusInWindow

        protected boolean requestFocusInWindow​(boolean temporary)
        要求这个Component得到输入焦点，如果这个Component的顶级祖先已经是焦点Window 。 该组件必须是可显示的，可聚焦的，可见的，并且所有的祖先（除了顶级窗口除外）必须对于被授予的请求可见。 将竭尽全力尊重这一要求; 然而，在某些情况下，这可能是不可能的。 开发者绝不能假定该组件是焦点所有者，直到该组件收到FOCUS_GAINED事件为止。

        此方法返回一个布尔值。 如果返回false ，则请求将被保证失败 。 如果返回true ，则除非被否决， 否则请求将成功， 否则在本地窗口系统授予请求之前，会发生特殊事件（如组件对等体的处理）。 同样，当返回值为true表示请求可能成功时，开发人员不能假定该组件是焦点所有者，直到该组件接收到FOCUS_GAINED事件为止。

        该方法无法用于将焦点所有者设置为无任何组件。 改用KeyboardFocusManager.clearGlobalFocusOwner 。

        这种方法的重点行为可以跨平台实现，因此，强烈建议开发人员在可能的情况下使用该方法超过requestFocus 。 依赖于requestFocus代码可能会在不同的平台上显示不同的焦点行为。

        将尽一切努力确保由此请求产生的FocusEvent s将具有指定的临时值。 但是，由于指定任意临时状态在所有本机窗口系统上可能无法实现，因此只能为轻量级组件确保此方法的正确行为。 此方法不适用于一般用途，而是作为轻量级组件库（如Swing）的钩子而存在。

        注意：并非所有的焦点传输都是通过调用此方法。 因此，组件可以接收焦点，而不会调用Component的其他requestFocus方法。

        参数
        temporary - 如果焦点更改是临时的，例如当窗口失去焦点时， temporary true; 有关临时焦点变化的更多信息，请参阅Focus Specification
        结果
        false如果焦点改变请求被保证失败; true如果有可能成功
        从以下版本开始：
        1.4
        另请参见：
        requestFocus() ， FocusEvent ， addFocusListener(java.awt.event.FocusListener) ， isFocusable() ， isDisplayable() ， KeyboardFocusManager.clearGlobalFocusOwner()

      • getFocusCycleRootAncestor

        public Container getFocusCycleRootAncestor​()
        返回作为该组件焦点遍历循环的焦点循环根的容器。 每个焦点遍历循环只有一个焦点循环根，而不是一个容器的每个组件只属于单个焦点遍历循环。 作为焦点循环根的容器属于两个循环：一个根据容器本身，一个根据容器最近的聚焦循环根祖先。 对于这样的容器，此方法将返回Container最近的focus-cycle-roots祖先。
        结果
        该组件最近的焦点循环根祖先
        从以下版本开始：
        1.4
        另请参见：
        Container.isFocusCycleRoot()

      • isFocusCycleRoot

        public boolean isFocusCycleRoot​(Container container)
        返回指定的Container是否是此组件焦点遍历周期的焦点循环根。 每个焦点遍历循环只有一个焦点循环根，而不是一个容器的每个组件只属于单个焦点遍历循环。
        参数
        container - 要测试的容器
        结果
        true如果指定的Container是此组件的焦点true根; 否则为false
        从以下版本开始：
        1.4
        另请参见：
        Container.isFocusCycleRoot()

      • transferFocus

        public void transferFocus​()
        将焦点转移到下一个组件，就像这个组件是焦点所有者一样。
        从以下版本开始：
        1.1
        另请参见：
        requestFocus()

      • nextFocus

        @Deprecated
public void nextFocus​()
        已过时。 从JDK 1.1版开始，由transferFocus（）替换。

      • transferFocusBackward

        public void transferFocusBackward​()
        将焦点转移到以前的组件，就像这个组件是焦点所有者一样。
        从以下版本开始：
        1.4
        另请参见：
        requestFocus()

      • transferFocusUpCycle

        public void transferFocusUpCycle​()
        将焦点转移到一个焦点遍历周期。 通常，焦点所有者设置为此组件的焦点循环根，并将当前焦点循环根设置为新焦点所有者的焦点循环根。 但是，如果此组件的焦点循环根为Window，则焦点所有者将设置为焦点循环根的默认组件以进行对焦，并且当前焦点循环根未更改。
        从以下版本开始：
        1.4
        另请参见：
        requestFocus() ，
Container.isFocusCycleRoot() ，
Container.setFocusCycleRoot(boolean)

      • hasFocus

        public boolean hasFocus​()
        如果这个Component是焦点所有者，则返回true 。 此方法已过时，已被替换为isFocusOwner() 。
        结果
        true如果这个Component是焦点所有者; false否则
        从以下版本开始：
        1.2

      • isFocusOwner

        public boolean isFocusOwner​()
        如果这个 Component是焦点所有者，则返回 true 。
        结果
        true如果这个Component是焦点所有者; 否则为false
        从以下版本开始：
        1.4

      • add

        public void add​(PopupMenu popup)
        将指定的弹出菜单添加到组件。
        参数
        popup - 要添加到组件的弹出菜单。
        异常
        NullPointerException - 如果 popup是 null
        从以下版本开始：
        1.1
        另请参见：
        remove(MenuComponent)

      • remove

        public void remove​(MenuComponent popup)
        从组件中删除指定的弹出菜单。
        Specified by:
        remove在接口 MenuContainer
        参数
        popup - 要删除的弹出菜单
        从以下版本开始：
        1.1
        另请参见：
        add(PopupMenu)

      • paramString

        protected String paramString​()
        返回表示此组件状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        结果
        该组件状态的字符串表示形式
        从以下版本开始：
        1.0

      • toString

        public String toString​()
        返回此组件及其值的字符串表示形式。
        重写：
        toString在 Object
        结果
        该组件的字符串表示形式
        从以下版本开始：
        1.0

      • list

        public void list​()
        将该组件的列表打印到标准系统输出流 System.out 。
        从以下版本开始：
        1.0
        另请参见：
        System.out

      • list

        public void list​(PrintStream out)
        将此组件的列表打印到指定的输出流。
        参数
        out - 打印流
        异常
        NullPointerException - 如果 out是 null
        从以下版本开始：
        1.0

      • list

        public void list​(PrintStream out,
                 int indent)
        从指定的缩进开始列出指定的打印流的列表。
        参数
        out - 打印流
        indent - 缩进的空格数
        异常
        NullPointerException - 如果 out是 null
        从以下版本开始：
        1.0
        另请参见：
        PrintStream.println(java.lang.Object)

      • list

        public void list​(PrintWriter out)
        将列表打印到指定的打印作者。
        参数
        out - 要打印的打印作者
        异常
        NullPointerException - 如果 out是 null
        从以下版本开始：
        1.1

      • list

        public void list​(PrintWriter out,
                 int indent)
        从指定的缩进开始列出指定的打印作者的列表。
        参数
        out - 要打印的打印作者
        indent - 要缩进的空格数
        异常
        NullPointerException - 如果 out是 null
        从以下版本开始：
        1.1
        另请参见：
        PrintStream.println(java.lang.Object)

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        将PropertyChangeListener添加到侦听器列表。 监听器已注册到此类的所有绑定属性，包括以下内容：
        • 这个组件的字体（“font”）
        • 此组件的背景颜色（“背景”）
        • 此组件的前景色（“前景”）
        • 该组件的可重点性（“可聚焦”）
        • 此组件的焦点遍历键启用状态（“focusTraversalKeysEnabled”）
        • 此组件的FORWARD_TRAVERSAL_KEYS（“forwardFocusTraversalKeys”）
        • 此组件的BACKWARD_TRAVERSAL_KEYS（“backwardFocusTraversalKeys”）
        • 此组件的UP_CYCLE_TRAVERSAL_KEYS（“upCycleFocusTraversalKeys”）
        • 此组件的首选大小（“preferredSize”）
        • 此组件的最小尺寸（“minimumSize”）
        • 此组件的最大大小（“maximumSize”）
        • 此组件的名称（“名称”）
        请注意，如果这个Component正在继承绑定属性，那么在继承属性的更改中将不会触发任何事件。

        如果listener是null ，则不会抛出异常，也不会执行任何操作。

        参数
        listener - 要添加的属性更改侦听器
        另请参见：
        removePropertyChangeListener(java.beans.PropertyChangeListener) ，
getPropertyChangeListeners() ，
addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener)

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener listener)
        从侦听器列表中移除PropertyChangeListener。 该方法应用于删除已为此类的所有绑定属性注册的PropertyChangeListeners。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        参数
        listener - 要删除的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ，
getPropertyChangeListeners() ，
removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​()
        返回在此组件上注册的所有属性更改侦听器的数组。
        结果
        所有这个组件的 PropertyChangeListener s或一个空数组，如果没有属性更改侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ，
removePropertyChangeListener(java.beans.PropertyChangeListener) ，
getPropertyChangeListeners(java.lang.String) ，
PropertyChangeSupport.getPropertyChangeListeners()

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String propertyName,
                                      PropertyChangeListener listener)
        将PropertyChangeListener添加到特定属性的侦听器列表中。 指定的属性可能是用户定义的，也可能是以下之一：
        • 这个组件的字体（“font”）
        • 此组件的背景颜色（“背景”）
        • 此组件的前景色（“前景”）
        • 该组件的可重点性（“可聚焦”）
        • 此组件的焦点遍历键启用状态（“focusTraversalKeysEnabled”）
        • 此组件的FORWARD_TRAVERSAL_KEYS（“forwardFocusTraversalKeys”）
        • 此组件的BACKWARD_TRAVERSAL_KEYS（“backwardFocusTraversalKeys”）
        • 此组件的UP_CYCLE_TRAVERSAL_KEYS（“upCycleFocusTraversalKeys”）
        请注意，如果此Component正在继承绑定属性，那么在继承属性的更改中将不会触发任何事件。

        如果propertyName或listener为null ，则不会抛出异常并且不采取任何操作。

        参数
        propertyName - 上面列出的属性名称之一
        listener - 要添加的属性更改侦听器
        另请参见：
        removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener) ，
getPropertyChangeListeners(java.lang.String) ，
addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener)

      • removePropertyChangeListener

        public void removePropertyChangeListener​(String propertyName,
                                         PropertyChangeListener listener)
        从侦听器列表中删除特定属性的PropertyChangeListener 。 该方法应用于删除已注册为特定绑定属性的PropertyChangeListener 。

        如果propertyName或listener为null ，则不会抛出异常，不执行任何操作。

        参数
        propertyName - 有效的属性名称
        listener - 要删除的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener) ，
getPropertyChangeListeners(java.lang.String) ，
removePropertyChangeListener(java.beans.PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
        返回与named属性相关联的所有侦听器的数组。
        参数
        propertyName - 属性名称
        结果
        所有的PropertyChangeListener s与命名的属性相关联; 如果没有添加这样的侦听器，或者如果propertyName是null ，则返回一个空数组
        从以下版本开始：
        1.4
        另请参见：
        addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener) ，
removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener) ，
getPropertyChangeListeners()

      • firePropertyChange

        protected void firePropertyChange​(String propertyName,
                                  Object oldValue,
                                  Object newValue)
        支持报告对象属性的绑定属性更改。 当绑定属性已更改时，可以调用此方法，并且将向适当的PropertyChangeEvent发送适当的PropertyChangeEvent。
        参数
        propertyName - 其值已更改的属性
        oldValue - 该物业的以前的价值
        newValue - 该物业的新价值

      • firePropertyChange

        protected void firePropertyChange​(String propertyName,
                                  boolean oldValue,
                                  boolean newValue)
        支持报告布尔属性的绑定属性更改。 当绑定属性已更改时，可以调用此方法，并且将向适当的PropertyChangeEvent发送适当的PropertyChangeEvent。
        参数
        propertyName - 其值已更改的属性
        oldValue - 该物业的以前的价值
        newValue - 物业的新价值
        从以下版本开始：
        1.4

      • firePropertyChange

        protected void firePropertyChange​(String propertyName,
                                  int oldValue,
                                  int newValue)
        支持报告整数属性的绑定属性更改。 当绑定属性已更改时，可以调用此方法，并且将向适当的PropertyChangeEvent发送适当的PropertyChangeEvent。
        参数
        propertyName - 其值已更改的属性
        oldValue - 该物业的以前的价值
        newValue - 该物业的新价值
        从以下版本开始：
        1.4

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               byte oldValue,
                               byte newValue)
        报告绑定属性更改。
        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 属性的旧值（以字节为单位）
        newValue - 属性的新值（作为一个字节）
        从以下版本开始：
        1.5
        另请参见：
        firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               char oldValue,
                               char newValue)
        报告绑定属性更改。
        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 属性的旧值（作为char）
        newValue - 属性的新值（作为char）
        从以下版本开始：
        1.5
        另请参见：
        firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               short oldValue,
                               short newValue)
        报告绑定属性更改。
        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 物业的旧价值（作为短期）
        newValue - 物业的新价值（作为一个简短的）
        从以下版本开始：
        1.5
        另请参见：
        firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               long oldValue,
                               long newValue)
        报告绑定属性更改。
        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 物业的旧价值（长期）
        newValue - 物业的新价值（长期）
        从以下版本开始：
        1.5
        另请参见：
        firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               float oldValue,
                               float newValue)
        报告绑定属性更改。
        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 属性的旧值（作为浮点数）
        newValue - 属性的新值（作为浮点数）
        从以下版本开始：
        1.5
        另请参见：
        firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               double oldValue,
                               double newValue)
        报告绑定属性更改。
        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 该属性的旧值（双重）
        newValue - 该属性的新值（双重）
        从以下版本开始：
        1.5
        另请参见：
        firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • setComponentOrientation

        public void setComponentOrientation​(ComponentOrientation o)
        设置用于对该组件中的元素或文本进行排序的语言敏感方向。 语言敏感的LayoutManager和Component子类将使用此属性来确定如何布局和绘制组件。

        在施工时，组件的方向设置为ComponentOrientation.UNKNOWN ，表示尚未明确指定。 UNKNOWN方向的行为与ComponentOrientation.LEFT_TO_RIGHT相同。

        要设置单个组件的方向，请使用此方法。 要设置整个组件层次结构的方向，请使用applyComponentOrientation 。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        o - 要设置的方向
        另请参见：
        ComponentOrientation ， invalidate()

      • getComponentOrientation

        public ComponentOrientation getComponentOrientation​()
        检索用于对该组件中的元素或文本进行排序的语言敏感方向。 LayoutManager和Component希望尊重方向的子类应该在执行布局或绘图之前调用此方法来获取组件的方向。
        结果
        方向来排列元素或文字
        另请参见：
        ComponentOrientation

      • applyComponentOrientation

        public void applyComponentOrientation​(ComponentOrientation orientation)
        设置此组件的ComponentOrientation属性及其中包含的所有组件。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        orientation - 此组件的新组件方向及其中包含的组件。
        异常
        NullPointerException - 如果 orientation为空。
        从以下版本开始：
        1.4
        另请参见：
        setComponentOrientation(java.awt.ComponentOrientation) ，
getComponentOrientation() ，
invalidate()

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取AccessibleContext与此Component相关联。 该基类实现的方法返回null。 扩展Component类应实现此方法以返回与该子类相关联的AccessibleContext 。
        结果
        该 AccessibleContext的这个 Component
        从以下版本开始：
        1.3

      • setMixingCutoutShape

        public void setMixingCutoutShape​(Shape shape)
        为此轻型组件设置“混合切割”形状。 该方法专门用于重磅/轻量级组件混合功能，如果应用于重量级组件，该方法将无效。 默认情况下，轻型组件被视为一个不透明矩形，用于重磅/轻量级组件混合功能。 这种方法使开发人员可以设置任意形状，从z列中轻量级组件下方的重量级组件切出。

        shape参数可能具有以下值：

        • null - 恢复默认的剪切形状（矩形等于组件的getBounds() ）
        • 空的形状 - 不会从重量级组件中切出任何东西。 这使得这个轻量级组件有效地透明。 请注意，轻量级组件的后代仍会影响重量级组件的形状。 空形状的一个例子是new Rectangle() 。
        • 非空的形状 - 给定的形状将从重量级组件中删除。

        需要“混合切割”形状的最常见的例子是玻璃板组件。 JRootPane.setGlassPane(java.awt.Component)方法自动将空形状设置为给定玻璃板组件的“混合切割”形状。 如果开发人员需要玻璃窗格的其他“混合切割”形状（这是罕见的），则必须在将玻璃窗格安装到根窗格之后手动更改。

        参数
        shape - 新的“混合切割”形状
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Component.AccessibleAWTComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Component.AccessibleAWTComponent

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    已知直接子类：
    Box.Filler.AccessibleBoxFiller ， Button.AccessibleAWTButton ， Canvas.AccessibleAWTCanvas ， Checkbox.AccessibleAWTCheckbox ， Choice.AccessibleAWTChoice ， Container.AccessibleAWTContainer ， Label.AccessibleAWTLabel ， List.AccessibleAWTList ， List.AccessibleAWTList.AccessibleAWTListChild ， Scrollbar.AccessibleAWTScrollBar ， TextComponent.AccessibleAWTTextComponent
    Enclosing class:
    Component

    protected abstract class Component.AccessibleAWTComponent
extends AccessibleContext
implements Serializable, AccessibleComponent
    组件的内部类用于为辅助功能提供默认支持。 这个类不是由应用程序开发人员直接使用，而是意味着仅由组件开发人员进行子类化。

    该类用于获取此对象的可访问角色。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
      Fire PropertyChange监听器，如果已注册，显示/隐藏..
      protected class  Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
      Fire PropertyChange监听器，如果有注册，焦点事件发生时

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ComponentListener accessibleAWTComponentHandler
      组件侦听器，用于跟踪show / hide / resize事件并将其转换为PropertyChange事件。
      protected FocusListener accessibleAWTFocusHandler
      监听焦点事件并将其转换为PropertyChange事件的侦听器。

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AccessibleAWTComponent​()
      虽然这个类是抽象的，但这应该由所有子类调用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      void addPropertyChangeListener​(PropertyChangeListener listener)
      添加一个 PropertyChangeListener到侦听器列表。
      boolean contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      Accessible getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      Accessible getAccessibleChild​(int i)
      返回对象的第n个 Accessible子对象。
      int getAccessibleChildrenCount​()
      返回对象中可访问的子项数。
      AccessibleComponent getAccessibleComponent​()
      获取与此对象关联的 AccessibleComponent如果存在）。
      String getAccessibleDescription​()
      获取此对象的可访问描述。
      int getAccessibleIndexInParent​()
      获取此对象在其可访问父级中的索引。
      String getAccessibleName​()
      获取此对象的可访问名称。
      Accessible getAccessibleParent​()
      获取此对象的 Accessible父项。
      AccessibleRole getAccessibleRole​()
      获得此对象的作用。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态。
      Color getBackground​()
      获取此对象的背景颜色。
      Rectangle getBounds​()
      以Rectangle对象的形式获取此对象的边界。
      Cursor getCursor​()
      获取此对象的 Cursor 。
      Font getFont​()
      获取此对象的 Font 。
      FontMetrics getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      Color getForeground​()
      获取此对象的前景色。
      Locale getLocale​()
      返回此对象的区域设置。
      Point getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Dimension getSize​()
      以 Dimension对象的形式返回此对象的大小。
      boolean isEnabled​()
      确定对象是否已启用。
      boolean isFocusTraversable​()
      返回此对象是否可以接受焦点。
      boolean isShowing​()
      确定对象是否正在显示。
      boolean isVisible​()
      确定对象是否可见。
      void removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除一个PropertyChangeListener。
      void requestFocus​()
      请求关注此对象。
      void setBackground​(Color c)
      设置此对象的背景颜色。
      void setBounds​(Rectangle r)
      以 Rectangle对象的形式设置此对象的边界。
      void setCursor​(Cursor cursor)
      设置此对象的 Cursor 。
      void setEnabled​(boolean b)
      设置对象的已启用状态。
      void setFont​(Font f)
      设置此对象的 Font 。
      void setForeground​(Color c)
      设置此对象的前景色。
      void setLocation​(Point p)
      设置对象相对于父对象的位置。
      void setSize​(Dimension d)
      调整此对象的大小，使其具有宽度和高度。
      void setVisible​(boolean b)
      设置对象的可见状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • accessibleAWTComponentHandler

        protected ComponentListener accessibleAWTComponentHandler
        组件侦听器，用于跟踪show / hide / resize事件并将其转换为PropertyChange事件。

      • accessibleAWTFocusHandler

        protected FocusListener accessibleAWTFocusHandler
        监听焦点事件并将其转换为PropertyChange事件的侦听器。

    • 构造方法详细信息

      • AccessibleAWTComponent

        protected AccessibleAWTComponent​()
        虽然这个类是抽象的，但这应该由所有子类调用。

    • 方法详细信息

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        添加 PropertyChangeListener到侦听器列表。
        重写：
        addPropertyChangeListener在 AccessibleContext
        参数
        listener - 要添加的属性更改侦听器
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY ， AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY ， AccessibleContext.ACCESSIBLE_STATE_PROPERTY ， AccessibleContext.ACCESSIBLE_VALUE_PROPERTY ， AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY ， AccessibleContext.ACCESSIBLE_TEXT_PROPERTY ， AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener listener)
        从侦听器列表中删除一个PropertyChangeListener。 这会删除为所有属性注册的PropertyChangeListener。
        重写：
        removePropertyChangeListener在类 AccessibleContext
        参数
        listener - 要删除的PropertyChangeListener

      • getAccessibleName

        public String getAccessibleName​()
        获取此对象的可访问名称。 这几乎永远不会返回java.awt.Component.getName() ，因为这通常不是本地化的名称，对用户没有意义。 如果对象基本上是文本对象（例如菜单项），可访问名称应该是对象的文本（例如“保存”）。 如果对象有一个工具提示，工具提示文本也可能是一个适当的String返回。
        重写：
        getAccessibleName在 AccessibleContext
        结果
        对象的本地化名称 - 如果此对象没有名称，则可以是 null
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleDescription

        public String getAccessibleDescription​()
        获取此对象的可访问描述。 这应该是对这个对象的简明的本地化描述 - 它对用户的意义。 如果对象具有工具提示，则工具提示文本可能是要返回的适当字符串，假设它包含对象的简明描述（而不仅仅是对象的名称），例如工具栏上的“保存”图标，该对象具有“保存“因为工具提示文本不应该返回工具提示文本作为说明，而是像”保存当前文本文档“一样。
        重写：
        getAccessibleDescription在 AccessibleContext
        结果
        对象的本地化描述可以是 null如果该对象没有描述
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获得此对象的作用。
        Specified by:
        getAccessibleRole在 AccessibleContext
        结果
        描述对象的作用的一个 AccessibleRole的实例
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态。
        Specified by:
        getAccessibleStateSet在 AccessibleContext
        结果
        一个 AccessibleStateSet的实例包含对象的当前状态集
        另请参见：
        AccessibleState

      • getAccessibleParent

        public Accessible getAccessibleParent​()
        获取此对象的Accessible父项。 如果这个对象的父对象实现了Accessible ，这个方法应该简单地返回getParent 。
        重写：
        getAccessibleParent在 AccessibleContext
        结果
        该对象的 Accessible父对象可以是 null如果此对象没有 Accessible父项

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent​()
        获取此对象在其可访问父级中的索引。
        Specified by:
        getAccessibleIndexInParent在 AccessibleContext
        结果
        该对象在其父项中的索引; 如果此对象没有可访问的父对象，则为-1
        另请参见：
        getAccessibleParent()

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount​()
        返回对象中可访问的子项数。 如果该对象的所有子项都实现了Accessible ，那么这个方法应该返回这个对象的子Accessible 。
        Specified by:
        getAccessibleChildrenCount在 AccessibleContext
        结果
        对象中可访问的孩子的数量

      • getAccessibleChild

        public Accessible getAccessibleChild​(int i)
        返回对象的第n个 Accessible子对象。
        Specified by:
        getAccessibleChild在 AccessibleContext
        参数
        i - 基于零的儿童索引
        结果
        对象的第n个 Accessible孩子
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale​()
        返回此对象的区域设置。
        Specified by:
        getLocale在 AccessibleContext
        结果
        该对象的区域设置

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent​()
        获取与此对象关联的AccessibleComponent如果存在）。 否则返回null 。
        重写：
        getAccessibleComponent在 AccessibleContext
        结果
        组件
        另请参见：
        AccessibleComponent

      • getBackground

        public Color getBackground​()
        获取此对象的背景颜色。
        Specified by:
        getBackground在接口 AccessibleComponent
        结果
        对象的背景颜色（如果支持）; 否则， null
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • setBackground

        public void setBackground​(Color c)
        设置此对象的背景颜色。 （有关透明度，请参阅isOpaque ）
        Specified by:
        setBackground在接口 AccessibleComponent
        参数
        c - 新的 Color为背景
        另请参见：
        Component.isOpaque()

      • getForeground

        public Color getForeground​()
        获取此对象的前景色。
        Specified by:
        getForeground在接口 AccessibleComponent
        结果
        对象的前景颜色（如果支持）; 否则， null
        另请参见：
        AccessibleComponent.setForeground(java.awt.Color)

      • setForeground

        public void setForeground​(Color c)
        设置此对象的前景色。
        Specified by:
        setForeground在接口 AccessibleComponent
        参数
        c - 新的 Color为前景
        另请参见：
        AccessibleComponent.getForeground()

      • getCursor

        public Cursor getCursor​()
        获取此对象的 Cursor 。
        Specified by:
        getCursor在接口 AccessibleComponent
        结果
        Cursor ，如果支持，则该对象; 否则， null
        另请参见：
        AccessibleComponent.setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor​(Cursor cursor)
        设置此对象的Cursor 。

        如果Java平台实现和/或本地系统不支持更改鼠标光标的形状，该方法可能没有视觉效果。

        Specified by:
        setCursor在接口 AccessibleComponent
        参数
        cursor - 新的 Cursor为对象
        另请参见：
        AccessibleComponent.getCursor()

      • getFont

        public Font getFont​()
        获取此对象的 Font 。
        Specified by:
        getFont在接口 AccessibleComponent
        结果
        Font ，如果支持，则为该对象; 否则， null
        另请参见：
        AccessibleComponent.setFont(java.awt.Font)

      • setFont

        public void setFont​(Font f)
        设置该对象的 Font 。
        Specified by:
        setFont在接口 AccessibleComponent
        参数
        f - 新的 Font的对象
        另请参见：
        AccessibleComponent.getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics​(Font f)
        获取此对象的 FontMetrics 。
        Specified by:
        getFontMetrics在接口 AccessibleComponent
        参数
        f - Font
        结果
        FontMetrics ，如果支持，则该对象; 否则， null
        另请参见：
        getFont()

      • isEnabled

        public boolean isEnabled​()
        确定对象是否已启用。
        Specified by:
        isEnabled在接口 AccessibleComponent
        结果
        如果对象启用，则为true; 否则，假
        另请参见：
        AccessibleComponent.setEnabled(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.ENABLED ， AccessibleStateSet

      • setEnabled

        public void setEnabled​(boolean b)
        设置对象的已启用状态。
        Specified by:
        setEnabled在接口 AccessibleComponent
        参数
        b - 如果为true，则启用此对象; 否则，禁用它
        另请参见：
        AccessibleComponent.isEnabled()

      • isVisible

        public boolean isVisible​()
        确定对象是否可见。 注意：这意味着该对象意图可见; 然而，它可能不会在屏幕上显示，因为该对象包含的对象之一是不可见的。 要确定对象是否在屏幕上显示，请使用isShowing 。
        Specified by:
        isVisible在接口 AccessibleComponent
        结果
        如果对象可见，则为true; 否则，假
        另请参见：
        AccessibleComponent.setVisible(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.VISIBLE ， AccessibleStateSet

      • setVisible

        public void setVisible​(boolean b)
        设置对象的可见状态。
        Specified by:
        setVisible在接口 AccessibleComponent
        参数
        b - 如果为真，则显示此对象; 否则隐藏它
        另请参见：
        AccessibleComponent.isVisible()

      • isShowing

        public boolean isShowing​()
        确定对象是否正在显示。 这是通过检查对象和对象的祖先的可见性来确定的。 注意：即使对象被另一个遮挡（例如，恰好在被拉下的菜单下方），这将返回true。
        Specified by:
        isShowing在接口 AccessibleComponent
        结果
        如果对象显示，则为true; 否则，假

      • contains

        public boolean contains​(Point p)
        检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
        Specified by:
        contains在接口 AccessibleComponent
        参数
        p - 相对于对象的坐标系的 Point
        结果
        如果对象包含Point ; 否则为虚假
        另请参见：
        AccessibleComponent.getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen​()
        返回对象在屏幕上的位置。
        Specified by:
        getLocationOnScreen在接口 AccessibleComponent
        结果
        屏幕上对象的位置 - 如果此对象不在屏幕上，可以是 null
        另请参见：
        AccessibleComponent.getBounds() ， AccessibleComponent.getLocation()

      • getLocation

        public Point getLocation​()
        以指定对象的左上角的点的形式获取对象相对于父对象的位置。
        Specified by:
        getLocation在接口 AccessibleComponent
        结果
        Point的一个实例代表屏幕坐标空间中对象边界的左上角; 如果此对象或其父对象不在屏幕上， null
        另请参见：
        AccessibleComponent.getBounds() ， AccessibleComponent.getLocationOnScreen()

      • setLocation

        public void setLocation​(Point p)
        设置对象相对于父对象的位置。
        Specified by:
        setLocation在接口 AccessibleComponent
        参数
        p - 对象的坐标
        另请参见：
        AccessibleComponent.getLocation()

      • getBounds

        public Rectangle getBounds​()
        以Rectangle对象的形式获取此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        Specified by:
        getBounds在接口 AccessibleComponent
        结果
        表示该组件边界的矩形; null如果此对象不在屏幕上
        另请参见：
        AccessibleComponent.contains(java.awt.Point)

      • setBounds

        public void setBounds​(Rectangle r)
        以Rectangle对象的形式设置此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        Specified by:
        setBounds在接口 AccessibleComponent
        参数
        r - 表示此组件边界的矩形
        另请参见：
        AccessibleComponent.getBounds()

      • getSize

        public Dimension getSize​()
        以Dimension对象的形式返回此对象的大小。 Dimension对象的height字段包含此对象的高度，而Dimension对象的width字段包含此对象的宽度。
        Specified by:
        getSize在接口 AccessibleComponent
        结果
        一个表示该组件大小的Dimension对象; 如果此对象不在屏幕上， null
        另请参见：
        AccessibleComponent.setSize(java.awt.Dimension)

      • setSize

        public void setSize​(Dimension d)
        调整此对象的大小，使其具有宽度和高度。
        Specified by:
        setSize在接口 AccessibleComponent
        参数
        d - 指定对象的新大小的维度
        另请参见：
        AccessibleComponent.getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt​(Point p)
        返回Accessible小孩（如果存在），包含在本地坐标Point 。 否则返回null 。
        Specified by:
        getAccessibleAt在接口 AccessibleComponent
        参数
        p -定义的左上角点 Accessible ，在对象的父对象的坐标空间中给出
        结果
        Accessible如果存在，在指定的位置; 其他null

      • isFocusTraversable

        public boolean isFocusTraversable​()
        返回此对象是否可以接受焦点。
        Specified by:
        isFocusTraversable在接口 AccessibleComponent
        结果
        true如果对象可以接受焦点; 否则为虚假
        另请参见：
        AccessibleContext.getAccessibleStateSet() ， AccessibleState.FOCUSABLE ， AccessibleState.FOCUSED ， AccessibleStateSet

      • requestFocus

        public void requestFocus​()
        请求关注此对象。
        Specified by:
        requestFocus在接口 AccessibleComponent
        另请参见：
        AccessibleComponent.isFocusTraversable()

      • addFocusListener

        public void addFocusListener​(FocusListener l)
        新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
        Specified by:
        addFocusListener在接口 AccessibleComponent
        参数
        l - 焦点侦听器
        另请参见：
        AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener​(FocusListener l)
        删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
        Specified by:
        removeFocusListener在接口 AccessibleComponent
        参数
        l - 焦点侦听器
        另请参见：
        AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

  • java.lang.Object
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
  • All Implemented Interfaces:
    ComponentListener ， EventListener
    Enclosing class:
    Component.AccessibleAWTComponent

    protected class Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
extends Object
implements ComponentListener
    Fire PropertyChange监听器，如果已注册，显示/隐藏..
    从以下版本开始：
    1.3

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTComponentHandler​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void componentHidden​(ComponentEvent e)
      当该组件不可见时调用。
      void componentMoved​(ComponentEvent e)
      当组件的位置更改时调用。
      void componentResized​(ComponentEvent e)
      当组件的大小更改时调用。
      void componentShown​(ComponentEvent e)
      当组件可见时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTComponentHandler

        protected AccessibleAWTComponentHandler​()

    • 方法详细信息

      • componentHidden

        public void componentHidden​(ComponentEvent e)
        说明从接口ComponentListener复制
        当该组件不可见时调用。
        Specified by:
        componentHidden在接口 ComponentListener
        参数
        e - 要处理的事件

      • componentShown

        public void componentShown​(ComponentEvent e)
        描述从接口ComponentListener复制
        当组件可见时调用。
        Specified by:
        componentShown在接口 ComponentListener
        参数
        e - 要处理的事件

      • componentMoved

        public void componentMoved​(ComponentEvent e)
        描述从接口ComponentListener复制
        当组件的位置更改时调用。
        Specified by:
        componentMoved在接口 ComponentListener
        参数
        e - 要处理的事件

      • componentResized

        public void componentResized​(ComponentEvent e)
        描述从接口ComponentListener复制
        当组件的大小更改时调用。
        Specified by:
        componentResized在接口 ComponentListener
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

  • java.lang.Object
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
  • All Implemented Interfaces:
    FocusListener ， EventListener
    Enclosing class:
    Component.AccessibleAWTComponent

    protected class Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
extends Object
implements FocusListener
    Fire PropertyChange监听器，如果有注册，焦点事件发生时
    从以下版本开始：
    1.3

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTFocusHandler​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void focusGained​(FocusEvent event)
      当组件获得键盘焦点时调用。
      void focusLost​(FocusEvent event)
      当组件丢失键盘焦点时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTFocusHandler

        protected AccessibleAWTFocusHandler​()

    • 方法详细信息

      • focusGained

        public void focusGained​(FocusEvent event)
        描述从接口FocusListener复制
        当组件获得键盘焦点时调用。
        Specified by:
        focusGained在接口 FocusListener
        参数
        event - 要处理的事件

      • focusLost

        public void focusLost​(FocusEvent event)
        描述从接口FocusListener复制
        当组件丢失键盘焦点时调用。
        Specified by:
        focusLost在接口 FocusListener
        参数
        event - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Component.BaselineResizeBehavior (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum Component.BaselineResizeBehavior

  • java.lang.Object
    • java.lang.Enum<Component.BaselineResizeBehavior>
      • java.awt.Component.BaselineResizeBehavior
  • All Implemented Interfaces:
    Serializable ， Comparable<Component.BaselineResizeBehavior>
    Enclosing class:
    Component

    public static enum Component.BaselineResizeBehavior
extends Enum<Component.BaselineResizeBehavior>
    枚举组件的基准线随着大小变化而改变的常见方式。 基准调整大小行为主要用于需要知道基准位置如何随着组件大小变化而变化的布局管理器。 通常，基准调整大小行为对于大于或等于最小大小（实际最小大小，而不是开发人员指定的最小大小）的大小将是有效的。 对于小于最小尺寸的尺寸，基线可能以基线调整大小行为以外的方式改变。 类似地，当大小接近Integer.MAX_VALUE和/或Short.MAX_VALUE ，基线可能以基线调整大小行为指示的方式改变。
    从以下版本开始：
    1.6
    另请参见：
    Component.getBaselineResizeBehavior() ， Component.getBaseline(int,int)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CENTER_OFFSET
      表示基线保持与组件中心的固定距离。
      CONSTANT_ASCENT
      表示基线相对于y-origin保持固定。
      CONSTANT_DESCENT
      表示基线相对于高度保持固定，并且不随宽度变化而改变。
      OTHER
      表示使用任何其他常量不能表示基准调整大小行为。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Component.BaselineResizeBehavior valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Component.BaselineResizeBehavior[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CONSTANT_ASCENT

        public static final Component.BaselineResizeBehavior CONSTANT_ASCENT
        表示基线相对于y-origin保持固定。 也就是说， getBaseline返回相同的值，而不管高度或宽度如何。 例如， JLabel具有垂直取向的含非空文本TOP应具有基线类型的CONSTANT_ASCENT 。

      • CONSTANT_DESCENT

        public static final Component.BaselineResizeBehavior CONSTANT_DESCENT
        表示基线相对于高度保持固定，并且不随宽度变化而改变。 也就是说，对于任何高度H，H和getBaseline(w, H)之间的差异是相同的。 例如， JLabel具有垂直取向的含非空文本BOTTOM应具有基线类型的CONSTANT_DESCENT 。

      • CENTER_OFFSET

        public static final Component.BaselineResizeBehavior CENTER_OFFSET
        表示基线保持与组件中心的固定距离。 也就是说，对于任何高度H， getBaseline(w, H)和H / 2之间的差异是相同的（加或减一，取决于舍入误差）。

        由于可能的舍入误差，建议您以两个连续的高度要求基线，并使用返回值来确定是否需要按1进行计算。以下显示了如何计算任何高度的基线：

          Dimension preferredSize = component.getPreferredSize();
   int baseline = getBaseline(preferredSize.width,
                              preferredSize.height);
   int nextBaseline = getBaseline(preferredSize.width,
                                  preferredSize.height + 1);
   // Amount to add to height when calculating where baseline
   // lands for a particular height:
   int padding = 0;
   // Where the baseline is relative to the mid point
   int baselineOffset = baseline - height / 2;
   if (preferredSize.height % 2 == 0 &&
       baseline != nextBaseline) {
       padding = 1;
   }
   else if (preferredSize.height % 2 == 1 &&
            baseline == nextBaseline) {
       baselineOffset--;
       padding = 1;
   }
   // The following calculates where the baseline lands for
   // the height z:
   int calculatedBaseline = (z + padding) / 2 + baselineOffset;

      • OTHER

        public static final Component.BaselineResizeBehavior OTHER
        表示使用任何其他常量不能表示基准调整大小行为。 这也可能表示基线随组件的宽度而变化。 这也由没有基线的组件返回。

    • 方法详细信息

      • values

        public static Component.BaselineResizeBehavior[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Component.BaselineResizeBehavior c : Component.BaselineResizeBehavior.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Component.BaselineResizeBehavior valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Component.BltBufferStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Component.BltBufferStrategy

  • java.lang.Object
    • java.awt.image.BufferStrategy
      • java.awt.Component.BltBufferStrategy
  • Enclosing class:
    Component

    protected class Component.BltBufferStrategy
extends BufferStrategy
    内部类别将屏幕外表面喷涂到组件上。
    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected VolatileImage[] backBuffers
      后缓冲
      protected BufferCapabilities caps
      缓冲功能
      protected int height
      后缓冲器的高度
      protected boolean validatedContents
      绘图缓冲区是否最近从丢失状态恢复。
      protected int width
      后缓冲区的宽度

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected BltBufferStrategy​(int numBuffers, BufferCapabilities caps)
      围绕组件创建一个新的blt缓冲策略

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean contentsLost​()
      返回上次调用 getDrawGraphics绘图缓冲区是否丢失。
      boolean contentsRestored​()
      返回绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）。
      protected void createBackBuffers​(int numBuffers)
      创建后台缓冲区
      void dispose​()
      释放此 BufferStrategy目前使用的系统资源，并将其从关联的组件中删除。
      BufferCapabilities getCapabilities​()
      返回 BufferCapabilities为这个 BufferStrategy 。
      Graphics getDrawGraphics​()
      为绘图缓冲区创建图形上下文。
      protected void revalidate​()
      如果绘图缓冲区丢失，则还原它
      void show​()
      使下一个可用缓冲区可见。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • caps

        protected BufferCapabilities caps
        缓冲功能

      • backBuffers

        protected VolatileImage[] backBuffers
        后缓冲

      • validatedContents

        protected boolean validatedContents
        绘图缓冲区是否最近从丢失状态恢复。

      • width

        protected int width
        后缓冲区的宽度

      • height

        protected int height
        后缓冲器的高度

    • 构造方法详细信息

      • BltBufferStrategy

        protected BltBufferStrategy​(int numBuffers,
                            BufferCapabilities caps)
        围绕组件创建一个新的blt缓冲策略
        参数
        numBuffers - 要创建的缓冲区数，包括前端缓冲区
        caps - 缓冲区的功能

    • 方法详细信息

      • dispose

        public void dispose​()
        释放此BufferStrategy当前使用的系统资源，并将其从关联的组件中删除。 调用此方法后， getBufferStrategy将返回null。 尝试使用BufferStrategy后，将会导致未定义的行为。
        重写：
        dispose在 BufferStrategy
        从以下版本开始：
        1.6
        另请参见：
        Window.createBufferStrategy(int) ，
Canvas.createBufferStrategy(int) ，
Window.getBufferStrategy() ，
Canvas.getBufferStrategy()

      • createBackBuffers

        protected void createBackBuffers​(int numBuffers)
        创建后台缓冲区
        参数
        numBuffers - 要创建的缓冲区数

      • getCapabilities

        public BufferCapabilities getCapabilities​()
        描述从类复制： BufferStrategy
        返回 BufferCapabilities为这 BufferStrategy 。
        Specified by:
        getCapabilities在 BufferStrategy
        结果
        这个策略的缓冲功能

      • getDrawGraphics

        public Graphics getDrawGraphics​()
        描述从类复制： BufferStrategy
        为绘图缓冲区创建图形上下文。 出于性能原因，此方法可能无法同步; 多线程使用此方法应在应用程序级别处理。 获取的图形对象的处理必须由应用程序处理。
        Specified by:
        getDrawGraphics在 BufferStrategy
        结果
        绘制图形

      • show

        public void show​()
        使下一个可用缓冲区可见。
        Specified by:
        show中的 BufferStrategy

      • revalidate

        protected void revalidate​()
        如果绘图缓冲区丢失，则还原它

      • contentsLost

        public boolean contentsLost​()
        描述从类复制： BufferStrategy
        返回自上次调用getDrawGraphics以来绘图缓冲区是否丢失。 由于缓冲区策略中的缓冲区通常是类型为VolatileImage ，它们可能会丢失。 有关丢失缓冲区的讨论，请参阅VolatileImage 。
        Specified by:
        contentsLost在 BufferStrategy
        结果
        自上次调用 getDrawGraphics以来，绘图缓冲区是否丢失
        另请参见：
        VolatileImage

      • contentsRestored

        public boolean contentsRestored​()
        描述从类复制： BufferStrategy
        返回绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）。 由于缓冲区策略中的缓冲区通常是类型为VolatileImage ，它们可能会丢失。 如果自上次调用getDrawGraphics以来，表面最近已经从丢失状态恢复，则可能需要重新绘制。 有关丢失缓冲区的讨论，请参阅VolatileImage 。
        Specified by:
        contentsRestored在 BufferStrategy
        结果
        绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）
        另请参见：
        VolatileImage
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Component.FlipBufferStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Component.FlipBufferStrategy

  • java.lang.Object
    • java.awt.image.BufferStrategy
      • java.awt.Component.FlipBufferStrategy
  • Enclosing class:
    Component

    protected class Component.FlipBufferStrategy
extends BufferStrategy
    内部类用于在组件上翻转缓冲区。 该组件必须是Canvas或Window或Applet 。
    从以下版本开始：
    1.4
    另请参见：
    Canvas ， Window ， Applet ， BufferStrategy

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected BufferCapabilities caps
      缓冲功能
      protected Image drawBuffer
      绘图缓冲区
      protected VolatileImage drawVBuffer
      绘图缓冲区作为易失性图像
      protected int numBuffers
      缓冲区的数量
      protected boolean validatedContents
      绘图缓冲区是否最近从丢失状态恢复。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FlipBufferStrategy​(int numBuffers, BufferCapabilities caps)
      为此组件创建一个新的翻转缓冲区策略。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type | 方法 | 描述
      boolean contentsLost​()
      返回自上次调用 getDrawGraphics以来绘图缓冲区是否丢失。
      boolean contentsRestored​()
      返回绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）。
      protected void createBuffers​(int numBuffers, BufferCapabilities caps)
      使用给定的功能创建一个或多个复杂的翻转缓冲区。
      protected void destroyBuffers​()
      破坏通过此对象创建的缓冲区
      void dispose​()
      释放此 BufferStrategy当前使用的系统资源，并将其从关联的组件中删除。
      protected void flip​(BufferCapabilities.FlipContents flipAction)
      翻转通过复制或移动视频指针将后缓冲区的内容移动到前缓冲区。
      protected Image | getBackBuffer​()
      BufferCapabilities getCapabilities​()
      返回 BufferCapabilities为这个 BufferStrategy 。
      Graphics getDrawGraphics​()
      为绘图缓冲区创建图形上下文。
      protected void revalidate​()
      如果绘图缓冲区丢失，则还原它
      void show​()
      使下一个可用的缓冲区可以被blitting或flipping看到。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • numBuffers

        protected int numBuffers
        缓冲区的数量

      • caps

        protected BufferCapabilities caps
        缓冲功能

      • drawBuffer

        protected Image drawBuffer
        绘图缓冲区

      • drawVBuffer

        protected VolatileImage drawVBuffer
        绘图缓冲区作为易失性图像

      • validatedContents

        protected boolean validatedContents
        绘图缓冲区是否最近从丢失状态恢复。

    • 构造方法详细信息

      • FlipBufferStrategy

        protected FlipBufferStrategy​(int numBuffers,
                             BufferCapabilities caps)
                      throws AWTException
        为此组件创建一个新的翻转缓冲区策略。 组件必须是Canvas或Window或Applet 。
        参数
        numBuffers - 缓冲区的数量
        caps - 缓冲区的功能
        异常
        AWTException - 如果提供的功能不能被支持或满足
        ClassCastException - 如果组件不是画布或窗口。
        IllegalStateException - 如果组件没有对等体
        IllegalArgumentException - 如果 numBuffers小于2，或者如果 BufferCapabilities.isPageFlipping不是 true 。
        另请参见：
        Canvas ， Window ， Applet ， createBuffers(int, BufferCapabilities)

    • 方法详细信息

      • createBuffers

        protected void createBuffers​(int numBuffers,
                             BufferCapabilities caps)
                      throws AWTException
        使用给定的功能创建一个或多个复杂的翻转缓冲区。
        参数
        numBuffers - 要创建的缓冲区数; 必须大于1
        caps - 缓冲区的功能。 BufferCapabilities.isPageFlipping必须是true 。
        异常
        AWTException - 如果提供的功能不能被支持或满足
        IllegalStateException - 如果组件没有对等体
        IllegalArgumentException - 如果numBuffers小于2，或者如果 BufferCapabilities.isPageFlipping不是 true 。
        另请参见：
        BufferCapabilities.isPageFlipping()

      • getBackBuffer

        protected Image getBackBuffer​()
        结果
        直接访问后台缓冲区，作为图像。
        异常
        IllegalStateException - 如果缓冲区尚未创建

      • flip

        protected void flip​(BufferCapabilities.FlipContents flipAction)
        翻转通过复制或移动视频指针将后缓冲区的内容移动到前缓冲区。
        参数
        flipAction - 描述后缓冲区内容的翻转动作的整数值。 这应该是BufferCapabilities.FlipContents属性的值之一。
        异常
        IllegalStateException - 如果尚未创建缓冲区
        另请参见：
        BufferCapabilities.getFlipContents()

      • destroyBuffers

        protected void destroyBuffers​()
        破坏通过此对象创建的缓冲区

      • getCapabilities

        public BufferCapabilities getCapabilities​()
        描述从类复制： BufferStrategy
        返回 BufferCapabilities为这个 BufferStrategy 。
        Specified by:
        getCapabilities在 BufferStrategy
        结果
        这个策略的缓冲功能

      • getDrawGraphics

        public Graphics getDrawGraphics​()
        描述从类复制： BufferStrategy
        为绘图缓冲区创建图形上下文。 出于性能原因，此方法可能无法同步; 多线程使用此方法应在应用程序级别处理。 获取的图形对象的处理必须由应用程序处理。
        Specified by:
        getDrawGraphics在 BufferStrategy
        结果
        绘图缓冲区上的图形。 出于性能原因，此方法可能无法同步; 多线程使用此方法应在应用程序级别处理。 图形对象的处理必须由应用程序处理。

      • revalidate

        protected void revalidate​()
        如果绘图缓冲区丢失，则还原它

      • contentsLost

        public boolean contentsLost​()
        描述从类复制： BufferStrategy
        返回自上次调用getDrawGraphics以来绘图缓冲区是否丢失。 由于缓冲区策略中的缓冲区通常是类型为VolatileImage ，它们可能会丢失。 有关丢失缓冲区的讨论，请参阅VolatileImage 。
        Specified by:
        contentsLost在 BufferStrategy
        结果
        自上次调用 getDrawGraphics ，绘图缓冲区是否丢失
        另请参见：
        VolatileImage

      • contentsRestored

        public boolean contentsRestored​()
        描述从类复制： BufferStrategy
        返回绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）。 由于缓冲区策略中的缓冲区通常是类型为VolatileImage ，它们可能会丢失。 如果自上次调用getDrawGraphics以来，表面最近已经从丢失状态恢复，则可能需要重新绘制。 有关丢失缓冲区的讨论，请参阅VolatileImage 。
        Specified by:
        contentsRestored在 BufferStrategy
        结果
        绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）
        另请参见：
        VolatileImage

      • show

        public void show​()
        使下一个可用的缓冲区可以被blitting或flipping看到。
        Specified by:
        show在 BufferStrategy

      • dispose

        public void dispose​()
        释放此BufferStrategy当前使用的系统资源，并将其从关联的组件中删除。 调用此方法后， getBufferStrategy将返回null。 在BufferStrategy之后尝试使用BufferStrategy将导致未定义的行为。
        重写：
        dispose在 BufferStrategy
        从以下版本开始：
        1.6
        另请参见：
        Window.createBufferStrategy(int) ，
Canvas.createBufferStrategy(int) ，
Window.getBufferStrategy() ，
Canvas.getBufferStrategy()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ComponentOrientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class ComponentOrientation

  • java.lang.Object
    • java.awt.ComponentOrientation
  • All Implemented Interfaces:
    Serializable

    public final class ComponentOrientation
extends Object
implements Serializable
    ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。 它用于反映西方字母，中东（如希伯来语）和远东（如日语）之间的这种排序的差异。

    从根本上说，这是管理排列在一行中的项目（如字符），然后排列在一个块中。 这也适用于小部件中的项目：例如，在框相对于文本定位的复选框中。

    现代语言有四种不同的方向，如下表所示。

      LT          RT          TL          TR
 A B C       C B A       A D G       G D A
 D E F       F E D       B E H       H E B
 G H I       I H G       C F I       I F C

    （在标题中，两个字母的缩写表示第一个字母中的项目方向，第二个字母中的行方向，例如，LT表示“从左到右，从上到下的行”，TL表示“从上到下，线从左到右”，等等。）

    方向是：

    • LT - 西欧（可选日语，中文，韩语）
    • RT - 中东（阿拉伯语，希伯来文）
    • TR - 日语，中文，韩语
    • TL - 蒙古语
    其视图和控制器代码取决于方向的组件应使用isLeftToRight()和isHorizontal()方法来确定其行为。 它们不应该包含与常量相关的类似切换的代码，例如：
      if (orientation == LEFT_TO_RIGHT) {
   ...
 } else if (orientation == RIGHT_TO_LEFT) {
   ...
 } else {
   // Oops
 }
    这是不安全的，因为将来可能添加更多的常量，因为不能保证定向对象是唯一的。
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ComponentOrientation LEFT_TO_RIGHT
      项目从左到右运行，线条从上到下实例：英语，法语。
      static ComponentOrientation RIGHT_TO_LEFT
      项目从右到左运行，线条从上到下实例：阿拉伯语，希伯来文。
      static ComponentOrientation UNKNOWN
      表示组件的方向尚未设置。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static ComponentOrientation getOrientation​(Locale locale)
      返回适合给定区域设置的方向。
      static ComponentOrientation getOrientation​(ResourceBundle bdl)
      已过时。
      从J2SE 1.4起，使用getOrientation(java.util.Locale) 。
      boolean isHorizontal​()
      线条水平吗？
      boolean isLeftToRight​()
      HorizontalLines：项目是否从左到右运行？

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LEFT_TO_RIGHT

        public static final ComponentOrientation LEFT_TO_RIGHT
        项目从左到右运行，线条从上到下实例：英语，法语。

      • RIGHT_TO_LEFT

        public static final ComponentOrientation RIGHT_TO_LEFT
        项目从右到左运行，线条从上到下实例：阿拉伯语，希伯来文。

      • UNKNOWN

        public static final ComponentOrientation UNKNOWN
        表示组件的方向尚未设置。 为了保留现有应用程序的行为，对于此值，isLeftToRight将返回true。

    • 方法详细信息

      • isHorizontal

        public boolean isHorizontal​()
        线条水平吗？ 对于横向的，从左到右的书写系统（如Roman），这将返回true。
        结果
        true如果这个方向有水平线

      • isLeftToRight

        public boolean isLeftToRight​()
        HorizontalLines：项目是否从左到右运行？
        垂直线：线从左到右行吗？
        对于横向的，从左到右的书写系统（如Roman），这将返回true。
        结果
        true如果这个方向是从左到右

      • getOrientation

        public static ComponentOrientation getOrientation​(Locale locale)
        返回适合给定区域设置的方向。
        参数
        locale - 指定的区域设置
        结果
        语言环境的方向

      • getOrientation

        @Deprecated
public static ComponentOrientation getOrientation​(ResourceBundle bdl)
        已过时。 从J2SE 1.4起，使用getOrientation(java.util.Locale) 。
        返回适合给定ResourceBundle本地化的方向。 按以下顺序尝试三种方法：
        1. 使用字符串“Orientation”作为关键字从ResourceBundle检索ComponentOrientation对象。
        2. 使用ResourceBundle.getLocale来确定包的区域设置，然后返回该区域设置的方向。
        3. 返回默认语言环境的方向。
        参数
        bdl - 要使用的包
        结果
        the orientation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Composite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface Composite

  • 所有已知实现类：
    AlphaComposite

    public interface Composite
    Composite界面以及CompositeContext定义了组合绘制基元与底层图形区域的方法。 在Composite在Graphics2D上下文中设置之后，它将形状，文本或正在渲染的图像与已经根据预定义规则渲染的颜色相结合。 实现此接口的类提供了为特定操作创建上下文的规则和方法。 CompositeContext是由操作开始之前由Graphics2D创建的合成操作使用的环境。 CompositeContext包含合成操作所需的私人信息和资源。 当CompositeContext不再需要时， Graphics2D对象处理它，以回收分配给该操作的资源。

    实现Composite的类的实例必须是不可变的，因为当将Graphics2D设置为具有setComposite方法的属性或克隆Graphics2D对象时， Graphics2D不会克隆这些对象。 这是为了避免Graphics2D未定义渲染行为，这是由于在Graphics2D上下文中设置的对象之后修改了Composite对象。

    由于该界面必须将目标设备或图像上的像素内容暴露于潜在的任意代码，所以在直接渲染到屏幕设备时使用实现此界面的自定义对象由readDisplayPixels AWTPermission管理 。 当这样的自定义对象被传递到将发生权限检查setComposite一个的方法Graphics2D从检索Component 。

    另请参见：
    AlphaComposite ， CompositeContext ， Graphics2D.setComposite(java.awt.Composite)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      CompositeContext createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建用于执行合成操作的上下文包含状态。

    • 方法详细信息

      • createContext

        CompositeContext createContext​(ColorModel srcColorModel,
                               ColorModel dstColorModel,
                               RenderingHints hints)
        创建用于执行合成操作的上下文包含状态。 在多线程环境中，单个Composite对象可以同时存在多个上下文。
        参数
        srcColorModel - 源码的ColorModel
        dstColorModel - 目的地的 ColorModel
        hints - 上下文对象用于在渲染替代方案之间进行选择的提示
        结果
        用于执行合成操作的 CompositeContext对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CompositeContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface CompositeContext

  • public interface CompositeContext
    CompositeContext接口为合成操作定义了封装和优化的环境。 CompositeContext对象维护合成操作的状态。 在多线程环境中，单个Composite对象可以同时存在多个上下文。
    另请参见：
    Composite

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void compose​(Raster src, Raster dstIn, WritableRaster dstOut)
      组合两个源Raster对象，并将结果放在目标WritableRaster中 。
      void dispose​()
      释放为上下文分配的资源。

    • 方法详细信息

      • dispose

        void dispose​()
        释放为上下文分配的资源。

      • compose

        void compose​(Raster src,
             Raster dstIn,
             WritableRaster dstOut)
        组合两个源Raster对象，并将结果放在目标WritableRaster中 。 请注意，目标可以是与第一个或第二个源相同的对象。 注意， dstIn和dstOut必须兼容dstColorModel传递给createContext方法的Composite接口。
        参数
        src - 合成操作的第一个来源
        dstIn - 合成操作的第二个来源
        dstOut - 存储操作结果的 WritableRaster
        另请参见：
        Composite
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Container (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Container

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable
    已知直接子类：
    BasicSplitPaneDivider ， CellRendererPane ， DefaultTreeCellEditor.EditorContainer ， JComponent ， Panel ， ScrollPane ， Window

    public class Container
extends Component
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。

    200新新新新新新旗新新新新旗新新旗新新旗新新旗新新旗新新200新200新新新新新新200架旗新新款： 列表的顺序将在容器内定义组件的前后堆叠顺序。 如果在向容器添加组件时未指定索引，则将其添加到列表的末尾（因此将添加到堆栈顺序的底部）。

    注意 ：有关焦点子系统的详细信息，请参阅How to Use the Focus Subsystem ， “Java教程”中的一节，以及有关详细信息的Focus Specification 。

    从以下版本开始：
    1.0
    另请参见：
    add(java.awt.Component, int) ， getComponent(int) ， LayoutManager ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Container.AccessibleAWTContainer
      Container的内部类用于为辅助功能提供默认支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Container​()
      构造一个新的容器。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Component add​(Component comp)
      将指定的组件附加到此容器的末尾。
      Component add​(Component comp, int index)
      在给定的位置将指定的组件添加到此容器。
      void add​(Component comp, Object constraints)
      将指定的组件添加到此容器的末尾。
      void add​(Component comp, Object constraints, int index)
      将指定的组件添加到指定索引处的指定约束的容器中。
      Component add​(String name, Component comp)
      将指定的组件添加到此容器。
      void addContainerListener​(ContainerListener l)
      添加指定的容器侦听器以从此容器接收容器事件。
      protected void addImpl​(Component comp, Object constraints, int index)
      在指定的索引处将指定的组件添加到此容器。
      void addNotify​()
      通过将此容器连接到本机屏幕资源来使此容器显示。
      void addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void applyComponentOrientation​(ComponentOrientation o)
      设置此容器的 ComponentOrientation属性及其中包含的所有组件。
      boolean areFocusTraversalKeysSet​(int id)
      返回是否为此容器显式定义了给定焦点遍历操作的聚焦遍历键集。
      int countComponents​()
      已过时。
      从JDK 1.1版开始，由getComponentCount（）替换。
      void deliverEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代
      void doLayout​()
      使此容器布置其组件。
      Component findComponentAt​(int x, int y)
      找到包含指定位置的可见子组件。
      Component findComponentAt​(Point p)
      找到包含指定点的可见子组件。
      float getAlignmentX​()
      返回沿x轴的对齐方式。
      float getAlignmentY​()
      返回沿着y轴的对齐。
      Component getComponent​(int n)
      获取此容器中的第n个组件。
      Component getComponentAt​(int x, int y)
      找到包含x，y位置的组件。
      Component getComponentAt​(Point p)
      获取包含指定点的组件。
      int getComponentCount​()
      获取此面板中的组件数量。
      Component[] getComponents​()
      获取此容器中的所有组件。
      int getComponentZOrder​(Component comp)
      返回容器内组件的z-order索引。
      ContainerListener[] getContainerListeners​()
      返回在此容器上注册的所有容器侦听器的数组。
      Set<AWTKeyStroke> getFocusTraversalKeys​(int id)
      返回此Container的给定遍历操作的聚焦遍历键集。
      FocusTraversalPolicy getFocusTraversalPolicy​()
      返回将管理此Container的子项的键盘遍历的焦点遍历策略，如果此Container不是焦点循环根，则返回null。
      Insets getInsets​()
      确定此容器的插入，这表示容器边框的大小。
      LayoutManager getLayout​()
      获取此容器的布局管理器。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回此 Container当前注册为 FooListener的所有对象的数组。
      Dimension getMaximumSize​()
      返回此容器的最大大小。
      Dimension getMinimumSize​()
      返回此容器的最小大小。
      Point getMousePosition​(boolean allowChildren)
      如果 Container位于鼠标指针下方，则返回该 Container的坐标空间中鼠标指针的位置，否则返回 null 。
      Dimension getPreferredSize​()
      返回此容器的首选大小。
      Insets insets​()
      已过时。
      从JDK 1.1版开始，由getInsets()替代。
      void invalidate​()
      使容器无效。
      boolean isAncestorOf​(Component c)
      检查组件是否包含在此容器的组件层次结构中。
      boolean isFocusCycleRoot​()
      返回此容器是否是焦点遍历循环的根。
      boolean isFocusCycleRoot​(Container container)
      返回指定的Container是否是此Container的焦点遍历循环的焦点循环根。
      boolean isFocusTraversalPolicyProvider​()
      返回此容器是否提供焦点遍历策略。
      boolean isFocusTraversalPolicySet​()
      返回是否为此Container显式设置了重点遍历策略。
      boolean isValidateRoot​()
      指示此容器是否为 验证根 。
      void layout​()
      已过时。
      从JDK 1.1版开始，由doLayout()代替。
      void list​(PrintStream out, int indent)
      将此容器的列表打印到指定的输出流。
      void list​(PrintWriter out, int indent)
      从指定的缩进开始列出指定的打印作者的列表。
      Component locate​(int x, int y)
      已过时。
      从JDK 1.1版开始，由getComponentAt(int, int)替代。
      Dimension minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      void paint​(Graphics g)
      涂上容器
      void paintComponents​(Graphics g)
      涂抹此容器中的每个组件。
      protected String paramString​()
      返回表示此 Container的状态的字符串。
      Dimension preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      void print​(Graphics g)
      打印容器。
      void printComponents​(Graphics g)
      打印此容器中的每个组件。
      protected void processContainerEvent​(ContainerEvent e)
      通过将容器事件发送到任何已注册的ContainerListener对象来处理容器事件。
      protected void processEvent​(AWTEvent e)
      处理此容器上的事件。
      void remove​(int index)
      从此容器中删除由 index指定的组件。
      void remove​(Component comp)
      从此容器中删除指定的组件。
      void removeAll​()
      从此容器中删除所有组件。
      void removeContainerListener​(ContainerListener l)
      删除指定的容器侦听器，使其不再从此容器接收容器事件。
      void removeNotify​()
      通过删除其与其本机屏幕资源的连接，使此容器不可显示。
      void setComponentZOrder​(Component comp, int index)
      将指定的组件移动到容器中指定的z顺序索引。
      void setFocusCycleRoot​(boolean focusCycleRoot)
      设置此容器是否是焦点遍历循环的根。
      void setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此容器的给定遍历操作的焦点遍历键。
      void setFocusTraversalPolicy​(FocusTraversalPolicy policy)
      设置焦点遍历策略，将管理此Container的子项的键盘遍历，如果此Container是焦点循环根。
      void setFocusTraversalPolicyProvider​(boolean provider)
      设置此容器是否将用于提供焦点遍历策略。
      void setFont​(Font f)
      设置此容器的字体。
      void setLayout​(LayoutManager mgr)
      设置此容器的布局管理器。
      void transferFocusDownCycle​()
      将焦点转移到一个焦点遍历周期。
      void update​(Graphics g)
      更新容器。
      void validate​()
      验证此容器及其所有子组件。
      protected void validateTree​()
      递归地下降容器树，并重新计算标记为需要的任何子树（标记为无效的）的布局。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Container

        public Container​()
        构造一个新的容器。 容器可以直接扩展，但在这种情况下是轻量级的，并且必须包含在本机组件树中较高的位置的父级。 （例如Frame）。

    • 方法详细信息

      • getComponentCount

        public int getComponentCount​()
        获取此面板中的组件数量。

        注意：此方法应在AWT树锁下调用。

        结果
        该面板中的组件数量。
        从以下版本开始：
        1.1
        另请参见：
        getComponent(int) ， Component.getTreeLock()

      • countComponents

        @Deprecated
public int countComponents​()
        已过时。 从JDK 1.1版开始，由getComponentCount（）替换。
        返回此容器中的组件数。
        结果
        该容器中的组件数

      • getComponent

        public Component getComponent​(int n)
        获取此容器中的第n个组件。

        注意：此方法应在AWT树锁下调用。

        参数
        n - 要获取的组件的索引。
        结果
        这个容器中的 第 n 个组件。
        异常
        ArrayIndexOutOfBoundsException - 如果第n 个值不存在。
        另请参见：
        Component.getTreeLock()

      • getComponents

        public Component[] getComponents​()
        获取此容器中的所有组件。

        注意：此方法应在AWT树锁下调用。

        结果
        这个容器中的所有组件的数组。
        另请参见：
        Component.getTreeLock()

      • getInsets

        public Insets getInsets​()
        确定此容器的插入，这表示容器边框的大小。

        例如， Frame对象具有对应于框架的标题栏的高度的顶部插入。

        结果
        这个容器的插图。
        从以下版本开始：
        1.1
        另请参见：
        Insets ， LayoutManager

      • insets

        @Deprecated
public Insets insets​()
        已过时。 从JDK 1.1版开始，由getInsets()替代。
        返回此容器的插入。
        结果
        这个容器的插图

      • add

        public Component add​(Component comp)
        将指定的组件附加到此容器的末尾。 这是一个方便的方法addImpl(java.awt.Component, java.lang.Object, int) 。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果容器已经被显示，则此后必须验证层次结构，以显示添加的组件。

        参数
        comp - 要添加的组件
        结果
        组件参数
        异常
        NullPointerException - 如果 comp是 null
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int) ，
invalidate() ，
validate() ，
JComponent.revalidate()

      • add

        public Component add​(String name,
                     Component comp)
        将指定的组件添加到此容器。 这是一个方便的方法addImpl(java.awt.Component, java.lang.Object, int) 。

        这种方法从1.1开始就已经过时了。 请改用方法add(Component, Object) 。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果容器已经被显示，则此后必须验证层次结构，以显示添加的组件。

        参数
        name - 要添加的组件的名称
        comp - 要添加的组件
        结果
        添加组件
        异常
        NullPointerException - 如果 comp是 null
        另请参见：
        add(Component, Object) ， invalidate()

      • add

        public Component add​(Component comp,
                     int index)
        在给定的位置将指定的组件添加到此容器。 这是一个方便的方法addImpl(java.awt.Component, java.lang.Object, int) 。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果容器已经被显示，则此后必须验证层次结构，以显示添加的组件。

        参数
        comp - 要添加的组件
        index - 要插入组件的位置，或 -1将组件附加到最后
        结果
        组件 comp
        异常
        NullPointerException - 如果 comp是 null
        IllegalArgumentException - 如果 index无效（详情请参阅 addImpl(java.awt.Component, java.lang.Object, int) ）
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int) ，
remove(int) ，
invalidate() ，
validate() ，
JComponent.revalidate()

      • setComponentZOrder

        public void setComponentZOrder​(Component comp,
                               int index)
        将指定的组件移动到容器中指定的z顺序索引。 z次序确定组件被绘制的顺序; 首先使用最高z阶涂料的组分，最后使用最低z阶涂料的组分。 在组件重叠的地方，具有较低z阶的组件涂覆在具有较高z阶的组件上。

        如果组件是某个其他容器的子对象，则在添加到此容器之前将其从该容器中删除。 此方法与java.awt.Container.add(Component, int)之间的重要区别在于，该方法不会在组件中调用removeNotify ，同时将其从其先前的容器中删除，除非必要时，以及底层本机窗口系统允许。 这样，如果组件具有键盘焦点，则在移动到新位置时会保持焦点。

        此属性保证仅适用于轻型非Container组件。

        该方法更改布局相关信息，因此使组件层次结构无效。

        注意 ：并非所有平台都支持将重量级组件的z顺序从一个容器更改为另一个，而无需调用removeNotify 。 无法检测平台是否支持此功能，因此开发人员不应作出任何假设。

        参数
        comp - 要移动的组件
        index - 容器列表中插入组件的位置，其中 getComponentCount()附加到最后
        异常
        NullPointerException - 如果 comp是 null
        IllegalArgumentException - 如果 comp是容器的父母之一
        IllegalArgumentException -如果 index不在范围 [0, getComponentCount()]用于容器之间移动时，或不在范围 [0, getComponentCount()-1]用于容器内部移动
        IllegalArgumentException - 如果向其自身添加容器
        IllegalArgumentException - 如果将 Window添加到容器中
        从以下版本开始：
        1.5
        另请参见：
        getComponentZOrder(java.awt.Component) ， invalidate()

      • getComponentZOrder

        public int getComponentZOrder​(Component comp)
        返回容器内组件的z-order索引。 组件在z阶层次中越高，其索引越低。 最后一个z顺序索引最低的组件，最重要的是其他子组件。
        参数
        comp - 要查询的组件
        结果
        组件的z阶索引; 否则返回-1，如果组件是null或不属于容器
        从以下版本开始：
        1.5
        另请参见：
        setComponentZOrder(java.awt.Component, int)

      • add

        public void add​(Component comp,
                Object constraints)
        将指定的组件添加到此容器的末尾。 还通知布局管理器使用指定的约束对象将组件添加到此容器的布局中。 这是一个方便的方法addImpl(java.awt.Component, java.lang.Object, int) 。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果容器已经被显示，则此后必须验证层次结构，以显示添加的组件。

        参数
        comp - 要添加的组件
        constraints - 表示此组件的布局约束的对象
        异常
        NullPointerException - 如果 comp是 null
        从以下版本开始：
        1.1
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int) ， invalidate() ， validate() ， JComponent.revalidate() ， LayoutManager

      • add

        public void add​(Component comp,
                Object constraints,
                int index)
        将指定的组件添加到指定索引处的指定约束的容器中。 还通知布局管理器使用指定的约束对象将组件添加到此容器的布局。 这是一个方便的方法addImpl(java.awt.Component, java.lang.Object, int) 。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果容器已经被显示，则此后必须验证层次结构，以显示添加的组件。

        参数
        comp - 要添加的组件
        constraints - 一个表示布局约束的对象
        index - 容器列表中插入组件的位置; -1表示在末端组件插入
        异常
        NullPointerException - 如果 comp是 null
        IllegalArgumentException - 如果 index无效（详情请参阅 addImpl(java.awt.Component, java.lang.Object, int) ）
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int) ， invalidate() ， validate() ， JComponent.revalidate() ， remove(int) ， LayoutManager

      • addImpl

        protected void addImpl​(Component comp,
                       Object constraints,
                       int index)
        在指定的索引处将指定的组件添加到此容器。 该方法还通过布局管理器通过addLayoutComponent方法使用指定的约束对象将组件添加到此容器的布局。

        约束由正在使用的特定布局管理器定义。 例如， BorderLayout类定义了五个约束： BorderLayout.NORTH ， BorderLayout.SOUTH ， BorderLayout.EAST ， BorderLayout.WEST ，和BorderLayout.CENTER 。

        GridBagLayout类需要一个GridBagConstraints对象。 未通过正确类型的约束对象会导致一个IllegalArgumentException 。

        如果当前的布局管理器实现了LayoutManager2 ，那么就调用了LayoutManager2.addLayoutComponent(Component,Object) 。 如果当前的布局管理器不实现LayoutManager2 ，并且约束是一个String ，那么它将调用LayoutManager.addLayoutComponent(String,Component) 。

        如果组件不是此容器的祖先，并且具有非空父项，则在将其添加到此容器之前，它将从其当前父进程中删除。

        如果程序需要跟踪每个添加到容器的请求，那么这种方法将会覆盖所有其他添加方法。 一个重写方法通常应该包括调用超类的方法版本：

        super.addImpl(comp, constraints, index)

        该方法更改布局相关信息，因此使组件层次结构无效。 如果容器已经被显示，则此后必须验证层次结构，以显示添加的组件。

        参数
        comp - 要添加的组件
        constraints - 表示此组件的布局约束的对象
        index - 容器列表中要插入组件的位置，其中 -1表示附加到最后
        异常
        IllegalArgumentException - 如果index无效;
如果comp是此容器的小孩，则有效范围为[-1, getComponentCount()-1] ;
如果组件不是此容器的子级，则有效范围为[-1, getComponentCount()]
        IllegalArgumentException - 如果 comp是此容器的祖先
        IllegalArgumentException - 如果向容器添加窗口
        NullPointerException - 如果 comp是 null
        从以下版本开始：
        1.1
        另请参见：
        add(Component) ， add(Component, int) ， add(Component, java.lang.Object) ， invalidate() ， LayoutManager ， LayoutManager2

      • remove

        public void remove​(int index)
        从此容器中删除由index指定的组件。 此方法还通知布局管理器通过removeLayoutComponent方法从该容器的布局中删除组件。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果已经显示了容器，则此后必须验证层次结构以反映更改。

        参数
        index - 要删除的组件的索引
        异常
        ArrayIndexOutOfBoundsException - 如果 index不在范围 [0, getComponentCount()-1]
        从以下版本开始：
        1.1
        另请参见：
        add(java.awt.Component) ，
invalidate() ，
validate() ，
getComponentCount()

      • remove

        public void remove​(Component comp)
        从此容器中删除指定的组件。 此方法还通知布局管理器通过removeLayoutComponent方法从该容器的布局中删除组件。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果已经显示了容器，则此后必须验证层次结构以反映更改。

        参数
        comp - 要删除的组件
        异常
        NullPointerException - 如果 comp是 null
        另请参见：
        add(java.awt.Component) ，
invalidate() ，
validate() ，
remove(int)

      • removeAll

        public void removeAll​()
        从此容器中删除所有组件。 此方法还通知布局管理器通过removeLayoutComponent方法从该容器的布局中删除组件。

        该方法更改布局相关信息，因此使组件层次结构无效。 如果已经显示了容器，则此后必须验证层次结构以反映更改。

        另请参见：
        add(java.awt.Component) ， remove(int) ， invalidate()

      • getLayout

        public LayoutManager getLayout​()
        获取此容器的布局管理器。
        结果
        该容器的当前布局管理器
        另请参见：
        doLayout() ， setLayout(java.awt.LayoutManager)

      • setLayout

        public void setLayout​(LayoutManager mgr)
        设置此容器的布局管理器。

        该方法更改布局相关信息，因此使组件层次结构无效。

        参数
        mgr - 指定的布局管理器
        另请参见：
        doLayout() ，
getLayout() ，
invalidate()

      • doLayout

        public void doLayout​()
        使此容器布置其组件。 大多数程序不应该直接调用此方法，而应该调用validate方法。
        重写：
        doLayout中的 Component
        从以下版本开始：
        1.1
        另请参见：
        LayoutManager.layoutContainer(java.awt.Container) ，
setLayout(java.awt.LayoutManager) ，
validate()

      • layout

        @Deprecated
public void layout​()
        已过时。 从JDK 1.1版开始，由doLayout()替代。
        重写：
        layout在 Component

      • isValidateRoot

        public boolean isValidateRoot​()
        指示此容器是否为验证根 。

        布局相关的更改（例如验证根后代的边界）不会影响验证根父的布局。 当方法遇到有效根时，这种特性使invalidate()方法能够停止使组件层次结构无效。 但是，为了保留向后兼容性，只有当java.awt.smartInvalidate系统属性值设置为true时， java.awt.smartInvalidate启用此新的优化行为。

        如果组件层次结构包含有效的根，并且启用了新的优化的invalidate()行为，则必须在先前无效组件的验证根上调用validate()方法，以便validate()恢复层次结构的有效性。 否则，应使用顶级容器（如Frame对象）调用validate()方法来恢复组件层次结构的有效性。

        Window类和Applet类是AWT中的有效根。 Swing引入更多有效的根。

        结果
        该容器是否是有效的根
        从以下版本开始：
        1.7
        另请参见：
        invalidate() ，
Component.invalidate() ，
JComponent.isValidateRoot() ，
JComponent.revalidate()

      • invalidate

        public void invalidate​()
        使容器无效。

        如果这个容器上安装的LayoutManager是LayoutManager2接口的一个实例，那么LayoutManager2.invalidateLayout(Container)方法被调用，它提供这个Container作为参数。

        之后，此方法标记此容器无效，并使其祖先无效。 有关详细信息，请参阅Component.invalidate()方法。

        重写：
        invalidate在 Component
        另请参见：
        validate() ， layout() ， LayoutManager2

      • validate

        public void validate​()
        验证此容器及其所有子组件。

        验证容器意味着布置其子组件。 与布局相关的更改，例如设置组件的边界，或者向容器添加组件，会自动使容器无效。 请注意，容器的祖先也可能无效（详细信息请参阅Component.invalidate() ）因此，要恢复层次结构的有效性，应在层次结构的最上层无效容器上调用validate()方法。

        验证容器可能是相当耗时的操作。 出于性能原因，开发人员可能推迟层次结构的验证，直到一组布局相关的操作完成，例如在将所有子项添加到容器之后。

        如果这个Container无效，此方法调用validateTree方法并将此Container标记为有效。 否则，不执行任何操作。

        重写：
        validate在 Component
        另请参见：
        add(java.awt.Component) ，
invalidate() ，
isValidateRoot() ，
JComponent.revalidate() ，
validateTree()

      • validateTree

        protected void validateTree​()
        递归地下降容器树，并重新计算标记为需要的任何子树（标记为无效的）的布局。 应该通过调用此方法的方法提供同步： validate 。
        另请参见：
        doLayout() ， validate()

      • setFont

        public void setFont​(Font f)
        设置此容器的字体。

        该方法更改布局相关信息，因此使组件层次结构无效。

        重写：
        setFont在 Component
        参数
        f - 成为此容器字体的字体。
        从以下版本开始：
        1.0
        另请参见：
        Component.getFont() ， invalidate()

      • getPreferredSize

        public Dimension getPreferredSize​()
        返回此容器的首选大小。 如果Component.setPreferredSize(Dimension)没有明确设置首选大小，而此Container具有non-null LayoutManager ，则使用LayoutManager.preferredLayoutSize(Container)计算优选大小。

        注意：某些实现可以缓存从LayoutManager返回的值。 该缓存不需要调用实现preferredLayoutSize上LayoutManager每次调用此方法，而时间LayoutManager后才会进行查询Container变得无效。

        重写：
        getPreferredSize在 Component
        结果
        表示此容器的首选大小的 Dimension的实例。
        另请参见：
        getMinimumSize() ，
getMaximumSize() ，
getLayout() ，
LayoutManager.preferredLayoutSize(Container) ，
Component.getPreferredSize()

      • preferredSize

        @Deprecated
public Dimension preferredSize​()
        已过时。 从JDK 1.1版开始，由getPreferredSize()替代。
        描述从类复制： Component
        返回组件的首选大小。
        重写：
        preferredSize在 Component
        结果
        该组件的首选尺寸

      • getMinimumSize

        public Dimension getMinimumSize​()
        返回此容器的最小大小。 如果Component.setMinimumSize(Dimension)未明确设定最小尺寸，而Container具有non-null LayoutManager ，则LayoutManager.minimumLayoutSize(Container)用于计算最小尺寸。

        注意：一些实现可以缓存从LayoutManager返回的值。 该缓存不需要调用实现minimumLayoutSize上LayoutManager每次调用此方法，而时间LayoutManager后才会进行查询Container变得无效。

        重写：
        getMinimumSize在 Component
        结果
        表示此容器的最小大小的 Dimension的实例。
        从以下版本开始：
        1.1
        另请参见：
        getPreferredSize() ，
getMaximumSize() ，
getLayout() ，
LayoutManager.minimumLayoutSize(Container) ，
Component.getMinimumSize()

      • minimumSize

        @Deprecated
public Dimension minimumSize​()
        已过时。 从JDK 1.1版开始，由getMinimumSize()替代。
        描述从类复制： Component
        返回此组件的最小大小。
        重写：
        minimumSize在 Component
        结果
        该组件的最小尺寸

      • getMaximumSize

        public Dimension getMaximumSize​()
        返回此容器的最大大小。 如果最大尺寸没有被明确设置Component.setMaximumSize(Dimension)和LayoutManager安装在此Container就是一个实例LayoutManager2 ，然后LayoutManager2.maximumLayoutSize(Container)用于计算的最大尺寸。

        注意：某些实现可以缓存从LayoutManager2返回的值。 该缓存不需要调用实现maximumLayoutSize上LayoutManager2每次调用此方法，而时间LayoutManager2后才会进行查询Container变得无效。

        重写：
        getMaximumSize中的 Component
        结果
        一个表示此容器最大大小的 Dimension的实例。
        另请参见：
        getPreferredSize() ，
getMinimumSize() ，
getLayout() ，
LayoutManager2.maximumLayoutSize(Container) ，
Component.getMaximumSize()

      • getAlignmentX

        public float getAlignmentX​()
        返回沿x轴的对齐方式。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        重写：
        getAlignmentX在 Component
        结果
        该组件的水平对齐

      • getAlignmentY

        public float getAlignmentY​()
        返回沿着y轴的对齐。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        重写：
        getAlignmentY在 Component
        结果
        该组件的垂直对齐

      • paint

        public void paint​(Graphics g)
        涂上容器 这会将油漆转移到任何这个容器的小孩的轻量级组件。 如果重新实现此方法，则应调用super.paint（g），以便轻量级组件正确呈现。 如果一个子组件被当前的剪裁设置（g）全部剪除，那么paint（）将不会转发给该小孩。
        重写：
        paint在 Component
        参数
        g - 指定的图形窗口
        另请参见：
        Component.update(Graphics)

      • update

        public void update​(Graphics g)
        更新容器。 这将更新转发给任何作为此容器的子级的轻量级组件。 如果重新实现此方法，则应调用super.update（g），以便正确渲染轻量级组件。 如果子组件被目前的削减设置（g）修剪完毕，则update（）不会被转发给该小孩。
        重写：
        update在 Component
        参数
        g - 指定的图形窗口
        另请参见：
        Component.update(Graphics)

      • print

        public void print​(Graphics g)
        打印容器。 这将打印转发到任何这个容器的孩子的轻量级组件。 如果重新实现此方法，则应调用super.print（g），以便正确渲染轻量级组件。 如果子组件完全被g中的剪切设置所限制，则print（）将不会转发给该小孩。
        重写：
        print在 Component
        参数
        g - 指定的图形窗口
        另请参见：
        Component.update(Graphics)

      • paintComponents

        public void paintComponents​(Graphics g)
        涂抹此容器中的每个组件。
        参数
        g - 图形上下文。
        另请参见：
        Component.paint(java.awt.Graphics) ， Component.paintAll(java.awt.Graphics)

      • printComponents

        public void printComponents​(Graphics g)
        打印此容器中的每个组件。
        参数
        g - 图形上下文。
        另请参见：
        Component.print(java.awt.Graphics) ， Component.printAll(java.awt.Graphics)

      • addContainerListener

        public void addContainerListener​(ContainerListener l)
        添加指定的容器侦听器以从此容器接收容器事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 容器侦听器
        另请参见：
        removeContainerListener(java.awt.event.ContainerListener) ， getContainerListeners()

      • removeContainerListener

        public void removeContainerListener​(ContainerListener l)
        删除指定的容器侦听器，使其不再从此容器接收容器事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 容器侦听器
        另请参见：
        addContainerListener(java.awt.event.ContainerListener) ， getContainerListeners()

      • getContainerListeners

        public ContainerListener[] getContainerListeners​()
        返回在此容器上注册的所有容器侦听器的数组。
        结果
        所有这个容器的 ContainerListener s或一个空数组，如果没有容器侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addContainerListener(java.awt.event.ContainerListener) ， removeContainerListener(java.awt.event.ContainerListener)

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册为FooListener的所有对象的数组，这个Container 。 FooListener使用addFooListener方法进行注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询Container c的容器侦听器：

          ContainerListener[] cls = (ContainerListener[])(c.getListeners(ContainerListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在 Component
        参数类型
        T - 侦听器的类型
        参数
        listenerType - 所请求的侦听器的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此容器上注册为 FooListener的所有对象的数组，如果没有添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType未指定实现 java.util.EventListener的类或接口
        NullPointerException - 如果 listenerType是 null
        从以下版本开始：
        1.3
        另请参见：
        getContainerListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此容器上的事件。 如果事件是一个ContainerEvent ，它调用processContainerEvent方法，否则它调用其超类的processEvent 。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        重写：
        processEvent中的 Component
        参数
        e - 事件
        另请参见：
        Component.processComponentEvent(java.awt.event.ComponentEvent) ，
Component.processFocusEvent(java.awt.event.FocusEvent) ，
Component.processKeyEvent(java.awt.event.KeyEvent) ，
Component.processMouseEvent(java.awt.event.MouseEvent) ，
Component.processMouseMotionEvent(java.awt.event.MouseEvent) ，
Component.processInputMethodEvent(java.awt.event.InputMethodEvent) ，
Component.processHierarchyEvent(java.awt.event.HierarchyEvent) ，
Component.processMouseWheelEvent(java.awt.event.MouseWheelEvent)

      • processContainerEvent

        protected void processContainerEvent​(ContainerEvent e)
        通过将容器事件发送到任何已注册的ContainerListener对象来处理容器事件。 注意：除非为此组件启用容器事件，否则不会调用此方法; 发生以下情况之一时：
        • ContainerListener对象通过addContainerListener注册
        • 容器事件通过enableEvents启用

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        参数
        e - 容器事件
        另请参见：
        Component.enableEvents(long)

      • deliverEvent

        @Deprecated
public void deliverEvent​(Event e)
        已过时。 从JDK 1.1版开始，替换为dispatchEvent(AWTEvent e)
        重写：
        deliverEvent在 Component
        参数
        e - 交付事件

      • getComponentAt

        public Component getComponentAt​(int x,
                                int y)
        找到包含x，y位置的组件。 在组件中存在重叠的情况下，返回最顶层的子组件。 这通过找到通过Component.contains（）声明包含给定点的索引0最接近的组件来确定，除了具有本机对等体的组件优先于不具有本机对等体的组件（即，轻量级组件）之外。
        重写：
        getComponentAt在 Component
        参数
        x - x坐标
        y - y坐标
        结果
        如果组件不包含位置，则为null。 如果请求点没有子组件，并且该点在容器的边界内，则返回容器本身; 否则返回最顶端的孩子。
        从以下版本开始：
        1.1
        另请参见：
        Component.contains(int, int)

      • locate

        @Deprecated
public Component locate​(int x,
                        int y)
        已过时。 从JDK 1.1版开始，由getComponentAt(int, int)代替。
        描述从类复制： Component
        返回占据指定位置的组件（此组件或直接子组件，如果前两个都不占用该位置，则返回null）。
        重写：
        locate在 Component
        参数
        x - 搜索组件的 x坐标
        y - 用于搜索组件的 y坐标
        结果
        指定位置的组件或 null

      • getComponentAt

        public Component getComponentAt​(Point p)
        获取包含指定点的组件。
        重写：
        getComponentAt类 Component
        参数
        p - 关键。
        结果
        返回包含该点的组件，如果组件不包含该点，则返回 null 。
        从以下版本开始：
        1.1
        另请参见：
        Component.contains(int, int)

      • getMousePosition

        public Point getMousePosition​(boolean allowChildren)
                       throws HeadlessException
        如果Container在鼠标指针下方，则返回鼠标指针在这个Container的坐标空间中的Container ，否则返回null 。 该方法类似于Component.getMousePosition() ，但可以考虑Container的孩子。 如果allowChildren是false ，则只有当鼠标指针直接位于false ，该方法才会返回非空值，而不是Container上方的部分上方。 如果allowChildren是true ，如果鼠标指针高于Container或其任何后代，则此方法返回非空值。
        参数
        allowChildren - 如果孩子应该被考虑， allowChildren true
        结果
        相对于此 Component鼠标坐标，或null
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.5
        另请参见：
        Component.getMousePosition()

      • findComponentAt

        public Component findComponentAt​(int x,
                                 int y)
        找到包含指定位置的可见子组件。 在组件中存在重叠的情况下，返回最顶层的子组件。 如果包含子组件是容器，则此方法将继续搜索最深的嵌套子组件。 在搜索过程中忽略不可见的组件。

        getComponentAt方法与getComponentAt不同，因为getComponentAt只搜索Container的直接子对象; 如果包含的组件是一个Container，那么findComponentAt将搜索该子节点以查找嵌套组件。

        参数
        x - x坐标
        y - y坐标
        结果
        如果组件不包含位置，则为null。 如果在请求点没有子组件，并且该点在容器的边界内，则返回容器本身。
        从以下版本开始：
        1.2
        另请参见：
        Component.contains(int, int) ， getComponentAt(int, int)

      • findComponentAt

        public Component findComponentAt​(Point p)
        找到包含指定点的可见子组件。 在组件中存在重叠的情况下，返回最顶层的子组件。 如果包含子组件是容器，则此方法将继续搜索最深的嵌套子组件。 在搜索过程中忽略不可见的组件。

        getComponentAt方法与getComponentAt不同，因为getComponentAt只搜索Container的直接子对象; 如果包含的组件是一个Container，那么findComponentAt将搜索该子节点以查找嵌套组件。

        参数
        p - 点。
        结果
        如果组件不包含位置，则为null。 如果在请求点没有子组件，并且该点在容器的边界内，则返回容器本身。
        异常
        NullPointerException - 如果 p是 null
        从以下版本开始：
        1.2
        另请参见：
        Component.contains(int, int) ， getComponentAt(int, int)

      • addNotify

        public void addNotify​()
        通过将此容器连接到本机屏幕资源来使此容器显示。 使容器显示可以使所有的孩子都可以显示。 该方法由工具包内部调用，不应由程序直接调用。
        重写：
        addNotify在 Component
        另请参见：
        Component.isDisplayable() ， removeNotify()

      • removeNotify

        public void removeNotify​()
        通过删除其与其本机屏幕资源的连接，使此容器不可显示。 使容器不可显示将导致其所有的孩子都变得不可显示。 该方法在内部被工具包调用，不应该被程序直接调用。
        重写：
        removeNotify在 Component
        另请参见：
        Component.isDisplayable() ， addNotify()

      • isAncestorOf

        public boolean isAncestorOf​(Component c)
        检查组件是否包含在此容器的组件层次结构中。
        参数
        c - 组件
        结果
        true如果是祖先， 否则为false 。
        从以下版本开始：
        1.1

      • paramString

        protected String paramString​()
        返回一个表示Container状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Component
        结果
        该容器的参数字符串

      • list

        public void list​(PrintStream out,
                 int indent)
        将此容器的列表打印到指定的输出流。 列表从指定的缩进开始。

        容器的直接儿童印有压痕indent+1 。 这些孩子的孩子们打印在indent+2等等。

        重写：
        list在 Component
        参数
        out - 打印流
        indent - 要缩进的空格数
        异常
        NullPointerException - 如果 out是 null
        从以下版本开始：
        1.0
        另请参见：
        Component.list(java.io.PrintStream, int)

      • list

        public void list​(PrintWriter out,
                 int indent)
        从指定的缩进开始列出指定的打印作者的列表。

        容器的直接子项印有压痕indent+1 。 这些孩子的孩子打印在indent+2等等。

        重写：
        list中的 Component
        参数
        out - 打印作者
        indent - 缩进的空格数
        异常
        NullPointerException - 如果 out是 null
        从以下版本开始：
        1.1
        另请参见：
        Component.list(java.io.PrintWriter, int)

      • setFocusTraversalKeys

        public void setFocusTraversalKeys​(int id,
                                  Set<? extends AWTKeyStroke> keystrokes)
        设置此容器的给定遍历操作的焦点遍历键。

        容器的焦点遍历键的默认值是依赖于实现的。 Sun建议特定本地平台的所有实现使用相同的默认值。 Windows和Unix的建议如下。 这些建议用于Sun AWT实现。

        Recommended default values for a Container's focus traversal keys Identifier Meaning Default KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS Normal forward keyboard traversal TAB on KEY_PRESSED, CTRL-TAB on KEY_PRESSED KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS Normal reverse keyboard traversal SHIFT-TAB on KEY_PRESSED, CTRL-SHIFT-TAB on KEY_PRESSED KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS Go up one focus traversal cycle none KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS Go down one focus traversal cycle none
        要禁用遍历键，请使用空的Set; 推荐使用Collections.EMPTY_SET。

        使用AWTKeyStroke API，客户端代码可以指定两个特定的KeyEvent，KEY_PRESSED或KEY_RELEASED中的哪一个，焦点遍历操作将发生。 然而，无论指定了哪个KeyEvent，与焦点遍历密钥相关的所有KeyEvent都将被使用，包括关联的KEY_TYPED事件，并且不会被分派到任何Container。 指定一个KEY_TYPED事件作为映射到焦点遍历操作的运行时错误，或将同一事件映射到多个默认焦点遍历操作。

        如果为Set指定了null值，则此Container将从其父项继承Set。 如果此容器的所有祖先对于Set指定了空值，则使用当前的KeyboardFocusManager的默认Set。

        这个方法可能会抛出一个ClassCastException如果Object中有keystrokes不是AWTKeyStroke 。

        重写：
        setFocusTraversalKeys在 Component
        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS之一
        keystrokes - 指定操作的AWTKeyStroke集
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS中的一个，或者键击包含null，或者如果任何键击代表KEY_TYPED事件，或者如果任何键击已经映射到另一个焦点遍历此容器的操作
        从以下版本开始：
        1.4
        另请参见：
        getFocusTraversalKeys(int) ， KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS ， KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS

      • getFocusTraversalKeys

        public Set<AWTKeyStroke> getFocusTraversalKeys​(int id)
        返回此Container的给定遍历操作的聚焦遍历键集。 （有关每个键的完整说明，请参阅setFocusTraversalKeys ）

        如果尚未为此Container显式定义一组遍历键，则返回此Container的父级Set。 如果没有为此Container的任何祖先显式定义Set，则返回当前的KeyboardFocusManager的默认Set。

        重写：
        getFocusTraversalKeys在 Component
        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS之一，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS
        结果
        指定操作的AWTKeyStrokes集。 该集将不可修改，可能为空。 将永远不会返回null。
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS中的一个
        从以下版本开始：
        1.4
        另请参见：
        setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS ， KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS

      • areFocusTraversalKeysSet

        public boolean areFocusTraversalKeysSet​(int id)
        返回是否为此容器显式定义了给定焦点遍历操作的聚焦遍历键集。 如果此方法返回false ，则此Container将从祖先继承Set，或从当前的KeyboardFocusManager继承。
        重写：
        areFocusTraversalKeysSet在 Component
        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS之一，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS
        结果
        true如果为该组件明确定义了给定焦点遍历操作的聚焦遍历键集合; false否则。
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS中的一个
        从以下版本开始：
        1.4

      • isFocusCycleRoot

        public boolean isFocusCycleRoot​(Container container)
        返回指定的Container是否是此Container的焦点遍历循环的焦点循环根。 每个焦点遍历循环只有一个焦点循环根，而不是焦点循环根的每个容器只属于单个焦点遍历循环。 作为焦点循环根的容器属于两个循环：一个根据容器本身，一个根据容器最近的聚焦循环根祖先。 在这种情况下，这种方法将返回true这两个容器。
        重写：
        isFocusCycleRoot在 Component
        参数
        container - 要测试的容器
        结果
        true如果指定的Container是此Container的焦点true根; 否则为false
        从以下版本开始：
        1.4
        另请参见：
        isFocusCycleRoot()

      • setFocusTraversalPolicy

        public void setFocusTraversalPolicy​(FocusTraversalPolicy policy)
        设置焦点遍历策略，将管理此Container的子项的键盘遍历，如果此Container是焦点循环根。 如果参数为null，则此Container将从其focus-cycle-root祖先继承其策略。 如果参数为非空值，则该策略将被所有不具有自己的键盘遍历策略的focus-cycle-root子节点继承（递归地，它们的焦点循环根节点）。

        如果此容器不是焦点循环根，则策略将被记住，但不会由此或任何其他容器使用或继承，直到此容器成为焦点循环根。

        参数
        policy - 此容器的新焦点遍历策略
        从以下版本开始：
        1.4
        另请参见：
        getFocusTraversalPolicy() ， setFocusCycleRoot(boolean) ， isFocusCycleRoot(java.awt.Container)

      • getFocusTraversalPolicy

        public FocusTraversalPolicy getFocusTraversalPolicy​()
        返回将管理此Container的子项的键盘遍历的焦点遍历策略，如果此Container不是焦点循环根，则返回null。 如果没有为此Container显式设置遍历策略，则返回此Container的focus-cycle-root祖先的策略。
        结果
        此容器的焦点遍历策略，如果此Container不是焦点循环根，则为null。
        从以下版本开始：
        1.4
        另请参见：
        setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ， setFocusCycleRoot(boolean) ， isFocusCycleRoot(java.awt.Container)

      • isFocusTraversalPolicySet

        public boolean isFocusTraversalPolicySet​()
        返回是否为此Container显式设置了重点遍历策略。 如果此方法返回false ，则此Container将从祖先继承其焦点遍历策略。
        结果
        true如果已经为此Container显式设置了焦点遍历策略; false否则。
        从以下版本开始：
        1.4

      • setFocusCycleRoot

        public void setFocusCycleRoot​(boolean focusCycleRoot)
        设置此容器是否是焦点遍历循环的根。 一旦焦点进入遍历循环，通常不能通过焦点遍历离开它，除非按下了上下循环键之一。 正常遍历仅限于此Container，并且所有这些Container的后代不是下焦点循环根的后代。 请注意，FocusTraversalPolicy可能会弯曲这些限制。 例如，ContainerOrderFocusTraversalPolicy支持隐式的下循环遍历。

        指定此Container的子进程的遍历顺序的另一种方法是使此Container为focus traversal policy provider 。

        参数
        focusCycleRoot - 指示此容器是否是焦点遍历循环的根
        从以下版本开始：
        1.4
        另请参见：
        isFocusCycleRoot() ， setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ， getFocusTraversalPolicy() ， ContainerOrderFocusTraversalPolicy ， setFocusTraversalPolicyProvider(boolean)

      • isFocusCycleRoot

        public boolean isFocusCycleRoot​()
        返回此容器是否是焦点遍历循环的根。 一旦焦点进入遍历循环，通常不能通过焦点遍历离开它，除非按下了上下循环键之一。 正常遍历仅限于此Container，并且所有这些Container的后代不是下焦点循环根的后代。 请注意，FocusTraversalPolicy可能会弯曲这些限制。 例如，ContainerOrderFocusTraversalPolicy支持隐式的下循环遍历。
        结果
        这个容器是否是焦点遍历循环的根
        从以下版本开始：
        1.4
        另请参见：
        setFocusCycleRoot(boolean) ， setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ， getFocusTraversalPolicy() ， ContainerOrderFocusTraversalPolicy

      • setFocusTraversalPolicyProvider

        public final void setFocusTraversalPolicyProvider​(boolean provider)
        设置此容器是否将用于提供焦点遍历策略。 将使用此属性为true容器来获取焦点遍历策略，而不是最近的焦点循环根祖先。
        参数
        provider - 指示此容器是否将用于提供焦点遍历策略
        从以下版本开始：
        1.5
        另请参见：
        setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ，
getFocusTraversalPolicy() ，
isFocusTraversalPolicyProvider()

      • isFocusTraversalPolicyProvider

        public final boolean isFocusTraversalPolicyProvider​()
        返回此容器是否提供焦点遍历策略。 如果此属性设置为true那么当键盘焦点管理器搜索容器层次结构以进行焦点遍历策略，并且在此属性为true或焦点循环根的任何其他容器之前遇到此容器时，将使用其焦点遍历策略而不是焦点循环根策略。
        结果
        true如果此容器提供焦点遍历策略，否则为 false
        从以下版本开始：
        1.5
        另请参见：
        setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ， getFocusTraversalPolicy() ， setFocusCycleRoot(boolean) ， setFocusTraversalPolicyProvider(boolean)

      • transferFocusDownCycle

        public void transferFocusDownCycle​()
        将焦点转移到一个焦点遍历周期。 如果此容器是焦点循环根，则将焦点所有者设置为此Container的默认组件以进行对焦，并将当前焦点循环根设置为此Container。 如果此Container不是焦点循环根，则不会发生焦点遍历操作。
        从以下版本开始：
        1.4
        另请参见：
        Component.requestFocus() ，
isFocusCycleRoot(java.awt.Container) ，
setFocusCycleRoot(boolean)

      • applyComponentOrientation

        public void applyComponentOrientation​(ComponentOrientation o)
        设置此容器的ComponentOrientation属性及其中包含的所有组件。

        该方法更改布局相关信息，因此使组件层次结构无效。

        重写：
        applyComponentOrientation在 Component
        参数
        o - 此容器的新组件方向及其中包含的组件。
        异常
        NullPointerException - 如果 orientation为空。
        从以下版本开始：
        1.4
        另请参见：
        Component.setComponentOrientation(java.awt.ComponentOrientation) ，
Component.getComponentOrientation() ，
invalidate()

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        将PropertyChangeListener添加到侦听器列表。 监听器已注册到此类的所有绑定属性，包括以下内容：
        • 这个容器的字体（“font”）
        • 此容器的背景颜色（“背景”）
        • 这个容器的前景色（“前景”）
        • 这个集装箱的聚焦性（“可聚焦”）
        • 此容器的焦点遍历键启用状态（“focusTraversalKeysEnabled”）
        • 此容器的一组FORWARD_TRAVERSAL_KEYS（“forwardFocusTraversalKeys”）
        • 此容器的一组BACKWARD_TRAVERSAL_KEYS（“backwardFocusTraversalKeys”）
        • 这个容器的一套UP_CYCLE_TRAVERSAL_KEYS（“upCycleFocusTraversalKeys”）
        • 这个容器的一套DOWN_CYCLE_TRAVERSAL_KEYS（“downCycleFocusTraversalKeys”）
        • 这个容器的焦点遍历策略（“focusTraversalPolicy”）
        • 这个容器的焦点循环根状态（“focusCycleRoot”）
        请注意，如果此容器是继承绑定属性，则不会在继承的属性中更改事件时触发任何事件。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        重写：
        addPropertyChangeListener在 Component
        参数
        listener - 要添加的PropertyChangeListener
        另请参见：
        Component.removePropertyChangeListener(java.beans.PropertyChangeListener) ， addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String propertyName,
                                      PropertyChangeListener listener)
        将PropertyChangeListener添加到特定属性的侦听器列表中。 指定的属性可能是用户定义的，也可能是以下默认值之一：
        • 这个容器的字体（“font”）
        • 此容器的背景颜色（“背景”）
        • 这个容器的前景色（“前景”）
        • 这个集装箱的聚焦性（“可聚焦”）
        • 此容器的焦点遍历键启用状态（“focusTraversalKeysEnabled”）
        • 此容器的一组FORWARD_TRAVERSAL_KEYS（“forwardFocusTraversalKeys”）
        • 此容器的一组BACKWARD_TRAVERSAL_KEYS（“backwardFocusTraversalKeys”）
        • 这个容器的一套UP_CYCLE_TRAVERSAL_KEYS（“upCycleFocusTraversalKeys”）
        • 这个容器的一套DOWN_CYCLE_TRAVERSAL_KEYS（“downCycleFocusTraversalKeys”）
        • 这个容器的焦点遍历策略（“focusTraversalPolicy”）
        • 这个容器的焦点循环根状态（“focusCycleRoot”）
        • 该容器的焦点遍历策略提供者状态（“focusTraversalPolicyProvider”）
        • 该容器的焦点遍历策略提供者状态（“focusTraversalPolicyProvider”）
        请注意，如果此容器是继承绑定属性，则不会在继承的属性中更改事件时触发任何事件。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        重写：
        addPropertyChangeListener在 Component
        参数
        propertyName - 上面列出的属性名称之一
        listener - 要添加的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， Component.removePropertyChangeListener(java.beans.PropertyChangeListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Container.AccessibleAWTContainer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Container.AccessibleAWTContainer

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    已知直接子类：
    Box.AccessibleBox ， CellRendererPane.AccessibleCellRendererPane ， JComponent.AccessibleJComponent ， Panel.AccessibleAWTPanel ， ScrollPane.AccessibleAWTScrollPane ， Window.AccessibleAWTWindow
    Enclosing class:
    Container

    protected class Container.AccessibleAWTContainer
extends Component.AccessibleAWTComponent
    Container的内部类用于为辅助功能提供默认支持。 这个类不是由应用程序开发人员直接使用的，而是意味着仅由容器开发人员进行子类化。

    该类用于获取此对象的可访问角色，以及在AccessibleContainer界面中实现许多方法。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Container.AccessibleAWTContainer.AccessibleContainerHandler
      Fire PropertyChange侦听器，如果有人注册，当孩子被添加或删除。

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ContainerListener accessibleContainerHandler
      处理器 PropertyChange当孩子被添加或删除时

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTContainer​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      Accessible getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      Accessible getAccessibleChild​(int i)
      返回对象的第n个 Accessible子对象。
      int getAccessibleChildrenCount​()
      返回对象中可访问的子项数。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除一个PropertyChangeListener。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleRole, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • accessibleContainerHandler

        protected ContainerListener accessibleContainerHandler
        PropertyChange或移除儿童时，处理程序 PropertyChange

    • 构造方法详细信息

      • AccessibleAWTContainer

        protected AccessibleAWTContainer​()

    • 方法详细信息

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount​()
        返回对象中可访问的子项数。 如果这个对象的所有子项都实现了Accessible ，那么这个方法应该返回这个对象的子Accessible 。
        重写：
        getAccessibleChildrenCount在 Component.AccessibleAWTComponent
        结果
        对象中可访问的孩子的数量

      • getAccessibleChild

        public Accessible getAccessibleChild​(int i)
        返回对象的第n个 Accessible子对象。
        重写：
        getAccessibleChild在 Component.AccessibleAWTComponent
        参数
        i - 基于零的儿童索引
        结果
        对象的第n个 Accessible小孩
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleAt

        public Accessible getAccessibleAt​(Point p)
        返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
        Specified by:
        getAccessibleAt在接口 AccessibleComponent
        重写：
        getAccessibleAt在 Component.AccessibleAWTComponent
        参数
        p -定义的左上角点 Accessible ，在对象的父对象的坐标空间中给出
        结果
        Accessible ，如果存在，在指定的位置; 其他null

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        将PropertyChangeListener添加到侦听器列表。
        重写：
        addPropertyChangeListener在 Component.AccessibleAWTComponent
        参数
        listener - 要添加的PropertyChangeListener
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY ， AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY ， AccessibleContext.ACCESSIBLE_STATE_PROPERTY ， AccessibleContext.ACCESSIBLE_VALUE_PROPERTY ， AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY ， AccessibleContext.ACCESSIBLE_TEXT_PROPERTY ， AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener listener)
        从侦听器列表中删除一个PropertyChangeListener。 这会删除为所有属性注册的PropertyChangeListener。
        重写：
        removePropertyChangeListener在 Component.AccessibleAWTComponent
        参数
        listener - 要删除的PropertyChangeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Container.AccessibleAWTContainer.AccessibleContainerHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Container.AccessibleAWTContainer.AccessibleContainerHandler

  • java.lang.Object
    • java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
  • All Implemented Interfaces:
    ContainerListener ， EventListener
    Enclosing class:
    Container.AccessibleAWTContainer

    protected class Container.AccessibleAWTContainer.AccessibleContainerHandler
extends Object
implements ContainerListener
    消防 PropertyChange侦听器，如果有人注册，当孩子被添加或删除。
    从以下版本开始：
    1.3

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleContainerHandler​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void componentAdded​(ContainerEvent e)
      当组件已添加到容器时调用。
      void componentRemoved​(ContainerEvent e)
      当组件从容器中删除时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleContainerHandler

        protected AccessibleContainerHandler​()

    • 方法详细信息

      • componentAdded

        public void componentAdded​(ContainerEvent e)
        描述从接口ContainerListener复制
        当组件已添加到容器时调用。
        Specified by:
        componentAdded在接口 ContainerListener
        参数
        e - 要处理的事件

      • componentRemoved

        public void componentRemoved​(ContainerEvent e)
        描述从接口ContainerListener复制
        当组件从容器中删除时调用。
        Specified by:
        componentRemoved在接口 ContainerListener
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContainerOrderFocusTraversalPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class ContainerOrderFocusTraversalPolicy

  • java.lang.Object
    • java.awt.FocusTraversalPolicy
      • java.awt.ContainerOrderFocusTraversalPolicy
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    DefaultFocusTraversalPolicy

    public class ContainerOrderFocusTraversalPolicy
extends FocusTraversalPolicy
implements Serializable
    FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。 从特定的焦点循环根中，策略对组件层次结构进行预先遍历，并根据Container.getComponents()返回的数组的顺序遍历Container的子Container.getComponents() 。 层级结构中不可见和可显示的部分将不被搜索。

    默认情况下，ContainerOrderFocusTraversalPolicy隐式转移焦点下行循环。 也就是说，在正常的正向聚焦遍历期间，在焦点循环根之后遍历的组件将是focus-cycle-root的默认组件对焦。 可以使用setImplicitDownCycleTraversal方法禁用此行为。

    默认情况下，此类的方法只有在可见，可显示，启用和可聚焦的情况下才会返回组件。 子类可以通过覆盖accept方法来修改此行为。

    此政策考虑到了focus traversal policy providers 。 当搜索第一个/最后一个/下一个/上一个组件时，如果遇到焦点遍历策略提供程序，则其焦点遍历策略用于执行搜索操作。

    从以下版本开始：
    1.4
    另请参见：
    Container.getComponents() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContainerOrderFocusTraversalPolicy​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected boolean accept​(Component aComponent)
      确定组件是否是新焦点所有者的可接受选择。
      Component getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      Component getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      Component getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      boolean getImplicitDownCycleTraversal​()
      返回此ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行循环。
      Component getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      void setImplicitDownCycleTraversal​(boolean implicitDownCycleTraversal)
      设置此ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行周期。

      • Methods inherited from class java.awt.FocusTraversalPolicy

        getInitialComponent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ContainerOrderFocusTraversalPolicy

        public ContainerOrderFocusTraversalPolicy​()

    • 方法详细信息

      • getComponentAfter

        public Component getComponentAfter​(Container aContainer,
                                   Component aComponent)
        返回在aComponent之后应该接收焦点的Component。 aContainer必须是aComponent或焦点遍历策略提供者的焦点循环根。

        默认情况下，ContainerOrderFocusTraversalPolicy隐式转移焦点下行循环。 也就是说，在正常的正向聚焦遍历期间，在焦点循环根之后遍历的组件将是focus-cycle-root的默认组件对焦。 可以使用setImplicitDownCycleTraversal方法禁用此行为。

        如果aContainer是focus traversal policy provider ，则焦点总是被转移到周期。

        Specified by:
        getComponentAfter在 FocusTraversalPolicy
        参数
        aContainer - aComponent或焦点遍历策略提供程序的焦点循环根
        aComponent - aContainer的一个（可能是间接的）子，或者一个 aComponent本身
        结果
        应该在aComponent之后接收焦点的组件，如果没有找到合适的组件，则为null
        异常
        IllegalArgumentException - 如果aContainer不是aComponent或焦点遍历策略提供程序的焦点循环根，或者aContainer或aComponent为null

      • getComponentBefore

        public Component getComponentBefore​(Container aContainer,
                                    Component aComponent)
        返回应该在aComponent之前接收焦点的Component。 aContainer必须是aComponent的焦点循环根或focus traversal policy provider 。
        Specified by:
        getComponentBefore中的 FocusTraversalPolicy
        参数
        aContainer - 组件或焦点遍历策略提供者的焦点循环根
        aComponent - aContainer的一个（可能是间接的）子，或者一个 aComponent本身
        结果
        应该在aComponent之前收到焦点的组件，如果没有找到合适的组件，则为null
        异常
        IllegalArgumentException - 如果aContainer不是组件或焦点遍历策略提供程序的焦点循环根，或者aContainer或aComponent为null

      • getFirstComponent

        public Component getFirstComponent​(Container aContainer)
        返回遍历周期中的第一个Component。 该方法用于确定当向前方向遍历包装时要聚焦的下一个组件。
        Specified by:
        getFirstComponent在 FocusTraversalPolicy
        参数
        aContainer - 要返回其第一个组件的焦点循环根或焦点遍历策略提供程序
        结果
        aContainer遍历周期中的第一个组件，如果没有找到合适的组件，则返回null
        异常
        IllegalArgumentException - 如果aContainer为空

      • getLastComponent

        public Component getLastComponent​(Container aContainer)
        返回遍历周期中的最后一个组件。 该方法用于确定当相反方向遍历包装时要聚焦的下一个组件。
        Specified by:
        getLastComponent类 FocusTraversalPolicy
        参数
        aContainer - 要返回最后一个组件的焦点循环根或焦点遍历策略提供程序
        结果
        aContainer遍历周期中的最后一个组件，如果没有找到合适的组件，则返回null
        异常
        IllegalArgumentException - 如果aContainer为空

      • getDefaultComponent

        public Component getDefaultComponent​(Container aContainer)
        返回要对焦的默认组件。 当向下移动到基于aContainer的新的焦点遍历循环时，该组件将成为第一个接收焦点的组件。 此方法的默认实现返回与getFirstComponent相同的组件。
        Specified by:
        getDefaultComponent中的 FocusTraversalPolicy
        参数
        aContainer - 要返回默认组件的焦点循环根或焦点遍历策略提供程序
        结果
        aContainer遍历周期中的默认组件，如果没有找到合适的组件，则返回null
        异常
        IllegalArgumentException - 如果aContainer为空
        另请参见：
        getFirstComponent(java.awt.Container)

      • setImplicitDownCycleTraversal

        public void setImplicitDownCycleTraversal​(boolean implicitDownCycleTraversal)
        设置此ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行周期。 如果是true ，在正常的向前聚焦遍历期间，在聚焦周期之后遍历的组件将是focus-cycle-root的默认组件对焦。 如果为false ，则将以遍历指定的焦点循环根为单位的对象遍历周期中的下一个组件进行遍历。 该属性的默认值为true 。
        参数
        implicitDownCycleTraversal - 这个ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行周期
        另请参见：
        getImplicitDownCycleTraversal() ， getFirstComponent(java.awt.Container)

      • getImplicitDownCycleTraversal

        public boolean getImplicitDownCycleTraversal​()
        返回此ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行循环。 如果是true ，在正常的向前聚焦遍历期间，在聚焦周期之后遍历的组件将是focus-cycle-root的默认组件对焦。 如果是false ，则将以遍历指定的焦点循环根的方式遍历聚焦遍历周期中的下一个组件。
        结果
        这个ContainerOrderFocusTraversalPolicy是否隐式转移焦点下行周期
        另请参见：
        setImplicitDownCycleTraversal(boolean) ， getFirstComponent(java.awt.Container)

      • accept

        protected boolean accept​(Component aComponent)
        确定组件是否是新焦点所有者的可接受选择。 默认情况下，当且仅当它可见，可显示，启用和可聚焦时，此方法将接受组件。
        参数
        aComponent - 要测试适合作为焦点所有者的组件
        结果
        如果aComponent可见，可显示，启用和可聚焦， true ; 否则为false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Cursor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Cursor

  • java.lang.Object
    • java.awt.Cursor
  • All Implemented Interfaces:
    Serializable

    public class Cursor
extends Object
implements Serializable
    封装鼠标光标位图表示的类。
    另请参见：
    Component.setCursor(java.awt.Cursor) ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CROSSHAIR_CURSOR
      十字准线游标类型。
      static int CUSTOM_CURSOR
      与所有自定义光标相关联的类型。
      static int DEFAULT_CURSOR
      默认游标类型（如果未定义游标，则设置）。
      static int E_RESIZE_CURSOR
      东调整游标类型。
      static int HAND_CURSOR
      手指光标类型。
      static int MOVE_CURSOR
      移动光标类型。
      static int N_RESIZE_CURSOR
      北移大小的游标类型。
      protected String name
      光标的用户可见名称。
      static int NE_RESIZE_CURSOR
      东北调整大小的光标类型。
      static int NW_RESIZE_CURSOR
      西北大小的游标类型。
      protected static Cursor[] predefined
      已过时。
      从JDK 1.7版开始，应该使用getPredefinedCursor(int)方法。
      static int S_RESIZE_CURSOR
      调整大小的光标类型。
      static int SE_RESIZE_CURSOR
      东南大小的光标类型。
      static int SW_RESIZE_CURSOR
      西南大小的光标类型。
      static int TEXT_CURSOR
      文本光标类型。
      static int W_RESIZE_CURSOR
      西调整游标类型。
      static int WAIT_CURSOR
      等待光标类型。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        Cursor​(int type)
      创建一个指定类型的新的游标对象。
      protected Cursor​(String name)
      使用指定的名称创建一个新的自定义游标对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Cursor getDefaultCursor​()
      返回系统默认光标。
      String getName​()
      返回此游标的名称。
      static Cursor getPredefinedCursor​(int type)
      返回具有指定预定义类型的游标对象。
      static Cursor getSystemCustomCursor​(String name)
      返回与指定名称匹配的特定于系统的自定义游标对象。
      int getType​()
      返回此游标的类型。
      String toString​()
      返回此游标的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DEFAULT_CURSOR

        public static final int DEFAULT_CURSOR
        默认游标类型（如果未定义游标，则设置）。
        另请参见：
        Constant Field Values

      • CROSSHAIR_CURSOR

        public static final int CROSSHAIR_CURSOR
        十字准线游标类型。
        另请参见：
        Constant Field Values

      • TEXT_CURSOR

        public static final int TEXT_CURSOR
        文本光标类型。
        另请参见：
        Constant Field Values

      • WAIT_CURSOR

        public static final int WAIT_CURSOR
        等待光标类型。
        另请参见：
        Constant Field Values

      • SW_RESIZE_CURSOR

        public static final int SW_RESIZE_CURSOR
        西南大小的光标类型。
        另请参见：
        Constant Field Values

      • SE_RESIZE_CURSOR

        public static final int SE_RESIZE_CURSOR
        东南大小的光标类型。
        另请参见：
        Constant Field Values

      • NW_RESIZE_CURSOR

        public static final int NW_RESIZE_CURSOR
        西北大小的游标类型。
        另请参见：
        Constant Field Values

      • NE_RESIZE_CURSOR

        public static final int NE_RESIZE_CURSOR
        东北调整大小的光标类型。
        另请参见：
        Constant Field Values

      • N_RESIZE_CURSOR

        public static final int N_RESIZE_CURSOR
        北移大小的游标类型。
        另请参见：
        Constant Field Values

      • S_RESIZE_CURSOR

        public static final int S_RESIZE_CURSOR
        调整大小的光标类型。
        另请参见：
        Constant Field Values

      • W_RESIZE_CURSOR

        public static final int W_RESIZE_CURSOR
        西调整游标类型。
        另请参见：
        Constant Field Values

      • E_RESIZE_CURSOR

        public static final int E_RESIZE_CURSOR
        东调整游标类型。
        另请参见：
        Constant Field Values

      • HAND_CURSOR

        public static final int HAND_CURSOR
        手指光标类型。
        另请参见：
        Constant Field Values

      • MOVE_CURSOR

        public static final int MOVE_CURSOR
        移动光标类型。
        另请参见：
        Constant Field Values

      • predefined

        @Deprecated
protected static Cursor[] predefined
        已过时。 从JDK 1.7版开始，应该使用getPredefinedCursor(int)方法。

      • CUSTOM_CURSOR

        public static final int CUSTOM_CURSOR
        与所有自定义光标相关联的类型。
        另请参见：
        Constant Field Values

      • name

        protected String name
        光标的用户可见名称。
        另请参见：
        getName()

    • 构造方法详细信息

      • Cursor

        @ConstructorProperties("type")
public Cursor​(int type)
        创建一个指定类型的新的游标对象。
        参数
        type - 光标的类型
        异常
        IllegalArgumentException - 如果指定的游标类型无效

      • Cursor

        protected Cursor​(String name)
        使用指定的名称创建一个新的自定义游标对象。

        注意：此构造函数只能由AWT实现使用，作为对自定义游标的支持的一部分。 应用程序应该使用Toolkit.createCustomCursor（）。

        参数
        name - 光标的用户可见名称。
        另请参见：
        Toolkit.createCustomCursor(java.awt.Image, java.awt.Point, java.lang.String)

    • 方法详细信息

      • getPredefinedCursor

        public static Cursor getPredefinedCursor​(int type)
        返回具有指定预定义类型的游标对象。
        参数
        type - 预定义光标的类型
        结果
        指定的预定义光标
        异常
        IllegalArgumentException - 如果指定的游标类型无效

      • getSystemCustomCursor

        public static Cursor getSystemCustomCursor​(String name)
                                    throws AWTException,
                                           HeadlessException
        返回与指定名称匹配的特定于系统的自定义游标对象。 例如，游标名称：“Invalid.16x16”
        参数
        name - 描述所需系统特定自定义光标的字符串
        结果
        系统具体定制游标命名
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回true
        AWTException - 在光标的错误检索的情况下

      • getDefaultCursor

        public static Cursor getDefaultCursor​()
        返回系统默认光标。
        结果
        默认光标

      • getType

        public int getType​()
        返回此游标的类型。
        结果
        光标类型

      • getName

        public String getName​()
        返回此游标的名称。
        结果
        这个光标的本地化描述。
        从以下版本开始：
        1.2

      • toString

        public String toString​()
        返回此游标的字符串表示形式。
        重写：
        toString类 Object
        结果
        这个光标的字符串表示形式。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DefaultFocusTraversalPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class DefaultFocusTraversalPolicy

  • java.lang.Object
    • java.awt.FocusTraversalPolicy
      • java.awt.ContainerOrderFocusTraversalPolicy
        • java.awt.DefaultFocusTraversalPolicy
  • All Implemented Interfaces:
    Serializable

    public class DefaultFocusTraversalPolicy
extends ContainerOrderFocusTraversalPolicy
    FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。 从特定焦点循环根中，策略对Component层次结构进行预先遍历，并根据Container.getComponents()返回的数组的顺序遍历Container的子Container.getComponents() 。 层级结构中不可见和可显示的部分将不被搜索。

    如果客户端代码通过覆盖Component.isFocusTraversable()或Component.isFocusable()或调用Component.setFocusable()明确设置组件的可Component.setFocusable() ，则DefaultFocusTraversalPolicy的行为与ContainerOrderFocusTraversalPolicy完全相同。 但是，如果组件依赖于默认焦点，则DefaultFocusTraversalPolicy将拒绝所有具有不可聚焦对象的组件。 这是所有AWT容器的默认FocusTraversalPolicy。

    对等体的聚焦性取决于实现。 Sun建议特定本地平台的所有实现以相同的可重定性构建对等体。 Windows和Unix的建议是：画布，标签，面板，滚动条，ScrollPanes，Windows和轻量级组件具有不可对焦的对等体，所有其他组件都具有可聚焦的对等体。 这些建议用于Sun AWT实现。 请注意，组件对等体的可集中性与组件本身的可重点性不同，也不影响组件本身的可重点性。

    请参阅How to Use the Focus Subsystem ， Java教程中的一节，以及有关详细信息的Focus Specification 。

    从以下版本开始：
    1.4
    另请参见：
    Container.getComponents() ，
Component.isFocusable() ，
Component.setFocusable(boolean) ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      DefaultFocusTraversalPolicy​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected boolean accept​(Component aComponent)
      确定组件是否是新焦点所有者的可接受选择。

      • Methods inherited from class java.awt.ContainerOrderFocusTraversalPolicy

        getComponentAfter, getComponentBefore, getDefaultComponent, getFirstComponent, getImplicitDownCycleTraversal, getLastComponent, setImplicitDownCycleTraversal

      • Methods inherited from class java.awt.FocusTraversalPolicy

        getInitialComponent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultFocusTraversalPolicy

        public DefaultFocusTraversalPolicy​()

    • 方法详细信息

      • accept

        protected boolean accept​(Component aComponent)
        确定组件是否是新焦点所有者的可接受选择。 组件必须可见，可显示和启用才能被接受。 如果客户端代码通过覆盖Component.isFocusTraversable()或Component.isFocusable()或通过调用Component.setFocusable()明确设置了组件的可Component.setFocusable() ，则当且仅当该组件可Component.setFocusable() ，该组件将被接受。 然而，如果组件依赖于默认的可重定向性，则所有画布，标签，面板，滚动条，ScrollPanes，Windows和轻量级组件都将被拒绝。
        重写：
        accept在 ContainerOrderFocusTraversalPolicy
        参数
        aComponent - 要测试适合作为焦点所有者的组件
        结果
        true如果一个组件满足上述要求; 否则为false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DefaultKeyboardFocusManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class DefaultKeyboardFocusManager

  • java.lang.Object
    • java.awt.KeyboardFocusManager
      • java.awt.DefaultKeyboardFocusManager
  • All Implemented Interfaces:
    KeyEventDispatcher ， KeyEventPostProcessor
    已知直接子类：
    FocusManager

    public class DefaultKeyboardFocusManager
extends KeyboardFocusManager
    用于AWT应用程序的默认KeyboardFocusManager。 聚焦遍历是针对组件的焦点遍历键，并使用容器的FocusTraversalPolicy进行的。

    请参阅How to Use the Focus Subsystem ， Java教程中的一节，以及有关详细信息的Focus Specification 。

    从以下版本开始：
    1.4
    另请参见：
    FocusTraversalPolicy ， Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， Component.getFocusTraversalKeys(int)

    • Field Summary

      • Fields inherited from class java.awt.KeyboardFocusManager

        BACKWARD_TRAVERSAL_KEYS, DOWN_CYCLE_TRAVERSAL_KEYS, FORWARD_TRAVERSAL_KEYS, UP_CYCLE_TRAVERSAL_KEYS

    • 构造方法摘要

      构造方法
      Constructor 描述
      DefaultKeyboardFocusManager​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void dequeueKeyEvents​(long after, Component untilFocused)
      发布正常调度到当前焦点所有者的所有KeyEvents，由于调用具有相同时间戳和组件的 enqueueKeyEvents而排队。
      protected void discardKeyEvents​(Component comp)
      丢弃由于一次或 enqueueKeyEvents使用指定的组件或其后代调用 enqueueKeyEvents而排入队列的所有KeyEvent。
      boolean dispatchEvent​(AWTEvent e)
      该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。
      boolean dispatchKeyEvent​(KeyEvent e)
      如果调度程序链中没有其他的KeyEventDispatcher调度了KeyEvent，或者如果没有其他的KeyEventDispatchers被注册，则调用 dispatchEvent 。
      void downFocusCycle​(Container aContainer)
      将焦点向下移动一个焦点遍历周期。
      protected void enqueueKeyEvents​(long after, Component untilFocused)
      延迟调度KeyEvents直到指定的Component成为焦点所有者。
      void focusNextComponent​(Component aComponent)
      将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
      void focusPreviousComponent​(Component aComponent)
      在组件之前聚焦组件，通常基于FocusTraversalPolicy。
      boolean postProcessKeyEvent​(KeyEvent e)
      此方法将由 dispatchKeyEvent 。
      void processKeyEvent​(Component focusedComponent, KeyEvent e)
      当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。
      void upFocusCycle​(Component aComponent)
      将焦点移动到一个焦点遍历周期。

      • Methods inherited from class java.awt.KeyboardFocusManager

        addKeyEventDispatcher, addKeyEventPostProcessor, addPropertyChangeListener, addPropertyChangeListener, addVetoableChangeListener, addVetoableChangeListener, clearFocusOwner, clearGlobalFocusOwner, downFocusCycle, firePropertyChange, fireVetoableChange, focusNextComponent, focusPreviousComponent, getActiveWindow, getCurrentFocusCycleRoot, getCurrentKeyboardFocusManager, getDefaultFocusTraversalKeys, getDefaultFocusTraversalPolicy, getFocusedWindow, getFocusOwner, getGlobalActiveWindow, getGlobalCurrentFocusCycleRoot, getGlobalFocusedWindow, getGlobalFocusOwner, getGlobalPermanentFocusOwner, getKeyEventDispatchers, getKeyEventPostProcessors, getPermanentFocusOwner, getPropertyChangeListeners, getPropertyChangeListeners, getVetoableChangeListeners, getVetoableChangeListeners, redispatchEvent, removeKeyEventDispatcher, removeKeyEventPostProcessor, removePropertyChangeListener, removePropertyChangeListener, removeVetoableChangeListener, removeVetoableChangeListener, setCurrentKeyboardFocusManager, setDefaultFocusTraversalKeys, setDefaultFocusTraversalPolicy, setGlobalActiveWindow, setGlobalCurrentFocusCycleRoot, setGlobalFocusedWindow, setGlobalFocusOwner, setGlobalPermanentFocusOwner, upFocusCycle

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultKeyboardFocusManager

        public DefaultKeyboardFocusManager​()

    • 方法详细信息

      • dispatchEvent

        public boolean dispatchEvent​(AWTEvent e)
        该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。 DefaultKeyboardFocusManagers调度所有FocusEvents，与焦点相关的所有WindowEvent和所有KeyEvents。 这些事件是基于KeyboardFocusManager对焦点所有者和聚焦和活动Windows的概念进行调度的，有时会覆盖指定AWTEvent的来源。 如果此方法返回false ，则AWT事件调度程序将尝试调度事件本身。
        Specified by:
        dispatchEvent中的 KeyboardFocusManager
        参数
        e - 要发送的AWTEvent
        结果
        true如果此方法调度事件; 否则为false
        另请参见：
        KeyboardFocusManager.redispatchEvent(java.awt.Component, java.awt.AWTEvent) ， KeyboardFocusManager.dispatchKeyEvent(java.awt.event.KeyEvent)

      • dispatchKeyEvent

        public boolean dispatchKeyEvent​(KeyEvent e)
        如果调度程序链中没有其他的KeyEventDispatcher调度了KeyEvent，或者如果没有其他的KeyEventDispatchers被注册，则调用dispatchEvent 。 如果事件尚未消耗，则其目标将被启用，并且焦点所有者不为空，此方法将事件分派到其目标。 此方法还将随后将事件发送到所有注册的KeyEventPostProcessors。 所有这些操作完成后，事件将传递给对等体进行处理。

        在所有情况下，此方法返回true ，因为DefaultKeyboardFocusManager旨在使dispatchEvent和AWT事件调度程序都不会在任何情况下对事件采取进一步措施。

        Specified by:
        dispatchKeyEvent在接口 KeyEventDispatcher
        Specified by:
        dispatchKeyEvent在 KeyboardFocusManager
        参数
        e - 要发送的KeyEvent
        结果
        true
        另请参见：
        Component.dispatchEvent(java.awt.AWTEvent)

      • postProcessKeyEvent

        public boolean postProcessKeyEvent​(KeyEvent e)
        此方法将由dispatchKeyEvent 。 它将通过消耗事件并激活快捷方式来处理映射到AWT MenuShortcut的任何未消息的KeyEvents。
        Specified by:
        postProcessKeyEvent在接口 KeyEventPostProcessor
        Specified by:
        postProcessKeyEvent中的 KeyboardFocusManager
        参数
        e - 后期处理的KeyEvent
        结果
        true
        另请参见：
        dispatchKeyEvent(java.awt.event.KeyEvent) ， MenuShortcut

      • processKeyEvent

        public void processKeyEvent​(Component focusedComponent,
                            KeyEvent e)
        当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。 预计focusComponent是当前的焦点所有者，尽管不一定是这样。 如果不是，焦点遍历将继续进行，就像focusedComponent是焦点所有者一样。
        Specified by:
        processKeyEvent在 KeyboardFocusManager
        参数
        focusedComponent - 作为聚焦遍历操作的基础的组件，如果指定的事件表示组件的焦点遍历键
        e - 可能代表焦点遍历键的事件

      • enqueueKeyEvents

        protected void enqueueKeyEvents​(long after,
                                Component untilFocused)
        延迟调度KeyEvents直到指定的Component成为焦点所有者。 具有晚于指定时间戳的时间戳的KeyEvent将被排入队列，直到指定的组件接收到FOCUS_GAINED事件，或AWT通过调用dequeueKeyEvents或discardKeyEvents取消延迟请求。
        Specified by:
        enqueueKeyEvents在 KeyboardFocusManager
        参数
        after - 当前事件的时间戳或当前事件没有时间戳的当前系统时间，或者AWT无法确定当前处理哪个事件
        untilFocused - 在任何待处理的KeyEvent之前将收到FOCUS_GAINED事件的组件
        另请参见：
        dequeueKeyEvents(long, java.awt.Component) ， discardKeyEvents(java.awt.Component)

      • dequeueKeyEvents

        protected void dequeueKeyEvents​(long after,
                                Component untilFocused)
        发布正常调度到当前焦点所有者所有由于调用具有相同时间戳和组件的enqueueKeyEvents KeyEvents。 如果给定的时间戳小于零，则应取消给具有最早时间戳（如果有）的给定组件的未完成的入队请求。
        Specified by:
        dequeueKeyEvents中的 KeyboardFocusManager
        参数
        after - 在调用 enqueueKeyEvents指定的时间戳，或任何值<0
        untilFocused - 在调用 enqueueKeyEvents指定的组件
        另请参见：
        enqueueKeyEvents(long, java.awt.Component) ， discardKeyEvents(java.awt.Component)

      • discardKeyEvents

        protected void discardKeyEvents​(Component comp)
        丢弃由于一个或多个调用 enqueueKeyEvents与指定的组件或其后代排入队列的所有KeyEvent。
        Specified by:
        discardKeyEvents中的 KeyboardFocusManager
        参数
        comp - 在一个或多个调用 enqueueKeyEvents指定的组件，或此类组件的父级
        另请参见：
        enqueueKeyEvents(long, java.awt.Component) ， dequeueKeyEvents(long, java.awt.Component)

      • focusPreviousComponent

        public void focusPreviousComponent​(Component aComponent)
        在组件之前聚焦组件，通常基于FocusTraversalPolicy。
        Specified by:
        focusPreviousComponent中的 KeyboardFocusManager
        参数
        aComponent - 作为焦点遍历操作的基础的组件
        另请参见：
        FocusTraversalPolicy ， Component.transferFocusBackward()

      • focusNextComponent

        public void focusNextComponent​(Component aComponent)
        将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
        Specified by:
        focusNextComponent在 KeyboardFocusManager
        参数
        aComponent - 作为焦点遍历操作的基础的组件
        另请参见：
        FocusTraversalPolicy ， Component.transferFocus()

      • upFocusCycle

        public void upFocusCycle​(Component aComponent)
        将焦点移动到一个焦点遍历周期。 通常，焦点所有者设置为aComponent的焦点循环根，并将当前焦点循环根设置为新焦点所有者的焦点循环根。 然而，如果aComponent的焦点循环根是Window，那么焦点所有者将被设置为焦点循环根的默认组件以进行对焦，并且当前焦点循环根不变。
        Specified by:
        upFocusCycle在 KeyboardFocusManager
        参数
        aComponent - 作为焦点遍历操作的基础的组件
        另请参见：
        Component.transferFocusUpCycle()

      • downFocusCycle

        public void downFocusCycle​(Container aContainer)
        将焦点向下移动一个焦点遍历周期。 如果aContainer是焦点循环根，那么焦点所有者将设置为aContainer的默认组件进行对焦，并将当前焦点循环根设置为aContainer。 如果aContainer不是焦点循环根，则不会发生焦点遍历操作。
        Specified by:
        downFocusCycle在 KeyboardFocusManager
        参数
        aContainer - 作为焦点遍历操作的基础的容器
        另请参见：
        Container.transferFocusDownCycle()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Desktop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Desktop

  • java.lang.Object
    • java.awt.Desktop

  • public class Desktop
extends Object
    Desktop类允许与各种桌面功能进行交互。

    支持的操作包括：

    • 启动用户默认浏览器以显示指定的URI;
    • 使用可选的mailto URI启动用户默认邮件客户端;
    • 启动已注册的应用程序来打开，编辑或打印指定的文件。

    该类提供与这些操作相对应的方法。 该方法查找在当前平台上注册的关联应用程序，并启动它来处理URI或文件。 如果没有关联的应用程序或相关应用程序无法启动，则抛出异常。 有关支持的操作和功能的完整列表，请参阅Desktop.Action 。

    应用程序注册到URI或文件类型。 注册，访问和启动相关应用程序的机制是平台相关的。

    每个操作是由Desktop.Action类表示的动作类型。

    注意：当一些操作被调用并且相关联的应用程序被执行时，它将在与启动Java应用程序的系统相同的系统上执行。

    从以下版本开始：
    1.6
    另请参见：
    Desktop.Action

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Desktop.Action
      表示动作类型。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addAppEventListener​(SystemEventListener listener)
      添加SystemEventListener的子类型来监听本机系统的通知。
      void browse​(URI uri)
      启动默认浏览器以显示 URI 。
      void browseFileDirectory​(File file)
      打开包含 file的文件夹，并在默认的系统文件管理器中选择它。
      void disableSuddenTermination​()
      防止此应用程序突然终止。
      void edit​(File file)
      启动相关的编辑器应用程序并打开一个文件进行编辑。
      void enableSuddenTermination​()
      使此应用程序突然终止。
      static Desktop getDesktop​()
      返回当前桌面上下文的 Desktop实例。
      static boolean isDesktopSupported​()
      测试此类是否在当前平台上得到支持。
      boolean isSupported​(Desktop.Action action)
      测试当前平台是否支持操作。
      void mail​()
      启动用户默认邮件客户端的邮件组合窗口。
      void mail​(URI mailtoURI)
      启动用户默认邮件客户端的邮件组合窗口，填写由 mailto: URI指定的邮件字段。
      boolean moveToTrash​(File file)
      将指定的文件移动到垃圾桶。
      void open​(File file)
      启动相关应用程序以打开文件。
      void openHelpViewer​()
      打开本机帮助查看器应用程序。
      void print​(File file)
      使用相关应用程序的打印命令打印本机桌面打印设备的文件。
      void removeAppEventListener​(SystemEventListener listener)
      删除子类型SystemEventListener以监听本机系统的通知。
      void requestForeground​(boolean allWindows)
      请求此应用程序移动到前台。
      void setAboutHandler​(AboutHandler aboutHandler)
      安装一个处理程序来显示应用程序的自定义关于窗口。
      void setDefaultMenuBar​(JMenuBar menuBar)
      设置当没有活动帧时使用的默认菜单栏。
      void setOpenFileHandler​(OpenFilesHandler openFileHandler)
      安装在应用程序被要求打开文件列表时通知的处理程序。
      void setOpenURIHandler​(OpenURIHandler openURIHandler)
      安装在请求应用程序打开URL时通知的处理程序。
      void setPreferencesHandler​(PreferencesHandler preferencesHandler)
      安装一个处理程序来显示应用程序的自定义首选项窗口。
      void setPrintFileHandler​(PrintFilesHandler printFileHandler)
      安装在应用程序被要求打印文件列表时通知的处理程序。
      void setQuitHandler​(QuitHandler quitHandler)
      安装处理程序，确定应用程序是否应该退出。
      void setQuitStrategy​(QuitStrategy strategy)
      设置用于退出此应用程序的默认策略。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDesktop

        public static Desktop getDesktop​()
        返回当前桌面上下文的Desktop实例。 在某些平台上，可能不支持Desktop API; 使用isDesktopSupported()方法来确定当前桌面是否受支持。
        结果
        桌面实例
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回 true
        UnsupportedOperationException - 如果当前平台不支持此类
        另请参见：
        isDesktopSupported() ， GraphicsEnvironment.isHeadless()

      • isDesktopSupported

        public static boolean isDesktopSupported​()
        测试此类是否在当前平台上得到支持。 如果支持，请使用getDesktop()检索实例。
        结果
        true如果在当前平台上支持此类; false否则
        另请参见：
        getDesktop()

      • isSupported

        public boolean isSupported​(Desktop.Action action)
        测试当前平台是否支持操作。

        即使平台支持操作，文件或URI可能没有注册的操作应用程序。 例如，大多数平台支持Desktop.Action.OPEN操作。 但是对于特定文件，可能没有注册的应用程序来打开它。 在这种情况下， isSupported(Action)可能会返回true ，但相应的动作方式会抛出一个IOException 。

        参数
        action - 指定的Desktop.Action
        结果
        true如果当前平台支持指定的动作; false否则
        另请参见：
        Desktop.Action

      • open

        public void open​(File file)
          throws IOException
        启动相关应用程序以打开文件。

        如果指定的文件是目录，则启动当前平台的文件管理器以将其打开。

        参数
        file - 要与相关应用程序打开的文件
        异常
        NullPointerException - 如果 file是 null
        IllegalArgumentException - 如果指定的文件不存在
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.OPEN操作
        IOException - 如果指定的文件没有关联的应用程序或相关应用程序无法启动
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对该文件的读取访问，或者拒绝 AWTPermission("showWindowWithoutWarningBanner")权限，或者调用线程不允许创建子进程
        另请参见：
        AWTPermission

      • edit

        public void edit​(File file)
          throws IOException
        启动相关的编辑器应用程序并打开一个文件进行编辑。
        参数
        file - 要打开进行编辑的文件
        异常
        NullPointerException - 如果指定的文件是 null
        IllegalArgumentException - 如果指定的文件不存在
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.EDIT操作
        IOException - 如果指定的文件没有关联的编辑器，或相关的应用程序无法启动
        SecurityException - 如果安全管理器存在，并且其
SecurityManager.checkRead(java.lang.String)方法拒绝对该文件的读取访问，或者
SecurityManager.checkWrite(java.lang.String)方法拒绝对该文件的写入访问，否则拒绝
AWTPermission("showWindowWithoutWarningBanner")权限，或者调用线程不允许创建子进程
        另请参见：
        AWTPermission

      • print

        public void print​(File file)
           throws IOException
        使用相关应用程序的打印命令打印本机桌面打印设备的文件。
        参数
        file - 要打印的文件
        异常
        NullPointerException - 如果指定的文件是 null
        IllegalArgumentException - 如果指定的文件不存在
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.PRINT操作
        IOException - 如果指定的文件没有可用于打印的关联应用程序
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对该文件的读取访问，或其 SecurityManager.checkPrintJobAccess()方法拒绝打印该文件的权限，或者调用线程不允许创建子进程

      • browse

        public void browse​(URI uri)
            throws IOException
        启动默认浏览器以显示URI 。 如果默认浏览器无法处理指定URI ，申请登记办理URIs指定类型的调用。 应用程序根据URI定义的URI的协议和路径确定。

        如果调用线程没有必要的权限，并且这是从applet中调用的，则使用AppletContext.showDocument() 。 类似地，如果调用没有必要的权限，并且这是从Java Web Started应用程序中调用的，则使用BasicService.showDocument() 。

        参数
        uri - 要在用户默认浏览器中显示的URI
        异常
        NullPointerException - 如果 uri是 null
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.BROWSE操作
        IOException - 如果未找到用户默认浏览器，或者无法启动，或默认处理程序应用程序无法启动
        SecurityException - 如果安全管理器存在，并且它拒绝AWTPermission("showWindowWithoutWarningBanner")权限，或者调用线程不允许创建子进程; 而不是从applet或Java Web Started应用程序中调用
        IllegalArgumentException - 如果必要的权限不可用，并且URI不能转换为 URL
        另请参见：
        URI ， AWTPermission ， AppletContext

      • mail

        public void mail​()
          throws IOException
        启动用户默认邮件客户端的邮件组合窗口。
        异常
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.MAIL操作
        IOException - 如果没有找到用户默认邮件客户端，或无法启动
        SecurityException - 如果安全管理器存在，并且它拒绝 AWTPermission("showWindowWithoutWarningBanner")权限，或者调用线程不允许创建子进程
        另请参见：
        AWTPermission

      • mail

        public void mail​(URI mailtoURI)
          throws IOException
        启动用户默认邮件客户端的邮件合成窗口，填写由mailto: URI指定的邮件字段。

        A mailto: URI可以指定包括“to” ， “cc” ， “subject” ， “body”等的消息字段。有关mailto: URI规范的详细信息，请参阅The mailto URL scheme (RFC 2368) 。

        参数
        mailtoURI - 指定的 mailto: URI
        异常
        NullPointerException - 如果指定的URI是 null
        IllegalArgumentException - 如果URI方案不是 "mailto"
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.MAIL操作
        IOException - 如果用户默认邮件客户端未找到或无法启动
        SecurityException - 如果安全管理器存在，并且它拒绝了 AWTPermission("showWindowWithoutWarningBanner")权限，或者调用线程不允许创建子进程
        另请参见：
        URI ， AWTPermission

      • addAppEventListener

        public void addAppEventListener​(SystemEventListener listener)
        添加子类型SystemEventListener以监听本机系统的通知。 如果在当前平台上不支持SystemEventListener的子类型，则不起作用。
        参数
        listener - 听众
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝了 RuntimePermission("canProcessApplicationEvents")权限
        从以下版本开始：
        9
        另请参见：
        AppForegroundListener ， AppHiddenListener ， AppReopenedListener ， ScreenSleepListener ， SystemSleepListener ， UserSessionListener

      • removeAppEventListener

        public void removeAppEventListener​(SystemEventListener listener)
        删除子类型SystemEventListener以监听本机系统的通知。 如果在当前平台上不支持SystemEventListener的子类型，则不起作用。
        参数
        listener - 听众
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝了 RuntimePermission("canProcessApplicationEvents")权限
        从以下版本开始：
        9
        另请参见：
        AppForegroundListener ， AppHiddenListener ， AppReopenedListener ， ScreenSleepListener ， SystemSleepListener ， UserSessionListener

      • setAboutHandler

        public void setAboutHandler​(AboutHandler aboutHandler)
        安装一个处理程序来显示应用程序的自定义关于窗口。

        将AboutHandler设置为null将其恢复为默认行为。

        参数
        aboutHandler - 响应 AboutHandler.handleAbout(AboutEvent)消息的处理程序
        异常
        SecurityException - 如果安全管理员存在，并且否认 RuntimePermission("canProcessApplicationEvents")权限
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_ABOUT操作
        从以下版本开始：
        9

      • setPreferencesHandler

        public void setPreferencesHandler​(PreferencesHandler preferencesHandler)
        安装一个处理程序来显示应用程序的自定义首选项窗口。

        将PreferencesHandler设置为null将其恢复为默认行为

        参数
        preferencesHandler -处理程序向响应 PreferencesHandler.handlePreferences(PreferencesEvent)
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝了 RuntimePermission("canProcessApplicationEvents")权限
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_PREFERENCES操作
        从以下版本开始：
        9

      • setOpenFileHandler

        public void setOpenFileHandler​(OpenFilesHandler openFileHandler)
        安装在应用程序被要求打开文件列表时通知的处理程序。
        Implementation Note:
        请注意，对于Mac OS，仅当Java应用程序是捆绑的应用程序时，才会发送通知，其Info.plist中包含一个CFBundleDocumentTypes阵列。 有关将CFBundleDocumentTypes键添加到应用程序的Info.plist的更多信息，请参阅Info.plist Key Reference 。
        参数
        openFileHandler - 处理程序
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读取访问，或者拒绝 RuntimePermission("canProcessApplicationEvents")权限，或者调用线程不允许创建子进程
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_OPEN_FILE操作
        从以下版本开始：
        9

      • setPrintFileHandler

        public void setPrintFileHandler​(PrintFilesHandler printFileHandler)
        安装在应用程序被要求打印文件列表时通知的处理程序。
        Implementation Note:
        请注意，对于Mac OS，仅当Java应用程序是捆绑的应用程序时，才会发送通知，其Info.plist中包含一个CFBundleDocumentTypes阵列。 有关将CFBundleDocumentTypes键添加到应用程序的Info.plist的更多信息，请参阅Info.plist Key Reference 。
        参数
        printFileHandler - 处理程序
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkPrintJobAccess()方法拒绝打印的权限，否则将拒绝 RuntimePermission("canProcessApplicationEvents")权限
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_PRINT_FILE操作
        从以下版本开始：
        9

      • setOpenURIHandler

        public void setOpenURIHandler​(OpenURIHandler openURIHandler)
        安装在请求应用程序打开URL时通知的处理程序。 将处理程序设置为null导致所有OpenURIHandler.openURI(OpenURIEvent)请求排入队列，直到设置另一个处理程序。
        Implementation Note:
        请注意，对于Mac OS，仅当Java应用程序是捆绑应用程序时，才会发送通知，其Info.plist中包含一个CFBundleDocumentTypes阵列。 有关向应用程序的Info.plist添加CFBundleDocumentTypes密钥的更多信息，请参阅Info.plist Key Reference 。
        参数
        openURIHandler - 处理程序 RuntimePermission("canProcessApplicationEvents")权限，或者调用线程不允许创建子进程
        异常
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_OPEN_URI操作
        从以下版本开始：
        9

      • setQuitHandler

        public void setQuitHandler​(QuitHandler quitHandler)
        安装处理程序，确定应用程序是否应该退出。 处理程序通过一个单击QuitResponse可以取消或继续退出。 将处理程序设置为null导致所有退出请求直接执行默认值QuitStrategy 。
        参数
        quitHandler - 请求退出应用程序时调用的处理程序
        异常
        SecurityException - 如果安全管理器存在，并且不允许调用者调用 System.exit或者拒绝 RuntimePermission("canProcessApplicationEvents")权限
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_QUIT_HANDLER操作
        从以下版本开始：
        9

      • setQuitStrategy

        public void setQuitStrategy​(QuitStrategy strategy)
        设置用于退出此应用程序的默认策略。 默认是调用SYSTEM_EXIT_0。
        参数
        strategy - 该应用程序应该关闭的方式
        异常
        SecurityException - 如果存在安全管理员，并且不允许主叫方调用 System.exit或拒绝 RuntimePermission("canProcessApplicationEvents")权限
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_QUIT_STRATEGY操作
        从以下版本开始：
        9
        另请参见：
        QuitStrategy

      • enableSuddenTermination

        public void enableSuddenTermination​()
        使此应用程序突然终止。 调用此方法来指示应用程序的状态已保存，并且不需要通知终止。 让您的应用程序保持终止可以通过避免在应用程序中重新分页，以便在要求退出时改善用户体验。 注意：启用突然终止将允许您的应用程序退出而不通知您的QuitHandler或运行任何关闭挂钩。 例如用户启动的Cmd-Q，注销，重新启动或关闭请求将有效地“杀死”您的应用程序。
        异常
        SecurityException - 如果安全管理员存在，并且不允许主叫方调用 System.exit或者拒绝 RuntimePermission("canProcessApplicationEvents")权限
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_SUDDEN_TERMINATION操作
        从以下版本开始：
        9
        另请参见：
        disableSuddenTermination()

      • disableSuddenTermination

        public void disableSuddenTermination​()
        防止此应用程序突然终止。 调用此方法来指示您的应用程序具有未保存的状态，如果没有通知，可能不会被终止。
        异常
        SecurityException - 如果安全管理器存在，并且不允许主叫方调用 System.exit或者拒绝 RuntimePermission("canProcessApplicationEvents")权限
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_SUDDEN_TERMINATION操作
        从以下版本开始：
        9
        另请参见：
        enableSuddenTermination()

      • requestForeground

        public void requestForeground​(boolean allWindows)
        请求此应用程序移动到前台。
        参数
        allWindows - 如果这个应用程序的所有窗口都应该被移动到前台，或者只是最前面的一个
        异常
        SecurityException - 如果安全管理器存在并且它拒绝了 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_REQUEST_FOREGROUND操作
        从以下版本开始：
        9

      • openHelpViewer

        public void openHelpViewer​()
        打开本机帮助查看器应用程序。
        Implementation Note:
        请注意，对于Mac OS，如果帮助书已添加到应用程序包并在Info.plist中与CFBundleHelpBookFolder注册，则会打开本机帮助查看器应用程序
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_HELP_VIEWER操作
        从以下版本开始：
        9

      • setDefaultMenuBar

        public void setDefaultMenuBar​(JMenuBar menuBar)
        设置当没有活动帧时使用的默认菜单栏。
        参数
        menuBar - 当没有其他框架处于活动状态时使用
        异常
        SecurityException - 如果安全管理器存在，并且它拒绝了 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.APP_MENU_BAR操作
        从以下版本开始：
        9

      • browseFileDirectory

        public void browseFileDirectory​(File file)
        打开包含 file的文件夹，并在默认的系统文件管理器中选择它。
        参数
        file - 该文件
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读访问
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.BROWSE_FILE_DIR操作
        NullPointerException - 如果 file是 null
        IllegalArgumentException - 如果指定的文件不存在
        从以下版本开始：
        9

      • moveToTrash

        public boolean moveToTrash​(File file)
        将指定的文件移动到垃圾桶。
        参数
        file - 该文件
        结果
        如果成功将文件移动到垃圾箱，则返回true。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkDelete(java.lang.String)方法拒绝删除该文件
        UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.MOVE_TO_TRASH操作
        NullPointerException - 如果 file是 null
        IllegalArgumentException - 如果指定的文件不存在
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Desktop.Action (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum Desktop.Action

  • java.lang.Object
    • java.lang.Enum<Desktop.Action>
      • java.awt.Desktop.Action
  • All Implemented Interfaces:
    Serializable ， Comparable<Desktop.Action>
    Enclosing class:
    Desktop

    public static enum Desktop.Action
extends Enum<Desktop.Action>
    表示动作类型。 每个平台支持一组不同的动作。 您可以使用Desktop.isSupported(java.awt.Desktop.Action)方法来确定给定的操作是否受到当前平台的支持。
    从以下版本开始：
    1.6
    另请参见：
    Desktop.isSupported(java.awt.Desktop.Action)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APP_ABOUT
      代表一个AboutHandler
      APP_EVENT_FOREGROUND
      表示AppForegroundListener
      APP_EVENT_HIDDEN
      表示AppHiddenListener
      APP_EVENT_REOPENED
      表示AppReopenedListener
      APP_EVENT_SCREEN_SLEEP
      表示ScreenSleepListener
      APP_EVENT_SYSTEM_SLEEP
      表示SystemSleepListener
      APP_EVENT_USER_SESSION
      表示一个UserSessionListener
      APP_HELP_VIEWER
      代表一个HelpViewer
      APP_MENU_BAR
      表示菜单栏
      APP_OPEN_FILE
      表示OpenFilesHandler
      APP_OPEN_URI
      代表OpenURIHandler
      APP_PREFERENCES
      表示PreferencesHandler
      APP_PRINT_FILE
      表示PrintFilesHandler
      APP_QUIT_HANDLER
      代表一个QuitHandler
      APP_QUIT_STRATEGY
      代表一个QuitStrategy
      APP_REQUEST_FOREGROUND
      表示requestForeground
      APP_SUDDEN_TERMINATION
      代表突发事件
      BROWSE
      代表“浏览”动作。
      BROWSE_FILE_DIR
      表示浏览文件目录
      EDIT
      代表“编辑”动作。
      MAIL
      代表“邮件”动作。
      MOVE_TO_TRASH
      代表垃圾的移动
      OPEN
      代表“开放”行动。
      PRINT
      表示“打印”动作。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Desktop.Action valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Desktop.Action[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • OPEN

        public static final Desktop.Action OPEN
        代表“开放”行动。
        另请参见：
        Desktop.open(java.io.File)

      • EDIT

        public static final Desktop.Action EDIT
        代表“编辑”动作。
        另请参见：
        Desktop.edit(java.io.File)

      • PRINT

        public static final Desktop.Action PRINT
        表示“打印”动作。
        另请参见：
        Desktop.print(java.io.File)

      • MAIL

        public static final Desktop.Action MAIL
        代表“邮件”动作。
        另请参见：
        Desktop.mail() ， Desktop.mail(java.net.URI)

      • BROWSE

        public static final Desktop.Action BROWSE
        代表“浏览”动作。
        另请参见：
        Desktop.browse(java.net.URI)

      • APP_EVENT_FOREGROUND

        public static final Desktop.Action APP_EVENT_FOREGROUND
        表示AppForegroundListener
        从以下版本开始：
        9
        另请参见：
        AppForegroundListener

      • APP_EVENT_HIDDEN

        public static final Desktop.Action APP_EVENT_HIDDEN
        表示AppHiddenListener
        从以下版本开始：
        9
        另请参见：
        AppHiddenListener

      • APP_EVENT_REOPENED

        public static final Desktop.Action APP_EVENT_REOPENED
        表示AppReopenedListener
        从以下版本开始：
        9
        另请参见：
        AppReopenedListener

      • APP_EVENT_SCREEN_SLEEP

        public static final Desktop.Action APP_EVENT_SCREEN_SLEEP
        表示ScreenSleepListener
        从以下版本开始：
        9
        另请参见：
        ScreenSleepListener

      • APP_EVENT_SYSTEM_SLEEP

        public static final Desktop.Action APP_EVENT_SYSTEM_SLEEP
        表示SystemSleepListener
        从以下版本开始：
        9
        另请参见：
        SystemSleepListener

      • APP_EVENT_USER_SESSION

        public static final Desktop.Action APP_EVENT_USER_SESSION
        表示一个UserSessionListener
        从以下版本开始：
        9
        另请参见：
        UserSessionListener

      • APP_ABOUT

        public static final Desktop.Action APP_ABOUT
        代表一个AboutHandler
        从以下版本开始：
        9
        另请参见：
        Desktop.setAboutHandler(java.awt.desktop.AboutHandler)

      • APP_PREFERENCES

        public static final Desktop.Action APP_PREFERENCES
        表示PreferencesHandler
        从以下版本开始：
        9
        另请参见：
        Desktop.setPreferencesHandler(java.awt.desktop.PreferencesHandler)

      • APP_OPEN_FILE

        public static final Desktop.Action APP_OPEN_FILE
        表示OpenFilesHandler
        从以下版本开始：
        9
        另请参见：
        Desktop.setOpenFileHandler(java.awt.desktop.OpenFilesHandler)

      • APP_PRINT_FILE

        public static final Desktop.Action APP_PRINT_FILE
        表示PrintFilesHandler
        从以下版本开始：
        9
        另请参见：
        Desktop.setPrintFileHandler(java.awt.desktop.PrintFilesHandler)

      • APP_OPEN_URI

        public static final Desktop.Action APP_OPEN_URI
        代表OpenURIHandler
        从以下版本开始：
        9
        另请参见：
        Desktop.setOpenURIHandler(java.awt.desktop.OpenURIHandler)

      • APP_QUIT_HANDLER

        public static final Desktop.Action APP_QUIT_HANDLER
        代表一个QuitHandler
        从以下版本开始：
        9
        另请参见：
        Desktop.setQuitHandler(java.awt.desktop.QuitHandler)

      • APP_QUIT_STRATEGY

        public static final Desktop.Action APP_QUIT_STRATEGY
        代表一个QuitStrategy
        从以下版本开始：
        9
        另请参见：
        Desktop.setQuitStrategy(java.awt.desktop.QuitStrategy)

      • APP_SUDDEN_TERMINATION

        public static final Desktop.Action APP_SUDDEN_TERMINATION
        代表突发事件
        从以下版本开始：
        9
        另请参见：
        Desktop.enableSuddenTermination()

      • APP_REQUEST_FOREGROUND

        public static final Desktop.Action APP_REQUEST_FOREGROUND
        表示requestForeground
        从以下版本开始：
        9
        另请参见：
        Desktop.requestForeground(boolean)

      • APP_HELP_VIEWER

        public static final Desktop.Action APP_HELP_VIEWER
        代表一个HelpViewer
        从以下版本开始：
        9
        另请参见：
        Desktop.openHelpViewer()

      • APP_MENU_BAR

        public static final Desktop.Action APP_MENU_BAR
        表示菜单栏
        从以下版本开始：
        9
        另请参见：
        Desktop.setDefaultMenuBar(javax.swing.JMenuBar)

      • BROWSE_FILE_DIR

        public static final Desktop.Action BROWSE_FILE_DIR
        表示浏览文件目录
        从以下版本开始：
        9
        另请参见：
        Desktop.browseFileDirectory(java.io.File)

      • MOVE_TO_TRASH

        public static final Desktop.Action MOVE_TO_TRASH
        代表垃圾的移动
        从以下版本开始：
        9
        另请参见：
        Desktop.moveToTrash(java.io.File)

    • 方法详细信息

      • values

        public static Desktop.Action[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Desktop.Action c : Desktop.Action.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Desktop.Action valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Dialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Dialog

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
          • java.awt.Dialog
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible
    已知直接子类：
    FileDialog ， JDialog

    public class Dialog
extends Window
    Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。 对话框的大小包括为边框指定的任何区域。 可以使用getInsets方法获得边界区域的尺寸，但是由于这些尺寸与平台相关，所以只有通过调用pack或show可以显示对话框，才能获得有效的插入值。 由于边界区域被包括在对话框的总体大小中，边界有效地掩盖了对话框的一部分，限制了可用于向左上角位置为(insets.left, insets.top)的矩形呈现和/或显示子组件的(insets.left, insets.top) ，以及具有width - (insets.left + insets.right)的height - (insets.top + insets.bottom) 。

    对话框的默认布局为BorderLayout 。

    对话框可能会以setUndecorated关闭其本机装饰（即Frame＆Titlebar）。 这只能在对话框不是displayable时才能完成。

    构建对话框时可能会有另一个窗口作为其所有者。 当可见对话框的所有者窗口最小化时，对话框将自动从用户隐藏。 当所有者窗口随后恢复时，对话框再次对用户可见。

    在多屏幕环境中，您可以在与其所有者不同的屏幕设备上创建Dialog 。 有关详细信息，请参阅Frame 。

    对话框可以是无模式（默认）或模态。 模态对话框是阻止对应用程序中某些其他顶级窗口的输入的对话框，除了使用对话框创建的任何窗口作为其所有者。 详见AWT Modality规范。

    对话框是能够产生以下的WindowEvents ： WindowOpened ， WindowClosing ， WindowClosed ， WindowActivated ， WindowDeactivated ， WindowGainedFocus ， WindowLostFocus 。

    从以下版本开始：
    1.0
    另请参见：
    WindowEvent ， Window.addWindowListener(java.awt.event.WindowListener) ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Dialog.AccessibleAWTDialog
      这个类实现 Dialog类的可访问性支持。
      static class  Dialog.ModalExclusionType
      任何顶级窗口都可以标记为不被模态对话框阻止。
      static class  Dialog.ModalityType
      模态对话框阻止某些顶级窗口的所有输入。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Window

        Window.AccessibleAWTWindow, Window.Type

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Dialog.ModalityType DEFAULT_MODALITY_TYPE
      模态对话框的默认模式类型。

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Dialog​(Dialog owner)
      构造一个最初看不见的，无模式的 Dialog与指定的所有者 Dialog和一个空的标题。
      Dialog​(Dialog owner, String title)
      构造一个最初看不见的，无指定的 Dialog与指定的所有者 Dialog和标题。
      Dialog​(Dialog owner, String title, boolean modal)
      构造一个最初看不见的 Dialog与指定的所有者 Dialog ，标题和模态。
      Dialog​(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
      构造一个最初不可见的 Dialog与指定的所有者 Dialog ，标题，模式和 GraphicsConfiguration 。
      Dialog​(Frame owner)
      构造一个初始隐形的，无指定的 Dialog与指定的所有者 Frame和一个空的标题。
      Dialog​(Frame owner, boolean modal)
      构造一个最初不可见的 Dialog与指定的所有者 Frame和模态和一个空的标题。
      Dialog​(Frame owner, String title)
      构造一个初始隐形的，无指定的 Dialog与指定的所有者 Frame和标题。
      Dialog​(Frame owner, String title, boolean modal)
      构造一个最初看不见的 Dialog与指定的所有者 Frame ，标题和模态。
      Dialog​(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
      构造一个最初看不见的 Dialog与指定的所有者 Frame ，标题，模态和 GraphicsConfiguration 。
      Dialog​(Window owner)
      构造一个初始隐形的，无指定的 Dialog与指定的所有者 Window和一个空的标题。
      Dialog​(Window owner, Dialog.ModalityType modalityType)
      构造一个最初看不见的 Dialog与指定的所有者 Window和模态和一个空的标题。
      Dialog​(Window owner, String title)
      构造一个最初看不见的，无模式的 Dialog与指定的所有者 Window和标题。
      Dialog​(Window owner, String title, Dialog.ModalityType modalityType)
      构造一个最初看不见的 Dialog与指定的所有者 Window ，标题和模态。
      Dialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      构造最初无形 Dialog与指定的所有者 Window ，标题，模式和 GraphicsConfiguration 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addNotify​()
      将此对话框通过将其连接到本机屏幕资源来显示。
      AccessibleContext getAccessibleContext​()
      获取与此对话框关联的AccessibleContext。
      Dialog.ModalityType getModalityType​()
      返回此对话框的模态类型。
      String getTitle​()
      获取对话框的标题。
      void hide​()
      已过时。
      自JDK版本1.5起，由setVisible(boolean)替代。
      boolean isModal​()
      指示对话框是否为模态。
      boolean isResizable​()
      指示用户是否可以调整此对话框的大小。
      boolean isUndecorated​()
      指示此对话框是否未装饰。
      protected String paramString​()
      返回表示此对话框状态的字符串。
      void setBackground​(Color bgColor)
      设置此窗口的背景颜色。
      void setModal​(boolean modal)
      指定此对话框是否应该是模态的。
      void setModalityType​(Dialog.ModalityType type)
      设置此对话框的模态类型。
      void setOpacity​(float opacity)
      设置窗口的不透明度。
      void setResizable​(boolean resizable)
      设置用户是否可以调整此对话框的大小。
      void setShape​(Shape shape)
      设置窗口的形状。
      void setTitle​(String title)
      设置对话框的标题。
      void setUndecorated​(boolean undecorated)
      禁用或启用此对话框的装饰。
      void setVisible​(boolean b)
      显示或隐藏此 Dialog取决于参数的值 b 。
      void show​()
      已过时。
      从JDK版本1.5开始，由setVisible(boolean)替代。
      void toBack​()
      如果此窗口可见，则将此窗口发送到后面，如果该窗口是聚焦窗口或活动窗口，则可能导致其失去焦点或激活。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, resize, resize, revalidate, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setMaximumSize, setMixingCutoutShape, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.Window

        addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBackground, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOpacity, getOwnedWindows, getOwner, getOwnerlessWindows, getShape, getToolkit, getType, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isAutoRequestFocus, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isOpaque, isShowing, isValidateRoot, pack, paint, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setAutoRequestFocus, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocation, setLocation, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setType, toFront

    • 字段详细信息

      • DEFAULT_MODALITY_TYPE

        public static final Dialog.ModalityType DEFAULT_MODALITY_TYPE
        模态对话框的默认模式类型。 默认模式类型为APPLICATION_MODAL 。 调用oldstyle setModal(true)等于setModalityType(DEFAULT_MODALITY_TYPE) 。
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType ， setModal(boolean)

    • 构造方法详细信息

      • Dialog

        public Dialog​(Frame owner)
        构造一个初始隐形的，无指定的 Dialog与指定的所有者 Frame和一个空的标题。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        另请参见：
        GraphicsEnvironment.isHeadless() ，
Component.setSize(int, int) ，
Component.setVisible(boolean)

      • Dialog

        public Dialog​(Frame owner,
              boolean modal)
        构造最初不可见的 Dialog与指定的所有者 Frame和模态和一个空的标题。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        modal - 指定对话框是否显示用户输入到其他顶级窗口。 如果是false ，对话框是MODELESS ; 如果是true ，则模态类型属性设置为DEFAULT_MODALITY_TYPE
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        另请参见：
        Dialog.ModalityType ， Dialog.ModalityType.MODELESS ， DEFAULT_MODALITY_TYPE ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless()

      • Dialog

        public Dialog​(Frame owner,
              String title)
        构造一个最初看不见的，无模式的 Dialog与指定的所有者 Frame和标题。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        title - 对话框的标题或 null如果此对话框没有标题
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        另请参见：
        GraphicsEnvironment.isHeadless() ，
Component.setSize(int, int) ，
Component.setVisible(boolean)

      • Dialog

        public Dialog​(Frame owner,
              String title,
              boolean modal)
        构造一个最初看不见的 Dialog与指定的所有者 Frame ，标题和模态。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        title - 对话框的标题或 null如果此对话框没有标题
        modal - 指定对话框是否显示用户输入到其他顶级窗口。 如果是false ，对话框是MODELESS ; 如果是true ，则模态类型属性设置为DEFAULT_MODALITY_TYPE
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        另请参见：
        Dialog.ModalityType ， Dialog.ModalityType.MODELESS ， DEFAULT_MODALITY_TYPE ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless() ， Component.setSize(int, int) ， Component.setVisible(boolean)

      • Dialog

        public Dialog​(Frame owner,
              String title,
              boolean modal,
              GraphicsConfiguration gc)
        构造一个最初不可见的 Dialog与指定的所有者 Frame ，标题，模式和 GraphicsConfiguration 。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        title - 对话框的标题或 null如果此对话框没有标题
        modal - 指定对话框是否显示用户输入到其他顶级窗口。 如果是false ，对话框是MODELESS ; 如果是true ，则模态类型属性设置为DEFAULT_MODALITY_TYPE
        gc - 目标屏幕设备的GraphicsConfiguration ; 如果是null ，则假设默认系统GraphicsConfiguration
        异常
        IllegalArgumentException - 如果 gc不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.4
        另请参见：
        Dialog.ModalityType ， Dialog.ModalityType.MODELESS ， DEFAULT_MODALITY_TYPE ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless() ， Component.setSize(int, int) ， Component.setVisible(boolean)

      • Dialog

        public Dialog​(Dialog owner)
        构造一个初始隐形的，无指定的 Dialog与指定的所有者 Dialog和一个空的标题。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是从屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.2
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Dialog

        public Dialog​(Dialog owner,
              String title)
        构造一个最初看不见的，无模式的 Dialog具有指定的所有者 Dialog和标题。
        参数
        owner - 对话框的所有者或 null如果没有所有者
        title - 对话框的标题或 null如果此对话框没有标题
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.2
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Dialog

        public Dialog​(Dialog owner,
              String title,
              boolean modal)
        构造最初不可见的 Dialog与指定的所有者 Dialog ，标题和模态。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        title - 对话框的标题或 null如果此对话框没有标题
        modal - 指定对话框是否显示用户输入到其他顶级窗口。 如果是false ，对话框是MODELESS ; 如果是true ，则模态类型属性设置为DEFAULT_MODALITY_TYPE
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是从屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.2
        另请参见：
        Dialog.ModalityType ， Dialog.ModalityType.MODELESS ， DEFAULT_MODALITY_TYPE ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless()

      • Dialog

        public Dialog​(Dialog owner,
              String title,
              boolean modal,
              GraphicsConfiguration gc)
        构造一个最初看不见的 Dialog与指定的所有者 Dialog ，标题，模式和 GraphicsConfiguration 。
        参数
        owner - 对话框的所有者或 null如果此对话框没有所有者
        title - 对话框的标题或 null如果此对话框没有标题
        modal - 指定对话框是否显示用户输入到其他顶级窗口。 如果是false ，对话框是MODELESS ; 如果是true ，则模态类型属性设置为DEFAULT_MODALITY_TYPE
        gc - 目标屏幕设备的GraphicsConfiguration ; 如果是null ，则假定默认系统GraphicsConfiguration
        异常
        IllegalArgumentException - 如果 gc不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.4
        另请参见：
        Dialog.ModalityType ， Dialog.ModalityType.MODELESS ， DEFAULT_MODALITY_TYPE ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless() ， Component.setSize(int, int) ， Component.setVisible(boolean)

      • Dialog

        public Dialog​(Window owner)
        构造一个最初看不见的，无指定的 Dialog与指定的所有者 Window和一个空的标题。
        参数
        owner - 对话框的所有者。 所有者必须是一个实例Dialog ， Frame ，任何他们的后代或null
        异常
        IllegalArgumentException - 如果owner不是Dialog或Frame的实例
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.6
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Dialog

        public Dialog​(Window owner,
              String title)
        构造一个初始隐形的，无指定的 Dialog与指定的所有者 Window和标题。
        参数
        owner - 对话框的所有者。 所有者必须是一个实例Dialog ， Frame ，任何他们的后代或null
        title - 对话框的标题或 null如果此对话框没有标题
        异常
        IllegalArgumentException - 如果owner不是Dialog或Frame的实例
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.6
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Dialog

        public Dialog​(Window owner,
              Dialog.ModalityType modalityType)
        构造最初不可见的 Dialog与指定的所有者 Window和模态和一个空的标题。
        参数
        owner - 对话框的所有者。 所有者必须是一个实例Dialog ， Frame ，任何他们的后代或null
        modalityType - 指定当显示的对话框是否输入到其他窗口。 null值和不受支持的模式类型等效于MODELESS
        异常
        IllegalArgumentException - 如果owner不是Dialog或Frame的实例
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        SecurityException - 如果调用线程没有权限使用给定的 modalityType创建模态对话框
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless() ， Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

      • Dialog

        public Dialog​(Window owner,
              String title,
              Dialog.ModalityType modalityType)
        构造一个最初不可见的 Dialog与指定的所有者 Window ，标题和模态。
        参数
        owner - 对话框的所有者。 所有者必须是一个实例Dialog ， Frame ，任何他们的后代或null
        title - 对话框的标题或 null如果此对话框没有标题
        modalityType - 指定当显示的对话框是否输入到其他窗口。 null值和不受支持的模式类型等效于MODELESS
        异常
        IllegalArgumentException - 如果owner不是Dialog或Frame的实例
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        SecurityException - 如果调用线程没有权限创建具有给定的模式对话框 modalityType
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless() ， Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

      • Dialog

        public Dialog​(Window owner,
              String title,
              Dialog.ModalityType modalityType,
              GraphicsConfiguration gc)
        构造一个最初不可见的 Dialog与指定的所有者 Window ，标题，模式和 GraphicsConfiguration 。
        参数
        owner - 对话框的所有者。 所有者必须是一个实例Dialog ， Frame ，任何他们的后代或null
        title - 对话框的标题或 null如果此对话框没有标题
        modalityType - 指定对话框是否显示输入到其他窗口。 null值和不受支持的模式类型等效于MODELESS
        gc - 目标屏幕设备的GraphicsConfiguration ; 如果是null ，则假定默认系统GraphicsConfiguration
        异常
        IllegalArgumentException - 如果owner不是Dialog或Frame的实例
        IllegalArgumentException - 如果 gc不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        SecurityException - 如果调用线程没有权限创建具有给定的模态对话框 modalityType
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType ， setModal(boolean) ， setModalityType(java.awt.Dialog.ModalityType) ， GraphicsEnvironment.isHeadless() ， Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

    • 方法详细信息

      • addNotify

        public void addNotify​()
        将此对话框通过将其连接到本机屏幕资源来显示。 使对话框显示可以使其任何一个孩子被显示。 该方法由工具包内部调用，不应由程序直接调用。
        重写：
        addNotify在 Window
        另请参见：
        Component.isDisplayable() ， Window.removeNotify()

      • isModal

        public boolean isModal​()
        指示对话框是否为模态。

        此方法已过时，仅用于向后兼容。 改用getModalityType() 。

        结果
        true如果此对话窗口是模态的; false否则
        另请参见：
        DEFAULT_MODALITY_TYPE ， Dialog.ModalityType.MODELESS ， setModal(boolean) ， getModalityType() ， setModalityType(java.awt.Dialog.ModalityType)

      • setModal

        public void setModal​(boolean modal)
        指定此对话框是否应该是模态的。

        此方法已过时，仅用于向后兼容。 改用setModalityType() 。

        注意：可见对话框的更改模式可能没有任何效果，直到它被隐藏，然后再次显示。

        参数
        modal - 指定当显示的对话框是否输入到其他窗口; 致电setModal(true)相当于setModalityType(Dialog.DEFAULT_MODALITY_TYPE) ，并致电setModal(false)相当于setModalityType(Dialog.ModalityType.MODELESS)
        从以下版本开始：
        1.1
        另请参见：
        DEFAULT_MODALITY_TYPE ，
Dialog.ModalityType.MODELESS ，
isModal() ，
getModalityType() ，
setModalityType(java.awt.Dialog.ModalityType)

      • getModalityType

        public Dialog.ModalityType getModalityType​()
        返回此对话框的模态类型。
        结果
        此对话框的模态类型
        从以下版本开始：
        1.6
        另请参见：
        setModalityType(java.awt.Dialog.ModalityType)

      • setModalityType

        public void setModalityType​(Dialog.ModalityType type)
        设置此对话框的模态类型。 有关可能的模式类型，请参阅ModalityType 。

        如果不支持给定的模式类型，则使用MODELESS 。 调用此方法后，您可能需要调用getModalityType()以确保已设置模态类型。

        注意：可见对话框的更改模式可能没有任何效果，直到它被隐藏，然后再次显示。

        参数
        type - 指定当显示的对话框是否输入到其他窗口。 null值和不受支持的模式类型等效于MODELESS
        异常
        SecurityException - 如果调用线程没有权限创建与给定的模式对话 modalityType
        从以下版本开始：
        1.6
        另请参见：
        getModalityType() ， Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

      • getTitle

        public String getTitle​()
        获取对话框的标题。 标题显示在对话框的边框中。
        结果
        该对话窗口的标题。 标题可能是null 。
        另请参见：
        setTitle(java.lang.String)

      • setTitle

        public void setTitle​(String title)
        设置对话框的标题。
        参数
        title - 对话框边框中显示的标题; 空值导致空标题
        另请参见：
        getTitle()

      • setVisible

        public void setVisible​(boolean b)
        显示或隐藏此 Dialog取决于参数的值 b 。
        重写：
        setVisible在 Window
        参数
        b - 如果true ，使Dialog可见，否则隐藏Dialog 。 如果对话框和/或其所有者尚未显示，则两者都可显示。 该对话框将在被显示之前被验证。 如果是false ，隐藏Dialog然后如果当前被阻止，则会导致setVisible(true)返回。

        模态对话框的注释 。

        • setVisible(true) ：如果对话框尚未显示，则通过调用setVisible(false)或dispose隐藏对话框，此调用将不会返回。
        • setVisible(false) ：隐藏对话框，然后如果当前被阻止，则返回setVisible(true) 。
        • 可以从事件调度线程调用此方法，因为该工具包确保在阻止此方法时其他事件不被阻止。
        另请参见：
        Window.setVisible(boolean) ，
Window.dispose() ，
Component.isDisplayable() ，
Component.validate() ，
isModal()

      • show

        @Deprecated
public void show​()
        已过时。 从JDK版本1.5开始，由setVisible(boolean)代替。
        使Dialog可见。 如果对话框和/或其所有者尚未显示，则两者都可显示。 该对话框将在被显示之前被验证。 如果对话框已经可见，这将使对话框显示在前面。

        如果对话框是模态的并且尚未显示，则通过调用隐藏或处理隐藏对话框之前，此调用将不会返回。 允许从事件调度线程显示模态对话框，因为工具箱将确保另一个事件泵运行，而调用此方法的那个被阻止。

        重写：
        show在 Window
        另请参见：
        Component.hide() ，
Component.isDisplayable() ，
Component.validate() ，
isModal() ，
Window.setVisible(boolean)

      • hide

        @Deprecated
public void hide​()
        已过时。 截至JDK 1.5版，由setVisible(boolean)替代。
        隐藏对话框，然后如果当前被阻止，则会导致 show返回。
        重写：
        hide在 Window
        另请参见：
        Window.show() ，
Window.dispose() ，
Window.setVisible(boolean)

      • toBack

        public void toBack​()
        如果此窗口可见，则将此窗口发送到后面，如果该窗口是聚焦窗口或活动窗口，则可能导致其失去焦点或激活。

        将此窗口放置在堆叠顺序的底部，并将其显示在此VM中的任何其他Windows之后。 这个窗口不可见，不会发生任何动作。 某些平台不允许其他Windows拥有的Windows显示在其所有者的下方。 每次尝试将堆叠顺序中的窗口移动到尽可能低的位置; 然而，开发人员不应该假设这种方法会将Window在所有其他窗口中移动到所有情况。

        由于本机窗口系统的变化，不能保证关注和活动的Windows的更改。 开发人员绝对不能假定此窗口不再是聚焦或活动窗口，直到此窗口收到WINDOW_LOST_FOCUS或WINDOW_DEACTIVATED事件为止。 在最上面的窗口是关注窗口的平台上，这种方法可能会导致此窗口失去焦点。 在这种情况下，这个VM中的下一个最高的可调焦窗口将会得到关注。 在堆叠顺序通常不会影响聚焦窗口的平台上，此方法可能会使焦点和活动窗口保持不变。

        如果此对话框是模态的，并阻止某些窗口，则所有这些对象都将发送到后端，以将它们保留在阻止对话框之下。

        重写：
        toBack在 Window
        另请参见：
        Window.toBack()

      • isResizable

        public boolean isResizable​()
        指示用户是否可以调整此对话框的大小。 默认情况下，所有对话框最初都可以调整大小。
        结果
        true如果用户可以调整对话大小; 否则为false 。
        另请参见：
        setResizable(boolean)

      • setResizable

        public void setResizable​(boolean resizable)
        设置用户是否可以调整此对话框的大小。
        参数
        resizable - true如果用户可以调整此对话框的大小; false否则。
        另请参见：
        isResizable()

      • setUndecorated

        public void setUndecorated​(boolean undecorated)
        禁用或启用此对话框的装饰。

        此方法只能在对话框不可显示时调用。 要使此对话框装饰，它必须是不透明的，并具有默认形状，否则将抛出IllegalComponentStateException 。 请参阅Window.setShape(java.awt.Shape) ， Window.setOpacity(float)和Window.setBackground(java.awt.Color)的细节

        参数
        undecorated - true如果不启用对话框装饰; false如果要启用对话框装饰
        异常
        IllegalComponentStateException - 对话框是否可显示
        IllegalComponentStateException - 如果 undecorated为 false ，并且此对话框没有默认形状
        IllegalComponentStateException - 如果 undecorated是 false ，而这个对话框的不透明度小于 1.0f
        IllegalComponentStateException - 如果 undecorated是 false ，并且此对话框背景颜色的alpha值小于 1.0f
        从以下版本开始：
        1.4
        另请参见：
        isUndecorated() ，
Component.isDisplayable() ，
Window.getShape() ，
Window.getOpacity() ，
Window.getBackground()

      • isUndecorated

        public boolean isUndecorated​()
        指示此对话框是否未装饰。 默认情况下，所有对话框都是初始化的。
        结果
        true如果对话框未装饰; 否则为false 。
        从以下版本开始：
        1.4
        另请参见：
        setUndecorated(boolean)

      • setOpacity

        public void setOpacity​(float opacity)
        设置窗口的不透明度。

        不透明度值在[0..1]的范围内。 请注意，设置不透明度级别为0可能会禁用此窗口上的鼠标事件处理。 这是依赖于平台的行为。

        为了使不透明度值小于1.0f必须满足以下条件：

        • 底层系统必须支持TRANSLUCENT半透明度
        • 窗口必须未装饰（见Frame.setUndecorated(boolean)和setUndecorated(boolean) ）
        • 窗口不能处于全屏模式（参见GraphicsDevice.setFullScreenWindow(Window) ）

        如果请求的不透明度值小于1.0f ，并且不符合上述任何条件，窗口不透明度将不会更改，并且将抛出IllegalComponentStateException 。

        单个像素的半透明度也可以通过其颜色的α分量（见Window.setBackground(Color) ）和该窗口的当前形状（参见Window.setShape(Shape) ）来实现。

        重写：
        setOpacity Window
        参数
        opacity - 设置为窗口的不透明度级别
        另请参见：
        Window.getOpacity() ， Window.setBackground(Color) ， Window.setShape(Shape) ， Frame.isUndecorated() ， isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency)

      • setShape

        public void setShape​(Shape shape)
        设置窗口的形状。

        设置形状会切断窗口的某些部分。 只有属于给定的Shape的部件保持可见和可点击。 如果形状参数为null ，则此方法将恢复默认形状，使窗口在大多数平台上呈矩形。

        必须满足以下条件才能设置非空形状：

        • 底层系统必须支持PERPIXEL_TRANSPARENT半透明度
        • 窗口必须未装饰（参见Frame.setUndecorated(boolean)和setUndecorated(boolean) ）
        • 窗口不能处于全屏模式（参见GraphicsDevice.setFullScreenWindow(Window) ）

        如果请求的形状不是null ，并且不符合上述任何条件，则此窗口的形状将不会改变，并且将抛出UnsupportedOperationException或IllegalComponentStateException 。

        单个像素的半透明度也可以通过其颜色的α分量（见Window.setBackground(Color) ）和不透明度值（见Window.setOpacity(float) ）来实现。 有关详细信息，请参阅GraphicsDevice.WindowTranslucency 。

        重写：
        setShape在 Window
        参数
        shape - 设置窗口的形状
        另请参见：
        Window.getShape() ， Window.setBackground(Color) ， Window.setOpacity(float) ， Frame.isUndecorated() ， isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency)

      • setBackground

        public void setBackground​(Color bgColor)
        设置此窗口的背景颜色。

        如果窗口系统支持PERPIXEL_TRANSLUCENT半透明，给定背景颜色的alpha分量可能会影响此窗口的操作模式：它指示此窗口是否为不透明（alpha等于1.0f ）或每像素半透明（alpha小于1.0f ）。 如果给定的背景颜色是null ，则该窗口被认为是完全不透明的。

        必须满足以下条件以启用此窗口的每像素透明度模式：

        • PERPIXEL_TRANSLUCENT半透明度必须由此窗口所在的图形设备支持
        • 窗口必须未装饰（参见Frame.setUndecorated(boolean)和setUndecorated(boolean) ）
        • 窗口不能处于全屏模式（参见GraphicsDevice.setFullScreenWindow(Window) ）

        如果所请求的背景颜色的alpha分量小于1.0f ，并且不满足上述任何条件，则此窗口的背景颜色不会改变，给定背景颜色的alpha分量不会影响操作模式这个窗口，和UnsupportedOperationException或IllegalComponentStateException将被抛出。

        当窗口是每像素半透明时，绘图子系统遵循每个像素的alpha值。 如果使用等于零的alpha颜色成分绘制像素，则它将变得视觉上透明。 如果像素的alpha等于1.0f，则像素完全不透明。 alpha颜色分量的中间值使像素半透明。 在此模式下，窗口的背景绘制为给定背景颜色的alpha值。 如果此方法的参数的alpha值等于0 ，则背景0根本无法显示。

        给定像素的半透明度的实际水平也取决于窗口不透明度（见Window.setOpacity(float) ）以及该窗口的当前形状（见Window.setShape(Shape) ）。

        请注意，绘制Alpha值为0的像素可能会禁用该像素上的鼠标事件处理。 这是依赖于平台的行为。 为了确保鼠标事件不被分派到特定的像素，像素必须从窗口的形状中排除。

        由于本机平台要求，启用每像素半透明模式可能会改变该窗口的图形配置。

        重写：
        setBackground在 Window
        参数
        bgColor - 成为此窗口的背景颜色的颜色。
        另请参见：
        Window.getBackground() ， Window.isOpaque() ， Window.setOpacity(float) ， Window.setShape(Shape) ， Frame.isUndecorated() ， isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency) ， GraphicsConfiguration.isTranslucencyCapable()

      • paramString

        protected String paramString​()
        返回表示此对话框状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Container
        结果
        该对话窗口的参数字符串。

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此对话框关联的AccessibleContext。 对于对话框，AccessibleContext采用AccessibleAWTDialog的形式。 如有必要，将创建一个新的AccessibleAWTDialog实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Window
        结果
        一个AccessibleAWTDialog，作为此对话框的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Dialog.AccessibleAWTDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Dialog.AccessibleAWTDialog

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    已知直接子类：
    JDialog.AccessibleJDialog
    Enclosing class:
    Dialog

    protected class Dialog.AccessibleAWTDialog
extends Window.AccessibleAWTWindow
    这个类实现Dialog类的辅助功能支持。 它提供了适用于对话框用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTDialog​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, removePropertyChangeListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTDialog

        protected AccessibleAWTDialog​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Window.AccessibleAWTWindow
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态。
        重写：
        getAccessibleStateSet在 Window.AccessibleAWTWindow
        结果
        包含对象的当前状态集的AccessibleStateSet实例
        另请参见：
        AccessibleState
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Dialog.ModalExclusionType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum Dialog.ModalExclusionType

  • java.lang.Object
    • java.lang.Enum<Dialog.ModalExclusionType>
      • java.awt.Dialog.ModalExclusionType
  • All Implemented Interfaces:
    Serializable ， Comparable<Dialog.ModalExclusionType>
    Enclosing class:
    Dialog

    public static enum Dialog.ModalExclusionType
extends Enum<Dialog.ModalExclusionType>
    任何顶级窗口都可以标记为不被模态对话框阻止。 这被称为“模式排斥”。 此枚举指定可能的模式排除类型。
    从以下版本开始：
    1.6
    另请参见：
    Window.getModalExclusionType() ，
Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType) ，
Toolkit.isModalExclusionTypeSupported(java.awt.Dialog.ModalExclusionType)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPLICATION_EXCLUDE
      APPLICATION_EXCLUDE表示顶级窗口不会被任何应用程序模态对话框阻止。
      NO_EXCLUDE
      没有模式排除。
      TOOLKIT_EXCLUDE
      TOOLKIT_EXCLUDE表示顶级窗口不会被应用程序模式或工具箱模态对话框阻止。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Dialog.ModalExclusionType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Dialog.ModalExclusionType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NO_EXCLUDE

        public static final Dialog.ModalExclusionType NO_EXCLUDE
        没有模式排除。

      • APPLICATION_EXCLUDE

        public static final Dialog.ModalExclusionType APPLICATION_EXCLUDE
        APPLICATION_EXCLUDE表示顶级窗口不会被任何应用程序模态对话框阻止。 此外，它不会从其子层次结构外部的文档模式对话框阻止。

      • TOOLKIT_EXCLUDE

        public static final Dialog.ModalExclusionType TOOLKIT_EXCLUDE
        TOOLKIT_EXCLUDE表示顶级窗口不会被应用程序模式或工具箱模态对话框阻止。 此外，它不会从其子层次结构外部的文档模式对话框阻止。 必须为此排除授予“toolkitModality” AWTPermission 。 如果排除属性更改为TOOLKIT_EXCLUDE并且未授予此权限，则将抛出SecurityException ，并且排除属性将保持不变。

    • 方法详细信息

      • values

        public static Dialog.ModalExclusionType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Dialog.ModalExclusionType c : Dialog.ModalExclusionType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Dialog.ModalExclusionType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Dialog.ModalityType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum Dialog.ModalityType

  • java.lang.Object
    • java.lang.Enum<Dialog.ModalityType>
      • java.awt.Dialog.ModalityType
  • All Implemented Interfaces:
    Serializable ， Comparable<Dialog.ModalityType>
    Enclosing class:
    Dialog

    public static enum Dialog.ModalityType
extends Enum<Dialog.ModalityType>
    模态对话框阻止某些顶级窗口的所有输入。 特定窗口是否被阻止取决于对话框的类型; 这被称为“阻塞范围”。 ModalityType枚举指定模态类型及其关联范围。
    从以下版本开始：
    1.6
    另请参见：
    Dialog.getModalityType() ，
Dialog.setModalityType(java.awt.Dialog.ModalityType) ，
Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPLICATION_MODAL
      一个 APPLICATION_MODAL对话框阻止来自同一个Java应用程序的所有顶级窗口，除了它们自己的子层次结构。
      DOCUMENT_MODAL
      一个 DOCUMENT_MODAL对话框阻止了输入到同一个文档的所有顶层窗口，除了它们自己的子层次结构。
      MODELESS
      MODELESS对话框不会阻止任何顶级窗口。
      TOOLKIT_MODAL
      一个 TOOLKIT_MODAL对话框阻止所有从同一个工具包运行的顶级窗口，除了自己的子层次结构。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Dialog.ModalityType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Dialog.ModalityType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MODELESS

        public static final Dialog.ModalityType MODELESS
        MODELESS对话框不会阻止任何顶级窗口。

      • DOCUMENT_MODAL

        public static final Dialog.ModalityType DOCUMENT_MODAL
        一个DOCUMENT_MODAL对话框阻止从同一个文档中输入到所有顶层窗口，而不同于它自己的子层次结构。 文档是没有所有者的顶级窗口。 它可能包含与顶级窗口一起处理为单个实体文档的子窗口。 由于每个顶级窗口都必须属于某个文档，所以它的根可以被找到为没有所有者的顶部最近的窗口。

      • APPLICATION_MODAL

        public static final Dialog.ModalityType APPLICATION_MODAL
        一个APPLICATION_MODAL对话框阻止来自同一个Java应用程序的所有顶级窗口，除了它们自己的子层次结构。 如果在浏览器中启动了几个小程序，则可以将它们视为单独的应用程序或单个应用程序。 这种行为是依赖于实现的。

      • TOOLKIT_MODAL

        public static final Dialog.ModalityType TOOLKIT_MODAL
        一个TOOLKIT_MODAL对话框阻止所有从同一个工具包运行的顶级窗口，除了自己的子层次结构。 如果在浏览器中启动了几个applet，它们都使用相同的工具包运行; 因此，applet显示的工具包模式对话可能会影响嵌入此工具包的Java运行时环境的浏览器实例的其他小程序和所有窗口。 特殊AWTPermission “toolkitModality”必须被授予使用工具包模态对话框。 如果正在创建TOOLKIT_MODAL对话框，并且未授予此权限，则将抛出SecurityException ，并且不会创建对话框。 如果一种模式类型被更改为TOOLKIT_MODAL并且不允许此权限，则将抛出一个SecurityException ，并且该模式类型将保持不变。

    • 方法详细信息

      • values

        public static Dialog.ModalityType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Dialog.ModalityType c : Dialog.ModalityType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Dialog.ModalityType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Dimension (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Dimension

  • java.lang.Object
    • java.awt.geom.Dimension2D
      • java.awt.Dimension
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    DimensionUIResource

    public class Dimension
extends Dimension2D
implements Serializable
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。 该类与组件的某些属性相关联。 由Component类和LayoutManager界面定义的几种方法返回一个Dimension对象。

    通常width和height的值都是非负整数。 允许您创建维度的构造函数不会阻止您为这些属性设置负值。 如果width或height值为负，则其他对象定义的某些方法的行为是未定义的。

    从以下版本开始：
    1.0
    另请参见：
    Component ， LayoutManager ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      int height
      高度尺寸 可以使用负值。
      int width
      宽度尺寸; 可以使用负值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Dimension​()
      创建一个宽度为零，高度为零的 Dimension的实例。
      Dimension​(int width, int height)
      构造一个 Dimension并将其初始化为指定的宽度和指定的高度。
      Dimension​(Dimension d)
      创建一个 Dimension的实例，其宽度和高度与指定维度相同。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查两维对象是否具有相等的值。
      double getHeight​()
      以双精度返回 Dimension的高度。
      Dimension getSize​()
      获取此 Dimension对象的大小。
      double getWidth​()
      以双精度返回此 Dimension的宽度。
      int hashCode​()
      返回此 Dimension的哈希码。
      void setSize​(double width, double height)
      将此 Dimension对象的大小以双精度设置为指定的宽度和高度。
      void setSize​(int width, int height)
      将此 Dimension对象的大小设置为指定的宽度和高度。
      void setSize​(Dimension d)
      将此 Dimension对象的大小设置为指定的大小。
      String toString​()
      返回 Dimension对象的 height和 width字段的值的字符串表示。

      • Methods inherited from class java.awt.geom.Dimension2D

        clone, setSize

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • width

        public int width
        宽度尺寸; 可以使用负值。
        从以下版本开始：
        1.0
        另请参见：
        getSize() ， setSize(double, double)

      • height

        public int height
        高度尺寸 可以使用负值。
        从以下版本开始：
        1.0
        另请参见：
        getSize() ， setSize(double, double)

    • 构造方法详细信息

      • Dimension

        public Dimension​()
        创建一个宽度为零，高度为零的 Dimension实例。

      • Dimension

        public Dimension​(Dimension d)
        创建一个 Dimension的实例，其宽度和高度与指定维度相同。
        参数
        d - width和 height值的指定维度

      • Dimension

        public Dimension​(int width,
                 int height)
        构造一个 Dimension并将其初始化为指定的宽度和指定的高度。
        参数
        width - 指定的宽度
        height - 指定的高度

    • 方法详细信息

      • getWidth

        public double getWidth​()
        以双精度返回此 Dimension的宽度。
        Specified by:
        getWidth在 Dimension2D
        结果
        该宽度为 Dimension 。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        以双精度返回此 Dimension的高度。
        Specified by:
        getHeight在 Dimension2D
        结果
        这个高度这 Dimension 。
        从以下版本开始：
        1.2

      • setSize

        public void setSize​(double width,
                    double height)
        将此Dimension对象的大小设置为双精度的指定宽度和高度。 请注意，如果width或height大于Integer.MAX_VALUE ，则将重置为Integer.MAX_VALUE 。
        Specified by:
        setSize中的 Dimension2D
        参数
        width - Dimension对象的新宽度
        height - Dimension对象的新高度
        从以下版本开始：
        1.2

      • getSize

        public Dimension getSize​()
        获取此Dimension对象的大小。 此方法是出于完整性考虑，它与所述getSize由定义的方法Component 。
        结果
        这个维度的大小，一个新的实例 Dimension具有相同的宽度和高度
        从以下版本开始：
        1.1
        另请参见：
        setSize(double, double) ， Component.getSize()

      • setSize

        public void setSize​(Dimension d)
        将此Dimension对象的大小设置为指定的大小。 此方法是出于完整性考虑，它与所述setSize由定义的方法Component 。
        参数
        d - 这个 Dimension对象的新大小
        从以下版本开始：
        1.1
        另请参见：
        getSize() ， Component.setSize(int, int)

      • setSize

        public void setSize​(int width,
                    int height)
        将此Dimension对象的大小设置为指定的宽度和高度。 此方法是出于完整性考虑，它与所述setSize由定义的方法Component 。
        参数
        width - 这个 Dimension对象的新宽度
        height - 这个 Dimension对象的新高度
        从以下版本开始：
        1.1
        另请参见：
        getSize() ， Component.setSize(int, int)

      • equals

        public boolean equals​(Object obj)
        检查两维对象是否具有相等的值。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Dimension的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 Dimension的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回Dimension对象的height和width字段的值的字符串表示形式。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        toString在 Object
        结果
        这个 Dimension对象的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DisplayMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class DisplayMode

  • java.lang.Object
    • java.awt.DisplayMode

  • public final class DisplayMode
extends Object
    所述DisplayMode类封装的位深度，高度，宽度，和刷新速率GraphicsDevice 。 更改图形设备显示模式的能力取决于平台和配置，并不总是可用（参见GraphicsDevice.isDisplayChangeSupported() ）。

    有关全屏独占模式API的更多信息，请参阅Full-Screen Exclusive Mode API Tutorial 。

    从以下版本开始：
    1.4
    另请参见：
    GraphicsDevice ， GraphicsDevice.isDisplayChangeSupported() ， GraphicsDevice.getDisplayModes() ， GraphicsDevice.setDisplayMode(java.awt.DisplayMode)

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BIT_DEPTH_MULTI
      在该显示模式下支持多个位深度时，位深度的值。
      static int REFRESH_RATE_UNKNOWN
      如果不知道刷新率的值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DisplayMode​(int width, int height, int bitDepth, int refreshRate)
      使用提供的参数创建一个新的显示模式对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(DisplayMode dm)
      返回两种显示模式是否相等。
      boolean equals​(Object dm)
      指示一些其他对象是否等于此。
      int getBitDepth​()
      以像素为单位返回显示的位深度。
      int getHeight​()
      返回显示的高度，以像素为单位。
      int getRefreshRate​()
      以赫兹为单位返回显示刷新率。
      int getWidth​()
      返回显示的宽度，以像素为单位。
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • BIT_DEPTH_MULTI

        @Native
public static final int BIT_DEPTH_MULTI
        在该显示模式下支持多个位深度时，位深度的值。
        另请参见：
        getBitDepth() ， Constant Field Values

      • REFRESH_RATE_UNKNOWN

        @Native
public static final int REFRESH_RATE_UNKNOWN
        如果不知道刷新率的值。
        另请参见：
        getRefreshRate() ， Constant Field Values

    • 构造方法详细信息

      • DisplayMode

        public DisplayMode​(int width,
                   int height,
                   int bitDepth,
                   int refreshRate)
        使用提供的参数创建一个新的显示模式对象。
        参数
        width - 显示的宽度，以像素为单位
        height - 显示的高度（以像素为单位）
        bitDepth - 显示器的位深度，以像素为单位。 如果多个位深度可用，则可以为BIT_DEPTH_MULTI 。
        refreshRate - 显示器的刷新率，单位为赫兹。 如果信息不可用，可以是REFRESH_RATE_UNKNOWN 。
        另请参见：
        BIT_DEPTH_MULTI ， REFRESH_RATE_UNKNOWN

    • 方法详细信息

      • getHeight

        public int getHeight​()
        返回显示的高度，以像素为单位。
        结果
        显示的高度，以像素为单位

      • getWidth

        public int getWidth​()
        返回显示的宽度，以像素为单位。
        结果
        显示的宽度，以像素为单位

      • getBitDepth

        public int getBitDepth​()
        以像素为单位返回显示的位深度。 如果在此显示模式下支持多个位深度，则可能为BIT_DEPTH_MULTI 。
        结果
        显示器的位深度（以像素为单位）。
        另请参见：
        BIT_DEPTH_MULTI

      • getRefreshRate

        public int getRefreshRate​()
        以赫兹为单位返回显示刷新率。 如果信息不可用，可能是REFRESH_RATE_UNKNOWN 。
        结果
        显示器的刷新率（赫兹）。
        另请参见：
        REFRESH_RATE_UNKNOWN

      • equals

        public boolean equals​(DisplayMode dm)
        返回两种显示模式是否相等。
        参数
        dm - 要比较的显示模式
        结果
        两种显示模式是否相等

      • equals

        public boolean equals​(Object dm)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，在多次调用x.equals(y)始终返回true或始终返回false ，没有设置中使用的信息equals比较上的对象被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        dm - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该方法， hashCode方法必须始终返回相同的整数，前提是修改了equals对象中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Event

  • java.lang.Object
    • java.awt.Event
  • All Implemented Interfaces:
    Serializable
    已过时。
    建议使用AWTEvent及其子类

    @Deprecated(since="9")
public class Event
extends Object
implements Serializable
    注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

    Event是一个独立于平台的类，用于在Java 1.0事件模型中封装来自平台的图形用户界面的事件。 在Java 1.1及更高版本中， Event类仅保留向后兼容性。 提供了此类描述中的信息，以帮助程序员将Java 1.0程序转换为新的事件模型。

    在Java 1.0事件模型中，一个事件包含一个id字段，指示它是什么类型的事件，哪个其他Event变量与事件相关。

    对于键盘事件， key包含一个值，表示激活了哪个键，而modifiers包含该事件的修饰符。 对于KEY_PRESS和KEY_RELEASE事件ID， key的值是该密钥的unicode字符代码。 对于KEY_ACTION和KEY_ACTION_RELEASE，的值key是在所定义的动作密钥标识符之一Event类（ PGUP ， PGDN ， F1 ， F2等）。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ACTION_EVENT
      已过时。
      此事件表示用户希望发生某些操作。
      static int ALT_MASK
      已过时。
      该标志表示事件发生时Alt键已关闭。
      Object arg
      已过时。
      事件的任意论证。
      static int BACK_SPACE
      已过时。
      BackSpace键。
      static int CAPS_LOCK
      已过时。
      大写锁定键，非ASCII操作键。
      int clickCount
      已过时。
      对于 MOUSE_DOWN事件，此字段指示连续点击次数。
      static int CTRL_MASK
      已过时。
      该标志表示事件发生时控制键已关闭。
      static int DELETE
      已过时。
      删除键。
      static int DOWN
      已过时。
      向下箭头键，非ASCII操作键。
      static int END
      已过时。
      结束键，非ASCII操作键。
      static int ENTER
      已过时。
      Enter键。
      static int ESCAPE
      已过时。
      退出键
      Event evt
      已过时。
      下一个事件。
      static int F1
      已过时。
      F1功能键，非ASCII动作键。
      static int F10
      已过时。
      F10功能键，非ASCII动作键。
      static int F11
      已过时。
      F11功能键，非ASCII操作键。
      static int F12
      已过时。
      F12功能键，非ASCII动作键。
      static int F2
      已过时。
      F2功能键，非ASCII动作键。
      static int F3
      已过时。
      F3功能键，非ASCII动作键。
      static int F4
      已过时。
      F4功能键，非ASCII动作键。
      static int F5
      已过时。
      F5功能键，非ASCII动作键。
      static int F6
      已过时。
      F6功能键，非ASCII动作键。
      static int F7
      已过时。
      F7功能键，非ASCII动作键。
      static int F8
      已过时。
      F8功能键，非ASCII动作键。
      static int F9
      已过时。
      F9功能键，非ASCII动作键。
      static int GOT_FOCUS
      已过时。
      一个组件获得了重点。
      static int HOME
      已过时。
      主键，非ASCII动作键。
      int id
      已过时。
      指示事件的事件类型，以及哪些其他 Event变量与事件相关。
      static int INSERT
      已过时。
      插入键，非ASCII操作键。
      int key
      已过时。
      在键盘事件中按下的键的键代码。
      static int KEY_ACTION
      已过时。
      用户按下非ASCII 操作键。
      static int KEY_ACTION_RELEASE
      已过时。
      用户已经发布了非ASCII 动作键。
      static int KEY_PRESS
      已过时。
      用户已按下正常键。
      static int KEY_RELEASE
      已过时。
      用户已经释放了一个普通键。
      static int LEFT
      已过时。
      左箭头键，非ASCII操作键。
      static int LIST_DESELECT
      已过时。
      列表中的项目已被取消选择。
      static int LIST_SELECT
      已过时。
      已选择列表中的项目。
      static int LOAD_FILE
      已过时。
      文件加载事件。
      static int LOST_FOCUS
      已过时。
      一个组件失去了焦点。
      static int META_MASK
      已过时。
      该标志表示事件发生时Meta键已关闭。
      int modifiers
      已过时。
      修饰键的状态。
      static int MOUSE_DOWN
      已过时。
      用户按下了鼠标按钮。
      static int MOUSE_DRAG
      已过时。
      用户已按下按钮移动鼠标。
      static int MOUSE_ENTER
      已过时。
      鼠标已经输入了一个组件。
      static int MOUSE_EXIT
      已过时。
      鼠标已经退出了一个组件。
      static int MOUSE_MOVE
      已过时。
      鼠标已经移动，没有按下按钮。
      static int MOUSE_UP
      已过时。
      用户已经释放鼠标按钮。
      static int NUM_LOCK
      已过时。
      数字锁定键，非ASCII动作键。
      static int PAUSE
      已过时。
      暂停键，非ASCII操作键。
      static int PGDN
      已过时。
      Page Down键，非ASCII操作键。
      static int PGUP
      已过时。
      Page Up键，非ASCII操作键。
      static int PRINT_SCREEN
      已过时。
      打印屏幕键，非ASCII操作键。
      static int RIGHT
      已过时。
      右箭头键，非ASCII操作键。
      static int SAVE_FILE
      已过时。
      文件保存事件。
      static int SCROLL_ABSOLUTE
      已过时。
      用户已将气泡（拇指）移动到滚动条中，移动到“绝对”位置，而不是从最后位置偏移。
      static int SCROLL_BEGIN
      已过时。
      滚动开始事件。
      static int SCROLL_END
      已过时。
      滚动结束事件。
      static int SCROLL_LINE_DOWN
      已过时。
      用户已经激活了一个滚动条的 下拉区域。
      static int SCROLL_LINE_UP
      已过时。
      用户激活了滚动条的 排列区域。
      static int SCROLL_LOCK
      已过时。
      滚动锁定键，非ASCII操作键。
      static int SCROLL_PAGE_DOWN
      已过时。
      用户激活滚动条的 向下翻页区域。
      static int SCROLL_PAGE_UP
      已过时。
      用户已经激活了滚动条的 页面向上区域。
      static int SHIFT_MASK
      已过时。
      该标志表示事件发生时Shift键已关闭。
      static int TAB
      已过时。
      Tab键。
      Object target
      已过时。
      目标组件。
      static int UP
      已过时。
      向上箭头键，非ASCII操作键。
      long when
      已过时。
      时间戳
      static int WINDOW_DEICONIFY
      已过时。
      用户已经要求窗口管理器去除图标化窗口。
      static int WINDOW_DESTROY
      已过时。
      用户已经要求窗口管理器杀死窗口。
      static int WINDOW_EXPOSE
      已过时。
      用户已经要求窗口管理器公开窗口。
      static int WINDOW_ICONIFY
      已过时。
      用户已经要求窗口管理器图标化窗口。
      static int WINDOW_MOVED
      已过时。
      用户已经要求窗口管理器移动窗口。
      int x
      已过时。
      事件的 x坐标。
      int y
      已过时。
      事件的 y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Event​(Object target, int id, Object arg)
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。
      Event​(Object target, long when, int id, int x, int y, int key, int modifiers)
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。
      Event​(Object target, long when, int id, int x, int y, int key, int modifiers, Object arg)
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean controlDown​()
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。
      boolean metaDown​()
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。
      protected String paramString​()
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。
      boolean shiftDown​()
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。
      String toString​()
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。
      void translate​(int dx, int dy)
      已过时。
      注意： Event类已过时，仅适用于向后兼容性。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SHIFT_MASK

        public static final int SHIFT_MASK
        已过时。
        该标志表示事件发生时Shift键已关闭。
        另请参见：
        Constant Field Values

      • CTRL_MASK

        public static final int CTRL_MASK
        已过时。
        该标志表示事件发生时控制键已关闭。
        另请参见：
        Constant Field Values

      • META_MASK

        public static final int META_MASK
        已过时。
        该标志表示事件发生时Meta键已关闭。 对于鼠标事件，该标志表示右按钮被按下或释放。
        另请参见：
        Constant Field Values

      • ALT_MASK

        public static final int ALT_MASK
        已过时。
        该标志表示事件发生时Alt键已关闭。 对于鼠标事件，该标志表示鼠标中键被按下或释放。
        另请参见：
        Constant Field Values

      • HOME

        public static final int HOME
        已过时。
        主键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • END

        public static final int END
        已过时。
        结束键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • PGUP

        public static final int PGUP
        已过时。
        Page Up键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • PGDN

        public static final int PGDN
        已过时。
        Page Down键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • UP

        public static final int UP
        已过时。
        向上箭头键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • DOWN

        public static final int DOWN
        已过时。
        向下箭头键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • LEFT

        public static final int LEFT
        已过时。
        左箭头键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • RIGHT

        public static final int RIGHT
        已过时。
        右箭头键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • F1

        public static final int F1
        已过时。
        F1功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F2

        public static final int F2
        已过时。
        F2功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F3

        public static final int F3
        已过时。
        F3功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F4

        public static final int F4
        已过时。
        F4功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F5

        public static final int F5
        已过时。
        F5功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F6

        public static final int F6
        已过时。
        F6功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F7

        public static final int F7
        已过时。
        F7功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F8

        public static final int F8
        已过时。
        F8功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F9

        public static final int F9
        已过时。
        F9功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F10

        public static final int F10
        已过时。
        F10功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • F11

        public static final int F11
        已过时。
        F11功能键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • F12

        public static final int F12
        已过时。
        F12功能键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • PRINT_SCREEN

        public static final int PRINT_SCREEN
        已过时。
        打印屏幕键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • SCROLL_LOCK

        public static final int SCROLL_LOCK
        已过时。
        滚动锁定键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • CAPS_LOCK

        public static final int CAPS_LOCK
        已过时。
        大写锁定键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • NUM_LOCK

        public static final int NUM_LOCK
        已过时。
        数字锁定键，非ASCII动作键。
        另请参见：
        Constant Field Values

      • PAUSE

        public static final int PAUSE
        已过时。
        暂停键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • INSERT

        public static final int INSERT
        已过时。
        插入键，非ASCII操作键。
        另请参见：
        Constant Field Values

      • ENTER

        public static final int ENTER
        已过时。
        Enter键。
        另请参见：
        Constant Field Values

      • BACK_SPACE

        public static final int BACK_SPACE
        已过时。
        BackSpace键。
        另请参见：
        Constant Field Values

      • TAB

        public static final int TAB
        已过时。
        Tab键。
        另请参见：
        Constant Field Values

      • ESCAPE

        public static final int ESCAPE
        已过时。
        退出键
        另请参见：
        Constant Field Values

      • DELETE

        public static final int DELETE
        已过时。
        删除键。
        另请参见：
        Constant Field Values

      • WINDOW_DESTROY

        public static final int WINDOW_DESTROY
        已过时。
        用户已经要求窗口管理器杀死窗口。
        另请参见：
        Constant Field Values

      • WINDOW_EXPOSE

        public static final int WINDOW_EXPOSE
        已过时。
        用户已经要求窗口管理器公开窗口。
        另请参见：
        Constant Field Values

      • WINDOW_ICONIFY

        public static final int WINDOW_ICONIFY
        已过时。
        用户已经要求窗口管理器图标化窗口。
        另请参见：
        Constant Field Values

      • WINDOW_DEICONIFY

        public static final int WINDOW_DEICONIFY
        已过时。
        用户已经要求窗口管理器去除图标化窗口。
        另请参见：
        Constant Field Values

      • WINDOW_MOVED

        public static final int WINDOW_MOVED
        已过时。
        用户已经要求窗口管理器移动窗口。
        另请参见：
        Constant Field Values

      • KEY_PRESS

        public static final int KEY_PRESS
        已过时。
        用户已按下正常键。
        另请参见：
        Constant Field Values

      • KEY_RELEASE

        public static final int KEY_RELEASE
        已过时。
        用户已经释放了一个普通键。
        另请参见：
        Constant Field Values

      • KEY_ACTION

        public static final int KEY_ACTION
        已过时。
        用户按下非ASCII 操作键。 key字段包含一个值，表示事件发生在其中一个动作键上，其中包括12个功能键，箭头（光标）键，Page Up，Page Down，Home，End，Print Screen，Scroll Lock，Caps锁定，数字锁定，暂停和插入。
        另请参见：
        Constant Field Values

      • KEY_ACTION_RELEASE

        public static final int KEY_ACTION_RELEASE
        已过时。
        用户已经发布了非ASCII 动作键。 key字段包含一个值，表示事件发生在其中一个操作键上，其中包括12个功能键，箭头（光标）键，Page Up，Page Down，Home，End，Print Screen，Scroll Lock，Caps锁定，数字锁定，暂停和插入。
        另请参见：
        Constant Field Values

      • MOUSE_DOWN

        public static final int MOUSE_DOWN
        已过时。
        用户按下了鼠标按钮。 ALT_MASK标志表示中间按钮已被按下。 META_MASK标志表示右按钮已被按下。
        另请参见：
        ALT_MASK ， META_MASK ， Constant Field Values

      • MOUSE_UP

        public static final int MOUSE_UP
        已过时。
        用户已经释放鼠标按钮。 ALT_MASK标志表示中间按钮已被释放。 META_MASK标志表示右按钮已被释放。
        另请参见：
        ALT_MASK ， META_MASK ， Constant Field Values

      • MOUSE_MOVE

        public static final int MOUSE_MOVE
        已过时。
        鼠标已经移动，没有按下按钮。
        另请参见：
        Constant Field Values

      • MOUSE_ENTER

        public static final int MOUSE_ENTER
        已过时。
        鼠标已经输入了一个组件。
        另请参见：
        Constant Field Values

      • MOUSE_EXIT

        public static final int MOUSE_EXIT
        已过时。
        鼠标已经退出了一个组件。
        另请参见：
        Constant Field Values

      • MOUSE_DRAG

        public static final int MOUSE_DRAG
        已过时。
        用户已按下按钮移动鼠标。 ALT_MASK标志表示中间按钮被按下。 META_MASK标志表示右按钮被按下。
        另请参见：
        ALT_MASK ， META_MASK ， Constant Field Values

      • SCROLL_LINE_UP

        public static final int SCROLL_LINE_UP
        已过时。
        用户激活了滚动条的 排列区域。
        另请参见：
        Constant Field Values

      • SCROLL_LINE_DOWN

        public static final int SCROLL_LINE_DOWN
        已过时。
        用户已经激活了一个滚动条的 下拉区域。
        另请参见：
        Constant Field Values

      • SCROLL_PAGE_UP

        public static final int SCROLL_PAGE_UP
        已过时。
        用户已经激活了滚动条的 页面向上区域。
        另请参见：
        Constant Field Values

      • SCROLL_PAGE_DOWN

        public static final int SCROLL_PAGE_DOWN
        已过时。
        用户激活滚动条的 向下翻页区域。
        另请参见：
        Constant Field Values

      • SCROLL_ABSOLUTE

        public static final int SCROLL_ABSOLUTE
        已过时。
        用户已将气泡（拇指）移动到滚动条中，移动到“绝对”位置，而不是从最后位置偏移。
        另请参见：
        Constant Field Values

      • SCROLL_BEGIN

        public static final int SCROLL_BEGIN
        已过时。
        滚动开始事件。
        另请参见：
        Constant Field Values

      • SCROLL_END

        public static final int SCROLL_END
        已过时。
        滚动结束事件。
        另请参见：
        Constant Field Values

      • LIST_SELECT

        public static final int LIST_SELECT
        已过时。
        已选择列表中的项目。
        另请参见：
        Constant Field Values

      • LIST_DESELECT

        public static final int LIST_DESELECT
        已过时。
        列表中的项目已被取消选择。
        另请参见：
        Constant Field Values

      • ACTION_EVENT

        public static final int ACTION_EVENT
        已过时。
        此事件表示用户希望发生某些操作。
        另请参见：
        Constant Field Values

      • LOAD_FILE

        public static final int LOAD_FILE
        已过时。
        文件加载事件。
        另请参见：
        Constant Field Values

      • SAVE_FILE

        public static final int SAVE_FILE
        已过时。
        文件保存事件。
        另请参见：
        Constant Field Values

      • GOT_FOCUS

        public static final int GOT_FOCUS
        已过时。
        一个组件获得了重点。
        另请参见：
        Constant Field Values

      • LOST_FOCUS

        public static final int LOST_FOCUS
        已过时。
        一个组件失去了焦点。
        另请参见：
        Constant Field Values

      • target

        public Object target
        已过时。
        目标组件。 这表示事件发生或与事件相关联的组件。 此对象已被AWTEvent.getSource（）替代
        另请参见：
        EventObject.getSource()

      • when

        public long when
        已过时。
        时间戳 由InputEvent.getWhen（）替换。
        另请参见：
        InputEvent.getWhen()

      • id

        public int id
        已过时。
        指示事件的事件类型，以及哪些其他Event变量与事件相关。 这已被AWTEvent.getID（）替代
        另请参见：
        AWTEvent.getID()

      • x

        public int x
        已过时。
        事件的x坐标。 由MouseEvent.getX（）替代
        另请参见：
        MouseEvent.getX()

      • y

        public int y
        已过时。
        事件的y坐标。 由MouseEvent.getY（）替代
        另请参见：
        MouseEvent.getY()

      • key

        public int key
        已过时。
        在键盘事件中按下的键的键代码。 这已被KeyEvent.getKeyCode（）
        另请参见：
        KeyEvent.getKeyCode()

      • modifiers

        public int modifiers
        已过时。
        修饰键的状态。 这被替换为InputEvent.getModifiers（）在java 1.1中MouseEvent和KeyEvent是InputEvent的子类。
        另请参见：
        InputEvent.getModifiers()

      • clickCount

        public int clickCount
        已过时。
        对于MOUSE_DOWN事件，此字段指示连续点击次数。 对于其他事件，其值为0 。 此字段已被MouseEvent.getClickCount（）替代。
        另请参见：
        MouseEvent.getClickCount()

      • arg

        public Object arg
        已过时。
        事件的任意论证。 该字段的值取决于事件的类型。 arg已被事件特定的属性所取代。

      • evt

        public Event evt
        已过时。
        下一个事件。 将事件放入链表时设置此字段。 这已被EventQueue所取代。
        另请参见：
        EventQueue

    • 构造方法详细信息

      • Event

        public Event​(Object target,
             long when,
             int id,
             int x,
             int y,
             int key,
             int modifiers,
             Object arg)
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        使用指定的目标组件，时间戳，事件类型， x和y坐标，键盘键，修改键的状态和参数创建一个Event的实例。

        参数
        target - 目标组件。
        when - 时间戳。
        id - 事件类型。
        x - x坐标。
        y - y坐标。
        key - 在键盘事件中按下的键。
        modifiers - 修饰键的状态。
        arg - 指定的参数。

      • Event

        public Event​(Object target,
             long when,
             int id,
             int x,
             int y,
             int key,
             int modifiers)
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        创建一个Event的实例，其中包含指定的目标组件，时间戳，事件类型， x和y坐标，键盘键，修改键的状态以及设置为null的参数。

        参数
        target - 目标组件。
        when - 时间戳。
        id - 事件类型。
        x - x坐标。
        y - y坐标。
        key - 在键盘事件中按下的键。
        modifiers - 修饰键的状态。

      • Event

        public Event​(Object target,
             int id,
             Object arg)
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        使用指定的目标组件，事件类型和参数创建一个Event的实例。

        参数
        target - 目标组件。
        id - 事件类型。
        arg - 指定的参数。

    • 方法详细信息

      • translate

        public void translate​(int dx,
                      int dy)
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        转换这个事件，使其x和y坐标分别增加dx和dy 。

        该方法将相对于给定组件的事件进行转换。 这至少涉及将坐标转换为给定组件的局部坐标系。 在曝光事件的情况下，还可能涉及翻译区域。

        参数
        dx - 转换 x坐标的距离。
        dy - 平移 y坐标的距离。

      • shiftDown

        public boolean shiftDown​()
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        检查Shift键是否关闭。

        结果
        true如果钥匙关闭; 否则为false 。
        另请参见：
        modifiers ， controlDown() ， metaDown()

      • controlDown

        public boolean controlDown​()
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        检查控制键是否关闭。

        结果
        true如果钥匙关闭; 否则为false 。
        另请参见：
        modifiers ， shiftDown() ， metaDown()

      • metaDown

        public boolean metaDown​()
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        检查Meta键是否关闭。

        结果
        true如果键是关闭的; 否则为false 。
        另请参见：
        modifiers ， shiftDown() ， controlDown()

      • paramString

        protected String paramString​()
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它被替换为AWTEvent类及其子类。

        返回表示Event的状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。

        结果
        该事件的参数字符串

      • toString

        public String toString​()
        已过时。
        注意： Event类已过时，仅适用于向后兼容性。 它已被替换为AWTEvent类及其子类。

        以字符串形式返回此事件值的表示形式。

        重写：
        toString在 Object
        结果
        一个表示事件的字符串及其成员字段的值。
        从以下版本开始：
        1.1
        另请参见：
        paramString()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class EventQueue

  • java.lang.Object
    • java.awt.EventQueue

  • public class EventQueue
extends Object
    EventQueue是一个独立于平台的类，可以从基础对等体类和可信应用程序类排队事件。

    它封装了从队列中提取事件，并通过调用调度它们异步事件指派机制dispatchEvent(AWTEvent)这种方法EventQueue与该事件被分派作为参数。 这种机器的特殊行为是依赖于实现的。 唯一的要求是实际排队到这个队列的事件（注意，发布到EventQueue事件可以合并）被调度：

    顺序。
    也就是说，不允许同时调度此队列中的几个事件。
    它们排列顺序相同。
    也就是说，如果AWTEvent A被排入到EventQueue前AWTEvent B，则事件B不能在事件A之前被指派

    一些浏览器将不同代码库中的小程序分割成单独的上下文，并在这些上下文之间建立墙壁。 在这种情况下，每个上下文将有一个EventQueue 。 其他浏览器将所有小程序放入相同的上下文中，这意味着所有小程序将只有一个全局的EventQueue 。 这种行为是依赖于实现的。 有关更多信息，请参阅浏览器的文档。

    有关事件调度机械线程问题的信息，请参阅AWT Threading Issues 。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventQueue​()
      初始化一个新的实例 EventQueue 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SecondaryLoop createSecondaryLoop​()
      创建与此事件队列相关联的新的 secondary loop 。
      protected void dispatchEvent​(AWTEvent event)
      调度事件。
      static AWTEvent getCurrentEvent​()
      返回与调用线程相关联的 EventQueue当前调度的事件。
      static long getMostRecentEventTime​()
      返回具有时间戳记的最新事件的时间戳，并从与调用线程相关联的 EventQueue中调度。
      AWTEvent getNextEvent​()
      从 EventQueue删除事件并返回。
      static void invokeAndWait​(Runnable runnable)
      导致 runnable在 dispatch thread的 dispatch thread中调用其 run方法。
      static void invokeLater​(Runnable runnable)
      导致 runnable要求其 run方法在 dispatch thread的 the system EventQueue中调用 。
      static boolean isDispatchThread​()
      如果调用线程是 the current AWT EventQueue的分派线程，则返回true。
      AWTEvent peekEvent​()
      返回 EventQueue上的第一个事件，而不删除它。
      AWTEvent peekEvent​(int id)
      返回具有指定ID的第一个事件（如果有）。
      protected void pop​()
      停止派遣事件使用这 EventQueue 。
      void postEvent​(AWTEvent theEvent)
      发布一个1.1风格的事件到 EventQueue 。
      void push​(EventQueue newEventQueue)
      用指定的替换现有的 EventQueue 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EventQueue

        public EventQueue​()
        初始化一个新的实例 EventQueue 。

    • 方法详细信息

      • postEvent

        public void postEvent​(AWTEvent theEvent)
        发布一个1.1样式的事件到EventQueue 。 如果具有相同ID和事件源的队列上存在现有事件，则将调用源Component的coalesceEvents方法。
        参数
        theEvent -实例 java.awt.AWTEvent ，或它的子类
        异常
        NullPointerException - 如果 theEvent是 null

      • getNextEvent

        public AWTEvent getNextEvent​()
                      throws InterruptedException
        从EventQueue删除事件并返回。 此方法将阻止，直到事件已被另一个线程发布。
        结果
        下一个 AWTEvent
        异常
        InterruptedException - 如果任何线程已经中断了此线程

      • peekEvent

        public AWTEvent peekEvent​()
        返回 EventQueue上的第一个事件，而不删除它。
        结果
        第一个事件

      • peekEvent

        public AWTEvent peekEvent​(int id)
        返回具有指定ID的第一个事件（如果有）。
        参数
        id - 所需事件类型的id
        结果
        指定id的第一个事件或 null如果没有这样的事件

      • dispatchEvent

        protected void dispatchEvent​(AWTEvent event)
        调度事件。 事件的分派方式取决于事件的类型和事件的源对象的类型： Event types, source types, and dispatch methods Event Type Source Type Dispatched To ActiveEvent Any event.dispatch() Other Component source.dispatchEvent(AWTEvent) Other MenuComponent source.dispatchEvent(AWTEvent) Other Other No action (ignored)
        参数
        event -实例 java.awt.AWTEvent ，或它的子类
        异常
        NullPointerException - 如果 event是 null
        从以下版本开始：
        1.2

      • getMostRecentEventTime

        public static long getMostRecentEventTime​()
        返回具有时间戳的最新事件的时间戳，并从与调用线程相关联的EventQueue中分派。 如果当前正在调度具有时间戳的事件，则会返回其时间戳。 如果尚未调度事件，则将返回EventQueue的初始化时间。在当前版本的JDK中，只有InputEvent s， ActionEvent s和InvocationEvent具有时间戳; 然而，JDK的未来版本可能会向其他事件类型添加时间戳。 请注意，此方法只能从应用程序的event dispatching thread调用。 如果从另一个线程调用此方法，则将返回当前系统时间（由System.currentTimeMillis()报告）。
        结果
        的时间戳最后 InputEvent ， ActionEvent ，或 InvocationEvent被分派，或 System.currentTimeMillis()如果该方法在不同于事件指派线程的线程上调用
        从以下版本开始：
        1.4
        另请参见：
        InputEvent.getWhen() ，
ActionEvent.getWhen() ，
InvocationEvent.getWhen() ，
isDispatchThread()

      • getCurrentEvent

        public static AWTEvent getCurrentEvent​()
        返回与调用线程相关联的EventQueue当前调度的事件。 如果一个方法需要对该事件的访问，但是这个方法没有被设计为接受对它的引用作为参数，这是有用的。 请注意，此方法只能从应用程序的事件调度线程调用。 如果从另一个线程调用此方法，则返回null。
        结果
        当前正在调度的事件，如果在除事件分派线程之外的线程上调用此方法，则为null
        从以下版本开始：
        1.4

      • push

        public void push​(EventQueue newEventQueue)
        用指定的替换现有的EventQueue 。 任何待处理的事件都将转移到新的EventQueue进行处理。
        参数
        newEventQueue - 要使用的 EventQueue （或其子类）实例
        异常
        NullPointerException - 如果 newEventQueue是 null
        从以下版本开始：
        1.2
        另请参见：
        pop()

      • pop

        protected void pop​()
            throws EmptyStackException
        停止使用这个EventQueue调度事件。 任何待处理的事件都将转移到先前的EventQueue进行处理。

        警告：为避免死锁，请勿在子类中声明此方法同步。

        异常
        EmptyStackException - 如果以前没有推出这个 EventQueue
        从以下版本开始：
        1.2
        另请参见：
        push(java.awt.EventQueue)

      • createSecondaryLoop

        public SecondaryLoop createSecondaryLoop​()
        创建与此事件队列相关联的新的secondary loop 。 使用SecondaryLoop.enter()和SecondaryLoop.exit()方法启动和停止事件循环并从此队列中分派事件。
        结果
        secondaryLoop一个新的辅助循环对象，可用于启动新的嵌套事件循环并从此队列调度事件
        从以下版本开始：
        1.7
        另请参见：
        SecondaryLoop.enter() ， SecondaryLoop.exit()

      • isDispatchThread

        public static boolean isDispatchThread​()
        如果调用线程是the current AWT EventQueue的分派线程，则返回true。 使用此方法确保某个特定任务正在执行（或不在）。

        注意：使用invokeLater(java.lang.Runnable)或invokeAndWait(java.lang.Runnable)方法在the current AWT EventQueue的发送线程中执行任务。

        结果
        如果在 the current AWT EventQueue的发送线程中运行， 则为 true
        从以下版本开始：
        1.2
        另请参见：
        invokeLater(java.lang.Runnable) ，
invokeAndWait(java.lang.Runnable) ，
Toolkit.getSystemEventQueue()

      • invokeLater

        public static void invokeLater​(Runnable runnable)
        导致runnable在dispatch thread的dispatch thread中调用其run方法。 这将在所有待处理的事件被处理之后发生。
        参数
        runnable - Runnable其 run方法应该在 event dispatch thread中异步执行 the system EventQueue
        从以下版本开始：
        1.2
        另请参见：
        invokeAndWait(java.lang.Runnable) ，
Toolkit.getSystemEventQueue() ，
isDispatchThread()

      • invokeAndWait

        public static void invokeAndWait​(Runnable runnable)
                          throws InterruptedException,
                                 InvocationTargetException
        导致runnable要求其run方法在dispatch thread的the system EventQueue中调用 。 这将在所有待处理的事件被处理之后发生。 调用块直到发生这种情况。 如果从event dispatcher thread调用，此方法将抛出错误。
        参数
        runnable - Runnable其 run方法应在 event dispatch thread中同步执行 event dispatch thread的 the system EventQueue
        异常
        InterruptedException - 如果任何线程中断了此线程
        InvocationTargetException - 如果在运行时抛出一个throwable runnable
        从以下版本开始：
        1.2
        另请参见：
        invokeLater(java.lang.Runnable) ，
Toolkit.getSystemEventQueue() ，
isDispatchThread()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class FileDialog

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
          • java.awt.Dialog
            • java.awt.FileDialog
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class FileDialog
extends Dialog
    FileDialog类显示一个对话窗口，用户可以从中选择一个文件。

    由于它是一个模态对话框，当应用程序调用其show方法来显示对话框时，它将阻止应用程序的其余部分，直到用户选择一个文件。

    从以下版本开始：
    1.0
    另请参见：
    Window.show() ， Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Dialog

        Dialog.AccessibleAWTDialog, Dialog.ModalExclusionType, Dialog.ModalityType

      • Nested classes/interfaces inherited from class java.awt.Window

        Window.AccessibleAWTWindow, Window.Type

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int LOAD
      该常量值表示文件对话窗口的目的是找到要从中读取的文件。
      static int SAVE
      该常量值表示文件对话窗口的目的是找到要写入的文件。

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from class java.awt.Dialog

        DEFAULT_MODALITY_TYPE

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileDialog​(Dialog parent)
      创建一个加载文件的文件对话框。
      FileDialog​(Dialog parent, String title)
      创建一个文件对话框窗口，其中包含用于加载文件的指定标题。
      FileDialog​(Dialog parent, String title, int mode)
      创建一个带有指定标题的文件对话窗口，用于加载或保存文件。
      FileDialog​(Frame parent)
      创建一个加载文件的文件对话框。
      FileDialog​(Frame parent, String title)
      创建一个文件对话框窗口，其中包含用于加载文件的指定标题。
      FileDialog​(Frame parent, String title, int mode)
      创建一个带有指定标题的文件对话窗口，用于加载或保存文件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addNotify​()
      创建文件对话框的对等体。
      String getDirectory​()
      获取此文件对话框的目录。
      String getFile​()
      获取此文件对话框的选定文件。
      FilenameFilter getFilenameFilter​()
      确定此文件对话框的文件名过滤器。
      File[] getFiles​()
      返回用户选择的文件。
      int getMode​()
      指示此文件对话框是从文件加载还是保存到文件。
      boolean isMultipleMode​()
      返回文件对话框是否允许多个文件选择。
      protected String paramString​()
      返回一个表示 FileDialog窗口状态的字符串。
      void setDirectory​(String dir)
      将此文件对话框窗口的目录设置为指定的目录。
      void setFile​(String file)
      将此文件对话框窗口的选定文件设置为指定的文件。
      void setFilenameFilter​(FilenameFilter filter)
      将此文件对话窗口的文件名过滤器设置为指定的过滤器。
      void setMode​(int mode)
      设置文件对话框的模式。
      void setMultipleMode​(boolean enable)
      启用或禁用文件对话框的多个文件选择。
      void setTitle​(String title)
      设置对话框的标题。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, resize, resize, revalidate, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setMaximumSize, setMixingCutoutShape, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from class java.awt.Dialog

        getAccessibleContext, getModalityType, getTitle, hide, isModal, isResizable, isUndecorated, setBackground, setModal, setModalityType, setOpacity, setResizable, setShape, setUndecorated, setVisible, show, toBack

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.Window

        addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBackground, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOpacity, getOwnedWindows, getOwner, getOwnerlessWindows, getShape, getToolkit, getType, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isAutoRequestFocus, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isOpaque, isShowing, isValidateRoot, pack, paint, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setAutoRequestFocus, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocation, setLocation, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setType, toFront

    • 字段详细信息

      • LOAD

        public static final int LOAD
        该常量值表示文件对话窗口的目的是找到要从中读取的文件。
        另请参见：
        Constant Field Values

      • SAVE

        public static final int SAVE
        该常量值表示文件对话窗口的目的是找到要写入的文件。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • FileDialog

        public FileDialog​(Frame parent)
        创建一个加载文件的文件对话框。 文件对话框的标题最初为空。 这是一个方便的方法FileDialog(parent, "", LOAD) 。

        注意：某些平台可能不支持在文件对话框中显示用户指定的标题。 在这种情况下，文件对话框的标题栏中不会显示任何标题，或者在某些系统上将不会显示文件对话框的标题栏。

        参数
        parent - 对话框的所有者
        从以下版本开始：
        1.1

      • FileDialog

        public FileDialog​(Frame parent,
                  String title)
        创建一个文件对话框窗口，其中包含用于加载文件的指定标题。 显示的文件是当前目录中的文件。 这是一个方便的方法FileDialog(parent, title, LOAD) 。

        注意：某些平台可能不支持在文件对话框中显示用户指定的标题。 在这种情况下，文件对话框的标题栏中不会显示任何标题，或者在某些系统上将不会显示文件对话框的标题栏。

        参数
        parent - 对话框的所有者
        title - 对话框的标题

      • FileDialog

        public FileDialog​(Frame parent,
                  String title,
                  int mode)
        创建一个带有指定标题的文件对话窗口，用于加载或保存文件。

        如果mode值为LOAD ，则文件对话框将找到要读取的文件，并显示当前目录中的文件。 如果mode值为SAVE ，则文件对话框正在找到一个写入文件的位置。

        注意：某些平台可能不支持在文件对话框中显示用户指定的标题。 在这种情况下，文件对话框的标题栏中不会显示任何标题，或者在某些系统上将不会显示文件对话框的标题栏。

        参数
        parent - 对话框的所有者
        title - 对话框的标题
        mode - 对话框的模式; FileDialog.LOAD或FileDialog.SAVE
        异常
        IllegalArgumentException - 如果提供非法文件对话模式
        另请参见：
        LOAD ， SAVE

      • FileDialog

        public FileDialog​(Dialog parent)
        创建一个加载文件的文件对话框。 文件对话框的标题最初为空。 这是一个方便的方法FileDialog(parent, "", LOAD) 。

        注意：某些平台可能不支持在文件对话框中显示用户指定的标题。 在这种情况下，文件对话框的标题栏中不会显示任何标题，或者在某些系统上将不会显示文件对话框的标题栏。

        参数
        parent - 对话框的所有者
        异常
        IllegalArgumentException - 如果 parent的 GraphicsConfiguration不是从屏幕设备;
        IllegalArgumentException - 如果parent是null ; 当GraphicsEnvironment.isHeadless返回true时，总是会抛出此异常
        从以下版本开始：
        1.5
        另请参见：
        GraphicsEnvironment.isHeadless()

      • FileDialog

        public FileDialog​(Dialog parent,
                  String title)
        创建一个文件对话框窗口，其中包含用于加载文件的指定标题。 显示的文件是当前目录中的文件。 这是一个方便的方法FileDialog(parent, title, LOAD) 。

        注意：某些平台可能不支持在文件对话框中显示用户指定的标题。 在这种情况下，文件对话框的标题栏中不会显示任何标题，或者在某些系统上将不会显示文件对话框的标题栏。

        参数
        parent - 对话框的所有者
        title - 对话框的标题; 一个null值将被接受，而不会引起NullPointerException
        异常
        IllegalArgumentException - 如果 parent的 GraphicsConfiguration不是从屏幕设备;
        IllegalArgumentException - 如果parent是null ; 当GraphicsEnvironment.isHeadless返回true时，始终抛出此异常
        从以下版本开始：
        1.5
        另请参见：
        GraphicsEnvironment.isHeadless()

      • FileDialog

        public FileDialog​(Dialog parent,
                  String title,
                  int mode)
        创建一个带有指定标题的文件对话窗口，用于加载或保存文件。

        如果mode值为LOAD ，则文件对话框将找到要读取的文件，并显示当前目录中的文件。 如果mode值为SAVE ，则文件对话框正在找到一个写入文件的位置。

        注意：某些平台可能不支持在文件对话框中显示用户指定的标题。 在这种情况下，文件对话框的标题栏中不会显示任何标题，或者在某些系统上将不会显示文件对话框的标题栏。

        参数
        parent - 对话框的所有者
        title - 对话的标题; 将接受一个null值，而不会导致抛出NullPointerException
        mode - 对话框的模式; FileDialog.LOAD或FileDialog.SAVE
        异常
        IllegalArgumentException - 如果提供非法文件对话模式;
        IllegalArgumentException - 如果 parent的 GraphicsConfiguration不是来自屏幕设备;
        IllegalArgumentException - 如果parent是null ; 当GraphicsEnvironment.isHeadless返回true时，总是抛出此异常
        从以下版本开始：
        1.5
        另请参见：
        GraphicsEnvironment.isHeadless() ， LOAD ， SAVE

    • 方法详细信息

      • setTitle

        public void setTitle​(String title)
        设置对话框的标题。

        注意：某些平台可能不支持在文件对话框中显示用户指定的标题。 在这种情况下，文件对话框的标题栏中不会显示任何标题，或者在某些系统上将不会显示文件对话框的标题栏。

        重写：
        setTitle在 Dialog
        参数
        title - 对话框边框中显示的标题; 空值导致空标题
        另请参见：
        Dialog.getTitle()

      • addNotify

        public void addNotify​()
        创建文件对话框的对等体。 对等体允许我们改变文件对话框的外观而不改变它的功能。
        重写：
        addNotify中的 Dialog
        另请参见：
        Component.isDisplayable() ， Window.removeNotify()

      • getMode

        public int getMode​()
        指示此文件对话框是从文件加载还是保存到文件。
        结果
        该文件对话窗口的模式，可以是 FileDialog.LOAD或 FileDialog.SAVE
        另请参见：
        LOAD ， SAVE ， setMode(int)

      • setMode

        public void setMode​(int mode)
        设置文件对话框的模式。 如果mode不是合法值，将抛出异常， mode将不会设置mode 。
        参数
        mode - 此文件对话框的模式， FileDialog.LOAD或 FileDialog.SAVE
        异常
        IllegalArgumentException - 如果提供非法文件对话模式
        从以下版本开始：
        1.1
        另请参见：
        LOAD ， SAVE ， getMode()

      • getDirectory

        public String getDirectory​()
        获取此文件对话框的目录。
        结果
        （潜在 null此的或无效的）目录 FileDialog
        另请参见：
        setDirectory(java.lang.String)

      • setDirectory

        public void setDirectory​(String dir)
        将此文件对话框窗口的目录设置为指定的目录。 指定null或无效目录意味着实现定义的默认值。 然而，直到用户选择了一个文件，这个默认值才会被实现。 直到这一点， getDirectory()将返回传递给这个方法的值。

        指定“”作为目录完全等同于指定null作为目录。

        参数
        dir - 指定的目录
        另请参见：
        getDirectory()

      • getFile

        public String getFile​()
        获取此文件对话框的选定文件。 如果用户选择了CANCEL ，则返回的文件为null 。
        结果
        此文件对话窗口当前选定的文件，或 null如果没有选择）
        另请参见：
        setFile(java.lang.String)

      • getFiles

        public File[] getFiles​()
        返回用户选择的文件。

        如果用户取消文件对话框，则该方法返回一个空数组。

        结果
        如果用户取消文件对话框，用户选择的文件或空数组。
        从以下版本开始：
        1.7
        另请参见：
        setFile(String) ， getFile()

      • setFile

        public void setFile​(String file)
        将此文件对话框窗口的选定文件设置为指定的文件。 如果在首次显示文件对话窗口之前设置该文件，该文件将成为默认文件。

        当显示对话框时，选择指定的文件。 选择的种类取决于文件的存在，对话框类型和本地平台。 例如，该文件可以在文件列表中突出显示，或者文件名编辑框可以用文件名填充。

        如果与setDirectory方法一起使用，则此方法接受完整文件路径或具有扩展名的文件名。

        指定“”作为文件完全等同于指定null作为文件。

        参数
        file - 正在设置的文件
        另请参见：
        getFile() ， getFiles()

      • setMultipleMode

        public void setMultipleMode​(boolean enable)
        启用或禁用文件对话框的多个文件选择。
        参数
        enable - 如果true ，启用多个文件选择; false - 禁用。
        从以下版本开始：
        1.7
        另请参见：
        isMultipleMode()

      • isMultipleMode

        public boolean isMultipleMode​()
        返回文件对话框是否允许多个文件选择。
        结果
        true如果文件对话框允许多个文件选择; 否则为false 。
        从以下版本开始：
        1.7
        另请参见：
        setMultipleMode(boolean)

      • getFilenameFilter

        public FilenameFilter getFilenameFilter​()
        确定此文件对话框的文件名过滤器。 文件名过滤器允许用户指定文件对话窗口中显示哪些文件。 文件名过滤器在Sun的Microsoft Windows参考实现中不起作用。
        结果
        此文件对话框的文件名过滤器
        另请参见：
        FilenameFilter ， setFilenameFilter(java.io.FilenameFilter)

      • setFilenameFilter

        public void setFilenameFilter​(FilenameFilter filter)
        将此文件对话窗口的文件名过滤器设置为指定的过滤器。 文件名过滤器在Sun的Microsoft Windows参考实现中不起作用。
        参数
        filter - 指定的过滤器
        另请参见：
        FilenameFilter ， getFilenameFilter()

      • paramString

        protected String paramString​()
        返回一个表示FileDialog窗口状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Dialog
        结果
        该文件对话窗口的参数字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FlowLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class FlowLayout

  • java.lang.Object
    • java.awt.FlowLayout
  • All Implemented Interfaces:
    LayoutManager ， Serializable

    public class FlowLayout
extends Object
implements LayoutManager, Serializable
    流程布局将组件布置在定向流中，与段落中的文本行类似。 流动方向由容器的componentOrientation属性确定，可以是两个值之一：
    • ComponentOrientation.LEFT_TO_RIGHT
    • ComponentOrientation.RIGHT_TO_LEFT
    流程布局通常用于布置面板中的按钮。 它可以水平排列按钮，直到不再有按钮在同一行上。 行对齐由align属性确定。 可能的值是：
    • LEFT
    • RIGHT
    • CENTER
    • LEADING
    • TRAILING

    例如，下图显示了使用流布局管理器（其默认布局管理器）定位三个按钮的小程序：

    这是applet的代码：

     import java.awt.*;
 import java.applet.Applet;

 public class myButtons extends Applet {
     Button button1, button2, button3;
     public void init() {
         button1 = new Button("Ok");
         button2 = new Button("Open");
         button3 = new Button("Close");
         add(button1);
         add(button2);
         add(button3);
     }
 }

    流程布局允许每个组件承担其自然（优选）大小。

    从以下版本开始：
    1.0
    另请参见：
    ComponentOrientation ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CENTER
      该值表示每行的组件应该居中。
      static int LEADING
      该值表示组件的每一行应该对齐到容器方向的前端，例如从左到右的方向向左。
      static int LEFT
      该值表示每一行的组件应为左对齐。
      static int RIGHT
      该值表示组件的每一行都应该是右对齐的。
      static int TRAILING
      该值表示组件的每一行应该对齐到容器方向的后端，例如从左到右的方向向右。

    • 构造方法摘要

      构造方法
      Constructor 描述
      FlowLayout​()
      构造一个新的 FlowLayout ，具有中心对齐和默认的5单位水平和垂直间隙。
      FlowLayout​(int align)
      构造新的 FlowLayout具有指定的对齐和默认的5单位水平和垂直间隙。
      FlowLayout​(int align, int hgap, int vgap)
      创建一个新的流程布局管理器，具有指示的对齐方式和指示的水平和垂直间距。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addLayoutComponent​(String name, Component comp)
      将指定的组件添加到布局。
      int getAlignment​()
      获取此布局的对齐方式。
      boolean getAlignOnBaseline​()
      如果组件沿其基线垂直对齐，则返回true。
      int getHgap​()
      获得组件之间以及组件之间的水平间隙和 Container的边框
      int getVgap​()
      获得组件之间以及组件之间的垂直间隙和 Container的边框。
      void layoutContainer​(Container target)
      放出容器。
      Dimension minimumLayoutSize​(Container target)
      返回布局指定目标容器中包含的 可见组件所需的最小尺寸。
      Dimension preferredLayoutSize​(Container target)
      给定指定目标容器中 可见组件的返回值。
      void removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void setAlignment​(int align)
      设置此布局的对齐方式。
      void setAlignOnBaseline​(boolean alignOnBaseline)
      组件是否应沿其基线垂直排列。
      void setHgap​(int hgap)
      设置组件之间以及组件之间的水平间隙和 Container的边框。
      void setVgap​(int vgap)
      设置组件之间以及组件与 Container的边框之间的垂直间距。
      String toString​()
      返回此 FlowLayout对象及其值的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • LEFT

        public static final int LEFT
        该值表示每一行的组件应为左对齐。
        另请参见：
        Constant Field Values

      • CENTER

        public static final int CENTER
        该值表示每行的组件应该居中。
        另请参见：
        Constant Field Values

      • RIGHT

        public static final int RIGHT
        该值表示组件的每一行都应该是右对齐的。
        另请参见：
        Constant Field Values

      • LEADING

        public static final int LEADING
        该值表示组件的每一行应该对齐到容器方向的前端，例如从左到右的方向向左。
        从以下版本开始：
        1.2
        另请参见：
        Component.getComponentOrientation() ， ComponentOrientation ， Constant Field Values

      • TRAILING

        public static final int TRAILING
        该值表示组件的每一行应该对齐到容器方向的后端，例如从左到右的方向向右。
        从以下版本开始：
        1.2
        另请参见：
        Component.getComponentOrientation() ， ComponentOrientation ， Constant Field Values

    • 构造方法详细信息

      • FlowLayout

        public FlowLayout​()
        构造一个新的 FlowLayout ，其中心对齐和默认的5单位水平和垂直间隙。

      • FlowLayout

        public FlowLayout​(int align)
        构造一个新的FlowLayout具有指定的对齐和默认的5单位水平和垂直间隙。 取向参数的值必须是一个FlowLayout.LEFT ， FlowLayout.RIGHT ， FlowLayout.CENTER ， FlowLayout.LEADING ，或FlowLayout.TRAILING 。
        参数
        align - 对齐值

      • FlowLayout

        public FlowLayout​(int align,
                  int hgap,
                  int vgap)
        创建一个新的流程布局管理器，具有指示的对齐方式和指示的水平和垂直间距。

        取向参数的值必须是一个FlowLayout.LEFT ， FlowLayout.RIGHT ， FlowLayout.CENTER ， FlowLayout.LEADING ，或FlowLayout.TRAILING 。

        参数
        align - 对齐值
        hgap - 组件之间和组件之间的水平间隙和 Container的边界
        vgap - 组件之间和组件之间的垂直间隙以及 Container的边框

    • 方法详细信息

      • getAlignment

        public int getAlignment​()
        获取此布局的对齐方式。 可能的值是FlowLayout.LEFT ， FlowLayout.RIGHT ， FlowLayout.CENTER ， FlowLayout.LEADING ，或FlowLayout.TRAILING 。
        结果
        此布局的对齐值
        从以下版本开始：
        1.1
        另请参见：
        setAlignment(int)

      • setAlignment

        public void setAlignment​(int align)
        设置此布局的对齐方式。 可能的值是
        • FlowLayout.LEFT
        • FlowLayout.RIGHT
        • FlowLayout.CENTER
        • FlowLayout.LEADING
        • FlowLayout.TRAILING
        参数
        align - 上面显示的对齐值之一
        从以下版本开始：
        1.1
        另请参见：
        getAlignment()

      • getHgap

        public int getHgap​()
        获取组件之间以及组件之间的水平间隙以及 Container的边框
        结果
        组件之间的水平间隙和组件之间的边界和 Container的边界
        从以下版本开始：
        1.1
        另请参见：
        setHgap(int)

      • setHgap

        public void setHgap​(int hgap)
        设置组件之间以及组件之间的水平间隙和 Container的边框。
        参数
        hgap - 组件之间和组件之间的水平间隙和 Container的边界
        从以下版本开始：
        1.1
        另请参见：
        getHgap()

      • getVgap

        public int getVgap​()
        获得组件之间以及组件之间的垂直间隙和 Container的边框。
        结果
        组件之间和组件之间的垂直间隙和边框 Container
        从以下版本开始：
        1.1
        另请参见：
        setVgap(int)

      • setVgap

        public void setVgap​(int vgap)
        设置组件之间以及组件与 Container的边框之间的垂直间距。
        参数
        vgap - 组件之间和组件之间的垂直间隙和边框 Container
        从以下版本开始：
        1.1
        另请参见：
        getVgap()

      • setAlignOnBaseline

        public void setAlignOnBaseline​(boolean alignOnBaseline)
        组件是否应沿其基线垂直排列。 没有基线的组件将居中。 默认值为false。
        参数
        alignOnBaseline是否应在其基线上垂直对齐
        从以下版本开始：
        1.6

      • getAlignOnBaseline

        public boolean getAlignOnBaseline​()
        如果组件沿其基线垂直对齐，则返回true。 默认值为false。
        结果
        如果组件沿其基线垂直对准，则为真
        从以下版本开始：
        1.6

      • addLayoutComponent

        public void addLayoutComponent​(String name,
                               Component comp)
        将指定的组件添加到布局。 本课不使用
        Specified by:
        addLayoutComponent在接口 LayoutManager
        参数
        name - 组件的名称
        comp - 要添加的组件

      • removeLayoutComponent

        public void removeLayoutComponent​(Component comp)
        从布局中删除指定的组件。 本课不使用
        Specified by:
        removeLayoutComponent在接口 LayoutManager
        参数
        comp - 要删除的组件
        另请参见：
        Container.removeAll()

      • preferredLayoutSize

        public Dimension preferredLayoutSize​(Container target)
        给定指定目标容器中 可见组件的返回值。
        Specified by:
        preferredLayoutSize在接口 LayoutManager
        参数
        target - 需要布置的容器
        结果
        布置指定容器的子组件的首选尺寸
        另请参见：
        Container ， minimumLayoutSize(java.awt.Container) ， Container.getPreferredSize()

      • minimumLayoutSize

        public Dimension minimumLayoutSize​(Container target)
        返回布局指定目标容器中包含的 可见组件所需的最小尺寸。
        Specified by:
        minimumLayoutSize在接口 LayoutManager
        参数
        target - 需要布置的容器
        结果
        布局指定容器的子组件的最小尺寸
        另请参见：
        preferredLayoutSize(java.awt.Container) ， Container ， Container.doLayout()

      • layoutContainer

        public void layoutContainer​(Container target)
        放出容器。 该方法通过重新整形目标容器中的组件，使每个可见组件采用其首选大小，以满足此FlowLayout对象的对齐。
        Specified by:
        layoutContainer在接口 LayoutManager
        参数
        target - 正在布置的指定组件
        另请参见：
        Container ， Container.doLayout()

      • toString

        public String toString​()
        返回此 FlowLayout对象及其值的字符串表示形式。
        重写：
        toString中的 Object
        结果
        此布局的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FocusTraversalPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class FocusTraversalPolicy

  • java.lang.Object
    • java.awt.FocusTraversalPolicy
  • 已知直接子类：
    ContainerOrderFocusTraversalPolicy ， InternalFrameFocusTraversalPolicy

    public abstract class FocusTraversalPolicy
extends Object
    FocusTraversalPolicy定义了遍历特定焦点循环根的组件的顺序。 实例可以将策略应用于任意焦点循环根，允许自己在容器之间共享。 当组件层次结构的焦点循环根源发生变化时，不需要重新初始化它们。

    FocusTraversalPolicy的核心职责是提供确定在UI中向前或向后遍历的下一个和以前的组件的算法。 每个FocusTraversalPolicy还必须提供用于确定遍历周期中的第一个，最后一个和默认组件的算法。 正常的向前和向后遍历分别使用第一个和最后一个组件。 当向下移动到新的聚焦遍历循环中时，默认组件是第一个接收焦点的组件。 FocusTraversalPolicy可以选择提供一种用于确定Window初始组件的算法。 初始组件是第一个在首次显示窗口时接收焦点的组件。

    FocusTraversalPolicy考虑到了focus traversal policy providers 。 当搜索第一个/最后一个/下一个/上一个组件时，如果遇到焦点遍历策略提供程序，则其焦点遍历策略用于执行搜索操作。

    请参阅How to Use the Focus Subsystem ， Java教程中的一节，以及有关更多信息的Focus Specification 。

    从以下版本开始：
    1.4
    另请参见：
    Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ，
Container.getFocusTraversalPolicy() ，
Container.setFocusCycleRoot(boolean) ，
Container.isFocusCycleRoot(java.awt.Container) ，
Container.setFocusTraversalPolicyProvider(boolean) ，
Container.isFocusTraversalPolicyProvider() ，
KeyboardFocusManager.setDefaultFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ，
KeyboardFocusManager.getDefaultFocusTraversalPolicy()

    • 构造方法摘要

      构造方法
      Constructor 描述
      FocusTraversalPolicy​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Component getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      abstract Component getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      abstract Component getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      abstract Component getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      Component getInitialComponent​(Window window)
      返回当窗口第一次可见时应接收焦点的组件。
      abstract Component getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FocusTraversalPolicy

        public FocusTraversalPolicy​()

    • 方法详细信息

      • getComponentAfter

        public abstract Component getComponentAfter​(Container aContainer,
                                            Component aComponent)
        返回在aComponent之后应该接收焦点的Component。 aContainer必须是aComponent或焦点遍历策略提供者的焦点循环根。
        参数
        aContainer - 组件或焦点遍历策略提供程序的焦点循环根
        aComponent - aContainer的一个（可能是间接的）子，或者一个 aComponent本身
        结果
        应该在aComponent之后接收焦点的组件，如果没有找到合适的组件，则为null
        异常
        IllegalArgumentException - 如果aContainer不是aComponent或焦点遍历策略提供程序的焦点循环根，或者aContainer或aComponent为null

      • getComponentBefore

        public abstract Component getComponentBefore​(Container aContainer,
                                             Component aComponent)
        返回应该在aComponent之前接收焦点的Component。 aContainer必须是aComponent或焦点遍历策略提供者的焦点循环根。
        参数
        aContainer - 组件或焦点遍历策略提供程序的焦点循环根
        aComponent - aContainer的一个（可能是间接的）子，或者一个 aComponent本身
        结果
        应该在aComponent之前收到焦点的组件，如果没有找到合适的组件，则为null
        异常
        IllegalArgumentException - 如果aContainer不是aComponent或焦点遍历策略提供程序的焦点循环根，或者aContainer或aComponent为null

      • getFirstComponent

        public abstract Component getFirstComponent​(Container aContainer)
        返回遍历周期中的第一个Component。 该方法用于确定当向前方向遍历包装时要聚焦的下一个组件。
        参数
        aContainer - 要返回其第一个组件的焦点循环根或焦点遍历策略提供程序
        结果
        aContainer遍历周期中的第一个组件，如果没有找到合适的组件，则返回null
        异常
        IllegalArgumentException - 如果aContainer为空

      • getLastComponent

        public abstract Component getLastComponent​(Container aContainer)
        返回遍历周期中的最后一个组件。 该方法用于确定当相反方向遍历包装时要聚焦的下一个组件。
        参数
        aContainer - 要返回其最后一个组件的焦点循环根或焦点遍历策略提供程序
        结果
        aContainer遍历周期中的最后一个组件，如果没有找到合适的组件，则返回null
        异常
        IllegalArgumentException - 如果aContainer为空

      • getDefaultComponent

        public abstract Component getDefaultComponent​(Container aContainer)
        返回要对焦的默认组件。 当向下移动到基于aContainer的新的焦点遍历循环时，该组件将成为第一个接收焦点的组件。
        参数
        aContainer - 要返回默认组件的焦点循环根或焦点遍历策略提供程序
        结果
        aContainer遍历周期中的默认组件，如果没有找到合适的组件，则返回null
        异常
        IllegalArgumentException - 如果aContainer为空

      • getInitialComponent

        public Component getInitialComponent​(Window window)
        返回当窗口第一次可见时应接收焦点的组件。 一旦通过调用show()或setVisible(true)可视窗口，初始组件将不再被使用。 相反，如果窗口丢失并随后重新获得焦点，或者使其成为隐形或不可显示，并随后使其可见和可显示，则Window最新关注的组件将成为焦点所有者。 此方法的默认实现返回默认组件。
        参数
        window - 要返回其初始组件的窗口
        结果
        当第一次显示窗口时应该接收焦点的组件，如果没有找到合适的组件，则为null
        异常
        IllegalArgumentException - 如果窗口为空
        另请参见：
        getDefaultComponent(java.awt.Container), Window.getMostRecentFocusOwner()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Font (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Font

  • java.lang.Object
    • java.awt.Font
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    FontUIResource

    public class Font
extends Object
implements Serializable
    Font类表示字体，用于以可见的方式呈现文本。 字体提供将字符序列映射到字形序列所需的信息，并在Graphics和Component对象上呈现字形序列。

    字符和字形

    字符是以抽象的方式表示诸如字母，数字或标点符号的项目的符号。 例如， 'g' ，LATIN SMALL LETTER G，是一个字符。

    字形是用于渲染字符或字符序列的形状。 在简单的书写系统中，比如拉丁文，通常一个字形代表一个字符。 然而，一般来说，字符和字形不具有一一对应关系。 例如，字符“¡”拉丁小写字母A与ACUTE，可以由两个字形表示：一个用于'一'，一个用于'Â'。 另一方面，双字符串“fi”可以由单个字形，“fi”连字符表示。 在复杂的写作系统中，如阿拉伯语，南亚和东南亚写作系统，字符和字形之间的关系可能更复杂，涉及字形的上下文相关选择以及字形重新排序。 字体封装渲染所选字符集所需的字形集合以及将字符序列映射到相应字符序列所需的表。

    物理和逻辑字体

    Java平台区分两种字体： 物理字体和逻辑字体。

    物理字体是包含使用TrueType或PostScript Type 1等字体技术从字符序列到字形序列映射的字形数据和表的实际字体库。Java Platform的所有实现必须支持TrueType字体; 对其他字体技术的支持依赖于实现。 物理字体可以使用诸如Helvetica，Palatino，HonMincho或任何数量的其他字体名称。 通常，每个物理字体仅支持有限的一套写入系统，例如只有拉丁字符，或仅支持日语和基本拉丁语。 可用物理字体的集合在配置之间不同。 需要特定字体的应用程序可以使用createFont方法进行捆绑并实例化。

    逻辑字体是由Java平台定义的五个字体系列，必须由任何Java运行时环境支持：Serif，SansSerif，Monospaced，Dialog和DialogInput。 这些逻辑字体不是实际的字体库。 而是通过Java运行时环境将逻辑字体名称映射到物理字体。 映射是实现，通常与区域设置相关，所以它们的外观和指标有所不同。 通常，每个逻辑字体名称映射到几个物理字体以覆盖大范围的字符。

    对等AWT组件，如Label和TextField ，只能使用逻辑字体。

    为相对的优点和使用物理或逻辑字体的缺点的讨论，请参阅Physical and Logical Fonts在The Java Tutorials文档。

    字体面和名称

    A Font可以有很多面孔，如重，中，斜，哥特和常规。 所有这些面孔都具有相似的印刷设计。

    有三种不同的名称可以从一个Font对象获得。 逻辑字体名称只是用于构造字体的名称。 字体名称或简称字体名称是特定字体的名称，如Helvetica Bold。 姓氏是字体系列的名称，用于确定多个面部的排版设计，如Helvetica。

    Font类表示来自主机系统的系统资源中存在的字体集合的字体的实例。 例如，Arial Bold和Courier Bold Italic是字体。 可以有几个与字体相关联的Font对象，每个对象的大小，样式，变换和字体功能都有所不同。

    由于平台限制（例如没有合适的平台字体来实现逻辑字体），字形可能并不总是被渲染为请求的属性（例如，字体和样式）。

    GraphicsEnvironment类的getAllFonts方法返回系统中可用的所有字体阵列。 这些字体面将返回为Font对象，大小为1，身份转换和默认字体特征。 然后，这些基本字体可以用于通过本类中的deriveFont方法来导出具有不同大小，样式，变换和字体功能的新的Font对象。

    Font和TextAttribute

    Font支持大多数TextAttribute s。 这使得一些操作（如渲染下划线的文本）变得方便，因为不需要明确构造一个TextLayout对象。 可以使用Map的TextAttribute值构造或导出属性来设置字体。

    一些TextAttributes的值不可序列化，因此尝试序列化具有此类值的Font的实例将不会将其序列化。 这意味着从这样一个流反序列化的字体将不会与包含不可序列化属性的原始字体相等。 这很少会引起问题，因为这些属性通常仅在特殊情况下使用，并且不太可能被序列化。

    • FOREGROUND和BACKGROUND使用Paint值。 子类Color是可序列化的，而GradientPaint和TexturePaint是。
    • CHAR_REPLACEMENT使用GraphicAttribute值。 子类ShapeGraphicAttribute和ImageGraphicAttribute不可序列化。
    • INPUT_METHOD_HIGHLIGHT使用InputMethodHighlight值，这是不可序列化的。 见InputMethodHighlight 。

    创建Paint和GraphicAttribute自定义子类的客户端可以使其可序列化，并避免此问题。 使用输入法亮点的客户端可以将它们转换为当前平台上该突出显示的平台特定属性，并将其设置为字体作为解决方法。

    基于Map的构造函数和deriveFont API忽略FONT属性，并且它不会被字体保留; 如果FONT属性可能存在，则应使用静态getFont(java.util.Map<? extends java.text.AttributedCharacterIterator.Attribute, ?>)方法。 有关详细信息，请参阅TextAttribute.FONT 。

    几个属性将导致额外的渲染开销和潜在的调用布局。 如果一个Font具有这样的属性，那么hasLayoutAttributes()方法将返回true。

    注意：字体旋转可以使文本基线旋转。 为了解决这种（罕见）可能性，指定字体API返回度量值并在“基线相对坐标”中获取参数。 这将“x”坐标映射到沿着基线的前进（正x沿着基线向前），“y”坐标到“x”处的基线垂直距离（正y为顺时针90度从基线矢量）。 这是特别重要的API被称为具有“基线相对坐标”。

    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BOLD
      大胆的风格常数。
      static int CENTER_BASELINE
      中文，日文，韩文等表意文字的基线。
      static String DIALOG
      逻辑字体“对话框”的规范系列名称的字符串常量。
      static String DIALOG_INPUT
      逻辑字体“DialogInput”的规范系列名称的字符串常量。
      static int HANGING_BASELINE
      Devanagari中使用的基线和类似的脚本。
      static int ITALIC
      斜体风格常数。
      static int LAYOUT_LEFT_TO_RIGHT
      一个用于布局GlyphVector的标志，指示由Bidi分析确定的文本是从左到右。
      static int LAYOUT_NO_LIMIT_CONTEXT
      一个用于layoutGlyphVector的标志，指示在指定的限制之后的char数组中的文本不应被检查。
      static int LAYOUT_NO_START_CONTEXT
      layoutGlyphVector的一个标志，指示在指定的开始之前的char数组中的文本不应被检查。
      static int LAYOUT_RIGHT_TO_LEFT
      一个标记为layoutGlyphVector的标志，指示由Bidi分析确定的文本是从右到左。
      static String MONOSPACED
      逻辑字体“Monospaced”的规范系列名称的字符串常量。
      protected String name
      这个 Font的逻辑名称，传递给构造函数。
      static int PLAIN
      平原风格常数。
      protected float pointSize
      该点大小 Font在 float 。
      static int ROMAN_BASELINE
      大多数罗马脚本在布局文本时使用的基线。
      static String SANS_SERIF
      逻辑字体“SansSerif”的规范系列名称的字符串常量。
      static String SERIF
      逻辑字体“Serif”的规范系列名称的字符串常量。
      protected int size
      该点的大小为 Font ，四舍五入为整数。
      protected int style
      这种 Font的样式，传递给构造函数。
      static int TRUETYPE_FONT
      识别TRUETYPE类型的字体资源。
      static int TYPE1_FONT
      识别类型TYPE1的字体资源。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Font​(Font font)
      创建一个新 Font从指定 font 。
        Font​(String name, int style, int size)
      从指定的名称，样式和点大小创建一个新的 Font 。
        Font​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      创建具有指定属性的新的 Font 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean canDisplay​(char c)
      检查这个 Font是否具有指定字符的字形。
      boolean canDisplay​(int codePoint)
      检查 Font是否具有指定字符的字形。
      int canDisplayUpTo​(char[] text, int start, int limit)
      指示此是否 Font可以显示在指定的字符 text在起始 start和在结束 limit 。
      int canDisplayUpTo​(String str)
      指示 Font是否可以显示指定的 String 。
      int canDisplayUpTo​(CharacterIterator iter, int start, int limit)
      指示 Font是否可以显示由 iter开始并以 start结尾的 limit指定的文本。
      static Font createFont​(int fontFormat, File fontFile)
      使用指定的字体类型和指定的字体文件返回一个新的 Font 。
      static Font createFont​(int fontFormat, InputStream fontStream)
      使用指定的字体类型和输入数据返回一个新的 Font 。
      static Font[] createFonts​(File fontFile)
      返回从指定文件解码的新数组 Font 。
      static Font[] createFonts​(InputStream fontStream)
      返回从指定的流解码的新数组 Font 。
      GlyphVector createGlyphVector​(FontRenderContext frc, char[] chars)
      创建GlyphVector通过映射字符字形的一对一的基础上在此的Unicode cmap Font 。
      GlyphVector createGlyphVector​(FontRenderContext frc, int[] glyphCodes)
      通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。
      GlyphVector createGlyphVector​(FontRenderContext frc, String str)
      通过在Font中的Unicode cmap将字符映射到字形，创建一个GlyphVector Font 。
      GlyphVector createGlyphVector​(FontRenderContext frc, CharacterIterator ci)
      通过在Font中基于Unicode cmap将指定的字符映射到字形，创建一个Font 。
      static Font decode​(String str)
      返回 Font ，该 str参数描述。
      Font deriveFont​(float size)
      通过复制当前的 Font对象并应用新的大小来创建一个新的 Font对象。
      Font deriveFont​(int style)
      通过复制当前的 Font对象并应用新的样式来创建一个新的 Font对象。
      Font deriveFont​(int style, float size)
      通过复制此 Font对象并应用新的样式和大小来创建新的 Font对象。
      Font deriveFont​(int style, AffineTransform trans)
      通过复制此 Font对象并应用新的样式和转换来创建新的 Font对象。
      Font deriveFont​(AffineTransform trans)
      通过复制当前的 Font对象并对其应用新的变换来创建新的 Font对象。
      Font deriveFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      通过复制当前的 Font对象并向其应用一组新的字体属性来创建新的 Font对象。
      boolean equals​(Object obj)
      将此 Font对象与指定的 Object 。
      Map<TextAttribute,?> getAttributes​()
      返回此 Font可用的字体属性的映射。
      AttributedCharacterIterator.Attribute[] getAvailableAttributes​()
      返回此 Font支持的所有属性的 Font 。
      byte getBaselineFor​(char c)
      返回适合显示此字符的基线。
      String getFamily​()
      返回该名称 Font 。
      String getFamily​(Locale l)
      返回此 Font本地化名称，用于指定的区域设置。
      static Font getFont​(String nm)
      从系统属性列表中返回一个 Font对象。
      static Font getFont​(String nm, Font font)
      从系统属性列表获取指定的 Font 。
      static Font getFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      返回一个适合属性的 Font 。
      String getFontName​()
      返回此 Font的字体名称。
      String getFontName​(Locale l)
      返回 Font的字体名称，该名称已针对指定的区域设置进行本地化。
      float getItalicAngle​()
      返回这个 Font的斜体角。
      LineMetrics getLineMetrics​(char[] chars, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的一个 LineMetrics对象。
      LineMetrics getLineMetrics​(String str, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的一个 LineMetrics对象。
      LineMetrics getLineMetrics​(String str, FontRenderContext frc)
      返回使用指定的String和FontRenderContext创建的一个LineMetrics对象。
      LineMetrics getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的一个 LineMetrics对象。
      Rectangle2D getMaxCharBounds​(FontRenderContext frc)
      返回具有指定的 FontRenderContext定义的最大边界的字符的边界。
      int getMissingGlyphCode​()
      返回当这个 Font没有指定unicode代码点的字形时使用的 Font 。
      String getName​()
      返回此 Font的逻辑名称。
      int getNumGlyphs​()
      返回此 Font的字形数。
      String getPSName​()
      返回此 Font的后记名称。
      int getSize​()
      返回此 Font的点大小，舍入为整数。
      float getSize2D​()
      返回此点大小 Font在 float值。
      Rectangle2D getStringBounds​(char[] chars, int beginIndex, int limit, FontRenderContext frc)
      返回指定的 FontRenderContext指定的字符数组的逻辑边界。
      Rectangle2D getStringBounds​(String str, int beginIndex, int limit, FontRenderContext frc)
      返回在指定的 String中指定的 FontRenderContext的逻辑边界。
      Rectangle2D getStringBounds​(String str, FontRenderContext frc)
      返回指定的 String中指定的 FontRenderContext的逻辑边界。
      Rectangle2D getStringBounds​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回指定索引的字符的逻辑边界CharacterIterator指定FontRenderContext 。
      int getStyle​()
      返回此 Font的样式。
      AffineTransform getTransform​()
      返回与此 Font相关联的转换的副本。
      int hashCode​()
      返回此 Font的哈希 Font 。
      boolean hasLayoutAttributes​()
      如果此字体包含需要额外布局处理的属性，则返回true。
      boolean hasUniformLineMetrics​()
      检查此 Font是否具有统一的线路度量。
      boolean isBold​()
      指示此 Font对象的样式是否为BOLD。
      boolean isItalic​()
      指示此 Font对象的样式是否为ITALIC。
      boolean isPlain​()
      指示此 Font对象的样式是否为PLAIN。
      boolean isTransformed​()
      指示此 Font对象是否具有影响其大小的变换以及Size属性。
      GlyphVector layoutGlyphVector​(FontRenderContext frc, char[] text, int start, int limit, int flags)
      返回一个新的 GlyphVector对象，如果可能，执行文本的全面布局。
      static boolean textRequiresLayout​(char[] chars, int start, int end)
      如果指定文本的任何部分来自复杂脚本，则实现将需要调用布局处理以便在使用 drawString(String,int,int)和其他文本呈现方法时正确呈现，则返回true。
      String toString​()
      将此 Font对象转换为 String表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DIALOG

        public static final String DIALOG
        逻辑字体“对话框”的规范系列名称的字符串常量。 它在字体构造中可用于提供编译时验证的名称。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • DIALOG_INPUT

        public static final String DIALOG_INPUT
        逻辑字体“DialogInput”的规范系列名称的字符串常量。 它在字体构造中可用于提供编译时验证的名称。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • SANS_SERIF

        public static final String SANS_SERIF
        逻辑字体“SansSerif”的规范系列名称的字符串常量。 它在字体构造中可用于提供编译时验证的名称。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • SERIF

        public static final String SERIF
        逻辑字体“Serif”的规范系列名称的字符串常量。 它在字体构造中可用于提供编译时验证的名称。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • MONOSPACED

        public static final String MONOSPACED
        逻辑字体“Monospaced”的规范系列名称的字符串常量。 它在字体构造中可用于提供编译时验证的名称。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • PLAIN

        public static final int PLAIN
        平原风格常数。
        另请参见：
        Constant Field Values

      • BOLD

        public static final int BOLD
        大胆的风格常数。 这可以与混合样式的其他样式常量（PLAIN除外）组合。
        另请参见：
        Constant Field Values

      • ITALIC

        public static final int ITALIC
        斜体风格常数。 这可以与混合样式的其他样式常量（PLAIN除外）组合。
        另请参见：
        Constant Field Values

      • ROMAN_BASELINE

        public static final int ROMAN_BASELINE
        大多数罗马脚本在布局文本时使用的基线。
        另请参见：
        Constant Field Values

      • CENTER_BASELINE

        public static final int CENTER_BASELINE
        中文，日文，韩文等表意文字的基线。
        另请参见：
        Constant Field Values

      • HANGING_BASELINE

        public static final int HANGING_BASELINE
        Devanagari中使用的基线和类似的脚本。
        另请参见：
        Constant Field Values

      • TRUETYPE_FONT

        public static final int TRUETYPE_FONT
        识别TRUETYPE类型的字体资源。 用于为createFont(int, java.io.InputStream)方法指定TrueType字体资源。 TrueType格式被扩展为OpenType格式，它增加了对Postscript轮廓的字体支持，因此这个标签引用了这些字体，以及使用TrueType轮廓的字体。
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • TYPE1_FONT

        public static final int TYPE1_FONT
        识别类型TYPE1的字体资源。 用于为createFont(int, java.io.InputStream)方法指定Type1字体资源。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • name

        protected String name
        这个 Font的逻辑名称，传递给构造函数。
        从以下版本开始：
        1.0
        另请参见：
        getName()

      • style

        protected int style
        这种Font的风格，传递给构造函数。 这种风格可以是PLAIN，BOLD，ITALIC或BOLD + ITALIC。
        从以下版本开始：
        1.0
        另请参见：
        getStyle()

      • size

        protected int size
        该点的大小为 Font ，舍入为整数。
        从以下版本开始：
        1.0
        另请参见：
        getSize()

      • pointSize

        protected float pointSize
        这个 Font的点大小在 float 。
        另请参见：
        getSize() ， getSize2D()

      • LAYOUT_LEFT_TO_RIGHT

        public static final int LAYOUT_LEFT_TO_RIGHT
        一个用于布局GlyphVector的标志，指示由Bidi分析确定的文本是从左到右。
        另请参见：
        Constant Field Values

      • LAYOUT_RIGHT_TO_LEFT

        public static final int LAYOUT_RIGHT_TO_LEFT
        一个标记为layoutGlyphVector的标志，指示由Bidi分析确定的文本是从右到左。
        另请参见：
        Constant Field Values

      • LAYOUT_NO_START_CONTEXT

        public static final int LAYOUT_NO_START_CONTEXT
        layoutGlyphVector的一个标志，指示在指定的开始之前的char数组中的文本不应被检查。
        另请参见：
        Constant Field Values

      • LAYOUT_NO_LIMIT_CONTEXT

        public static final int LAYOUT_NO_LIMIT_CONTEXT
        一个用于layoutGlyphVector的标志，指示在指定的限制之后的char数组中的文本不应被检查。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Font

        public Font​(String name,
            int style,
            int size)
        从指定的名称，样式和点大小创建新的Font 。

        字体名称可以是字体名称或字体族名称。 它与风格一起使用以找到适当的字体。 当指定字体系列名称时，样式参数用于选择家庭中最合适的脸部。 指定字体名称时，将合并脸部样式和样式参数，以找到同一系列中匹配最佳的字体。 例如，如果使用样式Font.ITALIC指定面部名称“Arial Bold”，则字体系统会在“Arial”系列中查找粗体和斜体的面部，并可将字体实例与物理字体“Arial Bold Italic”相关联。 。 样式参数与指定的脸部样式合并，不添加或减去。 这意味着，指定粗体和粗体样式不会使字体双倍膨胀，并且指定粗体和纯色样式不会减轻字体。

        如果没有找到所请求的样式的脸，字体系统可以应用算法样式来实现所需的样式。 例如，如果请求ITALIC ，但是没有斜体可用，来自平面的字形可能会被算术倾斜（倾斜）。

        使用美国地区的案例折叠规则，字体名称查找不区分大小写。

        如果name参数表示逻辑字体以外的东西，即被解释为物理字体或家庭，并且这不能被实现映射到物理字体或兼容替代品，则字体系统将映射到Font实例“对话”，例如， getFamily报道的家庭将是“对话框”。

        参数
        name - 字体名称。 这可以是字体名称或字体系列名称，并且可以表示在这个GraphicsEnvironment找到的逻辑字体或物理字体。 逻辑字体的系列名称为：Dialog，DialogInput，Monospaced，Serif或SansSerif。 所有这些名称都存在预定义的字符串常量，例如DIALOG 。 如果name为null ，则由getName()返回的新的Font的逻辑字体名称设置为“Default”。
        style -为对风格恒定Font风格参数是一个整数位掩码可以是PLAIN ，或按位联盟BOLD和/或ITALIC （例如ITALIC或BOLD|ITALIC ）。 如果style参数不符合预期的整数位掩码之一，则样式将设置为PLAIN 。
        size - 点大小为 Font
        从以下版本开始：
        1.0
        另请参见：
        GraphicsEnvironment.getAllFonts() ， GraphicsEnvironment.getAvailableFontFamilyNames()

      • Font

        public Font​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
        创建具有指定属性的新的Font 。 仅识别TextAttribute中定义的键。 此外，此构造函数不会识别FONT属性（请参阅getAvailableAttributes() ）。 只有具有有效类型值的属性才会影响新的Font 。

        如果attributes为null ， Font使用默认值初始化新的Font 。

        参数
        attributes - 要分配给新的 Font或 null
        另请参见：
        TextAttribute

      • Font

        protected Font​(Font font)
        创建一个新Font从指定font 。 这个构造函数是由子类使用的。
        参数
        font - 从中创建此 Font 。
        异常
        NullPointerException - 如果 font为空
        从以下版本开始：
        1.6

    • 方法详细信息

      • textRequiresLayout

        public static boolean textRequiresLayout​(char[] chars,
                                         int start,
                                         int end)
        如果指定文本的任何部分来自复杂脚本，则实现将需要调用布局处理，以便在使用drawString(String,int,int)和其他文本呈现方法时正确呈现，则返回true。 文本的测量可能类似地需要相同的额外处理。 提供start和end索引，使得应用程序可以仅请求考虑文本的一部分。 检查的最后一个char索引为"end-1" ，即检查整个数组的请求将是
          Font.textRequiresLayout(chars, 0, chars.length);
        应用程序可能会发现此信息对性能敏感代码有帮助。

        请注意，即使此方法返回false ，当与其中hasLayoutAttributes()返回true任何Font一起使用时，布局处理仍可能被调用，因此需要查询特定字体的方法，以获得这样的字体的答案属性。

        参数
        chars - 文字。
        start - 要检查的第一个字符的索引。
        end - 结束索引，独占。
        结果
        true如果指定的文本需要特殊布局。
        异常
        NullPointerException - 如果 chars为空。
        ArrayIndexOutOfBoundsException - 如果 start为负数或 end大于 chars数组的长度。
        从以下版本开始：
        9

      • getFont

        public static Font getFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
        返回一个适合属性的Font 。 如果attributes包含一个FONT属性，其中有一个有效的Font作为其值，它将与任何剩余的属性合并。 有关详细信息，请参阅TextAttribute.FONT 。
        参数
        attributes - 要分配给新的属性 Font
        结果
        用指定的属性创建一个新的 Font
        异常
        NullPointerException - 如果 attributes为空。
        从以下版本开始：
        1.2
        另请参见：
        TextAttribute

      • createFonts

        public static Font[] createFonts​(InputStream fontStream)
                          throws FontFormatException,
                                 IOException
        返回从指定的流解码的新数组Font 。 返回的Font[]将至少有一个元素。

        createFont(int, InputStream)方法中此变体的明确目的是支持表示TrueType / OpenType字体集合的字体源，并能够返回该集合中的所有单个字体。 因此，如果数据源不包含至少一个TrueType / OpenType字体，则此方法将抛出FontFormatException 。 如果集合中的任何字体不包含所需的字体表，同样的异常也将被抛出。

        条件“至少一个”允许流表示单个OpenType / TrueType字体。 也就是说，它不一定是一个集合。 每个Font返回的数组的元素与1和风格的点大小创建PLAIN 。 然后可以使用此基本字体与deriveFont中的deriveFont方法一起导出具有不同大小，样式，变换和字体功能的新的Font对象。

        此方法不关闭InputStream 。

        为了使每个Font提供给字体构造函数必须在注册GraphicsEnvironment致电registerFont(Font) 。

        参数
        fontStream - 表示字体或字体集合的输入数据的 InputStream对象。
        结果
        一个新的 Font[] 。
        异常
        FontFormatException - 如果 fontStream数据不包含集合的任何元素所需的字体表，或者根本不包含任何字体。
        IOException - 如果 fontStream无法完全阅读。
        从以下版本开始：
        9
        另请参见：
        GraphicsEnvironment.registerFont(Font)

      • createFonts

        public static Font[] createFonts​(File fontFile)
                          throws FontFormatException,
                                 IOException
        返回从指定文件解码的新数组Font 。 返回的Font[]将至少有一个元素。

        createFont(int, File)方法中此变体的明确目的是支持表示TrueType / OpenType字体集合的字体源，并能够返回该集合中的所有单个字体。 因此，如果数据源不包含至少一个TrueType / OpenType字体，则此方法将抛出FontFormatException 。 如果集合中的任何字体不包含所需的字体表，同样的异常也将被抛出。

        条件“至少一个”允许流表示单个OpenType / TrueType字体。 也就是说，它不一定是一个集合。 返回数组的每个Font元素的创建点的大小为1，样式为PLAIN 。 然后可以使用此基本字体与deriveFont中的deriveFont方法一起导出具有不同大小，样式，变换和字体功能的新的Font对象。

        为了使每个Font提供给字体构造函数必须在注册GraphicsEnvironment致电registerFont(Font) 。

        参数
        fontFile - 一个 File对象，其中包含字体或字体集合的输入数据。
        结果
        一个新的 Font[] 。
        异常
        FontFormatException - 如果 File不包含集合的任何元素所需的字体表，或者根本不包含任何字体。
        IOException - 如果 fontFile无法读取。
        从以下版本开始：
        9
        另请参见：
        GraphicsEnvironment.registerFont(Font)

      • createFont

        public static Font createFont​(int fontFormat,
                              InputStream fontStream)
                       throws FontFormatException,
                              IOException
        使用指定的字体类型和输入数据返回新的Font 。 新的Font创建的点大小为1，样式为PLAIN 。 然后可以使用此基本字体与deriveFont中的deriveFont方法一起导出具有不同大小，样式，变换和字体功能的新的Font对象。 此方法不关闭InputStream 。

        要使Font可用于Font构造函数，返回的Font必须通过调用registerFont(Font)在GraphicsEnvironment进行注册。

        参数
        fontFormat -该类型Font ，这是TRUETYPE_FONT如果指定一个TrueType资源。 或者如果指定了类型1资源，则为TYPE1_FONT 。
        fontStream - 表示字体输入数据的 InputStream对象。
        结果
        用指定的字体类型创建一个新的 Font 。
        异常
        IllegalArgumentException - 如果 fontFormat不是 TRUETYPE_FONT或 TYPE1_FONT 。
        FontFormatException - 如果 fontStream数据不包含指定格式所需的字体表。
        IOException - 如果 fontStream无法完全阅读。
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.registerFont(Font)

      • createFont

        public static Font createFont​(int fontFormat,
                              File fontFile)
                       throws FontFormatException,
                              IOException
        使用指定的字体类型和指定的字体文件返回一个新的Font 。 新的Font创建的点大小为1，样式为PLAIN 。 此基础字体可以与deriveFont中的deriveFont方法一起使用，以导出具有不同大小，样式，变换和字体功能的新的Font对象。
        参数
        fontFormat -该类型Font ，这是TRUETYPE_FONT如果指定或者一个TrueType资源TYPE1_FONT ，如果指定了一个类型1资源。 只要引用返回的字体或其派生字体，实现可能会继续访问fontFile以检索字体数据。 因此，如果文件被更改或变得不可访问，结果是未定义的。

        为了使Font提供给字体构造函数返回Font必须在注册GraphicsEnvironment致电registerFont(Font) 。

        fontFile - 表示字体输入数据的 File对象。
        结果
        一个新的 Font创建与指定的字体类型。
        异常
        IllegalArgumentException - 如果 fontFormat不是 TRUETYPE_FONT或 TYPE1_FONT 。
        NullPointerException - 如果 fontFile为null。
        IOException - 如果 fontFile无法读取。
        FontFormatException - 如果 fontFile不包含指定格式所需的字体表。
        SecurityException - 如果执行代码没有从文件读取的权限。
        从以下版本开始：
        1.5
        另请参见：
        GraphicsEnvironment.registerFont(Font)

      • getTransform

        public AffineTransform getTransform​()
        返回与此Font相关联的转换的副本。 此变换不一定是用于构建字体的变换。 如果字体具有算法上标或宽度调整，则将其并入返回的AffineTransform 。

        通常，字体不会被转换。 客户一般应该首先调用isTransformed() ，如果isTransformed返回true，则只调用此方法。

        结果
        一个AffineTransform对象表示此的变换属性Font对象。

      • getFamily

        public String getFamily​()
        返回此Font的系列名称。

        字体的姓氏是字体特定的。 Helvetica Italic和Helvetica Bold等两种字体的姓氏Helvetica ，而他们的字体名字分别是Helvetica Bold和Helvetica Italic 。 可以使用GraphicsEnvironment.getAvailableFontFamilyNames()方法获得可用姓氏列表。

        使用getName获取字体的逻辑名称。 使用getFontName获取字体的字体名称。

        结果
        一个 String是这个 Font的家族名字。
        从以下版本开始：
        1.1
        另请参见：
        getName() ， getFontName()

      • getFamily

        public String getFamily​(Locale l)
        返回此Font的家族名称，针对指定的区域设置进行本地化。

        字体的姓氏是字体特定的。 Helvetica Italic和Helvetica Bold等两种字体的姓氏Helvetica ，而他们的字体名字分别是Helvetica Bold和Helvetica Italic 。 可以通过使用GraphicsEnvironment.getAvailableFontFamilyNames()方法获得可用姓氏列表。

        使用getFontName获取字体的字体名称。

        参数
        l - 要获取姓氏的地区
        结果
        一个 String表示字体的家族名称，本地化为指定的区域设置。
        从以下版本开始：
        1.2
        另请参见：
        getFontName() ， Locale

      • getPSName

        public String getPSName​()
        返回此Font的后记名称。 使用getFamily获取字体的姓氏。 使用getFontName获取字体的字体名称。
        结果
        一个 String代表这个 Font的后记名称。
        从以下版本开始：
        1.2

      • getName

        public String getName​()
        返回此Font的逻辑名称。 使用getFamily获取字体的姓氏。 使用getFontName获取字体的字体名称。
        结果
        一个 String代表这个 Font的逻辑名称。
        从以下版本开始：
        1.0
        另请参见：
        getFamily() ， getFontName()

      • getFontName

        public String getFontName​()
        返回此Font的字体名称。 例如，Helvetica Bold可以作为字体脸名返回。 使用getFamily获取字体的姓氏。 使用getName获取字体的逻辑名称。
        结果
        一个 String代表这个 Font的字体脸名。
        从以下版本开始：
        1.2
        另请参见：
        getFamily() ， getName()

      • getFontName

        public String getFontName​(Locale l)
        返回Font的字体面部名称，该名称已针对指定的区域设置进行了本地化。 例如，Helvetica Fett可以作为字体名称返回。 使用getFamily获取字体的姓氏。
        参数
        l - 要获取字体面部名称的区域设置
        结果
        一个 String表示为指定的区域设置本地化的字体面部名称。
        另请参见：
        getFamily() ， Locale

      • getStyle

        public int getStyle​()
        返回此Font的样式。 风格可以是PLAIN，BOLD，ITALIC或BOLD + ITALIC。
        结果
        这样的风格 Font
        从以下版本开始：
        1.0
        另请参见：
        isPlain() ，
isBold() ，
isItalic()

      • getSize

        public int getSize​()
        返回此Font的点大小，舍入为整数。 大多数用户都熟悉使用点大小来指定字体中字形的大小的想法。 该点大小定义了在单个间隔文本文档中的一行与下一行的基线之间的基线之间的度量。 点大小基于大约1/72英寸的印刷点 。

        Java（tm）2D API采用惯例，即一点相当于用户坐标中的一个单位。 当使用归一化变换将用户空间坐标转换为设备空间坐标时，72个用户空间单元在设备空间中等于1英寸。 在这种情况下，一点是1/72英寸。

        结果
        这个 Font的点尺寸在1/72英寸单位。
        从以下版本开始：
        1.0
        另请参见：
        getSize2D() ，
GraphicsConfiguration.getDefaultTransform() ，
GraphicsConfiguration.getNormalizingTransform()

      • getSize2D

        public float getSize2D​()
        返回 Font中 float的点大小。
        结果
        该点的大小为 Font作为 float值。
        从以下版本开始：
        1.2
        另请参见：
        getSize()

      • isPlain

        public boolean isPlain​()
        指示此 Font对象的样式是否为PLAIN。
        结果
        true如果这个Font有一个PLAIN样式; 否则为false 。
        从以下版本开始：
        1.0
        另请参见：
        getStyle()

      • isBold

        public boolean isBold​()
        指示此 Font对象的样式是否为BOLD。
        结果
        true如果这个Font对象的样式是BOLD; false否则。
        从以下版本开始：
        1.0
        另请参见：
        getStyle()

      • isItalic

        public boolean isItalic​()
        指示此是否 Font对象的样式为ITALIC。
        结果
        true如果这个Font对象的样式是ITALIC; 否则为false 。
        从以下版本开始：
        1.0
        另请参见：
        getStyle()

      • isTransformed

        public boolean isTransformed​()
        指示此 Font对象是否具有影响其大小的变换以及Size属性。
        结果
        true如果此Font对象具有非身份的AffineTransform属性。 否则为false 。
        从以下版本开始：
        1.4
        另请参见：
        getTransform()

      • hasLayoutAttributes

        public boolean hasLayoutAttributes​()
        如果此字体包含需要额外布局处理的属性，则返回true。
        结果
        如果字体具有布局属性，则为true
        从以下版本开始：
        1.6

      • getFont

        public static Font getFont​(String nm)
        从系统属性列表中返回一个Font对象。 nm被视为要获取的系统属性的名称。 所述String该属性的值然后解释为Font根据所述规范对象Font.decode(String)如果没有找到指定的属性，或执行代码没有权限读取属性，空值代替返回。
        参数
        nm - 属性名称
        结果
        一个属性名称描述的 Font对象，如果不存在此属性，则为null。
        异常
        NullPointerException - 如果nm为空。
        从以下版本开始：
        1.2
        另请参见：
        decode(String)

      • decode

        public static Font decode​(String str)
        返回Font ，该str参数描述。 要确保此方法返回所需的字体，请以这些方式之一格式化str参数
        • 字体名-风格的pointsize
        • 字体名-的pointsize
        • 字体名风格
        • 字体名
        • fontname风格指向
        • fontname指向
        • fontname样式
        • 字体名
        在哪种风格四个不区分大小写的字符串之一： "PLAIN" ， "BOLD" ， "BOLDITALIC" ，或"ITALIC" ，和是的pointsize点大小的正十进制整数表示。 例如，如果您想要一个字体为Arial，粗体，点大小为18，则可以使用以下方法调用此方法：“Arial-BOLD-18”。 这相当于调用Font构造函数： new Font("Arial", Font.BOLD, 18);并且这些值被解释为由该构造函数指定。

        始终将有效的尾部十进制字段解释为pointsize。 因此，只能在fontname only表单中使用包含尾随十进制值的字体。

        如果样式名称字段不是有效的样式字符串之一，则将其解释为字体名称的一部分，并使用默认样式。

        可以使用“或” - “中的一个来分隔输入中的字段。 标识的分隔符是最接近字符串末尾的分隔符，该分隔符将有效的pointsize或有效的样式名称与该字符串的其余部分分开。 空（空）指针和样式字段被视为具有该字段的默认值的有效字段。

        某些字体名称可能包含分隔符“'或” - “。 如果str不与3组的部件，例如形成为使得style或pointsize字段不存在于str ，和fontname还包含一个字符确定为分隔符然后在那里它们表现为旨在是一部分这些字符fontname也可以是解释为分隔符，因此字体名称可能无法正确识别。

        默认大小为12，默认样式为PLAIN。 如果str未指定有效大小，则返回的Font的大小为12.如果str未指定有效样式，则返回的Font具有PLAIN样式。 如果在str参数中未指定有效的字体名称，则此方法将返回一个名称为“Dialog”的字体。 要确定系统中可用的字体族名称，请使用GraphicsEnvironment.getAvailableFontFamilyNames()方法。 如果str是null ，则返回一个新的Font ，其名称为“Dialog”，大小为12，PLAIN样式。

        参数
        str - 字体的名称，或 null
        结果
        该 Font对象 str描述，或一个新的默认 Font如果 str为 null 。
        从以下版本开始：
        1.1
        另请参见：
        getFamily()

      • getFont

        public static Font getFont​(String nm,
                           Font font)
        从系统属性列表中获取指定的Font 。 正如在getProperty的方法System ，第一个参数被视为要获得的系统属性的名称。 此属性的String值被解释为Font对象。

        属性值应为Font.decode(String)接受的Font.decode(String)如果没有找到指定的属性，或执行代码没有读取属性的权限，则返回font参数。

        参数
        nm - 不区分大小写的属性名称
        font - 如果属性 nm Font ，则返回默认值 Font
        结果
        该 Font价值为 Font 。
        异常
        NullPointerException - 如果nm为空。
        另请参见：
        decode(String)

      • hashCode

        public int hashCode​()
        返回此 Font的哈希 Font 。
        重写：
        hashCode在类 Object
        结果
        这个 Font的哈希码值。
        从以下版本开始：
        1.0
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此 Font对象与指定的 Object 。
        重写：
        equals在 Object
        参数
        obj - Object进行比较
        结果
        true如果对象是相同的，或者参数是一个Font对象描述与该对象相同的字体; 否则为false 。
        从以下版本开始：
        1.0
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        将此 Font对象转换为 String表示。
        重写：
        toString在 Object
        结果
        这个 Font对象的 String表示。
        从以下版本开始：
        1.0

      • getNumGlyphs

        public int getNumGlyphs​()
        返回此Font的字形数。 字形码为Font范围从0到getNumGlyphs() - 1。
        结果
        这个字形数在这 Font 。
        从以下版本开始：
        1.2

      • getMissingGlyphCode

        public int getMissingGlyphCode​()
        返回当这个 Font没有指定unicode代码点的字形时使用的 Font 。
        结果
        该字形码为 Font 。
        从以下版本开始：
        1.2

      • getBaselineFor

        public byte getBaselineFor​(char c)
        返回适合显示此字符的基线。

        大字体可以支持不同的书写系统，每个系统可以使用不同的基准。 字符参数确定要使用的写入系统。 客户不应假定所有角色使用相同的基线。

        参数
        c - 用于识别书写系统的字符
        结果
        基线适合指定字符。
        从以下版本开始：
        1.2
        另请参见：
        LineMetrics.getBaselineOffsets() ， ROMAN_BASELINE ， CENTER_BASELINE ， HANGING_BASELINE

      • getAttributes

        public Map<TextAttribute,?> getAttributes​()
        返回此Font可用的字体属性的映射。 属性包括诸如连字和字形替换等。
        结果
        这个 Font的属性图。

      • getAvailableAttributes

        public AttributedCharacterIterator.Attribute[] getAvailableAttributes​()
        返回此Font支持的所有属性的Font 。 这些属性可用于派生其他字体。
        结果
        一个包含 Font支持的所有属性的键的数组。
        从以下版本开始：
        1.2

      • deriveFont

        public Font deriveFont​(int style,
                       float size)
        通过复制此 Font对象并应用新的样式和大小来创建新的 Font对象。
        参数
        style - 新的风格 Font
        size - 新的尺寸 Font
        结果
        一个新的 Font对象。
        从以下版本开始：
        1.2

      • deriveFont

        public Font deriveFont​(int style,
                       AffineTransform trans)
        通过复制此 Font对象并应用新的样式和变换来创建新的 Font对象。
        参数
        style - 新款 Font
        trans - 与新的 AffineTransform相关联的 Font
        结果
        一个新的 Font对象。
        异常
        IllegalArgumentException - 如果 trans是 null
        从以下版本开始：
        1.2

      • deriveFont

        public Font deriveFont​(float size)
        通过复制当前的 Font对象并向其应用新的大小来创建一个新的 Font对象。
        参数
        size - 新的 Font的大小。
        结果
        一个新的 Font对象。
        从以下版本开始：
        1.2

      • deriveFont

        public Font deriveFont​(AffineTransform trans)
        通过复制当前的 Font对象并应用一个新的变换来创建一个新的 Font对象。
        参数
        trans - 与新的 AffineTransform相关联的 Font
        结果
        一个新的 Font对象。
        异常
        IllegalArgumentException - 如果 trans是 null
        从以下版本开始：
        1.2

      • deriveFont

        public Font deriveFont​(int style)
        通过复制当前的 Font对象并应用新的样式来创建一个新的 Font对象。
        参数
        style - 新的样式 Font
        结果
        一个新的 Font对象。
        从以下版本开始：
        1.2

      • deriveFont

        public Font deriveFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
        通过复制当前的 Font对象并向其应用一组新的字体属性来创建新的 Font对象。
        参数
        attributes - 为新的 Font启用的属性 Font
        结果
        一个新的 Font对象。
        从以下版本开始：
        1.2

      • canDisplay

        public boolean canDisplay​(char c)
        检查这个Font是否具有指定字符的字形。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用canDisplay(int)或canDisplayUpTo方法。

        参数
        c - 需要字形的字符
        结果
        true如果这个Font有这个字符的字形; 否则为false 。
        从以下版本开始：
        1.2

      • canDisplay

        public boolean canDisplay​(int codePoint)
        检查 Font是否具有指定字符的字形。
        参数
        codePoint - 需要字形的字符（Unicode代码点）。
        结果
        true如果这个Font有字符的字形; 否则为false 。
        异常
        IllegalArgumentException - 如果代码点不是有效的Unicode代码点。
        从以下版本开始：
        1.5
        另请参见：
        Character.isValidCodePoint(int)

      • canDisplayUpTo

        public int canDisplayUpTo​(String str)
        指示Font是否可以显示指定的String 。 对于具有Unicode编码的字符串，重要的是要知道特定字体是否可以显示字符串。 该方法返回一个偏移量， String str这是Font无法显示的第一个字符，而不使用缺少的字形代码。 如果Font可以显示所有字符，则返回-1。
        参数
        str - 一个 String对象
        结果
        的偏移量str指向的第一个字符str这Font不能显示; 或-1如果这Font可以显示所有字符在str 。
        从以下版本开始：
        1.2

      • canDisplayUpTo

        public int canDisplayUpTo​(char[] text,
                          int start,
                          int limit)
        指示此是否Font可以显示在指定的字符text在起始start和在结束limit 。 这个方法是一个方便的超载。
        参数
        text - 指定的 char数组的数组
        start - 指定的起始偏移量（在 char s）到指定的 char值的数组
        limit - 指定的结束偏移量（在 char s中）到指定的数组中的 char值
        结果
        的偏移量text指向的第一个字符text这Font不能显示; 或-1如果这Font可以显示所有字符在text 。
        从以下版本开始：
        1.2

      • canDisplayUpTo

        public int canDisplayUpTo​(CharacterIterator iter,
                          int start,
                          int limit)
        指示 Font是否可以显示由 iter开始并以 start结尾的 limit指定的文本。
        参数
        iter - 一个CharacterIterator对象
        start - 指定的起始偏移量指定为 CharacterIterator 。
        limit - 指定的结束偏移量到指定的 CharacterIterator 。
        结果
        的偏移量iter指向的第一个字符iter这Font不能显示; 或者-1如果Font可以显示所有字符iter 。
        从以下版本开始：
        1.2

      • getItalicAngle

        public float getItalicAngle​()
        返回这个Font的斜体角。 斜体角度是最符合这个Font姿势的插入符号的斜率。
        结果
        这个 Font风格的角度是 Font 。
        另请参见：
        TextAttribute.POSTURE

      • hasUniformLineMetrics

        public boolean hasUniformLineMetrics​()
        检查此Font是否具有统一的线路度量。 逻辑Font可能是复合字体，这意味着它由不同的物理字体组成以覆盖不同的代码范围。 这些字体中的每一种可能具有不同的LineMetrics 。 如果逻辑Font是单一字体，则度量将是统一的。
        结果
        true如果这Font有统一的线度量; 否则为false 。

      • getLineMetrics

        public LineMetrics getLineMetrics​(String str,
                                  FontRenderContext frc)
        返回使用指定的String和FontRenderContext创建的LineMetrics对象。
        参数
        str - 指定的 String
        frc - 指定的 FontRenderContext
        结果
        使用指定的String和FontRenderContext创建的一个LineMetrics对象。

      • getLineMetrics

        public LineMetrics getLineMetrics​(String str,
                                  int beginIndex,
                                  int limit,
                                  FontRenderContext frc)
        返回使用指定参数创建的一个 LineMetrics对象。
        参数
        str - 指定的 String
        beginIndex - 初始偏移量为 str
        limit - 最终偏移量为 str
        frc - 指定的 FontRenderContext
        结果
        使用指定的参数创建的一个 LineMetrics对象。

      • getLineMetrics

        public LineMetrics getLineMetrics​(char[] chars,
                                  int beginIndex,
                                  int limit,
                                  FontRenderContext frc)
        返回使用指定参数创建的一个 LineMetrics对象。
        参数
        chars - 一个字符数组
        beginIndex - 初始偏移量为 chars
        limit - 结束偏移量为 chars
        frc - 指定的 FontRenderContext
        结果
        使用指定的参数创建的一个 LineMetrics对象。

      • getLineMetrics

        public LineMetrics getLineMetrics​(CharacterIterator ci,
                                  int beginIndex,
                                  int limit,
                                  FontRenderContext frc)
        返回使用指定参数创建的一个 LineMetrics对象。
        参数
        ci - 指定的 CharacterIterator
        beginIndex -初始偏移 ci
        limit -的端部偏移量 ci
        frc - 指定的 FontRenderContext
        结果
        使用指定的参数创建的一个 LineMetrics对象。

      • getStringBounds

        public Rectangle2D getStringBounds​(String str,
                                   FontRenderContext frc)
        返回指定的String中指定的FontRenderContext的逻辑边界。 逻辑边界包含起点，上升，前进和高度，其中包括前导。 逻辑边界并不总是包含所有文本。 例如，在某些语言和某些字体中，重音标记可以位于上升或下降之上。 要得到可视的边界框，它包围了所有文本，使用getBounds的方法TextLayout 。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        str - 指定的 String
        frc - 指定的 FontRenderContext
        结果
        一个Rectangle2D是指定的String中指定的FontRenderContext 。
        从以下版本开始：
        1.2
        另请参见：
        FontRenderContext ， createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

      • getStringBounds

        public Rectangle2D getStringBounds​(String str,
                                   int beginIndex,
                                   int limit,
                                   FontRenderContext frc)
        返回指定的String中指定的FontRenderContext的逻辑边界。 逻辑边界包含起点，上升，前进和高度，其中包括前导。 逻辑边界并不总是包含所有文本。 例如，在某些语言和某些字体中，重音标记可以位于上升或下降之上。 要得到可视的边界框，它包围了所有文本，使用getBounds的方法TextLayout 。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        str - 指定的 String
        beginIndex - 初始偏移量为 str
        limit - 最终的偏移量为 str
        frc - 指定的 FontRenderContext
        结果
        一个 Rectangle2D这是指定的 String ，在指定的 FontRenderContext 。
        异常
        IndexOutOfBoundsException -如果 beginIndex小于零，或 limit比的长度大 str ，或 beginIndex大于 limit 。
        从以下版本开始：
        1.2
        另请参见：
        FontRenderContext ， createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

      • getStringBounds

        public Rectangle2D getStringBounds​(char[] chars,
                                   int beginIndex,
                                   int limit,
                                   FontRenderContext frc)
        返回指定的FontRenderContext中指定字符数组的逻辑边界。 逻辑边界包含起点，上升，前进和高度，其中包括前导。 逻辑边界并不总是包含所有文本。 例如，在某些语言和某些字体中，重音标记可以位于上升或下降之上。 要得到可视的边界框，它包围了所有文本，使用getBounds的方法TextLayout 。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        chars - 一个字符数组
        beginIndex - 字符数组中的初始偏移量
        limit - 字符数组中的结束偏移量
        frc - 指定的 FontRenderContext
        结果
        一个 Rectangle2D是指定的 FontRenderContext指定的字符数组的边界框。
        异常
        IndexOutOfBoundsException -如果 beginIndex小于零，或 limit比的长度大 chars ，或 beginIndex大于 limit 。
        从以下版本开始：
        1.2
        另请参见：
        FontRenderContext ， createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

      • getStringBounds

        public Rectangle2D getStringBounds​(CharacterIterator ci,
                                   int beginIndex,
                                   int limit,
                                   FontRenderContext frc)
        返回指定索引的字符的逻辑边界CharacterIterator指定FontRenderContext 。 逻辑边界包含起点，上升，前进和高度，其中包括前导。 逻辑边界并不总是包含所有文本。 例如，在某些语言和某些字体中，重音标记可以位于上升或下降之上。 要得到可视的边界框，它包围了所有文本，使用getBounds的方法TextLayout 。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        ci - 指定的 CharacterIterator
        beginIndex -初始偏移 ci
        limit - 最终的偏移量在 ci
        frc - 指定的 FontRenderContext
        结果
        一个 Rectangle2D即在指定的索引的字符的边界框 CharacterIterator在指定 FontRenderContext 。
        异常
        IndexOutOfBoundsException - 如果 beginIndex小于起始指数 ci ，或 limit大于最终指数 ci ，或 beginIndex大于 limit
        从以下版本开始：
        1.2
        另请参见：
        FontRenderContext ， createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

      • getMaxCharBounds

        public Rectangle2D getMaxCharBounds​(FontRenderContext frc)
        返回具有指定的FontRenderContext定义的最大边界的字符的边界。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        frc - 指定的 FontRenderContext
        结果
        一个 Rectangle2D是具有最大边界的字符的边框。

      • createGlyphVector

        public GlyphVector createGlyphVector​(FontRenderContext frc,
                                     String str)
        通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。 除了将字形映射到字符之外，此方法还没有其他处理。 这意味着这种方法对于需要重新排序，整形或连字替换的一些脚本（如阿拉伯语，希伯来语，泰语和印度语）是无用的。
        参数
        frc - 指定的 FontRenderContext
        str - 指定的 String
        结果
        一个新的 GlyphVector创建与指定的 String和指定的 FontRenderContext 。

      • createGlyphVector

        public GlyphVector createGlyphVector​(FontRenderContext frc,
                                     char[] chars)
        创建GlyphVector通过映射字符字形的一对一的基础上在此的Unicode cmap Font 。 除了将字形映射到字符之外，此方法还没有其他处理。 这意味着这种方法对于需要重新排序，整形或连字替换的一些脚本（如阿拉伯语，希伯来语，泰语和印度语）是无用的。
        参数
        frc - 指定的 FontRenderContext
        chars - 指定的字符数组
        结果
        新 GlyphVector与指定的字符数组和指定创建 FontRenderContext 。

      • createGlyphVector

        public GlyphVector createGlyphVector​(FontRenderContext frc,
                                     CharacterIterator ci)
        通过将Font中的Unicode cmap基于指定的字符映射到字形一对一来创建一个Font 。 除了将字形映射到字符之外，此方法还没有其他处理。 这意味着这种方法对于需要重新排序，整形或连字替换的一些脚本（如阿拉伯语，希伯来语，泰语和印度语）是无用的。
        参数
        frc - 指定的 FontRenderContext
        ci - 指定的 CharacterIterator
        结果
        一个新的 GlyphVector创建与指定的 CharacterIterator和指定的 FontRenderContext 。

      • createGlyphVector

        public GlyphVector createGlyphVector​(FontRenderContext frc,
                                     int[] glyphCodes)
        创建GlyphVector通过映射字符字形的一对一的基础上在此的Unicode cmap Font 。 除了将字形映射到字符之外，此方法还没有其他处理。 这意味着这种方法对于需要重新排序，整形或连字替换的一些脚本（如阿拉伯语，希伯来语，泰语和印度语）是无用的。
        参数
        frc - 指定的 FontRenderContext
        glyphCodes - 指定的整数数组
        结果
        新 GlyphVector与指定的整数数组和指定创建 FontRenderContext 。

      • layoutGlyphVector

        public GlyphVector layoutGlyphVector​(FontRenderContext frc,
                                     char[] text,
                                     int start,
                                     int limit,
                                     int flags)
        返回一个新的GlyphVector对象，如果可能，执行文本的全面布局。 对于复杂文本（如阿拉伯语或印地语）需要完整布局。 支持不同的脚本取决于字体和实现。

        布局需要双向分析，由Bidi执行，只能对具有统一方向的文本执行。 方向在flags参数中指示，使用LAYOUT_RIGHT_TO_LEFT表示从右到左（阿拉伯语和希伯来语）运行方向，或LAYOUT_LEFT_TO_RIGHT表示从左到右（英文）运行方向。

        此外，一些操作，如阿拉伯塑造，需要上下文，以便开始和限制的字符可以具有正确的形状。 有时缓冲区中提供范围之外的数据没有有效数据。 可以将值LAYOUT_NO_START_CONTEXT和LAYOUT_NO_LIMIT_CONTEXT添加到flags参数中，以指示不应在上下文中检查开始之前或之后的限制之后的文本。

        flags参数的所有其他值都保留。

        参数
        frc - 指定的 FontRenderContext
        text - 文本布局
        start - 文字的开头用于 GlyphVector
        limit - 用于 GlyphVector的文本的限制
        flags - 如上所述的控制标志
        结果
        新的 GlyphVector表示开始和限制之间的文本，选择和定位字形以最好地表示文本
        异常
        ArrayIndexOutOfBoundsException - 如果启动或限制超出范围
        从以下版本开始：
        1.4
        另请参见：
        Bidi ， LAYOUT_LEFT_TO_RIGHT ， LAYOUT_RIGHT_TO_LEFT ， LAYOUT_NO_START_CONTEXT ， LAYOUT_NO_LIMIT_CONTEXT
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FontFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class FontFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.FontFormatException
  • All Implemented Interfaces:
    Serializable

    public class FontFormatException
extends 异常
    在 Font类中通过方法createFont抛出，以指示指定的字体不好。
    从以下版本开始：
    1.3
    另请参见：
    Font ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FontFormatException​(String reason)
      报告FontFormatException为指定的原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FontFormatException

        public FontFormatException​(String reason)
        报告FontFormatException为指定的原因。
        参数
        reason - a String message indicating why the font is not accepted.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FontMetrics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class FontMetrics

  • java.lang.Object
    • java.awt.FontMetrics
  • All Implemented Interfaces:
    Serializable

    public abstract class FontMetrics
extends Object
implements Serializable
    FontMetrics类定义了一个字体度量对象，该对象封装了在特定屏幕上呈现特定字体的信息。

    对于子类的注意事项 ：由于许多这些方法形成闭合的相互递归循环，因此您必须注意在每个这样的循环中至少实现一个方法，以便在使用子类时防止无限递归。 特别地，以下是为了确保正确性和防止无限递归（尽管其他子集同样可行）覆盖的最小建议方法集合：

    • getAscent()
    • getLeading()
    • getMaxAdvance()
    • charWidth(char)
    • charsWidth(char[], int, int)

    字母“p”显示其“参考点” 请注意，这些方法的实现效率低下，因此通常会使用更有效的工具包特定实现来覆盖它们。

    当应用程序要求在位置（ x ， y ）放置一个字符时，放置该字符使其参考点（如附图中的点所示）放在该位置。 参考点指定一个水平线，称为字符的基线 。 在正常打印中，字符的基线应对齐。

    另外，字体中的每个字符都有上升 ， 下降和前进宽度 。 上升是字符在基线上方上升的量。 下降是字符下降到基线以下的量。 前进宽度表示AWT应放置下一个字符的位置。

    字符或字符串的数组也可以具有上升，下降和前进宽度。 数组的上升是数组中任何字符的最大上升。 下降是数组中任何字符的最大下降。 前进宽度是字符数组中每个字符的提前宽度的总和。 一的前进String沿着基线的距离String 。 该距离应为String定心或对齐方向所使用的String 。

    注意， String的提前String是孤立测量的字符的前进的总和，因为字符的宽度可以根据其上下文而变化。 例如，在阿拉伯语文本中，字符的形状可以改变以连接到其他字符。 此外，在某些脚本中，某些字符序列可以由单个形状表示，称为连字 。 单独测量字符不会影响这些转换。

    字体度量是基线相对的，这意味着它们通常与应用于字体的旋转无关（模可能的网格提示效果）。 见Font 。

    从以下版本开始：
    1.0
    另请参见：
    Font ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Font font
      创建字体度量的实际Font 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FontMetrics​(Font font)
      创建一个新的 FontMetrics用于找出的高度和宽度信息有关指定对象 Font在和特定字符字形的 Font 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int bytesWidth​(byte[] data, int off, int len)
      返回在此 Font显示指定字节数组的总进位宽度。
      int charsWidth​(char[] data, int off, int len)
      返回此 Font显示指定字符数组的总进位宽度。
      int charWidth​(char ch)
      返回此 Font指定字符的前进宽度。
      int charWidth​(int codePoint)
      返回此 Font指定字符的前进宽度。
      int getAscent​()
      确定此 FontMetrics对象描述的 Font 上升字体 。
      int getDescent​()
      确定此 FontMetrics对象描述的 Font的 字体下降 。
      Font getFont​()
      获取 Font通过此描述 FontMetrics对象。
      FontRenderContext getFontRenderContext​()
      获取 FontRenderContext使用此 FontMetrics对象测量文本。
      int getHeight​()
      获取此字体中文本行的标准高度。
      int getLeading​()
      确定此 FontMetrics对象描述的 Font的 标准引导 。
      LineMetrics getLineMetrics​(char[] chars, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定字符数组的LineMetrics对象。
      LineMetrics getLineMetrics​(String str, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定的String的LineMetrics对象。
      LineMetrics getLineMetrics​(String str, Graphics context)
      返回指定的Graphics上下文中指定的String的LineMetrics对象。
      LineMetrics getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定的CharacterIterator的LineMetrics对象。
      int getMaxAdvance​()
      获取此 Font中任何字符的最大提前宽度。
      int getMaxAscent​()
      确定 FontMetrics对象描述的 Font的最大上限。
      Rectangle2D getMaxCharBounds​(Graphics context)
      返回具有指定的 Graphics上下文中最大边界的字符的边界。
      int getMaxDecent​()
      已过时。
      截至JDK 1.1.1版，由getMaxDescent()替换。
      int getMaxDescent​()
      确定此 FontMetrics对象描述的 Font的最大下降。
      Rectangle2D getStringBounds​(char[] chars, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的字符数组的范围。
      Rectangle2D getStringBounds​(String str, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的 String的边界。
      Rectangle2D getStringBounds​(String str, Graphics context)
      返回指定的 Graphics上下文中指定的 String的边界。
      Rectangle2D getStringBounds​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的 CharacterIterator中索引的字符的边界。
      int[] getWidths​()
      获取 Font前256个字符的提前宽度。
      boolean hasUniformLineMetrics​()
      检查 Font是否具有统一的线度量。
      int stringWidth​(String str)
      返回在此 Font显示指定的 String的总进位宽度。
      String toString​()
      以 FontMetrics的形式返回此 FontMetrics对象的值的 String 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • font

        protected Font font
        创建字体度量的实际Font 。 这不能为空。
        另请参见：
        getFont()

    • 构造方法详细信息

      • FontMetrics

        protected FontMetrics​(Font font)
        创建一个新的 FontMetrics用于找出的高度和宽度信息有关指定对象 Font在和特定字符字形的 Font 。
        参数
        font - Font
        另请参见：
        Font

    • 方法详细信息

      • getFont

        public Font getFont​()
        获取 Font通过此描述 FontMetrics对象。
        结果
        所述 Font通过此描述 FontMetrics对象。

      • getFontRenderContext

        public FontRenderContext getFontRenderContext​()
        获取FontRenderContext使用此FontMetrics对象测量文本。

        注意，在这个类中的方法，其采取Graphics使用参数测量文本FontRenderContext说的Graphics对象这一点，而不是FontRenderContext

        结果
        该 FontRenderContext使用的 FontMetrics对象。
        从以下版本开始：
        1.6

      • getLeading

        public int getLeading​()
        确定FontMetrics对象描述的Font的标准引导 。 标准前导或行间距是在一行文本的下降与下一行的上升之间保留的逻辑空间量。 计算高度度量以包括这个额外的空间。
        结果
        标准领先的是 Font 。
        另请参见：
        getHeight() ，
getAscent() ，
getDescent()

      • getAscent

        public int getAscent​()
        确定FontMetrics对象描述的Font的字体上升 。 字体上升是从字体的基线到大多数字母数字字符顶部的距离。 Font中的某些字符可能会在字体上升线上方延伸。
        结果
        的字体上升了 Font 。
        另请参见：
        getMaxAscent()

      • getDescent

        public int getDescent​()
        确定此FontMetrics对象描述的Font的字体下降 。 字体下降是与字体的基线到具有下降沿的大多数字母数字字符的底部的距离。 Font中的某些字符可能会延伸到字体下降行以下。
        结果
        字体下降的 Font 。
        另请参见：
        getMaxDescent()

      • getHeight

        public int getHeight​()
        获取此字体中文本行的标准高度。 这是相邻文本行基线之间的距离。 它是领先的+上升+下降的总和。 由于四舍五入，这可能与getAscent（）+ getDescent（）+ getLeading（））不同。 不能保证在这个距离上间隔的文本行是不相交的; 如果某些字符超出标准上升或标准下降度量，这样的行可能会重叠。
        结果
        字体的标准高度。
        另请参见：
        getLeading() ，
getAscent() ，
getDescent()

      • getMaxAscent

        public int getMaxAscent​()
        确定FontMetrics对象描述的Font的最大上限。 没有任何字符比字体的基线高于此高度。
        结果
        Font中任何角色的最大上升。
        另请参见：
        getAscent()

      • getMaxDescent

        public int getMaxDescent​()
        确定此FontMetrics对象描述的Font的最大下降。 没有任何字符比字体的基线高出这个高度。
        结果
        任何字符的最大下降在 Font 。
        另请参见：
        getDescent()

      • getMaxDecent

        @Deprecated
public int getMaxDecent​()
        已过时。 自JDK版本1.1.1起，由getMaxDescent()替代。
        仅用于向后兼容
        结果
        任何字符的最大下降在 Font 。
        另请参见：
        getMaxDescent()

      • getMaxAdvance

        public int getMaxAdvance​()
        获取此Font中任何字符的最大提前宽度。 提前是从最左点到弦线基线最右点的距离。 String的进步不一定是其角色的进步之和。
        结果
        Font中任何字符的最大提前宽度，如果最大提前宽度 Font ， -1 。

      • charWidth

        public int charWidth​(int codePoint)
        返回此Font指定字符的前进宽度。 提前是从角色基线的最左点到最右点的距离。 请注意， String的预付款并不一定是其字符预付款的总和。

        此方法不会将指定的字符验证为有效的Unicode代码点。 如果需要，来电者必须使用Character.isValidCodePoint验证字符值。

        参数
        codePoint - 要测量的字符（Unicode代码点）
        结果
        Font描述的 FontMetrics对象的指定字符的提前宽度。
        另请参见：
        charsWidth(char[], int, int) ， stringWidth(String)

      • charWidth

        public int charWidth​(char ch)
        返回此Font指定字符的前进宽度。 提前是从角色基线的最左点到最右点的距离。 请注意， String的预付款不一定是其字符预付款的总和。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用charWidth(int)方法。

        参数
        ch - 要测量的字符
        结果
        由 FontMetrics对象描述的 Font中指定字符的提前宽度。
        另请参见：
        charsWidth(char[], int, int) ， stringWidth(String)

      • stringWidth

        public int stringWidth​(String str)
        返回显示指定的总的超前宽度String在此Font 。 提前是从最左点到弦线基线最右点的距离。

        请注意，一个String的提前不一定是它的字符的进步的总和。

        参数
        str - 要测量的 String
        结果
        指定的超前宽度 String在 Font此描述 FontMetrics 。
        异常
        NullPointerException - 如果str为空。
        另请参见：
        bytesWidth(byte[], int, int) ，
charsWidth(char[], int, int) ，
getStringBounds(String, Graphics)

      • charsWidth

        public int charsWidth​(char[] data,
                      int off,
                      int len)
        返回此Font显示指定字符数组的总进位宽度。 提前是从最左点到弦线基线最右点的距离。 String的推进不一定是其字符的进步的总和。 这相当于在指定范围内测量一个String的字符。
        参数
        data - 要测量的字符数组
        off - 数组中字符的起始偏移量
        len - 要从数组中测量的字符数
        结果
        由 FontMetrics对象描述的字体指定的 char数组的子阵列的前进宽度。
        异常
        NullPointerException - 如果 data为空。
        IndexOutOfBoundsException - 如果 off和 len参数的索引字符超出了 data数组的界限。
        另请参见：
        charWidth(int) ， charWidth(char) ， bytesWidth(byte[], int, int) ， stringWidth(String)

      • bytesWidth

        public int bytesWidth​(byte[] data,
                      int off,
                      int len)
        返回在此Font显示指定字节数组的总进位宽度。 提前是从最左点到弦线基线最右点的距离。 String的预付款不一定是其字符的进步之和。 这相当于在指定范围内测量一个String的字符。
        参数
        data - 要测量的字节数组
        off - 数组中字节的起始偏移量
        len - 要从数组中测量的字节数
        结果
        在 Font描述的 FontMetrics对象中指定的 byte阵列的子阵列的前进宽度。
        异常
        NullPointerException - 如果 data为空。
        IndexOutOfBoundsException - 如果 off和 len参数的索引字节超出了 data数组的界限。
        另请参见：
        charsWidth(char[], int, int) ， stringWidth(String)

      • getWidths

        public int[] getWidths​()
        获取Font前256个字符的提前宽度。 提前是从角色基线的最左点到最右点的距离。 请注意， String的预付款不一定是其字符的预付款的总和。
        结果
        一个数组，存储由 FontMetrics对象描述的 Font中的字符的提前宽度。

      • hasUniformLineMetrics

        public boolean hasUniformLineMetrics​()
        检查Font是否具有统一的线度量。 复合字体可以由几种不同的字体组成，以覆盖各种字符集。 在这种情况下， FontLineMetrics对象不统一。 不同的字体可能有不同的上升，下降，指标等。 此信息有时是线测量和断线所必需的。
        结果
        true如果字体具有统一的线度量; false否则。
        另请参见：
        Font.hasUniformLineMetrics()

      • getLineMetrics

        public LineMetrics getLineMetrics​(String str,
                                  Graphics context)
        返回指定的Graphics上下文中指定的String的LineMetrics对象。
        参数
        str - 指定的 String
        context - 指定的 Graphics上下文
        结果
        使用指定的 String和 Graphics上下文创建的一个 LineMetrics对象。
        另请参见：
        Font.getLineMetrics(String, FontRenderContext)

      • getLineMetrics

        public LineMetrics getLineMetrics​(String str,
                                  int beginIndex,
                                  int limit,
                                  Graphics context)
        返回指定的Graphics上下文中指定的String的LineMetrics对象。
        参数
        str - 指定的 String
        beginIndex -的初始偏移 str
        limit - 最终的偏移量为 str
        context - 指定的 Graphics上下文
        结果
        一个 LineMetrics对象，使用指定的 String和 Graphics上下文创建。
        另请参见：
        Font.getLineMetrics(String, int, int, FontRenderContext)

      • getLineMetrics

        public LineMetrics getLineMetrics​(char[] chars,
                                  int beginIndex,
                                  int limit,
                                  Graphics context)
        返回指定的Graphics上下文中指定字符数组的LineMetrics对象。
        参数
        chars - 指定的字符数组
        beginIndex - 初始偏移 chars
        limit - 最终的偏移量为 chars
        context - 指定的 Graphics上下文
        结果
        一个 LineMetrics对象，使用指定的字符数组和 Graphics上下文创建。
        另请参见：
        Font.getLineMetrics(char[], int, int, FontRenderContext)

      • getLineMetrics

        public LineMetrics getLineMetrics​(CharacterIterator ci,
                                  int beginIndex,
                                  int limit,
                                  Graphics context)
        返回指定的Graphics上下文中指定的CharacterIterator的LineMetrics对象。
        参数
        ci - 指定的 CharacterIterator
        beginIndex -初始偏移 ci
        limit - 最终指数为 ci
        context - 指定的 Graphics上下文
        结果
        用指定的参数创建的一个 LineMetrics对象。
        另请参见：
        Font.getLineMetrics(CharacterIterator, int, int, FontRenderContext)

      • getStringBounds

        public Rectangle2D getStringBounds​(String str,
                                   Graphics context)
        返回指定的Graphics上下文中指定的String的边界。 边界用于布局String 。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        str - 指定的 String
        context - 指定的 Graphics上下文
        结果
        一个Rectangle2D ，它是指定的边界框String在指定Graphics上下文。
        另请参见：
        Font.getStringBounds(String, FontRenderContext)

      • getStringBounds

        public Rectangle2D getStringBounds​(String str,
                                   int beginIndex,
                                   int limit,
                                   Graphics context)
        返回指定的Graphics上下文中指定的String的边界。 边界用于布局String 。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        str - 指定的 String
        beginIndex - str开头的偏移量
        limit - 最终偏移量为 str
        context - 指定的 Graphics上下文
        结果
        一个 Rectangle2D ，它是指定的边界框 String在指定 Graphics上下文。
        另请参见：
        Font.getStringBounds(String, int, int, FontRenderContext)

      • getStringBounds

        public Rectangle2D getStringBounds​(char[] chars,
                                   int beginIndex,
                                   int limit,
                                   Graphics context)
        返回指定的Graphics上下文中指定的字符数组的范围。 边界用于布局String创建的指定字符数组， beginIndex和limit 。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        chars - 一个字符数组
        beginIndex - 字符数组的初始偏移量
        limit - 字符数组的结束偏移量
        context - 指定的 Graphics上下文
        结果
        一个 Rectangle2D ，它是指定的 Graphics上下文中指定的字符数组的边界框。
        另请参见：
        Font.getStringBounds(char[], int, int, FontRenderContext)

      • getStringBounds

        public Rectangle2D getStringBounds​(CharacterIterator ci,
                                   int beginIndex,
                                   int limit,
                                   Graphics context)
        返回在指定的Graphics上下文中指定的CharacterIterator中索引的字符的边界。

        注意：返回的边界在基线相对坐标（见class notes ）。

        参数
        ci - 指定的 CharacterIterator
        beginIndex -初始偏移 ci
        limit - 最终指数为 ci
        context - 指定的 Graphics上下文
        结果
        一个 Rectangle2D是在指定的 Graphics上下文中指定的 CharacterIterator中索引的字符的边框。
        另请参见：
        Font.getStringBounds(CharacterIterator, int, int, FontRenderContext)

      • getMaxCharBounds

        public Rectangle2D getMaxCharBounds​(Graphics context)
        返回指定 Graphics上下文中具有最大边界的字符的边界。
        参数
        context - 指定的 Graphics上下文
        结果
        一个 Rectangle2D是具有最大边界的字符的边框。
        另请参见：
        Font.getMaxCharBounds(FontRenderContext)

      • toString

        public String toString​()
        返回此 FontMetrics对象的值作为 String的值。
        重写：
        toString在 Object
        结果
        这个 FontMetrics对象的 String表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Frame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Frame

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
          • java.awt.Frame
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible
    已知直接子类：
    JFrame

    public class Frame
extends Window
implements MenuContainer
    A Frame是具有标题和边框的顶级窗口。

    框架的大小包括为边框指定的任何区域。 可以使用getInsets方法获得边界区域的尺寸，但是由于这些尺寸与平台相关，因此无法通过调用pack或show显示帧，才能获得有效的插入值。 由于边框区域被包含在框架的整体尺寸中，边界有效地掩盖了框架的一部分，将可用于渲染和/或显示子组件的区域限制在左上角位置为(insets.left, insets.top) ，以及具有width - (insets.left + insets.right)的大小，由height - (insets.top + insets.bottom) 。

    帧的默认布局为BorderLayout 。

    一个框架可能有自己的装饰（即Frame和Titlebar ）关闭了setUndecorated 。 这只能在框架不是displayable时完成 。

    在多屏幕环境中，您可以在其他屏幕设备上创建一个Frame ，通过构建Frame与Frame(GraphicsConfiguration)或Frame(String title, GraphicsConfiguration) 。 GraphicsConfiguration对象是目标屏幕设备的GraphicsConfiguration对象之一。

    在桌面区域可跨越多个物理屏幕设备的虚拟设备多屏幕环境中，所有配置的边界都相对于虚拟坐标系。 虚拟坐标系的原点位于主物理屏幕的左上角。 根据虚拟设备中主屏幕的位置，可以使用负坐标，如下图所示。

    在这样的环境中，当调用setLocation ，必须将虚拟坐标传递给此方法。 同样，调用getLocationOnScreen上Frame返回虚拟设备坐标。 调用getBounds一个方法GraphicsConfiguration找到它的起源在虚拟坐标系统相同。

    下面的代码设置的位置Frame在（10，10）相对于所述相应的物理屏幕的原点GraphicsConfiguration 。 如果不考虑GraphicsConfiguration的边界，则Frame位置将相对于虚拟坐标系设置为（10,10），并将出现在主物理屏幕上，这可能与物理屏幕不同指定GraphicsConfiguration 。

      Frame f = new Frame(GraphicsConfiguration gc);
      Rectangle bounds = gc.getBounds();
      f.setLocation(10 + bounds.x, 10 + bounds.y);

    帧能够生成以下类型的WindowEvent s：

    • WINDOW_OPENED
    • WINDOW_CLOSING ：
      如果程序在处理此事件时没有明确隐藏或处理窗口，则窗口关闭操作将被取消。
    • WINDOW_CLOSED
    • WINDOW_ICONIFIED
    • WINDOW_DEICONIFIED
    • WINDOW_ACTIVATED
    • WINDOW_DEACTIVATED
    • WINDOW_GAINED_FOCUS
    • WINDOW_LOST_FOCUS
    • WINDOW_STATE_CHANGED
    从以下版本开始：
    1.0
    另请参见：
    WindowEvent ， Window.addWindowListener(java.awt.event.WindowListener) ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Frame.AccessibleAWTFrame
      该类为 Frame类实现可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Window

        Window.AccessibleAWTWindow, Window.Type

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CROSSHAIR_CURSOR
      已过时。
      替换为Cursor.CROSSHAIR_CURSOR 。
      static int DEFAULT_CURSOR
      已过时。
      替换为Cursor.DEFAULT_CURSOR 。
      static int E_RESIZE_CURSOR
      已过时。
      替换为Cursor.E_RESIZE_CURSOR 。
      static int HAND_CURSOR
      已过时。
      替换为Cursor.HAND_CURSOR 。
      static int ICONIFIED
      该状态位指示帧被图标化。
      static int MAXIMIZED_BOTH
      该状态位掩码表示帧完全最大化（即水平和垂直）。
      static int MAXIMIZED_HORIZ
      该状态位指示帧在水平方向上最大化。
      static int MAXIMIZED_VERT
      该状态位指示帧在垂直方向上最大化。
      static int MOVE_CURSOR
      已过时。
      替换为Cursor.MOVE_CURSOR 。
      static int N_RESIZE_CURSOR
      已过时。
      替换为Cursor.N_RESIZE_CURSOR 。
      static int NE_RESIZE_CURSOR
      已过时。
      替换为Cursor.NE_RESIZE_CURSOR 。
      static int NORMAL
      框架处于“正常”状态。
      static int NW_RESIZE_CURSOR
      已过时。
      替换为Cursor.NW_RESIZE_CURSOR 。
      static int S_RESIZE_CURSOR
      已过时。
      替换为Cursor.S_RESIZE_CURSOR 。
      static int SE_RESIZE_CURSOR
      已过时。
      替换为Cursor.SE_RESIZE_CURSOR 。
      static int SW_RESIZE_CURSOR
      已过时。
      取代Cursor.SW_RESIZE_CURSOR 。
      static int TEXT_CURSOR
      已过时。
      替换为Cursor.TEXT_CURSOR 。
      static int W_RESIZE_CURSOR
      已过时。
      替换为Cursor.W_RESIZE_CURSOR 。
      static int WAIT_CURSOR
      已过时。
      替换为Cursor.WAIT_CURSOR 。

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Frame​()
      构造最初不可见的新实例 Frame 。
      Frame​(GraphicsConfiguration gc)
      构造一个新的，初始看不见的 Frame与指定的 GraphicsConfiguration 。
      Frame​(String title)
      构造一个新的，最初无形的 Frame具有指定标题的对象。
      Frame​(String title, GraphicsConfiguration gc)
      构造一个新的，最初看不到的 Frame对象与指定的标题和一个 GraphicsConfiguration 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addNotify​()
      通过将此框架连接到本机屏幕资源来使此框架可以显示。
      AccessibleContext getAccessibleContext​()
      获取与此Frame相关联的AccessibleContext。
      int getCursorType​()
      已过时。
      从JDK 1.1版开始，由Component.getCursor()替代。
      int getExtendedState​()
      获取此框架的状态。
      static Frame[] getFrames​()
      返回由此应用程序创建的所有 Frame的数组。
      Image getIconImage​()
      返回要显示的图像作为此框架的图标。
      Rectangle getMaximizedBounds​()
      获得此框架的最大化边界。
      MenuBar getMenuBar​()
      获取此框架的菜单栏。
      int getState​()
      获取此框架的状态（已过时）。
      String getTitle​()
      获取框架的标题。
      boolean isResizable​()
      指示该框架是否可由用户调整大小。
      boolean isUndecorated​()
      指示此框架是否未装饰。
      protected String paramString​()
      返回表示此 Frame的状态的字符串。
      void remove​(MenuComponent m)
      从此框架中删除指定的菜单栏。
      void removeNotify​()
      通过删除其与其本机屏幕资源的连接，使此框架不可显示。
      void setBackground​(Color bgColor)
      设置此窗口的背景颜色。
      void setCursor​(int cursorType)
      已过时。
      从JDK 1.1版开始，替换为Component.setCursor(Cursor) 。
      void setExtendedState​(int state)
      设置此帧的状态。
      void setIconImage​(Image image)
      将要显示的图像设置为此窗口的图标。
      void setMaximizedBounds​(Rectangle bounds)
      设置此框架的最大化边界。
      void setMenuBar​(MenuBar mb)
      将此框架的菜单栏设置为指定的菜单栏。
      void setOpacity​(float opacity)
      设置窗口的不透明度。
      void setResizable​(boolean resizable)
      设置该框架是否可以由用户调整大小。
      void setShape​(Shape shape)
      设置窗口的形状。
      void setState​(int state)
      设置此框架的状态（已过时）。
      void setTitle​(String title)
      将此框架的标题设置为指定的字符串。
      void setUndecorated​(boolean undecorated)
      禁用或启用此框架的装饰。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, resize, resize, revalidate, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setMaximumSize, setMixingCutoutShape, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from interface java.awt.MenuContainer

        getFont, postEvent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.Window

        addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBackground, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOpacity, getOwnedWindows, getOwner, getOwnerlessWindows, getShape, getToolkit, getType, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isAutoRequestFocus, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isOpaque, isShowing, isValidateRoot, pack, paint, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setAutoRequestFocus, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImages, setLocation, setLocation, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setType, setVisible, show, toBack, toFront

    • 字段详细信息

      • DEFAULT_CURSOR

        @Deprecated
public static final int DEFAULT_CURSOR
        已过时。 替换为Cursor.DEFAULT_CURSOR 。
        另请参见：
        Constant Field Values

      • CROSSHAIR_CURSOR

        @Deprecated
public static final int CROSSHAIR_CURSOR
        已过时。 替换为Cursor.CROSSHAIR_CURSOR 。
        另请参见：
        Constant Field Values

      • TEXT_CURSOR

        @Deprecated
public static final int TEXT_CURSOR
        已过时。 替换为Cursor.TEXT_CURSOR 。
        另请参见：
        Constant Field Values

      • WAIT_CURSOR

        @Deprecated
public static final int WAIT_CURSOR
        已过时。 替换为Cursor.WAIT_CURSOR 。
        另请参见：
        Constant Field Values

      • SW_RESIZE_CURSOR

        @Deprecated
public static final int SW_RESIZE_CURSOR
        已过时。 替换为Cursor.SW_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • SE_RESIZE_CURSOR

        @Deprecated
public static final int SE_RESIZE_CURSOR
        已过时。 替换为Cursor.SE_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • NW_RESIZE_CURSOR

        @Deprecated
public static final int NW_RESIZE_CURSOR
        已过时。 替换为Cursor.NW_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • NE_RESIZE_CURSOR

        @Deprecated
public static final int NE_RESIZE_CURSOR
        已过时。 取代Cursor.NE_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • N_RESIZE_CURSOR

        @Deprecated
public static final int N_RESIZE_CURSOR
        已过时。 替换为Cursor.N_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • S_RESIZE_CURSOR

        @Deprecated
public static final int S_RESIZE_CURSOR
        已过时。 替换为Cursor.S_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • W_RESIZE_CURSOR

        @Deprecated
public static final int W_RESIZE_CURSOR
        已过时。 换成Cursor.W_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • E_RESIZE_CURSOR

        @Deprecated
public static final int E_RESIZE_CURSOR
        已过时。 替换为Cursor.E_RESIZE_CURSOR 。
        另请参见：
        Constant Field Values

      • HAND_CURSOR

        @Deprecated
public static final int HAND_CURSOR
        已过时。 替换为Cursor.HAND_CURSOR 。
        另请参见：
        Constant Field Values

      • MOVE_CURSOR

        @Deprecated
public static final int MOVE_CURSOR
        已过时。 替换为Cursor.MOVE_CURSOR 。
        另请参见：
        Constant Field Values

      • NORMAL

        public static final int NORMAL
        框架处于“正常”状态。 该符号常数命名所有状态位清零的帧状态。
        另请参见：
        setExtendedState(int) ， getExtendedState() ， Constant Field Values

      • ICONIFIED

        public static final int ICONIFIED
        该状态位指示帧被图标化。
        另请参见：
        setExtendedState(int) ， getExtendedState() ， Constant Field Values

      • MAXIMIZED_HORIZ

        public static final int MAXIMIZED_HORIZ
        该状态位指示帧在水平方向上最大化。
        从以下版本开始：
        1.4
        另请参见：
        setExtendedState(int) ， getExtendedState() ， Constant Field Values

      • MAXIMIZED_VERT

        public static final int MAXIMIZED_VERT
        该状态位指示帧在垂直方向上最大化。
        从以下版本开始：
        1.4
        另请参见：
        setExtendedState(int) ， getExtendedState() ， Constant Field Values

      • MAXIMIZED_BOTH

        public static final int MAXIMIZED_BOTH
        该状态位掩码表示帧完全最大化（即水平和垂直）。 这只是一个方便的别名MAXIMIZED_VERT | MAXIMIZED_HORIZ 。

        请注意，正确的框架测试是完全最大化的

          (state & Frame.MAXIMIZED_BOTH) == Frame.MAXIMIZED_BOTH

        要测试的是帧的最大化在某些方向使用

          (state & Frame.MAXIMIZED_BOTH) != 0
        从以下版本开始：
        1.4
        另请参见：
        setExtendedState(int) ， getExtendedState() ， Constant Field Values

    • 构造方法详细信息

      • Frame

        public Frame​()
      throws HeadlessException
        构造最初不可见的新实例Frame 。 Frame的标题是空的。
        异常
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        另请参见：
        GraphicsEnvironment.isHeadless() ，
Component.setSize(int, int) ，
Component.setVisible(boolean)

      • Frame

        public Frame​(GraphicsConfiguration gc)
        构造一个新的，最初看不到的 Frame与指定的 GraphicsConfiguration 。
        参数
        gc - 目标屏幕设备的GraphicsConfiguration 。 如果gc为null ，则假定系统默认为GraphicsConfiguration 。
        异常
        IllegalArgumentException - 如果 gc不是来自屏幕设备。
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Frame

        public Frame​(String title)
      throws HeadlessException
        构造一个新的，最初不可见的 Frame对象与指定的标题。
        参数
        title - 要在框架边框中显示的标题。 A null值被视为空字符串“”。
        异常
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        另请参见：
        GraphicsEnvironment.isHeadless() ，
Component.setSize(int, int) ，
Component.setVisible(boolean) ，
GraphicsConfiguration.getBounds()

      • Frame

        public Frame​(String title,
             GraphicsConfiguration gc)
        构造一个新的，最初看不见的 Frame具有指定标题的对象和一个 GraphicsConfiguration 。
        参数
        title - 要在框架边框中显示的标题。 A null值被视为空字符串“”。
        gc - 目标屏幕设备的GraphicsConfiguration 。 如果gc为null ，则假定系统默认为GraphicsConfiguration 。
        异常
        IllegalArgumentException - 如果 gc不是来自屏幕设备。
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless() ，
Component.setSize(int, int) ，
Component.setVisible(boolean) ，
GraphicsConfiguration.getBounds()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        通过将此框架连接到本机屏幕资源来使此框架可以显示。 使框架可显示将导致其任何一个孩子被显示。 该方法由工具包内部调用，不应由程序直接调用。
        重写：
        addNotify在 Window
        另请参见：
        Component.isDisplayable() ， removeNotify()

      • getTitle

        public String getTitle​()
        获取框架的标题。 标题显示在框架的边框中。
        结果
        此框架的标题或空字符串（“”），如果此框架没有标题。
        另请参见：
        setTitle(String)

      • setTitle

        public void setTitle​(String title)
        将此框架的标题设置为指定的字符串。
        参数
        title - 要显示在框架边框中的标题。 A null值被视为空字符串“”。
        另请参见：
        getTitle()

      • getIconImage

        public Image getIconImage​()
        返回要显示的图像作为此框架的图标。

        此方法已过时，仅用于向后兼容。 改用Window.getIconImages() 。

        如果将多个图像的列表指定为Window的图标，则此方法将返回列表的第一个项目。

        结果
        此框架的图标图像，如果此框架没有图标图像， null 。
        另请参见：
        setIconImage(Image) ， Window.getIconImages() ， Window.setIconImages(java.util.List<? extends java.awt.Image>)

      • setIconImage

        public void setIconImage​(Image image)
        将要显示的图像设置为此窗口的图标。

        可以使用此方法代替setIconImages()将单个图像指定为窗口的图标。

        以下声明：

          setIconImage(image);
        相当于：
          ArrayList<Image> imageList = new ArrayList<Image>();
     imageList.add(image);
     setIconImages(imageList);

        注意：根据上下文（例如窗口装饰，窗口列表，任务栏等），本机窗口系统可以使用不同尺寸的不同图像来表示窗口。 他们也可以仅使用单个图像进行所有上下文或根本没有图像。

        重写：
        setIconImage在 Window
        参数
        image - 要显示的图标图像。
        另请参见：
        Window.setIconImages(java.util.List<? extends java.awt.Image>) ， Window.getIconImages()

      • getMenuBar

        public MenuBar getMenuBar​()
        获取此框架的菜单栏。
        结果
        此框架的菜单栏，或 null如果此框架没有菜单栏。
        另请参见：
        setMenuBar(MenuBar)

      • setMenuBar

        public void setMenuBar​(MenuBar mb)
        将此框架的菜单栏设置为指定的菜单栏。
        参数
        mb - 正在设置菜单栏。 如果此参数为null则此框架上的任何现有菜单栏都将被删除。
        另请参见：
        getMenuBar()

      • isResizable

        public boolean isResizable​()
        指示该框架是否可由用户调整大小。 默认情况下，所有帧最初都可调整大小。
        结果
        true如果用户可以调整此框架大小; 否则为false 。
        另请参见：
        setResizable(boolean)

      • setResizable

        public void setResizable​(boolean resizable)
        设置该框架是否可以由用户调整大小。
        参数
        resizable - true如果此框架可调整大小; 否则为false 。
        另请参见：
        isResizable()

      • setState

        public void setState​(int state)
        设置此框架的状态（已过时）。

        在旧版本的JDK中，帧状态只能是NORMAL或ICONIFIED。 由于JDK 1.4支持的帧状态集合被扩展，并且帧状态被表示为按位掩码。

        为了与早期开发的应用程序兼容，此方法仅接受Frame.NORMAL和Frame.ICONIFIED 。 帧的标志状态只有改变，帧状态的其他方面不受此方法的影响。 如果传递给该方法的状态既不是Frame.NORMAL也不是Frame.ICONIFIED该方法根本不执行任何操作。

        请注意，如果给定平台不支持该状态，则getState()方法的状态和返回值都不会更改。 应用程序可以通过Toolkit.isFrameStateSupported(int)方法确定是否支持特定状态。

        如果框架当前在屏幕上可见 （ Window.isShowing()方法返回true ），则开发人员应检查通过WindowEvent收到的WindowEvent的WindowEvent.getNewState()方法的返回值，以确定状态实际已更改。

        如果框架在屏幕上不可见 ，则可能会生成事件，也可能不会生成事件。 在这种情况下，开发人员可以假定在该方法返回后状态立即改变。 稍后，当调用setVisible(true)方法时，框架将尝试应用此状态。 在这种情况下也不保证接收WindowEvent.WINDOW_STATE_CHANGED事件。

        参数
        state - Frame.NORMAL或 Frame.ICONIFIED 。
        另请参见：
        setExtendedState(int) ， Window.addWindowStateListener(java.awt.event.WindowStateListener)

      • setExtendedState

        public void setExtendedState​(int state)
        设置此帧的状态。 状态表示为按位掩码。
        • NORMAL
          表示没有设置状态位。
        • ICONIFIED
        • MAXIMIZED_HORIZ
        • MAXIMIZED_VERT
        • MAXIMIZED_BOTH
          连接MAXIMIZED_HORIZ和MAXIMIZED_VERT 。

        请注意，如果给定平台不支持该状态，则getExtendedState()方法的状态和返回值都不会更改。 应用程序可以通过Toolkit.isFrameStateSupported(int)方法确定是否支持特定状态。

        如果框架当前在屏幕上可见 （ Window.isShowing()方法返回true ），开发人员应检查通过WindowEvent收到的WindowEvent的270479818402752方法的返回值，以确定状态实际已更改。

        如果框架在屏幕上不可见 ，则可能会生成事件，也可能不会生成事件。 在这种情况下，开发人员可以假定在该方法返回后状态立即改变。 之后，当调用setVisible(true)方法时，框架将尝试应用此状态。 在这种情况下也不能保证收到任何WindowEvent.WINDOW_STATE_CHANGED事件。

        参数
        state - 帧状态常数的按位掩码
        从以下版本开始：
        1.4
        另请参见：
        Window.addWindowStateListener(java.awt.event.WindowStateListener)

      • getState

        public int getState​()
        获取此框架的状态（已过时）。

        在旧版本的JDK中，帧状态只能是NORMAL或ICONIFIED。 由于JDK 1.4支持的帧状态集合被扩展，并且帧状态被表示为按位掩码。

        为了与旧程序兼容，该方法仍然返回Frame.NORMAL和Frame.ICONIFIED但它只报告帧的标志状态，此方法不报告帧状态的其他方面。

        结果
        Frame.NORMAL或 Frame.ICONIFIED 。
        另请参见：
        setState(int) ， getExtendedState()

      • getExtendedState

        public int getExtendedState​()
        获取此框架的状态。 状态表示为按位掩码。
        • NORMAL
          表示没有设置状态位。
        • ICONIFIED
        • MAXIMIZED_HORIZ
        • MAXIMIZED_VERT
        • MAXIMIZED_BOTH
          连接MAXIMIZED_HORIZ和MAXIMIZED_VERT 。
        结果
        帧状态常数的按位掩码
        从以下版本开始：
        1.4
        另请参见：
        setExtendedState(int)

      • setMaximizedBounds

        public void setMaximizedBounds​(Rectangle bounds)
        设置此框架的最大化边界。

        当帧处于最大化状态时，系统提供一些默认边界。 该方法允许覆盖那些系统提供的值中的一些或全部。

        如果bounds是null ，请接受系统提供的边界。 如果非null可以通过将要从系统接受的字段设置为Integer.MAX_VALUE来接受其他系统提供的值。

        注意，给定的最大化边界用作本机系统的提示，因为底层平台可能不支持设置最大化窗口的位置和/或大小。 如果是这种情况，提供的值不会影响最大化状态下的帧的外观。

        参数
        bounds - 最大化状态的界限
        从以下版本开始：
        1.4
        另请参见：
        getMaximizedBounds()

      • getMaximizedBounds

        public Rectangle getMaximizedBounds​()
        获得此框架的最大化边界。 某些字段可能包含Integer.MAX_VALUE以表示必须使用该字段的系统提供的值。
        结果
        该框架的最大化边界; 可能是null
        从以下版本开始：
        1.4
        另请参见：
        setMaximizedBounds(Rectangle)

      • setUndecorated

        public void setUndecorated​(boolean undecorated)
        禁用或启用此框架的装饰。

        该方法只能在框架不可显示时被调用。 要使这个框架装饰，它必须是不透明的，并且具有默认形状，否则将抛出IllegalComponentStateException 。 请参阅Window.setShape(java.awt.Shape) ， Window.setOpacity(float)和Window.setBackground(java.awt.Color)的细节

        参数
        undecorated - true如果不启用框架装饰; false如果要启用框架装饰
        异常
        IllegalComponentStateException - 如果框架是可显示的
        IllegalComponentStateException - 如果 undecorated是 false ，并且此框架没有默认形状
        IllegalComponentStateException - 如果 undecorated是 false ，并且此帧不透明度小于 1.0f
        IllegalComponentStateException - 如果 undecorated是 false ，并且此框架背景颜色的alpha值小于 1.0f
        从以下版本开始：
        1.4
        另请参见：
        isUndecorated() ，
Component.isDisplayable() ，
Window.getShape() ，
Window.getOpacity() ，
Window.getBackground() ，
JFrame.setDefaultLookAndFeelDecorated(boolean)

      • isUndecorated

        public boolean isUndecorated​()
        指示此框架是否未装饰。 默认情况下，所有框架最初都是装饰的。
        结果
        如果框架未装饰， true ; false否则。
        从以下版本开始：
        1.4
        另请参见：
        setUndecorated(boolean)

      • setOpacity

        public void setOpacity​(float opacity)
        设置窗口的不透明度。

        不透明度值在[0..1]的范围内。 请注意，设置不透明度级别为0可能会禁用此窗口上的鼠标事件处理。 这是依赖于平台的行为。

        为了使不透明度值小于1.0f必须满足以下条件：

        • 底层系统必须支持TRANSLUCENT半透明度
        • 窗口必须未装饰（参见setUndecorated(boolean)和Dialog.setUndecorated(boolean) ）
        • 窗口不能处于全屏模式（参见GraphicsDevice.setFullScreenWindow(Window) ）

        如果请求的不透明度值小于1.0f ，并且不符合上述任何条件，窗口不透明度将不会更改，并且将抛出IllegalComponentStateException 。

        单个像素的半透明度也可以通过其颜色的α分量（参见Window.setBackground(Color) ）和该窗口的当前形状（参见Window.setShape(Shape) ）来实现。

        重写：
        setOpacity在 Window
        参数
        opacity - 设置为窗口的不透明度级别
        另请参见：
        Window.getOpacity() ， Window.setBackground(Color) ， Window.setShape(Shape) ， isUndecorated() ， Dialog.isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency)

      • setShape

        public void setShape​(Shape shape)
        设置窗口的形状。

        设置形状会切断窗口的某些部分。 只有属于给定的Shape的部件保持可见和可点击。 如果形状参数为null ，则此方法将恢复默认形状，使窗口在大多数平台上呈矩形。

        必须满足以下条件才能设置非空形状：

        • 底层系统必须支持PERPIXEL_TRANSPARENT半透明度
        • 窗口必须未装饰（参见setUndecorated(boolean)和Dialog.setUndecorated(boolean) ）
        • 窗口不能为全屏模式（请参阅GraphicsDevice.setFullScreenWindow(Window) ）

        如果请求的形状不是null ，并且不符合上述任何条件，则此窗口的形状将不会更改，并且将抛出UnsupportedOperationException或IllegalComponentStateException 。

        单个像素的半透明度也可以通过其颜色的α分量（参见Window.setBackground(Color) ）和不透明度值（参见Window.setOpacity(float) ）来实现。 详见GraphicsDevice.WindowTranslucency 。

        重写：
        setShape在 Window
        参数
        shape - 要设置窗口的形状
        另请参见：
        Window.getShape() ， Window.setBackground(Color) ， Window.setOpacity(float) ， isUndecorated() ， Dialog.isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency)

      • setBackground

        public void setBackground​(Color bgColor)
        设置此窗口的背景颜色。

        如果窗口系统支持PERPIXEL_TRANSLUCENT半透明度，给定背景颜色的alpha分量可能会影响此窗口的操作模式：它指示此窗口是否为不透明（alpha等于1.0f ）或每像素半透明（alpha小于1.0f ）。 如果给定的背景颜色是null ，则该窗口被认为是完全不透明的。

        必须满足以下条件以启用此窗口的每像素透明度模式：

        • PERPIXEL_TRANSLUCENT半透明度必须由此窗口所在的图形设备支持
        • 窗口必须未装饰（见setUndecorated(boolean)和Dialog.setUndecorated(boolean) ）
        • 窗口不能为全屏模式（请参阅GraphicsDevice.setFullScreenWindow(Window) ）

        如果所请求的背景颜色的alpha分量小于1.0f ，并且不满足上述任何条件，则此窗口的背景颜色不会改变，给定背景颜色的alpha分量不会影响这个窗口，和UnsupportedOperationException或IllegalComponentStateException将被抛出。

        当窗口是每像素半透明时，绘图子系统遵循每个像素的alpha值。 如果使用等于零的alpha颜色成分绘制像素，则它将变得视觉上透明。 如果像素的alpha等于1.0f，则像素完全不透明。 alpha颜色分量的中间值使像素半透明。 在此模式下，窗口的背景绘制为给定背景颜色的alpha值。 如果此方法的参数的alpha值等于0 ，则完全不绘制背景。

        给定像素的半透明度的实际水平也取决于窗口不透明度（见Window.setOpacity(float) ）以及该窗口的当前形状（见Window.setShape(Shape) ）。

        请注意，绘制Alpha值为0的像素可能会禁用此像素上的鼠标事件处理。 这是依赖于平台的行为。 为了确保鼠标事件不被分派到特定的像素，像素必须从窗口的形状中排除。

        由于本机平台要求，启用每像素半透明模式可能会改变该窗口的图形配置。

        重写：
        setBackground类 Window
        参数
        bgColor - 成为这个窗口的背景颜色的颜色。
        另请参见：
        Window.getBackground() ， Window.isOpaque() ， Window.setOpacity(float) ， Window.setShape(Shape) ， isUndecorated() ， Dialog.isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency) ， GraphicsConfiguration.isTranslucencyCapable()

      • remove

        public void remove​(MenuComponent m)
        从此框架中删除指定的菜单栏。
        Specified by:
        remove接口 MenuContainer
        重写：
        remove在 Component
        参数
        m - 要删除的菜单组件。 如果m为null ，则不采取任何措施
        另请参见：
        Component.add(PopupMenu)

      • removeNotify

        public void removeNotify​()
        通过删除其与其本机屏幕资源的连接，使此框架不可显示。 使框架不可显示将使其任何一个孩子被制成不可显示的。 该方法在内部被工具包调用，不应该被程序直接调用。
        重写：
        removeNotify在 Window
        另请参见：
        Component.isDisplayable() ， addNotify()

      • paramString

        protected String paramString​()
        返回一个表示Frame状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Container
        结果
        该帧的参数字符串

      • setCursor

        @Deprecated
public void setCursor​(int cursorType)
        已过时。 从JDK 1.1版开始，由Component.setCursor(Cursor)替代。
        将此帧的光标设置为指定的类型。
        参数
        cursorType - 游标类型

      • getCursorType

        @Deprecated
public int getCursorType​()
        已过时。 从JDK 1.1版开始，由Component.getCursor()替代。
        结果
        该帧的光标类型

      • getFrames

        public static Frame[] getFrames​()
        返回由此应用程序创建的所有Frame的数组。 如果从小程序调用，该数组只包含该applet可访问的Frame 。

        警告：此方法可能会返回系统创建的帧，例如Swing使用的共享隐藏帧。 应用程序不应该假定这些框架的存在，应用程序也不应该假定任何关于这些框架的内容，例如组件位置， LayoutManager或序列化。

        注意 ：要获取所有无主窗口的列表，包括无主版的Dialog （在版本1.6中引入），请使用Window.getOwnerlessWindows 。

        结果
        由该应用程序创建的所有 Frame的阵列
        从以下版本开始：
        1.2
        另请参见：
        Window.getWindows() ， Window.getOwnerlessWindows()

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此Frame相关联的AccessibleContext。 对于框架，AccessibleContext采用AccessibleAWTFrame的形式。 如有必要，将创建一个新的AccessibleAWTFrame实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Window
        结果
        作为此框架的AccessibleContext的AccessibleAWTFrame
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Frame.AccessibleAWTFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Frame.AccessibleAWTFrame

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Frame.AccessibleAWTFrame
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    已知直接子类：
    JFrame.AccessibleJFrame
    Enclosing class:
    Frame

    protected class Frame.AccessibleAWTFrame
extends Window.AccessibleAWTWindow
    该类实现Frame类的可访问性支持。 它提供了适用于框架用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTFrame​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, removePropertyChangeListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTFrame

        protected AccessibleAWTFrame​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole中的 Window.AccessibleAWTWindow
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态。
        重写：
        getAccessibleStateSet在 Window.AccessibleAWTWindow
        结果
        包含对象的当前状态集的AccessibleStateSet实例
        另请参见：
        AccessibleState
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GradientPaint

  • java.lang.Object
    • java.awt.GradientPaint
  • All Implemented Interfaces:
    Paint ， Transparency

    public class GradientPaint
extends Object
implements Paint
    GradientPaint类提供了一种填充Shape线性颜色渐变模式的方式。 如果Point P1与Color C1和Point P2与Color C2在用户空间中指定，P1，P2连接线上的Color将从C1到C2成比例地更改。 扩展P1，P2连接线上的任何点P都不具有在扩展P1，P2连接线上的P的垂直投影点P'的颜色。 P1，P2段外的扩展线上的点可以以两种方式之一进行着色。
    • 如果梯度是循环的，则扩展的P1，P2连接线上的点在颜色C1和C2之间来回循环。
    • 如果梯度是非循环的，那么该段的P1侧上的点具有常数Color C1，P2侧的点具有常数Color C2。
    Version:
    1997年2月10日
    另请参见：
    Paint ， Graphics2D.setPaint(java.awt.Paint)

    • Field Summary

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      GradientPaint​(float x1, float y1, Color color1, float x2, float y2, Color color2)
      构造一个简单的无环 GradientPaint对象。
      GradientPaint​(float x1, float y1, Color color1, float x2, float y2, Color color2, boolean cyclic)
      根据 boolean参数构造循环或非循环 GradientPaint对象。
      GradientPaint​(Point2D pt1, Color color1, Point2D pt2, Color color2)
      构造一个简单的非循环 GradientPaint对象。
      GradientPaint​(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
      根据 boolean参数构造循环或非循环 GradientPaint对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PaintContext createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      Color getColor1​()
      返回由点P1锚定的颜色C1。
      Color getColor2​()
      返回由点P2锚定的颜色C2。
      Point2D getPoint1​()
      返回锚点第一个颜色的点P1的副本。
      Point2D getPoint2​()
      返回锚定第二种颜色的点P2的副本。
      int getTransparency​()
      返回此 GradientPaint的透明度模式。
      boolean isCyclic​()
      如果梯度在两种颜色C1和C2之间重复循环，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GradientPaint

        public GradientPaint​(float x1,
                     float y1,
                     Color color1,
                     float x2,
                     float y2,
                     Color color2)
        构造一个简单的无环 GradientPaint对象。
        参数
        x1 - 用户空间中第一个指定的 Point x坐标
        y1 - 用户空间中第一个指定的 Point y坐标
        color1 - Color在第一个指定的 Point
        x2 - 用户空间中第二个指定的 Point x坐标
        y2 - 用户空间中第二个指定的 Point y坐标
        color2 - Color在第二个指定的 Point
        异常
        NullPointerException - 如果任何一种颜色为空

      • GradientPaint

        public GradientPaint​(Point2D pt1,
                     Color color1,
                     Point2D pt2,
                     Color color2)
        构造一个简单的无环 GradientPaint对象。
        参数
        pt1 - 用户空间中第一个指定的 Point
        color1 - Color在第一个指定的 Point
        pt2 - 第二个用户空间中指定的 Point
        color2 - Color在第二个指定的 Point
        异常
        NullPointerException - 如果颜色或点中的任何一个为空

      • GradientPaint

        public GradientPaint​(float x1,
                     float y1,
                     Color color1,
                     float x2,
                     float y2,
                     Color color2,
                     boolean cyclic)
        根据 boolean参数构建循环或非循环 GradientPaint对象。
        参数
        x1 - 用户空间中第一个指定的 Point x坐标
        y1 - 用户空间中第一个指定的 Point y坐标
        color1 - Color在第一个指定的 Point
        x2 - 用户空间中第二个指定的 Point x坐标
        y2 - 用户空间中第二个指定的 Point y坐标
        color2 - Color在第二个指定的 Point
        cyclic - true如果梯度图案应该在两种颜色之间重复循环; 否则为false

      • GradientPaint

        @ConstructorProperties({"point1","color1","point2","color2","cyclic"})
public GradientPaint​(Point2D pt1,
                     Color color1,
                     Point2D pt2,
                     Color color2,
                     boolean cyclic)
        根据 boolean参数构造循环或非循环 GradientPaint对象。
        参数
        pt1 - 用户空间中第一个指定的 Point
        color1 - Color在第一个指定的 Point
        pt2 - 第二个用户空间中指定的 Point
        color2 - Color在第二个指定的 Point
        cyclic - true如果梯度图案应该在两种颜色之间重复循环; 否则为false
        异常
        NullPointerException - 如果颜色或点中的任一个为空

    • 方法详细信息

      • getPoint1

        public Point2D getPoint1​()
        返回锚点第一个颜色的点P1的副本。
        结果
        一个Point2D对象，它是锚定此GradientPaint的第一个颜色的点的副本。

      • getColor1

        public Color getColor1​()
        返回由点P1锚定的颜色C1。
        结果
        一个 Color对象，它是由P1锚定的颜色。

      • getPoint2

        public Point2D getPoint2​()
        返回锚定第二种颜色的点P2的副本。
        结果
        一个Point2D对象，它是锚定此GradientPaint的第二个颜色的点的副本。

      • getColor2

        public Color getColor2​()
        返回由点P2锚定的颜色C2。
        结果
        一个 Color对象，是由P2锚定的颜色。

      • isCyclic

        public boolean isCyclic​()
        如果梯度在两种颜色C1和C2之间重复循环，则返回 true 。
        结果
        true如果梯度在两种颜色之间重复循环; false否则。

      • createContext

        public PaintContext createContext​(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform xform,
                                  RenderingHints hints)
        创建并返回一个用于生成线性颜色渐变模式的PaintContext 。 见specification方法在Paint界面上的空参数处理信息。
        Specified by:
        createContext接口 Paint
        参数
        cm - 首选的ColorModel ，表示呼叫者接收像素数据最方便的格式，如果没有偏好，则表示null 。
        deviceBounds - 正在渲染的图形基元的设备空间边界框。
        userBounds - 呈现的图形基元的用户空间边界框。
        xform - 从用户空间到设备空间的AffineTransform 。
        hints - 上下文对象可用于在呈现替代方案之间进行选择的一组提示。
        结果
        用于生成颜色图案的 PaintContext 。
        另请参见：
        Paint ， PaintContext ， ColorModel ， Rectangle ， Rectangle2D ， AffineTransform ， RenderingHints

      • getTransparency

        public int getTransparency​()
        返回此 GradientPaint的透明度模式。
        Specified by:
        getTransparency在接口 Transparency
        结果
        一个整数值，表示这个 GradientPaint对象的透明度模式。
        另请参见：
        Transparency
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Graphics2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Graphics2D

  • java.lang.Object
    • java.awt.Graphics
      • java.awt.Graphics2D

  • public abstract class Graphics2D
extends Graphics
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。 这是在Java（tm）平台上呈现二维形状，文字和图像的基础类。

    坐标空间

    传递给Graphics2D对象的所有坐标均在与设备无关的称为“用户空间”的坐标系中指定，由应用程序使用。 Graphics2D对象包含一个AffineTransform对象作为其渲染状态的一部分，它定义了如何将坐标从用户空间转换为设备空间中与设备相关的坐标。

    设备空间中的坐标通常是指单个设备像素，并且在这些像素之间的无限薄的间隙上对齐。 可以使用一些Graphics2D对象来捕获用于存储到图形元文件中的渲染操作，以便稍后在未知物理分辨率的具体设备上播放。 由于在捕获渲染操作时可能不知道分辨率，因此设置Graphics2D Transform将用户坐标转换为逼近目标设备的预期分辨率的虚拟设备空间。 如果估计不正确，则可能需要在播放时应用进一步的转换。

    渲染属性对象执行的一些操作发生在设备空间中，但所有Graphics2D方法都采用用户空间坐标。

    每个Graphics2D对象与定义渲染发生位置的目标相关联。 一个GraphicsConfiguration对象定义了渲染目标的特征，如像素格式和分辨率。 在一个Graphics2D对象的整个生命周期中使用相同的渲染目标。

    当创建一个Graphics2D目的， GraphicsConfiguration指定default transform为目标Graphics2D （一个Component或Image ）。 此默认变换将用户空间坐标系映射到屏幕和打印机设备坐标，使原点映射到设备目标区域的左上角，增加X坐标向右延伸，Y坐标向下延伸。 默认转换的缩放设置为接近72 dpi的设备（如屏幕设备）的标识。 对于高分辨率设备（如打印机），默认变换的缩放设置为每平方英寸约72个用户空间坐标。 对于图像缓冲区，默认变换是Identity变换。

    渲染过程

    渲染过程可以分解为由Graphics2D渲染属性控制的四个阶段。 渲染器可以通过将结果缓存为将来的调用，通过将多个虚拟步骤折叠为单个操作，或通过将各种属性识别为通过修改操作的其他部分可以消除的常见简单情况来优化许多这些步骤。

    渲染过程中的步骤如下：

    1. 确定要呈现的内容
    2. 将渲染操作约束到当前的Clip 。 该Clip由指定Shape在用户空间中，并通过使用各种夹操作方法的程序控制Graphics和Graphics2D 。 该用户剪辑由当前的Transform转换为设备空间，并与由Windows和设备扩展区的可见性定义的设备片段组合。 用户剪辑和设备剪辑的组合定义了复合剪辑 ，该剪辑确定了最终裁剪区域。 渲染系统不会修改用户剪辑以反映所生成的复合剪辑。
    3. 确定要呈现的颜色。
    4. 使用Graphics2D上下文中的当前Composite属性将颜色应用于目标绘图面。

    这三种渲染操作，以及它们每个特定渲染过程的细节是：
    1. Shape operations
      1. 如果该操作是一个draw(Shape)操作，则createStrokedShape上的当前方法Stroke在属性Graphics2D用于上下文构造新Shape对象包含指定的轮廓Shape 。
      2. Shape使用Graphics2D上下文中的当前Transform从用户空间转换为设备空间。
      3. 所述的轮廓Shape使用所提取的getPathIterator的方法Shape ，它返回一个PathIterator对象迭代沿的边界Shape 。
      4. 如果Graphics2D对象不能处理弯曲区段，所述PathIterator对象返回然后它可以调用备用getPathIterator的方法Shape ，其展平了Shape 。
      5. 查询Graphics2D上下文中的当前Paint查询PaintContext ，它指定在设备空间中呈现的颜色。
    2. Text operations
      1. 以下步骤用于确定呈现所指示的String所需的字形集：
        1. 如果参数是String ，那么当前Font在Graphics2D背景下被要求在中的Unicode字符转换String与任何基本布局和成形算法的字体工具为一组字形的呈现。
        2. 如果参数是一个AttributedCharacterIterator ，迭代器被要求使用其嵌入的字体属性将其自身转换为TextLayout 。 TextLayout实现了更复杂的字形布局算法，可以针对不同写入方向的多种字体自动执行Unicode双向布局调整。
        3. 如果参数是GlyphVector ，则GlyphVector对象已经包含适当的字体特定字形代码，其具有每个字形位置的显式坐标。
      2. 查询当前的Font以获取指示字形的轮廓。 这些轮廓在用户空间中被视为相对于在步骤1中确定的每个字形的位置的形状。
      3. 字符轮廓填充如上所述Shape operations 。
      4. 当前的Paint被查询了一个PaintContext ，它指定了在设备空间中渲染的颜色。
    3. Image Operations
      1. 感兴趣区域由源Image的边界框定义。 图像空间中指定了这个边界框，它是Image对象的局部坐标系。
      2. 如果AffineTransform传递给drawImage(Image, AffineTransform, ImageObserver) ，则AffineTransform用于将边界框从图像空间转换为用户空间。 如果没有提供AffineTransform ，则边界框被视为已经在用户空间中。
      3. 源Image的边界框使用当前的Transform从用户空间转换为设备空间。 注意，转换边界框的结果不一定导致设备空间中的矩形区域。
      4. Image对象确定要渲染的颜色，根据当前Transform指定的源到目标坐标映射和可选图像变换进行采样。

    默认渲染属性

    Graphics2D呈现属性的默认值为：
    Paint
    颜色为Component 。
    Font
    Font的Component 。
    Stroke
    线宽为1的方形笔，没有冲击，斜切段连接和方形端盖。
    Transform
    getDefaultTransform为GraphicsConfiguration的Component 。
    Composite
    AlphaComposite.SRC_OVER规则。
    Clip
    没有渲染Clip ，输出被剪切到Component 。

    呈现兼容性问题

    JDK（tm）1.1渲染模型基于一个像素化模型，它指定坐标无限薄，位于像素之间。 绘图操作使用一像素宽的笔来执行，该笔填充路径上的锚点下方和右侧的像素。 JDK 1.1渲染模型与大多数现有的平台渲染器类的能力一致，这些渲染器需要将整数坐标解析为完全落在指定像素数量上的离散笔。

    Java 2D（tm）（Java（tm）2平台）API支持抗锯齿渲染器。 与像素N + 1相反，宽度为一个像素的笔不需要完全落在像素N上。 笔可以部分地落在两个像素上。 不需要为宽笔选择偏移方向，因为沿着笔遍历边缘发生的混合使笔的子像素位置对用户可见。 另一方面，当通过将27048499274646提示键设置为VALUE_ANTIALIAS_OFF提示值来关闭抗锯齿时，渲染器可能需要应用偏移来确定当笔跨越像素边界时要修改的像素，例如当它是沿设备空间中的整数坐标绘制。 虽然抗锯齿渲染器的能力使得渲染模型不再需要为笔指定偏置，但是对于绘制一像素宽水平的常见情况，抗锯齿和非抗锯齿渲染器是理想的，垂直线在屏幕上。 为了确保通过将KEY_ANTIALIASING提示键设置为VALUE_ANTIALIAS_ON来启用抗锯齿功能并不会导致这样的线突然变成两倍宽和一半作为不透明，所以最好让该模型指定这样的线路，以便它们完全覆盖一个特定的一组像素，以帮助增加它们的脆度。

    Java 2D API保持与JDK 1.1呈现行为的兼容性，使得Java 2D API下的旧操作和现有渲染器行为不变。 定义映射到一般的draw和fill方法的传统方法，这清楚地表明Graphics2D如何基于Stroke和Transform属性和渲染提示的设置来扩展Graphics 。 该定义在默认属性设置下执行相同。 例如，默认的Stroke是BasicStroke ，宽度为1，没有BasicStroke ，屏幕绘图的默认转换是Identity变换。

    以下两个规则提供可预测的渲染行为，无论是否使用混叠或抗锯齿。

    • 设备坐标定义在设备像素之间，避免了别名和抗锯齿渲染之间的任何不一致的结果。 如果将坐标定义为像素的中心，则某个形状（例如矩形）覆盖的某些像素将仅覆盖一半。 使用别名渲染，半个被覆盖的像素将被呈现在形状内部或形状外部。 使用抗锯齿渲染，形状的整个边缘上的像素将被覆盖。 另一方面，由于坐标被定义在像素之间，像矩形的形状不会有半个被覆盖的像素，无论其是否使用抗锯齿渲染。
    • 使用BasicStroke对象绘制的线条和路径可能被“归一化”，以便在定位在可绘制的各个点上时提供轮廓的一致呈现，以及是否使用锯齿或锯齿绘制。 此归一化过程由KEY_STROKE_CONTROL提示控制。 没有规定精确的归一化算法，但是这种规范化的目标是确保线条呈现出一致的视觉外观，无论它们如何落在像素网格上，并且以抗锯齿模式促进更稳定的水平和垂直线，使得它们类似于他们的非抗锯齿的对手更紧密。 典型的归一化步骤可以将像素中心的抗锯齿线端点促进以减少混合的量或调整非抗锯齿线的子像素定位，使得浮点线宽度相当于偶数或奇数像素计数。 该过程可以将端点移动高达半个像素（通常沿着两个轴向正无穷大），以促进这些一致的结果。

    一般遗留方法的以下定义与默认属性设置下的以前指定的行为相同：

    • 对于fill操作，包括fillRect ， fillRoundRect ， fillOval ， fillArc ， fillPolygon ，并clearRect ， fill现在可以与所需称为Shape 。 例如，填充矩形时：
        fill(new Rectangle(x, y, w, h));
      叫做。
    • 同样，对于平局操作，包括drawLine ， drawRect ， drawRoundRect ， drawOval ， drawArc ， drawPolyline ，并drawPolygon ， draw现在可以与所需称为Shape 。 例如，绘制矩形时：
        draw(new Rectangle(x, y, w, h));
      叫做。
    • 该draw3DRect个fill3DRect方法是在条款实施drawLine种fillRect方法在Graphics类会在当前谓语他们的行为Stroke个Paint的对象Graphics2D环境。 该类覆盖那些使用当前的Color版本的实现，覆盖当前的Paint ，并且使用fillRect来描述与预先存在的方法完全相同的行为，而不管当前的Stroke的设置Stroke 。
    Graphics类仅定义了setColor方法来控制要绘制的颜色。 由于Java 2D API扩展了Color对象以实现新的Paint接口，现有的setColor方法现在是将当前Paint属性设置为Color对象的便利方法。 setColor(c)相当于setPaint(c) 。

    Graphics类定义了两种方法来控制如何将颜色应用于目标。

    1. 实现setPaintMode方法作为设置默认值Composite的方便方法，相当于setComposite(new AlphaComposite.SrcOver) 。
    2. setXORMode(Color xorcolor)方法被实现为一种方便的方法来设置一个特殊的Composite对象，它忽略源颜色的Alpha组件，并将目标颜色设置为值：
        dstpixel = (PixelOf(srccolor) ^ PixelOf(xorcolor) ^ dstpixel);
    另请参见：
    RenderingHints

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Graphics2D​()
      构造一个新的 Graphics2D对象。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void addRenderingHints​(Map<?,?> hints)
      为渲染算法设置任意数量的首选项的值。
      abstract void clip​(Shape s)
      将当前的 Clip与内部指定的 Shape ，并将 Clip设置为 Clip的交点。
      abstract void draw​(Shape s)
      使用当前的 Graphics2D上下文的设置来 Shape的轮廓。
      void draw3DRect​(int x, int y, int width, int height, boolean raised)
      绘制指定矩形的3-D高亮轮廓。
      abstract void drawGlyphVector​(GlyphVector g, float x, float y)
      使用Graphics2D上下文的渲染属性呈现指定的GlyphVector的文本。
      abstract void drawImage​(BufferedImage img, BufferedImageOp op, int x, int y)
      呈现一个BufferedImage ，用BufferedImageOp过滤。
      abstract boolean drawImage​(Image img, AffineTransform xform, ImageObserver obs)
      渲染图像，在绘制之前将图像空间的变换应用到用户空间中。
      abstract void drawRenderableImage​(RenderableImage img, AffineTransform xform)
      渲染一个RenderableImage ，在绘制之前将图像空间的变换应用到用户空间。
      abstract void drawRenderedImage​(RenderedImage img, AffineTransform xform)
      渲染一个RenderedImage ，在绘制之前将图像空间的变换应用到用户空间。
      abstract void drawString​(String str, float x, float y)
      使用 Graphics2D上下文中的当前文本属性状态呈现由指定的 String指定的文本。
      abstract void drawString​(String str, int x, int y)
      使用 Graphics2D上下文中的当前文本属性状态呈现指定的 String的文本。
      abstract void drawString​(AttributedCharacterIterator iterator, float x, float y)
      根据TextAttribute类的规范，渲染指定迭代器的文本，以应用其属性。
      abstract void drawString​(AttributedCharacterIterator iterator, int x, int y)
      根据TextAttribute类的规范，渲染指定迭代器的文本应用其属性。
      abstract void fill​(Shape s)
      使用 Graphics2D上下文的设置填充 Shape的内部。
      void fill3DRect​(int x, int y, int width, int height, boolean raised)
      绘制一个填充有当前颜色的3-D高亮矩形。
      abstract Color getBackground​()
      返回用于清除区域的背景颜色。
      abstract Composite getComposite​()
      返回当前 Composite在 Graphics2D环境。
      abstract GraphicsConfiguration getDeviceConfiguration​()
      返回与此 Graphics2D关联的设备配置。
      abstract FontRenderContext getFontRenderContext​()
      获取的渲染上下文 Font这个范围内 Graphics2D上下文。
      abstract Paint getPaint​()
      返回当前 Paint的的 Graphics2D环境。
      abstract Object getRenderingHint​(RenderingHints.Key hintKey)
      返回渲染算法的单个首选项的值。
      abstract RenderingHints getRenderingHints​()
      获取渲染算法的首选项。
      abstract Stroke getStroke​()
      返回 Graphics2D上下文中的当前 Stroke 。
      abstract AffineTransform getTransform​()
      返回 Graphics2D上下文中当前 Transform的 Graphics2D 。
      abstract boolean hit​(Rectangle rect, Shape s, boolean onStroke)
      检查指定的Shape是否与设备空间中指定的Shape相交。
      abstract void rotate​(double theta)
      使用旋转变换连接当前的 Graphics2D Transform 。
      abstract void rotate​(double theta, double x, double y)
      将当前的 Graphics2D Transform与转换的旋转变换连接起来。
      abstract void scale​(double sx, double sy)
      使用缩放变换连接当前的 Graphics2D Transform随后的渲染根据相对于之前的缩放比例的指定缩放因子调整大小。
      abstract void setBackground​(Color color)
      设置 Graphics2D上下文的背景颜色。
      abstract void setComposite​(Composite comp)
      设置 Composite为 Graphics2D的上下文。
      abstract void setPaint​(Paint paint)
      为 Graphics2D上下文设置 Paint属性。
      abstract void setRenderingHint​(RenderingHints.Key hintKey, Object hintValue)
      为渲染算法设置单个首选项的值。
      abstract void setRenderingHints​(Map<?,?> hints)
      用指定的 hints替换渲染算法的所有首选项的值。
      abstract void setStroke​(Stroke s)
      设置 Stroke为 Graphics2D的上下文。
      abstract void setTransform​(AffineTransform Tx)
      覆盖 Graphics2D上下文中的变换。
      abstract void shear​(double shx, double shy)
      使用剪切变换连接当前的 Graphics2D Transform 。
      abstract void transform​(AffineTransform Tx)
      组成一个 AffineTransform与对象 Transform在此 Graphics2D根据规则最后指定第一涂覆。
      abstract void translate​(double tx, double ty)
      将当前的 Graphics2D Transform与平移变换相结合。
      abstract void translate​(int x, int y)
      将 Graphics2D上下文的原点转换为当前坐标系中的点（ x ， y ）。

      • Methods inherited from class java.awt.Graphics

        clearRect, clipRect, copyArea, create, create, dispose, drawArc, drawBytes, drawChars, drawImage, drawImage, drawImage, drawImage, drawImage, drawImage, drawLine, drawOval, drawPolygon, drawPolygon, drawPolyline, drawRect, drawRoundRect, fillArc, fillOval, fillPolygon, fillPolygon, fillRect, fillRoundRect, finalize, getClip, getClipBounds, getClipBounds, getClipRect, getColor, getFont, getFontMetrics, getFontMetrics, hitClip, setClip, setClip, setColor, setFont, setPaintMode, setXORMode, toString

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Graphics2D

        protected Graphics2D​()
        构造一个新的Graphics2D对象。 由于Graphics2D是一个抽象类，并且由于必须由不同输出设备的子类定制，因此无法直接创建Graphics2D对象。 相反， Graphics2D对象必须从另一个Graphics2D对象获取，由Component创建，或从图像获取，如BufferedImage对象。
        另请参见：
        Component.getGraphics() ， Graphics.create()

    • 方法详细信息

      • draw3DRect

        public void draw3DRect​(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
        绘制指定矩形的3-D高亮轮廓。 矩形的边缘被突出显示，使得它们看起来是从左上角倾斜并点亮。

        用于突出显示效果的颜色是根据当前颜色确定的。 最终的矩形覆盖了width + 1像素宽， height + 1像素高的区域。 该方法使用当前的Color ，忽略当前的Paint 。

        重写：
        draw3DRect在 Graphics
        参数
        x - 要绘制的矩形的x坐标。
        y - 要绘制的矩形的y坐标。
        width - 要绘制的矩形的宽度。
        height - 要绘制的矩形的高度。
        raised - 一个布尔值，用于确定矩形是否显示为高于表面或沉入表面。
        另请参见：
        Graphics.fill3DRect(int, int, int, int, boolean)

      • fill3DRect

        public void fill3DRect​(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
        绘制一个填充有当前颜色的3-D高亮矩形。 矩形的边缘被突出显示，使其看起来好像边缘是从左上角倾斜并点亮。 用于突出显示效果和填充的颜色由当前的Color确定。 此方法仅使用当前的Color并忽略当前的Paint 。
        重写：
        fill3DRect在 Graphics
        参数
        x - 要填充的矩形的x坐标。
        y - 要填充的矩形的y坐标。
        width - 要填充的矩形的宽度。
        height - 要填充的矩形的高度。
        raised - 一个布尔值，用于确定矩形是否在表面上方凸起或蚀刻到表面中。
        另请参见：
        Graphics.draw3DRect(int, int, int, int, boolean)

      • draw

        public abstract void draw​(Shape s)
        使用当前的Graphics2D上下文的设置来Shape的轮廓。 应用的渲染属性包括Clip ， Transform ， Paint ， Composite和Stroke属性。
        参数
        s - 要呈现的 Shape
        另请参见：
        setStroke(java.awt.Stroke) ，
setPaint(java.awt.Paint) ，
Graphics.setColor(java.awt.Color) ，
transform(java.awt.geom.AffineTransform) ，
setTransform(java.awt.geom.AffineTransform) ，
clip(java.awt.Shape) ，
Graphics.setClip(int, int, int, int) ，
setComposite(java.awt.Composite)

      • drawImage

        public abstract boolean drawImage​(Image img,
                                  AffineTransform xform,
                                  ImageObserver obs)
        渲染图像，在绘制之前将图像空间的变换应用到用户空间中。 从用户空间变换到设备空间与当前进行Transform在Graphics2D 。 在应用Graphics2D上下文中的transform属性之前，将指定的变换应用于图像。 应用的呈现属性包括： Clip ， Transform ，并Composite属性。 请注意，如果指定的变换是不可转换的，则不执行渲染。
        参数
        img - 要呈现的指定图像。 如果img为空，此方法不起作用。
        xform - 从图像空间到用户空间的转换
        obs - ImageObserver被通知为更多的Image被转换
        结果
        true如果Image完全加载并完全呈现，或者如果它为null; false如果Image仍在加载。
        另请参见：
        transform(java.awt.geom.AffineTransform) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
clip(java.awt.Shape) ，
Graphics.setClip(int, int, int, int)

      • drawImage

        public abstract void drawImage​(BufferedImage img,
                               BufferedImageOp op,
                               int x,
                               int y)
        呈现一个BufferedImage ，用BufferedImageOp进行过滤。 应用的呈现属性包括： Clip ， Transform和Composite属性。 这相当于：
          img1 = op.filter(img, null);
 drawImage(img1, new AffineTransform(1f,0f,0f,1f,x,y), null);
        参数
        op - 渲染之前应用于图像的过滤器
        img - 要呈现的指定的BufferedImage 。 如果img为null，则此方法不起作用。
        x - 渲染图像左上角的用户空间中的位置的x坐标
        y - 渲染图像左上角的用户空间中的位置的y坐标
        另请参见：
        transform(java.awt.geom.AffineTransform) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
clip(java.awt.Shape) ，
Graphics.setClip(int, int, int, int)

      • drawRenderedImage

        public abstract void drawRenderedImage​(RenderedImage img,
                                       AffineTransform xform)
        渲染一个RenderedImage ，在绘制之前将图像空间的变换应用到用户空间中。 从用户空间变换到设备空间与当前进行Transform在Graphics2D 。 在应用Graphics2D上下文中的transform属性之前，将指定的变换应用于图像。 应用的呈现属性包括： Clip ， Transform ，并Composite属性。 请注意，如果指定的变换是不可转换的，则不执行渲染。
        参数
        img - 要呈现的图像。 如果img为null，则此方法不起作用。
        xform - 从图像空间到用户空间的转换
        另请参见：
        transform(java.awt.geom.AffineTransform) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
clip(java.awt.Shape) ，
Graphics.setClip(int, int, int, int)

      • drawRenderableImage

        public abstract void drawRenderableImage​(RenderableImage img,
                                         AffineTransform xform)
        渲染一个RenderableImage ，在绘制之前将图像空间的变换应用到用户空间。 从用户空间变换到设备空间与当前进行Transform在Graphics2D 。 在应用Graphics2D上下文中的transform属性之前，将指定的转换应用于图像。 应用的呈现属性包括： Clip ， Transform ，并Composite属性。 请注意，如果指定的变换是不可转换的，则不执行渲染。

        在Graphics2D对象上设置的渲染提示可能用于渲染RenderableImage 。 如果显式控制需要在由一个特定的识别特定提示RenderableImage ，或者如果需要，其中用于提示知识，则RenderedImage应直接从所获得的RenderableImage使用和呈现drawRenderedImage 。

        参数
        img - 要呈现的图像。 如果img为空，此方法不起作用。
        xform - 从图像空间到用户空间的转换
        另请参见：
        transform(java.awt.geom.AffineTransform) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
clip(java.awt.Shape) ，
Graphics.setClip(int, int, int, int) ，
drawRenderedImage(java.awt.image.RenderedImage, java.awt.geom.AffineTransform)

      • drawString

        public abstract void drawString​(String str,
                                int x,
                                int y)
        使用Graphics2D上下文中的当前文本属性状态呈现指定的String的文本。 第一个字符的基线在用户空间中的位置（ x ， y ）。 应用的渲染属性包括Clip ， Transform ， Paint ， Font和Composite属性。 对于诸如希伯来语和阿拉伯语的脚本系统中的字符，字形可以从右到左呈现，在这种情况下，提供的坐标是基线上最左边的字符的位置。
        Specified by:
        drawString在 Graphics
        参数
        str - 要呈现的字符串
        x - 应该呈现 String的位置的x坐标
        y - 应该呈现 String的位置的y坐标
        异常
        NullPointerException - 如果 str是 null
        从以下版本开始：
        1.0
        另请参见：
        Graphics.drawBytes(byte[], int, int, int, int) ， Graphics.drawChars(char[], int, int, int, int)

      • drawString

        public abstract void drawString​(String str,
                                float x,
                                float y)
        使用Graphics2D上下文中的当前文本属性状态呈现由指定的String指定的文本。 第一个字符的基线在用户空间中的位置（ x ， y ）。 应用的渲染属性包括Clip ， Transform ， Paint ， Font和Composite属性。 对于诸如希伯来语和阿拉伯语的脚本系统中的字符，字形可以从右到左呈现，在这种情况下，提供的坐标是基线上最左边的字符的位置。
        参数
        str - 要呈现的 String
        x - 应该呈现 String的位置的x坐标
        y - 应该呈现 String的位置的y坐标
        异常
        NullPointerException - 如果 str是 null
        另请参见：
        setPaint(java.awt.Paint) ，
Graphics.setColor(java.awt.Color) ，
Graphics.setFont(java.awt.Font) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
Graphics.setClip(int, int, int, int)

      • drawString

        public abstract void drawString​(AttributedCharacterIterator iterator,
                                int x,
                                int y)
        根据TextAttribute类的规范，渲染指定迭代器的文本，以应用其属性。

        第一个字符的基线位于用户空间中的位置（ x ， y ）。 对于诸如希伯来语和阿拉伯语的脚本系统中的字符，字形可以从右到左呈现，在这种情况下，提供的坐标是基线上最左边的字符的位置。

        Specified by:
        drawString在 Graphics
        参数
        iterator - 要呈现其文本的迭代器
        x - 要呈现迭代器文本的x坐标
        y - 要呈现迭代器文本的y坐标
        异常
        NullPointerException - 如果 iterator是 null
        另请参见：
        setPaint(java.awt.Paint) ，
Graphics.setColor(java.awt.Color) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
Graphics.setClip(int, int, int, int)

      • drawString

        public abstract void drawString​(AttributedCharacterIterator iterator,
                                float x,
                                float y)
        根据TextAttribute类的规范，渲染指定迭代器的文本应用其属性。

        第一个字符的基线位于用户空间中的位置（ x ， y ）。 对于诸如希伯来语和阿拉伯语的脚本系统中的字符，字形可以从右到左呈现，在这种情况下，提供的坐标是基线上最左边的字符的位置。

        参数
        iterator - 要呈现其文本的迭代器
        x - 要呈现迭代器文本的x坐标
        y - 要呈现迭代器文本的y坐标
        异常
        NullPointerException - 如果 iterator是 null
        另请参见：
        setPaint(java.awt.Paint) ，
Graphics.setColor(java.awt.Color) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
Graphics.setClip(int, int, int, int)

      • drawGlyphVector

        public abstract void drawGlyphVector​(GlyphVector g,
                                     float x,
                                     float y)
        使用Graphics2D上下文的渲染属性渲染指定的GlyphVector的文本。 应用的呈现属性包括： Clip ， Transform ， Paint ，并Composite属性。 该GlyphVector规定从各个字形Font 。 GlyphVector也可以包含字形位置。 这是将一组字符呈现给屏幕的最快方式。
        参数
        g - 要呈现的 GlyphVector
        x - 用户空间中应该呈现字形的x位置
        y - 用户空间中应显示字形的y位置
        异常
        NullPointerException - 如果 g是 null 。
        另请参见：
        Font.createGlyphVector(java.awt.font.FontRenderContext, java.lang.String) ， GlyphVector ， setPaint(java.awt.Paint) ， Graphics.setColor(java.awt.Color) ， setTransform(java.awt.geom.AffineTransform) ， setComposite(java.awt.Composite) ， Graphics.setClip(int, int, int, int)

      • fill

        public abstract void fill​(Shape s)
        使用Graphics2D上下文的设置填充Shape的内部。 应用的呈现属性包括： Clip ， Transform ， Paint ，并Composite 。
        参数
        s - 要填充的 Shape
        另请参见：
        setPaint(java.awt.Paint) ，
Graphics.setColor(java.awt.Color) ，
transform(java.awt.geom.AffineTransform) ，
setTransform(java.awt.geom.AffineTransform) ，
setComposite(java.awt.Composite) ，
clip(java.awt.Shape) ，
Graphics.setClip(int, int, int, int)

      • hit

        public abstract boolean hit​(Rectangle rect,
                            Shape s,
                            boolean onStroke)
        检查指定的Shape是否与设备空间中指定的Shape相交。 如果onStroke是假的，指定的内部此方法检查是否Shape相交指定Rectangle 。 如果onStroke是true ，该方法检查是否Stroke指定的Shape轮廓相交指定Rectangle 。 考虑到的呈现属性包括： Clip ， Transform ，并Stroke属性。
        参数
        rect - 设备空间中检查命中的区域
        s - Shape检查命中
        onStroke - 用于选择测试之间的标记或填充形状的标志。 如果标志是true ，则对Stroke轮廓进行测试。 如果标志为false ，则填充Shape进行测试。
        结果
        true如果有打击; false否则。
        另请参见：
        setStroke(java.awt.Stroke) ，
fill(java.awt.Shape) ，
draw(java.awt.Shape) ，
transform(java.awt.geom.AffineTransform) ，
setTransform(java.awt.geom.AffineTransform) ，
clip(java.awt.Shape) ，
Graphics.setClip(int, int, int, int)

      • getDeviceConfiguration

        public abstract GraphicsConfiguration getDeviceConfiguration​()
        返回与此 Graphics2D关联的设备配置。
        结果
        该设备配置为 Graphics2D 。

      • setComposite

        public abstract void setComposite​(Composite comp)
        为Composite设置Graphics2D上下文。 该Composite被所有的绘图方法，如所用drawImage ， drawString ， draw ，和fill 。 它指定在渲染过程中如何将新像素与图形设备上的现有像素组合。

        如果这个Graphics2D上下文在显示屏上绘制了一个Component ，而Composite是一个自定义对象，而不是一个AlphaComposite类的实例，如果有一个安全管理器，它的checkPermission方法被调用一个AWTPermission("readDisplayPixels")权限。

        参数
        comp - 用于渲染的 Composite对象
        异常
        SecurityException - 如果使用自定义的 Composite对象渲染到屏幕并设置了安全管理器，并且其 checkPermission方法不允许操作。
        另请参见：
        Graphics.setXORMode(java.awt.Color) ， Graphics.setPaintMode() ， getComposite() ， AlphaComposite ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • setPaint

        public abstract void setPaint​(Paint paint)
        设置Graphics2D上下文的Paint属性。 使用null Paint对象调用此方法对此Graphics2D的当前Paint属性没有任何影响。
        参数
        paint - 在绘制过程中要用于生成颜色的 Paint对象，或 null
        另请参见：
        Graphics.setColor(java.awt.Color) ， getPaint() ， GradientPaint ， TexturePaint

      • setStroke

        public abstract void setStroke​(Stroke s)
        设置 Stroke为 Graphics2D的上下文。
        参数
        s -所述 Stroke对象要用于中风 Shape在呈现过程中
        另请参见：
        BasicStroke ， getStroke()

      • setRenderingHint

        public abstract void setRenderingHint​(RenderingHints.Key hintKey,
                                      Object hintValue)
        为渲染算法设置单个首选项的值。 提示类别包括渲染过程中渲染质量和总体时间/质量权衡的控件。 有关一些常用键和值的定义，请参阅RenderingHints类。
        参数
        hintKey - 提示设置的关键。
        hintValue - 指示指定提示类别的首选项的值。
        另请参见：
        getRenderingHint(RenderingHints.Key) ， RenderingHints

      • getRenderingHint

        public abstract Object getRenderingHint​(RenderingHints.Key hintKey)
        返回渲染算法的单个首选项的值。 提示类别包括渲染过程中渲染质量和总体时间/质量权衡的控件。 有关某些常用键和值的定义，请参阅RenderingHints类。
        参数
        hintKey - 对应的提示的提示。
        结果
        表示指定提示键的值的对象。 一些键及其相关值在RenderingHints类中定义。
        另请参见：
        RenderingHints ， setRenderingHint(RenderingHints.Key, Object)

      • setRenderingHints

        public abstract void setRenderingHints​(Map<?,?> hints)
        用指定的hints替换渲染算法的所有首选项的值。 丢弃所有渲染提示的现有值，并从指定的Map对象初始化新的一组已知提示和值。 提示类别包括渲染过程中渲染质量和总体时间/质量权衡的控件。 有关常用键和值的定义，请参阅RenderingHints类。
        参数
        hints - 渲染提示要设置
        另请参见：
        getRenderingHints() ， RenderingHints

      • addRenderingHints

        public abstract void addRenderingHints​(Map<?,?> hints)
        为渲染算法设置任意数量的首选项的值。 仅修改指定的Map对象中存在的渲染提示的值。 不存在于指定对象中的所有其他首选项未修改。 提示类别包括渲染过程中渲染质量和总体时间/质量权衡的控件。 有关常用键和值的定义，请参阅RenderingHints类。
        参数
        hints - 渲染提示要设置
        另请参见：
        RenderingHints

      • getRenderingHints

        public abstract RenderingHints getRenderingHints​()
        获取渲染算法的首选项。 提示类别包括渲染过程中渲染质量和总体时间/质量权衡的控件。 返回在一个操作中指定的所有提示键/值对。 有关公用键和值的定义，请参阅RenderingHints类。
        结果
        对包含当前首选项的 RenderingHints的实例的引用。
        另请参见：
        RenderingHints ， setRenderingHints(Map)

      • translate

        public abstract void translate​(int x,
                               int y)
        将Graphics2D上下文的原点转换为当前坐标系中的点（ x ， y ）。 修改Graphics2D上下文，使其新的起始对应于Graphics2D上下文的前坐标系中的点（ x ， y ）。 在这种图形上下文中的后续渲染操作中使用的所有坐标都是相对于这个新的起点。
        Specified by:
        translate在 Graphics
        参数
        x - 指定的x坐标
        y - 指定的y坐标
        从以下版本开始：
        1.0

      • translate

        public abstract void translate​(double tx,
                               double ty)
        将当前的Graphics2D Transform与平移变换Graphics2D Transform 。 随后的渲染相对于前一位置转换指定的距离。 这相当于调用transform（T），其中T是由以下矩阵表示的AffineTransform ：
          [   1    0    tx  ]
          [   0    1    ty  ]
          [   0    0    1   ]
        参数
        tx - 沿x轴平移的距离
        ty - 沿y轴平移的距离

      • rotate

        public abstract void rotate​(double theta)
        连接当前的Graphics2D Transform与旋转变换。 随后的渲染相对于以前的原点旋转指定的弧度。 这相当于调用transform(R) ，其中R是由以下矩阵表示的AffineTransform ：
          [   cos(theta)    -sin(theta)    0   ]
          [   sin(theta)     cos(theta)    0   ]
          [       0              0         1   ]
        以正角度θ旋转正X轴上的点朝着正y轴旋转。
        参数
        theta - 以弧度表示的旋转角度

      • rotate

        public abstract void rotate​(double theta,
                            double x,
                            double y)
        将当前的Graphics2D Transform与平移的旋转变换连接起来。 随后的渲染由通过转换到指定位置，以指定弧度旋转并以与原始翻译相同的量翻译构造的变换来变换。 这相当于下列呼叫序列：
          translate(x, y);
          rotate(theta);
          translate(-x, -y);
        以正角度θ旋转正X轴上的点朝着正y轴旋转。
        参数
        theta - 以弧度表示的旋转角度
        x - 旋转原点的x坐标
        y - 旋转原点的y坐标

      • scale

        public abstract void scale​(double sx,
                           double sy)
        使用缩放变换连接当前的Graphics2D Transform后续渲染根据相对于以前缩放的指定缩放因子进行调整大小。 这相当于调用transform(S) ，其中S是由以下矩阵表示的AffineTransform ：
          [   sx   0    0   ]
          [   0    sy   0   ]
          [   0    0    1   ]
        参数
        sx - 后续渲染操作中的X坐标相对于以前的渲染操作相乘的量。
        sy - 后续渲染操作中Y坐标相对于以前的渲染操作相乘的量。

      • shear

        public abstract void shear​(double shx,
                           double shy)
        使用剪切变换连接当前的Graphics2D Transform 。 随后的渲染由相对于前一位置的指定乘数剪切。 这相当于调用transform(SH) ，其中SH是由以下矩阵表示的AffineTransform ：
          [   1   shx   0   ]
          [  shy   1    0   ]
          [   0    0    1   ]
        参数
        shx - 坐标根据其Y坐标在正X轴方向上移位的乘数
        shy - 坐标在正Y轴方向上移动的乘数作为其X坐标的函数

      • transform

        public abstract void transform​(AffineTransform Tx)
        组成一个AffineTransform与对象Transform在此Graphics2D根据规则最后指定第一涂覆。 如果当前的Transform是Cx，与Tx的组合结果是一个新的Transform Cx'。 Cx'成为Transform的Graphics2D 。 通过更新的Transform Cx'转换点p等价于首先通过Tx转换p，然后将结果转换为原始的Transform Cx。 换句话说，Cx'（p）= Cx（Tx（p））。 如果需要，可以复制Tx，因此对Tx的进一步修改不会影响渲染。
        参数
        Tx - AffineTransform对象由当前组成的 Transform
        另请参见：
        setTransform(java.awt.geom.AffineTransform) ， AffineTransform

      • setTransform

        public abstract void setTransform​(AffineTransform Tx)
        在Graphics2D上下文中覆盖变换。 警告：该方法不应用于在现有转换之上应用新的坐标变换，因为Graphics2D可能已经具有其他目的所需的变换，例如渲染Swing组件或应用缩放变换来调整分辨率的打印机。

        要添加坐标变换，使用transform ， rotate ， scale ，或shear方法。 setTransform方法仅用于在渲染后恢复原始的Graphics2D变换，如下例所示：

          // Get the current transform
 AffineTransform saveAT = g2.getTransform();
 // Perform transformation
 g2d.transform(...);
 // Render
 g2d.draw(...);
 // Restore original transform
 g2d.setTransform(saveAT);
        参数
        Tx -所述 AffineTransform这是从检索 getTransform方法
        另请参见：
        transform(java.awt.geom.AffineTransform) ， getTransform() ， AffineTransform

      • getTransform

        public abstract AffineTransform getTransform​()
        返回 Graphics2D上下文中当前 Transform的 Graphics2D 。
        结果
        目前 AffineTransform在 Graphics2D上下文中。
        另请参见：
        transform(java.awt.geom.AffineTransform) ， setTransform(java.awt.geom.AffineTransform)

      • getPaint

        public abstract Paint getPaint​()
        返回 Graphics2D上下文的当前 Paint 。
        结果
        当前的 Graphics2D Paint ，它定义了颜色或图案。
        另请参见：
        setPaint(java.awt.Paint) ， Graphics.setColor(java.awt.Color)

      • getComposite

        public abstract Composite getComposite​()
        返回 Graphics2D上下文中的当前 Composite 。
        结果
        当前的 Graphics2D Composite ，它定义了合成样式。
        另请参见：
        setComposite(java.awt.Composite)

      • setBackground

        public abstract void setBackground​(Color color)
        设置Graphics2D上下文的背景颜色。 背景颜色用于清除区域。 当为Graphics2D构建一个Component ，背景颜色继承自Component 。 设置在背景色Graphics2D方面仅影响后续clearRect调用，而不是背景色Component 。 要更改Component的背景，请使用适当的方法进行Component 。
        参数
        color - 后续调用中使用的背景颜色 clearRect
        另请参见：
        getBackground() ， Graphics.clearRect(int, int, int, int)

      • getBackground

        public abstract Color getBackground​()
        返回用于清除区域的背景颜色。
        结果
        当前的 Graphics2D Color ，它定义了背景颜色。
        另请参见：
        setBackground(java.awt.Color)

      • getStroke

        public abstract Stroke getStroke​()
        返回 Graphics2D上下文中的当前 Stroke 。
        结果
        目前的 Graphics2D Stroke ，它定义了线条样式。
        另请参见：
        setStroke(java.awt.Stroke)

      • clip

        public abstract void clip​(Shape s)
        将当前的Clip与内部指定的Shape ，并将Clip设置为Clip的交点。 指定的Shape在与当前Graphics2D Transform之前，用当前的Clip 。 该方法用于使当前的Clip更小。 要使Clip较大，请使用setClip 。 通过此方法修改的用户剪辑与与设备边界和可见性相关联的剪辑无关。 如果以前没有设置任何剪辑，或者如果剪辑已经被setClip用null参数清除，则指定的Shape将成为新的用户剪辑。
        参数
        s - Shape要与当前的Clip相交。 如果s为null ，此方法清除电流Clip 。

      • getFontRenderContext

        public abstract FontRenderContext getFontRenderContext​()
        获取此Graphics2D上下文中的Font的呈现上下文。 FontRenderContext封装了抗锯齿和分数指标等应用提示，以及目标设备特定信息，例如每英寸点数。 当使用执行排版格式化的对象（如Font和TextLayout时，该信息应由应用程序提供。 这些信息也应该由执行自己的布局的应用程序提供，并且当各种渲染提示已被应用于文本呈现时，需要对字形的各种特征进行准确的测量，例如提前和行高。
        结果
        引用FontRenderContext的一个实例。
        从以下版本开始：
        1.2
        另请参见：
        FontRenderContext ， Font.createGlyphVector(java.awt.font.FontRenderContext, java.lang.String) ， TextLayout
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Graphics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Graphics

  • java.lang.Object
    • java.awt.Graphics
  • 已知直接子类：
    DebugGraphics ， Graphics2D

    public abstract class Graphics
extends Object
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及屏幕外图像。

    一个Graphics对象封装了Java支持的基本渲染操作所需的状态信息。 该状态信息包括以下属性：

    • 要绘制的Component对象。
    • 用于渲染和剪切坐标的翻译原点。
    • 当前剪辑。
    • 当前的颜色。
    • 当前的字体。
    • 当前的逻辑像素运算功能（XOR或Paint）。
    • 当前XOR交替颜色（见setXORMode(java.awt.Color) ）。

    坐标无限薄，位于输出设备的像素之间。 绘制图形轮廓的操作通过遍历像素之间的无限薄的路径，其中一个像素大小的笔垂直下来并位于路径上的锚点右侧。 填充图形的操作通过填充无限薄路径的内部来操作。 渲染水平文本的操作将字符字形的上升部分全部呈现在基线坐标之上。

    图形笔从其穿过的路径向下垂直向右。 这具有以下含义：

    • 如果您绘制一个涵盖给定矩形的图形，则与填充由同一个矩形界定的图形相比，该图形在右边和底部边缘占据一个额外的像素行。
    • 如果您沿着与文本行基线相同的y坐标绘制水平线，则该行完全在文本下方绘制，除了任何下降。

    显示作为参数传递给该方法的所有坐标Graphics对象，都是相对于这个翻译的起源Graphics之前的方法的调用对象。

    所有渲染操作仅修改位于由当前剪辑限定的区域内的像素，由用户空间中的Shape指定，并由程序使用Graphics对象控制。 该用户剪辑被转换为设备空间并与设备剪辑组合，该剪辑由窗口和设备扩展区的可见性定义。 用户剪辑和设备剪辑的组合定义了复合剪辑 ，该剪辑确定了最终裁剪区域。 渲染系统无法修改用户剪辑以反映所生成的复合剪辑。 用户剪辑只能通过setClip或clipRect方法进行更改。 所有绘图或写入都是以当前颜色，使用当前绘图模式和当前字体完成的。

    从以下版本开始：
    1.0
    另请参见：
    Component ， clipRect(int, int, int, int) ， setColor(java.awt.Color) ， setPaintMode() ， setXORMode(java.awt.Color) ， setFont(java.awt.Font)

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Graphics​()
      构造一个新的 Graphics对象。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      abstract void clearRect​(int x, int y, int width, int height)
      通过填充当前图形表面的背景颜色来清除指定的矩形。
      abstract void clipRect​(int x, int y, int width, int height)
      用指定的矩形相交当前的剪辑。
      abstract void copyArea​(int x, int y, int width, int height, int dx, int dy)
      将组件的一个区域复制 dx和 dy指定的距离。
      abstract Graphics create​()
      创建一个新的 Graphics对象，该对象是此 Graphics对象的副本。
      Graphics create​(int x, int y, int width, int height)
      基于此 Graphics对象创建一个新的 Graphics对象，但使用新的翻译和剪辑区域。
      abstract void dispose​()
      处理此图形上下文并释放其正在使用的任何系统资源。
      void draw3DRect​(int x, int y, int width, int height, boolean raised)
      绘制指定矩形的3-D高亮轮廓。
      abstract void drawArc​(int x, int y, int width, int height, int startAngle, int arcAngle)
      绘制覆盖指定矩形的圆形或椭圆形圆弧的轮廓。
      void drawBytes​(byte[] data, int offset, int length, int x, int y)
      绘制由指定字节数组给出的文本，使用此图形上下文的当前字体和颜色。
      void drawChars​(char[] data, int offset, int length, int x, int y)
      绘制由指定的字符数组给出的文本，使用此图形上下文的当前字体和颜色。
      abstract boolean drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
      abstract boolean drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer)
      按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
      abstract boolean drawImage​(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      绘制与已经缩放以适应指定矩形内的指定图像的大小。
      abstract boolean drawImage​(Image img, int x, int y, int width, int height, ImageObserver observer)
      绘制与已经缩放以适应指定矩形内的指定图像的大小。
      abstract boolean drawImage​(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      绘制当前可用的指定图像的大小。
      abstract boolean drawImage​(Image img, int x, int y, ImageObserver observer)
      绘制当前可用的指定图像的大小。
      abstract void drawLine​(int x1, int y1, int x2, int y2)
      在此图形上下文的坐标系中点 (x1, y1)和 (x2, y2)之间绘制一条线，使用当前颜色。
      abstract void drawOval​(int x, int y, int width, int height)
      绘制椭圆形轮廓。
      abstract void drawPolygon​(int[] xPoints, int[] yPoints, int nPoints)
      绘制由 x和 y坐标数组定义的封闭多边形。
      void drawPolygon​(Polygon p)
      绘制由指定的 Polygon对象定义的多边形的轮廓。
      abstract void drawPolyline​(int[] xPoints, int[] yPoints, int nPoints)
      绘制由 x和 y坐标数组定义的连接线序列。
      void drawRect​(int x, int y, int width, int height)
      绘制指定矩形的轮廓。
      abstract void drawRoundRect​(int x, int y, int width, int height, int arcWidth, int arcHeight)
      使用此图形上下文的当前颜色绘制一个概略的圆角矩形。
      abstract void drawString​(String str, int x, int y)
      使用该图形上下文的当前字体和颜色绘制由指定字符串给出的文本。
      abstract void drawString​(AttributedCharacterIterator iterator, int x, int y)
      渲染指定迭代器的文本，根据TextAttribute类的规范应用其属性。
      void fill3DRect​(int x, int y, int width, int height, boolean raised)
      绘制一个填充有当前颜色的3-D高亮矩形。
      abstract void fillArc​(int x, int y, int width, int height, int startAngle, int arcAngle)
      填写一个圆形或椭圆形的圆弧覆盖指定的矩形。
      abstract void fillOval​(int x, int y, int width, int height)
      用当前颜色填充由指定矩形界定的椭圆。
      abstract void fillPolygon​(int[] xPoints, int[] yPoints, int nPoints)
      填充由 x和 y坐标数组定义的封闭多边形。
      void fillPolygon​(Polygon p)
      使用图形上下文的当前颜色填充由指定的多边形对象定义的多边形。
      abstract void fillRect​(int x, int y, int width, int height)
      填写指定的矩形。
      abstract void fillRoundRect​(int x, int y, int width, int height, int arcWidth, int arcHeight)
      使用当前颜色填充指定的圆角矩形。
      void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      abstract Shape getClip​()
      获取当前的裁剪区域。
      abstract Rectangle getClipBounds​()
      返回当前裁剪区域的边界矩形。
      Rectangle getClipBounds​(Rectangle r)
      返回当前裁剪区域的边界矩形。
      Rectangle getClipRect​()
      已过时。
      从JDK 1.1版开始，由getClipBounds()替代。
      abstract Color getColor​()
      获取此图形上下文的当前颜色。
      abstract Font getFont​()
      获取当前字体。
      FontMetrics getFontMetrics​()
      获取当前字体的字体度量。
      abstract FontMetrics getFontMetrics​(Font f)
      获取指定字体的字体指标。
      boolean hitClip​(int x, int y, int width, int height)
      如果指定的矩形区域可能与当前裁剪区域相交，则返回true。
      abstract void setClip​(int x, int y, int width, int height)
      将当前剪辑设置为由给定坐标指定的矩形。
      abstract void setClip​(Shape clip)
      将当前剪辑区域设置为任意剪辑形状。
      abstract void setColor​(Color c)
      将此图形上下文的当前颜色设置为指定的颜色。
      abstract void setFont​(Font font)
      将此图形上下文的字体设置为指定的字体。
      abstract void setPaintMode​()
      设置此图形上下文的绘制模式，以使用此图形上下文的当前颜色覆盖目标。
      abstract void setXORMode​(Color c1)
      设置此图形上下文的绘制模式，以在此图形上下文的当前颜色和新的指定颜色之间交替显示。
      String toString​()
      返回 String表示此对象 Graphics对象的值。
      abstract void translate​(int x, int y)
      将图形上下文的原点转换为当前坐标系中的点（ x ， y ）。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Graphics

        protected Graphics​()
        构造一个新的Graphics对象。 该构造函数是图形上下文的默认构造函数。

        由于Graphics是一个抽象类，因此应用程序不能直接调用此构造函数。 图形上下文从其他图形上下文中获取，或者通过调用getGraphics上的getGraphics创建。

        另请参见：
        create() ， Component.getGraphics()

    • 方法详细信息

      • create

        public abstract Graphics create​()
        创建一个新的 Graphics对象，该对象是此 Graphics对象的副本。
        结果
        一个新的图形上下文，这是这个图形上下文的副本。

      • create

        public Graphics create​(int x,
                       int y,
                       int width,
                       int height)
        基于此Graphics对象创建一个新的Graphics对象，但使用新的翻译和剪辑区域。 新的Graphics对象的起始点被转换为指定点（ x ， y ）。 其剪辑区域由原始剪辑区域与指定矩形的交集确定。 参数都在原始Graphics对象的坐标系中解释。 新的图形上下文与原始图形相同，不同之处在于：
        • 新的图形上下文由（ x ， y ）转换。 也就是说，点（ 0 ， 0在新的图形上下文）是一样的（X，Y）的原始图形上下文。
        • 除了继承自原始图形上下文的任何（翻译）裁剪矩形之外，新的图形上下文还有一个额外的剪切矩形。 新的剪辑矩形的原点是在（ 0 ， 0 ），以及由指定其大小width个height参数。
        参数
        x - x坐标。
        y - y坐标。
        width - 裁剪矩形的宽度。
        height - 剪裁矩形的高度。
        结果
        一个新的图形上下文。
        另请参见：
        translate(int, int) ， clipRect(int, int, int, int)

      • translate

        public abstract void translate​(int x,
                               int y)
        将图形上下文的原点转换为当前坐标系中的点（ x ， y ）。 修改这个图形上下文，使其新的原点对应于该图形上下文的原始坐标系中的点（ x ， y ）。 在此图形上下文中的后续渲染操作中使用的所有坐标将相对于此新的原点。
        参数
        x - x坐标。
        y - y坐标。

      • getColor

        public abstract Color getColor​()
        获取此图形上下文的当前颜色。
        结果
        这个图形上下文的当前颜色。
        另请参见：
        Color ， setColor(Color)

      • setColor

        public abstract void setColor​(Color c)
        将此图形上下文的当前颜色设置为指定的颜色。 使用此图形上下文的所有后续图形操作都使用此指定颜色。
        参数
        c - 新的渲染颜色。
        另请参见：
        Color ， getColor()

      • setPaintMode

        public abstract void setPaintMode​()
        设置此图形上下文的绘制模式，以使用此图形上下文的当前颜色覆盖目标。 这将逻辑像素操作功能设置为绘制或覆盖模式。 所有后续渲染操作将使用当前颜色覆盖目标。

      • setXORMode

        public abstract void setXORMode​(Color c1)
        设置此图形上下文的绘制模式，以在此图形上下文的当前颜色和新的指定颜色之间交替显示。 这指定在XOR模式下执行逻辑像素操作，XOR模式在当前颜色和指定的XOR颜色之间交替显示像素。

        当执行绘制操作时，作为当前颜色的像素被改变为指定的颜色，反之亦然。

        不同于这两种颜色的颜色的像素以不可预测但可逆的方式改变; 如果相同的图形被绘制两次，则所有像素将恢复到其原始值。

        参数
        c1 - XOR交替颜色

      • getFont

        public abstract Font getFont​()
        获取当前字体。
        结果
        这个图形上下文的当前字体。
        另请参见：
        Font ， setFont(Font)

      • setFont

        public abstract void setFont​(Font font)
        将此图形上下文的字体设置为指定的字体。 使用此图形上下文的所有后续文本操作都使用此字体。 空参数被默认忽略。
        参数
        font - 字体。
        另请参见：
        getFont() ，
drawString(java.lang.String, int, int) ，
drawBytes(byte[], int, int, int, int) ，
drawChars(char[], int, int, int, int)

      • getFontMetrics

        public FontMetrics getFontMetrics​()
        获取当前字体的字体度量。
        结果
        该图形上下文当前字体的字体指标。
        另请参见：
        getFont() ， FontMetrics ， getFontMetrics(Font)

      • getFontMetrics

        public abstract FontMetrics getFontMetrics​(Font f)
        获取指定字体的字体指标。
        参数
        f - 指定的字体
        结果
        指定字体的字体指标。
        另请参见：
        getFont() ， FontMetrics ， getFontMetrics()

      • getClipBounds

        public abstract Rectangle getClipBounds​()
        返回当前裁剪区域的边界矩形。 该方法是指用户剪辑，该剪辑与与设备界限相关联的剪辑和窗口可见性无关。 如果以前没有设置剪辑，或者使用setClip(null)清除剪辑，则此方法返回null 。 矩形中的坐标相对于该图形上下文的坐标系原点。
        结果
        当前裁剪区域的边界矩形，如果没有设置剪辑， null 。
        从以下版本开始：
        1.1
        另请参见：
        getClip() ，
clipRect(int, int, int, int) ，
setClip(int, int, int, int) ，
setClip(Shape)

      • clipRect

        public abstract void clipRect​(int x,
                              int y,
                              int width,
                              int height)
        用指定的矩形相交当前的剪辑。 产生的裁剪区域是当前裁剪区域和指定矩形的交点。 如果没有当前的裁剪区域，或者是因为剪辑从未被设置，或者剪辑已经被清除了setClip(null) ，则指定的矩形将成为新的剪辑。 此方法设置用户剪辑，该剪辑独立于与设备边界相关联的剪辑和窗口可见性。 该方法只能用于使当前的剪辑更小。 要使当前剪辑更大，请使用任何setClip方法。 渲染操作在裁剪区域之外没有任何效果。
        参数
        x - 与剪辑相交的矩形的x坐标
        y - 与剪辑相交的矩形的y坐标
        width - 与剪辑相交的矩形的宽度
        height - 与剪辑相交的矩形的高度
        另请参见：
        setClip(int, int, int, int) ， setClip(Shape)

      • setClip

        public abstract void setClip​(int x,
                             int y,
                             int width,
                             int height)
        将当前剪辑设置为由给定坐标指定的矩形。 此方法设置用户剪辑，该剪辑独立于与设备边界相关联的剪辑和窗口可见性。 渲染操作在裁剪区域之外没有任何效果。
        参数
        x - 新剪辑矩形的 x坐标。
        y - 新剪辑矩形的 y坐标。
        width - 新的剪辑矩形的宽度。
        height - 新剪辑矩形的高度。
        从以下版本开始：
        1.1
        另请参见：
        clipRect(int, int, int, int) ， setClip(Shape) ， getClip()

      • getClip

        public abstract Shape getClip​()
        获取当前的裁剪区域。 此方法返回用户剪辑，该剪辑独立于与设备边界相关联的剪辑和窗口可见性。 如果以前没有设置任何剪辑，或者使用setClip(null)清除剪辑，则此方法返回null 。
        结果
        表示当前剪辑区域的 Shape对象，如果没有设置剪辑， null 。
        从以下版本开始：
        1.1
        另请参见：
        getClipBounds() ，
clipRect(int, int, int, int) ，
setClip(int, int, int, int) ，
setClip(Shape)

      • setClip

        public abstract void setClip​(Shape clip)
        将当前剪辑区域设置为任意剪辑形状。 并非所有实现Shape接口的对象都可用于设置剪辑。 仅Shape被保证将支持的对象是Shape是经由所获得的对象getClip方法和经由Rectangle对象。 此方法设置用户剪辑，该剪辑独立于与设备边界相关联的剪辑和窗口可见性。
        参数
        clip - 用于设置剪辑的 Shape
        从以下版本开始：
        1.1
        另请参见：
        getClip() ，
clipRect(int, int, int, int) ，
setClip(int, int, int, int)

      • copyArea

        public abstract void copyArea​(int x,
                              int y,
                              int width,
                              int height,
                              int dx,
                              int dy)
        以dx和dy指定的距离复制组件的一个dy 。 从x和y指定的点y ，此方法x和y复制。 要向左或向上复制组件的区域，请指定一个负值为dx或dy 。 如果源矩形的一部分位于组件边界之外，或被其他窗口或组件遮挡，则copyArea将无法复制相关像素。 省略的区域可以通过调用组件的paint方法来刷新。
        参数
        x - 源矩形的 x坐标。
        y - 源矩形的 y坐标。
        width - 源矩形的宽度。
        height - 源矩形的高度。
        dx - 复制像素的水平距离。
        dy - 复制像素的垂直距离。

      • drawLine

        public abstract void drawLine​(int x1,
                              int y1,
                              int x2,
                              int y2)
        在这个图形上下文的坐标系中点 (x1, y1)和 (x2, y2)之间绘制一条线，使用当前的颜色。
        参数
        x1 - 第一个点的 x坐标。
        y1 - 第一个点的 y坐标。
        x2 - 第二点的 x坐标。
        y2 - 第二点的 y坐标。

      • fillRect

        public abstract void fillRect​(int x,
                              int y,
                              int width,
                              int height)
        填写指定的矩形。 矩形的左右边缘为x和x + width - 1 。 顶部和底部边缘为y和y + height - 1 。 所得到的矩形覆盖width像素宽， height像素高的区域。 使用图形上下文的当前颜色填充矩形。
        参数
        x - 要填充的矩形的 x坐标。
        y - 要填充的矩形的 y坐标。
        width - 要填充的矩形的宽度。
        height - 要填充的矩形的高度。
        另请参见：
        clearRect(int, int, int, int) ， drawRect(int, int, int, int)

      • drawRect

        public void drawRect​(int x,
                     int y,
                     int width,
                     int height)
        绘制指定矩形的轮廓。 矩形的左边和右边是x和x + width 。 顶部和底部边缘为y和y + height 。 使用图形上下文的当前颜色绘制矩形。
        参数
        x - 要绘制的矩形的 x坐标。
        y - 要绘制的矩形的 y坐标。
        width - 要绘制的矩形的宽度。
        height - 要绘制的矩形的高度。
        另请参见：
        fillRect(int, int, int, int) ， clearRect(int, int, int, int)

      • clearRect

        public abstract void clearRect​(int x,
                               int y,
                               int width,
                               int height)
        通过填充当前图形表面的背景颜色来清除指定的矩形。 此操作不使用当前的油漆模式。

        从Java 1.1开始，屏幕外图像的背景颜色可能取决于系统。 应用程序应该使用setColor其次是fillRect ，以确保离屏图像被清除到一个特定的颜色。

        参数
        x - 要清除的矩形的 x坐标。
        y - 要清除的矩形的 y坐标。
        width - 要清除的矩形的宽度。
        height - 要清除的矩形的高度。
        另请参见：
        fillRect(int, int, int, int) ，
drawRect(int, int, int, int) ，
setColor(java.awt.Color) ，
setPaintMode() ，
setXORMode(java.awt.Color)

      • drawRoundRect

        public abstract void drawRoundRect​(int x,
                                   int y,
                                   int width,
                                   int height,
                                   int arcWidth,
                                   int arcHeight)
        使用此图形上下文的当前颜色绘制一个概略的圆角矩形。 矩形的左右边缘分别为x和x + width 。 矩形的顶部和底部边缘为y和y + height 。
        参数
        x - 要绘制的矩形的 x坐标。
        y - 要绘制的矩形的 y坐标。
        width - 要绘制的矩形的宽度。
        height - 要绘制的矩形的高度。
        arcWidth - 四角的圆弧的水平直径。
        arcHeight - 弧角在四个角的垂直直径。
        另请参见：
        fillRoundRect(int, int, int, int, int, int)

      • fillRoundRect

        public abstract void fillRoundRect​(int x,
                                   int y,
                                   int width,
                                   int height,
                                   int arcWidth,
                                   int arcHeight)
        使用当前颜色填充指定的圆角矩形。 矩形的左右边缘分别为x和x + width - 1 。 矩形的顶部和底部边缘为y和y + height - 1 。
        参数
        x - 要填充的矩形的 x坐标。
        y - 要填充的矩形的 y坐标。
        width - 要填充的矩形的宽度。
        height - 要填充的矩形的高度。
        arcWidth - 四角的圆弧的水平直径。
        arcHeight - 四角的圆弧的垂直直径。
        另请参见：
        drawRoundRect(int, int, int, int, int, int)

      • draw3DRect

        public void draw3DRect​(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
        绘制指定矩形的3-D高亮轮廓。 矩形的边缘被突出显示，使得它们看起来是从左上角倾斜并点亮。

        用于突出显示效果的颜色是根据当前颜色确定的。 最终的矩形覆盖了width + 1像素宽， height + 1像素高的区域。

        参数
        x - 要绘制的矩形的 x坐标。
        y - 要绘制的矩形的 y坐标。
        width - 要绘制的矩形的宽度。
        height - 要绘制的矩形的高度。
        raised - 一个布尔值，用于确定矩形是否显示为高于表面或沉入表面。
        另请参见：
        fill3DRect(int, int, int, int, boolean)

      • fill3DRect

        public void fill3DRect​(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
        绘制一个填充有当前颜色的3-D高亮矩形。 矩形的边缘将被突出显示，使其看起来好像边缘是从左上角倾斜并点亮。 用于突出显示效果的颜色将根据当前颜色确定。
        参数
        x - 要填充的矩形的 x坐标。
        y - 要填充的矩形的 y坐标。
        width - 要填充的矩形的宽度。
        height - 要填充的矩形的高度。
        raised - 一个布尔值，用于确定矩形是否显示为高于表面或蚀刻到表面。
        另请参见：
        draw3DRect(int, int, int, int, boolean)

      • drawOval

        public abstract void drawOval​(int x,
                              int y,
                              int width,
                              int height)
        绘制椭圆形轮廓。 其结果是由指定的矩形内配合在一个圆或椭圆x ， y ， width ，和height参数。

        椭圆形涵盖的区域是width + 1像素宽， height + 1像素高。

        参数
        x - 要绘制的椭圆的左上角的 x坐标。
        y - 要绘制的椭圆的左上角的 y坐标。
        width - 要绘制的椭圆的宽度。
        height - 要绘制的椭圆的高度。
        另请参见：
        fillOval(int, int, int, int)

      • fillOval

        public abstract void fillOval​(int x,
                              int y,
                              int width,
                              int height)
        用当前颜色填充由指定矩形界定的椭圆。
        参数
        x - 要填充的椭圆的左上角的 x坐标。
        y - 要填充的椭圆的左上角的 y坐标。
        width - 要填充的椭圆的宽度。
        height - 要填充的椭圆的高度。
        另请参见：
        drawOval(int, int, int, int)

      • drawArc

        public abstract void drawArc​(int x,
                             int y,
                             int width,
                             int height,
                             int startAngle,
                             int arcAngle)
        绘制覆盖指定矩形的圆形或椭圆形圆弧的轮廓。

        所产生的弧开始于startAngle并使用当前颜色扩展arcAngle度。 角度被解释为0度在3点钟位置。 正值表示逆时针旋转，而负值表示顺时针旋转。

        圆弧的中心是矩形的中心，原点是（ x ， y ），其大小由width和height参数指定。

        所得到的弧面覆盖width + 1像素宽，高height + 1像素。

        角度相对于边界矩形的非正方形区域被指定，使得45度总是落在从椭圆的中心到边界矩形的右上角的直线上。 因此，如果一个轴上的边界矩形明显长于另一个轴，则弧段起点和终点的角度将沿边界的较长轴线偏斜。

        参数
        x - 要绘制的圆弧的左上角的 x坐标。
        y - 要绘制的圆弧的左上角的 y坐标。
        width - 要绘制的弧的宽度。
        height - 要绘制的弧的高度。
        startAngle - 起始角度
        arcAngle - 相对于起始角度的弧的角度范围。
        另请参见：
        fillArc(int, int, int, int, int, int)

      • fillArc

        public abstract void fillArc​(int x,
                             int y,
                             int width,
                             int height,
                             int startAngle,
                             int arcAngle)
        填写一个圆形或椭圆形的圆弧覆盖指定的矩形。

        最终的弧开始于startAngle并扩展为arcAngle度。 角度被解释为0度在3点钟位置。 正值表示逆时针旋转，而负值表示顺时针旋转。

        弧的中心是矩形的中心，原点是（ x ， y ），其大小由width和height参数指定。

        所产生的弧线覆盖width + 1像素宽， height + 1像素高的区域。

        角度相对于边界矩形的非正方形区域被指定，使得45度总是落在从椭圆的中心到边界矩形的右上角的直线上。 因此，如果一个轴上的边界矩形明显长于另一个轴，则弧段起点和终点的角度将沿边界的较长轴线偏斜。

        参数
        x - 要填充的圆弧的左上角的 x坐标。
        y - 要填充的圆弧的左上角的 y坐标。
        width - 要填充的弧的宽度。
        height - 要填充的弧的高度。
        startAngle - 起始角度
        arcAngle - 相对于起始角度的弧的角度范围。
        另请参见：
        drawArc(int, int, int, int, int, int)

      • drawPolyline

        public abstract void drawPolyline​(int[] xPoints,
                                  int[] yPoints,
                                  int nPoints)
        绘制由x和y坐标数组定义的连接线序列。 每对（ x ， y ）坐标定义一个点。 如果第一点与最后一点不同，则图形不会关闭。
        参数
        xPoints - 一个 x点数组
        yPoints - 一个 y点数组
        nPoints - 总分数
        从以下版本开始：
        1.1
        另请参见：
        drawPolygon(int[], int[], int)

      • drawPolygon

        public abstract void drawPolygon​(int[] xPoints,
                                 int[] yPoints,
                                 int nPoints)
        绘制由x和y坐标数组定义的封闭多边形。 每对（ x ， y ）坐标定义一个点。

        此方法绘制由定义的多边形nPoint线段，其中第一nPoint - 1线段是线段从(xPoints[i - 1], yPoints[i - 1])到(xPoints[i], yPoints[i]) ，为1‰‰¤I A‰¤ nPoints 。 如果这些点不同，则绘制连接最终点到第一个点的线将自动关闭该图形。

        参数
        xPoints - 一个 x坐标的数组。
        yPoints - 一个 y坐标的数组。
        nPoints - 一个总分数。
        另请参见：
        fillPolygon(int[], int[], int) ， drawPolyline(int[], int[], int)

      • drawPolygon

        public void drawPolygon​(Polygon p)
        绘制由指定的 Polygon对象定义的多边形的轮廓。
        参数
        p - 要绘制的多边形。
        另请参见：
        fillPolygon(int[], int[], int) ， drawPolyline(int[], int[], int)

      • fillPolygon

        public abstract void fillPolygon​(int[] xPoints,
                                 int[] yPoints,
                                 int nPoints)
        填充由x和y坐标数组定义的封闭多边形。

        此方法绘制由定义的多边形nPoint线段，其中第一nPoint - 1线段是线段从(xPoints[i - 1], yPoints[i - 1])到(xPoints[i], yPoints[i]) ，为1‰‰¤I A‰¤ nPoints 。 如果这些点不同，则绘制连接最终点到第一个点的线将自动关闭该图形。

        多边形内的区域使用偶数填充规则（也称为交替规则）来定义。

        参数
        xPoints - 一个 x坐标的数组。
        yPoints - 一个 y坐标的数组。
        nPoints - 一个总分数。
        另请参见：
        drawPolygon(int[], int[], int)

      • fillPolygon

        public void fillPolygon​(Polygon p)
        使用图形上下文的当前颜色填充由指定的多边形对象定义的多边形。

        多边形内的区域使用偶数填充规则（也称为交替规则）来定义。

        参数
        p - 要填充的多边形。
        另请参见：
        drawPolygon(int[], int[], int)

      • drawString

        public abstract void drawString​(String str,
                                int x,
                                int y)
        使用该图形上下文的当前字体和颜色绘制由指定字符串给出的文本。 最左边角色的基线是在这个图形上下文的坐标系中的位置（ x ， y ）。
        参数
        str - 要绘制的字符串。
        x - x坐标。
        y - y坐标。
        异常
        NullPointerException - 如果 str是 null 。
        另请参见：
        drawBytes(byte[], int, int, int, int) ， drawChars(char[], int, int, int, int)

      • drawString

        public abstract void drawString​(AttributedCharacterIterator iterator,
                                int x,
                                int y)
        渲染指定迭代器的文本，根据TextAttribute类的规范应用其属性。

        最左边角色的基线是在这个图形上下文的坐标系中的位置（ x ， y ）。

        参数
        iterator - 要绘制其文本的迭代器
        x - x坐标。
        y - y坐标。
        异常
        NullPointerException - 如果 iterator是 null 。
        另请参见：
        drawBytes(byte[], int, int, int, int) ， drawChars(char[], int, int, int, int)

      • drawChars

        public void drawChars​(char[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
        绘制由指定的字符数组给出的文本，使用此图形上下文的当前字体和颜色。 第一个字符的基线位于该图形上下文的坐标系中的位置（ x ， y ）。
        参数
        data - 要绘制的字符数组
        offset - 数据中的起始偏移量
        length - 要绘制的字符数
        x - 文本基线的 x坐标
        y - 文本基线的 y坐标
        异常
        NullPointerException - 如果 data是 null 。
        IndexOutOfBoundsException - 如果 offset或 length小于零，或 offset+length大于 data数组的长度。
        另请参见：
        drawBytes(byte[], int, int, int, int) ， drawString(java.lang.String, int, int)

      • drawBytes

        public void drawBytes​(byte[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
        绘制由指定字节数组给出的文本，使用此图形上下文的当前字体和颜色。 第一个字符的基线位于该图形上下文的坐标系中的位置（ x ， y ）。

        不建议使用此方法，因为每个字节被解释为0到255范围内的Unicode代码点，因此只能用于绘制该范围内的拉丁字符。

        参数
        data - 要绘制的数据
        offset - 数据中的起始偏移量
        length - 绘制的字节数
        x - 文本基线的 x坐标
        y - 文本基线的 y坐标
        异常
        NullPointerException - 如果 data是 null 。
        IndexOutOfBoundsException - 如果 offset或 length小于零，或 offset+length大于 data数组的长度。
        另请参见：
        drawChars(char[], int, int, int, int) ， drawString(java.lang.String, int, int)

      • drawImage

        public abstract boolean drawImage​(Image img,
                                  int x,
                                  int y,
                                  ImageObserver observer)
        绘制当前可用的指定图像的大小。 该图像在其图形上下文的坐标空间中的左上角（ x ， y ）处绘制。 图像中的透明像素不会影响已经存在的任何像素。

        即使完整图像尚未加载，并且当前输出设备尚未抖动和转换该方法，该方法在所有情况下立即返回。

        如果图像已经完全加载，并且其像素不再被更改，则drawImage返回true 。 否则， drawImage返回false ，随着更多的图像变得可用，或者是绘制另一帧动画的时候，加载图像的过程通知指定的图像观察者。

        参数
        img - 要绘制的指定图像。 如果img为空，此方法不起作用。
        x - x坐标。
        y - y坐标。
        observer - 要转换更多图像时要通知的对象。
        结果
        false如果图像像素仍在变化; 否则为true 。
        另请参见：
        Image ， ImageObserver ， ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public abstract boolean drawImage​(Image img,
                                  int x,
                                  int y,
                                  int width,
                                  int height,
                                  ImageObserver observer)
        绘制与已经缩放以适应指定矩形内的指定图像的大小。

        图像绘制在该图形上下文的坐标空间的指定矩形内，如有必要，将其缩放。 透明像素不会影响已经存在的像素。

        这种方法在所有情况下立即返回，即使整个图像尚未被缩放，抖动和转换为当前输出设备。 如果当前输出表示尚未完成，则drawImage返回false 。 随着更多的图像变得可用，加载图像的过程通过调用它的imageUpdate方法通知图像观察者。

        图像的缩放版本不一定立即可用，因为已为此输出设备构建了未缩放版本的映像。 图像的每个尺寸可以单独缓存并且在单独的图像生产序列中从原始数据生成。

        参数
        img - 要绘制的指定图像。 如果img为空，此方法不执行任何img 。
        x - x坐标。
        y - y坐标。
        width - 矩形的宽度。
        height - 矩形的高度。
        observer - 转换更多图像时要通知的对象。
        结果
        false如果图像像素仍在变化; 否则为true 。
        另请参见：
        Image ， ImageObserver ， ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public abstract boolean drawImage​(Image img,
                                  int x,
                                  int y,
                                  Color bgcolor,
                                  ImageObserver observer)
        绘制当前可用的指定图像的大小。 该图像在其图形上下文的坐标空间中的左上角（ x ， y ）处绘制。 透明像素以指定的背景颜色绘制。

        此操作相当于使用给定颜色填充指定图像的宽度和高度的矩形，然后在其上绘制图像，但可能更有效。

        即使完整图像尚未加载，并且当前输出设备尚未抖动和转换该方法，该方法在所有情况下立即返回。

        如果图像已经完全加载，并且其像素不再被更改，则drawImage返回true 。 否则， drawImage返回false并且随着更多的图像变得可用或者是绘制另一帧动画的时间，加载图像的过程通知指定的图像观察者。

        参数
        img - 要绘制的指定图像。 如果img为空，则此方法不起作用。
        x - x坐标。
        y - y坐标。
        bgcolor - 在图像的非不透明部分下绘制的背景颜色。
        observer - 要转换更多图像时要通知的对象。
        结果
        false如果图像像素仍在变化; 否则为true 。
        另请参见：
        Image ， ImageObserver ， ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public abstract boolean drawImage​(Image img,
                                  int x,
                                  int y,
                                  int width,
                                  int height,
                                  Color bgcolor,
                                  ImageObserver observer)
        绘制与已经缩放以适应指定矩形内的指定图像的大小。

        图像绘制在该图形上下文的坐标空间的指定矩形内，如有必要，将其缩放。 透明像素以指定的背景颜色绘制。 此操作相当于使用给定颜色填充指定图像的宽度和高度的矩形，然后在其上绘制图像，但可能更有效。

        这种方法在所有情况下立即返回，即使整个图像尚未被缩放，抖动和转换为当前输出设备。 如果当前输出表示尚未完成，则drawImage返回false 。 随着更多的图像可用，加载图像的过程通知指定的图像观察者。

        图像的缩放版本不一定立即可用，因为已为此输出设备构建了未缩放版本的映像。 图像的每个尺寸可以单独缓存并且在单独的图像生产序列中从原始数据生成。

        参数
        img - 要绘制的指定图像。 如果img为空，此方法不起作用。
        x - x坐标。
        y - y坐标。
        width - 矩形的宽度。
        height - 矩形的高度。
        bgcolor - 在图像的非不透明部分下绘制的背景颜色。
        observer - 要转换更多图像时要通知的对象。
        结果
        false如果图像像素仍在变化; 否则为true 。
        另请参见：
        Image ， ImageObserver ， ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public abstract boolean drawImage​(Image img,
                                  int dx1,
                                  int dy1,
                                  int dx2,
                                  int dy2,
                                  int sx1,
                                  int sy1,
                                  int sx2,
                                  int sy2,
                                  ImageObserver observer)
        按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。 透明像素不会影响已经存在的像素。

        这种方法在所有情况下立即返回，即使要绘制的图像区域尚未被缩放，抖动和转换为当前输出设备。 如果当前输出表示尚未完成，则drawImage返回false 。 随着更多的图像可用，加载图像的过程通知指定的图像观察者。

        该方法总是使用非标定版本的图像来渲染缩放的矩形，并且即时执行所需的缩放。 它不使用缓存的缩放版本的图像进行此操作。 执行图像从源到目的地的缩放，使得源矩形的第一坐标被映射到目的地矩形的第一坐标，并且将第二源坐标映射到第二目的地坐标。 子图像根据需要进行缩放和翻转以保留这些映射。

        参数
        img - 要绘制的指定图像。 如果img为空，则此方法不起作用。
        dx1 - 目标矩形的第一个角的 x坐标。
        dy1 - 目标矩形的第一个角的 y坐标。
        dx2 - 目标矩形的第二个角的 x坐标。
        dy2 - 目标矩形的第二个角的 y坐标。
        sx1 - 源矩形的第一个角的 x坐标。
        sy1 - 源矩形的第一个角的 y坐标。
        sx2 - 源矩形的第二个角的 x坐标。
        sy2 - 源矩形的第二个角的 y坐标。
        observer - 通过缩放和转换更多的图像来通知对象。
        结果
        false如果图像像素仍在改变; true否则。
        从以下版本开始：
        1.1
        另请参见：
        Image ， ImageObserver ， ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public abstract boolean drawImage​(Image img,
                                  int dx1,
                                  int dy1,
                                  int dx2,
                                  int dy2,
                                  int sx1,
                                  int sy1,
                                  int sx2,
                                  int sy2,
                                  Color bgcolor,
                                  ImageObserver observer)
        按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。

        透明像素以指定的背景颜色绘制。 此操作相当于使用给定颜色填充指定图像的宽度和高度的矩形，然后在其上绘制图像，但可能更有效。

        这种方法在所有情况下立即返回，即使要绘制的图像区域尚未被缩放，抖动和转换为当前输出设备。 如果当前输出表示尚未完成，则drawImage返回false 。 随着更多的图像可用，加载图像的过程通知指定的图像观察者。

        该方法总是使用非标定版本的图像来渲染缩放的矩形，并且即时执行所需的缩放。 它不使用缓存的缩放版本的图像进行此操作。 执行图像从源到目的地的缩放，使得源矩形的第一坐标被映射到目的地矩形的第一坐标，并且将第二源坐标映射到第二目的地坐标。 子图像根据需要进行缩放和翻转以保留这些映射。

        参数
        img - 要绘制的指定图像。 如果img为空，则此方法不起作用。
        dx1 - 目标矩形的第一个角的 x坐标。
        dy1 - 目标矩形的第一个角的 y坐标。
        dx2 - 目标矩形的第二个角的 x坐标。
        dy2 - 目标矩形的第二个角的 y坐标。
        sx1 - 源矩形的第一个角的 x坐标。
        sy1 - 源矩形的第一个角的 y坐标。
        sx2 - 源矩形的第二个角的 x坐标。
        sy2 - 源矩形的第二个角的 y坐标。
        bgcolor - 在图像的非不透明部分下绘制的背景颜色。
        observer - 通过缩放和转换更多的图像来通知对象。
        结果
        false如果图像像素仍在变化; true否则。
        从以下版本开始：
        1.1
        另请参见：
        Image ， ImageObserver ， ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • dispose

        public abstract void dispose​()
        处理此图形上下文并释放其正在使用的任何系统资源。 一个Graphics对象在dispose被调用后无法使用。

        当Java程序运行时，可以在短时间内创建大量的Graphics对象。 虽然垃圾收集器的完成过程也处理相同的系统资源，但是最好通过调用此方法手动释放相关资源，而不是依赖长时间不能完成的完成过程。

        作为参数的paint和update组件方法提供的图形对象在这些方法返回时由系统自动释放。 为了提高效率，只有在直接从组件或另一个Graphics对象创建Graphics对象时，程序员才可以调用dispose 。

        另请参见：
        finalize() ，
Component.paint(java.awt.Graphics) ，
Component.update(java.awt.Graphics) ，
Component.getGraphics() ，
create()

      • finalize

        @Deprecated(since="9")
public void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        一旦不再引用此图形上下文，就会处理这些图形上下文。
        重写：
        finalize在 Object
        另请参见：
        dispose()

      • toString

        public String toString​()
        返回 String表示此对象 Graphics对象的值。
        重写：
        toString类 Object
        结果
        这个图形上下文的字符串表示。

      • getClipRect

        @Deprecated
public Rectangle getClipRect​()
        已过时。 从JDK 1.1版开始，由getClipBounds()替代。
        返回当前裁剪区域的边界矩形。
        结果
        当前剪辑区域的边界矩形，如果没有设置剪辑，则为 null 。

      • hitClip

        public boolean hitClip​(int x,
                       int y,
                       int width,
                       int height)
        如果指定的矩形区域可能与当前裁剪区域相交，则返回true。 指定矩形区域的坐标在用户坐标空间中，并且相对于该图形上下文的坐标系原点。 该方法可以使用快速计算结果但即使指定的矩形区域不与裁剪区域相交也可能返回true的算法。 因此，所使用的具体算法可以降低速度的准确性，但是除非可以保证指定的矩形区域不与当前的剪切区域相交，否则它将永远不会返回假。 该方法使用的剪切区域可以表示通过该图形上下文的剪辑方法指定的用户剪辑的交集以及与设备或图像界限和窗口可视性相关联的剪辑。
        参数
        x - 要针对剪辑测试的矩形的x坐标
        y - 要针对剪辑测试的矩形的y坐标
        width - 要针对剪辑测试的矩形的宽度
        height - 要针对剪辑测试的矩形的高度
        结果
        true如果指定的矩形与当前剪辑的边界相交; 否则为false 。

      • getClipBounds

        public Rectangle getClipBounds​(Rectangle r)
        返回当前裁剪区域的边界矩形。 矩形中的坐标相对于该图形上下文的坐标系原点。 该方法与getClipBounds不同之处在于，使用现有的矩形而不是分配一个新矩形。 该方法是指用户剪辑，该剪辑与与设备界限相关联的剪辑和窗口可见性无关。 如果以前没有设置任何剪辑，或者使用setClip(null)清除剪辑，则此方法返回指定的Rectangle 。
        参数
        r - 当前裁剪区域被复制到的矩形。 此矩形中的任何当前值都将被覆盖。
        结果
        当前剪辑区域的边界矩形。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GraphicsConfigTemplate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GraphicsConfigTemplate

  • java.lang.Object
    • java.awt.GraphicsConfigTemplate
  • All Implemented Interfaces:
    Serializable

    public abstract class GraphicsConfigTemplate
extends Object
implements Serializable
    GraphicsConfigTemplate类用于获取有效的GraphicsConfiguration 。 用户实例化其中一个对象，然后根据需要设置所有非默认属性。 然后在GraphicsDevice类中找到的GraphicsDevice.getBestConfiguration(java.awt.GraphicsConfigTemplate)方法用这个GraphicsConfigTemplate 。 有效GraphicsConfiguration返回满足或超过什么的要求GraphicsConfigTemplate 。
    从以下版本开始：
    1.2
    另请参见：
    GraphicsDevice ， GraphicsConfiguration ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int PREFERRED
      用于“Enum”（整数）类型的值。
      static int REQUIRED
      用于“Enum”（整数）类型的值。
      static int UNNECESSARY
      用于“Enum”（整数）类型的值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GraphicsConfigTemplate​()
      这个类是一个抽象类，所以只有子类可以被实例化。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract GraphicsConfiguration getBestConfiguration​(GraphicsConfiguration[] gc)
      返回通过 GraphicsConfigTemplate定义的标准的“最佳”配置。
      abstract boolean isGraphicsConfigSupported​(GraphicsConfiguration gc)
      返回一个 boolean指示是否可以使用指定的 GraphicsConfiguration创建支持指定功能的绘图面。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • REQUIRED

        public static final int REQUIRED
        用于“Enum”（整数）类型的值。 这个功能是GraphicsConfiguration对象需要的。 如果此功能不可用，请勿选择GraphicsConfiguration对象。
        另请参见：
        Constant Field Values

      • PREFERRED

        public static final int PREFERRED
        用于“Enum”（整数）类型的值。 请确定GraphicsConfiguration对象需要此功能。 使用此功能的选择优先于不包含此功能的选项，尽管这两种选择都可以被认为是有效的匹配。
        另请参见：
        Constant Field Values

      • UNNECESSARY

        public static final int UNNECESSARY
        用于“Enum”（整数）类型的值。 说明该功能不需要用于选择GraphicsConfiguration对象。 没有此功能的选择优先于包含此功能的选项，因为它不被使用。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GraphicsConfigTemplate

        public GraphicsConfigTemplate​()
        这个类是一个抽象类，所以只有子类可以被实例化。

    • 方法详细信息

      • getBestConfiguration

        public abstract GraphicsConfiguration getBestConfiguration​(GraphicsConfiguration[] gc)
        返回通过 GraphicsConfigTemplate定义的标准的“最佳”配置。
        参数
        gc - 可选择的 GraphicsConfiguration对象数组。
        结果
        一个 GraphicsConfiguration对象是可能的最佳配置。
        另请参见：
        GraphicsConfiguration

      • isGraphicsConfigSupported

        public abstract boolean isGraphicsConfigSupported​(GraphicsConfiguration gc)
        返回一个 boolean指示是否可以使用指定的 GraphicsConfiguration创建支持指定功能的绘图面。
        参数
        gc - GraphicsConfiguration对象进行测试
        结果
        true如果此GraphicsConfiguration对象可用于创建支持指定功能的曲面; false如果GraphicsConfiguration无法用于创建此Java（tm）API可用的绘图表面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GraphicsConfiguration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GraphicsConfiguration

  • java.lang.Object
    • java.awt.GraphicsConfiguration

  • public abstract class GraphicsConfiguration
extends Object
    GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特征。 可以有许多GraphicsConfiguration对象与单个图形设备相关联，表示不同的绘图模式或功能。 平台对应的本机结构将有所不同。 例如，在X11窗口系统中，每个视觉是不同的GraphicsConfiguration 。 在Microsoft Windows上， GraphicsConfiguration表示当前分辨率和颜色深度可用的PixelFormats。

    在虚拟设备多屏幕环境中，桌面区域可跨越多个物理屏幕设备， GraphicsConfiguration对象的界限相对于虚拟坐标系。 当设置的部件的位置，使用getBounds以获得所需的边界GraphicsConfiguration和偏移与所述的坐标位置GraphicsConfiguration ，如下面的代码示例说明：

      Frame f = new Frame(gc);  // where gc is a GraphicsConfiguration
      Rectangle bounds = gc.getBounds();
      f.setLocation(10 + bounds.x, 10 + bounds.y);

    要确定您的环境是否是虚拟设备环境，请在系统中的所有GraphicsConfiguration对象上调用getBounds 。 如果返回范围的任何一个起始点不是（0,0），则您的环境是虚拟设备环境。

    您还可以使用getBounds来确定虚拟设备的边界。 为此，首先在系统中的所有GraphicsConfiguration对象上调用getBounds 。 然后计算从调用返回的所有界限的并集为getBounds 。 联合是虚拟设备的界限。 以下代码示例计算虚拟设备的边界。

       Rectangle virtualBounds = new Rectangle(); GraphicsEnvironment ge = GraphicsEnvironment. getLocalGraphicsEnvironment(); GraphicsDevice[] gs = ge.getScreenDevices(); for (int j = 0; j < gs.length; j++) { GraphicsDevice gd = gs[j]; GraphicsConfiguration[] gc = gd.getConfigurations(); for (int i=0; i < gc.length; i++) { virtualBounds = virtualBounds.union(gc[i].getBounds()); } }
    另请参见：
    Window ， Frame ， GraphicsEnvironment ， GraphicsDevice

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected GraphicsConfiguration​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      BufferedImage createCompatibleImage​(int width, int height)
      返回BufferedImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。
      BufferedImage createCompatibleImage​(int width, int height, int transparency)
      返回支持指定透明度的 BufferedImage ，并具有与该 GraphicsConfiguration兼容的数据布局和颜色模型。
      VolatileImage createCompatibleVolatileImage​(int width, int height)
      返回一个VolatileImage ，具有与该GraphicsConfiguration兼容的数据布局和颜色模型。
      VolatileImage createCompatibleVolatileImage​(int width, int height, int transparency)
      返回一个VolatileImage ，具有与此GraphicsConfiguration兼容的数据布局和颜色模型。
      VolatileImage createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps)
      使用指定的图像功能返回VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。
      VolatileImage createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps, int transparency)
      使用指定的图像功能和透明度值返回VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。
      abstract Rectangle getBounds​()
      返回设备坐标中的 GraphicsConfiguration的界限。
      BufferCapabilities getBufferCapabilities​()
      返回此 GraphicsConfiguration的缓冲功能。
      abstract ColorModel getColorModel​()
      返回ColorModel与此相关GraphicsConfiguration 。
      abstract ColorModel getColorModel​(int transparency)
      返回与支持指定透明度的 ColorModel相关联的 GraphicsConfiguration 。
      abstract AffineTransform getDefaultTransform​()
      返回AffineTransform的默认值GraphicsConfiguration 。
      abstract GraphicsDevice getDevice​()
      返回GraphicsDevice与此相关GraphicsConfiguration 。
      ImageCapabilities getImageCapabilities​()
      返回此 GraphicsConfiguration的图像功能。
      abstract AffineTransform getNormalizingTransform​()
      返回一个 AffineTransform可以与默认级联 AffineTransform一个的 GraphicsConfiguration ，使得单元72在用户空间等于设备空间的1英寸。
      boolean isTranslucencyCapable​()
      返回这个 GraphicsConfiguration是否支持 PERPIXEL_TRANSLUCENT类半透明。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GraphicsConfiguration

        protected GraphicsConfiguration​()
        这是一个无法直接实例化的抽象类。 必须从合适的工厂或查询方法获取实例。
        另请参见：
        GraphicsDevice.getConfigurations() ，
GraphicsDevice.getDefaultConfiguration() ，
GraphicsDevice.getBestConfiguration(java.awt.GraphicsConfigTemplate) ，
Graphics2D.getDeviceConfiguration()

    • 方法详细信息

      • getDevice

        public abstract GraphicsDevice getDevice​()
        返回GraphicsDevice与此相关GraphicsConfiguration 。
        结果
        一个 GraphicsDevice对象与该 GraphicsConfiguration相关联。

      • createCompatibleImage

        public BufferedImage createCompatibleImage​(int width,
                                           int height)
        返回BufferedImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。 该方法与设备的内存映射无关。 返回的BufferedImage具有最接近此本机设备配置的布局和颜色模型，因此可以将其优化为该设备。
        参数
        width - 返回的宽度为 BufferedImage
        height - 返回的高度为 BufferedImage
        结果
        一个 BufferedImage其数据布局和颜色模型与此 GraphicsConfiguration兼容。

      • createCompatibleImage

        public BufferedImage createCompatibleImage​(int width,
                                           int height,
                                           int transparency)
        返回支持指定透明度的BufferedImage ，并具有与该GraphicsConfiguration兼容的数据布局和颜色模型。 该方法与设备的内存映射无关。 返回的BufferedImage有一个布局和颜色模型，可以最佳地与这个GraphicsConfiguration的设备配合GraphicsConfiguration 。
        参数
        width - 返回的宽度为 BufferedImage
        height - 返回的高度是 BufferedImage
        transparency - 指定的透明度模式
        结果
        一个 BufferedImage其数据布局和颜色模型与此 GraphicsConfiguration兼容，并且还支持指定的透明度。
        异常
        IllegalArgumentException - 如果透明度不是有效值
        另请参见：
        Transparency.OPAQUE ， Transparency.BITMASK ， Transparency.TRANSLUCENT

      • createCompatibleVolatileImage

        public VolatileImage createCompatibleVolatileImage​(int width,
                                                   int height)
        返回一个VolatileImage ，具有与该GraphicsConfiguration兼容的数据布局和颜色模型。 返回的VolatileImage可能具有对底层图形设备进行最佳存储的数据，因此可能受益于平台特定的渲染加速。
        参数
        width - 返回的宽度为 VolatileImage
        height - 返回的高度是 VolatileImage
        结果
        一个 VolatileImage其数据布局和颜色模型与此 GraphicsConfiguration兼容。
        从以下版本开始：
        1.4
        另请参见：
        Component.createVolatileImage(int, int)

      • createCompatibleVolatileImage

        public VolatileImage createCompatibleVolatileImage​(int width,
                                                   int height,
                                                   int transparency)
        返回一个VolatileImage ，具有与此GraphicsConfiguration兼容的数据布局和颜色模型。 返回的VolatileImage可能具有最佳存储底层图形设备的数据，因此可能受益于平台特定的渲染加速。
        参数
        width - 返回的宽度为 VolatileImage
        height - 返回的高度为 VolatileImage
        transparency - 指定的透明度模式
        结果
        一个 VolatileImage其数据布局和颜色模型与此 GraphicsConfiguration兼容。
        异常
        IllegalArgumentException - 如果透明度不是有效值
        从以下版本开始：
        1.5
        另请参见：
        Transparency.OPAQUE ， Transparency.BITMASK ， Transparency.TRANSLUCENT ， Component.createVolatileImage(int, int)

      • createCompatibleVolatileImage

        public VolatileImage createCompatibleVolatileImage​(int width,
                                                   int height,
                                                   ImageCapabilities caps)
                                            throws AWTException
        使用指定的图像功能返回VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。 如果caps参数为空，则会被有效地忽略，此方法将创建一个VolatileImage，而不考虑ImageCapabilities约束。 返回的VolatileImage具有最接近此本机设备配置的布局和颜色模型，因此可以将其优化为该设备。
        参数
        width - 返回的宽度为 VolatileImage
        height - 返回的高度是 VolatileImage
        caps - 图像功能
        结果
        一个 VolatileImage其数据布局和颜色模型与此 GraphicsConfiguration兼容。
        异常
        AWTException - 如果图形配置不能满足提供的图像功能
        从以下版本开始：
        1.4

      • createCompatibleVolatileImage

        public VolatileImage createCompatibleVolatileImage​(int width,
                                                   int height,
                                                   ImageCapabilities caps,
                                                   int transparency)
                                            throws AWTException
        返回一个VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容，使用指定的图像功能和透明度值。 如果caps参数为空，则会被有效地忽略，此方法将创建一个VolatileImage，而不考虑ImageCapabilities约束。 返回的VolatileImage具有最接近此本机设备配置的布局和颜色模型，因此可以将其最佳地排除在此设备上。
        参数
        width - 返回的宽度为 VolatileImage
        height - 返回的高度为 VolatileImage
        caps - 图像功能
        transparency - 指定的透明度模式
        结果
        一个 VolatileImage其数据布局和颜色模型与此 GraphicsConfiguration兼容。
        异常
        IllegalArgumentException - 如果透明度不是有效值
        AWTException - 如果图形配置不能满足提供的图像功能
        从以下版本开始：
        1.5
        另请参见：
        Transparency.OPAQUE ， Transparency.BITMASK ， Transparency.TRANSLUCENT ， Component.createVolatileImage(int, int)

      • getColorModel

        public abstract ColorModel getColorModel​()
        返回ColorModel与该GraphicsConfiguration相关联。
        结果
        一个 ColorModel对象与该 GraphicsConfiguration相关联。

      • getColorModel

        public abstract ColorModel getColorModel​(int transparency)
        返回与支持指定透明度的 ColorModel相关联的 GraphicsConfiguration 。
        参数
        transparency - 指定的透明度模式
        结果
        一个与此 GraphicsConfiguration相关联的 ColorModel对象，并且如果透明度不是有效值，则支持指定的透明度或为null。
        另请参见：
        Transparency.OPAQUE ， Transparency.BITMASK ， Transparency.TRANSLUCENT

      • getDefaultTransform

        public abstract AffineTransform getDefaultTransform​()
        返回这个GraphicsConfiguration的默认值为 GraphicsConfiguration 。 这个AffineTransform通常是大多数正常屏幕的标识变换。 默认的AffineTransform将坐标映射到设备上，使得72个用户空间坐标单位在设备空间中测量大约1英寸。 归一化变换可用于使此映射更精确。 用于屏幕和打印机设备的默认AffineTransform定义的坐标空间中的坐标具有设备目标区域左上角的原点，X坐标向右增加，Y坐标向下增加。 对于与设备无关的图像缓冲区（如createCompatibleImage未创建的图像缓冲区），该标识变换是AffineTransform 。
        结果
        默认 AffineTransform为这个 GraphicsConfiguration 。

      • getNormalizingTransform

        public abstract AffineTransform getNormalizingTransform​()
        返回一个AffineTransform可以与默认级联AffineTransform一个的GraphicsConfiguration ，使得单元72在用户空间等于设备空间的1英寸。

        对于特定的Graphics2D ，g，可以通过使用以下伪代码来重置转换以创建此类映射：

          GraphicsConfiguration gc = g.getDeviceConfiguration();

      g.setTransform(gc.getDefaultTransform());
      g.transform(gc.getNormalizingTransform());
        请注意，有时这个AffineTransform是身份，例如打印机或图元文件输出，而且这个AffineTransform只是与底层系统提供的信息一样准确。 对于与设备不相关的图像缓冲区（如createCompatibleImage未创建的图像缓冲区），该AffineTransform是Identity变换，因为没有有效的距离测量。
        结果
        一个 AffineTransform连接到默认的 AffineTransform使用户空间中的72个单位映射到设备空间的1英寸。

      • getBounds

        public abstract Rectangle getBounds​()
        返回设备坐标中的GraphicsConfiguration的范围。 在具有虚拟设备的多屏幕环境中，边界可以具有负X或Y原点。
        结果
        该地区覆盖的范围 GraphicsConfiguration 。
        从以下版本开始：
        1.3

      • getBufferCapabilities

        public BufferCapabilities getBufferCapabilities​()
        返回这个 GraphicsConfiguration的缓冲功能。
        结果
        该图形配置对象的缓冲功能
        从以下版本开始：
        1.4

      • getImageCapabilities

        public ImageCapabilities getImageCapabilities​()
        返回此 GraphicsConfiguration的图像功能。
        结果
        该图形配置对象的图像功能
        从以下版本开始：
        1.4

      • isTranslucencyCapable

        public boolean isTranslucencyCapable​()
        返回这个 GraphicsConfiguration是否支持 PERPIXEL_TRANSLUCENT的半透明。
        结果
        给定的GraphicsConfiguration是否支持半透明效果。
        从以下版本开始：
        1.7
        另请参见：
        Window.setBackground(Color)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GraphicsDevice (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GraphicsDevice

  • java.lang.Object
    • java.awt.GraphicsDevice

  • public abstract class GraphicsDevice
extends Object
    GraphicsDevice课程描述了可能在特定图形环境中可用的图形设备。 这些包括屏幕和打印机设备。 请注意，在GraphicsEnvironment中可以有许多屏幕和许多打印机。 每个图形设备都有一个或多个GraphicsConfiguration对象相关联。 这些对象指定可以使用GraphicsDevice的不同配置。

    在多屏幕环境中，可以使用GraphicsConfiguration对象在多个屏幕上渲染组件。 下面的代码示例演示了如何创建一个JFrame为每个对象GraphicsConfiguration在每个屏幕设备上GraphicsEnvironment ：

       GraphicsEnvironment ge = GraphicsEnvironment. getLocalGraphicsEnvironment(); GraphicsDevice[] gs = ge.getScreenDevices(); for (int j = 0; j < gs.length; j++) { GraphicsDevice gd = gs[j]; GraphicsConfiguration[] gc = gd.getConfigurations(); for (int i=0; i < gc.length; i++) { JFrame f = new JFrame(gs[j].getDefaultConfiguration()); Canvas c = new Canvas(gc[i]); Rectangle gcBounds = gc[i].getBounds(); int xoffs = gcBounds.x; int yoffs = gcBounds.y; f.getContentPane().add(c); f.setLocation((i*50)+xoffs, (i*60)+yoffs); f.show(); } }

    有关全屏独占模式API的更多信息，请参阅Full-Screen Exclusive Mode API Tutorial 。

    另请参见：
    GraphicsEnvironment ， GraphicsConfiguration

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  GraphicsDevice.WindowTranslucency
      底层系统支持的半透明度。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TYPE_IMAGE_BUFFER
      设备是一个图像缓冲区。
      static int TYPE_PRINTER
      设备是打印机。
      static int TYPE_RASTER_SCREEN
      设备是光栅画面。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected GraphicsDevice​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      int getAvailableAcceleratedMemory​()
      此方法返回此设备上加速内存中可用的字节数。
      GraphicsConfiguration getBestConfiguration​(GraphicsConfigTemplate gct)
      返回通过GraphicsConfigTemplate中定义的标准的“最佳”配置。
      abstract GraphicsConfiguration[] getConfigurations​()
      返回与此 GraphicsDevice相关联的所有 GraphicsConfiguration对象。
      abstract GraphicsConfiguration getDefaultConfiguration​()
      返回默认 GraphicsConfiguration与此相关 GraphicsDevice 。
      DisplayMode getDisplayMode​()
      返回此 GraphicsDevice的当前显示模式。
      DisplayMode[] getDisplayModes​()
      返回此 GraphicsDevice可用的所有显示模式。
      Window getFullScreenWindow​()
      如果设备处于全屏模式，则返回表示全屏窗口的 Window对象。
      abstract String getIDstring​()
      返回与此 GraphicsDevice关联的标识字符串。
      abstract int getType​()
      返回此类型 GraphicsDevice 。
      boolean isDisplayChangeSupported​()
      返回 true如果这个 GraphicsDevice支持低级别的显示更改。
      boolean isFullScreenSupported​()
      如果这个 GraphicsDevice支持全屏独占模式，则返回 true 。
      boolean isWindowTranslucencySupported​(GraphicsDevice.WindowTranslucency translucencyKind)
      返回此图形设备是否支持给定的半透明级别。
      void setDisplayMode​(DisplayMode dm)
      设置此图形设备的显示模式。
      void setFullScreenWindow​(Window w)
      进入全屏模式，或返回窗口模式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TYPE_RASTER_SCREEN

        public static final int TYPE_RASTER_SCREEN
        设备是光栅画面。
        另请参见：
        Constant Field Values

      • TYPE_PRINTER

        public static final int TYPE_PRINTER
        设备是打印机。
        另请参见：
        Constant Field Values

      • TYPE_IMAGE_BUFFER

        public static final int TYPE_IMAGE_BUFFER
        设备是一个图像缓冲区。 该缓冲区可以驻留在设备或系统内存中，但不能由用户物理查看。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GraphicsDevice

        protected GraphicsDevice​()
        这是一个无法直接实例化的抽象类。 必须从合适的工厂或查询方法获取实例。
        另请参见：
        GraphicsEnvironment.getScreenDevices() ，
GraphicsEnvironment.getDefaultScreenDevice() ，
GraphicsConfiguration.getDevice()

    • 方法详细信息

      • getType

        public abstract int getType​()
        返回此类型 GraphicsDevice 。
        结果
        该类型为 GraphicsDevice ，可以是TYPE_RASTER_SCREEN，TYPE_PRINTER或TYPE_IMAGE_BUFFER。
        另请参见：
        TYPE_RASTER_SCREEN ， TYPE_PRINTER ， TYPE_IMAGE_BUFFER

      • getIDstring

        public abstract String getIDstring​()
        返回与此GraphicsDevice关联的标识字符串。

        一个特定的程序可能会在一个GraphicsDevice中使用多个GraphicsEnvironment 。 此方法返回String识别特定GraphicsDevice在本地GraphicsEnvironment 。 虽然没有公开的方法来设置这个String ，但程序员可以使用String进行调试。 Java String运行环境的供应商可以格式化String的返回值。 要确定如何解释String的值，请联系您的Java运行时的供应商。 要查找供应商是谁，从您的程序中，使用“java.vendor”调用System类的getProperty方法。

        结果
        一个 String是这个 GraphicsDevice的标识。

      • getConfigurations

        public abstract GraphicsConfiguration[] getConfigurations​()
        返回与此 GraphicsDevice相关联的所有 GraphicsConfiguration对象。
        结果
        与该 GraphicsDevice相关联的 GraphicsConfiguration对象的数组。

      • getDefaultConfiguration

        public abstract GraphicsConfiguration getDefaultConfiguration​()
        返回默认 GraphicsConfiguration与此相关 GraphicsDevice 。
        结果
        默认 GraphicsConfiguration这个 GraphicsDevice 。

      • getBestConfiguration

        public GraphicsConfiguration getBestConfiguration​(GraphicsConfigTemplate gct)
        返回可能通过GraphicsConfigTemplate中定义的条件的“最佳”配置。
        参数
        gct - GraphicsConfigTemplate对象用于获取有效的 GraphicsConfiguration
        结果
        一个 GraphicsConfiguration ，通过了指定的 GraphicsConfigTemplate定义的标准。
        另请参见：
        GraphicsConfigTemplate

      • isFullScreenSupported

        public boolean isFullScreenSupported​()
        如果这个GraphicsDevice支持全屏独占模式，则返回true 。 如果安装了SecurityManager，其checkPermission方法将使用AWTPermission("fullScreenExclusive")进行调用。 isFullScreenSupported仅在授予该权限isFullScreenSupported返回true。
        结果
        是否可以为此图形设备提供全屏独占模式
        从以下版本开始：
        1.4
        另请参见：
        AWTPermission

      • setFullScreenWindow

        public void setFullScreenWindow​(Window w)
        进入全屏模式，或返回窗口模式。 输入的全屏模式可能是独占的或模拟的。 独家模式仅在isFullScreenSupported返回true可用。

        独家模式意味着：

        • Windows不能与全屏窗口重叠。 所有其他应用程序窗口将始终以Z顺序显示在全屏窗口的下方。
        • 随时可以在设备上只有一个全屏窗口，所以在现有的全屏窗口中调用此方法将导致现有的全屏窗口返回窗口模式。
        • 输入法窗口被禁用。 建议调用Component.enableInputMethods(false)使组件成为输入法框架的非客户端。

        模拟全屏模式将窗口调整到屏幕最大可能的可见区域。 然而，本地窗口系统可以修改所请求的几何相关数据，使得Window对象以与桌面设置紧密相对的方式放置和调整大小。

        当进入全屏模式时，如果要用作全屏窗口的窗口不可见，则此方法将使其可见。 当返回到窗口模式时，它将保持可见。

        当进入全屏模式时，所有的半透明效果都将重新设置为窗口。 其形状设置为null ，不透明度值设置为1.0f，背景色alpha设置为255（完全不透明）。 返回窗口模式时，这些值不会恢复。

        如何在全屏模式下操作装饰窗口是未指定和依赖平台的。 因此，建议使用setUndecorated方法关闭Frame或Dialog对象中的装饰。

        当从专用全屏窗口返回窗口模式时，通过调用setDisplayMode进行的任何显示更改都将自动恢复到原始状态。

        参数
        w - 用作全屏窗口的窗口; null如果返回窗口模式。 一些平台期望全屏窗口成为顶级组件（即Frame ）; 因此，最好在这里使用Frame而不是Window 。
        从以下版本开始：
        1.4
        另请参见：
        isFullScreenSupported() ，
getFullScreenWindow() ，
setDisplayMode(java.awt.DisplayMode) ，
Component.enableInputMethods(boolean) ，
Component.setVisible(boolean) ，
Frame.setUndecorated(boolean) ，
Dialog.setUndecorated(boolean)

      • getFullScreenWindow

        public Window getFullScreenWindow​()
        如果设备处于全屏模式，则返回表示全屏窗口的 Window对象。
        结果
        全屏窗口，或 null如果设备不是全屏模式。
        从以下版本开始：
        1.4
        另请参见：
        setFullScreenWindow(Window)

      • isDisplayChangeSupported

        public boolean isDisplayChangeSupported​()
        返回true如果这个GraphicsDevice支持低级显示更改。 在某些平台上，只能在全屏专用模式下允许低级显示更改（即，如果isFullScreenSupported()返回true ，并且应用程序已使用setFullScreenWindow(java.awt.Window)进入全屏模式）。
        结果
        是否支持此图形设备的低级显示更改。
        从以下版本开始：
        1.4
        另请参见：
        isFullScreenSupported() ，
setDisplayMode(java.awt.DisplayMode) ，
setFullScreenWindow(java.awt.Window)

      • setDisplayMode

        public void setDisplayMode​(DisplayMode dm)
        设置此图形设备的显示模式。 只允许isDisplayChangeSupported()返回true并且可以使用setFullScreenWindow(java.awt.Window)首先进入全屏独占模式， 只要支持全屏独占模式（即isFullScreenSupported()返回true ）。

        显示模式必须是getDisplayModes()返回的显示模式之一，除了一个例外：通过DisplayMode.REFRESH_RATE_UNKNOWN刷新率的显示模式将导致从可用显示模式列表中选择匹配的宽度，高度和位深度的显示模式。 但是，如果在getDisplayModes()返回的列表中存在这种模式，则仅允许使用DisplayMode.BIT_DEPTH_MULTI的位深度显示模式。

        示例代码：

           Frame frame; DisplayMode newDisplayMode; GraphicsDevice gd; // create a Frame, select desired DisplayMode from the list of modes // returned by gd.getDisplayModes() ... if (gd.isFullScreenSupported()) { gd.setFullScreenWindow(frame); } else { // proceed in non-full-screen mode frame.setSize(...); frame.setLocation(...); frame.setVisible(true); } if (gd.isDisplayChangeSupported()) { gd.setDisplayMode(newDisplayMode); }
        参数
        dm - 这种图形设备的新显示模式。
        异常
        IllegalArgumentException - 如果提供的 DisplayMode是 null ，或者在 getDisplayModes返回的阵列中不可用
        UnsupportedOperationException - 如果 isDisplayChangeSupported返回 false
        从以下版本开始：
        1.4
        另请参见：
        getDisplayMode() ，
getDisplayModes() ，
isDisplayChangeSupported()

      • getDisplayMode

        public DisplayMode getDisplayMode​()
        返回此GraphicsDevice的当前显示模式。 返回的显示模式如果不确定，允许刷新率为DisplayMode.REFRESH_RATE_UNKNOWN 。 同样地，如果返回的显示模式是不确定的，或者如果支持多个位深度，则返回的显示模式允许位深DisplayMode.BIT_DEPTH_MULTI 。
        结果
        该图形设备的当前显示模式。
        从以下版本开始：
        1.4
        另请参见：
        setDisplayMode(DisplayMode)

      • getDisplayModes

        public DisplayMode[] getDisplayModes​()
        返回此GraphicsDevice可用的所有显示模式。 返回的显示模式如果不确定，允许刷新率为DisplayMode.REFRESH_RATE_UNKNOWN 。 同样，返回的显示模式如果不确定，或者支持多个位深度，则允许位深DisplayMode.BIT_DEPTH_MULTI 。
        结果
        所有显示模式可用于此图形设备。
        从以下版本开始：
        1.4

      • getAvailableAcceleratedMemory

        public int getAvailableAcceleratedMemory​()
        此方法返回此设备上加速内存中可用的字节数。 某些图像以先到先得的方式创建或缓存在加速内存中。 在某些操作系统上，这个内存是有限的资源。 调用此方法并仔细调度图像的创建和刷新可能使应用程序能够最有效地使用该有限资源。
        请注意，返回的数字是可用内存多少的快照; 一些图像可能仍然存在分配给该存储器的问题。 例如，根据操作系统，驱动程序，内存配置和线程情况，报告的大小的完整范围可能不适用于给定的图像。 有关与VolatileImage相关联的ImageCapabilities对象的进一步查询方法，可用于确定特定VolatileImage是否已在加速内存中创建。
        结果
        加速内存中可用的字节数。 负返回值表示此GraphicsDevice上的加速内存量是不确定的。
        从以下版本开始：
        1.4
        另请参见：
        Image.flush() ， ImageCapabilities.isAccelerated()

      • isWindowTranslucencySupported

        public boolean isWindowTranslucencySupported​(GraphicsDevice.WindowTranslucency translucencyKind)
        返回此图形设备是否支持给定的半透明级别。
        参数
        translucencyKind - 一种半透明支持
        结果
        是否支持给定的半透明度
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GraphicsDevice.WindowTranslucency (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum GraphicsDevice.WindowTranslucency

  • java.lang.Object
    • java.lang.Enum<GraphicsDevice.WindowTranslucency>
      • java.awt.GraphicsDevice.WindowTranslucency
  • All Implemented Interfaces:
    Serializable ， Comparable<GraphicsDevice.WindowTranslucency>
    Enclosing class:
    GraphicsDevice

    public static enum GraphicsDevice.WindowTranslucency
extends Enum<GraphicsDevice.WindowTranslucency>
    底层系统支持的半透明度。
    从以下版本开始：
    1.7
    另请参见：
    GraphicsDevice.isWindowTranslucencySupported(java.awt.GraphicsDevice.WindowTranslucency)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      PERPIXEL_TRANSLUCENT
      表示在底层系统中支持包含或可能包含0.0和1.0之间任意α值的像素的Windows。
      PERPIXEL_TRANSPARENT
      表示对底层系统的支持，每个像素的窗口保证完全不透明，alpha值为1.0，或者完全透明，Alpha值为0.0。
      TRANSLUCENT
      表示在底层系统中对Windows的支持，其所有像素具有相同的α值，包括0.0和1.0之间。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static GraphicsDevice.WindowTranslucency valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static GraphicsDevice.WindowTranslucency[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PERPIXEL_TRANSPARENT

        public static final GraphicsDevice.WindowTranslucency PERPIXEL_TRANSPARENT
        表示对底层系统的支持，每个像素的窗口保证完全不透明，alpha值为1.0，或者完全透明，Alpha值为0.0。

      • TRANSLUCENT

        public static final GraphicsDevice.WindowTranslucency TRANSLUCENT
        表示在底层系统中对Windows的支持，其所有像素具有相同的α值，包括0.0和1.0之间。

      • PERPIXEL_TRANSLUCENT

        public static final GraphicsDevice.WindowTranslucency PERPIXEL_TRANSLUCENT
        表示在底层系统中支持包含或可能包含0.0和1.0之间任意α值的像素的Windows。

    • 方法详细信息

      • values

        public static GraphicsDevice.WindowTranslucency[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (GraphicsDevice.WindowTranslucency c : GraphicsDevice.WindowTranslucency.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static GraphicsDevice.WindowTranslucency valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


GraphicsEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GraphicsEnvironment

  • java.lang.Object
    • java.awt.GraphicsEnvironment

  • public abstract class GraphicsEnvironment
extends Object
    GraphicsEnvironment类描述了特定平台上可用于Java（tm）应用程序的GraphicsDevice对象和Font对象的集合。 该GraphicsEnvironment的资源可能是本地的或远程机器上的。 GraphicsDevice对象可以是屏幕，打印机或图像缓冲区，并且是Graphics2D绘图方法的目标。 每个GraphicsDevice都有多个GraphicsConfiguration对象相关联。 这些对象指定可以使用GraphicsDevice的不同配置。
    另请参见：
    GraphicsDevice ， GraphicsConfiguration

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected GraphicsEnvironment​()
      这是一个抽象类，不能直接实例化。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Graphics2D createGraphics​(BufferedImage img)
      返回一个Graphics2D对象，用于渲染到指定的BufferedImage中 。
      abstract Font[] getAllFonts​()
      返回一个包含此 GraphicsEnvironment可用的所有字体的一点大小实例的 GraphicsEnvironment 。
      abstract String[] getAvailableFontFamilyNames​()
      返回一个数组，该数组包含本地化为默认语言环境的 GraphicsEnvironment中所有字体族的名称，由 Locale.getDefault()返回。
      abstract String[] getAvailableFontFamilyNames​(Locale l)
      返回一个数组，该数组包含本地化为指定区域设置的 GraphicsEnvironment的所有字体族的名称。
      Point getCenterPoint​()
      返回Windows应该居中的点。
      abstract GraphicsDevice getDefaultScreenDevice​()
      返回默认画面 GraphicsDevice 。
      static GraphicsEnvironment getLocalGraphicsEnvironment​()
      返回本地 GraphicsEnvironment 。
      Rectangle getMaximumWindowBounds​()
      返回居中Windows的最大边界。
      abstract GraphicsDevice[] getScreenDevices​()
      返回所有屏幕 GraphicsDevice对象的数组。
      static boolean isHeadless​()
      测试此环境中是否可以支持显示器，键盘和鼠标。
      boolean isHeadlessInstance​()
      返回在此图形环境中是否可以支持显示，键盘和鼠标。
      void preferLocaleFonts​()
      表示对逻辑字体映射到物理字体的区域设置特定字体的偏好。
      void preferProportionalFonts​()
      表示比例超过非比例的偏好（例如
      boolean registerFont​(Font font)
      注册一个 创建 Font在这个 GraphicsEnvironment 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GraphicsEnvironment

        protected GraphicsEnvironment​()
        这是一个抽象类，不能直接实例化。 必须从合适的工厂或查询方法获取实例。

    • 方法详细信息

      • getLocalGraphicsEnvironment

        public static GraphicsEnvironment getLocalGraphicsEnvironment​()
        返回本地 GraphicsEnvironment 。
        结果
        当地 GraphicsEnvironment

      • isHeadless

        public static boolean isHeadless​()
        测试此环境中是否可以支持显示器，键盘和鼠标。 如果此方法返回true，则会从依赖于显示器，键盘或鼠标的Toolkit和GraphicsEnvironment的区域抛出HeadlessException。
        结果
        true如果这种环境不能支持显示器，键盘和鼠标; 否则为false
        从以下版本开始：
        1.4
        另请参见：
        HeadlessException

      • isHeadlessInstance

        public boolean isHeadlessInstance​()
        返回在此图形环境中是否可以支持显示，键盘和鼠标。 如果这返回true， HeadlessException从依赖于显示器，键盘或鼠标的图形环境的区域抛出HeadlessException 。
        结果
        true如果在这种环境中可以支持显示器，键盘和鼠标; false否则
        从以下版本开始：
        1.4
        另请参见：
        HeadlessException ， isHeadless()

      • getScreenDevices

        public abstract GraphicsDevice[] getScreenDevices​()
                                           throws HeadlessException
        返回所有屏幕 GraphicsDevice对象的数组。
        结果
        一个包含所有表示屏幕设备的 GraphicsDevice对象的数组
        异常
        HeadlessException - 如果isHeadless（）返回true
        另请参见：
        isHeadless()

      • getDefaultScreenDevice

        public abstract GraphicsDevice getDefaultScreenDevice​()
                                               throws HeadlessException
        返回默认画面 GraphicsDevice 。
        结果
        表示默认屏幕设备的 GraphicsDevice
        异常
        HeadlessException - 如果isHeadless（）返回true
        另请参见：
        isHeadless()

      • createGraphics

        public abstract Graphics2D createGraphics​(BufferedImage img)
        返回一个Graphics2D对象，用于渲染到指定的BufferedImage中 。
        参数
        img - 指定 BufferedImage
        结果
        一个 Graphics2D用于渲染到指定的 BufferedImage
        异常
        NullPointerException - 如果 img为空

      • getAllFonts

        public abstract Font[] getAllFonts​()
        返回一个包含此GraphicsEnvironment可用的所有字体的一点大小实例的GraphicsEnvironment 。 典型的用法是允许用户选择特定的字体。 然后，应用程序可以通过在所选实例上调用deriveFont方法来deriveFont字体并设置各种字体属性。

        该方法为应用程序提供了最精确的控制，使用哪个Font实例来呈现文本。 如果该GraphicsEnvironment的字体具有多个可编程变量，则该数组中仅返回一个Font一个实例，并且应用程序必须导出其他变体。

        如果此环境中的字体有多个可编程变体，例如Multiple-Master字体，那么Font数组中Font返回该字体的一个实例。 其他变体必须由应用程序导出。

        结果
        一组 Font对象
        从以下版本开始：
        1.2
        另请参见：
        getAvailableFontFamilyNames() ， Font ， Font.deriveFont(int, float) ， Font.getFontName()

      • getAvailableFontFamilyNames

        public abstract String[] getAvailableFontFamilyNames​()
        返回一个数组，该数组包含本地化为默认语言环境的GraphicsEnvironment中所有字体族的名称，由Locale.getDefault()返回。

        典型的用法是呈现给用户以选择特定的姓氏。 然后，应用程序可以在创建字体时指定此名称，并结合使用粗体或斜体的样式，使字体系统灵活地选择自己在同一字体系列中的多种字体之间的最佳匹配。

        结果
        包含本地化为默认语言环境的字体族名称的 String数组，如果此区域设置中没有名称，则为合适的替代名称。
        从以下版本开始：
        1.2
        另请参见：
        getAllFonts() ， Font ， Font.getFamily()

      • getAvailableFontFamilyNames

        public abstract String[] getAvailableFontFamilyNames​(Locale l)
        返回包含在此所有字体系列名称的数组， GraphicsEnvironment本地化为指定的语言环境。

        典型的用法是呈现给用户以选择特定的姓氏。 然后，应用程序可以在创建字体时指定此名称，并结合使用粗体或斜体的样式，使字体系统灵活地选择自己在同一字体系列中的多种字体之间的最佳匹配。

        参数
        l - 代表特定地理，政治或文化区域的Locale对象。 指定null相当于指定Locale.getDefault() 。
        结果
        一个 String的数组，包含为指定的 Locale定位的字体族名，或者如果没有指定语言环境的名称，则为合适的替代名称。
        从以下版本开始：
        1.2
        另请参见：
        getAllFonts() ， Font ， Font.getFamily()

      • registerFont

        public boolean registerFont​(Font font)
        注册一个创建 Font在这个GraphicsEnvironment 。 创建的字体是从调用Font.createFont(int, java.io.InputStream)返回的字体，或通过调用Font.deriveFont(int, float)从创建的字体导出的 。 在调用此类字体后，可以在名称或姓氏中构建新的Font ，并在此应用程序或小程序的执行上下文中列出了getAvailableFontFamilyNames()和getAllFonts() 。 这意味着小程序无法以其他applet可见的方式注册字体。

        这种方法可能无法注册字体，因此返回false是：

        • 该字体不是创建 Font 。
        • 字体与未创建的Font冲突已经在这个GraphicsEnvironment 。 例如，如果名称是系统字体的名称，或27049428328991类的文档中描述的逻辑字体。 如果字体与系统字体具有相同的系列名称，字体是否也可能会发生冲突。

          请注意，应用程序可以使用新的字体替换先前创建的字体的注册。

        参数
        font - 要注册的字体
        结果
        如果 font在此 GraphicsEnvironment成功注册， GraphicsEnvironment 。
        异常
        NullPointerException - 如果 font为空
        从以下版本开始：
        1.6

      • preferLocaleFonts

        public void preferLocaleFonts​()
        表示对逻辑字体映射到物理字体的区域设置特定字体的偏好。 调用此方法表示字体渲染应主要使用主要写入系统特定的字体（由默认编码和初始默认语言环境指定的字体）。 例如，如果主要的书写系统是日语，那么如果可能，应该使用日语字体来呈现字符，而其他字体只能用于日文字体没有字形的字符。

        由调用此方法导致的字体渲染行为的实际变化取决于实现; 它可能没有任何效果，或者所请求的行为可能已经与默认行为相匹配。 轻量级和对等组件中的字体渲染行为可能会有所不同。 由于调用此方法请求不同的字体，客户端应该期望不同的度量，并且可能需要重新计算窗口大小和布局。 因此，在用户界面初始化之前应该调用此方法。

        从以下版本开始：
        1.5

      • preferProportionalFonts

        public void preferProportionalFonts​()
        表示在逻辑字体映射到物理字体时比例超过非比例（例如双间隔CJK字体）字体的偏好。 如果默认映射包含存在比例和非比例变量的字体，则调用此方法表示映射应使用比例变量。

        由调用此方法导致的字体渲染行为的实际变化取决于实现; 它可能没有任何效果。 轻量级和对等组件中的字体渲染行为可能会有所不同。 由于调用此方法请求不同的字体，客户端应该期望不同的度量，并且可能需要重新计算窗口大小和布局。 因此，在用户界面初始化之前应该调用此方法。

        从以下版本开始：
        1.5

      • getCenterPoint

        public Point getCenterPoint​()
                     throws HeadlessException
        返回Windows应该居中的点。 建议使用getMaximumWindowBounds（）检查居中的Windows，以确保它们适合可用的显示区域。
        结果
        Windows应该居中的地步
        异常
        HeadlessException - 如果isHeadless（）返回true
        从以下版本开始：
        1.4
        另请参见：
        getMaximumWindowBounds()

      • getMaximumWindowBounds

        public Rectangle getMaximumWindowBounds​()
                                 throws HeadlessException
        返回居中Windows的最大边界。 这些边界是本地窗口系统中的对象，如任务栏和菜单栏。 返回的界限将驻留在单个显示屏上，但有一个例外：在多屏幕系统中，Windows应以所有显示为中心，此方法返回整个显示区域的界限。

        要获得单个显示的可用边界，请使用GraphicsConfiguration.getBounds()和Toolkit.getScreenInsets() 。

        结果
        居中Windows的最大边界
        异常
        HeadlessException - 如果isHeadless（）返回true
        从以下版本开始：
        1.4
        另请参见：
        getCenterPoint() ，
GraphicsConfiguration.getBounds() ，
Toolkit.getScreenInsets(java.awt.GraphicsConfiguration)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GridBagConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GridBagConstraints

  • java.lang.Object
    • java.awt.GridBagConstraints
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class GridBagConstraints
extends Object
implements Cloneable, Serializable
    GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。
    从以下版本开始：
    1.0
    另请参见：
    GridBagLayout ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ABOVE_BASELINE
      可能的值为 anchor字段。
      static int ABOVE_BASELINE_LEADING
      可能的值为 anchor字段。
      static int ABOVE_BASELINE_TRAILING
      可能的值为 anchor字段。
      int anchor
      当该组件小于其显示区域时使用该字段。
      static int BASELINE
      可能的值为 anchor字段。
      static int BASELINE_LEADING
      可能的值为 anchor字段。
      static int BASELINE_TRAILING
      可能的值为 anchor字段。
      static int BELOW_BASELINE
      可能的值为 anchor字段。
      static int BELOW_BASELINE_LEADING
      可能的值为 anchor字段。
      static int BELOW_BASELINE_TRAILING
      可能的值为 anchor字段。
      static int BOTH
      水平和垂直调整组件的大小。
      static int CENTER
      将组件放在其显示区域的中央。
      static int EAST
      将组件放置在显示区域的右侧，垂直居中。
      int fill
      当组件的显示区域大于组件的请求大小时，将使用此字段。
      static int FIRST_LINE_END
      将组件放在其显示区域的一角，其中页面上的第一行文本正常结束当前的 ComponentOrientation 。
      static int FIRST_LINE_START
      将组件放置在其显示区域的一角，其中页面上的第一行文本通常将为当前的 ComponentOrientation开始。
      int gridheight
      指定组件显示区域的列中的单元格数。
      int gridwidth
      指定组件显示区域的一行中的单元格数。
      int gridx
      指定包含组件显示区域的前沿的单元格，其中一行中的第一个单元格具有 gridx=0 。
      int gridy
      指定组件显示区域顶部的单元格，其中最上面的单元格具有 gridy=0 。
      static int HORIZONTAL
      调整组件水平但不垂直。
      Insets insets
      该字段指定组件的外部填充，组件与其显示区域的边缘之间的最小空间量。
      int ipadx
      该字段指定组件的内部填充，添加到组件最小宽度的空间。
      int ipady
      该字段指定内部填充，即要添加到组件最小高度的空间。
      static int LAST_LINE_END
      将组件放置在其显示区域的一角，其中页面上的最后一行文本将正常结束当前的 ComponentOrientation 。
      static int LAST_LINE_START
      将组件放置在其显示区域的一角，其中页面上的最后一行文本通常将为当前的 ComponentOrientation启动。
      static int LINE_END
      将组件沿其显示区域的边缘放置，其中文本行将正常结束当前的 ComponentOrientation 。
      static int LINE_START
      将组件沿其显示区域的边缘放置，其中文本行正常开始为当前的 ComponentOrientation 。
      static int NONE
      不要调整组件的大小。
      static int NORTH
      将组件放置在其显示区域的顶部，水平居中。
      static int NORTHEAST
      将组件放在其显示区域的右上角。
      static int NORTHWEST
      将组件放在其显示区域的左上角。
      static int PAGE_END
      将组件沿着与当前 ComponentOrientation的页面末尾相关联的显示区域的边缘 ComponentOrientation 。
      static int PAGE_START
      将组件沿着与当前 ComponentOrientation的页面开头相关联的显示区域的边缘 ComponentOrientation 。
      static int RELATIVE
      指定此组件是下一个到最后一个组件在其行或列（ gridwidth ， gridheight ），或者该组分被旁边的以前添加的组件（放置 gridx ， gridy ）。
      static int REMAINDER
      指定此组件是其列或行中的最后一个组件。
      static int SOUTH
      将组件放在其显示区域的底部，水平居中。
      static int SOUTHEAST
      将组件放在其显示区域的右下角。
      static int SOUTHWEST
      将组件放在其显示区域的左下角。
      static int VERTICAL
      垂直调整组件大小但不水平调整。
      double weightx
      指定如何分配额外的水平空间。
      double weighty
      指定如何分配额外的垂直空间。
      static int WEST
      将组件放置在其显示区域的左侧，垂直居中。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GridBagConstraints​()
      创建一个 GridBagConstraint对象，其所有字段都设置为其默认值。
      GridBagConstraints​(int gridx, int gridy, int gridwidth, int gridheight, double weightx, double weighty, int anchor, int fill, Insets insets, int ipadx, int ipady)
      创建一个 GridBagConstraints对象，其所有字段都设置为传入参数。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建此网格包约束的副本。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • RELATIVE

        public static final int RELATIVE
        指定此组件是下一个到最后一个组件在其行或列（ gridwidth ， gridheight ），或者该组分被旁边的以前添加的组件（放置 gridx ， gridy ）。
        另请参见：
        gridwidth ， gridheight ， gridx ， gridy ， Constant Field Values

      • REMAINDER

        public static final int REMAINDER
        指定此组件是其列或行中的最后一个组件。
        另请参见：
        Constant Field Values

      • NONE

        public static final int NONE
        不要调整组件的大小。
        另请参见：
        Constant Field Values

      • BOTH

        public static final int BOTH
        水平和垂直调整组件的大小。
        另请参见：
        Constant Field Values

      • HORIZONTAL

        public static final int HORIZONTAL
        调整组件水平但不垂直。
        另请参见：
        Constant Field Values

      • VERTICAL

        public static final int VERTICAL
        垂直调整组件大小但不水平调整。
        另请参见：
        Constant Field Values

      • CENTER

        public static final int CENTER
        将组件放在其显示区域的中央。
        另请参见：
        Constant Field Values

      • NORTH

        public static final int NORTH
        将组件放置在其显示区域的顶部，水平居中。
        另请参见：
        Constant Field Values

      • NORTHEAST

        public static final int NORTHEAST
        将组件放在其显示区域的右上角。
        另请参见：
        Constant Field Values

      • EAST

        public static final int EAST
        将组件放置在显示区域的右侧，垂直居中。
        另请参见：
        Constant Field Values

      • SOUTHEAST

        public static final int SOUTHEAST
        将组件放在其显示区域的右下角。
        另请参见：
        Constant Field Values

      • SOUTH

        public static final int SOUTH
        将组件放在其显示区域的底部，水平居中。
        另请参见：
        Constant Field Values

      • SOUTHWEST

        public static final int SOUTHWEST
        将组件放在其显示区域的左下角。
        另请参见：
        Constant Field Values

      • WEST

        public static final int WEST
        将组件放置在其显示区域的左侧，垂直居中。
        另请参见：
        Constant Field Values

      • NORTHWEST

        public static final int NORTHWEST
        将组件放在其显示区域的左上角。
        另请参见：
        Constant Field Values

      • PAGE_START

        public static final int PAGE_START
        将组件沿与其当前的页面开头相关联的显示区域的边缘居中放置当前的ComponentOrientation 。 等于NORTH用于水平方向。
        另请参见：
        Constant Field Values

      • PAGE_END

        public static final int PAGE_END
        将组件沿着与当前ComponentOrientation的页面末尾相关联的显示区域的边缘ComponentOrientation 。 相当于SOUTH的水平方向。
        另请参见：
        Constant Field Values

      • LINE_START

        public static final int LINE_START
        将组件沿其显示区域的边缘放置，其中文本行正常开始为当前的ComponentOrientation 。 水平，从左到右的方向相当于WEST，水平，从右到左的方向为EAST。
        另请参见：
        Constant Field Values

      • LINE_END

        public static final int LINE_END
        将组件沿其显示区域的边缘放置，其中文本行将正常结束当前的ComponentOrientation 。 相对于横向，左至右方向的EAST，水平，从右到左的方向为WEST。
        另请参见：
        Constant Field Values

      • FIRST_LINE_START

        public static final int FIRST_LINE_START
        将组件放置在其显示区域的一角，其中页面上的第一行文本通常将为当前的ComponentOrientation开始。 相对于NORTHWEST，水平，从左到右的方向和NORTHEAST的水平，从右到左的方向。
        另请参见：
        Constant Field Values

      • FIRST_LINE_END

        public static final int FIRST_LINE_END
        将组件放置在其显示区域的一角，其中页面上的第一行文本将正常结束当前的ComponentOrientation 。 相对于NORTHEAST为水平，从左到右的方向，NORTHWEST为水平，从右到左的方向。
        另请参见：
        Constant Field Values

      • LAST_LINE_START

        public static final int LAST_LINE_START
        将组件放置在其显示区域的一角，其中页面上的最后一行文本通常将为当前的ComponentOrientation启动。 相对于SOUTHWEST的水平，从左到右的方向和SOUTHEAST的水平，从右到左的方向。
        另请参见：
        Constant Field Values

      • LAST_LINE_END

        public static final int LAST_LINE_END
        将组件放置在其显示区域的一角，其中页面上的最后一行文本将正常结束当前的ComponentOrientation 。 相当于SOUTHEAST的水平，从左到右的方向和SOUTHWEST的水平，从右到左的方向。
        另请参见：
        Constant Field Values

      • BASELINE

        public static final int BASELINE
        可能的值为anchor字段。 指定组件应沿着主要行的基准水平居中并垂直对齐。 如果组件没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • BASELINE_LEADING

        public static final int BASELINE_LEADING
        可能的值为anchor字段。 指定组件应沿着前沿水平放置。 对于具有从左到右方向的组件，前缘是左边缘。 垂直地，组件沿着主要行的基线对齐。 如果组件没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • BASELINE_TRAILING

        public static final int BASELINE_TRAILING
        可能的值为anchor字段。 指定组件应沿着后沿水平放置。 对于具有从左到右方向的组件，后缘是右边缘。 垂直地，组件沿着主要行的基线对齐。 如果组件没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • ABOVE_BASELINE

        public static final int ABOVE_BASELINE
        可能的值为anchor字段。 指定组件应该水平居中。 垂直地将组件定位成使其底部边缘接触起始行的基线。 如果起始行没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • ABOVE_BASELINE_LEADING

        public static final int ABOVE_BASELINE_LEADING
        可能值为anchor字段。 指定组件应沿着前沿水平放置。 对于具有从左到右方向的组件，前缘是左边缘。 垂直地将组件定位成使其底部边缘接触起始行的基线。 如果起始行没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • ABOVE_BASELINE_TRAILING

        public static final int ABOVE_BASELINE_TRAILING
        可能的值为anchor字段。 指定组件应沿着后沿水平放置。 对于具有从左到右方向的组件，后缘是右边缘。 垂直地将组件定位成使其底部边缘接触起始行的基线。 如果起始行没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • BELOW_BASELINE

        public static final int BELOW_BASELINE
        可能的值为anchor字段。 指定组件应该水平居中。 垂直地将组件定位成使其顶部边缘接触起始行的基线。 如果起始行没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • BELOW_BASELINE_LEADING

        public static final int BELOW_BASELINE_LEADING
        可能的值为anchor字段。 指定组件应沿着前沿水平放置。 对于具有从左到右方向的组件，前缘是左边缘。 垂直地将组件定位成使其顶部边缘接触起始行的基线。 如果起始行没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • BELOW_BASELINE_TRAILING

        public static final int BELOW_BASELINE_TRAILING
        可能的值为anchor字段。 指定组件应沿着后沿水平放置。 对于具有从左到右方向的组件，后缘是右边缘。 垂直地将组件定位成使其顶部边缘接触起始行的基线。 如果起始行没有基线，它将垂直居中。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • gridx

        public int gridx
        指定包含组件显示区域的前沿的单元格，其中一行中的第一个单元格具有gridx=0 。 组件显示区域的前沿是其左边缘，用于水平的从左到右的容器，其右边缘用于水平的从右到左的容器。 值RELATIVE指定组件在添加到该组件之前添加到容器中的组件之后立即放置。

        默认值为RELATIVE 。 gridx应为非负值。

        另请参见：
        clone() ， gridy ， ComponentOrientation

      • gridy

        public int gridy
        指定组件显示区域顶部的单元格，其中最上面的单元格具有gridy=0 。 值RELATIVE指定组件被放置在添加到该组件之前添加到容器的组件的正下方。

        默认值为RELATIVE 。 gridy应为非负值。

        另请参见：
        clone() ， gridx

      • gridwidth

        public int gridwidth
        指定组件显示区域的一行中的单元格数。

        使用REMAINDER指定组件的显示区域将从gridx到行中的最后一个单元格。 使用RELATIVE指定组件的显示区域将从gridx到其行中最后一个。

        gridwidth应为非负数，默认值为1。

        另请参见：
        clone() ， gridheight

      • gridheight

        public int gridheight
        指定组件显示区域的列中的单元格数。

        使用REMAINDER指定组件的显示区域将从gridy到列中的最后一个单元格。 使用RELATIVE指定组件的显示区域将从gridy到其列中最后一个。

        gridheight应为非负值，默认值为1。

        另请参见：
        clone() ， gridwidth

      • weightx

        public double weightx
        指定如何分配额外的水平空间。

        网格包布局管理器计算出列的权重是最大weightx列中的所有组件。 如果生成的布局水平比其需要填充的面积小，则额外的空间按其重量的比例分配到每个列。 重量为零的列不会占用额外的空间。

        如果所有重量都为零，则所有额外的空间出现在单元格的网格和左右边缘之间。

        该字段的默认值为0 。 weightx应为非负值。

        另请参见：
        clone() ， weighty

      • weighty

        public double weighty
        指定如何分配额外的垂直空间。

        网格布局管理器将一行中的所有组件的重量计算为最大值weighty 。 如果生成的布局垂直于要填充的区域较小，那么额外的空间按照其重量的比例分配给每一行。 重量为零的行不会收到额外的空间。

        如果所有重量都为零，则所有额外的空间出现在单元格的网格和顶部和底部边缘之间。

        该字段的默认值为0 。 weighty应为非负值。

        另请参见：
        clone() ， weightx

      • anchor

        public int anchor
        当该组件小于其显示区域时使用该字段。 它确定在显示区域内放置组件的位置。

        有三种可能的值：取向相对，基线相对和绝对值。 方向相对值相对于容器的组件方向属性来解释，基线相对值相对于基线解释，绝对值不是。 该绝对值为： CENTER ， NORTH ， NORTHEAST ， EAST ， SOUTHEAST ， SOUTH ， SOUTHWEST ， WEST ，并NORTHWEST 。 定向的相对值是： PAGE_START ， PAGE_END ， LINE_START ， LINE_END ， FIRST_LINE_START ， FIRST_LINE_END ， LAST_LINE_START和LAST_LINE_END 。 基线相对值是： BASELINE ， BASELINE_LEADING ， BASELINE_TRAILING ， ABOVE_BASELINE ， ABOVE_BASELINE_LEADING ， ABOVE_BASELINE_TRAILING ， BELOW_BASELINE ， BELOW_BASELINE_LEADING ，和BELOW_BASELINE_TRAILING 。 默认值为CENTER 。

        另请参见：
        clone() ， ComponentOrientation

      • fill

        public int fill
        当组件的显示区域大于组件的请求大小时，将使用此字段。 它决定是否调整组件的大小，如果是这样，怎么样。

        以下值适用于fill ：

        • NONE ：不要调整组件的大小。
        • HORIZONTAL ：使组件宽度足以水平填充其显示区域，但不要更改其高度。
        • VERTICAL ：使组件足够高以垂直填充其显示区域，但不要更改其宽度。
        • BOTH ：使组件完全填充其显示区域。

        默认值为NONE 。

        另请参见：
        clone()

      • insets

        public Insets insets
        该字段指定组件的外部填充，组件与其显示区域的边缘之间的最小空间量。

        默认值为new Insets(0, 0, 0, 0) 。

        另请参见：
        clone()

      • ipadx

        public int ipadx
        该字段指定组件的内部填充，添加到组件最小宽度的空间。 组件的宽度至少为其最小宽度加上ipadx像素。

        默认值为0 。

        另请参见：
        clone() ， ipady

      • ipady

        public int ipady
        该字段指定内部填充，即要添加到组件最小高度的空间。 组件的高度至少为其最小高度加上ipady像素。

        默认值为0。

        另请参见：
        clone() ， ipadx

    • 构造方法详细信息

      • GridBagConstraints

        public GridBagConstraints​()
        创建一个 GridBagConstraint对象，其所有字段设置为其默认值。

      • GridBagConstraints

        public GridBagConstraints​(int gridx,
                          int gridy,
                          int gridwidth,
                          int gridheight,
                          double weightx,
                          double weighty,
                          int anchor,
                          int fill,
                          Insets insets,
                          int ipadx,
                          int ipady)
        创建一个GridBagConstraints对象，其所有字段都设置为传入参数。 注意：由于使用此构造函数阻碍了源代码的可读性，因此该构造函数只能由自动源代码生成工具使用。
        参数
        gridx - 初始gridx值。
        gridy - 初始网格值。
        gridwidth - 初始 gridwidth值。
        gridheight - 初始 gridheight值。
        weightx - 初始 weightx值。
        weighty - 初始重量值。
        anchor - 初始锚值。
        fill - 初始填充值。
        insets - 初始 insets 。
        ipadx - 初始ipadx值。
        ipady - 初始ipady值。
        从以下版本开始：
        1.2
        另请参见：
        gridx ， gridy ， gridwidth ， gridheight ， weightx ， weighty ， anchor ， fill ， insets ， ipadx ， ipady

    • 方法详细信息

      • clone

        public Object clone​()
        创建此网格包约束的副本。
        重写：
        clone在 Object
        结果
        这个网格包约束的副本
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GridBagLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GridBagLayout

  • java.lang.Object
    • java.awt.GridBagLayout
  • All Implemented Interfaces:
    LayoutManager ， LayoutManager2 ， Serializable

    public class GridBagLayout
extends Object
implements LayoutManager2, Serializable
    GridBagLayout类是一种灵活的布局管理器，可以垂直，水平或沿其基准对齐组件，而不需要组件的大小相同。 每个GridBagLayout对象维护一个动态的，矩形的单元格网格，每个组件占据一个或多个单元格，称为其显示区域 。

    由GridBagLayout管理的每个组件与一个GridBagConstraints的实例相关联。 constraints对象指定组件的显示区域在网格上的位置以及组件在其显示区域内的位置。 除了其约束对象外， GridBagLayout还考虑每个组件的最小和首选大小，以确定组件的大小。

    电网的整体方向取决于集装箱的ComponentOrientation属性。 对于水平从左到右的方向，网格坐标（0,0）位于容器的左上角，其中x向右增加，y向下增加。 对于水平从右到左的方向，网格坐标（0,0）位于容器的右上角，其中x向左增加，y向下增加。

    为了有效使用网格包布局，必须定制一个或多个GridBagConstraints了与它的组件相关联的对象。 您可以通过设置一个或多个实例变量来自定义一个GridBagConstraints对象：

    GridBagConstraints.gridx ， GridBagConstraints.gridy
    指定包含组件显示区域的前角的单元格，其中网格原点的单元格地址gridx = 0 gridy = 0 。 对于水平从左到右的布局，组件的前角是其左上角。 对于水平从右到左的布局，组件的前角是其右上角。 使用GridBagConstraints.RELATIVE （默认值）来指定在添加该组件之前添加到容器中的组件，立即将组件放置在（沿x轴为gridx或y轴为gridy ）之后。
    GridBagConstraints.gridwidth ， GridBagConstraints.gridheight
    指定组件显示区域中一行中的单元格数（ gridwidth ）或列（ gridheight ）。 默认值为1.使用GridBagConstraints.REMAINDER指定组件的显示区域将从gridx到行中的最后一个单元格（ gridwidth ）或从gridy到列的最后一个单元格（ gridheight ）。 使用GridBagConstraints.RELATIVE指定组件的显示区域将从gridx到其行中最后一个单元格的下一个（ gridwidth或从gridy到其列中最后一个单元格的gridheight ）（ gridheight ）。
    GridBagConstraints.fill
    当组件的显示区域大于组件的请求大小时使用，以确定是否（以及如何）调整组件的大小。 可能的值为GridBagConstraints.NONE （默认值）， GridBagConstraints.HORIZONTAL （使组件宽度足以水平填充其显示区域，但不要更改其高度）， GridBagConstraints.VERTICAL （使组件足够高以垂直填充其显示区域，但不要更改其宽度）和GridBagConstraints.BOTH （使组件完全填充其显示区域）。
    GridBagConstraints.ipadx ， GridBagConstraints.ipady
    在布局中指定组件的内部填充，添加到组件的最小大小的多少。 组件的宽度至少为其最小宽度加上ipadx像素。 类似地，组件的高度将至少为最小高度加上ipady像素。
    GridBagConstraints.insets
    指定组件的外部填充，组件与其显示区域边缘之间的最小空间量。
    GridBagConstraints.anchor
    指定组件在其显示区域中的位置。 有三种可能的值：绝对值，方向相对值和基线相对方向相对值相对于容器的ComponentOrientation属性进行解释，绝对值不是。 基线相对值相对于基线计算。 有效值为： Absolute, relative and baseline values as described above

    Absolute Values

    Orientation Relative Values

    Baseline Relative Values

    • GridBagConstraints.NORTH
    • GridBagConstraints.SOUTH
    • GridBagConstraints.WEST
    • GridBagConstraints.EAST
    • GridBagConstraints.NORTHWEST
    • GridBagConstraints.NORTHEAST
    • GridBagConstraints.SOUTHWEST
    • GridBagConstraints.SOUTHEAST
    • GridBagConstraints.CENTER (the default)
    • GridBagConstraints.PAGE_START
    • GridBagConstraints.PAGE_END
    • GridBagConstraints.LINE_START
    • GridBagConstraints.LINE_END
    • GridBagConstraints.FIRST_LINE_START
    • GridBagConstraints.FIRST_LINE_END
    • GridBagConstraints.LAST_LINE_START
    • GridBagConstraints.LAST_LINE_END
    • GridBagConstraints.BASELINE
    • GridBagConstraints.BASELINE_LEADING
    • GridBagConstraints.BASELINE_TRAILING
    • GridBagConstraints.ABOVE_BASELINE
    • GridBagConstraints.ABOVE_BASELINE_LEADING
    • GridBagConstraints.ABOVE_BASELINE_TRAILING
    • GridBagConstraints.BELOW_BASELINE
    • GridBagConstraints.BELOW_BASELINE_LEADING
    • GridBagConstraints.BELOW_BASELINE_TRAILING
    GridBagConstraints.weightx ， GridBagConstraints.weighty
    用于确定如何分配空间，这对于指定调整大小的行为很重要。 除非您指定一行中至少一个组件（ weightx ）和列（ weighty ）的权重，否则所有组件都将集中在其容器的中心。 这是因为当重量为零（默认值）时， GridBagLayout对象在其单元格格栅和容器边缘之间放置任何额外的空格。

    每行可能有一个基线; 基线是由该行中具有有效基线和沿基线对齐（该组件的锚定值中的一个的分量确定BASELINE ， BASELINE_LEADING或BASELINE_TRAILING ）。 如果行中没有一个组件具有有效的基线，则该行不具有基线。

    如果组件跨越行，则它将与起始行的基线对齐（如果baseline-resize行为为CONSTANT_ASCENT ）或结束行（如果baseline-resize行为为CONSTANT_DESCENT ）。 组件对齐的行称为主要行 。

    下图显示了基线布局，并包括跨越行的组件：

    Baseline Layout The following text describes this graphic (Figure 1).
    此布局由三个组件组成：
    • 一个从第0行开始并以行1结尾的面板。面板的基线调整大小为CONSTANT_DESCENT ，锚点为BASELINE 。 由于基准调整大小的行为为CONSTANT_DESCENT ，面板的主要行为第1行。
    • 两个按钮，每个按钮的基线调整大小为CENTER_OFFSET ，锚点为BASELINE 。
    因为第二个按钮和面板共享相同的行，它们都沿着它们的基线对齐。

    使用其中一个基线相对值定位的组件的大小与使用绝对值或方向相对值定位时的大小不同。 组件变化的方式由当前行的基线如何变化决定。 如果具有相同主行的任何组件的基线调整大小行为为CONSTANT_DESCENT ，则基线将锚定到显示区域的CONSTANT_DESCENT ，否则基线将锚定到显示区域的顶部。 以下规则规定了调整大小的行为：

    • 位于基线以上的可调整大小的组件只能增长到基线的高度。 例如，如果基线为100并且位于顶部，则位于基线之上的可调整大小的组件永远不会增长超过100个单位。
    • 类似地，位于基线以下的可调整大小的组件只能增长到显示高度和基线之间的差。
    • 如果基准调整大小的行为为OTHER ，则位于基准OTHER的可调整大小的OTHER仅在调整大小的基线适合显示区域时才调整大小。 如果基准使得它不适合显示区域，则组件不会调整大小。
    • 位于基准线上的基准调整大小行为OTHER只能高达display height - baseline + baseline of component 。
    如果沿着基准定位组件，但组件没有有效的基线，则它将在其空间中垂直居中。 类似地，如果已经相对于基线定位了一个组件，并且该行中的任何组件都没有有效的基线，那么该组件就是垂直居中的。

    以下图显示了由网格包布局管理的十个组件（所有按钮）。 图2显示了一个水平的从左到右的容器的布局，图3显示了一个水平的，从右到左的容器的布局。

    Figures The preceding text describes this graphic (Figure 1). The preceding text describes this graphic (Figure 2). Figure 2: Horizontal, Left-to-Right Figure 3: Horizontal, Right-to-Left

    十个组件中的每一个都有其相关联的GridBagConstraints对象的fill字段设置为GridBagConstraints.BOTH 。 此外，组件具有以下非默认约束：

    • weightx = 1.0 ： weightx = 1.0
    • 将Button4： weightx = 1.0 ， gridwidth = GridBagConstraints.REMAINDER
    • Button5： gridwidth = GridBagConstraints.REMAINDER
    • Button6： gridwidth = GridBagConstraints.RELATIVE
    • Button7： gridwidth = GridBagConstraints.REMAINDER
    • 按钮8： gridheight = 2 ， weighty = 1.0
    • 按钮9，按钮10： gridwidth = GridBagConstraints.REMAINDER

    以下是实现上述示例的代码：

     import java.awt.*;
 import java.util.*;
 import java.applet.Applet;

 public class GridBagEx1 extends Applet {

     protected void makebutton(String name,
                               GridBagLayout gridbag,
                               GridBagConstraints c) {
         Button button = new Button(name);
         gridbag.setConstraints(button, c);
         add(button);
     }

     public void init() {
         GridBagLayout gridbag = new GridBagLayout();
         GridBagConstraints c = new GridBagConstraints();

         setFont(new Font("SansSerif", Font.PLAIN, 14));
         setLayout(gridbag);

         c.fill = GridBagConstraints.BOTH;
         c.weightx = 1.0;
         makebutton("Button1", gridbag, c);
         makebutton("Button2", gridbag, c);
         makebutton("Button3", gridbag, c);

         c.gridwidth = GridBagConstraints.REMAINDER; //end row
         makebutton("Button4", gridbag, c);

         c.weightx = 0.0;                //reset to the default
         makebutton("Button5", gridbag, c); //another row

         c.gridwidth = GridBagConstraints.RELATIVE; //next-to-last in row
         makebutton("Button6", gridbag, c);

         c.gridwidth = GridBagConstraints.REMAINDER; //end row
         makebutton("Button7", gridbag, c);

         c.gridwidth = 1;                //reset to the default
         c.gridheight = 2;
         c.weighty = 1.0;
         makebutton("Button8", gridbag, c);

         c.weighty = 0.0;                //reset to the default
         c.gridwidth = GridBagConstraints.REMAINDER; //end row
         c.gridheight = 1;               //reset to the default
         makebutton("Button9", gridbag, c);
         makebutton("Button10", gridbag, c);

         setSize(300, 100);
     }

     public static void main(String args[]) {
         Frame f = new Frame("GridBag Layout Example");
         GridBagEx1 ex1 = new GridBagEx1();

         ex1.init();

         f.add("Center", ex1);
         f.pack();
         f.setSize(f.getPreferredSize());
         f.show();
     }
 }
    从以下版本开始：
    1.0
    另请参见：
    GridBagConstraints ， GridBagLayoutInfo ， ComponentOrientation ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double[] columnWeights
      此字段保留对列权重的覆盖。
      int[] columnWidths
      此字段将覆盖列的最小宽度。
      protected Hashtable<Component,GridBagConstraints> comptable
      这个散列表维护了一个组件与其gridbag约束之间的关联。
      protected GridBagConstraints defaultConstraints
      该字段包含包含默认值的网格包约束实例，因此如果组件没有与其相关联的网格包约束，则该组件将被分配一份 defaultConstraints的副本。
      protected GridBagLayoutInfo layoutInfo
      该字段保存网格包的布局信息。
      protected static int MAXGRIDSIZE
      此字段不再用于保留阵列并保留向后兼容性。
      protected static int MINSIZE
      可以通过网格布局布局的最小网格。
      protected static int PREFERREDSIZE
      可以通过网格布局布局的首选网格尺寸。
      int[] rowHeights
      此字段将覆盖行的最小高度。
      double[] rowWeights
      此字段保留对行权重的覆盖。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GridBagLayout​()
      创建网格包布局管理器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addLayoutComponent​(Component comp, Object constraints)
      使用指定的 constraints对象将指定的组件添加到布局。
      void addLayoutComponent​(String name, Component comp)
      没有效果，因为此布局管理器不使用每个组件字符串。
      protected void adjustForGravity​(GridBagConstraints constraints, Rectangle r)
      根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
      protected void AdjustForGravity​(GridBagConstraints constraints, Rectangle r)
      根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
      protected void arrangeGrid​(Container parent)
      排出电网。
      protected void ArrangeGrid​(Container parent)
      此方法已过时，仅供后向兼容; 新代码应该调用arrangeGrid 。
      GridBagConstraints getConstraints​(Component comp)
      获取指定组件的约束。
      float getLayoutAlignmentX​(Container parent)
      返回沿x轴的对齐方式。
      float getLayoutAlignmentY​(Container parent)
      返回沿着y轴的对齐。
      int[][] getLayoutDimensions​()
      确定布局网格的列宽和行高。
      protected GridBagLayoutInfo getLayoutInfo​(Container parent, int sizeflag)
      针对当前管理的儿童组 GridBagLayoutInfo的例子。
      protected GridBagLayoutInfo GetLayoutInfo​(Container parent, int sizeflag)
      此方法已过时，仅供后向兼容; 新代码应该调用getLayoutInfo 。
      Point getLayoutOrigin​()
      确定目标容器的图形坐标空间中的布局区域的原点。
      double[][] getLayoutWeights​()
      确定布局网格的列和行的权重。
      protected Dimension getMinSize​(Container parent, GridBagLayoutInfo info)
      根据 getLayoutInfo的信息， getLayoutInfo主站的最小尺寸。
      protected Dimension GetMinSize​(Container parent, GridBagLayoutInfo info)
      此方法已过时，仅供后向兼容; 新代码应该调用getMinSize 。
      void invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      void layoutContainer​(Container parent)
      使用此网格包布局来放出指定的容器。
      Point location​(int x, int y)
      确定布局网格中的单元格包含由 (x, y)指定的点。
      protected GridBagConstraints lookupConstraints​(Component comp)
      检索指定组件的约束。
      Dimension maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension minimumLayoutSize​(Container parent)
      使用此网格包布局确定 parent容器的最小尺寸。
      Dimension preferredLayoutSize​(Container parent)
      使用此网格袋布局确定 parent容器的首选尺寸。
      void removeLayoutComponent​(Component comp)
      从此布局中删除指定的组件。
      void setConstraints​(Component comp, GridBagConstraints constraints)
      设置此布局中指定组件的约束。
      String toString​()
      返回此网格包布局值的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MAXGRIDSIZE

        protected static final int MAXGRIDSIZE
        此字段不再用于保留阵列并保留向后兼容性。 以前，这是网格布局布局的网格位置（水平和垂直）的最大数量。 当前的实施不会对网格的大小施加任何限制。
        另请参见：
        Constant Field Values

      • MINSIZE

        protected static final int MINSIZE
        可以通过网格布局布局的最小网格。
        另请参见：
        Constant Field Values

      • PREFERREDSIZE

        protected static final int PREFERREDSIZE
        可以通过网格布局布局的首选网格尺寸。
        另请参见：
        Constant Field Values

      • comptable

        protected Hashtable<Component,GridBagConstraints> comptable
        这个散列表维护了一个组件与其gridbag约束之间的关联。 comptable中的键是组件，值是GridBagConstraints的实例。
        另请参见：
        GridBagConstraints

      • defaultConstraints

        protected GridBagConstraints defaultConstraints
        此字段包含包含默认值的gridbag约束实例，因此如果组件没有与其相关联的 defaultConstraints约束，则将为该组件分配 defaultConstraints的副本。
        另请参见：
        getConstraints(Component) ， setConstraints(Component, GridBagConstraints) ， lookupConstraints(Component)

      • layoutInfo

        protected GridBagLayoutInfo layoutInfo
        该字段保存网格包的布局信息。 该字段中的信息是基于最近验证的网格包。 如果layoutInfo为null ，则表示null中没有组件，或者有组件，尚未验证。
        另请参见：
        getLayoutInfo(Container, int)

      • columnWidths

        public int[] columnWidths
        此字段将覆盖列的最小宽度。 如果此字段不是null ，则在计算所有最小列宽度之后，将值应用于网格包。 如果columnWidths具有比列数更多的元素，列将添加到gridbag中以匹配columnWidth中的元素数。
        另请参见：
        getLayoutDimensions()

      • rowHeights

        public int[] rowHeights
        此字段将覆盖行的最小高度。 如果此字段不是null ，则在计算所有最小行高后，将其应用于网格包。 如果rowHeights具有比行数更多的元素，则将行添加到rowHeights以匹配rowHeights的元素rowHeights 。
        另请参见：
        getLayoutDimensions()

      • columnWeights

        public double[] columnWeights
        此字段保留对列权重的覆盖。 如果此字段不是null ，则在计算所有列权重之后，将值应用于网格包。 如果列i的重量为columnWeights[i] > ，则列i的重量分配在columnWeights[i] 。 如果columnWeights具有比列数更多的元素，则会忽略多余的元素 - 它们不会导致创建更多的列。

      • rowWeights

        public double[] rowWeights
        此字段保留对行权重的覆盖。 如果此字段不是null ，则在计算所有行权重之后，将值应用于网格包。 如果行i的重量为rowWeights[i] > ，那么行i的重量分配在rowWeights[i] 。 如果rowWeights具有比行数更多的元素，则忽略多余的元素 - 它们不会导致创建更多的行。

    • 构造方法详细信息

      • GridBagLayout

        public GridBagLayout​()
        创建网格包布局管理器。

    • 方法详细信息

      • setConstraints

        public void setConstraints​(Component comp,
                           GridBagConstraints constraints)
        设置此布局中指定组件的约束。
        参数
        comp - 要修改的组件
        constraints - 要应用的约束

      • getConstraints

        public GridBagConstraints getConstraints​(Component comp)
        获取指定组件的约束。 返回实际的GridBagConstraints对象的副本。
        参数
        comp - 要查询的组件
        结果
        该网格包布局中指定组件的约束; 返回实际约束对象的副本

      • lookupConstraints

        protected GridBagConstraints lookupConstraints​(Component comp)
        检索指定组件的约束。 返回值不是副本，而是布局机制使用的实际对象GridBagConstraints对象。

        如果comp不在GridBagLayout ，则返回一组默认值GridBagConstraints 。 A comp值null无效，返回null 。

        参数
        comp - 要查询的组件
        结果
        指定组件的约束

      • getLayoutOrigin

        public Point getLayoutOrigin​()
        确定目标容器的图形坐标空间中的布局区域的原点。 该值表示布局区域左上角的像素坐标，而不考虑容器的ComponentOrientation值。 这与由单元格坐标（0,0）给出的网格原点不同。 大多数应用程序不直接调用此方法。
        结果
        布局网格左上角的单元格的图形原点
        从以下版本开始：
        1.1
        另请参见：
        ComponentOrientation

      • getLayoutDimensions

        public int[][] getLayoutDimensions​()
        确定布局网格的列宽和行高。

        大多数应用程序不直接调用此方法。

        结果
        两个数组的数组，包含布局列的宽度和布局行的高度
        从以下版本开始：
        1.1

      • getLayoutWeights

        public double[][] getLayoutWeights​()
        确定布局网格的列和行的权重。 如果布局有额外的空间，重量用于计算给定列或列延伸超出其首选尺寸的数量。

        大多数应用程序不直接调用此方法。

        结果
        两个数组的数组，表示布局列的横向权重和布局行的垂直权重
        从以下版本开始：
        1.1

      • location

        public Point location​(int x,
                      int y)
        确定布局网格中的单元格包含由(x, y)指定的点。 每个单元格通过其列索引（范围从0到列数减1）和其行索引（范围从0到行数减1）来标识。

        如果(x, y)点位于网格外，则使用以下规则。 如果x位于左至右容器布局的左侧或右至左容器布局右侧，则列索引返回为零。 列索引作为列数返回，如果x位于左右容器中的布局右侧或右至左容器中的左侧。 如果y位于布局上方，则行索引为零，并且如果y位于布局下方，则行索引返回为零。 容器的方向由其ComponentOrientation属性确定。

        参数
        x - 一个点的 x坐标
        y - 点的 y坐标
        结果
        指示布局网格中的单元格包含点（ x ， y ）的有序索引对。
        从以下版本开始：
        1.1
        另请参见：
        ComponentOrientation

      • addLayoutComponent

        public void addLayoutComponent​(String name,
                               Component comp)
        没有效果，因为此布局管理器不使用每个组件字符串。
        Specified by:
        addLayoutComponent在接口 LayoutManager
        参数
        name - 要与组件关联的字符串
        comp - 要添加的组件

      • addLayoutComponent

        public void addLayoutComponent​(Component comp,
                               Object constraints)
        使用指定的constraints对象将指定的组件添加到布局。 请注意，约束是可变的，因此在缓存时被克隆。
        Specified by:
        addLayoutComponent在接口 LayoutManager2
        参数
        comp - 要添加的组件
        constraints - 确定组件如何添加到布局的对象
        异常
        IllegalArgumentException - 如果 constraints不是 GridBagConstraint

      • removeLayoutComponent

        public void removeLayoutComponent​(Component comp)
        从此布局中删除指定的组件。

        大多数应用程序不直接调用此方法。

        Specified by:
        removeLayoutComponent在接口 LayoutManager
        参数
        comp - 要移除的组件。
        另请参见：
        Container.remove(java.awt.Component) ， Container.removeAll()

      • preferredLayoutSize

        public Dimension preferredLayoutSize​(Container parent)
        使用此网格包布局确定parent容器的首选大小。

        大多数应用程序不直接调用此方法。

        Specified by:
        preferredLayoutSize在接口 LayoutManager
        参数
        parent - 进行布局的容器
        结果
        parent容器的首选尺寸
        另请参见：
        Container.getPreferredSize()

      • minimumLayoutSize

        public Dimension minimumLayoutSize​(Container parent)
        使用此网格包布局确定parent容器的最小尺寸。

        大多数应用程序不直接调用此方法。

        Specified by:
        minimumLayoutSize在接口 LayoutManager
        参数
        parent - 进行布局的容器
        结果
        parent容器的最小尺寸
        另请参见：
        Container.doLayout()

      • maximumLayoutSize

        public Dimension maximumLayoutSize​(Container target)
        给定指定目标容器中的组件的返回布局的最大尺寸。
        Specified by:
        maximumLayoutSize在接口 LayoutManager2
        参数
        target - 需要布置的容器
        结果
        此布局的最大尺寸
        另请参见：
        Container ， minimumLayoutSize(Container) ， preferredLayoutSize(Container)

      • getLayoutAlignmentX

        public float getLayoutAlignmentX​(Container parent)
        返回沿x轴的对齐方式。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        Specified by:
        getLayoutAlignmentX接口 LayoutManager2
        参数
        parent - 目标容器
        结果
        值 0.5f表示居中

      • getLayoutAlignmentY

        public float getLayoutAlignmentY​(Container parent)
        返回沿着y轴的对齐。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        Specified by:
        getLayoutAlignmentY在接口 LayoutManager2
        参数
        parent - 目标容器
        结果
        值 0.5f表示居中

      • invalidateLayout

        public void invalidateLayout​(Container target)
        使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
        Specified by:
        invalidateLayout在接口 LayoutManager2
        参数
        target - 目标容器

      • layoutContainer

        public void layoutContainer​(Container parent)
        使用此网格包布局来放出指定的容器。 此方法会重塑为了满足这种的约束在指定的容器组件GridBagLayout对象。

        大多数应用程序不直接调用此方法。

        Specified by:
        layoutContainer在接口 LayoutManager
        参数
        parent - 要进行布局的容器
        另请参见：
        Container ， Container.doLayout()

      • toString

        public String toString​()
        返回此网格包布局值的字符串表示形式。
        重写：
        toString在 Object
        结果
        这个网格包布局的字符串表示形式。

      • getLayoutInfo

        protected GridBagLayoutInfo getLayoutInfo​(Container parent,
                                          int sizeflag)
        针对当前管理的儿童集GridBagLayoutInfo一个GridBagLayoutInfo的例子。 这需要通过一组孩子三次：
        1. 找出布局网格的尺寸。
        2. 确定组件占用的单元格。
        3. 在行/列之间分配权重和最小大小。
        这也缓存了所有孩子首次遇到的最小化（因此后续循环不需要再次询问）。

        这种方法只能在内部使用GridBagLayout 。

        参数
        parent - 布局容器
        sizeflag - PREFERREDSIZE或 MINSIZE
        结果
        GridBagLayoutInfo为一套儿童
        从以下版本开始：
        1.4

      • GetLayoutInfo

        protected GridBagLayoutInfo GetLayoutInfo​(Container parent,
                                          int sizeflag)
        此方法已过时，仅供后向兼容; 新代码应该调用getLayoutInfo 。 针对当前管理的儿童组GridBagLayoutInfo的实例。 此方法与getLayoutInfo相同; 详见getLayoutInfo说明。
        参数
        parent - 布局容器
        sizeflag - PREFERREDSIZE或 MINSIZE
        结果
        该 GridBagLayoutInfo的孩子

      • adjustForGravity

        protected void adjustForGravity​(GridBagConstraints constraints,
                                Rectangle r)
        根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。 该方法只能由内部使用GridBagLayout 。
        参数
        constraints - 要应用的约束
        r - 要调整的 Rectangle
        从以下版本开始：
        1.4

      • AdjustForGravity

        protected void AdjustForGravity​(GridBagConstraints constraints,
                                Rectangle r)
        根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。

        此方法已过时，仅供后向兼容; 新代码应该调用adjustForGravity 。 此方法与adjustForGravity相同

        参数
        constraints - 要应用的约束
        r - 要调整的 Rectangle

      • getMinSize

        protected Dimension getMinSize​(Container parent,
                               GridBagLayoutInfo info)
        根据getLayoutInfo的信息， getLayoutInfo主站的最小尺寸。 该方法只能由内部使用GridBagLayout 。
        参数
        parent - 布局容器
        info - 这个父母的布局信息
        结果
        一个包含最小尺寸的 Dimension对象
        从以下版本开始：
        1.4

      • GetMinSize

        protected Dimension GetMinSize​(Container parent,
                               GridBagLayoutInfo info)
        此方法已过时，仅供后向兼容; 新代码应该调用getMinSize 。 此方法与getMinSize相同
        参数
        parent - 布局容器
        info - 这个父母的布局信息
        结果
        一个 Dimension对象包含最小大小

      • arrangeGrid

        protected void arrangeGrid​(Container parent)
        排出电网。 这种方法只能在内部使用GridBagLayout 。
        参数
        parent - 布局容器
        从以下版本开始：
        1.4

      • ArrangeGrid

        protected void ArrangeGrid​(Container parent)
        此方法已过时，仅供后向兼容; 新代码应该调用arrangeGrid 。 该方法与arrangeGrid相同
        参数
        parent - 布局容器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GridBagLayoutInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GridBagLayoutInfo

  • java.lang.Object
    • java.awt.GridBagLayoutInfo
  • All Implemented Interfaces:
    Serializable

    public class GridBagLayoutInfo
extends Object
implements Serializable
    GridBagLayoutInfo是一个用于GridBagLayout布局管理器的实用程序类。 它存储容器内每个组件的对齐方式，大小和基线参数。
    从以下版本开始：
    1.6
    另请参见：
    GridBagLayout ， GridBagConstraints ， Serialized Form

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GridLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class GridLayout

  • java.lang.Object
    • java.awt.GridLayout
  • All Implemented Interfaces:
    LayoutManager ， Serializable

    public class GridLayout
extends Object
implements LayoutManager, Serializable
    GridLayout类是一个布局管理器，它将一个容器的组件放在矩形网格中。 容器被分成等大小的矩形，并且每个矩形中放置一个组件。 例如，以下是一个小程序，它将六个按钮放置成三行和两列：
     import java.awt.*;
 import java.applet.Applet;
 public class ButtonGrid extends Applet {
     public void init() {
         setLayout(new GridLayout(3,2));
         add(new Button("1"));
         add(new Button("2"));
         add(new Button("3"));
         add(new Button("4"));
         add(new Button("5"));
         add(new Button("6"));
     }
 }

    如果容器的ComponentOrientation属性是水平的并且从左到右，则上述示例生成图1所示的输出。如果容器的ComponentOrientation属性是水平的并且从右到左，则该示例生成如图2所示的输出。

    Figures Shows 6 buttons in rows of 2. Row 1 shows buttons 1 then 2. Row 2 shows buttons 3 then 4. Row 3 shows buttons 5 then 6. Shows 6 buttons in rows of 2. Row 1 shows buttons 2 then 1. Row 2 shows buttons 4 then 3. Row 3 shows buttons 6 then 5. Figure 1: Horizontal, Left-to-Right Figure 2: Horizontal, Right-to-Left

    当行数和列数都被设置为非零值时，无论是通过构造方法还是通过setRows和setColumns方法，都会忽略指定的列数。 而是从指定的行数和布局中的组件总数确定列的数量。 因此，例如，如果已经指定了三行和两列，并且将九个组件添加到布局，则它们将显示为三列三列。 仅当行数设置为零时，才指定列数影响布局。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      GridLayout​()
      在单个行中创建一个每个组件的默认值为一列的网格布局。
      GridLayout​(int rows, int cols)
      创建具有指定行数和列数的网格布局。
      GridLayout​(int rows, int cols, int hgap, int vgap)
      创建具有指定行数和列数的网格布局。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addLayoutComponent​(String name, Component comp)
      将具有指定名称的指定组件添加到布局。
      int getColumns​()
      获取此布局中的列数。
      int getHgap​()
      获得组件之间的水平间隙。
      int getRows​()
      获取此布局中的行数。
      int getVgap​()
      获取组件之间的垂直间距。
      void layoutContainer​(Container parent)
      使用此布局放出指定的容器。
      Dimension minimumLayoutSize​(Container parent)
      使用此网格布局确定容器参数的最小大小。
      Dimension preferredLayoutSize​(Container parent)
      使用此网格布局确定容器参数的首选大小。
      void removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void setColumns​(int cols)
      将此布局中的列数设置为指定的值。
      void setHgap​(int hgap)
      将组件之间的水平间距设置为指定值。
      void setRows​(int rows)
      将此布局中的行数设置为指定的值。
      void setVgap​(int vgap)
      将组件之间的垂直间距设置为指定值。
      String toString​()
      返回此网格布局值的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • GridLayout

        public GridLayout​()
        在单个行中创建一个每个组件的默认值为一列的网格布局。
        从以下版本开始：
        1.1

      • GridLayout

        public GridLayout​(int rows,
                  int cols)
        创建具有指定行数和列数的网格布局。 布局中的所有组件都具有相同的大小。

        rows和cols一个但不是两个可以为零，这意味着可以将任意数量的对象放置在一行或一列中。

        参数
        rows - 行，值为零表示任意数量的行。
        cols - 列，值为零表示任意数量的列。

      • GridLayout

        public GridLayout​(int rows,
                  int cols,
                  int hgap,
                  int vgap)
        创建具有指定行数和列数的网格布局。 布局中的所有组件都具有相同的大小。

        此外，水平和垂直间隙被设置为指定的值。 每个列之间放置水平间隙。 在每行之间放置垂直间隙。

        rows和cols一个但不是两个可以为零，这意味着可以将任意数量的对象放置在行或列中。

        所有GridLayout构造函数都GridLayout这一个。

        参数
        rows - 值为0，表示任意数量的行
        cols - 列，值为零表示任意数量的列
        hgap - 水平间隙
        vgap - 垂直间隙
        异常
        IllegalArgumentException - 如果 rows和 cols的值都设置为零

    • 方法详细信息

      • getRows

        public int getRows​()
        获取此布局中的行数。
        结果
        此布局中的行数
        从以下版本开始：
        1.1

      • setRows

        public void setRows​(int rows)
        将此布局中的行数设置为指定的值。
        参数
        rows - 此布局中的行数
        异常
        IllegalArgumentException - 如果 rows和 cols的值都设置为零
        从以下版本开始：
        1.1

      • getColumns

        public int getColumns​()
        获取此布局中的列数。
        结果
        此布局中的列数
        从以下版本开始：
        1.1

      • setColumns

        public void setColumns​(int cols)
        将此布局中的列数设置为指定的值。 如果由构造函数指定的行数或由setRows方法指定的行数不为零，则设置列数对布局没有影响。 在这种情况下，布局中显示的列数由组件的总数和指定的行数决定。
        参数
        cols - 此布局中的列数
        异常
        IllegalArgumentException - 如果 rows和 cols的值都设置为零
        从以下版本开始：
        1.1

      • getHgap

        public int getHgap​()
        获得组件之间的水平间隙。
        结果
        组件之间的水平间隙
        从以下版本开始：
        1.1

      • setHgap

        public void setHgap​(int hgap)
        将组件之间的水平间距设置为指定值。
        参数
        hgap - 组件之间的水平间隙
        从以下版本开始：
        1.1

      • getVgap

        public int getVgap​()
        获取组件之间的垂直间距。
        结果
        组件之间的垂直间隙
        从以下版本开始：
        1.1

      • setVgap

        public void setVgap​(int vgap)
        将组件之间的垂直间距设置为指定值。
        参数
        vgap - 组件之间的垂直间隙
        从以下版本开始：
        1.1

      • addLayoutComponent

        public void addLayoutComponent​(String name,
                               Component comp)
        将具有指定名称的指定组件添加到布局。
        Specified by:
        addLayoutComponent在接口 LayoutManager
        参数
        name - 组件的名称
        comp - 要添加的组件

      • removeLayoutComponent

        public void removeLayoutComponent​(Component comp)
        从布局中删除指定的组件。
        Specified by:
        removeLayoutComponent在接口 LayoutManager
        参数
        comp - 要删除的组件

      • preferredLayoutSize

        public Dimension preferredLayoutSize​(Container parent)
        使用此网格布局确定容器参数的首选大小。

        网格布局的首选宽度是容器中所有组件的最大优先宽度乘以列数，加上水平填充次数，列数减1，加上目标容器的左和右插入。

        网格布局的首选高度是容器中所有组件的最大优先高度乘以行数，加上垂直填充次数，行数减1，加上目标容器的顶部和底部插入。

        Specified by:
        preferredLayoutSize在接口 LayoutManager
        参数
        parent - 要进行布局的容器
        结果
        布置指定容器的子组件的首选尺寸
        另请参见：
        minimumLayoutSize(java.awt.Container) ， Container.getPreferredSize()

      • minimumLayoutSize

        public Dimension minimumLayoutSize​(Container parent)
        使用此网格布局确定容器参数的最小大小。

        网格布局的最小宽度是容器中所有组件的最大最小宽度乘以列数，加上水平填充次数，列数减1，加上目标容器的左和右插入。

        网格布局的最小高度是容器中所有组件的最大最小高度乘以行数，加上垂直填充乘以行数减1，加上目标容器的顶部和底部插入。

        Specified by:
        minimumLayoutSize在接口 LayoutManager
        参数
        parent - 进行布局的容器
        结果
        布置指定容器的子组件所需的最小尺寸
        另请参见：
        preferredLayoutSize(java.awt.Container) ， Container.doLayout()

      • layoutContainer

        public void layoutContainer​(Container parent)
        使用此布局放出指定的容器。

        该方法重新形成指定目标容器中的组件，以满足GridLayout对象的约束。

        网格布局管理器根据布局中的行数和列数将容器中的可用空间分成相等大小的部分来确定各个组件的大小。 容器的可用空间等于容器的尺寸减去任何插入物和任何指定的水平或垂直间隙。 网格布局中的所有组件都具有相同的大小。

        Specified by:
        layoutContainer在接口 LayoutManager
        参数
        parent - 进行布局的容器
        另请参见：
        Container ， Container.doLayout()

      • toString

        public String toString​()
        返回此网格布局值的字符串表示形式。
        重写：
        toString在 Object
        结果
        此网格布局的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HeadlessException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class HeadlessException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.UnsupportedOperationException
            • java.awt.HeadlessException
  • All Implemented Interfaces:
    Serializable

    public class HeadlessException
extends UnsupportedOperationException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。 依赖于任何这些设备中的任何代码应该使用首先确保它们的可用性GraphicsEnvironment.isHeadless()方法，并抛出HeadlessException如果后者返回true 。
    从以下版本开始：
    1.4
    另请参见：
    GraphicsEnvironment.isHeadless() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      HeadlessException​()
      构造新的 HeadlessException与空消息。
      HeadlessException​(String msg)
      使用指定的详细错误消息创建一个新实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getMessage​()
      返回此 HeadlessException的详细消息字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • HeadlessException

        public HeadlessException​()
        构造新的HeadlessException与空消息。 对于这样的HeadlessException ，某些平台可能会自动生成默认的无头错误消息。 默认的无头信息的文本可能取决于GraphicsEnvironment是否实际上是无头的。 也就是说，默认的无头信息是系统和环境依赖的。

      • HeadlessException

        public HeadlessException​(String msg)
        使用指定的详细错误消息创建一个新实例。 对于某些平台，可以在指定的消息的末尾添加默认的无头错误消息。 默认的无头信息的文本可能取决于GraphicsEnvironment是否实际上是无头的。 也就是说，默认的无头信息是系统和环境依赖的。
        参数
        msg - 错误信息

    • 方法详细信息

      • getMessage

        public String getMessage​()
        返回此HeadlessException的详细消息字符串。 根据平台，构造函数中指定的消息可能后跟默认的无头错误消息。 默认的无头信息的文本可能取决于GraphicsEnvironment是否实际上是无头的。 也就是说，默认的无头信息是系统和环境依赖的。
        重写：
        getMessage在 Throwable
        结果
        the detail message string of this HeadlessException instance (which may be null).
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalComponentStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class IllegalComponentStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.awt.IllegalComponentStateException
  • All Implemented Interfaces:
    Serializable

    public class IllegalComponentStateException
extends IllegalStateException
    表示AWT组件对于请求的操作不在适当的状态。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalComponentStateException​()
      构造一个没有详细消息的IllegalComponentStateException。
      IllegalComponentStateException​(String s)
      构造具有指定详细消息的IllegalComponentStateException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalComponentStateException

        public IllegalComponentStateException​()
        构造一个没有详细消息的IllegalComponentStateException。 详细消息是描述此特定异常的字符串。

      • IllegalComponentStateException

        public IllegalComponentStateException​(String s)
        构造具有指定详细消息的IllegalComponentStateException。 详细消息是描述此特定异常的字符串。
        参数
        s - 包含详细消息的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Image

  • java.lang.Object
    • java.awt.Image
  • 已知直接子类：
    AbstractMultiResolutionImage ， BufferedImage ， VolatileImage

    public abstract class Image
extends Object
    抽象类Image是表示图形图像的所有类的超类。 必须以平台特定的方式获取图像。
    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected float accelerationPriority
      优先加速此图像。
      static int SCALE_AREA_AVERAGING
      使用区域平均图像缩放算法。
      static int SCALE_DEFAULT
      使用默认的图像缩放算法。
      static int SCALE_FAST
      选择一种图像缩放算法，比缩放图像的平滑度更高优先级。
      static int SCALE_REPLICATE
      使用 ReplicateScaleFilter类中体现的图像缩放算法。
      static int SCALE_SMOOTH
      选择一种图像缩放算法，其优先级高于图像平滑度，而不是缩放速度。
      static Object UndefinedProperty
      每当获取未为特定图像定义的属性时，应返回 UndefinedProperty对象。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Image​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void flush​()
      刷新此Image对象正在使用的所有可重建资源。
      float getAccelerationPriority​()
      返回加速优先提示的当前值。
      ImageCapabilities getCapabilities​(GraphicsConfiguration gc)
      返回一个ImageCapabilities对象，可以在指定的GraphicsConfiguration上查询该Image的功能。
      abstract Graphics getGraphics​()
      创建图形上下文以绘制到离屏图像。
      abstract int getHeight​(ImageObserver observer)
      确定图像的高度。
      abstract Object getProperty​(String name, ImageObserver observer)
      通过名称获取此图像的属性。
      Image getScaledInstance​(int width, int height, int hints)
      创建此图像的缩放版本。
      abstract ImageProducer getSource​()
      获取产生图像像素的对象。
      abstract int getWidth​(ImageObserver observer)
      确定图像的宽度。
      void setAccelerationPriority​(float priority)
      为此图像设置一个关于加速度有多重要的提示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • accelerationPriority

        protected float accelerationPriority
        优先加速此图像。 子类可以自由设置不同的默认优先级，应用程序可以通过setAccelerationPriority(float)方法自由设置特定图像的优先级。
        从以下版本开始：
        1.5

      • UndefinedProperty

        public static final Object UndefinedProperty
        每当获取未为特定图像定义的属性时，应返回 UndefinedProperty对象。

      • SCALE_DEFAULT

        public static final int SCALE_DEFAULT
        使用默认的图像缩放算法。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SCALE_FAST

        public static final int SCALE_FAST
        选择一种图像缩放算法，比缩放图像的平滑度更高优先级。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SCALE_SMOOTH

        public static final int SCALE_SMOOTH
        选择一种图像缩放算法，其优先级高于图像平滑度，而不是缩放速度。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SCALE_REPLICATE

        public static final int SCALE_REPLICATE
        使用ReplicateScaleFilter类中体现的图像缩放算法。 Image对象可以自由替代执行相同算法的不同过滤器，而且可以更有效地集成到由工具包提供的成像基础架构中。
        从以下版本开始：
        1.1
        另请参见：
        ReplicateScaleFilter ， Constant Field Values

      • SCALE_AREA_AVERAGING

        public static final int SCALE_AREA_AVERAGING
        使用区域平均图像缩放算法。 图像对象可以自由地替换执行相同算法的不同过滤器，而且更有效地集成到工具包提供的图像基础设施中。
        从以下版本开始：
        1.1
        另请参见：
        AreaAveragingScaleFilter ， Constant Field Values

    • 构造方法详细信息

      • Image

        public Image​()

    • 方法详细信息

      • getWidth

        public abstract int getWidth​(ImageObserver observer)
        确定图像的宽度。 如果宽度尚未知道，则此方法返回-1 ，稍后通知指定的ImageObserver对象。
        参数
        observer - 等待图像加载的对象。
        结果
        该图像的宽度，如果宽度尚未知道， -1 。
        另请参见：
        getHeight(java.awt.image.ImageObserver) ， ImageObserver

      • getHeight

        public abstract int getHeight​(ImageObserver observer)
        确定图像的高度。 如果高度尚未知道，则此方法返回-1 ，稍后通知指定的ImageObserver对象。
        参数
        observer - 等待图像加载的对象。
        结果
        这个图像的高度，或 -1如果高度还不知道。
        另请参见：
        getWidth(java.awt.image.ImageObserver) ， ImageObserver

      • getSource

        public abstract ImageProducer getSource​()
        获取产生图像像素的对象。 该方法由图像过滤类和执行图像转换和缩放的方法调用。
        结果
        该图像生成器生成该图像的像素。
        另请参见：
        ImageProducer

      • getGraphics

        public abstract Graphics getGraphics​()
        创建图形上下文以绘制到离屏图像。 该方法只能用于离屏图像。
        结果
        绘制到屏幕外图像的图形上下文。
        异常
        UnsupportedOperationException - 如果调用了非屏幕截图图像。
        另请参见：
        Graphics ， Component.createImage(int, int)

      • getProperty

        public abstract Object getProperty​(String name,
                                   ImageObserver observer)
        通过名称获取此图像的属性。

        单个属性名称由各种图像格式定义。 如果未为特定图像定义属性，则此方法返回UndefinedProperty对象。

        如果此图像的属性尚未知道，则此方法返回null ，稍后通知ImageObserver对象。

        应使用属性名称"comment"来存储一个可选的注释，该注释可以作为图像，其来源或作者的描述呈现给应用程序。

        参数
        name - 属性名称。
        observer - 等待加载图像的对象。
        结果
        命名属性的值。
        异常
        NullPointerException - 如果属性名称为空。
        另请参见：
        ImageObserver ， UndefinedProperty

      • getScaledInstance

        public Image getScaledInstance​(int width,
                               int height,
                               int hints)
        创建此图像的缩放版本。 将返回一个新的Image对象，默认情况下将渲染指定的图像为width和height 。 即使原始源图像已经完全加载，新的Image对象也可能异步加载。

        如果width或height是负数，则代替值来维持原始图像尺寸的宽高比。 如果width和height都为负数，则使用原始图像尺寸。

        参数
        width - 缩放图像的宽度。
        height - 缩放图像的高度。
        hints - 用于指示用于图像重采样的算法类型的标志。
        结果
        图像的缩放版本。
        异常
        IllegalArgumentException - 如果 width或 height为零。
        从以下版本开始：
        1.1
        另请参见：
        SCALE_DEFAULT ， SCALE_FAST ， SCALE_SMOOTH ， SCALE_REPLICATE ， SCALE_AREA_AVERAGING

      • flush

        public void flush​()
        刷新此Image对象正在使用的所有可重建资源。 这包括正被缓存以呈现到屏幕的任何像素数据以及用于存储图像的数据或像素的任何系统资源，如果可以重新创建它们。 图像被重置为类似于首次创建的状态，以便如果再次呈现，则图像数据将不得不从其源重新创建或再次获取。

        该方法如何影响Image对象的特定类型的示例：

        • BufferedImage对象离开主要的栅格，将其像素保持不变，但可以刷新任何缓存有关像素的信息，例如上传到显示硬件的副本，以加速闪存。
        • 由Component方法创建的图像对象，其宽度和高度使其主要像素缓冲区保持不变，但是缓冲信息的释放与BufferedImage对象完全相同。
        • VolatileImage对象释放其所有像素资源，包括其主要副本，这些副本通常存储在资源稀少的显示硬件上。 以后可以使用它们的validate方法恢复这些对象。
        • 由文件，URL加载的或由ImageProducer生成的Toolkit和Component类创建的图像对象将被卸载，并释放所有本地资源。 这些对象随后可以根据需要从原始源重新载入，就像在第一次创建时一样。

      • getCapabilities

        public ImageCapabilities getCapabilities​(GraphicsConfiguration gc)
        返回一个ImageCapabilities对象，可以在指定的GraphicsConfiguration上查询该Image的功能。 这允许程序员找到关于他们创建的特定Image对象的更多运行时信息。 例如，用户可能会创建一个BufferedImage，但是系统可能没有视频内存用于在给定的GraphicsConfiguration上创建该大小的映像，因此虽然该对象通常可以加速，但它在该GraphicsConfiguration上没有这种功能。
        参数
        gc - 一个GraphicsConfiguration对象。 此参数的值为null将导致获取默认GraphicsConfiguration的映像功能。
        结果
        一个 ImageCapabilities对象，其中包含此 Image在指定的GraphicsConfiguration上的功能。
        从以下版本开始：
        1.5
        另请参见：
        VolatileImage.getCapabilities()

      • setAccelerationPriority

        public void setAccelerationPriority​(float priority)
        为此图像设置一个关于加速度有多重要的提示。 此优先提示用于在确定如何使用诸如视频存储器之类的稀缺加速资源时与其他Image对象的优先级进行比较。 当有可能加速此图像时，如果没有足够的资源可用来提供加速度，但足够的资源可以通过降低某些较低优先级的其他图像而被释放，那么该其他图像可能会被减速到这一个 具有相同优先级的图像以先到先得的方式占用资源。
        参数
        priority - 0和1之间的值，包括0和1，其中较高的值表示加速度更重要。 值为0意味着此图像不应该加速。 其他值仅用于确定相对于其他图像的加速优先级。
        异常
        IllegalArgumentException - 如果 priority小于零或大于1。
        从以下版本开始：
        1.5

      • getAccelerationPriority

        public float getAccelerationPriority​()
        返回加速优先提示的当前值。
        结果
        值在0和1之间，包括0，表示当前优先级值
        从以下版本开始：
        1.5
        另请参见：
        setAccelerationPriority
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImageCapabilities (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class ImageCapabilities

  • java.lang.Object
    • java.awt.ImageCapabilities
  • All Implemented Interfaces:
    Cloneable

    public class ImageCapabilities
extends Object
implements Cloneable
    图像的能力和属性。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageCapabilities​(boolean accelerated)
      创建一个用于指定图像功能的新对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建并返回此对象的副本。
      boolean isAccelerated​()
      如果能够封装在这个 ImageCapabilities的对象可以被加速，则返回 true 。
      boolean isTrueVolatile​()
      如果 VolatileImage描述的 ImageCapabilities可能会丢失其表面，则返回 true 。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ImageCapabilities

        public ImageCapabilities​(boolean accelerated)
        创建一个用于指定图像功能的新对象。
        参数
        accelerated - 是否需要加速图像

    • 方法详细信息

      • isAccelerated

        public boolean isAccelerated​()
        如果能够封装在此 ImageCapabilities的对象可以被加速，则返回 true 。
        结果
        图像是否可以或正在被加速。 有各种平台特定的方法来加速图像，包括像素图，VRAM，AGP。 这是一般的加速方法（而不是驻留在系统内存中）。

      • isTrueVolatile

        public boolean isTrueVolatile​()
        如果 VolatileImage描述的 ImageCapabilities可能会丢失其表面，则返回 true 。
        结果
        无论挥发性图像是否以操作系统的奇怪而失去其表面。

      • clone

        public Object clone​()
        描述从类别复制： Object
        创建并返回此对象的副本。 “复制”的精确含义可能取决于对象的类。 一般的意图是，对于任何对象x ，表达式：
         x.clone() != x
        将是真实的，而且表达：
         x.clone().getClass() == x.getClass()
        将是true ，但这些都不是绝对的要求。 通常情况是：
         x.clone().equals(x)
        将是true ，这不是绝对的要求。

        按照惯例，返回的对象应该通过调用super.clone获得。 如果一个类和它的所有超类（除了Object ）遵守这个惯例，那就是x.clone().getClass() == x.getClass()的情况。

        按照惯例，此方法返回的对象应该与此对象（正被克隆）无关。 为了实现这种独立性，可能需要修改super.clone返回的对象的一个或多个字段。 通常，这意味着复制构成被克隆的对象的内部“深层结构”的任何可变对象，并通过引用该副本替换对这些对象的引用。 如果一个类仅包含原始字段或对不可变对象的引用，则通常情况下， super.clone返回的对象中的字段通常不需要修改。

        该方法clone类Object执行特定克隆操作。 首先，如果此对象的类不实现接口Cloneable ，则抛出一个CloneNotSupportedException 。 请注意，所有阵列被认为是实现该接口Cloneable并且所述的返回类型clone数组类型的方法T[]是T[]其中T是任何引用或原始类型。 否则，该方法将创建该对象的类的新实例，并将其所有字段初始化为该对象的相应字段的内容，就像通过赋值一样。 这些字段的内容本身不被克隆。 因此，该方法执行该对象的“浅拷贝”，而不是“深度拷贝”操作。

        Object类Object并不实现接口Cloneable ，因此在类别为Object的对象上调用clone方法将导致在运行时抛出异常。

        重写：
        clone在 Object
        结果
        该ImageCapabilities对象的副本。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Insets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Insets

  • java.lang.Object
    • java.awt.Insets
  • All Implemented Interfaces:
    Serializable ， Cloneable
    已知直接子类：
    InsetsUIResource

    public class Insets
extends Object
implements Cloneable, Serializable
    一个Insets对象是容器边框的表示。 它指定容器必须在其每个边缘处留下的空间。 空格可以是边框，空格或标题。
    从以下版本开始：
    1.0
    另请参见：
    LayoutManager ， Container ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      int bottom
      从底部的插图。
      int left
      从左边的插图。
      int right
      从右边插入。
      int top
      从顶部的插图。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Insets​(int top, int left, int bottom, int right)
      使用指定的顶部，左侧，底部和右侧插入创建并初始化新的 Insets对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建此对象的副本。
      boolean equals​(Object obj)
      检查两个插入对象是否相等。
      int hashCode​()
      返回此Insets的哈希码。
      void set​(int top, int left, int bottom, int right)
      将顶部，左侧，底部和右侧设置为指定的值
      String toString​()
      返回此 Insets对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • top

        public int top
        从顶部的插图。 该值被添加到矩形的顶部以产生Top的新位置。
        另请参见：
        clone()

      • left

        public int left
        从左边的插图。 该值被添加到矩形的左侧以产生左边缘的新位置。
        另请参见：
        clone()

      • bottom

        public int bottom
        从底部的插图。 该值从矩形的底部减去，以产生底部的新位置。
        另请参见：
        clone()

      • right

        public int right
        从右边插入。 该值从矩形右侧减去，以产生右边缘的新位置。
        另请参见：
        clone()

    • 构造方法详细信息

      • Insets

        public Insets​(int top,
              int left,
              int bottom,
              int right)
        使用指定的顶部，左侧，底部和右侧插入创建并初始化新的 Insets对象。
        参数
        top - 从顶部的插图。
        left - 从左边的插图。
        bottom - 从底部的插图。
        right - 从右边的插图。

    • 方法详细信息

      • set

        public void set​(int top,
                int left,
                int bottom,
                int right)
        将顶部，左侧，底部和右侧设置为指定的值
        参数
        top - 从顶部的插图。
        left - 从左边的插图。
        bottom - 底部的插图。
        right - 从右边的插图。
        从以下版本开始：
        1.5

      • equals

        public boolean equals​(Object obj)
        检查两个插入对象是否相等。 的两个实例Insets都是平等的，如果字段的四个整数值top ， left ， bottom ，并right都是平等的。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果两个插图相等， true ; 否则false 。
        从以下版本开始：
        1.1
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此Insets的哈希码。
        重写：
        hashCode Object
        结果
        这个Insets的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此Insets对象的字符串表示形式。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        toString在 Object
        结果
        这个 Insets对象的字符串表示形式。

      • clone

        public Object clone​()
        创建此对象的副本。
        重写：
        clone在 Object
        结果
        这个 Insets对象的副本。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ItemSelectable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface ItemSelectable

  • All Known Subinterfaces:
    ButtonModel
    所有已知实现类：
    AbstractButton ， BasicArrowButton ， Checkbox ， CheckboxMenuItem ， Choice ， DefaultButtonModel ， JButton ， JCheckBox ， JCheckBoxMenuItem ， JComboBox ， JMenu ， JMenuItem ， JRadioButton ， JRadioButtonMenuItem ， JToggleButton ， JToggleButton.ToggleButtonModel ， List ， MetalComboBoxButton ， MetalScrollButton

    public interface ItemSelectable
    可以选择包含零个或多个项目的对象的对象接口。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addItemListener​(ItemListener l)
      当用户更改项目的状态时，添加监听器以接收项目事件。
      Object[] getSelectedObjects​()
      如果没有选择项目，则返回所选项目或 null 。
      void removeItemListener​(ItemListener l)
      删除项目侦听器。

    • 方法详细信息

      • getSelectedObjects

        Object[] getSelectedObjects​()
        如果未选择任何项目，则返回所选项目或 null 。
        结果
        所选对象的列表，或 null

      • addItemListener

        void addItemListener​(ItemListener l)
        当用户更改项目的状态时，添加监听器以接收项目事件。 当项目的状态以编程方式设置时，不会发送项目事件。 如果l为null ，则不会抛出任何异常，也不会执行任何操作。
        参数
        l - 接收事件的侦听器
        另请参见：
        ItemEvent

      • removeItemListener

        void removeItemListener​(ItemListener l)
        删除项目侦听器。 如果l为null ，则不会抛出异常，也不会执行任何操作。
        参数
        l - 被删除的侦听器
        另请参见：
        ItemEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt (Java SE 9 & JDK 9 )

java.awt

Interfaces

  • ActiveEvent
  • Adjustable
  • Composite
  • CompositeContext
  • ItemSelectable
  • KeyEventDispatcher
  • KeyEventPostProcessor
  • LayoutManager
  • LayoutManager2
  • MenuContainer
  • Paint
  • PaintContext
  • PrintGraphics
  • SecondaryLoop
  • Shape
  • Stroke
  • Transparency

Classes

  • AlphaComposite
  • AWTEvent
  • AWTEventMulticaster
  • AWTKeyStroke
  • AWTPermission
  • BasicStroke
  • BorderLayout
  • BufferCapabilities
  • BufferCapabilities.FlipContents
  • Button
  • Canvas
  • CardLayout
  • Checkbox
  • CheckboxGroup
  • CheckboxMenuItem
  • Choice
  • Color
  • Component
  • ComponentOrientation
  • Container
  • ContainerOrderFocusTraversalPolicy
  • Cursor
  • DefaultFocusTraversalPolicy
  • DefaultKeyboardFocusManager
  • Desktop
  • Dialog
  • Dimension
  • DisplayMode
  • Event
  • EventQueue
  • FileDialog
  • FlowLayout
  • FocusTraversalPolicy
  • Font
  • FontMetrics
  • Frame
  • GradientPaint
  • Graphics
  • Graphics2D
  • GraphicsConfigTemplate
  • GraphicsConfiguration
  • GraphicsDevice
  • GraphicsEnvironment
  • GridBagConstraints
  • GridBagLayout
  • GridBagLayoutInfo
  • GridLayout
  • Image
  • ImageCapabilities
  • Insets
  • JobAttributes
  • JobAttributes.DefaultSelectionType
  • JobAttributes.DestinationType
  • JobAttributes.DialogType
  • JobAttributes.MultipleDocumentHandlingType
  • JobAttributes.SidesType
  • KeyboardFocusManager
  • Label
  • LinearGradientPaint
  • List
  • MediaTracker
  • Menu
  • MenuBar
  • MenuComponent
  • MenuItem
  • MenuShortcut
  • MouseInfo
  • MultipleGradientPaint
  • PageAttributes
  • PageAttributes.ColorType
  • PageAttributes.MediaType
  • PageAttributes.OrientationRequestedType
  • PageAttributes.OriginType
  • PageAttributes.PrintQualityType
  • Panel
  • Point
  • PointerInfo
  • Polygon
  • PopupMenu
  • PrintJob
  • RadialGradientPaint
  • Rectangle
  • RenderingHints
  • RenderingHints.Key
  • Robot
  • Scrollbar
  • ScrollPane
  • ScrollPaneAdjustable
  • SplashScreen
  • SystemColor
  • SystemTray
  • Taskbar
  • TextArea
  • TextComponent
  • TextField
  • TexturePaint
  • Toolkit
  • TrayIcon
  • Window

Enums

  • Component.BaselineResizeBehavior
  • Desktop.Action
  • Dialog.ModalExclusionType
  • Dialog.ModalityType
  • GraphicsDevice.WindowTranslucency
  • MultipleGradientPaint.ColorSpaceType
  • MultipleGradientPaint.CycleMethod
  • Taskbar.Feature
  • Taskbar.State
  • TrayIcon.MessageType
  • Window.Type

Exceptions

  • AWTException
  • FontFormatException
  • HeadlessException
  • IllegalComponentStateException

Errors

  • AWTError


java.awt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt

包含用于创建用户界面和绘制图形和图像的所有类。 一个用户界面对象（如按钮或滚动条）在AWT术语中称为组件。 Component类是所有AWT组件的根。 有关所有AWT组件共享的属性的详细说明，请参阅组件。

200新新新新200新200新新200新200新新200新新200新200新新200新200新新200新新200新新200新新200新200新新200新新200新新200新新200新新200新新200新新 AWTEvent类及其子类用于表示AWT组件可以触发的事件。 有关AWT事件模型的描述，请参阅AWTEvent。

200的X- 200 X- 容器还可以具有一个布局管理器，用于控制容器中组件的可视化位置。 AWT包包含几个布局管理器类和一个用于构建自己的布局管理器的界面。 有关详细信息，请参阅Container和LayoutManager。

每个Component对象的最大大小和位置都受到限制，因为这些值存储为一个整数。 200 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200： 确切的最大值取决于平台。 无法在Java代码或本地代码中更改这些最大值。 这些限制也对组件布局施加了限制。 如果Component对象的边界超出平台限制，则无法在Container对象内正确排列它们。 对象的边界由任何对象的坐标与其相应轴上的大小组合定义。

附加规格

  • The AWT Focus Subsystem
  • The AWT Modality
  • The Java AWT Native Interface (JAWT)
从以下版本开始：
1.0
  • 接口摘要
    接口 描述
    ActiveEvent
    一个知道如何发送自己的事件的界面。
    Adjustable
    具有可调整数值的对象的界面包含在有限范围内的值。
    Composite
    Composite接口以及CompositeContext定义了组合绘制基元与底层图形区域的方法。
    CompositeContext
    CompositeContext接口为合成操作定义了封装和优化的环境。
    ItemSelectable
    可以选择包含零个或多个项目的对象的对象接口。
    KeyEventDispatcher
    KeyEventDispatcher与所有KeyEvents的目标和调度中的当前KeyboardFocusManager配合使用。
    KeyEventPostProcessor
    KeyEventPostProcessor与所有未消耗的KeyEvents的最终分辨率中的当前KeyboardFocusManager配合使用。
    LayoutManager
    定义知道如何布置 Container的类的界面。
    LayoutManager2
    为知道如何根据布局约束对象布局容器的类定义接口。
    MenuContainer
    所有菜单相关容器的超类。
    Paint
    这个Paint接口定义了如何为Graphics2D操作生成颜色模式。
    PaintContext
    PaintContext接口定义了封装和优化的环境，以在Graphics2D中为填充或笔画操作生成设备空间中的颜色模式。
    PrintGraphics
    一个为页面提供打印图形上下文的抽象类。
    SecondaryLoop
    一个辅助接口来运行嵌套事件循环。
    Shape
    Shape界面提供了表示某种形式几何形状的对象的定义。
    Stroke
    Stroke接口允许Graphics2D对象获得Shape ，它是指定的Shape的轮廓的轮廓或风格表示。
    Transparency
    Transparency接口定义了实现类的通用透明度模式。
  • 类摘要
    Class 描述
    AlphaComposite
    AlphaComposite类实现了基本的alpha合成规则，用于组合源和目标颜色，以实现图形和图像的混合和透明效果。
    AWTEvent
    所有AWT事件的根事件类。
    AWTEventMulticaster
    AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
    AWTKeyStroke
    AWTKeyStroke表示键盘或等效输入设备上的关键操作。
    AWTPermission
    此类用于AWT权限。
    BasicStroke
    BasicStroke类为图形基元的轮廓定义了一组基本的渲染属性，这些属性用一个Graphics2D对象渲染，该对象的Stroke属性设置为BasicStroke 。
    BorderLayout
    边界布局设置了一个容器，安排和调整其组件，以适应五个区域：北，南，东，西和中心。
    BufferCapabilities
    缓冲区的功能和属性。
    BufferCapabilities.FlipContents
    页面翻转后可能的反向缓冲区内容的类型安全枚举
    Button
    这个类创建一个标记的按钮。
    Canvas
    Canvas组件表示应用程序可以在其上绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。
    CardLayout
    CardLayout对象是容器的布局管理器。
    Checkbox
    复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
    CheckboxGroup
    CheckboxGroup类用于将一组 Checkbox按钮组合在一起。
    CheckboxMenuItem
    此类表示可以包含在菜单中的复选框。
    Choice
    Choice课程提供了一个弹出菜单的选择。
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    ComponentOrientation
    ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    ContainerOrderFocusTraversalPolicy
    FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
    Cursor
    封装鼠标光标位图表示的类。
    DefaultFocusTraversalPolicy
    FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
    DefaultKeyboardFocusManager
    用于AWT应用程序的默认KeyboardFocusManager。
    Desktop
    Desktop类允许与各种桌面功能进行交互。
    Dialog
    Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    DisplayMode
    所述 DisplayMode类封装的位深度，高度，宽度，和刷新速率 GraphicsDevice 。
    Event Deprecated.
    建议使用AWTEvent及其子类
    EventQueue
    EventQueue是一个独立于平台的类，用于从基础对等类和可信应用程序类排队事件。
    FileDialog
    FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
    FlowLayout
    流程布局将组件布置在定向流中，与段落中的文本行类似。
    FocusTraversalPolicy
    FocusTraversalPolicy定义了遍历特定焦点循环根的组件的顺序。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，该对象封装了有关在特定屏幕上呈现特定字体的信息。
    Frame
    A Frame是一个标题和边框的顶级窗口。
    GradientPaint
    GradientPaint课程提供了一种填充Shape线性颜色渐变模式的方式。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及离屏图像。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    GraphicsConfigTemplate
    GraphicsConfigTemplate类用于获取有效的GraphicsConfiguration 。
    GraphicsConfiguration
    GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特征。
    GraphicsDevice
    GraphicsDevice类描述了在特定图形环境中可能可用的图形设备。
    GraphicsEnvironment
    GraphicsEnvironment类描述了可用于特定平台上的Java（tm）应用程序的GraphicsDevice对象和Font对象的集合。
    GridBagConstraints
    GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。
    GridBagLayout
    GridBagLayout类是一种灵活的布局管理器，可以垂直，水平或沿其基准对齐组件，而不需要组件的大小相同。
    GridBagLayoutInfo
    GridBagLayoutInfo是 GridBagLayout布局管理器的实用程序类。
    GridLayout
    GridLayout类是一个布局管理器，它将一个容器的组件放在矩形网格中。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    ImageCapabilities
    图像的能力和属性。
    Insets
    一个 Insets对象是容器边框的表示。
    JobAttributes
    一组控制打印作业的属性。
    JobAttributes.DefaultSelectionType
    可能的默认选择状态的类型安全枚举。
    JobAttributes.DestinationType
    可能的工作目的地的类型安全枚举。
    JobAttributes.DialogType
    可以显示给用户的可能对话框的类型安全枚举。
    JobAttributes.MultipleDocumentHandlingType
    可能的多重复制处理状态的类型安全枚举。
    JobAttributes.SidesType
    可能的多页面强制的类型安全枚举。
    KeyboardFocusManager
    KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。
    Label
    Label对象是用于将文本放置在容器中的组件。
    LinearGradientPaint
    LinearGradientPaint课程提供了一种填充Shape线性颜色渐变模式的方式。
    List
    List组件向用户显示文本项的滚动列表。
    MediaTracker
    MediaTracker类是一个实用程序类，用于跟踪多个媒体对象的状态。
    Menu
    Menu对象是从菜单栏部署的下拉菜单组件。
    MenuBar
    MenuBar类封装了平台与框架绑定的菜单栏的概念。
    MenuComponent
    抽象类 MenuComponent是所有菜单相关组件的超类。
    MenuItem
    菜单中的所有项目必须属于类别 MenuItem或其子类之一。
    MenuShortcut
    MenuShortcut类代表一个MenuItem的键盘加速器。
    MouseInfo
    MouseInfo提供了获取鼠标信息的方法，如鼠标指针位置和鼠标按键数量。
    MultipleGradientPaint
    这是Paints的超类，它使用多色渐变填充其栅格。
    PageAttributes
    一组控制打印页面输出的属性。
    PageAttributes.ColorType
    可能的颜色状态的类型安全枚举。
    PageAttributes.MediaType
    可能的纸张尺寸的类型安全枚举。
    PageAttributes.OrientationRequestedType
    可能的方向的类型安全的枚举。
    PageAttributes.OriginType
    可能来源的类型安全枚举。
    PageAttributes.PrintQualityType
    可能的打印质量的类型安全枚举。
    Panel
    Panel是最简单的容器类。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    PointerInfo
    描述指针位置的类。
    Polygon
    Polygon类封装了坐标空间内封闭的二维区域的描述。
    PopupMenu
    一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
    PrintJob
    一个启动和执行打印作业的抽象类。
    RadialGradientPaint
    RadialGradientPaint类提供了一种填充圆形径向颜色渐变图案的形状的方法。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的区域，其宽度及其高度。
    RenderingHints
    RenderingHints类定义和管理密钥和关联值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。
    RenderingHints.Key
    定义与RenderingHints类一起使用的所有键的基本类型，以控制渲染和成像管道中的各种算法选择。
    Robot
    此类用于生成本机系统输入事件，用于测试自动化，自动运行演示和需要鼠标和键盘控制的其他应用程序。
    Scrollbar
    Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。
    ScrollPane
    一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。
    ScrollPaneAdjustable
    此类表示 ScrollPane的水平或垂直滚动条的 ScrollPane 。
    SplashScreen
    在Java虚拟机（JVM）启动之前，启动屏幕可以在应用程序启动时显示。
    SystemColor
    封装代表系统上本地GUI对象颜色的符号颜色的类。
    SystemTray
    SystemTray类代表桌面的系统托盘。
    Taskbar
    Taskbar类允许Java应用程序与系统任务区（任务栏，Dock等）进行交互。
    TextArea
    TextArea对象是显示文本的多行区域。
    TextComponent
    TextComponent类是允许编辑某些文本的任何组件的超类。
    TextField
    TextField对象是允许编辑单行文本的文本组件。
    TexturePaint
    TexturePaint类提供了一种填充Shape的方式，其中指定为BufferedImage 。
    Toolkit
    这个类是抽象窗口工具包的所有实际实现的抽象超类。
    TrayIcon
    TrayIcon对象表示可以添加到system tray的托盘图标。
    Window
    一个 Window对象是没有边框的顶级窗口，没有菜单。
  • 枚举摘要
    Enum 描述
    Component.BaselineResizeBehavior
    枚举组件的基准线随着大小变化而改变的常见方式。
    Desktop.Action
    表示动作类型。
    Dialog.ModalExclusionType
    任何顶级窗口都可以标记为不被模态对话框阻止。
    Dialog.ModalityType
    模态对话框阻止某些顶级窗口的所有输入。
    GraphicsDevice.WindowTranslucency
    底层系统支持的半透明度。
    MultipleGradientPaint.ColorSpaceType
    执行渐变插值的颜色空间。
    MultipleGradientPaint.CycleMethod
    绘画之外使用的方法边界渐变。
    Taskbar.Feature
    提供功能列表
    Taskbar.State
    可用窗口进度的种类状态。
    TrayIcon.MessageType
    消息类型确定在消息的标题中将显示哪个图标，以及在显示时消息可能产生的可能的系统声音。
    Window.Type
    枚举可用的 窗口类型 。
  • 异常摘要
    异常 描述
    AWTException
    表示发生抽象窗口工具包异常。
    FontFormatException
    在 Font类中通过 Font方法抛出，以指示指定的字体是坏的。
    HeadlessException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
    IllegalComponentStateException
    表示AWT组件对于请求的操作不在适当的状态。
  • Error Summary
    Error 描述
    AWTError
    Thrown when a serious Abstract Window Toolkit error has occurred.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Button.AccessibleAWTButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
        • java.awt.Canvas.AccessibleAWTCanvas
        • java.awt.Checkbox.AccessibleAWTCheckbox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue, java.awt.event.ItemListener)
        • java.awt.Choice.AccessibleAWTChoice (implements javax.accessibility.AccessibleAction)
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Panel.AccessibleAWTPanel
          • java.awt.ScrollPane.AccessibleAWTScrollPane
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
            • java.awt.Frame.AccessibleAWTFrame
        • java.awt.Label.AccessibleAWTLabel
        • java.awt.List.AccessibleAWTList (implements javax.accessibility.AccessibleSelection, java.awt.event.ActionListener, java.awt.event.ItemListener)
        • java.awt.List.AccessibleAWTList.AccessibleAWTListChild (implements javax.accessibility.Accessible)
        • java.awt.Scrollbar.AccessibleAWTScrollBar (implements javax.accessibility.AccessibleValue)
        • java.awt.TextComponent.AccessibleAWTTextComponent (implements javax.accessibility.AccessibleText, java.awt.event.TextListener)
          • java.awt.TextArea.AccessibleAWTTextArea
          • java.awt.TextField.AccessibleAWTTextField
      • java.awt.MenuComponent.AccessibleAWTMenuComponent (implements javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection, java.io.Serializable)
        • java.awt.MenuBar.AccessibleAWTMenuBar
        • java.awt.MenuItem.AccessibleAWTMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.Menu.AccessibleAWTMenu
            • java.awt.PopupMenu.AccessibleAWTPopupMenu
    • java.awt.AlphaComposite (implements java.awt.Composite)
    • java.awt.AWTEventMulticaster (implements java.awt.event.ActionListener, java.awt.event.AdjustmentListener, java.awt.event.ComponentListener, java.awt.event.ContainerListener, java.awt.event.FocusListener, java.awt.event.HierarchyBoundsListener, java.awt.event.HierarchyListener, java.awt.event.InputMethodListener, java.awt.event.ItemListener, java.awt.event.KeyListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener, java.awt.event.TextListener, java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
    • java.awt.AWTKeyStroke (implements java.io.Serializable)
    • java.awt.BasicStroke (implements java.awt.Stroke)
    • java.awt.BorderLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.BufferCapabilities (implements java.lang.Cloneable)
    • java.awt.BufferCapabilities.FlipContents
    • java.awt.image.BufferStrategy
      • java.awt.Component.BltBufferStrategy
      • java.awt.Component.FlipBufferStrategy
    • java.awt.CardLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.CheckboxGroup (implements java.io.Serializable)
    • java.awt.Color (implements java.awt.Paint, java.io.Serializable)
      • java.awt.SystemColor (implements java.io.Serializable)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Button (implements javax.accessibility.Accessible)
      • java.awt.Canvas (implements javax.accessibility.Accessible)
      • java.awt.Checkbox (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Choice (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Container
        • java.awt.Panel (implements javax.accessibility.Accessible)
        • java.awt.ScrollPane (implements javax.accessibility.Accessible)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • java.awt.Dialog
            • java.awt.FileDialog
          • java.awt.Frame (implements java.awt.MenuContainer)
      • java.awt.Label (implements javax.accessibility.Accessible)
      • java.awt.List (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Scrollbar (implements javax.accessibility.Accessible, java.awt.Adjustable)
      • java.awt.TextComponent (implements javax.accessibility.Accessible)
        • java.awt.TextArea
        • java.awt.TextField
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (implements java.awt.event.ComponentListener)
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (implements java.awt.event.FocusListener)
    • java.awt.ComponentOrientation (implements java.io.Serializable)
    • java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • java.awt.Cursor (implements java.io.Serializable)
    • java.awt.Desktop
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
      • java.awt.Dimension (implements java.io.Serializable)
    • java.awt.DisplayMode
    • java.awt.Event (implements java.io.Serializable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
    • java.awt.EventQueue
    • java.awt.FlowLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • java.awt.FocusTraversalPolicy
      • java.awt.ContainerOrderFocusTraversalPolicy (implements java.io.Serializable)
        • java.awt.DefaultFocusTraversalPolicy
    • java.awt.Font (implements java.io.Serializable)
    • java.awt.FontMetrics (implements java.io.Serializable)
    • java.awt.GradientPaint (implements java.awt.Paint)
    • java.awt.Graphics
      • java.awt.Graphics2D
    • java.awt.GraphicsConfigTemplate (implements java.io.Serializable)
    • java.awt.GraphicsConfiguration
    • java.awt.GraphicsDevice
    • java.awt.GraphicsEnvironment
    • java.awt.GridBagConstraints (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.GridBagLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.GridBagLayoutInfo (implements java.io.Serializable)
    • java.awt.GridLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • java.awt.Image
    • java.awt.ImageCapabilities (implements java.lang.Cloneable)
    • java.awt.Insets (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.JobAttributes (implements java.lang.Cloneable)
    • java.awt.JobAttributes.DefaultSelectionType
    • java.awt.JobAttributes.DestinationType
    • java.awt.JobAttributes.DialogType
    • java.awt.JobAttributes.MultipleDocumentHandlingType
    • java.awt.JobAttributes.SidesType
    • java.awt.KeyboardFocusManager (implements java.awt.KeyEventDispatcher, java.awt.KeyEventPostProcessor)
      • java.awt.DefaultKeyboardFocusManager
    • java.awt.MediaTracker (implements java.io.Serializable)
    • java.awt.MenuComponent (implements java.io.Serializable)
      • java.awt.MenuBar (implements javax.accessibility.Accessible, java.awt.MenuContainer)
      • java.awt.MenuItem (implements javax.accessibility.Accessible)
        • java.awt.CheckboxMenuItem (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
        • java.awt.Menu (implements javax.accessibility.Accessible, java.awt.MenuContainer)
          • java.awt.PopupMenu
    • java.awt.MenuShortcut (implements java.io.Serializable)
    • java.awt.MouseInfo
    • java.awt.MultipleGradientPaint (implements java.awt.Paint)
      • java.awt.LinearGradientPaint
      • java.awt.RadialGradientPaint
    • java.awt.PageAttributes (implements java.lang.Cloneable)
    • java.awt.PageAttributes.ColorType
    • java.awt.PageAttributes.MediaType
    • java.awt.PageAttributes.OrientationRequestedType
    • java.awt.PageAttributes.OriginType
    • java.awt.PageAttributes.PrintQualityType
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.awt.AWTPermission
    • java.awt.geom.Point2D (implements java.lang.Cloneable)
      • java.awt.Point (implements java.io.Serializable)
    • java.awt.PointerInfo
    • java.awt.Polygon (implements java.io.Serializable, java.awt.Shape)
    • java.awt.PrintJob
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
    • java.awt.RenderingHints (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.awt.RenderingHints.Key
    • java.awt.Robot
    • java.awt.ScrollPaneAdjustable (implements java.awt.Adjustable, java.io.Serializable)
    • java.awt.SplashScreen
    • java.awt.SystemTray
    • java.awt.Taskbar
    • java.awt.TexturePaint (implements java.awt.Paint)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.awt.AWTError
      • java.lang.异常
        • java.awt.AWTException
        • java.awt.FontFormatException
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.awt.IllegalComponentStateException
          • java.lang.UnsupportedOperationException
            • java.awt.HeadlessException
    • java.awt.Toolkit
    • java.awt.TrayIcon

Interface Hierarchy

  • java.awt.ActiveEvent
  • java.awt.Adjustable
  • java.awt.Composite
  • java.awt.CompositeContext
  • java.awt.ItemSelectable
  • java.awt.KeyEventDispatcher
  • java.awt.KeyEventPostProcessor
  • java.awt.LayoutManager
    • java.awt.LayoutManager2
  • java.awt.MenuContainer
  • java.awt.PaintContext
  • java.awt.PrintGraphics
  • java.awt.SecondaryLoop
  • java.awt.Shape
  • java.awt.Stroke
  • java.awt.Transparency
    • java.awt.Paint

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.Component.BaselineResizeBehavior
      • java.awt.Desktop.Action
      • java.awt.Dialog.ModalExclusionType
      • java.awt.Dialog.ModalityType
      • java.awt.GraphicsDevice.WindowTranslucency
      • java.awt.MultipleGradientPaint.ColorSpaceType
      • java.awt.MultipleGradientPaint.CycleMethod
      • java.awt.Taskbar.Feature
      • java.awt.Taskbar.State
      • java.awt.TrayIcon.MessageType
      • java.awt.Window.Type
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


JobAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class JobAttributes

  • java.lang.Object
    • java.awt.JobAttributes
  • All Implemented Interfaces:
    Cloneable

    public final class JobAttributes
extends Object
implements Cloneable
    一组控制打印作业的属性。

    该类的实例控制使用的每个打印作业的份数，默认选择，目的地，打印对话框，文件和打印机名称，页面范围，多个文档处理（包括排序规则）和多页面拼版（如双面）实例。 如果可能，属性名称符合Internet打印协议（IPP）1.1。 属性值在可能的情况下是部分兼容的。

    要使用一个接受内部类类型的方法，请将引用传递给内部类的一个常量字段。 客户端代码不能创建内部类类型的新实例，因为这些类都不具有公共构造函数。 例如，要将打印对话框类型设置为跨平台，纯Java打印对话框，请使用以下代码：

      import java.awt.JobAttributes;

 public class PureJavaPrintDialogExample {
     public void setPureJavaPrintDialog(JobAttributes jobAttributes) {
         jobAttributes.setDialog(JobAttributes.DialogType.COMMON);
     }
 }

    支持attributeName -default值的每个IPP属性都具有相应的setattributeNameToDefault方法。 未提供默认值字段。

    从以下版本开始：
    1.3

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  JobAttributes.DefaultSelectionType
      可能的默认选择状态的类型安全枚举。
      static class  JobAttributes.DestinationType
      可能的工作目的地的类型安全枚举。
      static class  JobAttributes.DialogType
      可以显示给用户的可能对话框的类型安全枚举。
      static class  JobAttributes.MultipleDocumentHandlingType
      可能的多重复制处理状态的类型安全枚举。
      static class  JobAttributes.SidesType
      可能的多页面强制的类型安全枚举。

    • 构造方法摘要

      构造方法
      Constructor 描述
      JobAttributes​()
      为每个属性构造具有默认值的 JobAttributes实例。
      JobAttributes​(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
      为每个属性构造具有指定值的 JobAttributes实例。
      JobAttributes​(JobAttributes obj)
      构造一个 JobAttributes实例，它是所提供的 JobAttributes的副本。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建并返回此 JobAttributes的副本。
      boolean equals​(Object obj)
      确定两个JobAttributes是否相等。
      int getCopies​()
      返回应用程序应使用这些属性为作业呈现的副本数。
      JobAttributes.DefaultSelectionType getDefaultSelection​()
      指定对于使用这些属性的作业，应用程序是否应打印所有页面，由返回值 getPageRanges指定的范围或当前选择。
      JobAttributes.DestinationType getDestination​()
      指定输出将是打印机还是使用这些属性的作业文件。
      JobAttributes.DialogType getDialog​()
      返回对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。
      String getFileName​()
      指定使用这些属性的作业的输出文件的文件名。
      int getFromPage​()
      对于使用这些属性的作业，如果要打印一系列页面，则返回要打印的第一页。
      int getMaxPage​()
      指定用户可以指定的最大值作为使用这些属性的作业打印的最后一页。
      int getMinPage​()
      指定用户可以指定的最小值作为使用这些属性的作业打印的第一页。
      JobAttributes.MultipleDocumentHandlingType getMultipleDocumentHandling​()
      指定对使用这些属性的作业处理多个副本（包括排序规则）。
      int[][] getPageRanges​()
      对于使用这些属性的作业，指定要打印的页面范围，如果要打印的页面范围。
      String getPrinter​()
      使用这些属性返回作业的目标打印机。
      JobAttributes.SidesType getSides​()
      返回在使用这些属性的作业的打印介质的两侧应该如何施加连续的页面。
      int getToPage​()
      对于要使用这些属性的作业，如果要打印的页面范围，则返回要打印的最后一页（包括）。
      int hashCode​()
      返回此JobAttributes的哈希码值。
      void set​(JobAttributes obj)
      将此 JobAttributes所有属性设置为与obj的属性相同的值。
      void setCopies​(int copies)
      指定应用程序应使用这些属性为作业呈现的副本数。
      void setCopiesToDefault​()
      设置应用程序应将这些属性的作业呈现给默认的副本数。
      void setDefaultSelection​(JobAttributes.DefaultSelectionType defaultSelection)
      指定对于使用这些属性的作业，应用程序是否应打印所有页面，由返回值 getPageRanges指定的范围或当前选择。
      void setDestination​(JobAttributes.DestinationType destination)
      指定输出将是打印机还是使用这些属性的作业文件。
      void setDialog​(JobAttributes.DialogType dialog)
      指定对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。
      void setFileName​(String fileName)
      指定使用这些属性的作业的输出文件的文件名。
      void setFromPage​(int fromPage)
      对于要使用这些属性的作业，如果要打印一系列页面，则指定要打印的第一页。
      void setMaxPage​(int maxPage)
      指定用户可以指定的最大值作为使用这些属性的作业打印的最后一页。
      void setMinPage​(int minPage)
      指定用户可以指定的最小值作为使用这些属性的作业打印的第一页。
      void setMultipleDocumentHandling​(JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling)
      指定对使用这些属性的作业处理多个副本（包括排序规则）。
      void setMultipleDocumentHandlingToDefault​()
      将使用这些属性的作业的多个副本（包括排序规则）的处理设置为默认值。
      void setPageRanges​(int[][] pageRanges)
      对于使用这些属性的作业，指定要打印的页面范围，如果要打印的页面范围。
      void setPrinter​(String printer)
      使用这些属性指定作业的目标打印机。
      void setSides​(JobAttributes.SidesType sides)
      指定在使用这些属性的作业的打印介质的两侧应如何施加连续的页面。
      void setSidesToDefault​()
      设置如何使用这些属性将打印介质的两侧的连续页面施加到默认页面。
      void setToPage​(int toPage)
      对于要使用这些属性的作业，如果要打印的页面范围，则指定要打印的最后一页（含）。
      String toString​()
      返回此JobAttributes的字符串表示形式。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobAttributes

        public JobAttributes​()
        为每个属性构造具有默认值的JobAttributes实例。 对话框默认为DialogType.NATIVE 。 最小页面默认为1 。 最大页面默认为Integer.MAX_VALUE 。 目的地默认为DestinationType.PRINTER 。 选择默认为DefaultSelectionType.ALL 。 份数默认为1 。 多个文档处理默认为MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 。 侧面默认为SidesType.ONE_SIDED 。 文件名默认为null 。

      • JobAttributes

        public JobAttributes​(JobAttributes obj)
        构造一个 JobAttributes实例，它是所提供的 JobAttributes的副本。
        参数
        obj - 要复制的 JobAttributes

      • JobAttributes

        public JobAttributes​(int copies,
                     JobAttributes.DefaultSelectionType defaultSelection,
                     JobAttributes.DestinationType destination,
                     JobAttributes.DialogType dialog,
                     String fileName,
                     int maxPage,
                     int minPage,
                     JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling,
                     int[][] pageRanges,
                     String printer,
                     JobAttributes.SidesType sides)
        为每个属性构造具有指定值的 JobAttributes实例。
        参数
        copies - 大于0的整数
        defaultSelection - DefaultSelectionType.ALL ， DefaultSelectionType.RANGE ，或 DefaultSelectionType.SELECTION
        destination - DestinationType.FILE或 DestinationType.PRINTER
        dialog - DialogType.COMMON ， DialogType.NATIVE ，或 DialogType.NONE
        fileName - 可能有 null文件名
        maxPage - 大于零且大于或等于 minPage的整数
        minPage - 大于零且小于或等于 maxPage的整数
        multipleDocumentHandling - MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES或 MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
        pageRanges - 两个元素的整数数组的数组; 一个数组被解释为涵盖指定页面之间的所有页面的范围; 范围必须按升序排列，不得重叠; 指定的页码不能小于minPage，也不能大于maxPage ; 例如：
          (new int[][] { new int[] { 1, 3 }, new int[] { 5, 5 },
                         new int[] { 15, 19 } }),
        指定页面new int[][] { new int[] { 1, 1 }, new int[] { 1, 2 } }和19.注意（ new int[][] { new int[] { 1, 1 }, new int[] { 1, 2 } } ）是一组无效的页面范围，因为两个范围重叠
        printer - 可能的 null打印机名称
        sides - SidesType.ONE_SIDED ， SidesType.TWO_SIDED_LONG_EDGE ，或 SidesType.TWO_SIDED_SHORT_EDGE
        异常
        IllegalArgumentException - 如果上述条件中的一个或多个被违反

    • 方法详细信息

      • clone

        public Object clone​()
        创建并返回此 JobAttributes的副本。
        重写：
        clone在 Object
        结果
        新创建的副本; 将此对象转换为JobAttributes是安全的
        另请参见：
        Cloneable

      • set

        public void set​(JobAttributes obj)
        将此 JobAttributes所有属性设置为与obj的属性相同的值。
        参数
        obj - 要复制的 JobAttributes

      • getCopies

        public int getCopies​()
        返回应用程序应使用这些属性为作业呈现的副本数。 此属性更新为用户选择的值。
        结果
        大于0的整数。

      • setCopies

        public void setCopies​(int copies)
        指定应用程序应使用这些属性为作业呈现的副本数。 不指定此属性等同于指定1 。
        参数
        copies - 大于0的整数
        异常
        IllegalArgumentException - 如果 copies小于或等于0

      • setCopiesToDefault

        public void setCopiesToDefault​()
        设置应用程序应将这些属性的作业呈现给默认的副本数。 默认份数为1。

      • getDefaultSelection

        public JobAttributes.DefaultSelectionType getDefaultSelection​()
        指定对于使用这些属性的作业，应用程序是否应打印所有页面，返回值为getPageRanges指定的范围，或当前选择。 此属性更新为用户选择的值。
        结果
        DefaultSelectionType.ALL，DefaultSelectionType.RANGE或DefaultSelectionType.SELECTION

      • setDefaultSelection

        public void setDefaultSelection​(JobAttributes.DefaultSelectionType defaultSelection)
        指定对于使用这些属性的作业，应用程序是否应打印所有页面，由返回值getPageRanges指定的范围或当前选择。 不指定此属性等同于指定DefaultSelectionType.ALL。
        参数
        defaultSelection - DefaultSelectionType.ALL，DefaultSelectionType.RANGE或DefaultSelectionType.SELECTION。
        异常
        IllegalArgumentException - 如果defaultSelection是 null

      • getDestination

        public JobAttributes.DestinationType getDestination​()
        指定输出将是打印机还是使用这些属性的作业文件。 此属性更新为用户选择的值。
        结果
        DestinationType.FILE或DestinationType.PRINTER

      • setDestination

        public void setDestination​(JobAttributes.DestinationType destination)
        指定输出将是打印机还是使用这些属性的作业文件。 不指定此属性等同于指定DestinationType.PRINTER。
        参数
        destination - DestinationType.FILE或DestinationType.PRINTER。
        异常
        IllegalArgumentException - 如果目的地为空。

      • getDialog

        public JobAttributes.DialogType getDialog​()
        返回对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。 DialogType.COMMON表示跨平台，纯Java打印对话框。 DialogType.NATIVE表示平台的本地打印对话框。 如果平台不支持本地打印对话框，则会显示纯Java打印对话框。 DialogType.NONE不指定打印对话框（即背景打印）。 该属性不能由实现或目标打印机修改，也不受任何限制。
        结果
        DialogType.COMMON ， DialogType.NATIVE ，或 DialogType.NONE

      • setDialog

        public void setDialog​(JobAttributes.DialogType dialog)
        指定对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。 DialogType.COMMON表示跨平台，纯Java打印对话框。 DialogType.NATIVE表示平台的本地打印对话框。 如果平台不支持本地打印对话框，则会显示纯Java打印对话框。 DialogType.NONE不指定打印对话框（即背景打印）。 不指定此属性等同于指定DialogType.NATIVE。
        参数
        dialog - DialogType.COMMON，DialogType.NATIVE或DialogType.NONE。
        异常
        IllegalArgumentException - 如果对话框为空。

      • getFileName

        public String getFileName​()
        指定使用这些属性的作业的输出文件的文件名。 此属性更新为用户选择的值。
        结果
        可能是 null文件名

      • setFileName

        public void setFileName​(String fileName)
        指定使用这些属性的作业的输出文件的文件名。 默认是平台依赖和实现定义。
        参数
        fileName - 可能为空的文件名。

      • getFromPage

        public int getFromPage​()
        对于使用这些属性的作业，如果要打印一系列页面，则返回要打印的第一页。 此属性更新为用户选择的值。 应用程序应忽略输出上的此属性，除非getDefaultSelection方法的返回值为DefaultSelectionType.RANGE。 如果可能，应用程序应遵守该方法的返回值为getPageRanges的返回值。
        结果
        大于零且小于或等于 toPage并大于或等于 minPage且小于或等于 maxPage的整数。

      • setFromPage

        public void setFromPage​(int fromPage)
        对于要使用这些属性的作业，如果要打印一系列页面，则指定要打印的第一页。 如果未指定此属性，则使用pageRanges属性中的值。 如果pageRanges和指定fromPage和toPage中的一个或两个，则优先使用pageRanges。 指定没有pageRanges，fromPage或toPage等价于调用setPageRanges（new int [] [] {new int [] { minPage }}）;
        参数
        fromPage - 大于零且小于或等于 toPage并大于或等于 minPage且小于或等于 maxPage的整数。
        异常
        IllegalArgumentException - 如果上述条件中的一个或多个被违反。

      • getMaxPage

        public int getMaxPage​()
        指定用户可以指定的最大值作为使用这些属性的作业打印的最后一页。 该属性不能由实现或目标打印机修改，也不受任何限制。
        结果
        大于零且大于或等于 minPage的整数。

      • setMaxPage

        public void setMaxPage​(int maxPage)
        指定用户可以指定的最大值作为使用这些属性的作业打印的最后一页。 不指定此属性等同于指定Integer.MAX_VALUE 。
        参数
        maxPage - 一个大于零且大于或等于 minPage的整数
        异常
        IllegalArgumentException - 如果上述条件中的一个或多个被违反

      • getMinPage

        public int getMinPage​()
        指定用户可以指定的最小值作为使用这些属性的作业打印的第一页。 该属性不能由实现或目标打印机修改，也不受任何限制。
        结果
        大于零且小于或等于 maxPage的整数。

      • setMinPage

        public void setMinPage​(int minPage)
        指定用户可以指定的最小值作为使用这些属性的作业打印的第一页。 不指定此属性等同于指定1 。
        参数
        minPage - 大于零且小于或等于 maxPage的整数。
        异常
        IllegalArgumentException - 如果上述条件中的一个或多个被违反。

      • getMultipleDocumentHandling

        public JobAttributes.MultipleDocumentHandlingType getMultipleDocumentHandling​()
        指定对使用这些属性的作业处理多个副本（包括排序规则）。 此属性更新为用户选择的值。
        结果
        MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES或MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。

      • setMultipleDocumentHandling

        public void setMultipleDocumentHandling​(JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling)
        指定对使用这些属性的作业处理多个副本（包括排序规则）。 不指定此属性等效于指定MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。
        参数
        multipleDocumentHandling - MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES或MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。
        异常
        IllegalArgumentException - 如果multipleDocumentHandling为null。

      • setMultipleDocumentHandlingToDefault

        public void setMultipleDocumentHandlingToDefault​()
        将使用这些属性的作业的多个副本（包括排序规则）的处理设置为默认值。 默认处理为MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。

      • getPageRanges

        public int[][] getPageRanges​()
        对于使用这些属性的作业，指定要打印的页面范围，如果要打印的页面范围。 所有范围数字均包含在内。 此属性更新为用户选择的值。 应用程序应该忽略输出上的此属性，除非getDefaultSelection方法的返回值为DefaultSelectionType.RANGE。
        结果
        2个元素的整数数组数组。 一个数组被解释为跨越包含指定页面的所有页面的范围。 范围必须按照升序排列，不得重叠。 指定的页码不能小于minPage，也不能大于maxPage 。 例如：（new int [] [] {new int [] {1，3}，new int [] {5，5}，new int [] {15,19}}），指定页面1,2,3 ，5，15，16，17，18和19。

      • setPageRanges

        public void setPageRanges​(int[][] pageRanges)
        对于使用这些属性的作业，指定要打印的页面范围，如果要打印的页面范围。 所有范围数字均包含在内。 如果未指定此属性，则使用fromPage和toPages属性的值。 如果pageRanges和指定fromPage和toPage中的一个或两个，则优先使用pageRanges。 指定没有pageRanges，fromPage或toPage等价于调用setPageRanges（new int [] [] {new int [] { minPage ， minPage }}）;
        参数
        pageRanges - 2个元素的整数数组数组。 一个数组被解释为跨越包含指定页面的所有页面的范围。 范围必须按照升序排列，不得重叠。 指定的页码不能小于minPage，也不能大于maxPage 。 例如：（new int [] [] {new int [] {1，3}，new int [] {5，5}，new int [] {15,19}}），指定页面1,2,3 ，5，15，16，17，18，和19.注意，（new int [] [] {new int [] {1，1}，new int [] {1，2}}）因为两个范围重叠。
        异常
        IllegalArgumentException - 如果上述条件中的一个或多个被违反。

      • getPrinter

        public String getPrinter​()
        使用这些属性返回作业的目标打印机。 此属性更新为用户选择的值。
        结果
        可能为空的打印机名称。

      • setPrinter

        public void setPrinter​(String printer)
        使用这些属性指定作业的目标打印机。 默认是平台依赖和实现定义。
        参数
        printer - 可能为空的打印机名称。

      • getSides

        public JobAttributes.SidesType getSides​()
        返回在使用这些属性的作业的打印介质的两侧应该如何施加连续的页面。 SidesType.ONE_SIDED将每个连续的页面强加在连续媒体页面的同一侧。 这种拼法有时被称为单纯形 。 SidesType.TWO_SIDED_LONG_EDGE在连续的介质页的前后两侧将每个连续的页面加在一起，使得介质上的每对页面的方向对于读取器来说将是正确的，如同在长边缘上的装订一样。 这种拼法有时被称为双面 。 SidesType.TWO_SIDED_SHORT_EDGE在连续介质页的前后两侧将每个连续的页面强加，使得介质上的每对页面的方向对于读取器将是正确的，如同在短边上的装订一样。 这种拼法有时被称为滚滚 。 此属性更新为用户选择的值。
        结果
        SidesType.ONE_SIDED，SidesType.TWO_SIDED_LONG_EDGE或SidesType.TWO_SIDED_SHORT_EDGE。

      • setSides

        public void setSides​(JobAttributes.SidesType sides)
        指定在使用这些属性的作业的打印介质的两侧应如何施加连续的页面。 SidesType.ONE_SIDED将每个连续的页面强加在连续媒体页面的同一侧。 这种拼法有时被称为单纯形 。 SidesType.TWO_SIDED_LONG_EDGE在连续的介质页的前后两侧将每个连续的页面加在一起，使得介质上的每对页面的方向对于读取器来说将是正确的，如同在长边缘上的装订一样。 这种拼法有时被称为双面 。 SidesType.TWO_SIDED_SHORT_EDGE在连续介质页的前后两侧将每个连续的页面强加，使得介质上的每对页面的方向对于读取器将是正确的，如同在短边上的装订一样。 这种拼法有时被称为滚滚 。 不指定此属性等同于指定SidesType.ONE_SIDED。
        参数
        sides - SidesType.ONE_SIDED，SidesType.TWO_SIDED_LONG_EDGE或SidesType.TWO_SIDED_SHORT_EDGE。
        异常
        IllegalArgumentException - 如果边为空。

      • setSidesToDefault

        public void setSidesToDefault​()
        设置如何使用这些属性将打印介质的两侧的连续页面施加到默认页面。 默认拼版为SidesType.ONE_SIDED。

      • getToPage

        public int getToPage​()
        对于要使用这些属性的作业，如果要打印的页面范围，则返回要打印的最后一页（包括）。 此属性更新为用户选择的值。 应用程序应该忽略输出上的此属性，除非getDefaultSelection方法的返回值为DefaultSelectionType.RANGE。 如果可能，应用程序应该遵守getPageRanges的返回值超过此方法的返回值。
        结果
        大于零且大于或等于 toPage并大于或等于 minPage并小于或等于 maxPage的整数。

      • setToPage

        public void setToPage​(int toPage)
        对于要使用这些属性的作业，如果要打印的页面范围，则指定要打印的最后一页（含）。 如果未指定此属性，则使用pageRanges属性中的值。 如果pageRanges和指定fromPage和toPage中的一个或两个，则优先使用pageRanges。 指定没有pageRanges，fromPage或toPage等价于调用setPageRanges（new int [] [] {new int [] { minPage }}）;
        参数
        toPage - 一个大于零且大于或等于 fromPage并大于或等于 minPage且小于或等于 maxPage的整数。
        异常
        IllegalArgumentException - 如果上述条件中的一个或多个被违反。

      • equals

        public boolean equals​(Object obj)
        确定两个JobAttributes是否相等。

        当且仅当它们的每个属性相等时，两个JobAttributes是相等的。 枚举类型的属性当且仅当这些域引用相同的唯一枚举对象时相等。 当且仅当集合长度相等时，一组页面范围是相等的，每个范围枚举相同的页面，范围是相同的顺序。

        重写：
        equals在 Object
        参数
        obj - 将检查其相等性的对象。
        结果
        根据上述标准，obj是否等于此JobAttribute。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此JobAttributes的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此JobAttributes的字符串表示形式。
        重写：
        toString在 Object
        结果
        the string representation.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JobAttributes.DefaultSelectionType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class JobAttributes.DefaultSelectionType

  • java.lang.Object
    • java.awt.JobAttributes.DefaultSelectionType
  • Enclosing class:
    JobAttributes

    public static final class JobAttributes.DefaultSelectionType
extends Object
    可能的默认选择状态的类型安全枚举。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JobAttributes.DefaultSelectionType ALL
      用于指定应打印作业的所有页面的 DefaultSelectionType实例。
      static JobAttributes.DefaultSelectionType RANGE
      用于指定应打印作业范围的 DefaultSelectionType实例。
      static JobAttributes.DefaultSelectionType SELECTION
      用于指定应打印当前选择的 DefaultSelectionType实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ALL

        public static final JobAttributes.DefaultSelectionType ALL
        用于指定应打印作业的所有页面的 DefaultSelectionType实例。

      • RANGE

        public static final JobAttributes.DefaultSelectionType RANGE
        用于指定应打印作业范围的 DefaultSelectionType实例。

      • SELECTION

        public static final JobAttributes.DefaultSelectionType SELECTION
        用于指定应打印当前选择的 DefaultSelectionType实例。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 在执行Java应用程序时，无论何时在同一个对象上多次调用相同的对象，则hashCode方法必须始终返回相同的整数，前提是在对象上的equals比较中没有使用任何信息进行修改。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JobAttributes.DestinationType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class JobAttributes.DestinationType

  • java.lang.Object
    • java.awt.JobAttributes.DestinationType
  • Enclosing class:
    JobAttributes

    public static final class JobAttributes.DestinationType
extends Object
    可能的工作目的地的类型安全枚举。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JobAttributes.DestinationType FILE
      用于指定打印到文件的 DestinationType实例。
      static JobAttributes.DestinationType PRINTER
      用于指定打印机打印的 DestinationType实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FILE

        public static final JobAttributes.DestinationType FILE
        用于指定打印到文件的 DestinationType实例。

      • PRINTER

        public static final JobAttributes.DestinationType PRINTER
        用于指定打印机打印的 DestinationType实例。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中的equals比较中没有使用的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在类 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JobAttributes.DialogType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class JobAttributes.DialogType

  • java.lang.Object
    • java.awt.JobAttributes.DialogType
  • Enclosing class:
    JobAttributes

    public static final class JobAttributes.DialogType
extends Object
    可以显示给用户的可能对话框的类型安全枚举。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JobAttributes.DialogType COMMON
      用于指定跨平台，纯Java打印对话框的 DialogType实例。
      static JobAttributes.DialogType NATIVE
      用于指定平台本机打印对话框的 DialogType实例。
      static JobAttributes.DialogType NONE
      用于指定不打印对话框的 DialogType实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • COMMON

        public static final JobAttributes.DialogType COMMON
        用于指定跨平台，纯Java打印对话框的 DialogType实例。

      • NATIVE

        public static final JobAttributes.DialogType NATIVE
        用于指定平台本机打印对话框的 DialogType实例。

      • NONE

        public static final JobAttributes.DialogType NONE
        用于指定不打印对话框的 DialogType实例。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 在执行Java应用程序时，无论何时在同一对象上多次调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JobAttributes.MultipleDocumentHandlingType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class JobAttributes.MultipleDocumentHandlingType

  • java.lang.Object
    • java.awt.JobAttributes.MultipleDocumentHandlingType
  • Enclosing class:
    JobAttributes

    public static final class JobAttributes.MultipleDocumentHandlingType
extends Object
    可能的多重复制处理状态的类型安全枚举。 它用于控制单个文档的多个副本的表格如何整理。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JobAttributes.MultipleDocumentHandlingType SEPARATE_DOCUMENTS_COLLATED_COPIES
      MultipleDocumentHandlingType实例用于指定作业应分为单独的整理副本。
      static JobAttributes.MultipleDocumentHandlingType SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
      MultipleDocumentHandlingType实例用于指定作业应分为单独的未分类的副本。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SEPARATE_DOCUMENTS_COLLATED_COPIES

        public static final JobAttributes.MultipleDocumentHandlingType SEPARATE_DOCUMENTS_COLLATED_COPIES
        MultipleDocumentHandlingType实例用于指定作业应分为单独的整理副本。

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES

        public static final JobAttributes.MultipleDocumentHandlingType SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
        MultipleDocumentHandlingType实例用于指定作业应分为单独的未分类副本。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JobAttributes.SidesType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class JobAttributes.SidesType

  • java.lang.Object
    • java.awt.JobAttributes.SidesType
  • Enclosing class:
    JobAttributes

    public static final class JobAttributes.SidesType
extends Object
    可能的多页面强制的类型安全枚举。 这些责任符合IPP 1.1。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static JobAttributes.SidesType ONE_SIDED
      用于指定连续作业页面的 SidesType实例应打印在连续介质页的同一侧。
      static JobAttributes.SidesType TWO_SIDED_LONG_EDGE
      用于指定连续作业页面的 SidesType实例应在连续介质页的正面和背面打印，以便介质上每对页面的方向对于读取器将是正确的，如同在长边上装订一样。
      static JobAttributes.SidesType TWO_SIDED_SHORT_EDGE
      用于指定连续作业页面的 SidesType实例应该被打印在连续介质页的正面和背面，使得介质上的每对页面的方向对于读取器将是正确的，如同在短边上的装订。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ONE_SIDED

        public static final JobAttributes.SidesType ONE_SIDED
        用于指定连续作业页面的 SidesType实例应打印在连续介质页的同一侧。

      • TWO_SIDED_LONG_EDGE

        public static final JobAttributes.SidesType TWO_SIDED_LONG_EDGE
        用于指定连续作业页面的 SidesType实例应该被打印在连续介质页的前侧和后侧，使得介质上的每对页面的方向对于读取器将是正确的，如同用于在长边缘上的装订。

      • TWO_SIDED_SHORT_EDGE

        public static final JobAttributes.SidesType TWO_SIDED_SHORT_EDGE
        用于指定连续作业页面的 SidesType实例应在连续的介质页的前侧和后侧打印，以使介质上的每对页面的方向对于读取器来说是正确的，如同在短边上装订一样。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals对比中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString中的 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


KeyboardFocusManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class KeyboardFocusManager

  • java.lang.Object
    • java.awt.KeyboardFocusManager
  • All Implemented Interfaces:
    KeyEventDispatcher ， KeyEventPostProcessor
    已知直接子类：
    DefaultKeyboardFocusManager

    public abstract class KeyboardFocusManager
extends Object
implements KeyEventDispatcher, KeyEventPostProcessor
    KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。 焦点所有者被定义为通常将接收用户生成的所有KeyEvent的应用程序中的组件。 关注的窗口是焦点所有者的或包含焦点所有者的窗口。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。

    KeyboardFocusManager是客户端代码查询焦点所有者并启动焦点更改的集中位置，以及所有FocusEvents，与焦点相关的WindowEvent和KeyEvents的事件调度程序。

    一些浏览器将不同代码库中的小程序分割成单独的上下文，并在这些上下文之间建立墙壁。 在这种情况下，每个上下文将有一个KeyboardFocusManager。 其他浏览器将所有小程序放入相同的上下文中，这意味着所有小程序都将只有一个全局的KeyboardFocusManager。 这种行为是依赖于实现的。 有关更多信息，请参阅浏览器的文档。 不管有多少上下文可能存在，但是，根据ClassLoader，永远不会有多个焦点所有者，关注窗口或活动窗口。

    请参阅How to Use the Focus Subsystem ， Java教程中的一节，以及有关更多信息的Focus Specification 。

    从以下版本开始：
    1.4
    另请参见：
    Window ， Frame ， Dialog ， FocusEvent ， WindowEvent ， KeyEvent

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BACKWARD_TRAVERSAL_KEYS
      后向聚焦遍历键的标识符。
      static int DOWN_CYCLE_TRAVERSAL_KEYS
      Down Cycle的标识符聚焦遍历键。
      static int FORWARD_TRAVERSAL_KEYS
      正向聚焦遍历键的标识符。
      static int UP_CYCLE_TRAVERSAL_KEYS
      上传周期聚焦遍历键的标识符。

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyboardFocusManager​()
      初始化KeyboardFocusManager。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addKeyEventDispatcher​(KeyEventDispatcher dispatcher)
      将KeyEventDispatcher添加到此KeyboardFocusManager的调度程序链中。
      void addKeyEventPostProcessor​(KeyEventPostProcessor processor)
      将KeyEventPostProcessor添加到此KeyboardFocusManager的后处理器链。
      void addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void addVetoableChangeListener​(VetoableChangeListener listener)
      将VetoableChangeListener添加到侦听器列表。
      void addVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      将VetoableChangeListener添加到特定属性的侦听器列表中。
      void clearFocusOwner​()
      如果焦点所有者存在并驻留在与调用线程相同的上下文中，则清除Java和本机级别的焦点所有者，否则该方法将静默返回。
      void clearGlobalFocusOwner​()
      在Java和本机级别清除全局焦点所有者。
      protected abstract void dequeueKeyEvents​(long after, Component untilFocused)
      由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。
      protected abstract void discardKeyEvents​(Component comp)
      由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。
      abstract boolean dispatchEvent​(AWTEvent e)
      该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。
      abstract boolean dispatchKeyEvent​(KeyEvent e)
      通常，如果调度程序链中没有其他的KeyEventDispatcher调度了KeyEvent，或者没有其他的KeyEventDispatchers被注册，这个方法将被调用 dispatchEvent 。
      void downFocusCycle​()
      当焦点所有者是当前焦点循环根的容器时，将焦点向下移动当前焦点所有者的一个焦点遍历循环。
      abstract void downFocusCycle​(Container aContainer)
      将焦点向下移动一个焦点遍历周期。
      protected abstract void enqueueKeyEvents​(long after, Component untilFocused)
      由AWT调用，通知KeyboardFocusManager它应该延迟调度KeyEvents，直到指定的Component成为焦点所有者。
      protected void firePropertyChange​(String propertyName, Object oldValue, Object newValue)
      触发PropertyChangeEvent以响应绑定属性的更改。
      protected void fireVetoableChange​(String propertyName, Object oldValue, Object newValue)
      触发PropertyChangeEvent以响应否决权属性的更改。
      void focusNextComponent​()
      在当前焦点所有者之后聚焦组件。
      abstract void focusNextComponent​(Component aComponent)
      将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
      void focusPreviousComponent​()
      将组件聚焦到当前焦点所有者之前。
      abstract void focusPreviousComponent​(Component aComponent)
      在组件之前聚焦组件，通常基于FocusTraversalPolicy。
      Window getActiveWindow​()
      如果活动窗口与调用线程处于相同的上下文中，则返回活动窗口。
      Container getCurrentFocusCycleRoot​()
      如果当前焦点循环根与调用线程处于相同的上下文中，则返回当前焦点循环根。
      static KeyboardFocusManager getCurrentKeyboardFocusManager​()
      返回调用线程上下文的当前KeyboardFocusManager实例。
      Set<AWTKeyStroke> getDefaultFocusTraversalKeys​(int id)
      返回给定遍历操作的一组默认焦点遍历键。
      FocusTraversalPolicy getDefaultFocusTraversalPolicy​()
      返回默认的FocusTraversalPolicy。
      Window getFocusedWindow​()
      如果集中的窗口与调用线程处于相同的上下文中，则返回关注的窗口。
      Component getFocusOwner​()
      如果焦点所有者与调用线程处于相同的上下文中，则返回焦点所有者。
      protected Window getGlobalActiveWindow​()
      返回活动窗口，即使调用线程与活动窗口处于不同的上下文中。
      protected Container getGlobalCurrentFocusCycleRoot​()
      返回当前焦点循环根，即使调用线程与当前焦点循环根不同。
      protected Window getGlobalFocusedWindow​()
      返回聚焦窗口，即使调用线程与聚焦窗口处于不同的上下文中。
      protected Component getGlobalFocusOwner​()
      即使调用线程与焦点所有者的上下文不同，返回焦点所有者。
      protected Component getGlobalPermanentFocusOwner​()
      返回永久焦点所有者，即使调用线程与永久焦点所有者处于不同的上下文中。
      protected List<KeyEventDispatcher> getKeyEventDispatchers​()
      将此KeyboardFocusManager的KeyEventDispatcher链作为列表返回。
      protected List<KeyEventPostProcessor> getKeyEventPostProcessors​()
      将此KeyboardFocusManager的KeyEventPostProcessor链返回为列表。
      Component getPermanentFocusOwner​()
      如果永久焦点所有者与调用线程处于相同的上下文中，则返回永久焦点所有者。
      PropertyChangeListener[] getPropertyChangeListeners​()
      返回在此键盘焦点管理器上注册的所有属性更改侦听器的数组。
      PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有 PropertyChangeListener的数组。
      VetoableChangeListener[] getVetoableChangeListeners​()
      返回在此键盘焦点管理器上注册的所有否决变更监听器的数组。
      VetoableChangeListener[] getVetoableChangeListeners​(String propertyName)
      返回与命名属性相关联的所有 VetoableChangeListener s的数组。
      abstract boolean postProcessKeyEvent​(KeyEvent e)
      此方法将由 dispatchKeyEvent 。
      abstract void processKeyEvent​(Component focusedComponent, KeyEvent e)
      当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。
      void redispatchEvent​(Component target, AWTEvent e)
      重新分配AWTEvent，AWT事件调度程序将不会递归地请求KeyboardFocusManager或任何已安装的KeyEventDispatchers再次发送事件。
      void removeKeyEventDispatcher​(KeyEventDispatcher dispatcher)
      删除之前添加到此KeyboardFocusManager调度程序链的KeyEventDispatcher。
      void removeKeyEventPostProcessor​(KeyEventPostProcessor processor)
      从此KeyboardFocusManager的后处理器链中删除以前添加的KeyEventPostProcessor。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
      void removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      从侦听器列表中为特定属性移除PropertyChangeListener。
      void removeVetoableChangeListener​(VetoableChangeListener listener)
      从侦听器列表中删除VetoableChangeListener。
      void removeVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      从侦听器列表中为特定属性删除VetoableChangeListener。
      static void setCurrentKeyboardFocusManager​(KeyboardFocusManager newManager)
      为调用线程的上下文设置当前的KeyboardFocusManager实例。
      void setDefaultFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置给定遍历操作的默认焦点遍历键。
      void setDefaultFocusTraversalPolicy​(FocusTraversalPolicy defaultPolicy)
      设置默认的FocusTraversalPolicy。
      protected void setGlobalActiveWindow​(Window activeWindow)
      设置活动窗口。
      void setGlobalCurrentFocusCycleRoot​(Container newFocusCycleRoot)
      设置当前焦点循环根。
      protected void setGlobalFocusedWindow​(Window focusedWindow)
      设置聚焦窗口。
      protected void setGlobalFocusOwner​(Component focusOwner)
      设置焦点所有者。
      protected void setGlobalPermanentFocusOwner​(Component permanentFocusOwner)
      设置永久焦点所有者。
      void upFocusCycle​()
      将焦点移动到当前焦点所有者的一个焦点遍历周期。
      abstract void upFocusCycle​(Component aComponent)
      将焦点移动到一个焦点遍历周期。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FORWARD_TRAVERSAL_KEYS

        public static final int FORWARD_TRAVERSAL_KEYS
        正向聚焦遍历键的标识符。
        另请参见：
        setDefaultFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， getDefaultFocusTraversalKeys(int) ， Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， Component.getFocusTraversalKeys(int) ， Constant Field Values

      • BACKWARD_TRAVERSAL_KEYS

        public static final int BACKWARD_TRAVERSAL_KEYS
        后向聚焦遍历键的标识符。
        另请参见：
        setDefaultFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， getDefaultFocusTraversalKeys(int) ， Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， Component.getFocusTraversalKeys(int) ， Constant Field Values

      • UP_CYCLE_TRAVERSAL_KEYS

        public static final int UP_CYCLE_TRAVERSAL_KEYS
        上传周期聚焦遍历键的标识符。
        另请参见：
        setDefaultFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， getDefaultFocusTraversalKeys(int) ， Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， Component.getFocusTraversalKeys(int) ， Constant Field Values

      • DOWN_CYCLE_TRAVERSAL_KEYS

        public static final int DOWN_CYCLE_TRAVERSAL_KEYS
        Down Cycle的标识符聚焦遍历键。
        另请参见：
        setDefaultFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， getDefaultFocusTraversalKeys(int) ， Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， Component.getFocusTraversalKeys(int) ， Constant Field Values

    • 构造方法详细信息

      • KeyboardFocusManager

        public KeyboardFocusManager​()
        初始化KeyboardFocusManager。

    • 方法详细信息

      • getCurrentKeyboardFocusManager

        public static KeyboardFocusManager getCurrentKeyboardFocusManager​()
        返回调用线程上下文的当前KeyboardFocusManager实例。
        结果
        这个线程的上下文的KeyboardFocusManager
        另请参见：
        setCurrentKeyboardFocusManager(java.awt.KeyboardFocusManager)

      • setCurrentKeyboardFocusManager

        public static void setCurrentKeyboardFocusManager​(KeyboardFocusManager newManager)
                                           throws SecurityException
        为调用线程的上下文设置当前的KeyboardFocusManager实例。 如果指定为null，则将使用DefaultKeyboardFocusManager的新实例替换当前的KeyboardFocusManager。

        如果安装了SecurityManager，则调用线程必须被授予AWTPermission“replaceKeyboardFocusManager”才能替换当前的KeyboardFocusManager。 如果未授予此权限，则此方法将抛出SecurityException，并且当前的KeyboardFocusManager将不会更改。

        参数
        newManager - 这个线程的上下文的新的KeyboardFocusManager
        异常
        SecurityException - 如果调用线程没有权限替换当前的KeyboardFocusManager
        另请参见：
        getCurrentKeyboardFocusManager() ， DefaultKeyboardFocusManager

      • getFocusOwner

        public Component getFocusOwner​()
        如果焦点所有者与调用线程处于相同的上下文中，则返回焦点所有者。 焦点所有者被定义为通常将接收用户生成的所有KeyEvent的应用程序中的组件。 如果为焦点所有者启用了焦点遍历键，则映射到焦点所有者焦点遍历键的KeyEvent将不会被传送。 此外，KeyEventDispatchers可能会在到达焦点所有者之前重新定位或使用KeyEvent。
        结果
        焦点所有者，如果焦点所有者不是调用线程的上下文的成员，则为null
        另请参见：
        getGlobalFocusOwner() ， setGlobalFocusOwner(java.awt.Component)

      • getGlobalFocusOwner

        protected Component getGlobalFocusOwner​()
                                 throws SecurityException
        即使调用线程与焦点所有者的上下文不同，返回焦点所有者。 焦点所有者被定义为通常将接收用户生成的所有KeyEvent的应用程序中的组件。 如果为焦点所有者启用了焦点遍历键，则映射到焦点所有者焦点遍历键的KeyEvent将不会被传送。 此外，KeyEventDispatchers可能会在到达焦点所有者之前重新定位或使用KeyEvent。

        如果此KeyboardFocusManager不是调用线程的上下文的当前KeyboardFocusManager，则此方法将抛出SecurityException。

        结果
        焦点所有者
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getFocusOwner() ， setGlobalFocusOwner(java.awt.Component)

      • setGlobalFocusOwner

        protected void setGlobalFocusOwner​(Component focusOwner)
                            throws SecurityException
        设置焦点所有者。 如果组件不可对焦，操作将被取消。 焦点所有者被定义为通常将接收用户生成的所有KeyEvent的应用程序中的组件。 如果为焦点所有者启用了焦点遍历键，则映射到焦点所有者焦点遍历键的KeyEvent将不会被传送。 此外，KeyEventDispatchers可能会在到达焦点所有者之前重新定位或使用KeyEvent。

        此方法实际上并没有将焦点设置为指定的组件。 它只存储getFocusOwner()随后返回的getFocusOwner() 。 使用Component.requestFocus()或Component.requestFocusInWindow()更改焦点所有者，受平台限制。

        参数
        focusOwner - 焦点所有者
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getFocusOwner() ，
getGlobalFocusOwner() ，
Component.requestFocus() ，
Component.requestFocusInWindow() ，
Component.isFocusable()

      • clearFocusOwner

        public void clearFocusOwner​()
        如果焦点所有者存在并驻留在与调用线程相同的上下文中，则清除Java和本机级别的焦点所有者，否则该方法将静默返回。

        焦点所有者组件将收到一个永久的FOCUS_LOST事件。 此操作完成后，本机窗口系统将丢弃所有用户生成的密钥事件，直到用户选择一个新的组件来接收焦点，或者通过调用requestFocus()明确指定了一个组件。 此操作不会更改聚焦或活动的Windows。

        从以下版本开始：
        1.8
        另请参见：
        Component.requestFocus() ， FocusEvent.FOCUS_LOST

      • clearGlobalFocusOwner

        public void clearGlobalFocusOwner​()
                           throws SecurityException
        在Java和本机级别清除全局焦点所有者。 如果存在焦点所有者，该组件将收到一个永久的FOCUS_LOST事件。 完成此操作后，本机窗口系统将丢弃所有用户生成的KeyEvent，直到用户选择新的Component来接收焦点，或者通过调用requestFocus()明确指定了一个Component。 此操作不会更改聚焦或活动的Windows。

        如果安装了SecurityManager，则调用线程必须被授予“replaceKeyboardFocusManager”AWTPermission。 如果未授予此权限，则此方法将抛出SecurityException异常，并且不会清除当前焦点所有者。

        此方法仅供KeyboardFocusManager设置为当前KeyboardFocusManager用于调用线程的上下文。 它不是一般客户使用。

        异常
        SecurityException - 如果调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        clearFocusOwner() ， Component.requestFocus() ， FocusEvent.FOCUS_LOST

      • getPermanentFocusOwner

        public Component getPermanentFocusOwner​()
        如果永久焦点所有者与调用线程处于相同的上下文中，则返回永久焦点所有者。 永久焦点所有者被定义为应用程序中接收永久FOCUS_GAINED事件的最后一个组件。 焦点所有者和永久焦点所有者是等效的，除非临时焦点更改目前有效。 在这种情况下，临时焦点变化结束时，永久性焦点所有者将再次成为焦点所有者。
        结果
        永久焦点所有者，如果永久焦点所有者不是调用线程的上下文的成员，则为null
        另请参见：
        getGlobalPermanentFocusOwner() ， setGlobalPermanentFocusOwner(java.awt.Component)

      • getGlobalPermanentFocusOwner

        protected Component getGlobalPermanentFocusOwner​()
                                          throws SecurityException
        返回永久焦点所有者，即使调用线程与永久焦点所有者处于不同的上下文中。 永久焦点所有者被定义为应用程序中接收永久FOCUS_GAINED事件的最后一个组件。 焦点所有者和永久焦点所有者是等效的，除非临时焦点更改目前有效。 在这种情况下，临时焦点变化结束时，永久性焦点所有者将再次成为焦点所有者。
        结果
        永久焦点所有者
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getPermanentFocusOwner() ， setGlobalPermanentFocusOwner(java.awt.Component)

      • setGlobalPermanentFocusOwner

        protected void setGlobalPermanentFocusOwner​(Component permanentFocusOwner)
                                     throws SecurityException
        设置永久焦点所有者。 如果组件不可对焦，操作将被取消。 永久焦点所有者被定义为应用程序中接收永久FOCUS_GAINED事件的最后一个组件。 焦点所有者和永久焦点所有者是等效的，除非临时焦点更改目前有效。 在这种情况下，临时焦点变化结束时，永久性焦点所有者将再次成为焦点所有者。

        此方法实际上并没有将焦点设置为指定的组件。 它仅存储getPermanentFocusOwner()后续返回的getPermanentFocusOwner() 。 使用Component.requestFocus()或Component.requestFocusInWindow()更改焦点所有者，但受平台限制。

        参数
        permanentFocusOwner - 永久焦点所有者
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getPermanentFocusOwner() ，
getGlobalPermanentFocusOwner() ，
Component.requestFocus() ，
Component.requestFocusInWindow() ，
Component.isFocusable()

      • getFocusedWindow

        public Window getFocusedWindow​()
        如果集中的窗口与调用线程处于相同的上下文中，则返回关注的窗口。 关注的窗口是包含焦点所有者的窗口。
        结果
        关注的窗口，如果聚焦的窗口不是调用线程的上下文的成员，则为null
        另请参见：
        getGlobalFocusedWindow() ， setGlobalFocusedWindow(java.awt.Window)

      • getGlobalFocusedWindow

        protected Window getGlobalFocusedWindow​()
                                 throws SecurityException
        返回聚焦窗口，即使调用线程与聚焦窗口处于不同的上下文中。 关注的窗口是包含焦点所有者的窗口。
        结果
        关注窗口
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getFocusedWindow() ， setGlobalFocusedWindow(java.awt.Window)

      • setGlobalFocusedWindow

        protected void setGlobalFocusedWindow​(Window focusedWindow)
                               throws SecurityException
        设置聚焦窗口。 关注的窗口是包含焦点所有者的窗口。 如果指定的对焦窗口不是可调焦窗口，则操作将被取消。

        就本地窗口系统而言，此方法实际上并没有改变关注窗口。 它仅存储getFocusedWindow()后续返回的getFocusedWindow() 。 使用Component.requestFocus()或Component.requestFocusInWindow()更改聚焦的窗口，受平台限制。

        参数
        focusedWindow - 聚焦窗口
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getFocusedWindow() ，
getGlobalFocusedWindow() ，
Component.requestFocus() ，
Component.requestFocusInWindow() ，
Window.isFocusableWindow()

      • getActiveWindow

        public Window getActiveWindow​()
        如果活动窗口与调用线程处于相同的上下文中，则返回活动窗口。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。
        结果
        活动窗口，如果活动窗口不是调用线程的上下文的成员，则为null
        另请参见：
        getGlobalActiveWindow() ， setGlobalActiveWindow(java.awt.Window)

      • getGlobalActiveWindow

        protected Window getGlobalActiveWindow​()
                                throws SecurityException
        返回活动窗口，即使调用线程与活动窗口处于不同的上下文中。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。
        结果
        活动窗口
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getActiveWindow() ， setGlobalActiveWindow(java.awt.Window)

      • setGlobalActiveWindow

        protected void setGlobalActiveWindow​(Window activeWindow)
                              throws SecurityException
        设置活动窗口。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。

        就本地窗口系统而言，此方法实际上并不会更改活动窗口。 它仅存储getActiveWindow()后续返回的getActiveWindow() 。 使用Component.requestFocus()或Component.requestFocusInWindow()更改活动窗口，受平台限制。

        参数
        activeWindow - 活动窗口
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getActiveWindow() ，
getGlobalActiveWindow() ，
Component.requestFocus() ，
Component.requestFocusInWindow()

      • getDefaultFocusTraversalPolicy

        public FocusTraversalPolicy getDefaultFocusTraversalPolicy​()
        返回默认的FocusTraversalPolicy。 顶级组件在创建时使用此值来通过显式调用Container.setFocusTraversalPolicy来初始化自己的焦点遍历策略。
        结果
        默认的FocusTraversalPolicy。 将永远不会返回null。
        另请参见：
        setDefaultFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ，
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ，
Container.getFocusTraversalPolicy()

      • setDefaultFocusTraversalPolicy

        public void setDefaultFocusTraversalPolicy​(FocusTraversalPolicy defaultPolicy)
        设置默认的FocusTraversalPolicy。 顶级组件在创建时使用此值来通过显式调用Container.setFocusTraversalPolicy来初始化自己的焦点遍历策略。 注意：此调用不会影响已创建的组件，因为它们的策略已初始化。 只有新组件将使用此策略作为其默认策略。
        参数
        defaultPolicy - 新的默认FocusTraversalPolicy
        异常
        IllegalArgumentException - 如果defaultPolicy为空
        另请参见：
        getDefaultFocusTraversalPolicy() ，
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ，
Container.getFocusTraversalPolicy()

      • setDefaultFocusTraversalKeys

        public void setDefaultFocusTraversalKeys​(int id,
                                         Set<? extends AWTKeyStroke> keystrokes)
        设置给定遍历操作的默认焦点遍历键。 这个遍历键Set将对所有没有自己明确定义的Set的所有Window都Window 。 这个Set也将被那些没有自己明确定义的这样的Set的那些Windows的任何一个小孩Component递归地继承。

        默认焦点遍历键的默认值与实现相关。 Sun建议特定本地平台的所有实现使用相同的默认值。 Windows和Unix的建议如下。 这些建议用于Sun AWT实现。

        Recommended default values for focus traversal keys Identifier Meaning Default KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS Normal forward keyboard traversal TAB on KEY_PRESSED, CTRL-TAB on KEY_PRESSED KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS Normal reverse keyboard traversal SHIFT-TAB on KEY_PRESSED, CTRL-SHIFT-TAB on KEY_PRESSED KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS Go up one focus traversal cycle none KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS Go down one focus traversal cycle none
        要禁用遍历键，请使用空的Set ; 推荐Collections.EMPTY_SET 。

        使用AWTKeyStroke API，客户端代码可以指定在其上的两个特定KeyEvent S， KEY_PRESSED或KEY_RELEASED ，会发生焦点遍历操作。 但是，无论指定了哪个KeyEvent ，所有KeyEvent与焦点遍历密钥相关的所有KeyEvent都将被使用，包括相关联的KEY_TYPED事件，并且不会发送到任何Component 。 将KEY_TYPED事件指定为聚焦遍历操作，或者将相同的事件映射到多个默认焦点遍历操作是一个运行时错误。

        这种方法可能抛出ClassCastException如有Object在keystrokes不是AWTKeyStroke 。

        参数
        id -一个 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS ，或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS
        keystrokes - 指定操作的 AWTKeyStroke的集合
        异常
        IllegalArgumentException -如果ID是不是一个 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS ，或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS ，或者击键为 null ，或者击键包含 null ，或者击键表示 KEY_TYPED事件，或者击键已映射为别的默认焦点遍历操作
        另请参见：
        getDefaultFocusTraversalKeys(int) ， Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， Component.getFocusTraversalKeys(int)

      • getDefaultFocusTraversalKeys

        public Set<AWTKeyStroke> getDefaultFocusTraversalKeys​(int id)
        返回给定遍历操作的一组默认焦点遍历键。 这个遍历密钥集将在所有没有自己显式定义的这样的组的Windows上生效。 该集合也将被那些没有自己明确定义的这样的组的那些Windows的任何子组件递归递归。 （有关各操作的完整说明，请参阅setDefaultFocusTraversalKeys ）
        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS之一，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS
        结果
        Set的AWTKeyStroke s为指定的操作; Set将不可修改，可能为空; 将永远不会返回null
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS中的一个
        另请参见：
        setDefaultFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ，
Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ，
Component.getFocusTraversalKeys(int)

      • getCurrentFocusCycleRoot

        public Container getCurrentFocusCycleRoot​()
        如果当前焦点循环根与调用线程处于相同的上下文中，则返回当前焦点循环根。 如果焦点所有者本身是焦点循环根，那么对于哪些组件表示正常聚焦遍历期间要聚焦的下一个和以前的组件可能是不明确的。 在这种情况下，当前的焦点循环根用于区分可能性。

        此方法仅供KeyboardFocusManagers和焦点实施使用。 它不是一般客户使用。

        结果
        当前焦点循环根，如果当前焦点循环根不是调用线程的上下文的成员，则为null
        另请参见：
        getGlobalCurrentFocusCycleRoot() ， setGlobalCurrentFocusCycleRoot(java.awt.Container)

      • getGlobalCurrentFocusCycleRoot

        protected Container getGlobalCurrentFocusCycleRoot​()
                                            throws SecurityException
        返回当前焦点循环根，即使调用线程与当前焦点循环根不同。 如果焦点所有者本身是焦点循环根，那么对于哪些组件表示正常聚焦遍历期间要聚焦的下一个和以前的组件可能是不明确的。 在这种情况下，当前的焦点循环根用于区分可能性。
        结果
        当前焦点循环根，如果当前焦点循环根不是调用线程的上下文的成员，则为null
        异常
        SecurityException - 如果此KeyboardFocusManager不是调用线程上下文的当前KeyboardFocusManager，并且调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getCurrentFocusCycleRoot() ， setGlobalCurrentFocusCycleRoot(java.awt.Container)

      • setGlobalCurrentFocusCycleRoot

        public void setGlobalCurrentFocusCycleRoot​(Container newFocusCycleRoot)
                                    throws SecurityException
        设置当前焦点循环根。 如果焦点所有者本身是焦点循环根，那么对于哪些组件表示正常聚焦遍历期间要聚焦的下一个和以前的组件可能是不明确的。 在这种情况下，当前的焦点循环根用于区分可能性。

        如果安装了SecurityManager，则调用线程必须被授予“replaceKeyboardFocusManager”AWTPermission。 如果未授予此权限，则此方法将抛出SecurityException，并且当前焦点循环根不会被更改。

        此方法仅供KeyboardFocusManagers和焦点实施使用。 它不是一般客户使用。

        参数
        newFocusCycleRoot - 新的焦点循环根
        异常
        SecurityException - 如果调用线程没有“replaceKeyboardFocusManager”权限
        另请参见：
        getCurrentFocusCycleRoot() ， getGlobalCurrentFocusCycleRoot()

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        将PropertyChangeListener添加到侦听器列表。 监听器已注册到此类的所有绑定属性，包括以下内容：
        • KeyboardFocusManager是否正在管理此应用程序或小程序的浏览器上下文（“manageFocus”）的焦点
        • 焦点所有者（“focusOwner”）
        • 永久焦点所有者（“permanentFocusOwner”）
        • 聚焦窗口（“focusedWindow”）
        • 活动窗口（“activeWindow”）
        • 默认焦点遍历策略（“defaultFocusTraversalPolicy”）
        • 默认设置FORWARD_TRAVERSAL_KEYS（“forwardDefaultFocusTraversalKeys”）
        • 默认设置BACKWARD_TRAVERSAL_KEYS（“backwardDefaultFocusTraversalKeys”）
        • 默认设置UP_CYCLE_TRAVERSAL_KEYS（“upCycleDefaultFocusTraversalKeys”）
        • 默认设置DOWN_CYCLE_TRAVERSAL_KEYS（“downCycleDefaultFocusTraversalKeys”）
        • 当前焦点循环根（“currentFocusCycleRoot”）
        如果侦听器为空，则不会抛出异常，也不会执行任何操作。
        参数
        listener - 要添加的PropertyChangeListener
        另请参见：
        removePropertyChangeListener(java.beans.PropertyChangeListener) ，
getPropertyChangeListeners() ，
addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener listener)
        从侦听器列表中移除PropertyChangeListener。 应该使用此方法来删除已为此类的所有绑定属性注册的PropertyChangeListeners。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        参数
        listener - 要删除的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ，
getPropertyChangeListeners() ，
removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​()
        返回在此键盘焦点管理器上注册的所有属性更改侦听器的数组。
        结果
        所有这个键盘焦点经理的 PropertyChangeListener s或一个空数组，如果没有属性更改侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ，
removePropertyChangeListener(java.beans.PropertyChangeListener) ，
getPropertyChangeListeners(java.lang.String)

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String propertyName,
                                      PropertyChangeListener listener)
        将PropertyChangeListener添加到特定属性的侦听器列表中。 指定的属性可能是用户定义的，也可能是以下之一：
        • KeyboardFocusManager是否正在管理此应用程序或小程序的浏览器上下文（“manageFocus”）的焦点
        • 焦点所有者（“focusOwner”）
        • 永久焦点所有者（“permanentFocusOwner”）
        • 聚焦窗口（“focusedWindow”）
        • 活动窗口（“activeWindow”）
        • 默认焦点遍历策略（“defaultFocusTraversalPolicy”）
        • 默认设置FORWARD_TRAVERSAL_KEYS（“forwardDefaultFocusTraversalKeys”）
        • 默认设置BACKWARD_TRAVERSAL_KEYS（“backwardDefaultFocusTraversalKeys”）
        • 默认设置UP_CYCLE_TRAVERSAL_KEYS（“upCycleDefaultFocusTraversalKeys”）
        • 默认设置DOWN_CYCLE_TRAVERSAL_KEYS（“downCycleDefaultFocusTraversalKeys”）
        • 当前焦点循环根（“currentFocusCycleRoot”）
        如果侦听器为空，则不会抛出异常，也不会执行任何操作。
        参数
        propertyName - 上面列出的属性名称之一
        listener - 要添加的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ，
removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener) ，
getPropertyChangeListeners(java.lang.String)

      • removePropertyChangeListener

        public void removePropertyChangeListener​(String propertyName,
                                         PropertyChangeListener listener)
        从侦听器列表中为特定属性移除PropertyChangeListener。 应该使用此方法来删除为特定绑定属性注册的PropertyChangeListeners。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        参数
        propertyName - 有效的属性名称
        listener - 要删除的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener) ，
getPropertyChangeListeners(java.lang.String) ，
removePropertyChangeListener(java.beans.PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
        返回与named属性相关联的所有 PropertyChangeListener的数组。
        参数
        propertyName - 属性名称
        结果
        所有 PropertyChangeListener与命名属性相关联，如果没有添加此类侦听器，则为空数组。
        从以下版本开始：
        1.4
        另请参见：
        addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener) ， removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

      • firePropertyChange

        protected void firePropertyChange​(String propertyName,
                                  Object oldValue,
                                  Object newValue)
        触发PropertyChangeEvent以响应绑定属性的更改。 该事件将传递给所有注册的PropertyChangeListeners。 如果oldValue和newValue相同，则不会传递任何事件。
        参数
        propertyName - 已更改的属性的名称
        oldValue - 该物业的以前的价值
        newValue - 该物业的新值

      • addVetoableChangeListener

        public void addVetoableChangeListener​(VetoableChangeListener listener)
        将VetoableChangeListener添加到侦听器列表。 监听器已注册该类的所有可判定属性，包括以下内容：
        • 焦点所有者（“focusOwner”）
        • 永久焦点所有者（“permanentFocusOwner”）
        • 聚焦窗口（“focusedWindow”）
        • 活动窗口（“activeWindow”）
        如果侦听器为空，则不会抛出异常，也不会执行任何操作。
        参数
        listener - 要添加的VetoableChangeListener
        另请参见：
        removeVetoableChangeListener(java.beans.VetoableChangeListener) ，
getVetoableChangeListeners() ，
addVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener)

      • removeVetoableChangeListener

        public void removeVetoableChangeListener​(VetoableChangeListener listener)
        从侦听器列表中删除VetoableChangeListener。 应该使用此方法来删除已为此类的所有可移动属性注册的VetoableChangeListeners。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        参数
        listener - 要删除的VetoableChangeListener
        另请参见：
        addVetoableChangeListener(java.beans.VetoableChangeListener) ，
getVetoableChangeListeners() ，
removeVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener)

      • getVetoableChangeListeners

        public VetoableChangeListener[] getVetoableChangeListeners​()
        返回在此键盘焦点管理器上注册的所有否决变更监听器的数组。
        结果
        所有这个键盘焦点经理的 VetoableChangeListener s或一个空数组，如果没有否决权变更听众当前注册
        从以下版本开始：
        1.4
        另请参见：
        addVetoableChangeListener(java.beans.VetoableChangeListener) ，
removeVetoableChangeListener(java.beans.VetoableChangeListener) ，
getVetoableChangeListeners(java.lang.String)

      • addVetoableChangeListener

        public void addVetoableChangeListener​(String propertyName,
                                      VetoableChangeListener listener)
        将VetoableChangeListener添加到特定属性的侦听器列表中。 指定的属性可能是用户定义的，也可能是以下之一：
        • 焦点所有者（“focusOwner”）
        • 永久焦点所有者（“permanentFocusOwner”）
        • 聚焦窗口（“focusedWindow”）
        • 活动窗口（“activeWindow”）
        如果侦听器为空，则不会抛出异常，也不会执行任何操作。
        参数
        propertyName - 上面列出的属性名称之一
        listener - 要添加的VetoableChangeListener
        另请参见：
        addVetoableChangeListener(java.beans.VetoableChangeListener) ，
removeVetoableChangeListener(java.beans.VetoableChangeListener) ，
getVetoableChangeListeners()

      • removeVetoableChangeListener

        public void removeVetoableChangeListener​(String propertyName,
                                         VetoableChangeListener listener)
        从侦听器列表中为特定属性删除VetoableChangeListener。 该方法应用于删除已注册为特定绑定属性的VetoableChangeListeners。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        参数
        propertyName - 有效的属性名称
        listener - 要删除的VetoableChangeListener
        另请参见：
        addVetoableChangeListener(java.beans.VetoableChangeListener) ，
getVetoableChangeListeners() ，
removeVetoableChangeListener(java.beans.VetoableChangeListener)

      • getVetoableChangeListeners

        public VetoableChangeListener[] getVetoableChangeListeners​(String propertyName)
        返回与命名属性相关联的所有 VetoableChangeListener的数组。
        参数
        propertyName - 属性名称
        结果
        所有 VetoableChangeListener与命名属性相关联，如果没有添加此类侦听器，则为空数组。
        从以下版本开始：
        1.4
        另请参见：
        addVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener) ，
removeVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener) ，
getVetoableChangeListeners()

      • fireVetoableChange

        protected void fireVetoableChange​(String propertyName,
                                  Object oldValue,
                                  Object newValue)
                           throws PropertyVetoException
        触发PropertyChangeEvent以响应否决权属性的更改。 该事件将交付给所有注册的VetoableChangeListeners。 如果VetoableChangeListener抛出PropertyVetoException，则会触发一个新事件，将所有VetoableChangeListener还原为旧值，然后重新引导异常。 如果oldValue和newValue相同，则不会传递任何事件。
        参数
        propertyName - 已更改的属性的名称
        oldValue - 该物业的以前的价值
        newValue - 该物业的新价值
        异常
        PropertyVetoException - 如果一个 VetoableChangeListener投掷 PropertyVetoException

      • addKeyEventDispatcher

        public void addKeyEventDispatcher​(KeyEventDispatcher dispatcher)
        将KeyEventDispatcher添加到此KeyboardFocusManager的调度程序链中。 此KeyboardFocusManager将请求每个KeyEventDispatcher调度由用户生成的KeyEvents，然后最终分派KeyEvent本身。 KeyEventDispatchers将按照添加的顺序进行通知。 一旦KeyEventDispatcher从其dispatchKeyEvent方法返回true ，通知将停止。 对于可以添加的KeyEventDispatchers的总数以及可以添加特定的KeyEventDispatcher实例的次数没有限制。

        如果指定了空调度器，则不会执行任何操作，也不会抛出任何异常。

        在多线程应用程序中， KeyEventDispatcher的行为与其他AWT侦听器相同。 详见AWT Threading Issues 。

        参数
        dispatcher - 要添加到调度程序链的KeyEventDispatcher
        另请参见：
        removeKeyEventDispatcher(java.awt.KeyEventDispatcher)

      • removeKeyEventDispatcher

        public void removeKeyEventDispatcher​(KeyEventDispatcher dispatcher)
        删除之前添加到此KeyboardFocusManager调度程序链的KeyEventDispatcher。 此KeyboardFocusManager本身不能被删除，除非通过调用addKeyEventDispatcher显式重新注册。

        如果指定了一个空调度器，如果指定的调度程序不在调度程序链中，或者如果在未明确重新注册的情况下指定了此KeyboardFocusManager，则不会执行任何操作，也不会引发异常。

        在多线程应用程序中， KeyEventDispatcher的行为与其他AWT侦听器相同。 详见AWT Threading Issues 。

        参数
        dispatcher - 要从调度程序链中删除的KeyEventDispatcher
        另请参见：
        addKeyEventDispatcher(java.awt.KeyEventDispatcher)

      • getKeyEventDispatchers

        protected List<KeyEventDispatcher> getKeyEventDispatchers​()
        将此KeyboardFocusManager的KeyEventDispatcher链作为列表返回。 该列表将不包括此KeyboardFocusManager，除非通过调用addKeyEventDispatcher显式重新注册。 如果没有其他的KeyEventDispatchers被注册，实现可以自由地返回null或一个长度为0的列表。客户端代码不应该假定一个行为超过另一个，也不应该假定一旦建立的行为将不会改变。
        结果
        可能为空或空的KeyEventDispatchers列表
        另请参见：
        addKeyEventDispatcher(java.awt.KeyEventDispatcher) ， removeKeyEventDispatcher(java.awt.KeyEventDispatcher)

      • addKeyEventPostProcessor

        public void addKeyEventPostProcessor​(KeyEventPostProcessor processor)
        将KeyEventPostProcessor添加到此KeyboardFocusManager的后处理器链。 在KeyEvent已经被派发到目标的目标之后，KeyboardFocusManager将要求每个KeyEventPostProcessor执行任何必要的后期处理，作为KeyEvent的最终解决方案的一部分。 KeyEventPostProcessors将按照添加的顺序进行通知; 当前的KeyboardFocusManager最后会被通知。 一旦KeyEventPostProcessor从其postProcessKeyEvent方法返回true ，通知将停止。 对于可以添加的KeyEventPostProcessors的总数以及可以添加特定的KeyEventPostProcessor实例的次数没有限制。

        如果指定了空的后处理器，则不会采取任何操作，也不会抛出任何异常。

        在多线程应用程序中， KeyEventPostProcessor与其他AWT侦听器的行为相同。 详见AWT Threading Issues 。

        参数
        processor - 要添加到后处理器链的KeyEventPostProcessor
        另请参见：
        removeKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

      • removeKeyEventPostProcessor

        public void removeKeyEventPostProcessor​(KeyEventPostProcessor processor)
        从此KeyboardFocusManager的后处理器链中删除以前添加的KeyEventPostProcessor。 这个KeyboardFocusManager本身不能从链中完全删除。 只有通过addKeyEventPostProcessor添加的其他参考文献可以被删除。

        如果指定了空的后处理器，如果指定的后处理器不在后处理器链中，或者如果未指定此KeyboardFocusManager，而不显式添加，则不会执行任何操作，也不会抛出任何异常。

        在多线程应用程序中， KeyEventPostProcessor的行为与其他AWT侦听器相同。 有关详细信息，请参阅AWT Threading Issues 。

        参数
        processor - 从后处理器链中删除的KeyEventPostProcessor
        另请参见：
        addKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

      • getKeyEventPostProcessors

        protected List<KeyEventPostProcessor> getKeyEventPostProcessors​()
        将此KeyboardFocusManager的KeyEventPostProcessor链返回为列表。 该列表将不包括此KeyboardFocusManager，除非通过调用显式添加到addKeyEventPostProcessor 。 如果没有注册KeyEventPostProcessors，实现可以返回null或者一个长度为0的列表。客户端代码不应该假定一个行为超过另一个，也不应该假定一旦建立的行为将不会改变。
        结果
        可能为空或空的KeyEventPostProcessors列表
        另请参见：
        addKeyEventPostProcessor(java.awt.KeyEventPostProcessor) ， removeKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

      • dispatchEvent

        public abstract boolean dispatchEvent​(AWTEvent e)
        该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。 预计所有的KeyboardFocusManagers将派发所有FocusEvents，所有与焦点相关的WindowEvent和所有KeyEvents。 这些事件应该基于KeyboardFocusManager对焦点所有者和聚焦和活动Windows的概念进行调度，有时覆盖指定的AWTEvent的源。 必须使用redispatchEvent进行调度，以防止AWT事件调度程序递归地请求KeyboardFocusManager再次分派事件。 如果此方法返回false ，则AWT事件调度程序将尝试调度事件本身。
        参数
        e - 要发送的AWTEvent
        结果
        true如果此方法调度事件; false否则
        另请参见：
        redispatchEvent(java.awt.Component, java.awt.AWTEvent) ， dispatchKeyEvent(java.awt.event.KeyEvent)

      • redispatchEvent

        public final void redispatchEvent​(Component target,
                                  AWTEvent e)
        重新分配AWTEvent，AWT事件调度程序将不会递归地请求KeyboardFocusManager或任何已安装的KeyEventDispatchers再次发送事件。 dispatchEvent和客户端定义的KeyEventDispatchers的客户端实现必须调用redispatchEvent(target, e)而不是target.dispatchEvent(e)来调度事件。

        此方法仅供KeyboardFocusManagers和KeyEventDispatchers使用。 它不是一般客户使用。

        参数
        target - 事件应分发到的组件
        e - 发送事件
        另请参见：
        dispatchEvent(java.awt.AWTEvent) ， KeyEventDispatcher

      • dispatchKeyEvent

        public abstract boolean dispatchKeyEvent​(KeyEvent e)
        通常，如果调度程序链中没有其他的KeyEventDispatcher调度了KeyEvent，或者没有其他的KeyEventDispatchers被注册，这个方法将被调用dispatchEvent 。 如果此方法的实现返回false ，则dispatchEvent可能会尝试发送KeyEvent本身，或者可以简单地返回false 。 如果true返回， dispatchEvent应该返回true为好。
        Specified by:
        dispatchKeyEvent在接口 KeyEventDispatcher
        参数
        e - 当前KeyboardFocusManager请求此KeyEventDispatcher调度的KeyEvent
        结果
        true如果发送了KeyEvent; false否则
        另请参见：
        dispatchEvent(java.awt.AWTEvent)

      • postProcessKeyEvent

        public abstract boolean postProcessKeyEvent​(KeyEvent e)
        此方法将由dispatchKeyEvent 。 默认情况下，此方法将通过消耗事件并激活快捷方式来处理映射到AWT MenuShortcut的任何未消息的KeyEvent。
        Specified by:
        postProcessKeyEvent在接口 KeyEventPostProcessor
        参数
        e - 后期处理的KeyEvent
        结果
        true表示没有其他的KeyEventPostProcessor将被通知KeyEvent。
        另请参见：
        dispatchKeyEvent(java.awt.event.KeyEvent) ， MenuShortcut

      • processKeyEvent

        public abstract void processKeyEvent​(Component focusedComponent,
                                     KeyEvent e)
        当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。 预计focusComponent是当前的焦点所有者，尽管不一定是这样。 如果不是，聚焦遍历将继续进行，就像focusedComponent是当前焦点所有者一样。
        参数
        focusedComponent - 如果指定的事件表示组件的聚焦遍历键，则该组件将成为聚焦遍历操作的基础
        e - 可能代表焦点遍历键的事件

      • enqueueKeyEvents

        protected abstract void enqueueKeyEvents​(long after,
                                         Component untilFocused)
        由AWT调用，通知KeyboardFocusManager它应该延迟调度KeyEvents，直到指定的Component成为焦点所有者。 如果客户端代码请求焦点更改，并且AWT确定此请求可能由本机窗口系统授予，则AWT将调用此方法。 KeyboardFocusManager有责任延迟时间戳晚于指定时间戳的KeyEvents调度，直到指定的组件收到FOCUS_GAINED事件为止，或AWT通过调用dequeueKeyEvents或discardKeyEvents取消延迟请求。
        参数
        after - 当前事件的时间戳或当前事件没有时间戳的当前系统时间，或者AWT无法确定当前处理的事件
        untilFocused - 应该在任何待处理的KeyEvent之前收到FOCUS_GAINED事件的组件
        另请参见：
        dequeueKeyEvents(long, java.awt.Component) ， discardKeyEvents(java.awt.Component)

      • dequeueKeyEvents

        protected abstract void dequeueKeyEvents​(long after,
                                         Component untilFocused)
        由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。 由于调用enqueueKeyEvents具有相同时间戳和组件而排队的所有KeyEvent都应该被释放，以便正常发送到当前焦点所有者。 如果给定的时间戳小于零，则应取消给具有最早时间戳（如果有）的给定组件的未完成的入队请求。
        参数
        after - 在调用 enqueueKeyEvents指定的时间戳，或任何值<0
        untilFocused - 在调用 enqueueKeyEvents指定的组件
        另请参见：
        enqueueKeyEvents(long, java.awt.Component) ， discardKeyEvents(java.awt.Component)

      • discardKeyEvents

        protected abstract void discardKeyEvents​(Component comp)
        由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。 由于对同一个组件的一个或多个调用enqueueKeyEvents所有KeyEvent都应该被丢弃。
        参数
        comp - 在一个或多个调用 enqueueKeyEvents指定的组件
        另请参见：
        enqueueKeyEvents(long, java.awt.Component) ， dequeueKeyEvents(long, java.awt.Component)

      • focusNextComponent

        public abstract void focusNextComponent​(Component aComponent)
        将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
        参数
        aComponent - 作为焦点遍历操作的基础的组件
        另请参见：
        FocusTraversalPolicy

      • focusPreviousComponent

        public abstract void focusPreviousComponent​(Component aComponent)
        在组件之前聚焦组件，通常基于FocusTraversalPolicy。
        参数
        aComponent - 作为焦点遍历操作的基础的组件
        另请参见：
        FocusTraversalPolicy

      • upFocusCycle

        public abstract void upFocusCycle​(Component aComponent)
        将焦点移动到一个焦点遍历周期。 通常，焦点所有者设置为aComponent的焦点循环根，并将当前焦点循环根设置为新焦点所有者的焦点循环根。 然而，如果aComponent的焦点循环根是Window，那么通常将焦点所有者设置为Window的默认组件进行聚焦，并且当前焦点循环根不变。
        参数
        aComponent - 作为焦点遍历操作的基础的组件

      • downFocusCycle

        public abstract void downFocusCycle​(Container aContainer)
        将焦点向下移动一个焦点遍历周期。 通常，如果aContainer是焦点循环根，则焦点所有者将设置为aContainer的默认组件以进行对焦，并将当前焦点循环根设置为aContainer。 如果aContainer不是焦点循环根，则不会发生焦点遍历操作。
        参数
        aContainer - 作为焦点遍历操作的基础的容器

      • focusNextComponent

        public final void focusNextComponent​()
        在当前焦点所有者之后聚焦组件。

      • focusPreviousComponent

        public final void focusPreviousComponent​()
        将组件聚焦到当前焦点所有者之前。

      • upFocusCycle

        public final void upFocusCycle​()
        将焦点移动到当前焦点所有者的一个焦点遍历周期。 通常，新的焦点所有者设置为当前焦点所有者的焦点循环根，并将当前焦点循环根设置为新焦点所有者的焦点循环根。 然而，如果当前焦点所有者的焦点循环根是Window，则通常将焦点所有者设置为焦点循环根的默认组件以进行对焦，并且当前焦点循环根不变。

      • downFocusCycle

        public final void downFocusCycle​()
        当焦点所有者是当前焦点循环根的容器时，将焦点向下移动当前焦点所有者的一个焦点遍历循环。 通常，焦点所有者设置为当前焦点所有者的默认组件以进行对焦，并将当前焦点循环根设置为当前焦点所有者。 如果当前焦点所有者不是作为焦点循环根的容器，则不会发生焦点遍历操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


KeyEventDispatcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface KeyEventDispatcher

  • 所有已知实现类：
    DefaultFocusManager ， DefaultKeyboardFocusManager ， FocusManager ， KeyboardFocusManager
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface KeyEventDispatcher
    KeyEventDispatcher与所有KeyEvents的目标和调度中的当前KeyboardFocusManager配合使用。 使用当前KeyboardFocusManager注册的KeyEventDispatchers将在它们被派发到其目标之前接收KeyEvent，从而允许每个KeyEventDispatcher重新定位事件，使用它，调度事件本身或进行其他更改。

    请注意，KeyboardFocusManager本身实现了KeyEventDispatcher。 默认情况下，当前的KeyboardFocusManager将是注册的KeyEventDispatchers未发送的所有KeyEvent的接收器。 当前的KeyboardFocusManager不能被完全注销为KeyEventDispatcher。 但是，如果KeyEventDispatcher报告它分派了KeyEvent，无论是否实际执行此操作，KeyboardFocusManager将不再对KeyEvent执行任何操作。 （虽然客户端代码可以将当前的KeyboardFocusManager注册为KeyEventDispatcher一次或多次，但这通常是不需要的，不推荐使用。）

    从以下版本开始：
    1.4
    另请参见：
    KeyboardFocusManager.addKeyEventDispatcher(java.awt.KeyEventDispatcher) ， KeyboardFocusManager.removeKeyEventDispatcher(java.awt.KeyEventDispatcher)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean dispatchKeyEvent​(KeyEvent e)
      此方法由当前的KeyboardFocusManager调用，请求此KeyEventDispatcher代表它分派指定的事件。

    • 方法详细信息

      • dispatchKeyEvent

        boolean dispatchKeyEvent​(KeyEvent e)
        此方法由当前的KeyboardFocusManager调用，请求此KeyEventDispatcher代表它分派指定的事件。 此KeyEventDispatcher可以自由重新定位事件，消耗它，分派它自己或进行其他更改。 此功能通常用于将KeyEvents传递给焦点所有者以外的组件。 例如，在可访问环境中导航不可聚焦Windows的子项时，这可能很有用。 请注意，如果KeyEventDispatcher调度KeyEvent本身，则必须使用redispatchEvent来防止当前的KeyboardFocusManager递归地请求此KeyEventDispatcher再次分派该事件。

        如果此方法的实现返回false ，则将KeyEvent传递到链中的下一个KeyEventDispatcher，以当前的KeyboardFocusManager结尾。 如果一个实现返回true ，则假定KeyEvent已被调度（尽管不需要这样），并且当前的KeyboardFocusManager将不再对KeyEvent执行任何操作。 在这种情况下， KeyboardFocusManager.dispatchEvent应该返回true 。 如果一个实现消耗了KeyEvent，但是返回false ，那么消耗的事件仍将被传递给链中的下一个KeyEventDispatcher。 开发人员必须检查KeyEvent是否在将其分派到目标之前已被使用。 默认情况下，当前的KeyboardFocusManager将不会调度消耗的KeyEvent。

        参数
        e - 要发送的KeyEvent
        结果
        true如果KeyboardFocusManager对KeyEvent不应该采取进一步的操作; false否则
        另请参见：
        KeyboardFocusManager.redispatchEvent(java.awt.Component, java.awt.AWTEvent)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


KeyEventPostProcessor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface KeyEventPostProcessor

  • 所有已知实现类：
    DefaultFocusManager ， DefaultKeyboardFocusManager ， FocusManager ， KeyboardFocusManager
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface KeyEventPostProcessor
    KeyEventPostProcessor与所有未消耗的KeyEvents的最终分辨率中的当前KeyboardFocusManager配合使用。 在当前的KeyboardFocusManager注册的KeyEventPostProcessors将在KeyEvents被派发到其目标并由其处理后接收KeyEvents。 否则将被丢弃的KeyEvents，因为应用程序当前拥有焦点的组件也将被转发到注册的KeyEventPostProcessors。 这将允许应用程序实现需要全局KeyEvent后处理的功能，如菜单快捷方式。

    请注意，KeyboardFocusManager本身实现了KeyEventPostProcessor。 默认情况下，当前的KeyboardFocusManager将是链中最终的KeyEventPostProcessor。 当前的KeyboardFocusManager不能被完全注销为KeyEventPostProcessor。 但是，如果KeyEventPostProcessor报告不需要对KeyEvent进行进一步的后处理，则AWT将会考虑该事件的完全处理，并且不会对该事件采取任何其他操作。 （虽然客户端代码可以将当前的KeyboardFocusManager注册为KeyEventPostProcessor一次或多次，但这通常是不需要的，不推荐使用。）

    从以下版本开始：
    1.4
    另请参见：
    KeyboardFocusManager.addKeyEventPostProcessor(java.awt.KeyEventPostProcessor) ， KeyboardFocusManager.removeKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean postProcessKeyEvent​(KeyEvent e)
      该方法由当前的KeyboardFocusManager调用，请求该KeyEventPostProcessor执行任何必要的后处理，该后处理应该是KeyEvent的最终解决方案的一部分。

    • 方法详细信息

      • postProcessKeyEvent

        boolean postProcessKeyEvent​(KeyEvent e)
        该方法由当前的KeyboardFocusManager调用，请求该KeyEventPostProcessor执行任何必要的后处理，该后处理应该是KeyEvent的最终解决方案的一部分。 在调用此方法时，通常KeyEvent已经被调度到其目标并由其处理。 但是，如果应用程序中没有组件当前拥有焦点，则KeyEvent尚未分派到任何组件。 通常情况下，KeyEvent后处理将用于实现需要全局KeyEvent后处理的功能，例如菜单快捷方式。 请注意，如果KeyEventPostProcessor希望分派KeyEvent，则它必须使用redispatchEvent来防止AWT递归地请求该KeyEventPostProcessor再次执行事件的后处理。

        如果此方法的实现返回false ，则将KeyEvent传递给链中的下一个KeyEventPostProcessor，以当前的KeyboardFocusManager结尾。 如果一个实现返回true ，则假定KeyEvent已被完全处理（尽管不需要这样），并且AWT将不会对KeyEvent采取进一步的操作。 如果一个实现消耗了KeyEvent但是返回false ，那么消耗的事件仍将被传递给链中的下一个KeyEventPostProcessor。 在执行任何后处理KeyEvent之前，开发人员必须检查KeyEvent是否已被使用。 默认情况下，当前的KeyboardFocusManager将不执行后处理以响应消耗的KeyEvent。

        参数
        e - 后期处理的KeyEvent
        结果
        true如果AWT不应该对KeyEvent采取进一步行动; 否则为false
        另请参见：
        KeyboardFocusManager.redispatchEvent(java.awt.Component, java.awt.AWTEvent)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Label (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Label

  • java.lang.Object
    • java.awt.Component
      • java.awt.Label
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class Label
extends Component
implements Accessible
    Label对象是用于将文本放置在容器中的组件。 标签显示一行只读文本。 文本可以由应用程序更改，但用户无法直接编辑。

    例如，代码。 。 。

     setLayout(new FlowLayout(FlowLayout.CENTER, 10, 10));
 add(new Label("Hi There!"));
 add(new Label("Another Label"));

    生成以下标签：

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Label.AccessibleAWTLabel
      该类为 Label类实现可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CENTER
      表示标签应该居中。
      static int LEFT
      表示标签应该保持对齐。
      static int RIGHT
      表示标签应该是正确的。

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Label​()
      构造一个空标签。
      Label​(String text)
      用指定的文本字符串构造一个新的标签，左对齐。
      Label​(String text, int alignment)
      构造一个新的标签，以指定的对齐方式显示指定的文本字符串。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addNotify​()
      创建此标签的对等体。
      AccessibleContext getAccessibleContext​()
      获取与此Label相关联的AccessibleContext。
      int getAlignment​()
      获取此标签的当前对齐方式。
      String getText​()
      获取此标签的文本。
      protected String paramString​()
      返回一个表示 Label状态的字符串。
      void setAlignment​(int alignment)
      将此标签的对齐方式设置为指定的对齐方式。
      void setText​(String text)
      将此标签的文本设置为指定的文本。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • LEFT

        public static final int LEFT
        表示标签应该保持对齐。
        另请参见：
        Constant Field Values

      • CENTER

        public static final int CENTER
        表示标签应该居中。
        另请参见：
        Constant Field Values

      • RIGHT

        public static final int RIGHT
        表示标签应该是正确的。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Label

        public Label​()
      throws HeadlessException
        构造一个空标签。 标签的文本是空字符串"" 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Label

        public Label​(String text)
      throws HeadlessException
        用指定的文本字符串构造一个新的标签，左对齐。
        参数
        text - 标签显示的字符串。 将接受一个null值，而不会导致抛出NullPointerException。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Label

        public Label​(String text,
             int alignment)
      throws HeadlessException
        构造一个新的标签，以指定的对齐方式显示指定的文本字符串。 可能值alignment是Label.LEFT ， Label.RIGHT ，并Label.CENTER 。
        参数
        text - 标签显示的字符串。 将接受一个null值，而不会导致抛出NullPointerException。
        alignment - 对齐值。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建此标签的对等体。 对等体允许我们修改标签的外观而不改变其功能。
        重写：
        addNotify在 Component
        另请参见：
        Component.isDisplayable() ，
Component.removeNotify() ，
Component.invalidate()

      • getAlignment

        public int getAlignment​()
        获取此标签的当前对齐方式。 可能的值是Label.LEFT ， Label.RIGHT ，并Label.CENTER 。
        结果
        这个标签的对齐
        另请参见：
        setAlignment(int)

      • setAlignment

        public void setAlignment​(int alignment)
        将此标签的对齐方式设置为指定的对齐方式。 可能的值是Label.LEFT ， Label.RIGHT ，并Label.CENTER 。
        参数
        alignment - 要设置的对齐。
        异常
        IllegalArgumentException - 如果给出了 alignment的不正确值。
        另请参见：
        getAlignment()

      • getText

        public String getText​()
        获取此标签的文本。
        结果
        该标签的文本，或 null如果文本已设置为 null 。
        另请参见：
        setText(java.lang.String)

      • setText

        public void setText​(String text)
        将此标签的文本设置为指定的文本。
        参数
        text - 此标签显示的文本。 如果text是null ，则将其视为空字符串""进行显示。
        另请参见：
        getText()

      • paramString

        protected String paramString​()
        返回一个表示Label状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Component
        结果
        该标签的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此Label相关联的AccessibleContext。 对于标签，AccessibleContext采用AccessibleAWTLabel的形式。 如有必要，将创建一个新的AccessibleAWTLabel实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        AccessibleAWTLabel作为此Label的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Label.AccessibleAWTLabel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Label.AccessibleAWTLabel

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Label.AccessibleAWTLabel
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    Enclosing class:
    Label

    protected class Label.AccessibleAWTLabel
extends Component.AccessibleAWTComponent
    该类实现Label类的可访问性支持。 它提供了适用于标记用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleAWTLabel​()
      可访问标签的构造方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getAccessibleName​()
      获取此对象的可访问名称。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTLabel

        public AccessibleAWTLabel​()
        可访问标签的构造方法。

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName​()
        获取此对象的可访问名称。
        重写：
        getAccessibleName在 Component.AccessibleAWTComponent
        结果
        对象的本地化名称 - 如果此对象没有名称，则可以为null
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LayoutManager2 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface LayoutManager2

  • All Superinterfaces:
    LayoutManager
    所有已知实现类：
    BasicSplitPaneUI.BasicHorizontalLayoutManager ， BasicSplitPaneUI.BasicVerticalLayoutManager ， BorderLayout ， BoxLayout ， CardLayout ， DefaultMenuLayout ， GridBagLayout ， GroupLayout ， JRootPane.RootLayout ， OverlayLayout ， SpringLayout

    public interface LayoutManager2
extends LayoutManager
    为知道如何根据布局约束对象布局容器的类定义接口。 该接口扩展了LayoutManager接口，以便在约束对象方面明确处理布局，这些约束对象指定了如何以及组件应该添加到布局中。

    对LayoutManager的这种最小的扩展适用于希望创建基于约束的布局的工具提供者。 它还没有为基于约束的自定义布局管理器提供全面的一般支持。

    另请参见：
    LayoutManager ， Container

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addLayoutComponent​(Component comp, Object constraints)
      使用指定的约束对象将指定的组件添加到布局。
      float getLayoutAlignmentX​(Container target)
      返回沿x轴的对齐方式。
      float getLayoutAlignmentY​(Container target)
      返回沿着y轴的对齐。
      void invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      Dimension maximumLayoutSize​(Container target)
      给定指定容器的最大尺寸尺寸，给定其包含的组件。

      • Methods inherited from interface java.awt.LayoutManager

        addLayoutComponent, layoutContainer, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent

    • 方法详细信息

      • addLayoutComponent

        void addLayoutComponent​(Component comp,
                        Object constraints)
        使用指定的约束对象将指定的组件添加到布局。
        参数
        comp - 要添加的组件
        constraints - 组件如何添加到布局中。

      • maximumLayoutSize

        Dimension maximumLayoutSize​(Container target)
        给定指定容器的最大尺寸尺寸，给定其包含的组件。
        参数
        target - 目标容器
        结果
        容器的最大尺寸
        另请参见：
        Component.getMaximumSize() ， LayoutManager

      • getLayoutAlignmentX

        float getLayoutAlignmentX​(Container target)
        返回沿x轴的对齐方式。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        参数
        target - 目标容器
        结果
        x轴对齐偏好

      • getLayoutAlignmentY

        float getLayoutAlignmentY​(Container target)
        返回沿着y轴的对齐。 这指定了组件如何相对于其他组件进行对齐。 该值应为0到1之间的数字，其中0表示原点对齐，1对齐最远离原点，0.5为中心等。
        参数
        target - 目标容器
        结果
        y轴对齐偏好

      • invalidateLayout

        void invalidateLayout​(Container target)
        使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
        参数
        target - 目标容器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LayoutManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface LayoutManager

  • All Known Subinterfaces:
    LayoutManager2
    所有已知实现类：
    BasicComboBoxUI.ComboBoxLayoutManager ， BasicInternalFrameTitlePane.TitlePaneLayout ， BasicInternalFrameUI.InternalFrameLayout ， BasicOptionPaneUI.ButtonAreaLayout ， BasicScrollBarUI ， BasicSplitPaneDivider.DividerLayout ， BasicSplitPaneUI.BasicHorizontalLayoutManager ， BasicSplitPaneUI.BasicVerticalLayoutManager ， BasicTabbedPaneUI.TabbedPaneLayout ， BorderLayout ， BoxLayout ， CardLayout ， DefaultMenuLayout ， FlowLayout ， GridBagLayout ， GridLayout ， GroupLayout ， JRootPane.RootLayout ， JSpinner.DateEditor ， JSpinner.DefaultEditor ， JSpinner.ListEditor ， JSpinner.NumberEditor ， MetalComboBoxUI.MetalComboBoxLayoutManager ， MetalScrollBarUI ， MetalTabbedPaneUI.TabbedPaneLayout ， OverlayLayout ， ScrollPaneLayout ， ScrollPaneLayout.UIResource ， SpringLayout ， SynthScrollBarUI ， ViewportLayout

    public interface LayoutManager
    定义知道如何布置Container的类的界面。

    秋千的绘画建筑假设一个JComponent的孩子不重叠。 如果一个JComponent的LayoutManager允许孩子重叠，则JComponent必须覆盖isOptimizedDrawingEnabled以返回false。

    另请参见：
    Container ， JComponent.isOptimizedDrawingEnabled()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addLayoutComponent​(String name, Component comp)
      如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与由 name指定的字符串相关联。
      void layoutContainer​(Container parent)
      放出指定的容器。
      Dimension minimumLayoutSize​(Container parent)
      计算指定容器的最小尺寸尺寸，给定其包含的组件。
      Dimension preferredLayoutSize​(Container parent)
      计算指定容器的首选大小尺寸，给定其包含的组件。
      void removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。

    • 方法详细信息

      • addLayoutComponent

        void addLayoutComponent​(String name,
                        Component comp)
        如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与 name指定的字符串相关联。
        参数
        name - 与组件关联的字符串
        comp - 要添加的组件

      • removeLayoutComponent

        void removeLayoutComponent​(Component comp)
        从布局中删除指定的组件。
        参数
        comp - 要删除的组件

      • preferredLayoutSize

        Dimension preferredLayoutSize​(Container parent)
        计算指定容器的首选大小尺寸，给定其包含的组件。
        参数
        parent - 要布置的容器
        结果
        容器的首选尺寸
        另请参见：
        minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        Dimension minimumLayoutSize​(Container parent)
        计算指定容器的最小尺寸尺寸，给定其包含的组件。
        参数
        parent - 要布局的组件
        结果
        容器的最小尺寸
        另请参见：
        preferredLayoutSize(java.awt.Container)

      • layoutContainer

        void layoutContainer​(Container parent)
        放出指定的容器。
        参数
        parent - 要布置的容器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LinearGradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class LinearGradientPaint

  • java.lang.Object
    • java.awt.MultipleGradientPaint
      • java.awt.LinearGradientPaint
  • All Implemented Interfaces:
    Paint ， Transparency

    public final class LinearGradientPaint
extends MultipleGradientPaint
    LinearGradientPaint课程提供了一种用线性颜色渐变模式填充Shape的方法。 用户可以指定两种或多种渐变颜色，并且这种颜色将在每种颜色之间提供插值。 用户还指定了起点和终点，这些点定义了用户空间中颜色渐变应该开始和结束的位置。

    用户必须提供一个浮动数组，指定如何沿渐变分布颜色。 这些值应该在0.0到1.0之间，并且像沿梯度的关键帧一样起作用（它们标记渐变应该是一个特定的颜色）。

    在用户没有将第一关键帧值设置为等于0和/或最后一个关键帧值等于1的情况下，将在这些位置创建关键帧，并且将在那里复制第一个和最后一个颜色。 因此，如果用户指定了以下数组来构造渐变：

      {Color.BLUE, Color.RED}, {.3f, .7f}
    这将被转换为具有以下关键帧的渐变：
      {Color.BLUE, Color.BLUE, Color.RED, Color.RED}, {0f, .3f, .7f, 1f}

    用户还可以通过将CycleMethod设置为REFLECTION或REPEAT来选择LinearGradientPaint对象在填充开始和结束点之外的空间时采取的动作。 渐变的任何反射或重复副本中的任何两种颜色之间的距离与起点和终点之间相同的两种颜色之间的距离相同。 请注意，由于以像素的粒度进行采样，可能会发生距离的一些微小变化。 如果未指定循环方式，默认情况下将选择NO_CYCLE ，这意味着端点颜色将用于填充剩余区域。

    colorSpace参数允许用户指定应在哪个颜色空间执行插值，默认sRGB或线性化RGB。

    以下代码演示了LinearGradientPaint典型用法：

      Point2D start = new Point2D.Float(0, 0);
     Point2D end = new Point2D.Float(50, 50);
     float[] dist = {0.0f, 0.2f, 1.0f};
     Color[] colors = {Color.RED, Color.WHITE, Color.BLUE};
     LinearGradientPaint p =
         new LinearGradientPaint(start, end, dist, colors);

    该代码将创建一个LinearGradientPaint ，其中前20％的梯度在红色和白色之间插值，剩余的80％在白色和蓝色之间插值。

    该图像演示了上述三个循环方法中的每个示例代码：

    从以下版本开始：
    1.6
    另请参见：
    Paint ， Graphics2D.setPaint(java.awt.Paint)

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.MultipleGradientPaint

        MultipleGradientPaint.ColorSpaceType, MultipleGradientPaint.CycleMethod

    • Field Summary

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinearGradientPaint​(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors)
      构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
      LinearGradientPaint​(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 LinearGradientPaint ，具有默认的 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors)
      构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 LinearGradientPaint ，默认为 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 LinearGradientPaint 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PaintContext createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      Point2D getEndPoint​()
      返回渐变轴终点的副本。
      Point2D getStartPoint​()
      返回渐变轴起始点的副本。

      • Methods inherited from class java.awt.MultipleGradientPaint

        getColors, getColorSpace, getCycleMethod, getFractions, getTransform, getTransparency

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LinearGradientPaint

        public LinearGradientPaint​(float startX,
                           float startY,
                           float endX,
                           float endY,
                           float[] fractions,
                           Color[] colors)
        构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
        参数
        startX - 用户空间中梯度轴起始点的X坐标
        startY - 用户空间中梯度轴起始点的Y坐标
        endX - 用户空间中渐变轴终点的X坐标
        endY - 用户空间中梯度轴终点的Y坐标
        fractions - 范围从0.0到1.0的数字，指定渐变颜色的分布
        colors - 对应于每个小数值的颜色数组
        异常
        NullPointerException - 如果 fractions数组为空，或 colors数组为空，
        IllegalArgumentException - 如果起点和终点是相同的点，或 fractions.length != colors.length或 colors大小小于2，或者 fractions值小于0.0或大于1.0，或者 fractions没有以严格的增加顺序提供

      • LinearGradientPaint

        public LinearGradientPaint​(float startX,
                           float startY,
                           float endX,
                           float endY,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
        构造一个 LinearGradientPaint ，默认为 SRGB颜色空间。
        参数
        startX - 用户空间中梯度轴起始点的X坐标
        startY - 用户空间中梯度轴起始点的Y坐标
        endX - 用户空间中渐变轴终点的X坐标
        endY - 用户空间中渐变轴终点的Y坐标
        fractions - 范围从0.0到1.0的数字，指定沿梯度的颜色分布
        colors - 对应于每个小数值的颜色数组
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        异常
        NullPointerException - 如果 fractions数组为空，或 colors数组为空，或 cycleMethod为空
        IllegalArgumentException - 如果起点和终点是相同的点，或 fractions.length != colors.length或 colors大小小于2，或者 fractions值小于0.0或大于1.0，或者 fractions不是以严格增加的顺序提供

      • LinearGradientPaint

        public LinearGradientPaint​(Point2D start,
                           Point2D end,
                           float[] fractions,
                           Color[] colors)
        构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
        参数
        start - 渐变轴启动 Point2D在用户空间
        end - 用户空间中的渐变轴端 Point2D
        fractions - 范围从0.0到1.0的数字，指定沿梯度的颜色分布
        colors - 对应于每个分数值的颜色数组
        异常
        NullPointerException - 如果其中一个点为空，或 fractions数组为空，或 colors数组为空
        IllegalArgumentException - 如果起点和终点是相同的点，或者 fractions.length != colors.length或 colors大小小于2，或者 fractions值小于0.0或大于1.0，或者 fractions不以严格的增加顺序提供

      • LinearGradientPaint

        public LinearGradientPaint​(Point2D start,
                           Point2D end,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
        构造一个 LinearGradientPaint与默认的 SRGB颜色空间。
        参数
        start - 用户空间中的渐变轴启动 Point2D
        end - 用户空间中的渐变轴端 Point2D
        fractions - 范围从0.0到1.0的数字，指定沿梯度的颜色分布
        colors - 与每个分数值对应的颜色数组
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        异常
        NullPointerException - 如果其中一个点为空，或 fractions数组为空，或 colors数组为空，或 cycleMethod为空
        IllegalArgumentException - 如果起点和终点是相同的点，或 fractions.length != colors.length或 colors大小小于2，或者 fractions值小于0.0或大于1.0，或者 fractions不以严格增加的顺序提供

      • LinearGradientPaint

        @ConstructorProperties({"startPoint","endPoint","fractions","colors","cycleMethod","colorSpace","transform"})
public LinearGradientPaint​(Point2D start,
                           Point2D end,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod,
                           MultipleGradientPaint.ColorSpaceType colorSpace,
                           AffineTransform gradientTransform)
        构造一个 LinearGradientPaint 。
        参数
        start - 渐变轴启动 Point2D在用户空间
        end - 用户空间中的渐变轴端 Point2D
        fractions - 范围从0.0到1.0的数字，指定沿梯度的颜色分布
        colors - 对应于每个分数值的颜色数组
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        colorSpace - 用于插值的颜色空间， SRGB或 LINEAR_RGB
        gradientTransform - 转换为应用于渐变
        异常
        NullPointerException - 如果其中一个点为空，或 fractions数组为空，或 colors数组为空，或 cycleMethod为空，或 colorSpace为空，或 gradientTransform为空
        IllegalArgumentException - 如果起点和终点是相同点，或 fractions.length != colors.length或 colors小于2，或者 fractions值小于0.0或大于1.0，或 fractions不以严格增加的顺序提供

    • 方法详细信息

      • createContext

        public PaintContext createContext​(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform transform,
                                  RenderingHints hints)
        创建并返回一个用于生成线性颜色渐变模式的PaintContext 。 见specification方法在Paint界面上的空参数处理信息。
        参数
        cm - 优选的ColorModel ，表示呼叫者接收像素数据的最方便的格式，如果没有偏好，则表示null 。
        deviceBounds - 正在呈现的图形基元的设备空间边界框。
        userBounds - 呈现的图形基元的用户空间边界框。
        transform - 从用户空间到设备空间的AffineTransform 。
        hints - 上下文对象可用于在呈现替代方案之间进行选择的一组提示。
        结果
        用于生成颜色图案的 PaintContext 。
        另请参见：
        Paint ， PaintContext ， ColorModel ， Rectangle ， Rectangle2D ， AffineTransform ， RenderingHints

      • getStartPoint

        public Point2D getStartPoint​()
        返回渐变轴起始点的副本。
        结果
        一个 Point2D对象，这是一个点的副本，锚定这个 LinearGradientPaint的第一个颜色

      • getEndPoint

        public Point2D getEndPoint​()
        返回渐变轴终点的副本。
        结果
        一个 Point2D对象，这是锚点 LinearGradientPaint的最后一个颜色的点的副本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


List (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class List

  • java.lang.Object
    • java.awt.Component
      • java.awt.List
  • All Implemented Interfaces:
    ImageObserver ， ItemSelectable ， MenuContainer ， Serializable ， Accessible

    public class List
extends Component
implements ItemSelectable, Accessible
    List组件向用户显示文本项的滚动列表。 可以设置列表，以便用户可以选择一个项目或多个项目。

    例如，代码。 。 。

     List lst = new List(4, false);
 lst.add("Mercury");
 lst.add("Venus");
 lst.add("Earth");
 lst.add("JavaSoft");
 lst.add("Mars");
 lst.add("Jupiter");
 lst.add("Saturn");
 lst.add("Uranus");
 lst.add("Neptune");
 lst.add("Pluto");
 cnt.add(lst);

    其中cnt是一个容器，生成以下滚动列表：

    如果列表允许多个选择，则单击已选择的项目将取消选择。 在上述示例中，一次只能选择滚动列表中的一个项目，因为创建新滚动列表时的第二个参数是false 。 如果列表不允许多个选择，则选择一个项目将导致任何其他所选项目被取消选择。

    请注意，所示示例中的列表是使用四个可见行创建的。 创建列表后，无法更改可见行数。 创建一个默认的List四行，这样lst = new List()相当于list = new List(4, false) 。

    从Java 1.1开始，抽象窗口工具包会发送List对象上的所有鼠标，键盘和焦点事件。 （旧AWT事件模型仅用于向后兼容性，不鼓励使用）。

    当用户选择或取消选择项目时，AWT会向列表发送一个ItemEvent的实例。 当用户双击滚动列表中的项目时，AWT会在项目事件ActionEvent向列表发送一个ActionEvent的实例。 当选择列表中的项目时，AWT还会生成一个动作事件，当用户按下返回键时。

    如果应用程序想要根据用户选择或激活的此列表中的项目执行某些操作，则应根据需要实现ItemListener或ActionListener ，并注册新的监听器以从该列表接收事件。

    对于多选择滚动列表，它被认为是更好的用户界面来使用外部手势（例如单击按钮）来触发动作。

    从以下版本开始：
    1.0
    另请参见：
    ItemEvent ， ItemListener ， ActionEvent ， ActionListener ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  List.AccessibleAWTList
      该类实现 List类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      List​()
      创建一个新的滚动列表。
      List​(int rows)
      创建一个以指定数量的可见行初始化的新滚动列表。
      List​(int rows, boolean multipleMode)
      创建一个初始化的新滚动列表，以显示指定的行数。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void add​(String item)
      将指定的项目添加到滚动列表的末尾。
      void add​(String item, int index)
      在指定的位置将指定的项目添加到滚动列表。
      void addActionListener​(ActionListener l)
      添加指定的动作侦听器以从此列表接收动作事件。
      void addItem​(String item)
      已过时。
      替换为add(String) 。
      void addItem​(String item, int index)
      已过时。
      替换为add(String, int) 。
      void addItemListener​(ItemListener l)
      添加指定的项目侦听器以从该列表接收项目事件。
      void addNotify​()
      创建列表的对等体。
      boolean allowsMultipleSelections​()
      已过时。
      从JDK 1.1版开始，替换为isMultipleMode() 。
      void clear​()
      已过时。
      从JDK 1.1版开始，替换为removeAll() 。
      int countItems​()
      已过时。
      从JDK 1.1版开始，由getItemCount()替代。
      void delItem​(int position)
      已过时。
      替换为remove(String)和remove(int) 。
      void delItems​(int start, int end)
      已过时。
      从JDK 1.1版开始，未来不会公开使用。 这种方法只能作为一个包私有方法保留。
      void deselect​(int index)
      取消选择指定索引处的项目。
      AccessibleContext getAccessibleContext​()
      获取 AccessibleContext与此 List相关联。
      ActionListener[] getActionListeners​()
      返回在此列表中注册的所有动作侦听器的数组。
      String getItem​(int index)
      获取与指定索引关联的项目。
      int getItemCount​()
      获取列表中的项目数。
      ItemListener[] getItemListeners​()
      返回在此列表中注册的所有项目侦听器的数组。
      String[] getItems​()
      获取列表中的项目。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，这个 List 。
      Dimension getMinimumSize​()
      确定此滚动列表的最小大小。
      Dimension getMinimumSize​(int rows)
      获取具有指定行数的列表的最小尺寸。
      Dimension getPreferredSize​()
      获取此滚动列表的首选大小。
      Dimension getPreferredSize​(int rows)
      获取具有指定行数的列表的首选尺寸。
      int getRows​()
      获取此列表中的可见行数。
      int getSelectedIndex​()
      获取列表中所选项目的索引，
      int[] getSelectedIndexes​()
      获取列表中选定的索引。
      String getSelectedItem​()
      获取此滚动列表中选定的项目。
      String[] getSelectedItems​()
      获取此滚动列表中选定的项目。
      Object[] getSelectedObjects​()
      在对象数组中获取此滚动列表中选定的项目。
      int getVisibleIndex​()
      获取方法 makeVisible上次显示的项目的索引。
      boolean isIndexSelected​(int index)
      确定是否选择了此滚动列表中的指定项目。
      boolean isMultipleMode​()
      确定此列表是否允许多个选择。
      boolean isSelected​(int index)
      已过时。
      从JDK 1.1版开始，由isIndexSelected(int)替换。
      void makeVisible​(int index)
      使指定索引处的项目可见。
      Dimension minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      Dimension minimumSize​(int rows)
      已过时。
      从JDK 1.1版开始，替换为getMinimumSize(int) 。
      protected String paramString​()
      返回表示此滚动列表状态的参数字符串。
      Dimension preferredSize​()
      已过时。
      从JDK 1.1版开始，替换为getPreferredSize() 。
      Dimension preferredSize​(int rows)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int)替代。
      protected void processActionEvent​(ActionEvent e)
      通过将这些事件发送到任何注册的 ActionListener对象来处理在此组件上发生的操作事件。
      protected void processEvent​(AWTEvent e)
      在此滚动列表中处理事件。
      protected void processItemEvent​(ItemEvent e)
      通过将其发送到任何已注册的 ItemListener对象来处理在此列表上发生的项目事件。
      void remove​(int position)
      从此滚动列表中移除指定位置的项目。
      void remove​(String item)
      从列表中删除项目的第一次出现。
      void removeActionListener​(ActionListener l)
      删除指定的动作侦听器，使其不再从此列表中接收到动作事件。
      void removeAll​()
      从此列表中删除所有项目。
      void removeItemListener​(ItemListener l)
      删除指定的项目监听器，使其不再从此列表中接收项目事件。
      void removeNotify​()
      删除此列表的对等体。
      void replaceItem​(String newValue, int index)
      使用新的字符串替换滚动列表中指定索引处的项目。
      void select​(int index)
      在滚动列表中选择指定索引处的项目。
      void setMultipleMode​(boolean b)
      设置确定此列表是否允许多个选择的标志。
      void setMultipleSelections​(boolean b)
      已过时。
      自JDK 1.1版起，由setMultipleMode(boolean)替代。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • List

        public List​()
     throws HeadlessException
        创建一个新的滚动列表。 默认情况下，有四条可见行，不允许多个选择。 请注意，这是一个方便的方法List(0, false) 。 另请注意，列表中的可见行数在创建后不能更改。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • List

        public List​(int rows)
     throws HeadlessException
        创建一个以指定数量的可见行初始化的新滚动列表。 默认情况下，不允许多个选择。 请注意，这是一个方便的方法List(rows, false) 。 还要注意，列表中可见行的数量在创建后不能更改。
        参数
        rows - 要显示的项目数。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

      • List

        public List​(int rows,
            boolean multipleMode)
     throws HeadlessException
        创建一个初始化的新滚动列表，以显示指定的行数。 请注意，如果指定了零行，则将创建列表，其默认值为四行。 还要注意，列表中可见行的数量在创建后不能更改。 如果multipleMode值为true ，则用户可以从列表中选择多个项目。 如果是false ，则false只能选择一个项目。
        参数
        rows - 要显示的项目数。
        multipleMode - 如果是true ，则允许多个选择; 否则，一次只能选择一个项目。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建列表的对等体。 对等体允许我们修改列表的外观而不改变它的功能。
        重写：
        addNotify在 Component
        另请参见：
        Component.isDisplayable() ，
Component.removeNotify() ，
Component.invalidate()

      • removeNotify

        public void removeNotify​()
        删除此列表的对等体。 对等体允许我们修改列表的外观而不改变它的功能。
        重写：
        removeNotify在 Component
        另请参见：
        Component.isDisplayable() ， Component.addNotify()

      • getItemCount

        public int getItemCount​()
        获取列表中的项目数。
        结果
        列表中的项目数
        从以下版本开始：
        1.1
        另请参见：
        getItem(int)

      • countItems

        @Deprecated
public int countItems​()
        已过时。 从JDK 1.1版开始，由getItemCount()替代。
        返回列表中的项目数。
        结果
        列表中的项目数

      • getItem

        public String getItem​(int index)
        获取与指定索引关联的项目。
        参数
        index - 项目的位置
        结果
        与指定索引相关联的项目
        另请参见：
        getItemCount()

      • getItems

        public String[] getItems​()
        获取列表中的项目。
        结果
        一个包含列表项的字符串数组
        从以下版本开始：
        1.1
        另请参见：
        select(int) ， deselect(int) ， isIndexSelected(int)

      • add

        public void add​(String item)
        将指定的项目添加到滚动列表的末尾。
        参数
        item - 要添加的项目
        从以下版本开始：
        1.1

      • addItem

        @Deprecated
public void addItem​(String item)
        已过时。 替换为add(String) 。
        将指定的项目添加到列表的末尾。
        参数
        item - 要添加的项目

      • add

        public void add​(String item,
                int index)
        在指定的位置将指定的项目添加到滚动列表。 索引为零。 如果索引的值小于零，或者如果索引的值大于或等于列表中的项目数，则将项添加到列表的末尾。
        参数
        item - 要添加的项目; 如果此参数为null则该项目被视为空字符串， ""
        index - 添加项目的位置
        从以下版本开始：
        1.1

      • addItem

        @Deprecated
public void addItem​(String item,
                    int index)
        已过时。 替换为add(String, int) 。
        在索引指示的位置将指定的项目添加到列表中。
        参数
        item - 要添加的项目
        index - 添加项目的位置

      • replaceItem

        public void replaceItem​(String newValue,
                        int index)
        使用新的字符串替换滚动列表中指定索引处的项目。
        参数
        newValue - 用于替换现有项目的新字符串
        index - 要更换的项目的位置
        异常
        ArrayIndexOutOfBoundsException - 如果 index超出范围

      • removeAll

        public void removeAll​()
        从此列表中删除所有项目。
        从以下版本开始：
        1.1
        另请参见：
        remove(java.lang.String) ， delItems(int, int)

      • clear

        @Deprecated
public void clear​()
        已过时。 从JDK 1.1版开始，替换为removeAll() 。

      • remove

        public void remove​(String item)
        从列表中删除项目的第一次出现。 如果选择了指定的项目，并且是列表中唯一选择的项目，列表将被设置为没有选择。
        参数
        item - 要从列表中删除的项目
        异常
        IllegalArgumentException - 如果项目不存在于列表中
        从以下版本开始：
        1.1

      • remove

        public void remove​(int position)
        从此滚动列表中移除指定位置的项目。 如果选择了具有指定位置的项目，并且是列表中唯一选择的项目，列表将被设置为不选择。
        参数
        position - 要删除的项目的索引
        异常
        ArrayIndexOutOfBoundsException - 如果 position小于0或大于 getItemCount()-1
        从以下版本开始：
        1.1
        另请参见：
        add(String, int)

      • delItem

        @Deprecated
public void delItem​(int position)
        已过时。 替换为remove(String)和remove(int) 。
        删除指定位置的项目。
        参数
        position - 要删除的项目的索引

      • getSelectedIndex

        public int getSelectedIndex​()
        获取列表中所选项目的索引，
        结果
        所选项目的索引; 如果没有选择项目，或者如果选择了多个项目，则返回-1 。
        另请参见：
        select(int) ， deselect(int) ， isIndexSelected(int)

      • getSelectedIndexes

        public int[] getSelectedIndexes​()
        获取列表中选定的索引。
        结果
        该滚动列表中所选索引的数组; 如果未选择任何项目，则返回零长度数组。
        另请参见：
        select(int) ， deselect(int) ， isIndexSelected(int)

      • getSelectedItem

        public String getSelectedItem​()
        获取此滚动列表中选定的项目。
        结果
        列表中选定的项目; 如果没有选择项目，或者如果选择了多个项目，则返回null 。
        另请参见：
        select(int) ， deselect(int) ， isIndexSelected(int)

      • getSelectedItems

        public String[] getSelectedItems​()
        获取此滚动列表中选定的项目。
        结果
        该滚动列表中所选项目的数组; 如果未选择任何项目，则返回零长度数组。
        另请参见：
        select(int) ， deselect(int) ， isIndexSelected(int)

      • getSelectedObjects

        public Object[] getSelectedObjects​()
        在对象数组中获取此滚动列表中选定的项目。
        Specified by:
        getSelectedObjects在接口 ItemSelectable
        结果
        表示此滚动列表上所选项目的数组Object s; 如果未选择任何项目，则返回零长度数组。
        另请参见：
        getSelectedItems() ， ItemSelectable

      • select

        public void select​(int index)
        在滚动列表中选择指定索引处的项目。

        请注意，超出范围参数无效，将导致未指定的行为。

        请注意，此方法应主要用于初始选择此组件中的项目。 以编程方式调用此方法不会触发ItemEvent 。 触发ItemEvent的唯一方法是通过用户交互。

        参数
        index - 要选择的项目的位置
        另请参见：
        getSelectedItem() ， deselect(int) ， isIndexSelected(int)

      • deselect

        public void deselect​(int index)
        取消选择指定索引处的项目。

        请注意，超出范围参数无效，将导致未指定的行为。

        如果未选择指定索引处的项目，则忽略该操作。

        参数
        index - 要取消选择的项目的位置
        另请参见：
        select(int) ， getSelectedItem() ， isIndexSelected(int)

      • isIndexSelected

        public boolean isIndexSelected​(int index)
        确定是否选择了此滚动列表中的指定项目。
        参数
        index - 要检查的项目
        结果
        true如果指定的项目已被选中; false否则
        从以下版本开始：
        1.1
        另请参见：
        select(int) ， deselect(int)

      • isSelected

        @Deprecated
public boolean isSelected​(int index)
        已过时。 从JDK 1.1版开始，由isIndexSelected(int)替代。
        确定列表中指定的项是否被选中。
        参数
        index - 指定要检查的项目
        结果
        true如果选择该项目; 否则false

      • getRows

        public int getRows​()
        获取此列表中的可见行数。 注意，一旦创建了这个List ，这个数字就永远不会改变。
        结果
        此滚动列表中的可见行数

      • isMultipleMode

        public boolean isMultipleMode​()
        确定此列表是否允许多个选择。
        结果
        true如果此列表允许多个选择; 否则， false
        从以下版本开始：
        1.1
        另请参见：
        setMultipleMode(boolean)

      • allowsMultipleSelections

        @Deprecated
public boolean allowsMultipleSelections​()
        已过时。 从JDK 1.1版开始，由isMultipleMode()替代。
        确定此列表是否允许多个选择。
        结果
        true如果此列表允许多个选择; 否则false

      • setMultipleMode

        public void setMultipleMode​(boolean b)
        设置确定此列表是否允许多个选择的标志。 当选择模式从多选择更改为单选时，所选项目将如下更改：如果所选项目具有位置光标，则只会选择该项目。 如果没有选定的项目具有位置光标，则所有项目将被取消选择。
        参数
        b - 如果true则允许多个选择; 否则，只能从列表中选择一个项目
        从以下版本开始：
        1.1
        另请参见：
        isMultipleMode()

      • setMultipleSelections

        @Deprecated
public void setMultipleSelections​(boolean b)
        已过时。 从JDK 1.1版开始，由setMultipleMode(boolean)替代。
        启用或禁用此列表的多选模式。
        参数
        b - true启用多模式，否则为 false

      • getVisibleIndex

        public int getVisibleIndex​()
        获取方法 makeVisible上次显示的项目的索引。
        结果
        上次显示的项目的索引
        另请参见：
        makeVisible(int)

      • makeVisible

        public void makeVisible​(int index)
        使指定索引处的项目可见。
        参数
        index - 项目的位置
        另请参见：
        getVisibleIndex()

      • getPreferredSize

        public Dimension getPreferredSize​(int rows)
        获取具有指定行数的列表的首选尺寸。
        参数
        rows - 列表中的行数
        结果
        给定指定行数必须可见的显示此滚动列表的首选尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getPreferredSize()

      • preferredSize

        @Deprecated
public Dimension preferredSize​(int rows)
        已过时。 从JDK 1.1版开始，替换为getPreferredSize(int) 。
        返回此组件的首选大小，假设它具有指定的行数。
        参数
        rows - 行数
        结果
        用于显示此列表的首选尺寸

      • getPreferredSize

        public Dimension getPreferredSize​()
        获取此滚动列表的首选大小。
        重写：
        getPreferredSize在 Component
        结果
        用于显示此滚动列表的首选尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getPreferredSize()

      • preferredSize

        @Deprecated
public Dimension preferredSize​()
        已过时。 自JDK 1.1版起，由getPreferredSize()取代。
        描述从类别复制： Component
        返回组件的首选大小。
        重写：
        preferredSize在 Component
        结果
        该组件的首选尺寸

      • getMinimumSize

        public Dimension getMinimumSize​(int rows)
        获取具有指定行数的列表的最小尺寸。
        参数
        rows - 列表中的行数
        结果
        给定指定行数必须可见的显示此滚动列表的最小尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getMinimumSize()

      • minimumSize

        @Deprecated
public Dimension minimumSize​(int rows)
        已过时。 从JDK 1.1版开始，由getMinimumSize(int)替代。
        返回具有指定行数的列表的最小尺寸。
        参数
        rows - 列表中的行数
        结果
        显示此列表的最小尺寸

      • getMinimumSize

        public Dimension getMinimumSize​()
        确定此滚动列表的最小大小。
        重写：
        getMinimumSize在 Component
        结果
        显示此滚动列表所需的最小尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getMinimumSize()

      • minimumSize

        @Deprecated
public Dimension minimumSize​()
        已过时。 从JDK 1.1版开始，替换为getMinimumSize() 。
        描述从类复制： Component
        返回此组件的最小大小。
        重写：
        minimumSize在 Component
        结果
        该组件的最小尺寸

      • addItemListener

        public void addItemListener​(ItemListener l)
        添加指定的项目侦听器以从该列表接收项目事件。 项目事件是响应于用户输入发送的，但不响应对select或deselect调用。 如果监听器l为null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        addItemListener在接口 ItemSelectable
        参数
        l - 项目监听器
        从以下版本开始：
        1.1
        另请参见：
        removeItemListener(java.awt.event.ItemListener) ， getItemListeners() ， select(int) ， deselect(int) ， ItemEvent ， ItemListener

      • removeItemListener

        public void removeItemListener​(ItemListener l)
        删除指定的项目监听器，使其不再从此列表中接收项目事件。 如果监听器l为null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        removeItemListener在接口 ItemSelectable
        参数
        l - 项目监听器
        从以下版本开始：
        1.1
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， getItemListeners() ， ItemEvent ， ItemListener

      • getItemListeners

        public ItemListener[] getItemListeners​()
        返回在此列表中注册的所有项目侦听器的数组。
        结果
        所有这个列表的 ItemListener s或一个空数组，如果没有项目监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addItemListener(java.awt.event.ItemListener) ， removeItemListener(java.awt.event.ItemListener) ， ItemEvent ， ItemListener

      • addActionListener

        public void addActionListener​(ActionListener l)
        添加指定的动作侦听器以从此列表接收动作事件。 当用户双击列表项时，会发生动作事件，或者当列表具有键盘焦点时，键入Enter。

        如果监听器l为null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器
        从以下版本开始：
        1.1
        另请参见：
        removeActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionEvent ， ActionListener

      • removeActionListener

        public void removeActionListener​(ActionListener l)
        删除指定的动作侦听器，使其不再从此列表中接收到动作事件。 当用户双击列表项时，会发生操作事件。 如果监听器l为null ，则不会抛出异常并且不执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器
        从以下版本开始：
        1.1
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionEvent ， ActionListener

      • getActionListeners

        public ActionListener[] getActionListeners​()
        返回在此列表中注册的所有动作侦听器的数组。
        结果
        所有这个列表的 ActionListener s或一个空数组，如果没有动作侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， removeActionListener(java.awt.event.ActionListener) ， ActionEvent ， ActionListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回此List当前注册为FooListener的所有对象的数组。 FooListener使用addFooListener方法注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询List l其项监听器：

          ItemListener[] ils = (ItemListener[])(l.getListeners(ItemListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在 Component
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此列表中注册为 FooListener的所有对象的数组，如果没有添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType未指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getItemListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        在此滚动列表中处理事件。 如果一个事件是一个ItemEvent的实例，它将调用processItemEvent方法。 否则，如果事件是ActionEvent一个实例，它将调用processActionEvent 。 如果事件不是项目事件或动作事件，它将在超类上调用processEvent 。

        请注意，如果事件参数是null ，行为是未指定的，可能会导致异常。

        重写：
        processEvent在 Component
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        ActionEvent ， ItemEvent ， processActionEvent(java.awt.event.ActionEvent) ， processItemEvent(java.awt.event.ItemEvent)

      • processItemEvent

        protected void processItemEvent​(ItemEvent e)
        通过将其发送到任何已注册的ItemListener对象来处理在此列表上发生的项目事件。

        除非为此组件启用项目事件，否则不会调用此方法。 当以下情况发生时，项目事件被启用：

        • 一个ItemListener对象通过addItemListener注册。
        • 项目事件通过enableEvents启用。

        请注意，如果事件参数为null该行为是未指定的，可能会导致异常。

        参数
        e - 项目事件
        从以下版本开始：
        1.1
        另请参见：
        ItemEvent ， ItemListener ， addItemListener(java.awt.event.ItemListener) ， Component.enableEvents(long)

      • processActionEvent

        protected void processActionEvent​(ActionEvent e)
        通过将此组件发送到任何已注册的ActionListener对象来处理此组件上发生的操作事件。

        除非为此组件启用了操作事件，否则不会调用此方法。 当发生以下情况之一时，启用操作事件：

        • 通过addActionListener注册一个ActionListener对象。
        • 操作事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 动作事件
        从以下版本开始：
        1.1
        另请参见：
        ActionEvent ， ActionListener ， addActionListener(java.awt.event.ActionListener) ， Component.enableEvents(long)

      • paramString

        protected String paramString​()
        返回表示此滚动列表状态的参数字符串。 此字符串对于调试很有用。
        重写：
        paramString在 Component
        结果
        该滚动列表的参数字符串

      • delItems

        @Deprecated
public void delItems​(int start,
                     int end)
        已过时。 从JDK 1.1版开始，未来不会公开使用。 这种方法只能作为一个包私有方法保留。
        删除指定索引范围内的列表项。
        参数
        start - 要删除的范围的开始索引
        end - 要删除的范围的结束索引

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取AccessibleContext与此List相关联。 对于名单中， AccessibleContext需要一个形式AccessibleAWTList 。 如果需要，将创建一个新的AccessibleAWTList实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个 AccessibleAWTList ，作为 AccessibleContext的这个 List
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


List.AccessibleAWTList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class List.AccessibleAWTList

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.List.AccessibleAWTList
  • All Implemented Interfaces:
    ActionListener ， ItemListener ， Serializable ， EventListener ， AccessibleComponent ， AccessibleSelection
    Enclosing class:
    List

    protected class List.AccessibleAWTList
extends Component.AccessibleAWTComponent
implements AccessibleSelection, ItemListener, ActionListener
    该类为List类实现可访问性支持。 它提供了适用于列出用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  List.AccessibleAWTList.AccessibleAWTListChild
      此类实现对List子项的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleAWTList​()
      构造新的 AccessibleAWTList

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void actionPerformed​(ActionEvent event)
      发生动作时调用。
      void addAccessibleSelection​(int i)
      将对象中指定的选定项目添加到对象的选择中。
      void clearAccessibleSelection​()
      清除对象中的选择，以便选择对象中的任何内容。
      Accessible getAccessibleAt​(Point p)
      返回包含在本地坐标Point（如果存在）的Accessible子项。
      Accessible getAccessibleChild​(int i)
      返回对象的第n个可访问子对象。
      int getAccessibleChildrenCount​()
      返回对象中可访问的子项数。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleSelection getAccessibleSelection​()
      获取与此对象关联的AccessibleSelection。
      Accessible getAccessibleSelection​(int i)
      返回表示对象中指定的选定项的Accessible。
      int getAccessibleSelectionCount​()
      返回当前选择的项目数。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态集。
      boolean isAccessibleChildSelected​(int i)
      如果选择此对象的当前子级，则返回true。
      void itemStateChanged​(ItemEvent event)
      当用户选择或取消选择项目时调用。
      void removeAccessibleSelection​(int i)
      从对象的选择中删除对象中指定的选定项目。
      void selectAllAccessibleSelection​()
      如果对象支持多个选择，则导致要选择的对象中的每个选定项目。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTList

        public AccessibleAWTList​()
        构造新的 AccessibleAWTList

    • 方法详细信息

      • actionPerformed

        public void actionPerformed​(ActionEvent event)
        描述从接口ActionListener复制
        发生动作时调用。
        Specified by:
        actionPerformed在接口 ActionListener
        参数
        event - 要处理的事件

      • itemStateChanged

        public void itemStateChanged​(ItemEvent event)
        说明从界面ItemListener复制
        当用户选择或取消选择项目时调用。 为此方法编写的代码执行在选择（或取消选择）项目时需要进行的操作。
        Specified by:
        itemStateChanged在接口 ItemListener
        参数
        event - 要处理的事件

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态集。
        重写：
        getAccessibleStateSet在 Component.AccessibleAWTComponent
        结果
        AccessibleState的一个实例包含对象的当前状态
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleAt

        public Accessible getAccessibleAt​(Point p)
        返回包含在本地坐标Point（如果存在）的Accessible子项。
        Specified by:
        getAccessibleAt在接口 AccessibleComponent
        重写：
        getAccessibleAt在 Component.AccessibleAWTComponent
        参数
        p -定义的左上角点 Accessible ，在对象的父对象的坐标空间中给出
        结果
        在指定位置的可访问（如果存在）

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount​()
        返回对象中可访问的子项数。 如果这个对象的所有子项都实现了Accessible，那么这个方法应该返回这个对象的子代数。
        重写：
        getAccessibleChildrenCount在 Component.AccessibleAWTComponent
        结果
        对象中可访问的孩子的数量。

      • getAccessibleChild

        public Accessible getAccessibleChild​(int i)
        返回对象的第n个可访问子对象。
        重写：
        getAccessibleChild的 Component.AccessibleAWTComponent
        参数
        i - 基于零的儿童索引
        结果
        对象的第n个可访问子对象
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection​()
        获取与此对象关联的AccessibleSelection。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleSelection接口。
        重写：
        getAccessibleSelection在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleSelection

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount​()
        返回当前选择的项目数。 如果没有选择任何项目，返回值将为0。
        Specified by:
        getAccessibleSelectionCount在接口 AccessibleSelection
        结果
        当前选择的项目数。

      • getAccessibleSelection

        public Accessible getAccessibleSelection​(int i)
        返回表示对象中指定的选定项的Accessible。 如果没有选择，或者比传入的整数选择的项目少，返回值将为空。
        Specified by:
        getAccessibleSelection在接口 AccessibleSelection
        参数
        i - 所选项目的从零开始的索引
        结果
        包含所选项的Accessible
        另请参见：
        AccessibleSelection.getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected​(int i)
        如果选择此对象的当前子级，则返回true。
        Specified by:
        isAccessibleChildSelected在接口 AccessibleSelection
        参数
        i - 此可访问对象 i的从零开始的索引。
        结果
        true如果选择了该对象的当前子对象; 其他false
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection​(int i)
        将对象中指定的选定项目添加到对象的选择中。 如果对象支持多个选择，则将指定的项目添加到任何现有的选择中，否则将替换对象中的任何现有选择。 如果指定的项目已被选中，则该方法无效。
        Specified by:
        addAccessibleSelection在接口 AccessibleSelection
        参数
        i - 可选项目的从零开始的索引
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection​(int i)
        从对象的选择中删除对象中指定的选定项目。 如果当前未选择指定的项目，则此方法无效。
        Specified by:
        removeAccessibleSelection在接口 AccessibleSelection
        参数
        i - 可选项目的从零开始的索引
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection​()
        清除对象中的选择，以便选择对象中的任何内容。
        Specified by:
        clearAccessibleSelection在接口 AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection​()
        如果对象支持多个选择，则导致要选择的对象中的每个选定项目。
        Specified by:
        selectAllAccessibleSelection在接口 AccessibleSelection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


List.AccessibleAWTList.AccessibleAWTListChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class List.AccessibleAWTList.AccessibleAWTListChild

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.List.AccessibleAWTList.AccessibleAWTListChild
  • All Implemented Interfaces:
    Serializable ， Accessible ， AccessibleComponent
    Enclosing class:
    List.AccessibleAWTList

    protected class List.AccessibleAWTList.AccessibleAWTListChild
extends Component.AccessibleAWTComponent
implements Accessible
    此类实现对List子项的可访问性支持。 它提供了适用于列出儿童用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleAWTListChild​(List parent, int indexInParent)
      构造新的 AccessibleAWTListChild与父 List的给定父母 List和0对象的索引。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      boolean contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      Accessible getAccessibleAt​(Point p)
      返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
      Accessible getAccessibleChild​(int i)
      返回对象的指定Accessible子对象。
      int getAccessibleChildrenCount​()
      返回对象的可访问子对象的数量。
      AccessibleContext getAccessibleContext​()
      获取此对象的AccessibleContext。
      int getAccessibleIndexInParent​()
      在其可访问的父项中获取此对象的基于0的索引。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态集。
      Color getBackground​()
      获取此对象的背景颜色。
      Rectangle getBounds​()
      以Rectangle对象的形式获取此对象的边界。
      Cursor getCursor​()
      获取此对象的Cursor。
      Font getFont​()
      获取此对象的字体。
      FontMetrics getFontMetrics​(Font f)
      获取此对象的FontMetrics。
      Color getForeground​()
      获取此对象的前景色。
      Locale getLocale​()
      获取组件的区域设置。
      Point getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Dimension getSize​()
      以Dimension对象的形式返回此对象的大小。
      boolean isEnabled​()
      确定对象是否已启用。
      boolean isFocusTraversable​()
      返回此对象是否可以接受焦点。
      boolean isShowing​()
      确定对象是否显示。
      boolean isVisible​()
      确定对象是否可见。
      void removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void requestFocus​()
      请求关注此对象。
      void setBackground​(Color c)
      设置此对象的背景颜色。
      void setBounds​(Rectangle r)
      以Rectangle对象的形式设置此对象的边界。
      void setCursor​(Cursor cursor)
      设置此对象的Cursor。
      void setEnabled​(boolean b)
      设置对象的已启用状态。
      void setFont​(Font f)
      设置此对象的Font。
      void setForeground​(Color c)
      设置此对象的前景色。
      void setLocation​(Point p)
      设置对象相对于父对象的位置。
      void setSize​(Dimension d)
      调整此对象的大小，使其具有宽度和高度。
      void setVisible​(boolean b)
      设置对象的可见状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addPropertyChangeListener, getAccessibleComponent, getAccessibleDescription, getAccessibleName, getAccessibleParent, removePropertyChangeListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTListChild

        public AccessibleAWTListChild​(List parent,
                              int indexInParent)
        构造新的 AccessibleAWTListChild与父 List的给定父母 List和0对象的索引。
        参数
        parent - 母公司 List
        indexInParent - 父项中的索引

    • 方法详细信息

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取此对象的AccessibleContext。 在该类的Java Accessibility API的实现中，返回此对象，该对象充当其自己的AccessibleContext。
        Specified by:
        getAccessibleContext在接口 Accessible
        结果
        这个对象

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态集。 对象的AccessibleStateSet由一组唯一的AccessibleState组成。 对象的AccessibleStateSet中的更改将导致为ACCESSIBLE_STATE_PROPERTY属性触发一个PropertyChangeEvent。
        重写：
        getAccessibleStateSet在 Component.AccessibleAWTComponent
        结果
        包含对象的当前状态集的AccessibleStateSet实例
        另请参见：
        AccessibleStateSet ， AccessibleState ， Component.AccessibleAWTComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getLocale

        public Locale getLocale​()
        获取组件的区域设置。 如果组件没有区域设置，则返回其父项的区域设置。
        重写：
        getLocale在 Component.AccessibleAWTComponent
        结果
        该组件的区域设置。 如果此组件没有区域设置，则返回其父项的区域设置。
        异常
        IllegalComponentStateException - 如果组件没有自己的区域设置，并且尚未添加到包含层次结构中，以便可以从包含的父项确定区域设置。

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent​()
        在其可访问的父项中获取此对象的基于0的索引。
        重写：
        getAccessibleIndexInParent在 Component.AccessibleAWTComponent
        结果
        该对象在其父项中的基于0的索引; -1如果此对象没有可访问的父对象。
        另请参见：
        Component.AccessibleAWTComponent.getAccessibleParent() ，
getAccessibleChildrenCount() ，
getAccessibleChild(int)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount​()
        返回对象的可访问子对象的数量。
        重写：
        getAccessibleChildrenCount在 Component.AccessibleAWTComponent
        结果
        对象的可访问子的数量。

      • getAccessibleChild

        public Accessible getAccessibleChild​(int i)
        返回对象的指定Accessible子对象。 Accessible对象的Accessible子项为零，所以Accessible子项的第一个子项的索引为0，第二个子项为索引1，依此类推。
        重写：
        getAccessibleChild在 Component.AccessibleAWTComponent
        参数
        i - 基于零的儿童索引
        结果
        对象的Accessible子对象
        另请参见：
        getAccessibleChildrenCount()

      • getBackground

        public Color getBackground​()
        获取此对象的背景颜色。
        Specified by:
        getBackground在接口 AccessibleComponent
        重写：
        getBackground在 Component.AccessibleAWTComponent
        结果
        对象的背景颜色（如果支持）; 否则为null
        另请参见：
        setBackground(java.awt.Color)

      • setBackground

        public void setBackground​(Color c)
        设置此对象的背景颜色。
        Specified by:
        setBackground在接口 AccessibleComponent
        重写：
        setBackground在 Component.AccessibleAWTComponent
        参数
        c - 新的背景颜色
        另请参见：
        setBackground(java.awt.Color)

      • getForeground

        public Color getForeground​()
        获取此对象的前景色。
        Specified by:
        getForeground接口 AccessibleComponent
        重写：
        getForeground在 Component.AccessibleAWTComponent
        结果
        对象的前景颜色（如果支持）; 否则为null
        另请参见：
        setForeground(java.awt.Color)

      • setForeground

        public void setForeground​(Color c)
        设置此对象的前景色。
        Specified by:
        setForeground在接口 AccessibleComponent
        重写：
        setForeground在 Component.AccessibleAWTComponent
        参数
        c - 前景的新颜色
        另请参见：
        getForeground()

      • getCursor

        public Cursor getCursor​()
        获取此对象的Cursor。
        Specified by:
        getCursor在接口 AccessibleComponent
        重写：
        getCursor在 Component.AccessibleAWTComponent
        结果
        如果支持该对象的光标; 否则为null
        另请参见：
        setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor​(Cursor cursor)
        设置此对象的Cursor。

        如果Java平台实现和/或本地系统不支持更改鼠标光标的形状，该方法可能没有视觉效果。

        Specified by:
        setCursor接口 AccessibleComponent
        重写：
        setCursor在 Component.AccessibleAWTComponent
        参数
        cursor - 对象的新Cursor
        另请参见：
        getCursor()

      • getFont

        public Font getFont​()
        获取此对象的字体。
        Specified by:
        getFont接口 AccessibleComponent
        重写：
        getFont在 Component.AccessibleAWTComponent
        结果
        如果支持该对象，则为Font; 否则为null
        另请参见：
        setFont(java.awt.Font)

      • setFont

        public void setFont​(Font f)
        设置此对象的Font。
        Specified by:
        setFont在接口 AccessibleComponent
        重写：
        setFont在 Component.AccessibleAWTComponent
        参数
        f - 对象的新字体
        另请参见：
        getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics​(Font f)
        获取此对象的FontMetrics。
        Specified by:
        getFontMetrics在接口 AccessibleComponent
        重写：
        getFontMetrics在 Component.AccessibleAWTComponent
        参数
        f - 字体
        结果
        FontMetrics，如果支持，该对象; 否则为null
        另请参见：
        getFont()

      • isEnabled

        public boolean isEnabled​()
        确定对象是否已启用。 启用的对象也将在AccessibleStateSet中设置AccessibleState.ENABLED状态。
        Specified by:
        isEnabled在接口 AccessibleComponent
        重写：
        isEnabled在 Component.AccessibleAWTComponent
        结果
        如果对象启用，则为true; 否则，假
        另请参见：
        setEnabled(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.ENABLED ， AccessibleStateSet

      • setEnabled

        public void setEnabled​(boolean b)
        设置对象的已启用状态。
        Specified by:
        setEnabled在接口 AccessibleComponent
        重写：
        setEnabled在 Component.AccessibleAWTComponent
        参数
        b - 如果为true，则启用此对象; 否则，禁用它
        另请参见：
        isEnabled()

      • isVisible

        public boolean isVisible​()
        确定对象是否可见。 注意：这意味着该对象意图可见; 然而，它可能不会显示在屏幕上，因为该对象包含的对象之一当前不可见。 要确定对象是否在屏幕上显示，请使用isShowing（）。

        可见的对象也将在其AccessibleStateSet中设置AccessibleState.VISIBLE状态。

        Specified by:
        isVisible在接口 AccessibleComponent
        重写：
        isVisible在 Component.AccessibleAWTComponent
        结果
        如果对象可见，则为true; 否则，假
        另请参见：
        setVisible(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.VISIBLE ， AccessibleStateSet

      • setVisible

        public void setVisible​(boolean b)
        设置对象的可见状态。
        Specified by:
        setVisible在接口 AccessibleComponent
        重写：
        setVisible在 Component.AccessibleAWTComponent
        参数
        b - 如果为true，则显示此对象; 否则隐藏它
        另请参见：
        isVisible()

      • isShowing

        public boolean isShowing​()
        确定对象是否显示。 这是通过检查对象的可见性和对象祖先的可见性来确定的。 注意：即使对象被另一个对象遮蔽（例如，对象被放在一个被拉下的菜单下面），这将返回true。
        Specified by:
        isShowing在接口 AccessibleComponent
        重写：
        isShowing在 Component.AccessibleAWTComponent
        结果
        如果对象显示，则为true; 否则，假

      • contains

        public boolean contains​(Point p)
        检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
        Specified by:
        contains在接口 AccessibleComponent
        重写：
        contains在 Component.AccessibleAWTComponent
        参数
        p - 相对于对象坐标系的点
        结果
        如果对象包含Point，则为true; 否则为虚假
        另请参见：
        getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen​()
        返回对象在屏幕上的位置。
        Specified by:
        getLocationOnScreen在接口 AccessibleComponent
        重写：
        getLocationOnScreen在 Component.AccessibleAWTComponent
        结果
        屏幕上物体的位置; 如果此对象不在屏幕上，则为null
        另请参见：
        getBounds() ， getLocation()

      • getLocation

        public Point getLocation​()
        以指定对象的左上角的点的形式获取对象相对于父对象的位置。
        Specified by:
        getLocation在接口 AccessibleComponent
        重写：
        getLocation在 Component.AccessibleAWTComponent
        结果
        Point的一个实例代表屏幕坐标空间中对象边界的左上角; 如果此对象或其父对象不在屏幕上，则为null
        另请参见：
        getBounds() ， getLocationOnScreen()

      • setLocation

        public void setLocation​(Point p)
        设置对象相对于父对象的位置。
        Specified by:
        setLocation在接口 AccessibleComponent
        重写：
        setLocation在 Component.AccessibleAWTComponent
        参数
        p - 左上角的新位置
        另请参见：
        getLocation()

      • getBounds

        public Rectangle getBounds​()
        以Rectangle对象的形式获取此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        Specified by:
        getBounds在接口 AccessibleComponent
        重写：
        getBounds中的 Component.AccessibleAWTComponent
        结果
        表示该组件边界的矩形; 如果此对象不在屏幕上，则为null。
        另请参见：
        contains(java.awt.Point)

      • setBounds

        public void setBounds​(Rectangle r)
        以Rectangle对象的形式设置此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        Specified by:
        setBounds在接口 AccessibleComponent
        重写：
        setBounds在 Component.AccessibleAWTComponent
        参数
        r - 表示此组件边界的矩形
        另请参见：
        getBounds()

      • getSize

        public Dimension getSize​()
        以Dimension对象的形式返回此对象的大小。 Dimension对象的height域包含此对象的高度，Dimension对象的width字段包含该对象的宽度。
        Specified by:
        getSize在接口 AccessibleComponent
        重写：
        getSize在 Component.AccessibleAWTComponent
        结果
        一个Dimension对象，指示该组件的大小; 如果此对象不在屏幕上，则为null
        另请参见：
        setSize(java.awt.Dimension)

      • setSize

        public void setSize​(Dimension d)
        调整此对象的大小，使其具有宽度和高度。
        Specified by:
        setSize在接口 AccessibleComponent
        重写：
        setSize中的 Component.AccessibleAWTComponent
        参数
        d - - 指定对象的新大小的维度。
        另请参见：
        getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt​(Point p)
        返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
        Specified by:
        getAccessibleAt在接口 AccessibleComponent
        重写：
        getAccessibleAt在 Component.AccessibleAWTComponent
        参数
        p - 相对于该对象的坐标系的点
        结果
        Accessible ，如果存在，在指定的位置; 否则null

      • isFocusTraversable

        public boolean isFocusTraversable​()
        返回此对象是否可以接受焦点。 可以接受焦点的对象也将在其AccessibleStateSet设置AccessibleState.FOCUSABLE状态。
        Specified by:
        isFocusTraversable在接口 AccessibleComponent
        重写：
        isFocusTraversable在 Component.AccessibleAWTComponent
        结果
        true如果对象可以接受焦点; 否则为虚假
        另请参见：
        AccessibleContext.getAccessibleStateSet() ， AccessibleState.FOCUSABLE ， AccessibleState.FOCUSED ， AccessibleStateSet

      • requestFocus

        public void requestFocus​()
        请求关注此对象。 如果此对象无法接受焦点，则不会发生任何事情。 否则，对象将尝试重点。
        Specified by:
        requestFocus在接口 AccessibleComponent
        重写：
        requestFocus在 Component.AccessibleAWTComponent
        另请参见：
        isFocusTraversable()

      • addFocusListener

        public void addFocusListener​(FocusListener l)
        新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
        Specified by:
        addFocusListener在接口 AccessibleComponent
        重写：
        addFocusListener在 Component.AccessibleAWTComponent
        参数
        l - 焦点侦听器
        另请参见：
        removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener​(FocusListener l)
        删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
        Specified by:
        removeFocusListener在接口 AccessibleComponent
        重写：
        removeFocusListener在 Component.AccessibleAWTComponent
        参数
        l - 焦点侦听器
        另请参见：
        addFocusListener(java.awt.event.FocusListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MediaTracker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MediaTracker

  • java.lang.Object
    • java.awt.MediaTracker
  • All Implemented Interfaces:
    Serializable

    public class MediaTracker
extends Object
implements Serializable
    MediaTracker类是一个实用程序类，用于跟踪多个媒体对象的状态。 媒体对象可以包括音频剪辑以及图像，但是目前只支持图像。

    要使用媒体跟踪器，请创建MediaTracker的实例，并为要跟踪的每个图像调用其addImage方法。 此外，每个图像可以被分配唯一的标识符。 该标识符控制获取图像的优先级顺序。 它还可以用于识别可独立等待的图像的唯一子集。 具有较低ID的图像优先于具有较高ID号的那些加载。

    跟踪动画图像可能不总是有用的，因为动画图像加载和绘画的多部分性质，但它是受支持的。 MediaTracker将第一帧完全加载时，将动画图像视为完全加载。 在这一点上， MediaTracker表示图像完全加载的任何服务员。 如果没有ImageObserver在第一帧加载完成时观察图像，图像可能会自动刷新以节省资源（请参阅Image.flush() ）。

    以下是使用MediaTracker的示例：

 import java.applet.Applet;
 import java.awt.Color;
 import java.awt.Image;
 import java.awt.Graphics;
 import java.awt.MediaTracker;

 public class ImageBlaster extends Applet implements Runnable {
      MediaTracker tracker;
      Image bg;
      Image anim[] = new Image[5];
      int index;
      Thread animator;

      // Get the images for the background (id == 0)
      // and the animation frames (id == 1)
      // and add them to the MediaTracker
      public void init() {
          tracker = new MediaTracker(this);
          bg = getImage(getDocumentBase(),
                  "images/background.gif");
          tracker.addImage(bg, 0);
          for (int i = 0; i < 5; i++) {
              anim[i] = getImage(getDocumentBase(),
                      "images/anim"+i+".gif");
              tracker.addImage(anim[i], 1);
          }
      }

      // Start the animation thread.
      public void start() {
          animator = new Thread(this);
          animator.start();
      }

      // Stop the animation thread.
      public void stop() {
          animator = null;
      }

      // Run the animation thread.
      // First wait for the background image to fully load
      // and paint.  Then wait for all of the animation
      // frames to finish loading. Finally, loop and
      // increment the animation frame index.
      public void run() {
          try {
              tracker.waitForID(0);
              tracker.waitForID(1);
          } catch (InterruptedException e) {
              return;
          }
          Thread me = Thread.currentThread();
          while (animator == me) {
              try {
                  Thread.sleep(100);
              } catch (InterruptedException e) {
                  break;
              }
              synchronized (this) {
                  index++;
                  if (index >= anim.length) {
                      index = 0;
                  }
              }
              repaint();
          }
      }

      // The background image fills the frame so we
      // don't need to clear the applet on repaints.
      // Just call the paint method.
      public void update(Graphics g) {
          paint(g);
      }

      // Paint a large red rectangle if there are any errors
      // loading the images.  Otherwise always paint the
      // background so that it appears incrementally as it
      // is loading.  Finally, only paint the current animation
      // frame if all of the frames (id == 1) are done loading,
      // so that we don't get partial animations.
      public void paint(Graphics g) {
          if ((tracker.statusAll(false) & MediaTracker.ERRORED) != 0) {
              g.setColor(Color.red);
              g.fillRect(0, 0, size().width, size().height);
              return;
          }
          g.drawImage(bg, 0, 0, this);
          if (tracker.statusID(1, false) == MediaTracker.COMPLETE) {
              g.drawImage(anim[index], 10, 10, this);
          }
      }
 }
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ABORTED
      表示媒体的下载中止了。
      static int COMPLETE
      表示媒体下载成功的标志。
      static int ERRORED
      表示媒体的下载遇到错误的标志。
      static int LOADING
      指示媒体当前正在加载的标志。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MediaTracker​(Component comp)
      创建媒体跟踪器以跟踪给定组件的图像。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addImage​(Image image, int id)
      将图像添加到此媒体跟踪器跟踪的图像列表中。
      void addImage​(Image image, int id, int w, int h)
      将缩放图像添加到此媒体跟踪器跟踪的图像列表中。
      boolean checkAll​()
      检查此媒体跟踪器跟踪的所有图像是否已完成加载。
      boolean checkAll​(boolean load)
      检查此媒体跟踪器跟踪的所有图像是否已完成加载。
      boolean checkID​(int id)
      检查由该媒体跟踪器跟踪的所有标记有指定标识符的图像是否已完成加载。
      boolean checkID​(int id, boolean load)
      检查由该媒体跟踪器跟踪的所有标记有指定标识符的图像是否已完成加载。
      Object[] getErrorsAny​()
      返回遇到错误的所有介质的列表。
      Object[] getErrorsID​(int id)
      返回具有遇到错误的指定ID的介质列表。
      boolean isErrorAny​()
      检查所有图像的错误状态。
      boolean isErrorID​(int id)
      检查具有指定标识符的此媒体跟踪器跟踪的所有图像的错误状态。
      void removeImage​(Image image)
      从此媒体跟踪器中删除指定的图像。
      void removeImage​(Image image, int id)
      从该媒体跟踪器的指定跟踪ID中删除指定的图像。
      void removeImage​(Image image, int id, int width, int height)
      从此媒体跟踪器中删除指定的宽度，高度和ID的指定图像。
      int statusAll​(boolean load)
      计算并返回此媒体跟踪器跟踪的所有媒体状态的按位包含 OR 。
      int statusID​(int id, boolean load)
      使用该媒体跟踪器跟踪的指定标识符计算并返回所有媒体状态的按位包含 OR 。
      void waitForAll​()
      开始加载此媒体跟踪器跟踪的所有图像。
      boolean waitForAll​(long ms)
      开始加载此媒体跟踪器跟踪的所有图像。
      void waitForID​(int id)
      开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。
      boolean waitForID​(int id, long ms)
      开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LOADING

        public static final int LOADING
        指示媒体当前正在加载的标志。
        另请参见：
        statusAll(boolean) ， statusID(int, boolean) ， Constant Field Values

      • ABORTED

        public static final int ABORTED
        表示媒体的下载中止了。
        另请参见：
        statusAll(boolean) ， statusID(int, boolean) ， Constant Field Values

      • ERRORED

        public static final int ERRORED
        表示媒体的下载遇到错误的标志。
        另请参见：
        statusAll(boolean) ， statusID(int, boolean) ， Constant Field Values

      • COMPLETE

        public static final int COMPLETE
        表示媒体下载成功的标志。
        另请参见：
        statusAll(boolean) ， statusID(int, boolean) ， Constant Field Values

    • 构造方法详细信息

      • MediaTracker

        public MediaTracker​(Component comp)
        创建媒体跟踪器以跟踪给定组件的图像。
        参数
        comp - 最终将绘制图像的组件

    • 方法详细信息

      • addImage

        public void addImage​(Image image,
                     int id)
        将图像添加到此媒体跟踪器跟踪的图像列表中。 图像最终将以默认（未缩放）大小显示。
        参数
        image - 要跟踪的图像
        id - 用于跟踪此图像的标识符

      • addImage

        public void addImage​(Image image,
                     int id,
                     int w,
                     int h)
        将缩放图像添加到此媒体跟踪器跟踪的图像列表中。 图像最终将以指定的宽度和高度呈现。
        参数
        image - 要跟踪的图像
        id - 可用于跟踪此图像的标识符
        w - 渲染图像的宽度
        h - 渲染图像的高度

      • checkAll

        public boolean checkAll​()
        检查此媒体跟踪器跟踪的所有图像是否已完成加载。

        如果图像尚未加载，则此方法不会启动加载。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用isErrorAny或isErrorID方法检查错误。

        结果
        true如果所有图像已完成加载，已中止或遇到错误; 否则为false
        另请参见：
        checkAll(boolean) ， checkID(int) ， isErrorAny() ， isErrorID(int)

      • checkAll

        public boolean checkAll​(boolean load)
        检查此媒体跟踪器跟踪的所有图像是否已完成加载。

        如果load标志的值为true ，则此方法将开始加载任何尚未加载的映像。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用isErrorAny和isErrorID方法检查错误。

        参数
        load - 如果是 true ，开始加载任何尚未加载的图像
        结果
        true如果所有图像已完成加载，已中止或遇到错误; 否则为false
        另请参见：
        checkID(int) ，
checkAll() ，
isErrorAny() ，
isErrorID(int)

      • isErrorAny

        public boolean isErrorAny​()
        检查所有图像的错误状态。
        结果
        true如果此媒体跟踪器跟踪的任何图像在加载期间有错误; false否则
        另请参见：
        isErrorID(int) ， getErrorsAny()

      • getErrorsAny

        public Object[] getErrorsAny​()
        返回遇到错误的所有介质的列表。
        结果
        此媒体跟踪器跟踪的媒体对象数组遇到错误，如果没有错误， null
        另请参见：
        isErrorAny() ， getErrorsID(int)

      • waitForAll

        public void waitForAll​()
                throws InterruptedException
        开始加载此媒体跟踪器跟踪的所有图像。 该方法等待直到所有被跟踪的图像都完成加载。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用isErrorAny或isErrorID方法检查错误。

        异常
        InterruptedException - 如果任何线程已经中断了这个线程
        另请参见：
        waitForID(int) ， waitForAll(long) ， isErrorAny() ， isErrorID(int)

      • waitForAll

        public boolean waitForAll​(long ms)
                   throws InterruptedException
        开始加载此媒体跟踪器跟踪的所有图像。 该方法等待直到所有正在被跟踪的图像已经完成加载，或者直到由ms参数指定的时间长度以毫秒为单位。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用isErrorAny或isErrorID方法检查错误。

        参数
        ms - 等待加载完成的毫秒数
        结果
        true如果所有图像都成功加载; 否则为false
        异常
        InterruptedException - 如果任何线程中断了此线程。
        另请参见：
        waitForID(int) ， waitForAll(long) ， isErrorAny() ， isErrorID(int)

      • statusAll

        public int statusAll​(boolean load)
        计算并返回此媒体跟踪器跟踪的所有媒体状态的按位包含OR 。

        由定义的可能标志MediaTracker类是LOADING ， ABORTED ， ERRORED ，并COMPLETE 。 尚未开始加载的图像的状态为零。

        如果load值为true ，则此方法将开始加载任何尚未加载的图像。

        参数
        load - 如果是 true ，开始加载任何尚未加载的图像
        结果
        追踪所有媒体状态的按位包容性 OR
        另请参见：
        statusID(int, boolean) ， LOADING ， ABORTED ， ERRORED ， COMPLETE

      • checkID

        public boolean checkID​(int id)
        检查由该媒体跟踪器跟踪的所有标记有指定标识符的图像是否已完成加载。

        如果图像尚未加载，则此方法不会启动加载。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用isErrorAny或isErrorID方法检查错误。

        参数
        id - 要检查的图像的标识符
        结果
        true如果所有图像已完成加载，已中止或遇到错误; false否则
        另请参见：
        checkID(int, boolean) ，
checkAll() ，
isErrorAny() ，
isErrorID(int)

      • checkID

        public boolean checkID​(int id,
                       boolean load)
        检查由该媒体跟踪器跟踪的所有标记有指定标识符的图像是否已完成加载。

        如果load标志的值为true ，则此方法将开始加载任何尚未加载的映像。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用isErrorAny或isErrorID方法检查错误。

        参数
        id - 要检查的图像的标识符
        load - 如果是 true ，开始加载任何尚未加载的图像
        结果
        true如果所有图像已完成加载，已中止或遇到错误; false否则
        另请参见：
        checkID(int, boolean) ，
checkAll() ，
isErrorAny() ，
isErrorID(int)

      • isErrorID

        public boolean isErrorID​(int id)
        检查具有指定标识符的此媒体跟踪器跟踪的所有图像的错误状态。
        参数
        id - 要检查的图像的标识符
        结果
        true如果具有指定标识符的任何图像在加载期间有错误; 否则为false
        另请参见：
        isErrorAny() ， getErrorsID(int)

      • getErrorsID

        public Object[] getErrorsID​(int id)
        返回具有遇到错误的指定ID的介质列表。
        参数
        id - 要检查的图像的标识符
        结果
        由具有指定的标识符遇到错误的媒体跟踪器跟踪的媒体对象数组，如果没有错误 null
        另请参见：
        isErrorID(int) ， isErrorAny() ， getErrorsAny()

      • waitForID

        public void waitForID​(int id)
               throws InterruptedException
        开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。 该方法等待直到具有指定标识符的所有图像已完成加载。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用isErrorAny和isErrorID方法检查错误。

        参数
        id - 要检查的图像的标识符
        异常
        InterruptedException - 如果任何线程中断了此线程。
        另请参见：
        waitForAll() ，
isErrorAny() ，
isErrorID(int)

      • waitForID

        public boolean waitForID​(int id,
                         long ms)
                  throws InterruptedException
        开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。 此方法等待直到具有指定标识符的所有映像已完成加载，或者直到ms参数以毫秒为单位指定的时间长度已过。

        如果在加载或缩放图像时出现错误，则该图像被认为已经完成加载。 使用statusID ， isErrorID ，并isErrorAny方法来检查错误。

        参数
        id - 要检查的图像的标识符
        ms - 等待加载完成的时间长度（以毫秒为单位）
        结果
        true如果装载完成时间; 否则为false
        异常
        InterruptedException - 如果任何线程中断了此线程。
        另请参见：
        waitForAll() ，
waitForID(int) ，
statusID(int, boolean) ，
isErrorAny() ，
isErrorID(int)

      • statusID

        public int statusID​(int id,
                    boolean load)
        使用该媒体跟踪器跟踪的指定标识符计算并返回所有媒体状态的按位包含OR 。

        由定义的可能标志MediaTracker类是LOADING ， ABORTED ， ERRORED ，并COMPLETE 。 尚未开始加载的图像的状态为零。

        如果load值为true ，则此方法将开始加载任何尚未加载的图像。

        参数
        id - 要检查的图像的标识符
        load - 如果是 true ，开始加载任何尚未加载的图像
        结果
        具有指定标识符的所有媒体的状态的按位包含 OR
        另请参见：
        statusAll(boolean) ， LOADING ， ABORTED ， ERRORED ， COMPLETE

      • removeImage

        public void removeImage​(Image image)
        从此媒体跟踪器中删除指定的图像。 指定图像的所有实例都将被删除，而不考虑比例或ID。
        参数
        image - 要删除的图像
        从以下版本开始：
        1.1
        另请参见：
        removeImage(java.awt.Image, int) ， removeImage(java.awt.Image, int, int, int)

      • removeImage

        public void removeImage​(Image image,
                        int id)
        从该媒体跟踪器的指定跟踪ID中删除指定的图像。 不论规模大小，都会删除在指定ID下跟踪的所有Image实例。
        参数
        image - 要删除的图像
        id - 从中删除图像的跟踪ID
        从以下版本开始：
        1.1
        另请参见：
        removeImage(java.awt.Image) ， removeImage(java.awt.Image, int, int, int)

      • removeImage

        public void removeImage​(Image image,
                        int id,
                        int width,
                        int height)
        从此媒体跟踪器中删除指定的宽度，高度和ID的指定图像。 只有指定的实例（有任何重复项）被删除。
        参数
        image - 要删除的图像
        id - 从中删除图像的跟踪ID
        width - 要移除的宽度（对于unscaled为-1）
        height - 要移除的高度（对于unscaled为-1）
        从以下版本开始：
        1.1
        另请参见：
        removeImage(java.awt.Image) ， removeImage(java.awt.Image, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Menu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Menu

  • java.lang.Object
    • java.awt.MenuComponent
      • java.awt.MenuItem
        • java.awt.Menu
  • All Implemented Interfaces:
    MenuContainer ， Serializable ， Accessible
    已知直接子类：
    PopupMenu

    public class Menu
extends MenuItem
implements MenuContainer, Accessible
    Menu对象是从菜单栏部署的下拉菜单组件。

    菜单可以选择是撕下菜单。 可以打开撕纸菜单并将其从父菜单栏或菜单中拖出。 鼠标按钮释放后仍保留在屏幕上。 拆卸菜单的机制是平台依赖的，因为撕下菜单的外观和感觉是由其对等方确定的。 在不支持拆除菜单的平台上，撕除属性将被忽略。

    菜单中的每个项目都必须属于MenuItem类。 它可以是一个MenuItem的实例，一个子菜单（一个实例Menu ）或一个复选框（一个CheckboxMenuItem的实例）。

    从以下版本开始：
    1.0
    另请参见：
    MenuItem ， CheckboxMenuItem ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。

      • Nested classes/interfaces inherited from class java.awt.MenuComponent

        MenuComponent.AccessibleAWTMenuComponent

      • Nested classes/interfaces inherited from class java.awt.MenuItem

        MenuItem.AccessibleAWTMenuItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      Menu​()
      构造一个带有空标签的新菜单。
      Menu​(String label)
      构造一个带有指定标签的新菜单。
      Menu​(String label, boolean tearOff)
      构造具有指定标签的新菜单，指示菜单是否可以被拆除。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      MenuItem add​(MenuItem mi)
      将指定的菜单项添加到此菜单。
      void add​(String label)
      将具有指定标签的项目添加到此菜单。
      void addNotify​()
      创建菜单的对等体。
      void addSeparator​()
      在当前位置的菜单中添加分隔线或连字符。
      int countItems​()
      已过时。
      从JDK 1.1版开始，由getItemCount()替代。
      AccessibleContext getAccessibleContext​()
      获取与此菜单关联的AccessibleContext。
      MenuItem getItem​(int index)
      获取位于此菜单的指定索引处的项目。
      int getItemCount​()
      获取此菜单中的项目数量。
      void insert​(MenuItem menuitem, int index)
      在指定位置的菜单中插入菜单项。
      void insert​(String label, int index)
      在指定位置的菜单中插入带有指定标签的菜单项。
      void insertSeparator​(int index)
      在指定位置插入分隔符。
      boolean isTearOff​()
      指示此菜单是否为撕纸菜单。
      String paramString​()
      返回一个表示 Menu状态的字符串。
      void remove​(int index)
      从此菜单中删除指定索引处的菜单项。
      void remove​(MenuComponent item)
      从此菜单中删除指定的菜单项。
      void removeAll​()
      从此菜单中删除所有项目。
      void removeNotify​()
      删除菜单的对等体。

      • Methods inherited from class java.awt.MenuComponent

        dispatchEvent, getFont, getName, getParent, getTreeLock, postEvent, setFont, setName, toString

      • Methods inherited from interface java.awt.MenuContainer

        getFont, postEvent

      • Methods inherited from class java.awt.MenuItem

        addActionListener, deleteShortcut, disable, disableEvents, enable, enable, enableEvents, getActionCommand, getActionListeners, getLabel, getListeners, getShortcut, isEnabled, processActionEvent, processEvent, removeActionListener, setActionCommand, setEnabled, setLabel, setShortcut

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Menu

        public Menu​()
     throws HeadlessException
        构造一个带有空标签的新菜单。 此菜单不是撕纸菜单。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Menu

        public Menu​(String label)
     throws HeadlessException
        构造一个带有指定标签的新菜单。 此菜单不是撕纸菜单。
        参数
        label - 菜单栏中的菜单标签，或在其他菜单中，此菜单是子菜单。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Menu

        public Menu​(String label,
            boolean tearOff)
     throws HeadlessException
        构造具有指定标签的新菜单，指示菜单是否可以被拆除。

        AWT的所有实现可能不支持撕除功能。 如果某个特定的实现不支持撕下菜单，则该值将被忽略。

        参数
        label - 菜单栏中的菜单标签，或在其他菜单中，此菜单是子菜单。
        tearOff - 如果是 true ，菜单是撕下菜单。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建菜单的对等体。 对等体允许我们修改菜单的外观而不改变其功能。
        重写：
        addNotify在 MenuItem

      • removeNotify

        public void removeNotify​()
        删除菜单的对等体。 对等体允许我们修改菜单的外观而不改变其功能。
        重写：
        removeNotify在 MenuComponent

      • isTearOff

        public boolean isTearOff​()
        指示此菜单是否为撕纸菜单。

        AWT的所有实现可能不支持撕除功能。 如果某个特定的实现不支持撕下菜单，则该值将被忽略。

        结果
        true如果这是一个撕下菜单; 否则为false 。

      • getItemCount

        public int getItemCount​()
        获取此菜单中的项目数量。
        结果
        此菜单中的项目数
        从以下版本开始：
        1.1

      • countItems

        @Deprecated
public int countItems​()
        已过时。 从JDK 1.1版开始，由getItemCount()替代。
        返回此菜单中的项目数。
        结果
        此菜单中的项目数

      • getItem

        public MenuItem getItem​(int index)
        获取位于此菜单的指定索引处的项目。
        参数
        index - 要返回的项目的位置。
        结果
        位于指定索引处的项目。

      • add

        public MenuItem add​(MenuItem mi)
        将指定的菜单项添加到此菜单。 如果菜单项已经是另一个菜单的一部分，则从该菜单中删除它。
        参数
        mi - 要添加的菜单项
        结果
        菜单项添加
        另请参见：
        insert(java.lang.String, int) ， insert(java.awt.MenuItem, int)

      • add

        public void add​(String label)
        将具有指定标签的项目添加到此菜单。
        参数
        label - 该项目上的文字
        另请参见：
        insert(java.lang.String, int) ， insert(java.awt.MenuItem, int)

      • insert

        public void insert​(MenuItem menuitem,
                   int index)
        在指定位置的菜单中插入菜单项。
        参数
        menuitem - 要插入的菜单项。
        index - 要插入菜单项的位置。
        异常
        IllegalArgumentException -如果值 index小于零
        从以下版本开始：
        1.1
        另请参见：
        add(java.lang.String) ， add(java.awt.MenuItem)

      • insert

        public void insert​(String label,
                   int index)
        在指定位置的菜单中插入带有指定标签的菜单项。 这是一个方便的方法insert(menuItem, index) 。
        参数
        label - 该项目的文本
        index - 要插入菜单项的位置
        异常
        IllegalArgumentException -如果值 index小于零
        从以下版本开始：
        1.1
        另请参见：
        add(java.lang.String) ， add(java.awt.MenuItem)

      • addSeparator

        public void addSeparator​()
        在当前位置的菜单中添加分隔线或连字符。
        另请参见：
        insertSeparator(int)

      • insertSeparator

        public void insertSeparator​(int index)
        在指定位置插入分隔符。
        参数
        index - 应插入菜单分隔符的位置。
        异常
        IllegalArgumentException -如果值 index小于0。
        从以下版本开始：
        1.1
        另请参见：
        addSeparator()

      • remove

        public void remove​(int index)
        从此菜单中删除指定索引处的菜单项。
        参数
        index - 要删除的项目的位置。

      • remove

        public void remove​(MenuComponent item)
        从此菜单中删除指定的菜单项。
        Specified by:
        remove在接口 MenuContainer
        参数
        item - 从菜单中删除的项目。 如果item是null或者不在这个菜单中，这个方法什么都不做。

      • removeAll

        public void removeAll​()
        从此菜单中删除所有项目。
        从以下版本开始：
        1.1

      • paramString

        public String paramString​()
        返回表示Menu的状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 MenuItem
        结果
        该菜单的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此菜单关联的AccessibleContext。 对于菜单，AccessibleContext采用AccessibleAWTMenu的形式。 如有必要，将创建一个新的AccessibleAWTMenu实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 MenuItem
        结果
        一个AccessibleAWTMenu，用作此菜单的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Menu.AccessibleAWTMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Menu.AccessibleAWTMenu

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.MenuComponent.AccessibleAWTMenuComponent
        • java.awt.MenuItem.AccessibleAWTMenuItem
          • java.awt.Menu.AccessibleAWTMenu
  • All Implemented Interfaces:
    Serializable ， AccessibleAction ， AccessibleComponent ， AccessibleSelection ， AccessibleValue
    已知直接子类：
    PopupMenu.AccessibleAWTPopupMenu
    Enclosing class:
    Menu

    protected class Menu.AccessibleAWTMenu
extends MenuItem.AccessibleAWTMenuItem
    菜单的内部类用于提供对辅助功能的默认支持。 这个类不是由应用程序开发人员直接使用的，而是意味着仅由菜单组件开发人员进行子类化。

    该类实现Menu类的可访问性支持。 它提供了适用于菜单用户界面元素的Java Accessibility API的实现。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTMenu​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.MenuComponent.AccessibleAWTMenuComponent

        addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.MenuItem.AccessibleAWTMenuItem

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleName, getAccessibleValue, getCurrentAccessibleValue, getMaximumAccessibleValue, getMinimumAccessibleValue, setCurrentAccessibleValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTMenu

        protected AccessibleAWTMenu​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 MenuItem.AccessibleAWTMenuItem
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MenuBar

  • java.lang.Object
    • java.awt.MenuComponent
      • java.awt.MenuBar
  • All Implemented Interfaces:
    MenuContainer ， Serializable ， Accessible

    public class MenuBar
extends MenuComponent
implements MenuContainer, Accessible
    MenuBar类封装了平台与框架绑定的菜单栏的概念。 为了将菜单栏与Frame对象相关联，请调用框架的setMenuBar方法。

    菜单栏可能是这样的：

    菜单栏处理菜单项的键盘快捷键，将其传递到其子菜单。 （可选的键盘快捷键为用户提供了一个替代鼠标来调用菜单项以及与之相关联的操作。）每个菜单项可以维护一个MenuShortcut的实例。 MenuBar类定义了几个方法， shortcuts()和getShortcutMenuItem(java.awt.MenuShortcut) ，它们检索有关给定菜单栏正在管理的快捷方式的信息。

    从以下版本开始：
    1.0
    另请参见：
    Frame ， Frame.setMenuBar(java.awt.MenuBar) ， Menu ， MenuItem ， MenuShortcut ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  MenuBar.AccessibleAWTMenuBar
      MenuBar的内部类用于为辅助功能提供默认支持。

      • Nested classes/interfaces inherited from class java.awt.MenuComponent

        MenuComponent.AccessibleAWTMenuComponent

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuBar​()
      创建一个新的菜单栏。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Menu add​(Menu m)
      将指定的菜单添加到菜单栏。
      void addNotify​()
      创建菜单栏的对等体。
      int countMenus​()
      已过时。
      从JDK 1.1版开始，由getMenuCount()替代。
      void deleteShortcut​(MenuShortcut s)
      删除指定的菜单快捷方式。
      AccessibleContext getAccessibleContext​()
      获取与此MenuBar关联的AccessibleContext。
      Menu getHelpMenu​()
      获取菜单栏上的帮助菜单。
      Menu getMenu​(int i)
      获取指定的菜单。
      int getMenuCount​()
      获取菜单栏上的菜单数量。
      MenuItem getShortcutMenuItem​(MenuShortcut s)
      获取的实例 MenuItem与指定相关 MenuShortcut的对象，或者 null如果被管理没有菜单项的通过该菜单栏与指定的菜单快捷方式有关。
      void remove​(int index)
      从此菜单栏中删除位于指定索引处的菜单。
      void remove​(MenuComponent m)
      从此菜单栏中删除指定的菜单组件。
      void removeNotify​()
      删除菜单栏的对等体。
      void setHelpMenu​(Menu m)
      将指定的菜单设置为此菜单栏的帮助菜单。
      Enumeration<MenuShortcut> shortcuts​()
      获取此菜单栏正在管理的所有菜单快捷方式的枚举。

      • Methods inherited from class java.awt.MenuComponent

        dispatchEvent, getFont, getName, getParent, getTreeLock, paramString, postEvent, processEvent, setFont, setName, toString

      • Methods inherited from interface java.awt.MenuContainer

        getFont, postEvent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MenuBar

        public MenuBar​()
        throws HeadlessException
        创建一个新的菜单栏。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建菜单栏的对等体。 对等体允许我们改变菜单栏的外观，而不改变任何菜单栏的功能。

      • removeNotify

        public void removeNotify​()
        删除菜单栏的对等体。 对等体允许我们改变菜单栏的外观，而不改变任何菜单栏的功能。
        重写：
        removeNotify在 MenuComponent

      • getHelpMenu

        public Menu getHelpMenu​()
        获取菜单栏上的帮助菜单。
        结果
        此菜单栏上的帮助菜单。

      • setHelpMenu

        public void setHelpMenu​(Menu m)
        将指定的菜单设置为此菜单栏的帮助菜单。 如果此菜单栏有一个现有的帮助菜单，旧的帮助菜单将从菜单栏中删除，并替换为指定的菜单。
        参数
        m - 要设置为帮助菜单的菜单

      • add

        public Menu add​(Menu m)
        将指定的菜单添加到菜单栏。 如果菜单已经是另一个菜单栏的一部分，请从该菜单栏中删除它。
        参数
        m - 要添加的菜单
        结果
        添加菜单
        另请参见：
        remove(int) ， remove(java.awt.MenuComponent)

      • remove

        public void remove​(int index)
        从此菜单栏中删除位于指定索引处的菜单。
        参数
        index - 要删除的菜单的位置。
        另请参见：
        add(java.awt.Menu)

      • remove

        public void remove​(MenuComponent m)
        从此菜单栏中删除指定的菜单组件。
        Specified by:
        remove在接口 MenuContainer
        参数
        m - 要删除的菜单组件。
        另请参见：
        add(java.awt.Menu)

      • getMenuCount

        public int getMenuCount​()
        获取菜单栏上的菜单数量。
        结果
        菜单栏上的菜单数量。
        从以下版本开始：
        1.1

      • countMenus

        @Deprecated
public int countMenus​()
        已过时。 从JDK 1.1版开始，由getMenuCount()替换。
        获取菜单栏上的菜单数量。
        结果
        菜单栏上的菜单数量。

      • getMenu

        public Menu getMenu​(int i)
        获取指定的菜单。
        参数
        i - 要返回的菜单的索引位置。
        结果
        在此菜单栏的指定索引处的菜单。

      • shortcuts

        public Enumeration<MenuShortcut> shortcuts​()
        获取此菜单栏正在管理的所有菜单快捷方式的枚举。
        结果
        列出此菜单栏正在管理的菜单快捷方式。
        从以下版本开始：
        1.1
        另请参见：
        MenuShortcut

      • getShortcutMenuItem

        public MenuItem getShortcutMenuItem​(MenuShortcut s)
        获取的实例 MenuItem与指定相关 MenuShortcut的对象，或者 null如果被管理没有菜单项的通过该菜单栏与指定的菜单快捷方式有关。
        参数
        s - 指定的菜单快捷方式。
        结果
        指定快捷方式的菜单项。
        从以下版本开始：
        1.1
        另请参见：
        MenuItem ， MenuShortcut

      • deleteShortcut

        public void deleteShortcut​(MenuShortcut s)
        删除指定的菜单快捷方式。
        参数
        s - 要删除的菜单快捷方式。
        从以下版本开始：
        1.1

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此MenuBar关联的AccessibleContext。 对于菜单栏，AccessibleContext采用AccessibleAWTMenuBar的形式。 如有必要，将创建一个新的AccessibleAWTMenuBar实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 MenuComponent
        结果
        一个AccessibleAWTMenuBar，作为该MenuBar的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuBar.AccessibleAWTMenuBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MenuBar.AccessibleAWTMenuBar

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.MenuComponent.AccessibleAWTMenuComponent
        • java.awt.MenuBar.AccessibleAWTMenuBar
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent ， AccessibleSelection
    Enclosing class:
    MenuBar

    protected class MenuBar.AccessibleAWTMenuBar
extends MenuComponent.AccessibleAWTMenuComponent
    MenuBar的内部类用于为辅助功能提供默认支持。 这个类不是由应用程序开发人员直接使用的，而是意味着仅由菜单组件开发人员进行子类化。

    该类实现MenuBar类的可访问性支持。 它提供了适用于菜单栏用户界面元素的Java Accessibility API的实现。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTMenuBar​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.MenuComponent.AccessibleAWTMenuComponent

        addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTMenuBar

        protected AccessibleAWTMenuBar​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 MenuComponent.AccessibleAWTMenuComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        从以下版本开始：
        1.4
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MenuComponent

  • java.lang.Object
    • java.awt.MenuComponent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    MenuBar ， MenuItem

    public abstract class MenuComponent
extends Object
implements Serializable
    抽象类MenuComponent是所有菜单相关组件的超类。 在这方面，类MenuComponent类似于AWT组件的抽象超类Component 。

    菜单组件通过方法processEvent接收和处理AWT事件，就像组件一样。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  MenuComponent.AccessibleAWTMenuComponent
      内部类别 MenuComponent用于为辅助功能提供默认支持。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuComponent​()
      创建一个 MenuComponent 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void dispatchEvent​(AWTEvent e)
      将事件提供给此组件或其子组件之一。
      AccessibleContext getAccessibleContext​()
      获取 AccessibleContext与此 MenuComponent相关联。
      Font getFont​()
      获取用于此菜单组件的字体。
      String getName​()
      获取菜单组件的名称。
      MenuContainer getParent​()
      返回此菜单组件的父容器。
      protected Object getTreeLock​()
      获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。
      protected String paramString​()
      返回一个表示 MenuComponent状态的字符串。
      boolean postEvent​(Event evt)
      已过时。
      从JDK 1.1版开始，由dispatchEvent替代。
      protected void processEvent​(AWTEvent e)
      处理在此菜单组件上发生的事件。
      void removeNotify​()
      删除菜单组件的对等体。
      void setFont​(Font f)
      将此菜单组件使用的字体设置为指定的字体。
      void setName​(String name)
      将组件的名称设置为指定的字符串。
      String toString​()
      以字符串形式返回此菜单组件的表示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MenuComponent

        public MenuComponent​()
              throws HeadlessException
        创建一个 MenuComponent 。
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回 true
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • getName

        public String getName​()
        获取菜单组件的名称。
        结果
        菜单组件的名称
        从以下版本开始：
        1.1
        另请参见：
        setName(java.lang.String)

      • setName

        public void setName​(String name)
        将组件的名称设置为指定的字符串。
        参数
        name - 菜单组件的名称
        从以下版本开始：
        1.1
        另请参见：
        getName()

      • getParent

        public MenuContainer getParent​()
        返回此菜单组件的父容器。
        结果
        包含此菜单组件的菜单组件，或 null如果此菜单组件是最外面的组件，菜单栏本身

      • getFont

        public Font getFont​()
        获取用于此菜单组件的字体。
        结果
        在这个菜单组件中使用的字体，如果有的话; 否则为null
        另请参见：
        setFont(java.awt.Font)

      • setFont

        public void setFont​(Font f)
        将此菜单组件使用的字体设置为指定的字体。 此字体也被该菜单组件的所有子组件使用，除非这些子组件指定了不同的字体。

        某些平台可能不支持菜单组件的所有字体属性的设置; 在这种情况下，调用setFont将不会对此菜单组件的不支持的字体属性产生影响。 除非此菜单组件的子组件指定不同的字体，否则这个字体将被这些子组件用于底层平台的支持。

        参数
        f - 要设置的字体
        另请参见：
        getFont() ， Font.getAttributes() ， TextAttribute

      • removeNotify

        public void removeNotify​()
        删除菜单组件的对等体。 对等体允许我们修改菜单组件的外观，而不改变菜单组件的功能。

      • postEvent

        @Deprecated
public boolean postEvent​(Event evt)
        已过时。 截至JDK 1.1版，由dispatchEvent替代。
        将指定的事件发布到菜单。 此方法是Java 1.0事件系统的一部分，它仅保留向后兼容性。 不鼓励使用它，将来可能不支持它。
        参数
        evt - 即将发生的事件
        结果
        无条件地返回false

      • dispatchEvent

        public final void dispatchEvent​(AWTEvent e)
        将事件提供给此组件或其子组件之一。
        参数
        e - 事件

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理在此菜单组件上发生的事件。

        请注意，如果事件参数是null ，行为是未指定的，可能会导致异常。

        参数
        e - 事件
        从以下版本开始：
        1.1

      • paramString

        protected String paramString​()
        返回表示MenuComponent的状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        结果
        该菜单组件的参数字符串

      • toString

        public String toString​()
        以字符串形式返回此菜单组件的表示。
        重写：
        toString在 Object
        结果
        此菜单组件的字符串表示形式

      • getTreeLock

        protected final Object getTreeLock​()
        获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。
        结果
        这个组件的锁定对象

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取AccessibleContext与此MenuComponent相关联。 该基类实现的方法返回null 。 扩展MenuComponent类应实现此方法以返回与该子类相关联的AccessibleContext 。
        结果
        该 AccessibleContext的这个 MenuComponent
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuComponent.AccessibleAWTMenuComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MenuComponent.AccessibleAWTMenuComponent

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.MenuComponent.AccessibleAWTMenuComponent
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent ， AccessibleSelection
    已知直接子类：
    MenuBar.AccessibleAWTMenuBar ， MenuItem.AccessibleAWTMenuItem
    Enclosing class:
    MenuComponent

    protected abstract class MenuComponent.AccessibleAWTMenuComponent
extends AccessibleContext
implements Serializable, AccessibleComponent, AccessibleSelection
    内部类别MenuComponent用于提供对辅助功能的默认支持。 这个类不是由应用程序开发人员直接使用的，而是意味着仅由菜单组件开发人员进行子类化。

    该类用于获取此对象的可访问角色。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AccessibleAWTMenuComponent​()
      虽然这个类是抽象的，但这应该被所有子类调用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addAccessibleSelection​(int i)
      将对象的指定的 Accessible子对象添加到对象的选择中。
      void addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      void clearAccessibleSelection​()
      清除对象中的选择，以使对象中没有子对象被选中。
      boolean contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      Accessible getAccessibleAt​(Point p)
      返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
      Accessible getAccessibleChild​(int i)
      返回对象的第n个 Accessible子对象。
      int getAccessibleChildrenCount​()
      返回对象中可访问的子项数。
      AccessibleComponent getAccessibleComponent​()
      获取与此对象关联的 AccessibleComponent如果存在）。
      String getAccessibleDescription​()
      获取此对象的可访问描述。
      int getAccessibleIndexInParent​()
      获取此对象在其可访问父级中的索引。
      String getAccessibleName​()
      获取此对象的可访问名称。
      Accessible getAccessibleParent​()
      获取此对象的 Accessible父项。
      AccessibleRole getAccessibleRole​()
      获得此对象的作用。
      AccessibleSelection getAccessibleSelection​()
      获取与此对象关联的 AccessibleSelection ，允许其 Accessible孩子被选中。
      Accessible getAccessibleSelection​(int i)
      返回表示对象中指定的选定子项的 Accessible 。
      int getAccessibleSelectionCount​()
      返回当前选择的 Accessible孩子的数量。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态。
      Color getBackground​()
      获取此对象的背景颜色。
      Rectangle getBounds​()
      以 Rectangle对象的形式获取此对象的边界。
      Cursor getCursor​()
      获取此对象的 Cursor 。
      Font getFont​()
      获取此对象的 Font 。
      FontMetrics getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      Color getForeground​()
      获取此对象的前景色。
      Locale getLocale​()
      返回此对象的区域设置。
      Point getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Dimension getSize​()
      以 Dimension对象的形式返回此对象的大小。
      boolean isAccessibleChildSelected​(int i)
      确定是否选择了此对象的当前子级。
      boolean isEnabled​()
      确定对象是否已启用。
      boolean isFocusTraversable​()
      返回此对象是否可以接受焦点。
      boolean isShowing​()
      确定对象是否正在显示。
      boolean isVisible​()
      确定对象是否可见。
      void removeAccessibleSelection​(int i)
      从对象的选择中删除对象的指定子对象。
      void removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void requestFocus​()
      请求关注此对象。
      void selectAllAccessibleSelection​()
      如果对象支持多个选择，则导致选择对象的每个子对象。
      void setBackground​(Color c)
      设置此对象的背景颜色。
      void setBounds​(Rectangle r)
      以 Rectangle对象的形式设置此对象的边界。
      void setCursor​(Cursor cursor)
      设置该对象的 Cursor 。
      void setEnabled​(boolean b)
      设置对象的已启用状态。
      void setFont​(Font f)
      设置此对象的 Font 。
      void setForeground​(Color c)
      设置此对象的前景色。
      void setLocation​(Point p)
      设置对象相对于父对象的位置。
      void setSize​(Dimension d)
      调整此对象的大小。
      void setVisible​(boolean b)
      设置对象的可见状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTMenuComponent

        protected AccessibleAWTMenuComponent​()
        虽然这个类是抽象的，但这应该被所有子类调用。

    • 方法详细信息

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection​()
        获取与此对象关联的 AccessibleSelection ，允许其 Accessible孩子被选中。
        重写：
        getAccessibleSelection在类 AccessibleContext
        结果
        AccessibleSelection如果由对象支持; 否则返回null
        另请参见：
        AccessibleSelection

      • getAccessibleName

        public String getAccessibleName​()
        获取此对象的可访问名称。 这几乎永远不会返回java.awt.MenuComponent.getName ，因为这通常不是本地化的名称，对用户没有意义。 如果对象基本上是文本对象（例如菜单项），可访问名称应该是对象的文本（例如“保存”）。 如果对象有一个工具提示，工具提示文本也可能是一个适当的String返回。
        重写：
        getAccessibleName在 AccessibleContext
        结果
        对象的本地化名称 - 如果此对象没有名称，则可以是 null
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleDescription

        public String getAccessibleDescription​()
        获取此对象的可访问描述。 这应该是对这个对象的简明的本地化描述 - 它对用户的意义。 如果对象具有工具提示，则工具提示文本可能是要返回的适当字符串，假设它包含对象的简明描述（而不仅仅是对象的名称），例如工具栏上的“保存”图标，该对象具有“保存“因为工具提示文本不应该返回工具提示文本作为说明，而是像”保存当前文本文档“一样。
        重写：
        getAccessibleDescription在 AccessibleContext
        结果
        对象的本地化描述 - 如果此对象没有描述，可以是 null
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获得此对象的作用。
        Specified by:
        getAccessibleRole在 AccessibleContext
        结果
        描述对象的作用的一个 AccessibleRole的实例
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态。
        Specified by:
        getAccessibleStateSet在 AccessibleContext
        结果
        一个 AccessibleStateSet的实例包含对象的当前状态集
        另请参见：
        AccessibleState

      • getAccessibleParent

        public Accessible getAccessibleParent​()
        获取此对象的Accessible父项。 如果这个对象的父对象实现了Accessible ，这个方法应该简单地返回getParent 。
        重写：
        getAccessibleParent在类 AccessibleContext
        结果
        该对象的 Accessible父对象可以是 null如果此对象没有一个 Accessible父对象

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent​()
        获取此对象在其可访问父级中的索引。
        Specified by:
        getAccessibleIndexInParent在 AccessibleContext
        结果
        该对象在其父项中的索引; -1如果此对象没有可访问的父对象
        另请参见：
        getAccessibleParent()

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount​()
        返回对象中可访问的子项数。 如果这个对象的所有子项都实现了Accessible ，那么这个方法应该返回这个对象的子数。
        Specified by:
        getAccessibleChildrenCount在 AccessibleContext
        结果
        对象中可访问的孩子的数量

      • getAccessibleChild

        public Accessible getAccessibleChild​(int i)
        返回对象的第n个 Accessible子对象。
        Specified by:
        getAccessibleChild在 AccessibleContext
        参数
        i - 基于零的儿童索引
        结果
        对象的第n个可访问子对象
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale​()
        返回此对象的区域设置。
        Specified by:
        getLocale在 AccessibleContext
        结果
        该对象的区域设置

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent​()
        获取与此对象关联的AccessibleComponent如果存在）。 否则返回null 。
        重写：
        getAccessibleComponent在类 AccessibleContext
        结果
        组件
        另请参见：
        AccessibleComponent

      • getBackground

        public Color getBackground​()
        获取此对象的背景颜色。
        Specified by:
        getBackground在接口 AccessibleComponent
        结果
        对象的背景颜色（如果支持）; 否则， null
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • setBackground

        public void setBackground​(Color c)
        设置此对象的背景颜色。 （有关透明度，请参阅isOpaque ）
        Specified by:
        setBackground在接口 AccessibleComponent
        参数
        c - 新的 Color为背景
        另请参见：
        Component.isOpaque()

      • getForeground

        public Color getForeground​()
        获取此对象的前景色。
        Specified by:
        getForeground在接口 AccessibleComponent
        结果
        对象的前景颜色（如果支持）; 否则， null
        另请参见：
        AccessibleComponent.setForeground(java.awt.Color)

      • setForeground

        public void setForeground​(Color c)
        设置此对象的前景色。
        Specified by:
        setForeground在接口 AccessibleComponent
        参数
        c - 新的 Color为前景
        另请参见：
        AccessibleComponent.getForeground()

      • getCursor

        public Cursor getCursor​()
        获取此对象的 Cursor 。
        Specified by:
        getCursor在接口 AccessibleComponent
        结果
        Cursor ，如果支持，则该对象; 否则， null
        另请参见：
        AccessibleComponent.setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor​(Cursor cursor)
        设置此对象的Cursor 。

        如果Java平台实现和/或本地系统不支持更改鼠标光标的形状，该方法可能没有视觉效果。

        Specified by:
        setCursor在接口 AccessibleComponent
        参数
        cursor - 新的 Cursor为对象
        另请参见：
        AccessibleComponent.getCursor()

      • getFont

        public Font getFont​()
        获取此对象的 Font 。
        Specified by:
        getFont在接口 AccessibleComponent
        结果
        Font ，如果支持，为对象; 否则， null
        另请参见：
        AccessibleComponent.setFont(java.awt.Font)

      • setFont

        public void setFont​(Font f)
        设置此对象的 Font 。
        Specified by:
        setFont在接口 AccessibleComponent
        参数
        f - 新的 Font为对象
        另请参见：
        AccessibleComponent.getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics​(Font f)
        获取此对象的 FontMetrics 。
        Specified by:
        getFontMetrics在接口 AccessibleComponent
        参数
        f - Font
        结果
        FontMetrics，如果支持，该对象; 否则， null
        另请参见：
        getFont()

      • isEnabled

        public boolean isEnabled​()
        确定对象是否已启用。
        Specified by:
        isEnabled在接口 AccessibleComponent
        结果
        如果对象启用，则为true; 否则，假
        另请参见：
        AccessibleComponent.setEnabled(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.ENABLED ， AccessibleStateSet

      • setEnabled

        public void setEnabled​(boolean b)
        设置对象的已启用状态。
        Specified by:
        setEnabled在接口 AccessibleComponent
        参数
        b - 如果为true，则启用此对象; 否则，禁用它
        另请参见：
        AccessibleComponent.isEnabled()

      • isVisible

        public boolean isVisible​()
        确定对象是否可见。 注意：这意味着该对象意图可见; 然而，它可能不会在屏幕上显示，因为该对象包含的对象之一是不可见的。 要确定对象是否在屏幕上显示，请使用isShowing 。
        Specified by:
        isVisible在接口 AccessibleComponent
        结果
        如果对象可见，则为true; 否则，假
        另请参见：
        AccessibleComponent.setVisible(boolean) ， AccessibleContext.getAccessibleStateSet() ， AccessibleState.VISIBLE ， AccessibleStateSet

      • setVisible

        public void setVisible​(boolean b)
        设置对象的可见状态。
        Specified by:
        setVisible在接口 AccessibleComponent
        参数
        b - 如果为true，则显示此对象; 否则隐藏它
        另请参见：
        AccessibleComponent.isVisible()

      • isShowing

        public boolean isShowing​()
        确定对象是否正在显示。 这是通过检查对象和对象的祖先的可见性来确定的。 注意：即使对象被另一个遮挡（例如，恰好在被拉下的菜单下方），这将返回true。
        Specified by:
        isShowing在接口 AccessibleComponent
        结果
        如果对象显示，则为true; 否则，假

      • contains

        public boolean contains​(Point p)
        检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
        Specified by:
        contains在接口 AccessibleComponent
        参数
        p - 相对于对象的坐标系的 Point
        结果
        如果对象包含Point ; 否则为虚假
        另请参见：
        AccessibleComponent.getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen​()
        返回对象在屏幕上的位置。
        Specified by:
        getLocationOnScreen在接口 AccessibleComponent
        结果
        屏幕上对象的位置 - 如果此对象不在屏幕上，可以是 null
        另请参见：
        AccessibleComponent.getBounds() ， AccessibleComponent.getLocation()

      • getLocation

        public Point getLocation​()
        以指定对象的左上角的点的形式获取对象相对于父对象的位置。
        Specified by:
        getLocation在接口 AccessibleComponent
        结果
        表示在屏幕的坐标空间中对象边界的左上角的Point的实例; null如果此对象或其父对象不在屏幕上
        另请参见：
        AccessibleComponent.getBounds() ， AccessibleComponent.getLocationOnScreen()

      • setLocation

        public void setLocation​(Point p)
        设置对象相对于父对象的位置。
        Specified by:
        setLocation在接口 AccessibleComponent
        参数
        p - 左上角的新位置
        另请参见：
        AccessibleComponent.getLocation()

      • getBounds

        public Rectangle getBounds​()
        以Rectangle对象的形式获取此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        Specified by:
        getBounds在接口 AccessibleComponent
        结果
        表示该组件边界的矩形; 如果此对象不在屏幕上， null
        另请参见：
        AccessibleComponent.contains(java.awt.Point)

      • setBounds

        public void setBounds​(Rectangle r)
        以Rectangle对象的形式设置此对象的边界。 边界指定相对于其父对象的宽度，高度和位置。
        Specified by:
        setBounds在接口 AccessibleComponent
        参数
        r - 表示此组件边界的矩形
        另请参见：
        AccessibleComponent.getBounds()

      • getSize

        public Dimension getSize​()
        以Dimension对象的形式返回此对象的大小。 Dimension对象的height字段包含该对象的高度，而Dimension对象的width字段包含此对象的宽度。
        Specified by:
        getSize在接口 AccessibleComponent
        结果
        一个Dimension对象，指示此组件的大小; null如果此对象不在屏幕上
        另请参见：
        AccessibleComponent.setSize(java.awt.Dimension)

      • setSize

        public void setSize​(Dimension d)
        调整此对象的大小。
        Specified by:
        setSize在接口 AccessibleComponent
        参数
        d - 指定对象的新大小的 Dimension
        另请参见：
        AccessibleComponent.getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt​(Point p)
        返回Accessible小孩，如果存在，则包含在本地坐标Point 。 如果没有Accessible小孩，则返回null 。
        Specified by:
        getAccessibleAt在接口 AccessibleComponent
        参数
        p -定义的左上角点 Accessible ，在对象的父对象的坐标空间中给出
        结果
        Accessible ，如果存在，在指定的位置; 其他null

      • isFocusTraversable

        public boolean isFocusTraversable​()
        返回此对象是否可以接受焦点。
        Specified by:
        isFocusTraversable在接口 AccessibleComponent
        结果
        true如果对象可以接受焦点; 否则为虚假
        另请参见：
        AccessibleContext.getAccessibleStateSet() ， AccessibleState.FOCUSABLE ， AccessibleState.FOCUSED ， AccessibleStateSet

      • requestFocus

        public void requestFocus​()
        请求关注此对象。
        Specified by:
        requestFocus在接口 AccessibleComponent
        另请参见：
        AccessibleComponent.isFocusTraversable()

      • addFocusListener

        public void addFocusListener​(FocusListener l)
        新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
        Specified by:
        addFocusListener在接口 AccessibleComponent
        参数
        l - 焦点听众
        另请参见：
        AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener​(FocusListener l)
        删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
        Specified by:
        removeFocusListener在接口 AccessibleComponent
        参数
        l - 焦点侦听器
        另请参见：
        AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount​()
        返回当前选择的Accessible孩子的数量。 如果没有选择小孩，则返回值为0。
        Specified by:
        getAccessibleSelectionCount在接口 AccessibleSelection
        结果
        当前选择的项目数

      • getAccessibleSelection

        public Accessible getAccessibleSelection​(int i)
        返回表示对象中指定的选定子项的Accessible 。 如果没有选择，或者选择的孩子比传入的整数少，则返回值为null 。

        请注意，该索引代表第i个所选子项，该子与第i个子不同。

        Specified by:
        getAccessibleSelection在接口 AccessibleSelection
        参数
        i - 所选儿童的零 i引
        结果
        第i个选定的孩子
        另请参见：
        getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected​(int i)
        确定是否选择了此对象的当前子级。
        Specified by:
        isAccessibleChildSelected在接口 AccessibleSelection
        参数
        i - 这个 Accessible对象中的小孩的从零开始的索引
        结果
        如果选择了该对象的当前子对象，则为true; 否则假
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection​(int i)
        添加指定Accessible子对象的对象的选择。 如果对象支持多个选择，则指定的子项将添加到任何现有的选择中，否则将替换对象中的任何现有选择。 如果指定的子项已被选中，则此方法无效。
        Specified by:
        addAccessibleSelection在接口 AccessibleSelection
        参数
        i - 小孩的从零开始的索引
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection​(int i)
        从对象的选择中删除对象的指定子对象。 如果当前未选择指定的项目，则此方法无效。
        Specified by:
        removeAccessibleSelection在接口 AccessibleSelection
        参数
        i - 小孩的从零开始的索引
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection​()
        清除对象中的选择，以使对象中没有子对象被选中。
        Specified by:
        clearAccessibleSelection在接口 AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection​()
        如果对象支持多个选择，则导致选择对象的每个子对象。
        Specified by:
        selectAllAccessibleSelection在接口 AccessibleSelection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuContainer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface MenuContainer

  • 所有已知实现类：
    AbstractButton ， AbstractColorChooserPanel ， Applet ， BasicArrowButton ， BasicComboBoxRenderer ， BasicComboBoxRenderer.UIResource ， BasicComboPopup ， BasicInternalFrameTitlePane ， BasicInternalFrameTitlePane.SystemMenuBar ， BasicSplitPaneDivider ， BasicToolBarUI.DragWindow ， Box ， Box.Filler ， Button ， Canvas ， CellRendererPane ， Checkbox ， Choice ， Component ， Container ， DefaultListCellRenderer ， DefaultListCellRenderer.UIResource ， DefaultTableCellRenderer ， DefaultTableCellRenderer.UIResource ， DefaultTreeCellEditor.DefaultTextField ， DefaultTreeCellEditor.EditorContainer ， DefaultTreeCellRenderer ， Dialog ， FileDialog ， Frame ， JApplet ， JButton ， JCheckBox ， JCheckBoxMenuItem ， JColorChooser ， JComboBox ， JComponent ， JDesktopPane ， JDialog ， JEditorPane ， JFileChooser ， JFormattedTextField ， JFrame ， JFXPanel ， JInternalFrame ， JInternalFrame.JDesktopIcon ， JLabel ， JLayer ， JLayeredPane ， JList ， JMenu ， JMenuBar ， JMenuItem ， JOptionPane ， JPanel ， JPasswordField JPasswordField ， JPopupMenu ， JPopupMenu.Separator ， JProgressBar ， JRadioButton ， JRadioButtonMenuItem ， JRootPane ， JScrollBar ， JScrollPane ， JScrollPane.ScrollBar ， JSeparator ， JSlider ， JSpinner ， JSpinner.DateEditor ， JSpinner.DefaultEditor ， JSpinner.ListEditor ， JSpinner.NumberEditor ， JSplitPane ， JTabbedPane ， JTable ， JTableHeader ， JTextArea ， JTextComponent ， JTextField ， JTextPane ， JToggleButton ， JToolBar ， JToolBar.Separator ， JToolTip ， JTree ， JViewport ， JWindow ， Label ， List ， Menu ， MenuBar ， MetalComboBoxButton ， MetalComboBoxUI.MetalComboPopup ， MetalFileChooserUI.FileRenderer ， MetalFileChooserUI.FilterComboBoxRenderer ， MetalInternalFrameTitlePane ， MetalScrollButton ， Panel ， PopupMenu ， Scrollbar ， ScrollPane ， TextArea ， TextComponent ， TextField ， Window

    public interface MenuContainer
    所有菜单相关容器的超类。

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      Font getFont​()
      返回此容器正在使用的字体。
      boolean postEvent​(Event evt)
      已过时。
      由JDK版本1.1替换为dispatchEvent（AWTEvent）。
      void remove​(MenuComponent comp)
      从菜单中删除指定的菜单组件。

    • 方法详细信息

      • getFont

        Font getFont​()
        返回此容器正在使用的字体。
        结果
        菜单字体

      • remove

        void remove​(MenuComponent comp)
        从菜单中删除指定的菜单组件。
        参数
        comp - 要删除的菜单组件

      • postEvent

        @Deprecated
boolean postEvent​(Event evt)
        已过时。 由JDK版本1.1替换为dispatchEvent（AWTEvent）。
        向事件发送一个事件。
        参数
        evt - 发送的事件
        结果
        发布事件的结果
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MenuItem

  • java.lang.Object
    • java.awt.MenuComponent
      • java.awt.MenuItem
  • All Implemented Interfaces:
    Serializable ， Accessible
    已知直接子类：
    CheckboxMenuItem ， Menu

    public class MenuItem
extends MenuComponent
implements Accessible
    菜单中的所有项目必须属于类别MenuItem或其子类之一。

    默认的MenuItem对象体现了一个简单的标签菜单项。

    菜单栏的这张照片显示五个菜单项： 以下文字描述了此图形。
    前两个项目是简单的菜单项，标记为"Basic"和"Simple" 。 以下这两个项目是一个分隔符，它本身就是一个菜单项，用标签"-"创建。 接下来是CheckboxMenuItem标记为"Check"的实例。 最后一个菜单项是一个标有"More Examples"的子菜单，此子菜单是Menu一个实例。

    当选择菜单项时，AWT会向菜单项发送一个动作事件。 由于事件是ActionEvent一个实例，因此processEvent方法检查事件并将其传递给processActionEvent 。 后一种方法将事件重定向到已经注册了对该菜单项生成的动作事件感兴趣的任何ActionListener对象。

    请注意，子类Menu会覆盖此行为，并且不会将任何事件发送到该帧，直到选择其中一个子项。

    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。

      • Nested classes/interfaces inherited from class java.awt.MenuComponent

        MenuComponent.AccessibleAWTMenuComponent

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuItem​()
      构造一个带有空标签的新菜单项，而不需要键盘快捷方式。
      MenuItem​(String label)
      使用指定的标签构建一个新的MenuItem，而不需要键盘快捷方式。
      MenuItem​(String label, MenuShortcut s)
      创建一个带有相关键盘快捷方式的菜单项。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addActionListener​(ActionListener l)
      添加指定的动作侦听器以从该菜单项接收动作事件。
      void addNotify​()
      创建菜单项的对等体。
      void deleteShortcut​()
      删除与此菜单项相关联的任何 MenuShortcut对象。
      void disable​()
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      protected void disableEvents​(long eventsToDisable)
      禁用由指定事件掩码参数定义的事件的此菜单项的事件传递。
      void enable​()
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      void enable​(boolean b)
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      protected void enableEvents​(long eventsToEnable)
      启用事件传递到此菜单项，以指定事件掩码参数定义的事件
      AccessibleContext getAccessibleContext​()
      获取与此MenuItem关联的AccessibleContext。
      String getActionCommand​()
      获取此菜单项触发的操作事件的命令名称。
      ActionListener[] getActionListeners​()
      返回在此菜单项上注册的所有动作侦听器的数组。
      String getLabel​()
      获取此菜单项的标签。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回此 MenuItem当前注册为 FooListener的所有对象的数组。
      MenuShortcut getShortcut​()
      获取与 MenuShortcut相关联的 MenuShortcut对象，
      boolean isEnabled​()
      检查此菜单项是否启用。
      String paramString​()
      返回一个表示 MenuItem状态的字符串。
      protected void processActionEvent​(ActionEvent e)
      处理在此菜单项上发生的操作事件，将其发送到任何已注册的对象 ActionListener 。
      protected void processEvent​(AWTEvent e)
      处理此菜单项上的事件。
      void removeActionListener​(ActionListener l)
      删除指定的动作监听器，使其不再从此菜单项接收动作事件。
      void setActionCommand​(String command)
      设置此菜单项触发的操作事件的命令名称。
      void setEnabled​(boolean b)
      设置是否可以选择此菜单项。
      void setLabel​(String label)
      将此菜单项的标签设置为指定的标签。
      void setShortcut​(MenuShortcut s)
      设置与 MenuShortcut相关联的 MenuShortcut对象。

      • Methods inherited from class java.awt.MenuComponent

        dispatchEvent, getFont, getName, getParent, getTreeLock, postEvent, removeNotify, setFont, setName, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MenuItem

        public MenuItem​()
         throws HeadlessException
        构造一个带有空标签的新菜单项，而不需要键盘快捷方式。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

      • MenuItem

        public MenuItem​(String label)
         throws HeadlessException
        使用指定的标签构建一个新的MenuItem，而不需要键盘快捷方式。 请注意，在标签中使用“ - ”保留以指示菜单项之间的分隔符。 默认情况下，除分隔符之外的所有菜单项都被启用。
        参数
        label - 此菜单项的标签。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        从以下版本开始：
        1.0
        另请参见：
        GraphicsEnvironment.isHeadless()

      • MenuItem

        public MenuItem​(String label,
                MenuShortcut s)
         throws HeadlessException
        创建一个带有相关键盘快捷方式的菜单项。 请注意，在标签中使用“ - ”保留以指示菜单项之间的分隔符。 默认情况下，除分隔符之外的所有菜单项都被启用。
        参数
        label - 此菜单项的标签。
        s - 与该菜单项相关联的 MenuShortcut的实例。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建菜单项的对等体。 对等体允许我们修改菜单项的外观而不改变其功能。

      • getLabel

        public String getLabel​()
        获取此菜单项的标签。
        结果
        此菜单项的标签，如果此菜单项没有标签， null 。
        从以下版本开始：
        1.0
        另请参见：
        setLabel(java.lang.String)

      • setLabel

        public void setLabel​(String label)
        将此菜单项的标签设置为指定的标签。
        参数
        label - 新标签，或 null无标签。
        从以下版本开始：
        1.0
        另请参见：
        getLabel()

      • isEnabled

        public boolean isEnabled​()
        检查此菜单项是否启用。
        结果
        true如果项目启用; 否则false
        从以下版本开始：
        1.0
        另请参见：
        setEnabled(boolean)

      • setEnabled

        public void setEnabled​(boolean b)
        设置是否可以选择此菜单项。
        参数
        b - 如果是true ，启用此菜单项; 如果false ，禁用它。
        从以下版本开始：
        1.1
        另请参见：
        isEnabled()

      • enable

        @Deprecated
public void enable​()
        已过时。 从JDK 1.1版开始，由setEnabled(boolean)代替。

      • enable

        @Deprecated
public void enable​(boolean b)
        已过时。 从JDK 1.1版开始，替换为setEnabled(boolean) 。
        设置是否可以选择此菜单项。
        参数
        b - 如果是true ，启用此菜单项; 否则禁用

      • disable

        @Deprecated
public void disable​()
        已过时。 从JDK 1.1版开始，由setEnabled(boolean)替代。

      • getShortcut

        public MenuShortcut getShortcut​()
        获取与 MenuShortcut相关联的 MenuShortcut对象，
        结果
        与此菜单项相关联的菜单快捷方式，如果没有指定， null 。
        从以下版本开始：
        1.1
        另请参见：
        setShortcut(java.awt.MenuShortcut)

      • setShortcut

        public void setShortcut​(MenuShortcut s)
        设置与MenuShortcut相关联的MenuShortcut对象。 如果菜单快捷方式已经与此菜单项相关联，则会被替换。
        参数
        s - 与此菜单项关联的菜单快捷方式。
        从以下版本开始：
        1.1
        另请参见：
        getShortcut()

      • deleteShortcut

        public void deleteShortcut​()
        删除与此菜单项相关联的任何 MenuShortcut对象。
        从以下版本开始：
        1.1

      • enableEvents

        protected final void enableEvents​(long eventsToEnable)
        启用事件传递到此菜单项，以指定事件掩码参数定义的事件

        由于事件类型会在将类型的侦听器添加到菜单项时自动启用，因此该方法仅需要由MenuItem的子类调用，该子类希望将指定的事件类型传递到processEvent而不管是否注册了侦听器。

        参数
        eventsToEnable - 定义事件类型的事件掩码
        从以下版本开始：
        1.1
        另请参见：
        processEvent(java.awt.AWTEvent) ， disableEvents(long) ， Component.enableEvents(long)

      • disableEvents

        protected final void disableEvents​(long eventsToDisable)
        禁用由指定事件掩码参数定义的事件的此菜单项的事件传递。
        参数
        eventsToDisable - 定义事件类型的事件掩码
        从以下版本开始：
        1.1
        另请参见：
        processEvent(java.awt.AWTEvent) ， enableEvents(long) ， Component.disableEvents(long)

      • setActionCommand

        public void setActionCommand​(String command)
        设置此菜单项触发的操作事件的命令名称。

        默认情况下，action命令设置为菜单项的标签。

        参数
        command - 要为此菜单项设置的动作命令。
        从以下版本开始：
        1.1
        另请参见：
        getActionCommand()

      • getActionCommand

        public String getActionCommand​()
        获取此菜单项触发的操作事件的命令名称。
        结果
        动作命令名称
        从以下版本开始：
        1.1
        另请参见：
        setActionCommand(java.lang.String)

      • addActionListener

        public void addActionListener​(ActionListener l)
        添加指定的动作侦听器以从该菜单项接收动作事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器。
        从以下版本开始：
        1.1
        另请参见：
        removeActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionEvent ， ActionListener

      • removeActionListener

        public void removeActionListener​(ActionListener l)
        删除指定的动作监听器，使其不再从此菜单项接收动作事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器。
        从以下版本开始：
        1.1
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionEvent ， ActionListener

      • getActionListeners

        public ActionListener[] getActionListeners​()
        返回在此菜单项上注册的所有动作侦听器的数组。
        结果
        所有这个菜单项的 ActionListener s或一个空数组，如果没有动作侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， removeActionListener(java.awt.event.ActionListener) ， ActionEvent ， ActionListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册为FooListener的所有对象的数组MenuItem 。 FooListener使用addFooListener方法注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询MenuItem m其动作侦听器：

          ActionListener[] als = (ActionListener[])(m.getListeners(ActionListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        参数类型
        T - 侦听器的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此菜单项上注册为 FooListener s的所有对象的数组，如果没有添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType未指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getActionListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此菜单项上的事件。 如果事件是ActionEvent一个实例，它将调用processActionEvent ，另一个由MenuItem定义的MenuItem 。

        目前，菜单项只支持动作事件。

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        重写：
        processEvent在 MenuComponent
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        processActionEvent(java.awt.event.ActionEvent)

      • processActionEvent

        protected void processActionEvent​(ActionEvent e)
        通过将这些事件发送到任何已注册的ActionListener对象来处理此菜单项上发生的操作事件。 除非为此组件启用了操作事件，否则不会调用此方法。 当发生以下情况之一时，启用操作事件：
        • 通过addActionListener注册一个ActionListener对象。
        • 通过enableEvents启用操作事件。

        请注意，如果事件参数为null该行为未指定，可能会导致异常。

        参数
        e - 动作事件
        从以下版本开始：
        1.1
        另请参见：
        ActionEvent ， ActionListener ， enableEvents(long)

      • paramString

        public String paramString​()
        返回一个表示MenuItem状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString的 MenuComponent
        结果
        该菜单项的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此MenuItem关联的AccessibleContext。 对于菜单项，AccessibleContext采用AccessibleAWTMenuItem的形式。 如有必要，将创建一个新的AccessibleAWTMenuItem实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 MenuComponent
        结果
        一个AccessibleAWTMenuItem，用作此MenuItem的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuItem.AccessibleAWTMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MenuItem.AccessibleAWTMenuItem

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.MenuComponent.AccessibleAWTMenuComponent
        • java.awt.MenuItem.AccessibleAWTMenuItem
  • All Implemented Interfaces:
    Serializable ， AccessibleAction ， AccessibleComponent ， AccessibleSelection ， AccessibleValue
    已知直接子类：
    CheckboxMenuItem.AccessibleAWTCheckboxMenuItem ， Menu.AccessibleAWTMenu
    Enclosing class:
    MenuItem

    protected class MenuItem.AccessibleAWTMenuItem
extends MenuComponent.AccessibleAWTMenuComponent
implements AccessibleAction, AccessibleValue
    MenuItem的内部类用于为辅助功能提供默认支持。 这个类不是由应用程序开发人员直接使用的，而是意味着仅由菜单组件开发人员进行子类化。

    该类实现MenuItem类的可访问性支持。 它提供了适用于菜单项用户界面元素的Java Accessibility API的实现。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTMenuItem​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean doAccessibleAction​(int i)
      对对象执行指定的Action
      AccessibleAction getAccessibleAction​()
      获取与此对象关联的AccessibleAction。
      int getAccessibleActionCount​()
      返回此对象中可用的操作数。
      String getAccessibleActionDescription​(int i)
      返回对象的指定操作的描述。
      String getAccessibleName​()
      获取此对象的可访问名称。
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleValue getAccessibleValue​()
      获取与此对象关联的AccessibleValue。
      Number getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      boolean setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。

      • Methods inherited from class javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.MenuComponent.AccessibleAWTMenuComponent

        addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTMenuItem

        protected AccessibleAWTMenuItem​()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName​()
        获取此对象的可访问名称。
        重写：
        getAccessibleName在 MenuComponent.AccessibleAWTMenuComponent
        结果
        对象的本地化名称 - 如果此对象没有名称，则可以为null
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 MenuComponent.AccessibleAWTMenuComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleAction

        public AccessibleAction getAccessibleAction​()
        获取与此对象关联的AccessibleAction。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleAction接口。
        重写：
        getAccessibleAction在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleAction

      • getAccessibleValue

        public AccessibleValue getAccessibleValue​()
        获取与此对象关联的AccessibleValue。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleValue接口。
        重写：
        getAccessibleValue在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleValue

      • getAccessibleActionCount

        public int getAccessibleActionCount​()
        返回此对象中可用的操作数。 菜单项的默认行为是一个动作。
        Specified by:
        getAccessibleActionCount在接口 AccessibleAction
        结果
        1，此对象中的Actions数

      • getAccessibleActionDescription

        public String getAccessibleActionDescription​(int i)
        返回对象的指定操作的描述。
        Specified by:
        getAccessibleActionDescription在接口 AccessibleAction
        参数
        i - 零操作的索引
        结果
        一个 String描述的动作
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction​(int i)
        对对象执行指定的Action
        Specified by:
        doAccessibleAction在接口 AccessibleAction
        参数
        i - 从零开始的行动指数
        结果
        如果行动执行，则为真; 否则为虚假。
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue​()
        将该对象的值作为数字获取。
        Specified by:
        getCurrentAccessibleValue在接口 AccessibleValue
        结果
        如果未选择，则为0的整数，如果选中则为整数为1。
        另请参见：
        AbstractButton.isSelected()

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue​(Number n)
        将此对象的值设置为数字。
        Specified by:
        setCurrentAccessibleValue在接口 AccessibleValue
        参数
        n - 用于该值的数字
        结果
        如果设置了该值，则为真。
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue​()
        将此对象的最小值作为数字获取。
        Specified by:
        getMinimumAccessibleValue在接口 AccessibleValue
        结果
        0的整数。
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue​()
        获取该对象的最大值作为数字。
        Specified by:
        getMaximumAccessibleValue接口 AccessibleValue
        结果
        0的整数。
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MenuShortcut (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MenuShortcut

  • java.lang.Object
    • java.awt.MenuShortcut
  • All Implemented Interfaces:
    Serializable

    public class MenuShortcut
extends Object
implements Serializable
    MenuShortcut类表示一个MenuItem的键盘加速器。

    使用虚拟键码而不是字符创建菜单快捷方式。 例如，将使用以下代码创建Ctrl-a的菜单快捷方式（假设Control是加速键）

    MenuShortcut ms = new MenuShortcut(KeyEvent.VK_A, false);

    或者替代地

    MenuShortcut ms = new MenuShortcut(KeyEvent.getExtendedKeyCodeForChar('A'), false);

    还可以使用java.awt.event.KeyEvent.getExtendedKeyCodeForChar通话为更广泛的键码组构建菜单快捷方式。 例如，创建“Ctrl + cyrillic ef”的菜单快捷方式

    MenuShortcut ms = new MenuShortcut(KeyEvent.getExtendedKeyCodeForChar('?'), false);

    请注意，在KeyEvent ，使用键码或扩展键码定义的常量创建的快捷方式与当前键盘布局无关。 但是，由KeyEvent未列出的扩展键码组成的快捷方式仅在当前键盘布局生成相应的字母时才起作用。

    加速键与平台有关，可通过Toolkit.getMenuShortcutKeyMask()获得。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MenuShortcut​(int key)
      为指定的虚拟键码构造一个新的MenuShortcut。
      MenuShortcut​(int key, boolean useShiftModifier)
      为指定的虚拟键码构造一个新的MenuShortcut。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(MenuShortcut s)
      返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。
      boolean equals​(Object obj)
      返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。
      int getKey​()
      返回此MenuShortcut的原始密码。
      int hashCode​()
      返回此MenuShortcut的哈希码。
      protected String paramString​()
      返回表示此MenuShortcut状态的参数字符串。
      String toString​()
      返回MenuShortcut的国际化描述。
      boolean usesShiftModifier​()
      返回是否必须使用SHIFT键调用该MenuShortcut。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MenuShortcut

        public MenuShortcut​(int key)
        为指定的虚拟键码构造一个新的MenuShortcut。
        参数
        key - 这个MenuShortcut的原始键码，如果这个键被按下，将在KeyEvent的keyCode字段中返回。
        另请参见：
        KeyEvent

      • MenuShortcut

        public MenuShortcut​(int key,
                    boolean useShiftModifier)
        为指定的虚拟键码构造一个新的MenuShortcut。
        参数
        key - 这个MenuShortcut的原始键码，如果该键被按下，将在KeyEvent的keyCode字段中返回。
        useShiftModifier - 指示是否使用SHIFT键调用此MenuShortcut。
        另请参见：
        KeyEvent

    • 方法详细信息

      • getKey

        public int getKey​()
        返回此MenuShortcut的原始密码。
        结果
        这个MenuShortcut的原始键码。
        从以下版本开始：
        1.1
        另请参见：
        KeyEvent

      • usesShiftModifier

        public boolean usesShiftModifier​()
        返回是否必须使用SHIFT键调用该MenuShortcut。
        结果
        true如果这个MenuShortcut必须使用SHIFT键调用，否则为 false 。
        从以下版本开始：
        1.1

      • equals

        public boolean equals​(MenuShortcut s)
        返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。
        参数
        s - 与此 s MenuShortcut。
        结果
        true如果这个MenuShortcut与另一个相同， false否则。
        从以下版本开始：
        1.1

      • equals

        public boolean equals​(Object obj)
        返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。
        重写：
        equals在 Object
        参数
        obj - 与之对比的对象。
        结果
        true如果这个MenuShortcut是一样的，否则 false 。
        从以下版本开始：
        1.2
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此MenuShortcut的哈希码。
        重写：
        hashCode在 Object
        结果
        这个MenuShortcut的哈希码。
        从以下版本开始：
        1.2
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回MenuShortcut的国际化描述。
        重写：
        toString在 Object
        结果
        这个MenuShortcut的字符串表示形式。
        从以下版本开始：
        1.1

      • paramString

        protected String paramString​()
        返回表示此MenuShortcut状态的参数字符串。 此字符串对于调试很有用。
        结果
        该MenuShortcut的参数字符串。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MouseInfo

  • java.lang.Object
    • java.awt.MouseInfo

  • public class MouseInfo
extends Object
    MouseInfo提供了获取鼠标信息的方法，如鼠标指针位置和鼠标按键数量。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static int getNumberOfButtons​()
      返回鼠标的按钮数量。
      static PointerInfo getPointerInfo​()
      返回表示鼠标指针当前位置的 PointerInfo实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getPointerInfo

        public static PointerInfo getPointerInfo​()
                                  throws HeadlessException
        返回表示鼠标指针当前位置的PointerInfo实例。 GraphicsDevice存储在此PointerInfo包含鼠标指针。 用于鼠标位置的坐标系取决于GraphicsDevice是否是虚拟屏幕设备的一部分。 对于虚拟屏幕设备，坐标在虚拟坐标系中给出，否则返回到GraphicsDevice的坐标系中。 有关虚拟屏幕设备的更多信息，请参阅GraphicsConfiguration 。 在没有鼠标的系统上，返回null 。

        如果有安全管理器，则在创建和返回PointerInfo对象之前，其checkPermission方法将被调用AWTPermission("watchMousePointer")权限。 这可能会导致一个SecurityException 。

        结果
        鼠标指针的位置
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许操作
        从以下版本开始：
        1.5
        另请参见：
        GraphicsConfiguration ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • getNumberOfButtons

        public static int getNumberOfButtons​()
                              throws HeadlessException
        返回鼠标的按钮数量。 在没有鼠标的系统上，返回-1 。 通过请求由底层本机平台设置的"awt.mouse.numButtons"桌面属性，可从AWT Toolkit获取按钮数量。
        结果
        鼠标的按钮数量
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.5
        另请参见：
        Toolkit.getDesktopProperty(java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MultipleGradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class MultipleGradientPaint

  • java.lang.Object
    • java.awt.MultipleGradientPaint
  • All Implemented Interfaces:
    Paint ， Transparency
    已知直接子类：
    LinearGradientPaint ， RadialGradientPaint

    public abstract class MultipleGradientPaint
extends Object
implements Paint
    这是Paints的超类，它使用多色渐变填充其栅格。 它为LinearGradientPaint和RadialGradientPaint共同的变量和枚举值提供存储。
    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  MultipleGradientPaint.ColorSpaceType
      执行渐变插值的颜色空间。
      static class  MultipleGradientPaint.CycleMethod
      绘画之外使用的方法边界渐变。

    • Field Summary

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Color[] getColors​()
      返回此梯度使用的颜色数组的副本。
      MultipleGradientPaint.ColorSpaceType getColorSpace​()
      返回枚举类型，它指定插值的颜色空间。
      MultipleGradientPaint.CycleMethod getCycleMethod​()
      返回指定循环行为的枚举类型。
      float[] getFractions​()
      返回此梯度使用的浮点数组的副本以计算颜色分布。
      AffineTransform getTransform​()
      返回应用于渐变的变换的副本。
      int getTransparency​()
      返回此 Paint对象的透明度模式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.awt.Paint

        createContext

    • 方法详细信息

      • getFractions

        public final float[] getFractions​()
        返回此梯度使用的浮点数组的副本以计算颜色分布。 返回的数组始终有0作为其第一个值，1作为其最后一个值，其间值越大。
        结果
        该梯度用于计算颜色分布的浮点数组的副本

      • getColors

        public final Color[] getColors​()
        返回此梯度使用的颜色数组的副本。 第一个颜色映射到分数数组中的第一个值，最后一个颜色映射到分数数组中的最后一个值。
        结果
        该梯度使用的颜色数组的副本

      • getCycleMethod

        public final MultipleGradientPaint.CycleMethod getCycleMethod​()
        返回指定循环行为的枚举类型。
        结果
        指定循环行为的枚举类型

      • getColorSpace

        public final MultipleGradientPaint.ColorSpaceType getColorSpace​()
        返回枚举类型，它指定插值的颜色空间。
        结果
        枚举类型，用于指定插值的颜色空间

      • getTransform

        public final AffineTransform getTransform​()
        返回应用于渐变的变换的副本。

        请注意，如果在创建梯形时不应用变换，则使用标识变换。

        结果
        应用于渐变的变换的副本

      • getTransparency

        public final int getTransparency​()
        返回此 Paint对象的透明度模式。
        Specified by:
        getTransparency在接口 Transparency
        结果
        OPAQUE如果此 Paint对象使用的所有颜色都不透明，则 TRANSLUCENT如果 Paint对象使用的颜色中至少有一种不是不透明的。
        另请参见：
        Transparency
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MultipleGradientPaint.ColorSpaceType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum MultipleGradientPaint.ColorSpaceType

  • java.lang.Object
    • java.lang.Enum<MultipleGradientPaint.ColorSpaceType>
      • java.awt.MultipleGradientPaint.ColorSpaceType
  • All Implemented Interfaces:
    Serializable ， Comparable<MultipleGradientPaint.ColorSpaceType>
    Enclosing class:
    MultipleGradientPaint

    public static enum MultipleGradientPaint.ColorSpaceType
extends Enum<MultipleGradientPaint.ColorSpaceType>
    执行渐变插值的颜色空间。
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      LINEAR_RGB
      表示颜色插值应发生在线性化的RGB空间中。
      SRGB
      表示颜色插值应发生在sRGB空间中。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static MultipleGradientPaint.ColorSpaceType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MultipleGradientPaint.ColorSpaceType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SRGB

        public static final MultipleGradientPaint.ColorSpaceType SRGB
        表示颜色插值应发生在sRGB空间中。

      • LINEAR_RGB

        public static final MultipleGradientPaint.ColorSpaceType LINEAR_RGB
        表示颜色插值应发生在线性化的RGB空间中。

    • 方法详细信息

      • values

        public static MultipleGradientPaint.ColorSpaceType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MultipleGradientPaint.ColorSpaceType c : MultipleGradientPaint.ColorSpaceType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MultipleGradientPaint.ColorSpaceType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


MultipleGradientPaint.CycleMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum MultipleGradientPaint.CycleMethod

  • java.lang.Object
    • java.lang.Enum<MultipleGradientPaint.CycleMethod>
      • java.awt.MultipleGradientPaint.CycleMethod
  • All Implemented Interfaces:
    Serializable ， Comparable<MultipleGradientPaint.CycleMethod>
    Enclosing class:
    MultipleGradientPaint

    public static enum MultipleGradientPaint.CycleMethod
extends Enum<MultipleGradientPaint.CycleMethod>
    绘画之外使用的方法边界渐变。
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NO_CYCLE
      使用终端颜色填充剩余的区域。
      REFLECT
      循环渐变颜色从头到尾，结束开始填充剩余的区域。
      REPEAT
      以渐变颜色从头到尾循环，从头到尾填充剩余的区域。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static MultipleGradientPaint.CycleMethod valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MultipleGradientPaint.CycleMethod[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NO_CYCLE

        public static final MultipleGradientPaint.CycleMethod NO_CYCLE
        使用终端颜色填充剩余的区域。

      • REFLECT

        public static final MultipleGradientPaint.CycleMethod REFLECT
        循环渐变颜色从头到尾，结束开始填充剩余的区域。

      • REPEAT

        public static final MultipleGradientPaint.CycleMethod REPEAT
        以渐变颜色从头到尾循环，从头到尾填充剩余的区域。

    • 方法详细信息

      • values

        public static MultipleGradientPaint.CycleMethod[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MultipleGradientPaint.CycleMethod c : MultipleGradientPaint.CycleMethod.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MultipleGradientPaint.CycleMethod valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


PageAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PageAttributes

  • java.lang.Object
    • java.awt.PageAttributes
  • All Implemented Interfaces:
    Cloneable

    public final class PageAttributes
extends Object
implements Cloneable
    一组控制打印页面输出的属性。

    该类的实例控制使用实例的每个页面的颜色状态，纸张尺寸（介质类型），方向，逻辑原点，打印质量和分辨率。 如果可能，属性名称符合Internet打印协议（IPP）1.1。 属性值在可能的情况下是部分兼容的。

    要使用一个接受内部类类型的方法，请将引用传递给内部类的一个常量字段。 客户端代码不能创建内部类类型的新实例，因为这些类都不具有公共构造函数。 例如，要将颜色状态设置为单色，请使用以下代码：

      import java.awt.PageAttributes;

 public class MonochromeExample {
     public void setMonochrome(PageAttributes pageAttributes) {
         pageAttributes.setColor(PageAttributes.ColorType.MONOCHROME);
     }
 }

    支持attributeName -default值的每个IPP属性都具有相应的setattributeNameToDefault方法。 未提供默认值字段。

    从以下版本开始：
    1.3

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  PageAttributes.ColorType
      可能的颜色状态的类型安全枚举。
      static class  PageAttributes.MediaType
      可能的纸张尺寸的类型安全枚举。
      static class  PageAttributes.OrientationRequestedType
      可能的方向的类型安全的枚举。
      static class  PageAttributes.OriginType
      可能来源的类型安全枚举。
      static class  PageAttributes.PrintQualityType
      可能的打印质量的类型安全枚举。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PageAttributes​()
      为每个属性构造具有默认值的PageAttributes实例。
      PageAttributes​(PageAttributes obj)
      构造一个PageAttributes实例，它是提供的PageAttributes的副本。
      PageAttributes​(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
      为每个属性构造一个具有指定值的PageAttributes实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建并返回此PageAttributes的副本。
      boolean equals​(Object obj)
      确定两个PageAttributes是否相等。
      PageAttributes.ColorType getColor​()
      返回是否使用这些属性的页面将以彩色或单色呈现。
      PageAttributes.MediaType getMedia​()
      返回使用这些属性的页面的纸张大小。
      PageAttributes.OrientationRequestedType getOrientationRequested​()
      返回使用这些属性的页面的打印方向。
      PageAttributes.OriginType getOrigin​()
      返回是否使用这些属性绘制（0,0）到页面的物理页面的左上角或可打印区域的左上角。
      int[] getPrinterResolution​()
      返回使用这些属性的页面的打印分辨率。
      PageAttributes.PrintQualityType getPrintQuality​()
      使用这些属性返回页面的打印质量。
      int hashCode​()
      返回此PageAttributes的哈希码值。
      void set​(PageAttributes obj)
      将此PageAttributes的所有属性设置为与obj的属性相同的值。
      void setColor​(PageAttributes.ColorType color)
      指定使用这些属性的页面是否以彩色或单色呈现。
      void setMedia​(PageAttributes.MediaType media)
      使用这些属性为页面指定所需的纸张尺寸。
      void setMediaToDefault​()
      将使用这些属性的页面的纸张大小设置为默认语言环境的默认大小。
      void setOrientationRequested​(int orientationRequested)
      指定使用这些属性的页面的打印方向。
      void setOrientationRequested​(PageAttributes.OrientationRequestedType orientationRequested)
      指定使用这些属性的页面的打印方向。
      void setOrientationRequestedToDefault​()
      将使用这些属性的页面的打印方向设置为默认值。
      void setOrigin​(PageAttributes.OriginType origin)
      指定使用这些属性绘制（0，0）到页面是否绘制在物理页面的左上角或可打印区域的左上角。
      void setPrinterResolution​(int printerResolution)
      使用这些属性为页面指定所需的交叉进给和每英寸点数的进纸打印分辨率。
      void setPrinterResolution​(int[] printerResolution)
      使用这些属性为页面指定所需的打印分辨率。
      void setPrinterResolutionToDefault​()
      将使用这些属性的页面的打印机分辨率设置为默认值。
      void setPrintQuality​(int printQuality)
      使用这些属性指定页面的打印质量。
      void setPrintQuality​(PageAttributes.PrintQualityType printQuality)
      使用这些属性指定页面的打印质量。
      void setPrintQualityToDefault​()
      将使用这些属性的页面的打印质量设置为默认值。
      String toString​()
      返回此PageAttributes的字符串表示形式。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PageAttributes

        public PageAttributes​()
        为每个属性构造具有默认值的PageAttributes实例。

      • PageAttributes

        public PageAttributes​(PageAttributes obj)
        构造一个PageAttributes实例，它是提供的PageAttributes的副本。
        参数
        obj - 要复制的PageAttributes。

      • PageAttributes

        public PageAttributes​(PageAttributes.ColorType color,
                      PageAttributes.MediaType media,
                      PageAttributes.OrientationRequestedType orientationRequested,
                      PageAttributes.OriginType origin,
                      PageAttributes.PrintQualityType printQuality,
                      int[] printerResolution)
        为每个属性构造一个具有指定值的PageAttributes实例。
        参数
        color - ColorType.COLOR或ColorType.MONOCHROME。
        media - MediaType类的常量字段之一。
        orientationRequested - OrientationRequestedType.PORTRAIT或OrientationRequestedType.LANDSCAPE。
        origin - OriginType.PHYSICAL或OriginType.PRINTABLE
        printQuality - PrintQualityType.DRAFT，PrintQualityType.NORMAL或PrintQualityType.HIGH
        printerResolution - 3个元素的整数数组。 第一个元素必须大于0.第二个元素必须大于0.第三个元素必须是3或4 。
        异常
        IllegalArgumentException - 如果上述条件中的一个或多个被违反。

    • 方法详细信息

      • clone

        public Object clone​()
        创建并返回此PageAttributes的副本。
        重写：
        clone在 Object
        结果
        新创建的副本。 将此对象转换为PageAttributes是安全的。
        另请参见：
        Cloneable

      • set

        public void set​(PageAttributes obj)
        将此PageAttributes的所有属性设置为与obj的属性相同的值。
        参数
        obj - 要复制的PageAttributes。

      • getColor

        public PageAttributes.ColorType getColor​()
        返回是否使用这些属性的页面将以彩色或单色呈现。 此属性更新为用户选择的值。
        结果
        ColorType.COLOR或ColorType.MONOCHROME。

      • setColor

        public void setColor​(PageAttributes.ColorType color)
        指定使用这些属性的页面是否以彩色或单色呈现。 不指定此属性等同于指定ColorType.MONOCHROME。
        参数
        color - ColorType.COLOR或ColorType.MONOCHROME。
        异常
        IllegalArgumentException - 如果颜色为空。

      • getMedia

        public PageAttributes.MediaType getMedia​()
        返回使用这些属性的页面的纸张大小。 此属性更新为用户选择的值。
        结果
        MediaType类的常量字段之一。

      • setMedia

        public void setMedia​(PageAttributes.MediaType media)
        使用这些属性为页面指定所需的纸张尺寸。 实际的纸张尺寸将由目标打印机的限制来决定。 如果找不到完全匹配，则实现将选择最接近的匹配。 不指定此属性等同于为默认语言环境指定默认大小。 美国和加拿大的语言环境的默认大小是MediaType.NA_LETTER。 所有其他区域设置的默认大小为MediaType.ISO_A4。
        参数
        media - MediaType类的常量字段之一。
        异常
        IllegalArgumentException - 如果media为null。

      • setMediaToDefault

        public void setMediaToDefault​()
        将使用这些属性的页面的纸张大小设置为默认语言环境的默认大小。 美国和加拿大的语言环境的默认大小是MediaType.NA_LETTER。 所有其他区域设置的默认大小为MediaType.ISO_A4。

      • getOrientationRequested

        public PageAttributes.OrientationRequestedType getOrientationRequested​()
        返回使用这些属性的页面的打印方向。 此属性更新为用户选择的值。
        结果
        OrientationRequestedType.PORTRAIT或OrientationRequestedType.LANDSCAPE。

      • setOrientationRequested

        public void setOrientationRequested​(PageAttributes.OrientationRequestedType orientationRequested)
        指定使用这些属性的页面的打印方向。 不指定属性等同于指定OrientationRequestedType.PORTRAIT。
        参数
        orientationRequested - OrientationRequestedType.PORTRAIT或OrientationRequestedType.LANDSCAPE。
        异常
        IllegalArgumentException - 如果orientationRequested为空。

      • setOrientationRequested

        public void setOrientationRequested​(int orientationRequested)
        指定使用这些属性的页面的打印方向。 指定3表示纵向。 指定4表示景观。 指定任何其他值将生成IllegalArgumentException。 不指定属性等效于调用setOrientationRequested（OrientationRequestedType.PORTRAIT）。
        参数
        orientationRequested - 3或者 4
        异常
        IllegalArgumentException - 如果orientationRequested不是 3或 4

      • setOrientationRequestedToDefault

        public void setOrientationRequestedToDefault​()
        将使用这些属性的页面的打印方向设置为默认值。 默认方向是纵向。

      • getOrigin

        public PageAttributes.OriginType getOrigin​()
        返回是否使用这些属性绘制（0,0）到页面的物理页面的左上角或可打印区域的左上角。 （请注意，这些位置可能是等效的。）该属性不能由实现或目标打印机进行修改，也不受任何限制。
        结果
        OriginType.PHYSICAL或OriginType.PRINTABLE

      • setOrigin

        public void setOrigin​(PageAttributes.OriginType origin)
        指定使用这些属性绘制（0，0）到页面是否绘制在物理页面的左上角或可打印区域的左上角。 （请注意，这些位置可以是等效的。）不指定属性等同于指定OriginType.PHYSICAL。
        参数
        origin - OriginType.PHYSICAL或OriginType.PRINTABLE
        异常
        IllegalArgumentException - 如果origin为null。

      • getPrintQuality

        public PageAttributes.PrintQualityType getPrintQuality​()
        使用这些属性返回页面的打印质量。 此属性更新为用户选择的值。
        结果
        PrintQualityType.DRAFT，PrintQualityType.NORMAL或PrintQualityType.HIGH

      • setPrintQuality

        public void setPrintQuality​(PageAttributes.PrintQualityType printQuality)
        使用这些属性指定页面的打印质量。 不指定属性等同于指定PrintQualityType.NORMAL。
        参数
        printQuality - PrintQualityType.DRAFT，PrintQualityType.NORMAL或PrintQualityType.HIGH
        异常
        IllegalArgumentException - 如果printQuality为空。

      • setPrintQuality

        public void setPrintQuality​(int printQuality)
        使用这些属性指定页面的打印质量。 指定3表示草稿。 指定4表示正常。 指定5表示高。 指定任何其他值将生成IllegalArgumentException。 不指定属性等效于调用setPrintQuality（PrintQualityType.NORMAL）。
        参数
        printQuality - 3 ， 4 ，或 5
        异常
        IllegalArgumentException -如果打印质量不 3 ， 4 ，或 5

      • setPrintQualityToDefault

        public void setPrintQualityToDefault​()
        将使用这些属性的页面的打印质量设置为默认值。 默认的打印质量是正常的。

      • getPrinterResolution

        public int[] getPrinterResolution​()
        返回使用这些属性的页面的打印分辨率。 数组的索引0指定交叉进给方向分辨率（通常为水平分辨率）。 数组的索引1指定进给方向分辨率（通常为垂直分辨率）。 数组的索引2指定分辨率是每英寸点数还是每厘米点数。 3表示每英寸点数。 4表示每厘米点数。
        结果
        3个元素的整数数组。 第一个元素必须大于0.第二个元素必须大于0.第三个元素必须是3或4 。

      • setPrinterResolution

        public void setPrinterResolution​(int[] printerResolution)
        使用这些属性为页面指定所需的打印分辨率。 实际分辨率将由实现和目标打印机的限制来决定。 数组的索引0指定交叉进给方向分辨率（通常为水平分辨率）。 数组的索引1指定进给方向分辨率（通常为垂直分辨率）。 数组的索引2指定分辨率是每英寸点数还是每厘米点数。 3表示每英寸点数。 4表示每厘米点数。 请注意，1.1打印实现（Toolkit.getPrintJob）要求进纸和交叉进纸分辨率相同。 不指定属性等效于调用setPrinterResolution（72）。
        参数
        printerResolution - 3个元素的整数数组。 第一个元素必须大于0.第二个元素必须大于0.第三个元素必须是3或4 。
        异常
        IllegalArgumentException - 如果违反了上述一个或多个条件。

      • setPrinterResolution

        public void setPrinterResolution​(int printerResolution)
        使用这些属性为页面指定所需的交叉进给和每英寸点数的进纸打印分辨率。 两个分辨率都使用相同的值。 实际的分辨率将由实施的限制和目标打印机决定。 不指定属性等同于指定72 。
        参数
        printerResolution - 大于0的整数。
        异常
        IllegalArgumentException - 如果printerResolution小于或等于0。

      • setPrinterResolutionToDefault

        public void setPrinterResolutionToDefault​()
        将使用这些属性的页面的打印机分辨率设置为默认值。 进给和交叉进给分辨率的默认值为72 dpi。

      • equals

        public boolean equals​(Object obj)
        确定两个PageAttributes是否相等。

        当且仅当它们的每个属性相等时，两个PageAttributes是相等的。 枚举类型的属性当且仅当这些域引用相同的唯一枚举对象时相等。 这意味着别名的媒体与其底层的独特媒体相同。 当且仅当进给分辨率，交叉进给分辨率和单位相等时，打印机分辨率相等。

        重写：
        equals Object
        参数
        obj - 将检查其相等性的对象。
        结果
        根据上述标准，obj是否等于此PageAttribute。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此PageAttributes的哈希码值。
        重写：
        hashCode在 Object
        结果
        哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此PageAttributes的字符串表示形式。
        重写：
        toString在 Object
        结果
        字符串表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PageAttributes.ColorType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PageAttributes.ColorType

  • java.lang.Object
    • java.awt.PageAttributes.ColorType
  • Enclosing class:
    PageAttributes

    public static final class PageAttributes.ColorType
extends Object
    可能的颜色状态的类型安全枚举。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PageAttributes.ColorType COLOR
      用于指定彩色打印的ColorType实例。
      static PageAttributes.ColorType MONOCHROME
      用于指定单色打印的ColorType实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • COLOR

        public static final PageAttributes.ColorType COLOR
        用于指定彩色打印的ColorType实例。

      • MONOCHROME

        public static final PageAttributes.ColorType MONOCHROME
        用于指定单色打印的ColorType实例。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals对比中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本上表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PageAttributes.MediaType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PageAttributes.MediaType

  • java.lang.Object
    • java.awt.PageAttributes.MediaType
  • Enclosing class:
    PageAttributes

    public static final class PageAttributes.MediaType
extends Object
    可能的纸张尺寸的类型安全枚举。 这些尺寸符合IPP 1.1。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PageAttributes.MediaType A
      Engineering A的MediaType实例，8 1/2 x 11 in。
      static PageAttributes.MediaType A0
      ISO_A0的别名。
      static PageAttributes.MediaType A1
      ISO_A1的别名。
      static PageAttributes.MediaType A10
      ISO_A10的别名。
      static PageAttributes.MediaType A2
      ISO_A2的别名。
      static PageAttributes.MediaType A3
      ISO_A3的别名。
      static PageAttributes.MediaType A4
      ISO_A4的别名。
      static PageAttributes.MediaType A5
      ISO_A5的别名。
      static PageAttributes.MediaType A6
      ISO_A6的别名。
      static PageAttributes.MediaType A7
      ISO_A7的别名。
      static PageAttributes.MediaType A8
      ISO_A8的别名。
      static PageAttributes.MediaType A9
      ISO_A9的别名。
      static PageAttributes.MediaType B
      Engineering B的MediaType实例，11 x 17 in。
      static PageAttributes.MediaType B0
      ISO_B0的别名。
      static PageAttributes.MediaType B1
      ISO_B1的别名。
      static PageAttributes.MediaType B10
      ISO_B10的别名。
      static PageAttributes.MediaType B2
      ISO_B2的别名。
      static PageAttributes.MediaType B3
      ISO_B3的别名。
      static PageAttributes.MediaType B4
      ISO_B4的别名。
      static PageAttributes.MediaType B5
      ISO_B5的别名。
      static PageAttributes.MediaType B6
      ISO_B6的别名。
      static PageAttributes.MediaType B7
      ISO_B7的别名。
      static PageAttributes.MediaType B8
      ISO_B8的别名。
      static PageAttributes.MediaType B9
      ISO_B9的别名。
      static PageAttributes.MediaType C
      Engineering C的MediaType实例，17 x 22 in。
      static PageAttributes.MediaType C0
      ISO_C0的别名。
      static PageAttributes.MediaType C1
      ISO_C1的别名。
      static PageAttributes.MediaType C10
      ISO_C10的别名。
      static PageAttributes.MediaType C2
      ISO_C2的别名。
      static PageAttributes.MediaType C3
      ISO_C3的别名。
      static PageAttributes.MediaType C4
      ISO_C4的别名。
      static PageAttributes.MediaType C5
      ISO_C5的别名。
      static PageAttributes.MediaType C6
      ISO_C6的别名。
      static PageAttributes.MediaType C7
      ISO_C7的别名。
      static PageAttributes.MediaType C8
      ISO_C8的别名。
      static PageAttributes.MediaType C9
      ISO_C9的别名。
      static PageAttributes.MediaType D
      Engineering D的MediaType实例，22 x 34 in。
      static PageAttributes.MediaType E
      Engineering E的MediaType实例，34 x 44 in。
      static PageAttributes.MediaType ENV_10
      NA_NUMBER_10_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_10X13
      NA_10X13_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_10X14
      NA_10X14_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_10X15
      NA_10X15_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_11
      NA_NUMBER_11_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_12
      NA_NUMBER_12_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_14
      NA_NUMBER_14_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_6X9
      NA_6X9_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_7X9
      NA_7X9_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_9
      NA_NUMBER_9_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_9X11
      NA_9X11_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_9X12
      NA_9X12_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_INVITE
      INVITE_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_ITALY
      ITALY_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_MONARCH
      MONARCH_ENVELOPE的别名。
      static PageAttributes.MediaType ENV_PERSONAL
      PERSONAL_ENVELOPE的别名。
      static PageAttributes.MediaType EXECUTIVE
      Executive的MediaType实例，7 1/4 x 10 1/2 in。
      static PageAttributes.MediaType FOLIO
      Folio的MediaType实例，8 1/2 x 13 in。
      static PageAttributes.MediaType INVITE
      INVITE_ENVELOPE的别名。
      static PageAttributes.MediaType INVITE_ENVELOPE
      邀请信封的MediaType实例，220 x 220毫米。
      static PageAttributes.MediaType INVOICE
      发票的MediaType实例，5 1/2 x 8 1/2 in。
      static PageAttributes.MediaType ISO_2A0
      用于ISO / DIN和JIS 2A0的MediaType实例，1189 x 1682 mm。
      static PageAttributes.MediaType ISO_4A0
      用于ISO / DIN和JIS 4A0的MediaType实例，1682 x 2378 mm。
      static PageAttributes.MediaType ISO_A0
      用于ISO / DIN和JIS A0的MediaType实例，841 x 1189 mm。
      static PageAttributes.MediaType ISO_A1
      用于ISO / DIN和JIS A1的MediaType实例，为594 x 841 mm。
      static PageAttributes.MediaType ISO_A10
      用于ISO / DIN和JIS A10的MediaType实例，26 x 37 mm。
      static PageAttributes.MediaType ISO_A2
      用于ISO / DIN和JIS A2的MediaType实例，420 x 594 mm。
      static PageAttributes.MediaType ISO_A3
      用于ISO / DIN和JIS A3的MediaType实例，297 x 420 mm。
      static PageAttributes.MediaType ISO_A4
      用于ISO / DIN和JIS A4的MediaType实例，210 x 297 mm。
      static PageAttributes.MediaType ISO_A5
      用于ISO / DIN和JIS A5的MediaType实例，148 x 210 mm。
      static PageAttributes.MediaType ISO_A6
      用于ISO / DIN和JIS A6的MediaType实例，105 x 148 mm。
      static PageAttributes.MediaType ISO_A7
      用于ISO / DIN和JIS A7的MediaType实例，74 x 105 mm。
      static PageAttributes.MediaType ISO_A8
      用于ISO / DIN和JIS A8的MediaType实例，52 x 74 mm。
      static PageAttributes.MediaType ISO_A9
      用于ISO / DIN和JIS A9的MediaType实例，37 x 52 mm。
      static PageAttributes.MediaType ISO_B0
      用于ISO / DIN B0，1000 x 1414 mm的MediaType实例。
      static PageAttributes.MediaType ISO_B1
      用于ISO / DIN B1，707 x 1000 mm的MediaType实例。
      static PageAttributes.MediaType ISO_B10
      用于ISO / DIN B10的MediaType实例，31 x 44 mm。
      static PageAttributes.MediaType ISO_B2
      用于ISO / DIN B2的MediaType实例，500 x 707 mm。
      static PageAttributes.MediaType ISO_B3
      ISO / DIN B3的MediaType实例，353 x 500 mm。
      static PageAttributes.MediaType ISO_B4
      用于ISO / DIN B4的MediaType实例，250 x 353 mm。
      static PageAttributes.MediaType ISO_B4_ENVELOPE
      ISO_B4的别名。
      static PageAttributes.MediaType ISO_B5
      用于ISO / DIN B5的介质类型实例，176 x 250 mm。
      static PageAttributes.MediaType ISO_B5_ENVELOPE
      ISO_B5的别名。
      static PageAttributes.MediaType ISO_B6
      用于ISO / DIN B6的MediaType实例，125 x 176 mm。
      static PageAttributes.MediaType ISO_B7
      用于ISO / DIN B7的MediaType实例，88 x 125 mm。
      static PageAttributes.MediaType ISO_B8
      用于ISO / DIN B8的MediaType实例，62 x 88 mm。
      static PageAttributes.MediaType ISO_B9
      用于ISO / DIN B9的MediaType实例，44 x 62 mm。
      static PageAttributes.MediaType ISO_C0
      用于ISO / DIN C0的MediaType实例，917 x 1297 mm。
      static PageAttributes.MediaType ISO_C0_ENVELOPE
      ISO_C0的别名。
      static PageAttributes.MediaType ISO_C1
      用于ISO / DIN C1的MediaType实例，648 x 917 mm。
      static PageAttributes.MediaType ISO_C1_ENVELOPE
      ISO_C1的别名。
      static PageAttributes.MediaType ISO_C10
      用于ISO / DIN C10的MediaType实例，28 x 40 mm。
      static PageAttributes.MediaType ISO_C10_ENVELOPE
      ISO_C10的别名。
      static PageAttributes.MediaType ISO_C2
      用于ISO / DIN C2的MediaType实例，458 x 648 mm。
      static PageAttributes.MediaType ISO_C2_ENVELOPE
      ISO_C2的别名。
      static PageAttributes.MediaType ISO_C3
      用于ISO / DIN C3的MediaType实例，324 x 458 mm。
      static PageAttributes.MediaType ISO_C3_ENVELOPE
      ISO_C3的别名。
      static PageAttributes.MediaType ISO_C4
      ISO / DIN C4的MediaType实例，229 x 324 mm。
      static PageAttributes.MediaType ISO_C4_ENVELOPE
      ISO_C4的别名。
      static PageAttributes.MediaType ISO_C5
      用于ISO / DIN C5的MediaType实例，162 x 229 mm。
      static PageAttributes.MediaType ISO_C5_ENVELOPE
      ISO_C5的别名。
      static PageAttributes.MediaType ISO_C6
      用于ISO / DIN C6的MediaType实例，114 x 162 mm。
      static PageAttributes.MediaType ISO_C6_ENVELOPE
      ISO_C6的别名。
      static PageAttributes.MediaType ISO_C7
      用于ISO / DIN C7的MediaType实例，81 x 114 mm。
      static PageAttributes.MediaType ISO_C7_ENVELOPE
      ISO_C7的别名。
      static PageAttributes.MediaType ISO_C8
      用于ISO / DIN C8的MediaType实例，57 x 81 mm。
      static PageAttributes.MediaType ISO_C8_ENVELOPE
      ISO_C8的别名。
      static PageAttributes.MediaType ISO_C9
      用于ISO / DIN C9的MediaType实例，40 x 57 mm。
      static PageAttributes.MediaType ISO_C9_ENVELOPE
      ISO_C9的别名。
      static PageAttributes.MediaType ISO_DESIGNATED_LONG
      ISO指定长的介质类型实例，110 x 220 mm。
      static PageAttributes.MediaType ISO_DESIGNATED_LONG_ENVELOPE
      ISO_DESIGNATED_LONG的别名。
      static PageAttributes.MediaType ITALY
      ITALY_ENVELOPE的别名。
      static PageAttributes.MediaType ITALY_ENVELOPE
      意大利信封的MediaType实例，110 x 230毫米。
      static PageAttributes.MediaType JIS_B0
      JIS B0的MediaType实例，1030 x 1456 mm。
      static PageAttributes.MediaType JIS_B1
      JIS B1的MediaType实例，728 x 1030 mm。
      static PageAttributes.MediaType JIS_B10
      JIS B10的MediaType实例，32 x 45 mm。
      static PageAttributes.MediaType JIS_B2
      JIS B2的MediaType实例，515 x 728 mm。
      static PageAttributes.MediaType JIS_B3
      JIS B3的MediaType实例，364 x 515毫米。
      static PageAttributes.MediaType JIS_B4
      JIS B4的MediaType实例，257 x 364 mm。
      static PageAttributes.MediaType JIS_B5
      JIS B5的MediaType实例，182 x 257 mm。
      static PageAttributes.MediaType JIS_B6
      JIS B6的MediaType实例，128 x 182 mm。
      static PageAttributes.MediaType JIS_B7
      用于JIS B7的MediaType实例，91 x 128 mm。
      static PageAttributes.MediaType JIS_B8
      用于JIS B8的MediaType实例，64 x 91毫米。
      static PageAttributes.MediaType JIS_B9
      JIS B9的MediaType实例，45 x 64 mm。
      static PageAttributes.MediaType LEDGER
      Ledger的MediaType实例，11 x 17 in。
      static PageAttributes.MediaType LEGAL
      NA_LEGAL的别名。
      static PageAttributes.MediaType LETTER
      NA_LETTER的别名。
      static PageAttributes.MediaType MONARCH
      MONARCH_ENVELOPE的别名。
      static PageAttributes.MediaType MONARCH_ENVELOPE
      Monarch Envelope的MediaType实例，3 7/8 x 7 1/2 in。
      static PageAttributes.MediaType NA_10X13_ENVELOPE
      MediaType实例为北美10 x 13 in。
      static PageAttributes.MediaType NA_10X14_ENVELOPE
      北美10 x 14英寸的MediaType实例。
      static PageAttributes.MediaType NA_10X15_ENVELOPE
      MediaType实例为北美10 x 15英寸
      static PageAttributes.MediaType NA_6X9_ENVELOPE
      北美6 x 9的MediaType实例。
      static PageAttributes.MediaType NA_7X9_ENVELOPE
      北美7 x 9英寸的MediaType实例。
      static PageAttributes.MediaType NA_9X11_ENVELOPE
      北美9 x 11英寸的MediaType实例
      static PageAttributes.MediaType NA_9X12_ENVELOPE
      北美9 x 12英寸的MediaType实例
      static PageAttributes.MediaType NA_LEGAL
      北美法律的MediaType实例，8 1/2 x 14英寸
      static PageAttributes.MediaType NA_LETTER
      北美信的MediaType实例，8 1/2 x 11 in。
      static PageAttributes.MediaType NA_NUMBER_10_ENVELOPE
      North America＃10 Business Envelope的MediaType实例，4 1/8 x 9 1/2 in。
      static PageAttributes.MediaType NA_NUMBER_11_ENVELOPE
      北美＃11商业信封的MediaType实例，4 1/2 x 10 3/8 in。
      static PageAttributes.MediaType NA_NUMBER_12_ENVELOPE
      北美＃12商业信封的MediaType实例，4 3/4 x 11英寸
      static PageAttributes.MediaType NA_NUMBER_14_ENVELOPE
      North American＃14 Business Envelope的MediaType实例，5 x 11 1/2 in。
      static PageAttributes.MediaType NA_NUMBER_9_ENVELOPE
      北美＃9商业信封的MediaType实例，3 7/8 x 8 7/8 in。
      static PageAttributes.MediaType NOTE
      NA_LETTER的别名。
      static PageAttributes.MediaType PERSONAL
      PERSONAL_ENVELOPE的别名。
      static PageAttributes.MediaType PERSONAL_ENVELOPE
      6 3/4信封的MediaType实例，3 5/8 x 6 1/2 in。
      static PageAttributes.MediaType QUARTO
      Quarto的MediaType实例，215 x 275 mm。
      static PageAttributes.MediaType STATEMENT
      INVOICE的别名。
      static PageAttributes.MediaType TABLOID
      LEDGER的别名。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ISO_4A0

        public static final PageAttributes.MediaType ISO_4A0
        用于ISO / DIN和JIS 4A0的MediaType实例，1682 x 2378 mm。

      • ISO_2A0

        public static final PageAttributes.MediaType ISO_2A0
        用于ISO / DIN和JIS 2A0的MediaType实例，1189 x 1682 mm。

      • ISO_A0

        public static final PageAttributes.MediaType ISO_A0
        用于ISO / DIN和JIS A0的MediaType实例，841 x 1189 mm。

      • ISO_A1

        public static final PageAttributes.MediaType ISO_A1
        用于ISO / DIN和JIS A1的MediaType实例，为594 x 841 mm。

      • ISO_A2

        public static final PageAttributes.MediaType ISO_A2
        用于ISO / DIN和JIS A2的MediaType实例，420 x 594 mm。

      • ISO_A3

        public static final PageAttributes.MediaType ISO_A3
        用于ISO / DIN和JIS A3的MediaType实例，297 x 420 mm。

      • ISO_A4

        public static final PageAttributes.MediaType ISO_A4
        用于ISO / DIN和JIS A4的MediaType实例，210 x 297 mm。

      • ISO_A5

        public static final PageAttributes.MediaType ISO_A5
        用于ISO / DIN和JIS A5的MediaType实例，148 x 210 mm。

      • ISO_A6

        public static final PageAttributes.MediaType ISO_A6
        用于ISO / DIN和JIS A6的MediaType实例，105 x 148 mm。

      • ISO_A7

        public static final PageAttributes.MediaType ISO_A7
        用于ISO / DIN和JIS A7的MediaType实例，74 x 105 mm。

      • ISO_A8

        public static final PageAttributes.MediaType ISO_A8
        用于ISO / DIN和JIS A8的MediaType实例，52 x 74 mm。

      • ISO_A9

        public static final PageAttributes.MediaType ISO_A9
        用于ISO / DIN和JIS A9的MediaType实例，37 x 52 mm。

      • ISO_A10

        public static final PageAttributes.MediaType ISO_A10
        用于ISO / DIN和JIS A10的MediaType实例，26 x 37 mm。

      • ISO_B0

        public static final PageAttributes.MediaType ISO_B0
        用于ISO / DIN B0，1000 x 1414 mm的MediaType实例。

      • ISO_B1

        public static final PageAttributes.MediaType ISO_B1
        用于ISO / DIN B1，707 x 1000 mm的MediaType实例。

      • ISO_B2

        public static final PageAttributes.MediaType ISO_B2
        用于ISO / DIN B2的MediaType实例，500 x 707 mm。

      • ISO_B3

        public static final PageAttributes.MediaType ISO_B3
        ISO / DIN B3的MediaType实例，353 x 500 mm。

      • ISO_B4

        public static final PageAttributes.MediaType ISO_B4
        用于ISO / DIN B4的MediaType实例，250 x 353 mm。

      • ISO_B5

        public static final PageAttributes.MediaType ISO_B5
        用于ISO / DIN B5的介质类型实例，176 x 250 mm。

      • ISO_B6

        public static final PageAttributes.MediaType ISO_B6
        用于ISO / DIN B6的MediaType实例，125 x 176 mm。

      • ISO_B7

        public static final PageAttributes.MediaType ISO_B7
        用于ISO / DIN B7的MediaType实例，88 x 125 mm。

      • ISO_B8

        public static final PageAttributes.MediaType ISO_B8
        用于ISO / DIN B8的MediaType实例，62 x 88 mm。

      • ISO_B9

        public static final PageAttributes.MediaType ISO_B9
        用于ISO / DIN B9的MediaType实例，44 x 62 mm。

      • ISO_B10

        public static final PageAttributes.MediaType ISO_B10
        用于ISO / DIN B10的MediaType实例，31 x 44 mm。

      • JIS_B0

        public static final PageAttributes.MediaType JIS_B0
        JIS B0的MediaType实例，1030 x 1456 mm。

      • JIS_B1

        public static final PageAttributes.MediaType JIS_B1
        JIS B1的MediaType实例，728 x 1030 mm。

      • JIS_B2

        public static final PageAttributes.MediaType JIS_B2
        JIS B2的MediaType实例，515 x 728 mm。

      • JIS_B3

        public static final PageAttributes.MediaType JIS_B3
        JIS B3的MediaType实例，364 x 515毫米。

      • JIS_B4

        public static final PageAttributes.MediaType JIS_B4
        JIS B4的MediaType实例，257 x 364 mm。

      • JIS_B5

        public static final PageAttributes.MediaType JIS_B5
        JIS B5的MediaType实例，182 x 257 mm。

      • JIS_B6

        public static final PageAttributes.MediaType JIS_B6
        JIS B6的MediaType实例，128 x 182 mm。

      • JIS_B7

        public static final PageAttributes.MediaType JIS_B7
        用于JIS B7的MediaType实例，91 x 128 mm。

      • JIS_B8

        public static final PageAttributes.MediaType JIS_B8
        用于JIS B8的MediaType实例，64 x 91毫米。

      • JIS_B9

        public static final PageAttributes.MediaType JIS_B9
        JIS B9的MediaType实例，45 x 64 mm。

      • JIS_B10

        public static final PageAttributes.MediaType JIS_B10
        JIS B10的MediaType实例，32 x 45 mm。

      • ISO_C0

        public static final PageAttributes.MediaType ISO_C0
        用于ISO / DIN C0的MediaType实例，917 x 1297 mm。

      • ISO_C1

        public static final PageAttributes.MediaType ISO_C1
        用于ISO / DIN C1的MediaType实例，648 x 917 mm。

      • ISO_C2

        public static final PageAttributes.MediaType ISO_C2
        用于ISO / DIN C2的MediaType实例，458 x 648 mm。

      • ISO_C3

        public static final PageAttributes.MediaType ISO_C3
        用于ISO / DIN C3的MediaType实例，324 x 458 mm。

      • ISO_C4

        public static final PageAttributes.MediaType ISO_C4
        ISO / DIN C4的MediaType实例，229 x 324 mm。

      • ISO_C5

        public static final PageAttributes.MediaType ISO_C5
        用于ISO / DIN C5的MediaType实例，162 x 229 mm。

      • ISO_C6

        public static final PageAttributes.MediaType ISO_C6
        用于ISO / DIN C6的MediaType实例，114 x 162 mm。

      • ISO_C7

        public static final PageAttributes.MediaType ISO_C7
        用于ISO / DIN C7的MediaType实例，81 x 114 mm。

      • ISO_C8

        public static final PageAttributes.MediaType ISO_C8
        用于ISO / DIN C8的MediaType实例，57 x 81 mm。

      • ISO_C9

        public static final PageAttributes.MediaType ISO_C9
        用于ISO / DIN C9的MediaType实例，40 x 57 mm。

      • ISO_C10

        public static final PageAttributes.MediaType ISO_C10
        用于ISO / DIN C10的MediaType实例，28 x 40 mm。

      • ISO_DESIGNATED_LONG

        public static final PageAttributes.MediaType ISO_DESIGNATED_LONG
        ISO指定长的介质类型实例，110 x 220 mm。

      • EXECUTIVE

        public static final PageAttributes.MediaType EXECUTIVE
        Executive的MediaType实例，7 1/4 x 10 1/2 in。

      • FOLIO

        public static final PageAttributes.MediaType FOLIO
        Folio的MediaType实例，8 1/2 x 13 in。

      • INVOICE

        public static final PageAttributes.MediaType INVOICE
        发票的MediaType实例，5 1/2 x 8 1/2 in。

      • LEDGER

        public static final PageAttributes.MediaType LEDGER
        Ledger的MediaType实例，11 x 17 in。

      • NA_LETTER

        public static final PageAttributes.MediaType NA_LETTER
        北美信的MediaType实例，8 1/2 x 11 in。

      • NA_LEGAL

        public static final PageAttributes.MediaType NA_LEGAL
        北美法律的MediaType实例，8 1/2 x 14英寸

      • QUARTO

        public static final PageAttributes.MediaType QUARTO
        Quarto的MediaType实例，215 x 275 mm。

      • A

        public static final PageAttributes.MediaType A
        Engineering A的MediaType实例，8 1/2 x 11 in。

      • B

        public static final PageAttributes.MediaType B
        Engineering B的MediaType实例，11 x 17 in。

      • C

        public static final PageAttributes.MediaType C
        Engineering C的MediaType实例，17 x 22 in。

      • D

        public static final PageAttributes.MediaType D
        Engineering D的MediaType实例，22 x 34 in。

      • E

        public static final PageAttributes.MediaType E
        Engineering E的MediaType实例，34 x 44 in。

      • NA_10X15_ENVELOPE

        public static final PageAttributes.MediaType NA_10X15_ENVELOPE
        MediaType实例为北美10 x 15英寸

      • NA_10X14_ENVELOPE

        public static final PageAttributes.MediaType NA_10X14_ENVELOPE
        北美10 x 14英寸的MediaType实例。

      • NA_10X13_ENVELOPE

        public static final PageAttributes.MediaType NA_10X13_ENVELOPE
        MediaType实例为北美10 x 13 in。

      • NA_9X12_ENVELOPE

        public static final PageAttributes.MediaType NA_9X12_ENVELOPE
        北美9 x 12英寸的MediaType实例

      • NA_9X11_ENVELOPE

        public static final PageAttributes.MediaType NA_9X11_ENVELOPE
        北美9 x 11英寸的MediaType实例

      • NA_7X9_ENVELOPE

        public static final PageAttributes.MediaType NA_7X9_ENVELOPE
        北美7 x 9英寸的MediaType实例。

      • NA_6X9_ENVELOPE

        public static final PageAttributes.MediaType NA_6X9_ENVELOPE
        北美6 x 9的MediaType实例。

      • NA_NUMBER_9_ENVELOPE

        public static final PageAttributes.MediaType NA_NUMBER_9_ENVELOPE
        北美＃9商业信封的MediaType实例，3 7/8 x 8 7/8 in。

      • NA_NUMBER_10_ENVELOPE

        public static final PageAttributes.MediaType NA_NUMBER_10_ENVELOPE
        North America＃10 Business Envelope的MediaType实例，4 1/8 x 9 1/2 in。

      • NA_NUMBER_11_ENVELOPE

        public static final PageAttributes.MediaType NA_NUMBER_11_ENVELOPE
        北美＃11商业信封的MediaType实例，4 1/2 x 10 3/8 in。

      • NA_NUMBER_12_ENVELOPE

        public static final PageAttributes.MediaType NA_NUMBER_12_ENVELOPE
        北美＃12商业信封的MediaType实例，4 3/4 x 11英寸

      • NA_NUMBER_14_ENVELOPE

        public static final PageAttributes.MediaType NA_NUMBER_14_ENVELOPE
        North American＃14 Business Envelope的MediaType实例，5 x 11 1/2 in。

      • INVITE_ENVELOPE

        public static final PageAttributes.MediaType INVITE_ENVELOPE
        邀请信封的MediaType实例，220 x 220毫米。

      • ITALY_ENVELOPE

        public static final PageAttributes.MediaType ITALY_ENVELOPE
        意大利信封的MediaType实例，110 x 230毫米。

      • MONARCH_ENVELOPE

        public static final PageAttributes.MediaType MONARCH_ENVELOPE
        Monarch Envelope的MediaType实例，3 7/8 x 7 1/2 in。

      • PERSONAL_ENVELOPE

        public static final PageAttributes.MediaType PERSONAL_ENVELOPE
        6 3/4信封的MediaType实例，3 5/8 x 6 1/2 in。

      • A0

        public static final PageAttributes.MediaType A0
        ISO_A0的别名。

      • A1

        public static final PageAttributes.MediaType A1
        ISO_A1的别名。

      • A2

        public static final PageAttributes.MediaType A2
        ISO_A2的别名。

      • A3

        public static final PageAttributes.MediaType A3
        ISO_A3的别名。

      • A4

        public static final PageAttributes.MediaType A4
        ISO_A4的别名。

      • A5

        public static final PageAttributes.MediaType A5
        ISO_A5的别名。

      • A6

        public static final PageAttributes.MediaType A6
        ISO_A6的别名。

      • A7

        public static final PageAttributes.MediaType A7
        ISO_A7的别名。

      • A8

        public static final PageAttributes.MediaType A8
        ISO_A8的别名。

      • A9

        public static final PageAttributes.MediaType A9
        ISO_A9的别名。

      • A10

        public static final PageAttributes.MediaType A10
        ISO_A10的别名。

      • B0

        public static final PageAttributes.MediaType B0
        ISO_B0的别名。

      • B1

        public static final PageAttributes.MediaType B1
        ISO_B1的别名。

      • B2

        public static final PageAttributes.MediaType B2
        ISO_B2的别名。

      • B3

        public static final PageAttributes.MediaType B3
        ISO_B3的别名。

      • B4

        public static final PageAttributes.MediaType B4
        ISO_B4的别名。

      • ISO_B4_ENVELOPE

        public static final PageAttributes.MediaType ISO_B4_ENVELOPE
        ISO_B4的别名。

      • B5

        public static final PageAttributes.MediaType B5
        ISO_B5的别名。

      • ISO_B5_ENVELOPE

        public static final PageAttributes.MediaType ISO_B5_ENVELOPE
        ISO_B5的别名。

      • B6

        public static final PageAttributes.MediaType B6
        ISO_B6的别名。

      • B7

        public static final PageAttributes.MediaType B7
        ISO_B7的别名。

      • B8

        public static final PageAttributes.MediaType B8
        ISO_B8的别名。

      • B9

        public static final PageAttributes.MediaType B9
        ISO_B9的别名。

      • B10

        public static final PageAttributes.MediaType B10
        ISO_B10的别名。

      • C0

        public static final PageAttributes.MediaType C0
        ISO_C0的别名。

      • ISO_C0_ENVELOPE

        public static final PageAttributes.MediaType ISO_C0_ENVELOPE
        ISO_C0的别名。

      • C1

        public static final PageAttributes.MediaType C1
        ISO_C1的别名。

      • ISO_C1_ENVELOPE

        public static final PageAttributes.MediaType ISO_C1_ENVELOPE
        ISO_C1的别名。

      • C2

        public static final PageAttributes.MediaType C2
        ISO_C2的别名。

      • ISO_C2_ENVELOPE

        public static final PageAttributes.MediaType ISO_C2_ENVELOPE
        ISO_C2的别名。

      • C3

        public static final PageAttributes.MediaType C3
        ISO_C3的别名。

      • ISO_C3_ENVELOPE

        public static final PageAttributes.MediaType ISO_C3_ENVELOPE
        ISO_C3的别名。

      • C4

        public static final PageAttributes.MediaType C4
        ISO_C4的别名。

      • ISO_C4_ENVELOPE

        public static final PageAttributes.MediaType ISO_C4_ENVELOPE
        ISO_C4的别名。

      • C5

        public static final PageAttributes.MediaType C5
        ISO_C5的别名。

      • ISO_C5_ENVELOPE

        public static final PageAttributes.MediaType ISO_C5_ENVELOPE
        ISO_C5的别名。

      • C6

        public static final PageAttributes.MediaType C6
        ISO_C6的别名。

      • ISO_C6_ENVELOPE

        public static final PageAttributes.MediaType ISO_C6_ENVELOPE
        ISO_C6的别名。

      • C7

        public static final PageAttributes.MediaType C7
        ISO_C7的别名。

      • ISO_C7_ENVELOPE

        public static final PageAttributes.MediaType ISO_C7_ENVELOPE
        ISO_C7的别名。

      • C8

        public static final PageAttributes.MediaType C8
        ISO_C8的别名。

      • ISO_C8_ENVELOPE

        public static final PageAttributes.MediaType ISO_C8_ENVELOPE
        ISO_C8的别名。

      • C9

        public static final PageAttributes.MediaType C9
        ISO_C9的别名。

      • ISO_C9_ENVELOPE

        public static final PageAttributes.MediaType ISO_C9_ENVELOPE
        ISO_C9的别名。

      • C10

        public static final PageAttributes.MediaType C10
        ISO_C10的别名。

      • ISO_C10_ENVELOPE

        public static final PageAttributes.MediaType ISO_C10_ENVELOPE
        ISO_C10的别名。

      • ISO_DESIGNATED_LONG_ENVELOPE

        public static final PageAttributes.MediaType ISO_DESIGNATED_LONG_ENVELOPE
        ISO_DESIGNATED_LONG的别名。

      • STATEMENT

        public static final PageAttributes.MediaType STATEMENT
        INVOICE的别名。

      • TABLOID

        public static final PageAttributes.MediaType TABLOID
        LEDGER的别名。

      • LETTER

        public static final PageAttributes.MediaType LETTER
        NA_LETTER的别名。

      • NOTE

        public static final PageAttributes.MediaType NOTE
        NA_LETTER的别名。

      • LEGAL

        public static final PageAttributes.MediaType LEGAL
        NA_LEGAL的别名。

      • ENV_10X15

        public static final PageAttributes.MediaType ENV_10X15
        NA_10X15_ENVELOPE的别名。

      • ENV_10X14

        public static final PageAttributes.MediaType ENV_10X14
        NA_10X14_ENVELOPE的别名。

      • ENV_10X13

        public static final PageAttributes.MediaType ENV_10X13
        NA_10X13_ENVELOPE的别名。

      • ENV_9X12

        public static final PageAttributes.MediaType ENV_9X12
        NA_9X12_ENVELOPE的别名。

      • ENV_9X11

        public static final PageAttributes.MediaType ENV_9X11
        NA_9X11_ENVELOPE的别名。

      • ENV_7X9

        public static final PageAttributes.MediaType ENV_7X9
        NA_7X9_ENVELOPE的别名。

      • ENV_6X9

        public static final PageAttributes.MediaType ENV_6X9
        NA_6X9_ENVELOPE的别名。

      • ENV_9

        public static final PageAttributes.MediaType ENV_9
        NA_NUMBER_9_ENVELOPE的别名。

      • ENV_10

        public static final PageAttributes.MediaType ENV_10
        NA_NUMBER_10_ENVELOPE的别名。

      • ENV_11

        public static final PageAttributes.MediaType ENV_11
        NA_NUMBER_11_ENVELOPE的别名。

      • ENV_12

        public static final PageAttributes.MediaType ENV_12
        NA_NUMBER_12_ENVELOPE的别名。

      • ENV_14

        public static final PageAttributes.MediaType ENV_14
        NA_NUMBER_14_ENVELOPE的别名。

      • ENV_INVITE

        public static final PageAttributes.MediaType ENV_INVITE
        INVITE_ENVELOPE的别名。

      • ENV_ITALY

        public static final PageAttributes.MediaType ENV_ITALY
        ITALY_ENVELOPE的别名。

      • ENV_MONARCH

        public static final PageAttributes.MediaType ENV_MONARCH
        MONARCH_ENVELOPE的别名。

      • ENV_PERSONAL

        public static final PageAttributes.MediaType ENV_PERSONAL
        PERSONAL_ENVELOPE的别名。

      • INVITE

        public static final PageAttributes.MediaType INVITE
        INVITE_ENVELOPE的别名。

      • ITALY

        public static final PageAttributes.MediaType ITALY
        ITALY_ENVELOPE的别名。

      • MONARCH

        public static final PageAttributes.MediaType MONARCH
        MONARCH_ENVELOPE的别名。

      • PERSONAL

        public static final PageAttributes.MediaType PERSONAL
        PERSONAL_ENVELOPE的别名。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PageAttributes.OrientationRequestedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PageAttributes.OrientationRequestedType

  • java.lang.Object
    • java.awt.PageAttributes.OrientationRequestedType
  • Enclosing class:
    PageAttributes

    public static final class PageAttributes.OrientationRequestedType
extends Object
    可能的方向的类型安全的枚举。 这些方向部分符合IPP 1.1。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PageAttributes.OrientationRequestedType LANDSCAPE
      用于指定横向的OrientationRequestedType实例。
      static PageAttributes.OrientationRequestedType PORTRAIT
      用于指定纵向方向的OrientationRequestedType实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • PORTRAIT

        public static final PageAttributes.OrientationRequestedType PORTRAIT
        用于指定纵向方向的OrientationRequestedType实例。

      • LANDSCAPE

        public static final PageAttributes.OrientationRequestedType LANDSCAPE
        用于指定横向的OrientationRequestedType实例。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PageAttributes.OriginType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PageAttributes.OriginType

  • java.lang.Object
    • java.awt.PageAttributes.OriginType
  • Enclosing class:
    PageAttributes

    public static final class PageAttributes.OriginType
extends Object
    可能来源的类型安全枚举。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PageAttributes.OriginType PHYSICAL
      用于指定物理原点的OriginType实例。
      static PageAttributes.OriginType PRINTABLE
      用于指定可打印原点的OriginType实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • PHYSICAL

        public static final PageAttributes.OriginType PHYSICAL
        用于指定物理原点的OriginType实例。

      • PRINTABLE

        public static final PageAttributes.OriginType PRINTABLE
        用于指定可打印原点的OriginType实例。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一个对象， hashCode方法必须始终返回相同的整数，前提是修改对象中的equals对比中没有使用的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PageAttributes.PrintQualityType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PageAttributes.PrintQualityType

  • java.lang.Object
    • java.awt.PageAttributes.PrintQualityType
  • Enclosing class:
    PageAttributes

    public static final class PageAttributes.PrintQualityType
extends Object
    可能的打印质量的类型安全枚举。 这些打印质量符合IPP 1.1。
    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PageAttributes.PrintQualityType DRAFT
      PrintQualityType实例用于指定打印质量草图。
      static PageAttributes.PrintQualityType HIGH
      PrintQualityType实例用于指定高打印质量。
      static PageAttributes.PrintQualityType NORMAL
      PrintQualityType实例用于指定正常的打印质量。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int hashCode​()
      返回对象的哈希码值。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • HIGH

        public static final PageAttributes.PrintQualityType HIGH
        PrintQualityType实例用于指定高打印质量。

      • NORMAL

        public static final PageAttributes.PrintQualityType NORMAL
        PrintQualityType实例用于指定正常的打印质量。

      • DRAFT

        public static final PageAttributes.PrintQualityType DRAFT
        PrintQualityType实例用于指定打印质量草图。

    • 方法详细信息

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了哈希表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一个对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中没有使用的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”这个对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Paint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface Paint

  • All Superinterfaces:
    Transparency
    所有已知实现类：
    Color ， ColorUIResource ， GradientPaint ， LinearGradientPaint ， MultipleGradientPaint ， RadialGradientPaint ， SystemColor ， TexturePaint

    public interface Paint
extends Transparency
    这个Paint接口定义了如何为Graphics2D操作生成颜色模式。 实现Paint接口的类被添加到Graphics2D上下文中，以定义draw和fill方法使用的颜色模式。

    实现Paint的类的实例必须是只读的，因为当Graphics2D被设置为具有setPaint方法的属性或者当本身克隆Graphics2D对象时， Graphics2D不会克隆这些对象。

    Version:
    1.36，06/05/07
    另请参见：
    PaintContext ， Color ， GradientPaint ， TexturePaint ， Graphics2D.setPaint(java.awt.Paint)

    • Field Summary

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      PaintContext createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成颜色模式的PaintContext 。

      • Methods inherited from interface java.awt.Transparency

        getTransparency

    • 方法详细信息

      • createContext

        PaintContext createContext​(ColorModel cm,
                           Rectangle deviceBounds,
                           Rectangle2D userBounds,
                           AffineTransform xform,
                           RenderingHints hints)
        创建并返回一个用于生成颜色模式的PaintContext 。 该方法的参数传达关于可以在Paint接口的各种实现上使用或忽略的渲染操作的附加信息。 呼叫者必须传递所有参数的非null值，但ColorModel参数可能为null ，表示不适用特定的ColorModel类型。 Paint接口的实现允许使用或忽略任何参数对其功能有意义，并且ColorModel于对返回的PaintContext使用指定的PaintContext ，即使不是null 。 实现允许抛出NullPointerException任何null比其他参数ColorModel的说法，但这样做不是必需的。
        参数
        cm - 优选的ColorModel ，表示呼叫者接收像素数据最方便的格式，如果没有偏好，则表示null 。
        deviceBounds - 正在呈现的图形基元的设备空间边界框。 Paint接口的实现允许为NullPointerException抛出null deviceBounds 。
        userBounds - 呈现的图形基元的用户空间边界框。 Paint接口的实现允许为NullPointerException抛出null userBounds 。
        xform - 从用户空间到设备空间的AffineTransform 。 Paint接口的实现允许为NullPointerException抛出null xform 。
        hints - 上下文对象可用于在呈现替代方案之间进行选择的一组提示。 Paint接口的实现允许为NullPointerException抛出null hints 。
        结果
        用于生成颜色图案的 PaintContext 。
        另请参见：
        PaintContext ， ColorModel ， Rectangle ， Rectangle2D ， AffineTransform ， RenderingHints
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PaintContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface PaintContext

  • public interface PaintContext
    PaintContext接口定义了封装和优化的环境，以在Graphics2D中为填充或笔画操作生成设备空间中的颜色模式。 PaintContext为Graphics2D操作提供必要的颜色，与ColorModel相关联的Raster的形式 。 PaintContext维护特定油漆操作的状态。 在多线程环境中，单个Paint对象可以同时存在多个上下文。
    另请参见：
    Paint

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dispose​()
      释放为操作分配的资源。
      ColorModel getColorModel​()
      返回输出的 ColorModel 。
      Raster getRaster​(int x, int y, int w, int h)
      返回包含为图形操作生成的颜色的 Raster 。

    • 方法详细信息

      • dispose

        void dispose​()
        释放为操作分配的资源。

      • getColorModel

        ColorModel getColorModel​()
        返回输出的ColorModel 。 请注意，这ColorModel可能会从指定的提示不同createContext的方法Paint 。 不是所有的PaintContext对象都能够在任意的ColorModel中生成颜色模式。
        结果
        产量为 ColorModel 。

      • getRaster

        Raster getRaster​(int x,
                 int y,
                 int w,
                 int h)
        返回包含为图形操作生成的颜色的 Raster 。
        参数
        x - 生成颜色的设备空间中的区域的x坐标。
        y - 生成颜色的设备空间中的区域的y坐标。
        w - 设备空间区域的宽度
        h - 设备空间区域的高度
        结果
        一个表示指定矩形区域的 Raster ，并包含为图形操作生成的颜色。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Panel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Panel

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Panel
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible
    已知直接子类：
    Applet

    public class Panel
extends Container
implements Accessible
    Panel是最简单的容器类。 面板提供应用程序可以附加任何其他组件（包括其他面板）的空间。

    面板的默认布局管理器是FlowLayout布局管理器。

    从以下版本开始：
    1.0
    另请参见：
    FlowLayout ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Panel.AccessibleAWTPanel
      该类实现 Panel类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Panel​()
      使用默认布局管理器创建新面板。
      Panel​(LayoutManager layout)
      使用指定的布局管理器创建一个新面板。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addNotify​()
      创建小组的同行。
      AccessibleContext getAccessibleContext​()
      获取与此面板关联的AccessibleContext。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, isValidateRoot, layout, list, list, locate, minimumSize, paint, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Panel

        public Panel​()
        使用默认布局管理器创建新面板。 所有面板的默认布局管理器是FlowLayout类。

      • Panel

        public Panel​(LayoutManager layout)
        使用指定的布局管理器创建一个新面板。
        参数
        layout - 此面板的布局管理器。
        从以下版本开始：
        1.1

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建小组的同行。 对等体允许您修改面板的外观而不更改其功能。
        重写：
        addNotify在 Container
        另请参见：
        Component.isDisplayable() ， Container.removeNotify()

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此面板关联的AccessibleContext。 对于面板，AccessibleContext采用AccessibleAWTPanel的形式。 如有必要，将创建一个新的AccessibleAWTPanel实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个AccessibleAWTPanel作为该面板的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Panel.AccessibleAWTPanel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Panel.AccessibleAWTPanel

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Panel.AccessibleAWTPanel
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    已知直接子类：
    Applet.AccessibleApplet
    Enclosing class:
    Panel

    protected class Panel.AccessibleAWTPanel
extends Container.AccessibleAWTContainer
    该类实现Panel类的可访问性支持。 它提供了适用于面板用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTPanel​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, removePropertyChangeListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTPanel

        protected AccessibleAWTPanel​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Point (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Point

  • java.lang.Object
    • java.awt.geom.Point2D
      • java.awt.Point
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class Point
extends Point2D
implements Serializable
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Point2D

        Point2D.Double, Point2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      int x
      这个 Point的X坐标。
      int y
      这个Y坐标 Point 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Point​()
      构造并初始化坐标空间原点（0，0）的点。
      Point​(int x, int y)
      构造并初始化坐标空间中指定的 (x,y)位置的点。
      Point​(Point p)
      构造和初始化与指定的 Point对象相同位置的点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      确定两点是否相等。
      Point getLocation​()
      返回这一点的位置。
      double getX​()
      以 double精度返回此 Point2D的X坐标。
      double getY​()
      返回这个 Point2D的Y坐标在 double精度。
      void move​(int x, int y)
      将此点移动到 (x,y)坐标平面中的指定位置。
      void setLocation​(double x, double y)
      将此点的位置设置为指定的双坐标。
      void setLocation​(int x, int y)
      更改要具有指定位置的点。
      void setLocation​(Point p)
      将点的位置设置为指定的位置。
      String toString​()
      返回此点及其位置在 (x,y)坐标空间中的字符串表示形式。
      void translate​(int dx, int dy)
      转换这一点上，在位置 (x,y) ，通过 dx沿 x轴和 dy沿 y轴线，使得其现在代表点 (x+dx,y+dy) 。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.geom.Point2D

        clone, distance, distance, distance, distanceSq, distanceSq, distanceSq, hashCode, setLocation

    • 字段详细信息

      • x

        public int x
        这个Point的X坐标。 如果没有设置X坐标，它将默认为0。
        从以下版本开始：
        1.0
        另请参见：
        getLocation() ， move(int, int)

      • y

        public int y
        这个Y坐标Point 。 如果没有设置Y坐标，则默认为0。
        从以下版本开始：
        1.0
        另请参见：
        getLocation() ， move(int, int)

    • 构造方法详细信息

      • Point

        public Point​()
        构造并初始化坐标空间原点（0，0）的点。
        从以下版本开始：
        1.1

      • Point

        public Point​(Point p)
        构造并初始化与指定的 Point对象相同位置的点。
        参数
        p - 一点
        从以下版本开始：
        1.1

      • Point

        public Point​(int x,
             int y)
        在坐标空间中指定的 (x,y)位置构造和初始化点。
        参数
        x - 新构建的X坐标 Point
        y - 新构建的Y坐标 Point
        从以下版本开始：
        1.0

    • 方法详细信息

      • getX

        public double getX​()
        返回此的X坐标 Point2D在 double精度。
        Specified by:
        getX在 Point2D
        结果
        这个 Point2D的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回 Point2D的Y坐标 double精度。
        Specified by:
        getY在 Point2D
        结果
        这个 Point2D的Y坐标。
        从以下版本开始：
        1.2

      • getLocation

        public Point getLocation​()
        返回这一点的位置。 包括这种方法的完整性，并行getLocation方法Component 。
        结果
        这个点的副本，在同一个位置
        从以下版本开始：
        1.1
        另请参见：
        Component.getLocation() ，
setLocation(java.awt.Point) ，
setLocation(int, int)

      • setLocation

        public void setLocation​(Point p)
        将点的位置设置为指定的位置。 此方法是出于完整性考虑，它与所述setLocation的方法Component 。
        参数
        p - 一点，这一点的新位置
        从以下版本开始：
        1.1
        另请参见：
        Component.setLocation(java.awt.Point) ， getLocation()

      • setLocation

        public void setLocation​(int x,
                        int y)
        更改要具有指定位置的点。

        包括这种方法的完整性，并行setLocation方法Component 。 其行为与move(int, int)相同。

        参数
        x - 新位置的X坐标
        y - 新位置的Y坐标
        从以下版本开始：
        1.1
        另请参见：
        Component.setLocation(int, int) ，
getLocation() ，
move(int, int)

      • setLocation

        public void setLocation​(double x,
                        double y)
        将此点的位置设置为指定的双坐标。 double值将四舍五入为整数值。 任何小于Integer.MIN_VALUE将重置为MIN_VALUE ，任何大于Integer.MAX_VALUE将重置为MAX_VALUE 。
        Specified by:
        setLocation在 Point2D
        参数
        x - 新位置的X坐标
        y - 新位置的Y坐标
        另请参见：
        getLocation()

      • move

        public void move​(int x,
                 int y)
        将此点移动到(x,y)坐标平面中的指定位置。 此方法与setLocation(int, int)相同。
        参数
        x - 新位置的X坐标
        y - 新位置的Y坐标
        另请参见：
        Component.setLocation(int, int)

      • translate

        public void translate​(int dx,
                      int dy)
        转换这一点上，在位置 (x,y) ，通过 dx沿 x轴和 dy沿 y轴线，使得其现在代表点 (x+dx,y+dy) 。
        参数
        dx - 沿着X轴移动该点的距离
        dy - 沿着Y轴移动该点的距离

      • equals

        public boolean equals​(Object obj)
        确定两点是否相等。 Point2D两个实例相同，如果它们的x和y成员字段的值表示其在坐标空间中的位置相同。
        重写：
        equals在 Point2D
        参数
        obj - 要与此 Point2D进行比较的对象
        结果
        true如果要比较的对象是Point2D的实例，并且具有相同的值; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        在(x,y)坐标空间中返回此点及其位置的字符串表示形式。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        toString在 Object
        结果
        这一点的字符串表示
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PointerInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PointerInfo

  • java.lang.Object
    • java.awt.PointerInfo

  • public class PointerInfo
extends Object
    描述指针位置的类。 它提供GraphicsDevice指针和表示指针坐标的Point 。

    该类的实例应通过MouseInfo.getPointerInfo()获得。 PointerInfo实例不会随鼠标移动而动态更新。 要获取更新的位置，您必须再次致电MouseInfo.getPointerInfo() 。

    从以下版本开始：
    1.5
    另请参见：
    MouseInfo.getPointerInfo()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      GraphicsDevice getDevice​()
      返回 GraphicsDevice ，其中鼠标指针是在创建这个 PointerInfo的那一刻。
      Point getLocation​()
      返回表示指针在屏幕上的坐标的 Point 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDevice

        public GraphicsDevice getDevice​()
        返回 GraphicsDevice ，其中鼠标指针是在创建这个 PointerInfo的那一刻。
        结果
        GraphicsDevice对应的指针
        从以下版本开始：
        1.5

      • getLocation

        public Point getLocation​()
        返回表示指针在屏幕上的坐标的Point 。 有关多画面系统的坐标计算的更多信息，请参阅MouseInfo.getPointerInfo() 。
        结果
        鼠标指针坐标
        从以下版本开始：
        1.5
        另请参见：
        MouseInfo ， MouseInfo.getPointerInfo()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Polygon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Polygon

  • java.lang.Object
    • java.awt.Polygon
  • All Implemented Interfaces:
    Shape ， Serializable

    public class Polygon
extends Object
implements Shape, Serializable
    Polygon类封装了坐标空间内封闭的二维区域的描述。 该区域由任意数量的线段限定，每个线段是多边形的一侧。 在内部，多边形包括(x,y)坐标对的列表，其中每对定义多边形的顶点 ，并且两个连续的对是作为多边形的一侧的线的端点。 (x,y)点的第一个和最后一对由一个关闭多边形的线段连接起来。 这个Polygon被定义为偶数绕组规则。 有关偶数绕组规则的定义，请参阅WIND_EVEN_ODD 。 这个类的命中测试方法，其中包括contains ， intersects和inside方法，用在描述的内部性定义Shape类评论。
    从以下版本开始：
    1.0
    另请参见：
    Shape ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Rectangle bounds
      这个边界 Polygon 。
      int npoints
      总分数。
      int[] xpoints
      X坐标数组。
      int[] ypoints
      Y坐标数组。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Polygon​()
      创建一个空多边形。
      Polygon​(int[] xpoints, int[] ypoints, int npoints)
      从指定的参数构造和初始化一个 Polygon 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addPoint​(int x, int y)
      将指定的坐标附加到此 Polygon 。
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      boolean contains​(int x, int y)
      确定指定的坐标是否在此 Polygon 。
      boolean contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      boolean contains​(Point p)
      确定指定的Point是否在此Polygon 。
      Rectangle getBoundingBox​()
      已过时。
      从JDK 1.1版开始，由getBounds()替代。
      Rectangle getBounds​()
      获得这个 Polygon的边框。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更精确的边界框。
      PathIterator getPathIterator​(AffineTransform at)
      返回迭代器对象，沿着这条边界迭代 Polygon ，并提供上网本的轮廓的几何 Polygon 。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代器对象，它沿着 Shape的边界进行迭代，并提供对 Shape轮廓几何的访问。
      boolean inside​(int x, int y)
      已过时。
      从JDK 1.1版开始，由contains(int, int)替代。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      void invalidate​()
      无效或刷新任何取决于此 Polygon的顶点坐标的内部缓存数据。
      void reset​()
      将此 Polygon对象重置为空多边形。
      void translate​(int deltaX, int deltaY)
      平移的顶点 Polygon由 deltaX沿x轴和由 deltaY沿y轴。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • npoints

        public int npoints
        总分数。 值npoints代表有效点的这个数Polygon ，并且可能小于元素的数量xpoints或者ypoints 。 该值可以为NULL。
        从以下版本开始：
        1.0
        另请参见：
        addPoint(int, int)

      • xpoints

        public int[] xpoints
        X坐标数组。 此数组中的元素数可能超过此Polygon的X坐标Polygon 。 额外的元素允许将新点添加到此Polygon而无需重新创建此数组。 npoints的值等于该Polygon的有效点数。
        从以下版本开始：
        1.0
        另请参见：
        addPoint(int, int)

      • ypoints

        public int[] ypoints
        Y坐标数组。 此数组中的元素数可能超过此Polygon的Y坐标Polygon 。 额外的元素允许将新点添加到此Polygon而不重新创建此数组。 npoints的值等于该Polygon中有效点的数量。
        从以下版本开始：
        1.0
        另请参见：
        addPoint(int, int)

      • bounds

        protected Rectangle bounds
        这个边界Polygon 。 该值可以为null。
        从以下版本开始：
        1.0
        另请参见：
        getBoundingBox() ， getBounds()

    • 构造方法详细信息

      • Polygon

        public Polygon​()
        创建一个空多边形。
        从以下版本开始：
        1.0

      • Polygon

        public Polygon​(int[] xpoints,
               int[] ypoints,
               int npoints)
        从指定的参数构造并初始化 Polygon 。
        参数
        xpoints - X坐标数组
        ypoints - 一个Y坐标数组
        npoints -点的总数 Polygon
        异常
        NegativeArraySizeException - 如果值为 npoints为负数。
        IndexOutOfBoundsException -如果 npoints比的长度大 xpoints或长度 ypoints 。
        NullPointerException - 如果 xpoints或 ypoints是 null 。
        从以下版本开始：
        1.0

    • 方法详细信息

      • reset

        public void reset​()
        将此Polygon对象重置为空多边形。 坐标数组及其中的数据保持不变，但将点数重置为零，以将旧顶点数据标记为无效，并开始在开始时累积新的顶点数据。 与旧顶点相关的所有内部缓存数据都将被丢弃。 请注意，由于复位之前的坐标数组被重新使用，如果新多边形数据中的顶点数量明显小于数据中的顶点数量，则创建一个新的空的Polygon可能会比重置当前的多个数据时更高的内存效率复位前。
        从以下版本开始：
        1.4
        另请参见：
        invalidate()

      • invalidate

        public void invalidate​()
        无效或刷新取决于此Polygon的顶点坐标的任何内部缓存的数据。 应该在xpoints或ypoints阵列中的任何直接操纵坐标之后调用此方法，以避免可能会从与顶点坐标相关的较早计算中缓存数据的方法（例如getBounds或contains不一致结果。
        从以下版本开始：
        1.4
        另请参见：
        getBounds()

      • translate

        public void translate​(int deltaX,
                      int deltaY)
        平移的顶点 Polygon由 deltaX沿x轴和由 deltaY沿y轴。
        参数
        deltaX - 沿X轴平移的量
        deltaY - 沿Y轴平移的量
        从以下版本开始：
        1.1

      • addPoint

        public void addPoint​(int x,
                     int y)
        将指定的坐标附加到此Polygon 。

        如果已经执行了计算此Polygon的边界框的操作，例如getBounds或contains ，则此方法将更新边界框。

        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.0
        另请参见：
        getBounds() ， contains(java.awt.Point)

      • getBounds

        public Rectangle getBounds​()
        获得这个Polygon的边框。 边框是最小的Rectangle ，它们的边平行于坐标空间的x和y轴，可以完全包含Polygon 。
        Specified by:
        getBounds在接口 Shape
        结果
        一个 Rectangle定义了这个 Polygon的范围。
        从以下版本开始：
        1.1
        另请参见：
        Shape.getBounds2D()

      • getBoundingBox

        @Deprecated
public Rectangle getBoundingBox​()
        已过时。 从JDK 1.1版开始，由getBounds()替代。
        返回这个 Polygon的范围。
        结果
        这个边界 Polygon 。
        从以下版本开始：
        1.0

      • contains

        public boolean contains​(Point p)
        确定指定的Point是否在此Polygon 。
        参数
        p - 要测试的 Point
        结果
        true如果Polygon包含Point ; 否则为false 。
        从以下版本开始：
        1.0
        另请参见：
        contains(double, double)

      • contains

        public boolean contains​(int x,
                        int y)
        确定指定的坐标是否在此 Polygon 。
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果这个Polygon包含指定的坐标(x,y) ; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        contains(double, double)

      • inside

        @Deprecated
public boolean inside​(int x,
                      int y)
        已过时。 从JDK 1.1版开始，由contains(int, int)代替。
        确定此 Polygon是否包含指定的坐标。
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果这个Polygon包含指定的坐标(x,y) ; 否则为false 。
        从以下版本开始：
        1.0
        另请参见：
        contains(double, double)

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape中这些点也未被包含的shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        Specified by:
        contains在接口 Shape
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标在Shape边界内; 否则为false 。
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(Point2D p)
        测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
        Specified by:
        contains在接口 Shape
        参数
        p - 要测试的指定的 Point2D
        结果
        true如果指定Point2D是的边界内Shape ; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 如果任何点包含在Shape的内部和指定的矩形区域中，则矩形区域被认为与Shape相交。

        Shape.intersects()方法允许Shape实现保守返回true当：

        • 矩形区域和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于一些Shapes这个方法可能会返回true即使矩形区域不与Shape相交。 Area类比大多数Shape对象执行更精确的几何交集计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; false否则。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • intersects

        public boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许Shape实现保守返回true当：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回true即使Rectangle2D没有与Shape相交。 Area类比大多数Shape对象执行更准确的几何交集计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的Rectangle2D的内部相交，或者两者极有可能相交并且交叉点计算将太昂贵执行; false否则。
        从以下版本开始：
        1.2
        另请参见：
        Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标必须位于Shape内，因为整个矩形区域将被视为包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false当：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于一些Shapes即使Shape包含矩形区域，此方法也可能返回false 。 Area类比大多数Shape对象执行更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则或如果Shape包含矩形区域，并且intersects方法返回true ，并且包含计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(Rectangle2D r)
        测试Shape的内部Shape全部包含指定的Rectangle2D 。 Shape.contains()方法允许Shape实现保守地返回false当：
        • intersect方法返回true和
        • 确定Shape是否完全包含Rectangle2D是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回false即使Shape包含Rectangle2D 。 Area类比大多数Shape对象执行更精确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果内部的Shape完全包含Rectangle2D ; false否则或如果Shape包含Rectangle2D和intersects方法返回true ，并且遏制计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Shape.contains(double, double, double, double)

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回一个迭代器对象，它沿着这个Polygon的边界进行迭代，并提供对这个Polygon的轮廓几何的访问。 可以指定可选的AffineTransform，以便相应地转换迭代中返回的坐标。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        结果
        一个PathIterator对象，提供对这个Polygon几何的Polygon 。
        从以下版本开始：
        1.2

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at,
                                    double flatness)
        返回迭代器对象沿的边界进行迭代Shape ，并提供访问的轮廓的几何Shape 。 只有SEG_MOVETO，SEG_LINETO和SEG_CLOSE点类型由迭代器返回。 由于多边形已经平坦，因此flatness参数将被忽略。 可以指定可选的AffineTransform在这种情况下，相应地转换迭代中返回的坐标。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        flatness - 给定曲线的控制点的最大量可以在细分曲线被连接端点的直线代替之前从共线变化。 由于多边形已经平坦，因此flatness参数将被忽略。
        结果
        一个 PathIterator对象，可以访问 Shape对象的几何。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PopupMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PopupMenu

  • java.lang.Object
    • java.awt.MenuComponent
      • java.awt.MenuItem
        • java.awt.Menu
          • java.awt.PopupMenu
  • All Implemented Interfaces:
    MenuContainer ， Serializable ， Accessible

    public class PopupMenu
extends Menu
    一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。

    随着继承层次的体现， PopupMenu可以在任何地方使用Menu 。 但是，如果您使用的是PopupMenu像Menu （例如，将其添加到MenuBar ），那么你就不能调用show上PopupMenu 。

    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。

      • Nested classes/interfaces inherited from class java.awt.Menu

        Menu.AccessibleAWTMenu

      • Nested classes/interfaces inherited from class java.awt.MenuComponent

        MenuComponent.AccessibleAWTMenuComponent

      • Nested classes/interfaces inherited from class java.awt.MenuItem

        MenuItem.AccessibleAWTMenuItem

    • 构造方法摘要

      构造方法
      Constructor 描述
      PopupMenu​()
      创建一个空名称的新的弹出菜单。
      PopupMenu​(String label)
      创建一个具有指定名称的新弹出菜单。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addNotify​()
      创建弹出菜单的对等体。
      AccessibleContext getAccessibleContext​()
      获取 AccessibleContext与此 PopupMenu相关联。
      MenuContainer getParent​()
      返回此菜单组件的父容器。
      void show​(Component origin, int x, int y)
      在相对于原始组件的x，y位置显示弹出式菜单。

      • Methods inherited from class java.awt.Menu

        add, add, addSeparator, countItems, getItem, getItemCount, insert, insert, insertSeparator, isTearOff, paramString, remove, remove, removeAll, removeNotify

      • Methods inherited from class java.awt.MenuComponent

        dispatchEvent, getFont, getName, getTreeLock, postEvent, setFont, setName, toString

      • Methods inherited from interface java.awt.MenuContainer

        getFont, postEvent

      • Methods inherited from class java.awt.MenuItem

        addActionListener, deleteShortcut, disable, disableEvents, enable, enable, enableEvents, getActionCommand, getActionListeners, getLabel, getListeners, getShortcut, isEnabled, processActionEvent, processEvent, removeActionListener, setActionCommand, setEnabled, setLabel, setShortcut

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PopupMenu

        public PopupMenu​()
          throws HeadlessException
        创建一个空名称的新的弹出菜单。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • PopupMenu

        public PopupMenu​(String label)
          throws HeadlessException
        创建一个具有指定名称的新弹出菜单。
        参数
        label - 非 null字符串，指定弹出菜单的标签
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • getParent

        public MenuContainer getParent​()
        返回此菜单组件的父容器。
        重写：
        getParent在 MenuComponent
        结果
        包含此菜单组件的菜单组件，或 null如果此菜单组件是最外面的组件，则菜单栏本身

      • addNotify

        public void addNotify​()
        创建弹出菜单的对等体。 对等体允许我们改变弹出式菜单的外观，而无需更改任何弹出菜单的功能。
        重写：
        addNotify在 Menu

      • show

        public void show​(Component origin,
                 int x,
                 int y)
        在相对于原始组件的x，y位置显示弹出式菜单。 原始组件必须包含在弹出菜单的父项的组件层次结构中。 原始和父母都必须在屏幕上显示，以使此方法有效。

        如果这个PopupMenu被用作Menu （即它有一个非Component父），那么你不能在PopupMenu上调用这个方法。

        参数
        origin - 定义坐标空间的组件
        x - 弹出菜单的x坐标位置
        y - 弹出菜单的y坐标位置
        异常
        NullPointerException - 如果父母是 null
        IllegalArgumentException - 如果这个 PopupMenu有一个非 Component父
        IllegalArgumentException - 如果原点不在父级的层次结构中
        RuntimeException - 如果父母没有在屏幕上显示

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取 AccessibleContext与此 PopupMenu相关联。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Menu
        结果
        该 AccessibleContext的这个 PopupMenu
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PopupMenu.AccessibleAWTPopupMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PopupMenu.AccessibleAWTPopupMenu

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.MenuComponent.AccessibleAWTMenuComponent
        • java.awt.MenuItem.AccessibleAWTMenuItem
          • java.awt.Menu.AccessibleAWTMenu
            • java.awt.PopupMenu.AccessibleAWTPopupMenu
  • All Implemented Interfaces:
    Serializable ， AccessibleAction ， AccessibleComponent ， AccessibleSelection ， AccessibleValue
    Enclosing class:
    PopupMenu

    protected class PopupMenu.AccessibleAWTPopupMenu
extends Menu.AccessibleAWTMenu
    PopupMenu的内部类用于提供对辅助功能的默认支持。 这个类不是由应用程序开发人员直接使用的，而是意味着仅由菜单组件开发人员进行子类化。

    该类用于获取此对象的可访问角色。

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from interface javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTPopupMenu​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.MenuComponent.AccessibleAWTMenuComponent

        addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.MenuItem.AccessibleAWTMenuItem

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleName, getAccessibleValue, getCurrentAccessibleValue, getMaximumAccessibleValue, getMinimumAccessibleValue, setCurrentAccessibleValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTPopupMenu

        protected AccessibleAWTPopupMenu​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Menu.AccessibleAWTMenu
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrintGraphics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface PrintGraphics

  • public interface PrintGraphics
    一个为页面提供打印图形上下文的抽象类。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      PrintJob getPrintJob​()
      返回此PrintGraphics对象始发的PrintJob对象。

    • 方法详细信息

      • getPrintJob

        PrintJob getPrintJob​()
        返回此PrintGraphics对象始发的PrintJob对象。
        结果
        该对象的打印作业
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrintJob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class PrintJob

  • java.lang.Object
    • java.awt.PrintJob

  • public abstract class PrintJob
extends Object
    一个启动和执行打印作业的抽象类。 它提供对打印图形对象的访问，该对象呈现给适当的打印设备。
    另请参见：
    Toolkit.getPrintJob(java.awt.Frame, java.lang.String, java.util.Properties)

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrintJob​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      abstract void end​()
      结束打印作业，并进行任何必要的清理。
      void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      abstract Graphics getGraphics​()
      获取将绘制到下一页的Graphics对象。
      abstract Dimension getPageDimension​()
      以像素为单位返回页面的尺寸。
      abstract int getPageResolution​()
      返回页面的分辨率（以像素为单位）。
      abstract boolean lastPageFirst​()
      如果最后一页将首先打印，则返回true。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PrintJob

        public PrintJob​()

    • 方法详细信息

      • getGraphics

        public abstract Graphics getGraphics​()
        获取将绘制到下一页的Graphics对象。 当图形对象被放置时，页面被发送到打印机。 该图形对象也将实现PrintGraphics界面。
        结果
        用于打印下一页的图形上下文
        另请参见：
        PrintGraphics

      • getPageDimension

        public abstract Dimension getPageDimension​()
        以像素为单位返回页面的尺寸。 选择页面的分辨率，使其与屏幕分辨率相似。
        结果
        页面维度

      • getPageResolution

        public abstract int getPageResolution​()
        返回页面的分辨率（以像素为单位）。 请注意，这不一定对应于打印机的物理分辨率。
        结果
        页面分辨率

      • lastPageFirst

        public abstract boolean lastPageFirst​()
        如果最后一页将首先打印，则返回true。
        结果
        true如果最后一页将首先打印; 否则false

      • end

        public abstract void end​()
        结束打印作业，并进行任何必要的清理。

      • finalize

        @Deprecated(since="9")
public void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        不再引用此打印作业结束。
        重写：
        finalize在 Object
        另请参见：
        end()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RadialGradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class RadialGradientPaint

  • java.lang.Object
    • java.awt.MultipleGradientPaint
      • java.awt.RadialGradientPaint
  • All Implemented Interfaces:
    Paint ， Transparency

    public final class RadialGradientPaint
extends MultipleGradientPaint
    RadialGradientPaint类提供了一种填充圆形径向颜色渐变图案的形状的方法。 用户可以指定2种或更多种渐变颜色，而这种颜色将在每种颜色之间提供插值。

    用户必须指定控制渐变图案的圆，它由中心点和半径描述。 用户还可以在该圆内指定单独的焦点，该点控制渐变的第一个颜色的位置。 默认情况下，焦点设置为圆的中心。

    此画面将渐变的第一个颜色映射到焦点，并将最后一个颜色映射到圆周边，为用户指定的任何中间颜色顺利插入。 从焦点到圆周绘制的任何线将会跨越所有的渐变颜色。

    在圆的半径之外指定聚焦点将导致渐变图案的环在焦点的方向上位于圆的边缘内的点上。 渲染将在内部使用此修改的位置，就像它是指定的焦点一样。

    用户必须提供一个浮动数组，指定如何沿渐变分布颜色。 这些值应该在0.0到1.0之间，并且像沿梯度的关键帧一样起作用（它们标记渐变应该是一个特定的颜色）。

    在用户没有将第一关键帧值设置为等于0和/或最后一个关键帧值等于1的情况下，将在这些位置创建关键帧，并且将在那里复制第一个和最后一个颜色。 因此，如果用户指定了以下数组来构造渐变：

      {Color.BLUE, Color.RED}, {.3f, .7f}
    这将被转换为具有以下关键帧的渐变：
      {Color.BLUE, Color.BLUE, Color.RED, Color.RED}, {0f, .3f, .7f, 1f}

    用户还可以通过将CycleMethod设置为REFLECTION或REPEAT来选择RadialGradientPaint对象在填充圆圈半径之外的空间时所采取的动作。 对于从焦点绘制的任何特定线，梯度颜色比例相等。 下图显示距离AB等于距离BC，距离AD等于距离DE。

    图像显示距离AB = BC，AD = DE

    如果梯度和图形渲染变换被均匀地缩放，并且用户设置焦点以使其与圆的中心一致，则从中心绘制的任何线的渐变颜色比例相等。 下图显示了距离AB，BC，AD和DE。 他们都是平等的

    请注意，由于以像素的粒度进行采样，可能会发生距离的一些微小变化。 如果没有指定循环方式，默认情况下将选择NO_CYCLE ，这意味着最后一个关键帧颜色将用于填充剩余的区域。

    colorSpace参数允许用户指定应在哪个颜色空间执行插值，默认sRGB或线性化RGB。

    以下代码演示了RadialGradientPaint典型用法，其中心点和焦点相同：

      Point2D center = new Point2D.Float(50, 50);
     float radius = 25;
     float[] dist = {0.0f, 0.2f, 1.0f};
     Color[] colors = {Color.RED, Color.WHITE, Color.BLUE};
     RadialGradientPaint p =
         new RadialGradientPaint(center, radius, dist, colors);

    此图像演示了上述示例代码，对于三种循环方法中的每一种，都使用默认（居中）焦点：

    也可以指定非中心焦点，如以下代码所示：

      Point2D center = new Point2D.Float(50, 50);
     float radius = 25;
     Point2D focus = new Point2D.Float(40, 40);
     float[] dist = {0.0f, 0.2f, 1.0f};
     Color[] colors = {Color.RED, Color.WHITE, Color.BLUE};
     RadialGradientPaint p =
         new RadialGradientPaint(center, radius, focus,
                                 dist, colors,
                                 CycleMethod.NO_CYCLE);

    此图像演示了上述示例代码，以三个周期方法中的每一个为非中心焦点：

    从以下版本开始：
    1.6
    另请参见：
    Paint ， Graphics2D.setPaint(java.awt.Paint)

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.MultipleGradientPaint

        MultipleGradientPaint.ColorSpaceType, MultipleGradientPaint.CycleMethod

    • Field Summary

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      RadialGradientPaint​(float cx, float cy, float radius, float[] fractions, Color[] colors)
      构建一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构建一个 RadialGradientPaint ，默认为 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，默认的颜色空间为 SRGB 。
      RadialGradientPaint​(Point2D center, float radius, float[] fractions, Color[] colors)
      构造一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构建一个 RadialGradientPaint ，默认为 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构建一个 RadialGradientPaint ，默认的颜色空间为 SRGB 。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 RadialGradientPaint 。
      RadialGradientPaint​(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，默认为 SRGB颜色空间。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PaintContext createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个PaintContext，用于生成圆形径向颜色渐变图案。
      Point2D getCenterPoint​()
      返回径向渐变中心点的副本。
      Point2D getFocusPoint​()
      返回径向渐变焦点的副本。
      float getRadius​()
      返回定义径向渐变的圆的半径。

      • Methods inherited from class java.awt.MultipleGradientPaint

        getColors, getColorSpace, getCycleMethod, getFractions, getTransform, getTransparency

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RadialGradientPaint

        public RadialGradientPaint​(float cx,
                           float cy,
                           float radius,
                           float[] fractions,
                           Color[] colors)
        构建一个 RadialGradientPaint ，默认为 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
        参数
        cx - 定义渐变的圆的中心点的用户空间中的X坐标。 渐变的最后一个颜色被映射到该圆的周长。
        cy - 定义渐变的圆的中心点的用户空间中的Y坐标。 渐变的最后一个颜色被映射到该圆的周长。
        radius - 定义颜色渐变范围的圆的半径
        fractions - 范围从0.0到1.0的数字，指定渐变颜色的分布
        colors - 在渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        异常
        NullPointerException - 如果 fractions数组为空，或 colors数组为空
        IllegalArgumentException - 如果 radius为非正数，或 fractions.length != colors.length ，或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions严格增加的顺序提供

      • RadialGradientPaint

        public RadialGradientPaint​(Point2D center,
                           float radius,
                           float[] fractions,
                           Color[] colors)
        构建一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
        参数
        center - 用户空间中定义渐变的圆的中心点
        radius - 定义颜色渐变范围的圆的半径
        fractions - 范围从0.0到1.0的数字，指定渐变颜色的分布
        colors - 渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        异常
        NullPointerException - 如果 center点为空，或 fractions数组为空，或 colors数组为空
        IllegalArgumentException - 如果 radius为非正数，或 fractions.length != colors.length或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions未提供严格增加的订单

      • RadialGradientPaint

        public RadialGradientPaint​(float cx,
                           float cy,
                           float radius,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
        构建一个 RadialGradientPaint ，默认为 SRGB颜色空间，以中心为焦点。
        参数
        cx - 定义渐变的圆的中心点的用户空间中的X坐标。 渐变的最后一个颜色被映射到该圆的周长。
        cy - 定义渐变的圆的中心点的用户空间中的Y坐标。 渐变的最后一个颜色被映射到该圆的周长。
        radius - 定义颜色渐变范围的圆的半径
        fractions - 数字范围从0.0到1.0，指定渐变颜色的分布
        colors - 渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        异常
        NullPointerException - 如果 fractions数组为空，或 colors数组为空，或 cycleMethod为空
        IllegalArgumentException - 如果 radius为非正数，或 fractions.length != colors.length ，或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions不提供严格的增加顺序

      • RadialGradientPaint

        public RadialGradientPaint​(Point2D center,
                           float radius,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
        构建一个 RadialGradientPaint ，默认为 SRGB色彩空间，以中心为焦点。
        参数
        center - 定义渐变的圆的用户空间中心点
        radius - 定义颜色渐变范围的圆的半径
        fractions - 范围从0.0到1.0的数字，指定沿梯度的颜色分布
        colors - 渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        异常
        NullPointerException - 如果 center点为空，或 fractions数组为空，或 colors数组为空，或 cycleMethod为空
        IllegalArgumentException - 如果 radius为非正数，或 fractions.length != colors.length ，或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions未提供严格增加的订单

      • RadialGradientPaint

        public RadialGradientPaint​(float cx,
                           float cy,
                           float radius,
                           float fx,
                           float fy,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
        构建一个 RadialGradientPaint ，默认为 SRGB颜色空间。
        参数
        cx - 定义渐变的圆的中心点的用户空间中的X坐标。 渐变的最后一个颜色被映射到该圆的周长。
        cy - 定义渐变的圆的中心点的用户空间中的Y坐标。 渐变的最后一个颜色被映射到该圆的周长。
        radius - 定义颜色渐变范围的圆的半径
        fx - 映射第一个颜色的用户空间中的点的X坐标
        fy - 映射第一个颜色的用户空间中的点的Y坐标
        fractions - 范围从0.0到1.0的数字，指定渐变颜色的分布
        colors - 渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        异常
        NullPointerException - 如果 fractions数组为空，或 colors数组为空，或 cycleMethod为空
        IllegalArgumentException - 如果 radius为非正数，或 fractions.length != colors.length ，或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions未提供严格增加的订单

      • RadialGradientPaint

        public RadialGradientPaint​(Point2D center,
                           float radius,
                           Point2D focus,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
        构造一个 RadialGradientPaint ，默认的颜色空间为 SRGB 。
        参数
        center - 定义渐变的圆的用户空间中心点。 渐变的最后一个颜色被映射到该圆的周长。
        radius - 定义颜色渐变范围的圆的半径
        focus - 映射第一种颜色的用户空间中的点
        fractions - 范围从0.0到1.0的数字，指定渐变颜色的分布
        colors - 在渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        异常
        NullPointerException - 如果其中一个点为空，或 fractions数组为空，或 colors数组为空，或 cycleMethod为空
        IllegalArgumentException - 如果 radius为非正数，或 fractions.length != colors.length ，或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions严格增加的顺序提供

      • RadialGradientPaint

        @ConstructorProperties({"centerPoint","radius","focusPoint","fractions","colors","cycleMethod","colorSpace","transform"})
public RadialGradientPaint​(Point2D center,
                           float radius,
                           Point2D focus,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod,
                           MultipleGradientPaint.ColorSpaceType colorSpace,
                           AffineTransform gradientTransform)
        构造一个 RadialGradientPaint 。
        参数
        center - 定义渐变的圆的用户空间中的中心点。 渐变的最后一个颜色被映射到该圆的周长。
        radius - 定义颜色渐变范围的圆的半径
        focus - 映射第一个颜色的用户空间中的点
        fractions - 范围从0.0到1.0的数字，指定渐变颜色的分布
        colors - 在渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        colorSpace - 用于插值的颜色空间， SRGB或 LINEAR_RGB
        gradientTransform - 转换为适用于渐变
        异常
        NullPointerException - 如果其中一个点为空，或 fractions数组为空，或 colors数组为空，或 cycleMethod为空，或 colorSpace为空，或 gradientTransform为空
        IllegalArgumentException - 如果 radius为非正数，或 fractions.length != colors.length ，或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions不提供严格增加的订单

      • RadialGradientPaint

        public RadialGradientPaint​(Rectangle2D gradientBounds,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
        构造一个RadialGradientPaint ，默认为SRGB颜色空间。 RadialGradientPaint的渐变圈由给定的边界框定义。

        这个构造函数是一种更方便的方式来表达以下（等价的）代码：

          double gw = gradientBounds.getWidth();
     double gh = gradientBounds.getHeight();
     double cx = gradientBounds.getCenterX();
     double cy = gradientBounds.getCenterY();
     Point2D center = new Point2D.Double(cx, cy);

     AffineTransform gradientTransform = new AffineTransform();
     gradientTransform.translate(cx, cy);
     gradientTransform.scale(gw / 2, gh / 2);
     gradientTransform.translate(-cx, -cy);

     RadialGradientPaint gp =
         new RadialGradientPaint(center, 1.0f, center,
                                 fractions, colors,
                                 cycleMethod,
                                 ColorSpaceType.SRGB,
                                 gradientTransform);
        参数
        gradientBounds - 用户空间中限定渐变最外侧范围的圆的边界框
        fractions - 范围从0.0到1.0的数字，指定沿梯度的颜色分布
        colors - 渐变中使用的颜色数组。 在焦点处使用第一种颜色，围绕圆周边的最后一种颜色。
        cycleMethod -无论是 NO_CYCLE ， REFLECT ，或 REPEAT
        异常
        NullPointerException - 如果 gradientBounds为空，或 fractions数组为空，或 colors数组为空，或 cycleMethod为空
        IllegalArgumentException - 如果 gradientBounds为空，或 fractions.length != colors.length或 colors小于2，或 fractions值小于0.0或大于1.0，或 fractions不提供严格的增加顺序

    • 方法详细信息

      • createContext

        public PaintContext createContext​(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform transform,
                                  RenderingHints hints)
        创建并返回一个PaintContext，用于生成圆形径向颜色渐变图案。 有关空参数处理的信息，请参阅createContext方法的说明。
        参数
        cm - 首选ColorModel ，表示呼叫方接收像素数据最方便的格式，如果没有偏好，则表示null 。
        deviceBounds - 正在渲染的图形基元的设备空间边界框。
        userBounds - 正在呈现的图形基元的用户空间边界框。
        transform - 从用户空间到设备空间的AffineTransform 。
        hints - 上下文对象可用于在呈现替代方案之间进行选择的一组提示。
        结果
        用于生成颜色图案的 PaintContext 。
        另请参见：
        Paint ， PaintContext ， ColorModel ， Rectangle ， Rectangle2D ， AffineTransform ， RenderingHints

      • getCenterPoint

        public Point2D getCenterPoint​()
        返回径向渐变中心点的副本。
        结果
        一个 Point2D对象，它是中心点的副本

      • getFocusPoint

        public Point2D getFocusPoint​()
        返回径向渐变焦点的副本。 请注意，如果在径向渐变构造时指定的对焦点位于圆的半径之外，即使渲染可能将颜色的环居中在位于半径范围内的不同点上，该方法仍将返回原始对焦点。
        结果
        一个 Point2D对象是焦点的副本

      • getRadius

        public float getRadius​()
        返回定义径向渐变的圆的半径。
        结果
        圆的半径定义径向梯度
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Rectangle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Rectangle

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    已知直接子类：
    DefaultCaret

    public class Rectangle
extends Rectangle2D
implements Shape, Serializable
    A Rectangle指定坐标空间中由Rectangle对象的左上点(x,y)的坐标空间中的区域，其宽度及其高度。

    A Rectangle对象的width和height是public字段。 创建Rectangle的构造函数，以及可以修改的方法，不妨碍为宽度或高度设置负值。

    A Rectangle whose width or height is exactly zero has location along those axes with zero dimension, but is otherwise considered empty.的isEmpty()方法就会为这样的一个返回true Rectangle 。 测试一个空的Rectangle包含或相交点或矩形的方法总是返回false，如果任一维度为零。 将这样的Rectangle与点或矩形组合的方法将包括结果中该轴上的Rectangle的位置， Rectangle调用add(Point)方法一样。

    A Rectangle whose width or height is negative has neither location nor dimension along those axes with negative dimensions. Such a Rectangle is treated as non-existent along those axes. Such a Rectangle is also empty with respect to containment calculations and methods which test if it contains or intersects a point or rectangle will always return false. Methods which combine such a Rectangle with a point or rectangle will ignore the Rectangle entirely in generating the result. If two Rectangle objects are combined and each has a negative dimension, the result will have at least one negative dimension.

    仅影响Rectangle的位置的Rectangle将在其位置上操作，而不管其沿着任一轴是否具有负或零维。

    请注意， Rectangle与默认的无参数的构造函数建成后，有尺寸0x0 ，因此是空的。 这Rectangle仍会有一个位置(0,0) ，将有助于该位置工会和添加操作。 因此，试图累积一组点的边界的代码应该首先构造具有特定负宽度和高度的Rectangle ，或者应该使用集合中的第一个点来构造Rectangle 。 例如：

       Rectangle bounds = new Rectangle(0, 0, -1, -1); for (int i = 0; i < points.length; i++) { bounds.add(points[i]); }
    或者如果我们知道点阵列至少包含一个点：
       Rectangle bounds = new Rectangle(points[0]); for (int i = 1; i < points.length; i++) { bounds.add(points[i]); }

    该类使用32位整数来存储其位置和尺寸。 频繁的操作可能会产生超过32位整数范围的结果。 这些方法将以避免中间结果的任何32位溢出的方式计算其结果，然后选择最佳表示形式将最终结果存储回保存位置和维度的32位字段。 结果的位置将通过将真实结果剪切到最接近的32位值来存储在x和y字段中。 存储在width和height维度字段中的值将被选择为尽可能包含真实结果的最大部分的32位值。 通常这意味着维度将被独立地剪切到32位整数的范围，除了如果位置必须被移动以将其存储到它的32位字段对中，则维度将相对于“最佳表示“的位置。 如果真正的结果具有负的尺寸，因此沿着一个或两个轴不存在，则存储的尺寸将是这些轴中的负数。 如果真正的结果具有可以在32位整数的范围内表示的位置，但沿着一个或两个轴的零维度，那么这些轴中存储的维度将为零。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Rectangle2D

        Rectangle2D.Double, Rectangle2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      int height
      的身高 Rectangle 。
      int width
      宽度为 Rectangle 。
      int x
      Rectangle左右角的X坐标值为 Rectangle 。
      int y
      左上角的Y坐标为 Rectangle 。

      • Fields inherited from class java.awt.geom.Rectangle2D

        OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP

    • 构造方法摘要

      构造方法
      Constructor 描述
      Rectangle​()
      构造新的 Rectangle其左上角在坐标空间中为（0,0），宽度和高度都为零。
      Rectangle​(int width, int height)
      构造新的 Rectangle其左上角在坐标空间中为（0,0），其宽度和高度由同名参数指定。
      Rectangle​(int x, int y, int width, int height)
      构造一个新的 Rectangle其左上角被指定为 (x,y) ，其宽度和高度由同名参数指定。
      Rectangle​(Dimension d)
      构造一个新的 Rectangle其左上角为（0,0），其宽度和高度由 Dimension参数指定。
      Rectangle​(Point p)
      构造一个新的 Rectangle其左上角是指定的 Point ，其宽度和高度均为零。
      Rectangle​(Point p, Dimension d)
      构造新的Rectangle其左上角由Point参数指定，其宽度和高度由Dimension参数指定。
      Rectangle​(Rectangle r)
      构造一个新的 Rectangle ，初始化为匹配指定的 Rectangle 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void add​(int newx, int newy)
      增加了一个点，由整数参数指定 newx,newy到此的边界 Rectangle 。
      void add​(Point pt)
      添加指定 Point本的界限 Rectangle 。
      void add​(Rectangle r)
      添加一个 Rectangle这个 Rectangle 。
      boolean contains​(int x, int y)
      检查此 Rectangle是否包含指定位置的点 (x,y) 。
      boolean contains​(int X, int Y, int W, int H)
      检查该 Rectangle是否完全包含 Rectangle在指定的位置 (X,Y)具有指定的尺寸 (W,H) 。
      boolean contains​(Point p)
      检查此 Rectangle是否包含指定的 Point 。
      boolean contains​(Rectangle r)
      检查这个 Rectangle是否完全包含指定的 Rectangle 。
      Rectangle2D createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      boolean equals​(Object obj)
      检查两个矩形是否相等。
      Rectangle getBounds​()
      获取边界 Rectangle如此 Rectangle 。
      Rectangle2D getBounds2D​()
      返回 Shape的 getBounds高精度和更准确的边界框。
      double getHeight​()
      返回 double精度的边界 Rectangle的高度。
      Point getLocation​()
      返回这个 Rectangle的位置。
      Dimension getSize​()
      获得 Rectangle的大小，由返回的 Dimension代表。
      double getWidth​()
      返回 double精度的边界 Rectangle的宽度。
      double getX​()
      以 double精度返回边界 Rectangle的X坐标。
      double getY​()
      返回 double精度的边界 Rectangle的Y坐标。
      void grow​(int h, int v)
      水平和垂直调整 Rectangle 。
      boolean inside​(int X, int Y)
      已过时。
      截至JDK 1.1版，由contains(int, int)替代。
      Rectangle intersection​(Rectangle r)
      计算 Rectangle与指定的 Rectangle 。
      boolean intersects​(Rectangle r)
      确定此 Rectangle和指定的 Rectangle相交。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      void move​(int x, int y)
      已过时。
      从JDK 1.1版开始，由setLocation(int, int)替代。
      int outcode​(double x, double y)
      确定相对于这个 Rectangle2D指定坐标的 Rectangle2D 。
      void reshape​(int x, int y, int width, int height)
      已过时。
      从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
      void resize​(int width, int height)
      已过时。
      从JDK 1.1版开始，由setSize(int, int)替代。
      void setBounds​(int x, int y, int width, int height)
      设置边界 Rectangle如此 Rectangle到指定 x ， y ， width ，并 height 。
      void setBounds​(Rectangle r)
      设置边界 Rectangle如此 Rectangle为指定 Rectangle 。
      void setLocation​(int x, int y)
      将此 Rectangle移动到指定的位置。
      void setLocation​(Point p)
      将此 Rectangle移动到指定的位置。
      void setRect​(double x, double y, double width, double height)
      设置此的边界 Rectangle为整数范围，其包含指定的 x ， y ， width ，和 height 。
      void setSize​(int width, int height)
      将此 Rectangle的大小设置为指定的宽度和高度。
      void setSize​(Dimension d)
      设置 Rectangle的大小以匹配指定的 Dimension 。
      String toString​()
      返回一个 String代表这个 Rectangle及其值。
      void translate​(int dx, int dy)
      将这种 Rectangle指定距离，沿X坐标轴的右侧，向下沿Y坐标轴。
      Rectangle union​(Rectangle r)
      计算该 Rectangle与指定的 Rectangle 。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.geom.Rectangle2D

        add, add, add, contains, contains, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, setRect, union

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

      • Methods inherited from interface java.awt.Shape

        contains, contains, contains, contains, getPathIterator, getPathIterator, intersects, intersects

    • 字段详细信息

      • x

        public int x
        左边角的X坐标为 Rectangle 。
        从以下版本开始：
        1.0
        另请参见：
        setLocation(int, int) ， getLocation()

      • y

        public int y
        左上角的Y坐标为 Rectangle 。
        从以下版本开始：
        1.0
        另请参见：
        setLocation(int, int) ， getLocation()

      • width

        public int width
        宽度为 Rectangle 。
        从以下版本开始：
        1.0
        另请参见：
        setSize(int, int) ， getSize()

      • height

        public int height
        高度 Rectangle 。
        从以下版本开始：
        1.0
        另请参见：
        setSize(int, int) ， getSize()

    • 构造方法详细信息

      • Rectangle

        public Rectangle​()
        构造新的 Rectangle其左上角在坐标空间中为（0,0），宽度和高度都为零。

      • Rectangle

        public Rectangle​(Rectangle r)
        构造一个新的 Rectangle ，初始化为匹配指定的 Rectangle 。
        参数
        r -所述 Rectangle从中初始值复制到新构造的 Rectangle
        从以下版本开始：
        1.1

      • Rectangle

        public Rectangle​(int x,
                 int y,
                 int width,
                 int height)
        构造一个新的 Rectangle其左上角指定为 (x,y) ，其宽度和高度由相同名称的参数指定。
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        width - 宽度为 Rectangle
        height - 高度的 Rectangle
        从以下版本开始：
        1.0

      • Rectangle

        public Rectangle​(int width,
                 int height)
        构造新的 Rectangle其左上角在坐标空间中为（0,0），其宽度和高度由同名参数指定。
        参数
        width - 宽度为 Rectangle
        height - 高度的 Rectangle

      • Rectangle

        public Rectangle​(Point p,
                 Dimension d)
        构造一个新的Rectangle其左上角由Point参数指定，其宽度和高度由Dimension参数指定。
        参数
        p - 一个 Point是左上角的 Rectangle
        d -一个 Dimension ，代表的宽度和高度 Rectangle

      • Rectangle

        public Rectangle​(Point p)
        构造一个新的 Rectangle其左上角是指定的 Point ，其宽度和高度均为零。
        参数
        p - 一个 Point这是 Rectangle

      • Rectangle

        public Rectangle​(Dimension d)
        构造一个新的 Rectangle其左上角为（0,0），宽度和高度由 Dimension参数指定。
        参数
        d - a Dimension ，指定宽度和高度

    • 方法详细信息

      • getX

        public double getX​()
        返回 double精度的边界 Rectangle的X坐标。
        Specified by:
        getX在 RectangularShape
        结果
        边界的X坐标为 Rectangle 。

      • getY

        public double getY​()
        返回 double精度的边界 Rectangle的Y坐标。
        Specified by:
        getY在 RectangularShape
        结果
        边界的Y坐标为 Rectangle 。

      • getWidth

        public double getWidth​()
        返回 double精度的边界 Rectangle的宽度。
        Specified by:
        getWidth在 RectangularShape
        结果
        边界的宽度为 Rectangle 。

      • getHeight

        public double getHeight​()
        返回 double精度的边界 Rectangle的高度。
        Specified by:
        getHeight在 RectangularShape
        结果
        高度的边界 Rectangle 。

      • getBounds

        public Rectangle getBounds​()
        获得Rectangle的边界Rectangle 。

        包括此方法的完整性，并行getBounds方法Component 。

        Specified by:
        getBounds在接口 Shape
        重写：
        getBounds在 RectangularShape
        结果
        新 Rectangle ，等于边界 Rectangle这个 Rectangle 。
        从以下版本开始：
        1.1
        另请参见：
        Component.getBounds() ， setBounds(Rectangle) ， setBounds(int, int, int, int)

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape的getBounds高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能会导致bounds对象的定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape中这些点也未被包含的shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        重写：
        getBounds2D在 Rectangle2D
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()

      • setBounds

        public void setBounds​(Rectangle r)
        设置此Rectangle的边界Rectangle以匹配指定的Rectangle 。

        包括这种方法的完整性，并行setBounds方法Component 。

        参数
        r - 指定的 Rectangle
        从以下版本开始：
        1.1
        另请参见：
        getBounds() ， Component.setBounds(java.awt.Rectangle)

      • setBounds

        public void setBounds​(int x,
                      int y,
                      int width,
                      int height)
        设置边界Rectangle如此Rectangle到指定x ， y ， width ，并height 。

        包括这种方法的完整性，并行setBounds方法Component 。

        参数
        x - 这个 Rectangle左上角的新X坐标
        y - 这个 Rectangle左上角的新Y坐标
        width - 这个 Rectangle的新宽度
        height - 这个 Rectangle的新高度
        从以下版本开始：
        1.1
        另请参见：
        getBounds() ， Component.setBounds(int, int, int, int)

      • setRect

        public void setRect​(double x,
                    double y,
                    double width,
                    double height)
        设置此的边界Rectangle为整数范围，其包含指定的x ， y ， width ，和height 。 如果参数指定超过最大整数范围的Rectangle ，则结果将是与最大整数边界相交的指定Rectangle的最佳表示。
        Specified by:
        setRect在 Rectangle2D
        参数
        x - 指定矩形左上角的X坐标
        y - 指定矩形左上角的Y坐标
        width - 指定矩形的宽度
        height - 指定矩形的新高度

      • reshape

        @Deprecated
public void reshape​(int x,
                    int y,
                    int width,
                    int height)
        已过时。 从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
        设置边界 Rectangle如此 Rectangle到指定 x ， y ， width ，并 height 。
        参数
        x - 这个 Rectangle左上角的新X坐标
        y - 这个 Rectangle左上角的新Y坐标
        width - 这个 Rectangle的新宽度
        height - 这个 Rectangle的新高度

      • getLocation

        public Point getLocation​()
        返回这个Rectangle的位置。

        包括此方法的完整性，并行getLocation方法Component 。

        结果
        这个 Point就是这个 Rectangle 。
        从以下版本开始：
        1.1
        另请参见：
        Component.getLocation() ， setLocation(Point) ， setLocation(int, int)

      • setLocation

        public void setLocation​(Point p)
        将此Rectangle移动到指定位置。

        包括此方法的完整性，并行setLocation方法Component 。

        参数
        p - 指定 Point的新位置的 Rectangle
        从以下版本开始：
        1.1
        另请参见：
        Component.setLocation(java.awt.Point) ， getLocation()

      • setLocation

        public void setLocation​(int x,
                        int y)
        将此Rectangle移动到指定位置。

        本方法包含的完整性，并行setLocation方法Component 。

        参数
        x - 新位置的X坐标
        y - 新位置的Y坐标
        从以下版本开始：
        1.1
        另请参见：
        getLocation() ， Component.setLocation(int, int)

      • move

        @Deprecated
public void move​(int x,
                 int y)
        已过时。 自JDK 1.1版起，由setLocation(int, int)替代。
        将此 Rectangle移动到指定位置。
        参数
        x - 新位置的X坐标
        y - 新位置的Y坐标

      • translate

        public void translate​(int dx,
                      int dy)
        将该指示距离沿着X坐标轴向右移动，并沿着Y坐标轴向下翻译 Rectangle 。
        参数
        dx - 沿着X轴移动这个 Rectangle的距离
        dy - 沿着Y轴移动这个 Rectangle的距离
        另请参见：
        setLocation(int, int) ， setLocation(java.awt.Point)

      • getSize

        public Dimension getSize​()
        获得Rectangle的大小，由返回的Dimension表示。

        包括这种方法的完整性，并行getSize方法Component 。

        结果
        一个 Dimension ，代表这个 Rectangle的大小。
        从以下版本开始：
        1.1
        另请参见：
        Component.getSize() ， setSize(Dimension) ， setSize(int, int)

      • setSize

        public void setSize​(Dimension d)
        设置这个Rectangle的大小，以匹配指定的Dimension 。

        包括此方法的完整性，并行setSize方法Component 。

        参数
        d - 新的大小为 Dimension对象
        从以下版本开始：
        1.1
        另请参见：
        Component.setSize(java.awt.Dimension) ， getSize()

      • setSize

        public void setSize​(int width,
                    int height)
        将此Rectangle的大小设置为指定的宽度和高度。

        包括此方法的完整性，并行setSize方法Component 。

        参数
        width - 这个 Rectangle的新宽度
        height - 这个 Rectangle的新高度
        从以下版本开始：
        1.1
        另请参见：
        Component.setSize(int, int) ， getSize()

      • resize

        @Deprecated
public void resize​(int width,
                   int height)
        已过时。 从JDK 1.1版开始，由setSize(int, int)替代。
        将此 Rectangle的大小设置为指定的宽度和高度。
        参数
        width - 这个 Rectangle的新宽度
        height - 这个 Rectangle的新高度

      • contains

        public boolean contains​(Point p)
        检查此 Rectangle是否包含指定的 Point 。
        参数
        p - Point要测试
        结果
        true如果指定的Point是在这个Rectangle ; false否则。
        从以下版本开始：
        1.1

      • contains

        public boolean contains​(int x,
                        int y)
        检查此 Rectangle是否包含指定位置的点 (x,y) 。
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        结果
        true如果点(x,y)是在这Rectangle ; 否则为false 。
        从以下版本开始：
        1.1

      • contains

        public boolean contains​(Rectangle r)
        检查这个 Rectangle是否完全包含指定的 Rectangle 。
        参数
        r - 指定的 Rectangle
        结果
        true如果Rectangle完全包含在这个Rectangle ; false否则
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(int X,
                        int Y,
                        int W,
                        int H)
        检查该 Rectangle是否完全包含 Rectangle在指定的位置 (X,Y)具有指定的尺寸 (W,H) 。
        参数
        X - 指定的X坐标
        Y - 指定的Y坐标
        W - 宽度为 Rectangle
        H - 的高度是 Rectangle
        结果
        true如果由Rectangle指定的(X, Y, W, H)完全封闭在这个Rectangle ; 否则为false 。
        从以下版本开始：
        1.1

      • inside

        @Deprecated
public boolean inside​(int X,
                      int Y)
        已过时。 从JDK 1.1版开始，代之以contains(int, int) 。
        检查此 Rectangle是否包含指定位置的点 (X,Y) 。
        参数
        X - 指定的X坐标
        Y - 指定的Y坐标
        结果
        true如果点(X,Y)是在这Rectangle里面; false否则。

      • intersects

        public boolean intersects​(Rectangle r)
        确定此Rectangle和指定的Rectangle相交。 两个矩形相交，如果它们的交集非空。
        参数
        r - 指定的 Rectangle
        结果
        true如果指定的Rectangle和这个Rectangle相交; 否则为false 。

      • intersection

        public Rectangle intersection​(Rectangle r)
        计算Rectangle与指定的Rectangle 。 返回一个新的Rectangle ，表示两个矩形的交集。 如果两个矩形不相交，结果将是一个空的矩形。
        参数
        r - 指定的 Rectangle
        结果
        最大Rectangle包含在规定的Rectangle和Rectangle ; 或者如果矩形不相交，则为空矩形。

      • union

        public Rectangle union​(Rectangle r)
        计算Rectangle与指定的Rectangle 。 返回一个新的Rectangle ，表示两个矩形的并集。

        如果Rectangle尺寸小于零，则适用non-existent矩形的规则。 如果只有一个维数小于零，则结果将是其他Rectangle的副本。 如果两者都具有小于零的维度，则结果将至少有一个维度小于零。

        如果由此产生的Rectangle的维度太大，无法表示为int ，结果将沿维度的尺寸为Integer.MAX_VALUE 。

        参数
        r - 指定的 Rectangle
        结果
        最小的 Rectangle包含指定的 Rectangle和这个 Rectangle 。

      • add

        public void add​(int newx,
                int newy)
        增加了一个点，由整数参数指定newx,newy到此的边界Rectangle 。

        如果Rectangle尺寸小于零，则适用non-existent矩形的规则。 在这种情况下，此Rectangle的新边界将具有等于指定坐标的位置，宽度和高度等于零。

        添加点后，调用contains添加点作为参数，并不一定会返回true 。 contains方法不会返回true的右侧或底部的Rectangle 。 因此，如果添加点落在扩大后的Rectangle的右边或底部边缘，那么contains将返回false 。 如果指定点必须包含在新的Rectangle ，则应添加1x1矩形：

          r.add(newx, newy, 1, 1);
        参数
        newx - 新点的X坐标
        newy - 新点的Y坐标

      • add

        public void add​(Point pt)
        添加指定Point本的界限Rectangle 。

        如果这个Rectangle尺寸小于零，则适用non-existent矩形的规则。 在这种情况下，这个Rectangle的新界限将具有等于指定的Point的坐标和宽度和高度等于零的位置。

        加入后Point ，将呼叫contains与加Point作为参数不一定返回true 。 该contains方法不返回true ，用于在右侧或底部边缘点Rectangle 。 因此，如果添加Point落在放大后的Rectangle的右边或底部边缘，那么contains返回false那个Point 。 如果指定的点必须包含在新的Rectangle ，则应添加1x1矩形：

          r.add(pt.x, pt.y, 1, 1);
        参数
        pt - 新增 Point加入此 Rectangle

      • add

        public void add​(Rectangle r)
        添加一个Rectangle这个Rectangle 。 由此产生的Rectangle是两个矩形的联合。

        如果Rectangle尺寸小于0，则其尺寸为Rectangle 。 如果Rectangle s至少有一个维度小于0，结果将至少有一个维度小于0。

        如果Rectangle具有等于0的一个或两个尺寸，那么具有0维度的那些轴的结果将等同于通过将对应的原点坐标添加到沿该轴的结果矩形而获得的结果，类似于add(Point)方法的操作，但没有进一步的贡献。

        如果由此产生的Rectangle将有一个维度太大，无法表示为int ，结果将沿维度的尺寸为Integer.MAX_VALUE 。

        参数
        r - 指定的 Rectangle

      • grow

        public void grow​(int h,
                 int v)
        水平和垂直调整Rectangle 。

        此方法会修改Rectangle ，以便它是h在左侧和右侧两者更大的单位，以及v单元在顶部和底部都增加。

        新的Rectangle具有(x - h, y - v)作为其左上角，宽度为(width + 2h) ，高度为(height + 2v) 。

        如果为h和v提供了h ，则v的大小Rectangle减少。 grow方法将检查整数溢出和下溢，但不检查width和height的结果值是否从负数增加到非负数，或从非负值收缩。

        参数
        h - 横向扩张
        v - 垂直展开

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，不包含任何区域。
        Specified by:
        isEmpty在 RectangularShape
        结果
        true如果RectangularShape是空的; 否则为false 。
        从以下版本开始：
        1.2

      • outcode

        public int outcode​(double x,
                   double y)
        确定相对于这个Rectangle2D指定坐标的Rectangle2D 。 该方法计算适当的掩码值的二进制OR，表示对于该Rectangle2D每一边，指定的坐标是否与该Rectangle2D的其余部分位于边的同一侧。
        Specified by:
        outcode在 Rectangle2D
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        结果
        所有适当输出代码的逻辑或。
        从以下版本开始：
        1.2
        另请参见：
        Rectangle2D.OUT_LEFT ， Rectangle2D.OUT_TOP ， Rectangle2D.OUT_RIGHT ， Rectangle2D.OUT_BOTTOM

      • createIntersection

        public Rectangle2D createIntersection​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
        Specified by:
        createIntersection在 Rectangle2D
        参数
        r -在 Rectangle2D与此相交 Rectangle2D
        结果
        最大的 Rectangle2D包含在指定的 Rectangle2D和这个 Rectangle2D 。
        从以下版本开始：
        1.2

      • createUnion

        public Rectangle2D createUnion​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
        Specified by:
        createUnion在 Rectangle2D
        参数
        r -在 Rectangle2D与此相结合 Rectangle2D
        结果
        最小的 Rectangle2D包含指定的 Rectangle2D和 Rectangle2D 。
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object obj)
        检查两个矩形是否相等。

        结果是true当且仅当参数不是null并且是一个Rectangle对象，具有与此Rectangle相同的左上角，宽度和高度。

        重写：
        equals在 Rectangle2D
        参数
        obj - Object与此 Rectangle进行比较
        结果
        true如果对象相等; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回一个 String代表这个 Rectangle及其值。
        重写：
        toString在 Object
        结果
        a String representing this Rectangle object's coordinate and size values.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderingHints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class RenderingHints

  • java.lang.Object
    • java.awt.RenderingHints
  • All Implemented Interfaces:
    Cloneable ， Map<Object,Object>

    public class RenderingHints
extends Object
implements Map<Object,Object>, Cloneable
    RenderingHints类定义和管理密钥和关联值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。 Graphics2D类和实现BufferedImageOp和RasterOp的类都提供了获取和可能设置RenderingHints密钥及其关联值的个人或组的RenderingHints 。 当这些实现执行任何渲染或图像处理操作时，他们应该检查呼叫者请求的任何RenderingHints的值，并根据他们的能力调整所使用的算法。

    请注意，由于这些键和值是提示 ，所以不需要给定的实现支持下面指出的所有可能的选择，或者它可以响应修改其算法选择的请求。 各种提示键的值也可以相互作用，使得当在一种情况下支持给定键的所有变体时，当与其他键相关联的值被修改时，实施可能会更受限制。 例如，当抗锯齿提示被关闭时，一些实施方式可能能够提供若干类型的抖动，但是当抗锯齿处于打开状态时，几乎不能控制抖动。 支持的键和提示的完整集合也可能因目的地而异，因为运行时间可能会使用不同的底层模块呈现到屏幕上，或者在打印时打印到BufferedImage对象。

    实现可以完全忽略提示，但应该尝试使用尽可能接近请求的实现算法。 如果一个实现支持一个给定的算法，当任何值用于相关联的提示密钥时，最低限度地，当该值的值是指定算法的确切值时，它必须这样做。

    用于控制提示的键都是对相关联的RenderingHints.Key类进行子类化的特殊值。 许多常见的提示在下面被表示为这个类中的静态常量，但是列表并不是详尽无遗的。 其他提示也可以由其他包创建，方法是定义新对象，该对象可以分类Key类并定义关联的值。

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  RenderingHints.Key
      定义与RenderingHints类一起使用的所有键的基本类型，以控制渲染和成像管道中的各种算法选择。

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static RenderingHints.Key KEY_ALPHA_INTERPOLATION
      Alpha插补提示键。
      static RenderingHints.Key KEY_ANTIALIASING
      抗锯齿提示键。
      static RenderingHints.Key KEY_COLOR_RENDERING
      显色提示键。
      static RenderingHints.Key KEY_DITHERING
      抖动提示键。
      static RenderingHints.Key KEY_FRACTIONALMETRICS
      字体分数指标提示键。
      static RenderingHints.Key KEY_INTERPOLATION
      插值提示键。
      static RenderingHints.Key KEY_RENDERING
      呈现提示键。
      static RenderingHints.Key KEY_RESOLUTION_VARIANT
      图像分辨率变体提示键。
      static RenderingHints.Key KEY_STROKE_CONTROL
      中风归一化控制提示键。
      static RenderingHints.Key KEY_TEXT_ANTIALIASING
      文本抗锯齿提示键。
      static RenderingHints.Key KEY_TEXT_LCD_CONTRAST
      LCD文字对比度提示键。
      static Object VALUE_ALPHA_INTERPOLATION_DEFAULT
      Alpha插值提示值 - alpha混合算法由实现选择，以实现性能与质量的良好折衷。
      static Object VALUE_ALPHA_INTERPOLATION_QUALITY
      选择Alpha插值提示值 - alpha混合算法，偏好精度和视觉质量。
      static Object VALUE_ALPHA_INTERPOLATION_SPEED
      选择Alpha插值提示值 - alpha混合算法，优先于计算速度。
      static Object VALUE_ANTIALIAS_DEFAULT
      抗锯齿提示值 - 使用实现选择的默认抗锯齿模式进行渲染。
      static Object VALUE_ANTIALIAS_OFF
      抗锯齿提示值 - 渲染完成时没有抗锯齿。
      static Object VALUE_ANTIALIAS_ON
      抗混叠提示值 - 使用抗锯齿来实现渲染。
      static Object VALUE_COLOR_RENDER_DEFAULT
      显色渲染提示值 - 执行颜色转换计算，以表示性能和精度之间的最佳可用权衡。
      static Object VALUE_COLOR_RENDER_QUALITY
      显色提示值 - 以最高的精度和视觉质量执行颜色转换计算。
      static Object VALUE_COLOR_RENDER_SPEED
      显色提示值 - 执行最快的颜色转换为输出设备的格式。
      static Object VALUE_DITHER_DEFAULT
      抖动提示值 - 使用实现选择的抖动的默认值。
      static Object VALUE_DITHER_DISABLE
      抖动提示值 - 渲染几何时不要抖动。
      static Object VALUE_DITHER_ENABLE
      抖动提示值 - 如果需要，渲染几何时，抖动。
      static Object VALUE_FRACTIONALMETRICS_DEFAULT
      字体分数度量提示值 - 字符字形按照实现选择的精度进行定位。
      static Object VALUE_FRACTIONALMETRICS_OFF
      字体分数度量提示值 - 字符字形以先进宽度定位，四舍五入到像素边界。
      static Object VALUE_FRACTIONALMETRICS_ON
      字体分数度量提示值 - 字符字形以子像素精度定位。
      static Object VALUE_INTERPOLATION_BICUBIC
      插值提示值 - 使用 X和 Y的三次函数对图像中9个附近整数坐标样本的颜色样本进行插值，以生成颜色样本。
      static Object VALUE_INTERPOLATION_BILINEAR
      插值提示值 - 图像中最近邻近4个整数坐标样本的颜色样本被线性内插以产生颜色样本。
      static Object VALUE_INTERPOLATION_NEAREST_NEIGHBOR
      插值提示值 - 使用图像中最近的相邻整数坐标样本的颜色样本。
      static Object VALUE_RENDER_DEFAULT
      渲染提示值 - 渲染算法由实现选择，以实现性能与质量的良好折衷。
      static Object VALUE_RENDER_QUALITY
      渲染提示值 - 选择渲染算法以优化输出质量。
      static Object VALUE_RENDER_SPEED
      渲染提示值 - 选择渲染算法以优先输出速度。
      static Object VALUE_RESOLUTION_VARIANT_BASE
      图像分辨率变体提示值 - 始终使用图像的标准分辨率。
      static Object VALUE_RESOLUTION_VARIANT_DEFAULT
      图像分辨率变体提示值 - 基于可能依赖于平台策略的默认启发式来选择图像分辨率变体
      static Object VALUE_RESOLUTION_VARIANT_DPI_FIT
      图像分辨率变体提示值 - 仅基于屏幕的DPI选择图像分辨率变体。
      static Object VALUE_RESOLUTION_VARIANT_SIZE_FIT
      图像分辨率变体提示值 - 基于屏幕的DPI和Graphics2D上下文中的变换来选择图像分辨率变体。
      static Object VALUE_STROKE_DEFAULT
      笔画归一化控制提示值 - 几何可能被修改或者保留为纯粹，取决于给定实现中的权衡。
      static Object VALUE_STROKE_NORMALIZE
      笔画归一化控制提示值 - 几何应归一化，以提高线条的均匀性或间距以及整体美感。
      static Object VALUE_STROKE_PURE
      笔画归一化控制提示值 - 几何应保持未修改，并以亚像素精度呈现。
      static Object VALUE_TEXT_ANTIALIAS_DEFAULT
      文本抗锯齿提示值 - 文本呈现是根据 KEY_ANTIALIASING提示或默认选择的实现方式完成的。
      static Object VALUE_TEXT_ANTIALIAS_GASP
      文本抗锯齿提示值 - 文本呈现请求使用字体资源中的信息，为每个点大小指定是否应用 VALUE_TEXT_ANTIALIAS_ON或 VALUE_TEXT_ANTIALIAS_OFF 。
      static Object VALUE_TEXT_ANTIALIAS_LCD_HBGR
      文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照B，G，R的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HBGR）的三倍， 。
      static Object VALUE_TEXT_ANTIALIAS_LCD_HRGB
      文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照R，G，B的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HRGB）的三倍， 。
      static Object VALUE_TEXT_ANTIALIAS_LCD_VBGR
      文本抗锯齿提示值 - 要求显示的文本被优化为具有从B，G，R的显示器顶部到底部的子像素组织的LCD显示，使得垂直子像素分辨率是全像素垂直分辨率（VBGR）的三倍。
      static Object VALUE_TEXT_ANTIALIAS_LCD_VRGB
      文本抗锯齿提示值 - 要求文本显示优化为具有子像素组织的液晶显示器，从R，G，B的显示顶部到底部，使得垂直子像素分辨率是全像素垂直分辨率（VRGB）的三倍。
      static Object VALUE_TEXT_ANTIALIAS_OFF
      文本抗锯齿提示值 - 文本呈现没有任何形式的抗锯齿。
      static Object VALUE_TEXT_ANTIALIAS_ON
      文本抗锯齿提示值 - 文本渲染是通过某种形式的抗锯齿来完成的。

    • 构造方法摘要

      构造方法
      Constructor 描述
      RenderingHints​(RenderingHints.Key key, Object value)
      使用指定的键/值对构造新对象。
      RenderingHints​(Map<RenderingHints.Key,?> init)
      构造一个新对象，该对象具有从指定的Map对象初始化的键和值，该对象可能为null。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(RenderingHints hints)
      将所有的键和对应的值从指定的 RenderingHints对象添加到此 RenderingHints对象。
      void clear​()
      清除所有键/值对的此 RenderingHints对象。
      Object clone​()
      创建此的克隆 RenderingHints具有相同的内容，因为这对象 RenderingHints对象。
      boolean containsKey​(Object key)
      如果此 RenderingHints包含指定键的映射，则返回 true 。
      boolean containsValue​(Object value)
      如果此RenderingHints将一个或多个键映射到指定的值，则返回true。
      Set<Map.Entry<Object,Object>> entrySet​()
      返回 Set视图包含在此映射的 RenderingHints 。
      boolean equals​(Object o)
      将指定的 Object与此 RenderingHints进行比较以获得相等性。
      Object get​(Object key)
      返回指定键映射到的值。
      int hashCode​()
      返回此 RenderingHints的哈希码值。
      boolean isEmpty​()
      如果此 RenderingHints包含键值映射，则返回 true 。
      Set<Object> keySet​()
      返回此 RenderingHints包含的键的 Set视图。
      Object put​(Object key, Object value)
      将指定的 key映射到此 RenderingHints对象中指定的 value 。
      void putAll​(Map<?,?> m)
      将所有映射从指定的 Map到此 RenderingHints 。
      Object remove​(Object key)
      从该 RenderingHints对象中删除该键及其对应的值。
      int size​()
      返回此 RenderingHints键值映射的 RenderingHints 。
      String toString​()
      返回hashmap的相当长的字符串表示形式，其中包含键值与此 RenderingHints对象的值的映射。
      Collection<Object> values​()
      返回 Collection视图包含在这个值的 RenderingHints 。

      • Methods inherited from interface java.util.Map

        compute, computeIfAbsent, computeIfPresent, entry, forEach, getOrDefault, merge, of, of, of, of, of, of, of, of, of, of, of, ofEntries, putIfAbsent, remove, replace, replace, replaceAll

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • KEY_ANTIALIASING

        public static final RenderingHints.Key KEY_ANTIALIASING
        抗锯齿提示键。 ANTIALIASING提示控制Graphics2D对象的几何渲染方法是否会尝试减少沿形状边缘的混叠伪影。

        典型的抗锯齿算法通过根据估计的形状的部分像素覆盖率将沿形状边界的像素的现有颜色与所请求的填充颜色混合起作用。

        此提示的允许值为

        • VALUE_ANTIALIAS_ON
        • VALUE_ANTIALIAS_OFF
        • VALUE_ANTIALIAS_DEFAULT

      • VALUE_ANTIALIAS_ON

        public static final Object VALUE_ANTIALIAS_ON
        抗混叠提示值 - 使用抗锯齿来实现渲染。
        另请参见：
        KEY_ANTIALIASING

      • VALUE_ANTIALIAS_OFF

        public static final Object VALUE_ANTIALIAS_OFF
        抗锯齿提示值 - 渲染完成时没有抗锯齿。
        另请参见：
        KEY_ANTIALIASING

      • VALUE_ANTIALIAS_DEFAULT

        public static final Object VALUE_ANTIALIAS_DEFAULT
        抗锯齿提示值 - 使用实现选择的默认抗锯齿模式进行渲染。
        另请参见：
        KEY_ANTIALIASING

      • KEY_RENDERING

        public static final RenderingHints.Key KEY_RENDERING
        呈现提示键。 RENDERING提示是一个一般性的提示，提供了一个高级别的建议，以便在评估权衡时是否偏移算法选择更多的速度或质量。 对于任何渲染或图像处理操作，可以参考这个提示，但是决定通常会优先于其他更具体的提示。

        此提示的允许值为

        • VALUE_RENDER_SPEED
        • VALUE_RENDER_QUALITY
        • VALUE_RENDER_DEFAULT

      • VALUE_RENDER_SPEED

        public static final Object VALUE_RENDER_SPEED
        渲染提示值 - 选择渲染算法以优先输出速度。
        另请参见：
        KEY_RENDERING

      • VALUE_RENDER_QUALITY

        public static final Object VALUE_RENDER_QUALITY
        渲染提示值 - 选择渲染算法以优化输出质量。
        另请参见：
        KEY_RENDERING

      • VALUE_RENDER_DEFAULT

        public static final Object VALUE_RENDER_DEFAULT
        渲染提示值 - 渲染算法由实现选择，以实现性能与质量的良好折衷。
        另请参见：
        KEY_RENDERING

      • KEY_DITHERING

        public static final RenderingHints.Key KEY_DITHERING
        抖动提示键。 DITHERING提示控制在以有限的颜色分辨率存储到目的地时近似近似颜色。

        一些渲染目的地可以支持有限数量的颜色选择，其可能无法准确地表示在渲染操作期间可能导致的全部颜色。 对于这样的目的地， DITHERING提示控制是否使用单个像素值的平坦实心填充完成渲染，该像素值是与请求的最接近的支持颜色，或者是否将填充颜色的图案，以便更好地近似颜色。

        此提示的允许值为

        • VALUE_DITHER_DISABLE
        • VALUE_DITHER_ENABLE
        • VALUE_DITHER_DEFAULT

      • VALUE_DITHER_DISABLE

        public static final Object VALUE_DITHER_DISABLE
        抖动提示值 - 渲染几何时不要抖动。
        另请参见：
        KEY_DITHERING

      • VALUE_DITHER_ENABLE

        public static final Object VALUE_DITHER_ENABLE
        抖动提示值 - 如果需要，渲染几何时，抖动。
        另请参见：
        KEY_DITHERING

      • VALUE_DITHER_DEFAULT

        public static final Object VALUE_DITHER_DEFAULT
        抖动提示值 - 使用实现选择的抖动的默认值。
        另请参见：
        KEY_DITHERING

      • KEY_TEXT_ANTIALIASING

        public static final RenderingHints.Key KEY_TEXT_ANTIALIASING
        文本抗锯齿提示键。 TEXT_ANTIALIASING提示可以独立于用于形状渲染的选择，控制文本使用抗锯齿算法。 通常，应用程序可能希望仅对文本使用抗锯齿，而不是为其他形状使用抗锯齿。 另外，用于减少文本的混叠伪影的算法通常比为一般渲染开发的算法更复杂，因此这个提示键提供可以控制某些特定于文本的算法的某些选项的附加值。 如果留在DEFAULT状态，这个提示通常会推迟到正常的KEY_ANTIALIASING提示键的值。

        此提示的允许值为

        • VALUE_TEXT_ANTIALIAS_ON
        • VALUE_TEXT_ANTIALIAS_OFF
        • VALUE_TEXT_ANTIALIAS_DEFAULT
        • VALUE_TEXT_ANTIALIAS_GASP
        • VALUE_TEXT_ANTIALIAS_LCD_HRGB
        • VALUE_TEXT_ANTIALIAS_LCD_HBGR
        • VALUE_TEXT_ANTIALIAS_LCD_VRGB
        • VALUE_TEXT_ANTIALIAS_LCD_VBGR

      • VALUE_TEXT_ANTIALIAS_ON

        public static final Object VALUE_TEXT_ANTIALIAS_ON
        文本抗锯齿提示值 - 文本渲染是通过某种形式的抗锯齿来完成的。
        另请参见：
        KEY_TEXT_ANTIALIASING

      • VALUE_TEXT_ANTIALIAS_OFF

        public static final Object VALUE_TEXT_ANTIALIAS_OFF
        文本抗锯齿提示值 - 文本呈现没有任何形式的抗锯齿。
        另请参见：
        KEY_TEXT_ANTIALIASING

      • VALUE_TEXT_ANTIALIAS_DEFAULT

        public static final Object VALUE_TEXT_ANTIALIAS_DEFAULT
        文本抗锯齿提示值 - 文本渲染是根据 KEY_ANTIALIASING提示或实现选择的默认完成的。
        另请参见：
        KEY_TEXT_ANTIALIASING

      • VALUE_TEXT_ANTIALIAS_GASP

        public static final Object VALUE_TEXT_ANTIALIAS_GASP
        文本抗锯齿提示值 - 请求文本呈现以使用字体资源中的信息指定每个点大小是否应用VALUE_TEXT_ANTIALIAS_ON或VALUE_TEXT_ANTIALIAS_OFF 。

        TrueType字体通常在'gasp'表中提供此信息。 在没有此信息的情况下，特定字体和大小的行为由实现默认值确定。

        注意：字体设计师通常会仔细提示最常见的用户界面点大小的字体。 因此，“喘气”表可能会指定仅在这些尺寸上使用暗示，而不是“平滑”。 所以在很多情况下，结果文本显示等同于VALUE_TEXT_ANTIALIAS_OFF 。 这可能是意想不到的但是是正确的。

        由多种物理字体组成的逻辑字体将一致性将使用最适合整体复合字体的设置。

        从以下版本开始：
        1.6
        另请参见：
        KEY_TEXT_ANTIALIASING

      • VALUE_TEXT_ANTIALIAS_LCD_HRGB

        public static final Object VALUE_TEXT_ANTIALIAS_LCD_HRGB
        文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照R，G，B的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HRGB）的三倍， 。 这是最常见的配置。 选择其他LCD子像素配置之一的显示提示可能会导致未聚焦的文本。

        笔记：
        选择是否应用任何LCD文本提示值时的实现可以考虑到因素，包括要求目标的颜色深度至少为每像素15位（即每个颜色分量5位），字体的特征，例如嵌入式位图可能会产生更好的结果，或者当显示给非本地网络显示设备时，只有在适当的协议可用时才启用它，或者如果执行非常高的分辨率渲染或者目标设备不合适，则忽略提示：例如打印时。

        这些提示可以在渲染到软件映像时同样适用，但是这些图像可能不适合于一般导出，因为文本将被适当地用于特定的子像素组织。 有损图像也不是很好的选择，也不是像有限颜色的GIF这样的图像格式。 因此，除非图像仅用于在具有相同配置的显示设备上呈现，否则其他一些文本反锯齿提示（如VALUE_TEXT_ANTIALIAS_ON）可能是更好的选择。

        选择与使用中的LCD显示不符的值可能会导致文字质量下降。 在不具有与LCD显示器相同特性的显示设备（即CRT）上，整体效果可能与标准文本抗锯齿相似，但质量可能会因颜色失真而降低。 模拟连接的液晶显示器与标准文本抗锯齿相比也可能没有任何优势，与CRT类似。

        换句话说，为了获得最佳效果，请使用具有数字显示连接器的LCD显示器，并指定适当的子像素配置。

        从以下版本开始：
        1.6
        另请参见：
        KEY_TEXT_ANTIALIASING

      • VALUE_TEXT_ANTIALIAS_LCD_HBGR

        public static final Object VALUE_TEXT_ANTIALIAS_LCD_HBGR
        文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照B，G，R的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HBGR）的三倍， 。 这是比HRGB更不常见的配置。 选择其他LCD子像素配置之一的显示提示可能会导致未聚焦的文本。 有关何时应用此提示的详细信息，请参阅VALUE_TEXT_ANTIALIAS_LCD_HRGB 。
        从以下版本开始：
        1.6
        另请参见：
        KEY_TEXT_ANTIALIASING

      • VALUE_TEXT_ANTIALIAS_LCD_VRGB

        public static final Object VALUE_TEXT_ANTIALIAS_LCD_VRGB
        文本抗锯齿提示值 - 要求文本显示优化为具有子像素组织的液晶显示器，从R，G，B的显示顶部到底部，使得垂直子像素分辨率是全像素垂直分辨率（VRGB）的三倍。 垂直方向非常罕见，可能主要用于物理旋转的显示。 选择其他LCD子像素配置之一的显示提示可能会导致未聚焦的文本。 有关何时应用此提示的详细信息，请参阅VALUE_TEXT_ANTIALIAS_LCD_HRGB 。
        从以下版本开始：
        1.6
        另请参见：
        KEY_TEXT_ANTIALIASING

      • VALUE_TEXT_ANTIALIAS_LCD_VBGR

        public static final Object VALUE_TEXT_ANTIALIAS_LCD_VBGR
        文本抗锯齿提示值 - 要求显示的文本被优化为具有从B，G，R的显示器顶部到底部的子像素组织的LCD显示，使得垂直子像素分辨率是全像素垂直分辨率（VBGR）的三倍。 垂直方向非常罕见，可能主要用于物理旋转的显示。 选择其他LCD子像素配置之一的显示提示可能会导致未聚焦的文本。 有关何时应用此提示的详细信息，请参阅VALUE_TEXT_ANTIALIAS_LCD_HRGB 。
        从以下版本开始：
        1.6
        另请参见：
        KEY_TEXT_ANTIALIASING

      • KEY_TEXT_LCD_CONTRAST

        public static final RenderingHints.Key KEY_TEXT_LCD_CONTRAST
        LCD文字对比度提示键。 该值是一个Integer对象，当与LCD文本反锯齿提示（如VALUE_TEXT_ANTIALIAS_LCD_HRGB）结合使用时，该对象用作文本对比度调整。
        • 值应为100到250范围内的正整数。
        • 较低的值（例如100）对应于在浅色背景上显示深色文字时的较高对比度文本。
        • 较高的值（例如200）对应于在浅色背景上显示深色文字时的较低对比度文本。
        • 典型的有用值在140-180的范围内。
        • 如果未指定值，则将应用系统或实现默认值。
        默认值可以预期在大多数情况下是足够的，因此客户端很少需要为此提示指定一个值，除非它们具有适当值的具体信息。 较高的值并不意味着较高的对比度，实际上是相反的。 校正以与显示系统的非线性感知亮度响应的伽马调整类似的方式应用，但是不表示对其进行全面校正。
        从以下版本开始：
        1.6
        另请参见：
        KEY_TEXT_ANTIALIASING

      • KEY_FRACTIONALMETRICS

        public static final RenderingHints.Key KEY_FRACTIONALMETRICS
        字体分数指标提示键。 FRACTIONALMETRICS提示控制单个字符字形的定位是否考虑了字体的缩放字符前进的子像素精度，或者这些前进向量是否舍入到整个设备像素的整数。 此提示仅建议使用多少精度来定位字形，并且不指定或推荐是否应修改字形的实际光栅化或像素边界以匹配。

        将文本呈现为低分辨率设备（如屏幕）将必然涉及多个舍入操作，因为字符字形的形状和度量的高质量和精确定义必须与分立的设备像素相匹配。 理想情况下，字体在文本布局中的定位将通过根据点大小缩放字体中的设计度量来计算，但是缩放的前进宽度不一定是整数像素。 如果根据这些缩放的设计度量字形以子像素精度定位，则理想地需要针对每个可能的子像素原点来调整光栅化。

        不幸的是，在文本布局期间缩放定制成其精确子像素原点的每个字形将是非常昂贵的，因此通常使用基于整数设备位置的简化系统来布局文本。 字形的光栅化和缩放的前进宽度都被一起调整，以产生看起来很好的设备分辨率的文本，并且在字形之间具有一致的整数像素距离，以帮助字形看起来均匀一致地间隔并且可读。

        将光栅化字形的前进宽度的舍入到整数的过程意味着文本串的字符密度和总长度将与理论设计测量值不同，这是由于每个调整的宽度的一系列小的差异的累积字形。 每个字形的具体差异将会有所不同，有些更为宽泛，有些比其理论设计尺寸更窄。 因此，字符密度和长度的总体差异将由许多因素而变化，这些因素包括字体，被指定的具体设备分辨率以及被选择以表示呈现的字符串的字形。 因此，在多个设备分辨率下渲染相同的字符串可能会产生整个字符串的广泛变化的度量。

        当启用FRACTIONALMETRICS ，真实字体设计度量按照点大小进行缩放，并用于具有子像素精度的布局。 因此，字符串的平均密度和长字符串的总长度将与字体的理论设计更紧密地匹配，但可读性可能会受到影响，因为单独的字符对可能并不总是看起来相距一致，取决于子字形源的像素累积与设备像素网格相啮合。 当执行在各种各样的输出分辨率之间必须一致的文本布局时，启用此提示可能是可取的。 具体来说，在文本的布局正在诸如最终将在高分辨率打印机或排版设备上呈现的用于输出的屏幕的低分辨率设备上预览的情况下，这种提示可能是期望的。

        禁用时，缩放的设计度量将舍入或调整为布局的整数距离。 任何特定的字形对之间的距离在设备上将更加均匀，但是长字符串的密度和总长度可能不再符合字体设计者的理论意图。 禁用此提示通常会在低分辨率设备（如计算机显示器）上产生更可读的结果。

        该键的允许值为

        • VALUE_FRACTIONALMETRICS_OFF
        • VALUE_FRACTIONALMETRICS_ON
        • VALUE_FRACTIONALMETRICS_DEFAULT

      • VALUE_FRACTIONALMETRICS_OFF

        public static final Object VALUE_FRACTIONALMETRICS_OFF
        字体分数度量提示值 - 字符字形以先进宽度定位，四舍五入到像素边界。
        另请参见：
        KEY_FRACTIONALMETRICS

      • VALUE_FRACTIONALMETRICS_ON

        public static final Object VALUE_FRACTIONALMETRICS_ON
        字体分数度量提示值 - 字符字形以子像素精度定位。
        另请参见：
        KEY_FRACTIONALMETRICS

      • VALUE_FRACTIONALMETRICS_DEFAULT

        public static final Object VALUE_FRACTIONALMETRICS_DEFAULT
        字体分数度量提示值 - 字符字形按照实现选择的精度进行定位。
        另请参见：
        KEY_FRACTIONALMETRICS

      • KEY_INTERPOLATION

        public static final RenderingHints.Key KEY_INTERPOLATION
        插值提示键。 INTERPOLATION提示控制在图像渲染操作过程中如何对图像像素进行过滤或重新采样。

        定义隐式图像以在整数坐标位置提供颜色样本。 当图像呈现直立而没有缩放到目的地时，选择哪个图像像素映射到哪个设备像素是显而易见的，并且图像中整数坐标位置处的样本被传送到设备像素上相应整数位置处的像素网格一个一个。 当图像以缩放，旋转或以其他方式变换的坐标系显示时，设备像素坐标的映射返回到图像可以提出使用什么颜色样本的连续坐标位于提供的整数位置之间的问题图像样本。 插值算法定义了基于周围整数坐标处的颜色样本为图像中任何连续坐标提供颜色样本的函数。

        此提示的允许值为

        • VALUE_INTERPOLATION_NEAREST_NEIGHBOR
        • VALUE_INTERPOLATION_BILINEAR
        • VALUE_INTERPOLATION_BICUBIC

      • VALUE_INTERPOLATION_NEAREST_NEIGHBOR

        public static final Object VALUE_INTERPOLATION_NEAREST_NEIGHBOR
        插值提示值 - 使用图像中最近的相邻整数坐标样本的颜色样本。 在概念上，图像被视为围绕每个图像像素的中心的颜色的单位尺寸的正方形区域的网格。

        随着图像的放大，它将看起来相当块。 当图像缩小时，源像素的颜色将被使用未修改，或者完全在输出表示中跳过。

        另请参见：
        KEY_INTERPOLATION

      • VALUE_INTERPOLATION_BILINEAR

        public static final Object VALUE_INTERPOLATION_BILINEAR
        插值提示值 - 图像中最近邻近4个整数坐标样本的颜色样本被线性内插以产生颜色样本。 在概念上，图像被视为一组无限小的点颜色样本，其仅在整数坐标像素的中心处具有值，并且这些像素中心之间的空间用直线连接相邻离散样本的线性斜坡填充。

        当图像放大时，图像中的颜色之间没有块状边缘，因为像NEAREST_NEIGHBOR一样 ，但是混合可能会显示沿水平和垂直边缘的一些细微的不连续性，这些不连续性与由突然变化引起的样本从样本的一侧到另一侧的插值的斜率。 随着图像缩小，更多的图像像素在其结果输出中表现出其颜色样本，因为每个输出像素从最多4个图像像素接收颜色信息。

        另请参见：
        KEY_INTERPOLATION

      • VALUE_INTERPOLATION_BICUBIC

        public static final Object VALUE_INTERPOLATION_BICUBIC
        插值提示值 - 使用X和Y的三次函数对图像中9个附近整数坐标样本的颜色样本进行插值，以生成颜色样本。 在概念上，图像的视图与BILINEAR算法中使用的视图非常相似，不同之处在于连接样本之间的颜色斜率是弯曲的，并且在样本边界之间越过斜率时具有更好的连续性。

        当图像放大时，没有块状边缘，并且内插应该显得比BILINEAR更平滑，并且更好地描绘了原始图像中的任何边缘。 随着图像的缩小，原始图像的原始颜色样本中的更多的颜色信息将通过并表示。

        另请参见：
        KEY_INTERPOLATION

      • KEY_ALPHA_INTERPOLATION

        public static final RenderingHints.Key KEY_ALPHA_INTERPOLATION
        Alpha插补提示键。 ALPHA_INTERPOLATION提示是一个一般性的提示，提供了一个高级别的建议，用于在评估权衡时是否偏移alpha混合算法选择更多的速度或质量。

        这个提示可以控制alpha混合计算的选择，牺牲一些精度来使用快速查找表或更低精度的SIMD指令。 这种提示还可以控制在计算更多线性视觉效果的同时，以额外的每像素计算为代价，将颜色和alpha值转换为线性颜色空间。

        此提示的允许值为

        • VALUE_ALPHA_INTERPOLATION_SPEED
        • VALUE_ALPHA_INTERPOLATION_QUALITY
        • VALUE_ALPHA_INTERPOLATION_DEFAULT

      • VALUE_ALPHA_INTERPOLATION_SPEED

        public static final Object VALUE_ALPHA_INTERPOLATION_SPEED
        选择Alpha插值提示值 - alpha混合算法，优先于计算速度。
        另请参见：
        KEY_ALPHA_INTERPOLATION

      • VALUE_ALPHA_INTERPOLATION_QUALITY

        public static final Object VALUE_ALPHA_INTERPOLATION_QUALITY
        选择Alpha插值提示值 - alpha混合算法，偏好精度和视觉质量。
        另请参见：
        KEY_ALPHA_INTERPOLATION

      • VALUE_ALPHA_INTERPOLATION_DEFAULT

        public static final Object VALUE_ALPHA_INTERPOLATION_DEFAULT
        Alpha插值提示值 - alpha混合算法由实现选择，以实现性能与质量的良好折衷。
        另请参见：
        KEY_ALPHA_INTERPOLATION

      • KEY_COLOR_RENDERING

        public static final RenderingHints.Key KEY_COLOR_RENDERING
        显色提示键。 COLOR_RENDERING提示控制在将颜色存储到目标图像或表面时的近似和转换的准确性。

        当渲染或图像处理操作产生必须存储到目的地的颜色值时，必须首先将该颜色转换为适合存储到目标图像或曲面的形式。 最低限度，颜色分量必须转换为位表示，并以正确的顺序进行排序，或者在将数据存储到目标存储器之前必须选择颜色查找表中的索引。 没有这种最小的转换，目标中的数据可能表示随机，不正确或甚至不支持的值。 将渲染操作的结果快速转换为最常见目的地的颜色格式的算法是众所周知的，并且相当优选地执行。

        简单地进行最基本的颜色格式转换以颜色存储到目的地可以潜在地忽略的校准的差ColorSpace源和目的地或其他因素，诸如伽马校正的线性度。 除非源和目的地ColorSpace是相同的，为了正确执行渲染操作，最重要的是要表示的颜色的准确性，源颜色应该转换为独立的设备ColorSpace ，然后将结果转换回目的地ColorSpace 。 此外，如果在渲染操作期间执行诸如混合多个源颜色之类的计算，则如果选择中间装置独立的ColorSpace在所计算的值与所计算的值之间具有线性关系，则ColorSpace更大的视觉清晰度人眼对输出设备的响应曲线。

        此提示的允许值为

        • VALUE_COLOR_RENDER_SPEED
        • VALUE_COLOR_RENDER_QUALITY
        • VALUE_COLOR_RENDER_DEFAULT

      • VALUE_COLOR_RENDER_SPEED

        public static final Object VALUE_COLOR_RENDER_SPEED
        显色提示值 - 执行最快的颜色转换为输出设备的格式。
        另请参见：
        KEY_COLOR_RENDERING

      • VALUE_COLOR_RENDER_QUALITY

        public static final Object VALUE_COLOR_RENDER_QUALITY
        显色提示值 - 以最高的精度和视觉质量执行颜色转换计算。
        另请参见：
        KEY_COLOR_RENDERING

      • VALUE_COLOR_RENDER_DEFAULT

        public static final Object VALUE_COLOR_RENDER_DEFAULT
        显色渲染提示值 - 执行颜色转换计算，以表示性能和精度之间的最佳可用权衡。
        另请参见：
        KEY_COLOR_RENDERING

      • KEY_STROKE_CONTROL

        public static final RenderingHints.Key KEY_STROKE_CONTROL
        中风归一化控制提示键。 STROKE_CONTROL提示控制是否应允许渲染实现修改渲染形状的几何，以实现各种目的。

        一些实施方案可能能够使用优化的平台渲染库，其可以比给定平台上的传统软件渲染算法更快，但是也可能不支持浮点坐标。 一些实施方案也可以具有扰乱路径坐标的复杂算法，使得宽线在宽度和间距上显得更均匀。

        如果一个实现执行路径的任何类型的修改或“归一化”，它不应该在任何方向上将坐标移动超过半个像素。

        此提示的允许值为

        • VALUE_STROKE_NORMALIZE
        • VALUE_STROKE_PURE
        • VALUE_STROKE_DEFAULT
        从以下版本开始：
        1.3

      • VALUE_STROKE_DEFAULT

        public static final Object VALUE_STROKE_DEFAULT
        笔画归一化控制提示值 - 几何可能被修改或者保留为纯粹，取决于给定实现中的权衡。 通常，此设置允许实现使用基于快速整数坐标的平台渲染库，但不会特别要求标准化的均匀性或美观性。
        从以下版本开始：
        1.3
        另请参见：
        KEY_STROKE_CONTROL

      • VALUE_STROKE_NORMALIZE

        public static final Object VALUE_STROKE_NORMALIZE
        笔画归一化控制提示值 - 几何应归一化，以提高线条的均匀性或间距以及整体美感。 注意，对于给定的输入路径，不同的归一化算法可能比其他归一化算法更成功
        从以下版本开始：
        1.3
        另请参见：
        KEY_STROKE_CONTROL

      • VALUE_STROKE_PURE

        public static final Object VALUE_STROKE_PURE
        笔画归一化控制提示值 - 几何应保持未修改，并以亚像素精度呈现。
        从以下版本开始：
        1.3
        另请参见：
        KEY_STROKE_CONTROL

      • KEY_RESOLUTION_VARIANT

        public static final RenderingHints.Key KEY_RESOLUTION_VARIANT
        图像分辨率变体提示键。 RESOLUTION_VARIANT提示控制哪些图像分辨率变体应用于图像绘制。
        • VALUE_RESOLUTION_VARIANT_DEFAULT
        • VALUE_RESOLUTION_VARIANT_BASE
        • VALUE_RESOLUTION_VARIANT_SIZE_FIT
        • VALUE_RESOLUTION_VARIANT_DPI_FIT
        从以下版本开始：
        9

      • VALUE_RESOLUTION_VARIANT_DEFAULT

        public static final Object VALUE_RESOLUTION_VARIANT_DEFAULT
        图像分辨率变体提示值 - 基于可能依赖于平台策略的默认启发式来选择图像分辨率变体
        从以下版本开始：
        9
        另请参见：
        KEY_RESOLUTION_VARIANT

      • VALUE_RESOLUTION_VARIANT_BASE

        public static final Object VALUE_RESOLUTION_VARIANT_BASE
        图像分辨率变体提示值 - 始终使用图像的标准分辨率。
        从以下版本开始：
        9
        另请参见：
        KEY_RESOLUTION_VARIANT

      • VALUE_RESOLUTION_VARIANT_SIZE_FIT

        public static final Object VALUE_RESOLUTION_VARIANT_SIZE_FIT
        图像分辨率变体提示值 - 基于屏幕的DPI和Graphics2D上下文中的变换来选择图像分辨率变体。
        从以下版本开始：
        9
        另请参见：
        KEY_RESOLUTION_VARIANT

      • VALUE_RESOLUTION_VARIANT_DPI_FIT

        public static final Object VALUE_RESOLUTION_VARIANT_DPI_FIT
        图像分辨率变体提示值 - 仅基于屏幕的DPI选择图像分辨率变体。
        从以下版本开始：
        9
        另请参见：
        KEY_RESOLUTION_VARIANT

    • 构造方法详细信息

      • RenderingHints

        public RenderingHints​(Map<RenderingHints.Key,?> init)
        构造一个新对象，该对象具有从指定的Map对象初始化的键和值，该对象可能为null。
        参数
        init - 用于初始化提示的键/值对的映射，如果对象应为空，则为null

      • RenderingHints

        public RenderingHints​(RenderingHints.Key key,
                      Object value)
        使用指定的键/值对构造新对象。
        参数
        key - 特定提示属性的关键
        value - 使用 key指定的提示属性的值

    • 方法详细信息

      • size

        public int size​()
        返回此 RenderingHints键值映射的 RenderingHints 。
        Specified by:
        size在接口 Map<Object,Object>
        结果
        这个 RenderingHints的键值映射 RenderingHints 。

      • isEmpty

        public boolean isEmpty​()
        如果此 RenderingHints包含键值映射，则返回 true 。
        Specified by:
        isEmpty在接口 Map<Object,Object>
        结果
        true如果此 RenderingHints包含键值映射。

      • containsKey

        public boolean containsKey​(Object key)
        如果此 RenderingHints包含指定键的映射，则返回 true 。
        Specified by:
        containsKey在接口 Map<Object,Object>
        参数
        key - 在这个 RenderingHints的存在的密钥要测试。
        结果
        true如果此 RenderingHints包含指定键的映射。
        异常
        ClassCastException - 如果密钥不能被转换为 RenderingHints.Key

      • containsValue

        public boolean containsValue​(Object value)
        如果此RenderingHints将一个或多个键映射到指定的值，则返回true。 更正式地，返回true当且仅当该RenderingHints包含的至少一个映射到一个值v使得
          (value==null ? v==null : value.equals(v))
        。 此操作可能会需要时间线性RenderingHints大小的大多数实现RenderingHints 。
        Specified by:
        containsValue在接口 Map<Object,Object>
        参数
        value - 要在此 RenderingHints存在的值要进行测试。
        结果
        true如果这个 RenderingHints将一个或多个键映射到指定的值。

      • get

        public Object get​(Object key)
        返回指定键映射到的值。
        Specified by:
        get在接口 Map<Object,Object>
        参数
        key - 一个渲染提示键
        结果
        键在此对象中映射到的值，如果键未映射到此对象中的任何值， null 。
        异常
        ClassCastException - 如果密钥不能转换为 RenderingHints.Key
        另请参见：
        put(Object, Object)

      • put

        public Object put​(Object key,
                  Object value)
        将指定的key映射到此RenderingHints对象中指定的value 。 钥匙和价值都不能是null 。 可以通过使用等于原始密钥的密钥调用get方法来检索该值。
        Specified by:
        put在接口 Map<Object,Object>
        参数
        key - 渲染提示键。
        value - 渲染提示值。
        结果
        该对象中指定键的上一个值，如果没有， null 。
        异常
        NullPointerException - 如果键是 null 。
        ClassCastException - 如果密钥不能转换为 RenderingHints.Key
        IllegalArgumentException - 如果指定键的 Key.isCompatibleValue()方法为指定的值返回false
        另请参见：
        get(Object)

      • add

        public void add​(RenderingHints hints)
        将所有键和对应的值从指定的RenderingHints对象添加到此RenderingHints对象。 存在于此RenderingHints对象中但不在指定的RenderingHints对象中的键不受影响。
        参数
        hints - 要添加到此 RenderingHints对象的一组键/值对

      • clear

        public void clear​()
        清除所有键/值对的 RenderingHints对象。
        Specified by:
        clear在接口 Map<Object,Object>

      • remove

        public Object remove​(Object key)
        从这个RenderingHints对象中删除键及其对应的值。 如果密钥不在此RenderingHints对象中，此方法不执行任何操作。
        Specified by:
        remove在接口 Map<Object,Object>
        参数
        key - 渲染提示需要删除的关键
        结果
        密钥先前映射到此 RenderingHints对象中的值，如果密钥没有映射， RenderingHints null 。
        异常
        ClassCastException - 如果密钥不能转换为 RenderingHints.Key

      • putAll

        public void putAll​(Map<?,?> m)
        将所有映射从指定的Map到此RenderingHints 。 这些映射取代了目前在指定的Map中的任何键的RenderingHints任何映射。
        Specified by:
        putAll在接口 Map<Object,Object>
        参数
        m - 指定的 Map
        异常
        ClassCastException - 在指定的 Map中的键或值的 Map可防止将其存储在此 RenderingHints 。
        IllegalArgumentException - 指定的 Map中某个键或值的某些方面可防止将其存储在此 RenderingHints 。

      • keySet

        public Set<Object> keySet​()
        返回Set视图包含在这个按键的RenderingHints 。 该套装由支持RenderingHints ，所以这种变化RenderingHints反映在Set ，反之亦然。 如果RenderingHints被修改，而在迭代Set正在进行中，迭代的结果是不确定的。 所述Set支撑元件移除，即从相应的映射RenderingHints ，经由Iterator.remove ， Set.remove ， removeAll retainAll ，和clear操作。 它不支持add或addAll操作。
        Specified by:
        keySet在接口 Map<Object,Object>
        结果
        一个 Set视图的钥匙包含在这个 RenderingHints 。

      • values

        public Collection<Object> values​()
        返回Collection视图包含在这个值的RenderingHints 。 该Collection由支持RenderingHints ，所以对变化RenderingHints反映在Collection ，反之亦然。 如果RenderingHints被修改，而在迭代Collection正在进行中，迭代的结果是不确定的。 所述Collection支持元素移除，其去除从所述相应的映射RenderingHints ，经由Iterator.remove ， Collection.remove ， removeAll ， retainAll和clear操作。 它不支持add或addAll操作。
        Specified by:
        values在接口 Map<Object,Object>
        结果
        一个 Collection视图中包含的值 RenderingHints 。

      • entrySet

        public Set<Map.Entry<Object,Object>> entrySet​()
        返回此RenderingHints包含的映射的Set视图。 返回的Set中的每个元素都是Map.Entry 。 该Set由支持RenderingHints ，所以对变化RenderingHints反映在Set ，反之亦然。 如果RenderingHints的同时，同时在迭代改进Set正在进行中，迭代的结果是不确定的。

        从RenderingHints对象返回的entrySet不可修改。

        Specified by:
        entrySet接口 Map<Object,Object>
        结果
        一个 Set视图包含在此映射的 RenderingHints 。

      • equals

        public boolean equals​(Object o)
        将指定的Object与此RenderingHints作比较。 如果指定的对象也是一个Map ，并且两个Map对象表示相同的映射，则返回true 。 更正式地，两个Map对象t1和t2表示相同的映射，如果t1.keySet().equals(t2.keySet())和k中的每个键t1.keySet() ，
          (t1.get(k)==null ? t2.get(k)==null : t1.get(k).equals(t2.get(k)))
        。 这样可确保equals方法在Map接口的不同实现中正常工作。
        Specified by:
        equals在接口 Map<Object,Object>
        重写：
        equals在 Object
        参数
        o - Object要与此 RenderingHints进行比较。
        结果
        true如果指定的 Object等于这个 RenderingHints 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此RenderingHints的哈希码值。 RenderingHints的哈希码被定义为RenderingHints对象的entrySet视图中每个Entry的hashCodes的总和。 这确保了t1.equals(t2)意味着t1.hashCode()==t2.hashCode()对于任何两个Map对象t1和t2 ，所要求的一般合同Object.hashCode 。
        Specified by:
        hashCode在接口 Map<Object,Object>
        重写：
        hashCode在 Object
        结果
        这个哈希码值为 RenderingHints 。
        另请参见：
        Map.Entry.hashCode() ，
Object.hashCode() ，
Object.equals(Object) ，
equals(Object)

      • clone

        public Object clone​()
        创建此的克隆 RenderingHints具有相同的内容，因为这对象 RenderingHints对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • toString

        public String toString​()
        返回hashmap的相当长的字符串表示形式，其中包含键值与此 RenderingHints对象的值的映射。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderingHints.Key (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class RenderingHints.Key

  • java.lang.Object
    • java.awt.RenderingHints.Key
  • Enclosing class:
    RenderingHints

    public abstract static class RenderingHints.Key
extends Object
    定义与RenderingHints类一起使用的所有键的基本类型，以控制渲染和成像管道中的各种算法选择。 这个类的实例是不可变的和唯一的，这意味着可以使用==操作符而不是更昂贵的equals()方法进行匹配测试。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Key​(int privatekey)
      使用指定的私钥构建密钥。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      所有Key对象的equals方法将返回与等式运算符“==”相同的结果。
      int hashCode​()
      所有Key对象的哈希码将与System.identityHashCode（）方法定义的对象的系统标识码相同。
      protected int intKey​()
      返回该子类实例化此Key的私有整数键。
      abstract boolean isCompatibleValue​(Object val)
      如果指定的对象是此Key的有效值，则返回true。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Key

        protected Key​(int privatekey)
        使用指定的私钥构建密钥。 Key的每个子类维护其自己唯一的整数键域。 不能构造具有相同整数键和相同特定子类的两个对象。 如果尝试使用与该子类的预先存在的实例相同的整数键来构造给定类的另一个对象，则将抛出异常。
        参数
        privatekey - 指定的键

    • 方法详细信息

      • isCompatibleValue

        public abstract boolean isCompatibleValue​(Object val)
        如果指定的对象是此Key的有效值，则返回true。
        参数
        val - Object以测试有效性
        结果
        true如果val有效; 否则为false 。

      • intKey

        protected final int intKey​()
        返回该子类实例化此Key的私有整数键。
        结果
        该子类的私有整数关键字与此Key实例化。

      • hashCode

        public final int hashCode​()
        所有Key对象的哈希码将与System.identityHashCode（）方法定义的对象的系统标识码相同。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public final boolean equals​(Object o)
        所有Key对象的equals方法将返回与等式运算符“==”相同的结果。
        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Robot (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Robot

  • java.lang.Object
    • java.awt.Robot

  • public class Robot
extends Object
    此类用于生成本机系统输入事件，用于测试自动化，自动运行演示和需要鼠标和键盘控制的其他应用程序。 Robot的主要目的是为了方便Java平台实现的自动化测试。

    使用类生成输入事件不同于将事件发布到AWT事件队列或AWT组件，因为事件在平台的本机输入队列中生成。 例如， Robot.mouseMove将实际上移动鼠标光标而不仅仅是生成鼠标移动事件。

    请注意，某些平台需要特殊权限或扩展才能访问低级别的输入控制。 如果当前平台配置不允许输入控制，则在尝试构造Robot对象时将抛出AWTException 。 例如，如果X服务器不支持（或未启用）XTEST 2.2标准扩展名，则X-Window系统将抛出异常。

    使用Robot进行自检以外的其他应用程序应优先处理这些错误条件。

    从以下版本开始：
    1.3

    • 构造方法摘要

      构造方法
      Constructor 描述
      Robot​()
      在主屏幕的坐标系中构造一个Robot对象。
      Robot​(GraphicsDevice screen)
      为给定的屏幕设备创建一个机器人。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MultiResolutionImage createMultiResolutionScreenCapture​(Rectangle screenRect)
      创建包含从屏幕读取的像素的图像。
      BufferedImage createScreenCapture​(Rectangle screenRect)
      创建包含从屏幕读取的像素的图像。
      void delay​(int ms)
      睡在指定的时间。
      int getAutoDelay​()
      返回此机器人在生成事件后休眠的毫秒数。
      Color getPixelColor​(int x, int y)
      返回给定屏幕坐标处的像素颜色。
      boolean isAutoWaitForIdle​()
      返回此机器人是否在生成事件后自动调用 waitForIdle 。
      void keyPress​(int keycode)
      按一个给定的键。
      void keyRelease​(int keycode)
      释放给定的键
      void mouseMove​(int x, int y)
      将鼠标指针移动到给定的屏幕坐标。
      void mousePress​(int buttons)
      按一个或多个鼠标按钮。
      void mouseRelease​(int buttons)
      释放一个或多个鼠标按钮。
      void mouseWheel​(int wheelAmt)
      在装有轮子的鼠标上旋转滚轮。
      void setAutoDelay​(int ms)
      设置机器人在生成事件后睡眠的毫秒数。
      void setAutoWaitForIdle​(boolean isOn)
      设置此机器人是否在生成事件后自动调用 waitForIdle 。
      String toString​()
      返回此Robot的字符串表示形式。
      void waitForIdle​()
      等待直到事件队列上的所有事件都处理完毕。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Robot

        public Robot​()
      throws AWTException
        在主屏幕的坐标系中构造一个Robot对象。
        异常
        AWTException - 如果平台配置不允许低电平输入控制。 当GraphicsEnvironment.isHeadless（）返回true时，总是会抛出此异常
        SecurityException - 如果没有授予 createRobot权限
        另请参见：
        GraphicsEnvironment.isHeadless() ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • Robot

        public Robot​(GraphicsDevice screen)
      throws AWTException
        为给定的屏幕设备创建一个机器人。 传递给Robot方法的坐标如mouseMove，getPixelColor和createScreenCapture将被解释为与指定屏幕在同一坐标系中。 请注意，根据平台配置，多个屏幕可以是：
        • 共享相同的坐标系以形成组合的虚拟屏幕
        • 使用不同的坐标系作为独立屏幕

        如果重新配置屏幕设备以使坐标系受到影响，则现有Robot对象的行为是未定义的。

        参数
        screen - 一个屏幕GraphicsDevice，指示机器人将在其中操作的坐标系。
        异常
        AWTException - 如果平台配置不允许低级别的输入控制。 当GraphicsEnvironment.isHeadless（）返回true时，总是会抛出此异常。
        IllegalArgumentException - 如果 screen不是屏幕GraphicsDevice。
        SecurityException - 如果没有授予 createRobot权限
        另请参见：
        GraphicsEnvironment.isHeadless() ， GraphicsDevice ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

    • 方法详细信息

      • mouseMove

        public void mouseMove​(int x,
                      int y)
        将鼠标指针移动到给定的屏幕坐标。
        参数
        x - X位置
        y - Y位置

      • mousePress

        public void mousePress​(int buttons)
        按一个或多个鼠标按钮。 应使用mouseRelease(int)方法释放鼠标按钮。
        参数
        buttons - 按钮面具; 一个或多个鼠标按钮掩码的组合。

        允许仅使用有效值的组合作为buttons参数。 有效的组合包括InputEvent.BUTTON1_DOWN_MASK ， InputEvent.BUTTON2_DOWN_MASK ， InputEvent.BUTTON3_DOWN_MASK由返回的和值InputEvent.getMaskForButton(button)方法。 有效组合也取决于Toolkit.areExtraMouseButtonsEnabled()的值如下：

        • 如果延长鼠标按钮的支持是disabled被Java那么就只允许使用下列标准按钮口罩： InputEvent.BUTTON1_DOWN_MASK ， InputEvent.BUTTON2_DOWN_MASK ， InputEvent.BUTTON3_DOWN_MASK 。
        • 如果通过Java支持扩展鼠标按键是enabled ，那么如果鼠标有三个以上的按钮，那么它允许使用标准按钮掩码和掩码来存在现有的扩展鼠标按钮。 这样就可以使用1到MouseInfo.getNumberOfButtons()范围内按钮对应的按钮掩码。
          建议使用InputEvent.getMaskForButton(button)方法获取任何鼠标按键的掩码。

        还可以接受以下标准按钮蒙版：

        • InputEvent.BUTTON1_MASK
        • InputEvent.BUTTON2_MASK
        • InputEvent.BUTTON3_MASK
        但是，建议使用InputEvent.BUTTON1_DOWN_MASK ， InputEvent.BUTTON2_DOWN_MASK ， InputEvent.BUTTON3_DOWN_MASK代替。 应使用_DOWN_MASK或旧版_MASK扩展值，但不应混合这两个模型。
        异常
        IllegalArgumentException - 如果 buttons面具包含额外的鼠标按钮的掩码和支持扩展的鼠标按钮是 disabled由Java
        IllegalArgumentException - 如果 buttons掩码包含鼠标不存在的额外鼠标按钮的掩码，并且支持扩展鼠标按钮，则为 enabled（由Java提供）
        另请参见：
        mouseRelease(int) ， InputEvent.getMaskForButton(int) ， Toolkit.areExtraMouseButtonsEnabled() ， MouseInfo.getNumberOfButtons() ， MouseEvent

      • mouseRelease

        public void mouseRelease​(int buttons)
        释放一个或多个鼠标按钮。
        参数
        buttons - 按钮面具; 一个或多个鼠标按钮掩码的组合。

        允许仅使用有效值的组合作为buttons参数。 有效的组合包括InputEvent.BUTTON1_DOWN_MASK ， InputEvent.BUTTON2_DOWN_MASK ， InputEvent.BUTTON3_DOWN_MASK由返回的和值InputEvent.getMaskForButton(button)方法。 有效组合还取决于Toolkit.areExtraMouseButtonsEnabled()的值如下：

        • 如果延长鼠标按钮的支持是disabled被Java那么就只允许使用下列标准按钮口罩： InputEvent.BUTTON1_DOWN_MASK ， InputEvent.BUTTON2_DOWN_MASK ， InputEvent.BUTTON3_DOWN_MASK 。
        • 如果通过Java支持扩展鼠标按键是enabled ，则允许使用现有扩展鼠标按钮的标准按钮掩码和掩码，如果鼠标有三个按钮。 以这种方式，可以使用与1到MouseInfo.getNumberOfButtons()范围内的按钮相对应的按钮遮罩 。
          建议使用InputEvent.getMaskForButton(button)方法获取任意鼠标按键的掩码。

        还可以接受以下标准按钮蒙版：

        • InputEvent.BUTTON1_MASK
        • InputEvent.BUTTON2_MASK
        • InputEvent.BUTTON3_MASK
        但是，建议使用InputEvent.BUTTON1_DOWN_MASK ， InputEvent.BUTTON2_DOWN_MASK ， InputEvent.BUTTON3_DOWN_MASK代替。 应该使用扩展的_DOWN_MASK或旧的_MASK值，但是这两个模型不应该混合使用。
        异常
        IllegalArgumentException - 如果 buttons面具包含用于额外的鼠标按钮的掩码，并且支持扩展鼠标按钮是由 disabled由Java
        IllegalArgumentException - 如果 buttons蒙版包含鼠标不存在的额外的鼠标按钮的掩码，并且支持扩展鼠标按钮是由 enabled由Java
        另请参见：
        mousePress(int) ， InputEvent.getMaskForButton(int) ， Toolkit.areExtraMouseButtonsEnabled() ， MouseInfo.getNumberOfButtons() ， MouseEvent

      • mouseWheel

        public void mouseWheel​(int wheelAmt)
        在装有轮子的鼠标上旋转滚轮。
        参数
        wheelAmt - 移动鼠标滚轮的“凹口”数量负值表示向上/远离用户的移动，正值表示向用户移动/移动。
        从以下版本开始：
        1.4

      • keyPress

        public void keyPress​(int keycode)
        按一个给定的键。 密钥应使用keyRelease方法发布。

        具有与其相关联的多个物理键的键代码（例如， KeyEvent.VK_SHIFT可能意味着左移或右移键）将映射到左键。

        参数
        keycode - 按键（例如 KeyEvent.VK_A ）
        异常
        IllegalArgumentException - 如果 keycode不是有效的密钥
        另请参见：
        keyRelease(int) ， KeyEvent

      • keyRelease

        public void keyRelease​(int keycode)
        释放给定的键

        具有与其相关联的多个物理键的键代码（例如， KeyEvent.VK_SHIFT可能意味着左移或右移键）将映射到左键。

        参数
        keycode - 释放钥匙（例如 KeyEvent.VK_A ）
        异常
        IllegalArgumentException - 如果 keycode不是有效的密钥
        另请参见：
        keyPress(int) ， KeyEvent

      • getPixelColor

        public Color getPixelColor​(int x,
                           int y)
        返回给定屏幕坐标处的像素颜色。
        参数
        x - 像素的X位置
        y - 像素的Y位置
        结果
        像素的颜色

      • createScreenCapture

        public BufferedImage createScreenCapture​(Rectangle screenRect)
        创建包含从屏幕读取的像素的图像。 此图像不包括鼠标光标。
        参数
        screenRect - 在屏幕坐标中进行矩形捕获
        结果
        拍摄的图像
        异常
        IllegalArgumentException - 如果 screenRect宽度和高度不大于零
        SecurityException - 如果没有授予 readDisplayPixels权限
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • createMultiResolutionScreenCapture

        public MultiResolutionImage createMultiResolutionScreenCapture​(Rectangle screenRect)
        创建包含从屏幕读取的像素的图像。 此图像不包括鼠标光标。 如果存在从用户空间到屏幕（设备）空间的缩放变换，则可以使用此方法。 通常这意味着显示器是高分辨率屏幕，尽管严格意味着有任何这种转换的情况。 返回一个MultiResolutionImage 。

        对于非缩放显示， MultiResolutionImage将具有一个图像变体：

        • 基本图像与用户指定的大小。

        对于具有缩放变换的高分辨率显示， MultiResolutionImage将具有两个图像变体：

        • 基本图像与用户指定的大小。 这是从屏幕缩放。
        • 本机设备分辨率图像与设备大小像素。

        例：

           Image nativeResImage; MultiResolutionImage mrImage = robot.createMultiResolutionScreenCapture(frame.getBounds()); List<Image> resolutionVariants = mrImage.getResolutionVariants(); if (resolutionVariants.size() > 1) { nativeResImage = resolutionVariants.get(1); } else { nativeResImage = resolutionVariants.get(0); }
        参数
        screenRect - 矩形捕获在屏幕坐标
        结果
        拍摄的图像
        异常
        IllegalArgumentException - 如果 screenRect宽度和高度不大于零
        SecurityException - 如果没有授予 readDisplayPixels权限
        从以下版本开始：
        9
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • isAutoWaitForIdle

        public boolean isAutoWaitForIdle​()
        返回此机器人是否在生成事件后自动调用 waitForIdle 。
        结果
        是否自动调用 waitForIdle

      • setAutoWaitForIdle

        public void setAutoWaitForIdle​(boolean isOn)
        设置此机器人是否在生成事件后自动调用 waitForIdle 。
        参数
        isOn - 是否自动调用 waitForIdle

      • getAutoDelay

        public int getAutoDelay​()
        返回此机器人在生成事件后休眠的毫秒数。
        结果
        延迟时间（以毫秒为单位）

      • setAutoDelay

        public void setAutoDelay​(int ms)
        设置机器人在生成事件后睡眠的毫秒数。
        参数
        ms - 以毫秒为单位的延迟持续时间
        异常
        IllegalArgumentException - 如果 ms不在0到60,000毫秒之间

      • delay

        public void delay​(int ms)
        睡在指定的时间。 要抓住发生的任何InterruptedException ，可以使用Thread.sleep() 。
        参数
        ms - 以毫秒为单位的睡眠时间
        异常
        IllegalArgumentException - 如果 ms不在0到60,000毫秒之间
        另请参见：
        Thread.sleep(long)

      • waitForIdle

        public void waitForIdle​()
        等待直到事件队列上的所有事件都处理完毕。
        异常
        IllegalThreadStateException - 如果在AWT事件调度线程上调用

      • toString

        public String toString​()
        返回此Robot的字符串表示形式。
        重写：
        toString在 Object
        结果
        字符串表示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Scrollbar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Scrollbar

  • java.lang.Object
    • java.awt.Component
      • java.awt.Scrollbar
  • All Implemented Interfaces:
    Adjustable ， ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class Scrollbar
extends Component
implements Adjustable, Accessible
    Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。 滚动条提供了一种方便的手段，允许用户从一系列值中进行选择。 以下三个垂直滚动条可用作滑块控件来选择颜色的红色，绿色和蓝色分量：

    本示例中的每个滚动条都可以使用与以下代码类似的代码创建：

     redSlider=new Scrollbar(Scrollbar.VERTICAL, 0, 1, 0, 255);
 add(redSlider);

    或者，滚动条可以表示一定范围的值。 例如，如果滚动条用于滚动文本，“气泡”（也称为“大拇指”或“滚动框”）的宽度可用于表示可见文本的数量。 下面是一个代表一个范围的滚动条的例子：

    在此示例中由气泡表示的值范围是可见量 。 此示例中的水平滚动条可以使用如下代码创建：

     ranger = new Scrollbar(Scrollbar.HORIZONTAL, 0, 60, 0, 300);
 add(ranger);

    请注意，滚动条的实际最大值为maximum减visible amount 。 在上一个例子中，因为maximum是300，而visible amount是60，所以实际的最大值是240.滚动条的范围是0到300.气泡的左边表示滚动条的值。

    通常，用户通过鼠标手势来更改滚动条的值。 例如，用户可以上下拖动滚动条的气泡，或者单击滚动条的单位增量或块增量区域。 键盘手势也可以映射到滚动条。 按照惯例， Page Up和Page Down键相当于在滚动条的块增量和块递减区域中单击。

    当用户更改滚动条的值时，滚动条接收一个AdjustmentEvent的实例。 滚动条处理此事件，将其传递给任何已注册的侦听器。

    希望通知滚动条值更改的任何对象都应该实现AdjustmentListener ，这是java.awt.event包中定义的接口。 通过调用方法addAdjustmentListener和removeAdjustmentListener可以动态添加和删除侦听器。

    AdjustmentEvent类定义了五种类型的调整事件：

    • 当用户拖动滚动条的气泡时，发送AdjustmentEvent.TRACK 。
    • AdjustmentEvent.UNIT_INCREMENT在用户点击水平滚动条的左箭头或垂直滚动条的顶部箭头时发出，或者从键盘进行等效手势。
    • AdjustmentEvent.UNIT_DECREMENT在用户点击水平滚动条的右箭头或垂直滚动条的底部箭头时发出，或者从键盘进行等效手势。
    • AdjustmentEvent.BLOCK_INCREMENT当用户点击轨道，水平滚动条上的气泡左侧或垂直滚动条上的气泡上方时发送。 按照惯例，如果用户使用定义了Page Up键的键盘，则Page Up键是等效的。
    • AdjustmentEvent.BLOCK_DECREMENT在用户在水平滚动条上点击轨迹右侧的气泡或垂直滚动条上的气泡下方发出。 按照惯例，如果用户正在使用定义Page Down键的键盘，则Page Down键是等效的。

    JDK 1.0事件系统支持向后兼容性，但不建议使用较新版本的平台。 JDK 1.1引入的五种类型的调整事件对应于与以前平台版本中的滚动条相关联的五种事件类型。 以下列表给出了调整事件类型，以及相应的JDK 1.0事件类型。

    • AdjustmentEvent.TRACK替换Event.SCROLL_ABSOLUTE
    • AdjustmentEvent.UNIT_INCREMENT替换Event.SCROLL_LINE_UP
    • AdjustmentEvent.UNIT_DECREMENT替换Event.SCROLL_LINE_DOWN
    • AdjustmentEvent.BLOCK_INCREMENT替换Event.SCROLL_PAGE_UP
    • AdjustmentEvent.BLOCK_DECREMENT替换Event.SCROLL_PAGE_DOWN

    注意 ：我们建议仅使用Scrollbar进行值选择。 如果要在容器内部实现可滚动组件，我们建议您使用ScrollPane 。 如果您为此目的使用了Scrollbar ，则可能会遇到绘画，按键处理，尺寸和定位等问题。

    从以下版本开始：
    1.0
    另请参见：
    AdjustmentEvent ， AdjustmentListener ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Scrollbar.AccessibleAWTScrollBar
      该类实现 Scrollbar类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int HORIZONTAL
      一个常量，表示水平滚动条。
      static int VERTICAL
      一个常量，表示垂直滚动条。

      • Fields inherited from interface java.awt.Adjustable

        NO_ORIENTATION

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Scrollbar​()
      构造一个新的垂直滚动条。
      Scrollbar​(int orientation)
      构造具有指定方向的新滚动条。
      Scrollbar​(int orientation, int value, int visible, int minimum, int maximum)
      构造具有指定方向，初始值，可见量以及最小值和最大值的新滚动条。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addAdjustmentListener​(AdjustmentListener l)
      添加指定的调整监听器以从此滚动条接收 AdjustmentEvent实例。
      void addNotify​()
      创建 Scrollbar的同行。
      AccessibleContext getAccessibleContext​()
      获取 AccessibleContext与此 Scrollbar相关联。
      AdjustmentListener[] getAdjustmentListeners​()
      返回在此滚动条上注册的所有调整监听器的数组。
      int getBlockIncrement​()
      获取此滚动条的块增量。
      int getLineIncrement​()
      已过时。
      从JDK 1.1版开始，由getUnitIncrement()替代。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回此 Scrollbar当前注册为 FooListener的所有对象的数组。
      int getMaximum​()
      获取此滚动条的最大值。
      int getMinimum​()
      获取此滚动条的最小值。
      int getOrientation​()
      返回此滚动条的方向。
      int getPageIncrement​()
      已过时。
      从JDK 1.1版开始，由getBlockIncrement()替代。
      int getUnitIncrement​()
      获取此滚动条的单位增量。
      int getValue​()
      获取此滚动条的当前值。
      boolean getValueIsAdjusting​()
      如果值正在由于用户执行的操作而改变，则返回true。
      int getVisible​()
      已过时。
      从JDK 1.1版开始，由getVisibleAmount()替代。
      int getVisibleAmount​()
      获取此滚动条的可见数量。
      protected String paramString​()
      返回表示 Scrollbar的状态的字符串。
      protected void processAdjustmentEvent​(AdjustmentEvent e)
      通过将调度事件发送到任何已注册的 AdjustmentListener对象来处理此滚动条上发生的调整事件。
      protected void processEvent​(AWTEvent e)
      处理此滚动条上的事件。
      void removeAdjustmentListener​(AdjustmentListener l)
      删除指定的调整监听器，使其不再从此滚动条接收 AdjustmentEvent实例。
      void setBlockIncrement​(int v)
      设置此滚动条的块增量。
      void setLineIncrement​(int v)
      已过时。
      从JDK 1.1版开始，由setUnitIncrement(int)替代。
      void setMaximum​(int newMaximum)
      设置此滚动条的最大值。
      void setMinimum​(int newMinimum)
      设置此滚动条的最小值。
      void setOrientation​(int orientation)
      设置此滚动条的方向。
      void setPageIncrement​(int v)
      已过时。
      从JDK 1.1版开始，由setBlockIncrement()代替。
      void setUnitIncrement​(int v)
      设置此滚动条的单位增量。
      void setValue​(int newValue)
      将此滚动条的值设置为指定的值。
      void setValueIsAdjusting​(boolean b)
      设置 valueIsAdjusting属性。
      void setValues​(int value, int visible, int minimum, int maximum)
      设置的四个属性此滚动条的值： value ， visibleAmount ， minimum ，并 maximum 。
      void setVisibleAmount​(int newAmount)
      设置此滚动条的可见数量。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • HORIZONTAL

        public static final int HORIZONTAL
        一个常量，表示水平滚动条。
        另请参见：
        Constant Field Values

      • VERTICAL

        public static final int VERTICAL
        一个常量，表示垂直滚动条。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Scrollbar

        public Scrollbar​()
          throws HeadlessException
        构造一个新的垂直滚动条。 滚动条的默认属性列在下表中： Scrollbar default properties Property Description Default Value orientation indicates whether the scroll bar is vertical
        or horizontal Scrollbar.VERTICAL value value which controls the location
        of the scroll bar's bubble 0 visible amount visible amount of the scroll bar's range,
        typically represented by the size of the
        scroll bar's bubble 10 minimum minimum value of the scroll bar 0 maximum maximum value of the scroll bar 100 unit increment amount the value changes when the
        Line Up or Line Down key is pressed,
        or when the end arrows of the scrollbar
        are clicked 1 block increment amount the value changes when the
        Page Up or Page Down key is pressed,
        or when the scrollbar track is clicked
        on either side of the bubble 10
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Scrollbar

        public Scrollbar​(int orientation)
          throws HeadlessException
        构造具有指定方向的新滚动条。

        orientation参数必须分别指示水平或垂直滚动条的值Scrollbar.HORIZONTAL或Scrollbar.VERTICAL一个。

        参数
        orientation - 表示滚动条的方向
        异常
        IllegalArgumentException - 当提供 orientation参数的非法值时
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • Scrollbar

        public Scrollbar​(int orientation,
                 int value,
                 int visible,
                 int minimum,
                 int maximum)
          throws HeadlessException
        构造具有指定方向，初始值，可见量以及最小值和最大值的新滚动条。

        orientation参数必须分别表示两个值Scrollbar.HORIZONTAL或Scrollbar.VERTICAL ，分别表示水平或垂直滚动条。

        提供给此构造函数的参数受到setValues(int, int, int, int)中描述的限制。

        参数
        orientation - 表示滚动条的方向。
        value - 滚动条的初始值
        visible - 滚动条的可见量，通常由气泡的大小表示
        minimum - 滚动条的最小值
        maximum - 滚动条的最大值
        异常
        IllegalArgumentException - 当提供 orientation参数的非法值时
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        setValues(int, int, int, int) ， GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建Scrollbar的同伴。 对等体允许您修改Scrollbar的外观，而无需更改其任何功能。
        重写：
        addNotify在 Component
        另请参见：
        Component.isDisplayable() ，
Component.removeNotify() ，
Component.invalidate()

      • getOrientation

        public int getOrientation​()
        返回此滚动条的方向。
        Specified by:
        getOrientation在接口 Adjustable
        结果
        该滚动条的方向， Scrollbar.HORIZONTAL或 Scrollbar.VERTICAL
        另请参见：
        setOrientation(int)

      • setOrientation

        public void setOrientation​(int orientation)
        设置此滚动条的方向。
        参数
        orientation - 此滚动条的方向， Scrollbar.HORIZONTAL或 Scrollbar.VERTICAL
        异常
        IllegalArgumentException - 如果为 orientation提供的值不是合法值
        从以下版本开始：
        1.1
        另请参见：
        getOrientation()

      • getValue

        public int getValue​()
        获取此滚动条的当前值。
        Specified by:
        getValue在接口 Adjustable
        结果
        此滚动条的当前值
        另请参见：
        getMinimum() ， getMaximum()

      • setValue

        public void setValue​(int newValue)
        将此滚动条的值设置为指定的值。

        如果提供的价值小于当前的minimum或大于当前的maximum - visibleAmount ，那么minimum或maximum - visibleAmount将被酌情替代。

        一般来说，程序只能通过调用setValues来更改滚动条的值。 setValues方法同时并同步设置滚动条的最小值，最大值，可见量和值属性，使它们相互一致。

        调用此方法不会触发AdjustmentEvent 。

        Specified by:
        setValue在接口 Adjustable
        参数
        newValue - 滚动条的新值
        另请参见：
        setValues(int, int, int, int) ，
getValue() ，
getMinimum() ，
getMaximum()

      • getMinimum

        public int getMinimum​()
        获取此滚动条的最小值。
        Specified by:
        getMinimum在接口 Adjustable
        结果
        此滚动条的最小值
        另请参见：
        getValue() ， getMaximum()

      • setMinimum

        public void setMinimum​(int newMinimum)
        设置此滚动条的最小值。

        当setMinimum ，最小值被更改，其他值（包括最大值，可见量和当前滚动条值）被改变为与新的最小值一致。

        一般来说，程序只能通过调用setValues来更改滚动条的最小值。 setValues方法同时并同步设置滚动条的最小值，最大值，可见量和值属性，使它们相互一致。

        请注意，将最小值设置为Integer.MAX_VALUE将导致新的最小值设置为Integer.MAX_VALUE - 1 。

        Specified by:
        setMinimum在接口 Adjustable
        参数
        newMinimum - 此滚动条的最小值
        从以下版本开始：
        1.1
        另请参见：
        setValues(int, int, int, int) ， setMaximum(int)

      • getMaximum

        public int getMaximum​()
        获取此滚动条的最大值。
        Specified by:
        getMaximum在接口 Adjustable
        结果
        此滚动条的最大值
        另请参见：
        getValue() ， getMinimum()

      • setMaximum

        public void setMaximum​(int newMaximum)
        设置此滚动条的最大值。

        当setMaximum ，最大值被更改，其他值（包括最小值，可见量和当前滚动条值）被更改为与新的最大值一致。

        一般来说，程序只能通过调用setValues来更改滚动条的最大值。 setValues方法同时并同步设置滚动条的最小值，最大值，可见量和值属性，使它们相互一致。

        请注意，将最大值设置为Integer.MIN_VALUE将导致新的最大值设置为Integer.MIN_VALUE + 1 。

        Specified by:
        setMaximum在接口 Adjustable
        参数
        newMaximum - 此滚动条的最大值
        从以下版本开始：
        1.1
        另请参见：
        setValues(int, int, int, int) ， setMinimum(int)

      • getVisibleAmount

        public int getVisibleAmount​()
        获取此滚动条的可见数量。

        当使用滚动条来选择范围的值时，可见量用于表示当前可见的值的范围。 滚动条的大小（也称为大拇指或滚动框）通常会给出可视量与滚动条范围的关系的可视化表示。 请注意，根据平台，可见量属性的值可能不会被气泡的大小视觉指示。

        当滚动条不可移动时，滚动条的气泡可能无法显示（例如，当它占据滚动条的轨迹的整个长度时，或当滚动条被禁用时）。 气泡是否显示不会影响getVisibleAmount返回的值。

        Specified by:
        getVisibleAmount在接口 Adjustable
        结果
        该滚动条的可见数量
        从以下版本开始：
        1.1
        另请参见：
        setVisibleAmount(int)

      • getVisible

        @Deprecated
public int getVisible​()
        已过时。 从JDK 1.1版开始，由getVisibleAmount()替代。
        返回此滚动条的可见数量。
        结果
        该滚动条的可见数量

      • setVisibleAmount

        public void setVisibleAmount​(int newAmount)
        设置此滚动条的可见数量。

        当使用滚动条来选择范围的值时，可见量用于表示当前可见的值的范围。 滚动条的大小（也称为大拇指或滚动框）通常会给出可视量与滚动条范围的关系的可视化表示。 请注意，根据平台，可见量属性的值可能不会被气泡的大小视觉指示。

        当滚动条不可移动时，滚动条的气泡可能无法显示（例如，当它占据滚动条的轨迹的整个长度时，或当滚动条被禁用时）。 气泡是否显示不会影响getVisibleAmount返回的值。

        如果所提供的可见光量小于one或大于当前的maximum - minimum ，那么根据one替换one或maximum - minimum 。

        通常情况下，程序只能通过调用setValues来更改滚动条的值。 setValues方法同时并同步设置滚动条的最小值，最大值，可见量和值属性，使其相互一致。

        Specified by:
        setVisibleAmount在接口 Adjustable
        参数
        newAmount - 新的可见量
        从以下版本开始：
        1.1
        另请参见：
        getVisibleAmount() ， setValues(int, int, int, int)

      • setUnitIncrement

        public void setUnitIncrement​(int v)
        设置此滚动条的单位增量。

        单位增量是当用户通过滚动条接收到的调整事件的鼠标或键盘手势激活滚动条的单位增量区域时加或减的值。 单位增量必须大于零。 尝试将单位增量设置为小于1的值将导致设置值为1。

        在某些操作系统中，底层控件可以忽略此属性。

        Specified by:
        setUnitIncrement在接口 Adjustable
        参数
        v - 滚动条的值增加或减少的量
        从以下版本开始：
        1.1
        另请参见：
        getUnitIncrement()

      • setLineIncrement

        @Deprecated
public void setLineIncrement​(int v)
        已过时。 从JDK 1.1版开始，由setUnitIncrement(int)替代。
        设置此滚动条的单位增量。
        参数
        v - 增量值

      • getUnitIncrement

        public int getUnitIncrement​()
        获取此滚动条的单位增量。

        单位增量是当用户通过滚动条接收到的调整事件的鼠标或键盘手势激活滚动条的单位增量区域时加或减的值。 单位增量必须大于零。

        在某些操作系统中，底层控件可以忽略此属性。

        Specified by:
        getUnitIncrement在接口 Adjustable
        结果
        这个滚动条的单位增量
        从以下版本开始：
        1.1
        另请参见：
        setUnitIncrement(int)

      • getLineIncrement

        @Deprecated
public int getLineIncrement​()
        已过时。 从JDK 1.1版开始，由getUnitIncrement()替代。
        返回此滚动条的单位增量。
        结果
        该滚动条的单位增量

      • setBlockIncrement

        public void setBlockIncrement​(int v)
        设置此滚动条的块增量。

        块增量是当用户通过滚动条接收到的作为调整事件的鼠标或键盘手势来激活滚动条的块递增区域时被加或减的值。 块增量必须大于零。 尝试将块增量设置为小于1的值将导致设置值为1。

        Specified by:
        setBlockIncrement在接口 Adjustable
        参数
        v - 用于增加或减少滚动条值的量
        从以下版本开始：
        1.1
        另请参见：
        getBlockIncrement()

      • setPageIncrement

        @Deprecated
public void setPageIncrement​(int v)
        已过时。 从JDK 1.1版开始，由setBlockIncrement()替代。
        设置此滚动条的块增量。
        参数
        v - 块增量

      • getBlockIncrement

        public int getBlockIncrement​()
        获取此滚动条的块增量。

        块增量是当用户通过滚动条接收到的作为调整事件的鼠标或键盘手势来激活滚动条的块递增区域时被加或减的值。 块增量必须大于零。

        Specified by:
        getBlockIncrement在接口 Adjustable
        结果
        该滚动条的块增量
        从以下版本开始：
        1.1
        另请参见：
        setBlockIncrement(int)

      • getPageIncrement

        @Deprecated
public int getPageIncrement​()
        已过时。 从JDK 1.1版开始，由getBlockIncrement()替代。
        返回此滚动条的块增量。
        结果
        该滚动条的块增量

      • setValues

        public void setValues​(int value,
                      int visible,
                      int minimum,
                      int maximum)
        设置的四个属性此滚动条的值： value ， visibleAmount ， minimum ，并maximum 。 如果为这些属性提供的值不一致或不正确，则将更改它们以确保一致性。

        该方法同时并同步设置四个滚动条属性的值，确保这些属性的值相互一致。 它强制执行以下限制： maximum必须大于minimum ， maximum - minimum不得大于Integer.MAX_VALUE ， visibleAmount必须大于零。 visibleAmount不得大于maximum - minimum ， value不得少于minimum ，并value必须不大于maximum - visibleAmount

        调用此方法不会触发AdjustmentEvent 。

        参数
        value - 是当前窗口中的位置
        visible - 是滚动条的可见量
        minimum - 是滚动条的最小值
        maximum - 是滚动条的最大值
        另请参见：
        setMinimum(int) ， setMaximum(int) ， setVisibleAmount(int) ， setValue(int)

      • getValueIsAdjusting

        public boolean getValueIsAdjusting​()
        如果值正在由于用户执行的操作而改变，则返回true。
        结果
        该值为 valueIsAdjusting属性
        从以下版本开始：
        1.4
        另请参见：
        setValueIsAdjusting(boolean)

      • setValueIsAdjusting

        public void setValueIsAdjusting​(boolean b)
        设置 valueIsAdjusting属性。
        参数
        b - 新的调整进度状态
        从以下版本开始：
        1.4
        另请参见：
        getValueIsAdjusting()

      • addAdjustmentListener

        public void addAdjustmentListener​(AdjustmentListener l)
        添加指定的调整监听器以从此滚动条接收AdjustmentEvent实例。 如果l为null ，则不会抛出异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        addAdjustmentListener在接口 Adjustable
        参数
        l - 调整监听器
        从以下版本开始：
        1.1
        另请参见：
        removeAdjustmentListener(java.awt.event.AdjustmentListener) ， getAdjustmentListeners() ， AdjustmentEvent ， AdjustmentListener

      • removeAdjustmentListener

        public void removeAdjustmentListener​(AdjustmentListener l)
        删除指定的调整监听器，使其不再从此滚动条接收AdjustmentEvent实例。 如果l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        removeAdjustmentListener在接口 Adjustable
        参数
        l - 调整听众
        从以下版本开始：
        1.1
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener) ， getAdjustmentListeners() ， AdjustmentEvent ， AdjustmentListener

      • getAdjustmentListeners

        public AdjustmentListener[] getAdjustmentListeners​()
        返回在此滚动条上注册的所有调整监听器的数组。
        结果
        所有这个滚动条的 AdjustmentListener s或一个空数组，如果没有调整监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener) ， removeAdjustmentListener(java.awt.event.AdjustmentListener) ， AdjustmentEvent ， AdjustmentListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回此Scrollbar当前注册为FooListener的所有对象的数组。 FooListener使用addFooListener注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询Scrollbar c的鼠标监听器：

          MouseListener[] mls = (MouseListener[])(c.getListeners(MouseListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在 Component
        参数类型
        T - 侦听器的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此组件上注册为 FooListener的所有对象的数组，如果未添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        Component.getComponentListeners() ，
Component.getFocusListeners() ，
Component.getHierarchyListeners() ，
Component.getHierarchyBoundsListeners() ，
Component.getKeyListeners() ，
Component.getMouseListeners() ，
Component.getMouseMotionListeners() ，
Component.getMouseWheelListeners() ，
Component.getInputMethodListeners() ，
Component.getPropertyChangeListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此滚动条上的事件。 如果事件是AdjustmentEvent一个实例，它将调用processAdjustmentEvent方法。 否则，它调用其超类的processEvent方法。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        重写：
        processEvent在类 Component
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        AdjustmentEvent ， processAdjustmentEvent(java.awt.event.AdjustmentEvent)

      • processAdjustmentEvent

        protected void processAdjustmentEvent​(AdjustmentEvent e)
        通过将调度事件发送到任何已注册的AdjustmentListener对象来处理此滚动条上发生的调整事件。

        除非为此组件启用调整事件，否则不调用此方法。 当发生以下其中一种情况时，启用调整事件：

        • 一个AdjustmentListener对象通过addAdjustmentListener注册。
        • 调整事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        参数
        e - 调整事件
        从以下版本开始：
        1.1
        另请参见：
        AdjustmentEvent ， AdjustmentListener ， addAdjustmentListener(java.awt.event.AdjustmentListener) ， Component.enableEvents(long)

      • paramString

        protected String paramString​()
        返回一个表示Scrollbar状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Component
        结果
        此滚动条的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取AccessibleContext与此Scrollbar相关联。 对于滚动条，所述AccessibleContext需要一个的形式AccessibleAWTScrollBar 。 如有必要，将创建一个新的AccessibleAWTScrollBar实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个 AccessibleAWTScrollBar ，作为 AccessibleContext这 ScrollBar
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Scrollbar.AccessibleAWTScrollBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Scrollbar.AccessibleAWTScrollBar

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Scrollbar.AccessibleAWTScrollBar
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent ， AccessibleValue
    Enclosing class:
    Scrollbar

    protected class Scrollbar.AccessibleAWTScrollBar
extends Component.AccessibleAWTComponent
implements AccessibleValue
    该类实现Scrollbar类的可访问性支持。 它提供了适用于滚动条用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTScrollBar​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态集。
      AccessibleValue getAccessibleValue​()
      获取与此对象关联的 AccessibleValue 。
      Number getCurrentAccessibleValue​()
      获取此对象的可访问值。
      Number getMaximumAccessibleValue​()
      获取此对象的最大可访问值。
      Number getMinimumAccessibleValue​()
      获取此对象的最小可访问值。
      boolean setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTScrollBar

        protected AccessibleAWTScrollBar​()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态集。
        重写：
        getAccessibleStateSet在 Component.AccessibleAWTComponent
        结果
        一个 AccessibleState的实例包含对象的当前状态
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        描述对象角色的 AccessibleRole一个实例
        另请参见：
        AccessibleRole

      • getAccessibleValue

        public AccessibleValue getAccessibleValue​()
        获取与此对象关联的AccessibleValue 。 在实现该类的Java Accessibility API时，返回此对象，该对象代表本身负责实现AccessibleValue接口。
        重写：
        getAccessibleValue在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue​()
        获取此对象的可访问值。
        Specified by:
        getCurrentAccessibleValue在接口 AccessibleValue
        结果
        该对象的当前值。
        另请参见：
        AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue​(Number n)
        将此对象的值设置为数字。
        Specified by:
        setCurrentAccessibleValue在接口 AccessibleValue
        参数
        n - 要用作数值的数字
        结果
        如果设置了该值，则为真。
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue​()
        获取此对象的最小可访问值。
        Specified by:
        getMinimumAccessibleValue在接口 AccessibleValue
        结果
        该对象的最小值。
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue​()
        获取此对象的最大可访问值。
        Specified by:
        getMaximumAccessibleValue在接口 AccessibleValue
        结果
        该对象的最大值。
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ScrollPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class ScrollPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.ScrollPane
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class ScrollPane
extends Container
implements Accessible
    一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。 滚动条的显示策略可以设置为：
    1. 根据需要：滚动条仅在滚动窗口需要时创建和显示
    2. 总是：滚动条创建并始终由滚动画面显示
    3. 从不：滚动条从未创建或由滚动画面显示

    水平和垂直滚动条的状态由实现Adjustable接口的两个ScrollPaneAdjustable对象（每个维度一个）表示。 API提供访问这些对象的方法，以便可以操纵Adjustable对象上的属性（如unitIncrement，value等）。

    某些可调整的属性（最小值，最大值，块输入和可见的安装）由滚动条内部根据滚动条及其子代的几何形状设置，这些属性不应由使用滚动条的程序设置。

    如果滚动条显示策略被定义为“从不”，则滚动窗格仍然可以使用setScrollPosition（）方法以编程方式滚动，滚动窗格将适当地移动和剪贴子内容。 如果程序需要创建和管理自己的可调节控件，则此策略很有用。

    滚动条的放置由用户在程序外部设置的平台特定属性控制。

    此容器的初始大小设置为100x100，但可以使用setSize（）重置。

    默认情况下，启用带轮盘鼠标的滚轮滚动。 这可以使用setWheelScrollingEnabled禁用。 可以通过设置水平和垂直可调节的块和单位增量来定制轮滚动。 有关如何调度鼠标滚轮事件的信息，请参阅MouseWheelEvent的类描述。

    Insets用于定义滚动条和滚动窗格创建的任何边框所使用的空间。 getInsets（）可用于获取插值的当前值。 如果scrollbarsAlwaysVisible的值为false，则插值的值将根据滚动条当前是否可见而动态更改。

    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  ScrollPane.AccessibleAWTScrollPane
      该类实现 ScrollPane类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int SCROLLBARS_ALWAYS
      指定水平/垂直滚动条应始终显示，而不管滚动条和子对象的大小如何。
      static int SCROLLBARS_AS_NEEDED
      指定仅当小孩的大小超过水平/垂直维度中滚动窗口的大小时才应显示水平/垂直滚动条。
      static int SCROLLBARS_NEVER
      指定水平/垂直滚动条不应该显示，而不管滚动条和子的相应大小。

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScrollPane​()
      创建一个滚动条显示策略为“根据需要”的新的滚动容器。
      ScrollPane​(int scrollbarDisplayPolicy)
      创建一个新的scrollpane容器。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected void addImpl​(Component comp, Object constraints, int index)
      将指定的组件添加到此滚动窗格容器。
      void addNotify​()
      创建滚动窗格的对等体。
      void doLayout​()
      通过将其小孩调整为首选尺寸，将这个容器放在一起。
      protected boolean eventTypeEnabled​(int type)
      如果启用滚动滚动，我们将为MouseWheelEvents返回true
      AccessibleContext getAccessibleContext​()
      获取与此ScrollPane关联的AccessibleContext。
      Adjustable getHAdjustable​()
      返回表示水平滚动条状态的 ScrollPaneAdjustable对象。
      int getHScrollbarHeight​()
      返回一个水平滚动条占用的高度，它与滚动窗格当前是否显示无关。
      int getScrollbarDisplayPolicy​()
      返回滚动条的显示策略。
      Point getScrollPosition​()
      返回显示在滚动面板视图端口的0,0位置的子项内的当前x，y位置。
      Adjustable getVAdjustable​()
      返回表示垂直滚动条状态的 ScrollPaneAdjustable对象。
      Dimension getViewportSize​()
      返回滚动窗格视图端口的当前大小。
      int getVScrollbarWidth​()
      返回垂直滚动条将占用的宽度，该宽度与滚动窗格当前是否显示无关。
      boolean isWheelScrollingEnabled​()
      指示是否会响应于鼠标滚轮进行滚动。
      void layout​()
      已过时。
      从JDK 1.1版开始，由doLayout()取代。
      String paramString​()
      返回表示 ScrollPane的状态的字符串。
      void printComponents​(Graphics g)
      在此滚动窗格中打印组件。
      protected void processMouseWheelEvent​(MouseWheelEvent e)
      通过滚动适当的量来处理传递给此 ScrollPane的鼠标滚轮事件。
      void setLayout​(LayoutManager mgr)
      设置此容器的布局管理器。
      void setScrollPosition​(int x, int y)
      滚动到子组件中的指定位置。
      void setScrollPosition​(Point p)
      滚动到子组件中的指定位置。
      void setWheelScrollingEnabled​(boolean handleWheel)
      启用/禁用滚动以响应鼠标滚轮的移动。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, isValidateRoot, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SCROLLBARS_AS_NEEDED

        public static final int SCROLLBARS_AS_NEEDED
        指定仅当小孩的大小超过水平/垂直维度中滚动窗口的大小时才应显示水平/垂直滚动条。
        另请参见：
        Constant Field Values

      • SCROLLBARS_ALWAYS

        public static final int SCROLLBARS_ALWAYS
        指定水平/垂直滚动条应始终显示，而不管滚动条和子对象的大小如何。
        另请参见：
        Constant Field Values

      • SCROLLBARS_NEVER

        public static final int SCROLLBARS_NEVER
        指定水平/垂直滚动条不应该显示，而不管滚动条和子的相应大小。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ScrollPane

        public ScrollPane​()
           throws HeadlessException
        创建一个滚动条显示策略为“根据需要”的新的滚动容器。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • ScrollPane

        @ConstructorProperties("scrollbarDisplayPolicy")
public ScrollPane​(int scrollbarDisplayPolicy)
           throws HeadlessException
        创建一个新的scrollpane容器。
        参数
        scrollbarDisplayPolicy - 应显示滚动条的政策
        异常
        IllegalArgumentException - 如果指定的滚动条显示策略无效
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addImpl

        protected final void addImpl​(Component comp,
                             Object constraints,
                             int index)
        将指定的组件添加到此滚动窗格容器。 如果滚动窗格具有现有的子组件，则删除该组件并添加新组件。
        重写：
        addImpl在 Container
        参数
        comp - 要添加的组件
        constraints - 不适用
        index - 子组件的位置（必须<= 0）
        另请参见：
        Container.add(Component) ， Container.add(Component, int) ， Container.add(Component, java.lang.Object) ， Container.invalidate() ， LayoutManager ， LayoutManager2

      • getScrollbarDisplayPolicy

        public int getScrollbarDisplayPolicy​()
        返回滚动条的显示策略。
        结果
        滚动条的显示策略

      • getViewportSize

        public Dimension getViewportSize​()
        返回滚动窗格视图端口的当前大小。
        结果
        视图端口的大小（以像素为单位）

      • getHScrollbarHeight

        public int getHScrollbarHeight​()
        返回一个水平滚动条占用的高度，它与滚动窗格当前是否显示无关。
        结果
        水平滚动条的高度（以像素为单位）

      • getVScrollbarWidth

        public int getVScrollbarWidth​()
        返回垂直滚动条将占用的宽度，该宽度与滚动窗格当前是否显示无关。
        结果
        垂直滚动条的宽度（以像素为单位）

      • getVAdjustable

        public Adjustable getVAdjustable​()
        返回表示垂直滚动条状态的ScrollPaneAdjustable对象。 该方法的声明返回类型为Adjustable以保持向后兼容性。
        结果
        垂直滚动条状态
        另请参见：
        ScrollPaneAdjustable

      • getHAdjustable

        public Adjustable getHAdjustable​()
        返回表示水平滚动条状态的ScrollPaneAdjustable对象。 此方法的声明返回类型为Adjustable以保持向后兼容性。
        结果
        水平滚动条状态
        另请参见：
        ScrollPaneAdjustable

      • setScrollPosition

        public void setScrollPosition​(int x,
                              int y)
        滚动到子组件中的指定位置。 调用此方法仅在滚动窗格包含子项时有效。 指定小孩合法滚动边界之外的位置将滚动到最接近的法定位置。 法定边界定义为矩形：x = 0，y = 0，width =（子宽度 - 视图端口宽度），height =（子高度 - 视图端口高度）。 这是一种方便的方法，它与可表示滚动条状态的可调整对象相连接。
        参数
        x - 要滚动到的x位置
        y - 要滚动到的位置
        异常
        NullPointerException - 如果滚动条不包含小孩

      • setScrollPosition

        public void setScrollPosition​(Point p)
        滚动到子组件中的指定位置。 调用此方法仅在滚动窗格包含子项并且指定位置在子代码的合法滚动范围内时有效。 指定小孩合法滚动边界之外的位置将滚动到最接近的法定位置。 法定边界定义为矩形：x = 0，y = 0，width =（子宽度 - 视图端口宽度），height =（子高度 - 视图端口高度）。 这是一种方便的方法，它与可表示滚动条状态的可调整对象相连接。
        参数
        p - 表示要滚动到的位置的点
        异常
        NullPointerException - 如果 p是 null

      • getScrollPosition

        public Point getScrollPosition​()
        返回显示在滚动面板视图端口的0,0位置的子项内的当前x，y位置。 这是一种与表示滚动条的状态的可调节对象相连接的方便方法。
        结果
        当前滚动位置的坐标位置
        异常
        NullPointerException - 如果滚动条不包含小孩

      • setLayout

        public final void setLayout​(LayoutManager mgr)
        设置此容器的布局管理器。 该方法被覆盖以防止布局mgr被设置。
        重写：
        setLayout在 Container
        参数
        mgr - 指定的布局管理器
        另请参见：
        Container.doLayout() ，
Container.getLayout() ，
Container.invalidate()

      • doLayout

        public void doLayout​()
        通过将其小孩调整为首选尺寸，将这个容器放在一起。 如果小孩的新的优选大小导致当前滚动位置无效，滚动位置被设置为最接近的有效位置。
        重写：
        doLayout在 Container
        另请参见：
        Component.validate()

      • layout

        @Deprecated
public void layout​()
        已过时。 从JDK 1.1版开始，由doLayout()替代。
        重写：
        layout在 Container

      • printComponents

        public void printComponents​(Graphics g)
        在此滚动窗格中打印组件。
        重写：
        printComponents在 Container
        参数
        g - 指定的图形窗口
        另请参见：
        Component.print(java.awt.Graphics) ， Component.printAll(java.awt.Graphics)

      • addNotify

        public void addNotify​()
        创建滚动窗格的对等体。
        重写：
        addNotify在 Container
        另请参见：
        Component.isDisplayable() ， Container.removeNotify()

      • paramString

        public String paramString​()
        返回表示ScrollPane的状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Container
        结果
        此滚动窗格的参数字符串

      • processMouseWheelEvent

        protected void processMouseWheelEvent​(MouseWheelEvent e)
        通过滚动适当的量来处理传递给此ScrollPane的鼠标滚轮事件。

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        重写：
        processMouseWheelEvent在 Component
        参数
        e - 鼠标滚轮事件
        从以下版本开始：
        1.4
        另请参见：
        MouseWheelEvent ， MouseWheelListener ， Component.addMouseWheelListener(java.awt.event.MouseWheelListener) ， Component.enableEvents(long)

      • eventTypeEnabled

        protected boolean eventTypeEnabled​(int type)
        如果启用滚动滚动，我们将为MouseWheelEvents返回true
        从以下版本开始：
        1.4

      • setWheelScrollingEnabled

        public void setWheelScrollingEnabled​(boolean handleWheel)
        启用/禁用滚动以响应鼠标滚轮的移动。 轮滚动默认启用。
        参数
        handleWheel - true如果滚动应该为MouseWheelEvent自动完成，否则为 false 。
        从以下版本开始：
        1.4
        另请参见：
        isWheelScrollingEnabled() ， MouseWheelEvent ， MouseWheelListener

      • isWheelScrollingEnabled

        public boolean isWheelScrollingEnabled​()
        指示是否会响应于鼠标滚轮进行滚动。 轮滚动默认启用。
        结果
        true如果滚轮启用; 否则false
        从以下版本开始：
        1.4
        另请参见：
        setWheelScrollingEnabled(boolean)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此ScrollPane关联的AccessibleContext。 对于滚动窗格，AccessibleContext采用AccessibleAWTScrollPane的形式。 如有必要，将创建一个新的AccessibleAWTScrollPane实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个AccessibleAWTScrollPane，用作此ScrollPane的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ScrollPane.AccessibleAWTScrollPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class ScrollPane.AccessibleAWTScrollPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.ScrollPane.AccessibleAWTScrollPane
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    Enclosing class:
    ScrollPane

    protected class ScrollPane.AccessibleAWTScrollPane
extends Container.AccessibleAWTContainer
    该类实现ScrollPane类的可访问性支持。 它提供了适用于滚动窗格用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTScrollPane​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, removePropertyChangeListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTScrollPane

        protected AccessibleAWTScrollPane​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ScrollPaneAdjustable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class ScrollPaneAdjustable

  • java.lang.Object
    • java.awt.ScrollPaneAdjustable
  • All Implemented Interfaces:
    Adjustable ， Serializable

    public class ScrollPaneAdjustable
extends Object
implements Adjustable, Serializable
    此类表示ScrollPane的水平或垂直滚动条的ScrollPane 。 此类的对象由ScrollPane方法返回。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from interface java.awt.Adjustable

        HORIZONTAL, NO_ORIENTATION, VERTICAL

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addAdjustmentListener​(AdjustmentListener l)
      添加指定的调整监听器以接收来自此 ScrollPaneAdjustable调整事件。
      AdjustmentListener[] getAdjustmentListeners​()
      返回在此 ScrollPaneAdjustable上注册的所有调整监听器的数组。
      int getBlockIncrement​()
      获取可调整对象的块值增量。
      int getMaximum​()
      获取可调整对象的最大值。
      int getMinimum​()
      获取可调整对象的最小值。
      int getOrientation​()
      返回此滚动条的方向。
      int getUnitIncrement​()
      获取可调整对象的单位增量。
      int getValue​()
      获取可调整对象的当前值。
      boolean getValueIsAdjusting​()
      如果值正在由于用户执行的操作而改变，则返回true。
      int getVisibleAmount​()
      获取比例指示器的长度。
      String paramString​()
      返回一个表示此滚动条状态的字符串。
      void removeAdjustmentListener​(AdjustmentListener l)
      删除指定的调整监听器，使其不再从此 ScrollPaneAdjustable接收调整事件。
      void setBlockIncrement​(int b)
      设置可调整对象的块值增量。
      void setMaximum​(int max)
      此方法 不应由用户代码调用。
      void setMinimum​(int min)
      此方法 不应由用户代码调用。
      void setUnitIncrement​(int u)
      设置可调整对象的单位值增量。
      void setValue​(int v)
      将此滚动条的值设置为指定的值。
      void setValueIsAdjusting​(boolean b)
      设置 valueIsAdjusting属性。
      void setVisibleAmount​(int v)
      此方法 不应由用户代码调用。
      String toString​()
      返回此滚动条及其值的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getOrientation

        public int getOrientation​()
        返回此滚动条的方向。
        Specified by:
        getOrientation在接口 Adjustable
        结果
        该滚动条的方向，或者是 Adjustable.HORIZONTAL或 Adjustable.VERTICAL

      • setMinimum

        public void setMinimum​(int min)
        此方法不应由用户代码调用。 这个方法是公开的这个类来正确实现Adjustable接口。
        Specified by:
        setMinimum在接口 Adjustable
        参数
        min - 最小值
        异常
        AWTError - 调用时总是发生错误。

      • getMinimum

        public int getMinimum​()
        说明从接口Adjustable复制
        获取可调整对象的最小值。
        Specified by:
        getMinimum在接口 Adjustable
        结果
        可调整对象的最小值

      • setMaximum

        public void setMaximum​(int max)
        此方法不应由用户代码调用。 这个方法是公开的这个类来正确实现Adjustable接口。
        Specified by:
        setMaximum在接口 Adjustable
        参数
        max - 最大值
        异常
        AWTError - 调用时总是发生错误。

      • getMaximum

        public int getMaximum​()
        描述从接口Adjustable复制
        获取可调整对象的最大值。
        Specified by:
        getMaximum在接口 Adjustable
        结果
        可调整对象的最大值

      • setUnitIncrement

        public void setUnitIncrement​(int u)
        描述从接口Adjustable复制
        设置可调整对象的单位值增量。
        Specified by:
        setUnitIncrement在接口 Adjustable
        参数
        u - 单位增量

      • getUnitIncrement

        public int getUnitIncrement​()
        说明从接口Adjustable复制
        获取可调整对象的单位增量。
        Specified by:
        getUnitIncrement在接口 Adjustable
        结果
        可调整对象的单位值增量

      • setBlockIncrement

        public void setBlockIncrement​(int b)
        说明从界面Adjustable复制
        设置可调整对象的块值增量。
        Specified by:
        setBlockIncrement在接口 Adjustable
        参数
        b - 块增量

      • getBlockIncrement

        public int getBlockIncrement​()
        描述从接口Adjustable复制
        获取可调整对象的块值增量。
        Specified by:
        getBlockIncrement在接口 Adjustable
        结果
        可调整对象的块值增量

      • setVisibleAmount

        public void setVisibleAmount​(int v)
        此方法不应由用户代码调用。 这个方法是公开的这个类来正确实现Adjustable接口。
        Specified by:
        setVisibleAmount在接口 Adjustable
        参数
        v - 指示器的长度
        异常
        AWTError - 调用时总是发生错误。

      • getVisibleAmount

        public int getVisibleAmount​()
        说明从接口Adjustable复制
        获取比例指示器的长度。
        Specified by:
        getVisibleAmount在接口 Adjustable
        结果
        比例指标的长度

      • setValueIsAdjusting

        public void setValueIsAdjusting​(boolean b)
        设置 valueIsAdjusting属性。
        参数
        b - 新的调整进度状态
        从以下版本开始：
        1.4
        另请参见：
        getValueIsAdjusting()

      • getValueIsAdjusting

        public boolean getValueIsAdjusting​()
        如果值正在由于用户执行的操作而改变，则返回true。
        结果
        该值为 valueIsAdjusting属性
        另请参见：
        setValueIsAdjusting(boolean)

      • setValue

        public void setValue​(int v)
        将此滚动条的值设置为指定的值。

        如果提供的值小于当前最小值或大于当前最大值，则根据需要替换其中一个值。

        Specified by:
        setValue在接口 Adjustable
        参数
        v - 滚动条的新值

      • getValue

        public int getValue​()
        说明从接口Adjustable复制
        获取可调整对象的当前值。
        Specified by:
        getValue在接口 Adjustable
        结果
        可调整对象的当前值

      • addAdjustmentListener

        public void addAdjustmentListener​(AdjustmentListener l)
        添加指定的调整监听器以接收来自此ScrollPaneAdjustable调整事件。 如果l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        addAdjustmentListener在接口 Adjustable
        参数
        l - 调整听众。
        另请参见：
        removeAdjustmentListener(java.awt.event.AdjustmentListener) ， getAdjustmentListeners() ， AdjustmentListener ， AdjustmentEvent

      • removeAdjustmentListener

        public void removeAdjustmentListener​(AdjustmentListener l)
        删除指定的调整监听器，使其不再从此ScrollPaneAdjustable接收调整事件。 如果l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        Specified by:
        removeAdjustmentListener在接口 Adjustable
        参数
        l - 调整听众。
        从以下版本开始：
        1.1
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener) ， getAdjustmentListeners() ， AdjustmentListener ， AdjustmentEvent

      • getAdjustmentListeners

        public AdjustmentListener[] getAdjustmentListeners​()
        返回在此 ScrollPaneAdjustable上注册的所有调整监听器的数组。
        结果
        所有这些 ScrollPaneAdjustable的 AdjustmentListener或一个空数组，如果没有调整监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener) ， removeAdjustmentListener(java.awt.event.AdjustmentListener) ， AdjustmentListener ， AdjustmentEvent

      • toString

        public String toString​()
        返回此滚动条及其值的字符串表示形式。
        重写：
        toString在 Object
        结果
        此滚动条的字符串表示形式。

      • paramString

        public String paramString​()
        返回一个表示此滚动条状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        结果
        此滚动条的参数字符串。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SecondaryLoop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface SecondaryLoop

  • public interface SecondaryLoop
    一个辅助接口来运行嵌套事件循环。

    使用EventQueue.createSecondaryLoop()方法创建实现此接口的对象。 该接口提供两种方法， enter()和exit() ，可用于启动和停止事件循环。

    当调用enter()方法时，当前线程被阻塞，直到循环被exit()方法终止。 而且，在事件分派线程上启动一个新的事件循环，它可能是也可能不是当前的线程。 可以通过调用其exit()方法在任何线程上终止循环。 循环结束后，可以重新使用SecondaryLoop对象来运行新的嵌套事件循环。

    应用此界面的典型用例是AWT和Swing模态对话框。 当在事件分派线程上显示一个模态对话框时，它将进入一个新的二级循环。 之后，当对话框被隐藏或处理时，它退出循环，线程继续执行。

    以下示例说明了次级循环的简单用例：

      SecondaryLoop loop;

   JButton jButton = new JButton("Button");
   jButton.addActionListener(new ActionListener() {
       @Override
       public void actionPerformed(ActionEvent e) {
           Toolkit tk = Toolkit.getDefaultToolkit();
           EventQueue eq = tk.getSystemEventQueue();
           loop = eq.createSecondaryLoop();

           // Spawn a new thread to do the work
           Thread worker = new WorkerThread();
           worker.start();

           // Enter the loop to block the current event
           // handler, but leave UI responsive
           if (!loop.enter()) {
               // Report an error
           }
       }
   });

   class WorkerThread extends Thread {
       @Override
       public void run() {
           // Perform calculations
           doSomethingUseful();

           // Exit the loop
           loop.exit();
       }
   }
    从以下版本开始：
    1.7
    另请参见：
    Dialog.show() ，
EventQueue.createSecondaryLoop() ，
Toolkit.getSystemEventQueue()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean enter​()
      阻止当前线程的执行，并在事件分派线程上输入新的辅助事件循环。
      boolean exit​()
      取消阻止由 enter()方法阻止的线程的执行，并退出次级循环。

    • 方法详细信息

      • enter

        boolean enter​()
        阻止当前线程的执行，并在事件分派线程上输入新的辅助事件循环。

        该方法可以由任何线程调用，包括事件调度线程。 该线程将被阻塞，直到调用exit()方法或终止该循环。 将在事件分派线程中创建一个新的二级循环，以便在任一情况下调度事件。

        此方法只能在每个对象一次启动一个新的事件循环。 如果此对象已经启动了辅助事件循环，并且当前仍在运行，则此方法返回false以指示在启动新事件循环时不成功。 否则，此方法将阻止调用线程，并且当新的事件循环终止时，此方法将返回true 。 此时，该对象可以再次用于启动另一个新的事件循环。

        结果
        true在二次循环终止后，如果二次循环由此呼叫启动， false

      • exit

        boolean exit​()
        解除阻止由enter()方法阻塞的线程的执行，并退出次级循环。

        此方法将恢复调用enter()方法的线程，并退出在调用enter()方法时创建的辅助循环。

        请注意，如果在此循环运行时启动任何其他辅助循环，则在嵌套循环终止之前，阻塞的线程将不会恢复执行。

        如果二次回路尚未开始与enter()法，或这二次回路已与成品exit()方法，该方法返回false ，否则true返回。

        结果
        true如果此循环以前启动并且还没有完成 exit()方法，则 false否则
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Shape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface Shape

  • 所有已知实现类：
    Arc2D ， Arc2D.Double ， Arc2D.Float ， Area ， BasicTextUI.BasicCaret ， CubicCurve2D ， CubicCurve2D.Double ， CubicCurve2D.Float ， DefaultCaret ， Ellipse2D ， Ellipse2D.Double ， Ellipse2D.Float ， GeneralPath ， Line2D ， Line2D.Double ， Line2D.Float ， Path2D ， Path2D.Double ， Path2D.Float ， Polygon ， QuadCurve2D ， QuadCurve2D.Double ， QuadCurve2D.Float ， Rectangle ， Rectangle2D ， Rectangle2D.Double ， Rectangle2D.Float ， RectangularShape ， RoundRectangle2D ， RoundRectangle2D.Double ， RoundRectangle2D.Float

    public interface Shape
    Shape接口为表示某种形状的几何形状的对象提供了定义。 Shape由PathIterator对象描述，可以表达Shape的轮廓，以及用于确定轮廓如何将2D平面划分为内部和外部点的规则。 每个Shape对象提供回调以获取几何的边界框，确定点或矩形部分或完全位于Shape的内部，并检索描述Shape轮廓的轨迹路径的PathIterator对象。

    Definition of insideness:一个点被认为是在一个Shape里面，如果且仅当：

    • 它完全位于内部Shape边界或
    • 它正好位于Shape边界上，紧邻X方向的点的空间完全在边界内或
    • 它恰好在水平边界段上， 并且在增加的Y方向上紧邻该点的空间在边界内。

    contains和intersects方法考虑到一个Shape的内部是它被包围的区域，就像它被填充一样。 这意味着这些方法认为未封闭的形状是隐式关闭的，以便确定形状是否包含或相交矩形，或者形状是否包含点。

    从以下版本开始：
    1.2
    另请参见：
    PathIterator ， AffineTransform ， FlatteningPathIterator ， GeneralPath

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      boolean contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      Rectangle getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      Rectangle2D getBounds2D​()
      返回 Shape的 getBounds高精度和更准确的边界框。
      PathIterator getPathIterator​(AffineTransform at)
      返回一个沿 Shape边界迭代的迭代器对象，并提供对 Shape大纲的几何形状的访问。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回一个沿着 Shape边界进行迭代的迭代器对象，并提供对 Shape轮廓几何体的平坦化视图的访问。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。

    • 方法详细信息

      • getBounds

        Rectangle getBounds​()
        返回一个整数Rectangle完全包围Shape 。 请注意，不保证返回的Rectangle是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle 。 如果Shape溢出整数数据类型的有限范围，返回的Rectangle也可能无法完全包含Shape 。 getBounds2D方法通常返回更严格的边界框，因为它具有更大的表示灵活性。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(x,y)需要bounds.contains(x,y)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(x,y)并不表示shape.contains(x,y)

        结果
        整数 Rectangle完全包围 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        getBounds2D()

      • getBounds2D

        Rectangle2D getBounds2D​()
        比getBounds方法返回Shape高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        getBounds()

      • contains

        boolean contains​(double x,
                 double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标是在Shape边界内; false否则。
        从以下版本开始：
        1.2

      • contains

        boolean contains​(Point2D p)
        测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
        参数
        p - 要测试的指定 Point2D
        结果
        true如果指定Point2D是的边界内Shape ; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        boolean intersects​(double x,
                   double y,
                   double w,
                   double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 如果任何点包含在Shape的内部和指定的矩形区域中，则矩形区域被认为与Shape相交。

        Shape.intersects()方法允许Shape实现保守返回true时：

        • 很可能矩形区域和Shape相交，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回true即使矩形区域不与Shape相交。 Area类比大多数Shape对象执行几何交集的更精确的计算，因此如果需要更精确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • intersects

        boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许一个Shape实现保守地返回true当：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回true即使Rectangle2D不与Shape相交。 Area类比大多数Shape对象执行更精确的几何交集计算，因此如果需要更精确的答案，则可以使用它。
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的Rectangle2D的内部相交，或者两者极有可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        intersects(double, double, double, double)

      • contains

        boolean contains​(double x,
                 double y,
                 double w,
                 double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标都必须位于Shape内，因为整个矩形区域被认为包含在Shape 。

        Shape.contains()方法允许一个Shape实现保守地返回false当：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回false即使Shape包含矩形区域。 Area类执行比大多数Shape对象更准确的几何计算，因此如果需要更准确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则或如果Shape包含矩形区域，并且intersects方法返回true ，并且包含计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， intersects(double, double, double, double)

      • contains

        boolean contains​(Rectangle2D r)
        测试Shape的内部Shape完全包含指定的Rectangle2D 。 Shape.contains()方法允许一个Shape实现保守返回false当：
        • intersect方法返回true和
        • 确定Shape是否完全包含Rectangle2D是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回false即使Shape包含Rectangle2D 。 Area类比大多数Shape对象执行更精确的几何计算，因此如果需要更精确的答案，则可以使用它。
        参数
        r - 指定的 Rectangle2D
        结果
        true如果内部的Shape完全包含Rectangle2D ; false否则或如果Shape包含Rectangle2D ，并且intersects方法返回true ，并且遏制计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        contains(double, double, double, double)

      • getPathIterator

        PathIterator getPathIterator​(AffineTransform at)
        返回一个沿着Shape边界进行迭代的迭代器对象，并提供对Shape轮廓几何的访问。 如果指定了可选的AffineTransform ，则相应地转换迭代中返回的坐标。

        此方法每次调用返回一个新鲜PathIterator对象横穿的几何形状Shape从任何其他独立对象PathIterator在使用中在相同的时间对象。

        建议但不能保证实现Shape接口的对象隔离在这样的迭代过程中可能发生的原始对象的几何的任何更改的迭代。

        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        结果
        一个新的 PathIterator对象，它独立地遍历了 Shape的几何。
        从以下版本开始：
        1.2

      • getPathIterator

        PathIterator getPathIterator​(AffineTransform at,
                             double flatness)
        返回一个沿Shape边界进行迭代的迭代器对象，并提供对Shape外形几何体的Shape平视图的访问。

        只有SEG_MOVETO，SEG_LINETO和SEG_CLOSE点类型由迭代器返回。

        如果指定了可选的AffineTransform ，则相应地转换迭代中返回的坐标。

        曲线段的细分量由flatness参数控制，该参数指定未平坦化变形曲线上的任何点可能偏离返回的平坦化路径段的最大距离。 注意，平坦化路径的精度的限制可能会被默认地施加，导致非常小的平坦化参数被视为较大的值。 这个限制（如果有的话）是由所使用的特定实现来定义的。

        对此方法的每次调用都将返回一个新鲜的PathIterator对象，该对象与所使用的任何其他PathIterator对象同时遍历Shape对象几何。

        建议但不能保证实现Shape接口的对象会隔离Shape迭代，因为在此类迭代期间原始对象的几何可能发生的任何更改。

        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        flatness - 用于近似曲线段的线段的最大距离允许偏离原始曲线上的任何点
        结果
        一个新的 PathIterator独立地横穿的几何形状的平面视图 Shape 。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SplashScreen (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class SplashScreen

  • java.lang.Object
    • java.awt.SplashScreen

  • public final class SplashScreen
extends Object
    在Java虚拟机（JVM）启动之前，启动屏幕可以在应用程序启动时显示。 启动屏幕显示为包含图像的未装饰窗口。 您可以为图像使用GIF，JPEG或PNG文件。 动画支持GIF格式，而GIF和PNG也支持透明度。 窗口位于屏幕的中心。 多监视器系统上的位置未指定。 它是平台和实现依赖的。 一旦Swing / AWT显示第一个窗口，启动屏幕窗口就会自动关闭（也可以使用Java API手动关闭，参见下文）。

    如果您的应用程序打包在一个jar文件中，您可以使用清单文件中的“SplashScreen-Image”选项来显示启动画面。 将图像放在jar存档中并指定选项中的路径。 该路径不应该有一个主要的斜杠。
    例如，在manifest.mf文件中：

      Manifest-Version: 1.0
 Main-Class: Test
 SplashScreen-Image: filename.gif

    如果Java实现提供命令行界面，并且使用命令行或快捷方式运行应用程序，请使用Java应用程序启动程序选项显示启动屏幕。 Oracle参考实现允许您使用-splash:选项指定启动屏幕图像位置。
    例如：

      java -splash:filename.gif Test
    还支持HiDPI缩放图像。 不考虑HiDPI和非HiDPI，所有图像类型的unscaled图像名称即filename.gif应该被传递manifest.mf -splash:选项。 以下是缩放图像的命名约定。 屏幕比例1.25：filename@125pct.gif屏幕比例1.50：filename@150pct.gif屏幕比例2：filename@200pct.gif和filename@2x.gif都支持屏幕比例2.50：filename@250pct.gif屏幕比例3：文件名@ 300pct.gif和filename@3x.gif都支持这些命令行界面的优先级高于清单设置。

    启动屏幕将尽可能忠实地显示给出目标平台和显示的限制的整个启动屏幕图像。

    这意味着指定的图像按“原样”显示在屏幕上，即保留图像文件中指定的精确颜色值。 然而，在某些情况下，所呈现的图像可能不同，例如，当应用颜色抖动以在16或8 bpp屏幕上呈现每像素32位（bpp）图像时。 本机平台显示配置还可能影响显示图像的颜色（例如颜色配置文件等）

    SplashScreen类提供了控制启动画面的API。 此类可用于关闭启动屏幕，更改启动屏幕图像，获取启动屏幕本机窗口位置/大小，并在启动屏幕中绘制。 它不能用于创建闪屏。 您应该使用Java实现提供的选项。

    这个类不能被实例化。 只有这个类的一个实例可以存在，并且它可以通过使用能够得到getSplashScreen()静态方法。 如果通过命令行或清单文件选项在应用程序启动时尚未创建启动屏幕，则getSplashScreen方法将返回null 。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      隐藏启动屏幕，关闭窗口，并释放所有关联的资源。
      Graphics2D createGraphics​()
      为启动屏幕叠加图像创建图形上下文（作为Graphics2D对象），允许您绘制闪屏。
      Rectangle getBounds​()
      以Rectangle返回启动屏幕窗口的边界 。
      URL getImageURL​()
      返回当前的闪屏图像。
      Dimension getSize​()
      以Dimension的形式返回闪屏的大小。
      static SplashScreen getSplashScreen​()
      返回用于支持显示的系统上的Java启动启动画面控件的 SplashScreen对象。
      boolean isVisible​()
      确定启动屏幕是否可见。
      void setImageURL​(URL imageURL)
      更改启动屏幕图像。
      void update​()
      使用覆盖图像的当前内容更新启动窗口。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getSplashScreen

        public static SplashScreen getSplashScreen​()
        返回用于支持显示的系统上的Java启动启动画面控件的 SplashScreen对象。
        结果
        SplashScreen实例，或null如果没有或已经关闭
        异常
        UnsupportedOperationException - 如果当前工具包不支持启动屏幕功能
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回true

      • setImageURL

        public void setImageURL​(URL imageURL)
                 throws NullPointerException,
                        IOException,
                        IllegalStateException
        更改启动屏幕图像。 新图像从指定的URL加载; 支持GIF，JPEG和PNG图像格式。 该方法在图像加载完成并且窗口已更新后返回。 启动屏幕窗口根据图像的大小调整大小，并以屏幕为中心。
        参数
        imageURL - 新的启动屏幕图像的非 null网址
        异常
        NullPointerException - 如果 imageURL是 null
        IOException - 如果在加载图像时出错
        IllegalStateException - 如果启动画面已经关闭

      • getImageURL

        public URL getImageURL​()
                throws IllegalStateException
        返回当前的闪屏图像。
        结果
        当前闪屏图像文件的URL
        异常
        IllegalStateException - 如果启动画面已经关闭

      • getBounds

        public Rectangle getBounds​()
                    throws IllegalStateException
        以Rectangle返回启动屏幕窗口的边界 。 如果您要将窗口替换为同一位置的启动画面，这可能会有用。

        您无法控制闪屏的大小或位置。 当图像更改时，启动画面尺寸会自动调整。

        图像可能包含透明区域，因此报告的边界可能大于屏幕上可见的闪屏图像。

        结果
        一个 Rectangle包含启动屏幕边界
        异常
        IllegalStateException - 如果启动画面已经关闭

      • getSize

        public Dimension getSize​()
                  throws IllegalStateException
        以Dimension的形式返回闪屏的大小。 如果您想要在闪屏上叠加表面上绘制，这可能很有用。

        您无法控制闪屏的大小或位置。 当图像更改时，启动画面尺寸会自动调整。

        图像可能包含透明区域，因此报告的大小可能大于屏幕上可见的闪屏图像。

        结果
        一个Dimension对象，指示启动屏幕大小
        异常
        IllegalStateException - 如果启动画面已经关闭

      • createGraphics

        public Graphics2D createGraphics​()
                          throws IllegalStateException
        为启动屏幕叠加图像创建图形上下文（作为Graphics2D对象），允许您绘制闪屏。 请注意，您不要绘制主图像，而是使用Alpha混合在主图像上显示的图像上。 还要注意，叠加图像上的绘图不一定会更新启动屏幕窗口的内容。 当您希望立即更新闪屏时，您应该拨打update() SplashScreen 。

        图形上下文坐标空间中的像素（0,0）对应于闪屏本机窗口界限的起点（见getBounds() ）。

        结果
        图形上下文为闪屏覆盖表面
        异常
        IllegalStateException - 如果启动画面已经关闭

      • update

        public void update​()
            throws IllegalStateException
        使用覆盖图像的当前内容更新启动窗口。
        异常
        IllegalStateException - 如果覆盖图像不存在; 例如，如果createGraphics从未被调用，或者启动屏幕已经关闭

      • close

        public void close​()
           throws IllegalStateException
        隐藏启动屏幕，关闭窗口，并释放所有关联的资源。
        异常
        IllegalStateException - 如果启动画面已经关闭

      • isVisible

        public boolean isVisible​()
        确定启动屏幕是否可见。 启动屏幕可能使用close()隐藏，当第一个AWT / Swing窗口可见时，它也会自动隐藏。

        请注意，本地平台可能会延迟在屏幕上显示启动屏幕本机窗口。 此方法的返回值为true仅保证隐藏启动屏幕窗口的条件尚未发生。

        结果
        如果启动屏幕可见（尚未关闭），则为true，否则为false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Stroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface Stroke

  • 所有已知实现类：
    BasicStroke

    public interface Stroke
    Stroke接口允许一个Graphics2D对象获得Shape的装饰轮廓或轮廓的风格表示的Shape 。 追踪Shape就像使用适当尺寸和形状的标记笔来追踪其轮廓。 笔会放置墨水的区域是由轮廓Shape包围的区域。

    所述的方法Graphics2D接口使用轮廓Shape通过返回Stroke对象包括draw以及其他在该方法方面实现的任何其他方法，如drawLine ， drawRect ， drawRoundRect ， drawOval ， drawArc ， drawPolyline ，和drawPolygon 。

    实现Stroke的类的对象必须是只读的，因为当Graphics2D被设置为具有setStroke方法的属性或者当Graphics2D对象本身被克隆时， Graphics2D不会克隆这些对象。 如果Stroke对象在Graphics2D上下文中设置后被修改，那么后续呈现的行为将是未定义的。

    另请参见：
    BasicStroke ， Graphics2D.setStroke(java.awt.Stroke)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Shape createStrokedShape​(Shape p)
      返回一个轮廓 Shape ，其中包含当 Shape按照实现 Stroke接口的对象定义的规则进行抚摸时应绘制的区域。

    • 方法详细信息

      • createStrokedShape

        Shape createStrokedShape​(Shape p)
        返回一个轮廓 Shape ，其中包含 Shape根据实现 Stroke接口的对象定义的规则进行绘制时应绘制的区域。
        参数
        p - 一个 Shape要抚摸
        结果
        the stroked outline Shape.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SystemColor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class SystemColor

  • java.lang.Object
    • java.awt.Color
      • java.awt.SystemColor
  • All Implemented Interfaces:
    Paint ， Transparency ， Serializable

    public final class SystemColor
extends Color
implements Serializable
    封装代表系统上本地GUI对象颜色的符号颜色的类。 对于支持动态更新系统颜色的系统（当用户更改颜色时），这些符号颜色的实际RGB值也将动态更改。 为了比较一个的“当前” RGB值SystemColor与非象征性Color对象对象， getRGB应使用，而不是equals 。

    请注意，这些系统颜色应用于GUI对象的方式可能会从平台到平台略有不同，因为GUI对象可能在每个平台上呈现不同的方式。

    系统颜色值也可以通过getDesktopProperty方法java.awt.Toolkit 。

    另请参见：
    Toolkit.getDesktopProperty(java.lang.String) ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ACTIVE_CAPTION
      阵列索引为 activeCaption系统颜色。
      static int ACTIVE_CAPTION_BORDER
      阵列索引为 activeCaptionBorder系统颜色。
      static int ACTIVE_CAPTION_TEXT
      阵列索引为 activeCaptionText系统颜色。
      static SystemColor activeCaption
      为当前活动窗口的窗口标题背景呈现的颜色。
      static SystemColor activeCaptionBorder
      为当前活动窗口周围的边框渲染的颜色。
      static SystemColor activeCaptionText
      为当前活动窗口的窗口标题文本呈现的颜色。
      static SystemColor control
      为控制面板和控制对象（如按钮）的背景渲染的颜色。
      static int CONTROL
      阵列索引为 control系统颜色。
      static int CONTROL_DK_SHADOW
      阵列索引为 controlDkShadow系统颜色。
      static int CONTROL_HIGHLIGHT
      阵列索引为 controlHighlight系统颜色。
      static int CONTROL_LT_HIGHLIGHT
      阵列索引为 controlLtHighlight系统颜色。
      static int CONTROL_SHADOW
      阵列索引为 controlShadow系统颜色。
      static int CONTROL_TEXT
      阵列索引为 controlText系统颜色。
      static SystemColor controlDkShadow
      在3D控件对象（如按钮）上为暗影区域呈现的颜色。
      static SystemColor controlHighlight
      为3D控制对象（如按钮）的亮区渲染颜色。
      static SystemColor controlLtHighlight
      为3D控件对象的高亮区域（如按钮）渲染颜色。
      static SystemColor controlShadow
      为3D控件对象（如按钮）的阴影区域呈现的颜色。
      static SystemColor controlText
      为控制面板和控制对象（如按钮）的文本呈现的颜色。
      static SystemColor desktop
      渲染为桌面背景的颜色。
      static int DESKTOP
      阵列索引为 desktop系统颜色。
      static int INACTIVE_CAPTION
      阵列索引为 inactiveCaption系统颜色。
      static int INACTIVE_CAPTION_BORDER
      阵列索引为 inactiveCaptionBorder系统颜色。
      static int INACTIVE_CAPTION_TEXT
      阵列索引为 inactiveCaptionText系统颜色。
      static SystemColor inactiveCaption
      为非活动窗口的窗口标题背景呈现的颜色。
      static SystemColor inactiveCaptionBorder
      为不活动窗口周围的边框渲染颜色。
      static SystemColor inactiveCaptionText
      为非活动窗口的窗口标题文本呈现的颜色。
      static SystemColor info
      为工具提示背景提供的颜色或现场帮助。
      static int INFO
      阵列索引为 info系统颜色。
      static int INFO_TEXT
      阵列索引为 infoText系统颜色。
      static SystemColor infoText
      为文本提供的工具提示颜色或点帮助。
      static SystemColor menu
      呈现为菜单背景的颜色。
      static int MENU
      阵列索引为 menu系统颜色。
      static int MENU_TEXT
      阵列索引为 menuText系统颜色。
      static SystemColor menuText
      为菜单文本呈现的颜色。
      static int NUM_COLORS
      数组中的系统颜色数。
      static SystemColor scrollbar
      呈现为滚动条背景的颜色。
      static int SCROLLBAR
      阵列索引为 scrollbar系统颜色。
      static SystemColor text
      为文本控件对象（如文本框和组合框）的背景渲染的颜色。
      static int TEXT
      阵列索引为 text系统颜色。
      static int TEXT_HIGHLIGHT
      阵列索引为 textHighlight系统颜色。
      static int TEXT_HIGHLIGHT_TEXT
      阵列索引为 textHighlightText系统颜色。
      static int TEXT_INACTIVE_TEXT
      阵列索引为 textInactiveText系统颜色。
      static int TEXT_TEXT
      阵列索引为 textText系统颜色。
      static SystemColor textHighlight
      为所选项目的背景渲染的颜色，如菜单，组合框和文本。
      static SystemColor textHighlightText
      为所选项目的文本呈现的颜色，如菜单，组合框和文本。
      static SystemColor textInactiveText
      为非活动项目的文本呈现的颜色，如菜单中。
      static SystemColor textText
      为文本控件对象（如文本框和组合框）的文本呈现的颜色。
      static SystemColor window
      为Windows内部区域背景渲染的颜色。
      static int WINDOW
      阵列索引为 window系统颜色。
      static int WINDOW_BORDER
      阵列索引为 windowBorder系统颜色。
      static int WINDOW_TEXT
      阵列索引为 windowText系统颜色。
      static SystemColor windowBorder
      为窗户内部区域的边界呈现的颜色。
      static SystemColor windowText
      为窗口内部区域的文字渲染的颜色。

      • Fields inherited from class java.awt.Color

        black, BLACK, blue, BLUE, cyan, CYAN, DARK_GRAY, darkGray, gray, GRAY, green, GREEN, LIGHT_GRAY, lightGray, magenta, MAGENTA, orange, ORANGE, pink, PINK, red, RED, white, WHITE, yellow, YELLOW

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回此 Color的值的字符串表示形式。

      • Methods inherited from class java.awt.Color

        brighter, createContext, darker, decode, equals, getAlpha, getBlue, getColor, getColor, getColor, getColorComponents, getColorComponents, getColorSpace, getComponents, getComponents, getGreen, getHSBColor, getRed, getRGB, getRGBColorComponents, getRGBComponents, getTransparency, hashCode, HSBtoRGB, RGBtoHSB

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DESKTOP

        @Native
public static final int DESKTOP
        desktop系统颜色的数组索引。
        另请参见：
        desktop ， Constant Field Values

      • ACTIVE_CAPTION

        @Native
public static final int ACTIVE_CAPTION
        阵列索引为 activeCaption系统颜色。
        另请参见：
        activeCaption ， Constant Field Values

      • ACTIVE_CAPTION_TEXT

        @Native
public static final int ACTIVE_CAPTION_TEXT
        activeCaptionText系统颜色的数组索引。
        另请参见：
        activeCaptionText ， Constant Field Values

      • ACTIVE_CAPTION_BORDER

        @Native
public static final int ACTIVE_CAPTION_BORDER
        阵列索引为 activeCaptionBorder系统颜色。
        另请参见：
        activeCaptionBorder ， Constant Field Values

      • INACTIVE_CAPTION

        @Native
public static final int INACTIVE_CAPTION
        inactiveCaption系统颜色的数组索引。
        另请参见：
        inactiveCaption ， Constant Field Values

      • INACTIVE_CAPTION_TEXT

        @Native
public static final int INACTIVE_CAPTION_TEXT
        阵列索引为 inactiveCaptionText系统颜色。
        另请参见：
        inactiveCaptionText ， Constant Field Values

      • INACTIVE_CAPTION_BORDER

        @Native
public static final int INACTIVE_CAPTION_BORDER
        阵列索引为 inactiveCaptionBorder系统颜色。
        另请参见：
        inactiveCaptionBorder ， Constant Field Values

      • WINDOW

        @Native
public static final int WINDOW
        阵列索引为 window系统颜色。
        另请参见：
        window ， Constant Field Values

      • WINDOW_BORDER

        @Native
public static final int WINDOW_BORDER
        阵列索引为 windowBorder系统颜色。
        另请参见：
        windowBorder ， Constant Field Values

      • WINDOW_TEXT

        @Native
public static final int WINDOW_TEXT
        阵列索引为 windowText系统颜色。
        另请参见：
        windowText ， Constant Field Values

      • MENU

        @Native
public static final int MENU
        阵列索引为 menu系统颜色。
        另请参见：
        menu ， Constant Field Values

      • MENU_TEXT

        @Native
public static final int MENU_TEXT
        menuText系统颜色的数组索引。
        另请参见：
        menuText ， Constant Field Values

      • TEXT

        @Native
public static final int TEXT
        阵列索引为 text系统颜色。
        另请参见：
        text ， Constant Field Values

      • TEXT_TEXT

        @Native
public static final int TEXT_TEXT
        textText系统颜色的数组索引。
        另请参见：
        textText ， Constant Field Values

      • TEXT_HIGHLIGHT

        @Native
public static final int TEXT_HIGHLIGHT
        textHighlight系统颜色的数组索引。
        另请参见：
        textHighlight ， Constant Field Values

      • TEXT_HIGHLIGHT_TEXT

        @Native
public static final int TEXT_HIGHLIGHT_TEXT
        textHighlightText系统颜色的数组索引。
        另请参见：
        textHighlightText ， Constant Field Values

      • TEXT_INACTIVE_TEXT

        @Native
public static final int TEXT_INACTIVE_TEXT
        textInactiveText系统颜色的数组索引。
        另请参见：
        textInactiveText ， Constant Field Values

      • CONTROL

        @Native
public static final int CONTROL
        阵列索引为 control系统颜色。
        另请参见：
        control ， Constant Field Values

      • CONTROL_TEXT

        @Native
public static final int CONTROL_TEXT
        controlText系统颜色的数组索引。
        另请参见：
        controlText ， Constant Field Values

      • CONTROL_HIGHLIGHT

        @Native
public static final int CONTROL_HIGHLIGHT
        阵列索引为 controlHighlight系统颜色。
        另请参见：
        controlHighlight ， Constant Field Values

      • CONTROL_LT_HIGHLIGHT

        @Native
public static final int CONTROL_LT_HIGHLIGHT
        controlLtHighlight系统颜色的数组索引。
        另请参见：
        controlLtHighlight ， Constant Field Values

      • CONTROL_SHADOW

        @Native
public static final int CONTROL_SHADOW
        controlShadow系统颜色的数组索引。
        另请参见：
        controlShadow ， Constant Field Values

      • CONTROL_DK_SHADOW

        @Native
public static final int CONTROL_DK_SHADOW
        controlDkShadow系统颜色的数组索引。
        另请参见：
        controlDkShadow ， Constant Field Values

      • SCROLLBAR

        @Native
public static final int SCROLLBAR
        阵列索引为 scrollbar系统颜色。
        另请参见：
        scrollbar ， Constant Field Values

      • INFO

        @Native
public static final int INFO
        阵列索引为 info系统颜色。
        另请参见：
        info ， Constant Field Values

      • INFO_TEXT

        @Native
public static final int INFO_TEXT
        阵列索引为 infoText系统颜色。
        另请参见：
        infoText ， Constant Field Values

      • NUM_COLORS

        @Native
public static final int NUM_COLORS
        数组中的系统颜色数。
        另请参见：
        Constant Field Values

      • desktop

        public static final SystemColor desktop
        渲染为桌面背景的颜色。

      • activeCaption

        public static final SystemColor activeCaption
        为当前活动窗口的窗口标题背景呈现的颜色。

      • activeCaptionText

        public static final SystemColor activeCaptionText
        为当前活动窗口的窗口标题文本呈现的颜色。

      • activeCaptionBorder

        public static final SystemColor activeCaptionBorder
        为当前活动窗口周围的边框渲染的颜色。

      • inactiveCaption

        public static final SystemColor inactiveCaption
        为非活动窗口的窗口标题背景呈现的颜色。

      • inactiveCaptionText

        public static final SystemColor inactiveCaptionText
        为非活动窗口的窗口标题文本呈现的颜色。

      • inactiveCaptionBorder

        public static final SystemColor inactiveCaptionBorder
        为不活动窗口周围的边框渲染颜色。

      • window

        public static final SystemColor window
        为Windows内部区域背景渲染的颜色。

      • windowBorder

        public static final SystemColor windowBorder
        为窗户内部区域的边界呈现的颜色。

      • windowText

        public static final SystemColor windowText
        为窗口内部区域的文字渲染的颜色。

      • menu

        public static final SystemColor menu
        呈现为菜单背景的颜色。

      • menuText

        public static final SystemColor menuText
        为菜单文本呈现的颜色。

      • text

        public static final SystemColor text
        为文本控件对象（如文本框和组合框）的背景渲染的颜色。

      • textText

        public static final SystemColor textText
        为文本控件对象（如文本框和组合框）的文本呈现的颜色。

      • textHighlight

        public static final SystemColor textHighlight
        为所选项目的背景渲染的颜色，如菜单，组合框和文本。

      • textHighlightText

        public static final SystemColor textHighlightText
        为所选项目的文本呈现的颜色，如菜单，组合框和文本。

      • textInactiveText

        public static final SystemColor textInactiveText
        为非活动项目的文本呈现的颜色，如菜单中。

      • control

        public static final SystemColor control
        为控制面板和控制对象（如按钮）的背景渲染的颜色。

      • controlText

        public static final SystemColor controlText
        为控制面板和控制对象（如按钮）的文本呈现的颜色。

      • controlHighlight

        public static final SystemColor controlHighlight
        为3D控制对象（如按钮）的亮区渲染颜色。 这种颜色通常来自于control背景颜色，以提供3D效果。

      • controlLtHighlight

        public static final SystemColor controlLtHighlight
        为3D控件对象的高亮区域（如按钮）渲染颜色。 这种颜色通常来源于control背景颜色，以提供3D效果。

      • controlShadow

        public static final SystemColor controlShadow
        为3D控件对象（如按钮）的阴影区域呈现的颜色。 这种颜色通常来源于control背景颜色，以提供3D效果。

      • controlDkShadow

        public static final SystemColor controlDkShadow
        在3D控件对象（如按钮）上为暗影区域呈现的颜色。 这种颜色通常来自于control背景颜色，以提供3D效果。

      • scrollbar

        public static final SystemColor scrollbar
        呈现为滚动条背景的颜色。

      • info

        public static final SystemColor info
        为工具提示背景提供的颜色或现场帮助。

      • infoText

        public static final SystemColor infoText
        为文本提供的工具提示颜色或点帮助。

    • 方法详细信息

      • toString

        public String toString​()
        返回此Color的值的字符串表示形式。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        toString在 Color
        结果
        这个 Color的字符串表示 Color
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SystemTray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class SystemTray

  • java.lang.Object
    • java.awt.SystemTray

  • public class SystemTray
extends Object
    SystemTray类表示桌面的系统托盘。 在Microsoft Windows上，它被称为“任务栏状态区”，在Gnome上将其称为“通知区域”，在KDE上称为“系统托盘”。 系统托盘由桌面上运行的所有应用程序共享。

    在某些平台上，系统托盘可能不存在或可能不受支持，在这种情况下， getSystemTray()抛出UnsupportedOperationException 。 要检测系统托盘是否受支持，请使用isSupported() 。

    SystemTray可能包含一个或多个TrayIcons ，它们使用add(java.awt.TrayIcon)方法添加到托盘，并在不再需要时使用remove(java.awt.TrayIcon)进行删除 。 TrayIcon由图像，弹出菜单和一组关联的侦听器组成。 详情请参阅TrayIcon课程。

    每个Java应用程序都有一个SystemTray实例，允许应用程序在应用程序运行时与桌面的系统托盘进行连接。 可以从getSystemTray()方法获得SystemTray实例。 应用程序可能无法创建自己的SystemTray实例。

    以下代码片段演示了如何访问和自定义系统托盘：

       TrayIcon trayIcon = null; if (SystemTray.isSupported()) { // get the SystemTray instance SystemTray tray = SystemTray.getSystemTray(); // load an image Image image = Toolkit.getDefaultToolkit().getImage(...); // create a action listener to listen for default action executed on the tray icon ActionListener listener = new ActionListener() { public void actionPerformed(ActionEvent e) { // execute default action of the application // ... } }; // create a popup menu PopupMenu popup = new PopupMenu(); // create menu item for the default action MenuItem defaultItem = new MenuItem(...); defaultItem.addActionListener(listener); popup.add(defaultItem); /// ... add other items // construct a TrayIcon trayIcon = new TrayIcon(image, "Tray Demo", popup); // set the TrayIcon properties trayIcon.addActionListener(listener); // ... // add the tray image try { tray.add(trayIcon); } catch (AWTException e) { System.err.println(e); } // ... } else { // disable tray option in your application or // perform other actions ... } // ... // some time later // the application state has changed - update the image if (trayIcon != null) { trayIcon.setImage(updatedImage); } // ...
    从以下版本开始：
    1.6
    另请参见：
    TrayIcon

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(TrayIcon trayIcon)
      添加 TrayIcon到 SystemTray 。
      void addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      在特定属性的列表中添加一个 PropertyChangeListener 。
      PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      static SystemTray getSystemTray​()
      获取表示桌面托盘区域的 SystemTray实例。
      TrayIcon[] getTrayIcons​()
      返回此应用程序添加到托盘中的所有图标的数组。
      Dimension getTrayIconSize​()
      返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
      static boolean isSupported​()
      返回当前平台是否支持系统托盘。
      void remove​(TrayIcon trayIcon)
      删除指定 TrayIcon从 SystemTray 。
      void removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      从侦听器列表中删除特定属性的 PropertyChangeListener 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getSystemTray

        public static SystemTray getSystemTray​()
        获取表示桌面托盘区域的SystemTray实例。 这总是返回每个应用程序相同的实例。 在某些平台上可能不支持系统托盘。 您可以使用isSupported()方法来检查系统托盘是否受支持。

        如果安装了SecurityManager，则必须授予accessSystemTray才能获取SystemTray实例。 否则这个方法会抛出一个SecurityException。

        结果
        表示桌面托盘区域的 SystemTray实例
        异常
        UnsupportedOperationException - 如果当前平台不支持系统托盘
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回 true
        SecurityException - 如果不授予 accessSystemTray权限
        另请参见：
        add(TrayIcon) ， TrayIcon ， isSupported() ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • isSupported

        public static boolean isSupported​()
        返回当前平台是否支持系统托盘。 除了显示托盘图标，最小的系统托盘支持还包括弹出式菜单（参见TrayIcon.setPopupMenu(PopupMenu) ）或操作事件（请参阅TrayIcon.addActionListener(ActionListener) ）。

        开发人员不应该假定所有的系统托盘功能都被支持。 要确保托盘图标的默认操作始终可以访问，请将默认操作添加到动作侦听器和弹出菜单。 有关如何执行此操作的示例，请参阅example 。

        注意 ：实现SystemTray和TrayIcon ， 强烈建议您将不同的手势分配给弹出菜单和动作事件。 为两个目的重载手势是混乱的，可能会阻止用户访问一个或另一个。

        结果
        false如果不支持系统托盘访问; 如果支持最小系统托盘访问，则此方法返回true ，但不保证当前平台支持所有系统托盘功能
        另请参见：
        getSystemTray()

      • add

        public void add​(TrayIcon trayIcon)
         throws AWTException
        在TrayIcon添加一个SystemTray 。 添加后，系统托盘中的托盘图标就会显示。 图标在托盘中显示的顺序未指定 - 它与平台和实现相关。

        在应用程序退出时，当桌面系统托盘不可用时，应用程序添加的所有图标都将自动从SystemTray删除。

        参数
        trayIcon - 要添加的 TrayIcon
        异常
        NullPointerException - 如果 trayIcon是 null
        IllegalArgumentException - 如果一个 TrayIcon的同一个实例被 TrayIcon添加
        AWTException - 如果桌面系统托盘丢失
        另请参见：
        remove(TrayIcon) ， getSystemTray() ， TrayIcon ， Image

      • remove

        public void remove​(TrayIcon trayIcon)
        删除指定TrayIcon从SystemTray 。

        应用程序退出时，应用程序添加的所有图标将自动从SystemTray删除，并且桌面系统托盘不可用时也会自动删除。

        如果trayIcon为null或未添加到系统托盘，则不会抛出异常，也不会执行任何操作。

        参数
        trayIcon - 要删除的 TrayIcon
        另请参见：
        add(TrayIcon) ， TrayIcon

      • getTrayIcons

        public TrayIcon[] getTrayIcons​()
        返回此应用程序添加到托盘中的所有图标的数组。 您无法访问另一个应用程序添加的图标。 一些浏览器将不同代码库中的小程序分割成单独的上下文，并在这些上下文之间建立墙壁。 在这种情况下，只会返回从上下文添加的托盘图标。

        返回的数组是实际数组的副本，可以以任何方式修改而不影响系统托盘。 要从TrayIcon删除SystemTray ，请使用remove(TrayIcon)方法。

        结果
        添加到此托盘的所有托盘图标的数组，如果没有添加，则为空数组
        另请参见：
        add(TrayIcon) ， TrayIcon

      • getTrayIconSize

        public Dimension getTrayIconSize​()
        返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。 在创建托盘图标之前，开发人员可以使用此方法获取托盘图标的图像属性的首选大小。 为方便起见，在TrayIcon类中有一个类似的方法TrayIcon.getSize() 。
        结果
        托盘图标的默认大小（以像素为单位）
        另请参见：
        TrayIcon.setImageAutoSize(boolean) ， Image ， TrayIcon.getSize()

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String propertyName,
                                      PropertyChangeListener listener)
        在特定属性的侦听器列表中添加一个PropertyChangeListener 。 目前支持以下属性： SystemTray properties Property Description trayIcons The SystemTray's array of TrayIcon objects. The array is accessed via the getTrayIcons() method.
        This property is changed when a tray icon is added to (or removed from) the system tray.
        For example, this property is changed when the system tray becomes unavailable on the desktop
        and the tray icons are automatically removed. systemTray This property contains SystemTray instance when the system tray is available or null otherwise.
        This property is changed when the system tray becomes available or unavailable on the desktop.
        The property is accessed by the getSystemTray() method.

        listener仅在此上下文中监听属性更改。

        如果listener为null ，则不会抛出异常，也不会执行任何操作。

        参数
        propertyName - 指定的属性
        listener - 要添加的属性更改侦听器
        另请参见：
        removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener) ， getPropertyChangeListeners(java.lang.String)

      • removePropertyChangeListener

        public void removePropertyChangeListener​(String propertyName,
                                         PropertyChangeListener listener)
        从侦听器列表中删除特定属性的PropertyChangeListener 。

        PropertyChangeListener必须来自这个上下文。

        如果propertyName或listener为null或无效，则不会抛出异常并且不采取任何操作。

        参数
        propertyName - 指定的属性
        listener - 要删除的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener) ， getPropertyChangeListeners(java.lang.String)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
        返回与named属性相关联的所有侦听器的数组。

        只有在这个上下文中的监听器被返回。

        参数
        propertyName - 指定的属性
        结果
        所有的PropertyChangeListener与命名的属性相关联; 如果没有添加此类侦听器，或者如果propertyName为null或无效，则返回一个空数组
        另请参见：
        addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener) ， removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Taskbar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Taskbar

  • java.lang.Object
    • java.awt.Taskbar

  • public class Taskbar
extends Object
    Taskbar类允许Java应用程序与系统任务区（任务栏，Dock等）进行交互。

    根据当前的平台有各种各样的交互，例如显示某些任务的进度，将用户指定的菜单附加到应用程序图标上下文菜单等。

    Implementation Note:
    Linux支持目前仅限于Unity。 但是要使这些功能在Unity上运行，该应用程序应该从具有指定的java.desktop.appName系统属性的.desktop文件运行。该属性设置为此.desktop文件名： Exec=java -Djava.desktop.appName=MyApp.desktop -jar /path/to/myapp.jar请参阅https://help.ubuntu.com/community/UnityLaunchersAndDesktopFiles
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Taskbar.Feature
      提供功能列表
      static class  Taskbar.State
      可用窗口进度的种类状态。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Image getIconImage​()
      获取此应用程序图标的图像。
      PopupMenu getMenu​()
      获取用于在系统任务区域中将项目添加到此应用程序图标的PopupMenu。
      static Taskbar getTaskbar​()
      返回当前任务栏上下文的 Taskbar实例。
      boolean isSupported​(Taskbar.Feature feature)
      测试当前平台是否支持 Feature 。
      static boolean isTaskbarSupported​()
      测试此类是否在当前平台上得到支持。
      void requestUserAttention​(boolean enabled, boolean critical)
      请求用户注意此应用程序。
      void requestWindowUserAttention​(Window w)
      请求用户注意指定的窗口。
      void setIconBadge​(String badge)
      在该应用程序的图标上贴上一个小系统提供的徽章。
      void setIconImage​(Image image)
      将此应用程序的图标更改为提供的图像。
      void setMenu​(PopupMenu menu)
      将提供的PopupMenu的内容附加到任务区域中的应用程序图标。
      void setProgressValue​(int value)
      在该应用程序的图标上贴上一个小系统提供的进度条。
      void setWindowIconBadge​(Window w, Image badge)
      在指定窗口的任务区域中贴上小应用程序的图标。
      void setWindowProgressState​(Window w, Taskbar.State state)
      设置指定窗口的进度状态。
      void setWindowProgressValue​(Window w, int value)
      在指定窗口的任务区域中显示确定的进度条。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • isSupported

        public boolean isSupported​(Taskbar.Feature feature)
        测试当前平台是否支持 Feature 。
        参数
        feature - 指定的Taskbar.Feature
        结果
        如果当前平台支持指定的功能，则为true

      • getTaskbar

        public static Taskbar getTaskbar​()
        返回当前任务栏上下文的Taskbar实例。 在某些平台上，Taskbar API可能不受支持; 使用isTaskbarSupported()方法来确定当前任务栏是否受支持。
        结果
        任务栏实例
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回 true
        UnsupportedOperationException - 如果当前平台不支持此类
        另请参见：
        isTaskbarSupported() ， GraphicsEnvironment.isHeadless()

      • isTaskbarSupported

        public static boolean isTaskbarSupported​()
        测试此类是否在当前平台上得到支持。 如果支持，请使用getTaskbar()检索实例。
        结果
        true如果在当前平台上支持此类; 否则为false
        另请参见：
        getTaskbar()

      • requestUserAttention

        public void requestUserAttention​(boolean enabled,
                                 boolean critical)
        请求用户注意此应用程序。 根据平台，这可以由任务区域中的弹跳或闪烁的图标在视觉上指示。 它可能对已经活动的应用程序没有影响。 在某些平台（例如Mac OS）上，此功能可能会在应用激活时消失，不能将enabled设置为false。 其他平台可能需要额外拨打requestUserAttention(boolean, boolean)以将该请求的enabled参数设置为false。
        参数
        enabled - 如果为false，则禁用此请求
        critical - 如果这是一个重要的请求
        异常
        SecurityException - 如果安全管理员存在并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.USER_ATTENTION功能

      • requestWindowUserAttention

        public void requestWindowUserAttention​(Window w)
        请求用户注意指定的窗口。 如果窗口表示在任务区域不可显示，则不起作用。 是否可显示，取决于所有窗口类型，平台和实现。
        参数
        w - 窗口
        异常
        SecurityException - 如果安全管理器存在，并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.USER_ATTENTION_WINDOW功能

      • setMenu

        public void setMenu​(PopupMenu menu)
        将提供的PopupMenu的内容附加到任务区域中的应用程序图标。
        参数
        menu - 要附加到此应用程序的PopupMenu
        异常
        SecurityException - 如果安全管理员存在并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.MENU功能

      • getMenu

        public PopupMenu getMenu​()
        获取用于在系统任务区域中将项目添加到此应用程序图标的PopupMenu。
        结果
        PopupMenu
        异常
        SecurityException - 如果安全管理器存在，并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.MENU功能

      • setIconImage

        public void setIconImage​(Image image)
        将此应用程序的图标更改为提供的图像。
        参数
        image - 更改
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.ICON_IMAGE功能

      • getIconImage

        public Image getIconImage​()
        获取此应用程序图标的图像。
        结果
        该应用程序图标的图像
        异常
        SecurityException - 如果存在安全管理员，并拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.ICON_IMAGE功能

      • setIconBadge

        public void setIconBadge​(String badge)
        在该应用程序的图标上贴上一个小系统提供的徽章。 通常一个数字。 某些平台不支持字符串值，只接受整数值。 在这种情况下，将以字符串表示的整数传递为参数。 这可以通过Feature.ICON_BADGE_TEXT和Feature.ICON_BADGE_NUMBER进行测试。 通过null作为参数隐藏徽章。
        参数
        badge - 标签附加到图标
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝了 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.ICON_BADGE_NUMBER或 Taskbar.Feature.ICON_BADGE_TEXT功能

      • setWindowIconBadge

        public void setWindowIconBadge​(Window w,
                               Image badge)
        在指定窗口的任务区域中贴上小应用程序的图标。 系统设置可能会被禁用。 如果窗口表示在任务区域不可显示，则不起作用。 是否可显示，取决于所有窗口类型，平台和实现。
        参数
        w - 要更新的窗口
        badge - 图像贴上图标
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.ICON_BADGE_IMAGE_WINDOW功能

      • setProgressValue

        public void setProgressValue​(int value)
        在该应用程序的图标上贴上一个小系统提供的进度条。
        参数
        value - 从0到100，其他禁用进度指示
        异常
        SecurityException - 如果安全管理员存在，并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.PROGRESS_VALUE功能

      • setWindowProgressValue

        public void setWindowProgressValue​(Window w,
                                   int value)
        在指定窗口的任务区域中显示确定的进度条。 如果窗口表示在任务区域不可显示，则不起作用。 是否可显示，取决于所有窗口类型，平台和实现。
        视觉行为是平台和Taskbar.State依赖。
        此通话取消了窗口的INDETERMINATE状态。
        请注意，当多个窗口分组在任务区域中时，行为是平台特定的。
        参数
        w - 要更新的窗口
        value - 从0到100，其他切换到 Taskbar.State.OFF状态并禁用进度指示
        异常
        SecurityException - 如果安全管理器存在，并且它拒绝 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.PROGRESS_VALUE_WINDOW功能
        另请参见：
        setWindowProgressState(java.awt.Window, State)

      • setWindowProgressState

        public void setWindowProgressState​(Window w,
                                   Taskbar.State state)
        设置指定窗口的进度状态。 如果窗口表示在任务区域不可显示，则不起作用。 是否可显示，取决于所有窗口类型，平台和实现。
        每个状态都以平台相关的方式显示进度。
        注意从INDETERMINATE状态切换到任何确定状态可能会将值设置为setWindowProgressValue
        参数
        w - 窗口
        state - 更改为
        异常
        SecurityException - 如果安全管理器存在，并且它拒绝了 RuntimePermission("canProcessApplicationEvents")权限。
        UnsupportedOperationException - 如果当前平台不支持 Taskbar.Feature.PROGRESS_STATE_WINDOW功能
        另请参见：
        Taskbar.State.OFF ， Taskbar.State.NORMAL ， Taskbar.State.PAUSED ， Taskbar.State.ERROR ， Taskbar.State.INDETERMINATE ， setWindowProgressValue(java.awt.Window, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Taskbar.Feature (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum Taskbar.Feature

  • java.lang.Object
    • java.lang.Enum<Taskbar.Feature>
      • java.awt.Taskbar.Feature
  • All Implemented Interfaces:
    Serializable ， Comparable<Taskbar.Feature>
    Enclosing class:
    Taskbar

    public static enum Taskbar.Feature
extends Enum<Taskbar.Feature>
    提供功能列表 每个平台支持不同的功能集。 您可以使用Taskbar.isSupported(java.awt.Taskbar.Feature)方法来确定给定功能是否由当前平台支持。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ICON_BADGE_IMAGE_WINDOW
      表示窗口的图形图标徽标功能。
      ICON_BADGE_NUMBER
      代表一个数字图标标志功能。
      ICON_BADGE_TEXT
      表示文字图标徽章功能。
      ICON_IMAGE
      表示图标功能。
      MENU
      表示菜单功能。
      PROGRESS_STATE_WINDOW
      表示指定窗口的进度状态特征。
      PROGRESS_VALUE
      表示进度值特征。
      PROGRESS_VALUE_WINDOW
      表示指定窗口的进度值特征。
      USER_ATTENTION
      表示用户注意请求功能。
      USER_ATTENTION_WINDOW
      表示指定窗口的用户注意请求功能。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Taskbar.Feature valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Taskbar.Feature[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ICON_BADGE_TEXT

        public static final Taskbar.Feature ICON_BADGE_TEXT
        表示文字图标徽章功能。
        另请参见：
        Taskbar.setIconBadge(java.lang.String)

      • ICON_BADGE_NUMBER

        public static final Taskbar.Feature ICON_BADGE_NUMBER
        代表一个数字图标标志功能。
        另请参见：
        Taskbar.setIconBadge(java.lang.String)

      • ICON_BADGE_IMAGE_WINDOW

        public static final Taskbar.Feature ICON_BADGE_IMAGE_WINDOW
        表示窗口的图形图标徽标功能。
        另请参见：
        Taskbar.setWindowIconBadge(java.awt.Window, java.awt.Image)

      • ICON_IMAGE

        public static final Taskbar.Feature ICON_IMAGE
        表示图标功能。
        另请参见：
        Taskbar.setIconImage(java.awt.Image)

      • MENU

        public static final Taskbar.Feature MENU
        表示菜单功能。
        另请参见：
        Taskbar.setMenu(java.awt.PopupMenu) ， Taskbar.getMenu()

      • PROGRESS_STATE_WINDOW

        public static final Taskbar.Feature PROGRESS_STATE_WINDOW
        表示指定窗口的进度状态特征。
        另请参见：
        Taskbar.setWindowProgressState(java.awt.Window, State)

      • PROGRESS_VALUE

        public static final Taskbar.Feature PROGRESS_VALUE
        表示进度值特征。
        另请参见：
        Taskbar.setProgressValue(int)

      • PROGRESS_VALUE_WINDOW

        public static final Taskbar.Feature PROGRESS_VALUE_WINDOW
        表示指定窗口的进度值特征。
        另请参见：
        Taskbar.setWindowProgressValue(java.awt.Window, int)

      • USER_ATTENTION

        public static final Taskbar.Feature USER_ATTENTION
        表示用户注意请求功能。
        另请参见：
        Taskbar.requestUserAttention(boolean, boolean)

      • USER_ATTENTION_WINDOW

        public static final Taskbar.Feature USER_ATTENTION_WINDOW
        表示指定窗口的用户注意请求功能。
        另请参见：
        Taskbar.requestWindowUserAttention(java.awt.Window)

    • 方法详细信息

      • values

        public static Taskbar.Feature[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Taskbar.Feature c : Taskbar.Feature.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Taskbar.Feature valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Taskbar.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum Taskbar.State

  • java.lang.Object
    • java.lang.Enum<Taskbar.State>
      • java.awt.Taskbar.State
  • All Implemented Interfaces:
    Serializable ， Comparable<Taskbar.State>
    Enclosing class:
    Taskbar

    public static enum Taskbar.State
extends Enum<Taskbar.State>
    可用窗口进度的种类状态。
    另请参见：
    Taskbar.setWindowProgressState(java.awt.Window, java.awt.Taskbar.State)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ERROR
      显示发生错误。
      INDETERMINATE
      进度指示器显示活动而不指定进度完成的比例。
      NORMAL
      进度指示器以正常颜色和确定模式显示。
      OFF
      停止显示进度。
      PAUSED
      显示进度为暂停，进度可以由用户恢复。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Taskbar.State valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Taskbar.State[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • OFF

        public static final Taskbar.State OFF
        停止显示进度。

      • NORMAL

        public static final Taskbar.State NORMAL
        进度指示器以正常颜色和确定模式显示。

      • PAUSED

        public static final Taskbar.State PAUSED
        显示进度为暂停，进度可以由用户恢复。 切换到确定显示。

      • INDETERMINATE

        public static final Taskbar.State INDETERMINATE
        进度指示器显示活动而不指定进度完成的比例。

      • ERROR

        public static final Taskbar.State ERROR
        显示发生错误。 切换到确定显示。

    • 方法详细信息

      • values

        public static Taskbar.State[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Taskbar.State c : Taskbar.State.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Taskbar.State valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


TextArea (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TextArea

  • java.lang.Object
    • java.awt.Component
      • java.awt.TextComponent
        • java.awt.TextArea
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class TextArea
extends TextComponent
    TextArea对象是显示文本的多行区域。 它可以设置为允许编辑或只读。

    以下图像显示文本区域的外观：

    此文本区域可以通过以下代码行创建：

     new TextArea("Hello", 5, 40);
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  TextArea.AccessibleAWTTextArea
      该类实现 TextArea类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.TextComponent

        TextComponent.AccessibleAWTTextComponent

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int SCROLLBARS_BOTH
      创建并显示垂直和水平滚动条。
      static int SCROLLBARS_HORIZONTAL_ONLY
      仅创建并显示水平滚动条。
      static int SCROLLBARS_NONE
      不要为文本区域创建或显示任何滚动条。
      static int SCROLLBARS_VERTICAL_ONLY
      仅创建并显示垂直滚动条。

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

      • Fields inherited from class java.awt.TextComponent

        textListener

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextArea​()
      构造一个新的文本区域，空字符串作为文本。
      TextArea​(int rows, int columns)
      构造具有指定行数和列数的新文本区域，空字符串作为文本。
      TextArea​(String text)
      构造具有指定文本的新文本区域。
      TextArea​(String text, int rows, int columns)
      构造具有指定文本的新文本区域，并具有指定的行数和列数。
      TextArea​(String text, int rows, int columns, int scrollbars)
      构造具有指定文本的新文本区域，并按照指定的行，列和滚动条可见性构造。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addNotify​()
      创建 TextArea的同伴。
      void append​(String str)
      将给定的文本附加到文本区域的当前文本。
      void appendText​(String str)
      已过时。
      从JDK 1.1版开始，由append(String)替代。
      AccessibleContext getAccessibleContext​()
      返回 AccessibleContext与此相关 TextArea 。
      int getColumns​()
      返回此文本区域中的列数。
      Dimension getMinimumSize​()
      确定此文本区域的最小大小。
      Dimension getMinimumSize​(int rows, int columns)
      确定具有指定行数和列数的文本区域的最小大小。
      Dimension getPreferredSize​()
      确定此文本区域的首选大小。
      Dimension getPreferredSize​(int rows, int columns)
      确定具有指定行数和列数的文本区域的首选大小。
      int getRows​()
      返回文本区域中的行数。
      int getScrollbarVisibility​()
      返回枚举值，指示文本区域使用的滚动条。
      void insert​(String str, int pos)
      在此文本区域的指定位置插入指定的文本。
      void insertText​(String str, int pos)
      已过时。
      从JDK 1.1版开始，由insert(String, int)替代。
      Dimension minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      Dimension minimumSize​(int rows, int columns)
      已过时。
      从JDK 1.1版开始，由getMinimumSize(int, int)替代。
      protected String paramString​()
      返回表示 TextArea的状态的字符串。
      Dimension preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension preferredSize​(int rows, int columns)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int, int)替代。
      void replaceRange​(String str, int start, int end)
      将指定的开始和结束位置之间的文本替换为指定的替换文本。
      void replaceText​(String str, int start, int end)
      已过时。
      从JDK 1.1版开始，由replaceRange(String, int, int)替代。
      void setColumns​(int columns)
      设置此文本区域的列数。
      void setRows​(int rows)
      设置此文本区域的行数。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.TextComponent

        addTextListener, enableInputMethods, getBackground, getCaretPosition, getInputMethodRequests, getListeners, getSelectedText, getSelectionEnd, getSelectionStart, getText, getTextListeners, isEditable, processEvent, processTextEvent, removeNotify, removeTextListener, select, selectAll, setBackground, setCaretPosition, setEditable, setSelectionEnd, setSelectionStart, setText

    • 字段详细信息

      • SCROLLBARS_BOTH

        public static final int SCROLLBARS_BOTH
        创建并显示垂直和水平滚动条。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SCROLLBARS_VERTICAL_ONLY

        public static final int SCROLLBARS_VERTICAL_ONLY
        仅创建并显示垂直滚动条。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SCROLLBARS_HORIZONTAL_ONLY

        public static final int SCROLLBARS_HORIZONTAL_ONLY
        仅创建并显示水平滚动条。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SCROLLBARS_NONE

        public static final int SCROLLBARS_NONE
        不要为文本区域创建或显示任何滚动条。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TextArea

        public TextArea​()
         throws HeadlessException
        构造一个新的文本区域，空字符串作为文本。 此文本区域的创建滚动条可见度等于SCROLLBARS_BOTH ，因此此文本区域的垂直和水平滚动条都将可见。
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • TextArea

        public TextArea​(String text)
         throws HeadlessException
        构造具有指定文本的新文本区域。 此文本区域的创建滚动条可见度等于SCROLLBARS_BOTH ，因此此文本区域的垂直和水平滚动条都将可见。
        参数
        text - 要显示的文字; 如果text为null ，则将显示空字符串""
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • TextArea

        public TextArea​(int rows,
                int columns)
         throws HeadlessException
        构造具有指定行数和列数的新文本区域，空字符串作为文本。 一列是平台相关的近似平均字符宽度。 文本区域的创建方式为滚动条可见度等于SCROLLBARS_BOTH ，因此此文本区域的垂直和水平滚动条都将可见。
        参数
        rows - 行数
        columns - 列数
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • TextArea

        public TextArea​(String text,
                int rows,
                int columns)
         throws HeadlessException
        构造具有指定文本的新文本区域，并具有指定的行数和列数。 一列是平台相关的近似平均字符宽度。 文本区域创建的滚动条可见度等于SCROLLBARS_BOTH ，因此垂直和水平滚动条将在此文本区域可见。
        参数
        text - 要显示的文字; 如果text为null ，将显示空字符串""
        rows - 行数
        columns - 列数
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • TextArea

        public TextArea​(String text,
                int rows,
                int columns,
                int scrollbars)
         throws HeadlessException
        构造具有指定文本的新文本区域，并按照指定的行，列和滚动条可见性构造。 所有TextArea构造函数都TextArea这一个。

        TextArea类定义了可以作为scrollbars参数的值提供的几个常量：

        • SCROLLBARS_BOTH ，
        • SCROLLBARS_VERTICAL_ONLY ，
        • SCROLLBARS_HORIZONTAL_ONLY ，
        • SCROLLBARS_NONE 。
        scrollbars参数的任何其他值无效，并将导致此文本区域创建时，滚动条的可见性等于默认值SCROLLBARS_BOTH 。
        参数
        text - 要显示的文字; 如果text为null ，将显示空字符串""
        rows - 行数; 如果rows小于0 ，则rows设置为0
        columns - 列数; 如果columns小于0 ，则columns设置为0
        scrollbars - 一个常量，用于确定创建哪些滚动条以查看文本区域
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建TextArea的同伴。 对等体允许我们修改TextArea的外观，而不改变它的任何功能。
        重写：
        addNotify在 TextComponent
        另请参见：
        TextComponent.removeNotify()

      • insert

        public void insert​(String str,
                   int pos)
        在此文本区域的指定位置插入指定的文本。

        请注意，通过null或参数不一致将导致未指定的行为。

        参数
        str - 要插入的非 null文本
        pos - 要插入的位置
        从以下版本开始：
        1.1
        另请参见：
        TextComponent.setText(java.lang.String) ，
replaceRange(java.lang.String, int, int) ，
append(java.lang.String)

      • insertText

        @Deprecated
public void insertText​(String str,
                       int pos)
        已过时。 从JDK 1.1版开始，由insert(String, int)替代。
        在此文本区域的指定位置插入指定的文本。
        参数
        str - 要插入的非 null文本
        pos - 要插入的位置

      • append

        public void append​(String str)
        将给定的文本附加到文本区域的当前文本。

        请注意，通过null或参数不一致将导致未指定的行为。

        参数
        str - 要追加的非 null文本
        从以下版本开始：
        1.1
        另请参见：
        insert(java.lang.String, int)

      • appendText

        @Deprecated
public void appendText​(String str)
        已过时。 从JDK 1.1版开始，由append(String)替代。
        将给定的文本附加到文本区域的当前文本。
        参数
        str - 要附加的文本

      • replaceRange

        public void replaceRange​(String str,
                         int start,
                         int end)
        将指定的开始和结束位置之间的文本替换为指定的替换文本。 最终位置的文本将不被替换。 起始位置的文本将被替换（除非起始位置与最终位置相同）。 文本位置为零。 插入的子字符串可能与其替换的文本的长度不同。

        请注意，通过null或参数不一致将导致未指定的行为。

        参数
        str - 非 null文本用作替代
        start - 起始位置
        end - 结束位置
        从以下版本开始：
        1.1
        另请参见：
        insert(java.lang.String, int)

      • replaceText

        @Deprecated
public void replaceText​(String str,
                        int start,
                        int end)
        已过时。 从JDK 1.1版开始，由replaceRange(String, int, int)替代。
        用指定的替换文本替换指定的开始和结束位置之间的字符范围（最终位置的文本将不被替换）。
        参数
        str - 用作替代的非 null文本
        start - 起始位置
        end - 最终位置

      • getRows

        public int getRows​()
        返回文本区域中的行数。
        结果
        文本区域中的行数
        从以下版本开始：
        1.0
        另请参见：
        setRows(int) ， getColumns()

      • setRows

        public void setRows​(int rows)
        设置此文本区域的行数。
        参数
        rows - 行数
        异常
        IllegalArgumentException - 如果为 rows提供的值小于 0
        从以下版本开始：
        1.1
        另请参见：
        getRows() ， setColumns(int)

      • getColumns

        public int getColumns​()
        返回此文本区域中的列数。
        结果
        文本区域中的列数
        另请参见：
        setColumns(int) ， getRows()

      • setColumns

        public void setColumns​(int columns)
        设置此文本区域的列数。
        参数
        columns - 列数
        异常
        IllegalArgumentException - 如果提供给 columns的值小于 0
        从以下版本开始：
        1.1
        另请参见：
        getColumns() ， setRows(int)

      • getScrollbarVisibility

        public int getScrollbarVisibility​()
        返回枚举值，指示文本区域使用的滚动条。

        TextArea类定义了四个整数常量，用于指定哪些滚动条可用。 TextArea具有一个构造函数，可以在滚动条上给出应用程序的权限。

        结果
        一个指示使用哪个滚动条的整数
        从以下版本开始：
        1.1
        另请参见：
        SCROLLBARS_BOTH ， SCROLLBARS_VERTICAL_ONLY ， SCROLLBARS_HORIZONTAL_ONLY ， SCROLLBARS_NONE ， TextArea(java.lang.String, int, int, int)

      • getPreferredSize

        public Dimension getPreferredSize​(int rows,
                                  int columns)
        确定具有指定行数和列数的文本区域的首选大小。
        参数
        rows - 行数
        columns - 列数
        结果
        显示具有指定行数和列数的文本区域所需的首选尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getPreferredSize()

      • preferredSize

        @Deprecated
public Dimension preferredSize​(int rows,
                               int columns)
        已过时。 截至JDK 1.1版，由getPreferredSize(int, int)取代。
        确定具有指定行数和列数的文本区域的首选大小。
        参数
        rows - 行数
        columns - 列数
        结果
        文本区域所需的首选尺寸

      • getPreferredSize

        public Dimension getPreferredSize​()
        确定此文本区域的首选大小。
        重写：
        getPreferredSize在 Component
        结果
        此文本区域所需的首选尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getPreferredSize()

      • preferredSize

        @Deprecated
public Dimension preferredSize​()
        已过时。 从JDK 1.1版开始，由getPreferredSize()替代。
        说明从类别复制Component
        返回组件的首选大小。
        重写：
        preferredSize在 Component
        结果
        该组件的首选尺寸

      • getMinimumSize

        public Dimension getMinimumSize​(int rows,
                                int columns)
        确定具有指定行数和列数的文本区域的最小大小。
        参数
        rows - 行数
        columns - 列数
        结果
        显示具有指定行数和列数的文本区域所需的最小尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getMinimumSize()

      • minimumSize

        @Deprecated
public Dimension minimumSize​(int rows,
                             int columns)
        已过时。 从JDK 1.1版开始，由getMinimumSize(int, int)替代。
        确定具有指定行数和列数的文本区域的最小大小。
        参数
        rows - 行数
        columns - 列数
        结果
        文本区域的最小大小

      • getMinimumSize

        public Dimension getMinimumSize​()
        确定此文本区域的最小大小。
        重写：
        getMinimumSize在 Component
        结果
        此文本区域所需的首选尺寸
        从以下版本开始：
        1.1
        另请参见：
        Component.getPreferredSize()

      • minimumSize

        @Deprecated
public Dimension minimumSize​()
        已过时。 从JDK 1.1版开始，由getMinimumSize()替代。
        描述从类复制： Component
        返回此组件的最小大小。
        重写：
        minimumSize在 Component
        结果
        该组件的最小尺寸

      • paramString

        protected String paramString​()
        返回一个表示TextArea状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 TextComponent
        结果
        此文本区域的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        返回AccessibleContext与此TextArea相关联。 对于文本区， AccessibleContext需要一个形式AccessibleAWTTextArea 。 如有必要，将创建一个新的AccessibleAWTTextArea实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 TextComponent
        结果
        一个 AccessibleAWTTextArea ，作为 AccessibleContext这 TextArea
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextArea.AccessibleAWTTextArea (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TextArea.AccessibleAWTTextArea

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.TextComponent.AccessibleAWTTextComponent
          • java.awt.TextArea.AccessibleAWTTextArea
  • All Implemented Interfaces:
    TextListener ， Serializable ， EventListener ， AccessibleComponent ， AccessibleText
    Enclosing class:
    TextArea

    protected class TextArea.AccessibleAWTTextArea
extends TextComponent.AccessibleAWTTextComponent
    这个类实现TextArea类的可访问性支持。 它提供了适用于文本区域用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from interface javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTTextArea​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态集。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.TextComponent.AccessibleAWTTextComponent

        getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, textValueChanged

    • 构造方法详细信息

      • AccessibleAWTTextArea

        protected AccessibleAWTTextArea​()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态集。
        重写：
        getAccessibleStateSet在 TextComponent.AccessibleAWTTextComponent
        结果
        AccessibleStateSet的一个实例描述对象的状态
        另请参见：
        AccessibleStateSet
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TextComponent

  • java.lang.Object
    • java.awt.Component
      • java.awt.TextComponent
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible
    已知直接子类：
    TextArea ， TextField

    public class TextComponent
extends Component
implements Accessible
    TextComponent类是允许编辑某些文本的任何组件的超类。

    文本组件体现了一串文本。 TextComponent类定义了一组确定此文本是否可编辑的方法。 如果组件是可编辑的，它定义了另一组支持文本插入插入符号的方法。

    此外，该类定义了用于从文本维护当前选择的方法。 文本选择，组件文本的子字符串，是编辑操作的目标。 它也被称为所选文本 。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  TextComponent.AccessibleAWTTextComponent
      该类实现 TextComponent类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected TextListener textListener
      将从此对象接收事件的侦听器列表。

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addNotify​()
      通过将此组件连接到本机屏幕资源来使此组件可以显示。
      void addTextListener​(TextListener l)
      添加指定的文本事件侦听器以从此文本组件接收文本事件。
      void enableInputMethods​(boolean enable)
      启用或禁用此文本组件的输入法支持。
      AccessibleContext getAccessibleContext​()
      获取与此TextComponent关联的AccessibleContext。
      Color getBackground​()
      获取此文本组件的背景颜色。
      int getCaretPosition​()
      返回文本插入插入符的位置。
      InputMethodRequests getInputMethodRequests​()
      获取支持该组件输入法的请求的输入法请求处理程序。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回此 TextComponent当前注册为 FooListener的所有对象的数组。
      String getSelectedText​()
      从由此文本组件呈现的文本中返回所选文本。
      int getSelectionEnd​()
      获取此文本组件中所选文本的最终位置。
      int getSelectionStart​()
      获取此文本组件中所选文本的起始位置。
      String getText​()
      返回此文本组件显示的文本。
      TextListener[] getTextListeners​()
      返回在此文本组件上注册的所有文本侦听器的数组。
      boolean isEditable​()
      指示此文本组件是否可编辑。
      protected String paramString​()
      返回表示 TextComponent状态的字符串。
      protected void processEvent​(AWTEvent e)
      处理此文本组件上的事件。
      protected void processTextEvent​(TextEvent e)
      通过将文本事件发送到任何已注册的 TextListener对象来处理在此文本组件上发生的文本事件。
      void removeNotify​()
      删除 TextComponent的同伴。
      void removeTextListener​(TextListener l)
      删除指定的文本事件侦听器，使其不再从此文本组件接收文本事件。如果 l为 null ，则不会抛出任何异常，也不会执行任何操作。
      void select​(int selectionStart, int selectionEnd)
      选择指定的开始和结束位置之间的文本。
      void selectAll​()
      选择此文本组件中的所有文本。
      void setBackground​(Color c)
      设置此文本组件的背景颜色。
      void setCaretPosition​(int position)
      设置文本插入插入符的位置。
      void setEditable​(boolean b)
      设置确定此文本组件是否可编辑的标志。
      void setSelectionEnd​(int selectionEnd)
      将此文本组件的选择结束设置为指定位置。
      void setSelectionStart​(int selectionStart)
      将此文本组件的选择开始设置为指定位置。
      void setText​(String t)
      将此文本组件呈现的文本设置为指定的文本。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • textListener

        protected transient TextListener textListener
        将从此对象接收事件的侦听器列表。

    • 方法详细信息

      • enableInputMethods

        public void enableInputMethods​(boolean enable)
        启用或禁用此文本组件的输入法支持。 如果启用了输入法支持，并且文本组件也处理关键事件，则传入事件将提供给当前输入方法，并且只有由组件处理或者如果输入方法不使用它们则调度到其侦听器。 默认情况下，启用或禁用此文本组件的输入方法和输入方式是否依赖于实现。
        重写：
        enableInputMethods在 Component
        参数
        enable - true启用，false禁用
        从以下版本开始：
        1.2
        另请参见：
        Component.processKeyEvent(java.awt.event.KeyEvent)

      • getInputMethodRequests

        public InputMethodRequests getInputMethodRequests​()
        描述从类别复制： Component
        获取支持该组件输入法的请求的输入法请求处理程序。 支持现场文本输入的组件必须覆盖此方法以返回InputMethodRequests实例。 同时，它也必须处理输入法事件。
        重写：
        getInputMethodRequests在 Component
        结果
        该组件的输入法请求处理程序默认为 null
        另请参见：
        Component.addInputMethodListener(java.awt.event.InputMethodListener)

      • addNotify

        public void addNotify​()
        通过将此组件连接到本机屏幕资源来使此组件可以显示。 该方法由工具包内部调用，不应由程序直接调用。
        重写：
        addNotify在类 Component
        另请参见：
        removeNotify()

      • removeNotify

        public void removeNotify​()
        删除TextComponent的同行。 对等体允许我们修改TextComponent的外观而不改变它的功能。
        重写：
        removeNotify在 Component
        另请参见：
        Component.isDisplayable() ， Component.addNotify()

      • setText

        public void setText​(String t)
        将此文本组件呈现的文本设置为指定的文本。
        参数
        t - 新文本; 如果此参数为null则文本设置为空字符串“”
        另请参见：
        getText()

      • getText

        public String getText​()
        返回此文本组件显示的文本。 默认情况下，这是一个空字符串。
        结果
        这个价值 TextComponent
        另请参见：
        setText(java.lang.String)

      • getSelectedText

        public String getSelectedText​()
        从由此文本组件呈现的文本中返回所选文本。
        结果
        该文本组件的选定文本
        另请参见：
        select(int, int)

      • isEditable

        public boolean isEditable​()
        指示此文本组件是否可编辑。
        结果
        true如果这个文本组件是可编辑的; false否则。
        从以下版本开始：
        1.0
        另请参见：
        setEditable(boolean)

      • setEditable

        public void setEditable​(boolean b)
        设置确定此文本组件是否可编辑的标志。

        如果标志设置为true ，则该文本组件将成为用户可编辑的。 如果标志设置为false ，则用户无法更改此文本组件的文本。 默认情况下，不可编辑的文本组件具有SystemColor.control的背景颜色。 这个默认值可以通过调用setBackground来重写。

        参数
        b - 指示此文本组件是否可用户可编辑的标志。
        从以下版本开始：
        1.0
        另请参见：
        isEditable()

      • getBackground

        public Color getBackground​()
        获取此文本组件的背景颜色。 默认情况下，不可编辑的文本组件具有SystemColor.control的背景颜色。 这个默认值可以通过调用setBackground来重写。
        重写：
        getBackground在 Component
        结果
        这个文本组件的背景颜色。 如果此文本组件没有背景颜色，则返回其父项的背景颜色。
        从以下版本开始：
        1.0
        另请参见：
        setBackground(Color)

      • setBackground

        public void setBackground​(Color c)
        设置此文本组件的背景颜色。
        重写：
        setBackground在 Component
        参数
        c - 成为此文本组件颜色的颜色。 如果此参数为null，则此文本组件将继承其父级的背景颜色。
        从以下版本开始：
        1.0
        另请参见：
        getBackground()

      • getSelectionStart

        public int getSelectionStart​()
        获取此文本组件中所选文本的起始位置。
        结果
        所选文本的起始位置
        另请参见：
        setSelectionStart(int) ， getSelectionEnd()

      • setSelectionStart

        public void setSelectionStart​(int selectionStart)
        将此文本组件的选择开始设置为指定位置。 新的起点被限制在当前选择结束之前或之前。 它也不能设置为小于零，组件文本的开头。 如果调用者提供超出范围的值为selectionStart的值，该方法将静默地强制执行这些约束，并且不会失败。
        参数
        selectionStart - 所选文本的开始位置
        从以下版本开始：
        1.1
        另请参见：
        getSelectionStart() ， setSelectionEnd(int)

      • getSelectionEnd

        public int getSelectionEnd​()
        获取此文本组件中所选文本的最终位置。
        结果
        所选文本的结束位置
        另请参见：
        setSelectionEnd(int) ， getSelectionStart()

      • setSelectionEnd

        public void setSelectionEnd​(int selectionEnd)
        将此文本组件的选择结束设置为指定位置。 新的终点被限制在当前选择开始之后或之后。 它也不能超出组件文本的结尾。 如果调用者提供超出范围的值为selectionEnd ，则该方法将静默地强制执行这些约束，并且不会失败。
        参数
        selectionEnd - 所选文本的结束位置
        从以下版本开始：
        1.1
        另请参见：
        getSelectionEnd() ， setSelectionStart(int)

      • select

        public void select​(int selectionStart,
                   int selectionEnd)
        选择指定的开始和结束位置之间的文本。

        该方法设置所选文本的开始和结束位置，强制开始位置必须大于或等于零的限制。 结束位置必须大于或等于起始位置，小于或等于文本组件文本的长度。 字符位置从零开始索引。 选择的长度为endPosition - startPosition ，因此未选择endPosition处的字符。 如果所选文本的开始和结束位置相等，则取消选择所有文本。

        如果调用者提供不一致或超出范围的值，则该方法将静默地强制执行这些约束，并且不会失败。 具体来说，如果起始位置或结束位置大于文本的长度，则将其重置为等于文本长度。 如果起始位置小于零，则将其复位为零，如果最终位置小于起始位置，则将其复位到起始位置。

        参数
        selectionStart - 要选择的第一个字符的零 selectionStart引（ char值）
        selectionEnd - 要选择的文本的从零开始的最终位置; 字符（ char在值） selectionEnd未选中
        另请参见：
        setSelectionStart(int) ， setSelectionEnd(int) ， selectAll()

      • selectAll

        public void selectAll​()
        选择此文本组件中的所有文本。
        另请参见：
        select(int, int)

      • setCaretPosition

        public void setCaretPosition​(int position)
        设置文本插入插入符的位置。 插入位置被限制在0和文本的最后一个字符之间（包括）。 如果传入值大于此范围，则该值将设置为最后一个字符（如果TextComponent包含文本， TextComponent 0），并且不返回错误。 如果传入值小于0，则抛出IllegalArgumentException 。
        参数
        position - 文本插入插入符的位置
        异常
        IllegalArgumentException - 如果 position小于零
        从以下版本开始：
        1.1

      • getCaretPosition

        public int getCaretPosition​()
        返回文本插入插入符的位置。 插入位置被限制在0和文本的最后一个字符之间（包括）。 如果文本或插入符号未设置，默认插入位置为0。
        结果
        文本插入插入符的位置
        从以下版本开始：
        1.1
        另请参见：
        setCaretPosition(int)

      • addTextListener

        public void addTextListener​(TextListener l)
        添加指定的文本事件侦听器以从此文本组件接收文本事件。 如果l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 文本事件侦听器
        另请参见：
        removeTextListener(java.awt.event.TextListener) ， getTextListeners() ， TextListener

      • removeTextListener

        public void removeTextListener​(TextListener l)
        删除指定的文本事件侦听器，使其不再从此文本组件接收文本事件。如果l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 文本侦听器
        从以下版本开始：
        1.1
        另请参见：
        addTextListener(java.awt.event.TextListener) ， getTextListeners() ， TextListener

      • getTextListeners

        public TextListener[] getTextListeners​()
        返回在此文本组件上注册的所有文本侦听器的数组。
        结果
        所有这些文本组件的 TextListener s或一个空数组，如果没有文本侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addTextListener(java.awt.event.TextListener) ， removeTextListener(java.awt.event.TextListener)

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回此TextComponent当前注册为FooListener的所有对象的数组。 FooListener s是使用addFooListener方法注册的。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询TextComponent t的文本侦听器：

          TextListener[] tls = (TextListener[])(t.getListeners(TextListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在 Component
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此文本组件上注册为 FooListener的所有对象的数组，如果未添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getTextListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此文本组件上的事件。 如果事件是一个TextEvent ，它将调用processTextEvent方法，否则它调用其超类的processEvent 。

        请注意，如果事件参数为null该行为是未指定的，可能会导致异常。

        重写：
        processEvent在 Component
        参数
        e - 事件
        另请参见：
        Component.processComponentEvent(java.awt.event.ComponentEvent) ，
Component.processFocusEvent(java.awt.event.FocusEvent) ，
Component.processKeyEvent(java.awt.event.KeyEvent) ，
Component.processMouseEvent(java.awt.event.MouseEvent) ，
Component.processMouseMotionEvent(java.awt.event.MouseEvent) ，
Component.processInputMethodEvent(java.awt.event.InputMethodEvent) ，
Component.processHierarchyEvent(java.awt.event.HierarchyEvent) ，
Component.processMouseWheelEvent(java.awt.event.MouseWheelEvent)

      • processTextEvent

        protected void processTextEvent​(TextEvent e)
        通过将文本事件发送到任何已注册的TextListener对象来处理此文本组件上发生的文本事件。

        注意：除非为此组件启用文本事件，否则不会调用此方法。 发生以下情况之一时：

        • A TextListener对象通过addTextListener注册
        • 文本事件通过enableEvents启用

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 文本事件
        另请参见：
        Component.enableEvents(long)

      • paramString

        protected String paramString​()
        返回表示TextComponent状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 Component
        结果
        此文本组件的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此TextComponent关联的AccessibleContext。 对于文本组件，AccessibleContext采用AccessibleAWTTextComponent的形式。 如有必要，将创建一个新的AccessibleAWTTextComponent实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        作为此TextComponent的AccessibleContext的AccessibleAWTTextComponent
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextComponent.AccessibleAWTTextComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TextComponent.AccessibleAWTTextComponent

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.TextComponent.AccessibleAWTTextComponent
  • All Implemented Interfaces:
    TextListener ， Serializable ， EventListener ， AccessibleComponent ， AccessibleText
    已知直接子类：
    TextArea.AccessibleAWTTextArea ， TextField.AccessibleAWTTextField
    Enclosing class:
    TextComponent

    protected class TextComponent.AccessibleAWTTextComponent
extends Component.AccessibleAWTComponent
implements AccessibleText, TextListener
    该类实现TextComponent类的可访问性支持。 它提供了适用于文本组件用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from interface javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Constructor 描述
      AccessibleAWTTextComponent​()
      构造一个AccessibleAWTTextComponent。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获得此对象的作用。
      AccessibleStateSet getAccessibleStateSet​()
      获取TextComponent的状态集。
      AccessibleText getAccessibleText​()
      获取与此对象关联的AccessibleText。
      String getAfterIndex​(int part, int index)
      返回给定索引后的String。
      String getAtIndex​(int part, int index)
      返回给定索引处的String。
      String getBeforeIndex​(int part, int index)
      返回给定索引之前的String。
      int getCaretPosition​()
      返回插入符号的从零开始的偏移量。
      AttributeSet getCharacterAttribute​(int i)
      返回给定字符的AttributeSet（在给定索引处）。
      Rectangle getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      int getCharCount​()
      返回字符数（有效索引）
      int getIndexAtPoint​(Point p)
      给定本地坐标点，返回该点下的字符从零开始的索引。
      String getSelectedText​()
      返回所选文本的部分。
      int getSelectionEnd​()
      返回所选文本中的结束偏移量。
      int getSelectionStart​()
      返回所选文本中的起始偏移量。
      void textValueChanged​(TextEvent textEvent)
      TextListener通知文本值更改。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTTextComponent

        public AccessibleAWTTextComponent​()
        构造一个AccessibleAWTTextComponent。 添加一个监听器来跟踪插入符号的更改。

    • 方法详细信息

      • textValueChanged

        public void textValueChanged​(TextEvent textEvent)
        TextListener通知文本值更改。
        Specified by:
        textValueChanged在接口 TextListener
        参数
        textEvent - 要处理的事件

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取TextComponent的状态集。 对象的AccessibleStateSet由一组唯一的AccessibleState组成。 对象的AccessibleStateSet的更改将导致为AccessibleContext.ACCESSIBLE_STATE_PROPERTY属性触发一个PropertyChangeEvent。
        重写：
        getAccessibleStateSet在 Component.AccessibleAWTComponent
        结果
        包含对象的当前状态集的AccessibleStateSet实例
        另请参见：
        AccessibleStateSet ， AccessibleState ， Component.AccessibleAWTComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获得此对象的作用。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的作用（AccessibleRole.TEXT）
        另请参见：
        AccessibleRole

      • getAccessibleText

        public AccessibleText getAccessibleText​()
        获取与此对象关联的AccessibleText。 在该类的Java Accessibility API的实现中，返回此对象，该对象负责代表自身实现AccessibleText接口。
        重写：
        getAccessibleText在 AccessibleContext
        结果
        这个对象
        另请参见：
        AccessibleText

      • getIndexAtPoint

        public int getIndexAtPoint​(Point p)
        给定本地坐标点，返回该点下的字符从零开始的索引。 如果该点无效，此方法返回-1。
        Specified by:
        getIndexAtPoint在接口 AccessibleText
        参数
        p - 本地坐标点
        结果
        点p处字符的从零开始的索引。

      • getCharacterBounds

        public Rectangle getCharacterBounds​(int i)
        将给定索引处的字符的边框确定为字符串。 边界以局部坐标返回。 如果索引无效，则返回空矩形。
        Specified by:
        getCharacterBounds在接口 AccessibleText
        参数
        i - String> = 0的索引
        结果
        字符边界框的屏幕坐标

      • getCharCount

        public int getCharCount​()
        返回字符数（有效索引）
        Specified by:
        getCharCount在接口 AccessibleText
        结果
        字符数> = 0

      • getCaretPosition

        public int getCaretPosition​()
        返回插入符号的从零开始的偏移量。 注意：插入符号右侧的字符将具有与偏移量相同的索引值（插入符号在两个字符之间）。
        Specified by:
        getCaretPosition在接口 AccessibleText
        结果
        插入符号的零基偏移量。

      • getCharacterAttribute

        public AttributeSet getCharacterAttribute​(int i)
        返回给定字符的AttributeSet（在给定索引处）。
        Specified by:
        getCharacterAttribute在接口 AccessibleText
        参数
        i - 文本中的从零开始的索引
        结果
        字符的AttributeSet

      • getSelectionStart

        public int getSelectionStart​()
        返回所选文本中的起始偏移量。 如果没有选择，但是有一个插入符号，开始和结束偏移将是一样的。 如果文本为空，则返回0，如果没有选择，返回插入位置。
        Specified by:
        getSelectionStart在接口 AccessibleText
        结果
        索引进入文本的开始选择> = 0

      • getSelectionEnd

        public int getSelectionEnd​()
        返回所选文本中的结束偏移量。 如果没有选择，但是有一个插入符号，开始和结束偏移将是一样的。 如果文本为空，则返回0，如果没有选择，返回插入位置。
        Specified by:
        getSelectionEnd在接口 AccessibleText
        结果
        索引到文本结尾的选择> = 0

      • getSelectedText

        public String getSelectedText​()
        返回所选文本的部分。
        Specified by:
        getSelectedText在接口 AccessibleText
        结果
        文本，如果没有选择，则为null

      • getAtIndex

        public String getAtIndex​(int part,
                         int index)
        返回给定索引处的String。
        Specified by:
        getAtIndex在接口 AccessibleText
        参数
        part - 要检索的AccessibleText.CHARACTER，AccessibleText.WORD或AccessibleText.SENTENCE
        index - 文本中的索引> = 0
        结果
        字母，单词或句子，无效的索引或部分为null

      • getAfterIndex

        public String getAfterIndex​(int part,
                            int index)
        返回给定索引后的String。
        Specified by:
        getAfterIndex在接口 AccessibleText
        参数
        part - 要检索的AccessibleText.CHARACTER，AccessibleText.WORD或AccessibleText.SENTENCE
        index - 文本中的索引> = 0
        结果
        字母，单词或句子，无效的索引或部分为null

      • getBeforeIndex

        public String getBeforeIndex​(int part,
                             int index)
        返回给定索引之前的String。
        Specified by:
        getBeforeIndex在接口 AccessibleText
        参数
        part - 要检索的AccessibleText.CHARACTER，AccessibleText.WORD或AccessibleText.SENTENCE
        index - 文本中的索引> = 0
        结果
        字母，单词或句子，无效的索引或部分为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TextField

  • java.lang.Object
    • java.awt.Component
      • java.awt.TextComponent
        • java.awt.TextField
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible

    public class TextField
extends TextComponent
    TextField对象是允许编辑单行文本的文本组件。

    例如，以下图像描绘了具有不同宽度的四个文本字段的帧。 其中两个文本字段显示预定义文本"Hello" 。

    以下是产生这四个文本字段的代码：

     TextField tf1, tf2, tf3, tf4;
 // a blank text field
 tf1 = new TextField();
 // blank field of 20 columns
 tf2 = new TextField("", 20);
 // predefined text displayed
 tf3 = new TextField("Hello!");
 // predefined text in 30 columns
 tf4 = new TextField("Hello", 30);

    每当用户在文本字段中键入一个键时，一个或多个键事件将发送到文本字段。 A KeyEvent可以是以下三种类型之一：keyPressed，keyReleased或keyTyped。 密钥事件的属性指示它们中的哪一种，以及关于事件的附加信息，例如什么修饰符应用于密钥事件和事件发生的时间。

    密钥事件传递给每个KeyListener或KeyAdapter对象，该对象使用组件的addKeyListener方法注册接收此类事件。 （ KeyAdapter对象实现KeyListener接口。）

    也可以点火ActionEvent 。 如果为文本字段启用了操作事件，则可能会按Return键触发。

    TextField类的processEvent方法检查动作事件，并将其传递给processActionEvent 。 后一种方法将事件重定向到已注册接收此文本字段生成的操作事件的任何ActionListener对象。

    从以下版本开始：
    1.0
    另请参见：
    KeyEvent ， KeyAdapter ， KeyListener ， ActionEvent ， Component.addKeyListener(java.awt.event.KeyListener) ， processEvent(java.awt.AWTEvent) ， processActionEvent(java.awt.event.ActionEvent) ， addActionListener(java.awt.event.ActionListener) ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  TextField.AccessibleAWTTextField
      这个类实现 TextField类的可访问性支持。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.TextComponent

        TextComponent.AccessibleAWTTextComponent

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

      • Fields inherited from class java.awt.TextComponent

        textListener

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextField​()
      构造一个新的文本字段。
      TextField​(int columns)
      构造具有指定列数的新的空文本字段。
      TextField​(String text)
      构造一个使用指定文本初始化的新文本字段。
      TextField​(String text, int columns)
      构造一个新的文本字段，并使用指定的文本进行初始化，以便显示，并且足够宽以容纳指定的列数。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addActionListener​(ActionListener l)
      添加指定的动作侦听器以从此文本字段接收动作事件。
      void addNotify​()
      创建TextField的对等体。
      boolean echoCharIsSet​()
      指示此文本字段是否具有用于回显的字符集。
      AccessibleContext getAccessibleContext​()
      获取与此TextField关联的AccessibleContext。
      ActionListener[] getActionListeners​()
      返回在此文本域中注册的所有操作侦听器的数组。
      int getColumns​()
      获取此文本字段中的列数。
      char getEchoChar​()
      获取要用于回显的字符。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回当前注册的所有对象的数组 FooListener在这个S TextField 。
      Dimension getMinimumSize​()
      获取此文本字段的最小尺寸。
      Dimension getMinimumSize​(int columns)
      获取具有指定列数的文本字段的最小尺寸。
      Dimension getPreferredSize​()
      获取此文本字段的首选大小。
      Dimension getPreferredSize​(int columns)
      使用指定的列数获取此文本字段的首选大小。
      Dimension minimumSize​()
      已过时。
      从JDK 1.1版开始，替换为getMinimumSize() 。
      Dimension minimumSize​(int columns)
      已过时。
      从JDK 1.1版开始，由getMinimumSize(int)替代。
      protected String paramString​()
      返回一个表示 TextField状态的字符串。
      Dimension preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension preferredSize​(int columns)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int)替代。
      protected void processActionEvent​(ActionEvent e)
      通过将其发送到任何已注册的 ActionListener对象来处理在此文本字段上发生的操作事件。
      protected void processEvent​(AWTEvent e)
      处理此文本字段上的事件。
      void removeActionListener​(ActionListener l)
      删除指定的动作侦听器，使其不再从此文本字段接收到动作事件。
      void setColumns​(int columns)
      设置此文本字段中的列数。
      void setEchoChar​(char c)
      设置此文本字段的回音字符。
      void setEchoCharacter​(char c)
      已过时。
      从JDK 1.1版开始，由setEchoChar(char)替代。
      void setText​(String t)
      将此文本组件呈现的文本设置为指定的文本。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.TextComponent

        addTextListener, enableInputMethods, getBackground, getCaretPosition, getInputMethodRequests, getSelectedText, getSelectionEnd, getSelectionStart, getText, getTextListeners, isEditable, processTextEvent, removeNotify, removeTextListener, select, selectAll, setBackground, setCaretPosition, setEditable, setSelectionEnd, setSelectionStart

    • 构造方法详细信息

      • TextField

        public TextField​()
          throws HeadlessException
        构造一个新的文本字段。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • TextField

        public TextField​(String text)
          throws HeadlessException
        构造一个使用指定文本初始化的新文本字段。
        参数
        text - 要显示的文字。 如果text为null ，将显示空字符串"" 。 如果text包含EOL和/或LF字符，则每个都将被空格字符替换。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • TextField

        public TextField​(int columns)
          throws HeadlessException
        构造具有指定列数的新的空文本字段。 一列是平台相关的近似平均字符宽度。
        参数
        columns - 列数。 如果columns小于0 ，则columns设置为0 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • TextField

        public TextField​(String text,
                 int columns)
          throws HeadlessException
        构造一个新的文本字段，并使用指定的文本进行初始化，以便显示，并且足够宽以容纳指定的列数。 一列是平台相关的近似平均字符宽度。
        参数
        text - 要显示的文字。 如果text为null ，则将显示空字符串"" 。 如果text包含EOL和/或LF字符，则每个都将被空格字符替换。
        columns - 列数。 如果columns小于0 ，则columns设为0 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • addNotify

        public void addNotify​()
        创建TextField的对等体。 对等体允许我们修改TextField的外观而不改变它的功能。
        重写：
        addNotify在 TextComponent
        另请参见：
        TextComponent.removeNotify()

      • getEchoChar

        public char getEchoChar​()
        获取要用于回显的字符。

        回声字符对于用户输入不应该回显到屏幕的文本字段很有用，如在输入密码的文本字段的情况下。 如果echoChar = 0 ，用户输入回显到屏幕不变。

        Java平台实现可能只支持有限的非空的echo字符集。 此函数返回最初通过setEchoChar（）请求的回显字符。 TextField实现中实际使用的回音字符可能不同。

        结果
        此文本字段的回音字符。
        另请参见：
        echoCharIsSet() ， setEchoChar(char)

      • setEchoChar

        public void setEchoChar​(char c)
        设置此文本字段的回音字符。

        回声字符对于用户输入不应该回显到屏幕的文本字段很有用，如在输入密码的文本字段的情况下。 设置echoChar = 0允许用户输入再次回到屏幕。

        Java平台实现可能只支持有限的非空的echo字符集。 尝试设置不支持的回音字符将导致使用默认回音字符。 对getEchoChar（）的后续调用将返回最初请求的回显字符。 这可能或可能不同于TextField实现中实际使用的回音字符。

        参数
        c - 此文本字段的回音字符。
        从以下版本开始：
        1.1
        另请参见：
        echoCharIsSet() ， getEchoChar()

      • setEchoCharacter

        @Deprecated
public void setEchoCharacter​(char c)
        已过时。 从JDK 1.1版开始，由setEchoChar(char)取代。
        设置受保护输入显示时要回显的字符。
        参数
        c - 此文本字段的回音字符

      • setText

        public void setText​(String t)
        将此文本组件呈现的文本设置为指定的文本。
        重写：
        setText在 TextComponent
        参数
        t - 新文本。 如果t为null ，将显示空字符串"" 。 如果t包含EOL和/或LF字符，则每个都将被空格字符替换。
        另请参见：
        TextComponent.getText()

      • echoCharIsSet

        public boolean echoCharIsSet​()
        指示此文本字段是否具有用于回显的字符集。

        回声字符对于用户输入不应该回显到屏幕的文本字段很有用，如在输入密码的文本字段的情况下。

        结果
        true如果此文本字段具有用于回显的字符集; 否则为false 。
        另请参见：
        setEchoChar(char) ， getEchoChar()

      • getColumns

        public int getColumns​()
        获取此文本字段中的列数。 一列是平台相关的近似平均字符宽度。
        结果
        列数。
        从以下版本开始：
        1.1
        另请参见：
        setColumns(int)

      • setColumns

        public void setColumns​(int columns)
        设置此文本字段中的列数。 一列是平台相关的近似平均字符宽度。
        参数
        columns - 列数。
        异常
        IllegalArgumentException - 如果为 columns提供的值小于 0 。
        从以下版本开始：
        1.1
        另请参见：
        getColumns()

      • getPreferredSize

        public Dimension getPreferredSize​(int columns)
        使用指定的列数获取此文本字段的首选大小。
        参数
        columns - 此文本字段中的列数。
        结果
        用于显示此文本字段的首选尺寸。
        从以下版本开始：
        1.1

      • preferredSize

        @Deprecated
public Dimension preferredSize​(int columns)
        已过时。 从JDK 1.1版开始，由getPreferredSize(int)替代。
        返回具有指定列数的此文本字段的首选大小。
        参数
        columns - 列数
        结果
        文本字段的首选大小

      • getPreferredSize

        public Dimension getPreferredSize​()
        获取此文本字段的首选大小。
        重写：
        getPreferredSize在 Component
        结果
        用于显示此文本字段的首选尺寸。
        从以下版本开始：
        1.1
        另请参见：
        Component.getMinimumSize() ， LayoutManager

      • preferredSize

        @Deprecated
public Dimension preferredSize​()
        已过时。 从JDK 1.1版开始，由getPreferredSize()取代。
        描述从类别复制： Component
        返回组件的首选大小。
        重写：
        preferredSize在 Component
        结果
        该组件的首选尺寸

      • getMinimumSize

        public Dimension getMinimumSize​(int columns)
        获取具有指定列数的文本字段的最小尺寸。
        参数
        columns - 此文本字段中的列数。
        结果
        此文本字段的最小大小
        从以下版本开始：
        1.1

      • minimumSize

        @Deprecated
public Dimension minimumSize​(int columns)
        已过时。 从JDK 1.1版开始，由getMinimumSize(int)替代。
        返回具有指定列数的文本字段的最小尺寸。
        参数
        columns - 列数
        结果
        此文本字段的最小大小

      • getMinimumSize

        public Dimension getMinimumSize​()
        获取此文本字段的最小尺寸。
        重写：
        getMinimumSize在 Component
        结果
        显示此文本字段的最小尺寸。
        从以下版本开始：
        1.1
        另请参见：
        Component.getPreferredSize() ， LayoutManager

      • minimumSize

        @Deprecated
public Dimension minimumSize​()
        已过时。 从JDK 1.1版开始，由getMinimumSize()替代。
        描述从类复制： Component
        返回此组件的最小大小。
        重写：
        minimumSize在 Component
        结果
        该组件的最小尺寸

      • addActionListener

        public void addActionListener​(ActionListener l)
        添加指定的动作侦听器以从此文本字段接收动作事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器。
        从以下版本开始：
        1.1
        另请参见：
        removeActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionListener

      • removeActionListener

        public void removeActionListener​(ActionListener l)
        删除指定的动作侦听器，使其不再从此文本字段接收到动作事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 动作侦听器。
        从以下版本开始：
        1.1
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionListener

      • getActionListeners

        public ActionListener[] getActionListeners​()
        返回在此文本域中注册的所有操作侦听器的数组。
        结果
        所有这个textfield的 ActionListener s或一个空数组，如果没有动作侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addActionListener(java.awt.event.ActionListener) ， removeActionListener(java.awt.event.ActionListener) ， ActionListener

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册为FooListener的所有对象的数组，此TextField 。 FooListener使用addFooListener方法注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询TextField t的动作侦听器：

          ActionListener[] als = (ActionListener[])(t.getListeners(ActionListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在 TextComponent
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此文本字段上注册为 FooListener的所有对象的数组，如果未添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType未指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.3
        另请参见：
        getActionListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        处理此文本字段上的事件。 如果事件是ActionEvent一个实例，它将调用processActionEvent方法。 否则，它将在超类上调用processEvent 。

        请注意，如果事件参数为null该行为是未指定的，可能会导致异常。

        重写：
        processEvent在 TextComponent
        参数
        e - 事件
        从以下版本开始：
        1.1
        另请参见：
        ActionEvent ， processActionEvent(java.awt.event.ActionEvent)

      • processActionEvent

        protected void processActionEvent​(ActionEvent e)
        通过将它们发送到任何已注册的ActionListener对象来处理在此文本字段上发生的操作事件。

        除非为此组件启用了操作事件，否则不会调用此方法。 当发生以下情况之一时，启用操作事件：

        • 通过addActionListener注册一个ActionListener对象。
        • 操作事件通过enableEvents启用。

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        参数
        e - 动作事件
        从以下版本开始：
        1.1
        另请参见：
        ActionListener ， addActionListener(java.awt.event.ActionListener) ， Component.enableEvents(long)

      • paramString

        protected String paramString​()
        返回表示TextField状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 TextComponent
        结果
        此文本字段的参数字符串

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此TextField关联的AccessibleContext。 对于文本字段，AccessibleContext采用AccessibleAWTTextField的形式。 如有必要，将创建一个新的AccessibleAWTTextField实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 TextComponent
        结果
        一个AccessibleAWTTextField，用作此TextField的AccessibleContext
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextField.AccessibleAWTTextField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TextField.AccessibleAWTTextField

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.TextComponent.AccessibleAWTTextComponent
          • java.awt.TextField.AccessibleAWTTextField
  • All Implemented Interfaces:
    TextListener ， Serializable ， EventListener ， AccessibleComponent ， AccessibleText
    Enclosing class:
    TextField

    protected class TextField.AccessibleAWTTextField
extends TextComponent.AccessibleAWTTextComponent
    这个类实现TextField类的可访问性支持。 它提供了适用于文本字段用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from interface javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTTextField​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态集。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.TextComponent.AccessibleAWTTextComponent

        getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, textValueChanged

    • 构造方法详细信息

      • AccessibleAWTTextField

        protected AccessibleAWTTextField​()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态集。
        重写：
        getAccessibleStateSet在 TextComponent.AccessibleAWTTextComponent
        结果
        AccessibleStateSet的一个实例描述对象的状态
        另请参见：
        AccessibleState
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TexturePaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TexturePaint

  • java.lang.Object
    • java.awt.TexturePaint
  • All Implemented Interfaces:
    Paint ， Transparency

    public class TexturePaint
extends Object
implements Paint
    TexturePaint类提供了一种填充一个Shape的方法 ，该纹理指定为BufferedImage 。 BufferedImage对象的大小应该很小，因为BufferedImage数据被TexturePaint对象复制。 在施工时，纹理锚定在用户空间中指定的Rectangle2D的左上角。 通过概念地在用户空间中向所有方向复制指定的Rectangle2D并将BufferedImage映射到每个复制的Rectangle2D计算设备空间中的位置的纹理。
    Version:
    1.48，06/05/07
    另请参见：
    Paint ， Graphics2D.setPaint(java.awt.Paint)

    • Field Summary

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      TexturePaint​(BufferedImage txtr, Rectangle2D anchor)
      构造一个 TexturePaint对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PaintContext createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成平铺图像模式的PaintContext 。
      Rectangle2D getAnchorRect​()
      返回锚定矩形的副本，该矩形位置和尺寸纹理图像。
      BufferedImage getImage​()
      返回用于填充形状的 BufferedImage纹理。
      int getTransparency​()
      返回此 TexturePaint的透明度模式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TexturePaint

        public TexturePaint​(BufferedImage txtr,
                    Rectangle2D anchor)
        构造一个 TexturePaint对象。
        参数
        txtr - 用于绘画的纹理的 BufferedImage对象
        anchor - 用户空间中的 Rectangle2D用于锚定和复制纹理

    • 方法详细信息

      • getImage

        public BufferedImage getImage​()
        返回用于填充形状的 BufferedImage纹理。
        结果
        一个 BufferedImage 。

      • getAnchorRect

        public Rectangle2D getAnchorRect​()
        返回锚定矩形的副本，该矩形位置和尺寸纹理图像。
        结果
        该 Rectangle2D用于锚定和大小这 TexturePaint 。

      • createContext

        public PaintContext createContext​(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform xform,
                                  RenderingHints hints)
        创建并返回一个用于生成平铺图像模式的PaintContext 。 见specification方法在Paint界面上的空参数处理信息。
        Specified by:
        createContext在接口 Paint
        参数
        cm - 首选的ColorModel ，表示呼叫方接收像素数据的最方便格式，如果没有偏好，则表示null 。
        deviceBounds - 正在呈现的图形基元的设备空间边界框。
        userBounds - 呈现的图形基元的用户空间边界框。
        xform - 从用户空间到设备空间的AffineTransform 。
        hints - 上下文对象可用于在呈现替代方案之间进行选择的一组提示。
        结果
        用于生成颜色图案的 PaintContext 。
        另请参见：
        Paint ， PaintContext ， ColorModel ， Rectangle ， Rectangle2D ， AffineTransform ， RenderingHints

      • getTransparency

        public int getTransparency​()
        返回此 TexturePaint的透明度模式。
        Specified by:
        getTransparency在接口 Transparency
        结果
        这个透明度模式为这个 TexturePaint作为一个整数值。
        另请参见：
        Transparency
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Toolkit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Toolkit

  • java.lang.Object
    • java.awt.Toolkit

  • public abstract class Toolkit
extends Object
    这个类是抽象窗口工具包的所有实际实现的抽象超类。 Toolkit类的子类用于将各种组件绑定到特定的本地工具包实现。

    如果没有明确指定相反的情况，许多GUI事件可能异步传递给用户。 以及许多GUI操作可以异步执行。 这个事实意味着如果组件的状态被设置，然后立即查询状态，则返回的值可能还未反映所请求的更改。 此行为包括但不限于：

    • 滚动到指定的位置。
      例如，如果原始请求尚未被处理，则呼叫ScrollPane.setScrollPosition然后getScrollPosition可能会返回错误的值。
    • 将焦点从一个组件移动到另一个组件。
      欲了解更多信息，请参阅Timing Focus Transfers ，在一节The Swing Tutorial 。
    • 使顶级容器可见。
      调用setVisible(true)上Window ， Frame或者Dialog可能异步发生。
    • 设置顶级容器的大小或位置。
      调用setSize ， setBounds或setLocation上的Window ， Frame或Dialog被转发到底层窗口管理系统，并且可以被忽略或修改。 详见Window 。

    大多数应用程序不应该直接调用此类中的任何方法。 Toolkit定义的方法是将java.awt包中与平台无关的类与其对应的java.awt.peer连接的“胶”。 Toolkit定义的一些方法直接查询本地操作系统。

    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Map<String,Object> desktopProperties
      桌面属性。
      protected PropertyChangeSupport desktopPropsSupport
      桌面属性更改支持。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Toolkit​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addAWTEventListener​(AWTEventListener listener, long eventMask)
      添加一个AWTEventListener来接收系统范围内符合给定的 eventMask所有AWTEvent。
      void addPropertyChangeListener​(String name, PropertyChangeListener pcl)
      为指定的桌面属性添加指定的属性更改侦听器。
      boolean areExtraMouseButtonsEnabled​()
      报告是否允许来自额外鼠标按钮的事件被处理并发布到 EventQueue 。
      abstract void beep​()
      根据本地系统设置和硬件功能发出音频蜂鸣声。
      abstract int checkImage​(Image image, int width, int height, ImageObserver observer)
      表示准备显示的指定图像的构造状态。
      Cursor createCustomCursor​(Image cursor, Point hotSpot, String name)
      创建一个新的自定义光标对象。
      <T extends DragGestureRecognizer>
      T             		createDragGestureRecognizer​(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
      创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。
      Image createImage​(byte[] imagedata)
      创建解码存储在指定字节数组中的图像的图像。
      abstract Image createImage​(byte[] imagedata, int imageoffset, int imagelength)
      创建一个图像，解码存储在指定字节数组中的图像，并以指定的偏移量和长度。
      abstract Image createImage​(ImageProducer producer)
      使用指定的图像生成器创建图像。
      abstract Image createImage​(String filename)
      返回从指定文件获取像素数据的图像。
      abstract Image createImage​(URL url)
      返回从指定的URL获取像素数据的图像。
      AWTEventListener[] getAWTEventListeners​()
      返回在该工具包上注册的所有 AWTEventListener的数组。
      AWTEventListener[] getAWTEventListeners​(long eventMask)
      返回在该工具包上注册的所有 AWTEventListener s的数组，该数组监听 eventMask参数中指定的所有事件类型。
      Dimension getBestCursorSize​(int preferredWidth, int preferredHeight)
      返回最接近所需大小的支持的光标维度。
      abstract ColorModel getColorModel​()
      确定该工具包屏幕的颜色模型。
      static Toolkit getDefaultToolkit​()
      获取默认工具包。
      Object getDesktopProperty​(String propertyName)
      获取指定的桌面属性的值。
      abstract String[] getFontList​()
      已过时。
      见GraphicsEnvironment.getAvailableFontFamilyNames()
      abstract FontMetrics getFontMetrics​(Font font)
      已过时。
      从JDK 1.2版开始，由Font方法getLineMetrics 。
      abstract Image getImage​(String filename)
      返回从指定文件获取像素数据的图像，其格式可以是GIF，JPEG或PNG。
      abstract Image getImage​(URL url)
      返回从指定的URL获取像素数据的图像。
      boolean getLockingKeyState​(int keyCode)
      返回键盘上给定的锁定键是否处于“开启”状态。
      int getMaximumCursorColors​()
      返回Toolkit在自定义光标调色板中支持的最大颜色数。
      int getMenuShortcutKeyMask​()
      确定哪个修饰键是菜单快捷键的适当加速键。
      protected static Container getNativeContainer​(Component c)
      给本地对等体提供给本地组件查询本机容器的能力（例如，直接父级可能是轻量级的）。
      PrintJob getPrintJob​(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
      获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
      abstract PrintJob getPrintJob​(Frame frame, String jobtitle, Properties props)
      获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
      static String getProperty​(String key, String defaultValue)
      获取具有指定键和默认值的属性。
      PropertyChangeListener[] getPropertyChangeListeners​()
      返回在此工具包上注册的所有属性更改侦听器的数组。
      PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
      返回与指定的桌面属性名称相关联的所有属性更改侦听器的数组。
      Insets getScreenInsets​(GraphicsConfiguration gc)
      获取屏幕的插图。
      abstract int getScreenResolution​()
      以英寸为单位返回屏幕分辨率。
      abstract Dimension getScreenSize​()
      获取屏幕的大小。
      abstract Clipboard getSystemClipboard​()
      获取与本地平台提供的剪贴板工具接口的系统剪贴板的单例实例。
      EventQueue getSystemEventQueue​()
      获取应用程序或小程序的EventQueue实例。
      protected abstract EventQueue getSystemEventQueueImpl​()
      获取应用程序或小程序的 EventQueue实例，而无需检查访问。
      Clipboard getSystemSelection​()
      获取系统选择的单例实例为 Clipboard对象。
      protected void initializeDesktopProperties​()
      initializeDesktopProperties
      boolean isAlwaysOnTopSupported​()
      返回此工具包是否支持始终在线模式。
      boolean isDynamicLayoutActive​()
      返回是否在底层操作系统和/或窗口管理器上启用了容器在resize上的动态布局。
      protected boolean isDynamicLayoutSet​()
      返回容器的布局在调整大小期间是否动态进行验证，或者在调整大小之后静态地验证。
      boolean isFrameStateSupported​(int state)
      返回Toolkit是否支持 Frame的状态。
      abstract boolean isModalExclusionTypeSupported​(Dialog.ModalExclusionType modalExclusionType)
      返回此工具包是否支持给定的模式排除类型。
      abstract boolean isModalityTypeSupported​(Dialog.ModalityType modalityType)
      返回此工具包是否支持给定的模态类型。
      protected Object lazilyLoadDesktopProperty​(String name)
      懒惰评估桌面属性值的机会。
      protected void loadSystemColors​(int[] systemColors)
      填充以当前系统颜色值作为参数提供的整数数组。
      abstract Map<TextAttribute,?> mapInputMethodHighlight​(InputMethodHighlight highlight)
      返回给定输入法突出显示的抽象级别描述的可视属性映射，如果没有找到映射，则返回null。
      abstract boolean prepareImage​(Image image, int width, int height, ImageObserver observer)
      准备渲染图像。
      void removeAWTEventListener​(AWTEventListener listener)
      从接收发送的AWTEvent中删除AWTEventListener。
      void removePropertyChangeListener​(String name, PropertyChangeListener pcl)
      为指定的桌面属性移除指定的属性更改侦听器。
      protected void setDesktopProperty​(String name, Object newValue)
      将指定的桌面属性设置为指定的值，并触发属性更改事件以通知任何侦听器该值已更改。
      void setDynamicLayout​(boolean dynamic)
      控制容器的布局在调整大小期间是否动态地进行验证，或者在调整大小之后静态地进行。
      void setLockingKeyState​(int keyCode, boolean on)
      设置键盘上给定锁定键的状态。
      abstract void sync​()
      同步该工具包的图形状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • desktopProperties

        protected final Map<String,Object> desktopProperties
        桌面属性。

      • desktopPropsSupport

        protected final PropertyChangeSupport desktopPropsSupport
        桌面属性更改支持。

    • 构造方法详细信息

      • Toolkit

        public Toolkit​()

    • 方法详细信息

      • loadSystemColors

        protected void loadSystemColors​(int[] systemColors)
                         throws HeadlessException
        填充以当前系统颜色值作为参数提供的整数数组。
        参数
        systemColors - 整数数组。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless()

      • setDynamicLayout

        public void setDynamicLayout​(boolean dynamic)
                      throws HeadlessException
        控制容器的布局在调整大小期间是否动态地进行验证，或者在调整大小之后静态地进行。 使用isDynamicLayoutActive()来检测此程序是否启用此功能，并由此操作系统和/或窗口管理器支持。 请注意，此功能不支持在所有平台上，相反，在某些平台上无法关闭此功能。 在这些平台上，不支持（或始终支持）调整大小时的动态布局，设置此属性不起作用。 请注意，在某些平台上，该功能可以作为操作系统或窗口管理器的属性进行设置或取消设置。 在这样的平台上，必须在操作系统或窗口管理器级别设置动态resize属性，才能使此方法生效。 此方法不会更改底层操作系统或窗口管理器的支持或设置。 可以使用getDesktopProperty（“awt.dynamicLayoutSupported”）方法查询OS / WM支持。
        参数
        dynamic - 如果为true，则容器应在容器调整大小时重新布局其组件。 如果为false，布局将在调整大小完成后验证。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.4
        另请参见：
        isDynamicLayoutSet() ， isDynamicLayoutActive() ， getDesktopProperty(String propertyName) ， GraphicsEnvironment.isHeadless()

      • isDynamicLayoutSet

        protected boolean isDynamicLayoutSet​()
                              throws HeadlessException
        返回容器的布局在调整大小期间是否动态进行验证，或者在调整大小之后静态地验证。 注意：此方法返回以编程方式设置的值; 它不反映在操作系统或窗口管理器级别对调整大小的动态布局或当前操作系统或窗口管理器设置的支持。 可以使用getDesktopProperty（“awt.dynamicLayoutSupported”）查询OS / WM支持。
        结果
        如果对容器进行动态验证，则为true，如果在调整大小完成后进行验证，则为false。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.4
        另请参见：
        setDynamicLayout(boolean dynamic) ， isDynamicLayoutActive() ， getDesktopProperty(String propertyName) ， GraphicsEnvironment.isHeadless()

      • isDynamicLayoutActive

        public boolean isDynamicLayoutActive​()
                              throws HeadlessException
        返回是否在底层操作系统和/或窗口管理器上启用了容器在resize上的动态布局。 如果平台支持， setDynamicLayout(boolean)可能用于以编程方式启用或禁用平台动态布局。 无论是否支持该切换，或者是否将true或false指定为参数，或者根本没有被调用，则此方法将返回活动的当前平台行为，JDK将在调整大小时确定布局策略。

        如果动态布局当前处于非活动状态，则容器在调整大小时将重新布局其组件。 因此， Component.validate()方法将仅调用一次调整大小。 如果动态布局当前处于活动状态，则Containers会在每个本机resize事件上重新布局其组件，并且每次都将调用validate()方法。 可以使用getDesktopProperty（“awt.dynamicLayoutSupported”）方法查询OS / WM支持。 该属性将反映平台的能力，但不足以说明当前是否启用。

        结果
        如果Resize上的Containers的动态布局当前处于活动状态，则为true，否则为false。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）方法返回true
        从以下版本开始：
        1.4
        另请参见：
        setDynamicLayout(boolean dynamic) ， isDynamicLayoutSet() ， getDesktopProperty(String propertyName) ， GraphicsEnvironment.isHeadless()

      • getScreenSize

        public abstract Dimension getScreenSize​()
                                 throws HeadlessException
        获取屏幕的大小。 在具有多个显示器的系统上，使用主显示器。 多屏幕显示尺寸可从GraphicsConfiguration和GraphicsDevice 。
        结果
        该工具包屏幕的大小（以像素为单位）。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsConfiguration.getBounds() ，
GraphicsDevice.getDisplayMode() ，
GraphicsEnvironment.isHeadless()

      • getScreenResolution

        public abstract int getScreenResolution​()
                                 throws HeadlessException
        以英寸为单位返回屏幕分辨率。
        结果
        该工具包的屏幕分辨率，以英寸为单位。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getScreenInsets

        public Insets getScreenInsets​(GraphicsConfiguration gc)
                       throws HeadlessException
        获取屏幕的插图。
        参数
        gc - a GraphicsConfiguration
        结果
        这个工具包屏幕的插图，以像素为单位。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getColorModel

        public abstract ColorModel getColorModel​()
                                  throws HeadlessException
        确定该工具包屏幕的颜色模型。

        ColorModel是一个抽象类，封装了在图像的像素值与其红色，绿色，蓝色和alpha分量之间进行转换的能力。

        该工具包方法由Component类的getColorModel方法Component 。

        结果
        该工具包屏幕的颜色模型。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless() ， ColorModel ， Component.getColorModel()

      • getFontList

        @Deprecated
public abstract String[] getFontList​()
        已过时。 见GraphicsEnvironment.getAvailableFontFamilyNames()
        返回此工具包中可用字体的名称。

        对于1.1，不推荐使用以下字体名称（替换名称如下）：

        • TimesRoman（使用Serif）
        • Helvetica（使用SansSerif）
        • 快递（使用Monospaced）

        ZapfDingbats fontname在1.1中也被弃用，但字符以Unicode开头，以0x2700为单位，从1.1开始，Java支持这些字符。

        结果
        该工具包中可用字体的名称。
        另请参见：
        GraphicsEnvironment.getAvailableFontFamilyNames()

      • getFontMetrics

        @Deprecated
public abstract FontMetrics getFontMetrics​(Font font)
        已过时。 从JDK 1.2版开始，代之以Font方法getLineMetrics 。
        获取用于呈现字体的屏幕设备度量。
        参数
        font - 一个字体
        结果
        该工具包中指定字体的屏幕指标
        另请参见：
        LineMetrics ， Font.getLineMetrics(java.lang.String, java.awt.font.FontRenderContext) ， GraphicsEnvironment.getScreenDevices()

      • sync

        public abstract void sync​()
        同步该工具包的图形状态。 一些窗口系统可能会执行图形事件的缓冲。

        此方法可确保显示器是最新的。 它对动画有用。

      • getDefaultToolkit

        public static Toolkit getDefaultToolkit​()
        获取默认工具包。

        如果命名的系统属性"java.awt.headless"设置为true那么无头执行Toolkit ，否则用默认的具体平台实现Toolkit使用。

        如果该工具包不是无头的实现，并且如果存在，则由系统属性javax.accessibility.assistive_technologies指定的AccessibilityProvider的服务提供商将被加载。

        设置此属性的一个示例是使用-Djavax.accessibility.assistive_technologies=MyServiceProvider调用Java。 除了MyServiceProvider之外，可以使用逗号分隔列表指定其他服务提供者。 AWT工具包创建后，服务提供商将被加载。 所有错误都通过AWTError异常处理。

        Assistive_technologies属性中指定的名称用于查询每个服务提供商的实现。 如果请求的名称相匹配的name服务提供商，该AccessibilityProvider.activate()方法将被调用，以激活匹配的服务提供商。

        实现要求：
        如果辅助技术服务提供商未指定系统属性，则此实现将查找属性文件，位置如下：
        • ${user.home}/.accessibility.properties
        • ${java.home}/conf/accessibility.properties
        将仅查询将要查找的第一个这些文件。 通过设置assistive_technologies=属性指定所请求的服务提供商。 可以指定单个提供者或逗号分隔的提供者列表。
        结果
        默认工具包。
        异常
        AWTError - 如果找不到工具包，或者无法访问或实例化。
        另请参见：
        ServiceLoader ， AccessibilityProvider

      • getImage

        public abstract Image getImage​(String filename)
        返回从指定文件获取像素数据的图像，其格式可以是GIF，JPEG或PNG。 底层工具包尝试将具有相同文件名的多个请求解析为相同的返回图像。

        由于促进Image对象共享所需的机制可能会继续持续到不再使用无限期的图像，因此鼓励开发人员通过使用createImage变体实现自己的图像缓存。 如果指定文件中包含的图像数据发生更改，则Image方法返回的Image对象可能仍包含在先前调用后从文件加载的过时信息。 以前加载的图像数据可以通过在返回的Image上调用flush方法手动丢弃。

        此方法首先检查是否安装了安全管理器。 如果是这样，该方法会使用指定的文件调用安全管理器的checkRead方法，以确保允许对该映像的访问。

        参数
        filename - 包含识别文件格式的像素数据的文件的名称。
        结果
        从指定文件获取其像素数据的图像。
        异常
        SecurityException - 如果安全管理器存在，并且其checkRead方法不允许操作。
        另请参见：
        createImage(java.lang.String)

      • getImage

        public abstract Image getImage​(URL url)
        返回从指定的URL获取像素数据的图像。 由指定的URL引用的像素数据必须采用以下格式之一：GIF，JPEG或PNG。 底层工具包尝试将具有相同URL的多个请求解析为相同的返回图像。

        由于促进共享Image对象所需的机制可能会继续保持不再使用无限期的图像，因此鼓励开发人员通过使用可用的createImage变体实现自己的图像缓存。 如果存储在指定URL中的图像数据发生更改，则Image方法返回的Image对象可能仍然包含在先前调用之后从URL获取的过时信息。 以前加载的图像数据可以通过在返回的Image上调用flush方法手动丢弃。

        此方法首先检查是否安装了安全管理器。 如果是这样，该方法使用url.openConnection（）。getPermission（）权限调用安全管理器的checkPermission方法，以确保允许对该映像的访问。 为了与1.2之前的安全管理员兼容，如果访问被拒绝使用FilePermission或SocketPermission ，该方法会抛出SecurityException如果相应的1.1型SecurityManager.checkXXX方法也拒绝许可。

        参数
        url - 用于获取像素数据的URL。
        结果
        从指定的URL获取其像素数据的图像。
        异常
        SecurityException - 如果安全管理器存在，并且其checkPermission方法不允许操作。
        另请参见：
        createImage(java.net.URL)

      • createImage

        public abstract Image createImage​(String filename)
        返回从指定文件获取像素数据的图像。 返回的图像是一个新对象，不会与此方法或其getImage变体的任何其他调用者共享。

        此方法首先检查是否安装了安全管理器。 如果是这样，该方法使用指定的文件调用安全管理器的checkRead方法，以确保允许创建映像。

        参数
        filename - 包含识别文件格式的像素数据的文件的名称。
        结果
        从指定文件获取其像素数据的图像。
        异常
        SecurityException - 如果安全管理器存在，并且其checkRead方法不允许操作。
        另请参见：
        getImage(java.lang.String)

      • createImage

        public abstract Image createImage​(URL url)
        返回从指定的URL获取像素数据的图像。 返回的图像是一个新对象，不会与此方法或其getImage变体的任何其他调用者共享。

        此方法首先检查是否安装了安全管理器。 如果是这样，该方法使用url.openConnection（）。getPermission（）权限调用安全管理器的checkPermission方法，以确保允许映像创建。 为了与1.2之前的安全管理员兼容，如果访问被拒绝使用FilePermission或SocketPermission ，该方法将抛出SecurityException如果相应的1.1型SecurityManager.checkXXX方法也拒绝许可。

        参数
        url - 用于获取像素数据的URL。
        结果
        从指定的URL获取其像素数据的图像。
        异常
        SecurityException - 如果安全管理器存在，并且其checkPermission方法不允许该操作。
        另请参见：
        getImage(java.net.URL)

      • prepareImage

        public abstract boolean prepareImage​(Image image,
                                     int width,
                                     int height,
                                     ImageObserver observer)
        准备渲染图像。

        如果width和height参数的值均为-1 ，则该方法将准备在默认屏幕上进行渲染的图像; 否则，该方法将在默认屏幕上以指定的宽度和高度准备渲染图像。

        图像数据在另一个线程中异步下载，并且生成图像的适当缩放的屏幕表示。

        该方法由组件prepareImage方法调用。

        有关此方法返回的标志的信息可以通过ImageObserver接口的定义找到。

        参数
        image - 准备屏幕表示的图像。
        width - 所需屏幕表示的宽度，或 -1 。
        height - 所需屏幕表示的高度，或 -1 。
        observer - ImageObserver对象在图像正在准备时被通知。
        结果
        true如果图像已经完全准备好了; false否则。
        另请参见：
        Component.prepareImage(java.awt.Image, java.awt.image.ImageObserver) ， Component.prepareImage(java.awt.Image, int, int, java.awt.image.ImageObserver) ， ImageObserver

      • checkImage

        public abstract int checkImage​(Image image,
                               int width,
                               int height,
                               ImageObserver observer)
        表示准备显示的指定图像的构造状态。

        如果width和height参数的值均为-1 ，则此方法返回此工具包中指定图像的屏幕表示的构造状态。 否则，此方法返回指定宽度和高度的图像的缩放表示的构造状态。

        此方法不会导致图像开始加载。 应用程序必须调用prepareImage强制加载映像。

        该方法由组件的checkImage方法调用。

        有关此方法返回的标志的信息可以通过ImageObserver接口的定义找到。

        参数
        image - 正在检查状态的图像。
        width - 正在检查其状态的缩放版本的宽度，或 -1 。
        height - 正在检查状态的缩放版本的高度，或 -1 。
        observer - 正在准备好要通知的 ImageObserver对象。
        结果
        当前可用的图像数据的 ImageObserver标志的按位包含 OR 。
        另请参见：
        prepareImage(java.awt.Image, int, int, java.awt.image.ImageObserver) ， Component.checkImage(java.awt.Image, java.awt.image.ImageObserver) ， Component.checkImage(java.awt.Image, int, int, java.awt.image.ImageObserver) ， ImageObserver

      • createImage

        public abstract Image createImage​(ImageProducer producer)
        使用指定的图像生成器创建图像。
        参数
        producer - 要使用的图像制作者。
        结果
        具有指定图像生成器的图像。
        另请参见：
        Image ， ImageProducer ， Component.createImage(java.awt.image.ImageProducer)

      • createImage

        public Image createImage​(byte[] imagedata)
        创建解码存储在指定字节数组中的图像的图像。

        数据必须是某种图像格式，如GIF或JPEG，这个工具包支持。

        参数
        imagedata - 以支持的图像格式表示图像数据的字节数组。
        结果
        一个图像。
        从以下版本开始：
        1.1

      • createImage

        public abstract Image createImage​(byte[] imagedata,
                                  int imageoffset,
                                  int imagelength)
        创建一个图像，解码存储在指定字节数组中的图像，并以指定的偏移量和长度。 数据必须是某种图像格式，如GIF或JPEG，这个工具包支持。
        参数
        imagedata - 以支持的图像格式表示图像数据的字节数组。
        imageoffset - 数组中数据开头的偏移量。
        imagelength - 数组中数据的长度。
        结果
        一个图像。
        从以下版本开始：
        1.1

      • getPrintJob

        public abstract PrintJob getPrintJob​(Frame frame,
                                     String jobtitle,
                                     Properties props)
        获取一个PrintJob对象，这是在工具包的平台上启动打印操作的结果。

        该方法的每个实际实现应首先检查是否安装了安全管理器。 如果有的话，该方法应该调用安全管理员的checkPrintJobAccess方法，以确保允许启动打印操作。 如果使用默认实现checkPrintJobAccess （即，该方法不被覆盖），则这将导致对安全管理器的checkPermission方法的checkPermission ，具有RuntimePermission("queuePrintJob")权限。

        参数
        frame - 打印对话框的父级。 可能不为空
        jobtitle - PrintJob的标题。 空标题等同于“”。
        props - 包含零个或多个属性的Properties对象。 属性不标准化，并且在实现中不一致。 因此，需要作业和页面控制的PrintJobs应该使用该函数的版本，该版本采用JobAttributes和PageAttributes对象。 此对象可能会被更新，以反映退出时用户的工作选择。 可能为null。
        结果
        一个 PrintJob对象，如果用户取消打印作业， null 。
        异常
        NullPointerException - if frame为null
        SecurityException - 如果此线程不允许启动打印作业请求
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless() ， PrintJob ， RuntimePermission

      • getPrintJob

        public PrintJob getPrintJob​(Frame frame,
                            String jobtitle,
                            JobAttributes jobAttributes,
                            PageAttributes pageAttributes)
        获取一个PrintJob对象，这是在工具包的平台上启动打印操作的结果。

        该方法的每个实际实现应首先检查是否安装了安全管理器。 如果有，该方法应该调用安全管理员的checkPrintJobAccess方法，以确保允许启动打印操作。 如果使用默认实现checkPrintJobAccess （即，该方法不被覆盖），则会导致对安全管理器的checkPermission方法的checkPermission ，具有RuntimePermission("queuePrintJob")权限。

        参数
        frame - 打印对话框的父项。 可能不为空
        jobtitle - PrintJob的标题。 空标题等同于“”。
        jobAttributes - 一组将控制PrintJob的作业属性。 属性将被更新以反映用户的选择，如JobAttributes文档中所述。 可能为null。
        pageAttributes - 将控制PrintJob的一组页面属性。 属性将应用于作业中的每个页面。 属性将被更新以反映用户的选择，如PageAttributes文档中所述。 可能为null。
        结果
        一个 PrintJob对象，如果用户取消了打印作业， null 。
        异常
        NullPointerException - if frame为null
        IllegalArgumentException - 如果pageAttributes指定了不同的交叉Feed和Feed分辨率。 此外，如果此线程可以访问文件系统，并且jobAttributes指定打印到文件，并且指定的目标文件存在但是是目录而不是常规文件，则不存在但不能创建，或由于任何其他原因无法打开。 然而，在打印到文件的情况下，如果还要求显示对话，则将给予用户选择文件并继续打印的机会。 该对话框将确保选择的输出文件在从此方法返回之前是有效的。
        SecurityException - 如果此线程不允许启动打印作业请求，或者如果jobAttributes指定打印到文件，并且此线程不允许访问文件系统
        从以下版本开始：
        1.3
        另请参见：
        PrintJob ， GraphicsEnvironment.isHeadless() ， RuntimePermission ， JobAttributes ， PageAttributes

      • beep

        public abstract void beep​()
        根据本地系统设置和硬件功能发出音频蜂鸣声。
        从以下版本开始：
        1.1

      • getSystemClipboard

        public abstract Clipboard getSystemClipboard​()
                                      throws HeadlessException
        获取与本地平台提供的剪贴板工具接口的系统剪贴板的单例实例。 此剪贴板可实现Java程序与使用本地剪贴板设备的本机应用程序之间的数据传输。

        除了任何和所有默认格式文本返回的文本剪贴板的getTransferData()方法可用于以下风格：

        • 选择DataFlavor.stringFlavor
        • DataFlavor.plainTextFlavor（ 已弃用 ）
        与java.awt.datatransfer.StringSelection ，如果要求的风味是DataFlavor.plainTextFlavor或相当的味道，则会返回读者。 注：系统剪贴板的的行为getTransferData()方法为DataFlavor.plainTextFlavor ，和等价DataFlavor与定义不一致DataFlavor.plainTextFlavor 。 正因为如此，为支持DataFlavor.plainTextFlavor ，等效flavor， 已被弃用 。

        该方法的每个实际实现应首先检查是否安装了安全管理器。 如果有的话，该方法应该调用安全管理员的checkPermission方法来检查AWTPermission("accessClipboard") 。

        结果
        系统剪贴板
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless() ， Clipboard ， StringSelection ， DataFlavor.stringFlavor ， DataFlavor.plainTextFlavor ， Reader ， AWTPermission

      • getSystemSelection

        public Clipboard getSystemSelection​()
                             throws HeadlessException
        获取系统选择的单例实例为Clipboard对象。 这允许应用程序读取和修改当前的系统范围选择。

        当用户使用鼠标或键盘选择文本时，应用程序负责更新系统选择。 通常，这是通过安装来实现FocusListener所有Component S的支持文本选择，和，之间FOCUS_GAINED个FOCUS_LOST传递到事件Component ，更新系统选择Clipboard当内选择更改Component 。 正确更新系统选择可确保Java应用程序与本机应用程序和系统上同时运行的其他Java应用程序正确交互。 请注意， java.awt.TextComponent和javax.swing.text.JTextComponent已经遵守了这一政策。 当使用这些类及其子类时，开发人员不需要编写任何其他代码。

        某些平台不支持系统选择Clipboard 。 在这些平台上，此方法将返回null 。 在这种情况下，如上所述，应用程序不能更新系统选择Clipboard 。

        该方法的每个实际实现应首先检查是否安装了安全管理器。 如果有的话，该方法应该调用安全管理员的checkPermission方法来检查AWTPermission("accessClipboard") 。

        结果
        系统选择为 Clipboard ，或 null如果本机平台不支持系统选择 Clipboard
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.4
        另请参见：
        Clipboard ， FocusListener ， FocusEvent.FOCUS_GAINED ， FocusEvent.FOCUS_LOST ， TextComponent ， JTextComponent ， AWTPermission ， GraphicsEnvironment.isHeadless()

      • getMenuShortcutKeyMask

        public int getMenuShortcutKeyMask​()
                           throws HeadlessException
        确定哪个修饰键是菜单快捷键的适当加速键。

        MenuShortcut课程体现的菜单快捷键由MenuBar课程处理。

        默认情况下，此方法返回Event.CTRL_MASK 。 如果Control键不是加速器的正确键，Toolkit实现应该覆盖此方法。

        结果
        Event类上的修饰符掩码，用于此工具包上的菜单快捷方式。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.1
        另请参见：
        GraphicsEnvironment.isHeadless() ， MenuBar ， MenuShortcut

      • getLockingKeyState

        public boolean getLockingKeyState​(int keyCode)
                           throws UnsupportedOperationException
        返回键盘上给定的锁定键是否处于“开启”状态。 有效键代码是VK_CAPS_LOCK ， VK_NUM_LOCK ， VK_SCROLL_LOCK ，并VK_KANA_LOCK 。
        参数
        keyCode - 关键代码
        结果
        true如果给定的键当前处于“开”状态; 否则false
        异常
        IllegalArgumentException - 如果 keyCode不是有效的密钥代码之一
        UnsupportedOperationException - 如果主机系统不允许以编程方式获取此密钥的状态，或者如果键盘没有此密钥
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless()

      • setLockingKeyState

        public void setLockingKeyState​(int keyCode,
                               boolean on)
                        throws UnsupportedOperationException
        设置键盘上给定锁定键的状态。 有效键代码是VK_CAPS_LOCK ， VK_NUM_LOCK ， VK_SCROLL_LOCK ，并VK_KANA_LOCK 。

        根据平台，设置锁定键的状态可能涉及事件处理，因此可能无法通过getLockingKeyState立即观察到。

        参数
        keyCode - 关键代码
        on - 关键的状态
        异常
        IllegalArgumentException - 如果 keyCode不是有效的密钥代码之一
        UnsupportedOperationException - 如果主机系统不允许以编程方式设置此密钥的状态，或者键盘没有此键
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getNativeContainer

        protected static Container getNativeContainer​(Component c)
        给本地对等体提供给本地组件查询本机容器的能力（例如，直接父级可能是轻量级的）。
        参数
        c - 获取容器的组件
        结果
        组件的本机容器对象

      • createCustomCursor

        public Cursor createCustomCursor​(Image cursor,
                                 Point hotSpot,
                                 String name)
                          throws IndexOutOfBoundsException,
                                 HeadlessException
        创建一个新的自定义光标对象。 如果要显示的图像无效，光标将被隐藏（完全透明），热点将被设置为（0,0）。

        请注意，多帧图像无效，可能导致此方法挂起。

        参数
        cursor - 激活光标时显示的图像
        hotSpot - 大光标热点的X和Y; hotSpot值必须小于getBestCursorSize返回的getBestCursorSize
        name - Java Accessibility使用的游标的本地化描述
        结果
        创建光标
        异常
        IndexOutOfBoundsException - 如果hotSpot值超出了光标的边界
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.2
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getBestCursorSize

        public Dimension getBestCursorSize​(int preferredWidth,
                                   int preferredHeight)
                            throws HeadlessException
        返回最接近所需大小的支持的光标维度。 仅支持单个光标大小的系统将返回该大小，而不考虑所需的大小。 不支持自定义游标的系统将返回0，0的维度。

        注意：如果使用其尺寸与支持的尺寸不一致的图像（由此方法返回），则Toolkit实施将尝试将图像的大小调整为受支持的大小。 由于转换低分辨率图像是困难的，因此不能保证不是支持尺寸的光标图像的质量。 因此，建议调用此方法，并使用合适的图像，以便不进行图像转换。

        参数
        preferredWidth - 组件想要使用的首选光标宽度。
        preferredHeight - 组件想要使用的首选光标高度。
        结果
        最接近的匹配支持的游标大小，或者如果Toolkit实现不支持自定义游标，则为0,0。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.2
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getMaximumCursorColors

        public int getMaximumCursorColors​()
                           throws HeadlessException
        返回Toolkit在自定义光标调色板中支持的最大颜色数。

        注意：如果使用的图像在其调色板中具有比支持的最大值更多的颜色，则Toolkit实现将尝试将调色板最大化。 由于转换低分辨率图像是困难的，因此不能保证具有比系统支持的颜色更多的光标图像的质量。 因此，建议调用此方法，并使用合适的图像，以便不进行图像转换。

        结果
        最大颜色数量，如果此Toolkit实现不支持自定义游标，则为零。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.2
        另请参见：
        GraphicsEnvironment.isHeadless()

      • isFrameStateSupported

        public boolean isFrameStateSupported​(int state)
                              throws HeadlessException
        返回Toolkit是否支持Frame的状态。 该方法可以说明是否支持UI概念 ，例如最大化或图标化。 它将总是为“复合”状态返回假，如Frame.ICONIFIED|Frame.MAXIMIZED_VERT 。 换句话说，经验法则是只有具有单个帧状态常量的查询作为参数是有意义的。

        请注意，支持一个给定的概念是平台相关的功能。 由于本机限制，Toolkit对象可能会将特定状态报告为受支持，但是同时Toolkit对象将无法将该状态应用于给定的帧。 这种情况有两个后果：

        • 只有本方法的返回值为false实际上表示不支持给定的状态。 如果方法返回true ，给定的状态可能仍然不被支持和/或不适用于特定的帧。
        • 开发商应考虑通过WindowEvent收到的WindowEvent的WindowEvent.getNewState()方法的值，而不是假定给予setExtendedState()方法的状态将被明确应用。 有关更多信息，请参阅Frame.setExtendedState(int)方法的文档。
        参数
        state - 命名帧状态常量之一。
        结果
        true是这个框架状态是由这个Toolkit实现的， false否则。
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回 true 。
        从以下版本开始：
        1.4
        另请参见：
        Window.addWindowStateListener(java.awt.event.WindowStateListener)

      • getProperty

        public static String getProperty​(String key,
                                 String defaultValue)
        获取具有指定键和默认值的属性。 如果找不到属性，此方法返回defaultValue。
        参数
        key - 关键
        defaultValue - 默认值
        结果
        该属性的值或默认值，如果该属性未找到

      • getSystemEventQueue

        public final EventQueue getSystemEventQueue​()
        获取应用程序或小程序的EventQueue实例。 根据Toolkit实现，可能会针对不同的小程序返回不同的EventQueues。 因此，Applet不应该假定此方法返回的EventQueue实例将被其他小程序或系统共享。

        如果有安全管理员，那么它的checkPermission方法被调用来检查AWTPermission("accessEventQueue") 。

        结果
        EventQueue对象
        异常
        SecurityException - 如果设置了安全管理员，并且它拒绝访问 EventQueue
        另请参见：
        AWTPermission

      • getSystemEventQueueImpl

        protected abstract EventQueue getSystemEventQueueImpl​()
        获取应用程序或小程序的EventQueue实例，而无需检查访问。 出于安全考虑，这只能从一个Toolkit子类中调用。
        结果
        EventQueue对象

      • createDragGestureRecognizer

        public <T extends DragGestureRecognizer> T createDragGestureRecognizer​(Class<T> abstractRecognizerClass,
                                                                       DragSource ds,
                                                                       Component c,
                                                                       int srcActions,
                                                                       DragGestureListener dgl)
        创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。 子类应该覆盖这个来提供自己的实现
        参数类型
        T - 要创建的DragGestureRecognizer的类型
        参数
        abstractRecognizerClass - 所需识别器的抽象类
        ds - DragSource
        c - DragGestureRecognizer的组件目标
        srcActions - 手势允许的动作
        dgl - DragGestureListener
        结果
        新对象或null。 如果GraphicsEnvironment.isHeadless（）返回true，则始终返回null。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getDesktopProperty

        public final Object getDesktopProperty​(String propertyName)
        获取指定的桌面属性的值。 桌面属性是属于Toolkit全局的资源的唯一命名值。 通常它也是底层平台依赖桌面设置的抽象表示。 有关AWT支持的桌面属性的更多信息，请参阅AWT Desktop Properties 。
        参数
        propertyName - 属性名称
        结果
        指定桌面属性的值

      • setDesktopProperty

        protected final void setDesktopProperty​(String name,
                                        Object newValue)
        将指定的桌面属性设置为指定的值，并触发属性更改事件以通知任何侦听器该值已更改。
        参数
        name - 属性名称
        newValue - 新的物业价值

      • lazilyLoadDesktopProperty

        protected Object lazilyLoadDesktopProperty​(String name)
        懒惰评估桌面属性值的机会。
        参数
        name - 的名字
        结果
        桌面属性或null

      • initializeDesktopProperties

        protected void initializeDesktopProperties​()
        initializeDesktopProperties

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String name,
                                      PropertyChangeListener pcl)
        为指定的桌面属性添加指定的属性更改侦听器。 当添加PropertyChangeListenerProxy对象时，其属性名称将被忽略，并且添加了包装的侦听器。 如果name是null或pcl是null ，则抛出异常并且不执行任何操作。
        参数
        name - 要收听的财产的名称
        pcl - 属性更改侦听器
        从以下版本开始：
        1.2
        另请参见：
        PropertyChangeSupport.addPropertyChangeListener(String, PropertyChangeListener)

      • removePropertyChangeListener

        public void removePropertyChangeListener​(String name,
                                         PropertyChangeListener pcl)
        为指定的桌面属性移除指定的属性更改侦听器。 删除PropertyChangeListenerProxy对象时，将忽略其属性名称，并删除包装的侦听器。 如果name为null或pcl为null ，则不会抛出异常，也不会执行任何操作。
        参数
        name - 要删除的属性的名称
        pcl - 属性更改侦听器
        从以下版本开始：
        1.2
        另请参见：
        PropertyChangeSupport.removePropertyChangeListener(String, PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​()
        返回在此工具包上注册的所有属性更改侦听器的数组。 返回的数组包含27050254484404个对象，将侦听器与桌面属性的名称相关联。
        结果
        所有此工具包的PropertyChangeListener对象包含在java.beans.PropertyChangeListenerProxy对象中，如果没有添加侦听器， java.beans.PropertyChangeListenerProxy空数组
        从以下版本开始：
        1.4
        另请参见：
        PropertyChangeSupport.getPropertyChangeListeners()

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
        返回与指定的桌面属性名称相关联的所有属性更改侦听器的数组。
        参数
        propertyName - 命名属性
        结果
        所有 PropertyChangeListener对象与桌面属性的指定名称相关联，如果没有添加此类侦听器，则为空数组
        从以下版本开始：
        1.4
        另请参见：
        PropertyChangeSupport.getPropertyChangeListeners(String)

      • isAlwaysOnTopSupported

        public boolean isAlwaysOnTopSupported​()
        返回此工具包是否支持始终在线模式。 要检测特定窗口是否支持始终在线模式，请使用Window.isAlwaysOnTopSupported() 。
        结果
        true ，如果当前工具包支持永远在线模式，否则返回 false
        从以下版本开始：
        1.6
        另请参见：
        Window.isAlwaysOnTopSupported() ， Window.setAlwaysOnTop(boolean)

      • isModalityTypeSupported

        public abstract boolean isModalityTypeSupported​(Dialog.ModalityType modalityType)
        返回此工具包是否支持给定的模态类型。 如果创建了不支持的模式类型的对话框，则使用Dialog.ModalityType.MODELESS 。
        参数
        modalityType - 要检查此工具包支持的模态类型
        结果
        true ，如果当前工具包支持给定模式类型，否则为 false
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType ， Dialog.getModalityType() ， Dialog.setModalityType(java.awt.Dialog.ModalityType)

      • isModalExclusionTypeSupported

        public abstract boolean isModalExclusionTypeSupported​(Dialog.ModalExclusionType modalExclusionType)
        返回此工具包是否支持给定的模式排除类型。 如果在窗口上设置了不支持的模式排除类型属性，则使用Dialog.ModalExclusionType.NO_EXCLUDE 。
        参数
        modalExclusionType - 此工具包支持的模式排除类型
        结果
        true ，如果当前工具包支持给定的模式排除类型，否则为 false
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalExclusionType ， Window.getModalExclusionType() ， Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType)

      • addAWTEventListener

        public void addAWTEventListener​(AWTEventListener listener,
                                long eventMask)
        添加一个AWTEventListener来接收系统范围内符合给定的eventMask所有AWTEvent。

        首先，如果有一个安全管理员，它的checkPermission方法被调用一个AWTPermission("listenToAllAWTEvents")权限。 这可能会导致SecurityException。

        eventMask是要接收的事件类型的位掩码。 它是通过对AWTEvent定义的事件掩码进行按位OR操作来AWTEvent 。

        注意：事件监听器使用不推荐用于正常应用程序，但仅用于支持特殊目的设施，包括对可访问性的支持，事件记录/回放和诊断跟踪。 如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        参数
        listener - 事件侦听器。
        eventMask - 要接收的事件类型的位掩码
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许操作。
        从以下版本开始：
        1.2
        另请参见：
        removeAWTEventListener(java.awt.event.AWTEventListener) ， getAWTEventListeners() ， SecurityManager.checkPermission(java.security.Permission) ， AWTEvent ， AWTPermission ， AWTEventListener ， AWTEventListenerProxy

      • removeAWTEventListener

        public void removeAWTEventListener​(AWTEventListener listener)
        从接收发送的AWTEvent中删除AWTEventListener。

        首先，如果有一个安全管理器，它的checkPermission方法被调用一个AWTPermission("listenToAllAWTEvents")权限。 这可能会导致SecurityException。

        注意：事件监听器使用不推荐用于正常应用程序，但仅用于支持特殊目的设施，包括对可访问性的支持，事件记录/回放和诊断跟踪。 如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        参数
        listener - 事件侦听器。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许操作。
        从以下版本开始：
        1.2
        另请参见：
        addAWTEventListener(java.awt.event.AWTEventListener, long) ， getAWTEventListeners() ， SecurityManager.checkPermission(java.security.Permission) ， AWTEvent ， AWTPermission ， AWTEventListener ， AWTEventListenerProxy

      • getAWTEventListeners

        public AWTEventListener[] getAWTEventListeners​()
        返回在该工具包上注册的所有AWTEventListener的数组。 如果有一个安全管理员，它的checkPermission方法被调用一个AWTPermission("listenToAllAWTEvents")权限。 这可能会导致SecurityException。 可以在AWTEventListenerProxy对象中返回侦听器，该对象还包含给定侦听器的事件掩码。 请注意，多次添加的侦听器对象在返回的数组中只显示一次。
        结果
        所有的 AWTEventListener s或一个空数组，如果没有听众当前注册
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许操作。
        从以下版本开始：
        1.4
        另请参见：
        addAWTEventListener(java.awt.event.AWTEventListener, long) ， removeAWTEventListener(java.awt.event.AWTEventListener) ， SecurityManager.checkPermission(java.security.Permission) ， AWTEvent ， AWTPermission ， AWTEventListener ， AWTEventListenerProxy

      • getAWTEventListeners

        public AWTEventListener[] getAWTEventListeners​(long eventMask)
        返回在该工具包上注册的所有AWTEventListener的数组，该数组监听eventMask参数中指定的所有事件类型。 如果有一个安全管理员，它的checkPermission方法被调用一个AWTPermission("listenToAllAWTEvents")权限。 这可能会导致SecurityException。 可以在AWTEventListenerProxy对象中返回侦听器，其中还包含给定侦听器的事件掩码。 请注意，多次添加的侦听器对象在返回的数组中只显示一次。
        参数
        eventMask - 要侦听的事件类型的位掩码
        结果
        所有 AWTEventListener在这个工具包上注册了指定的事件类型，如果没有这样的监听器当前注册，则为空数组
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许操作。
        从以下版本开始：
        1.4
        另请参见：
        addAWTEventListener(java.awt.event.AWTEventListener, long) ， removeAWTEventListener(java.awt.event.AWTEventListener) ， SecurityManager.checkPermission(java.security.Permission) ， AWTEvent ， AWTPermission ， AWTEventListener ， AWTEventListenerProxy

      • mapInputMethodHighlight

        public abstract Map<TextAttribute,?> mapInputMethodHighlight​(InputMethodHighlight highlight)
                                                      throws HeadlessException
        返回给定输入法突出显示的抽象级别描述的可视属性映射，如果没有找到映射，则返回null。 忽略输入法高亮的样式字段。 返回的地图是不可修改的。
        参数
        highlight - 输入法突出显示
        结果
        样式属性图，或 null
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回true
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless()

      • areExtraMouseButtonsEnabled

        public boolean areExtraMouseButtonsEnabled​()
                                    throws HeadlessException
        报告是否允许来自额外的鼠标按钮的事件被处理并发布到EventQueue 。
        要更改返回值，需要在Toolkit类初始化之前设置sun.awt.enableExtraMouseButtons属性。 可以通过以下命令在应用程序启动时完成此设置：
          java -Dsun.awt.enableExtraMouseButtons=false Application
        或者，可以通过使用以下代码在应用程序中设置属性：
          System.setProperty("sun.awt.enableExtraMouseButtons", "true");
        之前的Toolkit类初始化。 如果没有设置Toolkit类的初始化时间，这个属性将被初始化为true 。 在Toolkit类初始化后更改此值将不起作用。
        结果
        true如果允许来自额外的鼠标按钮的事件被处理和发布; false否则
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        从以下版本开始：
        1.7
        另请参见：
        System.getProperty(String propertyName) ， System.setProperty(String propertyName, String value) ， EventQueue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Transparency (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Interface Transparency

  • All Known Subinterfaces:
    Paint
    所有已知实现类：
    BufferedImage ， Color ， ColorModel ， ColorUIResource ， ComponentColorModel ， DirectColorModel ， GradientPaint ， IndexColorModel ， LinearGradientPaint ， MultipleGradientPaint ， PackedColorModel ， RadialGradientPaint ， SystemColor ， TexturePaint ， VolatileImage

    public interface Transparency
    Transparency接口定义了实现类的通用透明度模式。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BITMASK
      表示保证为完全不透明，Alpha值为1.0或完全透明，Alpha值为0.0的图像数据。
      static int OPAQUE
      表示保证完全不透明的图像数据，意味着所有像素的alpha值为1.0。
      static int TRANSLUCENT
      表示包含或可能包含0.0和1.0之间的任意α值的图像数据。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getTransparency​()
      返回此 Transparency的类型。

    • 字段详细信息

      • OPAQUE

        @Native
static final int OPAQUE
        表示保证完全不透明的图像数据，意味着所有像素的alpha值为1.0。
        另请参见：
        Constant Field Values

      • BITMASK

        @Native
static final int BITMASK
        表示保证为完全不透明，Alpha值为1.0或完全透明，Alpha值为0.0的图像数据。
        另请参见：
        Constant Field Values

      • TRANSLUCENT

        @Native
static final int TRANSLUCENT
        表示包含或可能包含0.0和1.0之间的任意α值的图像数据。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getTransparency

        int getTransparency​()
        返回此 Transparency的类型。
        结果
        这是 Transparency的字段类型，它是OPAQUE，BITMASK或TRANSLUCENT。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TrayIcon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class TrayIcon

  • java.lang.Object
    • java.awt.TrayIcon

  • public class TrayIcon
extends Object
    一个TrayIcon对象表示可以添加到system tray的托盘图标。 A TrayIcon可以具有工具提示（文本），图像，弹出式菜单以及与之相关的一组侦听器。

    A TrayIcon可以生成各种MouseEvents，并支持添加相应的收听者来接收这些事件的通知。 TrayIcon处理一些事件。 例如，默认情况下，当对TrayIcon执行鼠标右键单击时，它会显示指定的弹出菜单。 当鼠标悬停在TrayIcon ，显示工具提示（此行为依赖于平台）。

    注意：当MouseEvent发送到其注册听众时，其component属性将设置为null 。 （见ComponentEvent.getComponent() ） source属性将设置为TrayIcon 。 （见EventObject.getSource() ）

    注意：良好的TrayIcon实现将分配不同的手势来显示弹出菜单和选择托盘图标。

    A TrayIcon可以生成一个ActionEvent 。 在某些平台上，当用户使用鼠标或键盘选择托盘图标时，会发生这种情况。

    如果安装了SecurityManager，则必须授予accessSystemTray才能创建一个TrayIcon 。 否则构造函数将抛出一个SecurityException。

    有关如何使用TrayIcon API的示例，请参阅SystemTray课程概述。

    从以下版本开始：
    1.6
    另请参见：
    SystemTray.add(java.awt.TrayIcon) ，
ComponentEvent.getComponent() ，
EventObject.getSource()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TrayIcon.MessageType
      消息类型确定在消息的标题中将显示哪个图标，以及在显示时消息可能产生的可能的系统声音。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TrayIcon​(Image image)
      创建一个 TrayIcon与指定的图像。
      TrayIcon​(Image image, String tooltip)
      创建一个 TrayIcon与指定的图像和工具提示文本。
      TrayIcon​(Image image, String tooltip, PopupMenu popup)
      使用指定的图像，工具提示和弹出菜单创建 TrayIcon 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addActionListener​(ActionListener listener)
      添加指定的操作侦听器以接收 ActionEvent从这个S TrayIcon 。
      void addMouseListener​(MouseListener listener)
      添加指定的鼠标监听器以从此 TrayIcon接收鼠标事件。
      void addMouseMotionListener​(MouseMotionListener listener)
      添加指定的鼠标监听器以从此 TrayIcon接收鼠标移动事件。
      void displayMessage​(String caption, String text, TrayIcon.MessageType messageType)
      在托盘图标附近显示弹出消息。
      String getActionCommand​()
      返回此托盘图标触发的操作事件的命令名称。
      ActionListener[] getActionListeners​()
      返回在此 TrayIcon上注册的所有动作侦听器的数组。
      Image getImage​()
      返回用于此 TrayIcon的当前图像。
      MouseListener[] getMouseListeners​()
      返回在此 TrayIcon上注册的所有鼠标监听器的数组。
      MouseMotionListener[] getMouseMotionListeners​()
      返回在此 TrayIcon上注册的所有鼠标移动侦听器的 TrayIcon 。
      PopupMenu getPopupMenu​()
      返回与此 TrayIcon相关联的弹出菜单。
      Dimension getSize​()
      返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
      String getToolTip​()
      返回与此 TrayIcon相关联的工具提示字符串。
      boolean isImageAutoSize​()
      返回auto-size属性的值。
      void removeActionListener​(ActionListener listener)
      删除指定的动作侦听器。
      void removeMouseListener​(MouseListener listener)
      删除指定的鼠标监听器。
      void removeMouseMotionListener​(MouseMotionListener listener)
      删除指定的鼠标移动侦听器。
      void setActionCommand​(String command)
      设置此托盘图标触发的操作事件的命令名称。
      void setImage​(Image image)
      设置 TrayIcon的图像。
      void setImageAutoSize​(boolean autosize)
      设置自动大小属性。
      void setPopupMenu​(PopupMenu popup)
      设置此 TrayIcon的弹出式菜单。
      void setToolTip​(String tooltip)
      设置此 TrayIcon的工具提示字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TrayIcon

        public TrayIcon​(Image image)
        创建一个 TrayIcon与指定的图像。
        参数
        image - 要使用的 Image
        异常
        IllegalArgumentException - 如果 image是 null
        UnsupportedOperationException - 如果当前平台不支持系统托盘
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回 true
        SecurityException - 如果不授予 accessSystemTray权限
        另请参见：
        SystemTray.add(TrayIcon) ， TrayIcon(Image, String, PopupMenu) ， TrayIcon(Image, String) ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • TrayIcon

        public TrayIcon​(Image image,
                String tooltip)
        使用指定的图像和工具提示文本创建TrayIcon 。 某些平台上的工具提示可能不可见。
        参数
        image - 要使用的 Image
        tooltip - 用作工具提示文字的字符串; 如果值为null则不显示工具提示
        异常
        IllegalArgumentException - 如果 image是 null
        UnsupportedOperationException - 如果当前平台不支持系统托盘
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回 true
        SecurityException - 如果不授予 accessSystemTray权限
        另请参见：
        SystemTray.add(TrayIcon) ， TrayIcon(Image) ， TrayIcon(Image, String, PopupMenu) ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

      • TrayIcon

        public TrayIcon​(Image image,
                String tooltip,
                PopupMenu popup)
        使用指定的图像，工具提示和弹出菜单创建TrayIcon 。 某些平台上的工具提示可能不可见。
        参数
        image - 要使用的 Image
        tooltip - 用作工具提示文本的字符串; 如果值为null则不显示工具提示
        popup - 用于托盘图标的弹出菜单的菜单; 如果值为null则不显示弹出式菜单
        异常
        IllegalArgumentException - 如果 image是 null
        UnsupportedOperationException - 如果当前平台不支持系统托盘
        HeadlessException - 如果 GraphicsEnvironment.isHeadless()返回 true
        SecurityException - 如果不授予 accessSystemTray权限
        另请参见：
        SystemTray.add(TrayIcon) ， TrayIcon(Image, String) ， TrayIcon(Image) ， PopupMenu ， MouseListener ， addMouseListener(MouseListener) ， SecurityManager.checkPermission(java.security.Permission) ， AWTPermission

    • 方法详细信息

      • setImage

        public void setImage​(Image image)
        设置TrayIcon的图像。 先前的托盘图标图像被丢弃，而不调用Image.flush()方法 - 您需要手动调用它。

        如果图像代表动画图像，它将自动动画。

        有关显示图像的大小的详细信息，请参阅setImageAutoSize(boolean)属性。

        使用当前使用的相同图像调用此方法无效。

        参数
        image - 要使用的非空 Image
        异常
        NullPointerException - 如果 image是 null
        另请参见：
        getImage() ， Image ， SystemTray.add(TrayIcon) ， TrayIcon(Image, String)

      • getImage

        public Image getImage​()
        返回用于此 TrayIcon的当前图像。
        结果
        图片
        另请参见：
        setImage(Image) ， Image

      • setPopupMenu

        public void setPopupMenu​(PopupMenu popup)
        设置此TrayIcon的弹出菜单。 如果popup是null ，则不会弹出菜单与此TrayIcon相关联。

        请注意，此popup不得在托盘图标上设置之前或之后添加到任何父项。 如果将其添加到某个父级，则可以从该父级移除popup 。

        popup只能在一个TrayIcon上设置。 在多个TrayIcon上设置相同的弹出窗口将导致一个IllegalArgumentException 。

        注意：当用户右键单击托盘图标时，某些平台可能不支持显示用户指定的弹出菜单组件。 在这种情况下，不会显示任何菜单，或者在某些系统上可能会显示菜单的本地版本。

        参数
        popup - a PopupMenu或 null删除任何弹出式菜单
        异常
        IllegalArgumentException - 如果 popup已经设置为另一个 TrayIcon
        另请参见：
        getPopupMenu()

      • getPopupMenu

        public PopupMenu getPopupMenu​()
        返回与此 TrayIcon关联的弹出菜单。
        结果
        弹出菜单或 null如果不存在）
        另请参见：
        setPopupMenu(PopupMenu)

      • setToolTip

        public void setToolTip​(String tooltip)
        设置此TrayIcon的工具提示字符串。 当鼠标悬停在图标上时，将自动显示工具提示。 某些平台上的工具提示可能不可见。 将工具提示设置为null将删除任何工具提示文本。 显示时，工具提示字符串可能在某些平台上被截断; 可能显示的字符数量取决于平台。
        参数
        tooltip - 工具提示的字符串; 如果值为null则不显示工具提示
        另请参见：
        getToolTip()

      • getToolTip

        public String getToolTip​()
        返回与此 TrayIcon关联的工具提示字符串。
        结果
        工具提示字符串或 null如果不存在）
        另请参见：
        setToolTip(String)

      • setImageAutoSize

        public void setImageAutoSize​(boolean autosize)
        设置自动大小属性。 自动尺寸决定托盘图像是否自动调整大小以适应分配给托盘上图像的空间。 默认情况下，auto-size属性设置为false 。

        如果自动尺寸为false ，并且图像尺寸与托盘图标空间不匹配，则图像将在该空间内按原样绘制 - 如果大于分配的空间，则将被裁剪。

        如果自动尺寸为true ，图像将被拉伸或缩小以适应托盘图标空间。

        参数
        autosize - true自动调整图像大小， false否则
        另请参见：
        isImageAutoSize()

      • isImageAutoSize

        public boolean isImageAutoSize​()
        返回auto-size属性的值。
        结果
        true如果图像将自动调整大小，否则为 false
        另请参见：
        setImageAutoSize(boolean)

      • addMouseListener

        public void addMouseListener​(MouseListener listener)
        添加指定的鼠标监听器以从此TrayIcon接收鼠标事件。 使用null值调用此方法无效。

        注意 ： MouseEvent的坐标（从TrayIcon收到）是相对于屏幕，而不是TrayIcon 。

        注意：不支持MOUSE_ENTERED和MOUSE_EXITED鼠标事件。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        listener - 鼠标监听器
        另请参见：
        MouseEvent ， MouseListener ， removeMouseListener(MouseListener) ， getMouseListeners()

      • removeMouseListener

        public void removeMouseListener​(MouseListener listener)
        删除指定的鼠标监听器。 使用null或无效值调用此方法无效。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        listener - 鼠标监听器
        另请参见：
        MouseEvent ， MouseListener ， addMouseListener(MouseListener) ， getMouseListeners()

      • getMouseListeners

        public MouseListener[] getMouseListeners​()
        返回在此 TrayIcon上注册的所有鼠标监听器的数组。
        结果
        所有 MouseListeners注册在这个 TrayIcon或一个空数组，如果没有鼠标监听器当前注册
        另请参见：
        addMouseListener(MouseListener) ， removeMouseListener(MouseListener) ， MouseListener

      • addMouseMotionListener

        public void addMouseMotionListener​(MouseMotionListener listener)
        添加指定的鼠标监听器以接收来自此TrayIcon鼠标移动事件。 使用null值调用此方法无效。

        注意 ： MouseEvent的坐标（从TrayIcon收到）是相对于屏幕，而不是TrayIcon 。

        注意：不支持MOUSE_DRAGGED鼠标事件。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        listener - 鼠标监听器
        另请参见：
        MouseEvent ， MouseMotionListener ， removeMouseMotionListener(MouseMotionListener) ， getMouseMotionListeners()

      • removeMouseMotionListener

        public void removeMouseMotionListener​(MouseMotionListener listener)
        删除指定的鼠标移动侦听器。 使用null调用此方法或无效值无效。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        listener - 鼠标监听器
        另请参见：
        MouseEvent ， MouseMotionListener ， addMouseMotionListener(MouseMotionListener) ， getMouseMotionListeners()

      • getMouseMotionListeners

        public MouseMotionListener[] getMouseMotionListeners​()
        返回在此 TrayIcon上注册的所有鼠标移动侦听器的 TrayIcon 。
        结果
        所有 MouseInputListeners注册在这个 TrayIcon或一个空数组，如果没有鼠标监听器当前注册
        另请参见：
        addMouseMotionListener(MouseMotionListener) ， removeMouseMotionListener(MouseMotionListener) ， MouseMotionListener

      • getActionCommand

        public String getActionCommand​()
        返回此托盘图标触发的操作事件的命令名称。
        结果
        操作命令名称，如果不存在， null
        另请参见：
        addActionListener(ActionListener) ， setActionCommand(String)

      • setActionCommand

        public void setActionCommand​(String command)
        设置此托盘图标触发的操作事件的命令名称。 默认情况下，此操作命令设置为null 。
        参数
        command - 用于设置托盘图标的动作命令的字符串。
        另请参见：
        ActionEvent ， addActionListener(ActionListener) ， getActionCommand()

      • addActionListener

        public void addActionListener​(ActionListener listener)
        添加指定的动作侦听器以从此TrayIcon接收ActionEvent s。 当用户使用鼠标或键盘选择托盘图标时，通常会发生动作事件。 生成动作事件的条件取决于平台。

        使用null值调用此方法无效。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        listener - 动作侦听器
        另请参见：
        removeActionListener(java.awt.event.ActionListener) ， getActionListeners() ， ActionListener ， setActionCommand(String)

      • removeActionListener

        public void removeActionListener​(ActionListener listener)
        删除指定的动作侦听器。 使用null调用此方法或无效值无效。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        listener - 动作侦听器
        另请参见：
        ActionEvent ， ActionListener ， addActionListener(ActionListener) ， getActionListeners() ， setActionCommand(String)

      • getActionListeners

        public ActionListener[] getActionListeners​()
        返回在此 TrayIcon上注册的所有动作侦听器的数组。
        结果
        所有 ActionListeners注册在这个 TrayIcon或一个空数组，如果没有行动监听器当前注册
        另请参见：
        addActionListener(ActionListener) ， removeActionListener(ActionListener) ， ActionListener

      • displayMessage

        public void displayMessage​(String caption,
                           String text,
                           TrayIcon.MessageType messageType)
        在托盘图标附近显示弹出消息。 消息将在一段时间后消失，或者用户点击该消息。 点击该消息可能会触发一个ActionEvent 。

        无论是标题或文本可能是null ，而是NullPointerException被抛出，如果两者都null 。 显示时，标题或文本字符串可能在某些平台上被截断; 可能显示的字符数量取决于平台。

        注意：某些平台可能不支持显示消息。

        参数
        caption - 文字上方显示的标题，通常为粗体; 可能是null
        text - 为特定消息显示的文本; 可能是null
        messageType - 一个指示消息类型的枚举
        异常
        NullPointerException - 如果 caption和 text都是 null

      • getSize

        public Dimension getSize​()
        返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。 对于尚未添加到系统托盘的托盘图标，返回的大小等于SystemTray.getTrayIconSize()的结果。
        结果
        托盘图标的大小（以像素为单位）
        另请参见：
        setImageAutoSize(boolean) ， Image ， getSize()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TrayIcon.MessageType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum TrayIcon.MessageType

  • java.lang.Object
    • java.lang.Enum<TrayIcon.MessageType>
      • java.awt.TrayIcon.MessageType
  • All Implemented Interfaces:
    Serializable ， Comparable<TrayIcon.MessageType>
    Enclosing class:
    TrayIcon

    public static enum TrayIcon.MessageType
extends Enum<TrayIcon.MessageType>
    消息类型确定在消息的标题中将显示哪个图标，以及在显示时消息可能产生的可能的系统声音。
    从以下版本开始：
    1.6
    另请参见：
    TrayIcon ， TrayIcon.displayMessage(String, String, MessageType)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ERROR
      一个错误消息
      INFO
      一条信息消息
      NONE
      简单的信息
      WARNING
      一条警告信息

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static TrayIcon.MessageType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TrayIcon.MessageType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ERROR

        public static final TrayIcon.MessageType ERROR
        一个错误消息

      • WARNING

        public static final TrayIcon.MessageType WARNING
        一条警告信息

      • INFO

        public static final TrayIcon.MessageType INFO
        一条信息消息

      • NONE

        public static final TrayIcon.MessageType NONE
        简单的信息

    • 方法详细信息

      • values

        public static TrayIcon.MessageType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (TrayIcon.MessageType c : TrayIcon.MessageType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static TrayIcon.MessageType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt

  • Packages that use java.awt
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.imageio
    Java Image I / O API的主要包。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
  • Classes in java.awt used by com.sun.java.accessibility.util
    Class 描述
    AWTEvent
    所有AWT事件的根事件类。
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Cursor
    封装鼠标光标位图表示的类。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，它将特定字体的渲染信息封装在特定的屏幕上。
    IllegalComponentStateException
    表示AWT组件对于请求的操作不在适当的状态。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定由坐标空间中的 Rectangle对象的左上点 (x,y)的坐标空间中的区域，其宽度及其高度。
    Window
    一个 Window对象是没有边框的顶级窗口，没有菜单。
  • Classes in java.awt used by java.applet
    Class 描述
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.AccessibleAWTComponent
    组件的内部类用于为辅助功能提供默认支持。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Container.AccessibleAWTContainer
    Container的内部类用于为辅助功能提供默认支持。
    Dimension
    Dimension类封装了单个对象中组件的宽度和高度（以整数精度）。
    HeadlessException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    MenuContainer
    所有菜单相关容器的超类。
    Panel
    Panel是最简单的容器类。
    Panel.AccessibleAWTPanel
    这个类实现 Panel类的可访问性支持。
  • Classes in java.awt used by java.awt
    Class 描述
    Adjustable
    具有可调整数值的对象的界面包含在有限范围内的值。
    AlphaComposite
    AlphaComposite类实现基本的alpha合成规则，用于组合源和目标颜色，以实现图形和图像的混合和透明效果。
    AWTEvent
    所有AWT事件的根事件类。
    AWTException
    表示发生抽象窗口工具包异常。
    AWTKeyStroke
    AWTKeyStroke表示键盘或等效输入设备上的关键动作。
    BufferCapabilities
    缓冲区的功能和属性。
    BufferCapabilities.FlipContents
    页面翻转后可能的反向缓冲区内容的类型安全枚举
    Checkbox
    复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
    CheckboxGroup
    CheckboxGroup类用于将一组 Checkbox按钮组合在一起。
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.AccessibleAWTComponent
    组件的内部类用于为辅助功能提供默认支持。
    Component.BaselineResizeBehavior
    枚举组件的基准线随着大小变化而改变的常见方式。
    ComponentOrientation
    ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。
    Composite
    Composite界面以及CompositeContext定义了组合绘制图元与底层图形区域的方法。
    CompositeContext
    CompositeContext接口为合成操作定义了封装和优化的环境。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Container.AccessibleAWTContainer
    Container的内部类用于为辅助功能提供默认支持。
    ContainerOrderFocusTraversalPolicy
    FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
    Cursor
    封装鼠标光标位图表示的类。
    Desktop
    Desktop类允许与各种桌面功能进行交互。
    Desktop.Action
    表示动作类型。
    Dialog
    Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
    Dialog.ModalExclusionType
    任何顶级窗口都可以标记为不被模态对话框阻止。
    Dialog.ModalityType
    模态对话框阻止某些顶级窗口的所有输入。
    Dimension
    Dimension类封装了单个对象中组件的宽度和高度（以整数精度）。
    DisplayMode
    所述 DisplayMode类封装的位深度，高度，宽度，和刷新速率 GraphicsDevice 。
    Event
    已过时。
    建议使用AWTEvent及其子类
    EventQueue
    EventQueue是一个与平台无关的类，可以从基础对等类和可信应用程序类排队事件。
    FocusTraversalPolicy
    FocusTraversalPolicy定义了遍历特定焦点循环根的组件的顺序。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    FontFormatException
    在 Font类中通过方法createFont抛出，表示指定的字体不好。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，该对象封装了有关在特定屏幕上呈现特定字体的信息。
    Frame
    A Frame是一个标题和边框的顶级窗口。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及到屏幕外图像上。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    GraphicsConfigTemplate
    GraphicsConfigTemplate类用于获取有效的GraphicsConfiguration 。
    GraphicsConfiguration
    GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特征。
    GraphicsDevice
    GraphicsDevice类描述了在特定图形环境中可能可用的图形设备。
    GraphicsDevice.WindowTranslucency
    底层系统支持的半透明度。
    GraphicsEnvironment
    GraphicsEnvironment类描述了可用于特定平台上的Java（tm）应用程序的GraphicsDevice对象和Font对象的集合。
    GridBagConstraints
    GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。
    GridBagLayoutInfo
    GridBagLayoutInfo是一个用于 GridBagLayout布局管理器的实用程序类。
    HeadlessException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    ImageCapabilities
    图像的能力和属性。
    Insets
    一个 Insets对象是容器边框的表示。
    ItemSelectable
    可以选择包含零个或多个项目的对象的对象接口。
    JobAttributes
    一组控制打印作业的属性。
    JobAttributes.DefaultSelectionType
    可能的默认选择状态的类型安全枚举。
    JobAttributes.DestinationType
    可能的工作目的地的类型安全枚举。
    JobAttributes.DialogType
    可以显示给用户的可能对话框的类型安全枚举。
    JobAttributes.MultipleDocumentHandlingType
    可能的多重复制处理状态的类型安全枚举。
    JobAttributes.SidesType
    可能的多页面强制的类型安全枚举。
    KeyboardFocusManager
    KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。
    KeyEventDispatcher
    KeyEventDispatcher与所有KeyEvents的目标和调度中的当前KeyboardFocusManager配合使用。
    KeyEventPostProcessor
    KeyEventPostProcessor与所有未消耗的KeyEvents的最终分辨率中的当前KeyboardFocusManager配合使用。
    LayoutManager
    定义知道如何布置 Container的类的界面。
    LayoutManager2
    为知道如何根据布局约束对象布局容器的类定义接口。
    List
    List组件向用户呈现文本项的滚动列表。
    Menu
    Menu对象是从菜单栏部署的下拉菜单组件。
    Menu.AccessibleAWTMenu
    菜单的内部类用于提供对辅助功能的默认支持。
    MenuBar
    MenuBar类封装了平台的框架结构的菜单栏的概念。
    MenuComponent
    抽象类 MenuComponent是所有菜单相关组件的超类。
    MenuComponent.AccessibleAWTMenuComponent
    内部类别 MenuComponent用于提供对辅助功能的默认支持。
    MenuContainer
    所有菜单相关容器的超类。
    MenuItem
    菜单中的所有项目必须属于类别 MenuItem或其子类之一。
    MenuItem.AccessibleAWTMenuItem
    MenuItem的内部类用于为辅助功能提供默认支持。
    MenuShortcut
    MenuShortcut类代表一个MenuItem的键盘加速器。
    MultipleGradientPaint
    这是Paints的超类，它使用多色渐变填充其栅格。
    MultipleGradientPaint.ColorSpaceType
    执行渐变插值的颜色空间。
    MultipleGradientPaint.CycleMethod
    绘画之外使用的方法边界渐变。
    PageAttributes
    一组控制打印页面输出的属性。
    PageAttributes.ColorType
    可能的颜色状态的类型安全枚举。
    PageAttributes.MediaType
    可能的纸张尺寸的类型安全枚举。
    PageAttributes.OrientationRequestedType
    可能的方向的类型安全的枚举。
    PageAttributes.OriginType
    可能来源的类型安全枚举。
    PageAttributes.PrintQualityType
    可能的打印质量的类型安全枚举。
    Paint
    这个Paint接口定义了如何为Graphics2D操作生成颜色模式。
    PaintContext
    PaintContext接口定义了封装和优化的环境，以在Graphics2D中为填充或笔画操作生成设备空间中的颜色模式。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    PointerInfo
    描述指针位置的类。
    Polygon
    Polygon类封装了坐标空间内封闭的二维区域的描述。
    PopupMenu
    一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
    PrintJob
    一个启动和执行打印作业的抽象类。
    Rectangle
    A Rectangle指定由坐标空间中的 Rectangle对象的左上点 (x,y)的坐标空间中的区域，其宽度及其高度。
    RenderingHints
    RenderingHints类定义和管理密钥和相关值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。
    RenderingHints.Key
    定义与RenderingHints类一起使用的所有键的基本类型，以控制渲染和成像管道中的各种算法选择。
    SecondaryLoop
    一个辅助接口来运行嵌套事件循环。
    Shape
    Shape界面提供了表示某种形式的几何形状的对象的定义。
    SplashScreen
    在Java虚拟机（JVM）启动之前，启动屏幕可以在应用程序启动时显示。
    Stroke
    Stroke接口允许一个Graphics2D对象获得270498849824464的装饰轮廓或轮廓的风格表示的Shape 。
    SystemColor
    封装代表系统上本地GUI对象颜色的符号颜色的类。
    SystemTray
    SystemTray类代表桌面的系统托盘。
    Taskbar
    Taskbar类允许Java应用程序与系统任务区（任务栏，Dock等）进行交互。
    Taskbar.Feature
    提供功能列表
    Taskbar.State
    可用窗口进度的种类状态。
    TextComponent
    TextComponent类是允许编辑某些文本的任何组件的超类。
    TextComponent.AccessibleAWTTextComponent
    该类实现 TextComponent类的可访问性支持。
    Toolkit
    这个类是抽象窗口工具包的所有实际实现的抽象超类。
    Transparency
    Transparency接口定义了实现类的通用透明度模式。
    TrayIcon
    A TrayIcon对象表示可以添加到system tray的托盘图标。
    TrayIcon.MessageType
    消息类型确定在消息的标题中将显示哪个图标，以及在显示时消息可能产生的可能的系统声音。
    Window
    一个 Window对象是没有边框的顶级窗口，没有菜单。
    Window.AccessibleAWTWindow
    这个类实现 Window类的可访问性支持。
    Window.Type
    枚举可用的 窗口类型 。
  • Classes in java.awt used by java.awt.dnd
    Class 描述
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Cursor
    封装鼠标光标位图表示的类。
    HeadlessException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    Insets
    Insets对象是容器边框的表示。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
  • Classes in java.awt used by java.awt.event
    Class 描述
    ActiveEvent
    一个知道如何发送自己的事件的界面。
    Adjustable
    具有可调整数值的对象的界面包含在有限范围内的值。
    AWTEvent
    所有AWT事件的根事件类。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    ItemSelectable
    可以选择包含零个或多个项目的对象的对象接口。
    Point
    一个表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的区域，其宽度及其高度。
    Window
    一个 Window对象是没有边框的顶级窗口，没有菜单。
  • Classes in java.awt used by java.awt.font
    Class 描述
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上角 (x,y)的坐标空间中的区域，其宽度及其高度。
    Shape
    Shape界面提供了表示某种形式的几何形状的对象的定义。
  • Classes in java.awt used by java.awt.geom
    Class 描述
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)在坐标空间，其宽度及其高度中包围的区域。
    Shape
    Shape接口为表示某种形状的几何形状的对象提供定义。
  • Classes in java.awt used by java.awt.im
    Class 描述
    AWTEvent
    所有AWT事件的根事件类。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Rectangle
    A Rectangle指定坐标空间中由坐标空间中的 Rectangle对象的左上点 (x,y)的区域，其宽度及其高度。
  • Classes in java.awt used by java.awt.im.spi
    Class 描述
    AWTEvent
    所有AWT事件的根事件类。
    AWTException
    表示发生抽象窗口工具包异常。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的一个区域，其宽度及其高度。
    Window
    一个 Window对象是没有边框的顶级窗口，没有菜单。
  • Classes in java.awt used by java.awt.image
    Class 描述
    BufferCapabilities
    缓冲区的功能和属性。
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及离屏图像。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    GraphicsConfiguration
    GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特征。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    ImageCapabilities
    图像的能力和属性。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的区域，其宽度及其高度。
    RenderingHints
    RenderingHints类定义和管理密钥和相关值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。
    Transparency
    Transparency接口定义了实现类的通用透明度模式。
  • Classes in java.awt used by java.awt.image.renderable
    Class 描述
    RenderingHints
    RenderingHints类定义和管理密钥和相关值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。
    Shape
    Shape界面为表示某种形式的几何形状的对象提供了定义。
  • Classes in java.awt used by java.awt.print
    Class 描述
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及脱离屏幕图像。
    HeadlessException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
  • Classes in java.awt used by java.beans
    Class 描述
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及离屏图像。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上角 (x,y)的坐标空间中的区域，其宽度及其高度。
  • Classes in java.awt used by java.beans.beancontext
    Class 描述
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
  • Classes in java.awt used by javafx.embed.swing
    Class 描述
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及到屏幕外图像上。
    MenuContainer
    所有菜单相关容器的超类。
  • Classes in java.awt used by javax.accessibility
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Cursor
    封装鼠标光标位图表示的类。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类代表字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，该对象封装了特定屏幕上特定字体渲染的信息。
    IllegalComponentStateException
    表示AWT组件对于请求的操作不在适当的状态。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上角 (x,y)在坐标空间中的区域，其宽度及其高度。
  • Classes in java.awt used by javax.imageio
    Class 描述
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上角 (x,y)的坐标空间中的区域，其宽度及其高度。
  • Classes in java.awt used by javax.print
    Class 描述
    GraphicsConfiguration
    GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特征。
    HeadlessException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
  • Classes in java.awt used by javax.swing
    Class 描述
    Adjustable
    具有可调整数值的对象的界面包含在有限范围内的值。
    AWTKeyStroke
    AWTKeyStroke表示键盘或等效输入设备上的关键动作。
    BasicStroke
    BasicStroke类为图形基元的轮廓定义了一组基本的渲染属性，这些属性使用一个Graphics2D对象，其Stroke属性设置为BasicStroke 。
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.AccessibleAWTComponent
    组件的内部类用于为辅助功能提供默认支持。
    Component.BaselineResizeBehavior
    枚举组件的基准线随着大小变化而改变的常见方式。
    ComponentOrientation
    ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Container.AccessibleAWTContainer
    Container的内部类用于为辅助功能提供默认支持。
    Cursor
    封装鼠标光标位图表示的类。
    DefaultKeyboardFocusManager
    用于AWT应用程序的默认KeyboardFocusManager。
    Dialog
    Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
    Dialog.AccessibleAWTDialog
    该类实现 Dialog类的可访问性支持。
    Dialog.ModalityType
    模态对话框阻止某些顶级窗口的所有输入。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    FocusTraversalPolicy
    FocusTraversalPolicy定义了遍历特定焦点循环根的组件的顺序。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，它将特定字体的渲染信息封装在特定的屏幕上。
    Frame
    A Frame是具有标题和边框的顶级窗口。
    Frame.AccessibleAWTFrame
    这个类实现 Frame类的可访问性支持。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及脱离屏幕图像。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    GraphicsConfiguration
    GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特性。
    HeadlessException
    在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
    IllegalComponentStateException
    表示AWT组件对于请求的操作不在适当的状态。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    Insets
    一个 Insets对象是容器边框的表示。
    ItemSelectable
    可以选择包含零个或多个项目的对象的对象接口。
    KeyboardFocusManager
    KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。
    KeyEventDispatcher
    KeyEventDispatcher与所有KeyEvents的目标和调度中的当前KeyboardFocusManager配合使用。
    KeyEventPostProcessor
    KeyEventPostProcessor与所有未消耗的KeyEvents的最终分辨率中的当前KeyboardFocusManager配合使用。
    LayoutManager
    定义知道如何布置 Container的类的界面。
    LayoutManager2
    为知道如何根据布局约束对象布局容器的类定义接口。
    MediaTracker
    MediaTracker类是一个实用程序类，用于跟踪多个媒体对象的状态。
    MenuContainer
    所有菜单相关容器的超类。
    Paint
    这个Paint接口定义了如何为Graphics2D操作生成颜色模式。
    Panel
    Panel是最简单的容器类。
    Panel.AccessibleAWTPanel
    这个类实现 Panel类的可访问性支持。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的区域，其坐标空间，宽度及其高度。
    Shape
    Shape接口为表示某种形状的几何形状的对象提供了定义。
    Window
    一个 Window对象是没有边框的顶级窗口，没有菜单。
    Window.AccessibleAWTWindow
    这个类实现 Window类的可访问性支持。
  • Classes in java.awt used by javax.swing.border
    Class 描述
    BasicStroke
    所述BasicStroke类定义了一组基本呈现属性为图形基元的轮廓，它们呈现具有的Graphics2D具有其Stroke属性设置此对象BasicStroke 。
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.BaselineResizeBehavior
    枚举组件的基准线随着大小变化而改变的常见方式。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及到屏幕外图像上。
    Insets
    一个 Insets对象是容器边框的表示。
    Paint
    这个Paint接口定义了如何为Graphics2D操作生成颜色模式。
    Rectangle
    甲 Rectangle指定在由所附的坐标空间的区域 Rectangle对象的左上点 (x,y)在坐标空间中，它的宽度和高度可以。
  • Classes in java.awt used by javax.swing.colorchooser
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及到屏幕外图像上。
    MenuContainer
    所有菜单相关容器的超类。
  • Classes in java.awt used by javax.swing.event
    Class 描述
    AWTEvent
    所有AWT事件的根事件类。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
  • Classes in java.awt used by javax.swing.plaf
    Class 描述
    AWTEvent
    所有AWT事件的根事件类。
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.BaselineResizeBehavior
    枚举组件的基准线随着大小变化而改变的常见方式。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及离屏图像。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    Insets
    一个 Insets对象是容器边框的表示。
    Paint
    这个Paint接口定义了如何为Graphics2D操作生成颜色模式。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    甲 Rectangle指定在由所附的坐标空间的区域 Rectangle对象的左上点 (x,y)在坐标空间中，它的宽度和高度可以。
    Transparency
    Transparency接口定义了实现类的通用透明度模式。
  • Classes in java.awt used by javax.swing.plaf.basic
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或者由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.BaselineResizeBehavior
    枚举组件的基准线随着大小变化而改变的常见方式。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Dimension
    Dimension类封装了单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类代表字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，该对象封装了有关在特定屏幕上呈现特定字体的信息。
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及离屏图像。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    GridBagConstraints
    GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。
    Insets
    一个 Insets对象是容器边框的表示。
    ItemSelectable
    可以选择包含零个或多个项目的对象的对象接口。
    LayoutManager
    定义知道如何布置 Container的类的界面。
    LayoutManager2
    为知道如何根据布局约束对象布局容器的类定义接口。
    MenuContainer
    所有菜单相关容器的超类。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)在坐标空间，其宽度及其高度中包围的区域。
    Shape
    Shape接口为表示某种形状的几何形状的对象提供了定义。
    Window
    一个 Window对象是没有边框的顶级窗口，没有菜单。
  • Classes in java.awt used by javax.swing.plaf.metal
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及脱离屏幕图像。
    Insets
    一个 Insets对象是容器边框的表示。
    ItemSelectable
    可以选择包含零个或多个项目的对象的对象接口。
    LayoutManager
    定义知道如何布置 Container的类的界面。
    MenuContainer
    所有菜单相关容器的超类。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上角 (x,y)的坐标空间中的区域，其宽度及其高度。
  • Classes in java.awt used by javax.swing.plaf.multi
    Class 描述
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及到屏幕外的图像上。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上角 (x,y)的坐标空间中的区域，其宽度及其高度。
  • Classes in java.awt used by javax.swing.plaf.nimbus
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或者由ColorSpace标识的任意颜色空间中的颜色。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    Insets
    一个 Insets对象是容器边框的表示。
    LinearGradientPaint
    LinearGradientPaint类提供了一种用线性颜色渐变模式填充Shape的方法。
    RadialGradientPaint
    RadialGradientPaint类提供了一种填充圆形径向颜色渐变图案的形状的方法。
  • Classes in java.awt used by javax.swing.plaf.synth
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，它将特定字体的渲染信息封装在特定的屏幕上。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及屏幕外图像上。
    Insets
    一个 Insets对象是容器边框的表示。
    LayoutManager
    定义知道如何布置 Container的类的界面。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上角 (x,y)在坐标空间中的区域，其宽度及其高度。
  • Classes in java.awt used by javax.swing.table
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或者由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.AccessibleAWTComponent
    组件的内部类用于为辅助功能提供默认支持。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Container.AccessibleAWTContainer
    Container的内部类用于为辅助功能提供默认支持。
    Cursor
    封装鼠标光标位图表示的类。
    Dimension
    Dimension类封装了单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，该对象封装了特定屏幕上特定字体渲染的信息。
    MenuContainer
    所有菜单相关容器的超类。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的区域，坐标空间中的宽度及其高度。
  • Classes in java.awt used by javax.swing.text
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Component.AccessibleAWTComponent
    组件的内部类用于为辅助功能提供默认支持。
    ComponentOrientation
    ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Container.AccessibleAWTContainer
    Container的内部类用于为辅助功能提供默认支持。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类代表字体，用于以可见的方式呈现文本。
    FontMetrics
    FontMetrics类定义了一个字体度量对象，该对象封装了特定屏幕上特定字体呈现的信息。
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及离屏图像。
    Graphics2D
    这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
    Insets
    一个 Insets对象是容器边框的表示。
    MenuContainer
    所有菜单相关容器的超类。
    Point
    表示 (x,y)坐标空间中的位置的点，以整数精度指定。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的一个区域，其宽度及其高度。
    Shape
    Shape界面提供了表示某种形式几何形状的对象的定义。
  • Classes in java.awt used by javax.swing.text.html
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Cursor
    封装鼠标光标位图表示的类。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    Graphics
    Graphics类是用于所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件以及屏幕外图像。
    Image
    抽象类 Image是表示图形图像的所有类的超类。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的区域，其宽度及其高度。
    Shape
    Shape接口为表示某种形式的几何形状的对象提供了定义。
  • Classes in java.awt used by javax.swing.tree
    Class 描述
    Color
    Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
    Component
    组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
    Container
    通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
    Dimension
    Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
    Font
    Font类表示字体，用于以可见的方式呈现文本。
    Graphics
    Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及到屏幕外图像上。
    MenuContainer
    所有菜单相关容器的超类。
    Rectangle
    A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的区域，其坐标空间，宽度及其高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Window (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Window

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
  • All Implemented Interfaces:
    ImageObserver ， MenuContainer ， Serializable ， Accessible
    已知直接子类：
    BasicToolBarUI.DragWindow ， Dialog ， Frame ， JWindow

    public class Window
extends Container
implements Accessible
    一个Window对象是没有边框的顶级窗口，没有菜单。 窗口的默认布局为BorderLayout 。

    构建窗口时，窗口必须有一个框架，对话框或其他窗口，作为其所有者。

    在多屏幕环境中，你可以创建一个Window通过构建不同的屏幕设备上Window与Window(Window, GraphicsConfiguration) 。 GraphicsConfiguration对象是目标屏幕设备的GraphicsConfiguration对象之一。

    在桌面区域可跨越多个物理屏幕设备的虚拟设备多屏幕环境中，所有配置的边界都相对于虚拟设备坐标系。 虚拟坐标系的原点位于主物理屏幕的左上角。 根据虚拟设备中主屏幕的位置，可以使用负坐标，如下图所示。

    在这样的环境中，当调用setLocation ，必须将虚拟坐标传递给此方法。 同样，调用getLocationOnScreen上Window返回虚拟设备坐标。 调用getBounds一个方法GraphicsConfiguration找到它的起源在虚拟坐标系统相同。

    下面的代码设定的位置Window在（10，10）相对于所述相应的物理屏幕的原点GraphicsConfiguration 。 如果不考虑GraphicsConfiguration的边界，则Window位置将相对于虚拟坐标系设置为（10,10），并将出现在主物理屏幕上，这可能与物理屏幕不同指定GraphicsConfiguration 。

      Window w = new Window(Window owner, GraphicsConfiguration gc);
      Rectangle bounds = gc.getBounds();
      w.setLocation(10 + bounds.x, 10 + bounds.y);

    注意：顶级窗口的位置和大小（包括Window s， Frame s和Dialog ）位于桌面窗口管理系统的控制之下。 调用setLocation ， setSize ，并setBounds是转发到窗口管理系统的请求（不是指令）。 将竭尽全力履行这些要求。 然而，在某些情况下，窗口管理系统可能会忽略此类请求，或修改所请求的几何，以便以更符合桌面设置的方式放置和Window 。

    由于本地事件处理的异步特性，结果被返回getBounds ， getLocation ， getLocationOnScreen ，并getSize直到最后请求已被处理，可能不反映屏幕上Window的实际几何结构。 在处理后续请求期间，窗口管理系统满足请求时，这些值可能会相应地更改。

    应用程序可以任意设置不可见的Window的大小和位置，但是当Window可见时，窗口管理系统随后可以改变其大小和/或位置。 将生成一个或多个ComponentEvent s来指示新几何。

    Windows能够生成以下WindowEvents：WindowOpened，WindowClosed，WindowGainedFocus，WindowLostFocus。

    从以下版本开始：
    1.0
    另请参见：
    WindowEvent ， addWindowListener(java.awt.event.WindowListener) ， BorderLayout ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  Window.AccessibleAWTWindow
      该类为 Window类实现可访问性支持。
      static class  Window.Type
      枚举可用的 窗口类型 。

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      构造方法
      Constructor 描述
      Window​(Frame owner)
      构造一个新的，最初不可见的窗口，其中指定的 Frame为 Frame 。
      Window​(Window owner)
      构造一个新的，最初不可见的窗口，其指定的 Window作为其所有者。
      Window​(Window owner, GraphicsConfiguration gc)
      构造一个新的，最初不可见的窗口，其中指定的所有者为 Window和屏幕设备的 GraphicsConfiguration 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addNotify​()
      通过创建与其本机屏幕资源的连接，使此窗口可显示。
      void addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void addWindowFocusListener​(WindowFocusListener l)
      添加指定的窗口焦点侦听器以从此窗口接收窗口事件。
      void addWindowListener​(WindowListener l)
      添加指定的窗口侦听器以从此窗口接收窗口事件。
      void addWindowStateListener​(WindowStateListener l)
      添加指定的窗口状态侦听器以从此窗口接收窗口事件。
      void applyResourceBundle​(String rbName)
      已过时。
      截至J2SE 1.4，由Component.applyComponentOrientation替代。
      void applyResourceBundle​(ResourceBundle rb)
      已过时。
      截至J2SE 1.4，由Component.applyComponentOrientation替代。
      void createBufferStrategy​(int numBuffers)
      为此组件创建一个新的多缓冲策略。
      void createBufferStrategy​(int numBuffers, BufferCapabilities caps)
      在此组件上创建一个新策略，以实现所需的缓冲功能。
      void dispose​()
      释放此 Window及其子组件及其所有子集所使用的所有本地屏幕资源。
      AccessibleContext getAccessibleContext​()
      获取与此窗口关联的AccessibleContext。
      Color getBackground​()
      获取此窗口的背景颜色。
      BufferStrategy getBufferStrategy​()
      返回此组件使用的 BufferStrategy 。
      boolean getFocusableWindowState​()
      如果满足 isFocusableWindow列出的其他要求，则返回此窗口是否可以成为关注窗口。
      Container getFocusCycleRootAncestor​()
      始终返回null因为Windows没有祖先; 它们代表组件层次结构的顶部。
      Component getFocusOwner​()
      如果此窗口被聚焦，则返回此窗口的具有焦点的子组件; 否则返回null。
      Set<AWTKeyStroke> getFocusTraversalKeys​(int id)
      获取此窗口的焦点遍历键。
      List<Image> getIconImages​()
      返回要显示为此窗口的图标的图像序列。
      InputContext getInputContext​()
      获取此窗口的输入上下文。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，此 Window 。
      Locale getLocale​()
      获取与此窗口相关联的 Locale对象（如果已设置了语言环境）。
      Dialog.ModalExclusionType getModalExclusionType​()
      返回此窗口的模态排除类型。
      Component getMostRecentFocusOwner​()
      返回此窗口的子组件，该窗口将在此窗口聚焦时接收焦点。
      float getOpacity​()
      返回窗口的不透明度。
      Window[] getOwnedWindows​()
      返回一个包含此窗口当前拥有的所有窗口的数组。
      Window getOwner​()
      返回此窗口的所有者。
      static Window[] getOwnerlessWindows​()
      返回由此应用程序创建的，没有所有者的所有 Window的数组。
      Shape getShape​()
      返回窗口的形状。
      Toolkit getToolkit​()
      返回此框架的工具包。
      Window.Type getType​()
      返回窗口的类型。
      String getWarningString​()
      获取此窗口显示的警告字符串。
      WindowFocusListener[] getWindowFocusListeners​()
      返回在此窗口上注册的所有窗口焦点侦听器的数组。
      WindowListener[] getWindowListeners​()
      返回在此窗口上注册的所有窗口侦听器的数组。
      static Window[] getWindows​()
      返回由本应用程序创建的所有拥有和无主的 Window的数组。
      WindowStateListener[] getWindowStateListeners​()
      返回在此窗口上注册的所有窗口状态侦听器的数组。
      void hide​()
      已过时。
      从JDK版本1.5开始，替换为setVisible(boolean) 。
      boolean isActive​()
      返回此窗口是否处于活动状态。
      boolean isAlwaysOnTop​()
      返回此窗口是否为始终在上的窗口。
      boolean isAlwaysOnTopSupported​()
      返回此窗口是否支持始终在线模式。
      boolean isAutoRequestFocus​()
      返回此窗口是否应该随后显示焦点（调用 setVisible(true) ）或被移动到前面（调用 toFront() ）。
      boolean isFocusableWindow​()
      返回此窗口是否可以成为关注的窗口，也就是说，此窗口或其任何子组件是否可以成为焦点所有者。
      boolean isFocusCycleRoot​()
      始终返回 true因为所有Windows都必须是焦点遍历循环的根。
      boolean isFocused​()
      返回此窗口是否聚焦。
      boolean isLocationByPlatform​()
      如果此窗口在下一次此窗口可见时，此窗口将显示在本机窗口系统的默认位置，则返回 true 。
      boolean isOpaque​()
      指示窗口当前是否不透明。
      boolean isShowing​()
      检查此窗口是否在屏幕上显示。
      boolean isValidateRoot​()
      指示此容器是否为验证根。
      void pack​()
      使此窗口的大小适合其子组件的首选大小和布局。
      void paint​(Graphics g)
      涂上容器
      boolean postEvent​(Event e)
      已过时。
      由JDK版本1.1替换为dispatchEvent(AWTEvent) 。
      protected void processEvent​(AWTEvent e)
      在此窗口处理事件。
      protected void processWindowEvent​(WindowEvent e)
      通过将窗口事件分派到任何注册的WindowListener对象来处理窗口事件。
      protected void processWindowFocusEvent​(WindowEvent e)
      通过将窗口焦点事件分派到任何已注册的WindowFocusListener对象来处理窗口焦点事件。
      protected void processWindowStateEvent​(WindowEvent e)
      通过将窗口状态事件发送到任何已注册的 WindowStateListener对象来处理窗口状态事件。
      void removeNotify​()
      通过删除其与其本机屏幕资源的连接，使此容器不可显示。
      void removeWindowFocusListener​(WindowFocusListener l)
      删除指定的窗口焦点侦听器，使其不再从此窗口接收窗口事件。
      void removeWindowListener​(WindowListener l)
      删除指定的窗口监听器，使其不再从此窗口接收窗口事件。
      void removeWindowStateListener​(WindowStateListener l)
      删除指定的窗口状态监听器，使其不再从此窗口接收窗口事件。
      void reshape​(int x, int y, int width, int height)
      已过时。
      从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
      void setAlwaysOnTop​(boolean alwaysOnTop)
      设置此窗口是否应始终高于其他窗口。
      void setAutoRequestFocus​(boolean autoRequestFocus)
      设置此窗口是否应该随后显示焦点（调用 setVisible(true) ）或被移动到前面（通过调用 toFront() ）。
      void setBackground​(Color bgColor)
      设置此窗口的背景颜色。
      void setBounds​(int x, int y, int width, int height)
      移动并调整此组件的大小。
      void setBounds​(Rectangle r)
      移动并调整此组件的大小以符合新的边界矩形 r 。
      void setCursor​(Cursor cursor)
      将光标图像设置为指定的光标。
      void setFocusableWindowState​(boolean focusableWindowState)
      设置此窗口是否可以成为关注窗口，如果它符合 isFocusableWindow概述的其他要求。
      void setFocusCycleRoot​(boolean focusCycleRoot)
      没有因为Windows必须始终是焦点遍历循环的根源。
      void setIconImage​(Image image)
      将要显示的图像设置为此窗口的图标。
      void setIconImages​(List<? extends Image> icons)
      设置要显示为该窗口的图标的图像序列。
      void setLocation​(int x, int y)
      将此组件移动到新位置。
      void setLocation​(Point p)
      将此组件移动到新位置。
      void setLocationByPlatform​(boolean locationByPlatform)
      设置此窗口是否应显示在本机窗口系统的默认位置或当前位置（由 getLocation返回）下一次窗口可见时。
      void setLocationRelativeTo​(Component c)
      根据以下情况设置窗口相对于指定组件的位置。
      void setMinimumSize​(Dimension minimumSize)
      将此窗口的最小大小设置为常量值。
      void setModalExclusionType​(Dialog.ModalExclusionType exclusionType)
      指定此窗口的模态排除类型。
      void setOpacity​(float opacity)
      设置窗口的不透明度。
      void setShape​(Shape shape)
      设置窗口的形状。
      void setSize​(int width, int height)
      调整此组件的大小，使其宽度为 width ，高度为 height 。
      void setSize​(Dimension d)
      调整此组件的大小，使其宽度为 d.width ，高度为 d.height 。
      void setType​(Window.Type type)
      设置窗口的类型。
      void setVisible​(boolean b)
      显示或隐藏此 Window取决于参数的值 b 。
      void show​()
      已过时。
      从JDK版本1.5开始，由setVisible(boolean)替换。
      void toBack​()
      如果此窗口可见，则将此窗口发送到后面，如果该窗口是聚焦窗口或活动窗口，则可能导致其失去焦点或激活。
      void toFront​()
      如果此窗口可见，将此窗口放在前面，并可能使其成为聚焦窗口。

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, requestFocusInWindow, resize, resize, revalidate, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setMaximumSize, setMixingCutoutShape, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Window

        public Window​(Frame owner)
        构造一个新的，最初不可见的窗口，其中指定的是Frame作为其所有者。 除非其所有者显示在屏幕上，否则该窗口将不会对焦。

        如果有一个安全管理器集，它被调用来检查AWTPermission("showWindowWithoutWarningBanner") 。 如果该检查失败，并使用SecurityException则会创建警告SecurityException 。

        参数
        owner - Frame作为所有者或 null如果这个窗口没有所有者
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是从屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless返回 true
        另请参见：
        GraphicsEnvironment.isHeadless() ， isShowing()

      • Window

        public Window​(Window owner)
        构造一个新的，最初看不见的窗口，其指定的Window为Window 。 除非最近拥有Frame或Dialog在屏幕上显示，否则此窗口将不会被Dialog 。

        如果有一个安全管理器集，它被调用来检查AWTPermission("showWindowWithoutWarningBanner") 。 如果该检查失败并使用SecurityException则会创建一个警告横幅。

        参数
        owner - Window作为所有者或 null如果这个窗口没有所有者
        异常
        IllegalArgumentException - 如果 owner的 GraphicsConfiguration不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.2
        另请参见：
        GraphicsEnvironment.isHeadless() ， isShowing()

      • Window

        public Window​(Window owner,
              GraphicsConfiguration gc)
        构造一个新的，最初不可见的窗口，其中指定的所有者为Window和屏幕设备的GraphicsConfiguration 。 除非最近拥有的Frame或Dialog在屏幕上显示，否则窗口将不会Dialog 。

        如果有一个安全管理器设置，它被调用来检查AWTPermission("showWindowWithoutWarningBanner") 。 如果该检查失败并使用SecurityException则会创建一个警告横幅。

        参数
        owner - 作为所有者的窗口或 null如果此窗口没有所有者
        gc - 目标屏幕设备的GraphicsConfiguration ; 如果gc是null ，系统默认GraphicsConfiguration
        异常
        IllegalArgumentException - 如果 gc不是来自屏幕设备
        HeadlessException - 当 GraphicsEnvironment.isHeadless()返回 true
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless() ，
GraphicsConfiguration.getBounds() ，
isShowing()

    • 方法详细信息

      • getIconImages

        public List<Image> getIconImages​()
        返回要显示为此窗口的图标的图像序列。

        此方法返回内部存储的列表的副本，因此返回对象的所有操作都不会影响窗口的行为。

        结果
        该窗口的图标图像列表的副本，如果此窗口没有图标图像，则为空列表。
        从以下版本开始：
        1.6
        另请参见：
        setIconImages(java.util.List<? extends java.awt.Image>) ， setIconImage(Image)

      • setIconImages

        public void setIconImages​(List<? extends Image> icons)
        设置要显示为该窗口的图标的图像序列。 后续拨打getIconImages将永远返回icons列表的副本。

        根据平台功能，将使用不同维度的一个或多个图像作为窗口的图标。

        该icons列表也可以包含MultiResolutionImage图像。 从基座MultiResolutionImage图像中提取取决于屏幕分辨率的合适图像，并将其添加到图标列表，同时从列表中删除基本分辨率图像。 从一开始，将扫描icons列表中最合适尺寸的图像。 如果列表包含几个相同大小的图像，则会使用第一个图像。

        没有图标的无窗窗口使用平台默认图标。 拥有窗口的图标可以从所有者继承，除非明确覆盖。 将图标设置为null或空列表将恢复默认行为。

        注意：根据上下文（例如窗口装饰，窗口列表，任务栏等），本机窗口系统可以使用不同尺寸的不同图像来表示窗口。 他们也可以仅使用单个图像进行所有上下文或根本没有图像。

        参数
        icons - 要显示的图标图像的列表。
        从以下版本开始：
        1.6
        另请参见：
        getIconImages() ， setIconImage(Image)

      • setIconImage

        public void setIconImage​(Image image)
        将要显示的图像设置为此窗口的图标。

        可以使用此方法代替setIconImages()将单个图像指定为窗口的图标。

        以下声明：

          setIconImage(image);
        相当于：
          ArrayList<Image> imageList = new ArrayList<Image>();
     imageList.add(image);
     setIconImages(imageList);

        注意：根据上下文（例如窗口装饰，窗口列表，任务栏等），本机窗口系统可以使用不同尺寸的不同图像来表示窗口。 他们也可以仅使用单个图像进行所有上下文或根本没有图像。

        参数
        image - 要显示的图标图像。
        从以下版本开始：
        1.6
        另请参见：
        setIconImages(java.util.List<? extends java.awt.Image>) ， getIconImages()

      • addNotify

        public void addNotify​()
        通过创建与其本机屏幕资源的连接，使此窗口可显示。 该方法由工具包内部调用，不应由程序直接调用。
        重写：
        addNotify在 Container
        从以下版本开始：
        1.0
        另请参见：
        Component.isDisplayable() ， Container.removeNotify()

      • removeNotify

        public void removeNotify​()
        通过删除其与其本机屏幕资源的连接，使此容器不可显示。 使容器不可显示将导致其所有的孩子都变得不可显示。 该方法在内部被工具包调用，不应该被程序直接调用。
        重写：
        removeNotify在 Container
        另请参见：
        Component.isDisplayable() ， Container.addNotify()

      • pack

        public void pack​()
        使此窗口的大小适合其子组件的首选大小和布局。 如果尺寸小于上一次调用setMinimumSize方法规定的最小尺寸，窗口的宽度和高度将自动放大。

        如果窗口和/或其所有者不可显示，则在计算优选尺寸之前，它们都可显示。 窗口在其大小计算后验证。

        另请参见：
        Component.isDisplayable() ， setMinimumSize(java.awt.Dimension)

      • setMinimumSize

        public void setMinimumSize​(Dimension minimumSize)
        将此窗口的最小大小设置为常量值。 后续调用getMinimumSize将始终返回此值。 如果当前窗口的大小小于minimumSize ，窗口的大小将自动放大，以符合最小尺寸。

        如果setSize或setBounds方法之后被称为宽度或高度小于由setMinimumSize方法指定的方法，窗口将自动放大以满足minimumSize值。 minimumSize值也影响了pack方法的行为。

        通过将最小尺寸参数设置为null值来恢复默认行为。

        如果用户尝试将窗口的大小调整到minimumSize以下的值，则可能会限制调整大小操作。 这种行为是平台依赖的。

        重写：
        setMinimumSize在 Component
        参数
        minimumSize - 这个窗口的最小尺寸
        从以下版本开始：
        1.6
        另请参见：
        Component.setMinimumSize(java.awt.Dimension) ，
Container.getMinimumSize() ，
Component.isMinimumSizeSet() ，
setSize(Dimension) ，
pack()

      • setSize

        public void setSize​(Dimension d)
        调整此组件的大小，使其宽度为d.width ，高度为d.height 。

        该方法更改布局相关信息，因此使组件层次结构无效。

        如果d.width和d.height值都小于先前调用setMinimumSize指定的最小尺寸，则d.width和d.height值将自动放大。

        该方法更改几何相关数据。 因此，本地窗口系统可以忽略这样的请求，或者它可以修改所请求的数据，使得Window对象被放置并且以与桌面设置紧密对应的方式进行调整。

        重写：
        setSize在 Component
        参数
        d - 指定此组件的新大小的维度
        从以下版本开始：
        1.6
        另请参见：
        Component.getSize() ，
setBounds(int, int, int, int) ，
setMinimumSize(java.awt.Dimension)

      • setSize

        public void setSize​(int width,
                    int height)
        调整此组件的大小，使其宽度为width ，高度为height 。

        该方法更改布局相关信息，因此使组件层次结构无效。

        如果width和height值小于以前调用setMinimumSize指定的最小大小，则自动放大width和setMinimumSize 。

        该方法更改几何相关数据。 因此，本地窗口系统可以忽略这样的请求，或者它可以修改所请求的数据，使得Window对象被放置并且以与桌面设置密切对应的方式被Window 。

        重写：
        setSize在 Component
        参数
        width - 该组件的新宽度（以像素为单位）
        height - 该组件的新高度（以像素为单位）
        从以下版本开始：
        1.6
        另请参见：
        Component.getSize() ，
setBounds(int, int, int, int) ，
setMinimumSize(java.awt.Dimension)

      • setLocation

        public void setLocation​(int x,
                        int y)
        将此组件移动到新位置。 新位置的左上角由此组件父项的坐标空间中的x和y参数指定。

        该方法更改布局相关信息，因此使组件层次结构无效。

        该方法更改几何相关数据。 因此，本地窗口系统可以忽略这样的请求，或者它可以修改所请求的数据，使得Window对象被放置并且以与桌面设置密切对应的方式进行调整。

        重写：
        setLocation在 Component
        参数
        x - 父位置坐标空间中新位置左上角的 x坐标
        y - 新位置在父级坐标空间中左上角的 y坐标
        另请参见：
        Component.getLocation() ，
Component.setBounds(int, int, int, int) ，
Component.invalidate()

      • setLocation

        public void setLocation​(Point p)
        将此组件移动到新位置。 新位置的左上角由点p指定。 点p在父协调空间中给出。

        该方法更改布局相关信息，因此使组件层次结构无效。

        该方法更改几何相关数据。 因此，本地窗口系统可以忽略这样的请求，或者它可以修改所请求的数据，使得Window对象被放置并且以与桌面设置紧密对应的方式被Window 。

        重写：
        setLocation在 Component
        参数
        p - 定义新位置左上角的点，在该组件的父级的坐标空间中给出
        另请参见：
        Component.getLocation() ，
Component.setBounds(int, int, int, int) ，
Component.invalidate()

      • reshape

        @Deprecated
public void reshape​(int x,
                    int y,
                    int width,
                    int height)
        已过时。 从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
        描述从类别复制： Component
        重新整形这个组件的边界矩形。
        重写：
        reshape在 Component
        参数
        x - 矩形左上角的 x坐标
        y - 矩形左上角的 y坐标
        width - 矩形的宽度
        height - 矩形的高度

      • setVisible

        public void setVisible​(boolean b)
        显示或隐藏此Window取决于参数的值b 。

        如果方法显示窗口，则在以下条件下也将窗口重点放在：

        • Window符合isFocusableWindow()方法中的要求。
        • 该Window的autoRequestFocus属性是true价值。
        • 本机窗口系统允许Window聚焦。
        第二个条件（ autoRequestFocus属性的值）有一个异常。 如果窗口是模态对话框，则阻止当前关注的窗口，该属性不被考虑。

        除非接收到WINDOW_GAINED_FOCUS或WINDOW_ACTIVATED事件，否则开发人员绝不能假定该窗口是关注或活动的窗口。

        重写：
        setVisible在 Component
        参数
        b - 如果true ，使Window可见，否则隐藏Window 。 如果Window和/或其所有者尚未显示，则两者均可显示。 Window将在被显示之前验证。 如果Window已经可见，这将带来Window到前面。

        如果false ，隐藏这个Window ，它的子组件，以及它所有的所有的孩子。 Window及其子组件可以再次显示，呼叫#setVisible(true) 。

        另请参见：
        Component.isDisplayable() ，
Component.setVisible(boolean) ，
toFront() ，
dispose() ，
setAutoRequestFocus(boolean) ，
isFocusableWindow()

      • show

        @Deprecated
public void show​()
        已过时。 从JDK版本1.5开始，替换为setVisible(boolean) 。
        使窗口可见。 如果窗口和/或其所有者尚未显示，则两者都可显示。 窗口将被显示之前被验证。 如果窗口已经可见，这将使窗口到前面。
        重写：
        show在 Component
        另请参见：
        Component.isDisplayable() ， toFront()

      • hide

        @Deprecated
public void hide​()
        已过时。 自JDK版本1.5起，由setVisible(boolean)替代。
        隐藏此窗口，其子组件及其拥有的所有子项。 窗口及其子组件可以通过调用show再次show 。
        重写：
        hide在 Component
        另请参见：
        show() ， dispose()

      • dispose

        public void dispose​()
        发布此Window ，其子组件及其所有子集所使用的所有本地屏幕资源。 也就是说，这些Component的资源将被破坏，它们消耗的任何内存都将被返回到操作系统，并且它们将被标记为不可显示。

        Window及其子组件可以通过重新生成本地资源，再次调用pack或show 。 重新创建的Window及其子组件的状态将与处理Window处理的这些对象的状态相同（不考虑这些操作之间的其他修改）。

        注意 ：当Java虚拟机（VM）中的最后一个可显示的窗口被丢弃时，VM可能会终止。 详见AWT Threading Issues 。

        另请参见：
        Component.isDisplayable() ，
pack() ，
show()

      • toFront

        public void toFront​()
        如果此窗口可见，将此窗口放在前面，并可能使其成为聚焦窗口。

        将此窗口放置在堆叠顺序的顶部，并将其显示在此VM中任何其他Windows的前面。 如果此窗口不可见，将不会发生任何操作。 某些平台不允许拥有其他Windows的Windows显示在所拥有的Windows之上。 某些平台可能不允许此虚拟机将Windows位于本机应用程序的Windows或其他虚拟机的Windows上。 此权限可能取决于此VM中的窗口是否已经聚焦。 每次尝试将堆叠顺序中的该窗口移动到尽可能高的位置; 然而，开发人员不应该假设这种方法将在所有情况下将此窗口移到所有其他窗口之上。

        开发人员绝对不能假定此Window是焦点或活动的窗口，直到此窗口收到WINDOW_GAINED_FOCUS或WINDOW_ACTIVATED事件为止。 在最上面的窗口是关注窗口的平台上，在以下条件下，此方法可能会将此窗口（如果尚未集中）集中起来：

        • 窗口符合isFocusableWindow()方法中概述的要求。
        • 该窗口的属性autoRequestFocus是true价值。
        • 本机窗口系统允许窗口聚焦。
        在堆叠顺序通常不会影响聚焦窗口的平台上，此方法可能会使焦点和活动窗口保持不变。

        如果此方法导致此窗口被聚焦，并且此窗口是框架或对话框，它也将被激活。 如果此窗口被聚焦，但它不是框架或对话框，那么作为此窗口的所有者的第一个框架或对话框将被激活。

        如果此窗口被模态对话框阻止，则阻止对话框将显示在前面并保留在阻止窗口的上方。

        另请参见：
        toBack() ， setAutoRequestFocus(boolean) ， isFocusableWindow()

      • toBack

        public void toBack​()
        如果此窗口可见，则将此窗口发送到后面，如果该窗口是聚焦窗口或活动窗口，则可能导致其失去焦点或激活。

        将此窗口放置在堆叠顺序的底部，并将其显示在此VM中的任何其他Windows之后。 这个窗口不可见，不会发生任何动作。 某些平台不允许其他Windows拥有的Windows显示在其所有者的下方。 每次尝试将堆叠顺序中的窗口移动到尽可能低的位置; 然而，开发人员不应该假设这种方法会将Window在所有其他窗口中移动到所有情况。

        由于本机窗口系统的变化，不能保证关注和活动的Windows的更改。 开发人员绝对不能假定此窗口不再是聚焦或活动窗口，直到此窗口收到WINDOW_LOST_FOCUS或WINDOW_DEACTIVATED事件为止。 在最上面的窗口是关注窗口的平台上，这种方法可能会导致此窗口失去焦点。 在这种情况下，这个VM中的下一个最高的可调焦窗口将会得到关注。 在堆叠顺序通常不会影响聚焦窗口的平台上，此方法可能会使焦点和活动窗口保持不变。

        另请参见：
        toFront()

      • getToolkit

        public Toolkit getToolkit​()
        返回此框架的工具包。
        重写：
        getToolkit在 Component
        结果
        这个窗口的工具包。
        另请参见：
        Toolkit ， Toolkit.getDefaultToolkit() ， Component.getToolkit()

      • getWarningString

        public final String getWarningString​()
        获取此窗口显示的警告字符串。 如果此窗口不安全，警告字符串将显示在窗口的可见区域的某处。 如果有安全管理员，安全管理员否认AWTPermission("showWindowWithoutWarningBanner") ，则窗口不安全。

        如果窗口是安全的，那么getWarningString返回null 。 如果窗口不安全，则此方法将检查系统属性awt.appletWarning并返回该属性的字符串值。

        结果
        该窗口的警告字符串。

      • getLocale

        public Locale getLocale​()
        获取与此窗口相关联的Locale对象，如果已设置了区域设置。 如果没有设置语言环境，则返回默认语言环境。
        重写：
        getLocale在 Component
        结果
        为此窗口设置的区域设置。
        从以下版本开始：
        1.1
        另请参见：
        Locale

      • getInputContext

        public InputContext getInputContext​()
        获取此窗口的输入上下文。 窗口总是有一个输入上下文，它由子组件共享，除非它们创建并设置自己的。
        重写：
        getInputContext在 Component
        结果
        该组件使用的输入上下文; null如果没有上下文可以确定
        从以下版本开始：
        1.2
        另请参见：
        Component.getInputContext()

      • setCursor

        public void setCursor​(Cursor cursor)
        将光标图像设置为指定的光标。

        如果Java平台实现和/或本地系统不支持更改鼠标光标的形状，该方法可能没有视觉效果。

        重写：
        setCursor在 Component
        参数
        cursor - 由Cursor类定义的常量Cursor 。 如果此参数为空，则此窗口的光标将设置为Cursor.DEFAULT_CURSOR类型。
        从以下版本开始：
        1.1
        另请参见：
        Component.getCursor() ， Cursor

      • getOwner

        public Window getOwner​()
        返回此窗口的所有者。
        结果
        这个窗口的所有者
        从以下版本开始：
        1.2

      • getOwnedWindows

        public Window[] getOwnedWindows​()
        返回一个包含此窗口当前拥有的所有窗口的数组。
        结果
        所有所有窗口的阵列
        从以下版本开始：
        1.2

      • getWindows

        public static Window[] getWindows​()
        返回由该应用程序创建的所有Window s的数组，包括拥有和无主。 如果从小程序调用，该数组只包含该小程序可访问的Window 。

        警告：此方法可能会返回系统创建的窗口，如打印对话框。 应用程序不应该假定这些对话框的存在，应用程序也不应该假定任何关于这些对话框，如组件位置， LayoutManager或序列化。

        结果
        由应用程序创建的所有 Window的阵列
        从以下版本开始：
        1.6
        另请参见：
        Frame.getFrames() ， getOwnerlessWindows()

      • getOwnerlessWindows

        public static Window[] getOwnerlessWindows​()
        返回由此应用程序创建的所有Window的数组，该数组没有所有者。 它们包括Frame和Dialog s和Window s。 如果从小程序调用，该数组只包含该小程序可访问的Window 。

        警告：此方法可能会返回系统创建的窗口，如打印对话框。 应用程序不应该假定这些对话框存在，也不应该假定这些对话框如组件位置，任何LayoutManager或序列化。

        结果
        由该应用程序创建的所有无主的 Window的阵列
        从以下版本开始：
        1.6
        另请参见：
        Frame.getFrames() ， getWindows()

      • setModalExclusionType

        public void setModalExclusionType​(Dialog.ModalExclusionType exclusionType)
        指定此窗口的模态排除类型。 如果窗口被模式排除，则不会被某些模态对话框阻止。 有关可能的模式排除类型，请参阅Dialog.ModalExclusionType 。

        如果不支持给定类型，则使用NO_EXCLUDE 。

        注意：更改可见窗口的模式排除类型可能不会有任何效果，直到它被隐藏，然后再次显示。

        参数
        exclusionType - 此窗口的模态排除类型 一个null值相当于NO_EXCLUDE
        异常
        SecurityException - 如果调用线程没有权限将模式排除属性设置为给定的窗口与 exclusionType
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalExclusionType ， getModalExclusionType() ， Toolkit.isModalExclusionTypeSupported(java.awt.Dialog.ModalExclusionType)

      • getModalExclusionType

        public Dialog.ModalExclusionType getModalExclusionType​()
        返回此窗口的模态排除类型。
        结果
        此窗口的模态排除类型
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalExclusionType ， setModalExclusionType(java.awt.Dialog.ModalExclusionType)

      • addWindowListener

        public void addWindowListener​(WindowListener l)
        添加指定的窗口侦听器以从此窗口接收窗口事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 窗口监听器
        另请参见：
        removeWindowListener(java.awt.event.WindowListener) ， getWindowListeners()

      • addWindowStateListener

        public void addWindowStateListener​(WindowStateListener l)
        添加指定的窗口状态侦听器以从此窗口接收窗口事件。 如果l为null ，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 窗口状态侦听器
        从以下版本开始：
        1.4
        另请参见：
        removeWindowStateListener(java.awt.event.WindowStateListener) ， getWindowStateListeners()

      • addWindowFocusListener

        public void addWindowFocusListener​(WindowFocusListener l)
        添加指定的窗口焦点侦听器以从此窗口接收窗口事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 窗口焦点侦听器
        从以下版本开始：
        1.4
        另请参见：
        removeWindowFocusListener(java.awt.event.WindowFocusListener) ， getWindowFocusListeners()

      • removeWindowListener

        public void removeWindowListener​(WindowListener l)
        删除指定的窗口监听器，使其不再从此窗口接收窗口事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 窗口监听器
        另请参见：
        addWindowListener(java.awt.event.WindowListener) ， getWindowListeners()

      • removeWindowStateListener

        public void removeWindowStateListener​(WindowStateListener l)
        删除指定的窗口状态监听器，使其不再从此窗口接收窗口事件。 如果l为null ，则不会抛出异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 窗口状态侦听器
        从以下版本开始：
        1.4
        另请参见：
        addWindowStateListener(java.awt.event.WindowStateListener) ， getWindowStateListeners()

      • removeWindowFocusListener

        public void removeWindowFocusListener​(WindowFocusListener l)
        删除指定的窗口焦点侦听器，使其不再从此窗口接收窗口事件。 如果l为空，则不会抛出任何异常，也不会执行任何操作。

        有关AWT线程模型的详细信息，请参阅AWT Threading Issues 。

        参数
        l - 窗口焦点侦听器
        从以下版本开始：
        1.4
        另请参见：
        addWindowFocusListener(java.awt.event.WindowFocusListener) ， getWindowFocusListeners()

      • getWindowListeners

        public WindowListener[] getWindowListeners​()
        返回在此窗口上注册的所有窗口侦听器的数组。
        结果
        所有这个窗口的 WindowListener s或一个空数组，如果没有窗口监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addWindowListener(java.awt.event.WindowListener) ， removeWindowListener(java.awt.event.WindowListener)

      • getWindowFocusListeners

        public WindowFocusListener[] getWindowFocusListeners​()
        返回在此窗口上注册的所有窗口焦点侦听器的数组。
        结果
        所有这个窗口的 WindowFocusListener s或一个空数组，如果没有窗口焦点侦听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addWindowFocusListener(java.awt.event.WindowFocusListener) ， removeWindowFocusListener(java.awt.event.WindowFocusListener)

      • getWindowStateListeners

        public WindowStateListener[] getWindowStateListeners​()
        返回在此窗口上注册的所有窗口状态侦听器的数组。
        结果
        所有这个窗口的 WindowStateListener s或一个空数组，如果没有窗口状态监听器当前注册
        从以下版本开始：
        1.4
        另请参见：
        addWindowStateListener(java.awt.event.WindowStateListener) ， removeWindowStateListener(java.awt.event.WindowStateListener)

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        返回当前注册为FooListener的所有对象的数组Window 。 FooListener使用addFooListener方法进行注册。

        您可以使用类文字指定listenerType参数，如FooListener.class 。 例如，您可以使用以下代码查询Window w的窗口侦听器：

          WindowListener[] wls = (WindowListener[])(w.getListeners(WindowListener.class));
        如果没有这样的侦听器存在，这个方法返回一个空数组。
        重写：
        getListeners在 Container
        参数类型
        T - 听众的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在此窗口上注册为 FooListener的所有对象的数组，如果没有添加此类侦听器，则为空数组
        异常
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        NullPointerException - 如果 listenerType为 null
        从以下版本开始：
        1.3
        另请参见：
        getWindowListeners()

      • processEvent

        protected void processEvent​(AWTEvent e)
        在此窗口处理事件。 如果事件是一个WindowEvent ，它调用processWindowEvent方法，否则它调用其超类的processEvent 。

        请注意，如果事件参数为null该行为是未指定的，可能会导致异常。

        重写：
        processEvent在 Container
        参数
        e - 事件
        另请参见：
        Component.processComponentEvent(java.awt.event.ComponentEvent) ，
Component.processFocusEvent(java.awt.event.FocusEvent) ，
Component.processKeyEvent(java.awt.event.KeyEvent) ，
Component.processMouseEvent(java.awt.event.MouseEvent) ，
Component.processMouseMotionEvent(java.awt.event.MouseEvent) ，
Component.processInputMethodEvent(java.awt.event.InputMethodEvent) ，
Component.processHierarchyEvent(java.awt.event.HierarchyEvent) ，
Component.processMouseWheelEvent(java.awt.event.MouseWheelEvent)

      • processWindowEvent

        protected void processWindowEvent​(WindowEvent e)
        通过将窗口事件分派到任何注册的WindowListener对象来处理窗口事件。 注意：除非为此组件启用窗口事件，否则不会调用此方法; 发生以下情况之一时：
        • WindowListener对象通过addWindowListener注册
        • 窗口事件通过enableEvents启用

        请注意，如果事件参数为null该行为未指定，并可能导致异常。

        参数
        e - 窗口事件
        另请参见：
        Component.enableEvents(long)

      • processWindowFocusEvent

        protected void processWindowFocusEvent​(WindowEvent e)
        通过将窗口焦点事件分派到任何已注册的WindowFocusListener对象来处理窗口焦点事件。 注意：除非为此窗口启用窗口焦点事件，否则不会调用此方法。 发生以下情况之一时：
        • 一个WindowFocusListener通过addWindowFocusListener注册
        • 窗口焦点事件通过enableEvents启用

        请注意，如果事件参数为null则行为未指定，并可能导致异常。

        参数
        e - 窗口焦点事件
        从以下版本开始：
        1.4
        另请参见：
        Component.enableEvents(long)

      • processWindowStateEvent

        protected void processWindowStateEvent​(WindowEvent e)
        通过将窗口状态事件发送到任何已注册的WindowStateListener对象来处理窗口状态事件。 注意：除非为此窗口启用窗口状态事件，否则不会调用此方法。 发生以下情况之一时：
        • a WindowStateListener已通过addWindowStateListener注册
        • 窗口状态事件通过enableEvents启用

        请注意，如果事件参数为null则行为未指定，可能会导致异常。

        参数
        e - 窗口状态事件
        从以下版本开始：
        1.4
        另请参见：
        Component.enableEvents(long)

      • setAlwaysOnTop

        public final void setAlwaysOnTop​(boolean alwaysOnTop)
                          throws SecurityException
        设置此窗口是否应始终高于其他窗口。 如果有多个永久在线窗口，则它们的相对顺序是未指定的并且依赖于平台。

        如果某些其他窗口已经始终在顶部，则这些窗口之间的相对顺序是未指定的（取决于平台）。 除了可能是另一个永远在上的窗口之外，没有窗户可以被覆盖在始终在上的窗口。

        始终在上的窗口拥有的所有窗口都会继承此状态，并自动变为始终处于顶端状态。 如果一个窗口不再是顶级的，那么它所拥有的窗口将不再一直处于顶端。 当一个始终在上的窗口发送toBack时 ，它的始终在上状态设置为false 。

        当在一个值为true的窗口上调用此方法时，该窗口是可见的，并且该平台在此窗口上始终支持该窗口，该窗口将立即被提起，将其“保持”在最顶端的位置。 如果窗口当前不可见，则该方法将始终处于顶部状态设置为true但不会将窗口向前。 当窗口稍后显示时，它将始终在顶部。

        当在一个值为false的窗口上调用此方法时，始终在顶部状态设置为正常。 它也可能导致顶级窗口的z顺序的未指定的平台依赖性变化，但其他始终在上的窗口将保持在最高位置。 在具有正常状态的窗口上调用此值为false方法不起作用。

        注意 ：某些平台可能不支持永远在线的窗口。 要检测当前平台是否支持始终在线的窗口，请使用Toolkit.isAlwaysOnTopSupported()和isAlwaysOnTopSupported() 。 如果此窗口不支持永远在线模式，或者此窗口的工具包不支持永远在线窗口，则调用此方法不起作用。

        如果安装了SecurityManager，则调用线程必须被授予AWTPermission“setWindowAlwaysOnTop”才能设置此属性的值。 如果未授予此权限，则此方法将抛出SecurityException异常，该属性的当前值将保持不变。

        参数
        alwaysOnTop - 如果窗口应该始终高于其他窗口， alwaysOnTop true
        异常
        SecurityException - 如果调用线程没有设置always-on-top属性的值的权限
        从以下版本开始：
        1.5
        另请参见：
        isAlwaysOnTop() ， toFront() ， toBack() ， AWTPermission ， isAlwaysOnTopSupported() ， getToolkit() ， Toolkit.isAlwaysOnTopSupported()

      • isAlwaysOnTopSupported

        public boolean isAlwaysOnTopSupported​()
        返回此窗口是否支持始终在线模式。 某些平台可能不支持永远在线的窗口，有些平台可能只支持某些顶级窗口; 例如，平台可能不支持永远在上的模态对话框。
        结果
        true ，如果此窗口支持始终在线模式，此窗口的工具包支持永远在线窗口，否则为 false
        从以下版本开始：
        1.6
        另请参见：
        setAlwaysOnTop(boolean) ， getToolkit() ， Toolkit.isAlwaysOnTopSupported()

      • isAlwaysOnTop

        public final boolean isAlwaysOnTop​()
        返回此窗口是否为始终在上的窗口。
        结果
        true ，如果窗口处于永远在上状态，否则为 false
        从以下版本开始：
        1.5
        另请参见：
        setAlwaysOnTop(boolean)

      • getFocusOwner

        public Component getFocusOwner​()
        如果此窗口被聚焦，则返回此窗口的具有焦点的子组件; 否则返回null。
        结果
        具有焦点的子组件，如果此窗口未被聚焦，则为null
        另请参见：
        getMostRecentFocusOwner() ， isFocused()

      • getMostRecentFocusOwner

        public Component getMostRecentFocusOwner​()
        返回此窗口的子组件，该窗口将在此窗口聚焦时接收焦点。 如果此窗口当前被聚焦，则此方法返回与getFocusOwner()相同的组件。 如果此窗口未被聚焦，则将返回最近请求焦点的子组件。 如果没有子组件已经请求了焦点，并且这是一个可调焦窗口，则返回此窗口的初始可聚焦组件。 如果没有子组件已经请求了焦点，并且这是一个不可对焦窗口，则返回null。
        结果
        当该窗口聚焦时，将接收焦点的子组件
        从以下版本开始：
        1.4
        另请参见：
        getFocusOwner() ，
isFocused() ，
isFocusableWindow()

      • isActive

        public boolean isActive​()
        返回此窗口是否处于活动状态。 只有框架或对话框可能处于活动状态。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。
        结果
        这是否是活动的窗口。
        从以下版本开始：
        1.4
        另请参见：
        isFocused()

      • isFocused

        public boolean isFocused​()
        返回此窗口是否聚焦。 如果存在焦点所有者，则关注的窗口是该焦点所有者的窗口，或包含该焦点所有者的窗口。 如果没有焦点所有者，则不关注窗口。

        如果对焦窗口是Frame或Dialog，它也是活动窗口。 否则，活动窗口是第一个框架或对话框，它是聚焦窗口的所有者。

        结果
        这是否是关注的窗口。
        从以下版本开始：
        1.4
        另请参见：
        isActive()

      • getFocusTraversalKeys

        public Set<AWTKeyStroke> getFocusTraversalKeys​(int id)
        获取此窗口的焦点遍历键。 （有关每个键的完整说明，请参阅setFocusTraversalKeys ）

        如果没有为此窗口显式设置遍历键，则返回此窗口的父进程的遍历键。 如果没有为任何这个Window的祖先显式设置遍历键，则返回当前的KeyboardFocusManager的默认遍历键。

        重写：
        getFocusTraversalKeys在 Container
        参数
        id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS之一，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS
        结果
        指定键的AWTKeyStroke
        异常
        IllegalArgumentException - 如果id不是KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS，KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS，KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS或KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS中的一个
        从以下版本开始：
        1.4
        另请参见：
        Container.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>) ， KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS ， KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS ， KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS

      • setFocusCycleRoot

        public final void setFocusCycleRoot​(boolean focusCycleRoot)
        没有因为Windows必须始终是焦点遍历循环的根源。 传入值被忽略。
        重写：
        setFocusCycleRoot在 Container
        参数
        focusCycleRoot - 此值被忽略
        从以下版本开始：
        1.4
        另请参见：
        isFocusCycleRoot() ，
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ，
Container.getFocusTraversalPolicy()

      • isFocusCycleRoot

        public final boolean isFocusCycleRoot​()
        始终返回 true因为所有Windows都必须是焦点遍历循环的根。
        重写：
        isFocusCycleRoot在 Container
        结果
        true
        从以下版本开始：
        1.4
        另请参见：
        setFocusCycleRoot(boolean) ， Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy) ， Container.getFocusTraversalPolicy()

      • getFocusCycleRootAncestor

        public final Container getFocusCycleRootAncestor​()
        始终返回null因为Windows没有祖先; 它们代表组件层次结构的顶部。
        重写：
        getFocusCycleRootAncestor在 Component
        结果
        null
        从以下版本开始：
        1.4
        另请参见：
        Container.isFocusCycleRoot()

      • isFocusableWindow

        public final boolean isFocusableWindow​()
        返回此窗口是否可以成为关注的窗口，也就是说，此窗口或其任何子组件是否可以成为焦点所有者。 要使框架或对话框可true ，其true窗口状态必须设置为true 。 对于不是可true框架或对话框的窗口，其可true窗口状态必须设置为true ，其最近拥有的框架或对话框必须在屏幕上显示，并且必须在其焦点遍历循环中至少包含一个组件。 如果没有满足任何这些条件，那么这个Window和它的任何子组件都不能成为焦点所有者。
        结果
        true如果这个窗口可以是关注的窗口; 否则为false
        从以下版本开始：
        1.4
        另请参见：
        getFocusableWindowState() ， setFocusableWindowState(boolean) ， isShowing() ， Component.isFocusable()

      • getFocusableWindowState

        public boolean getFocusableWindowState​()
        如果满足isFocusableWindow概述的其他要求，则返回此窗口是否可以成为关注窗口。 如果此方法返回false ，那么isFocusableWindow也将返回false 。 如果此方法返回true ，则isFocusableWindow可能会返回true或false这取决于必须满足的其他要求才能使窗口可对焦。

        默认情况下，所有Windows都具有true窗口状态true 。

        结果
        这个窗口是否可以被关注的窗口
        从以下版本开始：
        1.4
        另请参见：
        isFocusableWindow() ， setFocusableWindowState(boolean) ， isShowing() ， Component.setFocusable(boolean)

      • setFocusableWindowState

        public void setFocusableWindowState​(boolean focusableWindowState)
        设置此窗口是否可以成为聚焦窗口，如果它符合isFocusableWindow概述的其他要求。 如果此窗口的可false窗口状态设置为false ，则isFocusableWindow将返回false 。 如果此窗口的可true窗口状态设置为true ，则isFocusableWindow可能会返回true或false这取决于isFocusableWindow可true而必须满足的其他要求。

        将窗口的对焦状态设置为false是应用程序向AWT标识将用作浮动调色板或工具栏的窗口的标准机制，因此应该是不可对焦的窗口。 在可见的Window上设置可聚焦状态可能会在某些平台上产生延迟效应 - 仅当Window变得隐藏，然后再次可见时，实际更改可能会发生。 为了确保跨平台的一致行为，当Window不可见时，设置Window状态，然后显示它。

        参数
        focusableWindowState - 这个窗口是否可以是聚焦的窗口
        从以下版本开始：
        1.4
        另请参见：
        isFocusableWindow() ，
getFocusableWindowState() ，
isShowing() ，
Component.setFocusable(boolean)

      • setAutoRequestFocus

        public void setAutoRequestFocus​(boolean autoRequestFocus)
        设置此窗口是否应该随后显示焦点（调用setVisible(true) ）或被移动到前面（通过调用toFront() ）。

        请注意，可以间接调用setVisible(true) （例如，当显示窗口的所有者使窗口显示时）。 toFront()也可以间接调用（例如，当setVisible(true)上调用已经可见窗口）。 在所有这种情况下，此属性也将生效。

        属性的值不是由拥有的窗口继承。

        参数
        autoRequestFocus - 这个窗口是否应该集中在随后被显示或被移动到前面
        从以下版本开始：
        1.7
        另请参见：
        isAutoRequestFocus() ， isFocusableWindow() ， setVisible(boolean) ， toFront()

      • isAutoRequestFocus

        public boolean isAutoRequestFocus​()
        返回此窗口是否应该随后显示焦点（调用setVisible(true) ）或被移动到前面（调用toFront() ）。

        默认情况下，窗口有autoRequestFocus值为true 。

        结果
        价值 autoRequestFocus
        从以下版本开始：
        1.7
        另请参见：
        setAutoRequestFocus(boolean)

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        将PropertyChangeListener添加到侦听器列表。 监听器已注册到此类的所有绑定属性，包括以下内容：
        • 这个窗口的字体（“font”）
        • 这个窗口的背景颜色（“background”）
        • 这个窗口的前景色（“前景”）
        • 这个窗口的对焦性（“focusable”）
        • 此窗口的焦点遍历键启用状态（“focusTraversalKeysEnabled”）
        • 此窗口的一组FORWARD_TRAVERSAL_KEYS（“forwardFocusTraversalKeys”）
        • 该窗口的一组BACKWARD_TRAVERSAL_KEYS（“backwardFocusTraversalKeys”）
        • 这个窗口的UP_CYCLE_TRAVERSAL_KEYS（“upCycleFocusTraversalKeys”）
        • 这个窗口的一组DOWN_CYCLE_TRAVERSAL_KEYS（“downCycleFocusTraversalKeys”）
        • 此窗口的焦点遍历策略（“focusTraversalPolicy”）
        • 此窗口的可调焦窗口状态（“focusableWindowState”）
        • 此窗口始终处于顶级状态（“alwaysOnTop”）
        请注意，如果此窗口继承了绑定属性，则不会在继承的属性中更改事件时触发任何事件。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        重写：
        addPropertyChangeListener在 Container
        参数
        listener - 要添加的PropertyChangeListener
        另请参见：
        Component.removePropertyChangeListener(java.beans.PropertyChangeListener) ， addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String propertyName,
                                      PropertyChangeListener listener)
        将PropertyChangeListener添加到特定属性的侦听器列表中。 指定的属性可能是用户定义的，也可能是以下之一：
        • 这个窗口的字体（“font”）
        • 这个窗口的背景颜色（“background”）
        • 这个窗口的前景色（“前景”）
        • 这个窗口的对焦性（“focusable”）
        • 此窗口的焦点遍历键启用状态（“focusTraversalKeysEnabled”）
        • 此窗口的一组FORWARD_TRAVERSAL_KEYS（“forwardFocusTraversalKeys”）
        • 该窗口的一组BACKWARD_TRAVERSAL_KEYS（“backwardFocusTraversalKeys”）
        • 这个窗口的UP_CYCLE_TRAVERSAL_KEYS（“upCycleFocusTraversalKeys”）
        • 这个窗口的一组DOWN_CYCLE_TRAVERSAL_KEYS（“downCycleFocusTraversalKeys”）
        • 此窗口的焦点遍历策略（“focusTraversalPolicy”）
        • 此窗口的可调焦窗口状态（“focusableWindowState”）
        • 此窗口始终处于顶级状态（“alwaysOnTop”）
        请注意，如果此窗口继承了绑定属性，则不会在继承的属性中更改事件时触发任何事件。

        如果侦听器为空，则不会抛出异常，也不会执行任何操作。

        重写：
        addPropertyChangeListener在 Container
        参数
        propertyName - 上面列出的属性名称之一
        listener - 要添加的PropertyChangeListener
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener) ， Component.removePropertyChangeListener(java.beans.PropertyChangeListener)

      • isValidateRoot

        public boolean isValidateRoot​()
        指示此容器是否为验证根。

        Window对象是验证根，因此，它们覆盖此方法以返回true 。

        重写：
        isValidateRoot在 Container
        结果
        true
        从以下版本开始：
        1.7
        另请参见：
        Container.isValidateRoot()

      • postEvent

        @Deprecated
public boolean postEvent​(Event e)
        已过时。 由JDK版本1.1替换为dispatchEvent(AWTEvent) 。
        说明从接口MenuContainer复制
        向事件发送一个事件。
        Specified by:
        postEvent在接口 MenuContainer
        重写：
        postEvent在 Component
        参数
        e - 发送的事件
        结果
        发布事件的结果

      • isShowing

        public boolean isShowing​()
        检查此窗口是否在屏幕上显示。
        重写：
        isShowing在 Component
        结果
        true如果组件显示，否则为 false
        另请参见：
        Component.setVisible(boolean)

      • applyResourceBundle

        @Deprecated
public void applyResourceBundle​(ResourceBundle rb)
        已过时。 截至J2SE 1.4，由Component.applyComponentOrientation取代。
        参数
        rb - 资源束

      • applyResourceBundle

        @Deprecated
public void applyResourceBundle​(String rbName)
        已过时。 截至J2SE 1.4，由Component.applyComponentOrientation替代。
        参数
        rbName - 资源名称

      • setType

        public void setType​(Window.Type type)
        设置窗口的类型。 此方法只能在窗口不可显示时被调用。
        参数
        type - 窗口类型
        异常
        IllegalComponentStateException - 如果窗口可显示。
        IllegalArgumentException - 如果类型是 null
        从以下版本开始：
        1.7
        另请参见：
        Component.isDisplayable() ， getType()

      • getType

        public Window.Type getType​()
        返回窗口的类型。
        结果
        窗口的类型
        从以下版本开始：
        1.7
        另请参见：
        setType(java.awt.Window.Type)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext​()
        获取与此窗口关联的AccessibleContext。 对于Windows，AccessibleContext采用AccessibleAWTWindow的形式。 如有必要，将创建一个新的AccessibleAWTWindow实例。
        Specified by:
        getAccessibleContext在接口 Accessible
        重写：
        getAccessibleContext在 Component
        结果
        一个AccessibleAWTWindow作为该窗口的AccessibleContext
        从以下版本开始：
        1.3

      • setLocationRelativeTo

        public void setLocationRelativeTo​(Component c)
        根据以下情况设置窗口相对于指定组件的位置。

        下面提到的目标屏幕是在调用setLocationRelativeTo方法之后应该放置窗口的屏幕。

        • 如果组件为null ，或与此组件关联的GraphicsConfiguration为null ，则窗口将放置在屏幕的中心。 中心点可以用GraphicsEnvironment.getCenterPoint方法获得。
        • 如果组件不是null ，但它当前没有显示，则窗口将放置在与此组件关联的GraphicsConfiguration定义的目标屏幕的中心。
        • 如果组件不是null并且显示在屏幕上，则窗口的位置使得窗口的中心与组件的中心重合。

        如果屏幕配置不允许将窗口从一个屏幕移动到另一个屏幕，则窗口仅被放置在根据上述条件确定的位置，并且其GraphicsConfiguration不改变GraphicsConfiguration 。

        注意 ：如果窗口的下边缘超出屏幕，则窗口将放置在最靠近屏幕中心的Component侧面。 因此，如果组件位于屏幕的右侧，窗口将放置在左侧，反之亦然。

        如果在计算了窗口位置之后，窗口的上，左或右边缘超出了屏幕，则窗口位于窗口的上，左或右边缘与屏幕的相应边缘。 如果窗口的左边缘和右边缘都不在屏幕之外，窗口将放置在屏幕的左侧。 如果顶部和底部边缘都超出屏幕，则会发生类似的放置。 在这种情况下，窗口被放置在屏幕的顶部。

        该方法更改几何相关数据。 因此，本地窗口系统可以忽略这样的请求，或者它可以修改所请求的数据，使得Window对象被放置并且以与桌面设置紧密对应的方式被Window 。

        参数
        c - 确定窗口位置的组件
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.getCenterPoint()

      • createBufferStrategy

        public void createBufferStrategy​(int numBuffers)
        为此组件创建一个新的多缓冲策略。 多缓冲对于渲染性能很有用。 此方法尝试使用提供的缓冲区数量创建可用的最佳策略。 它将始终使用该数量的缓冲区创建一个BufferStrategy 。 首先尝试翻页策略，然后尝试使用加速缓冲区的策略策略。 最后，使用非加速的制动策略。

        每次调用此方法时，将丢弃此组件的现有缓冲区策略。

        参数
        numBuffers - 要创建的缓冲区数
        异常
        IllegalArgumentException - 如果numBuffers小于1。
        IllegalStateException - 如果组件不可显示
        从以下版本开始：
        1.4
        另请参见：
        Component.isDisplayable() ， getBufferStrategy()

      • createBufferStrategy

        public void createBufferStrategy​(int numBuffers,
                                 BufferCapabilities caps)
                          throws AWTException
        在此组件上创建一个新策略，以实现所需的缓冲功能。 这是有用的，例如，如果只需要加速内存或页面翻转（由缓冲区功能指定）。

        每次调用此方法时，将丢弃此组件的现有缓冲区策略。

        参数
        numBuffers - 要创建的缓冲区数，包括前缓冲区
        caps - 创建缓冲策略所需的功能; 不能是null
        异常
        AWTException - 如果提供的功能不能被支持或满足; 这可能发生，例如，如果当前没有足够的加速内存可用，或者如果指定了页面翻转，但是不可能。
        IllegalArgumentException - 如果numBuffers小于1，或者如果cap是 null
        从以下版本开始：
        1.4
        另请参见：
        getBufferStrategy()

      • getBufferStrategy

        public BufferStrategy getBufferStrategy​()
        返回此组件使用的BufferStrategy 。 如果一个BufferStrategy尚未创建或已被处理，此方法将返回null。
        结果
        该组件使用的缓冲策略
        从以下版本开始：
        1.4
        另请参见：
        createBufferStrategy(int)

      • setLocationByPlatform

        public void setLocationByPlatform​(boolean locationByPlatform)
        设置下一次窗口是否可以显示本窗口系统的默认位置或当前位置（由getLocation返回）。 此行为类似于显示的本机窗口，无需以编程方式设置其位置。 大多数窗口系统如果它们的位置未被明确设置，则级联窗口。 一旦窗口显示在屏幕上，确定实际位置。

        通过将系统属性“java.awt.Window.locationByPlatform”设置为“true”，也可以启用此行为，尽管此方法的调用优先。

        拨打setVisible ， setLocation和setBounds调用后setLocationByPlatform窗口中清除此属性。

        例如，执行以下代码之后：

          setLocationByPlatform(true);
 setVisible(true);
 boolean flag = isLocationByPlatform();
        窗口将显示在平台的默认位置， flag将显示为false 。

        在以下示例中：

          setLocationByPlatform(true);
 setLocation(10, 10);
 boolean flag = isLocationByPlatform();
 setVisible(true);
        窗口将显示为（10,10）， flag将显示为false 。
        参数
        locationByPlatform - true如果这个窗口应该出现在默认位置， false如果在当前位置
        异常
        IllegalComponentStateException - 如果窗口显示在屏幕上，并且位置为 true 。
        从以下版本开始：
        1.5
        另请参见：
        setLocation(int, int) ， isShowing() ， setVisible(boolean) ， isLocationByPlatform() ， System.getProperty(String)

      • isLocationByPlatform

        public boolean isLocationByPlatform​()
        如果此窗口在下一次此窗口可见时，此窗口将显示在本机窗口系统的默认位置，则返回true 。 如果窗口显示在屏幕上，此方法总是返回false 。
        结果
        该窗口是否将显示在默认位置
        从以下版本开始：
        1.5
        另请参见：
        setLocationByPlatform(boolean) ， isShowing()

      • setBounds

        public void setBounds​(int x,
                      int y,
                      int width,
                      int height)
        移动并调整此组件的大小。 左上角的新位置由x和y指定，新尺寸由width和height指定。

        该方法更改布局相关信息，因此使组件层次结构无效。

        如果width或height值小于上一次拨打setMinimumSize所规定的最小尺寸，则自动放大width或setMinimumSize 。

        该方法更改几何相关数据。 因此，本地窗口系统可以忽略这样的请求，或者它可以修改所请求的数据，使得Window对象被放置并且以与桌面设置紧密相对应的方式被Window 。

        重写：
        setBounds在 Component
        参数
        x - 这个组件的新的 x- coordinate
        y - 这个组件的新 y-坐标
        width - 这个组件的新 width
        height - 这个组件的新 height
        从以下版本开始：
        1.6
        另请参见：
        Component.getBounds() ， setLocation(int, int) ， setLocation(Point) ， setSize(int, int) ， setSize(Dimension) ， setMinimumSize(java.awt.Dimension) ， setLocationByPlatform(boolean) ， isLocationByPlatform()

      • setBounds

        public void setBounds​(Rectangle r)
        移动并调整此组件的大小以符合新的边框矩形r 。 该组件的新职位由r.x和r.y指定，其新尺寸由r.width和r.height指定

        该方法更改布局相关信息，因此使组件层次结构无效。

        如果r.width或r.height值小于上一次调用setMinimumSize所规定的最小尺寸，则r.width或r.height值将自动放大。

        该方法更改几何相关数据。 因此，本地窗口系统可以忽略这样的请求，或者它可以修改所请求的数据，使得Window对象被放置并且以与桌面设置紧密对应的方式进行大小调整。

        重写：
        setBounds在 Component
        参数
        r - 此组件的新的边界矩形
        从以下版本开始：
        1.6
        另请参见：
        Component.getBounds() ， setLocation(int, int) ， setLocation(Point) ， setSize(int, int) ， setSize(Dimension) ， setMinimumSize(java.awt.Dimension) ， setLocationByPlatform(boolean) ， isLocationByPlatform()

      • getOpacity

        public float getOpacity​()
        返回窗口的不透明度。
        结果
        窗口的不透明度
        从以下版本开始：
        1.7
        另请参见：
        setOpacity(float) ， GraphicsDevice.WindowTranslucency

      • setOpacity

        public void setOpacity​(float opacity)
        设置窗口的不透明度。

        不透明度值在[0..1]的范围内。 请注意，设置不透明度级别为0可能会禁用此窗口上的鼠标事件处理。 这是依赖于平台的行为。

        为了使不透明度值小于1.0f必须满足以下条件：

        • 底层系统必须支持TRANSLUCENT半透明度
        • 窗口必须未装饰（见Frame.setUndecorated(boolean)和Dialog.setUndecorated(boolean) ）
        • 窗口不能处于全屏模式（参见GraphicsDevice.setFullScreenWindow(Window) ）

        如果请求的不透明度值小于1.0f ，并且不符合上述任何条件，窗口不透明度将不会更改，并且将抛出IllegalComponentStateException 。

        单个像素的半透明度也可以通过其颜色的α分量（参见setBackground(Color) ）和该窗口的当前形状（参见setShape(Shape) ）来实现。

        参数
        opacity - 设置为窗口的不透明度级别
        异常
        IllegalArgumentException - 如果不透明度超出范围[0..1]
        IllegalComponentStateException - 如果窗口被装饰，并且不透明度小于 1.0f
        IllegalComponentStateException - 如果窗口处于全屏模式， 1.0f透明度小于 1.0f
        UnsupportedOperationException - 如果不支持 GraphicsDevice.WindowTranslucency#TRANSLUCENT TRANSLUCENT半透明度，且不透明度小于 1.0f
        从以下版本开始：
        1.7
        另请参见：
        getOpacity() ， setBackground(Color) ， setShape(Shape) ， Frame.isUndecorated() ， Dialog.isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency)

      • getShape

        public Shape getShape​()
        返回窗口的形状。 此方法返回的值可能与以前使用setShape(shape)设置的setShape(shape) ，但保证其表示相同的形状。
        结果
        窗口的形状或 null如果没有为窗口指定形状
        从以下版本开始：
        1.7
        另请参见：
        setShape(Shape) ， GraphicsDevice.WindowTranslucency

      • setShape

        public void setShape​(Shape shape)
        设置窗口的形状。

        设置形状会切断窗口的某些部分。 只有属于给定的Shape的部件保持可见和可点击。 如果形状参数为null ，则此方法将恢复默认形状，使窗口在大多数平台上呈矩形。

        必须满足以下条件才能设置非空形状：

        • 底层系统必须支持PERPIXEL_TRANSPARENT半透明度
        • 窗口必须未装饰（见Frame.setUndecorated(boolean)和Dialog.setUndecorated(boolean) ）
        • 窗口不能处于全屏模式（参见GraphicsDevice.setFullScreenWindow(Window) ）

        如果请求的形状不是null ，并且不符合上述任何条件，则此窗口的形状将不会更改，并且将抛出UnsupportedOperationException或IllegalComponentStateException 。

        单个像素的半透明度也可以通过其颜色的α分量（参见setBackground(Color) ）和不透明度值（参见setOpacity(float) ）来实现。 详见GraphicsDevice.WindowTranslucency 。

        参数
        shape - 要设置窗口的形状
        异常
        IllegalComponentStateException - 如果形状不是 null ，窗口是装饰的
        IllegalComponentStateException - 如果形状不是 null ，并且窗口处于全屏模式
        UnsupportedOperationException - 如果形状不是 null和 PERPIXEL_TRANSPARENT半透明不被支持
        从以下版本开始：
        1.7
        另请参见：
        getShape() ， setBackground(Color) ， setOpacity(float) ， Frame.isUndecorated() ， Dialog.isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency)

      • getBackground

        public Color getBackground​()
        获取此窗口的背景颜色。

        请注意，返回颜色的alpha分量表示窗口是否处于非不透明（每像素半透明）模式。

        重写：
        getBackground在 Component
        结果
        这个组件的背景颜色
        另请参见：
        setBackground(Color) ， isOpaque() ， GraphicsDevice.WindowTranslucency

      • setBackground

        public void setBackground​(Color bgColor)
        设置此窗口的背景颜色。

        如果窗口系统支持PERPIXEL_TRANSLUCENT半透明，则给定背景颜色的alpha分量可能会影响此窗口的操作模式：它指示此窗口是否为不透明（alpha = 1.0f ）或每像素半透明（alpha小于1.0f ）。 如果给定的背景颜色是null ，则该窗口被认为是完全不透明的。

        必须满足以下条件以启用此窗口的每像素透明度模式：

        • PERPIXEL_TRANSLUCENT半透明度必须由此窗口所在的图形设备支持
        • 窗口必须未装饰（见Frame.setUndecorated(boolean)和Dialog.setUndecorated(boolean) ）
        • 窗口不能处于全屏模式（参见GraphicsDevice.setFullScreenWindow(Window) ）

        如果所请求的背景颜色的alpha分量小于1.0f ，并且不符合上述任何条件，则此窗口的背景颜色不会改变，给定背景颜色的alpha分量不会影响到这个窗口，和UnsupportedOperationException或IllegalComponentStateException将被抛出。

        当窗口是每像素半透明时，绘图子系统遵循每个像素的alpha值。 如果使用等于零的alpha颜色成分绘制像素，则它将变得视觉上透明。 如果像素的alpha等于1.0f，则像素完全不透明。 alpha颜色分量的中间值使像素半透明。 在此模式下，窗口的背景绘制为给定背景颜色的alpha值。 如果此方法的参数的alpha值等于0 ，则完全不绘制背景。

        给定像素的半透明度的实际水平也取决于窗口不透明度（见setOpacity(float) ）以及该窗口的当前形状（参见setShape(Shape) ）。

        请注意，绘制Alpha值为0的像素可能会禁用该像素上的鼠标事件处理。 这是依赖于平台的行为。 为了确保鼠标事件不被分派到特定的像素，像素必须从窗口的形状中排除。

        由于本机平台要求，启用每像素半透明模式可能会改变该窗口的图形配置。

        重写：
        setBackground在 Component
        参数
        bgColor - 成为这个窗口的背景颜色的颜色。
        异常
        IllegalComponentStateException - 如果给定的背景颜色的alpha值小于 1.0f并且窗口被装饰
        IllegalComponentStateException - 如果给定背景颜色的alpha值小于 1.0f ，并且窗口处于全屏模式
        UnsupportedOperationException -如果给定的背景颜色的α值小于 1.0f和 PERPIXEL_TRANSLUCENT半透明不支持
        另请参见：
        getBackground() ， isOpaque() ， setOpacity(float) ， setShape(Shape) ， Frame.isUndecorated() ， Dialog.isUndecorated() ， GraphicsDevice.WindowTranslucency ， GraphicsDevice.isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency) ， GraphicsConfiguration.isTranslucencyCapable()

      • isOpaque

        public boolean isOpaque​()
        指示窗口当前是否不透明。

        该方法返回false ，如果窗口的背景色是不null和颜色的Alpha分量小于1.0f 。 该方法返回true 。

        重写：
        isOpaque在 Component
        结果
        true如果窗口是不透明的， false否则
        从以下版本开始：
        1.7
        另请参见：
        getBackground() ， setBackground(Color)

      • paint

        public void paint​(Graphics g)
        涂上容器 这会将油漆转移到任何这个容器的小孩的轻量级组件。 如果重新实现此方法，则应调用super.paint（g），以便轻量级组件正确呈现。 如果一个子组件被当前的剪裁设置（g）全部剪除，那么paint（）将不会转发给该小孩。
        重写：
        paint在 Container
        参数
        g - 指定的图形窗口
        从以下版本开始：
        1.7
        另请参见：
        Component.update(Graphics)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Window.AccessibleAWTWindow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt

Class Window.AccessibleAWTWindow

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Window.AccessibleAWTWindow
  • All Implemented Interfaces:
    Serializable ， AccessibleComponent
    已知直接子类：
    Dialog.AccessibleAWTDialog ， Frame.AccessibleAWTFrame ， JWindow.AccessibleJWindow
    Enclosing class:
    Window

    protected class Window.AccessibleAWTWindow
extends Container.AccessibleAWTContainer
    这个类实现Window类的可访问性支持。 它提供了适用于窗口用户界面元素的Java Accessibility API的实现。
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

    • Field Summary

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

    • 构造方法摘要

      构造方法
      Modifier | Constructor | 描述
      protected | AccessibleAWTWindow​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      AccessibleRole getAccessibleRole​()
      获取此对象的角色。
      AccessibleStateSet getAccessibleStateSet​()
      获取此对象的状态。

      • Methods inherited from class javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • Methods inherited from class java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • Methods inherited from class java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, removePropertyChangeListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleAWTWindow

        protected AccessibleAWTWindow​()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole​()
        获取此对象的角色。
        重写：
        getAccessibleRole在 Component.AccessibleAWTComponent
        结果
        AccessibleRole的一个实例描述对象的角色
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet​()
        获取此对象的状态。
        重写：
        getAccessibleStateSet在 Component.AccessibleAWTComponent
        结果
        包含对象的当前状态集的AccessibleStateSet实例
        另请参见：
        AccessibleState
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Window.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt

Enum Window.Type

  • java.lang.Object
    • java.lang.Enum<Window.Type>
      • java.awt.Window.Type
  • All Implemented Interfaces:
    Serializable ， Comparable<Window.Type>
    Enclosing class:
    Window

    public static enum Window.Type
extends Enum<Window.Type>
    枚举可用的窗口类型 。 窗口类型定义了顶级窗口的通用视觉外观和行为。 例如，该类型可能会影响装饰的装饰Frame或Dialog实例。

    某些平台可能不完全支持某种窗口类型。 根据支持的级别，窗口类型的某些属性可能不服从。

    从以下版本开始：
    1.7
    另请参见：
    Window.getType() ， Window.setType(java.awt.Window.Type)

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      NORMAL
      表示 正常窗口。
      POPUP
      表示一个 弹出窗口。
      UTILITY
      表示 实用程序窗口。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Window.Type valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Window.Type[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NORMAL

        public static final Window.Type NORMAL
        表示正常窗口。 这是Window类或其后代的对象的默认类型。 对于常规的顶级窗口使用此类型。

      • UTILITY

        public static final Window.Type UTILITY
        表示实用程序窗口。 实用程序窗口通常是一个小窗口，如工具栏或调色板。 如果窗口是Frame或Dialog对象，并且启用了其装饰，本机系统可能会使窗口具有较小的标题栏。

      • POPUP

        public static final Window.Type POPUP
        表示一个弹出窗口。 弹出窗口是一个临时窗口，如下拉菜单或工具提示。 在某些平台上，即使是Frame或Dialog类的实例，也可能强制使该类型的窗口未装饰，并启用装饰。

    • 方法详细信息

      • values

        public static Window.Type[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Window.Type c : Window.Type.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Window.Type valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class java.awt.AlphaComposite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.AlphaComposite

  • Packages that use AlphaComposite
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of AlphaComposite in java.awt

      Fields in java.awt declared as AlphaComposite
      Modifier and Type Field 描述
      static AlphaComposite AlphaComposite.Clear
      AlphaComposite对象实现不透明的CLEAR规则，alpha为1.0f。
      static AlphaComposite AlphaComposite.Dst
      AlphaComposite对象实现不透明的DST规则，其alpha为1.0f。
      static AlphaComposite AlphaComposite.DstAtop
      AlphaComposite对象实现不透明的DST_ATOP规则，其alpha为1.0f。
      static AlphaComposite AlphaComposite.DstIn
      AlphaComposite对象实现不透明的DST_IN规则，其alpha为1.0f。
      static AlphaComposite AlphaComposite.DstOut
      AlphaComposite对象实现不透明的DST_OUT规则，alpha为1.0f。
      static AlphaComposite AlphaComposite.DstOver
      AlphaComposite对象实现不透明的DST_OVER规则，其alpha为1.0f。
      static AlphaComposite AlphaComposite.Src
      AlphaComposite对象实现不透明的SRC规则，alpha为1.0f。
      static AlphaComposite AlphaComposite.SrcAtop
      AlphaComposite对象实现不透明的SRC_ATOP规则，alpha为1.0f。
      static AlphaComposite AlphaComposite.SrcIn
      AlphaComposite对象实现不透明的SRC_IN规则，alpha为1.0f。
      static AlphaComposite AlphaComposite.SrcOut
      AlphaComposite对象实现的alpha值为1.0f的不透明的SRC_OUT规则。
      static AlphaComposite AlphaComposite.SrcOver
      AlphaComposite对象实现不透明的SRC_OVER规则，alpha为1.0f。
      static AlphaComposite AlphaComposite.Xor
      AlphaComposite对象实现了一个alpha为1.0f的不透明XOR规则。
      Methods in java.awt that return AlphaComposite
      Modifier and Type 方法 描述
      AlphaComposite AlphaComposite.derive​(float alpha)
      返回类似的 AlphaComposite对象，该对象使用指定的alpha值。
      AlphaComposite AlphaComposite.derive​(int rule)
      返回一个使用指定的合成规则的类似的 AlphaComposite对象。
      static AlphaComposite AlphaComposite.getInstance​(int rule)
      使用指定的规则创建一个 AlphaComposite对象。
      static AlphaComposite AlphaComposite.getInstance​(int rule, float alpha)
      创建一个具有指定规则的 AlphaComposite对象，并将常量alpha与源的alpha进行乘法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.AWTError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.AWTError

No usage of java.awt.AWTError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.AWTEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.AWTEvent

  • Packages that use AWTEvent
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。

    • Uses of AWTEvent in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util with parameters of type AWTEvent
      Modifier and Type 方法 描述
      void EventQueueMonitor.eventDispatched​(AWTEvent theEvent)
      在EventQueueMonitor.maybeInitialize()中的EventQueue上注册一个监听器来处理事件。

    • Uses of AWTEvent in java.awt

      Methods in java.awt that return AWTEvent
      Modifier and Type 方法 描述
      protected AWTEvent Component.coalesceEvents​(AWTEvent existingEvent, AWTEvent newEvent)
      潜在地合并现有事件发布的事件。
      static AWTEvent EventQueue.getCurrentEvent​()
      返回与调用线程相关联的 EventQueue当前调度的事件。
      AWTEvent EventQueue.getNextEvent​()
      从 EventQueue删除事件并返回。
      AWTEvent EventQueue.peekEvent​()
      返回 EventQueue上的第一个事件，而不删除它。
      AWTEvent EventQueue.peekEvent​(int id)
      返回具有指定ID的第一个事件（如果有）。
      Methods in java.awt with parameters of type AWTEvent
      Modifier and Type 方法 描述
      protected AWTEvent Component.coalesceEvents​(AWTEvent existingEvent, AWTEvent newEvent)
      潜在地合并现有事件发布的事件。
      void Component.dispatchEvent​(AWTEvent e)
      将事件分派到此组件或其一个子组件。
      boolean DefaultKeyboardFocusManager.dispatchEvent​(AWTEvent e)
      该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。
      protected void EventQueue.dispatchEvent​(AWTEvent event)
      调度事件。
      abstract boolean KeyboardFocusManager.dispatchEvent​(AWTEvent e)
      该方法由AWT事件调度程序调用，请求当前的KeyboardFocusManager代表它发送指定的事件。
      void MenuComponent.dispatchEvent​(AWTEvent e)
      将事件提供给此组件或其子组件之一。
      void EventQueue.postEvent​(AWTEvent theEvent)
      将一个1.1样式的事件发布到 EventQueue 。
      protected void Button.processEvent​(AWTEvent e)
      处理此按钮上的事件。
      protected void Checkbox.processEvent​(AWTEvent e)
      处理此复选框上的事件。
      protected void CheckboxMenuItem.processEvent​(AWTEvent e)
      处理此复选框菜单项上的事件。
      protected void Choice.processEvent​(AWTEvent e)
      处理此选择的事件。
      protected void Component.processEvent​(AWTEvent e)
      处理在此组件上发生的事件。
      protected void Container.processEvent​(AWTEvent e)
      处理此容器上的事件。
      protected void List.processEvent​(AWTEvent e)
      在此滚动列表中处理事件。
      protected void MenuComponent.processEvent​(AWTEvent e)
      处理在此菜单组件上发生的事件。
      protected void MenuItem.processEvent​(AWTEvent e)
      处理此菜单项上的事件。
      protected void Scrollbar.processEvent​(AWTEvent e)
      处理此滚动条上的事件。
      protected void TextComponent.processEvent​(AWTEvent e)
      处理此文本组件上的事件。
      protected void TextField.processEvent​(AWTEvent e)
      处理此文本字段上的事件。
      protected void Window.processEvent​(AWTEvent e)
      在此窗口处理事件。
      void KeyboardFocusManager.redispatchEvent​(Component target, AWTEvent e)
      重新分配AWTEvent，AWT事件调度程序将不会递归地请求KeyboardFocusManager或任何已安装的KeyEventDispatchers再次发送事件。

    • Uses of AWTEvent in java.awt.event

      Subclasses of AWTEvent in java.awt.event
      Modifier and Type Class 描述
      class  ActionEvent
      指示组件定义的动作发生的语义事件。
      class  AdjustmentEvent
      可调整对象发出的调整事件，如Scrollbar和ScrollPane 。
      class  ComponentEvent
      指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
      class  ContainerEvent
      低级别事件，表示容器的内容因添加或删除组件而发生更改。
      class  FocusEvent
      指示组件已经获得或丢失了输入焦点的低级事件。
      class  HierarchyEvent
      指示对 Component所属的 Component层次结构进行更改的事件。
      class  InputEvent
      所有组件级输入事件的根事件类。
      class  InputMethodEvent
      输入法事件包含使用输入法组合的文本信息。
      class  InvocationEvent
      在AWT事件调度程序线程调度时，在 Runnable执行 run()方法的事件。
      class  ItemEvent
      表示选择或取消选择项目的语义事件。
      class  KeyEvent
      指示组件中发生击键的事件。
      class  MouseEvent
      指示组件中发生鼠标操作的事件。
      class  MouseWheelEvent
      指示鼠标轮在组件中旋转的事件。
      class  PaintEvent
      组件级paint事件。
      class  TextEvent
      表示对象的文本改变的语义事件。
      class  WindowEvent
      指示窗口已更改其状态的低级别事件。
      Methods in java.awt.event with parameters of type AWTEvent
      Modifier and Type 方法 描述
      void AWTEventListener.eventDispatched​(AWTEvent event)
      在AWT中调度事件时调用。
      void AWTEventListenerProxy.eventDispatched​(AWTEvent event)
      将AWT事件转发给侦听器代理。

    • Uses of AWTEvent in java.awt.im

      Methods in java.awt.im with parameters of type AWTEvent
      Modifier and Type 方法 描述
      void InputContext.dispatchEvent​(AWTEvent event)
      将事件调度为活动输入法。

    • Uses of AWTEvent in java.awt.im.spi

      Methods in java.awt.im.spi with parameters of type AWTEvent
      Modifier and Type 方法 描述
      void InputMethod.dispatchEvent​(AWTEvent event)
      将事件调度到输入法。

    • Uses of AWTEvent in javax.swing.event

      Subclasses of AWTEvent in javax.swing.event
      Modifier and Type Class 描述
      class  AncestorEvent
      向组件层级中的祖先发送的子组件的事件。
      class  InternalFrameEvent
      一个 AWTEvent ，添加了对 JInternalFrame对象的支持作为事件源。
      class  MenuDragMouseEvent
      MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。
      class  MenuKeyEvent
      MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。

    • Uses of AWTEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type AWTEvent
      Modifier and Type 方法 描述
      void LayerUI.eventDispatched​(AWTEvent e, JLayer<? extends V> l)
      过程 AWTEvent s为 JLayer及其 所有后代到这个 LayerUI实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.AWTEventMulticaster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.AWTEventMulticaster

No usage of java.awt.AWTEventMulticaster
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.AWTException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.AWTException

  • Packages that use AWTException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。

    • Uses of AWTException in java.awt

      Methods in java.awt that throw AWTException
      Modifier and Type 方法 描述
      void SystemTray.add​(TrayIcon trayIcon)
      添加 TrayIcon到 SystemTray 。
      protected void Component.FlipBufferStrategy.createBuffers​(int numBuffers, BufferCapabilities caps)
      使用给定的功能创建一个或多个复杂的翻转缓冲区。
      void Canvas.createBufferStrategy​(int numBuffers, BufferCapabilities caps)
      在此组件上创建一个新策略，以实现所需的缓冲功能。
      void Window.createBufferStrategy​(int numBuffers, BufferCapabilities caps)
      在此组件上创建一个新策略，以实现所需的缓冲功能。
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps)
      使用指定的图像功能，返回VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps, int transparency)
      返回VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容，使用指定的图像功能和透明度值。
      VolatileImage Component.createVolatileImage​(int width, int height, ImageCapabilities caps)
      使用给定的功能创建一个易失的屏幕外可绘制图像。
      static Cursor Cursor.getSystemCustomCursor​(String name)
      返回与指定名称匹配的特定于系统的自定义游标对象。
      Constructors in java.awt that throw AWTException
      Constructor 描述
      FlipBufferStrategy​(int numBuffers, BufferCapabilities caps)
      为此组件创建一个新的翻转缓冲区策略。
      Robot​()
      在主屏幕的坐标系中构造一个Robot对象。
      Robot​(GraphicsDevice screen)
      为给定的屏幕设备创建一个机器人。

    • Uses of AWTException in java.awt.im.spi

      Methods in java.awt.im.spi that throw AWTException
      Modifier and Type 方法 描述
      Locale[] InputMethodDescriptor.getAvailableLocales​()
      返回相应输入法支持的语言环境。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.AWTKeyStroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.AWTKeyStroke

  • Packages that use AWTKeyStroke
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AWTKeyStroke in java.awt

      Methods in java.awt that return AWTKeyStroke
      Modifier and Type 方法 描述
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke​(char keyChar)
      返回一个 AWTKeyStroke的共享实例，表示指定字符的 KEY_TYPED事件。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke​(int keyCode, int modifiers)
      返回一个 AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke​(int keyCode, int modifiers, boolean onKeyRelease)
      返回一个 AWTKeyStroke的共享实例，给出一个数字键代码和一组修饰符，指定在按下或释放该键时是否激活该键。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke​(Character keyChar, int modifiers)
      返回 AWTKeyStroke的共享实例，该实例表示指定的Character对象和一组修饰符的 KEY_TYPED事件。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke​(String s)
      解析一个字符串并返回一个 AWTKeyStroke 。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStrokeForEvent​(KeyEvent anEvent)
      返回一个 AWTKeyStroke ，表示生成给定的 KeyEvent 。
      Methods in java.awt that return types with arguments of type AWTKeyStroke
      Modifier and Type 方法 描述
      Set<AWTKeyStroke> KeyboardFocusManager.getDefaultFocusTraversalKeys​(int id)
      返回给定遍历操作的一组默认焦点遍历键。
      Set<AWTKeyStroke> Component.getFocusTraversalKeys​(int id)
      返回此组件的给定遍历操作的聚焦遍历键集。
      Set<AWTKeyStroke> Container.getFocusTraversalKeys​(int id)
      返回此Container的给定遍历操作的聚焦遍历键集。
      Set<AWTKeyStroke> Window.getFocusTraversalKeys​(int id)
      获取此窗口的焦点遍历键。
      Method parameters in java.awt with type arguments of type AWTKeyStroke
      Modifier and Type 方法 描述
      void KeyboardFocusManager.setDefaultFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置给定遍历操作的默认焦点遍历键。
      void Component.setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此组件给定遍历操作的焦点遍历键。
      void Container.setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此容器的给定遍历操作的焦点遍历键。

    • Uses of AWTKeyStroke in javax.swing

      Subclasses of AWTKeyStroke in javax.swing
      Modifier and Type Class 描述
      class  KeyStroke
      KeyStroke表示键盘或等效输入设备上的关键操作。
      Method parameters in javax.swing with type arguments of type AWTKeyStroke
      Modifier and Type 方法 描述
      void JComponent.setFocusTraversalKeys​(int id, Set<? extends AWTKeyStroke> keystrokes)
      设置此组件给定遍历操作的焦点遍历键。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.AWTPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.AWTPermission

No usage of java.awt.AWTPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.BasicStroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.BasicStroke

  • Packages that use BasicStroke
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。

    • Uses of BasicStroke in javax.swing

      Methods in javax.swing with parameters of type BasicStroke
      Modifier and Type 方法 描述
      static Border BorderFactory.createStrokeBorder​(BasicStroke stroke)
      创建指定的边框 stroke 。
      static Border BorderFactory.createStrokeBorder​(BasicStroke stroke, Paint paint)
      创建指定的 stroke和 paint 。

    • Uses of BasicStroke in javax.swing.border

      Methods in javax.swing.border that return BasicStroke
      Modifier and Type 方法 描述
      BasicStroke StrokeBorder.getStroke​()
      返回在边框渲染期间用于描边形状的BasicStroke对象。
      Constructors in javax.swing.border with parameters of type BasicStroke
      Constructor 描述
      StrokeBorder​(BasicStroke stroke)
      创建指定的边框 stroke 。
      StrokeBorder​(BasicStroke stroke, Paint paint)
      Creates a border of the specified stroke and paint.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.BorderLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.BorderLayout

No usage of java.awt.BorderLayout
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.BufferCapabilities (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.BufferCapabilities

  • Packages that use BufferCapabilities
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。

    • Uses of BufferCapabilities in java.awt

      Fields in java.awt declared as BufferCapabilities
      Modifier and Type Field 描述
      protected BufferCapabilities Component.BltBufferStrategy.caps
      缓冲功能
      protected BufferCapabilities Component.FlipBufferStrategy.caps
      缓冲功能
      Methods in java.awt that return BufferCapabilities
      Modifier and Type | 方法 | 描述
      BufferCapabilities GraphicsConfiguration.getBufferCapabilities​()
      返回此 GraphicsConfiguration的缓冲功能。
      BufferCapabilities | Component.BltBufferStrategy.getCapabilities​()
      BufferCapabilities | Component.FlipBufferStrategy.getCapabilities​()
      Methods in java.awt with parameters of type BufferCapabilities
      Modifier and Type 方法 描述
      protected void Component.FlipBufferStrategy.createBuffers​(int numBuffers, BufferCapabilities caps)
      使用给定的功能创建一个或多个复杂的翻转缓冲区。
      void Canvas.createBufferStrategy​(int numBuffers, BufferCapabilities caps)
      在此组件上创建一个新策略，以实现所需的缓冲功能。
      void Window.createBufferStrategy​(int numBuffers, BufferCapabilities caps)
      在此组件上创建一个新策略，以实现所需的缓冲功能。
      Constructors in java.awt with parameters of type BufferCapabilities
      Constructor 描述
      BltBufferStrategy​(int numBuffers, BufferCapabilities caps)
      围绕组件创建一个新的blt缓冲策略
      FlipBufferStrategy​(int numBuffers, BufferCapabilities caps)
      为此组件创建一个新的翻转缓冲区策略。

    • Uses of BufferCapabilities in java.awt.image

      Methods in java.awt.image that return BufferCapabilities
      Modifier and Type 方法 描述
      abstract BufferCapabilities BufferStrategy.getCapabilities​()
      返回这个 BufferCapabilities的 BufferStrategy 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.BufferCapabilities.FlipContents (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.BufferCapabilities.FlipContents

  • Packages that use BufferCapabilities.FlipContents
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of BufferCapabilities.FlipContents in java.awt

      Fields in java.awt declared as BufferCapabilities.FlipContents
      Modifier and Type Field 描述
      static BufferCapabilities.FlipContents BufferCapabilities.FlipContents.BACKGROUND
      当翻转内容为 BACKGROUND ，翻转后背景缓冲区的内容将被清除。
      static BufferCapabilities.FlipContents BufferCapabilities.FlipContents.COPIED
      当翻转内容为 COPIED ，翻转时将后台缓冲区的内容复制到前端缓冲区。
      static BufferCapabilities.FlipContents BufferCapabilities.FlipContents.PRIOR
      当翻转内容为 PRIOR ，后台缓冲区的内容是前缓冲区的前一个内容（真正的页面翻页）。
      static BufferCapabilities.FlipContents BufferCapabilities.FlipContents.UNDEFINED
      当翻转内容为 UNDEFINED ，后缓冲区的内容在翻转后未定义。
      Methods in java.awt that return BufferCapabilities.FlipContents
      Modifier and Type | 方法 | 描述
      BufferCapabilities.FlipContents | BufferCapabilities.getFlipContents​()
      Methods in java.awt with parameters of type BufferCapabilities.FlipContents
      Modifier and Type 方法 描述
      protected void Component.FlipBufferStrategy.flip​(BufferCapabilities.FlipContents flipAction)
      翻转通过复制或移动视频指针将后缓冲区的内容移动到前缓冲区。
      Constructors in java.awt with parameters of type BufferCapabilities.FlipContents
      Constructor 描述
      BufferCapabilities​(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
      Creates a new object for specifying buffering capabilities
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Button (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Button

No usage of java.awt.Button
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Button.AccessibleAWTButton (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Button.AccessibleAWTButton

No usage of java.awt.Button.AccessibleAWTButton
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Canvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Canvas

No usage of java.awt.Canvas
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Canvas.AccessibleAWTCanvas (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Canvas.AccessibleAWTCanvas

No usage of java.awt.Canvas.AccessibleAWTCanvas
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.CardLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.CardLayout

No usage of java.awt.CardLayout
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Checkbox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Checkbox

  • Packages that use Checkbox
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Checkbox in java.awt

      Methods in java.awt that return Checkbox
      Modifier and Type 方法 描述
      Checkbox CheckboxGroup.getCurrent​()
      已过时。
      从JDK 1.1版开始，替换为getSelectedCheckbox() 。
      Checkbox CheckboxGroup.getSelectedCheckbox​()
      从此复选框组获取当前选择。
      Methods in java.awt with parameters of type Checkbox
      Modifier and Type 方法 描述
      void CheckboxGroup.setCurrent​(Checkbox box)
      已过时。
      从JDK 1.1版开始，由setSelectedCheckbox(Checkbox)替代。
      void CheckboxGroup.setSelectedCheckbox​(Checkbox box)
      Sets the currently selected check box in this group to be the specified check box.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Checkbox.AccessibleAWTCheckbox (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Checkbox.AccessibleAWTCheckbox

No usage of java.awt.Checkbox.AccessibleAWTCheckbox
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.CheckboxGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.CheckboxGroup

  • Packages that use CheckboxGroup
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of CheckboxGroup in java.awt

      Methods in java.awt that return CheckboxGroup
      Modifier and Type 方法 描述
      CheckboxGroup Checkbox.getCheckboxGroup​()
      确定此复选框的组。
      Methods in java.awt with parameters of type CheckboxGroup
      Modifier and Type 方法 描述
      void Checkbox.setCheckboxGroup​(CheckboxGroup g)
      将此复选框的组设置为指定的复选框组。
      Constructors in java.awt with parameters of type CheckboxGroup
      Constructor 描述
      Checkbox​(String label, boolean state, CheckboxGroup group)
      构造具有指定标签的复选框，设置为指定的状态，并在指定的复选框组中。
      Checkbox​(String label, CheckboxGroup group, boolean state)
      在指定的复选框组中创建带有指定标签的复选框，并设置为指定的状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.CheckboxMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.CheckboxMenuItem

No usage of java.awt.CheckboxMenuItem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

No usage of java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Choice (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Choice

No usage of java.awt.Choice
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Choice.AccessibleAWTChoice (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Choice.AccessibleAWTChoice

No usage of java.awt.Choice.AccessibleAWTChoice
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Color (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Color

  • Packages that use Color
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Color in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Color
      Modifier and Type 方法 描述
      Color Translator.getBackground​()
      获取此对象的背景 Color 。
      Color Translator.getForeground​()
      获取该对象的前景 Color 。
      Methods in com.sun.java.accessibility.util with parameters of type Color
      Modifier and Type 方法 描述
      void Translator.setBackground​(Color c)
      设置此对象的背景 Color 。
      void Translator.setForeground​(Color c)
      设置该对象的前台 Color 。

    • Uses of Color in java.awt

      Subclasses of Color in java.awt
      Modifier and Type Class 描述
      class  SystemColor
      封装代表系统上本地GUI对象颜色的符号颜色的类。
      Fields in java.awt declared as Color
      Modifier and Type Field 描述
      static Color Color.black
      颜色黑色。
      static Color Color.BLACK
      颜色黑色。
      static Color Color.blue
      颜色蓝色。
      static Color Color.BLUE
      颜色蓝色。
      static Color Color.cyan
      颜色青色。
      static Color Color.CYAN
      颜色青色。
      static Color Color.DARK_GRAY
      颜色深灰色。
      static Color Color.darkGray
      颜色深灰色。
      static Color Color.gray
      颜色灰色。
      static Color Color.GRAY
      颜色灰色。
      static Color Color.green
      颜色绿色。
      static Color Color.GREEN
      颜色绿色。
      static Color Color.LIGHT_GRAY
      颜色浅灰色。
      static Color Color.lightGray
      颜色浅灰色。
      static Color Color.magenta
      颜色洋红色。
      static Color Color.MAGENTA
      颜色洋红色。
      static Color Color.orange
      颜色橙色。
      static Color Color.ORANGE
      颜色橙色。
      static Color Color.pink
      颜色粉红色。
      static Color Color.PINK
      颜色粉红色。
      static Color Color.red
      颜色红色。
      static Color Color.RED
      颜色红色。
      static Color Color.white
      颜色白色。
      static Color Color.WHITE
      颜色白色。
      static Color Color.yellow
      颜色黄色。
      static Color Color.YELLOW
      颜色黄色。
      Methods in java.awt that return Color
      Modifier and Type 方法 描述
      Color Color.brighter​()
      创建一个新的 Color这是一个更明亮的版本的这个 Color 。
      Color Color.darker​()
      创建一个新的 Color这是一个较深的版本的这个 Color 。
      static Color Color.decode​(String nm)
      将 String转换为整数，并返回指定的不透明度 Color 。
      Color Component.AccessibleAWTComponent.getBackground​()
      获取此对象的背景颜色。
      Color Component.getBackground​()
      获取此组件的背景颜色。
      abstract Color Graphics2D.getBackground​()
      返回用于清除区域的背景颜色。
      Color List.AccessibleAWTList.AccessibleAWTListChild.getBackground​()
      获取此对象的背景颜色。
      Color MenuComponent.AccessibleAWTMenuComponent.getBackground​()
      获取此对象的背景颜色。
      Color TextComponent.getBackground​()
      获取此文本组件的背景颜色。
      Color Window.getBackground​()
      获取此窗口的背景颜色。
      static Color Color.getColor​(String nm)
      在系统属性中查找颜色。
      static Color Color.getColor​(String nm, int v)
      在系统属性中查找颜色。
      static Color Color.getColor​(String nm, Color v)
      在系统属性中查找颜色。
      abstract Color Graphics.getColor​()
      获取此图形上下文的当前颜色。
      Color GradientPaint.getColor1​()
      返回由点P1锚定的颜色C1。
      Color GradientPaint.getColor2​()
      返回由点P2锚定的颜色C2。
      Color[] MultipleGradientPaint.getColors​()
      返回此梯度使用的颜色数组的副本。
      Color Component.AccessibleAWTComponent.getForeground​()
      获取此对象的前景色。
      Color Component.getForeground​()
      获取此组件的前景色。
      Color List.AccessibleAWTList.AccessibleAWTListChild.getForeground​()
      获取此对象的前景色。
      Color MenuComponent.AccessibleAWTMenuComponent.getForeground​()
      获取此对象的前景色。
      static Color Color.getHSBColor​(float h, float s, float b)
      根据HSB颜色模型的指定值创建一个 Color对象。
      Color Robot.getPixelColor​(int x, int y)
      返回给定屏幕坐标处的像素颜色。
      Methods in java.awt with parameters of type Color
      Modifier and Type 方法 描述
      abstract boolean Graphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      绘制与已经缩放以适应指定矩形内的指定图像的大小。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      绘制当前可用的指定图像的大小。
      static Color Color.getColor​(String nm, Color v)
      在系统属性中查找颜色。
      void Component.AccessibleAWTComponent.setBackground​(Color c)
      设置此对象的背景颜色。
      void Component.setBackground​(Color c)
      设置此组件的背景颜色。
      void Dialog.setBackground​(Color bgColor)
      设置此窗口的背景颜色。
      void Frame.setBackground​(Color bgColor)
      设置此窗口的背景颜色。
      abstract void Graphics2D.setBackground​(Color color)
      设置 Graphics2D上下文的背景颜色。
      void List.AccessibleAWTList.AccessibleAWTListChild.setBackground​(Color c)
      设置此对象的背景颜色。
      void MenuComponent.AccessibleAWTMenuComponent.setBackground​(Color c)
      设置此对象的背景颜色。
      void TextComponent.setBackground​(Color c)
      设置此文本组件的背景颜色。
      void Window.setBackground​(Color bgColor)
      设置此窗口的背景颜色。
      abstract void Graphics.setColor​(Color c)
      将此图形上下文的当前颜色设置为指定的颜色。
      void Component.AccessibleAWTComponent.setForeground​(Color c)
      设置此对象的前景色。
      void Component.setForeground​(Color c)
      设置此组件的前景颜色。
      void List.AccessibleAWTList.AccessibleAWTListChild.setForeground​(Color c)
      设置此对象的前景色。
      void MenuComponent.AccessibleAWTMenuComponent.setForeground​(Color c)
      设置此对象的前景色。
      abstract void Graphics.setXORMode​(Color c1)
      设置此图形上下文的绘制模式，以在此图形上下文的当前颜色和新的指定颜色之间交替显示。
      Constructors in java.awt with parameters of type Color
      Constructor 描述
      GradientPaint​(float x1, float y1, Color color1, float x2, float y2, Color color2)
      构造一个简单的无环 GradientPaint对象。
      GradientPaint​(float x1, float y1, Color color1, float x2, float y2, Color color2, boolean cyclic)
      根据 boolean参数构建循环或非循环 GradientPaint对象。
      GradientPaint​(Point2D pt1, Color color1, Point2D pt2, Color color2)
      构造一个简单的无环 GradientPaint对象。
      GradientPaint​(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
      根据 boolean参数构造循环或非循环 GradientPaint对象。
      LinearGradientPaint​(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors)
      构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
      LinearGradientPaint​(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 LinearGradientPaint ，具有默认的 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors)
      构造一个 LinearGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 LinearGradientPaint ，默认为 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 LinearGradientPaint 。
      RadialGradientPaint​(float cx, float cy, float radius, float[] fractions, Color[] colors)
      构造一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，使用默认的 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint与默认的 SRGB颜色空间。
      RadialGradientPaint​(Point2D center, float radius, float[] fractions, Color[] colors)
      构造一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，具有默认的 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，默认为 SRGB颜色空间。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 RadialGradientPaint 。
      RadialGradientPaint​(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，默认为 SRGB颜色空间。

    • Uses of Color in javax.accessibility

      Methods in javax.accessibility that return Color
      Modifier and Type 方法 描述
      Color AccessibleComponent.getBackground​()
      获取此对象的背景颜色。
      Color AccessibleComponent.getForeground​()
      获取此对象的前景色。
      Methods in javax.accessibility with parameters of type Color
      Modifier and Type 方法 描述
      void AccessibleComponent.setBackground​(Color c)
      设置此对象的背景颜色。
      void AccessibleComponent.setForeground​(Color c)
      设置此对象的前景色。

    • Uses of Color in javax.swing

      Fields in javax.swing declared as Color
      Modifier and Type Field 描述
      protected Color JTable.gridColor
      网格的颜色。
      protected Color JTable.selectionBackground
      所选单元格的背景颜色。
      protected Color JTable.selectionForeground
      所选单元格的前景色。
      Methods in javax.swing that return Color
      Modifier and Type | 方法 | 描述
      static Color DebugGraphics.flashColor​()
      返回用于闪存绘图操作的颜色。
      Color | JList.AccessibleJList.AccessibleJListChild.getBackground​()
      Color JTable.AccessibleJTable.AccessibleJTableCell.getBackground​()
      获取此对象的背景颜色。
      Color JTree.AccessibleJTree.AccessibleJTreeNode.getBackground​()
      获取此对象的背景颜色。
      Color JTabbedPane.getBackgroundAt​(int index)
      返回标签背景颜色为 index 。
      Color DebugGraphics.getColor​()
      返回用于文本绘图操作的颜色。
      Color JColorChooser.getColor​()
      从颜色选择器获取当前颜色值。
      Color UIDefaults.getColor​(Object key)
      如果 key的值是 Color返回，否则返回 null 。
      Color UIDefaults.getColor​(Object key, Locale l)
      如果 key为 Locale为 Color ，则返回，否则返回 null 。
      static Color UIManager.getColor​(Object key)
      从默认值返回颜色。
      static Color UIManager.getColor​(Object key, Locale l)
      从适用于给定语言环境的默认值返回颜色。
      Color | JList.AccessibleJList.AccessibleJListChild.getForeground​()
      Color JTable.AccessibleJTable.AccessibleJTableCell.getForeground​()
      获取此对象的前景色。
      Color JTree.AccessibleJTree.AccessibleJTreeNode.getForeground​()
      获取此对象的前景色。
      Color JTabbedPane.getForegroundAt​(int index)
      返回标签前景色为 index 。
      Color JTable.getGridColor​()
      返回用于绘制网格线的颜色。
      Color JList.getSelectionBackground​()
      返回用于绘制所选项目背景的颜色。
      Color JTable.getSelectionBackground​()
      返回所选单元格的背景颜色。
      Color JList.getSelectionForeground​()
      返回用于绘制所选项目前景的颜色。
      Color JTable.getSelectionForeground​()
      返回所选单元格的前景颜色。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor, boolean colorTransparencySelectionEnabled)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      Methods in javax.swing with parameters of type Color
      Modifier and Type | 方法 | 描述
      static Border BorderFactory.createBevelBorder​(int type, Color highlight, Color shadow)
      使用指定的高亮和阴影创建指定类型的斜角边框。
      static Border BorderFactory.createBevelBorder​(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      创建指定类型的斜角边框，使用指定的颜色进行内部和外部高亮和阴影区域。
      static Border BorderFactory.createEtchedBorder​(int type, Color highlight, Color shadow)
      使用指定的高亮和阴影颜色创建一个“蚀刻”外观的边框。
      static Border BorderFactory.createEtchedBorder​(Color highlight, Color shadow)
      使用指定的高亮和阴影颜色创建一个“蚀刻”外观的边框。
      static Border BorderFactory.createLineBorder​(Color color)
      创建具有指定颜色的线边框。
      static Border BorderFactory.createLineBorder​(Color color, int thickness)
      创建具有指定颜色和宽度的线边框。
      static Border BorderFactory.createLineBorder​(Color color, int thickness, boolean rounded)
      创建具有指定颜色，粗细和拐角形状的线条边框。
      static MatteBorder BorderFactory.createMatteBorder​(int top, int left, int bottom, int right, Color color)
      使用纯色创建无光泽的边框。
      static Border BorderFactory.createSoftBevelBorder​(int type, Color highlight, Color shadow)
      使用指定的高亮和阴影创建具有软化角的指定类型的斜切边框。
      static Border BorderFactory.createSoftBevelBorder​(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      创建具有软化角的指定类型的斜切边框，使用指定的颜色用于突出显示的内边缘和外边缘以及阴影区域。
      static TitledBorder BorderFactory.createTitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      使用指定的定位，字体和颜色将标题添加到现有边框。
      boolean DebugGraphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      void JComponent.setBackground​(Color bg)
      设置此组件的背景颜色。
      void | JList.AccessibleJList.AccessibleJListChild.setBackground​(Color c)
      void JTable.AccessibleJTable.AccessibleJTableCell.setBackground​(Color c)
      设置此对象的背景颜色。
      void JTree.AccessibleJTree.AccessibleJTreeNode.setBackground​(Color c)
      设置此对象的背景颜色。
      void JTabbedPane.setBackgroundAt​(int index, Color background)
      将背景颜色设置为 index至 background ，可以是 null ，在这种情况下，选项卡的背景颜色将默认为 tabbedpane的背景颜色。
      void DebugGraphics.setColor​(Color aColor)
      设置用于绘制和填充线条和形状的颜色。
      void JColorChooser.setColor​(Color color)
      将颜色选择器的当前颜色设置为指定的颜色。
      static void DebugGraphics.setFlashColor​(Color flashColor)
      设置用于闪光绘图操作的颜色。
      void JComponent.setForeground​(Color fg)
      设置此组件的前景颜色。
      void | JList.AccessibleJList.AccessibleJListChild.setForeground​(Color c)
      void JTable.AccessibleJTable.AccessibleJTableCell.setForeground​(Color c)
      设置此对象的前景色。
      void | JTree.AccessibleJTree.AccessibleJTreeNode.setForeground​(Color c)
      void JTabbedPane.setForegroundAt​(int index, Color foreground)
      将前景颜色设置为 index至 foreground ，其可以是 null ，在这种情况下，标签的前景色将默认为此 tabbedpane的前景色。
      void JTable.setGridColor​(Color gridColor)
      将用于绘制网格线的颜色设置为 gridColor并重新显示。
      void JList.setSelectionBackground​(Color selectionBackground)
      设置用于绘制所选项目背景的颜色，哪些单元格渲染器可以使用填充所选单元格。
      void JTable.setSelectionBackground​(Color selectionBackground)
      设置所选单元格的背景颜色。
      void JList.setSelectionForeground​(Color selectionForeground)
      设置用于绘制所选项目的前景的颜色，哪些单元格渲染器可用于渲染文本和图形。
      void JTable.setSelectionForeground​(Color selectionForeground)
      设置所选单元格的前景色。
      void DebugGraphics.setXORMode​(Color aColor)
      覆盖 Graphics.setXORMode 。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor, boolean colorTransparencySelectionEnabled)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      Constructors in javax.swing with parameters of type Color
      Constructor 描述
      JColorChooser​(Color initialColor)
      创建具有指定初始颜色的颜色选择器窗格。

    • Uses of Color in javax.swing.border

      Fields in javax.swing.border declared as Color
      Modifier and Type Field 描述
      protected Color MatteBorder.color
      为边界呈现的颜色。
      protected Color EtchedBorder.highlight
      用于蚀刻高亮的颜色。
      protected Color BevelBorder.highlightInner
      用于斜面内部高光的颜色。
      protected Color BevelBorder.highlightOuter
      用于斜面外部高光的颜色。
      protected Color LineBorder.lineColor
      边框颜色
      protected Color EtchedBorder.shadow
      用于蚀刻阴影的颜色。
      protected Color BevelBorder.shadowInner
      用于斜面内阴影的颜色。
      protected Color BevelBorder.shadowOuter
      用于斜面外阴的颜色
      protected Color TitledBorder.titleColor
      标题的颜色。
      Methods in javax.swing.border that return Color
      Modifier and Type 方法 描述
      Color EtchedBorder.getHighlightColor​()
      返回蚀刻边框的突出显示颜色。
      Color EtchedBorder.getHighlightColor​(Component c)
      在指定的组件上渲染时返回蚀刻边框的突出显示颜色。
      Color BevelBorder.getHighlightInnerColor​()
      返回斜角边框的内部高亮颜色。
      Color BevelBorder.getHighlightInnerColor​(Component c)
      在指定的组件上渲染时返回斜角边框的内部高亮颜色。
      Color BevelBorder.getHighlightOuterColor​()
      返回斜角边框的外部高亮颜色。
      Color BevelBorder.getHighlightOuterColor​(Component c)
      在指定的组件上呈现时，返回斜角边框的外部高亮颜色。
      Color LineBorder.getLineColor​()
      返回边框的颜色。
      Color MatteBorder.getMatteColor​()
      返回用于平铺边框的颜色，如果正在使用图块图标，则返回null。
      Color EtchedBorder.getShadowColor​()
      返回蚀刻边框的阴影颜色。
      Color EtchedBorder.getShadowColor​(Component c)
      在指定的组件上呈现时，返回蚀刻边框的阴影颜色。
      Color BevelBorder.getShadowInnerColor​()
      返回斜角边框的内阴影颜色。
      Color BevelBorder.getShadowInnerColor​(Component c)
      在指定的组件上呈现时，返回斜角边框的内阴影颜色。
      Color BevelBorder.getShadowOuterColor​()
      返回斜角边框的外部阴影颜色。
      Color BevelBorder.getShadowOuterColor​(Component c)
      在指定的组件上呈现时，返回斜角边框的外阴影颜色。
      Color TitledBorder.getTitleColor​()
      返回标题边框的标题颜色。
      Methods in javax.swing.border with parameters of type Color
      Modifier and Type 方法 描述
      void TitledBorder.setTitleColor​(Color titleColor)
      设置标题边框的标题颜色。
      Constructors in javax.swing.border with parameters of type Color
      Constructor 描述
      BevelBorder​(int bevelType, Color highlight, Color shadow)
      创建具有指定类型，高亮和阴影颜色的斜角边框。
      BevelBorder​(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
      创建具有指定类型，高亮和阴影颜色的斜角边框。
      EtchedBorder​(int etchType, Color highlight, Color shadow)
      使用指定的蚀刻类型，高光和阴影颜色创建蚀刻边框。
      EtchedBorder​(Color highlight, Color shadow)
      使用指定的高光和阴影颜色创建一个降低的蚀刻边框。
      LineBorder​(Color color)
      创建具有指定颜色和厚度= 1的线边框。
      LineBorder​(Color color, int thickness)
      创建具有指定颜色和厚度的线边框。
      LineBorder​(Color color, int thickness, boolean roundedCorners)
      创建具有指定颜色，粗细和拐角形状的线条边框。
      MatteBorder​(int top, int left, int bottom, int right, Color matteColor)
      创建具有指定插图和颜色的无光泽边框。
      MatteBorder​(Insets borderInsets, Color matteColor)
      创建具有指定插图和颜色的无光泽边框。
      SoftBevelBorder​(int bevelType, Color highlight, Color shadow)
      创建具有指定类型，高亮和阴影颜色的斜角边框。
      SoftBevelBorder​(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
      创建具有指定类型的斜角边框，突出显示阴影颜色。
      TitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      创建带有指定边框，标题，标题对齐，标题位置，标题字体和标题颜色的TitledBorder实例。

    • Uses of Color in javax.swing.colorchooser

      Methods in javax.swing.colorchooser that return Color
      Modifier and Type 方法 描述
      protected Color AbstractColorChooserPanel.getColorFromModel​()
      返回当前选择的颜色。
      Color ColorSelectionModel.getSelectedColor​()
      返回所选的 Color ，它应该是非 null 。
      Color DefaultColorSelectionModel.getSelectedColor​()
      返回所选的 Color ，它应该是非 null 。
      Methods in javax.swing.colorchooser with parameters of type Color
      Modifier and Type 方法 描述
      void ColorSelectionModel.setSelectedColor​(Color color)
      将所选颜色设置为 color 。
      void DefaultColorSelectionModel.setSelectedColor​(Color color)
      将所选颜色设置为 color 。
      Constructors in javax.swing.colorchooser with parameters of type Color
      Constructor 描述
      DefaultColorSelectionModel​(Color color)
      创建一个 DefaultColorSelectionModel ，当前颜色设置为 color ，应为非 null 。

    • Uses of Color in javax.swing.plaf

      Subclasses of Color in javax.swing.plaf
      Modifier and Type Class 描述
      class  ColorUIResource
      实现UIResource的Color子类。
      Constructors in javax.swing.plaf with parameters of type Color
      Constructor 描述
      BevelBorderUIResource​(int bevelType, Color highlight, Color shadow)
      构造一个 BevelBorderUIResource 。
      BevelBorderUIResource​(int bevelType, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      构造一个 BevelBorderUIResource 。
      ColorUIResource​(Color c)
      构造一个 ColorUIResource 。
      EtchedBorderUIResource​(int etchType, Color highlight, Color shadow)
      构造一个 EtchedBorderUIResource 。
      EtchedBorderUIResource​(Color highlight, Color shadow)
      构造一个 EtchedBorderUIResource 。
      LineBorderUIResource​(Color color)
      构造一个 LineBorderUIResource 。
      LineBorderUIResource​(Color color, int thickness)
      构造一个 LineBorderUIResource 。
      MatteBorderUIResource​(int top, int left, int bottom, int right, Color color)
      构造一个 MatteBorderUIResource 。
      TitledBorderUIResource​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      构造一个 TitledBorderUIResource 。

    • Uses of Color in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Color
      Modifier and Type Field 描述
      protected Color BasicMenuItemUI.acceleratorForeground
      加速器前景的颜色。
      protected Color BasicMenuItemUI.acceleratorSelectionForeground
      加速器选择的颜色。
      protected Color BasicBorders.ButtonBorder.darkShadow
      阴影的颜色。
      protected Color BasicBorders.FieldBorder.darkShadow
      阴影的颜色。
      protected Color BasicTabbedPaneUI.darkShadow
      暗影色
      protected Color BasicMenuItemUI.disabledForeground
      禁用前景的颜色。
      protected Color BasicToolBarUI.dockingBorderColor
      对接边框的颜色。
      protected Color BasicToolBarUI.dockingColor
      对接边框的背景颜色。
      protected Color BasicToolBarUI.floatingBorderColor
      不对接边框的颜色。
      protected Color BasicToolBarUI.floatingColor
      不对接边框的背景颜色。
      protected Color BasicTabbedPaneUI.focus
      聚焦颜色
      protected Color BasicBorders.ButtonBorder.highlight
      亮点的颜色。
      protected Color BasicBorders.FieldBorder.highlight
      亮点的颜色。
      protected Color BasicBorders.SplitPaneBorder.highlight
      亮点的颜色
      protected Color BasicSeparatorUI.highlight
      突出显示的颜色。
      protected Color BasicTabbedPaneUI.highlight
      突出显示颜色
      protected Color BasicBorders.ButtonBorder.lightHighlight
      光的颜色突出。
      protected Color BasicBorders.FieldBorder.lightHighlight
      光的颜色突出。
      protected Color BasicTabbedPaneUI.lightHighlight
      光亮色彩
      protected Color BasicInternalFrameTitlePane.notSelectedTextColor
      未选择文字的颜色。
      protected Color BasicInternalFrameTitlePane.notSelectedTitleColor
      未选择标题的颜色。
      protected Color BasicInternalFrameTitlePane.selectedTextColor
      所选文字的颜色。
      protected Color BasicInternalFrameTitlePane.selectedTitleColor
      所选标题的颜色。
      protected Color BasicMenuItemUI.selectionBackground
      选择背景的颜色。
      protected Color BasicMenuItemUI.selectionForeground
      选择前景的颜色。
      protected Color BasicBorders.ButtonBorder.shadow
      阴影的颜色
      protected Color BasicBorders.FieldBorder.shadow
      阴影的颜色
      protected Color BasicBorders.SplitPaneBorder.shadow
      阴影的颜色
      protected Color BasicSeparatorUI.shadow
      阴影的颜色。
      protected Color BasicTabbedPaneUI.shadow
      阴影颜色
      protected Color BasicScrollBarUI.thumbColor
      拇指颜色
      protected Color BasicScrollBarUI.thumbDarkShadowColor
      拇指暗影色
      protected Color BasicScrollBarUI.thumbHighlightColor
      拇指高亮颜色
      protected Color BasicScrollBarUI.thumbLightShadowColor
      拇指光阴影色
      protected Color BasicScrollBarUI.trackColor
      跟踪颜色
      protected Color BasicScrollBarUI.trackHighlightColor
      跟踪高亮颜色
      Methods in javax.swing.plaf.basic that return Color
      Modifier and Type 方法 描述
      Color BasicToolBarUI.DragWindow.getBorderColor​()
      返回边框颜色。
      Color BasicToolBarUI.getDockingColor​()
      获取在停靠区域上显示的颜色
      Color BasicToolBarUI.getFloatingColor​()
      获取在浮动区域上显示的颜色
      protected Color BasicSliderUI.getFocusColor​()
      返回焦点颜色。
      protected Color BasicTreeUI.getHashColor​()
      返回散列颜色。
      protected Color BasicSliderUI.getHighlightColor​()
      返回突出显示颜色。
      protected Color BasicProgressBarUI.getSelectionBackground​()
      “selectionBackground”是当文字绘制在进度条的未填充区域时的颜色。
      protected Color BasicProgressBarUI.getSelectionForeground​()
      “selectionForeground”是当绘制在进度条的填充区域时的文本颜色。
      protected Color BasicSliderUI.getShadowColor​()
      返回阴影颜色。
      Methods in javax.swing.plaf.basic with parameters of type Color
      Modifier and Type 方法 描述
      static void BasicGraphicsUtils.drawBezel​(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      画一个挡板
      static void BasicGraphicsUtils.drawEtchedRect​(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      画一个蚀刻的矩形。
      static void BasicGraphicsUtils.drawGroove​(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
      画一个凹槽
      static void BasicGraphicsUtils.drawLoweredBezel​(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      画下一个挡板。
      protected void BasicMenuItemUI.paintBackground​(Graphics g, JMenuItem menuItem, Color bgColor)
      绘制菜单项的背景。
      protected void BasicMenuItemUI.paintMenuItem​(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
      画一个菜单项。
      void BasicToolBarUI.DragWindow.setBorderColor​(Color c)
      设置边框颜色。
      void BasicToolBarUI.setDockingColor​(Color c)
      设置在停靠区域上显示的颜色
      void BasicToolBarUI.setFloatingColor​(Color c)
      设置在浮动区域上显示的颜色
      protected void BasicTreeUI.setHashColor​(Color color)
      设置散列颜色。
      Constructors in javax.swing.plaf.basic with parameters of type Color
      Constructor 描述
      BasicArrowButton​(int direction, Color background, Color shadow, Color darkShadow, Color highlight)
      创建一个 BasicArrowButton其箭头以指定的方向绘制并具有指定的颜色。
      ButtonBorder​(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      构造一个新的实例 ButtonBorder 。
      FieldBorder​(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      构造一个新的实例 FieldBorder 。
      MenuBarBorder​(Color shadow, Color highlight)
      构造一个新的实例 MenuBarBorder 。
      RadioButtonBorder​(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      构造一个新的实例 RadioButtonBorder 。
      RolloverButtonBorder​(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      构造一个新的实例 RolloverButtonBorder 。
      SplitPaneBorder​(Color highlight, Color shadow)
      构造一个新的实例 SplitPaneBorder 。
      ToggleButtonBorder​(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      构造一个新的实例 ToggleButtonBorder 。

    • Uses of Color in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as Color
      Modifier and Type Field 描述
      protected static Color MetalSliderUI.darkShadowColor
      阴影的颜色。
      protected Color MetalButtonUI.disabledTextColor
      禁用颜色的颜色。
      protected Color MetalRadioButtonUI.disabledTextColor
      禁用文字的颜色。
      protected Color MetalToggleButtonUI.disabledTextColor
      禁用文字的颜色。
      protected Color MetalButtonUI.focusColor
      聚焦按钮的颜色。
      protected Color MetalRadioButtonUI.focusColor
      聚焦单选按钮的颜色。
      protected Color MetalToggleButtonUI.focusColor
      聚焦切换按钮的颜色。
      protected static Color MetalSliderUI.highlightColor
      突出的颜色。
      protected Color MetalButtonUI.selectColor
      所选按钮的颜色。
      protected Color MetalRadioButtonUI.selectColor
      所选单选按钮的颜色。
      protected Color MetalTabbedPaneUI.selectColor
      所选窗格的颜色。
      protected Color MetalToggleButtonUI.selectColor
      所选按钮的颜色。
      protected Color MetalTabbedPaneUI.selectHighlight
      亮点的颜色。
      protected Color MetalTabbedPaneUI.tabAreaBackground
      标签背景的颜色。
      protected static Color MetalSliderUI.thumbColor
      拇指的颜色
      Methods in javax.swing.plaf.metal that return Color
      Modifier and Type 方法 描述
      protected Color MetalTabbedPaneUI.getColorForGap​(int currentRun, int x, int y)
      返回间隙的颜色。
      protected Color MetalButtonUI.getDisabledTextColor​()
      返回禁用文字的颜色。
      protected Color MetalRadioButtonUI.getDisabledTextColor​()
      返回禁用文字的颜色。
      protected Color MetalToggleButtonUI.getDisabledTextColor​()
      返回禁用文字的颜色。
      protected Color MetalButtonUI.getFocusColor​()
      返回对焦按钮的颜色。
      protected Color MetalRadioButtonUI.getFocusColor​()
      返回聚焦的颜色 JRadioButton 。
      protected Color MetalToggleButtonUI.getFocusColor​()
      返回重点切换按钮的颜色。
      protected Color MetalButtonUI.getSelectColor​()
      返回所选按钮的颜色。
      protected Color MetalRadioButtonUI.getSelectColor​()
      返回所选 JRadioButton的颜色。
      protected Color MetalToggleButtonUI.getSelectColor​()
      返回所选按钮的颜色。

    • Uses of Color in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return Color
      Modifier and Type 方法 描述
      protected Color AbstractRegionPainter.decodeColor​(Color color1, Color color2, float midPoint)
      解码并返回从两个其他颜色之间的偏移导出的颜色。
      protected Color AbstractRegionPainter.decodeColor​(String key, float hOffset, float sOffset, float bOffset, int aOffset)
      解码并返回从UI默认值中的基色导出的颜色。
      protected Color NimbusStyle.getColorForState​(SynthContext ctx, ColorType type)
      返回指定状态的颜色。
      protected Color AbstractRegionPainter.getComponentColor​(JComponent c, String property, Color defaultColor, float saturationOffset, float brightnessOffset, int alphaOffset)
      从给定的JComponent获取颜色属性。
      protected Color NimbusLookAndFeel.getDerivedColor​(Color color1, Color color2, float midPoint)
      解码并返回从两个其他颜色之间的偏移导出的颜色。
      protected Color NimbusLookAndFeel.getDerivedColor​(Color color1, Color color2, float midPoint, boolean uiResource)
      解码并返回从两个其他颜色之间的偏移导出的颜色。
      Color NimbusLookAndFeel.getDerivedColor​(String uiDefaultParentName, float hOffset, float sOffset, float bOffset, int aOffset, boolean uiResource)
      获取派生颜色，派生颜色是共享实例，并且当其父UIDefault颜色更改时，颜色值将更改。
      Methods in javax.swing.plaf.nimbus with parameters of type Color
      Modifier and Type 方法 描述
      protected Color AbstractRegionPainter.decodeColor​(Color color1, Color color2, float midPoint)
      解码并返回从两个其他颜色之间的偏移导出的颜色。
      protected LinearGradientPaint AbstractRegionPainter.decodeGradient​(float x1, float y1, float x2, float y2, float[] midpoints, Color[] colors)
      给定用于创建LinearGradientPaint的参数，此方法将创建并返回一个线性渐变画线。
      protected RadialGradientPaint AbstractRegionPainter.decodeRadialGradient​(float x, float y, float r, float[] midpoints, Color[] colors)
      给定用于创建RadialGradientPaint的参数，此方法将创建并返回径向渐变画。
      protected Color AbstractRegionPainter.getComponentColor​(JComponent c, String property, Color defaultColor, float saturationOffset, float brightnessOffset, int alphaOffset)
      从给定的JComponent获取颜色属性。
      protected Color NimbusLookAndFeel.getDerivedColor​(Color color1, Color color2, float midPoint)
      解码并返回从两个其他颜色之间的偏移导出的颜色。
      protected Color NimbusLookAndFeel.getDerivedColor​(Color color1, Color color2, float midPoint, boolean uiResource)
      解码并返回从两个其他颜色之间的偏移导出的颜色。

    • Uses of Color in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Color
      Modifier and Type 方法 描述
      Color SynthStyle.getColor​(SynthContext context, ColorType type)
      返回指定状态的颜色。
      protected abstract Color SynthStyle.getColorForState​(SynthContext context, ColorType type)
      返回指定状态的颜色。

    • Uses of Color in javax.swing.table

      Methods in javax.swing.table that return Color
      Modifier and Type | 方法 | 描述
      Color | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBackground​()
      Color | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getForeground​()
      Methods in javax.swing.table with parameters of type Color
      Modifier and Type | 方法 | 描述
      void DefaultTableCellRenderer.setBackground​(Color c)
      覆盖 JComponent.setBackground以将未选择的背景颜色分配给指定的颜色。
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setBackground​(Color c)
      void DefaultTableCellRenderer.setForeground​(Color c)
      覆盖 JComponent.setForeground以将未选择的前景颜色分配给指定的颜色。
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setForeground​(Color c)

    • Uses of Color in javax.swing.text

      Methods in javax.swing.text that return Color
      Modifier and Type 方法 描述
      Color DefaultStyledDocument.getBackground​(AttributeSet attr)
      从属性集获取背景颜色。
      Color GlyphView.getBackground​()
      获取用于渲染字形的背景颜色。
      Color LabelView.getBackground​()
      获取用于渲染字形的背景颜色。
      static Color StyleConstants.getBackground​(AttributeSet a)
      从属性列表中获取背景颜色设置。
      Color StyleContext.getBackground​(AttributeSet attr)
      获取一组属性并将其转换为背景颜色规范。
      Color StyledDocument.getBackground​(AttributeSet attr)
      获取一组属性并将其转换为背景颜色规范。
      Color JTextComponent.getCaretColor​()
      获取当前用于渲染插入符号的颜色。
      Color DefaultHighlighter.DefaultHighlightPainter.getColor​()
      返回突出显示的颜色。
      Color JTextComponent.getDisabledTextColor​()
      获取用于呈现禁用的文本的当前颜色。
      Color DefaultStyledDocument.getForeground​(AttributeSet attr)
      从属性集获取前景色。
      Color GlyphView.getForeground​()
      获取用于渲染字形的前景色。
      Color LabelView.getForeground​()
      获取用于渲染字形的前景色。
      static Color StyleConstants.getForeground​(AttributeSet a)
      从属性列表获取前景色设置。
      Color StyleContext.getForeground​(AttributeSet attr)
      获取一组属性，并将其转换为前景颜色规范。
      Color StyledDocument.getForeground​(AttributeSet attr)
      获取一组属性，并将其转换为前景颜色规范。
      Color JTextComponent.getSelectedTextColor​()
      获取用于呈现所选文本的当前颜色。
      Color JTextComponent.getSelectionColor​()
      获取用于渲染选择的当前颜色。
      Methods in javax.swing.text with parameters of type Color
      Modifier and Type 方法 描述
      protected void LabelView.setBackground​(Color bg)
      设置视图的背景颜色。
      static void StyleConstants.setBackground​(MutableAttributeSet a, Color fg)
      设置背景颜色。
      void JTextComponent.setCaretColor​(Color c)
      设置用于渲染插入符号的当前颜色。
      void JTextComponent.setDisabledTextColor​(Color c)
      设置用于呈现禁用的文本的当前颜色。
      static void StyleConstants.setForeground​(MutableAttributeSet a, Color fg)
      设置前景色。
      void JTextComponent.setSelectedTextColor​(Color c)
      设置用于渲染所选文本的当前颜色。
      void JTextComponent.setSelectionColor​(Color c)
      设置用于渲染选择的当前颜色。
      Constructors in javax.swing.text with parameters of type Color
      Constructor 描述
      DefaultHighlightPainter​(Color c)
      构建一个新的亮点画家。
      ForegroundAction​(String nm, Color fg)
      创建一个新的ForegroundAction。

    • Uses of Color in javax.swing.text.html

      Methods in javax.swing.text.html that return Color
      Modifier and Type 方法 描述
      Color StyleSheet.getBackground​(AttributeSet a)
      获取一组属性并将其转换为背景颜色规范。
      Color StyleSheet.getForeground​(AttributeSet a)
      获取一组属性，并将其转换为前景颜色规范。
      Color StyleSheet.stringToColor​(String string)
      将颜色串（例如“RED”或“#NNNNNN”）转换为颜色。

    • Uses of Color in javax.swing.tree

      Fields in javax.swing.tree declared as Color
      Modifier and Type Field 描述
      protected Color DefaultTreeCellRenderer.backgroundNonSelectionColor
      未选择节点时用于背景的颜色。
      protected Color DefaultTreeCellRenderer.backgroundSelectionColor
      选择节点时用于背景的颜色。
      protected Color DefaultTreeCellEditor.borderSelectionColor
      如果绘制边框选择颜色，则为真。
      protected Color DefaultTreeCellRenderer.borderSelectionColor
      当节点具有焦点时，用于聚焦指示符的颜色。
      protected Color DefaultTreeCellRenderer.textNonSelectionColor
      用于未选择节点前景的颜色。
      protected Color DefaultTreeCellRenderer.textSelectionColor
      用于所选节点前景的颜色。
      Methods in javax.swing.tree that return Color
      Modifier and Type 方法 描述
      Color DefaultTreeCellRenderer.getBackgroundNonSelectionColor​()
      返回要用于非选定节点的背景颜色。
      Color DefaultTreeCellRenderer.getBackgroundSelectionColor​()
      如果选择节点，则返回用于背景的颜色。
      Color DefaultTreeCellEditor.getBorderSelectionColor​()
      返回绘制边框的颜色。
      Color DefaultTreeCellRenderer.getBorderSelectionColor​()
      返回绘制边框的颜色。
      Color DefaultTreeCellRenderer.getTextNonSelectionColor​()
      返回当未选择节点时绘制文本的颜色。
      Color DefaultTreeCellRenderer.getTextSelectionColor​()
      返回在选择节点时绘制文本的颜色。
      Methods in javax.swing.tree with parameters of type Color
      Modifier and Type 方法 描述
      void DefaultTreeCellRenderer.setBackground​(Color color)
      子类映射为 ColorUIResource s为null。
      void DefaultTreeCellRenderer.setBackgroundNonSelectionColor​(Color newColor)
      设置要用于非选定节点的背景颜色。
      void DefaultTreeCellRenderer.setBackgroundSelectionColor​(Color newColor)
      如果选择了节点，则设置用于背景的颜色。
      void DefaultTreeCellEditor.setBorderSelectionColor​(Color newColor)
      设置要用于边框的颜色。
      void DefaultTreeCellRenderer.setBorderSelectionColor​(Color newColor)
      设置要用于边框的颜色。
      void DefaultTreeCellRenderer.setTextNonSelectionColor​(Color newColor)
      当没有选择节点时，设置文本绘制的颜色。
      void DefaultTreeCellRenderer.setTextSelectionColor​(Color newColor)
      设置当选择节点时绘制文本的颜色。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Component (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Component

  • Packages that use Component
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.im
    提供输入法框架的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供 HTMLEditorKit类和支持类来创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Component in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as Component
      Modifier and Type Field 描述
      protected static Component AWTEventMonitor.componentWithFocus
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用; 使用getComponentWithFocus方法获取焦点的组件。
      Methods in com.sun.java.accessibility.util that return Component
      Modifier and Type 方法 描述
      static Component AWTEventMonitor.getComponentWithFocus​()
      返回当前具有键盘焦点的组件。

    • Uses of Component in java.applet

      Subclasses of Component in java.applet
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of Component in java.awt

      Subclasses of Component in java.awt
      Modifier and Type Class 描述
      class  Button
      这个类创建一个标记的按钮。
      class  Canvas
      Canvas组件表示应用程序可以在其上绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。
      class  Checkbox
      复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
      class  Choice
      Choice课程提供了一个弹出菜单的选择。
      class  Container
      通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
      class  Dialog
      Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      class  Frame
      A Frame是一个标题和边框的顶级窗口。
      class  Label
      A Label对象是用于将文本放置在容器中的组件。
      class  List
      List组件向用户显示文本项的滚动列表。
      class  Panel
      Panel是最简单的容器类。
      class  Scrollbar
      Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。
      class  ScrollPane
      一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。
      class  TextArea
      一个 TextArea对象是一个显示文本的多行区域。
      class  TextComponent
      TextComponent类是允许编辑某些文本的任何组件的超类。
      class  TextField
      TextField对象是允许编辑单行文本的文本组件。
      class  Window
      一个 Window对象是没有边框的顶级窗口，没有菜单栏。
      Fields in java.awt with type parameters of type Component
      Modifier and Type Field 描述
      protected Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
      这个散列表维护了一个组件与其gridbag约束之间的关联。
      Methods in java.awt that return Component
      Modifier and Type 方法 描述
      Component Container.add​(Component comp)
      将指定的组件附加到此容器的末尾。
      Component Container.add​(Component comp, int index)
      在给定的位置将指定的组件添加到此容器。
      Component Container.add​(String name, Component comp)
      将指定的组件添加到此容器。
      Component Container.findComponentAt​(int x, int y)
      找到包含指定位置的可见子组件。
      Component Container.findComponentAt​(Point p)
      找到包含指定点的可见子组件。
      Component Container.getComponent​(int n)
      获取此容器中的第n个组件。
      Component ContainerOrderFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      abstract Component FocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component Component.getComponentAt​(int x, int y)
      确定此组件或其一个直接子组件是否包含（ x ， y ）位置，如果是，则返回包含的组件。
      Component Component.getComponentAt​(Point p)
      返回包含指定点的组件或子组件。
      Component Container.getComponentAt​(int x, int y)
      找到包含x，y位置的组件。
      Component Container.getComponentAt​(Point p)
      获取包含指定点的组件。
      Component ContainerOrderFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      abstract Component FocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      Component[] Container.getComponents​()
      获取此容器中的所有组件。
      Component ContainerOrderFocusTraversalPolicy.getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      abstract Component FocusTraversalPolicy.getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      Component ContainerOrderFocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      abstract Component FocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      Component KeyboardFocusManager.getFocusOwner​()
      如果焦点所有者与调用线程处于相同的上下文中，则返回焦点所有者。
      Component Window.getFocusOwner​()
      如果此窗口被聚焦，则返回此窗口的具有焦点的子组件; 否则返回null。
      protected Component KeyboardFocusManager.getGlobalFocusOwner​()
      即使调用线程与焦点所有者的上下文不同，返回焦点所有者。
      protected Component KeyboardFocusManager.getGlobalPermanentFocusOwner​()
      返回永久焦点所有者，即使调用线程与永久焦点所有者处于不同的上下文中。
      Component FocusTraversalPolicy.getInitialComponent​(Window window)
      返回当窗口第一次可见时应接收焦点的组件。
      Component ContainerOrderFocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      abstract Component FocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      Component BorderLayout.getLayoutComponent​(Container target, Object constraints)
      基于目标 Container的组件方向返回与给定约束位置相对应的组件。
      Component BorderLayout.getLayoutComponent​(Object constraints)
      获取使用给定约束添加的组件
      Component Window.getMostRecentFocusOwner​()
      返回此窗口的子组件，该窗口将在此窗口聚焦时接收焦点。
      Component KeyboardFocusManager.getPermanentFocusOwner​()
      如果永久焦点所有者与调用线程处于相同的上下文中，则返回永久焦点所有者。
      Component Component.locate​(int x, int y)
      已过时。
      从JDK 1.1版开始，由getComponentAt（int，int）替换。
      Component Container.locate​(int x, int y)
      已过时。
      从JDK 1.1版开始，由getComponentAt(int, int)替代。
      Methods in java.awt with parameters of type Component
      Modifier and Type 方法 描述
      protected boolean ContainerOrderFocusTraversalPolicy.accept​(Component aComponent)
      确定组件是否是新焦点所有者的可接受选择。
      protected boolean DefaultFocusTraversalPolicy.accept​(Component aComponent)
      确定组件是否是新焦点所有者的可接受选择。
      Component Container.add​(Component comp)
      将指定的组件附加到此容器的末尾。
      Component Container.add​(Component comp, int index)
      在给定的位置将指定的组件添加到此容器。
      void Container.add​(Component comp, Object constraints)
      将指定的组件添加到此容器的末尾。
      void Container.add​(Component comp, Object constraints, int index)
      将指定的组件添加到指定索引处的指定约束的容器中。
      Component Container.add​(String name, Component comp)
      将指定的组件添加到此容器。
      protected void Container.addImpl​(Component comp, Object constraints, int index)
      在指定的索引处将指定的组件添加到此容器。
      protected void ScrollPane.addImpl​(Component comp, Object constraints, int index)
      将指定的组件添加到此滚动窗格容器。
      void BorderLayout.addLayoutComponent​(Component comp, Object constraints)
      使用指定的约束对象将指定的组件添加到布局。
      void BorderLayout.addLayoutComponent​(String name, Component comp)
      已过时。
      替换为addLayoutComponent(Component, Object) 。
      void CardLayout.addLayoutComponent​(Component comp, Object constraints)
      将指定的组件添加到此卡布局的内部名称表中。
      void CardLayout.addLayoutComponent​(String name, Component comp)
      已过时。
      替换为addLayoutComponent(Component, Object) 。
      void FlowLayout.addLayoutComponent​(String name, Component comp)
      将指定的组件添加到布局。
      void GridBagLayout.addLayoutComponent​(Component comp, Object constraints)
      使用指定的 constraints对象将指定的组件添加到布局。
      void GridBagLayout.addLayoutComponent​(String name, Component comp)
      没有效果，因为此布局管理器不使用每个组件字符串。
      void GridLayout.addLayoutComponent​(String name, Component comp)
      将具有指定名称的指定组件添加到布局。
      void LayoutManager.addLayoutComponent​(String name, Component comp)
      如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与由 name指定的字符串相关联。
      void LayoutManager2.addLayoutComponent​(Component comp, Object constraints)
      使用指定的约束对象将指定的组件添加到布局。
      <T extends DragGestureRecognizer>
      T             		Toolkit.createDragGestureRecognizer​(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
      创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。
      protected void DefaultKeyboardFocusManager.dequeueKeyEvents​(long after, Component untilFocused)
      发布正常分派给当前焦点所有者的所有KeyEvents，由于调用具有相同时间戳和组件的 enqueueKeyEvents而排入队列。
      protected abstract void KeyboardFocusManager.dequeueKeyEvents​(long after, Component untilFocused)
      由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。
      protected void DefaultKeyboardFocusManager.discardKeyEvents​(Component comp)
      丢弃由于一次或 enqueueKeyEvents使用指定的组件或其后代调用 enqueueKeyEvents而排入队列的所有KeyEvent。
      protected abstract void KeyboardFocusManager.discardKeyEvents​(Component comp)
      由AWT调用以通知KeyboardFocusManager它应该取消KeyEvents的延迟调度。
      protected void DefaultKeyboardFocusManager.enqueueKeyEvents​(long after, Component untilFocused)
      延迟调度KeyEvents直到指定的Component成为焦点所有者。
      protected abstract void KeyboardFocusManager.enqueueKeyEvents​(long after, Component untilFocused)
      由AWT调用，通知KeyboardFocusManager它应该延迟调度KeyEvents，直到指定的Component成为焦点所有者。
      void DefaultKeyboardFocusManager.focusNextComponent​(Component aComponent)
      将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
      abstract void KeyboardFocusManager.focusNextComponent​(Component aComponent)
      将组件聚焦在aComponent之后，通常基于FocusTraversalPolicy。
      void DefaultKeyboardFocusManager.focusPreviousComponent​(Component aComponent)
      在组件之前聚焦组件，通常基于FocusTraversalPolicy。
      abstract void KeyboardFocusManager.focusPreviousComponent​(Component aComponent)
      在组件之前聚焦组件，通常基于FocusTraversalPolicy。
      Component ContainerOrderFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      abstract Component FocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component ContainerOrderFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      abstract Component FocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      int Container.getComponentZOrder​(Component comp)
      返回容器内组件的z-order索引。
      Object BorderLayout.getConstraints​(Component comp)
      获取指定组件的约束
      GridBagConstraints GridBagLayout.getConstraints​(Component comp)
      获取指定组件的约束。
      protected static Container Toolkit.getNativeContainer​(Component c)
      给本地对等体提供给本地组件查询本机容器的能力（例如，直接父级可能是轻量级的）。
      boolean Container.isAncestorOf​(Component c)
      检查组件是否包含在此容器的组件层次结构中。
      protected GridBagConstraints GridBagLayout.lookupConstraints​(Component comp)
      检索指定组件的约束。
      void DefaultKeyboardFocusManager.processKeyEvent​(Component focusedComponent, KeyEvent e)
      当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。
      abstract void KeyboardFocusManager.processKeyEvent​(Component focusedComponent, KeyEvent e)
      当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。
      void KeyboardFocusManager.redispatchEvent​(Component target, AWTEvent e)
      重新分配AWTEvent，AWT事件调度程序将不会递归地请求KeyboardFocusManager或任何已安装的KeyEventDispatchers再次发送事件。
      void Container.remove​(Component comp)
      从此容器中删除指定的组件。
      void BorderLayout.removeLayoutComponent​(Component comp)
      从此边框布局中删除指定的组件。
      void CardLayout.removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void FlowLayout.removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void GridBagLayout.removeLayoutComponent​(Component comp)
      从此布局中删除指定的组件。
      void GridLayout.removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void LayoutManager.removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void Container.setComponentZOrder​(Component comp, int index)
      将指定的组件移动到容器中指定的z顺序索引。
      void GridBagLayout.setConstraints​(Component comp, GridBagConstraints constraints)
      设置此布局中指定组件的约束。
      protected void KeyboardFocusManager.setGlobalFocusOwner​(Component focusOwner)
      设置焦点所有者。
      protected void KeyboardFocusManager.setGlobalPermanentFocusOwner​(Component permanentFocusOwner)
      设置永久焦点所有者。
      void Window.setLocationRelativeTo​(Component c)
      根据以下情况设置窗口相对于指定组件的位置。
      void PopupMenu.show​(Component origin, int x, int y)
      在相对于原始组件的x，y位置显示弹出式菜单。
      void DefaultKeyboardFocusManager.upFocusCycle​(Component aComponent)
      将焦点移动到一个焦点遍历周期。
      abstract void KeyboardFocusManager.upFocusCycle​(Component aComponent)
      将焦点移动到一个焦点遍历周期。
      Constructors in java.awt with parameters of type Component
      Constructor 描述
      MediaTracker​(Component comp)
      创建媒体跟踪器以跟踪给定组件的图像。

    • Uses of Component in java.awt.dnd

      Fields in java.awt.dnd declared as Component
      Modifier and Type Field 描述
      protected Component DragGestureRecognizer.component
      该 Component与此 DragGestureRecognizer相关联。
      Methods in java.awt.dnd that return Component
      Modifier and Type 方法 描述
      Component DragGestureEvent.getComponent​()
      返回 Component与此相关 DragGestureEvent 。
      Component DragGestureRecognizer.getComponent​()
      该方法返回 Component ，由 DragGestureRecognizer “观察”用于拖动启动手势。
      Component DragSourceContext.getComponent​()
      返回 Component与此相关 DragSourceContext 。
      Component DropTarget.getComponent​()
      获取 Component与此 DropTarget相关联。
      Component DropTargetContext.getComponent​()
      此方法返回 Component与此相关 DropTargetContext 。
      Methods in java.awt.dnd with parameters of type Component
      Modifier and Type 方法 描述
      DragGestureRecognizer DragSource.createDefaultDragGestureRecognizer​(Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer实现的默认抽象子类 DragGestureRecognizer这个 DragSource ，并设置指定 Component和 DragGestureListener新创建的对象上。
      <T extends DragGestureRecognizer>
      T             		DragSource.createDragGestureRecognizer​(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer ，实现指定的抽象子类 DragGestureRecognizer ，并在新创建的对象上设置指定的 Component和 DragGestureListener 。
      protected DropTarget.DropTargetAutoScroller DropTarget.createDropTargetAutoScroller​(Component c, Point p)
      创建一个嵌入式自动推送器
      void DragGestureRecognizer.setComponent​(Component c)
      将DragGestureRecognizer与registerListeners（）和unregisterListeners（）相关联的组件设置为适当的副作用。
      void DropTarget.setComponent​(Component c)
      注意：此接口需要允许以两种方式之一安全地将DropTarget与组件关联： component.setDropTarget(droptarget);或 droptarget.setComponent(component);
      Constructors in java.awt.dnd with parameters of type Component
      Constructor 描述
      DragGestureRecognizer​(DragSource ds, Component c)
      构建一个新的 DragGestureRecognizer给出 DragSource用于此拖放操作，而 Component这个 DragGestureRecognizer应该“观察”拖动启动手势。
      DragGestureRecognizer​(DragSource ds, Component c, int sa)
      构造一个新的 DragGestureRecognizer给定 DragSource以在此拖放操作中使用， Component这个 DragGestureRecognizer应该“观察”用于拖动启动手势，以及此拖放操作支持的操作。
      DragGestureRecognizer​(DragSource ds, Component c, int sa, DragGestureListener dgl)
      构造一个新的 DragGestureRecognizer给定 DragSource用于这个拖放操作， Component这个 DragGestureRecognizer应该“观察”拖动启动手势，这个拖放操作支持的动作，以及 DragGestureListener通知一次已经检测到拖动启动手势。
      DropTarget​(Component c, int ops, DropTargetListener dtl)
      创建一个 DropTarget给出了 Component来关联自己，一个 int表示默认可接受的操作支持，一个 DropTargetListener处理事件处理。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act)
      创建一个 DropTarget给出 Component以关联自己，一个 int表示默认可接受的动作以支持，一个 DropTargetListener来处理事件处理，以及一个 boolean指示 DropTarget是否正在接受丢弃。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
      创建一个新的DropTarget，给出了 Component与自己相关联，一个 int表示默认可接受的动作来支持，一个 DropTargetListener处理事件处理，一个 boolean指示 DropTarget是否正在接受丢弃，以及一个 FlavorMap使用（或null为默认值 FlavorMap ）。
      DropTarget​(Component c, DropTargetListener dtl)
      创建一个 DropTarget给予 Component来关联自己，和 DropTargetListener来处理事件处理。
      DropTargetAutoScroller​(Component c, Point p)
      构建一个DropTargetAutoScroller
      MouseDragGestureRecognizer​(DragSource ds, Component c)
      构造一个新的 MouseDragGestureRecognizer给出 DragSource为 Component c和 Component观察。
      MouseDragGestureRecognizer​(DragSource ds, Component c, int act)
      构造一个新的 MouseDragGestureRecognizer给出 DragSource为 Component c， Component观察，并允许这种拖动操作的动作。
      MouseDragGestureRecognizer​(DragSource ds, Component c, int act, DragGestureListener dgl)
      构造一个新的 MouseDragGestureRecognizer给予 DragSource为 Component c， Component观察，这个拖动操作允许的动作，以及 DragGestureListener通知何时检测到拖动手势。

    • Uses of Component in java.awt.event

      Methods in java.awt.event that return Component
      Modifier and Type 方法 描述
      Component HierarchyEvent.getChanged​()
      返回已更改的层次结构顶部的组件。
      Component ContainerEvent.getChild​()
      返回受事件影响的组件。
      Component ComponentEvent.getComponent​()
      返回事件的发起者。
      Component HierarchyEvent.getComponent​()
      返回事件的发起者。
      Component FocusEvent.getOppositeComponent​()
      返回此焦点更改中涉及的其他组件。
      Constructors in java.awt.event with parameters of type Component
      Constructor 描述
      ComponentEvent​(Component source, int id)
      构造一个 ComponentEvent对象。
      ContainerEvent​(Component source, int id, Component child)
      构造一个 ContainerEvent对象。
      FocusEvent​(Component source, int id)
      构造一个 FocusEvent对象，并将其标识为焦点的永久性更改。
      FocusEvent​(Component source, int id, boolean temporary)
      构造一个 FocusEvent对象，并确定更改是否是临时的。
      FocusEvent​(Component source, int id, boolean temporary, Component opposite)
      构造一个 FocusEvent对象，具有指定的临时状态，对面为 Component和 Cause.UNKNOWN原因。
      FocusEvent​(Component source, int id, boolean temporary, Component opposite, FocusEvent.Cause cause)
      构造一个具有指定临时状态的 FocusEvent对象， Component的原因为 Component 。
      HierarchyEvent​(Component source, int id, Component changed, Container changedParent)
      构造一个 HierarchyEvent对象，以标识 Component层次结构中的更改。
      HierarchyEvent​(Component source, int id, Component changed, Container changedParent, long changeFlags)
      构造一个 HierarchyEvent对象，以标识 Component层次结构中的更改。
      InputMethodEvent​(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定源组件，类型，时间，文本，插入符和 InputMethodEvent 。
      InputMethodEvent​(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定源组件，类型，插入符号和 InputMethodEvent 。
      InputMethodEvent​(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定的源组件，类型，文本，插入符和 InputMethodEvent 。
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode)
      已过时。
      截至JDK1.1; 改用KeyEvent(Component, int, long, int, int, char)
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode, char keyChar)
      构造一个 KeyEvent对象。
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode, char keyChar, int keyLocation)
      构造一个 KeyEvent对象。
      MouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger)
      构造一个具有指定的源组件，类型，修饰符，坐标，点击数和弹出触发标志的 MouseEvent对象。
      MouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int button)
      构造一个具有指定的源组件，类型，时间，修饰符，坐标，点击计数，弹出触发器标志和按钮编号的 MouseEvent对象。
      MouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int button)
      构造一个具有指定源组件，类型，时间，修饰符，坐标，绝对坐标，点击计数，弹出触发标志和按钮编号的 MouseEvent对象。
      MouseWheelEvent​(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
      构造具有指定源组件，类型，修饰符，坐标，滚动类型，滚动量和轮子旋转的 MouseWheelEvent对象。
      MouseWheelEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
      构造具有指定的源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮子旋转的 MouseWheelEvent对象。
      MouseWheelEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation, double preciseWheelRotation)
      构造具有指定的源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮子旋转的 MouseWheelEvent对象。
      PaintEvent​(Component source, int id, Rectangle updateRect)
      使用指定的源组件和类型构造一个 PaintEvent对象。

    • Uses of Component in java.awt.im

      Methods in java.awt.im with parameters of type Component
      Modifier and Type 方法 描述
      void InputContext.removeNotify​(Component client)
      通知输入上下文，客户端组件已从其包含层次结构中删除，或该组件已禁用输入法支持。

    • Uses of Component in java.beans

      Methods in java.beans that return Component
      Modifier and Type 方法 描述
      Component PropertyEditor.getCustomEditor​()
      PropertyEditor可以选择提供编辑其属性值的完整自定义组件。
      Component PropertyEditorSupport.getCustomEditor​()
      PropertyEditor可以选择提供编辑其属性值的完整自定义组件。

    • Uses of Component in java.beans.beancontext

      Methods in java.beans.beancontext that return Component
      Modifier and Type 方法 描述
      Component BeanContextChildComponentProxy.getComponent​()
      获取 java.awt.Component相关联的 BeanContextChild 。

    • Uses of Component in javafx.embed.swing

      Subclasses of Component in javafx.embed.swing
      Modifier and Type Class 描述
      class  JFXPanel
      JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。

    • Uses of Component in javax.swing

      Classes in javax.swing with type parameters of type Component
      Modifier and Type Class 描述
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并且可以接收在其边框内生成的所有 AWTEvent的通知。
      Subclasses of Component in javax.swing
      Modifier and Type Class 描述
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      static class  Box.Filler
      参与布局但没有视图的轻量级组件的实现。
      class  CellRendererPane
      此类插入到单元格渲染器和使用它们的组件之间。
      class  DefaultListCellRenderer
      渲染列表中的项目。
      static class  DefaultListCellRenderer.UIResource
      实现UIResource的DefaultListCellRenderer的子类。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      class  JButton
      实现“推”按钮。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      class  JColorChooser
      JColorChooser提供了一个设计为允许用户操纵和选择颜色的控件窗格。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      class  JComponent
      除顶级容器之外的所有Swing组件的基类。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      class  JDialog
      创建对话窗口的主要类。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      class  JFileChooser
      JFileChooser提供了一种简单的机制，供用户选择文件。
      class  JFormattedTextField
      JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑了文本，就检索了一个特定的对象。
      class  JFrame
      扩展版本的 java.awt.Frame增加了对JFC / Swing组件架构的支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      static class  JInternalFrame.JDesktopIcon
      该组件代表 JInternalFrame的图标化版本。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并且可以接收在其边框内生成的所有 AWTEvent的通知。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem s的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。
      class  JMenuBar
      一个菜单栏的实现。
      class  JMenuItem
      菜单中项目的实现。
      class  JOptionPane
      JOptionPane可以方便地弹出一个标准对话框，提示用户获取值或通知他们某些东西。
      class  JPanel
      JPanel是一个通用的轻量级容器。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示已打字，但不显示原始字符。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      static class  JPopupMenu.Separator
      弹出菜单特定的分隔符。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      class  JRootPane
      通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
      class  JScrollBar
      一个滚动条的实现。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
      class  JSeparator
      JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      static class  JSpinner.DateEditor
      JSpinner的编辑器，型号为 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      更专业的编辑器的简单基类，可以使用 JFormattedTextField显示模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      class  JSplitPane
      JSplitPane用于划分两个（也只有两个） Component s。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      class  JTextArea
      A JTextArea是显示纯文本的多行区域。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      static class  JToolBar.Separator
      工具栏特定的分隔符。
      class  JToolTip
      用于显示组件的“提示”。
      class  JTree
      作为轮廓显示一组分层数据的控件。
      class  JViewport
      您可以通过它查看基础信息的“视口”或“舷窗”。
      class  JWindow
      A JWindow是可以在用户桌面上的任何位置显示的容器。
      Fields in javax.swing declared as Component
      Modifier and Type Field 描述
      protected static Component ImageIcon.component
      已过时。
      自1.8
      protected Component JTable.editorComp
      如果编辑， Component正在处理编辑。
      protected Component JRootPane.glassPane
      玻璃窗格覆盖菜单栏和内容窗格，因此可以拦截鼠标移动等。
      protected Component JLabel.labelFor
      该标签用于 如果标签不是组件的标签，则为null
      protected Component JSplitPane.leftComponent
      左或顶部组件。
      protected Component JScrollPane.lowerLeft
      要显示在左下角的组件。
      protected Component ScrollPaneLayout.lowerLeft
      要显示在左下角的组件。
      protected Component JScrollPane.lowerRight
      要显示在右下角的组件。
      protected Component ScrollPaneLayout.lowerRight
      要显示在右下角的组件。
      protected Component JSplitPane.rightComponent
      右侧或底部组件。
      protected Component JScrollPane.upperLeft
      组件显示在左上角。
      protected Component ScrollPaneLayout.upperLeft
      组件显示在左上角。
      protected Component JScrollPane.upperRight
      组件显示在右上角。
      protected Component ScrollPaneLayout.upperRight
      组件显示在右上角。
      Methods in javax.swing that return Component
      Modifier and Type | 方法 | 描述
      Component JMenu.add​(Component c)
      将一个组件附加到此菜单的末尾。
      Component JMenu.add​(Component c, int index)
      在给定的位置将指定的组件添加到此容器。
      Component JTabbedPane.add​(Component component)
      添加一个 component与选项卡标题默认为组件的名称，这是调用 component.getName的结果。
      Component JTabbedPane.add​(Component component, int index)
      在指定的选项卡索引处添加一个 component ，其中的选项卡标题默认为组件的名称。
      Component JTabbedPane.add​(String title, Component component)
      添加一个 component与指定的选项卡标题。
      protected Component ScrollPaneLayout.addSingletonComponent​(Component oldC, Component newC)
      删除现有组件。
      Component MenuSelectionManager.componentForPoint​(Component source, Point sourcePoint)
      返回当前所选路径中包含sourcePoint的组件。
      protected Component JRootPane.createGlassPane​()
      由构造函数调用方法创建默认 glassPane 。
      static Component Box.createGlue​()
      创建一个不可见的“胶水”组件，可在Box中使用，其可见组件具有最大宽度（对于水平框）或高度（对于垂直框）。
      static Component Box.createHorizontalGlue​()
      创建水平胶水组件。
      static Component Box.createHorizontalStrut​(int width)
      创建一个看不见的，固定宽度的组件。
      static Component Box.createRigidArea​(Dimension d)
      创建一个总是指定大小的不可见组件。
      static Component Box.createVerticalGlue​()
      创建垂直胶水组件。
      static Component Box.createVerticalStrut​(int height)
      创建一个看不见的，固定高度的组件。
      static Component SwingUtilities.findFocusOwner​(Component c)
      已过时。
      截至1.4，由KeyboardFocusManager.getFocusOwner()替代。
      Component JSplitPane.getBottomComponent​()
      返回下面的组件或分隔符的右侧。
      Component DefaultCellEditor.getComponent​()
      返回对编辑器组件的引用。
      Component JMenu.getComponent​()
      返回 java.awt.Component用于绘制这个 MenuElement 。
      Component JMenuBar.getComponent​()
      实现为 MenuElement 。
      Component JMenuItem.getComponent​()
      返回用于绘制此对象的 java.awt.Component 。
      Component JPopupMenu.getComponent​()
      返回此 JPopupMenu组件。
      Component MenuElement.getComponent​()
      此方法应返回用于绘制接收元素的 java.awt.Component 。
      Component Renderer.getComponent​()
      返回用于渲染值的组件。
      Component TransferHandler.TransferSupport.getComponent​()
      返回此传输的目标组件。
      Component DefaultFocusManager.getComponentAfter​(Container aContainer, Component aComponent)
      返回之后的组件。
      Component LayoutFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component SortingFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component JTabbedPane.getComponentAt​(int index)
      返回组件 index 。
      Component JMenuBar.getComponentAtIndex​(int i)
      已过时。
      替换为getComponent(int i)
      Component JPopupMenu.getComponentAtIndex​(int i)
      已过时。
      代之以Container.getComponent(int)
      Component JToolBar.getComponentAtIndex​(int i)
      返回指定索引处的组件。
      Component DefaultFocusManager.getComponentBefore​(Container aContainer, Component aComponent)
      返回之前的组件。
      Component LayoutFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      Component SortingFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      Component[] JLayeredPane.getComponentsInLayer​(int layer)
      返回指定图层中的组件数组。
      Component JScrollPane.getCorner​(String key)
      返回指定角落的组件。
      Component ScrollPaneLayout.getCorner​(String key)
      返回指定角落处的 Component 。
      protected Component JTable.AccessibleJTable.AccessibleJTableCell.getCurrentComponent​()
      获取表单元格渲染器组件。
      static Component SwingUtilities.getDeepestComponentAt​(Component parent, int x, int y)
      返回的最深可见后代组件 parent包含位置 x ， y 。
      Component SortingFocusTraversalPolicy.getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      Component ComboBoxEditor.getEditorComponent​()
      返回应该添加到该编辑器的树层次结构中的组件
      Component JTable.getEditorComponent​()
      返回处理编辑会话的组件。
      Component DefaultFocusManager.getFirstComponent​(Container aContainer)
      返回第一个组件。
      Component LayoutFocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      Component SortingFocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      Component JInternalFrame.getFocusOwner​()
      如果此 JInternalFrame处于活动状态，则返回具有焦点的小孩。
      Component JApplet.getGlassPane​()
      已过时。
      返回此applet的glassPane对象。
      Component JDialog.getGlassPane​()
      返回此对话框的 glassPane对象。
      Component JFrame.getGlassPane​()
      返回此帧的 glassPane对象。
      Component JInternalFrame.getGlassPane​()
      返回此内部框架的玻璃窗格。
      Component JRootPane.getGlassPane​()
      返回此 JRootPane的当前玻璃窗格。
      Component JWindow.getGlassPane​()
      返回此窗口的 glassPane Component 。
      Component RootPaneContainer.getGlassPane​()
      返回glassPane。
      Component InternalFrameFocusTraversalPolicy.getInitialComponent​(JInternalFrame frame)
      返回当第一次选择JInternalFrame时应该接收焦点的组件。
      Component JPopupMenu.getInvoker​()
      返回该弹出菜单的“调用者”组件。
      Component JLabel.getLabelFor​()
      获取此标签的组件。
      Component DefaultFocusManager.getLastComponent​(Container aContainer)
      返回最后一个组件。
      Component LayoutFocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      Component SortingFocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      Component JSplitPane.getLeftComponent​()
      将分量返回到左侧（或上方）。
      Component | DefaultListCellRenderer.getListCellRendererComponent​(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Component ListCellRenderer.getListCellRendererComponent​(JList<? extends E> list, E value, int index, boolean isSelected, boolean cellHasFocus)
      返回已配置为显示指定值的组件。
      Component JMenu.getMenuComponent​(int n)
      返回位置 n的组件。
      Component[] JMenu.getMenuComponents​()
      返回菜单的子组件的数组 Component 。
      Component JInternalFrame.getMostRecentFocusOwner​()
      返回此 JInternalFrame的子组件，当选择此 JInternalFrame时，该组件将接收焦点。
      Component JComponent.getNextFocusableComponent​()
      已过时。
      截至1.4，由FocusTraversalPolicy取代。
      Component JSplitPane.getRightComponent​()
      将分量返回到右侧（或更低）。
      static Component SwingUtilities.getRoot​(Component c)
      返回当前组件树的根组件。
      Component JTabbedPane.getSelectedComponent​()
      返回此选项卡窗格当前选定的组件。
      Component JTabbedPane.getTabComponentAt​(int index)
      返回标签组件 index 。
      Component DefaultCellEditor.getTableCellEditorComponent​(JTable table, Object value, boolean isSelected, int row, int column)
      实现 TableCellEditor界面。
      Component JSplitPane.getTopComponent​()
      返回上面的组件，或者分隔符的左边。
      Component DefaultCellEditor.getTreeCellEditorComponent​(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      实现 TreeCellEditor接口。
      static Component SwingUtilities.getUnwrappedView​(JViewport viewport)
      返回不是 JLayer的实例的第一个 JViewport的后代。
      Component JViewport.getView​()
      返回 JViewport的一个孩子或 null 。
      Component JTable.prepareEditor​(TableCellEditor editor, int row, int column)
      准备通过在查询的单元格的值和选择状态数据模型中的编辑器 row ， column 。
      Component JTable.prepareRenderer​(TableCellRenderer renderer, int row, int column)
      通过在查询的单元格的值和选择状态的数据模型来准备渲染器 row ， column 。
      Methods in javax.swing that return types with arguments of type Component
      Modifier and Type 方法 描述
      protected Comparator<? super Component> SortingFocusTraversalPolicy.getComparator​()
      返回将用于在焦点遍历循环中对“组件”进行排序的“比较器”。
      protected Hashtable<Component,Integer> JLayeredPane.getComponentToLayer​()
      返回将组件映射到图层的散列表。
      Methods in javax.swing with parameters of type Component
      Modifier and Type | 方法 | 描述
      protected boolean LayoutFocusTraversalPolicy.accept​(Component aComponent)
      确定指定的 Component是否是新焦点所有者的可接受的选择。
      protected boolean SortingFocusTraversalPolicy.accept​(Component aComponent)
      确定组件是否是新焦点所有者的可接受选择。
      Component JMenu.add​(Component c)
      将一个组件附加到此菜单的末尾。
      Component JMenu.add​(Component c, int index)
      在给定的位置将指定的组件添加到此容器。
      Component JTabbedPane.add​(Component component)
      添加一个 component与选项卡标题默认为组件的名称，这是调用 component.getName的结果。
      Component JTabbedPane.add​(Component component, int index)
      在指定的选项卡索引中添加一个 component ，其中的选项卡标题默认为组件的名称。
      void JTabbedPane.add​(Component component, Object constraints)
      在标签窗格中添加一个 component 。
      void JTabbedPane.add​(Component component, Object constraints, int index)
      在指定的选项卡索引中添加一个 component 。
      Component JTabbedPane.add​(String title, Component component)
      添加一个 component与指定的选项卡标题。
      GroupLayout.Group GroupLayout.Group.addComponent​(Component component)
      添加一个 Component到这个 Group 。
      GroupLayout.Group GroupLayout.Group.addComponent​(Component component, int min, int pref, int max)
      添加一个 Component到这个 Group与指定的大小。
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent​(Component component)
      添加一个 Component这个 Group 。
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent​(Component component, int min, int pref, int max)
      添加一个 Component到这个 Group与指定的大小。
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent​(Component component, GroupLayout.Alignment alignment)
      添加一个 Component到这个 ParallelGroup与指定的对齐。
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent​(Component component, GroupLayout.Alignment alignment, int min, int pref, int max)
      添加一个 Component到这个 ParallelGroup与指定的对齐和大小。
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent​(boolean useAsBaseline, Component component)
      添加一个 Component这个 Group 。
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent​(boolean useAsBaseline, Component component, int min, int pref, int max)
      添加一个 Component到这个 Group与指定的大小。
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent​(Component component)
      添加一个 Component这个 Group 。
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent​(Component component, int min, int pref, int max)
      添加一个 Component到这个 Group与指定的大小。
      protected void AbstractButton.addImpl​(Component comp, Object constraints, int index)
      将指定的组件添加到指定索引的此容器中，有关此方法的完整说明，请参阅 Container.addImpl(Component, Object, int) 。
      protected void CellRendererPane.addImpl​(Component x, Object constraints, int index)
      如果指定的组件已经是一个小孩，那么我们不用担心任何事情 - 堆栈顺序对于单元格渲染器组件并不重要（CellRendererPane不会绘制）。
      protected void JApplet.addImpl​(Component comp, Object constraints, int index)
      已过时。
      添加指定的小孩 Component 。
      protected void JDesktopPane.addImpl​(Component comp, Object constraints, int index)
      在指定的索引处将指定的组件添加到此容器。
      protected void JDialog.addImpl​(Component comp, Object constraints, int index)
      添加指定的小孩 Component 。
      protected void JFrame.addImpl​(Component comp, Object constraints, int index)
      添加指定的小孩 Component 。
      protected void JInternalFrame.addImpl​(Component comp, Object constraints, int index)
      添加指定的小孩 Component 。
      protected void JLayer.addImpl​(Component comp, Object constraints, int index)
      JLayer不支持此方法，并始终抛出 UnsupportedOperationException
      protected void | JLayeredPane.addImpl​(Component comp, Object constraints, int index)
      protected void JRootPane.addImpl​(Component comp, Object constraints, int index)
      覆盖以执行玻璃部件的位置作为零子。
      protected void JSplitPane.addImpl​(Component comp, Object constraints, int index)
      将指定的组件添加到此拆分窗格。
      protected void JToolBar.addImpl​(Component comp, Object constraints, int index)
      如果添加了一个 JButton ，它最初设置为禁用。
      protected void JViewport.addImpl​(Component child, Object constraints, int index)
      设置 JViewport的一个轻量级的小孩，可以是 null 。
      protected void JWindow.addImpl​(Component comp, Object constraints, int index)
      添加指定的小孩 Component 。
      void BoxLayout.addLayoutComponent​(Component comp, Object constraints)
      本课不使用
      void BoxLayout.addLayoutComponent​(String name, Component comp)
      本课不使用
      void GroupLayout.addLayoutComponent​(Component component, Object constraints)
      通知已将 Component添加到父容器。
      void GroupLayout.addLayoutComponent​(String name, Component component)
      通知已将 Component添加到父容器。
      void | JRootPane.RootLayout.addLayoutComponent​(Component comp, Object constraints)
      void | JRootPane.RootLayout.addLayoutComponent​(String name, Component comp)
      void JSpinner.DefaultEditor.addLayoutComponent​(String name, Component child)
      这个 LayoutManager方法什么都不做。
      void OverlayLayout.addLayoutComponent​(Component comp, Object constraints)
      使用指定的约束对象将指定的组件添加到布局。
      void OverlayLayout.addLayoutComponent​(String name, Component comp)
      将指定的组件添加到布局。
      void ScrollPaneLayout.addLayoutComponent​(String s, Component c)
      将指定的组件添加到布局。
      void SpringLayout.addLayoutComponent​(Component component, Object constraints)
      如果 constraints是 constraints的实例， SpringLayout.Constraints约束与指定的组件关联。
      void SpringLayout.addLayoutComponent​(String name, Component c)
      没有效果，因为此布局管理器不使用每个组件字符串。
      void ViewportLayout.addLayoutComponent​(String name, Component c)
      将指定的组件添加到布局。
      protected Component ScrollPaneLayout.addSingletonComponent​(Component oldC, Component newC)
      删除现有组件。
      void JTabbedPane.addTab​(String title, Component component)
      添加由 component代表的 title ，没有图标。
      void JTabbedPane.addTab​(String title, Icon icon, Component component)
      添加一个由 title和/或 component表示的 icon ，其中的一个可以是 null 。
      void JTabbedPane.addTab​(String title, Icon icon, Component component, String tip)
      增加了一个 component和 tip由a表示 title和/或 icon ，其中任一个可以是 null 。
      boolean DefaultFocusManager.compareTabOrder​(Component a, Component b)
      通过焦点遍历循环顺序对组件进行比较。
      Component MenuSelectionManager.componentForPoint​(Component source, Point sourcePoint)
      返回当前所选路径中包含sourcePoint的组件。
      static MouseEvent SwingUtilities.convertMouseEvent​(Component source, MouseEvent sourceEvent, Component destination)
      返回类似于 sourceEvent的MouseEvent，除了其x和y成员已转换为 destination的坐标系。
      static Point SwingUtilities.convertPoint​(Component source, int x, int y, Component destination)
      将 source坐标系中的点 (x,y)转换为 destination坐标系。
      static Point SwingUtilities.convertPoint​(Component source, Point aPoint, Component destination)
      转换为 aPoint在 source坐标系 destination坐标系。
      static void SwingUtilities.convertPointFromScreen​(Point p, Component c)
      将一个点从屏幕坐标转换为组件的坐标系
      static void SwingUtilities.convertPointToScreen​(Point p, Component c)
      将点从组件的坐标系转换为屏幕坐标。
      static Rectangle SwingUtilities.convertRectangle​(Component source, Rectangle aRectangle, Component destination)
      将 source坐标系中的矩形 aRectangle转换为 destination坐标系。
      static JDialog JColorChooser.createDialog​(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
      创建并返回一个包含指定的 ColorChooser窗格的新对话框以及“确定”，“取消”和“重置”按钮。
      protected JDialog JFileChooser.createDialog​(Component parent)
      创建并返回一个新的 JDialog包装 this居中于 parent在 parent的帧。
      JDialog JOptionPane.createDialog​(Component parentComponent, String title)
      创建并返回一个新的 JDialog包装 this居中于 parentComponent在 parentComponent的帧。
      JInternalFrame JOptionPane.createInternalFrame​(Component parentComponent, String title)
      创建并返回一个 JInternalFrame的实例。
      static RepaintManager RepaintManager.currentManager​(Component c)
      返回给定组件的调用线程的RepaintManager。
      static Component SwingUtilities.findFocusOwner​(Component c)
      已过时。
      截至1.4，由KeyboardFocusManager.getFocusOwner()取代。
      static Accessible SwingUtilities.getAccessibleAt​(Component c, Point p)
      返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。
      static Accessible SwingUtilities.getAccessibleChild​(Component c, int i)
      返回对象的第n个可访问子对象。
      static int SwingUtilities.getAccessibleChildrenCount​(Component c)
      返回对象中可访问的子项数。
      static int SwingUtilities.getAccessibleIndexInParent​(Component c)
      在其可访问的父项中获取此对象的索引。
      static AccessibleStateSet SwingUtilities.getAccessibleStateSet​(Component c)
      获取此对象的状态。
      static Container SwingUtilities.getAncestorNamed​(String name, Component comp)
      在组件层次结构中搜索 comp以上的方便方法，并返回其找到的第一个对象 name 。
      static Container SwingUtilities.getAncestorOfClass​(Class<?> c, Component comp)
      以上搜索的便捷方法 comp组件层次结构中，并返回类的第一个目的 c它找到。
      Component DefaultFocusManager.getComponentAfter​(Container aContainer, Component aComponent)
      返回之后的组件。
      Component LayoutFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component SortingFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component DefaultFocusManager.getComponentBefore​(Container aContainer, Component aComponent)
      返回之前的组件。
      Component LayoutFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      Component SortingFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      int JMenuBar.getComponentIndex​(Component c)
      返回指定组件的索引。
      int JPopupMenu.getComponentIndex​(Component c)
      返回指定组件的索引。
      int JToolBar.getComponentIndex​(Component c)
      返回指定组件的索引。
      Spring SpringLayout.getConstraint​(String edgeName, Component c)
      返回控制组件的指定边缘与其父级的顶部或左侧边缘之间的距离的弹簧。
      SpringLayout.Constraints SpringLayout.getConstraints​(Component c)
      返回指定组件的约束。
      static Component SwingUtilities.getDeepestComponentAt​(Component parent, int x, int y)
      返回的最深可见后代组件 parent包含位置 x ， y 。
      static JDesktopPane JOptionPane.getDesktopPaneForComponent​(Component parentComponent)
      返回指定组件的桌面窗格。
      static Frame JOptionPane.getFrameForComponent​(Component parentComponent)
      返回指定的组件的 Frame 。
      int JLayeredPane.getIndexOf​(Component c)
      返回指定Component的索引。
      int JLayeredPane.getLayer​(Component c)
      返回指定Component的layer属性。
      static JLayeredPane JLayeredPane.getLayeredPaneAbove​(Component c)
      方便方法返回包含指定组件的第一个JLayeredPane。
      static Rectangle SwingUtilities.getLocalBounds​(Component aComponent)
      返回组件 aComponent的矩形（0,0，bounds.width，bounds.height）
      Image RepaintManager.getOffscreenBuffer​(Component c, int proposedWidth, int proposedHeight)
      返回应使用组件 c作为双缓冲区的屏幕外缓冲区。
      Popup PopupFactory.getPopup​(Component owner, Component contents, int x, int y)
      创建 Popup为组件 owner包含Component contents 。
      protected Popup PopupFactory.getPopup​(Component owner, Component contents, int x, int y, boolean isHeavyWeightPopup)
      创建 Popup为组件 owner包含Component contents 。
      int JLayeredPane.getPosition​(Component c)
      获取组件在其层内的相对位置。
      static Component SwingUtilities.getRoot​(Component c)
      返回当前组件树的根组件。
      static JRootPane SwingUtilities.getRootPane​(Component c)
      如果c是JRootPane后代，则返回其JRootPane祖先。
      static Container SwingUtilities.getUnwrappedParent​(Component component)
      返回component的第一个祖先，而不是JLayer的一个实例。
      Image RepaintManager.getVolatileOffscreenBuffer​(Component c, int proposedWidth, int proposedHeight)
      返回一个挥发性的屏幕外缓冲区，应该用作具有指定组件 c的双缓冲区。
      static Window SwingUtilities.getWindowAncestor​(Component c)
      返回第 Window祖先 c ，或 null如果 c未包含在里面 Window 。
      static Spring Spring.height​(Component c)
      返回一个弹簧，其 最小值 ， 首选 值 ， 最大值和 值属性由所提供组件的 minimumSize ， preferredSize ， maximumSize和 size属性的高度定义。
      int JTabbedPane.indexOfComponent​(Component component)
      返回指定组件的选项卡的索引。
      int JTabbedPane.indexOfTabComponent​(Component tabComponent)
      返回指定选项卡组件的选项卡的索引。
      void JPopupMenu.insert​(Component component, int index)
      将指定的组件插入到给定位置的菜单中。
      void JTextPane.insertComponent​(Component c)
      将组件插入到文档中作为当前所选内容的替代。
      void JTabbedPane.insertTab​(String title, Icon icon, Component component, String tip, int index)
      在给定的索引处插入给定组件的新选项卡，由给定的标题和/或图标表示，其中任一个可能为 null 。
      boolean MenuSelectionManager.isComponentPartOfCurrentMenu​(Component c)
      如果 c是当前使用的菜单的一部分，则返回true
      static boolean SwingUtilities.isDescendingFrom​(Component a, Component b)
      如果组件 a从组件 b true则返回 b
      static boolean JComponent.isLightweightComponent​(Component c)
      如果此组件是轻量级的，则返回true，也就是说，如果该组件没有本机窗口系统对等体，则返回true。
      boolean JMenu.isMenuComponent​(Component c)
      如果指定的组件存在于子菜单层次结构中，则返回true。
      void GroupLayout.linkSize​(int axis, Component... components)
      强制指定的组件沿指定的轴具有相同的大小，而不管其首选，最小或最大尺寸。
      void GroupLayout.linkSize​(Component... components)
      强制指定的组件具有相同的大小，无论其首选，最小或最大大小如何。
      void JLayeredPane.moveToBack​(Component c)
      将组件移动到当前层中的组件底部（位置-1）。
      void JLayeredPane.moveToFront​(Component c)
      将组件移动到当前层（位置0）中组件的顶部。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h)
      调用this.paintComponent（g，c，p，x，y，w，h，false）。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
      在图形对象上绘制单元格渲染器组件c。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      调用this.paintComponent（）与矩形x，y，width，height字段。
      static void SwingUtilities.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h)
      绘制一个组件到指定的 Graphics 。
      static void SwingUtilities.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      将组件绘制到指定的 Graphics 。
      void Icon.paintIcon​(Component c, Graphics g, int x, int y)
      在指定位置绘制图标。
      void ImageIcon.paintIcon​(Component c, Graphics g, int x, int y)
      画图标。
      void LookAndFeel.provideErrorFeedback​(Component component)
      当用户尝试无效操作时调用，例如粘贴到具有焦点的不可编辑的 JTextField中。
      void SpringLayout.putConstraint​(String e1, Component c1, int pad, String e2, Component c2)
      链接边缘 e1组分 c1到边缘 e2组分 c2 ，边与边之间的距离固定。
      void SpringLayout.putConstraint​(String e1, Component c1, Spring s, String e2, Component c2)
      链接边缘 e1组分 c1到边缘 e2组分 c2 。
      void JApplet.remove​(Component comp)
      已过时。
      从容器中删除指定的组件。
      void JDesktopPane.remove​(Component comp)
      从此容器中删除指定的组件。
      void JDialog.remove​(Component comp)
      从容器中删除指定的组件。
      void JFrame.remove​(Component comp)
      从容器中删除指定的组件。
      void JInternalFrame.remove​(Component comp)
      从容器中删除指定的组件。
      void JLayer.remove​(Component comp)
      从此容器中删除指定的组件。
      void JMenu.remove​(Component c)
      从此菜单中删除组件 c 。
      void JSplitPane.remove​(Component component)
      从窗格中删除子组件 component 。
      void JTabbedPane.remove​(Component component)
      删除指定 Component从 JTabbedPane 。
      void JViewport.remove​(Component child)
      删除 Viewport的一个轻量级的孩子。
      void JWindow.remove​(Component comp)
      从容器中删除指定的组件。
      void BoxLayout.removeLayoutComponent​(Component comp)
      本课不使用
      void GroupLayout.removeLayoutComponent​(Component component)
      通知已从父容器中删除 Component 。
      void | JRootPane.RootLayout.removeLayoutComponent​(Component comp)
      void JSpinner.DefaultEditor.removeLayoutComponent​(Component child)
      这个 LayoutManager方法什么都不做。
      void OverlayLayout.removeLayoutComponent​(Component comp)
      从布局中删除指定的组件。
      void ScrollPaneLayout.removeLayoutComponent​(Component c)
      从布局中删除指定的组件。
      void SpringLayout.removeLayoutComponent​(Component c)
      删除与指定组件关联的约束。
      void ViewportLayout.removeLayoutComponent​(Component c)
      从布局中删除指定的组件。
      void GroupLayout.replace​(Component existingComponent, Component newComponent)
      用新的组件代替现有组件。
      void JSplitPane.setBottomComponent​(Component comp)
      设置下面的分量，或分配器的右侧。
      void JScrollPane.setColumnHeaderView​(Component view)
      如果需要，创建列标题视口，设置其视图，然后将列标题视口添加到滚动页面。
      void JTabbedPane.setComponentAt​(int index, Component component)
      将组件设置为 index至 component 。
      void JDesktopPane.setComponentZOrder​(Component comp, int index)
      将指定的组件移动到容器中指定的z顺序索引。
      void JScrollPane.setCorner​(String key, Component corner)
      添加一个孩子，出现在一个滚动窗格的角落，如果有空间。
      void JApplet.setGlassPane​(Component glassPane)
      已过时。
      设置glassPane属性。
      void JDialog.setGlassPane​(Component glassPane)
      设置 glassPane属性。
      void JFrame.setGlassPane​(Component glassPane)
      设置 glassPane属性。
      void JInternalFrame.setGlassPane​(Component glass)
      设置这个 JInternalFrame的 glassPane属性。
      void JRootPane.setGlassPane​(Component glass)
      将指定的 Component设置为此根窗格的玻璃窗格。
      void JWindow.setGlassPane​(Component glassPane)
      设置 glassPane属性。
      void RootPaneContainer.setGlassPane​(Component glassPane)
      glassPane始终是rootPane的第一个孩子，rootPane布局管理器确保它始终与rootPane一样大。
      void GroupLayout.setHonorsVisibility​(Component component, Boolean honorsVisibility)
      设置组件的可见性是否考虑到尺寸和定位。
      void JPopupMenu.setInvoker​(Component invoker)
      设置此弹出菜单的调用者 - 要显示弹出菜单菜单的组件。
      void JLabel.setLabelFor​(Component c)
      设置标签的组件。
      void JLayeredPane.setLayer​(Component c, int layer)
      设置指定组件上的图层属性，使其成为该图层中最底层的组件。
      void JLayeredPane.setLayer​(Component c, int layer, int position)
      设置指定组件的层属性，并设置其在该层中的位置。
      void JSplitPane.setLeftComponent​(Component comp)
      将组件设置在左边（或更高）分隔线。
      void JComponent.setNextFocusableComponent​(Component aComponent)
      已过时。
      截至1.4，由FocusTraversalPolicy替代
      void JLayeredPane.setPosition​(Component c, int position)
      将组件移动到其当前层中的 position ，其中0是层内的最高位置，-1是最底层的位置。
      void JSplitPane.setRightComponent​(Component comp)
      将组件设置在右侧（或更低）分隔线。
      void JScrollPane.setRowHeaderView​(Component view)
      如果需要，创建行标题视口，设置其视图，然后将行标题视口添加到滚动条。
      void JMenuBar.setSelected​(Component sel)
      设置当前选择的组件，产生对选择模型的更改。
      void JPopupMenu.setSelected​(Component sel)
      设置当前选择的组件，这将导致选择模型的更改。
      void JTabbedPane.setSelectedComponent​(Component c)
      设置此选项卡窗格的选定组件。
      void JTabbedPane.setTabComponentAt​(int index, Component component)
      设置负责渲染指定选项卡的标题的组件。
      void JSplitPane.setTopComponent​(Component comp)
      设置上面的分量，或分隔线的左边。
      void JViewport.setView​(Component view)
      设置 JViewport的一个轻便孩子（ view ），可以是 null 。
      void JScrollPane.setViewportView​(Component view)
      如果需要，创建一个视口，然后设置它的视图。
      void JPopupMenu.show​(Component invoker, int x, int y)
      在组件调用者的坐标空间中的位置x，y处显示弹出式菜单。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message)
      启动对话框，选择是 ， 否和取消 ; 标题为“ 选择选项” 。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType)
      提出一个对话框，其中选择次数由 optionType参数决定。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType)
      调出其中的选项的数目由所确定的一个对话框 optionType参数，其中，所述 messageType参数确定要显示的图标。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
      启动具有指定图标的对话框，其中选择数由 optionType参数决定。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor, boolean colorTransparencySelectionEnabled)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      int JFileChooser.showDialog​(Component parent, String approveButtonText)
      使用自定义批准按钮弹出自定义文件选择器对话框。
      static String JOptionPane.showInputDialog​(Component parentComponent, Object message)
      显示一个问题消息对话框，要求从父母的用户输入 parentComponent 。
      static String JOptionPane.showInputDialog​(Component parentComponent, Object message, Object initialSelectionValue)
      显示一个问题消息对话框，请求从用户输入并父母为 parentComponent 。
      static String JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType)
      显示一个对话框，请求从父级为 parentComponent的用户输入，对话框具有标题 title和消息类型 messageType 。
      static Object JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      在阻止对话框中提示用户输入，可以指定初始选择，可能的选择和所有其他选项。
      static int JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message)
      启动一个内部对话面板，选择是 ， 否和取消 ; 标题为“ 选择选项” 。
      static int JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType)
      启动内部对话面板，其中选择次数由 optionType参数确定。
      static int JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType)
      调出其中的选项数由所确定的内部对话框面板 optionType参数，其中，所述 messageType参数确定要显示的图标。
      static int JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
      启动具有指定图标的内部对话面板，其中选择次数由 optionType参数确定。
      static String JOptionPane.showInternalInputDialog​(Component parentComponent, Object message)
      显示一个内部问题消息对话框，要求从父母的用户输入 parentComponent 。
      static String JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType)
      显示一个内部对话框，请求从 parentComponent的用户输入的对话框，标题为 title ，消息类型为 messageType 。
      static Object JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      在阻止内部对话框中提示输入用户，可以指定初始选择，可能的选择和所有其他选项。
      static void JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message)
      启动内部确认对话框面板。
      static void JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message, String title, int messageType)
      启动内部对话面板，使用 messageType参数确定的默认图标显示消息。
      static void JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon)
      启动一个显示消息的内部对话框面板，指定所有参数。
      static int JOptionPane.showInternalOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      启动具有指定图标的内部对话面板，其中初始选择由 initialValue参数确定，选择次数由 optionType参数确定。
      static void JOptionPane.showMessageDialog​(Component parentComponent, Object message)
      提供一个名为“消息”的信息消息对话框。
      static void JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType)
      使用由 messageType参数确定的默认图标显示消息的对话框。
      static void JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon)
      显示一个显示消息的对话框，指定所有参数。
      int JFileChooser.showOpenDialog​(Component parent)
      弹出一个“打开文件”文件选择器对话框。
      static int JOptionPane.showOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      启动一个带有指定图标的对话框，其中初始选择由 initialValue参数确定，选择次数由 optionType参数决定。
      int JFileChooser.showSaveDialog​(Component parent)
      弹出“保存文件”文件选择器对话框。
      static void SwingUtilities.updateComponentTreeUI​(Component c)
      一个简单的头脑的感觉变化：请问树中的每个节点是否是 updateUI() - 即用当前的外观来初始化其UI属性。
      static Spring Spring.width​(Component c)
      返回一个弹簧，其 最小值 ， 首选 值 ， 最大值和 值属性由所提供组件的 minimumSize ， preferredSize ， maximumSize和 size属性的宽度定义。
      static Window SwingUtilities.windowForComponent​(Component c)
      返回第 Window祖先 c ，或 null如果 c未包含在里面 Window 。
      Method parameters in javax.swing with type arguments of type Component
      Modifier and Type 方法 描述
      protected void SortingFocusTraversalPolicy.setComparator​(Comparator<? super Component> comparator)
      设置在焦点遍历周期中用于对组件进行排序的比较器。
      Constructors in javax.swing with parameters of type Component
      Constructor 描述
      Constraints​(Component c)
      创建 Constraints与合适的物体 x ， y ， width和 height弹簧用于组分， c 。
      JScrollPane​(Component view)
      创建一个 JScrollPane ，显示指定组件的内容，当组件的内容大于视图时，水平和垂直滚动条都会显示。
      JScrollPane​(Component view, int vsbPolicy, int hsbPolicy)
      创建一个 JScrollPane ，在视口中显示视图组件，其视图位置可以用一对滚动条来控制。
      JSplitPane​(int newOrientation, boolean newContinuousLayout, Component newLeftComponent, Component newRightComponent)
      使用指定的方向和重绘样式以及指定的组件创建一个新的 JSplitPane 。
      JSplitPane​(int newOrientation, Component newLeftComponent, Component newRightComponent)
      使用指定的方向和指定的组件创建一个新的 JSplitPane 。
      Popup​(Component owner, Component contents, int x, int y)
      创建 Popup为组件 owner包含Component contents 。
      ProgressMonitor​(Component parentComponent, Object message, String note, int min, int max)
      构造一个显示进度的图形对象，通常通过填充矩形栏来完成过程。
      ProgressMonitorInputStream​(Component parentComponent, Object message, InputStream in)
      构造一个对象来监视输入流的进度。
      TransferSupport​(Component component, Transferable transferable)
      为给定组件创建一个 TransferSupport isDrop() false和 Transferable 。
      Constructor parameters in javax.swing with type arguments of type Component
      Constructor 描述
      SortingFocusTraversalPolicy​(Comparator<? super Component> comparator)
      使用指定的比较器构造SortingFocusTraversalPolicy。

    • Uses of Component in javax.swing.border

      Methods in javax.swing.border with parameters of type Component
      Modifier and Type 方法 描述
      int AbstractBorder.getBaseline​(Component c, int width, int height)
      返回基线。
      int TitledBorder.getBaseline​(Component c, int width, int height)
      返回基线。
      Component.BaselineResizeBehavior AbstractBorder.getBaselineResizeBehavior​(Component c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior TitledBorder.getBaselineResizeBehavior​(Component c)
      返回一个枚举，指示边框的基线如何随着大小的变化而改变。
      Insets AbstractBorder.getBorderInsets​(Component c)
      此默认实现返回一个由AbstractBorder.getBorderInsets(Component,Insets)方法初始化的新的Insets对象。
      Insets AbstractBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets BevelBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets Border.getBorderInsets​(Component c)
      返回边框的插入。
      Insets CompoundBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets EmptyBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets EtchedBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets LineBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets MatteBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets SoftBevelBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets StrokeBorder.getBorderInsets​(Component c, Insets insets)
      使用此边框的当前插图重新初始化 insets参数。
      Insets TitledBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      protected Font TitledBorder.getFont​(Component c)
      返回标题边框的默认字体。
      Color EtchedBorder.getHighlightColor​(Component c)
      在指定的组件上渲染时返回蚀刻边框的突出显示颜色。
      Color BevelBorder.getHighlightInnerColor​(Component c)
      在指定的组件上渲染时返回斜角边框的内部高亮颜色。
      Color BevelBorder.getHighlightOuterColor​(Component c)
      在指定的组件上呈现时，返回斜角边框的外部高亮颜色。
      Rectangle AbstractBorder.getInteriorRectangle​(Component c, int x, int y, int width, int height)
      这种方便方法调用静态方法。
      static Rectangle AbstractBorder.getInteriorRectangle​(Component c, Border b, int x, int y, int width, int height)
      使用参数减去边框的插入返回一个矩形。
      Dimension TitledBorder.getMinimumSize​(Component c)
      返回边框所需的最小尺寸，以便完全显示边框和标题。
      Color EtchedBorder.getShadowColor​(Component c)
      在指定的组件上呈现时，返回蚀刻边框的阴影颜色。
      Color BevelBorder.getShadowInnerColor​(Component c)
      在指定的组件上呈现时，返回斜角边框的内阴影颜色。
      Color BevelBorder.getShadowOuterColor​(Component c)
      在指定的组件上呈现时，返回斜角边框的外阴影颜色。
      void AbstractBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      此默认实现不绘画。
      void BevelBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void Border.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void CompoundBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      通过用指定的位置和大小绘制外部边框来绘制复合边框，然后通过外部边框的插入在指定位置和大小偏移处绘制内边框。
      void EmptyBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      默认情况下不绘图。
      void EtchedBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void LineBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void MatteBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      涂抹无光泽的边框。
      void SoftBevelBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void StrokeBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void TitledBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      protected void BevelBorder.paintLoweredBevel​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定部件的下降斜面。
      protected void BevelBorder.paintRaisedBevel​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的凸起斜面。

    • Uses of Component in javax.swing.colorchooser

      Subclasses of Component in javax.swing.colorchooser
      Modifier and Type Class 描述
      class  AbstractColorChooserPanel
      这是颜色选择器的抽象超类。

    • Uses of Component in javax.swing.event

      Constructors in javax.swing.event with parameters of type Component
      Constructor 描述
      MenuDragMouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      构造一个MenuDragMouseEvent对象。
      MenuDragMouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      构造一个MenuDragMouseEvent对象。
      MenuKeyEvent​(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
      构造一个MenuKeyEvent对象。

    • Uses of Component in javax.swing.plaf

      Classes in javax.swing.plaf with type parameters of type Component
      Modifier and Type Class 描述
      class  LayerUI<V extends Component>
      所有JLayer的UI代表的基类。
      Methods in javax.swing.plaf with parameters of type Component
      Modifier and Type | 方法 | 描述
      Insets | BorderUIResource.getBorderInsets​(Component c)
      void | BorderUIResource.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | IconUIResource.paintIcon​(Component c, Graphics g, int x, int y)

    • Uses of Component in javax.swing.plaf.basic

      Subclasses of Component in javax.swing.plaf.basic
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
      class  BasicComboBoxRenderer
      ComboBox渲染器
      static class  BasicComboBoxRenderer.UIResource
      BasicComboBoxRenderer的子类实现UIResource。
      class  BasicComboPopup
      这是 ComboPopup接口的基本实现。
      class  BasicInternalFrameTitlePane
      管理基本标题栏的类
      class  BasicInternalFrameTitlePane.SystemMenuBar
      这个类应该被视为一个“受保护”的内部类。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。
      Fields in javax.swing.plaf.basic declared as Component
      Modifier and Type Field 描述
      protected Component[] BasicSplitPaneUI.BasicHorizontalLayoutManager.components
      组件。
      protected Component BasicTreeUI.MouseInputHandler.destination
      接收所有事件的目的地。
      protected Component BasicTreeUI.editingComponent
      编辑时，这将是正在进行实际编辑的组件。
      protected Component BasicComboBoxUI.editor
      @ {code ComboBoxEditor}用于编辑的组件。
      protected Component BasicSplitPaneDivider.hiddenDivider
      用于非连续布局模式的分隔线。
      protected Component BasicOptionPaneUI.initialFocusComponent
      在使用selectInitialValue消息时接收焦点的组件。
      protected Component BasicSplitPaneUI.nonContinuousLayoutDivider
      当使用非连续布局时，分隔线阴影的实例。
      protected Component BasicTreeUI.MouseInputHandler.source
      来源于事件来自。
      Component BasicMenuUI.ChangeHandler.wasFocused
      集中的组件。
      Methods in javax.swing.plaf.basic that return Component
      Modifier and Type | 方法 | 描述
      protected Component BasicSplitPaneUI.createDefaultNonContinuousLayoutDivider​()
      返回默认的非连续布局分隔符，这是一个 Canvas的实例，用灰色填充背景。
      protected Component BasicSpinnerUI.createNextButton​()
      创建一个增量按钮，即使用 spinner.getNextValue返回的对象替换微调 spinner.getNextValue值的 spinner.getNextValue 。
      protected Component BasicSpinnerUI.createPreviousButton​()
      创建一个减量按钮，即使用 spinner.getPreviousValue返回的对象替换微调 spinner.getPreviousValue值的 spinner.getPreviousValue 。
      Component | BasicComboBoxEditor.getEditorComponent​()
      protected Component BasicSliderUI.getHighestValueLabel​()
      返回与标签表中最低的滑块值对应的标签。
      Component | BasicComboBoxRenderer.getListCellRendererComponent​(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      protected Component BasicSliderUI.getLowestValueLabel​()
      返回与标签表中最高的滑块值对应的标签。
      Component BasicSplitPaneUI.getNonContinuousLayoutDivider​()
      当 JSplitPane配置为不连续布局时，返回要使用的分隔符。
      protected Component BasicTabbedPaneUI.getVisibleComponent​()
      返回可见组件。
      Methods in javax.swing.plaf.basic with parameters of type Component
      Modifier and Type | 方法 | 描述
      void | BasicComboBoxUI.ComboBoxLayoutManager.addLayoutComponent​(String name, Component comp)
      void | BasicInternalFrameTitlePane.TitlePaneLayout.addLayoutComponent​(String name, Component c)
      void BasicInternalFrameUI.InternalFrameLayout.addLayoutComponent​(String name, Component c)
      如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与 name指定的字符串相关联。
      void | BasicOptionPaneUI.ButtonAreaLayout.addLayoutComponent​(String string, Component comp)
      void | BasicScrollBarUI.addLayoutComponent​(String name, Component child)
      void | BasicSplitPaneDivider.DividerLayout.addLayoutComponent​(String string, Component c)
      void BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent​(Component comp, Object constraints)
      使用指定的约束对象将指定的组件添加到布局。
      void BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent​(String place, Component component)
      将组件添加到位置。
      void | BasicTabbedPaneUI.TabbedPaneLayout.addLayoutComponent​(String name, Component comp)
      boolean BasicToolBarUI.canDock​(Component c, Point p)
      如果 JToolBar可以在给定的位置停靠，则返回 true 。
      protected void BasicTreeUI.drawCentered​(Component c, Graphics graphics, Icon icon, int x, int y)
      绘制以（x，y）为中心的 icon 。
      Insets | BasicBorders.ButtonBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.FieldBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.MarginBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.MenuBarBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.RadioButtonBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.SplitPaneBorder.getBorderInsets​(Component c)
      Insets | BasicBorders.ToggleButtonBorder.getBorderInsets​(Component c, Insets insets)
      protected int BasicSplitPaneUI.BasicHorizontalLayoutManager.getPreferredSizeOfComponent​(Component c)
      返回传递的组件首选大小的宽度。
      protected Dimension BasicComboBoxUI.getSizeForComponent​(Component comp)
      如果用作单元格渲染器，则返回组件将具有的大小。
      protected int BasicSplitPaneUI.BasicHorizontalLayoutManager.getSizeOfComponent​(Component c)
      返回传入组件的宽度。
      protected void BasicSpinnerUI.installNextButtonListeners​(Component c)
      在下一个按钮 c上安装必要的听众，以更新 JSpinner以响应用户的手势。
      protected void BasicSpinnerUI.installPreviousButtonListeners​(Component c)
      在上一个按钮 c上安装必要的听众，以更新 JSpinner以响应用户的手势。
      void | BasicBorders.ButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.FieldBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.MenuBarBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.RadioButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.RolloverButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | BasicBorders.SplitPaneBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.ToggleButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      protected void BasicSliderUI.paintHorizontalLabel​(Graphics g, int value, Component label)
      为标签表中的每个标签调用。
      protected void BasicSliderUI.paintVerticalLabel​(Graphics g, int value, Component label)
      为标签表中的每个标签调用。
      void | BasicComboBoxUI.ComboBoxLayoutManager.removeLayoutComponent​(Component comp)
      void | BasicInternalFrameTitlePane.TitlePaneLayout.removeLayoutComponent​(Component c)
      void BasicInternalFrameUI.InternalFrameLayout.removeLayoutComponent​(Component c)
      从布局中删除指定的组件。
      void | BasicOptionPaneUI.ButtonAreaLayout.removeLayoutComponent​(Component c)
      void | BasicScrollBarUI.removeLayoutComponent​(Component child)
      void | BasicSplitPaneDivider.DividerLayout.removeLayoutComponent​(Component c)
      void BasicSplitPaneUI.BasicHorizontalLayoutManager.removeLayoutComponent​(Component component)
      从我们的知识中删除指定的组件。
      void | BasicTabbedPaneUI.TabbedPaneLayout.removeLayoutComponent​(Component comp)
      protected void BasicToolBarUI.setBorderToNonRollover​(Component c)
      将组件的边框设置为具有由 BasicToolBarUI.createNonRolloverBorder()方法创建的非滚动边框。
      protected void BasicToolBarUI.setBorderToNormal​(Component c)
      将组件的边框设置为具有正常边框。
      protected void BasicToolBarUI.setBorderToRollover​(Component c)
      将组件的边框设置为具有由 BasicToolBarUI.createRolloverBorder()方法创建的翻转边框。
      protected void BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize​(Component c, int size, int location, Insets insets, Dimension containerSize)
      将组件 c的宽度设置为 size ，将其x位置放置在 location ，y到 insets.top ，高度为 containerSize.height减少顶部和底部插入。
      protected void BasicSplitPaneUI.setNonContinuousLayoutDivider​(Component newDivider)
      将 JSplitPane配置为不连续布局时，设置使用的分隔符。
      protected void BasicSplitPaneUI.setNonContinuousLayoutDivider​(Component newDivider, boolean rememberSizes)
      设置要使用的分隔符。
      protected void BasicTabbedPaneUI.setVisibleComponent​(Component component)
      设置可见组件。
      Constructors in javax.swing.plaf.basic with parameters of type Component
      Constructor 描述
      MouseInputHandler​(Component source, Component destination, MouseEvent event)
      构造一个新的实例 MouseInputHandler 。

    • Uses of Component in javax.swing.plaf.metal

      Subclasses of Component in javax.swing.plaf.metal
      Modifier and Type Class 描述
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalComboBoxUI.MetalComboPopup
      已过时。
      从Java 2平台v1.4开始。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      class  MetalFileChooserUI.FilterComboBoxRenderer
      渲染不同类型的尺寸和样式。
      class  MetalInternalFrameTitlePane
      管理JLF标题栏的类
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。
      Methods in javax.swing.plaf.metal that return Component
      Modifier and Type | 方法 | 描述
      Component | MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent​(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Methods in javax.swing.plaf.metal with parameters of type Component
      Modifier and Type | 方法 | 描述
      protected void MetalCheckBoxIcon.drawCheck​(Component c, Graphics g, int x, int y)
      油漆 MetalCheckBoxIcon 。
      Insets | MetalBorders.ButtonBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.Flush3DBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.InternalFrameBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.MenuBarBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.MenuItemBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.OptionDialogBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.PaletteBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.PopupMenuBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.ScrollPaneBorder.getBorderInsets​(Component c, Insets insets)
      Insets | MetalBorders.TableHeaderBorder.getBorderInsets​(Component c, Insets insets)
      Insets | MetalBorders.ToolBarBorder.getBorderInsets​(Component c, Insets newInsets)
      void | MetalBorders.ButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.Flush3DBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.InternalFrameBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.MenuBarBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.MenuItemBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.OptionDialogBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.PaletteBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.PopupMenuBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.RolloverButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.ScrollPaneBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.TableHeaderBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.TextFieldBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.ToggleButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.ToolBarBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalCheckBoxIcon.paintIcon​(Component c, Graphics g, int x, int y)
      void MetalComboBoxIcon.paintIcon​(Component c, Graphics g, int x, int y)
      涂上水平条
      void | MetalIconFactory.FileIcon16.paintIcon​(Component c, Graphics g, int x, int y)
      void | MetalIconFactory.FolderIcon16.paintIcon​(Component c, Graphics g, int x, int y)
      void | MetalIconFactory.PaletteCloseIcon.paintIcon​(Component c, Graphics g, int x, int y)
      void | MetalIconFactory.TreeControlIcon.paintIcon​(Component c, Graphics g, int x, int y)
      void MetalIconFactory.TreeControlIcon.paintMe​(Component c, Graphics g, int x, int y)
      TreeControlIcon 。
      void MetalLookAndFeel.provideErrorFeedback​(Component component)
      当用户尝试无效操作时调用，例如粘贴到具有焦点的不可编辑的 JTextField中。
      protected void | MetalToolBarUI.setBorderToNonRollover​(Component c)

    • Uses of Component in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Component
      Modifier and Type 方法 描述
      protected Component SynthSplitPaneUI.createDefaultNonContinuousLayoutDivider​()
      返回默认的非连续布局分隔符，这是一个 Canvas的实例，用灰色填充背景。
      protected Component SynthSpinnerUI.createNextButton​()
      创建一个增量按钮，即用 spinner.getNextValue返回的对象替换微调 spinner.getNextValue值的 spinner.getNextValue 。
      protected Component SynthSpinnerUI.createPreviousButton​()
      创建一个减量按钮，即使用 spinner.getPreviousValue返回的对象替换微调 spinner.getPreviousValue值的 spinner.getPreviousValue 。
      Methods in javax.swing.plaf.synth with parameters of type Component
      Modifier and Type | 方法 | 描述
      protected void SynthTreeUI.drawCentered​(Component c, Graphics graphics, Icon icon, int x, int y)
      绘制以（x，y）为中心的 icon 。
      default void | SynthIcon.paintIcon​(Component c, Graphics g, int x, int y)
      protected void SynthToolBarUI.setBorderToNonRollover​(Component c)
      这个实现什么都不做，因为 JToolBar类的 rollover属性在Synth Look and Feel中没有使用。
      protected void SynthToolBarUI.setBorderToNormal​(Component c)
      这个实现什么都不做，因为 JToolBar类的 rollover属性在Synth Look和Feel中没有使用。
      protected void SynthToolBarUI.setBorderToRollover​(Component c)
      这个实现什么都不做，因为 JToolBar类的 rollover属性没有用在Synth Look and Feel中。
      static void SynthLookAndFeel.updateStyles​(Component c)
      更新与 c及其所有子项相关联的样式。

    • Uses of Component in javax.swing.table

      Subclasses of Component in javax.swing.table
      Modifier and Type Class 描述
      class  DefaultTableCellRenderer
      在 JTable渲染（显示）单个单元格的标准类。
      static class  DefaultTableCellRenderer.UIResource
      DefaultTableCellRenderer的子类实现 UIResource 。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。
      Methods in javax.swing.table that return Component
      Modifier and Type 方法 描述
      Component TableCellEditor.getTableCellEditorComponent​(JTable table, Object value, boolean isSelected, int row, int column)
      为编辑器设置初始 value 。
      Component DefaultTableCellRenderer.getTableCellRendererComponent​(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
      返回默认的表格单元格渲染器。
      Component TableCellRenderer.getTableCellRendererComponent​(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
      返回用于绘制单元格的组件。

    • Uses of Component in javax.swing.text

      Subclasses of Component in javax.swing.text
      Modifier and Type Class 描述
      class  JTextComponent
      JTextComponent是摆动文本组件的基础类。
      Methods in javax.swing.text that return Component
      Modifier and Type 方法 描述
      protected Component ComponentView.createComponent​()
      创建与此视图关联的组件。
      Component ComponentView.getComponent​()
      获取与视图关联的组件。
      static Component StyleConstants.getComponent​(AttributeSet a)
      从属性列表获取组件设置。
      Methods in javax.swing.text with parameters of type Component
      Modifier and Type 方法 描述
      protected void PlainView.damageLineRange​(int line0, int line1, Shape a, Component host)
      重复给定行范围。
      static void StyleConstants.setComponent​(MutableAttributeSet a, Component c)
      设置组件属性。

    • Uses of Component in javax.swing.text.html

      Methods in javax.swing.text.html that return Component
      Modifier and Type 方法 描述
      protected Component FormView.createComponent​()
      创建组件。
      protected Component ObjectView.createComponent​()
      创建组件。

    • Uses of Component in javax.swing.tree

      Subclasses of Component in javax.swing.tree
      Modifier and Type Class 描述
      class  DefaultTreeCellEditor.DefaultTextField
      当不提供编辑器时使用 TextField 。
      class  DefaultTreeCellEditor.EditorContainer
      集装箱负责放置 editingComponent 。
      class  DefaultTreeCellRenderer
      在树中显示一个条目。
      Fields in javax.swing.tree declared as Component
      Modifier and Type Field 描述
      protected Component DefaultTreeCellEditor.editingComponent
      组件用于编辑，从 editingContainer获得。
      Methods in javax.swing.tree that return Component
      Modifier and Type 方法 描述
      Component DefaultTreeCellEditor.getTreeCellEditorComponent​(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      配置编辑器。
      Component TreeCellEditor.getTreeCellEditorComponent​(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      设置编辑器的初始 值 。
      Component DefaultTreeCellRenderer.getTreeCellRendererComponent​(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus)
      根据传入的组件配置渲染器。
      Component TreeCellRenderer.getTreeCellRendererComponent​(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
      将当前树状单元格的值设置为 value 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Component.AccessibleAWTComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Component.AccessibleAWTComponent

  • Packages that use Component.AccessibleAWTComponent
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Component.AccessibleAWTComponent in java.applet

      Subclasses of Component.AccessibleAWTComponent in java.applet
      Modifier and Type Class 描述
      protected class  Applet.AccessibleApplet
      已过时。
      这个类实现 Applet类的可访问性支持。

    • Uses of Component.AccessibleAWTComponent in java.awt

      Subclasses of Component.AccessibleAWTComponent in java.awt
      Modifier and Type Class 描述
      protected class  Button.AccessibleAWTButton
      这个类实现 Button类的可访问性支持。
      protected class  Canvas.AccessibleAWTCanvas
      该类实现 Canvas类的可访问性支持。
      protected class  Checkbox.AccessibleAWTCheckbox
      该类实现 Checkbox类的可访问性支持。
      protected class  Choice.AccessibleAWTChoice
      该类实现 Choice类的可访问性支持。
      protected class  Container.AccessibleAWTContainer
      Container的内部类用于为辅助功能提供默认支持。
      protected class  Dialog.AccessibleAWTDialog
      这个类实现 Dialog类的可访问性支持。
      protected class  Frame.AccessibleAWTFrame
      这个类实现 Frame类的可访问性支持。
      protected class  Label.AccessibleAWTLabel
      这个类实现 Label类的可访问性支持。
      protected class  List.AccessibleAWTList
      这个类实现了 List类的可访问性支持。
      protected class  List.AccessibleAWTList.AccessibleAWTListChild
      此类实现对List子项的可访问性支持。
      protected class  Panel.AccessibleAWTPanel
      这个类实现 Panel类的辅助功能支持。
      protected class  Scrollbar.AccessibleAWTScrollBar
      这个类实现 Scrollbar类的可访问性支持。
      protected class  ScrollPane.AccessibleAWTScrollPane
      这个类实现 ScrollPane类的可访问性支持。
      protected class  TextArea.AccessibleAWTTextArea
      这个类实现 TextArea类的辅助功能支持。
      protected class  TextComponent.AccessibleAWTTextComponent
      这个类实现 TextComponent类的可访问性支持。
      protected class  TextField.AccessibleAWTTextField
      这个类实现 TextField类的可访问性支持。
      protected class  Window.AccessibleAWTWindow
      这个类实现 Window类的可访问性支持。

    • Uses of Component.AccessibleAWTComponent in javax.swing

      Subclasses of Component.AccessibleAWTComponent in javax.swing
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现 AbstractButton类的可访问性支持。
      protected class  Box.AccessibleBox
      这个类实现 Box类的可访问性支持。
      protected class  Box.Filler.AccessibleBoxFiller
      这个类实现 Box.Filler类的可访问性支持。
      protected class  CellRendererPane.AccessibleCellRendererPane
      该类为 CellRendererPane类实现可访问性支持。
      protected class  JApplet.AccessibleJApplet
      已过时。
      这个类实现 JApplet类的可访问性支持。
      protected class  JButton.AccessibleJButton
      该类实现 JButton类的可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      这个类实现 JCheckBox类的可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      这个类实现 JCheckBoxMenuItem类的可访问性支持。
      protected class  JColorChooser.AccessibleJColorChooser
      该类实现 JColorChooser类的可访问性支持。
      protected class  JComboBox.AccessibleJComboBox
      这个类实现 JComboBox类的可访问性支持。
      class  JComponent.AccessibleJComponent
      JComponent的内部类用于为辅助功能提供默认支持。
      protected class  JDesktopPane.AccessibleJDesktopPane
      这个类实现 JDesktopPane类的可访问性支持。
      protected class  JDialog.AccessibleJDialog
      该类实现 JDialog类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText 。
      protected class  JFileChooser.AccessibleJFileChooser
      这个类实现 JFileChooser类的可访问性支持。
      protected class  JFrame.AccessibleJFrame
      这个类实现 JFrame类的辅助功能支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      这个类实现 JInternalFrame类的可访问性支持。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      这个类实现 JInternalFrame.JDesktopIcon类的可访问性支持。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      protected class  JLayeredPane.AccessibleJLayeredPane
      这个类实现 JLayeredPane类的辅助功能支持。
      protected class  JList.AccessibleJList
      这个类实现 JList类的辅助功能支持。
      protected class  JMenu.AccessibleJMenu
      这个类实现 JMenu类的辅助功能支持。
      protected class  JMenuBar.AccessibleJMenuBar
      该类实现 JMenuBar类的可访问性支持。
      protected class  JMenuItem.AccessibleJMenuItem
      这个类实现 JMenuItem类的可访问性支持。
      protected class  JOptionPane.AccessibleJOptionPane
      该类实现 JOptionPane类的可访问性支持。
      protected class  JPanel.AccessibleJPanel
      该类实现 JPanel课程的可访问性支持。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现 JPasswordField类的可访问性支持。
      protected class  JPopupMenu.AccessibleJPopupMenu
      该类实现 JPopupMenu类的可访问性支持。
      protected class  JProgressBar.AccessibleJProgressBar
      该类实现 JProgressBar类的辅助功能支持。
      protected class  JRadioButton.AccessibleJRadioButton
      这个类实现 JRadioButton类的可访问性支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      该类实现 JRadioButtonMenuItem类的可访问性支持。
      protected class  JRootPane.AccessibleJRootPane
      这个类实现 JRootPane类的辅助功能支持。
      protected class  JScrollBar.AccessibleJScrollBar
      该类实现 JScrollBar类的可访问性支持。
      protected class  JScrollPane.AccessibleJScrollPane
      这个类实现 JScrollPane类的可访问性支持。
      protected class  JSeparator.AccessibleJSeparator
      该类实现 JSeparator类的可访问性支持。
      protected class  JSlider.AccessibleJSlider
      该类实现 JSlider类的可访问性支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner实现 JSpinner类的可访问性支持。
      protected class  JSplitPane.AccessibleJSplitPane
      该类实现 JSplitPane类的可访问性支持。
      protected class  JTabbedPane.AccessibleJTabbedPane
      该类实现 JTabbedPane类的可访问性支持。
      protected class  JTable.AccessibleJTable
      这个类实现 JTable类的可访问性支持。
      protected class  JTextArea.AccessibleJTextArea
      这个类实现 JTextArea类的辅助功能支持。
      protected class  JTextField.AccessibleJTextField
      这个类实现了 JTextField类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      该类实现 JToggleButton类的辅助功能支持。
      protected class  JToolBar.AccessibleJToolBar
      这个类实现 JToolBar类的可访问性支持。
      protected class  JToolTip.AccessibleJToolTip
      这个类实现 JToolTip类的可访问性支持。
      protected class  JTree.AccessibleJTree
      该类实现 JTree类的可访问性支持。
      protected class  JViewport.AccessibleJViewport
      该类实现 JViewport类的可访问性支持。
      protected class  JWindow.AccessibleJWindow
      该类实现 JWindow类的可访问性支持。

    • Uses of Component.AccessibleAWTComponent in javax.swing.table

      Subclasses of Component.AccessibleAWTComponent in javax.swing.table
      Modifier and Type Class 描述
      protected class  JTableHeader.AccessibleJTableHeader
      这个类实现 JTableHeader类的辅助功能支持。

    • Uses of Component.AccessibleAWTComponent in javax.swing.text

      Subclasses of Component.AccessibleAWTComponent in javax.swing.text
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      该类实现 JTextComponent类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

No usage of java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

No usage of java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Component.BaselineResizeBehavior (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Component.BaselineResizeBehavior

  • Packages that use Component.BaselineResizeBehavior
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of Component.BaselineResizeBehavior in java.awt

      Methods in java.awt that return Component.BaselineResizeBehavior
      Modifier and Type 方法 描述
      Component.BaselineResizeBehavior Component.getBaselineResizeBehavior​()
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      static Component.BaselineResizeBehavior Component.BaselineResizeBehavior.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Component.BaselineResizeBehavior[] Component.BaselineResizeBehavior.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of Component.BaselineResizeBehavior in javax.swing

      Methods in javax.swing that return Component.BaselineResizeBehavior
      Modifier and Type 方法 描述
      Component.BaselineResizeBehavior JComponent.getBaselineResizeBehavior​()
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior JSpinner.DefaultEditor.getBaselineResizeBehavior​()
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。

    • Uses of Component.BaselineResizeBehavior in javax.swing.border

      Methods in javax.swing.border that return Component.BaselineResizeBehavior
      Modifier and Type 方法 描述
      Component.BaselineResizeBehavior AbstractBorder.getBaselineResizeBehavior​(Component c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior TitledBorder.getBaselineResizeBehavior​(Component c)
      返回一个枚举，指示边框的基线如何随着大小的变化而改变。

    • Uses of Component.BaselineResizeBehavior in javax.swing.plaf

      Methods in javax.swing.plaf that return Component.BaselineResizeBehavior
      Modifier and Type 方法 描述
      Component.BaselineResizeBehavior ComponentUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior LayerUI.getBaselineResizeBehavior​(JComponent c)
      如果 JLayer的视图组件不是 null ，则返回视图 getBaselineResizeBehavior()方法的结果。

    • Uses of Component.BaselineResizeBehavior in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return Component.BaselineResizeBehavior
      Modifier and Type 方法 描述
      Component.BaselineResizeBehavior BasicButtonUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicComboBoxUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicLabelUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicListUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicPanelUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicProgressBarUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicScrollPaneUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicSliderUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicSpinnerUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicTabbedPaneUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicTableUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicTextAreaUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicTextFieldUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      Component.BaselineResizeBehavior BasicTreeUI.getBaselineResizeBehavior​(JComponent c)
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Component.BltBufferStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Component.BltBufferStrategy

No usage of java.awt.Component.BltBufferStrategy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Component.FlipBufferStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Component.FlipBufferStrategy

No usage of java.awt.Component.FlipBufferStrategy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.ComponentOrientation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.ComponentOrientation

  • Packages that use ComponentOrientation
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of ComponentOrientation in java.awt

      Fields in java.awt declared as ComponentOrientation
      Modifier and Type Field 描述
      static ComponentOrientation ComponentOrientation.LEFT_TO_RIGHT
      项目从左到右运行，线条从上到下实例：英语，法语。
      static ComponentOrientation ComponentOrientation.RIGHT_TO_LEFT
      项目从右到左运行，线条从上到下实例：阿拉伯语，希伯来文。
      static ComponentOrientation ComponentOrientation.UNKNOWN
      表示组件的方向尚未设置。
      Methods in java.awt that return ComponentOrientation
      Modifier and Type 方法 描述
      ComponentOrientation Component.getComponentOrientation​()
      检索用于对该组件中的元素或文本进行排序的语言敏感方向。
      static ComponentOrientation ComponentOrientation.getOrientation​(Locale locale)
      返回适合给定区域设置的方向。
      static ComponentOrientation ComponentOrientation.getOrientation​(ResourceBundle bdl)
      已过时。
      截至J2SE 1.4，使用getOrientation(java.util.Locale) 。
      Methods in java.awt with parameters of type ComponentOrientation
      Modifier and Type 方法 描述
      void Component.applyComponentOrientation​(ComponentOrientation orientation)
      设置此组件的 ComponentOrientation属性及其中包含的所有组件。
      void Container.applyComponentOrientation​(ComponentOrientation o)
      设置此容器的 ComponentOrientation属性及其中包含的所有组件。
      void Component.setComponentOrientation​(ComponentOrientation o)
      设置用于对该组件中的元素或文本进行排序的语言敏感方向。

    • Uses of ComponentOrientation in javax.swing

      Methods in javax.swing with parameters of type ComponentOrientation
      Modifier and Type | 方法 | 描述
      void JMenu.applyComponentOrientation​(ComponentOrientation o)
      设置此菜单的 ComponentOrientation属性及其中包含的所有组件。
      void | JMenu.setComponentOrientation​(ComponentOrientation o)
      void JScrollPane.setComponentOrientation​(ComponentOrientation co)
      设置由 ComponentOrientation参数确定的垂直和水平滚动条的方向。
      void JSpinner.NumberEditor.setComponentOrientation​(ComponentOrientation o)
      设置用于对该组件中的元素或文本进行排序的语言敏感方向。

    • Uses of ComponentOrientation in javax.swing.text

      Methods in javax.swing.text with parameters of type ComponentOrientation
      Modifier and Type | 方法 | 描述
      void | JTextComponent.setComponentOrientation​(ComponentOrientation o)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Container (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Container

  • Packages that use Container
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Container in java.applet

      Subclasses of Container in java.applet
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of Container in java.awt

      Subclasses of Container in java.awt
      Modifier and Type Class 描述
      class  Dialog
      Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      class  Frame
      A Frame是一个标题和边框的顶级窗口。
      class  Panel
      Panel是最简单的容器类。
      class  ScrollPane
      一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。
      class  Window
      一个 Window对象是没有边框的顶级窗口，没有菜单。
      Methods in java.awt that return Container
      Modifier and Type 方法 描述
      Container KeyboardFocusManager.getCurrentFocusCycleRoot​()
      如果当前焦点循环根与调用线程处于相同的上下文中，则返回当前焦点循环根。
      Container Component.getFocusCycleRootAncestor​()
      返回作为该组件焦点遍历循环的焦点循环根的容器。
      Container Window.getFocusCycleRootAncestor​()
      始终返回null因为Windows没有祖先; 它们代表组件层次结构的顶部。
      protected Container KeyboardFocusManager.getGlobalCurrentFocusCycleRoot​()
      返回当前焦点循环根，即使调用线程与当前焦点循环根不同。
      protected static Container Toolkit.getNativeContainer​(Component c)
      给本地对等体提供给本地组件查询本机容器的能力（例如，直接父级可能是轻量级的）。
      Container Component.getParent​()
      获取此组件的父级。
      Methods in java.awt with parameters of type Container
      Modifier and Type 方法 描述
      protected void GridBagLayout.arrangeGrid​(Container parent)
      排出电网。
      protected void GridBagLayout.ArrangeGrid​(Container parent)
      此方法已过时，仅供后向兼容; 新代码应该调用arrangeGrid 。
      void DefaultKeyboardFocusManager.downFocusCycle​(Container aContainer)
      将焦点向下移动一个焦点遍历周期。
      abstract void KeyboardFocusManager.downFocusCycle​(Container aContainer)
      将焦点向下移动一个焦点遍历周期。
      void CardLayout.first​(Container parent)
      翻转到容器的第一张卡片。
      Component ContainerOrderFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      abstract Component FocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component ContainerOrderFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      abstract Component FocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      Component ContainerOrderFocusTraversalPolicy.getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      abstract Component FocusTraversalPolicy.getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      Component ContainerOrderFocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      abstract Component FocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      Component ContainerOrderFocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      abstract Component FocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      float BorderLayout.getLayoutAlignmentX​(Container parent)
      返回沿x轴的对齐方式。
      float CardLayout.getLayoutAlignmentX​(Container parent)
      返回沿x轴的对齐方式。
      float GridBagLayout.getLayoutAlignmentX​(Container parent)
      返回沿x轴的对齐方式。
      float LayoutManager2.getLayoutAlignmentX​(Container target)
      返回沿x轴的对齐方式。
      float BorderLayout.getLayoutAlignmentY​(Container parent)
      返回沿着y轴的对齐。
      float CardLayout.getLayoutAlignmentY​(Container parent)
      返回沿着y轴的对齐。
      float GridBagLayout.getLayoutAlignmentY​(Container parent)
      返回沿着y轴的对齐。
      float LayoutManager2.getLayoutAlignmentY​(Container target)
      返回沿着y轴的对齐。
      Component BorderLayout.getLayoutComponent​(Container target, Object constraints)
      基于目标 Container的组件方向返回与给定约束位置相对应的组件。
      protected GridBagLayoutInfo GridBagLayout.getLayoutInfo​(Container parent, int sizeflag)
      填充当前管理子集的一个 GridBagLayoutInfo的实例。
      protected GridBagLayoutInfo GridBagLayout.GetLayoutInfo​(Container parent, int sizeflag)
      此方法已过时，仅供后向兼容; 新代码应该调用getLayoutInfo 。
      protected Dimension GridBagLayout.getMinSize​(Container parent, GridBagLayoutInfo info)
      根据 getLayoutInfo的信息， getLayoutInfo主站的最小尺寸。
      protected Dimension GridBagLayout.GetMinSize​(Container parent, GridBagLayoutInfo info)
      此方法已过时，仅供后向兼容; 新代码应该调用getMinSize 。
      void BorderLayout.invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      void CardLayout.invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      void GridBagLayout.invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      void LayoutManager2.invalidateLayout​(Container target)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      boolean Component.isFocusCycleRoot​(Container container)
      返回指定的Container是否是此组件焦点遍历周期的焦点循环根。
      boolean Container.isFocusCycleRoot​(Container container)
      返回指定的Container是否是此Container的焦点遍历循环的焦点循环根。
      void CardLayout.last​(Container parent)
      翻转到容器的最后一张卡片。
      void BorderLayout.layoutContainer​(Container target)
      使用此边框布局来填充容器参数。
      void CardLayout.layoutContainer​(Container parent)
      使用此卡布局来放出指定的容器。
      void FlowLayout.layoutContainer​(Container target)
      放出容器。
      void GridBagLayout.layoutContainer​(Container parent)
      使用此网格包布局来放出指定的容器。
      void GridLayout.layoutContainer​(Container parent)
      使用此布局放出指定的容器。
      void LayoutManager.layoutContainer​(Container parent)
      放出指定的容器。
      Dimension BorderLayout.maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension CardLayout.maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension GridBagLayout.maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension LayoutManager2.maximumLayoutSize​(Container target)
      给定指定容器的最大尺寸尺寸，给定其包含的组件。
      Dimension BorderLayout.minimumLayoutSize​(Container target)
      使用此布局管理器确定 target容器的最小大小。
      Dimension CardLayout.minimumLayoutSize​(Container parent)
      计算指定面板的最小尺寸。
      Dimension FlowLayout.minimumLayoutSize​(Container target)
      返回布局指定目标容器中包含的 可见组件所需的最小尺寸。
      Dimension GridBagLayout.minimumLayoutSize​(Container parent)
      使用此网格包布局确定 parent容器的最小尺寸。
      Dimension GridLayout.minimumLayoutSize​(Container parent)
      使用此网格布局确定容器参数的最小大小。
      Dimension LayoutManager.minimumLayoutSize​(Container parent)
      计算指定容器的最小尺寸尺寸，给定其包含的组件。
      void CardLayout.next​(Container parent)
      翻转到指定容器的下一张卡片。
      Dimension BorderLayout.preferredLayoutSize​(Container target)
      根据容器中的组件确定使用此布局管理器的 target容器的首选大小。
      Dimension CardLayout.preferredLayoutSize​(Container parent)
      使用此卡布局确定容器参数的首选大小。
      Dimension FlowLayout.preferredLayoutSize​(Container target)
      给定指定目标容器中 可见组件的返回值。
      Dimension GridBagLayout.preferredLayoutSize​(Container parent)
      使用此网格包布局确定 parent容器的首选大小。
      Dimension GridLayout.preferredLayoutSize​(Container parent)
      使用此网格布局确定容器参数的首选大小。
      Dimension LayoutManager.preferredLayoutSize​(Container parent)
      计算指定容器的首选大小尺寸，给定其包含的组件。
      void CardLayout.previous​(Container parent)
      翻转到指定容器的前一张卡片。
      void KeyboardFocusManager.setGlobalCurrentFocusCycleRoot​(Container newFocusCycleRoot)
      设置当前焦点循环根。
      void CardLayout.show​(Container parent, String name)
      翻转到已添加到该布局与指定的组件 name ，使用 addLayoutComponent 。

    • Uses of Container in java.awt.event

      Methods in java.awt.event that return Container
      Modifier and Type 方法 描述
      Container HierarchyEvent.getChangedParent​()
      返回由 getChanged()返回的组件的父 getChanged() 。
      Container ContainerEvent.getContainer​()
      返回事件的发起者。
      Constructors in java.awt.event with parameters of type Container
      Constructor 描述
      HierarchyEvent​(Component source, int id, Component changed, Container changedParent)
      构造一个 HierarchyEvent对象，以识别 Component层次结构中的更改。
      HierarchyEvent​(Component source, int id, Component changed, Container changedParent, long changeFlags)
      构造一个 HierarchyEvent对象，以识别 Component层次结构中的更改。

    • Uses of Container in java.beans.beancontext

      Methods in java.beans.beancontext that return Container
      Modifier and Type 方法 描述
      Container BeanContextContainerProxy.getContainer​()
      获取 java.awt.Container与此 BeanContext相关联。

    • Uses of Container in javafx.embed.swing

      Subclasses of Container in javafx.embed.swing
      Modifier and Type Class 描述
      class  JFXPanel
      JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。

    • Uses of Container in javax.swing

      Subclasses of Container in javax.swing
      Modifier and Type Class 描述
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      static class  Box.Filler
      参与布局但没有视图的轻量级组件的实现。
      class  CellRendererPane
      此类插入到单元格渲染器和使用它们的组件之间。
      class  DefaultListCellRenderer
      渲染列表中的项目。
      static class  DefaultListCellRenderer.UIResource
      实现UIResource的DefaultListCellRenderer的子类。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      class  JButton
      实现“推”按钮。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      class  JColorChooser
      JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      class  JComponent
      除顶级容器之外的所有Swing组件的基类。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      class  JDialog
      创建对话窗口的主要类。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      class  JFileChooser
      JFileChooser为用户提供了一种简单的选择文件的机制。
      class  JFormattedTextField
      JFormattedTextField扩展了 JTextField增加了对格式化任意值的支持，以及一旦用户编辑文本就检索特定对象。
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      static class  JInternalFrame.JDesktopIcon
      该组件代表 JInternalFrame的图标化版本。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并且可以接收在其边框内生成的所有 AWTEvent的通知。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem s的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。
      class  JMenuBar
      一个菜单栏的实现。
      class  JMenuItem
      菜单中项目的实现。
      class  JOptionPane
      JOptionPane可以轻松地弹出一个标准对话框，提示用户获取值或通知他们某些东西。
      class  JPanel
      JPanel是一个通用的轻量级容器。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示已打字，但不显示原始字符。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      static class  JPopupMenu.Separator
      弹出菜单特定的分隔符。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      class  JRootPane
      通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
      class  JScrollBar
      一个滚动条的实现。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
      class  JSeparator
      JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      更专业的编辑器的简单基类，可以使用 JFormattedTextField显示模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      class  JSplitPane
      JSplitPane用于分割二（只有两个） Component s。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      class  JTextArea
      A JTextArea是显示纯文本的多行区域。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      static class  JToolBar.Separator
      工具栏特定的分隔符。
      class  JToolTip
      用于显示组件的“提示”。
      class  JTree
      将一组分层数据显示为大纲的控件。
      class  JViewport
      您可以通过它查看基础信息的“视口”或“舷窗”。
      class  JWindow
      A JWindow是可以显示在用户桌面上的任意位置的容器。
      Fields in javax.swing declared as Container
      Modifier and Type Field 描述
      protected Container JRootPane.contentPane
      内容窗格。
      Methods in javax.swing that return Container
      Modifier and Type 方法 描述
      protected Container JRootPane.createContentPane​()
      由构造函数调用方法创建默认 contentPane 。
      static Container SwingUtilities.getAncestorNamed​(String name, Component comp)
      以上搜索的便捷方法 comp组件层次结构中，并返回的第一对象 name它找到。
      static Container SwingUtilities.getAncestorOfClass​(Class<?> c, Component comp)
      在组件层次结构中搜索 comp上方的方便方法，并返回它发现的类别 c的第一个对象。
      Container JApplet.getContentPane​()
      已过时。
      返回此applet的contentPane对象。
      Container JDialog.getContentPane​()
      返回此对话框的 contentPane对象。
      Container JFrame.getContentPane​()
      返回此帧的 contentPane对象。
      Container JInternalFrame.getContentPane​()
      返回此内部框架的内容窗格。
      Container JRootPane.getContentPane​()
      返回内容窗格 - 保存由根窗格父化的组件的容器。
      Container JWindow.getContentPane​()
      返回 Container ，这是该窗口的 contentPane 。
      Container RootPaneContainer.getContentPane​()
      返回contentPane。
      Container JInternalFrame.getFocusCycleRootAncestor​()
      始终返回 null因为 JInternalFrame必须始终是焦点遍历循环的根。
      Container BoxLayout.getTarget​()
      返回使用此布局管理器的容器。
      Container OverlayLayout.getTarget​()
      返回使用此布局管理器的容器。
      Container JComponent.getTopLevelAncestor​()
      返回此组件的顶级祖先（包含 Window或 Applet ），如果此组件尚未添加到任何容器，则 null 。
      static Container SwingUtilities.getUnwrappedParent​(Component component)
      返回component的第一个祖先，而不是JLayer的一个实例。
      Methods in javax.swing with parameters of type Container
      Modifier and Type | 方法 | 描述
      Component DefaultFocusManager.getComponentAfter​(Container aContainer, Component aComponent)
      返回之后的组件。
      Component LayoutFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component SortingFocusTraversalPolicy.getComponentAfter​(Container aContainer, Component aComponent)
      返回在aComponent之后应该接收焦点的Component。
      Component DefaultFocusManager.getComponentBefore​(Container aContainer, Component aComponent)
      返回之前的组件。
      Component LayoutFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      Component SortingFocusTraversalPolicy.getComponentBefore​(Container aContainer, Component aComponent)
      返回应该在aComponent之前接收焦点的Component。
      abstract int LayoutStyle.getContainerGap​(JComponent component, int position, Container parent)
      返回要放置在组件与其父项的指定边缘之间的空间量。
      Component SortingFocusTraversalPolicy.getDefaultComponent​(Container aContainer)
      返回要对焦的默认组件。
      Component DefaultFocusManager.getFirstComponent​(Container aContainer)
      返回第一个组件。
      Component LayoutFocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      Component SortingFocusTraversalPolicy.getFirstComponent​(Container aContainer)
      返回遍历周期中的第一个Component。
      Component DefaultFocusManager.getLastComponent​(Container aContainer)
      返回最后一个组件。
      Component LayoutFocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      Component SortingFocusTraversalPolicy.getLastComponent​(Container aContainer)
      返回遍历周期中的最后一个组件。
      float BoxLayout.getLayoutAlignmentX​(Container target)
      返回容器沿X轴的对齐方式。
      float GroupLayout.getLayoutAlignmentX​(Container parent)
      返回沿x轴的对齐方式。
      float | JRootPane.RootLayout.getLayoutAlignmentX​(Container target)
      float OverlayLayout.getLayoutAlignmentX​(Container target)
      返回容器沿x轴的对齐方式。
      float SpringLayout.getLayoutAlignmentX​(Container p)
      返回0.5f（居中）。
      float BoxLayout.getLayoutAlignmentY​(Container target)
      返回容器沿着Y轴的对齐方式。
      float GroupLayout.getLayoutAlignmentY​(Container parent)
      返回沿着y轴的对齐。
      float | JRootPane.RootLayout.getLayoutAlignmentY​(Container target)
      float OverlayLayout.getLayoutAlignmentY​(Container target)
      返回容器沿y轴的对齐方式。
      float SpringLayout.getLayoutAlignmentY​(Container p)
      返回0.5f（居中）。
      abstract int LayoutStyle.getPreferredGap​(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
      返回两个组件之间使用的空间量。
      void BoxLayout.invalidateLayout​(Container target)
      表示一个孩子已经更改了其布局相关信息，因此应该刷新任何缓存的计算。
      void GroupLayout.invalidateLayout​(Container parent)
      使布局无效，指示如果布局管理器已缓存信息，则应将其丢弃。
      void | JRootPane.RootLayout.invalidateLayout​(Container target)
      void OverlayLayout.invalidateLayout​(Container target)
      表示小孩已更改其布局相关信息，这会导致任何缓存计算被刷新。
      void | SpringLayout.invalidateLayout​(Container p)
      void BoxLayout.layoutContainer​(Container target)
      由AWT召集 当指定的容器需要布置时。
      void GroupLayout.layoutContainer​(Container parent)
      放出指定的容器。
      void JRootPane.RootLayout.layoutContainer​(Container parent)
      指示布局管理器执行指定容器的布局。
      void JSpinner.DefaultEditor.layoutContainer​(Container parent)
      调整一个（而且只）的孩子，以完全填补父母插图内的区域。
      void OverlayLayout.layoutContainer​(Container target)
      当指定的容器需要布置时，由AWT调用。
      void ScrollPaneLayout.layoutContainer​(Container parent)
      吹出滚屏。
      void | SpringLayout.layoutContainer​(Container parent)
      void ViewportLayout.layoutContainer​(Container parent)
      当指定的容器需要布置时，由AWT调用。
      Dimension BoxLayout.maximumLayoutSize​(Container target)
      返回目标容器可用于布局其包含的组件的最大尺寸。
      Dimension GroupLayout.maximumLayoutSize​(Container parent)
      返回指定容器的最大大小。
      Dimension JRootPane.RootLayout.maximumLayoutSize​(Container target)
      返回布局可以使用的最大空间量。
      Dimension OverlayLayout.maximumLayoutSize​(Container target)
      返回布局包含在指定目标容器中的组件所需的最大尺寸。
      Dimension | SpringLayout.maximumLayoutSize​(Container parent)
      Dimension BoxLayout.minimumLayoutSize​(Container target)
      返回布局包含在指定目标容器中的组件所需的最小尺寸。
      Dimension GroupLayout.minimumLayoutSize​(Container parent)
      返回指定容器的最小大小。
      Dimension JRootPane.RootLayout.minimumLayoutSize​(Container parent)
      返回布局所需的最小空间量。
      Dimension JSpinner.DefaultEditor.minimumLayoutSize​(Container parent)
      返回第一个（且仅））小孩的最小大小加上父母插入的大小。
      Dimension OverlayLayout.minimumLayoutSize​(Container target)
      返回布局包含在指定目标容器中的组件所需的最小尺寸。
      Dimension ScrollPaneLayout.minimumLayoutSize​(Container parent)
      ScrollPane的最小大小是 ScrollPane大小加视口的最小尺寸，加上滚动窗口的viewportBorder插入，加上可见标题的最小大小，以及displayPolicy不是永远不会的滚动条的最小大小。
      Dimension | SpringLayout.minimumLayoutSize​(Container parent)
      Dimension ViewportLayout.minimumLayoutSize​(Container parent)
      返回布局指定目标容器中包含的组件所需的最小尺寸。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h)
      调用this.paintComponent（g，c，p，x，y，w，h，false）。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
      在图形对象上绘制单元格渲染器组件c。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      调用this.paintComponent（）与矩形x，y，width，height字段。
      static void SwingUtilities.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h)
      绘制一个组件到指定的 Graphics 。
      static void SwingUtilities.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      绘制一个组件到指定的 Graphics 。
      Dimension BoxLayout.preferredLayoutSize​(Container target)
      给定指定目标容器中的组件，返回此布局的首选尺寸。
      Dimension GroupLayout.preferredLayoutSize​(Container parent)
      返回指定容器的首选大小。
      Dimension JRootPane.RootLayout.preferredLayoutSize​(Container parent)
      返回布局想要的空间量。
      Dimension JSpinner.DefaultEditor.preferredLayoutSize​(Container parent)
      返回首个（而且仅）子项的首选大小加上父母插入的大小。
      Dimension OverlayLayout.preferredLayoutSize​(Container target)
      给定指定目标容器中的组件，返回此布局的首选尺寸。
      Dimension ScrollPaneLayout.preferredLayoutSize​(Container parent)
      ScrollPane的首选大小是插图的大小，加上视口的首选大小，加上可见标题的首选大小，以及给定当前视图和当前滚动条displayPolicies的滚动条的首选大小。
      Dimension | SpringLayout.preferredLayoutSize​(Container parent)
      Dimension ViewportLayout.preferredLayoutSize​(Container parent)
      给定指定目标容器中的组件，返回此布局的首选尺寸。
      void JApplet.setContentPane​(Container contentPane)
      已过时。
      设置contentPane属性。
      void JDialog.setContentPane​(Container contentPane)
      设置 contentPane属性。
      void JFrame.setContentPane​(Container contentPane)
      设置 contentPane属性。
      void JInternalFrame.setContentPane​(Container c)
      设置这个 JInternalFrame的 contentPane属性。
      void JRootPane.setContentPane​(Container content)
      设置内容窗格 - 保存由根窗格加载的组件的容器。
      void JWindow.setContentPane​(Container contentPane)
      设置此窗口的 contentPane属性。
      void RootPaneContainer.setContentPane​(Container contentPane)
      “contentPane”是应用程序特定组件的主容器。
      Constructors in javax.swing with parameters of type Container
      Constructor 描述
      BoxLayout​(Container target, int axis)
      创建一个布局管理器，它将沿着给定的轴布局组件。
      GroupLayout​(Container host)
      创建 GroupLayout为指定 Container 。
      OverlayLayout​(Container target)
      构建一个布局管理器，执行子项的覆盖排列。

    • Uses of Container in javax.swing.colorchooser

      Subclasses of Container in javax.swing.colorchooser
      Modifier and Type Class 描述
      class  AbstractColorChooserPanel
      这是颜色选择器的抽象超类。

    • Uses of Container in javax.swing.event

      Methods in javax.swing.event that return Container
      Modifier and Type 方法 描述
      Container AncestorEvent.getAncestor​()
      返回事件实际发生的祖先。
      Container AncestorEvent.getAncestorParent​()
      返回事件实际发生的祖先的父级。
      Constructors in javax.swing.event with parameters of type Container
      Constructor 描述
      AncestorEvent​(JComponent source, int id, Container ancestor, Container ancestorParent)
      构造一个AncestorEvent对象，以识别祖先组件的显示状态的变化。

    • Uses of Container in javax.swing.plaf.basic

      Subclasses of Container in javax.swing.plaf.basic
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
      class  BasicComboBoxRenderer
      ComboBox渲染器
      static class  BasicComboBoxRenderer.UIResource
      BasicComboBoxRenderer的子类实现UIResource。
      class  BasicComboPopup
      这是 ComboPopup界面的基本实现。
      class  BasicInternalFrameTitlePane
      管理基本标题栏的类
      class  BasicInternalFrameTitlePane.SystemMenuBar
      这个类应该被视为一个“受保护”的内部类。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。
      Methods in javax.swing.plaf.basic that return Container
      Modifier and Type 方法 描述
      protected Container BasicOptionPaneUI.createButtonArea​()
      创建并返回包含按钮的 Container 。
      protected Container BasicOptionPaneUI.createMessageArea​()
      消息从 installComponents创建一个 Container包含消息的正文。
      protected Container BasicOptionPaneUI.createSeparator​()
      返回一个分隔符。
      Methods in javax.swing.plaf.basic with parameters of type Container
      Modifier and Type | 方法 | 描述
      protected void BasicOptionPaneUI.addButtonComponents​(Container container, Object[] buttons, int initialIndex)
      创建适当的对象来表示 buttons每个对象，并将其添加到 container 。
      protected void BasicOptionPaneUI.addIcon​(Container top)
      创建并添加一个表示从 getIcon返回的图标到 top 。
      protected void BasicOptionPaneUI.addMessageComponents​(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)
      创建适当的对象来表示 msg并将其放入 container 。
      protected void BasicOptionPaneUI.burstStringInto​(Container c, String d, int maxll)
      递归创建新的 JLabel实例来表示 d 。
      float BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentX​(Container target)
      返回沿x轴的对齐方式。
      float BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentY​(Container target)
      返回沿着y轴的对齐。
      void BasicSplitPaneUI.BasicHorizontalLayoutManager.invalidateLayout​(Container c)
      什么也没做。
      void | BasicComboBoxUI.ComboBoxLayoutManager.layoutContainer​(Container parent)
      void | BasicInternalFrameTitlePane.TitlePaneLayout.layoutContainer​(Container c)
      void BasicInternalFrameUI.InternalFrameLayout.layoutContainer​(Container c)
      放出指定的容器。
      void | BasicOptionPaneUI.ButtonAreaLayout.layoutContainer​(Container container)
      void | BasicScrollBarUI.layoutContainer​(Container scrollbarContainer)
      void | BasicSplitPaneDivider.DividerLayout.layoutContainer​(Container c)
      void BasicSplitPaneUI.BasicHorizontalLayoutManager.layoutContainer​(Container container)
      实际布局。
      void BasicTabbedPaneUI.TabbedPaneLayout.layoutContainer​(Container parent)
      放出指定的容器。
      Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.maximumLayoutSize​(Container target)
      返回两个方向的最大布局大小，即Integer.MAX_VALUE。
      Dimension | BasicComboBoxUI.ComboBoxLayoutManager.minimumLayoutSize​(Container parent)
      Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.minimumLayoutSize​(Container c)
      Dimension BasicInternalFrameUI.InternalFrameLayout.minimumLayoutSize​(Container c)
      计算指定容器的最小尺寸尺寸，给定其包含的组件。
      Dimension | BasicOptionPaneUI.ButtonAreaLayout.minimumLayoutSize​(Container c)
      Dimension | BasicScrollBarUI.minimumLayoutSize​(Container scrollbarContainer)
      Dimension | BasicSplitPaneDivider.DividerLayout.minimumLayoutSize​(Container c)
      Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.minimumLayoutSize​(Container container)
      返回包含子项所需的最小大小。
      Dimension | BasicTabbedPaneUI.TabbedPaneLayout.minimumLayoutSize​(Container parent)
      Dimension | BasicComboBoxUI.ComboBoxLayoutManager.preferredLayoutSize​(Container parent)
      Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.preferredLayoutSize​(Container c)
      Dimension BasicInternalFrameUI.InternalFrameLayout.preferredLayoutSize​(Container c)
      计算指定容器的首选大小尺寸，给定其包含的组件。
      Dimension | BasicOptionPaneUI.ButtonAreaLayout.preferredLayoutSize​(Container c)
      Dimension | BasicScrollBarUI.preferredLayoutSize​(Container scrollbarContainer)
      Dimension | BasicSplitPaneDivider.DividerLayout.preferredLayoutSize​(Container c)
      Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.preferredLayoutSize​(Container container)
      返回包含子项所需的首选大小。
      Dimension | BasicTabbedPaneUI.TabbedPaneLayout.preferredLayoutSize​(Container parent)
      Dimension | DefaultMenuLayout.preferredLayoutSize​(Container target)
      Constructors in javax.swing.plaf.basic with parameters of type Container
      Constructor 描述
      DefaultMenuLayout​(Container target, int axis)
      构造一个新的实例 DefaultMenuLayout 。

    • Uses of Container in javax.swing.plaf.metal

      Subclasses of Container in javax.swing.plaf.metal
      Modifier and Type Class 描述
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalComboBoxUI.MetalComboPopup
      已过时。
      从Java 2平台v1.4开始。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      class  MetalFileChooserUI.FilterComboBoxRenderer
      渲染不同类型的尺寸和样式。
      class  MetalInternalFrameTitlePane
      管理JLF标题栏的类
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。
      Methods in javax.swing.plaf.metal with parameters of type Container
      Modifier and Type | 方法 | 描述
      void MetalComboBoxUI.layoutComboBox​(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)
      勾画出 JComboBox在 parent容器。
      void | MetalComboBoxUI.MetalComboBoxLayoutManager.layoutContainer​(Container parent)
      void MetalComboBoxUI.MetalComboBoxLayoutManager.superLayout​(Container parent)
      放出父容器。

    • Uses of Container in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Container
      Modifier and Type 方法 描述
      protected Container SynthOptionPaneUI.createMessageArea​()
      调用从 SynthOptionPaneUI.installComponents()创建一个 Container包含消息的正文。
      protected Container SynthOptionPaneUI.createSeparator​()
      返回一个分隔符。

    • Uses of Container in javax.swing.table

      Subclasses of Container in javax.swing.table
      Modifier and Type Class 描述
      class  DefaultTableCellRenderer
      在 JTable渲染（显示）单个单元格的标准类。
      static class  DefaultTableCellRenderer.UIResource
      DefaultTableCellRenderer的子类实现 UIResource 。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。

    • Uses of Container in javax.swing.text

      Subclasses of Container in javax.swing.text
      Modifier and Type Class 描述
      class  JTextComponent
      JTextComponent是摆动文本组件的基类。
      Methods in javax.swing.text that return Container
      Modifier and Type 方法 描述
      Container View.getContainer​()
      获取托管视图的容器。

    • Uses of Container in javax.swing.tree

      Subclasses of Container in javax.swing.tree
      Modifier and Type Class 描述
      class  DefaultTreeCellEditor.DefaultTextField
      当不提供编辑器时使用 TextField 。
      class  DefaultTreeCellEditor.EditorContainer
      集装箱负责放置 editingComponent 。
      class  DefaultTreeCellRenderer
      在树中显示一个条目。
      Fields in javax.swing.tree declared as Container
      Modifier and Type Field 描述
      protected Container DefaultTreeCellEditor.editingContainer
      编辑容器，将包含 editorComponent 。
      Methods in javax.swing.tree that return Container
      Modifier and Type 方法 描述
      protected Container DefaultTreeCellEditor.createContainer​()
      创建容器管理 editingComponent位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Container.AccessibleAWTContainer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Container.AccessibleAWTContainer

  • Packages that use Container.AccessibleAWTContainer
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Container.AccessibleAWTContainer in java.applet

      Subclasses of Container.AccessibleAWTContainer in java.applet
      Modifier and Type Class 描述
      protected class  Applet.AccessibleApplet
      已过时。
      这个类实现 Applet类的可访问性支持。

    • Uses of Container.AccessibleAWTContainer in java.awt

      Subclasses of Container.AccessibleAWTContainer in java.awt
      Modifier and Type Class 描述
      protected class  Dialog.AccessibleAWTDialog
      这个类实现 Dialog类的可访问性支持。
      protected class  Frame.AccessibleAWTFrame
      这个类实现 Frame类的可访问性支持。
      protected class  Panel.AccessibleAWTPanel
      这个类实现 Panel类的可访问性支持。
      protected class  ScrollPane.AccessibleAWTScrollPane
      这个类实现 ScrollPane类的辅助功能支持。
      protected class  Window.AccessibleAWTWindow
      这个类实现 Window类的可访问性支持。

    • Uses of Container.AccessibleAWTContainer in javax.swing

      Subclasses of Container.AccessibleAWTContainer in javax.swing
      Modifier and Type Class 描述
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现 AbstractButton类的可访问性支持。
      protected class  Box.AccessibleBox
      这个类实现 Box类的辅助功能支持。
      protected class  CellRendererPane.AccessibleCellRendererPane
      这个类实现 CellRendererPane类的可访问性支持。
      protected class  JApplet.AccessibleJApplet
      已过时。
      这个类实现 JApplet类的可访问性支持。
      protected class  JButton.AccessibleJButton
      该类为 JButton类实现可访问性支持。
      protected class  JCheckBox.AccessibleJCheckBox
      该类实现 JCheckBox类的可访问性支持。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      这个类实现 JCheckBoxMenuItem类的可访问性支持。
      protected class  JColorChooser.AccessibleJColorChooser
      这个类实现 JColorChooser类的可访问性支持。
      protected class  JComboBox.AccessibleJComboBox
      该类为 JComboBox类实现可访问性支持。
      class  JComponent.AccessibleJComponent
      JComponent的内部类用于为辅助功能提供默认支持。
      protected class  JDesktopPane.AccessibleJDesktopPane
      这个类实现 JDesktopPane类的可访问性支持。
      protected class  JDialog.AccessibleJDialog
      这个类实现 JDialog类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText
      protected class  JFileChooser.AccessibleJFileChooser
      该类实现 JFileChooser类的可访问性支持。
      protected class  JFrame.AccessibleJFrame
      这个类实现 JFrame类的可访问性支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      这个类实现 JInternalFrame类的可访问性支持。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      这个类实现 JInternalFrame.JDesktopIcon类的可访问性支持。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      protected class  JLayeredPane.AccessibleJLayeredPane
      这个类实现 JLayeredPane类的可访问性支持。
      protected class  JList.AccessibleJList
      该类实现 JList类的可访问性支持。
      protected class  JMenu.AccessibleJMenu
      该类为 JMenu类实现可访问性支持。
      protected class  JMenuBar.AccessibleJMenuBar
      这个类实现 JMenuBar类的可访问性支持。
      protected class  JMenuItem.AccessibleJMenuItem
      这个类实现 JMenuItem类的辅助功能支持。
      protected class  JOptionPane.AccessibleJOptionPane
      这个类实现 JOptionPane类的可访问性支持。
      protected class  JPanel.AccessibleJPanel
      这个类实现 JPanel类的可访问性支持。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现 JPasswordField类的辅助功能支持。
      protected class  JPopupMenu.AccessibleJPopupMenu
      这个类实现 JPopupMenu类的可访问性支持。
      protected class  JProgressBar.AccessibleJProgressBar
      该类实现对 JProgressBar类的可访问性支持。
      protected class  JRadioButton.AccessibleJRadioButton
      该类实现 JRadioButton类的辅助功能支持。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现 JRadioButtonMenuItem类的辅助功能支持。
      protected class  JRootPane.AccessibleJRootPane
      该类实现 JRootPane类的可访问性支持。
      protected class  JScrollBar.AccessibleJScrollBar
      这个类实现 JScrollBar类的可访问性支持。
      protected class  JScrollPane.AccessibleJScrollPane
      该类为 JScrollPane类实现可访问性支持。
      protected class  JSeparator.AccessibleJSeparator
      该类实现 JSeparator类的可访问性支持。
      protected class  JSlider.AccessibleJSlider
      这个类实现 JSlider类的辅助功能支持。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner为 JSpinner类实现可访问性支持。
      protected class  JSplitPane.AccessibleJSplitPane
      这个类实现 JSplitPane类的可访问性支持。
      protected class  JTabbedPane.AccessibleJTabbedPane
      这个类实现 JTabbedPane类的可访问性支持。
      protected class  JTable.AccessibleJTable
      这个类实现 JTable类的辅助功能支持。
      protected class  JTextArea.AccessibleJTextArea
      这个类实现 JTextArea类的可访问性支持。
      protected class  JTextField.AccessibleJTextField
      这个类实现 JTextField类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      该类为 JToggleButton类实现可访问性支持。
      protected class  JToolBar.AccessibleJToolBar
      这个类实现 JToolBar类的可访问性支持。
      protected class  JToolTip.AccessibleJToolTip
      该类实现 JToolTip类的可访问性支持。
      protected class  JTree.AccessibleJTree
      该类实现 JTree类的可访问性支持。
      protected class  JViewport.AccessibleJViewport
      这个类实现 JViewport类的可访问性支持。
      protected class  JWindow.AccessibleJWindow
      该类实现 JWindow类的可访问性支持。

    • Uses of Container.AccessibleAWTContainer in javax.swing.table

      Subclasses of Container.AccessibleAWTContainer in javax.swing.table
      Modifier and Type Class 描述
      protected class  JTableHeader.AccessibleJTableHeader
      该类为 JTableHeader类实现可访问性支持。

    • Uses of Container.AccessibleAWTContainer in javax.swing.text

      Subclasses of Container.AccessibleAWTContainer in javax.swing.text
      Modifier and Type Class 描述
      class  JTextComponent.AccessibleJTextComponent
      这个类实现 JTextComponent类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler

No usage of java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.ContainerOrderFocusTraversalPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.ContainerOrderFocusTraversalPolicy

  • Packages that use ContainerOrderFocusTraversalPolicy
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of ContainerOrderFocusTraversalPolicy in java.awt

      Subclasses of ContainerOrderFocusTraversalPolicy in java.awt
      Modifier and Type Class 描述
      class  DefaultFocusTraversalPolicy
      FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Cursor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Cursor

  • Packages that use Cursor
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。

    • Uses of Cursor in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Cursor
      Modifier and Type 方法 描述
      Cursor Translator.getCursor​()
      获取此对象的 Cursor 。
      Methods in com.sun.java.accessibility.util with parameters of type Cursor
      Modifier and Type 方法 描述
      void Translator.setCursor​(Cursor c)
      设置这个对象的 Cursor 。

    • Uses of Cursor in java.awt

      Fields in java.awt declared as Cursor
      Modifier and Type Field 描述
      protected static Cursor[] Cursor.predefined
      已过时。
      从JDK 1.7版开始，应该使用getPredefinedCursor(int)方法。
      Methods in java.awt that return Cursor
      Modifier and Type 方法 描述
      Cursor Toolkit.createCustomCursor​(Image cursor, Point hotSpot, String name)
      创建一个新的自定义光标对象。
      Cursor Component.AccessibleAWTComponent.getCursor​()
      获取此对象的 Cursor 。
      Cursor Component.getCursor​()
      获取组件中的光标集。
      Cursor List.AccessibleAWTList.AccessibleAWTListChild.getCursor​()
      获取此对象的Cursor。
      Cursor MenuComponent.AccessibleAWTMenuComponent.getCursor​()
      获取此对象的 Cursor 。
      static Cursor Cursor.getDefaultCursor​()
      返回系统默认光标。
      static Cursor Cursor.getPredefinedCursor​(int type)
      返回具有指定预定义类型的游标对象。
      static Cursor Cursor.getSystemCustomCursor​(String name)
      返回与指定名称匹配的特定于系统的自定义游标对象。
      Methods in java.awt with parameters of type Cursor
      Modifier and Type 方法 描述
      void Component.AccessibleAWTComponent.setCursor​(Cursor cursor)
      设置此对象的 Cursor 。
      void Component.setCursor​(Cursor cursor)
      将光标图像设置为指定的光标。
      void List.AccessibleAWTList.AccessibleAWTListChild.setCursor​(Cursor cursor)
      设置此对象的Cursor。
      void MenuComponent.AccessibleAWTMenuComponent.setCursor​(Cursor cursor)
      设置该对象的 Cursor 。
      void Window.setCursor​(Cursor cursor)
      将光标图像设置为指定的光标。

    • Uses of Cursor in java.awt.dnd

      Fields in java.awt.dnd declared as Cursor
      Modifier and Type Field 描述
      static Cursor DragSource.DefaultCopyDrop
      默认 Cursor ，用于复制操作，指示当前允许丢弃。
      static Cursor DragSource.DefaultCopyNoDrop
      使用默认值 Cursor进行复制操作，指示当前不允许下拉。
      static Cursor DragSource.DefaultLinkDrop
      缺省 Cursor ，用于指示当前允许丢弃的链接操作。
      static Cursor DragSource.DefaultLinkNoDrop
      默认使用 Cursor链接操作，指示当前不允许丢弃。
      static Cursor DragSource.DefaultMoveDrop
      默认 Cursor ，用于指示当前允许下降的移动操作。
      static Cursor DragSource.DefaultMoveNoDrop
      默认的 Cursor与移动操作一起使用，指示当前不允许丢弃。
      Methods in java.awt.dnd that return Cursor
      Modifier and Type 方法 描述
      Cursor DragSourceContext.getCursor​()
      返回当前自定义拖动 Cursor 。
      Methods in java.awt.dnd with parameters of type Cursor
      Modifier and Type 方法 描述
      protected DragSourceContext DragSource.createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      void DragSourceContext.setCursor​(Cursor c)
      将此拖动操作的自定义光标设置为指定的 Cursor 。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Transferable transferable)
      开始拖动操作中给出的 Cursor此拖动操作和 Transferable表示此拖动操作的源数据。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始拖动给出初始的 Cursor显示， Transferable对象和 DragSourceListener使用。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl)
      启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
      Constructors in java.awt.dnd with parameters of type Cursor
      Constructor 描述
      DragSourceContext​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
      从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。

    • Uses of Cursor in javax.accessibility

      Methods in javax.accessibility that return Cursor
      Modifier and Type 方法 描述
      Cursor AccessibleComponent.getCursor​()
      获取此对象的光标。
      Methods in javax.accessibility with parameters of type Cursor
      Modifier and Type 方法 描述
      void AccessibleComponent.setCursor​(Cursor cursor)
      设置此对象的光标。

    • Uses of Cursor in javax.swing

      Methods in javax.swing that return Cursor
      Modifier and Type | 方法 | 描述
      Cursor | JList.AccessibleJList.AccessibleJListChild.getCursor​()
      Cursor JTable.AccessibleJTable.AccessibleJTableCell.getCursor​()
      获取此对象的 Cursor 。
      Cursor | JTree.AccessibleJTree.AccessibleJTreeNode.getCursor​()
      Cursor JInternalFrame.getLastCursor​()
      返回由 setCursor方法设置的最后一个 Cursor ，该方法不是可调整大小的 Cursor 。
      Methods in javax.swing with parameters of type Cursor
      Modifier and Type | 方法 | 描述
      void JInternalFrame.setCursor​(Cursor cursor)
      将光标图像设置为指定的光标。
      void | JList.AccessibleJList.AccessibleJListChild.setCursor​(Cursor c)
      void JTable.AccessibleJTable.AccessibleJTableCell.setCursor​(Cursor c)
      设置此对象的 Cursor 。
      void | JTree.AccessibleJTree.AccessibleJTreeNode.setCursor​(Cursor c)

    • Uses of Cursor in javax.swing.table

      Methods in javax.swing.table that return Cursor
      Modifier and Type | 方法 | 描述
      Cursor | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getCursor​()
      Methods in javax.swing.table with parameters of type Cursor
      Modifier and Type | 方法 | 描述
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setCursor​(Cursor c)

    • Uses of Cursor in javax.swing.text.html

      Methods in javax.swing.text.html that return Cursor
      Modifier and Type 方法 描述
      Cursor HTMLEditorKit.getDefaultCursor​()
      返回默认游标。
      Cursor HTMLEditorKit.getLinkCursor​()
      返回光标以超链接使用。
      Methods in javax.swing.text.html with parameters of type Cursor
      Modifier and Type 方法 描述
      void HTMLEditorKit.setDefaultCursor​(Cursor cursor)
      设置默认光标。
      void HTMLEditorKit.setLinkCursor​(Cursor cursor)
      将光标设置为使用链接。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.DefaultFocusTraversalPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.DefaultFocusTraversalPolicy

No usage of java.awt.DefaultFocusTraversalPolicy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.DefaultKeyboardFocusManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.DefaultKeyboardFocusManager

  • Packages that use DefaultKeyboardFocusManager
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of DefaultKeyboardFocusManager in javax.swing

      Subclasses of DefaultKeyboardFocusManager in javax.swing
      Modifier and Type Class 描述
      class  DefaultFocusManager
      这个类已被1.4焦点API过时了。
      class  FocusManager
      这个类已被1.4焦点API过时了。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Desktop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Desktop

  • Packages that use Desktop
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Desktop in java.awt

      Methods in java.awt that return Desktop
      Modifier and Type 方法 描述
      static Desktop Desktop.getDesktop​()
      返回当前桌面上下文的 Desktop实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Desktop.Action (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Desktop.Action

  • Packages that use Desktop.Action
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Desktop.Action in java.awt

      Methods in java.awt that return Desktop.Action
      Modifier and Type 方法 描述
      static Desktop.Action Desktop.Action.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Desktop.Action[] Desktop.Action.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type Desktop.Action
      Modifier and Type 方法 描述
      boolean Desktop.isSupported​(Desktop.Action action)
      测试当前平台是否支持操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Dialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Dialog

  • Packages that use Dialog
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Dialog in java.awt

      Subclasses of Dialog in java.awt
      Modifier and Type Class 描述
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      Constructors in java.awt with parameters of type Dialog
      Constructor 描述
      Dialog​(Dialog owner)
      构造一个最初不可见的，无模式 Dialog带有指定的所有者 Dialog和空标题。
      Dialog​(Dialog owner, String title)
      构造一个初始隐形的，无指定的 Dialog与指定的所有者 Dialog和标题。
      Dialog​(Dialog owner, String title, boolean modal)
      构造最初不可见的 Dialog与指定的所有者 Dialog ，标题和模态。
      Dialog​(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
      构造最初无形 Dialog与指定的所有者 Dialog ，标题，模式和 GraphicsConfiguration 。
      FileDialog​(Dialog parent)
      创建一个加载文件的文件对话框。
      FileDialog​(Dialog parent, String title)
      创建一个文件对话框窗口，其中包含用于加载文件的指定标题。
      FileDialog​(Dialog parent, String title, int mode)
      创建一个带有指定标题的文件对话窗口，用于加载或保存文件。

    • Uses of Dialog in javax.swing

      Subclasses of Dialog in javax.swing
      Modifier and Type Class 描述
      class  JDialog
      创建对话窗口的主要类。
      Constructors in javax.swing with parameters of type Dialog
      Constructor 描述
      JDialog​(Dialog owner)
      使用指定的 Dialog作为其所有者创建无模式对话框，并创建一个空标题。
      JDialog​(Dialog owner, boolean modal)
      创建一个具有空标题和指定模态的 Dialog ，其中所有者为 Dialog 。
      JDialog​(Dialog owner, String title)
      使用指定的标题和指定的所有者对话框创建无模式对话框。
      JDialog​(Dialog owner, String title, boolean modal)
      创建一个具有指定标题，模态和指定所有者的 Dialog 。
      JDialog​(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
      创建一个具有指定标题的对话框，拥有者 Dialog ，模式和 GraphicsConfiguration 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Dialog.AccessibleAWTDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Dialog.AccessibleAWTDialog

  • Packages that use Dialog.AccessibleAWTDialog
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Dialog.AccessibleAWTDialog in javax.swing

      Subclasses of Dialog.AccessibleAWTDialog in javax.swing
      Modifier and Type Class 描述
      protected class  JDialog.AccessibleJDialog
      该类实现 JDialog类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Dialog.ModalExclusionType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Dialog.ModalExclusionType

  • Packages that use Dialog.ModalExclusionType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Dialog.ModalExclusionType in java.awt

      Methods in java.awt that return Dialog.ModalExclusionType
      Modifier and Type 方法 描述
      Dialog.ModalExclusionType Window.getModalExclusionType​()
      返回此窗口的模态排除类型。
      static Dialog.ModalExclusionType Dialog.ModalExclusionType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Dialog.ModalExclusionType[] Dialog.ModalExclusionType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type Dialog.ModalExclusionType
      Modifier and Type 方法 描述
      abstract boolean Toolkit.isModalExclusionTypeSupported​(Dialog.ModalExclusionType modalExclusionType)
      返回此工具包是否支持给定的模式排除类型。
      void Window.setModalExclusionType​(Dialog.ModalExclusionType exclusionType)
      指定此窗口的模态排除类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Dialog.ModalityType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Dialog.ModalityType

  • Packages that use Dialog.ModalityType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Dialog.ModalityType in java.awt

      Fields in java.awt declared as Dialog.ModalityType
      Modifier and Type Field 描述
      static Dialog.ModalityType Dialog.DEFAULT_MODALITY_TYPE
      模态对话框的默认模式类型。
      Methods in java.awt that return Dialog.ModalityType
      Modifier and Type 方法 描述
      Dialog.ModalityType Dialog.getModalityType​()
      返回此对话框的模态类型。
      static Dialog.ModalityType Dialog.ModalityType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Dialog.ModalityType[] Dialog.ModalityType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type Dialog.ModalityType
      Modifier and Type 方法 描述
      abstract boolean Toolkit.isModalityTypeSupported​(Dialog.ModalityType modalityType)
      返回此工具包是否支持给定的模态类型。
      void Dialog.setModalityType​(Dialog.ModalityType type)
      设置此对话框的模态类型。
      Constructors in java.awt with parameters of type Dialog.ModalityType
      Constructor 描述
      Dialog​(Window owner, Dialog.ModalityType modalityType)
      构造最初不可见的 Dialog与指定的所有者 Window和模态和一个空的标题。
      Dialog​(Window owner, String title, Dialog.ModalityType modalityType)
      构造一个最初看不见的 Dialog与指定的所有者 Window ，标题和模态。
      Dialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      构造一个最初看不见的 Dialog与指定的所有者 Window ，标题，模式和 GraphicsConfiguration 。

    • Uses of Dialog.ModalityType in javax.swing

      Constructors in javax.swing with parameters of type Dialog.ModalityType
      Constructor 描述
      JDialog​(Window owner, Dialog.ModalityType modalityType)
      创建一个具有空标题和指定模态的 Window ，其中所有者为 Window 。
      JDialog​(Window owner, String title, Dialog.ModalityType modalityType)
      创建一个带有指定标题的对话框，拥有者 Window和模态。
      JDialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      创建一个具有指定标题的对话框，拥有者 Window ，模态和 GraphicsConfiguration 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Dimension (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Dimension

  • Packages that use Dimension
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.imageio
    Java Image I / O API的主要包。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Dimension in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Dimension
      Modifier and Type 方法 描述
      Dimension Translator.getSize​()
      返回此对象的当前大小。
      Methods in com.sun.java.accessibility.util with parameters of type Dimension
      Modifier and Type 方法 描述
      void Translator.setSize​(Dimension d)
      设置此对象的当前大小。

    • Uses of Dimension in java.applet

      Methods in java.applet with parameters of type Dimension
      Modifier and Type 方法 描述
      void Applet.resize​(Dimension d)
      已过时。
      请求这个小程序调整大小。

    • Uses of Dimension in java.awt

      Methods in java.awt that return Dimension
      Modifier and Type 方法 描述
      Dimension Toolkit.getBestCursorSize​(int preferredWidth, int preferredHeight)
      返回最接近所需大小的支持的光标维度。
      Dimension Component.getMaximumSize​()
      获取此组件的最大大小。
      Dimension Container.getMaximumSize​()
      返回此容器的最大大小。
      Dimension Component.getMinimumSize​()
      获取此组件的最小大小。
      Dimension Container.getMinimumSize​()
      返回此容器的最小大小。
      Dimension List.getMinimumSize​()
      确定此滚动列表的最小大小。
      Dimension List.getMinimumSize​(int rows)
      获取具有指定行数的列表的最小尺寸。
      Dimension TextArea.getMinimumSize​()
      确定此文本区域的最小大小。
      Dimension TextArea.getMinimumSize​(int rows, int columns)
      确定具有指定行数和列数的文本区域的最小大小。
      Dimension TextField.getMinimumSize​()
      获取此文本字段的最小尺寸。
      Dimension TextField.getMinimumSize​(int columns)
      获取具有指定列数的文本字段的最小尺寸。
      protected Dimension GridBagLayout.getMinSize​(Container parent, GridBagLayoutInfo info)
      根据 getLayoutInfo的信息， getLayoutInfo出主机的最小尺寸。
      protected Dimension GridBagLayout.GetMinSize​(Container parent, GridBagLayoutInfo info)
      此方法已过时，仅供后向兼容; 新代码应该调用getMinSize 。
      abstract Dimension PrintJob.getPageDimension​()
      以像素为单位返回页面的尺寸。
      Dimension Component.getPreferredSize​()
      获取此组件的首选大小。
      Dimension Container.getPreferredSize​()
      返回此容器的首选大小。
      Dimension List.getPreferredSize​()
      获取此滚动列表的首选大小。
      Dimension List.getPreferredSize​(int rows)
      获取具有指定行数的列表的首选尺寸。
      Dimension TextArea.getPreferredSize​()
      确定此文本区域的首选大小。
      Dimension TextArea.getPreferredSize​(int rows, int columns)
      确定具有指定行数和列数的文本区域的首选大小。
      Dimension TextField.getPreferredSize​()
      获取此文本字段的首选大小。
      Dimension TextField.getPreferredSize​(int columns)
      使用指定的列数获取此文本字段的首选大小。
      abstract Dimension Toolkit.getScreenSize​()
      获取屏幕的大小。
      Dimension Component.AccessibleAWTComponent.getSize​()
      以 Dimension对象的形式返回此对象的大小。
      Dimension Component.getSize​()
      以 Dimension对象的形式返回此组件的大小。
      Dimension Component.getSize​(Dimension rv)
      将该组件的宽度/高度存储到“返回值” rv并返回 rv 。
      Dimension Dimension.getSize​()
      获取此 Dimension对象的大小。
      Dimension List.AccessibleAWTList.AccessibleAWTListChild.getSize​()
      以Dimension对象的形式返回此对象的大小。
      Dimension MenuComponent.AccessibleAWTMenuComponent.getSize​()
      以 Dimension对象的形式返回此对象的大小。
      Dimension Rectangle.getSize​()
      获取 Rectangle的大小，由返回的 Dimension表示。
      Dimension SplashScreen.getSize​()
      以Dimension的形式返回闪屏的大小。
      Dimension TrayIcon.getSize​()
      返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
      Dimension SystemTray.getTrayIconSize​()
      返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
      Dimension ScrollPane.getViewportSize​()
      返回滚动窗格视图端口的当前大小。
      Dimension BorderLayout.maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension CardLayout.maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension GridBagLayout.maximumLayoutSize​(Container target)
      给定指定目标容器中的组件的返回布局的最大尺寸。
      Dimension LayoutManager2.maximumLayoutSize​(Container target)
      给定指定容器的最大尺寸尺寸，给定其包含的组件。
      Dimension BorderLayout.minimumLayoutSize​(Container target)
      使用此布局管理器确定 target容器的最小大小。
      Dimension CardLayout.minimumLayoutSize​(Container parent)
      计算指定面板的最小尺寸。
      Dimension FlowLayout.minimumLayoutSize​(Container target)
      返回布局指定目标容器中包含的 可见组件所需的最小尺寸。
      Dimension GridBagLayout.minimumLayoutSize​(Container parent)
      使用此网格包布局确定 parent容器的最小尺寸。
      Dimension GridLayout.minimumLayoutSize​(Container parent)
      使用此网格布局确定容器参数的最小大小。
      Dimension LayoutManager.minimumLayoutSize​(Container parent)
      计算指定容器的最小尺寸尺寸，给定其包含的组件。
      Dimension Component.minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替换。
      Dimension Container.minimumSize​()
      已过时。
      自JDK 1.1版起，由getMinimumSize()替代。
      Dimension List.minimumSize​()
      已过时。
      自JDK版本1.1起，由getMinimumSize()替代。
      Dimension List.minimumSize​(int rows)
      已过时。
      从JDK 1.1版开始，由getMinimumSize(int)替代。
      Dimension TextArea.minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      Dimension TextArea.minimumSize​(int rows, int columns)
      已过时。
      从JDK 1.1版开始，由getMinimumSize(int, int)替代。
      Dimension TextField.minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      Dimension TextField.minimumSize​(int columns)
      已过时。
      从JDK 1.1版开始，替换为getMinimumSize(int) 。
      Dimension BorderLayout.preferredLayoutSize​(Container target)
      根据容器中的组件确定使用此布局管理器的 target容器的首选大小。
      Dimension CardLayout.preferredLayoutSize​(Container parent)
      使用此卡布局确定容器参数的首选大小。
      Dimension FlowLayout.preferredLayoutSize​(Container target)
      给定指定目标容器中 可见组件的返回值。
      Dimension GridBagLayout.preferredLayoutSize​(Container parent)
      使用此网格包布局确定 parent容器的首选大小。
      Dimension GridLayout.preferredLayoutSize​(Container parent)
      使用此网格布局确定容器参数的首选大小。
      Dimension LayoutManager.preferredLayoutSize​(Container parent)
      计算指定容器的首选大小尺寸，给定其包含的组件。
      Dimension Component.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()代替。
      Dimension Container.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension List.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension List.preferredSize​(int rows)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int)替代。
      Dimension TextArea.preferredSize​()
      已过时。
      从JDK 1.1版开始，替换为getPreferredSize() 。
      Dimension TextArea.preferredSize​(int rows, int columns)
      已过时。
      自JDK 1.1版起，由getPreferredSize(int, int)替代。
      Dimension TextField.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension TextField.preferredSize​(int columns)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int)替代。
      Dimension Component.size​()
      已过时。
      从JDK 1.1版开始，由getSize()替代。
      Methods in java.awt with parameters of type Dimension
      Modifier and Type 方法 描述
      Dimension Component.getSize​(Dimension rv)
      将该组件的宽度/高度存储到“返回值” rv并返回 rv 。
      void Component.resize​(Dimension d)
      已过时。
      截至JDK 1.1版，由setSize(Dimension)取代。
      void Component.setMaximumSize​(Dimension maximumSize)
      将此组件的最大大小设置为常量值。
      void Component.setMinimumSize​(Dimension minimumSize)
      将此组件的最小大小设置为常量值。
      void Window.setMinimumSize​(Dimension minimumSize)
      将此窗口的最小大小设置为常量值。
      void Component.setPreferredSize​(Dimension preferredSize)
      将此组件的首选大小设置为常量值。
      void Component.AccessibleAWTComponent.setSize​(Dimension d)
      调整此对象的大小，使其具有宽度和高度。
      void Component.setSize​(Dimension d)
      调整此组件的大小，使其宽度为 d.width ，高度为 d.height 。
      void Dimension.setSize​(Dimension d)
      将此 Dimension对象的大小设置为指定的大小。
      void List.AccessibleAWTList.AccessibleAWTListChild.setSize​(Dimension d)
      调整此对象的大小，使其具有宽度和高度。
      void MenuComponent.AccessibleAWTMenuComponent.setSize​(Dimension d)
      调整此对象的大小。
      void Rectangle.setSize​(Dimension d)
      设置此 Rectangle的大小以匹配指定的 Dimension 。
      void Window.setSize​(Dimension d)
      调整此组件的大小，使其具有宽度 d.width和高度 d.height 。
      Constructors in java.awt with parameters of type Dimension
      Constructor 描述
      Dimension​(Dimension d)
      创建一个 Dimension的实例，其宽度和高度与指定维度相同。
      Rectangle​(Dimension d)
      构造一个新的 Rectangle其左上角为（0,0），其宽度和高度由 Dimension参数指定。
      Rectangle​(Point p, Dimension d)
      构造一个新的Rectangle其左上角由Point参数指定，其宽度和高度由Dimension参数指定。

    • Uses of Dimension in javafx.embed.swing

      Methods in javafx.embed.swing that return Dimension
      Modifier and Type 方法 描述
      Dimension JFXPanel.getPreferredSize​()
      返回此 JFXPanel的首选大小，先前使用 JComponent.setPreferredSize(Dimension)设置，或根据连接到此 JFXPanel的JavaFX场景的内容。

    • Uses of Dimension in javax.accessibility

      Methods in javax.accessibility that return Dimension
      Modifier and Type 方法 描述
      Dimension AccessibleComponent.getSize​()
      以 Dimension对象的形式返回此对象的大小。
      Methods in javax.accessibility with parameters of type Dimension
      Modifier and Type 方法 描述
      void AccessibleComponent.setSize​(Dimension d)
      调整此对象的大小，使其具有宽度和高度。

    • Uses of Dimension in javax.imageio

      Fields in javax.imageio declared as Dimension
      Modifier and Type Field 描述
      protected Dimension[] ImageWriteParam.preferredTileSizes
      一组优选的瓷砖尺寸范围对。
      protected Dimension ImageReadParam.sourceRenderSize
      所需的渲染宽度和高度，如果 canSetSourceRenderSize是 true或 null 。
      Methods in javax.imageio that return Dimension
      Modifier and Type 方法 描述
      Dimension[] ImageWriter.getPreferredThumbnailSizes​(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata)
      返回 Dimension的数组，表示缩略图的合法大小范围，因为它们将被编码在输出文件或流中。
      Dimension[] ImageWriteParam.getPreferredTileSizes​()
      返回一个 Dimension s的数组，表示瓦片的合法尺寸范围，因为它们将被编码在输出文件或流中。
      Dimension ImageReadParam.getSourceRenderSize​()
      如果它们是通过 setSourceRenderSize方法设置的，则返回源映像在解码过程中渲染的宽度和高度。
      Methods in javax.imageio with parameters of type Dimension
      Modifier and Type 方法 描述
      void ImageReadParam.setSourceRenderSize​(Dimension size)
      如果图像能够以任意大小呈现，请将源宽度和高度设置为提供的值。

    • Uses of Dimension in javax.swing

      Fields in javax.swing declared as Dimension
      Modifier and Type Field 描述
      protected Dimension JTable.preferredViewportSize
      由 Scrollable界面用于确定初始可见区域。
      Methods in javax.swing that return Dimension
      Modifier and Type | 方法 | 描述
      Dimension UIDefaults.getDimension​(Object key)
      如果 key的值是 Dimension返回，否则返回 null 。
      Dimension UIDefaults.getDimension​(Object key, Locale l)
      如果值 key对于给定 Locale是 Dimension返回它，否则返回 null 。
      static Dimension UIManager.getDimension​(Object key)
      从默认值返回维度。
      static Dimension UIManager.getDimension​(Object key, Locale l)
      从适用于给定语言环境的默认值返回维度。
      Dimension RepaintManager.getDoubleBufferMaximumSize​()
      返回最大双缓冲区大小。
      Dimension JViewport.getExtentSize​()
      返回视图坐标中视图的可见部分的大小。
      Dimension JTable.getIntercellSpacing​()
      返回单元格之间的水平和垂直空间。
      Dimension JComponent.getMaximumSize​()
      如果最大大小已设置为非 null ，则返回值。
      Dimension JScrollBar.getMaximumSize​()
      滚动条沿其滚动轴线是柔性的，并且沿着另一个轴线是刚性的。
      Dimension JToolBar.Separator.getMaximumSize​()
      返回分隔符的最大大小。
      Dimension JComponent.getMinimumSize​()
      如果最小尺寸设置为非 null ，则返回值。
      Dimension JScrollBar.getMinimumSize​()
      滚动条沿其滚动轴线是柔性的，并且沿着另一个轴线是刚性的。
      Dimension JToolBar.Separator.getMinimumSize​()
      返回分隔符的最小大小。
      Dimension JLayer.getPreferredScrollableViewportSize​()
      返回视图组件的视口的首选大小。
      Dimension JList.getPreferredScrollableViewportSize​()
      计算显示 visibleRowCount行所需的视口大小。
      Dimension JTable.getPreferredScrollableViewportSize​()
      返回此表的视口的首选大小。
      Dimension JTextArea.getPreferredScrollableViewportSize​()
      如果此组件嵌入在JScrollPane中，则返回视口的首选大小。
      Dimension JTree.getPreferredScrollableViewportSize​()
      返回 JTree的首选显示大小。
      Dimension Scrollable.getPreferredScrollableViewportSize​()
      返回视图组件的视口的首选大小。
      Dimension JComponent.getPreferredSize​()
      如果 preferredSize已被设置为非 null值，则返回值。
      Dimension JEditorPane.getPreferredSize​()
      返回 JEditorPane的首选大小。
      Dimension JTextArea.getPreferredSize​()
      返回TextArea的首选大小。
      Dimension JTextField.getPreferredSize​()
      返回 Dimensions所需的首选大小 TextField 。
      Dimension JToolBar.Separator.getPreferredSize​()
      返回分隔符的首选大小。
      Dimension JToolBar.Separator.getSeparatorSize​()
      返回分隔符的大小
      Dimension JComponent.getSize​(Dimension rv)
      将此组件的宽度/高度存储为“返回值” rv并返回 rv 。
      Dimension | JList.AccessibleJList.AccessibleJListChild.getSize​()
      Dimension | JTable.AccessibleJTable.AccessibleJTableCell.getSize​()
      Dimension | JTree.AccessibleJTree.AccessibleJTreeNode.getSize​()
      Dimension JViewport.getViewSize​()
      如果视图的大小尚未被明确设置，返回首选大小，否则返回视图的当前大小。
      Dimension BoxLayout.maximumLayoutSize​(Container target)
      返回目标容器可用于布局其包含的组件的最大尺寸。
      Dimension GroupLayout.maximumLayoutSize​(Container parent)
      返回指定容器的最大大小。
      Dimension JRootPane.RootLayout.maximumLayoutSize​(Container target)
      返回布局可以使用的最大空间量。
      Dimension OverlayLayout.maximumLayoutSize​(Container target)
      返回布局包含在指定目标容器中的组件所需的最大尺寸。
      Dimension | SpringLayout.maximumLayoutSize​(Container parent)
      Dimension BoxLayout.minimumLayoutSize​(Container target)
      返回布局包含在指定目标容器中的组件所需的最小尺寸。
      Dimension GroupLayout.minimumLayoutSize​(Container parent)
      返回指定容器的最小大小。
      Dimension JRootPane.RootLayout.minimumLayoutSize​(Container parent)
      返回布局所需的最小空间量。
      Dimension JSpinner.DefaultEditor.minimumLayoutSize​(Container parent)
      返回第一个（且仅））小孩的最小大小加上父母插入的大小。
      Dimension OverlayLayout.minimumLayoutSize​(Container target)
      返回布局包含在指定目标容器中的组件所需的最小尺寸。
      Dimension ScrollPaneLayout.minimumLayoutSize​(Container parent)
      ScrollPane的最小大小是 ScrollPane的大小加上视口的最小大小，加上滚动窗口的viewportBorder插入，加上可见标题的最小大小，加上displayPolicy不是永远不会的滚动条的最小大小。
      Dimension | SpringLayout.minimumLayoutSize​(Container parent)
      Dimension ViewportLayout.minimumLayoutSize​(Container parent)
      返回布局指定目标容器中包含的组件所需的最小尺寸。
      Dimension BoxLayout.preferredLayoutSize​(Container target)
      给定指定目标容器中的组件，返回此布局的首选尺寸。
      Dimension GroupLayout.preferredLayoutSize​(Container parent)
      返回指定容器的首选大小。
      Dimension JRootPane.RootLayout.preferredLayoutSize​(Container parent)
      返回布局想要的空间量。
      Dimension JSpinner.DefaultEditor.preferredLayoutSize​(Container parent)
      返回首个（而且仅）子项的首选大小加上父母插入的大小。
      Dimension OverlayLayout.preferredLayoutSize​(Container target)
      给定指定目标容器中的组件，返回此布局的首选尺寸。
      Dimension ScrollPaneLayout.preferredLayoutSize​(Container parent)
      ScrollPane的首选大小是插图的大小，加上视口的首选大小，加上可见标题的首选大小，加上当前视图和当前滚动条displayPolicies将显示的滚动条的首选大小。
      Dimension | SpringLayout.preferredLayoutSize​(Container parent)
      Dimension ViewportLayout.preferredLayoutSize​(Container parent)
      给定指定目标容器中的组件，返回此布局的首选尺寸。
      Dimension JViewport.toViewCoordinates​(Dimension size)
      转换像素坐标中的大小以查看坐标。
      Methods in javax.swing with parameters of type Dimension
      Modifier and Type | 方法 | 描述
      void JToolBar.addSeparator​(Dimension size)
      将指定大小的分隔符追加到工具栏的末尾。
      void Box.Filler.changeShape​(Dimension min, Dimension pref, Dimension max)
      更改此形状的大小请求。
      protected boolean JViewport.computeBlit​(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
      计算一个blit的参数，其中后备存储图像当前包含 oldLoc在左上角，我们正在滚动到 newLoc 。
      static Component Box.createRigidArea​(Dimension d)
      创建一个总是指定大小的不可见组件。
      Dimension JComponent.getSize​(Dimension rv)
      将此组件的宽度/高度存储为“返回值” rv并返回 rv 。
      void RepaintManager.setDoubleBufferMaximumSize​(Dimension d)
      设置最大双缓冲区大小。
      void JViewport.setExtentSize​(Dimension newExtent)
      使用视图坐标设置视图的可见部分的大小。
      void JTable.setIntercellSpacing​(Dimension intercellSpacing)
      设置 rowMargin和 columnMargin （单元格之间的空间的高度和宽度）为 intercellSpacing 。
      void JComponent.setMaximumSize​(Dimension maximumSize)
      将此组件的最大大小设置为常量值。
      void JComponent.setMinimumSize​(Dimension minimumSize)
      将此组件的最小大小设置为常量值。
      void JPopupMenu.setPopupSize​(Dimension d)
      使用 Dimension对象设置弹出窗口的大小。
      void JTable.setPreferredScrollableViewportSize​(Dimension size)
      设置此表的视口的首选大小。
      void JComponent.setPreferredSize​(Dimension preferredSize)
      设置此组件的首选大小。
      void JToolBar.Separator.setSeparatorSize​(Dimension size)
      设置分隔符的大小。
      void | JList.AccessibleJList.AccessibleJListChild.setSize​(Dimension d)
      void | JTable.AccessibleJTable.AccessibleJTableCell.setSize​(Dimension d)
      void | JTree.AccessibleJTree.AccessibleJTreeNode.setSize​(Dimension d)
      void JViewport.setViewSize​(Dimension newSize)
      设置视图的大小。
      Dimension JViewport.toViewCoordinates​(Dimension size)
      转换像素坐标中的大小以查看坐标。
      Constructors in javax.swing with parameters of type Dimension
      Constructor 描述
      Filler​(Dimension min, Dimension pref, Dimension max)
      创建具有给定大小范围的形状的构造函数。
      Separator​(Dimension size)
      创建一个具有指定大小的新工具栏分隔符。

    • Uses of Dimension in javax.swing.border

      Methods in javax.swing.border that return Dimension
      Modifier and Type 方法 描述
      Dimension TitledBorder.getMinimumSize​(Component c)
      返回边框所需的最小尺寸，以便完全显示边框和标题。

    • Uses of Dimension in javax.swing.plaf

      Subclasses of Dimension in javax.swing.plaf
      Modifier and Type Class 描述
      class  DimensionUIResource
      Dimension的子类实现 UIResource 。
      Methods in javax.swing.plaf that return Dimension
      Modifier and Type 方法 描述
      Dimension ComponentUI.getMaximumSize​(JComponent c)
      返回指定组件的最大尺寸，适合外观和感觉。
      Dimension LayerUI.getMaximumSize​(JComponent c)
      如果 JLayer的视图组件不是 null ，则返回视图 getMaximumSize()方法的结果。
      Dimension ComponentUI.getMinimumSize​(JComponent c)
      返回指定组件的最小尺寸，适合外观和感觉。
      Dimension LayerUI.getMinimumSize​(JComponent c)
      如果 JLayer的视图组件不是 null ，则返回视图 getMinimalSize()方法的结果。
      Dimension ComponentUI.getPreferredSize​(JComponent c)
      返回指定组件的偏好大小，适合外观和感觉。
      Dimension LayerUI.getPreferredSize​(JComponent c)
      如果 JLayer的视图组件不是 null ，则返回视图的 getPreferredSize()方法的结果。

    • Uses of Dimension in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Dimension
      Modifier and Type Field 描述
      protected Dimension BasicComboBoxUI.cachedMinimumSize
      缓存的最小首选大小。
      protected Dimension BasicScrollBarUI.maximumThumbSize
      最大拇指大小
      protected Dimension BasicOptionPaneUI.minimumSize
      大小 JOptionPane 。
      protected Dimension BasicScrollBarUI.minimumThumbSize
      最小拇指尺寸
      protected Dimension BasicTreeUI.preferredMinSize
      最小尺寸。
      protected Dimension BasicTreeUI.preferredSize
      完全显示所有节点所需的大小。
      Methods in javax.swing.plaf.basic that return Dimension
      Modifier and Type | 方法 | 描述
      protected Dimension BasicTabbedPaneUI.TabbedPaneLayout.calculateSize​(boolean minimum)
      返回计算的大小。
      protected Dimension BasicComboBoxUI.getDefaultSize​()
      使用当前渲染器和字体返回组合框的空显示区域的默认大小。
      protected Dimension BasicComboBoxUI.getDisplaySize​()
      返回显示区域的计算大小。
      Dimension BasicArrowButton.getMaximumSize​()
      返回 BasicArrowButton的最大大小。
      Dimension | BasicButtonUI.getMaximumSize​(JComponent c)
      Dimension | BasicComboBoxUI.getMaximumSize​(JComponent c)
      Dimension BasicDesktopIconUI.getMaximumSize​(JComponent c)
      桌面图标无法调整大小。
      Dimension | BasicDesktopPaneUI.getMaximumSize​(JComponent c)
      Dimension BasicInternalFrameUI.getMaximumSize​(JComponent x)
      返回最大大小。
      Dimension | BasicLabelUI.getMaximumSize​(JComponent c)
      Dimension | BasicMenuBarUI.getMaximumSize​(JComponent c)
      Dimension | BasicMenuItemUI.getMaximumSize​(JComponent c)
      Dimension | BasicMenuUI.getMaximumSize​(JComponent c)
      Dimension | BasicProgressBarUI.getMaximumSize​(JComponent c)
      Dimension | BasicScrollBarUI.getMaximumSize​(JComponent c)
      Dimension | BasicScrollPaneUI.getMaximumSize​(JComponent c)
      Dimension | BasicSeparatorUI.getMaximumSize​(JComponent c)
      Dimension BasicSliderUI.getMaximumSize​(JComponent c)
      返回最大大小。
      Dimension BasicSplitPaneUI.getMaximumSize​(JComponent jc)
      返回传入的组件的最大大小，这被传递给当前的布局管理器。
      Dimension | BasicTabbedPaneUI.getMaximumSize​(JComponent c)
      Dimension BasicTableHeaderUI.getMaximumSize​(JComponent c)
      返回标题的最大大小。
      Dimension BasicTableUI.getMaximumSize​(JComponent c)
      返回表的最大大小。
      Dimension BasicTextUI.getMaximumSize​(JComponent c)
      获取编辑器组件的最大大小。
      Dimension | BasicToolTipUI.getMaximumSize​(JComponent c)
      Dimension BasicTreeUI.getMaximumSize​(JComponent c)
      返回此组件的最大大小，如果实例当前处于JTree或0,0，则该大小将是首选大小。
      protected Dimension BasicScrollBarUI.getMaximumThumbSize​()
      返回拇指的最大可接受尺寸。
      Dimension BasicSliderUI.getMinimumHorizontalSize​()
      返回最小水平尺寸。
      Dimension BasicOptionPaneUI.getMinimumOptionPaneSize​()
      返回选项窗格应该是最小的大小。
      Dimension BasicArrowButton.getMinimumSize​()
      返回 BasicArrowButton的最小大小。
      Dimension | BasicButtonUI.getMinimumSize​(JComponent c)
      Dimension BasicComboBoxUI.getMinimumSize​(JComponent c)
      最小尺寸是显示区域的大小加上插页加上按钮。
      Dimension | BasicDesktopIconUI.getMinimumSize​(JComponent c)
      Dimension | BasicDesktopPaneUI.getMinimumSize​(JComponent c)
      Dimension BasicInternalFrameUI.getMinimumSize​(JComponent x)
      返回最小大小。
      Dimension | BasicLabelUI.getMinimumSize​(JComponent c)
      Dimension | BasicMenuBarUI.getMinimumSize​(JComponent c)
      Dimension | BasicMenuItemUI.getMinimumSize​(JComponent c)
      Dimension BasicProgressBarUI.getMinimumSize​(JComponent c)
      该组件的最小大小为10。
      Dimension | BasicSeparatorUI.getMinimumSize​(JComponent c)
      Dimension BasicSliderUI.getMinimumSize​(JComponent c)
      返回最小大小。
      Dimension BasicSplitPaneDivider.getMinimumSize​()
      返回dividerSize x dividerSize
      Dimension BasicSplitPaneUI.getMinimumSize​(JComponent jc)
      返回传入的组件的最小大小，这被传递给当前的布局管理器。
      Dimension | BasicTabbedPaneUI.getMinimumSize​(JComponent c)
      Dimension BasicTableHeaderUI.getMinimumSize​(JComponent c)
      返回标题的最小大小。
      Dimension BasicTableUI.getMinimumSize​(JComponent c)
      返回表的最小大小。
      Dimension BasicTextAreaUI.getMinimumSize​(JComponent c)
      该方法被覆盖以考虑插入符宽度。
      Dimension BasicTextUI.getMinimumSize​(JComponent c)
      获取编辑器组件的最小大小。
      Dimension | BasicToolTipUI.getMinimumSize​(JComponent c)
      Dimension BasicTreeUI.getMinimumSize​(JComponent c)
      返回此组件的最小大小。
      protected Dimension BasicScrollBarUI.getMinimumThumbSize​()
      返回拇指的最小可接受尺寸。
      Dimension BasicSliderUI.getMinimumVerticalSize​()
      返回最小垂直尺寸。
      static Dimension BasicGraphicsUtils.getPreferredButtonSize​(AbstractButton b, int textIconGap)
      返回按钮的首选大小。
      Dimension BasicSliderUI.getPreferredHorizontalSize​()
      返回首选的水平尺寸。
      protected Dimension BasicProgressBarUI.getPreferredInnerHorizontal​()
      返回水平的首选大小 JProgressBar 。
      protected Dimension BasicProgressBarUI.getPreferredInnerVertical​()
      返回首选的垂直尺寸 JProgressBar 。
      protected Dimension BasicMenuItemUI.getPreferredMenuItemSize​(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      返回菜单项的首选大小。
      Dimension BasicTreeUI.getPreferredMinSize​()
      返回最小首选大小。
      Dimension BasicArrowButton.getPreferredSize​()
      返回 BasicArrowButton的首选大小。
      Dimension | BasicButtonUI.getPreferredSize​(JComponent c)
      Dimension | BasicComboBoxRenderer.getPreferredSize​()
      Dimension | BasicComboBoxUI.getPreferredSize​(JComponent c)
      Dimension | BasicDesktopIconUI.getPreferredSize​(JComponent c)
      Dimension | BasicDesktopPaneUI.getPreferredSize​(JComponent c)
      Dimension BasicInternalFrameUI.getPreferredSize​(JComponent x)
      返回首选大小。
      Dimension | BasicLabelUI.getPreferredSize​(JComponent c)
      Dimension BasicListUI.getPreferredSize​(JComponent c)
      列表的preferredSize取决于布局方向。
      Dimension | BasicMenuItemUI.getPreferredSize​(JComponent c)
      Dimension BasicOptionPaneUI.getPreferredSize​(JComponent c)
      如果 c是 JOptionPane的接收器，则返回的首选大小是 LayoutManager的 JOptionPane和 getMinimumOptionPaneSize的首选大小的 getMinimumOptionPaneSize 。
      Dimension | BasicPopupMenuSeparatorUI.getPreferredSize​(JComponent c)
      Dimension | BasicProgressBarUI.getPreferredSize​(JComponent c)
      Dimension BasicRadioButtonUI.getPreferredSize​(JComponent c)
      单选按钮的首选大小
      Dimension BasicScrollBarUI.getPreferredSize​(JComponent c)
      垂直滚动条的首选宽度是（非 null ）递增/递减按钮的最大宽度和拇指的最小宽度的最大值。
      Dimension | BasicSeparatorUI.getPreferredSize​(JComponent c)
      Dimension BasicSliderUI.getPreferredSize​(JComponent c)
      返回首选大小。
      Dimension BasicSplitPaneDivider.getPreferredSize​()
      返回dividerSize x dividerSize
      Dimension BasicSplitPaneUI.getPreferredSize​(JComponent jc)
      返回传入的组件的首选大小，这被传递给当前的布局管理器。
      Dimension BasicTableHeaderUI.getPreferredSize​(JComponent c)
      返回标题的首选大小。
      Dimension BasicTableUI.getPreferredSize​(JComponent c)
      返回表的首选大小。
      Dimension BasicTextAreaUI.getPreferredSize​(JComponent c)
      该方法被覆盖以考虑插入符宽度。
      Dimension BasicTextUI.getPreferredSize​(JComponent c)
      获取编辑器组件的首选大小。
      Dimension | BasicToolBarSeparatorUI.getPreferredSize​(JComponent c)
      Dimension | BasicToolTipUI.getPreferredSize​(JComponent c)
      Dimension BasicTreeUI.getPreferredSize​(JComponent c)
      返回首选大小以正确显示树，这是一个覆盖方法 getPreferredSize(c, true) 。
      Dimension BasicTreeUI.getPreferredSize​(JComponent c, boolean checkConsistency)
      返回在 c中表示树的首选大小。
      Dimension BasicSliderUI.getPreferredVerticalSize​()
      返回首选的垂直尺寸。
      protected Dimension BasicComboBoxUI.getSizeForComponent​(Component comp)
      如果用作单元格渲染器，则返回组件将具有的大小。
      protected Dimension BasicSliderUI.getThumbSize​()
      返回拇指大小。
      Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.maximumLayoutSize​(Container target)
      返回两个方向的最大布局大小，即Integer.MAX_VALUE。
      Dimension | BasicComboBoxUI.ComboBoxLayoutManager.minimumLayoutSize​(Container parent)
      Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.minimumLayoutSize​(Container c)
      Dimension BasicInternalFrameUI.InternalFrameLayout.minimumLayoutSize​(Container c)
      计算指定容器的最小尺寸尺寸，给定其包含的组件。
      Dimension | BasicOptionPaneUI.ButtonAreaLayout.minimumLayoutSize​(Container c)
      Dimension | BasicScrollBarUI.minimumLayoutSize​(Container scrollbarContainer)
      Dimension | BasicSplitPaneDivider.DividerLayout.minimumLayoutSize​(Container c)
      Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.minimumLayoutSize​(Container container)
      返回包含子项所需的最小大小。
      Dimension | BasicTabbedPaneUI.TabbedPaneLayout.minimumLayoutSize​(Container parent)
      Dimension | BasicComboBoxUI.ComboBoxLayoutManager.preferredLayoutSize​(Container parent)
      Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.preferredLayoutSize​(Container c)
      Dimension BasicInternalFrameUI.InternalFrameLayout.preferredLayoutSize​(Container c)
      计算指定容器的首选大小尺寸，给定其包含的组件。
      Dimension | BasicOptionPaneUI.ButtonAreaLayout.preferredLayoutSize​(Container c)
      Dimension | BasicScrollBarUI.preferredLayoutSize​(Container scrollbarContainer)
      Dimension | BasicSplitPaneDivider.DividerLayout.preferredLayoutSize​(Container c)
      Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.preferredLayoutSize​(Container container)
      返回包含子项所需的首选大小。
      Dimension | BasicTabbedPaneUI.TabbedPaneLayout.preferredLayoutSize​(Container parent)
      Dimension | DefaultMenuLayout.preferredLayoutSize​(Container target)
      Methods in javax.swing.plaf.basic with parameters of type Dimension
      Modifier and Type 方法 描述
      protected int BasicSplitPaneUI.BasicHorizontalLayoutManager.getAvailableSize​(Dimension containerSize, Insets insets)
      根据容器大小和 Insets返回可用宽度。
      protected void BasicRadioButtonUI.paintFocus​(Graphics g, Rectangle textRect, Dimension size)
      油漆聚焦单选按钮。
      protected void BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize​(Component c, int size, int location, Insets insets, Dimension containerSize)
      将组件 c的宽度设置为 size ，将其x位置放置在 location ，y到 insets.top ，高度为 containerSize.height减去顶部和底部插入。
      void BasicTreeUI.setPreferredMinSize​(Dimension newSize)
      设置首选的最小尺寸。

    • Uses of Dimension in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return Dimension
      Modifier and Type | 方法 | 描述
      Dimension | MetalDesktopIconUI.getMaximumSize​(JComponent c)
      Dimension MetalFileChooserUI.getMaximumSize​(JComponent c)
      返回 JFileChooser的最大大小。
      Dimension | MetalScrollButton.getMaximumSize​()
      Dimension | MetalComboBoxButton.getMinimumSize​()
      Dimension | MetalComboBoxUI.getMinimumSize​(JComponent c)
      Dimension | MetalDesktopIconUI.getMinimumSize​(JComponent c)
      Dimension MetalFileChooserUI.getMinimumSize​(JComponent c)
      返回 JFileChooser的最小大小。
      Dimension | MetalScrollButton.getMinimumSize​()
      protected Dimension | MetalScrollBarUI.getMinimumThumbSize​()
      Dimension | MetalDesktopIconUI.getPreferredSize​(JComponent c)
      Dimension MetalFileChooserUI.getPreferredSize​(JComponent c)
      返回指定的首选大小 JFileChooser 。
      Dimension | MetalPopupMenuSeparatorUI.getPreferredSize​(JComponent c)
      Dimension | MetalScrollBarUI.getPreferredSize​(JComponent c)
      Dimension | MetalScrollButton.getPreferredSize​()
      Dimension | MetalSeparatorUI.getPreferredSize​(JComponent c)
      Dimension | MetalToolTipUI.getPreferredSize​(JComponent c)
      protected Dimension | MetalSliderUI.getThumbSize​()
      Methods in javax.swing.plaf.metal with parameters of type Dimension
      Modifier and Type | 方法 | 描述
      protected void | MetalRadioButtonUI.paintFocus​(Graphics g, Rectangle t, Dimension d)

    • Uses of Dimension in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return Dimension
      Modifier and Type 方法 描述
      Dimension MultiButtonUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiColorChooserUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiComboBoxUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiDesktopIconUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiDesktopPaneUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiFileChooserUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiInternalFrameUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiLabelUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiListUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiMenuBarUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiMenuItemUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiOptionPaneUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiPanelUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiPopupMenuUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiProgressBarUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiRootPaneUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiScrollBarUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiScrollPaneUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiSeparatorUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiSliderUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiSpinnerUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiSplitPaneUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiTabbedPaneUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiTableHeaderUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiTableUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiTextUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiToolBarUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiToolTipUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiTreeUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiViewportUI.getMaximumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMaximumSize方法。
      Dimension MultiButtonUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiColorChooserUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiComboBoxUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiDesktopIconUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiDesktopPaneUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiFileChooserUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiInternalFrameUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiLabelUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiListUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiMenuBarUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiMenuItemUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiOptionPaneUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiPanelUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiPopupMenuUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiProgressBarUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiRootPaneUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiScrollBarUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiScrollPaneUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiSeparatorUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiSliderUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiSpinnerUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiSplitPaneUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiTabbedPaneUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiTableHeaderUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiTableUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiTextUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiToolBarUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiToolTipUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiTreeUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiViewportUI.getMinimumSize​(JComponent a)
      在此对象处理的每个UI上调用 getMinimumSize方法。
      Dimension MultiButtonUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiColorChooserUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiComboBoxUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiDesktopIconUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiDesktopPaneUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiFileChooserUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiInternalFrameUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiLabelUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiListUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiMenuBarUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiMenuItemUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiOptionPaneUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiPanelUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiPopupMenuUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiProgressBarUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiRootPaneUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiScrollBarUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiScrollPaneUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiSeparatorUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiSliderUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiSpinnerUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiSplitPaneUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiTabbedPaneUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiTableHeaderUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiTableUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiTextUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiToolBarUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiToolTipUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiTreeUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。
      Dimension MultiViewportUI.getPreferredSize​(JComponent a)
      在此对象处理的每个UI上调用 getPreferredSize方法。

    • Uses of Dimension in javax.swing.plaf.nimbus

      Constructors in javax.swing.plaf.nimbus with parameters of type Dimension
      Constructor 描述
      PaintContext​(Insets insets, Dimension canvasSize, boolean inverted)
      创建一个新的PaintContext，它不会尝试缓存或缩放任何缓存的图像。
      PaintContext​(Insets insets, Dimension canvasSize, boolean inverted, AbstractRegionPainter.PaintContext.CacheMode cacheMode, double maxH, double maxV)
      创建一个新的PaintContext。

    • Uses of Dimension in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Dimension
      Modifier and Type 方法 描述
      protected Dimension SynthComboBoxUI.getDefaultSize​()
      使用当前渲染器和字体返回组合框的空显示区域的默认大小。
      Dimension SynthButtonUI.getMaximumSize​(JComponent c)
      返回指定组件的最大尺寸，适合外观和感觉。
      Dimension SynthGraphicsUtils.getMaximumSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      返回正确呈现图标和文本所需的最大大小。
      Dimension SynthLabelUI.getMaximumSize​(JComponent c)
      返回指定组件的最大尺寸，适合外观和感觉。
      Dimension SynthSeparatorUI.getMaximumSize​(JComponent c)
      返回指定组件的最大尺寸，适合外观和感觉。
      Dimension SynthButtonUI.getMinimumSize​(JComponent c)
      返回指定组件的最小尺寸，适合外观和感觉。
      Dimension SynthGraphicsUtils.getMinimumSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      返回正确呈现图标和文本所需的最小尺寸。
      Dimension SynthLabelUI.getMinimumSize​(JComponent c)
      返回指定组件的最小尺寸，适合外观和感觉。
      Dimension SynthSeparatorUI.getMinimumSize​(JComponent c)
      返回指定组件的最小尺寸，适合外观和感觉。
      Dimension SynthSliderUI.getMinimumSize​(JComponent c)
      返回最小大小。
      protected Dimension SynthScrollBarUI.getMinimumThumbSize​()
      返回拇指的最小可接受尺寸。
      protected Dimension SynthMenuItemUI.getPreferredMenuItemSize​(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      返回菜单项的首选大小。
      protected Dimension SynthMenuUI.getPreferredMenuItemSize​(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      返回菜单项的首选大小。
      Dimension SynthButtonUI.getPreferredSize​(JComponent c)
      返回指定组件的偏好大小，适合外观和感觉。
      Dimension SynthGraphicsUtils.getPreferredSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      返回正确呈现图标和文字所需的首选大小。
      Dimension SynthLabelUI.getPreferredSize​(JComponent c)
      返回指定组件的偏好大小，适合外观和感觉。
      Dimension SynthProgressBarUI.getPreferredSize​(JComponent c)
      返回指定组件的偏好大小，适合外观和感觉。
      Dimension SynthScrollBarUI.getPreferredSize​(JComponent c)
      垂直滚动条的首选宽度是（非 null ）增量/减量按钮的最大宽度和拇指的最小宽度的最大值。
      Dimension SynthSeparatorUI.getPreferredSize​(JComponent c)
      返回指定组件的偏好大小，适合外观和感觉。
      Dimension SynthSliderUI.getPreferredSize​(JComponent c)
      返回首选大小。
      Dimension SynthToolTipUI.getPreferredSize​(JComponent c)
      返回指定组件的偏好大小，适合外观和感觉。
      protected Dimension SynthSliderUI.getThumbSize​()
      返回拇指大小。

    • Uses of Dimension in javax.swing.table

      Methods in javax.swing.table that return Dimension
      Modifier and Type | 方法 | 描述
      Dimension JTableHeader.getPreferredSize​()
      返回表头的首选大小。
      Dimension | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getSize​()
      Methods in javax.swing.table with parameters of type Dimension
      Modifier and Type | 方法 | 描述
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setSize​(Dimension d)

    • Uses of Dimension in javax.swing.text

      Methods in javax.swing.text that return Dimension
      Modifier and Type 方法 描述
      Dimension JTextComponent.getPreferredScrollableViewportSize​()
      返回视图组件的视口的首选大小。

    • Uses of Dimension in javax.swing.tree

      Methods in javax.swing.tree that return Dimension
      Modifier and Type 方法 描述
      Dimension DefaultTreeCellEditor.DefaultTextField.getPreferredSize​()
      覆盖 JTextField.getPreferredSize以返回基于当前字体的首选大小，如果设置，或者使用渲染器的字体。
      Dimension DefaultTreeCellEditor.EditorContainer.getPreferredSize​()
      返回 Container的首选大小。
      Dimension DefaultTreeCellRenderer.getPreferredSize​()
      覆盖 JComponent.getPreferredSize以返回稍宽的首选大小值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.DisplayMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.DisplayMode

  • Packages that use DisplayMode
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of DisplayMode in java.awt

      Methods in java.awt that return DisplayMode
      Modifier and Type 方法 描述
      DisplayMode GraphicsDevice.getDisplayMode​()
      返回此 GraphicsDevice的当前显示模式。
      DisplayMode[] GraphicsDevice.getDisplayModes​()
      返回此 GraphicsDevice可用的所有显示模式。
      Methods in java.awt with parameters of type DisplayMode
      Modifier and Type 方法 描述
      boolean DisplayMode.equals​(DisplayMode dm)
      返回两种显示模式是否相等。
      void GraphicsDevice.setDisplayMode​(DisplayMode dm)
      设置此图形设备的显示模式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Event

  • Packages that use Event
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Event in java.awt

      Fields in java.awt declared as Event
      Modifier and Type Field 描述
      Event Event.evt
      已过时。
      下一个事件。
      Methods in java.awt with parameters of type Event
      Modifier and Type 方法 描述
      boolean Component.action​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，应该在组件上注册此组件作为ActionListener，该组件将触发动作事件。
      void Component.deliverEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代。
      void Container.deliverEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代
      boolean Component.gotFocus​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
      boolean Component.handleEvent​(Event evt)
      已过时。
      从JDK版本1.1替换为processEvent（AWTEvent）。
      boolean Component.keyDown​(Event evt, int key)
      已过时。
      从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
      boolean Component.keyUp​(Event evt, int key)
      已过时。
      从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
      boolean Component.lostFocus​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
      boolean Component.mouseDown​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean Component.mouseDrag​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
      boolean Component.mouseEnter​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean Component.mouseExit​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean Component.mouseMove​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
      boolean Component.mouseUp​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean Component.postEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent（AWTEvent）替换。
      boolean MenuComponent.postEvent​(Event evt)
      已过时。
      从JDK 1.1版开始，由dispatchEvent替代。
      boolean MenuContainer.postEvent​(Event evt)
      已过时。
      由JDK版本1.1替换为dispatchEvent（AWTEvent）。
      boolean Window.postEvent​(Event e)
      已过时。
      由JDK版本1.1替换为dispatchEvent(AWTEvent) 。
      Constructors in java.awt with parameters of type Event
      Constructor 描述
      AWTEvent​(Event event)
      已过时。
      建议使用AWTEvent(Object, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.EventQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.EventQueue

  • Packages that use EventQueue
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of EventQueue in java.awt

      Methods in java.awt that return EventQueue
      Modifier and Type 方法 描述
      EventQueue Toolkit.getSystemEventQueue​()
      获取应用程序或小程序的EventQueue实例。
      protected abstract EventQueue Toolkit.getSystemEventQueueImpl​()
      获取应用程序或小程序的 EventQueue实例，而无需检查访问。
      Methods in java.awt with parameters of type EventQueue
      Modifier and Type 方法 描述
      void EventQueue.push​(EventQueue newEventQueue)
      用指定的替换现有的 EventQueue 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.FileDialog (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.FileDialog

No usage of java.awt.FileDialog
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.FlowLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.FlowLayout

No usage of java.awt.FlowLayout
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.FocusTraversalPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.FocusTraversalPolicy

  • Packages that use FocusTraversalPolicy
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of FocusTraversalPolicy in java.awt

      Subclasses of FocusTraversalPolicy in java.awt
      Modifier and Type Class 描述
      class  ContainerOrderFocusTraversalPolicy
      FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
      class  DefaultFocusTraversalPolicy
      FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
      Methods in java.awt that return FocusTraversalPolicy
      Modifier and Type 方法 描述
      FocusTraversalPolicy KeyboardFocusManager.getDefaultFocusTraversalPolicy​()
      返回默认的FocusTraversalPolicy。
      FocusTraversalPolicy Container.getFocusTraversalPolicy​()
      返回将管理此Container的子项的键盘遍历的焦点遍历策略，如果此Container不是焦点循环根，则返回null。
      Methods in java.awt with parameters of type FocusTraversalPolicy
      Modifier and Type 方法 描述
      void KeyboardFocusManager.setDefaultFocusTraversalPolicy​(FocusTraversalPolicy defaultPolicy)
      设置默认的FocusTraversalPolicy。
      void Container.setFocusTraversalPolicy​(FocusTraversalPolicy policy)
      设置焦点遍历策略，将管理此Container的子项的键盘遍历，如果此Container是焦点循环根。

    • Uses of FocusTraversalPolicy in javax.swing

      Subclasses of FocusTraversalPolicy in javax.swing
      Modifier and Type Class 描述
      class  InternalFrameFocusTraversalPolicy
      FocusTraversalPolicy可以选择提供一种用于确定JInternalFrame初始组件的算法。
      class  LayoutFocusTraversalPolicy
      一个SortingFocusTraversalPolicy，它根据大小，位置和方向对组件进行排序。
      class  SortingFocusTraversalPolicy
      FocusTraversalPolicy通过基于给定的比较器对焦点遍历周期的组件进行排序来确定遍历顺序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Font (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Font

  • Packages that use Font
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Font in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Font
      Modifier and Type 方法 描述
      Font Translator.getFont​()
      获取此对象的 Font 。
      Methods in com.sun.java.accessibility.util with parameters of type Font
      Modifier and Type 方法 描述
      FontMetrics Translator.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      void Translator.setFont​(Font f)
      设置此对象的 Font 。

    • Uses of Font in java.awt

      Fields in java.awt declared as Font
      Modifier and Type Field 描述
      protected Font FontMetrics.font
      创建字体指标的实际Font 。
      Methods in java.awt that return Font
      Modifier and Type 方法 描述
      static Font Font.createFont​(int fontFormat, File fontFile)
      使用指定的字体类型和指定的字体文件返回一个新的 Font 。
      static Font Font.createFont​(int fontFormat, InputStream fontStream)
      使用指定的字体类型和输入数据返回一个新的 Font 。
      static Font[] Font.createFonts​(File fontFile)
      返回从指定文件解码的新数组 Font 。
      static Font[] Font.createFonts​(InputStream fontStream)
      返回从指定流解码的新数组 Font 。
      static Font Font.decode​(String str)
      返回 Font ，该 str参数描述。
      Font Font.deriveFont​(float size)
      通过复制当前的 Font对象并对其应用新的大小来创建一个新的 Font对象。
      Font Font.deriveFont​(int style)
      通过复制当前的 Font对象并应用新的样式来创建一个新的 Font对象。
      Font Font.deriveFont​(int style, float size)
      通过复制这个 Font对象并应用新的样式和大小来创建一个新的 Font对象。
      Font Font.deriveFont​(int style, AffineTransform trans)
      通过复制这个 Font对象并应用新的样式和变换来创建一个新的 Font对象。
      Font Font.deriveFont​(AffineTransform trans)
      通过复制当前的 Font对象并应用一个新的变换来创建一个新的 Font对象。
      Font Font.deriveFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      通过复制当前的 Font对象并应用一组新的字体属性来创建一个新的 Font对象。
      abstract Font[] GraphicsEnvironment.getAllFonts​()
      返回一个包含此 GraphicsEnvironment可用的所有字体的一点大小实例的 GraphicsEnvironment 。
      Font Component.AccessibleAWTComponent.getFont​()
      获取此对象的 Font 。
      Font Component.getFont​()
      获取此组件的字体。
      static Font Font.getFont​(String nm)
      从系统属性列表中返回一个 Font对象。
      static Font Font.getFont​(String nm, Font font)
      从系统属性列表获取指定的 Font 。
      static Font Font.getFont​(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
      返回适合于属性的 Font 。
      Font FontMetrics.getFont​()
      获取 Font通过此描述 FontMetrics对象。
      abstract Font Graphics.getFont​()
      获取当前字体。
      Font List.AccessibleAWTList.AccessibleAWTListChild.getFont​()
      获取此对象的字体。
      Font MenuComponent.AccessibleAWTMenuComponent.getFont​()
      获取此对象的 Font 。
      Font MenuComponent.getFont​()
      获取用于此菜单组件的字体。
      Font MenuContainer.getFont​()
      返回此容器正在使用的字体。
      Methods in java.awt with parameters of type Font
      Modifier and Type 方法 描述
      static Font Font.getFont​(String nm, Font font)
      从系统属性列表获取指定的 Font 。
      FontMetrics Component.AccessibleAWTComponent.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      FontMetrics Component.getFontMetrics​(Font font)
      获取指定字体的字体指标。
      abstract FontMetrics Graphics.getFontMetrics​(Font f)
      获取指定字体的字体指标。
      FontMetrics List.AccessibleAWTList.AccessibleAWTListChild.getFontMetrics​(Font f)
      获取此对象的FontMetrics。
      FontMetrics MenuComponent.AccessibleAWTMenuComponent.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      abstract FontMetrics Toolkit.getFontMetrics​(Font font)
      已过时。
      从JDK版本1.2开始，替换为Font方法getLineMetrics 。
      boolean GraphicsEnvironment.registerFont​(Font font)
      注册一个 创建 Font在这个 GraphicsEnvironment 。
      void Component.AccessibleAWTComponent.setFont​(Font f)
      设置此对象的 Font 。
      void Component.setFont​(Font f)
      设置此组件的字体。
      void Container.setFont​(Font f)
      设置此容器的字体。
      abstract void Graphics.setFont​(Font font)
      将此图形上下文的字体设置为指定的字体。
      void List.AccessibleAWTList.AccessibleAWTListChild.setFont​(Font f)
      设置此对象的Font。
      void MenuComponent.AccessibleAWTMenuComponent.setFont​(Font f)
      设置此对象的 Font 。
      void MenuComponent.setFont​(Font f)
      将此菜单组件使用的字体设置为指定的字体。
      Constructors in java.awt with parameters of type Font
      Constructor 描述
      Font​(Font font)
      创建一个新 Font从指定 font 。
      FontMetrics​(Font font)
      创建一个新的 FontMetrics用于找出的高度和宽度信息有关指定对象 Font在和特定字符字形的 Font 。

    • Uses of Font in java.awt.font

      Methods in java.awt.font that return Font
      Modifier and Type 方法 描述
      Font MultipleMaster.deriveMMFont​(float[] axes)
      根据指定数组中包含的设计轴值创建多个主字体的新实例。
      Font MultipleMaster.deriveMMFont​(float[] glyphWidths, float avgStemWidth, float typicalCapHeight, float typicalXHeight, float italicAngle)
      基于详细的度量标准信息创建一个多个主字体的新实例。
      abstract Font GlyphVector.getFont​()
      返回 Font与此相关 GlyphVector 。
      Constructors in java.awt.font with parameters of type Font
      Constructor 描述
      TextLayout​(String string, Font font, FontRenderContext frc)
      构造一个TextLayout从String和Font 。

    • Uses of Font in javax.accessibility

      Methods in javax.accessibility that return Font
      Modifier and Type 方法 描述
      Font AccessibleComponent.getFont​()
      获取此对象的字体。
      Methods in javax.accessibility with parameters of type Font
      Modifier and Type 方法 描述
      FontMetrics AccessibleComponent.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      void AccessibleComponent.setFont​(Font f)
      设置此对象的字体。

    • Uses of Font in javax.swing

      Methods in javax.swing that return Font
      Modifier and Type | 方法 | 描述
      Font DebugGraphics.getFont​()
      返回用于文本绘图操作的字体。
      Font | JList.AccessibleJList.AccessibleJListChild.getFont​()
      Font JTable.AccessibleJTable.AccessibleJTableCell.getFont​()
      获取此对象的 Font 。
      Font | JTree.AccessibleJTree.AccessibleJTreeNode.getFont​()
      Font UIDefaults.getFont​(Object key)
      如果 key的值是 Font返回，否则返回 null 。
      Font UIDefaults.getFont​(Object key, Locale l)
      如果值 key对于给定 Locale是 Font返回它，否则返回 null 。
      static Font UIManager.getFont​(Object key)
      从默认值返回一个字体。
      static Font UIManager.getFont​(Object key, Locale l)
      从适用于给定语言环境的默认值返回一个字体。
      Methods in javax.swing with parameters of type Font
      Modifier and Type | 方法 | 描述
      static TitledBorder BorderFactory.createTitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      使用指定的定位和字体，使用默认文本颜色（由当前外观确定）将标题添加到现有边框。
      static TitledBorder BorderFactory.createTitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      使用指定的定位，字体和颜色将标题添加到现有边框。
      FontMetrics DebugGraphics.getFontMetrics​(Font f)
      覆盖 Graphics.getFontMetrics 。
      FontMetrics JComponent.getFontMetrics​(Font font)
      获取 FontMetrics指定的 Font 。
      FontMetrics | JList.AccessibleJList.AccessibleJListChild.getFontMetrics​(Font f)
      FontMetrics JTable.AccessibleJTable.AccessibleJTableCell.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      FontMetrics | JTree.AccessibleJTree.AccessibleJTreeNode.getFontMetrics​(Font f)
      void DebugGraphics.setFont​(Font aFont)
      设置用于文本绘图操作的字体。
      void JComponent.setFont​(Font font)
      设置此组件的字体。
      void | JList.AccessibleJList.AccessibleJListChild.setFont​(Font f)
      void JSlider.setFont​(Font font)
      设置此组件的字体。
      void JTable.AccessibleJTable.AccessibleJTableCell.setFont​(Font f)
      设置此对象的 Font 。
      void JTextArea.setFont​(Font f)
      设置当前字体。
      void JTextField.setFont​(Font f)
      设置当前字体。
      void | JTree.AccessibleJTree.AccessibleJTreeNode.setFont​(Font f)

    • Uses of Font in javax.swing.border

      Fields in javax.swing.border declared as Font
      Modifier and Type Field 描述
      protected Font TitledBorder.titleFont
      用于呈现标题的字体。
      Methods in javax.swing.border that return Font
      Modifier and Type 方法 描述
      protected Font TitledBorder.getFont​(Component c)
      返回标题边框的默认字体。
      Font TitledBorder.getTitleFont​()
      返回标题边框的标题字体。
      Methods in javax.swing.border with parameters of type Font
      Modifier and Type 方法 描述
      void TitledBorder.setTitleFont​(Font titleFont)
      设置标题边框的标题字体。
      Constructors in javax.swing.border with parameters of type Font
      Constructor 描述
      TitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      创建带有指定边框，标题，标题对齐，标题位置和标题字体的TitledBorder实例。
      TitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      创建带有指定边框，标题，标题对齐，标题位置，标题字体和标题颜色的TitledBorder实例。

    • Uses of Font in javax.swing.plaf

      Subclasses of Font in javax.swing.plaf
      Modifier and Type Class 描述
      class  FontUIResource
      实现UIResource的java.awt.Font的子类。
      Constructors in javax.swing.plaf with parameters of type Font
      Constructor 描述
      FontUIResource​(Font font)
      构造一个 FontUIResource 。
      TitledBorderUIResource​(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      构造一个 TitledBorderUIResource 。
      TitledBorderUIResource​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      构造一个 TitledBorderUIResource 。

    • Uses of Font in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Font
      Modifier and Type Field 描述
      protected Font BasicMenuItemUI.acceleratorFont
      加速器字体。
      Methods in javax.swing.plaf.basic with parameters of type Font
      Modifier and Type 方法 描述
      protected void BasicTabbedPaneUI.paintText​(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
      油漆文字。

    • Uses of Font in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return Font
      Modifier and Type 方法 描述
      protected Font NimbusStyle.getFontForState​(SynthContext ctx)
      返回指定状态的字体。

    • Uses of Font in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Font
      Modifier and Type 方法 描述
      Font SynthStyle.getFont​(SynthContext context)
      返回指定状态的Font。
      protected abstract Font SynthStyle.getFontForState​(SynthContext context)
      返回指定状态的字体。
      Methods in javax.swing.plaf.synth with parameters of type Font
      Modifier and Type 方法 描述
      int SynthGraphicsUtils.computeStringWidth​(SynthContext ss, Font font, FontMetrics metrics, String text)
      返回传入的字符串的大小。
      Dimension SynthGraphicsUtils.getMaximumSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      返回正确呈现图标和文本所需的最大大小。
      Dimension SynthGraphicsUtils.getMinimumSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      返回正确呈现图标和文本所需的最小尺寸。
      Dimension SynthGraphicsUtils.getPreferredSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      返回正确呈现图标和文字所需的首选大小。

    • Uses of Font in javax.swing.table

      Methods in javax.swing.table that return Font
      Modifier and Type | 方法 | 描述
      Font | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFont​()
      Methods in javax.swing.table with parameters of type Font
      Modifier and Type | 方法 | 描述
      FontMetrics | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFontMetrics​(Font f)
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setFont​(Font f)

    • Uses of Font in javax.swing.text

      Methods in javax.swing.text that return Font
      Modifier and Type 方法 描述
      Font DefaultStyledDocument.getFont​(AttributeSet attr)
      从属性集获取字体。
      Font GlyphView.getFont​()
      获取字形应该基于的字体。
      Font LabelView.getFont​()
      获取字形应该基于的字体。
      Font StyleContext.getFont​(String family, int style, int size)
      获取一个新的字体。
      Font StyleContext.getFont​(AttributeSet attr)
      从属性集获取字体。
      Font StyledDocument.getFont​(AttributeSet attr)
      获取一组属性并将其转换为字体规范。
      Methods in javax.swing.text with parameters of type Font
      Modifier and Type 方法 描述
      FontMetrics StyleContext.getFontMetrics​(Font f)
      返回字体的字体指标。

    • Uses of Font in javax.swing.text.html

      Methods in javax.swing.text.html that return Font
      Modifier and Type 方法 描述
      Font StyleSheet.getFont​(AttributeSet a)
      获取用于给定属性集的字体。

    • Uses of Font in javax.swing.tree

      Fields in javax.swing.tree declared as Font
      Modifier and Type Field 描述
      protected Font DefaultTreeCellEditor.font
      要绘制的字体， null表示将使用渲染器的字体。
      Methods in javax.swing.tree that return Font
      Modifier and Type | 方法 | 描述
      Font | DefaultTreeCellEditor.DefaultTextField.getFont​()
      Font DefaultTreeCellEditor.getFont​()
      获取用于编辑的字体。
      Font DefaultTreeCellRenderer.getFont​()
      获取此组件的字体。
      Methods in javax.swing.tree with parameters of type Font
      Modifier and Type 方法 描述
      void DefaultTreeCellEditor.setFont​(Font font)
      设置要编辑的字体。
      void DefaultTreeCellRenderer.setFont​(Font font)
      Subclassed to map FontUIResources to null.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.FontFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.FontFormatException

  • Packages that use FontFormatException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of FontFormatException in java.awt

      Methods in java.awt that throw FontFormatException
      Modifier and Type 方法 描述
      static Font Font.createFont​(int fontFormat, File fontFile)
      使用指定的字体类型和指定的字体文件返回一个新的 Font 。
      static Font Font.createFont​(int fontFormat, InputStream fontStream)
      使用指定的字体类型和输入数据返回一个新的 Font 。
      static Font[] Font.createFonts​(File fontFile)
      返回从指定文件解码的新数组 Font 。
      static Font[] Font.createFonts​(InputStream fontStream)
      返回从指定的流解码的新数组 Font 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.FontMetrics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.FontMetrics

  • Packages that use FontMetrics
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of FontMetrics in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return FontMetrics
      Modifier and Type 方法 描述
      FontMetrics Translator.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。

    • Uses of FontMetrics in java.awt

      Methods in java.awt that return FontMetrics
      Modifier and Type 方法 描述
      FontMetrics Component.AccessibleAWTComponent.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      FontMetrics Component.getFontMetrics​(Font font)
      获取指定字体的字体指标。
      FontMetrics Graphics.getFontMetrics​()
      获取当前字体的字体度量。
      abstract FontMetrics Graphics.getFontMetrics​(Font f)
      获取指定字体的字体指标。
      FontMetrics List.AccessibleAWTList.AccessibleAWTListChild.getFontMetrics​(Font f)
      获取此对象的FontMetrics。
      FontMetrics MenuComponent.AccessibleAWTMenuComponent.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      abstract FontMetrics Toolkit.getFontMetrics​(Font font)
      已过时。
      从JDK 1.2版开始，由Font方法getLineMetrics 。

    • Uses of FontMetrics in javax.accessibility

      Methods in javax.accessibility that return FontMetrics
      Modifier and Type 方法 描述
      FontMetrics AccessibleComponent.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。

    • Uses of FontMetrics in javax.swing

      Methods in javax.swing that return FontMetrics
      Modifier and Type | 方法 | 描述
      FontMetrics DebugGraphics.getFontMetrics​()
      覆盖 Graphics.getFontMetrics 。
      FontMetrics DebugGraphics.getFontMetrics​(Font f)
      覆盖 Graphics.getFontMetrics 。
      FontMetrics JComponent.getFontMetrics​(Font font)
      获取 FontMetrics指定的 Font 。
      FontMetrics | JList.AccessibleJList.AccessibleJListChild.getFontMetrics​(Font f)
      FontMetrics JTable.AccessibleJTable.AccessibleJTableCell.getFontMetrics​(Font f)
      获取此对象的 FontMetrics 。
      FontMetrics | JTree.AccessibleJTree.AccessibleJTreeNode.getFontMetrics​(Font f)
      Methods in javax.swing with parameters of type FontMetrics
      Modifier and Type 方法 描述
      static int SwingUtilities.computeStringWidth​(FontMetrics fm, String str)
      使用指定的“metrics”（大小）的字体计算字符串的宽度。
      static String SwingUtilities.layoutCompoundLabel​(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。
      static String SwingUtilities.layoutCompoundLabel​(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。

    • Uses of FontMetrics in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return FontMetrics
      Modifier and Type 方法 描述
      protected FontMetrics BasicTabbedPaneUI.getFontMetrics​()
      返回字体指标。
      Methods in javax.swing.plaf.basic with parameters of type FontMetrics
      Modifier and Type 方法 描述
      protected int BasicTabbedPaneUI.calculateTabWidth​(int tabPlacement, int tabIndex, FontMetrics metrics)
      计算标签宽度。
      static String BasicGraphicsUtils.getClippedString​(JComponent c, FontMetrics fm, String string, int availTextWidth)
      将传入的字符串剪切到提供的空格。
      static float BasicGraphicsUtils.getStringWidth​(JComponent c, FontMetrics fm, String string)
      使用提供的组件的文本属性和反锯齿提示返回传入的字符串的宽度。
      protected String BasicInternalFrameTitlePane.getTitle​(String text, FontMetrics fm, int availTextWidth)
      返回标题。
      protected String BasicLabelUI.layoutCL​(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
      转发给SwingUtilities.layoutCompoundLabel（）的调用。
      protected void BasicTabbedPaneUI.layoutLabel​(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      Laysout一个标签。
      protected void BasicTabbedPaneUI.paintText​(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
      油漆文字。

    • Uses of FontMetrics in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return FontMetrics
      Modifier and Type 方法 描述
      protected FontMetrics SynthTabbedPaneUI.getFontMetrics​()
      返回字体指标。
      Methods in javax.swing.plaf.synth with parameters of type FontMetrics
      Modifier and Type 方法 描述
      protected int SynthTabbedPaneUI.calculateTabWidth​(int tabPlacement, int tabIndex, FontMetrics metrics)
      计算标签宽度。
      int SynthGraphicsUtils.computeStringWidth​(SynthContext ss, Font font, FontMetrics metrics, String text)
      返回传入的字符串的大小。
      String SynthGraphicsUtils.layoutText​(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
      通过引用将文本和图标返回，放置图标和文本的位置。

    • Uses of FontMetrics in javax.swing.table

      Methods in javax.swing.table that return FontMetrics
      Modifier and Type | 方法 | 描述
      FontMetrics | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFontMetrics​(Font f)

    • Uses of FontMetrics in javax.swing.text

      Fields in javax.swing.text declared as FontMetrics
      Modifier and Type Field 描述
      protected FontMetrics PlainView.metrics
      当前字体的字体指标。
      Methods in javax.swing.text that return FontMetrics
      Modifier and Type 方法 描述
      protected FontMetrics FieldView.getFontMetrics​()
      获取与托管此视图的组件相关联的字体度量。
      protected FontMetrics LabelView.getFontMetrics​()
      已过时。
      在JDK中运行时，FontMetrics不用于字形渲染。
      FontMetrics StyleContext.getFontMetrics​(Font f)
      返回字体的字体指标。
      Methods in javax.swing.text with parameters of type FontMetrics
      Modifier and Type 方法 描述
      static int Utilities.getBreakLocation​(Segment s, FontMetrics metrics, float x0, float x, TabExpander e, int startOffset)
      确定在给定的范围内打破给定文本的位置。
      static int Utilities.getBreakLocation​(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.getBreakLocation(Segment, FontMetrics, float, float, TabExpander, int)
      static int Utilities.getTabbedTextOffset​(Segment s, FontMetrics metrics, float x0, float x, TabExpander e, int startOffset, boolean round)
      确定最佳表示视图坐标系中给定跨度的给定文本的相对偏移量。
      static int Utilities.getTabbedTextOffset​(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)
      static int Utilities.getTabbedTextOffset​(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
      已过时。
      替换为Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)
      static float Utilities.getTabbedTextWidth​(Segment s, FontMetrics metrics, float x, TabExpander e, int startOffset)
      确定考虑到选项卡的给定段文本的宽度。
      static int Utilities.getTabbedTextWidth​(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.getTabbedTextWidth(Segment, FontMetrics, float, TabExpander, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Frame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Frame

  • Packages that use Frame
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Frame in java.awt

      Methods in java.awt that return Frame
      Modifier and Type 方法 描述
      static Frame[] Frame.getFrames​()
      返回此应用程序创建的所有 Frame的数组。
      Methods in java.awt with parameters of type Frame
      Modifier and Type 方法 描述
      PrintJob Toolkit.getPrintJob​(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
      获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
      abstract PrintJob Toolkit.getPrintJob​(Frame frame, String jobtitle, Properties props)
      获取一个 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
      Constructors in java.awt with parameters of type Frame
      Constructor 描述
      Dialog​(Frame owner)
      构造一个最初不可见的，无模式 Dialog带有指定的所有者 Frame和空标题。
      Dialog​(Frame owner, boolean modal)
      构造最初不可见的 Dialog与指定的所有者 Frame和模态和一个空的标题。
      Dialog​(Frame owner, String title)
      构造一个最初看不见的，无模式的 Dialog与指定的所有者 Frame和标题。
      Dialog​(Frame owner, String title, boolean modal)
      构造一个最初不可见的 Dialog与指定的所有者 Frame ，标题和模态。
      Dialog​(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
      构造最初不可见的 Dialog与指定的所有者 Frame ，标题，模式和 GraphicsConfiguration 。
      FileDialog​(Frame parent)
      创建一个加载文件的文件对话框。
      FileDialog​(Frame parent, String title)
      创建一个文件对话框窗口，其中包含用于加载文件的指定标题。
      FileDialog​(Frame parent, String title, int mode)
      创建一个带有指定标题的文件对话窗口，用于加载或保存文件。
      Window​(Frame owner)
      构造一个新的，最初不可见的窗口，其中指定的是 Frame作为其所有者。

    • Uses of Frame in javax.swing

      Subclasses of Frame in javax.swing
      Modifier and Type Class 描述
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      Methods in javax.swing that return Frame
      Modifier and Type 方法 描述
      static Frame JOptionPane.getFrameForComponent​(Component parentComponent)
      返回指定的组件的 Frame 。
      static Frame JOptionPane.getRootFrame​()
      返回 Frame用于不提供框架的类方法。
      Methods in javax.swing with parameters of type Frame
      Modifier and Type 方法 描述
      static void JOptionPane.setRootFrame​(Frame newRootFrame)
      将框架设置为不提供框架的类方法。
      Constructors in javax.swing with parameters of type Frame
      Constructor 描述
      JDialog​(Frame owner)
      使用指定的 Frame作为其所有者创建无模式对话框，并创建一个空标题。
      JDialog​(Frame owner, boolean modal)
      创建一个具有空标题和指定模式的 Frame ，其中所有者为 Frame 。
      JDialog​(Frame owner, String title)
      使用指定的标题和指定的所有者框架创建无模式对话框。
      JDialog​(Frame owner, String title, boolean modal)
      创建一个具有指定标题的对话框，拥有者 Frame和模态。
      JDialog​(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
      创建一个具有指定标题的对话框，拥有者 Frame ，模态和 GraphicsConfiguration 。
      JWindow​(Frame owner)
      创建具有指定所有者框架的窗口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Frame.AccessibleAWTFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Frame.AccessibleAWTFrame

  • Packages that use Frame.AccessibleAWTFrame
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Frame.AccessibleAWTFrame in javax.swing

      Subclasses of Frame.AccessibleAWTFrame in javax.swing
      Modifier and Type Class 描述
      protected class  JFrame.AccessibleJFrame
      该类实现 JFrame类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GradientPaint

No usage of java.awt.GradientPaint
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Graphics2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Graphics2D

  • Packages that use Graphics2D
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.image
    提供创建和修改图像的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Graphics2D in java.awt

      Methods in java.awt that return Graphics2D
      Modifier and Type 方法 描述
      abstract Graphics2D GraphicsEnvironment.createGraphics​(BufferedImage img)
      返回一个Graphics2D对象，用于渲染到指定的BufferedImage中 。
      Graphics2D SplashScreen.createGraphics​()
      为启动屏幕叠加图像创建图形上下文（作为Graphics2D对象），允许您绘制闪屏。

    • Uses of Graphics2D in java.awt.font

      Methods in java.awt.font with parameters of type Graphics2D
      Modifier and Type 方法 描述
      abstract void GraphicAttribute.draw​(Graphics2D graphics, float x, float y)
      在指定的位置渲染此 GraphicAttribute 。
      void ImageGraphicAttribute.draw​(Graphics2D graphics, float x, float y)
      在指定的位置渲染此 GraphicAttribute 。
      void ShapeGraphicAttribute.draw​(Graphics2D graphics, float x, float y)
      在指定的位置渲染此 GraphicAttribute 。
      void TextLayout.draw​(Graphics2D g2, float x, float y)
      这呈现TextLayout在指定的指定位置Graphics2D上下文。

    • Uses of Graphics2D in java.awt.image

      Methods in java.awt.image that return Graphics2D
      Modifier and Type 方法 描述
      Graphics2D BufferedImage.createGraphics​()
      创建一个 Graphics2D ，可以用来绘制这个 BufferedImage 。
      abstract Graphics2D VolatileImage.createGraphics​()
      创建一个 Graphics2D ，可以用来绘制这个 VolatileImage 。

    • Uses of Graphics2D in javax.swing

      Methods in javax.swing with parameters of type Graphics2D
      Modifier and Type 方法 描述
      void Painter.paint​(Graphics2D g, T object, int width, int height)
      给予给定的Graphics2D对象。

    • Uses of Graphics2D in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type Graphics2D
      Modifier and Type 方法 描述
      static void BasicGraphicsUtils.drawString​(JComponent c, Graphics2D g, String string, float x, float y)
      使用提供的组件的文本属性和反锯齿提示在指定位置绘制给定的字符串。
      static void BasicGraphicsUtils.drawStringUnderlineCharAt​(JComponent c, Graphics2D g, String string, int underlinedIndex, float x, float y)
      在指定的位置绘制给定的字符串，强调指定的字符。

    • Uses of Graphics2D in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus with parameters of type Graphics2D
      Modifier and Type 方法 描述
      protected void AbstractRegionPainter.configureGraphics​(Graphics2D g)
      配置给定的Graphics2D。
      protected abstract void AbstractRegionPainter.doPaint​(Graphics2D g, JComponent c, int width, int height, Object[] extendedCacheKeys)
      实际执行绘画操作。
      void AbstractRegionPainter.paint​(Graphics2D g, JComponent c, int w, int h)
      渲染给给定的Graphics2D对象。

    • Uses of Graphics2D in javax.swing.text

      Methods in javax.swing.text with parameters of type Graphics2D
      Modifier and Type | 方法 | 描述
      protected float PasswordView.drawEchoCharacter​(Graphics2D g, float x, float y, char c)
      呈现回音字符，或者用于显示密码字符的任何图形。
      protected void PlainView.drawLine​(int lineIndex, Graphics2D g, float x, float y)
      渲染一行文本，最终抑制空格并展开任何标签。
      protected void WrappedPlainView.drawLine​(int p0, int p1, Graphics2D g, float x, float y)
      渲染一行文本，最终抑制空格并展开任何标签。
      protected float | PasswordView.drawSelectedText​(Graphics2D g, float x, float y, int p0, int p1)
      protected float PlainView.drawSelectedText​(Graphics2D g, float x, float y, int p0, int p1)
      将模型中的给定范围渲染为所选文本。
      protected float WrappedPlainView.drawSelectedText​(Graphics2D g, float x, float y, int p0, int p1)
      将模型中的给定范围渲染为所选文本。
      static float Utilities.drawTabbedText​(Segment s, float x, float y, Graphics2D g, TabExpander e, int startOffset)
      绘制给定的文本，使用给定的选项卡扩展技术扩展包含的所有选项卡。
      protected float | PasswordView.drawUnselectedText​(Graphics2D g, float x, float y, int p0, int p1)
      protected float PlainView.drawUnselectedText​(Graphics2D g, float x, float y, int p0, int p1)
      将模型中的给定范围呈现为正常未选择的文本。
      protected float WrappedPlainView.drawUnselectedText​(Graphics2D g, float x, float y, int p0, int p1)
      将模型中的给定范围呈现为正常未选择的文本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Graphics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Graphics

  • Packages that use Graphics
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Graphics in java.awt

      Subclasses of Graphics in java.awt
      Modifier and Type Class 描述
      class  Graphics2D
      这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。
      Methods in java.awt that return Graphics
      Modifier and Type | 方法 | 描述
      abstract Graphics Graphics.create​()
      创建一个新的 Graphics对象，该对象是此 Graphics对象的副本。
      Graphics Graphics.create​(int x, int y, int width, int height)
      基于此 Graphics对象创建一个新的 Graphics对象，但具有新的翻译和剪辑区域。
      Graphics | Component.BltBufferStrategy.getDrawGraphics​()
      Graphics | Component.FlipBufferStrategy.getDrawGraphics​()
      Graphics Component.getGraphics​()
      为此组件创建图形上下文。
      abstract Graphics Image.getGraphics​()
      创建图形上下文以绘制到离屏图像。
      abstract Graphics PrintJob.getGraphics​()
      获取将绘制到下一页的Graphics对象。
      Methods in java.awt with parameters of type Graphics
      Modifier and Type 方法 描述
      LineMetrics FontMetrics.getLineMetrics​(char[] chars, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定字符数组的LineMetrics对象。
      LineMetrics FontMetrics.getLineMetrics​(String str, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定的String的LineMetrics对象。
      LineMetrics FontMetrics.getLineMetrics​(String str, Graphics context)
      返回指定的Graphics上下文中指定的String的LineMetrics对象。
      LineMetrics FontMetrics.getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定的CharacterIterator的LineMetrics对象。
      Rectangle2D FontMetrics.getMaxCharBounds​(Graphics context)
      返回具有指定的 Graphics上下文中最大边界的字符的边界。
      Rectangle2D FontMetrics.getStringBounds​(char[] chars, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的字符数组的范围。
      Rectangle2D FontMetrics.getStringBounds​(String str, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的 String的边界。
      Rectangle2D FontMetrics.getStringBounds​(String str, Graphics context)
      返回指定的 Graphics上下文中指定的 String的边界。
      Rectangle2D FontMetrics.getStringBounds​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回在指定的 Graphics上下文中指定的 CharacterIterator中索引的字符的边界。
      void Canvas.paint​(Graphics g)
      画这幅画。
      void Component.paint​(Graphics g)
      涂抹这个组件。
      void Container.paint​(Graphics g)
      涂上容器
      void Window.paint​(Graphics g)
      涂上容器
      void Component.paintAll​(Graphics g)
      绘制此组件及其所有子组件。
      void Container.paintComponents​(Graphics g)
      涂抹此容器中的每个组件。
      void Component.print​(Graphics g)
      打印此组件。
      void Container.print​(Graphics g)
      打印容器。
      void Component.printAll​(Graphics g)
      打印此组件及其所有子组件。
      void Container.printComponents​(Graphics g)
      打印此容器中的每个组件。
      void ScrollPane.printComponents​(Graphics g)
      在此滚动窗格中打印组件。
      void Canvas.update​(Graphics g)
      更新此画布。
      void Component.update​(Graphics g)
      更新此组件。
      void Container.update​(Graphics g)
      更新容器。

    • Uses of Graphics in java.awt.image

      Methods in java.awt.image that return Graphics
      Modifier and Type 方法 描述
      abstract Graphics BufferStrategy.getDrawGraphics​()
      为绘图缓冲区创建图形上下文。
      Graphics AbstractMultiResolutionImage.getGraphics​()
      根据基础 Image#getGraphics()方法的合同，此实现将始终抛出 UnsupportedOperationException因为只有离屏图像可以返回一个 Graphics对象。
      Graphics BufferedImage.getGraphics​()
      此方法返回一个Graphics2D ，但这里是向后兼容性。
      Graphics VolatileImage.getGraphics​()
      此方法返回一个Graphics2D ，但这里是向后兼容性。

    • Uses of Graphics in java.awt.print

      Methods in java.awt.print with parameters of type Graphics
      Modifier and Type 方法 描述
      int Printable.print​(Graphics graphics, PageFormat pageFormat, int pageIndex)
      以指定的格式将指定索引的页面打印到指定的Graphics上下文中。

    • Uses of Graphics in java.beans

      Methods in java.beans with parameters of type Graphics
      Modifier and Type 方法 描述
      void PropertyEditor.paintValue​(Graphics gfx, Rectangle box)
      将值的表示绘制到屏幕不动产的给定区域。
      void PropertyEditorSupport.paintValue​(Graphics gfx, Rectangle box)
      将值的表示绘制到屏幕不动产的给定区域。

    • Uses of Graphics in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type Graphics
      Modifier and Type 方法 描述
      protected void JFXPanel.paintComponent​(Graphics g)
      覆盖 JComponent.paintComponent(Graphics)方法来绘制附加到此 JFXpanel的JavaFX场景的内容。

    • Uses of Graphics in javax.swing

      Subclasses of Graphics in javax.swing
      Modifier and Type Class 描述
      class  DebugGraphics
      图形子类支持图形调试。
      Methods in javax.swing that return Graphics
      Modifier and Type 方法 描述
      Graphics DebugGraphics.create​()
      覆盖 Graphics.create以返回一个DebugGraphics对象。
      Graphics DebugGraphics.create​(int x, int y, int width, int height)
      覆盖 Graphics.create以返回一个DebugGraphics对象。
      protected Graphics JComponent.getComponentGraphics​(Graphics g)
      返回用于绘制该组件的图形对象。
      Graphics JApplet.getGraphics​()
      已过时。
      为此组件创建图形上下文。
      Graphics JComponent.getGraphics​()
      返回此组件的图形上下文，可用于绘制组件。
      Graphics JDialog.getGraphics​()
      为此组件创建图形上下文。
      Graphics JFrame.getGraphics​()
      为此组件创建图形上下文。
      Graphics JWindow.getGraphics​()
      为此组件创建图形上下文。
      Methods in javax.swing with parameters of type Graphics
      Modifier and Type 方法 描述
      protected Graphics JComponent.getComponentGraphics​(Graphics g)
      返回用于绘制该组件的图形对象。
      void CellRendererPane.paint​(Graphics g)
      不应该叫
      void JComponent.paint​(Graphics g)
      由Swing调用来绘制组件。
      void JLayer.paint​(Graphics g)
      将所有绘画委托给LayerUI对象。
      void JLayeredPane.paint​(Graphics g)
      在指定的图形上下文中绘制JLayeredPane。
      void JViewport.paint​(Graphics g)
      取决于是否启用了 backingStore ，可以通过后备存储来绘制图像，也可以仅绘制最近曝光的部分，使用后备存储将其余部分“blit”。
      protected void AbstractButton.paintBorder​(Graphics g)
      如果 BorderPainted属性为true并且按钮具有边框，则 BorderPainted按钮的边框。
      protected void JComponent.paintBorder​(Graphics g)
      绘制组件的边框。
      protected void JMenuBar.paintBorder​(Graphics g)
      如果 BorderPainted属性为true，则绘制菜单栏的边框。
      protected void JPopupMenu.paintBorder​(Graphics g)
      如果 borderPainted属性为 true绘制弹出菜单的边框。
      protected void JProgressBar.paintBorder​(Graphics g)
      如果 borderPainted属性为 true则绘制进度条的边框。
      protected void JToolBar.paintBorder​(Graphics g)
      如果 borderPainted属性为 true则绘制工具栏的边框。
      protected void JComponent.paintChildren​(Graphics g)
      涂抹这个组件的孩子。
      protected void JSplitPane.paintChildren​(Graphics g)
      Subclassed消息的UI与 finishedPaintingChildren之后，超级已经被消息，以及画边框。
      protected void Box.Filler.paintComponent​(Graphics g)
      Filler这 Filler 。
      protected void Box.paintComponent​(Graphics g)
      Box这 Box 。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h)
      调用this.paintComponent（g，c，p，x，y，w，h，false）。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
      在图形对象上绘制单元格渲染器组件c。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      调用this.paintComponent（）与矩形x，y，width，height字段。
      protected void JComponent.paintComponent​(Graphics g)
      调用UI null的paint方法，如果UI null 。
      protected void JInternalFrame.paintComponent​(Graphics g)
      被覆盖以允许在拖动内部框架时优化绘画。
      protected void JLayer.paintComponent​(Graphics g)
      这种方法是空的，因为所有的绘画都是由 JLayer.paint(Graphics)和 ComponentUI.update(Graphics, JComponent)方法完成的
      static void SwingUtilities.paintComponent​(Graphics g, Component c, Container p, int x, int y, int w, int h)
      绘制一个组件到指定的 Graphics 。
      static void SwingUtilities.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      绘制一个组件到指定的 Graphics 。
      void Icon.paintIcon​(Component c, Graphics g, int x, int y)
      在指定位置绘制图标。
      void ImageIcon.paintIcon​(Component c, Graphics g, int x, int y)
      画图标。
      void JComponent.print​(Graphics g)
      调用此方法将组件打印到指定的 Graphics 。
      void JComponent.printAll​(Graphics g)
      调用此方法打印组件。
      protected void JComponent.printBorder​(Graphics g)
      打印组件的边框。
      protected void JComponent.printChildren​(Graphics g)
      打印此组件的子项。
      protected void JComponent.printComponent​(Graphics g)
      这在打印操作期间被调用。
      void CellRendererPane.update​(Graphics g)
      不应该叫
      void JApplet.update​(Graphics g)
      已过时。
      只需打电话 paint(g) 。
      void JComponent.update​(Graphics g)
      致电 paint 。
      void JDialog.update​(Graphics g)
      致电 paint(g) 。
      void JFrame.update​(Graphics g)
      只需拨打 paint(g) 。
      void JWindow.update​(Graphics g)
      致电 paint(g) 。
      Constructors in javax.swing with parameters of type Graphics
      Constructor 描述
      DebugGraphics​(Graphics graphics)
      构建一个调试图形上下文从现有的图形上下文，支持减慢绘图。
      DebugGraphics​(Graphics graphics, JComponent component)
      从现有的图形上下文中构建调试图形上下文，从而减缓指定组件的绘图。

    • Uses of Graphics in javax.swing.border

      Methods in javax.swing.border with parameters of type Graphics
      Modifier and Type 方法 描述
      void AbstractBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      此默认实现不绘画。
      void BevelBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void Border.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void CompoundBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      通过用指定的位置和大小绘制外部边框来绘制复合边框，然后通过外部边框的插入在指定位置和大小偏移处绘制内边框。
      void EmptyBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      默认情况下不绘图。
      void EtchedBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void LineBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void MatteBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      涂抹无光泽的边框。
      void SoftBevelBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void StrokeBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      void TitledBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的边框。
      protected void BevelBorder.paintLoweredBevel​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定部件的下降斜面。
      protected void BevelBorder.paintRaisedBevel​(Component c, Graphics g, int x, int y, int width, int height)
      用指定的位置和大小绘制指定组件的凸起斜面。

    • Uses of Graphics in javax.swing.colorchooser

      Methods in javax.swing.colorchooser with parameters of type Graphics
      Modifier and Type 方法 描述
      void AbstractColorChooserPanel.paint​(Graphics g)
      画面板。

    • Uses of Graphics in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type Graphics
      Modifier and Type | 方法 | 描述
      abstract void SplitPaneUI.finishedPaintingChildren​(JSplitPane jc, Graphics g)
      在JSplitPane之后，接收器为其孩子提供了油漆的外观和感觉。
      void ComponentUI.paint​(Graphics g, JComponent c)
      适当地涂抹指定的组件的外观和感觉。
      void LayerUI.paint​(Graphics g, JComponent c)
      绘制指定的组件。
      void | BorderUIResource.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | IconUIResource.paintIcon​(Component c, Graphics g, int x, int y)
      void ComponentUI.update​(Graphics g, JComponent c)
      通知这个UI委托是时候绘制指定的组件。

    • Uses of Graphics in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type Graphics
      Modifier and Type | 方法 | 描述
      static void BasicGraphicsUtils.drawBezel​(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      画一个挡板
      protected void BasicTreeUI.drawCentered​(Component c, Graphics graphics, Icon icon, int x, int y)
      以（x，y）为中心绘制 icon 。
      protected void BasicTreeUI.drawDashedHorizontalLine​(Graphics g, int y, int x1, int x2)
      画一条水平虚线。
      static void BasicGraphicsUtils.drawDashedRect​(Graphics g, int x, int y, int width, int height)
      绘制虚线矩形。
      protected void BasicTreeUI.drawDashedVerticalLine​(Graphics g, int x, int y1, int y2)
      画一条垂直虚线。
      static void BasicGraphicsUtils.drawEtchedRect​(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      画一个蚀刻的矩形。
      static void BasicGraphicsUtils.drawGroove​(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
      画一个凹槽
      static void BasicGraphicsUtils.drawLoweredBezel​(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      画下一个挡板。
      static void BasicGraphicsUtils.drawString​(Graphics g, String text, int underlinedChar, int x, int y)
      绘制一个字符串的图形 g在位置（x，y）就像 g.drawString会。
      static void BasicGraphicsUtils.drawStringUnderlineCharAt​(Graphics g, String text, int underlinedIndex, int x, int y)
      画一个字符串与图形 g在位置（ x ， y ）就像 g.drawString会。
      void BasicSplitPaneUI.finishedPaintingChildren​(JSplitPane sp, Graphics g)
      当指定的拆分窗格绘制其子项时调用。
      protected Point BasicProgressBarUI.getStringPlacement​(Graphics g, String progressString, int x, int y, int width, int height)
      指定进度字符串将被绘制的地方。
      void | BasicArrowButton.paint​(Graphics g)
      void | BasicButtonUI.paint​(Graphics g, JComponent c)
      void | BasicComboBoxUI.paint​(Graphics g, JComponent c)
      void | BasicDesktopPaneUI.paint​(Graphics g, JComponent c)
      void | BasicInternalFrameTitlePane.SystemMenuBar.paint​(Graphics g)
      void BasicLabelUI.paint​(Graphics g, JComponent c)
      用前景颜色绘制标签文本，如果标签不透明，则使用背景颜色绘制整个背景。
      void BasicListUI.paint​(Graphics g, JComponent c)
      绘制与Graphics对象clipRect相交的行。
      void | BasicMenuItemUI.paint​(Graphics g, JComponent c)
      void | BasicPopupMenuSeparatorUI.paint​(Graphics g, JComponent c)
      void BasicProgressBarUI.paint​(Graphics g, JComponent c)
      代表绘画为两种方法之一：paintDeterminate或paintIndeterminate。
      void BasicRadioButtonUI.paint​(Graphics g, JComponent c)
      画单选按钮
      void | BasicScrollBarUI.paint​(Graphics g, JComponent c)
      void | BasicScrollPaneUI.paint​(Graphics g, JComponent c)
      void | BasicSeparatorUI.paint​(Graphics g, JComponent c)
      void | BasicSliderUI.paint​(Graphics g, JComponent c)
      void BasicSplitPaneDivider.paint​(Graphics g)
      涂抹分隔线。
      void BasicSplitPaneUI.paint​(Graphics g, JComponent jc)
      适当地涂抹指定的组件的外观和感觉。
      void | BasicTabbedPaneUI.paint​(Graphics g, JComponent c)
      void | BasicTableHeaderUI.paint​(Graphics g, JComponent c)
      void BasicTableUI.paint​(Graphics g, JComponent c)
      绘制在installUI（）中设置的 table实例的表示。
      void BasicTextUI.paint​(Graphics g, JComponent c)
      绘制界面。
      void | BasicToggleButtonUI.paint​(Graphics g, JComponent c)
      void | BasicToolBarSeparatorUI.paint​(Graphics g, JComponent c)
      void | BasicToolBarUI.DragWindow.paint​(Graphics g)
      void | BasicToolTipUI.paint​(Graphics g, JComponent c)
      void | BasicTreeUI.paint​(Graphics g, JComponent c)
      protected void BasicMenuItemUI.paintBackground​(Graphics g, JMenuItem menuItem, Color bgColor)
      绘制菜单项的背景。
      protected void BasicTextUI.paintBackground​(Graphics g)
      绘制视图的背景。
      void | BasicBorders.ButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.FieldBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.MenuBarBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.RadioButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.RolloverButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | BasicBorders.SplitPaneBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      void | BasicBorders.ToggleButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)
      protected void BasicButtonUI.paintButtonPressed​(Graphics g, AbstractButton b)
      画一个按下的按钮。
      protected void BasicListUI.paintCell​(Graphics g, int row, Rectangle rowBounds, ListCellRenderer<Object> cellRenderer, ListModel<Object> dataModel, ListSelectionModel selModel, int leadIndex)
      绘制一个列表单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane进行绘制。
      void | BasicInternalFrameTitlePane.paintComponent​(Graphics g)
      protected void BasicTabbedPaneUI.paintContentBorder​(Graphics g, int tabPlacement, int selectedIndex)
      绘制内容边框。
      protected void BasicTabbedPaneUI.paintContentBorderBottomEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      绘制内容边框底边。
      protected void BasicTabbedPaneUI.paintContentBorderLeftEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      绘制内容边框左边缘。
      protected void BasicTabbedPaneUI.paintContentBorderRightEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      绘制内容边框右边缘。
      protected void BasicTabbedPaneUI.paintContentBorderTopEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      绘制内容边框上边缘。
      void BasicComboBoxUI.paintCurrentValue​(Graphics g, Rectangle bounds, boolean hasFocus)
      绘制当前选定的项目。
      void BasicComboBoxUI.paintCurrentValueBackground​(Graphics g, Rectangle bounds, boolean hasFocus)
      绘制当前所选项目的背景。
      protected void BasicScrollBarUI.paintDecreaseHighlight​(Graphics g)
      绘制减少亮点。
      protected void BasicProgressBarUI.paintDeterminate​(Graphics g, JComponent c)
      所有目的的油漆方法应该对几乎所有线性，确定进度条做正确的事情。
      protected void BasicLabelUI.paintDisabledText​(JLabel l, Graphics g, String s, int textX, int textY)
      在textX上绘制clippedText，textY与background.lighter（），然后向下移动并向右移动一个像素与background.darker（）。
      protected void BasicToolBarUI.paintDragWindow​(Graphics g)
      绘制用于拖动的窗口的内容。
      protected void BasicTreeUI.paintDropLine​(Graphics g)
      画下线。
      protected void BasicLabelUI.paintEnabledText​(JLabel l, Graphics g, String s, int textX, int textY)
      在textX上绘制clippedText，textY带有标签前景色。
      protected void BasicTreeUI.paintExpandControl​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的展开（切换）部分。
      protected void BasicButtonUI.paintFocus​(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      涂一个专注的按钮。
      protected void BasicRadioButtonUI.paintFocus​(Graphics g, Rectangle textRect, Dimension size)
      油漆聚焦单选按钮。
      void BasicSliderUI.paintFocus​(Graphics g)
      油漆重点
      protected void BasicTabbedPaneUI.paintFocusIndicator​(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      绘制焦点指示器。
      protected void BasicSliderUI.paintHorizontalLabel​(Graphics g, int value, Component label)
      为标签表中的每个标签调用。
      protected void BasicTreeUI.paintHorizontalLine​(Graphics g, JComponent c, int y, int left, int right)
      画一条水平线。
      protected void BasicTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      涂抹腿部的水平部分。
      protected void BasicButtonUI.paintIcon​(Graphics g, JComponent c, Rectangle iconRect)
      绘制当前按钮的图标。
      protected void BasicTabbedPaneUI.paintIcon​(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
      画一个图标。
      protected void BasicToggleButtonUI.paintIcon​(Graphics g, AbstractButton b, Rectangle iconRect)
      在指定位置绘制图标。
      protected void BasicScrollBarUI.paintIncreaseHighlight​(Graphics g)
      涂抹增加亮点。
      protected void BasicProgressBarUI.paintIndeterminate​(Graphics g, JComponent c)
      所有的线性弹跳框进度条都应该做正确的事情。
      void BasicSliderUI.paintLabels​(Graphics g)
      涂上标签。
      protected void BasicSliderUI.paintMajorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      绘制水平滑块的主要刻度。
      protected void BasicSliderUI.paintMajorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      绘制垂直滑块的主要刻度。
      protected void BasicMenuItemUI.paintMenuItem​(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
      画一个菜单项。
      protected void BasicSliderUI.paintMinorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      为水平滑块绘制小刻度。
      protected void BasicSliderUI.paintMinorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      为垂直滑块绘制小刻度。
      protected void BasicTreeUI.paintRow​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的渲染器部分。
      protected void BasicTextUI.paintSafely​(Graphics g)
      保证界面安全，保证模型不会从此线程的视图中改变。
      protected void BasicProgressBarUI.paintString​(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
      绘制进度字符串。
      protected void BasicTabbedPaneUI.paintTab​(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
      画一个标签。
      protected void BasicTabbedPaneUI.paintTabArea​(Graphics g, int tabPlacement, int selectedIndex)
      绘制标签区域中的选项卡。
      protected void BasicTabbedPaneUI.paintTabBackground​(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      绘制标签背景。
      protected void BasicTabbedPaneUI.paintTabBorder​(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      此函数绘制每个选项卡周围的边框，该函数现在绘制该选项卡的背景。
      protected void BasicButtonUI.paintText​(Graphics g, AbstractButton b, Rectangle textRect, String text)
      呈现当前按钮文本的方法。
      protected void BasicButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)
      呈现当前按钮文本的方法。
      protected void BasicMenuItemUI.paintText​(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
      呈现当前菜单项的文本。
      protected void BasicTabbedPaneUI.paintText​(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
      油漆文字。
      protected void BasicScrollBarUI.paintThumb​(Graphics g, JComponent c, Rectangle thumbBounds)
      画拇指
      void BasicSliderUI.paintThumb​(Graphics g)
      画拇指
      void BasicSliderUI.paintTicks​(Graphics g)
      油漆滴答
      protected void BasicInternalFrameTitlePane.paintTitleBackground​(Graphics g)
      从paintComponent调用。
      protected void BasicScrollBarUI.paintTrack​(Graphics g, JComponent c, Rectangle trackBounds)
      画轨道。
      void BasicSliderUI.paintTrack​(Graphics g)
      油漆轨道。
      void BasicArrowButton.paintTriangle​(Graphics g, int x, int y, int size, int direction, boolean isEnabled)
      涂三角形
      protected void BasicSliderUI.paintVerticalLabel​(Graphics g, int value, Component label)
      为标签表中的每个标签调用。
      protected void BasicTreeUI.paintVerticalLine​(Graphics g, JComponent c, int x, int top, int bottom)
      画一条垂直线。
      protected void BasicTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      涂上腿部的垂直部分。
      void BasicMenuItemUI.update​(Graphics g, JComponent c)
      我们在paintMenuItem（）中绘制背景，因此覆盖更新（默认填写不透明组件的背景）来调用paint（）。
      void BasicTextUI.update​(Graphics g, JComponent c)
      Superclass以不可控制的方式绘制背景（即可能需要将图像平铺到背景中）。

    • Uses of Graphics in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type Graphics
      Modifier and Type | 方法 | 描述
      protected void MetalCheckBoxIcon.drawCheck​(Component c, Graphics g, int x, int y)
      油漆 MetalCheckBoxIcon 。
      void | MetalComboBoxUI.paint​(Graphics g, JComponent c)
      void | MetalPopupMenuSeparatorUI.paint​(Graphics g, JComponent c)
      void | MetalRadioButtonUI.paint​(Graphics g, JComponent c)
      void | MetalScrollButton.paint​(Graphics g)
      void | MetalSeparatorUI.paint​(Graphics g, JComponent c)
      void | MetalTabbedPaneUI.paint​(Graphics g, JComponent c)
      void | MetalToolTipUI.paint​(Graphics g, JComponent c)
      void | MetalTreeUI.paint​(Graphics g, JComponent c)
      void | MetalBorders.ButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.Flush3DBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.InternalFrameBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.MenuBarBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.MenuItemBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.OptionDialogBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.PaletteBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.PopupMenuBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.RolloverButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.ScrollPaneBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.TableHeaderBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.TextFieldBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.ToggleButtonBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      void | MetalBorders.ToolBarBorder.paintBorder​(Component c, Graphics g, int x, int y, int w, int h)
      protected void MetalTabbedPaneUI.paintBottomTabBorder​(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      绘制底部标签边框。
      protected void | MetalButtonUI.paintButtonPressed​(Graphics g, AbstractButton b)
      protected void | MetalToggleButtonUI.paintButtonPressed​(Graphics g, AbstractButton b)
      void | MetalComboBoxButton.paintComponent​(Graphics g)
      void | MetalInternalFrameTitlePane.paintComponent​(Graphics g)
      protected void | MetalTabbedPaneUI.paintContentBorderBottomEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | MetalTabbedPaneUI.paintContentBorderLeftEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | MetalTabbedPaneUI.paintContentBorderRightEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | MetalTabbedPaneUI.paintContentBorderTopEdge​(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      void MetalComboBoxUI.paintCurrentValue​(Graphics g, Rectangle bounds, boolean hasFocus)
      如果需要，可以涂抹当前选择的项目。
      void MetalComboBoxUI.paintCurrentValueBackground​(Graphics g, Rectangle bounds, boolean hasFocus)
      如果需要，可以画出当前所选项目的背景。
      void MetalProgressBarUI.paintDeterminate​(Graphics g, JComponent c)
      在进度条上画出一点特别的亮点。
      protected void MetalLabelUI.paintDisabledText​(JLabel l, Graphics g, String s, int textX, int textY)
      只需将文字画成灰色（Label.disabledForeground），而不是标签前景色。
      protected void | MetalButtonUI.paintFocus​(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void | MetalRadioButtonUI.paintFocus​(Graphics g, Rectangle t, Dimension d)
      void | MetalSliderUI.paintFocus​(Graphics g)
      protected void | MetalToggleButtonUI.paintFocus​(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void | MetalTabbedPaneUI.paintFocusIndicator​(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      protected void | MetalTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      protected void MetalTreeUI.paintHorizontalSeparators​(Graphics g, JComponent c)
      绘制水平分隔符。
      void | MetalCheckBoxIcon.paintIcon​(Component c, Graphics g, int x, int y)
      void MetalComboBoxIcon.paintIcon​(Component c, Graphics g, int x, int y)
      涂上水平条
      void | MetalIconFactory.FileIcon16.paintIcon​(Component c, Graphics g, int x, int y)
      void | MetalIconFactory.FolderIcon16.paintIcon​(Component c, Graphics g, int x, int y)
      void | MetalIconFactory.PaletteCloseIcon.paintIcon​(Component c, Graphics g, int x, int y)
      void | MetalIconFactory.TreeControlIcon.paintIcon​(Component c, Graphics g, int x, int y)
      protected void MetalToggleButtonUI.paintIcon​(Graphics g, AbstractButton b, Rectangle iconRect)
      在空间 iconRect绘制按钮 b的相应图标。
      void MetalProgressBarUI.paintIndeterminate​(Graphics g, JComponent c)
      在进度条和弹跳框上绘制一点特别的亮点。
      protected void MetalTabbedPaneUI.paintLeftTabBorder​(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      画左标签边框。
      protected void | MetalSliderUI.paintMajorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      protected void | MetalSliderUI.paintMajorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      void MetalIconFactory.TreeControlIcon.paintMe​(Component c, Graphics g, int x, int y)
      TreeControlIcon 。
      protected void | MetalSliderUI.paintMinorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      protected void | MetalSliderUI.paintMinorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      void MetalInternalFrameTitlePane.paintPalette​(Graphics g)
      油漆调色板
      protected void MetalTabbedPaneUI.paintRightTabBorder​(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      绘制正确的标签边框。
      protected void | MetalTabbedPaneUI.paintTabBackground​(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      protected void | MetalTabbedPaneUI.paintTabBorder​(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      protected void | MetalButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)
      protected void | MetalToggleButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)
      protected void | MetalScrollBarUI.paintThumb​(Graphics g, JComponent c, Rectangle thumbBounds)
      void | MetalSliderUI.paintThumb​(Graphics g)
      protected void MetalTabbedPaneUI.paintTopTabBorder​(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      绘制顶部标签边框。
      protected void | MetalScrollBarUI.paintTrack​(Graphics g, JComponent c, Rectangle trackBounds)
      void | MetalSliderUI.paintTrack​(Graphics g)
      protected void | MetalTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      void MetalButtonUI.update​(Graphics g, JComponent c)
      如果需要，则绘制组件的背景，然后调用 paint 。
      void MetalMenuBarUI.update​(Graphics g, JComponent c)
      如果需要，则绘制组件的背景，然后调用 paint 。
      void | MetalTabbedPaneUI.update​(Graphics g, JComponent c)
      void MetalToggleButtonUI.update​(Graphics g, JComponent c)
      如果需要涂抹组件的背景，然后调用 paint 。
      void MetalToolBarUI.update​(Graphics g, JComponent c)
      如果需要涂抹组件的背景，然后调用 paint 。

    • Uses of Graphics in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type Graphics
      Modifier and Type 方法 描述
      void MultiSplitPaneUI.finishedPaintingChildren​(JSplitPane a, Graphics b)
      在此对象处理的每个UI上调用 finishedPaintingChildren方法。
      void MultiButtonUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiColorChooserUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiComboBoxUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiDesktopIconUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiDesktopPaneUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiFileChooserUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiInternalFrameUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiLabelUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiListUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiMenuBarUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiMenuItemUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiOptionPaneUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiPanelUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiPopupMenuUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiProgressBarUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiRootPaneUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiScrollBarUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiScrollPaneUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiSeparatorUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiSliderUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiSpinnerUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiSplitPaneUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiTabbedPaneUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiTableHeaderUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiTableUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiTextUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiToolBarUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiToolTipUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiTreeUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiViewportUI.paint​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 paint方法。
      void MultiButtonUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiColorChooserUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiComboBoxUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiDesktopIconUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiDesktopPaneUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiFileChooserUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiInternalFrameUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiLabelUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiListUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiMenuBarUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiMenuItemUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiOptionPaneUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiPanelUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiPopupMenuUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiProgressBarUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiRootPaneUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiScrollBarUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiScrollPaneUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiSeparatorUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiSliderUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiSpinnerUI.update​(Graphics a, JComponent b)
      新新新新 update
      void MultiSplitPaneUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiTabbedPaneUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiTableHeaderUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiTableUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiTextUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiToolBarUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiToolTipUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiTreeUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。
      void MultiViewportUI.update​(Graphics a, JComponent b)
      在此对象处理的每个UI上调用 update方法。

    • Uses of Graphics in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type Graphics
      Modifier and Type | 方法 | 描述
      protected void SynthTreeUI.drawCentered​(Component c, Graphics graphics, Icon icon, int x, int y)
      以（x，y）为中心绘制 icon 。
      void SynthGraphicsUtils.drawLine​(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2)
      在两个终点之间画一条线。
      void SynthGraphicsUtils.drawLine​(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey)
      在两个终点之间画一条线。
      void SynthSplitPaneUI.finishedPaintingChildren​(JSplitPane jc, Graphics g)
      当指定的拆分窗格绘制其子项时调用。
      void SynthButtonUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthButtonUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthColorChooserUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthColorChooserUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthComboBoxUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthComboBoxUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthDesktopIconUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthDesktopIconUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthDesktopPaneUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthDesktopPaneUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      protected void SynthEditorPaneUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthInternalFrameUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthInternalFrameUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthLabelUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthLabelUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthMenuBarUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthMenuBarUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthMenuItemUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthMenuItemUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthMenuUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthMenuUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthOptionPaneUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthOptionPaneUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthPanelUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthPanelUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthPopupMenuUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthPopupMenuUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthProgressBarUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthProgressBarUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthRootPaneUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthRootPaneUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthScrollBarUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthScrollBarUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthScrollPaneUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthScrollPaneUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthSeparatorUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthSeparatorUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthSliderUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthSliderUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthSpinnerUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthSpinnerUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthSplitPaneUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthSplitPaneUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthTabbedPaneUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthTabbedPaneUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthTableHeaderUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthTableHeaderUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthTableUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthTableUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      protected void SynthTextAreaUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      protected void SynthTextFieldUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthToolBarUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthToolBarUI.paint​(SynthContext context, Graphics g)
      绘制工具栏。
      void SynthToolTipUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthToolTipUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthTreeUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthTreeUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthViewportUI.paint​(Graphics g, JComponent c)
      根据外观和外观绘制指定的组件。
      protected void SynthViewportUI.paint​(SynthContext context, Graphics g)
      绘制指定的组件。
      void SynthPainter.paintArrowButtonBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制箭头按钮的背景。
      void SynthPainter.paintArrowButtonBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个箭头按钮的边框。
      void SynthPainter.paintArrowButtonForeground​(SynthContext context, Graphics g, int x, int y, int w, int h, int direction)
      画一个箭头按钮的前景。
      protected void SynthEditorPaneUI.paintBackground​(Graphics g)
      绘制视图的背景。
      protected void SynthTextAreaUI.paintBackground​(Graphics g)
      绘制视图的背景。
      protected void SynthTextFieldUI.paintBackground​(Graphics g)
      绘制视图的背景。
      void SynthButtonUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthCheckBoxMenuItemUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthCheckBoxUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthColorChooserUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthComboBoxUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthDesktopIconUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthDesktopPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthEditorPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthFormattedTextFieldUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthInternalFrameUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthLabelUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthListUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthMenuBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthMenuItemUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthMenuUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthOptionPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthPanelUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthPasswordFieldUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthPopupMenuUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthProgressBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthRadioButtonMenuItemUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthRadioButtonUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthRootPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthScrollBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthScrollPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthSeparatorUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthSliderUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthSpinnerUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthSplitPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthTabbedPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthTableHeaderUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthTableUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthTextAreaUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthTextFieldUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthTextPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthToggleButtonUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthToolBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthToolTipUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthTreeUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthViewportUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画边框
      void SynthPainter.paintButtonBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个按钮的背景。
      void SynthPainter.paintButtonBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个按钮的边框。
      void SynthPainter.paintCheckBoxBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个复选框的背景。
      void SynthPainter.paintCheckBoxBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个复选框的边框。
      void SynthPainter.paintCheckBoxMenuItemBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制复选框菜单项的背景。
      void SynthPainter.paintCheckBoxMenuItemBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制复选框菜单项的边框。
      void SynthPainter.paintColorChooserBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个颜色选择器的背景。
      void SynthPainter.paintColorChooserBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制颜色选择器的边框。
      void SynthPainter.paintComboBoxBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个组合框的背景。
      void SynthPainter.paintComboBoxBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个组合框的边框。
      protected void SynthToolBarUI.paintContent​(SynthContext context, Graphics g, Rectangle bounds)
      绘制工具栏内容。
      void SynthComboBoxUI.paintCurrentValue​(Graphics g, Rectangle bounds, boolean hasFocus)
      绘制当前选定的项目。
      void SynthPainter.paintDesktopIconBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制桌面图标的背景。
      void SynthPainter.paintDesktopIconBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制桌面图标的边框。
      void SynthPainter.paintDesktopPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制桌面窗格的背景。
      void SynthPainter.paintDesktopPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制桌面窗格的背景。
      protected void SynthToolBarUI.paintDragWindow​(Graphics g)
      绘制用于拖动的窗口的内容。
      protected void SynthTreeUI.paintDropLine​(Graphics g)
      画下线。
      void SynthPainter.paintEditorPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制编辑器窗格的背景。
      void SynthPainter.paintEditorPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制编辑器窗格的边框。
      protected void SynthTreeUI.paintExpandControl​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的展开（切换）部分。
      void SynthPainter.paintFileChooserBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制文件选择器的背景。
      void SynthPainter.paintFileChooserBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制文件选择器的边框。
      void SynthPainter.paintFormattedTextFieldBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制格式化文本字段的背景。
      void SynthPainter.paintFormattedTextFieldBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制格式化文本字段的边框。
      protected void SynthTreeUI.paintHorizontalLine​(Graphics g, JComponent c, int y, int left, int right)
      画一条水平线。
      protected void SynthTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      涂抹腿部的水平部分。
      static void SynthGraphicsUtils.paintIcon​(Icon icon, SynthContext context, Graphics g, int x, int y, int width, int height)
      画图标。
      default void | SynthIcon.paintIcon​(Component c, Graphics g, int x, int y)
      void SynthIcon.paintIcon​(SynthContext context, Graphics g, int x, int y, int width, int height)
      在给定的合成器上下文的指定位置绘制图标。
      void SynthPainter.paintInternalFrameBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      描绘内部框架的背景。
      void SynthPainter.paintInternalFrameBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制内部框架的边框。
      void SynthPainter.paintInternalFrameTitlePaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制内部框架标题窗格的背景。
      void SynthPainter.paintInternalFrameTitlePaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制内部框架标题窗格的边框。
      void SynthPainter.paintLabelBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      涂上标签的背景。
      void SynthPainter.paintLabelBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      涂上标签的边框。
      void SynthPainter.paintListBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制列表的背景。
      void SynthPainter.paintListBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制列表的边框。
      void SynthPainter.paintMenuBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个菜单的背景。
      void SynthPainter.paintMenuBarBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个菜单栏的背景。
      void SynthPainter.paintMenuBarBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制菜单栏的边框。
      void SynthPainter.paintMenuBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个菜单的边框。
      void SynthPainter.paintMenuItemBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制菜单项的背景。
      void SynthPainter.paintMenuItemBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制菜单项的边框。
      void SynthPainter.paintOptionPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制选项窗格的背景。
      void SynthPainter.paintOptionPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制选项窗格的边框。
      void SynthPainter.paintPanelBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个面板的背景。
      void SynthPainter.paintPanelBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个面板的边框。
      void SynthPainter.paintPasswordFieldBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个密码字段的背景。
      void SynthPainter.paintPasswordFieldBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制密码字段的边框。
      void SynthPainter.paintPopupMenuBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个弹出菜单的背景。
      void SynthPainter.paintPopupMenuBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制弹出菜单的边框。
      void SynthPainter.paintProgressBarBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个进度条的背景。
      void SynthPainter.paintProgressBarBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      画一个进度条的背景。
      void SynthPainter.paintProgressBarBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制进度条的边框。
      void SynthPainter.paintProgressBarBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制进度条的边框。
      void SynthPainter.paintProgressBarForeground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制进度条的前景。 负责提供进度条进度的指示。
      void SynthPainter.paintRadioButtonBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个单选按钮的背景。
      void SynthPainter.paintRadioButtonBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个单选按钮的边框。
      void SynthPainter.paintRadioButtonMenuItemBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制单选按钮菜单项的背景。
      void SynthPainter.paintRadioButtonMenuItemBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制单选按钮菜单项的边框。
      void SynthPainter.paintRootPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制根窗格的背景。
      void SynthPainter.paintRootPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制根窗格的边框。
      void SynthPainter.paintScrollBarBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滚动条的背景。
      void SynthPainter.paintScrollBarBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滚动条的背景。
      void SynthPainter.paintScrollBarBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滚动条的边框。
      void SynthPainter.paintScrollBarBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滚动条的边框。
      void SynthPainter.paintScrollBarThumbBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      画一个滚动条的拇指的背景。
      void SynthPainter.paintScrollBarThumbBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滚动条的拇指的边框。
      void SynthPainter.paintScrollBarTrackBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滚动条的轨迹的背景。
      void SynthPainter.paintScrollBarTrackBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滚动条的轨迹的背景。
      void SynthPainter.paintScrollBarTrackBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滚动条轨迹的边框。
      void SynthPainter.paintScrollBarTrackBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滚动条轨迹的边框。
      void SynthPainter.paintScrollPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滚动窗格的背景。
      void SynthPainter.paintScrollPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滚动窗格的边框。
      void SynthPainter.paintSeparatorBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个分隔符的背景。
      void SynthPainter.paintSeparatorBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      画一个分隔符的背景。
      void SynthPainter.paintSeparatorBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制分隔符的边框。
      void SynthPainter.paintSeparatorBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制分隔符的边框。
      void SynthPainter.paintSeparatorForeground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      画一个分隔符的前景。
      void SynthPainter.paintSliderBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滑块的背景。
      void SynthPainter.paintSliderBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滑块的背景。
      void SynthPainter.paintSliderBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滑块的边框。
      void SynthPainter.paintSliderBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滑块的边框。
      void SynthPainter.paintSliderThumbBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滑块的拇指的背景。
      void SynthPainter.paintSliderThumbBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滑块的拇指的边框。
      void SynthPainter.paintSliderTrackBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滑块的轨迹的背景。
      void SynthPainter.paintSliderTrackBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滑块的轨迹的背景。
      void SynthPainter.paintSliderTrackBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制滑块轨迹的边框。
      void SynthPainter.paintSliderTrackBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制滑块轨迹的边框。
      void SynthPainter.paintSpinnerBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个旋转器的背景。
      void SynthPainter.paintSpinnerBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个旋转器的边框。
      void SynthPainter.paintSplitPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制拆分窗格的背景。
      void SynthPainter.paintSplitPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制拆分窗格的边框。
      void SynthPainter.paintSplitPaneDividerBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制拆分窗格的分隔符的背景。
      void SynthPainter.paintSplitPaneDividerBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制拆分窗格的分隔符的背景。
      void SynthPainter.paintSplitPaneDividerForeground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制拆分窗格的分隔符的前景。
      void SynthPainter.paintSplitPaneDragDivider​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      当用户拖动分隔线时，绘制分割窗格的分隔线。
      protected void | SynthTabbedPaneUI.paintTabArea​(Graphics g, int tabPlacement, int selectedIndex)
      void SynthPainter.paintTabbedPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制标签窗格的背景。
      void SynthPainter.paintTabbedPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制标签窗格的边框。
      void SynthPainter.paintTabbedPaneContentBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制包含选项卡窗格选定选项卡内容的区域的背景。
      void SynthPainter.paintTabbedPaneContentBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制包含选项卡窗格选定选项卡内容的区域的边框。
      void SynthPainter.paintTabbedPaneTabAreaBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制标签窗格的选项卡后面区域的背景。
      void SynthPainter.paintTabbedPaneTabAreaBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制标签窗格的选项卡后面区域的背景。
      void SynthPainter.paintTabbedPaneTabAreaBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制标签窗格的标签后面区域的边框。
      void SynthPainter.paintTabbedPaneTabAreaBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制标签窗格的标签后面区域的边框。
      void SynthPainter.paintTabbedPaneTabBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex)
      绘制标签窗格的选项卡的背景。
      void SynthPainter.paintTabbedPaneTabBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation)
      绘制标签窗格的选项卡的背景。
      void SynthPainter.paintTabbedPaneTabBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex)
      绘制标签窗格的选项卡的边框。
      void SynthPainter.paintTabbedPaneTabBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation)
      绘制标签窗格的选项卡的边框。
      void SynthPainter.paintTableBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一张桌子的背景。
      void SynthPainter.paintTableBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一张桌子的边框。
      void SynthPainter.paintTableHeaderBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制表格标题的背景。
      void SynthPainter.paintTableHeaderBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制表格标题的边框。
      void SynthGraphicsUtils.paintText​(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex)
      在指定位置绘制文本。
      void SynthGraphicsUtils.paintText​(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex)
      在指定位置绘制文本。
      void SynthGraphicsUtils.paintText​(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset)
      画一个图标和文字。
      protected void SynthProgressBarUI.paintText​(SynthContext context, Graphics g, String title)
      绘制组件的文本。
      void SynthPainter.paintTextAreaBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个文本区域的背景。
      void SynthPainter.paintTextAreaBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制文本区域的边框。
      void SynthPainter.paintTextFieldBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制文本字段的背景。
      void SynthPainter.paintTextFieldBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制文本字段的边框。
      void SynthPainter.paintTextPaneBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制文本窗格的背景。
      void SynthPainter.paintTextPaneBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制文本窗格的边框。
      protected void SynthScrollBarUI.paintThumb​(SynthContext context, Graphics g, Rectangle thumbBounds)
      绘制滚动条拇指。
      protected void SynthSliderUI.paintThumb​(SynthContext context, Graphics g, Rectangle thumbBounds)
      绘制滑块拇指。
      void SynthPainter.paintToggleButtonBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一个切换按钮的背景。
      void SynthPainter.paintToggleButtonBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制切换按钮的边框。
      void SynthPainter.paintToolBarBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制工具栏的背景。
      void SynthPainter.paintToolBarBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制工具栏的背景。
      void SynthPainter.paintToolBarBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制工具栏的边框。
      void SynthPainter.paintToolBarBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制工具栏的边框。
      void SynthPainter.paintToolBarContentBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制工具栏内容区域的背景。
      void SynthPainter.paintToolBarContentBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制工具栏内容区域的背景。
      void SynthPainter.paintToolBarContentBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制工具栏的内容区域的边框。
      void SynthPainter.paintToolBarContentBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制工具栏的内容区域的边框。
      void SynthPainter.paintToolBarDragWindowBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制包含工具栏的窗口的背景，当它与主框架分离时。
      void SynthPainter.paintToolBarDragWindowBackground​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制包含工具栏的窗口的背景，当它与主框架分离时。
      void SynthPainter.paintToolBarDragWindowBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制包含工具栏的窗口的边框，当它与主框架分离时。
      void SynthPainter.paintToolBarDragWindowBorder​(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      绘制包含工具栏的窗口的边框，当它与主框架分离时。
      void SynthPainter.paintToolTipBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      描绘工具提示的背景。
      void SynthPainter.paintToolTipBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      涂抹工具尖端的边框。
      protected void SynthScrollBarUI.paintTrack​(SynthContext context, Graphics g, Rectangle trackBounds)
      绘制滚动条轨道。
      protected void SynthSliderUI.paintTrack​(SynthContext context, Graphics g, Rectangle trackBounds)
      绘制滑块轨道。
      void SynthPainter.paintTreeBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一棵树的背景。
      void SynthPainter.paintTreeBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      画一棵树的边界。
      void SynthPainter.paintTreeCellBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      在树中绘制包含单元格的行的背景。
      void SynthPainter.paintTreeCellBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制包含树中单元格的行的边框。
      void SynthPainter.paintTreeCellFocus​(SynthContext context, Graphics g, int x, int y, int w, int h)
      在树中具有焦点时，绘制单元格的焦点指示符。
      protected void SynthTreeUI.paintVerticalLine​(Graphics g, JComponent c, int x, int top, int bottom)
      画一条垂直线。
      protected void SynthTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      涂上腿部的垂直部分。
      void SynthPainter.paintViewportBackground​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制视口的背景。
      void SynthPainter.paintViewportBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)
      绘制视口的边框。
      void SynthButtonUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthColorChooserUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthComboBoxUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthDesktopIconUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthDesktopPaneUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthEditorPaneUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthInternalFrameUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthLabelUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthListUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthMenuBarUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthMenuItemUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthMenuUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthOptionPaneUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthPanelUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthPopupMenuUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthProgressBarUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthRootPaneUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthScrollBarUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthScrollPaneUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthSeparatorUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthSliderUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthSpinnerUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthSplitPaneUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthTabbedPaneUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthTableHeaderUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthTableUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthTextAreaUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthTextFieldUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthToolBarUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthToolTipUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthTreeUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。
      void SynthViewportUI.update​(Graphics g, JComponent c)
      通知此UI代理重新绘制指定的组件。

    • Uses of Graphics in javax.swing.text

      Methods in javax.swing.text that return Graphics
      Modifier and Type 方法 描述
      Graphics View.getGraphics​()
      获取 Graphics进行渲染。
      Methods in javax.swing.text with parameters of type Graphics
      Modifier and Type | 方法 | 描述
      protected int PasswordView.drawEchoCharacter​(Graphics g, int x, int y, char c)
      已过时。
      代之以PasswordView.drawEchoCharacter(Graphics2D, float, float, char)
      protected void PlainView.drawLine​(int lineIndex, Graphics g, int x, int y)
      已过时。
      替换为PlainView.drawLine(int, Graphics2D, float, float)
      protected void WrappedPlainView.drawLine​(int p0, int p1, Graphics g, int x, int y)
      已过时。
      替换为WrappedPlainView.drawLine(int, int, Graphics2D, float, float)
      protected int PasswordView.drawSelectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为PasswordView.drawSelectedText(Graphics2D, float, float, int, int)
      protected int PlainView.drawSelectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为PlainView.drawSelectedText(Graphics2D, float, float, int, int)
      protected int WrappedPlainView.drawSelectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      由WrappedPlainView.drawSelectedText(Graphics2D, float, float, int, int)取代
      static int Utilities.drawTabbedText​(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.drawTabbedText(Segment, float, float, Graphics2D, TabExpander, int)
      protected int PasswordView.drawUnselectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为PasswordView.drawUnselectedText(Graphics2D, float, float, int, int)
      protected int PlainView.drawUnselectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为PlainView.drawUnselectedText(Graphics2D, float, float, int, int)
      protected int WrappedPlainView.drawUnselectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为WrappedPlainView.drawUnselectedText(Graphics2D, float, float, int, int)
      void AsyncBoxView.paint​(Graphics g, Shape alloc)
      使用给定的分配和渲染表面渲染视图。
      void BoxView.paint​(Graphics g, Shape allocation)
      使用给定的渲染表面和该表面上的区域渲染 BoxView 。
      void Caret.paint​(Graphics g)
      渲染插入符号。
      void ComponentView.paint​(Graphics g, Shape a)
      真正的绘画行为自然地发生在组件与其父容器（托管此视图的同一容器）的关联中。
      void DefaultCaret.paint​(Graphics g)
      将插入符号作为垂直线。
      void DefaultHighlighter.DefaultHighlightPainter.paint​(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c)
      画亮点
      void DefaultHighlighter.paint​(Graphics g)
      渲染亮点。
      void FieldView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      abstract void GlyphView.GlyphPainter.paint​(GlyphView v, Graphics g, Shape a, int p0, int p1)
      绘制表示给定范围的字形。
      void GlyphView.paint​(Graphics g, Shape a)
      渲染文本样式运行的一部分。
      void Highlighter.HighlightPainter.paint​(Graphics g, int p0, int p1, Shape bounds, JTextComponent c)
      渲染亮点。
      void Highlighter.paint​(Graphics g)
      渲染亮点。
      void IconView.paint​(Graphics g, Shape a)
      画图标。
      void ParagraphView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      void PlainView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      abstract void View.paint​(Graphics g, Shape allocation)
      渲染使用给定的渲染表面和该表面上的区域。
      void WrappedPlainView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      protected void BoxView.paintChild​(Graphics g, Rectangle alloc, int index)
      涂一个孩子
      void AsyncBoxView.ChildLocator.paintChildren​(Graphics g)
      绘制与剪辑区域相交的孩子。
      Shape DefaultHighlighter.DefaultHighlightPainter.paintLayer​(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view)
      画出一部分亮点。
      abstract Shape | LayeredHighlighter.LayerPainter.paintLayer​(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      void DefaultHighlighter.paintLayeredHighlights​(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      当叶视图（如LabelView）呈现时，它们应该调用此方法。
      abstract void LayeredHighlighter.paintLayeredHighlights​(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      当叶视图（如LabelView）呈现时，它们应该调用此方法。

    • Uses of Graphics in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Graphics
      Modifier and Type 方法 描述
      void BlockView.paint​(Graphics g, Shape allocation)
      渲染使用给定的渲染表面和该表面上的区域。
      void ImageView.paint​(Graphics g, Shape a)
      绘制视图。
      void ListView.paint​(Graphics g, Shape allocation)
      渲染使用给定的渲染表面和该表面上的区域。
      void ParagraphView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      void StyleSheet.BoxPainter.paint​(Graphics g, float x, float y, float w, float h, View v)
      根据给出的属性绘制CSS框。
      void StyleSheet.ListPainter.paint​(Graphics g, float x, float y, float w, float h, View v, int item)
      根据给出的属性绘制CSS列表装饰。
      protected void ListView.paintChild​(Graphics g, Rectangle alloc, int index)
      画一个孩子; 由paint（）调用。

    • Uses of Graphics in javax.swing.tree

      Methods in javax.swing.tree with parameters of type Graphics
      Modifier and Type 方法 描述
      void DefaultTreeCellEditor.EditorContainer.paint​(Graphics g)
      覆盖 Container.paint以绘制节点的图标，并使用背景的选择颜色。
      void DefaultTreeCellRenderer.paint​(Graphics g)
      绘制价值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GraphicsConfigTemplate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GraphicsConfigTemplate

  • Packages that use GraphicsConfigTemplate
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of GraphicsConfigTemplate in java.awt

      Methods in java.awt with parameters of type GraphicsConfigTemplate
      Modifier and Type 方法 描述
      GraphicsConfiguration GraphicsDevice.getBestConfiguration​(GraphicsConfigTemplate gct)
      返回可能通过GraphicsConfigTemplate中定义的条件的“最佳”配置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GraphicsConfiguration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GraphicsConfiguration

  • Packages that use GraphicsConfiguration
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of GraphicsConfiguration in java.awt

      Methods in java.awt that return GraphicsConfiguration
      Modifier and Type 方法 描述
      abstract GraphicsConfiguration GraphicsConfigTemplate.getBestConfiguration​(GraphicsConfiguration[] gc)
      返回可能通过 GraphicsConfigTemplate定义的条件的“最佳”配置。
      GraphicsConfiguration GraphicsDevice.getBestConfiguration​(GraphicsConfigTemplate gct)
      返回可能通过GraphicsConfigTemplate中定义的条件的“最佳”配置。
      abstract GraphicsConfiguration[] GraphicsDevice.getConfigurations​()
      返回与此 GraphicsDevice相关联的所有 GraphicsConfiguration对象。
      abstract GraphicsConfiguration GraphicsDevice.getDefaultConfiguration​()
      返回默认 GraphicsConfiguration与此相关 GraphicsDevice 。
      abstract GraphicsConfiguration Graphics2D.getDeviceConfiguration​()
      返回与此 Graphics2D关联的设备配置。
      GraphicsConfiguration Component.getGraphicsConfiguration​()
      获取 GraphicsConfiguration与此 Component相关联。
      Methods in java.awt with parameters of type GraphicsConfiguration
      Modifier and Type 方法 描述
      abstract GraphicsConfiguration GraphicsConfigTemplate.getBestConfiguration​(GraphicsConfiguration[] gc)
      返回可能通过 GraphicsConfigTemplate定义的条件的“最佳”配置。
      ImageCapabilities Image.getCapabilities​(GraphicsConfiguration gc)
      返回一个ImageCapabilities对象，可以在指定的GraphicsConfiguration上查询该Image的功能。
      Insets Toolkit.getScreenInsets​(GraphicsConfiguration gc)
      获取屏幕的插图。
      abstract boolean GraphicsConfigTemplate.isGraphicsConfigSupported​(GraphicsConfiguration gc)
      返回一个 boolean指示是否可以使用指定的 GraphicsConfiguration来创建支持指定功能的绘图面。
      Constructors in java.awt with parameters of type GraphicsConfiguration
      Constructor 描述
      Canvas​(GraphicsConfiguration config)
      给一个GraphicsConfiguration对象构造一个新的Canvas。
      Dialog​(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
      构造最初无形 Dialog与指定的所有者 Dialog ，标题，模式和 GraphicsConfiguration 。
      Dialog​(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
      构造最初不可见的 Dialog与指定的所有者 Frame ，标题，模态和 GraphicsConfiguration 。
      Dialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      构造最初不可见的 Dialog与指定的所有者 Window ，标题，模式和 GraphicsConfiguration 。
      Frame​(GraphicsConfiguration gc)
      构造一个新的，最初看不到的 Frame ，其中指定的是 GraphicsConfiguration 。
      Frame​(String title, GraphicsConfiguration gc)
      构造一个新的，最初不可见的 Frame对象与指定的标题和一个 GraphicsConfiguration 。
      Window​(Window owner, GraphicsConfiguration gc)
      构造一个新的最初不可见的窗口，其中指定的所有者为 Window和屏幕设备的 GraphicsConfiguration 。

    • Uses of GraphicsConfiguration in java.awt.image

      Methods in java.awt.image with parameters of type GraphicsConfiguration
      Modifier and Type 方法 描述
      abstract int VolatileImage.validate​(GraphicsConfiguration gc)
      如果自上一次 validate调用后表面已丢失，则尝试恢复图像的绘图面。

    • Uses of GraphicsConfiguration in javax.print

      Methods in javax.print with parameters of type GraphicsConfiguration
      Modifier and Type 方法 描述
      static PrintService ServiceUI.printDialog​(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      向用户呈现一个对话框，用于选择打印服务（打印机）。

    • Uses of GraphicsConfiguration in javax.swing

      Constructors in javax.swing with parameters of type GraphicsConfiguration
      Constructor 描述
      JDialog​(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
      创建一个具有指定标题的对话框，所有者 Dialog ，模式和 GraphicsConfiguration 。
      JDialog​(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
      创建一个具有指定标题的对话框，所有者 Frame ，模态和 GraphicsConfiguration 。
      JDialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      创建一个具有指定标题的对话框，所有者 Window ，模态和 GraphicsConfiguration 。
      JFrame​(GraphicsConfiguration gc)
      在屏幕设备的指定 GraphicsConfiguration中创建一个 Frame和一个空白标题。
      JFrame​(String title, GraphicsConfiguration gc)
      创建 JFrame具有指定标题和指定 GraphicsConfiguration屏幕设备的。
      JWindow​(GraphicsConfiguration gc)
      使用指定的屏幕设备 GraphicsConfiguration创建一个窗口。
      JWindow​(Window owner, GraphicsConfiguration gc)
      创建具有指定所有者窗口的窗口和屏幕设备的 GraphicsConfiguration 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GraphicsDevice (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GraphicsDevice

  • Packages that use GraphicsDevice
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of GraphicsDevice in java.awt

      Methods in java.awt that return GraphicsDevice
      Modifier and Type 方法 描述
      abstract GraphicsDevice GraphicsEnvironment.getDefaultScreenDevice​()
      返回默认画面 GraphicsDevice 。
      abstract GraphicsDevice GraphicsConfiguration.getDevice​()
      返回GraphicsDevice与此GraphicsConfiguration相关联。
      GraphicsDevice PointerInfo.getDevice​()
      返回 GraphicsDevice其中鼠标指针是在创建这个 PointerInfo的时刻。
      abstract GraphicsDevice[] GraphicsEnvironment.getScreenDevices​()
      返回所有屏幕 GraphicsDevice对象的数组。
      Constructors in java.awt with parameters of type GraphicsDevice
      Constructor 描述
      Robot​(GraphicsDevice screen)
      为给定的屏幕设备创建一个机器人。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GraphicsDevice.WindowTranslucency (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GraphicsDevice.WindowTranslucency

  • Packages that use GraphicsDevice.WindowTranslucency
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of GraphicsDevice.WindowTranslucency in java.awt

      Methods in java.awt that return GraphicsDevice.WindowTranslucency
      Modifier and Type 方法 描述
      static GraphicsDevice.WindowTranslucency GraphicsDevice.WindowTranslucency.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static GraphicsDevice.WindowTranslucency[] GraphicsDevice.WindowTranslucency.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type GraphicsDevice.WindowTranslucency
      Modifier and Type 方法 描述
      boolean GraphicsDevice.isWindowTranslucencySupported​(GraphicsDevice.WindowTranslucency translucencyKind)
      返回此图形设备是否支持给定的半透明级别。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GraphicsEnvironment (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GraphicsEnvironment

  • Packages that use GraphicsEnvironment
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of GraphicsEnvironment in java.awt

      Methods in java.awt that return GraphicsEnvironment
      Modifier and Type 方法 描述
      static GraphicsEnvironment GraphicsEnvironment.getLocalGraphicsEnvironment​()
      返回本地 GraphicsEnvironment 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GridBagConstraints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GridBagConstraints

  • Packages that use GridBagConstraints
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of GridBagConstraints in java.awt

      Fields in java.awt declared as GridBagConstraints
      Modifier and Type Field 描述
      protected GridBagConstraints GridBagLayout.defaultConstraints
      该字段包含包含默认值的网格包约束实例，因此如果组件没有与其相关联的网格包约束，则将为该组件分配 defaultConstraints的副本。
      Fields in java.awt with type parameters of type GridBagConstraints
      Modifier and Type Field 描述
      protected Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
      这个散列表维护了一个组件与其gridbag约束之间的关联。
      Methods in java.awt that return GridBagConstraints
      Modifier and Type 方法 描述
      GridBagConstraints GridBagLayout.getConstraints​(Component comp)
      获取指定组件的约束。
      protected GridBagConstraints GridBagLayout.lookupConstraints​(Component comp)
      检索指定组件的约束。
      Methods in java.awt with parameters of type GridBagConstraints
      Modifier and Type 方法 描述
      protected void GridBagLayout.adjustForGravity​(GridBagConstraints constraints, Rectangle r)
      根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
      protected void GridBagLayout.AdjustForGravity​(GridBagConstraints constraints, Rectangle r)
      根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
      void GridBagLayout.setConstraints​(Component comp, GridBagConstraints constraints)
      设置此布局中指定组件的约束。

    • Uses of GridBagConstraints in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type GridBagConstraints
      Modifier and Type 方法 描述
      protected void BasicOptionPaneUI.addMessageComponents​(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)
      创建适当的对象来表示 msg并将其放入 container 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GridBagLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GridBagLayout

No usage of java.awt.GridBagLayout
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GridBagLayoutInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GridBagLayoutInfo

  • Packages that use GridBagLayoutInfo
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of GridBagLayoutInfo in java.awt

      Fields in java.awt declared as GridBagLayoutInfo
      Modifier and Type Field 描述
      protected GridBagLayoutInfo GridBagLayout.layoutInfo
      该字段保存网格包的布局信息。
      Methods in java.awt that return GridBagLayoutInfo
      Modifier and Type 方法 描述
      protected GridBagLayoutInfo GridBagLayout.getLayoutInfo​(Container parent, int sizeflag)
      GridBagLayoutInfo当前管理子集的一个 GridBagLayoutInfo的例子。
      protected GridBagLayoutInfo GridBagLayout.GetLayoutInfo​(Container parent, int sizeflag)
      此方法已过时，仅供后向兼容; 新代码应该调用getLayoutInfo 。
      Methods in java.awt with parameters of type GridBagLayoutInfo
      Modifier and Type 方法 描述
      protected Dimension GridBagLayout.getMinSize​(Container parent, GridBagLayoutInfo info)
      根据 getLayoutInfo的信息， getLayoutInfo主站的最小尺寸。
      protected Dimension GridBagLayout.GetMinSize​(Container parent, GridBagLayoutInfo info)
      此方法已过时，仅供后向兼容; 新代码应该调用getMinSize 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.GridLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.GridLayout

No usage of java.awt.GridLayout
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.HeadlessException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.HeadlessException

  • Packages that use HeadlessException
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.print
    提供通用打印API的类和接口。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of HeadlessException in java.applet

      Constructors in java.applet that throw HeadlessException
      Constructor 描述
      Applet​()
      已过时。
      构建一个新的Applet。

    • Uses of HeadlessException in java.awt

      Methods in java.awt that throw HeadlessException
      Modifier and Type 方法 描述
      boolean Toolkit.areExtraMouseButtonsEnabled​()
      报告是否允许来自额外的鼠标按钮的事件被处理并发布到 EventQueue 。
      Cursor Toolkit.createCustomCursor​(Image cursor, Point hotSpot, String name)
      创建一个新的自定义光标对象。
      Dimension Toolkit.getBestCursorSize​(int preferredWidth, int preferredHeight)
      返回最接近所需大小的支持的光标维度。
      Point GraphicsEnvironment.getCenterPoint​()
      返回Windows应该居中的点。
      abstract ColorModel Toolkit.getColorModel​()
      确定该工具包屏幕的颜色模型。
      abstract GraphicsDevice GraphicsEnvironment.getDefaultScreenDevice​()
      返回默认画面 GraphicsDevice 。
      int Toolkit.getMaximumCursorColors​()
      返回Toolkit在自定义光标调色板中支持的最大颜色数。
      Rectangle GraphicsEnvironment.getMaximumWindowBounds​()
      返回居中Windows的最大边界。
      int Toolkit.getMenuShortcutKeyMask​()
      确定哪个修饰键是菜单快捷键的适当加速键。
      Point Component.getMousePosition​()
      如果 Component是直接在鼠标指针下面，则返回鼠标指针在 Component的坐标空间中的位置，否则返回 null 。
      Point Container.getMousePosition​(boolean allowChildren)
      返回鼠标指针在该位置 Container的坐标空间，如果 Container是鼠标指针下，否则返回 null 。
      static int MouseInfo.getNumberOfButtons​()
      返回鼠标的按钮数量。
      static PointerInfo MouseInfo.getPointerInfo​()
      返回表示鼠标指针当前位置的 PointerInfo实例。
      abstract GraphicsDevice[] GraphicsEnvironment.getScreenDevices​()
      返回所有屏幕 GraphicsDevice对象的数组。
      Insets Toolkit.getScreenInsets​(GraphicsConfiguration gc)
      获取屏幕的插图。
      abstract int Toolkit.getScreenResolution​()
      以英寸为单位返回屏幕分辨率。
      abstract Dimension Toolkit.getScreenSize​()
      获取屏幕的大小。
      abstract Clipboard Toolkit.getSystemClipboard​()
      获取与本地平台提供的剪贴板工具接口的系统剪贴板的单例实例。
      static Cursor Cursor.getSystemCustomCursor​(String name)
      返回与指定名称匹配的特定于系统的自定义游标对象。
      Clipboard Toolkit.getSystemSelection​()
      获取系统选择的单例实例为 Clipboard对象。
      boolean Toolkit.isDynamicLayoutActive​()
      返回是否在底层操作系统和/或窗口管理器上启用了容器在resize上的动态布局。
      protected boolean Toolkit.isDynamicLayoutSet​()
      返回容器的布局在调整大小期间是否动态进行验证，或者在调整大小之后静态地验证。
      boolean Toolkit.isFrameStateSupported​(int state)
      返回Toolkit是否支持 Frame的状态。
      protected void Toolkit.loadSystemColors​(int[] systemColors)
      填充以当前系统颜色值作为参数提供的整数数组。
      abstract Map<TextAttribute,?> Toolkit.mapInputMethodHighlight​(InputMethodHighlight highlight)
      返回给定输入法突出显示的抽象级别描述的可视属性映射，如果没有找到映射，则返回null。
      void Toolkit.setDynamicLayout​(boolean dynamic)
      控制容器的布局在调整大小期间是否动态地进行验证，或者在调整大小之后静态地进行。
      Constructors in java.awt that throw HeadlessException
      Constructor 描述
      Button​()
      构造一个带有标签的空字符串的按钮。
      Button​(String label)
      构造具有指定标签的按钮。
      Checkbox​()
      为其标签创建一个带有空字符串的复选框。
      Checkbox​(String label)
      创建一个带有指定标签的复选框。
      Checkbox​(String label, boolean state)
      创建一个带有指定标签的复选框，并设置指定的状态。
      Checkbox​(String label, boolean state, CheckboxGroup group)
      构造具有指定标签的复选框，设置为指定的状态，并在指定的复选框组中。
      Checkbox​(String label, CheckboxGroup group, boolean state)
      在指定的复选框组中创建带有指定标签的复选框，并设置为指定的状态。
      CheckboxMenuItem​()
      创建一个带有空标签的复选框菜单项。
      CheckboxMenuItem​(String label)
      创建带有指定标签的复选框菜单项。
      CheckboxMenuItem​(String label, boolean state)
      创建带有指定标签和状态的复选框菜单项。
      Choice​()
      创建一个新的选择菜单。
      Frame​()
      构造最初不可见的新实例 Frame 。
      Frame​(String title)
      构造一个新的，最初不可见的 Frame具有指定标题的对象。
      Label​()
      构造一个空标签。
      Label​(String text)
      用指定的文本字符串构造一个新的标签，左对齐。
      Label​(String text, int alignment)
      构造一个新的标签，以指定的对齐方式显示指定的文本字符串。
      List​()
      创建一个新的滚动列表。
      List​(int rows)
      创建一个以指定数量的可见行初始化的新滚动列表。
      List​(int rows, boolean multipleMode)
      创建一个初始化的新滚动列表，以显示指定的行数。
      Menu​()
      构造一个带有空标签的新菜单。
      Menu​(String label)
      构造一个带有指定标签的新菜单。
      Menu​(String label, boolean tearOff)
      构造具有指定标签的新菜单，指示菜单是否可以被拆除。
      MenuBar​()
      创建一个新的菜单栏。
      MenuComponent​()
      创建一个 MenuComponent 。
      MenuItem​()
      构造一个带有空标签的新菜单项，而不需要键盘快捷方式。
      MenuItem​(String label)
      使用指定的标签构建一个新的MenuItem，而不需要键盘快捷方式。
      MenuItem​(String label, MenuShortcut s)
      创建一个带有相关键盘快捷方式的菜单项。
      PopupMenu​()
      创建一个空名称的新的弹出菜单。
      PopupMenu​(String label)
      创建一个具有指定名称的新弹出菜单。
      Scrollbar​()
      构造一个新的垂直滚动条。
      Scrollbar​(int orientation)
      构造具有指定方向的新滚动条。
      Scrollbar​(int orientation, int value, int visible, int minimum, int maximum)
      构造具有指定方向，初始值，可见量以及最小值和最大值的新滚动条。
      ScrollPane​()
      创建一个滚动条显示策略为“根据需要”的新的滚动容器。
      ScrollPane​(int scrollbarDisplayPolicy)
      创建一个新的scrollpane容器。
      TextArea​()
      构造一个新的文本区域，空字符串作为文本。
      TextArea​(int rows, int columns)
      构造具有指定行数和列数的新文本区域，空字符串作为文本。
      TextArea​(String text)
      构造具有指定文本的新文本区域。
      TextArea​(String text, int rows, int columns)
      构造具有指定文本的新文本区域，并具有指定的行数和列数。
      TextArea​(String text, int rows, int columns, int scrollbars)
      构造具有指定文本的新文本区域，并按照指定的行，列和滚动条可见性构造。
      TextField​()
      构造一个新的文本字段。
      TextField​(int columns)
      构造具有指定列数的新的空文本字段。
      TextField​(String text)
      构造一个使用指定文本初始化的新文本字段。
      TextField​(String text, int columns)
      构造一个新的文本字段，并使用指定的文本进行初始化，以便显示，并且足够宽以容纳指定的列数。

    • Uses of HeadlessException in java.awt.dnd

      Constructors in java.awt.dnd that throw HeadlessException
      Constructor 描述
      DragSource​()
      创建一个新的 DragSource 。
      DropTarget​()
      创建一个 DropTarget 。
      DropTarget​(Component c, int ops, DropTargetListener dtl)
      创建一个 DropTarget给出了 Component来关联自己，一个 int表示默认可接受的操作支持，一个 DropTargetListener处理事件处理。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act)
      创建一个 DropTarget给出 Component以关联自己，一个 int表示默认可接受的动作以支持，一个 DropTargetListener处理事件处理，以及一个 boolean指示 DropTarget是否正在接受丢弃。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
      创建一个新的DropTarget，给出 Component以将自身关联，一个 int表示默认可接受的动作来支持，一个 DropTargetListener处理事件处理，一个 boolean指示 DropTarget是否正在接受丢弃，以及一个 FlavorMap使用（或null为默认值 FlavorMap ）。
      DropTarget​(Component c, DropTargetListener dtl)
      创建一个 DropTarget给出了 Component来关联自己，和 DropTargetListener来处理事件处理。

    • Uses of HeadlessException in java.awt.print

      Methods in java.awt.print that throw HeadlessException
      Modifier and Type 方法 描述
      abstract PageFormat PrinterJob.pageDialog​(PageFormat page)
      显示允许修改 PageFormat实例的对话框。
      PageFormat PrinterJob.pageDialog​(PrintRequestAttributeSet attributes)
      显示跨平台页面设置对话框的便捷方法。
      abstract boolean PrinterJob.printDialog​()
      向用户呈现一个对话框，用于更改打印作业的属性。
      boolean PrinterJob.printDialog​(PrintRequestAttributeSet attributes)
      一种方便的方法，显示可以使用 Pageable界面打印2D图形的所有服务的跨平台打印对话框。

    • Uses of HeadlessException in javax.print

      Methods in javax.print that throw HeadlessException
      Modifier and Type 方法 描述
      static PrintService ServiceUI.printDialog​(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      向用户呈现一个对话框，用于选择打印服务（打印机）。

    • Uses of HeadlessException in javax.swing

      Methods in javax.swing that throw HeadlessException
      Modifier and Type 方法 描述
      static JDialog JColorChooser.createDialog​(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
      创建并返回一个包含指定的 ColorChooser窗格的新对话框以及“确定”，“取消”和“重置”按钮。
      protected JDialog JFileChooser.createDialog​(Component parent)
      创建并返回一个新的 JDialog包装 this居中于 parent在 parent的帧。
      JDialog JOptionPane.createDialog​(Component parentComponent, String title)
      创建并返回一个新的 JDialog包装 this居中于 parentComponent在 parentComponent的帧。
      JDialog JOptionPane.createDialog​(String title)
      创建并返回具有指定标题的新的无父母 JDialog 。
      static Frame JOptionPane.getFrameForComponent​(Component parentComponent)
      返回指定的组件的 Frame 。
      static Frame JOptionPane.getRootFrame​()
      返回用于不提供框架的类方法的 Frame 。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive)
      按照功能全面的 print方法的说明打印此表，默认打印机指定为打印服务。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
      打印 JTable 。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message)
      启动对话框，选择是 ， 否和取消 ; 标题为“ 选择选项” 。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType)
      启动一个对话框，其中选择次数由 optionType参数决定。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType)
      调出其中的选项的数目由所确定的一个对话框 optionType参数，其中，所述 messageType参数确定要显示的图标。
      static int JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
      提出一个带有指定图标的对话框，其中选择的数量由 optionType参数确定。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor, boolean colorTransparencySelectionEnabled)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      int JFileChooser.showDialog​(Component parent, String approveButtonText)
      使用自定义批准按钮弹出自定义文件选择器对话框。
      static String JOptionPane.showInputDialog​(Component parentComponent, Object message)
      显示一个问题消息对话框，要求从父母的用户输入 parentComponent 。
      static String JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType)
      显示一个对话框，请求从用户父母的输入 parentComponent ，对话框标题为 title和消息类型 messageType 。
      static Object JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      在阻止对话框中提示用户输入，可以指定初始选择，可能的选择和所有其他选项。
      static String JOptionPane.showInputDialog​(Object message)
      显示一个请求用户输入的问题消息对话框。
      static void JOptionPane.showMessageDialog​(Component parentComponent, Object message)
      提供一个名为“消息”的信息消息对话框。
      static void JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType)
      使用由 messageType参数确定的默认图标显示消息的对话框。
      static void JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon)
      显示一个显示消息的对话框，指定所有参数。
      int JFileChooser.showOpenDialog​(Component parent)
      弹出一个“打开文件”文件选择器对话框。
      static int JOptionPane.showOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      启动具有指定图标的对话框，其中初始选择由 initialValue参数确定，选择次数由 optionType参数确定。
      int JFileChooser.showSaveDialog​(Component parent)
      弹出“保存文件”文件选择器对话框。
      Constructors in javax.swing that throw HeadlessException
      Constructor 描述
      JApplet​()
      已过时。
      创建一个swing applet实例。
      JFrame​()
      构造一个最初不可见的新框架。
      JFrame​(String title)
      创建一个新的，最初不可见的 Frame与指定的标题。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.IllegalComponentStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.IllegalComponentStateException

  • Packages that use IllegalComponentStateException
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of IllegalComponentStateException in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that throw IllegalComponentStateException
      Modifier and Type 方法 描述
      Locale Translator.getLocale​()
      获取组件的 Locale 。

    • Uses of IllegalComponentStateException in javax.accessibility

      Methods in javax.accessibility that throw IllegalComponentStateException
      Modifier and Type 方法 描述
      abstract Locale AccessibleContext.getLocale​()
      获取组件的区域设置。

    • Uses of IllegalComponentStateException in javax.swing

      Methods in javax.swing that throw IllegalComponentStateException
      Modifier and Type 方法 描述
      Locale ImageIcon.AccessibleImageIcon.getLocale​()
      返回此对象的区域设置。
      Locale ProgressMonitor.AccessibleProgressMonitor.getLocale​()
      Gets the locale of the component.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Image

  • Packages that use Image
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.awt.image
    提供创建和修改图像的类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。

    • Uses of Image in java.applet

      Methods in java.applet that return Image
      Modifier and Type 方法 描述
      Image Applet.getImage​(URL url)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      Image Applet.getImage​(URL url, String name)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。
      Image AppletContext.getImage​(URL url)
      已过时。
      返回一个 Image对象，然后可以在屏幕上绘制。

    • Uses of Image in java.awt

      Fields in java.awt declared as Image
      Modifier and Type Field 描述
      protected Image Component.FlipBufferStrategy.drawBuffer
      绘图缓冲区
      Methods in java.awt that return Image
      Modifier and Type | 方法 | 描述
      Image Component.createImage​(int width, int height)
      创建一个用于双缓冲的屏幕外可绘图像。
      Image Component.createImage​(ImageProducer producer)
      从指定的图像制作者创建图像。
      Image Toolkit.createImage​(byte[] imagedata)
      创建解码存储在指定字节数组中的图像的图像。
      abstract Image Toolkit.createImage​(byte[] imagedata, int imageoffset, int imagelength)
      创建一个图像，解码存储在指定字节数组中的图像，并以指定的偏移量和长度。
      abstract Image Toolkit.createImage​(ImageProducer producer)
      使用指定的图像生成器创建图像。
      abstract Image Toolkit.createImage​(String filename)
      返回从指定文件获取像素数据的图像。
      abstract Image Toolkit.createImage​(URL url)
      返回从指定的URL获取像素数据的图像。
      protected Image | Component.FlipBufferStrategy.getBackBuffer​()
      Image Frame.getIconImage​()
      返回要显示的图像作为此框架的图标。
      Image Taskbar.getIconImage​()
      获取此应用程序图标的图像。
      abstract Image Toolkit.getImage​(String filename)
      返回从指定文件获取像素数据的图像，其格式可以是GIF，JPEG或PNG。
      abstract Image Toolkit.getImage​(URL url)
      返回从指定的URL获取像素数据的图像。
      Image TrayIcon.getImage​()
      返回用于此 TrayIcon的当前图像。
      Image Image.getScaledInstance​(int width, int height, int hints)
      创建此图像的缩放版本。
      Methods in java.awt that return types with arguments of type Image
      Modifier and Type 方法 描述
      List<Image> Window.getIconImages​()
      返回要显示为此窗口的图标的图像序列。
      Methods in java.awt with parameters of type Image
      Modifier and Type 方法 描述
      void MediaTracker.addImage​(Image image, int id)
      将图像添加到此媒体跟踪器跟踪的图像列表中。
      void MediaTracker.addImage​(Image image, int id, int w, int h)
      将缩放图像添加到此媒体跟踪器跟踪的图像列表中。
      int Component.checkImage​(Image image, int width, int height, ImageObserver observer)
      返回构造指定图像的屏幕表示的状态。
      int Component.checkImage​(Image image, ImageObserver observer)
      返回构造指定图像的屏幕表示的状态。
      abstract int Toolkit.checkImage​(Image image, int width, int height, ImageObserver observer)
      表示准备显示的指定图像的构造状态。
      Cursor Toolkit.createCustomCursor​(Image cursor, Point hotSpot, String name)
      创建一个新的自定义光标对象。
      abstract boolean Graphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
      abstract boolean Graphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer)
      按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      绘制与已经缩放以适应指定矩形内的指定图像的大小。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, int width, int height, ImageObserver observer)
      绘制与已经缩放以适应指定矩形内的指定图像的大小。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      绘制当前可用的指定图像的大小。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, ImageObserver observer)
      绘制当前可用的指定图像的大小。
      abstract boolean Graphics2D.drawImage​(Image img, AffineTransform xform, ImageObserver obs)
      渲染图像，在绘制之前将图像空间的变换应用到用户空间中。
      boolean Component.imageUpdate​(Image img, int infoflags, int x, int y, int w, int h)
      当图像发生变化时重新编辑组件。
      boolean Component.prepareImage​(Image image, int width, int height, ImageObserver observer)
      准备一个图像，以指定的宽度和高度在此组件上渲染。
      boolean Component.prepareImage​(Image image, ImageObserver observer)
      准备用于在此组件上呈现的图像。
      abstract boolean Toolkit.prepareImage​(Image image, int width, int height, ImageObserver observer)
      准备渲染图像。
      void MediaTracker.removeImage​(Image image)
      从此媒体跟踪器中删除指定的图像。
      void MediaTracker.removeImage​(Image image, int id)
      从该媒体跟踪器的指定跟踪ID中删除指定的图像。
      void MediaTracker.removeImage​(Image image, int id, int width, int height)
      从此媒体跟踪器中删除指定的宽度，高度和ID的指定图像。
      void Frame.setIconImage​(Image image)
      将要显示的图像设置为此窗口的图标。
      void Taskbar.setIconImage​(Image image)
      将此应用程序的图标更改为提供的图像。
      void Window.setIconImage​(Image image)
      将要显示的图像设置为此窗口的图标。
      void TrayIcon.setImage​(Image image)
      设置 TrayIcon的图像。
      void Taskbar.setWindowIconBadge​(Window w, Image badge)
      在指定窗口的任务区域中贴上小应用程序的图标。
      Method parameters in java.awt with type arguments of type Image
      Modifier and Type 方法 描述
      void Window.setIconImages​(List<? extends Image> icons)
      设置要显示为该窗口的图标的图像序列。
      Constructors in java.awt with parameters of type Image
      Constructor 描述
      TrayIcon​(Image image)
      创建具有指定图像的 TrayIcon 。
      TrayIcon​(Image image, String tooltip)
      创建一个 TrayIcon与指定的图像和工具提示文本。
      TrayIcon​(Image image, String tooltip, PopupMenu popup)
      使用指定的图像，工具提示和弹出菜单创建 TrayIcon 。

    • Uses of Image in java.awt.dnd

      Methods in java.awt.dnd with parameters of type Image
      Modifier and Type 方法 描述
      protected DragSourceContext DragSource.createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl)
      启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
      Constructors in java.awt.dnd with parameters of type Image
      Constructor 描述
      DragSourceContext​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
      从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。

    • Uses of Image in java.awt.font

      Constructors in java.awt.font with parameters of type Image
      Constructor 描述
      ImageGraphicAttribute​(Image image, int alignment)
      构造一个ImageGraphicAttribute从指定Image 。
      ImageGraphicAttribute​(Image image, int alignment, float originX, float originY)
      构造一个 ImageGraphicAttribute从指定 Image 。

    • Uses of Image in java.awt.im.spi

      Methods in java.awt.im.spi that return Image
      Modifier and Type 方法 描述
      Image InputMethodDescriptor.getInputMethodIcon​(Locale inputLocale)
      返回相应输入法的图标。

    • Uses of Image in java.awt.image

      Subclasses of Image in java.awt.image
      Modifier and Type Class 描述
      class  AbstractMultiResolutionImage
      该类为要实现 MultiResolutionImage接口的类提供了几个 Image方法的默认实现。
      class  BaseMultiResolutionImage
      这个类是一个基于数组的 AbstractMultiResolutionImage类的实现。
      class  BufferedImage
      BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
      class  VolatileImage
      VolatileImage是由于超出应用程序控制的情况（例如由操作系统或其他应用程序引起的情况），可能随时丢失其内容的映像。
      Methods in java.awt.image that return Image
      Modifier and Type | 方法 | 描述
      protected abstract Image AbstractMultiResolutionImage.getBaseImage​()
      返回表示最佳版本的图像的基本图像，以便以默认的宽度和高度渲染。
      protected Image | BaseMultiResolutionImage.getBaseImage​()
      Image | BaseMultiResolutionImage.getResolutionVariant​(double destImageWidth, double destImageHeight)
      Image MultiResolutionImage.getResolutionVariant​(double destImageWidth, double destImageHeight)
      获取一个特定的图像，这是以指定大小表示该逻辑图像的最佳变体。
      Methods in java.awt.image that return types with arguments of type Image
      Modifier and Type | 方法 | 描述
      List<Image> | BaseMultiResolutionImage.getResolutionVariants​()
      List<Image> MultiResolutionImage.getResolutionVariants​()
      获取所有分辨率变体的可读列表。
      Methods in java.awt.image with parameters of type Image
      Modifier and Type 方法 描述
      boolean ImageObserver.imageUpdate​(Image img, int infoflags, int x, int y, int width, int height)
      当先前使用异步接口请求的图像的信息变得可用时，将调用此方法。
      Constructors in java.awt.image with parameters of type Image
      Constructor 描述
      BaseMultiResolutionImage​(int baseImageIndex, Image... resolutionVariants)
      使用给定的基本图像索引和分辨率变体创建多分辨率图像。
      BaseMultiResolutionImage​(Image... resolutionVariants)
      使用给定的分辨率变体创建多分辨率图像。
      PixelGrabber​(Image img, int x, int y, int w, int h, boolean forceRGB)
      创建一个PixelGrabber对象，从指定的图像中获取像素的（x，y，w，h）矩形部分。
      PixelGrabber​(Image img, int x, int y, int w, int h, int[] pix, int off, int scansize)
      创建一个PixelGrabber对象，将（x，y，w，h）像素的矩形部分从指定的图像进入给定的数组。

    • Uses of Image in java.beans

      Methods in java.beans that return Image
      Modifier and Type 方法 描述
      Image BeanInfo.getIcon​(int iconKind)
      返回可用于在工具箱或工具栏中表示bean的图像。
      Image SimpleBeanInfo.getIcon​(int iconKind)
      声明没有可用的图标。
      Image SimpleBeanInfo.loadImage​(String resourceName)
      这是一种帮助加载图标图像的实用方法。

    • Uses of Image in javax.swing

      Fields in javax.swing declared as Image
      Modifier and Type Field 描述
      protected Image JViewport.backingStoreImage
      用于后台存储的视图图像。
      Methods in javax.swing that return Image
      Modifier and Type 方法 描述
      static Image GrayFilter.createDisabledImage​(Image i)
      创建禁用的图像
      Image TransferHandler.getDragImage​()
      返回拖动图像。
      Image ImageIcon.getImage​()
      返回此图标的 Image 。
      Image RepaintManager.getOffscreenBuffer​(Component c, int proposedWidth, int proposedHeight)
      返回应使用组件 c作为双缓冲区的屏幕外缓冲区。
      Image RepaintManager.getVolatileOffscreenBuffer​(Component c, int proposedWidth, int proposedHeight)
      返回应该用作具有指定组件 c的双缓冲区的易失性屏幕缓冲区。
      Methods in javax.swing with parameters of type Image
      Modifier and Type 方法 描述
      static Image GrayFilter.createDisabledImage​(Image i)
      创建禁用的图像
      boolean DebugGraphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, int width, int height, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean AbstractButton.imageUpdate​(Image img, int infoflags, int x, int y, int w, int h)
      如果当前的 Icon的 Image不等于 Image img传递的内容，则这被覆盖返回false。
      boolean JLabel.imageUpdate​(Image img, int infoflags, int x, int y, int w, int h)
      如果当前图标的图像不等于图像 img传递的图像，则这被覆盖以返回false。
      boolean JLayer.imageUpdate​(Image img, int infoflags, int x, int y, int w, int h)
      将其功能委托给 LayerUI.imageUpdate(java.awt.Image, int, int, int, int, int, JLayer)方法，如果设置了 LayerUI 。
      boolean JSlider.imageUpdate​(Image img, int infoflags, int x, int y, int w, int h)
      当图像发生变化时重新编辑组件。
      protected void ImageIcon.loadImage​(Image image)
      加载图像，仅在加载图像时返回。
      void TransferHandler.setDragImage​(Image img)
      设置拖动图像参数。
      void JFrame.setIconImage​(Image image)
      将要显示的图像设置为此窗口的图标。
      void ImageIcon.setImage​(Image image)
      设置此图标显示的图像。
      Constructors in javax.swing with parameters of type Image
      Constructor 描述
      ImageIcon​(Image image)
      从图像对象创建一个ImageIcon。
      ImageIcon​(Image image, String description)
      从图像创建一个ImageIcon。

    • Uses of Image in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type Image
      Modifier and Type 方法 描述
      boolean LayerUI.imageUpdate​(Image img, int infoflags, int x, int y, int w, int h, JLayer<? extends V> l)
      将其功能委托给继承自 JLayer的基类的 JLayer.imageUpdate方法的默认实现。

    • Uses of Image in javax.swing.text.html

      Methods in javax.swing.text.html that return Image
      Modifier and Type 方法 描述
      Image ImageView.getImage​()
      返回要呈现的图像。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.ImageCapabilities (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.ImageCapabilities

  • Packages that use ImageCapabilities
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。

    • Uses of ImageCapabilities in java.awt

      Methods in java.awt that return ImageCapabilities
      Modifier and Type | 方法 | 描述
      ImageCapabilities | BufferCapabilities.getBackBufferCapabilities​()
      ImageCapabilities Image.getCapabilities​(GraphicsConfiguration gc)
      返回一个ImageCapabilities对象，可以在指定的GraphicsConfiguration上查询该Image的功能。
      ImageCapabilities | BufferCapabilities.getFrontBufferCapabilities​()
      ImageCapabilities GraphicsConfiguration.getImageCapabilities​()
      返回这个 GraphicsConfiguration的图像功能。
      Methods in java.awt with parameters of type ImageCapabilities
      Modifier and Type 方法 描述
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps)
      使用指定的图像功能返回VolatileImage，其中包含与此GraphicsConfiguration兼容的数据布局和颜色模型。
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps, int transparency)
      使用指定的图像功能和透明度值返回VolatileImage，其中包含与此GraphicsConfiguration兼容的数据布局和颜色模型。
      VolatileImage Component.createVolatileImage​(int width, int height, ImageCapabilities caps)
      使用给定的功能创建一个易失的屏幕外可绘制图像。
      Constructors in java.awt with parameters of type ImageCapabilities
      Constructor 描述
      BufferCapabilities​(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
      创建一个用于指定缓冲功能的新对象

    • Uses of ImageCapabilities in java.awt.image

      Methods in java.awt.image that return ImageCapabilities
      Modifier and Type 方法 描述
      abstract ImageCapabilities VolatileImage.getCapabilities​()
      返回一个ImageCapabilities对象，可以查询该VolatileImage的具体功能。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Insets (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Insets

  • Packages that use Insets
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Insets in java.awt

      Fields in java.awt declared as Insets
      Modifier and Type Field 描述
      Insets GridBagConstraints.insets
      该字段指定组件的外部填充，组件与其显示区域的边缘之间的最小空间量。
      Methods in java.awt that return Insets
      Modifier and Type 方法 描述
      Insets Container.getInsets​()
      确定此容器的插入，这表示容器边框的大小。
      Insets Toolkit.getScreenInsets​(GraphicsConfiguration gc)
      获取屏幕的插图。
      Insets Container.insets​()
      已过时。
      从JDK 1.1版开始，替换为getInsets() 。
      Constructors in java.awt with parameters of type Insets
      Constructor 描述
      GridBagConstraints​(int gridx, int gridy, int gridwidth, int gridheight, double weightx, double weighty, int anchor, int fill, Insets insets, int ipadx, int ipady)
      创建一个 GridBagConstraints对象，其所有字段都设置为传入参数。

    • Uses of Insets in java.awt.dnd

      Methods in java.awt.dnd that return Insets
      Modifier and Type 方法 描述
      Insets Autoscroll.getAutoscrollInsets​()
      此方法返回描述相对于实现组件几何的自动滚动区域或边框的 Insets 。

    • Uses of Insets in javax.swing

      Methods in javax.swing that return Insets
      Modifier and Type 方法 描述
      Insets JComponent.getInsets​()
      如果在此组件上设置了边框，则返回边框的插入; 否则拨打super.getInsets 。
      Insets JComponent.getInsets​(Insets insets)
      返回一个包含该组件插入值的 Insets对象。
      Insets JViewport.getInsets​()
      由于边框不支持 JViewport ，因此将其作为（0,0,0,0）的尺寸返回。
      Insets JViewport.getInsets​(Insets insets)
      返回一个包含这个 JViewport的插入值的 Insets对象。
      Insets UIDefaults.getInsets​(Object key)
      如果 key的值是 Insets返回，否则返回 null 。
      Insets UIDefaults.getInsets​(Object key, Locale l)
      如果值 key对于给定 Locale是 Insets返回它，否则返回 null 。
      static Insets UIManager.getInsets​(Object key)
      从默认值返回一个 Insets对象。
      static Insets UIManager.getInsets​(Object key, Locale l)
      从适用于给定语言环境的默认值返回一个 Insets对象。
      Insets AbstractButton.getMargin​()
      返回按钮边框和标签之间的边距。
      Insets JMenuBar.getMargin​()
      返回菜单边框和菜单之间的边距。
      Insets JPopupMenu.getMargin​()
      返回弹出菜单的边框和容器之间的边距（以像素为单位）。
      Insets JToolBar.getMargin​()
      返回工具栏边框与其按钮之间的边距。
      Methods in javax.swing with parameters of type Insets
      Modifier and Type 方法 描述
      Insets JComponent.getInsets​(Insets insets)
      返回包含此组件的插入值的 Insets对象。
      Insets JViewport.getInsets​(Insets insets)
      返回一个 Insets对象，其中包含这个 JViewport的插入值。
      void AbstractButton.setMargin​(Insets m)
      在按钮的边框和标签之间设置边距空间。
      void JMenuBar.setMargin​(Insets m)
      设置菜单边界和菜单之间的边距。
      void JToolBar.setMargin​(Insets m)
      X- 200 X- 200 200 X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X-

    • Uses of Insets in javax.swing.border

      Methods in javax.swing.border that return Insets
      Modifier and Type 方法 描述
      Insets AbstractBorder.getBorderInsets​(Component c)
      此默认实现返回一个由AbstractBorder.getBorderInsets(Component,Insets)方法初始化的新的Insets对象。
      Insets AbstractBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets BevelBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets Border.getBorderInsets​(Component c)
      返回边框的插入。
      Insets CompoundBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets EmptyBorder.getBorderInsets​()
      返回边框的插入。
      Insets EmptyBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets EtchedBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets LineBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets MatteBorder.getBorderInsets​()
      返回边框的插入。
      Insets MatteBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets SoftBevelBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets StrokeBorder.getBorderInsets​(Component c, Insets insets)
      使用此边框的当前插图重新初始化 insets参数。
      Insets TitledBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Methods in javax.swing.border with parameters of type Insets
      Modifier and Type 方法 描述
      Insets AbstractBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets BevelBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets CompoundBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets EmptyBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets EtchedBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets LineBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets MatteBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets SoftBevelBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Insets StrokeBorder.getBorderInsets​(Component c, Insets insets)
      使用此边框的当前插图重新初始化 insets参数。
      Insets TitledBorder.getBorderInsets​(Component c, Insets insets)
      使用此Border的当前Insets重新初始化insets参数。
      Constructors in javax.swing.border with parameters of type Insets
      Constructor 描述
      EmptyBorder​(Insets borderInsets)
      使用指定的插图创建空白边框。
      MatteBorder​(Insets borderInsets, Color matteColor)
      创建具有指定插图和颜色的无光泽边框。
      MatteBorder​(Insets borderInsets, Icon tileIcon)
      使用指定的插图和图块图标创建无光泽边框。

    • Uses of Insets in javax.swing.plaf

      Subclasses of Insets in javax.swing.plaf
      Modifier and Type Class 描述
      class  InsetsUIResource
      Insets实现UIResource的子类。
      Methods in javax.swing.plaf that return Insets
      Modifier and Type | 方法 | 描述
      Insets | BorderUIResource.getBorderInsets​(Component c)
      Constructors in javax.swing.plaf with parameters of type Insets
      Constructor 描述
      EmptyBorderUIResource​(Insets insets)
      构造一个 EmptyBorderUIResource 。

    • Uses of Insets in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Insets
      Modifier and Type Field 描述
      protected Insets BasicTabbedPaneUI.contentBorderInsets
      内容边框插图
      protected Insets BasicSliderUI.focusInsets
      焦点插图
      protected Insets BasicSliderUI.insetCache
      插入缓存
      protected Insets BasicComboBoxUI.padding
      如果指定了这些插值，则在组合框中布置和绘制“选定”项时，这些插值将围绕单元格渲染器充当填充。
      protected Insets BasicTabbedPaneUI.selectedTabPadInsets
      所选标签插入
      protected Insets BasicTabbedPaneUI.tabAreaInsets
      标签区域插入
      protected Insets BasicTabbedPaneUI.tabInsets
      标签插入
      Methods in javax.swing.plaf.basic that return Insets
      Modifier and Type | 方法 | 描述
      Insets | BasicBorders.ButtonBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.FieldBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.MarginBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.MenuBarBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.RadioButtonBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.SplitPaneBorder.getBorderInsets​(Component c)
      Insets | BasicBorders.ToggleButtonBorder.getBorderInsets​(Component c, Insets insets)
      protected Insets BasicTabbedPaneUI.getContentBorderInsets​(int tabPlacement)
      返回内容边框插入。
      static Insets BasicGraphicsUtils.getEtchedInsets​()
      返回由 drawEtchedRect()绘制的边框占用的空间量
      static Insets BasicGraphicsUtils.getGrooveInsets​()
      返回由 drawGroove()绘制的边框占用的空间量
      protected Insets BasicComboBoxUI.getInsets​()
      从JComboBox获取插图。
      Insets BasicDesktopIconUI.getInsets​(JComponent c)
      返回插图。
      Insets BasicSplitPaneDivider.getInsets​()
      如果在此组件上设置了边框，则返回边框的插入，否则调用super.getInsets。
      Insets BasicSplitPaneUI.getInsets​(JComponent jc)
      返回插图。
      Insets | BasicToolBarUI.DragWindow.getInsets​()
      protected Insets BasicTabbedPaneUI.getSelectedTabPadInsets​(int tabPlacement)
      返回所选的选项卡垫插入。
      protected Insets BasicTabbedPaneUI.getTabAreaInsets​(int tabPlacement)
      返回标签区域插入。
      protected Insets BasicTabbedPaneUI.getTabInsets​(int tabPlacement, int tabIndex)
      返回标签插入。
      Methods in javax.swing.plaf.basic with parameters of type Insets
      Modifier and Type | 方法 | 描述
      protected int BasicProgressBarUI.getAmountFull​(Insets b, int width, int height)
      这将根据从模型收集的百分比确定应填充的进度条的数量。
      protected int BasicSplitPaneUI.BasicHorizontalLayoutManager.getAvailableSize​(Dimension containerSize, Insets insets)
      根据容器大小和 Insets返回可用宽度。
      Insets | BasicBorders.ButtonBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.FieldBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.MarginBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.MenuBarBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.RadioButtonBorder.getBorderInsets​(Component c, Insets insets)
      Insets | BasicBorders.ToggleButtonBorder.getBorderInsets​(Component c, Insets insets)
      protected int BasicSplitPaneUI.BasicHorizontalLayoutManager.getInitialLocation​(Insets insets)
      返回左插图，除非 Insets为null，在这种情况下返回0。
      protected void BasicTreeUI.paintExpandControl​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的展开（切换）部分。
      protected void BasicTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      涂抹腿部的水平部分。
      protected void BasicTreeUI.paintRow​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的渲染器部分。
      protected void BasicProgressBarUI.paintString​(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
      绘制进度字符串。
      protected void BasicTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      涂上腿部的垂直部分。
      protected static void BasicTabbedPaneUI.rotateInsets​(Insets topInsets, Insets targetInsets, int targetPlacement)
      旋转插图。
      protected void BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize​(Component c, int size, int location, Insets insets, Dimension containerSize)
      将组件 c的宽度设置为 size ，将其x位置设置为 location ，y到 insets.top ，高度为 containerSize.height减去顶部和底部的插入。

    • Uses of Insets in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as Insets
      Modifier and Type Field 描述
      protected static Insets MetalBorders.ButtonBorder.borderInsets
      边界插入。
      protected static Insets MetalBorders.MenuBarBorder.borderInsets
      边界插入。
      protected static Insets MetalBorders.MenuItemBorder.borderInsets
      边界插入。
      protected static Insets MetalBorders.PopupMenuBorder.borderInsets
      边界插入。
      protected Insets MetalBorders.TableHeaderBorder.editorBorderInsets
      边界插入。
      protected static Insets MetalComboBoxEditor.editorBorderInsets
      默认编辑器边框 Insets 。
      Methods in javax.swing.plaf.metal that return Insets
      Modifier and Type | 方法 | 描述
      Insets | MetalBorders.ButtonBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.Flush3DBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.InternalFrameBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.MenuBarBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.MenuItemBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.OptionDialogBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.PaletteBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.PopupMenuBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.ScrollPaneBorder.getBorderInsets​(Component c, Insets insets)
      Insets | MetalBorders.TableHeaderBorder.getBorderInsets​(Component c, Insets insets)
      Insets | MetalBorders.ToolBarBorder.getBorderInsets​(Component c, Insets newInsets)
      Methods in javax.swing.plaf.metal with parameters of type Insets
      Modifier and Type | 方法 | 描述
      Insets | MetalBorders.ButtonBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.Flush3DBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.InternalFrameBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.MenuBarBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.MenuItemBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.OptionDialogBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.PaletteBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.PopupMenuBorder.getBorderInsets​(Component c, Insets newInsets)
      Insets | MetalBorders.ScrollPaneBorder.getBorderInsets​(Component c, Insets insets)
      Insets | MetalBorders.TableHeaderBorder.getBorderInsets​(Component c, Insets insets)
      Insets | MetalBorders.ToolBarBorder.getBorderInsets​(Component c, Insets newInsets)
      protected void | MetalTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      protected void | MetalTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

    • Uses of Insets in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return Insets
      Modifier and Type 方法 描述
      Insets NimbusStyle.getInsets​(SynthContext ctx, Insets in)
      返回用于计算大小信息的Insets。
      Methods in javax.swing.plaf.nimbus with parameters of type Insets
      Modifier and Type 方法 描述
      Insets NimbusStyle.getInsets​(SynthContext ctx, Insets in)
      返回用于计算大小信息的Insets。
      Constructors in javax.swing.plaf.nimbus with parameters of type Insets
      Constructor 描述
      PaintContext​(Insets insets, Dimension canvasSize, boolean inverted)
      创建一个新的PaintContext，它不会尝试缓存或缩放任何缓存的图像。
      PaintContext​(Insets insets, Dimension canvasSize, boolean inverted, AbstractRegionPainter.PaintContext.CacheMode cacheMode, double maxH, double maxV)
      创建一个新的PaintContext。

    • Uses of Insets in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Insets
      Modifier and Type 方法 描述
      Insets SynthStyle.getInsets​(SynthContext context, Insets insets)
      返回用于计算大小信息的Insets。
      protected Insets SynthTabbedPaneUI.getTabInsets​(int tabPlacement, int tabIndex)
      返回标签插入。
      Methods in javax.swing.plaf.synth with parameters of type Insets
      Modifier and Type 方法 描述
      Insets SynthStyle.getInsets​(SynthContext context, Insets insets)
      返回用于计算大小信息的Insets。
      protected void SynthTreeUI.paintExpandControl​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的展开（切换）部分。
      protected void SynthTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      涂抹腿部的水平部分。
      protected void SynthTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      涂上腿部的垂直部分。

    • Uses of Insets in javax.swing.text

      Methods in javax.swing.text that return Insets
      Modifier and Type 方法 描述
      Insets JTextComponent.getMargin​()
      返回文本组件的边框和文本之间的边距。
      Methods in javax.swing.text with parameters of type Insets
      Modifier and Type 方法 描述
      void JTextComponent.setMargin​(Insets m)
      在文本组件的边框和文本之间设置边距空间。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.JobAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.JobAttributes

  • Packages that use JobAttributes
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of JobAttributes in java.awt

      Methods in java.awt with parameters of type JobAttributes
      Modifier and Type 方法 描述
      PrintJob Toolkit.getPrintJob​(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
      获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
      void JobAttributes.set​(JobAttributes obj)
      将此 JobAttributes所有属性设置为与obj的属性相同的值。
      Constructors in java.awt with parameters of type JobAttributes
      Constructor 描述
      JobAttributes​(JobAttributes obj)
      构造一个 JobAttributes实例，它是所提供的 JobAttributes的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.JobAttributes.DefaultSelectionType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.JobAttributes.DefaultSelectionType

  • Packages that use JobAttributes.DefaultSelectionType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of JobAttributes.DefaultSelectionType in java.awt

      Fields in java.awt declared as JobAttributes.DefaultSelectionType
      Modifier and Type Field 描述
      static JobAttributes.DefaultSelectionType JobAttributes.DefaultSelectionType.ALL
      用于指定应打印作业的所有页面的 DefaultSelectionType实例。
      static JobAttributes.DefaultSelectionType JobAttributes.DefaultSelectionType.RANGE
      DefaultSelectionType实例用于指定应打印作业范围的页面。
      static JobAttributes.DefaultSelectionType JobAttributes.DefaultSelectionType.SELECTION
      用于指定应打印当前选择的 DefaultSelectionType实例。
      Methods in java.awt that return JobAttributes.DefaultSelectionType
      Modifier and Type 方法 描述
      JobAttributes.DefaultSelectionType JobAttributes.getDefaultSelection​()
      指定对于使用这些属性的作业，应用程序是否应打印所有页面，返回值为 getPageRanges指定的范围，或当前选择。
      Methods in java.awt with parameters of type JobAttributes.DefaultSelectionType
      Modifier and Type 方法 描述
      void JobAttributes.setDefaultSelection​(JobAttributes.DefaultSelectionType defaultSelection)
      指定对于使用这些属性的作业，应用程序是否应打印所有页面，由返回值 getPageRanges指定的范围或当前选择。
      Constructors in java.awt with parameters of type JobAttributes.DefaultSelectionType
      Constructor 描述
      JobAttributes​(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
      Constructs a JobAttributes instance with the specified values for every attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.JobAttributes.DestinationType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.JobAttributes.DestinationType

  • Packages that use JobAttributes.DestinationType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of JobAttributes.DestinationType in java.awt

      Fields in java.awt declared as JobAttributes.DestinationType
      Modifier and Type Field 描述
      static JobAttributes.DestinationType JobAttributes.DestinationType.FILE
      用于指定打印到文件的 DestinationType实例。
      static JobAttributes.DestinationType JobAttributes.DestinationType.PRINTER
      用于指定打印机打印的 DestinationType实例。
      Methods in java.awt that return JobAttributes.DestinationType
      Modifier and Type 方法 描述
      JobAttributes.DestinationType JobAttributes.getDestination​()
      指定输出将是打印机还是使用这些属性的作业文件。
      Methods in java.awt with parameters of type JobAttributes.DestinationType
      Modifier and Type 方法 描述
      void JobAttributes.setDestination​(JobAttributes.DestinationType destination)
      指定输出将是打印机还是使用这些属性的作业文件。
      Constructors in java.awt with parameters of type JobAttributes.DestinationType
      Constructor 描述
      JobAttributes​(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
      为每个属性构造具有指定值的 JobAttributes实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.JobAttributes.DialogType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.JobAttributes.DialogType

  • Packages that use JobAttributes.DialogType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of JobAttributes.DialogType in java.awt

      Fields in java.awt declared as JobAttributes.DialogType
      Modifier and Type Field 描述
      static JobAttributes.DialogType JobAttributes.DialogType.COMMON
      用于指定跨平台，纯Java打印对话框的 DialogType实例。
      static JobAttributes.DialogType JobAttributes.DialogType.NATIVE
      用于指定平台本机打印对话框的 DialogType实例。
      static JobAttributes.DialogType JobAttributes.DialogType.NONE
      用于指定不打印对话框的 DialogType实例。
      Methods in java.awt that return JobAttributes.DialogType
      Modifier and Type 方法 描述
      JobAttributes.DialogType JobAttributes.getDialog​()
      返回对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。
      Methods in java.awt with parameters of type JobAttributes.DialogType
      Modifier and Type 方法 描述
      void JobAttributes.setDialog​(JobAttributes.DialogType dialog)
      指定对于使用这些属性的作业，用户是否应该看到要修改打印设置的打印对话框，以及应显示哪种类型的打印对话框。
      Constructors in java.awt with parameters of type JobAttributes.DialogType
      Constructor 描述
      JobAttributes​(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
      Constructs a JobAttributes instance with the specified values for every attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.JobAttributes.MultipleDocumentHandlingType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.JobAttributes.MultipleDocumentHandlingType

  • Packages that use JobAttributes.MultipleDocumentHandlingType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of JobAttributes.MultipleDocumentHandlingType in java.awt

      Fields in java.awt declared as JobAttributes.MultipleDocumentHandlingType
      Modifier and Type Field 描述
      static JobAttributes.MultipleDocumentHandlingType JobAttributes.MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES
      MultipleDocumentHandlingType实例用于指定作业应分为单独的整理副本。
      static JobAttributes.MultipleDocumentHandlingType JobAttributes.MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
      MultipleDocumentHandlingType实例用于指定作业应分为单独的未分类副本。
      Methods in java.awt that return JobAttributes.MultipleDocumentHandlingType
      Modifier and Type 方法 描述
      JobAttributes.MultipleDocumentHandlingType JobAttributes.getMultipleDocumentHandling​()
      指定对使用这些属性的作业处理多个副本（包括排序规则）。
      Methods in java.awt with parameters of type JobAttributes.MultipleDocumentHandlingType
      Modifier and Type 方法 描述
      void JobAttributes.setMultipleDocumentHandling​(JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling)
      指定对使用这些属性的作业处理多个副本（包括排序规则）。
      Constructors in java.awt with parameters of type JobAttributes.MultipleDocumentHandlingType
      Constructor 描述
      JobAttributes​(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
      构造具有每个属性的指定值的 JobAttributes实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.JobAttributes.SidesType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.JobAttributes.SidesType

  • Packages that use JobAttributes.SidesType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of JobAttributes.SidesType in java.awt

      Fields in java.awt declared as JobAttributes.SidesType
      Modifier and Type Field 描述
      static JobAttributes.SidesType JobAttributes.SidesType.ONE_SIDED
      用于指定连续作业页面的 SidesType实例应打印在连续介质页的同一侧。
      static JobAttributes.SidesType JobAttributes.SidesType.TWO_SIDED_LONG_EDGE
      用于指定连续作业页面的 SidesType实例应在连续的介质页的正面和背面打印，以使介质上的每对页面的方向对于读取器来说将是正确的，就像在长边上进行装订。
      static JobAttributes.SidesType JobAttributes.SidesType.TWO_SIDED_SHORT_EDGE
      用于指定连续作业页面的 SidesType实例应在连续介质页的正面和背面打印，以便介质上每对页面的方向对于读取器来说是正确的，如同在短边装订一样。
      Methods in java.awt that return JobAttributes.SidesType
      Modifier and Type 方法 描述
      JobAttributes.SidesType JobAttributes.getSides​()
      返回在使用这些属性的作业的打印介质的两侧应该如何施加连续的页面。
      Methods in java.awt with parameters of type JobAttributes.SidesType
      Modifier and Type 方法 描述
      void JobAttributes.setSides​(JobAttributes.SidesType sides)
      指定在使用这些属性的作业的打印介质的两侧应如何施加连续的页面。
      Constructors in java.awt with parameters of type JobAttributes.SidesType
      Constructor 描述
      JobAttributes​(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
      Constructs a JobAttributes instance with the specified values for every attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.KeyboardFocusManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.KeyboardFocusManager

  • Packages that use KeyboardFocusManager
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of KeyboardFocusManager in java.awt

      Subclasses of KeyboardFocusManager in java.awt
      Modifier and Type Class 描述
      class  DefaultKeyboardFocusManager
      用于AWT应用程序的默认KeyboardFocusManager。
      Methods in java.awt that return KeyboardFocusManager
      Modifier and Type 方法 描述
      static KeyboardFocusManager KeyboardFocusManager.getCurrentKeyboardFocusManager​()
      返回调用线程上下文的当前KeyboardFocusManager实例。
      Methods in java.awt with parameters of type KeyboardFocusManager
      Modifier and Type 方法 描述
      static void KeyboardFocusManager.setCurrentKeyboardFocusManager​(KeyboardFocusManager newManager)
      为调用线程的上下文设置当前的KeyboardFocusManager实例。

    • Uses of KeyboardFocusManager in javax.swing

      Subclasses of KeyboardFocusManager in javax.swing
      Modifier and Type Class 描述
      class  DefaultFocusManager
      这个类已被1.4焦点API过时了。
      class  FocusManager
      This class has been obsoleted by the 1.4 focus APIs.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Label (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Label

No usage of java.awt.Label
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Label.AccessibleAWTLabel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Label.AccessibleAWTLabel

No usage of java.awt.Label.AccessibleAWTLabel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.LinearGradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.LinearGradientPaint

  • Packages that use LinearGradientPaint
    软件包 描述
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。

    • Uses of LinearGradientPaint in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return LinearGradientPaint
      Modifier and Type 方法 描述
      protected LinearGradientPaint AbstractRegionPainter.decodeGradient​(float x1, float y1, float x2, float y2, float[] midpoints, Color[] colors)
      给定用于创建LinearGradientPaint的参数，此方法将创建并返回一个线性渐变画线。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.List (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.List

  • Packages that use List
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of List in java.awt

      Constructors in java.awt with parameters of type List
      Constructor 描述
      AccessibleAWTListChild​(List parent, int indexInParent)
      构造新的 AccessibleAWTListChild与给定父母 List和基于0的父对象的索引。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.List.AccessibleAWTList (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.List.AccessibleAWTList

No usage of java.awt.List.AccessibleAWTList
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.List.AccessibleAWTList.AccessibleAWTListChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.List.AccessibleAWTList.AccessibleAWTListChild

No usage of java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MediaTracker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MediaTracker

  • Packages that use MediaTracker
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of MediaTracker in javax.swing

      Fields in javax.swing declared as MediaTracker
      Modifier and Type Field 描述
      protected static MediaTracker ImageIcon.tracker
      已过时。
      自1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Menu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Menu

  • Packages that use Menu
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Menu in java.awt

      Subclasses of Menu in java.awt
      Modifier and Type Class 描述
      class  PopupMenu
      一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
      Methods in java.awt that return Menu
      Modifier and Type 方法 描述
      Menu MenuBar.add​(Menu m)
      将指定的菜单添加到菜单栏。
      Menu MenuBar.getHelpMenu​()
      获取菜单栏上的帮助菜单。
      Menu MenuBar.getMenu​(int i)
      获取指定的菜单。
      Methods in java.awt with parameters of type Menu
      Modifier and Type 方法 描述
      Menu MenuBar.add​(Menu m)
      将指定的菜单添加到菜单栏。
      void MenuBar.setHelpMenu​(Menu m)
      Sets the specified menu to be this menu bar's help menu.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Menu.AccessibleAWTMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Menu.AccessibleAWTMenu

  • Packages that use Menu.AccessibleAWTMenu
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Menu.AccessibleAWTMenu in java.awt

      Subclasses of Menu.AccessibleAWTMenu in java.awt
      Modifier and Type Class 描述
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MenuBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MenuBar

  • Packages that use MenuBar
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MenuBar in java.awt

      Methods in java.awt that return MenuBar
      Modifier and Type 方法 描述
      MenuBar Frame.getMenuBar​()
      获取此框架的菜单栏。
      Methods in java.awt with parameters of type MenuBar
      Modifier and Type 方法 描述
      void Frame.setMenuBar​(MenuBar mb)
      将此框架的菜单栏设置为指定的菜单栏。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MenuBar.AccessibleAWTMenuBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MenuBar.AccessibleAWTMenuBar

No usage of java.awt.MenuBar.AccessibleAWTMenuBar
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MenuComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MenuComponent

  • Packages that use MenuComponent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MenuComponent in java.awt

      Subclasses of MenuComponent in java.awt
      Modifier and Type Class 描述
      class  CheckboxMenuItem
      此类表示可以包含在菜单中的复选框。
      class  Menu
      Menu对象是从菜单栏部署的下拉菜单组件。
      class  MenuBar
      MenuBar类封装了平台的框架结构的菜单栏的概念。
      class  MenuItem
      菜单中的所有项目必须属于类别 MenuItem或其子类之一。
      class  PopupMenu
      一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
      Methods in java.awt with parameters of type MenuComponent
      Modifier and Type 方法 描述
      void Component.remove​(MenuComponent popup)
      从组件中删除指定的弹出菜单。
      void Frame.remove​(MenuComponent m)
      从此框架中删除指定的菜单栏。
      void Menu.remove​(MenuComponent item)
      从此菜单中删除指定的菜单项。
      void MenuBar.remove​(MenuComponent m)
      从此菜单栏中删除指定的菜单组件。
      void MenuContainer.remove​(MenuComponent comp)
      从菜单中删除指定的菜单组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MenuComponent.AccessibleAWTMenuComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MenuComponent.AccessibleAWTMenuComponent

  • Packages that use MenuComponent.AccessibleAWTMenuComponent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MenuComponent.AccessibleAWTMenuComponent in java.awt

      Subclasses of MenuComponent.AccessibleAWTMenuComponent in java.awt
      Modifier and Type Class 描述
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      protected class  MenuBar.AccessibleAWTMenuBar
      MenuBar的内部类用于为辅助功能提供默认支持。
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MenuItem

  • Packages that use MenuItem
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MenuItem in java.awt

      Subclasses of MenuItem in java.awt
      Modifier and Type Class 描述
      class  CheckboxMenuItem
      此类表示可以包含在菜单中的复选框。
      class  Menu
      Menu对象是从菜单栏部署的下拉菜单组件。
      class  PopupMenu
      一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
      Methods in java.awt that return MenuItem
      Modifier and Type 方法 描述
      MenuItem Menu.add​(MenuItem mi)
      将指定的菜单项添加到此菜单。
      MenuItem Menu.getItem​(int index)
      获取位于此菜单的指定索引处的项目。
      MenuItem MenuBar.getShortcutMenuItem​(MenuShortcut s)
      获取的实例 MenuItem与指定相关 MenuShortcut的对象，或者 null如果被管理没有菜单项的通过该菜单栏与指定的菜单快捷方式有关。
      Methods in java.awt with parameters of type MenuItem
      Modifier and Type 方法 描述
      MenuItem Menu.add​(MenuItem mi)
      将指定的菜单项添加到此菜单。
      void Menu.insert​(MenuItem menuitem, int index)
      在指定位置的菜单中插入菜单项。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MenuItem.AccessibleAWTMenuItem (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MenuItem.AccessibleAWTMenuItem

  • Packages that use MenuItem.AccessibleAWTMenuItem
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MenuItem.AccessibleAWTMenuItem in java.awt

      Subclasses of MenuItem.AccessibleAWTMenuItem in java.awt
      Modifier and Type Class 描述
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MenuShortcut (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MenuShortcut

  • Packages that use MenuShortcut
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MenuShortcut in java.awt

      Methods in java.awt that return MenuShortcut
      Modifier and Type 方法 描述
      MenuShortcut MenuItem.getShortcut​()
      获取与 MenuShortcut相关联的 MenuShortcut对象，
      Methods in java.awt that return types with arguments of type MenuShortcut
      Modifier and Type 方法 描述
      Enumeration<MenuShortcut> MenuBar.shortcuts​()
      获取此菜单栏正在管理的所有菜单快捷方式的枚举。
      Methods in java.awt with parameters of type MenuShortcut
      Modifier and Type 方法 描述
      void MenuBar.deleteShortcut​(MenuShortcut s)
      删除指定的菜单快捷方式。
      boolean MenuShortcut.equals​(MenuShortcut s)
      返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。
      MenuItem MenuBar.getShortcutMenuItem​(MenuShortcut s)
      获取的实例 MenuItem与指定相关 MenuShortcut的对象，或者 null如果被管理没有菜单项的通过该菜单栏与指定的菜单快捷方式有关。
      void MenuItem.setShortcut​(MenuShortcut s)
      设置与 MenuShortcut相关联的 MenuShortcut对象。
      Constructors in java.awt with parameters of type MenuShortcut
      Constructor 描述
      MenuItem​(String label, MenuShortcut s)
      创建一个带有相关键盘快捷方式的菜单项。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MouseInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MouseInfo

No usage of java.awt.MouseInfo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MultipleGradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MultipleGradientPaint

  • Packages that use MultipleGradientPaint
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MultipleGradientPaint in java.awt

      Subclasses of MultipleGradientPaint in java.awt
      Modifier and Type Class 描述
      class  LinearGradientPaint
      LinearGradientPaint课程提供了一种用线性颜色渐变模式填充Shape的方法。
      class  RadialGradientPaint
      RadialGradientPaint类提供了一种填充圆形径向颜色渐变图案的形状的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MultipleGradientPaint.ColorSpaceType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MultipleGradientPaint.ColorSpaceType

  • Packages that use MultipleGradientPaint.ColorSpaceType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MultipleGradientPaint.ColorSpaceType in java.awt

      Methods in java.awt that return MultipleGradientPaint.ColorSpaceType
      Modifier and Type 方法 描述
      MultipleGradientPaint.ColorSpaceType MultipleGradientPaint.getColorSpace​()
      返回枚举类型，它指定插值的颜色空间。
      static MultipleGradientPaint.ColorSpaceType MultipleGradientPaint.ColorSpaceType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MultipleGradientPaint.ColorSpaceType[] MultipleGradientPaint.ColorSpaceType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in java.awt with parameters of type MultipleGradientPaint.ColorSpaceType
      Constructor 描述
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 LinearGradientPaint 。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 RadialGradientPaint 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.MultipleGradientPaint.CycleMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.MultipleGradientPaint.CycleMethod

  • Packages that use MultipleGradientPaint.CycleMethod
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of MultipleGradientPaint.CycleMethod in java.awt

      Methods in java.awt that return MultipleGradientPaint.CycleMethod
      Modifier and Type 方法 描述
      MultipleGradientPaint.CycleMethod MultipleGradientPaint.getCycleMethod​()
      返回指定循环行为的枚举类型。
      static MultipleGradientPaint.CycleMethod MultipleGradientPaint.CycleMethod.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MultipleGradientPaint.CycleMethod[] MultipleGradientPaint.CycleMethod.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in java.awt with parameters of type MultipleGradientPaint.CycleMethod
      Constructor 描述
      LinearGradientPaint​(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 LinearGradientPaint与默认的 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 LinearGradientPaint ，默认的颜色空间为 SRGB 。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 LinearGradientPaint 。
      RadialGradientPaint​(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，具有默认的 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，默认为 SRGB颜色空间。
      RadialGradientPaint​(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，使用默认的 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，默认为 SRGB颜色空间。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 RadialGradientPaint 。
      RadialGradientPaint​(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      Constructs a RadialGradientPaint with a default SRGB color space.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PageAttributes (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PageAttributes

  • Packages that use PageAttributes
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PageAttributes in java.awt

      Methods in java.awt with parameters of type PageAttributes
      Modifier and Type 方法 描述
      PrintJob Toolkit.getPrintJob​(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
      获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
      void PageAttributes.set​(PageAttributes obj)
      将此PageAttributes的所有属性设置为与obj的属性相同的值。
      Constructors in java.awt with parameters of type PageAttributes
      Constructor 描述
      PageAttributes​(PageAttributes obj)
      构造一个PageAttributes实例，它是提供的PageAttributes的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PageAttributes.ColorType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PageAttributes.ColorType

  • Packages that use PageAttributes.ColorType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PageAttributes.ColorType in java.awt

      Fields in java.awt declared as PageAttributes.ColorType
      Modifier and Type Field 描述
      static PageAttributes.ColorType PageAttributes.ColorType.COLOR
      用于指定彩色打印的ColorType实例。
      static PageAttributes.ColorType PageAttributes.ColorType.MONOCHROME
      用于指定单色打印的ColorType实例。
      Methods in java.awt that return PageAttributes.ColorType
      Modifier and Type 方法 描述
      PageAttributes.ColorType PageAttributes.getColor​()
      返回是否使用这些属性的页面将以彩色或单色呈现。
      Methods in java.awt with parameters of type PageAttributes.ColorType
      Modifier and Type 方法 描述
      void PageAttributes.setColor​(PageAttributes.ColorType color)
      指定使用这些属性的页面是否以彩色或单色呈现。
      Constructors in java.awt with parameters of type PageAttributes.ColorType
      Constructor 描述
      PageAttributes​(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
      为每个属性构造一个具有指定值的PageAttributes实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PageAttributes.MediaType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PageAttributes.MediaType

  • Packages that use PageAttributes.MediaType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PageAttributes.MediaType in java.awt

      Fields in java.awt declared as PageAttributes.MediaType
      Modifier and Type Field 描述
      static PageAttributes.MediaType PageAttributes.MediaType.A
      Engineering A的MediaType实例，8 1/2 x 11 in。
      static PageAttributes.MediaType PageAttributes.MediaType.A0
      ISO_A0的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A1
      ISO_A1的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A10
      ISO_A10的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A2
      ISO_A2的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A3
      ISO_A3的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A4
      ISO_A4的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A5
      ISO_A5的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A6
      ISO_A6的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A7
      ISO_A7的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A8
      ISO_A8的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.A9
      ISO_A9的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B
      Engineering B的MediaType实例，11 x 17 in。
      static PageAttributes.MediaType PageAttributes.MediaType.B0
      ISO_B0的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B1
      ISO_B1的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B10
      ISO_B10的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B2
      ISO_B2的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B3
      ISO_B3的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B4
      ISO_B4的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B5
      ISO_B5的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B6
      ISO_B6的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B7
      ISO_B7的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B8
      ISO_B8的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.B9
      ISO_B9的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C
      Engineering C的MediaType实例，17 x 22 in。
      static PageAttributes.MediaType PageAttributes.MediaType.C0
      ISO_C0的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C1
      ISO_C1的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C10
      ISO_C10的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C2
      ISO_C2的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C3
      ISO_C3的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C4
      ISO_C4的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C5
      ISO_C5的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C6
      ISO_C6的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C7
      ISO_C7的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C8
      ISO_C8的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.C9
      ISO_C9的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.D
      Engineering D的MediaType实例，22 x 34 in。
      static PageAttributes.MediaType PageAttributes.MediaType.E
      Engineering E的MediaType实例，34 x 44 in。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_10
      NA_NUMBER_10_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_10X13
      NA_10X13_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_10X14
      NA_10X14_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_10X15
      NA_10X15_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_11
      NA_NUMBER_11_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_12
      NA_NUMBER_12_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_14
      NA_NUMBER_14_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_6X9
      NA_6X9_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_7X9
      NA_7X9_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_9
      NA_NUMBER_9_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_9X11
      NA_9X11_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_9X12
      NA_9X12_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_INVITE
      INVITE_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_ITALY
      ITALY_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_MONARCH
      MONARCH_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ENV_PERSONAL
      PERSONAL_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.EXECUTIVE
      Executive的MediaType实例，7 1/4 x 10 1/2 in。
      static PageAttributes.MediaType PageAttributes.MediaType.FOLIO
      Folio的MediaType实例，8 1/2 x 13 in。
      static PageAttributes.MediaType PageAttributes.MediaType.INVITE
      INVITE_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.INVITE_ENVELOPE
      邀请信封的MediaType实例，220 x 220毫米。
      static PageAttributes.MediaType PageAttributes.MediaType.INVOICE
      发票的MediaType实例，5 1/2 x 8 1/2 in。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_2A0
      用于ISO / DIN和JIS 2A0的MediaType实例，1189 x 1682 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_4A0
      用于ISO / DIN和JIS 4A0的MediaType实例，1682 x 2378 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A0
      用于ISO / DIN和JIS A0的MediaType实例，841 x 1189 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A1
      用于ISO / DIN和JIS A1的MediaType实例，为594 x 841 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A10
      用于ISO / DIN和JIS A10的MediaType实例，26 x 37 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A2
      用于ISO / DIN和JIS A2的MediaType实例，420 x 594 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A3
      用于ISO / DIN和JIS A3的MediaType实例，297 x 420 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A4
      用于ISO / DIN和JIS A4的MediaType实例，210 x 297 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A5
      用于ISO / DIN和JIS A5的MediaType实例，148 x 210 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A6
      用于ISO / DIN和JIS A6的MediaType实例，105 x 148 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A7
      用于ISO / DIN和JIS A7的MediaType实例，74 x 105 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A8
      用于ISO / DIN和JIS A8的MediaType实例，52 x 74 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_A9
      用于ISO / DIN和JIS A9的MediaType实例，37 x 52 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B0
      用于ISO / DIN B0，1000 x 1414 mm的MediaType实例。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B1
      用于ISO / DIN B1，707 x 1000 mm的MediaType实例。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B10
      用于ISO / DIN B10的MediaType实例，31 x 44 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B2
      用于ISO / DIN B2的MediaType实例，500 x 707 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B3
      ISO / DIN B3的MediaType实例，353 x 500 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B4
      用于ISO / DIN B4的MediaType实例，250 x 353 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B4_ENVELOPE
      ISO_B4的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B5
      用于ISO / DIN B5的介质类型实例，176 x 250 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B5_ENVELOPE
      ISO_B5的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B6
      用于ISO / DIN B6的MediaType实例，125 x 176 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B7
      用于ISO / DIN B7的MediaType实例，88 x 125 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B8
      用于ISO / DIN B8的MediaType实例，62 x 88 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_B9
      用于ISO / DIN B9的MediaType实例，44 x 62 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C0
      用于ISO / DIN C0的MediaType实例，917 x 1297 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C0_ENVELOPE
      ISO_C0的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C1
      用于ISO / DIN C1的MediaType实例，648 x 917 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C1_ENVELOPE
      ISO_C1的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C10
      用于ISO / DIN C10的MediaType实例，28 x 40 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C10_ENVELOPE
      ISO_C10的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C2
      用于ISO / DIN C2的MediaType实例，458 x 648 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C2_ENVELOPE
      ISO_C2的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C3
      用于ISO / DIN C3的MediaType实例，324 x 458 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C3_ENVELOPE
      ISO_C3的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C4
      ISO / DIN C4的MediaType实例，229 x 324 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C4_ENVELOPE
      ISO_C4的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C5
      用于ISO / DIN C5的MediaType实例，162 x 229 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C5_ENVELOPE
      ISO_C5的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C6
      用于ISO / DIN C6的MediaType实例，114 x 162 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C6_ENVELOPE
      ISO_C6的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C7
      用于ISO / DIN C7的MediaType实例，81 x 114 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C7_ENVELOPE
      ISO_C7的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C8
      用于ISO / DIN C8的MediaType实例，57 x 81 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C8_ENVELOPE
      ISO_C8的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C9
      用于ISO / DIN C9的MediaType实例，40 x 57 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_C9_ENVELOPE
      ISO_C9的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_DESIGNATED_LONG
      ISO指定长的介质类型实例，110 x 220 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.ISO_DESIGNATED_LONG_ENVELOPE
      ISO_DESIGNATED_LONG的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ITALY
      ITALY_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.ITALY_ENVELOPE
      意大利信封的MediaType实例，110 x 230毫米。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B0
      JIS B0的MediaType实例，1030 x 1456 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B1
      JIS B1的MediaType实例，728 x 1030 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B10
      JIS B10的MediaType实例，32 x 45 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B2
      JIS B2的MediaType实例，515 x 728 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B3
      JIS B3的MediaType实例，364 x 515毫米。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B4
      JIS B4的MediaType实例，257 x 364 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B5
      JIS B5的MediaType实例，182 x 257 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B6
      JIS B6的MediaType实例，128 x 182 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B7
      用于JIS B7的MediaType实例，91 x 128 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B8
      用于JIS B8的MediaType实例，64 x 91毫米。
      static PageAttributes.MediaType PageAttributes.MediaType.JIS_B9
      JIS B9的MediaType实例，45 x 64 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.LEDGER
      Ledger的MediaType实例，11 x 17 in。
      static PageAttributes.MediaType PageAttributes.MediaType.LEGAL
      NA_LEGAL的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.LETTER
      NA_LETTER的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.MONARCH
      MONARCH_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.MONARCH_ENVELOPE
      Monarch Envelope的MediaType实例，3 7/8 x 7 1/2 in。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_10X13_ENVELOPE
      MediaType实例为北美10 x 13 in。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_10X14_ENVELOPE
      北美10 x 14英寸的MediaType实例。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_10X15_ENVELOPE
      MediaType实例为北美10 x 15英寸
      static PageAttributes.MediaType PageAttributes.MediaType.NA_6X9_ENVELOPE
      北美6 x 9的MediaType实例。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_7X9_ENVELOPE
      北美7 x 9英寸的MediaType实例。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_9X11_ENVELOPE
      北美9 x 11英寸的MediaType实例
      static PageAttributes.MediaType PageAttributes.MediaType.NA_9X12_ENVELOPE
      北美9 x 12英寸的MediaType实例
      static PageAttributes.MediaType PageAttributes.MediaType.NA_LEGAL
      北美法律的MediaType实例，8 1/2 x 14英寸
      static PageAttributes.MediaType PageAttributes.MediaType.NA_LETTER
      北美信的MediaType实例，8 1/2 x 11 in。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_NUMBER_10_ENVELOPE
      North America＃10 Business Envelope的MediaType实例，4 1/8 x 9 1/2 in。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_NUMBER_11_ENVELOPE
      北美＃11商业信封的MediaType实例，4 1/2 x 10 3/8 in。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_NUMBER_12_ENVELOPE
      北美＃12商业信封的MediaType实例，4 3/4 x 11英寸
      static PageAttributes.MediaType PageAttributes.MediaType.NA_NUMBER_14_ENVELOPE
      North American＃14 Business Envelope的MediaType实例，5 x 11 1/2 in。
      static PageAttributes.MediaType PageAttributes.MediaType.NA_NUMBER_9_ENVELOPE
      北美＃9商业信封的MediaType实例，3 7/8 x 8 7/8 in。
      static PageAttributes.MediaType PageAttributes.MediaType.NOTE
      NA_LETTER的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.PERSONAL
      PERSONAL_ENVELOPE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.PERSONAL_ENVELOPE
      6 3/4信封的MediaType实例，3 5/8 x 6 1/2 in。
      static PageAttributes.MediaType PageAttributes.MediaType.QUARTO
      Quarto的MediaType实例，215 x 275 mm。
      static PageAttributes.MediaType PageAttributes.MediaType.STATEMENT
      INVOICE的别名。
      static PageAttributes.MediaType PageAttributes.MediaType.TABLOID
      LEDGER的别名。
      Methods in java.awt that return PageAttributes.MediaType
      Modifier and Type 方法 描述
      PageAttributes.MediaType PageAttributes.getMedia​()
      返回使用这些属性的页面的纸张大小。
      Methods in java.awt with parameters of type PageAttributes.MediaType
      Modifier and Type 方法 描述
      void PageAttributes.setMedia​(PageAttributes.MediaType media)
      使用这些属性为页面指定所需的纸张尺寸。
      Constructors in java.awt with parameters of type PageAttributes.MediaType
      Constructor 描述
      PageAttributes​(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
      Constructs a PageAttributes instance with the specified values for every attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PageAttributes.OrientationRequestedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PageAttributes.OrientationRequestedType

  • Packages that use PageAttributes.OrientationRequestedType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PageAttributes.OrientationRequestedType in java.awt

      Fields in java.awt declared as PageAttributes.OrientationRequestedType
      Modifier and Type Field 描述
      static PageAttributes.OrientationRequestedType PageAttributes.OrientationRequestedType.LANDSCAPE
      用于指定横向的OrientationRequestedType实例。
      static PageAttributes.OrientationRequestedType PageAttributes.OrientationRequestedType.PORTRAIT
      用于指定纵向方向的OrientationRequestedType实例。
      Methods in java.awt that return PageAttributes.OrientationRequestedType
      Modifier and Type 方法 描述
      PageAttributes.OrientationRequestedType PageAttributes.getOrientationRequested​()
      返回使用这些属性的页面的打印方向。
      Methods in java.awt with parameters of type PageAttributes.OrientationRequestedType
      Modifier and Type 方法 描述
      void PageAttributes.setOrientationRequested​(PageAttributes.OrientationRequestedType orientationRequested)
      指定使用这些属性的页面的打印方向。
      Constructors in java.awt with parameters of type PageAttributes.OrientationRequestedType
      Constructor 描述
      PageAttributes​(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
      为每个属性构造一个具有指定值的PageAttributes实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PageAttributes.OriginType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PageAttributes.OriginType

  • Packages that use PageAttributes.OriginType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PageAttributes.OriginType in java.awt

      Fields in java.awt declared as PageAttributes.OriginType
      Modifier and Type Field 描述
      static PageAttributes.OriginType PageAttributes.OriginType.PHYSICAL
      用于指定物理原点的OriginType实例。
      static PageAttributes.OriginType PageAttributes.OriginType.PRINTABLE
      用于指定可打印原点的OriginType实例。
      Methods in java.awt that return PageAttributes.OriginType
      Modifier and Type 方法 描述
      PageAttributes.OriginType PageAttributes.getOrigin​()
      返回是否使用这些属性绘制（0,0）到页面的物理页面的左上角或可打印区域的左上角。
      Methods in java.awt with parameters of type PageAttributes.OriginType
      Modifier and Type 方法 描述
      void PageAttributes.setOrigin​(PageAttributes.OriginType origin)
      指定使用这些属性绘制（0，0）到页面是否绘制在物理页面的左上角或可打印区域的左上角。
      Constructors in java.awt with parameters of type PageAttributes.OriginType
      Constructor 描述
      PageAttributes​(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
      为每个属性构造一个具有指定值的PageAttributes实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PageAttributes.PrintQualityType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PageAttributes.PrintQualityType

  • Packages that use PageAttributes.PrintQualityType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PageAttributes.PrintQualityType in java.awt

      Fields in java.awt declared as PageAttributes.PrintQualityType
      Modifier and Type Field 描述
      static PageAttributes.PrintQualityType PageAttributes.PrintQualityType.DRAFT
      PrintQualityType实例用于指定打印质量草图。
      static PageAttributes.PrintQualityType PageAttributes.PrintQualityType.HIGH
      PrintQualityType实例用于指定高打印质量。
      static PageAttributes.PrintQualityType PageAttributes.PrintQualityType.NORMAL
      PrintQualityType实例用于指定正常的打印质量。
      Methods in java.awt that return PageAttributes.PrintQualityType
      Modifier and Type 方法 描述
      PageAttributes.PrintQualityType PageAttributes.getPrintQuality​()
      使用这些属性返回页面的打印质量。
      Methods in java.awt with parameters of type PageAttributes.PrintQualityType
      Modifier and Type 方法 描述
      void PageAttributes.setPrintQuality​(PageAttributes.PrintQualityType printQuality)
      使用这些属性指定页面的打印质量。
      Constructors in java.awt with parameters of type PageAttributes.PrintQualityType
      Constructor 描述
      PageAttributes​(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
      Constructs a PageAttributes instance with the specified values for every attribute.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Panel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Panel

  • Packages that use Panel
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Panel in java.applet

      Subclasses of Panel in java.applet
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of Panel in javax.swing

      Subclasses of Panel in javax.swing
      Modifier and Type Class 描述
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Panel.AccessibleAWTPanel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Panel.AccessibleAWTPanel

  • Packages that use Panel.AccessibleAWTPanel
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Panel.AccessibleAWTPanel in java.applet

      Subclasses of Panel.AccessibleAWTPanel in java.applet
      Modifier and Type Class 描述
      protected class  Applet.AccessibleApplet
      已过时。
      这个类实现 Applet类的可访问性支持。

    • Uses of Panel.AccessibleAWTPanel in javax.swing

      Subclasses of Panel.AccessibleAWTPanel in javax.swing
      Modifier and Type Class 描述
      protected class  JApplet.AccessibleJApplet
      已过时。
      这个类实现 JApplet类的辅助功能支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Point (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Point

  • Packages that use Point
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.image
    提供创建和修改图像的类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.imageio
    Java Image I / O API的主要包。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Point in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Point
      Modifier and Type 方法 描述
      static Point EventQueueMonitor.getCurrentMousePosition​()
      将鼠标的最后记录位置返回到屏幕坐标。
      Point Translator.getLocation​()
      返回对象相对于父对象的位置。
      Point Translator.getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Methods in com.sun.java.accessibility.util with parameters of type Point
      Modifier and Type 方法 描述
      boolean Translator.contains​(Point p)
      检查指定的 Point是否在该对象的边界内，其中 Point是相对于对象的坐标系。
      static Accessible EventQueueMonitor.getAccessibleAt​(Point p)
      在屏幕上的给定点获取Accessible对象。
      Accessible Translator.getAccessibleAt​(Point p)
      返回包含在本地坐标Point（如果存在）的可访问子项。
      void Translator.setLocation​(Point p)
      设置对象相对于父对象的位置。

    • Uses of Point in java.awt

      Methods in java.awt that return Point
      Modifier and Type 方法 描述
      Point GraphicsEnvironment.getCenterPoint​()
      返回Windows应该居中的点。
      Point GridBagLayout.getLayoutOrigin​()
      确定目标容器的图形坐标空间中的布局区域的原点。
      Point Component.AccessibleAWTComponent.getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point Component.getLocation​()
      以指定组件左上角的点的形式获取此组件的位置。
      Point Component.getLocation​(Point rv)
      将该组件的x，y原点存储到“返回值” rv并返回 rv 。
      Point List.AccessibleAWTList.AccessibleAWTListChild.getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point MenuComponent.AccessibleAWTMenuComponent.getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point Point.getLocation​()
      返回这一点的位置。
      Point PointerInfo.getLocation​()
      返回表示指针在屏幕上的坐标的 Point 。
      Point Rectangle.getLocation​()
      返回这个 Rectangle的位置。
      Point Component.AccessibleAWTComponent.getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Point Component.getLocationOnScreen​()
      以指定组件左上角的点的形式获取此组件的位置。
      Point List.AccessibleAWTList.AccessibleAWTListChild.getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Point MenuComponent.AccessibleAWTMenuComponent.getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Point Component.getMousePosition​()
      如果 Component直接位于鼠标指针下，则返回鼠标指针在 Component的坐标空间中的位置，否则返回 null 。
      Point Container.getMousePosition​(boolean allowChildren)
      返回鼠标指针在该位置 Container的坐标空间，如果 Container是鼠标指针下，否则返回 null 。
      Point ScrollPane.getScrollPosition​()
      返回显示在滚动面板视图端口的0,0位置的子项内的当前x，y位置。
      Point Component.location​()
      已过时。
      从JDK 1.1版开始，由getLocation()替代。
      Point GridBagLayout.location​(int x, int y)
      确定布局网格中的单元格包含由 (x, y)指定的点。
      Methods in java.awt with parameters of type Point
      Modifier and Type 方法 描述
      void Rectangle.add​(Point pt)
      添加指定 Point本的界限 Rectangle 。
      boolean Component.AccessibleAWTComponent.contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      boolean Component.contains​(Point p)
      检查此组件是否“包含”指定点，其中点的 x和 y坐标被定义为相对于该组件的坐标系。
      boolean List.AccessibleAWTList.AccessibleAWTListChild.contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      boolean MenuComponent.AccessibleAWTMenuComponent.contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      boolean Polygon.contains​(Point p)
      确定指定的Point是否在此Polygon 。
      boolean Rectangle.contains​(Point p)
      检查此 Rectangle是否包含指定的 Point 。
      Cursor Toolkit.createCustomCursor​(Image cursor, Point hotSpot, String name)
      创建一个新的自定义光标对象。
      Component Container.findComponentAt​(Point p)
      找到包含指定点的可见子组件。
      Accessible Component.AccessibleAWTComponent.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果有的话）包含在本地坐标 Point 。
      Accessible Container.AccessibleAWTContainer.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果有的话）包含在本地坐标 Point 。
      Accessible List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      Accessible List.AccessibleAWTList.getAccessibleAt​(Point p)
      返回包含在本地坐标Point（如果存在）的Accessible子项。
      Accessible MenuComponent.AccessibleAWTMenuComponent.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      Component Component.getComponentAt​(Point p)
      返回包含指定点的组件或子组件。
      Component Container.getComponentAt​(Point p)
      获取包含指定点的组件。
      int TextComponent.AccessibleAWTTextComponent.getIndexAtPoint​(Point p)
      给定本地坐标点，返回该点下的字符从零开始的索引。
      Point Component.getLocation​(Point rv)
      将该组件的x，y原点存储到“返回值” rv并返回 rv 。
      void Component.AccessibleAWTComponent.setLocation​(Point p)
      设置对象相对于父对象的位置。
      void Component.setLocation​(Point p)
      将此组件移动到新位置。
      void List.AccessibleAWTList.AccessibleAWTListChild.setLocation​(Point p)
      设置对象相对于父对象的位置。
      void MenuComponent.AccessibleAWTMenuComponent.setLocation​(Point p)
      设置对象相对于父对象的位置。
      void Point.setLocation​(Point p)
      将点的位置设置为指定的位置。
      void Rectangle.setLocation​(Point p)
      将此 Rectangle移动到指定的位置。
      void Window.setLocation​(Point p)
      将此组件移动到新位置。
      void ScrollPane.setScrollPosition​(Point p)
      滚动到子组件中的指定位置。
      Constructors in java.awt with parameters of type Point
      Constructor 描述
      Point​(Point p)
      构造并初始化与指定的 Point对象相同位置的点。
      Rectangle​(Point p)
      构造一个新的 Rectangle其左上角是指定的 Point ，其宽度和高度均为零。
      Rectangle​(Point p, Dimension d)
      构造一个新的Rectangle其左上角由Point参数指定，其宽度和高度由Dimension参数指定。

    • Uses of Point in java.awt.dnd

      Methods in java.awt.dnd that return Point
      Modifier and Type 方法 描述
      Point DragGestureEvent.getDragOrigin​()
      返回 Point中的坐标 Component在开始拖动。
      Point DragSourceEvent.getLocation​()
      此方法返回一个 Point表示在此事件发生时屏幕坐标中的光标位置，如果未为此事件指定光标位置，则 null 。
      Point DropTargetDragEvent.getLocation​()
      此方法返回一个 Point表示 Component'的坐标中的 Cursor的当前位置。
      Point DropTargetDropEvent.getLocation​()
      该方法返回一个 Point指示 Cursor “在当前位置 Component坐标”。
      Methods in java.awt.dnd with parameters of type Point
      Modifier and Type 方法 描述
      void Autoscroll.autoscroll​(Point cursorLocn)
      通知 Component自动滚屏
      protected DragSourceContext DragSource.createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      protected DropTarget.DropTargetAutoScroller DropTarget.createDropTargetAutoScroller​(Component c, Point p)
      创建一个嵌入式自动推送器
      protected void DragGestureRecognizer.fireDragGestureRecognized​(int dragAction, Point p)
      通知DragGestureListener发生拖放启动手势。
      protected void DropTarget.initializeAutoscrolling​(Point p)
      初始化自动滚动
      void DragGestureEvent.startDrag​(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl)
      启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
      protected void DropTarget.updateAutoscroll​(Point dragCursorLocn)
      更新当前光标位置的自动滚动
      protected void DropTarget.DropTargetAutoScroller.updateLocation​(Point newLocn)
      导致自动滚屏发生
      Constructors in java.awt.dnd with parameters of type Point
      Constructor 描述
      DragGestureEvent​(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
      构造一个 DragGestureEvent由给定对象 DragGestureRecognizer实例激发此事件中， act表示用户的首选操作参数，一个 ori参数指示拖动原点，和一个 List组成动作（事件 evs参数）。
      DragSourceContext​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
      从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。
      DropTargetAutoScroller​(Component c, Point p)
      构建一个DropTargetAutoScroller
      DropTargetDragEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
      构造一个 DropTargetDragEvent给出的 DropTargetContext此操作中，“拖”的位置 Cursor “在S热点 Component坐标”，用户放置动作，和源drop操作。
      DropTargetDropEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
      构造一个 DropTargetDropEvent给出的 DropTargetContext进行此操作，拖动的位置 Cursor的在热点 Component坐标，当前选择的用户放置动作，和当前的一组源支持的操作“。
      DropTargetDropEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
      构造一个 DropTargetEvent给出了这个操作的 DropTargetContext ，拖动 Cursor的热点位置在 Component的坐标，当前选择的用户放置动作，当前由源支持的一组动作，以及 boolean是否指示源与目标相同的JVM。

    • Uses of Point in java.awt.event

      Methods in java.awt.event that return Point
      Modifier and Type 方法 描述
      Point MouseEvent.getLocationOnScreen​()
      返回事件的绝对x，y位置。
      Point MouseEvent.getPoint​()
      返回事件相对于源组件的x，y位置。

    • Uses of Point in java.awt.image

      Methods in java.awt.image that return Point
      Modifier and Type 方法 描述
      Point[] BufferedImage.getWritableTileIndices​()
      返回一个Point个对象的数组，指示哪些图块被签出用于写入。
      Point[] WritableRenderedImage.getWritableTileIndices​()
      返回一个Point对象数组，指示哪些tile被签出用于写入。
      Methods in java.awt.image with parameters of type Point
      Modifier and Type 方法 描述
      static WritableRaster Raster.createBandedRaster​(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location)
      基于具有指定数据类型，宽度，高度，扫描线步长，银行索引和带偏移的BandedSampleModel创建光栅。
      static WritableRaster Raster.createBandedRaster​(int dataType, int w, int h, int bands, Point location)
      根据具有指定数据类型，宽度，高度和频带数的BandedSampleModel创建栅格。
      static WritableRaster Raster.createBandedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location)
      根据指定的DataBuffer，width，height，scanline stride，bank index和band offsets创建一个基于BandedSampleModel的光栅。
      static WritableRaster Raster.createInterleavedRaster​(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location)
      基于具有指定数据类型，宽度，高度，扫描线步长，像素步长和带偏移的PixelInterleavedSampleModel创建光栅。
      static WritableRaster Raster.createInterleavedRaster​(int dataType, int w, int h, int bands, Point location)
      基于具有指定数据类型，宽度，高度和频带数的PixelInterleavedSampleModel创建光栅。
      static WritableRaster Raster.createInterleavedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长，像素步幅和带偏移的PixelInterleavedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(int dataType, int w, int h, int[] bandMasks, Point location)
      基于具有指定数据类型，宽度，高度和带屏蔽的SinglePixelPackedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(int dataType, int w, int h, int bands, int bitsPerBand, Point location)
      根据指定的数据类型，宽度，高度，频带数和每个频段的位数，打包SampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长和带屏蔽的SinglePixelPackedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location)
      基于具有指定DataBuffer，宽度，高度和每像素位数的MultiPixelPackedSampleModel创建光栅。
      static Raster Raster.createRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建光栅。
      static WritableRaster Raster.createWritableRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建WritableRaster。
      static WritableRaster Raster.createWritableRaster​(SampleModel sm, Point location)
      使用指定的SampleModel创建WritableRaster。
      Constructors in java.awt.image with parameters of type Point
      Constructor 描述
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造光栅。
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
      使用给定的SampleModel，DataBuffer和父构造栅格。
      Raster​(SampleModel sampleModel, Point origin)
      使用给定的SampleModel构造光栅。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造WritableRaster。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
      使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。
      WritableRaster​(SampleModel sampleModel, Point origin)
      使用给定的SampleModel构造WritableRaster。

    • Uses of Point in javax.accessibility

      Methods in javax.accessibility that return Point
      Modifier and Type 方法 描述
      Point AccessibleComponent.getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point AccessibleComponent.getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Methods in javax.accessibility with parameters of type Point
      Modifier and Type 方法 描述
      boolean AccessibleComponent.contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      Accessible AccessibleComponent.getAccessibleAt​(Point p)
      返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
      int AccessibleText.getIndexAtPoint​(Point p)
      给定局部坐标点，返回该点下的字符的从零开始的索引。
      void AccessibleComponent.setLocation​(Point p)
      设置对象相对于父对象的位置。

    • Uses of Point in javax.imageio

      Fields in javax.imageio declared as Point
      Modifier and Type Field 描述
      protected Point IIOParam.destinationOffset
      应放置左上角解码像素的目的地偏移量。
      Methods in javax.imageio that return Point
      Modifier and Type 方法 描述
      Point IIOParam.getDestinationOffset​()
      返回目标图像中要放置像素的偏移量。
      Methods in javax.imageio with parameters of type Point
      Modifier and Type 方法 描述
      void IIOParam.setDestinationOffset​(Point destinationOffset)
      指定目标图像中的未来解码像素的偏移量，读取时或写入区域的位置。

    • Uses of Point in javax.swing

      Fields in javax.swing declared as Point
      Modifier and Type Field 描述
      protected Point JViewport.lastPaintPosition
      最后一个 viewPosition我们画了，所以我们知道多少后备店的图像是有效的。
      Methods in javax.swing that return Point
      Modifier and Type | 方法 | 描述
      static Point SwingUtilities.convertPoint​(Component source, int x, int y, Component destination)
      将 source坐标系中的点 (x,y)转换为 destination坐标系。
      static Point SwingUtilities.convertPoint​(Component source, Point aPoint, Component destination)
      转换为 aPoint在 source坐标系 destination坐标系。
      Point TransferHandler.getDragImageOffset​()
      返回要拖动的图像的锚点偏移量。
      Point TransferHandler.DropLocation.getDropPoint​()
      返回下拉点，表示鼠标在组件内的当前位置。
      Point JComponent.getLocation​(Point rv)
      将该组件的x，y原点存储到“返回值” rv并返回 rv 。
      Point | JList.AccessibleJList.AccessibleJListChild.getLocation​()
      Point JTable.AccessibleJTable.AccessibleJTableCell.getLocation​()
      以指定对象的左上角的点的形式获取对象相对于父对象的位置。
      Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocation​()
      protected Point JTree.AccessibleJTree.AccessibleJTreeNode.getLocationInJTree​()
      返回节点的相对位置
      Point | JList.AccessibleJList.AccessibleJListChild.getLocationOnScreen​()
      Point JTable.AccessibleJTable.AccessibleJTableCell.getLocationOnScreen​()
      返回对象在屏幕上的位置。
      Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocationOnScreen​()
      Point JComponent.getPopupLocation​(MouseEvent event)
      返回在该组件的坐标系中显示弹出菜单的首选位置。
      protected Point JMenu.getPopupMenuOrigin​()
      计算 JMenu的弹出菜单的原点。
      Point JComponent.getToolTipLocation​(MouseEvent event)
      返回此组件坐标系中的工具提示位置。
      Point JViewport.getViewPosition​()
      返回出现在视口左上角的视图坐标，如果没有视图则返回0,0。
      Point JList.indexToLocation​(int index)
      返回列表坐标系中指定项目的原点。
      Point JViewport.toViewCoordinates​(Point p)
      转换像素坐标中的点以查看坐标。
      Methods in javax.swing with parameters of type Point
      Modifier and Type | 方法 | 描述
      int JTable.columnAtPoint​(Point point)
      返回 point所在列的索引，如果结果不在[ getColumnCount() -1]范围内，则 getColumnCount() -1。
      Component MenuSelectionManager.componentForPoint​(Component source, Point sourcePoint)
      返回当前所选路径中包含sourcePoint的组件。
      protected boolean JViewport.computeBlit​(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
      计算一个blit的参数，其中后备存储图像当前包含 oldLoc在左上角，我们正在滚动到 newLoc 。
      boolean | JList.AccessibleJList.AccessibleJListChild.contains​(Point p)
      boolean JTable.AccessibleJTable.AccessibleJTableCell.contains​(Point p)
      检查指定点是否在该对象的边界内，其中该点的x和y坐标被定义为相对于该对象的坐标系。
      boolean | JTree.AccessibleJTree.AccessibleJTreeNode.contains​(Point p)
      static Point SwingUtilities.convertPoint​(Component source, Point aPoint, Component destination)
      转换为 aPoint在 source坐标系 destination坐标系。
      static void SwingUtilities.convertPointFromScreen​(Point p, Component c)
      将一个点从屏幕坐标转换为组件的坐标系
      static void SwingUtilities.convertPointToScreen​(Point p, Component c)
      将点从组件的坐标系转换为屏幕坐标。
      Accessible JEditorPane.AccessibleJEditorPaneHTML.getAccessibleAt​(Point p)
      返回Accessible小组（如果存在）包含在本地坐标Point。
      Accessible | JList.AccessibleJList.AccessibleJListChild.getAccessibleAt​(Point p)
      Accessible JList.AccessibleJList.getAccessibleAt​(Point p)
      返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。
      Accessible JTabbedPane.AccessibleJTabbedPane.getAccessibleAt​(Point p)
      返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。
      Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAt​(Point p)
      Accessible JTable.AccessibleJTable.getAccessibleAt​(Point p)
      返回 Accessible小孩，如果存在，则包含在本地坐标 Point 。
      Accessible JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在），包含在本地坐标 Point 。
      Accessible JTree.AccessibleJTree.getAccessibleAt​(Point p)
      返回 Accessible小孩（如果存在的话）包含在本地坐标 Point 。
      static Accessible SwingUtilities.getAccessibleAt​(Component c, Point p)
      返回包含在本地坐标 Point中的 Accessible子 Point （如果存在）。
      int AbstractButton.AccessibleAbstractButton.getIndexAtPoint​(Point p)
      给定本地坐标点，返回该点下的字符从零开始的索引。
      int JLabel.AccessibleJLabel.getIndexAtPoint​(Point p)
      给定本地坐标点，返回该点下的字符从零开始的索引。
      int JSpinner.AccessibleJSpinner.getIndexAtPoint​(Point p)
      给定本地坐标点，返回该点下的字符从零开始的索引。
      int ProgressMonitor.AccessibleProgressMonitor.getIndexAtPoint​(Point p)
      给定本地坐标点，返回该点下的字符从零开始的索引。
      Point JComponent.getLocation​(Point rv)
      将该组件的x，y原点存储到“返回值” rv并返回 rv 。
      int JList.locationToIndex​(Point location)
      返回最接近列表坐标系中给定位置的单元格索引。
      int JTable.rowAtPoint​(Point point)
      返回 point所在行的索引，如果结果不在[ getRowCount() -1]范围内，则 getRowCount() -1。
      void TransferHandler.setDragImageOffset​(Point p)
      设置要拖动的图像的锚点偏移量。
      void | JList.AccessibleJList.AccessibleJListChild.setLocation​(Point p)
      void JTable.AccessibleJTable.AccessibleJTableCell.setLocation​(Point p)
      设置对象相对于父对象的位置。
      void | JTree.AccessibleJTree.AccessibleJTreeNode.setLocation​(Point p)
      void JViewport.setViewPosition​(Point p)
      设置出现在视口左上角的视图坐标，如果没有视图，则不执行任何操作。
      Point JViewport.toViewCoordinates​(Point p)
      转换像素坐标中的点以查看坐标。
      Constructors in javax.swing with parameters of type Point
      Constructor 描述
      DropLocation​(Point dropPoint)
      为给定点构建一个放置位置。

    • Uses of Point in javax.swing.plaf

      Methods in javax.swing.plaf that return Point
      Modifier and Type 方法 描述
      abstract Point ListUI.indexToLocation​(JList<?> list, int index)
      返回列表坐标系中给定的 JList中指定项目的原点。
      Methods in javax.swing.plaf with parameters of type Point
      Modifier and Type 方法 描述
      String TextUI.getToolTipText​(JTextComponent t, Point pt)
      已过时。
      替换为TextUI.getToolTipText2D(JTextComponent, Point2D)
      abstract int ListUI.locationToIndex​(JList<?> list, Point location)
      返回最接近列表坐标系中给定位置的指定的 JList中的单元 JList 。
      abstract int TextUI.viewToModel​(JTextComponent t, Point pt)
      已过时。
      替换为TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
      abstract int TextUI.viewToModel​(JTextComponent t, Point pt, Position.Bias[] biasReturn)
      已过时。
      替换为TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])

    • Uses of Point in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Point
      Modifier and Type Field 描述
      protected Point BasicToolBarUI.DockingListener.origin
      原点。
      Methods in javax.swing.plaf.basic that return Point
      Modifier and Type 方法 描述
      Point BasicToolBarUI.DragWindow.getOffset​()
      返回偏移量。
      protected Point BasicProgressBarUI.getStringPlacement​(Graphics g, String progressString, int x, int y, int width, int height)
      指定进度字符串将被绘制的地方。
      Point BasicListUI.indexToLocation​(JList<?> list, int index)
      返回列表坐标系中给定的 JList中指定项目的原点。
      Methods in javax.swing.plaf.basic with parameters of type Point
      Modifier and Type 方法 描述
      boolean BasicToolBarUI.canDock​(Component c, Point p)
      如果 JToolBar可以在给定的位置停靠，则返回 true 。
      protected void BasicToolBarUI.dragTo​(Point position, Point origin)
      该方法是用来拖动 DragWindow在 JToolBar被拖动。
      protected void BasicToolBarUI.floatAt​(Point position, Point origin)
      在拖动结束时调用该方法将框架放置在其原始位置或其浮动框架中。
      String BasicTextUI.getToolTipText​(JTextComponent t, Point pt)
      返回要用作传入位置的工具提示的字符串。
      int BasicListUI.locationToIndex​(JList<?> list, Point location)
      返回最接近列表坐标系中给定位置的指定的 JList中的单元 JList 。
      void BasicToolBarUI.setFloating​(boolean b, Point p)
      设置浮动属性。
      void BasicToolBarUI.DragWindow.setOffset​(Point p)
      设置偏移量。
      int BasicTextUI.viewToModel​(JTextComponent tc, Point pt)
      已过时。
      替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
      int BasicTextUI.viewToModel​(JTextComponent tc, Point pt, Position.Bias[] biasReturn)
      已过时。
      替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])

    • Uses of Point in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type Point
      Modifier and Type 方法 描述
      protected void MetalToolBarUI.setDragOffset​(Point p)
      设置鼠标光标在DragWindow内的偏移量。

    • Uses of Point in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return Point
      Modifier and Type 方法 描述
      Point MultiListUI.indexToLocation​(JList<?> a, int b)
      在此对象处理的每个UI上调用 indexToLocation方法。
      Methods in javax.swing.plaf.multi with parameters of type Point
      Modifier and Type 方法 描述
      String MultiTextUI.getToolTipText​(JTextComponent a, Point b)
      在此对象处理的每个UI上调用 getToolTipText方法。
      int MultiListUI.locationToIndex​(JList<?> a, Point b)
      在此对象处理的每个UI上调用 locationToIndex方法。
      int MultiTextUI.viewToModel​(JTextComponent a, Point b)
      已过时。
      int MultiTextUI.viewToModel​(JTextComponent a, Point b, Position.Bias[] c)
      已过时。

    • Uses of Point in javax.swing.table

      Methods in javax.swing.table that return Point
      Modifier and Type | 方法 | 描述
      Point | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocation​()
      Point | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocationOnScreen​()
      Methods in javax.swing.table with parameters of type Point
      Modifier and Type | 方法 | 描述
      int JTableHeader.columnAtPoint​(Point point)
      返回 point所在列的索引，如果它位于边界之外，则返回-1。
      boolean | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.contains​(Point p)
      Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAt​(Point p)
      Accessible JTableHeader.AccessibleJTableHeader.getAccessibleAt​(Point p)
      返回Accessible小组（如果存在）包含在本地坐标Point。
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setLocation​(Point p)

    • Uses of Point in javax.swing.text

      Methods in javax.swing.text that return Point
      Modifier and Type 方法 描述
      Point Caret.getMagicCaretPosition​()
      获取当前的插入符号视觉位置。
      Point DefaultCaret.getMagicCaretPosition​()
      获取保留的插入符位置。
      Methods in javax.swing.text with parameters of type Point
      Modifier and Type 方法 描述
      int JTextComponent.AccessibleJTextComponent.getIndexAtPoint​(Point p)
      给定本地坐标点，返回该点下的字符从零开始的索引。
      void Caret.setMagicCaretPosition​(Point p)
      设置当前插入符的视觉位置。
      void DefaultCaret.setMagicCaretPosition​(Point p)
      保存当前插入位置。
      int JTextComponent.viewToModel​(Point pt)
      已过时。
      替换为JTextComponent.viewToModel2D(Point2D)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PointerInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PointerInfo

  • Packages that use PointerInfo
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PointerInfo in java.awt

      Methods in java.awt that return PointerInfo
      Modifier and Type 方法 描述
      static PointerInfo MouseInfo.getPointerInfo​()
      返回表示当前鼠标指针位置的 PointerInfo实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Polygon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Polygon

  • Packages that use Polygon
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Polygon in java.awt

      Methods in java.awt with parameters of type Polygon
      Modifier and Type 方法 描述
      void Graphics.drawPolygon​(Polygon p)
      绘制由指定的 Polygon对象定义的多边形的轮廓。
      void Graphics.fillPolygon​(Polygon p)
      使用图形上下文的当前颜色填充由指定的多边形对象定义的多边形。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PopupMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PopupMenu

  • Packages that use PopupMenu
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PopupMenu in java.awt

      Methods in java.awt that return PopupMenu
      Modifier and Type 方法 描述
      PopupMenu Taskbar.getMenu​()
      获取用于在系统任务区域中将项目添加到此应用程序图标的PopupMenu。
      PopupMenu TrayIcon.getPopupMenu​()
      返回与此 TrayIcon关联的弹出菜单。
      Methods in java.awt with parameters of type PopupMenu
      Modifier and Type 方法 描述
      void Component.add​(PopupMenu popup)
      将指定的弹出菜单添加到组件。
      void Taskbar.setMenu​(PopupMenu menu)
      将提供的PopupMenu的内容附加到任务区域中的应用程序图标。
      void TrayIcon.setPopupMenu​(PopupMenu popup)
      设置这个 TrayIcon的弹出菜单。
      Constructors in java.awt with parameters of type PopupMenu
      Constructor 描述
      TrayIcon​(Image image, String tooltip, PopupMenu popup)
      Creates a TrayIcon with the specified image, tooltip and popup menu.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PopupMenu.AccessibleAWTPopupMenu (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PopupMenu.AccessibleAWTPopupMenu

No usage of java.awt.PopupMenu.AccessibleAWTPopupMenu
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.PrintJob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.PrintJob

  • Packages that use PrintJob
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PrintJob in java.awt

      Methods in java.awt that return PrintJob
      Modifier and Type 方法 描述
      PrintJob PrintGraphics.getPrintJob​()
      返回此PrintGraphics对象始发的PrintJob对象。
      PrintJob Toolkit.getPrintJob​(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
      获取一个 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
      abstract PrintJob Toolkit.getPrintJob​(Frame frame, String jobtitle, Properties props)
      获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.RadialGradientPaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.RadialGradientPaint

  • Packages that use RadialGradientPaint
    软件包 描述
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。

    • Uses of RadialGradientPaint in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return RadialGradientPaint
      Modifier and Type 方法 描述
      protected RadialGradientPaint AbstractRegionPainter.decodeRadialGradient​(float x, float y, float r, float[] midpoints, Color[] colors)
      给定用于创建RadialGradientPaint的参数，此方法将创建并返回径向渐变画。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Rectangle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Rectangle

  • Packages that use Rectangle
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.awt.image
    提供创建和修改图像的类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.imageio
    Java Image I / O API的主要包。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Rectangle in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Rectangle
      Modifier and Type 方法 描述
      Rectangle Translator.getBounds​()
      返回此对象的当前边界。
      Methods in com.sun.java.accessibility.util with parameters of type Rectangle
      Modifier and Type 方法 描述
      void Translator.setBounds​(Rectangle r)
      设置此对象的当前边界。

    • Uses of Rectangle in java.awt

      Fields in java.awt declared as Rectangle
      Modifier and Type Field 描述
      protected Rectangle Polygon.bounds
      这个边界 Polygon 。
      Methods in java.awt that return Rectangle
      Modifier and Type 方法 描述
      Rectangle Component.bounds​()
      已过时。
      从JDK 1.1版开始，替换为getBounds() 。
      Rectangle Polygon.getBoundingBox​()
      已过时。
      从JDK 1.1版开始，替换为getBounds() 。
      Rectangle Component.AccessibleAWTComponent.getBounds​()
      以Rectangle对象的形式获取此对象的边界。
      Rectangle Component.getBounds​()
      以 Rectangle对象的形式获取此组件的边界。
      Rectangle Component.getBounds​(Rectangle rv)
      将此组件的边界存储到“返回值” rv并返回 rv 。
      abstract Rectangle GraphicsConfiguration.getBounds​()
      返回设备坐标中的 GraphicsConfiguration的边界。
      Rectangle List.AccessibleAWTList.AccessibleAWTListChild.getBounds​()
      以Rectangle对象的形式获取此对象的边界。
      Rectangle MenuComponent.AccessibleAWTMenuComponent.getBounds​()
      以 Rectangle对象的形式获取此对象的边界。
      Rectangle Polygon.getBounds​()
      获取这个 Polygon的边框。
      Rectangle Rectangle.getBounds​()
      获取边界 Rectangle如此 Rectangle 。
      Rectangle Shape.getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      Rectangle SplashScreen.getBounds​()
      返回启动屏幕窗口的边界为270466139404048 。
      Rectangle TextComponent.AccessibleAWTTextComponent.getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      abstract Rectangle Graphics.getClipBounds​()
      返回当前裁剪区域的边界矩形。
      Rectangle Graphics.getClipBounds​(Rectangle r)
      返回当前裁剪区域的边界矩形。
      Rectangle Graphics.getClipRect​()
      已过时。
      从JDK 1.1版开始，由getClipBounds()替代。
      Rectangle Frame.getMaximizedBounds​()
      获得此框架的最大化边界。
      Rectangle GraphicsEnvironment.getMaximumWindowBounds​()
      返回居中Windows的最大边界。
      Rectangle Rectangle.intersection​(Rectangle r)
      计算 Rectangle与指定的 Rectangle 。
      Rectangle Rectangle.union​(Rectangle r)
      计算 Rectangle与指定的 Rectangle 。
      Methods in java.awt with parameters of type Rectangle
      Modifier and Type 方法 描述
      void Rectangle.add​(Rectangle r)
      添加一个 Rectangle这个 Rectangle 。
      protected void GridBagLayout.adjustForGravity​(GridBagConstraints constraints, Rectangle r)
      根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
      protected void GridBagLayout.AdjustForGravity​(GridBagConstraints constraints, Rectangle r)
      根据约束几何和焊盘，将x，y，width和height字段调整为正确的值。
      boolean Rectangle.contains​(Rectangle r)
      检查这个 Rectangle是否完全包含指定的 Rectangle 。
      PaintContext Color.createContext​(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成纯色字段模式的PaintContext 。
      PaintContext GradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个PaintContext，用于生成线性颜色渐变模式。
      PaintContext LinearGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext Paint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成颜色模式的PaintContext 。
      PaintContext RadialGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成圆形径向颜色渐变图案的PaintContext 。
      PaintContext TexturePaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成平铺图像模式的PaintContext 。
      MultiResolutionImage Robot.createMultiResolutionScreenCapture​(Rectangle screenRect)
      创建包含从屏幕读取的像素的图像。
      BufferedImage Robot.createScreenCapture​(Rectangle screenRect)
      创建包含从屏幕读取的像素的图像。
      Rectangle Component.getBounds​(Rectangle rv)
      将此组件的边界存储到“返回值” rv并返回 rv 。
      Rectangle Graphics.getClipBounds​(Rectangle r)
      返回当前裁剪区域的边界矩形。
      abstract boolean Graphics2D.hit​(Rectangle rect, Shape s, boolean onStroke)
      检查指定的Shape是否与设备空间中指定的Shape相交。
      Rectangle Rectangle.intersection​(Rectangle r)
      计算 Rectangle与指定的 Rectangle 。
      boolean Rectangle.intersects​(Rectangle r)
      确定此 Rectangle和指定的 Rectangle相交。
      void Component.AccessibleAWTComponent.setBounds​(Rectangle r)
      以 Rectangle对象的形式设置此对象的边界。
      void Component.setBounds​(Rectangle r)
      移动并调整此组件的大小以符合新的边框矩形 r 。
      void List.AccessibleAWTList.AccessibleAWTListChild.setBounds​(Rectangle r)
      以Rectangle对象的形式设置此对象的边界。
      void MenuComponent.AccessibleAWTMenuComponent.setBounds​(Rectangle r)
      以 Rectangle对象的形式设置此对象的边界。
      void Rectangle.setBounds​(Rectangle r)
      设置此 Rectangle的边界 Rectangle以匹配指定的 Rectangle 。
      void Window.setBounds​(Rectangle r)
      移动并调整此组件的大小以符合新的边框矩形 r 。
      void Frame.setMaximizedBounds​(Rectangle bounds)
      设置此框架的最大化边界。
      Rectangle Rectangle.union​(Rectangle r)
      计算 Rectangle与指定的 Rectangle 。
      Constructors in java.awt with parameters of type Rectangle
      Constructor 描述
      Rectangle​(Rectangle r)
      构造新的 Rectangle ，初始化以匹配指定的 Rectangle 。

    • Uses of Rectangle in java.awt.event

      Methods in java.awt.event that return Rectangle
      Modifier and Type 方法 描述
      Rectangle PaintEvent.getUpdateRect​()
      返回表示需要重绘的区域的矩形，以响应此事件。
      Methods in java.awt.event with parameters of type Rectangle
      Modifier and Type 方法 描述
      void PaintEvent.setUpdateRect​(Rectangle updateRect)
      设置表示需要重新绘制的区域的矩形以响应此事件。
      Constructors in java.awt.event with parameters of type Rectangle
      Constructor 描述
      PaintEvent​(Component source, int id, Rectangle updateRect)
      使用指定的源组件和类型构造一个 PaintEvent对象。

    • Uses of Rectangle in java.awt.font

      Methods in java.awt.font that return Rectangle
      Modifier and Type 方法 描述
      Rectangle GlyphVector.getGlyphPixelBounds​(int index, FontRenderContext renderFRC, float x, float y)
      当这个返回index字形的像素边界 GlyphVector在渲染 Graphics给定 FontRenderContext在给定位置。
      Rectangle GlyphVector.getPixelBounds​(FontRenderContext renderFRC, float x, float y)
      在给定位置的给定 FontRenderContext的图形中渲染时，返回此 GlyphVector的像素边界。
      Rectangle TextLayout.getPixelBounds​(FontRenderContext frc, float x, float y)
      在给定位置的给定 FontRenderContext的图形中渲染时，返回 TextLayout的像素边界。

    • Uses of Rectangle in java.awt.geom

      Methods in java.awt.geom that return Rectangle
      Modifier and Type 方法 描述
      Rectangle Area.getBounds​()
      返回边界Rectangle完全包围此Area 。
      Rectangle CubicCurve2D.getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      Rectangle Line2D.getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      Rectangle Path2D.getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      Rectangle QuadCurve2D.getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      Rectangle RectangularShape.getBounds​()
      返回一个整数Rectangle完全包围Shape 。

    • Uses of Rectangle in java.awt.im

      Methods in java.awt.im that return Rectangle
      Modifier and Type 方法 描述
      Rectangle InputMethodRequests.getTextLocation​(TextHitInfo offset)
      获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。

    • Uses of Rectangle in java.awt.im.spi

      Methods in java.awt.im.spi with parameters of type Rectangle
      Modifier and Type 方法 描述
      void InputMethod.notifyClientWindowChange​(Rectangle bounds)
      通知客户端窗口位置或状态的这种输入方式的更改。

    • Uses of Rectangle in java.awt.image

      Methods in java.awt.image that return Rectangle
      Modifier and Type 方法 描述
      Rectangle Raster.getBounds​()
      返回此栅格的边界矩形。
      Methods in java.awt.image with parameters of type Rectangle
      Modifier and Type 方法 描述
      WritableRaster Raster.createCompatibleWritableRaster​(Rectangle rect)
      创建一个兼容的WritableRaster，它具有由rect指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。
      Raster BufferedImage.getData​(Rectangle rect)
      计算并返回 BufferedImage的任意区域。
      Raster RenderedImage.getData​(Rectangle rect)
      计算并返回RenderedImage的任意区域。
      Constructors in java.awt.image with parameters of type Rectangle
      Constructor 描述
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
      使用给定的SampleModel，DataBuffer和父构造栅格。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
      使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。

    • Uses of Rectangle in java.beans

      Methods in java.beans with parameters of type Rectangle
      Modifier and Type 方法 描述
      void PropertyEditor.paintValue​(Graphics gfx, Rectangle box)
      将值的表示绘制到屏幕不动产的给定区域。
      void PropertyEditorSupport.paintValue​(Graphics gfx, Rectangle box)
      将值的表示绘制到屏幕不动产的给定区域。

    • Uses of Rectangle in javax.accessibility

      Methods in javax.accessibility that return Rectangle
      Modifier and Type 方法 描述
      Rectangle AccessibleComponent.getBounds​()
      以 Rectangle对象的形式获取此对象的边界。
      Rectangle AccessibleText.getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      Rectangle AccessibleExtendedText.getTextBounds​(int startIndex, int endIndex)
      返回两个索引之间文本的边界矩形。
      Methods in javax.accessibility with parameters of type Rectangle
      Modifier and Type 方法 描述
      void AccessibleComponent.setBounds​(Rectangle r)
      以 Rectangle对象的形式设置此对象的边界。

    • Uses of Rectangle in javax.imageio

      Fields in javax.imageio declared as Rectangle
      Modifier and Type Field 描述
      protected Rectangle IIOParam.sourceRegion
      源区域，如果没有设置， null 。
      Methods in javax.imageio that return Rectangle
      Modifier and Type 方法 描述
      Rectangle IIOParam.getSourceRegion​()
      返回要使用的源区域。
      protected static Rectangle ImageReader.getSourceRegion​(ImageReadParam param, int srcWidth, int srcHeight)
      读者可以使用一种实用方法来计算应该读取的源图像的区域，同时考虑到所提供的 ImageReadParam中的任何源区域和子采样偏移设置。
      Methods in javax.imageio with parameters of type Rectangle
      Modifier and Type 方法 描述
      protected static void ImageReader.computeRegions​(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion)
      计算感兴趣的源区域和目标区域，将源图像的宽度和高度，可选的目标图像和可选的 ImageReadParam考虑在内。
      void ImageWriter.prepareReplacePixels​(int imageIndex, Rectangle region)
      准备作者处理一系列对 replacePixels方法的电话。
      void IIOParam.setSourceRegion​(Rectangle sourceRegion)
      设置感兴趣的源区域。

    • Uses of Rectangle in javax.swing

      Methods in javax.swing that return Rectangle
      Modifier and Type | 方法 | 描述
      static Rectangle SwingUtilities.calculateInnerArea​(JComponent c, Rectangle r)
      存储 r指定组件的 r区域的位置和大小，并返回 r 。
      static Rectangle[] SwingUtilities.computeDifference​(Rectangle rectA, Rectangle rectB)
      方便返回一组 rectA ，表示 rectA内与 rectB不重叠的 rectB 。
      static Rectangle SwingUtilities.computeIntersection​(int x, int y, int width, int height, Rectangle dest)
      方便计算两个矩形的交点，而不分配一个新的矩形。
      static Rectangle SwingUtilities.computeUnion​(int x, int y, int width, int height, Rectangle dest)
      计算两个矩形的并集而不分配新矩形的便捷方法。
      static Rectangle SwingUtilities.convertRectangle​(Component source, Rectangle aRectangle, Component destination)
      将 source坐标系中的矩形 aRectangle转换为 destination坐标系。
      Rectangle JComponent.getBounds​(Rectangle rv)
      将此组件的边界存储为“返回值” rv并返回 rv 。
      Rectangle | JList.AccessibleJList.AccessibleJListChild.getBounds​()
      Rectangle | JTable.AccessibleJTable.AccessibleJTableCell.getBounds​()
      Rectangle | JTree.AccessibleJTree.AccessibleJTreeNode.getBounds​()
      Rectangle JTabbedPane.getBoundsAt​(int index)
      在 index返回标签边界。
      protected Rectangle DefaultDesktopManager.getBoundsForIconOf​(JInternalFrame f)
      iconifyFrame()代码调用这个来确定desktopIcon的正确边界。
      Rectangle JList.getCellBounds​(int index0, int index1)
      返回列表坐标系中由两个索引指定的单元格范围的边界矩形。
      Rectangle JTable.getCellRect​(int row, int column, boolean includeSpacing)
      返回位于 row和 column交点处的单元格的矩形。
      Rectangle AbstractButton.AccessibleAbstractButton.getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      Rectangle JLabel.AccessibleJLabel.getCharacterBounds​(int i)
      返回字符串中给定索引处字符的边界框。
      Rectangle JSpinner.AccessibleJSpinner.getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      Rectangle ProgressMonitor.AccessibleProgressMonitor.getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      Rectangle DebugGraphics.getClipBounds​()
      覆盖 Graphics.getClipBounds 。
      Rectangle RepaintManager.getDirtyRegion​(JComponent aComponent)
      返回组件当前的脏区域。
      static Rectangle SwingUtilities.getLocalBounds​(Component aComponent)
      返回组件 aComponent的矩形（0,0，bounds.width，bounds.height）
      Rectangle JInternalFrame.getNormalBounds​()
      如果JInternalFrame未处于最大化状态，则返回getBounds() ; 否则，返回JInternalFrame将被还原的范围。
      Rectangle JTree.getPathBounds​(TreePath path)
      返回指定节点将被绘制的 Rectangle 。
      protected Rectangle DefaultDesktopManager.getPreviousBounds​(JInternalFrame f)
      在组件最大化之前获取组件的正常范围。
      Rectangle JTree.getRowBounds​(int row)
      返回指定行中的节点被绘制的 Rectangle 。
      Rectangle JScrollPane.getViewportBorderBounds​()
      返回视口边框的边界。
      Rectangle ScrollPaneLayout.getViewportBorderBounds​(JScrollPane scrollpane)
      已过时。
      截至JDK版本的Swing1.1由JScrollPane.getViewportBorderBounds()替换。
      Rectangle JViewport.getViewRect​()
      返回原点为 getViewPosition ，大小为 getExtentSize 。
      Rectangle JComponent.getVisibleRect​()
      返回 Component的“可见矩形” - 该组件的可见矩形， new Rectangle(0, 0, getWidth(), getHeight())及其所有祖先的可见矩形的交集。
      Methods in javax.swing with parameters of type Rectangle
      Modifier and Type | 方法 | 描述
      static Rectangle SwingUtilities.calculateInnerArea​(JComponent c, Rectangle r)
      存储 r指定组件的 r区域的位置和大小，并返回 r 。
      protected boolean JViewport.computeBlit​(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
      计算一个blit的参数，其中后备存储图像当前包含在左上角的 oldLoc ，并且我们滚动到 newLoc 。
      static Rectangle[] SwingUtilities.computeDifference​(Rectangle rectA, Rectangle rectB)
      方便返回一个 rectA数组，表示 rectA中与 rectB不重叠的 rectB 。
      static Rectangle SwingUtilities.computeIntersection​(int x, int y, int width, int height, Rectangle dest)
      方便计算两个矩形的交点，而不分配一个新的矩形。
      static Rectangle SwingUtilities.computeUnion​(int x, int y, int width, int height, Rectangle dest)
      计算两个矩形的并集而不分配新矩形的便捷方法。
      void JComponent.computeVisibleRect​(Rectangle visibleRect)
      返回 Component的“可见矩形矩形” - 该组件的可见矩形与其所有祖先的交集。
      static Rectangle SwingUtilities.convertRectangle​(Component source, Rectangle aRectangle, Component destination)
      将 source坐标系中的矩形 aRectangle转换为 destination坐标系。
      Rectangle JComponent.getBounds​(Rectangle rv)
      将此组件的边界存储为“返回值” rv并返回 rv 。
      int JLayer.getScrollableBlockIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回滚动增量，这是显示逻辑行或列的组件所必需的，以便根据方向的值完全暴露一个行或列的块。
      int JList.getScrollableBlockIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回要滚动以显示下一个或上一个块的距离。
      int JTable.getScrollableBlockIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回 visibleRect.height或 visibleRect.width ，具体取决于该表的方向。
      int JTree.getScrollableBlockIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回块增量，这是高度或宽度的量 visibleRect ，基于 orientation 。
      int Scrollable.getScrollableBlockIncrement​(Rectangle visibleRect, int orientation, int direction)
      显示逻辑行或列的组件应计算将根据取向值完全暴露一行行或列的滚动增量。
      int JLayer.getScrollableUnitIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回滚动增量，这是显示逻辑行或列的组件所必需的，以便根据方向的值完全暴露一个新行或列。
      int JList.getScrollableUnitIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回滚动的距离以显示下一行或上一行（垂直滚动）或列（用于水平滚动）。
      int JTable.getScrollableUnitIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回完全暴露一个新行或列的滚动增量（以像素为单位）（取决于方向）。
      int JTextArea.getScrollableUnitIncrement​(Rectangle visibleRect, int orientation, int direction)
      显示逻辑行或列的组件应计算将根据取向值完全暴露一个新行或列的滚动增量。
      int JTree.getScrollableUnitIncrement​(Rectangle visibleRect, int orientation, int direction)
      返回滚动时增加的量。
      int Scrollable.getScrollableUnitIncrement​(Rectangle visibleRect, int orientation, int direction)
      显示逻辑行或列的组件应计算将根据取向值完全暴露一个新行或列的滚动增量。
      static boolean SwingUtilities.isRectangleContainingRectangle​(Rectangle a, Rectangle b)
      返回 true如果@ {代码}包含 b
      static String SwingUtilities.layoutCompoundLabel​(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。
      static String SwingUtilities.layoutCompoundLabel​(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。
      void CellRendererPane.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      调用this.paintComponent（）与矩形x，y，width，height字段。
      static void SwingUtilities.paintComponent​(Graphics g, Component c, Container p, Rectangle r)
      绘制一个组件到指定的 Graphics 。
      void JComponent.paintImmediately​(Rectangle r)
      现在涂漆指定区域。
      void DefaultListCellRenderer.repaint​(Rectangle r)
      由于性能原因而被覆盖。
      void JComponent.repaint​(Rectangle r)
      如果组件显示，则将指定的区域添加到脏区列表。
      void JComponent.scrollRectToVisible​(Rectangle aRect)
      向 JComponent的父母转发 scrollRectToVisible()消息。
      void JTextField.scrollRectToVisible​(Rectangle r)
      向左或向右滚动字段。
      void JViewport.scrollRectToVisible​(Rectangle contentRect)
      滚动视图，使视图内的 Rectangle变得可见。
      void | JList.AccessibleJList.AccessibleJListChild.setBounds​(Rectangle r)
      void | JTable.AccessibleJTable.AccessibleJTableCell.setBounds​(Rectangle r)
      void | JTree.AccessibleJTree.AccessibleJTreeNode.setBounds​(Rectangle r)
      void JInternalFrame.setNormalBounds​(Rectangle r)
      设置此内部框架的正常范围，该内部框架将从其最大化状态恢复到的边界。
      protected void DefaultDesktopManager.setPreviousBounds​(JInternalFrame f, Rectangle r)
      在最大化调用之前存储组件的边界。

    • Uses of Rectangle in javax.swing.border

      Methods in javax.swing.border that return Rectangle
      Modifier and Type 方法 描述
      Rectangle AbstractBorder.getInteriorRectangle​(Component c, int x, int y, int width, int height)
      这种方便方法调用静态方法。
      static Rectangle AbstractBorder.getInteriorRectangle​(Component c, Border b, int x, int y, int width, int height)
      使用参数减去边框的插入返回一个矩形。

    • Uses of Rectangle in javax.swing.plaf

      Methods in javax.swing.plaf that return Rectangle
      Modifier and Type 方法 描述
      abstract Rectangle ListUI.getCellBounds​(JList<?> list, int index1, int index2)
      返回给定列表的坐标系中由两个索引指定的单元格范围的边界矩形。
      abstract Rectangle TreeUI.getPathBounds​(JTree tree, TreePath path)
      返回包围路径中最后一个项目将被绘制的标签部分的Rectangle。
      abstract Rectangle TabbedPaneUI.getTabBounds​(JTabbedPane pane, int index)
      返回Tab边界的矩形。
      abstract Rectangle TextUI.modelToView​(JTextComponent t, int pos)
      已过时。
      替换为TextUI.modelToView2D(JTextComponent, int, Position.Bias)
      abstract Rectangle TextUI.modelToView​(JTextComponent t, int pos, Position.Bias bias)
      已过时。
      替换为TextUI.modelToView2D(JTextComponent, int, Position.Bias)

    • Uses of Rectangle in javax.swing.plaf.basic

      Subclasses of Rectangle in javax.swing.plaf.basic
      Modifier and Type Class 描述
      static class  BasicTextUI.BasicCaret
      接口默认实现 Caret 。
      Fields in javax.swing.plaf.basic declared as Rectangle
      Modifier and Type Field 描述
      protected Rectangle BasicProgressBarUI.boxRect
      用于保存弹出框（由getBox返回）的位置和大小以进行绘制。
      protected Rectangle BasicTabbedPaneUI.calcRect
      用于一般布局计算的矩形，以避免构建许多新的矩形。
      protected Rectangle BasicSliderUI.contentRect
      内容矩形
      protected Rectangle BasicSliderUI.focusRect
      焦点矩形
      protected Rectangle BasicSliderUI.labelRect
      标签矩形
      protected Rectangle[] BasicTabbedPaneUI.rects
      标签
      protected Rectangle BasicScrollBarUI.thumbRect
      拇指矩形
      protected Rectangle BasicSliderUI.thumbRect
      拇指矩形
      protected Rectangle BasicSliderUI.tickRect
      勾选矩形
      protected Rectangle BasicScrollBarUI.trackRect
      跟踪矩形
      protected Rectangle BasicSliderUI.trackRect
      跟踪矩形
      Methods in javax.swing.plaf.basic that return Rectangle
      Modifier and Type 方法 描述
      protected Rectangle BasicComboPopup.computePopupBounds​(int px, int py, int pw, int ph)
      基于组合框位置和封闭屏幕边界，计算组合框的弹出部分的位置和大小。
      protected Rectangle BasicProgressBarUI.getBox​(Rectangle r)
      存储将在 r为当前动画索引绘制的弹跳框的位置和大小，并返回 r 。
      Rectangle BasicListUI.getCellBounds​(JList<?> list, int index1, int index2)
      返回给定列表的坐标系中由两个索引指定的单元格范围的边界矩形。
      protected Rectangle BasicTreeUI.getDropLineRect​(JTree.DropLocation loc)
      返回下拉线的无界框。
      Rectangle BasicTreeUI.NodeDimensionsHandler.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle size)
      负责获取特定节点的大小。
      Rectangle BasicTreeUI.getPathBounds​(JTree tree, TreePath path)
      返回包围路径中最后一个项目将被绘制的标签部分的Rectangle。
      protected Rectangle BasicTabbedPaneUI.getTabBounds​(int tabIndex, Rectangle dest)
      返回JTabbedPane组件坐标空间中指定选项卡的边界。
      Rectangle BasicTabbedPaneUI.getTabBounds​(JTabbedPane pane, int i)
      返回指定选项卡索引的边界。
      protected Rectangle BasicScrollBarUI.getThumbBounds​()
      返回当前的大小/位置。
      protected Rectangle BasicScrollBarUI.getTrackBounds​()
      返回轨道的当前边界，即增量和减量按钮之间的空间，减去插值。
      protected Rectangle BasicTextUI.getVisibleEditorRect​()
      获取分配给根视图。
      Rectangle BasicTextUI.modelToView​(JTextComponent tc, int pos)
      已过时。
      替换为BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
      Rectangle BasicTextUI.modelToView​(JTextComponent tc, int pos, Position.Bias bias)
      已过时。
      替换为BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
      protected Rectangle BasicComboBoxUI.rectangleForCurrentValue​()
      返回保留用于绘制当前选定项目的区域。
      Methods in javax.swing.plaf.basic with parameters of type Rectangle
      Modifier and Type 方法 描述
      protected Rectangle BasicProgressBarUI.getBox​(Rectangle r)
      存储将在 r为当前动画索引绘制的弹跳框的位置和大小，并返回 r 。
      Rectangle BasicTreeUI.NodeDimensionsHandler.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle size)
      负责获取特定节点的大小。
      protected Rectangle BasicTabbedPaneUI.getTabBounds​(int tabIndex, Rectangle dest)
      返回JTabbedPane组件坐标空间中指定选项卡的边界。
      protected String BasicLabelUI.layoutCL​(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
      转发给SwingUtilities.layoutCompoundLabel（）的调用。
      protected void BasicTabbedPaneUI.layoutLabel​(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      Laysout一个标签。
      protected void BasicListUI.paintCell​(Graphics g, int row, Rectangle rowBounds, ListCellRenderer<Object> cellRenderer, ListModel<Object> dataModel, ListSelectionModel selModel, int leadIndex)
      绘制一个列表单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane进行绘制。
      void BasicComboBoxUI.paintCurrentValue​(Graphics g, Rectangle bounds, boolean hasFocus)
      绘制当前选定的项目。
      void BasicComboBoxUI.paintCurrentValueBackground​(Graphics g, Rectangle bounds, boolean hasFocus)
      绘制当前所选项目的背景。
      protected void BasicTreeUI.paintExpandControl​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的展开（切换）部分。
      protected void BasicButtonUI.paintFocus​(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      涂一个专注的按钮。
      protected void BasicRadioButtonUI.paintFocus​(Graphics g, Rectangle textRect, Dimension size)
      油漆聚焦单选按钮。
      protected void BasicTabbedPaneUI.paintFocusIndicator​(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      绘制焦点指示器。
      protected void BasicTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      涂抹腿部的水平部分。
      protected void BasicButtonUI.paintIcon​(Graphics g, JComponent c, Rectangle iconRect)
      绘制当前按钮的图标。
      protected void BasicTabbedPaneUI.paintIcon​(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
      画一个图标。
      protected void BasicToggleButtonUI.paintIcon​(Graphics g, AbstractButton b, Rectangle iconRect)
      在指定位置绘制图标。
      protected void BasicSliderUI.paintMajorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      绘制水平滑块的主要刻度。
      protected void BasicSliderUI.paintMajorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      绘制垂直滑块的主要刻度。
      protected void BasicSliderUI.paintMinorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      为水平滑块绘制小刻度。
      protected void BasicSliderUI.paintMinorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      为垂直滑块绘制小刻度。
      protected void BasicTreeUI.paintRow​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的渲染器部分。
      protected void BasicTabbedPaneUI.paintTab​(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
      画一个标签。
      protected void BasicButtonUI.paintText​(Graphics g, AbstractButton b, Rectangle textRect, String text)
      呈现当前按钮文本的方法。
      protected void BasicButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)
      呈现当前按钮文本的方法。
      protected void BasicMenuItemUI.paintText​(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
      呈现当前菜单项的文本。
      protected void BasicTabbedPaneUI.paintText​(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
      油漆文字。
      protected void BasicScrollBarUI.paintThumb​(Graphics g, JComponent c, Rectangle thumbBounds)
      画拇指
      protected void BasicScrollBarUI.paintTrack​(Graphics g, JComponent c, Rectangle trackBounds)
      画轨道。
      protected void BasicTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      涂上腿部的垂直部分。

    • Uses of Rectangle in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type Rectangle
      Modifier and Type | 方法 | 描述
      void MetalComboBoxUI.paintCurrentValue​(Graphics g, Rectangle bounds, boolean hasFocus)
      如果需要，可以涂抹当前选择的项目。
      void MetalComboBoxUI.paintCurrentValueBackground​(Graphics g, Rectangle bounds, boolean hasFocus)
      如果需要，可以画出当前所选项目的背景。
      protected void | MetalButtonUI.paintFocus​(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void | MetalRadioButtonUI.paintFocus​(Graphics g, Rectangle t, Dimension d)
      protected void | MetalToggleButtonUI.paintFocus​(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void | MetalTabbedPaneUI.paintFocusIndicator​(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      protected void | MetalTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      protected void MetalToggleButtonUI.paintIcon​(Graphics g, AbstractButton b, Rectangle iconRect)
      在空间 iconRect绘制按钮 b的相应图标。
      protected void | MetalSliderUI.paintMajorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      protected void | MetalSliderUI.paintMajorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      protected void | MetalSliderUI.paintMinorTickForHorizSlider​(Graphics g, Rectangle tickBounds, int x)
      protected void | MetalSliderUI.paintMinorTickForVertSlider​(Graphics g, Rectangle tickBounds, int y)
      protected void | MetalButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)
      protected void | MetalToggleButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)
      protected void | MetalScrollBarUI.paintThumb​(Graphics g, JComponent c, Rectangle thumbBounds)
      protected void | MetalScrollBarUI.paintTrack​(Graphics g, JComponent c, Rectangle trackBounds)
      protected void | MetalTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

    • Uses of Rectangle in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return Rectangle
      Modifier and Type 方法 描述
      Rectangle MultiListUI.getCellBounds​(JList<?> a, int b, int c)
      在此对象处理的每个UI上调用 getCellBounds方法。
      Rectangle MultiTreeUI.getPathBounds​(JTree a, TreePath b)
      在此对象处理的每个UI上调用 getPathBounds方法。
      Rectangle MultiTabbedPaneUI.getTabBounds​(JTabbedPane a, int b)
      在此对象处理的每个UI上调用 getTabBounds方法。
      Rectangle MultiTextUI.modelToView​(JTextComponent a, int b)
      已过时。
      替换为MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)
      Rectangle MultiTextUI.modelToView​(JTextComponent a, int b, Position.Bias c)
      已过时。
      替换为MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)

    • Uses of Rectangle in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Rectangle
      Modifier and Type 方法 描述
      protected Rectangle SynthProgressBarUI.getBox​(Rectangle r)
      存储将在 r为当前动画索引绘制的弹跳框的位置和大小，并返回 r 。
      Methods in javax.swing.plaf.synth with parameters of type Rectangle
      Modifier and Type 方法 描述
      protected Rectangle SynthProgressBarUI.getBox​(Rectangle r)
      存储将在 r为当前动画索引绘制的弹跳框的位置和大小，并返回 r 。
      String SynthGraphicsUtils.layoutText​(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
      通过引用将文本和图标返回，放置图标和文本的位置。
      protected void SynthToolBarUI.paintContent​(SynthContext context, Graphics g, Rectangle bounds)
      绘制工具栏内容。
      void SynthComboBoxUI.paintCurrentValue​(Graphics g, Rectangle bounds, boolean hasFocus)
      绘制当前选定的项目。
      protected void SynthTreeUI.paintExpandControl​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      绘制一行的展开（切换）部分。
      protected void SynthTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      涂抹腿部的水平部分。
      void SynthGraphicsUtils.paintText​(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex)
      在指定位置绘制文本。
      protected void SynthScrollBarUI.paintThumb​(SynthContext context, Graphics g, Rectangle thumbBounds)
      绘制滚动条拇指。
      protected void SynthSliderUI.paintThumb​(SynthContext context, Graphics g, Rectangle thumbBounds)
      绘制滑块拇指。
      protected void SynthScrollBarUI.paintTrack​(SynthContext context, Graphics g, Rectangle trackBounds)
      绘制滚动条轨道。
      protected void SynthSliderUI.paintTrack​(SynthContext context, Graphics g, Rectangle trackBounds)
      绘制滑块轨道。
      protected void SynthTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      涂上腿部的垂直部分。

    • Uses of Rectangle in javax.swing.table

      Methods in javax.swing.table that return Rectangle
      Modifier and Type | 方法 | 描述
      Rectangle | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBounds​()
      Rectangle JTableHeader.getHeaderRect​(int column)
      返回包含标题图块的矩形为 column 。
      Methods in javax.swing.table with parameters of type Rectangle
      Modifier and Type | 方法 | 描述
      void DefaultTableCellRenderer.repaint​(Rectangle r)
      由于性能原因而被覆盖。
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setBounds​(Rectangle r)

    • Uses of Rectangle in javax.swing.text

      Subclasses of Rectangle in javax.swing.text
      Modifier and Type Class 描述
      class  DefaultCaret
      默认的Caret实现。
      Fields in javax.swing.text declared as Rectangle
      Modifier and Type Field 描述
      protected Rectangle AsyncBoxView.ChildLocator.childAlloc
      用于子分配的形状，以避免产生大量的垃圾。
      protected Rectangle AsyncBoxView.ChildLocator.lastAlloc
      最后看到的分配（当更改被刷新时重新绘制）。
      Methods in javax.swing.text that return Rectangle
      Modifier and Type 方法 描述
      Rectangle JTextComponent.AccessibleJTextComponent.getCharacterBounds​(int i)
      将给定索引处的字符的边框确定为字符串。
      protected Rectangle CompositeView.getInsideAllocation​(Shape a)
      将给予视图的不可变分配转换为表示内部分配的可变分配（即，删除顶，左，底和右插入的给定分配的边界。
      Rectangle JTextComponent.AccessibleJTextComponent.getTextBounds​(int startIndex, int endIndex)
      返回 Rectangle包含两个指标之间的文本。
      protected Rectangle PlainView.lineToRect​(Shape a, int line)
      确定表示给定行的矩形。
      Rectangle JTextComponent.modelToView​(int pos)
      已过时。
      替换为JTextComponent.modelToView2D(int)
      Methods in javax.swing.text with parameters of type Rectangle
      Modifier and Type 方法 描述
      protected void DefaultCaret.adjustVisibility​(Rectangle nloc)
      滚动关联视图（如有必要）使插入符可见。
      void FlowView.FlowStrategy.changedUpdate​(FlowView fv, DocumentEvent e, Rectangle alloc)
      在该视图负责的位置向文档发出属性更改的通知。
      protected void BoxView.childAllocation​(int index, Rectangle alloc)
      为子视图分配一个区域。
      protected abstract void CompositeView.childAllocation​(int index, Rectangle a)
      返回给定子项的分配。
      protected void DefaultCaret.damage​(Rectangle r)
      损坏插入符号周围的区域，使其在新的位置重画。
      int JTextComponent.getScrollableBlockIncrement​(Rectangle visibleRect, int orientation, int direction)
      显示逻辑行或列的组件应计算将根据取向值完全暴露一行行或列的滚动增量。
      int JTextComponent.getScrollableUnitIncrement​(Rectangle visibleRect, int orientation, int direction)
      显示逻辑行或列的组件应计算将根据取向值完全暴露一个新行或列的滚动增量。
      protected View BoxView.getViewAtPoint​(int x, int y, Rectangle alloc)
      在给定坐标处获取子视图。
      protected abstract View CompositeView.getViewAtPoint​(int x, int y, Rectangle alloc)
      在给定坐标处获取子视图。
      protected View CompositeView.getViewAtPosition​(int pos, Rectangle a)
      获取代表模型中给定位置的子视图。
      protected View TableView.getViewAtPosition​(int pos, Rectangle a)
      获取代表模型中给定位置的子视图。
      protected View TableView.TableRow.getViewAtPosition​(int pos, Rectangle a)
      获取代表模型中给定位置的子视图。
      void FlowView.FlowStrategy.insertUpdate​(FlowView fv, DocumentEvent e, Rectangle alloc)
      在给定的流程视图负责的位置发出通知。
      protected boolean BoxView.isAfter​(int x, int y, Rectangle innerAlloc)
      确定一个点是否落在分配的区域之后。
      protected abstract boolean CompositeView.isAfter​(int x, int y, Rectangle alloc)
      测试一个点是否在矩形范围之后。
      protected boolean BoxView.isBefore​(int x, int y, Rectangle innerAlloc)
      确定一个点是否落在分配的区域之前。
      protected abstract boolean CompositeView.isBefore​(int x, int y, Rectangle alloc)
      测试点是否在矩形范围之前。
      protected void BoxView.paintChild​(Graphics g, Rectangle alloc, int index)
      涂一个孩子
      void FlowView.FlowStrategy.removeUpdate​(FlowView fv, DocumentEvent e, Rectangle alloc)
      在给定流程视图负责的位置发出文档中已删除某些内容的通知。

    • Uses of Rectangle in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Rectangle
      Modifier and Type 方法 描述
      protected void ListView.paintChild​(Graphics g, Rectangle alloc, int index)
      画一个孩子; 由paint（）调用。

    • Uses of Rectangle in javax.swing.tree

      Methods in javax.swing.tree that return Rectangle
      Modifier and Type 方法 描述
      abstract Rectangle AbstractLayoutCache.getBounds​(TreePath path, Rectangle placeIn)
      返回一个给出绘制路径所需边界的矩形。
      Rectangle FixedHeightLayoutCache.getBounds​(TreePath path, Rectangle placeIn)
      返回一个给出绘制路径所需边界的矩形。
      Rectangle VariableHeightLayoutCache.getBounds​(TreePath path, Rectangle placeIn)
      返回包含 Rectangle标识的项目的标签部分的 path 。
      protected Rectangle AbstractLayoutCache.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle placeIn)
      通过参考，返回 placeIn ，表示 value所需的大小。
      abstract Rectangle AbstractLayoutCache.NodeDimensions.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle bounds)
      通过边界的引用返回大小和x的起始位置。
      Methods in javax.swing.tree with parameters of type Rectangle
      Modifier and Type 方法 描述
      abstract Rectangle AbstractLayoutCache.getBounds​(TreePath path, Rectangle placeIn)
      返回一个给出绘制路径所需边界的矩形。
      Rectangle FixedHeightLayoutCache.getBounds​(TreePath path, Rectangle placeIn)
      返回一个给出绘制路径所需边界的矩形。
      Rectangle VariableHeightLayoutCache.getBounds​(TreePath path, Rectangle placeIn)
      返回包含 Rectangle标识的项目的标签部分的 path 。
      protected Rectangle AbstractLayoutCache.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle placeIn)
      通过参考，返回 placeIn ，代表 value所需的大小。
      abstract Rectangle AbstractLayoutCache.NodeDimensions.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle bounds)
      通过边界的引用返回大小和x的起始位置。
      int AbstractLayoutCache.getPreferredWidth​(Rectangle bounds)
      返回传入区域的首选宽度。
      int VariableHeightLayoutCache.getPreferredWidth​(Rectangle bounds)
      返回 visibleRegion区域的首选宽度和高度。
      void DefaultTreeCellRenderer.repaint​(Rectangle r)
      由于性能原因而被覆盖。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.RenderingHints (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.RenderingHints

  • Packages that use RenderingHints
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of RenderingHints in java.awt

      Methods in java.awt that return RenderingHints
      Modifier and Type 方法 描述
      abstract RenderingHints Graphics2D.getRenderingHints​()
      获取渲染算法的首选项。
      Methods in java.awt with parameters of type RenderingHints
      Modifier and Type 方法 描述
      void RenderingHints.add​(RenderingHints hints)
      将所有的键和对应的值从指定的 RenderingHints对象添加到此 RenderingHints对象。
      CompositeContext AlphaComposite.createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建合成操作的上下文。
      PaintContext Color.createContext​(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成纯色字段模式的PaintContext 。
      CompositeContext Composite.createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建用于执行合成操作的上下文包含状态。
      PaintContext GradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext LinearGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext Paint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成颜色模式的PaintContext 。
      PaintContext RadialGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成圆形径向颜色渐变模式的PaintContext 。
      PaintContext TexturePaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成平铺图像模式的PaintContext 。

    • Uses of RenderingHints in java.awt.image

      Methods in java.awt.image that return RenderingHints
      Modifier and Type 方法 描述
      RenderingHints AffineTransformOp.getRenderingHints​()
      返回此变换操作使用的渲染提示。
      RenderingHints BandCombineOp.getRenderingHints​()
      返回此操作的呈现提示。
      RenderingHints BufferedImageOp.getRenderingHints​()
      返回此操作的呈现提示。
      RenderingHints ColorConvertOp.getRenderingHints​()
      返回此op使用的渲染提示。
      RenderingHints ConvolveOp.getRenderingHints​()
      返回此操作的渲染提示。
      RenderingHints LookupOp.getRenderingHints​()
      返回此操作的渲染提示。
      RenderingHints RasterOp.getRenderingHints​()
      返回此RasterOp的渲染提示。
      RenderingHints RescaleOp.getRenderingHints​()
      返回此操作的渲染提示。
      Constructors in java.awt.image with parameters of type RenderingHints
      Constructor 描述
      AffineTransformOp​(AffineTransform xform, RenderingHints hints)
      构造一个 AffineTransformOp给出一个仿射变换。
      BandCombineOp​(float[][] matrix, RenderingHints hints)
      构造具有指定矩阵的 BandCombineOp 。
      ColorConvertOp​(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
      从两个ColorSpace对象构造一个新的ColorConvertOp。
      ColorConvertOp​(ColorSpace cspace, RenderingHints hints)
      从ColorSpace对象构造一个新的ColorConvertOp。
      ColorConvertOp​(ICC_Profile[] profiles, RenderingHints hints)
      从ICC_Profiles数组构造一个新的ColorConvertOp。
      ColorConvertOp​(RenderingHints hints)
      构造一个新的ColorConvertOp，它将从源颜色空间转换为目标色彩空间。
      ConvolveOp​(Kernel kernel, int edgeCondition, RenderingHints hints)
      构造一个给定内核，边缘条件和RenderingHints对象（可能为null）的ConvolveOp。
      LookupOp​(LookupTable lookup, RenderingHints hints)
      给出一个 LookupOp对象，给出了查找表和一个 RenderingHints对象，可能是 null 。
      RescaleOp​(float[] scaleFactors, float[] offsets, RenderingHints hints)
      构建一个具有所需比例因子和偏移量的新RescaleOp。
      RescaleOp​(float scaleFactor, float offset, RenderingHints hints)
      构造一个具有所需比例因子和偏移量的新RescaleOp。

    • Uses of RenderingHints in java.awt.image.renderable

      Methods in java.awt.image.renderable that return RenderingHints
      Modifier and Type 方法 描述
      RenderingHints RenderContext.getRenderingHints​()
      获取这个 RenderContext的渲染提示。
      Methods in java.awt.image.renderable with parameters of type RenderingHints
      Modifier and Type 方法 描述
      RenderedImage RenderedImageFactory.create​(ParameterBlock paramBlock, RenderingHints hints)
      创建表示给定ParameterBlock和RenderingHints的成像操作（或操作链）的结果的RenderedImage。
      RenderedImage RenderableImage.createScaledRendering​(int w, int h, RenderingHints hints)
      以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。
      RenderedImage RenderableImageOp.createScaledRendering​(int w, int h, RenderingHints hints)
      以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。
      void RenderContext.setRenderingHints​(RenderingHints hints)
      设置这个 RenderContext的渲染提示。
      Constructors in java.awt.image.renderable with parameters of type RenderingHints
      Constructor 描述
      RenderContext​(AffineTransform usr2dev, RenderingHints hints)
      构造一个具有给定变换和渲染提示的RenderContext。
      RenderContext​(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
      构造具有给定变换的RenderContext。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.RenderingHints.Key (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.RenderingHints.Key

  • Packages that use RenderingHints.Key
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of RenderingHints.Key in java.awt

      Fields in java.awt declared as RenderingHints.Key
      Modifier and Type Field 描述
      static RenderingHints.Key RenderingHints.KEY_ALPHA_INTERPOLATION
      Alpha插补提示键。
      static RenderingHints.Key RenderingHints.KEY_ANTIALIASING
      抗锯齿提示键。
      static RenderingHints.Key RenderingHints.KEY_COLOR_RENDERING
      显色提示键。
      static RenderingHints.Key RenderingHints.KEY_DITHERING
      抖动提示键。
      static RenderingHints.Key RenderingHints.KEY_FRACTIONALMETRICS
      字体分数指标提示键。
      static RenderingHints.Key RenderingHints.KEY_INTERPOLATION
      插值提示键。
      static RenderingHints.Key RenderingHints.KEY_RENDERING
      呈现提示键。
      static RenderingHints.Key RenderingHints.KEY_RESOLUTION_VARIANT
      图像分辨率变体提示键。
      static RenderingHints.Key RenderingHints.KEY_STROKE_CONTROL
      中风归一化控制提示键。
      static RenderingHints.Key RenderingHints.KEY_TEXT_ANTIALIASING
      文本抗锯齿提示键。
      static RenderingHints.Key RenderingHints.KEY_TEXT_LCD_CONTRAST
      LCD文字对比度提示键。
      Methods in java.awt with parameters of type RenderingHints.Key
      Modifier and Type 方法 描述
      abstract Object Graphics2D.getRenderingHint​(RenderingHints.Key hintKey)
      返回渲染算法的单个首选项的值。
      abstract void Graphics2D.setRenderingHint​(RenderingHints.Key hintKey, Object hintValue)
      为渲染算法设置单个首选项的值。
      Constructors in java.awt with parameters of type RenderingHints.Key
      Constructor 描述
      RenderingHints​(RenderingHints.Key key, Object value)
      使用指定的键/值对构造新对象。
      Constructor parameters in java.awt with type arguments of type RenderingHints.Key
      Constructor 描述
      RenderingHints​(Map<RenderingHints.Key,?> init)
      构造一个新对象，该对象具有从指定的Map对象初始化的键和值，该对象可能为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Robot (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Robot

No usage of java.awt.Robot
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Scrollbar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Scrollbar

No usage of java.awt.Scrollbar
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Scrollbar.AccessibleAWTScrollBar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Scrollbar.AccessibleAWTScrollBar

No usage of java.awt.Scrollbar.AccessibleAWTScrollBar
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.ScrollPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.ScrollPane

No usage of java.awt.ScrollPane
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.ScrollPane.AccessibleAWTScrollPane (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.ScrollPane.AccessibleAWTScrollPane

No usage of java.awt.ScrollPane.AccessibleAWTScrollPane
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.ScrollPaneAdjustable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.ScrollPaneAdjustable

No usage of java.awt.ScrollPaneAdjustable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.SplashScreen (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.SplashScreen

  • Packages that use SplashScreen
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of SplashScreen in java.awt

      Methods in java.awt that return SplashScreen
      Modifier and Type 方法 描述
      static SplashScreen SplashScreen.getSplashScreen​()
      返回用于支持显示的系统上的Java启动启动画面控件的 SplashScreen对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.SystemColor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.SystemColor

  • Packages that use SystemColor
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of SystemColor in java.awt

      Fields in java.awt declared as SystemColor
      Modifier and Type Field 描述
      static SystemColor SystemColor.activeCaption
      为当前活动窗口的窗口标题背景呈现的颜色。
      static SystemColor SystemColor.activeCaptionBorder
      为当前活动窗口周围的边框渲染的颜色。
      static SystemColor SystemColor.activeCaptionText
      为当前活动窗口的窗口标题文本呈现的颜色。
      static SystemColor SystemColor.control
      为控制面板和控制对象（如按钮）的背景渲染的颜色。
      static SystemColor SystemColor.controlDkShadow
      在3D控件对象（如按钮）上为暗影区域呈现的颜色。
      static SystemColor SystemColor.controlHighlight
      为3D控制对象（如按钮）的亮区渲染颜色。
      static SystemColor SystemColor.controlLtHighlight
      为3D控件对象的高亮区域（如按钮）渲染颜色。
      static SystemColor SystemColor.controlShadow
      为3D控件对象（如按钮）的阴影区域呈现的颜色。
      static SystemColor SystemColor.controlText
      为控制面板和控制对象（如按钮）的文本呈现的颜色。
      static SystemColor SystemColor.desktop
      渲染为桌面背景的颜色。
      static SystemColor SystemColor.inactiveCaption
      为非活动窗口的窗口标题背景呈现的颜色。
      static SystemColor SystemColor.inactiveCaptionBorder
      为不活动窗口周围的边框渲染颜色。
      static SystemColor SystemColor.inactiveCaptionText
      为非活动窗口的窗口标题文本呈现的颜色。
      static SystemColor SystemColor.info
      为工具提示背景提供的颜色或现场帮助。
      static SystemColor SystemColor.infoText
      为文本提供的工具提示颜色或点帮助。
      static SystemColor SystemColor.menu
      呈现为菜单背景的颜色。
      static SystemColor SystemColor.menuText
      为菜单文本呈现的颜色。
      static SystemColor SystemColor.scrollbar
      呈现为滚动条背景的颜色。
      static SystemColor SystemColor.text
      为文本控件对象（如文本框和组合框）的背景渲染的颜色。
      static SystemColor SystemColor.textHighlight
      为所选项目的背景渲染的颜色，如菜单，组合框和文本。
      static SystemColor SystemColor.textHighlightText
      为所选项目的文本呈现的颜色，如菜单，组合框和文本。
      static SystemColor SystemColor.textInactiveText
      为非活动项目的文本呈现的颜色，如菜单中。
      static SystemColor SystemColor.textText
      为文本控件对象（如文本框和组合框）的文本呈现的颜色。
      static SystemColor SystemColor.window
      为Windows内部区域背景渲染的颜色。
      static SystemColor SystemColor.windowBorder
      为窗户内部区域的边界呈现的颜色。
      static SystemColor SystemColor.windowText
      为窗口内部区域的文字渲染的颜色。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.SystemTray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.SystemTray

  • Packages that use SystemTray
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of SystemTray in java.awt

      Methods in java.awt that return SystemTray
      Modifier and Type 方法 描述
      static SystemTray SystemTray.getSystemTray​()
      获取表示桌面托盘区域的 SystemTray实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Taskbar (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Taskbar

  • Packages that use Taskbar
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Taskbar in java.awt

      Methods in java.awt that return Taskbar
      Modifier and Type 方法 描述
      static Taskbar Taskbar.getTaskbar​()
      返回当前任务栏上下文的 Taskbar实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Taskbar.Feature (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Taskbar.Feature

  • Packages that use Taskbar.Feature
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Taskbar.Feature in java.awt

      Methods in java.awt that return Taskbar.Feature
      Modifier and Type 方法 描述
      static Taskbar.Feature Taskbar.Feature.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Taskbar.Feature[] Taskbar.Feature.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type Taskbar.Feature
      Modifier and Type 方法 描述
      boolean Taskbar.isSupported​(Taskbar.Feature feature)
      测试当前平台是否支持 Feature 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Taskbar.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Taskbar.State

  • Packages that use Taskbar.State
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Taskbar.State in java.awt

      Methods in java.awt that return Taskbar.State
      Modifier and Type 方法 描述
      static Taskbar.State Taskbar.State.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Taskbar.State[] Taskbar.State.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type Taskbar.State
      Modifier and Type 方法 描述
      void Taskbar.setWindowProgressState​(Window w, Taskbar.State state)
      设置指定窗口的进度状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TextArea (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TextArea

No usage of java.awt.TextArea
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TextArea.AccessibleAWTTextArea (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TextArea.AccessibleAWTTextArea

No usage of java.awt.TextArea.AccessibleAWTTextArea
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TextComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TextComponent

  • Packages that use TextComponent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of TextComponent in java.awt

      Subclasses of TextComponent in java.awt
      Modifier and Type Class 描述
      class  TextArea
      一个 TextArea对象是一个显示文本的多行区域。
      class  TextField
      一个 TextField对象是允许编辑单行文本的文本组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TextComponent.AccessibleAWTTextComponent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TextComponent.AccessibleAWTTextComponent

  • Packages that use TextComponent.AccessibleAWTTextComponent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of TextComponent.AccessibleAWTTextComponent in java.awt

      Subclasses of TextComponent.AccessibleAWTTextComponent in java.awt
      Modifier and Type Class 描述
      protected class  TextArea.AccessibleAWTTextArea
      这个类实现 TextArea类的可访问性支持。
      protected class  TextField.AccessibleAWTTextField
      这个类实现 TextField类的可访问性支持。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TextField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TextField

No usage of java.awt.TextField
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TextField.AccessibleAWTTextField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TextField.AccessibleAWTTextField

No usage of java.awt.TextField.AccessibleAWTTextField
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TexturePaint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TexturePaint

No usage of java.awt.TexturePaint
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Toolkit (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Toolkit

  • Packages that use Toolkit
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Toolkit in java.awt

      Methods in java.awt that return Toolkit
      Modifier and Type 方法 描述
      static Toolkit Toolkit.getDefaultToolkit​()
      获取默认工具包。
      Toolkit Component.getToolkit​()
      获取此组件的工具包。
      Toolkit Window.getToolkit​()
      返回此框架的工具包。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TrayIcon (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TrayIcon

  • Packages that use TrayIcon
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of TrayIcon in java.awt

      Methods in java.awt that return TrayIcon
      Modifier and Type 方法 描述
      TrayIcon[] SystemTray.getTrayIcons​()
      返回此应用程序添加到托盘中的所有图标的数组。
      Methods in java.awt with parameters of type TrayIcon
      Modifier and Type 方法 描述
      void SystemTray.add​(TrayIcon trayIcon)
      添加 TrayIcon到 SystemTray 。
      void SystemTray.remove​(TrayIcon trayIcon)
      删除指定 TrayIcon从 SystemTray 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.TrayIcon.MessageType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.TrayIcon.MessageType

  • Packages that use TrayIcon.MessageType
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of TrayIcon.MessageType in java.awt

      Methods in java.awt that return TrayIcon.MessageType
      Modifier and Type 方法 描述
      static TrayIcon.MessageType TrayIcon.MessageType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static TrayIcon.MessageType[] TrayIcon.MessageType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type TrayIcon.MessageType
      Modifier and Type 方法 描述
      void TrayIcon.displayMessage​(String caption, String text, TrayIcon.MessageType messageType)
      在托盘图标附近显示弹出消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Window (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Window

  • Packages that use Window
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of Window in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Window
      Modifier and Type 方法 描述
      static Window[] EventQueueMonitor.getTopLevelWindows​()
      返回在Java虚拟机中使用的顶级Windows的列表。
      static Window EventQueueMonitor.getTopLevelWindowWithFocus​()
      返回当前具有键盘焦点的顶级 Window 。
      Methods in com.sun.java.accessibility.util with parameters of type Window
      Modifier and Type 方法 描述
      void TopLevelWindowListener.topLevelWindowCreated​(Window w)
      当创建新的顶级窗口时调用。
      void TopLevelWindowListener.topLevelWindowDestroyed​(Window w)
      当顶级窗口被销毁时调用。

    • Uses of Window in java.awt

      Subclasses of Window in java.awt
      Modifier and Type Class 描述
      class  Dialog
      Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      class  Frame
      A Frame是一个标题和边框的顶级窗口。
      Methods in java.awt that return Window
      Modifier and Type 方法 描述
      Window KeyboardFocusManager.getActiveWindow​()
      如果活动窗口与调用线程处于相同的上下文中，则返回活动窗口。
      Window KeyboardFocusManager.getFocusedWindow​()
      如果集中的窗口与调用线程处于相同的上下文中，则返回关注的窗口。
      Window GraphicsDevice.getFullScreenWindow​()
      如果设备处于全屏模式，则返回表示全屏窗口的 Window对象。
      protected Window KeyboardFocusManager.getGlobalActiveWindow​()
      返回活动窗口，即使调用线程与活动窗口处于不同的上下文中。
      protected Window KeyboardFocusManager.getGlobalFocusedWindow​()
      返回聚焦窗口，即使调用线程与聚焦窗口处于不同的上下文中。
      Window[] Window.getOwnedWindows​()
      返回一个包含此窗口当前拥有的所有窗口的数组。
      Window Window.getOwner​()
      返回此窗口的所有者。
      static Window[] Window.getOwnerlessWindows​()
      返回由此应用程序创建的所有 Window的数组，该数组没有所有者。
      static Window[] Window.getWindows​()
      返回由此应用程序创建的所有拥有和无主的所有 Window的数组。
      Methods in java.awt with parameters of type Window
      Modifier and Type 方法 描述
      Component FocusTraversalPolicy.getInitialComponent​(Window window)
      返回当窗口第一次可见时应接收焦点的组件。
      void Taskbar.requestWindowUserAttention​(Window w)
      请求用户注意指定的窗口。
      void GraphicsDevice.setFullScreenWindow​(Window w)
      进入全屏模式，或返回窗口模式。
      protected void KeyboardFocusManager.setGlobalActiveWindow​(Window activeWindow)
      设置活动窗口。
      protected void KeyboardFocusManager.setGlobalFocusedWindow​(Window focusedWindow)
      设置聚焦窗口。
      void Taskbar.setWindowIconBadge​(Window w, Image badge)
      在指定窗口的任务区域中贴上小应用程序的图标。
      void Taskbar.setWindowProgressState​(Window w, Taskbar.State state)
      设置指定窗口的进度状态。
      void Taskbar.setWindowProgressValue​(Window w, int value)
      在指定窗口的任务区域中显示确定的进度条。
      Constructors in java.awt with parameters of type Window
      Constructor 描述
      Dialog​(Window owner)
      构造一个初始隐形的，无指定的 Dialog与指定的所有者 Window和一个空的标题。
      Dialog​(Window owner, Dialog.ModalityType modalityType)
      构造一个最初看不见的 Dialog与指定的所有者 Window和模态和一个空的标题。
      Dialog​(Window owner, String title)
      构造一个初始隐形的，无模式的 Dialog与指定的所有者 Window和标题。
      Dialog​(Window owner, String title, Dialog.ModalityType modalityType)
      构造一个最初看不见的 Dialog与指定的所有者 Window ，标题和模态。
      Dialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      构造一个最初看不见的 Dialog与指定的所有者 Window ，标题，模态和 GraphicsConfiguration 。
      Window​(Window owner)
      构造一个新的，最初不可见的窗口，其中所指定的 Window 。
      Window​(Window owner, GraphicsConfiguration gc)
      构造具有指定的所有者一个新的，最初不可见的窗口 Window和 GraphicsConfiguration屏幕设备的。

    • Uses of Window in java.awt.event

      Methods in java.awt.event that return Window
      Modifier and Type 方法 描述
      Window WindowEvent.getOppositeWindow​()
      返回此焦点或激活更改中涉及的其他窗口。
      Window WindowEvent.getWindow​()
      返回事件的发起者。
      Constructors in java.awt.event with parameters of type Window
      Constructor 描述
      WindowEvent​(Window source, int id)
      构造一个 WindowEvent对象。
      WindowEvent​(Window source, int id, int oldState, int newState)
      构造具有指定的上一个和新窗口状态的 WindowEvent对象。
      WindowEvent​(Window source, int id, Window opposite)
      构造一个 WindowEvent对象，其中指定的对端为 Window 。
      WindowEvent​(Window source, int id, Window opposite, int oldState, int newState)
      构造一个 WindowEvent对象。

    • Uses of Window in java.awt.im.spi

      Methods in java.awt.im.spi that return Window
      Modifier and Type 方法 描述
      Window InputMethodContext.createInputMethodWindow​(String title, boolean attachToInputContext)
      创建一个顶级窗口，供输入法使用。

    • Uses of Window in javax.swing

      Subclasses of Window in javax.swing
      Modifier and Type Class 描述
      class  JDialog
      创建对话窗口的主要类。
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      class  JWindow
      A JWindow是可以在用户桌面上的任意位置显示的容器。
      Methods in javax.swing that return Window
      Modifier and Type 方法 描述
      static Window SwingUtilities.getWindowAncestor​(Component c)
      返回第 Window祖先 c ，或 null如果 c未包含在里面 Window 。
      static Window SwingUtilities.windowForComponent​(Component c)
      返回第 Window祖先 c ，或 null如果 c不包含在一个 Window 。
      Methods in javax.swing with parameters of type Window
      Modifier and Type 方法 描述
      void RepaintManager.addDirtyRegion​(Window window, int x, int y, int w, int h)
      将 window添加到需要重新绘制的 Component s的列表中。
      Constructors in javax.swing with parameters of type Window
      Constructor 描述
      JDialog​(Window owner)
      使用指定的 Window作为其所有者创建无模式对话框，并创建一个空标题。
      JDialog​(Window owner, Dialog.ModalityType modalityType)
      创建一个具有空标题和指定模式的 Window ，其中所有者为 Window 。
      JDialog​(Window owner, String title)
      使用指定的标题和所有者创建无模式对话框 Window 。
      JDialog​(Window owner, String title, Dialog.ModalityType modalityType)
      创建一个具有指定标题的对话框，拥有者 Window和模态。
      JDialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      创建一个具有指定标题的对话框，所有者 Window ，模式和 GraphicsConfiguration 。
      JWindow​(Window owner)
      创建具有指定所有者窗口的窗口。
      JWindow​(Window owner, GraphicsConfiguration gc)
      创建具有指定所有者窗口的窗口和屏幕设备的 GraphicsConfiguration 。

    • Uses of Window in javax.swing.plaf.basic

      Subclasses of Window in javax.swing.plaf.basic
      Modifier and Type Class 描述
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Window.AccessibleAWTWindow (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Window.AccessibleAWTWindow

  • Packages that use Window.AccessibleAWTWindow
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Window.AccessibleAWTWindow in java.awt

      Subclasses of Window.AccessibleAWTWindow in java.awt
      Modifier and Type Class 描述
      protected class  Dialog.AccessibleAWTDialog
      这个类实现 Dialog类的可访问性支持。
      protected class  Frame.AccessibleAWTFrame
      这个类实现 Frame类的可访问性支持。

    • Uses of Window.AccessibleAWTWindow in javax.swing

      Subclasses of Window.AccessibleAWTWindow in javax.swing
      Modifier and Type Class 描述
      protected class  JDialog.AccessibleJDialog
      该类实现 JDialog类的可访问性支持。
      protected class  JFrame.AccessibleJFrame
      该类实现 JFrame类的可访问性支持。
      protected class  JWindow.AccessibleJWindow
      This class implements accessibility support for the JWindow class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.Window.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.Window.Type

  • Packages that use Window.Type
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Window.Type in java.awt

      Methods in java.awt that return Window.Type
      Modifier and Type 方法 描述
      Window.Type Window.getType​()
      返回窗口的类型。
      static Window.Type Window.Type.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Window.Type[] Window.Type.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt with parameters of type Window.Type
      Modifier and Type 方法 描述
      void Window.setType​(Window.Type type)
      设置窗口的类型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.ActiveEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.ActiveEvent

  • Packages that use ActiveEvent
    软件包 描述
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。

    • Uses of ActiveEvent in java.awt.event

      Classes in java.awt.event that implement ActiveEvent
      Modifier and Type Class 描述
      class  InvocationEvent
      在由AWT事件调度程序线程调度时，在 Runnable执行 run()方法的事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.Adjustable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.Adjustable

  • Packages that use Adjustable
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Adjustable in java.awt

      Classes in java.awt that implement Adjustable
      Modifier and Type Class 描述
      class  Scrollbar
      Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。
      class  ScrollPaneAdjustable
      该类表示 ScrollPane的水平或垂直滚动条的 ScrollPane 。
      Methods in java.awt that return Adjustable
      Modifier and Type 方法 描述
      Adjustable ScrollPane.getHAdjustable​()
      返回表示水平滚动条状态的 ScrollPaneAdjustable对象。
      Adjustable ScrollPane.getVAdjustable​()
      返回表示垂直滚动条状态的 ScrollPaneAdjustable对象。

    • Uses of Adjustable in java.awt.event

      Methods in java.awt.event that return Adjustable
      Modifier and Type 方法 描述
      Adjustable AdjustmentEvent.getAdjustable​()
      返回发生此事件的 Adjustable对象。
      Constructors in java.awt.event with parameters of type Adjustable
      Constructor 描述
      AdjustmentEvent​(Adjustable source, int id, int type, int value)
      构造一个 AdjustmentEvent与指定对象 Adjustable源，事件类型，调整类型和值。
      AdjustmentEvent​(Adjustable source, int id, int type, int value, boolean isAdjusting)
      构造具有指定的可调源，事件类型，调整类型和值的 AdjustmentEvent对象。

    • Uses of Adjustable in javax.swing

      Classes in javax.swing that implement Adjustable
      Modifier and Type Class 描述
      class  JScrollBar
      一个滚动条的实现。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.Composite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.Composite

  • Packages that use Composite
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Composite in java.awt

      Classes in java.awt that implement Composite
      Modifier and Type Class 描述
      class  AlphaComposite
      AlphaComposite类实现了基本的alpha合成规则，用于组合源和目标颜色，以实现图形和图像的混合和透明效果。
      Methods in java.awt that return Composite
      Modifier and Type 方法 描述
      abstract Composite Graphics2D.getComposite​()
      返回当前 Composite在 Graphics2D环境。
      Methods in java.awt with parameters of type Composite
      Modifier and Type 方法 描述
      abstract void Graphics2D.setComposite​(Composite comp)
      设置 Composite为 Graphics2D的上下文。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.CompositeContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.CompositeContext

  • Packages that use CompositeContext
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of CompositeContext in java.awt

      Methods in java.awt that return CompositeContext
      Modifier and Type 方法 描述
      CompositeContext AlphaComposite.createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建合成操作的上下文。
      CompositeContext Composite.createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建用于执行合成操作的上下文包含状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.ItemSelectable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.ItemSelectable

  • Packages that use ItemSelectable
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。

    • Uses of ItemSelectable in java.awt

      Classes in java.awt that implement ItemSelectable
      Modifier and Type Class 描述
      class  Checkbox
      复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
      class  CheckboxMenuItem
      此类表示可以包含在菜单中的复选框。
      class  Choice
      Choice课程提供了弹出菜单的选择。
      class  List
      List组件向用户显示文本项的滚动列表。

    • Uses of ItemSelectable in java.awt.event

      Methods in java.awt.event that return ItemSelectable
      Modifier and Type 方法 描述
      ItemSelectable ItemEvent.getItemSelectable​()
      返回事件的发起者。
      Constructors in java.awt.event with parameters of type ItemSelectable
      Constructor 描述
      ItemEvent​(ItemSelectable source, int id, Object item, int stateChange)
      构造一个 ItemEvent对象。

    • Uses of ItemSelectable in javax.swing

      Subinterfaces of ItemSelectable in javax.swing
      Modifier and Type 接口 描述
      interface  ButtonModel
      按钮的状态模型。
      Classes in javax.swing that implement ItemSelectable
      Modifier and Type Class 描述
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      class  DefaultButtonModel
      默认实现的一个 Button组件的数据模型。
      class  JButton
      实现“推”按钮。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户选择 JMenuBar上的项目时 JMenuBar 。
      class  JMenuItem
      菜单中项目的实现。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      class  JToggleButton
      一个两状态按钮的实现。
      static class  JToggleButton.ToggleButtonModel
      ToggleButton模型

    • Uses of ItemSelectable in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ItemSelectable
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。

    • Uses of ItemSelectable in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ItemSelectable
      Modifier and Type Class 描述
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.KeyEventDispatcher (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.KeyEventDispatcher

  • Packages that use KeyEventDispatcher
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of KeyEventDispatcher in java.awt

      Classes in java.awt that implement KeyEventDispatcher
      Modifier and Type Class 描述
      class  DefaultKeyboardFocusManager
      用于AWT应用程序的默认KeyboardFocusManager。
      class  KeyboardFocusManager
      KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。
      Methods in java.awt that return types with arguments of type KeyEventDispatcher
      Modifier and Type 方法 描述
      protected List<KeyEventDispatcher> KeyboardFocusManager.getKeyEventDispatchers​()
      将此KeyboardFocusManager的KeyEventDispatcher链作为列表返回。
      Methods in java.awt with parameters of type KeyEventDispatcher
      Modifier and Type 方法 描述
      void KeyboardFocusManager.addKeyEventDispatcher​(KeyEventDispatcher dispatcher)
      将KeyEventDispatcher添加到此KeyboardFocusManager的调度程序链中。
      void KeyboardFocusManager.removeKeyEventDispatcher​(KeyEventDispatcher dispatcher)
      删除之前添加到此KeyboardFocusManager调度程序链的KeyEventDispatcher。

    • Uses of KeyEventDispatcher in javax.swing

      Classes in javax.swing that implement KeyEventDispatcher
      Modifier and Type Class 描述
      class  DefaultFocusManager
      这个类已被1.4焦点API过时了。
      class  FocusManager
      这个类已被1.4焦点API过时了。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.KeyEventPostProcessor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.KeyEventPostProcessor

  • Packages that use KeyEventPostProcessor
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of KeyEventPostProcessor in java.awt

      Classes in java.awt that implement KeyEventPostProcessor
      Modifier and Type Class 描述
      class  DefaultKeyboardFocusManager
      用于AWT应用程序的默认KeyboardFocusManager。
      class  KeyboardFocusManager
      KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。
      Methods in java.awt that return types with arguments of type KeyEventPostProcessor
      Modifier and Type 方法 描述
      protected List<KeyEventPostProcessor> KeyboardFocusManager.getKeyEventPostProcessors​()
      将此KeyboardFocusManager的KeyEventPostProcessor链返回为列表。
      Methods in java.awt with parameters of type KeyEventPostProcessor
      Modifier and Type 方法 描述
      void KeyboardFocusManager.addKeyEventPostProcessor​(KeyEventPostProcessor processor)
      将KeyEventPostProcessor添加到此KeyboardFocusManager的后处理器链。
      void KeyboardFocusManager.removeKeyEventPostProcessor​(KeyEventPostProcessor processor)
      从此KeyboardFocusManager的后处理器链中删除以前添加的KeyEventPostProcessor。

    • Uses of KeyEventPostProcessor in javax.swing

      Classes in javax.swing that implement KeyEventPostProcessor
      Modifier and Type Class 描述
      class  DefaultFocusManager
      这个类已被1.4焦点API过时了。
      class  FocusManager
      这个类已被1.4焦点API过时了。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.LayoutManager2 (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.LayoutManager2

  • Packages that use LayoutManager2
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of LayoutManager2 in java.awt

      Classes in java.awt that implement LayoutManager2
      Modifier and Type Class 描述
      class  BorderLayout
      边界布局设置了一个容器，安排和调整其组件，以适应五个区域：北，南，东，西和中心。
      class  CardLayout
      一个 CardLayout对象是一个容器的布局管理器。
      class  GridBagLayout
      GridBagLayout类是一种灵活的布局管理器，可以垂直，水平或沿其基准对齐组件，而不需要组件的大小相同。

    • Uses of LayoutManager2 in javax.swing

      Classes in javax.swing that implement LayoutManager2
      Modifier and Type Class 描述
      class  BoxLayout
      一个布局管理器，可以将多个组件垂直或水平放置。
      class  GroupLayout
      GroupLayout是一个 LayoutManager ，它分层组合组件，以便将它们定位在一个 Container 。
      protected class  JRootPane.RootLayout
      一个自定义布局管理器，负责分层面，玻璃面和菜单栏的布局。
      class  OverlayLayout
      布局管理器将组件排列在彼此的顶部。
      class  SpringLayout
      A SpringLayout根据一组约束规定了其关联容器的子项。

    • Uses of LayoutManager2 in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement LayoutManager2
      Modifier and Type Class 描述
      class  BasicSplitPaneUI.BasicHorizontalLayoutManager
      具有方向为HORIZONTAL_SPLIT的JSplitPanes的LayoutManager。
      class  BasicSplitPaneUI.BasicVerticalLayoutManager
      LayoutManager用于JSplitPanes，方向为VERTICAL_SPLIT。
      class  DefaultMenuLayout
      弹出菜单和菜单栏的默认布局管理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.LayoutManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.LayoutManager

  • Packages that use LayoutManager
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。

    • Uses of LayoutManager in java.awt

      Subinterfaces of LayoutManager in java.awt
      Modifier and Type 接口 描述
      interface  LayoutManager2
      为知道如何根据布局约束对象布局容器的类定义接口。
      Classes in java.awt that implement LayoutManager
      Modifier and Type Class 描述
      class  BorderLayout
      边界布局设置了一个容器，安排和调整其组件，以适应五个区域：北，南，东，西和中心。
      class  CardLayout
      一个 CardLayout对象是一个容器的布局管理器。
      class  FlowLayout
      流程布局将组件布置在定向流中，与段落中的文本行类似。
      class  GridBagLayout
      GridBagLayout类是一种灵活的布局管理器，可以垂直，水平或沿其基准对齐组件，而不需要组件的大小相同。
      class  GridLayout
      GridLayout类是一个布局管理器，它将一个容器的组件放置在矩形网格中。
      Methods in java.awt that return LayoutManager
      Modifier and Type 方法 描述
      LayoutManager Container.getLayout​()
      获取此容器的布局管理器。
      Methods in java.awt with parameters of type LayoutManager
      Modifier and Type 方法 描述
      void Container.setLayout​(LayoutManager mgr)
      设置此容器的布局管理器。
      void ScrollPane.setLayout​(LayoutManager mgr)
      设置此容器的布局管理器。
      Constructors in java.awt with parameters of type LayoutManager
      Constructor 描述
      Panel​(LayoutManager layout)
      使用指定的布局管理器创建一个新面板。

    • Uses of LayoutManager in javax.swing

      Classes in javax.swing that implement LayoutManager
      Modifier and Type Class 描述
      class  BoxLayout
      一个布局管理器，可以将多个组件垂直或水平放置。
      class  GroupLayout
      GroupLayout是一个 LayoutManager ，它以分层方式对组件进行分组，以便将它们放置在一个 Container 。
      protected class  JRootPane.RootLayout
      一个自定义布局管理器，负责分层面，玻璃面和菜单栏的布局。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      更专业的编辑器的简单基础类，可以使用 JFormattedTextField显示模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      class  OverlayLayout
      布局管理器将组件排列在彼此的顶部。
      class  ScrollPaneLayout
      由 JScrollPane使用的布局管理器。
      static class  ScrollPaneLayout.UIResource
      UI资源版本为 ScrollPaneLayout 。
      class  SpringLayout
      A SpringLayout根据一组约束来 SpringLayout其关联容器的子项。
      class  ViewportLayout
      默认布局管理器为 JViewport 。
      Methods in javax.swing that return LayoutManager
      Modifier and Type 方法 描述
      protected LayoutManager JViewport.createLayoutManager​()
      子类可以覆盖此，以在构造函数中安装不同的布局管理器（或 null ）。
      protected LayoutManager JRootPane.createRootLayout​()
      由构造函数调用方法创建默认 layoutManager 。
      Methods in javax.swing with parameters of type LayoutManager
      Modifier and Type | 方法 | 描述
      void AbstractButton.setLayout​(LayoutManager mgr)
      设置此容器的布局管理器，有关此方法的完整说明，请参阅 Container.setLayout(LayoutManager) 。
      void Box.setLayout​(LayoutManager l)
      抛出AWTError，因为Box只能使用BoxLayout。
      void JApplet.setLayout​(LayoutManager manager)
      已过时。
      设置 LayoutManager 。
      void JDialog.setLayout​(LayoutManager manager)
      设置 LayoutManager 。
      void JFrame.setLayout​(LayoutManager manager)
      设置 LayoutManager 。
      void JInternalFrame.setLayout​(LayoutManager manager)
      确保默认情况下，无法设置此组件的布局。
      void JLayer.setLayout​(LayoutManager mgr)
      设置此容器的布局管理器。
      void JScrollPane.setLayout​(LayoutManager layout)
      设置这个 JScrollPane的布局管理器。
      void | JToolBar.setLayout​(LayoutManager mgr)
      void JWindow.setLayout​(LayoutManager manager)
      设置 LayoutManager 。
      Constructors in javax.swing with parameters of type LayoutManager
      Constructor 描述
      JPanel​(LayoutManager layout)
      使用指定的布局管理器创建一个新的缓冲JPanel
      JPanel​(LayoutManager layout, boolean isDoubleBuffered)
      使用指定的布局管理器和缓冲策略创建一个新的JPanel。

    • Uses of LayoutManager in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement LayoutManager
      Modifier and Type Class 描述
      class  BasicComboBoxUI.ComboBoxLayoutManager
      该布局管理器处理组合框的“标准”布局。
      class  BasicInternalFrameTitlePane.TitlePaneLayout
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameUI.InternalFrameLayout
      内部框架布局。
      static class  BasicOptionPaneUI.ButtonAreaLayout
      ButtonAreaLayout行为类似于 FlowLayout 。
      class  BasicScrollBarUI
      实现ScrollBarUI的基本外观和感觉
      protected class  BasicSplitPaneDivider.DividerLayout
      用于布局 BasicSplitPaneDivider 。
      class  BasicSplitPaneUI.BasicHorizontalLayoutManager
      具有方向为HORIZONTAL_SPLIT的JSplitPanes的LayoutManager。
      class  BasicSplitPaneUI.BasicVerticalLayoutManager
      LayoutManager用于JSplitPanes，方向为VERTICAL_SPLIT。
      class  BasicTabbedPaneUI.TabbedPaneLayout
      这个类应该被视为一个“受保护”的内部类。
      class  DefaultMenuLayout
      弹出菜单和菜单栏的默认布局管理器。
      Fields in javax.swing.plaf.basic declared as LayoutManager
      Modifier and Type Field 描述
      protected LayoutManager BasicInternalFrameUI.internalFrameLayout
      内部框架布局
      Methods in javax.swing.plaf.basic that return LayoutManager
      Modifier and Type 方法 描述
      protected LayoutManager BasicInternalFrameTitlePane.createLayout​()
      返回布局管理器。
      protected LayoutManager BasicSpinnerUI.createLayout​()
      创建一个 LayoutManager管理的 editor ， nextButton ，并 previousButton的JSpinner的儿童。
      protected LayoutManager BasicComboBoxUI.createLayoutManager​()
      创建一个布局管理器来管理构成组合框的组件。
      protected LayoutManager BasicInternalFrameUI.createLayoutManager​()
      创建布局管理器。
      protected LayoutManager BasicOptionPaneUI.createLayoutManager​()
      返回布局管理器。
      protected LayoutManager BasicTabbedPaneUI.createLayoutManager​()
      调用 installUI创建一个布局管理器对象来管理 JTabbedPane 。

    • Uses of LayoutManager in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement LayoutManager
      Modifier and Type Class 描述
      class  MetalComboBoxUI.MetalComboBoxLayoutManager
      这个类应该被视为一个“受保护”的内部类。
      class  MetalScrollBarUI
      实现ScrollBarUI的金属外观和感觉
      class  MetalTabbedPaneUI.TabbedPaneLayout
      这个类应该被视为一个“受保护”的内部类。
      Methods in javax.swing.plaf.metal that return LayoutManager
      Modifier and Type | 方法 | 描述
      protected LayoutManager | MetalInternalFrameTitlePane.createLayout​()
      protected LayoutManager | MetalComboBoxUI.createLayoutManager​()
      protected LayoutManager | MetalTabbedPaneUI.createLayoutManager​()

    • Uses of LayoutManager in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement LayoutManager
      Modifier and Type Class 描述
      class  SynthScrollBarUI
      为JScrollBar提供Synth L＆F UI代表。
      Methods in javax.swing.plaf.synth that return LayoutManager
      Modifier and Type 方法 描述
      protected LayoutManager SynthSpinnerUI.createLayout​()
      创建一个 LayoutManager管理的 editor ， nextButton ，并 previousButton的JSpinner的儿童。
      protected LayoutManager SynthToolBarUI.createLayout​()
      创建一个 LayoutManager与工具栏一起使用。
      protected LayoutManager SynthTabbedPaneUI.createLayoutManager​()
      调用 installUI创建一个布局管理器对象来管理 JTabbedPane 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.MenuContainer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.MenuContainer

  • Packages that use MenuContainer
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of MenuContainer in java.applet

      Classes in java.applet that implement MenuContainer
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of MenuContainer in java.awt

      Classes in java.awt that implement MenuContainer
      Modifier and Type Class 描述
      class  Button
      这个类创建一个标记的按钮。
      class  Canvas
      A Canvas组件表示应用程序可以绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。
      class  Checkbox
      复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
      class  Choice
      Choice课程提供了弹出菜单的选择。
      class  Component
      组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
      class  Container
      通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
      class  Dialog
      Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      class  Frame
      A Frame是具有标题和边框的顶级窗口。
      class  Label
      Label对象是用于将文本放置在容器中的组件。
      class  List
      List组件向用户显示文本项的滚动列表。
      class  Menu
      Menu对象是从菜单栏部署的下拉菜单组件。
      class  MenuBar
      MenuBar类封装了平台与框架绑定的菜单栏的概念。
      class  Panel
      Panel是最简单的容器类。
      class  PopupMenu
      一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
      class  Scrollbar
      Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。
      class  ScrollPane
      一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。
      class  TextArea
      TextArea对象是显示文本的多行区域。
      class  TextComponent
      TextComponent类是允许编辑某些文本的任何组件的超类。
      class  TextField
      TextField对象是允许编辑单行文本的文本组件。
      class  Window
      一个 Window对象是没有边框的顶级窗口，没有菜单。
      Methods in java.awt that return MenuContainer
      Modifier and Type 方法 描述
      MenuContainer MenuComponent.getParent​()
      返回此菜单组件的父容器。
      MenuContainer PopupMenu.getParent​()
      返回此菜单组件的父容器。

    • Uses of MenuContainer in javafx.embed.swing

      Classes in javafx.embed.swing that implement MenuContainer
      Modifier and Type Class 描述
      class  JFXPanel
      JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。

    • Uses of MenuContainer in javax.swing

      Classes in javax.swing that implement MenuContainer
      Modifier and Type Class 描述
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      static class  Box.Filler
      参与布局但没有视图的轻量级组件的实现。
      class  CellRendererPane
      此类插入到单元格渲染器和使用它们的组件之间。
      class  DefaultListCellRenderer
      渲染列表中的项目。
      static class  DefaultListCellRenderer.UIResource
      实现UIResource的DefaultListCellRenderer的子类。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      class  JButton
      实现“推”按钮。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      class  JColorChooser
      JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      class  JComponent
      除顶级容器之外的所有Swing组件的基类。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      class  JDialog
      创建对话窗口的主要类。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      class  JFileChooser
      JFileChooser为用户提供了一种选择文件的简单机制。
      class  JFormattedTextField
      JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑文本，就检索特定的对象。
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      static class  JInternalFrame.JDesktopIcon
      该组件代表 JInternalFrame的图标化版本。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并接收其边框内生成的所有 AWTEvent的通知。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。
      class  JMenuBar
      一个菜单栏的实现。
      class  JMenuItem
      菜单中项目的实现。
      class  JOptionPane
      JOptionPane可以方便地弹出一个标准对话框，提示用户输入一个值或通知他们某些东西。
      class  JPanel
      JPanel是一个通用的轻型容器。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示已打字，但不显示原始字符。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      static class  JPopupMenu.Separator
      弹出菜单特定的分隔符。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      class  JRootPane
      通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
      class  JScrollBar
      一个滚动条的实现。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
      class  JSeparator
      JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      一个更专业的编辑器的简单基类，通过一个 JFormattedTextField显示模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      class  JSplitPane
      JSplitPane用于分割两个（也只有两个） Component s。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      class  JTextArea
      A JTextArea是显示纯文本的多行区域。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      static class  JToolBar.Separator
      工具栏特定的分隔符。
      class  JToolTip
      用于显示组件的“提示”。
      class  JTree
      将一组分层数据显示为大纲的控件。
      class  JViewport
      您可以通过它查看基础信息的“视口”或“舷窗”。
      class  JWindow
      A JWindow是可以在用户桌面上的任意位置显示的容器。

    • Uses of MenuContainer in javax.swing.colorchooser

      Classes in javax.swing.colorchooser that implement MenuContainer
      Modifier and Type Class 描述
      class  AbstractColorChooserPanel
      这是颜色选择器的抽象超类。

    • Uses of MenuContainer in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement MenuContainer
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
      class  BasicComboBoxRenderer
      ComboBox渲染器
      static class  BasicComboBoxRenderer.UIResource
      BasicComboBoxRenderer的子类实现UIResource。
      class  BasicComboPopup
      这是 ComboPopup接口的基本实现。
      class  BasicInternalFrameTitlePane
      管理基本标题栏的类
      class  BasicInternalFrameTitlePane.SystemMenuBar
      这个类应该被视为一个“受保护”的内部类。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。

    • Uses of MenuContainer in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement MenuContainer
      Modifier and Type Class 描述
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalComboBoxUI.MetalComboPopup
      已过时。
      从Java 2平台v1.4开始。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      class  MetalFileChooserUI.FilterComboBoxRenderer
      渲染不同类型的尺寸和样式。
      class  MetalInternalFrameTitlePane
      管理JLF标题栏的类
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。

    • Uses of MenuContainer in javax.swing.table

      Classes in javax.swing.table that implement MenuContainer
      Modifier and Type Class 描述
      class  DefaultTableCellRenderer
      在 JTable渲染（显示）单个单元格的标准类。
      static class  DefaultTableCellRenderer.UIResource
      DefaultTableCellRenderer的子类实现 UIResource 。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。

    • Uses of MenuContainer in javax.swing.text

      Classes in javax.swing.text that implement MenuContainer
      Modifier and Type Class 描述
      class  JTextComponent
      JTextComponent是摆动文本组件的基类。

    • Uses of MenuContainer in javax.swing.tree

      Classes in javax.swing.tree that implement MenuContainer
      Modifier and Type Class 描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField未提供编辑器时使用。
      class  DefaultTreeCellEditor.EditorContainer
      集装箱负责放置 editingComponent 。
      class  DefaultTreeCellRenderer
      Displays an entry in a tree.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.Paint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.Paint

  • Packages that use Paint
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。

    • Uses of Paint in java.awt

      Classes in java.awt that implement Paint
      Modifier and Type Class 描述
      class  Color
      Color类用于将默认的sRGB颜色空间或由ColorSpace标识的任意颜色空间中的颜色进行封装 。
      class  GradientPaint
      GradientPaint课程提供了一种使用线性颜色渐变模式填充Shape的方法。
      class  LinearGradientPaint
      LinearGradientPaint课程提供了一种填充Shape线性颜色渐变模式的方式。
      class  MultipleGradientPaint
      这是Paints的超类，它使用多色渐变填充其栅格。
      class  RadialGradientPaint
      RadialGradientPaint类提供了一种填充圆形径向颜色渐变图案的形状的方法。
      class  SystemColor
      封装代表系统上本地GUI对象颜色的符号颜色的类。
      class  TexturePaint
      TexturePaint课程提供了一种填充Shape的方式 ，其纹理被指定为BufferedImage 。
      Methods in java.awt that return Paint
      Modifier and Type 方法 描述
      abstract Paint Graphics2D.getPaint​()
      返回当前 Paint的的 Graphics2D环境。
      Methods in java.awt with parameters of type Paint
      Modifier and Type 方法 描述
      abstract void Graphics2D.setPaint​(Paint paint)
      为 Graphics2D上下文设置 Paint属性。

    • Uses of Paint in javax.swing

      Methods in javax.swing with parameters of type Paint
      Modifier and Type 方法 描述
      static Border BorderFactory.createDashedBorder​(Paint paint)
      创建指定的 paint的虚线边框。
      static Border BorderFactory.createDashedBorder​(Paint paint, float length, float spacing)
      创建指定的 paint ，相对 length和相对 spacing的虚线边框。
      static Border BorderFactory.createDashedBorder​(Paint paint, float thickness, float length, float spacing, boolean rounded)
      创建指定的 paint ， thickness ，相对 length和相对 spacing的虚线边框。
      static Border BorderFactory.createStrokeBorder​(BasicStroke stroke, Paint paint)
      创建指定的边框 stroke和 paint 。

    • Uses of Paint in javax.swing.border

      Methods in javax.swing.border that return Paint
      Modifier and Type 方法 描述
      Paint StrokeBorder.getPaint​()
      返回在边框渲染期间用于生成颜色的Paint对象。
      Constructors in javax.swing.border with parameters of type Paint
      Constructor 描述
      StrokeBorder​(BasicStroke stroke, Paint paint)
      创建指定的边框 stroke和 paint 。

    • Uses of Paint in javax.swing.plaf

      Classes in javax.swing.plaf that implement Paint
      Modifier and Type Class 描述
      class  ColorUIResource
      实现UIResource的Color子类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.PaintContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.PaintContext

  • Packages that use PaintContext
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PaintContext in java.awt

      Methods in java.awt that return PaintContext
      Modifier and Type 方法 描述
      PaintContext Color.createContext​(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成纯色字段模式的PaintContext 。
      PaintContext GradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext LinearGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext Paint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成颜色模式的PaintContext 。
      PaintContext RadialGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个PaintContext，用于生成圆形径向颜色渐变图案。
      PaintContext TexturePaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      Creates and returns a PaintContext used to generate a tiled image pattern.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.PrintGraphics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.PrintGraphics

No usage of java.awt.PrintGraphics
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.SecondaryLoop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.SecondaryLoop

  • Packages that use SecondaryLoop
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of SecondaryLoop in java.awt

      Methods in java.awt that return SecondaryLoop
      Modifier and Type 方法 描述
      SecondaryLoop EventQueue.createSecondaryLoop​()
      创建与此事件队列关联的新的 secondary loop 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.Shape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.Shape

  • Packages that use Shape
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供 HTMLEditorKit类和支持类来创建HTML文本编辑器。

    • Uses of Shape in java.awt

      Classes in java.awt that implement Shape
      Modifier and Type Class 描述
      class  Polygon
      Polygon类封装了坐标空间内封闭的二维区域的描述。
      class  Rectangle
      A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的一个区域，其宽度及其高度。
      Methods in java.awt that return Shape
      Modifier and Type 方法 描述
      Shape BasicStroke.createStrokedShape​(Shape s)
      返回一个 Shape其内部定义了指定的 Shape轮廓。
      Shape Stroke.createStrokedShape​(Shape p)
      返回一个轮廓 Shape ，其中包含根据由实现 Stroke接口的对象定义的规则来绘制 Shape时应绘制的区域。
      abstract Shape Graphics.getClip​()
      获取当前的裁剪区域。
      Shape Window.getShape​()
      返回窗口的形状。
      Methods in java.awt with parameters of type Shape
      Modifier and Type 方法 描述
      abstract void Graphics2D.clip​(Shape s)
      将当前的 Clip与指定的 Shape的内部相交，并将 Shape设置为 Clip的交点。
      Shape BasicStroke.createStrokedShape​(Shape s)
      返回一个 Shape其内部定义了指定的 Shape轮廓。
      Shape Stroke.createStrokedShape​(Shape p)
      返回一个轮廓 Shape ，其中包含根据由实现 Stroke接口的对象定义的规则来描绘 Shape时应绘制的区域。
      abstract void Graphics2D.draw​(Shape s)
      使用当前的 Graphics2D上下文的设置来 Shape的轮廓。
      abstract void Graphics2D.fill​(Shape s)
      使用 Graphics2D上下文的设置填充 Shape的内部。
      abstract boolean Graphics2D.hit​(Rectangle rect, Shape s, boolean onStroke)
      检查指定的Shape是否与设备空间中指定的Shape相交。
      abstract void Graphics.setClip​(Shape clip)
      将当前剪辑区域设置为任意剪辑形状。
      void Component.setMixingCutoutShape​(Shape shape)
      为此轻型组件设置“混合切割”形状。
      void Dialog.setShape​(Shape shape)
      设置窗口的形状。
      void Frame.setShape​(Shape shape)
      设置窗口的形状。
      void Window.setShape​(Shape shape)
      设置窗口的形状。

    • Uses of Shape in java.awt.font

      Methods in java.awt.font that return Shape
      Modifier and Type 方法 描述
      Shape TextLayout.getBlackBoxBounds​(int firstEndpoint, int secondEndpoint)
      返回指定范围内的字符的黑框边界。
      Shape TextLayout.getCaretShape​(TextHitInfo hit)
      返回一个 Shape代表这个 TextLayout的自然界限内的指定点的插入符号。
      Shape TextLayout.getCaretShape​(TextHitInfo hit, Rectangle2D bounds)
      返回一个Shape，表示指定边界内指定点的插入符号。
      Shape[] TextLayout.getCaretShapes​(int offset)
      返回对应于强和弱插入符号的两个路径。
      Shape[] TextLayout.getCaretShapes​(int offset, Rectangle2D bounds)
      返回对应于强和弱插入符号的两个路径。
      Shape[] TextLayout.getCaretShapes​(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy)
      返回对应于强和弱插入符号的两个路径。
      abstract Shape GlyphVector.getGlyphLogicalBounds​(int glyphIndex)
      返回此 GlyphVector指定字形的逻辑边界。
      abstract Shape GlyphVector.getGlyphOutline​(int glyphIndex)
      返回一个 Shape其内部对应于此 GlyphVector指定字形的视觉表示。
      Shape GlyphVector.getGlyphOutline​(int glyphIndex, float x, float y)
      返回一个 Shape其内部对应于此 GlyphVector内的指定字形的视觉表示，偏移到x，y。
      abstract Shape GlyphVector.getGlyphVisualBounds​(int glyphIndex)
      返回 GlyphVector指定字形的视觉边界。
      Shape TextLayout.getLogicalHighlightShape​(int firstEndpoint, int secondEndpoint)
      返回一个 Shape将逻辑选择包含在指定的范围内，扩展到这个 TextLayout 。
      Shape TextLayout.getLogicalHighlightShape​(int firstEndpoint, int secondEndpoint, Rectangle2D bounds)
      返回一个包含在指定范围内的逻辑选择的 Shape ，扩展到指定的 bounds 。
      abstract Shape GlyphVector.getOutline​()
      返回一个 Shape其内部对应于该 GlyphVector的视觉表示。
      abstract Shape GlyphVector.getOutline​(float x, float y)
      返回一个 Shape其内部对应于这个 GlyphVector在x，y渲染时的视觉表示。
      Shape GraphicAttribute.getOutline​(AffineTransform tx)
      返回一个Shape ，表示GraphicAttribute呈现的区域。
      Shape ShapeGraphicAttribute.getOutline​(AffineTransform tx)
      返回一个Shape ，表示ShapeGraphicAttribute呈现的区域。
      Shape TextLayout.getOutline​(AffineTransform tx)
      返回 Shape表示此轮廓 TextLayout 。
      Shape TextLayout.getVisualHighlightShape​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint)
      返回一个 Shape将视觉选择包含在指定的范围内，扩展到边界。
      Shape TextLayout.getVisualHighlightShape​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds)
      返回包含指定范围内的视觉选择的路径，扩展为 bounds 。
      Constructors in java.awt.font with parameters of type Shape
      Constructor 描述
      ShapeGraphicAttribute​(Shape shape, int alignment, boolean stroke)
      构造一个ShapeGraphicAttribute为指定Shape 。

    • Uses of Shape in java.awt.geom

      Classes in java.awt.geom that implement Shape
      Modifier and Type Class 描述
      class  Arc2D
      Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或 PIE ）。
      static class  Arc2D.Double
      此类定义了 double精度中指定的弧。
      static class  Arc2D.Float
      此类定义了精度为 float指定的弧。
      class  Area
      一个 Area对象存储和操纵二维空间的封闭区域的分辨率独立描述。
      class  CubicCurve2D
      CubicCurve2D类定义了 (x,y)坐标空间中的三次参数曲线段。
      static class  CubicCurve2D.Double
      用 double坐标指定的三次参数曲线段。
      static class  CubicCurve2D.Float
      用 float协调指定的三次参数曲线段。
      class  Ellipse2D
      Ellipse2D类描述了由框架矩形定义的椭圆。
      static class  Ellipse2D.Double
      Double类定义了一个 double精度中指定的椭圆。
      static class  Ellipse2D.Float
      Float类定义了一个 float精度中指定的椭圆。
      class  GeneralPath
      GeneralPath类代表由直线构造的几何路径，以及二次和立方（Bézier）曲线。
      class  Line2D
      此 Line2D表示 (x,y)坐标空间中的线段。
      static class  Line2D.Double
      用双坐标指定的线段。
      static class  Line2D.Float
      用浮点坐标指定的线段。
      class  Path2D
      Path2D类提供了一个简单而又灵活的形状，表示任意的几何路径。
      static class  Path2D.Double
      Double类定义了一个几何路径，坐标存储在双精度浮点中。
      static class  Path2D.Float
      Float类定义了具有存储在单精度浮点中的坐标的几何路径。
      class  QuadCurve2D
      QuadCurve2D类定义了 (x,y)坐标空间中的二次参数曲线段。
      static class  QuadCurve2D.Double
      用 double坐标指定的二次参数曲线段。
      static class  QuadCurve2D.Float
      用 float坐标指定的二次参数曲线段。
      class  Rectangle2D
      Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
      static class  Rectangle2D.Double
      Double类定义了一个以双坐标指定的矩形。
      static class  Rectangle2D.Float
      Float类定义了一个以浮点坐标指定的矩形。
      class  RectangularShape
      RectangularShape是几何由矩形框架定义的Shape对象的基类。
      class  RoundRectangle2D
      RoundRectangle2D类定义了一个矩形，其圆角由位置 (x,y)定义，尺寸为 (w x h) ，以及 (w x h)的宽度和高度。
      static class  RoundRectangle2D.Double
      Double类定义了一个带有圆角的矩形，全部在 double指定。
      static class  RoundRectangle2D.Float
      Float类定义了一个带有圆角的矩形，全部在 float坐标中指定。
      Methods in java.awt.geom that return Shape
      Modifier and Type 方法 描述
      Shape AffineTransform.createTransformedShape​(Shape pSrc)
      返回一个新Shape由指定的几何定义的对象Shape已通过此变换之后。
      Shape Path2D.createTransformedShape​(AffineTransform at)
      返回一个新的 Shape代表这个 Path2D的转换版本。
      Methods in java.awt.geom with parameters of type Shape
      Modifier and Type 方法 描述
      void Path2D.append​(Shape s, boolean connect)
      将指定的 Shape对象的几何对象附加到路径，可能将新几何体连接到具有线段的现有路径段。
      Shape AffineTransform.createTransformedShape​(Shape pSrc)
      返回一个新Shape由指定的几何定义的对象Shape已通过此变换之后。
      Constructors in java.awt.geom with parameters of type Shape
      Constructor 描述
      Area​(Shape s)
      Area类从指定的Shape对象创建区域几何。
      Double​(Shape s)
      构造一个新的双精度Path2D从任意对象Shape对象。
      Double​(Shape s, AffineTransform at)
      构造一个新的单精度Path2D从任意物体Shape对象，由一个转化AffineTransform对象。
      Float​(Shape s)
      构造一个新的单精度Path2D从任意对象Shape对象。
      Float​(Shape s, AffineTransform at)
      构造一个新的单精度Path2D从任意物体Shape对象，由一个转化AffineTransform对象。
      GeneralPath​(Shape s)
      构造一个新GeneralPath从任意对象Shape对象。

    • Uses of Shape in java.awt.image.renderable

      Methods in java.awt.image.renderable that return Shape
      Modifier and Type 方法 描述
      Shape RenderContext.getAreaOfInterest​()
      获取当前包含在RenderContext中的兴趣。
      Methods in java.awt.image.renderable with parameters of type Shape
      Modifier and Type 方法 描述
      void RenderContext.setAreaOfInterest​(Shape newAoi)
      设置当前感兴趣的区域。
      Constructors in java.awt.image.renderable with parameters of type Shape
      Constructor 描述
      RenderContext​(AffineTransform usr2dev, Shape aoi)
      构造一个具有给定变换和感兴趣区域的RenderContext。
      RenderContext​(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
      构造具有给定变换的RenderContext。

    • Uses of Shape in javax.swing

      Methods in javax.swing that return Shape
      Modifier and Type 方法 描述
      Shape DebugGraphics.getClip​()
      覆盖 Graphics.getClip 。
      Methods in javax.swing with parameters of type Shape
      Modifier and Type 方法 描述
      void DebugGraphics.setClip​(Shape clip)
      覆盖 Graphics.setClip 。

    • Uses of Shape in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Shape
      Modifier and Type Class 描述
      static class  BasicTextUI.BasicCaret
      接口默认实现 Caret 。

    • Uses of Shape in javax.swing.text

      Classes in javax.swing.text that implement Shape
      Modifier and Type Class 描述
      class  DefaultCaret
      默认的Caret实现。
      Methods in javax.swing.text that return Shape
      Modifier and Type | 方法 | 描述
      protected Shape FieldView.adjustAllocation​(Shape a)
      调整给予视图的分配是文本字段的合适分配。
      protected Shape AsyncBoxView.ChildLocator.getChildAllocation​(int index)
      获取用于子视图的分配。
      Shape AsyncBoxView.ChildLocator.getChildAllocation​(int index, Shape a)
      获取用于子视图的分配。
      Shape AsyncBoxView.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      Shape BoxView.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      Shape CompositeView.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      Shape View.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      Shape AsyncBoxView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape BoxView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape ComponentView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从模型的坐标空间到视图的坐标空间的映射。
      Shape CompositeView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape CompositeView.modelToView​(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape FieldView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      abstract Shape GlyphView.GlyphPainter.modelToView​(GlyphView v, int pos, Position.Bias bias, Shape a)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape GlyphView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape IconView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape PasswordView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape PlainView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape View.modelToView​(int pos, Shape a)
      已过时。
      abstract Shape View.modelToView​(int pos, Shape a, Position.Bias b)
      提供给定字符从文档模型坐标空间到视图坐标空间的映射。
      Shape View.modelToView​(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
      Shape DefaultHighlighter.DefaultHighlightPainter.paintLayer​(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view)
      画出一部分亮点。
      abstract Shape | LayeredHighlighter.LayerPainter.paintLayer​(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      Methods in javax.swing.text with parameters of type Shape
      Modifier and Type | 方法 | 描述
      protected Shape FieldView.adjustAllocation​(Shape a)
      调整给予视图的分配是文本字段的合适分配。
      View ParagraphView.breakView​(int axis, float len, Shape a)
      以给定长度在给定轴上打破此视图。
      void FlowView.changedUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      void GlyphView.changedUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      void LabelView.changedUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      void ParagraphView.changedUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      void PlainView.changedUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      void View.changedUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      void WrappedPlainView.changedUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      protected void PlainView.damageLineRange​(int line0, int line1, Shape a, Component host)
      重复给定行范围。
      protected void BoxView.forwardUpdate​(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      将给定的 DocumentEvent转发给需要通知模型更改的子视图。
      protected void | TableView.forwardUpdate​(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      protected void View.forwardUpdate​(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      将给定的 DocumentEvent转发给需要通知模型更改的子视图。
      protected void View.forwardUpdateToView​(View v, DocumentEvent e, Shape a, ViewFactory f)
      向前 DocumentEvent给予子视图。
      Shape AsyncBoxView.ChildLocator.getChildAllocation​(int index, Shape a)
      获取用于子视图的分配。
      Shape AsyncBoxView.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      Shape BoxView.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      Shape CompositeView.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      Shape View.getChildAllocation​(int index, Shape a)
      获取给定子视图的分配。
      protected int ParagraphView.getClosestPositionTo​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
      将最接近的模型位置返回到 x 。
      protected Rectangle CompositeView.getInsideAllocation​(Shape a)
      将给予视图的不可变分配转换为表示内部分配的可变分配（即，删除顶，左，底和右插入的给定分配的边界。
      protected int CompositeView.getNextEastWestVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      返回光标的下一个视觉位置，以东或西方向。
      protected int CompositeView.getNextNorthSouthVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      返回光标的下一个视觉位置，在北或南方向。
      protected int ParagraphView.getNextNorthSouthVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      返回光标的下一个视觉位置，以东或西方向。
      int AsyncBoxView.getNextVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。
      int CompositeView.getNextVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。
      int GlyphView.getNextVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。
      int GlyphView.GlyphPainter.getNextVisualPositionFrom​(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      提供一种方法来确定可能放置插入符号的下一个视觉表示的模型位置。
      int View.getNextVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      提供一种方法来确定下一个可视表示的模型位置，在该位置可以放置插入符。
      String View.getToolTipText​(float x, float y, Shape allocation)
      返回指定位置的工具提示文本。
      int View.getViewIndex​(float x, float y, Shape allocation)
      返回表示视图中给定位置的子视图索引。
      int AsyncBoxView.ChildLocator.getViewIndexAtPoint​(float x, float y, Shape a)
      在给定点获取子视图索引。
      void FieldView.insertUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      void FlowView.insertUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      void GlyphView.insertUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      void PlainView.insertUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      void View.insertUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      void WrappedPlainView.insertUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      void ZoneView.insertUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      protected Rectangle PlainView.lineToRect​(Shape a, int line)
      确定表示给定行的矩形。
      Shape AsyncBoxView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape BoxView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape ComponentView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从模型的坐标空间到视图的坐标空间的映射。
      Shape CompositeView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape CompositeView.modelToView​(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape FieldView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      abstract Shape GlyphView.GlyphPainter.modelToView​(GlyphView v, int pos, Position.Bias bias, Shape a)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape GlyphView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape IconView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape PasswordView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape PlainView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Shape View.modelToView​(int pos, Shape a)
      已过时。
      abstract Shape View.modelToView​(int pos, Shape a, Position.Bias b)
      提供给定字符从文档模型坐标空间到视图坐标空间的映射。
      Shape View.modelToView​(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
      void AsyncBoxView.paint​(Graphics g, Shape alloc)
      使用给定的分配和渲染表面渲染视图。
      void BoxView.paint​(Graphics g, Shape allocation)
      使用给定的渲染表面和该表面上的区域渲染 BoxView 。
      void ComponentView.paint​(Graphics g, Shape a)
      真正的绘画行为自然地发生在组件与其父容器（托管此视图的同一容器）的关联中。
      void DefaultHighlighter.DefaultHighlightPainter.paint​(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c)
      画亮点
      void FieldView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      abstract void GlyphView.GlyphPainter.paint​(GlyphView v, Graphics g, Shape a, int p0, int p1)
      绘制表示给定范围的字形。
      void GlyphView.paint​(Graphics g, Shape a)
      渲染文本样式运行的一部分。
      void Highlighter.HighlightPainter.paint​(Graphics g, int p0, int p1, Shape bounds, JTextComponent c)
      渲染亮点。
      void IconView.paint​(Graphics g, Shape a)
      画图标。
      void ParagraphView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      void PlainView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      abstract void View.paint​(Graphics g, Shape allocation)
      渲染使用给定的渲染表面和该表面上的区域。
      void WrappedPlainView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      Shape DefaultHighlighter.DefaultHighlightPainter.paintLayer​(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view)
      画出一部分亮点。
      abstract Shape | LayeredHighlighter.LayerPainter.paintLayer​(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      void DefaultHighlighter.paintLayeredHighlights​(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      当叶视图（如LabelView）呈现时，它们应该调用此方法。
      abstract void LayeredHighlighter.paintLayeredHighlights​(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      当叶视图（如LabelView）呈现时，它们应该调用此方法。
      void FieldView.removeUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      void FlowView.removeUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      void GlyphView.removeUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      void PlainView.removeUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      void View.removeUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      void WrappedPlainView.removeUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      void ZoneView.removeUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      protected void AsyncBoxView.ChildLocator.setAllocation​(Shape a)
      将当前分配的形状复制到用于存储当前分配的Rectangle中。
      protected void PlainView.updateDamage​(DocumentEvent changes, Shape a, ViewFactory f)
      重印给定文件事件所涉及的变化区域。
      protected void AsyncBoxView.updateLayout​(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      响应于从模型接收到更改的通知更新布局。
      protected void View.updateLayout​(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      响应于从模型接收到更改的通知更新布局。
      int AsyncBoxView.viewToModel​(float x, float y, Shape a, Position.Bias[] biasReturn)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int BoxView.viewToModel​(float x, float y, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int ComponentView.viewToModel​(float x, float y, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int CompositeView.viewToModel​(float x, float y, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int FieldView.viewToModel​(float fx, float fy, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      abstract int GlyphView.GlyphPainter.viewToModel​(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int GlyphView.viewToModel​(float x, float y, Shape a, Position.Bias[] biasReturn)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int IconView.viewToModel​(float x, float y, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int PasswordView.viewToModel​(float fx, float fy, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int PlainView.viewToModel​(float x, float y, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
      int View.viewToModel​(float x, float y, Shape a)
      已过时。
      abstract int View.viewToModel​(float x, float y, Shape a, Position.Bias[] biasReturn)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。

    • Uses of Shape in javax.swing.text.html

      Methods in javax.swing.text.html that return Shape
      Modifier and Type 方法 描述
      Shape ImageView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      Methods in javax.swing.text.html with parameters of type Shape
      Modifier and Type | 方法 | 描述
      void | BlockView.changedUpdate​(DocumentEvent changes, Shape a, ViewFactory f)
      void ImageView.changedUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      当Elements属性更改时调用。
      void InlineView.changedUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置向文档发出属性更改的通知。
      String ImageView.getToolTipText​(float x, float y, Shape allocation)
      对于图像，工具提示文本来自使用 ALT属性指定的文本。
      void InlineView.insertUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出通知。
      Shape ImageView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      void BlockView.paint​(Graphics g, Shape allocation)
      渲染使用给定的渲染表面和该表面上的区域。
      void ImageView.paint​(Graphics g, Shape a)
      绘制视图。
      void ListView.paint​(Graphics g, Shape allocation)
      渲染使用给定的渲染表面和该表面上的区域。
      void ParagraphView.paint​(Graphics g, Shape a)
      渲染使用给定的渲染表面和该表面上的区域。
      void InlineView.removeUpdate​(DocumentEvent e, Shape a, ViewFactory f)
      在该视图负责的位置发出文档中已删除某些内容的通知。
      int ImageView.viewToModel​(float x, float y, Shape a, Position.Bias[] bias)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.Stroke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.Stroke

  • Packages that use Stroke
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of Stroke in java.awt

      Classes in java.awt that implement Stroke
      Modifier and Type Class 描述
      class  BasicStroke
      所述BasicStroke类定义了一组基本呈现属性为图形基元的轮廓，它们呈现具有的Graphics2D具有其Stroke属性设置此对象BasicStroke 。
      Methods in java.awt that return Stroke
      Modifier and Type 方法 描述
      abstract Stroke Graphics2D.getStroke​()
      返回 Graphics2D上下文中的当前 Stroke 。
      Methods in java.awt with parameters of type Stroke
      Modifier and Type 方法 描述
      abstract void Graphics2D.setStroke​(Stroke s)
      设置 Stroke为 Graphics2D的上下文。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.Transparency (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.Transparency

  • Packages that use Transparency
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。

    • Uses of Transparency in java.awt

      Subinterfaces of Transparency in java.awt
      Modifier and Type 接口 描述
      interface  Paint
      这个Paint接口定义了如何为Graphics2D操作生成颜色模式。
      Classes in java.awt that implement Transparency
      Modifier and Type Class 描述
      class  Color
      Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
      class  GradientPaint
      GradientPaint课程提供了一种使用线性颜色渐变模式填充Shape的方法。
      class  LinearGradientPaint
      LinearGradientPaint课程提供了一种填充Shape线性颜色渐变模式的方式。
      class  MultipleGradientPaint
      这是Paints的超类，它使用多色渐变填充其栅格。
      class  RadialGradientPaint
      RadialGradientPaint类提供了一种填充圆形径向颜色渐变图案的形状的方法。
      class  SystemColor
      封装代表系统上本地GUI对象颜色的符号颜色的类。
      class  TexturePaint
      TexturePaint类提供了一种填充Shape的方法，其中一个纹理被指定为BufferedImage 。

    • Uses of Transparency in java.awt.image

      Classes in java.awt.image that implement Transparency
      Modifier and Type Class 描述
      class  BufferedImage
      BufferedImage子类描述了具有图像数据的可访问缓冲区的Image 。
      class  ColorModel
      ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和Alpha组件的方法。
      class  ComponentColorModel
      一个 ColorModel类，用于将颜色和alpha信息表示为单独样本的像素值，并将每个样本存储在单独的数据元素中。
      class  DirectColorModel
      DirectColorModel类是一个 ColorModel类，适用于将RGB颜色和alpha信息表示为单独样本的像素值，并将单个像素的所有样本包装为单个int，short或byte数量。
      class  IndexColorModel
      IndexColorModel类是一个 ColorModel类，适用于由单个样本组成的像素值，该样本是默认sRGB色彩空间中固定色彩映射的索引。
      class  PackedColorModel
      PackedColorModel类是一个抽象的ColorModel类，它与像素值一起使用，它们将颜色和alpha信息表示为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。
      class  VolatileImage
      VolatileImage是由于超出应用程序控制的情况（例如由操作系统或其他应用程序引起的情况），可能随时丢失其内容的映像。

    • Uses of Transparency in javax.swing.plaf

      Classes in javax.swing.plaf that implement Transparency
      Modifier and Type Class 描述
      class  ColorUIResource
      A subclass of Color that implements UIResource.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


CMMException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.color

Class CMMException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.awt.color.CMMException
  • All Implemented Interfaces:
    Serializable

    public class CMMException
extends RuntimeException
    如果本机CMM返回错误，则抛出此异常。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CMMException​(String s)
      构造具有指定详细消息的CMMException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CMMException

        public CMMException​(String s)
        构造具有指定详细消息的CMMException。
        参数
        s - 指定的详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ColorSpace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.color

Class ColorSpace

  • java.lang.Object
    • java.awt.color.ColorSpace
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ICC_ColorSpace

    public abstract class ColorSpace
extends Object
implements Serializable
    该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。 它包含将特定颜色空间中的颜色转换为/从sRGB和/或来自明确定义的CIEXYZ颜色空间的方法。

    为了这个类中的方法的目的，颜色被表示为由每个ColorSpace定义的归一化范围内的浮点表示的颜色分量的数组。 对于许多ColorSpaces（例如sRGB），此范围为0.0到1.0。 但是，某些ColorSpaces具有值范围不同的组件。 提供方法来查询每个组件的最小和最大归一化值。

    为了引用颜色空间类型（例如，TYPE_RGB，TYPE_XYZ等）和引用特定颜色空间（例如CS_sRGB和CS_CIEXYZ），定义了几个变量。 sRGB是一种提出的标准RGB色彩空间。 有关详细信息，请参阅http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html 。

    转换到明确定义的CIEXYZ色彩空间的方法的目的是以相当高的准确度支持任何两个颜色空间之间的转换。 预计ColorSpace的子类的特定实现（例如ICC_ColorSpace）将支持基于底层平台颜色管理系统的高性能转换。

    toCIEXYZ / fromCIEXYZ方法使用的CS_CIEXYZ空间可以描述如下：

            CIEXYZ
      viewing illuminance: 200 lux
      viewing white point: CIE D50
      media white point: "that of a perfectly reflecting diffuser" -- D50
      media black point: 0 lux or 0 Reflectance
      flare: 1 percent
      surround: 20percent of the media white point
      media description: reflection print (i.e., RLAB, Hunt viewing media)
      note: For developers creating an ICC profile for this conversion
            space, the following is applicable.  Use a simple Von Kries
            white point adaptation folded into the 3X3 matrix parameters
            and fold the flare and surround effects into the three
            one-dimensional lookup tables (assuming one uses the minimal
            model for monitors).
    另请参见：
    ICC_ColorSpace ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CS_CIEXYZ
      上面定义的CIEXYZ转换颜色空间。
      static int CS_GRAY
      内置线性灰度色彩空间。
      static int CS_LINEAR_RGB
      内置线性RGB色彩空间。
      static int CS_PYCC
      照片YCC转换颜色空间。
      static int CS_sRGB
      sRGB颜色空间定义在 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html 。
      static int TYPE_2CLR
      通用2分量颜色空间。
      static int TYPE_3CLR
      通用3组件颜色空间。
      static int TYPE_4CLR
      通用4组分颜色空间。
      static int TYPE_5CLR
      通用5组件颜色空间。
      static int TYPE_6CLR
      通用6组件颜色空间。
      static int TYPE_7CLR
      通用7组件颜色空间。
      static int TYPE_8CLR
      通用8分量颜色空间。
      static int TYPE_9CLR
      通用9组件颜色空间。
      static int TYPE_ACLR
      通用10组分色彩空间。
      static int TYPE_BCLR
      通用11组件颜色空间。
      static int TYPE_CCLR
      通用12组件颜色空间。
      static int TYPE_CMY
      任何一个家庭的CMY色彩空间。
      static int TYPE_CMYK
      任何一个CMYK色彩空间的家庭。
      static int TYPE_DCLR
      通用13组件颜色空间。
      static int TYPE_ECLR
      通用14组件颜色空间。
      static int TYPE_FCLR
      通用15组件颜色空间。
      static int TYPE_GRAY
      任何一个灰色家庭的颜色空间。
      static int TYPE_HLS
      任何家庭的HLS颜色空间。
      static int TYPE_HSV
      任何家庭的HSV色彩空间。
      static int TYPE_Lab
      任何一个Lab颜色空间的家庭。
      static int TYPE_Luv
      任何Luv色彩空间的家庭。
      static int TYPE_RGB
      任何RGB色彩空间的家庭。
      static int TYPE_XYZ
      任何家庭的XYZ色彩空间。
      static int TYPE_YCbCr
      任何YCbCr色彩空间的家庭。
      static int TYPE_Yxy
      任何家庭的Yxy颜色空间。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ColorSpace​(int type, int numcomponents)
      给定一个ColorSpace对象，给出一个颜色空间类型和组件数量。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract float[] fromCIEXYZ​(float[] colorvalue)
      将CS_CIEXYZ转换颜色空间中假定的颜色值转换为此ColorSpace。
      abstract float[] fromRGB​(float[] rgbvalue)
      将假定为默认的CS_sRGB颜色空间的颜色值转换为此ColorSpace。
      static ColorSpace getInstance​(int colorspace)
      返回表示特定预定义颜色空间之一的ColorSpace。
      float getMaxValue​(int component)
      返回指定组件的最大标准化颜色分量值。
      float getMinValue​(int component)
      返回指定组件的最小标准化颜色分量值。
      String getName​(int idx)
      返回给定组件索引的组件的名称。
      int getNumComponents​()
      返回此ColorSpace的组件数。
      int getType​()
      返回此ColorSpace的颜色空间类型（例如TYPE_RGB，TYPE_XYZ，...）。
      boolean isCS_sRGB​()
      如果ColorSpace为CS_sRGB，则返回true。
      abstract float[] toCIEXYZ​(float[] colorvalue)
      将此ColorSpace中假定为的颜色值转换为CS_CIEXYZ转换颜色空间。
      abstract float[] toRGB​(float[] colorvalue)
      将假定在此ColorSpace中的颜色值转换为默认CS_sRGB颜色空间中的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TYPE_XYZ

        @Native
public static final int TYPE_XYZ
        任何家庭的XYZ色彩空间。
        另请参见：
        Constant Field Values

      • TYPE_Lab

        @Native
public static final int TYPE_Lab
        任何一个Lab颜色空间的家庭。
        另请参见：
        Constant Field Values

      • TYPE_Luv

        @Native
public static final int TYPE_Luv
        任何Luv色彩空间的家庭。
        另请参见：
        Constant Field Values

      • TYPE_YCbCr

        @Native
public static final int TYPE_YCbCr
        任何YCbCr色彩空间的家庭。
        另请参见：
        Constant Field Values

      • TYPE_Yxy

        @Native
public static final int TYPE_Yxy
        任何家庭的Yxy颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_RGB

        @Native
public static final int TYPE_RGB
        任何RGB色彩空间的家庭。
        另请参见：
        Constant Field Values

      • TYPE_GRAY

        @Native
public static final int TYPE_GRAY
        任何一个灰色家庭的颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_HSV

        @Native
public static final int TYPE_HSV
        任何家庭的HSV色彩空间。
        另请参见：
        Constant Field Values

      • TYPE_HLS

        @Native
public static final int TYPE_HLS
        任何家庭的HLS颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_CMYK

        @Native
public static final int TYPE_CMYK
        任何一个CMYK色彩空间的家庭。
        另请参见：
        Constant Field Values

      • TYPE_CMY

        @Native
public static final int TYPE_CMY
        任何一个家庭的CMY色彩空间。
        另请参见：
        Constant Field Values

      • TYPE_2CLR

        @Native
public static final int TYPE_2CLR
        通用2分量颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_3CLR

        @Native
public static final int TYPE_3CLR
        通用3组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_4CLR

        @Native
public static final int TYPE_4CLR
        通用4组分颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_5CLR

        @Native
public static final int TYPE_5CLR
        通用5组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_6CLR

        @Native
public static final int TYPE_6CLR
        通用6组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_7CLR

        @Native
public static final int TYPE_7CLR
        通用7组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_8CLR

        @Native
public static final int TYPE_8CLR
        通用8分量颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_9CLR

        @Native
public static final int TYPE_9CLR
        通用9组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_ACLR

        @Native
public static final int TYPE_ACLR
        通用10组分色彩空间。
        另请参见：
        Constant Field Values

      • TYPE_BCLR

        @Native
public static final int TYPE_BCLR
        通用11组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_CCLR

        @Native
public static final int TYPE_CCLR
        通用12组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_DCLR

        @Native
public static final int TYPE_DCLR
        通用13组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_ECLR

        @Native
public static final int TYPE_ECLR
        通用14组件颜色空间。
        另请参见：
        Constant Field Values

      • TYPE_FCLR

        @Native
public static final int TYPE_FCLR
        通用15组件颜色空间。
        另请参见：
        Constant Field Values

      • CS_sRGB

        @Native
public static final int CS_sRGB
        sRGB颜色空间定义在 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html 。
        另请参见：
        Constant Field Values

      • CS_LINEAR_RGB

        @Native
public static final int CS_LINEAR_RGB
        内置线性RGB色彩空间。 该空间基于与CS_sRGB相同的RGB原色，但具有线性色调再现曲线。
        另请参见：
        Constant Field Values

      • CS_CIEXYZ

        @Native
public static final int CS_CIEXYZ
        上面定义的CIEXYZ转换颜色空间。
        另请参见：
        Constant Field Values

      • CS_PYCC

        @Native
public static final int CS_PYCC
        照片YCC转换颜色空间。
        另请参见：
        Constant Field Values

      • CS_GRAY

        @Native
public static final int CS_GRAY
        内置线性灰度色彩空间。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ColorSpace

        protected ColorSpace​(int type,
                     int numcomponents)
        给定一个ColorSpace对象，给出一个颜色空间类型和组件数量。
        参数
        type - ColorSpace类型常量之一
        numcomponents - 颜色空间中的组件数

    • 方法详细信息

      • getInstance

        public static ColorSpace getInstance​(int colorspace)
        返回表示特定预定义颜色空间之一的ColorSpace。
        参数
        colorspace - 由预定义的类常量之一（例如CS_sRGB，CS_LINEAR_RGB，CS_CIEXYZ，CS_GRAY或CS_PYCC）标识的特定颜色空间，
        结果
        请求的 ColorSpace对象

      • isCS_sRGB

        public boolean isCS_sRGB​()
        如果ColorSpace为CS_sRGB，则返回true。
        结果
        true如果这是一个 CS_sRGB颜色空间， false如果不是

      • toRGB

        public abstract float[] toRGB​(float[] colorvalue)
        将假定在此ColorSpace中的颜色值转换为默认CS_sRGB颜色空间中的值。

        该方法使用旨在产生输入和输出颜色之间最佳感知匹配的算法来转换颜色值。 为了进行颜色值的比色转换，您应该使用此颜色空间的toCIEXYZ方法首先将输入颜色空间转换为CS_CIEXYZ颜色空间，然后使用CS_sRGB颜色空间的fromCIEXYZ方法将其从CS_CIEXYZ转换为输出颜色空间。 有关详细信息，请参阅toCIEXYZ和fromCIEXYZ 。

        参数
        colorvalue - 长度至少为此ColorSpace中组件数量的浮点数组
        结果
        长度为3的浮点数组
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度至少不在此ColorSpace中的组件数量

      • fromRGB

        public abstract float[] fromRGB​(float[] rgbvalue)
        将假定为默认的CS_sRGB颜色空间的颜色值转换为此ColorSpace。

        该方法使用旨在产生输入和输出颜色之间最佳感知匹配的算法来转换颜色值。 为了进行颜色值的比色转换，您应该使用CS_sRGB颜色空间的toCIEXYZ方法首先将输入颜色空间转换为CS_CIEXYZ颜色空间，然后使用此颜色空间的fromCIEXYZ方法将其从CS_CIEXYZ转换为输出颜色空间。 有关详细信息，请参阅toCIEXYZ和fromCIEXYZ 。

        参数
        rgbvalue - 长度至少为3的浮点数组
        结果
        长度等于此ColorSpace中组件数量的浮点数组
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度不小于3

      • toCIEXYZ

        public abstract float[] toCIEXYZ​(float[] colorvalue)
        将此ColorSpace中假定为的颜色值转换为CS_CIEXYZ转换颜色空间。

        该方法使用国际色彩联盟标准定义的相对比色法来转换颜色值。 这意味着通过该方法返回的XYZ值相对于CS_CIEXYZ颜色空间的D50白点来表示。 这种表示在两步颜色转换过程中是有用的，其中颜色从输入颜色空间转换为CS_CIEXYZ，然后转换为输出颜色空间。 该表示与通过色度计从给定颜色值测量的XYZ值不同。 需要进一步的转换来计算使用当前CIE推荐做法测量的XYZ值。 见toCIEXYZ的方法ICC_ColorSpace进一步的信息。

        参数
        colorvalue - 一个长度至少为此ColorSpace中组件数量的浮点数组
        结果
        长度为3的浮点数组
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度至少不在此ColorSpace中的组件数量。

      • fromCIEXYZ

        public abstract float[] fromCIEXYZ​(float[] colorvalue)
        将CS_CIEXYZ转换颜色空间中假定的颜色值转换为此ColorSpace。

        该方法使用国际色彩联盟标准定义的相对比色法来转换颜色值。 这意味着该方法采用的XYZ参数值相对于CS_CIEXYZ颜色空间的D50白点表示。 这种表示在两步颜色转换过程中是有用的，其中颜色从输入颜色空间转换为CS_CIEXYZ，然后转换为输出颜色空间。 该方法返回的颜色值不是那些通过色度计测量时会产生传递给方法的XYZ值的那些。 如果您使用与使用当前CIE推荐做法进行测量相对应的XYZ值，则必须将其转换为D50相对值，然后再传递给此方法。 见fromCIEXYZ的方法ICC_ColorSpace进一步的信息。

        参数
        colorvalue - 一个长度至少为3的浮点数组
        结果
        长度等于此ColorSpace中组件数量的浮点数组
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度不小于3

      • getType

        public int getType​()
        返回此ColorSpace的颜色空间类型（例如TYPE_RGB，TYPE_XYZ，...）。 该类型定义了颜色空间和解释的组件数量，例如，TYPE_RGB用三个组件（红色，绿色和蓝色）来标识颜色空间。 它不定义空间的特定颜色特征，例如初级色度。
        结果
        表示此类型的类型常数 ColorSpace

      • getNumComponents

        public int getNumComponents​()
        返回此ColorSpace的组件数。
        结果
        这个组件的数量在这个 ColorSpace 。

      • getName

        public String getName​(int idx)
        返回给定组件索引的组件的名称。
        参数
        idx - 组件索引
        结果
        指定索引处的组件的名称
        异常
        IllegalArgumentException - 如果 idx小于0或大于numComponents - 1

      • getMinValue

        public float getMinValue​(int component)
        返回指定组件的最小标准化颜色分量值。 该抽象类中的默认实现为所有组件返回0.0。 如果需要，子类应该覆盖此方法。
        参数
        component - 组件索引
        结果
        最小归一化分量值
        异常
        IllegalArgumentException - 如果组件小于0或大于numComponents - 1
        从以下版本开始：
        1.4

      • getMaxValue

        public float getMaxValue​(int component)
        返回指定组件的最大标准化颜色分量值。 该抽象类中的默认实现为所有组件返回1.0。 如果需要，子类应该覆盖此方法。
        参数
        component - 组件索引
        结果
        最大归一化分量值
        异常
        IllegalArgumentException - 如果组件小于0或大于numComponents - 1
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ICC_ColorSpace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.color

Class ICC_ColorSpace

  • java.lang.Object
    • java.awt.color.ColorSpace
      • java.awt.color.ICC_ColorSpace
  • All Implemented Interfaces:
    Serializable

    public class ICC_ColorSpace
extends ColorSpace
    ICC_ColorSpace类是抽象ColorSpace类的一个实现。 这种与设备无关和设备相关色彩空间的表示基于国际色彩联盟规范ICC.1：2001-12，色彩档案格式（见http://www.color.org ）。

    通常，Color或ColorModel将与ICC配置文件相关联，ICC配置文件是输入，显示或输出配置文件（请参阅ICC规范）。 还有其他类型的ICC配置文件，例如抽象配置文件，设备链接配置文件和命名的颜色配置文件，不包含适用于表示颜色，图像或设备颜色空间的信息（请参阅ICC_Profile）。 尝试从不适当的ICC配置文件创建ICC_ColorSpace对象是一个错误。

    ICC配置文件表示从配置文件（例如监视器）的颜色空间到配置文件连接空间（PCS）的转换。 用于标记图像或颜色感兴趣的配置文件具有PCS，它是ICC配置文件格式规范中定义的设备独立空间（一个CIEXYZ空间和两个CIELab空间）之一。 感兴趣的大多数资料都可以进行可逆转换，也可以明确地指出双向转换。 如果使用ICC_ColorSpace对象需要从PCS转换到配置文件的本机空间，并且没有足够的数据来正确执行转换，则ICC_ColorSpace对象将产生指定类型的颜色空间的输出（例如TYPE_RGB，TYPE_CMYK等） 。），但是输出数据的特定颜色值将是未定义的。

    这个类的细节对于绘制默认颜色空间或者使用已知颜色空间操纵和显示导入图像的简单小程序不重要。 最多，这样的小程序需要通过ColorSpace.getInstance（）获得默认的颜色空间。

    另请参见：
    ColorSpace ， ICC_Profile ， Serialized Form

    • Field Summary

      • Fields inherited from class java.awt.color.ColorSpace

        CS_CIEXYZ, CS_GRAY, CS_LINEAR_RGB, CS_PYCC, CS_sRGB, TYPE_2CLR, TYPE_3CLR, TYPE_4CLR, TYPE_5CLR, TYPE_6CLR, TYPE_7CLR, TYPE_8CLR, TYPE_9CLR, TYPE_ACLR, TYPE_BCLR, TYPE_CCLR, TYPE_CMY, TYPE_CMYK, TYPE_DCLR, TYPE_ECLR, TYPE_FCLR, TYPE_GRAY, TYPE_HLS, TYPE_HSV, TYPE_Lab, TYPE_Luv, TYPE_RGB, TYPE_XYZ, TYPE_YCbCr, TYPE_Yxy

    • 构造方法摘要

      构造方法
      Constructor 描述
      ICC_ColorSpace​(ICC_Profile profile)
      从ICC_Profile对象构造一个新的ICC_ColorSpace。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      float[] fromCIEXYZ​(float[] colorvalue)
      将CS_CIEXYZ转换颜色空间中假定的颜色值转换为此ColorSpace。
      float[] fromRGB​(float[] rgbvalue)
      将假定为默认的CS_sRGB颜色空间的颜色值转换为此ColorSpace。
      float getMaxValue​(int component)
      返回指定组件的最大标准化颜色分量值。
      float getMinValue​(int component)
      返回指定组件的最小标准化颜色分量值。
      ICC_Profile getProfile​()
      返回ICC_ColorSpace的ICC_Profile。
      float[] toCIEXYZ​(float[] colorvalue)
      将此ColorSpace中假定为的颜色值转换为CS_CIEXYZ转换颜色空间。
      float[] toRGB​(float[] colorvalue)
      将假定在此ColorSpace中的颜色值转换为默认CS_sRGB颜色空间中的值。

      • Methods inherited from class java.awt.color.ColorSpace

        getInstance, getName, getNumComponents, getType, isCS_sRGB

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ICC_ColorSpace

        public ICC_ColorSpace​(ICC_Profile profile)
        从ICC_Profile对象构造一个新的ICC_ColorSpace。
        参数
        profile - 指定的ICC_Profile对象
        异常
        IllegalArgumentException - 如果配置文件不适合代表ColorSpace。

    • 方法详细信息

      • getProfile

        public ICC_Profile getProfile​()
        返回ICC_ColorSpace的ICC_Profile。
        结果
        该ICC_ColorSpace的ICC_Profile。

      • toRGB

        public float[] toRGB​(float[] colorvalue)
        将假定在此ColorSpace中的颜色值转换为默认CS_sRGB颜色空间中的值。

        该方法使用旨在产生输入和输出颜色之间最佳感知匹配的算法来转换颜色值。 为了进行颜色值的比色转换，您应该使用此颜色空间的toCIEXYZ方法首先将输入颜色空间转换为CS_CIEXYZ颜色空间，然后使用CS_sRGB颜色空间的fromCIEXYZ方法将CS_CIEXYZ转换为输出颜色空间。 有关详细信息，请参阅toCIEXYZ和fromCIEXYZ 。

        Specified by:
        toRGB在 ColorSpace
        参数
        colorvalue - 长度至少为此ColorSpace中组件数量的浮点数组。
        结果
        长度为3的浮点数组。
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度至少不在此ColorSpace中的组件数量。

      • fromRGB

        public float[] fromRGB​(float[] rgbvalue)
        将假定为默认的CS_sRGB颜色空间的颜色值转换为此ColorSpace。

        该方法使用旨在产生输入和输出颜色之间最佳感知匹配的算法来转换颜色值。 为了进行颜色值的比色转换，您应该使用CS_sRGB颜色空间的toCIEXYZ方法首先将输入颜色空间转换为CS_CIEXYZ颜色空间，然后使用此颜色空间的fromCIEXYZ方法将其从CS_CIEXYZ转换为输出颜色空间。 有关详细信息，请参阅toCIEXYZ和fromCIEXYZ 。

        Specified by:
        fromRGB在 ColorSpace
        参数
        rgbvalue - 长度至少为3的浮点数组。
        结果
        长度等于此ColorSpace中组件数量的浮点数组。
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度不小于3。

      • toCIEXYZ

        public float[] toCIEXYZ​(float[] colorvalue)
        将此ColorSpace中假定为的颜色值转换为CS_CIEXYZ转换颜色空间。

        该方法使用ICC规范定义的相对比色法来转换颜色值。 这意味着通过该方法返回的XYZ值相对于CS_CIEXYZ颜色空间的D50白点来表示。 这种表示在两步颜色转换过程中是有用的，其中颜色从输入颜色空间转换为CS_CIEXYZ，然后转换为输出颜色空间。 该表示与通过色度计从给定颜色值测量的XYZ值不同。 需要进一步的转换来计算使用当前CIE推荐做法测量的XYZ值。 下面的段落更详细地解释了这一点。

        ICC标准使用设备独立色彩空间（DICS）作为将颜色从一个设备转换到另一个设备的机制。 在此架构中，颜色从源设备的颜色空间转换为ICC DICS，然后从ICC DICS转换为目标设备的颜色空间。 ICC标准定义了包含将在设备的颜色空间和ICC DICS之间转换的转换的设备配置文件。 通过将源设备的配置文件的设备到DICS变换连接到目标设备的配置文件的DICS到设备的变换，可以实现从源设备到目标设备的颜色的整体转换。 因此，ICC DICS通常被称为配置文件连接空间（PCS）。 用于CIEXYZ和CIEXYZ的方法中使用的色彩空间是由ICC规范定义的CIEXYZ PCS。 这也是ColorSpace.CS_CIEXYZ表示的颜色空间。

        颜色的XYZ值通常表示为相对于某些白点，因此，在不知道这些值的白点的情况下，不能知道XYZ值的实际含义。 这被称为相对比色法。 PCS使用D50的白点，因此PCS的XYZ值相对于D50。 例如，PCS中的白色将具有D50的XYZ值，其定义为X = .9642，Y = 1.000，Z = 0.8249。 这个白点通常用于图形艺术应用，但是其他应用通常被使用。

        为了量化诸如打印机或监视器的设备的颜色特性，通常进行特定设备颜色的XYZ值的测量。 为了讨论的目的，术语设备XYZ值用于表示将使用当前CIE推荐做法从设备颜色测量的XYZ值。

        通过此方法返回的设备XYZ值和PCS XYZ值之间的转换对应于在CIE色度值表示的设备颜色空间与PCS之间进行转换。 这个过程涉及很多因素，其中一些是相当微妙的。 然而，最重要的是对设备的白点和PCS白点之间的差异进行调整。 有很多这样做的技术，它是目前研究和争议的主题。 一些常用的方法是XYZ缩放，von Kries变换和Bradford变换。 正确的使用方法取决于每个特定应用程序。

        最简单的方法是XYZ缩放。 在该方法中，通过将PCS XYZ值乘以PCS白点（D50）与设备白点的比例，将每个设备XYZ值转换为PCS XYZ值。

          Xd, Yd, Zd are the device XYZ values
 Xdw, Ydw, Zdw are the device XYZ white point values
 Xp, Yp, Zp are the PCS XYZ values
 Xd50, Yd50, Zd50 are the PCS XYZ white point values

 Xp = Xd * (Xd50 / Xdw)
 Yp = Yd * (Yd50 / Ydw)
 Zp = Zd * (Zd50 / Zdw)

        从PCS到设备的转换将通过颠倒这些方程：

          Xd = Xp * (Xdw / Xd50)
 Yd = Yp * (Ydw / Yd50)
 Zd = Zp * (Zdw / Zd50)

        请注意，ICC配置文件中的介质白点标签与设备白点不同。 介质白点标签以PCS值表示，用于表示在该光源下测量时，设备光源的XYZ与设备介质的XYZ之间的差异。 设备白点表示为与设备上显示的白色对应的设备XYZ值。 例如，在sRGB设备上显示RGB颜色（1.0,1.0,1.0）将导致测量的设备XYZ值为D65。 这与sRGB设备的ICC配置文件中的媒体白点标签XYZ值不同。

        Specified by:
        toCIEXYZ在 ColorSpace
        参数
        colorvalue - 一个长度至少为此ColorSpace中组件数量的浮点数组。
        结果
        长度为3的浮点数组。
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度至少不在此ColorSpace中的组件数量。

      • fromCIEXYZ

        public float[] fromCIEXYZ​(float[] colorvalue)
        将CS_CIEXYZ转换颜色空间中假定的颜色值转换为此ColorSpace。

        该方法使用ICC规范定义的相对比色法来转换颜色值。 这意味着该方法采用的XYZ参数值相对于CS_CIEXYZ颜色空间的D50白点表示。 这种表示在两步颜色转换过程中是有用的，其中颜色从输入颜色空间转换为CS_CIEXYZ，然后转换为输出颜色空间。 该方法返回的颜色值不是那些通过色度计测量时会产生传递给方法的XYZ值的那些。 如果您使用与使用当前CIE推荐做法进行测量相对应的XYZ值，则必须将其转换为D50相对值，然后再传递给此方法。 下面的段落更详细地解释了这一点。

        ICC标准使用设备独立色彩空间（DICS）作为将颜色从一个设备转换到另一个设备的机制。 在此架构中，颜色从源设备的颜色空间转换为ICC DICS，然后从ICC DICS转换为目标设备的颜色空间。 ICC标准定义了包含将在设备的颜色空间和ICC DICS之间转换的转换的设备配置文件。 通过将源设备的配置文件的设备到DICS变换连接到目标设备的配置文件的DICS到设备的变换，可以实现从源设备到目标设备的颜色的整体转换。 因此，ICC DICS通常被称为配置文件连接空间（PCS）。 用于CIEXYZ和CIEXYZ的方法中使用的色彩空间是由ICC规范定义的CIEXYZ PCS。 这也是ColorSpace.CS_CIEXYZ表示的颜色空间。

        颜色的XYZ值通常表示为相对于某些白点，因此，在不知道这些值的白点的情况下，不能知道XYZ值的实际含义。 这被称为相对比色法。 PCS使用D50的白点，因此PCS的XYZ值相对于D50。 例如，PCS中的白色将具有D50的XYZ值，其定义为X = .9642，Y = 1.000，Z = 0.8249。 这个白点通常用于图形艺术应用，但是其他应用通常被使用。

        为了量化诸如打印机或监视器的设备的颜色特性，通常进行特定设备颜色的XYZ值的测量。 为了讨论的目的，术语设备XYZ值用于表示将使用当前CIE推荐做法从设备颜色测量的XYZ值。

        通过此方法将设备XYZ值和作为参数的PCS XYZ值之间的转换对应于以CIE比色值表示的设备颜色空间与PCS之间的转换。 这个过程涉及很多因素，其中一些是相当微妙的。 然而，最重要的是对设备的白点和PCS白点之间的差异进行调整。 有很多这样做的技术，它是目前研究和争议的主题。 一些常用的方法是XYZ缩放，von Kries变换和Bradford变换。 正确的使用方法取决于每个特定应用程序。

        最简单的方法是XYZ缩放。 在该方法中，通过将PCS XYZ值乘以PCS白点（D50）与设备白点的比例，将每个设备XYZ值转换为PCS XYZ值。

          Xd, Yd, Zd are the device XYZ values
 Xdw, Ydw, Zdw are the device XYZ white point values
 Xp, Yp, Zp are the PCS XYZ values
 Xd50, Yd50, Zd50 are the PCS XYZ white point values

 Xp = Xd * (Xd50 / Xdw)
 Yp = Yd * (Yd50 / Ydw)
 Zp = Zd * (Zd50 / Zdw)

        从PCS到设备的转换将通过颠倒这些方程：

          Xd = Xp * (Xdw / Xd50)
 Yd = Yp * (Ydw / Yd50)
 Zd = Zp * (Zdw / Zd50)

        请注意，ICC配置文件中的介质白点标签与设备白点不同。 介质白点标签以PCS值表示，用于表示在该光源下测量时，设备光源的XYZ与设备介质的XYZ之间的差异。 设备白点表示为与设备上显示的白色对应的设备XYZ值。 例如，在sRGB设备上显示RGB颜色（1.0,1.0,1.0）将导致测量的设备XYZ值为D65。 这与sRGB设备的ICC配置文件中的媒体白点标签XYZ值不同。

        Specified by:
        fromCIEXYZ在 ColorSpace
        参数
        colorvalue - 长度至少为3的浮点数组。
        结果
        长度等于此ColorSpace中组件数量的浮点数组。
        异常
        ArrayIndexOutOfBoundsException - 如果数组长度不小于3。

      • getMinValue

        public float getMinValue​(int component)
        返回指定组件的最小标准化颜色分量值。 对于TYPE_XYZ空格，此方法为所有组件返回最小值0.0。 对于TYPE_Lab空格，此方法对于L和b组件返回0.0，L和-128.0。 这与ICC规范中的XYZ和Lab Profile连接空间的编码一致。 对于所有其他类型，此方法对所有组件返回0.0。 当使用具有需要不同最小组件值的配置文件的ICC_ColorSpace时，需要对此类进行子类化并覆盖此方法。
        重写：
        getMinValue在 ColorSpace
        参数
        component - 组件索引。
        结果
        最小归一化分量值。
        异常
        IllegalArgumentException - 如果组件小于0或大于numComponents - 1。
        从以下版本开始：
        1.4

      • getMaxValue

        public float getMaxValue​(int component)
        返回指定组件的最大标准化颜色分量值。 对于TYPE_XYZ空格，此方法为所有组件返回最大值为1.0 +（32767.0 / 32768.0）。 对于TYPE_Lab空格，此方法对于L和B组件返回100.0和127.0。 这与ICC规范中的XYZ和Lab Profile连接空间的编码一致。 对于所有其他类型，此方法对所有组件返回1.0。 当使用ICC_ColorSpace与配置文件需要不同的最大组件值时，有必要对此类进行子类化并覆盖此方法。
        重写：
        getMaxValue在 ColorSpace
        参数
        component - 组件索引。
        结果
        最大归一化分量值。
        异常
        IllegalArgumentException - 如果组件小于0或大于numComponents - 1。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ICC_Profile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.color

Class ICC_Profile

  • java.lang.Object
    • java.awt.color.ICC_Profile
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ICC_ProfileGray ， ICC_ProfileRGB

    public class ICC_Profile
extends Object
implements Serializable
    基于国际色彩联盟规范ICC.1：2001-12，颜色配置文件的格式（参见http://www.color.org ），用于与设备无关和与设备相关的色彩空间的颜色配置文件数据的表示。

    ICC_ColorSpace对象可以从一个适当的ICC_Profile构造。 通常，ICC_ColorSpace将与ICC配置文件相关联，ICC配置文件是输入，显示或输出配置文件（请参阅ICC规范）。 还有设备链接，抽象，颜色空间转换和命名的颜色配置文件。 这些对于标记颜色或图像不太有用，但对于其他目的（特别是设备链接配置文件可以提供改进的性能，从一个设备的颜色空间转换到另一个）。

    ICC配置文件表示从配置文件（例如监视器）的颜色空间到配置文件连接空间（PCS）的转换。 用于标记图像或颜色的兴趣类型具有PCS，它是ICC配置文件格式规范中定义的两个特定设备独立空间（一个CIEXYZ空间和一个CIELab空间）之一。 感兴趣的大多数资料都可以进行可逆转换，也可以明确地指出双向转换。

    另请参见：
    ICC_ColorSpace ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CLASS_ABSTRACT
      简档类是抽象的。
      static int CLASS_COLORSPACECONVERSION
      Profile类是颜色空间的转换。
      static int CLASS_DEVICELINK
      配置文件类是设备链接。
      static int CLASS_DISPLAY
      Profile类是显示。
      static int CLASS_INPUT
      配置文件类是输入。
      static int CLASS_NAMEDCOLOR
      配置文件类命名为颜色。
      static int CLASS_OUTPUT
      配置文件类被输出。
      static int icAbsoluteColorimetric
      ICC配置文件渲染意图：绝对色度。
      static int icCurveCount
      ICC Profile Constant：curveType count。
      static int icCurveData
      ICC Profile Constant：curveType数据。
      static int icHdrAttributes
      ICC配置文件头位置：设备属性。
      static int icHdrCmmId
      ICC Profile Header位置：此配置文件的CMM。
      static int icHdrColorSpace
      ICC Profile Header位置：数据的颜色空间。
      static int icHdrCreator
      ICC Profile Header位置：个人资料创建者。
      static int icHdrDate
      ICC配置文件头位置：创建日期配置文件。
      static int icHdrDeviceClass
      ICC配置文件头位置：配置文件的类型。
      static int icHdrFlags
      ICC配置文件头位置：各种位设置。
      static int icHdrIlluminant
      ICC Profile Header位置：配置文件。
      static int icHdrMagic
      ICC Profile Header位置：icMagicNumber。
      static int icHdrManufacturer
      ICC Profile Header位置：设备制造商。
      static int icHdrModel
      ICC Profile Header位置：设备型号。
      static int icHdrPcs
      ICC Profile Header位置：PCS - XYZ或Lab。
      static int icHdrPlatform
      ICC Profile Header位置：主平台。
      static int icHdrProfileID
      ICC Profile Header位置：个人资料ID。
      static int icHdrRenderingIntent
      ICC Profile Header位置：渲染意图。
      static int icHdrSize
      ICC Profile Header位置：配置文件大小（以字节为单位）。
      static int icHdrVersion
      ICC Profile Header位置：格式版本号。
      static int icICCAbsoluteColorimetric
      ICC Profile Rendering Intent：ICC-AbsoluteColorimetric。
      static int icMediaRelativeColorimetric
      ICC配置文件渲染意图：Media-RelativeColorimetric。
      static int icPerceptual
      ICC概要呈现意图：感性。
      static int icRelativeColorimetric
      ICC配置文件渲染意图：RelativeColorimetric。
      static int icSaturation
      ICC配置文件渲染意图：饱和度。
      static int icSigAbstractClass
      ICC简介类别签名：'abst'。
      static int icSigAToB0Tag
      ICC简介标签签名：'A2B0'。
      static int icSigAToB1Tag
      ICC简介标签签名：'A2B1'。
      static int icSigAToB2Tag
      ICC简介标签签名：'A2B2'。
      static int icSigBlueColorantTag
      ICC简介标签签名：'bXYZ'。
      static int icSigBlueMatrixColumnTag
      ICC简介标签签名：'bXYZ'。
      static int icSigBlueTRCTag
      ICC简介标签签名：'bTRC'。
      static int icSigBToA0Tag
      ICC Profile Tag签名：'B2A0'。
      static int icSigBToA1Tag
      ICC简介标签签名：'B2A1'。
      static int icSigBToA2Tag
      ICC简介标签签名：'B2A2'。
      static int icSigCalibrationDateTimeTag
      ICC简介标签签名：'calt'。
      static int icSigCharTargetTag
      ICC简介标签签名：'targ'。
      static int icSigChromaticAdaptationTag
      ICC简介标签签名：'乍得'。
      static int icSigChromaticityTag
      ICC简介标签签名：'chrm'。
      static int icSigCmyData
      ICC配置文件颜色空间类型签名：'CMY'。
      static int icSigCmykData
      ICC配置文件颜色空间类型签名：'CMYK'。
      static int icSigColorantOrderTag
      ICC简介标签签名：'clro'。
      static int icSigColorantTableTag
      ICC简介标签签名：'clrt'。
      static int icSigColorSpaceClass
      ICC Profile Class签名：'spac'。
      static int icSigCopyrightTag
      ICC简介标签签名：'cprt'。
      static int icSigCrdInfoTag
      ICC简介标签签名：'crdi'。
      static int icSigDeviceMfgDescTag
      ICC配置文件标签签名：'dmnd'。
      static int icSigDeviceModelDescTag
      ICC配置文件标签签名：'dmdd'。
      static int icSigDeviceSettingsTag
      ICC Profile Tag签名：'devs'。
      static int icSigDisplayClass
      ICC简介类别签名：'mntr'。
      static int icSigGamutTag
      ICC简介标签签名：'gamt'。
      static int icSigGrayData
      ICC配置文件颜色空间类型签名：'GREY'。
      static int icSigGrayTRCTag
      ICC简介标签签名：'kTRC'。
      static int icSigGreenColorantTag
      ICC简介标签签名：'gXYZ'。
      static int icSigGreenMatrixColumnTag
      ICC简介标签签名：'gXYZ'。
      static int icSigGreenTRCTag
      ICC简介标签签名：'gTRC'。
      static int icSigHead
      ICC简介标签签名：'头' - 特别。
      static int icSigHlsData
      ICC配置文件颜色空间类型签名：'HLS'。
      static int icSigHsvData
      ICC配置文件颜色空间类型签名：'HSV'。
      static int icSigInputClass
      ICC档案类签名：'scnr'。
      static int icSigLabData
      ICC简介颜色空间类型签名：'实验室'。
      static int icSigLinkClass
      ICC档案类签名：'link'。
      static int icSigLuminanceTag
      ICC简介标签签名：'lumi'。
      static int icSigLuvData
      ICC简介颜色空间类型签名：'Luv'。
      static int icSigMeasurementTag
      ICC简介标签签名：'meas'。
      static int icSigMediaBlackPointTag
      ICC简介标签签名：'bkpt'。
      static int icSigMediaWhitePointTag
      ICC简介标签签名：'wtpt'。
      static int icSigNamedColor2Tag
      ICC配置文件标签签名：'ncl2'。
      static int icSigNamedColorClass
      ICC简介类签名：'nmcl'。
      static int icSigOutputClass
      ICC档案类签名：'prtr'。
      static int icSigOutputResponseTag
      ICC简介标签签名：'resp'。
      static int icSigPreview0Tag
      ICC简介标签签名：'pre0'。
      static int icSigPreview1Tag
      ICC简介标签签名：'pre1'。
      static int icSigPreview2Tag
      ICC简介标签签名：'pre2'。
      static int icSigProfileDescriptionTag
      ICC简介标签签名：'desc'。
      static int icSigProfileSequenceDescTag
      ICC简介标签签名：'pseq'。
      static int icSigPs2CRD0Tag
      ICC配置文件标签签名：'psd0'。
      static int icSigPs2CRD1Tag
      ICC配置文件标签签名：'psd1'。
      static int icSigPs2CRD2Tag
      ICC配置文件标签签名：'psd2'。
      static int icSigPs2CRD3Tag
      ICC配置文件标签签名：'psd3'。
      static int icSigPs2CSATag
      ICC简介标签签名：'ps2s'。
      static int icSigPs2RenderingIntentTag
      ICC配置文件标签签名：'ps2i'。
      static int icSigRedColorantTag
      ICC简介标签签名：'rXYZ'。
      static int icSigRedMatrixColumnTag
      ICC简介标签签名：'rXYZ'。
      static int icSigRedTRCTag
      ICC简介标签签名：'rTRC'。
      static int icSigRgbData
      ICC配置文件颜色空间类型签名：'RGB'。
      static int icSigScreeningDescTag
      ICC简介标签签名：'scrd'。
      static int icSigScreeningTag
      ICC简介标签签名：'scrn'。
      static int icSigSpace2CLR
      ICC配置文件颜色空间类型签名：'2CLR'。
      static int icSigSpace3CLR
      ICC配置文件颜色空间类型签名：'3CLR'。
      static int icSigSpace4CLR
      ICC配置文件颜色空间类型签名：'4CLR'。
      static int icSigSpace5CLR
      ICC配置文件颜色空间类型签名：'5CLR'。
      static int icSigSpace6CLR
      ICC配置文件颜色空间类型签名：'6CLR'。
      static int icSigSpace7CLR
      ICC配置文件颜色空间类型签名：'7CLR'。
      static int icSigSpace8CLR
      ICC配置文件颜色空间类型签名：'8CLR'。
      static int icSigSpace9CLR
      ICC配置文件颜色空间类型签名：'9CLR'。
      static int icSigSpaceACLR
      ICC配置文件颜色空间类型签名：'ACLR'。
      static int icSigSpaceBCLR
      ICC配置文件颜色空间类型签名：'BCLR'。
      static int icSigSpaceCCLR
      ICC配置文件颜色空间类型签名：'CCLR'。
      static int icSigSpaceDCLR
      ICC配置文件颜色空间类型签名：'DCLR'。
      static int icSigSpaceECLR
      ICC简介颜色空间类型签名：'ECLR'。
      static int icSigSpaceFCLR
      ICC配置文件颜色空间类型签名：'FCLR'。
      static int icSigTechnologyTag
      ICC简介标签签名：'科技'。
      static int icSigUcrBgTag
      ICC配置文件标签签名：'bfd'。
      static int icSigViewingCondDescTag
      ICC简介标签签名：'vued'。
      static int icSigViewingConditionsTag
      ICC简介标签签名：'视图'。
      static int icSigXYZData
      ICC配置文件颜色空间类型签名：'XYZ'。
      static int icSigYCbCrData
      ICC配置文件颜色空间类型签名：'YCbr'。
      static int icSigYxyData
      ICC配置文件颜色空间类型签名：'Yxy'。
      static int icTagReserved
      ICC配置常数：保留。
      static int icTagType
      ICC Profile Constant：标签类型签名。
      static int icXYZNumberX
      ICC配置常数：XYZNumber X.

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      int getColorSpaceType​()
      返回颜色空间类型。
      byte[] getData​()
      返回与该ICC_Profile的数据对应的字节数组。
      byte[] getData​(int tagSignature)
      从配置文件返回特定的标记数据元素作为字节数组。
      static ICC_Profile getInstance​(byte[] data)
      构造与字节数组中的数据相对应的ICC_Profile对象。
      static ICC_Profile getInstance​(int cspace)
      构造一个对应于由ColorSpace类定义的特定颜色空间之一的ICC_Profile（例如CS_sRGB）。
      static ICC_Profile getInstance​(InputStream s)
      构造一个与InputStream中数据对应的ICC_Profile。
      static ICC_Profile getInstance​(String fileName)
      构造与文件中数据对应的ICC_Profile。
      int getMajorVersion​()
      返回配置文件主版本。
      int getMinorVersion​()
      返回配置文件小版本。
      int getNumComponents​()
      返回此配置文件的“输入”颜色空间中的颜色分量数。
      int getPCSType​()
      返回配置文件连接空间（PCS）的颜色空间类型。
      int getProfileClass​()
      返回概要文件类。
      protected Object readResolve​()
      将被反序列化的实例解析为使用CMM注册的实例。
      void setData​(int tagSignature, byte[] tagData)
      从一个字节数组中设置一个特定的标记数据元素。
      void write​(OutputStream s)
      将此ICC_Profile写入OutputStream。
      void write​(String fileName)
      将此ICC_Profile写入文件。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • CLASS_INPUT

        public static final int CLASS_INPUT
        配置文件类是输入。
        另请参见：
        Constant Field Values

      • CLASS_DISPLAY

        public static final int CLASS_DISPLAY
        Profile类是显示。
        另请参见：
        Constant Field Values

      • CLASS_OUTPUT

        public static final int CLASS_OUTPUT
        配置文件类被输出。
        另请参见：
        Constant Field Values

      • CLASS_DEVICELINK

        public static final int CLASS_DEVICELINK
        配置文件类是设备链接。
        另请参见：
        Constant Field Values

      • CLASS_COLORSPACECONVERSION

        public static final int CLASS_COLORSPACECONVERSION
        Profile类是颜色空间的转换。
        另请参见：
        Constant Field Values

      • CLASS_ABSTRACT

        public static final int CLASS_ABSTRACT
        简档类是抽象的。
        另请参见：
        Constant Field Values

      • CLASS_NAMEDCOLOR

        public static final int CLASS_NAMEDCOLOR
        配置文件类命名为颜色。
        另请参见：
        Constant Field Values

      • icSigXYZData

        public static final int icSigXYZData
        ICC配置文件颜色空间类型签名：'XYZ'。
        另请参见：
        Constant Field Values

      • icSigLabData

        public static final int icSigLabData
        ICC简介颜色空间类型签名：'实验室'。
        另请参见：
        Constant Field Values

      • icSigLuvData

        public static final int icSigLuvData
        ICC简介颜色空间类型签名：'Luv'。
        另请参见：
        Constant Field Values

      • icSigYCbCrData

        public static final int icSigYCbCrData
        ICC配置文件颜色空间类型签名：'YCbr'。
        另请参见：
        Constant Field Values

      • icSigYxyData

        public static final int icSigYxyData
        ICC配置文件颜色空间类型签名：'Yxy'。
        另请参见：
        Constant Field Values

      • icSigRgbData

        public static final int icSigRgbData
        ICC配置文件颜色空间类型签名：'RGB'。
        另请参见：
        Constant Field Values

      • icSigGrayData

        public static final int icSigGrayData
        ICC配置文件颜色空间类型签名：'GREY'。
        另请参见：
        Constant Field Values

      • icSigHsvData

        public static final int icSigHsvData
        ICC配置文件颜色空间类型签名：'HSV'。
        另请参见：
        Constant Field Values

      • icSigHlsData

        public static final int icSigHlsData
        ICC配置文件颜色空间类型签名：'HLS'。
        另请参见：
        Constant Field Values

      • icSigCmykData

        public static final int icSigCmykData
        ICC配置文件颜色空间类型签名：'CMYK'。
        另请参见：
        Constant Field Values

      • icSigCmyData

        public static final int icSigCmyData
        ICC配置文件颜色空间类型签名：'CMY'。
        另请参见：
        Constant Field Values

      • icSigSpace2CLR

        public static final int icSigSpace2CLR
        ICC配置文件颜色空间类型签名：'2CLR'。
        另请参见：
        Constant Field Values

      • icSigSpace3CLR

        public static final int icSigSpace3CLR
        ICC配置文件颜色空间类型签名：'3CLR'。
        另请参见：
        Constant Field Values

      • icSigSpace4CLR

        public static final int icSigSpace4CLR
        ICC配置文件颜色空间类型签名：'4CLR'。
        另请参见：
        Constant Field Values

      • icSigSpace5CLR

        public static final int icSigSpace5CLR
        ICC配置文件颜色空间类型签名：'5CLR'。
        另请参见：
        Constant Field Values

      • icSigSpace6CLR

        public static final int icSigSpace6CLR
        ICC配置文件颜色空间类型签名：'6CLR'。
        另请参见：
        Constant Field Values

      • icSigSpace7CLR

        public static final int icSigSpace7CLR
        ICC配置文件颜色空间类型签名：'7CLR'。
        另请参见：
        Constant Field Values

      • icSigSpace8CLR

        public static final int icSigSpace8CLR
        ICC配置文件颜色空间类型签名：'8CLR'。
        另请参见：
        Constant Field Values

      • icSigSpace9CLR

        public static final int icSigSpace9CLR
        ICC配置文件颜色空间类型签名：'9CLR'。
        另请参见：
        Constant Field Values

      • icSigSpaceACLR

        public static final int icSigSpaceACLR
        ICC配置文件颜色空间类型签名：'ACLR'。
        另请参见：
        Constant Field Values

      • icSigSpaceBCLR

        public static final int icSigSpaceBCLR
        ICC配置文件颜色空间类型签名：'BCLR'。
        另请参见：
        Constant Field Values

      • icSigSpaceCCLR

        public static final int icSigSpaceCCLR
        ICC配置文件颜色空间类型签名：'CCLR'。
        另请参见：
        Constant Field Values

      • icSigSpaceDCLR

        public static final int icSigSpaceDCLR
        ICC配置文件颜色空间类型签名：'DCLR'。
        另请参见：
        Constant Field Values

      • icSigSpaceECLR

        public static final int icSigSpaceECLR
        ICC简介颜色空间类型签名：'ECLR'。
        另请参见：
        Constant Field Values

      • icSigSpaceFCLR

        public static final int icSigSpaceFCLR
        ICC配置文件颜色空间类型签名：'FCLR'。
        另请参见：
        Constant Field Values

      • icSigInputClass

        public static final int icSigInputClass
        ICC档案类签名：'scnr'。
        另请参见：
        Constant Field Values

      • icSigDisplayClass

        public static final int icSigDisplayClass
        ICC简介类别签名：'mntr'。
        另请参见：
        Constant Field Values

      • icSigOutputClass

        public static final int icSigOutputClass
        ICC档案类签名：'prtr'。
        另请参见：
        Constant Field Values

      • icSigLinkClass

        public static final int icSigLinkClass
        ICC档案类签名：'link'。
        另请参见：
        Constant Field Values

      • icSigAbstractClass

        public static final int icSigAbstractClass
        ICC简介类别签名：'abst'。
        另请参见：
        Constant Field Values

      • icSigColorSpaceClass

        public static final int icSigColorSpaceClass
        ICC Profile Class签名：'spac'。
        另请参见：
        Constant Field Values

      • icSigNamedColorClass

        public static final int icSigNamedColorClass
        ICC简介类签名：'nmcl'。
        另请参见：
        Constant Field Values

      • icPerceptual

        public static final int icPerceptual
        ICC概要呈现意图：感性。
        另请参见：
        Constant Field Values

      • icRelativeColorimetric

        public static final int icRelativeColorimetric
        ICC配置文件渲染意图：RelativeColorimetric。
        另请参见：
        Constant Field Values

      • icMediaRelativeColorimetric

        public static final int icMediaRelativeColorimetric
        ICC配置文件渲染意图：Media-RelativeColorimetric。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icSaturation

        public static final int icSaturation
        ICC配置文件渲染意图：饱和度。
        另请参见：
        Constant Field Values

      • icAbsoluteColorimetric

        public static final int icAbsoluteColorimetric
        ICC配置文件渲染意图：绝对色度。
        另请参见：
        Constant Field Values

      • icICCAbsoluteColorimetric

        public static final int icICCAbsoluteColorimetric
        ICC Profile Rendering Intent：ICC-AbsoluteColorimetric。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icSigHead

        public static final int icSigHead
        ICC简介标签签名：'头' - 特别。
        另请参见：
        Constant Field Values

      • icSigAToB0Tag

        public static final int icSigAToB0Tag
        ICC简介标签签名：'A2B0'。
        另请参见：
        Constant Field Values

      • icSigAToB1Tag

        public static final int icSigAToB1Tag
        ICC简介标签签名：'A2B1'。
        另请参见：
        Constant Field Values

      • icSigAToB2Tag

        public static final int icSigAToB2Tag
        ICC简介标签签名：'A2B2'。
        另请参见：
        Constant Field Values

      • icSigBlueColorantTag

        public static final int icSigBlueColorantTag
        ICC简介标签签名：'bXYZ'。
        另请参见：
        Constant Field Values

      • icSigBlueMatrixColumnTag

        public static final int icSigBlueMatrixColumnTag
        ICC简介标签签名：'bXYZ'。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icSigBlueTRCTag

        public static final int icSigBlueTRCTag
        ICC简介标签签名：'bTRC'。
        另请参见：
        Constant Field Values

      • icSigBToA0Tag

        public static final int icSigBToA0Tag
        ICC Profile Tag签名：'B2A0'。
        另请参见：
        Constant Field Values

      • icSigBToA1Tag

        public static final int icSigBToA1Tag
        ICC简介标签签名：'B2A1'。
        另请参见：
        Constant Field Values

      • icSigBToA2Tag

        public static final int icSigBToA2Tag
        ICC简介标签签名：'B2A2'。
        另请参见：
        Constant Field Values

      • icSigCalibrationDateTimeTag

        public static final int icSigCalibrationDateTimeTag
        ICC简介标签签名：'calt'。
        另请参见：
        Constant Field Values

      • icSigCharTargetTag

        public static final int icSigCharTargetTag
        ICC简介标签签名：'targ'。
        另请参见：
        Constant Field Values

      • icSigCopyrightTag

        public static final int icSigCopyrightTag
        ICC简介标签签名：'cprt'。
        另请参见：
        Constant Field Values

      • icSigCrdInfoTag

        public static final int icSigCrdInfoTag
        ICC简介标签签名：'crdi'。
        另请参见：
        Constant Field Values

      • icSigDeviceMfgDescTag

        public static final int icSigDeviceMfgDescTag
        ICC配置文件标签签名：'dmnd'。
        另请参见：
        Constant Field Values

      • icSigDeviceModelDescTag

        public static final int icSigDeviceModelDescTag
        ICC配置文件标签签名：'dmdd'。
        另请参见：
        Constant Field Values

      • icSigDeviceSettingsTag

        public static final int icSigDeviceSettingsTag
        ICC Profile Tag签名：'devs'。
        另请参见：
        Constant Field Values

      • icSigGamutTag

        public static final int icSigGamutTag
        ICC简介标签签名：'gamt'。
        另请参见：
        Constant Field Values

      • icSigGrayTRCTag

        public static final int icSigGrayTRCTag
        ICC简介标签签名：'kTRC'。
        另请参见：
        Constant Field Values

      • icSigGreenColorantTag

        public static final int icSigGreenColorantTag
        ICC简介标签签名：'gXYZ'。
        另请参见：
        Constant Field Values

      • icSigGreenMatrixColumnTag

        public static final int icSigGreenMatrixColumnTag
        ICC简介标签签名：'gXYZ'。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icSigGreenTRCTag

        public static final int icSigGreenTRCTag
        ICC简介标签签名：'gTRC'。
        另请参见：
        Constant Field Values

      • icSigLuminanceTag

        public static final int icSigLuminanceTag
        ICC简介标签签名：'lumi'。
        另请参见：
        Constant Field Values

      • icSigMeasurementTag

        public static final int icSigMeasurementTag
        ICC简介标签签名：'meas'。
        另请参见：
        Constant Field Values

      • icSigMediaBlackPointTag

        public static final int icSigMediaBlackPointTag
        ICC简介标签签名：'bkpt'。
        另请参见：
        Constant Field Values

      • icSigMediaWhitePointTag

        public static final int icSigMediaWhitePointTag
        ICC简介标签签名：'wtpt'。
        另请参见：
        Constant Field Values

      • icSigNamedColor2Tag

        public static final int icSigNamedColor2Tag
        ICC配置文件标签签名：'ncl2'。
        另请参见：
        Constant Field Values

      • icSigOutputResponseTag

        public static final int icSigOutputResponseTag
        ICC简介标签签名：'resp'。
        另请参见：
        Constant Field Values

      • icSigPreview0Tag

        public static final int icSigPreview0Tag
        ICC简介标签签名：'pre0'。
        另请参见：
        Constant Field Values

      • icSigPreview1Tag

        public static final int icSigPreview1Tag
        ICC简介标签签名：'pre1'。
        另请参见：
        Constant Field Values

      • icSigPreview2Tag

        public static final int icSigPreview2Tag
        ICC简介标签签名：'pre2'。
        另请参见：
        Constant Field Values

      • icSigProfileDescriptionTag

        public static final int icSigProfileDescriptionTag
        ICC简介标签签名：'desc'。
        另请参见：
        Constant Field Values

      • icSigProfileSequenceDescTag

        public static final int icSigProfileSequenceDescTag
        ICC简介标签签名：'pseq'。
        另请参见：
        Constant Field Values

      • icSigPs2CRD0Tag

        public static final int icSigPs2CRD0Tag
        ICC配置文件标签签名：'psd0'。
        另请参见：
        Constant Field Values

      • icSigPs2CRD1Tag

        public static final int icSigPs2CRD1Tag
        ICC配置文件标签签名：'psd1'。
        另请参见：
        Constant Field Values

      • icSigPs2CRD2Tag

        public static final int icSigPs2CRD2Tag
        ICC配置文件标签签名：'psd2'。
        另请参见：
        Constant Field Values

      • icSigPs2CRD3Tag

        public static final int icSigPs2CRD3Tag
        ICC配置文件标签签名：'psd3'。
        另请参见：
        Constant Field Values

      • icSigPs2CSATag

        public static final int icSigPs2CSATag
        ICC简介标签签名：'ps2s'。
        另请参见：
        Constant Field Values

      • icSigPs2RenderingIntentTag

        public static final int icSigPs2RenderingIntentTag
        ICC配置文件标签签名：'ps2i'。
        另请参见：
        Constant Field Values

      • icSigRedColorantTag

        public static final int icSigRedColorantTag
        ICC简介标签签名：'rXYZ'。
        另请参见：
        Constant Field Values

      • icSigRedMatrixColumnTag

        public static final int icSigRedMatrixColumnTag
        ICC简介标签签名：'rXYZ'。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icSigRedTRCTag

        public static final int icSigRedTRCTag
        ICC简介标签签名：'rTRC'。
        另请参见：
        Constant Field Values

      • icSigScreeningDescTag

        public static final int icSigScreeningDescTag
        ICC简介标签签名：'scrd'。
        另请参见：
        Constant Field Values

      • icSigScreeningTag

        public static final int icSigScreeningTag
        ICC简介标签签名：'scrn'。
        另请参见：
        Constant Field Values

      • icSigTechnologyTag

        public static final int icSigTechnologyTag
        ICC简介标签签名：'科技'。
        另请参见：
        Constant Field Values

      • icSigUcrBgTag

        public static final int icSigUcrBgTag
        ICC配置文件标签签名：'bfd'。
        另请参见：
        Constant Field Values

      • icSigViewingCondDescTag

        public static final int icSigViewingCondDescTag
        ICC简介标签签名：'vued'。
        另请参见：
        Constant Field Values

      • icSigViewingConditionsTag

        public static final int icSigViewingConditionsTag
        ICC简介标签签名：'视图'。
        另请参见：
        Constant Field Values

      • icSigChromaticityTag

        public static final int icSigChromaticityTag
        ICC简介标签签名：'chrm'。
        另请参见：
        Constant Field Values

      • icSigChromaticAdaptationTag

        public static final int icSigChromaticAdaptationTag
        ICC简介标签签名：'乍得'。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icSigColorantOrderTag

        public static final int icSigColorantOrderTag
        ICC简介标签签名：'clro'。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icSigColorantTableTag

        public static final int icSigColorantTableTag
        ICC简介标签签名：'clrt'。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icHdrSize

        public static final int icHdrSize
        ICC Profile Header位置：配置文件大小（以字节为单位）。
        另请参见：
        Constant Field Values

      • icHdrCmmId

        public static final int icHdrCmmId
        ICC Profile Header位置：此配置文件的CMM。
        另请参见：
        Constant Field Values

      • icHdrVersion

        public static final int icHdrVersion
        ICC Profile Header位置：格式版本号。
        另请参见：
        Constant Field Values

      • icHdrDeviceClass

        public static final int icHdrDeviceClass
        ICC配置文件头位置：配置文件的类型。
        另请参见：
        Constant Field Values

      • icHdrColorSpace

        public static final int icHdrColorSpace
        ICC Profile Header位置：数据的颜色空间。
        另请参见：
        Constant Field Values

      • icHdrPcs

        public static final int icHdrPcs
        ICC Profile Header位置：PCS - XYZ或Lab。
        另请参见：
        Constant Field Values

      • icHdrDate

        public static final int icHdrDate
        ICC配置文件头位置：创建日期配置文件。
        另请参见：
        Constant Field Values

      • icHdrMagic

        public static final int icHdrMagic
        ICC Profile Header位置：icMagicNumber。
        另请参见：
        Constant Field Values

      • icHdrPlatform

        public static final int icHdrPlatform
        ICC Profile Header位置：主平台。
        另请参见：
        Constant Field Values

      • icHdrFlags

        public static final int icHdrFlags
        ICC配置文件头位置：各种位设置。
        另请参见：
        Constant Field Values

      • icHdrManufacturer

        public static final int icHdrManufacturer
        ICC Profile Header位置：设备制造商。
        另请参见：
        Constant Field Values

      • icHdrModel

        public static final int icHdrModel
        ICC Profile Header位置：设备型号。
        另请参见：
        Constant Field Values

      • icHdrAttributes

        public static final int icHdrAttributes
        ICC配置文件头位置：设备属性。
        另请参见：
        Constant Field Values

      • icHdrRenderingIntent

        public static final int icHdrRenderingIntent
        ICC Profile Header位置：渲染意图。
        另请参见：
        Constant Field Values

      • icHdrIlluminant

        public static final int icHdrIlluminant
        ICC Profile Header位置：配置文件。
        另请参见：
        Constant Field Values

      • icHdrCreator

        public static final int icHdrCreator
        ICC Profile Header位置：个人资料创建者。
        另请参见：
        Constant Field Values

      • icHdrProfileID

        public static final int icHdrProfileID
        ICC Profile Header位置：个人资料ID。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • icTagType

        public static final int icTagType
        ICC Profile Constant：标签类型签名。
        另请参见：
        Constant Field Values

      • icTagReserved

        public static final int icTagReserved
        ICC配置常数：保留。
        另请参见：
        Constant Field Values

      • icCurveCount

        public static final int icCurveCount
        ICC Profile Constant：curveType count。
        另请参见：
        Constant Field Values

      • icCurveData

        public static final int icCurveData
        ICC Profile Constant：curveType数据。
        另请参见：
        Constant Field Values

      • icXYZNumberX

        public static final int icXYZNumberX
        ICC配置常数：XYZNumber X.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • finalize

        @Deprecated(since="9")
protected void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中描述的方式调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        释放与ICC_Profile对象关联的资源。
        重写：
        finalize在 Object
        另请参见：
        WeakReference ， PhantomReference

      • getInstance

        public static ICC_Profile getInstance​(byte[] data)
        构造与字节数组中的数据相对应的ICC_Profile对象。 如果数据不对应于有效的ICC配置文件，则抛出IllegalArgumentException异常。
        参数
        data - 指定的ICC配置文件数据
        结果
        一个 ICC_Profile对象对应于指定的 data数组的数据。

      • getInstance

        public static ICC_Profile getInstance​(int cspace)
        构造一个对应于由ColorSpace类定义的特定颜色空间之一的ICC_Profile（例如CS_sRGB）。 如果cspace不是已定义的颜色空间之一，则抛出IllegalArgumentException异常。
        参数
        cspace - 为其创建配置文件的颜色空间的类型。 指定的类型是ColorSpace类中定义的颜色空间常量之一。
        结果
        一个 ICC_Profile对象对应于指定的 ColorSpace类型。
        异常
        IllegalArgumentException - 如果 cspace不是预定义的颜色空间类型之一。

      • getInstance

        public static ICC_Profile getInstance​(String fileName)
                               throws IOException
        构造与文件中数据对应的ICC_Profile。 fileName可以是绝对或相对文件规范。 在几个地方查找相对文件名：首先，相对于java.iccprofile.path属性指定的任何目录; 第二，相对于由java.class.path属性指定的任何目录; 最后，在用于存储配置文件的目录中始终可用，例如sRGB的配置文件。 内置配置文件使用.pf作为配置文件的文件扩展名，例如sRGB.pf。 如果指定的文件无法打开或读取文件时发生I / O错误，则此方法会引发IOException。 如果文件不包含有效的ICC配置文件数据，它将抛出IllegalArgumentException异常。
        参数
        fileName - 包含配置文件数据的文件。
        结果
        一个 ICC_Profile对象对应于指定文件中的数据。
        异常
        IOException - 如果指定的文件无法打开或读取文件时发生I / O错误。
        IllegalArgumentException - 如果文件不包含有效的ICC配置文件数据。
        SecurityException - 如果已安装安全管理器，并且不允许对给定文件的读取访问。

      • getInstance

        public static ICC_Profile getInstance​(InputStream s)
                               throws IOException
        构造一个与InputStream中数据对应的ICC_Profile。 如果流不包含有效的ICC配置文件数据，则此方法将抛出IllegalArgumentException异常。 如果在读取流时发生I / O错误，则会抛出IOException。
        参数
        s - 从中读取配置文件数据的输入流。
        结果
        一个 ICC_Profile对象对应于指定的数据 InputStream 。
        异常
        IOException - 如果在读取流时发生I / O错误。
        IllegalArgumentException - 如果流不包含有效的ICC配置文件数据。

      • getMajorVersion

        public int getMajorVersion​()
        返回配置文件主版本。
        结果
        配置文件的主要版本。

      • getMinorVersion

        public int getMinorVersion​()
        返回配置文件小版本。
        结果
        配置文件的次要版本。

      • getProfileClass

        public int getProfileClass​()
        返回概要文件类。
        结果
        其中一个预定义的配置文件类常量。

      • getColorSpaceType

        public int getColorSpaceType​()
        返回颜色空间类型。 返回ColorSpace类定义的颜色空间类型常量之一。 这是配置文件的“输入”颜色空间。 该类型定义了颜色空间和解释的组件数量，例如，TYPE_RGB用三个组件（红色，绿色和蓝色）来标识颜色空间。 它不定义空间的特定颜色特征，例如初级色度。
        结果
        ColorSpace类中定义的颜色空间类型常量之一。

      • getPCSType

        public int getPCSType​()
        返回配置文件连接空间（PCS）的颜色空间类型。 返回ColorSpace类定义的颜色空间类型常量之一。 这是配置文件的“输出”颜色空间。 对于可用于标记颜色或图像的输入，显示或输出配置文件，可以是TYPE_XYZ或TYPE_Lab，并应被解释为ICC规范中定义的相应的特定颜色空间。 对于设备链接配置文件，这可以是任何颜色空间类型常量。
        结果
        ColorSpace类中定义的颜色空间类型常量之一。

      • write

        public void write​(String fileName)
           throws IOException
        将此ICC_Profile写入文件。
        参数
        fileName - 将配置文件数据写入的文件。
        异常
        IOException - 如果无法打开文件进行写入或在写入文件时发生I / O错误。

      • write

        public void write​(OutputStream s)
           throws IOException
        将此ICC_Profile写入OutputStream。
        参数
        s - 将配置文件数据写入的流。
        异常
        IOException - 如果在写入流时发生I / O错误。

      • getData

        public byte[] getData​()
        返回与该ICC_Profile的数据对应的字节数组。
        结果
        包含配置文件数据的字节数组。
        另请参见：
        setData(int, byte[])

      • getData

        public byte[] getData​(int tagSignature)
        从配置文件返回特定的标记数据元素作为字节数组。 元素由ICC规范中定义的签名标识。 标签icSigHead可用于获取标题。 此方法对于需要直接访问配置文件数据的高级小应用程序或应用程序很有用。
        参数
        tagSignature - 要获取的数据元素的ICC标签签名。
        结果
        包含标记数据元素的字节数组。 如果指定的标签不存在，则返回null 。
        另请参见：
        setData(int, byte[])

      • setData

        public void setData​(int tagSignature,
                    byte[] tagData)
        从一个字节数组中设置一个特定的标记数据元素。 阵列应包含格式的数据，对应于ICC规范第10节定义的tagSignature该方法对于需要直接访问配置文件数据的高级小应用程序或应用程序很有用。
        参数
        tagSignature - 要设置的数据元素的ICC标记签名。
        tagData - 为指定标签签名设置的数据
        异常
        IllegalArgumentException - 如果 tagSignature不是ICC规范中定义的签名。
        IllegalArgumentException - 如果 tagData数组的内容不能被解释为有效的标签数据，对应于 tagSignature 。
        另请参见：
        getData()

      • getNumComponents

        public int getNumComponents​()
        返回此配置文件的“输入”颜色空间中的颜色分量数。 例如，如果此配置文件的颜色空间类型为TYPE_RGB，则此方法将返回3。
        结果
        配置文件输入颜色空间中颜色组件的数量。
        异常
        ProfileDataException - 如果配置文件中的颜色空间无效

      • readResolve

        protected Object readResolve​()
                      throws ObjectStreamException
        将被反序列化的实例解析为使用CMM注册的实例。
        结果
        使用CMM注册的配置文件的ICC_Profile对象。
        异常
        ObjectStreamException - 从未抛出，但是由序列化规范强制。
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ICC_ProfileGray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.color

Class ICC_ProfileGray

  • java.lang.Object
    • java.awt.color.ICC_Profile
      • java.awt.color.ICC_ProfileGray
  • All Implemented Interfaces:
    Serializable

    public class ICC_ProfileGray
extends ICC_Profile
    ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为TYPE_GRAY，配置文件包含grayTRCTag和mediaWhitePointTag标签。 这种配置文件的示例是单色输入配置文件，单色显示配置文件和单色输出配置文件。 当满足上述条件时，ICC_Profile类中的getInstance方法将返回一个ICC_ProfileGray对象。 这个类的优点是它提供了一个查找表，在某些情况下，Java或本机方法可以直接使用来优化颜色转换。

    要从GREY设备配置文件颜色空间转换到CIEXYZ配置文件连接空间，设备灰色组件通过色调再现曲线（TRC）的查找进行转换。 结果被视为PCS的消色差分量。

                      PCSY = grayTRC[deviceGray]
    逆变换是通过将灰色TRC的反相转换为PCS Y组件到设备Gray来完成的。
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.awt.color.ICC_Profile

        CLASS_ABSTRACT, CLASS_COLORSPACECONVERSION, CLASS_DEVICELINK, CLASS_DISPLAY, CLASS_INPUT, CLASS_NAMEDCOLOR, CLASS_OUTPUT, icAbsoluteColorimetric, icCurveCount, icCurveData, icHdrAttributes, icHdrCmmId, icHdrColorSpace, icHdrCreator, icHdrDate, icHdrDeviceClass, icHdrFlags, icHdrIlluminant, icHdrMagic, icHdrManufacturer, icHdrModel, icHdrPcs, icHdrPlatform, icHdrProfileID, icHdrRenderingIntent, icHdrSize, icHdrVersion, icICCAbsoluteColorimetric, icMediaRelativeColorimetric, icPerceptual, icRelativeColorimetric, icSaturation, icSigAbstractClass, icSigAToB0Tag, icSigAToB1Tag, icSigAToB2Tag, icSigBlueColorantTag, icSigBlueMatrixColumnTag, icSigBlueTRCTag, icSigBToA0Tag, icSigBToA1Tag, icSigBToA2Tag, icSigCalibrationDateTimeTag, icSigCharTargetTag, icSigChromaticAdaptationTag, icSigChromaticityTag, icSigCmyData, icSigCmykData, icSigColorantOrderTag, icSigColorantTableTag, icSigColorSpaceClass, icSigCopyrightTag, icSigCrdInfoTag, icSigDeviceMfgDescTag, icSigDeviceModelDescTag, icSigDeviceSettingsTag, icSigDisplayClass, icSigGamutTag, icSigGrayData, icSigGrayTRCTag, icSigGreenColorantTag, icSigGreenMatrixColumnTag, icSigGreenTRCTag, icSigHead, icSigHlsData, icSigHsvData, icSigInputClass, icSigLabData, icSigLinkClass, icSigLuminanceTag, icSigLuvData, icSigMeasurementTag, icSigMediaBlackPointTag, icSigMediaWhitePointTag, icSigNamedColor2Tag, icSigNamedColorClass, icSigOutputClass, icSigOutputResponseTag, icSigPreview0Tag, icSigPreview1Tag, icSigPreview2Tag, icSigProfileDescriptionTag, icSigProfileSequenceDescTag, icSigPs2CRD0Tag, icSigPs2CRD1Tag, icSigPs2CRD2Tag, icSigPs2CRD3Tag, icSigPs2CSATag, icSigPs2RenderingIntentTag, icSigRedColorantTag, icSigRedMatrixColumnTag, icSigRedTRCTag, icSigRgbData, icSigScreeningDescTag, icSigScreeningTag, icSigSpace2CLR, icSigSpace3CLR, icSigSpace4CLR, icSigSpace5CLR, icSigSpace6CLR, icSigSpace7CLR, icSigSpace8CLR, icSigSpace9CLR, icSigSpaceACLR, icSigSpaceBCLR, icSigSpaceCCLR, icSigSpaceDCLR, icSigSpaceECLR, icSigSpaceFCLR, icSigTechnologyTag, icSigUcrBgTag, icSigViewingCondDescTag, icSigViewingConditionsTag, icSigXYZData, icSigYCbCrData, icSigYxyData, icTagReserved, icTagType, icXYZNumberX

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      float getGamma​()
      返回表示色调再现曲线（TRC）的伽马值。
      float[] getMediaWhitePoint​()
      返回一个长度为3的浮点数组，其中包含ICC配置文件中mediaWhitePointTag的X，Y和Z组件。
      short[] getTRC​()
      将TRC作为一组短裤返回。

      • Methods inherited from class java.awt.color.ICC_Profile

        finalize, getColorSpaceType, getData, getData, getInstance, getInstance, getInstance, getInstance, getMajorVersion, getMinorVersion, getNumComponents, getPCSType, getProfileClass, readResolve, setData, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getMediaWhitePoint

        public float[] getMediaWhitePoint​()
        返回一个长度为3的浮点数组，其中包含ICC配置文件中mediaWhitePointTag的X，Y和Z组件。
        结果
        一个包含ICC配置文件中mediaWhitePointTag组件的数组。

      • getGamma

        public float getGamma​()
        返回表示色调再现曲线（TRC）的伽马值。 如果配置文件将TRC表示为表，而不是单个gamma值，则抛出异常。 在这种情况下，实际的表可以通过getTRC（）获得。 当使用伽马值时，PCS Y组件计算如下：
                                    gamma
         PCSY = deviceGray
        结果
        伽马值为浮点数。
        异常
        ProfileDataException - 如果配置文件没有将TRC指定为单个伽玛值。

      • getTRC

        public short[] getTRC​()
        将TRC作为一组短裤返回。 如果配置文件将TRC指定为线性（gamma = 1.0）或简单的伽玛值，则此方法将抛出异常，并且应使用getGamma（）方法获取伽玛值。 否则返回的短数组表示一个查找表，其中输入的灰值在概念上在[0.0，1.0]的范围内。 值0.0映射到数组索引0，值1.0映射到数组索引长度-1。 可以使用插值来生成不精确映射到数组中的索引的输入值的输出值。 输出值也线性映射到范围[0.0，1.0]。 值0.0由数组值0x0000和值1.0由0xFFFF表示，即这些值是真正的无符号短值，尽管它们以短数组返回。
        结果
        代表TRC的短阵列。
        异常
        ProfileDataException - 如果配置文件没有将TRC指定为表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ICC_ProfileRGB (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.color

Class ICC_ProfileRGB

  • java.lang.Object
    • java.awt.color.ICC_Profile
      • java.awt.color.ICC_ProfileRGB
  • All Implemented Interfaces:
    Serializable

    public class ICC_ProfileRGB
extends ICC_Profile
    ICC_ProfileRGB类是ICC_Profile类的子类，表示符合以下条件的配置文件：
    • 配置文件的颜色空间类型为RGB。
    • 该配置文件包含redColorantTag ， greenColorantTag ， blueColorantTag ， redTRCTag ， greenTRCTag ， blueTRCTag ，并mediaWhitePointTag标签。
    当满足这些条件时， ICC_Profile getInstance方法将返回一个ICC_ProfileRGB对象。 三组件，基于矩阵的输入配置文件和RGB显示配置文件是这种类型配置文件的示例。

    此配置文件类提供了颜色转换矩阵和查找表，Java或本机方法可以在某些情况下直接使用颜色转换来优化颜色转换。

    要从设备配置文件颜色空间转换到CIEXYZ配置文件连接空间，每个设备颜色组件首先通过相应的色调再现曲线（TRC）的查找进行线性化。 所得到的线性RGB分量使用由RGB着色剂构成的3×3矩阵转换为CIEXYZ PCS。

                      linearR = redTRC[deviceR]

                 linearG = greenTRC[deviceG]

                 linearB = blueTRC[deviceB]

   _      _       _                                             _   _         _
  [  PCSX  ]     [  redColorantX  greenColorantX  blueColorantX  ] [  linearR  ]
  [        ]     [                                               ] [           ]
  [  PCSY  ]  =  [  redColorantY  greenColorantY  blueColorantY  ] [  linearG  ]
  [        ]     [                                               ] [           ]
  [_ PCSZ _]     [_ redColorantZ  greenColorantZ  blueColorantZ _] [_ linearB _]
    通过将PCS XYZ分量转换为上述3×3矩阵的逆的线性RGB分量，然后通过反向TRC将线性RGB转换为设备RGB来执行逆变换。
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BLUECOMPONENT
      用于获取蓝色分量的伽马值或TRC。
      static int GREENCOMPONENT
      用于获取绿色组件的伽马值或TRC。
      static int REDCOMPONENT
      用于获得红色分量的伽马值或TRC。

      • Fields inherited from class java.awt.color.ICC_Profile

        CLASS_ABSTRACT, CLASS_COLORSPACECONVERSION, CLASS_DEVICELINK, CLASS_DISPLAY, CLASS_INPUT, CLASS_NAMEDCOLOR, CLASS_OUTPUT, icAbsoluteColorimetric, icCurveCount, icCurveData, icHdrAttributes, icHdrCmmId, icHdrColorSpace, icHdrCreator, icHdrDate, icHdrDeviceClass, icHdrFlags, icHdrIlluminant, icHdrMagic, icHdrManufacturer, icHdrModel, icHdrPcs, icHdrPlatform, icHdrProfileID, icHdrRenderingIntent, icHdrSize, icHdrVersion, icICCAbsoluteColorimetric, icMediaRelativeColorimetric, icPerceptual, icRelativeColorimetric, icSaturation, icSigAbstractClass, icSigAToB0Tag, icSigAToB1Tag, icSigAToB2Tag, icSigBlueColorantTag, icSigBlueMatrixColumnTag, icSigBlueTRCTag, icSigBToA0Tag, icSigBToA1Tag, icSigBToA2Tag, icSigCalibrationDateTimeTag, icSigCharTargetTag, icSigChromaticAdaptationTag, icSigChromaticityTag, icSigCmyData, icSigCmykData, icSigColorantOrderTag, icSigColorantTableTag, icSigColorSpaceClass, icSigCopyrightTag, icSigCrdInfoTag, icSigDeviceMfgDescTag, icSigDeviceModelDescTag, icSigDeviceSettingsTag, icSigDisplayClass, icSigGamutTag, icSigGrayData, icSigGrayTRCTag, icSigGreenColorantTag, icSigGreenMatrixColumnTag, icSigGreenTRCTag, icSigHead, icSigHlsData, icSigHsvData, icSigInputClass, icSigLabData, icSigLinkClass, icSigLuminanceTag, icSigLuvData, icSigMeasurementTag, icSigMediaBlackPointTag, icSigMediaWhitePointTag, icSigNamedColor2Tag, icSigNamedColorClass, icSigOutputClass, icSigOutputResponseTag, icSigPreview0Tag, icSigPreview1Tag, icSigPreview2Tag, icSigProfileDescriptionTag, icSigProfileSequenceDescTag, icSigPs2CRD0Tag, icSigPs2CRD1Tag, icSigPs2CRD2Tag, icSigPs2CRD3Tag, icSigPs2CSATag, icSigPs2RenderingIntentTag, icSigRedColorantTag, icSigRedMatrixColumnTag, icSigRedTRCTag, icSigRgbData, icSigScreeningDescTag, icSigScreeningTag, icSigSpace2CLR, icSigSpace3CLR, icSigSpace4CLR, icSigSpace5CLR, icSigSpace6CLR, icSigSpace7CLR, icSigSpace8CLR, icSigSpace9CLR, icSigSpaceACLR, icSigSpaceBCLR, icSigSpaceCCLR, icSigSpaceDCLR, icSigSpaceECLR, icSigSpaceFCLR, icSigTechnologyTag, icSigUcrBgTag, icSigViewingCondDescTag, icSigViewingConditionsTag, icSigXYZData, icSigYCbCrData, icSigYxyData, icTagReserved, icTagType, icXYZNumberX

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      float getGamma​(int component)
      返回表示特定组件的色调再现曲线（TRC）的伽马值。
      float[][] getMatrix​()
      返回一个3x3 float矩阵从X，Y构造和配置文件的Z分量 redColorantTag ， greenColorantTag ，并 blueColorantTag 。
      float[] getMediaWhitePoint​()
      返回一个包含配置文件 mediaWhitePointTag组件的 mediaWhitePointTag 。
      short[] getTRC​(int component)
      将特定组件的TRC作为数组返回。

      • Methods inherited from class java.awt.color.ICC_Profile

        finalize, getColorSpaceType, getData, getData, getInstance, getInstance, getInstance, getInstance, getMajorVersion, getMinorVersion, getNumComponents, getPCSType, getProfileClass, readResolve, setData, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • REDCOMPONENT

        public static final int REDCOMPONENT
        用于获得红色分量的伽马值或TRC。
        另请参见：
        Constant Field Values

      • GREENCOMPONENT

        public static final int GREENCOMPONENT
        用于获取绿色组件的伽马值或TRC。
        另请参见：
        Constant Field Values

      • BLUECOMPONENT

        public static final int BLUECOMPONENT
        用于获取蓝色分量的伽马值或TRC。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getMediaWhitePoint

        public float[] getMediaWhitePoint​()
        返回一个数组，其中包含配置文件的组件 mediaWhitePointTag 。
        结果
        一个包含配置文件 mediaWhitePointTag的x，y和z组件的3元素 float数组。

      • getMatrix

        public float[][] getMatrix​()
        返回一个3x3 float矩阵从X，Y构造和配置文件的Z分量redColorantTag ， greenColorantTag ，并blueColorantTag 。

        该矩阵可用于轮廓的正向颜色变换 - 从轮廓颜色空间到CIEXYZ PCS。

        结果
        的3×3 float阵列包含x，y和配置文件的的z分量 redColorantTag ， greenColorantTag ，和 blueColorantTag 。

      • getGamma

        public float getGamma​(int component)
        返回表示特定组件的色调再现曲线（TRC）的伽马值。 组件参数必须是REDCOMPONENT，GREENCOMPONENT或BLUECOMPONENT之一。

        如果配置文件表示相应组件的TRC作为表而不是单个gamma值，则会抛出异常。 在这种情况下，实际的表可以通过getTRC(int)方法获得。 当使用伽马值时，线性分量（R，G或B）计算如下：

                                                    gamma
          linearComponent = deviceComponent
        参数
        component - 表示要检索其TRC的组件的 ICC_ProfileRGB常量
        结果
        伽马值为浮点数。
        异常
        ProfileDataException - 如果配置文件没有将相应的TRC指定为单个伽玛值。

      • getTRC

        public short[] getTRC​(int component)
        将特定组件的TRC作为数组返回。 组件必须是REDCOMPONENT ， GREENCOMPONENT ，或BLUECOMPONENT 。 否则，返回的数组表示一个查找表，其中输入组件值在概念上在[0.0，1.0]的范围内。 值0.0映射到数组索引0，值1.0映射到数组索引长度-1。 可以使用插值来生成不精确映射到数组中的索引的输入值的输出值。 输出值也线性映射到范围[0.0，1.0]。 值0.0由数组值0x0000和值1.0由0xFFFF表示。 换句话说，即使这些值在short数组中返回，这些值也是无符号的short值。 如果配置文件已将相应的TRC指定为线性（gamma = 1.0）或简单的伽玛值，则此方法会引发异常。 在这种情况下，应使用getGamma(int)方法获取伽玛值。
        参数
        component -该 ICC_ProfileRGB常量，表示要检索其TRC的分量： REDCOMPONENT ， GREENCOMPONENT ，或 BLUECOMPONENT 。
        结果
        代表TRC的短阵列。
        异常
        ProfileDataException - 如果配置文件没有将相应的TRC指定为表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.color (Java SE 9 & JDK 9 )

java.awt.color

Classes

  • ColorSpace
  • ICC_ColorSpace
  • ICC_Profile
  • ICC_ProfileGray
  • ICC_ProfileRGB

Exceptions

  • CMMException
  • ProfileDataException


java.awt.color (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.color

提供颜色空间的类。 它包含基于国际色彩联盟（ICC）配置文件格式规范，版本3.4，1997年8月15日的颜色空间的实现。它还包含基于ICC配置文件格式规范的颜色配置文件。
从以下版本开始：
1.2
  • 类摘要
    Class 描述
    ColorSpace
    该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。
    ICC_ColorSpace
    ICC_ColorSpace类是抽象ColorSpace类的一个实现。
    ICC_Profile
    基于国际色彩联盟规范ICC.1：2001-12，颜色配置文件格式（参见 http://www.color.org ）的设备无关和设备相关色彩空间的颜色配置文件数据的表示。
    ICC_ProfileGray
    ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为TYPE_GRAY，配置文件包含grayTRCTag和mediaWhitePointTag标签。
    ICC_ProfileRGB
    ICC_ProfileRGB类是ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为RGB。 该配置文件包含redColorantTag ， greenColorantTag ， blueColorantTag ， redTRCTag ， greenTRCTag ， blueTRCTag ，并mediaWhitePointTag标签。 当满足这些条件时， ICC_Profile getInstance方法将返回一个ICC_ProfileRGB对象。
  • 异常摘要
    异常 描述
    CMMException
    如果本机CMM返回错误，则抛出此异常。
    ProfileDataException
    在访问或处理ICC_Profile对象时发生错误时抛出此异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.color Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.color

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.color.ColorSpace (implements java.io.Serializable)
      • java.awt.color.ICC_ColorSpace
    • java.awt.color.ICC_Profile (implements java.io.Serializable)
      • java.awt.color.ICC_ProfileGray
      • java.awt.color.ICC_ProfileRGB
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.awt.color.CMMException
          • java.awt.color.ProfileDataException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ProfileDataException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.color

Class ProfileDataException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.awt.color.ProfileDataException
  • All Implemented Interfaces:
    Serializable

    public class ProfileDataException
extends RuntimeException
    在访问或处理ICC_Profile对象时发生错误时抛出此异常。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProfileDataException​(String s)
      构造具有指定详细消息的ProfileDataException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ProfileDataException

        public ProfileDataException​(String s)
        构造具有指定详细消息的ProfileDataException。
        参数
        s - 指定的详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.color (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.color

  • Packages that use java.awt.color
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.image
    提供创建和修改图像的类。
    javax.imageio
    Java Image I / O API的主要包。
  • Classes in java.awt.color used by java.awt
    Class 描述
    ColorSpace
    该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。
  • Classes in java.awt.color used by java.awt.color
    Class 描述
    ColorSpace
    该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。
    ICC_Profile
    基于国际色彩联盟规范ICC.1：2001-12，颜色配置文件格式（参见 http://www.color.org ）的设备无关和设备相关色彩空间的颜色配置文件数据的表示。
  • Classes in java.awt.color used by java.awt.image
    Class 描述
    ColorSpace
    该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。
    ICC_Profile
    基于国际色彩联盟规范ICC.1：2001-12，颜色配置文件的格式（参见 http://www.color.org ），用于独立于设备的设备和色彩空间的颜色配置文件数据的表示。
  • Classes in java.awt.color used by javax.imageio
    Class 描述
    ColorSpace
    该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.color.CMMException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.color.CMMException

No usage of java.awt.color.CMMException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.color.ColorSpace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.color.ColorSpace

  • Packages that use ColorSpace
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.image
    提供创建和修改图像的类。
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of ColorSpace in java.awt

      Methods in java.awt that return ColorSpace
      Modifier and Type 方法 描述
      ColorSpace Color.getColorSpace​()
      返回这个 ColorSpace的 Color 。
      Methods in java.awt with parameters of type ColorSpace
      Modifier and Type 方法 描述
      float[] Color.getColorComponents​(ColorSpace cspace, float[] compArray)
      返回一个 float阵列包含的唯一颜色分量 Color在 ColorSpace由指定 cspace参数。
      float[] Color.getComponents​(ColorSpace cspace, float[] compArray)
      返回一个 float阵列包含的颜色和alpha分量 Color ，在 ColorSpace由指定 cspace参数。
      Constructors in java.awt with parameters of type ColorSpace
      Constructor 描述
      Color​(ColorSpace cspace, float[] components, float alpha)
      在指定的 ColorSpace使用 float数组中指定的颜色组件和指定的alpha创建颜色。

    • Uses of ColorSpace in java.awt.color

      Subclasses of ColorSpace in java.awt.color
      Modifier and Type Class 描述
      class  ICC_ColorSpace
      ICC_ColorSpace类是抽象ColorSpace类的一个实现。
      Methods in java.awt.color that return ColorSpace
      Modifier and Type 方法 描述
      static ColorSpace ColorSpace.getInstance​(int colorspace)
      返回表示特定预定义颜色空间之一的ColorSpace。

    • Uses of ColorSpace in java.awt.image

      Methods in java.awt.image that return ColorSpace
      Modifier and Type 方法 描述
      ColorSpace ColorModel.getColorSpace​()
      返回 ColorSpace与此相关 ColorModel 。
      Constructors in java.awt.image with parameters of type ColorSpace
      Constructor 描述
      ColorConvertOp​(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
      从两个ColorSpace对象构造一个新的ColorConvertOp。
      ColorConvertOp​(ColorSpace cspace, RenderingHints hints)
      从ColorSpace对象构造一个新的ColorConvertOp。
      ColorModel​(int pixel_bits, int[] bits, ColorSpace cspace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
      构造一个 ColorModel ，将像素值转换为颜色/ alpha组件。
      ComponentColorModel​(ColorSpace colorSpace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
      从指定的参数构造一个 ComponentColorModel 。
      ComponentColorModel​(ColorSpace colorSpace, int[] bits, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
      从指定的参数构造一个 ComponentColorModel 。
      DirectColorModel​(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int transferType)
      从指定的参数构造一个 DirectColorModel 。
      PackedColorModel​(ColorSpace space, int bits, int[] colorMaskArray, int alphaMask, boolean isAlphaPremultiplied, int trans, int transferType)
      构造一个 PackedColorModel从一个颜色掩码数组，其中指定 int像素表示中的哪个位包含每个颜色样本和一个alpha掩码。
      PackedColorModel​(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int trans, int transferType)
      从指定的掩码构建一个 PackedColorModel ，指示 int像素表示中的哪个位包含alpha，红，绿和蓝色样本。

    • Uses of ColorSpace in javax.imageio

      Methods in javax.imageio with parameters of type ColorSpace
      Modifier and Type 方法 描述
      static ImageTypeSpecifier ImageTypeSpecifier.createBanded​(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied)
      返回带状图像格式的说明符，该格式将使用 ComponentColorModel和 BandedSampleModel将每个通道存储在单独的阵列中。
      static ImageTypeSpecifier ImageTypeSpecifier.createInterleaved​(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied)
      返回一个用于交错图像格式的说明符，它将使用 ComponentColorModel和 PixelInterleavedSampleModel将每个像素组件存储在单独的字节，短或int中。
      static ImageTypeSpecifier ImageTypeSpecifier.createPacked​(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied)
      返回一个用于打包图像格式的说明符，它将使用 DirectColorModel和打包的 SampleModel来存储单个字节，短或int中打包的每个像素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.color.ICC_ColorSpace (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.color.ICC_ColorSpace

No usage of java.awt.color.ICC_ColorSpace
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.color.ICC_Profile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.color.ICC_Profile

  • Packages that use ICC_Profile
    软件包 描述
    java.awt.color
    提供颜色空间的类。
    java.awt.image
    提供创建和修改图像的类。

    • Uses of ICC_Profile in java.awt.color

      Subclasses of ICC_Profile in java.awt.color
      Modifier and Type Class 描述
      class  ICC_ProfileGray
      ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为TYPE_GRAY，配置文件包含grayTRCTag和mediaWhitePointTag标签。
      class  ICC_ProfileRGB
      ICC_ProfileRGB类是ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为RGB。 该配置文件包含redColorantTag ， greenColorantTag ， blueColorantTag ， redTRCTag ， greenTRCTag ， blueTRCTag ，并mediaWhitePointTag标签。 当满足这些条件时， ICC_Profile getInstance方法将返回一个ICC_ProfileRGB对象。
      Methods in java.awt.color that return ICC_Profile
      Modifier and Type 方法 描述
      static ICC_Profile ICC_Profile.getInstance​(byte[] data)
      构造与字节数组中的数据相对应的ICC_Profile对象。
      static ICC_Profile ICC_Profile.getInstance​(int cspace)
      构造一个对应于由ColorSpace类定义的特定颜色空间之一的ICC_Profile（例如CS_sRGB）。
      static ICC_Profile ICC_Profile.getInstance​(InputStream s)
      构造一个与InputStream中数据对应的ICC_Profile。
      static ICC_Profile ICC_Profile.getInstance​(String fileName)
      构造与文件中数据对应的ICC_Profile。
      ICC_Profile ICC_ColorSpace.getProfile​()
      返回ICC_ColorSpace的ICC_Profile。
      Constructors in java.awt.color with parameters of type ICC_Profile
      Constructor 描述
      ICC_ColorSpace​(ICC_Profile profile)
      从ICC_Profile对象构造一个新的ICC_ColorSpace。

    • Uses of ICC_Profile in java.awt.image

      Methods in java.awt.image that return ICC_Profile
      Modifier and Type 方法 描述
      ICC_Profile[] ColorConvertOp.getICC_Profiles​()
      返回用于构造此ColorConvertOp的ICC_Profiles数组。
      Constructors in java.awt.image with parameters of type ICC_Profile
      Constructor 描述
      ColorConvertOp​(ICC_Profile[] profiles, RenderingHints hints)
      从ICC_Profiles数组构造一个新的ColorConvertOp。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.color.ICC_ProfileGray (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.color.ICC_ProfileGray

No usage of java.awt.color.ICC_ProfileGray
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.color.ICC_ProfileRGB (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.color.ICC_ProfileRGB

No usage of java.awt.color.ICC_ProfileRGB
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.color.ProfileDataException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.color.ProfileDataException

No usage of java.awt.color.ProfileDataException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Clipboard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Class Clipboard

  • java.lang.Object
    • java.awt.datatransfer.Clipboard

  • public class Clipboard
extends Object
    实现使用剪切/复制/粘贴操作传输数据的机制的类。

    FlavorListener可能会在Clipboard类的实例上注册，以通知关于此剪贴板上可用的一组DataFlavor s的更改（请参阅addFlavorListener(java.awt.datatransfer.FlavorListener) ）。

    从以下版本开始：
    1.1
    另请参见：
    Toolkit.getSystemClipboard() ， Toolkit.getSystemSelection()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Transferable contents
      剪贴板的内容。
      protected ClipboardOwner owner
      剪贴板的所有者。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Clipboard​(String name)
      创建剪贴板对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addFlavorListener​(FlavorListener listener)
      注册指定的 FlavorListener从此剪贴板接收 FlavorEvent s。
      DataFlavor[] getAvailableDataFlavors​()
      返回一个 DataFlavor秒的数组，其中可以提供此剪贴板的当前内容。
      Transferable getContents​(Object requestor)
      返回表示剪贴板当前内容的可转移对象。
      Object getData​(DataFlavor flavor)
      在指定的 DataFlavor返回表示此剪贴板当前内容的对象。
      FlavorListener[] getFlavorListeners​()
      返回当前在此 Clipboard上注册的所有 FlavorListener的数组。
      String getName​()
      返回此剪贴板对象的名称。
      boolean isDataFlavorAvailable​(DataFlavor flavor)
      返回是否可以在指定的 DataFlavor提供此剪贴板的当前内容。
      void removeFlavorListener​(FlavorListener listener)
      删除指定的 FlavorListener ，使其不再从此 Clipboard接收 FlavorEvent s。
      void setContents​(Transferable contents, ClipboardOwner owner)
      将剪贴板的当前内容设置为指定的可转移对象，并将指定的剪贴板所有者注册为新内容的所有者。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • owner

        protected ClipboardOwner owner
        剪贴板的所有者。

      • contents

        protected Transferable contents
        剪贴板的内容。

    • 构造方法详细信息

      • Clipboard

        public Clipboard​(String name)
        创建剪贴板对象。
        参数
        name - 为剪贴板
        另请参见：
        Toolkit.getSystemClipboard()

    • 方法详细信息

      • getName

        public String getName​()
        返回此剪贴板对象的名称。
        结果
        该剪贴板对象的名称
        另请参见：
        Toolkit.getSystemClipboard()

      • setContents

        public void setContents​(Transferable contents,
                        ClipboardOwner owner)
        将剪贴板的当前内容设置为指定的可转移对象，并将指定的剪贴板所有者注册为新内容的所有者。

        如果现有拥有者与参数owner不同，则通知该拥有者不再通过调用该拥有者的ClipboardOwner.lostOwnership()来保存剪贴板内容的所有权。 一个setContents()的实现是lostOwnership()直接从这个方法调用lostOwnership() 。 例如，可以稍后在不同的线程上调用lostOwnership() 。 同样适用于在此剪贴板上注册的FlavorListener 。

        如果剪贴板当前不可用，该方法将抛出IllegalStateException 。 例如，在某些平台上，系统剪贴板在被其他应用程序访问时不可用。

        参数
        contents - 表示剪贴板内容的可转移对象
        owner - 拥有剪贴板内容的对象
        异常
        IllegalStateException - 如果剪贴板当前不可用
        另请参见：
        Toolkit.getSystemClipboard()

      • getContents

        public Transferable getContents​(Object requestor)
        返回表示剪贴板当前内容的可转移对象。 如果剪贴板当前没有内容，它将返回null 。 当前未使用参数对象请求者。 如果剪贴板当前不可用，该方法将抛出IllegalStateException 。 例如，在某些平台上，系统剪贴板在被其他应用程序访问时不可用。
        参数
        requestor - 请求剪辑数据的对象（未使用）
        结果
        剪贴板上的当前可转移对象
        异常
        IllegalStateException - 如果剪贴板当前不可用
        另请参见：
        Toolkit.getSystemClipboard()

      • getAvailableDataFlavors

        public DataFlavor[] getAvailableDataFlavors​()
        返回一个DataFlavor s的数组，其中可以提供此剪贴板的当前内容。 如果没有DataFlavor可用，则此方法返回零长度数组。
        结果
        一个 DataFlavor的阵列，其中可以提供此剪贴板的当前内容
        异常
        IllegalStateException - 如果此剪贴板当前不可用
        从以下版本开始：
        1.5

      • isDataFlavorAvailable

        public boolean isDataFlavorAvailable​(DataFlavor flavor)
        返回是否可以在指定的 DataFlavor提供此剪贴板的当前内容。
        参数
        flavor - 请求的 DataFlavor的内容
        结果
        true如果此剪贴板的当前内容可以在指定的DataFlavor ; 否则为false
        异常
        NullPointerException - 如果 flavor是 null
        IllegalStateException - 如果此剪贴板当前不可用
        从以下版本开始：
        1.5

      • getData

        public Object getData​(DataFlavor flavor)
               throws UnsupportedFlavorException,
                      IOException
        在指定的DataFlavor返回表示此剪贴板当前内容的对象。 返回的对象的类由flavor的表示类定义。
        参数
        flavor - 要求的 DataFlavor的内容
        结果
        表示该指定的 DataFlavor中此剪贴板的当前内容的对象
        异常
        NullPointerException - 如果 flavor是 null
        IllegalStateException - 如果此剪贴板当前不可用
        UnsupportedFlavorException - 如果请求的 DataFlavor不可用
        IOException - 如果无法检索请求的 DataFlavor的数据
        从以下版本开始：
        1.5
        另请参见：
        DataFlavor.getRepresentationClass()

      • addFlavorListener

        public void addFlavorListener​(FlavorListener listener)
        注册指定的FlavorListener以从此剪贴板接收FlavorEvent s。 如果listener为null ，则不会抛出任何异常，也不会执行任何操作。
        参数
        listener - 要添加的侦听器
        从以下版本开始：
        1.5
        另请参见：
        removeFlavorListener(java.awt.datatransfer.FlavorListener) ， getFlavorListeners() ， FlavorListener ， FlavorEvent

      • removeFlavorListener

        public void removeFlavorListener​(FlavorListener listener)
        删除指定的FlavorListener ，使其不再从此Clipboard接收FlavorEvent s。 如果由参数指定的侦听器以前未添加到此Clipboard ，则此方法不执行任何功能，也不会抛出异常。 如果listener为null ，则不会抛出异常，也不会执行任何操作。
        参数
        listener - 要删除的侦听器
        从以下版本开始：
        1.5
        另请参见：
        addFlavorListener(java.awt.datatransfer.FlavorListener) ， getFlavorListeners() ， FlavorListener ， FlavorEvent

      • getFlavorListeners

        public FlavorListener[] getFlavorListeners​()
        返回当前在该 Clipboard上注册的所有 FlavorListener的数组。
        结果
        所有这个剪贴板的 FlavorListener s或一个空数组，如果没有监听器当前注册
        从以下版本开始：
        1.5
        另请参见：
        addFlavorListener(java.awt.datatransfer.FlavorListener) ， removeFlavorListener(java.awt.datatransfer.FlavorListener) ， FlavorListener ， FlavorEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClipboardOwner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Interface ClipboardOwner

  • 所有已知实现类：
    StringSelection

    public interface ClipboardOwner
    定义将向剪贴板提供数据的类的接口。 此接口的实例成为一个剪贴板（剪贴板所有者），如果它被作为一个参数传递给中的内容所有者Clipboard.setContents(java.awt.datatransfer.Transferable, java.awt.datatransfer.ClipboardOwner)剪贴板的方法，并且此方法成功返回。 实例保留剪贴板所有者，直到另一个应用程序或此应用程序内的另一个对象声明此剪贴板的所有权。
    从以下版本开始：
    1.1
    另请参见：
    Clipboard

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void lostOwnership​(Clipboard clipboard, Transferable contents)
      通知此对象不再是剪贴板所有者。

    • 方法详细信息

      • lostOwnership

        void lostOwnership​(Clipboard clipboard,
                   Transferable contents)
        通知此对象不再是剪贴板所有者。 当该应用程序中的另一个应用程序或另一个对象断言剪贴板的所有权时，将调用此方法。
        参数
        clipboard - 不再拥有的剪贴板
        contents - 该业主放在 clipboard
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataFlavor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Class DataFlavor

  • java.lang.Object
    • java.awt.datatransfer.DataFlavor
  • All Implemented Interfaces:
    Externalizable ， Serializable ， Cloneable
    已知直接子类：
    ActivationDataFlavor

    public class DataFlavor
extends Object
implements Externalizable, Cloneable
    A DataFlavor提供有关数据的元信息。 DataFlavor通常用于访问剪贴板上的数据，或者在拖放操作期间。

    DataFlavor的实例封装了RFC 2045和RFC 2046中定义的内容类型。 内容类型通常称为MIME类型。

    内容类型由媒体类型（称为主类型），子类型和可选参数组成。 有关MIME类型的语法的详细信息，请参阅RFC 2045 。

    JRE数据传输实现将MIME类型的参数“类”解释为表示类 。 表示类反映正在传输的对象的类。 换句话说，表示类是由Transferable.getTransferData(java.awt.datatransfer.DataFlavor)返回的对象的类型。 例如， imageFlavor的MIME类型为"image/x-java-image;class=java.awt.Image" ，主要类型为image ，子类型为x-java-image ，表示类为java.awt.Image 。 当getTransferData与调用DataFlavor的imageFlavor ，实例java.awt.Image返回。 重要的是要注意， DataFlavor没有对代表类进行错误检查。 由DataFlavor消费者，如Transferable ，以兑现代表班。
    请注意，如果在创建DataFlavor时未指定表示类，则使用默认表示类。 请参阅DataFlavor的构造函数的相应文档。

    此外，具有“文本”主MIME类型的DataFlavor实例可能具有“charset”参数。 有关“文本”MIME类型和“charset”参数的详细信息，请参阅RFC 2046和selectBestTextFlavor(java.awt.datatransfer.DataFlavor[]) 。

    DataFlavors平等由主要类型，子类型和表示类决定。 详见equals(DataFlavor) 。 当确定相等时，任何可选参数都将被忽略。 例如，以下产生两个被认为是相同的DataFlavors ：

      DataFlavor flavor1 = new DataFlavor(Object.class, "X-test/test; class=<java.lang.Object>; foo=bar");
   DataFlavor flavor2 = new DataFlavor(Object.class, "X-test/test; class=<java.lang.Object>; x=y");
   // The following returns true.
   flavor1.equals(flavor2);
    如上所述， flavor1和flavor2被认为是相同的。 因此，要求Transferable为DataFlavor返回相同的结果。

    有关使用Swing进行数据传输的更多信息，请参阅Java教程中的How to Use Drag and Drop and Data Transfer部分。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static DataFlavor allHtmlFlavor
      代表一个HTML标记。
      static DataFlavor fragmentHtmlFlavor
      代表一个HTML标记。
      static DataFlavor imageFlavor
      DataFlavor代表Java Image类，其中：
      static DataFlavor javaFileListFlavor
      要将文件列表从Java（和底层平台） DataFlavor到一个 DataFlavor的这种类型/子类型和表示类别为 java.util.List 。
      static String javaJVMLocalObjectMimeType
      要将引用传递给不具有关联MIME内容类型的任意Java对象引用，通过在同一JVM中的 Transferable接口，将 DataFlavor具有此类型/子类型的 representationClass ，其中 representationClass等于类/接口的类型正在通过 Transferable 。
      static String javaRemoteObjectMimeType
      为了通过拖放 ACTION_LINK操作将实时链接传递给远程对象， ACTION_LINK使用Mime Content应用程序类型/ x-java-remote-object，其中 DataFlavor的表示类表示 Remote接口的类型被转移。
      static String javaSerializedObjectMimeType
      MIME内容 - 应用程序类型/ x-java-serialized-object表示已被持久化的Java对象的图形。
      static DataFlavor plainTextFlavor
      已过时。
      截至1.3。 使用getReaderForText(java.awt.datatransfer.Transferable)而不是Transferable.getTransferData(DataFlavor.plainTextFlavor) 。
      static DataFlavor selectionHtmlFlavor
      代表一个HTML标记。
      static DataFlavor stringFlavor
      DataFlavor代表Java Unicode String类，其中：

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataFlavor​()
      构造新的 DataFlavor 。
      DataFlavor​(Class<?> representationClass, String humanPresentableName)
      构造一个表示Java类的 DataFlavor 。
      DataFlavor​(String mimeType)
      从一个 mimeType字符串构造一个 DataFlavor 。
      DataFlavor​(String mimeType, String humanPresentableName)
      构造一个 DataFlavor ，代表一个 MimeType 。
      DataFlavor​(String mimeType, String humanPresentableName, ClassLoader classLoader)
      构造一个 DataFlavor ，代表一个 MimeType 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回此 DataFlavor的克隆。
      boolean equals​(DataFlavor that)
      此方法与 equals(Object)具有相同的行为。
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      boolean equals​(String s)
      已过时。
      与hashCode()合同不一致，请改用isMimeTypeEqual(String) 。
      Class<?> getDefaultRepresentationClass​()
      返回默认表示类。
      String getDefaultRepresentationClassAsString​()
      返回默认表示类的名称。
      String getHumanPresentableName​()
      返回 DataFlavor表示的数据格式的人性化名称。
      String getMimeType​()
      返回此 DataFlavor的MIME类型字符串。
      String getParameter​(String paramName)
      如果 paramName等于“humanPresentableName”，则返回此 DataFlavor的人性化名称。
      String getPrimaryType​()
      返回此 DataFlavor的主MIME类型。
      Reader getReaderForText​(Transferable transferable)
      获取一个文本风味的阅读器，如有必要，解码为预期的字符集（编码）。
      Class<?> getRepresentationClass​()
      返回 Class其对象支持此 DataFlavor时，这将返回 DataFlavor请求。
      String getSubType​()
      返回此 DataFlavor的子MIME类型。
      static DataFlavor getTextPlainUnicodeFlavor​()
      返回一个 DataFlavor代表纯文本与Unicode编码，其中：
      int hashCode​()
      返回这个 DataFlavor哈希码。
      boolean isFlavorJavaFileListType​()
      如果指定的 DataFlavor表示文件对象的列表，则返回 true 。
      boolean isFlavorRemoteObjectType​()
      如果指定的 DataFlavor表示远程对象，则返回 true 。
      boolean isFlavorSerializedObjectType​()
      如果指定的 DataFlavor表示序列化对象，则返回 true 。
      boolean isFlavorTextType​()
      返回这个 DataFlavor是否是Java平台实现的有效文本风格。
      boolean isMimeTypeEqual​(DataFlavor dataFlavor)
      比较 mimeType的 DataFlavor对象。
      boolean isMimeTypeEqual​(String mimeType)
      返回传入的MIME类型的字符串表示是否等同于此 DataFlavor的MIME类型。
      boolean isMimeTypeSerializedObject​()
      DataFlavor是否代表序列化对象？
      boolean isRepresentationClassByteBuffer​()
      返回此 DataFlavor的表示类是 java.nio.ByteBuffer还是其子类。
      boolean isRepresentationClassCharBuffer​()
      返回这个 DataFlavor的表示类是 java.nio.CharBuffer还是其子类。
      boolean isRepresentationClassInputStream​()
      DataFlavor是否代表 java.io.InputStream ？
      boolean isRepresentationClassReader​()
      返回此 DataFlavor的表示类是 java.io.Reader还是其子类。
      boolean isRepresentationClassRemote​()
      返回 true如果表示形式类为 Remote 。
      boolean isRepresentationClassSerializable​()
      如果表示类可以序列化，则返回 true 。
      boolean match​(DataFlavor that)
      与 equals(DataFlavor)相同。
      protected String normalizeMimeType​(String mimeType)
      已过时。
      此方法从1.1开始就不会被此实现所调用
      protected String normalizeMimeTypeParameter​(String parameterName, String parameterValue)
      已过时。
      此方法从1.1开始就不会被此实现所调用
      void readExternal​(ObjectInput is)
      从序列化状态恢复此 DataFlavor 。
      static DataFlavor selectBestTextFlavor​(DataFlavor[] availableFlavors)
      选择最好的文本 DataFlavor从数组 DataFlavor秒。
      void setHumanPresentableName​(String humanPresentableName)
      为 DataFlavor表示的数据格式设置人类可呈现的名称。
      String toString​()
      这个 DataFlavor字符串表示及其参数。
      protected static Class<?> tryToLoadClass​(String className, ClassLoader fallback)
      尝试加载一个类：引导加载程序，系统加载程序，上下文加载程序（如果存在），最后指定加载程序。
      void writeExternal​(ObjectOutput os)
      序列化这个 DataFlavor 。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • stringFlavor

        public static final DataFlavor stringFlavor
        代表Java Unicode String类的DataFlavor ，其中：
          representationClass = java.lang.String
     mimeType            = "application/x-java-serialized-object"

      • imageFlavor

        public static final DataFlavor imageFlavor
        表示Java Image类的DataFlavor ，其中：
          representationClass = java.awt.Image
     mimeType            = "image/x-java-image"
        将null如果java.awt.Image不可见， java.desktop模块未加载，或java.desktop模块不在运行时映像中。

      • plainTextFlavor

        @Deprecated
public static final DataFlavor plainTextFlavor
        已过时。 截至1.3。 使用getReaderForText(java.awt.datatransfer.Transferable)而不是Transferable.getTransferData(DataFlavor.plainTextFlavor) 。
        DataFlavor用Unicode编码表示纯文本，其中：
          representationClass = InputStream
     mimeType            = "text/plain; charset=unicode"
        这个DataFlavor已被弃用，因为：
        • 它的表示是一个InputStream，一个8位的表示，而Unicode是一个16位的字符集
        • 字符集“unicode”没有明确定义。 “unicode”意味着特定平台的Unicode实现，而不是跨平台的实现

      • javaSerializedObjectMimeType

        public static final String javaSerializedObjectMimeType
        MIME内容 - 应用程序类型/ x-java-serialized-object表示已被持久化的Java对象的图形。

        与此DataFlavor关联的表示类识别从调用返回的对象的Java类型java.awt.datatransfer.getTransferData 。

        另请参见：
        Constant Field Values

      • javaFileListFlavor

        public static final DataFlavor javaFileListFlavor
        要将文件列表从Java（和底层平台） DataFlavor到一个DataFlavor的这种类型/子类型和表示类别为java.util.List 。 列表中的每个元素都需要/保证为java.io.File类型。

      • javaJVMLocalObjectMimeType

        public static final String javaJVMLocalObjectMimeType
        要将引用传递给具有相关联的MIME内容类型的任意Java对象引用，通过在同一个JVM中的Transferable接口，将DataFlavor具有此类型/子类型的representationClass ，其中representationClass等于类/接口的类型正在通过Transferable 。

        从Transferable.getTransferData返回的对于具有此MIME Content-Type的DataFlavor的对象引用Transferable.getTransferData是DataFlavor的表示类的DataFlavor 。

        另请参见：
        Constant Field Values

      • javaRemoteObjectMimeType

        public static final String javaRemoteObjectMimeType
        为了通过拖放 ACTION_LINK操作将实时链接传递给远程对象， ACTION_LINK使用Mime Content应用程序类型/ x-java-remote-object，其中 DataFlavor的表示类表示 Remote接口的类型被转移。
        另请参见：
        Constant Field Values

      • selectionHtmlFlavor

        public static DataFlavor selectionHtmlFlavor
        代表一个HTML标记。 标记由源侧选择的部分组成。 因此，标记中的某些标签可能不成对。 如果风味用于表示Transferable实例中的数据，则不会进行任何其他更改。 该DataFlavor实例表示与DataFlavor实例相同的HTML标记，内容MIME类型不包含文档参数，表示类是String类。
          representationClass = String
     mimeType            = "text/html"
        从以下版本开始：
        1.8

      • fragmentHtmlFlavor

        public static DataFlavor fragmentHtmlFlavor
        代表一个HTML标记。 如果可能，从本地系统接收到的标记用对标签补充为格式良好的HTML标记。 如果风味用于表示Transferable实例中的数据，则不会进行任何其他更改。
          representationClass = String
     mimeType            = "text/html"
        从以下版本开始：
        1.8

      • allHtmlFlavor

        public static DataFlavor allHtmlFlavor
        代表一个HTML标记。 如果可能，从本机系统接收的标记补充有附加标签，以组成一个格式良好的HTML文档。 如果风味用于表示Transferable实例中的数据，则不会进行其他更改。
          representationClass = String
     mimeType            = "text/html"
        从以下版本开始：
        1.8

    • 构造方法详细信息

      • DataFlavor

        public DataFlavor​()
        构造新的DataFlavor 。 此构造函数仅用于支持Externalizable接口。 它不适用于公共（客户端）使用。
        从以下版本开始：
        1.2

      • DataFlavor

        public DataFlavor​(Class<?> representationClass,
                  String humanPresentableName)
        构造一个表示Java类的DataFlavor 。

        返回的DataFlavor将具有以下特点：

          representationClass = representationClass
    mimeType            = application/x-java-serialized-object
        参数
        representationClass - 用于传输这种风味的数据的类
        humanPresentableName - 用于识别这种风味的人类可读字符串; 如果此参数为null则使用MIME内容类型的值
        异常
        NullPointerException - 如果 representationClass是 null

      • DataFlavor

        public DataFlavor​(String mimeType,
                  String humanPresentableName)
        构造一个DataFlavor代表一个MimeType 。

        返回的DataFlavor将具有以下特点：

        如果mimeType是“application / x-java-serialized-object; class = <representation class>”，结果与调用new DataFlavor(Class.forName(<representation class>)相同。

        除此以外：

          representationClass = InputStream
     mimeType            = mimeType
        参数
        mimeType - 用于识别此风味的MIME类型的字符串; 如果mimeType没有指定“class =”参数，或者类未成功加载，则抛出一个IllegalArgumentException
        humanPresentableName - 用于识别这种风味的人类可读字符串; 如果此参数为null则使用MIME内容类型的值
        异常
        IllegalArgumentException - 如果 mimeType无效或类未成功加载
        NullPointerException - 如果 mimeType是 null

      • DataFlavor

        public DataFlavor​(String mimeType,
                  String humanPresentableName,
                  ClassLoader classLoader)
           throws ClassNotFoundException
        构造一个DataFlavor ，代表一个MimeType 。

        返回的DataFlavor将具有以下特点：

        如果mimeType是“application / x-java-serialized-object; class = <representation class>”，结果与调用new DataFlavor(Class.forName(<representation class>)相同。

        除此以外：

          representationClass = InputStream
     mimeType            = mimeType
        参数
        mimeType - 用于标识此风味的MIME类型的字符串
        humanPresentableName - 用于识别这种风味的人类可读字符串
        classLoader - 要使用的类加载器
        异常
        ClassNotFoundException - 如果该类没有加载
        IllegalArgumentException - 如果 mimeType无效
        NullPointerException - 如果 mimeType是 null

      • DataFlavor

        public DataFlavor​(String mimeType)
           throws ClassNotFoundException
        从一个mimeType字符串构造一个DataFlavor 。 该字符串可以指定一个“class = <完全指定的Java类名>>参数以创建具有所需代表类的DataFlavor 。 如果字符串不包含“class =”参数，则默认使用java.io.InputStream 。
        参数
        mimeType - 用于识别此风味的MIME类型的字符串; 如果“class =”参数指定的类未成功加载，则抛出ClassNotFoundException
        异常
        ClassNotFoundException - 如果该类没有加载
        IllegalArgumentException - 如果 mimeType无效
        NullPointerException - 如果 mimeType是 null

    • 方法详细信息

      • tryToLoadClass

        protected static final Class<?> tryToLoadClass​(String className,
                                               ClassLoader fallback)
                                        throws ClassNotFoundException
        尝试加载一个类：引导加载程序，系统加载程序，上下文加载程序（如果存在），最后指定加载程序。
        参数
        className - 要加载的类的名称
        fallback - 后备装载机
        结果
        上课了
        异常
        ClassNotFoundException - 如果没有找到类

      • toString

        public String toString​()
        这个DataFlavor字符串表示及其参数。 所得到的String包含DataFlavor类的名称，这种风格的MIME类型及其表示类。 如果这种风格的主要MIME类型为“text”，则支持charset参数，并且具有编码表示形式，还包括flavor的字符集。 有关支持charset参数的文本风格列表，请参阅selectBestTextFlavor 。
        重写：
        toString在 Object
        结果
        字符串表示的这个 DataFlavor
        另请参见：
        selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

      • getTextPlainUnicodeFlavor

        public static final DataFlavor getTextPlainUnicodeFlavor​()
        返回一个DataFlavor代表Unicode编码的纯文本，其中：
          representationClass = java.io.InputStream
     mimeType            = "text/plain;
                            charset=<platform default Unicode encoding>"
        Implementation Note:
        Oracle对Microsoft Windows和macOS的实现使用编码utf-16le 。 Oracle对Solaris和Linux的实现使用编码iso-10646-ucs-2 。
        结果
        一个 DataFlavor用Unicode编码表示纯文本
        从以下版本开始：
        1.3

      • selectBestTextFlavor

        public static final DataFlavor selectBestTextFlavor​(DataFlavor[] availableFlavors)
        选择最好的文本DataFlavor从数组DataFlavor秒。 只有DataFlavor.stringFlavor ，以及等效的口味和主要MIME类型为“text”的口味被考虑用于选择。

        风味首先按照以下顺序按其MIME类型排序：

        • “文/ SGML”
        • “文/ XML”
        • “text / html的”
        • “文/ RTF”
        • “文/富”
        • “文/富文本”
        • “文/ URI列表”
        • “文本/标签分隔值”
        • “文/ T140”
        • “文/ RFC822报头”
        • “文/ parityfec”
        • “文/目录”
        • “文/ CSS”
        • “文本/日历”
        • “应用程序/ x-java的序列化对象”
        • “text / plain的”
        • “文本/ <其它>”

        例如，“text / sgml”将通过“text / html”进行选择，而DataFlavor.stringFlavor将被选择超过DataFlavor.plainTextFlavor 。

        如果两个或更多个口味在数组中共享最好的MIME类型，那么将检查该MIME类型，以查看它是否支持charset参数。

        以下MIME类型支持或被视为支持charset参数：

        • “文/ SGML”
        • “文/ XML”
        • “text / html的”
        • “文/富”
        • “文/富文本”
        • “文/ URI列表”
        • “文/目录”
        • “文/ CSS”
        • “文本/日历”
        • “应用程序/ x-java的序列化对象”
        • “text / plain的”
        以下MIME类型不支持或被视为不支持charset参数：
        • “文/ RTF”
        • “文本/标签分隔值”
        • “文/ T140”
        • “文/ RFC822报头”
        • “文/ parityfec”
        对于“text / <other>”MIME类型，JRE首次需要确定MIME类型是否支持charset参数，它将检查该参数是否在使用该MIME类型的任意选择的DataFlavor明确列出。 如果是这样，JRE将从该点假设MIME类型支持charset参数，并且不会再次检查。 如果没有明确列出参数，JRE将从该点假设MIME类型不支持charset参数，并且不会再次检查。 由于此检查是在任意选择的DataFlavor执行的，所以开发者必须确保所有具有“text / <other>”MIME类型的所有DataFlavor都指定了该MIME类型支持的charset参数。 开发人员不应该依赖JRE将平台的默认字符集替换为“text / <other>”DataFlavor。 不遵守这一限制将导致未定义的行为。

        如果阵列中的最佳MIME类型不支持charset参数，则共享MIME类型的flavor然后可通过它们的表示的类以下面的顺序进行排序： java.io.InputStream ， java.nio.ByteBuffer ， [B ，<所有其他>。

        如果两种或更多种口味共享最佳代表类，或者如果没有风味具有三种指定表示之一，那么这些口味之一将被非确定性地选择。

        如果阵列中的最佳MIME类型不支持charset参数，则共享MIME类型的flavor然后可通过它们的表示的类以下面的顺序进行排序： java.io.Reader ， java.lang.String ， java.nio.CharBuffer ， [C ，<所有其他>。

        如果两个或更多个口味分享最好的代表类，并且该表示是明确列出的四个之一，那么这些口味之一将被非确定性地选择。 然而，如果没有风味有四个指定的表示之一，那么风味将被它们的字符集排序。 Unicode字符集，如“UTF-16”，“UTF-8”，“UTF-16BE”，“UTF-16LE”及其别名被认为是最佳的。 之后，选择平台默认字符集及其别名。 “US-ASCII”及其别名最差。 所有其他字符集都按字母顺序进行选择，但仅考虑Java平台实施支持的字符集。

        如果两个或多个flavor共享最佳的charset，则flavor再次按照其表示形式类排序，顺序如下： java.io.InputStream ， java.nio.ByteBuffer ， [B ，<所有其他>。

        如果两种或更多种口味共享最佳代表类，或者如果没有风味具有三种指定表示之一，那么这些口味之一将被非确定性地选择。

        参数
        availableFlavors - 一个可用的数组 DataFlavor s
        结果
        根据上述规定，最佳（最高保真度）风味，或 null ，如果 availableFlavors为 null ，具有零长度，或不含文字口味
        从以下版本开始：
        1.3

      • getReaderForText

        public Reader getReaderForText​(Transferable transferable)
                        throws UnsupportedFlavorException,
                               IOException
        获取一个文本风味的阅读器，如有必要，解码为预期的字符集（编码）。 支持的表示形式类是java.io.Reader ， java.lang.String ， java.nio.CharBuffer ， [C ， java.io.InputStream ， java.nio.ByteBuffer ，并[B 。

        由于不支持charset参数的文本风格以非标准格式编码，因此不应该调用此方法。 然而，为了保持向后兼容性，如果这种方法被称为这样的风格，那么这种方法将会将风格视为支持charset参数并尝试相应地进行解码。 有关不支持charset参数的文本风格列表，请参阅selectBestTextFlavor 。

        参数
        transferable - Transferable的数据将被要求在这种风格
        结果
        一个 Reader读取 Transferable的数据
        异常
        IllegalArgumentException - 如果代表类不是上面列出的七个之一
        IllegalArgumentException - 如果 Transferable有 null数据
        NullPointerException - 如果 Transferable是 null
        UnsupportedEncodingException -如果此flavor的表示形式为 java.io.InputStream ， java.nio.ByteBuffer ，或 [B这个flavor的编码不能由此实现Java平台的支持
        UnsupportedFlavorException - 如果 Transferable不支持这种风味
        IOException - 如果由于I / O错误而无法读取数据
        从以下版本开始：
        1.3
        另请参见：
        selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

      • getMimeType

        public String getMimeType​()
        返回此 DataFlavor的MIME类型字符串。
        结果
        这种风味的MIME类型字符串

      • getRepresentationClass

        public Class<?> getRepresentationClass​()
        返回 Class其对象支持此 DataFlavor时，这将返回 DataFlavor请求。
        结果
        在 Class其对象支持此 DataFlavor时，这将返回 DataFlavor请求

      • getHumanPresentableName

        public String getHumanPresentableName​()
        返回DataFlavor表示的数据格式的人性化名称。 该名称将针对不同的国家进行本地化。
        结果
        该 DataFlavor代表的数据格式的人性化名称

      • getPrimaryType

        public String getPrimaryType​()
        返回此 DataFlavor的主MIME类型。
        结果
        这是 DataFlavor的主要MIME类型

      • getSubType

        public String getSubType​()
        返回此 DataFlavor的子MIME类型。
        结果
        该MIME类型为 DataFlavor

      • getParameter

        public String getParameter​(String paramName)
        如果paramName等于“humanPresentableName”，则返回此DataFlavor的人性化名称。 否则返回与paramName相关联的MIME类型值。
        参数
        paramName - 请求的参数名称
        结果
        name参数的值，如果没有关联值， null

      • setHumanPresentableName

        public void setHumanPresentableName​(String humanPresentableName)
        设置DataFlavor表示的数据格式的人性化名称。 该名称将针对不同的国家进行本地化。
        参数
        humanPresentableName - 新的人性化的名字

      • equals

        public boolean equals​(Object o)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 一致 ：对于任何非空参考值x和y ，多个调用x.equals(y)一致返回true或一致返回false ，只要在equals对对象进行比较的信息进行修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        DataFlavor类的等价比较实现如下：当且仅当MIME主类型和子类型和表示类相等时，两个DataFlavor被认为是相等的。 此外，如果主类型是“文本”，子类型表示文本flavor支持charset参数，和表示类不是java.io.Reader ， java.lang.String ， java.nio.CharBuffer ，或[C ，所述charset参数也必须是相等的。 如果未对DataFlavor的一个或两个显式指定字符集，则假定平台默认编码。 有关支持charset参数的文本风格列表，请参阅selectBestTextFlavor 。

        重写：
        equals在 Object
        参数
        o - Object与 this进行比较
        结果
        true如果that相当于这个DataFlavor ; 否则为false
        另请参见：
        selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

      • equals

        public boolean equals​(DataFlavor that)
        此方法与equals(Object)具有相同的行为。 唯一的区别是它需要DataFlavor实例作为参数。
        参数
        that - DataFlavor与 this进行比较
        结果
        true如果that相当于这个DataFlavor ; 否则为false
        另请参见：
        selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

      • equals

        @Deprecated
public boolean equals​(String s)
        已过时。 与hashCode()合同不一致，请改用isMimeTypeEqual(String) 。
        只比较mimeType对String和representationClass的通过，在比较中没有考虑。 如果representationClass要比较的需求，然后equals(new DataFlavor(s))可以使用。
        参数
        s - mimeType进行比较
        结果
        如果String（MimeType）相等， true ; false否则或如果s是null

      • hashCode

        public int hashCode​()
        返回这个DataFlavor哈希码。 对于两个相等的DataFlavor s，哈希码是相等的。 为String匹配DataFlavor.equals(String) ，它不能保证DataFlavor的哈希码等于的哈希码String 。
        重写：
        hashCode在 Object
        结果
        这个 DataFlavor的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • match

        public boolean match​(DataFlavor that)
        与 equals(DataFlavor)相同。
        参数
        that - DataFlavor与 this进行比较
        结果
        true如果that相当于这个DataFlavor ; 否则为false
        从以下版本开始：
        1.3
        另请参见：
        selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

      • isMimeTypeEqual

        public boolean isMimeTypeEqual​(String mimeType)
        返回传入的MIME类型的字符串表示是否等同于此DataFlavor的MIME类型。 参数不包括在比较中。
        参数
        mimeType - MIME类型的字符串表示形式
        结果
        true如果传入的MIME类型的字符串表示相当于此DataFlavor的MIME类型; 否则为false
        异常
        NullPointerException - 如果mimeType是 null

      • isMimeTypeEqual

        public final boolean isMimeTypeEqual​(DataFlavor dataFlavor)
        比较mimeType的DataFlavor对象。 没有考虑参数。
        参数
        dataFlavor - 要比较的 DataFlavor
        结果
        true如果 MimeType相同，否则为 false

      • isMimeTypeSerializedObject

        public boolean isMimeTypeSerializedObject​()
        DataFlavor是否代表序列化对象？
        结果
        是否表示序列化对象

      • getDefaultRepresentationClass

        public final Class<?> getDefaultRepresentationClass​()
        返回默认表示类。
        结果
        默认表示类

      • getDefaultRepresentationClassAsString

        public final String getDefaultRepresentationClassAsString​()
        返回默认表示类的名称。
        结果
        默认表示类的名称

      • isRepresentationClassInputStream

        public boolean isRepresentationClassInputStream​()
        DataFlavor是否代表 java.io.InputStream ？
        结果
        这个 DataFlavor是否代表 java.io.InputStream

      • isRepresentationClassReader

        public boolean isRepresentationClassReader​()
        返回此 DataFlavor的表示类是 java.io.Reader还是其子类。
        结果
        该 DataFlavor的表示类是否为 java.io.Reader或其子类
        从以下版本开始：
        1.4

      • isRepresentationClassCharBuffer

        public boolean isRepresentationClassCharBuffer​()
        返回此 DataFlavor的表示类是 java.nio.CharBuffer还是其子类。
        结果
        该 DataFlavor的表示类是否为 java.nio.CharBuffer或其子类
        从以下版本开始：
        1.4

      • isRepresentationClassByteBuffer

        public boolean isRepresentationClassByteBuffer​()
        返回这个 DataFlavor的表示类是 java.nio.ByteBuffer还是其子类。
        结果
        该 DataFlavor的表示类是否为 java.nio.ByteBuffer或其子类
        从以下版本开始：
        1.4

      • isRepresentationClassSerializable

        public boolean isRepresentationClassSerializable​()
        如果代表类可以序列化，则返回 true 。
        结果
        true如果表示类可以序列化

      • isRepresentationClassRemote

        public boolean isRepresentationClassRemote​()
        返回 true如果表示形式类为 Remote 。
        结果
        true如果表示类是 Remote

      • isFlavorSerializedObjectType

        public boolean isFlavorSerializedObjectType​()
        如果指定的 DataFlavor表示序列化对象，则返回 true 。
        结果
        true如果指定的 DataFlavor表示序列化对象

      • isFlavorRemoteObjectType

        public boolean isFlavorRemoteObjectType​()
        如果指定的 DataFlavor表示远程对象，则返回 true 。
        结果
        true如果指定的 DataFlavor表示远程对象

      • isFlavorJavaFileListType

        public boolean isFlavorJavaFileListType​()
        如果指定的 DataFlavor表示文件对象的列表，则返回 true 。
        结果
        true如果 DataFlavor指定表示 java.util.List的 java.io.File对象

      • isFlavorTextType

        public boolean isFlavorTextType​()
        返回这个DataFlavor是否是Java平台实现的有效文本风格。 只有等同于DataFlavor.stringFlavor和DataFlavor的主要MIME类型为“text”的口味可以是有效的文本风格。

        如果此flavor支持charset参数，它必须等于DataFlavor.stringFlavor ，或其代表必须是java.io.Reader ， java.lang.String ， java.nio.CharBuffer ， [C ， java.io.InputStream ， java.nio.ByteBuffer ，或[B 。 如果表示是java.io.InputStream ， java.nio.ByteBuffer ，或[B ，那么这个味道的charset参数必须通过此实现Java平台的支持。 如果未指定字符集，则会始终支持始终支持的平台默认字符集。

        如果此flavor不支持charset参数，其形式必须是java.io.InputStream ， java.nio.ByteBuffer ，或[B 。

        有关支持charset参数的文本风格列表，请参阅selectBestTextFlavor 。

        结果
        true如果这个DataFlavor是如上所述的有效的文字风味; 否则为false
        从以下版本开始：
        1.4
        另请参见：
        selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

      • writeExternal

        public void writeExternal​(ObjectOutput os)
                   throws IOException
        序列化这个 DataFlavor 。
        Specified by:
        writeExternal在接口 Externalizable
        参数
        os - 将对象写入的流
        异常
        IOException - 包括可能发生的任何I / O异常

      • readExternal

        public void readExternal​(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
        从序列化状态恢复此 DataFlavor 。
        Specified by:
        readExternal在接口 Externalizable
        参数
        is - 为了恢复对象，读取数据的流
        异常
        IOException - 如果发生I / O错误
        ClassNotFoundException - 如果找不到正在恢复的对象的类。

      • clone

        public Object clone​()
             throws CloneNotSupportedException
        返回此 DataFlavor的克隆。
        重写：
        clone在 Object
        结果
        这个克隆的这个 DataFlavor
        异常
        CloneNotSupportedException - 如果对象的类不支持Cloneable接口。 覆盖clone方法的子类也可以引发此异常以指示实例无法克隆。
        另请参见：
        Cloneable

      • normalizeMimeTypeParameter

        @Deprecated
protected String normalizeMimeTypeParameter​(String parameterName,
                                            String parameterValue)
        已过时。 此方法从1.1开始就不会被此实现所调用
        针对每个MIME类型参数调用DataFlavor ，以允许DataFlavor子类处理特殊参数，如text / plain charset参数，其值不区分大小写。 （MIME类型参数值应该区分大小写。

        每个参数名称/值对都调用此方法，并返回parameterValue的归一化表示。

        参数
        parameterName - 参数名称
        parameterValue - 参数值
        结果
        参数值

      • normalizeMimeType

        @Deprecated
protected String normalizeMimeType​(String mimeType)
        已过时。 此方法从1.1开始就不会被此实现所调用
        调用每个MIME类型的字符串，给予DataFlavor子类型改变MIME类型规范化如何完成的机会。 一种可能的用途是在传入的MIME类型字符串中不存在的情况下添加默认参数/值对。
        参数
        mimeType - mime类型
        结果
        mime类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FlavorEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Class FlavorEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.datatransfer.FlavorEvent
  • All Implemented Interfaces:
    Serializable

    public class FlavorEvent
extends EventObject
    FlavorEvent用于通知有关方面270468398802253 （事件源）中有可用的DataFlavor已更改。
    从以下版本开始：
    1.5
    另请参见：
    FlavorListener ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      FlavorEvent​(Clipboard source)
      构造一个 FlavorEvent对象。

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FlavorEvent

        public FlavorEvent​(Clipboard source)
        构造一个 FlavorEvent对象。
        参数
        source - 这是事件的来源的 Clipboard
        异常
        IllegalArgumentException - 如果 source是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FlavorListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Interface FlavorListener

  • All Superinterfaces:
    EventListener

    public interface FlavorListener
extends EventListener
    定义一个监听FlavorEvent的对象。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void flavorsChanged​(FlavorEvent e)
      当侦听器的目标Clipboard更改其可用的DataFlavor s时调用。

    • 方法详细信息

      • flavorsChanged

        void flavorsChanged​(FlavorEvent e)
        当侦听器的目标Clipboard已更改其可用的DataFlavor s时调用。

        某些通知可能是冗余的 - 它们不是由剪贴板上可用的DataFlavors的更改引起的。 例如，如果剪贴板子系统假设系统剪贴板的内容已经更改，但是在访问剪贴板时由于某些异常情况而无法确定其DataFlavors是否已被更改，则会发送通知以确保忽略重要的通知。 通常，这些冗余通知应该是偶尔的。

        参数
        e - a FlavorEvent对象
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FlavorMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Interface FlavorMap

  • All Known Subinterfaces:
    FlavorTable
    所有已知实现类：
    SystemFlavorMap

    public interface FlavorMap
    对应于平台特定数据格式的“本土”（字符串）和“风格”（DataFlavors）之间的双向映射，它们与平台无关的MIME类型相对应。 FlavorMaps不必是对称的，而是通常是对称的。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Map<String,DataFlavor> getFlavorsForNatives​(String[] natives)
      返回 Map的 String本地人对应的 DataFlavor 。
      Map<DataFlavor,String> getNativesForFlavors​(DataFlavor[] flavors)
      将 Map的 DataFlavor为相应的 String本机。

    • 方法详细信息

      • getNativesForFlavors

        Map<DataFlavor,String> getNativesForFlavors​(DataFlavor[] flavors)
        返回Map的DataFlavor的相应String本机。 返回的Map是该FlavorMap的内部数据的可修改副本。 客户端代码可以自由修改Map而不影响该对象。
        参数
        flavors -的阵列DataFlavor S的将是所返回的密钥集Map 。 如果null指定，所有的映射DataFlavor目前已知这个S FlavorMap到其相应String当地人将被退回。
        结果
        一个 java.util.Map的 DataFlavor s到 String当地人

      • getFlavorsForNatives

        Map<String,DataFlavor> getFlavorsForNatives​(String[] natives)
        返回一个Map的String本地人到其对应的DataFlavor 。 返回的Map是这个FlavorMap的内部数据的可修改副本。 客户端代码可以自由修改Map而不影响此对象。
        参数
        natives -的阵列String S的将是所返回的密钥集Map 。 如果null指定，所有的映射String目前已知这个当地人FlavorMap到其相应DataFlavor旨意被退回。
        结果
        一个 java.util.Map的 String当地人 DataFlavor s
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FlavorTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Interface FlavorTable

  • All Superinterfaces:
    FlavorMap
    所有已知实现类：
    SystemFlavorMap

    public interface FlavorTable
extends FlavorMap
    一个FlavorMap，放宽了地图传统的1对1限制。 允许将风味映射到任何数量的本地人，同样，本地人也可以映射到任何数量的口味。 FlavorTables不必是对称的，而是通常是对称的。
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      List<DataFlavor> getFlavorsForNative​(String nat)
      返回 List的 DataFlavor s到其指定的 String对应。
      List<String> getNativesForFlavor​(DataFlavor flav)
      返回 List的 String当地人到指定 DataFlavor对应。

      • Methods inherited from interface java.awt.datatransfer.FlavorMap

        getFlavorsForNatives, getNativesForFlavors

    • 方法详细信息

      • getNativesForFlavor

        List<String> getNativesForFlavor​(DataFlavor flav)
        返回一个List的String对象中指定的DataFlavor对应的DataFlavor 。 List将从最好的本地到最坏的排序。 也就是说，第一个本机将最好将指定风味的数据反映到底层本机平台。 返回的List是FlavorTable的内部数据的可修改副本。 客户端代码可以免费修改List而不影响此对象。
        参数
        flav - 应该归还相应的本地人的DataFlavor 。 如果指定了null ， FlavorTable非确定性顺序返回此FlavorTable当前已知的所有当地人。
        结果
        一个 java.util.List的 java.lang.String对象，它们是平台特定数据格式的平台特定表示

      • getFlavorsForNative

        List<DataFlavor> getFlavorsForNative​(String nat)
        返回List的DataFlavor s，其中指定的String对应。 List将从最好的DataFlavor排序到最差。 也就是说，第一个DataFlavor将最好地反映指定的本机到Java应用程序的数据。 返回的List是这个FlavorTable的内部数据的可修改副本。 客户端代码是免费修改List而不影响此对象。
        参数
        nat - 应该返回对应的DataFlavor的本机。 如果null指定，所有DataFlavor目前已知这个S FlavorTable在一个不确定的顺序返回。
        结果
        一个 java.util.List的 DataFlavor对象，其中可以翻译指定的平台特定本机的平台特定数据
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.datatransfer (Java SE 9 & JDK 9 )

java.awt.datatransfer

Interfaces

  • ClipboardOwner
  • FlavorListener
  • FlavorMap
  • FlavorTable
  • Transferable

Classes

  • Clipboard
  • DataFlavor
  • FlavorEvent
  • StringSelection
  • SystemFlavorMap

Exceptions

  • MimeTypeParseException
  • UnsupportedFlavorException


java.awt.datatransfer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.datatransfer

Package java.awt.datatransfer

提供用于在应用程序之间和之间传输数据的接口和类。 它定义了一个“可转让”对象的概念，该对象是能够在应用程序内或应用程序之间转移的对象。 一个对象通过实现可传递接口将自身识别为可转移。

它还提供了剪贴板机制，该机制是临时保存可在应用程序内或内部传送的可转移对象的对象。 剪贴板通常用于复制和粘贴操作。 虽然可以创建一个剪贴板以在应用程序中使用，但大多数应用程序将使用系统剪贴板来确保可以跨平台上运行的应用程序传输数据。

从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    ClipboardOwner
    定义将向剪贴板提供数据的类的接口。
    FlavorListener
    定义一个监听FlavorEvent的对象。
    FlavorMap
    对应于平台特定数据格式的“本土”（字符串）和“风格”（DataFlavors）之间的双向映射，它们与平台无关的MIME类型相对应。
    FlavorTable
    一个FlavorMap，放宽了地图传统的1对1限制。
    Transferable
    定义可用于为传输操作提供数据的类的接口。
  • 类摘要
    Class 描述
    Clipboard
    实现使用剪切/复制/粘贴操作传输数据的机制的类。
    DataFlavor
    A DataFlavor提供有关数据的元信息。
    FlavorEvent
    FlavorEvent用于通知有关方面Clipboard （事件源）中有可用的DataFlavor已更改。
    StringSelection
    A Transferable ，其实现传送 String所需的能力。
    SystemFlavorMap
    SystemFlavorMap是与“平台”特定的数据格式相对应的“本地”（Stratives）和与平台无关的MIME类型对应的“风格”（DataFlavors）之间的可配置映射。
  • 异常摘要
    异常 描述
    MimeTypeParseException
    封装MimeType解析相关异常的类。
    UnsupportedFlavorException
    Signals that the requested data is not supported in this flavor.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.datatransfer Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.datatransfer

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.datatransfer.Clipboard
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.datatransfer.FlavorEvent
    • java.awt.datatransfer.StringSelection (implements java.awt.datatransfer.ClipboardOwner, java.awt.datatransfer.Transferable)
    • java.awt.datatransfer.SystemFlavorMap (implements java.awt.datatransfer.FlavorMap, java.awt.datatransfer.FlavorTable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.awt.datatransfer.MimeTypeParseException
        • java.awt.datatransfer.UnsupportedFlavorException

Interface Hierarchy

  • java.awt.datatransfer.ClipboardOwner
  • java.util.EventListener
    • java.awt.datatransfer.FlavorListener
  • java.awt.datatransfer.FlavorMap
    • java.awt.datatransfer.FlavorTable
  • java.awt.datatransfer.Transferable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


MimeTypeParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Class MimeTypeParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.datatransfer.MimeTypeParseException
  • All Implemented Interfaces:
    Serializable

    public class MimeTypeParseException
extends 异常
    封装MimeType解析相关异常的类。
    从以下版本开始：
    1.3

    • 构造方法摘要

      构造方法
      Constructor 描述
      MimeTypeParseException​()
      构造一个没有指定的详细信息的MimeTypeParseException。
      MimeTypeParseException​(String s)
      构造具有指定详细消息的MimeTypeParseException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MimeTypeParseException

        public MimeTypeParseException​()
        构造一个没有指定的详细信息的MimeTypeParseException。

      • MimeTypeParseException

        public MimeTypeParseException​(String s)
        构造具有指定详细消息的MimeTypeParseException。
        参数
        s - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringSelection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Class StringSelection

  • java.lang.Object
    • java.awt.datatransfer.StringSelection
  • All Implemented Interfaces:
    ClipboardOwner ， Transferable

    public class StringSelection
extends Object
implements Transferable, ClipboardOwner
    A Transferable ，其实现传送String所需的能力。

    这Transferable正确支持DataFlavor.stringFlavor和所有相当的口味。 支持DataFlavor.plainTextFlavor和所有等同香料已被弃用 。 不支持其他DataFlavor 。

    从以下版本开始：
    1.1
    另请参见：
    DataFlavor.stringFlavor ， DataFlavor.plainTextFlavor

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringSelection​(String data)
      创建 Transferable能够传送所述指定的 String 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getTransferData​(DataFlavor flavor)
      如果可能，返回请求的 DataFlavor中的 Transferable的数据。
      DataFlavor[] getTransferDataFlavors​()
      返回一个数组，其中这个 Transferable可以提供 Transferable 。
      boolean isDataFlavorSupported​(DataFlavor flavor)
      返回此 Transferable是否支持请求的风格。
      void lostOwnership​(Clipboard clipboard, Transferable contents)
      通知此对象不再是剪贴板所有者。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringSelection

        public StringSelection​(String data)
        创建 Transferable能够传送所述指定的 String 。
        参数
        data - 要传输的字符串

    • 方法详细信息

      • getTransferDataFlavors

        public DataFlavor[] getTransferDataFlavors​()
        返回一个数组，其中这个Transferable可以提供数据。 DataFlavor.stringFlavor得到了正确的支持。 支持DataFlavor.plainTextFlavor已弃用 。
        Specified by:
        getTransferDataFlavors在接口 Transferable
        结果
        长度为2的数组，其元素为 DataFlavor.stringFlavor和 DataFlavor.plainTextFlavor

      • isDataFlavorSupported

        public boolean isDataFlavorSupported​(DataFlavor flavor)
        返回此 Transferable是否支持请求的风格。
        Specified by:
        isDataFlavorSupported在接口 Transferable
        参数
        flavor - 数据所需的风味
        结果
        true如果flavor等于DataFlavor.stringFlavor或DataFlavor.plainTextFlavor ; false如果是flavor不是上述之一
        异常
        NullPointerException - 如果 flavor是 null

      • getTransferData

        public Object getTransferData​(DataFlavor flavor)
                       throws UnsupportedFlavorException,
                              IOException
        返回Transferable所请求的数据DataFlavor如果可能的话。 如果所需的味道是DataFlavor.stringFlavor或等同的味道，则返回表示选择的String 。 如果所需的味道是DataFlavor.plainTextFlavor或相当的味道，则返回Reader 。
        注意：此方法的行为DataFlavor.plainTextFlavor个等效DataFlavor S与定义不一致DataFlavor.plainTextFlavor 。
        Specified by:
        getTransferData在接口 Transferable
        参数
        flavor - 要求的数据风味
        结果
        请求的风味中的数据，如上所述
        异常
        UnsupportedFlavorException - 如果请求的数据风味不等于 DataFlavor.stringFlavor或 DataFlavor.plainTextFlavor
        IOException - 如果在检索数据时发生IOException。 默认情况下，StringSelection不会抛出此异常，但可能是子类。
        NullPointerException - 如果 flavor是 null
        另请参见：
        Reader

      • lostOwnership

        public void lostOwnership​(Clipboard clipboard,
                          Transferable contents)
        说明从界面复制： ClipboardOwner
        通知此对象不再是剪贴板所有者。 当该应用程序中的另一个应用程序或另一个对象断言剪贴板的所有权时，将调用此方法。
        Specified by:
        lostOwnership在接口 ClipboardOwner
        参数
        clipboard - 不再拥有的剪贴板
        contents - 该业主放置在 clipboard
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SystemFlavorMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Class SystemFlavorMap

  • java.lang.Object
    • java.awt.datatransfer.SystemFlavorMap
  • All Implemented Interfaces:
    FlavorMap ， FlavorTable

    public final class SystemFlavorMap
extends Object
implements FlavorMap, FlavorTable
    SystemFlavorMap是与“平台”特定的数据格式相对应的“本地”（Stratives）和与平台无关的MIME类型对应的“风格”（DataFlavors）之间的可配置映射。 该映射由数据传输子系统用于在Java和本机应用程序之间以及在单独的VM中的Java应用程序之间传输数据。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addFlavorForUnencodedNative​(String nat, DataFlavor flav)
      添加从单个 String本机到单个 DataFlavor 。
      void addUnencodedNativeForFlavor​(DataFlavor flav, String nat)
      将指定的 DataFlavor （和所有 DataFlavor s等于指定的 DataFlavor ）的映射添加到指定的 String本机。
      static DataFlavor decodeDataFlavor​(String nat)
      解码 String本机用作 DataFlavor 。
      static String decodeJavaMIMEType​(String nat)
      解码一个 String本机用作Java MIME类型。
      static String encodeDataFlavor​(DataFlavor flav)
      编码 DataFlavor用作本地的 String 。
      static String encodeJavaMIMEType​(String mimeType)
      将MIME类型编码为 String本机。
      static FlavorMap getDefaultFlavorMap​()
      返回此线程的ClassLoader的默认FlavorMap。
      List<DataFlavor> getFlavorsForNative​(String nat)
      返回一个 List的 DataFlavor ，其中指定的 String本机可以由数据传输子系统翻译。
      Map<String,DataFlavor> getFlavorsForNatives​(String[] natives)
      返回一个 Map的 String本地人到他们最喜欢的 DataFlavor 。
      List<String> getNativesForFlavor​(DataFlavor flav)
      返回 List的 String本地数据，数据传输子系统可以转换指定的 DataFlavor 。
      Map<DataFlavor,String> getNativesForFlavors​(DataFlavor[] flavors)
      将 Map的 DataFlavor为最优选的 String本机。
      static boolean isJavaMIMEType​(String str)
      返回指定的 String是否是编码的Java MIME类型。
      void setFlavorsForNative​(String nat, DataFlavor[] flavors)
      丢弃指定的 String本机的当前映射，并创建新的映射到指定的 DataFlavor 。
      void setNativesForFlavor​(DataFlavor flav, String[] natives)
      丢弃指定的 DataFlavor的当前映射，所有 DataFlavor等于指定的 DataFlavor ，并为指定的 String本地人创建新的映射。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDefaultFlavorMap

        public static FlavorMap getDefaultFlavorMap​()
        返回此线程的ClassLoader的默认FlavorMap。
        结果
        该线程的ClassLoader的默认FlavorMap

      • getNativesForFlavor

        public List<String> getNativesForFlavor​(DataFlavor flav)
        返回List的String本地数据，指定的DataFlavor可以由数据传输子系统翻译。 List将从最好的本地到最坏的排序。 也就是说，第一个本机将最好将指定风味的数据反映到底层本机平台。

        如果指定的DataFlavor以前是数据传输子系统未知的，并且数据传输子系统无法将此DataFlavor为任何现有本机，则调用此方法将在指定的DataFlavor和其MIME的编码版本之间建立两个方向的映射键入作为其本机。

        Specified by:
        getNativesForFlavor在接口 FlavorTable
        参数
        flav - 其相应的本地人应该退回的DataFlavor 。 如果指定了null ，则数据传输子系统当前已知的所有本地人以非确定性顺序返回。
        结果
        java.util.List的 java.lang.String对象，它们是平台特定数据格式的平台特定表示
        从以下版本开始：
        1.4
        另请参见：
        encodeDataFlavor(java.awt.datatransfer.DataFlavor)

      • getFlavorsForNative

        public List<DataFlavor> getFlavorsForNative​(String nat)
        返回List的DataFlavor ，其中指定的String本机可由数据传输子系统翻译。 List将从最好的DataFlavor排序到最差。 也就是说，第一个DataFlavor将最好地反映Java应用程序指定的本地数据。

        如果指定的本机对于数据传输子系统以前是未知的，并且本机已被正确编码，则调用此方法将在指定的本机和DataFlavor之间的两个方向建立映射，其MIME类型是本机的解码版本。

        如果指定本机是不是正确编码的本地和本本地映射没有被篡改与setFlavorsForNative ，那么内容List与平台相关，但null不能退货。

        Specified by:
        getFlavorsForNative在接口 FlavorTable
        参数
        nat - 应该返回对应的DataFlavor的本机。 如果null指定，所有DataFlavor目前已知的数据传输子系统S IN非确定性顺序返回。
        结果
        一个 java.util.List的 DataFlavor对象，指定的平台特定的本机的平台特定数据可以被翻译成
        从以下版本开始：
        1.4
        另请参见：
        encodeJavaMIMEType(java.lang.String)

      • getNativesForFlavors

        public Map<DataFlavor,String> getNativesForFlavors​(DataFlavor[] flavors)
        返回Map的DataFlavor的最优选String本机。 每个本机值将与由指定风味的getNativesForFlavor返回的列表中的第一个本机值相同。

        如果指定的DataFlavor以前是数据传输子系统未知的，则调用此方法将在指定的DataFlavor和其MIME类型的编码版本之间的双向建立映射，作为其本机。

        Specified by:
        getNativesForFlavors在接口 FlavorMap
        参数
        flavors - 一个DataFlavor s的数组，这将是返回的Map的键集。 如果null被指定时，所有的映射DataFlavor已知的数据传输子系统到其最优选的小号String当地人将被返回。
        结果
        一个 java.util.Map的 DataFlavor s到 String当地人
        另请参见：
        getNativesForFlavor(java.awt.datatransfer.DataFlavor) ， encodeDataFlavor(java.awt.datatransfer.DataFlavor)

      • getFlavorsForNatives

        public Map<String,DataFlavor> getFlavorsForNatives​(String[] natives)
        返回指定的String本地人的Map ，以最优先的DataFlavor 。 每个DataFlavor值将与第一个DataFlavor相同，由列表返回的getFlavorsForNative指定的本机。

        如果指定的本机对于数据传输子系统以前是未知的，并且本机已被正确编码，则调用此方法将在指定的本机和DataFlavor之间的两个方向建立映射，其MIME类型是本机的解码版本。

        Specified by:
        getFlavorsForNatives在接口 FlavorMap
        参数
        natives -的阵列String S的将是所返回的密钥集Map 。 如果null指定，所有的映射支持String当地人到其大多数首选DataFlavor旨意被退回。
        结果
        一个 java.util.Map的 String当地人 DataFlavor s
        另请参见：
        getFlavorsForNative(java.lang.String) ， encodeJavaMIMEType(java.lang.String)

      • addUnencodedNativeForFlavor

        public void addUnencodedNativeForFlavor​(DataFlavor flav,
                                        String nat)
        将指定的DataFlavor （和所有DataFlavor s等于指定的DataFlavor ）的映射添加到指定的String本机。 与getNativesForFlavor不同，映射将仅在一个方向上建立，并且本机将不被编码。 要建立双向映射，也可以拨打addFlavorForUnencodedNative 。 新的映射将优先于任何现有的映射。 如果从指定的或等于DataFlavor到指定的String本机的映射已经存在，则此方法无效。
        参数
        flav - DataFlavor键的映射
        nat - String映射的本机值
        异常
        NullPointerException - 如果 NullPointerException或nat是 null
        从以下版本开始：
        1.4
        另请参见：
        addFlavorForUnencodedNative(java.lang.String, java.awt.datatransfer.DataFlavor)

      • setNativesForFlavor

        public void setNativesForFlavor​(DataFlavor flav,
                                String[] natives)
        丢弃指定的DataFlavor的当前映射，所有DataFlavor等于指定的DataFlavor ，并为指定的String本地人创建新的映射。 与getNativesForFlavor不同，映射只能在一个方向上建立，而且本地人不会被编码。 要建立双向映射，也可以拨打setFlavorsForNative 。 阵列中的第一个本机将代表最高优先级映射。 随后的本地人将代表降低优先级的映射。

        如果数组包含几个引用相同的String元素， String这个方法将为这些元素中的第一个元素建立新的映射，并忽略其余的元素。

        建议客户端代码不会重置由数据传输子系统建立的映射。 此方法只能用于应用程序级映射。

        参数
        flav - DataFlavor键的映射
        natives - String映射的本机值
        异常
        NullPointerException - 如果 NullPointerException或当地人是 null或如果当地人包含 null元素
        从以下版本开始：
        1.4
        另请参见：
        setFlavorsForNative(java.lang.String, java.awt.datatransfer.DataFlavor[])

      • addFlavorForUnencodedNative

        public void addFlavorForUnencodedNative​(String nat,
                                        DataFlavor flav)
        添加一个从一个String本机到一个DataFlavor 。 与getFlavorsForNative不同，映射将仅在一个方向上建立，并且本机将不被编码。 要建立双向映射，也可以拨打addUnencodedNativeForFlavor 。 新的映射将优先于任何现有的映射。 如果从指定的String本机到指定的或等于DataFlavor已经存在，则此方法不起作用。
        参数
        nat - 用于映射的 String本机密钥
        flav - DataFlavor的映射值
        异常
        NullPointerException - 如果 nat或 flav是 null
        从以下版本开始：
        1.4
        另请参见：
        addUnencodedNativeForFlavor(java.awt.datatransfer.DataFlavor, java.lang.String)

      • setFlavorsForNative

        public void setFlavorsForNative​(String nat,
                                DataFlavor[] flavors)
        放弃指定的当前映射String人，并创建新的映射到指定DataFlavor秒。 与getFlavorsForNative不同，映射只能在一个方向建立，而不需要编码。 要建立双向映射，也可以拨打setNativesForFlavor 。 阵列中的第一个DataFlavor将代表最高优先级映射。 后续的DataFlavor将表示降低优先级的映射。

        如果数组包含引用等于DataFlavor s的几个元素，则该方法将为这些元素中的第一个元素建立新的映射，并忽略其余的元素。

        建议客户端代码不会重置由数据传输子系统建立的映射。 此方法只能用于应用程序级映射。

        参数
        nat - String本地密钥的映射
        flavors - DataFlavor值的映射
        异常
        NullPointerException - 如果 nat或 flavors为 null或如果 flavors包含 null元素
        从以下版本开始：
        1.4
        另请参见：
        setNativesForFlavor(java.awt.datatransfer.DataFlavor, java.lang.String[])

      • encodeJavaMIMEType

        public static String encodeJavaMIMEType​(String mimeType)
        将MIME类型编码为String本机。 MIME类型的编码表示的格式是依赖于实现的。 唯一的限制是：
        • 编码表示为null当且仅当MIME类型为String为null
        • 两个非null MIME类型的编码表示String s等于当且仅当这些String根据String.equals(Object)相等时
        此方法的参考实现返回指定的MIME类型String前缀为JAVA_DATAFLAVOR: 。
        参数
        mimeType - 要编码的MIME类型
        结果
        编码 String或 null如果 mimeType是 null

      • encodeDataFlavor

        public static String encodeDataFlavor​(DataFlavor flav)
        编码一个DataFlavor用作String本机。 编码DataFlavor的格式取决于实现。 唯一的限制是：
        • 编码表示是null当且仅当指定DataFlavor是null或其MIME类型String是null
        • 为两个非经编码表示null DataFlavor s的非null MIME类型String s为等于当且仅当MIME类型String这帮的DataFlavor S以相等String.equals(Object)
        此方法的参考实现返回指定的DataFlavor的MIME类型String ，前缀为JAVA_DATAFLAVOR: 。
        参数
        flav - DataFlavor进行编码
        结果
        编码 String或 null如果 flav是 null或具有 null MIME类型

      • isJavaMIMEType

        public static boolean isJavaMIMEType​(String str)
        返回指定的 String是否是编码的Java MIME类型。
        参数
        str - String要测试
        结果
        true如果String编码; false否则

      • decodeJavaMIMEType

        public static String decodeJavaMIMEType​(String nat)
        解码一个 String本机用作Java MIME类型。
        参数
        nat - 要解码的 String
        结果
        解码的Java MIME类型，或 null如果 nat不是编码的 String本机

      • decodeDataFlavor

        public static DataFlavor decodeDataFlavor​(String nat)
                                   throws ClassNotFoundException
        解码为 String本机，用作 DataFlavor 。
        参数
        nat - 要解码的 String
        结果
        解码的 DataFlavor或 null如果 nat不是编码的 String本机
        异常
        ClassNotFoundException - 如果没有加载数据flavor的类
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Transferable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Interface Transferable

  • 所有已知实现类：
    DataHandler ， DropTargetContext.TransferableProxy ， StringSelection

    public interface Transferable
    定义可用于为传输操作提供数据的类的接口。

    有关使用Swing进行数据传输的信息，请参阅“Java教程”中的“ How to Use Drag and Drop and Data Transfer ”一节。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。
      DataFlavor[] getTransferDataFlavors​()
      返回一个DataFlavor对象数组，指示可以提供数据的风格。
      boolean isDataFlavorSupported​(DataFlavor flavor)
      返回此对象是否支持指定的数据flavor。

    • 方法详细信息

      • getTransferDataFlavors

        DataFlavor[] getTransferDataFlavors​()
        返回一个DataFlavor对象数组，指示可以提供数据的风格。数组应根据提供数据的偏好（从最丰富的描述到最少描述）排序。
        结果
        一系列可以传输此数据的数据风格

      • isDataFlavorSupported

        boolean isDataFlavorSupported​(DataFlavor flavor)
        返回此对象是否支持指定的数据flavor。
        参数
        flavor - 要求的数据风味
        结果
        布尔值表示是否支持数据风格

      • getTransferData

        Object getTransferData​(DataFlavor flavor)
                throws UnsupportedFlavorException,
                       IOException
        返回表示要传输的数据的对象。 返回的对象的类由flavor的表示类定义。
        参数
        flavor - 要求的数据风味
        结果
        表示要传送的数据的对象
        异常
        IOException - 如果数据在请求的风味中不再可用
        UnsupportedFlavorException - 如果不支持请求的数据风格
        另请参见：
        DataFlavor.getRepresentationClass()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnsupportedFlavorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.datatransfer
软件包 java.awt.datatransfer

Class UnsupportedFlavorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.datatransfer.UnsupportedFlavorException
  • All Implemented Interfaces:
    Serializable

    public class UnsupportedFlavorException
extends 异常
    表示在此风格中不支持请求的数据。
    从以下版本开始：
    1.1
    另请参见：
    Transferable.getTransferData(java.awt.datatransfer.DataFlavor) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedFlavorException​(DataFlavor flavor)
      构造一个UnsupportedFlavorException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedFlavorException

        public UnsupportedFlavorException​(DataFlavor flavor)
        构造一个UnsupportedFlavorException。
        参数
        flavor - the flavor object which caused the exception. May be null.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.datatransfer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.datatransfer

  • Packages that use java.awt.datatransfer
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.activation
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
  • Classes in java.awt.datatransfer used by java.awt
    Class 描述
    Clipboard
    实现使用剪切/复制/粘贴操作传输数据的机制的类。
  • Classes in java.awt.datatransfer used by java.awt.datatransfer
    Class 描述
    Clipboard
    实现使用剪切/复制/粘贴操作传输数据的机制的类。
    ClipboardOwner
    定义将向剪贴板提供数据的类的接口。
    DataFlavor
    A DataFlavor提供有关数据的元信息。
    FlavorEvent
    FlavorEvent用于通知有关方面Clipboard （事件源）中可用的DataFlavor已更改。
    FlavorListener
    定义一个侦听FlavorEvent的对象。
    FlavorMap
    对应于平台特定数据格式的“本土”（字符串）和“风格”（DataFlavors）之间的双向映射，它们与平台无关的MIME类型相对应。
    FlavorTable
    一个FlavorMap，放宽了地图传统的1对1限制。
    Transferable
    定义可用于为传输操作提供数据的类的接口。
    UnsupportedFlavorException
    表示在此风格中不支持请求的数据。
  • Classes in java.awt.datatransfer used by java.awt.dnd
    Class 描述
    DataFlavor
    A DataFlavor提供有关数据的元信息。
    FlavorMap
    对应于平台特定数据格式的“本土”（字符串）和“风格”（DataFlavors）之间的双向映射，它们与平台无关的MIME类型相对应。
    Transferable
    定义可用于为传输操作提供数据的类的接口。
    UnsupportedFlavorException
    表示在此风格中不支持请求的数据。
  • Classes in java.awt.datatransfer used by javax.accessibility
    Class 描述
    DataFlavor
    A DataFlavor提供有关数据的元信息。
  • Classes in java.awt.datatransfer used by javax.activation
    Class 描述
    DataFlavor
    A DataFlavor提供有关数据的元信息。
    Transferable
    定义可用于为传输操作提供数据的类的接口。
    UnsupportedFlavorException
    表示在此风格中不支持请求的数据。
  • Classes in java.awt.datatransfer used by javax.jnlp
    Class 描述
    Transferable
    定义可用于为传输操作提供数据的类的接口。
  • Classes in java.awt.datatransfer used by javax.swing
    Class 描述
    Clipboard
    实现使用剪切/复制/粘贴操作传输数据的机制的类。
    DataFlavor
    A DataFlavor提供有关数据的元信息。
    Transferable
    定义可用于为传输操作提供数据的类的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.datatransfer.Clipboard (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.datatransfer.Clipboard

  • Packages that use Clipboard
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Clipboard in java.awt

      Methods in java.awt that return Clipboard
      Modifier and Type 方法 描述
      abstract Clipboard Toolkit.getSystemClipboard​()
      获取与本地平台提供的剪贴板工具接口的系统剪贴板的单例实例。
      Clipboard Toolkit.getSystemSelection​()
      获取系统选择的单例实例为 Clipboard对象。

    • Uses of Clipboard in java.awt.datatransfer

      Methods in java.awt.datatransfer with parameters of type Clipboard
      Modifier and Type | 方法 | 描述
      void ClipboardOwner.lostOwnership​(Clipboard clipboard, Transferable contents)
      通知此对象不再是剪贴板所有者。
      void | StringSelection.lostOwnership​(Clipboard clipboard, Transferable contents)
      Constructors in java.awt.datatransfer with parameters of type Clipboard
      Constructor 描述
      FlavorEvent​(Clipboard source)
      构造一个 FlavorEvent对象。

    • Uses of Clipboard in javax.swing

      Methods in javax.swing with parameters of type Clipboard
      Modifier and Type 方法 描述
      void TransferHandler.exportToClipboard​(JComponent comp, Clipboard clip, int action)
      导致从给定组件转移到给定的剪贴板。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.datatransfer.DataFlavor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.datatransfer.DataFlavor

  • Packages that use DataFlavor
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.activation
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of DataFlavor in java.awt.datatransfer

      Fields in java.awt.datatransfer declared as DataFlavor
      Modifier and Type Field 描述
      static DataFlavor DataFlavor.allHtmlFlavor
      代表一个HTML标记。
      static DataFlavor DataFlavor.fragmentHtmlFlavor
      代表一个HTML标记。
      static DataFlavor DataFlavor.imageFlavor
      代表Java Image类的 DataFlavor ，其中：
      static DataFlavor DataFlavor.javaFileListFlavor
      要将文件列表/从Java（和底层平台） DataFlavor到此类型的一个 DataFlavor /子类型和表示类别为 java.util.List 。
      static DataFlavor DataFlavor.plainTextFlavor
      已过时。
      截至1.3。 使用getReaderForText(java.awt.datatransfer.Transferable)而不是Transferable.getTransferData(DataFlavor.plainTextFlavor) 。
      static DataFlavor DataFlavor.selectionHtmlFlavor
      代表一个HTML标记。
      static DataFlavor DataFlavor.stringFlavor
      DataFlavor代表Java Unicode String类，其中：
      Methods in java.awt.datatransfer that return DataFlavor
      Modifier and Type 方法 描述
      static DataFlavor SystemFlavorMap.decodeDataFlavor​(String nat)
      解码 String本机用作 DataFlavor 。
      DataFlavor[] Clipboard.getAvailableDataFlavors​()
      返回一个 DataFlavor的数组，其中可以提供此剪贴板的当前内容。
      static DataFlavor DataFlavor.getTextPlainUnicodeFlavor​()
      返回一个 DataFlavor表示Unicode编码的纯文本，其中：
      DataFlavor[] StringSelection.getTransferDataFlavors​()
      返回flavor在此的数组 Transferable可以提供该数据。
      DataFlavor[] Transferable.getTransferDataFlavors​()
      返回一个DataFlavor对象数组，指示可以提供数据的风格。
      static DataFlavor DataFlavor.selectBestTextFlavor​(DataFlavor[] availableFlavors)
      选择最好的文本 DataFlavor从数组 DataFlavor秒。
      Methods in java.awt.datatransfer that return types with arguments of type DataFlavor
      Modifier and Type 方法 描述
      List<DataFlavor> FlavorTable.getFlavorsForNative​(String nat)
      返回 List的 DataFlavor s，其中指定的 String对应。
      List<DataFlavor> SystemFlavorMap.getFlavorsForNative​(String nat)
      返回 List的 DataFlavor ，其中指定的 String本机可以由数据传输子系统翻译。
      Map<String,DataFlavor> FlavorMap.getFlavorsForNatives​(String[] natives)
      将 String本地人的 Map返回到对应的 DataFlavor 。
      Map<String,DataFlavor> SystemFlavorMap.getFlavorsForNatives​(String[] natives)
      返回一个 Map的 String当地人，最喜欢 DataFlavor 。
      Map<DataFlavor,String> FlavorMap.getNativesForFlavors​(DataFlavor[] flavors)
      返回 Map指定的 DataFlavor s到其对应的 String本地人。
      Map<DataFlavor,String> SystemFlavorMap.getNativesForFlavors​(DataFlavor[] flavors)
      返回 Map指定的 DataFlavor s到其大多数首选 String本地人。
      Methods in java.awt.datatransfer with parameters of type DataFlavor
      Modifier and Type 方法 描述
      void SystemFlavorMap.addFlavorForUnencodedNative​(String nat, DataFlavor flav)
      添加一个从一个 String本机到一个 DataFlavor 。
      void SystemFlavorMap.addUnencodedNativeForFlavor​(DataFlavor flav, String nat)
      将指定的 DataFlavor （和所有 DataFlavor s等于指定的 DataFlavor ）的映射添加到指定的 String本机。
      static String SystemFlavorMap.encodeDataFlavor​(DataFlavor flav)
      编码一个 DataFlavor用作一个 String本机。
      boolean DataFlavor.equals​(DataFlavor that)
      此方法与 equals(Object)具有相同的行为。
      Object Clipboard.getData​(DataFlavor flavor)
      在指定的 DataFlavor返回表示此剪贴板当前内容的对象。
      List<String> FlavorTable.getNativesForFlavor​(DataFlavor flav)
      返回 List对于 DataFlavor对应的 String原住民。
      List<String> SystemFlavorMap.getNativesForFlavor​(DataFlavor flav)
      返回 List的 String本地数据，数据传输子系统可以转换指定的 DataFlavor 。
      Map<DataFlavor,String> FlavorMap.getNativesForFlavors​(DataFlavor[] flavors)
      将 Map的 DataFlavor为相应的 String本机。
      Map<DataFlavor,String> SystemFlavorMap.getNativesForFlavors​(DataFlavor[] flavors)
      返回 Map指定的 DataFlavor s到其大多数首选 String本地人。
      Object StringSelection.getTransferData​(DataFlavor flavor)
      返回 Transferable所请求的数据 DataFlavor如果可能的话。
      Object Transferable.getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。
      boolean Clipboard.isDataFlavorAvailable​(DataFlavor flavor)
      返回是否可以在指定的 DataFlavor提供此剪贴板的当前内容。
      boolean StringSelection.isDataFlavorSupported​(DataFlavor flavor)
      返回此 Transferable是否支持请求的风味。
      boolean Transferable.isDataFlavorSupported​(DataFlavor flavor)
      返回此对象是否支持指定的数据flavor。
      boolean DataFlavor.isMimeTypeEqual​(DataFlavor dataFlavor)
      比较 mimeType两个 DataFlavor对象。
      boolean DataFlavor.match​(DataFlavor that)
      与 equals(DataFlavor)相同。
      static DataFlavor DataFlavor.selectBestTextFlavor​(DataFlavor[] availableFlavors)
      选择最好的文本 DataFlavor从数组 DataFlavor秒。
      void SystemFlavorMap.setFlavorsForNative​(String nat, DataFlavor[] flavors)
      丢弃指定的 String本机的当前映射，并创建新的映射到指定的 DataFlavor 。
      void SystemFlavorMap.setNativesForFlavor​(DataFlavor flav, String[] natives)
      丢弃指定的 DataFlavor的当前映射和所有 DataFlavor s等于指定的 DataFlavor映射，并为指定的 String本地人创建新的映射。
      Constructors in java.awt.datatransfer with parameters of type DataFlavor
      Constructor 描述
      UnsupportedFlavorException​(DataFlavor flavor)
      构造一个UnsupportedFlavorException。

    • Uses of DataFlavor in java.awt.dnd

      Methods in java.awt.dnd that return DataFlavor
      Modifier and Type 方法 描述
      protected DataFlavor[] DropTargetContext.getCurrentDataFlavors​()
      获取此操作的 Transferable操作数的可用DataFlavors。
      DataFlavor[] DropTargetDragEvent.getCurrentDataFlavors​()
      此方法从 DropTargetContext返回当前的 DataFlavor s。
      DataFlavor[] DropTargetDropEvent.getCurrentDataFlavors​()
      此方法返回当前DataFlavors。
      DataFlavor[] DropTargetContext.TransferableProxy.getTransferDataFlavors​()
      返回一个DataFlavor对象数组，表示可封装的可传递数据可以提供数据的风格。
      Methods in java.awt.dnd that return types with arguments of type DataFlavor
      Modifier and Type 方法 描述
      protected List<DataFlavor> DropTargetContext.getCurrentDataFlavorsAsList​()
      该方法返回当前可用的 Transferable操作数DataFlavors作为 java.util.List 。
      List<DataFlavor> DropTargetDragEvent.getCurrentDataFlavorsAsList​()
      此方法返回当前的 DataFlavor作为 java.util.List
      List<DataFlavor> DropTargetDropEvent.getCurrentDataFlavorsAsList​()
      此方法返回当前可用的 DataFlavor s作为 java.util.List 。
      Methods in java.awt.dnd with parameters of type DataFlavor
      Modifier and Type 方法 描述
      Object DropTargetContext.TransferableProxy.getTransferData​(DataFlavor df)
      返回一个对象，该对象表示由所请求的数据风格的可封装转移提供的数据。
      protected boolean DropTargetContext.isDataFlavorSupported​(DataFlavor df)
      此方法返回一个 boolean表示该 DataFlavor是否支持给定的 DropTargetContext 。
      boolean DropTargetContext.TransferableProxy.isDataFlavorSupported​(DataFlavor flavor)
      返回指定的数据风格是否被封装的可转移支持。
      boolean DropTargetDragEvent.isDataFlavorSupported​(DataFlavor df)
      此方法返回一个 boolean指示是否支持指定的 DataFlavor 。
      boolean DropTargetDropEvent.isDataFlavorSupported​(DataFlavor df)
      此方法返回一个 boolean指示是否从源中可以使用指定的 DataFlavor 。

    • Uses of DataFlavor in javax.accessibility

      Methods in javax.accessibility that return DataFlavor
      Modifier and Type 方法 描述
      DataFlavor[] AccessibleStreamable.getMimeTypes​()
      返回此对象支持的MIME类型的 DataFlavor对象的数组。
      Methods in javax.accessibility with parameters of type DataFlavor
      Modifier and Type 方法 描述
      InputStream AccessibleStreamable.getStream​(DataFlavor flavor)
      返回一个 InputStream为 DataFlavor 。

    • Uses of DataFlavor in javax.activation

      Subclasses of DataFlavor in javax.activation
      Modifier and Type Class 描述
      class  ActivationDataFlavor
      ActivationDataFlavor类是 java.awt.datatransfer.DataFlavor的特殊子类。
      Methods in javax.activation that return DataFlavor
      Modifier and Type 方法 描述
      DataFlavor[] DataContentHandler.getTransferDataFlavors​()
      返回一个DataFlavor对象数组，指示可以提供数据的风格。
      DataFlavor[] DataHandler.getTransferDataFlavors​()
      返回此数据可用的DataFlavors。
      Methods in javax.activation with parameters of type DataFlavor
      Modifier and Type 方法 描述
      boolean ActivationDataFlavor.equals​(DataFlavor dataFlavor)
      将传入的DataFlavor与此DataFlavor进行比较; 调用isMimeTypeEqual方法。
      Object DataContentHandler.getTransferData​(DataFlavor df, DataSource ds)
      返回表示要传输的数据的对象。
      Object DataHandler.getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。
      boolean DataHandler.isDataFlavorSupported​(DataFlavor flavor)
      返回此对象是否支持指定的数据flavor。

    • Uses of DataFlavor in javax.swing

      Methods in javax.swing that return DataFlavor
      Modifier and Type 方法 描述
      DataFlavor[] TransferHandler.TransferSupport.getDataFlavors​()
      返回此传输的数据风格。
      Methods in javax.swing with parameters of type DataFlavor
      Modifier and Type 方法 描述
      boolean TransferHandler.canImport​(JComponent comp, DataFlavor[] transferFlavors)
      指示组件是否将在实际尝试导入之前接受给定的一组数据风格的导入。
      boolean TransferHandler.TransferSupport.isDataFlavorSupported​(DataFlavor df)
      返回是否支持给定的数据风格。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.datatransfer.FlavorEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.datatransfer.FlavorEvent

  • Packages that use FlavorEvent
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。

    • Uses of FlavorEvent in java.awt.datatransfer

      Methods in java.awt.datatransfer with parameters of type FlavorEvent
      Modifier and Type 方法 描述
      void FlavorListener.flavorsChanged​(FlavorEvent e)
      当侦听器的目标Clipboard已更改其可用的DataFlavor s时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.datatransfer.MimeTypeParseException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.datatransfer.MimeTypeParseException

No usage of java.awt.datatransfer.MimeTypeParseException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.datatransfer.StringSelection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.datatransfer.StringSelection

No usage of java.awt.datatransfer.StringSelection
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.datatransfer.SystemFlavorMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.datatransfer.SystemFlavorMap

No usage of java.awt.datatransfer.SystemFlavorMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.datatransfer.UnsupportedFlavorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.datatransfer.UnsupportedFlavorException

  • Packages that use UnsupportedFlavorException
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    javax.activation

    • Uses of UnsupportedFlavorException in java.awt.datatransfer

      Methods in java.awt.datatransfer that throw UnsupportedFlavorException
      Modifier and Type 方法 描述
      Object Clipboard.getData​(DataFlavor flavor)
      在指定的 DataFlavor返回表示此剪贴板当前内容的对象。
      Reader DataFlavor.getReaderForText​(Transferable transferable)
      获取一个文本风味的阅读器，如有必要，解码为预期的字符集（编码）。
      Object StringSelection.getTransferData​(DataFlavor flavor)
      如果可能，返回请求的 DataFlavor中的 Transferable的数据。
      Object Transferable.getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。

    • Uses of UnsupportedFlavorException in java.awt.dnd

      Methods in java.awt.dnd that throw UnsupportedFlavorException
      Modifier and Type 方法 描述
      Object DropTargetContext.TransferableProxy.getTransferData​(DataFlavor df)
      返回一个对象，该对象表示由所请求的数据风格的可封装转移提供的数据。

    • Uses of UnsupportedFlavorException in javax.activation

      Methods in javax.activation that throw UnsupportedFlavorException
      Modifier and Type 方法 描述
      Object DataContentHandler.getTransferData​(DataFlavor df, DataSource ds)
      返回表示要传输的数据的对象。
      Object DataHandler.getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.datatransfer.ClipboardOwner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.datatransfer.ClipboardOwner

  • Packages that use ClipboardOwner
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。

    • Uses of ClipboardOwner in java.awt.datatransfer

      Classes in java.awt.datatransfer that implement ClipboardOwner
      Modifier and Type Class 描述
      class  StringSelection
      A Transferable ，其实现传送 String所需的能力。
      Fields in java.awt.datatransfer declared as ClipboardOwner
      Modifier and Type Field 描述
      protected ClipboardOwner Clipboard.owner
      剪贴板的所有者。
      Methods in java.awt.datatransfer with parameters of type ClipboardOwner
      Modifier and Type 方法 描述
      void Clipboard.setContents​(Transferable contents, ClipboardOwner owner)
      将剪贴板的当前内容设置为指定的可转移对象，并将指定的剪贴板所有者注册为新内容的所有者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.datatransfer.FlavorListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.datatransfer.FlavorListener

  • Packages that use FlavorListener
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。

    • Uses of FlavorListener in java.awt.datatransfer

      Methods in java.awt.datatransfer that return FlavorListener
      Modifier and Type 方法 描述
      FlavorListener[] Clipboard.getFlavorListeners​()
      返回当前在该 Clipboard上注册的所有 FlavorListener的数组。
      Methods in java.awt.datatransfer with parameters of type FlavorListener
      Modifier and Type 方法 描述
      void Clipboard.addFlavorListener​(FlavorListener listener)
      注册指定的 FlavorListener以从此剪贴板接收 FlavorEvent s。
      void Clipboard.removeFlavorListener​(FlavorListener listener)
      删除指定的 FlavorListener ，使其不再从此 Clipboard接收 FlavorEvent s。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.datatransfer.FlavorMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.datatransfer.FlavorMap

  • Packages that use FlavorMap
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of FlavorMap in java.awt.datatransfer

      Subinterfaces of FlavorMap in java.awt.datatransfer
      Modifier and Type 接口 描述
      interface  FlavorTable
      一个FlavorMap，放宽了地图传统的1对1限制。
      Classes in java.awt.datatransfer that implement FlavorMap
      Modifier and Type Class 描述
      class  SystemFlavorMap
      SystemFlavorMap是与“平台”特定的数据格式相对应的“本地”（Stratives）和与平台无关的MIME类型对应的“风格”（DataFlavors）之间的可配置映射。
      Methods in java.awt.datatransfer that return FlavorMap
      Modifier and Type 方法 描述
      static FlavorMap SystemFlavorMap.getDefaultFlavorMap​()
      返回此线程的ClassLoader的默认FlavorMap。

    • Uses of FlavorMap in java.awt.dnd

      Methods in java.awt.dnd that return FlavorMap
      Modifier and Type 方法 描述
      FlavorMap DragSource.getFlavorMap​()
      此方法为该 FlavorMap返回 DragSource 。
      FlavorMap DropTarget.getFlavorMap​()
      获取 FlavorMap与此 DropTarget相关联。
      Methods in java.awt.dnd with parameters of type FlavorMap
      Modifier and Type 方法 描述
      void DropTarget.setFlavorMap​(FlavorMap fm)
      设置 FlavorMap与此 DropTarget相关联。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
      Constructors in java.awt.dnd with parameters of type FlavorMap
      Constructor 描述
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
      创建一个新的DropTarget，给出 Component与自己相关联，一个 int表示默认可接受的操作来支持，一个 DropTargetListener处理事件处理，一个 boolean指示 DropTarget是否正在接受丢弃，以及一个 FlavorMap （或null为默认值 FlavorMap ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.datatransfer.FlavorTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.datatransfer.FlavorTable

  • Packages that use FlavorTable
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。

    • Uses of FlavorTable in java.awt.datatransfer

      Classes in java.awt.datatransfer that implement FlavorTable
      Modifier and Type Class 描述
      class  SystemFlavorMap
      SystemFlavorMap是与“平台”特定的数据格式相对应的“本地”（Stratives）和与平台无关的MIME类型对应的“风格”（DataFlavors）之间的可配置映射。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.datatransfer.Transferable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.datatransfer.Transferable

  • Packages that use Transferable
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    javax.activation
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Transferable in java.awt.datatransfer

      Classes in java.awt.datatransfer that implement Transferable
      Modifier and Type Class 描述
      class  StringSelection
      A Transferable ，其实现传送 String所需的能力。
      Fields in java.awt.datatransfer declared as Transferable
      Modifier and Type Field 描述
      protected Transferable Clipboard.contents
      剪贴板的内容。
      Methods in java.awt.datatransfer that return Transferable
      Modifier and Type 方法 描述
      Transferable Clipboard.getContents​(Object requestor)
      返回表示剪贴板当前内容的可转移对象。
      Methods in java.awt.datatransfer with parameters of type Transferable
      Modifier and Type | 方法 | 描述
      Reader DataFlavor.getReaderForText​(Transferable transferable)
      获取一个文本风味的阅读器，如有必要，解码为预期的字符集（编码）。
      void ClipboardOwner.lostOwnership​(Clipboard clipboard, Transferable contents)
      通知此对象不再是剪贴板所有者。
      void | StringSelection.lostOwnership​(Clipboard clipboard, Transferable contents)
      void Clipboard.setContents​(Transferable contents, ClipboardOwner owner)
      将剪贴板的当前内容设置为指定的可转移对象，并将指定的剪贴板所有者注册为新内容的所有者。

    • Uses of Transferable in java.awt.dnd

      Classes in java.awt.dnd that implement Transferable
      Modifier and Type Class 描述
      protected class  DropTargetContext.TransferableProxy
      TransferableProxy是一个助手内部类，它实现 Transferable接口，并作为代表另一个 Transferable对象的代理，代表特定的拖放操作的数据传输。
      Fields in java.awt.dnd declared as Transferable
      Modifier and Type Field 描述
      protected Transferable DropTargetContext.TransferableProxy.transferable
      封装 Transferable对象。
      Methods in java.awt.dnd that return Transferable
      Modifier and Type 方法 描述
      protected Transferable DropTargetContext.createTransferableProxy​(Transferable t, boolean local)
      创建一个TransferableProxy代理指定的Transferable。
      Transferable DragSourceContext.getTransferable​()
      返回 Transferable与此相关 DragSourceContext 。
      protected Transferable DropTargetContext.getTransferable​()
      获取此操作的可转移（代理）操作数
      Transferable DropTargetDragEvent.getTransferable​()
      此方法返回表示与当前拖动操作相关联的数据的Transferable对象。
      Transferable DropTargetDropEvent.getTransferable​()
      此方法返回与该drop相关联的 Transferable对象。
      Methods in java.awt.dnd with parameters of type Transferable
      Modifier and Type 方法 描述
      protected DragSourceContext DragSource.createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      protected Transferable DropTargetContext.createTransferableProxy​(Transferable t, boolean local)
      创建一个TransferableProxy代理指定的Transferable。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Transferable transferable)
      开始拖动操作，给出 Cursor用于此拖动操作， Transferable表示此拖动操作的源数据。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始拖动给予初始 Cursor显示， Transferable对象和 DragSourceListener使用。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl)
      启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
      Constructors in java.awt.dnd with parameters of type Transferable
      Constructor 描述
      DragSourceContext​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
      从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image来自触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。

    • Uses of Transferable in javax.activation

      Classes in javax.activation that implement Transferable
      Modifier and Type Class 描述
      class  DataHandler
      DataHandler类为许多不同来源和格式的数据提供了一致的界面。

    • Uses of Transferable in javax.jnlp

      Methods in javax.jnlp that return Transferable
      Modifier and Type 方法 描述
      Transferable ClipboardService.getContents​()
      返回表示剪贴板当前内容的 Transferable对象。
      Methods in javax.jnlp with parameters of type Transferable
      Modifier and Type 方法 描述
      void ClipboardService.setContents​(Transferable contents)
      将剪贴板的当前内容设置为指定的 Transferable对象。

    • Uses of Transferable in javax.swing

      Methods in javax.swing that return Transferable
      Modifier and Type 方法 描述
      protected Transferable TransferHandler.createTransferable​(JComponent c)
      创建一个 Transferable作为数据传输的来源。
      Transferable TransferHandler.TransferSupport.getTransferable​()
      返回与此传输相关联的 Transferable 。
      Methods in javax.swing with parameters of type Transferable
      Modifier and Type 方法 描述
      protected void TransferHandler.exportDone​(JComponent source, Transferable data, int action)
      数据导出后调用。
      Icon TransferHandler.getVisualRepresentation​(Transferable t)
      返回一个建立传输外观的对象。
      boolean TransferHandler.importData​(JComponent comp, Transferable t)
      导致从剪贴板或DND丢弃操作传输到组件。
      Constructors in javax.swing with parameters of type Transferable
      Constructor 描述
      TransferSupport​(Component component, Transferable transferable)
      为给定的组件和 Transferable创建一个 TransferSupport ， isDrop() false为 Transferable 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AboutEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class AboutEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.AboutEvent
  • All Implemented Interfaces:
    Serializable

    public final class AboutEvent
extends AppEvent
    当应用程序被要求打开窗口时发送事件。
    从以下版本开始：
    9
    另请参见：
    AboutHandler.handleAbout(java.awt.desktop.AboutEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      AboutEvent​()
      构造一个 AboutEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AboutEvent

        public AboutEvent​()
        构造一个 AboutEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AboutHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface AboutHandler

  • public interface AboutHandler
    当应用程序被要求显示对话框时，实现者会收到通知。
    从以下版本开始：
    9
    另请参见：
    Desktop.setAboutHandler(java.awt.desktop.AboutHandler)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void handleAbout​(AboutEvent e)
      当应用程序被要求显示其对话框时调用。

    • 方法详细信息

      • handleAbout

        void handleAbout​(AboutEvent e)
        当应用程序被要求显示其对话框时调用。
        参数
        e - 显示关于对话框的请求。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class AppEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AboutEvent ， AppForegroundEvent ， AppHiddenEvent ， AppReopenedEvent ， FilesEvent ， OpenURIEvent ， PreferencesEvent ， QuitEvent ， ScreenSleepEvent ， SystemSleepEvent ， UserSessionEvent

    public class AppEvent
extends EventObject
    AppEvent被发送到安装在Desktop上的监听器和处理程序。
    从以下版本开始：
    9
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppForegroundEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class AppForegroundEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.AppForegroundEvent
  • All Implemented Interfaces:
    Serializable

    public final class AppForegroundEvent
extends AppEvent
    当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。
    从以下版本开始：
    9
    另请参见：
    AppForegroundListener.appRaisedToForeground(AppForegroundEvent) ， AppForegroundListener.appMovedToBackground(AppForegroundEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      AppForegroundEvent​()
      构造一个 AppForegroundEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AppForegroundEvent

        public AppForegroundEvent​()
        构造一个 AppForegroundEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppForegroundListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface AppForegroundListener

  • All Superinterfaces:
    EventListener ， SystemEventListener

    public interface AppForegroundListener
extends SystemEventListener
    当应用程序成为前台应用程序，何时不再是前台应用程序，实施者会收到通知。 此通知对于隐藏和显示临时UI（如调色板窗口）非常有用，当应用程序在后台时应该隐藏。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void appMovedToBackground​(AppForegroundEvent e)
      当应用程序成为后台应用程序并且另一个应用程序成为前台应用程序时调用。
      void appRaisedToForeground​(AppForegroundEvent e)
      当应用程序成为前台应用程序时调用。

    • 方法详细信息

      • appRaisedToForeground

        void appRaisedToForeground​(AppForegroundEvent e)
        当应用程序成为前台应用程序时调用。
        参数
        e - 事件

      • appMovedToBackground

        void appMovedToBackground​(AppForegroundEvent e)
        当应用程序成为后台应用程序并且另一个应用程序成为前台应用程序时调用。
        参数
        e - 事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppHiddenEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class AppHiddenEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.AppHiddenEvent
  • All Implemented Interfaces:
    Serializable

    public final class AppHiddenEvent
extends AppEvent
    应用程序隐藏或显示时发送的事件。
    从以下版本开始：
    9
    另请参见：
    AppHiddenListener.appHidden(AppHiddenEvent) ， AppHiddenListener.appUnhidden(AppHiddenEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      AppHiddenEvent​()
      构造一个 AppHiddenEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AppHiddenEvent

        public AppHiddenEvent​()
        构造一个 AppHiddenEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppHiddenListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface AppHiddenListener

  • All Superinterfaces:
    EventListener ， SystemEventListener

    public interface AppHiddenListener
extends SystemEventListener
    当应用程序被用户隐藏或显示时，将通知实施者。 如果用户不可见，此通知有助于停止昂贵的动画。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void appHidden​(AppHiddenEvent e)
      被称为应用程序被隐藏。
      void appUnhidden​(AppHiddenEvent e)
      当隐藏的应用程序再次显示（但不一定被带到前台）时调用。

    • 方法详细信息

      • appHidden

        void appHidden​(AppHiddenEvent e)
        被称为应用程序被隐藏。
        参数
        e - 事件

      • appUnhidden

        void appUnhidden​(AppHiddenEvent e)
        当隐藏的应用程序再次显示（但不一定被带到前台）时调用。
        参数
        e - 事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppReopenedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class AppReopenedEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.AppReopenedEvent
  • All Implemented Interfaces:
    Serializable

    public final class AppReopenedEvent
extends AppEvent
    当应用程序被要求重新打开时发送事件。
    从以下版本开始：
    9
    另请参见：
    AppReopenedListener.appReopened(AppReopenedEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      AppReopenedEvent​()
      构造一个 AppReopenedEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AppReopenedEvent

        public AppReopenedEvent​()
        构造一个 AppReopenedEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AppReopenedListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface AppReopenedListener

  • All Superinterfaces:
    EventListener ， SystemEventListener

    public interface AppReopenedListener
extends SystemEventListener
    当应用程序被要求再次打开时，实施者会收到通知。 当您的应用没有打开的窗口时，此通知对于显示新文档很有用。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void appReopened​(AppReopenedEvent e)
      当应用程序重新打开时调用

    • 方法详细信息

      • appReopened

        void appReopened​(AppReopenedEvent e)
        当应用程序重新打开时调用
        参数
        e - 重新打开应用程序的请求
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class FilesEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.FilesEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    OpenFilesEvent ， PrintFilesEvent

    public class FilesEvent
extends AppEvent
    辅助事件包含文件列表。
    从以下版本开始：
    9
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      List<File> getFiles​()
      获取文件列表

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getFiles

        public List<File> getFiles​()
        获取文件列表
        结果
        文件列表
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.desktop (Java SE 9 & JDK 9 )

java.awt.desktop

Interfaces

  • AboutHandler
  • AppForegroundListener
  • AppHiddenListener
  • AppReopenedListener
  • OpenFilesHandler
  • OpenURIHandler
  • PreferencesHandler
  • PrintFilesHandler
  • QuitHandler
  • QuitResponse
  • ScreenSleepListener
  • SystemEventListener
  • SystemSleepListener
  • UserSessionListener

Classes

  • AboutEvent
  • AppEvent
  • AppForegroundEvent
  • AppHiddenEvent
  • AppReopenedEvent
  • FilesEvent
  • OpenFilesEvent
  • OpenURIEvent
  • PreferencesEvent
  • PrintFilesEvent
  • QuitEvent
  • ScreenSleepEvent
  • SystemSleepEvent
  • UserSessionEvent

Enums

  • QuitStrategy
  • UserSessionEvent.Reason


java.awt.desktop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.desktop

提供与各种桌面功能交互的接口和类。
从以下版本开始：
9
  • 接口摘要
    接口 描述
    AboutHandler
    当应用程序被要求显示对话框时，实现者会收到通知。
    AppForegroundListener
    当应用程序成为前台应用程序，何时不再是前台应用程序，实施者会收到通知。
    AppHiddenListener
    当应用程序被用户隐藏或显示时，将通知实施者。
    AppReopenedListener
    当应用程序被要求再次打开时，实施者会收到通知。
    OpenFilesHandler
    当应用程序被要求打开文件列表时，通知实施者。
    OpenURIHandler
    当应用程序被要求打开一个URI时，通知一个实现者。
    PreferencesHandler
    当应用程序被要求显示其首选项UI时，会通知实施者。
    PrintFilesHandler
    实施者可以响应打印应用程序注册处理的文档的请求。
    QuitHandler
    执行者确定是否应该继续或取消退出此应用程序的请求。
    QuitResponse
    用于响应退出应用程序的请求。
    ScreenSleepListener
    当连接到系统的显示器进入省电睡眠时，实施者会收到通知。
    SystemEventListener
    所有事件监听器子类的公共接口。
    SystemSleepListener
    当系统进入睡眠状态，系统唤醒后，实施者会收到通知。
    UserSessionListener
    当用户会话更改时，实现者会收到通知。
  • 类摘要
    Class 描述
    AboutEvent
    当应用程序被要求打开窗口时发送事件。
    AppEvent
    AppEvent被发送到安装在Desktop上的监听器和处理程序。
    AppForegroundEvent
    当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。
    AppHiddenEvent
    应用程序隐藏或显示时发送的事件。
    AppReopenedEvent
    当应用程序被要求重新打开时发送事件。
    FilesEvent
    辅助事件包含文件列表。
    OpenFilesEvent
    当应用程序被要求打开文件列表时发送事件。
    OpenURIEvent
    当应用程序被要求打开一个 URI时发送的事件。
    PreferencesEvent
    当请求应用程序打开其首选项窗口时发送事件。
    PrintFilesEvent
    当应用程序被要求打印文件列表时发送事件。
    QuitEvent
    当应用程序被要求退出时发送事件。
    ScreenSleepEvent
    当系统显示器进入并退出省电睡眠时发送事件。
    SystemSleepEvent
    系统进入和退出省电休眠时发送的事件。
    UserSessionEvent
    用户会话更改时发送的事件。
  • 枚举摘要
    Enum 描述
    QuitStrategy
    如果未启用“突发终止”，则用于关闭应用程序的策略。
    UserSessionEvent.Reason
    Kinds of available reasons of user session change.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.desktop Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.desktop

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.desktop.AppEvent
        • java.awt.desktop.AboutEvent
        • java.awt.desktop.AppForegroundEvent
        • java.awt.desktop.AppHiddenEvent
        • java.awt.desktop.AppReopenedEvent
        • java.awt.desktop.FilesEvent
          • java.awt.desktop.OpenFilesEvent
          • java.awt.desktop.PrintFilesEvent
        • java.awt.desktop.OpenURIEvent
        • java.awt.desktop.PreferencesEvent
        • java.awt.desktop.QuitEvent
        • java.awt.desktop.ScreenSleepEvent
        • java.awt.desktop.SystemSleepEvent
        • java.awt.desktop.UserSessionEvent

Interface Hierarchy

  • java.awt.desktop.AboutHandler
  • java.util.EventListener
    • java.awt.desktop.SystemEventListener
      • java.awt.desktop.AppForegroundListener
      • java.awt.desktop.AppHiddenListener
      • java.awt.desktop.AppReopenedListener
      • java.awt.desktop.ScreenSleepListener
      • java.awt.desktop.SystemSleepListener
      • java.awt.desktop.UserSessionListener
  • java.awt.desktop.OpenFilesHandler
  • java.awt.desktop.OpenURIHandler
  • java.awt.desktop.PreferencesHandler
  • java.awt.desktop.PrintFilesHandler
  • java.awt.desktop.QuitHandler
  • java.awt.desktop.QuitResponse

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.desktop.QuitStrategy
      • java.awt.desktop.UserSessionEvent.Reason
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


OpenFilesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class OpenFilesEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.FilesEvent
          • java.awt.desktop.OpenFilesEvent
  • All Implemented Interfaces:
    Serializable

    public final class OpenFilesEvent
extends FilesEvent
    当应用程序被要求打开文件列表时发送事件。
    从以下版本开始：
    9
    另请参见：
    OpenFilesHandler.openFiles(java.awt.desktop.OpenFilesEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      OpenFilesEvent​(List<File> files, String searchTerm)
      构造一个 OpenFilesEvent

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getSearchTerm​()
      获取搜索字词。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.awt.desktop.FilesEvent

        getFiles

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • OpenFilesEvent

        public OpenFilesEvent​(List<File> files,
                      String searchTerm)
        构造一个 OpenFilesEvent
        参数
        files - 文件
        searchTerm - searchTerm

    • 方法详细信息

      • getSearchTerm

        public String getSearchTerm​()
        获取搜索字词。 该平台可以可选地提供用于查找文件的搜索项。 例如Mac OS X上的情况，当使用Spotlight搜索菜单或Finder搜索窗口打开文件时。 这在文档打开时突出显示搜索项很有用。
        结果
        用于查找文件的搜索字词
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OpenFilesHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface OpenFilesHandler

  • public interface OpenFilesHandler
    当应用程序被要求打开文件列表时，通知实施者。
    从以下版本开始：
    9
    另请参见：
    Desktop.setOpenFileHandler(java.awt.desktop.OpenFilesHandler)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void openFiles​(OpenFilesEvent e)
      当应用程序被要求打开文件列表时调用。

    • 方法详细信息

      • openFiles

        void openFiles​(OpenFilesEvent e)
        当应用程序被要求打开文件列表时调用。
        参数
        e - 打开文件列表的请求，以及用于查找文件的搜索字词（如果有）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OpenURIEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class OpenURIEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.OpenURIEvent
  • All Implemented Interfaces:
    Serializable

    public final class OpenURIEvent
extends AppEvent
    事件发送时，应用程序被要求打开一个 URI 。
    从以下版本开始：
    9
    另请参见：
    OpenURIHandler.openURI(OpenURIEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      OpenURIEvent​(URI uri)
      构造一个 OpenURIEvent

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      URI getURI​()
      获取 URI该应用被要求打开

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • OpenURIEvent

        public OpenURIEvent​(URI uri)
        构造一个 OpenURIEvent
        参数
        uri - URI

    • 方法详细信息

      • getURI

        public URI getURI​()
        获取 URI的应用程序被要求打开
        结果
        URI
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OpenURIHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface OpenURIHandler

  • public interface OpenURIHandler
    当应用程序被要求打开一个URI时，通知一个实现者。
    从以下版本开始：
    9
    另请参见：
    Desktop.setOpenURIHandler(java.awt.desktop.OpenURIHandler)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void openURI​(OpenURIEvent e)
      当应用程序被要求打开一个 URI

    • 方法详细信息

      • openURI

        void openURI​(OpenURIEvent e)
        当应用程序被要求打开一个 URI
        参数
        e - 打开 URI的请求
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PreferencesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class PreferencesEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.PreferencesEvent
  • All Implemented Interfaces:
    Serializable

    public final class PreferencesEvent
extends AppEvent
    当请求应用程序打开其首选项窗口时发送事件。
    从以下版本开始：
    9
    另请参见：
    PreferencesHandler.handlePreferences(java.awt.desktop.PreferencesEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      PreferencesEvent​()
      构造一个 PreferencesEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PreferencesEvent

        public PreferencesEvent​()
        构造一个 PreferencesEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PreferencesHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface PreferencesHandler

  • public interface PreferencesHandler
    当应用程序被要求显示其首选项UI时，会通知实施者。
    从以下版本开始：
    9
    另请参见：
    Desktop.setPreferencesHandler(java.awt.desktop.PreferencesHandler)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void handlePreferences​(PreferencesEvent e)
      当应用程序被要求显示其首选项UI时调用。

    • 方法详细信息

      • handlePreferences

        void handlePreferences​(PreferencesEvent e)
        当应用程序被要求显示其首选项UI时调用。
        参数
        e - 显示偏好的请求。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrintFilesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class PrintFilesEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.FilesEvent
          • java.awt.desktop.PrintFilesEvent
  • All Implemented Interfaces:
    Serializable

    public final class PrintFilesEvent
extends FilesEvent
    当应用程序被要求打印文件列表时发送事件。
    从以下版本开始：
    9
    另请参见：
    PrintFilesHandler.printFiles(PrintFilesEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrintFilesEvent​(List<File> files)
      构造一个 PrintFilesEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.awt.desktop.FilesEvent

        getFiles

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrintFilesEvent

        public PrintFilesEvent​(List<File> files)
        构造一个 PrintFilesEvent
        参数
        files - files
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrintFilesHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface PrintFilesHandler

  • public interface PrintFilesHandler
    实施者可以响应打印应用程序注册处理的文档的请求。
    从以下版本开始：
    9
    另请参见：
    Desktop.setPrintFileHandler(java.awt.desktop.PrintFilesHandler)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void printFiles​(PrintFilesEvent e)
      当应用程序被要求打印文件列表时调用。

    • 方法详细信息

      • printFiles

        void printFiles​(PrintFilesEvent e)
        当应用程序被要求打印文件列表时调用。
        参数
        e - 打印文件列表的请求。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


QuitEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class QuitEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.QuitEvent
  • All Implemented Interfaces:
    Serializable

    public final class QuitEvent
extends AppEvent
    当应用程序被要求退出时发送事件。
    从以下版本开始：
    9
    另请参见：
    QuitHandler.handleQuitRequestWith(QuitEvent, QuitResponse) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      QuitEvent​()
      构造一个 QuitEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • QuitEvent

        public QuitEvent​()
        构造一个 QuitEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


QuitHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface QuitHandler

  • public interface QuitHandler
    执行者确定是否应该继续或取消退出此应用程序的请求。
    从以下版本开始：
    9
    另请参见：
    Desktop.setQuitHandler(java.awt.desktop.QuitHandler) ， Desktop.setQuitStrategy(java.awt.desktop.QuitStrategy)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void handleQuitRequestWith​(QuitEvent e, QuitResponse response)
      当应用程序被要求退出时调用。

    • 方法详细信息

      • handleQuitRequestWith

        void handleQuitRequestWith​(QuitEvent e,
                           QuitResponse response)
        当应用程序被要求退出时调用。 实现者必须调用要么QuitResponse.cancelQuit() ， QuitResponse.performQuit() ，或确保应用程序终止。 请求此应用程序退出的进程（或注销）将被阻止，直到处理QuitResponse 。 需要复杂UI关闭的应用程序可以从任何线程调用QuitResponse 。 在您回复初始请求之前，您的应用可能会被要求退出多次。 该处理器将被调用每次退出请求，并同QuitResponse对象传递，直到它被处理。 一旦使用， QuitResponse不能再用来改变决定。
        参数
        e - 退出此应用程序的请求。
        response - the one-shot response object used to cancel or proceed with the quit action.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


QuitResponse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface QuitResponse

  • public interface QuitResponse
    用于响应退出应用程序的请求。
    从以下版本开始：
    9
    另请参见：
    Desktop.setQuitHandler(java.awt.desktop.QuitHandler) ， QuitHandler ， Desktop.setQuitStrategy(java.awt.desktop.QuitStrategy)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void cancelQuit​()
      通知外部退出请求者用户已明确取消挂起的退出，并使应用程序运行。
      void performQuit​()
      通知外部退出请求者退出将进行，并执行默认值QuitStrategy 。

    • 方法详细信息

      • performQuit

        void performQuit​()
        通知外部退出请求者退出将进行，并执行默认值QuitStrategy 。

      • cancelQuit

        void cancelQuit​()
        Notifies the external quit requester that the user has explicitly canceled the pending quit, and leaves the application running. Note: this will cancel a pending log-out, restart, or shutdown.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


QuitStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Enum QuitStrategy

  • java.lang.Object
    • java.lang.Enum<QuitStrategy>
      • java.awt.desktop.QuitStrategy
  • All Implemented Interfaces:
    Serializable ， Comparable<QuitStrategy>

    public enum QuitStrategy
extends Enum<QuitStrategy>
    如果未启用“突发终止”，则用于关闭应用程序的策略。
    从以下版本开始：
    9
    另请参见：
    Desktop.setQuitHandler(java.awt.desktop.QuitHandler) ，
Desktop.setQuitStrategy(java.awt.desktop.QuitStrategy) ，
Desktop.enableSuddenTermination() ，
Desktop.disableSuddenTermination()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CLOSE_ALL_WINDOWS
      通过从后到左关闭每个窗口来关闭应用程序。
      NORMAL_EXIT
      通过拨打 System.exit(0)关闭应用程序。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static QuitStrategy valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static QuitStrategy[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NORMAL_EXIT

        public static final QuitStrategy NORMAL_EXIT
        通过拨打System.exit(0)关闭应用程序。 这是默认策略。

      • CLOSE_ALL_WINDOWS

        public static final QuitStrategy CLOSE_ALL_WINDOWS
        通过从后到左关闭每个窗口来关闭应用程序。

    • 方法详细信息

      • values

        public static QuitStrategy[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (QuitStrategy c : QuitStrategy.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static QuitStrategy valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ScreenSleepEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class ScreenSleepEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.ScreenSleepEvent
  • All Implemented Interfaces:
    Serializable

    public final class ScreenSleepEvent
extends AppEvent
    当系统显示器进入并退出省电睡眠时发送事件。
    从以下版本开始：
    9
    另请参见：
    ScreenSleepListener.screenAboutToSleep(ScreenSleepEvent) ， ScreenSleepListener.screenAwoke(ScreenSleepEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ScreenSleepEvent​()
      构造一个ScreenSleepEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ScreenSleepEvent

        public ScreenSleepEvent​()
        构造一个ScreenSleepEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ScreenSleepListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface ScreenSleepListener

  • All Superinterfaces:
    EventListener ， SystemEventListener

    public interface ScreenSleepListener
extends SystemEventListener
    当连接到系统的显示器进入省电睡眠时，实施者会收到通知。 此通知对于停止昂贵的动画或指示用户不再存在于网络服务中很有用。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void screenAboutToSleep​(ScreenSleepEvent e)
      当系统显示进入省电睡眠时调用。
      void screenAwoke​(ScreenSleepEvent e)
      当系统显示已经从省电睡眠唤醒时调用。

    • 方法详细信息

      • screenAboutToSleep

        void screenAboutToSleep​(ScreenSleepEvent e)
        当系统显示进入省电睡眠时调用。
        参数
        e - 屏幕睡眠事件

      • screenAwoke

        void screenAwoke​(ScreenSleepEvent e)
        当系统显示已经从省电睡眠唤醒时调用。
        参数
        e - 屏幕睡眠事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SystemEventListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface SystemEventListener

  • All Superinterfaces:
    EventListener
    All Known Subinterfaces:
    AppForegroundListener ， AppHiddenListener ， AppReopenedListener ， ScreenSleepListener ， SystemSleepListener ， UserSessionListener

    public interface SystemEventListener
extends EventListener
    所有事件监听器子类的公共接口。 实现者可以实现多个子类型，但只需要调用Desktop.addAppEventListener(SystemEventListener)来接收所有通知。
    从以下版本开始：
    9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SystemSleepEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class SystemSleepEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.SystemSleepEvent
  • All Implemented Interfaces:
    Serializable

    public final class SystemSleepEvent
extends AppEvent
    系统进入和退出省电休眠时发送的事件。
    从以下版本开始：
    9
    另请参见：
    SystemSleepListener.systemAboutToSleep(SystemSleepEvent) ， SystemSleepListener.systemAwoke(SystemSleepEvent) ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      SystemSleepEvent​()
      构造一个SystemSleepEvent

    • 方法摘要

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SystemSleepEvent

        public SystemSleepEvent​()
        构造一个SystemSleepEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SystemSleepListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface SystemSleepListener

  • All Superinterfaces:
    EventListener ， SystemEventListener

    public interface SystemSleepListener
extends SystemEventListener
    当系统进入睡眠状态，系统唤醒后，实施者会收到通知。 此通知对于在睡眠之前与网络服务断开连接或在睡眠期间如果网络配置已更改时重新建立连接非常有用。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void systemAboutToSleep​(SystemSleepEvent e)
      当系统即将睡觉时调用。
      void systemAwoke​(SystemSleepEvent e)
      系统唤醒后唤醒睡眠。

    • 方法详细信息

      • systemAboutToSleep

        void systemAboutToSleep​(SystemSleepEvent e)
        当系统即将睡觉时调用。 注意：在实际的系统休眠之前，此消息可能未被传送，并且可能在相应的唤醒发生后被处理。
        参数
        e - 系统睡眠事件

      • systemAwoke

        void systemAwoke​(SystemSleepEvent e)
        系统唤醒后唤醒睡眠。
        参数
        e - 系统睡眠事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UserSessionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Class UserSessionEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.desktop.AppEvent
        • java.awt.desktop.UserSessionEvent
  • All Implemented Interfaces:
    Serializable

    public final class UserSessionEvent
extends AppEvent
    用户会话更改时发送的事件。 一些系统可能提供用户会话更改的原因。
    从以下版本开始：
    9
    另请参见：
    UserSessionListener.userSessionActivated(UserSessionEvent) ， UserSessionListener.userSessionDeactivated(UserSessionEvent) ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  UserSessionEvent.Reason
      用户会话更改的可能原因的种类。

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      UserSessionEvent​(UserSessionEvent.Reason reason)
      构造一个 UserSessionEvent

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      UserSessionEvent.Reason getReason​()
      获取用户会话更改的原因。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UserSessionEvent

        public UserSessionEvent​(UserSessionEvent.Reason reason)
        构造一个 UserSessionEvent
        参数
        reason - 会话更改

    • 方法详细信息

      • getReason

        public UserSessionEvent.Reason getReason​()
        获取用户会话更改的原因。
        结果
        理由一个原因
        另请参见：
        UserSessionEvent.Reason.UNSPECIFIED ， UserSessionEvent.Reason.CONSOLE ， UserSessionEvent.Reason.REMOTE ， UserSessionEvent.Reason.LOCK
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UserSessionEvent.Reason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Enum UserSessionEvent.Reason

  • java.lang.Object
    • java.lang.Enum<UserSessionEvent.Reason>
      • java.awt.desktop.UserSessionEvent.Reason
  • All Implemented Interfaces:
    Serializable ， Comparable<UserSessionEvent.Reason>
    Enclosing class:
    UserSessionEvent

    public static enum UserSessionEvent.Reason
extends Enum<UserSessionEvent.Reason>
    用户会话更改的可能原因的种类。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CONSOLE
      会话已连接/断开连接到控制台终端。
      LOCK
      会话已被锁定/解锁。
      REMOTE
      会话已连接/断开连接到远程终端。
      UNSPECIFIED
      系统不提供会话更改的原因。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static UserSessionEvent.Reason valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static UserSessionEvent.Reason[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNSPECIFIED

        public static final UserSessionEvent.Reason UNSPECIFIED
        系统不提供会话更改的原因。

      • CONSOLE

        public static final UserSessionEvent.Reason CONSOLE
        会话已连接/断开连接到控制台终端。

      • REMOTE

        public static final UserSessionEvent.Reason REMOTE
        会话已连接/断开连接到远程终端。

      • LOCK

        public static final UserSessionEvent.Reason LOCK
        会话已被锁定/解锁。

    • 方法详细信息

      • values

        public static UserSessionEvent.Reason[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (UserSessionEvent.Reason c : UserSessionEvent.Reason.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static UserSessionEvent.Reason valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


UserSessionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.desktop

Interface UserSessionListener

  • All Superinterfaces:
    EventListener ， SystemEventListener

    public interface UserSessionListener
extends SystemEventListener
    当用户会话更改时，实现者会收到通知。 此通知对于停止昂贵的动画或指示用户不再存在于网络服务中很有用。 一些系统可能提供用户会话更改的原因。
    从以下版本开始：
    9
    另请参见：
    UserSessionEvent.Reason.UNSPECIFIED ， UserSessionEvent.Reason.CONSOLE ， UserSessionEvent.Reason.REMOTE ， UserSessionEvent.Reason.LOCK

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void userSessionActivated​(UserSessionEvent e)
      当用户会话切换到时被调用。
      void userSessionDeactivated​(UserSessionEvent e)
      当用户会话被关闭时调用。

    • 方法详细信息

      • userSessionDeactivated

        void userSessionDeactivated​(UserSessionEvent e)
        当用户会话被关闭时调用。
        参数
        e - 用户会话切换事件

      • userSessionActivated

        void userSessionActivated​(UserSessionEvent e)
        当用户会话切换到时被调用。
        参数
        e - 用户会话切换事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.desktop (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.desktop

  • Packages that use java.awt.desktop
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
  • Classes in java.awt.desktop used by java.awt
    Class 描述
    AboutHandler
    当应用程序被要求显示对话框时，实现者会收到通知。
    OpenFilesHandler
    当应用程序被要求打开文件列表时，通知实施者。
    OpenURIHandler
    当应用程序被要求打开一个URI时，通知一个实现者。
    PreferencesHandler
    当应用程序被要求显示其首选项UI时，会通知实施者。
    PrintFilesHandler
    实施者可以响应打印应用程序注册处理的文档的请求。
    QuitHandler
    执行者确定是否应该继续或取消退出此应用程序的请求。
    QuitStrategy
    如果未启用“突发终止”，则用于关闭应用程序的策略。
    SystemEventListener
    所有事件监听器子类的公共接口。
  • Classes in java.awt.desktop used by java.awt.desktop
    Class 描述
    AboutEvent
    当应用程序被要求打开窗口时发送事件。
    AppEvent
    AppEvent被发送到安装在Desktop上的监听器和处理程序。
    AppForegroundEvent
    当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。
    AppHiddenEvent
    应用程序隐藏或显示时发送的事件。
    AppReopenedEvent
    当应用程序被要求重新打开时发送事件。
    FilesEvent
    辅助事件包含文件列表。
    OpenFilesEvent
    当应用程序被要求打开文件列表时发送事件。
    OpenURIEvent
    当应用程序被要求打开一个 URI时发送的事件。
    PreferencesEvent
    当请求应用程序打开其首选项窗口时发送事件。
    PrintFilesEvent
    当应用程序被要求打印文件列表时发送事件。
    QuitEvent
    当应用程序被要求退出时发送事件。
    QuitResponse
    用于响应退出应用程序的请求。
    QuitStrategy
    如果未启用“突发终止”，则用于关闭应用程序的策略。
    ScreenSleepEvent
    当系统显示器进入并退出省电睡眠时发送事件。
    SystemEventListener
    所有事件监听器子类的公共接口。
    SystemSleepEvent
    系统进入和退出省电休眠时发送的事件。
    UserSessionEvent
    用户会话更改时发送的事件。
    UserSessionEvent.Reason
    用户会话更改的可能原因的种类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.AboutEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.AboutEvent

  • Packages that use AboutEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of AboutEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type AboutEvent
      Modifier and Type 方法 描述
      void AboutHandler.handleAbout​(AboutEvent e)
      当应用程序被要求显示其对话框时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.AppEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.AppEvent

  • Packages that use AppEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of AppEvent in java.awt.desktop

      Subclasses of AppEvent in java.awt.desktop
      Modifier and Type Class 描述
      class  AboutEvent
      当应用程序被要求打开窗口时发送事件。
      class  AppForegroundEvent
      当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。
      class  AppHiddenEvent
      应用程序隐藏或显示时发送的事件。
      class  AppReopenedEvent
      当应用程序被要求重新打开时发送事件。
      class  FilesEvent
      辅助事件包含文件列表。
      class  OpenFilesEvent
      当应用程序被要求打开文件列表时发送事件。
      class  OpenURIEvent
      当应用程序被要求打开一个 URI时发送的事件。
      class  PreferencesEvent
      当请求应用程序打开其首选项窗口时发送事件。
      class  PrintFilesEvent
      当应用程序被要求打印文件列表时发送事件。
      class  QuitEvent
      当应用程序被要求退出时发送事件。
      class  ScreenSleepEvent
      当系统显示器进入并退出省电睡眠时发送事件。
      class  SystemSleepEvent
      系统进入和退出省电休眠时发送的事件。
      class  UserSessionEvent
      用户会话更改时发送的事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.AppForegroundEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.AppForegroundEvent

  • Packages that use AppForegroundEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of AppForegroundEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type AppForegroundEvent
      Modifier and Type 方法 描述
      void AppForegroundListener.appMovedToBackground​(AppForegroundEvent e)
      当应用程序成为后台应用程序并且另一个应用程序成为前台应用程序时调用。
      void AppForegroundListener.appRaisedToForeground​(AppForegroundEvent e)
      当应用程序成为前台应用程序时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.AppHiddenEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.AppHiddenEvent

  • Packages that use AppHiddenEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of AppHiddenEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type AppHiddenEvent
      Modifier and Type 方法 描述
      void AppHiddenListener.appHidden​(AppHiddenEvent e)
      被称为应用程序被隐藏。
      void AppHiddenListener.appUnhidden​(AppHiddenEvent e)
      当隐藏的应用程序再次显示（但不一定被带到前台）时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.AppReopenedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.AppReopenedEvent

  • Packages that use AppReopenedEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of AppReopenedEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type AppReopenedEvent
      Modifier and Type 方法 描述
      void AppReopenedListener.appReopened​(AppReopenedEvent e)
      当应用程序重新打开时调用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.FilesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.FilesEvent

  • Packages that use FilesEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of FilesEvent in java.awt.desktop

      Subclasses of FilesEvent in java.awt.desktop
      Modifier and Type Class 描述
      class  OpenFilesEvent
      当应用程序被要求打开文件列表时发送事件。
      class  PrintFilesEvent
      当应用程序被要求打印文件列表时发送事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.OpenFilesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.OpenFilesEvent

  • Packages that use OpenFilesEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of OpenFilesEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type OpenFilesEvent
      Modifier and Type 方法 描述
      void OpenFilesHandler.openFiles​(OpenFilesEvent e)
      当应用程序被要求打开文件列表时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.OpenURIEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.OpenURIEvent

  • Packages that use OpenURIEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of OpenURIEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type OpenURIEvent
      Modifier and Type 方法 描述
      void OpenURIHandler.openURI​(OpenURIEvent e)
      当应用程序被要求打开一个 URI
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.PreferencesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.PreferencesEvent

  • Packages that use PreferencesEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of PreferencesEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type PreferencesEvent
      Modifier and Type 方法 描述
      void PreferencesHandler.handlePreferences​(PreferencesEvent e)
      当应用程序被要求显示其首选项UI时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.PrintFilesEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.PrintFilesEvent

  • Packages that use PrintFilesEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of PrintFilesEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type PrintFilesEvent
      Modifier and Type 方法 描述
      void PrintFilesHandler.printFiles​(PrintFilesEvent e)
      当应用程序被要求打印文件列表时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.QuitEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.QuitEvent

  • Packages that use QuitEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of QuitEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type QuitEvent
      Modifier and Type 方法 描述
      void QuitHandler.handleQuitRequestWith​(QuitEvent e, QuitResponse response)
      当应用程序被要求退出时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.QuitStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.QuitStrategy

  • Packages that use QuitStrategy
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of QuitStrategy in java.awt

      Methods in java.awt with parameters of type QuitStrategy
      Modifier and Type 方法 描述
      void Desktop.setQuitStrategy​(QuitStrategy strategy)
      设置用于退出此应用程序的默认策略。

    • Uses of QuitStrategy in java.awt.desktop

      Methods in java.awt.desktop that return QuitStrategy
      Modifier and Type 方法 描述
      static QuitStrategy QuitStrategy.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static QuitStrategy[] QuitStrategy.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.ScreenSleepEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.ScreenSleepEvent

  • Packages that use ScreenSleepEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of ScreenSleepEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type ScreenSleepEvent
      Modifier and Type 方法 描述
      void ScreenSleepListener.screenAboutToSleep​(ScreenSleepEvent e)
      当系统显示进入省电睡眠时调用。
      void ScreenSleepListener.screenAwoke​(ScreenSleepEvent e)
      当系统显示已经从省电睡眠唤醒时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.SystemSleepEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.SystemSleepEvent

  • Packages that use SystemSleepEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of SystemSleepEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type SystemSleepEvent
      Modifier and Type 方法 描述
      void SystemSleepListener.systemAboutToSleep​(SystemSleepEvent e)
      当系统即将睡觉时调用。
      void SystemSleepListener.systemAwoke​(SystemSleepEvent e)
      系统唤醒后唤醒睡眠。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.UserSessionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.UserSessionEvent

  • Packages that use UserSessionEvent
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of UserSessionEvent in java.awt.desktop

      Methods in java.awt.desktop with parameters of type UserSessionEvent
      Modifier and Type 方法 描述
      void UserSessionListener.userSessionActivated​(UserSessionEvent e)
      当用户会话切换到时被调用。
      void UserSessionListener.userSessionDeactivated​(UserSessionEvent e)
      当用户会话被关闭时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.desktop.UserSessionEvent.Reason (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.desktop.UserSessionEvent.Reason

  • Packages that use UserSessionEvent.Reason
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of UserSessionEvent.Reason in java.awt.desktop

      Methods in java.awt.desktop that return UserSessionEvent.Reason
      Modifier and Type 方法 描述
      UserSessionEvent.Reason UserSessionEvent.getReason​()
      获取用户会话更改的原因。
      static UserSessionEvent.Reason UserSessionEvent.Reason.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static UserSessionEvent.Reason[] UserSessionEvent.Reason.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in java.awt.desktop with parameters of type UserSessionEvent.Reason
      Constructor 描述
      UserSessionEvent​(UserSessionEvent.Reason reason)
      构造一个 UserSessionEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.AboutHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.AboutHandler

  • Packages that use AboutHandler
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of AboutHandler in java.awt

      Methods in java.awt with parameters of type AboutHandler
      Modifier and Type 方法 描述
      void Desktop.setAboutHandler​(AboutHandler aboutHandler)
      安装一个处理程序来显示应用程序的自定义关于窗口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.AppForegroundListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.AppForegroundListener

No usage of java.awt.desktop.AppForegroundListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.AppHiddenListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.AppHiddenListener

No usage of java.awt.desktop.AppHiddenListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.AppReopenedListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.AppReopenedListener

No usage of java.awt.desktop.AppReopenedListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.OpenFilesHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.OpenFilesHandler

  • Packages that use OpenFilesHandler
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of OpenFilesHandler in java.awt

      Methods in java.awt with parameters of type OpenFilesHandler
      Modifier and Type 方法 描述
      void Desktop.setOpenFileHandler​(OpenFilesHandler openFileHandler)
      安装在应用程序被要求打开文件列表时通知的处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.OpenURIHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.OpenURIHandler

  • Packages that use OpenURIHandler
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of OpenURIHandler in java.awt

      Methods in java.awt with parameters of type OpenURIHandler
      Modifier and Type 方法 描述
      void Desktop.setOpenURIHandler​(OpenURIHandler openURIHandler)
      安装在请求应用程序打开URL时通知的处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.PreferencesHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.PreferencesHandler

  • Packages that use PreferencesHandler
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PreferencesHandler in java.awt

      Methods in java.awt with parameters of type PreferencesHandler
      Modifier and Type 方法 描述
      void Desktop.setPreferencesHandler​(PreferencesHandler preferencesHandler)
      安装一个处理程序来显示应用程序的自定义首选项窗口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.PrintFilesHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.PrintFilesHandler

  • Packages that use PrintFilesHandler
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of PrintFilesHandler in java.awt

      Methods in java.awt with parameters of type PrintFilesHandler
      Modifier and Type 方法 描述
      void Desktop.setPrintFileHandler​(PrintFilesHandler printFileHandler)
      安装在应用程序被要求打印文件列表时通知的处理程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.QuitHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.QuitHandler

  • Packages that use QuitHandler
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of QuitHandler in java.awt

      Methods in java.awt with parameters of type QuitHandler
      Modifier and Type 方法 描述
      void Desktop.setQuitHandler​(QuitHandler quitHandler)
      安装处理程序，确定应用程序是否应该退出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.QuitResponse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.QuitResponse

  • Packages that use QuitResponse
    软件包 描述
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of QuitResponse in java.awt.desktop

      Methods in java.awt.desktop with parameters of type QuitResponse
      Modifier and Type 方法 描述
      void QuitHandler.handleQuitRequestWith​(QuitEvent e, QuitResponse response)
      当应用程序被要求退出时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.ScreenSleepListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.ScreenSleepListener

No usage of java.awt.desktop.ScreenSleepListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.SystemEventListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.SystemEventListener

  • Packages that use SystemEventListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。

    • Uses of SystemEventListener in java.awt

      Methods in java.awt with parameters of type SystemEventListener
      Modifier and Type 方法 描述
      void Desktop.addAppEventListener​(SystemEventListener listener)
      添加子类型SystemEventListener以监听本机系统的通知。
      void Desktop.removeAppEventListener​(SystemEventListener listener)
      删除子类型SystemEventListener以监听本机系统的通知。

    • Uses of SystemEventListener in java.awt.desktop

      Subinterfaces of SystemEventListener in java.awt.desktop
      Modifier and Type 接口 描述
      interface  AppForegroundListener
      当应用程序成为前台应用程序，何时不再是前台应用程序，实施者会收到通知。
      interface  AppHiddenListener
      当应用程序被用户隐藏或显示时，将通知实施者。
      interface  AppReopenedListener
      当应用程序被要求再次打开时，实施者会收到通知。
      interface  ScreenSleepListener
      当连接到系统的显示器进入省电睡眠时，实施者会收到通知。
      interface  SystemSleepListener
      当系统进入睡眠状态，系统唤醒后，实施者会收到通知。
      interface  UserSessionListener
      当用户会话更改时，实现者会收到通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.SystemSleepListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.SystemSleepListener

No usage of java.awt.desktop.SystemSleepListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.desktop.UserSessionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.desktop.UserSessionListener

No usage of java.awt.desktop.UserSessionListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Autoscroll (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Interface Autoscroll

  • public interface Autoscroll
    在DnD操作期间，用户可能希望将操作的主题放在用户当前不可见的可滚动GUI控件的区域上。

    在这种情况下，希望GUI控件检测到这一点并进行滚动操作，以使使用者可见的遮蔽区域。 此功能称为自动滚动。

    如果GUI控件既是一个活动的DropTarget也是可滚动的，它可以通过实现该界面从DnD系统接收用户自动滚动手势的通知。

    用户通过将拖动光标Component在Component的边界区域（称为“自动滚动区域”）预定的时间段内，由用户启动自动滚屏手势，这将导致向Component重复滚动请求，直到拖动Cursor恢复其动作。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void autoscroll​(Point cursorLocn)
      通知 Component自动滚屏
      Insets getAutoscrollInsets​()
      此方法返回描述相对于实现组件几何的自动滚动区域或边框的 Insets 。

    • 方法详细信息

      • getAutoscrollInsets

        Insets getAutoscrollInsets​()
        该方法返回描述自动滚动区域或相对于实现组件几何的边框的Insets 。

        这个值是由读取一次DropTarget在拖动进入Cursor到相关Component 。

        结果
        插图

      • autoscroll

        void autoscroll​(Point cursorLocn)
        通知 Component自动滚屏
        参数
        cursorLocn - A Point指示触发此操作的光标的位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DnDConstants (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DnDConstants

  • java.lang.Object
    • java.awt.dnd.DnDConstants

  • public final class DnDConstants
extends Object
    此类包含表示由拖放操作执行的操作类型的常量值。
    从以下版本开始：
    1.2

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ACTION_COPY
      一个 int代表一个“复制”动作。
      static int ACTION_COPY_OR_MOVE
      代表“复制”或“移动”动作的 int 。
      static int ACTION_LINK
      一个 int代表一个“链接”动作。
      static int ACTION_MOVE
      一个 int代表一个“移动”动作。
      static int ACTION_NONE
      一个 int表示没有动作。
      static int ACTION_REFERENCE
      代表“参考”动作的 int （ACTION_LINK的同义词）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ACTION_NONE

        @Native
public static final int ACTION_NONE
        一个 int表示无动作。
        另请参见：
        Constant Field Values

      • ACTION_COPY

        @Native
public static final int ACTION_COPY
        代表“复制”动作的 int 。
        另请参见：
        Constant Field Values

      • ACTION_MOVE

        @Native
public static final int ACTION_MOVE
        一个 int代表一个“移动”动作。
        另请参见：
        Constant Field Values

      • ACTION_COPY_OR_MOVE

        @Native
public static final int ACTION_COPY_OR_MOVE
        代表“复制”或“移动”动作的 int 。
        另请参见：
        Constant Field Values

      • ACTION_LINK

        @Native
public static final int ACTION_LINK
        代表“链接”动作的int 。 链接动词在许多（如果不是全部）本地DnD平台中都可以找到，并且LINK语义的实际解释是平台和应用程序相关的。 广义而言，语义是“不要复制，或移动操作数，而是创建一个引用”。 定义“引用”的含义是引入歧义的地方。 提供动词是为了完整性，但不推荐在逻辑上不同的应用程序之间进行DnD操作，因为操作语义的误解可能会导致用户混淆的结果。
        另请参见：
        Constant Field Values

      • ACTION_REFERENCE

        @Native
public static final int ACTION_REFERENCE
        代表“参考”动作的 int （ACTION_LINK的同义词）。
        另请参见：
        Constant Field Values
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragGestureEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragGestureEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.dnd.DragGestureEvent
  • All Implemented Interfaces:
    Serializable

    public class DragGestureEvent
extends EventObject
    甲DragGestureEvent被传递给DragGestureListener的dragGestureRecognized（）方法时的具体DragGestureRecognizer检测到已经发生了一个平台相关的拖动启动手势的Component它正在跟踪。 任何DragGestureEvent实例的action字段应采用以下值之一：
    • DnDConstants.ACTION_COPY
    • DnDConstants.ACTION_MOVE
    • DnDConstants.ACTION_LINK
    分配与上述不同的值将导致未指定的行为。
    另请参见：
    DragGestureRecognizer ， DragGestureListener ， DragSource ， DnDConstants ， Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragGestureEvent​(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
      构造一个 DragGestureEvent由给定对象 DragGestureRecognizer实例激发此事件中， act表示用户的首选操作参数，一个 ori参数指示拖动原点，和一个 List组成动作（事件 evs参数）。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Component getComponent​()
      返回 Component与此 DragGestureEvent相关联。
      int getDragAction​()
      返回表示用户选择的动作的 int 。
      Point getDragOrigin​()
      返回 Point中的坐标 Component在开始拖动。
      DragSource getDragSource​()
      返回 DragSource 。
      DragGestureRecognizer getSourceAsDragGestureRecognizer​()
      返回源为 DragGestureRecognizer 。
      InputEvent getTriggerEvent​()
      返回触发手势的初始事件。
      Iterator<InputEvent> iterator​()
      返回一个包含手势的事件的 Iterator 。
      void startDrag​(Cursor dragCursor, Transferable transferable)
      开始拖动操作，给出 Cursor这个拖动操作，而 Transferable表示这个拖动操作的源数据。
      void startDrag​(Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始拖动给出初始的 Cursor显示， Transferable对象和 DragSourceListener使用。
      void startDrag​(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl)
      启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。
      Object[] toArray​()
      返回包含拖动手势的事件的 Object数组。
      Object[] toArray​(Object[] array)
      返回包含拖动手势的事件数组。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DragGestureEvent

        public DragGestureEvent​(DragGestureRecognizer dgr,
                        int act,
                        Point ori,
                        List<? extends InputEvent> evs)
        构造一个 DragGestureEvent由给定对象 DragGestureRecognizer实例激发此事件中， act表示用户的首选操作参数，一个 ori参数指示拖动原点，和一个 List组成动作（事件 evs参数）。
        参数
        dgr - DragGestureRecognizer发射这个事件
        act - 用户的首选操作。 有关允许值的信息，请参阅DragGestureEvent的类描述
        ori - 拖曳的起源
        evs - 构成手势的事件的 List
        异常
        IllegalArgumentException - 如果任何参数等于 null
        IllegalArgumentException - 如果act参数不符合DragGestureEvent的类描述中给出的值
        另请参见：
        DnDConstants

    • 方法详细信息

      • getSourceAsDragGestureRecognizer

        public DragGestureRecognizer getSourceAsDragGestureRecognizer​()
        返回源为 DragGestureRecognizer 。
        结果
        来源为 DragGestureRecognizer

      • getComponent

        public Component getComponent​()
        返回 Component与此相关 DragGestureEvent 。
        结果
        组件

      • getDragSource

        public DragSource getDragSource​()
        返回 DragSource 。
        结果
        DragSource

      • getDragOrigin

        public Point getDragOrigin​()
        返回 Point中的坐标 Component在开始拖动。
        结果
        拖动起始于组件坐标的点。

      • iterator

        public Iterator<InputEvent> iterator​()
        为包含手势的事件返回 Iterator 。
        结果
        一个包含手势的事件的迭代器

      • toArray

        public Object[] toArray​()
        返回包含拖动手势的事件的 Object数组。
        结果
        包括该姿势的事件的阵列

      • toArray

        public Object[] toArray​(Object[] array)
        返回包含拖动手势的事件数组。
        参数
        array - EventObject子（类型）的数组
        结果
        包括该姿势的事件的阵列

      • getDragAction

        public int getDragAction​()
        返回表示用户选择的动作的 int 。
        结果
        由用户选择的动作

      • getTriggerEvent

        public InputEvent getTriggerEvent​()
        返回触发手势的初始事件。
        结果
        在手势序列中的第一个“触发”事件

      • startDrag

        public void startDrag​(Cursor dragCursor,
                      Transferable transferable)
               throws InvalidDnDOperationException
        开始拖动操作，给出Cursor用于此拖动操作， Transferable表示此拖动操作的源数据。
        如果指定了一个null Cursor则不会抛出任何异常，并使用默认拖动光标。
        如果null Transferable指定NullPointerException将被抛出。
        参数
        dragCursor - 这个拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的更多详细信息，请参阅DragSourceContext
        transferable - 表示此拖动操作的源数据的 Transferable 。
        异常
        InvalidDnDOperationException - 如果拖放系统无法启动拖动操作，或者如果用户尝试在现有拖动操作仍在执行时启动拖动。
        NullPointerException - 如果 Transferable是 null
        从以下版本开始：
        1.4

      • startDrag

        public void startDrag​(Cursor dragCursor,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
        开始拖动给出初始的 Cursor显示， Transferable对象和 DragSourceListener使用。
        参数
        dragCursor - 用于此拖动操作的初始Cursor或默认光标处理的null ; 有关拖放中光标处理机制的更多详细信息，请参阅DragSourceContext
        transferable - 源的可转移
        dsl - 源的DragSourceListener
        异常
        InvalidDnDOperationException - 如果拖放系统无法启动拖动操作，或者如果用户尝试在现有拖动操作仍在执行时启动拖动。

      • startDrag

        public void startDrag​(Cursor dragCursor,
                      Image dragImage,
                      Point imageOffset,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
        启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。
        参数
        dragCursor - 这个拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的详细信息，请参阅DragSourceContext
        dragImage - 源的dragImage
        imageOffset - dragImage的偏移量
        transferable - 源的可转移
        dsl - 源的DragSourceListener
        异常
        InvalidDnDOperationException - if the Drag and Drop system is unable to initiate a drag operation, or if the user attempts to start a drag while an existing drag operation is still executing.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragGestureListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Interface DragGestureListener

  • All Superinterfaces:
    EventListener

    public interface DragGestureListener
extends EventListener
    用于接收拖动手势事件的侦听器界面。 此界面用于拖动手势识别实现。 有关如何注册侦听器接口的详细信息，请参阅DragGestureRecognizer的规范。 在识别拖动手势时， DragGestureRecognizer调用此接口的dragGestureRecognized()方法并传递一个DragGestureEvent 。
    另请参见：
    DragGestureRecognizer ， DragGestureEvent ， DragSource

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dragGestureRecognized​(DragGestureEvent dge)
      DragGestureRecognizer当 DragGestureRecognizer检测到与平台相关的拖动启动手势时调用此方法。

    • 方法详细信息

      • dragGestureRecognized

        void dragGestureRecognized​(DragGestureEvent dge)
        当DragGestureRecognizer检测到平台相关的拖动启动手势时，这个方法由DragGestureRecognizer调用。 要启动拖放操作，如果合适的话， startDrag()的方法DragGestureEvent已被调用。
        参数
        dge - 描述刚刚发生的手势的 DragGestureEvent
        另请参见：
        DragGestureRecognizer, DragGestureEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragGestureRecognizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragGestureRecognizer

  • java.lang.Object
    • java.awt.dnd.DragGestureRecognizer
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    MouseDragGestureRecognizer

    public abstract class DragGestureRecognizer
extends Object
implements Serializable
    DragGestureRecognizer是一个用于规范平台相关侦听器的抽象基类，可以与特定的Component相关联，以便识别平台相关的拖动启动手势。

    适当DragGestureRecognizer子类的实例被从所获得的DragSource与特定相关Component ，或者从Toolkit对象通过其createDragGestureRecognizer()方法。

    一旦DragGestureRecognizer与特定的Component相关联，它将在该Component上注册适当的侦听器接口，以便跟踪传递给Component的输入事件。

    一旦DragGestureRecognizer识别关于事件的序列Component作为拖动启动动作时，将通知单播DragGestureListener通过调用其gestureRecognized()方法。

    当混凝土DragGestureRecognizer实例检测的拖拽在启动动作Component与其相关联，它触发一个DragGestureEvent到DragGestureListener单播事件源上用于注册DragGestureListener事件。 此DragGestureListener负责导致关联的DragSource启动拖放操作（如果适用）。

    另请参见：
    DragGestureListener ， DragGestureEvent ， DragSource ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Component component
      该 Component与此 DragGestureRecognizer相关联。
      protected DragGestureListener dragGestureListener
      该 DragGestureListener与此 DragGestureRecognizer相关联。
      protected DragSource dragSource
      该 DragSource与此 DragGestureRecognizer相关联。
      protected ArrayList<InputEvent> events
      DragGestureRecognizer “识别”作为触发拖动的“手势”的事件列表（顺序）。
      protected int sourceActions
      一个 int表示此拖放操作中使用的操作类型。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DragGestureRecognizer​(DragSource ds)
      构造一个新的 DragGestureRecognizer给出了在这个拖放操作中使用的 DragSource 。
      protected DragGestureRecognizer​(DragSource ds, Component c)
      构造一个新的 DragGestureRecognizer给定 DragSource用于此拖放操作，而 Component这 DragGestureRecognizer应该“观察”拖动启动手势。
      protected DragGestureRecognizer​(DragSource ds, Component c, int sa)
      构造一个新的 DragGestureRecognizer给定 DragSource将被用于这个拖放操作， Component这个 DragGestureRecognizer应该“观察”拖动启动手势，以及这个拖放操作支持的动作。
      protected DragGestureRecognizer​(DragSource ds, Component c, int sa, DragGestureListener dgl)
      构造一个新的 DragGestureRecognizer给予 DragSource以在此拖放操作中使用， Component此 DragGestureRecognizer应该“观察”用于拖动启动手势，此拖动操作支持的操作，以及 DragGestureListener通知一次已经检测到拖动启动手势。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void addDragGestureListener​(DragGestureListener dgl)
      注册新的 DragGestureListener 。
      protected void appendEvent​(InputEvent awtie)
      通过此识别器在组件上注册的侦听器应记录被识别为通过该API组成拖放启动手势的一系列事件的一部分的所有事件。
      protected void fireDragGestureRecognized​(int dragAction, Point p)
      通知DragGestureListener发生拖放启动手势。
      Component getComponent​()
      该方法返回 Component ，由 DragGestureRecognizer进行“观察”，用于拖动启动手势。
      DragSource getDragSource​()
      这个方法返回 DragSource这个 DragGestureRecognizer将会用来处理拖放操作。
      int getSourceActions​()
      此方法返回一个表示此拖放操作将支持的操作类型的int。
      InputEvent getTriggerEvent​()
      此方法返回启动拖放操作的一系列事件中的第一个事件。
      protected abstract void registerListeners​()
      注册该DragGestureRecognizer的Listeners与Component子类必须覆盖此方法
      void removeDragGestureListener​(DragGestureListener dgl)
      取消注册当前的DragGestureListener
      void resetRecognizer​()
      重置识别器，如果其当前识别手势，则忽略它。
      void setComponent​(Component c)
      将DragGestureRecognizer与registerListeners（）和unregisterListeners（）相关联的组件设置为适当的副作用。
      void setSourceActions​(int actions)
      此方法为此拖放操作设置允许的源拖动操作。
      protected abstract void unregisterListeners​()
      使用Component子类取消注册此DragGestureRecognizer的侦听器必须覆盖此方法

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • dragSource

        protected DragSource dragSource
        该 DragSource与此 DragGestureRecognizer相关联。

      • component

        protected Component component
        该 Component与此 DragGestureRecognizer相关联。

      • dragGestureListener

        protected transient DragGestureListener dragGestureListener
        DragGestureListener与此 DragGestureRecognizer相关联。

      • sourceActions

        protected int sourceActions
        一个表示此拖放操作中使用的操作类型的 int 。

      • events

        protected ArrayList<InputEvent> events
        DragGestureRecognizer “识别”作为触发拖动的“手势”的事件列表（按顺序）。

    • 构造方法详细信息

      • DragGestureRecognizer

        protected DragGestureRecognizer​(DragSource ds,
                                Component c,
                                int sa,
                                DragGestureListener dgl)
        构造一个新的 DragGestureRecognizer给予 DragSource用于这个拖放操作， Component这个 DragGestureRecognizer应该“观察”拖动启动手势，这个拖放操作支持的动作，以及 DragGestureListener通知一次已经检测到拖动启动手势。
        参数
        ds - DragSource这个 DragGestureRecognizer将用于处理拖放操作
        c - Component这个DragGestureRecognizer应该“观察”事件流，以便检测拖动启动手势。 如果该值为null ，则DragGestureRecognizer与任何Component不相关。
        sa -设定的（逻辑OR） DnDConstants ，该拖放操作将支持
        dgl - 在 DragGestureRecognizer到拖动手势时通知的 DragGestureRecognizer
        异常
        IllegalArgumentException - 如果ds是 null 。

      • DragGestureRecognizer

        protected DragGestureRecognizer​(DragSource ds,
                                Component c,
                                int sa)
        构造新的 DragGestureRecognizer给定 DragSource将用于此拖放操作， Component这 DragGestureRecognizer应该“观察”拖动启动手势，以及此拖放操作支持的操作。
        参数
        ds - DragSource这个 DragGestureRecognizer将用于处理拖放操作
        c - Component这个DragGestureRecognizer应该“观察”事件流，以便检测拖动启动手势。 如果该值为null ，则DragGestureRecognizer与任何Component不相关。
        sa -设定的（逻辑OR） DnDConstants ，该拖放操作将支持
        异常
        IllegalArgumentException - 如果ds是 null 。

      • DragGestureRecognizer

        protected DragGestureRecognizer​(DragSource ds,
                                Component c)
        构造一个新的 DragGestureRecognizer给出 DragSource用于此拖放操作，而 Component这个 DragGestureRecognizer应该“观察”拖动启动手势。
        参数
        ds - DragSource这个 DragGestureRecognizer将用于处理拖放操作
        c - Component这个DragGestureRecognizer应该“观察”事件流，以便检测拖动启动手势。 如果该值为null ，则DragGestureRecognizer与任何Component不相关。
        异常
        IllegalArgumentException - 如果ds是 null 。

      • DragGestureRecognizer

        protected DragGestureRecognizer​(DragSource ds)
        构造一个新的 DragGestureRecognizer给予 DragSource用于此拖放操作。
        参数
        ds - DragSource这个 DragGestureRecognizer将用于处理拖放操作
        异常
        IllegalArgumentException - 如果ds是 null 。

    • 方法详细信息

      • registerListeners

        protected abstract void registerListeners​()
        注册该DragGestureRecognizer的Listeners与Component子类必须覆盖此方法

      • unregisterListeners

        protected abstract void unregisterListeners​()
        使用Component子类取消注册此DragGestureRecognizer的侦听器必须覆盖此方法

      • getDragSource

        public DragSource getDragSource​()
        这个方法返回 DragSource这个 DragGestureRecognizer将会用来处理拖放操作。
        结果
        DragSource

      • getComponent

        public Component getComponent​()
        该方法返回 Component为 DragGestureRecognizer进行拖动启动手势的“观察”。
        结果
        与DragGestureRecognizer相关联的组件

      • setComponent

        public void setComponent​(Component c)
        将DragGestureRecognizer与registerListeners（）和unregisterListeners（）相关联的组件设置为适当的副作用。
        参数
        c - Component或 null

      • getSourceActions

        public int getSourceActions​()
        此方法返回一个表示此拖放操作将支持的操作类型的int。
        结果
        当前允许的来源动作

      • setSourceActions

        public void setSourceActions​(int actions)
        此方法为此拖放操作设置允许的源拖动操作。
        参数
        actions - 允许的源拖动动作

      • getTriggerEvent

        public InputEvent getTriggerEvent​()
        此方法返回启动拖放操作的一系列事件中的第一个事件。
        结果
        触发拖动手势的初始事件

      • resetRecognizer

        public void resetRecognizer​()
        重置识别器，如果其当前识别手势，则忽略它。

      • addDragGestureListener

        public void addDragGestureListener​(DragGestureListener dgl)
                            throws TooManyListenersException
        注册新的 DragGestureListener 。
        参数
        dgl - DragGestureListener要注册这个 DragGestureRecognizer 。
        异常
        TooManyListenersException - 如果已经添加了一个 DragGestureListener 。

      • removeDragGestureListener

        public void removeDragGestureListener​(DragGestureListener dgl)
        取消注册当前的DragGestureListener
        参数
        dgl - DragGestureListener注销的 DragGestureRecognizer
        异常
        IllegalArgumentException - 如果dgl不是（等于）当前注册的 DragGestureListener 。

      • fireDragGestureRecognized

        protected void fireDragGestureRecognized​(int dragAction,
                                         Point p)
        通知DragGestureListener发生拖放启动手势。 然后重置识别器的状态。
        参数
        dragAction - 用户手势最初选择的动作
        p - 手势起源的点（在组件坐标中）

      • appendEvent

        protected void appendEvent​(InputEvent awtie)
        通过此识别器在组件上注册的侦听器应记录被识别为通过该API组成拖放启动手势的一系列事件的一部分的所有事件。

        该方法由DragGestureRecognizer实现使用，可以将InputEvent子类（它认为是构成拖放操作的一系列事件中的一个）添加到此DragGestureRecognizer内部维护的事件数组中。

        参数
        awtie -在InputEvent添加到这个DragGestureRecognizer的内部事件的数组。 请注意， null不是有效值，将被忽略。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragSource

  • java.lang.Object
    • java.awt.dnd.DragSource
  • All Implemented Interfaces:
    Serializable

    public class DragSource
extends Object
implements Serializable
    DragSource是负责启动拖放操作的实体，可用于多种情况：
    • 该JVM的生命周期为每个JVM 1个默认实例。
    • 每个潜在的Drag Initiator对象（例如TextField）的实例为1个实例。 [实施依赖]
    • 特定Component每个实例1，或与GUI中的Component实例相关联的应用程序特定对象。 [实施依赖]
    • 一些其他任意关联。 [实施依赖]
    一旦DragSource获得，一个DragGestureRecognizer也应获得的关联DragSource与特定Component 。

    用户手势的初步解释以及随后的拖动操作开始是实施Component的责任，通常由DragGestureRecognizer实现。

    当拖动手势发生时，将DragSource的startDrag（）方法，以便处理用户的导航手势和传递拖放协议通知。 A DragSource只允许在任何一个时间进行单次拖放操作，并且通过抛出一个IllegalDnDOperationException直到现在的操作完成之前拒绝任何进一步的startDrag（）请求。

    startDrag（）方法调用createDragSourceContext（）方法来实例化一个合适的DragSourceContext ，并将DragSourceContextPeer与之相关联。

    如果拖放系统由于某种原因无法启动拖动操作，则startDrag（）方法将引发一个java.awt.dnd.InvalidDnDOperationException来表示这种情况。 通常，当底层平台系统不处于启动拖动状态或指定的参数无效时，会抛出此异常。

    请注意，在拖动期间，在拖动操作开始时由源公开的操作集可能不会更改，直到操作完成。 在DragSource的操作期间，操作是DragSource 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Cursor DefaultCopyDrop
      使用默认值 Cursor进行复制操作，指示当前允许丢弃。
      static Cursor DefaultCopyNoDrop
      与复制操作一起使用的默认 Cursor ，表示当前不允许删除。
      static Cursor DefaultLinkDrop
      缺省 Cursor ，用于链接操作，表示当前允许丢弃。
      static Cursor DefaultLinkNoDrop
      默认使用 Cursor链接操作，指示当前不允许丢弃。
      static Cursor DefaultMoveDrop
      默认的 Cursor与移动操作一起使用，指示当前允许丢弃。
      static Cursor DefaultMoveNoDrop
      默认 Cursor ，与移动操作一起使用，表示当前不允许丢弃。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragSource​()
      创建一个新的 DragSource 。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addDragSourceListener​(DragSourceListener dsl)
      将指定的 DragSourceListener添加到此 DragSource以在使用此 DragSource启动的拖动操作期间接收拖动源事件。
      void addDragSourceMotionListener​(DragSourceMotionListener dsml)
      将指定的 DragSourceMotionListener添加到此 DragSource以在使用此 DragSource启动的拖动操作期间接收拖动运动事件。
      DragGestureRecognizer createDefaultDragGestureRecognizer​(Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer实现的默认抽象子类 DragGestureRecognizer这个 DragSource ，并设置指定 Component和 DragGestureListener新创建的对象上。
      <T extends DragGestureRecognizer>
      T             		createDragGestureRecognizer​(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer ，实现指定的抽象子类 DragGestureRecognizer ，并在新创建的对象上设置指定的 Component和 DragGestureListener 。
      protected DragSourceContext createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      static DragSource getDefaultDragSource​()
      获取与底层平台相关联的 DragSource对象。
      DragSourceListener[] getDragSourceListeners​()
      获得 DragSourceListener注册的所有 DragSource 。
      DragSourceMotionListener[] getDragSourceMotionListeners​()
      获取 DragSourceMotionListener注册的所有 DragSource 。
      static int getDragThreshold​()
      返回拖动手势运动阈值。
      FlavorMap getFlavorMap​()
      此方法为该 FlavorMap返回 DragSource 。
      <T extends EventListener>
      T[]             		getListeners​(Class<T> listenerType)
      获取当前注册的所有对象为 FooListener s在此 DragSource 。
      static boolean isDragImageSupported​()
      报告是否在底层平台上提供拖动 Image支持。
      void removeDragSourceListener​(DragSourceListener dsl)
      删除指定 DragSourceListener从这个 DragSource 。
      void removeDragSourceMotionListener​(DragSourceMotionListener dsml)
      删除指定 DragSourceMotionListener从这个 DragSource 。
      void startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。
      void startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
      void startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener ，和 FlavorMap 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DefaultCopyDrop

        public static final Cursor DefaultCopyDrop
        使用默认值Cursor进行复制操作，指示当前允许丢弃。 null如果GraphicsEnvironment.isHeadless()返回true 。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DefaultMoveDrop

        public static final Cursor DefaultMoveDrop
        默认的Cursor与移动操作一起使用，指示当前允许丢弃。 null如果GraphicsEnvironment.isHeadless()返回true 。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DefaultLinkDrop

        public static final Cursor DefaultLinkDrop
        默认Cursor ，用于指示当前允许丢弃的链接操作。 null如果GraphicsEnvironment.isHeadless()返回true 。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DefaultCopyNoDrop

        public static final Cursor DefaultCopyNoDrop
        使用默认值Cursor进行复制操作，指示当前不允许放置。 null如果GraphicsEnvironment.isHeadless()返回true 。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DefaultMoveNoDrop

        public static final Cursor DefaultMoveNoDrop
        使用默认值Cursor进行移动操作，指示当前不允许丢弃。 null如果GraphicsEnvironment.isHeadless()返回true 。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DefaultLinkNoDrop

        public static final Cursor DefaultLinkNoDrop
        缺省Cursor ，用于指示当前不允许下拉列表的链接操作。 null如果GraphicsEnvironment.isHeadless()返回true 。
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 构造方法详细信息

      • DragSource

        public DragSource​()
           throws HeadlessException
        创建一个新的 DragSource 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • getDefaultDragSource

        public static DragSource getDefaultDragSource​()
        获取与底层平台相关联的 DragSource对象。
        结果
        平台DragSource
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • isDragImageSupported

        public static boolean isDragImageSupported​()
        报告是否在底层平台上提供拖动 Image支持。
        结果
        如果在此平台上提供拖动图像支持

      • startDrag

        public void startDrag​(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Image dragImage,
                      Point imageOffset,
                      Transferable transferable,
                      DragSourceListener dsl,
                      FlavorMap flavorMap)
               throws InvalidDnDOperationException
        开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
        参数
        trigger - 发起拖动的 DragGestureEvent
        dragCursor - 这个拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的详细信息，请参阅DragSourceContext
        dragImage - 要拖动的图像或 null
        imageOffset - Image起点与触发瞬间 Cursor热点的偏移
        transferable - 拖动的主题数据
        dsl - DragSourceListener
        flavorMap - 要使用的 FlavorMap ，或 null
        异常
        InvalidDnDOperationException - 如果拖放系统无法启动拖动操作，或者如果用户尝试在现有拖动操作仍在执行时启动拖动

      • startDrag

        public void startDrag​(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Transferable transferable,
                      DragSourceListener dsl,
                      FlavorMap flavorMap)
               throws InvalidDnDOperationException
        开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
        参数
        trigger - 发起拖动的 DragGestureEvent
        dragCursor - 这个拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的详细信息，请参阅DragSourceContext
        transferable - 拖动的主题数据
        dsl - DragSourceListener
        flavorMap - 要使用的 FlavorMap或 null
        异常
        InvalidDnDOperationException - 如果拖放系统无法启动拖动操作，或者如果用户尝试在现有拖动操作仍在执行时启动拖动

      • startDrag

        public void startDrag​(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Image dragImage,
                      Point dragOffset,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
        开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
        参数
        trigger - 发起拖动的 DragGestureEvent
        dragCursor - 这个拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的详细信息，请参阅DragSourceContext
        dragImage - Image拖动或 null
        dragOffset - Image起始 Cursor触发瞬间 Cursor热点的偏移
        transferable - 拖动的主题数据
        dsl - DragSourceListener
        异常
        InvalidDnDOperationException - 如果拖放系统无法启动拖动操作，或者如果用户尝试在现有拖动操作仍在执行时启动拖动

      • startDrag

        public void startDrag​(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
        开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。
        参数
        trigger - 发起拖动的 DragGestureEvent
        dragCursor - 这个拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的详细信息，请参阅DragSourceContext类
        transferable - 拖动的主题数据
        dsl - DragSourceListener
        异常
        InvalidDnDOperationException - 如果拖放系统无法启动拖动操作，或者如果用户尝试在现有拖动操作仍在执行时启动拖动

      • createDragSourceContext

        protected DragSourceContext createDragSourceContext​(DragGestureEvent dgl,
                                                    Cursor dragCursor,
                                                    Image dragImage,
                                                    Point imageOffset,
                                                    Transferable t,
                                                    DragSourceListener dsl)
        创建DragSourceContext来处理当前的拖动操作。

        要结合一个新的DragSourceContext子类，子类DragSource并覆盖此方法。

        如果dragImage为null ，则不会使用任何图像表示对此拖动操作的反馈拖动，但不会抛出NullPointerException 。

        如果dsl为null ，则不会在创建的DragSourceContext注册拖动源侦听DragSourceContext ，但不会抛出NullPointerException 。

        参数
        dgl - 触发了拖动的 DragGestureEvent
        dragCursor - 用于此拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的详细信息，请参阅DragSourceContext类
        dragImage - Image拖动或 null
        imageOffset - Image起始点在触发时刻光标热点的偏移量
        t - 拖动的主题数据
        dsl - DragSourceListener
        结果
        DragSourceContext
        异常
        NullPointerException - 如果 dscp是 null
        NullPointerException - 如果 dgl是 null
        NullPointerException - 如果 dragImage不是 null和 imageOffset是 null
        NullPointerException - 如果 t是 null
        IllegalArgumentException - 如果与触发事件相关联的 Component是 null 。
        IllegalArgumentException -如果 DragSource触发事件为 null 。
        IllegalArgumentException - 如果触发事件的拖动操作是 DnDConstants.ACTION_NONE 。
        IllegalArgumentException - 如果与触发事件相关联的 DragGestureRecognizer的源操作等于 DnDConstants.ACTION_NONE 。

      • getFlavorMap

        public FlavorMap getFlavorMap​()
        此方法为该 FlavorMap返回 DragSource 。
        结果
        该 FlavorMap为这 DragSource

      • createDragGestureRecognizer

        public <T extends DragGestureRecognizer> T createDragGestureRecognizer​(Class<T> recognizerAbstractClass,
                                                                       Component c,
                                                                       int actions,
                                                                       DragGestureListener dgl)
        创建一个新的 DragGestureRecognizer ，实现指定的抽象子类为 DragGestureRecognizer ，并在新创建的对象上设置指定的 Component和 DragGestureListener 。
        参数类型
        T - 要创建的类型 DragGestureRecognizer
        参数
        recognizerAbstractClass - 请求的抽象类型
        actions - 允许的源拖动操作
        c - Component目标
        dgl - 要通知的 DragGestureListener
        结果
        新的 DragGestureRecognizer或 null如果 Toolkit.createDragGestureRecognizer方法没有实现可用于请求的 DragGestureRecognizer子类并返回 null

      • createDefaultDragGestureRecognizer

        public DragGestureRecognizer createDefaultDragGestureRecognizer​(Component c,
                                                                int actions,
                                                                DragGestureListener dgl)
        创建一个新的DragGestureRecognizer实现的默认抽象子类DragGestureRecognizer这个DragSource ，并设置指定Component和DragGestureListener新创建的对象上。 对于这个DragSource ，默认值是MouseDragGestureRecognizer 。
        参数
        c - 识别器的 Component目标
        actions - 允许的源操作
        dgl - 要通知的 DragGestureListener
        结果
        新的 DragGestureRecognizer或 null如果 Toolkit.createDragGestureRecognizer方法没有实现可用于请求的 DragGestureRecognizer子类，并返回 null

      • addDragSourceListener

        public void addDragSourceListener​(DragSourceListener dsl)
        将指定的DragSourceListener添加到此DragSource以在使用此DragSource启动的拖动操作期间接收拖动源事件。 如果指定了一个null监听器，则不会采取任何操作，也不会抛出异常。
        参数
        dsl - 要添加的 DragSourceListener
        从以下版本开始：
        1.4
        另请参见：
        removeDragSourceListener(java.awt.dnd.DragSourceListener) ， getDragSourceListeners()

      • removeDragSourceListener

        public void removeDragSourceListener​(DragSourceListener dsl)
        删除指定DragSourceListener从这个DragSource 。 如果指定了一个null监听器，则不会采取任何操作，也不会抛出任何异常。 如果参数指定的侦听器以前未添加到此DragSource ，则不会采取任何操作，也不会抛出任何异常。
        参数
        dsl - 要删除的 DragSourceListener
        从以下版本开始：
        1.4
        另请参见：
        addDragSourceListener(java.awt.dnd.DragSourceListener) ， getDragSourceListeners()

      • getDragSourceListeners

        public DragSourceListener[] getDragSourceListeners​()
        获取所有 DragSourceListener注册此 DragSource 。
        结果
        所有这些 DragSource的 DragSourceListener s或一个空数组，如果没有这样的听众当前注册
        从以下版本开始：
        1.4
        另请参见：
        addDragSourceListener(java.awt.dnd.DragSourceListener) ， removeDragSourceListener(java.awt.dnd.DragSourceListener)

      • addDragSourceMotionListener

        public void addDragSourceMotionListener​(DragSourceMotionListener dsml)
        将指定的DragSourceMotionListener添加到此DragSource以在使用此DragSource启动的拖动操作期间接收拖动运动事件。 如果指定了一个null监听器，则不会采取任何操作，也不会抛出任何异常。
        参数
        dsml - 要添加的 DragSourceMotionListener
        从以下版本开始：
        1.4
        另请参见：
        removeDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener) ， getDragSourceMotionListeners()

      • removeDragSourceMotionListener

        public void removeDragSourceMotionListener​(DragSourceMotionListener dsml)
        删除指定DragSourceMotionListener从这个DragSource 。 如果指定了一个null监听器，则不会采取任何操作，也不会抛出任何异常。 如果由参数指定的侦听器以前未添加到此DragSource ，则不会执行任何操作，也不会抛出任何异常。
        参数
        dsml - 要删除的 DragSourceMotionListener
        从以下版本开始：
        1.4
        另请参见：
        addDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener) ， getDragSourceMotionListeners()

      • getDragSourceMotionListeners

        public DragSourceMotionListener[] getDragSourceMotionListeners​()
        获取所有 DragSourceMotionListener注册此 DragSource 。
        结果
        所有这些 DragSource的 DragSourceMotionListener s或一个空数组，如果没有这样的听众当前注册
        从以下版本开始：
        1.4
        另请参见：
        addDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener) ， removeDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener)

      • getListeners

        public <T extends EventListener> T[] getListeners​(Class<T> listenerType)
        获取当前注册的所有对象为FooListener s在此DragSource 。 FooListener是使用addFooListener方法注册的。
        参数类型
        T - 侦听器对象的类型
        参数
        listenerType - 所请求的听众的类型; 此参数应指定从java.util.EventListener下降的接口
        结果
        在这个 DragSource上注册为 FooListener的所有对象的数组，如果没有添加这样的侦听器，则是一个空数组
        异常
        ClassCastException - 如果 listenerType没有指定实现 java.util.EventListener的类或接口
        从以下版本开始：
        1.4
        另请参见：
        getDragSourceListeners() ， getDragSourceMotionListeners()

      • getDragThreshold

        public static int getDragThreshold​()
        返回拖动手势运动阈值。 拖动手势运动阈值定义了MouseDragGestureRecognizer的推荐行为。

        如果系统属性awt.dnd.drag.threshold设置为正整数，则此方法返回系统属性的值; 否则如果相关的桌面属性可用并且由Java平台的实现支持，则此方法返回该属性的值; 否则此方法返回一些默认值。 相关的桌面属性可以使用java.awt.Toolkit.getDesktopProperty("DnD.gestureMotionThreshold")进行查询。

        结果
        拖动手势运动阈值
        从以下版本开始：
        1.5
        另请参见：
        MouseDragGestureRecognizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSourceAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragSourceAdapter

  • java.lang.Object
    • java.awt.dnd.DragSourceAdapter
  • All Implemented Interfaces:
    DragSourceListener ， DragSourceMotionListener ， EventListener

    public abstract class DragSourceAdapter
extends Object
implements DragSourceListener, DragSourceMotionListener
    用于接收拖动源事件的抽象适配器类。 这个类中的方法是空的。 此类只能作为创建侦听器对象的方便。

    扩展此类以创建一个DragSourceEvent监听器并覆盖感兴趣事件的方法。 （如果您实现了DragSourceListener接口，则必须定义其中的所有方法。此抽象类为它们定义了空方法，因此您只需定义关心的事件的方法。）

    使用扩展类创建一个侦听器对象，然后使用DragSource注册它。 当拖动进入，移过或退出一个放置点，放置操作改变时，并且当拖动结束，在收听对象中的相关方法被调用，并且DragSourceEvent被传递给它。

    落点与以前的相关dragEnter()如果最新调用调用 dragEnter()该适配器上对应于放置点，并没有跟随dragExit()调用该适配器上。

    从以下版本开始：
    1.4
    另请参见：
    DragSourceEvent ， DragSourceListener ， DragSourceMotionListener

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragSourceAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dragDropEnd​(DragSourceDropEvent dsde)
      调用此方法来表示拖放操作完成。
      void dragEnter​(DragSourceDragEvent dsde)
      称为光标的热点进入平台依赖的放置站点。
      void dragExit​(DragSourceEvent dse)
      称为光标的热点退出平台相关的放置站点。
      void dragMouseMoved​(DragSourceDragEvent dsde)
      在拖动操作期间鼠标移动时调用。
      void dragOver​(DragSourceDragEvent dsde)
      称为光标的热点在平台相关的放置站点上移动。
      void dropActionChanged​(DragSourceDragEvent dsde)
      当用户修改了放置手势时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DragSourceAdapter

        public DragSourceAdapter​()

    • 方法详细信息

      • dragEnter

        public void dragEnter​(DragSourceDragEvent dsde)
        称为光标的热点进入平台依赖的放置站点。 当所有以下条件为真时，将调用此方法：
        • 光标的热点进入平台依赖的放置站点的可操作部分。
        • 投放站点处于活动状态。
        • 拖放站点接受拖动。
        Specified by:
        dragEnter在接口 DragSourceListener
        参数
        dsde - DragSourceDragEvent

      • dragOver

        public void dragOver​(DragSourceDragEvent dsde)
        称为光标的热点在平台相关的放置站点上移动。 当所有以下条件为真时，将调用此方法：
        • 游标的热点已经移动，但仍然与与之前的dragEnter（）调用相关联的放置站点的可操作部分相交。
        • 投放站点仍然活跃。
        • 拖放站点接受拖动。
        Specified by:
        dragOver在接口 DragSourceListener
        参数
        dsde - DragSourceDragEvent

      • dragMouseMoved

        public void dragMouseMoved​(DragSourceDragEvent dsde)
        在拖动操作期间鼠标移动时调用。
        Specified by:
        dragMouseMoved在接口 DragSourceMotionListener
        参数
        dsde - DragSourceDragEvent

      • dropActionChanged

        public void dropActionChanged​(DragSourceDragEvent dsde)
        当用户修改了放置手势时调用。 当用户正在交互的输入设备的状态发生变化时，将调用此方法。 这样的设备通常是用户正在交互的鼠标按钮或键盘修改器。
        Specified by:
        dropActionChanged在接口 DragSourceListener
        参数
        dsde - DragSourceDragEvent

      • dragExit

        public void dragExit​(DragSourceEvent dse)
        称为光标的热点退出平台相关的放置站点。 当以下任一条件为真时，将调用此方法：
        • 光标的热点不再与与之前的dragEnter（）调用相关联的放置站点的可操作部分相交。
        要么
        • 与之前的dragEnter（）调用相关联的丢弃站点不再处于活动状态。
        要么
        • 与之前的dragEnter（）调用相关联的丢弃站点已经拒绝了该拖动。
        Specified by:
        dragExit在接口 DragSourceListener
        参数
        dse - DragSourceEvent

      • dragDropEnd

        public void dragDropEnd​(DragSourceDropEvent dsde)
        调用此方法来表示拖放操作完成。 所述的getDropSuccess（）方法DragSourceDropEvent可用于确定终止状态。 getDropAction（）方法返回选择要应用于放置操作的放置站点的操作。 一旦这个方法完成，当前的DragSourceContext和相关的资源变得无效。
        Specified by:
        dragDropEnd在接口 DragSourceListener
        参数
        dsde - DragSourceDropEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSourceContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragSourceContext

  • java.lang.Object
    • java.awt.dnd.DragSourceContext
  • All Implemented Interfaces:
    DragSourceListener ， DragSourceMotionListener ， Serializable ， EventListener

    public class DragSourceContext
extends Object
implements DragSourceListener, DragSourceMotionListener, Serializable
    DragSourceContext类负责管理拖放协议的发起方。 特别地，它负责管理拖动事件通知给DragSourceListeners和DragSourceMotionListeners ，并提供表示拖动操作的源数据的Transferable 。

    请注意， DragSourceContext本身实现了DragSourceListener和DragSourceMotionListener接口。 这是为了允许由DragSource创建的平台对等体（ DragSourceContextPeer实例）通知正在进行的操作中的状态更改的DragSourceContext 。 这允许DragSourceContext对象自身插入平台和由拖动操作的启动器提供的侦听器之间。

    默认情况下， DragSourceContext根据拖放操作的当前状态设置光标。 例如，如果用户选择了the move action ，并且指针在接受移动动作的目标上，则显示默认移动光标。 当指针位于不接受传输的区域上时，将显示默认的“不丢弃”光标。

    当通过setCursor(java.awt.Cursor)方法设置自定义光标时，此默认处理机制将被禁用。 当默认处理被禁用时，通过监听DragSource事件并调用setCursor()方法，开发人员有责任将光标保持最新。 或者，您可以通过提供DragSource和DragSourceContext类的自定义实现来提供自定义游标行为。

    从以下版本开始：
    1.2
    另请参见：
    DragSourceListener ， DragSourceMotionListener ， DnDConstants ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected static int CHANGED
      一个 int由updateCurrentCursor（使用）的指示用户操作已经改变。
      protected static int DEFAULT
      一个 int由updateCurrentCursor（）使用，表示 Cursor应该更改为默认值（无丢弃） Cursor 。
      protected static int ENTER
      一个 int ）由updateCurrentCursor（用来指示 Cursor已进入 DropTarget 。
      protected static int OVER
      一个 int由updateCurrentCursor使用（）指示所述 Cursor是在 DropTarget 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragSourceContext​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
      从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addDragSourceListener​(DragSourceListener dsl)
      添加 DragSourceListener这个 DragSourceContext如果一个尚未加入。
      void dragDropEnd​(DragSourceDropEvent dsde)
      致电 dragDropEnd在 DragSourceListener注册了这个 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDropEvent 。
      void dragEnter​(DragSourceDragEvent dsde)
      致电 dragEnter在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
      void dragExit​(DragSourceEvent dse)
      致电 dragExit在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceEvent 。
      void dragMouseMoved​(DragSourceDragEvent dsde)
      致电 dragMouseMoved在 DragSourceMotionListener注册与 DragSource相关联的这个 DragSourceContext ，他们通过了指定的 DragSourceDragEvent 。
      void dragOver​(DragSourceDragEvent dsde)
      致电 dragOver在 DragSourceListener注册该 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
      void dropActionChanged​(DragSourceDragEvent dsde)
      致电 dropActionChanged在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
      Component getComponent​()
      返回 Component与此 DragSourceContext相关联。
      Cursor getCursor​()
      返回当前自定义拖动 Cursor 。
      DragSource getDragSource​()
      返回 DragSource ，实例化了这个 DragSourceContext 。
      int getSourceActions​()
      返回 DnDConstants的按位掩码，表示与此 DragSourceContext相关联的拖动操作的拖动源支持的放置操作集。
      Transferable getTransferable​()
      返回 Transferable与此相关 DragSourceContext 。
      DragGestureEvent getTrigger​()
      返回最初触发拖动的 DragGestureEvent 。
      void removeDragSourceListener​(DragSourceListener dsl)
      删除指定 DragSourceListener从这个 DragSourceContext 。
      void setCursor​(Cursor c)
      将此拖动操作的自定义光标设置为指定的 Cursor 。
      void transferablesFlavorsChanged​()
      通知对等方， Transferable的 DataFlavor已更改。
      protected void updateCurrentCursor​(int sourceAct, int targetAct, int status)
      如果默认拖动光标行为处于活动状态，则此方法将为拖动源支持的指定操作，放置目标操作和状态设置默认拖动光标，否则此方法不执行任何操作。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT

        protected static final int DEFAULT
        由updateCurrentCursor（）使用的一个 int ，表示 Cursor应该更改为默认值（不下降） Cursor 。
        另请参见：
        Constant Field Values

      • ENTER

        protected static final int ENTER
        由updateCurrentCursor（）使用的一个 int ，表示该 Cursor已经输入了一个 DropTarget 。
        另请参见：
        Constant Field Values

      • OVER

        protected static final int OVER
        一个 int由updateCurrentCursor使用（）指示所述 Cursor是在 DropTarget 。
        另请参见：
        Constant Field Values

      • CHANGED

        protected static final int CHANGED
        一个 int由updateCurrentCursor（使用）的指示用户操作已经改变。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DragSourceContext

        public DragSourceContext​(DragGestureEvent trigger,
                         Cursor dragCursor,
                         Image dragImage,
                         Point offset,
                         Transferable t,
                         DragSourceListener dsl)
        从名为DragSource ，该构造函数创建一个新DragSourceContext给出的DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的DragSourceListener 。
        如果DragSourceContextPeer是null NullPointerException被抛出。
        如果DragGestureEvent是null NullPointerException被抛出。
        如果Cursor为null不会引发异常，并为此拖动操作激活默认拖动光标行为。
        如果Image是null没有异常抛出。
        如果Image不是null并且偏移是null NullPointerException被抛出。
        如果Transferable是null NullPointerException被抛出。
        如果DragSourceListener是null没有异常抛出。
        参数
        trigger - 触发事件
        dragCursor - 这个拖动操作的初始Cursor或默认光标处理的null ; 有关拖放时光标处理机制的详细信息，请参阅class level documentation
        dragImage - Image拖（或 null ）
        offset - 触发事件瞬间图像源与热点的偏移
        t - Transferable
        dsl - DragSourceListener
        异常
        IllegalArgumentException - 如果与触发事件相关联的 Component是 null 。
        IllegalArgumentException -如果 DragSource触发事件为 null 。
        IllegalArgumentException - 如果触发事件的拖动操作是 DnDConstants.ACTION_NONE 。
        IllegalArgumentException - 如果与触发事件相关联的 DragGestureRecognizer的源操作等于 DnDConstants.ACTION_NONE 。
        NullPointerException - 如果dscp，trigger或t为空，或者dragImage为非空，并且offset为null

    • 方法详细信息

      • getDragSource

        public DragSource getDragSource​()
        返回 DragSource认为这个实例 DragSourceContext 。
        结果
        该 DragSource实例化了这个 DragSourceContext

      • getComponent

        public Component getComponent​()
        返回 Component与此相关 DragSourceContext 。
        结果
        Component开始拖动

      • getTrigger

        public DragGestureEvent getTrigger​()
        返回最初触发拖动的 DragGestureEvent 。
        结果
        触发拖动的事件

      • getSourceActions

        public int getSourceActions​()
        返回 DnDConstants的按位掩码，表示与此 DragSourceContext相关联的拖动操作的拖动源支持的放置操作集。
        结果
        拖动源支持的拖放操作

      • setCursor

        public void setCursor​(Cursor c)
        将此拖动操作的自定义光标设置为指定的Cursor 。 如果指定的Cursor为null ，则为此拖动操作启用默认拖动光标行为，否则将被禁用。
        参数
        c - 用于此拖动操作的初始Cursor ，或用于默认光标处理的null ; 有关拖放时光标处理的更多详细信息，请参阅class level documentation

      • getCursor

        public Cursor getCursor​()
        返回当前自定义拖动 Cursor 。
        结果
        当前自定义拖动 Cursor ，如果设置否则返回 null 。
        另请参见：
        setCursor(java.awt.Cursor)

      • addDragSourceListener

        public void addDragSourceListener​(DragSourceListener dsl)
                           throws TooManyListenersException
        添加DragSourceListener这个DragSourceContext如果一个尚未加入。 如果一个DragSourceListener已经存在，这个方法会抛出一个TooManyListenersException 。
        参数
        dsl - 要添加的DragSourceListener 。 请注意，虽然不禁止null ，但它是不可接受的参数。
        异常
        TooManyListenersException - 如果已经添加了 DragSourceListener

      • removeDragSourceListener

        public void removeDragSourceListener​(DragSourceListener dsl)
        删除指定 DragSourceListener从这个 DragSourceContext 。
        参数
        dsl - 要删除的DragSourceListener ; 请注意，虽然不禁止null ，但它是不可接受的参数

      • transferablesFlavorsChanged

        public void transferablesFlavorsChanged​()
        通知对方， Transferable的 DataFlavor已更改。

      • dragEnter

        public void dragEnter​(DragSourceDragEvent dsde)
        致电 dragEnter在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
        Specified by:
        dragEnter在接口 DragSourceListener
        参数
        dsde - DragSourceDragEvent

      • dragOver

        public void dragOver​(DragSourceDragEvent dsde)
        致电 dragOver在 DragSourceListener注册该 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
        Specified by:
        dragOver在接口 DragSourceListener
        参数
        dsde - DragSourceDragEvent

      • dragExit

        public void dragExit​(DragSourceEvent dse)
        致电 dragExit在 DragSourceListener注册了这个 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceEvent 。
        Specified by:
        dragExit在接口 DragSourceListener
        参数
        dse - DragSourceEvent

      • dropActionChanged

        public void dropActionChanged​(DragSourceDragEvent dsde)
        致电 dropActionChanged在 DragSourceListener注册了这个 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
        Specified by:
        dropActionChanged在接口 DragSourceListener
        参数
        dsde - DragSourceDragEvent

      • dragDropEnd

        public void dragDropEnd​(DragSourceDropEvent dsde)
        致电 dragDropEnd在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceDropEvent 。
        Specified by:
        dragDropEnd在接口 DragSourceListener
        参数
        dsde - DragSourceDropEvent

      • dragMouseMoved

        public void dragMouseMoved​(DragSourceDragEvent dsde)
        电话 dragMouseMoved在 DragSourceMotionListener注册与 DragSource相关联的这个 DragSourceContext ，他们通过了指定的 DragSourceDragEvent 。
        Specified by:
        dragMouseMoved接口 DragSourceMotionListener
        参数
        dsde - DragSourceDragEvent
        从以下版本开始：
        1.4

      • getTransferable

        public Transferable getTransferable​()
        返回 Transferable与此 DragSourceContext相关联。
        结果
        Transferable

      • updateCurrentCursor

        protected void updateCurrentCursor​(int sourceAct,
                                   int targetAct,
                                   int status)
        如果默认拖动光标行为处于活动状态，则此方法将为拖动源支持的指定操作，放置目标操作和状态设置默认拖动光标，否则此方法不执行任何操作。
        参数
        sourceAct - 拖动源支持的操作
        targetAct - 放下目标动作
        status -一个字段 DEFAULT ， ENTER ， OVER ， CHANGED
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSourceDragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragSourceDragEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.dnd.DragSourceEvent
        • java.awt.dnd.DragSourceDragEvent
  • All Implemented Interfaces:
    Serializable

    public class DragSourceDragEvent
extends DragSourceEvent
    该DragSourceDragEvent从交付DragSourceContextPeer ，通过DragSourceContext ，到DragSourceListener与注册DragSourceContext和与其关联DragSource 。

    DragSourceDragEvent报告目标放置操作和反映拖动操作的当前状态的用户放置操作。

    目标放置操作是DnDConstants中的一个，表示当拖动源支持该拖放操作时，当前放置目标所选择的放置操作，或DnDConstants.ACTION_NONE如果拖放源不支持此放置操作）。

    用户放置操作取决于拖动源支持的放置操作和用户选择的放置操作。 用户可以在拖动操作期间按修改键来选择放置操作：

      Ctrl + Shift -> ACTION_LINK
   Ctrl         -> ACTION_COPY
   Shift        -> ACTION_MOVE
    如果用户选择放置操作，则用户放置操作是DnDConstants中的一个，表示当拖动源支持该放置操作时所选择的放置操作，或DnDConstants.ACTION_NONE如果拖放源不支持此放置操作。

    如果用户没有选drop操作，一组DnDConstants表示设置拖动源支持的放置动作中搜索DnDConstants.ACTION_MOVE ，然后DnDConstants.ACTION_COPY ，然后为DnDConstants.ACTION_LINK和用户drop操作是找到的第一个常量。 如果没有找到常量，则用户删除操作是DnDConstants.ACTION_NONE 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragSourceDragEvent​(DragSourceContext dsc, int dropAction, int action, int modifiers)
      构造一个 DragSourceDragEvent 。
      DragSourceDragEvent​(DragSourceContext dsc, int dropAction, int action, int modifiers, int x, int y)
      构造一个 DragSourceDragEvent给定指定的 DragSourceContext ，用户放置操作，目标放置操作，修饰符和坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getDropAction​()
      此方法返回目标放置操作与拖动源支持的放置操作集合的逻辑交集。
      int getGestureModifiers​()
      该方法返回表示与用户手势相关联的输入设备修饰符的当前状态的 int 。
      int getGestureModifiersEx​()
      该方法返回表示与用户手势相关联的输入设备扩展修饰符的当前状态的 int 。
      int getTargetActions​()
      此方法返回目标放置操作。
      int getUserAction​()
      此方法返回用户放置操作。

      • Methods inherited from class java.awt.dnd.DragSourceEvent

        getDragSourceContext, getLocation, getX, getY

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DragSourceDragEvent

        public DragSourceDragEvent​(DragSourceContext dsc,
                           int dropAction,
                           int action,
                           int modifiers)
        构造一个DragSourceDragEvent 。 该类通常由DragSourceContextPeer实例化，而不是直接由客户端代码实例化。 此DragSourceDragEvent的坐标未指定，因此getLocation将为此事件返回null 。

        参数dropAction和action应该是表示单个动作的DnDConstants中的一个。 参数modifiers应该是旧的java.awt.event.InputEvent.*_MASK常量的按位掩码或扩展的java.awt.event.InputEvent.*_DOWN_MASK常量的按位掩码。 此构造方法不抛出无效任何异常dropAction ， action和modifiers 。

        参数
        dsc - 用于管理此事件的通知的 DragSourceContext 。
        dropAction - 用户删除操作。
        action - 目标下降动作。
        modifiers - 在事件期间修改器键（shift，ctrl，alt，meta）应该使用扩展_DOWN_MASK或旧_MASK修饰符，但是两个模型不应该在一个事件中混合。 优选使用延伸改性剂。
        异常
        IllegalArgumentException - 如果 dsc是 null 。
        另请参见：
        InputEvent ， DragSourceEvent.getLocation()

      • DragSourceDragEvent

        public DragSourceDragEvent​(DragSourceContext dsc,
                           int dropAction,
                           int action,
                           int modifiers,
                           int x,
                           int y)
        构造一个DragSourceDragEvent给定指定的DragSourceContext ，用户放置操作，目标放置操作，修饰符和坐标。

        参数dropAction和action应该是表示单个动作的DnDConstants中的一个。 参数modifiers应该是旧的java.awt.event.InputEvent.*_MASK常数的按位掩码或扩展的java.awt.event.InputEvent.*_DOWN_MASK常量的按位掩码。 此构造方法不抛出无效任何异常dropAction ， action和modifiers 。

        参数
        dsc - 与此事件有关的 DragSourceContext 。
        dropAction - 用户删除操作。
        action - 目标删除操作。
        modifiers - 在事件期间修改器键（shift，ctrl，alt，meta）应该使用扩展_DOWN_MASK或旧_MASK修饰符，但是两个模型不应该在一个事件中混合。 优选使用延伸改性剂。
        x - 光标位置的水平坐标
        y - 光标位置的垂直坐标
        异常
        IllegalArgumentException - 如果 dsc是 null 。
        从以下版本开始：
        1.4
        另请参见：
        InputEvent

    • 方法详细信息

      • getTargetActions

        public int getTargetActions​()
        此方法返回目标放置操作。
        结果
        目标放下动作。

      • getGestureModifiers

        public int getGestureModifiers​()
        该方法返回表示与用户手势相关联的输入设备修饰符的当前状态的int 。 通常这些将是鼠标按钮或键盘修饰符。

        如果传递给构造函数的modifiers无效，则此方法不会更改它们。

        结果
        输入设备修改器的当前状态

      • getGestureModifiersEx

        public int getGestureModifiersEx​()
        该方法返回表示与用户手势相关联的输入设备扩展修饰符的当前状态的int 。 见InputEvent.getModifiersEx()

        如果传递给构造函数的modifiers无效，则此方法不会更改它们。

        结果
        输入设备的当前状态扩展修改器
        从以下版本开始：
        1.4

      • getUserAction

        public int getUserAction​()
        此方法返回用户放置操作。
        结果
        用户放下动作。

      • getDropAction

        public int getDropAction​()
        此方法返回目标放置操作与拖动源支持的放置操作集合的逻辑交集。
        结果
        目标放置操作与拖动源支持的放置操作集合的逻辑交集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSourceDropEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragSourceDropEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.dnd.DragSourceEvent
        • java.awt.dnd.DragSourceDropEvent
  • All Implemented Interfaces:
    Serializable

    public class DragSourceDropEvent
extends DragSourceEvent
    所述DragSourceDropEvent从递送DragSourceContextPeer ，经由DragSourceContext ，到dragDropEnd的方法DragSourceListener与注册小号DragSourceContext和与其相关联的DragSource 。 它包含足够的信息，用于操作的发起者，以便在操作完成时向最终用户提供适当的反馈。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragSourceDropEvent​(DragSourceContext dsc)
      构造一个 DragSourceDropEvent用于不会导致丢弃的拖动。
      DragSourceDropEvent​(DragSourceContext dsc, int action, boolean success)
      构建一个 DragSourceDropEvent的一个下降，给出了 DragSourceContext的下降操作，以及一个 boolean表示下降是否成功。
      DragSourceDropEvent​(DragSourceContext dsc, int action, boolean success, int x, int y)
      构造一个 DragSourceDropEvent一个下降，给出了 DragSourceContext ，下降动作，一个 boolean指示下降是否成功和坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getDropAction​()
      此方法返回一个 int表示由目标执行的关于该删除主题的操作。
      boolean getDropSuccess​()
      此方法返回一个 boolean指示下降是否成功。

      • Methods inherited from class java.awt.dnd.DragSourceEvent

        getDragSourceContext, getLocation, getX, getY

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DragSourceDropEvent

        public DragSourceDropEvent​(DragSourceContext dsc,
                           int action,
                           boolean success)
        构建一个DragSourceDropEvent的一个下降，给出了DragSourceContext的下拉操作，以及一个boolean表示跌落是否成功。 此DragSourceDropEvent的坐标未指定，因此getLocation将为此事件返回null 。

        参数action应该是表示单个操作的DnDConstants之一。 此构造函数不会为无效的action引发任何异常。

        参数
        dsc - 该 DragSourceContext与此 DragSourceDropEvent相关联
        action - 放下的动作
        success - 一个布尔值，指示下降是否成功
        异常
        IllegalArgumentException - 如果 dsc是 null 。
        另请参见：
        DragSourceEvent.getLocation()

      • DragSourceDropEvent

        public DragSourceDropEvent​(DragSourceContext dsc,
                           int action,
                           boolean success,
                           int x,
                           int y)
        构造一个DragSourceDropEvent一个下降，给出了DragSourceContext ，下降动作，一个boolean表示下降是否成功，并且坐标。

        参数action应该是代表一个动作的DnDConstants之一。 此构造函数不会为无效的action引发任何异常。

        参数
        dsc -在 DragSourceContext与此相关 DragSourceDropEvent
        action - 下降动作
        success - 一个布尔值，表示下降是否成功
        x - 光标位置的水平坐标
        y - 光标位置的垂直坐标
        异常
        IllegalArgumentException - 如果 dsc是 null 。
        从以下版本开始：
        1.4

      • DragSourceDropEvent

        public DragSourceDropEvent​(DragSourceContext dsc)
        构造一个DragSourceDropEvent用于不会导致丢弃的拖动。 此DragSourceDropEvent的坐标未指定，因此getLocation将为此事件返回null 。
        参数
        dsc - DragSourceContext
        异常
        IllegalArgumentException - 如果 dsc是 null 。
        另请参见：
        DragSourceEvent.getLocation()

    • 方法详细信息

      • getDropSuccess

        public boolean getDropSuccess​()
        此方法返回一个 boolean指示下降是否成功。
        结果
        true如果下拉目标接受掉落并成功执行了一个放置动作; false如果丢弃目标拒绝了该丢弃，或者如果丢弃目标接受了丢弃，但未能执行删除操作。

      • getDropAction

        public int getDropAction​()
        此方法返回一个 int表示目标对投影对象执行的操作。
        结果
        the action performed by the target on the subject of the drop if the drop target accepted the drop and the target drop action is supported by the drag source; otherwise, DnDConstants.ACTION_NONE.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSourceEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DragSourceEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.dnd.DragSourceEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    DragSourceDragEvent ， DragSourceDropEvent

    public class DragSourceEvent
extends EventObject
    这个类是DragSourceDragEvent和DragSourceDropEvent的基类。

    每当拖动进入，移动或退出拖放站点时，当拖放操作更改时，以及拖动结束时都会生成DragSourceEvent 。 生成的DragSourceEvent的位置在此事件发生时指定屏幕坐标中的鼠标光标位置。

    在没有虚拟设备的多屏幕环境中，光标位置在启动器 GraphicsConfiguration的坐标系中指定。 启动器 GraphicsConfiguration是GraphicsConfiguration的Component ，其中当前拖动操作的拖动手势被识别。 如果光标位置在启动器GraphicsConfiguration的边界GraphicsConfiguration ，则报告的坐标被剪切以适应该GraphicsConfiguration的界限。

    在具有虚拟设备的多屏幕环境中，位置在相应的虚拟坐标系中指定。 如果光标位置在虚拟设备的边界之外，则报告的坐标被剪切以适合虚拟设备的界限。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DragSourceEvent​(DragSourceContext dsc)
      构造一个 DragSourceEvent给定一个指定的 DragSourceContext 。
      DragSourceEvent​(DragSourceContext dsc, int x, int y)
      构造一个 DragSourceEvent给定一个指定的 DragSourceContext和坐标的光标位置。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DragSourceContext getDragSourceContext​()
      此方法返回发起事件的 DragSourceContext 。
      Point getLocation​()
      此方法返回一个 Point表示在此事件发生时屏幕坐标中的光标位置，如果未为此事件指定光标位置，则 null 。
      int getX​()
      此方法在此事件发生时返回屏幕坐标中光标位置的水平坐标，如果未为此事件指定光标位置，则返回0。
      int getY​()
      此方法返回在此事件发生时屏幕坐标中光标位置的垂直坐标，如果未为此事件指定光标位置，则返回0。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DragSourceEvent

        public DragSourceEvent​(DragSourceContext dsc)
        构造一个DragSourceEvent给定一个指定的DragSourceContext 。 此DragSourceEvent的坐标未指定，因此getLocation将为此事件返回null 。
        参数
        dsc - DragSourceContext
        异常
        IllegalArgumentException - 如果 dsc是 null 。
        另请参见：
        getLocation()

      • DragSourceEvent

        public DragSourceEvent​(DragSourceContext dsc,
                       int x,
                       int y)
        构造一个 DragSourceEvent给定一个指定的 DragSourceContext和光标位置的坐标。
        参数
        dsc - DragSourceContext
        x - 光标位置的水平坐标
        y - 光标位置的垂直坐标
        异常
        IllegalArgumentException - 如果 dsc是 null 。
        从以下版本开始：
        1.4

    • 方法详细信息

      • getDragSourceContext

        public DragSourceContext getDragSourceContext​()
        此方法返回发起事件的 DragSourceContext 。
        结果
        发起事件的 DragSourceContext

      • getLocation

        public Point getLocation​()
        此方法返回一个 Point表示在此事件发生时屏幕坐标中的光标位置，如果未为此事件指定光标位置，则 null 。
        结果
        所述 Point指示光标位置或 null ，如果没有指定光标位置
        从以下版本开始：
        1.4

      • getX

        public int getX​()
        此方法在此事件发生时返回屏幕坐标中光标位置的水平坐标，如果未为此事件指定光标位置，则返回0。
        结果
        指示光标位置的水平坐标的整数，如果未指定光标位置，则为零
        从以下版本开始：
        1.4

      • getY

        public int getY​()
        此方法返回在此事件发生时屏幕坐标中光标位置的垂直坐标，如果未为此事件指定光标位置，则返回0。
        结果
        指示光标位置的垂直坐标的整数，如果未指定光标位置，则为零
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSourceListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Interface DragSourceListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    DragSourceAdapter ， DragSourceContext

    public interface DragSourceListener
extends EventListener
    DragSourceListener定义了用于跟踪用户手势状态的拖放操作的发起者的事件接口，并在拖放操作中向用户提供适当的“拖拽”反馈。

    如果最近在此侦听dragEnter()上调用了dragEnter() ，则该丢弃站点与之前的dragEnter()调用相关联 ：

    • 对应于该下降站点
    • 在此侦听器后面不会有一个dragExit()调用。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dragDropEnd​(DragSourceDropEvent dsde)
      调用此方法来表示拖放操作完成。
      void dragEnter​(DragSourceDragEvent dsde)
      称为光标的热点进入平台依赖的放置站点。
      void dragExit​(DragSourceEvent dse)
      称为光标的热点退出平台相关的放置站点。
      void dragOver​(DragSourceDragEvent dsde)
      称为光标的热点在平台相关的放置站点上移动。
      void dropActionChanged​(DragSourceDragEvent dsde)
      当用户修改了放置手势时调用。

    • 方法详细信息

      • dragEnter

        void dragEnter​(DragSourceDragEvent dsde)
        称为光标的热点进入平台依赖的放置站点。 当所有以下条件为真时，将调用此方法：
        • 光标的热点进入平台相关的放置位置的可操作部分。
        • 投放站点处于活动状态。
        • 拖放站点接受拖动。
        参数
        dsde - DragSourceDragEvent

      • dragOver

        void dragOver​(DragSourceDragEvent dsde)
        称为光标的热点在平台相关的放置站点上移动。 当所有以下条件为真时，将调用此方法：
        • 光标的热点已移动，但仍与与之前的dragEnter（）调用相关联的放置站点的可操作部分相交。
        • 投放站点仍然活跃。
        • 拖放站点接受拖动。
        参数
        dsde - DragSourceDragEvent

      • dropActionChanged

        void dropActionChanged​(DragSourceDragEvent dsde)
        当用户修改了放置手势时调用。 当用户正在交互的输入设备的状态发生变化时，将调用此方法。 这样的设备通常是用户正在交互的鼠标按钮或键盘修改器。
        参数
        dsde - DragSourceDragEvent

      • dragExit

        void dragExit​(DragSourceEvent dse)
        称为光标的热点退出平台相关的放置站点。 当以下任一条件为真时，将调用此方法：
        • 光标的热点不再与与之前的dragEnter（）调用相关联的放置站点的可操作部分相交。
        要么
        • 与之前的dragEnter（）调用相关联的丢弃站点不再处于活动状态。
        要么
        • 与之前的dragEnter（）调用相关联的丢弃站点已经拒绝了该拖动。
        参数
        dse - DragSourceEvent

      • dragDropEnd

        void dragDropEnd​(DragSourceDropEvent dsde)
        调用此方法来表示拖放操作完成。 所述的getDropSuccess（）方法DragSourceDropEvent可用于确定终止状态。 getDropAction（）方法返回选择要应用于放置操作的放置站点的操作。 一旦这个方法完成，当前的DragSourceContext和相关的资源变得无效。
        参数
        dsde - the DragSourceDropEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DragSourceMotionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Interface DragSourceMotionListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    DragSourceAdapter ， DragSourceContext

    public interface DragSourceMotionListener
extends EventListener
    用于在拖动操作期间接收鼠标运动事件的侦听器界面。

    在拖动操作期间有兴趣处理鼠标运动事件的类可以实现此接口或扩展抽象的DragSourceAdapter类（仅覆盖感兴趣的方法）。

    使用该类创建一个侦听器对象，然后使用DragSource注册它。 无论何时鼠标在使用此DragSource启动的拖动操作期间移动，将调用该对象的dragMouseMoved方法，并传递DragSourceDragEvent 。

    从以下版本开始：
    1.4
    另请参见：
    DragSourceDragEvent ， DragSource ， DragSourceListener ， DragSourceAdapter

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dragMouseMoved​(DragSourceDragEvent dsde)
      在拖动操作期间鼠标移动时调用。

    • 方法详细信息

      • dragMouseMoved

        void dragMouseMoved​(DragSourceDragEvent dsde)
        在拖动操作期间鼠标移动时调用。
        参数
        dsde - DragSourceDragEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTarget (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTarget

  • java.lang.Object
    • java.awt.dnd.DropTarget
  • All Implemented Interfaces:
    DropTargetListener ， Serializable ， EventListener

    public class DropTarget
extends Object
implements DropTargetListener, Serializable
    该DropTarget与相关Component时Component希望接受拖放操作期间下降。

    每个DropTarget都与一个FlavorMap相关联。 默认FlavorMap以后指定FlavorMap返回的SystemFlavorMap.getDefaultFlavorMap() 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected static class  DropTarget.DropTargetAutoScroller
      这个受保护的嵌套类实现自动滚动

    • 构造方法摘要

      构造方法
      Constructor 描述
      DropTarget​()
      创建一个 DropTarget 。
      DropTarget​(Component c, int ops, DropTargetListener dtl)
      创建一个 DropTarget给出了 Component以关联自己，一个 int表示默认可接受的操作支持，一个 DropTargetListener处理事件处理。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act)
      创建一个 DropTarget给出 Component以关联自己，一个 int表示默认可接受的操作支持，一个 DropTargetListener来处理事件处理，以及一个 boolean指示 DropTarget是否正在接受丢弃。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
      创建一个新的DropTarget，给出了 Component以将自身关联，一个 int表示默认可接受的操作来支持，一个 DropTargetListener处理事件处理，一个 boolean指示 DropTarget是否正在接受丢弃，以及一个 FlavorMap （或null为默认值 FlavorMap ）。
      DropTarget​(Component c, DropTargetListener dtl)
      创建一个 DropTarget给出了 Component来关联自己，和 DropTargetListener来处理事件处理。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addDropTargetListener​(DropTargetListener dtl)
      添加新的 DropTargetListener （UNICAST SOURCE）。
      void addNotify​()
      通知与组件关联的DropTarget此方法通常从与此DropTarget关联的组件的java.awt.Component.addNotify（）中调用，以通知DropTarget ComponentPeer已与该组件相关联。
      protected void clearAutoscroll​()
      清除自动滚动
      protected DropTarget.DropTargetAutoScroller createDropTargetAutoScroller​(Component c, Point p)
      创建一个嵌入式自动推送器
      protected DropTargetContext createDropTargetContext​()
      创建与此DropTarget关联的DropTargetContext。
      void dragEnter​(DropTargetDragEvent dtde)
      致电 dragEnter注册 DropTargetListener并通过指定的 DropTargetDragEvent 。
      void dragExit​(DropTargetEvent dte)
      致电 dragExit注册 DropTargetListener并通过指定的 DropTargetEvent 。
      void dragOver​(DropTargetDragEvent dtde)
      致电 dragOver注册 DropTargetListener并通过指定的 DropTargetDragEvent 。
      void drop​(DropTargetDropEvent dtde)
      致电 drop注册 DropTargetListener并通过它指定的 DropTargetDropEvent如果这 DropTarget是活动的。
      void dropActionChanged​(DropTargetDragEvent dtde)
      致电 dropActionChanged在注册的 DropTargetListener并通过指定的 DropTargetDragEvent 。
      Component getComponent​()
      获取 Component与此 DropTarget相关联。
      int getDefaultActions​()
      获取一个 int表示受此支持的当前操作（一个或多个） DropTarget 。
      DropTargetContext getDropTargetContext​()
      获取 DropTargetContext与此 DropTarget相关联。
      FlavorMap getFlavorMap​()
      获取 FlavorMap与此 DropTarget相关联。
      protected void initializeAutoscrolling​(Point p)
      初始化自动滚动
      boolean isActive​()
      报告此 DropTarget是否当前处于活动状态（准备接受 DropTarget ）。
      void removeDropTargetListener​(DropTargetListener dtl)
      删除当前的 DropTargetListener （UNICAST SOURCE）。
      void removeNotify​()
      通知从组件中取消关联的DropTarget此方法通常从与此DropTarget关联的组件的java.awt.Component.removeNotify（）中调用，以通知DropTarget ComponentPeer已与该组件取消关联。
      void setActive​(boolean isActive)
      将DropTarget设置为积极的，如果 true ，不活跃，如果 false 。
      void setComponent​(Component c)
      注意：此接口需要允许以两种方式之一将DropTarget与组件安全关联： component.setDropTarget(droptarget);或 droptarget.setComponent(component);
      void setDefaultActions​(int ops)
      设置此 DropTarget的默认可接受操作
      void setFlavorMap​(FlavorMap fm)
      设置 FlavorMap与此相关 DropTarget 。
      protected void updateAutoscroll​(Point dragCursorLocn)
      更新当前光标位置的自动滚动

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DropTarget

        public DropTarget​(Component c,
                  int ops,
                  DropTargetListener dtl,
                  boolean act,
                  FlavorMap fm)
           throws HeadlessException
        创建一个新的DropTarget，给出了Component来关联自己，一个int表示默认可接受的操作来支持，一个DropTargetListener处理事件处理，一个boolean指示DropTarget是否正在接受丢弃，以及一个FlavorMap （或null为默认值FlavorMap ）。

        组件只有在启用时才会接收到丢弃。

        参数
        c -该 Component与此 DropTarget关联
        ops - 此 DropTarget的默认可接受操作
        dtl - DropTargetListener为这 DropTarget
        act - 是 DropTarget接受滴。
        fm - 要使用的 FlavorMap ，或默认为null FlavorMap
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DropTarget

        public DropTarget​(Component c,
                  int ops,
                  DropTargetListener dtl,
                  boolean act)
           throws HeadlessException
        创建一个DropTarget给出Component以自己的int ，一个int表示默认可接受的动作，以支持，一个DropTargetListener来处理事件处理，以及一个boolean指示DropTarget是否正在接受丢弃。

        组件只有在启用时才会接收到丢弃。

        参数
        c -该 Component与此 DropTarget关联
        ops - 此 DropTarget的默认可接受操作
        dtl - DropTargetListener为这 DropTarget
        act - 是 DropTarget接受滴。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DropTarget

        public DropTarget​()
           throws HeadlessException
        创建一个 DropTarget 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DropTarget

        public DropTarget​(Component c,
                  DropTargetListener dtl)
           throws HeadlessException
        创建一个DropTarget给出了Component与其自身的关联，而DropTargetListener处理事件处理。

        组件只有在启用时才会接收到丢弃。

        参数
        c -该 Component与此 DropTarget关联
        dtl - DropTargetListener为这 DropTarget
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • DropTarget

        public DropTarget​(Component c,
                  int ops,
                  DropTargetListener dtl)
           throws HeadlessException
        创建一个DropTarget给出了Component来关联自己，一个int表示默认可接受的操作支持，一个DropTargetListener来处理事件处理。

        组件只有在启用时才会接收到丢弃。

        参数
        c -该 Component与此 DropTarget关联
        ops - 此 DropTarget的默认可接受操作
        dtl - DropTargetListener为这 DropTarget
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true
        另请参见：
        GraphicsEnvironment.isHeadless()

    • 方法详细信息

      • setComponent

        public void setComponent​(Component c)
        注意：此接口需要允许以两种方式之一安全地将DropTarget与组件关联： component.setDropTarget(droptarget);或droptarget.setComponent(component);

        组件只有在启用时才会接收到丢弃。

        参数
        c - 新的 Component这个 DropTarget是要关联的。

      • getComponent

        public Component getComponent​()
        获取 Component与此 DropTarget相关联。
        结果
        当前 Component

      • setDefaultActions

        public void setDefaultActions​(int ops)
        设置此 DropTarget的默认可接受操作
        参数
        ops - 默认动作
        另请参见：
        DnDConstants

      • getDefaultActions

        public int getDefaultActions​()
        获取 int表示此 DropTarget支持的当前操作。
        结果
        当前的默认动作

      • setActive

        public void setActive​(boolean isActive)
        将DropTarget设置为激活，如果为 true ，如果为 true ，则 false 。
        参数
        isActive - 设置 DropTarget （in）活动。

      • isActive

        public boolean isActive​()
        报告此 DropTarget是否当前处于活动状态（准备接受 DropTarget ）。
        结果
        true如果活动， false如果没有

      • addDropTargetListener

        public void addDropTargetListener​(DropTargetListener dtl)
                           throws TooManyListenersException
        添加新的 DropTargetListener （UNICAST SOURCE）。
        参数
        dtl - 新的 DropTargetListener
        异常
        TooManyListenersException - 如果一个 DropTargetListener已经添加到这个 DropTarget 。

      • removeDropTargetListener

        public void removeDropTargetListener​(DropTargetListener dtl)
        删除当前的 DropTargetListener （UNICAST SOURCE）。
        参数
        dtl - DropTargetListener注销。

      • dragEnter

        public void dragEnter​(DropTargetDragEvent dtde)
        致电dragEnter注册DropTargetListener并通过指定的DropTargetDragEvent 。 如果此DropTarget未处于活动状态，则无效。
        Specified by:
        dragEnter在接口 DropTargetListener
        参数
        dtde - DropTargetDragEvent
        异常
        NullPointerException - 如果这个 DropTarget是活动的，而 dtde是 null
        另请参见：
        isActive()

      • dragOver

        public void dragOver​(DropTargetDragEvent dtde)
        致电dragOver注册DropTargetListener并通过指定的DropTargetDragEvent 。 没有效果，如果这个DropTarget没有活动。
        Specified by:
        dragOver在接口 DropTargetListener
        参数
        dtde - DropTargetDragEvent
        异常
        NullPointerException - 如果这个 DropTarget是活动的，而 dtde是 null
        另请参见：
        isActive()

      • dropActionChanged

        public void dropActionChanged​(DropTargetDragEvent dtde)
        致电dropActionChanged在注册的DropTargetListener并通过它指定的DropTargetDragEvent 。 没有效果，如果这个DropTarget没有活动。
        Specified by:
        dropActionChanged在接口 DropTargetListener
        参数
        dtde - DropTargetDragEvent
        异常
        NullPointerException - 如果这个 DropTarget是活动的，而 dtde是 null
        另请参见：
        isActive()

      • dragExit

        public void dragExit​(DropTargetEvent dte)
        致电dragExit在注册的DropTargetListener并通过指定的DropTargetEvent 。 如果此DropTarget未激活，则无效。

        此方法本身不会为null参数引发任何异常，而是针对侦听器的相应方法抛出的异常。

        Specified by:
        dragExit在接口 DropTargetListener
        参数
        dte - DropTargetEvent
        另请参见：
        isActive()

      • drop

        public void drop​(DropTargetDropEvent dtde)
        致电 drop在注册的 DropTargetListener并通过它指定的 DropTargetDropEvent如果这 DropTarget是活动的。
        Specified by:
        drop在接口 DropTargetListener
        参数
        dtde - DropTargetDropEvent
        异常
        NullPointerException - 如果 dtde为空，并且至少有一个为真：此 DropTarget未激活，或者没有注册 DropTargetListener 。
        另请参见：
        isActive()

      • getFlavorMap

        public FlavorMap getFlavorMap​()
        获取FlavorMap与此DropTarget相关联。 如果没有FlavorMap设置DropTarget ，则它与默认值FlavorMap相关联。
        结果
        该DropTarget的FlavorMap

      • setFlavorMap

        public void setFlavorMap​(FlavorMap fm)
        设置 FlavorMap与此相关 DropTarget 。
        参数
        fm - 新的 FlavorMap ，或者将null默认FlavorMap与此DropTarget相关联。

      • addNotify

        public void addNotify​()
        通知与组件关联的DropTarget此方法通常从与此DropTarget关联的组件的java.awt.Component.addNotify（）中调用，以通知DropTarget ComponentPeer已与该组件相关联。 调用此方法，除了将ComponentPeer与组件关联的此DropTarget通知可能会导致DnD系统故障。

      • removeNotify

        public void removeNotify​()
        通知从组件中取消关联的DropTarget此方法通常从与此DropTarget关联的组件的java.awt.Component.removeNotify（）中调用，以通知DropTarget ComponentPeer已与该组件取消关联。 调用此方法，除了通知此DropTarget之外，ComponentPeer从Component中取消关联可能会导致DnD系统发生故障。

      • getDropTargetContext

        public DropTargetContext getDropTargetContext​()
        获取 DropTargetContext与此 DropTarget相关联。
        结果
        该 DropTargetContext与此 DropTarget相关联。

      • createDropTargetContext

        protected DropTargetContext createDropTargetContext​()
        创建与此DropTarget关联的DropTargetContext。 子类可以覆盖此方法来实例化自己的DropTargetContext子类。 这个调用通常仅由平台的DropTargetContextPeer调用，因为拖动操作遇到此DropTarget。 当没有拖动当前时访问上下文有未定义的结果。
        结果
        与此DropTarget关联的DropTargetContext

      • createDropTargetAutoScroller

        protected DropTarget.DropTargetAutoScroller createDropTargetAutoScroller​(Component c,
                                                                         Point p)
        创建一个嵌入式自动推送器
        参数
        c - Component
        p - Point
        结果
        嵌入式自动翻转器

      • initializeAutoscrolling

        protected void initializeAutoscrolling​(Point p)
        初始化自动滚动
        参数
        p - Point

      • updateAutoscroll

        protected void updateAutoscroll​(Point dragCursorLocn)
        更新当前光标位置的自动滚动
        参数
        dragCursorLocn - Point

      • clearAutoscroll

        protected void clearAutoscroll​()
        清除自动滚动
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTarget.DropTargetAutoScroller (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTarget.DropTargetAutoScroller

  • java.lang.Object
    • java.awt.dnd.DropTarget.DropTargetAutoScroller
  • All Implemented Interfaces:
    ActionListener ， EventListener
    Enclosing class:
    DropTarget

    protected static class DropTarget.DropTargetAutoScroller
extends Object
implements ActionListener
    这个受保护的嵌套类实现自动滚动

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DropTargetAutoScroller​(Component c, Point p)
      构建一个DropTargetAutoScroller

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void actionPerformed​(ActionEvent e)
      导致自动滚屏发生
      protected void stop​()
      导致自动滚动停止
      protected void updateLocation​(Point newLocn)
      导致自动滚屏发生

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DropTargetAutoScroller

        protected DropTargetAutoScroller​(Component c,
                                 Point p)
        构建一个DropTargetAutoScroller
        参数
        c - Component
        p - Point

    • 方法详细信息

      • updateLocation

        protected void updateLocation​(Point newLocn)
        导致自动滚屏发生
        参数
        newLocn - Point

      • stop

        protected void stop​()
        导致自动滚动停止

      • actionPerformed

        public void actionPerformed​(ActionEvent e)
        导致自动滚屏发生
        Specified by:
        actionPerformed在接口 ActionListener
        参数
        e - ActionEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTargetAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTargetAdapter

  • java.lang.Object
    • java.awt.dnd.DropTargetAdapter
  • All Implemented Interfaces:
    DropTargetListener ， EventListener

    public abstract class DropTargetAdapter
extends Object
implements DropTargetListener
    用于接收丢弃目标事件的抽象适配器类。 这个类中的方法是空的。 此类只能作为创建侦听器对象的方便。

    扩展此类以创建一个DropTargetEvent监听器，并覆盖感兴趣事件的方法。 （如果您实现了DropTargetListener接口，则必须定义其中的所有方法。此抽象类为除drop(DropTargetDropEvent)之外的每个方法定义了一个空实现，因此您只需定义关心的事件的方法。）您必须提供一个实施至少drop(DropTargetDropEvent) 。 此方法不能有空实现，因为它的规范要求您接受或拒绝该删除，并且如果接受，则指示该丢弃是否成功。

    使用扩展类创建一个侦听器对象，然后使用一个DropTarget注册它。 当拖动进入时，移动或退出DropTarget的拖放站点的可操作部分，当拖放操作发生变化时，发生丢弃时，将调用侦听器对象中的相关方法，并将DropTargetEvent传递给它。

    DropTarget的放置站点的可操作部分是相关联的Component的几何体的一部分，它不会被重叠的顶层窗口或另一个具有相关联的活动DropTarget的Z顺序的另一个Component所DropTarget 。

    在拖动期间，可以通过在传递给侦听器的方法的DropTargetDragEvent实例上调用getTransferable()来检索与当前拖动操作相关联的数据。

    请注意， getTransferable()实例上的DropTargetDragEvent应仅在相应侦听器的方法中调用，并且所有必需的数据应在返回的方法之前从返回的Transferable检索。

    从以下版本开始：
    1.4
    另请参见：
    DropTargetEvent ， DropTargetListener

    • 构造方法摘要

      构造方法
      Constructor 描述
      DropTargetAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dragEnter​(DropTargetDragEvent dtde)
      当拖动操作正在进行时，当鼠标指针进入为此侦听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
      void dragExit​(DropTargetEvent dte)
      当拖动操作正在进行时，当鼠标指针已经退出到该监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
      void dragOver​(DropTargetDragEvent dtde)
      当拖动操作正在进行时被调用，而鼠标指针仍在超过可用于此监听 DropTarget注册的 DropTarget的放置站点的可操作部分。
      void dropActionChanged​(DropTargetDragEvent dtde)
      如果用户修改了当前的放置手势，则被调用。

      • Methods inherited from interface java.awt.dnd.DropTargetListener

        drop

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DropTargetAdapter

        public DropTargetAdapter​()

    • 方法详细信息

      • dragEnter

        public void dragEnter​(DropTargetDragEvent dtde)
        当拖动操作正在进行时，当鼠标指针进入为此监听 DropTarget注册的 DropTarget站点的可操作部分时 DropTarget 。
        Specified by:
        dragEnter在接口 DropTargetListener
        参数
        dtde - DropTargetDragEvent

      • dragOver

        public void dragOver​(DropTargetDragEvent dtde)
        当拖动操作正在进行时被调用，而鼠标指针仍然 DropTarget在为此侦听 DropTarget注册的 DropTarget的放置站点的可操作部分。
        Specified by:
        dragOver在接口 DropTargetListener
        参数
        dtde - DropTargetDragEvent

      • dropActionChanged

        public void dropActionChanged​(DropTargetDragEvent dtde)
        如果用户修改了当前的放置手势，则被调用。
        Specified by:
        dropActionChanged在接口 DropTargetListener
        参数
        dtde - DropTargetDragEvent

      • dragExit

        public void dragExit​(DropTargetEvent dte)
        当拖动操作正在进行时，当鼠标指针已经退出了对此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
        Specified by:
        dragExit在接口 DropTargetListener
        参数
        dte - DropTargetEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTargetContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTargetContext

  • java.lang.Object
    • java.awt.dnd.DropTargetContext
  • All Implemented Interfaces:
    Serializable

    public class DropTargetContext
extends Object
implements Serializable
    甲DropTargetContext每当用拖放操作相关联的逻辑光标用的可见几何一致创建Component与相关联DropTarget 。 DropTargetContext提供了一种放下操作的潜在接收器的机制，以向最终用户提供反馈下的适当拖动，但是如果适当的话，还可以实现后续的数据传输。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      protected class  DropTargetContext.TransferableProxy
      TransferableProxy是一个助手内部类，实现 Transferable接口，并作为另一个 Transferable对象的代理，代表特定的拖放操作的数据传输。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void acceptDrag​(int dragOperation)
      接受拖动。
      protected void acceptDrop​(int dropOperation)
      称为使用指定的操作可以接受下降。
      protected Transferable createTransferableProxy​(Transferable t, boolean local)
      创建一个TransferableProxy代理指定的Transferable。
      void dropComplete​(boolean success)
      该方法表明，下降完成并且成功。
      Component getComponent​()
      此方法返回 Component与此相关 DropTargetContext 。
      protected DataFlavor[] getCurrentDataFlavors​()
      获取此操作的 Transferable操作数的可用DataFlavors。
      protected List<DataFlavor> getCurrentDataFlavorsAsList​()
      该方法返回当前可用的 Transferable操作数DataFlavors作为 java.util.List 。
      DropTarget getDropTarget​()
      此方法返回 DropTarget与此相关 DropTargetContext 。
      protected int getTargetActions​()
      此方法返回一个 int表示 DropTarget将接受的当前操作。
      protected Transferable getTransferable​()
      获取此操作的可转移（代理）操作数
      protected boolean isDataFlavorSupported​(DataFlavor df)
      该方法返回一个 boolean表示 DataFlavor是否支持给定的 DropTargetContext 。
      protected void rejectDrag​()
      拒绝拖动。
      protected void rejectDrop​()
      呼吁说这个下降是不能接受的。
      protected void setTargetActions​(int actions)
      此方法将当前操作设置为 DropTarget可接受。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDropTarget

        public DropTarget getDropTarget​()
        此方法返回 DropTarget与此相关 DropTargetContext 。
        结果
        该 DropTarget与此 DropTargetContext相关联

      • getComponent

        public Component getComponent​()
        此方法返回 Component与此相关 DropTargetContext 。
        结果
        与此上下文关联的组件

      • setTargetActions

        protected void setTargetActions​(int actions)
        此方法将当前操作设置为 DropTarget可接受。
        参数
        actions - 表示支持的动作的 int

      • getTargetActions

        protected int getTargetActions​()
        此方法返回一个 int表示 DropTarget将接受的当前操作。
        结果
        目前的行动可以接受这个 DropTarget

      • dropComplete

        public void dropComplete​(boolean success)
                  throws InvalidDnDOperationException
        该方法表明，下降完成并且成功。
        参数
        success - 如果没有成功， success true
        异常
        InvalidDnDOperationException - 如果一滴不突出/现存

      • acceptDrag

        protected void acceptDrag​(int dragOperation)
        接受拖动。
        参数
        dragOperation - 支持的操作

      • rejectDrag

        protected void rejectDrag​()
        拒绝拖动。

      • acceptDrop

        protected void acceptDrop​(int dropOperation)
        称为使用指定的操作可以接受下降。 必须在DropTargetListener.drop方法调用期间调用。
        参数
        dropOperation - 支持的操作

      • rejectDrop

        protected void rejectDrop​()
        呼吁说这个下降是不能接受的。 必须在DropTargetListener.drop方法调用期间调用。

      • getCurrentDataFlavors

        protected DataFlavor[] getCurrentDataFlavors​()
        获取此操作的 Transferable操作数的可用DataFlavors。
        结果
        一个 DataFlavor[]含有支持 DataFlavor S中的 Transferable操作数。

      • getCurrentDataFlavorsAsList

        protected List<DataFlavor> getCurrentDataFlavorsAsList​()
        该方法返回当前可用的 Transferable操作数DataFlavors作为 java.util.List 。
        结果
        目前可用的DataFlavors为 java.util.List

      • isDataFlavorSupported

        protected boolean isDataFlavorSupported​(DataFlavor df)
        此方法返回一个 boolean指示 DataFlavor是否支持该 DropTargetContext 。
        参数
        df - DataFlavor
        结果
        如果支持 DataFlavor指定

      • getTransferable

        protected Transferable getTransferable​()
                                throws InvalidDnDOperationException
        获取此操作的可转移（代理）操作数
        结果
        Transferable
        异常
        InvalidDnDOperationException - 如果拖动不是很好/现存

      • createTransferableProxy

        protected Transferable createTransferableProxy​(Transferable t,
                                               boolean local)
        创建一个TransferableProxy代理指定的Transferable。
        参数
        t - 要代理的 Transferable
        local - true如果 t表示局部拖放操作的结果。
        结果
        新的 TransferableProxy实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTargetContext.TransferableProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTargetContext.TransferableProxy

  • java.lang.Object
    • java.awt.dnd.DropTargetContext.TransferableProxy
  • All Implemented Interfaces:
    Transferable
    Enclosing class:
    DropTargetContext

    protected class DropTargetContext.TransferableProxy
extends Object
implements Transferable
    TransferableProxy是一个助手内部类，它实现Transferable接口，并作为另一个Transferable对象的代理，代表特定的拖放操作的数据传输。

    代理将所有请求转发到可封装的可转移，并在本地传输的情况下自动对由可封装的可转移的数据返回的数据执行附加转换。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected boolean isLocal
      A boolean指示封装的 Transferable对象是否表示本地拖放操作的结果（在同一个JVM中）。
      protected Transferable transferable
      封装的 Transferable对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getTransferData​(DataFlavor df)
      返回一个对象，该对象表示由所请求的数据风格的可封装转移提供的数据。
      DataFlavor[] getTransferDataFlavors​()
      返回一个DataFlavor对象数组，表示可封装的可传递数据可以提供数据的风格。
      boolean isDataFlavorSupported​(DataFlavor flavor)
      返回指定的数据风格是否被封装的可转移支持。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • transferable

        protected Transferable transferable
        封装的 Transferable对象。

      • isLocal

        protected boolean isLocal
        A boolean指示封装的 Transferable对象是否表示本地拖放操作的结果（在同一个JVM中）。

    • 方法详细信息

      • getTransferDataFlavors

        public DataFlavor[] getTransferDataFlavors​()
        返回一个DataFlavor对象数组，表示可封装的可传递数据可以提供数据的风格。
        Specified by:
        getTransferDataFlavors在接口 Transferable
        结果
        数据风格的数组，其中数据可以通过封装的可转移提供

      • isDataFlavorSupported

        public boolean isDataFlavorSupported​(DataFlavor flavor)
        返回指定的数据风格是否被封装的可转移支持。
        Specified by:
        isDataFlavorSupported接口 Transferable
        参数
        flavor - 数据所需的风味
        结果
        true如果数据气息支持， false否则

      • getTransferData

        public Object getTransferData​(DataFlavor df)
                       throws UnsupportedFlavorException,
                              IOException
        返回一个对象，该对象表示由所请求的数据风格的可封装转移提供的数据。

        在本地传输的情况下，当在application / x-java-serialized-object数据风格中请求数据时，提供由封装的可传输文件返回的对象的序列化副本。

        Specified by:
        getTransferData在接口 Transferable
        参数
        df - 数据所需的风味
        结果
        表示要传送的数据的对象
        异常
        IOException - 如果数据在请求的风味中不再可用。
        UnsupportedFlavorException - 如果不支持请求的数据风格。
        另请参见：
        DataFlavor.getRepresentationClass()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTargetDragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTargetDragEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.dnd.DropTargetEvent
        • java.awt.dnd.DropTargetDragEvent
  • All Implemented Interfaces:
    Serializable

    public class DropTargetDragEvent
extends DropTargetEvent
    所述DropTargetDragEvent被输送到DropTargetListener经由其dragEnter事件（）和的dragover（）方法。

    DropTargetDragEvent报告源放置操作和反映拖动操作的当前状态的用户放置操作。

    源放置操作是DnDConstants的按位掩码，表示拖动操作支持的拖放操作的集合。

    用户放置操作取决于拖动源支持的放置操作和用户选择的放置操作。 用户可以在拖动操作期间按修改键来选择放置操作：

      Ctrl + Shift -> ACTION_LINK
   Ctrl         -> ACTION_COPY
   Shift        -> ACTION_MOVE
    如果用户选择放置操作，则用户放置操作是DnDConstants中的一个，表示当拖放源支持该放置操作时所选择的放置操作，如果拖放源不支持此拖动操作，则表示DnDConstants.ACTION_NONE 。

    如果用户没有选drop操作，一组DnDConstants表示设置拖动源支持的放置动作中搜索DnDConstants.ACTION_MOVE ，然后DnDConstants.ACTION_COPY ，然后为DnDConstants.ACTION_LINK和用户drop操作是找到的第一个常量。 如果没有找到常量，则用户删除操作是DnDConstants.ACTION_NONE 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.awt.dnd.DropTargetEvent

        context

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DropTargetDragEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
      构造一个 DropTargetDragEvent给出的 DropTargetContext此操作中，“拖”的位置 Cursor “在S热点 Component坐标”，用户放置动作，和源drop操作。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void acceptDrag​(int dragOperation)
      接受拖动
      DataFlavor[] getCurrentDataFlavors​()
      该方法返回当前 DataFlavor从S DropTargetContext 。
      List<DataFlavor> getCurrentDataFlavorsAsList​()
      此方法返回当前的 DataFlavor s作为 java.util.List
      int getDropAction​()
      此方法返回用户放置操作。
      Point getLocation​()
      该方法返回一个 Point表示 Cursor的当前位置在 Component'的坐标内。
      int getSourceActions​()
      此方法返回源放置操作。
      Transferable getTransferable​()
      此方法返回表示与当前拖动操作相关联的数据的Transferable对象。
      boolean isDataFlavorSupported​(DataFlavor df)
      此方法返回一个 boolean指示是否支持指定的 DataFlavor 。
      void rejectDrag​()
      由于检查了 dropAction或可用的 DataFlavor类型，因此拒绝拖动。

      • Methods inherited from class java.awt.dnd.DropTargetEvent

        getDropTargetContext

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DropTargetDragEvent

        public DropTargetDragEvent​(DropTargetContext dtc,
                           Point cursorLocn,
                           int dropAction,
                           int srcActions)
        构造一个 DropTargetDragEvent给出的 DropTargetContext此操作中，“拖”的位置 Cursor “在S热点 Component坐标”，用户放置动作，和源drop操作。
        参数
        dtc - 此操作的DropTargetContext
        cursorLocn - 组件坐标中“拖动”光标的热点的位置
        dropAction - 用户放弃操作
        srcActions - 源丢弃操作
        异常
        NullPointerException - 如果cursorLocn为空
        IllegalArgumentException - 如果dropAction不是 DnDConstants 。
        IllegalArgumentException -如果srcActions不是位掩码 DnDConstants 。
        IllegalArgumentException - 如果dtc是 null 。

    • 方法详细信息

      • getLocation

        public Point getLocation​()
        此方法返回一个 Point指示 Component'的坐标中的 Cursor的当前位置。
        结果
        当前光标位置在 Component 。

      • getCurrentDataFlavors

        public DataFlavor[] getCurrentDataFlavors​()
        此方法从 DropTargetContext返回当前的 DataFlavor s。
        结果
        来自DropTargetContext的当前DataFlavors

      • getCurrentDataFlavorsAsList

        public List<DataFlavor> getCurrentDataFlavorsAsList​()
        此方法返回当前的 DataFlavor作为 java.util.List
        结果
        一个 java.util.List的当前 DataFlavor s

      • isDataFlavorSupported

        public boolean isDataFlavorSupported​(DataFlavor df)
        此方法返回一个 boolean指示是否支持指定的 DataFlavor 。
        参数
        df - DataFlavor要测试
        结果
        如果支持特定的DataFlavor

      • getSourceActions

        public int getSourceActions​()
        此方法返回源放置操作。
        结果
        源放弃操作

      • getDropAction

        public int getDropAction​()
        此方法返回用户放置操作。
        结果
        用户放下动作

      • getTransferable

        public Transferable getTransferable​()
        此方法返回表示与当前拖动操作相关联的数据的Transferable对象。
        结果
        与拖动操作相关联的Transferable
        异常
        InvalidDnDOperationException - 如果与拖动操作相关联的数据不可用
        从以下版本开始：
        1.5

      • acceptDrag

        public void acceptDrag​(int dragOperation)
        接受拖动 此方法应来自被称为DropTargetListeners dragEnter ， dragOver和dropActionChanged方法如果实现希望接受从比由用户选择如由表示的一个其它srcActions操作dropAction 。
        参数
        dragOperation - 目标接受的操作

      • rejectDrag

        public void rejectDrag​()
        Rejects the drag as a result of examining either the dropAction or the available DataFlavor types.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTargetDropEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTargetDropEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.dnd.DropTargetEvent
        • java.awt.dnd.DropTargetDropEvent
  • All Implemented Interfaces:
    Serializable

    public class DropTargetDropEvent
extends DropTargetEvent
    DropTargetDropEvent通过DropTargetListener drop（）方法提供。

    DropTargetDropEvent报告源放置操作和反映当前拖放操作状态的用户放置操作。

    源放置操作是DnDConstants的按位掩码，表示拖放源对此拖放操作支持的放置操作的集合。

    用户放置操作取决于拖动源支持的放置操作和用户选择的放置操作。 用户可以在拖动操作期间按修改键来选择放置操作：

      Ctrl + Shift -> ACTION_LINK
   Ctrl         -> ACTION_COPY
   Shift        -> ACTION_MOVE
    如果用户选择放置操作，则用户放置操作是DnDConstants中的一个，表示如果拖放源支持该放置操作，则表示选定的放置操作，如果此拖动操作不受拖动源支持，则表示DnDConstants.ACTION_NONE 。

    如果用户没有选drop操作，一组DnDConstants表示设置拖动源支持的放置动作中搜索DnDConstants.ACTION_MOVE ，然后DnDConstants.ACTION_COPY ，然后为DnDConstants.ACTION_LINK和用户drop操作是找到的第一个常量。 如果没有找到常量，则用户删除操作是DnDConstants.ACTION_NONE 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.awt.dnd.DropTargetEvent

        context

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DropTargetDropEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
      构造一个 DropTargetDropEvent给出的 DropTargetContext进行此操作，拖动的位置 Cursor的在热点 Component坐标，当前选择的用户放置动作，和当前的一组源支持的操作“。
      DropTargetDropEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
      构造一个 DropTargetEvent给出了这个操作的 DropTargetContext ，拖动 Cursor的热点 Component的坐标位置，当前选择的用户放置动作，源的当前动作集合以及表示源的 boolean与目标相同的JVM。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void acceptDrop​(int dropAction)
      使用指定的操作接受下拉。
      void dropComplete​(boolean success)
      该方法通知 DragSource丢弃传输已完成。
      DataFlavor[] getCurrentDataFlavors​()
      此方法返回当前DataFlavors。
      List<DataFlavor> getCurrentDataFlavorsAsList​()
      此方法返回当前可用的 DataFlavor s作为 java.util.List 。
      int getDropAction​()
      此方法返回用户放置操作。
      Point getLocation​()
      该方法返回一个 Point表示 Cursor在 Component的坐标中的当前位置。
      int getSourceActions​()
      此方法返回源放置操作。
      Transferable getTransferable​()
      此方法返回与该drop相关联的 Transferable对象。
      boolean isDataFlavorSupported​(DataFlavor df)
      此方法返回一个 boolean指示是否从源中可以使用指定的 DataFlavor 。
      boolean isLocalTransfer​()
      此方法返回一个 int指示源是否与目标位于相同的JVM。
      void rejectDrop​()
      拒绝掉落。

      • Methods inherited from class java.awt.dnd.DropTargetEvent

        getDropTargetContext

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DropTargetDropEvent

        public DropTargetDropEvent​(DropTargetContext dtc,
                           Point cursorLocn,
                           int dropAction,
                           int srcActions)
        构造一个DropTargetDropEvent给出了DropTargetContext的这个操作，拖动Cursor的位置Component的坐标，当前选择的用户放置动作的位置，以及源的当前支持的一组动作。 默认情况下，此构造函数假定目标与源不在同一个虚拟机中; 那就是isLocalTransfer()会返回false 。
        参数
        dtc - 此操作的 DropTargetContext
        cursorLocn - Component坐标中“拖动”光标的热点 Component
        dropAction - 用户删除操作。
        srcActions - 源丢弃操作。
        异常
        NullPointerException - 如果cursorLocn是 null
        IllegalArgumentException - 如果dropAction不是 DnDConstants 。
        IllegalArgumentException -如果srcActions不是位掩码 DnDConstants 。
        IllegalArgumentException - 如果dtc是 null 。

      • DropTargetDropEvent

        public DropTargetDropEvent​(DropTargetContext dtc,
                           Point cursorLocn,
                           int dropAction,
                           int srcActions,
                           boolean isLocal)
        构造一个 DropTargetEvent给出的 DropTargetContext进行此操作，拖动的位置 Cursor的在热点 Component坐标“时，当前选定的用户放置动作，当前一组的所述源支持的动作，和一个 boolean指示源与目标相同的JVM。
        参数
        dtc - 用于此操作的DropTargetContext
        cursorLocn - 组件坐标中“拖动”光标的热点位置
        dropAction - 用户删除操作。
        srcActions - 源丢弃操作。
        isLocal - 如果源与目标位于相同的JVM中， isLocal真
        异常
        NullPointerException - 如果cursorLocn是 null
        IllegalArgumentException - 如果dropAction不是 DnDConstants 。
        IllegalArgumentException -如果srcActions不是位掩码 DnDConstants 。
        IllegalArgumentException - 如果dtc是 null 。

    • 方法详细信息

      • getLocation

        public Point getLocation​()
        该方法返回一个 Point指示 Cursor “在当前位置 Component坐标”。
        结果
        当前的 Cursor位置在组件的 Cursor 。

      • getCurrentDataFlavors

        public DataFlavor[] getCurrentDataFlavors​()
        此方法返回当前DataFlavors。
        结果
        当前DataFlavors

      • getCurrentDataFlavorsAsList

        public List<DataFlavor> getCurrentDataFlavorsAsList​()
        该方法返回当前可用的 DataFlavor作为 java.util.List 。
        结果
        当前可用的DataFlavors作为java.util.List

      • isDataFlavorSupported

        public boolean isDataFlavorSupported​(DataFlavor df)
        此方法返回一个 boolean指示是否可以从源中指定 DataFlavor 。
        参数
        df - 要测试的 DataFlavor
        结果
        如果指定的DataFlavor可以从源中获得

      • getSourceActions

        public int getSourceActions​()
        此方法返回源放置操作。
        结果
        源放弃操作。

      • getDropAction

        public int getDropAction​()
        此方法返回用户放置操作。
        结果
        用户删除操作。

      • getTransferable

        public Transferable getTransferable​()
        此方法返回与该下拉关联的 Transferable对象。
        结果
        Transferable与下降有关

      • acceptDrop

        public void acceptDrop​(int dropAction)
        使用指定的操作接受下拉。
        参数
        dropAction - 指定的操作

      • rejectDrop

        public void rejectDrop​()
        拒绝掉落。

      • dropComplete

        public void dropComplete​(boolean success)
        该方法通知 DragSource丢弃传输已完成。
        参数
        success boolean指示丢弃传送完成。

      • isLocalTransfer

        public boolean isLocalTransfer​()
        此方法返回一个 int指示源是否与目标相同。
        结果
        如果Source在同一个JVM中
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTargetEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class DropTargetEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.dnd.DropTargetEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    DropTargetDragEvent ， DropTargetDropEvent

    public class DropTargetEvent
extends EventObject
    DropTargetEvent是DropTargetDragEvent和DropTargetDropEvent的基础类。 它封装了拖放操作的当前状态，特别是当前的DropTargetContext 。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected DropTargetContext context
      该 DropTargetContext与此 DropTargetEvent相关联。

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      DropTargetEvent​(DropTargetContext dtc)
      构造一个 DropTargetEvent对象与指定的 DropTargetContext 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      DropTargetContext getDropTargetContext​()
      此方法返回 DropTargetContext与此相关 DropTargetEvent 。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • context

        protected DropTargetContext context
        该 DropTargetContext与此 DropTargetEvent相关联。

    • 构造方法详细信息

      • DropTargetEvent

        public DropTargetEvent​(DropTargetContext dtc)
        使用指定的 DropTargetContext构造一个 DropTargetEvent对象。
        参数
        dtc - The DropTargetContext
        异常
        NullPointerException - 如果 dtc等于 null 。
        另请参见：
        EventObject.getSource() ， getDropTargetContext()

    • 方法详细信息

      • getDropTargetContext

        public DropTargetContext getDropTargetContext​()
        此方法返回 DropTargetContext与此相关 DropTargetEvent 。
        结果
        DropTargetContext
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DropTargetListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Interface DropTargetListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    DropTarget ， DropTargetAdapter

    public interface DropTargetListener
extends EventListener
    DropTargetListener接口是DropTarget类使用的回调接口，用于提供涉及主题DropTarget的DnD操作的通知。 可以实现该接口的方法，以在整个拖放操作中向用户提供“拖动”视觉反馈。

    通过实现接口创建一个监听器对象，然后使用DropTarget注册它。 当拖动进入时，移动或退出DropTarget的拖放站点的可操作部分，当拖放操作发生变化时，当发生DropTarget时，将调用侦听器对象中的相关方法，并将DropTargetEvent传递给它。

    DropTarget的下拉站点的可操作部分是相关联的Component的几何体的一部分，它不被重叠的顶层窗口或另一个具有相关联的活动DropTarget的Z顺序的另一个Component DropTarget 。

    在拖动期间，与当前的拖动操作相关的数据可以通过调用来检索getTransferable()上DropTargetDragEvent传递到听者的方法实例。

    请注意， getTransferable()实例上的DropTargetDragEvent应该仅在相应的监听器方法中调用，并且所有必需的数据应该在该方法返回之前从返回的Transferable检索。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void dragEnter​(DropTargetDragEvent dtde)
      当拖动操作正在进行时，当鼠标指针进入为此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
      void dragExit​(DropTargetEvent dte)
      当拖动操作正在进行时，当鼠标指针已经退出了对此监听 DropTarget注册的 DropTarget站点的可操作部分时 DropTarget 。
      void dragOver​(DropTargetDragEvent dtde)
      当拖动操作正在进行时被调用，而鼠标指针仍然在为该监听 DropTarget注册的 DropTarget的放置站点的可操作部分上。
      void drop​(DropTargetDropEvent dtde)
      当拖放操作终止时，拖放操作已被终止，而该拖放操作已在该监听 DropTarget注册的 DropTarget的丢弃站点的可操作部分上掉落。
      void dropActionChanged​(DropTargetDragEvent dtde)
      如果用户修改了当前的放置手势，则被调用。

    • 方法详细信息

      • dragEnter

        void dragEnter​(DropTargetDragEvent dtde)
        当拖动操作正在进行时，当鼠标指针进入为此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
        参数
        dtde - DropTargetDragEvent

      • dragOver

        void dragOver​(DropTargetDragEvent dtde)
        当拖动操作正在进行时被调用，而鼠标指针仍然 DropTarget在为此侦听 DropTarget注册的 DropTarget的放置站点的可操作部分。
        参数
        dtde - DropTargetDragEvent

      • dropActionChanged

        void dropActionChanged​(DropTargetDragEvent dtde)
        如果用户修改了当前的放置手势，则被调用。
        参数
        dtde - DropTargetDragEvent

      • dragExit

        void dragExit​(DropTargetEvent dte)
        当拖动操作正在进行时，当鼠标指针已经退出了对此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
        参数
        dte - DropTargetEvent

      • drop

        void drop​(DropTargetDropEvent dtde)
        当拖放操作已终止时，在该监听DropTarget注册的DropTarget的可放置站点的可操作部分下降时DropTarget 。

        该方法负责进行与手势相关联的数据的传送。 DropTargetDropEvent提供了一种获取表示要传输的数据对象的Transferable对象的方法。

        通过这种方法， DropTargetListener将通过接受或拒绝该丢弃通过acceptDrop（int dropAction）或rejectDrop（）方法的DropTargetDropEvent参数。

        在acceptDrop（）之后，但不在之前，可以调用DropTargetDropEvent的getTransferable（）方法，并且可以通过返回的Transferable的getTransferData（）方法执行数据传输。

        在完成一个下降之后，需要执行此方法来通过将适当的boolean传递给DropTargetDropEvent的dropComplete（布尔成功）方法来表示掉落的成功/失败。

        注意：在调用DropTargetDropEvent的dropComplete（boolean success）方法之前，应该完成数据传输。 之后，只有当数据传输是本地时，才能保证Transferable返回的DropTargetDropEvent.getTransferable()的getTransferData（）方法的调用成功; 也就是说，只有DropTargetDropEvent.isLocalTransfer()返回true 。 否则，呼叫的行为是依赖于实现的。

        参数
        dtde - the DropTargetDropEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidDnDOperationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class InvalidDnDOperationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.awt.dnd.InvalidDnDOperationException
  • All Implemented Interfaces:
    Serializable

    public class InvalidDnDOperationException
extends IllegalStateException
    java.awt.dnd包中的各种方法抛出此异常。 通常，由于潜在的DnD系统不在适当状态，因此通常会指出目标目标无法进行当前所请求的操作。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidDnDOperationException​()
      创建一个默认的异常
      InvalidDnDOperationException​(String msg)
      使用自己的描述性消息创建异常

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidDnDOperationException

        public InvalidDnDOperationException​()
        创建一个默认的异常

      • InvalidDnDOperationException

        public InvalidDnDOperationException​(String msg)
        使用自己的描述性消息创建异常
        参数
        msg - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.dnd (Java SE 9 & JDK 9 )

java.awt.dnd

Interfaces

  • Autoscroll
  • DragGestureListener
  • DragSourceListener
  • DragSourceMotionListener
  • DropTargetListener

Classes

  • DnDConstants
  • DragGestureEvent
  • DragGestureRecognizer
  • DragSource
  • DragSourceAdapter
  • DragSourceContext
  • DragSourceDragEvent
  • DragSourceDropEvent
  • DragSourceEvent
  • DropTarget
  • DropTarget.DropTargetAutoScroller
  • DropTargetAdapter
  • DropTargetContext
  • DropTargetDragEvent
  • DropTargetDropEvent
  • DropTargetEvent
  • MouseDragGestureRecognizer

Exceptions

  • InvalidDnDOperationException


java.awt.dnd (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.dnd

拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。 通常由使用适当输入设备的人类用户的身体手势驱动，拖放提供了一种机制，以便在通过GUI中的呈现元素的导航期间启用关于任何后续数据传送到用户的可能结果的连续反馈，以及提供任何后续数据协商和转让的设施。

此包定义了在Java中执行拖放操作所需的类和接口。 它定义了drag-source和drop-target的类，以及用于传输被拖动的数据的事件。 该包还提供了在拖放操作的持续时间内向用户提供视觉反馈的方法。

典型的拖放操作可以分解成以下状态（不是完全依次）：

  • A DragSource存在，与GUI中的一些表示元素（ Component ）相关联，以启动一些潜在的Transferable数据的拖放。
  • 1或更多的DropTarget （s）进入/退出存在，与GUI（组件）中的表示元素相关联，潜在地能够消耗Transferable数据类型。
  • 甲DragGestureRecognizer从所得DragSource并且与相关联的Component ，以便跟踪和由用户在识别任何拖动启动动作Component 。
  • 用户通过Component （其注册的DragGestureRecognizer检测到的拖动手势，并通知其DragGestureListener 。

    注意：虽然这个API一贯地指的是一个拖放操作是由人类用户进行的物理手势的刺激，但是在给出适当的DragSource实现的情况下，这并不排除编程驱动的DnD操作。 该包包含用于识别鼠标设备手势的抽象类MouseDragGestureRecognizer 。 其他抽象子类可以由平台提供，以支持其他输入设备或特定的Component类语义。

  • DragGestureListener导致DragSource代表用户启动拖放操作，可能动画化GUI Cursor和/或呈现作为操作Image的项目的Image 。
  • 当用户手势导航超过Component在具有相关联的GUI（或多个） DropTarget （S），所述DragSource接收以便提供“拖过”反馈效果通知，并且DropTarget （一个或多个），以提供“拖放在接收通知“反馈效应基于所支持的操作和所涉及的数据类型。

手势本身将逻辑游标移动通过GUI层次结构，与GUI组件的几何相交，可能导致逻辑“拖”光标进入，交叉，随后离开Component （s）和关联的DropTarget （s）。

DragSource对象通过动画化与逻辑游标相关联的GUI Cursor ，在典型的情况下向用户显示“拖曳”反馈。

DropTarget对象通过将动画渲染到GUI Cursor下的关联GUI Component ，在典型的情况下，向用户显示“Drag Under”反馈。

应该发生反馈效应的确定以及数据传输的最终成功或失败，参数如下：

  • 通过用户选择的传输“操作”，并由DragSource和DropTarget ：复制，移动或引用（链接）支持。
  • 由DragSource提供的一组数据类型和DropTarget理解的数据类型DropTarget 。
  • 当用户终止拖动操作，通常导致一个成功的掉落，无论是DragSource和DropTarget接收通知包括，并导致类型的协商和的，与相关联的信息传送DragSource经由Transferable对象。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    Autoscroll
    在DnD操作期间，用户可能希望将操作的主题放在用户当前不可见的可滚动GUI控件的区域上。
    DragGestureListener
    用于接收拖动手势事件的侦听器界面。
    DragSourceListener
    DragSourceListener定义了用于跟踪用户手势状态的拖放操作的发起者的事件接口，并在拖放操作中向用户提供适当的“拖拽”反馈。
    DragSourceMotionListener
    用于在拖动操作期间接收鼠标运动事件的侦听器界面。
    DropTargetListener
    DropTargetListener接口是 DropTarget类使用的回调接口，用于提供涉及主题 DropTarget的DnD操作的通知。
  • 类摘要
    Class 描述
    DnDConstants
    此类包含表示由拖放操作执行的操作类型的常量值。
    DragGestureEvent
    当特定的 DragGestureRecognizer检测到正在跟踪的 Component上发生平台相关的拖动启动手势时， DragGestureEvent将传递给 DragGestureListener的dragGestureRecognized（）方法。
    DragGestureRecognizer
    DragGestureRecognizer是一个用于规范平台相关的监听器的抽象基类，可以与特定的 Component相关联，以便识别平台相关的拖动启动手势。
    DragSource
    DragSource是负责启动拖放操作的实体，可用于多种情况：在该JVM的生命周期中，每个JVM使用1个默认实例。
    DragSourceAdapter
    用于接收拖动源事件的抽象适配器类。
    DragSourceContext
    DragSourceContext类负责管理拖放协议的发起方。
    DragSourceDragEvent
    DragSourceDragEvent从 DragSourceContextPeer通过 DragSourceContext发送到 DragSourceListener注册 DragSourceContext及其相关联的 DragSource 。
    DragSourceDropEvent
    所述 DragSourceDropEvent从递送 DragSourceContextPeer ，经由 DragSourceContext ，到 dragDropEnd的方法 DragSourceListener与注册小号 DragSourceContext和与其相关联的 DragSource 。
    DragSourceEvent
    这个类是 DragSourceDragEvent和 DragSourceDropEvent的基类。
    DropTarget
    该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。
    DropTarget.DropTargetAutoScroller
    这个受保护的嵌套类实现自动滚动
    DropTargetAdapter
    用于接收丢弃目标事件的抽象适配器类。
    DropTargetContext
    甲 DropTargetContext每当用拖放操作相关联的逻辑光标用的可见几何一致创建 Component与相关联 DropTarget 。
    DropTargetDragEvent
    所述 DropTargetDragEvent被输送到 DropTargetListener经由其dragEnter事件（）和的dragover（）方法。
    DropTargetDropEvent
    DropTargetDropEvent是通过 DropTargetListener drop（）方法提供的。
    DropTargetEvent
    DropTargetEvent是 DropTargetDragEvent和 DropTargetDropEvent的基础类。
    MouseDragGestureRecognizer
    DragGestureRecognizer这个抽象子类定义了一个基于鼠标的手势的 DragGestureRecognizer 。
  • 异常摘要
    异常 描述
    InvalidDnDOperationException
    java.awt.dnd包中的各种方法抛出此异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.dnd Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.dnd

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.dnd.DnDConstants
    • java.awt.dnd.DragGestureRecognizer (implements java.io.Serializable)
      • java.awt.dnd.MouseDragGestureRecognizer (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.dnd.DragSource (implements java.io.Serializable)
    • java.awt.dnd.DragSourceAdapter (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener)
    • java.awt.dnd.DragSourceContext (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener, java.io.Serializable)
    • java.awt.dnd.DropTarget (implements java.awt.dnd.DropTargetListener, java.io.Serializable)
    • java.awt.dnd.DropTarget.DropTargetAutoScroller (implements java.awt.event.ActionListener)
    • java.awt.dnd.DropTargetAdapter (implements java.awt.dnd.DropTargetListener)
    • java.awt.dnd.DropTargetContext (implements java.io.Serializable)
    • java.awt.dnd.DropTargetContext.TransferableProxy (implements java.awt.datatransfer.Transferable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.dnd.DragGestureEvent
      • java.awt.dnd.DragSourceEvent
        • java.awt.dnd.DragSourceDragEvent
        • java.awt.dnd.DragSourceDropEvent
      • java.awt.dnd.DropTargetEvent
        • java.awt.dnd.DropTargetDragEvent
        • java.awt.dnd.DropTargetDropEvent
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.awt.dnd.InvalidDnDOperationException

Interface Hierarchy

  • java.awt.dnd.Autoscroll
  • java.util.EventListener
    • java.awt.dnd.DragGestureListener
    • java.awt.dnd.DragSourceListener
    • java.awt.dnd.DragSourceMotionListener
    • java.awt.dnd.DropTargetListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


MouseDragGestureRecognizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.dnd

Class MouseDragGestureRecognizer

  • java.lang.Object
    • java.awt.dnd.DragGestureRecognizer
      • java.awt.dnd.MouseDragGestureRecognizer
  • All Implemented Interfaces:
    MouseListener ， MouseMotionListener ， Serializable ， EventListener

    public abstract class MouseDragGestureRecognizer
extends DragGestureRecognizer
implements MouseListener, MouseMotionListener
    DragGestureRecognizer这个抽象子类定义了一个基于鼠标的手势的DragGestureRecognizer 。 每个平台通过Toolkit.createDragGestureRecognizer（）方法实现了自己具有的这个类的具体子类，以便对启动拖放操作的平台相关鼠标手势的识别进行封装。

    鼠标拖动手势识别器应该遵守拖动手势运动阈值，可通过DragSource.getDragThreshold()获得 。 只有当最新的鼠标拖动事件的位置与相应的鼠标按钮按下事件的位置之间的水平或垂直方向上的距离大于拖动手势运动阈值时才能识别拖动手势。

    使用DragSource.createDefaultDragGestureRecognizer(java.awt.Component, int, java.awt.dnd.DragGestureListener)创建的拖动手势识别器遵循此惯例。

    另请参见：
    DragGestureListener ， DragGestureEvent ， DragSource ， Serialized Form

    • Field Summary

      • Fields inherited from class java.awt.dnd.DragGestureRecognizer

        component, dragGestureListener, dragSource, events, sourceActions

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected MouseDragGestureRecognizer​(DragSource ds)
      构造新的 MouseDragGestureRecognizer给予 DragSource为 Component 。
      protected MouseDragGestureRecognizer​(DragSource ds, Component c)
      构建新的 MouseDragGestureRecognizer给予 DragSource为 Component c和 Component观察。
      protected MouseDragGestureRecognizer​(DragSource ds, Component c, int act)
      构造新的 MouseDragGestureRecognizer给予 DragSource为 Component c， Component观察，并允许这种拖动操作的动作。
      protected MouseDragGestureRecognizer​(DragSource ds, Component c, int act, DragGestureListener dgl)
      构造一个新的 MouseDragGestureRecognizer给出 DragSource为 Component c， Component观察，这个拖动操作允许的动作，以及 DragGestureListener通知何时检测到拖动手势。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void mouseClicked​(MouseEvent e)
      当鼠标点击组件时调用。
      void mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void mouseMoved​(MouseEvent e)
      在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
      void mousePressed​(MouseEvent e)
      在 Component上按下鼠标按钮时调用。
      void mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。
      protected void registerListeners​()
      使用组件注册此DragGestureRecognizer的侦听器
      protected void unregisterListeners​()
      使用Component子类取消注册此DragGestureRecognizer的侦听器必须覆盖此方法

      • Methods inherited from class java.awt.dnd.DragGestureRecognizer

        addDragGestureListener, appendEvent, fireDragGestureRecognized, getComponent, getDragSource, getSourceActions, getTriggerEvent, removeDragGestureListener, resetRecognizer, setComponent, setSourceActions

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MouseDragGestureRecognizer

        protected MouseDragGestureRecognizer​(DragSource ds,
                                     Component c,
                                     int act,
                                     DragGestureListener dgl)
        构造一个新的 MouseDragGestureRecognizer给出 DragSource为 Component c， Component观察，这个拖动操作允许的动作，以及 DragGestureListener通知何时检测到拖动手势。
        参数
        ds - 组件的DragSource c
        c - 要观察的组件
        act - 此拖动允许的操作
        dgl - 当检测到手势时通知DragGestureListener

      • MouseDragGestureRecognizer

        protected MouseDragGestureRecognizer​(DragSource ds,
                                     Component c,
                                     int act)
        构造一个新的 MouseDragGestureRecognizer给予 DragSource为 Component c， Component观察，并允许这个拖动操作的动作。
        参数
        ds - 组件的DragSource c
        c - 要观察的组件
        act - 此拖动允许的操作

      • MouseDragGestureRecognizer

        protected MouseDragGestureRecognizer​(DragSource ds,
                                     Component c)
        构建新的 MouseDragGestureRecognizer给予 DragSource为 Component c和 Component观察。
        参数
        ds - 组件的DragSource c
        c - 要观察的组件

      • MouseDragGestureRecognizer

        protected MouseDragGestureRecognizer​(DragSource ds)
        构造一个新的 MouseDragGestureRecognizer给予 DragSource为 Component 。
        参数
        ds - 组件的DragSource

    • 方法详细信息

      • registerListeners

        protected void registerListeners​()
        使用组件注册此DragGestureRecognizer的侦听器
        Specified by:
        registerListeners在 DragGestureRecognizer

      • unregisterListeners

        protected void unregisterListeners​()
        使用Component子类取消注册此DragGestureRecognizer的侦听器必须覆盖此方法
        Specified by:
        unregisterListeners在 DragGestureRecognizer

      • mouseClicked

        public void mouseClicked​(MouseEvent e)
        当鼠标点击组件时调用。
        Specified by:
        mouseClicked接口 MouseListener
        参数
        e - MouseEvent

      • mousePressed

        public void mousePressed​(MouseEvent e)
        在 Component上按下鼠标按钮时调用。
        Specified by:
        mousePressed接口 MouseListener
        参数
        e - MouseEvent

      • mouseReleased

        public void mouseReleased​(MouseEvent e)
        在组件上释放鼠标按钮时调用。
        Specified by:
        mouseReleased接口 MouseListener
        参数
        e - MouseEvent

      • mouseEntered

        public void mouseEntered​(MouseEvent e)
        当鼠标进入组件时调用。
        Specified by:
        mouseEntered在接口 MouseListener
        参数
        e - MouseEvent

      • mouseExited

        public void mouseExited​(MouseEvent e)
        当鼠标退出组件时调用。
        Specified by:
        mouseExited在接口 MouseListener
        参数
        e - MouseEvent

      • mouseDragged

        public void mouseDragged​(MouseEvent e)
        在组件上按下鼠标按钮时调用。
        Specified by:
        mouseDragged在接口 MouseMotionListener
        参数
        e - MouseEvent

      • mouseMoved

        public void mouseMoved​(MouseEvent e)
        在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
        Specified by:
        mouseMoved在接口 MouseMotionListener
        参数
        e - the MouseEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.dnd (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.dnd

  • Packages that use java.awt.dnd
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
  • Classes in java.awt.dnd used by java.awt
    Class 描述
    DragGestureListener
    用于接收拖动手势事件的侦听器界面。
    DragGestureRecognizer
    DragGestureRecognizer是一个抽象基类，用于规范与平台相关的侦听器，可以与特定的 Component相关联，以便识别平台相关的拖动启动手势。
    DragSource
    DragSource是负责启动“拖放”操作的实体，可用于多种情况：该JVM的生命周期为每个JVM使用1个默认实例。
    DropTarget
    该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。
  • Classes in java.awt.dnd used by java.awt.dnd
    Class 描述
    DragGestureEvent
    当特定的 DragGestureRecognizer检测到正在跟踪的 Component上发生平台相关的拖动启动手势时， DragGestureEvent将传递给 DragGestureListener的dragGestureRecognized（）方法。
    DragGestureListener
    用于接收拖动手势事件的侦听器界面。
    DragGestureRecognizer
    DragGestureRecognizer是一个用于指定与平台相关的侦听器的抽象基类，可以与特定的 Component相关联，以便识别平台相关的拖动启动手势。
    DragSource
    DragSource是负责启动拖放操作的实体，可用于多种情况：在该JVM的生命周期中每个JVM使用1个默认实例。
    DragSourceContext
    DragSourceContext类负责管理拖放协议的发起方。
    DragSourceDragEvent
    DragSourceDragEvent从 DragSourceContextPeer通过 DragSourceContext发送到 DragSourceListener注册 DragSourceContext及其相关联的 DragSource 。
    DragSourceDropEvent
    DragSourceDropEvent从 DragSourceContextPeer通过 DragSourceContext发送到 dragDropEnd注册的 DragSourceListener的 DragSourceContext及其相关联的 DragSource 。
    DragSourceEvent
    这个类是 DragSourceDragEvent和 DragSourceDropEvent的基类。
    DragSourceListener
    DragSourceListener定义了用于跟踪用户手势状态的拖放操作的发起者的事件接口，并在拖放操作中向用户提供适当的“拖拽”反馈。
    DragSourceMotionListener
    用于在拖动操作期间接收鼠标运动事件的侦听器界面。
    DropTarget
    该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。
    DropTarget.DropTargetAutoScroller
    这个受保护的嵌套类实现自动滚动
    DropTargetContext
    甲 DropTargetContext每当用拖放操作相关联的逻辑光标用的可见几何一致创建 Component与相关联 DropTarget 。
    DropTargetDragEvent
    所述 DropTargetDragEvent被输送到 DropTargetListener经由其dragEnter事件（）和的dragover（）方法。
    DropTargetDropEvent
    DropTargetDropEvent通过 DropTargetListener drop（）方法传递。
    DropTargetEvent
    DropTargetEvent是 DropTargetDragEvent和 DropTargetDropEvent的基础类。
    DropTargetListener
    DropTargetListener接口是 DropTarget类使用的回调接口，用于提供涉及主题 DropTarget的DnD操作的通知。
    InvalidDnDOperationException
    java.awt.dnd包中的各种方法抛出此异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DnDConstants (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DnDConstants

No usage of java.awt.dnd.DnDConstants
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragGestureEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragGestureEvent

  • Packages that use DragGestureEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragGestureEvent in java.awt.dnd

      Methods in java.awt.dnd that return DragGestureEvent
      Modifier and Type 方法 描述
      DragGestureEvent DragSourceContext.getTrigger​()
      返回最初触发拖动的 DragGestureEvent 。
      Methods in java.awt.dnd with parameters of type DragGestureEvent
      Modifier and Type 方法 描述
      protected DragSourceContext DragSource.createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      void DragGestureListener.dragGestureRecognized​(DragGestureEvent dge)
      当 DragGestureRecognizer检测到平台相关的拖动启动手势时，这个方法由 DragGestureRecognizer调用。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
      Constructors in java.awt.dnd with parameters of type DragGestureEvent
      Constructor 描述
      DragSourceContext​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
      从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragGestureRecognizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragGestureRecognizer

  • Packages that use DragGestureRecognizer
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragGestureRecognizer in java.awt

      Methods in java.awt with type parameters of type DragGestureRecognizer
      Modifier and Type 方法 描述
      <T extends DragGestureRecognizer>
      T             		Toolkit.createDragGestureRecognizer​(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
      创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。

    • Uses of DragGestureRecognizer in java.awt.dnd

      Subclasses of DragGestureRecognizer in java.awt.dnd
      Modifier and Type Class 描述
      class  MouseDragGestureRecognizer
      DragGestureRecognizer这个抽象子类定义了一个基于鼠标的手势的 DragGestureRecognizer 。
      Methods in java.awt.dnd with type parameters of type DragGestureRecognizer
      Modifier and Type 方法 描述
      <T extends DragGestureRecognizer>
      T             		DragSource.createDragGestureRecognizer​(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer ，实现指定的抽象子类 DragGestureRecognizer ，并在新创建的对象上设置指定的 Component和 DragGestureListener 。
      Methods in java.awt.dnd that return DragGestureRecognizer
      Modifier and Type 方法 描述
      DragGestureRecognizer DragSource.createDefaultDragGestureRecognizer​(Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer实现的默认抽象子类 DragGestureRecognizer这个 DragSource ，并设置指定 Component和 DragGestureListener新创建的对象上。
      DragGestureRecognizer DragGestureEvent.getSourceAsDragGestureRecognizer​()
      返回源为 DragGestureRecognizer 。
      Constructors in java.awt.dnd with parameters of type DragGestureRecognizer
      Constructor 描述
      DragGestureEvent​(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
      构造一个 DragGestureEvent由给定对象 DragGestureRecognizer实例激发此事件中， act表示用户的首选操作参数，一个 ori参数指示拖动原点，和一个 List组成动作（事件 evs参数）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragSource

  • Packages that use DragSource
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragSource in java.awt

      Methods in java.awt with parameters of type DragSource
      Modifier and Type 方法 描述
      <T extends DragGestureRecognizer>
      T             		Toolkit.createDragGestureRecognizer​(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
      创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。

    • Uses of DragSource in java.awt.dnd

      Fields in java.awt.dnd declared as DragSource
      Modifier and Type Field 描述
      protected DragSource DragGestureRecognizer.dragSource
      该 DragSource与此 DragGestureRecognizer相关联。
      Methods in java.awt.dnd that return DragSource
      Modifier and Type 方法 描述
      static DragSource DragSource.getDefaultDragSource​()
      获取与底层平台相关联的 DragSource对象。
      DragSource DragGestureEvent.getDragSource​()
      返回 DragSource 。
      DragSource DragGestureRecognizer.getDragSource​()
      此方法返回 DragSource这个 DragGestureRecognizer将会使用为了处理拖放操作。
      DragSource DragSourceContext.getDragSource​()
      返回 DragSource认为这个实例 DragSourceContext 。
      Constructors in java.awt.dnd with parameters of type DragSource
      Constructor 描述
      DragGestureRecognizer​(DragSource ds)
      构造一个新的 DragGestureRecognizer给予 DragSource用于此拖放操作。
      DragGestureRecognizer​(DragSource ds, Component c)
      构造一个新的 DragGestureRecognizer给定 DragSource用于这个拖放操作，而 Component这 DragGestureRecognizer应该“观察”拖动启动手势。
      DragGestureRecognizer​(DragSource ds, Component c, int sa)
      构造一个新的 DragGestureRecognizer给定 DragSource用于这个拖放操作， Component这 DragGestureRecognizer应该“观察”拖动启动手势，以及此拖放操作支持的操作。
      DragGestureRecognizer​(DragSource ds, Component c, int sa, DragGestureListener dgl)
      构造一个新的 DragGestureRecognizer给定 DragSource用于这个拖放操作， Component这个 DragGestureRecognizer应该“观察”拖动启动手势，这个拖放操作支持的动作，以及 DragGestureListener通知一次已经检测到拖动启动手势。
      MouseDragGestureRecognizer​(DragSource ds)
      构造一个新的 MouseDragGestureRecognizer给予 DragSource为 Component 。
      MouseDragGestureRecognizer​(DragSource ds, Component c)
      构造新的 MouseDragGestureRecognizer给予 DragSource为 Component c和 Component观察。
      MouseDragGestureRecognizer​(DragSource ds, Component c, int act)
      构造一个新的 MouseDragGestureRecognizer给出 DragSource为 Component c， Component观察，并允许这个拖动操作的动作。
      MouseDragGestureRecognizer​(DragSource ds, Component c, int act, DragGestureListener dgl)
      构造一个新的 MouseDragGestureRecognizer给出 DragSource的 Component c， Component观察，允许此拖动操作的动作，以及 DragGestureListener在检测到拖动手势时通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragSourceAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragSourceAdapter

No usage of java.awt.dnd.DragSourceAdapter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragSourceContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragSourceContext

  • Packages that use DragSourceContext
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragSourceContext in java.awt.dnd

      Methods in java.awt.dnd that return DragSourceContext
      Modifier and Type 方法 描述
      protected DragSourceContext DragSource.createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      DragSourceContext DragSourceEvent.getDragSourceContext​()
      此方法返回发起事件的 DragSourceContext 。
      Constructors in java.awt.dnd with parameters of type DragSourceContext
      Constructor 描述
      DragSourceDragEvent​(DragSourceContext dsc, int dropAction, int action, int modifiers)
      构造一个 DragSourceDragEvent 。
      DragSourceDragEvent​(DragSourceContext dsc, int dropAction, int action, int modifiers, int x, int y)
      构造一个 DragSourceDragEvent给定了指定的 DragSourceContext ，用户放置操作，目标放置操作，修饰符和坐标。
      DragSourceDropEvent​(DragSourceContext dsc)
      构造一个 DragSourceDropEvent用于不会导致下降的拖动。
      DragSourceDropEvent​(DragSourceContext dsc, int action, boolean success)
      构建一个 DragSourceDropEvent的一个下降，给出了 DragSourceContext的下拉操作，以及一个 boolean表示下降是否成功。
      DragSourceDropEvent​(DragSourceContext dsc, int action, boolean success, int x, int y)
      构造一个 DragSourceDropEvent的一个下降，给出了 DragSourceContext ，下降动作，一个 boolean指示下降是否成功，并且坐标。
      DragSourceEvent​(DragSourceContext dsc)
      构造一个 DragSourceEvent给定一个指定的 DragSourceContext 。
      DragSourceEvent​(DragSourceContext dsc, int x, int y)
      构造一个 DragSourceEvent给定一个指定的 DragSourceContext和光标位置的坐标。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragSourceDragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragSourceDragEvent

  • Packages that use DragSourceDragEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragSourceDragEvent in java.awt.dnd

      Methods in java.awt.dnd with parameters of type DragSourceDragEvent
      Modifier and Type 方法 描述
      void DragSourceAdapter.dragEnter​(DragSourceDragEvent dsde)
      称为光标的热点进入平台依赖的放置站点。
      void DragSourceContext.dragEnter​(DragSourceDragEvent dsde)
      电话 dragEnter在 DragSourceListener注册了这个 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
      void DragSourceListener.dragEnter​(DragSourceDragEvent dsde)
      称为光标的热点进入平台依赖的放置站点。
      void DragSourceAdapter.dragMouseMoved​(DragSourceDragEvent dsde)
      在拖动操作期间鼠标移动时调用。
      void DragSourceContext.dragMouseMoved​(DragSourceDragEvent dsde)
      呼吁 dragMouseMoved上 DragSourceMotionListener与注册小号 DragSource与此相关 DragSourceContext ，并将它们传递指定 DragSourceDragEvent 。
      void DragSourceMotionListener.dragMouseMoved​(DragSourceDragEvent dsde)
      在拖动操作期间鼠标移动时调用。
      void DragSourceAdapter.dragOver​(DragSourceDragEvent dsde)
      称为光标的热点在平台相关的放置站点上移动。
      void DragSourceContext.dragOver​(DragSourceDragEvent dsde)
      致电 dragOver在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
      void DragSourceListener.dragOver​(DragSourceDragEvent dsde)
      称为光标的热点在平台相关的放置站点上移动。
      void DragSourceAdapter.dropActionChanged​(DragSourceDragEvent dsde)
      当用户修改了放置手势时调用。
      void DragSourceContext.dropActionChanged​(DragSourceDragEvent dsde)
      致电 dropActionChanged在 DragSourceListener注册的 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDragEvent 。
      void DragSourceListener.dropActionChanged​(DragSourceDragEvent dsde)
      Called when the user has modified the drop gesture.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragSourceDropEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragSourceDropEvent

  • Packages that use DragSourceDropEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragSourceDropEvent in java.awt.dnd

      Methods in java.awt.dnd with parameters of type DragSourceDropEvent
      Modifier and Type 方法 描述
      void DragSourceAdapter.dragDropEnd​(DragSourceDropEvent dsde)
      调用此方法来表示拖放操作完成。
      void DragSourceContext.dragDropEnd​(DragSourceDropEvent dsde)
      致电 dragDropEnd在 DragSourceListener注册该 DragSourceContext和相关联的 DragSource ，并通过他们指定的 DragSourceDropEvent 。
      void DragSourceListener.dragDropEnd​(DragSourceDropEvent dsde)
      调用此方法来表示拖放操作完成。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DragSourceEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DragSourceEvent

  • Packages that use DragSourceEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragSourceEvent in java.awt.dnd

      Subclasses of DragSourceEvent in java.awt.dnd
      Modifier and Type Class 描述
      class  DragSourceDragEvent
      DragSourceDragEvent从 DragSourceContextPeer通过 DragSourceContext发送到 DragSourceListener注册 DragSourceContext及其相关联的 DragSource 。
      class  DragSourceDropEvent
      DragSourceDropEvent是从 DragSourceContextPeer通过 DragSourceContext发送到 dragDropEnd的 DragSourceListener注册的 DragSourceContext及其相关联的 DragSource 。
      Methods in java.awt.dnd with parameters of type DragSourceEvent
      Modifier and Type 方法 描述
      void DragSourceAdapter.dragExit​(DragSourceEvent dse)
      称为光标的热点退出平台相关的放置站点。
      void DragSourceContext.dragExit​(DragSourceEvent dse)
      致电 dragExit在 DragSourceListener注册了这个 DragSourceContext和相关的 DragSource ，并通过他们指定的 DragSourceEvent 。
      void DragSourceListener.dragExit​(DragSourceEvent dse)
      称为光标的热点退出平台相关的放置站点。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTarget (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTarget

  • Packages that use DropTarget
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DropTarget in java.awt

      Methods in java.awt that return DropTarget
      Modifier and Type 方法 描述
      DropTarget Component.getDropTarget​()
      获取 DropTarget与此 Component相关联。
      Methods in java.awt with parameters of type DropTarget
      Modifier and Type 方法 描述
      void Component.setDropTarget​(DropTarget dt)
      将一个 DropTarget与此组件关联。

    • Uses of DropTarget in java.awt.dnd

      Methods in java.awt.dnd that return DropTarget
      Modifier and Type 方法 描述
      DropTarget DropTargetContext.getDropTarget​()
      此方法返回 DropTarget与此相关 DropTargetContext 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTarget.DropTargetAutoScroller (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTarget.DropTargetAutoScroller

  • Packages that use DropTarget.DropTargetAutoScroller
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DropTarget.DropTargetAutoScroller in java.awt.dnd

      Methods in java.awt.dnd that return DropTarget.DropTargetAutoScroller
      Modifier and Type 方法 描述
      protected DropTarget.DropTargetAutoScroller DropTarget.createDropTargetAutoScroller​(Component c, Point p)
      创建一个嵌入式自动推送器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTargetAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTargetAdapter

No usage of java.awt.dnd.DropTargetAdapter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTargetContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTargetContext

  • Packages that use DropTargetContext
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DropTargetContext in java.awt.dnd

      Fields in java.awt.dnd declared as DropTargetContext
      Modifier and Type Field 描述
      protected DropTargetContext DropTargetEvent.context
      该 DropTargetContext与此 DropTargetEvent相关联。
      Methods in java.awt.dnd that return DropTargetContext
      Modifier and Type 方法 描述
      protected DropTargetContext DropTarget.createDropTargetContext​()
      创建与此DropTarget关联的DropTargetContext。
      DropTargetContext DropTarget.getDropTargetContext​()
      获取 DropTargetContext与此 DropTarget相关联。
      DropTargetContext DropTargetEvent.getDropTargetContext​()
      此方法返回 DropTargetContext与此相关 DropTargetEvent 。
      Constructors in java.awt.dnd with parameters of type DropTargetContext
      Constructor 描述
      DropTargetDragEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
      构造一个 DropTargetDragEvent给出的 DropTargetContext此操作中，“拖”的位置 Cursor “在S热点 Component坐标”，用户放置动作，和源drop操作。
      DropTargetDropEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
      构造一个 DropTargetDropEvent给出的 DropTargetContext进行此操作，拖动的位置 Cursor的在热点 Component坐标，当前选择的用户放置动作，和当前的一组源支持的操作“。
      DropTargetDropEvent​(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
      构造一个 DropTargetEvent给出的 DropTargetContext进行此操作，拖动的位置 Cursor的在热点 Component坐标“时，当前选定的用户放置动作，当前一组的所述源支持的动作，和一个 boolean指示源与目标相同的JVM。
      DropTargetEvent​(DropTargetContext dtc)
      构造一个 DropTargetEvent对象与指定的 DropTargetContext 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTargetContext.TransferableProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTargetContext.TransferableProxy

No usage of java.awt.dnd.DropTargetContext.TransferableProxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTargetDragEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTargetDragEvent

  • Packages that use DropTargetDragEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DropTargetDragEvent in java.awt.dnd

      Methods in java.awt.dnd with parameters of type DropTargetDragEvent
      Modifier and Type 方法 描述
      void DropTarget.dragEnter​(DropTargetDragEvent dtde)
      致电 dragEnter在注册的 DropTargetListener并通过指定的 DropTargetDragEvent 。
      void DropTargetAdapter.dragEnter​(DropTargetDragEvent dtde)
      当拖动操作正在进行时，当鼠标指针进入为此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
      void DropTargetListener.dragEnter​(DropTargetDragEvent dtde)
      当拖动操作正在进行时，当鼠标指针进入为此监听 DropTarget注册的 DropTarget站点的可操作部分时 DropTarget 。
      void DropTarget.dragOver​(DropTargetDragEvent dtde)
      致电 dragOver注册 DropTargetListener并通过指定的 DropTargetDragEvent 。
      void DropTargetAdapter.dragOver​(DropTargetDragEvent dtde)
      当拖动操作正在进行时被调用，而鼠标指针仍然在该监听 DropTarget注册的 DropTarget的放置站点的可操作部分上。
      void DropTargetListener.dragOver​(DropTargetDragEvent dtde)
      当拖动操作正在进行时被调用，而鼠标指针仍然在为该监听 DropTarget注册的 DropTarget的放置站点的可操作部分上。
      void DropTarget.dropActionChanged​(DropTargetDragEvent dtde)
      致电 dropActionChanged在注册的 DropTargetListener并通过指定的 DropTargetDragEvent 。
      void DropTargetAdapter.dropActionChanged​(DropTargetDragEvent dtde)
      如果用户修改了当前的放置手势，则被调用。
      void DropTargetListener.dropActionChanged​(DropTargetDragEvent dtde)
      如果用户修改了当前的放置手势，则被调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTargetDropEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTargetDropEvent

  • Packages that use DropTargetDropEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DropTargetDropEvent in java.awt.dnd

      Methods in java.awt.dnd with parameters of type DropTargetDropEvent
      Modifier and Type 方法 描述
      void DropTarget.drop​(DropTargetDropEvent dtde)
      致电 drop在注册的 DropTargetListener并通过它指定的 DropTargetDropEvent如果这个 DropTarget是活动的。
      void DropTargetListener.drop​(DropTargetDropEvent dtde)
      当拖动操作已终止时，在该监听 DropTarget注册的 DropTarget的可放置站点的可操作部分中 DropTarget 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.DropTargetEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.DropTargetEvent

  • Packages that use DropTargetEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DropTargetEvent in java.awt.dnd

      Subclasses of DropTargetEvent in java.awt.dnd
      Modifier and Type Class 描述
      class  DropTargetDragEvent
      所述 DropTargetDragEvent被输送到 DropTargetListener经由其dragEnter事件（）和的dragover（）方法。
      class  DropTargetDropEvent
      DropTargetDropEvent通过 DropTargetListener drop（）方法传递。
      Methods in java.awt.dnd with parameters of type DropTargetEvent
      Modifier and Type 方法 描述
      void DropTarget.dragExit​(DropTargetEvent dte)
      致电 dragExit在注册的 DropTargetListener并通过指定的 DropTargetEvent 。
      void DropTargetAdapter.dragExit​(DropTargetEvent dte)
      当拖动操作正在进行时，当鼠标指针已经退出到此监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
      void DropTargetListener.dragExit​(DropTargetEvent dte)
      当拖动操作正在进行时，当鼠标指针已经退出了对该监听 DropTarget注册的 DropTarget的放置站点的可操作部分时 DropTarget 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.InvalidDnDOperationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.InvalidDnDOperationException

  • Packages that use InvalidDnDOperationException
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of InvalidDnDOperationException in java.awt.dnd

      Methods in java.awt.dnd that throw InvalidDnDOperationException
      Modifier and Type 方法 描述
      void DropTargetContext.dropComplete​(boolean success)
      该方法表明，下降完成并且成功。
      protected Transferable DropTargetContext.getTransferable​()
      获取此操作的可转移（代理）操作数
      void DragGestureEvent.startDrag​(Cursor dragCursor, Transferable transferable)
      开始拖动操作，给出 Cursor此拖动操作，而 Transferable表示此拖动操作的源数据。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始拖动给出初始的 Cursor显示， Transferable对象和 DragSourceListener使用。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl)
      开始拖动给出初始的 Cursor来显示，拖动 Image ，偏移量为 Image ，对象为 Transferable ，并使用 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.dnd.MouseDragGestureRecognizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.dnd.MouseDragGestureRecognizer

No usage of java.awt.dnd.MouseDragGestureRecognizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.dnd.Autoscroll (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.dnd.Autoscroll

No usage of java.awt.dnd.Autoscroll
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.dnd.DragGestureListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.dnd.DragGestureListener

  • Packages that use DragGestureListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragGestureListener in java.awt

      Methods in java.awt with parameters of type DragGestureListener
      Modifier and Type 方法 描述
      <T extends DragGestureRecognizer>
      T             		Toolkit.createDragGestureRecognizer​(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
      创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。

    • Uses of DragGestureListener in java.awt.dnd

      Fields in java.awt.dnd declared as DragGestureListener
      Modifier and Type Field 描述
      protected DragGestureListener DragGestureRecognizer.dragGestureListener
      该 DragGestureListener与此 DragGestureRecognizer相关联。
      Methods in java.awt.dnd with parameters of type DragGestureListener
      Modifier and Type 方法 描述
      void DragGestureRecognizer.addDragGestureListener​(DragGestureListener dgl)
      注册新的 DragGestureListener 。
      DragGestureRecognizer DragSource.createDefaultDragGestureRecognizer​(Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer实现的默认抽象子类 DragGestureRecognizer这个 DragSource ，并设置指定 Component和 DragGestureListener新创建的对象上。
      <T extends DragGestureRecognizer>
      T             		DragSource.createDragGestureRecognizer​(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer ，实现指定的抽象子类为 DragGestureRecognizer ，并在新创建的对象上设置指定的 Component和 DragGestureListener 。
      void DragGestureRecognizer.removeDragGestureListener​(DragGestureListener dgl)
      取消注册当前的DragGestureListener
      Constructors in java.awt.dnd with parameters of type DragGestureListener
      Constructor 描述
      DragGestureRecognizer​(DragSource ds, Component c, int sa, DragGestureListener dgl)
      构造一个新的 DragGestureRecognizer给定 DragSource将用于此拖放操作， Component这 DragGestureRecognizer应该“观察”拖动启动手势，这个拖放操作支持的动作，以及 DragGestureListener通知一次已经检测到拖动启动手势。
      MouseDragGestureRecognizer​(DragSource ds, Component c, int act, DragGestureListener dgl)
      构造一个新的 MouseDragGestureRecognizer给予 DragSource为 Component c， Component观察，这个拖动操作允许的动作，以及 DragGestureListener通知何时检测到拖动手势。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.dnd.DragSourceListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.dnd.DragSourceListener

  • Packages that use DragSourceListener
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragSourceListener in java.awt.dnd

      Classes in java.awt.dnd that implement DragSourceListener
      Modifier and Type Class 描述
      class  DragSourceAdapter
      用于接收拖动源事件的抽象适配器类。
      class  DragSourceContext
      DragSourceContext类负责管理拖放协议的发起方。
      Methods in java.awt.dnd that return DragSourceListener
      Modifier and Type 方法 描述
      DragSourceListener[] DragSource.getDragSourceListeners​()
      获得 DragSourceListener注册的所有 DragSource 。
      Methods in java.awt.dnd with parameters of type DragSourceListener
      Modifier and Type 方法 描述
      void DragSource.addDragSourceListener​(DragSourceListener dsl)
      将指定的 DragSourceListener添加到此 DragSource以在使用此 DragSource启动的拖动操作期间接收拖动源事件。
      void DragSourceContext.addDragSourceListener​(DragSourceListener dsl)
      添加 DragSourceListener这个 DragSourceContext如果一个尚未加入。
      protected DragSourceContext DragSource.createDragSourceContext​(DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
      创建 DragSourceContext来处理当前的拖动操作。
      void DragSource.removeDragSourceListener​(DragSourceListener dsl)
      删除指定 DragSourceListener从这个 DragSource 。
      void DragSourceContext.removeDragSourceListener​(DragSourceListener dsl)
      删除指定 DragSourceListener从这个 DragSourceContext 。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始拖动给出初始的 Cursor显示， Transferable对象和 DragSourceListener使用。
      void DragGestureEvent.startDrag​(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl)
      启动给定的初始拖拽 Cursor显示，拖动 Image ，所述的偏移 Image ，所述 Transferable对象和 DragSourceListener使用。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Transferable拖动的目标数据，该 DragSourceListener和 FlavorMap 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在触发，拖动的目标数据的瞬间，和 DragSourceListener 。
      void DragSource.startDrag​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
      开始一拖，鉴于 DragGestureEvent启动拖动，初步 Cursor用， Image给拖累，抵消的 Image从的热点起源 Cursor在扳机的瞬间， Transferable拖动的目标数据， DragSourceListener和 FlavorMap 。
      Constructors in java.awt.dnd with parameters of type DragSourceListener
      Constructor 描述
      DragSourceContext​(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
      从名为 DragSource ，该构造函数创建一个新 DragSourceContext给出的 DragSourceContextPeer此拖累， DragGestureEvent触发该Drag的初始 Cursor使用的拖累，（可选的） Image ，而将正在发生显示的偏移 Image起源于触发事件瞬间的热点， Transferable主题数据，以及拖放操作期间使用的 DragSourceListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.dnd.DragSourceMotionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.dnd.DragSourceMotionListener

  • Packages that use DragSourceMotionListener
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DragSourceMotionListener in java.awt.dnd

      Classes in java.awt.dnd that implement DragSourceMotionListener
      Modifier and Type Class 描述
      class  DragSourceAdapter
      用于接收拖动源事件的抽象适配器类。
      class  DragSourceContext
      DragSourceContext类负责管理拖放协议的发起方。
      Methods in java.awt.dnd that return DragSourceMotionListener
      Modifier and Type 方法 描述
      DragSourceMotionListener[] DragSource.getDragSourceMotionListeners​()
      获得 DragSourceMotionListener注册的所有 DragSource 。
      Methods in java.awt.dnd with parameters of type DragSourceMotionListener
      Modifier and Type 方法 描述
      void DragSource.addDragSourceMotionListener​(DragSourceMotionListener dsml)
      添加指定 DragSourceMotionListener这个 DragSource期间与由此引发的拖动操作接收的拖动移动事件 DragSource 。
      void DragSource.removeDragSourceMotionListener​(DragSourceMotionListener dsml)
      删除指定 DragSourceMotionListener从这个 DragSource 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.dnd.DropTargetListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.dnd.DropTargetListener

  • Packages that use DropTargetListener
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

    • Uses of DropTargetListener in java.awt.dnd

      Classes in java.awt.dnd that implement DropTargetListener
      Modifier and Type Class 描述
      class  DropTarget
      该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。
      class  DropTargetAdapter
      用于接收丢弃目标事件的抽象适配器类。
      Methods in java.awt.dnd with parameters of type DropTargetListener
      Modifier and Type 方法 描述
      void DropTarget.addDropTargetListener​(DropTargetListener dtl)
      添加新的 DropTargetListener （UNICAST SOURCE）。
      void DropTarget.removeDropTargetListener​(DropTargetListener dtl)
      删除当前的 DropTargetListener （UNICAST SOURCE）。
      Constructors in java.awt.dnd with parameters of type DropTargetListener
      Constructor 描述
      DropTarget​(Component c, int ops, DropTargetListener dtl)
      创建 DropTarget给出的 Component与之关联，一个 int表示的默认可接受操作（一个或多个）来支持，和一个 DropTargetListener来处理事件处理。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act)
      创建一个 DropTarget给出 Component以关联自己，一个 int表示默认可接受的行动以支持，一个 DropTargetListener处理事件处理，以及一个 boolean指示 DropTarget是否正在接受丢弃。
      DropTarget​(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
      创建给定一个新的DropTarget Component与之关联，一个 int表示的默认可接受操作（一个或多个）来支持，一个 DropTargetListener来处理事件处理中， boolean指示该 DropTarget当前是否接受drop和 FlavorMap使用（或null为默认值 FlavorMap ）。
      DropTarget​(Component c, DropTargetListener dtl)
      创建一个 DropTarget给定的 Component来关联自己，和 DropTargetListener来处理事件处理。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AWT Threading Issues

Listeners and threads

Unless otherwise noted all AWT listeners are notified on the event dispatch thread. It is safe to remove/add listeners from any thread during dispatching, but the changes only effect subsequent notification.
For example, if a key listeners is added from another key listener, the newly added listener is only notified on subsequent key events.

Auto-shutdown

According to The Java™ Virtual Machine Specification, sections 2.17.9 and 2.19, the Java virtual machine (JVM) initially starts up with a single non-daemon thread, which typically calls the main method of some class. The virtual machine terminates all its activity and exits when one of two things happens:
  • All the threads that are not daemon threads terminate.
  • Some thread invokes the exit method of class Runtime or class System, and the exit operation is permitted by the security manager.

This implies that if an application doesn't start any threads itself, the JVM will exit as soon as main terminates. This is not the case, however, for a simple application that creates and displays a java.awt.Frame:

        public static void main(String[] args) {
            Frame frame = new Frame();
            frame.setVisible(true);
         }
The reason is that AWT encapsulates asynchronous event dispatch machinery to process events AWT or Swing components can fire. The exact behavior of this machinery is implementation-dependent. In particular, it can start non-daemon helper threads for its internal purposes. In fact, these are the threads that prevent the example above from exiting. The only restrictions imposed on the behavior of this machinery are as follows:
  • EventQueue.isDispatchThread returns true if and only if the calling thread is the event dispatch thread started by the machinery;
  • AWTEvents which were actually enqueued to a particular EventQueue (note that events being posted to the EventQueue can be coalesced) are dispatched:
    • Sequentially.
      That is, it is not permitted that several events from this queue are dispatched simultaneously.
    • In the same order as they are enqueued.
      That is, if AWTEvent A is enqueued to the EventQueue before AWTEvent B then event B will not be dispatched before event A.
  • There is at least one alive non-daemon thread while there is at least one displayable AWT or Swing component within the application (see Component.isDisplayable).
The implications of the third restriction are as follows:
  • The JVM will exit if some thread invokes the exit method of class Runtime or class System regardless of the presence of displayable components;
  • Even if the application terminates all non-daemon threads it started, the JVM will not exit while there is at least one displayable component.
It depends on the implementation if and when the non-daemon helper threads are terminated once all components are made undisplayable. The implementation-specific details are given below.

Implementation-dependent behavior.

Prior to 1.4, the helper threads were never terminated.

Starting with 1.4, the behavior has changed as a result of the fix for 4030718. With the current implementation, AWT terminates all its helper threads allowing the application to exit cleanly when the following three conditions are true:

  • There are no displayable AWT or Swing components.
  • There are no native events in the native event queue.
  • There are no AWT events in java EventQueues.
Therefore, a stand-alone AWT application that wishes to exit cleanly without calling System.exit must:
  • Make sure that all AWT or Swing components are made undisplayable when the application finishes. This can be done by calling Window.dispose on all top-level Windows. See Frame.getFrames.
  • Make sure that no method of AWT event listeners registered by the application with any AWT or Swing component can run into an infinite loop or hang indefinitely. For example, an AWT listener method triggered by some AWT event can post a new AWT event of the same type to the EventQueue. The argument is that methods of AWT event listeners are typically executed on helper threads.
Note, that while an application following these recommendations will exit cleanly under normal conditions, it is not guaranteed that it will exit cleanly in all cases. Two examples:
  • Other packages can create displayable components for internal needs and never make them undisplayable. See 4515058, 4671025, and 4465537.
  • Both Microsoft Windows and X11 allow an application to send native events to windows that belong to another application. With this feature it is possible to write a malicious program that will continuously send events to all available windows preventing any AWT application from exiting cleanly.
On the other hand, if you require the JVM to continue running even after the application has made all components undisplayable you should start a non-daemon thread that blocks forever.
        <...>
        Runnable r = new Runnable() {
            public void run() {
                Object o = new Object();
                try {
                    synchronized (o) {
                        o.wait();
                    }
                } catch (InterruptedException ie) {
                }
            }
        };
        Thread t = new Thread(r);
        t.setDaemon(false);
        t.start();
        <...>
The Java™ Virtual Machine Specification guarantees that the JVM doesn't exit until this thread terminates.


AWT Desktop Properties

The following refers to standard AWT desktop properties that may be obtained via the Toolkit.getDesktopProperty method.

Each desktop property is named by a unique string, which is the "name" of that property.

Desktop properties supported by the AWT but not documented elsewhere - typically because there is no suitable method or class - are documented here.

Desktop properties documented elsewhere are those which are tightly coupled with a method or class which documents them.

Since desktop properties abstract an underlying platform setting, they may not be available in environments that do not support them. In the event that a desktop property is unavailable for any reason, the implementation will return null.

The following table summarizes the desktop properties documented here, and their value types.

Property Name | Value Type | Summary Description
awt.font.desktophints | java.util.Map | Font smoothing (text antialiasing) settings.
sun.awt.enableExtraMouseButtons | java.lang.Boolean | Controls if mouse events from extra buttons are to be generated or not

Desktop Font Rendering Hints

Desktop Property: "awt.font.desktophints"

Modern desktops support various forms of text antialiasing (font smoothing).

These are applied by platform-specific heavyweight components. However an application may want to render text using the same text antialiasing on a drawing surface or lightweight (non-platform) component using Graphics2D methods. This is particularly important when creating Swing components which are required to appear consistent with native desktop components or other Swing components.

Basic Usage

The standard desktop property named "awt.font.desktophints" can be used to obtain the rendering hints that best match the desktop settings. The return value is a Map of RenderingHints which can be directly applied to a Graphics2D.

It is a Map as more than one hint may be needed. If non-null this can be directly applied to the Graphics2D.

Toolkit tk = Toolkit.getDefaultToolkit();
Map map = (Map)(tk.getDesktopProperty("awt.font.desktophints"));
if (map != null) {
    graphics2D.addRenderingHints(map);
}

Advanced Usage Tips

Listening for changes

An application can listen for changes in the property using a PropertyChangeListener :

tk.addPropertyChangeListener("awt.font.desktophints", pcl);
Listening for changes is recommended as users can, on rare occasions, reconfigure a desktop environment whilst applications are running in a way that may affect the selection of these hints, and furthermore many desktop environments support dynamic reconfiguration of these running applications to conform to the new settings.

There is no direct way to discover if dynamic reconfiguration is expected of running applications but the default assumption should be that it is expected, since most modern desktop environments do provide this capability.

Text Measurement

Text always needs to be measured using the same FontRenderContext as used for rendering. The text anti-aliasing hint is a component of the FontRenderContext. A FontMetrics obtained from the Graphics object on which the hint has been set will measure text appropriately. This is not a unique requirement for clients that specify this hint directly, since the value of the FontRenderContext should never be assumed, so is discussed here principally as a reminder.

Saving and restoring Graphics State

Sometimes an application may need to apply these hints on a shared Graphics only temporarily, restoring the previous values after they have been applied to text rendering operations. The following sample code shows one way to do this.

/**
  * Get rendering hints from a Graphics instance.
  * "hintsToSave" is a Map of RenderingHint key-values.
  * For each hint key present in that map, the value of that
  * hint is obtained from the Graphics and stored as the value
  * for the key in savedHints.
  */
RenderingHints getRenderingHints(Graphics2D g2d,
                                  RenderingHints hintsToSave,
                                  RenderingHints savedHints) {
     if (savedHints == null) {
         savedHints = new RenderingHints(null);
     } else {
         savedHints.clear();
     }
     if (hintsToSave.size() == 0) {
         return savedHints;
     }
     /* RenderingHints.keySet() returns Set<Object> */
     for (Object o : hintsToSave.keySet()) {
         RenderingHints.Key key = (RenderingHints.Key)o;
         Object value = g2d.getRenderingHint(key);
         savedHints.put(key, value);
     }
     return savedHints;
}

Toolkit tk = Toolkit.getDefaultToolkit();
Map map = (Map)(tk.getDesktopProperty("awt.font.desktophints"));
Map oldHints;
if (map != null) {
     oldHints = getRenderingHints(graphic2D, map, null);
     graphics2D.addRenderingHints(map);
     ..
     graphics2D.addRenderingHints(oldHints);
}

Details

  • The return value will always be null or a Map

  • If the return value is null, then no desktop properties are available, and dynamic updates will not be available. This is a typical behaviour if the JDK does not recognise the desktop environment, or it is one which has no such settings. The Headless toolkit is one such example. Therefore it is important to test against null before using the map.

  • If non-null the value will be a Map of RenderingHints such that every key is an instance of RenderingHints.Key and the value is a legal value for that key.

  • The map may contain the default value for a hint. This is needed in the event there is a previously a non-default value for the hint set on the Graphics2D. If the map did not contain the default value, then addRenderingHints(Map) would leave the previous hint which may not correspond to the desktop setting.

    An application can use setRenderingHints(Map) to reinitialise all hints, but this would affect unrelated hints too.

  • A multi-screen desktop may support per-screen device settings in which case the returned value is for the default screen of the desktop. An application may want to use the settings for the screen on which they will be applied. The per-screen device hints may be obtained by per-device property names which are constructed as the String concatenation

"awt.font.desktophints" + "." + GraphicsDevice.getIDstring();

    An application can also listen for changes on these properties.

    However this is an extremely unlikely configuration, so to help ease of development, if only a single, desktop-wide setting is supported, then querying each of these per-device settings will return null. So to determine if there are per-device settings it is sufficient to determine that there is a non-null return for any screen device using the per-device property name.

Mouse Functionality

Desktop Property: "sun.awt.enableExtraMouseButtons"

This property determines if events from extra mouse buttons (if they are exist and are enabled by the underlying operating system) are allowed to be processed and posted into {@code EventQueue}.
The value could be changed by passing "sun.awt.enableExtraMouseButtons" property value into java before application starts. This could be done with the following command:

java -Dsun.awt.enableExtraMouseButtons=false Application
Once set on application startup, it is impossible to change this value after.
Current value could also be queried using getDesktopProperty("sun.awt.enableExtraMouseButtons") method.
If the property is set to {@code true} then
  • it is still legal to create {@code MouseEvent} objects with standard buttons and, if the mouse has more then three buttons, it is also legal to use buttons from the range started from 0 up to {@link java.awt.MouseInfo#getNumberOfButtons() getNumberOfButtons()}.
  • it is legal to use standard button masks when using {@code Robot.mousePress()} and {@code Robot.mouseRelease()} methods and, if the mouse has more then three buttons, it is also legal to use masks for existing extended mouse buttons. That way, if there are more then three buttons on the mouse then it is allowed to use button masks corresponding to the buttons in the range from 1 up to {@link java.awt.MouseInfo#getNumberOfButtons() getNumberOfButtons()}

If the property is set to {@code false} then
  • it is legal to create {@code MouseEvent} objects with standard buttons only: {@code NOBUTTON}, {@code BUTTON1}, {@code BUTTON2} and {@code BUTTON3}
  • it is legal to use standard button masks only: {@code InputEvent.BUTTON1_DOWN_MASK}, {@code InputEvent.BUTTON2_DOWN_MASK}, {@code InputEvent.BUTTON3_DOWN_MASK}
This property should be used when there is no need in listening mouse events fired as a result of activity with extra mouse button. By default this property is set to {@code true}.


The AWT Focus Subsystem

Prior to Java 2 Standard Edition, JDK 1.4, the AWT focus subsystem was inadequate. It suffered from major design and API problems, as well as over a hundred open bugs. Many of these bugs were caused by platform inconsistencies, or incompatibilities between the native focus system for heavyweights and the Java focus system for lightweights.

The single worst problem with the AWT focus implementation was the inability to query for the currently focused Component. Not only was there no API for such a query, but also, because of an insufficient architecture, such information was not even maintained by the code.

Almost as bad was the inability of lightweight children of a Window (not a Frame or a Dialog) to receive keyboard input. This problem existed because Windows never received WINDOW_ACTIVATED events and thus could never be activated, and only active Windows could contain focused Components.

In addition, many developers noted that the APIs for FocusEvent and WindowEvent were insufficient because they did not provide a way for determining the "opposite" Component involved in the focus or activation change. For example, when a Component received a FOCUS_LOST event, it had no way of knowing which Component was gaining focus. Since Microsoft Windows provides this functionality for free, developers migrating from Microsoft Windows C/C++ or Visual Basic to Java had been frustrated by the omission.

To address these and other deficiencies, we have designed a new focus model for the AWT in JDK 1.4. The primary design changes were the construction of a new centralized KeyboardFocusManager class, and a lightweight focus architecture. The amount of focus-related, platform-dependent code has been minimized and replaced by fully pluggable and extensible public APIs in the AWT. While we have attempted to remain backward compatible with the existing implementation, we were forced to make minor incompatible changes in order to reach an elegant and workable conclusion. We anticipate that these incompatibilities will have only a trivial impact on existing applications.

This document is a formal specification both of the new APIs and of existing APIs which remain relevant in the new model. Combined with the javadoc for focus-related classes and methods, this document should enable developers to create substantial AWT and Swing applications with a focus behavior that is customized yet consistent across platforms. This document has the following sections:

  • Overview of KeyboardFocusManager
  • KeyboardFocusManager and Browser Contexts
  • KeyEventDispatcher
  • FocusEvent and WindowEvent
  • Event Delivery
  • Opposite Components and Windows
  • Temporary FocusEvents
  • Focus Traversal
  • Focus Traversal Policy
  • Focus Traversal Policy Providers
  • Programmatic Traversal
  • Focusability
  • Focusable Windows
  • Requesting Focus
  • Focus and PropertyChangeListener
  • Focus and VetoableChangeListener
  • Z-Order
  • Replacing DefaultKeyboardFocusManager
  • Incompatibilities with Previous Releases

Overview of KeyboardFocusManager

The focus model is centralized around a single class, KeyboardFocusManager, that provides a set of APIs for client code to inquire about the current focus state, initiate focus changes, and replace default focus event dispatching with a custom dispatcher. Clients can inquire about the focus state directly, or can register a PropertyChangeListener that will receive PropertyChangeEvents when a change to the focus state occurs.

KeyboardFocusManager introduces the following main concepts and their terminology:

  1. The "focus owner" -- the Component which typically receives keyboard input.
  2. The "permanent focus owner" -- the last Component to receive focus permanently. The "focus owner" and the "permanent focus owner" are equivalent unless a temporary focus change is currently in effect. In such a situation, the "permanent focus owner" will again be the "focus owner" when the temporary focus change ends.
  3. The "focused Window" -- the Window which contains the "focus owner".
  4. The "active Window" -- the Frame or Dialog that is either the "focused Window", or the first Frame or Dialog that is an owner of the "focused Window".
  5. "Focus traversal" -- the user's ability to change the "focus owner" without moving the cursor. Typically, this is done using the keyboard (for example, by using the TAB key), or an equivalent device in an accessible environment. Client code can also initiate traversal programmatically. Normal focus traversal can be either "forward" to the "next" Component, or "backward" to the "previous" Component.
  6. "Focus traversal cycle" -- a portion of the Component hierarchy, such that normal focus traversal "forward" (or "backward") will traverse through all of the Components in the focus cycle, but no other Components. This cycle provides a mapping from an arbitrary Component in the cycle to its "next" (forward traversal) and "previous" (backward traversal) Components.
  7. "Traversable Component" -- Component that is in the focus traversal cycle.
  8. "Non-traversable Component" -- Component that is not in the focus traversal cycle. Note that a non-traversable Component can nevertheless be focused in other way (e.g. by direct focus request).
  9. "Focus cycle root" -- Container that is the root of the Component hierarchy for a particular "focus traversal cycle". When the "focus owner" is a Component inside a particular cycle, normal forward and backward focus traversal cannot move the "focus owner" above the focus cycle root in the Component hierarchy. Instead, two additional traversal operations, "up cycle" and "down cycle", are defined to allow keyboard and programmatic navigation up and down the focus traversal cycle hierarchy.
  10. "Focus traversal policy provider" - Container which has "FocusTraversalPolicyProvider" property as true. This Container will be used to acquire focus traversal policy. This container doesn't define new focus cycle but only modifies the order by which its children are traversed "forward" and "backward". Focus traversal policy provider can be set using setFocusTraversalPolicyProvider on the Container.

Every Window and JInternalFrame is, by default, a "focus cycle root". If it's the only focus cycle root, then all of its focusable descendants should be in its focus cycle, and its focus traversal policy should enforce that they are by making sure that all will be reached during normal forward (or backward) traversal. If, on the other hand, the Window or JInternalFrame has descendants that are also focus cycle roots, then each such descendant is a member of two focus cycles: the one that it is the root of, and the one of its nearest focus-cycle-root ancestor. In order to traverse the focusable components belonging to the focus cycle of such a "descendant" focus cycle root, one first traverses (forward or backward) to reach the descendant, and then uses the "down cycle" operation to reach, in turn, its descendants.

Here is an example:
Three groups as described below: ABCF BDE and DGH.

Assume the following:

  • A is a Window, which means that it must be a focus cycle root.
  • B and D are Containers that are focus cycle roots.
  • C is a Container that is not a focus cycle root.
  • G, H, E, and F are all Components.
There are a total of three focus cycle roots in this example:
  1. A is a root, and A, B, C, and F are members of A's cycle.
  2. B is a root, and B, D, and E are members of B's cycle.
  3. D is a root, and D, G, and H are members of D's cycle.
Windows are the only Containers which, by default, are focus cycle roots. KeyboardFocusManager is an abstract class. AWT provides a default implementation in the DefaultKeyboardFocusManager class.

KeyboardFocusManager and Browser Contexts

Some browsers partition applets in different code bases into separate contexts, and establish walls between these contexts. Each thread and each Component is associated with a particular context and cannot interfere with threads or access Components in other contexts. In such a scenario, there will be one KeyboardFocusManager per context. Other browsers place all applets into the same context, implying that there will be only a single, global KeyboardFocusManager for all applets. This behavior is implementation-dependent. Consult your browser's documentation for more information. No matter how many contexts there may be, however, there can never be more than one focus owner, focused Window, or active Window, per ClassLoader.

KeyEventDispatcher and KeyEventPostProcessor

While the user's KeyEvents should generally be delivered to the focus owner, there are rare cases where this is not desirable. An input method is an example of a specialized Component that should receive KeyEvents even though its associated text Component is and should remain the focus owner.

A KeyEventDispatcher is a lightweight interface that allows client code to pre-listen to all KeyEvents in a particular context. Instances of classes that implement the interface and are registered with the current KeyboardFocusManager will receive KeyEvents before they are dispatched to the focus owner, allowing the KeyEventDispatcher to retarget the event, consume it, dispatch it itself, or make other changes.

For consistency, KeyboardFocusManager itself is a KeyEventDispatcher. By default, the current KeyboardFocusManager will be the sink for all KeyEvents not dispatched by the registered KeyEventDispatchers. The current KeyboardFocusManager cannot be completely deregistered as a KeyEventDispatcher. However, if a KeyEventDispatcher reports that it dispatched the KeyEvent, regardless of whether it actually did so, the KeyboardFocusManager will take no further action with regard to the KeyEvent. (While it is possible for client code to register the current KeyboardFocusManager as a KeyEventDispatcher one or more times, there is no obvious reason why this would be necessary, and therefore it is not recommended.)

Client-code may also post-listen to KeyEvents in a particular context using the KeyEventPostProcessor interface. KeyEventPostProcessors registered with the current KeyboardFocusManager will receive KeyEvents after the KeyEvents have been dispatched to and handled by the focus owner. The KeyEventPostProcessors will also receive KeyEvents that would have been otherwise discarded because no Component in the application currently owns the focus. This will allow applications to implement features that require global KeyEvent post- handling, such as menu shortcuts.

Like KeyEventDispatcher, KeyboardFocusManager also implements KeyEventPostProcessor, and similar restrictions apply to its use in that capacity.

FocusEvent and WindowEvent

The AWT defines the following six event types central to the focus model in two different java.awt.event classes:

  1. WindowEvent.WINDOW_ACTIVATED: This event is dispatched to a Frame or Dialog (but never a Window which is not a Frame or Dialog) when it becomes the active Window.
  2. WindowEvent.WINDOW_GAINED_FOCUS: This event is dispatched to a Window when it becomes the focused Window. Only focusable Windows can receive this event.
  3. FocusEvent.FOCUS_GAINED: This event is dispatched to a Component when it becomes the focus owner. Only focusable Components can receive this event.
  4. FocusEvent.FOCUS_LOST: This event is dispatched to a Component when it is no longer the focus owner.
  5. WindowEvent.WINDOW_LOST_FOCUS: This event is dispatched to a Window when it is no longer the focused Window.
  6. WindowEvent.WINDOW_DEACTIVATED: This event is dispatched to a Frame or Dialog (but never a Window which is not a Frame or Dialog) when it is no longer the active Window.

Event Delivery

If the focus is not in java application and the user clicks on a focusable child Componenta of an inactive Frame b, the following events will be dispatched and handled in order:

  1. b will receive a WINDOW_ACTIVATED event.
  2. Next, b will receive a WINDOW_GAINED_FOCUS event.
  3. Finally, a will receive a FOCUS_GAINED event.
If the user later clicks on a focusable child Component c of another Frame d, the following events will be dispatched and handled in order:
  1. a will receive a FOCUS_LOST event.
  2. b will receive a WINDOW_LOST_FOCUS event.
  3. b will receive a WINDOW_DEACTIVATED event.
  4. d will receive a WINDOW_ACTIVATED event.
  5. d will receive a WINDOW_GAINED_FOCUS event.
  6. c will receive a FOCUS_GAINED event.
Note that each event will be fully handled before the next event is dispatched. This restriction will be enforced even if the Components are in different contexts and are handled on different event dispatching threads.

In addition, each event type will be dispatched in 1-to-1 correspondence with its opposite event type. For example, if a Component receives a FOCUS_GAINED event, under no circumstances can it ever receive another FOCUS_GAINED event without an intervening FOCUS_LOST event.

Finally, it is important to note that these events are delivered for informational purposes only. It is impossible, for example, to prevent the delivery of a pending FOCUS_GAINED event by requesting focus back to the Component losing focus while handling the preceding FOCUS_LOST event. While client code may make such a request, the pending FOCUS_GAINED will still be delivered, followed later by the events transferring focus back to the original focus owner.

If it is absolutely necessary to suppress the FOCUS_GAINED event, client code can install a VetoableChangeListener which rejects the focus change. See Focus and VetoableChangeListener.

Opposite Components and Windows

Each event includes information about the "opposite" Component or Window involved in the focus or activation change. For example, for a FOCUS_GAINED event, the opposite Component is the Component that lost focus. If the focus or activation change occurs with a native application, with a Java application in a different VM or context, or with no other Component, then the opposite Component or Window is null. This information is accessible using FocusEvent.getOppositeComponent or WindowEvent.getOppositeWindow.

On some platforms, it is not possible to discern the opposite Component or Window when the focus or activation change occurs between two different heavyweight Components. In these cases, the opposite Component or Window may be set to null on some platforms, and to a valid non-null value on other platforms. However, for a focus change between two lightweight Components which share the same heavyweight Container, the opposite Component will always be set correctly. Thus, a pure Swing application can ignore this platform restriction when using the opposite Component of a focus change that occurred within a top-level Window.

Temporary FocusEvents

FOCUS_GAINED and FOCUS_LOST events are marked as either temporary or permanent.

Temporary FOCUS_LOST events are sent when a Component is losing the focus, but will regain the focus shortly. These events can be useful when focus changes are used as triggers for validation of data. For instance, a text Component may want to commit its contents when the user begins interacting with another Component, and can accomplish this by responding to FOCUS_LOST events. However, if the FocusEvent received is temporary, the commit should not be done, since the text field will be receiving the focus again shortly.

A permanent focus transfer typically occurs as the result of a user clicking on a selectable, heavyweight Component, focus traversal with the keyboard or an equivalent input device, or from a call to requestFocus() or requestFocusInWindow().

A temporary focus transfer typically occurs as the result of showing a Menu or PopupMenu, clicking or dragging a Scrollbar, moving a Window by dragging the title bar, or making another Window the focused Window. Note that on some platforms, these actions may not generate any FocusEvents at all. On others, temporary focus transfers will occur.

When a Component receives a temporary FOCUS_LOST event, the event's opposite Component (if any) may receive a temporary FOCUS_GAINED event, but could also receive a permanent FOCUS_GAINED event. Showing a Menu or PopupMenu, or clicking or dragging a Scrollbar, should generate a temporary FOCUS_GAINED event. Changing the focused Window, however, will yield a permanent FOCUS_GAINED event for the new focus owner.

The Component class includes variants of requestFocus and requestFocusInWindow which take a desired temporary state as a parameter. However, because specifying an arbitrary temporary state may not be implementable on all native windowing systems, correct behavior for this method can be guaranteed only for lightweight Components. This method is not intended for general use, but exists instead as a hook for lightweight Component libraries, such as Swing.

Focus Traversal

Each Component defines its own Set of focus traversal keys for a given focus traversal operation. Components support separate Sets of keys for forward and backward traversal, and also for traversal up one focus traversal cycle. Containers which are focus cycle roots also support a Set of keys for traversal down one focus traversal cycle. If a Set is not explicitly defined for a Component, that Component recursively inherits a Set from its parent, and ultimately from a context-wide default set on the current KeyboardFocusManager.

Using the AWTKeyStroke API, client code can specify on which of two specific KeyEvents, KEY_PRESSED or KEY_RELEASED, the focus traversal operation will occur. Regardless of which KeyEvent is specified, however, all KeyEvents related to the focus traversal key, including the associated KEY_TYPED event, will be consumed, and will not be dispatched to any Component. It is a runtime error to specify a KEY_TYPED event as mapping to a focus traversal operation, or to map the same event to multiple focus traversal operations for any particular Component or for a KeyboardFocusManager's defaults.

The default focus traversal keys are implementation-dependent. Sun recommends that the all implementations for a particular native platform use the same keys. For Windows and Unix, the recommendations are:

  • traverse forward to the next Component:
    TextAreas: CTRL-TAB on KEY_PRESSED
    All others: TAB on KEY_PRESSED and CTRL-TAB on KEY_PRESSED
  • traverse backward to the previous Component:
    TextAreas: CTRL-SHIFT-TAB on KEY_PRESSED
    All others: SHIFT-TAB on KEY_PRESSED and CTRL-SHIFT-TAB on KEY_PRESSED
  • traverse up one focus traversal cycle : <none>
  • traverse down one focus traversal cycle : <none>

Components can enable and disable all of their focus traversal keys en masse using Component.setFocusTraversalKeysEnabled. When focus traversal keys are disabled, the Component receives all KeyEvents for those keys. When focus traversal keys are enabled, the Component never receives KeyEvents for traversal keys; instead, the KeyEvents are automatically mapped to focus traversal operations.

For normal forward and backward traversal, the AWT focus implementation determines which Component to focus next based on the FocusTraversalPolicy of the focus owner's focus cycle root or focus traversal policy provider. If the focus owner is a focus cycle root, then it may be ambiguous as to which Components represent the next and previous Components to focus during normal focus traversal. Thus, the current KeyboardFocusManager maintains a reference to the "current" focus cycle root, which is global across all contexts. The current focus cycle root is used to resolve the ambiguity.

For up-cycle traversal, the focus owner is set to the current focus owner's focus cycle root, and the current focus cycle root is set to the new focus owner's focus cycle root. If, however, the current focus owner's focus cycle root is a top-level window, then the focus owner is set to the focus cycle root's default component to focus, and the current focus cycle root is unchanged.

For down-cycle traversal, if the current focus owner is a focus cycle root, then the focus owner is set to the current focus owner's default component to focus, and the current focus cycle root is set to the current focus owner. If the current focus owner is not a focus cycle root, then no focus traversal operation occurs.

FocusTraversalPolicy

A FocusTraversalPolicy defines the order in which Components within a particular focus cycle root or focus traversal policy provider are traversed. Instances of FocusTraversalPolicy can be shared across Containers, allowing those Containers to implement the same traversal policy. FocusTraversalPolicies do not need to be reinitialized when the focus-traversal-cycle hierarchy changes.

Each FocusTraversalPolicy must define the following five algorithms:

  1. Given a focus cycle root and a Component a in that cycle, the next Component after a.
  2. Given a focus cycle root and a Component a in that cycle, the previous Component before a.
  3. Given a focus cycle root, the "first" Component in that cycle. The "first" Component is the Component to focus when traversal wraps in the forward direction.
  4. Given a focus cycle root, the "last" Component in that cycle. The "last" Component is the Component to focus when traversal wraps in the reverse direction.
  5. Given a focus cycle root, the "default" Component in that cycle. The "default" Component will be the first to receive focus when traversing down into a new focus traversal cycle. This may be the same as the "first" Component, but need not be.

A FocusTraversalPolicy may optionally provide an algorithm for the following:

Given a Window, the "initial" Component in that Window. The initial Component will be the first to receive focus when the Window is first made visible. By default, this is the same as the "default" Component.
In addition, Swing provides a subclass of FocusTraversalPolicy, InternalFrameFocusTraversalPolicy, which allows developers to provide an algorithm for the following:
Given a JInternalFrame, the "initial" Component in that JInternalFrame. The initial Component is the first to receive focus when the JInternalFrame is first selected. By default, this is the same as the JInternalFrame's default Component to focus.
A FocusTraversalPolicy is installed on a Container using Container. setFocusTraversalPolicy. If a policy is not explicitly set, then a Container inherits its policy from its nearest focus-cycle-root ancestor. Top-levels initialize their focus traversal policies using the context default policy. The context default policy is established by using KeyboardFocusManager. setDefaultFocusTraversalPolicy.

AWT provides two standard FocusTraversalPolicy implementations for use by client code.

  1. ContainerOrderFocusTraversalPolicy: Iterates across the Components in a focus traversal cycle in the order they were added to their Containers. Each Component is tested for fitness using the accept(Component) method. By default, a Component is fit only if it is visible, displayable, enabled, and focusable.
  2. By default, ContainerOrderFocusTraversalPolicy implicitly transfers focus down-cycle. That is, during normal forward focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus, regardless of whether the focus cycle root is a traversable or non-traversable Container (see the pic.1,2 below). Such behavior provides backward compatibility with applications designed without the concepts of up- and down-cycle traversal.
  3. DefaultFocusTraversalPolicy: A subclass of ContainerOrderFocusTraversalPolicy which redefines the fitness test. If client code has explicitly set the focusability of a Component by either overriding Component.isFocusTraversable() or Component.isFocusable(), or by calling Component.setFocusable(boolean), then a DefaultFocusTraversalPolicy behaves exactly like a ContainerOrderFocusTraversalPolicy. If, however, the Component is relying on default focusability, then a DefaultFocusTraversalPolicy will reject all Components with non-focusable peers.
    The focusability of a peer is implementation-dependent. Sun recommends that all implementations for a particular native platform construct peers with the same focusability. The recommendations for Windows and Unix are that Canvases, Labels, Panels, Scrollbars, ScrollPanes, Windows, and lightweight Components have non-focusable peers, and all other Components have focusable peers. These recommendations are used in the Sun AWT implementations. Note that the focusability of a Component's peer is different from, and does not impact, the focusability of the Component itself.

Swing provides two additional, standard FocusTraversalPolicy implementations for use by client code. Each implementation is an InternalFrameFocusTraversalPolicy.

  1. SortingFocusTraversalPolicy: Determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator. Each Component is tested for fitness using the accept(Component) method. By default, a Component is fit only if it is visible, displayable, enabled, and focusable.
  2. By default, SortingFocusTraversalPolicy implicitly transfers focus down-cycle. That is, during normal forward focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus, regardless of whether the focus cycle root is a traversable or non-traversable Container (see the pic.1,2 below). Such behavior provides backward compatibility with applications designed without the concepts of up- and down-cycle traversal.
  3. LayoutFocusTraversalPolicy: A subclass of SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation. Based on their size and position, Components are roughly categorized into rows and columns. For a Container with horizontal orientation, columns run left-to-right or right-to-left, and rows run top-to-bottom. For a Container with vertical orientation, columns run top-to-bottom and rows run left-to-right or right-to-left. All columns in a row are fully traversed before proceeding to the next row.
    In addition, the fitness test is extended to exclude JComponents that have or inherit empty InputMaps.

The figure below shows an implicit focus transfer:
Implicit focus transfer.
Assume the following:

  • A, B and C are components in some window (a container)
  • R is a container in the window and it is a parent of B and C. Besides, R is a focus cycle root.
  • B is the default component in the focul traversal cycle of R
  • R is a traversable Container in the pic.1, and it is a non-traversable Container in the pic.2.
  • In such a case a forward traversal will look as follows:
    • pic.1 : A -> R -> B -> C
    • pic.2 : A -> B -> C

Swing applications, or mixed Swing/AWT applications, that use one of the standard look and feels, or any other look and feel derived from BasicLookAndFeel, will use LayoutFocusTraversalPolicy for all Containers by default.

All other applications, including pure AWT applications, will use DefaultFocusTraversalPolicy by default.

Focus Traversal Policy Providers

A Container that isn't a focus cycle root has an option to provide a FocusTraversalPolicy of its own. To do so, one needs to set Container's focus traversal policy provider property to true with the call to

Container.setFocusTraversalPolicyProvider(boolean)
To determine whether a Container is a focus traversal policy provider, the following method should be used:
Container.isFocusTraversalPolicyProvider()
If focus traversal policy provider property is set on a focus cycle root, it isn't considered a focus traversal policy provider and behaves just like any other focus cycle root.

The main difference between focus cycle roots and focus traversal policy providers is that the latter allow focus to enter and leave them just as all other Containers. However, children inside focus traversal policy provider are traversed in the order determined by provider's FocusTraversalPolicy. In order to enable focus traversal policy providers to behave this way, FocusTraversalPolicies treat them in the following manner:

  • Focus traversal policy providers can be passed to FocusTraversalPolicy methods instead of focus cycle roots.
  • When calculating next or previous Component in FocusTraversalPolicy.getComponentAfter or FocusTraversalPolicy.getComponentBefore,
    • if a Component is a child of a focus traversal policy provider, the next and previous for this Component are determined using this focus traversal policy provider's FocusTraversalPolicy. However, in order for focus to leave the provider, the following rules are applied:
      • if at some point the next found Component is the first Component of focus traversal policy provider, the Component after the focus traversal policy provider is returned
      • if at some point the previous found Component is the last Component of focus traversal policy provider, the Component before the focus traversal policy provider is returned
    • When calculating the next Component in FocusTraversalPolicy.getComponentAfter,
      • if an obtained Component is a non-traversable Container and it is a focus traversal policy provider, then the default Component of that provider is returned
      • if the Component passed to the FocusTraversalPolicy.getComponentAfter method is a traversable Container and it is a focus traversal policy provider, then the default Component of this provider is returned
    • When calculating the previous Component in FocusTraversalPolicy.getComponentBefore,
      • if an obtained Component is a Container (traversable or non-traversable) and it is a focus traversal policy provider, then the last Component of that provider is returned
  • When calculating the first Component in FocusTraversalPolicy.getFirstComponent,
    • if an obtained Component is a non-traversable Container and it is a focus traversal policy provider, then the default Component of that provider is returned
    • if an obtained Component is a traversable Container and it is a focus traversal policy provider, then that Container itself is returned
  • When calculating the last Component in FocusTraversalPolicy.getLastComponent,
    • if an obtained Component is a Container (traversable or non-traversable) and it is a focus traversal policy provider, then the last Component of that provider is returned

Programmatic Traversal

In addition to user-initiated focus traversal, client code can initiate a focus traversal operation programmatically. To client code, programmatic traversals are indistinguishable from user-initiated traversals. The preferred way to initiate a programmatic traversal is to use one of the following methods on KeyboardFocusManager:

  • KeyboardFocusManager.focusNextComponent()
  • KeyboardFocusManager.focusPreviousComponent()
  • KeyboardFocusManager.upFocusCycle()
  • KeyboardFocusManager.downFocusCycle()

Each of these methods initiates the traversal operation with the current focus owner. If there is currently no focus owner, then no traversal operation occurs. In addition, if the focus owner is not a focus cycle root, then downFocusCycle() performs no traversal operation.

KeyboardFocusManager also supports the following variants of these methods:

  • KeyboardFocusManager.focusNextComponent(Component)
  • KeyboardFocusManager.focusPreviousComponent(Component)
  • KeyboardFocusManager.upFocusCycle(Component)
  • KeyboardFocusManager.downFocusCycle(Container)
Each of these methods initiates the traversal operation with the specified Component rather than the focus owner. That is, the traversal occurs as though the specified Component is the focus owner, though it need not be.

Alternate, but equivalent, APIs are defined on the Component and Container classes themselves:

  • Component.transferFocus()
  • Component.transferFocusBackward()
  • Component.transferFocusUpCycle()
  • Container.transferFocusDownCycle()
As with the KeyboardFocusManager variants, each of these methods initiates the traversal operation as though the Component is the focus owner, though it need not be.

Also note that hiding or disabling the focus owner, directly or indirectly via an ancestor, or making the focus owner non-displayable or non-focusable, initiates an automatic, forward focus traversal. While hiding any ancestor, lightweight or heavyweight, will always indirectly hide its children, only disabling a heavyweight ancestor will disable its children. Thus, disabling a lightweight ancestor of the focus owner does not automatically initiate a focus traversal.

If client code initiates a focus traversal, and there is no other Component to focus, then the focus owner remains unchanged. If client code initiates an automatic focus traversal by hiding the focus owner, directly or indirectly, or by making the focus owner non-displayable or non-focusable, and there is no other Component to focus, then the global focus owner is cleared. If client code initiates an automatic focus traversal by disabling the focus owner, directly or indirectly, and there is no other Component to focus, then the focus owner remains unchanged.

Focusability

A focusable Component can become the focus owner ("focusability") and participates in keyboard focus traversal ("focus traversability") with a FocusTraversalPolicy. There is no separation of these two concepts; a Component must either be both focusable and focus traversable, or neither. A Component expresses this state via the isFocusable() method. By default, all Components return true from this method. Client code can change this default by calling Component.setFocusable(boolean).

Focusable Windows

To support palette windows and input methods, client code can prevent a Window from becoming the focused Window. By transitivity, this prevents the Window or any of its descendants from becoming the focus owner. Non-focusable Windows may still own Windows that are focusable. By default, every Frame and Dialog is focusable. Every Window which is not a Frame or Dialog, but whose nearest owning Frame or Dialog is showing on the screen, and which has at least one Component in its focus traversal cycle, is also focusable by default. To make a Window non-focusable, use Window.setFocusableWindowState(false).

If a Window is non-focusable, this restriction is enforced when the KeyboardFocusManager sees a WINDOW_GAINED_FOCUS event for the Window. At this point, the focus change is rejected and focus is reset to a different Window. The rejection recovery scheme is the same as if a VetoableChangeListener rejected the focus change. See Focus and VetoableChangeListener.

Because the new focus implementation requires that KeyEvents intended for a Window or its descendants be proxied through a child of the Window's owner, and because this proxy must be mapped on X11 in order to receive events, a Window whose nearest owning Frame or Dialog is not showing could never receive KeyEvents on X11. To support this restriction, we have made a distinction between a Window's "window focusability" and its "window focusability state". A Window's focusability state is combined with the showing state of the Window's nearest owning Frame or Dialog to determine the Window's focusability. By default, all Windows have a focusability state of true. Setting a Window's focusability state to false ensures that it will not become the focused Window regardless of the showing state of its nearest owning Frame or Dialog.

Swing allows applications to create JWindows with null owners. Swing constructs all such JWindows so that they are owned by a private, hidden Frame. Because the showing state of this Frame will always be false, a JWindow constructed will a null owner can never be the focused Window, even if it has a Window focusability state of true.

If the focused Window is made non-focusable, then the AWT will attempt to focus the most recently focused Component of the Window's owner. The Window's owner will thus become the new focused Window. If the Window's owner is also a non-focusable Window, then the focus change request will proceed up the ownership hierarchy recursively. Since not all platforms support cross-Window focus changes (see Requesting Focus), it is possible that all such focus change requests will fail. In this case, the global focus owner will be cleared and the focused Window will remain unchanged.

Requesting Focus

A Component can request that it become the focus owner by calling Component.requestFocus(). This initiates a permanent focus transfer to the Component only if the Component is displayable, focusable, visible and all of its ancestors (with the exception of the top-level Window) are visible. The request will be immediately denied if any of these conditions is not met. A disabled Component may be the focus owner; however, in this case, all KeyEvents will be discarded.

The request will also be denied if the Component's top-level Window is not the focused Window and the platform does not support requesting focus across Windows. If the request is denied for this reason, the request is remembered and will be granted when the Window is later focused by the user. Otherwise, the focus change request changes the focused Window as well.

There is no way to determine synchronously whether a focus change request has been granted. Instead, client code must install a FocusListener on the Component and watch for the delivery of a FOCUS_GAINED event. Client code must not assume that the Component is the focus owner until it receives this event. The event may or may not be delivered before requestFocus() returns. Developers must not assume one behavior or the other.

The AWT supports type-ahead if all focus change requests are made on the EventDispatchThread. If client code requests a focus change, and the AWT determines that this request might be granted by the native windowing system, then the AWT will notify the current KeyboardFocusManager that is should enqueue all KeyEvents with a timestamp later than the that of the event currently being handled. These KeyEvents will not be dispatched until the new Component becomes the focus owner. The AWT will cancel the delayed dispatching request if the focus change does not succeed at the native level, if the Component's peer is disposed, or if the focus change is vetoed by a VetoableChangeListener. KeyboardFocusManagers are not required to support type-ahead if a focus change request is made from a thread other than the EventDispatchThread.

Because Component.requestFocus() cannot be implemented consistently across platforms, developers are encouraged to use Component.requestFocusInWindow() instead. This method denies cross-Window focus transfers on all platforms automatically. By eliminating the only platform-specific element of the focus transfer, this method achieves consistent cross-platform behavior.

In addition, requestFocusInWindow() returns a boolean value. If 'false' is returned, the request is guaranteed to fail. If 'true' is returned, the request will succeed unless it is vetoed, or an extraordinary event, such as disposal of the Component's peer, occurs before the request can be granted by the native windowing system. Again, while a return value of 'true' indicates that the request is likely to succeed, developers must never assume that this Component is the focus owner until this Component receives a FOCUS_GAINED event.

If client code wants no Component in the application to be the focus owner, it can call the method KeyboardFocusManager. clearGlobalFocusOwner() on the current KeyboardFocusManager. If there exists a focus owner when this method is called, the focus owner will receive a permanent FOCUS_LOST event. After this point, the AWT focus implementation will discard all KeyEvents until the user or client code explicitly sets focus to a Component.

The Component class also supports variants of requestFocus and requestFocusInWindow that allow client code to specify a temporary state. See Temporary FocusEvents

Focus and PropertyChangeListener

Client code can listen to changes in context-wide focus state, or to changes in focus-related state in Components, via PropertyChangeListeners.

The KeyboardFocusManager supports the following properties:

  1. focusOwner: the focus owner
  2. focusedWindow: the focused Window
  3. activeWindow: the active Window
  4. defaultFocusTraversalPolicy: the default focus traversal policy
  5. forwardDefaultFocusTraversalKeys: the Set of default FORWARD_TRAVERSAL_KEYS
  6. backwardDefaultFocusTraversalKeys: the Set of default BACKWARD_TRAVERSAL_KEYS
  7. upCycleDefaultFocusTraversalKeys: the Set of default UP_CYCLE_TRAVERSAL_KEYS
  8. downCycleDefaultFocusTraversalKeys: the Set of default DOWN_CYCLE_TRAVERSAL_KEYS
  9. currentFocusCycleRoot: the current focus cycle root

A PropertyChangeListener installed on the current KeyboardFocusManager will only see these changes within the KeyboardFocusManager's context, even though the focus owner, focused Window, active Window, and current focus cycle root comprise the global focus state shared by all contexts. We believe this is less intrusive than requiring client code to pass a security check before installing a PropertyChangeListener.

Component supports the following focus-related properties:

  1. focusable: the Component's focusability
  2. focusTraversalKeysEnabled: the Component's focus traversal keys enabled state
  3. forwardFocusTraversalKeys: the Component's Set of FORWARD_TRAVERSAL_KEYS
  4. backwardFocusTraversalKeys: the Component's Set of BACKWARD_TRAVERSAL_KEYS
  5. upCycleFocusTraversalKeys: the Component's Set of UP_CYCLE_TRAVERSAL_KEYS

In addition to the Component properties, Container supports the following focus-related properties:

  1. downCycleFocusTraversalKeys: the Container's Set of DOWN_CYCLE_TRAVERSAL_KEYS
  2. focusTraversalPolicy: the Container's focus traversal policy
  3. focusCycleRoot: the Container's focus-cycle-root state

In addition to the Container properties, Window supports the following focus-related property:

  1. focusableWindow: the Window's focusable Window state

Also note that a PropertyChangeListener installed on a Window will never see a PropertyChangeEvent for the focusCycleRoot property. A Window is always a focus cycle root; this property cannot change.

Focus and VetoableChangeListener

The KeyboardFocusManager also supports VetoableChangeListeners for the following properties:

  1. "focusOwner": the focus owner
  2. "focusedWindow": the focused Window
  3. "activeWindow": the active Window
If a VetoableChangeListener vetoes a focus or activation change by throwing a PropertyVetoException, the change is aborted. Any VetoableChangeListeners which had already approved the change will asynchronously receive PropertyChangeEvents indicating a reversion of state to the previous value.

VetoableChangeListeners are notified of the state change before the change is reflected in the KeyboardFocusManager. Conversely, PropertyChangeListeners are notified after the change is reflected. It follows that all VetoableChangeListeners will be notified before any PropertyChangeListener.

VetoableChangeListeners must be idempotent, and must veto both loss and gain events for a particular focus change (e.g., both FOCUS_LOST and FOCUS_GAINED). For example, if a VetoableChangeListener vetoes a FOCUS_LOST event, a KeyboardFocusManager is not required to search the EventQueue and remove the associated pending FOCUS_GAINED event. Instead, the KeyboardFocusManager is free to attempt to dispatch this event and it is the responsibility of the VetoableChangeListener to veto it as well. In addition, during processing of the FOCUS_GAINED event, the KeyboardFocusManager may attempt to resync the global focus state by synthesizing another FOCUS_LOST event. This event must be vetoed just as the first FOCUS_LOST event was.

A KeyboardFocusManager may not hold any locks while notifying PropertyChangeListeners of a state change. This requirement is relaxed for VetoableChangeListeners, however. Therefore, client-definied VetoableChangeListeners should avoid acquiring additional locks inside vetoableChange(PropertyChangeEvent) as this may lead to deadlock. If a focus or activation change is rejected, the KeyboardFocusManager will initiate rejection recovery as follows:

  • If a focused or active Window change was rejected, then the focused or active Window will be reset to the Window which was previously the focused or active Window. If there is no such Window, then the KeyboardFocusManager will clear the global focus owner.
  • If a focus owner change was rejected, then the focus owner will be reset to the Component which was previously the focus owner. If that is not possible, then it will be reset to the next Component in the focus traversal cycle after the previous focus owner. If that is also not possible, then the KeyboardFocusManager will clear the global focus owner.
VetoableChangeListeners must be careful to avoid vetoing focus changes initiated as a result of veto rejection recovery. Failure to anticipate this situation could lead to an infinite cycle of vetoed focus changes and recovery attempts.

Z-Order

On some native windowing systems, the Z-order of a Window can affect its focused or active (if applicable) state. On Microsoft Windows, the top-most Window is naturally the focused Window as well. However, on Solaris, many window managers use a point-to-focus model that ignores Z-order in determining the focused Window. When focusing or activating Windows, the AWT adheres to the UI requirements of the native platform. Therefore, the focus behavior of Z-order-related methods such as:

  • Window.toFront()
  • Window.toBack()
  • Window.show()
  • Window.hide()
  • Window.setVisible(boolean)
  • Window.dispose()
  • Frame.setState(int)
is platform-dependent. In JDK 1.4, the behavior of these methods on Microsoft Windows and Solaris is as follows:
  • Window.toFront():
    Microsoft Windows: The Window is moved to front, if possible. While we will always be able to move this Window in front of other Windows in the same VM, Windows 98 and Windows 2000 do not allow an application to bring any of its windows to the front unless one of that application's windows is already in the foreground. In this case, Windows will instead flash the Window's icon in the taskbar. If the Window is moved to the front, it will be made the focused and (if applicable) active Window.
    Solaris: The Window is moved to front. In a point-to-focus window manager, the Window will become the focused Window if it is the top-most Window underneath the cursor. In a click-to-focus window manager, the focused Window will remain unchanged.
  • Window.toBack():
    Microsoft Windows: The Window is moved to back. Note however that Microsoft Windows insists that an owned Window always be in front of all of its recursive owners. Thus, after the completion of this operation, the Window may not be the lowest Java Window in the Z-order. If the Window, or any of its owners, was the focused Window, then the focused Window is reset to the top-most Window in the VM.
    Solaris: The Window is moved to back. Like Microsoft Windows, some window managers insist than an owned Window always be in front of all of its recursive owners. Thus, after the completion of this operation, the Window may not be the lowest Java Window in the Z-order. If the Window was the focused Window, it will lose focus in a point-to-focus window manager if it is no longer the top-most Window under the cursor. In a click-to-focus window manager, the focused Window will remain unchanged.
  • Window.show()/Window.setVisible(true)/Frame.setState(NORMAL):
    Microsoft Windows: The Window is moved to front and becomes the focused Window.
    Solaris: The Window is moved to front. In a point-to-focus focus window manager, the Window will be focused if it is now the top-most Window under the cursor. In a click-to-focus window manager, the Window will become the focused Window.
  • Window.hide()/Window.setVisible(false)/Window.dispose()/ Frame.setState(ICONIFIED):
    Microsoft Windows: If the Window was the focused Window, the focused Window is reset to a window chosen by the OS, or to no window. The window may be in a native application, or a Java application in another VM.
    Solaris: If the Window was the focused Window, in a point-to- focus window manager, the top-most Window under the cursor will become the focused Window. In a click-to-focus window manager, the focused Window is reset to a window chosen by the window manager. The window may be in a native application, or a Java application in another VM.

Replacing DefaultKeyboardFocusManager

KeyboardFocusManagers are pluggable at the browser context level. Client code can subclass KeyboardFocusManager or DefaultKeyboardFocusManager to modify the way that WindowEvents related to focus, FocusEvents, and KeyEvents are handled and dispatched, and to examine and modify the global focus state. A custom KeyboardFocusManager can also reject focus changes at a more fundamental level then a FocusListener or WindowListener ever could.

While giving a developer ultimate control over the focus model, replacing the entire KeyboardFocusManager is a difficult process requiring a thorough understanding of the peer focus layer. Fortunately, most applications do not need this much control. Developers are encouraged to use KeyEventDispatchers, KeyEventPostProcessors, FocusTraversalPolicies, VetoableChangeListeners, and other concepts discussed in this document before resorting to a full replacement of the KeyboardFocusManager.

First note that, because unhindered access to Components in other contexts represents a security hole, the SecurityManager must grant a new permission, "replaceKeyboardFocusManager", before client code is permitted to replace the KeyboardFocusManager with an arbitrary subclass instance. Because of the security check, replacing the KeyboardFocusManager is not an option for applications that will be deployed in environments with a SecurityManager, such as applets in a browser.

Once installed, a KeyboardFocusManager instance has access to the global focus state via a set of protected functions. The KeyboardFocusManager can only call these functions if it is installed in the calling thread's context. This ensures that malicious code cannot circumvent the security check in KeyboardFocusManager.setCurrentFocusManager. A KeyboardFocusManager should always work with the global focus state instead of the context focus state. Failure to do this will lead to incorrect behavior of the KeyboardFocusManager.

The primary responsibility of a KeyboardFocusManager is the dispatch of the following events:

  • all KeyEvents
  • all FocusEvents
  • WindowEvent.WINDOW_GAINED_FOCUS
  • WindowEvent.WINDOW_LOST_FOCUS
  • WindowEvent.WINDOW_ACTIVATED
  • WindowEvent.WINDOW_DEACTIVATED
The peer layer will provide the KeyboardFocusManager with all of the above events except WINDOW_ACTIVATED and WINDOW_DEACTIVATED. The KeyboardFocusManager must synthesize WINDOW_ACTIVATED and WINDOW_DEACTIVATED events when appropriate and target them accordingly.

The KeyboardFocusManager may need to retarget the events provided by the peer layer to its own notion of the focus owner or focused Window:

  • A KeyEvent must be retargeted to the focus owner. Because the peer layer is unaware of any lightweight Components, KeyEvents will arrive from the peer layer targeted to the focus owner's heavyweight Container, not the focus owner.
  • A FOCUS_LOST event must be retargeted to the focus owner. Again, this is necessary because the peer layer is unaware of lightweight Components.
  • A WINDOW_LOST_FOCUS event must be retargeted to the focused Window. The implementation of the Window class may cause the native focused Window to differ from the Java focused Window.

A KeyboardFocusManager must ensure proper event ordering, and a 1-to-1 correspondence between an event and its opposite event type. The peer layer does not make any of these guarantees. For example, it is possible for the peer layer to send a FOCUS_GAINED event before a WINDOW_GAINED_FOCUS event. The KeyboardFocusManager is responsible for ensuring that the WINDOW_GAINED_FOCUS event is dispatched before the FOCUS_GAINED event.

Before redispatching an event via KeyboardFocusManager. redispatchEvent, a KeyboardFocusManager must attempt to update the global focus state. Typically, this is done using one of the KeyboardFocusManager.setGlobal* methods; however, an implementation is free to implement its own methods. After attempting an update, the KeyboardFocusManager must verify that the global focus state change was not rejected. A rejection is detected when a call to the corresponding getGlobal* method returns a value different than the value just set. Rejections occur in three standard cases:

  • If the KeyboardFocusManager attempts to set the global focus owner to a non-focusable Component.
  • If the KeyboardFocusManager attempts to set the global focused Window to a non-focusable Window.
  • If the change is rejected by an installed VetoableChangeListener.

Client-defined implementations of KeyboardFocusManager can adjust the set of focus transfers which are rejected by overriding the accessor and mutator methods for the global focus state.

If a request to change the global focus state is rejected, the KeyboardFocusManager must discard the event which prompted the focus change request. The Component to which the event was targeted must not receive the event.

The KeyboardFocusManager is also expected to initiate rejection recovery as outlined in Focus and VetoableChangeListener.

Finally, a KeyboardFocusManager must handle the following set of special cases:

  • When handling a WINDOW_GAINED_FOCUS event, the KeyboardFocusManager must set focus to the appropriate child Component of the Window. If a child Component of the Window previously requested focus, but the focus change was rejected because the platform does not support cross-Window focus change requests, then focus should be set to that child Component. Otherwise, if the Window has never been focused, focus should be set to the Window's initial Component to focus. If the Window was previously focused, focus should be set to the Window's most recent focus owner.
  • The KeyboardFocusManager must ensure that the opposite Component or Window are as accurate as the native windowing platform permits. For example, the KeyboardFocusManager may need to retarget the opposite Component to a lightweight child of the heavyweight initially specified by the peer layer.
    If the peer layer states that the opposite Component or Window is null, it is acceptable for the KeyboardFocusManager to propagate this value. null indicates that it is highly probably that no other Component or Window was involved in the focus or activation change. Because of platform limitations, this computation may be subject to a heuristic and could be incorrect. Nevertheless, this heuristic will be the best possible guess which the peer layer could make.
  • Focus and activation changes in which a Component or Window loses focus or activation to itself must be discarded.
  • Events posted by the peer layer claiming that the active Window has lost focus to the focused Window must be discarded. The peer implementation of the Window class may generate these spurious events.

Incompatibilities with Previous Releases

Cross-platform changes:

  1. The default focus traversability for all Components is now 'true'. Previously, some Components (in particular, all lightweights), had a default focus traversability of 'false'. Note that despite this change, however, the DefaultFocusTraversalPolicy for all AWT Containers will preserve the traversal order of previous releases.
  2. A request to focus a non-focus traversable (i.e., non-focusable) Component will be denied. Previously, such requests were granted.
  3. Window.toFront() and Window.toBack() now perform no operation if the Window is not visible. Previously, the behavior was platform-dependent.
  4. KeyListeners installed on Components will no longer see KeyEvents that map to focus traversal operations, and Component.handleEvent() will no longer be invoked for such events. Previously, AWT Components saw these events and had an opportunity to consume them before AWT initiated focus traversal. Code that requires this functionality should instead disable focus traversal keys on its Components and handle focus traversal itself. Alternately, the code can use an AWTEventListener or KeyEventDispatcher to pre-listen to all KeyEvents.

Changes specific to Microsoft Windows:

  1. Window.toBack() changes the focused Window to the top-most Window after the Z-order change.
  2. requestFocus() now allows cross-Window focus change requests in all cases. Previously, requests were granted for heavyweights, but denied for lightweights.


The AWT Modality

This document, together with the API documentation for modality-related classes (such as java.awt.Dialog), briefly describes the new modality features and how to use them. It contains the following sections:

  • Definitions
  • Modality types
  • Show/hide blocking
  • Modal exclusion
  • Related AWT features
  • Security
  • Platform support
  • Compatibility
  • Examples

Definitions

Document - a window without an owner that, together with all its child hierarchy, may be operated on as a single self-contained document. Every window belongs to some document — its root can be found as the closest ancestor window without an owner.

Modal blocked window - a window, that:

  • doesn't receive any user input events
  • doesn't receive input focus
  • keeps its Z-order below the modal dialog that blocks it
Warning! Some window managers allow users to change the window Z-order in an arbitrary way — in that case the last requirement may not be met.

Modal dialog - a dialog that blocks some windows while it is visible. The blocked windows are determined according to the dialog's scope of blocking.

Modal excluded window - a window that stays unblocked while the modal dialog is visible. If a window is modal excluded then all its owned windows and child components are also excluded.

Scope of blocking (SB) - the set of windows (instances of java.awt.Window and all derived classes) that are blocked by the modal dialog while it is visible.

Note: Everywhere in this document the notion of "window" is equal to a top-level window in the Java programming language — in other words an instance of java.awt.Window or any descendant class.

Modality types

There are four supported modality types :

  • toolkit
  • application
  • document
  • modeless
A dialog is, by default, modeless. A modal dialog is, by default, application-modal.
  1. Modeless dialogs
    A modeless dialog doesn't block any windows while visible.
  2. Document-modal dialogs
    A document-modal dialog blocks all windows from the same document except those from its child hierarchy. The document root is determined as the closest ancestor window without an owner.
  3. Application-modal dialogs
    An application-modal dialog blocks all windows from the same application except for those from its child hierarchy. If there are several applets launched in a browser, they can be treated either as separate applications or a single application. This behavior is implementation-dependent.
  4. Toolkit-modal dialogs
    A toolkit-modal dialog blocks all windows that run in the same toolkit except those from its child hierarchy. If there are several applets launched all of them run with the same toolkit, so a toolkit-modal dialog shown from an applet may affect other applets and all windows of the browser instance which embeds the Java runtime environment for this toolkit. See the security section below.

Modality priority is arranged by the strength of blocking: modeless, document-modal, application-modal and toolkit-modal. This arrangement is used when determining what dialog should remain unblocked if two are visible and block each other. It naturally reflects the nesting of a dialog's scope of blocking (SB): a modeless dialog has an empty SB, a document-modal dialog's SB is complete in some applications, and all the applications are run in one toolkit.

Notes about owners:

  • Creating a document-modal dialog without an owner:
    Since Dialog is a class derived from Window, a Dialog instance automatically becomes the root of the document if it has no owner. Thus, if such a dialog is document-modal, its scope of blocking is empty and it behaves the same way as a modeless dialog.
  • Creating an application-modal or toolkit-modal dialog with an owner:
    The scope of blocking for an application- or toolkit-modal dialog, as opposed to a document-modal dialog, doesn't depend on its owner. Thus, in this case the only thing that the owner affects is the Z-order: the dialog always stays on top of its owner.
Implementation note: Changing the modality type for a visible dialog may have no effect until it is hidden and then shown again.

Show/hide blocking

Showing the window or modeless dialog: "F"
All the visible modal dialogs are looked through — if F is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, F remains unblocked.

Showing the modal dialog: "M"
When modal dialog M is shown, all the visible windows fall into one of three distinct groups:

  • Blockers of M (modal dialogs that block M and either are in M's child hierarchy, or are not blocked by M, or have a greater mode of modality, or block some other blocker of M)
  • Blocked by M (windows from M's SB that are not blockers and are not in child hierarchy of any blocker)
  • All other windows (windows or modeless dialogs outside M's SB and modal dialogs outside M's SB that do not block M).

After the modal dialog M is shown, it becomes blocked by the first shown dialog from the first group (if there are any), all the windows from the second one become blocked by M, and all the windows from the third group remain untouched.

In typical cases, when no child dialogs are shown before their owners, this rule can be simplified. (The following, simplified case, may leave out some details).

Showing the document-modal dialog: "M"
All the visible application- and toolkit-modal dialogs are looked through — if M is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, M remains unblocked.

Showing the application-modal dialog: "M"
All the visible toolkit-modal dialogs are looked through — if M is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, M remains unblocked.

Showing the toolkit-modal dialog: "M"
M remains unblocked.

The Standard Blocking Matrix
current/shown | frame & modeless | document | application | toolkit
- | - | - | - | -
document | blocked | - | - | -
application | blocked | blocked | - | -
toolkit | blocked | blocked | blocked | -

After the modal dialog is shown, all the windows from its SB are blocked, except those that block this modal dialog.

Hiding the window or modeless dialog: "F"
If F was blocked by any modal dialog M, it becomes unblocked and is removed from M's blocked windows list.

Hiding the modal dialog: "M"
If M was blocked by any other modal dialog, for example, "N", it becomes unblocked and is removed from N's blocked windows list. Then, all the windows and dialogs blocked by M become unblocked, and after that the same checks (as in Showing the modal dialog: "M") are performed for each of them in the order they were initially shown.

Modal exclusion

There are two modal exclusion types introduced as of JDK 6

  • Exclusion from blocking of toolkit-modal dialogs
  • Exclusion from blocking of application-modal dialogs
By default, a window's modal exclusion property is turned off.
  1. Application-modal exclusion
    If a window is application-modal excluded, it is not blocked by any application-modal dialogs. Also, it is not blocked by document-modal dialogs from outside of its child hierarchy.
  2. Toolkit-modal exclusion
    If a window is toolkit-modal excluded, it is not blocked by any application- or toolkit-modal dialogs. Also, it is not blocked by document-modal dialogs from outside of their child hierarchy.
Implementation note: Changing the modal exclusion type for a visible window may have no effect until it is hidden and then shown again.

Related AWT features

Always-On-Top
When a modal dialog that is not always-on-top blocks an always-on-top window, their relative Z-order is unspecified and platform-dependent.

The toFront() and toBack() methods
A modal dialog should always be above all its blocked windows. Thus, if a blocked window is brought to the front, its blocking dialog, if any, is also brought to the front and remains above the blocked window. Likewise, if a modal dialog is sent to the back, all of its blocked windows are sent to the back to keep them below the blocking dialog.

Minimizing, maximizing and closing blocked windows
When a modal dialog blocks a window, the user may not be able to maximize or minimize the blocked window— however, the actual behavior is unspecified and platform-dependent. In any case, the user can't close the blocked window interactively— but it can be closed programmatically by calling the setVisible(false) or dispose() methods on the blocked window.

Blocked windows activations
When the user selects a blocked window, it may be brought to the front, along with the blocking modal dialog which would then become the active window— however, the actual behavior is unspecified and platform-dependent.

Hiding a modal dialog
When the modal dialog that currently has focus is hidden, it is unspecified and platform-dependent, which other window will become the active window. Any of the following may become the active window:

  1. The owner of the modal dialog - if the owner is unblocked.
  2. The Window, which was active before this modal dialog gained focus - if the owner of the modal dialog is absent or is blocked.
If the modal dialog to be hidden does not have focus, the active window remains unchanged.

Security

A special AWTPermission, "toolkitModality", is required to show toolkit-modal dialogs. This would prevent, for example, blocking a browser or Java Web Start (JWS) by modal dialogs shown from applets.

The same permission is required to exclude a window from toolkit modality. This would prevent, for example, a dialog shown from an applet not to be blocked by a browser's or JWS's modal dialog.

Platform support

Two java.awt.Toolkit methods allow you to check whether the current platform supports specific modality features:

  • isModalityTypeSupported(modalityType)
    Returns whether the specified modality type is supported on the current platform. If mode "M" is not supported and a dialog is set to M-modal, it behaves as modeless.
  • isModalExclusionTypeSupported(modalExclusionType)
    Returns whether the given modal exclusion type is supported on the current platform. If exclusion type "E" is not supported and a window is marked as E-excluded, this has no effect.

Compatibility

The default modality type is application-modal. It is used by the API calls: Dialog.setModal(true), Dialog(owner, true), etc. Prior to JDK 6 the default type was toolkit-modal, but the only distinction between application- and toolkit-modality is for applets and applications launched from Java Web Start.

Examples

  1. Frame "F" is shown
  2. Document-modal dialog "Di" is shown
  3. F becomes blocked by Di — it's in the same document
  4. Document-modal dialog "Dii" is shown
  5. Di becomes blocked by Dii — it's in the same document

 Example 1
  1. Frame "F" is shown
  2. Document-modal dialog "Di" is shown
  3. F becomes blocked by Di — it's in the same document
  4. Document-modal dialog "Dii" is shown
  5. Di becomes blocked by Dii — it's in the same document
  6. Di is hidden
  7. F becomes blocked by Dii — it's in the same document

 Example 2
  1. Frame "F" is shown
  2. Toolkit-modal dialog "Di" is created, but not shown
  3. Document-modal dialog "Dii" is shown
  4. F becomes blocked by Dii — it's in the same document
  5. Application-modal dialog "Diii" is shown
  6. Dii becomes blocked by Diii — it's in the same application
  7. Di is shown
  8. Di becomes blocked by Dii — it's its owner
  9. Diii remains unblocked — it blocks Dii and Dii blocks Di

 Example 3
  1. Frame "F" is shown
  2. Toolkit-modal dialog "Di" is created, but not shown
  3. Document-modal dialog "Dii" is shown
  4. F becomes blocked by Dii — it's in the same document
  5. Application-modal dialog "Diii" is shown
  6. Dii becomes blocked by Diii — it's in the same application
  7. Di is shown
  8. Diii becomes blocked by Di — Di is not blocked
  9. Di remains unblocked

 Example 4


ActionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class ActionEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ActionEvent
  • All Implemented Interfaces:
    Serializable

    public class ActionEvent
extends AWTEvent
    指示组件定义的动作发生的语义事件。 当发生组件特定操作（例如被按下）时，此高级事件由组件（例如Button ）生成。 事件被传递给使用组件的addActionListener方法注册接收此类事件的每个ActionListener对象。

    注意：要调用ActionEvent上Button使用键盘，使用空格键。

    当事件发生时，实现ActionListener接口的对象获得此ActionEvent 。 因此，监听器不需要处理单个鼠标移动和鼠标点击的细节，而是可以处理像“按钮”一样的“有意义”（语义）事件。

    如果任何特定ActionEvent实例的id参数不在从ACTION_FIRST到ACTION_LAST的范围内，将会导致未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    ActionListener ， Tutorial: How to Write an Action Listener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ACTION_FIRST
      用于动作事件的ids范围中的第一个数字。
      static int ACTION_LAST
      用于操作事件的ID的范围中的最后一个数字。
      static int ACTION_PERFORMED
      此事件ID表示发生了有意义的操作。
      static int ALT_MASK
      alt修饰符。
      static int CTRL_MASK
      控制修饰符。
      static int META_MASK
      元修饰符。
      static int SHIFT_MASK
      班次修改。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ActionEvent​(Object source, int id, String command)
      构造一个 ActionEvent对象。
      ActionEvent​(Object source, int id, String command, int modifiers)
      使用修饰键构造一个 ActionEvent对象。
      ActionEvent​(Object source, int id, String command, long when, int modifiers)
      使用指定的修饰符键和时间戳构造一个 ActionEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getActionCommand​()
      返回与此操作相关联的命令字符串。
      int getModifiers​()
      返回此操作事件期间按住的修饰键。
      long getWhen​()
      返回发生此事件的时间戳。
      String paramString​()
      返回标识此操作事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SHIFT_MASK

        public static final int SHIFT_MASK
        班次修改。 在事件期间转移键被按下的指示器。
        另请参见：
        Constant Field Values

      • CTRL_MASK

        public static final int CTRL_MASK
        控制修饰符。 在事件期间控制键被按下的指示器。
        另请参见：
        Constant Field Values

      • META_MASK

        public static final int META_MASK
        元修饰符。 事件中元键被按下的一个指标。
        另请参见：
        Constant Field Values

      • ALT_MASK

        public static final int ALT_MASK
        alt修饰符。 在事件期间Alt键被按下的指示器。
        另请参见：
        Constant Field Values

      • ACTION_FIRST

        public static final int ACTION_FIRST
        用于动作事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • ACTION_LAST

        public static final int ACTION_LAST
        用于操作事件的ID的范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • ACTION_PERFORMED

        @Native
public static final int ACTION_PERFORMED
        此事件ID表示发生了有意义的操作。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ActionEvent

        public ActionEvent​(Object source,
                   int id,
                   String command)
        构造一个ActionEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。 A null command字符串是合法的，但不推荐。

        参数
        source - 发起事件的对象
        id - 标识事件的整数。 有关允许值的信息，请参阅ActionEvent的类描述
        command - 可以指定与事件关联的命令（可能是其中一个）的字符串
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getActionCommand()

      • ActionEvent

        public ActionEvent​(Object source,
                   int id,
                   String command,
                   int modifiers)
        使用修饰键构造一个ActionEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。 A null command字符串是合法的，但不推荐。

        参数
        source - 发起事件的对象
        id - 一个标识事件的整数。 有关允许值的信息，请参阅ActionEvent的类说明
        command - 可以指定与事件相关联的命令（可能是其中一个）的字符串
        modifiers - 修改器在事件期间按下（shift，ctrl，alt，meta）。 不推荐传递负参数。 零值表示没有通过修饰符
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getActionCommand() ，
getModifiers()

      • ActionEvent

        public ActionEvent​(Object source,
                   int id,
                   String command,
                   long when,
                   int modifiers)
        构造具有指定修饰键和时间戳的ActionEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。 A null command字符串是合法的，但不推荐。

        参数
        source - 发起事件的对象
        id - 一个标识事件的整数。 有关允许值的信息，请参阅ActionEvent的类描述
        command - 可以指定与事件关联的命令（可能是其中一个）的字符串
        modifiers - 修改器在事件期间按下（shift，ctrl，alt，meta）。 不推荐传递负参数。 零值表示没有通过修饰符
        when - 给出事件发生的时间很长。 不建议传递负值或零值
        异常
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getActionCommand() ，
getModifiers() ，
getWhen()

    • 方法详细信息

      • getActionCommand

        public String getActionCommand​()
        返回与此操作相关联的命令字符串。 该字符串允许“模态”组件根据其状态指定几个命令之一。 例如，单个按钮可以在“显示详细信息”和“隐藏详细信息”之间切换。 源对象和事件在每种情况下都是相同的，但是命令字符串将标识预期的操作。

        请注意，如果一个null命令字符串传递给该ActionEvent的构造ActionEvent ，则此方法返回null 。

        结果
        该字符串标识此事件的命令

      • getWhen

        public long getWhen​()
        返回发生此事件的时间戳。 因为ActionEvent是一个高级语义事件，所以时间戳通常与底层的InputEvent相同。
        结果
        这个事件的时间戳
        从以下版本开始：
        1.4

      • getModifiers

        public int getModifiers​()
        返回此操作事件期间按住的修饰键。
        结果
        按位或修饰符常数

      • paramString

        public String paramString​()
        返回标识此操作事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 AWTEvent
        结果
        标识事件及其相关命令的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ActionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface ActionListener

  • All Superinterfaces:
    EventListener
    All Known Subinterfaces:
    Action
    所有已知实现类：
    AbstractAction ， AWTEventMulticaster ， BasicDesktopPaneUI.CloseAction ， BasicDesktopPaneUI.MaximizeAction ， BasicDesktopPaneUI.MinimizeAction ， BasicDesktopPaneUI.NavigateAction ， BasicDesktopPaneUI.OpenAction ， BasicFileChooserUI.ApproveSelectionAction ， BasicFileChooserUI.CancelSelectionAction ， BasicFileChooserUI.ChangeToParentDirectoryAction ， BasicFileChooserUI.GoHomeAction ， BasicFileChooserUI.NewFolderAction ， BasicFileChooserUI.UpdateAction ， BasicInternalFrameTitlePane.CloseAction ， BasicInternalFrameTitlePane.IconifyAction ， BasicInternalFrameTitlePane.MaximizeAction ， BasicInternalFrameTitlePane.MoveAction ， BasicInternalFrameTitlePane.RestoreAction ， BasicInternalFrameTitlePane.SizeAction ， BasicOptionPaneUI.ButtonActionListener ， BasicScrollBarUI.ScrollListener ， BasicSliderUI.ActionScroller ， BasicSliderUI.ScrollListener ， BasicSplitPaneUI.KeyboardDownRightHandler ， BasicSplitPaneUI.KeyboardEndHandler ， BasicSplitPaneUI.KeyboardHomeHandler ， BasicSplitPaneUI.KeyboardResizeToggleHandler ， BasicSplitPaneUI.KeyboardUpLeftHandler ， BasicTreeUI.ComponentHandler ， BasicTreeUI.TreeCancelEditingAction ， BasicTreeUI.TreeHomeAction ， BasicTreeUI.TreeIncrementAction ， BasicTreeUI.TreePageAction ， BasicTreeUI.TreeToggleAction ， BasicTreeUI.TreeTraverseAction ， DefaultCellEditor.EditorDelegate ， DefaultEditorKit.BeepAction ， DefaultEditorKit.CopyAction ， DefaultEditorKit.CutAction ， DefaultEditorKit.DefaultKeyTypedAction ， DefaultEditorKit.InsertBreakAction ， DefaultEditorKit.InsertContentAction ， DefaultEditorKit.InsertTabAction ， DefaultEditorKit.PasteAction ， DefaultTreeCellEditor ， DropTarget.DropTargetAutoScroller ， FormView ， HTMLEditorKit.HTMLTextAction ， HTMLEditorKit.InsertHTMLTextAction ， JComboBox ， List.AccessibleAWTList ， MetalFileChooserUI.DirectoryComboBoxAction ， StyledEditorKit.AlignmentAction ， StyledEditorKit.BoldAction ， StyledEditorKit.FontFamilyAction ， StyledEditorKit.FontSizeAction StyledEditorKit.FontSizeAction ， StyledEditorKit.ForegroundAction ， StyledEditorKit.ItalicAction ， StyledEditorKit.StyledTextAction ， StyledEditorKit.UnderlineAction ， TextAction ， ToolTipManager.insideTimerAction ， ToolTipManager.outsideTimerAction ， ToolTipManager.stillInsideTimerAction

    public interface ActionListener
extends EventListener
    用于接收动作事件的侦听器界面。 有兴趣处理动作事件的类实现此接口，并使用该组件的addActionListener方法将使用该类创建的对象注册到组件中。 当事件发生时，调用该对象的actionPerformed方法。
    从以下版本开始：
    1.1
    另请参见：
    ActionEvent ， How to Write an Action Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void actionPerformed​(ActionEvent e)
      发生动作时调用。

    • 方法详细信息

      • actionPerformed

        void actionPerformed​(ActionEvent e)
        发生动作时调用。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AdjustmentEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class AdjustmentEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.AdjustmentEvent
  • All Implemented Interfaces:
    Serializable

    public class AdjustmentEvent
extends AWTEvent
    可调整对象发出的调整事件，如Scrollbar和ScrollPane 。 当用户更改滚动组件的值时，它会接收一个AdjustmentEvent的实例。

    如果任何特定AdjustmentEvent实例的id参数不在从ADJUSTMENT_FIRST到ADJUSTMENT_LAST的范围内，将会导致未指定的行为。

    任何AdjustmentEvent实例的type都需要以下值之一：

    • UNIT_INCREMENT
    • UNIT_DECREMENT
    • BLOCK_INCREMENT
    • BLOCK_DECREMENT
    • TRACK
    分配与上述不同的值将导致未指定的行为。
    从以下版本开始：
    1.1
    另请参见：
    Adjustable ， AdjustmentListener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ADJUSTMENT_FIRST
      标记调整事件ID范围的第一个整数ID。
      static int ADJUSTMENT_LAST
      标记调整事件ID的范围的最后整数ID。
      static int ADJUSTMENT_VALUE_CHANGED
      调整值改变事件。
      static int BLOCK_DECREMENT
      块减量调整类型。
      static int BLOCK_INCREMENT
      块增量调整类型。
      static int TRACK
      绝对跟踪调整类型。
      static int UNIT_DECREMENT
      单位减量调整类型。
      static int UNIT_INCREMENT
      单位增量调整类型。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      AdjustmentEvent​(Adjustable source, int id, int type, int value)
      构造具有指定的 Adjustable源，事件类型，调整类型和值的 AdjustmentEvent对象。
      AdjustmentEvent​(Adjustable source, int id, int type, int value, boolean isAdjusting)
      构造具有指定的可调源，事件类型，调整类型和值的 AdjustmentEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Adjustable getAdjustable​()
      返回此事件始发的 Adjustable对象。
      int getAdjustmentType​()
      返回导致值更改事件的调整类型。
      int getValue​()
      返回调整事件中的当前值。
      boolean getValueIsAdjusting​()
      如果这是多个调整事件之一，则返回 true 。
      String paramString​()
      返回表示此 Event的状态的字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ADJUSTMENT_FIRST

        public static final int ADJUSTMENT_FIRST
        标记调整事件ID范围的第一个整数ID。
        另请参见：
        Constant Field Values

      • ADJUSTMENT_LAST

        public static final int ADJUSTMENT_LAST
        标记调整事件ID的范围的最后整数ID。
        另请参见：
        Constant Field Values

      • ADJUSTMENT_VALUE_CHANGED

        public static final int ADJUSTMENT_VALUE_CHANGED
        调整值改变事件。
        另请参见：
        Constant Field Values

      • UNIT_INCREMENT

        @Native
public static final int UNIT_INCREMENT
        单位增量调整类型。
        另请参见：
        Constant Field Values

      • UNIT_DECREMENT

        @Native
public static final int UNIT_DECREMENT
        单位减量调整类型。
        另请参见：
        Constant Field Values

      • BLOCK_DECREMENT

        @Native
public static final int BLOCK_DECREMENT
        块减量调整类型。
        另请参见：
        Constant Field Values

      • BLOCK_INCREMENT

        @Native
public static final int BLOCK_INCREMENT
        块增量调整类型。
        另请参见：
        Constant Field Values

      • TRACK

        @Native
public static final int TRACK
        绝对跟踪调整类型。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • AdjustmentEvent

        public AdjustmentEvent​(Adjustable source,
                       int id,
                       int type,
                       int value)
        构造具有指定的Adjustable源，事件类型，调整类型和值的AdjustmentEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 事件起源的 Adjustable对象
        id - 指示事件类型的整数。 有关允许值的信息，请参阅AdjustmentEvent的类描述
        type - 指示调整类型的整数。 有关允许值的信息，请参阅AdjustmentEvent的类描述
        value - 调整的当前值
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getAdjustmentType() ，
getValue()

      • AdjustmentEvent

        public AdjustmentEvent​(Adjustable source,
                       int id,
                       int type,
                       int value,
                       boolean isAdjusting)
        构造具有指定的可调源，事件类型，调整类型和值的AdjustmentEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发生事件的 Adjustable对象
        id - 表示事件类型的整数。 有关允许值的信息，请参阅AdjustmentEvent的类说明
        type - 表示调整类型的整数。 有关允许值的信息，请参阅AdjustmentEvent的类说明
        value - 调整的当前值
        isAdjusting - 一个布尔值等于 true如果事件是一系列多个调整事件之一，否则为 false
        异常
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getAdjustmentType() ，
getValue() ，
getValueIsAdjusting()

    • 方法详细信息

      • getAdjustable

        public Adjustable getAdjustable​()
        返回发生此事件的 Adjustable对象。
        结果
        该事件起源的 Adjustable对象

      • getValue

        public int getValue​()
        返回调整事件中的当前值。
        结果
        调整事件中的当前值

      • getAdjustmentType

        public int getAdjustmentType​()
        返回导致值更改事件的调整类型。 它将具有以下值之一：
        • UNIT_INCREMENT
        • UNIT_DECREMENT
        • BLOCK_INCREMENT
        • BLOCK_DECREMENT
        • TRACK
        结果
        上述调整值之一

      • getValueIsAdjusting

        public boolean getValueIsAdjusting​()
        如果这是多个调整事件之一，则返回 true 。
        结果
        true如果这是多个调整事件之一，否则返回 false
        从以下版本开始：
        1.4

      • paramString

        public String paramString​()
        描述从类复制： AWTEvent
        返回表示此Event的状态的字符串。 该方法仅用于调试目的，并且返回的字符串的内容和格式可能因实现而异。 返回的字符串可能为空，但可能不是null 。
        重写：
        paramString在 AWTEvent
        结果
        此事件的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AdjustmentListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface AdjustmentListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster

    public interface AdjustmentListener
extends EventListener
    用于接收调整事件的侦听器接口。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void adjustmentValueChanged​(AdjustmentEvent e)
      当可调整的值已更改时调用。

    • 方法详细信息

      • adjustmentValueChanged

        void adjustmentValueChanged​(AdjustmentEvent e)
        当可调整的值已更改时调用。
        参数
        e - the event to be processed
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTEventListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface AWTEventListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventListenerProxy ， EventQueueMonitor

    public interface AWTEventListener
extends EventListener
    用于接收分派到作为Component或MenuComponent或其子类的实例的对象的事件的侦听器接口。 与此程序包中的其他事件监听器不同，AWTEventListeners被动地观察系统范围内在AWT中调度的事件。 大多数应用程序不应该使用这个类; 可能使用AWTEventListeners的应用程序包括用于自动测试的事件记录器，以及Java辅助功能包等设施。

    感兴趣于监视AWT事件的类实现了此接口，并且使用该工具包的addAWTEventListener方法将该类创建的对象注册到Toolkit。 当事件在AWT的任何地方发送时，将调用该对象的eventDispatched方法。

    从以下版本开始：
    1.2
    另请参见：
    AWTEvent ， Toolkit.addAWTEventListener(java.awt.event.AWTEventListener, long) ， Toolkit.removeAWTEventListener(java.awt.event.AWTEventListener)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void eventDispatched​(AWTEvent event)
      在AWT中调度事件时调用。

    • 方法详细信息

      • eventDispatched

        void eventDispatched​(AWTEvent event)
        在AWT中调度事件时调用。
        参数
        event - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AWTEventListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class AWTEventListenerProxy

  • java.lang.Object
    • java.util.EventListenerProxy<AWTEventListener>
      • java.awt.event.AWTEventListenerProxy
  • All Implemented Interfaces:
    AWTEventListener ， EventListener

    public class AWTEventListenerProxy
extends EventListenerProxy<AWTEventListener>
implements AWTEventListener
    一个扩展EventListenerProxy专门为特定事件掩码添加一个AWTEventListener的类。 此类的实例可以添加为AWTEventListener s到一个Toolkit对象。

    该getAWTEventListeners的方法Toolkit可以返回的混合物AWTEventListener个AWTEventListenerProxy对象。

    从以下版本开始：
    1.4
    另请参见：
    Toolkit ， EventListenerProxy

    • 构造方法摘要

      构造方法
      Constructor 描述
      AWTEventListenerProxy​(long eventMask, AWTEventListener listener)
      构造函数将 AWTEventListener绑定到特定事件掩码。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void eventDispatched​(AWTEvent event)
      将AWT事件转发给侦听器代理。
      long getEventMask​()
      返回与侦听器关联的事件掩码。

      • Methods inherited from class java.util.EventListenerProxy

        getListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AWTEventListenerProxy

        public AWTEventListenerProxy​(long eventMask,
                             AWTEventListener listener)
        构造函数将 AWTEventListener绑定到特定事件掩码。
        参数
        eventMask - 要接收的事件类型的位图
        listener - 侦听器对象

    • 方法详细信息

      • eventDispatched

        public void eventDispatched​(AWTEvent event)
        将AWT事件转发给侦听器代理。
        Specified by:
        eventDispatched在接口 AWTEventListener
        参数
        event - AWT事件

      • getEventMask

        public long getEventMask​()
        返回与侦听器关联的事件掩码。
        结果
        与侦听器关联的事件掩码
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ComponentAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class ComponentAdapter

  • java.lang.Object
    • java.awt.event.ComponentAdapter
  • All Implemented Interfaces:
    ComponentListener ， EventListener
    已知直接子类：
    BasicSliderUI.ComponentHandler ， BasicTreeUI.ComponentHandler ， JViewport.ViewListener

    public abstract class ComponentAdapter
extends Object
implements ComponentListener
    用于接收组件事件的抽象适配器类。 这个类中的方法是空的。 此类作为创建侦听器对象的方便而存在。

    扩展此类以创建一个ComponentEvent监听器，并覆盖感兴趣事件的方法。 （如果您实现了ComponentListener接口，则必须定义其中的所有方法，这个抽象类为它们定义了空方法，因此您只能定义关心事件的方法。）

    使用您的类创建一个侦听器对象，然后使用组件的addComponentListener方法将其注册到组件。 当组件的大小，位置或可见性更改时，将调用侦听器对象中的相关方法，并将其传递给该ComponentEvent 。

    从以下版本开始：
    1.1
    另请参见：
    ComponentEvent ， ComponentListener ， Tutorial: Writing a Component Listener

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComponentAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void componentHidden​(ComponentEvent e)
      当该组件不可见时调用。
      void componentMoved​(ComponentEvent e)
      当组件的位置更改时调用。
      void componentResized​(ComponentEvent e)
      当组件的大小更改时调用。
      void componentShown​(ComponentEvent e)
      当组件可见时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ComponentAdapter

        public ComponentAdapter​()

    • 方法详细信息

      • componentResized

        public void componentResized​(ComponentEvent e)
        当组件的大小更改时调用。
        Specified by:
        componentResized在接口 ComponentListener
        参数
        e - 要处理的事件

      • componentMoved

        public void componentMoved​(ComponentEvent e)
        当组件的位置更改时调用。
        Specified by:
        componentMoved在接口 ComponentListener
        参数
        e - 要处理的事件

      • componentShown

        public void componentShown​(ComponentEvent e)
        当组件可见时调用。
        Specified by:
        componentShown在接口 ComponentListener
        参数
        e - 要处理的事件

      • componentHidden

        public void componentHidden​(ComponentEvent e)
        当该组件不可见时调用。
        Specified by:
        componentHidden在接口 ComponentListener
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ComponentEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class ComponentEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ContainerEvent ， FocusEvent ， InputEvent ， PaintEvent ， WindowEvent

    public class ComponentEvent
extends AWTEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。

    组件事件仅供通知用途; AWT将自动处理组件移动并在内部调整大小，以使GUI布局正常工作，而不管程序是否正在接收这些事件。

    除了作为其他组件相关事件（InputEvent，FocusEvent，WindowEvent，ContainerEvent）的基类之外，此类还定义了指示组件大小，位置或可见性变化的事件。

    当组件移动，调整大小，呈现不可见或再次可见时，此低级事件由组件对象（例如List）生成。 事件被传递给每个ComponentListener或ComponentAdapter对象，其注册使用组件的addComponentListener方法接收此类事件。 （ ComponentAdapter对象实现ComponentListener接口。）当事件发生时，每个这样的侦听器对象获得这个ComponentEvent 。

    如果任何特定的ComponentEvent实例的id参数不在从COMPONENT_FIRST到COMPONENT_LAST的范围内，将会导致未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    ComponentAdapter ， ComponentListener ， Tutorial: Writing a Component Listener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int COMPONENT_FIRST
      用于组件事件的ids范围中的第一个数字。
      static int COMPONENT_HIDDEN
      此事件表示该组件被呈现为不可见。
      static int COMPONENT_LAST
      用于组件事件的ID的范围中的最后一个数字。
      static int COMPONENT_MOVED
      此事件表示组件的位置已更改。
      static int COMPONENT_RESIZED
      此事件表示组件的大小已更改。
      static int COMPONENT_SHOWN
      此事件表示组件已显示。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComponentEvent​(Component source, int id)
      构造一个 ComponentEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Component getComponent​()
      返回事件的发起者。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • COMPONENT_FIRST

        public static final int COMPONENT_FIRST
        用于组件事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • COMPONENT_LAST

        public static final int COMPONENT_LAST
        用于组件事件的ID的范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • COMPONENT_MOVED

        @Native
public static final int COMPONENT_MOVED
        此事件表示组件的位置已更改。
        另请参见：
        Constant Field Values

      • COMPONENT_RESIZED

        @Native
public static final int COMPONENT_RESIZED
        此事件表示组件的大小已更改。
        另请参见：
        Constant Field Values

      • COMPONENT_SHOWN

        @Native
public static final int COMPONENT_SHOWN
        此事件表示组件已显示。
        另请参见：
        Constant Field Values

      • COMPONENT_HIDDEN

        @Native
public static final int COMPONENT_HIDDEN
        此事件表示该组件被呈现为不可见。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ComponentEvent

        public ComponentEvent​(Component source,
                      int id)
        构造一个ComponentEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅ComponentEvent的类描述
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        getComponent() ， AWTEvent.getID()

    • 方法详细信息

      • getComponent

        public Component getComponent​()
        返回事件的发起者。
        结果
        所述 Component对象发起事件，或 null ，如果对象不是 Component 。

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString类 AWTEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ComponentListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface ComponentListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicInternalFrameUI.ComponentHandler ， BasicSliderUI.ComponentHandler ， BasicTreeUI.ComponentHandler ， Component.AccessibleAWTComponent.AccessibleAWTComponentHandler ， ComponentAdapter ， JViewport.ViewListener

    public interface ComponentListener
extends EventListener
    用于接收组件事件的侦听器接口。 有兴趣处理组件事件的类实现此接口（及其包含的所有方法）或扩展抽象的ComponentAdapter类（仅覆盖感兴趣的方法）。 然后，使用组件的addComponentListener方法将从该类创建的侦听器对象注册到组件。 当组件的大小，位置或可见性更改时，将调用侦听器对象中的相关方法，并将其传递给该ComponentEvent 。

    组件事件仅供通知用途; AWT将自动处理组件移动并在内部调整大小，以使GUI布局正常工作，而不管程序是否注册了ComponentListener 。

    从以下版本开始：
    1.1
    另请参见：
    ComponentAdapter ， ComponentEvent ， Tutorial: Writing a Component Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void componentHidden​(ComponentEvent e)
      当该组件不可见时调用。
      void componentMoved​(ComponentEvent e)
      当组件的位置更改时调用。
      void componentResized​(ComponentEvent e)
      当组件的大小更改时调用。
      void componentShown​(ComponentEvent e)
      当组件可见时调用。

    • 方法详细信息

      • componentResized

        void componentResized​(ComponentEvent e)
        当组件的大小更改时调用。
        参数
        e - 要处理的事件

      • componentMoved

        void componentMoved​(ComponentEvent e)
        当组件的位置更改时调用。
        参数
        e - 要处理的事件

      • componentShown

        void componentShown​(ComponentEvent e)
        当组件可见时调用。
        参数
        e - 要处理的事件

      • componentHidden

        void componentHidden​(ComponentEvent e)
        当该组件不可见时调用。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContainerAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class ContainerAdapter

  • java.lang.Object
    • java.awt.event.ContainerAdapter
  • All Implemented Interfaces:
    ContainerListener ， EventListener

    public abstract class ContainerAdapter
extends Object
implements ContainerListener
    用于接收容器事件的抽象适配器类。 这个类中的方法是空的。 此类作为创建侦听器对象的方便而存在。

    扩展此类以创建一个ContainerEvent监听器并覆盖感兴趣的事件的方法。 （如果您实现了ContainerListener接口，则必须定义其中的所有方法，这个抽象类为它们定义了空方法，因此您只能为所关心的事件定义方法。）

    使用扩展类创建侦听器对象，然后使用组件的addContainerListener方法将其注册到组件。 当容器的内容因添加或删除组件而发生变化时，将调用侦听器对象中的相关方法，并将其传递给其中的ContainerEvent 。

    从以下版本开始：
    1.1
    另请参见：
    ContainerEvent ， ContainerListener ， Tutorial: Writing a Container Listener

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContainerAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void componentAdded​(ContainerEvent e)
      当组件已添加到容器时调用。
      void componentRemoved​(ContainerEvent e)
      当组件从容器中删除时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ContainerAdapter

        public ContainerAdapter​()

    • 方法详细信息

      • componentAdded

        public void componentAdded​(ContainerEvent e)
        当组件已添加到容器时调用。
        Specified by:
        componentAdded在接口 ContainerListener
        参数
        e - 要处理的事件

      • componentRemoved

        public void componentRemoved​(ContainerEvent e)
        当组件从容器中删除时调用。
        Specified by:
        componentRemoved在接口 ContainerListener
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContainerEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class ContainerEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.ContainerEvent
  • All Implemented Interfaces:
    Serializable

    public class ContainerEvent
extends ComponentEvent
    低级别事件，表示容器的内容因添加或删除组件而发生更改。

    集装箱事件仅供通报用途; AWT将自动处理内部对容器内容的更改，以使程序正常工作，而不管程序是否接收到这些事件。

    当组件被添加到该组件或从其中删除时，此低级事件由容器对象（例如Panel）生成。 该事件传递给每个ContainerListener或ContainerAdapter对象，该对象使用组件的addContainerListener方法注册接收此类事件。 （ ContainerAdapter对象实现ContainerListener接口）每个这样的侦听器对象在事件发生时得到这个ContainerEvent 。

    任何特定ContainerEvent实例的id参数不在CONTAINER_FIRST至CONTAINER_LAST的范围内，将会引起未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    ContainerAdapter ， ContainerListener ， Tutorial: Writing a Container Listener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int COMPONENT_ADDED
      此事件表示组件已添加到容器中。
      static int COMPONENT_REMOVED
      此事件表示组件已从容器中删除。
      static int CONTAINER_FIRST
      用于容器事件的ids范围中的第一个数字。
      static int CONTAINER_LAST
      用于容器事件的ids范围中的最后一个数字。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContainerEvent​(Component source, int id, Component child)
      构造一个 ContainerEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Component getChild​()
      返回受事件影响的组件。
      Container getContainer​()
      返回事件的发起者。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • CONTAINER_FIRST

        public static final int CONTAINER_FIRST
        用于容器事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • CONTAINER_LAST

        public static final int CONTAINER_LAST
        用于容器事件的ids范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • COMPONENT_ADDED

        public static final int COMPONENT_ADDED
        此事件表示组件已添加到容器中。
        另请参见：
        Constant Field Values

      • COMPONENT_REMOVED

        public static final int COMPONENT_REMOVED
        此事件表示组件已从容器中删除。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ContainerEvent

        public ContainerEvent​(Component source,
                      int id,
                      Component child)
        构造一个ContainerEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component对象（容器）
        id - 指示事件类型的整数。 有关允许值的信息，请参阅ContainerEvent的类描述
        child - 添加或删除的组件
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        getContainer() ，
AWTEvent.getID() ，
getChild()

    • 方法详细信息

      • getContainer

        public Container getContainer​()
        返回事件的发起者。
        结果
        所述 Container对象发起事件，或 null ，如果对象不是 Container 。

      • getChild

        public Component getChild​()
        返回受事件影响的组件。
        结果
        添加或删除的组件对象

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 ComponentEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContainerListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface ContainerListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicToolBarUI.ToolBarContListener ， Container.AccessibleAWTContainer.AccessibleContainerHandler ， ContainerAdapter ， JComponent.AccessibleJComponent.AccessibleContainerHandler ， MetalToolBarUI.MetalContainerListener

    public interface ContainerListener
extends EventListener
    用于接收容器事件的侦听器接口。 处理容器事件感兴趣的类可以实现这个接口（和它包含的所有方法），也可以扩展抽象的ContainerAdapter类（仅覆盖感兴趣的方法）。 然后，使用该组件的addContainerListener方法将从该类创建的侦听器对象注册到组件。 当容器的内容因添加或删除组件而发生变化时，将调用侦听器对象中的相关方法，并将其传递给该应用程序ContainerEvent 。

    集装箱事件仅供通报用途; AWT将自动处理内部的添加和删除操作，以便程序正常工作，无论程序是否注册了ContainerListener 。

    从以下版本开始：
    1.1
    另请参见：
    ContainerAdapter ， ContainerEvent ， Tutorial: Writing a Container Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void componentAdded​(ContainerEvent e)
      当组件已添加到容器时调用。
      void componentRemoved​(ContainerEvent e)
      当组件从容器中删除时调用。

    • 方法详细信息

      • componentAdded

        void componentAdded​(ContainerEvent e)
        当组件已添加到容器时调用。
        参数
        e - 要处理的事件

      • componentRemoved

        void componentRemoved​(ContainerEvent e)
        当组件从容器中删除时调用。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FocusAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class FocusAdapter

  • java.lang.Object
    • java.awt.event.FocusAdapter
  • All Implemented Interfaces:
    FocusListener ， EventListener
    已知直接子类：
    BasicSplitPaneUI.FocusHandler ， BasicTabbedPaneUI.FocusHandler

    public abstract class FocusAdapter
extends Object
implements FocusListener
    用于接收键盘焦点事件的抽象适配器类。 这个类中的方法是空的。 此类作为创建侦听器对象的方便而存在。

    扩展此类以创建一个FocusEvent监听器并覆盖感兴趣的事件的方法。 （如果您实现了FocusListener接口，则必须定义其中的所有方法，这个抽象类为它们定义了空方法，因此您只能为所关心的事件定义方法。）

    使用扩展类创建侦听器对象，然后使用组件的addFocusListener方法将其注册到组件。 当组分获得或失去键盘焦点，在收听对象中的相关方法被调用，并且FocusEvent被传递给它。

    从以下版本开始：
    1.1
    另请参见：
    FocusEvent ， FocusListener ， Tutorial: Writing a Focus Listener

    • 构造方法摘要

      构造方法
      Constructor 描述
      FocusAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void focusGained​(FocusEvent e)
      当组件获得键盘焦点时调用。
      void focusLost​(FocusEvent e)
      当组件丢失键盘焦点时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FocusAdapter

        public FocusAdapter​()

    • 方法详细信息

      • focusGained

        public void focusGained​(FocusEvent e)
        当组件获得键盘焦点时调用。
        Specified by:
        focusGained在接口 FocusListener
        参数
        e - 要处理的事件

      • focusLost

        public void focusLost​(FocusEvent e)
        当组件丢失键盘焦点时调用。
        Specified by:
        focusLost在接口 FocusListener
        参数
        e - the event to be processed
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FocusEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class FocusEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.FocusEvent
  • All Implemented Interfaces:
    Serializable

    public class FocusEvent
extends ComponentEvent
    指示组件已经获得或丢失了输入焦点的低级事件。 此低级别事件由组件（如TextField）生成。 事件被传递给使用组件的addFocusListener方法注册接收此类事件的每个FocusListener或FocusAdapter对象。 （ FocusAdapter对象实现FocusListener接口。）每个这样的侦听器对象在事件发生时得到这个FocusEvent 。

    焦点事件有两个层次：永久性和临时性。 当焦点直接从一个组件移动到另一个组件时，例如通过调用requestFocus（）或用户使用TAB键遍历组件时，会发生永久性焦点更改事件。 当组件临时丢失焦点作为另一个操作的间接结果（如窗口停用或滚动条拖动）时，会发生临时焦点更改事件。 在这种情况下，一旦操作完成，原始对焦状态就会自动恢复，或者在Windows停用的情况下，当窗口重新激活时。 永久和临时焦点事件都使用FOCUS_GAINED和FOCUS_LOST事件ID进行传递; 在使用isTemporary（）方法的情况下，可以区分该级别。

    每FocusEvent记录它的原因 - 这个事件被生成的原因。 原因是在焦点事件创建期间分配的，可以通过调用getCause()来检索。

    如果任何特定的FocusEvent实例的id参数不在从FOCUS_FIRST到FOCUS_LAST的范围内，将会引起未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    FocusAdapter ， FocusListener ， Tutorial: Writing a Focus Listener ， Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  FocusEvent.Cause
      这个枚举代表了一个 FocusEvent的原因 - 其发生的原因。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int FOCUS_FIRST
      用于焦点事件的ids范围中的第一个数字。
      static int FOCUS_GAINED
      此事件表示组件现在是焦点所有者。
      static int FOCUS_LAST
      用于焦点事件的ids范围中的最后一个数字。
      static int FOCUS_LOST
      此事件表示组件不再是焦点所有者。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      FocusEvent​(Component source, int id)
      构造一个 FocusEvent对象，并将其标识为焦点的永久性更改。
      FocusEvent​(Component source, int id, boolean temporary)
      构造一个 FocusEvent对象，并确定更改是否是临时的。
      FocusEvent​(Component source, int id, boolean temporary, Component opposite)
      构造一个具有指定临时状态的 FocusEvent对象，与 Component相反， Cause.UNKNOWN原因。
      FocusEvent​(Component source, int id, boolean temporary, Component opposite, FocusEvent.Cause cause)
      构造一个 FocusEvent对象，具有指定的临时状态，相反的是 Component及其原因。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      FocusEvent.Cause getCause​()
      返回事件原因。
      Component getOppositeComponent​()
      返回此焦点更改中涉及的其他组件。
      boolean isTemporary​()
      将焦点更改事件标识为临时或永久。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FOCUS_FIRST

        public static final int FOCUS_FIRST
        用于焦点事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • FOCUS_LAST

        public static final int FOCUS_LAST
        用于焦点事件的ids范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • FOCUS_GAINED

        public static final int FOCUS_GAINED
        此事件表示组件现在是焦点所有者。
        另请参见：
        Constant Field Values

      • FOCUS_LOST

        public static final int FOCUS_LOST
        此事件表示组件不再是焦点所有者。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • FocusEvent

        public FocusEvent​(Component source,
                  int id,
                  boolean temporary,
                  Component opposite)
        构造一个具有指定临时状态的FocusEvent对象，与Component相反， Cause.UNKNOWN原因。 相反的Component是另外Component涉及到这个焦点的变化。 对于FOCUS_GAINED事件，这是Component失去焦点。 对于FOCUS_LOST事件，这是获得焦点的Component 。 如果本机应用程序发生此焦点更改，在不同的VM中使用Java应用程序，或者没有其他的Component ，那么相反的Component是null 。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 表示事件类型的整数。 有关允许值的信息，请参阅FocusEvent的类说明
        temporary - 如果焦点变化是暂时的，则等于true ; 否则为false
        opposite - 涉及焦点更改的其他组件，或 null
        异常
        IllegalArgumentException - 如果 source等于 null
        从以下版本开始：
        1.4
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
isTemporary() ，
getOppositeComponent() ，
FocusEvent.Cause.UNKNOWN

      • FocusEvent

        public FocusEvent​(Component source,
                  int id,
                  boolean temporary,
                  Component opposite,
                  FocusEvent.Cause cause)
        构造一个FocusEvent对象，具有指定的临时状态，相反的原因是Component 。 相反的Component是另外Component涉及到这个焦点变化。 对于FOCUS_GAINED事件，这是Component失去了焦点。 对于FOCUS_LOST事件，这是获得焦点的Component 。 如果使用本机应用程序发生此焦点更改，使用Java应用程序在不同的VM中，或者没有其他的Component ，则相反的Component是null 。

        此方法抛出IllegalArgumentException如果source或cause是null 。

        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅FocusEvent的类描述
        temporary - 如果焦点改变是暂时的，则等于true ; 否则为false
        opposite - 涉及焦点更改的其他组件，或 null
        cause - 焦点事件原因。
        异常
        IllegalArgumentException - 如果 source等于 null或如果 cause等于 null
        从以下版本开始：
        9
        另请参见：
        EventObject.getSource() ， AWTEvent.getID() ， isTemporary() ， getOppositeComponent() ， FocusEvent.Cause

      • FocusEvent

        public FocusEvent​(Component source,
                  int id,
                  boolean temporary)
        构造一个FocusEvent对象，并确定更改是否是临时的。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅FocusEvent的类说明
        temporary - 如果焦点变化是暂时的，则等于true ; false否则
        异常
        IllegalArgumentException - 如果 source等于 null
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
isTemporary()

      • FocusEvent

        public FocusEvent​(Component source,
                  int id)
        构造一个FocusEvent对象，并将其标识为焦点的永久性更改。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 表示事件类型的整数。 有关允许值的信息，请参阅FocusEvent的类描述
        异常
        IllegalArgumentException - 如果 source等于 null
        另请参见：
        EventObject.getSource() ， AWTEvent.getID()

    • 方法详细信息

      • isTemporary

        public boolean isTemporary​()
        将焦点更改事件标识为临时或永久。
        结果
        true如果焦点变化是暂时的; 否则为false

      • getOppositeComponent

        public Component getOppositeComponent​()
        返回此焦点更改中涉及的其他组件。 对于FOCUS_GAINED事件，这是失去焦点的组件。 对于FOCUS_LOST事件，这是获得焦点的组件。 如果本地应用程序发生此焦点更改，在不同的VM或上下文中使用Java应用程序，或者没有其他组件，则返回null。
        结果
        其他组件涉及到焦点更改，或为null
        从以下版本开始：
        1.4

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 ComponentEvent
        结果
        标识事件及其属性的字符串

      • getCause

        public final FocusEvent.Cause getCause​()
        返回事件原因。
        结果
        一个FocusEvent.Cause值
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FocusEvent.Cause (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt.event

Enum FocusEvent.Cause

  • java.lang.Object
    • java.lang.Enum<FocusEvent.Cause>
      • java.awt.event.FocusEvent.Cause
  • All Implemented Interfaces:
    Serializable ， Comparable<FocusEvent.Cause>
    Enclosing class:
    FocusEvent

    public static enum FocusEvent.Cause
extends Enum<FocusEvent.Cause>
    这个枚举代表了一个FocusEvent的原因 - 它发生的原因。 可能的原因包括鼠标事件，键盘焦点遍历，窗口激活。 如果没有提供任何理由，那么原因是UNKNOWN 。
    从以下版本开始：
    9

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ACTIVATION
      激活一个tople窗口。
      CLEAR_GLOBAL_FOCUS_OWNER
      清理全球焦点所有者。
      MOUSE_EVENT
      激活鼠标事件。
      ROLLBACK
      焦点请求之后恢复焦点已被拒绝。
      TRAVERSAL
      具有未指定方向的焦点遍历动作。
      TRAVERSAL_BACKWARD
      反向聚焦遍历动作。
      TRAVERSAL_DOWN
      下循环焦点遍历动作。
      TRAVERSAL_FORWARD
      前向焦点遍历动作。
      TRAVERSAL_UP
      循环重点遍历动作。
      UNEXPECTED
      导致意外焦点更改的系统操作。
      UNKNOWN
      默认值。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static FocusEvent.Cause valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FocusEvent.Cause[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNKNOWN

        public static final FocusEvent.Cause UNKNOWN
        默认值。

      • MOUSE_EVENT

        public static final FocusEvent.Cause MOUSE_EVENT
        激活鼠标事件。

      • TRAVERSAL

        public static final FocusEvent.Cause TRAVERSAL
        具有未指定方向的焦点遍历动作。

      • TRAVERSAL_UP

        public static final FocusEvent.Cause TRAVERSAL_UP
        循环重点遍历动作。

      • TRAVERSAL_DOWN

        public static final FocusEvent.Cause TRAVERSAL_DOWN
        下循环焦点遍历动作。

      • TRAVERSAL_FORWARD

        public static final FocusEvent.Cause TRAVERSAL_FORWARD
        前向焦点遍历动作。

      • TRAVERSAL_BACKWARD

        public static final FocusEvent.Cause TRAVERSAL_BACKWARD
        反向聚焦遍历动作。

      • ROLLBACK

        public static final FocusEvent.Cause ROLLBACK
        焦点请求之后恢复焦点已被拒绝。

      • UNEXPECTED

        public static final FocusEvent.Cause UNEXPECTED
        导致意外焦点更改的系统操作。

      • ACTIVATION

        public static final FocusEvent.Cause ACTIVATION
        激活一个tople窗口。

      • CLEAR_GLOBAL_FOCUS_OWNER

        public static final FocusEvent.Cause CLEAR_GLOBAL_FOCUS_OWNER
        清理全球焦点所有者。

    • 方法详细信息

      • values

        public static FocusEvent.Cause[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (FocusEvent.Cause c : FocusEvent.Cause.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static FocusEvent.Cause valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


FocusListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface FocusListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicButtonListener ， BasicComboBoxEditor ， BasicComboBoxEditor.UIResource ， BasicComboBoxUI.FocusHandler ， BasicListUI.FocusHandler ， BasicSliderUI.FocusHandler ， BasicSplitPaneUI.FocusHandler ， BasicTabbedPaneUI.FocusHandler ， BasicTableUI.FocusHandler ， BasicTextUI.BasicCaret ， BasicToolBarUI.ToolBarFocusListener ， BasicTreeUI.FocusHandler ， Component.AccessibleAWTComponent.AccessibleAWTFocusHandler ， DefaultCaret ， FocusAdapter ， JComponent.AccessibleJComponent.AccessibleFocusHandler ， MetalComboBoxEditor ， MetalComboBoxEditor.UIResource

    public interface FocusListener
extends EventListener
    用于在组件上接收键盘焦点事件的侦听器界面。 有兴趣处理焦点事件的类实现此接口（及其包含的所有方法）或扩展抽象的FocusAdapter类（仅覆盖感兴趣的方法）。 然后，使用组件的addFocusListener方法将从该类创建的侦听器对象注册到组件。 当组分获得或失去键盘焦点，在收听对象中的相关方法被调用，并且FocusEvent被传递给它。
    从以下版本开始：
    1.1
    另请参见：
    FocusAdapter ， FocusEvent ， Tutorial: Writing a Focus Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void focusGained​(FocusEvent e)
      当组件获得键盘焦点时调用。
      void focusLost​(FocusEvent e)
      当组件丢失键盘焦点时调用。

    • 方法详细信息

      • focusGained

        void focusGained​(FocusEvent e)
        当组件获得键盘焦点时调用。
        参数
        e - 要处理的事件

      • focusLost

        void focusLost​(FocusEvent e)
        当组件丢失键盘焦点时调用。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HierarchyBoundsAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class HierarchyBoundsAdapter

  • java.lang.Object
    • java.awt.event.HierarchyBoundsAdapter
  • All Implemented Interfaces:
    HierarchyBoundsListener ， EventListener

    public abstract class HierarchyBoundsAdapter
extends Object
implements HierarchyBoundsListener
    用于接收祖先移动和调整大小的事件的抽象适配器类。 这个类中的方法是空的。 此类存在为创建侦听器对象的方便。

    扩展此类并覆盖感兴趣的事件的方法。 （如果您实现了HierarchyBoundsListener接口，则必须在其中定义两个方法，这个抽象类为它们定义了空方法，因此您只需定义所关心事件的方法。）

    使用您的类创建侦听器对象，然后使用组件的addHierarchyBoundsListener方法将其注册到组件。 当组件所属通过调整大小或祖先的运动改变到层次结构中，在收听者对象中的相关方法被调用，并且HierarchyEvent被传递给它。

    从以下版本开始：
    1.3
    另请参见：
    HierarchyBoundsListener ， HierarchyEvent

    • 构造方法摘要

      构造方法
      Constructor 描述
      HierarchyBoundsAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void ancestorMoved​(HierarchyEvent e)
      当源的祖先移动时调用。
      void ancestorResized​(HierarchyEvent e)
      调用源的祖先调整大小时。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HierarchyBoundsAdapter

        public HierarchyBoundsAdapter​()

    • 方法详细信息

      • ancestorMoved

        public void ancestorMoved​(HierarchyEvent e)
        当源的祖先移动时调用。
        Specified by:
        ancestorMoved在接口 HierarchyBoundsListener
        参数
        e - 要处理的事件

      • ancestorResized

        public void ancestorResized​(HierarchyEvent e)
        调用源的祖先调整大小时。
        Specified by:
        ancestorResized在接口 HierarchyBoundsListener
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HierarchyBoundsListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface HierarchyBoundsListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， HierarchyBoundsAdapter

    public interface HierarchyBoundsListener
extends EventListener
    用于接收祖先移动和调整大小的事件的侦听器接口。 有兴趣处理这些事件的类可以实现这个接口（和它包含的所有方法），或扩展抽象的HierarchyBoundsAdapter类（仅覆盖感兴趣的方法）。 然后，使用组件的addHierarchyBoundsListener方法将从该类创建的侦听器对象注册到组件。 当组件所属的层次结构通过祖先的调整大小或移动进行更改时，将调用侦听器对象中的相关方法，并将其传递给该HierarchyEvent 。

    层次结构事件仅供通报用途; AWT将自动处理层次结构内部的更改，以使GUI布局正常工作，无论程序是否注册了HierarchyBoundsListener 。

    从以下版本开始：
    1.3
    另请参见：
    HierarchyBoundsAdapter ， HierarchyEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void ancestorMoved​(HierarchyEvent e)
      当源的祖先移动时调用。
      void ancestorResized​(HierarchyEvent e)
      调用源的祖先调整大小时。

    • 方法详细信息

      • ancestorMoved

        void ancestorMoved​(HierarchyEvent e)
        当源的祖先移动时调用。
        参数
        e - 要处理的事件

      • ancestorResized

        void ancestorResized​(HierarchyEvent e)
        调用源的祖先调整大小时。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HierarchyEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class HierarchyEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.HierarchyEvent
  • All Implemented Interfaces:
    Serializable

    public class HierarchyEvent
extends AWTEvent
    表示Component属于Component层次结构的更改的事件。
    • 层次结构更改事件（HierarchyListener）
      • 加上祖先
      • 去除祖先
      • 层次结构可显示
      • 层次结构不可显示
      • 屏幕上显示的层次结构（可见和可显示）
      • 屏幕上隐藏的层次结构（不可见或不可显示）
    • 祖先重塑事件（HierarchyBoundsListener）
      • 祖先被调整大小
      • 祖先被移动了

    层次结构事件仅供通报用途。 AWT将自动处理内部对层次结构的更改，以使GUI布局和可显示性正常工作，而不管程序是否正在接收这些事件。

    当容器被添加，删除，移动或调整大小并传递给层次结构时，此事件由Container对象（例如Panel）生成。 它也通过一个组件对象生成时该对象的addNotify ， removeNotify ， show ，或hide被调用的方法。 将ANCESTOR_MOVED和ANCESTOR_RESIZED事件发送到使用组件的addHierarchyBoundsListener方法注册接收此类事件的每个HierarchyBoundsListener或HierarchyBoundsAdapter对象。 （ HierarchyBoundsAdapter对象实现HierarchyBoundsListener接口。）将HIERARCHY_CHANGED事件发送到每个HierarchyListener对象，该对象使用组件的addHierarchyListener方法注册接收此类事件。 当事件发生时，每个这样的侦听器对象获得这个HierarchyEvent 。

    如果任何特定HierarchyEvent实例的id参数不在从HIERARCHY_FIRST到HIERARCHY_LAST的范围内，将会引起未指定的行为。
    任何HierarchyEvent实例的changeFlags参数都需要以下值之一：

    • HierarchyEvent.PARENT_CHANGED
    • HierarchyEvent.DISPLAYABILITY_CHANGED
    • HierarchyEvent.SHOWING_CHANGED
    分配与上述不同的值将导致未指定的行为。
    从以下版本开始：
    1.3
    另请参见：
    HierarchyListener ， HierarchyBoundsAdapter ， HierarchyBoundsListener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ANCESTOR_MOVED
      指示一个祖先的容器ID被移动了。
      static int ANCESTOR_RESIZED
      指示祖先的事件ID容器被调整大小。
      static int DISPLAYABILITY_CHANGED
      更改标志表示 HIERARCHY_CHANGED事件是由于层次可显示性的改变而生成的。
      static int HIERARCHY_CHANGED
      事件id表示对整个层次结构树进行了修改。
      static int HIERARCHY_FIRST
      标记层次结构事件ID范围的第一个整数ID。
      static int HIERARCHY_LAST
      标记祖先事件ID的范围的最后一个整数ID。
      static int PARENT_CHANGED
      更改标志表示 HIERARCHY_CHANGED事件是由重新启动操作生成的。
      static int SHOWING_CHANGED
      更改标志表示 HIERARCHY_CHANGED事件由于显示状态的层次结构的变化而生成。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      HierarchyEvent​(Component source, int id, Component changed, Container changedParent)
      构造一个 HierarchyEvent对象，以标识 Component层次结构中的更改。
      HierarchyEvent​(Component source, int id, Component changed, Container changedParent, long changeFlags)
      构造一个 HierarchyEvent对象，以标识 Component层次结构中的更改。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Component getChanged​()
      返回已更改的层次结构顶部的组件。
      Container getChangedParent​()
      返回由 getChanged()返回的组件的父 getChanged() 。
      long getChangeFlags​()
      返回一个位掩码，指示此事件对象中表示的HIERARCHY_CHANGED事件的类型。
      Component getComponent​()
      返回事件的发起者。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • HIERARCHY_FIRST

        public static final int HIERARCHY_FIRST
        标记层次结构事件ID范围的第一个整数ID。
        另请参见：
        Constant Field Values

      • HIERARCHY_CHANGED

        public static final int HIERARCHY_CHANGED
        事件id表示对整个层次结构树进行了修改。
        另请参见：
        Constant Field Values

      • ANCESTOR_MOVED

        public static final int ANCESTOR_MOVED
        指示一个祖先的容器ID被移动了。
        另请参见：
        Constant Field Values

      • ANCESTOR_RESIZED

        public static final int ANCESTOR_RESIZED
        指示祖先的事件ID容器被调整大小。
        另请参见：
        Constant Field Values

      • HIERARCHY_LAST

        public static final int HIERARCHY_LAST
        标记祖先事件ID的范围的最后一个整数ID。
        另请参见：
        Constant Field Values

      • PARENT_CHANGED

        public static final int PARENT_CHANGED
        更改标志表示 HIERARCHY_CHANGED事件是由重新启动操作生成的。
        另请参见：
        Constant Field Values

      • DISPLAYABILITY_CHANGED

        public static final int DISPLAYABILITY_CHANGED
        更改标志表示HIERARCHY_CHANGED事件是由于层次可显示性的改变而生成的。 要辨别层次结构的当前可显示性，请调用Component.isDisplayable方法。 显示更改发生在对Component.addNotify和Component.removeNotify方法的显式或隐式调用的响应中。
        另请参见：
        Component.isDisplayable() ，
Component.addNotify() ，
Component.removeNotify() ，
Constant Field Values

      • SHOWING_CHANGED

        public static final int SHOWING_CHANGED
        更改标志表示由于显示状态的层次结构的改变而产生了HIERARCHY_CHANGED事件。 要辨别当前显示状态的层次结构，请调用Component.isShowing方法。 当层次结构的可显示性或可见性发生时，显示状态更改。 响应显式或隐式调用Component.show和Component.hide方法，可见性更改。
        另请参见：
        Component.isShowing() ，
Component.addNotify() ，
Component.removeNotify() ，
Component.show() ，
Component.hide() ，
Constant Field Values

    • 构造方法详细信息

      • HierarchyEvent

        public HierarchyEvent​(Component source,
                      int id,
                      Component changed,
                      Container changedParent)
        构造一个HierarchyEvent对象，以标识Component层次结构中的更改。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component对象
        id - 表示事件类型的整数。 有关允许值的信息，请参阅HierarchyEvent的类描述
        changed - 层次结构顶部的 Component已更改
        changedParent - changed组件的父changed 。 这可能是变更之前或之后的父母，具体取决于变化的类型
        异常
        IllegalArgumentException - 如果 source是 null
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getChanged() ，
getChangedParent()

      • HierarchyEvent

        public HierarchyEvent​(Component source,
                      int id,
                      Component changed,
                      Container changedParent,
                      long changeFlags)
        构造一个HierarchyEvent对象，以标识Component层次结构中的更改。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component对象
        id - 指示事件类型的整数。 有关允许值的信息，请参阅HierarchyEvent的类说明
        changed - 位于层次结构顶端的 Component已更改
        changedParent - changed组件的父changed 。 这可能是变更之前或之后的父母，具体取决于变化的类型
        changeFlags - 表示此事件对象中表示的HIERARCHY_CHANGED事件的类型的位掩码。 有关允许值的信息，请参阅HierarchyEvent的类说明
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getChanged() ，
getChangedParent() ，
getChangeFlags()

    • 方法详细信息

      • getComponent

        public Component getComponent​()
        返回事件的发起者。
        结果
        所述 Component对象发起事件，或 null ，如果对象不是 Component 。

      • getChanged

        public Component getChanged​()
        返回已更改的层次结构顶部的组件。
        结果
        更改的组件

      • getChangedParent

        public Container getChangedParent​()
        返回由getChanged()返回的组件的父getChanged() 。 对于通过调用Container.add更改类型为PARENT_CHANGED的HIERARCHY_CHANGED事件，返回的父级是添加操作后的父级。 对于通过调用Container.remove ，更改类型为PARENT_CHANGED的HIERARCHY_CHANGED事件，返回的父级是删除操作之前的父级。 对于所有其他事件和类型，返回的父级是操作期间的父级。
        结果
        更改的组件的父级

      • getChangeFlags

        public long getChangeFlags​()
        返回一个位掩码，指示此事件对象中表示的HIERARCHY_CHANGED事件的类型。 这些位已经按比例地排列在一起。
        结果
        位掩码，如果不是HIERARCHY_CHANGED事件，则为0

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 AWTEvent
        结果
        a string identifying the event and its attributes
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HierarchyListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface HierarchyListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster

    public interface HierarchyListener
extends EventListener
    用于接收层次结构的侦听器界面更改事件。 有兴趣处理层次结构改变事件的类应该实现这个接口。 然后，使用组件的addHierarchyListener方法，使用从该类创建的侦听器对象向组件注册。 当层次结构组件所属的变化， hierarchyChanged在听者对象方法调用，并且HierarchyEvent被传递给它。

    层次结构事件仅供通报用途; AWT将自动处理内部对层次结构的更改，以使GUI布局，可显示性和可见性正常工作，而不管程序是否注册了HierarchyListener 。

    从以下版本开始：
    1.3
    另请参见：
    HierarchyEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void hierarchyChanged​(HierarchyEvent e)
      当层次结构被更改时调用。

    • 方法详细信息

      • hierarchyChanged

        void hierarchyChanged​(HierarchyEvent e)
        当层次结构被更改时调用。 要了解实际的更改类型，请致电HierarchyEvent.getChangeFlags() 。
        参数
        e - 要处理的事件
        另请参见：
        HierarchyEvent.getChangeFlags()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class InputEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    KeyEvent ， MouseEvent

    public abstract class InputEvent
extends ComponentEvent
    所有组件级输入事件的根事件类。 输入事件在它们发起的源正常处理之前传递给收听者。 这允许侦听器和组件子类“消耗”事件，以便源将不会以其默认方式处理它们。 例如，在Button组件上使用mousePressed事件将阻止Button被激活。
    从以下版本开始：
    1.1
    另请参见：
    KeyEvent ， KeyAdapter ， MouseEvent ， MouseAdapter ， MouseMotionAdapter ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ALT_DOWN_MASK
      Alt键扩展修饰符常数。
      static int ALT_GRAPH_DOWN_MASK
      AltGraph键扩展修饰符常数。
      static int ALT_GRAPH_MASK
      已过时。
      建议使用ALT_GRAPH_DOWN_MASK和getModifiersEx()
      static int ALT_MASK
      已过时。
      建议使用ALT_DOWN_MASK和getModifiersEx()
      static int BUTTON1_DOWN_MASK
      鼠标Button1扩展修饰符常数。
      static int BUTTON1_MASK
      已过时。
      建议使用BUTTON1_DOWN_MASK和getModifiersEx()
      static int BUTTON2_DOWN_MASK
      鼠标Button2扩展修饰符常数。
      static int BUTTON2_MASK
      已过时。
      建议使用BUTTON2_DOWN_MASK和getModifiersEx() 。 请注意，BUTTON2_MASK的值与ALT_MASK相同。
      static int BUTTON3_DOWN_MASK
      鼠标Button3扩展修饰符常数。
      static int BUTTON3_MASK
      已过时。
      建议使用BUTTON3_DOWN_MASK和getModifiersEx() 。 请注意，BUTTON3_MASK与META_MASK具有相同的值。
      static int CTRL_DOWN_MASK
      控制键扩展修改常数。
      static int CTRL_MASK
      已过时。
      建议使用CTRL_DOWN_MASK和getModifiersEx()
      static int META_DOWN_MASK
      Meta键扩展修饰符常数。
      static int META_MASK
      已过时。
      建议使用META_DOWN_MASK和getModifiersEx()
      static int SHIFT_DOWN_MASK
      Shift键扩展修饰符常数。
      static int SHIFT_MASK
      已过时。
      建议使用SHIFT_DOWN_MASK和getModifiersEx()

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void consume​()
      消耗此事件，使其不会以源自源的默认方式处理。
      static int getMaskForButton​(int button)
      获取任何现有鼠标按钮的掩码的方法。
      int getModifiers​()
      已过时。
      建议使用扩展修饰键和getModifiersEx()
      int getModifiersEx​()
      返回此事件的扩展修饰符掩码。
      static String getModifiersExText​(int modifiers)
      返回一个描述扩展修饰符键和鼠标按钮的字符串，例如“Shift”，“Button1”或“Ctrl + Shift”。
      long getWhen​()
      返回此事件发生的时间戳与1970年1月1日UTC之间的毫秒之间的差异。
      boolean isAltDown​()
      返回此事件的Alt修饰符是否关闭。
      boolean isAltGraphDown​()
      返回此事件的AltGraph修饰符是否关闭。
      boolean isConsumed​()
      返回此事件是否已被使用。
      boolean isControlDown​()
      返回此修改器是否关闭此事件。
      boolean isMetaDown​()
      返回Meta修饰符在此事件上是否关闭。
      boolean isShiftDown​()
      返回此事件的Shift修饰符是否关闭。

      • Methods inherited from class java.awt.AWTEvent

        getID, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent, paramString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SHIFT_MASK

        @Deprecated(since="9")
public static final int SHIFT_MASK
        已过时。 建议使用SHIFT_DOWN_MASK和getModifiersEx()
        Shift键修饰符常数。
        另请参见：
        Constant Field Values

      • CTRL_MASK

        @Deprecated(since="9")
public static final int CTRL_MASK
        已过时。 建议使用CTRL_DOWN_MASK和getModifiersEx()
        控制键修饰符常数。
        另请参见：
        Constant Field Values

      • META_MASK

        @Deprecated(since="9")
public static final int META_MASK
        已过时。 建议使用META_DOWN_MASK和getModifiersEx()
        元键修饰符常数。
        另请参见：
        Constant Field Values

      • ALT_MASK

        @Deprecated(since="9")
public static final int ALT_MASK
        已过时。 建议使用ALT_DOWN_MASK和getModifiersEx()
        Alt键修饰符常数。
        另请参见：
        Constant Field Values

      • ALT_GRAPH_MASK

        @Deprecated(since="9")
public static final int ALT_GRAPH_MASK
        已过时。 建议使用ALT_GRAPH_DOWN_MASK和getModifiersEx()
        AltGraph键修饰符常数。
        另请参见：
        Constant Field Values

      • BUTTON1_MASK

        @Deprecated(since="9")
public static final int BUTTON1_MASK
        已过时。 建议使用BUTTON1_DOWN_MASK和getModifiersEx()
        鼠标Button1修饰符常量。
        另请参见：
        Constant Field Values

      • BUTTON2_MASK

        @Deprecated(since="9")
public static final int BUTTON2_MASK
        已过时。 建议使用BUTTON2_DOWN_MASK和getModifiersEx() 。 请注意，BUTTON2_MASK的值与ALT_MASK相同。
        鼠标Button2修饰符常量。
        另请参见：
        Constant Field Values

      • BUTTON3_MASK

        @Deprecated(since="9")
public static final int BUTTON3_MASK
        已过时。 建议使用BUTTON3_DOWN_MASK和getModifiersEx() 。 请注意，BUTTON3_MASK与META_MASK具有相同的值。
        鼠标Button3修饰符常量。
        另请参见：
        Constant Field Values

      • SHIFT_DOWN_MASK

        public static final int SHIFT_DOWN_MASK
        Shift键扩展修饰符常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • CTRL_DOWN_MASK

        public static final int CTRL_DOWN_MASK
        控制键扩展修改常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • META_DOWN_MASK

        public static final int META_DOWN_MASK
        Meta键扩展修饰符常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • ALT_DOWN_MASK

        public static final int ALT_DOWN_MASK
        Alt键扩展修饰符常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • BUTTON1_DOWN_MASK

        public static final int BUTTON1_DOWN_MASK
        鼠标Button1扩展修饰符常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • BUTTON2_DOWN_MASK

        public static final int BUTTON2_DOWN_MASK
        鼠标Button2扩展修饰符常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • BUTTON3_DOWN_MASK

        public static final int BUTTON3_DOWN_MASK
        鼠标Button3扩展修饰符常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • ALT_GRAPH_DOWN_MASK

        public static final int ALT_GRAPH_DOWN_MASK
        AltGraph键扩展修饰符常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getMaskForButton

        public static int getMaskForButton​(int button)
        获取任何现有鼠标按钮的掩码的方法。 返回的面罩可以用于不同的目的。 以下是其中的一些：
        • mousePress(buttons)和mouseRelease(buttons)
        • 作为创建新的MouseEvent实例时的modifiers参数
        • 以查询modifiersEx现有的MouseEvent
        参数
        button - 是一个从1开始的按钮的数字。例如，
          int button = InputEvent.getMaskForButton(1);
        将具有相同的含义
          int button = InputEvent.getMaskForButton(MouseEvent.BUTTON1);
        因为MouseEvent.BUTTON1等于1.如果鼠标有三个启用的按钮（见MouseInfo.getNumberOfButtons() ），那么传递给该方法的左列的值将从右列返回相应的值：
          button    returned mask
    BUTTON1  BUTTON1_DOWN_MASK
    BUTTON2  BUTTON2_DOWN_MASK
    BUTTON3  BUTTON3_DOWN_MASK
        如果鼠标有三个以上的启用按钮，则可以允许更多的值（4,5等）。 这些扩展按钮没有分配的常量。 此方法返回的额外按钮的按钮掩码没有分配的名称，如前三个按钮蒙版。

        该方法具有以下实现限制。 它只返回有限数量按钮的遮罩。 最大数量取决于实现，可能会有所不同。 该限制由鼠标可能假设存在的按钮的相关数量定义，但大于MouseInfo.getNumberOfButtons() 。

        结果
        现有鼠标按钮的面具。
        异常
        IllegalArgumentException - 如果 button小于零或大于为按钮保留的按钮屏蔽的数量
        从以下版本开始：
        1.7
        另请参见：
        MouseInfo.getNumberOfButtons() ，
Toolkit.areExtraMouseButtonsEnabled() ，
getModifiers() ，
MouseEvent.getModifiersEx()

      • isShiftDown

        public boolean isShiftDown​()
        返回此事件的Shift修饰符是否关闭。
        结果
        Shift修饰符是否关闭此事件

      • isControlDown

        public boolean isControlDown​()
        返回此修改器是否关闭此事件。
        结果
        此修改器是否关闭此事件

      • isMetaDown

        public boolean isMetaDown​()
        返回Meta修饰符在此事件上是否关闭。
        结果
        Meta修饰符是否关闭此事件

      • isAltDown

        public boolean isAltDown​()
        返回此事件的Alt修饰符是否关闭。
        结果
        此修改器是否关闭此事件

      • isAltGraphDown

        public boolean isAltGraphDown​()
        返回此事件的AltGraph修饰符是否关闭。
        结果
        AltGraph修饰符是否关闭此事件

      • getWhen

        public long getWhen​()
        返回此事件发生的时间戳与1970年1月1日UTC之间的毫秒之间的差异。
        结果
        1970年1月1日UTC时间戳与午夜之间的毫秒数之间的差异

      • getModifiers

        @Deprecated(since="9")
public int getModifiers​()
        已过时。 建议使用扩展修饰键和getModifiersEx()
        返回此事件的修饰符掩码。
        结果
        此事件的修饰符掩码

      • getModifiersEx

        public int getModifiersEx​()
        返回此事件的扩展修饰符掩码。

        扩展修饰符是以_DOWN_MASK后缀结尾的修饰符，如ALT_DOWN_MASK，BUTTON1_DOWN_MASK等。

        扩展修饰符表示所有模态键的状态，如ALT，CTRL，META和事件发生后的鼠标按钮。

        例如，如果用户按下按钮1跟随按钮2 ，然后以相同的顺序释放它们，则生成以下事件序列：

          MOUSE_PRESSED:  BUTTON1_DOWN_MASK
    MOUSE_PRESSED:  BUTTON1_DOWN_MASK | BUTTON2_DOWN_MASK
    MOUSE_RELEASED: BUTTON2_DOWN_MASK
    MOUSE_CLICKED:  BUTTON2_DOWN_MASK
    MOUSE_RELEASED:
    MOUSE_CLICKED:

        不建议使用==比较此方法的返回值，因为将来可以添加新的修饰符。 例如，检查SHIFT和BUTTON1是否正常，但是CTRL已经起作用的适当方法可以通过以下代码来证明：

          int onmask = SHIFT_DOWN_MASK | BUTTON1_DOWN_MASK;
    int offmask = CTRL_DOWN_MASK;
    if ((event.getModifiersEx() & (onmask | offmask)) == onmask) {
        ...
    }
        即使添加了新的修饰符，上述代码也可以正常工作。
        结果
        此事件的扩展修饰符掩码
        从以下版本开始：
        1.4

      • consume

        public void consume​()
        消耗此事件，使其不会以源自源的默认方式处理。
        重写：
        consume在 AWTEvent

      • isConsumed

        public boolean isConsumed​()
        返回此事件是否已被使用。
        重写：
        isConsumed在 AWTEvent
        结果
        这个事件是否被消耗了
        另请参见：
        consume()

      • getModifiersExText

        public static String getModifiersExText​(int modifiers)
        返回一个描述扩展修饰符键和鼠标按钮的字符串，例如“Shift”，“Button1”或“Ctrl + Shift”。 这些字符串可以通过更改awt.properties文件进行本地化。

        请注意，传递负参数不正确，将返回未指定的字符串。 零参数意味着没有修改器被传递并且将导致返回一个空字符串。

        参数
        modifiers - 描述事件的扩展修饰符键和鼠标按钮的修饰符掩码
        结果
        一个描述扩展修饰键和鼠标按钮的字符串
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputMethodEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class InputMethodEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.InputMethodEvent
  • All Implemented Interfaces:
    Serializable

    public class InputMethodEvent
extends AWTEvent
    输入法事件包含使用输入法组合的文本信息。 每当文本更改时，输入法都会发送一个事件。 如果当前正在使用输入法的文本组件是活动客户端，则会将事件分派到该组件。 否则，它将被分派到单独的组合窗口。

    输入法事件中包含的文本由两部分组成：提交文本和合成文本。 任一部分都可能是空的。 两个部分一起替代以前事件中发送的任何未提交的合成文本，或当前选择的提交文本。 提交的文本应该被集成到文本组件的持久性数据中，不会再发送。 组合的文本可能会重复发送，并进行更改以反映用户的编辑操作。 提交的文本总是在组合文本之前。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CARET_POSITION_CHANGED
      指示输入法文本中更改的插入点的事件类型。
      static int INPUT_METHOD_FIRST
      标记输入法事件ids范围的第一个整数ID。
      static int INPUT_METHOD_LAST
      标记输入法事件ids范围的最后一个整数ID。
      static int INPUT_METHOD_TEXT_CHANGED
      事件类型指示改变的输入法文本。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputMethodEvent​(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定的源组件，类型，时间，文本，插入符和 InputMethodEvent 。
      InputMethodEvent​(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
      构造一个具有指定的源组件，类型，插入符和 InputMethodEvent 。
      InputMethodEvent​(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造一个具有指定的源组件，类型，文本，插入符和 InputMethodEvent 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void consume​()
      消耗此事件，使其不会以源自源的默认方式处理。
      TextHitInfo getCaret​()
      得到插入符号。
      int getCommittedCharacterCount​()
      获取文本中提交的字符数。
      AttributedCharacterIterator getText​()
      获取组合的承诺和合成文本。
      TextHitInfo getVisiblePosition​()
      获取最显着的位置。
      long getWhen​()
      返回发生此事件的时间戳。
      boolean isConsumed​()
      返回此事件是否已被使用。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        getID, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INPUT_METHOD_FIRST

        @Native
public static final int INPUT_METHOD_FIRST
        标记输入法事件ids范围的第一个整数ID。
        另请参见：
        Constant Field Values

      • INPUT_METHOD_TEXT_CHANGED

        @Native
public static final int INPUT_METHOD_TEXT_CHANGED
        事件类型指示改变的输入法文本。 该事件在处理输入时由输入法生成。
        另请参见：
        Constant Field Values

      • CARET_POSITION_CHANGED

        @Native
public static final int CARET_POSITION_CHANGED
        指示输入法文本中更改的插入点的事件类型。 如果只有插入符号改变，则处理输入时，此事件由输入法生成。
        另请参见：
        Constant Field Values

      • INPUT_METHOD_LAST

        @Native
public static final int INPUT_METHOD_LAST
        标记输入法事件ids范围的最后一个整数ID。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • InputMethodEvent

        public InputMethodEvent​(Component source,
                        int id,
                        long when,
                        AttributedCharacterIterator text,
                        int committedCharacterCount,
                        TextHitInfo caret,
                        TextHitInfo visiblePosition)
        构造具有指定的源组件，类型，时间，文本，插入符和InputMethodEvent 。

        插入符号和visiblePosition的偏移量与当前组合文本相关; 也就是说，内撰写文本text ，如果这是一个INPUT_METHOD_TEXT_CHANGED情况下，内撰写文本text前述的INPUT_METHOD_TEXT_CHANGED事件否则。

        请注意，传递无效的id导致未指定的行为。 此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 事件发生的对象
        id - 事件类型
        when - 指定事件发生时间的长整数
        text - 组合承诺和合成文本，承诺文本第一; 必须是null时事件类型是CARET_POSITION_CHANGED ; 可能是null为INPUT_METHOD_TEXT_CHANGED如果没有提交或撰写文本
        committedCharacterCount - 文本中提交的字符数
        caret - 插入符号（又称插入点）; null如果在当前组合文本中没有插入符号
        visiblePosition - 最重要的可见位置; null如果没有建议在当前组合文本中的可见位置
        异常
        IllegalArgumentException - 如果id不在范围INPUT_METHOD_FIRST .. INPUT_METHOD_LAST ;
或者如果id是CARET_POSITION_CHANGED和text不是null ;
或者如果committedCharacterCount不在范围0 .. (text.getEndIndex() - text.getBeginIndex())
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4

      • InputMethodEvent

        public InputMethodEvent​(Component source,
                        int id,
                        AttributedCharacterIterator text,
                        int committedCharacterCount,
                        TextHitInfo caret,
                        TextHitInfo visiblePosition)
        构造具有指定的源组件，类型，文本，插入符号和InputMethodEvent 。

        插入符号和visiblePosition的偏移量与当前组合文本相关; 也就是说，内撰写文本text ，如果这是一个INPUT_METHOD_TEXT_CHANGED情况下，内撰写文本text前述的INPUT_METHOD_TEXT_CHANGED事件否则。 此事件的时间戳通过调用EventQueue.getMostRecentEventTime()进行初始化。

        请注意，传递无效的id导致未指定的行为。 此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 事件发生的对象
        id - 事件类型
        text - 组合承诺和合成文本，承诺文本第一; 必须是null时事件类型是CARET_POSITION_CHANGED ; 如果没有提交或撰写文本，则可能是null的INPUT_METHOD_TEXT_CHANGED
        committedCharacterCount - 文字中提交的字符数
        caret - 插入符号（也称插入点）; null如果在当前组合文本中没有插入符号
        visiblePosition - 最visiblePosition着的位置; null如果没有建议在当前组合文本中的可见位置
        异常
        IllegalArgumentException - 如果id不在范围INPUT_METHOD_FIRST .. INPUT_METHOD_LAST ;
或者如果id是CARET_POSITION_CHANGED和text不是null ;
或者如果committedCharacterCount不在范围0 .. (text.getEndIndex() - text.getBeginIndex())
        IllegalArgumentException - 如果 source为空

      • InputMethodEvent

        public InputMethodEvent​(Component source,
                        int id,
                        TextHitInfo caret,
                        TextHitInfo visiblePosition)
        构造具有指定的源组件，类型，插入符号和InputMethodEvent 。 文本设置为null ， committedCharacterCount为0。

        caret和visiblePosition的偏移量相对于当前组合文本; 也就是说，如果事件被构造为CARET_POSITION_CHANGED事件，则前面的INPUT_METHOD_TEXT_CHANGED事件的text中的组合文本。 对于没有文字的INPUT_METHOD_TEXT_CHANGED事件， caret和visiblePosition必须为null 。 通过调用EventQueue.getMostRecentEventTime()初始化此事件的时间戳。

        请注意，传递无效的id导致未指定的行为。 此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 事件发生的对象
        id - 事件类型
        caret - 插入符号（也称插入点）; null如果当前组合文本中没有插入符号
        visiblePosition - 最visiblePosition着的位置; null如果没有建议在当前组合文本中的可见位置
        异常
        IllegalArgumentException - 如果 id不在范围 INPUT_METHOD_FIRST .. INPUT_METHOD_LAST
        IllegalArgumentException - 如果 source为空

    • 方法详细信息

      • getText

        public AttributedCharacterIterator getText​()
        获取组合的承诺和合成文本。 从索引0到索引getCommittedCharacterCount() - 1是提交文本，其余的字符都是文本。
        结果
        文本。 CARET_POSITION_CHANGED始终为空; 如果没有组合或提交的文本，则INPUT_METHOD_TEXT_CHANGED可能为null。

      • getCommittedCharacterCount

        public int getCommittedCharacterCount​()
        获取文本中提交的字符数。
        结果
        文字中承诺的字符数

      • getCaret

        public TextHitInfo getCaret​()
        得到插入符号。

        插入符的偏移量与当前组合文本相对应; 也就是getText（）中的组合文本，如果这是一个INPUT_METHOD_TEXT_CHANGED事件，则前面的INPUT_METHOD_TEXT_CHANGED事件的getText（）中的合成文本不然。

        结果
        插入符号（也称插入点）。 如果当前组合文本中没有插入符号，则为空。

      • getVisiblePosition

        public TextHitInfo getVisiblePosition​()
        获取最显着的位置。

        可见位置的偏移量相对于当前组合文本; 也就是getText（）中的组合文本，如果这是一个INPUT_METHOD_TEXT_CHANGED事件，则前面的INPUT_METHOD_TEXT_CHANGED事件的getText（）中的合成文本不然。

        结果
        最显着的位置。 如果在当前合成文本中没有可视位置的建议，则为空。

      • consume

        public void consume​()
        消耗此事件，使其不会以源自源的默认方式处理。
        重写：
        consume在 AWTEvent

      • isConsumed

        public boolean isConsumed​()
        返回此事件是否已被使用。
        重写：
        isConsumed在 AWTEvent
        结果
        true如果此事件已被消耗; 否则false
        另请参见：
        consume()

      • getWhen

        public long getWhen​()
        返回发生此事件的时间戳。
        结果
        这个事件的时间戳
        从以下版本开始：
        1.4

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。 它包含文本形式的事件ID，由“+”分隔的提交和合成文本的字符，提交的字符数，插入符号和可见位置。
        重写：
        paramString在 AWTEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputMethodListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface InputMethodListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster

    public interface InputMethodListener
extends EventListener
    用于接收输入法事件的侦听器接口。 文本编辑组件必须安装输入法事件侦听器才能使用输入法。

    文本编辑组件还必须提供一个InputMethodRequests的实例。

    从以下版本开始：
    1.2
    另请参见：
    InputMethodEvent ， InputMethodRequests

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void caretPositionChanged​(InputMethodEvent event)
      当合成文本内的插入符已更改时调用。
      void inputMethodTextChanged​(InputMethodEvent event)
      当通过输入法输入的文本已更改时调用。

    • 方法详细信息

      • inputMethodTextChanged

        void inputMethodTextChanged​(InputMethodEvent event)
        当通过输入法输入的文本已更改时调用。
        参数
        event - 要处理的事件

      • caretPositionChanged

        void caretPositionChanged​(InputMethodEvent event)
        当合成文本内的插入符已更改时调用。
        参数
        event - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvocationEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class InvocationEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.InvocationEvent
  • All Implemented Interfaces:
    ActiveEvent ， Serializable

    public class InvocationEvent
extends AWTEvent
implements ActiveEvent
    在AWT事件调度程序线程调度时，在Runnable执行run()方法的事件。 该类可以用作ActiveEvent的参考实现，而不是声明一个新类并定义dispatch() 。

    该类的EventQueue通过拨打invokeLater和invokeAndWait 。 客户端代码可以使用这个事实来编写invokeLater和invokeAndWait替换函数，而不需要在任何AWTEventListener对象中编写特殊情况代码。

    任何特定InvocationEvent实例的id参数不在从INVOCATION_FIRST到INVOCATION_LAST的范围内，将会引起未指定的行为。

    从以下版本开始：
    1.2
    另请参见：
    ActiveEvent ， EventQueue.invokeLater(java.lang.Runnable) ， EventQueue.invokeAndWait(java.lang.Runnable) ， AWTEventListener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected boolean catchExceptions
      如果dispatch（）捕获Throwable并将其存储在异常实例变量中，则设置为true。
      static int INVOCATION_DEFAULT
      所有InvocationEvents的默认ID。
      static int INVOCATION_FIRST
      标记调用事件ID的范围的第一个整数ID。
      static int INVOCATION_LAST
      标记调用事件ID的范围的最后一个整数ID。
      protected Object notifier
      在Runnable.run（）方法返回或抛出异常之后或事件处理完毕后，将立即调用其notifyAll（）方法的（可能为空）的对象。
      protected Runnable runnable
      Runnable的run（）方法将被调用。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected InvocationEvent​(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables)
      构造一个 InvocationEvent具有指定源和ID将执行可运行的 run时调度方法。
        InvocationEvent​(Object source, Runnable runnable)
      构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。
        InvocationEvent​(Object source, Runnable runnable, Object notifier, boolean catchThrowables)
      构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。
        InvocationEvent​(Object source, Runnable runnable, Runnable listener, boolean catchThrowables)
      构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispatch​()
      执行Runnable的 run()方法，并在 run()返回或引发异常时通知通知程序（如果有）。
      异常 getException​()
      返回在执行Runnable的 run()方法时捕获的任何异常。
      Throwable getThrowable​()
      返回在执行Runnable的 run()方法时捕获的任何Throwable。
      long getWhen​()
      返回发生此事件的时间戳。
      boolean isDispatched​()
      返回 true如果事件被分派或者在发送任何异常被抛出， false否则。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INVOCATION_FIRST

        public static final int INVOCATION_FIRST
        标记调用事件ID的范围的第一个整数ID。
        另请参见：
        Constant Field Values

      • INVOCATION_DEFAULT

        public static final int INVOCATION_DEFAULT
        所有InvocationEvents的默认ID。
        另请参见：
        Constant Field Values

      • INVOCATION_LAST

        public static final int INVOCATION_LAST
        标记调用事件ID的范围的最后一个整数ID。
        另请参见：
        Constant Field Values

      • runnable

        protected Runnable runnable
        Runnable的run（）方法将被调用。

      • notifier

        protected volatile Object notifier
        在Runnable.run（）方法返回或抛出异常之后或事件处理完毕后，将立即调用其notifyAll（）方法的（可能为空）的对象。
        另请参见：
        isDispatched()

      • catchExceptions

        protected boolean catchExceptions
        如果dispatch（）捕获Throwable并将其存储在异常实例变量中，则设置为true。 如果为false，则Throwables将传播到EventDispatchThread的调度循环。

    • 构造方法详细信息

      • InvocationEvent

        public InvocationEvent​(Object source,
                       Runnable runnable)
        构造一个InvocationEvent与将执行可运行的指定的源run时调度方法。

        这是一个方便的构造函数。 调用表单InvocationEvent(source, runnable)行为方式与调用InvocationEvent(source, runnable, null, false)的方式完全相同 。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Object
        runnable -该 Runnable ，其 run方法将被执行
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ， InvocationEvent(Object, Runnable, Object, boolean)

      • InvocationEvent

        public InvocationEvent​(Object source,
                       Runnable runnable,
                       Object notifier,
                       boolean catchThrowables)
        构造一个InvocationEvent与将执行可运行的指定的源run时调度方法。 如果通知程序null notifyAll()将在run已经返回或抛出异常后立即调用。

        调用表单InvocationEvent(source, runnable, notifier, catchThrowables)行为方式与调用InvocationEvent(source, InvocationEvent.INVOCATION_DEFAULT, runnable, notifier, catchThrowables)的方式完全相同 。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Object
        runnable -该 Runnable ，其 run方法将被执行
        notifier - Object其 notifyAll方法将在 Runnable.run后 Runnable.run已返回或抛出异常或事件处理完毕
        catchThrowables - 指定在执行 Runnable的 run方法时是否 dispatch应该捕获Throwable，或者应该将这些Throwables传播到EventDispatchThread的调度循环
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ， InvocationEvent(Object, int, Runnable, Object, boolean)

      • InvocationEvent

        public InvocationEvent​(Object source,
                       Runnable runnable,
                       Runnable listener,
                       boolean catchThrowables)
        构造一个InvocationEvent与将执行可运行的指定的源run时调度方法。 如果听者不null ， listener.run()将被调用后立即run又回来了，抛出一个异常，或者被设置在事件。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 起源于事件的 Object
        runnable -该 Runnable ，其 run方法将被执行
        listener - Runnable的 run()方法将在 InvocationEvent被调用或处理的 run()方法
        catchThrowables - 指定在执行 Runnable的 run方法时是否 dispatch应该捕获Throwable，或者应该将这些Throwables传播到EventDispatchThread的调度循环
        异常
        IllegalArgumentException - 如果 source为空

      • InvocationEvent

        protected InvocationEvent​(Object source,
                          int id,
                          Runnable runnable,
                          Object notifier,
                          boolean catchThrowables)
        构造一个InvocationEvent具有指定源和ID将执行可运行的run时调度方法。 如果通知是非null ， notifyAll将它称为后立即run返回或抛出异常。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 起始事件的 Object
        id - 表示事件类型的整数。 有关允许值的信息，请参阅InvocationEvent的类说明
        runnable -该 Runnable ，其 run方法将被执行
        notifier - Object的 notifyAll方法将在 Runnable.run之后被调用返回或抛出异常或事件被处理之后
        catchThrowables - 指定在执行 Runnable的 run方法时是否 dispatch应该捕获Throwable，或者应该将这些Throwables传播到EventDispatchThread的调度循环
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ， AWTEvent.getID()

    • 方法详细信息

      • dispatch

        public void dispatch​()
        执行Runnable的 run()方法，并在 run()已返回或抛出异常时通知通知程序（如果有）。
        Specified by:
        dispatch在接口 ActiveEvent
        另请参见：
        isDispatched()

      • getException

        public 异常 getException​()
        返回在执行Runnable的 run()方法时捕获的任何异常。
        结果
        引用异常，如果被抛出; 如果没有抛出异常，或者如果此InvocationEvent没有捕获异常，则为null

      • getThrowable

        public Throwable getThrowable​()
        返回在执行Runnable的 run()方法时捕获的任何Throwable。
        结果
        引用Throwable如果被抛出; 如果没有抛出Throwable，或者如果此InvocationEvent不捕获Throwables，则为null
        从以下版本开始：
        1.5

      • getWhen

        public long getWhen​()
        返回发生此事件的时间戳。
        结果
        这个事件的时间戳
        从以下版本开始：
        1.4

      • isDispatched

        public boolean isDispatched​()
        返回true如果事件被分派或者在发送任何异常被抛出， false否则。 该方法应该被调用notifier.wait()方法的等待线程调用。 由于虚假唤醒是可能的（如Object.wait()中所述 ），该方法应该在等待循环中使用，以确保事件被分派：
          while (!event.isDispatched()) {
         notifier.wait();
     }
        如果等待线程在不调度事件的情况下唤醒，则isDispatched()方法返回false ，并且while循环再次执行，从而导致唤醒线程恢复到等待模式。

        如果notifier.notifyAll()发生在等待线程进入notifier.wait()方法之前， while循环确保等待线程不会进入notifier.wait()方法。 否则，不能保证等待线程从等待中醒来。

        结果
        true如果事件已经调度，或者任何异常在调度时抛出， false否则
        从以下版本开始：
        1.7
        另请参见：
        dispatch() ， notifier ， catchExceptions

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 AWTEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ItemEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class ItemEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ItemEvent
  • All Implemented Interfaces:
    Serializable

    public class ItemEvent
extends AWTEvent
    表示选择或取消选择项目的语义事件。 当用户选择或取消选择项目时，此高级事件由ItemSelectable对象（例如List）生成。 事件被传递给每个注册使用组件的addItemListener方法接收此类事件的每个ItemListener对象。

    当事件发生时，实现ItemListener接口的对象获得此ItemEvent 。 监听器免除处理单个鼠标移动和鼠标点击的细节，并且可以代替处理“有意义的”（语义）事件，如“选择项目”或“取消选择项目”。

    如果任何特定的ItemEvent实例的id参数不在从ITEM_FIRST到ITEM_LAST的范围内，将会导致未指定的行为。

    任何ItemEvent实例的stateChange都需要以下值之一：

    • ItemEvent.SELECTED
    • ItemEvent.DESELECTED
    分配与上述不同的值将导致未指定的行为。
    从以下版本开始：
    1.1
    另请参见：
    ItemSelectable ， ItemListener ， Tutorial: Writing an Item Listener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DESELECTED
      该状态变化值表示已选择的项目被取消选择。
      static int ITEM_FIRST
      用于项目事件的ids范围中的第一个数字。
      static int ITEM_LAST
      用于项目事件的ID的范围中的最后一个数字。
      static int ITEM_STATE_CHANGED
      此事件id表示项目状态已更改。
      static int SELECTED
      此状态变化值表示已选择项目。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      ItemEvent​(ItemSelectable source, int id, Object item, int stateChange)
      构造一个 ItemEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getItem​()
      返回受事件影响的项目。
      ItemSelectable getItemSelectable​()
      返回事件的发起者。
      int getStateChange​()
      返回状态更改的类型（选择或取消选择）。
      String paramString​()
      返回标识此项事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ITEM_FIRST

        public static final int ITEM_FIRST
        用于项目事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • ITEM_LAST

        public static final int ITEM_LAST
        用于项目事件的ID的范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • ITEM_STATE_CHANGED

        public static final int ITEM_STATE_CHANGED
        此事件id表示项目状态已更改。
        另请参见：
        Constant Field Values

      • SELECTED

        public static final int SELECTED
        此状态变化值表示已选择项目。
        另请参见：
        Constant Field Values

      • DESELECTED

        public static final int DESELECTED
        该状态变化值表示已选择的项目被取消选择。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ItemEvent

        public ItemEvent​(ItemSelectable source,
                 int id,
                 Object item,
                 int stateChange)
        构造一个ItemEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 ItemSelectable对象
        id - 标识事件类型的整数。 有关允许值的信息，请参阅ItemEvent的类说明
        item - 对象 - 受事件影响的项目
        stateChange - 一个整数，指示项目是否被选中或取消选择。 有关允许值的信息，请参阅ItemEvent的类描述
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        getItemSelectable() ，
AWTEvent.getID() ，
getStateChange()

    • 方法详细信息

      • getItemSelectable

        public ItemSelectable getItemSelectable​()
        返回事件的发起者。
        结果
        发起事件的ItemSelectable对象。

      • getItem

        public Object getItem​()
        返回受事件影响的项目。
        结果
        受事件影响的项目（对象）

      • getStateChange

        public int getStateChange​()
        返回状态更改的类型（选择或取消选择）。
        结果
        一个整数，表示该项目是被选中还是被取消选择
        另请参见：
        SELECTED ， DESELECTED

      • paramString

        public String paramString​()
        返回标识此项事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 AWTEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ItemListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface ItemListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicComboBoxUI.ItemHandler ， BasicComboPopup.ItemHandler ， Checkbox.AccessibleAWTCheckbox ， DefaultCellEditor.EditorDelegate ， JCheckBox.AccessibleJCheckBox ， JRadioButton.AccessibleJRadioButton ， JToggleButton.AccessibleJToggleButton ， List.AccessibleAWTList

    public interface ItemListener
extends EventListener
    用于接收项目事件的侦听器接口。 对处理项目事件感兴趣的类实现此接口。 然后使用该组件的addItemListener方法将使用该类创建的对象注册到组件。 当项目选择事件发生时，调用侦听器对象的itemStateChanged方法。
    从以下版本开始：
    1.1
    另请参见：
    ItemSelectable ， ItemEvent ， Tutorial: Writing an Item Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void itemStateChanged​(ItemEvent e)
      当用户选择或取消选择项目时调用。

    • 方法详细信息

      • itemStateChanged

        void itemStateChanged​(ItemEvent e)
        当用户选择或取消选择项目时调用。 为此方法编写的代码执行在选择（或取消选择）项目时需要进行的操作。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.event (Java SE 9 & JDK 9 )

java.awt.event

Interfaces

  • ActionListener
  • AdjustmentListener
  • AWTEventListener
  • ComponentListener
  • ContainerListener
  • FocusListener
  • HierarchyBoundsListener
  • HierarchyListener
  • InputMethodListener
  • ItemListener
  • KeyListener
  • MouseListener
  • MouseMotionListener
  • MouseWheelListener
  • TextListener
  • WindowFocusListener
  • WindowListener
  • WindowStateListener

Classes

  • ActionEvent
  • AdjustmentEvent
  • AWTEventListenerProxy
  • ComponentAdapter
  • ComponentEvent
  • ContainerAdapter
  • ContainerEvent
  • FocusAdapter
  • FocusEvent
  • HierarchyBoundsAdapter
  • HierarchyEvent
  • InputEvent
  • InputMethodEvent
  • InvocationEvent
  • ItemEvent
  • KeyAdapter
  • KeyEvent
  • MouseAdapter
  • MouseEvent
  • MouseMotionAdapter
  • MouseWheelEvent
  • PaintEvent
  • TextEvent
  • WindowAdapter
  • WindowEvent

Enums

  • FocusEvent.Cause


java.awt.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.event

提供用于处理AWT组件触发的不同类型事件的接口和类。 有关AWT事件模型的详细信息，请参阅java.awt.AWTEvent课程。 活动由事件来源触发。 事件侦听器向事件源注册以接收关于特定类型的事件的通知。 此包定义事件和事件侦听器以及事件侦听器适配器，这些方便类使事务侦听器的写入过程更为简单。
从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    ActionListener
    用于接收动作事件的侦听器界面。
    AdjustmentListener
    用于接收调整事件的侦听器接口。
    AWTEventListener
    用于接收分派到作为Component或MenuComponent或其子类的实例的对象的事件的侦听器接口。
    ComponentListener
    用于接收组件事件的侦听器接口。
    ContainerListener
    用于接收容器事件的侦听器接口。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    HierarchyBoundsListener
    用于接收祖先移动和调整大小的事件的侦听器接口。
    HierarchyListener
    用于接收层次结构的侦听器界面更改事件。
    InputMethodListener
    用于接收输入法事件的侦听器接口。
    ItemListener
    用于接收项目事件的侦听器接口。
    KeyListener
    用于接收键盘事件（按键）的侦听器界面。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
    TextListener
    用于接收文本事件的侦听器界面。
    WindowFocusListener
    收听界面接收 WindowEvents ，其中包括 WINDOW_GAINED_FOCUS和 WINDOW_LOST_FOCUS事件。
    WindowListener
    用于接收窗口事件的侦听器界面。
    WindowStateListener
    用于接收窗口状态事件的侦听器接口。
  • 类摘要
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    AdjustmentEvent
    可调整对象发出的调整事件，如Scrollbar和ScrollPane 。
    AWTEventListenerProxy
    一个扩展 EventListenerProxy专门用于为特定事件掩码添加一个 AWTEventListener的类。
    ComponentAdapter
    用于接收组件事件的抽象适配器类。
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    ContainerAdapter
    用于接收容器事件的抽象适配器类。
    ContainerEvent
    低级别事件，表示容器的内容因添加或删除组件而发生更改。
    FocusAdapter
    用于接收键盘焦点事件的抽象适配器类。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    HierarchyBoundsAdapter
    用于接收祖先移动和调整大小的事件的抽象适配器类。
    HierarchyEvent
    表示 Component所属的 Component层次结构发生变化的事件。
    InputEvent
    所有组件级输入事件的根事件类。
    InputMethodEvent
    输入法事件包含使用输入法组合的文本信息。
    InvocationEvent
    在由AWT事件调度程序线程调度时，在 Runnable执行 run()方法的事件。
    ItemEvent
    表示选择或取消选择项目的语义事件。
    KeyAdapter
    用于接收键盘事件的抽象适配器类。
    KeyEvent
    指示组件中发生击键的事件。
    MouseAdapter
    用于接收鼠标事件的抽象适配器类。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseMotionAdapter
    用于接收鼠标运动事件的抽象适配器类。
    MouseWheelEvent
    指示鼠标轮在组件中旋转的事件。
    PaintEvent
    组件级paint事件。
    TextEvent
    表示对象的文本改变的语义事件。
    WindowAdapter
    用于接收窗口事件的抽象适配器类。
    WindowEvent
    指示窗口已更改其状态的低级别事件。
  • 枚举摘要
    Enum 描述
    FocusEvent.Cause
    这个枚举代表了一个 FocusEvent的原因 - 它的发生原因。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.event Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.event

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
    • java.awt.event.ContainerAdapter (implements java.awt.event.ContainerListener)
    • java.util.EventListenerProxy<T> (implements java.util.EventListener)
      • java.awt.event.AWTEventListenerProxy (implements java.awt.event.AWTEventListener)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
        • java.awt.event.ActionEvent
        • java.awt.event.AdjustmentEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.ContainerEvent
          • java.awt.event.FocusEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
            • java.awt.event.MouseEvent
              • java.awt.event.MouseWheelEvent
          • java.awt.event.PaintEvent
          • java.awt.event.WindowEvent
        • java.awt.event.HierarchyEvent
        • java.awt.event.InputMethodEvent
        • java.awt.event.InvocationEvent (implements java.awt.ActiveEvent)
        • java.awt.event.ItemEvent
        • java.awt.event.TextEvent
    • java.awt.event.FocusAdapter (implements java.awt.event.FocusListener)
    • java.awt.event.HierarchyBoundsAdapter (implements java.awt.event.HierarchyBoundsListener)
    • java.awt.event.KeyAdapter (implements java.awt.event.KeyListener)
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
    • java.awt.event.MouseMotionAdapter (implements java.awt.event.MouseMotionListener)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)

Interface Hierarchy

  • java.util.EventListener
    • java.awt.event.ActionListener
    • java.awt.event.AdjustmentListener
    • java.awt.event.AWTEventListener
    • java.awt.event.ComponentListener
    • java.awt.event.ContainerListener
    • java.awt.event.FocusListener
    • java.awt.event.HierarchyBoundsListener
    • java.awt.event.HierarchyListener
    • java.awt.event.InputMethodListener
    • java.awt.event.ItemListener
    • java.awt.event.KeyListener
    • java.awt.event.MouseListener
    • java.awt.event.MouseMotionListener
    • java.awt.event.MouseWheelListener
    • java.awt.event.TextListener
    • java.awt.event.WindowFocusListener
    • java.awt.event.WindowListener
    • java.awt.event.WindowStateListener

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.event.FocusEvent.Cause
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


KeyAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class KeyAdapter

  • java.lang.Object
    • java.awt.event.KeyAdapter
  • All Implemented Interfaces:
    KeyListener ， EventListener
    已知直接子类：
    BasicComboBoxUI.KeyHandler ， BasicComboPopup.InvocationKeyHandler ， BasicTreeUI.KeyHandler

    public abstract class KeyAdapter
extends Object
implements KeyListener
    用于接收键盘事件的抽象适配器类。 这个类中的方法是空的。 此类作为创建侦听器对象的方便而存在。

    扩展此类以创建一个KeyEvent监听器并覆盖感兴趣的事件的方法。 （如果您实现了KeyListener接口，则必须定义其中的所有方法，这个抽象类为它们定义了空方法，因此只需要定义关心事件的方法。）

    使用扩展类创建侦听器对象，然后使用组件的addKeyListener方法将其注册到组件。 当一个键被按下，释放或键入，在监听器对象中的相关方法被调用，并KeyEvent传递给它。

    从以下版本开始：
    1.1
    另请参见：
    KeyEvent ， KeyListener ， Tutorial: Writing a Key Listener

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void keyPressed​(KeyEvent e)
      按下键时调用。
      void keyReleased​(KeyEvent e)
      当键已被释放时调用。
      void keyTyped​(KeyEvent e)
      键入键时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyAdapter

        public KeyAdapter​()

    • 方法详细信息

      • keyTyped

        public void keyTyped​(KeyEvent e)
        键入键时调用。 当按下按键时，会发生此事件。
        Specified by:
        keyTyped在接口 KeyListener
        参数
        e - 要处理的事件

      • keyPressed

        public void keyPressed​(KeyEvent e)
        按下键时调用。
        Specified by:
        keyPressed在接口 KeyListener
        参数
        e - 要处理的事件

      • keyReleased

        public void keyReleased​(KeyEvent e)
        当键已被释放时调用。
        Specified by:
        keyReleased在接口 KeyListener
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


KeyEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class KeyEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    MenuKeyEvent

    public class KeyEvent
extends InputEvent
    指示组件中发生击键的事件。

    当按下，释放或键入键时，此低级别事件由组件对象（例如文本字段）生成。 该事件传递给每个KeyListener或KeyAdapter对象，其注册使用组件的addKeyListener方法接收此类事件。 （ KeyAdapter对象实现KeyListener接口。）每个这样的侦听器对象在事件发生时得到这个KeyEvent 。

    “键型”事件较高级，通常不依赖于平台或键盘布局。 它们在输入Unicode字符时生成，并且是查找字符输入的首选方式。 在最简单的情况下，键型事件由一个按键（例如'a'）产生。 然而，通常，通过一系列按键（例如，“shift”+“a”）产生字符，并且从按键事件到键类型事件的映射可以是多对一或多对多。 主要版本通常不需要生成键入类型的事件，但有些情况下键盘事件不会生成，直到键被释放（例如，通过Windows中的Alt-Numpad方法输入ASCII序列）。 不生成不产生Unicode字符的键（例如，操作键，修饰键等）的键类型事件。

    getKeyChar方法总是返回一个有效的Unicode字符或CHAR_UNDEFINED。 字符输入由KEY_TYPED事件报告：KEY_PRESSED和KEY_RELEASED事件不一定与字符输入相关联。 因此，getKeyChar方法的结果保证仅对KEY_TYPED事件有意义。

    对于按键和键释放事件，getKeyCode方法返回事件的keyCode。 对于键类型事件，getKeyCode方法总是返回VK_UNDEFINED 。 getExtendedKeyCode方法也可以与许多国际键盘布局一起使用。

    “按键”和“按键释放”事件较低级别，取决于平台和键盘布局。 它们是按键或释放键生成的，是找出不产生字符输入的键的唯一方法（例如，操作键，修改键等）。 按下或释放的键由getKeyCode和getExtendedKeyCode方法指示，返回虚拟键码。

    虚拟键码用于报告已按下哪个键盘键，而不是由一个或多个按键组合（例如来自shift和“a”的“A”）产生的字符。

    例如，按Shift键将导致带有VK_SHIFT keyCode的KEY_PRESSED事件，而按'a'键将导致VK_A keyCode。 在“a”键被释放后，KEY_RELEASED事件将被触发VK_A。 另外，生成keyChar值为“A”的KEY_TYPED事件。

    按下并释放键盘上的一个键可以产生以下关键事件（按顺序）：

      KEY_PRESSED
    KEY_TYPED (is only generated if a valid Unicode character could be generated.)
    KEY_RELEASED
    但是在某些情况下（例如，自动重复或输入法被激活），顺序可能不同（和平台依赖）。

    笔记：

    • 不会导致Unicode字符的键组合（例如F1和HELP键等动作键）不生成KEY_TYPED事件。
    • 并不是所有的键盘或系统都能够生成所有虚拟键代码。 在Java中没有尝试人为地生成这些密钥。
    • 虚拟键代码不能识别物理键：它们取决于平台和键盘布局。 例如，使用美国键盘布局时生成VK_Q的键将在使用法语键盘布局时生成VK_A。
    • 使用美国键盘布局时生成VK_Q的关键字也会为俄语或希伯来语布局生成唯一的代码。 这些和许多其他代码在各种布局中没有一个VK_常数。 这些代码可以通过使用getExtendedKeyCode获得，并且在使用VK_常数时使用。
    • 并不是所有的字符都有与它们相关联的键码。 例如，问号没有键码，因为它没有出现在主图层上的键盘。
    • 为了支持独立于平台的操作键处理，Java平台使用一些额外的虚拟键常量来为功能解释虚拟键代码和修饰符而必须被识别的功能。 例如，对于日语Windows键盘，使用ALT修饰符返回VK_ALL_CANDIDATES而不是VK_CONVERT。
    • 按照Focus Specification中的规定，默认情况下将重点事件调度到焦点所有者。

    警告：除了由Java语言（VK_ENTER，VK_BACK_SPACE和VK_TAB）定义的那些键外，不要依赖于VK_常量的值。 平台管家保留根据需要更改这些值的权利，以适应未来更广泛的键盘。

    如果任何特定KeyEvent实例的id参数不在从KEY_FIRST到KEY_LAST的范围内，将会导致未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    KeyAdapter ， KeyListener ， Tutorial: Writing a Key Listener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field | 描述
      static char CHAR_UNDEFINED
      KEY_PRESSED和KEY_RELEASED事件不映射到一个有效的Unicode字符使用它作为keyChar值。
      static int KEY_FIRST
      用于关键事件的ids范围中的第一个数字。
      static int KEY_LAST
      用于关键事件的ids范围中的最后一个数字。
      static int KEY_LOCATION_LEFT
      指示按下或释放的键位于左键位置（该键有多个可能位置）的常数。
      static int KEY_LOCATION_NUMPAD
      指示键数据小键盘上的密钥事件或与数字小键盘对应的虚拟键的常数。
      static int KEY_LOCATION_RIGHT
      一个常数表示按下或释放的键位于正确的键位置（该键有多个可能的位置）。
      static int KEY_LOCATION_STANDARD
      指示按键或释放的键不被区分为键的左或右版本，并且不起源于数字键盘（或不是源自与数字键盘对应的虚拟键）。
      static int KEY_LOCATION_UNKNOWN
      一个常量，表示keyLocation不确定或不相关。
      static int KEY_PRESSED
      “按键”事件。
      static int KEY_RELEASED
      “关键发布”事件。
      static int KEY_TYPED
      “键入”事件。
      static int VK_0
      常数为“0”键。
      static int VK_1
      常数为“1”键。
      static int VK_2
      常数为“2”键。
      static int VK_3
      常数为“3”键。
      static int VK_4
      常数为“4”键。
      static int VK_5
      常数为“5”键。
      static int VK_6
      常数为“6”键。
      static int VK_7
      常数为“7”键。
      static int VK_8
      常数为“8”键。
      static int VK_9
      常数为“9”键。
      static int VK_A
      常数为“A”键。
      static int VK_ACCEPT
      接受或提交功能键的常数。
      static int VK_ADD
      常数为数字键添加键。
      static int | VK_AGAIN
      static int VK_ALL_CANDIDATES
      所有候选人的常数功能键。
      static int VK_ALPHANUMERIC
      字母数字功能键的常数。
      static int VK_ALT
      ALT虚拟键的常数。
      static int VK_ALT_GRAPH
      AltGraph功能键的常数。
      static int | VK_AMPERSAND
      static int | VK_ASTERISK
      static int VK_AT
      “@”键的常数。
      static int VK_B
      常数为“B”键。
      static int VK_BACK_QUOTE
      常量为BACK_QUOTE键。
      static int VK_BACK_SLASH
      常数为斜杠，“\”
      static int VK_BACK_SPACE
      常量为BACK_SPACE虚拟键。
      static int VK_BEGIN
      常数为开始键。
      static int | VK_BRACELEFT
      static int | VK_BRACERIGHT
      static int VK_C
      常数为“C”键。
      static int VK_CANCEL
      CANCEL虚拟键的常数。
      static int VK_CAPS_LOCK
      CAPS_LOCK虚拟键的常数。
      static int VK_CIRCUMFLEX
      常数为“^”键。
      static int VK_CLEAR
      CLEAR虚拟键的常数。
      static int VK_CLOSE_BRACKET
      关闭括号键的常数，“]”
      static int VK_CODE_INPUT
      代码输入功能键的常数。
      static int VK_COLON
      “：”键的常数。
      static int VK_COMMA
      常数为逗号键“，”
      static int VK_COMPOSE
      编写功能键的常数。
      static int VK_CONTEXT_MENU
      Microsoft Windows上下文菜单键的常数。
      static int VK_CONTROL
      CONTROL虚拟键的常数。
      static int VK_CONVERT
      转换功能键的常数。
      static int | VK_COPY
      static int | VK_CUT
      static int VK_D
      常数为“D”键。
      static int | VK_DEAD_ABOVEDOT
      static int | VK_DEAD_ABOVERING
      static int | VK_DEAD_ACUTE
      static int | VK_DEAD_BREVE
      static int | VK_DEAD_CARON
      static int | VK_DEAD_CEDILLA
      static int | VK_DEAD_CIRCUMFLEX
      static int | VK_DEAD_DIAERESIS
      static int | VK_DEAD_DOUBLEACUTE
      static int | VK_DEAD_GRAVE
      static int | VK_DEAD_IOTA
      static int | VK_DEAD_MACRON
      static int | VK_DEAD_OGONEK
      static int | VK_DEAD_SEMIVOICED_SOUND
      static int | VK_DEAD_TILDE
      static int | VK_DEAD_VOICED_SOUND
      static int VK_DECIMAL
      数字小数点键的常数。
      static int VK_DELETE
      常数为删除键。
      static int VK_DIVIDE
      数字键分割键的常数。
      static int VK_DOLLAR
      “$”键的常数。
      static int VK_DOWN
      常数为非numpad 向下箭头键。
      static int VK_E
      常数为“E”键。
      static int VK_END
      END虚拟键的常数。
      static int VK_ENTER
      ENTER虚拟键的常数。
      static int VK_EQUALS
      等于键的常数，“=”
      static int VK_ESCAPE
      ESCAPE虚拟键的常数。
      static int VK_EURO_SIGN
      欧元货币符号键的常数。
      static int VK_EXCLAMATION_MARK
      常数为“！”
      static int VK_F
      常数为“F”键。
      static int VK_F1
      常数为F1功能键。
      static int VK_F10
      常数为F10功能键。
      static int VK_F11
      常数为F11功能键。
      static int VK_F12
      F12功能键的常数。
      static int VK_F13
      F13功能键的常数。
      static int VK_F14
      F14功能键的常数。
      static int VK_F15
      F15功能键的常数。
      static int VK_F16
      F16功能键的常数。
      static int VK_F17
      F17功能键的常数。
      static int VK_F18
      F18功能键的常数。
      static int VK_F19
      F19功能键的常数。
      static int VK_F2
      F2功能键的常数。
      static int VK_F20
      F20功能键的常数。
      static int VK_F21
      F21功能键的常数。
      static int VK_F22
      F22功能键的常数。
      static int VK_F23
      F23功能键的常数。
      static int VK_F24
      F24功能键的常数。
      static int VK_F3
      F3功能键的常数。
      static int VK_F4
      F4功能键的常数。
      static int VK_F5
      F5功能键的常数。
      static int VK_F6
      常数为F6功能键。
      static int VK_F7
      F7功能键的常数。
      static int VK_F8
      F8功能键的常数。
      static int VK_F9
      常数为F9功能键。
      static int VK_FINAL
      FINAL键的常数。
      static int | VK_FIND
      static int VK_FULL_WIDTH
      全角字符的常量功能键。
      static int VK_G
      常数为“G”键。
      static int | VK_GREATER
      static int VK_H
      恒定为“H”键。
      static int VK_HALF_WIDTH
      半角字符功能键的常数。
      static int VK_HELP
      常用于帮助键。
      static int VK_HIRAGANA
      平假名功能键的常数。
      static int VK_HOME
      HOME虚拟键的常数。
      static int VK_I
      常数为“I”键。
      static int VK_INPUT_METHOD_ON_OFF
      输入法/常规键的常数。
      static int VK_INSERT
      INSERT键的常数。
      static int VK_INVERTED_EXCLAMATION_MARK
      反转感叹号的常数。
      static int VK_J
      常数为“J”键。
      static int VK_JAPANESE_HIRAGANA
      日文 - 平假名功能键的常数。
      static int VK_JAPANESE_KATAKANA
      日本片假名功能键的常数。
      static int VK_JAPANESE_ROMAN
      日常罗马功能键的常数。
      static int VK_K
      常数为“K”键。
      static int VK_KANA
      KANA锁定键的常数。
      static int VK_KANA_LOCK
      锁定假名功能键的常数。
      static int VK_KANJI
      康乃馨
      static int VK_KATAKANA
      片假名功能键的常数。
      static int VK_KP_DOWN
      常数为数字键盘 向下箭头键。
      static int VK_KP_LEFT
      常数为数字键盘 左箭头键。
      static int VK_KP_RIGHT
      数字键盘 右箭头键的常数。
      static int VK_KP_UP
      常数为数字键盘 向上箭头键。
      static int VK_L
      常数为“L”键。
      static int VK_LEFT
      常数为非numpad 左箭头键。
      static int VK_LEFT_PARENTHESIS
      常数为“（”键。
      static int | VK_LESS
      static int VK_M
      常数为“M”键。
      static int VK_META
      常数为META密钥。
      static int VK_MINUS
      常数为减号，“ - ”
      static int VK_MODECHANGE
      MODECHANGE键的常数。
      static int VK_MULTIPLY
      数字键的常数乘法键。
      static int VK_N
      常数为“N”键。
      static int VK_NONCONVERT
      不转换功能键的常数。
      static int VK_NUM_LOCK
      常数为NUM_LOCK键。
      static int VK_NUMBER_SIGN
      “＃”键的常数。
      static int VK_NUMPAD0
      数字键“0”键的常数。
      static int VK_NUMPAD1
      数字键“1”键的常数。
      static int VK_NUMPAD2
      数字键“2”键的常数。
      static int VK_NUMPAD3
      数字键“3”键的常数。
      static int VK_NUMPAD4
      数字键“4”键的常数。
      static int VK_NUMPAD5
      数字键“5”键的常数。
      static int VK_NUMPAD6
      数字键“6”键的常数。
      static int VK_NUMPAD7
      数字键“7”键的常数。
      static int VK_NUMPAD8
      数字键“8”键的常数。
      static int VK_NUMPAD9
      数字键“9”键的常数。
      static int VK_O
      常数为“O”键。
      static int VK_OPEN_BRACKET
      常数为打开括号的键，“[”
      static int VK_P
      “P”键的常数。
      static int VK_PAGE_DOWN
      PAGE_DOWN虚拟键的常数。
      static int VK_PAGE_UP
      PAGE_UP虚拟键的常数。
      static int | VK_PASTE
      static int VK_PAUSE
      PAUSE虚拟键的常数。
      static int VK_PERIOD
      期间关键的常数“”。
      static int VK_PLUS
      常数为“+”键。
      static int VK_PREVIOUS_CANDIDATE
      上一个候选功能键的常数。
      static int VK_PRINTSCREEN
      PRINTSCREEN键的常数。
      static int | VK_PROPS
      static int VK_Q
      常数为“Q”键。
      static int VK_QUOTE
      QUOTE键的常数。
      static int | VK_QUOTEDBL
      static int VK_R
      常数为“R”键。
      static int VK_RIGHT
      常数为非numpad 右箭头键。
      static int VK_RIGHT_PARENTHESIS
      常数为“）”键。
      static int VK_ROMAN_CHARACTERS
      罗马字符功能键的常数。
      static int VK_S
      常数为“S”键。
      static int VK_SCROLL_LOCK
      SCROLL_LOCK键的常数。
      static int VK_SEMICOLON
      常数为分号键，“;”
      static int VK_SEPARATER
      此常数已过时，仅用于向后兼容。
      static int VK_SEPARATOR
      Numpad Separator键的常数。
      static int VK_SHIFT
      SHIFT虚拟键的常数。
      static int VK_SLASH
      正斜杠的常数为“/”
      static int VK_SPACE
      SPACE虚拟键的常数。
      static int | VK_STOP
      static int VK_SUBTRACT
      数字键的常数减去键。
      static int VK_T
      常数为“T”键。
      static int VK_TAB
      TAB虚拟键的常数。
      static int VK_U
      常数为“U”键。
      static int VK_UNDEFINED
      该值用于表示keyCode未知。
      static int VK_UNDERSCORE
      常量为“_”键。
      static int | VK_UNDO
      static int VK_UP
      常数为非numpad 向上箭头键。
      static int VK_V
      “V”键的常数。
      static int VK_W
      常数为“W”键。
      static int VK_WINDOWS
      Microsoft Windows“Windows”键的常数。
      static int VK_X
      常数为“X”键。
      static int VK_Y
      常数为“Y”键。
      static int VK_Z
      常数为“Z”键。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

      • Fields inherited from class java.awt.event.InputEvent

        ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK

    • 构造方法摘要

      构造方法
      Constructor 描述
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode)
      已过时。
      截至JDK1.1; 改用KeyEvent(Component, int, long, int, int, char)
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode, char keyChar)
      构造一个 KeyEvent对象。
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode, char keyChar, int keyLocation)
      构造一个 KeyEvent对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int getExtendedKeyCode​()
      返回事件的扩展密钥代码。
      static int getExtendedKeyCodeForChar​(int c)
      返回unicode字符的扩展密钥代码。
      char getKeyChar​()
      返回与此事件中的键相关联的字符。
      int getKeyCode​()
      返回与此事件中的键相关联的整数keyCode。
      int getKeyLocation​()
      返回发起此键事件的键的位置。
      static String getKeyModifiersText​(int modifiers)
      已过时。
      建议使用扩展修饰键和InputEvent.getModifiersExText(int)
      static String getKeyText​(int keyCode)
      返回一个描述keyCode的String，如“HOME”，“F1”或“A”。
      boolean isActionKey​()
      返回此事件中的键是否为“动作”键。
      String paramString​()
      返回标识此事件的参数字符串。
      void setKeyChar​(char keyChar)
      设置keyChar值以指示逻辑字符。
      void setKeyCode​(int keyCode)
      设置keyCode值以指示物理键。
      void setModifiers​(int modifiers)
      已过时。
      截至JDK1.1.4

      • Methods inherited from class java.awt.AWTEvent

        getID, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.awt.event.InputEvent

        consume, getMaskForButton, getModifiers, getModifiersEx, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • KEY_FIRST

        public static final int KEY_FIRST
        用于关键事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • KEY_LAST

        public static final int KEY_LAST
        用于关键事件的ids范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • KEY_TYPED

        public static final int KEY_TYPED
        “键入”事件。 此事件是在输入字符时生成的。 在最简单的情况下，它是由单个按键生成的。 然而，通常，通过一系列按键产生字符，并且从按键事件到键类型事件的映射可以是多对一或多对多。
        另请参见：
        Constant Field Values

      • KEY_PRESSED

        public static final int KEY_PRESSED
        “按键”事件。 当按下一个键时，会生成此事件。
        另请参见：
        Constant Field Values

      • KEY_RELEASED

        public static final int KEY_RELEASED
        “关键发布”事件。 当一个关键字放开时，会产生此事件。
        另请参见：
        Constant Field Values

      • VK_ENTER

        public static final int VK_ENTER
        ENTER虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_BACK_SPACE

        public static final int VK_BACK_SPACE
        常量为BACK_SPACE虚拟键。
        另请参见：
        Constant Field Values

      • VK_TAB

        public static final int VK_TAB
        TAB虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_CANCEL

        public static final int VK_CANCEL
        CANCEL虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_CLEAR

        public static final int VK_CLEAR
        CLEAR虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_SHIFT

        public static final int VK_SHIFT
        SHIFT虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_CONTROL

        public static final int VK_CONTROL
        CONTROL虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_ALT

        public static final int VK_ALT
        ALT虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_PAUSE

        public static final int VK_PAUSE
        PAUSE虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_CAPS_LOCK

        public static final int VK_CAPS_LOCK
        CAPS_LOCK虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_ESCAPE

        public static final int VK_ESCAPE
        ESCAPE虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_SPACE

        public static final int VK_SPACE
        SPACE虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_PAGE_UP

        public static final int VK_PAGE_UP
        PAGE_UP虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_PAGE_DOWN

        public static final int VK_PAGE_DOWN
        PAGE_DOWN虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_END

        public static final int VK_END
        END虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_HOME

        public static final int VK_HOME
        HOME虚拟键的常数。
        另请参见：
        Constant Field Values

      • VK_LEFT

        public static final int VK_LEFT
        常数为非numpad 左箭头键。
        另请参见：
        VK_KP_LEFT ， Constant Field Values

      • VK_UP

        public static final int VK_UP
        常数为非numpad 向上箭头键。
        另请参见：
        VK_KP_UP ， Constant Field Values

      • VK_RIGHT

        public static final int VK_RIGHT
        常数为非numpad 右箭头键。
        另请参见：
        VK_KP_RIGHT ， Constant Field Values

      • VK_DOWN

        public static final int VK_DOWN
        常数为非numpad 向下箭头键。
        另请参见：
        VK_KP_DOWN ， Constant Field Values

      • VK_COMMA

        public static final int VK_COMMA
        常数为逗号键“，”
        另请参见：
        Constant Field Values

      • VK_MINUS

        public static final int VK_MINUS
        常数为减号，“ - ”
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_PERIOD

        public static final int VK_PERIOD
        期间关键的常数“”。
        另请参见：
        Constant Field Values

      • VK_SLASH

        public static final int VK_SLASH
        正斜杠的常数为“/”
        另请参见：
        Constant Field Values

      • VK_0

        public static final int VK_0
        常数为“0”键。
        另请参见：
        Constant Field Values

      • VK_1

        public static final int VK_1
        常数为“1”键。
        另请参见：
        Constant Field Values

      • VK_2

        public static final int VK_2
        常数为“2”键。
        另请参见：
        Constant Field Values

      • VK_3

        public static final int VK_3
        常数为“3”键。
        另请参见：
        Constant Field Values

      • VK_4

        public static final int VK_4
        常数为“4”键。
        另请参见：
        Constant Field Values

      • VK_5

        public static final int VK_5
        常数为“5”键。
        另请参见：
        Constant Field Values

      • VK_6

        public static final int VK_6
        常数为“6”键。
        另请参见：
        Constant Field Values

      • VK_7

        public static final int VK_7
        常数为“7”键。
        另请参见：
        Constant Field Values

      • VK_8

        public static final int VK_8
        常数为“8”键。
        另请参见：
        Constant Field Values

      • VK_9

        public static final int VK_9
        常数为“9”键。
        另请参见：
        Constant Field Values

      • VK_SEMICOLON

        public static final int VK_SEMICOLON
        常数为分号键，“;”
        另请参见：
        Constant Field Values

      • VK_EQUALS

        public static final int VK_EQUALS
        等于键的常数，“=”
        另请参见：
        Constant Field Values

      • VK_A

        public static final int VK_A
        常数为“A”键。
        另请参见：
        Constant Field Values

      • VK_B

        public static final int VK_B
        常数为“B”键。
        另请参见：
        Constant Field Values

      • VK_C

        public static final int VK_C
        常数为“C”键。
        另请参见：
        Constant Field Values

      • VK_D

        public static final int VK_D
        常数为“D”键。
        另请参见：
        Constant Field Values

      • VK_E

        public static final int VK_E
        常数为“E”键。
        另请参见：
        Constant Field Values

      • VK_F

        public static final int VK_F
        常数为“F”键。
        另请参见：
        Constant Field Values

      • VK_G

        public static final int VK_G
        常数为“G”键。
        另请参见：
        Constant Field Values

      • VK_H

        public static final int VK_H
        恒定为“H”键。
        另请参见：
        Constant Field Values

      • VK_I

        public static final int VK_I
        常数为“I”键。
        另请参见：
        Constant Field Values

      • VK_J

        public static final int VK_J
        常数为“J”键。
        另请参见：
        Constant Field Values

      • VK_K

        public static final int VK_K
        常数为“K”键。
        另请参见：
        Constant Field Values

      • VK_L

        public static final int VK_L
        常数为“L”键。
        另请参见：
        Constant Field Values

      • VK_M

        public static final int VK_M
        常数为“M”键。
        另请参见：
        Constant Field Values

      • VK_N

        public static final int VK_N
        常数为“N”键。
        另请参见：
        Constant Field Values

      • VK_O

        public static final int VK_O
        常数为“O”键。
        另请参见：
        Constant Field Values

      • VK_P

        public static final int VK_P
        “P”键的常数。
        另请参见：
        Constant Field Values

      • VK_Q

        public static final int VK_Q
        常数为“Q”键。
        另请参见：
        Constant Field Values

      • VK_R

        public static final int VK_R
        常数为“R”键。
        另请参见：
        Constant Field Values

      • VK_S

        public static final int VK_S
        常数为“S”键。
        另请参见：
        Constant Field Values

      • VK_T

        public static final int VK_T
        常数为“T”键。
        另请参见：
        Constant Field Values

      • VK_U

        public static final int VK_U
        常数为“U”键。
        另请参见：
        Constant Field Values

      • VK_V

        public static final int VK_V
        “V”键的常数。
        另请参见：
        Constant Field Values

      • VK_W

        public static final int VK_W
        常数为“W”键。
        另请参见：
        Constant Field Values

      • VK_X

        public static final int VK_X
        常数为“X”键。
        另请参见：
        Constant Field Values

      • VK_Y

        public static final int VK_Y
        常数为“Y”键。
        另请参见：
        Constant Field Values

      • VK_Z

        public static final int VK_Z
        常数为“Z”键。
        另请参见：
        Constant Field Values

      • VK_OPEN_BRACKET

        public static final int VK_OPEN_BRACKET
        常数为打开括号的键，“[”
        另请参见：
        Constant Field Values

      • VK_BACK_SLASH

        public static final int VK_BACK_SLASH
        常数为斜杠，“\”
        另请参见：
        Constant Field Values

      • VK_CLOSE_BRACKET

        public static final int VK_CLOSE_BRACKET
        关闭括号键的常数，“]”
        另请参见：
        Constant Field Values

      • VK_NUMPAD0

        public static final int VK_NUMPAD0
        数字键“0”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD1

        public static final int VK_NUMPAD1
        数字键“1”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD2

        public static final int VK_NUMPAD2
        数字键“2”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD3

        public static final int VK_NUMPAD3
        数字键“3”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD4

        public static final int VK_NUMPAD4
        数字键“4”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD5

        public static final int VK_NUMPAD5
        数字键“5”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD6

        public static final int VK_NUMPAD6
        数字键“6”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD7

        public static final int VK_NUMPAD7
        数字键“7”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD8

        public static final int VK_NUMPAD8
        数字键“8”键的常数。
        另请参见：
        Constant Field Values

      • VK_NUMPAD9

        public static final int VK_NUMPAD9
        数字键“9”键的常数。
        另请参见：
        Constant Field Values

      • VK_MULTIPLY

        public static final int VK_MULTIPLY
        数字键的常数乘法键。
        另请参见：
        Constant Field Values

      • VK_ADD

        public static final int VK_ADD
        常数为数字键添加键。
        另请参见：
        Constant Field Values

      • VK_SEPARATER

        public static final int VK_SEPARATER
        此常数已过时，仅用于向后兼容。
        另请参见：
        VK_SEPARATOR ， Constant Field Values

      • VK_SEPARATOR

        public static final int VK_SEPARATOR
        Numpad Separator键的常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • VK_SUBTRACT

        public static final int VK_SUBTRACT
        数字键的常数减去键。
        另请参见：
        Constant Field Values

      • VK_DECIMAL

        public static final int VK_DECIMAL
        数字小数点键的常数。
        另请参见：
        Constant Field Values

      • VK_DIVIDE

        public static final int VK_DIVIDE
        数字键分割键的常数。
        另请参见：
        Constant Field Values

      • VK_DELETE

        public static final int VK_DELETE
        常数为删除键。
        另请参见：
        Constant Field Values

      • VK_NUM_LOCK

        public static final int VK_NUM_LOCK
        常数为NUM_LOCK键。
        另请参见：
        Constant Field Values

      • VK_SCROLL_LOCK

        public static final int VK_SCROLL_LOCK
        SCROLL_LOCK键的常数。
        另请参见：
        Constant Field Values

      • VK_F1

        public static final int VK_F1
        常数为F1功能键。
        另请参见：
        Constant Field Values

      • VK_F2

        public static final int VK_F2
        F2功能键的常数。
        另请参见：
        Constant Field Values

      • VK_F3

        public static final int VK_F3
        F3功能键的常数。
        另请参见：
        Constant Field Values

      • VK_F4

        public static final int VK_F4
        F4功能键的常数。
        另请参见：
        Constant Field Values

      • VK_F5

        public static final int VK_F5
        F5功能键的常数。
        另请参见：
        Constant Field Values

      • VK_F6

        public static final int VK_F6
        常数为F6功能键。
        另请参见：
        Constant Field Values

      • VK_F7

        public static final int VK_F7
        F7功能键的常数。
        另请参见：
        Constant Field Values

      • VK_F8

        public static final int VK_F8
        F8功能键的常数。
        另请参见：
        Constant Field Values

      • VK_F9

        public static final int VK_F9
        常数为F9功能键。
        另请参见：
        Constant Field Values

      • VK_F10

        public static final int VK_F10
        常数为F10功能键。
        另请参见：
        Constant Field Values

      • VK_F11

        public static final int VK_F11
        常数为F11功能键。
        另请参见：
        Constant Field Values

      • VK_F12

        public static final int VK_F12
        F12功能键的常数。
        另请参见：
        Constant Field Values

      • VK_F13

        public static final int VK_F13
        F13功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F14

        public static final int VK_F14
        F14功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F15

        public static final int VK_F15
        F15功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F16

        public static final int VK_F16
        F16功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F17

        public static final int VK_F17
        F17功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F18

        public static final int VK_F18
        F18功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F19

        public static final int VK_F19
        F19功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F20

        public static final int VK_F20
        F20功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F21

        public static final int VK_F21
        F21功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F22

        public static final int VK_F22
        F22功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F23

        public static final int VK_F23
        F23功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_F24

        public static final int VK_F24
        F24功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_PRINTSCREEN

        public static final int VK_PRINTSCREEN
        PRINTSCREEN键的常数。
        另请参见：
        Constant Field Values

      • VK_INSERT

        public static final int VK_INSERT
        INSERT键的常数。
        另请参见：
        Constant Field Values

      • VK_HELP

        public static final int VK_HELP
        常用于帮助键。
        另请参见：
        Constant Field Values

      • VK_META

        public static final int VK_META
        常数为META密钥。
        另请参见：
        Constant Field Values

      • VK_BACK_QUOTE

        public static final int VK_BACK_QUOTE
        常量为BACK_QUOTE键。
        另请参见：
        Constant Field Values

      • VK_QUOTE

        public static final int VK_QUOTE
        QUOTE键的常数。
        另请参见：
        Constant Field Values

      • VK_KP_UP

        public static final int VK_KP_UP
        常数为数字键盘 向上箭头键。
        从以下版本开始：
        1.2
        另请参见：
        VK_UP ， Constant Field Values

      • VK_KP_DOWN

        public static final int VK_KP_DOWN
        常数为数字键盘 向下箭头键。
        从以下版本开始：
        1.2
        另请参见：
        VK_DOWN ， Constant Field Values

      • VK_KP_LEFT

        public static final int VK_KP_LEFT
        常数为数字键盘 左箭头键。
        从以下版本开始：
        1.2
        另请参见：
        VK_LEFT ， Constant Field Values

      • VK_KP_RIGHT

        public static final int VK_KP_RIGHT
        数字键盘 右箭头键的常数。
        从以下版本开始：
        1.2
        另请参见：
        VK_RIGHT ， Constant Field Values

      • VK_DEAD_GRAVE

        public static final int VK_DEAD_GRAVE
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_ACUTE

        public static final int VK_DEAD_ACUTE
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_CIRCUMFLEX

        public static final int VK_DEAD_CIRCUMFLEX
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_TILDE

        public static final int VK_DEAD_TILDE
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_MACRON

        public static final int VK_DEAD_MACRON
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_BREVE

        public static final int VK_DEAD_BREVE
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_ABOVEDOT

        public static final int VK_DEAD_ABOVEDOT
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_DIAERESIS

        public static final int VK_DEAD_DIAERESIS
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_ABOVERING

        public static final int VK_DEAD_ABOVERING
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_DOUBLEACUTE

        public static final int VK_DEAD_DOUBLEACUTE
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_CARON

        public static final int VK_DEAD_CARON
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_CEDILLA

        public static final int VK_DEAD_CEDILLA
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_OGONEK

        public static final int VK_DEAD_OGONEK
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_IOTA

        public static final int VK_DEAD_IOTA
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_VOICED_SOUND

        public static final int VK_DEAD_VOICED_SOUND
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DEAD_SEMIVOICED_SOUND

        public static final int VK_DEAD_SEMIVOICED_SOUND
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_AMPERSAND

        public static final int VK_AMPERSAND
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_ASTERISK

        public static final int VK_ASTERISK
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_QUOTEDBL

        public static final int VK_QUOTEDBL
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_LESS

        public static final int VK_LESS
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_GREATER

        public static final int VK_GREATER
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_BRACELEFT

        public static final int VK_BRACELEFT
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_BRACERIGHT

        public static final int VK_BRACERIGHT
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_AT

        public static final int VK_AT
        “@”键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_COLON

        public static final int VK_COLON
        “：”键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_CIRCUMFLEX

        public static final int VK_CIRCUMFLEX
        常数为“^”键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_DOLLAR

        public static final int VK_DOLLAR
        “$”键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_EURO_SIGN

        public static final int VK_EURO_SIGN
        欧元货币符号键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_EXCLAMATION_MARK

        public static final int VK_EXCLAMATION_MARK
        常数为“！” 键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_INVERTED_EXCLAMATION_MARK

        public static final int VK_INVERTED_EXCLAMATION_MARK
        反转感叹号的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_LEFT_PARENTHESIS

        public static final int VK_LEFT_PARENTHESIS
        常数为“（”键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_NUMBER_SIGN

        public static final int VK_NUMBER_SIGN
        “＃”键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_PLUS

        public static final int VK_PLUS
        常数为“+”键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_RIGHT_PARENTHESIS

        public static final int VK_RIGHT_PARENTHESIS
        常数为“）”键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_UNDERSCORE

        public static final int VK_UNDERSCORE
        常量为“_”键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_WINDOWS

        public static final int VK_WINDOWS
        Microsoft Windows“Windows”键的常数。 它用于键盘的左右两个版本。
        从以下版本开始：
        1.5
        另请参见：
        getKeyLocation() ， Constant Field Values

      • VK_CONTEXT_MENU

        public static final int VK_CONTEXT_MENU
        Microsoft Windows上下文菜单键的常数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • VK_FINAL

        public static final int VK_FINAL
        FINAL键的常数。
        另请参见：
        Constant Field Values

      • VK_CONVERT

        public static final int VK_CONVERT
        转换功能键的常数。
        另请参见：
        Constant Field Values

      • VK_NONCONVERT

        public static final int VK_NONCONVERT
        不转换功能键的常数。
        另请参见：
        Constant Field Values

      • VK_ACCEPT

        public static final int VK_ACCEPT
        接受或提交功能键的常数。
        另请参见：
        Constant Field Values

      • VK_MODECHANGE

        public static final int VK_MODECHANGE
        MODECHANGE键的常数。
        另请参见：
        Constant Field Values

      • VK_KANA

        public static final int VK_KANA
        KANA锁定键的常数。
        另请参见：
        VK_KANA_LOCK ， Constant Field Values

      • VK_KANJI

        public static final int VK_KANJI
        康乃馨
        另请参见：
        VK_INPUT_METHOD_ON_OFF ， Constant Field Values

      • VK_ALPHANUMERIC

        public static final int VK_ALPHANUMERIC
        字母数字功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_KATAKANA

        public static final int VK_KATAKANA
        片假名功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_HIRAGANA

        public static final int VK_HIRAGANA
        平假名功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_FULL_WIDTH

        public static final int VK_FULL_WIDTH
        全角字符的常量功能键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_HALF_WIDTH

        public static final int VK_HALF_WIDTH
        半角字符功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_ROMAN_CHARACTERS

        public static final int VK_ROMAN_CHARACTERS
        罗马字符功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_ALL_CANDIDATES

        public static final int VK_ALL_CANDIDATES
        所有候选人的常数功能键。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_PREVIOUS_CANDIDATE

        public static final int VK_PREVIOUS_CANDIDATE
        上一个候选功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_CODE_INPUT

        public static final int VK_CODE_INPUT
        代码输入功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_JAPANESE_KATAKANA

        public static final int VK_JAPANESE_KATAKANA
        日本片假名功能键的常数。 该键切换到日文输入法，并选择其片假名输入模式。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_JAPANESE_HIRAGANA

        public static final int VK_JAPANESE_HIRAGANA
        日文 - 平假名功能键的常数。 此键切换到日语输入法，并选择其平假名输入模式。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_JAPANESE_ROMAN

        public static final int VK_JAPANESE_ROMAN
        日常罗马功能键的常数。 该键切换到日语输入法，并选择其Roman-Direct输入模式。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_KANA_LOCK

        public static final int VK_KANA_LOCK
        锁定假名功能键的常数。 该键将键盘锁定到假名布局。
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • VK_INPUT_METHOD_ON_OFF

        public static final int VK_INPUT_METHOD_ON_OFF
        输入法/常规键的常数。
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • VK_CUT

        public static final int VK_CUT
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_COPY

        public static final int VK_COPY
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_PASTE

        public static final int VK_PASTE
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_UNDO

        public static final int VK_UNDO
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_AGAIN

        public static final int VK_AGAIN
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_FIND

        public static final int VK_FIND
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_PROPS

        public static final int VK_PROPS
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_STOP

        public static final int VK_STOP
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_COMPOSE

        public static final int VK_COMPOSE
        编写功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_ALT_GRAPH

        public static final int VK_ALT_GRAPH
        AltGraph功能键的常数。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • VK_BEGIN

        public static final int VK_BEGIN
        常数为开始键。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • VK_UNDEFINED

        public static final int VK_UNDEFINED
        该值用于表示keyCode未知。 KEY_TYPED事件没有keyCode值; 该值被替代使用。
        另请参见：
        Constant Field Values

      • CHAR_UNDEFINED

        public static final char CHAR_UNDEFINED
        KEY_PRESSED和KEY_RELEASED事件不映射到一个有效的Unicode字符使用它作为keyChar值。
        另请参见：
        Constant Field Values

      • KEY_LOCATION_UNKNOWN

        public static final int KEY_LOCATION_UNKNOWN
        一个常量，表示keyLocation不确定或不相关。 KEY_TYPED事件没有keyLocation; 该值被替代使用。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • KEY_LOCATION_STANDARD

        public static final int KEY_LOCATION_STANDARD
        指示按键或释放的键不被区分为键的左或右版本，并且不起源于数字键盘（或不是源自与数字键盘对应的虚拟键）。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • KEY_LOCATION_LEFT

        public static final int KEY_LOCATION_LEFT
        指示按下或释放的键位于左键位置（该键有多个可能位置）的常数。 示例：左移键。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • KEY_LOCATION_RIGHT

        public static final int KEY_LOCATION_RIGHT
        一个常数表示按下或释放的键位于正确的键位置（该键有多个可能的位置）。 示例：右移键。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • KEY_LOCATION_NUMPAD

        public static final int KEY_LOCATION_NUMPAD
        指示键数据小键盘上的密钥事件或与数字小键盘对应的虚拟键的常数。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • KeyEvent

        public KeyEvent​(Component source,
                int id,
                long when,
                int modifiers,
                int keyCode,
                char keyChar,
                int keyLocation)
        构造一个KeyEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅KeyEvent的类描述
        when - 指定事件发生时间的长整数。 不建议传递负值或零值
        modifiers - 修改器在事件期间按下（shift，ctrl，alt，meta）。 不推荐传递负值。 零值表示没有通过修饰符。 使用扩展_DOWN_MASK或旧_MASK修饰符，但不要在一个事件中混合模型。 扩展的修饰剂优选用于使用
        keyCode - 实际键的整数代码，或VK_UNDEFINED（用于键入事件）
        keyChar - 此事件生成的Unicode字符或CHAR_UNDEFINED（对于未映射到有效Unicode字符的按键和键释放事件）
        keyLocation - 标识密钥位置。 唯一的合法值是KEY_LOCATION_UNKNOWN ， KEY_LOCATION_STANDARD ， KEY_LOCATION_LEFT ， KEY_LOCATION_RIGHT ，并KEY_LOCATION_NUMPAD 。
        异常
        IllegalArgumentException - 如果id是KEY_TYPED和keyChar是CHAR_UNDEFINED ;
或如果id是KEY_TYPED和keyCode不是VK_UNDEFINED ;
或如果id是KEY_TYPED和keyLocation不是KEY_LOCATION_UNKNOWN ;
或者如果keyLocation不是上面列举的合法价值之一。
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
InputEvent.getWhen() ，
InputEvent.getModifiers() ，
getKeyCode() ，
getKeyChar() ，
getKeyLocation()

      • KeyEvent

        public KeyEvent​(Component source,
                int id,
                long when,
                int modifiers,
                int keyCode,
                char keyChar)
        构造一个KeyEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅KeyEvent的类描述
        when - 指定事件发生时间的长整数。 不建议传递负值或零值
        modifiers - 修改器在事件期间按下（shift，ctrl，alt，meta）。 不推荐传递负值。 零值表示没有通过修饰符。 使用扩展_DOWN_MASK或旧_MASK修饰符，但不要在一个事件中混合模型。 扩展的修饰剂优选用于使用
        keyCode - 实际键的整数代码，或VK_UNDEFINED（对于键入事件）
        keyChar - 此事件生成的Unicode字符或CHAR_UNDEFINED（对于未映射到有效Unicode字符的按键和键释放事件）
        异常
        IllegalArgumentException - 如果id是KEY_TYPED和keyChar是CHAR_UNDEFINED ; 或如果id是KEY_TYPED和keyCode不是VK_UNDEFINED
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
InputEvent.getWhen() ，
InputEvent.getModifiers() ，
getKeyCode() ，
getKeyChar()

      • KeyEvent

        @Deprecated
public KeyEvent​(Component source,
                int id,
                long when,
                int modifiers,
                int keyCode)
        已过时。 截至JDK1.1; 请改用KeyEvent(Component, int, long, int, int, char)
        参数
        source - 发起事件的 Component
        id - 表示事件类型的整数。 有关允许值的信息，请参阅KeyEvent的类说明
        when - 指定事件发生时间的长整数。 不建议传递负值或零值
        modifiers - 修改器在事件期间按下（shift，ctrl，alt，meta）。 不推荐传递负值。 零值表示没有通过修饰符。 使用扩展_DOWN_MASK或旧_MASK修饰符，但不要在一个事件中混合模型。 扩展的修饰剂优选用于使用
        keyCode - 实际键的整数代码，或VK_UNDEFINED（用于键入事件）

    • 方法详细信息

      • getKeyCode

        public int getKeyCode​()
        返回与此事件中的键相关联的整数keyCode。
        结果
        键盘上实际键的整数代码。 （对于KEY_TYPED事件，keyCode为VK_UNDEFINED ）

      • setKeyCode

        public void setKeyCode​(int keyCode)
        设置keyCode值以指示物理键。
        参数
        keyCode - 与键盘上的实际键对应的整数。

      • getKeyChar

        public char getKeyChar​()
        返回与此事件中的键相关联的字符。 例如，shift +“a”的KEY_TYPED事件返回“A”的值。

        KEY_PRESSED和KEY_RELEASED事件不用于报告字符输入。 因此，此方法返回的值将被保证仅对KEY_TYPED事件有意义。

        结果
        为此键事件定义的Unicode字符。 如果此键事件不存在有效的Unicode字符，则返回CHAR_UNDEFINED 。

      • setKeyChar

        public void setKeyChar​(char keyChar)
        设置keyChar值以指示逻辑字符。
        参数
        keyChar - 对应于构成此事件的按键组合的 keyChar 。

      • setModifiers

        @Deprecated
public void setModifiers​(int modifiers)
        已过时。 截至JDK1.1.4
        设置修饰符以指示被定义为InputEvent的一部分的其他被按下的键（例如shift，ctrl，alt，meta）。

        注意：不建议使用此方法，因为许多AWT实现不会识别修饰符更改。 对于更改换档修改器的KEY_TYPED事件尤其如此。

        参数
        modifiers - 修饰符常数的整数组合。
        另请参见：
        InputEvent

      • getKeyLocation

        public int getKeyLocation​()
        返回发起此键事件的键的位置。 一些键在键盘上不止一次出现，例如左右移动键。 另外，数字键盘上也会出现一些键。 这提供了区分这些键的方式。
        结果
        按下或释放的键的位置。 始终为KEY_TYPED事件返回KEY_LOCATION_UNKNOWN 。
        从以下版本开始：
        1.4

      • getKeyText

        public static String getKeyText​(int keyCode)
        返回一个描述keyCode的String，如“HOME”，“F1”或“A”。 这些字符串可以通过更改awt.properties文件进行本地化。
        参数
        keyCode - 要返回描述的关键字
        结果
        一个包含物理键的文本描述的字符串，由其keyCode标识

      • getKeyModifiersText

        @Deprecated(since="9")
public static String getKeyModifiersText​(int modifiers)
        已过时。 建议使用扩展修饰键和InputEvent.getModifiersExText(int)
        返回描述修饰键（例如“Shift”或“Ctrl + Shift”）的String 。 这些字符串可以通过更改awt.properties文件进行本地化。

        请注意， InputEvent.ALT_MASK和InputEvent.BUTTON2_MASK具有相同的值，因此对于两个修饰符都将返回字符串“Alt”。 同样， InputEvent.META_MASK和InputEvent.BUTTON3_MASK具有相同的值，因此对于两个修饰符都将返回字符串“Meta”。

        参数
        modifiers - 要处理的修饰符掩码
        结果
        字符串在事件期间按住的修饰符键的组合的文本描述
        另请参见：
        InputEvent.getModifiersExText(int)

      • isActionKey

        public boolean isActionKey​()
        返回此事件中的键是否为“动作”键。 通常，动作键不会触发unicode字符，而不是修饰符键。
        结果
        true如果键是一个“动作”键，否则为 false

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 ComponentEvent
        结果
        标识事件及其属性的字符串

      • getExtendedKeyCode

        public int getExtendedKeyCode​()
        返回事件的扩展密钥代码。 扩展密钥代码是分配给键盘上的键的唯一ID，就像keyCode 。 但是，与keyCode不同，此值取决于当前的键盘布局。 例如，在一个共同的英文布局按左最上面的字母键的值相同keyCode ， VK_Q 。 在俄罗斯的常规布局中按相同的键可以给出另外一个代码，这个代码对于“西里尔字母I”来说是独一无二的。
        结果
        该事件的扩展密钥代码
        从以下版本开始：
        1.7

      • getExtendedKeyCodeForChar

        public static int getExtendedKeyCodeForChar​(int c)
        返回unicode字符的扩展密钥代码。
        参数
        c - 要处理的unicode字符
        结果
        对于一个unicode字符与相应的VK_常数 - 这个VK_常数; 对于出现在已知键盘布局的主要级别上的角色 - 唯一的整数。 如果字符未显示在已知键盘的主级上，则返回VK_UNDEFINED 。
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


KeyListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface KeyListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicComboBoxUI.KeyHandler ， BasicComboPopup.InvocationKeyHandler ， BasicTableUI.KeyHandler ， BasicTreeUI.KeyHandler ， KeyAdapter

    public interface KeyListener
extends EventListener
    用于接收键盘事件（按键）的侦听器界面。 有兴趣处理键盘事件的类实现此接口（及其包含的所有方法）或扩展抽象的KeyAdapter类（仅覆盖感兴趣的方法）。

    然后，使用该组件的addKeyListener方法将从该类创建的侦听器对象注册到组件。 按键，释放或键入时会产生键盘事件。 然后在收听对象中的相关方法被调用，并且KeyEvent被传递给它。

    从以下版本开始：
    1.1
    另请参见：
    KeyAdapter ， KeyEvent ， Tutorial: Writing a Key Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void keyPressed​(KeyEvent e)
      按下键时调用。
      void keyReleased​(KeyEvent e)
      当键已被释放时调用。
      void keyTyped​(KeyEvent e)
      键入键时调用。

    • 方法详细信息

      • keyTyped

        void keyTyped​(KeyEvent e)
        键入键时调用。 有关键入事件的定义，请参阅KeyEvent的类描述。
        参数
        e - 要处理的事件

      • keyPressed

        void keyPressed​(KeyEvent e)
        按下键时调用。 有关按键事件的定义，请参阅KeyEvent的类说明。
        参数
        e - 要处理的事件

      • keyReleased

        void keyReleased​(KeyEvent e)
        当键已被释放时调用。 关于释放事件的定义，请参阅KeyEvent的类描述。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class MouseAdapter

  • java.lang.Object
    • java.awt.event.MouseAdapter
  • All Implemented Interfaces:
    MouseListener ， MouseMotionListener ， MouseWheelListener ， EventListener
    已知直接子类：
    BasicComboPopup.InvocationMouseHandler ， BasicComboPopup.ListMouseHandler ， BasicFileChooserUI.DoubleClickListener ， BasicScrollBarUI.ArrowButtonListener ， BasicScrollBarUI.TrackListener ， BasicSplitPaneDivider.MouseHandler ， BasicTabbedPaneUI.MouseHandler ， BasicTreeUI.MouseHandler ， FormView.MouseEventListener ， HTMLEditorKit.LinkController ， MetalFileChooserUI.SingleClickListener ， MouseInputAdapter ， ToolTipManager

    public abstract class MouseAdapter
extends Object
implements MouseListener, MouseWheelListener, MouseMotionListener
    用于接收鼠标事件的抽象适配器类。 这个类中的方法是空的。 此类作为创建侦听器对象的方便而存在。

    鼠标事件可以让您跟踪鼠标按下，释放，点击，移动，拖动，进入组件，退出时和鼠标滚轮移动时。

    扩展此类创建一个MouseEvent （包括拖动和运动事件）或/和MouseWheelEvent监听器并覆盖感兴趣事件的方法。 （如果要实现MouseListener ， MouseMotionListener接口，你必须定义所有的在它的方法。此抽象类定义了所有这些空方法，所以你可以只需要针对所关心的事件重写方法。）

    创建使用扩展的类的监听器对象，然后使用组件的一个组件注册addMouseListener addMouseMotionListener ， addMouseWheelListener方法。 调用监听器对象中的相关方法，并在以下情况下传递MouseEvent或MouseWheelEvent ：

    • 当按下，释放或点击（按下并释放）鼠标按钮时，
    • 当鼠标光标进入或退出组件时
    • 当鼠标滚轮旋转时，或鼠标移动或拖动
    从以下版本开始：
    1.1
    另请参见：
    MouseEvent ， MouseWheelEvent ， MouseListener ， MouseMotionListener ， MouseWheelListener ， Tutorial: Writing a Mouse Listener

    • 构造方法摘要

      构造方法
      Constructor 描述
      MouseAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void mouseClicked​(MouseEvent e)
      在组件上单击（按下并释放）鼠标按钮时调用。
      void mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。
      void mousePressed​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。
      void mouseWheelMoved​(MouseWheelEvent e)
      当鼠标滚轮旋转时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MouseAdapter

        public MouseAdapter​()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked​(MouseEvent e)
        在组件上单击（按下并释放）鼠标按钮时调用。
        Specified by:
        mouseClicked在接口 MouseListener
        参数
        e - 要处理的事件

      • mousePressed

        public void mousePressed​(MouseEvent e)
        在组件上按下鼠标按钮时调用。
        Specified by:
        mousePressed在接口 MouseListener
        参数
        e - 要处理的事件

      • mouseReleased

        public void mouseReleased​(MouseEvent e)
        在组件上释放鼠标按钮时调用。
        Specified by:
        mouseReleased在接口 MouseListener
        参数
        e - 要处理的事件

      • mouseEntered

        public void mouseEntered​(MouseEvent e)
        当鼠标进入组件时调用。
        Specified by:
        mouseEntered在接口 MouseListener
        参数
        e - 要处理的事件

      • mouseExited

        public void mouseExited​(MouseEvent e)
        当鼠标退出组件时调用。
        Specified by:
        mouseExited在接口 MouseListener
        参数
        e - 要处理的事件

      • mouseWheelMoved

        public void mouseWheelMoved​(MouseWheelEvent e)
        当鼠标滚轮旋转时调用。
        Specified by:
        mouseWheelMoved在接口 MouseWheelListener
        参数
        e - 要处理的事件
        从以下版本开始：
        1.6
        另请参见：
        MouseWheelEvent

      • mouseDragged

        public void mouseDragged​(MouseEvent e)
        在组件上按下鼠标按钮然后拖动时调用。 MOUSE_DRAGGED事件将继续传递到拖动发起的组件，直到鼠标按钮释放（无论鼠标位置是否在组件的边界内）。

        由于平台相关的拖放实现，在本机拖放操作期间可能无法传送MOUSE_DRAGGED事件。

        Specified by:
        mouseDragged在接口 MouseMotionListener
        参数
        e - 要处理的事件
        从以下版本开始：
        1.6

      • mouseMoved

        public void mouseMoved​(MouseEvent e)
        当鼠标光标移动到组件上但没有按钮被按下时调用。
        Specified by:
        mouseMoved在接口 MouseMotionListener
        参数
        e - 要处理的事件
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class MouseEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
            • java.awt.event.MouseEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    MenuDragMouseEvent ， MouseWheelEvent

    public class MouseEvent
extends InputEvent
    指示组件中发生鼠标操作的事件。 如果且仅当鼠标光标位于组件边界的视野不足部分时，才会在特定组件中发生鼠标动作。 对于轻量级组件（如Swing的组件），如果组件上已启用鼠标事件类型，则鼠标事件仅会分派到组件。 通过将相应的基于鼠标的EventListener到组件（ MouseListener或MouseMotionListener ）或通过使用适当的掩码参数（ AWTEvent.MOUSE_EVENT_MASK或AWTEvent.MOUSE_MOTION_EVENT_MASK ）调用Component.enableEvents(long)来启用鼠标事件类型。 如果组件上尚未启用鼠标事件类型，则将相应的鼠标事件分派到已启用鼠标事件类型的第一个祖先。

    例如，如果MouseListener添加到组件，或已调用enableEvents(AWTEvent.MOUSE_EVENT_MASK) ，则将所有由MouseListener定义的事件分派到组件。 在另一方面，如果一个MouseMotionListener未添加和enableEvents未被调用与AWTEvent.MOUSE_MOTION_EVENT_MASK ，然后鼠标移动事件不分派给该组件。 而是将鼠标运动事件调度到已启用鼠标移动事件的第一个祖先。

    此低级事件由以下组件对象生成：

    • 鼠标事件
      • 按下鼠标按钮
      • 鼠标按钮被释放
      • 单击鼠标按钮（按下并释放）
      • 鼠标光标进入组件几何图形的视野不大的部分
      • 鼠标光标会离开组件几何体的视线部分
    • 鼠标运动事件
      • 鼠标移动
      • 鼠标被拖动

    将MouseEvent对象传递给每个MouseListener或MouseAdapter对象，该对象被注册以使用组件的addMouseListener方法接收“有趣”的鼠标事件。 （ MouseAdapter对象实现MouseListener接口。）每个这样的侦听器对象获取包含鼠标事件的MouseEvent 。

    一个MouseEvent对象也被传递给每个MouseMotionListener或MouseMotionAdapter对象，该对象被注册以使用组件的addMouseMotionListener方法接收鼠标运动事件。 （ MouseMotionAdapter对象实现MouseMotionListener接口。）每个这样的侦听器对象获取包含鼠标移动事件的MouseEvent 。

    当单击鼠标按钮时，生成事件并发送到注册的MouseListener 。 可以使用InputEvent.getModifiers()和InputEvent.getModifiersEx()检索模态键的状态。 InputEvent.getModifiers()返回的按钮掩码只反映改变状态的按钮，而不是所有按钮的当前状态。 （注意：由于ALT_MASK / BUTTON2_MASK和META_MASK / BUTTON3_MASK的值重叠，这对于涉及修饰键的鼠标事件并不总是如此）。 要获取所有按钮和修饰键的状态，请使用InputEvent.getModifiersEx() 。 已更改状态的按钮返回getButton()

    例如，如果按下第一个鼠标按钮，则按以下顺序发送事件：

       id modifiers button MOUSE_PRESSED: BUTTON1_MASK BUTTON1 MOUSE_RELEASED: BUTTON1_MASK BUTTON1 MOUSE_CLICKED: BUTTON1_MASK BUTTON1
    当按下多个鼠标按钮时，每次按下，释放和点击会导致单独的事件。

    例如，如果用户按下按钮1跟随按钮2 ，然后以相同的顺序释放它们，则生成以下事件序列：

       id modifiers button MOUSE_PRESSED: BUTTON1_MASK BUTTON1 MOUSE_PRESSED: BUTTON2_MASK BUTTON2 MOUSE_RELEASED: BUTTON1_MASK BUTTON1 MOUSE_CLICKED: BUTTON1_MASK BUTTON1 MOUSE_RELEASED: BUTTON2_MASK BUTTON2 MOUSE_CLICKED: BUTTON2_MASK BUTTON2
    如果按钮2先释放，则MOUSE_RELEASED MOUSE_CLICKED对BUTTON2_MASK到达，其次是BUTTON1_MASK 。

    一些额外的鼠标按钮被添加到扩展标准组由下列常数表示按钮： BUTTON1 ， BUTTON2 ，和BUTTON3 。 额外的按钮没有分配BUTTONx常量，它们的按钮掩码没有分配BUTTONx_DOWN_MASK常量。 然而，从4开始的序数可以用作按钮编号（按钮ID）。 通过getMaskForButton(button)方法获得的值可以用作按钮掩码。

    MOUSE_DRAGGED事件传递到Component ，其中按下鼠标按钮直到鼠标按钮释放（无论鼠标位置是否在Component的范围内）。 由于平台相关的拖放实现，在本机拖放操作期间可能无法传送MOUSE_DRAGGED事件。 在多屏幕环境鼠标拖动事件被传递到Component即使鼠标位置在边界之外GraphicsConfiguration与之相关Component 。 但是，在这种情况下，鼠标拖动事件的报告位置可能与实际的鼠标位置不同：

    • 在没有虚拟设备的多屏环境中：
      报告的鼠标拖动事件的坐标被剪切以适合与GraphicsConfiguration相关联的Component的范围内。
    • 在具有虚拟设备的多屏环境中：
      报告的鼠标拖动事件的坐标被剪切以适合与Component相关联的虚拟设备的Component 。

    如果任何特定MouseEvent实例的id参数不在MOUSE_FIRST到MOUSE_LAST -1（ MOUSE_WHEEL不可接受）的范围内，将会引起未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    MouseAdapter ， MouseListener ， MouseMotionAdapter ， MouseMotionListener ， MouseWheelListener ， Tutorial: Writing a Mouse Listener ， Tutorial: Writing a Mouse Motion Listener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BUTTON1
      表示鼠标按钮＃1; 由getButton()使用 。
      static int BUTTON2
      表示鼠标按钮＃2; 由getButton()使用 。
      static int BUTTON3
      表示鼠标按钮＃3; 由getButton()使用 。
      static int MOUSE_CLICKED
      “鼠标点击”事件。
      static int MOUSE_DRAGGED
      “鼠标拖动”事件。
      static int MOUSE_ENTERED
      “鼠标进入”事件。
      static int MOUSE_EXITED
      “鼠标退出”事件。
      static int MOUSE_FIRST
      用于鼠标事件的ids范围中的第一个数字。
      static int MOUSE_LAST
      用于鼠标事件的ids范围中的最后一个数字。
      static int MOUSE_MOVED
      “鼠标移动”事件。
      static int MOUSE_PRESSED
      “鼠标按下”事件。
      static int MOUSE_RELEASED
      “鼠标释放”事件。
      static int MOUSE_WHEEL
      “鼠标滚轮”事件。
      static int NOBUTTON
      表示没有鼠标按钮; 由getButton()使用 。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

      • Fields inherited from class java.awt.event.InputEvent

        ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK

    • 构造方法摘要

      构造方法
      Constructor 描述
      MouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger)
      构造具有指定的源组件，类型，修饰符，坐标，点击数和弹出触发标志的 MouseEvent对象。
      MouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int button)
      构造具有指定的源组件，类型，时间，修饰符，坐标，点击计数，弹出触发器标志和按钮编号的 MouseEvent对象。
      MouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int button)
      使用指定的源组件，类型，时间，修饰符，坐标，绝对坐标，点击计数，弹出触发标志和按钮编号构建一个 MouseEvent对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getButton​()
      返回哪个鼠标按钮（如果有）已更改状态。
      int getClickCount​()
      返回与此事件关联的鼠标点击次数。
      Point getLocationOnScreen​()
      返回事件的绝对x，y位置。
      int getModifiersEx​()
      返回此事件的扩展修饰符掩码。
      static String getMouseModifiersText​(int modifiers)
      返回描述在事件期间关闭的修改键和鼠标按钮的 String实例，例如“Shift”或“Ctrl + Shift”。
      Point getPoint​()
      返回事件相对于源组件的x，y位置。
      int getX​()
      返回事件相对于源组件的水平x位置。
      int getXOnScreen​()
      返回事件的绝对水平x位置。
      int getY​()
      返回事件相对于源组件的垂直y位置。
      int getYOnScreen​()
      返回事件的绝对垂直y位置。
      boolean isPopupTrigger​()
      返回此鼠标事件是否为平台的弹出菜单触发器事件。
      String paramString​()
      返回标识此事件的参数字符串。
      void translatePoint​(int x, int y)
      通过添加指定的 x （水平）和 y （垂直）偏移量将事件的坐标转换为新位置。

      • Methods inherited from class java.awt.AWTEvent

        getID, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.awt.event.InputEvent

        consume, getMaskForButton, getModifiers, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MOUSE_FIRST

        public static final int MOUSE_FIRST
        用于鼠标事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • MOUSE_LAST

        public static final int MOUSE_LAST
        用于鼠标事件的ids范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • MOUSE_CLICKED

        public static final int MOUSE_CLICKED
        “鼠标点击”事件。 当按下并释放鼠标按钮时，会发生MouseEvent 。
        另请参见：
        Constant Field Values

      • MOUSE_PRESSED

        public static final int MOUSE_PRESSED
        “鼠标按下”事件。 当按下鼠标按钮时，会发生MouseEvent 。
        另请参见：
        Constant Field Values

      • MOUSE_RELEASED

        public static final int MOUSE_RELEASED
        “鼠标释放”事件。 当鼠标按钮MouseEvent时，会发生MouseEvent 。
        另请参见：
        Constant Field Values

      • MOUSE_MOVED

        public static final int MOUSE_MOVED
        “鼠标移动”事件。 当鼠标位置发生变化时，会发生MouseEvent 。
        另请参见：
        Constant Field Values

      • MOUSE_ENTERED

        public static final int MOUSE_ENTERED
        “鼠标进入”事件。 当鼠标光标进入组件几何的视野MouseEvent时，会发生此MouseEvent 。
        另请参见：
        Constant Field Values

      • MOUSE_EXITED

        public static final int MOUSE_EXITED
        “鼠标退出”事件。 当鼠标光标退出组件几何的视野MouseEvent时，会发生此MouseEvent 。
        另请参见：
        Constant Field Values

      • MOUSE_DRAGGED

        public static final int MOUSE_DRAGGED
        “鼠标拖动”事件。 当按下鼠标按钮时鼠标位置发生变化时，会发生MouseEvent 。
        另请参见：
        Constant Field Values

      • MOUSE_WHEEL

        public static final int MOUSE_WHEEL
        “鼠标滚轮”事件。 这是唯一的MouseWheelEvent 。 当装有轮子的鼠标轮旋转时，会发生这种情况。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • NOBUTTON

        public static final int NOBUTTON
        表示没有鼠标按钮; 由getButton()使用 。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • BUTTON1

        public static final int BUTTON1
        表示鼠标按钮＃1; 由getButton()使用 。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • BUTTON2

        public static final int BUTTON2
        表示鼠标按钮＃2; 由getButton()使用 。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • BUTTON3

        public static final int BUTTON3
        表示鼠标按钮＃3; 由getButton()使用 。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • MouseEvent

        public MouseEvent​(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int clickCount,
                  boolean popupTrigger,
                  int button)
        构造具有指定的源组件，类型，时间，修饰符，坐标，点击计数，弹出触发器标志和按钮编号的MouseEvent对象。

        创建无效事件（例如通过使用多个旧的_MASK或不匹配的修饰符/按钮值）导致未指定的行为。 调用表单MouseEvent(source, id, when, modifiers, x, y, clickCount, popupTrigger, button)行为方式与调用MouseEvent(source, id, when, modifiers, x, y, xAbs, yAbs, clickCount, popupTrigger, button)完全相同 ，其中xAbs和yAb定义为屏幕上的源位置加上相对坐标x和y。 如果源未显示，则xAbs和yAb设置为零。 此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅MouseEvent的类说明
        when - 给出事件发生时间的长整数。 不建议传递负值或零值
        modifiers - 描述在事件期间关闭的修饰符键和鼠标按钮（例如shift，ctrl，alt和meta）的修饰符掩码。 只允许使用扩展修饰符作为此参数的值（有关扩展修饰符的说明，请参阅InputEvent.getModifiersEx()类）。 不推荐传递负参数。 零值表示没有通过修饰符
        x - 鼠标位置的水平x坐标。 允许传递负值
        y - 鼠标位置的垂直y坐标。 允许传递负值
        clickCount - 与事件关联的鼠标点击次数。 不推荐传递负值
        popupTrigger - 如果此事件是弹出式菜单的触发器，则该值为 true的布尔值
        button - 一个整数，指示哪个鼠标按钮已更改其状态。 以下规则适用于此参数：
        • 如果扩展的鼠标按钮的支持是disabled被Java则允许创建MouseEvent个与标准按钮对象： NOBUTTON ， BUTTON1 ， BUTTON2 ，并BUTTON3 。
        • 如果通过Java支持扩展鼠标按钮是enabled ，则可以使用标准按钮创建MouseEvent对象。 如果通过Java支持扩展鼠标按钮是enabled ，那么除了标准按钮之外，如果鼠标有三个以上的按钮， MouseEvent可以使用从4到MouseInfo.getNumberOfButtons()的范围内的按钮创建MouseEvent对象。
        异常
        IllegalArgumentException - 如果 button小于零
        IllegalArgumentException - 如果 source为空
        IllegalArgumentException - 如果 button大于BUTTON3，并且对扩展鼠标按钮的支持是由Java提供的是 disabled
        IllegalArgumentException - 如果 button大于 current number of buttons，并且对扩展鼠标按钮的支持是 enabled由Java
        IllegalArgumentException - 如果传递无效的 button值
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
InputEvent.getWhen() ，
InputEvent.getModifiers() ，
getX() ，
getY() ，
getClickCount() ，
isPopupTrigger() ，
getButton()

      • MouseEvent

        public MouseEvent​(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int clickCount,
                  boolean popupTrigger)
        构造一个具有指定源组件，类型，修饰符，坐标，点击数和弹出触发标志的MouseEvent对象。 调用表单MouseEvent(source, id, when, modifiers, x, y, clickCount, popupTrigger)行为方式与调用MouseEvent(source, id, when, modifiers, x, y, xAbs, yAbs, clickCount, popupTrigger, MouseEvent.NOBUTTON)完全相同 ，其中xAbs和yAbs定义为屏幕上的源位置加上相对坐标x和y。 如果源未显示，则xAbs和yAb设置为零。 此方法抛出IllegalArgumentException如果source为null 。
        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅MouseEvent的类描述
        when - 给出事件发生时间的长整数。 不建议传递负值或零值
        modifiers - 描述在事件期间关闭的修饰符键和鼠标按钮（例如shift，ctrl，alt和meta）的修饰符掩码。 只允许使用扩展修饰符作为此参数的值（有关扩展修饰符的说明，请参阅InputEvent.getModifiersEx()类）。 不推荐传递负参数。 零值表示没有通过修饰符
        x - 鼠标位置的水平x坐标。 允许传递负值
        y - 鼠标位置的垂直y坐标。 允许传递负值
        clickCount - 与事件关联的鼠标点击次数。 不推荐传递负值
        popupTrigger - 如果此事件是弹出菜单的触发器，则该值为 true的布尔值
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
InputEvent.getWhen() ，
InputEvent.getModifiers() ，
getX() ，
getY() ，
getClickCount() ，
isPopupTrigger()

      • MouseEvent

        public MouseEvent​(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int xAbs,
                  int yAbs,
                  int clickCount,
                  boolean popupTrigger,
                  int button)
        构造具有指定源组件，类型，时间，修饰符，坐标，绝对坐标，点击计数，弹出触发标志和按钮编号的MouseEvent对象。

        创建无效事件（例如通过使用多个旧的_MASK或不匹配的修饰符/按钮值）导致未指定的行为。 即使将相对和绝对坐标的不一致值传递给构造函数，仍然创建鼠标事件实例，并且不会抛出任何异常。 此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 指示事件类型的整数。 有关允许值的信息，请参阅MouseEvent的类描述
        when - 给出事件发生时间的长整数。 不建议传递负值或零值
        modifiers - 描述在事件期间关闭的修饰符键和鼠标按钮（例如shift，ctrl，alt和meta）的修饰符掩码。 只允许使用扩展修饰符作为此参数的值（有关扩展修饰符的描述，请参阅InputEvent.getModifiersEx()类）。 不推荐传递负参数。 零值表示没有通过修饰符
        x - 鼠标位置的水平x坐标。 允许传递负值
        y - 鼠标位置的垂直y坐标。 允许传递负值
        xAbs - 鼠标位置的绝对水平x坐标允许传递负值
        yAbs - 鼠标位置的绝对垂直y坐标允许传递负值
        clickCount - 与事件关联的鼠标点击次数。 不推荐传递负值
        popupTrigger - 如果此事件是弹出菜单的触发器，则该值为 true的布尔值
        button - 一个整数，指示哪个鼠标按钮已更改其状态。 以下规则适用于此参数：
        • 如果扩展的鼠标按钮的支持是disabled被Java则允许创建MouseEvent个与标准按钮对象： NOBUTTON ， BUTTON1 ， BUTTON2 ，并BUTTON3 。
        • 如果通过Java支持扩展鼠标按键是enabled ，则允许使用标准按钮创建MouseEvent对象。 如果通过Java支持扩展鼠标按钮是enabled ，那么除了标准按钮之外，如果鼠标有三个以上的按钮， MouseEvent可以使用从4到MouseInfo.getNumberOfButtons()之间的范围内的按钮创建MouseEvent对象。
        异常
        IllegalArgumentException - 如果 button小于零
        IllegalArgumentException - 如果 source为空
        IllegalArgumentException - 如果 button大于BUTTON3，并且对扩展鼠标按钮的支持是 disabled由Java
        IllegalArgumentException - 如果 button大于 current number of buttons，并且对于扩展鼠标按钮的支持是 enabled由Java
        IllegalArgumentException - 如果传递无效的 button值
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.6
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
InputEvent.getWhen() ，
InputEvent.getModifiers() ，
getX() ，
getY() ，
getXOnScreen() ，
getYOnScreen() ，
getClickCount() ，
isPopupTrigger() ，
getButton() ，
button ，
Toolkit.areExtraMouseButtonsEnabled() ，
MouseInfo.getNumberOfButtons() ，
InputEvent.getMaskForButton(int)

    • 方法详细信息

      • getLocationOnScreen

        public Point getLocationOnScreen​()
        返回事件的绝对x，y位置。 在桌面区域可以跨越多个物理屏幕设备的虚拟设备多屏幕环境中，这些坐标相对于虚拟坐标系。 否则，这些坐标是相对于与组件的GraphicsConfiguration关联的坐标系。
        结果
        一个包含绝对x和y坐标的 Point对象。
        从以下版本开始：
        1.6
        另请参见：
        GraphicsConfiguration

      • getXOnScreen

        public int getXOnScreen​()
        返回事件的绝对水平x位置。 在桌面区域可跨越多个物理屏幕设备的虚拟设备多屏幕环境中，该坐标相对于虚拟坐标系。 否则，该坐标是相对于与组件的GraphicsConfiguration相关联的坐标系。
        结果
        x表示绝对水平位置的整数。
        从以下版本开始：
        1.6
        另请参见：
        GraphicsConfiguration

      • getYOnScreen

        public int getYOnScreen​()
        返回事件的绝对垂直y位置。 在桌面区域可跨越多个物理屏幕设备的虚拟设备多屏幕环境中，该坐标相对于虚拟坐标系。 否则，该坐标是相对于与组件的GraphicsConfiguration相关联的坐标系。
        结果
        y表示绝对垂直位置的整数。
        从以下版本开始：
        1.6
        另请参见：
        GraphicsConfiguration

      • getModifiersEx

        public int getModifiersEx​()
        返回此事件的扩展修饰符掩码。

        扩展修饰符是以_DOWN_MASK后缀结尾的修饰符，如ALT_DOWN_MASK，BUTTON1_DOWN_MASK等。

        扩展修饰符表示所有模态键的状态，如ALT，CTRL，META和事件发生后的鼠标按钮。

        例如，如果用户按下按钮1跟随按钮2 ，然后以相同的顺序释放它们，则生成以下事件序列：

          MOUSE_PRESSED:  BUTTON1_DOWN_MASK
    MOUSE_PRESSED:  BUTTON1_DOWN_MASK | BUTTON2_DOWN_MASK
    MOUSE_RELEASED: BUTTON2_DOWN_MASK
    MOUSE_CLICKED:  BUTTON2_DOWN_MASK
    MOUSE_RELEASED:
    MOUSE_CLICKED:

        不建议使用==比较此方法的返回值，因为将来可以添加新的修饰符。 例如，检查SHIFT和BUTTON1是否正常，但是CTRL已经起作用的适当方法可以通过以下代码来证明：

          int onmask = SHIFT_DOWN_MASK | BUTTON1_DOWN_MASK;
    int offmask = CTRL_DOWN_MASK;
    if ((event.getModifiersEx() & (onmask | offmask)) == onmask) {
        ...
    }
        即使添加了新的修饰符，上述代码也可以正常工作。
        重写：
        getModifiersEx在 InputEvent
        结果
        此事件的扩展修饰符掩码

      • getX

        public int getX​()
        返回事件相对于源组件的水平x位置。
        结果
        x表示相对于组件的水平位置的整数

      • getY

        public int getY​()
        返回事件相对于源组件的垂直y位置。
        结果
        y表示相对于组件的垂直位置的整数

      • getPoint

        public Point getPoint​()
        返回事件相对于源组件的x，y位置。
        结果
        一个 Point对象，包含相对于源组件的x和y坐标

      • translatePoint

        public void translatePoint​(int x,
                           int y)
        通过添加指定的 x （水平）和 y （垂直）偏移量将事件的坐标转换为新位置。
        参数
        x - 要添加到当前x坐标位置的水平x值
        y - 要添加到当前y坐标位置的垂直y值

      • getClickCount

        public int getClickCount​()
        返回与此事件关联的鼠标点击次数。
        结果
        点击次数的整数值

      • getButton

        public int getButton​()
        返回哪个鼠标按钮（如果有）已更改状态。 返回值的范围为0到MouseInfo.getNumberOfButtons() 。 返回值至少包含以下常数：
        • NOBUTTON
        • BUTTON1
        • BUTTON2
        • BUTTON3
        允许使用这些常量与应用程序中返回的按钮编号进行比较。 例如，
          if (anEvent.getButton() == MouseEvent.BUTTON1) {
        特别地，对于具有一个，两个或三个按钮的鼠标，该方法可以返回以下值：
        • 0（ NOBUTTON ）
        • 1（ BUTTON1 ）
        • 2（ BUTTON2 ）
        • 3（ BUTTON3 ）
        大于BUTTON3按钮号码不具有常量标识符。 因此，如果安装了五个按钮的鼠标，此方法可能会返回以下值：
        • 0（ NOBUTTON ）
        • 1（ BUTTON1 ）
        • 2（ BUTTON2 ）
        • 3（ BUTTON3 ）
        • 4
        • 五

        注意：如果通过Java支持扩展鼠标按钮是disabled ，则AWT事件子系统不会为扩展鼠标按钮生成鼠标事件。 因此，它并不期望该方法返回任何东西，除了NOBUTTON ， BUTTON1 ， BUTTON2 ， BUTTON3 。

        结果
        从0到MouseInfo.getNumberOfButtons()的值之一，如果通过Java支持扩展鼠标按键是enabled 。 该范围包括NOBUTTON ， BUTTON1 ， BUTTON2 ， BUTTON3 ;
        NOBUTTON ， BUTTON1 ， BUTTON2或BUTTON3如果针对扩展鼠标按键支持是disabled被Java
        从以下版本开始：
        1.4
        另请参见：
        Toolkit.areExtraMouseButtonsEnabled() ， MouseInfo.getNumberOfButtons() ， MouseEvent(Component, int, long, int, int, int, int, int, int, boolean, int) ， InputEvent.getMaskForButton(int)

      • isPopupTrigger

        public boolean isPopupTrigger​()
        返回此鼠标事件是否为平台的弹出菜单触发器事件。

        注意 ：弹出菜单在不同的系统上触发不同。 因此， isPopupTrigger应检查mousePressed和mouseReleased以获得正确的跨平台功能。

        结果
        boolean，如果此事件是此平台的弹出菜单触发器，则为true

      • getMouseModifiersText

        public static String getMouseModifiersText​(int modifiers)
        返回描述在事件期间关闭的修改键和鼠标按钮的String实例，例如“Shift”或“Ctrl + Shift”。 这些字符串可以通过更改awt.properties文件进行本地化。

        请注意， InputEvent.ALT_MASK和InputEvent.BUTTON2_MASK具有相等的值，因此为两个修饰符返回“Alt”字符串。 同样， InputEvent.META_MASK和InputEvent.BUTTON3_MASK具有相等的值，因此为两个修饰符返回“Meta”字符串。

        请注意，传递负参数不正确，将返回未指定的字符串。 零参数意味着没有修改器被传递并且将导致返回一个空字符串。

        参数
        modifiers - 描述在事件期间关闭的修饰符键和鼠标按钮的修改器蒙版
        结果
        在事件期间关闭的修改键和鼠标按钮的组合的字符串字符串文本描述
        从以下版本开始：
        1.4
        另请参见：
        InputEvent.getModifiersExText(int)

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 ComponentEvent
        结果
        a string identifying the event and its attributes
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface MouseListener

  • All Superinterfaces:
    EventListener
    All Known Subinterfaces:
    MouseInputListener
    所有已知实现类：
    AWTEventMulticaster ， BasicButtonListener ， BasicComboPopup.InvocationMouseHandler ， BasicComboPopup.ListMouseHandler ， BasicDesktopIconUI.MouseInputHandler ， BasicFileChooserUI.DoubleClickListener ， BasicInternalFrameUI.BorderListener ， BasicInternalFrameUI.GlassPaneDispatcher ， BasicListUI.MouseInputHandler ， BasicMenuItemUI.MouseInputHandler ， BasicMenuUI.MouseInputHandler ， BasicScrollBarUI.ArrowButtonListener ， BasicScrollBarUI.TrackListener ， BasicSliderUI.TrackListener ， BasicSplitPaneDivider.MouseHandler ， BasicTabbedPaneUI.MouseHandler ， BasicTableHeaderUI.MouseInputHandler ， BasicTableUI.MouseInputHandler ， BasicTextUI.BasicCaret ， BasicToolBarUI.DockingListener ， BasicTreeUI.MouseHandler ， BasicTreeUI.MouseInputHandler ， DefaultCaret ， FormView.MouseEventListener ， HTMLEditorKit.LinkController ， MetalFileChooserUI.SingleClickListener ， MetalToolBarUI.MetalDockingListener ， MouseAdapter ， MouseDragGestureRecognizer ， MouseInputAdapter ， ToolTipManager

    public interface MouseListener
extends EventListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。 （要跟踪鼠标移动和鼠标拖动，请使用MouseMotionListener ）

    有兴趣处理鼠标事件的类可以实现这个接口（和它包含的所有方法），或扩展抽象的MouseAdapter类（仅覆盖感兴趣的方法）。

    然后使用该组件的addMouseListener方法将从该类创建的侦听器对象注册到组件。 当鼠标被按下，释放点击（按下并释放）时，会生成鼠标事件。 当鼠标光标进入或离开组件时，也会生成鼠标事件。 当鼠标事件发生时，将调用侦听器对象中的相关方法，并将其传递给该对象MouseEvent 。

    从以下版本开始：
    1.1
    另请参见：
    MouseAdapter ， MouseEvent ， Tutorial: Writing a Mouse Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void mouseClicked​(MouseEvent e)
      在组件上单击（按下并释放）鼠标按钮时调用。
      void mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void mousePressed​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。

    • 方法详细信息

      • mouseClicked

        void mouseClicked​(MouseEvent e)
        在组件上单击（按下并释放）鼠标按钮时调用。
        参数
        e - 要处理的事件

      • mousePressed

        void mousePressed​(MouseEvent e)
        在组件上按下鼠标按钮时调用。
        参数
        e - 要处理的事件

      • mouseReleased

        void mouseReleased​(MouseEvent e)
        在组件上释放鼠标按钮时调用。
        参数
        e - 要处理的事件

      • mouseEntered

        void mouseEntered​(MouseEvent e)
        当鼠标进入组件时调用。
        参数
        e - 要处理的事件

      • mouseExited

        void mouseExited​(MouseEvent e)
        当鼠标退出组件时调用。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseMotionAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class MouseMotionAdapter

  • java.lang.Object
    • java.awt.event.MouseMotionAdapter
  • All Implemented Interfaces:
    MouseMotionListener ， EventListener
    已知直接子类：
    BasicComboPopup.InvocationMouseMotionHandler ， BasicComboPopup.ListMouseMotionHandler

    public abstract class MouseMotionAdapter
extends Object
implements MouseMotionListener
    用于接收鼠标运动事件的抽象适配器类。 这个类中的方法是空的。 此类作为创建侦听器对象的方便而存在。

    当鼠标移动或拖动时，会发生鼠标移动事件。 （许多这样的事件将在正常程序中生成。要跟踪点击次数和其他鼠标事件，请使用MouseAdapter。）

    扩展此类以创建一个MouseEvent监听器，并覆盖感兴趣的事件的方法。 （如果您实现了MouseMotionListener接口，则必须定义其中的所有方法，这个抽象类为它们定义了空方法，因此您只能定义关心事件的方法。）

    使用扩展类创建侦听器对象，然后使用组件的addMouseMotionListener方法将其注册到组件。 移动或拖动鼠标时，将调用侦听器对象中的相关方法，并将其传递给其中的MouseEvent 。

    从以下版本开始：
    1.1
    另请参见：
    MouseEvent ， MouseMotionListener ， Tutorial: Writing a Mouse Motion Listener

    • 构造方法摘要

      构造方法
      Constructor 描述
      MouseMotionAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void mouseMoved​(MouseEvent e)
      在组件上移动鼠标按钮时调用（没有按钮没有关闭）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MouseMotionAdapter

        public MouseMotionAdapter​()

    • 方法详细信息

      • mouseDragged

        public void mouseDragged​(MouseEvent e)
        在组件上按下鼠标按钮然后拖动时调用。 鼠标拖动事件将继续传递到第一个起始的组件，直到鼠标按钮释放（无论鼠标位置是否在组件的边界内）。
        Specified by:
        mouseDragged在接口 MouseMotionListener
        参数
        e - 要处理的事件

      • mouseMoved

        public void mouseMoved​(MouseEvent e)
        在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
        Specified by:
        mouseMoved在接口 MouseMotionListener
        参数
        e - the event to be processed
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseMotionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface MouseMotionListener

  • All Superinterfaces:
    EventListener
    All Known Subinterfaces:
    MouseInputListener
    所有已知实现类：
    AWTEventMulticaster ， BasicButtonListener ， BasicComboPopup.InvocationMouseHandler ， BasicComboPopup.InvocationMouseMotionHandler ， BasicComboPopup.ListMouseHandler ， BasicComboPopup.ListMouseMotionHandler ， BasicDesktopIconUI.MouseInputHandler ， BasicFileChooserUI.DoubleClickListener ， BasicInternalFrameUI.BorderListener ， BasicInternalFrameUI.GlassPaneDispatcher ， BasicListUI.MouseInputHandler ， BasicMenuItemUI.MouseInputHandler ， BasicMenuUI.MouseInputHandler ， BasicScrollBarUI.ArrowButtonListener ， BasicScrollBarUI.TrackListener ， BasicSliderUI.TrackListener ， BasicSplitPaneDivider.MouseHandler ， BasicTabbedPaneUI.MouseHandler ， BasicTableHeaderUI.MouseInputHandler ， BasicTableUI.MouseInputHandler ， BasicTextUI.BasicCaret ， BasicToolBarUI.DockingListener ， BasicTreeUI.MouseHandler ， BasicTreeUI.MouseInputHandler ， DefaultCaret ， FormView.MouseEventListener ， HTMLEditorKit.LinkController ， MetalFileChooserUI.SingleClickListener ， MetalToolBarUI.MetalDockingListener ， MouseAdapter ， MouseDragGestureRecognizer ， MouseInputAdapter ， MouseMotionAdapter ， ToolTipManager

    public interface MouseMotionListener
extends EventListener
    用于在组件上接收鼠标运动事件的侦听器界面。 （对于点击和其他鼠标事件，请使用MouseListener ）

    有兴趣处理鼠标运动事件的类可以实现这个接口（和它包含的所有方法），或扩展抽象的MouseMotionAdapter类（仅覆盖感兴趣的方法）。

    然后使用该组件的addMouseMotionListener方法向该组件注册从该类创建的侦听器对象。 鼠标移动或拖动时会生成鼠标移动事件。 （将会生成许多这样的事件）。 当鼠标移动事件发生时，在听者对象中的相关方法被调用，并且MouseEvent被传递给它。

    从以下版本开始：
    1.1
    另请参见：
    MouseMotionAdapter ， MouseEvent ， Tutorial: Writing a Mouse Motion Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。

    • 方法详细信息

      • mouseDragged

        void mouseDragged​(MouseEvent e)
        在组件上按下鼠标按钮然后拖动时调用。 MOUSE_DRAGGED事件将继续传递到拖动发起的组件，直到鼠标按钮释放（无论鼠标位置是否在组件的边界内）。

        由于与平台相关的拖放实现， MOUSE_DRAGGED事件可能无法在本地拖放操作期间传递。

        参数
        e - 要处理的事件

      • mouseMoved

        void mouseMoved​(MouseEvent e)
        当鼠标光标移动到组件上但没有按钮被按下时调用。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseWheelEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class MouseWheelEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
            • java.awt.event.MouseEvent
              • java.awt.event.MouseWheelEvent
  • All Implemented Interfaces:
    Serializable

    public class MouseWheelEvent
extends MouseEvent
    指示鼠标轮在组件中旋转的事件。

    轮鼠标是具有代替中间按钮的轮的鼠标。 该轮可以朝向或远离用户旋转。 鼠标滚轮最常用于滚动，虽然其他用途是可能的。

    将MouseWheelEvent对象传递给每个MouseWheelListener对象，该对象使用组件的addMouseWheelListener方法注册接收“有趣”的鼠标事件。 每个这样的侦听器对象得到包含鼠标事件的MouseEvent 。

    由于鼠标滚轮与滚动组件的特殊关系，MouseWheelEvents的传递与其他MouseEvents有所不同。 这是因为当其他MouseEvents通常影响鼠标光标下方的组件更改（例如，单击按钮时），MouseWheelEvents通常会从鼠标光标中移除效果（在ScrollPane中的组件上移动滚轮滚动ScrollPane上的滚动条之一）。

    MouseWheelEvents从鼠标光标下面的组件开始传递。 如果在组件上未启用MouseWheelEvents，那么事件将被发送到启用了MouseWheelEvents的第一个祖先Container。 这通常是启用滚轮滚动的ScrollPane。 源组件和x，y坐标将相对于事件的最终目标（ScrollPane）。 这样就可以将一个复杂的GUI安装到一个ScrollPane中，而不用修改ScrollPane，并将所有的MouseWheelEvents传递给ScrollPane进行滚动。

    一些AWT组件使用显示自己的滚动条并处理自己的滚动条的本机部件实现。 这是真实的特定组件将因平台而异。 当鼠标滚轮移动到这些组件之一时，事件将直接传递到本机窗口小部件，而不会传播到祖先。

    平台可以自定义当鼠标滚轮移动时应该发生的滚动量。 两个最常见的设置是滚动一定数量的“单位”（通常在基于文本的组件中的文本行）或整个“块”（类似于页面上/下/下）。 MouseWheelEvent提供了符合底层平台设置的方法。 这些平台设置可以随时由用户进行更改。 MouseWheelEvents反映最近的设置。

    MouseWheelEvent课程包括获取旋转鼠标滚轮的“点击次数”的方法。 getWheelRotation()方法返回与轮的旋转次数相对应的“点击次数”整数。 除了这种方法之外， MouseWheelEvent类还提供了getPreciseWheelRotation()方法，它可以在发生部分旋转的情况下返回双倍数量的“点击”。 如果鼠标支持高分辨率车轮，例如自由旋转的车轮，无凹槽，则getPreciseWheelRotation()方法非常有用。 应用程序可以通过使用这种方法更精确地处理鼠标滚轮事件，从而使视觉感知更平滑。

    从以下版本开始：
    1.4
    另请参见：
    MouseWheelListener ， ScrollPane ， ScrollPane.setWheelScrollingEnabled(boolean) ， JScrollPane ， JScrollPane.setWheelScrollingEnabled(boolean) ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int WHEEL_BLOCK_SCROLL
      表示通过“块”滚动的常量（如滚动页面向下，向下翻页键）
      static int WHEEL_UNIT_SCROLL
      表示以“单位”滚动的常量（如用箭头键滚动）

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

      • Fields inherited from class java.awt.event.InputEvent

        ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK

      • Fields inherited from class java.awt.event.MouseEvent

        BUTTON1, BUTTON2, BUTTON3, MOUSE_CLICKED, MOUSE_DRAGGED, MOUSE_ENTERED, MOUSE_EXITED, MOUSE_FIRST, MOUSE_LAST, MOUSE_MOVED, MOUSE_PRESSED, MOUSE_RELEASED, MOUSE_WHEEL, NOBUTTON

    • 构造方法摘要

      构造方法
      Constructor 描述
      MouseWheelEvent​(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
      构造具有指定源组件，类型，修饰符，坐标，滚动类型，滚动量和轮转的 MouseWheelEvent对象。
      MouseWheelEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
      使用指定的源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮子旋转构造一个 MouseWheelEvent对象。
      MouseWheelEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation, double preciseWheelRotation)
      构造具有指定的源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮子旋转的 MouseWheelEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getPreciseWheelRotation​()
      返回鼠标滚轮旋转的“点击次数”为双倍。
      int getScrollAmount​()
      返回每次点击鼠标滚轮旋转时应滚动的单位数。
      int getScrollType​()
      返回响应此事件应该发生的滚动类型。
      int getUnitsToScroll​()
      这是一个方便的方法来帮助实现常用的MouseWheelListener - 将ScrollPane或JScrollPane滚动一个符合平台设置的量。
      int getWheelRotation​()
      返回鼠标滚轮旋转的“点击次数”为整数。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        getID, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.awt.event.InputEvent

        consume, getMaskForButton, getModifiers, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown

      • Methods inherited from class java.awt.event.MouseEvent

        getButton, getClickCount, getLocationOnScreen, getModifiersEx, getMouseModifiersText, getPoint, getX, getXOnScreen, getY, getYOnScreen, isPopupTrigger, translatePoint

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • WHEEL_UNIT_SCROLL

        @Native
public static final int WHEEL_UNIT_SCROLL
        表示以“单位”滚动的常量（如用箭头键滚动）
        另请参见：
        getScrollType() ， Constant Field Values

      • WHEEL_BLOCK_SCROLL

        @Native
public static final int WHEEL_BLOCK_SCROLL
        表示通过“块”滚动的常量（如滚动页面向下，向下翻页键）
        另请参见：
        getScrollType() ， Constant Field Values

    • 构造方法详细信息

      • MouseWheelEvent

        public MouseWheelEvent​(Component source,
                       int id,
                       long when,
                       int modifiers,
                       int x,
                       int y,
                       int clickCount,
                       boolean popupTrigger,
                       int scrollType,
                       int scrollAmount,
                       int wheelRotation)
        使用指定的源组件，类型，修饰符，坐标，滚动类型，滚动量和轮子旋转构造一个MouseWheelEvent对象。

        绝对坐标xAbs和yAbs被设置为屏幕上的源位置加上相对坐标x和y。 如果源未显示，则xAbs和yAb设置为零。

        请注意，传递无效的id导致未指定的行为。 此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Component
        id - 标识事件的整数
        when - 一个很长的时间，给出事件发生的时间
        modifiers - 修改键在事件期间向下（shift，ctrl，alt，meta）
        x - 鼠标位置的水平x坐标
        y - 鼠标位置的垂直y坐标
        clickCount - 与事件关联的鼠标点击次数
        popupTrigger - 一个布尔值，如果此事件是弹出菜单的触发器，则为true
        scrollType - 响应于此事件应该发生的滚动类型; 有效值为WHEEL_UNIT_SCROLL和WHEEL_BLOCK_SCROLL
        scrollAmount - 对于scrollType WHEEL_UNIT_SCROLL ，要滚动的单位数
        wheelRotation - 旋转鼠标滚轮的“点击次数”的整数
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        MouseEvent(java.awt.Component, int, long, int, int, int, int, boolean) ， MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)

      • MouseWheelEvent

        public MouseWheelEvent​(Component source,
                       int id,
                       long when,
                       int modifiers,
                       int x,
                       int y,
                       int xAbs,
                       int yAbs,
                       int clickCount,
                       boolean popupTrigger,
                       int scrollType,
                       int scrollAmount,
                       int wheelRotation)
        使用指定的源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮子旋转构造一个MouseWheelEvent对象。

        请注意，传递无效的id导致未指定的行为。 此方法抛出IllegalArgumentException如果source为null 。

        即使将相对和绝对坐标的不一致值传递给构造函数，仍将创建MouseWheelEvent实例，并且不会抛出任何异常。

        参数
        source - 发起事件的 Component
        id - 标识事件的整数
        when - 一个很长的时间，给出事件发生的时间
        modifiers - 修改器在事件期间按下（shift，ctrl，alt，meta）
        x - 鼠标位置的水平x坐标
        y - 鼠标位置的垂直y坐标
        xAbs - 鼠标位置的绝对水平x坐标
        yAbs - 鼠标位置的绝对垂直y坐标
        clickCount - 与事件关联的鼠标点击次数
        popupTrigger - 一个布尔值，如果此事件是弹出菜单的触发器，则为true
        scrollType - 响应于此事件应该发生的滚动类型; 有效值为WHEEL_UNIT_SCROLL和WHEEL_BLOCK_SCROLL
        scrollAmount - 对于scrollType WHEEL_UNIT_SCROLL ，要滚动的单位数
        wheelRotation - 旋转鼠标滚轮的“点击次数”的整数
        异常
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.6
        另请参见：
        MouseEvent(java.awt.Component, int, long, int, int, int, int, boolean) ， MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)

      • MouseWheelEvent

        public MouseWheelEvent​(Component source,
                       int id,
                       long when,
                       int modifiers,
                       int x,
                       int y,
                       int xAbs,
                       int yAbs,
                       int clickCount,
                       boolean popupTrigger,
                       int scrollType,
                       int scrollAmount,
                       int wheelRotation,
                       double preciseWheelRotation)
        使用指定的源组件，类型，修饰符，坐标，绝对坐标，滚动类型，滚动量和轮子旋转构造一个MouseWheelEvent对象。

        请注意，传入无效的id参数会导致未指定的行为。 此方法抛出IllegalArgumentException如果source等于null 。

        即使将相对和绝对坐标的不一致值传递给构造函数，仍将创建一个MouseWheelEvent实例，也不会抛出任何异常。

        参数
        source - 发起事件的 Component
        id - 标识事件的整数值
        when - 给出事件发生时间的长 when数值
        modifiers - 修改键在事件期间向下（shift，ctrl，alt，meta）
        x - 水平 x坐标的鼠标位置
        y - 垂直的 y坐标的鼠标位置
        xAbs - 鼠标位置的绝对水平坐标 x
        yAbs - 鼠标位置的绝对垂直坐标 y
        clickCount - 与事件关联的鼠标点击次数
        popupTrigger - 一个布尔值， true如果此事件是弹出菜单的触发器
        scrollType - 响应此事件应该发生的滚动类型; 有效值为WHEEL_UNIT_SCROLL和WHEEL_BLOCK_SCROLL
        scrollAmount - 对于scrollType WHEEL_UNIT_SCROLL ，要滚动的单位数
        wheelRotation - 旋转鼠标滚轮的“点击次数”的整数
        preciseWheelRotation - 旋转鼠标滚轮的双击“点击次数”
        异常
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.7
        另请参见：
        MouseEvent(java.awt.Component, int, long, int, int, int, int, boolean) ， MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)

    • 方法详细信息

      • getScrollType

        public int getScrollType​()
        返回响应此事件应该发生的滚动类型。 这是由本机平台决定的。 合法价值是：
        • MouseWheelEvent.WHEEL_UNIT_SCROLL
        • MouseWheelEvent.WHEEL_BLOCK_SCROLL
        结果
        MouseWheelEvent.WHEEL_UNIT_SCROLL或MouseWheelEvent.WHEEL_BLOCK_SCROLL，具体取决于本机平台的配置。
        另请参见：
        Adjustable.getUnitIncrement() ，
Adjustable.getBlockIncrement() ，
Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int) ，
Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

      • getScrollAmount

        public int getScrollAmount​()
        返回每次点击鼠标滚轮旋转时应滚动的单位数。 仅在getScrollType返回MouseWheelEvent.WHEEL_UNIT_SCROLL有效
        结果
        要滚动的单位数，或 getScrollType返回 MouseWheelEvent.WHEEL_BLOCK_SCROLL的未定义值
        另请参见：
        getScrollType()

      • getWheelRotation

        public int getWheelRotation​()
        返回鼠标滚轮旋转的“点击次数”为整数。 如果鼠标支持高分辨率轮，则可能会发生部分旋转。 在这种情况下，该方法返回0，直到累积完整的“点击”为止。
        结果
        如果鼠标滚轮向上/远离用户旋转，则为负值，如果鼠标滚轮朝向用户向下旋转，则为正值
        另请参见：
        getPreciseWheelRotation()

      • getPreciseWheelRotation

        public double getPreciseWheelRotation​()
        返回鼠标滚轮旋转的“点击次数”为双倍。 如果鼠标支持高分辨率轮，则可能会发生部分旋转。 在这种情况下，返回值将包含小数点击。
        结果
        如果鼠标滚轮向上旋转或远离用户，则为负值，如果鼠标滚轮向下旋转或朝向用户旋转，则为正值
        从以下版本开始：
        1.7
        另请参见：
        getWheelRotation()

      • getUnitsToScroll

        public int getUnitsToScroll​()
        这是一个方便的方法来帮助实现常用的MouseWheelListener - 将ScrollPane或JScrollPane滚动一个符合平台设置的量。 （请注意， ScrollPane和JScrollPane已经内置了此功能。）

        当滚动类型为MouseWheelEvent.WHEEL_UNIT_SCROLL时，此方法返回滚动的单位数，只有当getScrollType返回MouseWheelEvent.WHEEL_UNIT_SCROLL时，才能调用getScrollType 。

        滚动方向，车轮移动量和车轮滚动的平台设置都被考虑在内。 此方法不能也不能考虑可调/可滚动单位增量的值，因为这将在滚动组件之间变化。

        在侦听器中如何使用此方法的简化示例：

          mouseWheelMoved(MouseWheelEvent event) {
      ScrollPane sp = getScrollPaneFromSomewhere();
      Adjustable adj = sp.getVAdjustable()
      if (MouseWheelEvent.getScrollType() == WHEEL_UNIT_SCROLL) {
          int totalScrollAmount =
              event.getUnitsToScroll() *
              adj.getUnitIncrement();
          adj.setValue(adj.getValue() + totalScrollAmount);
      }
  }
        结果
        基于鼠标滚轮旋转的方向和数量滚动的单位数量，以及本机平台的滚轮滚动设置
        另请参见：
        getScrollType() ， getScrollAmount() ， MouseWheelListener ， Adjustable ， Adjustable.getUnitIncrement() ， Scrollable ， Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int) ， ScrollPane ， ScrollPane.setWheelScrollingEnabled(boolean) ， JScrollPane ， JScrollPane.setWheelScrollingEnabled(boolean)

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 MouseEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MouseWheelListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface MouseWheelListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicComboPopup.InvocationMouseHandler ， BasicComboPopup.ListMouseHandler ， BasicDesktopIconUI.MouseInputHandler ， BasicFileChooserUI.DoubleClickListener ， BasicInternalFrameUI.BorderListener ， BasicScrollBarUI.ArrowButtonListener ， BasicScrollBarUI.TrackListener ， BasicScrollPaneUI.MouseWheelHandler ， BasicSliderUI.TrackListener ， BasicSplitPaneDivider.MouseHandler ， BasicTabbedPaneUI.MouseHandler ， BasicTreeUI.MouseHandler ， FormView.MouseEventListener ， HTMLEditorKit.LinkController ， MetalFileChooserUI.SingleClickListener ， MouseAdapter ， MouseInputAdapter ， ToolTipManager

    public interface MouseWheelListener
extends EventListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。 （对于点击和其他鼠标事件，请使用MouseListener对于鼠标移动和拖动，请使用MouseMotionListener ）

    有兴趣处理鼠标滚轮事件的类实现了这个接口（以及它包含的所有方法）。

    然后，使用该组件的addMouseWheelListener方法将从该类创建的侦听器对象注册到组件。 当鼠标滚轮旋转时，会产生鼠标滚轮事件。 当鼠标滚轮事件发生时，将调用该对象的mouseWheelMoved方法。

    有关如何调度鼠标滚轮事件的信息，请参阅MouseWheelEvent的类描述。

    从以下版本开始：
    1.4
    另请参见：
    MouseWheelEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void mouseWheelMoved​(MouseWheelEvent e)
      当鼠标滚轮旋转时调用。

    • 方法详细信息

      • mouseWheelMoved

        void mouseWheelMoved​(MouseWheelEvent e)
        当鼠标滚轮旋转时调用。
        参数
        e - 要处理的事件
        另请参见：
        MouseWheelEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PaintEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class PaintEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.PaintEvent
  • All Implemented Interfaces:
    Serializable

    public class PaintEvent
extends ComponentEvent
    组件级paint事件。 此事件是一种特殊类型，用于确保绘画/更新方法调用与从事件队列传递的其他事件一起被序列化。 此事件不适用于事件监听器模型; 程序应该继续覆盖油漆/更新方法，以便正确地渲染它们。

    如果任何特定的PaintEvent实例的id参数不在从PAINT_FIRST到PAINT_LAST的范围内，将会导致未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int PAINT
      油漆事件类型。
      static int PAINT_FIRST
      标记paint事件ID范围的第一个整数id。
      static int PAINT_LAST
      标记paint事件ID范围的最后一个整数id。
      static int UPDATE
      更新事件类型。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      PaintEvent​(Component source, int id, Rectangle updateRect)
      构造具有指定源组件和类型的 PaintEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle getUpdateRect​()
      返回表示需要重绘的区域的矩形，以响应此事件。
      String paramString​()
      返回标识此事件的参数字符串。
      void setUpdateRect​(Rectangle updateRect)
      设置表示需要重新绘制的区域的矩形以响应此事件。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • PAINT_FIRST

        public static final int PAINT_FIRST
        标记paint事件ID范围的第一个整数id。
        另请参见：
        Constant Field Values

      • PAINT_LAST

        public static final int PAINT_LAST
        标记paint事件ID范围的最后一个整数id。
        另请参见：
        Constant Field Values

      • PAINT

        public static final int PAINT
        油漆事件类型。
        另请参见：
        Constant Field Values

      • UPDATE

        public static final int UPDATE
        更新事件类型。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • PaintEvent

        public PaintEvent​(Component source,
                  int id,
                  Rectangle updateRect)
        构造具有指定源组件和类型的PaintEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 事件发生的对象
        id - 标识事件类型的整数。 有关允许值的信息，请参阅PaintEvent的类描述
        updateRect - 需要重新绘制的矩形区域
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ，
AWTEvent.getID() ，
getUpdateRect()

    • 方法详细信息

      • getUpdateRect

        public Rectangle getUpdateRect​()
        返回表示需要重绘的区域的矩形，以响应此事件。
        结果
        该矩形表示响应于此事件需要重新绘制的区域

      • setUpdateRect

        public void setUpdateRect​(Rectangle updateRect)
        设置表示需要重新绘制的区域的矩形以响应此事件。
        参数
        updateRect - 需要重新绘制的矩形区域

      • paramString

        public String paramString​()
        描述从类复制： ComponentEvent
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 ComponentEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class TextEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.TextEvent
  • All Implemented Interfaces:
    Serializable

    public class TextEvent
extends AWTEvent
    表示对象的文本改变的语义事件。 这个高级别事件是由对象（如TextComponent）在其文本更改时生成的。 该事件被传递给使用组件的addTextListener方法注册接收此类事件的每个TextListener对象。

    当事件发生时，实现TextListener接口的对象获得此TextEvent 。 监听器免除处理单个鼠标移动和关键笔划的细节，而不是像“文本改变”那样处理一个“有意义的”（语义）事件。

    如果任何特定TextEvent实例的id参数不在TEXT_FIRST到TEXT_LAST之间，将会引起未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    TextComponent ， TextListener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TEXT_FIRST
      用于文本事件的ids范围中的第一个数字。
      static int TEXT_LAST
      用于文本事件的ids范围中的最后一个数字。
      static int TEXT_VALUE_CHANGED
      此事件id表示对象的文本已更改。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextEvent​(Object source, int id)
      构造一个 TextEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String paramString​()
      返回标识此文本事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TEXT_FIRST

        public static final int TEXT_FIRST
        用于文本事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • TEXT_LAST

        public static final int TEXT_LAST
        用于文本事件的ids范围中的最后一个数字。
        另请参见：
        Constant Field Values

      • TEXT_VALUE_CHANGED

        public static final int TEXT_VALUE_CHANGED
        此事件id表示对象的文本已更改。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TextEvent

        public TextEvent​(Object source,
                 int id)
        构造一个TextEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的（ TextComponent ）对象
        id - 标识事件类型的整数。 有关允许值的信息，请参阅TextEvent的类说明
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        EventObject.getSource() ， AWTEvent.getID()

    • 方法详细信息

      • paramString

        public String paramString​()
        返回标识此文本事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 AWTEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface TextListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， TextArea.AccessibleAWTTextArea ， TextComponent.AccessibleAWTTextComponent ， TextField.AccessibleAWTTextField

    public interface TextListener
extends EventListener
    用于接收文本事件的侦听器界面。 对处理文本事件感兴趣的类实现此接口。 然后使用该类创建的对象使用组件的addTextListener方法向组件注册。 当组件的文本更改时，将调用侦听器对象的textValueChanged方法。
    从以下版本开始：
    1.1
    另请参见：
    TextEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void textValueChanged​(TextEvent e)
      当文本的值已更改时调用。

    • 方法详细信息

      • textValueChanged

        void textValueChanged​(TextEvent e)
        当文本的值已更改时调用。 为此方法编写的代码执行文本更改时需要执行的操作。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.event (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.event

  • Packages that use java.awt.event
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
  • Classes in java.awt.event used by com.sun.java.accessibility.util
    Class 描述
    ActionListener
    用于接收动作事件的侦听器界面。
    AdjustmentListener
    用于接收调整事件的侦听器接口。
    AWTEventListener
    用于接收分派到作为Component或MenuComponent或其子类的实例的对象的事件的侦听器接口。
    ComponentListener
    用于接收组件事件的侦听器接口。
    ContainerListener
    用于接收容器事件的侦听器接口。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    ItemListener
    用于接收项目事件的侦听器接口。
    KeyListener
    用于接收键盘事件（按键）的侦听器界面。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    TextListener
    用于接收文本事件的侦听器界面。
    WindowListener
    用于接收窗口事件的侦听器界面。
  • Classes in java.awt.event used by java.awt
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
    AdjustmentEvent
    可调整对象发出的调整事件，如Scrollbar和ScrollPane 。
    AdjustmentListener
    用于接收调整事件的侦听器接口。
    AWTEventListener
    用于接收分派到作为Component或MenuComponent或其子类的实例的对象的事件的侦听器接口。
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    ComponentListener
    用于接收组件事件的侦听器接口。
    ContainerEvent
    低级别事件，表示容器的内容因添加或删除组件而发生更改。
    ContainerListener
    用于接收容器事件的侦听器接口。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    FocusEvent.Cause
    这个枚举代表了一个 FocusEvent的原因 - 其发生的原因。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    HierarchyBoundsListener
    用于接收祖先移动和调整大小的事件的侦听器接口。
    HierarchyEvent
    表示对 Component所属的 Component层次结构进行更改的事件。
    HierarchyListener
    用于接收层次结构的侦听器界面更改事件。
    InputMethodEvent
    输入法事件包含使用输入法组合的文本信息。
    InputMethodListener
    用于接收输入法事件的侦听器接口。
    ItemEvent
    表示选择或取消选择项目的语义事件。
    ItemListener
    用于接收项目事件的侦听器接口。
    KeyEvent
    指示组件中发生击键的事件。
    KeyListener
    用于接收键盘事件（按键）的侦听器界面。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelEvent
    指示鼠标轮在组件中旋转的事件。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
    TextEvent
    表示对象的文本改变的语义事件。
    TextListener
    用于接收文本事件的侦听器界面。
    WindowEvent
    指示窗口已更改其状态的低级别事件。
    WindowFocusListener
    收听界面接收 WindowEvents ，其中 WINDOW_GAINED_FOCUS和 WINDOW_LOST_FOCUS事件。
    WindowListener
    用于接收窗口事件的侦听器界面。
    WindowStateListener
    用于接收窗口状态事件的侦听器接口。
  • Classes in java.awt.event used by java.awt.dnd
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
    InputEvent
    所有组件级输入事件的根事件类。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
  • Classes in java.awt.event used by java.awt.event
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    AdjustmentEvent
    可调整对象发出的调整事件，如Scrollbar和ScrollPane 。
    AWTEventListener
    用于接收分派到作为Component或MenuComponent或其子类的实例的对象的事件的侦听器接口。
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    ComponentListener
    用于接收组件事件的侦听器接口。
    ContainerEvent
    低级别事件，表示容器的内容因添加或删除组件而发生更改。
    ContainerListener
    用于接收容器事件的侦听器接口。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    FocusEvent.Cause
    这个枚举代表了一个 FocusEvent的原因 - 它发生的原因。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    HierarchyBoundsListener
    用于接收祖先移动和调整大小的事件的侦听器接口。
    HierarchyEvent
    指示对 Component所属的 Component层次结构进行更改的事件。
    InputEvent
    所有组件级输入事件的根事件类。
    InputMethodEvent
    输入法事件包含使用输入法组合的文本信息。
    ItemEvent
    表示选择或取消选择项目的语义事件。
    KeyEvent
    指示组件中发生击键的事件。
    KeyListener
    用于接收键盘事件（按键）的侦听器界面。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelEvent
    指示鼠标轮在组件中旋转的事件。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
    TextEvent
    表示对象的文本改变的语义事件。
    WindowEvent
    指示窗口已更改其状态的低级别事件。
    WindowFocusListener
    收听界面接收 WindowEvents ，其中包括 WINDOW_GAINED_FOCUS和 WINDOW_LOST_FOCUS事件。
    WindowListener
    用于接收窗口事件的侦听器界面。
    WindowStateListener
    用于接收窗口状态事件的侦听器接口。
  • Classes in java.awt.event used by javafx.embed.swing
    Class 描述
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    HierarchyEvent
    表示对 Component所属的 Component层次结构进行更改的事件。
    InputMethodEvent
    输入法事件包含使用输入法组合的文本信息。
    KeyEvent
    指示组件中发生击键的事件。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseWheelEvent
    指示鼠标轮在组件中旋转的事件。
  • Classes in java.awt.event used by javax.accessibility
    Class 描述
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
  • Classes in java.awt.event used by javax.swing
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
    AdjustmentListener
    用于接收调整事件的侦听器接口。
    ComponentAdapter
    用于接收组件事件的抽象适配器类。
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    ComponentListener
    用于接收组件事件的侦听器接口。
    ContainerEvent
    低级别事件，表示容器的内容因添加或删除组件而发生更改。
    ContainerListener
    用于接收容器事件的侦听器接口。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    FocusEvent.Cause
    这个枚举代表了一个 FocusEvent的原因 - 其发生的原因。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    InputEvent
    所有组件级输入事件的根事件类。
    InputMethodEvent
    输入法事件包含使用输入法组合的文本信息。
    ItemEvent
    表示选择或取消选择项目的语义事件。
    ItemListener
    用于接收项目事件的侦听器接口。
    KeyEvent
    指示组件中发生击键的事件。
    MouseAdapter
    用于接收鼠标事件的抽象适配器类。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
    WindowAdapter
    用于接收窗口事件的抽象适配器类。
    WindowEvent
    指示窗口已更改其状态的低级别事件。
    WindowFocusListener
    收听界面接收 WindowEvents ，其中包括 WINDOW_GAINED_FOCUS和 WINDOW_LOST_FOCUS事件。
    WindowListener
    用于接收窗口事件的侦听器界面。
    WindowStateListener
    用于接收窗口状态事件的侦听器接口。
  • Classes in java.awt.event used by javax.swing.event
    Class 描述
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    InputEvent
    所有组件级输入事件的根事件类。
    KeyEvent
    指示组件中发生击键的事件。
    MouseAdapter
    用于接收鼠标事件的抽象适配器类。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
  • Classes in java.awt.event used by javax.swing.plaf
    Class 描述
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    HierarchyEvent
    表示对 Component所属的 Component层次结构进行更改的事件。
    InputMethodEvent
    输入法事件包含使用输入法组合的文本信息。
    KeyEvent
    指示组件中发生击键的事件。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseWheelEvent
    指示鼠标轮在组件中旋转的事件。
  • Classes in java.awt.event used by javax.swing.plaf.basic
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
    ComponentAdapter
    用于接收组件事件的抽象适配器类。
    ComponentEvent
    指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
    ComponentListener
    用于接收组件事件的侦听器接口。
    ContainerEvent
    低级别事件，表示容器的内容因添加或删除组件而发生更改。
    ContainerListener
    用于接收容器事件的侦听器接口。
    FocusAdapter
    用于接收键盘焦点事件的抽象适配器类。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    ItemEvent
    表示选择或取消选择项目的语义事件。
    ItemListener
    用于接收项目事件的侦听器接口。
    KeyAdapter
    用于接收键盘事件的抽象适配器类。
    KeyEvent
    指示组件中发生击键的事件。
    KeyListener
    用于接收键盘事件（按键）的侦听器界面。
    MouseAdapter
    用于接收鼠标事件的抽象适配器类。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionAdapter
    用于接收鼠标运动事件的抽象适配器类。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelEvent
    指示鼠标轮在组件中旋转的事件。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
    WindowAdapter
    用于接收窗口事件的抽象适配器类。
    WindowEvent
    指示窗口已更改其状态的低级别事件。
    WindowFocusListener
    收听界面接收 WindowEvents ，其中包括 WINDOW_GAINED_FOCUS和 WINDOW_LOST_FOCUS事件。
    WindowListener
    用于接收窗口事件的侦听器界面。
    WindowStateListener
    用于接收窗口状态事件的侦听器接口。
  • Classes in java.awt.event used by javax.swing.plaf.metal
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
    ContainerListener
    用于接收容器事件的侦听器接口。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    MouseAdapter
    用于接收鼠标事件的抽象适配器类。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
  • Classes in java.awt.event used by javax.swing.plaf.multi
    Class 描述
    MouseEvent
    指示组件中发生鼠标操作的事件。
  • Classes in java.awt.event used by javax.swing.plaf.synth
    Class 描述
    ComponentListener
    用于接收组件事件的侦听器接口。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
  • Classes in java.awt.event used by javax.swing.table
    Class 描述
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    MouseEvent
    指示组件中发生鼠标操作的事件。
  • Classes in java.awt.event used by javax.swing.text
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
    FocusEvent
    指示组件已经获得或丢失了输入焦点的低级事件。
    FocusListener
    用于在组件上接收键盘焦点事件的侦听器界面。
    InputMethodEvent
    输入法事件包含使用输入法组合的文本信息。
    InputMethodListener
    用于接收输入法事件的侦听器接口。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
  • Classes in java.awt.event used by javax.swing.text.html
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
    InputEvent
    所有组件级输入事件的根事件类。
    MouseAdapter
    用于接收鼠标事件的抽象适配器类。
    MouseEvent
    指示组件中发生鼠标操作的事件。
    MouseListener
    用于在组件上接收“有趣”鼠标事件（按，释放，单击，输入和退出）的侦听器界面。
    MouseMotionListener
    用于在组件上接收鼠标运动事件的侦听器界面。
    MouseWheelListener
    用于在组件上接收鼠标滚轮事件的侦听器界面。
  • Classes in java.awt.event used by javax.swing.tree
    Class 描述
    ActionEvent
    指示组件定义的动作发生的语义事件。
    ActionListener
    用于接收动作事件的侦听器界面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


WindowAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class WindowAdapter

  • java.lang.Object
    • java.awt.event.WindowAdapter
  • All Implemented Interfaces:
    WindowFocusListener ， WindowListener ， WindowStateListener ， EventListener
    已知直接子类：
    BasicToolBarUI.FrameListener ， JMenu.WinListener

    public abstract class WindowAdapter
extends Object
implements WindowListener, WindowStateListener, WindowFocusListener
    用于接收窗口事件的抽象适配器类。 这个类中的方法是空的。 此类作为创建侦听器对象的方便而存在。

    扩展此类以创建一个WindowEvent监听器并覆盖感兴趣事件的方法。 （如果您实现了WindowListener接口，则必须定义其中的所有方法，这个抽象类为它们定义了空方法，因此您只能为所关心的事件定义方法。）

    使用扩展类创建一个侦听器对象，然后使用窗口的addWindowListener方法将其注册到一个窗口中。 当窗口的状态借助于被打开的变化，关闭，激活或去激活，或图标化取消图标化，在收听对象中的相关方法被调用，并且WindowEvent被传递给它。

    从以下版本开始：
    1.1
    另请参见：
    WindowEvent ， WindowListener ， Tutorial: Writing a Window Listener

    • 构造方法摘要

      构造方法
      Constructor 描述
      WindowAdapter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void windowActivated​(WindowEvent e)
      激活窗口时调用。
      void windowClosed​(WindowEvent e)
      当窗口关闭时调用。
      void windowClosing​(WindowEvent e)
      当窗口处于关闭状态时调用。
      void windowDeactivated​(WindowEvent e)
      当窗口被禁用时调用。
      void windowDeiconified​(WindowEvent e)
      当窗口被去图标化时调用。
      void windowGainedFocus​(WindowEvent e)
      当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
      void windowIconified​(WindowEvent e)
      当窗口被图标化时调用。
      void windowLostFocus​(WindowEvent e)
      当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。
      void windowOpened​(WindowEvent e)
      当窗口打开时调用。
      void windowStateChanged​(WindowEvent e)
      当窗口状态改变时调用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WindowAdapter

        public WindowAdapter​()

    • 方法详细信息

      • windowOpened

        public void windowOpened​(WindowEvent e)
        当窗口打开时调用。
        Specified by:
        windowOpened接口 WindowListener
        参数
        e - 要处理的事件

      • windowClosing

        public void windowClosing​(WindowEvent e)
        当窗口处于关闭状态时调用。 此时可以覆盖关闭操作。
        Specified by:
        windowClosing在接口 WindowListener
        参数
        e - 要处理的事件

      • windowClosed

        public void windowClosed​(WindowEvent e)
        当窗口关闭时调用。
        Specified by:
        windowClosed在接口 WindowListener
        参数
        e - 要处理的事件

      • windowIconified

        public void windowIconified​(WindowEvent e)
        当窗口被图标化时调用。
        Specified by:
        windowIconified接口 WindowListener
        参数
        e - 要处理的事件
        另请参见：
        Frame.setIconImage(java.awt.Image)

      • windowDeiconified

        public void windowDeiconified​(WindowEvent e)
        当窗口被去图标化时调用。
        Specified by:
        windowDeiconified在接口 WindowListener
        参数
        e - 要处理的事件

      • windowActivated

        public void windowActivated​(WindowEvent e)
        激活窗口时调用。
        Specified by:
        windowActivated在接口 WindowListener
        参数
        e - 要处理的事件

      • windowDeactivated

        public void windowDeactivated​(WindowEvent e)
        当窗口被禁用时调用。
        Specified by:
        windowDeactivated在接口 WindowListener
        参数
        e - 要处理的事件

      • windowStateChanged

        public void windowStateChanged​(WindowEvent e)
        当窗口状态改变时调用。
        Specified by:
        windowStateChanged在接口 WindowStateListener
        参数
        e - 要处理的事件
        从以下版本开始：
        1.4

      • windowGainedFocus

        public void windowGainedFocus​(WindowEvent e)
        当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
        Specified by:
        windowGainedFocus在接口 WindowFocusListener
        参数
        e - 要处理的事件
        从以下版本开始：
        1.4

      • windowLostFocus

        public void windowLostFocus​(WindowEvent e)
        当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。
        Specified by:
        windowLostFocus在接口 WindowFocusListener
        参数
        e - 要处理的事件
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WindowEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Class WindowEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.WindowEvent
  • All Implemented Interfaces:
    Serializable

    public class WindowEvent
extends ComponentEvent
    指示窗口已更改其状态的低级别事件。 当Window对象被打开，关闭，激活，停用，图标化或去隐藏时，或当焦点转移到窗口中或从窗口传出时，此低级事件由Window对象生成。

    该事件被传递给使用窗口的addWindowListener方法注册接收这种事件的每个WindowListener或WindowAdapter对象。 （ WindowAdapter对象实现WindowListener接口。）每个这样的侦听器对象在事件发生时得到这个WindowEvent 。

    如果任何特定的WindowEvent实例的id参数不在从WINDOW_FIRST到WINDOW_LAST的范围内，将会导致未指定的行为。

    从以下版本开始：
    1.1
    另请参见：
    WindowAdapter ， WindowListener ， Tutorial: Writing a Window Listener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int WINDOW_ACTIVATED
      窗口激活的事件类型。
      static int WINDOW_CLOSED
      窗户关闭事件。
      static int WINDOW_CLOSING
      “窗口正在关闭”事件。
      static int WINDOW_DEACTIVATED
      窗口停用事件类型。
      static int WINDOW_DEICONIFIED
      窗口deiconified事件类型。
      static int WINDOW_FIRST
      用于窗口事件的ids范围中的第一个数字。
      static int WINDOW_GAINED_FOCUS
      窗口获取焦点事件类型。
      static int WINDOW_ICONIFIED
      窗口图标化事件。
      static int WINDOW_LAST
      用于窗口事件的ID的范围中的最后一个数字。
      static int WINDOW_LOST_FOCUS
      窗口丢失焦点事件类型。
      static int WINDOW_OPENED
      窗户打开事件。
      static int WINDOW_STATE_CHANGED
      窗口状态更改的事件类型。

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      WindowEvent​(Window source, int id)
      构造一个 WindowEvent对象。
      WindowEvent​(Window source, int id, int oldState, int newState)
      构造具有指定的上一个和新的窗口状态的 WindowEvent对象。
      WindowEvent​(Window source, int id, Window opposite)
      构造一个 WindowEvent对象，其指定的对端为 Window 。
      WindowEvent​(Window source, int id, Window opposite, int oldState, int newState)
      构造一个 WindowEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getNewState​()
      对于 WINDOW_STATE_CHANGED事件返回窗口的新状态。
      int getOldState​()
      对于 WINDOW_STATE_CHANGED事件返回窗口的先前状态。
      Window getOppositeWindow​()
      返回此焦点或激活更改中涉及的其他窗口。
      Window getWindow​()
      返回事件的发起者。
      String paramString​()
      返回标识此事件的参数字符串。

      • Methods inherited from class java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • Methods inherited from class java.awt.event.ComponentEvent

        getComponent

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • WINDOW_FIRST

        public static final int WINDOW_FIRST
        用于窗口事件的ids范围中的第一个数字。
        另请参见：
        Constant Field Values

      • WINDOW_OPENED

        @Native
public static final int WINDOW_OPENED
        窗户打开事件。 此事件仅在窗口第一次可见时才提供。
        另请参见：
        Constant Field Values

      • WINDOW_CLOSING

        @Native
public static final int WINDOW_CLOSING
        “窗口正在关闭”事件。 当用户尝试从窗口的系统菜单中关闭窗口时，会传送此事件。 如果程序在处理此事件时没有明确隐藏或处理窗口，则窗口关闭操作将被取消。
        另请参见：
        Constant Field Values

      • WINDOW_CLOSED

        @Native
public static final int WINDOW_CLOSED
        窗户关闭事件。 此事件是由于处理呼叫而导致可显示窗口关闭后发送的。
        另请参见：
        Component.isDisplayable() ， Window.dispose() ， Constant Field Values

      • WINDOW_ICONIFIED

        @Native
public static final int WINDOW_ICONIFIED
        窗口图标化事件。 当窗口从正常状态更改为最小化状态时，将传递此事件。 对于许多平台，最小化的窗口将显示为窗口的iconImage属性中指定的图标。
        另请参见：
        Frame.setIconImage(java.awt.Image) ， Constant Field Values

      • WINDOW_DEICONIFIED

        @Native
public static final int WINDOW_DEICONIFIED
        窗口deiconified事件类型。 当窗口从最小化状态更改为正常状态时，将传递此事件。
        另请参见：
        Constant Field Values

      • WINDOW_ACTIVATED

        @Native
public static final int WINDOW_ACTIVATED
        窗口激活的事件类型。 当窗口成为活动窗口时，会传送此事件。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。
        另请参见：
        Constant Field Values

      • WINDOW_DEACTIVATED

        @Native
public static final int WINDOW_DEACTIVATED
        窗口停用事件类型。 当窗口不再是活动窗口时，会传送此事件。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。
        另请参见：
        Constant Field Values

      • WINDOW_GAINED_FOCUS

        @Native
public static final int WINDOW_GAINED_FOCUS
        窗口获取焦点事件类型。 当窗口成为聚焦窗口时，会传递此事件，这意味着窗口或其子组件之一将接收键盘事件。
        另请参见：
        Constant Field Values

      • WINDOW_LOST_FOCUS

        @Native
public static final int WINDOW_LOST_FOCUS
        窗口丢失焦点事件类型。 当窗口不再是聚焦窗口时，会传递此事件，这意味着键盘事件将不再传递到窗口或其任何子组件。
        另请参见：
        Constant Field Values

      • WINDOW_STATE_CHANGED

        @Native
public static final int WINDOW_STATE_CHANGED
        窗口状态更改的事件类型。 当窗口的状态由于图标化，最大化等而改变时，会传送此事件。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • WINDOW_LAST

        public static final int WINDOW_LAST
        用于窗口事件的ID的范围中的最后一个数字。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • WindowEvent

        public WindowEvent​(Window source,
                   int id,
                   Window opposite,
                   int oldState,
                   int newState)
        构造一个WindowEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Window对象
        id - 指示事件类型的整数。 有关允许值的信息，请参阅WindowEvent的类描述
        opposite - 涉及焦点或激活更改的其他窗口，或 null
        oldState - 窗口状态更改事件的窗口的上一个状态。 有关允许的值，请参阅#getOldState()
        newState - 窗口状态更改事件的窗口的新状态。 有关允许的值，请参阅#getNewState()
        异常
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4
        另请参见：
        getWindow() ，
AWTEvent.getID() ，
getOppositeWindow() ，
getOldState() ，
getNewState()

      • WindowEvent

        public WindowEvent​(Window source,
                   int id,
                   Window opposite)
        构造一个WindowEvent对象，指定的对端为Window 。 相反的Window是另一个Window涉及到这个焦点或激活的变化。 对于WINDOW_ACTIVATED或WINDOW_GAINED_FOCUS事件，这是Window失去激活或焦点。 对于WINDOW_DEACTIVATED或WINDOW_LOST_FOCUS事件，这是获得激活或焦点的Window 。 如果本机应用程序发生此焦点更改，在不同的VM中使用Java应用程序，或者没有其他的Window ，那么相反的窗口是null 。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Window对象
        id - 指示事件类型的整数。 有关允许值的信息，请参阅WindowEvent的类说明。 据预计，此构造将不会被用于其他然后WINDOW_ACTIVATED ， WINDOW_DEACTIVATED ， WINDOW_GAINED_FOCUS ，或WINDOW_LOST_FOCUS 。 WindowEvent类型，因为其他事件类型相反的Window将永远是null 。
        opposite - 其他 Window涉及到焦点或激活更改，或 null
        异常
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4
        另请参见：
        getWindow() ，
AWTEvent.getID() ，
getOppositeWindow()

      • WindowEvent

        public WindowEvent​(Window source,
                   int id,
                   int oldState,
                   int newState)
        构造具有指定的上一个和新窗口状态的WindowEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Window对象
        id - 指示事件类型的整数。 有关允许值的信息，请参阅WindowEvent的类说明。 据预计，此构造将不会被用于其他然后WINDOW_STATE_CHANGED WindowEvent类型，因为以前和新的窗口状态是无意义的其他事件类型。
        oldState - 表示上一窗口状态的整数。 关于允许值，请参阅#getOldState()
        newState - 表示新窗口状态的整数。 有关允许值，请参阅#getNewState()
        异常
        IllegalArgumentException - 如果 source为空
        从以下版本开始：
        1.4
        另请参见：
        getWindow() ，
AWTEvent.getID() ，
getOldState() ，
getNewState()

      • WindowEvent

        public WindowEvent​(Window source,
                   int id)
        构造一个WindowEvent对象。

        此方法抛出IllegalArgumentException如果source为null 。

        参数
        source - 发起事件的 Window对象
        id - 表示事件类型的整数。 有关允许值的信息，请参阅WindowEvent的类说明。
        异常
        IllegalArgumentException - 如果 source为空
        另请参见：
        getWindow() ， AWTEvent.getID()

    • 方法详细信息

      • getWindow

        public Window getWindow​()
        返回事件的发起者。
        结果
        发起事件的Window对象

      • getOppositeWindow

        public Window getOppositeWindow​()
        返回此焦点或激活更改中涉及的其他窗口。 对于WINDOW_ACTIVATED或WINDOW_GAINED_FOCUS事件，这是失去激活或焦点的窗口。 对于WINDOW_DEACTIVATED或WINDOW_LOST_FOCUS事件，这是获得激活或焦点的窗口。 对于任何其他类型的WindowEvent，或者如果本机应用程序发生焦点或激活更改，在不同的VM或上下文中使用Java应用程序，或者没有其他Window，则返回null。
        结果
        另一个窗口涉及到焦点或激活更改，或为null
        从以下版本开始：
        1.4

      • getOldState

        public int getOldState​()
        对于WINDOW_STATE_CHANGED事件返回窗口的先前状态。 状态表示为按位掩码。
        • NORMAL
          表示没有设置状态位。
        • ICONIFIED
        • MAXIMIZED_HORIZ
        • MAXIMIZED_VERT
        • MAXIMIZED_BOTH
          连接MAXIMIZED_HORIZ和MAXIMIZED_VERT 。
        结果
        前一窗口状态的按位掩码
        从以下版本开始：
        1.4
        另请参见：
        Frame.getExtendedState()

      • getNewState

        public int getNewState​()
        对于WINDOW_STATE_CHANGED事件返回窗口的新状态。 状态表示为按位掩码。
        • NORMAL
          表示没有设置状态位。
        • ICONIFIED
        • MAXIMIZED_HORIZ
        • MAXIMIZED_VERT
        • MAXIMIZED_BOTH
          连接MAXIMIZED_HORIZ和MAXIMIZED_VERT 。
        结果
        新窗口状态的按位掩码
        从以下版本开始：
        1.4
        另请参见：
        Frame.getExtendedState()

      • paramString

        public String paramString​()
        返回标识此事件的参数字符串。 此方法对于事件记录和调试很有用。
        重写：
        paramString在 ComponentEvent
        结果
        标识事件及其属性的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WindowFocusListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface WindowFocusListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicToolBarUI.FrameListener ， JMenu.WinListener ， WindowAdapter

    public interface WindowFocusListener
extends EventListener
    收听界面接收WindowEvents ，其中包括WINDOW_GAINED_FOCUS和WINDOW_LOST_FOCUS事件。 有兴趣处理一个WindowEvent的类实现了这个接口（和它包含的所有方法），或扩展了抽象的WindowAdapter类（仅覆盖了感兴趣的方法）。 从该类所创建的侦听器对象，然后，注册Window使用Window的addWindowFocusListener方法。 当Window的状态由于被打开，关闭，激活，停用，图标化或去隐藏而变化，或者通过焦点转移到或传出Window ，调用监听器对象中的相关方法，并且WindowEvent被传递给它
    从以下版本开始：
    1.4
    另请参见：
    WindowAdapter ， WindowEvent ， Tutorial: Writing a Window Listener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void windowGainedFocus​(WindowEvent e)
      当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
      void windowLostFocus​(WindowEvent e)
      当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。

    • 方法详细信息

      • windowGainedFocus

        void windowGainedFocus​(WindowEvent e)
        当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
        参数
        e - 要处理的事件

      • windowLostFocus

        void windowLostFocus​(WindowEvent e)
        当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WindowListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface WindowListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicToolBarUI.FrameListener ， JMenu.WinListener ， WindowAdapter

    public interface WindowListener
extends EventListener
    用于接收窗口事件的侦听器界面。 有兴趣处理窗口事件的类可以实现这个接口（和它包含的所有方法），或扩展抽象的WindowAdapter类（仅覆盖感兴趣的方法）。 然后，使用窗口的addWindowListener方法，使用从该类创建的侦听器对象向窗口注册。 当窗口的状态借助于被打开的变化，关闭，激活或去激活，或图标化取消图标化，在收听对象中的相关方法被调用，并且WindowEvent被传递给它。
    从以下版本开始：
    1.1
    另请参见：
    WindowAdapter ， WindowEvent ， Tutorial: How to Write Window Listeners

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void windowActivated​(WindowEvent e)
      当窗口设置为活动窗口时调用。
      void windowClosed​(WindowEvent e)
      当窗口关闭时调用窗口调用处理结果时调用。
      void windowClosing​(WindowEvent e)
      当用户尝试从窗口的系统菜单中关闭窗口时调用。
      void windowDeactivated​(WindowEvent e)
      当窗口不再是活动窗口时调用。
      void windowDeiconified​(WindowEvent e)
      当窗口从最小化更改为正常状态时调用。
      void windowIconified​(WindowEvent e)
      当窗口从正常状态更改为最小化状态时调用。
      void windowOpened​(WindowEvent e)
      第一次调用窗口可见。

    • 方法详细信息

      • windowOpened

        void windowOpened​(WindowEvent e)
        第一次调用窗口可见。
        参数
        e - 要处理的事件

      • windowClosing

        void windowClosing​(WindowEvent e)
        当用户尝试从窗口的系统菜单中关闭窗口时调用。
        参数
        e - 要处理的事件

      • windowClosed

        void windowClosed​(WindowEvent e)
        当窗口关闭时调用窗口调用处理结果时调用。
        参数
        e - 要处理的事件

      • windowIconified

        void windowIconified​(WindowEvent e)
        当窗口从正常状态更改为最小化状态时调用。 对于许多平台，最小化的窗口将显示为窗口的iconImage属性中指定的图标。
        参数
        e - 要处理的事件
        另请参见：
        Frame.setIconImage(java.awt.Image)

      • windowDeiconified

        void windowDeiconified​(WindowEvent e)
        当窗口从最小化更改为正常状态时调用。
        参数
        e - 要处理的事件

      • windowActivated

        void windowActivated​(WindowEvent e)
        当窗口设置为活动窗口时调用。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。
        参数
        e - 要处理的事件

      • windowDeactivated

        void windowDeactivated​(WindowEvent e)
        当窗口不再是活动窗口时调用。 只有框架或对话框可以是活动窗口。 本地窗口系统可以表示活动窗口或其具有特殊装饰的儿童，例如突出显示的标题栏。 活动窗口始终是聚焦的窗口，或者是聚焦窗口的所有者的第一个框架或对话框。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WindowStateListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.event

Interface WindowStateListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    AWTEventMulticaster ， BasicToolBarUI.FrameListener ， JMenu.WinListener ， WindowAdapter

    public interface WindowStateListener
extends EventListener
    用于接收窗口状态事件的侦听器接口。

    有兴趣处理窗口状态事件的类可以实现这个接口（和它包含的所有方法），或扩展抽象的WindowAdapter类（仅覆盖感兴趣的方法）。

    然后从该类创建的侦听器对象使用Window的addWindowStateListener方法向窗口注册。 当窗口的状态由于是图标化的变化，达到最大等等， windowStateChanged在听者对象方法调用，并且WindowEvent被传递给它。

    从以下版本开始：
    1.4
    另请参见：
    WindowAdapter ， WindowEvent

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void windowStateChanged​(WindowEvent e)
      窗口状态改变时调用。

    • 方法详细信息

      • windowStateChanged

        void windowStateChanged​(WindowEvent e)
        窗口状态改变时调用。
        参数
        e - 要处理的事件
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class java.awt.event.ActionEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.ActionEvent

  • Packages that use ActionEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of ActionEvent in java.awt

      Methods in java.awt with parameters of type ActionEvent
      Modifier and Type | 方法 | 描述
      void AWTEventMulticaster.actionPerformed​(ActionEvent e)
      通过调用listener-a和listener-b上的actionPerformed方法来处理actionPerformed事件。
      void | List.AccessibleAWTList.actionPerformed​(ActionEvent event)
      protected void Button.processActionEvent​(ActionEvent e)
      通过将此按钮分派到任何已注册的 ActionListener对象来处理在此按钮上发生的操作事件。
      protected void List.processActionEvent​(ActionEvent e)
      通过将此组件发送到任何已注册的 ActionListener对象来处理此组件上发生的操作事件。
      protected void MenuItem.processActionEvent​(ActionEvent e)
      处理此菜单项上发生的操作事件，将其发送到任何已注册的 ActionListener对象。
      protected void TextField.processActionEvent​(ActionEvent e)
      通过将其发送到任何已注册的 ActionListener对象来处理在此文本字段上发生的操作事件。

    • Uses of ActionEvent in java.awt.dnd

      Methods in java.awt.dnd with parameters of type ActionEvent
      Modifier and Type 方法 描述
      void DropTarget.DropTargetAutoScroller.actionPerformed​(ActionEvent e)
      导致自动滚屏发生

    • Uses of ActionEvent in java.awt.event

      Methods in java.awt.event with parameters of type ActionEvent
      Modifier and Type 方法 描述
      void ActionListener.actionPerformed​(ActionEvent e)
      发生动作时调用。

    • Uses of ActionEvent in javax.swing

      Methods in javax.swing with parameters of type ActionEvent
      Modifier and Type 方法 描述
      void DefaultCellEditor.EditorDelegate.actionPerformed​(ActionEvent e)
      执行动作时，编辑结束。
      void JComboBox.actionPerformed​(ActionEvent e)
      这种方法是公共的，作为实现的副作用。
      void ToolTipManager.insideTimerAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void ToolTipManager.outsideTimerAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void ToolTipManager.stillInsideTimerAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      protected void AbstractButton.fireActionPerformed​(ActionEvent event)
      通知所有在此事件类型上通知有兴趣的听众。
      protected void DefaultButtonModel.fireActionPerformed​(ActionEvent e)
      通知所有在此事件类型上通知有兴趣的听众。
      protected void Timer.fireActionPerformed​(ActionEvent e)
      通知所有在此事件类型上通知有兴趣的听众。

    • Uses of ActionEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ActionEvent
      Modifier and Type | 方法 | 描述
      void | BasicDesktopPaneUI.CloseAction.actionPerformed​(ActionEvent evt)
      void | BasicDesktopPaneUI.MaximizeAction.actionPerformed​(ActionEvent evt)
      void | BasicDesktopPaneUI.MinimizeAction.actionPerformed​(ActionEvent evt)
      void | BasicDesktopPaneUI.NavigateAction.actionPerformed​(ActionEvent evt)
      void | BasicDesktopPaneUI.OpenAction.actionPerformed​(ActionEvent evt)
      void BasicFileChooserUI.ApproveSelectionAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void BasicFileChooserUI.CancelSelectionAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void BasicFileChooserUI.ChangeToParentDirectoryAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void | BasicFileChooserUI.GoHomeAction.actionPerformed​(ActionEvent e)
      void BasicFileChooserUI.NewFolderAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void BasicFileChooserUI.UpdateAction.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void | BasicInternalFrameTitlePane.CloseAction.actionPerformed​(ActionEvent e)
      void | BasicInternalFrameTitlePane.IconifyAction.actionPerformed​(ActionEvent e)
      void | BasicInternalFrameTitlePane.MaximizeAction.actionPerformed​(ActionEvent evt)
      void | BasicInternalFrameTitlePane.MoveAction.actionPerformed​(ActionEvent e)
      void | BasicInternalFrameTitlePane.RestoreAction.actionPerformed​(ActionEvent evt)
      void | BasicInternalFrameTitlePane.SizeAction.actionPerformed​(ActionEvent e)
      void | BasicOptionPaneUI.ButtonActionListener.actionPerformed​(ActionEvent e)
      void BasicScrollBarUI.ScrollListener.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void BasicSliderUI.ActionScroller.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void BasicSliderUI.ScrollListener.actionPerformed​(ActionEvent e)
      发生动作时调用。
      void | BasicSplitPaneUI.KeyboardDownRightHandler.actionPerformed​(ActionEvent ev)
      void | BasicSplitPaneUI.KeyboardEndHandler.actionPerformed​(ActionEvent ev)
      void | BasicSplitPaneUI.KeyboardHomeHandler.actionPerformed​(ActionEvent ev)
      void | BasicSplitPaneUI.KeyboardResizeToggleHandler.actionPerformed​(ActionEvent ev)
      void | BasicSplitPaneUI.KeyboardUpLeftHandler.actionPerformed​(ActionEvent ev)
      void BasicTreeUI.ComponentHandler.actionPerformed​(ActionEvent ae)
      由于计时器而公开。
      void | BasicTreeUI.TreeCancelEditingAction.actionPerformed​(ActionEvent e)
      void | BasicTreeUI.TreeHomeAction.actionPerformed​(ActionEvent e)
      void | BasicTreeUI.TreeIncrementAction.actionPerformed​(ActionEvent e)
      void | BasicTreeUI.TreePageAction.actionPerformed​(ActionEvent e)
      void | BasicTreeUI.TreeToggleAction.actionPerformed​(ActionEvent e)
      void | BasicTreeUI.TreeTraverseAction.actionPerformed​(ActionEvent e)

    • Uses of ActionEvent in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type ActionEvent
      Modifier and Type | 方法 | 描述
      void | MetalFileChooserUI.DirectoryComboBoxAction.actionPerformed​(ActionEvent e)

    • Uses of ActionEvent in javax.swing.text

      Methods in javax.swing.text with parameters of type ActionEvent
      Modifier and Type 方法 描述
      void DefaultEditorKit.BeepAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void DefaultEditorKit.CopyAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void DefaultEditorKit.CutAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void DefaultEditorKit.DefaultKeyTypedAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void DefaultEditorKit.InsertBreakAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void DefaultEditorKit.InsertContentAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void DefaultEditorKit.InsertTabAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void DefaultEditorKit.PasteAction.actionPerformed​(ActionEvent e)
      触发此操作时执行的操作。
      void StyledEditorKit.AlignmentAction.actionPerformed​(ActionEvent e)
      设置对齐。
      void StyledEditorKit.BoldAction.actionPerformed​(ActionEvent e)
      切换粗体属性。
      void StyledEditorKit.FontFamilyAction.actionPerformed​(ActionEvent e)
      设置字体系列。
      void StyledEditorKit.FontSizeAction.actionPerformed​(ActionEvent e)
      设置字体大小。
      void StyledEditorKit.ForegroundAction.actionPerformed​(ActionEvent e)
      设置前景色。
      void StyledEditorKit.ItalicAction.actionPerformed​(ActionEvent e)
      切换斜体属性。
      void StyledEditorKit.UnderlineAction.actionPerformed​(ActionEvent e)
      切换下划线属性。
      protected JEditorPane StyledEditorKit.StyledTextAction.getEditor​(ActionEvent e)
      获取操作的目标编辑器。
      protected JTextComponent TextAction.getTextComponent​(ActionEvent e)
      确定要用于操作的组件。

    • Uses of ActionEvent in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type ActionEvent
      Modifier and Type 方法 描述
      void FormView.actionPerformed​(ActionEvent evt)
      负责处理ActionEvent。
      void HTMLEditorKit.InsertHTMLTextAction.actionPerformed​(ActionEvent ae)
      将HTML插入到文档中。

    • Uses of ActionEvent in javax.swing.tree

      Methods in javax.swing.tree with parameters of type ActionEvent
      Modifier and Type 方法 描述
      void DefaultTreeCellEditor.actionPerformed​(ActionEvent e)
      在定时器触发时消息传送，这将开始编辑会话。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.AdjustmentEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.AdjustmentEvent

  • Packages that use AdjustmentEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。

    • Uses of AdjustmentEvent in java.awt

      Methods in java.awt with parameters of type AdjustmentEvent
      Modifier and Type 方法 描述
      void AWTEventMulticaster.adjustmentValueChanged​(AdjustmentEvent e)
      通过调用listener-a和listener-b上的adjustValueChanged方法来处理adjustValueChanged事件。
      protected void Scrollbar.processAdjustmentEvent​(AdjustmentEvent e)
      通过将调度事件发送到任何已注册的 AdjustmentListener对象来处理此滚动条上发生的调整事件。

    • Uses of AdjustmentEvent in java.awt.event

      Methods in java.awt.event with parameters of type AdjustmentEvent
      Modifier and Type 方法 描述
      void AdjustmentListener.adjustmentValueChanged​(AdjustmentEvent e)
      当可调整的值已更改时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.AWTEventListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.AWTEventListenerProxy

No usage of java.awt.event.AWTEventListenerProxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.ComponentAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.ComponentAdapter

  • Packages that use ComponentAdapter
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of ComponentAdapter in javax.swing

      Subclasses of ComponentAdapter in javax.swing
      Modifier and Type Class 描述
      protected class  JViewport.ViewListener
      视图的监听器。

    • Uses of ComponentAdapter in javax.swing.plaf.basic

      Subclasses of ComponentAdapter in javax.swing.plaf.basic
      Modifier and Type Class 描述
      class  BasicSliderUI.ComponentHandler
      调整事件大小的侦听器。
      class  BasicTreeUI.ComponentHandler
      更新滚动时的首选大小（如有必要）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.ComponentEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.ComponentEvent

  • Packages that use ComponentEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of ComponentEvent in java.awt

      Methods in java.awt with parameters of type ComponentEvent
      Modifier and Type | 方法 | 描述
      void AWTEventMulticaster.componentHidden​(ComponentEvent e)
      通过在listener-a和listener-b上调用componentHidden方法来处理componentHidden事件。
      void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentHidden​(ComponentEvent e)
      void AWTEventMulticaster.componentMoved​(ComponentEvent e)
      通过调用listener-a和listener-b上的componentMoved方法来处理componentMoved事件。
      void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentMoved​(ComponentEvent e)
      void AWTEventMulticaster.componentResized​(ComponentEvent e)
      通过调用listener-a和listener-b上的componentResized方法来处理componentResized事件。
      void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentResized​(ComponentEvent e)
      void AWTEventMulticaster.componentShown​(ComponentEvent e)
      通过调用listener-a和listener-b上的componentShown方法来处理componentShown事件。
      void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentShown​(ComponentEvent e)
      protected void Component.processComponentEvent​(ComponentEvent e)
      通过将组件事件发送到任何已注册的 ComponentListener对象来处理此组件上发生的组件事件。

    • Uses of ComponentEvent in java.awt.event

      Subclasses of ComponentEvent in java.awt.event
      Modifier and Type Class 描述
      class  ContainerEvent
      低级别事件，表示容器的内容因添加或删除组件而发生更改。
      class  FocusEvent
      指示组件已经获得或丢失了输入焦点的低级事件。
      class  InputEvent
      所有组件级输入事件的根事件类。
      class  KeyEvent
      指示组件中发生击键的事件。
      class  MouseEvent
      指示组件中发生鼠标操作的事件。
      class  MouseWheelEvent
      指示鼠标轮在组件中旋转的事件。
      class  PaintEvent
      组件级paint事件。
      class  WindowEvent
      指示窗口已更改其状态的低级别事件。
      Methods in java.awt.event with parameters of type ComponentEvent
      Modifier and Type 方法 描述
      void ComponentAdapter.componentHidden​(ComponentEvent e)
      当该组件不可见时调用。
      void ComponentListener.componentHidden​(ComponentEvent e)
      当该组件不可见时调用。
      void ComponentAdapter.componentMoved​(ComponentEvent e)
      当组件的位置更改时调用。
      void ComponentListener.componentMoved​(ComponentEvent e)
      当组件的位置更改时调用。
      void ComponentAdapter.componentResized​(ComponentEvent e)
      当组件的大小更改时调用。
      void ComponentListener.componentResized​(ComponentEvent e)
      当组件的大小更改时调用。
      void ComponentAdapter.componentShown​(ComponentEvent e)
      当组件可见时调用。
      void ComponentListener.componentShown​(ComponentEvent e)
      当组件可见时调用。

    • Uses of ComponentEvent in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type ComponentEvent
      Modifier and Type 方法 描述
      protected void JFXPanel.processComponentEvent​(ComponentEvent e)
      覆盖 Component.processComponentEvent(ComponentEvent)方法将 COMPONENT_RESIZED事件发送到附加到此 JFXPanel的JavaFX场景。

    • Uses of ComponentEvent in javax.swing

      Methods in javax.swing with parameters of type ComponentEvent
      Modifier and Type | 方法 | 描述
      void | JViewport.ViewListener.componentResized​(ComponentEvent e)

    • Uses of ComponentEvent in javax.swing.event

      Subclasses of ComponentEvent in javax.swing.event
      Modifier and Type Class 描述
      class  MenuDragMouseEvent
      MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。
      class  MenuKeyEvent
      MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。

    • Uses of ComponentEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type ComponentEvent
      Modifier and Type 方法 描述
      protected void LayerUI.processComponentEvent​(ComponentEvent e, JLayer<? extends V> l)
      处理在JLayer或其任何子组件上发生的组件事件。

    • Uses of ComponentEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ComponentEvent
      Modifier and Type | 方法 | 描述
      void BasicInternalFrameUI.ComponentHandler.componentHidden​(ComponentEvent e)
      当该组件不可见时调用。
      void BasicInternalFrameUI.ComponentHandler.componentMoved​(ComponentEvent e)
      当组件的位置更改时调用。
      void | BasicTreeUI.ComponentHandler.componentMoved​(ComponentEvent e)
      void BasicInternalFrameUI.ComponentHandler.componentResized​(ComponentEvent e)
      当JInternalFrame的父级大小更改时调用。
      void | BasicSliderUI.ComponentHandler.componentResized​(ComponentEvent e)
      void BasicInternalFrameUI.ComponentHandler.componentShown​(ComponentEvent e)
      当组件可见时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.ContainerAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.ContainerAdapter

No usage of java.awt.event.ContainerAdapter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.ContainerEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.ContainerEvent

  • Packages that use ContainerEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of ContainerEvent in java.awt

      Methods in java.awt with parameters of type ContainerEvent
      Modifier and Type | 方法 | 描述
      void AWTEventMulticaster.componentAdded​(ContainerEvent e)
      通过调用listener-a和listener-b上的componentAdded方法来处理componentAdded容器事件。
      void | Container.AccessibleAWTContainer.AccessibleContainerHandler.componentAdded​(ContainerEvent e)
      void AWTEventMulticaster.componentRemoved​(ContainerEvent e)
      通过调用listener-a和listener-b上的componentRemoved方法来处理componentRemoved容器事件。
      void | Container.AccessibleAWTContainer.AccessibleContainerHandler.componentRemoved​(ContainerEvent e)
      protected void Container.processContainerEvent​(ContainerEvent e)
      通过将容器事件发送到任何已注册的ContainerListener对象来处理容器事件。

    • Uses of ContainerEvent in java.awt.event

      Methods in java.awt.event with parameters of type ContainerEvent
      Modifier and Type 方法 描述
      void ContainerAdapter.componentAdded​(ContainerEvent e)
      当组件已添加到容器时调用。
      void ContainerListener.componentAdded​(ContainerEvent e)
      当组件已添加到容器时调用。
      void ContainerAdapter.componentRemoved​(ContainerEvent e)
      当组件从容器中删除时调用。
      void ContainerListener.componentRemoved​(ContainerEvent e)
      当组件从容器中删除时调用。

    • Uses of ContainerEvent in javax.swing

      Methods in javax.swing with parameters of type ContainerEvent
      Modifier and Type | 方法 | 描述
      void | JComponent.AccessibleJComponent.AccessibleContainerHandler.componentAdded​(ContainerEvent e)
      void | JComponent.AccessibleJComponent.AccessibleContainerHandler.componentRemoved​(ContainerEvent e)

    • Uses of ContainerEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ContainerEvent
      Modifier and Type | 方法 | 描述
      void | BasicToolBarUI.ToolBarContListener.componentAdded​(ContainerEvent e)
      void | BasicToolBarUI.ToolBarContListener.componentRemoved​(ContainerEvent e)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.FocusAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.FocusAdapter

  • Packages that use FocusAdapter
    软件包 描述
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of FocusAdapter in javax.swing.plaf.basic

      Subclasses of FocusAdapter in javax.swing.plaf.basic
      Modifier and Type Class 描述
      class  BasicSplitPaneUI.FocusHandler
      JSplitPane UI使用的FocusListener的实现。
      class  BasicTabbedPaneUI.FocusHandler
      这个类应该被视为一个“受保护”的内部类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.FocusEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.FocusEvent

  • Packages that use FocusEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of FocusEvent in java.awt

      Methods in java.awt with parameters of type FocusEvent
      Modifier and Type | 方法 | 描述
      void AWTEventMulticaster.focusGained​(FocusEvent e)
      通过在listener-a和listener-b上调用focusGained方法来处理focusGained事件。
      void | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusGained​(FocusEvent event)
      void AWTEventMulticaster.focusLost​(FocusEvent e)
      通过在listener-a和listener-b上调用focusLost方法来处理focusLost事件。
      void | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusLost​(FocusEvent event)
      protected void Component.processFocusEvent​(FocusEvent e)
      通过将这些事件发送到任何已注册的 FocusListener对象来处理发生在该组件上的焦点事件。

    • Uses of FocusEvent in java.awt.event

      Methods in java.awt.event with parameters of type FocusEvent
      Modifier and Type 方法 描述
      void FocusAdapter.focusGained​(FocusEvent e)
      当组件获得键盘焦点时调用。
      void FocusListener.focusGained​(FocusEvent e)
      当组件获得键盘焦点时调用。
      void FocusAdapter.focusLost​(FocusEvent e)
      当组件丢失键盘焦点时调用。
      void FocusListener.focusLost​(FocusEvent e)
      当组件丢失键盘焦点时调用。

    • Uses of FocusEvent in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type FocusEvent
      Modifier and Type 方法 描述
      protected void JFXPanel.processFocusEvent​(FocusEvent e)
      覆盖 Component.processFocusEvent(FocusEvent)方法来将焦点事件分配给连接到此 JFXPanel的JavaFX场景。

    • Uses of FocusEvent in javax.swing

      Methods in javax.swing with parameters of type FocusEvent
      Modifier and Type | 方法 | 描述
      void JComponent.AccessibleJComponent.AccessibleFocusHandler.focusGained​(FocusEvent event)
      已过时。
      void JComponent.AccessibleJComponent.AccessibleFocusHandler.focusLost​(FocusEvent event)
      已过时。
      protected void JFormattedTextField.processFocusEvent​(FocusEvent e)
      处理任何焦点事件，例如 FocusEvent.FOCUS_GAINED或 FocusEvent.FOCUS_LOST 。
      protected void | JPopupMenu.processFocusEvent​(FocusEvent evt)

    • Uses of FocusEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type FocusEvent
      Modifier and Type 方法 描述
      protected void LayerUI.processFocusEvent​(FocusEvent e, JLayer<? extends V> l)
      处理发生在JLayer或其任何子组件上的焦点事件。

    • Uses of FocusEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type FocusEvent
      Modifier and Type | 方法 | 描述
      void | BasicButtonListener.focusGained​(FocusEvent e)
      void | BasicComboBoxEditor.focusGained​(FocusEvent e)
      void | BasicComboBoxUI.FocusHandler.focusGained​(FocusEvent e)
      void | BasicListUI.FocusHandler.focusGained​(FocusEvent e)
      void | BasicSliderUI.FocusHandler.focusGained​(FocusEvent e)
      void | BasicSplitPaneUI.FocusHandler.focusGained​(FocusEvent ev)
      void | BasicTabbedPaneUI.FocusHandler.focusGained​(FocusEvent e)
      void | BasicTableUI.FocusHandler.focusGained​(FocusEvent e)
      void | BasicToolBarUI.ToolBarFocusListener.focusGained​(FocusEvent e)
      void BasicTreeUI.FocusHandler.focusGained​(FocusEvent e)
      在我们所在的树上激活焦点时调用，重绘铅笔。
      void | BasicButtonListener.focusLost​(FocusEvent e)
      void | BasicComboBoxEditor.focusLost​(FocusEvent e)
      void | BasicComboBoxUI.FocusHandler.focusLost​(FocusEvent e)
      void | BasicListUI.FocusHandler.focusLost​(FocusEvent e)
      void | BasicSliderUI.FocusHandler.focusLost​(FocusEvent e)
      void | BasicSplitPaneUI.FocusHandler.focusLost​(FocusEvent ev)
      void | BasicTabbedPaneUI.FocusHandler.focusLost​(FocusEvent e)
      void | BasicTableUI.FocusHandler.focusLost​(FocusEvent e)
      void | BasicToolBarUI.ToolBarFocusListener.focusLost​(FocusEvent e)
      void BasicTreeUI.FocusHandler.focusLost​(FocusEvent e)
      在我们所在的树上激活焦点时调用，重绘铅笔。

    • Uses of FocusEvent in javax.swing.text

      Methods in javax.swing.text with parameters of type FocusEvent
      Modifier and Type 方法 描述
      void DefaultCaret.focusGained​(FocusEvent e)
      当包含插入符号的组件获取焦点时调用。
      void DefaultCaret.focusLost​(FocusEvent e)
      当包含插入符号的组件失去焦点时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.FocusEvent.Cause (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.FocusEvent.Cause

  • Packages that use FocusEvent.Cause
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of FocusEvent.Cause in java.awt

      Methods in java.awt with parameters of type FocusEvent.Cause
      Modifier and Type 方法 描述
      protected boolean Component.requestFocus​(boolean temporary, FocusEvent.Cause cause)
      要求由 cause这个 Component得到输入的焦点，而这 Component的顶级祖先成为焦点 Window 。
      void Component.requestFocus​(FocusEvent.Cause cause)
      请求由 cause这个组件得到输入焦点，并且该组件的顶级祖先成为关注的窗口。
      boolean Component.requestFocusInWindow​(FocusEvent.Cause cause)
      请求由 cause的原因，该组件获取输入焦点，如果此组件的顶级祖先已经是关注的窗口。

    • Uses of FocusEvent.Cause in java.awt.event

      Methods in java.awt.event that return FocusEvent.Cause
      Modifier and Type 方法 描述
      FocusEvent.Cause FocusEvent.getCause​()
      返回事件原因。
      static FocusEvent.Cause FocusEvent.Cause.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static FocusEvent.Cause[] FocusEvent.Cause.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Constructors in java.awt.event with parameters of type FocusEvent.Cause
      Constructor 描述
      FocusEvent​(Component source, int id, boolean temporary, Component opposite, FocusEvent.Cause cause)
      构造一个具有指定临时状态的 FocusEvent对象， Component的原因为 Component 。

    • Uses of FocusEvent.Cause in javax.swing

      Methods in javax.swing with parameters of type FocusEvent.Cause
      Modifier and Type 方法 描述
      void JToggleButton.requestFocus​(FocusEvent.Cause cause)
      如果此切换按钮是ButtonGroup的成员，该另一个切换按钮已被选中，并且可以是焦点所有者，并且焦点原因参数表示任何方向的窗口激活或焦点遍历操作，则方法执行的结果与在组中选择的切换按钮上调用Component.requestFocus(FocusEvent.Cause) 。
      boolean JToggleButton.requestFocusInWindow​(FocusEvent.Cause cause)
      如果此切换按钮是ButtonGroup的成员，该另一个切换按钮被选中并且可以是焦点所有者，并且焦点原因参数表示任何方向的窗口激活或焦点遍历操作，则方法执行的结果与在组中选择的切换按钮上调用Component.requestFocusInWindow(FocusEvent.Cause) 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.HierarchyBoundsAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.HierarchyBoundsAdapter

No usage of java.awt.event.HierarchyBoundsAdapter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.HierarchyEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.HierarchyEvent

  • Packages that use HierarchyEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。

    • Uses of HierarchyEvent in java.awt

      Methods in java.awt with parameters of type HierarchyEvent
      Modifier and Type 方法 描述
      void AWTEventMulticaster.ancestorMoved​(HierarchyEvent e)
      通过在listener-a和listener-b上调用ancestorMoved方法来处理ancestorMoved事件。
      void AWTEventMulticaster.ancestorResized​(HierarchyEvent e)
      通过调用listener-a和listener-b上的ancestorResized方法来处理ancestorResized事件。
      void AWTEventMulticaster.hierarchyChanged​(HierarchyEvent e)
      通过调用listener-a和listener-b上的hierarchyChanged方法来处理hierarchyChanged事件。
      protected void Component.processHierarchyBoundsEvent​(HierarchyEvent e)
      进程层次结构通过 HierarchyBoundsListener到任何已注册的 HierarchyBoundsListener对象来限制发生在该组件上的事件。
      protected void Component.processHierarchyEvent​(HierarchyEvent e)
      通过将其分派到任何已注册的 HierarchyListener对象来处理在此组件上发生的层次结构事件。

    • Uses of HierarchyEvent in java.awt.event

      Methods in java.awt.event with parameters of type HierarchyEvent
      Modifier and Type 方法 描述
      void HierarchyBoundsAdapter.ancestorMoved​(HierarchyEvent e)
      当源的祖先移动时调用。
      void HierarchyBoundsListener.ancestorMoved​(HierarchyEvent e)
      当源的祖先移动时调用。
      void HierarchyBoundsAdapter.ancestorResized​(HierarchyEvent e)
      调用源的祖先调整大小时。
      void HierarchyBoundsListener.ancestorResized​(HierarchyEvent e)
      调用源的祖先调整大小时。
      void HierarchyListener.hierarchyChanged​(HierarchyEvent e)
      当层次结构被更改时调用。

    • Uses of HierarchyEvent in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type HierarchyEvent
      Modifier and Type | 方法 | 描述
      protected void JFXPanel.processHierarchyBoundsEvent​(HierarchyEvent e)
      覆盖 Component.processHierarchyBoundsEvent(HierarchyEvent)方法来处理 ANCESTOR_MOVED事件，并更新JavaFX场景位置以匹配屏幕上的 JFXPanel位置。
      protected void | JFXPanel.processHierarchyEvent​(HierarchyEvent e)

    • Uses of HierarchyEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type HierarchyEvent
      Modifier and Type 方法 描述
      protected void LayerUI.processHierarchyBoundsEvent​(HierarchyEvent e, JLayer<? extends V> l)
      进程层次结构限制事件发生在JLayer或其任何子组件上。
      protected void LayerUI.processHierarchyEvent​(HierarchyEvent e, JLayer<? extends V> l)
      处理在JLayer或其任何子组件上发生的层次结构事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.InputEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.InputEvent

  • Packages that use InputEvent
    软件包 描述
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类来创建HTML文本编辑器。

    • Uses of InputEvent in java.awt.dnd

      Fields in java.awt.dnd with type parameters of type InputEvent
      Modifier and Type Field 描述
      protected ArrayList<InputEvent> DragGestureRecognizer.events
      事件列表（按顺序）， DragGestureRecognizer “识别”为触发拖动的“手势”。
      Methods in java.awt.dnd that return InputEvent
      Modifier and Type 方法 描述
      InputEvent DragGestureEvent.getTriggerEvent​()
      返回触发手势的初始事件。
      InputEvent DragGestureRecognizer.getTriggerEvent​()
      此方法返回启动拖放操作的一系列事件中的第一个事件。
      Methods in java.awt.dnd that return types with arguments of type InputEvent
      Modifier and Type 方法 描述
      Iterator<InputEvent> DragGestureEvent.iterator​()
      为包含手势的事件返回 Iterator 。
      Methods in java.awt.dnd with parameters of type InputEvent
      Modifier and Type 方法 描述
      protected void DragGestureRecognizer.appendEvent​(InputEvent awtie)
      通过此识别器在组件上注册的侦听器应记录被识别为通过该API组成拖放启动手势的一系列事件的一部分的所有事件。
      Constructor parameters in java.awt.dnd with type arguments of type InputEvent
      Constructor 描述
      DragGestureEvent​(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
      构造一个 DragGestureEvent由给定对象 DragGestureRecognizer实例激发此事件中， act表示用户的首选操作参数，一个 ori参数指示拖动原点，和一个 List组成动作（事件 evs参数）。

    • Uses of InputEvent in java.awt.event

      Subclasses of InputEvent in java.awt.event
      Modifier and Type Class 描述
      class  KeyEvent
      指示组件中发生击键的事件。
      class  MouseEvent
      指示组件中发生鼠标操作的事件。
      class  MouseWheelEvent
      指示鼠标轮在组件中旋转的事件。

    • Uses of InputEvent in javax.swing

      Methods in javax.swing with parameters of type InputEvent
      Modifier and Type 方法 描述
      void TransferHandler.exportAsDrag​(JComponent comp, InputEvent e, int action)
      导致启动Swing拖动支持。

    • Uses of InputEvent in javax.swing.event

      Subclasses of InputEvent in javax.swing.event
      Modifier and Type Class 描述
      class  MenuDragMouseEvent
      MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。
      class  MenuKeyEvent
      MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。
      Methods in javax.swing.event that return InputEvent
      Modifier and Type 方法 描述
      InputEvent HyperlinkEvent.getInputEvent​()
      返回触发超链接事件的 InputEvent 。
      Constructors in javax.swing.event with parameters of type InputEvent
      Constructor 描述
      HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement, InputEvent inputEvent)
      创建一个表示超文本链接事件的新对象。

    • Uses of InputEvent in javax.swing.text.html

      Constructors in javax.swing.text.html with parameters of type InputEvent
      Constructor 描述
      HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)
      创建一个表示超文本链接事件的新对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.InputMethodEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.InputMethodEvent

  • Packages that use InputMethodEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of InputMethodEvent in java.awt

      Methods in java.awt with parameters of type InputMethodEvent
      Modifier and Type 方法 描述
      void AWTEventMulticaster.caretPositionChanged​(InputMethodEvent e)
      通过在listener-a和listener-b上调用caretPositionChanged方法处理caretPositionChanged事件。
      void AWTEventMulticaster.inputMethodTextChanged​(InputMethodEvent e)
      通过调用listener-a和listener-b上的inputMethodTextChanged方法来处理inputMethodTextChanged事件。
      protected void Component.processInputMethodEvent​(InputMethodEvent e)
      通过将此组件发送到任何已注册的 InputMethodListener对象来处理在此组件上发生的输入方法事件。

    • Uses of InputMethodEvent in java.awt.event

      Methods in java.awt.event with parameters of type InputMethodEvent
      Modifier and Type 方法 描述
      void InputMethodListener.caretPositionChanged​(InputMethodEvent event)
      当合成文本内的插入符已更改时调用。
      void InputMethodListener.inputMethodTextChanged​(InputMethodEvent event)
      当通过输入法输入的文本已更改时调用。

    • Uses of InputMethodEvent in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type InputMethodEvent
      Modifier and Type | 方法 | 描述
      protected void | JFXPanel.processInputMethodEvent​(InputMethodEvent e)

    • Uses of InputMethodEvent in javax.swing

      Methods in javax.swing with parameters of type InputMethodEvent
      Modifier and Type 方法 描述
      protected void JFormattedTextField.processInputMethodEvent​(InputMethodEvent e)
      处理任何输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED或 InputMethodEvent.CARET_POSITION_CHANGED 。

    • Uses of InputMethodEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type InputMethodEvent
      Modifier and Type 方法 描述
      protected void LayerUI.processInputMethodEvent​(InputMethodEvent e, JLayer<? extends V> l)
      Processes input event occurring on the JLayer or any of its subcomponents.

    • Uses of InputMethodEvent in javax.swing.text

      Methods in javax.swing.text with parameters of type InputMethodEvent
      Modifier and Type | 方法 | 描述
      protected void | JTextComponent.processInputMethodEvent​(InputMethodEvent e)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.InvocationEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.InvocationEvent

No usage of java.awt.event.InvocationEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.ItemEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.ItemEvent

  • Packages that use ItemEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of ItemEvent in java.awt

      Methods in java.awt with parameters of type ItemEvent
      Modifier and Type | 方法 | 描述
      void AWTEventMulticaster.itemStateChanged​(ItemEvent e)
      通过调用listener-a和listener-b上的itemStateChanged方法来处理itemStateChanged事件。
      void Checkbox.AccessibleAWTCheckbox.itemStateChanged​(ItemEvent e)
      当触发按钮的状态改变时，可触及的属性更改事件。
      void | List.AccessibleAWTList.itemStateChanged​(ItemEvent event)
      protected void Checkbox.processItemEvent​(ItemEvent e)
      通过将此复选框发送到任何已注册的 ItemListener对象来处理在此复选框上发生的项目事件。
      protected void CheckboxMenuItem.processItemEvent​(ItemEvent e)
      通过将此复选框菜单项发送到任何已注册的 ItemListener对象来处理发生的项目事件。
      protected void Choice.processItemEvent​(ItemEvent e)
      通过将其发送到任何已注册的 ItemListener对象来处理在此 Choice菜单上发生的项目事件。
      protected void List.processItemEvent​(ItemEvent e)
      通过将其发送到任何已注册的 ItemListener对象来处理在此列表上发生的项目事件。

    • Uses of ItemEvent in java.awt.event

      Methods in java.awt.event with parameters of type ItemEvent
      Modifier and Type 方法 描述
      void ItemListener.itemStateChanged​(ItemEvent e)
      当用户选择或取消选择项目时调用。

    • Uses of ItemEvent in javax.swing

      Methods in javax.swing with parameters of type ItemEvent
      Modifier and Type 方法 描述
      protected void AbstractButton.fireItemStateChanged​(ItemEvent event)
      通知所有在此事件类型上通知有兴趣的听众。
      protected void DefaultButtonModel.fireItemStateChanged​(ItemEvent e)
      通知所有在此事件类型上通知有兴趣的听众。
      protected void JComboBox.fireItemStateChanged​(ItemEvent e)
      通知所有在此事件类型上通知有兴趣的听众。
      void DefaultCellEditor.EditorDelegate.itemStateChanged​(ItemEvent e)
      当项目的状态改变时，编辑结束。
      void JToggleButton.AccessibleJToggleButton.itemStateChanged​(ItemEvent e)
      当触发按钮的状态改变时，可触及的属性更改事件。

    • Uses of ItemEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ItemEvent
      Modifier and Type | 方法 | 描述
      void | BasicComboBoxUI.ItemHandler.itemStateChanged​(ItemEvent e)
      void | BasicComboPopup.ItemHandler.itemStateChanged​(ItemEvent e)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.KeyAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.KeyAdapter

  • Packages that use KeyAdapter
    软件包 描述
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of KeyAdapter in javax.swing.plaf.basic

      Subclasses of KeyAdapter in javax.swing.plaf.basic
      Modifier and Type Class 描述
      class  BasicComboBoxUI.KeyHandler
      该侦听器检查键事件是否不是导航键。
      class  BasicComboPopup.InvocationKeyHandler
      从Java 2平台v 1.4开始，此类现在已经过时，仅用于向后兼容API。
      class  BasicTreeUI.KeyHandler
      这用于获取多个关键事件以适当地生成事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.KeyEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.KeyEvent

  • Packages that use KeyEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of KeyEvent in java.awt

      Methods in java.awt with parameters of type KeyEvent
      Modifier and Type 方法 描述
      boolean DefaultKeyboardFocusManager.dispatchKeyEvent​(KeyEvent e)
      调用 dispatchEvent如果调度程序链中的其他KeyEventDispatcher没有分派KeyEvent，或者没有其他的KeyEventDispatchers被注册。
      abstract boolean KeyboardFocusManager.dispatchKeyEvent​(KeyEvent e)
      通常，如果调度程序链中没有其他的KeyEventDispatcher调度了KeyEvent，或者没有其他的KeyEventDispatchers被注册，通常这个方法将被调用 dispatchEvent 。
      boolean KeyEventDispatcher.dispatchKeyEvent​(KeyEvent e)
      此方法由当前的KeyboardFocusManager调用，请求此KeyEventDispatcher代表它分派指定的事件。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStrokeForEvent​(KeyEvent anEvent)
      返回一个 AWTKeyStroke ，表示生成给定的 KeyEvent 。
      void AWTEventMulticaster.keyPressed​(KeyEvent e)
      通过在listener-a和listener-b上调用keyPressed方法来处理keyPressed事件。
      void AWTEventMulticaster.keyReleased​(KeyEvent e)
      通过调用listener-a和listener-b上的keyReleased方法来处理keyReleased事件。
      void AWTEventMulticaster.keyTyped​(KeyEvent e)
      通过在listener-a和listener-b上调用keyTyped方法来处理keyTyped事件。
      boolean DefaultKeyboardFocusManager.postProcessKeyEvent​(KeyEvent e)
      此方法将由 dispatchKeyEvent 。
      abstract boolean KeyboardFocusManager.postProcessKeyEvent​(KeyEvent e)
      这个方法将被调用 dispatchKeyEvent 。
      boolean KeyEventPostProcessor.postProcessKeyEvent​(KeyEvent e)
      该方法由当前的KeyboardFocusManager调用，请求该KeyEventPostProcessor执行任何必要的后处理，该后处理应该是KeyEvent的最终解决方案的一部分。
      protected void Component.processKeyEvent​(KeyEvent e)
      通过将这些事件发送到任何已注册的 KeyListener对象来处理此组件上发生的关键事件。
      void DefaultKeyboardFocusManager.processKeyEvent​(Component focusedComponent, KeyEvent e)
      当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。
      abstract void KeyboardFocusManager.processKeyEvent​(Component focusedComponent, KeyEvent e)
      当且仅当KeyEvent表示指定的focusComponent的焦点遍历键时，此方法启动焦点遍历操作。

    • Uses of KeyEvent in java.awt.event

      Methods in java.awt.event with parameters of type KeyEvent
      Modifier and Type 方法 描述
      void KeyAdapter.keyPressed​(KeyEvent e)
      按下键时调用。
      void KeyListener.keyPressed​(KeyEvent e)
      按下键时调用。
      void KeyAdapter.keyReleased​(KeyEvent e)
      当键已被释放时调用。
      void KeyListener.keyReleased​(KeyEvent e)
      当键已被释放时调用。
      void KeyAdapter.keyTyped​(KeyEvent e)
      键入键时调用。
      void KeyListener.keyTyped​(KeyEvent e)
      键入键时调用。

    • Uses of KeyEvent in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type KeyEvent
      Modifier and Type 方法 描述
      protected void JFXPanel.processKeyEvent​(KeyEvent e)
      覆盖 Component.processKeyEvent(KeyEvent)方法将键事件发送到附加到此 JFXPanel的JavaFX场景。

    • Uses of KeyEvent in javax.swing

      Methods in javax.swing with parameters of type KeyEvent
      Modifier and Type | 方法 | 描述
      static KeyStroke KeyStroke.getKeyStrokeForEvent​(KeyEvent anEvent)
      返回一个KeyStroke，它表示生成给定KeyEvent的笔触。
      static boolean SwingUtilities.notifyAction​(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
      调用 actionPerformed上 action如果 action是非 null并接受发送对象。
      protected void JComponent.processComponentKeyEvent​(KeyEvent e)
      处理组件本身识别的任何关键事件。
      protected boolean JComboBox.processKeyBinding​(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      调用以处理键绑定为 ks作为的结果 KeyEvent e 。
      protected boolean JComponent.processKeyBinding​(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      调用处理密钥绑定 ks作为 KeyEvent e的结果。
      protected boolean JMenuBar.processKeyBinding​(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      子类检查所有的子菜单。
      protected boolean | JTable.processKeyBinding​(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      static boolean SwingUtilities.processKeyBindings​(KeyEvent event)
      处理用于在所述键绑定 Component关联 event 。
      void JComboBox.processKeyEvent​(KeyEvent e)
      处理 KeyEvent s，寻找Tab键。
      protected void JComponent.processKeyEvent​(KeyEvent e)
      覆盖 processKeyEvent以处理事件。
      protected void JMenu.processKeyEvent​(KeyEvent evt)
      处理关键笔划事件，如助记符和加速器。
      void JMenuBar.processKeyEvent​(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      实现成为一个 MenuElement - 什么也没做。
      void JMenuItem.processKeyEvent​(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      处理从 MenuSelectionManager转发的密钥事件，如有必要，可以使用 MenuSelectionManager的API更改菜单选项。
      protected void JPopupMenu.processKeyEvent​(KeyEvent evt)
      处理关键笔划事件，如助记符和加速器。
      void JPopupMenu.processKeyEvent​(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      处理从 MenuSelectionManager转发的密钥事件，并根据需要更改菜单选项，使用 MenuSelectionManager的API。
      void MenuElement.processKeyEvent​(KeyEvent event, MenuElement[] path, MenuSelectionManager manager)
      处理关键事件。
      void MenuSelectionManager.processKeyEvent​(KeyEvent e)
      当MenuElement从KeyListener接收到一个事件时，它不应该直接处理该事件。

    • Uses of KeyEvent in javax.swing.event

      Subclasses of KeyEvent in javax.swing.event
      Modifier and Type Class 描述
      class  MenuKeyEvent
      MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。

    • Uses of KeyEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type KeyEvent
      Modifier and Type 方法 描述
      protected void LayerUI.processKeyEvent​(KeyEvent e, JLayer<? extends V> l)
      处理JLayer或其任何子组件发生的关键事件。

    • Uses of KeyEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type KeyEvent
      Modifier and Type | 方法 | 描述
      void | BasicComboBoxUI.KeyHandler.keyPressed​(KeyEvent e)
      void | BasicTableUI.KeyHandler.keyPressed​(KeyEvent e)
      void | BasicTreeUI.KeyHandler.keyPressed​(KeyEvent e)
      void | BasicComboPopup.InvocationKeyHandler.keyReleased​(KeyEvent e)
      void | BasicTableUI.KeyHandler.keyReleased​(KeyEvent e)
      void | BasicTreeUI.KeyHandler.keyReleased​(KeyEvent e)
      void | BasicTableUI.KeyHandler.keyTyped​(KeyEvent e)
      void BasicTreeUI.KeyHandler.keyTyped​(KeyEvent e)
      键入键时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.MouseAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.MouseAdapter

  • Packages that use MouseAdapter
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.text.html
    提供 HTMLEditorKit类和支持类来创建HTML文本编辑器。

    • Uses of MouseAdapter in javax.swing

      Subclasses of MouseAdapter in javax.swing
      Modifier and Type Class 描述
      class  ToolTipManager
      管理系统中的所有 ToolTips 。

    • Uses of MouseAdapter in javax.swing.event

      Subclasses of MouseAdapter in javax.swing.event
      Modifier and Type Class 描述
      class  MouseInputAdapter
      空闲的 MouseInputListener接口的实现，通过扩展和实现感兴趣的方法，为简化创建监听者的任务提供了方便。

    • Uses of MouseAdapter in javax.swing.plaf.basic

      Subclasses of MouseAdapter in javax.swing.plaf.basic
      Modifier and Type Class 描述
      protected class  BasicComboPopup.InvocationMouseHandler
      在组合框（ 而不是其弹出菜单）上注册的侦听器来处理影响弹出菜单状态的鼠标事件。
      protected class  BasicComboPopup.ListMouseHandler
      当列表中释放鼠标时，此侦听器会隐藏弹出窗口。
      class  BasicDesktopIconUI.MouseInputHandler
      监听鼠标移动并对其进行操作。
      protected class  BasicFileChooserUI.DoubleClickListener
      双击监听器。
      protected class  BasicInternalFrameUI.BorderListener
      倾听边界调整。
      protected class  BasicScrollBarUI.ArrowButtonListener
      光标键侦听器。
      protected class  BasicScrollBarUI.TrackListener
      跟踪鼠标拖动。
      class  BasicSliderUI.TrackListener
      跟踪鼠标移动。
      protected class  BasicSplitPaneDivider.MouseHandler
      MouseHandler负责将鼠标事件（释放，拖动...）转换为适当的DragController方法。
      class  BasicTabbedPaneUI.MouseHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTreeUI.MouseHandler
      TreeMouseListener负责根据鼠标事件更新选择。

    • Uses of MouseAdapter in javax.swing.plaf.metal

      Subclasses of MouseAdapter in javax.swing.plaf.metal
      Modifier and Type Class 描述
      protected class  MetalFileChooserUI.SingleClickListener
      已过时。
      截至JDK版本9.过时的课程。

    • Uses of MouseAdapter in javax.swing.text.html

      Subclasses of MouseAdapter in javax.swing.text.html
      Modifier and Type Class 描述
      protected class  FormView.MouseEventListener
      当类型等于图像的输入点击时，MouseEventListener类可以处理表单提交。
      static class  HTMLEditorKit.LinkController
      在适当的时候，类可以观看相关组件并在其上触发超链接事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.MouseEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.MouseEvent

  • Packages that use MouseEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供 HTMLEditorKit和用于创建HTML文本编辑器的支持类。

    • Uses of MouseEvent in java.awt

      Methods in java.awt with parameters of type MouseEvent
      Modifier and Type 方法 描述
      void AWTEventMulticaster.mouseClicked​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseClicked方法来处理mouseClicked事件。
      void AWTEventMulticaster.mouseDragged​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseDragged方法来处理mouseDragged事件。
      void AWTEventMulticaster.mouseEntered​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseEntered方法来处理mouseEntered事件。
      void AWTEventMulticaster.mouseExited​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseExited方法来处理mouseExited事件。
      void AWTEventMulticaster.mouseMoved​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseMoved方法来处理mouseMoved事件。
      void AWTEventMulticaster.mousePressed​(MouseEvent e)
      通过在listener-a和listener-b上调用mousePressed方法来处理mousePressed事件。
      void AWTEventMulticaster.mouseReleased​(MouseEvent e)
      通过在listener-a和listener-b上调用mouseReleased方法来处理mouseReleased事件。
      protected void Component.processMouseEvent​(MouseEvent e)
      通过将此组件发送到任何已注册的 MouseListener对象来处理发生在此组件上的鼠标事件。
      protected void Component.processMouseMotionEvent​(MouseEvent e)
      通过将此组件发送到任何已注册的 MouseMotionListener对象来处理发生在该组件上的鼠标运动事件。

    • Uses of MouseEvent in java.awt.dnd

      Methods in java.awt.dnd with parameters of type MouseEvent
      Modifier and Type 方法 描述
      void MouseDragGestureRecognizer.mouseClicked​(MouseEvent e)
      当鼠标点击组件时调用。
      void MouseDragGestureRecognizer.mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void MouseDragGestureRecognizer.mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void MouseDragGestureRecognizer.mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void MouseDragGestureRecognizer.mouseMoved​(MouseEvent e)
      在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
      void MouseDragGestureRecognizer.mousePressed​(MouseEvent e)
      在 Component上按下鼠标按钮时调用。
      void MouseDragGestureRecognizer.mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。

    • Uses of MouseEvent in java.awt.event

      Subclasses of MouseEvent in java.awt.event
      Modifier and Type Class 描述
      class  MouseWheelEvent
      指示鼠标轮在组件中旋转的事件。
      Methods in java.awt.event with parameters of type MouseEvent
      Modifier and Type 方法 描述
      void MouseAdapter.mouseClicked​(MouseEvent e)
      在组件上单击（按下并释放）鼠标按钮时调用。
      void MouseListener.mouseClicked​(MouseEvent e)
      在组件上单击（按下并释放）鼠标按钮时调用。
      void MouseAdapter.mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void MouseMotionAdapter.mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void MouseMotionListener.mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void MouseAdapter.mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void MouseListener.mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void MouseAdapter.mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void MouseListener.mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void MouseAdapter.mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。
      void MouseMotionAdapter.mouseMoved​(MouseEvent e)
      在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
      void MouseMotionListener.mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。
      void MouseAdapter.mousePressed​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void MouseListener.mousePressed​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void MouseAdapter.mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。
      void MouseListener.mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。

    • Uses of MouseEvent in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type MouseEvent
      Modifier and Type 方法 描述
      protected void JFXPanel.processMouseEvent​(MouseEvent e)
      覆盖 Component.processMouseEvent(MouseEvent)方法将鼠标事件发送到附加到此 JFXPanel的JavaFX场景。
      protected void JFXPanel.processMouseMotionEvent​(MouseEvent e)
      覆盖 Component.processMouseMotionEvent(MouseEvent)方法将鼠标移动事件发送到连接到此 JFXPanel的JavaFX场景。

    • Uses of MouseEvent in javax.swing

      Methods in javax.swing that return MouseEvent
      Modifier and Type 方法 描述
      static MouseEvent SwingUtilities.convertMouseEvent​(Component source, MouseEvent sourceEvent, Component destination)
      返回类似于 sourceEvent的MouseEvent，但其x和y成员已转换为 destination的坐标系。
      Methods in javax.swing with parameters of type MouseEvent
      Modifier and Type 方法 描述
      static MouseEvent SwingUtilities.convertMouseEvent​(Component source, MouseEvent sourceEvent, Component destination)
      返回类似于 sourceEvent的MouseEvent，但其x和y成员已转换为 destination的坐标系。
      Point JComponent.getPopupLocation​(MouseEvent event)
      返回在该组件的坐标系中显示弹出菜单的首选位置。
      Point JComponent.getToolTipLocation​(MouseEvent event)
      返回此组件坐标系中的工具提示位置。
      String JComponent.getToolTipText​(MouseEvent event)
      返回要用作 事件的工具提示的字符串。
      String JList.getToolTipText​(MouseEvent event)
      返回用于给定事件的工具提示文本。
      String JTabbedPane.getToolTipText​(MouseEvent event)
      返回由鼠标事件位置确定的组件的工具提示文本。
      String JTable.getToolTipText​(MouseEvent event)
      覆盖 JComponent的 getToolTipText方法，以允许渲染器的提示被使用，如果它有文本集。
      String JTree.getToolTipText​(MouseEvent event)
      覆盖 JComponent的 getToolTipText方法，以便允许使用渲染器的提示，如果它具有文本集。
      static boolean SwingUtilities.isLeftMouseButton​(MouseEvent anEvent)
      如果鼠标事件指定鼠标左键，则返回true。
      static boolean SwingUtilities.isMiddleMouseButton​(MouseEvent anEvent)
      如果鼠标事件指定鼠标中键，则返回true。
      boolean JPopupMenu.isPopupTrigger​(MouseEvent e)
      如果 MouseEvent被 JPopupMenu当前安装的UI视为弹出式触发器，则返回true。
      static boolean SwingUtilities.isRightMouseButton​(MouseEvent anEvent)
      如果鼠标事件指定了鼠标右键，则返回true。
      void ToolTipManager.mouseDragged​(MouseEvent event)
      当鼠标被按下并拖动时调用。
      void ToolTipManager.mouseEntered​(MouseEvent event)
      当鼠标进入组件的区域时调用。
      void ToolTipManager.mouseExited​(MouseEvent event)
      当鼠标退出组件的区域时调用。
      void ToolTipManager.mouseMoved​(MouseEvent event)
      当鼠标移动时调用。
      void ToolTipManager.mousePressed​(MouseEvent event)
      当鼠标被按下时调用。
      protected void JComponent.processMouseEvent​(MouseEvent e)
      通过将此组件发送到任何已注册的 MouseListener对象来处理发生在该组件上的鼠标事件，有关此方法的完整说明，请参阅 Component.processMouseEvent(MouseEvent) 。
      void JMenuBar.processMouseEvent​(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      实现成为一个 MenuElement - 什么也没做。
      void JMenuItem.processMouseEvent​(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      处理从 MenuSelectionManager转发的鼠标事件，如有必要，使用 MenuSelectionManager的API更改菜单选项。
      void JPopupMenu.processMouseEvent​(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      这种方法是符合 MenuElement接口所必需的，但没有实现。
      void MenuElement.processMouseEvent​(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      处理鼠标事件。
      void MenuSelectionManager.processMouseEvent​(MouseEvent event)
      当MenuElement从MouseListener接收到一个事件时，它不应该直接处理该事件。
      protected void JComponent.processMouseMotionEvent​(MouseEvent e)
      处理鼠标运动事件，如MouseEvent.MOUSE_DRAGGED。

    • Uses of MouseEvent in javax.swing.event

      Subclasses of MouseEvent in javax.swing.event
      Modifier and Type Class 描述
      class  MenuDragMouseEvent
      MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。

    • Uses of MouseEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type MouseEvent
      Modifier and Type 方法 描述
      boolean PopupMenuUI.isPopupTrigger​(MouseEvent e)
      返回给定的 MouseEvent是否是平台的弹出菜单触发事件
      protected void LayerUI.processMouseEvent​(MouseEvent e, JLayer<? extends V> l)
      处理发生在JLayer或其任何子组件上的鼠标事件。
      protected void LayerUI.processMouseMotionEvent​(MouseEvent e, JLayer<? extends V> l)
      处理JLayer或其任何子组件发生的鼠标运动事件。

    • Uses of MouseEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return MouseEvent
      Modifier and Type 方法 描述
      protected MouseEvent BasicComboPopup.convertMouseEvent​(MouseEvent e)
      转换鼠标事件。
      Methods in javax.swing.plaf.basic with parameters of type MouseEvent
      Modifier and Type | 方法 | 描述
      protected void BasicSplitPaneDivider.DragController.completeDrag​(MouseEvent e)
      消息finishDraggingTo与鼠标事件的新位置。
      protected void BasicSplitPaneDivider.DragController.continueDrag​(MouseEvent e)
      消息dragDividerTo与鼠标事件的新位置。
      protected MouseEvent BasicComboPopup.convertMouseEvent​(MouseEvent e)
      转换鼠标事件。
      protected void BasicComboPopup.delegateFocus​(MouseEvent e)
      这是一种实用方法，可帮助事件处理程序在弹出弹出窗口时找出发送焦点的位置。
      protected boolean BasicTreeUI.isMultiSelectEvent​(MouseEvent event)
      返回 true表示节点上的鼠标事件应从锚点中选择。
      boolean | BasicPopupMenuUI.isPopupTrigger​(MouseEvent e)
      protected boolean BasicTreeUI.isToggleEvent​(MouseEvent event)
      返回 true表示鼠标下的行应根据事件切换。
      protected boolean BasicTreeUI.isToggleSelectionEvent​(MouseEvent event)
      返回 true表示节点上的鼠标事件应切换仅对鼠标下的行进行选择。
      void | BasicButtonListener.mouseClicked​(MouseEvent e)
      void BasicFileChooserUI.DoubleClickListener.mouseClicked​(MouseEvent e)
      在组件上单击（按下并释放）鼠标按钮时调用。
      void | BasicInternalFrameUI.BorderListener.mouseClicked​(MouseEvent e)
      void BasicInternalFrameUI.GlassPaneDispatcher.mouseClicked​(MouseEvent e)
      在组件上单击（按下并释放）鼠标按钮时调用。
      void | BasicListUI.MouseInputHandler.mouseClicked​(MouseEvent e)
      void BasicMenuItemUI.MouseInputHandler.mouseClicked​(MouseEvent e)
      在组件上单击（按下并释放）鼠标按钮时调用。
      void | BasicMenuUI.MouseInputHandler.mouseClicked​(MouseEvent e)
      void | BasicTableHeaderUI.MouseInputHandler.mouseClicked​(MouseEvent e)
      void | BasicTableUI.MouseInputHandler.mouseClicked​(MouseEvent e)
      void | BasicToolBarUI.DockingListener.mouseClicked​(MouseEvent e)
      void | BasicTreeUI.MouseInputHandler.mouseClicked​(MouseEvent e)
      void | BasicButtonListener.mouseDragged​(MouseEvent e)
      void | BasicComboPopup.InvocationMouseMotionHandler.mouseDragged​(MouseEvent e)
      void | BasicDesktopIconUI.MouseInputHandler.mouseDragged​(MouseEvent e)
      void | BasicInternalFrameUI.BorderListener.mouseDragged​(MouseEvent e)
      void BasicInternalFrameUI.GlassPaneDispatcher.mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void | BasicListUI.MouseInputHandler.mouseDragged​(MouseEvent e)
      void BasicMenuItemUI.MouseInputHandler.mouseDragged​(MouseEvent e)
      在组件上按下鼠标按钮然后拖动时调用。
      void BasicMenuUI.MouseInputHandler.mouseDragged​(MouseEvent e)
      在菜单上按下鼠标按钮然后拖动时调用。
      void BasicScrollBarUI.TrackListener.mouseDragged​(MouseEvent e)
      将模型值设置为垂直滚动条的顶部的位置，或水平滚动条左右对齐/左右滚动条相对于轨迹原点的左/右。
      void BasicSliderUI.TrackListener.mouseDragged​(MouseEvent e)
      将模型值设置为拇指顶部/左侧相对于轨迹原点的位置。
      void BasicSplitPaneDivider.MouseHandler.mouseDragged​(MouseEvent e)
      如果dragger不为null，则会使用continueDrag进行消息传递。
      void | BasicTableHeaderUI.MouseInputHandler.mouseDragged​(MouseEvent e)
      void | BasicTableUI.MouseInputHandler.mouseDragged​(MouseEvent e)
      void | BasicToolBarUI.DockingListener.mouseDragged​(MouseEvent e)
      void | BasicTreeUI.MouseHandler.mouseDragged​(MouseEvent e)
      void | BasicTreeUI.MouseInputHandler.mouseDragged​(MouseEvent e)
      void | BasicButtonListener.mouseEntered​(MouseEvent e)
      void BasicFileChooserUI.DoubleClickListener.mouseEntered​(MouseEvent e)
      用于表示文件的JList是由子类创建的，但是在此类中监视选择。
      void | BasicInternalFrameUI.BorderListener.mouseEntered​(MouseEvent e)
      void BasicInternalFrameUI.GlassPaneDispatcher.mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void | BasicListUI.MouseInputHandler.mouseEntered​(MouseEvent e)
      void BasicMenuItemUI.MouseInputHandler.mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void BasicMenuUI.MouseInputHandler.mouseEntered​(MouseEvent e)
      当光标进入菜单时调用。
      void BasicSplitPaneDivider.MouseHandler.mouseEntered​(MouseEvent e)
      当鼠标进入组件时调用。
      void | BasicTableHeaderUI.MouseInputHandler.mouseEntered​(MouseEvent e)
      void | BasicTableUI.MouseInputHandler.mouseEntered​(MouseEvent e)
      void | BasicToolBarUI.DockingListener.mouseEntered​(MouseEvent e)
      void | BasicTreeUI.MouseInputHandler.mouseEntered​(MouseEvent e)
      void | BasicButtonListener.mouseExited​(MouseEvent e)
      void | BasicInternalFrameUI.BorderListener.mouseExited​(MouseEvent e)
      void BasicInternalFrameUI.GlassPaneDispatcher.mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void | BasicListUI.MouseInputHandler.mouseExited​(MouseEvent e)
      void BasicMenuItemUI.MouseInputHandler.mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void | BasicMenuUI.MouseInputHandler.mouseExited​(MouseEvent e)
      void BasicScrollBarUI.TrackListener.mouseExited​(MouseEvent e)
      当鼠标退出滚动条时调用。
      void BasicSplitPaneDivider.MouseHandler.mouseExited​(MouseEvent e)
      当鼠标退出组件时调用。
      void | BasicTableHeaderUI.MouseInputHandler.mouseExited​(MouseEvent e)
      void | BasicTableUI.MouseInputHandler.mouseExited​(MouseEvent e)
      void | BasicToolBarUI.DockingListener.mouseExited​(MouseEvent e)
      void | BasicTreeUI.MouseInputHandler.mouseExited​(MouseEvent e)
      void | BasicButtonListener.mouseMoved​(MouseEvent e)
      void | BasicComboPopup.ListMouseMotionHandler.mouseMoved​(MouseEvent anEvent)
      void | BasicDesktopIconUI.MouseInputHandler.mouseMoved​(MouseEvent e)
      void | BasicInternalFrameUI.BorderListener.mouseMoved​(MouseEvent e)
      void BasicInternalFrameUI.GlassPaneDispatcher.mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。
      void | BasicListUI.MouseInputHandler.mouseMoved​(MouseEvent e)
      void BasicMenuItemUI.MouseInputHandler.mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。
      void | BasicMenuUI.MouseInputHandler.mouseMoved​(MouseEvent e)
      void BasicScrollBarUI.TrackListener.mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。
      void BasicSliderUI.TrackListener.mouseMoved​(MouseEvent e)
      当鼠标光标移动到组件上但没有按钮被按下时调用。
      void BasicSplitPaneDivider.MouseHandler.mouseMoved​(MouseEvent e)
      根据方向重新设置光标。
      void | BasicTableHeaderUI.MouseInputHandler.mouseMoved​(MouseEvent e)
      void | BasicTableUI.MouseInputHandler.mouseMoved​(MouseEvent e)
      void | BasicToolBarUI.DockingListener.mouseMoved​(MouseEvent e)
      void BasicTreeUI.MouseHandler.mouseMoved​(MouseEvent e)
      在组件上移动鼠标按钮时调用（没有按钮没有关闭）。
      void | BasicTreeUI.MouseInputHandler.mouseMoved​(MouseEvent e)
      void | BasicButtonListener.mousePressed​(MouseEvent e)
      void BasicComboPopup.InvocationMouseHandler.mousePressed​(MouseEvent e)
      响应组合框上的鼠标按下的事件。
      void | BasicComboPopup.ListMouseHandler.mousePressed​(MouseEvent e)
      void | BasicDesktopIconUI.MouseInputHandler.mousePressed​(MouseEvent e)
      void | BasicInternalFrameUI.BorderListener.mousePressed​(MouseEvent e)
      void BasicInternalFrameUI.GlassPaneDispatcher.mousePressed​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void | BasicListUI.MouseInputHandler.mousePressed​(MouseEvent e)
      void BasicMenuItemUI.MouseInputHandler.mousePressed​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void BasicMenuUI.MouseInputHandler.mousePressed​(MouseEvent e)
      当鼠标在菜单上点击时调用。
      void | BasicScrollBarUI.ArrowButtonListener.mousePressed​(MouseEvent e)
      void BasicScrollBarUI.TrackListener.mousePressed​(MouseEvent e)
      如果鼠标按在“thumb”组件上方，则将滚动条值减少一页（“向上”），否则将其增加一页。
      void BasicSliderUI.TrackListener.mousePressed​(MouseEvent e)
      如果鼠标按在“thumb”组件上方，则将滚动条值减少一页（“向上”），否则将其增加一页。
      void BasicSplitPaneDivider.MouseHandler.mousePressed​(MouseEvent e)
      通过创建适当的DragController实例来启动拖动会话。
      void | BasicTabbedPaneUI.MouseHandler.mousePressed​(MouseEvent e)
      void | BasicTableHeaderUI.MouseInputHandler.mousePressed​(MouseEvent e)
      void | BasicTableUI.MouseInputHandler.mousePressed​(MouseEvent e)
      void | BasicToolBarUI.DockingListener.mousePressed​(MouseEvent e)
      void BasicTreeUI.MouseHandler.mousePressed​(MouseEvent e)
      在组件上按下鼠标按钮时调用。
      void | BasicTreeUI.MouseInputHandler.mousePressed​(MouseEvent e)
      void | BasicButtonListener.mouseReleased​(MouseEvent e)
      void BasicComboPopup.InvocationMouseHandler.mouseReleased​(MouseEvent e)
      响应用户终止组合框上开始的点击或拖动。
      void | BasicComboPopup.ListMouseHandler.mouseReleased​(MouseEvent anEvent)
      void | BasicDesktopIconUI.MouseInputHandler.mouseReleased​(MouseEvent e)
      void | BasicInternalFrameUI.BorderListener.mouseReleased​(MouseEvent e)
      void BasicInternalFrameUI.GlassPaneDispatcher.mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。
      void | BasicListUI.MouseInputHandler.mouseReleased​(MouseEvent e)
      void BasicMenuItemUI.MouseInputHandler.mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。
      void BasicMenuUI.MouseInputHandler.mouseReleased​(MouseEvent e)
      当鼠标在菜单上释放时调用。
      void | BasicScrollBarUI.ArrowButtonListener.mouseReleased​(MouseEvent e)
      void BasicScrollBarUI.TrackListener.mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。
      void BasicSliderUI.TrackListener.mouseReleased​(MouseEvent e)
      在组件上释放鼠标按钮时调用。
      void BasicSplitPaneDivider.MouseHandler.mouseReleased​(MouseEvent e)
      如果dragger不为null，则会使用completeDrag进行消息传递。
      void | BasicTableHeaderUI.MouseInputHandler.mouseReleased​(MouseEvent e)
      void | BasicTableUI.MouseInputHandler.mouseReleased​(MouseEvent e)
      void | BasicToolBarUI.DockingListener.mouseReleased​(MouseEvent e)
      void | BasicTreeUI.MouseHandler.mouseReleased​(MouseEvent e)
      void | BasicTreeUI.MouseInputHandler.mouseReleased​(MouseEvent e)
      protected int BasicSplitPaneDivider.DragController.positionForMouseEvent​(MouseEvent e)
      返回基于MouseEvent中传递的分隔符的新位置。
      protected int BasicSplitPaneDivider.VerticalDragController.positionForMouseEvent​(MouseEvent e)
      返回基于MouseEvent中传递的分隔符的新位置。
      void BasicCheckBoxMenuItemUI.processMouseEvent​(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      当鼠标事件发生时调用。
      void BasicRadioButtonMenuItemUI.processMouseEvent​(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      当鼠标事件发生时调用。
      protected void BasicTreeUI.selectPathForEvent​(TreePath path, MouseEvent event)
      通过特定行更新基于 MouseEvent的选择。
      protected boolean BasicTreeUI.startEditing​(TreePath path, MouseEvent event)
      如果有 cellEditor和 shouldSelectCell返回 true将开始编辑节点。
      protected void BasicComboPopup.updateListBoxSelectionForEvent​(MouseEvent anEvent, boolean shouldScroll)
      事件侦听器使用的实用方法。
      Constructors in javax.swing.plaf.basic with parameters of type MouseEvent
      Constructor 描述
      DragController​(MouseEvent e)
      构造一个新的实例 DragController 。
      MouseInputHandler​(Component source, Component destination, MouseEvent event)
      构造一个新的实例 MouseInputHandler 。
      VerticalDragController​(MouseEvent e)
      构造新的实例 VerticalDragController 。

    • Uses of MouseEvent in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type MouseEvent
      Modifier and Type | 方法 | 描述
      void MetalComboBoxUI.MetalComboPopup.delegateFocus​(MouseEvent e)
      已过时。
      void | MetalToolBarUI.MetalDockingListener.mouseDragged​(MouseEvent e)
      void | MetalToolBarUI.MetalDockingListener.mousePressed​(MouseEvent e)

    • Uses of MouseEvent in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type MouseEvent
      Modifier and Type 方法 描述
      boolean MultiPopupMenuUI.isPopupTrigger​(MouseEvent a)
      在此对象处理的每个UI上调用 isPopupTrigger方法。

    • Uses of MouseEvent in javax.swing.table

      Methods in javax.swing.table with parameters of type MouseEvent
      Modifier and Type 方法 描述
      String JTableHeader.getToolTipText​(MouseEvent event)
      允许渲染器的提示被使用，如果有文本集。

    • Uses of MouseEvent in javax.swing.text

      Methods in javax.swing.text with parameters of type MouseEvent
      Modifier and Type 方法 描述
      String JTextComponent.getToolTipText​(MouseEvent event)
      返回要用作 event的工具提示的 event 。
      void DefaultCaret.mouseClicked​(MouseEvent e)
      当鼠标点击时调用。
      void DefaultCaret.mouseDragged​(MouseEvent e)
      根据鼠标指针的当前位置移动插入符号位置。
      void DefaultCaret.mouseEntered​(MouseEvent e)
      当鼠标进入区域时调用。
      void DefaultCaret.mouseExited​(MouseEvent e)
      当鼠标退出区域时调用。
      void DefaultCaret.mouseMoved​(MouseEvent e)
      当鼠标移动时调用。
      void DefaultCaret.mousePressed​(MouseEvent e)
      如果按下按钮1，则将其实现为请求关注相关联的文本组件，并设置插入符位置。
      void DefaultCaret.mouseReleased​(MouseEvent e)
      当鼠标释放时调用。
      protected void DefaultCaret.moveCaret​(MouseEvent e)
      尝试使用viewToModel（）从鼠标事件的坐标移动插入符的位置。
      protected void DefaultCaret.positionCaret​(MouseEvent e)
      尝试使用viewToModel（）从鼠标事件的坐标设置插入符号的位置。

    • Uses of MouseEvent in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type MouseEvent
      Modifier and Type | 方法 | 描述
      void HTMLEditorKit.LinkController.mouseClicked​(MouseEvent e)
      被称为鼠标点击事件。
      void | HTMLEditorKit.LinkController.mouseDragged​(MouseEvent e)
      void | HTMLEditorKit.LinkController.mouseMoved​(MouseEvent e)
      void | FormView.MouseEventListener.mouseReleased​(MouseEvent evt)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.MouseMotionAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.MouseMotionAdapter

  • Packages that use MouseMotionAdapter
    软件包 描述
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of MouseMotionAdapter in javax.swing.plaf.basic

      Subclasses of MouseMotionAdapter in javax.swing.plaf.basic
      Modifier and Type Class 描述
      protected class  BasicComboPopup.InvocationMouseMotionHandler
      如果拖动列表，该监听器将监视拖动并更新列表中的当前选择。
      protected class  BasicComboPopup.ListMouseMotionHandler
      当您将鼠标移动到列表上时，此侦听器将更改所选项。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.MouseWheelEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.MouseWheelEvent

  • Packages that use MouseWheelEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of MouseWheelEvent in java.awt

      Methods in java.awt with parameters of type MouseWheelEvent
      Modifier and Type 方法 描述
      void AWTEventMulticaster.mouseWheelMoved​(MouseWheelEvent e)
      通过在listener-a和listener-b上调用mouseWheelMoved方法来处理mouseWheelMoved事件。
      protected void Component.processMouseWheelEvent​(MouseWheelEvent e)
      通过将鼠标滚轮事件发送到任何已注册的 MouseWheelListener对象来处理鼠标滚轮事件。
      protected void ScrollPane.processMouseWheelEvent​(MouseWheelEvent e)
      通过滚动适当的量来处理传递给此 ScrollPane的鼠标滚轮事件。

    • Uses of MouseWheelEvent in java.awt.event

      Methods in java.awt.event with parameters of type MouseWheelEvent
      Modifier and Type 方法 描述
      void MouseAdapter.mouseWheelMoved​(MouseWheelEvent e)
      当鼠标滚轮旋转时调用。
      void MouseWheelListener.mouseWheelMoved​(MouseWheelEvent e)
      当鼠标滚轮旋转时调用。

    • Uses of MouseWheelEvent in javafx.embed.swing

      Methods in javafx.embed.swing with parameters of type MouseWheelEvent
      Modifier and Type 方法 描述
      protected void JFXPanel.processMouseWheelEvent​(MouseWheelEvent e)
      覆盖 Component.processMouseWheelEvent(MouseWheelEvent)方法将鼠标滚轮事件发送到附加到此 JFXPanel的JavaFX场景。

    • Uses of MouseWheelEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type MouseWheelEvent
      Modifier and Type 方法 描述
      protected void LayerUI.processMouseWheelEvent​(MouseWheelEvent e, JLayer<? extends V> l)
      处理JLayer或其任何子组件发生的鼠标滚轮事件。

    • Uses of MouseWheelEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type MouseWheelEvent
      Modifier and Type 方法 描述
      void BasicScrollPaneUI.MouseWheelHandler.mouseWheelMoved​(MouseWheelEvent e)
      Called when the mouse wheel is rotated while over a JScrollPane.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.PaintEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.PaintEvent

No usage of java.awt.event.PaintEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.TextEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.TextEvent

  • Packages that use TextEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。

    • Uses of TextEvent in java.awt

      Methods in java.awt with parameters of type TextEvent
      Modifier and Type | 方法 | 描述
      protected void TextComponent.processTextEvent​(TextEvent e)
      通过将文本事件发送到任何已注册的 TextListener对象来处理此文本组件上发生的文本事件。
      void | AWTEventMulticaster.textValueChanged​(TextEvent e)
      void TextComponent.AccessibleAWTTextComponent.textValueChanged​(TextEvent textEvent)
      TextListener通知文本值更改。

    • Uses of TextEvent in java.awt.event

      Methods in java.awt.event with parameters of type TextEvent
      Modifier and Type 方法 描述
      void TextListener.textValueChanged​(TextEvent e)
      当文本的值已更改时调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.WindowAdapter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.WindowAdapter

  • Packages that use WindowAdapter
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of WindowAdapter in javax.swing

      Subclasses of WindowAdapter in javax.swing
      Modifier and Type Class 描述
      protected class  JMenu.WinListener
      监听一个弹出窗口关闭的监听器类。

    • Uses of WindowAdapter in javax.swing.plaf.basic

      Subclasses of WindowAdapter in javax.swing.plaf.basic
      Modifier and Type Class 描述
      protected class  BasicToolBarUI.FrameListener
      该类监听窗口事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.event.WindowEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.event.WindowEvent

  • Packages that use WindowEvent
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of WindowEvent in java.awt

      Methods in java.awt with parameters of type WindowEvent
      Modifier and Type 方法 描述
      protected void Window.processWindowEvent​(WindowEvent e)
      通过将窗口事件分派到任何注册的WindowListener对象来处理窗口事件。
      protected void Window.processWindowFocusEvent​(WindowEvent e)
      通过将窗口焦点事件分派到任何已注册的WindowFocusListener对象来处理窗口焦点事件。
      protected void Window.processWindowStateEvent​(WindowEvent e)
      通过将窗口状态调度到任何已注册的 WindowStateListener对象来处理窗口状态事件。
      void AWTEventMulticaster.windowActivated​(WindowEvent e)
      通过调用listener-a和listener-b上的windowActivated方法来处理windowActivated事件。
      void AWTEventMulticaster.windowClosed​(WindowEvent e)
      通过调用listener-a和listener-b上的windowClosed方法来处理windowClosed事件。
      void AWTEventMulticaster.windowClosing​(WindowEvent e)
      通过调用listener-a和listener-b上的windowClosing方法处理windowClosing事件。
      void AWTEventMulticaster.windowDeactivated​(WindowEvent e)
      通过调用listener-a和listener-b上的windowDeactivated方法来处理windowDeactivated事件。
      void AWTEventMulticaster.windowDeiconified​(WindowEvent e)
      通过调用listener-a和listener-b上的windowDeiconified方法来处理windowDeiconified事件。
      void AWTEventMulticaster.windowGainedFocus​(WindowEvent e)
      通过调用listener-a和listener-b上的windowGainedFocus方法来处理windowGainedFocus事件。
      void AWTEventMulticaster.windowIconified​(WindowEvent e)
      通过调用listener-a和listener-b上的windowIconified方法来处理windowIconified事件。
      void AWTEventMulticaster.windowLostFocus​(WindowEvent e)
      通过调用listener-a和listener-b上的windowLostFocus方法来处理windowLostFocus事件。
      void AWTEventMulticaster.windowOpened​(WindowEvent e)
      通过调用listener-a和listener-b上的windowOpened方法处理windowOpened事件。
      void AWTEventMulticaster.windowStateChanged​(WindowEvent e)
      通过调用listener-a和listener-b上的windowStateChanged方法来处理windowStateChanged事件。

    • Uses of WindowEvent in java.awt.event

      Methods in java.awt.event with parameters of type WindowEvent
      Modifier and Type 方法 描述
      void WindowAdapter.windowActivated​(WindowEvent e)
      激活窗口时调用。
      void WindowListener.windowActivated​(WindowEvent e)
      当窗口设置为活动窗口时调用。
      void WindowAdapter.windowClosed​(WindowEvent e)
      当窗口关闭时调用。
      void WindowListener.windowClosed​(WindowEvent e)
      当窗口关闭时调用窗口调用处理结果时调用。
      void WindowAdapter.windowClosing​(WindowEvent e)
      当窗口处于关闭状态时调用。
      void WindowListener.windowClosing​(WindowEvent e)
      当用户尝试从窗口的系统菜单中关闭窗口时调用。
      void WindowAdapter.windowDeactivated​(WindowEvent e)
      当窗口被禁用时调用。
      void WindowListener.windowDeactivated​(WindowEvent e)
      当窗口不再是活动窗口时调用。
      void WindowAdapter.windowDeiconified​(WindowEvent e)
      当窗口被去图标化时调用。
      void WindowListener.windowDeiconified​(WindowEvent e)
      当窗口从最小化更改为正常状态时调用。
      void WindowAdapter.windowGainedFocus​(WindowEvent e)
      当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
      void WindowFocusListener.windowGainedFocus​(WindowEvent e)
      当窗口设置为聚焦窗口时调用，这意味着窗口或其子组件之一将接收键盘事件。
      void WindowAdapter.windowIconified​(WindowEvent e)
      当窗口被图标化时调用。
      void WindowListener.windowIconified​(WindowEvent e)
      当窗口从正常状态更改为最小化状态时调用。
      void WindowAdapter.windowLostFocus​(WindowEvent e)
      当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。
      void WindowFocusListener.windowLostFocus​(WindowEvent e)
      当窗口不再是聚焦窗口时调用，这意味着键盘事件将不再传递到窗口或其任何子组件。
      void WindowAdapter.windowOpened​(WindowEvent e)
      当窗口打开时调用。
      void WindowListener.windowOpened​(WindowEvent e)
      第一次调用窗口可见。
      void WindowAdapter.windowStateChanged​(WindowEvent e)
      当窗口状态改变时调用。
      void WindowStateListener.windowStateChanged​(WindowEvent e)
      窗口状态改变时调用。

    • Uses of WindowEvent in javax.swing

      Methods in javax.swing with parameters of type WindowEvent
      Modifier and Type 方法 描述
      protected void JDialog.processWindowEvent​(WindowEvent e)
      根据 defaultCloseOperation属性的状态处理窗口事件。
      protected void JFrame.processWindowEvent​(WindowEvent e)
      处理在此组件上发生的窗口事件。
      void JMenu.WinListener.windowClosing​(WindowEvent e)
      弹出窗口从外部关闭时取消选择菜单。

    • Uses of WindowEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type WindowEvent
      Modifier and Type | 方法 | 描述
      void | BasicToolBarUI.FrameListener.windowClosing​(WindowEvent w)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.ActionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.ActionListener

  • Packages that use ActionListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of ActionListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as ActionListener
      Modifier and Type Field 描述
      protected static ActionListener AWTEventMonitor.actionListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type ActionListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addActionListener​(ActionListener l)
      添加指定的侦听器，以便在Java虚拟机发生时的每个组件实例上接收所有 ACTION个事件。
      static void AWTEventMonitor.removeActionListener​(ActionListener l)
      移除指定的侦听器，使其不再接收到 ACTION个事件。

    • Uses of ActionListener in java.awt

      Classes in java.awt that implement ActionListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      protected class  List.AccessibleAWTList
      该类实现 List类的可访问性支持。
      Methods in java.awt that return ActionListener
      Modifier and Type 方法 描述
      static ActionListener AWTEventMulticaster.add​(ActionListener a, ActionListener b)
      添加action-listener-a与action-listener-b，并返回生成的组播侦听器。
      ActionListener[] Button.getActionListeners​()
      返回在此按钮上注册的所有动作侦听器的数组。
      ActionListener[] List.getActionListeners​()
      返回在此列表中注册的所有动作侦听器的数组。
      ActionListener[] MenuItem.getActionListeners​()
      返回在此菜单项上注册的所有动作侦听器的数组。
      ActionListener[] TextField.getActionListeners​()
      返回在此文本域中注册的所有操作侦听器的数组。
      ActionListener[] TrayIcon.getActionListeners​()
      返回在这个 TrayIcon上注册的所有动作侦听器的数组。
      static ActionListener AWTEventMulticaster.remove​(ActionListener l, ActionListener oldl)
      从action-listener-l中删除旧的action-listener，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type ActionListener
      Modifier and Type 方法 描述
      static ActionListener AWTEventMulticaster.add​(ActionListener a, ActionListener b)
      添加action-listener-a与action-listener-b，并返回生成的组播侦听器。
      void Button.addActionListener​(ActionListener l)
      添加指定的动作侦听器以从此按钮接收动作事件。
      void List.addActionListener​(ActionListener l)
      添加指定的动作侦听器以从此列表接收动作事件。
      void MenuItem.addActionListener​(ActionListener l)
      添加指定的动作侦听器以从该菜单项接收动作事件。
      void TextField.addActionListener​(ActionListener l)
      添加指定的动作侦听器以从此文本字段接收动作事件。
      void TrayIcon.addActionListener​(ActionListener listener)
      添加指定的动作侦听器以从此 TrayIcon接收 ActionEvent s。
      static ActionListener AWTEventMulticaster.remove​(ActionListener l, ActionListener oldl)
      从action-listener-l中删除旧的action-listener，并返回生成的组播侦听器。
      void Button.removeActionListener​(ActionListener l)
      删除指定的动作侦听器，使其不再从此按钮接收到动作事件。
      void List.removeActionListener​(ActionListener l)
      删除指定的动作侦听器，使其不再从此列表中接收到动作事件。
      void MenuItem.removeActionListener​(ActionListener l)
      删除指定的动作监听器，使其不再从此菜单项接收动作事件。
      void TextField.removeActionListener​(ActionListener l)
      删除指定的动作侦听器，使其不再从此文本字段接收到动作事件。
      void TrayIcon.removeActionListener​(ActionListener listener)
      删除指定的动作侦听器。

    • Uses of ActionListener in java.awt.dnd

      Classes in java.awt.dnd that implement ActionListener
      Modifier and Type Class 描述
      protected static class  DropTarget.DropTargetAutoScroller
      这个受保护的嵌套类实现自动滚动

    • Uses of ActionListener in javax.swing

      Subinterfaces of ActionListener in javax.swing
      Modifier and Type 接口 描述
      interface  Action
      所述 Action接口提供了一个有用的扩展到 ActionListener在箱子接口，其中相同的功能可以由若干控件访问。
      Classes in javax.swing that implement ActionListener
      Modifier and Type Class 描述
      class  AbstractAction
      该类提供了JFC Action接口的默认实现。
      protected class  DefaultCellEditor.EditorDelegate
      受保护的 EditorDelegate类。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      protected class  ToolTipManager.insideTimerAction
      内部定时器动作。
      protected class  ToolTipManager.outsideTimerAction
      外部定时器动作。
      protected class  ToolTipManager.stillInsideTimerAction
      仍然在定时器动作。
      Fields in javax.swing declared as ActionListener
      Modifier and Type Field 描述
      protected ActionListener AbstractButton.actionListener
      按钮型号 ActionListener 。
      Methods in javax.swing that return ActionListener
      Modifier and Type 方法 描述
      protected ActionListener AbstractButton.createActionListener​()
      返回添加到型号的 ActionListener 。
      ActionListener JComponent.getActionForKeyStroke​(KeyStroke aKeyStroke)
      返回将执行为给定键击注册的操作的对象。
      ActionListener[] AbstractButton.getActionListeners​()
      返回使用addActionListener（）添加到此AbstractButton的所有 ActionListener的数组。
      ActionListener[] DefaultButtonModel.getActionListeners​()
      返回在此 DefaultButtonModel上注册的所有动作侦听器的数组。
      ActionListener[] JComboBox.getActionListeners​()
      返回使用addActionListener（）添加到此JComboBox的所有 ActionListener的数组。
      ActionListener[] JFileChooser.getActionListeners​()
      返回在此文件选择器上注册的所有动作侦听器的数组。
      ActionListener[] JTextField.getActionListeners​()
      返回使用addActionListener（）添加到此JTextField的所有 ActionListener的数组。
      ActionListener[] Timer.getActionListeners​()
      返回在此定时器上注册的所有动作侦听器的数组。
      Methods in javax.swing with parameters of type ActionListener
      Modifier and Type 方法 描述
      void AbstractButton.addActionListener​(ActionListener l)
      在按钮中添加一个 ActionListener 。
      void ButtonModel.addActionListener​(ActionListener l)
      向模型添加一个 ActionListener 。
      void ComboBoxEditor.addActionListener​(ActionListener l)
      添加一个ActionListener。
      void DefaultButtonModel.addActionListener​(ActionListener l)
      添加一个 ActionListener模型。
      void JComboBox.addActionListener​(ActionListener l)
      添加 ActionListener 。
      void JFileChooser.addActionListener​(ActionListener l)
      添加一个 ActionListener到文件选择器。
      void JTextField.addActionListener​(ActionListener l)
      添加指定的动作侦听器以从此文本字段接收动作事件。
      void Timer.addActionListener​(ActionListener listener)
      在 Timer添加一个动作侦听 Timer 。
      static JDialog JColorChooser.createDialog​(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
      创建并返回一个包含指定的 ColorChooser窗格的新对话框以及“确定”，“取消”和“重置”按钮。
      void JComponent.registerKeyboardAction​(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
      此方法现在已经过时了，请使用 getActionMap()和 getInputMap()的组合进行类似的操作。
      void JComponent.registerKeyboardAction​(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
      此方法现已过时，请使用 getActionMap()和 getInputMap()的组合进行类似的操作。
      void AbstractButton.removeActionListener​(ActionListener l)
      从按钮中删除 ActionListener 。
      void ButtonModel.removeActionListener​(ActionListener l)
      从模型中移除 ActionListener 。
      void ComboBoxEditor.removeActionListener​(ActionListener l)
      删除一个ActionListener
      void DefaultButtonModel.removeActionListener​(ActionListener l)
      从模型中移除 ActionListener 。
      void JComboBox.removeActionListener​(ActionListener l)
      删除一个 ActionListener 。
      void JFileChooser.removeActionListener​(ActionListener l)
      从文件选择器中删除一个 ActionListener 。
      void JTextField.removeActionListener​(ActionListener l)
      删除指定的动作监听器，使其不再从此文本字段接收动作事件。
      void Timer.removeActionListener​(ActionListener listener)
      从 Timer删除指定的动作侦听 Timer 。
      Constructors in javax.swing with parameters of type ActionListener
      Constructor 描述
      Timer​(int delay, ActionListener listener)
      创建一个 Timer ，并将初始延迟和事件间延迟初始化为 delay毫秒。

    • Uses of ActionListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ActionListener
      Modifier and Type Class 描述
      protected class  BasicDesktopPaneUI.CloseAction
      处理关闭内部框架。
      protected class  BasicDesktopPaneUI.MaximizeAction
      处理最大化内部框架。
      protected class  BasicDesktopPaneUI.MinimizeAction
      处理最小化内部框架。
      protected class  BasicDesktopPaneUI.NavigateAction
      处理导航到下一个内部框架。
      protected class  BasicDesktopPaneUI.OpenAction
      处理恢复最小化或最大化的内部框架。
      protected class  BasicFileChooserUI.ApproveSelectionAction
      响应打开或保存请求
      protected class  BasicFileChooserUI.CancelSelectionAction
      回复取消请求。
      protected class  BasicFileChooserUI.ChangeToParentDirectoryAction
      更改为父目录操作。
      protected class  BasicFileChooserUI.GoHomeAction
      在“家”键事件或等效事件上行事。
      protected class  BasicFileChooserUI.NewFolderAction
      创建一个新文件夹。
      protected class  BasicFileChooserUI.UpdateAction
      重新扫描当前目录中的文件
      class  BasicInternalFrameTitlePane.CloseAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.IconifyAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MaximizeAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MoveAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.RestoreAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.SizeAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicOptionPaneUI.ButtonActionListener
      这个类应该被视为一个“受保护”的内部类。
      protected class  BasicScrollBarUI.ScrollListener
      ScrollPane发起的滚动事件侦听器。
      class  BasicSliderUI.ActionScroller
      从Java 2平台v1.3开始，这个未记录的类就不再使用了。
      class  BasicSliderUI.ScrollListener
      滚动事件侦听器。
      class  BasicSplitPaneUI.KeyboardDownRightHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardEndHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardHomeHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardResizeToggleHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicSplitPaneUI.KeyboardUpLeftHandler
      JSplitPane UI用于处理特定按键的ActionListener的实现。
      class  BasicTreeUI.ComponentHandler
      更新滚动时的首选大小（如有必要）。
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener在执行操作时调用cancelEditing。
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction用于处理结束/ home操作。
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction用于处理上/下动作。
      class  BasicTreeUI.TreePageAction
      TreePageAction处理页面向上和向下翻页事件。
      class  BasicTreeUI.TreeToggleAction
      对于第一个选定的行展开将被切换。
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction是用于左/右键的动作。
      Fields in javax.swing.plaf.basic declared as ActionListener
      Modifier and Type Field 描述
      protected ActionListener BasicSplitPaneUI.keyboardDownRightListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardEndListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardHomeListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardResizeToggleListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardUpLeftListener
      已过时。
      从Java 2平台v1.3开始。
      Methods in javax.swing.plaf.basic that return ActionListener
      Modifier and Type 方法 描述
      protected ActionListener BasicOptionPaneUI.createButtonActionListener​(int buttonIndex)
      构造一个新的实例 ButtonActionListener 。
      protected ActionListener BasicSplitPaneUI.createKeyboardDownRightListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardEndListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardHomeListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardResizeToggleListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardUpLeftListener​()
      已过时。
      从Java 2平台v1.3开始。
      Methods in javax.swing.plaf.basic with parameters of type ActionListener
      Modifier and Type | 方法 | 描述
      void | BasicComboBoxEditor.addActionListener​(ActionListener l)
      void | BasicComboBoxEditor.removeActionListener​(ActionListener l)

    • Uses of ActionListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ActionListener
      Modifier and Type Class 描述
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      当DirectoryComboBox更改所选项目时使用。

    • Uses of ActionListener in javax.swing.text

      Classes in javax.swing.text that implement ActionListener
      Modifier and Type Class 描述
      static class  DefaultEditorKit.BeepAction
      发出哔声
      static class  DefaultEditorKit.CopyAction
      复制所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.CutAction
      剪切所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.DefaultKeyTypedAction
      如果接收到 键入类型的事件并且没有键映射条目，则默认执行的操作。
      static class  DefaultEditorKit.InsertBreakAction
      在文档中放置一个行/段落。
      static class  DefaultEditorKit.InsertContentAction
      将内容放入相关的文档。
      static class  DefaultEditorKit.InsertTabAction
      将标签字符放在文档中。
      static class  DefaultEditorKit.PasteAction
      将系统剪贴板的内容粘贴到所选区域中，或者如果没有选择任何内容，则将其插入插入符号之前。
      static class  StyledEditorKit.AlignmentAction
      设置段落对齐的动作。
      static class  StyledEditorKit.BoldAction
      用于切换粗体属性的操作。
      static class  StyledEditorKit.FontFamilyAction
      在关联的JEditorPane中设置字体系列的操作。
      static class  StyledEditorKit.FontSizeAction
      在关联的JEditorPane中设置字体大小的操作。
      static class  StyledEditorKit.ForegroundAction
      设置前景色的动作。
      static class  StyledEditorKit.ItalicAction
      切换斜体属性的动作。
      static class  StyledEditorKit.StyledTextAction
      一个假定它被安装在一个带有StyledEditorKit（或子类）的JEditorPane上被触发的动作。
      static class  StyledEditorKit.UnderlineAction
      切换下划线属性的动作。
      class  TextAction
      对于跨多个不同文本组件共享的键绑定的Action实现。

    • Uses of ActionListener in javax.swing.text.html

      Classes in javax.swing.text.html that implement ActionListener
      Modifier and Type Class 描述
      class  FormView
      组件装饰器，用于实现表单元素<input>，<textarea>和<select>的视图界面。
      static class  HTMLEditorKit.HTMLTextAction
      一个抽象的Action提供了一些方便的方法，可能有助于将HTML插入到现有文档中。
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction可用于将HTML的任意字符串插入到现有的HTML文档中。

    • Uses of ActionListener in javax.swing.tree

      Classes in javax.swing.tree that implement ActionListener
      Modifier and Type Class 描述
      class  DefaultTreeCellEditor
      A TreeCellEditor 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.AdjustmentListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.AdjustmentListener

  • Packages that use AdjustmentListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of AdjustmentListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as AdjustmentListener
      Modifier and Type Field 描述
      protected static AdjustmentListener AWTEventMonitor.adjustmentListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type AdjustmentListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addAdjustmentListener​(AdjustmentListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ADJUSTMENT事件。
      static void AWTEventMonitor.removeAdjustmentListener​(AdjustmentListener l)
      删除指定的侦听器，使其不再接收 ADJUSTMENT个事件。

    • Uses of AdjustmentListener in java.awt

      Classes in java.awt that implement AdjustmentListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      Methods in java.awt that return AdjustmentListener
      Modifier and Type 方法 描述
      static AdjustmentListener AWTEventMulticaster.add​(AdjustmentListener a, AdjustmentListener b)
      使用adjust-listener-b添加调整监听器a，并返回生成的组播侦听器。
      AdjustmentListener[] Scrollbar.getAdjustmentListeners​()
      返回在此滚动条上注册的所有调整监听器的数组。
      AdjustmentListener[] ScrollPaneAdjustable.getAdjustmentListeners​()
      返回在这个 ScrollPaneAdjustable上注册的所有调整监听器的数组。
      static AdjustmentListener AWTEventMulticaster.remove​(AdjustmentListener l, AdjustmentListener oldl)
      从调整监听器l中删除旧的调整监听器，并返回结果组播监听器。
      Methods in java.awt with parameters of type AdjustmentListener
      Modifier and Type 方法 描述
      static AdjustmentListener AWTEventMulticaster.add​(AdjustmentListener a, AdjustmentListener b)
      使用adjust-listener-b添加调整监听器a，并返回生成的组播侦听器。
      void Adjustable.addAdjustmentListener​(AdjustmentListener l)
      添加一个监听器，以便在可调整对象的值更改时接收调整事件。
      void Scrollbar.addAdjustmentListener​(AdjustmentListener l)
      添加指定的调整监听器以从此滚动条接收 AdjustmentEvent实例。
      void ScrollPaneAdjustable.addAdjustmentListener​(AdjustmentListener l)
      添加指定的调整监听器以接收来自此 ScrollPaneAdjustable调整事件。
      static AdjustmentListener AWTEventMulticaster.remove​(AdjustmentListener l, AdjustmentListener oldl)
      从调整监听器l中删除旧的调整监听器，并返回结果组播监听器。
      void Adjustable.removeAdjustmentListener​(AdjustmentListener l)
      删除调整监听器。
      void Scrollbar.removeAdjustmentListener​(AdjustmentListener l)
      删除指定的调整监听器，使其不再从此滚动条接收 AdjustmentEvent实例。
      void ScrollPaneAdjustable.removeAdjustmentListener​(AdjustmentListener l)
      删除指定的调整监听器，使其不再从此 ScrollPaneAdjustable接收调整事件。

    • Uses of AdjustmentListener in javax.swing

      Methods in javax.swing that return AdjustmentListener
      Modifier and Type 方法 描述
      AdjustmentListener[] JScrollBar.getAdjustmentListeners​()
      返回使用addAdjustmentListener（）添加到此JScrollBar的所有 AdjustmentListener的数组。
      Methods in javax.swing with parameters of type AdjustmentListener
      Modifier and Type 方法 描述
      void JScrollBar.addAdjustmentListener​(AdjustmentListener l)
      添加一个AdjustmentListener。
      void JScrollBar.removeAdjustmentListener​(AdjustmentListener l)
      删除AdjustmentEvent侦听器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.AWTEventListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.AWTEventListener

  • Packages that use AWTEventListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。

    • Uses of AWTEventListener in com.sun.java.accessibility.util

      Classes in com.sun.java.accessibility.util that implement AWTEventListener
      Modifier and Type Class 描述
      class  EventQueueMonitor
      EventQueueMonitor类为辅助技术提供了关键的核心功能（以及需要与辅助技术需要的相同内容的其他系统级技术）。

    • Uses of AWTEventListener in java.awt

      Methods in java.awt that return AWTEventListener
      Modifier and Type 方法 描述
      AWTEventListener[] Toolkit.getAWTEventListeners​()
      返回在该工具包上注册的所有 AWTEventListener的数组。
      AWTEventListener[] Toolkit.getAWTEventListeners​(long eventMask)
      返回在该工具包上注册的所有 AWTEventListener的数组，该数组监听 eventMask参数中指定的所有事件类型。
      Methods in java.awt with parameters of type AWTEventListener
      Modifier and Type 方法 描述
      void Toolkit.addAWTEventListener​(AWTEventListener listener, long eventMask)
      添加一个AWTEventListener以接收符合给定的 eventMask系统范围内的所有AWTEvent。
      void Toolkit.removeAWTEventListener​(AWTEventListener listener)
      从接收发送的AWTEvent中删除AWTEventListener。

    • Uses of AWTEventListener in java.awt.event

      Classes in java.awt.event that implement AWTEventListener
      Modifier and Type Class 描述
      class  AWTEventListenerProxy
      一个扩展 EventListenerProxy专门用于为特定事件掩码添加一个 AWTEventListener的类。
      Constructors in java.awt.event with parameters of type AWTEventListener
      Constructor 描述
      AWTEventListenerProxy​(long eventMask, AWTEventListener listener)
      将 AWTEventListener绑定到特定事件掩码的构造方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.ComponentListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.ComponentListener

  • Packages that use ComponentListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。

    • Uses of ComponentListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as ComponentListener
      Modifier and Type Field 描述
      protected static ComponentListener AWTEventMonitor.componentListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type ComponentListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addComponentListener​(ComponentListener l)
      添加指定的侦听器，以便在Java虚拟机中发生的每个组件实例上接收所有 COMPONENT事件。
      static void AWTEventMonitor.removeComponentListener​(ComponentListener l)
      移除指定的侦听器，使其不再接收 COMPONENT事件。

    • Uses of ComponentListener in java.awt

      Classes in java.awt that implement ComponentListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现了高效和线程安全的多播事件调度。
      protected class  Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
      Fire PropertyChange监听器，如果已注册，显示/隐藏..
      Fields in java.awt declared as ComponentListener
      Modifier and Type Field 描述
      protected ComponentListener Component.AccessibleAWTComponent.accessibleAWTComponentHandler
      组件侦听器，用于跟踪show / hide / resize事件并将其转换为PropertyChange事件。
      Methods in java.awt that return ComponentListener
      Modifier and Type 方法 描述
      static ComponentListener AWTEventMulticaster.add​(ComponentListener a, ComponentListener b)
      将component-listener-a与component-listener-b相加，并返回生成的组播侦听器。
      ComponentListener[] Component.getComponentListeners​()
      返回在此组件上注册的所有组件侦听器的数组。
      static ComponentListener AWTEventMulticaster.remove​(ComponentListener l, ComponentListener oldl)
      从component-listener-l中删除旧的组件侦听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type ComponentListener
      Modifier and Type 方法 描述
      static ComponentListener AWTEventMulticaster.add​(ComponentListener a, ComponentListener b)
      将component-listener-a与component-listener-b相加，并返回生成的组播侦听器。
      void Component.addComponentListener​(ComponentListener l)
      添加指定的组件侦听器以从该组件接收组件事件。
      static ComponentListener AWTEventMulticaster.remove​(ComponentListener l, ComponentListener oldl)
      从component-listener-l中删除旧的组件侦听器，并返回生成的组播侦听器。
      void Component.removeComponentListener​(ComponentListener l)
      删除指定的组件侦听器，使其不再从此组件接收组件事件。

    • Uses of ComponentListener in java.awt.event

      Classes in java.awt.event that implement ComponentListener
      Modifier and Type Class 描述
      class  ComponentAdapter
      用于接收组件事件的抽象适配器类。

    • Uses of ComponentListener in javax.swing

      Classes in javax.swing that implement ComponentListener
      Modifier and Type Class 描述
      protected class  JViewport.ViewListener
      视图的监听器。

    • Uses of ComponentListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ComponentListener
      Modifier and Type Class 描述
      protected class  BasicInternalFrameUI.ComponentHandler
      组件处理程序
      class  BasicSliderUI.ComponentHandler
      调整事件大小的侦听器。
      class  BasicTreeUI.ComponentHandler
      更新滚动时的首选大小（如有必要）。
      Fields in javax.swing.plaf.basic declared as ComponentListener
      Modifier and Type Field 描述
      protected ComponentListener BasicInternalFrameUI.componentListener
      组件侦听器
      protected ComponentListener BasicSliderUI.componentListener
      组件侦听器
      Methods in javax.swing.plaf.basic that return ComponentListener
      Modifier and Type 方法 描述
      protected ComponentListener BasicInternalFrameUI.createComponentListener​()
      创建组件侦听器。
      protected ComponentListener BasicSliderUI.createComponentListener​(JSlider slider)
      创建一个复合侦听器。
      protected ComponentListener BasicTreeUI.createComponentListener​()
      创建并返回一个新的ComponentHandler。

    • Uses of ComponentListener in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return ComponentListener
      Modifier and Type 方法 描述
      protected ComponentListener SynthInternalFrameUI.createComponentListener​()
      Creates a component listener.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.ContainerListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.ContainerListener

  • Packages that use ContainerListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。

    • Uses of ContainerListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as ContainerListener
      Modifier and Type Field 描述
      protected static ContainerListener AWTEventMonitor.containerListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type ContainerListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addContainerListener​(ContainerListener l)
      添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 CONTAINER事件。
      static void AWTEventMonitor.removeContainerListener​(ContainerListener l)
      删除指定的侦听器，使其不再接收 CONTAINER事件。

    • Uses of ContainerListener in java.awt

      Classes in java.awt that implement ContainerListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      protected class  Container.AccessibleAWTContainer.AccessibleContainerHandler
      Fire PropertyChange侦听器，如果有人注册，当孩子被添加或删除。
      Fields in java.awt declared as ContainerListener
      Modifier and Type Field 描述
      protected ContainerListener Container.AccessibleAWTContainer.accessibleContainerHandler
      处理器 PropertyChange当孩子被添加或删除时
      Methods in java.awt that return ContainerListener
      Modifier and Type 方法 描述
      static ContainerListener AWTEventMulticaster.add​(ContainerListener a, ContainerListener b)
      将container-listener-a与container-listener-b相加，并返回生成的组播侦听器。
      ContainerListener[] Container.getContainerListeners​()
      返回在此容器上注册的所有容器侦听器的数组。
      static ContainerListener AWTEventMulticaster.remove​(ContainerListener l, ContainerListener oldl)
      从container-listener-l中删除旧容器监听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type ContainerListener
      Modifier and Type 方法 描述
      static ContainerListener AWTEventMulticaster.add​(ContainerListener a, ContainerListener b)
      将container-listener-a与container-listener-b相加，并返回生成的组播侦听器。
      void Container.addContainerListener​(ContainerListener l)
      添加指定的容器侦听器以从此容器接收容器事件。
      static ContainerListener AWTEventMulticaster.remove​(ContainerListener l, ContainerListener oldl)
      从container-listener-l中删除旧容器监听器，并返回生成的组播侦听器。
      void Container.removeContainerListener​(ContainerListener l)
      删除指定的容器侦听器，使其不再从此容器接收容器事件。

    • Uses of ContainerListener in java.awt.event

      Classes in java.awt.event that implement ContainerListener
      Modifier and Type Class 描述
      class  ContainerAdapter
      用于接收容器事件的抽象适配器类。

    • Uses of ContainerListener in javax.swing

      Classes in javax.swing that implement ContainerListener
      Modifier and Type Class 描述
      protected class  JComponent.AccessibleJComponent.AccessibleContainerHandler
      Fire PropertyChange监听器，如果一个注册，当孩子添加/删除。

    • Uses of ContainerListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ContainerListener
      Modifier and Type Class 描述
      protected class  BasicToolBarUI.ToolBarContListener
      该类侦听组件事件。
      Fields in javax.swing.plaf.basic declared as ContainerListener
      Modifier and Type Field 描述
      protected ContainerListener BasicMenuBarUI.containerListener
      实例 ContainerListener 。
      protected ContainerListener BasicToolBarUI.toolBarContListener
      一个 ContainerListener的实例。
      Methods in javax.swing.plaf.basic that return ContainerListener
      Modifier and Type 方法 描述
      protected ContainerListener BasicMenuBarUI.createContainerListener​()
      返回一个 ContainerListener的实例。
      protected ContainerListener BasicToolBarUI.createToolBarContListener​()
      返回一个 ContainerListener的实例。

    • Uses of ContainerListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ContainerListener
      Modifier and Type Class 描述
      protected class  MetalToolBarUI.MetalContainerListener
      不再使用
      Fields in javax.swing.plaf.metal declared as ContainerListener
      Modifier and Type Field 描述
      protected ContainerListener MetalToolBarUI.contListener
      此保护字段是实现特定的。
      Methods in javax.swing.plaf.metal that return ContainerListener
      Modifier and Type 方法 描述
      protected ContainerListener MetalToolBarUI.createContainerListener​()
      创建一个将添加到JToolBar的容器监听器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.FocusListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.FocusListener

  • Packages that use FocusListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of FocusListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as FocusListener
      Modifier and Type Field 描述
      protected static FocusListener AWTEventMonitor.focusListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type FocusListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addFocusListener​(FocusListener l)
      添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 FOCUS事件。
      void Translator.addFocusListener​(FocusListener l)
      添加指定的 FocusListener以从该组件接收焦点事件。
      static void AWTEventMonitor.removeFocusListener​(FocusListener l)
      删除指定的侦听器，使其不再接收 FOCUS个事件。
      void Translator.removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。

    • Uses of FocusListener in java.awt

      Classes in java.awt that implement FocusListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      protected class  Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
      Fire PropertyChange监听器，如果有注册，焦点事件发生时
      Fields in java.awt declared as FocusListener
      Modifier and Type Field 描述
      protected FocusListener Component.AccessibleAWTComponent.accessibleAWTFocusHandler
      监听焦点事件并将其转换为PropertyChange事件的侦听器。
      Methods in java.awt that return FocusListener
      Modifier and Type 方法 描述
      static FocusListener AWTEventMulticaster.add​(FocusListener a, FocusListener b)
      将focus-listener-a与focus-listener-b相加，并返回生成的组播侦听器。
      FocusListener[] Component.getFocusListeners​()
      返回在此组件上注册的所有焦点侦听器的数组。
      static FocusListener AWTEventMulticaster.remove​(FocusListener l, FocusListener oldl)
      从focus-listener-l中删除旧的focus-listener，并返回生成的组播监听器。
      Methods in java.awt with parameters of type FocusListener
      Modifier and Type 方法 描述
      static FocusListener AWTEventMulticaster.add​(FocusListener a, FocusListener b)
      将focus-listener-a与focus-listener-b相加，并返回生成的组播侦听器。
      void Component.AccessibleAWTComponent.addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      void Component.addFocusListener​(FocusListener l)
      当该组件获得输入焦点时，添加指定的焦点侦听器以从该组件接收焦点事件。
      void List.AccessibleAWTList.AccessibleAWTListChild.addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      void MenuComponent.AccessibleAWTMenuComponent.addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      static FocusListener AWTEventMulticaster.remove​(FocusListener l, FocusListener oldl)
      从focus-listener-l中删除旧的focus-listener，并返回生成的组播监听器。
      void Component.AccessibleAWTComponent.removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void Component.removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void List.AccessibleAWTList.AccessibleAWTListChild.removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。
      void MenuComponent.AccessibleAWTMenuComponent.removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。

    • Uses of FocusListener in java.awt.event

      Classes in java.awt.event that implement FocusListener
      Modifier and Type Class 描述
      class  FocusAdapter
      用于接收键盘焦点事件的抽象适配器类。

    • Uses of FocusListener in javax.accessibility

      Methods in javax.accessibility with parameters of type FocusListener
      Modifier and Type 方法 描述
      void AccessibleComponent.addFocusListener​(FocusListener l)
      新新新200新新新200新新新200新新新200新新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新
      void AccessibleComponent.removeFocusListener​(FocusListener l)
      删除指定的焦点侦听器，使其不再从此组件接收焦点事件。

    • Uses of FocusListener in javax.swing

      Classes in javax.swing that implement FocusListener
      Modifier and Type Class 描述
      protected class  JComponent.AccessibleJComponent.AccessibleFocusHandler
      已过时。
      此类不再使用或需要。 java.awt.Component.AccessibleAWTComponent提供相同的功能，它在Component处理。
      Fields in javax.swing declared as FocusListener
      Modifier and Type Field 描述
      protected FocusListener JComponent.AccessibleJComponent.accessibleFocusHandler
      已过时。
      Methods in javax.swing with parameters of type FocusListener
      Modifier and Type | 方法 | 描述
      void | JList.AccessibleJList.AccessibleJListChild.addFocusListener​(FocusListener l)
      void | JTable.AccessibleJTable.AccessibleJTableCell.addFocusListener​(FocusListener l)
      void | JTree.AccessibleJTree.AccessibleJTreeNode.addFocusListener​(FocusListener l)
      void | JList.AccessibleJList.AccessibleJListChild.removeFocusListener​(FocusListener l)
      void | JTable.AccessibleJTable.AccessibleJTableCell.removeFocusListener​(FocusListener l)
      void | JTree.AccessibleJTree.AccessibleJTreeNode.removeFocusListener​(FocusListener l)

    • Uses of FocusListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement FocusListener
      Modifier and Type Class 描述
      class  BasicButtonListener
      按钮监听器
      class  BasicComboBoxEditor
      可编辑组合框的默认编辑器。
      static class  BasicComboBoxEditor.UIResource
      BasicComboBoxEditor的子类实现UIResource。
      class  BasicComboBoxUI.FocusHandler
      当焦点丢失时，此侦听器隐藏弹出窗口。
      class  BasicListUI.FocusHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicSliderUI.FocusHandler
      聚焦改变听众
      class  BasicSplitPaneUI.FocusHandler
      JSplitPane UI使用的FocusListener的实现。
      class  BasicTabbedPaneUI.FocusHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableUI.FocusHandler
      这个类应该被视为一个“受保护”的内部类。
      static class  BasicTextUI.BasicCaret
      默认实现接口 Caret 。
      protected class  BasicToolBarUI.ToolBarFocusListener
      班级聆听焦点事件。
      class  BasicTreeUI.FocusHandler
      当重点丢失/获得时，重新排列主导选择行。
      Fields in javax.swing.plaf.basic declared as FocusListener
      Modifier and Type Field 描述
      protected FocusListener BasicComboBoxUI.focusListener
      此保护字段是实现特定的。
      protected FocusListener BasicListUI.focusListener
      FocusListener ，附于 JList 。
      protected FocusListener BasicSliderUI.focusListener
      聚焦听众
      protected FocusListener BasicSplitPaneUI.focusListener
      此JSplitPane的FocusListener的实例。
      protected FocusListener BasicTabbedPaneUI.focusListener
      焦点变化听众
      protected FocusListener BasicTableUI.focusListener
      FocusListener附加到 JTable 。
      protected FocusListener BasicToolBarUI.toolBarFocusListener
      一个 FocusListener 。
      Methods in javax.swing.plaf.basic that return FocusListener
      Modifier and Type 方法 描述
      protected FocusListener BasicComboBoxUI.createFocusListener​()
      创建一个将被添加到组合框的 FocusListener 。
      protected FocusListener BasicListUI.createFocusListener​()
      返回一个 FocusListener的实例。
      protected FocusListener BasicSliderUI.createFocusListener​(JSlider slider)
      创建焦点侦听器。
      protected FocusListener BasicSplitPaneUI.createFocusListener​()
      为 JSplitPane UI创建一个 FocusListener 。
      protected FocusListener BasicTabbedPaneUI.createFocusListener​()
      创建焦点侦听器。
      protected FocusListener BasicTableUI.createFocusListener​()
      在 JTable创建处理键盘导航的焦点侦听 JTable 。
      protected FocusListener BasicTreeUI.createFocusListener​()
      创建一个监听器，负责在焦点丢失/获取时更新显示。
      protected FocusListener BasicToolBarUI.createToolBarFocusListener​()
      返回一个 FocusListener的实例。

    • Uses of FocusListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement FocusListener
      Modifier and Type Class 描述
      class  MetalComboBoxEditor
      Metal可编辑组合框的默认编辑器
      static class  MetalComboBoxEditor.UIResource
      BasicComboBoxEditor的子类实现UIResource。

    • Uses of FocusListener in javax.swing.table

      Methods in javax.swing.table with parameters of type FocusListener
      Modifier and Type | 方法 | 描述
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addFocusListener​(FocusListener l)
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.removeFocusListener​(FocusListener l)

    • Uses of FocusListener in javax.swing.text

      Classes in javax.swing.text that implement FocusListener
      Modifier and Type Class 描述
      class  DefaultCaret
      A default implementation of Caret.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.HierarchyBoundsListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.HierarchyBoundsListener

  • Packages that use HierarchyBoundsListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。

    • Uses of HierarchyBoundsListener in java.awt

      Classes in java.awt that implement HierarchyBoundsListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现了高效和线程安全的多播事件调度。
      Methods in java.awt that return HierarchyBoundsListener
      Modifier and Type 方法 描述
      static HierarchyBoundsListener AWTEventMulticaster.add​(HierarchyBoundsListener a, HierarchyBoundsListener b)
      将hierarchy-bounds-listener-a与hierarchy-bounds-listener-b相加，并返回生成的组播监听器。
      HierarchyBoundsListener[] Component.getHierarchyBoundsListeners​()
      返回在此组件上注册的所有层次结构边界侦听器的数组。
      static HierarchyBoundsListener AWTEventMulticaster.remove​(HierarchyBoundsListener l, HierarchyBoundsListener oldl)
      从hierarchy-bounds-listener-l中删除旧的hierarchy-bounds-listener，并返回生成的组播监听器。
      Methods in java.awt with parameters of type HierarchyBoundsListener
      Modifier and Type 方法 描述
      static HierarchyBoundsListener AWTEventMulticaster.add​(HierarchyBoundsListener a, HierarchyBoundsListener b)
      将hierarchy-bounds-listener-a与hierarchy-bounds-listener-b相加，并返回生成的组播监听器。
      void Component.addHierarchyBoundsListener​(HierarchyBoundsListener l)
      添加指定的层次结构边界侦听器以在此容器所属的层次结构更改时从此组件接收层次结构边界事件。
      static HierarchyBoundsListener AWTEventMulticaster.remove​(HierarchyBoundsListener l, HierarchyBoundsListener oldl)
      从hierarchy-bounds-listener-l中删除旧的hierarchy-bounds-listener，并返回生成的组播监听器。
      void Component.removeHierarchyBoundsListener​(HierarchyBoundsListener l)
      删除指定的层次结构边界监听器，使其不再从此组件接收层次结构限制事件。

    • Uses of HierarchyBoundsListener in java.awt.event

      Classes in java.awt.event that implement HierarchyBoundsListener
      Modifier and Type Class 描述
      class  HierarchyBoundsAdapter
      用于接收祖先移动和调整大小的事件的抽象适配器类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.HierarchyListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.HierarchyListener

  • Packages that use HierarchyListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of HierarchyListener in java.awt

      Classes in java.awt that implement HierarchyListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event软件包中定义的AWT事件实现高效和线程安全的多播事件调度。
      Methods in java.awt that return HierarchyListener
      Modifier and Type 方法 描述
      static HierarchyListener AWTEventMulticaster.add​(HierarchyListener a, HierarchyListener b)
      添加具有hierarchy-listener-b的hierarchy-listener-a并返回生成的组播侦听器。
      HierarchyListener[] Component.getHierarchyListeners​()
      返回在此组件上注册的所有层级监听器的数组。
      static HierarchyListener AWTEventMulticaster.remove​(HierarchyListener l, HierarchyListener oldl)
      从hierarchy-listener-l中删除旧的层次结构监听器，并返回结果组播监听器。
      Methods in java.awt with parameters of type HierarchyListener
      Modifier and Type 方法 描述
      static HierarchyListener AWTEventMulticaster.add​(HierarchyListener a, HierarchyListener b)
      添加具有hierarchy-listener-b的hierarchy-listener-a并返回生成的组播侦听器。
      void Component.addHierarchyListener​(HierarchyListener l)
      添加指定的层次监听器，以便在此容器所属的层次结构更改时从此组件接收层次结构更改的事件。
      static HierarchyListener AWTEventMulticaster.remove​(HierarchyListener l, HierarchyListener oldl)
      从hierarchy-listener-l中删除旧的层次结构监听器，并返回结果组播监听器。
      void Component.removeHierarchyListener​(HierarchyListener l)
      删除指定的层次监听器，使其不再从此组件接收层次结构更改的事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.InputMethodListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.InputMethodListener

  • Packages that use InputMethodListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of InputMethodListener in java.awt

      Classes in java.awt that implement InputMethodListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster针对 java.awt.event软件包中定义的AWT事件实现了高效和线程安全的多播事件调度。
      Methods in java.awt that return InputMethodListener
      Modifier and Type 方法 描述
      static InputMethodListener AWTEventMulticaster.add​(InputMethodListener a, InputMethodListener b)
      将input-method-listener-a与input-method-listener-b相加，并返回生成的组播侦听器。
      InputMethodListener[] Component.getInputMethodListeners​()
      返回在此组件上注册的所有输入法侦听器的数组。
      static InputMethodListener AWTEventMulticaster.remove​(InputMethodListener l, InputMethodListener oldl)
      从input-method-listener-l中删除旧的输入法侦听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type InputMethodListener
      Modifier and Type 方法 描述
      static InputMethodListener AWTEventMulticaster.add​(InputMethodListener a, InputMethodListener b)
      将input-method-listener-a与input-method-listener-b相加，并返回生成的组播侦听器。
      void Component.addInputMethodListener​(InputMethodListener l)
      添加指定的输入法侦听器以从该组件接收输入法事件。
      static InputMethodListener AWTEventMulticaster.remove​(InputMethodListener l, InputMethodListener oldl)
      从input-method-listener-l中删除旧的输入法侦听器，并返回生成的组播侦听器。
      void Component.removeInputMethodListener​(InputMethodListener l)
      删除指定的输入法侦听器，使其不再从此组件接收输入法事件。

    • Uses of InputMethodListener in javax.swing.text

      Methods in javax.swing.text with parameters of type InputMethodListener
      Modifier and Type | 方法 | 描述
      void | JTextComponent.addInputMethodListener​(InputMethodListener l)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.ItemListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.ItemListener

  • Packages that use ItemListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of ItemListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as ItemListener
      Modifier and Type Field 描述
      protected static ItemListener AWTEventMonitor.itemListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type ItemListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addItemListener​(ItemListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 ITEM个事件。
      static void AWTEventMonitor.removeItemListener​(ItemListener l)
      删除指定的侦听器，使其不再接收 ITEM个事件。

    • Uses of ItemListener in java.awt

      Classes in java.awt that implement ItemListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event软件包中定义的AWT事件实现高效和线程安全的多播事件调度。
      protected class  Checkbox.AccessibleAWTCheckbox
      这个类实现 Checkbox类的可访问性支持。
      protected class  List.AccessibleAWTList
      该类实现 List类的可访问性支持。
      Methods in java.awt that return ItemListener
      Modifier and Type 方法 描述
      static ItemListener AWTEventMulticaster.add​(ItemListener a, ItemListener b)
      将item-listener-a与item-listener-b相加，并返回生成的组播监听器。
      ItemListener[] Checkbox.getItemListeners​()
      返回在此复选框上注册的所有项目侦听器的数组。
      ItemListener[] CheckboxMenuItem.getItemListeners​()
      返回在此复选框菜单上注册的所有项目侦听器的数组。
      ItemListener[] Choice.getItemListeners​()
      返回在此选项上注册的所有项目侦听器的数组。
      ItemListener[] List.getItemListeners​()
      返回在此列表中注册的所有项目侦听器的数组。
      static ItemListener AWTEventMulticaster.remove​(ItemListener l, ItemListener oldl)
      从item-listener-l中删除旧的项目监听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type ItemListener
      Modifier and Type 方法 描述
      static ItemListener AWTEventMulticaster.add​(ItemListener a, ItemListener b)
      将item-listener-a与item-listener-b相加，并返回生成的组播监听器。
      void Checkbox.addItemListener​(ItemListener l)
      添加指定的项目侦听器以从此复选框接收项目事件。
      void CheckboxMenuItem.addItemListener​(ItemListener l)
      添加指定的项目侦听器以从此复选框菜单项接收项目事件。
      void Choice.addItemListener​(ItemListener l)
      添加指定的项目监听器以从此 Choice菜单接收项目事件。
      void ItemSelectable.addItemListener​(ItemListener l)
      当用户更改项目的状态时，添加监听器以接收项目事件。
      void List.addItemListener​(ItemListener l)
      添加指定的项目侦听器以从该列表接收项目事件。
      static ItemListener AWTEventMulticaster.remove​(ItemListener l, ItemListener oldl)
      从item-listener-l中删除旧的项目监听器，并返回生成的组播侦听器。
      void Checkbox.removeItemListener​(ItemListener l)
      删除指定的项目监听器，以使项目监听器不再从此复选框接收项目事件。
      void CheckboxMenuItem.removeItemListener​(ItemListener l)
      删除指定的项目监听器，使其不再从此复选框菜单项目接收项目事件。
      void Choice.removeItemListener​(ItemListener l)
      删除指定的项目监听器，使其不再从此 Choice菜单中接收项目事件。
      void ItemSelectable.removeItemListener​(ItemListener l)
      删除项目侦听器。
      void List.removeItemListener​(ItemListener l)
      删除指定的项目监听器，使其不再从此列表中接收项目事件。

    • Uses of ItemListener in javax.swing

      Classes in javax.swing that implement ItemListener
      Modifier and Type Class 描述
      protected class  DefaultCellEditor.EditorDelegate
      受保护的 EditorDelegate课。
      protected class  JCheckBox.AccessibleJCheckBox
      该类实现 JCheckBox类的辅助功能支持。
      protected class  JRadioButton.AccessibleJRadioButton
      这个类实现 JRadioButton类的可访问性支持。
      protected class  JToggleButton.AccessibleJToggleButton
      该类为 JToggleButton类实现可访问性支持。
      Fields in javax.swing declared as ItemListener
      Modifier and Type Field 描述
      protected ItemListener AbstractButton.itemListener
      按钮型号 ItemListener 。
      Methods in javax.swing that return ItemListener
      Modifier and Type 方法 描述
      protected ItemListener AbstractButton.createItemListener​()
      返回 ItemListener ，它被添加到模型中。
      ItemListener[] AbstractButton.getItemListeners​()
      返回一个使用addItemListener（）添加到此AbstractButton的所有 ItemListener的数组。
      ItemListener[] DefaultButtonModel.getItemListeners​()
      返回在此 DefaultButtonModel上注册的所有项目侦听器的数组。
      ItemListener[] JComboBox.getItemListeners​()
      返回使用addItemListener（）添加到此JComboBox的所有 ItemListener的数组。
      Methods in javax.swing with parameters of type ItemListener
      Modifier and Type 方法 描述
      void AbstractButton.addItemListener​(ItemListener l)
      为 ItemListener添加一个 checkbox 。
      void ButtonModel.addItemListener​(ItemListener l)
      添加一个 ItemListener到模型。
      void DefaultButtonModel.addItemListener​(ItemListener l)
      向模型添加一个 ItemListener 。
      void JComboBox.addItemListener​(ItemListener aListener)
      添加一个 ItemListener 。
      void AbstractButton.removeItemListener​(ItemListener l)
      从按钮中删除 ItemListener 。
      void ButtonModel.removeItemListener​(ItemListener l)
      从模型中移除 ItemListener 。
      void DefaultButtonModel.removeItemListener​(ItemListener l)
      从模型中移除 ItemListener 。
      void JComboBox.removeItemListener​(ItemListener aListener)
      删除一个 ItemListener 。

    • Uses of ItemListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ItemListener
      Modifier and Type Class 描述
      class  BasicComboBoxUI.ItemHandler
      此监听器监视组合框中对选择的更改。
      protected class  BasicComboPopup.ItemHandler
      此监听器监视组合框中对选择的更改。
      Fields in javax.swing.plaf.basic declared as ItemListener
      Modifier and Type Field 描述
      protected ItemListener BasicComboBoxUI.itemListener
      此保护字段是实现特定的。
      protected ItemListener BasicComboPopup.itemListener
      此保护字段是实现特定的。
      Methods in javax.swing.plaf.basic that return ItemListener
      Modifier and Type 方法 描述
      protected ItemListener BasicComboBoxUI.createItemListener​()
      创建一个 ItemListener ，它将被添加到组合框中。
      protected ItemListener BasicComboPopup.createItemListener​()
      创建一个将被添加到组合框的 ItemListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.KeyListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.KeyListener

  • Packages that use KeyListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of KeyListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as KeyListener
      Modifier and Type Field 描述
      protected static KeyListener AWTEventMonitor.keyListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type KeyListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addKeyListener​(KeyListener l)
      添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 KEY事件。
      static void AWTEventMonitor.removeKeyListener​(KeyListener l)
      删除指定的侦听器，使其不再接收 27047436641394事件。

    • Uses of KeyListener in java.awt

      Classes in java.awt that implement KeyListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现了高效和线程安全的多播事件调度。
      Methods in java.awt that return KeyListener
      Modifier and Type 方法 描述
      static KeyListener AWTEventMulticaster.add​(KeyListener a, KeyListener b)
      将key-listener-a与key-listener-b相加，并返回生成的组播侦听器。
      KeyListener[] Component.getKeyListeners​()
      返回在此组件上注册的所有关键侦听器的数组。
      static KeyListener AWTEventMulticaster.remove​(KeyListener l, KeyListener oldl)
      从key-listener-l中删除旧的密钥监听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type KeyListener
      Modifier and Type 方法 描述
      static KeyListener AWTEventMulticaster.add​(KeyListener a, KeyListener b)
      将key-listener-a与key-listener-b相加，并返回生成的组播侦听器。
      void Component.addKeyListener​(KeyListener l)
      添加指定的密钥侦听器以从该组件接收密钥事件。
      static KeyListener AWTEventMulticaster.remove​(KeyListener l, KeyListener oldl)
      从key-listener-l中删除旧的密钥监听器，并返回生成的组播侦听器。
      void Component.removeKeyListener​(KeyListener l)
      删除指定的密钥侦听器，使其不再从此组件接收密钥事件。

    • Uses of KeyListener in java.awt.event

      Classes in java.awt.event that implement KeyListener
      Modifier and Type Class 描述
      class  KeyAdapter
      用于接收键盘事件的抽象适配器类。

    • Uses of KeyListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement KeyListener
      Modifier and Type Class 描述
      class  BasicComboBoxUI.KeyHandler
      该侦听器检查键事件是否不是导航键。
      class  BasicComboPopup.InvocationKeyHandler
      从Java 2平台v 1.4开始，此类现在已经过时，仅用于向后兼容API。
      class  BasicTableUI.KeyHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTreeUI.KeyHandler
      这用于获取多个关键事件以适当地生成事件。
      Fields in javax.swing.plaf.basic declared as KeyListener
      Modifier and Type Field 描述
      protected KeyListener BasicComboBoxUI.keyListener
      此保护字段是实现特定的。
      protected KeyListener BasicComboPopup.keyListener
      此保护字段是实现特定的。
      protected KeyListener BasicTableUI.keyListener
      KeyListener ，附于 JTable 。
      protected KeyListener BasicComboBoxUI.popupKeyListener
      KeyListener聆听事件。
      Methods in javax.swing.plaf.basic that return KeyListener
      Modifier and Type 方法 描述
      protected KeyListener BasicComboBoxUI.createKeyListener​()
      创建一个 KeyListener将被添加到组合框。
      protected KeyListener BasicComboPopup.createKeyListener​()
      创建将添加到组合框的关键侦听器。
      protected KeyListener BasicTableUI.createKeyListener​()
      在 JTable创建处理键盘导航的关键侦听 JTable 。
      protected KeyListener BasicTreeUI.createKeyListener​()
      创建负责从树中获取关键事件的监听器。
      KeyListener BasicComboPopup.getKeyListener​()
      实现ComboPopup.getKeyListener（）。
      KeyListener ComboPopup.getKeyListener​()
      Returns a key listener that will be added to the combo box or null.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.MouseListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.MouseListener

  • Packages that use MouseListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。

    • Uses of MouseListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as MouseListener
      Modifier and Type Field 描述
      protected static MouseListener AWTEventMonitor.mouseListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type MouseListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addMouseListener​(MouseListener l)
      添加指定的侦听器，以便在Java虚拟机发生时的每个组件实例上接收所有 MOUSE事件。
      static void AWTEventMonitor.removeMouseListener​(MouseListener l)
      移除指定的侦听器，使其不再接收 MOUSE事件。

    • Uses of MouseListener in java.awt

      Classes in java.awt that implement MouseListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      Methods in java.awt that return MouseListener
      Modifier and Type 方法 描述
      static MouseListener AWTEventMulticaster.add​(MouseListener a, MouseListener b)
      添加mouse-listener-a与mouse-listener-b并返回结果组播监听器。
      MouseListener[] Component.getMouseListeners​()
      返回在此组件上注册的所有鼠标监听器的数组。
      MouseListener[] TrayIcon.getMouseListeners​()
      返回在这个 TrayIcon上注册的所有鼠标监听器的数组。
      static MouseListener AWTEventMulticaster.remove​(MouseListener l, MouseListener oldl)
      从mouse-listener-l中删除旧的鼠标监听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type MouseListener
      Modifier and Type 方法 描述
      static MouseListener AWTEventMulticaster.add​(MouseListener a, MouseListener b)
      添加mouse-listener-a与mouse-listener-b并返回结果组播监听器。
      void Component.addMouseListener​(MouseListener l)
      添加指定的鼠标监听器以从该组件接收鼠标事件。
      void TrayIcon.addMouseListener​(MouseListener listener)
      添加指定的鼠标监听器以从此 TrayIcon接收鼠标事件。
      static MouseListener AWTEventMulticaster.remove​(MouseListener l, MouseListener oldl)
      从mouse-listener-l中删除旧的鼠标监听器，并返回生成的组播侦听器。
      void Component.removeMouseListener​(MouseListener l)
      删除指定的鼠标监听器，使其不再从此组件接收鼠标事件。
      void TrayIcon.removeMouseListener​(MouseListener listener)
      删除指定的鼠标监听器。

    • Uses of MouseListener in java.awt.dnd

      Classes in java.awt.dnd that implement MouseListener
      Modifier and Type Class 描述
      class  MouseDragGestureRecognizer
      DragGestureRecognizer这个抽象子类定义了一个 DragGestureRecognizer用于基于鼠标的手势。

    • Uses of MouseListener in java.awt.event

      Classes in java.awt.event that implement MouseListener
      Modifier and Type Class 描述
      class  MouseAdapter
      用于接收鼠标事件的抽象适配器类。

    • Uses of MouseListener in javax.swing

      Classes in javax.swing that implement MouseListener
      Modifier and Type Class 描述
      class  ToolTipManager
      管理系统中的所有 ToolTips 。

    • Uses of MouseListener in javax.swing.event

      Subinterfaces of MouseListener in javax.swing.event
      Modifier and Type 接口 描述
      interface  MouseInputListener
      一个监听器，实现 MouseListener和 MouseMotionListener接口中的所有方法。
      Classes in javax.swing.event that implement MouseListener
      Modifier and Type Class 描述
      class  MouseInputAdapter
      一个空的实现的 MouseInputListener接口，为方便简化创建监听器的任务，仅通过扩展和实现感兴趣的方法。

    • Uses of MouseListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement MouseListener
      Modifier and Type Class 描述
      class  BasicButtonListener
      按钮监听器
      protected class  BasicComboPopup.InvocationMouseHandler
      在组合框（ 而不是其弹出菜单）上注册的侦听器来处理影响弹出菜单状态的鼠标事件。
      protected class  BasicComboPopup.ListMouseHandler
      当列表中释放鼠标时，此侦听器会隐藏弹出窗口。
      class  BasicDesktopIconUI.MouseInputHandler
      监听鼠标移动并对其进行操作。
      protected class  BasicFileChooserUI.DoubleClickListener
      双击监听器。
      protected class  BasicInternalFrameUI.BorderListener
      倾听边界调整。
      protected class  BasicInternalFrameUI.GlassPaneDispatcher
      玻璃窗格调度器。
      class  BasicListUI.MouseInputHandler
      鼠标输入和JList的焦点处理。
      protected class  BasicMenuItemUI.MouseInputHandler
      鼠标输入处理程序
      protected class  BasicMenuUI.MouseInputHandler
      由菜单项实例化和使用，以处理鼠标事件当前的菜单选择。
      protected class  BasicScrollBarUI.ArrowButtonListener
      光标键侦听器。
      protected class  BasicScrollBarUI.TrackListener
      跟踪鼠标拖动。
      class  BasicSliderUI.TrackListener
      跟踪鼠标移动。
      protected class  BasicSplitPaneDivider.MouseHandler
      MouseHandler负责将鼠标事件（释放，拖动...）转换为适当的DragController方法。
      class  BasicTabbedPaneUI.MouseHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableHeaderUI.MouseInputHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableUI.MouseInputHandler
      这个类应该被视为一个“受保护”的内部类。
      static class  BasicTextUI.BasicCaret
      默认实现接口 Caret 。
      class  BasicToolBarUI.DockingListener
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTreeUI.MouseHandler
      TreeMouseListener负责根据鼠标事件更新选择。
      class  BasicTreeUI.MouseInputHandler
      MouseInputHandler处理所有鼠标事件，包括鼠标移动事件，直到鼠标释放到它构造的目的地。
      Fields in javax.swing.plaf.basic declared as MouseListener
      Modifier and Type Field 描述
      protected MouseListener BasicComboPopup.listMouseListener
      此保护字段是实现特定的。
      protected MouseListener BasicComboPopup.mouseListener
      此保护字段是实现特定的。
      protected MouseListener BasicTabbedPaneUI.mouseListener
      鼠标更改侦听器
      protected MouseListener BasicComboBoxUI.popupMouseListener
      MouseListener倾听事件。
      Methods in javax.swing.plaf.basic that return MouseListener
      Modifier and Type 方法 描述
      protected MouseListener BasicFileChooserUI.createDoubleClickListener​(JFileChooser fc, JList<?> list)
      创建一个双击监听器。
      protected MouseListener BasicComboPopup.createListMouseListener​()
      创建一个鼠标监听器，在弹出的列表中监视鼠标事件。
      protected MouseListener BasicComboPopup.createMouseListener​()
      创建一个监听器，它将在组合框上观察鼠标按键和释放事件。
      protected MouseListener BasicTabbedPaneUI.createMouseListener​()
      创建一个鼠标监听器。
      protected MouseListener BasicTreeUI.createMouseListener​()
      创建负责更新基于鼠标事件的选择的监听器。
      MouseListener BasicComboPopup.getMouseListener​()
      实现ComboPopup.getMouseListener（）。
      MouseListener ComboPopup.getMouseListener​()
      返回一个将被添加到组合框或null的鼠标监听器。

    • Uses of MouseListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement MouseListener
      Modifier and Type Class 描述
      protected class  MetalFileChooserUI.SingleClickListener
      已过时。
      截至JDK版本9.过时的课程。
      protected class  MetalToolBarUI.MetalDockingListener
      DockingListener适用于 MetalToolBarUI 。

    • Uses of MouseListener in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return MouseListener
      Modifier and Type 方法 描述
      protected MouseListener SynthTabbedPaneUI.createMouseListener​()
      创建一个鼠标监听器。

    • Uses of MouseListener in javax.swing.text

      Classes in javax.swing.text that implement MouseListener
      Modifier and Type Class 描述
      class  DefaultCaret
      默认的Caret实现。

    • Uses of MouseListener in javax.swing.text.html

      Classes in javax.swing.text.html that implement MouseListener
      Modifier and Type Class 描述
      protected class  FormView.MouseEventListener
      当类型等于图像的输入点击时，MouseEventListener类可以处理表单提交。
      static class  HTMLEditorKit.LinkController
      在适当的时候，类可以观看相关组件并在其上触发超链接事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.MouseMotionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.MouseMotionListener

  • Packages that use MouseMotionListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。

    • Uses of MouseMotionListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as MouseMotionListener
      Modifier and Type Field 描述
      protected static MouseMotionListener AWTEventMonitor.mouseMotionListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type MouseMotionListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addMouseMotionListener​(MouseMotionListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有鼠标 MOTION事件。
      static void AWTEventMonitor.removeMouseMotionListener​(MouseMotionListener l)
      移除指定的侦听器，使其不再在事件发生时收到 MOTION事件。

    • Uses of MouseMotionListener in java.awt

      Classes in java.awt that implement MouseMotionListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      Methods in java.awt that return MouseMotionListener
      Modifier and Type 方法 描述
      static MouseMotionListener AWTEventMulticaster.add​(MouseMotionListener a, MouseMotionListener b)
      添加mouse-motion-listener-a与mouse-motion-listener-b并返回生成的组播侦听器。
      MouseMotionListener[] Component.getMouseMotionListeners​()
      返回在此组件上注册的所有鼠标移动侦听器的数组。
      MouseMotionListener[] TrayIcon.getMouseMotionListeners​()
      返回在此 TrayIcon上注册的所有鼠标移动侦听器的 TrayIcon 。
      static MouseMotionListener AWTEventMulticaster.remove​(MouseMotionListener l, MouseMotionListener oldl)
      从mouse-motion-listener-l中删除旧的鼠标移动监听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type MouseMotionListener
      Modifier and Type 方法 描述
      static MouseMotionListener AWTEventMulticaster.add​(MouseMotionListener a, MouseMotionListener b)
      添加mouse-motion-listener-a与mouse-motion-listener-b并返回生成的组播侦听器。
      void Component.addMouseMotionListener​(MouseMotionListener l)
      添加指定的鼠标移动侦听器以从该组件接收鼠标移动事件。
      void TrayIcon.addMouseMotionListener​(MouseMotionListener listener)
      添加指定的鼠标监听器以从此 TrayIcon接收鼠标移动事件。
      static MouseMotionListener AWTEventMulticaster.remove​(MouseMotionListener l, MouseMotionListener oldl)
      从mouse-motion-listener-l中删除旧的鼠标移动监听器，并返回生成的组播侦听器。
      void Component.removeMouseMotionListener​(MouseMotionListener l)
      删除指定的鼠标移动侦听器，使其不再从此组件接收鼠标移动事件。
      void TrayIcon.removeMouseMotionListener​(MouseMotionListener listener)
      删除指定的鼠标移动侦听器。

    • Uses of MouseMotionListener in java.awt.dnd

      Classes in java.awt.dnd that implement MouseMotionListener
      Modifier and Type Class 描述
      class  MouseDragGestureRecognizer
      DragGestureRecognizer这个抽象子类定义了一个基于鼠标的手势的 DragGestureRecognizer 。

    • Uses of MouseMotionListener in java.awt.event

      Classes in java.awt.event that implement MouseMotionListener
      Modifier and Type Class 描述
      class  MouseAdapter
      用于接收鼠标事件的抽象适配器类。
      class  MouseMotionAdapter
      用于接收鼠标运动事件的抽象适配器类。

    • Uses of MouseMotionListener in javax.swing

      Classes in javax.swing that implement MouseMotionListener
      Modifier and Type Class 描述
      class  ToolTipManager
      管理系统中的所有 ToolTips 。

    • Uses of MouseMotionListener in javax.swing.event

      Subinterfaces of MouseMotionListener in javax.swing.event
      Modifier and Type 接口 描述
      interface  MouseInputListener
      在 MouseListener和 MouseMotionListener接口中实现所有方法的侦听器。
      Classes in javax.swing.event that implement MouseMotionListener
      Modifier and Type Class 描述
      class  MouseInputAdapter
      MouseInputListener接口的空白实现，为简化创建侦听器的任务提供了方便，仅通过扩展和实现感兴趣的方法。

    • Uses of MouseMotionListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement MouseMotionListener
      Modifier and Type Class 描述
      class  BasicButtonListener
      按钮监听器
      protected class  BasicComboPopup.InvocationMouseHandler
      在组合框（ 而不是其弹出菜单）上注册的侦听器来处理影响弹出菜单状态的鼠标事件。
      protected class  BasicComboPopup.InvocationMouseMotionHandler
      如果拖动列表，该监听器将监视拖动并更新列表中的当前选择。
      protected class  BasicComboPopup.ListMouseHandler
      当列表中释放鼠标时，此侦听器会隐藏弹出窗口。
      protected class  BasicComboPopup.ListMouseMotionHandler
      当您将鼠标移动到列表上时，此侦听器将更改所选项。
      class  BasicDesktopIconUI.MouseInputHandler
      监听鼠标移动并对其进行操作。
      protected class  BasicFileChooserUI.DoubleClickListener
      双击监听器。
      protected class  BasicInternalFrameUI.BorderListener
      倾听边界调整。
      protected class  BasicInternalFrameUI.GlassPaneDispatcher
      玻璃窗格调度器。
      class  BasicListUI.MouseInputHandler
      鼠标输入和JList的焦点处理。
      protected class  BasicMenuItemUI.MouseInputHandler
      鼠标输入处理程序
      protected class  BasicMenuUI.MouseInputHandler
      由菜单项实例化和使用，以处理鼠标事件当前的菜单选择。
      protected class  BasicScrollBarUI.ArrowButtonListener
      光标键侦听器。
      protected class  BasicScrollBarUI.TrackListener
      跟踪鼠标拖动。
      class  BasicSliderUI.TrackListener
      跟踪鼠标移动。
      protected class  BasicSplitPaneDivider.MouseHandler
      MouseHandler负责将鼠标事件（释放，拖动...）转换为适当的DragController方法。
      class  BasicTabbedPaneUI.MouseHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableHeaderUI.MouseInputHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTableUI.MouseInputHandler
      这个类应该被视为一个“受保护”的内部类。
      static class  BasicTextUI.BasicCaret
      接口默认实现 Caret 。
      class  BasicToolBarUI.DockingListener
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTreeUI.MouseHandler
      TreeMouseListener负责根据鼠标事件更新选择。
      class  BasicTreeUI.MouseInputHandler
      MouseInputHandler处理所有鼠标事件，包括鼠标移动事件，直到鼠标释放到它构造的目的地。
      Fields in javax.swing.plaf.basic declared as MouseMotionListener
      Modifier and Type Field 描述
      protected MouseMotionListener BasicComboPopup.listMouseMotionListener
      此保护字段是实现特定的。
      protected MouseMotionListener BasicComboPopup.mouseMotionListener
      此保护字段是实现特定的。
      protected MouseMotionListener BasicComboBoxUI.popupMouseMotionListener
      MouseMotionListener听事件。
      Methods in javax.swing.plaf.basic that return MouseMotionListener
      Modifier and Type 方法 描述
      protected MouseMotionListener BasicComboPopup.createListMouseMotionListener​()
      创建一个鼠标移动侦听器，在弹出的列表中监视鼠标移动事件。
      protected MouseMotionListener BasicComboPopup.createMouseMotionListener​()
      创建将添加到组合框的鼠标移动侦听器。
      MouseMotionListener BasicComboPopup.getMouseMotionListener​()
      实现ComboPopup.getMouseMotionListener（）。
      MouseMotionListener ComboPopup.getMouseMotionListener​()
      返回一个将被添加到组合框或null的鼠标移动侦听器。

    • Uses of MouseMotionListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement MouseMotionListener
      Modifier and Type Class 描述
      protected class  MetalFileChooserUI.SingleClickListener
      已过时。
      截至JDK版本9.过时的课程。
      protected class  MetalToolBarUI.MetalDockingListener
      DockingListener适用于 MetalToolBarUI 。

    • Uses of MouseMotionListener in javax.swing.text

      Classes in javax.swing.text that implement MouseMotionListener
      Modifier and Type Class 描述
      class  DefaultCaret
      默认的Caret实现。

    • Uses of MouseMotionListener in javax.swing.text.html

      Classes in javax.swing.text.html that implement MouseMotionListener
      Modifier and Type Class 描述
      protected class  FormView.MouseEventListener
      当类型等于图像的输入点击时，MouseEventListener类可以处理表单提交。
      static class  HTMLEditorKit.LinkController
      Class to watch the associated component and fire hyperlink events on it when appropriate.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.MouseWheelListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.MouseWheelListener

  • Packages that use MouseWheelListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。

    • Uses of MouseWheelListener in java.awt

      Classes in java.awt that implement MouseWheelListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      Methods in java.awt that return MouseWheelListener
      Modifier and Type 方法 描述
      static MouseWheelListener AWTEventMulticaster.add​(MouseWheelListener a, MouseWheelListener b)
      添加鼠标滚轮监听器a和鼠标滚轮监听器b并返回结果组播侦听器。
      MouseWheelListener[] Component.getMouseWheelListeners​()
      返回在此组件上注册的所有鼠标滚轮侦听器的数组。
      static MouseWheelListener AWTEventMulticaster.remove​(MouseWheelListener l, MouseWheelListener oldl)
      从mouse-wheel-listener-l中删除旧的鼠标滚轮监听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type MouseWheelListener
      Modifier and Type 方法 描述
      static MouseWheelListener AWTEventMulticaster.add​(MouseWheelListener a, MouseWheelListener b)
      添加鼠标滚轮监听器a和鼠标滚轮监听器b并返回结果组播侦听器。
      void Component.addMouseWheelListener​(MouseWheelListener l)
      添加指定的鼠标滚轮侦听器以从该组件接收鼠标滚轮事件。
      static MouseWheelListener AWTEventMulticaster.remove​(MouseWheelListener l, MouseWheelListener oldl)
      从mouse-wheel-listener-l中删除旧的鼠标滚轮监听器，并返回生成的组播侦听器。
      void Component.removeMouseWheelListener​(MouseWheelListener l)
      删除指定的鼠标滚轮侦听器，使其不再从此组件接收鼠标滚轮事件。

    • Uses of MouseWheelListener in java.awt.event

      Classes in java.awt.event that implement MouseWheelListener
      Modifier and Type Class 描述
      class  MouseAdapter
      用于接收鼠标事件的抽象适配器类。

    • Uses of MouseWheelListener in javax.swing

      Classes in javax.swing that implement MouseWheelListener
      Modifier and Type Class 描述
      class  ToolTipManager
      管理系统中的所有 ToolTips 。

    • Uses of MouseWheelListener in javax.swing.event

      Classes in javax.swing.event that implement MouseWheelListener
      Modifier and Type Class 描述
      class  MouseInputAdapter
      MouseInputListener接口的空实现，通过扩展和实现感兴趣的方法，为简化创建侦听器的任务提供了方便。

    • Uses of MouseWheelListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement MouseWheelListener
      Modifier and Type Class 描述
      protected class  BasicComboPopup.InvocationMouseHandler
      在组合框（ 而不是其弹出菜单）上注册的侦听器来处理影响弹出菜单状态的鼠标事件。
      protected class  BasicComboPopup.ListMouseHandler
      当列表中释放鼠标时，此侦听器会隐藏弹出窗口。
      class  BasicDesktopIconUI.MouseInputHandler
      监听鼠标移动并对其进行操作。
      protected class  BasicFileChooserUI.DoubleClickListener
      双击监听器。
      protected class  BasicInternalFrameUI.BorderListener
      倾听边界调整。
      protected class  BasicScrollBarUI.ArrowButtonListener
      光标键侦听器。
      protected class  BasicScrollBarUI.TrackListener
      跟踪鼠标拖动。
      protected class  BasicScrollPaneUI.MouseWheelHandler
      MouseWheelHandler是一个实现MouseWheelListener接口的内部类。
      class  BasicSliderUI.TrackListener
      跟踪鼠标移动。
      protected class  BasicSplitPaneDivider.MouseHandler
      MouseHandler负责将鼠标事件（释放，拖动...）转换为适当的DragController方法。
      class  BasicTabbedPaneUI.MouseHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicTreeUI.MouseHandler
      TreeMouseListener负责根据鼠标事件更新选择。
      Methods in javax.swing.plaf.basic that return MouseWheelListener
      Modifier and Type 方法 描述
      protected MouseWheelListener BasicScrollPaneUI.createMouseWheelListener​()
      创建一个MouseWheelListener的实例，该实例由installUI（）添加到JScrollPane中。

    • Uses of MouseWheelListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement MouseWheelListener
      Modifier and Type Class 描述
      protected class  MetalFileChooserUI.SingleClickListener
      已过时。
      截至JDK版本9.过时的课程。

    • Uses of MouseWheelListener in javax.swing.text.html

      Classes in javax.swing.text.html that implement MouseWheelListener
      Modifier and Type Class 描述
      protected class  FormView.MouseEventListener
      当类型等于图像的输入点击时，MouseEventListener类可以处理表单提交。
      static class  HTMLEditorKit.LinkController
      在适当的时候，类可以观看相关组件并在其上触发超链接事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.TextListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.TextListener

  • Packages that use TextListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of TextListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as TextListener
      Modifier and Type Field 描述
      protected static TextListener AWTEventMonitor.textListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type TextListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addTextListener​(TextListener l)
      添加指定的侦听器以在Java虚拟机发生时在每个组件实例上接收所有 TEXT个事件。
      static void AWTEventMonitor.removeTextListener​(TextListener l)
      删除指定的侦听器，使其不再接收 TEXT事件。

    • Uses of TextListener in java.awt

      Classes in java.awt that implement TextListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      protected class  TextArea.AccessibleAWTTextArea
      该类实现 TextArea类的可访问性支持。
      protected class  TextComponent.AccessibleAWTTextComponent
      该类实现 TextComponent类的可访问性支持。
      protected class  TextField.AccessibleAWTTextField
      该类实现 TextField类的可访问性支持。
      Fields in java.awt declared as TextListener
      Modifier and Type Field 描述
      protected TextListener TextComponent.textListener
      将从此对象接收事件的侦听器列表。
      Methods in java.awt that return TextListener
      Modifier and Type 方法 描述
      static TextListener AWTEventMulticaster.add​(TextListener a, TextListener b)
      将text-listener-a与text-listener-b相加，并返回生成的多播侦听器。
      TextListener[] TextComponent.getTextListeners​()
      返回在此文本组件上注册的所有文本侦听器的数组。
      static TextListener AWTEventMulticaster.remove​(TextListener l, TextListener oldl)
      从text-listener-l中删除旧的文本侦听器，并返回生成的组播侦听器。
      Methods in java.awt with parameters of type TextListener
      Modifier and Type 方法 描述
      static TextListener AWTEventMulticaster.add​(TextListener a, TextListener b)
      将text-listener-a与text-listener-b相加，并返回生成的多播侦听器。
      void TextComponent.addTextListener​(TextListener l)
      添加指定的文本事件侦听器以从此文本组件接收文本事件。
      static TextListener AWTEventMulticaster.remove​(TextListener l, TextListener oldl)
      从text-listener-l中删除旧的文本侦听器，并返回生成的组播侦听器。
      void TextComponent.removeTextListener​(TextListener l)
      删除指定的文本事件侦听器，使其不再从此文本组件接收文本事件。如果 l为 null ，则不抛出任何异常并且不执行任何操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.WindowFocusListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.WindowFocusListener

  • Packages that use WindowFocusListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of WindowFocusListener in java.awt

      Classes in java.awt that implement WindowFocusListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现了高效和线程安全的多播事件调度。
      Methods in java.awt that return WindowFocusListener
      Modifier and Type 方法 描述
      static WindowFocusListener AWTEventMulticaster.add​(WindowFocusListener a, WindowFocusListener b)
      使用window-focus-listener-b添加window-focus-listener-a，并返回生成的多播侦听器。
      WindowFocusListener[] Window.getWindowFocusListeners​()
      返回在此窗口上注册的所有窗口焦点侦听器的数组。
      static WindowFocusListener AWTEventMulticaster.remove​(WindowFocusListener l, WindowFocusListener oldl)
      从window-focus-listener-l中删除旧的window-focus-listener，并返回结果组播监听器。
      Methods in java.awt with parameters of type WindowFocusListener
      Modifier and Type 方法 描述
      static WindowFocusListener AWTEventMulticaster.add​(WindowFocusListener a, WindowFocusListener b)
      使用window-focus-listener-b添加window-focus-listener-a，并返回生成的多播侦听器。
      void Window.addWindowFocusListener​(WindowFocusListener l)
      添加指定的窗口焦点侦听器以从此窗口接收窗口事件。
      static WindowFocusListener AWTEventMulticaster.remove​(WindowFocusListener l, WindowFocusListener oldl)
      从window-focus-listener-l中删除旧的window-focus-listener，并返回结果组播监听器。
      void Window.removeWindowFocusListener​(WindowFocusListener l)
      删除指定的窗口焦点侦听器，使其不再从此窗口接收窗口事件。

    • Uses of WindowFocusListener in java.awt.event

      Classes in java.awt.event that implement WindowFocusListener
      Modifier and Type Class 描述
      class  WindowAdapter
      用于接收窗口事件的抽象适配器类。

    • Uses of WindowFocusListener in javax.swing

      Classes in javax.swing that implement WindowFocusListener
      Modifier and Type Class 描述
      protected class  JMenu.WinListener
      监听一个弹出窗口关闭的监听器类。

    • Uses of WindowFocusListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement WindowFocusListener
      Modifier and Type Class 描述
      protected class  BasicToolBarUI.FrameListener
      该类监听窗口事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.WindowListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.WindowListener

  • Packages that use WindowListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of WindowListener in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util declared as WindowListener
      Modifier and Type Field 描述
      protected static WindowListener AWTEventMonitor.windowListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      Methods in com.sun.java.accessibility.util with parameters of type WindowListener
      Modifier and Type 方法 描述
      static void AWTEventMonitor.addWindowListener​(WindowListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 WINDOW事件。
      static void AWTEventMonitor.removeWindowListener​(WindowListener l)
      删除指定的侦听器，使其不再接收 WINDOW个事件。

    • Uses of WindowListener in java.awt

      Classes in java.awt that implement WindowListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。
      Methods in java.awt that return WindowListener
      Modifier and Type 方法 描述
      static WindowListener AWTEventMulticaster.add​(WindowListener a, WindowListener b)
      添加window-listener-a与window-listener-b并返回结果组播侦听器。
      WindowListener[] Window.getWindowListeners​()
      返回在此窗口上注册的所有窗口侦听器的数组。
      static WindowListener AWTEventMulticaster.remove​(WindowListener l, WindowListener oldl)
      从window-listener-l中删除旧的window-listener，并返回结果组播监听器。
      Methods in java.awt with parameters of type WindowListener
      Modifier and Type 方法 描述
      static WindowListener AWTEventMulticaster.add​(WindowListener a, WindowListener b)
      添加window-listener-a与window-listener-b并返回结果组播侦听器。
      void Window.addWindowListener​(WindowListener l)
      添加指定的窗口侦听器以从此窗口接收窗口事件。
      static WindowListener AWTEventMulticaster.remove​(WindowListener l, WindowListener oldl)
      从window-listener-l中删除旧的window-listener，并返回结果组播监听器。
      void Window.removeWindowListener​(WindowListener l)
      删除指定的窗口监听器，使其不再从此窗口接收窗口事件。

    • Uses of WindowListener in java.awt.event

      Classes in java.awt.event that implement WindowListener
      Modifier and Type Class 描述
      class  WindowAdapter
      用于接收窗口事件的抽象适配器类。

    • Uses of WindowListener in javax.swing

      Classes in javax.swing that implement WindowListener
      Modifier and Type Class 描述
      protected class  JMenu.WinListener
      监听一个弹出窗口关闭的监听器类。

    • Uses of WindowListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement WindowListener
      Modifier and Type Class 描述
      protected class  BasicToolBarUI.FrameListener
      该类监听窗口事件。
      Methods in javax.swing.plaf.basic that return WindowListener
      Modifier and Type 方法 描述
      protected WindowListener BasicToolBarUI.createFrameListener​()
      构造一个新的实例 WindowListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.event.WindowStateListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.event.WindowStateListener

  • Packages that use WindowStateListener
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。

    • Uses of WindowStateListener in java.awt

      Classes in java.awt that implement WindowStateListener
      Modifier and Type Class 描述
      class  AWTEventMulticaster
      AWTEventMulticaster针对 java.awt.event程序包中定义的AWT事件实现了高效和线程安全的多播事件调度。
      Methods in java.awt that return WindowStateListener
      Modifier and Type 方法 描述
      static WindowStateListener AWTEventMulticaster.add​(WindowStateListener a, WindowStateListener b)
      将window-state-listener-a与window-state-listener-b相加，并返回结果组播监听器。
      WindowStateListener[] Window.getWindowStateListeners​()
      返回在此窗口上注册的所有窗口状态侦听器的数组。
      static WindowStateListener AWTEventMulticaster.remove​(WindowStateListener l, WindowStateListener oldl)
      从window-state-listener-l中删除旧的window-state-listener，并返回结果组播监听器。
      Methods in java.awt with parameters of type WindowStateListener
      Modifier and Type 方法 描述
      static WindowStateListener AWTEventMulticaster.add​(WindowStateListener a, WindowStateListener b)
      将window-state-listener-a与window-state-listener-b相加，并返回结果组播监听器。
      void Window.addWindowStateListener​(WindowStateListener l)
      添加指定的窗口状态侦听器以从此窗口接收窗口事件。
      static WindowStateListener AWTEventMulticaster.remove​(WindowStateListener l, WindowStateListener oldl)
      从window-state-listener-l中删除旧的window-state-listener，并返回结果组播监听器。
      void Window.removeWindowStateListener​(WindowStateListener l)
      删除指定的窗口状态监听器，使其不再从此窗口接收窗口事件。

    • Uses of WindowStateListener in java.awt.event

      Classes in java.awt.event that implement WindowStateListener
      Modifier and Type Class 描述
      class  WindowAdapter
      用于接收窗口事件的抽象适配器类。

    • Uses of WindowStateListener in javax.swing

      Classes in javax.swing that implement WindowStateListener
      Modifier and Type Class 描述
      protected class  JMenu.WinListener
      监听一个弹出窗口关闭的监听器类。

    • Uses of WindowStateListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement WindowStateListener
      Modifier and Type Class 描述
      protected class  BasicToolBarUI.FrameListener
      该类监听窗口事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


FontRenderContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class FontRenderContext

  • java.lang.Object
    • java.awt.font.FontRenderContext

  • public class FontRenderContext
extends Object
    FontRenderContext类是用于正确测量文本所需信息的容器。 文本的测量可能因为将轮廓映射到像素的规则以及应用程序提供的提示而有所不同。

    一个这样的信息是将印刷点缩放到像素的变换。 （一个点被定义为正好1/72英寸，与一点的传统机械测量略有不同）。在600dpi设备上以12pt渲染的字符可能与提供的相同字符的大小不同在72dpi设备上的12pt，因为诸如四舍五入到像素边界和字体设计者可能指定的提示等因素。

    应用程序指定的抗锯齿和分数度量也可能会影响字符的大小，因为四舍五入到像素边界。

    通常， FontRenderContext实例是从Graphics2D对象获得的。 直接构造的FontRenderContext很可能不代表任何实际的图形设备，并可能导致意外或不正确的结果。

    另请参见：
    RenderingHints.KEY_TEXT_ANTIALIASING ， RenderingHints.KEY_FRACTIONALMETRICS ， Graphics2D.getFontRenderContext() ， LineMetrics

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FontRenderContext​()
      构造一个新的 FontRenderContext对象。
        FontRenderContext​(AffineTransform tx, boolean isAntiAliased, boolean usesFractionalMetrics)
      从可选的AffineTransform和两个boolean值构造一个FontRenderContext对象，以确定新构造的对象是否具有抗锯齿或小数度量。
        FontRenderContext​(AffineTransform tx, Object aaHint, Object fmHint)
      从可选的AffineTransform和两个Object构造一个FontRenderContext对象，确定新构造的对象是否具有抗锯齿或小数度量。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(FontRenderContext rhs)
      如果rhs具有相同的变换，抗锯齿和小数度量值，则返回true。
      boolean equals​(Object obj)
      如果obj是FontRenderContext的一个实例，并且具有与此相同的转换，抗锯齿和小数度量值，则返回true。
      Object getAntiAliasingHint​()
      返回此 FontRenderContext使用的文本反锯齿渲染模式提示。
      Object getFractionalMetricsHint​()
      返回此 FontRenderContext使用的文本分数度量渲染模式提示。
      AffineTransform getTransform​()
      获取用于将排印点缩放到像素的变换，这个 FontRenderContext 。
      int getTransformType​()
      返回 FontRenderContext的仿射变换的整数类型，由 AffineTransform.getType()
      int hashCode​()
      返回此FontRenderContext的哈希码。
      boolean isAntiAliased​()
      返回一个布尔值，表示某个形式的抗锯齿是否由此 FontRenderContext指定。
      boolean isTransformed​()
      指示此 FontRenderContext对象是否在变换的渲染上下文中测量文本。
      boolean usesFractionalMetrics​()
      返回一个布尔值，这是否在这个 FontRenderContext使用了文本分数度量模式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FontRenderContext

        protected FontRenderContext​()
        构造一个新的 FontRenderContext对象。

      • FontRenderContext

        public FontRenderContext​(AffineTransform tx,
                         boolean isAntiAliased,
                         boolean usesFractionalMetrics)
        从可选的AffineTransform和两个boolean值构造一个FontRenderContext对象，确定新构造的对象是否具有抗锯齿或小数度量。 在每种情况下，布尔值true和false对应于呈现提示值ON和OFF 。

        要指定其他提示值，请使用将渲染提示值指定为参数的构造函数： FontRenderContext(AffineTransform, Object, Object) 。

        参数
        tx - 用于将排印点缩放到像素的变换FontRenderContext 。 如果为空，则使用身份转换。
        isAntiAliased - 确定新构造的对象是否具有抗锯齿。
        usesFractionalMetrics - 确定新构建的对象是否具有小数度量。

      • FontRenderContext

        public FontRenderContext​(AffineTransform tx,
                         Object aaHint,
                         Object fmHint)
        从可选的AffineTransform和两个Object值构造一个FontRenderContext对象，以确定新构造的对象是否具有抗锯齿或小数度量。
        参数
        tx - 用于将排印点缩放到像素的变换FontRenderContext 。 如果为空，则使用身份转换。
        aaHint - - java.awt.RenderingHints中定义的文本抗锯齿渲染提示值之一。 任何其他值将抛出IllegalArgumentException 。 可以指定VALUE_TEXT_ANTIALIAS_DEFAULT ，在这种情况下，所使用的模式取决于实现。
        fmHint - - java.awt.RenderingHints中定义的文本分数渲染提示值之一。 可以指定VALUE_FRACTIONALMETRICS_DEFAULT ，在这种情况下，所使用的模式取决于实现。 任何其他值将抛出IllegalArgumentException
        异常
        IllegalArgumentException - 如果提示不是合法价值之一。
        从以下版本开始：
        1.6

    • 方法详细信息

      • isTransformed

        public boolean isTransformed​()
        指示此 FontRenderContext对象是否测量转换的渲染上下文中的文本。
        结果
        true如果此FontRenderContext对象具有非身份的AffineTransform属性。 否则为false 。
        从以下版本开始：
        1.6
        另请参见：
        getTransform()

      • getTransformType

        public int getTransformType​()
        为这将返回仿射的整数类型的变换 FontRenderContext如通过指定 AffineTransform.getType()
        结果
        转换的类型。
        从以下版本开始：
        1.6
        另请参见：
        AffineTransform

      • getTransform

        public AffineTransform getTransform​()
        获取用于将排印点缩放到像素的变换（ FontRenderContext 。
        结果
        这 AffineTransform的 FontRenderContext 。
        另请参见：
        AffineTransform

      • isAntiAliased

        public boolean isAntiAliased​()
        返回一个布尔值，表示某个形式的抗锯齿是否由此FontRenderContext指定。 请致电getAntiAliasingHint()了解具体的渲染提示值。
        结果
        true ，如果文本是反锯齿在这FontRenderContext ; 否则为false 。
        另请参见：
        RenderingHints.KEY_TEXT_ANTIALIASING ， FontRenderContext(AffineTransform,boolean,boolean) ， FontRenderContext(AffineTransform,Object,Object)

      • usesFractionalMetrics

        public boolean usesFractionalMetrics​()
        返回在此FontRenderContext是否使用文本分数度量模式的布尔值。 调用getFractionalMetricsHint()获取相应的渲染提示值。
        结果
        true ，如果布局应使用小数度量进行; 否则为false 。 在这FontRenderContext 。
        另请参见：
        RenderingHints.KEY_FRACTIONALMETRICS ， FontRenderContext(AffineTransform,boolean,boolean) ， FontRenderContext(AffineTransform,Object,Object)

      • getAntiAliasingHint

        public Object getAntiAliasingHint​()
        返回这个FontRenderContext使用的文本反锯齿渲染模式提示。 这将是java.awt.RenderingHints中定义的文本抗锯齿渲染提示值之一。
        结果
        文本抗锯齿渲染模式提示在这个 FontRenderContext 。
        从以下版本开始：
        1.6

      • getFractionalMetricsHint

        public Object getFractionalMetricsHint​()
        返回此FontRenderContext使用的文本小数度量渲染模式提示。 这将是java.awt.RenderingHints中定义的文本分数度量渲染提示值之一。
        结果
        在这个 FontRenderContext使用的文本分数度量渲染模式提示。
        从以下版本开始：
        1.6

      • equals

        public boolean equals​(Object obj)
        如果obj是FontRenderContext的一个实例，并且具有与此相同的转换，抗锯齿和小数度量值，则返回true。
        重写：
        equals在 Object
        参数
        obj - 要测试相等的对象
        结果
        true如果指定的对象等于这个FontRenderContext ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • equals

        public boolean equals​(FontRenderContext rhs)
        如果rhs具有相同的变换，抗锯齿和小数度量值，则返回true。
        参数
        rhs - FontRenderContext测试平等
        结果
        true如果rhs等于这个FontRenderContext ; 否则为false 。
        从以下版本开始：
        1.4

      • hashCode

        public int hashCode​()
        返回此FontRenderContext的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GlyphJustificationInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class GlyphJustificationInfo

  • java.lang.Object
    • java.awt.font.GlyphJustificationInfo

  • public final class GlyphJustificationInfo
extends Object
    GlyphJustificationInfo类表示有关字形对齐属性的信息。 字形是一个或多个字符的视觉表示。 可以使用许多不同的字形来表示单个字符或字符的组合。 由GlyphJustificationInfo代表的四个对齐属性是权重，优先级，吸收和限制。

    重量是线条中字形的总体“重量”。 通常它与字体的大小成正比。 具有较大重量的雕文分配相应较大量的空间变化。

    优先级决定了使用此字形的对齐阶段。 在下一个优先级的字形之前检查相同优先级的所有字形。 如果空间的所有更改都可以分配给这些字形而不超出它们的限制，则不检查下一个优先级的字形。 有四个优先事项，kashida，空格，interchar和none。 KASHIDA是第一优先考虑的。 NONE是最新研究的优先事项。

    吸收决定字形是否吸收空间的所有变化。 在给定的优先级中，一些字形可能会吸收所有的空间变化。 如果存在这些字形中的任何一个，则不检查稍后优先级的字形。

    限制确定字形可以更改的最大或最小量。 字形的左侧和右侧可以有不同的限制。

    每个GlyphJustificationInfo代表两组度量，它们正在不断增长和缩小 。 当线上的字形要分开以适应较大的宽度时，会使用越来越多的指标。 当字形要一起移动以适应较小的宽度时，将使用缩小度量。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      boolean growAbsorb
      如果 true ，这个字形在增长时吸收这个和较低优先级的所有额外空间。
      float growLeftLimit
      这个字形左侧的最大数量可以增长。
      int growPriority
      这个字形的优先级正在增长。
      float growRightLimit
      这个字形的右侧可以增长的最大数量。
      static int PRIORITY_INTERCHAR
      第二低的理由优先。
      static int PRIORITY_KASHIDA
      最高的理由优先。
      static int PRIORITY_NONE
      最低的理由优先。
      static int PRIORITY_WHITESPACE
      第二高的理由优先。
      boolean shrinkAbsorb
      如果 true ，这个字形吸收所有剩余的收缩率在这个和较低的优先级，因为它收缩。
      float shrinkLeftLimit
      这个字形左侧的最大值可以缩小（正数）。
      int shrinkPriority
      这个字形的优先级正在缩小。
      float shrinkRightLimit
      这个字形右侧的最大数量可以缩小（正数）。
      float weight
      这个字形的重量。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GlyphJustificationInfo​(float weight, boolean growAbsorb, int growPriority, float growLeftLimit, float growRightLimit, boolean shrinkAbsorb, int shrinkPriority, float shrinkLeftLimit, float shrinkRightLimit)
      构造关于字形对齐属性的信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • PRIORITY_KASHIDA

        public static final int PRIORITY_KASHIDA
        最高的理由优先。
        另请参见：
        Constant Field Values

      • PRIORITY_WHITESPACE

        public static final int PRIORITY_WHITESPACE
        第二高的理由优先。
        另请参见：
        Constant Field Values

      • PRIORITY_INTERCHAR

        public static final int PRIORITY_INTERCHAR
        第二低的理由优先。
        另请参见：
        Constant Field Values

      • PRIORITY_NONE

        public static final int PRIORITY_NONE
        最低的理由优先。
        另请参见：
        Constant Field Values

      • weight

        public final float weight
        这个字形的重量。

      • growPriority

        public final int growPriority
        这个字形的优先级正在增长。

      • growAbsorb

        public final boolean growAbsorb
        如果是 true ，这个字形在增长时吸收这个优先级和低优先级的所有额外的空间。

      • growLeftLimit

        public final float growLeftLimit
        这个字形左侧的最大数量可以增长。

      • growRightLimit

        public final float growRightLimit
        这个字形的右侧可以增长的最大数量。

      • shrinkPriority

        public final int shrinkPriority
        这个字形的优先级正在缩小。

      • shrinkAbsorb

        public final boolean shrinkAbsorb
        如果 true ，这个字形在收缩时吸收在这个和较低优先级的所有剩余收缩。

      • shrinkLeftLimit

        public final float shrinkLeftLimit
        这个字形左侧的最大值可以缩小（正数）。

      • shrinkRightLimit

        public final float shrinkRightLimit
        这个字形右侧的最大数量可以缩小（正数）。

    • 构造方法详细信息

      • GlyphJustificationInfo

        public GlyphJustificationInfo​(float weight,
                              boolean growAbsorb,
                              int growPriority,
                              float growLeftLimit,
                              float growRightLimit,
                              boolean shrinkAbsorb,
                              int shrinkPriority,
                              float shrinkLeftLimit,
                              float shrinkRightLimit)
        构造关于字形对齐属性的信息。
        参数
        weight - 分配空间时这个字形的权重。 必须是非负数。
        growAbsorb - 如果 true此字形吸收了此优先级的所有额外空间，并在其增长时吸收较低的优先级
        growPriority - 这个字形在增长时的优先级
        growLeftLimit - 此字形左侧可以增长的最大数量。 必须是非负数。
        growRightLimit - 这个字形右侧可以增长的最大数量。 必须是非负数。
        shrinkAbsorb - 如果是 true ，这个字形在收缩时吸收这个和较低优先级的所有剩余收缩
        shrinkPriority - shrinkPriority时这个字形的优先级
        shrinkLeftLimit - 这个字形左侧可以缩小的最大数量。 必须是非负数。
        shrinkRightLimit - 这个字形右侧可以缩小的最大数量。 必须是非负数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GlyphMetrics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class GlyphMetrics

  • java.lang.Object
    • java.awt.font.GlyphMetrics

  • public final class GlyphMetrics
extends Object
    GlyphMetrics类代表单个字形的信息。 字形是一个或多个字符的视觉表示。 可以使用许多不同的字形来表示单个字符或字符的组合。 GlyphMetrics实例由Font生成，并且适用于特定Font的特定字形。

    标志是标准，LIGATURE，组合或组件。

    • 标准字形通常用于表示单个字符。
    • LIGATURE字形用于表示字符序列。
    • GlyphVector中的 COMPONENT字形与文本模型中的特定字符不对应。 相反，COMPONENT字形被添加为排版原因，如阿拉伯语对齐。
    • 组合字形修饰STANDARD或LIGATURE字形，如重音符号。 拼贴不会在组合字形之前出现。

    通过GlyphMetrics提供的其他指标是前进，视觉界限和左右侧轴承的组件。

    用于旋转字体的字形，或从向字形应用旋转的GlyphVector获得的字形可以具有包含X和Y组件的进步。 通常进步只有一个组件。

    字形的前进是从字形的原点到下一个字形的原点的距离，其基线是垂直的或水平的。 请注意，在GlyphVector ，由于字距或其他定位调整，从字形到其下一个字形的距离可能不是字形的前进。

    边界是完全包含字形轮廓的最小矩形。 边界矩形是相对于字形的起点。 左侧轴承是从字形起点到其边界矩形左侧的距离。 如果左侧轴承为负，则字形的一部分将绘制在其原点的左侧。 右侧轴承是从边界矩形右侧到下一个字形起点（原点加上前进）的距离。 如果为负，则字形的一部分将被绘制在下一个字形起点的右侧。 请注意，由于光栅化和像素调整效果，边界不一定会包含渲染字形时影响的所有像素。

    虽然可以直接构建GlyphMetrics实例，但它们几乎总是从GlyphVector获得。 一旦构造， GlyphMetrics对象是不可变的。

    示例 ：

    查询Font的字形信息

     Font font = ...;
 int glyphIndex = ...;
 GlyphMetrics metrics = GlyphVector.getGlyphMetrics(glyphIndex);
 int isStandard = metrics.isStandard();
 float glyphAdvance = metrics.getAdvance();
    另请参见：
    Font ， GlyphVector

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static byte COMBINING
      表示表示组合字符的字形，例如变音符号。
      static byte COMPONENT
      表示后备存储中没有相应字符的字形。
      static byte LIGATURE
      表示一个字形，表示多个字符为连字，例如“fi”或“ffi”。
      static byte STANDARD
      表示表示单个标准字符的字形。
      static byte WHITESPACE
      表示没有视觉表示的字形。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GlyphMetrics​(boolean horizontal, float advanceX, float advanceY, Rectangle2D bounds, byte glyphType)
      构造一个 GlyphMetrics对象。
      GlyphMetrics​(float advance, Rectangle2D bounds, byte glyphType)
      构造一个 GlyphMetrics对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      float getAdvance​()
      返回字符沿基线的前进（水平或垂直）。
      float getAdvanceX​()
      返回字形前进的x分量。
      float getAdvanceY​()
      返回字形前进的y分量。
      Rectangle2D getBounds2D​()
      返回字形的边界。
      float getLSB​()
      返回字形的左（上）侧方向。
      float getRSB​()
      返回字形的右侧（底部）侧面。
      int getType​()
      返回原始字形类型代码。
      boolean isCombining​()
      如果这是一个组合字形，则返回 true 。
      boolean isComponent​()
      如果这是一个组件字形，则返回 true 。
      boolean isLigature​()
      如果这是一个连字符，返回 true 。
      boolean isStandard​()
      如果这是标准字形，则返回 true 。
      boolean isWhitespace​()
      返回 true如果这是一个空白字形。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • STANDARD

        public static final byte STANDARD
        表示表示单个标准字符的字形。
        另请参见：
        Constant Field Values

      • LIGATURE

        public static final byte LIGATURE
        表示一个字形，表示多个字符为连字，例如“fi”或“ffi”。 后面是填充字形的剩余字符。 填充和组合字形可以混合，以控制在逻辑上的连字上的重音标记的定位。
        另请参见：
        Constant Field Values

      • COMBINING

        public static final byte COMBINING
        表示表示组合字符的字形，例如变音符号。 这个字形与上一个字形之间没有插入位置。
        另请参见：
        Constant Field Values

      • COMPONENT

        public static final byte COMPONENT
        表示后备存储中没有相应字符的字形。 字形与由逻辑上前面的非组件字形表示的字符相关联。 这用于kashida对齐或其他对现有字形的视觉修改。 这个字形与上一个字形之间没有插入位置。
        另请参见：
        Constant Field Values

      • WHITESPACE

        public static final byte WHITESPACE
        表示没有视觉表示的字形。 它可以添加到其他代码值以指示不可见的字形。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GlyphMetrics

        public GlyphMetrics​(float advance,
                    Rectangle2D bounds,
                    byte glyphType)
        构造一个 GlyphMetrics对象。
        参数
        advance - 字形的前进宽度
        bounds - 字形的黑框边界
        glyphType - 字形的类型

      • GlyphMetrics

        public GlyphMetrics​(boolean horizontal,
                    float advanceX,
                    float advanceY,
                    Rectangle2D bounds,
                    byte glyphType)
        构造一个 GlyphMetrics对象。
        参数
        horizontal - 如果为真，度量用于水平基准，否则它们用于垂直基线
        advanceX - 字形提前的X分量
        advanceY - 字形提前的Y分量
        bounds - 字形的视觉界限
        glyphType - 字形的类型
        从以下版本开始：
        1.4

    • 方法详细信息

      • getAdvance

        public float getAdvance​()
        返回字符沿基线的前进（水平或垂直）。
        结果
        字形的进步

      • getAdvanceX

        public float getAdvanceX​()
        返回字形前进的x分量。
        结果
        字形前进的x分量
        从以下版本开始：
        1.4

      • getAdvanceY

        public float getAdvanceY​()
        返回字形前进的y分量。
        结果
        字形前进的y分量
        从以下版本开始：
        1.4

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回字形的边界。 这是字形轮廓的边框。 由于光栅化和像素对齐效果，它不一定包含渲染字形时受影响的像素。
        结果
        一个Rectangle2D是字形的边界。

      • getLSB

        public float getLSB​()
        返回字形的左（上）侧方向。

        这是从0，0到字形边界的左边（顶部）的距离。 如果字形的边界位于（上）原点的左侧，则LSB为负。

        结果
        字形的左侧方位。

      • getRSB

        public float getRSB​()
        返回字形的右侧（底部）侧面。

        这是从右边（底部）的字形边界到前进的距离。 如果字形的边界在（下）的右侧，则RSB为负。

        结果
        右侧的字形轴承。

      • getType

        public int getType​()
        返回原始字形类型代码。
        结果
        原始字形类型代码。

      • isStandard

        public boolean isStandard​()
        如果这是标准字形，则返回 true 。
        结果
        true如果这是标准字形; 否则为false 。

      • isLigature

        public boolean isLigature​()
        如果这是连字字形，则返回 true 。
        结果
        true如果这是一个连字符号; 否则为false 。

      • isCombining

        public boolean isCombining​()
        如果这是一个组合字形，则返回 true 。
        结果
        true如果这是一个组合字形; 否则为false 。

      • isComponent

        public boolean isComponent​()
        如果这是一个组件字形，则返回 true 。
        结果
        true如果这是一个组件字形; 否则为false 。

      • isWhitespace

        public boolean isWhitespace​()
        如果这是一个空白字形，返回 true 。
        结果
        true如果这是一个空白字形; 否则为false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GlyphVector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class GlyphVector

  • java.lang.Object
    • java.awt.font.GlyphVector
  • All Implemented Interfaces:
    Cloneable

    public abstract class GlyphVector
extends Object
implements Cloneable
    GlyphVector对象是包含几何信息的字形的集合，用于在对应于最终显示GlyphVector的设备的变换的坐标空间中放置每个字形。

    GlyphVector不会尝试对其包含的字形序列的任何解释。 序列中相邻字形之间的关系仅用于确定字形在视觉坐标空间中的位置。

    实例GlyphVector由创建Font 。

    在可以缓存文本的中间表示的文本处理应用中，用于渲染期间的GlyphVector创建和后续高速缓存是向用户呈现字符的可视表示的最快方法。

    A GlyphVector与正好一个Font相关联，并且可以提供仅对于该Font有用的数据。 此外，从GlyphVector获得的GlyphVector通常不是几何可缩放的，因为像素化和间隔取决于Font网格拟合算法。 为了方便对GlyphVector及其组件字形的精确测量，您必须在创建GlyphVector时指定缩放变换，反混叠模式和小数度量模式。 这些特性可以从目标设备导出。

    对于GlyphVector每个字形，您可以获取：

    • 字形的位置
    • 与字形相关联的转换
    • 字形在GlyphVector的上下文中的GlyphVector 。 在不同的变换，应用程序指定的渲染提示和GlyphVector中的字形的具体实例中，字形的度量可能不同。

    改变用于创建数据GlyphVector不会改变的状态GlyphVector 。

    提供了方法来调整字形在GlyphVector内的GlyphVector 。 这些方法对于正在执行用于呈现字形的对齐操作的应用程序是最合适的。

    提供了方法来转换GlyphVector内的各个字形。 这些方法主要用于特殊效果。

    提供一些方法以返回两个整个的视觉，逻辑和像素范围GlyphVector的内或各个字形的GlyphVector 。

    提供了方法来为GlyphVector和GlyphVector中的单个字形返回一个GlyphVector 。

    另请参见：
    Font ， GlyphMetrics ， TextLayout

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int FLAG_COMPLEX_GLYPHS
      与getLayoutFlags一起使用的标志，表示该 GlyphVector具有复杂的字形到字符映射（一个不以符合运行方向的严格升序或降序的方式将字形映射到字符一对一）。
      static int FLAG_HAS_POSITION_ADJUSTMENTS
      与getLayoutFlags一起使用的标志，表示此 GlyphVector具有位置调整。
      static int FLAG_HAS_TRANSFORMS
      与getLayoutFlags一起使用的标志，表示此 GlyphVector具有每个字形转换。
      static int FLAG_MASK
      来自getLayoutFlags的支持标志的掩码。
      static int FLAG_RUN_RTL
      与getLayoutFlags一起使用的标志，表示此 GlyphVector具有从右到左的运行方向。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GlyphVector​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract boolean equals​(GlyphVector set)
      测试指定的 GlyphVector完全等于此 GlyphVector 。
      abstract Font getFont​()
      返回 Font与此 GlyphVector相关联。
      abstract FontRenderContext getFontRenderContext​()
      返回FontRenderContext与此相关GlyphVector 。
      int getGlyphCharIndex​(int glyphIndex)
      返回指定字形的字符索引。
      int[] getGlyphCharIndices​(int beginGlyphIndex, int numEntries, int[] codeReturn)
      返回指定字形的字符索引。
      abstract int getGlyphCode​(int glyphIndex)
      返回指定字形的字形代码。
      abstract int[] getGlyphCodes​(int beginGlyphIndex, int numEntries, int[] codeReturn)
      返回指定字形的字形数组。
      abstract GlyphJustificationInfo getGlyphJustificationInfo​(int glyphIndex)
      将指定索引中的字形的对齐信息返回到此 GlyphVector 。
      abstract Shape getGlyphLogicalBounds​(int glyphIndex)
      返回此 GlyphVector指定字形的逻辑边界。
      abstract GlyphMetrics getGlyphMetrics​(int glyphIndex)
      将指定索引中的字形的度量返回到此 GlyphVector 。
      abstract Shape getGlyphOutline​(int glyphIndex)
      返回一个 Shape其内部对应于此 GlyphVector指定字形的视觉表示。
      Shape getGlyphOutline​(int glyphIndex, float x, float y)
      返回一个 Shape其内部对应于该 GlyphVector内的指定字形的视觉表示，偏移到x，y。
      Rectangle getGlyphPixelBounds​(int index, FontRenderContext renderFRC, float x, float y)
      当这个返回index字形的像素边界 GlyphVector在渲染 Graphics给定 FontRenderContext在给定位置。
      abstract Point2D getGlyphPosition​(int glyphIndex)
      返回指定字形相对于此 GlyphVector的原点的 GlyphVector 。
      abstract float[] getGlyphPositions​(int beginGlyphIndex, int numEntries, float[] positionReturn)
      返回指定字形的字形位置数组。
      abstract AffineTransform getGlyphTransform​(int glyphIndex)
      返回此 GlyphVector指定字形的变换。
      abstract Shape getGlyphVisualBounds​(int glyphIndex)
      返回 GlyphVector指定字形的视觉边界。
      int getLayoutFlags​()
      返回描述GlyphVector全局状态的标志。
      abstract Rectangle2D getLogicalBounds​()
      返回此 GlyphVector的逻辑边界。
      abstract int getNumGlyphs​()
      返回此 GlyphVector的字形数。
      abstract Shape getOutline​()
      返回一个 Shape其内部对应于此 GlyphVector的视觉表示。
      abstract Shape getOutline​(float x, float y)
      返回一个 Shape其内部对应于这个 GlyphVector在x，y渲染时的视觉表示。
      Rectangle getPixelBounds​(FontRenderContext renderFRC, float x, float y)
      在给定位置的给定 FontRenderContext的图形中渲染时，返回此 GlyphVector的像素边界。
      abstract Rectangle2D getVisualBounds​()
      返回此 GlyphVector的边界 GlyphVector视觉边界是这个 GlyphVector轮廓的边界框。
      abstract void performDefaultLayout​()
      为此 GlyphVector每个字形分配默认位置。
      abstract void setGlyphPosition​(int glyphIndex, Point2D newPos)
      设置此 GlyphVector指定字形的位置。
      abstract void setGlyphTransform​(int glyphIndex, AffineTransform newTX)
      设置此 GlyphVector指定字形的变换。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FLAG_HAS_TRANSFORMS

        public static final int FLAG_HAS_TRANSFORMS
        与getLayoutFlags一起使用的标志，表示此 GlyphVector具有每个字形转换。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • FLAG_HAS_POSITION_ADJUSTMENTS

        public static final int FLAG_HAS_POSITION_ADJUSTMENTS
        与getLayoutFlags一起使用的标志，表示该GlyphVector具有位置调整。 当这是真的，字形位置与字形的累积默认进度不匹配（例如，如果已经完成了字距调整）。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • FLAG_RUN_RTL

        public static final int FLAG_RUN_RTL
        与getLayoutFlags一起使用的标志，表示此GlyphVector具有从右到左的运行方向。 这是指字形到字符映射，并不意味着字形的视觉位置必然按照这个顺序，尽管通常它们将是。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • FLAG_COMPLEX_GLYPHS

        public static final int FLAG_COMPLEX_GLYPHS
        与getLayoutFlags一起使用的标志，表示该 GlyphVector具有复杂的字形到字符映射（一个不以符合运行方向的严格升序或降序的方式将字形映射到字符一对一）。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • FLAG_MASK

        public static final int FLAG_MASK
        来自getLayoutFlags的支持标志的掩码。 只有面罩覆盖的位才能被测试。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GlyphVector

        public GlyphVector​()

    • 方法详细信息

      • getFont

        public abstract Font getFont​()
        返回 Font与此 GlyphVector相关联。
        结果
        Font用于创建这个 GlyphVector 。
        另请参见：
        Font

      • getFontRenderContext

        public abstract FontRenderContext getFontRenderContext​()
        返回FontRenderContext与此相关GlyphVector 。
        结果
        FontRenderContext用于创建这个 GlyphVector 。
        另请参见：
        FontRenderContext ， Font

      • performDefaultLayout

        public abstract void performDefaultLayout​()
        为此GlyphVector每个字形分配默认位置。 这可能会破坏在此GlyphVector初始布局期间生成的信息。

      • getNumGlyphs

        public abstract int getNumGlyphs​()
        返回此 GlyphVector的字形数。
        结果
        这个字形数在这 GlyphVector 。

      • getGlyphCode

        public abstract int getGlyphCode​(int glyphIndex)
        返回指定字形的字形代码。 除了创建此GlyphVector的Font对象之外，此返回值是无意义的。
        参数
        glyphIndex - 这个 GlyphVector中的索引对应于从中检索字形的字形。
        结果
        字形的字形在指定的 glyphIndex 。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数

      • getGlyphCodes

        public abstract int[] getGlyphCodes​(int beginGlyphIndex,
                                    int numEntries,
                                    int[] codeReturn)
        返回指定字形的字形数组。 Font用于创建此GlyphVector的Font之外，此返回值的内容是无意义的。 当处理字形时，该方法用于方便和性能。 如果没有传入数组，则会创建一个新数组。
        参数
        beginGlyphIndex - 这个 GlyphVector的索引开始检索字形
        numEntries - 要检索的字形数的数量
        codeReturn - 接收字形并返回的数组
        结果
        指定字形的字形数组数组。
        异常
        IllegalArgumentException - 如果 numEntries小于0
        IndexOutOfBoundsException - 如果 beginGlyphIndex小于0
        IndexOutOfBoundsException -如果总和 beginGlyphIndex和 numEntries比字形的这个数越大 GlyphVector

      • getGlyphCharIndex

        public int getGlyphCharIndex​(int glyphIndex)
        返回指定字形的字符索引。 字符索引是由字形表示的第一个逻辑字符的索引。 默认实现假定字符与字符的一对一，从左到右的映射。
        参数
        glyphIndex - 字形的索引
        结果
        由字形表示的第一个字符的索引
        从以下版本开始：
        1.4

      • getGlyphCharIndices

        public int[] getGlyphCharIndices​(int beginGlyphIndex,
                                 int numEntries,
                                 int[] codeReturn)
        返回指定字形的字符索引。 字符索引是由字形表示的第一个逻辑字符的索引。 指数以字形顺序返回。 默认实现为每个字形调用getGlyphCharIndex，因为性能原因，子类可能需要覆盖此实现。 使用此方法方便和性能处理字形。 如果没有传入数组，则会创建一个新数组。
        参数
        beginGlyphIndex - 第一个字形的索引
        numEntries - 字形指数的数量
        codeReturn - 返回字符索引的数组
        结果
        一系列字符索引，每个字形一个。
        从以下版本开始：
        1.4

      • getLogicalBounds

        public abstract Rectangle2D getLogicalBounds​()
        返回此GlyphVector的逻辑边界。 当定位GlyphVector与视觉上相邻的GlyphVector对象相关时使用此方法。
        结果
        一个Rectangle2D ，它是此的逻辑边界GlyphVector 。

      • getVisualBounds

        public abstract Rectangle2D getVisualBounds​()
        返回这个GlyphVector的视觉边界视觉边界是这个GlyphVector的轮廓的边界框。 由于像素的光栅化和对齐，可能这个框不会包含所有受渲染影响的像素GlyphVector 。
        结果
        一个 Rectangle2D这是这个 GlyphVector的边框。

      • getPixelBounds

        public Rectangle getPixelBounds​(FontRenderContext renderFRC,
                                float x,
                                float y)
        在给定位置的给定FontRenderContext的图形中渲染时，返回此GlyphVector的像素边界。 renderFRC不需要与此GlyphVector的FontRenderContext相同，并且可以为null。 如果为空，则使用该FontRenderContext的GlyphVector 。 默认实现返回可视边界，偏移量为x，y，并舍入到下一个整数值（即返回一个包围视觉边界的整数矩形），并忽略FRC。 子类应该覆盖此方法。
        参数
        renderFRC - FontRenderContext的 Graphics 。
        x - 呈现这个 GlyphVector的x坐标。
        y - 渲染这个 GlyphVector的y坐标。
        结果
        一个 Rectangle限制将受影响的像素。
        从以下版本开始：
        1.4

      • getOutline

        public abstract Shape getOutline​()
        返回一个 Shape其内部对应于该 GlyphVector的视觉表示。
        结果
        一个 Shape是这个 GlyphVector的轮廓。

      • getOutline

        public abstract Shape getOutline​(float x,
                                 float y)
        返回一个 Shape其内部对应于在x，y呈现时的 GlyphVector的视觉表示。
        参数
        x - 这个 GlyphVector的X坐标。
        y - 这个 GlyphVector的Y坐标。
        结果
        一个 Shape是这个 GlyphVector的轮廓，当在指定的坐标渲染时。

      • getGlyphOutline

        public abstract Shape getGlyphOutline​(int glyphIndex)
        返回一个Shape其内部对应于该GlyphVector指定字形的视觉表示。 通过此方法返回的轮廓位于每个单个字形的原点周围。
        参数
        glyphIndex - 该指数 GlyphVector
        结果
        一个 Shape是这个 GlyphVector指定的 glyphIndex的字形轮廓。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数

      • getGlyphOutline

        public Shape getGlyphOutline​(int glyphIndex,
                             float x,
                             float y)
        返回一个Shape其内部对应于该GlyphVector内的指定字形的视觉表示，偏移到x，y。 通过此方法返回的轮廓位于每个单个字形的原点周围。
        参数
        glyphIndex - 索引到这个 GlyphVector
        x - 这个 GlyphVector的位置的X坐标
        y - 这个位置的Y坐标 GlyphVector
        结果
        一个 Shape是在指定的坐标处呈现 glyphIndex的 GlyphVector的字形的轮廓。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数
        从以下版本开始：
        1.4

      • getGlyphPosition

        public abstract Point2D getGlyphPosition​(int glyphIndex)
        返回指定字形相对于该GlyphVector的原点的GlyphVector 。 如果glyphIndex于此GlyphVector的字形数，则此方法返回最后一个字形后的位置。 这个位置用于定义整个GlyphVector 。
        参数
        glyphIndex - 该指数 GlyphVector
        结果
        一个Point2D对象，它是在指定的glyphIndex处的字形位置。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于此 GlyphVector的字形数
        另请参见：
        setGlyphPosition(int, java.awt.geom.Point2D)

      • setGlyphPosition

        public abstract void setGlyphPosition​(int glyphIndex,
                                      Point2D newPos)
        设置此GlyphVector指定字形的位置。 如果glyphIndex等于在这个字形数GlyphVector ，此方法设置的最后一个字形后的位置。 这个位置用来定义整个GlyphVector 。
        参数
        glyphIndex - 索引到这个 GlyphVector
        newPos - Point2D在 Point2D定位字形在指定的 glyphIndex
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于此 GlyphVector的字形数
        另请参见：
        getGlyphPosition(int)

      • getGlyphTransform

        public abstract AffineTransform getGlyphTransform​(int glyphIndex)
        返回此GlyphVector指定字形的变换。 该变换是相对于字形位置。 如果没有应用特殊转换，可以返回null 。 空返回表示身份转换。
        参数
        glyphIndex - 索引到这个 GlyphVector
        结果
        一个AffineTransform这是在指定的glyphIndex的字形的变换。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数
        另请参见：
        setGlyphTransform(int, java.awt.geom.AffineTransform)

      • setGlyphTransform

        public abstract void setGlyphTransform​(int glyphIndex,
                                       AffineTransform newTX)
        设置此GlyphVector指定字形的变换。 该变换是相对于字形位置。 甲null参数为newTX表示被应用于指定字形没有特殊的变换。 该方法可用于旋转，反射，翻译和缩放字形。 添加变换可能导致显着的性能变化。
        参数
        glyphIndex - 索引到这个 GlyphVector
        newTX - 字形的新变换在 glyphIndex
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于该字形数 GlyphVector
        另请参见：
        getGlyphTransform(int)

      • getLayoutFlags

        public int getLayoutFlags​()
        返回描述GlyphVector全局状态的标志。 下面没有描述的标志是保留的。 默认实现为位置调整，变换，rtl和复杂标志返回0（意思是假）。 子类应该覆盖此方法，并确保它正确地描述了GlyphVector并对应于相关调用的结果。
        结果
        一个包含描述状态的标志的int
        从以下版本开始：
        1.4
        另请参见：
        FLAG_HAS_POSITION_ADJUSTMENTS ， FLAG_HAS_TRANSFORMS ， FLAG_RUN_RTL ， FLAG_COMPLEX_GLYPHS ， FLAG_MASK

      • getGlyphPositions

        public abstract float[] getGlyphPositions​(int beginGlyphIndex,
                                          int numEntries,
                                          float[] positionReturn)
        返回指定字形的字形位置数组。 当处理字形位置时，该方法用于方便和性能。 如果没有传入数组，则会创建一个新数组。 以位置零开始的偶数编号的数组条目是beginGlyphIndex + position/2为beginGlyphIndex + position/2的字形的X坐标。 以位置1开始的奇数编号的数组条目是beginGlyphIndex + (position-1)/2为beginGlyphIndex + (position-1)/2的字形的Y坐标。 如果beginGlyphIndex等于字形在这个数量GlyphVector ，这种方法获取的位置的最后字形后，该位置用于定义整个的提前GlyphVector 。
        参数
        beginGlyphIndex - 开始检索字形位置的索引
        numEntries - 要检索的字形数
        positionReturn - 接收字形位置然后返回的数组。
        结果
        由 beginGlyphIndex和 numEntries指定的字形位置数组。
        异常
        IllegalArgumentException - 如果 numEntries小于0
        IndexOutOfBoundsException - 如果 beginGlyphIndex小于0
        IndexOutOfBoundsException - 如果 beginGlyphIndex和 numEntries的总和大于此 GlyphVector加上的字形数

      • getGlyphLogicalBounds

        public abstract Shape getGlyphLogicalBounds​(int glyphIndex)
        返回此GlyphVector指定字形的逻辑边界。 这些逻辑边界共有四个边，其中两个边在字形变换下平行于基线，而另外两个边与存在的相邻字形共享。 该方法对于指定字形的命中测试，在符号的前导或后沿定位插入符号以及用于在指定字形周围绘制高亮区域是有用的。
        参数
        glyphIndex - 对应于从其检索其逻辑边界的字形的此 GlyphVector中的索引
        结果
        一个 Shape这是在指定的 glyphIndex的字形的逻辑边界。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数
        另请参见：
        getGlyphVisualBounds(int)

      • getGlyphVisualBounds

        public abstract Shape getGlyphVisualBounds​(int glyphIndex)
        返回GlyphVector指定字形的视觉边界。 此方法返回的边界位于每个单个字形的原点周围。
        参数
        glyphIndex - 对应于从其中检索其视觉边界的字形的此 GlyphVector中的索引
        结果
        一个 Shape这是在指定的 glyphIndex的字形的视觉边界。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数
        另请参见：
        getGlyphLogicalBounds(int)

      • getGlyphPixelBounds

        public Rectangle getGlyphPixelBounds​(int index,
                                     FontRenderContext renderFRC,
                                     float x,
                                     float y)
        当这个返回index字形的像素边界GlyphVector在渲染Graphics给定FontRenderContext在给定位置。 renderFRC不需要与此GlyphVector的FontRenderContext相同，并且可以为null。 如果为null，则使用该FontRenderContext的GlyphVector 。 默认实现返回字形的视觉边界，偏移量为x，y，并舍入到下一个整数值，并忽略FRC。 子类应该覆盖此方法。
        参数
        index - 字形的索引。
        renderFRC - FontRenderContext的 Graphics 。
        x - 要呈现这个 GlyphVector的X位置。
        y - 要渲染这个 GlyphVector的Y位置。
        结果
        一个 Rectangle限制将受影响的像素。
        从以下版本开始：
        1.4

      • getGlyphMetrics

        public abstract GlyphMetrics getGlyphMetrics​(int glyphIndex)
        将指定索引中的字形的度量返回到此 GlyphVector 。
        参数
        glyphIndex - 这个 GlyphVector的索引对应于从中检索其指标的字形
        结果
        一个GlyphMetrics对象，表示字形的在指定的指标glyphIndex到此GlyphVector 。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数

      • getGlyphJustificationInfo

        public abstract GlyphJustificationInfo getGlyphJustificationInfo​(int glyphIndex)
        将指定索引中的字形的对齐信息返回到此 GlyphVector 。
        参数
        glyphIndex - 这个 GlyphVector中的索引对应于从中检索其对齐属性的字形
        结果
        一个GlyphJustificationInfo对象，表示字形的在指定的调整属性glyphIndex到此GlyphVector 。
        异常
        IndexOutOfBoundsException - 如果 glyphIndex小于0或大于或等于此 GlyphVector的字形数

      • equals

        public abstract boolean equals​(GlyphVector set)
        测试指定的 GlyphVector完全等于此 GlyphVector 。
        参数
        set - 指定的 GlyphVector进行测试
        结果
        true如果指定的GlyphVector等于这个GlyphVector ; 否则为false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GraphicAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class GraphicAttribute

  • java.lang.Object
    • java.awt.font.GraphicAttribute
  • 已知直接子类：
    ImageGraphicAttribute ， ShapeGraphicAttribute

    public abstract class GraphicAttribute
extends Object
    该类与CHAR_REPLACEMENT属性一起使用。

    GraphicAttribute类代表嵌入文本的图形。 客户端子类实现自己的char替换图形。 希望在文本中嵌入形状和图像的客户不需要对这个类进行子类化。 相反，客户端可以使用ShapeGraphicAttribute和ImageGraphicAttribute类。

    子类必须确保它们的对象在构造后是不可变的。 在GraphicAttribute中使用的突变GraphicAttribute会导致来自TextLayout未定义行为。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BOTTOM_ALIGNMENT
      将图形底部对齐到底部。
      static int CENTER_BASELINE
      将图形的起点与线的中心基线对齐。
      static int HANGING_BASELINE
      将图形的起点与线的垂直基线对齐。
      static int ROMAN_BASELINE
      将图形的起点与罗马线的基线对齐。
      static int TOP_ALIGNMENT
      将图形顶部与顶部对齐。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected GraphicAttribute​(int alignment)
      构造一个 GraphicAttribute 。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void draw​(Graphics2D graphics, float x, float y)
      在指定的位置渲染此 GraphicAttribute 。
      abstract float getAdvance​()
      返回这个 GraphicAttribute 。
      int getAlignment​()
      返回这个 GraphicAttribute的对齐方式。
      abstract float getAscent​()
      返回此 GraphicAttribute的上升。
      Rectangle2D getBounds​()
      返回一个Rectangle2D ，它包含相对于渲染位置由此GraphicAttribute绘制的所有位。
      abstract float getDescent​()
      返回此 GraphicAttribute的下降。
      GlyphJustificationInfo getJustificationInfo​()
      返回此 GraphicAttribute的对齐信息。
      Shape getOutline​(AffineTransform tx)
      返回一个Shape ，表示该区域GraphicAttribute呈现。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TOP_ALIGNMENT

        public static final int TOP_ALIGNMENT
        将图形顶部与顶部对齐。
        另请参见：
        Constant Field Values

      • BOTTOM_ALIGNMENT

        public static final int BOTTOM_ALIGNMENT
        将图形底部对齐到底部。
        另请参见：
        Constant Field Values

      • ROMAN_BASELINE

        public static final int ROMAN_BASELINE
        将图形的起点与罗马线的基线对齐。
        另请参见：
        Constant Field Values

      • CENTER_BASELINE

        public static final int CENTER_BASELINE
        将图形的起点与线的中心基线对齐。
        另请参见：
        Constant Field Values

      • HANGING_BASELINE

        public static final int HANGING_BASELINE
        将图形的起点与线的垂直基线对齐。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GraphicAttribute

        protected GraphicAttribute​(int alignment)
        构造一个GraphicAttribute 。 子类使用它来定义图形的对齐方式。
        参数
        alignment - 表示 GraphicAttribute对齐字段之一的int
        异常
        IllegalArgumentException - 如果对齐不是五个定义值之一。

    • 方法详细信息

      • getAscent

        public abstract float getAscent​()
        返回此GraphicAttribute的上升。 图形可以在其上方呈现。
        结果
        这个 GraphicAttribute的上升。
        另请参见：
        getBounds()

      • getDescent

        public abstract float getDescent​()
        返回此GraphicAttribute的下降。 图形可以在其下降之下呈现。
        结果
        这个 GraphicAttribute的下降。
        另请参见：
        getBounds()

      • getAdvance

        public abstract float getAdvance​()
        返回此GraphicAttribute 。 GraphicAttribute对象的进步是从图形渲染点开始的距离以及渲染下一个字符或图形的点。 一个图形可以超越它的进步
        结果
        这个进步 GraphicAttribute 。
        另请参见：
        getBounds()

      • getBounds

        public Rectangle2D getBounds​()
        返回一个Rectangle2D ，它包含了相对于渲染位置的GraphicAttribute绘制的所有位。 图形可能会超出其起源，上升，下降或提前; 但是如果是，则该方法的实现必须指示图形的呈现位置。 默认边界是矩形（0，-ascent，advance，ascent + descent）。
        结果
        一个 Rectangle2D ，它包含了这个 GraphicAttribute呈现的所有位。

      • getOutline

        public Shape getOutline​(AffineTransform tx)
        返回一个Shape ，表示该区域GraphicAttribute呈现。 当请求TextLayout返回文本的大纲时使用。 （未变形）的形状不得超出由getBounds返回的矩形界限getBounds 。 默认实现返回getBounds()返回的矩形，由提供的AffineTransform（如果存在）转换。
        参数
        tx - 可选的AffineTransform以应用于此GraphicAttribute的大纲。 这可以是null。
        结果
        一个 Shape代表这种图形属性，适合于抚摸或填充。
        从以下版本开始：
        1.6

      • draw

        public abstract void draw​(Graphics2D graphics,
                          float x,
                          float y)
        在指定的位置渲染此 GraphicAttribute 。
        参数
        graphics - 用于呈现图形的Graphics2D
        x - 呈现图形的用户空间X坐标
        y - 图形呈现的用户空间Y坐标

      • getAlignment

        public final int getAlignment​()
        返回GraphicAttribute的对齐方式。 对齐可以是一个特定的基线，也可以是一行的绝对顶部或底部。
        结果
        对齐这个 GraphicAttribute 。

      • getJustificationInfo

        public GlyphJustificationInfo getJustificationInfo​()
        返回此GraphicAttribute的对齐信息。 子类可以覆盖此方法以提供不同的对齐信息。
        结果
        一个GlyphJustificationInfo对象，其中包含此GraphicAttribute的对齐信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImageGraphicAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class ImageGraphicAttribute

  • java.lang.Object
    • java.awt.font.GraphicAttribute
      • java.awt.font.ImageGraphicAttribute

  • public final class ImageGraphicAttribute
extends GraphicAttribute
    该ImageGraphicAttribute类的实现GraphicAttribute其中提请在图像TextLayout 。
    另请参见：
    GraphicAttribute

    • Field Summary

      • Fields inherited from class java.awt.font.GraphicAttribute

        BOTTOM_ALIGNMENT, CENTER_BASELINE, HANGING_BASELINE, ROMAN_BASELINE, TOP_ALIGNMENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageGraphicAttribute​(Image image, int alignment)
      构造一个ImageGraphicAttribute从指定Image 。
      ImageGraphicAttribute​(Image image, int alignment, float originX, float originY)
      构造一个 ImageGraphicAttribute从指定 Image 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void draw​(Graphics2D graphics, float x, float y)
      在指定的位置渲染此 GraphicAttribute 。
      boolean equals​(ImageGraphicAttribute rhs)
      将此 ImageGraphicAttribute与指定的 ImageGraphicAttribute 。
      boolean equals​(Object rhs)
      将此ImageGraphicAttribute比较为Object 。
      float getAdvance​()
      返回此 ImageGraphicAttribute 。
      float getAscent​()
      返回此 ImageGraphicAttribute的上升。
      Rectangle2D getBounds​()
      返回一个Rectangle2D ，它包含相对于渲染位置的由此ImageGraphicAttribute呈现的所有位。
      float getDescent​()
      返回此 ImageGraphicAttribute的下降。
      int hashCode​()
      返回此 ImageGraphicAttribute的哈希 ImageGraphicAttribute 。

      • Methods inherited from class java.awt.font.GraphicAttribute

        getAlignment, getJustificationInfo, getOutline

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ImageGraphicAttribute

        public ImageGraphicAttribute​(Image image,
                             int alignment)
        构造一个ImageGraphicAttribute从指定Image 。 原点是（0，0）。
        参数
        image - 由Image呈现的ImageGraphicAttribute 。 此对象保留对image的引用。
        alignment - 这个 ImageGraphicAttribute的对齐方式 ImageGraphicAttribute

      • ImageGraphicAttribute

        public ImageGraphicAttribute​(Image image,
                             int alignment,
                             float originX,
                             float originY)
        构造一个ImageGraphicAttribute从指定Image 。 点（ originX ， originY的） Image出现在原点ImageGraphicAttribute文本中。
        参数
        image - 由Image呈现的ImageGraphicAttribute 。 此对象保留对image的引用。
        alignment - 这个 ImageGraphicAttribute的对齐方式 ImageGraphicAttribute
        originX - Image中出现在文本行 ImageGraphicAttribute原点的点的X坐标。
        originY -将内的点的Y坐标 Image出现在原点 ImageGraphicAttribute的文本行。

    • 方法详细信息

      • getAscent

        public float getAscent​()
        返回此ImageGraphicAttribute的上升。 ImageGraphicAttribute的上升是从图像顶部到原点的距离。
        Specified by:
        getAscent在 GraphicAttribute
        结果
        这个 ImageGraphicAttribute的上升。
        另请参见：
        GraphicAttribute.getBounds()

      • getDescent

        public float getDescent​()
        返回此ImageGraphicAttribute的下降。 ImageGraphicAttribute的下降是从原点到图像底部的距离。
        Specified by:
        getDescent在 GraphicAttribute
        结果
        这个 ImageGraphicAttribute的下降。
        另请参见：
        GraphicAttribute.getBounds()

      • getAdvance

        public float getAdvance​()
        返回这个ImageGraphicAttribute 。 ImageGraphicAttribute是从原始图像到右边缘的距离。
        Specified by:
        getAdvance中的 GraphicAttribute
        结果
        这个进步 ImageGraphicAttribute 。
        另请参见：
        GraphicAttribute.getBounds()

      • getBounds

        public Rectangle2D getBounds​()
        返回一个Rectangle2D ，它包含相对于渲染位置的由此ImageGraphicAttribute呈现的所有位。 图形可以超出它的起源，上升，下降或提前; 但是如果是，则该方法的实现必须指示图形的呈现位置。
        重写：
        getBounds在 GraphicAttribute
        结果
        一个 Rectangle2D ，其中包含了由此 ImageGraphicAttribute呈现的所有位。

      • draw

        public void draw​(Graphics2D graphics,
                 float x,
                 float y)
        在指定的位置渲染此 GraphicAttribute 。
        Specified by:
        draw中的 GraphicAttribute
        参数
        graphics - 用于呈现图形的Graphics2D
        x - 呈现图形的用户空间X坐标
        y - 呈现图形的用户空间Y坐标

      • hashCode

        public int hashCode​()
        返回此 ImageGraphicAttribute的哈希 ImageGraphicAttribute 。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object rhs)
        比较该ImageGraphicAttribute到指定Object 。
        重写：
        equals在 Object
        参数
        rhs - 相对于 Object进行比较
        结果
        true如果这个ImageGraphicAttribute等于rhs ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • equals

        public boolean equals​(ImageGraphicAttribute rhs)
        比较该 ImageGraphicAttribute到指定 ImageGraphicAttribute 。
        参数
        rhs - 相对于 ImageGraphicAttribute进行比较
        结果
        true如果这个ImageGraphicAttribute等于rhs ; 否则为false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.font (Java SE 9 & JDK 9 )

java.awt.font

Interfaces

  • MultipleMaster
  • OpenType

Classes

  • FontRenderContext
  • GlyphJustificationInfo
  • GlyphMetrics
  • GlyphVector
  • GraphicAttribute
  • ImageGraphicAttribute
  • LayoutPath
  • LineBreakMeasurer
  • LineMetrics
  • NumericShaper
  • ShapeGraphicAttribute
  • TextAttribute
  • TextHitInfo
  • TextLayout
  • TextLayout.CaretPolicy
  • TextMeasurer
  • TransformAttribute

Enums

  • NumericShaper.Range


java.awt.font (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.font

提供与字体相关的类和界面。 它支持表示类型1，类型1多主字体，OpenType字体和TrueType字体。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    MultipleMaster
    MultipleMaster接口表示Type 1 Multiple Master字体。
    OpenType
    OpenType接口代表OpenType和TrueType字体。
  • 类摘要
    Class 描述
    FontRenderContext
    FontRenderContext类是用于正确测量文本所需信息的容器。
    GlyphJustificationInfo
    GlyphJustificationInfo类表示有关字形对齐属性的信息。
    GlyphMetrics
    GlyphMetrics类代表单个字形的信息。
    GlyphVector
    GlyphVector对象是包含几何信息的字形的集合，用于在对应于最终显示 GlyphVector的设备的变换的坐标空间中放置每个字形。
    GraphicAttribute
    该类与CHAR_REPLACEMENT属性一起使用。
    ImageGraphicAttribute
    该ImageGraphicAttribute类的实现GraphicAttribute其中提请在图像TextLayout 。
    LayoutPath
    LayoutPath提供了相对于基准的位置和用户空间中的点之间的映射。
    LineBreakMeasurer
    LineBreakMeasurer类允许将样式文本分解成符合特定视觉进步的线（或段）。
    LineMetrics
    LineMetrics类允许访问沿线排列字符和布局一组行所需的度量。
    NumericShaper
    NumericShaper类用于将Latin-1（欧洲）数字转换为其他Unicode十进制数字。
    ShapeGraphicAttribute
    该ShapeGraphicAttribute类的实现GraphicAttribute绘制形状在TextLayout 。
    TextAttribute
    TextAttribute类定义用于文本呈现的属性键和属性值。
    TextHitInfo
    TextHitInfo类表示文本模型中的字符位置，以及字符的 偏差或“侧”。
    TextLayout
    TextLayout是风格字符数据的不可变图形表示。
    TextLayout.CaretPolicy
    定义确定强插插位置的策略。
    TextMeasurer
    TextMeasurer类提供换行所需的原始操作：测量一个给定的提前，确定一个字符范围的提前，并为一系列字符生成一个 TextLayout 。
    TransformAttribute
    TransformAttribute类为变换提供了一个不可变的包装器，以便作为属性使用是安全的。
  • 枚举摘要
    Enum 描述
    NumericShaper.Range
    A NumericShaper.Range表示具有其自己的十进制数字的脚本的Unicode范围。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.font Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.font

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute (implements java.io.Serializable)
      • java.awt.font.TextAttribute
    • java.awt.font.FontRenderContext
    • java.awt.font.GlyphJustificationInfo
    • java.awt.font.GlyphMetrics
    • java.awt.font.GlyphVector (implements java.lang.Cloneable)
    • java.awt.font.GraphicAttribute
      • java.awt.font.ImageGraphicAttribute
      • java.awt.font.ShapeGraphicAttribute
    • java.awt.font.LayoutPath
    • java.awt.font.LineBreakMeasurer
    • java.awt.font.LineMetrics
    • java.awt.font.NumericShaper (implements java.io.Serializable)
    • java.awt.font.TextHitInfo
    • java.awt.font.TextLayout (implements java.lang.Cloneable)
    • java.awt.font.TextLayout.CaretPolicy
    • java.awt.font.TextMeasurer (implements java.lang.Cloneable)
    • java.awt.font.TransformAttribute (implements java.io.Serializable)

Interface Hierarchy

  • java.awt.font.MultipleMaster
  • java.awt.font.OpenType

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.font.NumericShaper.Range
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


LayoutPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class LayoutPath

  • java.lang.Object
    • java.awt.font.LayoutPath

  • public abstract class LayoutPath
extends Object
    LayoutPath提供了相对于基准的位置和用户空间中的点之间的映射。 位置包括沿着基线的进展，以及在提前处垂直于基线的偏移。 垂直方向的正值与基线矢量顺时针方向为90度。 位置表示为Point2D ，其中x是advance，y是偏移量。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      LayoutPath​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void pathToPoint​(Point2D location, boolean preceding, Point2D point)
      将相对于路径的位置转换为用户坐标中的某个点。
      abstract boolean pointToPath​(Point2D point, Point2D location)
      将用户空间中的点转换为相对于路径的位置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LayoutPath

        public LayoutPath​()

    • 方法详细信息

      • pointToPath

        public abstract boolean pointToPath​(Point2D point,
                                    Point2D location)
        将用户空间中的点转换为相对于路径的位置。 选择位置以使从点到路径的距离最小化（例如，偏移的幅度将最小）。 如果有多个这样的位置，则选择具有最小提前的位置。
        参数
        point - 转换点。 如果它不是与位置相同的对象，则该调用将保持未修改。
        location - 一个Point2D保存返回的位置。 它可以是与点相同的对象。
        结果
        如果该点与位置之前的路径部分相关联，则为true，如果它与以下部分相关联，则为false。 默认情况下，如果位置不在路径中断或急弯，则返回true。
        异常
        NullPointerException - 如果点或位置为空
        从以下版本开始：
        1.6

      • pathToPoint

        public abstract void pathToPoint​(Point2D location,
                                 boolean preceding,
                                 Point2D point)
        将相对于路径的位置转换为用户坐标中的某个点。 路径可能突然弯曲，或者在该位置的前进处于不相干的状态。 如果是这种情况，“前”的值用于消除将位置和斜率用于解释偏移的路径部分。
        参数
        location - 表示相对于路径的位置的前进（以x为单位）和偏移（以y为单位）的Point2D 。 如果位置与点不同，则该调用将保持未修改的位置。
        preceding - 如果为真，则应使用提前前的部分，如果假，则应使用之后的部分。 如果路径没有突破或急速弯曲，则这无效果。
        point - a Point2D保留返回点。 它可以是与位置相同的对象。
        异常
        NullPointerException - 如果位置或点为空
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LineBreakMeasurer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class LineBreakMeasurer

  • java.lang.Object
    • java.awt.font.LineBreakMeasurer

  • public final class LineBreakMeasurer
extends Object
    LineBreakMeasurer类允许将样式文本分解成符合特定视觉进步的线（或段）。 这对于希望显示适合特定宽度的文本段（称为包装宽度）的客户端是有用的。

    LineBreakMeasurer用样式文本的迭代器构造。 迭代器的范围应该是文本中的一个段落。 LineBreakMeasurer在文本中保留开始下一个文本段的位置。 最初，这个位置是文本的开始。 根据双向格式规则，段落被分配一个整体方向（从左到右或从右到左）。 从段落获得的所有分段具有与段落相同的方向。

    通过调用方法nextLayout获得文本段，该方法返回表示适合包装宽度的文本的TextLayout 。 nextLayout方法将当前位置移动到从nextLayout返回的布局的nextLayout 。

    LineBreakMeasurer实现了最常用的划线策略：适合包装宽度的每个单词都放在行上。 如果第一个字不适合，那么适合包装宽度的所有字符都放在行上。 每条线上至少放置一个字符。

    TextLayout返回的TextLayout实例LineBreakMeasurer标签视为0宽度的空格。 希望获取制表符分隔段以进行定位的客户端应使用nextLayout的超负荷，该超负荷在nextLayout中进行了限制。 限制偏移应该是标签后的第一个字符。 从此方法返回的TextLayout对象以提供的限制结束（或之前，如果当前位置和限制之间的文本将完全不适合包装宽度）。

    布局制表符分隔文本的客户在第一个细分受众群放在一行之后，需要略有不同的破产政策。 不要在剩余空间中拟合部分单词，而应将下一行中不完整的单词放在剩余空间中。 可以在nextLayout的过载中请求此策略的更改，该参数需要boolean参数。 如果此参数为true ，如果第一个字不适合给定的空间，则nextLayout返回null 。 请参阅下面的选项卡示例。

    一般来说，如果用于构建LineBreakMeasurer的文本发生更改， LineBreakMeasurer必须构建新的LineBreakMeasurer以反映更改。 （旧的LineBreakMeasurer继续正常工作，但不会意识到文本的更改。）然而，如果文本更改是插入或删除单个字符，现有的LineBreakMeasurer可以通过调用insertChar或更新deleteChar 。 更新现有的LineBreakMeasurer比创建新的更快。 基于用户输入修改文本的客户端应该利用这些方法。

    示例 ：

    在组件中渲染段落

 public void paint(Graphics graphics) {

     float dx = 0f, dy = 5f;
     Graphics2D g2d = (Graphics2D)graphics;
     FontRenderContext frc = g2d.getFontRenderContext();

     AttributedString text = new AttributedString(".....");
     AttributedCharacterIterator paragraph = text.getIterator();

     LineBreakMeasurer measurer = new LineBreakMeasurer(paragraph, frc);
     measurer.setPosition(paragraph.getBeginIndex());
     float wrappingWidth = (float)getSize().width;

     while (measurer.getPosition() < paragraph.getEndIndex()) {

         TextLayout layout = measurer.nextLayout(wrappingWidth);

         dy += (layout.getAscent());
         float dx = layout.isLeftToRight() ?
             0 : (wrappingWidth - layout.getAdvance());

         layout.draw(graphics, dx, dy);
         dy += layout.getDescent() + layout.getLeading();
     }
 }

    用标签渲染文本。 为简单起见，假定整个文本方向是从左到右

 public void paint(Graphics graphics) {

     float leftMargin = 10, rightMargin = 310;
     float[] tabStops = { 100, 250 };

     // assume styledText is an AttributedCharacterIterator, and the number
     // of tabs in styledText is tabCount

     int[] tabLocations = new int[tabCount+1];

     int i = 0;
     for (char c = styledText.first(); c != styledText.DONE; c = styledText.next()) {
         if (c == '\t') {
             tabLocations[i++] = styledText.getIndex();
         }
     }
     tabLocations[tabCount] = styledText.getEndIndex() - 1;

     // Now tabLocations has an entry for every tab's offset in
     // the text.  For convenience, the last entry is tabLocations
     // is the offset of the last character in the text.

     LineBreakMeasurer measurer = new LineBreakMeasurer(styledText);
     int currentTab = 0;
     float verticalPos = 20;

     while (measurer.getPosition() < styledText.getEndIndex()) {

         // Lay out and draw each line.  All segments on a line
         // must be computed before any drawing can occur, since
         // we must know the largest ascent on the line.
         // TextLayouts are computed and stored in a Vector;
         // their horizontal positions are stored in a parallel
         // Vector.

         // lineContainsText is true after first segment is drawn
         boolean lineContainsText = false;
         boolean lineComplete = false;
         float maxAscent = 0, maxDescent = 0;
         float horizontalPos = leftMargin;
         Vector layouts = new Vector(1);
         Vector penPositions = new Vector(1);

         while (!lineComplete) {
             float wrappingWidth = rightMargin - horizontalPos;
             TextLayout layout =
                     measurer.nextLayout(wrappingWidth,
                                         tabLocations[currentTab]+1,
                                         lineContainsText);

             // layout can be null if lineContainsText is true
             if (layout != null) {
                 layouts.addElement(layout);
                 penPositions.addElement(new Float(horizontalPos));
                 horizontalPos += layout.getAdvance();
                 maxAscent = Math.max(maxAscent, layout.getAscent());
                 maxDescent = Math.max(maxDescent,
                     layout.getDescent() + layout.getLeading());
             } else {
                 lineComplete = true;
             }

             lineContainsText = true;

             if (measurer.getPosition() == tabLocations[currentTab]+1) {
                 currentTab++;
             }

             if (measurer.getPosition() == styledText.getEndIndex())
                 lineComplete = true;
             else if (horizontalPos >= tabStops[tabStops.length-1])
                 lineComplete = true;

             if (!lineComplete) {
                 // move to next tab stop
                 int j;
                 for (j=0; horizontalPos >= tabStops[j]; j++) {}
                 horizontalPos = tabStops[j];
             }
         }

         verticalPos += maxAscent;

         Enumeration layoutEnum = layouts.elements();
         Enumeration positionEnum = penPositions.elements();

         // now iterate through layouts and draw them
         while (layoutEnum.hasMoreElements()) {
             TextLayout nextLayout = (TextLayout) layoutEnum.nextElement();
             Float nextPosition = (Float) positionEnum.nextElement();
             nextLayout.draw(graphics, nextPosition.floatValue(), verticalPos);
         }

         verticalPos += maxDescent;
     }
 }
    另请参见：
    TextLayout

    • 构造方法摘要

      构造方法
      Constructor 描述
      LineBreakMeasurer​(AttributedCharacterIterator text, FontRenderContext frc)
      为指定的文本构造一个 LineBreakMeasurer 。
      LineBreakMeasurer​(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
      为指定的文本构造一个 LineBreakMeasurer 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void deleteChar​(AttributedCharacterIterator newParagraph, int deletePos)
      从文本中删除单个字符后，更新此 LineBreakMeasurer ，并将当前位置设置为段落的开头。
      int getPosition​()
      返回此 LineBreakMeasurer的当前位置。
      void insertChar​(AttributedCharacterIterator newParagraph, int insertPos)
      在将单个字符插入到文本中后，更新此 LineBreakMeasurer ，并将当前位置设置为段落的开头。
      TextLayout nextLayout​(float wrappingWidth)
      返回下一个布局，并更新当前位置。
      TextLayout nextLayout​(float wrappingWidth, int offsetLimit, boolean requireNextWord)
      返回下一个布局，并更新当前位置。
      int nextOffset​(float wrappingWidth)
      返回下一个布局末尾的位置。
      int nextOffset​(float wrappingWidth, int offsetLimit, boolean requireNextWord)
      返回下一个布局末尾的位置。
      void setPosition​(int newPosition)
      设置此 LineBreakMeasurer的当前位置。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LineBreakMeasurer

        public LineBreakMeasurer​(AttributedCharacterIterator text,
                         FontRenderContext frc)
        为指定的文本构造一个 LineBreakMeasurer 。
        参数
        text - 这个LineBreakMeasurer生成TextLayout对象的文本; 该文本必须至少包含一个字符; 如果可以通过文本iter变化，这进一步要求LineBreakMeasurer实例是不确定的（除非在某些情况下，当insertChar或者deleteChar被调用后-见下文）
        frc - 包含有关正确测量文本所需的图形设备的信息; 文本测量可能会因设备分辨率和抗锯齿等属性而略有不同。 此参数不指定LineBreakMeasurer与用户空间之间的LineBreakMeasurer
        另请参见：
        insertChar(java.text.AttributedCharacterIterator, int) ， deleteChar(java.text.AttributedCharacterIterator, int)

      • LineBreakMeasurer

        public LineBreakMeasurer​(AttributedCharacterIterator text,
                         BreakIterator breakIter,
                         FontRenderContext frc)
        为指定的文本构造一个 LineBreakMeasurer 。
        参数
        text - 这个LineBreakMeasurer生成TextLayout对象的文字 该文本必须至少包含一个字符; 如果可以通过文本iter变化，这进一步要求LineBreakMeasurer实例是不确定的（除非在某些情况下，当insertChar或者deleteChar被调用后-见下文）
        breakIter - 定义换行符的BreakIterator
        frc - 包含有关正确测量文本所需的图形设备的信息; 文本测量可能会因设备分辨率和抗锯齿等属性而略有不同。 此参数不指定LineBreakMeasurer和用户空间之间的LineBreakMeasurer
        异常
        IllegalArgumentException - 如果文本具有少于一个字符
        另请参见：
        insertChar(java.text.AttributedCharacterIterator, int) ， deleteChar(java.text.AttributedCharacterIterator, int)

    • 方法详细信息

      • nextOffset

        public int nextOffset​(float wrappingWidth)
        返回下一个布局末尾的位置。 不更新此LineBreakMeasurer的当前位置。
        参数
        wrappingWidth - 下一个布局文本允许的最大可见提前
        结果
        文字中的偏移量代表下一个 TextLayout的限制。

      • nextOffset

        public int nextOffset​(float wrappingWidth,
                      int offsetLimit,
                      boolean requireNextWord)
        返回下一个布局末尾的位置。 不更新此LineBreakMeasurer的当前位置。
        参数
        wrappingWidth - 下一个布局文本允许的最大可见提前
        offsetLimit - 下一个布局中无法包含的第一个字符，即使限制后的文本也适合包装宽度; offsetLimit必须大于当前位置
        requireNextWord - 如果是true ，如果整个下一个字不符合wrappingWidth ，返回的当前位置; 如果为false ，返回的偏移量至少比当前位置大一个
        结果
        文字中的偏移量代表下一个 TextLayout的限制

      • nextLayout

        public TextLayout nextLayout​(float wrappingWidth)
        返回下一个布局，并更新当前位置。
        参数
        wrappingWidth - 下一个布局文本允许的最大可见提前
        结果
        一个 TextLayout ，从当前位置开始，代表下一行拟合 wrappingWidth

      • nextLayout

        public TextLayout nextLayout​(float wrappingWidth,
                             int offsetLimit,
                             boolean requireNextWord)
        返回下一个布局，并更新当前位置。
        参数
        wrappingWidth - 下一个布局文本允许的最大可见提前
        offsetLimit - 下一个布局中不能包含的第一个字符，即使限制后的文本也适合包装宽度; offsetLimit必须大于当前位置
        requireNextWord - 如果是true ，如果当前位置的整个字不适合包装宽度，则返回null 。 如果是false ，则返回一个至少包含当前位置字符的有效布局
        结果
        一个TextLayout ，从当前位置开始，代表wrappingWidth的下一行。 如果当前位置在该LineBreakMeasurer使用的文本的LineBreakMeasurer ，则返回null

      • getPosition

        public int getPosition​()
        返回此 LineBreakMeasurer的当前位置。
        结果
        这个 LineBreakMeasurer的当前位置
        另请参见：
        setPosition(int)

      • setPosition

        public void setPosition​(int newPosition)
        设置此 LineBreakMeasurer的当前位置。
        参数
        newPosition -此的当前位置LineBreakMeasurer ; 该位置应在用于构建此文本的文本内LineBreakMeasurer （或在最近传递给insertChar或deleteChar
        另请参见：
        getPosition()

      • insertChar

        public void insertChar​(AttributedCharacterIterator newParagraph,
                       int insertPos)
        在将单个字符插入到文本中后，更新此 LineBreakMeasurer ，并将当前位置设置为段落的开头。
        参数
        newParagraph - 插入后的文字
        insertPos - 插入字符的文本中的位置
        异常
        IndexOutOfBoundsException - 如果 insertPos小于 newParagraph或大于或等于末端的 newParagraph
        NullPointerException - 如果 newParagraph是 null
        另请参见：
        deleteChar(java.text.AttributedCharacterIterator, int)

      • deleteChar

        public void deleteChar​(AttributedCharacterIterator newParagraph,
                       int deletePos)
        在从文本中删除单个字符后更新此 LineBreakMeasurer ，并将当前位置设置为段落的开头。
        参数
        newParagraph - 删除后的文字
        deletePos - 字符被删除的文本中的位置
        异常
        IndexOutOfBoundsException -如果 deletePos小于开始 newParagraph或大于的端 newParagraph
        NullPointerException - 如果 newParagraph是 null
        另请参见：
        insertChar(java.text.AttributedCharacterIterator, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LineMetrics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class LineMetrics

  • java.lang.Object
    • java.awt.font.LineMetrics

  • public abstract class LineMetrics
extends Object
    LineMetrics类允许访问沿着一行排列字符和布局一组行所需的度量。 LineMetrics对象封装与文本运行相关联的测量信息。

    字体可以为不同范围的字符使用不同的指标。 所述getLineMetrics的方法Font采取一些文本作为参数，并返回一个LineMetrics对象描述在该文本字符的初始数量的度量，如通过返回getNumChars() 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      LineMetrics​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract float getAscent​()
      返回文本的上升。
      abstract int getBaselineIndex​()
      返回文本的基准索引。
      abstract float[] getBaselineOffsets​()
      返回相对于文本基线的文本的基线偏移量。
      abstract float getDescent​()
      返回文本的下降。
      abstract float getHeight​()
      返回文本的高度。
      abstract float getLeading​()
      返回文本的前导。
      abstract int getNumChars​()
      返回由此 LineMetrics对象封装其指标的文本中的字符数（ char值）。
      abstract float getStrikethroughOffset​()
      返回贯穿线相对于基线的位置。
      abstract float getStrikethroughThickness​()
      返回穿透线的厚度。
      abstract float getUnderlineOffset​()
      返回下划线相对于基线的位置。
      abstract float getUnderlineThickness​()
      返回下划线的厚度。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LineMetrics

        public LineMetrics​()

    • 方法详细信息

      • getNumChars

        public abstract int getNumChars​()
        返回文本中由 LineMetrics对象封装其度量标准的字符数（ char值）。
        结果
        在创建这个 LineMetrics的文本中的字符数（ char值）。

      • getAscent

        public abstract float getAscent​()
        返回文本的上升。 上升是从基线到上升线的距离。 上升通常代表文本大写字母的高度。 一些字符可以在上行线上方延伸。
        结果
        文本的上升。

      • getDescent

        public abstract float getDescent​()
        返回文本的下降。 下降是从基线到下降线的距离。 下降通常表示小写字母如“p”的底部距离。 一些角色可以延伸到下行线以下。
        结果
        文本的下降。

      • getLeading

        public abstract float getLeading​()
        返回文本的前导。 领先的是从下降线底部到下一行顶部的推荐距离。
        结果
        文字的领先。

      • getHeight

        public abstract float getHeight​()
        返回文本的高度。 高度等于上升，下降和前进的总和。
        结果
        文字的高度。

      • getBaselineIndex

        public abstract int getBaselineIndex​()
        返回文本的基准索引。 该指数是一个ROMAN_BASELINE ， CENTER_BASELINE ， HANGING_BASELINE 。
        结果
        文本的基线。

      • getBaselineOffsets

        public abstract float[] getBaselineOffsets​()
        返回相对于文本基线的文本的基线偏移量。 偏移量由基准指数索引。 例如，如果基准指数为CENTER_BASELINE则offsets[HANGING_BASELINE]通常为负， offsets[CENTER_BASELINE]为零， offsets[ROMAN_BASELINE]通常为正。
        结果
        文本的基线偏移量。

      • getStrikethroughOffset

        public abstract float getStrikethroughOffset​()
        返回贯穿线相对于基线的位置。
        结果
        穿透线的位置。

      • getStrikethroughThickness

        public abstract float getStrikethroughThickness​()
        返回穿透线的厚度。
        结果
        穿透线的厚度。

      • getUnderlineOffset

        public abstract float getUnderlineOffset​()
        返回下划线相对于基线的位置。
        结果
        下划线的位置。

      • getUnderlineThickness

        public abstract float getUnderlineThickness​()
        返回下划线的厚度。
        结果
        下划线的厚度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MultipleMaster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Interface MultipleMaster

  • public interface MultipleMaster
    MultipleMaster接口表示Type 1 Multiple Master字体。 一个特定的Font对象可以实现这个接口。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Font deriveMMFont​(float[] axes)
      根据指定数组中包含的设计轴值创建多个主字体的新实例。
      Font deriveMMFont​(float[] glyphWidths, float avgStemWidth, float typicalCapHeight, float typicalXHeight, float italicAngle)
      基于详细的度量标准信息创建一个多个主字体的新实例。
      float[] getDesignAxisDefaults​()
      返回每个轴的默认设计值数组。
      String[] getDesignAxisNames​()
      返回每个设计轴的名称。
      float[] getDesignAxisRanges​()
      返回一个设计限制的数组，每个轴以[从...到]的形式进行交错。
      int getNumDesignAxes​()
      返回多个主设计控件的数量。

    • 方法详细信息

      • getNumDesignAxes

        int getNumDesignAxes​()
        返回多个主设计控件的数量。 设计轴包括宽度，重量和光学缩放等。
        结果
        多个主设计控件的数量

      • getDesignAxisRanges

        float[] getDesignAxisRanges​()
        返回一个设计限制的数组，每个轴以[从...到]的形式进行交错。 例如，重量的设计限制可以是0.1到1.0。 值将按照getDesignAxisNames返回的相同顺序返回。
        结果
        每个轴的设计限制阵列。

      • getDesignAxisDefaults

        float[] getDesignAxisDefaults​()
        返回每个轴的默认设计值数组。 例如，权重的默认值可以是1.6。 值将按照getDesignAxisNames返回的相同顺序返回。
        结果
        每个轴的默认设计值数组。

      • getDesignAxisNames

        String[] getDesignAxisNames​()
        返回每个设计轴的名称。 这也决定了返回每个轴的值的顺序。
        结果
        一个包含每个设计轴名称的数组。

      • deriveMMFont

        Font deriveMMFont​(float[] axes)
        根据指定数组中包含的设计轴值创建多个主字体的新实例。 数组的大小必须对应于从getNumDesignAxes返回的值，并且数组元素的值必须在getDesignAxesLimits规定的限制内。 如果出现错误，则返回null 。
        参数
        axes - 包含轴值的数组
        结果
        一个Font对象，它是一个MultipleMaster的实例，基于axes提供的设计轴值。

      • deriveMMFont

        Font deriveMMFont​(float[] glyphWidths,
                  float avgStemWidth,
                  float typicalCapHeight,
                  float typicalXHeight,
                  float italicAngle)
        基于详细的度量标准信息创建一个多个主字体的新实例。 如果出现错误，则返回null 。
        参数
        glyphWidths - 表示字体空间中每个字形所需宽度的浮点数组
        avgStemWidth - 字体空间中整体字体的平均词干宽度
        typicalCapHeight - 典型的大写字母的高度
        typicalXHeight - 典型小写字母的高度
        italicAngle - 斜体倾斜的角度，以垂直方向逆时针旋转
        结果
        a Font object that is an instance of MultipleMaster and is based on the specified metric information.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NumericShaper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class NumericShaper

  • java.lang.Object
    • java.awt.font.NumericShaper
  • All Implemented Interfaces:
    Serializable

    public final class NumericShaper
extends Object
implements Serializable
    NumericShaper类用于将Latin-1（欧洲）数字转换为其他Unicode十进制数字。 这个类的用户主要是希望使用国家数字形状呈现数据的人，但是使用Latin-1（欧洲）数字，可以更方便地在内部表示数据。 这不会解释不推荐使用的数字形状选择器字符（U + 206E）。

    NumericShaper实例通常作为属性应用于TextAttribute类的NUMERIC_SHAPING属性的文本。 例如，这个代码片段会导致一个TextLayout在阿拉伯语中形成欧洲数字到阿拉伯语：

     Map map = new HashMap();
 map.put(TextAttribute.NUMERIC_SHAPING,
     NumericShaper.getContextualShaper(NumericShaper.ARABIC));
 FontRenderContext frc = ...;
 TextLayout layout = new TextLayout(text, map, frc);
 layout.draw(g2d, x, y);

    也可以使用NumericShaper实例明确地执行数字整形，因为这个代码段演示如下：
     char[] text = ...;
 // shape all EUROPEAN digits (except zero) to ARABIC digits
 NumericShaper shaper = NumericShaper.getShaper(NumericShaper.ARABIC);
 shaper.shape(text, start, count);

 // shape European digits to ARABIC digits if preceding text is Arabic, or
 // shape European digits to TAMIL digits if preceding text is Tamil, or
 // leave European digits alone if there is no preceding text, or
 // preceding text is neither Arabic nor Tamil
 NumericShaper shaper =
     NumericShaper.getContextualShaper(NumericShaper.ARABIC |
                                         NumericShaper.TAMIL,
                                       NumericShaper.EUROPEAN);
 shaper.shape(text, start, count);

    基于位掩码和基于枚举的Unicode范围

    该类支持两种不同的编程接口来表示特定于脚本的数字的Unicode范围：基于位掩码的数据，例如NumericShaper.ARABIC和基于枚举的数据，例如NumericShaper.Range.ARABIC 。 可以通过ORing位掩码的常量来指定多个范围，例如：

     NumericShaper.ARABIC | NumericShaper.TAMIL
    或创建Set与NumericShaper.Range常量，如：
     EnumSet.of(NumericShaper.Range.ARABIC, NumericShaper.Range.TAMIL)
    基于枚举的范围是基于位掩码的超级集。

    如果两个接口混合（包括序列化），则Unicode范围值映射到可以进行映射的对应方，如NumericShaper.Range.ARABIC从/到NumericShaper.ARABIC 。 如果指定了任何不可映射的范围值，例如NumericShaper.Range.BALINESE ，那么这些范围将被忽略。

    十进制数优先

    Unicode范围可能有多个十进制数字。 如果为同一个Unicode范围指定了多个十进制数字集，则其中一个集合的优先级如下。

    NumericShaper constants precedence Unicode Range NumericShaper Constants Precedence Arabic NumericShaper.ARABIC
    NumericShaper.EASTERN_ARABIC NumericShaper.EASTERN_ARABIC NumericShaper.Range.ARABIC
    NumericShaper.Range.EASTERN_ARABIC NumericShaper.Range.EASTERN_ARABIC Tai Tham NumericShaper.Range.TAI_THAM_HORA
    NumericShaper.Range.TAI_THAM_THAM NumericShaper.Range.TAI_THAM_THAM
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  NumericShaper.Range
      A NumericShaper.Range表示具有其自己的十进制数字的脚本的Unicode范围。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ALL_RANGES
      识别所有范围，用于完整的上下文整形。
      static int ARABIC
      标识ARABIC范围和十进制基数。
      static int BENGALI
      标识BENGALI范围和十进制基数。
      static int DEVANAGARI
      标识DEVANAGARI范围和十进制基数。
      static int EASTERN_ARABIC
      标识ARABIC范围和ARABIC_EXTENDED十进制基数。
      static int ETHIOPIC
      标识ETHIOPIC范围和十进制基数。
      static int EUROPEAN
      确定拉丁语1（欧洲）和扩展范围以及拉丁语1（欧洲）十进制基数。
      static int GUJARATI
      标识GUJARATI范围和十进制基数。
      static int GURMUKHI
      标识GURMUKHI范围和十进制基数。
      static int KANNADA
      标识KANNADA范围和十进制基数。
      static int KHMER
      标识KHMER范围和十进制基数。
      static int LAO
      标识LAO范围和十进制基数。
      static int MALAYALAM
      标识MALAYALAM范围和十进制基数。
      static int MONGOLIAN
      标识MONGOLIAN范围和十进制基数。
      static int MYANMAR
      标识MYANMAR范围和十进制基数。
      static int ORIYA
      标识ORIYA范围和十进制基数。
      static int TAMIL
      标识TAMIL范围和十进制基数。
      static int TELUGU
      标识TELUGU范围和十进制基数。
      static int THAI
      标识THAI范围和十进制基数。
      static int TIBETAN
      标识TIBETAN范围和十进制基数。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object o)
      返回 true如果指定的对象是 NumericShaper的实例，并且其形状与此一样，与范围表示，位掩码或枚举无关。
      static NumericShaper getContextualShaper​(int ranges)
      返回提供的unicode范围的上下文整形器。
      static NumericShaper getContextualShaper​(int ranges, int defaultContext)
      返回提供的unicode范围的上下文整形器。
      static NumericShaper getContextualShaper​(Set<NumericShaper.Range> ranges)
      返回提供的Unicode范围的上下文整形器。
      static NumericShaper getContextualShaper​(Set<NumericShaper.Range> ranges, NumericShaper.Range defaultContext)
      返回提供的Unicode范围的上下文整形器。
      int getRanges​()
      返回一个 int ，将所有范围的值组合在一起。
      Set<NumericShaper.Range> getRangeSet​()
      返回 Set代表所有的Unicode范围在此 NumericShaper将要成型。
      static NumericShaper getShaper​(int singleRange)
      返回提供的unicode范围的整形器。
      static NumericShaper getShaper​(NumericShaper.Range singleRange)
      返回提供的Unicode范围的整形器。
      int hashCode​()
      返回此整形器的哈希码。
      boolean isContextual​()
      返回一个 boolean指示此成形器是否上下文形状。
      void shape​(char[] text, int start, int count)
      转换在start和start + count之间发生的文本中的数字。
      void shape​(char[] text, int start, int count, int context)
      使用提供的上下文转换在start和start + count之间发生的文本中的数字。
      void shape​(char[] text, int start, int count, NumericShaper.Range context)
      使用提供的 context转换出现在 start和 start + count之间的文本中的数字。
      String toString​()
      返回描述此整形器的 String 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • EUROPEAN

        public static final int EUROPEAN
        确定拉丁语1（欧洲）和扩展范围以及拉丁语1（欧洲）十进制基数。
        另请参见：
        Constant Field Values

      • ARABIC

        public static final int ARABIC
        标识ARABIC范围和十进制基数。
        另请参见：
        Constant Field Values

      • EASTERN_ARABIC

        public static final int EASTERN_ARABIC
        标识ARABIC范围和ARABIC_EXTENDED十进制基数。
        另请参见：
        Constant Field Values

      • DEVANAGARI

        public static final int DEVANAGARI
        标识DEVANAGARI范围和十进制基数。
        另请参见：
        Constant Field Values

      • BENGALI

        public static final int BENGALI
        标识BENGALI范围和十进制基数。
        另请参见：
        Constant Field Values

      • GURMUKHI

        public static final int GURMUKHI
        标识GURMUKHI范围和十进制基数。
        另请参见：
        Constant Field Values

      • GUJARATI

        public static final int GUJARATI
        标识GUJARATI范围和十进制基数。
        另请参见：
        Constant Field Values

      • ORIYA

        public static final int ORIYA
        标识ORIYA范围和十进制基数。
        另请参见：
        Constant Field Values

      • TAMIL

        public static final int TAMIL
        标识TAMIL范围和十进制基数。
        另请参见：
        Constant Field Values

      • TELUGU

        public static final int TELUGU
        标识TELUGU范围和十进制基数。
        另请参见：
        Constant Field Values

      • KANNADA

        public static final int KANNADA
        标识KANNADA范围和十进制基数。
        另请参见：
        Constant Field Values

      • MALAYALAM

        public static final int MALAYALAM
        标识MALAYALAM范围和十进制基数。
        另请参见：
        Constant Field Values

      • THAI

        public static final int THAI
        标识THAI范围和十进制基数。
        另请参见：
        Constant Field Values

      • LAO

        public static final int LAO
        标识LAO范围和十进制基数。
        另请参见：
        Constant Field Values

      • TIBETAN

        public static final int TIBETAN
        标识TIBETAN范围和十进制基数。
        另请参见：
        Constant Field Values

      • MYANMAR

        public static final int MYANMAR
        标识MYANMAR范围和十进制基数。
        另请参见：
        Constant Field Values

      • ETHIOPIC

        public static final int ETHIOPIC
        标识ETHIOPIC范围和十进制基数。
        另请参见：
        Constant Field Values

      • KHMER

        public static final int KHMER
        标识KHMER范围和十进制基数。
        另请参见：
        Constant Field Values

      • MONGOLIAN

        public static final int MONGOLIAN
        标识MONGOLIAN范围和十进制基数。
        另请参见：
        Constant Field Values

      • ALL_RANGES

        public static final int ALL_RANGES
        识别所有范围，用于完整的上下文整形。

        该常数指定所有基于位掩码的范围。 使用EnumSet.allOf(NumericShaper.Range.class)指定所有基于枚举的范围。

        另请参见：
        Constant Field Values

    • 方法详细信息

      • getShaper

        public static NumericShaper getShaper​(int singleRange)
        返回提供的unicode范围的整形器。 所有Latin-1（EUROPEAN）数字转换为相应的十进制unicode数字。
        参数
        singleRange - 指定的Unicode范围
        结果
        非上下文数字整形器
        异常
        IllegalArgumentException - 如果范围不是单个范围

      • getShaper

        public static NumericShaper getShaper​(NumericShaper.Range singleRange)
        返回提供的Unicode范围的整形器。 所有Latin-1（EUROPEAN）数字都将转换为指定Unicode范围的相应十进制数字。
        参数
        singleRange - 由NumericShaper.Range常量给出的Unicode范围。
        结果
        一个非上下文的 NumericShaper 。
        异常
        NullPointerException - 如果 singleRange是 null
        从以下版本开始：
        1.7

      • getContextualShaper

        public static NumericShaper getContextualShaper​(int ranges)
        返回提供的unicode范围的上下文整形器。 如果范围是所提供的范围之一，则将Latin-1（EUROPEAN）数字转换为与前一文本范围相对应的十进制数字。 多个范围由值或值组合表示，例如NumericShaper.ARABIC | NumericShaper.THAI 。 整形器以欧洲方式为起始语境，也就是说，如果字符串中任何强有力的方向文本之前遇到欧洲数字，则上下文被推定为欧洲，因此数字将不会变形。
        参数
        ranges - 指定的Unicode范围
        结果
        指定范围的整形器

      • getContextualShaper

        public static NumericShaper getContextualShaper​(Set<NumericShaper.Range> ranges)
        返回提供的Unicode范围的上下文整形器。 如果范围是提供的范围之一，则将Latin-1（EUROPEAN）数字转换为与前一文本范围相对应的十进制数字。

        整形器以欧洲方式为起始语境，也就是说，如果字符串中任何强有力的方向文本之前遇到欧洲数字，则上下文被推定为欧洲，因此数字将不会变形。

        参数
        ranges - 指定的Unicode范围
        结果
        指定范围的上下文整形器
        异常
        NullPointerException - 如果 ranges是 null 。
        从以下版本开始：
        1.7

      • getContextualShaper

        public static NumericShaper getContextualShaper​(int ranges,
                                                int defaultContext)
        返回提供的unicode范围的上下文整形器。 如果范围是提供的范围之一，则拉丁-1（欧洲）数字将被转换为对应于前一文本范围的十进制数字。 多个范围由值或值组合表示，例如NumericShaper.ARABIC | NumericShaper.THAI 。 整形器使用defaultContext作为起始上下文。
        参数
        ranges - 指定的Unicode范围
        defaultContext - 起始上下文，如 NumericShaper.EUROPEAN
        结果
        指定Unicode范围的整形器。
        异常
        IllegalArgumentException - 如果指定的 defaultContext不是单个有效范围。

      • getContextualShaper

        public static NumericShaper getContextualShaper​(Set<NumericShaper.Range> ranges,
                                                NumericShaper.Range defaultContext)
        返回提供的Unicode范围的上下文整形器。 如果范围是提供的范围之一，则Latin-1（EUROPEAN）数字将被转换为对应于前一文本范围的十进制数字。 整形器使用defaultContext作为起始上下文。
        参数
        ranges - 指定的Unicode范围
        defaultContext - 起始上下文，如 NumericShaper.Range.EUROPEAN
        结果
        指定Unicode范围的上下文整形器。
        异常
        NullPointerException - 如果是 ranges或 defaultContext是 null
        从以下版本开始：
        1.7

      • shape

        public void shape​(char[] text,
                  int start,
                  int count)
        转换在start和start + count之间发生的文本中的数字。
        参数
        text - 要转换的字符数组
        start - 索引为 text开始转换
        count - 要转换的字符数 text
        异常
        IndexOutOfBoundsException - 如果启动或启动+计数超出范围
        NullPointerException - 如果文本为空

      • shape

        public void shape​(char[] text,
                  int start,
                  int count,
                  int context)
        使用提供的上下文转换在start和start + count之间发生的文本中的数字。 如果整形器不是上下文整形器，则忽略上下文。
        参数
        text - 一个字符数组
        start - 索引到 text开始转换
        count - 要转换的字符数 text
        context - 转换为字符的上下文，如 NumericShaper.EUROPEAN
        异常
        IndexOutOfBoundsException - 如果启动或启动+计数超出范围
        NullPointerException - 如果文本为空
        IllegalArgumentException - 如果这是一个上下文整形器，并且指定的 context不是单个有效范围。

      • shape

        public void shape​(char[] text,
                  int start,
                  int count,
                  NumericShaper.Range context)
        使用提供的context转换出现在start和start + count之间的文本中的数字。 如果整形器不是上下文整形器，则忽略Context 。
        参数
        text - a char数组
        start - 索引到 text开始转换
        count -数量 char S IN text转换
        context - 转换为字符的上下文，如 NumericShaper.Range.EUROPEAN
        异常
        IndexOutOfBoundsException - 如果 start或 start + count超出范围
        NullPointerException - 如果 text或 context为空
        从以下版本开始：
        1.7

      • isContextual

        public boolean isContextual​()
        返回一个 boolean指示此成形器是否内容形状。
        结果
        true如果这个整形器是上下文的; 否则为false 。

      • getRanges

        public int getRanges​()
        返回一个int ，将所有范围的值组合在一起。

        例如，要检查整形器是否形状为阿拉伯语，您将使用以下内容：

        if ((shaper.getRanges() & shaper.ARABIC) != 0) &#123; ...

        请注意，此方法仅支持基于位掩码的范围。 请致电getRangeSet()查询基于枚举的范围。

        结果
        要形成的所有范围的值。

      • getRangeSet

        public Set<NumericShaper.Range> getRangeSet​()
        返回 Set代表所有的Unicode范围在此 NumericShaper将要成型。
        结果
        所有的Unicode范围都要形成。
        从以下版本开始：
        1.7

      • hashCode

        public int hashCode​()
        返回此整形器的哈希码。
        重写：
        hashCode在 Object
        结果
        这个整形器的哈希码。
        另请参见：
        Object.hashCode()

      • equals

        public boolean equals​(Object o)
        如果指定的对象是NumericShaper的实例，并且与此对象的形状相同，则返回true ，无论范围表示，位掩码或枚举如何。 例如，以下代码生成"true" 。
         NumericShaper ns1 = NumericShaper.getShaper(NumericShaper.ARABIC);
 NumericShaper ns2 = NumericShaper.getShaper(NumericShaper.Range.ARABIC);
 System.out.println(ns1.equals(ns2));
        重写：
        equals在 Object
        参数
        o -指定要比较的对象这个 NumericShaper
        结果
        true如果o是实例NumericShaper种形状以同样的方式; false否则。
        另请参见：
        Object.equals(java.lang.Object)

      • toString

        public String toString​()
        返回描述此整形器的String 。 此方法仅用于调试。
        重写：
        toString在 Object
        结果
        一个 String描述这个整形器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NumericShaper.Range (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.desktop
软件包 java.awt.font

Enum NumericShaper.Range

  • java.lang.Object
    • java.lang.Enum<NumericShaper.Range>
      • java.awt.font.NumericShaper.Range
  • All Implemented Interfaces:
    Serializable ， Comparable<NumericShaper.Range>
    Enclosing class:
    NumericShaper

    public static enum NumericShaper.Range
extends Enum<NumericShaper.Range>
    A NumericShaper.Range表示具有其自己的十进制数字的脚本的Unicode范围。 例如， THAI范围内有泰文数字，THAI DIGIT ZERO（U + 0E50）到THAI DIGIT NINE（U + 0E59）。

    Range枚举替代了传统的基于位掩码的值（例如， NumericShaper.ARABIC ），并支持比基于位掩码的更多的Unicode范围。 例如，使用位掩码的以下代码：

     NumericShaper.getContextualShaper(NumericShaper.ARABIC |
                                     NumericShaper.TAMIL,
                                   NumericShaper.EUROPEAN);
    可以用这个枚举写成：
     NumericShaper.getContextualShaper(EnumSet.of(
                                     NumericShaper.Range.ARABIC,
                                     NumericShaper.Range.TAMIL),
                                   NumericShaper.Range.EUROPEAN);
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ARABIC
      阿拉伯语范围与阿拉伯语 - 印度数字。
      BALINESE
      巴厘岛系列与巴厘岛数字。
      BENGALI
      孟加拉语范围与孟加拉语数字。
      CHAM
      Cham系列与Cham数字。
      DEVANAGARI
      梵文的范围与梵文数字。
      EASTERN_ARABIC
      阿拉伯语范围与东部阿拉伯语 - 印度数字。
      ETHIOPIC
      埃塞俄比亚的范围与埃塞俄比亚数字。
      EUROPEAN
      拉丁语（欧洲）范围与拉丁（ASCII）数字。
      GUJARATI
      古吉拉特语古吉拉特语数字。
      GURMUKHI
      古尔穆赫（Gurmukhi）范围与古尔穆奇数字。
      JAVANESE
      爪哇范围与爪哇数字。
      KANNADA
      卡纳达范围与卡纳达数字。
      KAYAH_LI
      Kayah Li范围与Kayah Li数字。
      KHMER
      高棉范围与高棉数字。
      LAO
      老挝数字老挝范围。
      LEPCHA
      Lepcha范围与Lepcha数字。
      LIMBU
      Limbu范围与Limbu数字。
      MALAYALAM
      马拉雅拉姆岛的马拉雅拉姆数字。
      MEETEI_MAYEK
      Meetei Mayek系列与Meetei Mayek数字。
      MONGOLIAN
      蒙古数字与蒙古数字。
      MYANMAR
      缅甸的数字与缅甸数字相同。
      MYANMAR_SHAN
      缅甸与缅甸山脉的数字。
      MYANMAR_TAI_LAING
      缅甸扩大B区与缅甸泰安数字。
      NEW_TAI_LUE
      新泰乐系列与新泰乐数位。
      NKO
      N'Ko范围与N'Ko数字。
      OL_CHIKI
      Ol Chiki数字的Ol Chiki系列。
      ORIYA
      Oriya系列与Oriya数字。
      SAURASHTRA
      Saurashtra系列与Saurashtra数字。
      SINHALA
      僧伽罗语范围与僧伽罗数字。
      SUNDANESE
      Sundㄧese Sund Sund Sund Sund。。。
      TAI_THAM_HORA
      泰泰霍亚（Tai Tham Hora）系列与泰泰尔（Tai Tham Hora）数位。
      TAI_THAM_THAM
      泰晤士报泰山系列与泰泰泰姆数位。
      TAMIL
      泰米尔语范围与泰米尔数字。
      TELUGU
      具有泰卢固语数字的泰卢固语范围。
      THAI
      泰国范围与泰国数字。
      TIBETAN
      藏族数字与西藏数字。
      VAI
      Vai范围与Vai数字。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static NumericShaper.Range valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static NumericShaper.Range[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • EUROPEAN

        public static final NumericShaper.Range EUROPEAN
        拉丁语（欧洲）范围与拉丁（ASCII）数字。

      • ARABIC

        public static final NumericShaper.Range ARABIC
        阿拉伯语范围与阿拉伯语 - 印度数字。

      • EASTERN_ARABIC

        public static final NumericShaper.Range EASTERN_ARABIC
        阿拉伯语范围与东部阿拉伯语 - 印度数字。

      • DEVANAGARI

        public static final NumericShaper.Range DEVANAGARI
        梵文的范围与梵文数字。

      • BENGALI

        public static final NumericShaper.Range BENGALI
        孟加拉语范围与孟加拉语数字。

      • GURMUKHI

        public static final NumericShaper.Range GURMUKHI
        古尔穆赫（Gurmukhi）范围与古尔穆奇数字。

      • GUJARATI

        public static final NumericShaper.Range GUJARATI
        古吉拉特语古吉拉特语数字。

      • ORIYA

        public static final NumericShaper.Range ORIYA
        Oriya系列与Oriya数字。

      • TAMIL

        public static final NumericShaper.Range TAMIL
        泰米尔语范围与泰米尔数字。

      • TELUGU

        public static final NumericShaper.Range TELUGU
        具有泰卢固语数字的泰卢固语范围。

      • KANNADA

        public static final NumericShaper.Range KANNADA
        卡纳达范围与卡纳达数字。

      • MALAYALAM

        public static final NumericShaper.Range MALAYALAM
        马拉雅拉姆岛的马拉雅拉姆数字。

      • THAI

        public static final NumericShaper.Range THAI
        泰国范围与泰国数字。

      • LAO

        public static final NumericShaper.Range LAO
        老挝数字老挝范围。

      • TIBETAN

        public static final NumericShaper.Range TIBETAN
        藏族数字与西藏数字。

      • MYANMAR

        public static final NumericShaper.Range MYANMAR
        缅甸的数字与缅甸数字相同。

      • ETHIOPIC

        public static final NumericShaper.Range ETHIOPIC
        埃塞俄比亚的范围与埃塞俄比亚数字。 埃塞俄比亚没有十进制数字0，因此使用拉丁语（欧洲）0。

      • KHMER

        public static final NumericShaper.Range KHMER
        高棉范围与高棉数字。

      • MONGOLIAN

        public static final NumericShaper.Range MONGOLIAN
        蒙古数字与蒙古数字。

      • NKO

        public static final NumericShaper.Range NKO
        N'Ko范围与N'Ko数字。

      • MYANMAR_SHAN

        public static final NumericShaper.Range MYANMAR_SHAN
        缅甸与缅甸山脉的数字。

      • LIMBU

        public static final NumericShaper.Range LIMBU
        Limbu范围与Limbu数字。

      • NEW_TAI_LUE

        public static final NumericShaper.Range NEW_TAI_LUE
        新泰乐系列与新泰乐数位。

      • BALINESE

        public static final NumericShaper.Range BALINESE
        巴厘岛系列与巴厘岛数字。

      • SUNDANESE

        public static final NumericShaper.Range SUNDANESE
        Sundㄧese Sund Sund Sund Sund。。。

      • LEPCHA

        public static final NumericShaper.Range LEPCHA
        Lepcha范围与Lepcha数字。

      • OL_CHIKI

        public static final NumericShaper.Range OL_CHIKI
        Ol Chiki数字的Ol Chiki系列。

      • VAI

        public static final NumericShaper.Range VAI
        Vai范围与Vai数字。

      • SAURASHTRA

        public static final NumericShaper.Range SAURASHTRA
        Saurashtra系列与Saurashtra数字。

      • KAYAH_LI

        public static final NumericShaper.Range KAYAH_LI
        Kayah Li范围与Kayah Li数字。

      • CHAM

        public static final NumericShaper.Range CHAM
        Cham系列与Cham数字。

      • TAI_THAM_HORA

        public static final NumericShaper.Range TAI_THAM_HORA
        泰泰霍亚（Tai Tham Hora）系列与泰泰尔（Tai Tham Hora）数位。

      • TAI_THAM_THAM

        public static final NumericShaper.Range TAI_THAM_THAM
        泰晤士报泰山系列与泰泰泰姆数位。

      • JAVANESE

        public static final NumericShaper.Range JAVANESE
        爪哇范围与爪哇数字。

      • MEETEI_MAYEK

        public static final NumericShaper.Range MEETEI_MAYEK
        Meetei Mayek系列与Meetei Mayek数字。

      • SINHALA

        public static final NumericShaper.Range SINHALA
        僧伽罗语范围与僧伽罗数字。
        从以下版本开始：
        9

      • MYANMAR_TAI_LAING

        public static final NumericShaper.Range MYANMAR_TAI_LAING
        缅甸扩大B区与缅甸泰安数字。
        从以下版本开始：
        9

    • 方法详细信息

      • values

        public static NumericShaper.Range[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (NumericShaper.Range c : NumericShaper.Range.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static NumericShaper.Range valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


OpenType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Interface OpenType

  • public interface OpenType
    OpenType接口代表OpenType和TrueType字体。 该界面使得可以从字体获取sfnt表。 一个特定的Font对象可以实现这个接口。

    有关TrueType和OpenType字体的更多信息，请参阅OpenType规范。 （ http://www.microsoft.com/typography/otspec/ ）。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TAG_ACNT
      重音附件。
      static int TAG_AVAR
      轴变化。
      static int TAG_BASE
      基准数据
      static int TAG_BDAT
      位图数据。
      static int TAG_BLOC
      位图位置。
      static int TAG_BSLN
      基线表。
      static int TAG_CFF
      紧凑字体格式（Type1字体）。
      static int TAG_CMAP
      字符到字形映射。
      static int TAG_CVAR
      CVT变化。
      static int TAG_CVT
      控制值表。
      static int TAG_DSIG
      电子签名。
      static int TAG_EBDT
      嵌入式位图数据。
      static int TAG_EBLC
      嵌入式位图位置。
      static int TAG_EBSC
      嵌入式位图缩放。
      static int TAG_FDSC
      字体描述符。
      static int TAG_FEAT
      功能名称
      static int TAG_FMTX
      字体指标。
      static int TAG_FPGM
      字体程序。
      static int TAG_FVAR
      字体变体。
      static int TAG_GASP
      网格拟合和扫描转换程序。
      static int TAG_GDEF
      字形定义。
      static int TAG_GLYF
      字形数据。
      static int TAG_GPOS
      字形定位
      static int TAG_GSUB
      雕文取代
      static int TAG_GVAR
      字形变异。
      static int TAG_HDMX
      水平设备指标。
      static int TAG_HEAD
      字体标题
      static int TAG_HHEA
      水平度量标题。
      static int TAG_HMTX
      水平指标。
      static int TAG_JSTF
      理由。
      static int TAG_JUST
      理由。
      static int TAG_KERN
      字距。
      static int TAG_LCAR
      特征插入符号。
      static int TAG_LOCA
      位置索引
      static int TAG_LTSH
      线性阈值。
      static int TAG_MAXP
      最大配置文件
      static int TAG_MMFX
      多个主字体指标。
      static int TAG_MMSD
      多个主要补充数据。
      static int TAG_MORT
      雕文变态
      static int TAG_NAME
      命名表。
      static int TAG_OPBD
      光学界限。
      static int TAG_OS2
      OS / 2和Windows特定指标。
      static int TAG_PCLT
      PCL 5数据。
      static int TAG_POST
      PostScript信息。
      static int TAG_PREP
      CVT预制程序。
      static int TAG_PROP
      雕文属性。
      static int TAG_TRAK
      跟踪。
      static int TAG_TYP1
      Adobe Type 1字体数据。
      static int TAG_VDMX
      垂直设备指标。
      static int TAG_VHEA
      垂直度量标题。
      static int TAG_VMTX
      垂直指标。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      byte[] getFontTable​(int sfntTag)
      将表作为指定标记的字节数组返回。
      byte[] getFontTable​(int sfntTag, int offset, int count)
      将表的子集作为指定标记的字节数组返回。
      byte[] getFontTable​(String strSfntTag)
      将表作为指定标记的字节数组返回。
      byte[] getFontTable​(String strSfntTag, int offset, int count)
      将表的子集作为指定标记的字节数组返回。
      int getFontTableSize​(int sfntTag)
      返回指定标记的表的大小。
      int getFontTableSize​(String strSfntTag)
      返回指定标记的表的大小。
      int getVersion​()
      返回OpenType字体的版本。 1.0表示为0x00010000。

    • 字段详细信息

      • TAG_CMAP

        static final int TAG_CMAP
        字符到字形映射。 打开类型规范中的表标记“cmap”。
        另请参见：
        Constant Field Values

      • TAG_HEAD

        static final int TAG_HEAD
        字体标题 打开类型规范中的表标记“头”。
        另请参见：
        Constant Field Values

      • TAG_NAME

        static final int TAG_NAME
        命名表。 打开类型规范中的表标记“名称”。
        另请参见：
        Constant Field Values

      • TAG_GLYF

        static final int TAG_GLYF
        字形数据。 打开类型规范中的表标记“glyf”。
        另请参见：
        Constant Field Values

      • TAG_MAXP

        static final int TAG_MAXP
        最大配置文件 打开类型规范中的表标记“maxp”。
        另请参见：
        Constant Field Values

      • TAG_PREP

        static final int TAG_PREP
        CVT预制程序。 表格标签“准备”在开放类型规范。
        另请参见：
        Constant Field Values

      • TAG_HMTX

        static final int TAG_HMTX
        水平指标。 打开类型规范中的表标记“hmtx”。
        另请参见：
        Constant Field Values

      • TAG_KERN

        static final int TAG_KERN
        字距。 打开类型规范中的表标记“kern”。
        另请参见：
        Constant Field Values

      • TAG_HDMX

        static final int TAG_HDMX
        水平设备指标。 打开类型规范中的表标记“hdmx”。
        另请参见：
        Constant Field Values

      • TAG_LOCA

        static final int TAG_LOCA
        位置索引 打开类型规范中的表标记“loca”。
        另请参见：
        Constant Field Values

      • TAG_POST

        static final int TAG_POST
        PostScript信息。 打开类型规范中的表标签“post”。
        另请参见：
        Constant Field Values

      • TAG_OS2

        static final int TAG_OS2
        OS / 2和Windows特定指标。 打开类型规范中的表标记“OS / 2”。
        另请参见：
        Constant Field Values

      • TAG_CVT

        static final int TAG_CVT
        控制值表。 打开类型规范中的表标记“cvt”。
        另请参见：
        Constant Field Values

      • TAG_GASP

        static final int TAG_GASP
        网格拟合和扫描转换程序。 打开类型规范中的表标签“gasp”。
        另请参见：
        Constant Field Values

      • TAG_VDMX

        static final int TAG_VDMX
        垂直设备指标。 打开类型规范中的表标记“VDMX”。
        另请参见：
        Constant Field Values

      • TAG_VMTX

        static final int TAG_VMTX
        垂直指标。 打开类型规范中的表标记“vmtx”。
        另请参见：
        Constant Field Values

      • TAG_VHEA

        static final int TAG_VHEA
        垂直度量标题。 打开类型规范中的表标签“vhea”。
        另请参见：
        Constant Field Values

      • TAG_HHEA

        static final int TAG_HHEA
        水平度量标题。 打开类型规范中的表标记“hhea”。
        另请参见：
        Constant Field Values

      • TAG_TYP1

        static final int TAG_TYP1
        Adobe Type 1字体数据。 打开类型规范中的表标记“typ1”。
        另请参见：
        Constant Field Values

      • TAG_BSLN

        static final int TAG_BSLN
        基线表。 打开类型规范中的表标记“bsln”。
        另请参见：
        Constant Field Values

      • TAG_GSUB

        static final int TAG_GSUB
        雕文取代 开放类型规范中的表格标签“GSUB”。
        另请参见：
        Constant Field Values

      • TAG_DSIG

        static final int TAG_DSIG
        电子签名。 打开类型规范中的表标签“DSIG”。
        另请参见：
        Constant Field Values

      • TAG_FPGM

        static final int TAG_FPGM
        字体程序。 打开类型规范中的表标记“fpgm”。
        另请参见：
        Constant Field Values

      • TAG_FVAR

        static final int TAG_FVAR
        字体变体。 打开类型规范中的表标记“fvar”。
        另请参见：
        Constant Field Values

      • TAG_GVAR

        static final int TAG_GVAR
        字形变异。 打开类型规范中的表格标签“gvar”。
        另请参见：
        Constant Field Values

      • TAG_CFF

        static final int TAG_CFF
        紧凑字体格式（Type1字体）。 打开类型规范中的表标记“CFF”。
        另请参见：
        Constant Field Values

      • TAG_MMSD

        static final int TAG_MMSD
        多个主要补充数据。 打开类型规范中的表标签“MMSD”。
        另请参见：
        Constant Field Values

      • TAG_MMFX

        static final int TAG_MMFX
        多个主字体指标。 打开类型规范中的表格标签“MMFX”。
        另请参见：
        Constant Field Values

      • TAG_BASE

        static final int TAG_BASE
        基准数据 打开类型规范中的表标签“BASE”。
        另请参见：
        Constant Field Values

      • TAG_GDEF

        static final int TAG_GDEF
        字形定义。 打开类型规范中的表格“GDEF”。
        另请参见：
        Constant Field Values

      • TAG_GPOS

        static final int TAG_GPOS
        字形定位 打开类型规范中的表标记“GPOS”。
        另请参见：
        Constant Field Values

      • TAG_JSTF

        static final int TAG_JSTF
        理由。 打开类型规范中的表标记“JSTF”。
        另请参见：
        Constant Field Values

      • TAG_EBDT

        static final int TAG_EBDT
        嵌入式位图数据。 打开类型规范中的表标签“EBDT”。
        另请参见：
        Constant Field Values

      • TAG_EBLC

        static final int TAG_EBLC
        嵌入式位图位置。 表格标签“EBLC”在开放类型规范。
        另请参见：
        Constant Field Values

      • TAG_EBSC

        static final int TAG_EBSC
        嵌入式位图缩放。 打开类型规范中的表标记“EBSC”。
        另请参见：
        Constant Field Values

      • TAG_LTSH

        static final int TAG_LTSH
        线性阈值。 打开类型规范中的表标签“LTSH”。
        另请参见：
        Constant Field Values

      • TAG_PCLT

        static final int TAG_PCLT
        PCL 5数据。 表格标签“PCLT”在开放类型规范。
        另请参见：
        Constant Field Values

      • TAG_ACNT

        static final int TAG_ACNT
        重音附件。 打开类型规范中的表标记“acnt”。
        另请参见：
        Constant Field Values

      • TAG_AVAR

        static final int TAG_AVAR
        轴变化。 Open标准中的表格标签“avar”。
        另请参见：
        Constant Field Values

      • TAG_BDAT

        static final int TAG_BDAT
        位图数据。 打开类型规范中的表标记“bdat”。
        另请参见：
        Constant Field Values

      • TAG_BLOC

        static final int TAG_BLOC
        位图位置。 打开类型规范中的表标记“bloc”。
        另请参见：
        Constant Field Values

      • TAG_CVAR

        static final int TAG_CVAR
        CVT变化。 开放类型规范中的表格标签“cvar”。
        另请参见：
        Constant Field Values

      • TAG_FEAT

        static final int TAG_FEAT
        功能名称 打开类型规范中的表标记“feat”。
        另请参见：
        Constant Field Values

      • TAG_FDSC

        static final int TAG_FDSC
        字体描述符。 打开类型规范中的表标记“fdsc”。
        另请参见：
        Constant Field Values

      • TAG_FMTX

        static final int TAG_FMTX
        字体指标。 打开类型规范中的表标记“fmtx”。
        另请参见：
        Constant Field Values

      • TAG_JUST

        static final int TAG_JUST
        理由。 打开类型规范中的表格标签“just”。
        另请参见：
        Constant Field Values

      • TAG_LCAR

        static final int TAG_LCAR
        特征插入符号。 打开类型规范中的表标记“lcar”。
        另请参见：
        Constant Field Values

      • TAG_MORT

        static final int TAG_MORT
        雕文变态 打开类型规范中的表格标签“mort”。
        另请参见：
        Constant Field Values

      • TAG_OPBD

        static final int TAG_OPBD
        光学界限。 打开类型规范中的表标记“opbd”。
        另请参见：
        Constant Field Values

      • TAG_PROP

        static final int TAG_PROP
        雕文属性。 打开类型规范中的表格标签“prop”。
        另请参见：
        Constant Field Values

      • TAG_TRAK

        static final int TAG_TRAK
        跟踪。 打开类型规范中的表标签“trak”。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getVersion

        int getVersion​()
        返回OpenType字体的版本。 1.0表示为0x00010000。
        结果
        该版本的 OpenType字体。

      • getFontTable

        byte[] getFontTable​(int sfntTag)
        将表作为指定标记的字节数组返回。 sfnt表的标签包括cmap ， name和head等项。 返回的byte数组是内存中字体数据的副本。
        参数
        sfntTag - 作为32位整数的四字符代码
        结果
        一个 byte数组，它是包含与指定标签对应的字体数据的表。

      • getFontTable

        byte[] getFontTable​(String strSfntTag)
        将表作为指定标记的字节数组返回。 sfnt表的标签包括cmap ， name和head等项。 返回的字节数组是内存中字体数据的副本。
        参数
        strSfntTag - 一个四字符代码作为 String
        结果
        一个 byte数组，它是包含与指定标签对应的字体数据的表。

      • getFontTable

        byte[] getFontTable​(int sfntTag,
                    int offset,
                    int count)
        将表的子集作为指定标记的字节数组返回。 sfnt表的标签包括cmap ， name和head等项。 返回的字节数组是内存中字体数据的副本。
        参数
        sfntTag - 一个四位字符的代码，作为32位整数
        offset - 从表返回的第一个字节的索引
        count - 从表返回的字节数
        结果
        该表的子集对应于 sfntTag并包含从 offset字节开始并包括 count个字节的字节。

      • getFontTable

        byte[] getFontTable​(String strSfntTag,
                    int offset,
                    int count)
        将表的子集作为指定标记的字节数组返回。 sfnt表的标签包括cmap ， name和head等项。 返回的byte数组是内存中字体数据的副本。
        参数
        strSfntTag - 一个四字符代码作为 String
        offset - 从表返回的第一个字节的索引
        count - 从表返回的字节数
        结果
        该表的子集对应于 strSfntTag并包含从 offset字节开始并包括 count个字节的字节。

      • getFontTableSize

        int getFontTableSize​(int sfntTag)
        返回指定标记的表的大小。 sfnt表的标签包括cmap ， name和head等项。
        参数
        sfntTag - 一个四位字符的代码，作为32位整数
        结果
        表的大小对应于指定的标签。

      • getFontTableSize

        int getFontTableSize​(String strSfntTag)
        返回指定标记的表的大小。 sfnt表的标签包括cmap ， name和head等项。
        参数
        strSfntTag - 一个四字符代码作为 String
        结果
        表的大小对应于指定的标签。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ShapeGraphicAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class ShapeGraphicAttribute

  • java.lang.Object
    • java.awt.font.GraphicAttribute
      • java.awt.font.ShapeGraphicAttribute

  • public final class ShapeGraphicAttribute
extends GraphicAttribute
    该ShapeGraphicAttribute类的实现GraphicAttribute绘制形状在TextLayout 。
    另请参见：
    GraphicAttribute

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static boolean FILL
      一个表示形状的键应该被填充。
      static boolean STROKE
      一个指示形状的键应该用1像素宽的笔划来抚摸。

      • Fields inherited from class java.awt.font.GraphicAttribute

        BOTTOM_ALIGNMENT, CENTER_BASELINE, HANGING_BASELINE, ROMAN_BASELINE, TOP_ALIGNMENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      ShapeGraphicAttribute​(Shape shape, int alignment, boolean stroke)
      构造一个ShapeGraphicAttribute为指定Shape 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void draw​(Graphics2D graphics, float x, float y)
      在指定的位置渲染此 GraphicAttribute 。
      boolean equals​(ShapeGraphicAttribute rhs)
      将此 ShapeGraphicAttribute与指定的 ShapeGraphicAttribute 。
      boolean equals​(Object rhs)
      将此 ShapeGraphicAttribute与指定的 Object 。
      float getAdvance​()
      返回此 ShapeGraphicAttribute 。
      float getAscent​()
      返回此 ShapeGraphicAttribute的上升。
      Rectangle2D getBounds​()
      返回一个Rectangle2D ，它包含相对于渲染位置的ShapeGraphicAttribute绘制的所有位。
      float getDescent​()
      返回此 ShapeGraphicAttribute的下降。
      Shape getOutline​(AffineTransform tx)
      返回一个Shape ，表示该区域ShapeGraphicAttribute呈现。
      int hashCode​()
      返回此 ShapeGraphicAttribute的哈希 ShapeGraphicAttribute 。

      • Methods inherited from class java.awt.font.GraphicAttribute

        getAlignment, getJustificationInfo

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • STROKE

        public static final boolean STROKE
        一个指示形状的键应该用1像素宽的笔划来抚摸。
        另请参见：
        Constant Field Values

      • FILL

        public static final boolean FILL
        一个表示形状的键应该被填充。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ShapeGraphicAttribute

        public ShapeGraphicAttribute​(Shape shape,
                             int alignment,
                             boolean stroke)
        构造一个ShapeGraphicAttribute为指定Shape 。
        参数
        shape - 要呈现的Shape 。 Shape的原产地ShapeGraphicAttribute的主机TextLayout 。 此对象维护对shape的引用。
        alignment - 从这个 ShapeGraphicAttribute一个对齐方式。
        stroke - true如果Shape应该抚摸; false如果要填写Shape 。

    • 方法详细信息

      • getAscent

        public float getAscent​()
        返回此ShapeGraphicAttribute的上升。 一的上升ShapeGraphicAttribute是从它的起源的正距离Shape它的边界的顶部Shape 。
        Specified by:
        getAscent在 GraphicAttribute
        结果
        这个 ShapeGraphicAttribute的上升。
        另请参见：
        GraphicAttribute.getBounds()

      • getDescent

        public float getDescent​()
        返回此ShapeGraphicAttribute的下降。 一个ShapeGraphicAttribute的下降是从其Shape的起点到其Shape的边界的底部的Shape 。
        Specified by:
        getDescent在 GraphicAttribute
        结果
        这个 ShapeGraphicAttribute的下降。
        另请参见：
        GraphicAttribute.getBounds()

      • getAdvance

        public float getAdvance​()
        返回此ShapeGraphicAttribute 。 一个ShapeGraphicAttribute是从它的Shape的起源到它的Shape的边界的Shape 。
        Specified by:
        getAdvance在 GraphicAttribute
        结果
        这个进步 ShapeGraphicAttribute 。
        另请参见：
        GraphicAttribute.getBounds()

      • draw

        public void draw​(Graphics2D graphics,
                 float x,
                 float y)
        在指定的位置渲染此 GraphicAttribute 。
        Specified by:
        draw在 GraphicAttribute
        参数
        graphics - 其中呈现图形的Graphics2D
        x - 呈现图形的用户空间X坐标
        y - 呈现图形的用户空间Y坐标

      • getBounds

        public Rectangle2D getBounds​()
        返回一个Rectangle2D ，其中包含由该ShapeGraphicAttribute绘制的相对于呈现位置的所有位。 图形可以超出它的起源，上升，下降或提前; 但是如果这样做，则该方法的实现应该指示图形的呈现位置。
        重写：
        getBounds在 GraphicAttribute
        结果
        一个 Rectangle2D ，它包含了由这个 ShapeGraphicAttribute呈现的所有位。

      • getOutline

        public Shape getOutline​(AffineTransform tx)
        返回一个Shape ，表示该区域ShapeGraphicAttribute呈现。 当请求TextLayout返回文本的大纲时使用。 （未变形）形状不得超出由getBounds返回的矩形界限getBounds 。
        重写：
        getOutline在 GraphicAttribute
        参数
        tx - 一个可选的AffineTransform适用于这个ShapeGraphicAttribute 。 这可以是null。
        结果
        Shape代表这种图形属性，适合于抚摸或填充。
        从以下版本开始：
        1.6

      • hashCode

        public int hashCode​()
        返回此 ShapeGraphicAttribute的哈希 ShapeGraphicAttribute 。
        重写：
        hashCode在 Object
        结果
        这个 ShapeGraphicAttribute的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object rhs)
        将此 ShapeGraphicAttribute与指定的 Object 。
        重写：
        equals在 Object
        参数
        rhs - 相对于 Object进行比较
        结果
        true如果这个ShapeGraphicAttribute等于rhs ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • equals

        public boolean equals​(ShapeGraphicAttribute rhs)
        将此 ShapeGraphicAttribute与指定的 ShapeGraphicAttribute 。
        参数
        rhs - ShapeGraphicAttribute比较平等
        结果
        true如果这个ShapeGraphicAttribute等于rhs ; 否则为false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class TextAttribute

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute
      • java.awt.font.TextAttribute
  • All Implemented Interfaces:
    Serializable

    public final class TextAttribute
extends AttributedCharacterIterator.Attribute
    TextAttribute类定义用于文本呈现的属性键和属性值。

    TextAttribute实例用作属性键中标识的属性Font ， TextLayout ， AttributedCharacterIterator ，和其它类处理文本属性。 此类中定义的其他常量可用作属性值。

    对于每个文本属性，文档提供：

    • 其价值的类型，
    • 相关的预定义常量，如果有的话
    • 如果属性不存在，则为默认效果
    • 有效值如果有限制
    • 对效果的描述。

    值

    • 属性的值必须始终是不可变的。
    • 在给定价值限制的情况下，该集合之外的任何值保留供将来使用; 该值将被视为默认值。
    • 值null被视为与默认值相同，并导致默认行为。
    • 如果该值不是正确的类型，该属性将被忽略。
    • 价值的身份并不重要，只有实际的价值。 例如， TextAttribute.WEIGHT_BOLD和Float.valueOf(2.0f)表示相同的WEIGHT 。
    • 属性类型的值Number （用于WEIGHT ， WIDTH ， POSTURE ， SIZE ， JUSTIFICATION和TRACKING ）可沿其自然的范围内变化，并且不限制于预定义的常量。 Number.floatValue()用于从Number获取实际值。
    • 为值WEIGHT ， WIDTH ，和POSTURE由系统，它可以选择“最近的可用”字体或使用其他技术来近似用户的请求内插。

    属性摘要

    Key, value type, principal constants, and default value behavior of all TextAttributes Key Value Type Principal Constants Default Value FAMILY String See Font DIALOG, DIALOG_INPUT,
    SERIF, SANS_SERIF, and MONOSPACED. "Default" (use platform default) WEIGHT Number WEIGHT_REGULAR, WEIGHT_BOLD WEIGHT_REGULAR WIDTH Number WIDTH_CONDENSED, WIDTH_REGULAR,
    WIDTH_EXTENDED WIDTH_REGULAR POSTURE Number POSTURE_REGULAR, POSTURE_OBLIQUE POSTURE_REGULAR SIZE Number none 12.0 TRANSFORM TransformAttribute See TransformAttribute IDENTITY TransformAttribute.IDENTITY SUPERSCRIPT Integer SUPERSCRIPT_SUPER, SUPERSCRIPT_SUB 0 (use the standard glyphs and metrics) FONT Font none null (do not override font resolution) CHAR_REPLACEMENT GraphicAttribute none null (draw text using font glyphs) FOREGROUND Paint none null (use current graphics paint) BACKGROUND Paint none null (do not render background) UNDERLINE Integer UNDERLINE_ON -1 (do not render underline) STRIKETHROUGH Boolean STRIKETHROUGH_ON false (do not render strikethrough) RUN_DIRECTION Boolean RUN_DIRECTION_LTR
    RUN_DIRECTION_RTL null (use Bidi standard default) BIDI_EMBEDDING Integer none 0 (use base line direction) JUSTIFICATION Number JUSTIFICATION_FULL JUSTIFICATION_FULL INPUT_METHOD_HIGHLIGHT InputMethodHighlight,
    Annotation (see class) null (do not apply input highlighting) INPUT_METHOD_UNDERLINE Integer UNDERLINE_LOW_ONE_PIXEL,
    UNDERLINE_LOW_TWO_PIXEL -1 (do not render underline) SWAP_COLORS Boolean SWAP_COLORS_ON false (do not swap colors) NUMERIC_SHAPING NumericShaper none null (do not shape digits) KERNING Integer KERNING_ON 0 (do not request kerning) LIGATURES Integer LIGATURES_ON 0 (do not form optional ligatures) TRACKING Number TRACKING_LOOSE, TRACKING_TIGHT 0 (do not add tracking)
    另请参见：
    Font ， TextLayout ， AttributedCharacterIterator ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static TextAttribute BACKGROUND
      用于渲染文本背景的绘画的属性键。
      static TextAttribute BIDI_EMBEDDING
      文本嵌入级别的属性键。
      static TextAttribute CHAR_REPLACEMENT
      用于用户定义的字形显示的属性键代替字符的字体标准字形。
      static TextAttribute FAMILY
      字体名称的属性键。
      static TextAttribute FONT
      用于提供用于呈现文本的字体的属性键。
      static TextAttribute FOREGROUND
      用于渲染文本的颜色的属性键。
      static TextAttribute INPUT_METHOD_HIGHLIGHT
      输入法高亮样式的属性键。
      static TextAttribute INPUT_METHOD_UNDERLINE
      输入法的属性键加下划线。
      static TextAttribute JUSTIFICATION
      段落的理由的属性关键。
      static Float JUSTIFICATION_FULL
      将线对齐为满请求宽度。
      static Float JUSTIFICATION_NONE
      不要让线路有道理。
      static TextAttribute KERNING
      要求字距调整的属性键。
      static Integer KERNING_ON
      请求标准字距。
      static TextAttribute LIGATURES
      启用可选连字的属性键。
      static Integer LIGATURES_ON
      请求标准可选连字。
      static TextAttribute NUMERIC_SHAPING
      将ASCII十进制数字转换为其他十进制范围的属性键。
      static TextAttribute POSTURE
      字体姿势的属性键。
      static Float POSTURE_OBLIQUE
      标准斜体姿势。
      static Float POSTURE_REGULAR
      标准姿势，直立。
      static TextAttribute RUN_DIRECTION
      行的运行方向的属性键。
      static Boolean RUN_DIRECTION_LTR
      从左到右的运行方向。
      static Boolean RUN_DIRECTION_RTL
      从右到左的运行方向。
      static TextAttribute SIZE
      字体大小的属性键。
      static TextAttribute STRIKETHROUGH
      删除线的属性键。
      static Boolean STRIKETHROUGH_ON
      一个删除线。
      static TextAttribute SUPERSCRIPT
      上标和下标的属性键。
      static Integer SUPERSCRIPT_SUB
      标准下标。
      static Integer SUPERSCRIPT_SUPER
      标准上标。
      static TextAttribute SWAP_COLORS
      用于交换前景和背景的属性键 Paints 。
      static Boolean SWAP_COLORS_ON
      交换前景和背景。
      static TextAttribute TRACKING
      属性键控制跟踪。
      static Float TRACKING_LOOSE
      执行松动跟踪。
      static Float TRACKING_TIGHT
      执行紧跟踪。
      static TextAttribute TRANSFORM
      用于转换字体的属性键。
      static TextAttribute UNDERLINE
      下划线的属性键。
      static Integer UNDERLINE_LOW_DASHED
      单像素虚线低下划线。
      static Integer UNDERLINE_LOW_DOTTED
      单像素点下划线。
      static Integer UNDERLINE_LOW_GRAY
      双像素灰色低下划线。
      static Integer UNDERLINE_LOW_ONE_PIXEL
      单像素固体低下划线。
      static Integer UNDERLINE_LOW_TWO_PIXEL
      双像素固体低下划线。
      static Integer UNDERLINE_ON
      标准下划线。
      static TextAttribute WEIGHT
      字体重量的属性键。
      static Float WEIGHT_BOLD
      标准大胆的体重。
      static Float WEIGHT_DEMIBOLD
      重量比中等重量比 WEIGHT_BOLD 。
      static Float WEIGHT_DEMILIGHT
      中间重量在 WEIGHT_LIGHT和 WEIGHT_STANDARD之间。
      static Float WEIGHT_EXTRA_LIGHT
      最轻的预定义重量。
      static Float WEIGHT_EXTRABOLD
      重量过重
      static Float WEIGHT_HEAVY
      重量比中度重 WEIGHT_BOLD 。
      static Float WEIGHT_LIGHT
      标准重量轻。
      static Float WEIGHT_MEDIUM
      中间重量在 WEIGHT_REGULAR和 WEIGHT_BOLD之间。
      static Float WEIGHT_REGULAR
      标准重量。
      static Float WEIGHT_SEMIBOLD
      中等重量比 WEIGHT_REGULAR 。
      static Float WEIGHT_ULTRABOLD
      最重的预定义重量。
      static TextAttribute WIDTH
      字体宽度的属性键。
      static Float WIDTH_CONDENSED
      最浓缩的预定宽度。
      static Float WIDTH_EXTENDED
      最大的预定宽度。
      static Float WIDTH_REGULAR
      标准宽度。
      static Float WIDTH_SEMI_CONDENSED
      中等浓度的宽度。
      static Float WIDTH_SEMI_EXTENDED
      中等宽度的宽度。

      • Fields inherited from class java.text.AttributedCharacterIterator.Attribute

        INPUT_METHOD_SEGMENT, LANGUAGE, READING

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected TextAttribute​(String name)
      构造具有指定名称的 TextAttribute 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object readResolve​()
      解析反序列化为预定义常量的实例。

      • Methods inherited from class java.text.AttributedCharacterIterator.Attribute

        equals, getName, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FAMILY

        public static final TextAttribute FAMILY
        字体名称的属性键。 值为String实例。 默认值为"Default" ，这将导致使用平台默认字体系列。

        所述Font类定义的逻辑字体名常量DIALOG ， DIALOG_INPUT ， SANS_SERIF ， SERIF ，和MONOSPACED 。

        这将将传递给name的值定义为Font构造函数。 逻辑和物理字体名称都是允许的。 如果未找到具有请求名称的字体，则使用默认字体。

        注意：这个属性不幸被命名，因为它指定了面部名称，而不仅仅是家庭。 因此，诸如“Lucida Sans Bold”这样的值将选择该面部存在。 但是，请注意，如果请求的脸部不存在，默认值将以常规权重使用。 名称中的“Bold”是脸部名称的一部分，而不是单独的请求，字体的重量是粗体。

      • WEIGHT

        public static final TextAttribute WEIGHT
        字体重量的属性键。 值为Number实例。 默认值为WEIGHT_REGULAR 。

        提供了几个常量值，见WEIGHT_EXTRA_LIGHT ， WEIGHT_LIGHT ， WEIGHT_DEMILIGHT ， WEIGHT_REGULAR ， WEIGHT_SEMIBOLD ， WEIGHT_MEDIUM ， WEIGHT_DEMIBOLD ， WEIGHT_BOLD ， WEIGHT_HEAVY ， WEIGHT_EXTRABOLD ，并WEIGHT_ULTRABOLD 。 值WEIGHT_BOLD对应于传递给Font构造函数的样式值Font.BOLD 。

        该值大致是杆宽与常规重量的比值。

        系统可以内插提供的值。

      • WEIGHT_EXTRA_LIGHT

        public static final Float WEIGHT_EXTRA_LIGHT
        最轻的预定义重量。
        另请参见：
        WEIGHT

      • WEIGHT_LIGHT

        public static final Float WEIGHT_LIGHT
        标准重量轻。
        另请参见：
        WEIGHT

      • WEIGHT_DEMILIGHT

        public static final Float WEIGHT_DEMILIGHT
        中间重量在 WEIGHT_LIGHT和 WEIGHT_STANDARD之间。
        另请参见：
        WEIGHT

      • WEIGHT_REGULAR

        public static final Float WEIGHT_REGULAR
        标准重量。 这是WEIGHT的默认值。
        另请参见：
        WEIGHT

      • WEIGHT_SEMIBOLD

        public static final Float WEIGHT_SEMIBOLD
        比 WEIGHT_REGULAR中等重。
        另请参见：
        WEIGHT

      • WEIGHT_MEDIUM

        public static final Float WEIGHT_MEDIUM
        中间重量在 WEIGHT_REGULAR和 WEIGHT_BOLD之间。
        另请参见：
        WEIGHT

      • WEIGHT_DEMIBOLD

        public static final Float WEIGHT_DEMIBOLD
        重量比中等重量比 WEIGHT_BOLD 。
        另请参见：
        WEIGHT

      • WEIGHT_BOLD

        public static final Float WEIGHT_BOLD
        标准大胆的体重。
        另请参见：
        WEIGHT

      • WEIGHT_HEAVY

        public static final Float WEIGHT_HEAVY
        比 WEIGHT_BOLD中等重。
        另请参见：
        WEIGHT

      • WEIGHT_EXTRABOLD

        public static final Float WEIGHT_EXTRABOLD
        重量过重
        另请参见：
        WEIGHT

      • WEIGHT_ULTRABOLD

        public static final Float WEIGHT_ULTRABOLD
        最重的预定义重量。
        另请参见：
        WEIGHT

      • WIDTH

        public static final TextAttribute WIDTH
        字体宽度的属性键。 值为Number实例。 默认值为WIDTH_REGULAR 。

        提供了几个常量值，见WIDTH_CONDENSED ， WIDTH_SEMI_CONDENSED ， WIDTH_REGULAR ， WIDTH_SEMI_EXTENDED ， WIDTH_EXTENDED 。

        该值大致是前进宽度与正常宽度的比率。

        系统可以内插提供的值。

      • WIDTH_CONDENSED

        public static final Float WIDTH_CONDENSED
        最浓缩的预定宽度。
        另请参见：
        WIDTH

      • WIDTH_SEMI_CONDENSED

        public static final Float WIDTH_SEMI_CONDENSED
        中等浓度的宽度。
        另请参见：
        WIDTH

      • WIDTH_REGULAR

        public static final Float WIDTH_REGULAR
        标准宽度。 这是WIDTH的默认值。
        另请参见：
        WIDTH

      • WIDTH_SEMI_EXTENDED

        public static final Float WIDTH_SEMI_EXTENDED
        中等宽度的宽度。
        另请参见：
        WIDTH

      • WIDTH_EXTENDED

        public static final Float WIDTH_EXTENDED
        最大的预定宽度。
        另请参见：
        WIDTH

      • POSTURE

        public static final TextAttribute POSTURE
        字体姿势的属性键。 值为Number实例。 默认值为POSTURE_REGULAR 。

        提供两个常数值， POSTURE_REGULAR和POSTURE_OBLIQUE 。 值POSTURE_OBLIQUE对应于传递给Font构造函数的样式值Font.ITALIC 。

        该值大体上是字体的斜率，表示为上升。 正值正确。

        系统可以内插提供的值。

        这将影响Font.getItalicAngle返回的字体的斜体角度。

        另请参见：
        Font.getItalicAngle()

      • POSTURE_REGULAR

        public static final Float POSTURE_REGULAR
        标准姿势，直立。 这是POSTURE的默认值。
        另请参见：
        POSTURE

      • POSTURE_OBLIQUE

        public static final Float POSTURE_OBLIQUE
        标准斜体姿势。
        另请参见：
        POSTURE

      • SIZE

        public static final TextAttribute SIZE
        字体大小的属性键。 值是Number实例。 默认值为12pt。

        这对应于Font构造函数的size参数。

        非常大或小的尺寸将影响渲染性能，并且渲染系统可能不会以这些尺寸呈现文本。 负大小是非法的，并导致默认大小。

        请注意，具有2x变换的12pt字体的外观和度量可能与不具有变换的24点字体的外观和度量不同。

      • TRANSFORM

        public static final TextAttribute TRANSFORM
        用于转换字体的属性键。 值是TransformAttribute实例。 默认值为TransformAttribute.IDENTITY 。

        TransformAttribute类定义了常量IDENTITY 。

        这对应于转换为Font.deriveFont(AffineTransform) 。 由于该变换是可变的，并且TextAttribute值不能为，因此使用TransformAttribute包装类。

        主要目的是支持缩放和倾斜，尽管其他效果也是可能的。

        一些变换将导致基线被旋转和/或移位。 将文本和基线一起转换，使文本符合新的基线。 例如，对于水平基线上的文本，新的基线遵循通过变换的单位x向量的方向。 文本度量是根据这个新的基线测量的。 所以，例如，在其他方面相同的情况下，用旋转的TRANSFORM和未旋转的TRANSFORM呈现的文本将被测量为具有相同的上升，下降和提前。

        在样式文本中，每个此类运行的基准一个接一个对齐，以便为整个文本运行创建一个非线性基线。 有关详细信息，请参阅TextLayout.getLayoutPath() 。

        另请参见：
        TransformAttribute ， AffineTransform

      • SUPERSCRIPT

        public static final TextAttribute SUPERSCRIPT
        上标和下标的属性键。 值为Integer实例。 默认值为0，这意味着不使用上标或下标。

        提供两个常数值，参见SUPERSCRIPT_SUPER和SUPERSCRIPT_SUB 。 这些值分别为1和-1。 更大幅度的数值定义了更高水平的上标或下标，例如，2对应于超上标3，超超上标，对于负值和下标也相似，高达7（或-7）的水平。 保留超出此范围的值; 行为依赖于平台。

        SUPERSCRIPT可以影响字体的上升和下降。 然而，上升和下降永远不会变成消极的。

      • SUPERSCRIPT_SUPER

        public static final Integer SUPERSCRIPT_SUPER
        标准上标。
        另请参见：
        SUPERSCRIPT

      • SUPERSCRIPT_SUB

        public static final Integer SUPERSCRIPT_SUB
        标准下标。
        另请参见：
        SUPERSCRIPT

      • FONT

        public static final TextAttribute FONT
        用于提供用于呈现文本的字体的属性键。 值为Font的实例。 默认值为null，表示应该执行属性的正常分辨率为Font 。

        TextLayout和AttributedCharacterIterator以Maps的TextAttributes 。 通常，所有属性都将被检查并用于选择和配置一个Font实例。 如果FONT属性存在，虽然其相关Font将被使用。 这为用户提供了将字体属性分辨率覆盖到Font ，或强制使用特定的Font实例。 这也允许用户指定的子类Font的情况下，一个Font可以被继承。

        FONT用于特殊情况，其中客户端已有Font实例，但仍需使用基于Map的API。 通常情况下，会有在没有其他属性Map除了FONT属性。 使用基于Map的API，常见的情况是单独指定所有属性，因此不需要或希望使用FONT 。

        但是，如果FONT和其他属性均存在于Map ，则绘制系统将将其中的属性合并在Font定义的属性。 此合并过程将TextAttributes分为两组。 一个组，“主要”组被认为是字体的选择和度量行为的基础。 这些属性是FAMILY ， WEIGHT ， WIDTH ， POSTURE ， SIZE ， TRANSFORM ， SUPERSCRIPT ，并TRACKING 。 另一组，“次要”组由所有其他定义的属性组成，但本身不包括FONT 。

        为了生成新的Map ，首先从Font获取FONT属性，并将其所有属性提取为新的Map 。 那么只有来自原始Map的辅助属性Map添加到新的Map 。 因此初级属性的值从所述单独来Font ，和次要属性的值与起源Font但是可以通过其他的值在被覆盖Map 。

        注意：基于Font's Map的构造函数和deriveFont方法不处理FONT属性，因为这些属性用于创建新的Font对象。 相反， Font.getFont(Map)应该用来处理FONT属性。

        另请参见：
        Font

      • CHAR_REPLACEMENT

        public static final TextAttribute CHAR_REPLACEMENT
        用于用户定义的字形显示的属性键代替字符的字体标准字形。 值是GraphicAttribute的实例。 默认值为null，表示应使用字体提供的标准字形。

        此属性用于为嵌入文本行的图形或其他组件保留空间。 当执行双向重新排序（见Bidi ）时，需要在线内部的“内联”组件进行正确定位。 将使用提供的GraphicAttribute呈现每个字符（Unicode代码点）。 通常，应用此属性的字符应为\uFFFC 。

        GraphicAttribute确定文本的逻辑和视觉边界; 实际的字体值将被忽略。

        另请参见：
        GraphicAttribute

      • FOREGROUND

        public static final TextAttribute FOREGROUND
        用于渲染文本的颜色的属性键。 值是Paint实例。 默认值为null，表示在渲染时使用Paint设置的Graphics2D 。

        无论Graphics （或参见SWAP_COLORS ）中设置的Paint值如何，将使用此Paint渲染字形。

        另请参见：
        Paint ， SWAP_COLORS

      • BACKGROUND

        public static final TextAttribute BACKGROUND
        用于渲染文本背景的绘画的属性键。 值是Paint实例。 默认值为null，表示不应呈现背景。

        文本的逻辑边界将使用此Paint填充，然后文本将在其上显示（但请参阅SWAP_COLORS ）。

        如果需要，文本的可视界限被扩展为包括逻辑边界。 大纲不受影响。

        另请参见：
        Paint ， SWAP_COLORS

      • UNDERLINE

        public static final TextAttribute UNDERLINE
        下划线的属性键。 值是Integer实例。 默认值为-1，表示没有下划线。

        提供常数值UNDERLINE_ON 。

        下划线影响文本的视觉界限和轮廓。

      • UNDERLINE_ON

        public static final Integer UNDERLINE_ON
        标准下划线。
        另请参见：
        UNDERLINE

      • STRIKETHROUGH

        public static final TextAttribute STRIKETHROUGH
        删除线的属性键。 值为Boolean实例。 默认值为false ，这意味着没有删除线。

        提供常数值STRIKETHROUGH_ON 。

        删除线影响文本的视觉界限和大纲。

      • STRIKETHROUGH_ON

        public static final Boolean STRIKETHROUGH_ON
        一个删除线。
        另请参见：
        STRIKETHROUGH

      • RUN_DIRECTION

        public static final TextAttribute RUN_DIRECTION
        行的运行方向的属性键。 值为Boolean实例。 默认值为null，表示用于确定运行方向的标准Bidi算法应与值Bidi.DIRECTION_DEFAULT_LEFT_TO_RIGHT一起使用。

        提供常数RUN_DIRECTION_RTL和RUN_DIRECTION_LTR 。

        这将确定传递给Bidi构造函数的值，以选择段落中文本的主要方向。

        注意：此属性对于段落中的所有文本应具有相同的值，否则行为未确定。

        另请参见：
        Bidi

      • RUN_DIRECTION_LTR

        public static final Boolean RUN_DIRECTION_LTR
        从左到右的运行方向。
        另请参见：
        RUN_DIRECTION

      • RUN_DIRECTION_RTL

        public static final Boolean RUN_DIRECTION_RTL
        从右到左的运行方向。
        另请参见：
        RUN_DIRECTION

      • BIDI_EMBEDDING

        public static final TextAttribute BIDI_EMBEDDING
        文本嵌入级别的属性键。 值是Integer实例。 默认值为null ，表示双向算法在没有明确嵌入的情况下运行。

        正值1到61是嵌入级别，负值-1到-61是覆盖级别。 值0表示使用基线方向。 这些级别在嵌入级别数组中传递给Bidi构造函数。

        注意：当此属性出现在段落中的任何位置时，段落中的任何Unicode双向控制字符（RLO，LRO，RLE，LRE和PDF）将被忽略，并且不存在此属性的文本的运行被视为它是存在的，值为0。

        另请参见：
        Bidi

      • JUSTIFICATION

        public static final TextAttribute JUSTIFICATION
        段落的理由的属性关键。 值为Number实例。 默认值为1，表示对齐应使用提供的全部宽度。 值固定在范围[0..1]。

        提供常数JUSTIFICATION_FULL和JUSTIFICATION_NONE 。

        指定在TextLayout请求对齐时使用的额外空间的分数。 例如，如果线是50点宽，并且被要求证明为70点，则0.75的值将用于占用剩余空间的四分之三或15点，使得所得到的线将为65点长度。

        注意：对于段落中的所有文本应该具有相同的值，否则行为是不确定的。

        另请参见：
        TextLayout.getJustifiedLayout(float)

      • JUSTIFICATION_FULL

        public static final Float JUSTIFICATION_FULL
        将线对齐为满请求宽度。 这是JUSTIFICATION的默认值。
        另请参见：
        JUSTIFICATION

      • JUSTIFICATION_NONE

        public static final Float JUSTIFICATION_NONE
        不要让线路有道理。
        另请参见：
        JUSTIFICATION

      • INPUT_METHOD_HIGHLIGHT

        public static final TextAttribute INPUT_METHOD_HIGHLIGHT
        输入法高亮样式的属性键。

        值为InputMethodHighlight或Annotation的实例。 默认值为null ，这意味着在渲染之前不应该应用输入法样式。

        如果具有相同的文本相邻的运行InputMethodHighlight需要单独呈现时， InputMethodHighlights应包裹在Annotation实例。

        当输入法正在组合文本时，使用输入法高亮。 文本编辑组件应该保留它们，即使它们通常仅处理未被写入的文本，并使它们可用于绘图例程。

        另请参见：
        Font ， InputMethodHighlight ， Annotation

      • INPUT_METHOD_UNDERLINE

        public static final TextAttribute INPUT_METHOD_UNDERLINE
        输入法的属性键加下划线。 值为Integer实例。 默认值为-1 ，这意味着没有下划线。

        提供了几个常量值，见UNDERLINE_LOW_ONE_PIXEL ， UNDERLINE_LOW_TWO_PIXEL ， UNDERLINE_LOW_DOTTED ， UNDERLINE_LOW_GRAY ，并UNDERLINE_LOW_DASHED 。

        如果需要，可以与UNDERLINE结合使用。 主要目的是使用输入法。 其他使用这些下划线的简单装饰可能会使用户混淆。

        输入法下划线影响文本的视觉界限和轮廓。

        从以下版本开始：
        1.3

      • UNDERLINE_LOW_ONE_PIXEL

        public static final Integer UNDERLINE_LOW_ONE_PIXEL
        单像素固体低下划线。
        从以下版本开始：
        1.3
        另请参见：
        INPUT_METHOD_UNDERLINE

      • UNDERLINE_LOW_TWO_PIXEL

        public static final Integer UNDERLINE_LOW_TWO_PIXEL
        双像素固体低下划线。
        从以下版本开始：
        1.3
        另请参见：
        INPUT_METHOD_UNDERLINE

      • UNDERLINE_LOW_DOTTED

        public static final Integer UNDERLINE_LOW_DOTTED
        单像素点下划线。
        从以下版本开始：
        1.3
        另请参见：
        INPUT_METHOD_UNDERLINE

      • UNDERLINE_LOW_GRAY

        public static final Integer UNDERLINE_LOW_GRAY
        双像素灰色低下划线。
        从以下版本开始：
        1.3
        另请参见：
        INPUT_METHOD_UNDERLINE

      • UNDERLINE_LOW_DASHED

        public static final Integer UNDERLINE_LOW_DASHED
        单像素虚线低下划线。
        从以下版本开始：
        1.3
        另请参见：
        INPUT_METHOD_UNDERLINE

      • SWAP_COLORS

        public static final TextAttribute SWAP_COLORS
        用于交换前景和背景的属性键Paints 。 值为Boolean实例。 默认值为false ，这意味着不要交换颜色。

        定义常数值SWAP_COLORS_ON 。

        如果设置了FOREGROUND属性，则其Paint将被用作背景，否则将使用Paint当前的Graphics 。 如果设置了BACKGROUND属性，则其Paint将被用作前台，否则系统将会找到与（已解析）背景的对比色，以使文本可见。

        另请参见：
        FOREGROUND ， BACKGROUND

      • SWAP_COLORS_ON

        public static final Boolean SWAP_COLORS_ON
        交换前景和背景。
        从以下版本开始：
        1.3
        另请参见：
        SWAP_COLORS

      • NUMERIC_SHAPING

        public static final TextAttribute NUMERIC_SHAPING
        将ASCII十进制数字转换为其他十进制范围的属性键。 值是NumericShaper的实例。 默认值为null ，这意味着不执行数字整形。

        当定义数字整形器时，文本首先由整形器处理，然后执行文本的任何其他分析。

        注意：对于段落中的所有文本应该具有相同的值，否则行为是不确定的。

        从以下版本开始：
        1.4
        另请参见：
        NumericShaper

      • KERNING

        public static final TextAttribute KERNING
        要求字距调整的属性键。 值为Integer实例。 默认值为0 ，不要求字距调整。

        提供常数值KERNING_ON 。

        单个字符的默认进度不适用于某些字符序列，例如“To”或“AWAY”。 没有字距，相邻的字符似乎被太多的空间分开。 字距会导致所选择的字符序列间隔不同以获得更令人愉悦的视觉外观。

        从以下版本开始：
        1.6

      • KERNING_ON

        public static final Integer KERNING_ON
        请求标准字距。
        从以下版本开始：
        1.6
        另请参见：
        KERNING

      • LIGATURES

        public static final TextAttribute LIGATURES
        启用可选连字的属性键。 值为Integer实例。 默认值为0 ，这意味着不要使用可选连字。

        定义常数值LIGATURES_ON 。

        始终启用写入系统所需的联结。

        从以下版本开始：
        1.6

      • LIGATURES_ON

        public static final Integer LIGATURES_ON
        请求标准可选连字。
        从以下版本开始：
        1.6
        另请参见：
        LIGATURES

      • TRACKING

        public static final TextAttribute TRACKING
        属性键控制跟踪。 值为Number实例。 默认值为0 ，这意味着没有额外的跟踪。

        提供常数值TRACKING_TIGHT和TRACKING_LOOSE 。

        跟踪值乘以字体点大小，并通过字体转换，以确定添加到每个字形集群的前进的附加数量。 正的跟踪值将抑制可选结扎的形成。 跟踪值通常在-0.1和0.3之间; 超出该范围的值通常是不期望的。

        从以下版本开始：
        1.6

      • TRACKING_TIGHT

        public static final Float TRACKING_TIGHT
        执行紧跟踪。
        从以下版本开始：
        1.6
        另请参见：
        TRACKING

      • TRACKING_LOOSE

        public static final Float TRACKING_LOOSE
        执行松动跟踪。
        从以下版本开始：
        1.6
        另请参见：
        TRACKING

    • 构造方法详细信息

      • TextAttribute

        protected TextAttribute​(String name)
        构造具有指定名称的 TextAttribute 。
        参数
        name - 要分配给此 TextAttribute的属性名称

    • 方法详细信息

      • readResolve

        protected Object readResolve​()
                      throws InvalidObjectException
        解析反序列化为预定义常量的实例。
        重写：
        readResolve在 AttributedCharacterIterator.Attribute
        结果
        解决了 Attribute对象
        异常
        InvalidObjectException - 如果要解析的对象不是 Attribute的实例
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextHitInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class TextHitInfo

  • java.lang.Object
    • java.awt.font.TextHitInfo

  • public final class TextHitInfo
extends Object
    TextHitInfo类表示文本模型中的字符位置，以及字符的偏差或“侧”。 偏差是前导 （左边缘，从左到右的字符）或尾随 （右边缘，从左到右的字符）。 TextHitInfo实例用于指定文本中的插入和插入位置。

    例如，考虑文本“abc”。 TextHitInfo.trailing（1）对应于文本中“b”的右侧。

    TextHitInfo主要由TextLayout和TextLayout的客户端TextLayout 。 客户端TextLayout查询TextHitInfo插入偏移的实例，其中新文本插入到文本模型中。 插入偏移量等于TextHitInfo的偏移量为前导的字符位置，如果偏移量为后置，则为一个字符。 TextHitInfo.trailing（1）的插入偏移量为2。

    有时是很方便的构建TextHitInfo具有相同的插入作为现有的偏移，但在相对的字符。 getOtherHit方法构造一个具有与现有插入偏移相同的插入偏移的新的TextHitInfo ，并且插入偏移的另一侧上的字符被击中。 尾随（1）调用getOtherHit将返回前导（2）。 一般来说， getOtherHit对于尾（n）返回领先（n + 1），而getOtherHit用于领先（n）返回尾部（n-1）。

    示例 ：

    将图形点转换为文本模型中的插入点

     TextLayout layout = ...;
 Point2D.Float hitPoint = ...;
 TextHitInfo hitInfo = layout.hitTestChar(hitPoint.x, hitPoint.y);
 int insPoint = hitInfo.getInsertionIndex();
 // insPoint is relative to layout;  may need to adjust for use
 // in a text model
    另请参见：
    TextLayout

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static TextHitInfo afterOffset​(int offset)
      以指定的偏移量创建 TextHitInfo ，与偏移后的字符相关联。
      static TextHitInfo beforeOffset​(int offset)
      以指定的偏移量创建 TextHitInfo ，与偏移量之前的字符相关联。
      boolean equals​(TextHitInfo hitInfo)
      返回 true如果指定 TextHitInfo具有相同 charIndex和 isLeadingEdge ，因为这 TextHitInfo 。
      boolean equals​(Object obj)
      返回 true如果指定 Object是 TextHitInfo ，等于这个 TextHitInfo 。
      int getCharIndex​()
      返回字符命中的索引。
      int getInsertionIndex​()
      返回插入索引。
      TextHitInfo getOffsetHit​(int delta)
      创建 TextHitInfo其字符索引由偏移 delta从 charIndex此的 TextHitInfo 。
      TextHitInfo getOtherHit​()
      在插入点的另一边创建一个 TextHitInfo 。
      int hashCode​()
      返回哈希码。
      boolean isLeadingEdge​()
      如果角色的前沿被击中，则返回 true 。
      static TextHitInfo leading​(int charIndex)
      在指定的 charIndex的字符 TextHitInfo创建一个 charIndex 。
      String toString​()
      返回一个 String表示仅用于调试的命中。
      static TextHitInfo trailing​(int charIndex)
      在指定的 charIndex处创建字符后端的命中。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getCharIndex

        public int getCharIndex​()
        返回字符命中的索引。
        结果
        角色命中的索引。

      • isLeadingEdge

        public boolean isLeadingEdge​()
        如果角色的前沿被击中，则返回 true 。
        结果
        true如果角色的前缘被击中; 否则为false 。

      • getInsertionIndex

        public int getInsertionIndex​()
        返回插入索引。 如果字符的前沿被命中，则这是字符索引，如果后缘被命中，则它大于字符索引。
        结果
        插入索引。

      • hashCode

        public int hashCode​()
        返回哈希码。
        重写：
        hashCode在 Object
        结果
        这个 TextHitInfo的哈希码，这也是 charIndex的 TextHitInfo 。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        返回 true如果指定 Object是 TextHitInfo ，等于这个 TextHitInfo 。
        重写：
        equals在 Object
        参数
        obj - Object测试平等
        结果
        true如果指定的Object等于这个TextHitInfo ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • equals

        public boolean equals​(TextHitInfo hitInfo)
        返回true如果指定TextHitInfo具有相同charIndex和isLeadingEdge ，因为这TextHitInfo 。 这与插入偏移量相同。
        参数
        hitInfo - 一个指定的 TextHitInfo
        结果
        true如果指定的 TextHitInfo具有相同的 charIndex和 isLeadingEdge作为这 TextHitInfo 。

      • toString

        public String toString​()
        返回一个 String表示仅用于调试的命中。
        重写：
        toString在 Object
        结果
        一个 String代表这 TextHitInfo 。

      • leading

        public static TextHitInfo leading​(int charIndex)
        创建 TextHitInfo上的字符在指定的前沿 charIndex 。
        参数
        charIndex - 字符命中的索引
        结果
        一个 TextHitInfo在 TextHitInfo的字符在指定的 charIndex 。

      • trailing

        public static TextHitInfo trailing​(int charIndex)
        在指定的 charIndex字符的后端创建一个命中。
        参数
        charIndex - 字符命中的索引
        结果
        一个 TextHitInfo在字符的后端在指定的 charIndex 。

      • beforeOffset

        public static TextHitInfo beforeOffset​(int offset)
        以指定的偏移量创建 TextHitInfo ，与偏移量之前的字符相关联。
        参数
        offset - 与偏移之前的字符相关联的偏移量
        结果
        一个 TextHitInfo在指定的偏移量。

      • afterOffset

        public static TextHitInfo afterOffset​(int offset)
        以指定的偏移量创建 TextHitInfo ，与偏移后的字符相关联。
        参数
        offset - 与偏移后的字符相关联的偏移量
        结果
        一个 TextHitInfo在指定的偏移量。

      • getOtherHit

        public TextHitInfo getOtherHit​()
        在插入点的另一侧创建一个TextHitInfo 。 这TextHitInfo保持不变。
        结果
        一个 TextHitInfo在插入点的另一边。

      • getOffsetHit

        public TextHitInfo getOffsetHit​(int delta)
        创建TextHitInfo其字符索引由偏移delta从charIndex此的TextHitInfo 。 这TextHitInfo保持不变。
        参数
        delta - 要抵消的价值 charIndex
        结果
        一个 TextHitInfo ，其 charIndex被抵消 delta从 charIndex如此 TextHitInfo 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class TextLayout

  • java.lang.Object
    • java.awt.font.TextLayout
  • All Implemented Interfaces:
    Cloneable

    public final class TextLayout
extends Object
implements Cloneable
    TextLayout是风格字符数据的不可变图形表示。

    它提供以下功能：

    • 隐式双向分析和重新排序，
    • 光标定位和移动，包括用于混合方向文本的分割光标，
    • 突出显示，包括混合方向文本的逻辑和视觉突出显示，
    • 多个基线（罗马，挂起和居中），
    • 打测试，
    • 理由，
    • 默认字体替换，
    • 诸如上升，下降和提前的度量信息，以及
    • 翻译

    A TextLayout对象可以使用其draw方法呈现。

    TextLayout可以构造直接或通过使用一个的LineBreakMeasurer 。 直接构建时，源文本代表一个段落。 LineBreakMeasurer允许将样式文本分解成适合特定宽度的行。 有关详细信息，请参阅LineBreakMeasurer文档。

    TextLayout建设逻辑上如下：

    • 段落属性被提取和检查，
    • 文本被分析用于双向重新排序，并且如果需要则重新排序信息被计算，
    • 文本被分割成样式运行
    • 为样式运行选择字体，首先如果属性TextAttribute.FONT存在，则使用字体，否则通过使用已定义的属性计算默认字体
    • 如果文本在多个基准上，则运行或子文件进一步分解为共享一个共同基准的子目录，
    • 使用所选择的字体为每次运行生成glyphvectors，
    • 对glyphvectors执行最终双向重排序

    从TextLayout对象的方法返回的所有图形信息都相对于TextLayout的原点，这是TextLayout对象的基线与其左边缘的交集。 另外，假定传递给TextLayout对象的方法的坐标是相对于TextLayout对象的来源。 客户通常需要在TextLayout对象的坐标系和另一个对象（如Graphics对象）中的坐标系之间进行转换。

    TextLayout对象由样式文本构造，但它们不保留对其源文本的引用。 因此，以前用于生成TextLayout的文本的更改不会影响TextLayout 。

    一对三种方法TextLayout对象（ getNextRightHit ， getNextLeftHit ，并hitTestChar ）返回的实例TextHitInfo 。 这些TextHitInfo对象中包含的偏移量相对于TextLayout ， 而不是用于创建TextLayout的文本。 类似地，接受TextHitInfo实例作为参数的TextLayout方法期望TextHitInfo对象的偏移量相对于TextLayout ，而不是任何基础文本存储模型。

    示例 ：

    构造和绘制一个TextLayout及其边界矩形：

       Graphics2D g = ...;
   Point2D loc = ...;
   Font font = Font.getFont("Helvetica-bold-italic");
   FontRenderContext frc = g.getFontRenderContext();
   TextLayout layout = new TextLayout("This is a string", font, frc);
   layout.draw(g, (float)loc.getX(), (float)loc.getY());

   Rectangle2D bounds = layout.getBounds();
   bounds.setRect(bounds.getX()+loc.getX(),
                  bounds.getY()+loc.getY(),
                  bounds.getWidth(),
                  bounds.getHeight());
   g.draw(bounds);

    命中测试TextLayout （确定哪个字符在特定图形位置）：

       Point2D click = ...;
   TextHitInfo hit = layout.hitTestChar(
                         (float) (click.getX() - loc.getX()),
                         (float) (click.getY() - loc.getY()));

    按右箭头按键：

       int insertionIndex = ...;
   TextHitInfo next = layout.getNextRightHit(insertionIndex);
   if (next != null) {
       // translate graphics to origin of layout on screen
       g.translate(loc.getX(), loc.getY());
       Shape[] carets = layout.getCaretShapes(next.getInsertionIndex());
       g.draw(carets[0]);
       if (carets[1] != null) {
           g.draw(carets[1]);
       }
   }

    绘制对应于源文本中的子字符串的选择范围。 所选区域可能不是视觉上连续的：

       // selStart, selLimit should be relative to the layout,
   // not to the source text

   int selStart = ..., selLimit = ...;
   Color selectionColor = ...;
   Shape selection = layout.getLogicalHighlightShape(selStart, selLimit);
   // selection may consist of disjoint areas
   // graphics is assumed to be translated to origin of layout
   g.setColor(selectionColor);
   g.fill(selection);

    绘制视觉上连续的选择范围。 选择范围可以对应于源文本中的多个子字符串。 可以使用getLogicalRangesForVisualSelection()获取相应源文本子串的范围：

       TextHitInfo selStart = ..., selLimit = ...;
   Shape selection = layout.getVisualHighlightShape(selStart, selLimit);
   g.setColor(selectionColor);
   g.fill(selection);
   int[] ranges = getLogicalRangesForVisualSelection(selStart, selLimit);
   // ranges[0], ranges[1] is the first selection range,
   // ranges[2], ranges[3] is the second selection range, etc.

    注意：字体旋转可以使文本基线旋转，多次运行不同的旋转可能导致基线弯曲或曲折。 为了解决这个（罕见的）可能性，指定了一些API返回度量值并在“基线相对坐标”（例如，上升，前进）中获取参数，而其他API在“标准坐标”（例如getBounds）中。 基线相对坐标中的值将“x”坐标映射到沿着基线的距离（正x沿着基线向前），“y”坐标与“x”处垂直于基线的距离y从基线矢量顺时针旋转90度）。 沿着x轴和y轴测量标准坐标值，在TextLayout的原点为0,0。 每个相关API的文档指示什么值在什么坐标系中。 通常，与测量相关的API处于基准相对坐标，而与显示相关的API处于标准坐标。

    另请参见：
    LineBreakMeasurer ， TextAttribute ， TextHitInfo ， LayoutPath

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  TextLayout.CaretPolicy
      定义确定强插插位置的策略。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static TextLayout.CaretPolicy DEFAULT_CARET_POLICY
      当客户端未指定策略时，将使用此 CaretPolicy 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextLayout​(String string, Font font, FontRenderContext frc)
      构造一个TextLayout从String和Font 。
      TextLayout​(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
      从一个 String和一个属性集构造一个 TextLayout 。
      TextLayout​(AttributedCharacterIterator text, FontRenderContext frc)
      从样式文本的迭代器构造一个 TextLayout 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object clone​()
      创建一个这个 TextLayout的副本。
      void draw​(Graphics2D g2, float x, float y)
      在指定的Graphics2D上下文中的指定位置渲染此TextLayout 。
      boolean equals​(TextLayout rhs)
      如果两个布局相等，则返回 true 。
      float getAdvance​()
      返回此 TextLayout 。
      float getAscent​()
      返回此 TextLayout的上升。
      byte getBaseline​()
      返回此 TextLayout的基准。
      float[] getBaselineOffsets​()
      返回用于此 TextLayout的基线的偏移数组。
      Shape getBlackBoxBounds​(int firstEndpoint, int secondEndpoint)
      返回指定范围内的字符的黑框边界。
      Rectangle2D getBounds​()
      返回此 TextLayout的边界。
      float[] getCaretInfo​(TextHitInfo hit)
      返回与 hit相对应的插入符的信息。
      float[] getCaretInfo​(TextHitInfo hit, Rectangle2D bounds)
      返回与 hit对应的插入符的信息。
      Shape getCaretShape​(TextHitInfo hit)
      返回一个 Shape代表这个 TextLayout的自然界限内的指定点的插入符号。
      Shape getCaretShape​(TextHitInfo hit, Rectangle2D bounds)
      返回一个Shape，表示指定边界内指定点的插入符号。
      Shape[] getCaretShapes​(int offset)
      返回对应于强和弱插入符号的两个路径。
      Shape[] getCaretShapes​(int offset, Rectangle2D bounds)
      返回对应于强和弱插入符号的两个路径。
      Shape[] getCaretShapes​(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy)
      返回对应于强和弱插入符号的两个路径。
      int getCharacterCount​()
      返回此 TextLayout代表的字符数。
      byte getCharacterLevel​(int index)
      返回字符的级别为 index 。
      float getDescent​()
      返回此 TextLayout的下降。
      TextLayout getJustifiedLayout​(float justificationWidth)
      创建一个 TextLayout对齐到指定宽度的副本。
      LayoutPath getLayoutPath​()
      返回LayoutPath，如果布局路径是默认路径，则为null（x映射到advance，y映射到offset）。
      float getLeading​()
      返回领先的 TextLayout 。
      Shape getLogicalHighlightShape​(int firstEndpoint, int secondEndpoint)
      返回一个 Shape将逻辑选择包围在指定的范围内，扩展到这个 TextLayout 。
      Shape getLogicalHighlightShape​(int firstEndpoint, int secondEndpoint, Rectangle2D bounds)
      返回一个 Shape将逻辑选择包含在指定的范围内，扩展到指定的 bounds 。
      int[] getLogicalRangesForVisualSelection​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint)
      返回与视觉选择对应的文本的逻辑范围。
      TextHitInfo getNextLeftHit​(int offset)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo getNextLeftHit​(int offset, TextLayout.CaretPolicy policy)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo getNextLeftHit​(TextHitInfo hit)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo getNextRightHit​(int offset)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo getNextRightHit​(int offset, TextLayout.CaretPolicy policy)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo getNextRightHit​(TextHitInfo hit)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      Shape getOutline​(AffineTransform tx)
      返回一个表示 Shape的轮廓的 TextLayout 。
      Rectangle getPixelBounds​(FontRenderContext frc, float x, float y)
      在给定位置的给定 FontRenderContext的图形中渲染时，返回此 TextLayout的像素边界。
      float getVisibleAdvance​()
      返回这个 TextLayout ，减去尾随空格。
      Shape getVisualHighlightShape​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint)
      返回一个 Shape将可视选择包围在指定的范围内，扩展到边界。
      Shape getVisualHighlightShape​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds)
      返回包含指定范围内的视觉选择的路径，扩展为 bounds 。
      TextHitInfo getVisualOtherHit​(TextHitInfo hit)
      返回指定命中的插入符号对面的命中。
      protected void handleJustify​(float justificationWidth)
      证明这个布局。
      TextHitInfo hitTestChar​(float x, float y)
      返回对应于指定点的 TextHitInfo 。
      TextHitInfo hitTestChar​(float x, float y, Rectangle2D bounds)
      返回对应于指定点的 TextHitInfo 。
      void hitToPoint​(TextHitInfo hit, Point2D point)
      将命中转换为标准坐标中的一个点。
      boolean isLeftToRight​()
      如果 TextLayout具有从左到右的基本方向或 false如果它具有从右到左的基本方向），则返回 true 。
      boolean isVertical​()
      如果这个 TextLayout是垂直的，则返回 true 。
      String toString​()
      返回此 TextLayout调试信息。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DEFAULT_CARET_POLICY

        public static final TextLayout.CaretPolicy DEFAULT_CARET_POLICY
        当客户端未指定策略时，将使用此CaretPolicy 。 有了这个策略，对方向与线方向相同的角色的打击比反向角色的命中强。 如果角色的方向相同，则角色前缘的命中要强于角色后缘的命中。

    • 构造方法详细信息

      • TextLayout

        public TextLayout​(String string,
                  Font font,
                  FontRenderContext frc)
        构造一个TextLayout从String和Font 。 所有文本都使用指定的Font样式Font 。

        String必须指定单个文本段落，因为双向算法需要整个段落。

        参数
        string - 要显示的文字
        font - 一个 Font用于样式文本
        frc - 包含有关正确测量文本所需的图形设备的信息。 文本测量可能会根据设备分辨率和抗锯齿等属性略有不同。 此参数不指定TextLayout和用户空间之间的TextLayout 。

      • TextLayout

        public TextLayout​(String string,
                  Map<? extends AttributedCharacterIterator.Attribute,?> attributes,
                  FontRenderContext frc)
        从一个String和一个属性集构造一个TextLayout 。

        所有文本都使用提供的属性进行风格化。

        string必须指定单个文本段落，因为双向算法需要整个段落。

        参数
        string - 要显示的文本
        attributes - 用于对文本进行样式的属性
        frc - 包含有关正确测量文本所需的图形设备的信息。 文本测量可能会根据设备分辨率和抗锯齿等属性略有不同。 该参数不指定TextLayout与用户空间之间的TextLayout 。

      • TextLayout

        public TextLayout​(AttributedCharacterIterator text,
                  FontRenderContext frc)
        从样式文本的迭代器构造一个TextLayout 。

        迭代器必须指定单个文本段落，因为双向算法需要整个段落。

        参数
        text - 要显示的样式文本
        frc - 包含有关正确测量文本所需的图形设备的信息。 文本测量可能会根据设备分辨率和抗锯齿等属性略有不同。 此参数不指定TextLayout和用户空间之间的TextLayout 。

    • 方法详细信息

      • clone

        protected Object clone​()
        创建一个这个 TextLayout的副本。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • getJustifiedLayout

        public TextLayout getJustifiedLayout​(float justificationWidth)
        创建这个TextLayout的副本对齐到指定的宽度。

        如果这个TextLayout已经被证明是正当的，那么抛出异常。 如果此TextLayout对象的调整率为零，一个TextLayout相同此TextLayout被返回。

        参数
        justificationWidth - 调整justificationWidth使用的宽度。 为了获得最佳效果，它不应该与当前的进展情况有太大的不同。
        结果
        一个 TextLayout对齐到指定的宽度。
        异常
        Error - 如果这个布局已被证明是对的，那么会抛出一个错误。

      • handleJustify

        protected void handleJustify​(float justificationWidth)
        证明这个布局。 被子类别覆盖以控制对齐（如果有子类，那就是...）如果段落属性（源文本，可能由布局属性默认）表示非零对齐比，布局将只能证明。 文本将被对齐到指定的宽度。 当前的实现还会调整悬挂的标点符号和尾随空格以超出对齐宽度。 一旦有理由，布局可能不会被重新调整。

        一些代码可能依赖于布局的不变性。 子类不应该直接调用它，而应该调用getJustifiedLayout，这将在此布局的克隆上调用此方法，保留原始。

        参数
        justificationWidth - 调整justificationWidth使用的宽度。 为了获得最佳效果，它不应该与当前的进展情况有太大的不同。
        另请参见：
        getJustifiedLayout(float)

      • getBaseline

        public byte getBaseline​()
        返回此TextLayout的基准。 基线是Font定义的值之一，它们是罗马，中心和悬挂。 上升和下降是相对于这个基线。 baselineOffsets也相对于这个基线。
        结果
        这个 TextLayout的基线。
        另请参见：
        getBaselineOffsets() ， Font

      • getBaselineOffsets

        public float[] getBaselineOffsets​()
        返回用于此TextLayout的基线的offsets数组。

        该数组由Font定义的值之一Font ，它们是罗马，居中和悬挂。 这些值是相对于这个TextLayout对象的基线，所以getBaselineOffsets[getBaseline()] == 0 。 将偏移量添加到TextLayout对象的基线的位置以获取新基线的位置。

        结果
        该偏移数组包含用于此 TextLayout的基线。
        另请参见：
        getBaseline() ， Font

      • getAdvance

        public float getAdvance​()
        返回此TextLayout 。 提前是从原始到最右边（最下方）字符前进的距离。 这是在基线相对坐标。
        结果
        这个进步 TextLayout 。

      • getVisibleAdvance

        public float getVisibleAdvance​()
        返回这个TextLayout ，减去尾随空格。 这是在基线相对坐标。
        结果
        这个 TextLayout没有尾随的空格。
        另请参见：
        getAdvance()

      • getAscent

        public float getAscent​()
        返回此TextLayout的上升。 上升是从TextLayout的顶部（右）到基线的距离。 它始终为正或零。 上升足以容纳上标的文本，并且是每个字形的上升，偏移和基线的总和的最大值。 上升是TextLayout中所有文本基线的最大上升。 它在基线相对坐标。
        结果
        这个 TextLayout的上升。

      • getDescent

        public float getDescent​()
        返回此TextLayout的下降。 下降距离基线到TextLayout底部（左）的TextLayout 。 它始终为正或零。 下降足以适应下标文本，并且是每个字形的下降，偏移和基线之和的最大值。 这是TextLayout中所有文本基线的最大下降。 它在基线相对坐标。
        结果
        这个 TextLayout的下降。

      • getLeading

        public float getLeading​()
        返回TextLayout的领先TextLayout 。 领先的是这个TextLayout间距。 这是在基线相对坐标。

        领先是从所有glyphvectors的领先，下降和基线计算的TextLayout 。 算法大致如下：

         maxD = 0;
 maxDL = 0;
 for (GlyphVector g in all glyphvectors) {
    maxD = max(maxD, g.getDescent() + offsets[g.getBaseline()]);
    maxDL = max(maxDL, g.getDescent() + g.getLeading() +
                       offsets[g.getBaseline()]);
 }
 return maxDL - maxD;
        结果
        领先这 TextLayout 。

      • getBounds

        public Rectangle2D getBounds​()
        返回此TextLayout的边界。 边界是标准坐标。

        由于光栅化效果，此边界可能不会包含TextLayout渲染的所有像素。

        这可能与TextLayout的上升，下降，起源或进展TextLayout 。
        结果
        一个Rectangle2D这是这个TextLayout的界限。

      • getPixelBounds

        public Rectangle getPixelBounds​(FontRenderContext frc,
                                float x,
                                float y)
        在给定位置给定的FontRenderContext的图形中渲染时，返回此TextLayout的像素边界。 图形渲染方面不一定是一样的FontRenderContext用于创建此TextLayout ，并且可以为null。 如果为空，则FontRenderContext如此TextLayout使用。
        参数
        frc - FontRenderContext的 Graphics 。
        x - 要呈现这个 TextLayout的x坐标。
        y - 渲染此 TextLayout的y坐标。
        结果
        一个 Rectangle限制将受影响的像素。
        从以下版本开始：
        1.6
        另请参见：
        GlyphVector.getPixelBounds(java.awt.font.FontRenderContext, float, float)

      • isLeftToRight

        public boolean isLeftToRight​()
        如果这个TextLayout具有从左到右基本方向或false如果它具有从右到左的基本方向），则返回true 。 TextLayout具有从左到右（LTR）或从右到左（RTL）的基本方向。 基本方向与线上文本的实际方向无关，可能是LTR，RTL或混合。 从左到右的布局默认情况下应该向左摆放。 如果布局在选项卡上，则选项卡从左到右运行，以便逻辑上连续的布局从左到右定位。 RTL布局也是如此。 默认情况下，它们应该向左定位，并且选项卡从左到右运行。
        结果
        true如果这个TextLayout的基本方向是从左到右; 否则为false 。

      • isVertical

        public boolean isVertical​()
        如果 TextLayout是垂直的，则返回 true 。
        结果
        true如果这个TextLayout是垂直的; 否则为false 。

      • getCharacterCount

        public int getCharacterCount​()
        返回此 TextLayout代表的字符数。
        结果
        这个 TextLayout的字符数。

      • getCaretInfo

        public float[] getCaretInfo​(TextHitInfo hit,
                            Rectangle2D bounds)
        返回与hit对应的插入符的信息。 数组的第一个元素是插入符号与基线的交集，作为基线的距离。 数组的第二个元素是相对于该点基线测量的插入符号的倒数斜率（运行/上升）。

        此方法用于信息使用。 要显示getCaretShapes ，最好使用getCaretShapes 。

        参数
        hit - 在这个 TextLayout一个角色的 TextLayout
        bounds - 构建插入符号信息的界限。 边界在基线相对坐标。
        结果
        一个包含插入符位置和斜率的双元素数组。 返回的插入符号信息在基线相对坐标中。
        另请参见：
        getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy) ， Font.getItalicAngle()

      • getCaretInfo

        public float[] getCaretInfo​(TextHitInfo hit)
        返回与hit相对应的插入符的信息。 这种方法是一个方便的超载getCaretInfo并且使用这个TextLayout 。
        参数
        hit - 这个 TextLayout一个角色的 TextLayout
        结果
        关于与命中对应的插入符号的信息。 返回的插入符号信息在基线相对坐标中。

      • getNextRightHit

        public TextHitInfo getNextRightHit​(TextHitInfo hit)
        返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。 如果命中字符索引超出范围，则抛出IllegalArgumentException 。
        参数
        hit - 这个布局中的一个角色的命中
        结果
        一个命中，其插入符号出现在提供的命中的插入符号的右侧（底部）的下一个位置，或 null 。

      • getNextRightHit

        public TextHitInfo getNextRightHit​(int offset,
                                   TextLayout.CaretPolicy policy)
        返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。 按照指定的策略确定，指定的偏移量处于右侧的强插销符号。 返回的命中是指定策略确定的两个可能命中之一。
        参数
        offset - 此TextLayout偏移量。 不能小于0或大于TextLayout对象的字符数。
        policy - 用于选择强 policy符的策略
        结果
        一个命中，其插入符号出现在提供的命中的插入符号右侧（底部）的下一个位置，或 null 。

      • getNextRightHit

        public TextHitInfo getNextRightHit​(int offset)
        返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。 按照默认策略确定，指定偏移量处的右侧插入符号位于右侧。 返回的命中是由默认策略确定的两个可能的命中中更强的。
        参数
        offset - 此TextLayout偏移量。 不能小于0或大于TextLayout对象的字符数。
        结果
        一个命中，其插入符号出现在提供的命中的插入符号右侧（底部）的下一个位置，或 null 。

      • getNextLeftHit

        public TextHitInfo getNextLeftHit​(TextHitInfo hit)
        返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。 如果命中字符索引超出范围，则抛出一个IllegalArgumentException 。
        参数
        hit - 这个 TextLayout一个角色的 TextLayout 。
        结果
        一个命中，其插入符号出现在提供的命中的插入符号左侧（顶部）的下一个位置，或 null 。

      • getNextLeftHit

        public TextHitInfo getNextLeftHit​(int offset,
                                  TextLayout.CaretPolicy policy)
        返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。 击打位于指定偏移处的强插销符号的左侧，由指定的策略确定。 返回的命中是指定策略确定的两个可能命中之一。
        参数
        offset - 此TextLayout偏移量。 不能小于0或大于此TextLayout对象的字符数。
        policy - 用于选择强 policy符的策略
        结果
        一个命中，其插入符号出现在提供的命中的插入符号左侧（顶部）的下一个位置，或 null 。

      • getNextLeftHit

        public TextHitInfo getNextLeftHit​(int offset)
        返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。 击打位于指定偏移量的强插销符号左侧，由默认策略确定。 返回的命中是由默认策略确定的两个可能的命中中更强的。
        参数
        offset - 此TextLayout偏移量。 不能小于0或大于此TextLayout对象的字符数。
        结果
        一个命中，其插入符号出现在提供的命中的插入符号左侧（顶部）的下一个位置，或 null 。

      • getVisualOtherHit

        public TextHitInfo getVisualOtherHit​(TextHitInfo hit)
        返回指定命中的插入符号对面的命中。
        参数
        hit - 指定的命中
        结果
        在指定的命中的插入符号的对面的一个打击。

      • getCaretShape

        public Shape getCaretShape​(TextHitInfo hit,
                           Rectangle2D bounds)
        返回一个Shape，表示指定边界内指定点的插入符号。
        参数
        hit - 生成插入符号的命中
        bounds - 用于生成插入符号的TextLayout的范围。 边界在基线相对坐标。
        结果
        一个Shape代表插入符号。 返回的形状是标准坐标。

      • getCaretShape

        public Shape getCaretShape​(TextHitInfo hit)
        返回 Shape代表在指定的打这个的自然边界中插入符号 TextLayout 。
        参数
        hit - 生成插入符号的命中
        结果
        一个Shape代表插入符号。 返回的形状是标准坐标。

      • getCharacterLevel

        public byte getCharacterLevel​(int index)
        返回字符的级别为index 。 指数-1和characterCount被分配到该TextLayout的基准水平。
        参数
        index - 从中获取级别的角色的索引
        结果
        在指定索引处的字符级别。

      • getCaretShapes

        public Shape[] getCaretShapes​(int offset,
                              Rectangle2D bounds,
                              TextLayout.CaretPolicy policy)
        返回对应于强和弱插入符号的两个路径。
        参数
        offset - 这个 TextLayout一个补偿
        bounds - 扩展bounds的范围。 边界在基线相对坐标。
        policy - 指定的 CaretPolicy
        结果
        两个路径的数组。 元素零是强插支符号。 如果有两个插入符号，元素是弱插入符，否则为null 。 返回的形状是标准坐标。

      • getCaretShapes

        public Shape[] getCaretShapes​(int offset,
                              Rectangle2D bounds)
        返回对应于强和弱插入符号的两个路径。 此方法是使用默认脱字符策略的方便重载getCaretShapes 。
        参数
        offset - 在这个 TextLayout一个抵消
        bounds - 扩展bounds的界限。 这是在基线相对坐标。
        结果
        对应于DEFAULT_CARET_POLICY定义的强和弱插入符号的两个路径。 这些是标准坐标。

      • getCaretShapes

        public Shape[] getCaretShapes​(int offset)
        返回对应于强和弱插入符号的两个路径。 这种方法是一个方便的超负荷getCaretShapes ，它使用默认的插入符号策略和这个TextLayout对象的自然界限。
        参数
        offset - 在这个 TextLayout一个偏移量
        结果
        对应于由DEFAULT_CARET_POLICY定义的强和弱插入符号的两个路径。 这些是标准坐标。

      • getLogicalRangesForVisualSelection

        public int[] getLogicalRangesForVisualSelection​(TextHitInfo firstEndpoint,
                                                TextHitInfo secondEndpoint)
        返回与视觉选择对应的文本的逻辑范围。
        参数
        firstEndpoint - 视觉范围的终点
        secondEndpoint - 视觉范围的另一端点。 该端点可以小于firstEndpoint 。
        结果
        一组整数，表示所选范围的起始/极限对。
        另请参见：
        getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D)

      • getVisualHighlightShape

        public Shape getVisualHighlightShape​(TextHitInfo firstEndpoint,
                                     TextHitInfo secondEndpoint,
                                     Rectangle2D bounds)
        返回包含指定范围内的视觉选择的路径，扩展为bounds 。

        如果选择包括最左边（最上面）位置，则选择将扩展到bounds的左侧（顶部）。 如果选择包括最右边（最下）位置，则选择将扩展到边界的右侧（底部）。 选择的高度（垂直线宽度）始终扩展为bounds 。

        虽然选择始终是连续的，但逻辑选择的文本在具有混合方向文本的行上可能是不连续的。 可以使用getLogicalRangesForVisualSelection检索所选文本的逻辑范围。 例如，考虑文本“ABCdef”，大写字母表示从右到左的文本，从右到左的行显示，从0L的视觉选择（“A”的前沿）到3T（尾随'd'的边缘）。 文本显示如下，粗体下划线区域表示选择：

          defCBA
        逻辑选择范围为0-3,4-6（ABC，ef），因为视觉上连续的文本在逻辑上是不连续的。 另请注意，由于布局上的最右边的位置（在'A'的右边）被选中，所以选择被扩展到边界的右边。
        参数
        firstEndpoint - 视觉选择的一端
        secondEndpoint - 视觉选择的另一端
        bounds - 扩展选择的边界矩形。 这是在基线相对坐标。
        结果
        一个Shape封闭选择。 这是在标准坐标。
        另请参见：
        getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo) ， getLogicalHighlightShape(int, int, Rectangle2D)

      • getVisualHighlightShape

        public Shape getVisualHighlightShape​(TextHitInfo firstEndpoint,
                                     TextHitInfo secondEndpoint)
        返回一个Shape将视觉选择包围在指定的范围内，扩展到边界。 这种方法是使用getVisualHighlightShape的自然界限的TextLayout的方便超载。
        参数
        firstEndpoint - 视觉选择的一端
        secondEndpoint - 视觉选择的另一端
        结果
        一个Shape封闭选择。 这是在标准坐标。

      • getLogicalHighlightShape

        public Shape getLogicalHighlightShape​(int firstEndpoint,
                                      int secondEndpoint,
                                      Rectangle2D bounds)
        返回一个包含在指定范围内的逻辑选择的Shape ，扩展到指定的bounds 。

        如果选择范围包括所述第一逻辑字符，则选择被扩展到的所述部分bounds此开始前TextLayout 。 如果该范围包括最后的逻辑字符，选择被扩展到的所述部分bounds此结束后TextLayout 。 选择的高度（垂直线上的宽度）始终扩展为bounds 。

        在具有混合方向文本的行上，选择可以是不连续的。 只有开始和关闭之间逻辑范围内的这些字符才会显示出来。 例如，考虑文本“ABCdef”，其中大写字母表示从右到左的文本，以从右到左的行显示，逻辑选择从0到4（“ABCd”）。 文字显示如下，粗体字用于选择，下划线为扩展名：

          defCBA
        选择是不连续的，因为所选择的字符在视觉上是不连续的。 另请注意，由于范围包括第一个逻辑字符（A），所以选择扩展到布局开始之前的bounds部分，在这种情况下（从右到左）是右侧部分bounds 。
        参数
        firstEndpoint - 要选择的字符范围内的端点
        secondEndpoint - 要选择的字符范围的另一个端点。 可以小于firstEndpoint 。 范围包括min（firstEndpoint，secondEndpoint）的字符，但不包括max（firstEndpoint，secondEndpoint）。
        bounds - 扩展选择的边界矩形。 这是在基线相对坐标。
        结果
        包围选区的区域。 这是在标准坐标。
        另请参见：
        getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D)

      • getLogicalHighlightShape

        public Shape getLogicalHighlightShape​(int firstEndpoint,
                                      int secondEndpoint)
        返回一个包含在指定范围内的逻辑选择的Shape ，扩展到此TextLayout 。 这种方法是一个方便的超载getLogicalHighlightShape ，它使用这个TextLayout的自然界限。
        参数
        firstEndpoint - 要选择的字符范围内的端点
        secondEndpoint - 要选择的字符范围的另一个端点。 可以小于firstEndpoint 。 范围包括min（firstEndpoint，secondEndpoint）的字符，但不包括max（firstEndpoint，secondEndpoint）。
        结果
        一个Shape封闭选择。 这是在标准坐标。

      • getBlackBoxBounds

        public Shape getBlackBoxBounds​(int firstEndpoint,
                               int secondEndpoint)
        返回指定范围内的字符的黑框边界。 黑框边界是由对应于开始和限制之间的字符的所有字形的边界框的并集组成的区域。 这个区域可以是不相交的。
        参数
        firstEndpoint - 字符范围的一端
        secondEndpoint - 字符范围的另一端。 可以小于firstEndpoint 。
        结果
        一个封闭黑盒边界的Shape 。 这是在标准坐标。

      • hitTestChar

        public TextHitInfo hitTestChar​(float x,
                               float y,
                               Rectangle2D bounds)
        返回与指定点对应的TextHitInfo 。 在TextLayout映射的边界之外的坐标在第一个逻辑字符的前沿或适合的最后一个逻辑字符的后沿，无论该字符在行中的位置如何。 只有沿着基准线的方向才被用来做这个评估。
        参数
        x - 这个来自这个TextLayout的x偏移量。 这是在标准坐标。
        y - 从这个TextLayout的起点的y偏移。 这是在标准坐标。
        bounds -的的界限TextLayout 。 这是在基线相对坐标。
        结果
        描述指定点下的字符和边缘（前导或尾部）的命中。

      • hitTestChar

        public TextHitInfo hitTestChar​(float x,
                               float y)
        返回对应于指定点的TextHitInfo 。 这种方法是一个方便的超载hitTestChar ，它使用这个TextLayout的自然界限。
        参数
        x - 从这个TextLayout的起点的x偏移。 这是在标准坐标。
        y - 从这个TextLayout的起点的y偏移量。 这是在标准坐标。
        结果
        描述指定点下的字符和边缘（前导或尾部）的命中。

      • equals

        public boolean equals​(TextLayout rhs)
        如果两个布局相等，则返回true 。 遵守equals(Object)的总合同。
        参数
        rhs - 与 TextLayout相比较的 TextLayout
        结果
        true如果指定的 TextLayout等于这个 TextLayout 。

      • toString

        public String toString​()
        返回此 TextLayout调试信息。
        重写：
        toString在 Object
        结果
        该 textLine为 TextLayout作为 String 。

      • draw

        public void draw​(Graphics2D g2,
                 float x,
                 float y)
        这呈现TextLayout在指定的指定位置Graphics2D上下文。 布局的起点位于x，y处。 渲染可能会触及此职位的getBounds()内的任何一点。 这使g2不变。 文本沿基线路径呈现。
        参数
        g2 - 要渲染布局的 Graphics2D上下文
        x - 这个 TextLayout的原点的X坐标
        y - 这个 TextLayout的原点的Y坐标
        另请参见：
        getBounds()

      • getOutline

        public Shape getOutline​(AffineTransform tx)
        返回一个表示 Shape的轮廓的 TextLayout 。
        参数
        tx - 可选的AffineTransform适用于此TextLayout的大纲。
        结果
        一个Shape是这个TextLayout的大纲。 这是在标准坐标。

      • getLayoutPath

        public LayoutPath getLayoutPath​()
        返回LayoutPath，如果布局路径是默认路径，则为null（x映射到advance，y映射到offset）。
        结果
        布局路径
        从以下版本开始：
        1.6

      • hitToPoint

        public void hitToPoint​(TextHitInfo hit,
                       Point2D point)
        将命中转换为标准坐标中的一个点。 该点在字符的前后边缘的基线上，如果合适的话。 如果路径在由击中所代表的角色的侧面断开，该点将与该角色相邻。
        参数
        hit - 打击检查。 这必须是TextLayout上的有效命中。
        point - 返回点。 点在标准坐标。
        异常
        IllegalArgumentException - 如果命中对TextLayout无效。
        NullPointerException - 如果命中或点为空。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextLayout.CaretPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class TextLayout.CaretPolicy

  • java.lang.Object
    • java.awt.font.TextLayout.CaretPolicy
  • Enclosing class:
    TextLayout

    public static class TextLayout.CaretPolicy
extends Object
    定义确定强插插位置的策略。 此类包含一个方法， getStrongCaret ，用于指定决定双重插入文本中强插入符的策略。 强插嘴用于将插入符号向左或向右移动。 此类的实例可以传递给getCaretShapes ， getNextLeftHit和getNextRightHit自定义强插入符选择。

    要指定替代插入策略，子类CaretPolicy并覆盖getStrongCaret 。 getStrongCaret应检查两个TextHitInfo参数，并选择其中一个作为强插入符号。

    大多数客户端不需要使用这个类。

    • 构造方法摘要

      构造方法
      Constructor 描述
      CaretPolicy​()
      构造一个 CaretPolicy 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      TextHitInfo getStrongCaret​(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout)
      在指定的 TextHitInfo选择一个指定的 TextHitInfo实例作为强 TextLayout符号。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CaretPolicy

        public CaretPolicy​()
        构造一个 CaretPolicy 。

    • 方法详细信息

      • getStrongCaret

        public TextHitInfo getStrongCaret​(TextHitInfo hit1,
                                  TextHitInfo hit2,
                                  TextLayout layout)
        在指定的 TextHitInfo选择一个指定的 TextHitInfo实例作为强 TextLayout符。
        参数
        hit1 - 有效的命中 layout
        hit2 - 有效的命中 layout
        layout -所述 TextLayout其中 hit1和 hit2用于
        结果
        hit1或 hit2 （或等效的 TextHitInfo ），表示强 TextHitInfo符号。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TextMeasurer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class TextMeasurer

  • java.lang.Object
    • java.awt.font.TextMeasurer
  • All Implemented Interfaces:
    Cloneable

    public final class TextMeasurer
extends Object
implements Cloneable
    TextMeasurer类提供换行所需的原始操作：测量一个给定的提前，确定一个字符范围的提前，并为一系列字符生成一个TextLayout 。 它还提供了段落增量编辑的方法。

    甲TextMeasurer对象被构造用AttributedCharacterIterator表示文本的一个段落。 由返回的值getBeginIndex的方法AttributedCharacterIterator限定的第一个字符的绝对索引。 在返回的值getEndIndex的方法AttributedCharacterIterator定义过去的最后一个字符的索引。 这些值定义了在调用TextMeasurer使用的索引的范围。 例如，要获取一定范围的文本或一行文本的换行符的调用必须使用起始和结束索引值之间的索引。 致电insertChar和deleteChar重新设置TextMeasurer使用这些调用中传递的AttributedCharacterIterator的起始索引和结束索引。

    大多数客户端将使用更方便的LineBreakMeasurer ，它实现标准换行政策（放置尽可能多的单词适合每一行）。

    从以下版本开始：
    1.3
    另请参见：
    LineBreakMeasurer

    • 构造方法摘要

      构造方法
      Constructor 描述
      TextMeasurer​(AttributedCharacterIterator text, FontRenderContext frc)
      从源文本构造一个 TextMeasurer 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object clone​()
      创建并返回此对象的副本。
      void deleteChar​(AttributedCharacterIterator newParagraph, int deletePos)
      更新 TextMeasurer后一个字符已经从当前由此表示的段落中删除 TextMeasurer 。
      float getAdvanceBetween​(int start, int limit)
      返回从 start开始的行的图形宽度，其中包含高达 limit字符。
      TextLayout getLayout​(int start, int limit)
      在给定的字符范围内返回一个 TextLayout 。
      int getLineBreakIndex​(int start, float maxAdvance)
      返回在 start开始的行上不适合的第一个字符的索引，并且可以以图形宽度测量高达 maxAdvance 。
      void insertChar​(AttributedCharacterIterator newParagraph, int insertPos)
      更新 TextMeasurer单个字符已经被插入到当前这个表示的段落后 TextMeasurer 。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TextMeasurer

        public TextMeasurer​(AttributedCharacterIterator text,
                    FontRenderContext frc)
        从源文本构造一个TextMeasurer 。 源文本应该是一个整个段落。
        参数
        text - 来源段落。 不能为空。
        frc - 有关正确测量文本所需的图形设备的信息。 不能为空。

    • 方法详细信息

      • clone

        protected Object clone​()
        描述从类复制： Object
        创建并返回此对象的副本。 “复制”的精确含义可能取决于对象的类。 一般的意图是，对于任何对象x ，表达式：
         x.clone() != x
        将是真实的，而且表达：
         x.clone().getClass() == x.getClass()
        将是true ，但这些都不是绝对的要求。 通常情况是：
         x.clone().equals(x)
        将是true ，这不是一个绝对的要求。

        按惯例，返回的对象应该通过调用super.clone获得。 如果一个类和它的所有超类（除了Object ）遵守这个惯例，那就是x.clone().getClass() == x.getClass()的情况。

        按照惯例，此方法返回的对象应该与此对象（正被克隆）无关。 为了实现这种独立性，可能需要修改super.clone返回的对象的一个或多个字段。 通常，这意味着复制构成被克隆的对象的内部“深层结构”的任何可变对象，并通过引用该副本替换对这些对象的引用。 如果类只包含原始字段或引用不可变对象，则通常情况下，需要修改super.clone返回的对象中的字段。

        该方法clone类Object执行特定克隆操作。 首先，如果此对象的类不实现接口Cloneable ，则抛出一个CloneNotSupportedException 。 请注意，所有阵列被认为是实现该接口Cloneable并且所述的返回类型clone数组类型的方法T[]是T[]其中T是任何引用或原始类型。 否则，该方法将创建该对象的类的新实例，并将其所有字段初始化为该对象的相应字段的内容，就像通过赋值一样。 这些字段的内容本身不被克隆。 因此，该方法执行该对象的“浅拷贝”，而不是“深度拷贝”操作。

        Object类Object并不实现接口Cloneable ，因此在类为Object的对象上调用clone方法将导致在运行时抛出异常。

        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable

      • getLineBreakIndex

        public int getLineBreakIndex​(int start,
                             float maxAdvance)
        返回在 start开始的行上不适合的第一个字符的索引，并且可以以图形宽度测量高达 maxAdvance 。
        参数
        start - 开始测量的字符索引。 start是一个绝对的索引，不是相对于段落的开头
        maxAdvance - 行必须符合的图形宽度
        结果
        最后一个字符后面的索引将适合从 start开始的行，图形宽度不超过 maxAdvance
        异常
        IllegalArgumentException - 如果 start小于段落的开头。

      • getAdvanceBetween

        public float getAdvanceBetween​(int start,
                               int limit)
        返回从start开始的行的图形宽度，包括最多limit字符。 start和limit是绝对指数，不是相对于段落的开头。
        参数
        start - 开始测量的字符索引
        limit - 停止测量的字符索引
        结果
        以 start开头的行的图形宽度，最多包含 limit
        异常
        IndexOutOfBoundsException - 如果 limit小于 start
        IllegalArgumentException - 如果 start或 limit不在段落开头和段落结尾之间。

      • getLayout

        public TextLayout getLayout​(int start,
                            int limit)
        在给定的字符范围内返回一个 TextLayout 。
        参数
        start - 第一个字符的索引
        limit - 最后一个字符后的索引。 必须大于start
        结果
        一个 TextLayout的字符，从 start开始，直到（但不包括） limit
        异常
        IndexOutOfBoundsException - 如果 limit小于 start
        IllegalArgumentException - 如果 start或 limit不在段落开头和段落结尾之间。

      • insertChar

        public void insertChar​(AttributedCharacterIterator newParagraph,
                       int insertPos)
        更新TextMeasurer单个字符已经被插入到当前这个表示的段落后TextMeasurer 。 此电话后，此TextMeasurer相当于从文本创建的新的TextMeasurer ; 然而，更新现有的TextMeasurer比从头开始创建一个新的更有效。
        参数
        newParagraph - 执行插入后段落的文本。 不能为空。
        insertPos - 插入字符的文本中的位置。 不得少于newParagraph的开始，而且必须小于newParagraph的结尾。
        异常
        IndexOutOfBoundsException -如果 insertPos小于开始 newParagraph ，或者大于或等于的端 newParagraph
        NullPointerException - 如果 newParagraph是 null

      • deleteChar

        public void deleteChar​(AttributedCharacterIterator newParagraph,
                       int deletePos)
        更新TextMeasurer后一个字符已经从当前由此表示的段落中删除TextMeasurer 。 此电话后，此TextMeasurer相当于从文本创建的新的TextMeasurer ; 然而，更新现有的TextMeasurer比从头开始创建一个新的更有效。
        参数
        newParagraph - 执行删除后段落的文本。 不能为空。
        deletePos - 字符被删除的文本中的位置。 不得小于newParagraph ，而不能大于末尾的newParagraph 。
        异常
        IndexOutOfBoundsException -如果 deletePos小于开始 newParagraph或大于的端 newParagraph
        NullPointerException - 如果 newParagraph是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TransformAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.font

Class TransformAttribute

  • java.lang.Object
    • java.awt.font.TransformAttribute
  • All Implemented Interfaces:
    Serializable

    public final class TransformAttribute
extends Object
implements Serializable
    TransformAttribute类为变换提供了一个不可变的包装器，以便作为属性使用是安全的。
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static TransformAttribute IDENTITY
      A TransformAttribute表示身份转换。

    • 构造方法摘要

      构造方法
      Constructor 描述
      TransformAttribute​(AffineTransform transform)
      包装指定的变换。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object rhs)
      返回 true如果rhs是一个 TransformAttribute其变换等于这个 TransformAttribute的变换。
      AffineTransform getTransform​()
      返回包装转换的副本。
      int hashCode​()
      返回对象的哈希码值。
      boolean isIdentity​()
      如果包装的变换是一个身份转换，则返回 true 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • IDENTITY

        public static final TransformAttribute IDENTITY
        A TransformAttribute表示身份转换。
        从以下版本开始：
        1.6

    • 构造方法详细信息

      • TransformAttribute

        public TransformAttribute​(AffineTransform transform)
        包装指定的变换。 克隆变体，并保留对克隆的引用。 原始转换不变。 如果null作为参数传递，则此构造函数的行为就像身份转换一样。 （注意，在这种情况下最好使用IDENTITY ）
        参数
        transform - 要包装的指定的AffineTransform ，或null。

    • 方法详细信息

      • getTransform

        public AffineTransform getTransform​()
        返回包装转换的副本。
        结果
        一个 AffineTransform是这个 TransformAttribute的包装转换的 TransformAttribute 。

      • isIdentity

        public boolean isIdentity​()
        如果包装的变换是一个身份转换，则返回 true 。
        结果
        true如果包装的变换是一个身份转换; 否则为false 。
        从以下版本开始：
        1.4

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则hashCode两个对象中的每个对象调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同的对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.6
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object rhs)
        如果rhs是一个 TransformAttribute其变换等于这个 TransformAttribute的变换，则返回 true 。
        重写：
        equals在 Object
        参数
        rhs - 要比较的对象
        结果
        true如果参数是一个 TransformAttribute其变换等于这个 TransformAttribute的变换。
        从以下版本开始：
        1.6
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.font (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.font

  • Packages that use java.awt.font
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
  • Classes in java.awt.font used by java.awt
    Class 描述
    FontRenderContext
    FontRenderContext类是用于正确测量文本所需信息的容器。
    GlyphVector
    GlyphVector对象是包含几何信息的字形的集合，用于在与最终显示 GlyphVector的设备相对应的变换的坐标空间中放置每个字形。
    LineMetrics
    LineMetrics类允许访问沿线排列字符和布局一组线所需的度量。
    TextAttribute
    TextAttribute类定义用于文本呈现的属性键和属性值。
  • Classes in java.awt.font used by java.awt.event
    Class 描述
    TextHitInfo
    TextHitInfo类表示文本模型中的字符位置，以及字符的 偏差或“侧”。
  • Classes in java.awt.font used by java.awt.font
    Class 描述
    FontRenderContext
    FontRenderContext类是用于正确测量文本所需信息的容器。
    GlyphJustificationInfo
    GlyphJustificationInfo类表示有关字形对齐属性的信息。
    GlyphMetrics
    GlyphMetrics类代表单个字形的信息。
    GlyphVector
    GlyphVector对象是包含几何信息的字形的集合，用于在对应于最终显示 GlyphVector的设备的变换的坐标空间中放置每个字形。
    GraphicAttribute
    该类与CHAR_REPLACEMENT属性一起使用。
    ImageGraphicAttribute
    该ImageGraphicAttribute类的实现GraphicAttribute其中提请在图像TextLayout 。
    LayoutPath
    LayoutPath提供了相对于基准的位置和用户空间中的点之间的映射。
    NumericShaper
    NumericShaper类用于将Latin-1（欧洲）数字转换为其他Unicode十进制数字。
    NumericShaper.Range
    A NumericShaper.Range表示具有其自己的十进制数字的脚本的Unicode范围。
    ShapeGraphicAttribute
    该ShapeGraphicAttribute类的实现GraphicAttribute绘制形状在TextLayout 。
    TextAttribute
    TextAttribute类定义用于文本呈现的属性键和属性值。
    TextHitInfo
    TextHitInfo类表示文本模型中的字符位置，以及字符的 偏差或“边”。
    TextLayout
    TextLayout是风格字符数据的不可变图形表示。
    TextLayout.CaretPolicy
    定义确定强插插位置的策略。
    TransformAttribute
    TransformAttribute类为变换提供了一个不可变的包装器，以便作为属性使用是安全的。
  • Classes in java.awt.font used by java.awt.im
    Class 描述
    TextAttribute
    TextAttribute类定义用于文本呈现的属性键和属性值。
    TextHitInfo
    TextHitInfo类表示文本模型中的字符位置，以及字符的 偏差或“侧”。
  • Classes in java.awt.font used by java.awt.im.spi
    Class 描述
    TextHitInfo
    TextHitInfo类表示文本模型中的字符位置，以及字符的 偏见或“侧”。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.FontRenderContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.FontRenderContext

  • Packages that use FontRenderContext
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of FontRenderContext in java.awt

      Methods in java.awt that return FontRenderContext
      Modifier and Type 方法 描述
      FontRenderContext FontMetrics.getFontRenderContext​()
      获取 FontRenderContext使用此 FontMetrics对象测量文本。
      abstract FontRenderContext Graphics2D.getFontRenderContext​()
      获取的渲染上下文 Font这个范围内 Graphics2D上下文。
      Methods in java.awt with parameters of type FontRenderContext
      Modifier and Type 方法 描述
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, char[] chars)
      通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, int[] glyphCodes)
      创建GlyphVector通过映射字符字形的一对一的基础上在此的Unicode cmap Font 。
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, String str)
      通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, CharacterIterator ci)
      通过在Font中基于Unicode cmap将指定的字符映射到字形，创建一个Font 。
      LineMetrics Font.getLineMetrics​(char[] chars, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的对象 LineMetrics 。
      LineMetrics Font.getLineMetrics​(String str, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的 LineMetrics对象。
      LineMetrics Font.getLineMetrics​(String str, FontRenderContext frc)
      返回使用指定的String和FontRenderContext创建的LineMetrics对象。
      LineMetrics Font.getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的一个 LineMetrics对象。
      Rectangle2D Font.getMaxCharBounds​(FontRenderContext frc)
      返回具有指定的 FontRenderContext定义的最大边界的字符的边界。
      Rectangle2D Font.getStringBounds​(char[] chars, int beginIndex, int limit, FontRenderContext frc)
      返回指定的 FontRenderContext中指定字符数组的逻辑边界。
      Rectangle2D Font.getStringBounds​(String str, int beginIndex, int limit, FontRenderContext frc)
      返回在指定的 String中指定的 FontRenderContext的逻辑边界。
      Rectangle2D Font.getStringBounds​(String str, FontRenderContext frc)
      返回在指定的 String中指定的 FontRenderContext的逻辑边界。
      Rectangle2D Font.getStringBounds​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回指定索引的字符的逻辑边界CharacterIterator指定FontRenderContext 。
      GlyphVector Font.layoutGlyphVector​(FontRenderContext frc, char[] text, int start, int limit, int flags)
      返回一个新的 GlyphVector对象，如果可能，执行文本的全面布局。

    • Uses of FontRenderContext in java.awt.font

      Methods in java.awt.font that return FontRenderContext
      Modifier and Type 方法 描述
      abstract FontRenderContext GlyphVector.getFontRenderContext​()
      返回FontRenderContext与此相关GlyphVector 。
      Methods in java.awt.font with parameters of type FontRenderContext
      Modifier and Type 方法 描述
      boolean FontRenderContext.equals​(FontRenderContext rhs)
      如果rhs具有相同的变换，抗锯齿和小数度量值，则返回true。
      Rectangle GlyphVector.getGlyphPixelBounds​(int index, FontRenderContext renderFRC, float x, float y)
      当这个返回index字形的像素边界 GlyphVector在渲染 Graphics给定 FontRenderContext在给定位置。
      Rectangle GlyphVector.getPixelBounds​(FontRenderContext renderFRC, float x, float y)
      在给定位置的给定 FontRenderContext的图形中渲染时，返回此 GlyphVector的像素边界。
      Rectangle TextLayout.getPixelBounds​(FontRenderContext frc, float x, float y)
      在给定位置的给定 FontRenderContext的图形中渲染时返回此 TextLayout的像素边界。
      Constructors in java.awt.font with parameters of type FontRenderContext
      Constructor 描述
      LineBreakMeasurer​(AttributedCharacterIterator text, FontRenderContext frc)
      为指定的文本构造一个 LineBreakMeasurer 。
      LineBreakMeasurer​(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
      为指定的文本构造一个 LineBreakMeasurer 。
      TextLayout​(String string, Font font, FontRenderContext frc)
      构造一个TextLayout从String和Font 。
      TextLayout​(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
      从一个 String和一个属性集构造一个 TextLayout 。
      TextLayout​(AttributedCharacterIterator text, FontRenderContext frc)
      从迭代器构造一个 TextLayout超过样式文本。
      TextMeasurer​(AttributedCharacterIterator text, FontRenderContext frc)
      从源文本构造一个 TextMeasurer 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.GlyphJustificationInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.GlyphJustificationInfo

  • Packages that use GlyphJustificationInfo
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of GlyphJustificationInfo in java.awt.font

      Methods in java.awt.font that return GlyphJustificationInfo
      Modifier and Type 方法 描述
      abstract GlyphJustificationInfo GlyphVector.getGlyphJustificationInfo​(int glyphIndex)
      将指定索引中的字形的对齐信息返回到此 GlyphVector 。
      GlyphJustificationInfo GraphicAttribute.getJustificationInfo​()
      返回此 GraphicAttribute的对齐信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.GlyphMetrics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.GlyphMetrics

  • Packages that use GlyphMetrics
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of GlyphMetrics in java.awt.font

      Methods in java.awt.font that return GlyphMetrics
      Modifier and Type 方法 描述
      abstract GlyphMetrics GlyphVector.getGlyphMetrics​(int glyphIndex)
      将指定索引中的字形的度量返回到此 GlyphVector 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.GlyphVector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.GlyphVector

  • Packages that use GlyphVector
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of GlyphVector in java.awt

      Methods in java.awt that return GlyphVector
      Modifier and Type 方法 描述
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, char[] chars)
      通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, int[] glyphCodes)
      通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, String str)
      通过在Font中基于Unicode cmap将字符映射到字形，创建一个Font 。
      GlyphVector Font.createGlyphVector​(FontRenderContext frc, CharacterIterator ci)
      通过在Font中基于Unicode cmap将指定的字符映射到字形，创建一个Font 。
      GlyphVector Font.layoutGlyphVector​(FontRenderContext frc, char[] text, int start, int limit, int flags)
      返回一个新的 GlyphVector对象，如果可能，执行文本的全面布局。
      Methods in java.awt with parameters of type GlyphVector
      Modifier and Type 方法 描述
      abstract void Graphics2D.drawGlyphVector​(GlyphVector g, float x, float y)
      使用Graphics2D上下文的呈现属性呈现指定的GlyphVector的文本。

    • Uses of GlyphVector in java.awt.font

      Methods in java.awt.font with parameters of type GlyphVector
      Modifier and Type 方法 描述
      abstract boolean GlyphVector.equals​(GlyphVector set)
      测试指定的 GlyphVector完全等于此 GlyphVector 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.GraphicAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.GraphicAttribute

  • Packages that use GraphicAttribute
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of GraphicAttribute in java.awt.font

      Subclasses of GraphicAttribute in java.awt.font
      Modifier and Type Class 描述
      class  ImageGraphicAttribute
      该ImageGraphicAttribute类的实现GraphicAttribute其中提请在图像TextLayout 。
      class  ShapeGraphicAttribute
      该ShapeGraphicAttribute类的实现GraphicAttribute绘制形状在TextLayout 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.ImageGraphicAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.ImageGraphicAttribute

  • Packages that use ImageGraphicAttribute
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of ImageGraphicAttribute in java.awt.font

      Methods in java.awt.font with parameters of type ImageGraphicAttribute
      Modifier and Type 方法 描述
      boolean ImageGraphicAttribute.equals​(ImageGraphicAttribute rhs)
      将此 ImageGraphicAttribute比较为指定的 ImageGraphicAttribute 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.LayoutPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.LayoutPath

  • Packages that use LayoutPath
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of LayoutPath in java.awt.font

      Methods in java.awt.font that return LayoutPath
      Modifier and Type 方法 描述
      LayoutPath TextLayout.getLayoutPath​()
      返回LayoutPath，如果布局路径是默认路径，则为null（x映射到advance，y映射到offset）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.LineBreakMeasurer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.LineBreakMeasurer

No usage of java.awt.font.LineBreakMeasurer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.LineMetrics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.LineMetrics

  • Packages that use LineMetrics
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of LineMetrics in java.awt

      Methods in java.awt that return LineMetrics
      Modifier and Type 方法 描述
      LineMetrics Font.getLineMetrics​(char[] chars, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的对象 LineMetrics 。
      LineMetrics Font.getLineMetrics​(String str, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的对象 LineMetrics 。
      LineMetrics Font.getLineMetrics​(String str, FontRenderContext frc)
      返回使用指定的String和FontRenderContext创建的LineMetrics对象。
      LineMetrics Font.getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回使用指定参数创建的对象 LineMetrics 。
      LineMetrics FontMetrics.getLineMetrics​(char[] chars, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定字符数组的LineMetrics对象。
      LineMetrics FontMetrics.getLineMetrics​(String str, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定的String的LineMetrics对象。
      LineMetrics FontMetrics.getLineMetrics​(String str, Graphics context)
      返回指定的Graphics上下文中指定的String的LineMetrics对象。
      LineMetrics FontMetrics.getLineMetrics​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回指定的Graphics上下文中指定的CharacterIterator的LineMetrics对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.NumericShaper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.NumericShaper

  • Packages that use NumericShaper
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of NumericShaper in java.awt.font

      Methods in java.awt.font that return NumericShaper
      Modifier and Type 方法 描述
      static NumericShaper NumericShaper.getContextualShaper​(int ranges)
      返回提供的unicode范围的上下文整形器。
      static NumericShaper NumericShaper.getContextualShaper​(int ranges, int defaultContext)
      返回提供的unicode范围的上下文整形器。
      static NumericShaper NumericShaper.getContextualShaper​(Set<NumericShaper.Range> ranges)
      返回提供的Unicode范围的上下文整形器。
      static NumericShaper NumericShaper.getContextualShaper​(Set<NumericShaper.Range> ranges, NumericShaper.Range defaultContext)
      返回提供的Unicode范围的上下文整形器。
      static NumericShaper NumericShaper.getShaper​(int singleRange)
      返回提供的unicode范围的整形器。
      static NumericShaper NumericShaper.getShaper​(NumericShaper.Range singleRange)
      Returns a shaper for the provided Unicode range.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.NumericShaper.Range (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.NumericShaper.Range

  • Packages that use NumericShaper.Range
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of NumericShaper.Range in java.awt.font

      Methods in java.awt.font that return NumericShaper.Range
      Modifier and Type 方法 描述
      static NumericShaper.Range NumericShaper.Range.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static NumericShaper.Range[] NumericShaper.Range.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.awt.font that return types with arguments of type NumericShaper.Range
      Modifier and Type 方法 描述
      Set<NumericShaper.Range> NumericShaper.getRangeSet​()
      返回 Set代表所有的Unicode范围在此 NumericShaper将要成型。
      Methods in java.awt.font with parameters of type NumericShaper.Range
      Modifier and Type 方法 描述
      static NumericShaper NumericShaper.getContextualShaper​(Set<NumericShaper.Range> ranges, NumericShaper.Range defaultContext)
      返回提供的Unicode范围的上下文整形器。
      static NumericShaper NumericShaper.getShaper​(NumericShaper.Range singleRange)
      返回提供的Unicode范围的整形器。
      void NumericShaper.shape​(char[] text, int start, int count, NumericShaper.Range context)
      使用提供的 context转换出现在 start和 start + count之间的文本中的数字。
      Method parameters in java.awt.font with type arguments of type NumericShaper.Range
      Modifier and Type 方法 描述
      static NumericShaper NumericShaper.getContextualShaper​(Set<NumericShaper.Range> ranges)
      返回提供的Unicode范围的上下文整形器。
      static NumericShaper NumericShaper.getContextualShaper​(Set<NumericShaper.Range> ranges, NumericShaper.Range defaultContext)
      返回提供的Unicode范围的上下文整形器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.ShapeGraphicAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.ShapeGraphicAttribute

  • Packages that use ShapeGraphicAttribute
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of ShapeGraphicAttribute in java.awt.font

      Methods in java.awt.font with parameters of type ShapeGraphicAttribute
      Modifier and Type 方法 描述
      boolean ShapeGraphicAttribute.equals​(ShapeGraphicAttribute rhs)
      将此 ShapeGraphicAttribute与指定的 ShapeGraphicAttribute 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.TextAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.TextAttribute

  • Packages that use TextAttribute
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。

    • Uses of TextAttribute in java.awt

      Methods in java.awt that return types with arguments of type TextAttribute
      Modifier and Type 方法 描述
      Map<TextAttribute,?> Font.getAttributes​()
      返回此 Font可用的字体属性的映射。
      abstract Map<TextAttribute,?> Toolkit.mapInputMethodHighlight​(InputMethodHighlight highlight)
      返回给定输入法突出显示的抽象级别描述的可视属性映射，如果没有找到映射，则返回null。

    • Uses of TextAttribute in java.awt.font

      Fields in java.awt.font declared as TextAttribute
      Modifier and Type Field 描述
      static TextAttribute TextAttribute.BACKGROUND
      用于渲染文本背景的绘画的属性键。
      static TextAttribute TextAttribute.BIDI_EMBEDDING
      文本嵌入级别的属性键。
      static TextAttribute TextAttribute.CHAR_REPLACEMENT
      用于用户定义的字形显示的属性键代替字符的字体标准字形。
      static TextAttribute TextAttribute.FAMILY
      字体名称的属性键。
      static TextAttribute TextAttribute.FONT
      用于提供用于呈现文本的字体的属性键。
      static TextAttribute TextAttribute.FOREGROUND
      用于渲染文本的颜色的属性键。
      static TextAttribute TextAttribute.INPUT_METHOD_HIGHLIGHT
      输入法高亮样式的属性键。
      static TextAttribute TextAttribute.INPUT_METHOD_UNDERLINE
      输入法的属性键加下划线。
      static TextAttribute TextAttribute.JUSTIFICATION
      段落的理由的属性关键。
      static TextAttribute TextAttribute.KERNING
      要求字距调整的属性键。
      static TextAttribute TextAttribute.LIGATURES
      启用可选连字的属性键。
      static TextAttribute TextAttribute.NUMERIC_SHAPING
      将ASCII十进制数字转换为其他十进制范围的属性键。
      static TextAttribute TextAttribute.POSTURE
      字体姿势的属性键。
      static TextAttribute TextAttribute.RUN_DIRECTION
      行的运行方向的属性键。
      static TextAttribute TextAttribute.SIZE
      字体大小的属性键。
      static TextAttribute TextAttribute.STRIKETHROUGH
      删除线的属性键。
      static TextAttribute TextAttribute.SUPERSCRIPT
      上标和下标的属性键。
      static TextAttribute TextAttribute.SWAP_COLORS
      用于交换前景和背景的属性键 Paints 。
      static TextAttribute TextAttribute.TRACKING
      属性键控制跟踪。
      static TextAttribute TextAttribute.TRANSFORM
      用于转换字体的属性键。
      static TextAttribute TextAttribute.UNDERLINE
      下划线的属性键。
      static TextAttribute TextAttribute.WEIGHT
      字体重量的属性键。
      static TextAttribute TextAttribute.WIDTH
      字体宽度的属性键。

    • Uses of TextAttribute in java.awt.im

      Methods in java.awt.im that return types with arguments of type TextAttribute
      Modifier and Type 方法 描述
      Map<TextAttribute,?> InputMethodHighlight.getStyle​()
      返回文本范围的渲染样式属性，或返回null。
      Constructor parameters in java.awt.im with type arguments of type TextAttribute
      Constructor 描述
      InputMethodHighlight​(boolean selected, int state, int variation, Map<TextAttribute,?> style)
      构造输入法高亮记录。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.TextHitInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.TextHitInfo

  • Packages that use TextHitInfo
    软件包 描述
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。

    • Uses of TextHitInfo in java.awt.event

      Methods in java.awt.event that return TextHitInfo
      Modifier and Type 方法 描述
      TextHitInfo InputMethodEvent.getCaret​()
      得到插入符号。
      TextHitInfo InputMethodEvent.getVisiblePosition​()
      获取最显着的位置。
      Constructors in java.awt.event with parameters of type TextHitInfo
      Constructor 描述
      InputMethodEvent​(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定源组件，类型，时间，文本，插入符和 InputMethodEvent 。
      InputMethodEvent​(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
      构造具有指定的源组件，类型，插入符号和 InputMethodEvent 。
      InputMethodEvent​(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      构造一个具有指定的源组件，类型，文本，插入符号和 InputMethodEvent 。

    • Uses of TextHitInfo in java.awt.font

      Methods in java.awt.font that return TextHitInfo
      Modifier and Type 方法 描述
      static TextHitInfo TextHitInfo.afterOffset​(int offset)
      以指定的偏移量创建 TextHitInfo ，与偏移后的字符相关联。
      static TextHitInfo TextHitInfo.beforeOffset​(int offset)
      以指定的偏移量创建 TextHitInfo ，与偏移前的字符相关联。
      TextHitInfo TextLayout.getNextLeftHit​(int offset)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.getNextLeftHit​(int offset, TextLayout.CaretPolicy policy)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.getNextLeftHit​(TextHitInfo hit)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.getNextRightHit​(int offset)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.getNextRightHit​(int offset, TextLayout.CaretPolicy policy)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.getNextRightHit​(TextHitInfo hit)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的打击，返回null 。
      TextHitInfo TextHitInfo.getOffsetHit​(int delta)
      创建 TextHitInfo其字符索引由偏移 delta从 charIndex此的 TextHitInfo 。
      TextHitInfo TextHitInfo.getOtherHit​()
      在插入点的另一侧创建一个 TextHitInfo 。
      TextHitInfo TextLayout.CaretPolicy.getStrongCaret​(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout)
      在指定的 TextHitInfo选择一个指定的 TextHitInfo实例作为强 TextLayout符号。
      TextHitInfo TextLayout.getVisualOtherHit​(TextHitInfo hit)
      返回指定命中的插入符号对面的命中。
      TextHitInfo TextLayout.hitTestChar​(float x, float y)
      返回对应于指定点的 TextHitInfo 。
      TextHitInfo TextLayout.hitTestChar​(float x, float y, Rectangle2D bounds)
      返回对应于指定点的 TextHitInfo 。
      static TextHitInfo TextHitInfo.leading​(int charIndex)
      创建 TextHitInfo上的字符在指定的前沿 charIndex 。
      static TextHitInfo TextHitInfo.trailing​(int charIndex)
      在指定的 charIndex创建字符后端的命中。
      Methods in java.awt.font with parameters of type TextHitInfo
      Modifier and Type 方法 描述
      boolean TextHitInfo.equals​(TextHitInfo hitInfo)
      返回 true如果指定 TextHitInfo具有相同 charIndex和 isLeadingEdge ，因为这 TextHitInfo 。
      float[] TextLayout.getCaretInfo​(TextHitInfo hit)
      返回与 hit对应的插入符号的信息。
      float[] TextLayout.getCaretInfo​(TextHitInfo hit, Rectangle2D bounds)
      返回与 hit对应的插入符号的信息。
      Shape TextLayout.getCaretShape​(TextHitInfo hit)
      返回一个 Shape代表在这个 TextLayout的自然界内的指定命中的插入符号。
      Shape TextLayout.getCaretShape​(TextHitInfo hit, Rectangle2D bounds)
      返回一个Shape，表示指定边界内指定点的插入符号。
      int[] TextLayout.getLogicalRangesForVisualSelection​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint)
      返回与视觉选择对应的文本的逻辑范围。
      TextHitInfo TextLayout.getNextLeftHit​(TextHitInfo hit)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.getNextRightHit​(TextHitInfo hit)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.CaretPolicy.getStrongCaret​(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout)
      选择指定的一个 TextHitInfo实例作为指定的强插入符 TextLayout 。
      Shape TextLayout.getVisualHighlightShape​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint)
      返回一个 Shape包含指定范围内的视觉选择，扩展到边界。
      Shape TextLayout.getVisualHighlightShape​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds)
      返回包含指定范围内的视觉选择的路径，扩展为 bounds 。
      TextHitInfo TextLayout.getVisualOtherHit​(TextHitInfo hit)
      返回指定命中的插入符号对面的命中。
      void TextLayout.hitToPoint​(TextHitInfo hit, Point2D point)
      将命中转换为标准坐标中的一个点。

    • Uses of TextHitInfo in java.awt.im

      Methods in java.awt.im that return TextHitInfo
      Modifier and Type 方法 描述
      TextHitInfo InputMethodRequests.getLocationOffset​(int x, int y)
      获取屏幕上指定的绝对x和y坐标的组合文本中的偏移量。
      Methods in java.awt.im with parameters of type TextHitInfo
      Modifier and Type 方法 描述
      Rectangle InputMethodRequests.getTextLocation​(TextHitInfo offset)
      获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。

    • Uses of TextHitInfo in java.awt.im.spi

      Methods in java.awt.im.spi with parameters of type TextHitInfo
      Modifier and Type 方法 描述
      void InputMethodContext.dispatchInputMethodEvent​(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      从给定的参数创建输入法事件并将其分派到客户端组件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.TextLayout (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.TextLayout

  • Packages that use TextLayout
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of TextLayout in java.awt.font

      Methods in java.awt.font that return TextLayout
      Modifier and Type 方法 描述
      TextLayout TextLayout.getJustifiedLayout​(float justificationWidth)
      创建一个 TextLayout对齐到指定宽度的副本。
      TextLayout TextMeasurer.getLayout​(int start, int limit)
      在给定的字符范围内返回 TextLayout 。
      TextLayout LineBreakMeasurer.nextLayout​(float wrappingWidth)
      返回下一个布局，并更新当前位置。
      TextLayout LineBreakMeasurer.nextLayout​(float wrappingWidth, int offsetLimit, boolean requireNextWord)
      返回下一个布局，并更新当前位置。
      Methods in java.awt.font with parameters of type TextLayout
      Modifier and Type 方法 描述
      boolean TextLayout.equals​(TextLayout rhs)
      如果两个布局相等，则返回 true 。
      TextHitInfo TextLayout.CaretPolicy.getStrongCaret​(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout)
      Chooses one of the specified TextHitInfo instances as a strong caret in the specified TextLayout.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.TextLayout.CaretPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.TextLayout.CaretPolicy

  • Packages that use TextLayout.CaretPolicy
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of TextLayout.CaretPolicy in java.awt.font

      Fields in java.awt.font declared as TextLayout.CaretPolicy
      Modifier and Type Field 描述
      static TextLayout.CaretPolicy TextLayout.DEFAULT_CARET_POLICY
      当客户端未指定策略时，将使用此 CaretPolicy 。
      Methods in java.awt.font with parameters of type TextLayout.CaretPolicy
      Modifier and Type 方法 描述
      Shape[] TextLayout.getCaretShapes​(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy)
      返回对应于强和弱插入符号的两个路径。
      TextHitInfo TextLayout.getNextLeftHit​(int offset, TextLayout.CaretPolicy policy)
      返回左侧（顶部）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
      TextHitInfo TextLayout.getNextRightHit​(int offset, TextLayout.CaretPolicy policy)
      返回右侧（下）的下一个插入符号的命中; 如果没有这样的命中，返回null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.TextMeasurer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.TextMeasurer

No usage of java.awt.font.TextMeasurer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.font.TransformAttribute (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.font.TransformAttribute

  • Packages that use TransformAttribute
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。

    • Uses of TransformAttribute in java.awt.font

      Fields in java.awt.font declared as TransformAttribute
      Modifier and Type Field 描述
      static TransformAttribute TransformAttribute.IDENTITY
      A TransformAttribute表示身份转换。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.font.MultipleMaster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.font.MultipleMaster

No usage of java.awt.font.MultipleMaster
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.font.OpenType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.font.OpenType

No usage of java.awt.font.OpenType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AffineTransform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class AffineTransform

  • java.lang.Object
    • java.awt.geom.AffineTransform
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class AffineTransform
extends Object
implements Cloneable, Serializable
    AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“直线度”和“平行度”。 仿射变换可以使用翻译，缩放，翻转，旋转和剪切的顺序来构建。

    这样的坐标变换可以由3行×3列矩阵表示，隐含的最后一行为[0 0 1]。 该矩阵将源坐标(x,y)转换为目标坐标(x',y') ，将它们视为列向量，并根据以下处理将坐标矢量乘以矩阵：

      [ x']   [  m00  m01  m02  ] [ x ]   [ m00x + m01y + m02 ]
      [ y'] = [  m10  m11  m12  ] [ y ] = [ m10x + m11y + m12 ]
      [ 1 ]   [   0    0    1   ] [ 1 ]   [         1         ]

    Handling 90-Degree Rotations

    在AffineTransform类中的rotate方法的某些变体中，双精度参数指定以弧度表示的旋转角度。 这些方法对于大约90度的旋转（包括180,270和360度的倍数）具有特殊处理，使得更有效地处理象限旋转的常见情况。 这种特殊的处理可以使角度非常接近90度的倍数，被视为90度的精确倍数。 对于90度的小倍数，处理为象限旋转的角度范围约为0.00000121度宽。 这一节解释了为什么需要这样特别的关心以及如何实施。

    由于90度以弧度表示为PI/2 ，并且由于PI是超越（因此是非理性的）数字，所以不可能精确地表示90度的倍数作为以弧度测量的精确双精度值。 因此，在理论上不可能使用这些值来描述象限旋转（90,180,270或360度）。 双精度浮点值可以非常接近PI/2的非零倍数，但不能足够接近正弦或余弦正好为PI/2或-1.0。 的实现Math.sin()和Math.cos()相应从不为比其它任何情况下返回0.0 Math.sin(0.0) 。 然而，这些相同的实现对于90度的每个倍数的一些范围的数字返回正好为1.0和-1.0，因为正确答案如此接近1.0或-1.0，所以双精度有效位数不能像它可以精确地表示差异对于接近0.0的数字。

    这些问题的最终结果是，如果使用Math.sin()和Math.cos()方法在这些基于弧度的旋转操作期间直接生成矩阵修改的值，则所得到的变换即使对于简单的情况也不会被严格地分类为象限旋转rotate(Math.PI/2.0) ，由于正弦和余弦所获得的非0.0值引起的矩阵微小变化。 如果这些转换不被划分为象限旋转，则根据变换类型尝试优化进一步操作的后续代码将被归入其最一般的实现。

    因为象限旋转是相当普遍的，所以这个类应该适当地处理这些情况，既可以将旋转应用于变换，也可以将结果变换应用于坐标。 为了便于这种最佳处理，采用以弧度测量的旋转角度的方法尝试检测旨在进行四分之一轮转的角度并对其进行处理。 因此，如果Math.sin(theta)或Math.cos(theta)正好返回1.0或-1.0，则这些方法将角度θ视为象限旋转。 作为经验法则，该属性适用于Math.PI/2.0小倍数附近约0.0000000211弧度（或0.00000121度）的Math.PI/2.0 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TYPE_FLIP
      该标志位指示由该对象定义的变换除了由其他标志位指示的转换之外还执行关于某个轴的镜像翻转，该轴将常规右手坐标系改变为左手系统。
      static int TYPE_GENERAL_ROTATION
      该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行任意角度的旋转。
      static int TYPE_GENERAL_SCALE
      该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行一般尺度。
      static int TYPE_GENERAL_TRANSFORM
      该常数表示由该对象定义的变换执行输入坐标的任意转换。
      static int TYPE_IDENTITY
      该常数表示由该对象定义的变换是一个身份变换。
      static int TYPE_MASK_ROTATION
      该常数是任何旋转标志位的位掩码。
      static int TYPE_MASK_SCALE
      该常数是任何刻度标志位的位掩码。
      static int TYPE_QUADRANT_ROTATION
      该标志位表示除了由其他标志位指示的转换之外，由该对象定义的变换执行了90度的几倍的象限旋转。
      static int TYPE_TRANSLATION
      该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行转换。
      static int TYPE_UNIFORM_SCALE
      该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行统一的标度。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AffineTransform​()
      构造一个新的 AffineTransform代表身份转换。
      AffineTransform​(double[] flatmatrix)
      从表示3x3转换矩阵的4个非转换条目或6个可指定条目的双精度值数组构造新的 AffineTransform 。
      AffineTransform​(double m00, double m10, double m01, double m11, double m02, double m12)
      从6个双精度值构造新的 AffineTransform ，表示3x3变换矩阵的6个可指定条目。
      AffineTransform​(float[] flatmatrix)
      从表示3x3转换矩阵的4个非转换条目或6个可指定条目的浮点值数组构造新的 AffineTransform 。
      AffineTransform​(float m00, float m10, float m01, float m11, float m02, float m12)
      从6个浮点值构造新的 AffineTransform ，表示3x3变换矩阵的6个可指定条目。
      AffineTransform​(AffineTransform Tx)
      构造一个新的 AffineTransform ，它是一个指定的 AffineTransform对象的副本。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      返回此 AffineTransform对象的副本。
      void concatenate​(AffineTransform Tx)
      将 AffineTransform Tx连接到这个 AffineTransform Cx中，以最常用的方式提供映射到前一个用户空间的新用户空间 Tx 。
      AffineTransform createInverse​()
      返回表示逆变换的 AffineTransform对象。
      Shape createTransformedShape​(Shape pSrc)
      返回一个新Shape由指定的几何定义的对象Shape已通过此变换之后。
      void deltaTransform​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过该变换来变换相对距离向量的数组。
      Point2D deltaTransform​(Point2D ptSrc, Point2D ptDst)
      转换 ptSrc指定的相对距离向量， ptSrc结果存储在 ptDst 。
      boolean equals​(Object obj)
      如果此 AffineTransform表示与指定参数相同的仿射坐标变换，则返回 true 。
      double getDeterminant​()
      返回变换的矩阵表示的行列式。
      void getMatrix​(double[] flatmatrix)
      检索3x3仿射变换矩阵中的6个可指定值，并将它们置于双重精度值的数组中。
      static AffineTransform getQuadrantRotateInstance​(int numquadrants)
      返回一个将坐标旋转指定数量的象限的变换。
      static AffineTransform getQuadrantRotateInstance​(int numquadrants, double anchorx, double anchory)
      返回一个转换，该变换将坐标指定指定锚点周围的指定数量的象限旋转。
      static AffineTransform getRotateInstance​(double theta)
      返回表示旋转变换的变换。
      static AffineTransform getRotateInstance​(double vecx, double vecy)
      返回一个根据旋转矢量旋转坐标的变换。
      static AffineTransform getRotateInstance​(double theta, double anchorx, double anchory)
      返回一个在锚点周围旋转坐标的变换。
      static AffineTransform getRotateInstance​(double vecx, double vecy, double anchorx, double anchory)
      返回一个根据旋转向量旋转锚点周围的坐标点的变换。
      static AffineTransform getScaleInstance​(double sx, double sy)
      返回表示缩放变换的变换。
      double getScaleX​()
      返回3x3仿射变换矩阵的 m00元素。
      double getScaleY​()
      返回3x3仿射变换矩阵的 m11元素。
      static AffineTransform getShearInstance​(double shx, double shy)
      返回代表剪切变换的变换。
      double getShearX​()
      返回3x3仿射变换矩阵的X坐标剪切元素（m01）。
      double getShearY​()
      返回3x3仿射变换矩阵的Y坐标剪切元素（m10）。
      static AffineTransform getTranslateInstance​(double tx, double ty)
      返回表示平移变换的变换。
      double getTranslateX​()
      返回3x3仿射变换矩阵的平移元素（m02）的X坐标。
      double getTranslateY​()
      返回3x3仿射变换矩阵的平移元素（m12）的Y坐标。
      int getType​()
      检索描述此转换的转换属性的标志位。
      int hashCode​()
      返回此转换的哈希码。
      void inverseTransform​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过此变换反向转换双精度坐标数组。
      Point2D inverseTransform​(Point2D ptSrc, Point2D ptDst)
      反向转换指定的 ptSrc并将结果存储在 ptDst 。
      void invert​()
      将此变换设置为本身的倒数。
      boolean isIdentity​()
      如果这个 AffineTransform是一个身份转换，则返回 true 。
      void preConcatenate​(AffineTransform Tx)
      串接的 AffineTransform Tx本 AffineTransform CX在一个不常用的方式，使得 Tx坐标变换相对于绝对像素空间而不是相对于现有的用户空间修改。
      void quadrantRotate​(int numquadrants)
      使用将坐标旋转指定数量的象限的变换来连接此变换。
      void quadrantRotate​(int numquadrants, double anchorx, double anchory)
      使用将坐标旋转指定锚点周围指定数量的象限的变换来连接此变换。
      void rotate​(double theta)
      使用旋转变换连接此变换。
      void rotate​(double vecx, double vecy)
      使用根据旋转矢量旋转坐标的变换来连接此变换。
      void rotate​(double theta, double anchorx, double anchory)
      将此变换与使锚点附近旋转坐标的变换相连。
      void rotate​(double vecx, double vecy, double anchorx, double anchory)
      使用根据旋转矢量围绕锚点旋转坐标的变换来连接此变换。
      void scale​(double sx, double sy)
      使用缩放变换连接此变换。
      void setToIdentity​()
      将此转换重置为Identity变换。
      void setToQuadrantRotation​(int numquadrants)
      将此变换设置为将坐标旋转指定数量的象限的旋转变换。
      void setToQuadrantRotation​(int numquadrants, double anchorx, double anchory)
      将此转换设置为转换的旋转变换，该转换将坐标指定指定锚点周围的指定数量的象限旋转。
      void setToRotation​(double theta)
      将此变换设置为旋转变换。
      void setToRotation​(double vecx, double vecy)
      将此变换设置为根据旋转矢量旋转坐标的旋转变换。
      void setToRotation​(double theta, double anchorx, double anchory)
      将此转换设置为转换的旋转变换。
      void setToRotation​(double vecx, double vecy, double anchorx, double anchory)
      将此变换设置为根据旋转向量旋转锚点周围的坐标的旋转变换。
      void setToScale​(double sx, double sy)
      将此变换设置为缩放变换。
      void setToShear​(double shx, double shy)
      将此变换设置为剪切变换。
      void setToTranslation​(double tx, double ty)
      将此变换设置为转换变换。
      void setTransform​(double m00, double m10, double m01, double m11, double m02, double m12)
      将此变换设置为由6个双精度值指定的矩阵。
      void setTransform​(AffineTransform Tx)
      将此变换设置为指定的 AffineTransform对象中的变换副本。
      void shear​(double shx, double shy)
      将此变换与剪切变换相结合。
      String toString​()
      返回一个表示String的值的String 。
      void transform​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过此转换来转换双精度坐标数组。
      void transform​(double[] srcPts, int srcOff, float[] dstPts, int dstOff, int numPts)
      通过此转换来转换双精度坐标数组，并将结果存储到浮点数组中。
      void transform​(float[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过此转换来转换浮点坐标数组，并将结果存储到双精度数组中。
      void transform​(float[] srcPts, int srcOff, float[] dstPts, int dstOff, int numPts)
      通过此变换来转换浮点坐标数组。
      void transform​(Point2D[] ptSrc, int srcOff, Point2D[] ptDst, int dstOff, int numPts)
      通过此转换来转换点对象数组。
      Point2D transform​(Point2D ptSrc, Point2D ptDst)
      转换指定的 ptSrc并将结果存储在 ptDst 。
      void translate​(double tx, double ty)
      将此转换与转换变换相结合。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TYPE_IDENTITY

        public static final int TYPE_IDENTITY
        该常数表示由该对象定义的变换是一个身份变换。 身份变换是输出坐标与输入坐标始终相同的变换。 如果此变换是身份转换以外的其他变体，则该变换将作为常量GENERAL_TRANSFORM或适用于该变换执行的各种坐标转换的标志位的组合。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_TRANSLATION ， TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， TYPE_FLIP ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， TYPE_GENERAL_TRANSFORM ， getType() ， Constant Field Values

      • TYPE_TRANSLATION

        public static final int TYPE_TRANSLATION
        该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行转换。 平移在x和y上移动坐标恒定的量，而不改变向量的长度或角度。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， TYPE_FLIP ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， TYPE_GENERAL_TRANSFORM ， getType() ， Constant Field Values

      • TYPE_UNIFORM_SCALE

        public static final int TYPE_UNIFORM_SCALE
        该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行统一的标度。 均匀标度在x和y方向上将向量的长度乘以相同的量，而不改变向量之间的角度。 该标志位与TYPE_GENERAL_SCALE标志相互排斥。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_TRANSLATION ， TYPE_GENERAL_SCALE ， TYPE_FLIP ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， TYPE_GENERAL_TRANSFORM ， getType() ， Constant Field Values

      • TYPE_GENERAL_SCALE

        public static final int TYPE_GENERAL_SCALE
        该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行一般尺度。 一般比例尺在x和y方向上乘以不同量的向量长度，而不改变垂直向量之间的角度。 该标志位与TYPE_UNIFORM_SCALE标志相互排斥。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_TRANSLATION ， TYPE_UNIFORM_SCALE ， TYPE_FLIP ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， TYPE_GENERAL_TRANSFORM ， getType() ， Constant Field Values

      • TYPE_MASK_SCALE

        public static final int TYPE_MASK_SCALE
        该常数是任何刻度标志位的位掩码。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， Constant Field Values

      • TYPE_FLIP

        public static final int TYPE_FLIP
        该标志位指示由该对象定义的变换除了由其他标志位指示的转换之外还执行关于某个轴的镜像翻转，该轴将常规右手坐标系改变为左手系统。 右手坐标系是正X轴逆时针旋转以覆盖正Y轴的方式，类似于当您盯着拇指时右手指卷曲的方向。 左手坐标系是正X轴顺时针旋转以覆盖正Y轴的方式，类似于左手指上的手指卷曲。 没有数学方法来确定原始翻转或镜像变换的角度，因为在适当的调整旋转情况下，所有翻转角都相同。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_TRANSLATION ， TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， TYPE_GENERAL_TRANSFORM ， getType() ， Constant Field Values

      • TYPE_QUADRANT_ROTATION

        public static final int TYPE_QUADRANT_ROTATION
        该标志位表示除了由其他标志位指示的转换之外，由该对象定义的变换执行了90度的几倍的象限旋转。 旋转方向将向量的角度改变相同的量，而不管矢量的原始方向如何，而不改变向量的长度。 该标志位与TYPE_GENERAL_ROTATION标志相互排斥。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_TRANSLATION ， TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， TYPE_FLIP ， TYPE_GENERAL_ROTATION ， TYPE_GENERAL_TRANSFORM ， getType() ， Constant Field Values

      • TYPE_GENERAL_ROTATION

        public static final int TYPE_GENERAL_ROTATION
        该标志位表示由该对象定义的变换除了由其他标志位指示的转换之外还执行任意角度的旋转。 旋转方向将向量的角度改变相同的量，而不管矢量的原始方向如何，而不改变向量的长度。 该标志位与TYPE_QUADRANT_ROTATION标志相互排斥。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_TRANSLATION ， TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， TYPE_FLIP ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_TRANSFORM ， getType() ， Constant Field Values

      • TYPE_MASK_ROTATION

        public static final int TYPE_MASK_ROTATION
        该常数是任何旋转标志位的位掩码。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， Constant Field Values

      • TYPE_GENERAL_TRANSFORM

        public static final int TYPE_GENERAL_TRANSFORM
        该常数表示由该对象定义的变换执行输入坐标的任意转换。 如果该变换可以通过以上任何常数进行分类，则该变换将执行常量TYPE_IDENTITY或适用于各种坐标转换的相应标志位的组合。
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_TRANSLATION ， TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， TYPE_FLIP ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， getType() ， Constant Field Values

    • 构造方法详细信息

      • AffineTransform

        public AffineTransform​()
        构造一个新的 AffineTransform代表身份转换。
        从以下版本开始：
        1.2

      • AffineTransform

        public AffineTransform​(AffineTransform Tx)
        构造一个新的 AffineTransform ，它是一个指定的 AffineTransform对象的副本。
        参数
        Tx - 要复制的 AffineTransform对象
        从以下版本开始：
        1.2

      • AffineTransform

        @ConstructorProperties({"scaleX","shearY","shearX","scaleY","translateX","translateY"})
public AffineTransform​(float m00,
                       float m10,
                       float m01,
                       float m11,
                       float m02,
                       float m12)
        从6个浮点值构造新的 AffineTransform ，表示3x3变换矩阵的6个可指定条目。
        参数
        m00 - 3x3矩阵的X坐标缩放元素
        m10 - 3x3矩阵的Y坐标剪切元素
        m01 - 3x3矩阵的X坐标剪切元素
        m11 - 3x3矩阵的Y坐标缩放元素
        m02 - 3x3矩阵的X坐标转换元素
        m12 - 3x3矩阵的Y坐标转换元素
        从以下版本开始：
        1.2

      • AffineTransform

        public AffineTransform​(float[] flatmatrix)
        从表示3x3转换矩阵的4个非转换条目或6个可指定条目的浮点值数组构造新的AffineTransform 。 将值从数组中检索为{m00 m10 m01 m11 [m02 m12]}。
        参数
        flatmatrix - 包含要在新的AffineTransform对象中设置的值的float数组。 数组的长度假定为至少为4.如果数组的长度小于6，则仅取前4个值。 如果阵列的长度大于6，则采用前6个值。
        从以下版本开始：
        1.2

      • AffineTransform

        public AffineTransform​(double m00,
                       double m10,
                       double m01,
                       double m11,
                       double m02,
                       double m12)
        从6个双精度值构造新的 AffineTransform ，表示3x3变换矩阵的6个可指定条目。
        参数
        m00 - 3x3矩阵的X坐标缩放元素
        m10 - 3x3矩阵的Y坐标剪切元素
        m01 - 3x3矩阵的X坐标剪切元素
        m11 - 3x3矩阵的Y坐标缩放元素
        m02 - 3x3矩阵的X坐标转换元素
        m12 - 3x3矩阵的Y坐标转换元素
        从以下版本开始：
        1.2

      • AffineTransform

        public AffineTransform​(double[] flatmatrix)
        从表示3x3转换矩阵的4个非转换条目或6个可指定条目的双精度值数组构造新的AffineTransform 。 将值从数组中检索为{m00 m10 m01 m11 [m02 m12]}。
        参数
        flatmatrix - 包含要在新的AffineTransform对象中设置的值的双数组。 数组的长度假定为至少为4.如果数组的长度小于6，则仅取前4个值。 如果阵列的长度大于6，则采用前6个值。
        从以下版本开始：
        1.2

    • 方法详细信息

      • getTranslateInstance

        public static AffineTransform getTranslateInstance​(double tx,
                                                   double ty)
        返回表示平移变换的变换。 表示返回的变换的矩阵为：
          [   1    0    tx  ]
          [   0    1    ty  ]
          [   0    0    1   ]
        参数
        tx - 坐标在X轴方向上平移的距离
        ty - 坐标在Y轴方向上平移的距离
        结果
        一个 AffineTransform对象，表示使用指定向量创建的转换转换。
        从以下版本开始：
        1.2

      • getRotateInstance

        public static AffineTransform getRotateInstance​(double theta)
        返回表示旋转变换的变换。 表示返回的变换的矩阵为：
          [   cos(theta)    -sin(theta)    0   ]
          [   sin(theta)     cos(theta)    0   ]
          [       0              0         1   ]
        以正角度θ旋转正X轴上的点朝向正Y轴旋转。 另请注意上述Handling 90-Degree Rotations的讨论。
        参数
        theta - 以弧度测量的旋转角度
        结果
        一个 AffineTransform对象，它是以指定的旋转角度创建的旋转变换。
        从以下版本开始：
        1.2

      • getRotateInstance

        public static AffineTransform getRotateInstance​(double theta,
                                                double anchorx,
                                                double anchory)
        返回一个在锚点周围旋转坐标的变换。 该操作等效于平移坐标，使锚点位于原点（S1），然后绕新原点（S2）旋转它们，最后平移，使得中间原点恢复到原始锚点的坐标（S3）。

        此操作等同于以下呼叫序列：

          AffineTransform Tx = new AffineTransform();
     Tx.translate(anchorx, anchory);    // S3: final translation
     Tx.rotate(theta);                  // S2: rotate around anchor
     Tx.translate(-anchorx, -anchory);  // S1: translate anchor to origin
        表示返回的变换的矩阵为：
          [   cos(theta)    -sin(theta)    x-x*cos+y*sin  ]
          [   sin(theta)     cos(theta)    y-x*sin-y*cos  ]
          [       0              0               1        ]
        以正角度θ旋转正X轴上的点朝向正Y轴旋转。 另请注意上述Handling 90-Degree Rotations的讨论。
        参数
        theta - 以弧度测量的旋转角度
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        结果
        一个 AffineTransform对象，它将指定点周围的坐标旋转指定的旋转角度。
        从以下版本开始：
        1.2

      • getRotateInstance

        public static AffineTransform getRotateInstance​(double vecx,
                                                double vecy)
        返回一个根据旋转矢量旋转坐标的变换。 所有坐标以原点相同的数量旋转。 旋转量使得沿着前正X轴的坐标随后将与从原点指向矢量坐标的向量对齐。 如果vecx和vecy都为0.0，则返回身份转换。 此操作相当于调用：
          AffineTransform.getRotateInstance(Math.atan2(vecy, vecx));
        参数
        vecx - 旋转矢量的X坐标
        vecy - 旋转矢量的Y坐标
        结果
        一个 AffineTransform对象，根据指定的旋转矢量旋转坐标。
        从以下版本开始：
        1.6

      • getRotateInstance

        public static AffineTransform getRotateInstance​(double vecx,
                                                double vecy,
                                                double anchorx,
                                                double anchory)
        返回一个根据旋转向量旋转锚点周围的坐标点的变换。 所有坐标围绕指定的锚点坐标旋转相同的量。 旋转量使得沿着前正X轴的坐标随后将与从原点指向矢量坐标的向量对齐。 如果vecx和vecy都为0.0，则返回身份转换。 此操作相当于调用：
          AffineTransform.getRotateInstance(Math.atan2(vecy, vecx),
                                       anchorx, anchory);
        参数
        vecx - 旋转矢量的X坐标
        vecy - 旋转矢量的Y坐标
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        结果
        一个 AffineTransform对象，根据指定的旋转矢量旋转指定点附近的坐标。
        从以下版本开始：
        1.6

      • getQuadrantRotateInstance

        public static AffineTransform getQuadrantRotateInstance​(int numquadrants)
        返回一个将坐标旋转指定数量的象限的变换。 此操作相当于调用：
          AffineTransform.getRotateInstance(numquadrants * Math.PI / 2.0);
        旋转正数的象限将正X轴上的点向正Y轴旋转。
        参数
        numquadrants - 要旋转的90度弧数
        结果
        一个 AffineTransform对象，它将坐标旋转指定的象限数。
        从以下版本开始：
        1.6

      • getQuadrantRotateInstance

        public static AffineTransform getQuadrantRotateInstance​(int numquadrants,
                                                        double anchorx,
                                                        double anchory)
        返回一个转换，该变换将坐标指定指定锚点周围的指定数量的象限旋转。 此操作相当于调用：
          AffineTransform.getRotateInstance(numquadrants * Math.PI / 2.0,
                                       anchorx, anchory);
        旋转正数的象限将正X轴上的点向正Y轴旋转。
        参数
        numquadrants - 要旋转的90度弧数
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        结果
        一个 AffineTransform对象，它将坐标指定指定锚点周围的指定数量的象限旋转。
        从以下版本开始：
        1.6

      • getScaleInstance

        public static AffineTransform getScaleInstance​(double sx,
                                               double sy)
        返回表示缩放变换的变换。 表示返回的变换的矩阵为：
          [   sx   0    0   ]
          [   0    sy   0   ]
          [   0    0    1   ]
        参数
        sx - 坐标沿X轴方向缩放的因子
        sy - 坐标沿Y轴方向缩放的因子
        结果
        一个 AffineTransform对象，它根据指定的因素缩放坐标。
        从以下版本开始：
        1.2

      • getShearInstance

        public static AffineTransform getShearInstance​(double shx,
                                               double shy)
        返回代表剪切变换的变换。 表示返回的变换的矩阵为：
          [   1   shx   0   ]
          [  shy   1    0   ]
          [   0    0    1   ]
        参数
        shx - 坐标在正X轴方向上移位的乘数作为其Y坐标系数
        shy - 坐标沿正Y轴方向移动的乘数作为其X坐标系数
        结果
        一个 AffineTransform对象，通过指定的乘数剪切坐标。
        从以下版本开始：
        1.2

      • getType

        public int getType​()
        检索描述此转换的转换属性的标志位。 返回值是常量TYPE_IDENTITY或TYPE_GENERAL_TRANSFORM之一，或相应标志位的组合。 标志位的有效组合是除了TYPE_UNIFORM_SCALE或TYPE_GENERAL_SCALE标志位之外的TYPE_TRANSLATION标志位以及TYPE_QUADRANT_ROTATION或TYPE_GENERAL_ROTATION标志位之一之外的组合的异或运算。
        结果
        任何适用于此变换的指示标志的OR组合
        从以下版本开始：
        1.2
        另请参见：
        TYPE_IDENTITY ， TYPE_TRANSLATION ， TYPE_UNIFORM_SCALE ， TYPE_GENERAL_SCALE ， TYPE_QUADRANT_ROTATION ， TYPE_GENERAL_ROTATION ， TYPE_GENERAL_TRANSFORM

      • getDeterminant

        public double getDeterminant​()
        返回变换的矩阵表示的行列式。 决定因素对于确定变换是否可以被反转并且获得表示变换的组合X和Y缩放的单个值是有用的。

        如果行列式非零，则该变换是可逆的，并且依赖于逆变换的各种方法不需要抛出一个NoninvertibleTransformException 。 如果行列式为零，则该变换不能反转，因为变换将所有输入坐标映射到一行或一点上。 如果决定因素接近于零，那么逆变换操作可能不足以产生有意义的结果。

        如果这种变换表示统一的比例，如getType方法所示，则行列式也代表统一比例因子的平方，通过该平方，所有点都从原点扩展或收缩。 如果该变换表示不均匀的标度或更一般的变换，那么除了确定逆变换是否可能之外，行列式不可能表示用于任何目的的值。

        在数学上，行列式使用以下公式计算：

          |  m00  m01  m02  |
          |  m10  m11  m12  |  =  m00 * m11 - m01 * m10
          |   0    0    1   |
        结果
        用于转换坐标的矩阵的行列式。
        从以下版本开始：
        1.2
        另请参见：
        getType() ，
createInverse() ，
inverseTransform(java.awt.geom.Point2D, java.awt.geom.Point2D) ，
TYPE_UNIFORM_SCALE

      • getMatrix

        public void getMatrix​(double[] flatmatrix)
        检索3x3仿射变换矩阵中的6个可指定值，并将它们置于双重精度值的数组中。 这些值作为{m00 m10 m01 m11 m02 m12}存储在数组中。 也可以指定4个双精度数组，在这种情况下，仅检索表示阵列的非变换部分的前四个元素，并将值作为{m00 m10 m01 m11}存储到数组中
        参数
        flatmatrix - 用于存储返回值的double数组。
        从以下版本开始：
        1.2
        另请参见：
        getScaleX() ，
getScaleY() ，
getShearX() ，
getShearY() ，
getTranslateX() ，
getTranslateY()

      • getScaleX

        public double getScaleX​()
        返回3x3仿射变换矩阵的m00元素。 该矩阵因子确定输入X坐标如何影响输出X坐标，并且是变换尺度的一个元素。 要测量通过此转换拉伸或收缩X坐标的完整数量，请使用以下代码：
          Point2D p = new Point2D.Double(1, 0);
     p = tx.deltaTransform(p, p);
     double scaleX = p.distance(0, 0);
        结果
        一个双重值，即3x3仿射变换矩阵的 m00元素。
        从以下版本开始：
        1.2
        另请参见：
        getMatrix(double[])

      • getScaleY

        public double getScaleY​()
        返回3x3仿射变换矩阵的m11元素。 该矩阵因子确定输入Y坐标如何影响输出Y坐标，并且是变换标度的一个元素。 要测量通过此变换延伸或收缩Y坐标的全部数量，请使用以下代码：
          Point2D p = new Point2D.Double(0, 1);
     p = tx.deltaTransform(p, p);
     double scaleY = p.distance(0, 0);
        结果
        一个双重值，即3×3仿射变换矩阵的 m11元素。
        从以下版本开始：
        1.2
        另请参见：
        getMatrix(double[])

      • getShearX

        public double getShearX​()
        返回3x3仿射变换矩阵的X坐标剪切元素（m01）。
        结果
        作为仿射变换矩阵的剪切元素的X坐标的双重值。
        从以下版本开始：
        1.2
        另请参见：
        getMatrix(double[])

      • getShearY

        public double getShearY​()
        返回3x3仿射变换矩阵的Y坐标剪切元素（m10）。
        结果
        作为仿射变换矩阵的剪切元素的Y坐标的双重值。
        从以下版本开始：
        1.2
        另请参见：
        getMatrix(double[])

      • getTranslateX

        public double getTranslateX​()
        返回3x3仿射变换矩阵的平移元素（m02）的X坐标。
        结果
        一个双重值，它是仿射变换矩阵的平移元素的X坐标。
        从以下版本开始：
        1.2
        另请参见：
        getMatrix(double[])

      • getTranslateY

        public double getTranslateY​()
        返回3x3仿射变换矩阵的平移元素（m12）的Y坐标。
        结果
        作为仿射变换矩阵的平移元素的Y坐标的双重值。
        从以下版本开始：
        1.2
        另请参见：
        getMatrix(double[])

      • translate

        public void translate​(double tx,
                      double ty)
        将此转换与转换变换相结合。 这相当于调用连接（T），其中T是由以下矩阵表示的AffineTransform ：
          [   1    0    tx  ]
          [   0    1    ty  ]
          [   0    0    1   ]
        参数
        tx - 坐标在X轴方向上平移的距离
        ty - 坐标在Y轴方向上平移的距离
        从以下版本开始：
        1.2

      • rotate

        public void rotate​(double theta)
        使用旋转变换连接此变换。 这相当于调用连接（R），其中R是由以下矩阵表示的AffineTransform ：
          [   cos(theta)    -sin(theta)    0   ]
          [   sin(theta)     cos(theta)    0   ]
          [       0              0         1   ]
        以正角度θ旋转正X轴上的点朝向正Y轴旋转。 还要注意上述Handling 90-Degree Rotations的讨论。
        参数
        theta - 以弧度测量的旋转角度
        从以下版本开始：
        1.2

      • rotate

        public void rotate​(double theta,
                   double anchorx,
                   double anchory)
        将此变换与使锚点附近旋转坐标的变换相连。 该操作等效于平移坐标，使锚点位于原点（S1），然后绕新原点（S2）旋转它们，最后平移，使得中间原点恢复到原始锚点的坐标（S3）。

        此操作等同于以下呼叫序列：

          translate(anchorx, anchory);      // S3: final translation
     rotate(theta);                    // S2: rotate around anchor
     translate(-anchorx, -anchory);    // S1: translate anchor to origin
        以正角度θ旋转正X轴上的点朝向正Y轴旋转。 另请注意上述Handling 90-Degree Rotations的讨论。
        参数
        theta - 以弧度测量的旋转角度
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        从以下版本开始：
        1.2

      • rotate

        public void rotate​(double vecx,
                   double vecy)
        使用根据旋转矢量旋转坐标的变换来连接此变换。 所有坐标以原点相同的数量旋转。 旋转量使得沿着前正X轴的坐标随后将与从原点指向矢量坐标的向量对齐。 如果vecx和vecy都为0.0，则不会向此变换添加额外的旋转。 此操作相当于调用：
          rotate(Math.atan2(vecy, vecx));
        参数
        vecx - 旋转矢量的X坐标
        vecy - 旋转矢量的Y坐标
        从以下版本开始：
        1.6

      • rotate

        public void rotate​(double vecx,
                   double vecy,
                   double anchorx,
                   double anchory)
        使用根据旋转矢量围绕锚点旋转坐标的变换来连接此变换。 所有坐标围绕指定的锚点坐标旋转相同的量。 旋转量使得沿着前正X轴的坐标随后将与从原点指向矢量坐标的向量对齐。 如果vecx和vecy都为0.0，则不会以任何方式修改变换。 这个方法相当于调用：
          rotate(Math.atan2(vecy, vecx), anchorx, anchory);
        参数
        vecx - 旋转矢量的X坐标
        vecy - 旋转矢量的Y坐标
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        从以下版本开始：
        1.6

      • quadrantRotate

        public void quadrantRotate​(int numquadrants)
        使用将坐标旋转指定数量的象限的变换来连接此变换。 这相当于调用：
          rotate(numquadrants * Math.PI / 2.0);
        旋转正数的象限将正X轴上的点向正Y轴旋转。
        参数
        numquadrants - 要旋转的90度弧数
        从以下版本开始：
        1.6

      • quadrantRotate

        public void quadrantRotate​(int numquadrants,
                           double anchorx,
                           double anchory)
        使用将坐标旋转指定锚点周围指定数量的象限的变换来连接此变换。 这个方法相当于调用：
          rotate(numquadrants * Math.PI / 2.0, anchorx, anchory);
        旋转正数的象限将正X轴上的点向正Y轴旋转。
        参数
        numquadrants - 要旋转的90度弧数
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        从以下版本开始：
        1.6

      • scale

        public void scale​(double sx,
                  double sy)
        使用缩放变换连接此变换。 这相当于调用连接（S），其中S是由以下矩阵表示的AffineTransform ：
          [   sx   0    0   ]
          [   0    sy   0   ]
          [   0    0    1   ]
        参数
        sx - 坐标沿X轴方向缩放的因子
        sy - 坐标沿Y轴方向缩放的因子
        从以下版本开始：
        1.2

      • shear

        public void shear​(double shx,
                  double shy)
        将此变换与剪切变换相结合。 这相当于调用连接（SH），其中SH是由以下矩阵表示的AffineTransform ：
          [   1   shx   0   ]
          [  shy   1    0   ]
          [   0    0    1   ]
        参数
        shx - 坐标在正X轴方向上偏移的乘数作为其Y坐标系数
        shy - 坐标沿正Y轴方向移位的乘数作为其X坐标系数
        从以下版本开始：
        1.2

      • setToIdentity

        public void setToIdentity​()
        将此转换重置为Identity变换。
        从以下版本开始：
        1.2

      • setToTranslation

        public void setToTranslation​(double tx,
                             double ty)
        将此变换设置为转换变换。 表示该变换的矩阵变为：
          [   1    0    tx  ]
          [   0    1    ty  ]
          [   0    0    1   ]
        参数
        tx - 坐标在X轴方向上平移的距离
        ty - 坐标在Y轴方向上平移的距离
        从以下版本开始：
        1.2

      • setToRotation

        public void setToRotation​(double theta)
        将此变换设置为旋转变换。 表示该变换的矩阵变为：
          [   cos(theta)    -sin(theta)    0   ]
          [   sin(theta)     cos(theta)    0   ]
          [       0              0         1   ]
        以正角度θ旋转正X轴上的点朝向正Y轴旋转。 还要注意上述Handling 90-Degree Rotations的讨论。
        参数
        theta - 以弧度测量的旋转角度
        从以下版本开始：
        1.2

      • setToRotation

        public void setToRotation​(double theta,
                          double anchorx,
                          double anchory)
        将此转换设置为转换的旋转变换。 该操作等效于平移坐标，使锚点位于原点（S1），然后绕新原点（S2）旋转它们，最后平移，使得中间原点恢复到原始锚点的坐标（S3）。

        此操作等同于以下呼叫序列：

          setToTranslation(anchorx, anchory); // S3: final translation
     rotate(theta);                      // S2: rotate around anchor
     translate(-anchorx, -anchory);      // S1: translate anchor to origin
        表示该变换的矩阵变为：
          [   cos(theta)    -sin(theta)    x-x*cos+y*sin  ]
          [   sin(theta)     cos(theta)    y-x*sin-y*cos  ]
          [       0              0               1        ]
        以正角度θ旋转正X轴上的点朝向正Y轴旋转。 还要注意上述Handling 90-Degree Rotations的讨论。
        参数
        theta - 以弧度测量的旋转角度
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        从以下版本开始：
        1.2

      • setToRotation

        public void setToRotation​(double vecx,
                          double vecy)
        将此变换设置为根据旋转矢量旋转坐标的旋转变换。 所有坐标以原点相同的数量旋转。 旋转量使得沿着前正X轴的坐标随后将与从原点指向矢量坐标的向量对齐。 如果vecx和vecy都为0.0，则将变换设置为身份转换。 此操作相当于调用：
          setToRotation(Math.atan2(vecy, vecx));
        参数
        vecx - 旋转矢量的X坐标
        vecy - 旋转矢量的Y坐标
        从以下版本开始：
        1.6

      • setToRotation

        public void setToRotation​(double vecx,
                          double vecy,
                          double anchorx,
                          double anchory)
        将此变换设置为根据旋转向量旋转锚点周围的坐标的旋转变换。 所有坐标围绕指定的锚点坐标旋转相同的量。 旋转量使得沿着前正X轴的坐标随后将与从原点指向矢量坐标的向量对齐。 如果vecx和vecy都为0.0，则将变换设置为身份转换。 此操作相当于调用：
          setToTranslation(Math.atan2(vecy, vecx), anchorx, anchory);
        参数
        vecx - 旋转矢量的X坐标
        vecy - 旋转矢量的Y坐标
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        从以下版本开始：
        1.6

      • setToQuadrantRotation

        public void setToQuadrantRotation​(int numquadrants)
        将此变换设置为将坐标旋转指定数量的象限的旋转变换。 此操作相当于调用：
          setToRotation(numquadrants * Math.PI / 2.0);
        旋转正数的象限将正X轴上的点向正Y轴旋转。
        参数
        numquadrants - 要旋转的90度弧数
        从以下版本开始：
        1.6

      • setToQuadrantRotation

        public void setToQuadrantRotation​(int numquadrants,
                                  double anchorx,
                                  double anchory)
        将此转换设置为转换的旋转变换，该转换将坐标指定指定锚点周围的指定数量的象限旋转。 此操作相当于调用：
          setToRotation(numquadrants * Math.PI / 2.0, anchorx, anchory);
        旋转正数的象限将正X轴上的点向正Y轴旋转。
        参数
        numquadrants - 要旋转的90度弧数
        anchorx - 旋转锚点的X坐标
        anchory - 旋转锚点的Y坐标
        从以下版本开始：
        1.6

      • setToScale

        public void setToScale​(double sx,
                       double sy)
        将此变换设置为缩放变换。 表示该变换的矩阵变为：
          [   sx   0    0   ]
          [   0    sy   0   ]
          [   0    0    1   ]
        参数
        sx - 坐标沿X轴方向缩放的因子
        sy - 坐标沿Y轴方向缩放的因子
        从以下版本开始：
        1.2

      • setToShear

        public void setToShear​(double shx,
                       double shy)
        将此变换设置为剪切变换。 表示该变换的矩阵变为：
          [   1   shx   0   ]
          [  shy   1    0   ]
          [   0    0    1   ]
        参数
        shx - 坐标在正X轴方向上移动的乘数作为其Y坐标系数
        shy - 坐标在正Y轴的方向上作为其X坐标系数的乘数
        从以下版本开始：
        1.2

      • setTransform

        public void setTransform​(AffineTransform Tx)
        将此变换设置为指定的 AffineTransform对象中的变换副本。
        参数
        Tx - AffineTransform复制转换的 AffineTransform对象
        从以下版本开始：
        1.2

      • setTransform

        public void setTransform​(double m00,
                         double m10,
                         double m01,
                         double m11,
                         double m02,
                         double m12)
        将此变换设置为由6个双精度值指定的矩阵。
        参数
        m00 - 3x3矩阵的X坐标缩放元素
        m10 - 3x3矩阵的Y坐标剪切元素
        m01 - 3x3矩阵的X坐标剪切元素
        m11 - 3x3矩阵的Y坐标缩放元素
        m02 - 3x3矩阵的X坐标转换元素
        m12 - 3x3矩阵的Y坐标转换元素
        从以下版本开始：
        1.2

      • concatenate

        public void concatenate​(AffineTransform Tx)
        将AffineTransform Tx连接到这个AffineTransform Cx中，最常用的方式是提供一个映射到前一个用户空间的新用户空间Tx 。 Cx被更新以执行组合变换。 通过更新的变换Cx'转换点p等价于首先将p转换为Tx ，然后将结果转换为原始变换Cx，如下所示：Cx'（p）= Cx（Tx（p））以矩阵表示法，如果这样变换Cx由矩阵[this]表示， Tx由矩阵[Tx]表示，则该方法执行以下操作：
          [this] = [this] x [Tx]
        参数
        Tx -在 AffineTransform对象与此串接 AffineTransform对象。
        从以下版本开始：
        1.2
        另请参见：
        preConcatenate(java.awt.geom.AffineTransform)

      • preConcatenate

        public void preConcatenate​(AffineTransform Tx)
        串接的AffineTransform Tx本AffineTransform CX在一个不常用的方式，使得Tx坐标变换相对于绝对像素空间而不是相对于现有的用户空间修改。 Cx被更新以执行组合变换。 通过更新的变换Cx'转换点p等价于首先通过原始变换Cx变换p，然后将结果转换为Tx如下所示：Cx'（p）= Tx（Cx（p））以矩阵表示法，如果这样变换Cx由矩阵[this]表示， Tx由矩阵[Tx]表示，则该方法执行以下操作：
          [this] = [Tx] x [this]
        参数
        Tx -在 AffineTransform对象与此串接 AffineTransform对象。
        从以下版本开始：
        1.2
        另请参见：
        concatenate(java.awt.geom.AffineTransform)

      • createInverse

        public AffineTransform createInverse​()
                              throws NoninvertibleTransformException
        返回表示逆变换的AffineTransform对象。 该变换Tx的逆变换Tx'将由Tx变换的坐标映射回其原始坐标。 换句话说，Tx'（Tx（p））= p = Tx（Tx'（p））。

        如果这个变换将所有的坐标映射到一个点或一行上，那么它将不会有一个反向，因为不在目标点或线上的坐标将不具有逆映射。 可以使用getDeterminant方法来确定此变换是否没有反向，在这种情况下，如果调用了createInverse方法，将抛出异常。

        结果
        一个新的 AffineTransform对象表示逆变换。
        异常
        NoninvertibleTransformException - 如果矩阵不能被反转。
        从以下版本开始：
        1.2
        另请参见：
        getDeterminant()

      • invert

        public void invert​()
            throws NoninvertibleTransformException
        将此变换设置为本身的倒数。 该变换Tx的逆变换Tx'将由Tx变换的坐标映射回其原始坐标。 换句话说，Tx'（Tx（p））= p = Tx（Tx'（p））。

        如果这个变换将所有的坐标映射到一个点或一行上，那么它将不会有一个反向，因为不在目标点或线上的坐标将不具有逆映射。 可以使用getDeterminant方法确定此变换是否没有反向，在这种情况下，如果调用了invert方法，将抛出异常。

        异常
        NoninvertibleTransformException - 如果矩阵不能被反转。
        从以下版本开始：
        1.6
        另请参见：
        getDeterminant()

      • transform

        public Point2D transform​(Point2D ptSrc,
                         Point2D ptDst)
        转换指定的ptSrc并将结果存储在ptDst 。 如果ptDst为null ，则会分配一个新的Point2D对象，然后转换的结果存储在此对象中。 在任一情况下，为方便起见，返回包含转换点的ptDst 。 如果ptSrc和ptDst是相同的对象，则输入点被转换点正确覆盖。
        参数
        ptSrc - 要转换的指定的 Point2D
        ptDst - 指定的 Point2D存储转换结果 ptSrc
        结果
        ptDst转换 ptSrc ，并将结果存储在 ptDst 。
        从以下版本开始：
        1.2

      • transform

        public void transform​(Point2D[] ptSrc,
                      int srcOff,
                      Point2D[] ptDst,
                      int dstOff,
                      int numPts)
        通过此转换来转换点对象数组。 如果ptDst阵列的任何元素为null ，则在存储转换结果之前，将分配新的Point2D对象并将其存储到该元素中。

        请注意，该方法不采取任何预防措施，以避免将结果存储到将被用作源阵列进一步计算的源的Point2D对象中引起的问题。 该方法确保如果指定的Point2D对象既是同一个单点变换操作的源和目标，那么在计算完成之前，结果将不会被存储，以避免将结果存储在操作数之上。 然而，如果一个操作的目标Point2D对象与源Point2D对象相对应，对于进一步向下源数组的另一个操作，那么该点之前的原始坐标在被转换之前被覆盖。

        参数
        ptSrc - 包含源点对象的数组
        ptDst - 返回变换点对象的数组
        srcOff - 要在源数组中转换的第一个点对象的偏移量
        dstOff - 存储在目标数组中的第一个转换点对象位置的偏移量
        numPts - 要转换的点对象的数量
        从以下版本开始：
        1.2

      • transform

        public void transform​(float[] srcPts,
                      int srcOff,
                      float[] dstPts,
                      int dstOff,
                      int numPts)
        通过此变换来转换浮点坐标数组。 两个坐标阵列部分可以完全相同，也可以是相同阵列的重叠部分，而不影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为一对x，y坐标。
        dstPts - 返回转换点坐标的阵列。 每个点被存储为一对x，y坐标。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的积分数
        从以下版本开始：
        1.2

      • transform

        public void transform​(double[] srcPts,
                      int srcOff,
                      double[] dstPts,
                      int dstOff,
                      int numPts)
        通过此转换来转换双精度坐标数组。 两个坐标阵列部分可以完全相同，也可以是相同阵列的重叠部分，而不影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为一对x，y坐标。
        dstPts - 返回转换点坐标的数组。 每个点被存储为一对x，y坐标。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的点对象的数量
        从以下版本开始：
        1.2

      • transform

        public void transform​(float[] srcPts,
                      int srcOff,
                      double[] dstPts,
                      int dstOff,
                      int numPts)
        通过此转换来转换浮点坐标数组，并将结果存储到双精度数组中。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为一对x，y坐标。
        dstPts - 返回变换点坐标的数组。 每个点被存储为一对x，y坐标。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的点数
        从以下版本开始：
        1.2

      • transform

        public void transform​(double[] srcPts,
                      int srcOff,
                      float[] dstPts,
                      int dstOff,
                      int numPts)
        通过此转换来转换双精度坐标数组，并将结果存储到浮点数组中。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为一对x，y坐标。
        dstPts - 返回转换点坐标的阵列。 每个点被存储为一对x，y坐标。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的点对象的数量
        从以下版本开始：
        1.2

      • inverseTransform

        public Point2D inverseTransform​(Point2D ptSrc,
                                Point2D ptDst)
                         throws NoninvertibleTransformException
        反转换指定的ptSrc ，并将结果存储在ptDst 。 如果ptDst是null ，则会分配一个新的Point2D对象，然后将该转换的结果存储在该对象中。 在任一情况下，为方便起见，返回包含转换点的ptDst 。 如果ptSrc和ptDst是相同的对象，则输入点被转换点正确覆盖。
        参数
        ptSrc - 要进行逆变换的点
        ptDst - 得到的转化点
        结果
        ptDst ，其中包含逆变换的结果。
        异常
        NoninvertibleTransformException - 如果矩阵不能被反转。
        从以下版本开始：
        1.2

      • inverseTransform

        public void inverseTransform​(double[] srcPts,
                             int srcOff,
                             double[] dstPts,
                             int dstOff,
                             int numPts)
                      throws NoninvertibleTransformException
        通过此变换反向转换双精度坐标数组。 两个坐标阵列部分可以完全相同，也可以是相同阵列的重叠部分，而不影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源点坐标的数组。 每个点被存储为一对x，y坐标。
        dstPts - 返回转换点坐标的数组。 每个点被存储为一对x，y坐标。
        srcOff - 要在源数组中转换的第一个点的偏移量
        dstOff - 存储在目标数组中的第一个转换点的位置的偏移量
        numPts - 要转换的点对象的数量
        异常
        NoninvertibleTransformException - 如果矩阵不能被反转。
        从以下版本开始：
        1.2

      • deltaTransform

        public Point2D deltaTransform​(Point2D ptSrc,
                              Point2D ptDst)
        转换ptSrc指定的相对距离向量， ptSrc结果存储在ptDst 。 使用以下等式，不使用仿射变换矩阵的平移分量来变换相对距离矢量：
          [  x' ]   [  m00  m01 (m02) ] [  x  ]   [ m00x + m01y ]
  [  y' ] = [  m10  m11 (m12) ] [  y  ] = [ m10x + m11y ]
  [ (1) ]   [  (0)  (0) ( 1 ) ] [ (1) ]   [     (1)     ]
        如果ptDst是null ，则会分配一个新的Point2D对象，然后转换的结果存储在该对象中。 在这两种情况下，为方便起见，返回包含转换点的ptDst 。 如果ptSrc和ptDst是相同的对象，则输入点被转换点正确覆盖。
        参数
        ptSrc - 要进行delta变换的距离向量
        ptDst - 所得到的变换距离向量
        结果
        ptDst ，其中包含转换的结果。
        从以下版本开始：
        1.2

      • deltaTransform

        public void deltaTransform​(double[] srcPts,
                           int srcOff,
                           double[] dstPts,
                           int dstOff,
                           int numPts)
        通过该变换来变换相对距离向量的数组。 使用以下等式，不使用仿射变换矩阵的平移分量来变换相对距离矢量：
          [  x' ]   [  m00  m01 (m02) ] [  x  ]   [ m00x + m01y ]
  [  y' ] = [  m10  m11 (m12) ] [  y  ] = [ m10x + m11y ]
  [ (1) ]   [  (0)  (0) ( 1 ) ] [ (1) ]   [     (1)     ]
        两个坐标阵列部分可以完全相同，也可以是相同阵列的重叠部分，而不影响结果的有效性。 该方法确保在前一个操作可以被转换之前，不会覆盖源坐标。 坐标以[x0, y0, x1, y1, ..., xn, yn]的顺序从指定的偏移开始存储在阵列中。
        参数
        srcPts - 包含源距离向量的数组。 每个向量存储为一对相对的x，y坐标。
        dstPts - 返回变换的距离向量的阵列。 每个向量存储为一对相对的x，y坐标。
        srcOff - 要在源数组中转换的第一个向量的偏移量
        dstOff - 存储在目标数组中的第一个变换向量的位置的偏移量
        numPts - 要转换的向量坐标对的数量
        从以下版本开始：
        1.2

      • createTransformedShape

        public Shape createTransformedShape​(Shape pSrc)
        返回一个新Shape由指定的几何定义的对象Shape已通过此变换之后。
        参数
        pSrc - 要通过此转换转换的指定的 Shape对象。
        结果
        一个新的 Shape对象，它定义了转换后的 Shape的几何体，如果 pSrc为null，则为null。
        从以下版本开始：
        1.2

      • toString

        public String toString​()
        返回一个表示String的值的String 。
        重写：
        toString在 Object
        结果
        一个 String代表这个 Object的价值。
        从以下版本开始：
        1.2

      • isIdentity

        public boolean isIdentity​()
        返回 true如果这个 AffineTransform是一个身份转换。
        结果
        true如果这是AffineTransform是一个身份转换; 否则为false 。
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        返回此 AffineTransform对象的副本。
        重写：
        clone在 Object
        结果
        一个 Object是这个 AffineTransform对象的副本。
        从以下版本开始：
        1.2
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        返回此转换的哈希码。
        重写：
        hashCode在 Object
        结果
        用于此转换的哈希码。
        从以下版本开始：
        1.2
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        返回 true如果此 AffineTransform表示与指定参数相同的仿射坐标变换。
        重写：
        equals在 Object
        参数
        obj - Object以测试与这个 AffineTransform平等
        结果
        true如果obj等于这个AffineTransform对象; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Arc2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Arc2D

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Arc2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    Arc2D.Double ， Arc2D.Float

    public abstract class Arc2D
extends RectangularShape
    Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或PIE ）。

    The arc is a partial section of a full ellipse which inscribes the framing rectangle of its parent RectangularShape 。 The angles are specified relative to the non-square framing rectangle such that 45 degrees always falls on the line from the center of the ellipse to the upper right corner of the framing rectangle. As a result, if the framing rectangle is noticeably longer along one axis than the other, the angles to the start and end of the arc segment will be skewed farther along the longer axis of the frame.

    坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Arc2D.Double
      此类定义了 double精度中指定的弧。
      static class  Arc2D.Float
      此类定义了 float精度中指定的弧。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CHORD
      通过从弧段开始绘制直线段到弧段的末端，关闭电弧的闭合类型。
      static int OPEN
      用于开弧的闭合类型，没有连接弧段两端的路段。
      static int PIE
      通过将直线段从弧段开始到完全椭圆的中心并从该点到弧段的末端将闭合类型关闭。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Arc2D​()
      这是一个无法直接实例化的抽象类。
      protected Arc2D​(int type)
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean contains​(double x, double y)
      确定指定点是否在弧的边界内。
      boolean contains​(double x, double y, double w, double h)
      确定圆弧的内部是否完全包含指定的矩形。
      boolean contains​(Rectangle2D r)
      确定圆弧的内部是否完全包含指定的矩形。
      boolean containsAngle​(double angle)
      确定指定角度是否在弧的角度范围内。
      boolean equals​(Object obj)
      确定指定的 Object是否等于此 Arc2D 。
      abstract double getAngleExtent​()
      返回弧的角度范围。
      abstract double getAngleStart​()
      返回弧的起始角度。
      int getArcType​()
      返回弧的弧闭合类型： OPEN ， CHORD ，或 PIE 。
      Rectangle2D getBounds2D​()
      返回圆弧的高精度框架矩形。
      Point2D getEndPoint​()
      返回圆弧的终点。
      PathIterator getPathIterator​(AffineTransform at)
      返回定义圆弧边界的迭代对象。
      Point2D getStartPoint​()
      返回圆弧的起始点。
      int hashCode​()
      返回此 Arc2D的哈希 Arc2D 。
      boolean intersects​(double x, double y, double w, double h)
      确定圆弧的内部是否与指定矩形的内部相交。
      protected abstract Rectangle2D makeBounds​(double x, double y, double w, double h)
      构造一个适合精度的 Rectangle2D ，以将计算的参数保持为该弧的框架矩形。
      abstract void setAngleExtent​(double angExt)
      将此弧的角度范围设置为指定的双精度值。
      void setAngles​(double x1, double y1, double x2, double y2)
      使用两组坐标设置该弧的起始角度和角度范围。
      void setAngles​(Point2D p1, Point2D p2)
      使用两点设置此弧的起始角度和角度范围。
      abstract void setAngleStart​(double angSt)
      将此弧的起始角度设置为指定的双精度值。
      void setAngleStart​(Point2D p)
      将该弧的起始角度设置为指定点相对于该弧的中心定义的角度。
      abstract void setArc​(double x, double y, double w, double h, double angSt, double angExt, int closure)
      将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。
      void setArc​(Arc2D a)
      将此弧设置为与指定弧相同。
      void setArc​(Point2D loc, Dimension2D size, double angSt, double angExt, int closure)
      将该弧的位置，大小，角度范围和闭合类型设置为指定的值。
      void setArc​(Rectangle2D rect, double angSt, double angExt, int closure)
      将该弧的位置，大小，角度范围和闭合类型设置为指定的值。
      void setArcByCenter​(double x, double y, double radius, double angSt, double angExt, int closure)
      将此弧的位置，边界，角度范围和闭合类型设置为指定的值。
      void setArcByTangent​(Point2D p1, Point2D p2, Point2D p3, double radius)
      将该弧的位置，边界和角度范围设置为指定的值。
      void setArcType​(int type)
      将此弧为指定值的闭合类型： OPEN ， CHORD ，或 PIE 。
      void setFrame​(double x, double y, double w, double h)
      将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • OPEN

        public static final int OPEN
        用于开弧的闭合类型，没有连接弧段两端的路段。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • CHORD

        public static final int CHORD
        通过从弧段开始绘制直线段到弧段的末端，关闭电弧的闭合类型。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • PIE

        public static final int PIE
        通过将直线段从弧段开始到完全椭圆的中心并从该点到弧段的末端将闭合类型关闭。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Arc2D

        protected Arc2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。

        该构造函数创建一个默认关闭类型为OPEN的对象。 它仅用于启用子类的序列化。

        另请参见：
        Arc2D.Float ， Arc2D.Double

      • Arc2D

        protected Arc2D​(int type)
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        参数
        type -此弧的闭合类型： OPEN ， CHORD ，或 PIE 。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.Float ， Arc2D.Double

    • 方法详细信息

      • getAngleStart

        public abstract double getAngleStart​()
        返回弧的起始角度。
        结果
        表示圆弧起始角度（以度为单位）的双重值。
        从以下版本开始：
        1.2
        另请参见：
        setAngleStart(double)

      • getAngleExtent

        public abstract double getAngleExtent​()
        返回弧的角度范围。
        结果
        表示圆弧角度范围的双重值，以度为单位。
        从以下版本开始：
        1.2
        另请参见：
        setAngleExtent(double)

      • getArcType

        public int getArcType​()
        返回弧的弧闭合类型： OPEN ， CHORD ，或 PIE 。
        结果
        在此类中定义的整数常量闭包类型之一。
        从以下版本开始：
        1.2
        另请参见：
        setArcType(int)

      • getStartPoint

        public Point2D getStartPoint​()
        返回圆弧的起始点。 这一点是从起始角度和圆弧的椭圆边界定义的中心的交点。
        结果
        一个 Point2D对象，表示弧的起始点的x，y坐标。
        从以下版本开始：
        1.2

      • getEndPoint

        public Point2D getEndPoint​()
        返回圆弧的终点。 这一点是从起始角度加上弧的角度范围和弧的椭圆边界定义的中心的交点。
        结果
        表示圆弧终点的x，y坐标的物体 Point2D 。
        从以下版本开始：
        1.2

      • setArc

        public abstract void setArc​(double x,
                            double y,
                            double w,
                            double h,
                            double angSt,
                            double angExt,
                            int closure)
        将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。
        参数
        x - 圆弧左上角的X坐标。
        y - 圆弧左上角的Y坐标。
        w - 整个椭圆的整体宽度，其中该弧是部分截面。
        h - 整个椭圆的整体高度，其圆弧为部分截面。
        angSt - 圆弧的起始角度，以度为单位。
        angExt - 弧度的角度范围。
        closure -闭合型的弧线： OPEN ， CHORD ，或 PIE 。
        从以下版本开始：
        1.2

      • setArc

        public void setArc​(Point2D loc,
                   Dimension2D size,
                   double angSt,
                   double angExt,
                   int closure)
        将该弧的位置，大小，角度范围和闭合类型设置为指定的值。
        参数
        loc - 表示弧线左上角坐标的 Point2D 。
        size - Dimension2D表示其圆弧为部分截面的全椭圆的宽度和高度。
        angSt - 圆弧的起始角度，以度为单位。
        angExt - 弧度的角度范围。
        closure -闭合型的弧线： OPEN ， CHORD ，或 PIE 。
        从以下版本开始：
        1.2

      • setArc

        public void setArc​(Rectangle2D rect,
                   double angSt,
                   double angExt,
                   int closure)
        将该弧的位置，大小，角度范围和闭合类型设置为指定的值。
        参数
        rect - 定义整个椭圆的外边界的框架矩形，其中该弧是部分截面。
        angSt - 圆弧的起始角度，以度为单位。
        angExt - 弧度的角度范围。
        closure -闭合型的弧线： OPEN ， CHORD ，或 PIE 。
        从以下版本开始：
        1.2

      • setArc

        public void setArc​(Arc2D a)
        将此弧设置为与指定弧相同。
        参数
        a - 用于设置弧的值的 Arc2D 。
        从以下版本开始：
        1.2

      • setArcByCenter

        public void setArcByCenter​(double x,
                           double y,
                           double radius,
                           double angSt,
                           double angExt,
                           int closure)
        将此弧的位置，边界，角度范围和闭合类型设置为指定的值。 圆弧由中心点和半径而不是整个椭圆的框架矩形定义。
        参数
        x - 圆弧中心的X坐标。
        y - 圆弧中心的Y坐标。
        radius - 弧的半径。
        angSt - 圆弧的起始角度，以度为单位。
        angExt - 弧度的角度范围。
        closure -闭合型的弧线： OPEN ， CHORD ，或 PIE 。
        从以下版本开始：
        1.2

      • setArcByTangent

        public void setArcByTangent​(Point2D p1,
                            Point2D p2,
                            Point2D p3,
                            double radius)
        将该弧的位置，边界和角度范围设置为指定的值。 弧的起始角度与点（p1，p2）指定的线相切，终点与点（p2，p3）指定的线相切，弧线具有指定的半径。
        参数
        p1 - 定义弧的第一个点。 弧的起始角度与由点（p1，p2）指定的线相切。
        p2 - 第二个定义弧的点。 弧的起始角度与由点（p1，p2）指定的线相切。 弧的终止角与点（p2，p3）指定的线相切。
        p3 - 定义弧的第三点。 弧的终止角与点（p2，p3）指定的线相切。
        radius - 弧的半径。
        从以下版本开始：
        1.2

      • setAngleStart

        public abstract void setAngleStart​(double angSt)
        将此弧的起始角度设置为指定的双精度值。
        参数
        angSt - 圆弧的起始角度，以度为单位。
        从以下版本开始：
        1.2
        另请参见：
        getAngleStart()

      • setAngleExtent

        public abstract void setAngleExtent​(double angExt)
        将此弧的角度范围设置为指定的双精度值。
        参数
        angExt - 弧度的角度范围。
        从以下版本开始：
        1.2
        另请参见：
        getAngleExtent()

      • setAngleStart

        public void setAngleStart​(Point2D p)
        将该弧的起始角度设置为指定点相对于该弧的中心定义的角度。 电弧的角度范围将保持不变。
        参数
        p - 定义起始角度的 Point2D 。
        从以下版本开始：
        1.2
        另请参见：
        getAngleStart()

      • setAngles

        public void setAngles​(double x1,
                      double y1,
                      double x2,
                      double y2)
        使用两组坐标设置该弧的起始角度和角度范围。 第一组坐标用于确定起点相对于弧中心的角度。 第二组坐标用于确定终点相对于弧的中心的角度。 电弧始终为非空，并从第一个点到第二个点逆时针延伸。
        参数
        x1 - 弧起点的X坐标。
        y1 - 弧起点的Y坐标。
        x2 - 圆弧终点的X坐标。
        y2 - 圆弧终点的Y坐标。
        从以下版本开始：
        1.2

      • setAngles

        public void setAngles​(Point2D p1,
                      Point2D p2)
        使用两点设置此弧的起始角度和角度范围。 第一点用于确定起点相对于弧的中心的角度。 第二点用于确定终点相对于弧的中心的角度。 电弧始终为非空，并从第一个点到第二个点逆时针延伸。
        参数
        p1 - 定义弧线起点的 Point2D 。
        p2 - 定义圆弧终点的 Point2D 。
        从以下版本开始：
        1.2

      • setArcType

        public void setArcType​(int type)
        将此弧为指定值的闭合类型： OPEN ， CHORD ，或 PIE 。
        参数
        type -表示此弧的闭合类型的整数常量： OPEN ， CHORD ，或 PIE 。
        异常
        IllegalArgumentException - 如果 type不是0，1或2. +
        从以下版本开始：
        1.2
        另请参见：
        getArcType()

      • setFrame

        public void setFrame​(double x,
                     double y,
                     double w,
                     double h)
        将此Shape的成帧矩形的位置和大小设置为指定的矩形值。 注意弧partially inscribes这个框架矩形这个RectangularShape 。
        Specified by:
        setFrame在 RectangularShape
        参数
        x - 指定矩形左上角的X坐标
        y - 指定矩形左上角的Y坐标
        w - 指定矩形形状的宽度
        h - 指定长方形的高度
        从以下版本开始：
        1.2
        另请参见：
        RectangularShape.getFrame()

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回圆弧的高精度框架矩形。 框架矩形仅包含Arc2D的起始角度和结束角度之间的一部分，并包含饼形楔块，如果此Arc2D具有PIE封闭类型。

        此方法从不同getBounds ，所述getBounds方法只返回此的包围椭圆的边界Arc2D不考虑开始和结束这个角度Arc2D 。

        结果
        代表弧的框架矩形的 Rectangle2D 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()

      • makeBounds

        protected abstract Rectangle2D makeBounds​(double x,
                                          double y,
                                          double w,
                                          double h)
        构造一个适合精度的 Rectangle2D ，以将计算的参数保持为该弧的框架矩形。
        参数
        x - 框架矩形左上角的X坐标。
        y - 框架矩形左上角的Y坐标。
        w - 框架矩形的宽度。
        h - 框架矩形的高度。
        结果
        一个 Rectangle2D这是这个弧的框架矩形。
        从以下版本开始：
        1.2

      • containsAngle

        public boolean containsAngle​(double angle)
        确定指定角度是否在弧的角度范围内。
        参数
        angle - 要测试的角度。
        结果
        true如果电弧包含角度， false如果电弧不包含角度。
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(double x,
                        double y)
        确定指定点是否在弧的边界内。
        参数
        x - 要测试点的X坐标。
        y - 要测试点的Y坐标。
        结果
        true如果点位于弧线的范围内，如果该点位于弧线的边界之外， false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        确定圆弧的内部是否与指定矩形的内部相交。
        参数
        x - 矩形左上角的X坐标。
        y - 矩形左上角的Y坐标。
        w - 矩形的宽度。
        h - 矩形的高度。
        结果
        true如果圆弧与矩形相交，如果圆弧不与矩形相交， false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        确定圆弧的内部是否完全包含指定的矩形。
        参数
        x - 矩形左上角的X坐标。
        y - 矩形左上角的Y坐标。
        w - 矩形的宽度。
        h - 矩形的高度。
        结果
        true如果弧包含矩形， false如果弧不包含矩形。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(Rectangle2D r)
        确定圆弧的内部是否完全包含指定的矩形。
        Specified by:
        contains在接口 Shape
        重写：
        contains在 RectangularShape
        参数
        r - 要测试的 Rectangle2D 。
        结果
        true如果弧包含矩形， false如果弧不包含矩形。
        从以下版本开始：
        1.2
        另请参见：
        Shape.contains(double, double, double, double)

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回定义圆弧边界的迭代对象。 这个迭代器是多线程安全的。 Arc2D保证对弧的几何形状的修改不会影响已经处理的几何的任何迭代。
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标，则为空。
        结果
        A PathIterator定义了弧的边界。
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回此 Arc2D的哈希 Arc2D 。
        重写：
        hashCode在 Object
        结果
        这个 Arc2D的哈希 Arc2D 。
        从以下版本开始：
        1.6
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        确定指定的Object是否等于此Arc2D 。 指定Object等于该Arc2D ，如果它是一个实例Arc2D ，如果它的位置，大小，电弧程度和类型是相同的，因为这Arc2D 。
        重写：
        equals在 Object
        参数
        obj - 一个 Object要与这个 Arc2D进行比较。
        结果
        true如果obj是的一个实例Arc2D ，并且具有相同的值; false否则。
        从以下版本开始：
        1.6
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Arc2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Arc2D.Double

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Arc2D
        • java.awt.geom.Arc2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Arc2D

    public static class Arc2D.Double
extends Arc2D
implements Serializable
    此类定义了 double精度中指定的弧。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Arc2D

        Arc2D.Double, Arc2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double extent
      电弧的角度范围为度。
      double height
      整个椭圆的整体高度，其圆弧为部分剖面（不考虑角度范围）。
      double start
      电弧的起始角度以度为单位。
      double width
      整个椭圆的整个宽度，其圆弧是部分截面（不考虑角度范围）。
      double x
      圆弧框架矩形左上角的X坐标。
      double y
      圆弧框架矩形左上角的Y坐标。

      • Fields inherited from class java.awt.geom.Arc2D

        CHORD, OPEN, PIE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造一个新的OPEN弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）。
      Double​(double x, double y, double w, double h, double start, double extent, int type)
      构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
      Double​(int type)
      构造一个新弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）以及指定的闭合类型。
      Double​(Rectangle2D ellipseBounds, double start, double extent, int type)
      构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getAngleExtent​()
      返回弧的角度范围。
      double getAngleStart​()
      返回弧的起始角度。
      double getHeight​()
      返回 double精度的框架矩形的高度。
      double getWidth​()
      返回 double精度的成帧矩形的宽度。
      double getX​()
      返回 double精度的框架矩形左上角的X坐标。
      double getY​()
      返回 double精度的框架矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      protected Rectangle2D makeBounds​(double x, double y, double w, double h)
      构造一个适合精度的 Rectangle2D ，以将计算的参数保持为该弧的框架矩形。
      void setAngleExtent​(double angExt)
      将此弧的角度范围设置为指定的双精度值。
      void setAngleStart​(double angSt)
      将此弧的起始角度设置为指定的双精度值。
      void setArc​(double x, double y, double w, double h, double angSt, double angExt, int closure)
      将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。

      • Methods inherited from class java.awt.geom.Arc2D

        contains, contains, contains, containsAngle, equals, getArcType, getBounds2D, getEndPoint, getPathIterator, getStartPoint, hashCode, intersects, setAngles, setAngles, setAngleStart, setArc, setArc, setArc, setArcByCenter, setArcByTangent, setArcType, setFrame

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • x

        public double x
        圆弧框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • y

        public double y
        圆弧框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • width

        public double width
        整个椭圆的整个宽度，其圆弧是部分截面（不考虑角度范围）。
        从以下版本开始：
        1.2

      • height

        public double height
        整个椭圆的整体高度，其圆弧为部分剖面（不考虑角度范围）。
        从以下版本开始：
        1.2

      • start

        public double start
        电弧的起始角度以度为单位。
        从以下版本开始：
        1.2

      • extent

        public double extent
        电弧的角度范围为度。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        构造一个新的OPEN弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）。
        从以下版本开始：
        1.2

      • Double

        public Double​(int type)
        构造一个新弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）以及指定的闭合类型。
        参数
        type -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x,
              double y,
              double w,
              double h,
              double start,
              double extent,
              int type)
        构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
        参数
        x - 圆弧框架矩形左上角的X坐标。
        y - 圆弧框架矩形左上角的Y坐标。
        w - 整个椭圆的整体宽度，其中该弧是部分截面。
        h - 整个椭圆的整体高度，其中该弧为部分截面。
        start - 圆弧的起始角度，以度为单位。
        extent - 弧度的角度范围。
        type -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

      • Double

        public Double​(Rectangle2D ellipseBounds,
              double start,
              double extent,
              int type)
        构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
        参数
        ellipseBounds - 定义整个椭圆的外边界的框架矩形，其中该弧是部分截面。
        start - 圆弧的起始角度，以度为单位。
        extent - 弧度的角度范围。
        type -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        返回double精度的框架矩形左上角的X坐标。 需要注意的是圆弧partially inscribes本的框架矩形RectangularShape 。
        Specified by:
        getX在 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回double精度的框架矩形左上角的Y坐标。 请注意，这个RectangularShape的框架矩形弧RectangularShape 。
        Specified by:
        getY在 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        以double精度返回框架矩形的宽度。 请注意，这个RectangularShape的框架矩形RectangularShape 。
        Specified by:
        getWidth在 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        返回double精度的成帧矩形的高度。 请注意，弧partially inscribes这个框架矩形这个RectangularShape 。
        Specified by:
        getHeight在类 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • getAngleStart

        public double getAngleStart​()
        返回弧的起始角度。
        Specified by:
        getAngleStart在 Arc2D
        结果
        表示圆弧起始角度（以度为单位）的双重值。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.setAngleStart(double)

      • getAngleExtent

        public double getAngleExtent​()
        返回弧的角度范围。
        Specified by:
        getAngleExtent在 Arc2D
        结果
        表示圆弧角度范围的双重值，以度为单位。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.setAngleExtent(double)

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，它不包含任何区域。
        Specified by:
        isEmpty在 RectangularShape
        结果
        true如果RectangularShape是空的; false否则。
        从以下版本开始：
        1.2

      • setArc

        public void setArc​(double x,
                   double y,
                   double w,
                   double h,
                   double angSt,
                   double angExt,
                   int closure)
        将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。
        Specified by:
        setArc在 Arc2D
        参数
        x - 圆弧左上角的X坐标。
        y - 圆弧左上角的Y坐标。
        w - 整个椭圆的整体宽度，其中该弧为部分截面。
        h - 整个椭圆的整体高度，其中该弧为部分截面。
        angSt - 圆弧的起始角度，以度为单位。
        angExt - 弧度的角度范围。
        closure -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

      • setAngleStart

        public void setAngleStart​(double angSt)
        将此弧的起始角度设置为指定的双精度值。
        Specified by:
        setAngleStart在 Arc2D
        参数
        angSt - 圆弧的起始角度，以度为单位。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.getAngleStart()

      • setAngleExtent

        public void setAngleExtent​(double angExt)
        将此弧的角度范围设置为指定的双精度值。
        Specified by:
        setAngleExtent在 Arc2D
        参数
        angExt - 弧度的角度范围。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.getAngleExtent()

      • makeBounds

        protected Rectangle2D makeBounds​(double x,
                                 double y,
                                 double w,
                                 double h)
        构造一个适合精度的 Rectangle2D ，以将计算的参数保存为该弧的框架矩形。
        Specified by:
        makeBounds在类 Arc2D
        参数
        x - 框架矩形左上角的X坐标。
        y - 框架矩形左上角的Y坐标。
        w - 框架矩形的宽度。
        h - 框架矩形的高度。
        结果
        一个 Rectangle2D是这个弧的框架矩形。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Arc2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Arc2D.Float

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Arc2D
        • java.awt.geom.Arc2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Arc2D

    public static class Arc2D.Float
extends Arc2D
implements Serializable
    此类定义了 float精度中指定的弧。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Arc2D

        Arc2D.Double, Arc2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float extent
      电弧的角度范围为度。
      float height
      整个椭圆的整体高度，其圆弧为部分剖面（不考虑角度范围）。
      float start
      电弧的起始角度以度为单位。
      float width
      整个椭圆的整个宽度，其圆弧是部分截面（不考虑角度范围）。
      float x
      圆弧框架矩形左上角的X坐标。
      float y
      圆弧框架矩形左上角的Y坐标。

      • Fields inherited from class java.awt.geom.Arc2D

        CHORD, OPEN, PIE

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造一个新的OPEN弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）。
      Float​(float x, float y, float w, float h, float start, float extent, int type)
      构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
      Float​(int type)
      构造一个新弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）以及指定的闭合类型。
      Float​(Rectangle2D ellipseBounds, float start, float extent, int type)
      构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getAngleExtent​()
      返回弧的角度范围。
      double getAngleStart​()
      返回弧的起始角度。
      double getHeight​()
      以 double精度返回框架矩形的高度。
      double getWidth​()
      以 double精度返回框架矩形的宽度。
      double getX​()
      以 double精度返回框架矩形左上角的X坐标。
      double getY​()
      以 double精度返回成帧矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      protected Rectangle2D makeBounds​(double x, double y, double w, double h)
      构造一个适合精度的 Rectangle2D ，以将计算的参数保存为该弧的框架矩形。
      void setAngleExtent​(double angExt)
      将此弧的角度范围设置为指定的双精度值。
      void setAngleStart​(double angSt)
      将此弧的起始角度设置为指定的双精度值。
      void setArc​(double x, double y, double w, double h, double angSt, double angExt, int closure)
      将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。

      • Methods inherited from class java.awt.geom.Arc2D

        contains, contains, contains, containsAngle, equals, getArcType, getBounds2D, getEndPoint, getPathIterator, getStartPoint, hashCode, intersects, setAngles, setAngles, setAngleStart, setArc, setArc, setArc, setArcByCenter, setArcByTangent, setArcType, setFrame

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • x

        public float x
        圆弧框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • y

        public float y
        圆弧框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • width

        public float width
        整个椭圆的整个宽度，其圆弧是部分截面（不考虑角度范围）。
        从以下版本开始：
        1.2

      • height

        public float height
        整个椭圆的整体高度，其圆弧为部分剖面（不考虑角度范围）。
        从以下版本开始：
        1.2

      • start

        public float start
        电弧的起始角度以度为单位。
        从以下版本开始：
        1.2

      • extent

        public float extent
        电弧的角度范围为度。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造一个新的OPEN弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）。
        从以下版本开始：
        1.2

      • Float

        public Float​(int type)
        构造一个新弧，初始化为位置（0,0），大小（0,0），角度范围（起始= 0，范围= 0）以及指定的闭合类型。
        参数
        type -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x,
             float y,
             float w,
             float h,
             float start,
             float extent,
             int type)
        构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
        参数
        x - 圆弧框架矩形左上角的X坐标。
        y - 圆弧框架矩形左上角的Y坐标。
        w - 整个椭圆的整体宽度，其中该弧为部分截面。
        h - 整个椭圆的整体高度，其圆弧为部分截面。
        start - 圆弧的起始角度，以度为单位。
        extent - 弧度的角度范围。
        type -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

      • Float

        public Float​(Rectangle2D ellipseBounds,
             float start,
             float extent,
             int type)
        构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
        参数
        ellipseBounds - 定义整个椭圆的外边界的框架矩形，其中该弧是部分截面。
        start - 圆弧的起始角度，以度为单位。
        extent - 弧度的角度范围。
        type -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        返回double精度的框架矩形左上角的X坐标。 请注意，这个RectangularShape的框架矩形弧RectangularShape 。
        Specified by:
        getX在类 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回double精度的框架矩形左上角的Y坐标。 注意，这个RectangularShape的框架矩形RectangularShape 。
        Specified by:
        getY在类 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        返回double精度的框架矩形的宽度。 请注意，这个RectangularShape的框架矩形弧RectangularShape 。
        Specified by:
        getWidth在 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        以double精度返回框架矩形的高度。 请注意，这个RectangularShape的框架矩形弧RectangularShape 。
        Specified by:
        getHeight在 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • getAngleStart

        public double getAngleStart​()
        返回弧的起始角度。
        Specified by:
        getAngleStart在类 Arc2D
        结果
        表示圆弧起始角度（以度为单位）的双重值。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.setAngleStart(double)

      • getAngleExtent

        public double getAngleExtent​()
        返回弧的角度范围。
        Specified by:
        getAngleExtent在 Arc2D
        结果
        表示圆弧角度范围的双重值，以度为单位。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.setAngleExtent(double)

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，它不包含任何区域。
        Specified by:
        isEmpty在 RectangularShape
        结果
        true如果RectangularShape是空的; false否则。
        从以下版本开始：
        1.2

      • setArc

        public void setArc​(double x,
                   double y,
                   double w,
                   double h,
                   double angSt,
                   double angExt,
                   int closure)
        将此弧的位置，大小，角度范围和闭合类型设置为指定的双精度值。
        Specified by:
        setArc在 Arc2D
        参数
        x - 圆弧左上角的X坐标。
        y - 圆弧左上角的Y坐标。
        w - 整个椭圆的整体宽度，这个圆弧是部分截面。
        h - 整个椭圆的整体高度，其中该弧是部分截面。
        angSt - 圆弧的起始角度，以度为单位。
        angExt - 弧度的角度范围。
        closure -闭合型的弧线： Arc2D.OPEN ， Arc2D.CHORD ，或 Arc2D.PIE 。
        从以下版本开始：
        1.2

      • setAngleStart

        public void setAngleStart​(double angSt)
        将此弧的起始角度设置为指定的双精度值。
        Specified by:
        setAngleStart在 Arc2D
        参数
        angSt - 圆弧的起始角度，以度为单位。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.getAngleStart()

      • setAngleExtent

        public void setAngleExtent​(double angExt)
        将此弧的角度范围设置为指定的双精度值。
        Specified by:
        setAngleExtent中的 Arc2D
        参数
        angExt - 弧度的角度范围。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D.getAngleExtent()

      • makeBounds

        protected Rectangle2D makeBounds​(double x,
                                 double y,
                                 double w,
                                 double h)
        构造一个适合精度的 Rectangle2D ，以将计算的参数保存为该弧的框架矩形。
        Specified by:
        makeBounds在 Arc2D
        参数
        x - 框架矩形左上角的X坐标。
        y - 框架矩形左上角的Y坐标。
        w - 框架矩形的宽度。
        h - 框架矩形的高度。
        结果
        一个 Rectangle2D是这个弧的框架矩形。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Area (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Area

  • java.lang.Object
    • java.awt.geom.Area
  • All Implemented Interfaces:
    Shape ， Cloneable

    public class Area
extends Object
implements Shape, Cloneable
    Area对象存储和操纵对二维空间的封闭区域的分辨率独立描述。 Area对象可以被转化，并且当与其它组合可以执行各种建设性区域几何形状（CAG）操作Area对象。 该CAG操作包括区域addition ， subtraction ， intersection ，并exclusive or 。 有关各种操作的示例，请参阅链接方法文档。

    Area类实现了Shape接口，并提供了对所有命中测试和路径迭代功能的全面支持，但是Area在多种方式中比通用路径更具体：

    • 只存储封闭的路径和子路径。 Area从未封闭路径构造的对象在构造过程中隐式关闭，就好像这些路径已经被Graphics2D.fill方法填充了Graphics2D.fill 。
    • 各个存储的子路径的内部都是非空的且不重叠的。 路径在构建过程中被分解为单独的组件非重叠部分，路径的空块被丢弃，然后通过所有后续CAG操作来维护这些非空和不重叠的属性。 不同组件子路径的轮廓可以互相接触，只要它们不交叉，使得它们的封闭区域重叠。
    • 描述Area的轮廓的路径的几何形状类似于构造它的路径，只是它描述了相同的封闭的二维区域，但是可能使用完全不同的类型和路径段的顺序来实现。
    使用Area时并不总是很明显的有趣问题包括：
    • Area关闭（打开） Shape创建Shape导致Area对象中的封闭轮廓。
    • 从Shape创建一个Area ，它不包含任何区域（即使当“关闭”）生成一个空的Area 。 这个问题的一个常见的例子是，从行生成Area将是空的，因为该行不包含任何区域。 空的Area将在其PathIterator对象中不迭代几何。
    • 自相交Shape可以被分成两个（或更多个）子路径，每个子路径包围原始路径的不相交部分之一。
    • 即使原始轮廓简单明了， Area也可能需要更多的路径段来描述相同的几何形状。 Area课程必须在道路上进行的分析可能不会反映出人类感觉到的“简单明了”的概念。
    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      Area​()
      创建空区域的默认构造函数。
      Area​(Shape s)
      Area类从指定的Shape对象创建区域几何。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void add​(Area rhs)
      添加指定的形状 Area这种形状 Area 。
      Object clone​()
      返回此 Area对象的精确副本。
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      boolean contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      Area createTransformedArea​(AffineTransform t)
      创建一个新的 Area对象，该对象包含与指定的 AffineTransform转换的 Area相同的几何。
      boolean equals​(Area other)
      测试两个 Area对象的几何是否相等。
      void exclusiveOr​(Area rhs)
      设置此的形状 Area是其当前形状的组合区域和指定的形状 Area ，减去其交集。
      Rectangle getBounds​()
      返回边界Rectangle完全包围此Area 。
      Rectangle2D getBounds2D​()
      返回一个高精度的边界Rectangle2D完全包围此Area 。
      PathIterator getPathIterator​(AffineTransform at)
      为此Area对象的轮廓创建一个PathIterator 。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      为这个 Area对象的扁平轮廓创建一个 PathIterator 。
      void intersect​(Area rhs)
      将这个 Area的形状设置为其当前形状和指定的形状 Area 。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      boolean isEmpty​()
      测试此 Area对象是否包围任何区域。
      boolean isPolygonal​()
      测试这个 Area是否完全由直边多边形几何组成。
      boolean isRectangular​()
      测试这个 Area是否是矩形的。
      boolean isSingular​()
      测试这个 Area是否由一个封闭的子路径组成。
      void reset​()
      从这个 Area删除所有几何图形并将其还原到空白区域。
      void subtract​(Area rhs)
      减去指定的形状 Area从这个形状 Area 。
      void transform​(AffineTransform t)
      使用指定的AffineTransform转换Area的几何。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Area

        public Area​()
        创建空区域的默认构造函数。
        从以下版本开始：
        1.2

      • Area

        public Area​(Shape s)
        Area类从指定的Shape对象创建区域几何。 如果Shape尚未关闭，几何体将被明确关闭。 由Shape的几何形状指定的填充规则（偶数或绕组）用于确定产生的封闭区域。
        参数
        s - 建造该地区的 Shape
        异常
        NullPointerException - 如果 s为空
        从以下版本开始：
        1.2

    • 方法详细信息

      • add

        public void add​(Area rhs)
        添加指定的形状Area这种形状Area 。 由此形成的Area将包含两种形状的联合，或包含在此或指定的Area所有区域。
          // Example:
     Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
     Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
     a1.add(a2);

        a1(before)     +         a2         =     a1(after)

     ################     ################     ################
     ##############         ##############     ################
     ############             ############     ################
     ##########                 ##########     ################
     ########                     ########     ################
     ######                         ######     ######    ######
     ####                             ####     ####        ####
     ##                                 ##     ##            ##
        参数
        rhs - 要添加到当前形状的 Area
        异常
        NullPointerException - 如果 rhs为空
        从以下版本开始：
        1.2

      • subtract

        public void subtract​(Area rhs)
        Area的形状中减去指定的形状Area 。 由此形成的Area将包含仅在此Area而不是在指定的Area中的Area 。
          // Example:
     Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
     Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
     a1.subtract(a2);

        a1(before)     -         a2         =     a1(after)

     ################     ################
     ##############         ##############     ##
     ############             ############     ####
     ##########                 ##########     ######
     ########                     ########     ########
     ######                         ######     ######
     ####                             ####     ####
     ##                                 ##     ##
        参数
        rhs - 要从当前形状中减去的 Area
        异常
        NullPointerException - 如果 rhs为空
        从以下版本开始：
        1.2

      • intersect

        public void intersect​(Area rhs)
        将此Area的形状设置为其当前形状和指定的形状Area 。 由此形成的Area将仅包含Area和指定的Area中包含的区域。
          // Example:
     Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
     Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
     a1.intersect(a2);

      a1(before)   intersect     a2         =     a1(after)

     ################     ################     ################
     ##############         ##############       ############
     ############             ############         ########
     ##########                 ##########           ####
     ########                     ########
     ######                         ######
     ####                             ####
     ##                                 ##
        参数
        rhs -在 Area与此相交 Area
        异常
        NullPointerException - 如果 rhs为空
        从以下版本开始：
        1.2

      • exclusiveOr

        public void exclusiveOr​(Area rhs)
        设置此的形状Area是其当前形状的组合区域和指定的形状Area ，减去其交集。 由此形成的Area将仅包含Area或指定的Area中包含的区域，但不包括在两者中。
          // Example:
     Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
     Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
     a1.exclusiveOr(a2);

        a1(before)    xor        a2         =     a1(after)

     ################     ################
     ##############         ##############     ##            ##
     ############             ############     ####        ####
     ##########                 ##########     ######    ######
     ########                     ########     ################
     ######                         ######     ######    ######
     ####                             ####     ####        ####
     ##                                 ##     ##            ##
        参数
        rhs - Area要与这个 Area独家ORed。
        异常
        NullPointerException - 如果 rhs为空
        从以下版本开始：
        1.2

      • reset

        public void reset​()
        从这个 Area删除所有几何图形，并将其还原到一个空白区域。
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        测试此 Area对象是否包围任何区域。
        结果
        true如果此Area对象表示空白区域; 否则为false 。
        从以下版本开始：
        1.2

      • isPolygonal

        public boolean isPolygonal​()
        测试这个 Area是否完全由直边多边形几何组成。
        结果
        true如果这个Area的几何完全由线段组成; 否则为false 。
        从以下版本开始：
        1.2

      • isRectangular

        public boolean isRectangular​()
        测试这个 Area是否是矩形的。
        结果
        true如果这个Area的几何形状是矩形的; 否则为false 。
        从以下版本开始：
        1.2

      • isSingular

        public boolean isSingular​()
        测试这个Area是否由一个封闭的子路径组成。 此方法返回true如果路径中包含0或1的子路径，或false如果路径中包含多个子路径1。 这些子路径由路径中出现的SEG_MOVETO段计数。
        结果
        true如果Area由单个基本几何构成; 否则为false 。
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回一个高精度的边界Rectangle2D完全包围此Area 。

        Area类将尝试返回Shape的最紧密的边界框。 边框不会被填充以包括Shape的轮廓中的曲线的控制点，但应紧密地适合轮廓本身的实际几何。

        Specified by:
        getBounds2D在接口 Shape
        结果
        边界 Rectangle2D为 Area 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()

      • getBounds

        public Rectangle getBounds​()
        返回边界Rectangle完全包围此Area 。

        Area类将尝试返回Shape的最紧密的边界框。 边框不会被填充以包括Shape的轮廓中的曲线的控制点，但应紧密地适合轮廓本身的实际几何。 由于返回的对象表示具有整数的边界框，边界框只能与包含Shape几何的最接近的整数坐标一样紧。

        Specified by:
        getBounds在接口 Shape
        结果
        边界 Rectangle为 Area 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds2D()

      • clone

        public Object clone​()
        返回此 Area对象的精确副本。
        重写：
        clone在 Object
        结果
        创建克隆对象
        从以下版本开始：
        1.2
        另请参见：
        Cloneable

      • equals

        public boolean equals​(Area other)
        测试两个Area对象的几何是否相等。 如果参数为null，此方法将返回false。
        参数
        other -在 Area被比作此 Area
        结果
        true如果两个几何相等; 否则为false 。
        从以下版本开始：
        1.2

      • transform

        public void transform​(AffineTransform t)
        使用指定的AffineTransform转换Area的几何。 几何被转换到位，永久地改变由该对象定义的封闭区域。
        参数
        t - 用于转换区域的转换
        异常
        NullPointerException - 如果 t为空
        从以下版本开始：
        1.2

      • createTransformedArea

        public Area createTransformedArea​(AffineTransform t)
        创建一个新的Area对象，其中包含与指定的AffineTransform转换的Area相同的几何。 这个Area对象没有变化。
        参数
        t - 指定的 AffineTransform用于转换新的 Area
        结果
        一个新的 Area对象，表示转换的几何。
        异常
        NullPointerException - 如果 t为空
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        Specified by:
        contains在接口 Shape
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标在Shape边界内; 否则为false 。
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(Point2D p)
        测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
        Specified by:
        contains在接口 Shape
        参数
        p - 要测试的指定 Point2D
        结果
        true如果指定Point2D是的边界内Shape ; 否则为false 。
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标都必须位于Shape内，整个矩形区域都包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false时：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回false即使Shape包含矩形区域。 Area类比大多数Shape对象执行更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则，或者如果Shape包含矩形区域，并且intersects方法返回true并且遏制计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(Rectangle2D r)
        测试Shape的内部Shape全部包含指定的Rectangle2D 。 Shape.contains()方法允许Shape实现保守返回false当：
        • intersect方法返回true和
        • 确定Shape是否完全包含Rectangle2D是非常昂贵的。
        这意味着对于一些Shapes这个方法可能会返回false即使Shape包含Rectangle2D 。 Area类比大多数Shape对象执行更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果内部的Shape完全包含Rectangle2D ; false否则或如果Shape包含Rectangle2D和intersects方法返回true并且遏制计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Shape.contains(double, double, double, double)

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 如果任何点包含在Shape的内部和指定的矩形区域中，则矩形区域被认为与Shape相交。

        Shape.intersects()方法允许Shape实现保守返回true时：

        • 矩形区域与Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回true即使矩形区域不与Shape相交。 Area类比大多数Shape对象执行几何交集的更精确的计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者很可能相交，并且交叉点计算将太昂贵，不能执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • intersects

        public boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许Shape实现保守返回true时：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回true即使Rectangle2D不相交Shape 。 Area类比大多数Shape对象执行几何交叉的更精确的计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的内部Rectangle2D相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.intersects(double, double, double, double)

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        为此Area对象的轮廓创建一个PathIterator 。 此Area对象不变。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        结果
        PathIterator对象返回此 Area的轮廓的几何，一次一个段。
        从以下版本开始：
        1.2

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at,
                                    double flatness)
        为此Area对象的扁平轮廓创建一个PathIterator 。 由SEG_MOVETO，SEG_LINETO和SEG_CLOSE点类型表示的未曲线的路径段仅由迭代器返回。 这个Area对象没有变化。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        flatness - 给定曲线的控制点的最大量可以在共线之前变化，而细分曲线由连接终点的直线代替
        结果
        PathIterator对象返回此 Area的轮廓的几何，一次一个段。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CubicCurve2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class CubicCurve2D

  • java.lang.Object
    • java.awt.geom.CubicCurve2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    CubicCurve2D.Double ， CubicCurve2D.Float

    public abstract class CubicCurve2D
extends Object
implements Shape, Cloneable
    CubicCurve2D类定义了(x,y)坐标空间中的三次参数曲线段。

    该类只是存储二维立方曲线段的所有对象的抽象超类。 坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  CubicCurve2D.Double
      用 double坐标指定的三次参数曲线段。
      static class  CubicCurve2D.Float
      用 float坐标指定的三次参数曲线段。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected CubicCurve2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建与此对象相同类的新对象。
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      boolean contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      Rectangle getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      abstract Point2D getCtrlP1​()
      返回第一个控制点。
      abstract Point2D getCtrlP2​()
      返回第二个控制点。
      abstract double getCtrlX1​()
      以双精度返回第一个控制点的X坐标。
      abstract double getCtrlX2​()
      以双精度返回第二个控制点的X坐标。
      abstract double getCtrlY1​()
      以双精度返回第一个控制点的Y坐标。
      abstract double getCtrlY2​()
      以双精度返回第二个控制点的Y坐标。
      double getFlatness​()
      返回该曲线的平坦度。
      static double getFlatness​(double[] coords, int offset)
      返回由指定的数组中指定的索引处存储的控制点指定的三次曲线的平坦度。
      static double getFlatness​(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2)
      返回由指示的控制点指定的三次曲线的平坦度。
      double getFlatnessSq​()
      返回该曲线的平坦度的平方。
      static double getFlatnessSq​(double[] coords, int offset)
      返回由指定的数组中存储的指示索引指定的控制点指定的三次曲线的平坦度的平方。
      static double getFlatnessSq​(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2)
      返回由指示的控制点指定的三次曲线的平坦度的平方。
      abstract Point2D getP1​()
      返回起始点。
      abstract Point2D getP2​()
      返回终点。
      PathIterator getPathIterator​(AffineTransform at)
      返回定义形状边界的迭代对象。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回定义展平形状边界的迭代对象。
      abstract double getX1​()
      200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
      abstract double getX2​()
      X-
      abstract double getY1​()
      新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
      abstract double getY2​()
      以双精度返回终点的Y坐标。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      void setCurve​(double[] coords, int offset)
      将该曲线的终点和控制点的位置设置为指定数组中指定偏移处的双坐标。
      abstract void setCurve​(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2)
      将该曲线的终点和控制点的位置设置为指定的双坐标。
      void setCurve​(CubicCurve2D c)
      将该曲线的终点和控制点的位置设置为与指定的 CubicCurve2D 。
      void setCurve​(Point2D[] pts, int offset)
      将该曲线的终点和控制点的位置设置为指定数组中指定偏移量处的 Point2D对象的坐标。
      void setCurve​(Point2D p1, Point2D cp1, Point2D cp2, Point2D p2)
      将此曲线的终点和控制点的位置设置为指定的 Point2D坐标。
      static int solveCubic​(double[] eqn)
      解决其系数在 eqn数组中的 eqn ，并将非复数根返回到同一个数组中，返回根数。
      static int solveCubic​(double[] eqn, double[] res)
      求解系数在 eqn数组中的 eqn ，并将非复数根放入 res数组中，返回根数。
      static void subdivide​(double[] src, int srcoff, double[] left, int leftoff, double[] right, int rightoff)
      细分由存储在 src阵列中的坐标指定的三次曲线，索引号为 srcoff至（ srcoff + 7），并将所得到的两条细分曲线存储在相应索引处的两个结果数组中。
      void subdivide​(CubicCurve2D left, CubicCurve2D right)
      细分此三次曲线并将所得到的两个细分曲线存储在左曲线和右曲线参数中。
      static void subdivide​(CubicCurve2D src, CubicCurve2D left, CubicCurve2D right)
      细分由 src参数指定的三次曲线，并将生成的两个细分曲线存储到 left和 right曲线参数中。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.awt.Shape

        getBounds2D

    • 构造方法详细信息

      • CubicCurve2D

        protected CubicCurve2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        CubicCurve2D.Float ， CubicCurve2D.Double

    • 方法详细信息

      • getX1

        public abstract double getX1​()
        200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
        结果
        起始点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getY1

        public abstract double getY1​()
        新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
        结果
        起始点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getP1

        public abstract Point2D getP1​()
        返回起始点。
        结果
        一个 Point2D是 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX1

        public abstract double getCtrlX1​()
        以双精度返回第一个控制点的X坐标。
        结果
        第一个控制点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlY1

        public abstract double getCtrlY1​()
        以双精度返回第一个控制点的Y坐标。
        结果
        第一个控制点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlP1

        public abstract Point2D getCtrlP1​()
        返回第一个控制点。
        结果
        一个 Point2D那就是第一控制点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX2

        public abstract double getCtrlX2​()
        以双精度返回第二个控制点的X坐标。
        结果
        第二个控制点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlY2

        public abstract double getCtrlY2​()
        以双精度返回第二个控制点的Y坐标。
        结果
        第二个控制点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlP2

        public abstract Point2D getCtrlP2​()
        返回第二个控制点。
        结果
        一个 Point2D那是的第二个控制点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getX2

        public abstract double getX2​()
        X-
        结果
        CubicCurve2D的终点的X坐标。
        从以下版本开始：
        1.2

      • getY2

        public abstract double getY2​()
        以双精度返回终点的Y坐标。
        结果
        终点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getP2

        public abstract Point2D getP2​()
        返回终点。
        结果
        一个 Point2D那就是终点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • setCurve

        public abstract void setCurve​(double x1,
                              double y1,
                              double ctrlx1,
                              double ctrly1,
                              double ctrlx2,
                              double ctrly2,
                              double x2,
                              double y2)
        将该曲线的终点和控制点的位置设置为指定的双坐标。
        参数
        x1 - 用于设置此 CubicCurve2D起始点的X坐标
        y1 - 用于设置此 CubicCurve2D起始点的Y坐标
        ctrlx1 - 用于设置此 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 用于设置此 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 用于设置此 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 用于设置此 CubicCurve2D的第二个控制点的Y坐标
        x2 - 用于设置此 CubicCurve2D的终点的X坐标
        y2 - 用于设置此 CubicCurve2D的终点的Y坐标
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(double[] coords,
                     int offset)
        将该曲线的终点和控制点的位置设置为指定数组中指定偏移处的双坐标。
        参数
        coords - 包含坐标的双数组
        offset - offset的索引， coords开始将此曲线的终点和控制点设置为 coords包含的坐标
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(Point2D p1,
                     Point2D cp1,
                     Point2D cp2,
                     Point2D p2)
        将该曲线的终点和控制点的位置设置为指定的 Point2D坐标。
        参数
        p1 - 第一个指定的 Point2D用于设置此曲线的起始点
        cp1 - 第二个指定的 Point2D用于设置此曲线的第一个控制点
        cp2 - 第三个指定的 Point2D用于设置此曲线的第二个控制点
        p2 - 第四个指定的 Point2D用于设置此曲线的终点
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(Point2D[] pts,
                     int offset)
        将此曲线的终点和控制点的位置设置为指定数组中指定偏移量处的 Point2D对象的坐标。
        参数
        pts - 一个 Point2D对象的数组
        offset - offset的索引， pts开始将该曲线的终点和控制点设置为 pts包含的点
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(CubicCurve2D c)
        将该曲线的终点和控制点的位置设置为与指定的 CubicCurve2D 。
        参数
        c - 指定的 CubicCurve2D
        从以下版本开始：
        1.2

      • getFlatnessSq

        public static double getFlatnessSq​(double x1,
                                   double y1,
                                   double ctrlx1,
                                   double ctrly1,
                                   double ctrlx2,
                                   double ctrly2,
                                   double x2,
                                   double y2)
        返回由指示的控制点指定的三次曲线的平坦度的平方。 平直度是控制点与连接端点的线的最大距离。
        参数
        x1 -的X坐标指定的起点 CubicCurve2D
        y1 - Y坐标，它指定的起点 CubicCurve2D
        ctrlx1 - 指定 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 指定 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 指定 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 指定 CubicCurve2D的第二个控制点的Y坐标
        x2 - 指定 CubicCurve2D的终点的X坐标
        y2 - 指定 CubicCurve2D的终点的Y坐标
        结果
        CubicCurve2D的平坦度由指定的坐标表示。
        从以下版本开始：
        1.2

      • getFlatness

        public static double getFlatness​(double x1,
                                 double y1,
                                 double ctrlx1,
                                 double ctrly1,
                                 double ctrlx2,
                                 double ctrly2,
                                 double x2,
                                 double y2)
        返回由指示的控制点指定的三次曲线的平坦度。 平直度是控制点与连接端点的线的最大距离。
        参数
        x1 -的X坐标指定的起点 CubicCurve2D
        y1 - Y坐标，它指定的起点 CubicCurve2D
        ctrlx1 - 指定 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 指定 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 指定 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 指定 CubicCurve2D的第二个控制点的Y坐标
        x2 - 指定 CubicCurve2D的终点的X坐标
        y2 - 指定 CubicCurve2D的终点的Y坐标
        结果
        由指定坐标表示的 CubicCurve2D的平坦度。
        从以下版本开始：
        1.2

      • getFlatnessSq

        public static double getFlatnessSq​(double[] coords,
                                   int offset)
        返回由指定的数组中存储的指示索引指定的控制点指定的三次曲线的平坦度的平方。 平直度是控制点与连接端点的线的最大距离。
        参数
        coords - 包含坐标的数组
        offset - offset的索引， coords开始获取曲线的终点和控制点
        结果
        所述的平面度的平方 CubicCurve2D在由坐标指定 coords指定的偏移量。
        从以下版本开始：
        1.2

      • getFlatness

        public static double getFlatness​(double[] coords,
                                 int offset)
        返回由指定的数组中指定的索引处存储的控制点指定的三次曲线的平坦度。 平直度是控制点与连接端点的线的最大距离。
        参数
        coords - 包含坐标的数组
        offset - 索引 coords ，从中开始获取曲线的终点和控制点
        结果
        所述的平坦性 CubicCurve2D在由坐标指定 coords指定的偏移量。
        从以下版本开始：
        1.2

      • getFlatnessSq

        public double getFlatnessSq​()
        返回该曲线的平坦度的平方。 平直度是控制点与连接端点的线的最大距离。
        结果
        该曲线平坦度的平方。
        从以下版本开始：
        1.2

      • getFlatness

        public double getFlatness​()
        返回该曲线的平坦度。 平直度是控制点与连接端点的线的最大距离。
        结果
        这个曲线的平坦度。
        从以下版本开始：
        1.2

      • subdivide

        public void subdivide​(CubicCurve2D left,
                      CubicCurve2D right)
        细分此三次曲线并将所得到的两个细分曲线存储在左曲线和右曲线参数中。 左右对象中的一个或两个可以与该对象相同或为空。
        参数
        left - 用于存储细分曲线左侧或前半部分的三次曲线对象
        right - 用于存储分割曲线的右半部分或后半部分的三次曲线对象
        从以下版本开始：
        1.2

      • subdivide

        public static void subdivide​(CubicCurve2D src,
                             CubicCurve2D left,
                             CubicCurve2D right)
        细分由src参数指定的三次曲线，并将所得到的两个细分曲线存储到left和right曲线参数中。 left和right对象中的一个或两个可能与src对象或null 。
        参数
        src - 要细分的三次曲线
        left - 用于存储细分曲线的左半部分或前半部分的三次曲线对象
        right - 用于存储细分曲线的右半部分或后半部分的三次曲线对象
        从以下版本开始：
        1.2

      • subdivide

        public static void subdivide​(double[] src,
                             int srcoff,
                             double[] left,
                             int leftoff,
                             double[] right,
                             int rightoff)
        将存储在src数组中的坐标指定的三次曲线细分为索引srcoff至（ srcoff + 7），并将所得到的两个细分曲线存储在相应索引处的两个结果数组中。 left和right阵列中的一个或两者可以是null或对与src阵列相同的数组的src 。 请注意，第一个细分曲线中的最后一个点与第二个细分曲线中的第一个点相同。 因此，能够通过相同的数组为left和right和使用偏移，例如rightoff等于（ leftoff + 6），以避免该公共点分配额外的存储空间。
        参数
        src - 保存源曲线坐标的数组
        srcoff - 偏移到数组的开头的6个源坐标
        left - 用于存储细分曲线前半部分坐标的数组
        leftoff - 偏移到数组的开头的6个左坐标
        right - 用于存储细分曲线后半部分坐标的数组
        rightoff - 偏移到数组的开头的6个右坐标
        从以下版本开始：
        1.2

      • solveCubic

        public static int solveCubic​(double[] eqn)
        解决其系数在eqn数组中的eqn ，并将非复数根返回到同一个数组中，返回根数。 求解的立方体由下式表示：
          eqn = {c, b, a, d}
     dx^3 + ax^2 + bx + c = 0
        使用返回值-1来区分一个常数等式，该常数方程可能始终为0或从0不存在零的方程。
        参数
        eqn - 包含立方体系数的数组
        结果
        根数，如果方程为常数则为-1。
        从以下版本开始：
        1.2

      • solveCubic

        public static int solveCubic​(double[] eqn,
                             double[] res)
        求解系数在eqn数组中的eqn ，并将非复数根放入res数组中，返回根数。 求解的三次方程由等式表示：eqn = {c，b，a，d} dx ^ 3 + ax ^ 2 + bx + c = 0使用-1的返回值来区分常数方程，始终为0或从不为零，从无零的方程式。
        参数
        eqn - 用于求解三次方程的指定数组的系数
        res - 包含由三次方程的解得到的非复数根的数组
        结果
        根数，如果方程为常数则为-1
        从以下版本开始：
        1.3

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        Specified by:
        contains在接口 Shape
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标是在Shape边界内; 否则为false 。
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(Point2D p)
        测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
        Specified by:
        contains在接口 Shape
        参数
        p - 要测试的指定的 Point2D
        结果
        true如果指定Point2D是的边界内Shape ; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 矩形区域被认为是交叉的Shape如果任何点被包含在双方的内部Shape和指定的矩形区域。

        Shape.intersects()方法允许Shape实现保守返回true当：

        • 矩形区域和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回true即使矩形区域不与Shape相交。 Area类比大多数Shape对象执行几何交集的更准确的计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • intersects

        public boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许Shape实现保守返回true当：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回true即使Rectangle2D不相交Shape 。 Area类对大多数Shape对象执行几何交集的更准确的计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的Rectangle2D的内部相交，或者很可能相交，并且交叉点计算将太昂贵执行; false否则。
        从以下版本开始：
        1.2
        另请参见：
        Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标必须位于Shape内，因为整个矩形区域将被视为包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false当：

        • 该intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于某些Shapes即使Shape包含矩形区域，此方法也可能返回false 。 Area类执行比大多数Shape对象更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则或如果Shape包含矩形区域，并且intersects方法返回true并且包含计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(Rectangle2D r)
        测试Shape的内部Shape完全包含指定的Rectangle2D 。 Shape.contains()方法允许Shape实现保守返回false当：
        • intersect方法返回true和
        • 计算确定Shape是否完全包含Rectangle2D是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回false即使Shape包含Rectangle2D 。 Area类比大多数Shape对象执行更精确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果内部的Shape完全包含Rectangle2D ; false否则或如果Shape包含Rectangle2D并且intersects方法返回true ，并且遏制计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Shape.contains(double, double, double, double)

      • getBounds

        public Rectangle getBounds​()
        返回一个整数Rectangle完全包围Shape 。 请注意，不保证返回的Rectangle是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle 。 如果Shape溢出整数数据类型的有限范围，返回的Rectangle也可能无法完全包含Shape 。 getBounds2D方法通常返回更严格的边界框，因为它在表示方面具有更大的灵活性。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(x,y)需要bounds.contains(x,y)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(x,y)并不表示shape.contains(x,y)

        Specified by:
        getBounds在接口 Shape
        结果
        一个整数 Rectangle ，完全包围了 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds2D()

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回定义形状边界的迭代对象。 此类的迭代器不是多线程安全的，这意味着此CubicCurve2D类不保证对此CubicCurve2D对象的几何的修改不会影响已经处理的该几何的任何迭代。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果未转换坐标是 null
        结果
        该 PathIterator对象返回此 CubicCurve2D的轮廓的几何，一次一个段。
        从以下版本开始：
        1.2

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at,
                                    double flatness)
        返回定义展平形状边界的迭代对象。 此类的迭代器不是多线程安全的，这意味着此CubicCurve2D类不保证对此CubicCurve2D对象的几何的修改不会影响已处理的该几何的任何迭代。
        Specified by:
        getPathIterator接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        flatness - 给定曲线的控制点的最大量可以在共线之前变化，而细分曲线由连接终点的直线代替
        结果
        PathIterator对象，返回此 CubicCurve2D的轮廓的几何， CubicCurve2D一个段。
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        创建与此对象相同类的新对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.2
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CubicCurve2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class CubicCurve2D.Double

  • java.lang.Object
    • java.awt.geom.CubicCurve2D
      • java.awt.geom.CubicCurve2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    CubicCurve2D

    public static class CubicCurve2D.Double
extends CubicCurve2D
implements Serializable
    用 double坐标指定的三次参数曲线段。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.CubicCurve2D

        CubicCurve2D.Double, CubicCurve2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double ctrlx1
      三次曲线段的第一个控制点的X坐标。
      double ctrlx2
      三次曲线段的第二个控制点的X坐标。
      double ctrly1
      三次曲线段的第一个控制点的Y坐标。
      double ctrly2
      三次曲线段的第二个控制点的Y坐标。
      double x1
      三次曲线段起始点的X坐标。
      double x2
      三次曲线段终点的X坐标。
      double y1
      三次曲线段起始点的Y坐标。
      double y2
      三次曲线段终点的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造并初始化坐标（0，0，0，0，0，0，0，0）的CubicCurve。
      Double​(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2)
      构造并初始化一个 CubicCurve2D从指定 double坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法高精度和更准确的边界框。
      Point2D getCtrlP1​()
      返回第一个控制点。
      Point2D getCtrlP2​()
      返回第二个控制点。
      double getCtrlX1​()
      以双精度返回第一个控制点的X坐标。
      double getCtrlX2​()
      以双精度返回第二个控制点的X坐标。
      double getCtrlY1​()
      以双精度返回第一个控制点的Y坐标。
      double getCtrlY2​()
      以双精度返回第二个控制点的Y坐标。
      Point2D getP1​()
      返回起始点。
      Point2D getP2​()
      返回终点。
      double getX1​()
      以双精度返回起始点的X坐标。
      double getX2​()
      以双精度返回终点的X坐标。
      double getY1​()
      以双精度返回起始点的Y坐标。
      double getY2​()
      以双精度返回终点的Y坐标。
      void setCurve​(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2)
      将该曲线的终点和控制点的位置设置为指定的双坐标。

      • Methods inherited from class java.awt.geom.CubicCurve2D

        clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveCubic, solveCubic, subdivide, subdivide, subdivide

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • x1

        public double x1
        三次曲线段起始点的X坐标。
        从以下版本开始：
        1.2

      • y1

        public double y1
        三次曲线段起始点的Y坐标。
        从以下版本开始：
        1.2

      • ctrlx1

        public double ctrlx1
        三次曲线段的第一个控制点的X坐标。
        从以下版本开始：
        1.2

      • ctrly1

        public double ctrly1
        三次曲线段的第一个控制点的Y坐标。
        从以下版本开始：
        1.2

      • ctrlx2

        public double ctrlx2
        三次曲线段的第二个控制点的X坐标。
        从以下版本开始：
        1.2

      • ctrly2

        public double ctrly2
        三次曲线段的第二个控制点的Y坐标。
        从以下版本开始：
        1.2

      • x2

        public double x2
        三次曲线段终点的X坐标。
        从以下版本开始：
        1.2

      • y2

        public double y2
        三次曲线段终点的Y坐标。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        构造并初始化坐标（0，0，0，0，0，0，0，0）的CubicCurve。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x1,
              double y1,
              double ctrlx1,
              double ctrly1,
              double ctrlx2,
              double ctrly2,
              double x2,
              double y2)
        构造并初始化一个 CubicCurve2D从指定 double坐标。
        参数
        x1 - 生成的 x1的X坐标 CubicCurve2D
        y1 - 生成的 y1的Y坐标 CubicCurve2D
        ctrlx1 - 所得到的 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 所得的 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 所得的 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 所得到的第二个控制点的Y坐标 CubicCurve2D
        x2 - 结果的终点的X坐标 CubicCurve2D
        y2 - 所得结果的Y坐标为 CubicCurve2D
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX1

        public double getX1​()
        200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
        Specified by:
        getX1在 CubicCurve2D
        结果
        起始点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getY1

        public double getY1​()
        新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
        Specified by:
        getY1在 CubicCurve2D
        结果
        起始点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getP1

        public Point2D getP1​()
        返回起始点。
        Specified by:
        getP1在 CubicCurve2D
        结果
        一个 Point2D是 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX1

        public double getCtrlX1​()
        以双精度返回第一个控制点的X坐标。
        Specified by:
        getCtrlX1类 CubicCurve2D
        结果
        第一个控制点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlY1

        public double getCtrlY1​()
        以双精度返回第一个控制点的Y坐标。
        Specified by:
        getCtrlY1在 CubicCurve2D
        结果
        第一个控制点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlP1

        public Point2D getCtrlP1​()
        返回第一个控制点。
        Specified by:
        getCtrlP1在 CubicCurve2D
        结果
        一个 Point2D那就是第一控制点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX2

        public double getCtrlX2​()
        以双精度返回第二个控制点的X坐标。
        Specified by:
        getCtrlX2在 CubicCurve2D
        结果
        第二个控制点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlY2

        public double getCtrlY2​()
        以双精度返回第二个控制点的Y坐标。
        Specified by:
        getCtrlY2在 CubicCurve2D
        结果
        第二个控制点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlP2

        public Point2D getCtrlP2​()
        返回第二个控制点。
        Specified by:
        getCtrlP2 CubicCurve2D
        结果
        一个 Point2D那是的第二个控制点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getX2

        public double getX2​()
        X-
        Specified by:
        getX2在 CubicCurve2D
        结果
        终点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getY2

        public double getY2​()
        以双精度返回终点的Y坐标。
        Specified by:
        getY2在 CubicCurve2D
        结果
        终点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getP2

        public Point2D getP2​()
        返回终点。
        Specified by:
        getP2中的 CubicCurve2D
        结果
        一个 Point2D那就是终点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(double x1,
                     double y1,
                     double ctrlx1,
                     double ctrly1,
                     double ctrlx2,
                     double ctrly2,
                     double x2,
                     double y2)
        将该曲线的终点和控制点的位置设置为指定的双坐标。
        Specified by:
        setCurve在 CubicCurve2D
        参数
        x1 - 用于设置此 CubicCurve2D起始点的X坐标
        y1 - 用于设置此 CubicCurve2D起始点的Y坐标
        ctrlx1 - 用于设置此 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 用于设置此 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 用于设置此 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 用于设置此 CubicCurve2D的第二个控制点的Y坐标
        x2 - 用于设置此 CubicCurve2D的终点的X坐标
        y2 - 用于设置此 CubicCurve2D的终点的Y坐标
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法高精度和更精确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更getBounds ，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D一个实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CubicCurve2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class CubicCurve2D.Float

  • java.lang.Object
    • java.awt.geom.CubicCurve2D
      • java.awt.geom.CubicCurve2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    CubicCurve2D

    public static class CubicCurve2D.Float
extends CubicCurve2D
implements Serializable
    用 float坐标指定的三次参数曲线段。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.CubicCurve2D

        CubicCurve2D.Double, CubicCurve2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float ctrlx1
      三次曲线段的第一个控制点的X坐标。
      float ctrlx2
      三次曲线段的第二个控制点的X坐标。
      float ctrly1
      三次曲线段的第一个控制点的Y坐标。
      float ctrly2
      三次曲线段的第二个控制点的Y坐标。
      float x1
      三次曲线段起始点的X坐标。
      float x2
      三次曲线段终点的X坐标。
      float y1
      三次曲线段起始点的Y坐标。
      float y2
      三次曲线段终点的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造并初始化坐标（0，0，0，0，0，0，0，0）的CubicCurve。
      Float​(float x1, float y1, float ctrlx1, float ctrly1, float ctrlx2, float ctrly2, float x2, float y2)
      构造并初始化一个 CubicCurve2D从指定 float坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Point2D getCtrlP1​()
      返回第一个控制点。
      Point2D getCtrlP2​()
      返回第二个控制点。
      double getCtrlX1​()
      以双精度返回第一个控制点的X坐标。
      double getCtrlX2​()
      以双精度返回第二个控制点的X坐标。
      double getCtrlY1​()
      以双精度返回第一个控制点的Y坐标。
      double getCtrlY2​()
      以双精度返回第二个控制点的Y坐标。
      Point2D getP1​()
      返回起始点。
      Point2D getP2​()
      返回终点。
      double getX1​()
      以双精度返回起始点的X坐标。
      double getX2​()
      以双精度返回终点的X坐标。
      double getY1​()
      以双精度返回起始点的Y坐标。
      double getY2​()
      以双精度返回终点的Y坐标。
      void setCurve​(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2)
      将该曲线的终点和控制点的位置设置为指定的双坐标。
      void setCurve​(float x1, float y1, float ctrlx1, float ctrly1, float ctrlx2, float ctrly2, float x2, float y2)
      将此曲线的终点和控制点的位置设置为指定的 float坐标。

      • Methods inherited from class java.awt.geom.CubicCurve2D

        clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveCubic, solveCubic, subdivide, subdivide, subdivide

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • x1

        public float x1
        三次曲线段起始点的X坐标。
        从以下版本开始：
        1.2

      • y1

        public float y1
        三次曲线段起始点的Y坐标。
        从以下版本开始：
        1.2

      • ctrlx1

        public float ctrlx1
        三次曲线段的第一个控制点的X坐标。
        从以下版本开始：
        1.2

      • ctrly1

        public float ctrly1
        三次曲线段的第一个控制点的Y坐标。
        从以下版本开始：
        1.2

      • ctrlx2

        public float ctrlx2
        三次曲线段的第二个控制点的X坐标。
        从以下版本开始：
        1.2

      • ctrly2

        public float ctrly2
        三次曲线段的第二个控制点的Y坐标。
        从以下版本开始：
        1.2

      • x2

        public float x2
        三次曲线段终点的X坐标。
        从以下版本开始：
        1.2

      • y2

        public float y2
        三次曲线段终点的Y坐标。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造并初始化坐标（0，0，0，0，0，0，0，0）的CubicCurve。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x1,
             float y1,
             float ctrlx1,
             float ctrly1,
             float ctrlx2,
             float ctrly2,
             float x2,
             float y2)
        构造并初始化一个 CubicCurve2D从指定 float坐标。
        参数
        x1 - 生成的 x1的X坐标 CubicCurve2D
        y1 - 生成的 y1的Y坐标 CubicCurve2D
        ctrlx1 - 所得到的 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 所得的 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 所得到的 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 所得的 CubicCurve2D的第二个控制点的Y坐标
        x2 - 结果 CubicCurve2D的终点的X坐标
        y2 - 结果的终点的Y坐标 CubicCurve2D
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX1

        public double getX1​()
        200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
        Specified by:
        getX1在 CubicCurve2D
        结果
        起始点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getY1

        public double getY1​()
        新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
        Specified by:
        getY1在 CubicCurve2D
        结果
        起始点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getP1

        public Point2D getP1​()
        返回起始点。
        Specified by:
        getP1在 CubicCurve2D
        结果
        一个 Point2D是 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX1

        public double getCtrlX1​()
        以双精度返回第一个控制点的X坐标。
        Specified by:
        getCtrlX1在 CubicCurve2D
        结果
        第一个控制点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlY1

        public double getCtrlY1​()
        以双精度返回第一个控制点的Y坐标。
        Specified by:
        getCtrlY1在 CubicCurve2D
        结果
        第一个控制点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlP1

        public Point2D getCtrlP1​()
        返回第一个控制点。
        Specified by:
        getCtrlP1在 CubicCurve2D
        结果
        一个 Point2D那就是第一控制点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX2

        public double getCtrlX2​()
        以双精度返回第二个控制点的X坐标。
        Specified by:
        getCtrlX2在 CubicCurve2D
        结果
        第二个控制点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlY2

        public double getCtrlY2​()
        以双精度返回第二个控制点的Y坐标。
        Specified by:
        getCtrlY2在 CubicCurve2D
        结果
        第二个控制点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlP2

        public Point2D getCtrlP2​()
        返回第二个控制点。
        Specified by:
        getCtrlP2在 CubicCurve2D
        结果
        一个 Point2D那是的第二个控制点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getX2

        public double getX2​()
        X-
        Specified by:
        getX2在 CubicCurve2D
        结果
        终点的X坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getY2

        public double getY2​()
        以双精度返回终点的Y坐标。
        Specified by:
        getY2在 CubicCurve2D
        结果
        终点的Y坐标为 CubicCurve2D 。
        从以下版本开始：
        1.2

      • getP2

        public Point2D getP2​()
        返回终点。
        Specified by:
        getP2在 CubicCurve2D
        结果
        一个 Point2D那就是终点 CubicCurve2D 。
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(double x1,
                     double y1,
                     double ctrlx1,
                     double ctrly1,
                     double ctrlx2,
                     double ctrly2,
                     double x2,
                     double y2)
        将该曲线的终点和控制点的位置设置为指定的双坐标。
        Specified by:
        setCurve在 CubicCurve2D
        参数
        x1 - 用于设置此 CubicCurve2D起始点的X坐标
        y1 - 用于设置此 CubicCurve2D起始点的Y坐标
        ctrlx1 - 用于设置此 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 用于设置此 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 用于设置此 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 用于设置此 CubicCurve2D的第二个控制点的Y坐标
        x2 - 用于设置此 CubicCurve2D的终点的X坐标
        y2 - 用于设置此 CubicCurve2D的终点的Y坐标
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(float x1,
                     float y1,
                     float ctrlx1,
                     float ctrly1,
                     float ctrlx2,
                     float ctrly2,
                     float x2,
                     float y2)
        将此曲线的终点和控制点的位置设置为指定的 float坐标。
        参数
        x1 - 用于设置此 CubicCurve2D起始点的X坐标
        y1 - 用于设置此 CubicCurve2D起始点的Y坐标
        ctrlx1 - 用于设置此 CubicCurve2D的第一个控制点的X坐标
        ctrly1 - 用于设置此 CubicCurve2D的第一个控制点的Y坐标
        ctrlx2 - 用于设置此 CubicCurve2D的第二个控制点的X坐标
        ctrly2 - 用于设置此 CubicCurve2D的第二个控制点的Y坐标
        x2 - 用于设置此 CubicCurve2D的终点的X坐标
        y2 - 用于设置此 CubicCurve2D的终点的Y坐标
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        比getBounds方法返回Shape高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D一个实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape中这些点也未被包含的shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Dimension2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Dimension2D

  • java.lang.Object
    • java.awt.geom.Dimension2D
  • All Implemented Interfaces:
    Cloneable
    已知直接子类：
    Dimension

    public abstract class Dimension2D
extends Object
implements Cloneable
    Dimension2D类是封装宽度和高度维度。

    此类只是存储2D维的所有对象的抽象超类。 大小的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Dimension2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建与此对象相同类的新对象。
      abstract double getHeight​()
      以双精度返回此 Dimension的高度。
      abstract double getWidth​()
      以双精度返回此 Dimension的宽度。
      abstract void setSize​(double width, double height)
      将此 Dimension对象的大小设置为指定的宽度和高度。
      void setSize​(Dimension2D d)
      设置此 Dimension2D对象的大小以匹配指定的大小。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Dimension2D

        protected Dimension2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        Dimension

    • 方法详细信息

      • getWidth

        public abstract double getWidth​()
        以双精度返回此 Dimension的宽度。
        结果
        该宽度为 Dimension 。
        从以下版本开始：
        1.2

      • getHeight

        public abstract double getHeight​()
        以双精度返回此 Dimension的高度。
        结果
        的高度这 Dimension 。
        从以下版本开始：
        1.2

      • setSize

        public abstract void setSize​(double width,
                             double height)
        将此Dimension对象的大小设置为指定的宽度和高度。 包括此方法的完整性，并行getSize方法Component 。
        参数
        width - Dimension对象的新宽度
        height - Dimension对象的新高度
        从以下版本开始：
        1.2

      • setSize

        public void setSize​(Dimension2D d)
        设置此Dimension2D对象的大小以匹配指定的大小。 包括此方法的完整性，并行getSize方法Component 。
        参数
        d - Dimension2D对象的新大小
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        创建与此对象相同类的新对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.2
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Ellipse2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Ellipse2D

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Ellipse2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    Ellipse2D.Double ， Ellipse2D.Float

    public abstract class Ellipse2D
extends RectangularShape
    Ellipse2D类描述了由框架矩形定义的椭圆。

    该类只是存储2D椭圆的所有对象的抽象超类。 坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Ellipse2D.Double
      Double类定义了一个 double精度中指定的椭圆。
      static class  Ellipse2D.Float
      Float类定义了一个 float精度中指定的椭圆。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Ellipse2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      boolean equals​(Object obj)
      确定指定的 Object是否等于此 Ellipse2D 。
      PathIterator getPathIterator​(AffineTransform at)
      返回一个定义 Ellipse2D边界的迭代对象。
      int hashCode​()
      返回此 Ellipse2D的哈希 Ellipse2D 。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

      • Methods inherited from interface java.awt.Shape

        getBounds2D

    • 构造方法详细信息

      • Ellipse2D

        protected Ellipse2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        Ellipse2D.Float ， Ellipse2D.Double

    • 方法详细信息

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标是在Shape边界内; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 矩形区域被认为是交叉的Shape如果任何点被包含在双方的内部Shape和指定的矩形区域。

        Shape.intersects()方法允许Shape实现保守返回true当：

        • 很可能矩形区域和Shape相交，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回true即使矩形区域没有相交Shape 。 Area类比大多数Shape对象执行几何交集的更准确的计算，因此如果需要更准确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标必须位于Shape内，因为整个矩形区域将被视为包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false当：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于一些Shapes即使Shape包含矩形区域，此方法也可能返回false 。 Area类比大多数Shape对象执行更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则，或者如果Shape包含矩形区域，并且intersects方法返回true ，并且控制计算将太昂贵，无法执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回一个定义Ellipse2D边界的迭代对象。 该类的迭代器是多线程安全的，这意味着这个Ellipse2D类保证对这个Ellipse2D对象的几何的修改不会影响已经在处理的几何的任何迭代。
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        结果
        PathIterator对象返回此 Ellipse2D轮廓的几何， Ellipse2D一个段。
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回此 Ellipse2D的哈希 Ellipse2D 。
        重写：
        hashCode中的 Object
        结果
        这个 Ellipse2D的哈希 Ellipse2D 。
        从以下版本开始：
        1.6
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        确定指定的Object是否等于此Ellipse2D 。 指定Object等于该Ellipse2D ，如果它是一个实例Ellipse2D ，如果它的位置和大小是相同的，因为这Ellipse2D 。
        重写：
        equals在类 Object
        参数
        obj - 一个 Object要与这个 Ellipse2D进行比较。
        结果
        true如果obj是的一个实例Ellipse2D ，并且具有相同的值; 否则为false 。
        从以下版本开始：
        1.6
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Ellipse2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Ellipse2D.Double

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Ellipse2D
        • java.awt.geom.Ellipse2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Ellipse2D

    public static class Ellipse2D.Double
extends Ellipse2D
implements Serializable
    Double类定义了一个 double精度指定的椭圆。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Ellipse2D

        Ellipse2D.Double, Ellipse2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double height
      整体高度为 Ellipse2D 。
      double width
      这个 Ellipse2D的整体宽度。
      double x
      这个 Ellipse2D的框架矩形的左上角的X坐标。
      double y
      该 Ellipse2D框架矩形左上角的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造一个新的 Ellipse2D ，初始化为位置（0，0）和大小（0，0）。
      Double​(double x, double y, double w, double h)
      从指定的坐标构建和初始化一个 Ellipse2D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      比 getBounds方法返回 Shape高精度和更准确的边界框。
      double getHeight​()
      以 double精度返回框架矩形的高度。
      double getWidth​()
      以 double精度返回框架矩形的宽度。
      double getX​()
      返回 double精度的成帧矩形左上角的X坐标。
      double getY​()
      返回 double精度的成帧矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      void setFrame​(double x, double y, double w, double h)
      将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

      • Methods inherited from class java.awt.geom.Ellipse2D

        contains, contains, equals, getPathIterator, hashCode, intersects

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • x

        public double x
        此 Ellipse2D框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • y

        public double y
        这个 Ellipse2D框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • width

        public double width
        这个 Ellipse2D的整体宽度。
        从以下版本开始：
        1.2

      • height

        public double height
        整体高度为 Ellipse2D 。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        构造一个新的 Ellipse2D ，初始化为位置（0,0）和大小（0,0）。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x,
              double y,
              double w,
              double h)
        从指定的坐标构建和初始化一个 Ellipse2D 。
        参数
        x - 框架矩形左上角的X坐标
        y - 框架矩形左上角的Y坐标
        w - 框架矩形的宽度
        h - 框架矩形的高度
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        返回 double精度的框架矩形左上角的X坐标。
        Specified by:
        getX在 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回 double精度的框架矩形左上角的Y坐标。
        Specified by:
        getY在 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        以 double精度返回框架矩形的宽度。
        Specified by:
        getWidth在 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        以 double精度返回框架矩形的高度。
        Specified by:
        getHeight在 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，它不包含任何区域。
        Specified by:
        isEmpty在 RectangularShape
        结果
        true如果RectangularShape是空的; 否则为false 。
        从以下版本开始：
        1.2

      • setFrame

        public void setFrame​(double x,
                     double y,
                     double w,
                     double h)
        将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。
        Specified by:
        setFrame在 RectangularShape
        参数
        x - 指定矩形左上角的X坐标
        y - 指定矩形左上角的Y坐标
        w - 指定矩形形状的宽度
        h - 指定长方形的高度
        从以下版本开始：
        1.2
        另请参见：
        RectangularShape.getFrame()

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape高精度和更准确的边界框，比getBounds方法。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界通常比getBounds方法返回的getBounds更getBounds并且由于溢出问题而永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致bounds对象定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Ellipse2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Ellipse2D.Float

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Ellipse2D
        • java.awt.geom.Ellipse2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Ellipse2D

    public static class Ellipse2D.Float
extends Ellipse2D
implements Serializable
    Float类定义了一个 float精度中指定的椭圆。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Ellipse2D

        Ellipse2D.Double, Ellipse2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float height
      这个 Ellipse2D的整体高度。
      float width
      这个 Ellipse2D的整体宽度。
      float x
      这个 Ellipse2D的框架矩形左上角的X坐标。
      float y
      该 Ellipse2D框架矩形左上角的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造一个新的 Ellipse2D ，初始化为位置（0,0）和大小（0,0）。
      Float​(float x, float y, float w, float h)
      从指定的坐标构建和初始化一个 Ellipse2D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      比 getBounds方法返回 Shape高精度和更准确的边界框。
      double getHeight​()
      返回 double精度的成帧矩形的高度。
      double getWidth​()
      返回 double精度的成帧矩形的宽度。
      double getX​()
      返回 double精度的框架矩形左上角的X坐标。
      double getY​()
      返回 double精度中框架矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      void setFrame​(double x, double y, double w, double h)
      将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。
      void setFrame​(float x, float y, float w, float h)
      将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。

      • Methods inherited from class java.awt.geom.Ellipse2D

        contains, contains, equals, getPathIterator, hashCode, intersects

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • x

        public float x
        此 Ellipse2D框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • y

        public float y
        此 Ellipse2D框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • width

        public float width
        这个 Ellipse2D的整体宽度。
        从以下版本开始：
        1.2

      • height

        public float height
        这个 Ellipse2D的整体高度。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造一个新的 Ellipse2D ，初始化为位置（0,0）和大小（0,0）。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x,
             float y,
             float w,
             float h)
        从指定的坐标构建和初始化一个 Ellipse2D 。
        参数
        x - 框架矩形左上角的X坐标
        y - 框架矩形左上角的Y坐标
        w - 框架矩形的宽度
        h - 框架矩形的高度
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        以 double精度返回成帧矩形左上角的X坐标。
        Specified by:
        getX在 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        以 double精度返回成帧矩形左上角的Y坐标。
        Specified by:
        getY在 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        返回 double精度的成帧矩形的宽度。
        Specified by:
        getWidth在 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        以 double精度返回框架矩形的高度。
        Specified by:
        getHeight在 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，不包含任何区域。
        Specified by:
        isEmpty中的 RectangularShape
        结果
        true如果RectangularShape是空的; 否则为false 。
        从以下版本开始：
        1.2

      • setFrame

        public void setFrame​(float x,
                     float y,
                     float w,
                     float h)
        将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。
        参数
        x - 指定矩形左上角的X坐标
        y - 指定矩形左上角的Y坐标
        w - 指定矩形的宽度
        h - 指定矩形形状的高度
        从以下版本开始：
        1.2

      • setFrame

        public void setFrame​(double x,
                     double y,
                     double w,
                     double h)
        将此 Shape的框架矩形的位置和大小设置为指定的矩形值。
        Specified by:
        setFrame在 RectangularShape
        参数
        x - 指定矩形左上角的X坐标
        y - 指定矩形左上角的Y坐标
        w - 指定矩形形状的宽度
        h - 指定矩形形状的高度
        从以下版本开始：
        1.2
        另请参见：
        RectangularShape.getFrame()

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能会导致bounds对象定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始的shape也不包含这些点的情况下。

        如果一个point是在shape根据contains(point)方法，那么它必须在Rectangle2D范围内的对象中，根据contains(point)方法的bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FlatteningPathIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class FlatteningPathIterator

  • java.lang.Object
    • java.awt.geom.FlatteningPathIterator
  • All Implemented Interfaces:
    PathIterator

    public class FlatteningPathIterator
extends Object
implements PathIterator
    FlatteningPathIterator类返回另一个PathIterator对象的扁平化视图。 其他Shape类可以使用此类为其路径提供扁平化行为，而不必自己执行插值计算。

    • Field Summary

      • Fields inherited from interface java.awt.geom.PathIterator

        SEG_CLOSE, SEG_CUBICTO, SEG_LINETO, SEG_MOVETO, SEG_QUADTO, WIND_EVEN_ODD, WIND_NON_ZERO

    • 构造方法摘要

      构造方法
      Constructor 描述
      FlatteningPathIterator​(PathIterator src, double flatness)
      构造一个新的 FlatteningPathIterator对象，使其在遍历它时平坦化一个路径。
      FlatteningPathIterator​(PathIterator src, double flatness, int limit)
      构造一个新的 FlatteningPathIterator对象，在对其进行迭代时使其 FlatteningPathIterator 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int currentSegment​(double[] coords)
      返回迭代中当前路径段的坐标和类型。
      int currentSegment​(float[] coords)
      返回迭代中当前路径段的坐标和类型。
      double getFlatness​()
      返回此迭代器的平坦度。
      int getRecursionLimit​()
      返回此迭代器的递归限制。
      int getWindingRule​()
      返回确定路径内部的绕组规则。
      boolean isDone​()
      测试迭代是否完成。
      void next​()
      只要在该方向上有更多的点，将迭代器沿着遍历的主要方向向前移动到路径的下一个段。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FlatteningPathIterator

        public FlatteningPathIterator​(PathIterator src,
                              double flatness)
        构造一个新的FlatteningPathIterator对象，使其在遍历它时平坦化一个路径。 迭代器不会将从源迭代器读取的任何曲线细分为超过10个细分级别，每个曲线最多可产生1024个线段。
        参数
        src - 重复的原始未平坦的路径
        flatness - 控制点与平坦曲线之间的最大允许距离

      • FlatteningPathIterator

        public FlatteningPathIterator​(PathIterator src,
                              double flatness,
                              int limit)
        构造一个新的FlatteningPathIterator对象，在对其进行迭代时FlatteningPathIterator对象平坦化。 limit参数允许您控制迭代器可以在假定曲线足够平坦，而不对flatness参数进行测量之前可以进行的递归细分的最大数量。 因此，平坦化的迭代不会产生每曲线最多(2^limit)线段。
        参数
        src - 原始的未平坦的路径被迭代
        flatness - 控制点和平坦曲线之间的最大允许距离
        limit - 允许任何曲线段的递归细分的最大数量
        异常
        IllegalArgumentException - 如果 flatness或 limit小于零

    • 方法详细信息

      • getFlatness

        public double getFlatness​()
        返回此迭代器的平坦度。
        结果
        平坦度这 FlatteningPathIterator 。

      • getRecursionLimit

        public int getRecursionLimit​()
        返回此迭代器的递归限制。
        结果
        这个 FlatteningPathIterator的递归限制。

      • getWindingRule

        public int getWindingRule​()
        返回确定路径内部的绕组规则。
        Specified by:
        getWindingRule在接口 PathIterator
        结果
        原始未平坦路径的绕组规则被迭代。
        另请参见：
        PathIterator.WIND_EVEN_ODD ， PathIterator.WIND_NON_ZERO

      • isDone

        public boolean isDone​()
        测试迭代是否完成。
        Specified by:
        isDone在接口 PathIterator
        结果
        true如果所有段已被读取; 否则为false 。

      • next

        public void next​()
        只要在该方向上有更多的点，将迭代器沿着遍历的主要方向向前移动到路径的下一个段。
        Specified by:
        next在接口 PathIterator

      • currentSegment

        public int currentSegment​(float[] coords)
        返回迭代中当前路径段的坐标和类型。 返回值是路径段类型：SEG_MOVETO，SEG_LINETO或SEG_CLOSE。 必须传入长度为6的浮点数组，并可用于存储点的坐标。 每个点存储为一对浮点x，y坐标。 SEG_MOVETO和SEG_LINETO类型返回一个点，并且SEG_CLOSE不返回任何点。
        Specified by:
        currentSegment在接口 PathIterator
        参数
        coords - 保存从此方法返回的数据的数组
        结果
        当前路径段的路径段类型。
        异常
        NoSuchElementException - 如果在平坦化路径中没有更多要返回的元素。
        另请参见：
        PathIterator.SEG_MOVETO ， PathIterator.SEG_LINETO ， PathIterator.SEG_CLOSE

      • currentSegment

        public int currentSegment​(double[] coords)
        返回迭代中当前路径段的坐标和类型。 返回值是路径段类型：SEG_MOVETO，SEG_LINETO或SEG_CLOSE。 必须传入长度为6的双数组，并可用于存储点的坐标。 每个点被存储为一对双x，y坐标。 SEG_MOVETO和SEG_LINETO类型返回一个点，并且SEG_CLOSE不返回任何点。
        Specified by:
        currentSegment在接口 PathIterator
        参数
        coords - 保存从此方法返回的数据的数组
        结果
        当前路径段的路径段类型。
        异常
        NoSuchElementException - 如果在平坦化路径中没有更多要返回的元素。
        另请参见：
        PathIterator.SEG_MOVETO ， PathIterator.SEG_LINETO ， PathIterator.SEG_CLOSE
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GeneralPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class GeneralPath

  • java.lang.Object
    • java.awt.geom.Path2D
      • java.awt.geom.Path2D.Float
        • java.awt.geom.GeneralPath
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable

    public final class GeneralPath
extends Path2D.Float
    GeneralPath类代表由直线，二次和立方（Bézier）曲线构成的几何路径。 它可以包含多个子路径。

    GeneralPath是一个传统的最终类，它完全实现了其超类Path2D.Float的行为。 与Path2D.Double一起， Path2D类提供了一般通用几何路径的完整实现，支持Shape和PathIterator接口的所有功能，能够明确地选择不同级别的内部坐标精度。

    当处理可以用浮点精度表示和使用的数据时，使用Path2D.Float （或这个传统的GeneralPath子类）。 对于要求准确度或双精度范围的数据，请使用Path2D.Double 。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Path2D

        Path2D.Double, Path2D.Float

    • Field Summary

      • Fields inherited from class java.awt.geom.Path2D

        WIND_EVEN_ODD, WIND_NON_ZERO

    • 构造方法摘要

      构造方法
      Constructor 描述
      GeneralPath​()
      构造一个新的空单精度 GeneralPath对象，其默认缠绕规则为 Path2D.WIND_NON_ZERO 。
      GeneralPath​(int rule)
      使用指定的绕组规则构造新的 GeneralPath对象，以控制需要定义路径内部的操作。
      GeneralPath​(int rule, int initialCapacity)
      构造具有指定绕组规则的新的 GeneralPath对象和指定的初始容量以存储路径坐标。
      GeneralPath​(Shape s)
      构造一个新GeneralPath从任意对象Shape对象。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.Path2D

        append, closePath, contains, contains, contains, contains, contains, contains, contains, contains, createTransformedShape, getBounds, getCurrentPoint, getPathIterator, getWindingRule, intersects, intersects, intersects, intersects, reset, setWindingRule

      • Methods inherited from class java.awt.geom.Path2D.Float

        append, clone, curveTo, curveTo, getBounds2D, getPathIterator, lineTo, lineTo, moveTo, moveTo, quadTo, quadTo, transform

    • 构造方法详细信息

      • GeneralPath

        public GeneralPath​()
        构造一个新的空单精度 GeneralPath对象，默认绕组规则为 Path2D.WIND_NON_ZERO 。
        从以下版本开始：
        1.2

      • GeneralPath

        public GeneralPath​(int rule)
        使用指定的绕组规则构造新的 GeneralPath对象，以控制需要定义路径内部的操作。
        参数
        rule - 绕线规则
        从以下版本开始：
        1.2
        另请参见：
        Path2D.WIND_EVEN_ODD ， Path2D.WIND_NON_ZERO

      • GeneralPath

        public GeneralPath​(int rule,
                   int initialCapacity)
        构造一个新的GeneralPath对象，具有指定的绕组规则和指定的初始容量以存储路径坐标。 这个数字是关于将多少路径段添加到路径的初步猜测，但根据需要扩展存储，以存储添加的任何路径段。
        参数
        rule - 绕线规则
        initialCapacity - 路径中路径段数的估计
        从以下版本开始：
        1.2
        另请参见：
        Path2D.WIND_EVEN_ODD ， Path2D.WIND_NON_ZERO

      • GeneralPath

        public GeneralPath​(Shape s)
        构造一个新GeneralPath从任意对象Shape对象。 该路径的所有初始几何和绕组规则均取自指定的Shape对象。
        参数
        s - 指定的 Shape对象
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalPathStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class IllegalPathStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.awt.geom.IllegalPathStateException
  • All Implemented Interfaces:
    Serializable

    public class IllegalPathStateException
extends RuntimeException
    如果在相对于正在执行的特定操作处于非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段追加到GeneralPath 。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalPathStateException​()
      构造一个没有详细消息的 IllegalPathStateException 。
      IllegalPathStateException​(String s)
      构造具有指定详细消息的 IllegalPathStateException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalPathStateException

        public IllegalPathStateException​()
        构造一个没有详细消息的 IllegalPathStateException 。
        从以下版本开始：
        1.2

      • IllegalPathStateException

        public IllegalPathStateException​(String s)
        构造具有指定详细消息的 IllegalPathStateException 。
        参数
        s - 详细信息
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.geom (Java SE 9 & JDK 9 )

java.awt.geom

Interfaces

  • PathIterator

Classes

  • AffineTransform
  • Arc2D
  • Arc2D.Double
  • Arc2D.Float
  • Area
  • CubicCurve2D
  • CubicCurve2D.Double
  • CubicCurve2D.Float
  • Dimension2D
  • Ellipse2D
  • Ellipse2D.Double
  • Ellipse2D.Float
  • FlatteningPathIterator
  • GeneralPath
  • Line2D
  • Line2D.Double
  • Line2D.Float
  • Path2D
  • Path2D.Double
  • Path2D.Float
  • Point2D
  • Point2D.Double
  • Point2D.Float
  • QuadCurve2D
  • QuadCurve2D.Double
  • QuadCurve2D.Float
  • Rectangle2D
  • Rectangle2D.Double
  • Rectangle2D.Float
  • RectangularShape
  • RoundRectangle2D
  • RoundRectangle2D.Double
  • RoundRectangle2D.Float

Exceptions

  • IllegalPathStateException
  • NoninvertibleTransformException


java.awt.geom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.geom

提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。 该软件包的一些重要功能包括：
  • 用于操作几何的类，如AffineTransform和由所有Shape对象实现的PathIterator接口。
  • 实现Shape接口的类，如CubicCurve2D，Ellipse2D，Line2D，Rectangle2D和GeneralShape。
  • Area类，它提供了对其他Shape对象进行add（union），subtraction，intersect和exclusiveOR操作的机制。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    PathIterator
    PathIterator接口提供了实现Shape接口的对象的机制，以便通过允许调用者一次检索该边界的路径来返回其边界的几何。
  • 类摘要
    Class 描述
    AffineTransform
    AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“平直度”和“平行度”。
    Arc2D
    Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或 PIE ）。
    Arc2D.Double
    此类定义了 double精度中指定的弧。
    Arc2D.Float
    该类定义了 float精度中指定的弧。
    Area
    一个 Area对象存储并操纵对二维空间的封闭区域的分辨率独立描述。
    CubicCurve2D
    CubicCurve2D类定义了 (x,y)坐标空间中的三次参数曲线段。
    CubicCurve2D.Double
    用 double坐标指定的三次参数曲线段。
    CubicCurve2D.Float
    用 float坐标指定的三次参数曲线段。
    Dimension2D
    Dimension2D类是封装宽度和高度维度。
    Ellipse2D
    Ellipse2D类描述了由框架矩形定义的椭圆。
    Ellipse2D.Double
    Double类定义了一个 double精度中指定的椭圆。
    Ellipse2D.Float
    Float类定义了一个 float精度中指定的椭圆。
    FlatteningPathIterator
    FlatteningPathIterator类返回另一个PathIterator对象的展平视图。
    GeneralPath
    GeneralPath类表示由直线，二次和立方（Bézier）曲线构成的几何路径。
    Line2D
    此 Line2D表示 (x,y)坐标空间中的线段。
    Line2D.Double
    用双坐标指定的线段。
    Line2D.Float
    用浮点坐标指定的线段。
    Path2D
    Path2D类提供了一个简单而又灵活的形状，表示任意的几何路径。
    Path2D.Double
    Double类定义了一个几何路径，坐标存储在双精度浮点中。
    Path2D.Float
    Float类定义了坐标存储在单精度浮点中的几何路径。
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Point2D.Double
    Double类定义了 double精度中指定的点。
    Point2D.Float
    Float类定义了浮点精度指定的点。
    QuadCurve2D
    QuadCurve2D类定义了 (x,y)坐标空间中的二次参数曲线段。
    QuadCurve2D.Double
    用 double坐标指定的二次参数曲线段。
    QuadCurve2D.Float
    用 float坐标指定的二次参数曲线段。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
    Rectangle2D.Double
    Double类定义了一个双坐标指定的矩形。
    Rectangle2D.Float
    Float类定义了一个以浮点坐标指定的矩形。
    RectangularShape
    RectangularShape是几何由矩形框架定义的Shape对象的基类。
    RoundRectangle2D
    RoundRectangle2D类定义了一个矩形，其圆角由位置 (x,y)定义，尺寸为 (w x h) ，以及 (w x h)的宽度和高度。
    RoundRectangle2D.Double
    Double类定义了一个矩形，其圆角在 double均指定。
    RoundRectangle2D.Float
    Float类定义了一个带有圆角的矩形，全部在 float坐标中指定。
  • 异常摘要
    异常 描述
    IllegalPathStateException
    如果在正在执行的特定操作的非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段追加到GeneralPath 。
    NoninvertibleTransformException
    The NoninvertibleTransformException class represents an exception that is thrown if an operation is performed requiring the inverse of an AffineTransform object but the AffineTransform is in a non-invertible state.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.geom Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.geom

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.geom.AffineTransform (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.geom.Area (implements java.lang.Cloneable, java.awt.Shape)
    • java.awt.geom.CubicCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.CubicCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.CubicCurve2D.Float (implements java.io.Serializable)
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
    • java.awt.geom.FlatteningPathIterator (implements java.awt.geom.PathIterator)
    • java.awt.geom.Line2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Line2D.Double (implements java.io.Serializable)
      • java.awt.geom.Line2D.Float (implements java.io.Serializable)
    • java.awt.geom.Path2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Path2D.Double (implements java.io.Serializable)
      • java.awt.geom.Path2D.Float (implements java.io.Serializable)
        • java.awt.geom.GeneralPath
    • java.awt.geom.Point2D (implements java.lang.Cloneable)
      • java.awt.geom.Point2D.Double (implements java.io.Serializable)
      • java.awt.geom.Point2D.Float (implements java.io.Serializable)
    • java.awt.geom.QuadCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.QuadCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.QuadCurve2D.Float (implements java.io.Serializable)
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Arc2D
        • java.awt.geom.Arc2D.Double (implements java.io.Serializable)
        • java.awt.geom.Arc2D.Float (implements java.io.Serializable)
      • java.awt.geom.Ellipse2D
        • java.awt.geom.Ellipse2D.Double (implements java.io.Serializable)
        • java.awt.geom.Ellipse2D.Float (implements java.io.Serializable)
      • java.awt.geom.Rectangle2D
        • java.awt.geom.Rectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.Rectangle2D.Float (implements java.io.Serializable)
      • java.awt.geom.RoundRectangle2D
        • java.awt.geom.RoundRectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.RoundRectangle2D.Float (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.awt.geom.NoninvertibleTransformException
        • java.lang.RuntimeException
          • java.awt.geom.IllegalPathStateException

Interface Hierarchy

  • java.awt.geom.PathIterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Line2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Line2D

  • java.lang.Object
    • java.awt.geom.Line2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    Line2D.Double ， Line2D.Float

    public abstract class Line2D
extends Object
implements Shape, Cloneable
    此Line2D表示(x,y)坐标空间中的线段。

    此类只是存储2D线段的所有对象的抽象超类。 坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Line2D.Double
      用双坐标指定的线段。
      static class  Line2D.Float
      用浮点坐标指定的线段。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Line2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建与此对象相同类的新对象。
      boolean contains​(double x, double y)
      测试指定的坐标是否在该 Line2D的边界内。
      boolean contains​(double x, double y, double w, double h)
      测试这个 Line2D的内部 Line2D完全包含指定的一组直角坐标。
      boolean contains​(Point2D p)
      测试一个给定的 Point2D是否在这个 Line2D的边界内。
      boolean contains​(Rectangle2D r)
      测试这个 Line2D的内部 Line2D完全包含指定的 Rectangle2D 。
      Rectangle getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      abstract Point2D getP1​()
      返回开始 Point2D如此 Line2D 。
      abstract Point2D getP2​()
      返回结束 Point2D如此 Line2D 。
      PathIterator getPathIterator​(AffineTransform at)
      返回定义此 Line2D边界的迭代对象。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代对象，该对象定义了此扁平化的边界 Line2D 。
      abstract double getX1​()
      以双精度返回起始点的X坐标。
      abstract double getX2​()
      X-
      abstract double getY1​()
      新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
      abstract double getY2​()
      以双精度返回终点的Y坐标。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      boolean intersectsLine​(double x1, double y1, double x2, double y2)
      测试从 (x1,y1)到 (x2,y2)线段 (x2,y2)与此线段相交。
      boolean intersectsLine​(Line2D l)
      测试指定的线段是否与此线段相交。
      static boolean linesIntersect​(double x1, double y1, double x2, double y2, double x3, double y3, double x4, double y4)
      测试，如果线段从 (x1,y1)到 (x2,y2)相交的线段从 (x3,y3)到 (x4,y4) 。
      double ptLineDist​(double px, double py)
      返回从点到此行的距离。
      static double ptLineDist​(double x1, double y1, double x2, double y2, double px, double py)
      返回从点到行的距离。
      double ptLineDist​(Point2D pt)
      返回从 Point2D到此行的距离。
      double ptLineDistSq​(double px, double py)
      返回从点到此行的距离的平方。
      static double ptLineDistSq​(double x1, double y1, double x2, double y2, double px, double py)
      返回从点到行的距离的平方。
      double ptLineDistSq​(Point2D pt)
      返回从指定的 Point2D到此行的距离的平方。
      double ptSegDist​(double px, double py)
      返回从点到此线段的距离。
      static double ptSegDist​(double x1, double y1, double x2, double y2, double px, double py)
      返回从点到线段的距离。
      double ptSegDist​(Point2D pt)
      返回从 Point2D到此线段的距离。
      double ptSegDistSq​(double px, double py)
      返回从点到该线段的距离的平方。
      static double ptSegDistSq​(double x1, double y1, double x2, double y2, double px, double py)
      返回从点到线段的距离的平方。
      double ptSegDistSq​(Point2D pt)
      返回从 Point2D到此线段的距离的平方。
      int relativeCCW​(double px, double py)
      返回指定点 (px,py)相对于该线段所在的位置的 (px,py) 。
      static int relativeCCW​(double x1, double y1, double x2, double y2, double px, double py)
      返回指定点 (px,py)相对于从 (x1,y1)到 (x2,y2)线段的 (x1,y1)的 (x2,y2) 。
      int relativeCCW​(Point2D p)
      返回相对于该线段指定的 Point2D位置的指示符。
      abstract void setLine​(double x1, double y1, double x2, double y2)
      将此 Line2D的终点的位置设置为指定的双坐标。
      void setLine​(Line2D l)
      将此 Line2D的终点位置设置为与指定的 Line2D终点相同。
      void setLine​(Point2D p1, Point2D p2)
      将此 Line2D的终点位置设置为指定的 Point2D坐标。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.awt.Shape

        getBounds2D

    • 构造方法详细信息

      • Line2D

        protected Line2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种附件方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        Line2D.Float ， Line2D.Double

    • 方法详细信息

      • getX1

        public abstract double getX1​()
        200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
        结果
        该 Line2D对象的起始点的X坐标。
        从以下版本开始：
        1.2

      • getY1

        public abstract double getY1​()
        新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
        结果
        这个 Line2D对象的起始点的Y坐标。
        从以下版本开始：
        1.2

      • getP1

        public abstract Point2D getP1​()
        返回 Point2D的起始 Line2D 。
        结果
        该 Point2D的起始 Line2D 。
        从以下版本开始：
        1.2

      • getX2

        public abstract double getX2​()
        X-
        结果
        该 Line2D对象的终点的X坐标。
        从以下版本开始：
        1.2

      • getY2

        public abstract double getY2​()
        以双精度返回终点的Y坐标。
        结果
        该 Line2D对象的终点的Y坐标。
        从以下版本开始：
        1.2

      • getP2

        public abstract Point2D getP2​()
        返回结束 Point2D如此 Line2D 。
        结果
        这 Point2D的这个 Line2D 。
        从以下版本开始：
        1.2

      • setLine

        public abstract void setLine​(double x1,
                             double y1,
                             double x2,
                             double y2)
        将此 Line2D的终点位置设置为指定的双坐标。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • setLine

        public void setLine​(Point2D p1,
                    Point2D p2)
        将此 Line2D的终点位置设置为指定的 Point2D坐标。
        参数
        p1 - 线段的启动 Point2D
        p2 - 线段的末端 Point2D
        从以下版本开始：
        1.2

      • setLine

        public void setLine​(Line2D l)
        将此 Line2D的终点位置设置为与指定的 Line2D终点相同。
        参数
        l - 指定的 Line2D
        从以下版本开始：
        1.2

      • relativeCCW

        public static int relativeCCW​(double x1,
                              double y1,
                              double x2,
                              double y2,
                              double px,
                              double py)
        返回指定点(px,py)相对于从(x1,y1)到(x2,y2)线段的(x1,y1)的(x2,y2) 。 返回值可以是1，-1或0，并指示指定的行必须围绕其第一个终点(x1,y1)枢转，以指向指定点(px,py) 。

        返回值为1表示线段必须朝向正Y轴的正X轴方向转动。 在Java 2D使用的默认坐标系中，该方向是逆时针方向。

        返回值为-1表示线段必须朝向正Y轴取正X轴的方向转动。 在默认坐标系中，该方向为顺时针方向。

        返回值为0表示该点正好位于线段上。 请注意，指标值为0是罕见的，因为浮点舍入问题而不能用于确定共线性。

        如果该点共线与线段，但终点之间没有，则该值将是-1如果点“超越(x1,y1) ”或1如果点“超越(x2,y2) ”。

        参数
        x1 - 指定线段起始点的X坐标
        y1 - 指定线段起始点的Y坐标
        x2 - 指定线段终点的X坐标
        y2 - 指定线段终点的Y坐标
        px - 要与指定线段进行比较的指定点的X坐标
        py - 要与指定线段进行比较的指定点的Y坐标
        结果
        指示相对于由前两个指定坐标形成的线段的第三指定坐标的位置的整数。
        从以下版本开始：
        1.2

      • relativeCCW

        public int relativeCCW​(double px,
                       double py)
        返回指定点(px,py)相对于该线段所在的指示。 请参阅方法注释relativeCCW(double, double, double, double, double, double)来解释返回值。
        参数
        px - 要与此 Line2D进行比较的指定点的X坐标
        py - 要与此 Line2D进行比较的指定点的Y坐标
        结果
        一个整数，表示相对于这个 Line2D的指定坐标的位置
        从以下版本开始：
        1.2
        另请参见：
        relativeCCW(double, double, double, double, double, double)

      • relativeCCW

        public int relativeCCW​(Point2D p)
        返回相对于该线段指定的Point2D所在位置的指示符。 请参阅方法注释relativeCCW(double, double, double, double, double, double)来解释返回值。
        参数
        p - 指定的 Point2D要与此 Line2D进行比较
        结果
        一个整数，表示指定的 Point2D相对于该 Line2D
        从以下版本开始：
        1.2
        另请参见：
        relativeCCW(double, double, double, double, double, double)

      • linesIntersect

        public static boolean linesIntersect​(double x1,
                                     double y1,
                                     double x2,
                                     double y2,
                                     double x3,
                                     double y3,
                                     double x4,
                                     double y4)
        测试，如果线段从 (x1,y1)到 (x2,y2)相交的线段从 (x3,y3)到 (x4,y4) 。
        参数
        x1 - 第一个指定线段起始点的X坐标
        y1 - 第一个指定线段起始点的Y坐标
        x2 - 第一个指定线段的终点的X坐标
        y2 - 第一个指定线段的终点的Y坐标
        x3 - 第二个指定线段起始点的X坐标
        y3 - 第二个指定线段起始点的Y坐标
        x4 - 第二个指定线段的终点的X坐标
        y4 - 第二个指定线段的终点的Y坐标
        结果
        true如果第一个指定的线段和第二个指定的线段相交; 否则为false 。
        从以下版本开始：
        1.2

      • intersectsLine

        public boolean intersectsLine​(double x1,
                              double y1,
                              double x2,
                              double y2)
        测试从 (x1,y1)到 (x2,y2)线段 (x2,y2)与此线段相交。
        参数
        x1 - 指定线段起始点的X坐标
        y1 - 指定线段起始点的Y坐标
        x2 - 指定线段终点的X坐标
        y2 - 指定线段终点的Y坐标
        结果
        true如果这个线段和指定的线段相交; 否则为false 。
        从以下版本开始：
        1.2

      • intersectsLine

        public boolean intersectsLine​(Line2D l)
        测试指定的线段是否与此线段相交。
        参数
        l - 指定的 Line2D
        结果
        true如果这个线段和指定的线段相交; 否则为false 。
        从以下版本开始：
        1.2

      • ptSegDistSq

        public static double ptSegDistSq​(double x1,
                                 double y1,
                                 double x2,
                                 double y2,
                                 double px,
                                 double py)
        返回从点到线段的距离的平方。 测量的距离是指定点与指定终点之间最近点之间的距离。 如果指定的点与终点之间的线段相交，则此方法返回0.0。
        参数
        x1 - 指定线段起始点的X坐标
        y1 - 指定线段起始点的Y坐标
        x2 - 指定线段终点的X坐标
        y2 - 指定线段终点的Y坐标
        px - 相对于指定线段测量的指定点的X坐标
        py - 相对于指定线段测量的指定点的Y坐标
        结果
        一个双指数值，即从指定点到指定线段的距离的平方。
        从以下版本开始：
        1.2
        另请参见：
        ptLineDistSq(double, double, double, double, double, double)

      • ptSegDist

        public static double ptSegDist​(double x1,
                               double y1,
                               double x2,
                               double y2,
                               double px,
                               double py)
        返回从点到线段的距离。 测量的距离是指定点与指定终点之间最近点之间的距离。 如果指定的点与终点之间的线段相交，则此方法返回0.0。
        参数
        x1 - 指定线段起始点的X坐标
        y1 - 指定线段起始点的Y坐标
        x2 - 指定线段终点的X坐标
        y2 - 指定线段终点的Y坐标
        px - 相对于指定线段测量的指定点的X坐标
        py - 根据指定的线段测量指定点的Y坐标
        结果
        一个双重值，即从指定点到指定线段的距离。
        从以下版本开始：
        1.2
        另请参见：
        ptLineDist(double, double, double, double, double, double)

      • ptSegDistSq

        public double ptSegDistSq​(double px,
                          double py)
        返回从点到该线段的距离的平方。 测量的距离是指定点与当前行终点之间最近点之间的距离。 如果指定的点与终点之间的线段相交，则此方法返回0.0。
        参数
        px - 针对该线段测量的指定点的X坐标
        py - 针对该线段测量的指定点的Y坐标
        结果
        一个双指数值，即从指定点到当前线段的距离的平方。
        从以下版本开始：
        1.2
        另请参见：
        ptLineDistSq(double, double)

      • ptSegDistSq

        public double ptSegDistSq​(Point2D pt)
        返回从Point2D到该线段的距离的平方。 测量的距离是指定点与当前行终点之间最近点之间的距离。 如果指定的点与终点之间的线段相交，则此方法返回0.0。
        参数
        pt - 根据该线段测量指定的 Point2D 。
        结果
        一个双重值，即从指定的 Point2D到当前线段的距离的平方。
        从以下版本开始：
        1.2
        另请参见：
        ptLineDistSq(Point2D)

      • ptSegDist

        public double ptSegDist​(double px,
                        double py)
        返回从点到此线段的距离。 测量的距离是指定点与当前行终点之间最近点之间的距离。 如果指定的点与终点之间的线段相交，则此方法返回0.0。
        参数
        px - 针对该线段测量的指定点的X坐标
        py - 针对该线段测量的指定点的Y坐标
        结果
        一个双重值，即从指定点到当前线段的距离。
        从以下版本开始：
        1.2
        另请参见：
        ptLineDist(double, double)

      • ptSegDist

        public double ptSegDist​(Point2D pt)
        返回从Point2D到此线段的距离。 测量的距离是指定点与当前行终点之间最近点之间的距离。 如果指定的点与终点之间的线段相交，则此方法返回0.0。
        参数
        pt - 根据该线段测量指定的 Point2D
        结果
        一个双重值，即从指定的 Point2D到当前线段的距离。
        从以下版本开始：
        1.2
        另请参见：
        ptLineDist(Point2D)

      • ptLineDistSq

        public static double ptLineDistSq​(double x1,
                                  double y1,
                                  double x2,
                                  double y2,
                                  double px,
                                  double py)
        返回从点到行的距离的平方。 测量的距离是指定点与由指定坐标定义的无限延伸线之间的最近点之间的距离。 如果指定的点与行相交，则此方法返回0.0。
        参数
        x1 - 指定行的起始点的X坐标
        y1 - 指定行的起始点的Y坐标
        x2 - 指定行终点的X坐标
        y2 - 指定行终点的Y坐标
        px - 要针对指定线测量的指定点的X坐标
        py - 根据指定线测量的指定点的Y坐标
        结果
        一个双重值，即从指定点到指定行的距离的平方。
        从以下版本开始：
        1.2
        另请参见：
        ptSegDistSq(double, double, double, double, double, double)

      • ptLineDist

        public static double ptLineDist​(double x1,
                                double y1,
                                double x2,
                                double y2,
                                double px,
                                double py)
        返回从点到行的距离。 测量的距离是指定点与由指定坐标定义的无限延伸线之间的最近点之间的距离。 如果指定的点与行相交，则此方法返回0.0。
        参数
        x1 - 指定行的起始点的X坐标
        y1 - 指定行起始点的Y坐标
        x2 - 指定行终点的X坐标
        y2 - 指定行终点的Y坐标
        px - 根据指定线测量的指定点的X坐标
        py - 指定点的Y坐标是根据指定的线进行测量
        结果
        一个双重值，即从指定点到指定行的距离。
        从以下版本开始：
        1.2
        另请参见：
        ptSegDist(double, double, double, double, double, double)

      • ptLineDistSq

        public double ptLineDistSq​(double px,
                           double py)
        返回从点到此行的距离的平方。 测量的距离是指定点与由该Line2D定义的无限延伸线之间的最近点之间的距离。 如果指定的点与行相交，则此方法返回0.0。
        参数
        px - 针对该行测量的指定点的X坐标
        py - 针对该行测量的指定点的Y坐标
        结果
        一个双重值，即从指定点到当前行的距离的平方。
        从以下版本开始：
        1.2
        另请参见：
        ptSegDistSq(double, double)

      • ptLineDistSq

        public double ptLineDistSq​(Point2D pt)
        返回从指定的Point2D到该行的距离的平方。 测量的距离是指定点与由该Line2D定义的无限延伸线之间的最近点之间的距离。 如果指定的点与行相交，则此方法返回0.0。
        参数
        pt - 根据该行测量指定的 Point2D
        结果
        一个双重值，即从指定的 Point2D到当前行的距离的平方。
        从以下版本开始：
        1.2
        另请参见：
        ptSegDistSq(Point2D)

      • ptLineDist

        public double ptLineDist​(double px,
                         double py)
        返回从点到此行的距离。 测量的距离是指定点与由该Line2D定义的无限延伸线之间的最近点之间的距离。 如果指定的点与行相交，则此方法返回0.0。
        参数
        px - 针对该行测量的指定点的X坐标
        py - 针对该行测量的指定点的Y坐标
        结果
        一个双重值，即从指定点到当前行的距离。
        从以下版本开始：
        1.2
        另请参见：
        ptSegDist(double, double)

      • ptLineDist

        public double ptLineDist​(Point2D pt)
        返回从Point2D到此行的距离。 测量的距离是指定点与由该Line2D定义的无限延伸线之间的最近点之间的距离。 如果指定的点与行相交，则此方法返回0.0。
        参数
        pt - 正在测量指定的 Point2D
        结果
        一个双重值，即从指定的 Point2D到当前行的距离。
        从以下版本开始：
        1.2
        另请参见：
        ptSegDist(Point2D)

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在该Line2D的边界内。 这种方法是实现Shape接口所必需的，但在Line2D对象的情况下，它始终返回false因为一行不包含区域。
        Specified by:
        contains在接口 Shape
        参数
        x - 要测试的指定点的X坐标
        y - 要测试的指定点的Y坐标
        结果
        false因为一个 Line2D包含区域。
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(Point2D p)
        测试一个给定的Point2D是否在这个Line2D的边界内。 这种方法是实现Shape接口所必需的，但在Line2D对象的情况下，它总是返回false因为一行不包含区域。
        Specified by:
        contains在接口 Shape
        参数
        p - 要测试的指定的 Point2D
        结果
        false因为 Line2D包含区域。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 矩形区域被认为是交叉的Shape如果任何点被包含在双方的内部Shape和指定的矩形区域。

        Shape.intersects()方法允许Shape实现保守返回true当：

        • 矩形区域与Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回true即使矩形区域不与Shape相交。 Area类比大多数Shape对象执行几何交集的更精确的计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • intersects

        public boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许Shape实现保守返回true时：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于一些Shapes这个方法可能会返回true即使Rectangle2D不与Shape相交。 Area类比大多数Shape对象执行几何交集的更精确的计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的Rectangle2D的内部相交，或者很可能相交，并且交叉点计算将太昂贵，不能执行; false否则。
        从以下版本开始：
        1.2
        另请参见：
        Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试这个Line2D的内部是否包含指定的一组直角坐标。 这种方法是实现Shape接口所必需的，但在Line2D对象的情况下，它总是返回false，因为一行不包含区域。
        Specified by:
        contains接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        false因为一个 Line2D包含区域。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(Rectangle2D r)
        测试这个Line2D的内部Line2D全部包含指定的Rectangle2D 。 这种方法是实现Shape接口所必需的，但在Line2D对象的情况下，它总是返回false因为一行不包含区域。
        Specified by:
        contains在接口 Shape
        参数
        r - 要测试的指定 Rectangle2D
        结果
        false因为一个 Line2D包含区域。
        从以下版本开始：
        1.2
        另请参见：
        Shape.contains(double, double, double, double)

      • getBounds

        public Rectangle getBounds​()
        返回一个整数Rectangle完全包围Shape 。 请注意，不保证返回的Rectangle是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle 。 如果Shape溢出整数数据类型的有限范围，则返回的Rectangle也可能无法完全包含Shape 。 getBounds2D方法通常返回更严格的边界框，因为它在表示方面具有更大的灵活性。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(x,y)需要bounds.contains(x,y)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(x,y)并不表示shape.contains(x,y)

        Specified by:
        getBounds接口 Shape
        结果
        一个整数 Rectangle ，完全包围了 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds2D()

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回一个定义Line2D边界的迭代对象。 此类的迭代器不是多线程安全的，这意味着此Line2D类不保证对此Line2D对象的几何形状的修改不会影响已处理的该几何的任何迭代。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 指定的AffineTransform
        结果
        一个PathIterator定义了这个Line2D的边界。
        从以下版本开始：
        1.2

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at,
                                    double flatness)
        返回一个迭代对象，该对象定义了此扁平化的边界Line2D 。 此类的迭代器不是多线程安全的，这意味着该Line2D类不保证对此Line2D对象的几何的修改不会影响已经在处理的该几何的任何迭代。
        Specified by:
        getPathIterator接口 Shape
        参数
        at - 指定的 AffineTransform
        flatness - 给定曲线的控制点的最大量可以在将细分曲线替换为连接终点的直线代替之前从共线线变化。 由于Line2D对象总是平坦的，因此该参数将被忽略。
        结果
        一个 PathIterator定义了平面化的边界 Line2D
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        创建与此对象相同类的新对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.2
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Line2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Line2D.Double

  • java.lang.Object
    • java.awt.geom.Line2D
      • java.awt.geom.Line2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Line2D

    public static class Line2D.Double
extends Line2D
implements Serializable
    用双坐标指定的线段。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Line2D

        Line2D.Double, Line2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double x1
      线段起始点的X坐标。
      double x2
      线段终点的X坐标。
      double y1
      线段起始点的Y坐标。
      double y2
      线段终点的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造并初始化坐标（0，0）→（0，0）的行。
      Double​(double x1, double y1, double x2, double y2)
      从指定的坐标构建和初始化一个 Line2D 。
      Double​(Point2D p1, Point2D p2)
      构造并初始化一个 Line2D从指定 Point2D对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Point2D getP1​()
      返回开始 Point2D如此 Line2D 。
      Point2D getP2​()
      返回结束 Point2D如此 Line2D 。
      double getX1​()
      以双精度返回起始点的X坐标。
      double getX2​()
      以双精度返回终点的X坐标。
      double getY1​()
      以双精度返回起始点的Y坐标。
      double getY2​()
      以双精度返回终点的Y坐标。
      void setLine​(double x1, double y1, double x2, double y2)
      将此 Line2D的终点的位置设置为指定的双坐标。

      • Methods inherited from class java.awt.geom.Line2D

        clone, contains, contains, contains, contains, getBounds, getPathIterator, getPathIterator, intersects, intersects, intersectsLine, intersectsLine, linesIntersect, ptLineDist, ptLineDist, ptLineDist, ptLineDistSq, ptLineDistSq, ptLineDistSq, ptSegDist, ptSegDist, ptSegDist, ptSegDistSq, ptSegDistSq, ptSegDistSq, relativeCCW, relativeCCW, relativeCCW, setLine, setLine

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • x1

        public double x1
        线段起始点的X坐标。
        从以下版本开始：
        1.2

      • y1

        public double y1
        线段起始点的Y坐标。
        从以下版本开始：
        1.2

      • x2

        public double x2
        线段终点的X坐标。
        从以下版本开始：
        1.2

      • y2

        public double y2
        线段终点的Y坐标。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        构造并初始化坐标（0，0）→（0，0）的行。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x1,
              double y1,
              double x2,
              double y2)
        从指定的坐标构建和初始化一个 Line2D 。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • Double

        public Double​(Point2D p1,
              Point2D p2)
        构造并初始化一个 Line2D从指定 Point2D对象。
        参数
        p1 - 该线段的启动 Point2D
        p2 - 该线段的末端 Point2D
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX1

        public double getX1​()
        200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
        Specified by:
        getX1在类 Line2D
        结果
        这个 Line2D对象的起始点的X坐标。
        从以下版本开始：
        1.2

      • getY1

        public double getY1​()
        新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
        Specified by:
        getY1在类 Line2D
        结果
        这个 Line2D对象的起点的Y坐标。
        从以下版本开始：
        1.2

      • getP1

        public Point2D getP1​()
        返回开始 Point2D如此 Line2D 。
        Specified by:
        getP1在 Line2D
        结果
        该 Point2D的起始 Line2D 。
        从以下版本开始：
        1.2

      • getX2

        public double getX2​()
        X-
        Specified by:
        getX2在 Line2D
        结果
        这个 Line2D对象的终点的X坐标。
        从以下版本开始：
        1.2

      • getY2

        public double getY2​()
        以双精度返回终点的Y坐标。
        Specified by:
        getY2在 Line2D
        结果
        该 Line2D对象的终点的Y坐标。
        从以下版本开始：
        1.2

      • getP2

        public Point2D getP2​()
        返回 Point2D的结尾 Line2D 。
        Specified by:
        getP2在 Line2D
        结果
        最终 Point2D如此 Line2D 。
        从以下版本开始：
        1.2

      • setLine

        public void setLine​(double x1,
                    double y1,
                    double x2,
                    double y2)
        将此 Line2D的终点的位置设置为指定的双坐标。
        Specified by:
        setLine在 Line2D
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 该方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape的定义轮廓上的shape可能不被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Line2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Line2D.Float

  • java.lang.Object
    • java.awt.geom.Line2D
      • java.awt.geom.Line2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Line2D

    public static class Line2D.Float
extends Line2D
implements Serializable
    用浮点坐标指定的线段。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Line2D

        Line2D.Double, Line2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float x1
      线段起始点的X坐标。
      float x2
      线段终点的X坐标。
      float y1
      线段起始点的Y坐标。
      float y2
      线段终点的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造并初始化坐标（0，0）→（0，0）的行。
      Float​(float x1, float y1, float x2, float y2)
      从指定的坐标构造和初始化一行。
      Float​(Point2D p1, Point2D p2)
      构造并初始化一个 Line2D从指定 Point2D对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Point2D getP1​()
      返回开始 Point2D如此 Line2D 。
      Point2D getP2​()
      返回结束 Point2D如此 Line2D 。
      double getX1​()
      200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
      double getX2​()
      X-
      double getY1​()
      新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
      double getY2​()
      以双精度返回终点的Y坐标。
      void setLine​(double x1, double y1, double x2, double y2)
      将此 Line2D的终点的位置设置为指定的双坐标。
      void setLine​(float x1, float y1, float x2, float y2)
      将此 Line2D的终点的位置设置为指定的浮点坐标。

      • Methods inherited from class java.awt.geom.Line2D

        clone, contains, contains, contains, contains, getBounds, getPathIterator, getPathIterator, intersects, intersects, intersectsLine, intersectsLine, linesIntersect, ptLineDist, ptLineDist, ptLineDist, ptLineDistSq, ptLineDistSq, ptLineDistSq, ptSegDist, ptSegDist, ptSegDist, ptSegDistSq, ptSegDistSq, ptSegDistSq, relativeCCW, relativeCCW, relativeCCW, setLine, setLine

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • x1

        public float x1
        线段起始点的X坐标。
        从以下版本开始：
        1.2

      • y1

        public float y1
        线段起始点的Y坐标。
        从以下版本开始：
        1.2

      • x2

        public float x2
        线段终点的X坐标。
        从以下版本开始：
        1.2

      • y2

        public float y2
        线段终点的Y坐标。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造并初始化坐标（0，0）→（0，0）的行。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x1,
             float y1,
             float x2,
             float y2)
        从指定的坐标构造和初始化一行。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • Float

        public Float​(Point2D p1,
             Point2D p2)
        构造并初始化一个 Line2D从指定 Point2D对象。
        参数
        p1 - 该线段的启动 Point2D
        p2 - 该线段的末端 Point2D
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX1

        public double getX1​()
        200新新新新200新新200新200新新200新200新新200新新200新新200新新200新新200新新新200新新200
        Specified by:
        getX1在 Line2D
        结果
        这个 Line2D对象的起始点的X坐标。
        从以下版本开始：
        1.2

      • getY1

        public double getY1​()
        新新新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新200新新200
        Specified by:
        getY1中的 Line2D
        结果
        这个 Line2D对象的起点的Y坐标。
        从以下版本开始：
        1.2

      • getP1

        public Point2D getP1​()
        返回 Point2D的起始 Line2D 。
        Specified by:
        getP1在类 Line2D
        结果
        开始 Point2D如此 Line2D 。
        从以下版本开始：
        1.2

      • getX2

        public double getX2​()
        X-
        Specified by:
        getX2在 Line2D
        结果
        该 Line2D对象的终点的X坐标。
        从以下版本开始：
        1.2

      • getY2

        public double getY2​()
        以双精度返回终点的Y坐标。
        Specified by:
        getY2在 Line2D
        结果
        该 Line2D对象的终点的Y坐标。
        从以下版本开始：
        1.2

      • getP2

        public Point2D getP2​()
        返回结束 Point2D如此 Line2D 。
        Specified by:
        getP2在 Line2D
        结果
        该 Point2D的这个 Line2D 。
        从以下版本开始：
        1.2

      • setLine

        public void setLine​(double x1,
                    double y1,
                    double x2,
                    double y2)
        将此 Line2D的终点的位置设置为指定的双坐标。
        Specified by:
        setLine在 Line2D
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • setLine

        public void setLine​(float x1,
                    float y1,
                    float x2,
                    float y2)
        将此 Line2D的终点的位置设置为指定的浮点坐标。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更精确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义大纲上的shape可能不被视为包含在返回的bounds对象中的情况，但仅在原始shape未考虑这些点的情况下。

        如果一个point是在shape根据contains(point)方法，那么它必须在Rectangle2D范围内的对象中，根据contains(point)方法的bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NoninvertibleTransformException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class NoninvertibleTransformException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.geom.NoninvertibleTransformException
  • All Implemented Interfaces:
    Serializable

    public class NoninvertibleTransformException
extends 异常
    NoninvertibleTransformException类表示如果执行需要AffineTransform对象的反向但AffineTransform处于非可逆状态的操作时抛出的异常。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoninvertibleTransformException​(String s)
      使用指定的详细消息构造一个 NoninvertibleTransformException的实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoninvertibleTransformException

        public NoninvertibleTransformException​(String s)
        构造具有指定详细消息的 NoninvertibleTransformException实例。
        参数
        s - 详细信息
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Path2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Path2D

  • java.lang.Object
    • java.awt.geom.Path2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    Path2D.Double ， Path2D.Float

    public abstract class Path2D
extends Object
implements Shape, Cloneable
    Path2D类提供了一个简单而又灵活的形状，表示任意的几何路径。 它可以完全表示可以由PathIterator接口迭代的任何路径，包括其所有段类型和绕组规则，并且它实现了Shape接口的所有基本命中测试方法。

    处理可以用浮点精度表示和使用的数据时使用Path2D.Float 。 对于要求准确度或双精度范围的数据，请使用Path2D.Double 。

    Path2D提供了基本构建和管理几何路径所需的这些设施以及上述接口的实现，几乎没有添加解释。 如果操作封闭几何形状的内部是非常有用的，超过简单的命中测试，那么Area类提供了特别针对封闭图形的附加功能。 虽然这两个类名义上实现Shape接口，它们在目的不同，它们一起提供了一个几何形状，其中两个有用的视图Path2D主要处理由路径段和形成的轨迹Area更多地处理解释和2D几何空间封闭区域的操纵。

    PathIterator接口对构成路径的段类型进行了更详细的描述，并且对绕组规则进行了更详细的描述，该规则控制了如何确定哪些区域在路径内部或外部。

    从以下版本开始：
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Path2D.Double
      Double类定义了一个几何路径，坐标存储在双精度浮点中。
      static class  Path2D.Float
      Float类定义了坐标存储在单精度浮点中的几何路径。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int WIND_EVEN_ODD
      用于确定路径内部的偶数绕组规则。
      static int WIND_NON_ZERO
      用于确定路径内部的非零绕组规则。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void append​(PathIterator pi, boolean connect)
      将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
      void append​(Shape s, boolean connect)
      将指定的 Shape对象的几何对象附加到路径，可能将新几何体连接到具有线段的现有路径段。
      abstract Object clone​()
      创建与此对象相同类的新对象。
      void closePath​()
      通过将直线绘制回最后一个 moveTo的坐标来关闭当前子路径。
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      static boolean contains​(PathIterator pi, double x, double y)
      测试指定的坐标是否在指定的PathIterator的封闭边界内。
      static boolean contains​(PathIterator pi, double x, double y, double w, double h)
      测试指定的矩形区域是否完全在指定的PathIterator的封闭边界内。
      static boolean contains​(PathIterator pi, Point2D p)
      测试指定Point2D是指定的封闭边界内PathIterator 。
      static boolean contains​(PathIterator pi, Rectangle2D r)
      测试指定Rectangle2D是完全指定的封闭边界内PathIterator 。
      boolean contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      Shape createTransformedShape​(AffineTransform at)
      返回一个新的 Shape代表这个 Path2D的转换版本。
      abstract void curveTo​(double x1, double y1, double x2, double y2, double x3, double y3)
      通过绘制与当前坐标和指定坐标 (x3,y3)相交的Bézier曲线，使用指定点 (x1,y1)和 (x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。
      Rectangle getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      Point2D getCurrentPoint​()
      将最近添加到路径末尾的坐标作为Point2D对象返回。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回一个沿 Shape边界迭代的迭代器对象，并提供对 Shape轮廓几何体的平坦化视图的访问。
      int getWindingRule​()
      返回填充样式卷绕规则。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。
      static boolean intersects​(PathIterator pi, double x, double y, double w, double h)
      测试指定的PathIterator的内部是否与指定的一组直角坐标的内部相交。
      static boolean intersects​(PathIterator pi, Rectangle2D r)
      测试指定的内部PathIterator相交指定的内部Rectangle2D 。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      abstract void lineTo​(double x, double y)
      通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
      abstract void moveTo​(double x, double y)
      通过移动到以双精度指定的指定坐标添加点到路径。
      abstract void quadTo​(double x1, double y1, double x2, double y2)
      通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
      void reset​()
      将路径重置为空。
      void setWindingRule​(int rule)
      将此路径的绕组规则设置为指定值。
      abstract void transform​(AffineTransform at)
      使用指定的AffineTransform转换此路径的几何。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.awt.Shape

        getBounds2D, getPathIterator

    • 字段详细信息

      • WIND_EVEN_ODD

        public static final int WIND_EVEN_ODD
        用于确定路径内部的偶数绕组规则。
        从以下版本开始：
        1.6
        另请参见：
        PathIterator.WIND_EVEN_ODD ， Constant Field Values

      • WIND_NON_ZERO

        public static final int WIND_NON_ZERO
        用于确定路径内部的非零绕组规则。
        从以下版本开始：
        1.6
        另请参见：
        PathIterator.WIND_NON_ZERO ， Constant Field Values

    • 方法详细信息

      • moveTo

        public abstract void moveTo​(double x,
                            double y)
        通过移动到以双精度指定的指定坐标添加点到路径。
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6

      • lineTo

        public abstract void lineTo​(double x,
                            double y)
        通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6

      • quadTo

        public abstract void quadTo​(double x1,
                            double y1,
                            double x2,
                            double y2)
        通过绘制与当前坐标和指定坐标(x2,y2)相交的二次曲线，使用指定点(x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。 所有坐标均以双精度指定。
        参数
        x1 - 二次控制点的X坐标
        y1 - 二次控制点的Y坐标
        x2 - 最终终点的X坐标
        y2 - 最终终点的Y坐标
        从以下版本开始：
        1.6

      • curveTo

        public abstract void curveTo​(double x1,
                             double y1,
                             double x2,
                             double y2,
                             double x3,
                             double y3)
        通过绘制与当前坐标和指定坐标(x3,y3)两者相交的Bézier曲线，使用指定点(x1,y1)和(x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。 所有坐标均以双精度指定。
        参数
        x1 - 第一个Bézier控制点的X坐标
        y1 - 第一个Bézier控制点的Y坐标
        x2 - 第二个Bézier控制点的X坐标
        y2 - 第二个Bézier控制点的Y坐标
        x3 - 最终终点的X坐标
        y3 - 最终终点的Y坐标
        从以下版本开始：
        1.6

      • closePath

        public final void closePath​()
        通过将直线绘制回最后一个moveTo的坐标来关闭当前子路径。 如果路径已经关闭，则此方法无效。
        从以下版本开始：
        1.6

      • append

        public final void append​(Shape s,
                         boolean connect)
        将指定的Shape对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。 如果connect参数为true ，并且路径不为空，则所附的Shape的几何中的任何初始moveTo Shape将变为lineTo段。 如果这种连接lineTo段的目的地坐标与当前打开的子路径的结束坐标匹配，那么该段被省略为多余的。 指定的Shape的绕组规则将被忽略，附加的几何体由为此路径指定的绕组规则控制。
        参数
        s - 其几何被附加到此路径的 Shape
        connect - 一个布尔值，用于控制是否将初始化的 moveTo段转换为 lineTo段，以将新几何体连接到现有路径
        从以下版本开始：
        1.6

      • append

        public abstract void append​(PathIterator pi,
                            boolean connect)
        将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。 如果connect参数为true ，并且路径不为空，则附加的Shape的几何中的任何初始moveTo Shape将变为lineTo段。 如果这样的连接lineTo段的目标坐标与当前打开的子路径的结束坐标匹配，则该段被省略为多余的。 指定的Shape的绕组规则将被忽略，附加的几何体由为此路径指定的绕组规则控制。
        参数
        pi - 其几何被附加到此路径的 PathIterator
        connect - 一个布尔值，用于控制是否将初始的 moveTo段转换为 lineTo段，以将新几何体连接到现有路径
        从以下版本开始：
        1.6

      • getWindingRule

        public final int getWindingRule​()
        返回填充样式卷绕规则。
        结果
        一个表示当前绕组规则的整数。
        从以下版本开始：
        1.6
        另请参见：
        WIND_EVEN_ODD ， WIND_NON_ZERO ， setWindingRule(int)

      • setWindingRule

        public final void setWindingRule​(int rule)
        将此路径的绕组规则设置为指定值。
        参数
        rule - 表示指定绕组规则的整数
        异常
        IllegalArgumentException - 如果 rule不是 WIND_EVEN_ODD或 WIND_NON_ZERO
        从以下版本开始：
        1.6
        另请参见：
        getWindingRule()

      • getCurrentPoint

        public final Point2D getCurrentPoint​()
        将最近添加到路径末尾的坐标作为Point2D对象返回。
        结果
        一个 Point2D对象，包含路径的结束坐标，如果路径中没有点， null 。
        从以下版本开始：
        1.6

      • reset

        public final void reset​()
        将路径重置为空。 追加位置被设置回路径的开头，所有坐标和点类型都被遗忘。
        从以下版本开始：
        1.6

      • transform

        public abstract void transform​(AffineTransform at)
        使用指定的AffineTransform转换此路径的几何。 几何体被转换到位，永久地改变由该对象定义的边界。
        参数
        at - AffineTransform用于转换区域
        从以下版本开始：
        1.6

      • createTransformedShape

        public final Shape createTransformedShape​(AffineTransform at)
        返回一个新的Shape代表这个Path2D的转换版本。 请注意，此方法未指定返回值的确切类型和坐标精度。 该方法将返回一个Shape，该Path2D对于转换后的几何不会比目前维护的Path2D精度更低，但也可能不包含更多的精度。 如果结果中精度与存储大小的权衡很重要，则应使用Path2D.Float和Path2D.Double子类中的方便构造函数来进行选择。
        参数
        at - AffineTransform用于转换新的 Shape 。
        结果
        一个新的 Shape ，转换为指定的 AffineTransform 。
        从以下版本开始：
        1.6

      • getBounds

        public final Rectangle getBounds​()
        返回一个整数Rectangle完全包围Shape 。 请注意，不保证返回的Rectangle是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle 。 如果Shape溢出整数数据类型的有限范围，则返回的Rectangle也可能无法完全包围Shape 。 getBounds2D方法通常返回更严格的边界框，因为它在表示方面具有更大的灵活性。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始的shape也不包含这些点的情况下。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(x,y)需要bounds.contains(x,y)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(x,y)并不表示shape.contains(x,y)

        Specified by:
        getBounds在接口 Shape
        结果
        一个整数 Rectangle ，完全包围了 Shape 。
        从以下版本开始：
        1.6
        另请参见：
        Shape.getBounds2D()

      • contains

        public static boolean contains​(PathIterator pi,
                               double x,
                               double y)
        测试指定的坐标是否在指定的PathIterator的封闭边界内。

        该方法为Shape接口的实现者提供了实现Shape.contains(double, double)方法支持的基本功能。

        参数
        pi - 指定的 PathIterator
        x - 指定的X坐标
        y - 指定的Y坐标
        结果
        true如果指定的坐标在指定的PathIterator ; 否则为false
        从以下版本开始：
        1.6

      • contains

        public static boolean contains​(PathIterator pi,
                               Point2D p)
        测试指定Point2D是指定的封闭边界内PathIterator 。

        该方法为Shape接口的实现者提供了实现Shape.contains(Point2D)方法支持的基本功能。

        参数
        pi - 指定的 PathIterator
        p - 指定的 Point2D
        结果
        true如果指定的坐标在指定的PathIterator ; false否则
        从以下版本开始：
        1.6

      • contains

        public final boolean contains​(double x,
                              double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        Specified by:
        contains在接口 Shape
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标在Shape边界内; 否则为false 。
        从以下版本开始：
        1.6

      • contains

        public final boolean contains​(Point2D p)
        测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
        Specified by:
        contains接口 Shape
        参数
        p - 要测试的指定的 Point2D
        结果
        true如果指定Point2D是的边界内Shape ; 否则为false 。
        从以下版本开始：
        1.6

      • contains

        public static boolean contains​(PathIterator pi,
                               double x,
                               double y,
                               double w,
                               double h)
        测试指定的矩形区域是否完全在指定的PathIterator的封闭边界内。

        这种方法为Shape接口的实现者提供了一个基本的工具来实现Shape.contains(double, double, double, double)方法的支持。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回false，但该段不表示路径的内部和外部之间的边界。 如果它们是具有WIND_NON_ZERO卷绕规则的路径的一部分，或者如果片段在相反方向上被回缩以使得两组片段彼此抵消而没有任何外部区域落在它们之间，那么这样的片段可以完全位于路径的内部中他们。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        参数
        pi - 指定的 PathIterator
        x - 指定的X坐标
        y - 指定的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果指定的PathIterator包含指定的矩形区域; false否则。
        从以下版本开始：
        1.6

      • contains

        public static boolean contains​(PathIterator pi,
                               Rectangle2D r)
        测试指定Rectangle2D是完全指定的封闭边界内PathIterator 。

        该方法为Shape接口的实现者提供了实现对Shape.contains(Rectangle2D)方法的支持的基本功能。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回false，但该段不表示路径的内部和外部之间的边界。 如果它们是具有WIND_NON_ZERO卷绕规则的路径的一部分，或者如果段在相反方向上被回缩以使得两组段彼此抵消而没有任何外部区域落在其间，则这样的段可以完全位于路径的内部中他们。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        参数
        pi - 指定的 PathIterator
        r - 一个指定的 Rectangle2D
        结果
        true如果指定的PathIterator包含指定的Rectangle2D ; 否则为false 。
        从以下版本开始：
        1.6

      • contains

        public final boolean contains​(double x,
                              double y,
                              double w,
                              double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标必须位于Shape内，整个矩形区域将被包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false当：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回false即使Shape包含矩形区域。 Area类比大多数Shape对象执行更精确的几何计算，因此如果需要更精确的答案，则可以使用它。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回false，但该段不表示路径的内部和外部之间的边界。 如果它们是具有WIND_NON_ZERO卷绕规则的路径的一部分或者如果段在相反方向上被回缩以使得两组段彼此抵消而没有任何外部区域落在两个区域之间，那么这样的段可以完全位于路径的内部中他们。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        Specified by:
        contains在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则或如果Shape包含矩形区域，并且intersects方法返回true并且包含计算将太昂贵执行。
        从以下版本开始：
        1.6
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • contains

        public final boolean contains​(Rectangle2D r)
        测试Shape的内部Shape完全包含指定的Rectangle2D 。 Shape.contains()方法允许Shape实现保守返回false当：
        • intersect方法返回true和
        • 计算确定Shape是否完全包含Rectangle2D是非常昂贵的。
        这意味着对于一些Shapes这个方法可能会返回false即使Shape包含Rectangle2D 。 Area类比大多数Shape对象执行更精确的几何计算，因此如果需要更精确的答案，则可以使用它。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回false，但该段不表示路径的内部和外部之间的边界。 如果它们是具有WIND_NON_ZERO绕组规则的路径的一部分，或者如果段在相反方向上被回溯以使得两组段彼此抵消而没有任何外部区域落在其间，则这些段可以完全位于路径的内部中他们。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        Specified by:
        contains在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果内部的Shape完全包含Rectangle2D ; false否则或如果Shape包含Rectangle2D和intersects方法返回true并且包含计算将太昂贵执行。
        从以下版本开始：
        1.6
        另请参见：
        Shape.contains(double, double, double, double)

      • intersects

        public static boolean intersects​(PathIterator pi,
                                 double x,
                                 double y,
                                 double w,
                                 double h)
        测试指定的PathIterator的内部是否与指定的一组直角坐标的内部相交。

        该方法为Shape接口的实现者提供了实现Shape.intersects(double, double, double, double)方法支持的基本功能。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回true，但该段不表示路径的内部和外部之间的边界。 如果路径的一些段的一部分在相反的方向回溯，使得两组段相互抵消而没有它们之间的任何内部区域，则可能发生这种情况。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        参数
        pi - 指定的 PathIterator
        x - 指定的X坐标
        y - 指定的Y坐标
        w - 指定的直角坐标的宽度
        h - 指定的直角坐标的高度
        结果
        true如果指定的PathIterator和指定的一组直角坐标的内部相交; false否则。
        从以下版本开始：
        1.6

      • intersects

        public static boolean intersects​(PathIterator pi,
                                 Rectangle2D r)
        测试指定的内部PathIterator是否与指定的内部相交Rectangle2D 。

        该方法为Shape接口的实现者提供了实现Shape.intersects(Rectangle2D)方法支持的基本功能。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回true，但该段不表示路径的内部和外部之间的边界。 如果路径的一些段的一部分在相反的方向回溯，使得两组段相互抵消而没有它们之间的任何内部区域，则可能发生这种情况。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        参数
        pi - 指定的 PathIterator
        r - 指定的 Rectangle2D
        结果
        true如果指定的PathIterator和指定的内部Rectangle2D相互相交; 否则为false 。
        从以下版本开始：
        1.6

      • intersects

        public final boolean intersects​(double x,
                                double y,
                                double w,
                                double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 如果任何点包含在Shape的内部和指定的矩形区域中，则矩形区域被认为与Shape相交。

        Shape.intersects()方法允许Shape实现保守返回true时：

        • 矩形区域和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回true即使矩形区域不与Shape相交。 Area类比大多数Shape对象执行几何交集的更准确的计算，因此如果需要更精确的答案，则可以使用它。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回true，但该段不表示路径的内部和外部之间的边界。 如果路径的一些段的一部分在相反的方向回溯，使得两组段相互抵消而没有它们之间的任何内部区域，则可能发生这种情况。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        Specified by:
        intersects在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; false否则。
        从以下版本开始：
        1.6
        另请参见：
        Area

      • intersects

        public final boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许一个Shape实现保守返回true当时：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于一些Shapes这个方法可能会返回true即使Rectangle2D不与Shape相交。 Area类比大多数Shape对象执行几何交集的更准确的计算，因此如果需要更精确的答案，则可以使用它。

        在指定的矩形区域与路径的段相交的情况下，该方法对象可以保守地返回true，但该段不表示路径的内部和外部之间的边界。 如果路径的一些段的一部分在相反的方向回溯，使得两组段相互抵消而没有它们之间的任何内部区域，则可能发生这种情况。 为了确定段代表路径内部的真实边界将需要涉及路径和绕组规则的所有段的广泛计算，因此超出了该实现的范围。

        Specified by:
        intersects在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的Rectangle2D的内部相交，或者很可能相交，并且交叉点计算将太昂贵，不能执行; 否则为false 。
        从以下版本开始：
        1.6
        另请参见：
        Shape.intersects(double, double, double, double)

      • getPathIterator

        public final PathIterator getPathIterator​(AffineTransform at,
                                          double flatness)
        返回一个沿着Shape边界迭代的迭代器对象，并提供对Shape轮廓几何体的平坦化视图的访问。

        只有SEG_MOVETO，SEG_LINETO和SEG_CLOSE点类型由迭代器返回。

        如果指定了可选的AffineTransform ，则相应地转换迭代中返回的坐标。

        曲线段的细分量由flatness参数控制，该参数指定未平坦化变换曲线上的任何点可能偏离返回的平坦化路径段的最大距离。 注意，平坦化路径的精度的限制可能会被默认地施加，导致非常小的平坦化参数被视为较大的值。 这个限制（如果有的话）是由所使用的特定实现来定义的。

        对此方法的每次调用都将返回一个新鲜的PathIterator对象，该对象与所使用的任何其他PathIterator对象同时遍历Shape对象几何。

        建议但不能保证实现Shape接口的对象会隔离Shape迭代，这些迭代可能会在此类迭代期间对原始对象的几何构成的任何更改进行任何更改。

        此类的迭代器不是多线程安全的，这意味着此Path2D类不保证对此Path2D对象的几何的修改不会影响已处理的该几何的任何迭代。

        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        flatness - 用于近似曲线段的线段的最大距离允许偏离原始曲线上的任何点
        结果
        一个新的 PathIterator独立地横穿的几何形状的平面视图 Shape 。
        从以下版本开始：
        1.6

      • clone

        public abstract Object clone​()
        创建与此对象相同类的新对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.6
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Path2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Path2D.Double

  • java.lang.Object
    • java.awt.geom.Path2D
      • java.awt.geom.Path2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Path2D

    public static class Path2D.Double
extends Path2D
implements Serializable
    Double类定义了一个几何路径，坐标存储在双精度浮点中。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Path2D

        Path2D.Double, Path2D.Float

    • Field Summary

      • Fields inherited from class java.awt.geom.Path2D

        WIND_EVEN_ODD, WIND_NON_ZERO

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造一个新的空双精度 Path2D对象，默认缠绕规则为 Path2D.WIND_NON_ZERO 。
      Double​(int rule)
      使用指定的绕组规则构造一个新的空双精度 Path2D对象，以控制需要定义路径内部的操作。
      Double​(int rule, int initialCapacity)
      使用指定的绕组规则和指定的初始容量构建新的空双精度 Path2D对象，以存储路径段。
      Double​(Shape s)
      构造一个新的双精度Path2D从任意对象Shape对象。
      Double​(Shape s, AffineTransform at)
      从任意的Shape对象构造一个新的双精度Path2D对象，由一个AffineTransform对象转换。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void append​(PathIterator pi, boolean connect)
      将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
      Object clone​()
      创建与此对象相同类的新对象。
      void curveTo​(double x1, double y1, double x2, double y2, double x3, double y3)
      通过绘制与当前坐标和指定坐标 (x3,y3)相交的Bézier曲线，使用指定点 (x1,y1)和 (x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      PathIterator getPathIterator​(AffineTransform at)
      返回一个沿着 Shape边界迭代的迭代器对象，并提供对 Shape大纲的几何形状的访问。
      void lineTo​(double x, double y)
      通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
      void moveTo​(double x, double y)
      通过移动到以双精度指定的指定坐标添加点到路径。
      void quadTo​(double x1, double y1, double x2, double y2)
      通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
      void transform​(AffineTransform at)
      使用指定的AffineTransform转换此路径的几何。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.Path2D

        append, closePath, contains, contains, contains, contains, contains, contains, contains, contains, createTransformedShape, getBounds, getCurrentPoint, getPathIterator, getWindingRule, intersects, intersects, intersects, intersects, reset, setWindingRule

    • 构造方法详细信息

      • Double

        public Double​()
        构造一个新的空双精度 Path2D对象，其默认缠绕规则为 Path2D.WIND_NON_ZERO 。
        从以下版本开始：
        1.6

      • Double

        public Double​(int rule)
        使用指定的绕组规则构造新的空双精度 Path2D对象，以控制需要定义路径内部的操作。
        参数
        rule - 绕线规则
        从以下版本开始：
        1.6
        另请参见：
        Path2D.WIND_EVEN_ODD ， Path2D.WIND_NON_ZERO

      • Double

        public Double​(int rule,
              int initialCapacity)
        使用指定的绕组规则和指定的初始容量构建新的空双精度Path2D对象，以存储路径段。 这个数字是关于路径中有多少路径段的初步猜测，但根据需要扩展存储，以存储将任何路径段添加到此路径。
        参数
        rule - 绕线规则
        initialCapacity - 路径中路径段数的估计
        从以下版本开始：
        1.6
        另请参见：
        Path2D.WIND_EVEN_ODD ， Path2D.WIND_NON_ZERO

      • Double

        public Double​(Shape s)
        构造一个新的双精度Path2D从任意对象Shape对象。 此路径的所有初始几何和绕组规则均取自指定的Shape对象。
        参数
        s - 指定的 Shape对象
        从以下版本开始：
        1.6

      • Double

        public Double​(Shape s,
              AffineTransform at)
        构造一个新的单精度Path2D从任意物体Shape对象，由一个转化AffineTransform对象。 此路径的所有初始几何和绕组规则均取自指定的Shape对象，并由指定的AffineTransform对象进行转换。
        参数
        s - 指定的 Shape对象
        at - 指定的 AffineTransform对象
        从以下版本开始：
        1.6

    • 方法详细信息

      • moveTo

        public final void moveTo​(double x,
                         double y)
        通过移动到以双精度指定的指定坐标添加点到路径。
        Specified by:
        moveTo在 Path2D
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6

      • lineTo

        public final void lineTo​(double x,
                         double y)
        通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
        Specified by:
        lineTo在 Path2D
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6

      • quadTo

        public final void quadTo​(double x1,
                         double y1,
                         double x2,
                         double y2)
        通过绘制与当前坐标和指定坐标(x2,y2)相交的二次曲线，使用指定点(x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。 所有坐标均以双精度指定。
        Specified by:
        quadTo在 Path2D
        参数
        x1 - 二次控制点的X坐标
        y1 - 二次控制点的Y坐标
        x2 - 最终终点的X坐标
        y2 - 最终终点的Y坐标
        从以下版本开始：
        1.6

      • curveTo

        public final void curveTo​(double x1,
                          double y1,
                          double x2,
                          double y2,
                          double x3,
                          double y3)
        通过绘制与当前坐标和指定坐标(x3,y3)相交的Bézier曲线，使用指定点(x1,y1)和(x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。 所有坐标均以双精度指定。
        Specified by:
        curveTo在 Path2D
        参数
        x1 - 第一个Bézier控制点的X坐标
        y1 - 第一个Bézier控制点的Y坐标
        x2 - 第二个Bézier控制点的X坐标
        y2 - 第二个Bézier控制点的Y坐标
        x3 - 最终终点的X坐标
        y3 - 最终终点的Y坐标
        从以下版本开始：
        1.6

      • append

        public final void append​(PathIterator pi,
                         boolean connect)
        将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。 如果connect参数为true ，并且路径不为空，则附加的Shape的几何中的任何初始moveTo Shape将转换为lineTo段。 如果这样的连接lineTo段的目标坐标与当前打开的子路径的结束坐标匹配，那么该段被省略为多余的。 指定的Shape的绕组规则将被忽略，附加的几何体由为此路径指定的绕组规则控制。
        Specified by:
        append在 Path2D
        参数
        pi - 其几何被附加到此路径的 PathIterator
        connect - 一个布尔值，用于控制是否将初始化的 moveTo段转换为 lineTo段以将新几何体连接到现有路径
        从以下版本开始：
        1.6

      • transform

        public final void transform​(AffineTransform at)
        使用指定的AffineTransform转换此路径的几何。 几何体被转换到位，永久地改变由该对象定义的边界。
        Specified by:
        transform在 Path2D
        参数
        at - 用于转换区域的 AffineTransform
        从以下版本开始：
        1.6

      • getBounds2D

        public final Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 该方法返回的边界通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape中这些点也未被包含的shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.6
        另请参见：
        Shape.getBounds()

      • getPathIterator

        public final PathIterator getPathIterator​(AffineTransform at)
        返回一个沿Shape边界迭代的迭代器对象，并提供对Shape大纲的几何形状的访问。 如果指定了可选的AffineTransform ，则相应地转换迭代中返回的坐标。

        此方法每次调用返回一个新鲜PathIterator对象横穿的几何形状Shape从任何其他独立对象PathIterator在使用中在相同的时间对象。

        建议但不能保证实现Shape接口的对象隔离在这些迭代期间原始对象的几何可能发生的任何更改的迭代。

        此类的迭代器不是多线程安全的，这意味着Path2D类不保证对此Path2D对象的几何的修改不会影响已经在处理的该几何的任何迭代。

        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 一个 AffineTransform
        结果
        一个新的 PathIterator ，沿着这个 Shape的边界进行迭代，并提供对这个 Shape的大纲的几何形状的访问
        从以下版本开始：
        1.6

      • clone

        public final Object clone​()
        创建与此对象相同类的新对象。
        Specified by:
        clone在 Path2D
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.6
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Path2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Path2D.Float

  • java.lang.Object
    • java.awt.geom.Path2D
      • java.awt.geom.Path2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    已知直接子类：
    GeneralPath
    Enclosing class:
    Path2D

    public static class Path2D.Float
extends Path2D
implements Serializable
    Float类定义了一个几何路径，坐标存储在单精度浮点中。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Path2D

        Path2D.Double, Path2D.Float

    • Field Summary

      • Fields inherited from class java.awt.geom.Path2D

        WIND_EVEN_ODD, WIND_NON_ZERO

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造一个新的空单精度 Path2D对象，默认卷绕规则为 Path2D.WIND_NON_ZERO 。
      Float​(int rule)
      使用指定的绕组规则构造新的空单精度 Path2D对象，以控制需要定义路径内部的操作。
      Float​(int rule, int initialCapacity)
      使用指定的卷绕规则和指定的初始容量构建新的空单精度 Path2D对象，以存储路径段。
      Float​(Shape s)
      构造一个新的单精度Path2D从任意对象Shape对象。
      Float​(Shape s, AffineTransform at)
      从任意的27048273414922对象构造一个新的单精度Path2D对象，由一个AffineTransform对象转换。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void append​(PathIterator pi, boolean connect)
      将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
      Object clone​()
      创建与此对象相同类的新对象。
      void curveTo​(double x1, double y1, double x2, double y2, double x3, double y3)
      通过使用指定点 (x1,y1)和 (x2,y2)作为Bézier控制点 (x1,y1)与当前坐标和指定坐标 (x3,y3)相交的Bézier曲线，将一个由三个新点定义的曲线段添加到路径。
      void curveTo​(float x1, float y1, float x2, float y2, float x3, float y3)
      通过绘制与当前坐标和指定坐标 (x3,y3)相交的Bézier曲线，使用指定点 (x1,y1)和 (x2,y2)作为Bézier控制点，将一个由三个新点定义的曲线段添加到路径。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法高精度和更准确的边界框。
      PathIterator getPathIterator​(AffineTransform at)
      返回一个迭代器对象，它沿着 Shape边界进行迭代，并提供对 Shape大纲的几何形状的访问。
      void lineTo​(double x, double y)
      通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
      void lineTo​(float x, float y)
      通过从当前坐标绘制直线到浮点精度指定的新指定坐标，向路径添加点。
      void moveTo​(double x, double y)
      通过移动到以双精度指定的指定坐标添加点到路径。
      void moveTo​(float x, float y)
      通过移动到以float精度指定的指定坐标，向路径添加点。
      void quadTo​(double x1, double y1, double x2, double y2)
      通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
      void quadTo​(float x1, float y1, float x2, float y2)
      通过绘制与当前坐标和指定坐标 (x2,y2)相交的二次曲线，使用指定点 (x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。
      void transform​(AffineTransform at)
      使用指定的AffineTransform转换此路径的几何。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.Path2D

        append, closePath, contains, contains, contains, contains, contains, contains, contains, contains, createTransformedShape, getBounds, getCurrentPoint, getPathIterator, getWindingRule, intersects, intersects, intersects, intersects, reset, setWindingRule

    • 构造方法详细信息

      • Float

        public Float​()
        构造一个新的空单精度 Path2D对象，默认卷绕规则为 Path2D.WIND_NON_ZERO 。
        从以下版本开始：
        1.6

      • Float

        public Float​(int rule)
        使用指定的绕组规则构造新的空单精度 Path2D对象，以控制需要定义路径内部的操作。
        参数
        rule - 绕线规则
        从以下版本开始：
        1.6
        另请参见：
        Path2D.WIND_EVEN_ODD ， Path2D.WIND_NON_ZERO

      • Float

        public Float​(int rule,
             int initialCapacity)
        构造新的空单精度Path2D对象，具有指定的绕组规则和指定的初始容量以存储路径段。 这个数字是关于将多少路径段添加到路径的初步猜测，但根据需要扩展存储，以存储添加的任何路径段。
        参数
        rule - 绕线规则
        initialCapacity - 路径中路径段数的估计
        从以下版本开始：
        1.6
        另请参见：
        Path2D.WIND_EVEN_ODD ， Path2D.WIND_NON_ZERO

      • Float

        public Float​(Shape s)
        构造一个新的单精度Path2D从任意对象Shape对象。 此路径的所有初始几何和绕组规则均取自指定的Shape对象。
        参数
        s - 指定的 Shape对象
        从以下版本开始：
        1.6

      • Float

        public Float​(Shape s,
             AffineTransform at)
        从任意的Shape对象构造一个新的单精度Path2D对象，由一个AffineTransform对象转换。 此路径的所有初始几何和绕组规则均取自指定的Shape对象，并由指定的AffineTransform对象进行转换。
        参数
        s - 指定的 Shape对象
        at - 指定的 AffineTransform对象
        从以下版本开始：
        1.6

    • 方法详细信息

      • moveTo

        public final void moveTo​(double x,
                         double y)
        通过移动到以双精度指定的指定坐标添加点到路径。
        Specified by:
        moveTo在 Path2D
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6

      • moveTo

        public final void moveTo​(float x,
                         float y)
        通过移动到以float精度指定的指定坐标，向路径添加点。

        该方法提供了基于Path2D类的双精度moveTo()方法的单精度变量。

        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6
        另请参见：
        Path2D.moveTo(double, double)

      • lineTo

        public final void lineTo​(double x,
                         double y)
        通过从当前坐标绘制直线到双精度指定的新指定坐标，向路径添加点。
        Specified by:
        lineTo在 Path2D
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6

      • lineTo

        public final void lineTo​(float x,
                         float y)
        通过从当前坐标绘制直线到浮点精度指定的新指定坐标，向路径添加点。

        该方法提供了基于Path2D类的双精度lineTo()方法的单精度变量。

        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        从以下版本开始：
        1.6
        另请参见：
        Path2D.lineTo(double, double)

      • quadTo

        public final void quadTo​(double x1,
                         double y1,
                         double x2,
                         double y2)
        通过绘制与当前坐标和指定坐标(x2,y2)相交的二次曲线，使用指定点(x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。 所有坐标均以双精度指定。
        Specified by:
        quadTo在 Path2D
        参数
        x1 - 二次控制点的X坐标
        y1 - 二次控制点的Y坐标
        x2 - 最终终点的X坐标
        y2 - 最终终点的Y坐标
        从以下版本开始：
        1.6

      • quadTo

        public final void quadTo​(float x1,
                         float y1,
                         float x2,
                         float y2)
        通过绘制与当前坐标和指定坐标(x2,y2)相交的二次曲线，使用指定点(x1,y1)作为二次参数控制点，将一个由两个新点定义的曲线段添加到路径。 所有坐标均以浮动精度指定。

        该方法提供了基于Path2D类的双精度quadTo()方法的单精度变量。

        参数
        x1 - 二次控制点的X坐标
        y1 - 二次控制点的Y坐标
        x2 - 最终终点的X坐标
        y2 - 最终终点的Y坐标
        从以下版本开始：
        1.6
        另请参见：
        Path2D.quadTo(double, double, double, double)

      • curveTo

        public final void curveTo​(double x1,
                          double y1,
                          double x2,
                          double y2,
                          double x3,
                          double y3)
        通过绘制与当前坐标和指定坐标(x3,y3)相交的Bézier曲线，使用指定点(x1,y1)和(x2,y2)作为Bζ控制点，将一个由三个新点定义的曲线段添加到路径。 所有坐标均以双精度指定。
        Specified by:
        curveTo在 Path2D
        参数
        x1 - 第一个Bézier控制点的X坐标
        y1 - 第一个Bézier控制点的Y坐标
        x2 - 第二个Bézier控制点的X坐标
        y2 - 第二个Bézier控制点的Y坐标
        x3 - 最终终点的X坐标
        y3 - 最终终点的Y坐标
        从以下版本开始：
        1.6

      • curveTo

        public final void curveTo​(float x1,
                          float y1,
                          float x2,
                          float y2,
                          float x3,
                          float y3)
        通过绘制与当前坐标和指定坐标(x3,y3)相交的Bézier曲线，使用指定点(x1,y1)和(x2,y2)作为BÃzier控制点，将一个由三个新点定义的曲线段添加到路径。 所有坐标均以浮动精度指定。

        该方法提供了基于Path2D类的双精度curveTo()方法的单精度变量。

        参数
        x1 - 第一个Bézier控制点的X坐标
        y1 - 第一个Bézier控制点的Y坐标
        x2 - 第二个Bézier控制点的X坐标
        y2 - 第二个Bézier控制点的Y坐标
        x3 - 最终终点的X坐标
        y3 - 最终终点的Y坐标
        从以下版本开始：
        1.6
        另请参见：
        Path2D.curveTo(double, double, double, double, double, double)

      • append

        public final void append​(PathIterator pi,
                         boolean connect)
        将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。 如果connect参数为true且路径不为空，则附加的Shape的几何中的任何初始moveTo Shape将转换为lineTo段。 如果这样的连接lineTo段的目的地坐标与当前打开的子路径的结束坐标匹配，那么该段被省略为多余的。 指定的Shape的绕组规则将被忽略，附加的几何体由为此路径指定的绕组规则控制。
        Specified by:
        append在 Path2D
        参数
        pi - 其几何被附加到此路径的 PathIterator
        connect - 一个布尔值，用于控制是否将初始的 moveTo段转换为 lineTo段以将新几何与现有路径相连
        从以下版本开始：
        1.6

      • transform

        public final void transform​(AffineTransform at)
        使用指定的AffineTransform转换此路径的几何。 几何体被转换到位，永久地改变由该对象定义的边界。
        Specified by:
        transform在 Path2D
        参数
        at - 用于转换区域的 AffineTransform
        从以下版本开始：
        1.6

      • getBounds2D

        public final Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致bounds对象定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape中也未考虑这些点的情况下。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.6
        另请参见：
        Shape.getBounds()

      • getPathIterator

        public final PathIterator getPathIterator​(AffineTransform at)
        返回一个沿Shape边界迭代的迭代器对象，并提供对Shape大纲的几何形状的访问。 如果指定了可选的AffineTransform ，则相应地转换迭代中返回的坐标。

        此方法每次调用返回一个新鲜PathIterator对象横穿的几何形状Shape从任何其他独立对象PathIterator在使用中在相同的时间对象。

        建议但不能保证，实现Shape接口的对象会隔离Shape迭代， Shape在此类迭代期间原始对象的几何可能发生的任何更改。

        此类的迭代器不是多线程安全的，这意味着Path2D类不保证对此Path2D对象的几何的修改不会影响已经在处理的该几何的任何迭代。

        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        结果
        一个新的 PathIterator对象，它独立地遍历 Shape的几何。
        从以下版本开始：
        1.6

      • clone

        public final Object clone​()
        创建与此对象相同类的新对象。
        Specified by:
        clone中的 Path2D
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.6
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PathIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Interface PathIterator

  • 所有已知实现类：
    FlatteningPathIterator

    public interface PathIterator
    PathIterator接口为实现Shape接口的对象提供了通过允许调用者一次检索该边界的路径来返回其边界的几何的机制。 该接口允许这些对象通过使用第一到第三阶Bézier曲线来检索它们的边界的路径，该曲线是线和二次或三次Bézier样条。

    可以通过使用“MOVETO”段来表示多个子路径，以在几何中创建不连续性，以从一个子路径的末尾移动到下一个子路径的开头。

    每个子路径可以通过在与子路径的开始“MOVETO”段相同的坐标上的子路径中结束最后一个段，或者通过使用“CLOSE”段将最后一个点的线段追回到第一个路段。 请注意，手动关闭轮廓而不是使用“CLOSE”段来关闭路径可能会导致在子路径的终点处使用不同的线型装饰。 例如，如果遇到“CLOSE”段，则BasicStroke对象使用线“JOIN”装饰来连接第一个和最后一个点，而简单地结束与起始坐标相同坐标的路径会导致行“CAP”装饰为在末端使用

    另请参见：
    Shape ， BasicStroke

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int SEG_CLOSE
      通过将线段追加到与最近的SEG_MOVETO对应的点来指定应该关闭前一子路径的段类型常量。
      static int SEG_CUBICTO
      指定要从最近指定点绘制的三次参数曲线的3个点集合的段类型常数。
      static int SEG_LINETO
      指定要从最近指定点绘制的行的终点的点的段类型常量。
      static int SEG_MOVETO
      指定新子路径起始位置的点的段类型常量。
      static int SEG_QUADTO
      指定从最近指定点绘制的二次参数曲线的一对点的段类型常数。
      static int WIND_EVEN_ODD
      用于指定用于确定路径内部的偶数奇数规则的绕组规则常数。
      static int WIND_NON_ZERO
      用于指定用于确定路径内部的非零规则的卷绕规则常数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int currentSegment​(double[] coords)
      返回迭代中当前路径段的坐标和类型。
      int currentSegment​(float[] coords)
      返回迭代中当前路径段的坐标和类型。
      int getWindingRule​()
      返回确定路径内部的绕组规则。
      boolean isDone​()
      测试迭代是否完成。
      void next​()
      只要在该方向上有更多的点，将迭代器沿着遍历的主要方向向前移动到路径的下一个段。

    • 字段详细信息

      • WIND_EVEN_ODD

        @Native
static final int WIND_EVEN_ODD
        用于指定用于确定路径内部的偶数奇数规则的绕组规则常数。 奇数规则规定，如果从该点到无穷远的任何方向绘制的射线被路径段奇数次穿过，则点位于路径内。
        另请参见：
        Constant Field Values

      • WIND_NON_ZERO

        @Native
static final int WIND_NON_ZERO
        用于指定用于确定路径内部的非零规则的卷绕规则常数。 非零规则规定如果从该点到无穷远的任何方向绘制的光线在顺时针方向上比路顺序段顺时针方向超过顺时针方向，则该点位于路径内。
        另请参见：
        Constant Field Values

      • SEG_MOVETO

        @Native
static final int SEG_MOVETO
        指定新子路径起始位置的点的段类型常量。
        另请参见：
        Constant Field Values

      • SEG_LINETO

        @Native
static final int SEG_LINETO
        指定要从最近指定点绘制的行的终点的点的段类型常量。
        另请参见：
        Constant Field Values

      • SEG_QUADTO

        @Native
static final int SEG_QUADTO
        指定从最近指定点绘制的二次参数曲线的一对点的段类型常数。 通过使用最近指定的（当前）点（CP），第一控制点（P1）和最终的内插控制点（P2）求解范围(t=[0..1])的参数控制方程来内(t=[0..1]) 。 该曲线的参数控制方程为：
          P(t) = B(2,0)*CP + B(2,1)*P1 + B(2,2)*P2
          0 <= t <= 1

        B(n,m) = mth coefficient of nth degree Bernstein polynomial
               = C(n,m) * t^(m) * (1 - t)^(n-m)
        C(n,m) = Combinations of n things, taken m at a time
               = n! / (m! * (n-m)!)
        另请参见：
        Constant Field Values

      • SEG_CUBICTO

        @Native
static final int SEG_CUBICTO
        指定要从最近指定点绘制的三次参数曲线的3个点集合的段类型常数。 通过使用最近指定的（当前）点（CP），第一控制点（P1），第二控制点（P2）和最终内插控制点（P2）来求解范围(t=[0..1])的参数控制方程P3）。 该曲线的参数控制方程为：
          P(t) = B(3,0)*CP + B(3,1)*P1 + B(3,2)*P2 + B(3,3)*P3
          0 <= t <= 1

        B(n,m) = mth coefficient of nth degree Bernstein polynomial
               = C(n,m) * t^(m) * (1 - t)^(n-m)
        C(n,m) = Combinations of n things, taken m at a time
               = n! / (m! * (n-m)!)
        这种形式的曲线通常被称为Bézier曲线。
        另请参见：
        Constant Field Values

      • SEG_CLOSE

        @Native
static final int SEG_CLOSE
        通过将线段追加到与最近的SEG_MOVETO对应的点来指定应该关闭前一子路径的段类型常量。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getWindingRule

        int getWindingRule​()
        返回确定路径内部的绕组规则。
        结果
        缠绕规则。
        另请参见：
        WIND_EVEN_ODD ， WIND_NON_ZERO

      • isDone

        boolean isDone​()
        测试迭代是否完成。
        结果
        true如果所有的段已被读取; 否则为false 。

      • next

        void next​()
        只要在该方向上有更多的点，将迭代器沿着遍历的主要方向向前移动到路径的下一个段。

      • currentSegment

        int currentSegment​(float[] coords)
        返回迭代中当前路径段的坐标和类型。 返回值是路径段类型：SEG_MOVETO，SEG_LINETO，SEG_QUADTO，SEG_CUBICTO或SEG_CLOSE。 必须传入长度为6的浮点数组，并可用于存储点的坐标。 每个点存储为一对浮点x，y坐标。 SEG_MOVETO和SEG_LINETO类型返回一个点，SEG_QUADTO返回两个点，SEG_CUBICTO返回3分，SEG_CLOSE不返回任何点。
        参数
        coords - 保存从此方法返回的数据的数组
        结果
        当前路径段的路径段类型。
        另请参见：
        SEG_MOVETO ， SEG_LINETO ， SEG_QUADTO ， SEG_CUBICTO ， SEG_CLOSE

      • currentSegment

        int currentSegment​(double[] coords)
        返回迭代中当前路径段的坐标和类型。 返回值是路径段类型：SEG_MOVETO，SEG_LINETO，SEG_QUADTO，SEG_CUBICTO或SEG_CLOSE。 必须传入长度为6的双数组，并可用于存储点的坐标。 每个点被存储为一对双x，y坐标。 SEG_MOVETO和SEG_LINETO类型返回一个点，SEG_QUADTO返回两个点，SEG_CUBICTO返回3分，SEG_CLOSE不返回任何点。
        参数
        coords - 保存从此方法返回的数据的数组
        结果
        当前路径段的路径段类型。
        另请参见：
        SEG_MOVETO, SEG_LINETO, SEG_QUADTO, SEG_CUBICTO, SEG_CLOSE
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Point2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Point2D

  • java.lang.Object
    • java.awt.geom.Point2D
  • All Implemented Interfaces:
    Cloneable
    已知直接子类：
    Point ， Point2D.Double ， Point2D.Float

    public abstract class Point2D
extends Object
implements Cloneable
    Point2D类定义了一个表示(x,y)坐标空间中的位置的点。

    此类只是存储2D坐标的所有对象的抽象超类。 坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Point2D.Double
      Double类定义了 double精度中指定的点。
      static class  Point2D.Float
      Float类定义了浮点精度指定的点。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Point2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建与该对象相同的类和新内容相同的新对象。
      double distance​(double px, double py)
      返回从该 Point2D到指定点的距离。
      static double distance​(double x1, double y1, double x2, double y2)
      返回两点之间的距离。
      double distance​(Point2D pt)
      返回从该 Point2D到指定的 Point2D的距离。
      double distanceSq​(double px, double py)
      返回从该 Point2D到指定点的距离的平方。
      static double distanceSq​(double x1, double y1, double x2, double y2)
      返回两点之间距离的平方。
      double distanceSq​(Point2D pt)
      返回从该 Point2D到指定的 Point2D的距离的平方。
      boolean equals​(Object obj)
      确定两点是否相等。
      abstract double getX​()
      以 double精度返回此 Point2D的X坐标。
      abstract double getY​()
      返回这个 Point2D的Y坐标，精度为 double 。
      int hashCode​()
      返回此 Point2D的哈希 Point2D 。
      abstract void setLocation​(double x, double y)
      将此 Point2D的位置设置为指定的 double坐标。
      void setLocation​(Point2D p)
      将此 Point2D的位置设置为与指定的 Point2D对象相同的坐标。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Point2D

        protected Point2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        Point2D.Float ， Point2D.Double ， Point

    • 方法详细信息

      • getX

        public abstract double getX​()
        以 double精度返回此 Point2D的X坐标。
        结果
        这个 Point2D的X坐标。
        从以下版本开始：
        1.2

      • getY

        public abstract double getY​()
        返回这个 Point2D的Y坐标，精度为 double 。
        结果
        这个 Point2D的Y坐标。
        从以下版本开始：
        1.2

      • setLocation

        public abstract void setLocation​(double x,
                                 double y)
        将此 Point2D的位置设置为指定的 double坐标。
        参数
        x - 这个 Point2D的新X坐标
        y - 这个 Point2D的新的Y坐标
        从以下版本开始：
        1.2

      • setLocation

        public void setLocation​(Point2D p)
        将此 Point2D的位置设置为与指定的 Point2D对象相同的坐标。
        参数
        p - 指定的 Point2D要设置这个 Point2D
        从以下版本开始：
        1.2

      • distanceSq

        public static double distanceSq​(double x1,
                                double y1,
                                double x2,
                                double y2)
        返回两点之间距离的平方。
        参数
        x1 - 第一个指定点的X坐标
        y1 - 第一个指定点的Y坐标
        x2 - 第二个指定点的X坐标
        y2 - 第二个指定点的Y坐标
        结果
        两组指定坐标之间的距离的平方。
        从以下版本开始：
        1.2

      • distance

        public static double distance​(double x1,
                              double y1,
                              double x2,
                              double y2)
        返回两点之间的距离。
        参数
        x1 - 第一个指定点的X坐标
        y1 - 第一个指定点的Y坐标
        x2 - 第二个指定点的X坐标
        y2 - 第二个指定点的Y坐标
        结果
        两组指定坐标之间的距离。
        从以下版本开始：
        1.2

      • distanceSq

        public double distanceSq​(double px,
                         double py)
        返回从该 Point2D到指定点的距离的平方。
        参数
        px - 要针对此 Point2D测量的指定点的X坐标
        py - 要针对此 Point2D测量的指定点的Y坐标
        结果
        这个 Point2D和指定点之间的距离的平方。
        从以下版本开始：
        1.2

      • distanceSq

        public double distanceSq​(Point2D pt)
        返回从该 Point2D到指定的 Point2D的距离的平方。
        参数
        pt - 根据此 Point2D计量的指定点数
        结果
        这个距离的平方 Point2D到一个指定的 Point2D 。
        从以下版本开始：
        1.2

      • distance

        public double distance​(double px,
                       double py)
        返回从该 Point2D到指定点的距离。
        参数
        px - 要针对此 Point2D测量的指定点的X坐标
        py - 要针对此 Point2D测量的指定点的Y坐标
        结果
        这个 Point2D和一个指定点之间的距离。
        从以下版本开始：
        1.2

      • distance

        public double distance​(Point2D pt)
        返回从该 Point2D到指定的 Point2D的距离。
        参数
        pt - 要针对此 Point2D进行测量的指定点
        结果
        这个 Point2D和指定的 Point2D之间的距离。
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        创建与该对象相同的类和新内容相同的新对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.2
        另请参见：
        Cloneable

      • hashCode

        public int hashCode​()
        返回此 Point2D的哈希 Point2D 。
        重写：
        hashCode在 Object
        结果
        这个 Point2D的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        确定两点是否相等。 如果x和y成员字段的值在坐标空间中的位置相同，那么Point2D两个实例是相等的。
        重写：
        equals在 Object
        参数
        obj - 一个与此 Point2D进行比较的对象
        结果
        true如果要比较的对象是Point2D的实例，并且具有相同的值; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Point2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Point2D.Double

  • java.lang.Object
    • java.awt.geom.Point2D
      • java.awt.geom.Point2D.Double
  • All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    Point2D

    public static class Point2D.Double
extends Point2D
implements Serializable
    Double类定义了 double精度指定的点。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Point2D

        Point2D.Double, Point2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double x
      这个 Point2D的X坐标。
      double y
      这个Y坐标 Point2D 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造并初始化具有坐标（0，0）的 Point2D 。
      Double​(double x, double y)
      构造并初始化具有指定坐标的 Point2D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getX​()
      返回 double精度的 Point2D的X坐标。
      double getY​()
      返回 double精度的 Point2D的Y坐标。
      void setLocation​(double x, double y)
      将此 Point2D的位置设置为指定的 double坐标。
      String toString​()
      返回一个表示 String的值的 Point2D 。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.geom.Point2D

        clone, distance, distance, distance, distanceSq, distanceSq, distanceSq, equals, hashCode, setLocation

    • 字段详细信息

      • x

        public double x
        这个 Point2D的X坐标。
        从以下版本开始：
        1.2

      • y

        public double y
        这个 Point2D的Y坐标。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        构造并初始化具有坐标（0，0）的 Point2D 。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x,
              double y)
        构造并初始化具有指定坐标的 Point2D 。
        参数
        x - 新建的 Point2D的X坐标
        y - 新建的 Point2D的Y坐标
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        以 double精度返回此 Point2D的X坐标。
        Specified by:
        getX中的 Point2D
        结果
        这个 Point2D的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回此的Y坐标 Point2D在 double精度。
        Specified by:
        getY在 Point2D
        结果
        这个 Point2D的Y坐标。
        从以下版本开始：
        1.2

      • setLocation

        public void setLocation​(double x,
                        double y)
        将此 Point2D的位置设置为指定的 double坐标。
        Specified by:
        setLocation中的 Point2D
        参数
        x - 这个 Point2D的新X坐标
        y - 这个 Point2D的新的Y坐标
        从以下版本开始：
        1.2

      • toString

        public String toString​()
        返回一个表示 String的值的 Point2D 。
        重写：
        toString在 Object
        结果
        这个 Point2D的字符串表示 Point2D 。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Point2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Point2D.Float

  • java.lang.Object
    • java.awt.geom.Point2D
      • java.awt.geom.Point2D.Float
  • All Implemented Interfaces:
    Serializable ， Cloneable
    Enclosing class:
    Point2D

    public static class Point2D.Float
extends Point2D
implements Serializable
    Float类定义了浮点精度指定的点。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Point2D

        Point2D.Double, Point2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float x
      这个 Point2D的X坐标。
      float y
      这个Y坐标 Point2D 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造并初始化具有坐标（0，0）的 Point2D 。
      Float​(float x, float y)
      构造并初始化具有指定坐标的 Point2D 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getX​()
      返回 double精度的 Point2D的X坐标。
      double getY​()
      返回这个 Point2D的Y坐标在 double精度。
      void setLocation​(double x, double y)
      将此 Point2D的位置设置为指定的 double坐标。
      void setLocation​(float x, float y)
      将此 Point2D的位置设置为指定的 float坐标。
      String toString​()
      返回一个表示 String的值的 Point2D 。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.geom.Point2D

        clone, distance, distance, distance, distanceSq, distanceSq, distanceSq, equals, hashCode, setLocation

    • 字段详细信息

      • x

        public float x
        这个 Point2D的X坐标。
        从以下版本开始：
        1.2

      • y

        public float y
        这个Y坐标 Point2D 。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造并初始化具有坐标（0,0）的 Point2D 。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x,
             float y)
        构造并初始化具有指定坐标的 Point2D 。
        参数
        x - 新建的 Point2D的X坐标
        y - 新构建的Y坐标 Point2D
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        以 double精度返回此 Point2D的X坐标。
        Specified by:
        getX在 Point2D
        结果
        这个 Point2D的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回 double精度的 Point2D的Y坐标。
        Specified by:
        getY在 Point2D
        结果
        这个 Point2D的Y坐标。
        从以下版本开始：
        1.2

      • setLocation

        public void setLocation​(double x,
                        double y)
        将此 Point2D的位置设置为指定的 double坐标。
        Specified by:
        setLocation在 Point2D
        参数
        x - 这个 Point2D的新X坐标
        y - 这个 Point2D的新的Y坐标
        从以下版本开始：
        1.2

      • setLocation

        public void setLocation​(float x,
                        float y)
        将此 Point2D的位置设置为指定的 float坐标。
        参数
        x - 这个 Point2D的新X坐标
        y - 这个新的Y坐标 Point2D
        从以下版本开始：
        1.2

      • toString

        public String toString​()
        返回一个表示 String的值的 Point2D 。
        重写：
        toString在 Object
        结果
        这个 Point2D的字符串表示 Point2D 。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


QuadCurve2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class QuadCurve2D

  • java.lang.Object
    • java.awt.geom.QuadCurve2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    QuadCurve2D.Double ， QuadCurve2D.Float

    public abstract class QuadCurve2D
extends Object
implements Shape, Cloneable
    QuadCurve2D类定义了(x,y)坐标空间中的二次参数曲线段。

    该类只是存储2D二次曲线段的所有对象的抽象超类。 坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  QuadCurve2D.Double
      用 double坐标指定的二次参数曲线段。
      static class  QuadCurve2D.Float
      用 float协调指定的二次参数曲线段。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected QuadCurve2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建与该对象相同的类和新内容相同的新对象。
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      boolean contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      Rectangle getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      abstract Point2D getCtrlPt​()
      返回控制点。
      abstract double getCtrlX​()
      以 double精度返回控制点的X坐标。
      abstract double getCtrlY​()
      以 double精度返回控制点的Y坐标。
      double getFlatness​()
      返回 QuadCurve2D的控制点与连接终点的线的平坦度或最大距离。
      static double getFlatness​(double[] coords, int offset)
      返回控制点与连接终点的线的平坦度或最大距离，由指定的数组中存储在指示索引处的控制点指定的二次曲线。
      static double getFlatness​(double x1, double y1, double ctrlx, double ctrly, double x2, double y2)
      返回由指示的控制点指定的二次曲线的平滑度或控制点与连接端点的线的最大距离。
      double getFlatnessSq​()
      返回这个 QuadCurve2D的平直度的平方或控制点与连接端点的线的最大距离。
      static double getFlatnessSq​(double[] coords, int offset)
      返回由指示的数组中存储的指示索引处存储的控制点指定的二次曲线的平坦度或控制点与连接终点的线的最大距离。
      static double getFlatnessSq​(double x1, double y1, double ctrlx, double ctrly, double x2, double y2)
      返回由指示的控制点指定的二次曲线的平坦度或控制点与连接终点的线的最大距离。
      abstract Point2D getP1​()
      返回起始点。
      abstract Point2D getP2​()
      返回终点。
      PathIterator getPathIterator​(AffineTransform at)
      返回定义 QuadCurve2D形状边界的迭代对象。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回定义此 QuadCurve2D的展平形状边界的迭代对象。
      abstract double getX1​()
      以 double的精度返回起始点的X坐标。
      abstract double getX2​()
      以 double精度返回终点的X坐标。
      abstract double getY1​()
      以 double精度返回起始点的Y坐标。
      abstract double getY2​()
      以 double精度返回终点的Y坐标。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定矩形区域的内部相交。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      void setCurve​(double[] coords, int offset)
      将该 QuadCurve2D的终点和控制点的位置设置为指定数组中指定偏移量的 double坐标。
      abstract void setCurve​(double x1, double y1, double ctrlx, double ctrly, double x2, double y2)
      将该曲线的终点和控制点的位置设置为指定的 double坐标。
      void setCurve​(Point2D[] pts, int offset)
      将 QuadCurve2D的终点和控制点的位置设置为指定数组中指定偏移量处的 Point2D对象的坐标。
      void setCurve​(Point2D p1, Point2D cp, Point2D p2)
      将此 QuadCurve2D的终点和控制点的位置设置为指定的 Point2D坐标。
      void setCurve​(QuadCurve2D c)
      将此 QuadCurve2D的终点和控制点的位置设置为与指定的 QuadCurve2D 。
      static int solveQuadratic​(double[] eqn)
      eqn其系数在 eqn数组中，并将非复数根返回到同一个数组中，返回根数。
      static int solveQuadratic​(double[] eqn, double[] res)
      eqn其系数在 eqn数组中的二次方，并将非复数根放入 res数组中，返回根数。
      static void subdivide​(double[] src, int srcoff, double[] left, int leftoff, double[] right, int rightoff)
      细分由存储在 src阵列中的坐标指定的二次曲线，索引为 srcoff至 srcoff + 5，并将生成的两个细分曲线存储在相应索引处的两个结果数组中。
      void subdivide​(QuadCurve2D left, QuadCurve2D right)
      细分此 QuadCurve2D ，并将生成的两个细分曲线存储到 left和 right曲线参数中。
      static void subdivide​(QuadCurve2D src, QuadCurve2D left, QuadCurve2D right)
      细分由 src参数指定的二次曲线，并将生成的两个细分曲线存储到 left和 right曲线参数中。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.awt.Shape

        getBounds2D

    • 构造方法详细信息

      • QuadCurve2D

        protected QuadCurve2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        QuadCurve2D.Float ， QuadCurve2D.Double

    • 方法详细信息

      • getX1

        public abstract double getX1​()
        以 double的精度返回起始点的X坐标。
        结果
        起始点的X坐标。
        从以下版本开始：
        1.2

      • getY1

        public abstract double getY1​()
        返回起始点的Y坐标在 double精度。
        结果
        起始点的Y坐标。
        从以下版本开始：
        1.2

      • getP1

        public abstract Point2D getP1​()
        返回起始点。
        结果
        一个 Point2D这是 QuadCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX

        public abstract double getCtrlX​()
        以 double精度返回控制点的X坐标。
        结果
        X坐标控制点
        从以下版本开始：
        1.2

      • getCtrlY

        public abstract double getCtrlY​()
        以 double精度返回控制点的Y坐标。
        结果
        控制点的Y坐标。
        从以下版本开始：
        1.2

      • getCtrlPt

        public abstract Point2D getCtrlPt​()
        返回控制点。
        结果
        一个 Point2D是这个 Point2D的控制点。
        从以下版本开始：
        1.2

      • getX2

        public abstract double getX2​()
        以 double精度返回终点的X坐标。
        结果
        终点的x坐标。
        从以下版本开始：
        1.2

      • getY2

        public abstract double getY2​()
        以 double精度返回终点的Y坐标。
        结果
        终点的Y坐标。
        从以下版本开始：
        1.2

      • getP2

        public abstract Point2D getP2​()
        返回终点。
        结果
        一个 Point对象，它是本的终点 Point2D 。
        从以下版本开始：
        1.2

      • setCurve

        public abstract void setCurve​(double x1,
                              double y1,
                              double ctrlx,
                              double ctrly,
                              double x2,
                              double y2)
        将该曲线的终点和控制点的位置设置为指定的 double坐标。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(double[] coords,
                     int offset)
        将 QuadCurve2D的终点和控制点的位置设置为指定数组中指定偏移量的 double坐标。
        参数
        coords - 包含坐标值的数组
        offset - 从中开始获取坐标值并将其分配给该数组的索引 QuadCurve2D
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(Point2D p1,
                     Point2D cp,
                     Point2D p2)
        将此 QuadCurve2D的终点和控制点的位置设置为指定的 Point2D坐标。
        参数
        p1 - 起点
        cp - 控制点
        p2 - 终点
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(Point2D[] pts,
                     int offset)
        将此 QuadCurve2D的终点和控制点的位置设置为指定数组中指定偏移量处的 Point2D对象的坐标。
        参数
        pts -一个阵列含有 Point2D定义坐标值
        offset - 索引为 pts ，从中开始获取坐标值并将其分配给此 QuadCurve2D
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(QuadCurve2D c)
        将此 QuadCurve2D的终点和控制点的位置设置为与指定的 QuadCurve2D的位置相同。
        参数
        c - 指定的 QuadCurve2D
        从以下版本开始：
        1.2

      • getFlatnessSq

        public static double getFlatnessSq​(double x1,
                                   double y1,
                                   double ctrlx,
                                   double ctrly,
                                   double x2,
                                   double y2)
        返回由指示的控制点指定的二次曲线的平坦度或控制点与连接终点的线的最大距离。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        结果
        由指定坐标定义的二次曲线的平坦度的平方。
        从以下版本开始：
        1.2

      • getFlatness

        public static double getFlatness​(double x1,
                                 double y1,
                                 double ctrlx,
                                 double ctrly,
                                 double x2,
                                 double y2)
        返回由指示的控制点指定的二次曲线的平滑度或控制点与连接端点的线的最大距离。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        结果
        由指定坐标定义的二次曲线的平坦度。
        从以下版本开始：
        1.2

      • getFlatnessSq

        public static double getFlatnessSq​(double[] coords,
                                   int offset)
        返回由指示的数组中存储的指示索引处存储的控制点指定的二次曲线的平坦度或控制点与连接终点的线的最大距离。
        参数
        coords - 包含坐标值的数组
        offset - 索引到 coords从 coords开始从数组中获取值
        结果
        由指定数组中指定索引处的值定义的二次曲线的平坦度。
        从以下版本开始：
        1.2

      • getFlatness

        public static double getFlatness​(double[] coords,
                                 int offset)
        返回控制点与连接终点的线的平坦度或最大距离，由指定的数组中存储在指示索引处的控制点指定的二次曲线。
        参数
        coords - 包含坐标值的数组
        offset - 索引为 coords ，从中开始获取坐标值
        结果
        由指定的数组在指定的偏移量定义的二次曲线的平坦度。
        从以下版本开始：
        1.2

      • getFlatnessSq

        public double getFlatnessSq​()
        返回 QuadCurve2D的平坦度或控制点与连接终点的线的最大距离的 QuadCurve2D 。
        结果
        该平方度的平方度这 QuadCurve2D 。
        从以下版本开始：
        1.2

      • getFlatness

        public double getFlatness​()
        返回 QuadCurve2D度或控制点与连接端点的线的最大距离。
        结果
        平坦度这 QuadCurve2D 。
        从以下版本开始：
        1.2

      • subdivide

        public void subdivide​(QuadCurve2D left,
                      QuadCurve2D right)
        细分此QuadCurve2D ，并将所得的两条细分曲线存储到left和right曲线参数中。 left和right对象中的任何一个或两者可以与此QuadCurve2D或null相同。
        参数
        left - 用于存储细分曲线的左半部分或上半部分的 QuadCurve2D对象
        right - 用于存储细分曲线的右半部分或后半部分的 QuadCurve2D对象
        从以下版本开始：
        1.2

      • subdivide

        public static void subdivide​(QuadCurve2D src,
                             QuadCurve2D left,
                             QuadCurve2D right)
        细分由src参数指定的二次曲线，并将生成的两个细分曲线存储到left和right曲线参数中。 left和right对象中的任一个或两者可以与src对象或null 。
        参数
        src - 待细分的二次曲线
        left - 用于存储细分曲线的左半部分或上半部分的 QuadCurve2D对象
        right - 用于存储细分曲线的右半部分或后半部分的 QuadCurve2D对象
        从以下版本开始：
        1.2

      • subdivide

        public static void subdivide​(double[] src,
                             int srcoff,
                             double[] left,
                             int leftoff,
                             double[] right,
                             int rightoff)
        细分由存储在src数组中的坐标指定的二次曲线，索引为srcoff至srcoff + 5，并将生成的两个细分曲线存储在相应索引处的两个结果数组中。 所述的任一或两者left个right数组可以是null或同一数组的引用和作为偏移src阵列。 请注意，第一个细分曲线中的最后一个点与第二个细分曲线中的第一个点相同。 因此，可以通过left和right的相同阵列，并使用偏移量使得rightoff等于leftoff + 4，以避免为该公共点分配额外的存储空间。
        参数
        src - 保存源曲线坐标的数组
        srcoff - 偏移到数组的开头的6个源坐标
        left - 用于存储细分曲线前半部分坐标的数组
        leftoff - 偏移到 leftoff左坐标开头的数组
        right - 用于存储细分曲线后半部分坐标的数组
        rightoff - 偏移到数组的开头的6个正确的坐标
        从以下版本开始：
        1.2

      • solveQuadratic

        public static int solveQuadratic​(double[] eqn)
        eqn其系数在eqn数组中，并将非复数根返回到同一个数组中，返回根数。 二次求解由下式表示：
          eqn = {C, B, A};
     ax^2 + bx + c = 0
        使用返回值-1来区分来自不具有零的等式的常数等式，其可以始终为0或从不0。
        参数
        eqn - 包含二次系数的数组
        结果
        根数，或 -1如果方程是一个常数
        从以下版本开始：
        1.2

      • solveQuadratic

        public static int solveQuadratic​(double[] eqn,
                                 double[] res)
        eqn其系数在eqn数组中的二次方，并将非复数根放入res数组中，返回根数。 二次求解由下式表示：
          eqn = {C, B, A};
     ax^2 + bx + c = 0
        使用返回值-1来区分一个常数为0或从不等于0的常数方程。
        参数
        eqn - 用于求解二次方程的指定数组的系数
        res - 包含由二次方程的解产生的非复杂根的数组
        结果
        根数，或 -1如果方程是一个常数。
        从以下版本开始：
        1.3

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        Specified by:
        contains在接口 Shape
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标在Shape边界内; 否则为false 。
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(Point2D p)
        测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
        Specified by:
        contains在接口 Shape
        参数
        p - 要测试的指定的 Point2D
        结果
        true如果指定Point2D是的边界内Shape ; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 如果任何点包含在Shape的内部和指定的矩形区域中，则矩形区域被认为与Shape相交。

        Shape.intersects()方法允许Shape实现保守返回true当：

        • 矩形区域和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回true即使矩形区域没有相交Shape 。 Area类比大多数Shape对象执行几何交集的更精确的计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; false否则。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • intersects

        public boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许Shape实现保守返回true时：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于一些Shapes这个方法可能会返回true即使Rectangle2D不与Shape相交。 Area类比大多数Shape对象执行更准确的几何交集计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的Rectangle2D的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; false否则。
        从以下版本开始：
        1.2
        另请参见：
        Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标必须位于Shape内，因为整个矩形区域将被视为包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false当：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回false即使Shape包含矩形区域。 Area类执行比大多数Shape对象更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则，或者如果Shape包含矩形区域，并且intersects方法返回true ，并且遏制计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(Rectangle2D r)
        测试Shape的内部Shape完全包含指定的Rectangle2D 。 Shape.contains()方法允许Shape实现保守返回false当：
        • intersect方法返回true和
        • 计算确定Shape是否完全包含Rectangle2D是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回false即使Shape包含Rectangle2D 。 Area类比大多数Shape对象执行更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果内部的Shape完全包含Rectangle2D ; false否则或如果Shape包含Rectangle2D和intersects方法返回true并且包含计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Shape.contains(double, double, double, double)

      • getBounds

        public Rectangle getBounds​()
        返回一个整数Rectangle完全包围Shape 。 请注意，不保证返回的Rectangle是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle 。 如果Shape溢出整数数据类型的有限范围，则返回的Rectangle也可能无法完全包围Shape 。 getBounds2D方法通常返回更严格的边界框，因为它具有更大的表示灵活性。

        请注意， definition of insideness可能导致在返回的bounds对象中不包含shape定义轮廓上的点的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(x,y)要求bounds.contains(x,y)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(x,y)并不表示shape.contains(x,y)

        Specified by:
        getBounds在接口 Shape
        结果
        整数 Rectangle完全包围了 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds2D()

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回定义QuadCurve2D形状边界的迭代对象。 此类的迭代器不是多线程安全的，这意味着此QuadCurve2D类不保证对此QuadCurve2D对象的几何的修改不会影响已处理的该几何的任何迭代。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 可选的AffineTransform适用于形状边界
        结果
        一个定义形状边界的PathIterator对象。
        从以下版本开始：
        1.2

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at,
                                    double flatness)
        返回定义此QuadCurve2D的展平形状边界的迭代对象。 此类的迭代器不是多线程安全的，这意味着此QuadCurve2D类不保证对此QuadCurve2D对象的几何的修改不会影响已经在处理的该几何的任何迭代。
        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 可选的 AffineTransform适用于形状的边界
        flatness - 分割曲线的控制点相对于连接该曲线的端点的线的最大距离，该曲线由连接端点的直线代替。
        结果
        一个 PathIterator对象，定义了形状的平坦边界。
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        创建与该对象相同的类和新内容相同的新对象。
        重写：
        clone在 Object类
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.2
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


QuadCurve2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class QuadCurve2D.Double

  • java.lang.Object
    • java.awt.geom.QuadCurve2D
      • java.awt.geom.QuadCurve2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    QuadCurve2D

    public static class QuadCurve2D.Double
extends QuadCurve2D
implements Serializable
    用 double坐标指定的二次参数曲线段。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.QuadCurve2D

        QuadCurve2D.Double, QuadCurve2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double ctrlx
      二次曲线段控制点的X坐标。
      double ctrly
      二次曲线段控制点的Y坐标。
      double x1
      二次曲线段起始点的X坐标。
      double x2
      二次曲线段终点的X坐标。
      double y1
      二次曲线段起始点的Y坐标。
      double y2
      二次曲线段终点的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造并初始化一个 QuadCurve2D ，坐标（ QuadCurve2D ）。
      Double​(double x1, double y1, double ctrlx, double ctrly, double x2, double y2)
      构造并初始化一个 QuadCurve2D从指定 double坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Point2D getCtrlPt​()
      返回控制点。
      double getCtrlX​()
      以 double精度返回控制点的X坐标。
      double getCtrlY​()
      以 double精度返回控制点的Y坐标。
      Point2D getP1​()
      返回起始点。
      Point2D getP2​()
      返回终点。
      double getX1​()
      以 double的精度返回起始点的X坐标。
      double getX2​()
      以 double精度返回终点的X坐标。
      double getY1​()
      返回起始点的Y坐标在 double精度。
      double getY2​()
      以 double精度返回终点的Y坐标。
      void setCurve​(double x1, double y1, double ctrlx, double ctrly, double x2, double y2)
      将该曲线的终点和控制点的位置设置为指定的 double坐标。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.QuadCurve2D

        clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveQuadratic, solveQuadratic, subdivide, subdivide, subdivide

    • 字段详细信息

      • x1

        public double x1
        二次曲线段起始点的X坐标。
        从以下版本开始：
        1.2

      • y1

        public double y1
        二次曲线段起始点的Y坐标。
        从以下版本开始：
        1.2

      • ctrlx

        public double ctrlx
        二次曲线段控制点的X坐标。
        从以下版本开始：
        1.2

      • ctrly

        public double ctrly
        二次曲线段控制点的Y坐标。
        从以下版本开始：
        1.2

      • x2

        public double x2
        二次曲线段终点的X坐标。
        从以下版本开始：
        1.2

      • y2

        public double y2
        二次曲线段终点的Y坐标。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        使用坐标（ QuadCurve2D构造并初始化 QuadCurve2D 。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x1,
              double y1,
              double ctrlx,
              double ctrly,
              double x2,
              double y2)
        构造并初始化一个 QuadCurve2D从指定 double坐标。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX1

        public double getX1​()
        以 double的精度返回起始点的X坐标。
        Specified by:
        getX1在 QuadCurve2D
        结果
        起始点的X坐标。
        从以下版本开始：
        1.2

      • getY1

        public double getY1​()
        以 double精度返回起始点的Y坐标。
        Specified by:
        getY1在 QuadCurve2D
        结果
        起始点的Y坐标。
        从以下版本开始：
        1.2

      • getP1

        public Point2D getP1​()
        返回起始点。
        Specified by:
        getP1在 QuadCurve2D
        结果
        一个 Point2D这是 QuadCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX

        public double getCtrlX​()
        以 double精度返回控制点的X坐标。
        Specified by:
        getCtrlX在 QuadCurve2D
        结果
        X坐标控制点
        从以下版本开始：
        1.2

      • getCtrlY

        public double getCtrlY​()
        以 double精度返回控制点的Y坐标。
        Specified by:
        getCtrlY QuadCurve2D
        结果
        控制点的Y坐标。
        从以下版本开始：
        1.2

      • getCtrlPt

        public Point2D getCtrlPt​()
        返回控制点。
        Specified by:
        getCtrlPt在 QuadCurve2D
        结果
        一个 Point2D是这个控制点 Point2D 。
        从以下版本开始：
        1.2

      • getX2

        public double getX2​()
        以 double精度返回终点的X坐标。
        Specified by:
        getX2在 QuadCurve2D
        结果
        终点的x坐标。
        从以下版本开始：
        1.2

      • getY2

        public double getY2​()
        以 double精度返回终点的Y坐标。
        Specified by:
        getY2在 QuadCurve2D
        结果
        终点的Y坐标。
        从以下版本开始：
        1.2

      • getP2

        public Point2D getP2​()
        返回终点。
        Specified by:
        getP2在 QuadCurve2D
        结果
        一个 Point对象，它是本的终点 Point2D 。
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(double x1,
                     double y1,
                     double ctrlx,
                     double ctrly,
                     double x2,
                     double y2)
        将该曲线的终点和控制点的位置设置为指定的 double坐标。
        Specified by:
        setCurve在 QuadCurve2D
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致bounds对象定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape未考虑这些点的情况下。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)要求bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


QuadCurve2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class QuadCurve2D.Float

  • java.lang.Object
    • java.awt.geom.QuadCurve2D
      • java.awt.geom.QuadCurve2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    QuadCurve2D

    public static class QuadCurve2D.Float
extends QuadCurve2D
implements Serializable
    用 float坐标指定的二次参数曲线段。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.QuadCurve2D

        QuadCurve2D.Double, QuadCurve2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float ctrlx
      二次曲线段控制点的X坐标。
      float ctrly
      二次曲线段控制点的Y坐标。
      float x1
      二次曲线段起始点的X坐标。
      float x2
      二次曲线段终点的X坐标。
      float y1
      二次曲线段起始点的Y坐标。
      float y2
      二次曲线段终点的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造并初始化具有坐标（ QuadCurve2D 。
      Float​(float x1, float y1, float ctrlx, float ctrly, float x2, float y2)
      构造并初始化一个 QuadCurve2D从指定 float坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D getBounds2D​()
      返回 Shape高精度和更准确的边框，比 getBounds方法。
      Point2D getCtrlPt​()
      返回控制点。
      double getCtrlX​()
      以 double精度返回控制点的X坐标。
      double getCtrlY​()
      以 double精度返回控制点的Y坐标。
      Point2D getP1​()
      返回起始点。
      Point2D getP2​()
      返回终点。
      double getX1​()
      以 double的精度返回起始点的X坐标。
      double getX2​()
      以 double精度返回终点的X坐标。
      double getY1​()
      返回 double精度的起始点的Y坐标。
      double getY2​()
      以 double精度返回终点的Y坐标。
      void setCurve​(double x1, double y1, double ctrlx, double ctrly, double x2, double y2)
      将该曲线的终点和控制点的位置设置为指定的 double坐标。
      void setCurve​(float x1, float y1, float ctrlx, float ctrly, float x2, float y2)
      将该曲线的终点和控制点的位置设置为指定的 float坐标。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.QuadCurve2D

        clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveQuadratic, solveQuadratic, subdivide, subdivide, subdivide

    • 字段详细信息

      • x1

        public float x1
        二次曲线段起始点的X坐标。
        从以下版本开始：
        1.2

      • y1

        public float y1
        二次曲线段起始点的Y坐标。
        从以下版本开始：
        1.2

      • ctrlx

        public float ctrlx
        二次曲线段控制点的X坐标。
        从以下版本开始：
        1.2

      • ctrly

        public float ctrly
        二次曲线段控制点的Y坐标。
        从以下版本开始：
        1.2

      • x2

        public float x2
        二次曲线段终点的X坐标。
        从以下版本开始：
        1.2

      • y2

        public float y2
        二次曲线段终点的Y坐标。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造并初始化具有坐标（ QuadCurve2D 。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x1,
             float y1,
             float ctrlx,
             float ctrly,
             float x2,
             float y2)
        构造并初始化一个 QuadCurve2D从指定 float坐标。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX1

        public double getX1​()
        以 double的精度返回起始点的X坐标。
        Specified by:
        getX1在 QuadCurve2D
        结果
        起始点的X坐标。
        从以下版本开始：
        1.2

      • getY1

        public double getY1​()
        以 double精度返回起始点的Y坐标。
        Specified by:
        getY1在 QuadCurve2D
        结果
        起始点的Y坐标。
        从以下版本开始：
        1.2

      • getP1

        public Point2D getP1​()
        返回起始点。
        Specified by:
        getP1在 QuadCurve2D
        结果
        一个 Point2D这是 QuadCurve2D 。
        从以下版本开始：
        1.2

      • getCtrlX

        public double getCtrlX​()
        以 double精度返回控制点的X坐标。
        Specified by:
        getCtrlX的 QuadCurve2D
        结果
        X坐标控制点
        从以下版本开始：
        1.2

      • getCtrlY

        public double getCtrlY​()
        以 double精度返回控制点的Y坐标。
        Specified by:
        getCtrlY在 QuadCurve2D
        结果
        控制点的Y坐标。
        从以下版本开始：
        1.2

      • getCtrlPt

        public Point2D getCtrlPt​()
        返回控制点。
        Specified by:
        getCtrlPt在 QuadCurve2D
        结果
        一个 Point2D是这个 Point2D的控制点。
        从以下版本开始：
        1.2

      • getX2

        public double getX2​()
        以 double精度返回终点的X坐标。
        Specified by:
        getX2在 QuadCurve2D
        结果
        终点的x坐标。
        从以下版本开始：
        1.2

      • getY2

        public double getY2​()
        以 double精度返回终点的Y坐标。
        Specified by:
        getY2在 QuadCurve2D
        结果
        终点的Y坐标。
        从以下版本开始：
        1.2

      • getP2

        public Point2D getP2​()
        返回终点。
        Specified by:
        getP2在 QuadCurve2D
        结果
        一个 Point对象，它是本的终点 Point2D 。
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(double x1,
                     double y1,
                     double ctrlx,
                     double ctrly,
                     double x2,
                     double y2)
        将该曲线的终点和控制点的位置设置为指定的 double坐标。
        Specified by:
        setCurve在 QuadCurve2D
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • setCurve

        public void setCurve​(float x1,
                     float y1,
                     float ctrlx,
                     float ctrly,
                     float x2,
                     float y2)
        将该曲线的终点和控制点的位置设置为指定的 float坐标。
        参数
        x1 - x1的X坐标
        y1 - y1的Y坐标
        ctrlx - 控制点的X坐标
        ctrly - 控制点的Y坐标
        x2 - 终点的X坐标
        y2 - 终点的Y坐标
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致在返回的bounds对象中不包含shape定义轮廓上的点的情况，但仅在原始shape未考虑这些点的情况下。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Rectangle2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Rectangle2D

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Rectangle2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    Rectangle ， Rectangle2D.Double ， Rectangle2D.Float

    public abstract class Rectangle2D
extends RectangularShape
    Rectangle2D类描述了由位置(x,y)和维度(w x h)定义的矩形。

    该类只是存储2D矩形的所有对象的抽象超类。 坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Rectangle2D.Double
      Double类定义了一个双坐标指定的矩形。
      static class  Rectangle2D.Float
      Float类定义了一个在浮点坐标中指定的矩形。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int OUT_BOTTOM
      该位掩码表示一个点位于此 Rectangle2D 。
      static int OUT_LEFT
      该位掩码表示一个点位于此 Rectangle2D的左侧。
      static int OUT_RIGHT
      该位掩码表示一个点位于此 Rectangle2D的右侧。
      static int OUT_TOP
      该位掩码表示一个点在 Rectangle2D 。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Rectangle2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void add​(double newx, double newy)
      将由双精度参数 newx和 newy指定的点添加到此 Rectangle2D 。
      void add​(Point2D pt)
      将 Point2D对象 pt添加到此 Rectangle2D 。
      void add​(Rectangle2D r)
      在这个 Rectangle2D添加一个 Rectangle2D对象。
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      abstract Rectangle2D createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      abstract Rectangle2D createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      boolean equals​(Object obj)
      确定指定的 Object是否等于此 Rectangle2D 。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      PathIterator getPathIterator​(AffineTransform at)
      返回定义 Rectangle2D边界的迭代对象。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代对象，该对象定义了展平 Rectangle2D的边界。
      int hashCode​()
      返回此 Rectangle2D的哈希 Rectangle2D 。
      static void intersect​(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest)
      相互对对指定的源 Rectangle2D对象，并将结果放入指定的目的地 Rectangle2D对象。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定的矩形区域的内部相交。
      boolean intersectsLine​(double x1, double y1, double x2, double y2)
      测试指定的线段是否与此 Rectangle2D的内部相交。
      boolean intersectsLine​(Line2D l)
      测试指定的线段是否与此 Rectangle2D的内部相交。
      abstract int outcode​(double x, double y)
      确定相对于这个 Rectangle2D指定坐标的 Rectangle2D 。
      int outcode​(Point2D p)
      确定指定的Point2D相对于该Rectangle2D 。
      void setFrame​(double x, double y, double w, double h)
      将此 Rectangle2D的外部边界的位置和大小设置为指定的矩形值。
      abstract void setRect​(double x, double y, double w, double h)
      将此 Rectangle2D的位置和大小设置为指定的 double值。
      void setRect​(Rectangle2D r)
      将此 Rectangle2D设置为与指定的 Rectangle2D相同。
      static void union​(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest)
      使用一对源 Rectangle2D对象并将结果放入指定的目的地 Rectangle2D对象。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • OUT_LEFT

        public static final int OUT_LEFT
        该位掩码表示一个点位于此 Rectangle2D的左侧。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • OUT_TOP

        public static final int OUT_TOP
        该位掩码表示一个点位于此 Rectangle2D 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • OUT_RIGHT

        public static final int OUT_RIGHT
        该位掩码表示一个点位于此 Rectangle2D的右侧。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • OUT_BOTTOM

        public static final int OUT_BOTTOM
        该位掩码表示一个点位于此 Rectangle2D 。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Rectangle2D

        protected Rectangle2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        Rectangle2D.Float ， Rectangle2D.Double ， Rectangle

    • 方法详细信息

      • setRect

        public abstract void setRect​(double x,
                             double y,
                             double w,
                             double h)
        将此 Rectangle2D的位置和大小设置为指定的 double值。
        参数
        x - 这个 Rectangle2D左上角的X坐标
        y - 这个 Rectangle2D左上角的Y坐标
        w - 这个 Rectangle2D的宽度
        h - 这个高度 Rectangle2D
        从以下版本开始：
        1.2

      • setRect

        public void setRect​(Rectangle2D r)
        将此 Rectangle2D设置为与指定的 Rectangle2D相同。
        参数
        r - 指定的 Rectangle2D
        从以下版本开始：
        1.2

      • intersectsLine

        public boolean intersectsLine​(double x1,
                              double y1,
                              double x2,
                              double y2)
        测试指定的线段是否与此 Rectangle2D的内部相交。
        参数
        x1 - 指定线段起始点的X坐标
        y1 - 指定线段起始点的Y坐标
        x2 - 指定线段终点的X坐标
        y2 - 指定线段终点的Y坐标
        结果
        true如果指定的线段与此Rectangle2D的内部相交; 否则为false 。
        从以下版本开始：
        1.2

      • intersectsLine

        public boolean intersectsLine​(Line2D l)
        测试指定的线段是否与此 Rectangle2D的内部相交。
        参数
        l - 指定的Line2D测试与这个Rectangle2D的内部Rectangle2D
        结果
        true如果指定的Line2D与这个Rectangle2D的内部相交; false否则。
        从以下版本开始：
        1.2

      • outcode

        public abstract int outcode​(double x,
                            double y)
        确定相对于该Rectangle2D指定坐标的Rectangle2D 。 该方法计算适当掩码值的二进制OR，表示对于该Rectangle2D每一边，指定的坐标是否与该Rectangle2D的其余部分位于边的同一侧。
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        结果
        所有适当输出代码的逻辑或。
        从以下版本开始：
        1.2
        另请参见：
        OUT_LEFT ， OUT_TOP ， OUT_RIGHT ， OUT_BOTTOM

      • outcode

        public int outcode​(Point2D p)
        确定指定的Point2D相对于该Rectangle2D 。 此方法计算的二进制OR指示适当的掩码值的，对于此的每一侧Rectangle2D ，指定是否Point2D是在边缘，因为这的剩余部分的同一侧Rectangle2D 。
        参数
        p - 指定的 Point2D
        结果
        所有适当输出代码的逻辑或。
        从以下版本开始：
        1.2
        另请参见：
        OUT_LEFT ， OUT_TOP ， OUT_RIGHT ， OUT_BOTTOM

      • setFrame

        public void setFrame​(double x,
                     double y,
                     double w,
                     double h)
        将此 Rectangle2D的外部边界的位置和大小设置为指定的矩形值。
        Specified by:
        setFrame在 RectangularShape
        参数
        x - 这个 Rectangle2D左上角的X坐标
        y - 这个 Rectangle2D左上角的Y坐标
        w - 这个 Rectangle2D的宽度
        h - 这个高度 Rectangle2D
        从以下版本开始：
        1.2
        另请参见：
        RectangularShape.getFrame()

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape可能不被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果一个point是在shape按contains(point)方法，那就必须在Rectangle2D范围内的Rectangle2D边界对象中，按contains(point)方法的bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标是在Shape边界内; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 如果任何点包含在Shape的内部和指定的矩形区域中，则矩形区域被认为与Shape相交。

        Shape.intersects()方法允许Shape实现保守返回true当：

        • 矩形区域和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回true即使矩形区域没有相交Shape 。 Area类比大多数Shape对象执行几何交集的更精确的计算，因此如果需要更精确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标必须位于Shape内，因为整个矩形区域将被视为包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false当：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于Shapes这个方法可能会返回false即使Shape包含矩形区域。 Area类比大多数Shape对象执行更精确的几何计算，因此如果需要更精确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则，或者如果Shape包含矩形区域，并且intersects方法返回true并且包含计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • createIntersection

        public abstract Rectangle2D createIntersection​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
        参数
        r -在 Rectangle2D与此相交 Rectangle2D
        结果
        最大的 Rectangle2D包含在指定的 Rectangle2D和在这 Rectangle2D 。
        从以下版本开始：
        1.2

      • intersect

        public static void intersect​(Rectangle2D src1,
                             Rectangle2D src2,
                             Rectangle2D dest)
        相互对对指定的源Rectangle2D对象，并将结果放入指定的目的地Rectangle2D对象。 源矩形之一也可以是避免创建第三个Rectangle2D对象的目的地，但在这种情况下，此源矩形的原始点将被该方法覆盖。
        参数
        src1 - 要彼此相交的一对 Rectangle2D对象中的第一个
        src2 - 要彼此相交的一对 Rectangle2D对象中的第二个
        dest -所述 Rectangle2D保存的交集的结果 src1和 src2
        从以下版本开始：
        1.2

      • createUnion

        public abstract Rectangle2D createUnion​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
        参数
        r -在 Rectangle2D与此相结合 Rectangle2D
        结果
        最小的 Rectangle2D包含指定的 Rectangle2D和 Rectangle2D 。
        从以下版本开始：
        1.2

      • union

        public static void union​(Rectangle2D src1,
                         Rectangle2D src2,
                         Rectangle2D dest)
        连接一对源Rectangle2D对象，并将结果放入指定的目标位置Rectangle2D对象。 源矩形之一也可以是避免创建第三个Rectangle2D对象的目的地，但在这种情况下，此源矩形的原始点将被该方法覆盖。
        参数
        src1 - 一对 Rectangle2D对象中的第一个要彼此组合
        src2 - 要彼此组合的一对 Rectangle2D对象中的第二个
        dest -在 Rectangle2D持有的联合的结果 src1和 src2
        从以下版本开始：
        1.2

      • add

        public void add​(double newx,
                double newy)
        将由双精度参数newx和newy指定的点添加到此Rectangle2D 。 所得的Rectangle2D是最小的Rectangle2D ，其中包含原始的Rectangle2D和指定点。

        添加点后，调用contains添加点作为参数不一定返回true 。 contains方法不会返回true对于矩形右侧或底部边缘的点。 因此，如果添加点落在放大矩形的左边缘或下边缘，那么contains返回false 。

        参数
        newx - 新点的X坐标
        newy - 新点的Y坐标
        从以下版本开始：
        1.2

      • add

        public void add​(Point2D pt)
        将Point2D对象pt添加到此Rectangle2D 。 所得的Rectangle2D是最小的Rectangle2D ，其中包含原始的Rectangle2D和指定的Point2D 。

        添加点后，调用contains添加点作为参数不一定返回true 。 contains方法不会返回true对于矩形右边或底边的点。 因此，如果添加点落在放大矩形的左边缘或下边缘，那么contains返回false 。

        参数
        pt - 新增 Point2D这个 Rectangle2D 。
        从以下版本开始：
        1.2

      • add

        public void add​(Rectangle2D r)
        在这个Rectangle2D添加一个Rectangle2D对象。 所得到的Rectangle2D是两个Rectangle2D对象的并集。
        参数
        r - Rectangle2D添加到这个 Rectangle2D 。
        从以下版本开始：
        1.2

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回一个定义Rectangle2D边界的迭代对象。 该类的迭代器是多线程安全的，这意味着这个Rectangle2D类保证对这个Rectangle2D对象的几何的修改不会影响已经在处理的几何的任何迭代。
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        结果
        PathIterator对象，返回此 Rectangle2D的轮廓的几何，一次一个段。
        从以下版本开始：
        1.2

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at,
                                    double flatness)
        返回一个迭代对象，它定义了Rectangle2D化的边界Rectangle2D 。 由于矩形已经平坦，因此flatness参数将被忽略。 该类的迭代器是多线程安全的，这意味着这个Rectangle2D类保证对这个Rectangle2D对象的几何的修改不会影响已经在处理的几何的任何迭代。
        Specified by:
        getPathIterator在接口 Shape
        重写：
        getPathIterator在 RectangularShape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null
        flatness - 用于近似曲线段的线段的最大距离允许偏离原始曲线上的任何点。 由于矩形已经平坦，因此flatness参数将被忽略。
        结果
        PathIterator对象返回此 Rectangle2D的轮廓的几何，一次一个段。
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回此 Rectangle2D的哈希 Rectangle2D 。
        重写：
        hashCode在 Object
        结果
        这个 Rectangle2D的哈希 Rectangle2D 。
        从以下版本开始：
        1.2
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        确定指定的Object是否等于此Rectangle2D 。 指定Object等于该Rectangle2D ，如果它是一个实例Rectangle2D ，如果它的位置和大小是相同的，因为这Rectangle2D 。
        重写：
        equals在 Object
        参数
        obj - 一个 Object要与这个 Rectangle2D进行比较。
        结果
        true如果obj是的一个实例Rectangle2D ，并且具有相同的值; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Rectangle2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Rectangle2D.Double

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Rectangle2D
        • java.awt.geom.Rectangle2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Rectangle2D

    public static class Rectangle2D.Double
extends Rectangle2D
implements Serializable
    Double类定义了一个双坐标指定的矩形。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Rectangle2D

        Rectangle2D.Double, Rectangle2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double height
      这个高度这 Rectangle2D 。
      double width
      这个宽度 Rectangle2D 。
      double x
      这个 Rectangle2D的X坐标。
      double y
      这个 Rectangle2D的Y坐标。

      • Fields inherited from class java.awt.geom.Rectangle2D

        OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造一个新的 Rectangle2D ，初始化为位置（0,0）和大小（0,0）。
      Double​(double x, double y, double w, double h)
      构造并初始化一个 Rectangle2D从指定 double坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      double getHeight​()
      double
      double getWidth​()
      以 double精度返回成帧矩形的宽度。
      double getX​()
      返回 double精度的成帧矩形左上角的X坐标。
      double getY​()
      返回 double精度的框架矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      int outcode​(double x, double y)
      确定相对于该 Rectangle2D指定坐标的 Rectangle2D 。
      void setRect​(double x, double y, double w, double h)
      将此 Rectangle2D的位置和大小设置为指定的 double值。
      void setRect​(Rectangle2D r)
      将此 Rectangle2D设置为与指定的 Rectangle2D相同。
      String toString​()
      返回此 Rectangle2D的 String表示。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.geom.Rectangle2D

        add, add, add, contains, contains, equals, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, union

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • x

        public double x
        这个 Rectangle2D的X坐标。
        从以下版本开始：
        1.2

      • y

        public double y
        这个 Rectangle2D的Y坐标。
        从以下版本开始：
        1.2

      • width

        public double width
        这个宽度 Rectangle2D 。
        从以下版本开始：
        1.2

      • height

        public double height
        这个高度这个 Rectangle2D 。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        构造新的 Rectangle2D ，初始化为位置（0，0）和大小（0，0）。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x,
              double y,
              double w,
              double h)
        构造并初始化一个 Rectangle2D从指定 double坐标。
        参数
        x - 新构建的左上角的X坐标 Rectangle2D
        y - 新构建的左上角的Y坐标 Rectangle2D
        w - 新建 Rectangle2D的宽度
        h - 新建 Rectangle2D的高度
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        以 double精度返回框架矩形左上角的X坐标。
        Specified by:
        getX在 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回 double精度的框架矩形左上角的Y坐标。
        Specified by:
        getY中的 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        返回 double精度的成帧矩形的宽度。
        Specified by:
        getWidth在 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        以 double精度返回框架矩形的高度。
        Specified by:
        getHeight在 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，不包含任何区域。
        Specified by:
        isEmpty在 RectangularShape
        结果
        true如果RectangularShape是空的; 否则为false 。
        从以下版本开始：
        1.2

      • setRect

        public void setRect​(double x,
                    double y,
                    double w,
                    double h)
        将此 Rectangle2D的位置和大小设置为指定的 double值。
        Specified by:
        setRect在 Rectangle2D
        参数
        x - 这个 Rectangle2D左上角的X坐标
        y - 这个 Rectangle2D左上角的Y坐标
        w - 这个 Rectangle2D的宽度
        h - 这个高度 Rectangle2D
        从以下版本开始：
        1.2

      • setRect

        public void setRect​(Rectangle2D r)
        将此 Rectangle2D设置为与指定的 Rectangle2D相同。
        重写：
        setRect在 Rectangle2D
        参数
        r - 指定的 Rectangle2D
        从以下版本开始：
        1.2

      • outcode

        public int outcode​(double x,
                   double y)
        确定相对于该Rectangle2D指定坐标的Rectangle2D 。 该方法计算适当掩码值的二进制OR，该值适用于该Rectangle2D每一侧，指定的坐标是否与该Rectangle2D的其余部分位于同一边。
        Specified by:
        outcode在 Rectangle2D
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        结果
        所有适当输出代码的逻辑或。
        从以下版本开始：
        1.2
        另请参见：
        Rectangle2D.OUT_LEFT ， Rectangle2D.OUT_TOP ， Rectangle2D.OUT_RIGHT ， Rectangle2D.OUT_BOTTOM

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape高精度和更准确的边框，比getBounds方法。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果point中没有shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        重写：
        getBounds2D在 Rectangle2D
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()

      • createIntersection

        public Rectangle2D createIntersection​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
        Specified by:
        createIntersection在 Rectangle2D
        参数
        r -在 Rectangle2D与此相交 Rectangle2D
        结果
        最大的 Rectangle2D包含在指定的 Rectangle2D和在这 Rectangle2D 。
        从以下版本开始：
        1.2

      • createUnion

        public Rectangle2D createUnion​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
        Specified by:
        createUnion在 Rectangle2D
        参数
        r -在 Rectangle2D与此相结合 Rectangle2D
        结果
        最小的 Rectangle2D包含指定的 Rectangle2D和 Rectangle2D 。
        从以下版本开始：
        1.2

      • toString

        public String toString​()
        返回此 Rectangle2D的 String表示。
        重写：
        toString在 Object
        结果
        一个 String表示此 Rectangle2D 。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Rectangle2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class Rectangle2D.Float

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Rectangle2D
        • java.awt.geom.Rectangle2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    Rectangle2D

    public static class Rectangle2D.Float
extends Rectangle2D
implements Serializable
    Float类定义了一个以浮点坐标指定的矩形。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.Rectangle2D

        Rectangle2D.Double, Rectangle2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float height
      这个高度这 Rectangle2D 。
      float width
      该宽度为 Rectangle2D 。
      float x
      这个X坐标 Rectangle2D 。
      float y
      这个Y坐标是 Rectangle2D 。

      • Fields inherited from class java.awt.geom.Rectangle2D

        OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造一个新的 Rectangle2D ，初始化为位置（ Rectangle2D ）和大小（ Rectangle2D ）。
      Float​(float x, float y, float w, float h)
      构造并初始化一个 Rectangle2D从指定 float坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Rectangle2D createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边框。
      double getHeight​()
      以 double精度返回框架矩形的高度。
      double getWidth​()
      以 double精度返回框架矩形的宽度。
      double getX​()
      以 double精度返回成帧矩形左上角的X坐标。
      double getY​()
      返回 double精度的框架矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      int outcode​(double x, double y)
      确定相对于该 Rectangle2D指定坐标的 Rectangle2D 。
      void setRect​(double x, double y, double w, double h)
      将此 Rectangle2D的位置和大小设置为指定的 double值。
      void setRect​(float x, float y, float w, float h)
      将此 Rectangle2D的位置和大小设置为指定的 float值。
      void setRect​(Rectangle2D r)
      将此 Rectangle2D设置为与指定的 Rectangle2D相同。
      String toString​()
      返回此 Rectangle2D的 String表示。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.geom.Rectangle2D

        add, add, add, contains, contains, equals, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, union

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

    • 字段详细信息

      • x

        public float x
        这个 Rectangle2D的X坐标。
        从以下版本开始：
        1.2

      • y

        public float y
        这个Y坐标 Rectangle2D 。
        从以下版本开始：
        1.2

      • width

        public float width
        该宽度为 Rectangle2D 。
        从以下版本开始：
        1.2

      • height

        public float height
        这高度这 Rectangle2D 。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造一个新的 Rectangle2D ，初始化为位置（ Rectangle2D ）和大小（ Rectangle2D ）。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x,
             float y,
             float w,
             float h)
        构造并初始化一个 Rectangle2D从指定 float坐标。
        参数
        x - 新构建的左上角的X坐标 Rectangle2D
        y - 新构建的左上角的Y坐标 Rectangle2D
        w - 新建 Rectangle2D的宽度
        h - 新建 Rectangle2D的高度
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        以 double精度返回成帧矩形左上角的X坐标。
        Specified by:
        getX在 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        返回 double精度的框架矩形左上角的Y坐标。
        Specified by:
        getY在 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        以 double精度返回框架矩形的宽度。
        Specified by:
        getWidth类 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        以 double精度返回框架矩形的高度。
        Specified by:
        getHeight在 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 RectangularShape为空时，不包含区域。
        Specified by:
        isEmpty在 RectangularShape
        结果
        true如果RectangularShape是空的; false否则。
        从以下版本开始：
        1.2

      • setRect

        public void setRect​(float x,
                    float y,
                    float w,
                    float h)
        将此 Rectangle2D的位置和大小设置为指定的 float值。
        参数
        x -在X本的左上角坐标 Rectangle2D
        y - 这个 Rectangle2D左上角的Y坐标
        w - 这个 Rectangle2D的宽度
        h - 这个 Rectangle2D的高度
        从以下版本开始：
        1.2

      • setRect

        public void setRect​(double x,
                    double y,
                    double w,
                    double h)
        将此 Rectangle2D的位置和大小设置为指定的 double值。
        Specified by:
        setRect在 Rectangle2D
        参数
        x - 这个 Rectangle2D左上角的X坐标
        y - 这个 Rectangle2D左上角的Y坐标
        w - 这个 Rectangle2D的宽度
        h - 这个 Rectangle2D的高度
        从以下版本开始：
        1.2

      • setRect

        public void setRect​(Rectangle2D r)
        将此 Rectangle2D设置为与指定的 Rectangle2D相同。
        重写：
        setRect在 Rectangle2D
        参数
        r - 指定的 Rectangle2D
        从以下版本开始：
        1.2

      • outcode

        public int outcode​(double x,
                   double y)
        确定相对于该Rectangle2D指定坐标的Rectangle2D 。 该方法计算适当的掩码值的二进制OR，表示对于该Rectangle2D每一边，指定的坐标是否与该Rectangle2D的其余部分位于边的同一侧。
        Specified by:
        outcode在 Rectangle2D
        参数
        x - 指定的X坐标
        y - 指定的Y坐标
        结果
        所有适当输出代码的逻辑或。
        从以下版本开始：
        1.2
        另请参见：
        Rectangle2D.OUT_LEFT ， Rectangle2D.OUT_TOP ， Rectangle2D.OUT_RIGHT ， Rectangle2D.OUT_BOTTOM

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape中这些点也未被包含的shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        重写：
        getBounds2D在 Rectangle2D
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()

      • createIntersection

        public Rectangle2D createIntersection​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
        Specified by:
        createIntersection在 Rectangle2D
        参数
        r -在 Rectangle2D与此相交 Rectangle2D
        结果
        最大的 Rectangle2D包含在指定的 Rectangle2D和在这 Rectangle2D 。
        从以下版本开始：
        1.2

      • createUnion

        public Rectangle2D createUnion​(Rectangle2D r)
        返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
        Specified by:
        createUnion的 Rectangle2D
        参数
        r -在 Rectangle2D与此相结合 Rectangle2D
        结果
        最小的 Rectangle2D包含指定的 Rectangle2D和 Rectangle2D 。
        从以下版本开始：
        1.2

      • toString

        public String toString​()
        返回此 Rectangle2D的 String表示。
        重写：
        toString在 Object
        结果
        一个 String代表这 Rectangle2D 。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RectangularShape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class RectangularShape

  • java.lang.Object
    • java.awt.geom.RectangularShape
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    Arc2D ， Ellipse2D ， Rectangle2D ， RoundRectangle2D

    public abstract class RectangularShape
extends Object
implements Shape, Cloneable
    RectangularShape是几何由矩形框架定义的Shape对象的基类。 这个类本身并不直接指定任何特定的几何体，而只是提供由Shape对象的整个类别继承的操作方法。 该类提供的操作方法可用于查询和修改矩形框架，为框架子集定义几何图形提供了参考。
    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected RectangularShape​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建与该对象相同的类和新内容相同的新对象。
      boolean contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      Rectangle getBounds​()
      返回一个整数Rectangle完全包围Shape 。
      double getCenterX​()
      以 double精度 Shape double框架矩形中心的X坐标。
      double getCenterY​()
      以 double精度 Shape double框架矩形中心的Y坐标。
      Rectangle2D getFrame​()
      返回定义此对象的整体形状的框架Rectangle2D 。
      abstract double getHeight​()
      以 double精度返回框架矩形的高度。
      double getMaxX​()
      以 double精度返回 Shape的成帧矩形的最大X坐标。
      double getMaxY​()
      以 double精度返回 Shape的成帧矩形的最大Y坐标。
      double getMinX​()
      以 double精度返回 Shape的框架矩形的最小X坐标。
      double getMinY​()
      以 double精度返回 Shape的成帧矩形的最小Y坐标。
      PathIterator getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代器对象，它沿 Shape对象的边界进行迭代，并提供对 Shape对象的几何体轮廓的平坦化视图的访问。
      abstract double getWidth​()
      以 double精度返回成帧矩形的宽度。
      abstract double getX​()
      以 double精度返回成帧矩形左上角的X坐标。
      abstract double getY​()
      返回 double精度的框架矩形左上角的Y坐标。
      boolean intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      abstract boolean isEmpty​()
      确定 RectangularShape是否为空。
      abstract void setFrame​(double x, double y, double w, double h)
      将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。
      void setFrame​(Point2D loc, Dimension2D size)
      将此Shape的成帧矩形的位置和大小分别设置为Point2D和Dimension2D 。
      void setFrame​(Rectangle2D r)
      将此 Shape的成帧矩形设置为指定的 Rectangle2D 。
      void setFrameFromCenter​(double centerX, double centerY, double cornerX, double cornerY)
      根据指定的中心点坐标和角点坐标设置此 Shape的框架矩形。
      void setFrameFromCenter​(Point2D center, Point2D corner)
      根据指定的中心 Point2D和角 Point2D设置此 Shape的框架矩形。
      void setFrameFromDiagonal​(double x1, double y1, double x2, double y2)
      基于两个指定的坐标，设置此 Shape框架矩形的对角线。
      void setFrameFromDiagonal​(Point2D p1, Point2D p2)
      基于两个指定的 Point2D对象设置 Shape的框架矩形的对角线。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.awt.Shape

        contains, contains, getBounds2D, getPathIterator, intersects

    • 构造方法详细信息

      • RectangularShape

        protected RectangularShape​()
        这是一个无法直接实例化的抽象类。
        从以下版本开始：
        1.2
        另请参见：
        Arc2D ， Ellipse2D ， Rectangle2D ， RoundRectangle2D

    • 方法详细信息

      • getX

        public abstract double getX​()
        以 double精度返回成帧矩形左上角的X坐标。
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public abstract double getY​()
        以 double精度返回成帧矩形左上角的Y坐标。
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public abstract double getWidth​()
        以 double精度返回成帧矩形的宽度。
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public abstract double getHeight​()
        以 double精度返回框架矩形的高度。
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • getMinX

        public double getMinX​()
        以 double精度返回 Shape的成帧矩形的最小X坐标。
        结果
        Shape的框架矩形的最小X坐标。
        从以下版本开始：
        1.2

      • getMinY

        public double getMinY​()
        以 double精度返回 Shape的成帧矩形的最小Y坐标。
        结果
        Shape的框架矩形的最小Y坐标。
        从以下版本开始：
        1.2

      • getMaxX

        public double getMaxX​()
        以 double精度返回 Shape的成帧矩形的最大X坐标。
        结果
        Shape的框架矩形的最大X坐标。
        从以下版本开始：
        1.2

      • getMaxY

        public double getMaxY​()
        以 double精度返回 Shape的成帧矩形的最大Y坐标。
        结果
        Shape框架矩形的最大Y坐标。
        从以下版本开始：
        1.2

      • getCenterX

        public double getCenterX​()
        以 double精度返回 Shape的框架矩形中心的X坐标。
        结果
        Shape框架矩形中心的X坐标。
        从以下版本开始：
        1.2

      • getCenterY

        public double getCenterY​()
        以 double精度 Shape double框架矩形中心的Y坐标。
        结果
        Shape框架矩形中心的Y坐标。
        从以下版本开始：
        1.2

      • getFrame

        public Rectangle2D getFrame​()
        返回定义此对象的整体形状的框架Rectangle2D 。
        结果
        一个 Rectangle2D ，在 double指定坐标。
        从以下版本开始：
        1.2
        另请参见：
        setFrame(double, double, double, double) ，
setFrame(Point2D, Dimension2D) ，
setFrame(Rectangle2D)

      • isEmpty

        public abstract boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，它不会包围任何区域。
        结果
        true如果RectangularShape是空的; 否则为false 。
        从以下版本开始：
        1.2

      • setFrame

        public abstract void setFrame​(double x,
                              double y,
                              double w,
                              double h)
        将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。
        参数
        x - 指定矩形左上角的X坐标
        y - 指定矩形左上角的Y坐标
        w - 指定长方形的宽度
        h - 指定长方形的高度
        从以下版本开始：
        1.2
        另请参见：
        getFrame()

      • setFrame

        public void setFrame​(Point2D loc,
                     Dimension2D size)
        将此Shape的成帧矩形的位置和大小分别设置为Point2D和Dimension2D 。 框架矩形由RectangularShape的子类用于定义其几何。
        参数
        loc - 指定的 Point2D
        size - 指定的 Dimension2D
        从以下版本开始：
        1.2
        另请参见：
        getFrame()

      • setFrame

        public void setFrame​(Rectangle2D r)
        将此Shape的成帧矩形设置为指定的Rectangle2D 。 框架矩形由RectangularShape的子类用于定义其几何。
        参数
        r - 指定的 Rectangle2D
        从以下版本开始：
        1.2
        另请参见：
        getFrame()

      • setFrameFromDiagonal

        public void setFrameFromDiagonal​(double x1,
                                 double y1,
                                 double x2,
                                 double y2)
        基于两个指定的坐标，设置该Shape的框架矩形的对角线。 框架矩形由RectangularShape的子类用于定义其几何。
        参数
        x1 - 指定对角线起始点的X坐标
        y1 - 指定对角线起始点的Y坐标
        x2 - 指定对角线的终点的X坐标
        y2 - 指定对角线终点的Y坐标
        从以下版本开始：
        1.2

      • setFrameFromDiagonal

        public void setFrameFromDiagonal​(Point2D p1,
                                 Point2D p2)
        基于两个指定的Point2D对象设置Shape的框架矩形的对角线。 框架矩形由RectangularShape的子类用于定义其几何。
        参数
        p1 - 指定对角线的起始 Point2D
        p2 - 指定对角线的末端 Point2D
        从以下版本开始：
        1.2

      • setFrameFromCenter

        public void setFrameFromCenter​(double centerX,
                               double centerY,
                               double cornerX,
                               double cornerY)
        根据指定的中心点坐标和角点坐标设置此Shape的框架矩形。 框架矩形由RectangularShape的子类用于定义其几何。
        参数
        centerX - 指定中心点的X坐标
        centerY - 指定中心点的Y坐标
        cornerX - 指定角点的X坐标
        cornerY - 指定角点的Y坐标
        从以下版本开始：
        1.2

      • setFrameFromCenter

        public void setFrameFromCenter​(Point2D center,
                               Point2D corner)
        根据指定的中心Point2D和角Point2D设置此Shape的框架矩形。 框架矩形由RectangularShape的子类用于定义其几何。
        参数
        center - 指定中心 Point2D
        corner - 指定的角 Point2D
        从以下版本开始：
        1.2

      • contains

        public boolean contains​(Point2D p)
        测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
        Specified by:
        contains在接口 Shape
        参数
        p - 要测试的指定的 Point2D
        结果
        true如果指定Point2D是的边界内Shape ; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(Rectangle2D r)
        测试Shape的内部是否与指定的内部相交Rectangle2D 。 Shape.intersects()方法允许一个Shape实现保守返回true当：
        • Rectangle2D和Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于一些Shapes这个方法可能会返回true即使Rectangle2D不与Shape相交。 Area类对大多数Shape对象执行几何交集的更准确的计算，因此如果需要更准确的答案，则可以使用它。
        Specified by:
        intersects在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果Shape的内部和指定的Rectangle2D的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.intersects(double, double, double, double)

      • contains

        public boolean contains​(Rectangle2D r)
        测试Shape的内部Shape完全包含指定的Rectangle2D 。 Shape.contains()方法允许一个Shape实现保守地返回false当：
        • intersect方法返回true和
        • 确定Shape是否完全包含Rectangle2D是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回false即使Shape包含Rectangle2D 。 Area类比大多数Shape对象执行更准确的几何计算，因此如果需要更精确的答案，则可以使用它。
        Specified by:
        contains在接口 Shape
        参数
        r - 指定的 Rectangle2D
        结果
        true如果内部的Shape完全包含Rectangle2D ; false否则或如果Shape包含Rectangle2D和intersects方法返回true ，并且包含计算将太昂贵执行。
        从以下版本开始：
        1.2
        另请参见：
        Shape.contains(double, double, double, double)

      • getBounds

        public Rectangle getBounds​()
        返回一个整数Rectangle完全包围Shape 。 请注意，不保证返回的Rectangle是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle 。 如果Shape溢出整数数据类型的有限范围，则返回的Rectangle也可能无法完全包含Shape 。 getBounds2D方法通常返回更严格的边界框，因为它具有更大的表示灵活性。

        需要注意的是definition of insideness可能会导致出现对的定义轮廓点的情况下shape可能不被认为包含在返回bounds对象，但只有在这些点也未审议了原有的情况下shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(x,y)需要bounds.contains(x,y)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(x,y)并不表示shape.contains(x,y)

        Specified by:
        getBounds在接口 Shape
        结果
        整数 Rectangle完全包围了 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds2D()

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at,
                                    double flatness)
        返回一个迭代器对象，该对象沿Shape对象的边界进行迭代，并提供对Shape对象的几何体轮廓的平坦化视图的访问。

        只有SEG_MOVETO，SEG_LINETO和SEG_CLOSE点类型将由迭代器返回。

        曲线段的细分量由flatness参数控制，该参数指定未平坦化变换曲线上的任何点可能偏离返回的平坦化路径段的最大距离。 可以指定可选的AffineTransform，以便相应地转换迭代中返回的坐标。

        Specified by:
        getPathIterator在接口 Shape
        参数
        at - 要在迭代中返回时应用于坐标的可选 AffineTransform ，如果需要未转换的坐标， null 。
        flatness - 用于近似曲线段的线段的最大距离允许偏离原始曲线上的任何点
        结果
        一个 PathIterator对象，可以访问 Shape对象的展平几何。
        从以下版本开始：
        1.2

      • clone

        public Object clone​()
        创建与该对象相同的类和新内容相同的新对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        异常
        OutOfMemoryError - 如果没有足够的内存
        从以下版本开始：
        1.2
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RoundRectangle2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class RoundRectangle2D

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.RoundRectangle2D
  • All Implemented Interfaces:
    Shape ， Cloneable
    已知直接子类：
    RoundRectangle2D.Double ， RoundRectangle2D.Float

    public abstract class RoundRectangle2D
extends RectangularShape
    RoundRectangle2D类定义了一个带有圆角的矩形，由一个位置(x,y)定义，一个尺寸为(w x h) ，以及用于围绕角落的圆弧的宽度和高度。

    该类是存储2D圆角矩形的所有对象的抽象超类。 坐标的实际存储表示留给子类。

    从以下版本开始：
    1.2

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  RoundRectangle2D.Double
      Double类定义了一个带有圆角的矩形，全部在 double指定。
      static class  RoundRectangle2D.Float
      Float类定义了一个具有圆角的矩形，全部在 float坐标中指定。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected RoundRectangle2D​()
      这是一个无法直接实例化的抽象类。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      boolean contains​(double x, double y)
      测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
      boolean contains​(double x, double y, double w, double h)
      测试 Shape的内部 Shape完全包含指定的矩形区域。
      boolean equals​(Object obj)
      确定指定的 Object是否等于此 RoundRectangle2D 。
      abstract double getArcHeight​()
      获取圆角圆弧的高度。
      abstract double getArcWidth​()
      获取从角落舍入的圆弧的宽度。
      PathIterator getPathIterator​(AffineTransform at)
      返回定义 RoundRectangle2D边界的迭代对象。
      int hashCode​()
      返回此 RoundRectangle2D的哈希 RoundRectangle2D 。
      boolean intersects​(double x, double y, double w, double h)
      测试 Shape的内部是否与指定的矩形区域的内部相交。
      void setFrame​(double x, double y, double w, double h)
      将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。
      abstract void setRoundRect​(double x, double y, double w, double h, double arcWidth, double arcHeight)
      将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。
      void setRoundRect​(RoundRectangle2D rr)
      将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

      • Methods inherited from interface java.awt.Shape

        getBounds2D

    • 构造方法详细信息

      • RoundRectangle2D

        protected RoundRectangle2D​()
        这是一个无法直接实例化的抽象类。 类型特定的实现子类可用于实例化，并提供了许多格式，用于存储满足以下各种存取方法所必需的信息。
        从以下版本开始：
        1.2
        另请参见：
        RoundRectangle2D.Float ， RoundRectangle2D.Double

    • 方法详细信息

      • getArcWidth

        public abstract double getArcWidth​()
        获取从角落舍入的圆弧的宽度。
        结果
        从 RoundRectangle2D角落圆弧的宽度。
        从以下版本开始：
        1.2

      • getArcHeight

        public abstract double getArcHeight​()
        获取圆角圆弧的高度。
        结果
        从 RoundRectangle2D的角落圆弧的高度。
        从以下版本开始：
        1.2

      • setRoundRect

        public abstract void setRoundRect​(double x,
                                  double y,
                                  double w,
                                  double h,
                                  double arcWidth,
                                  double arcHeight)
        将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。
        参数
        x - 设置此 RoundRectangle2D的位置的X坐标
        y - 设置此 RoundRectangle2D的位置的Y坐标
        w - 设置此 RoundRectangle2D的宽度
        h - 设置此 RoundRectangle2D的高度
        arcWidth - 设置此 RoundRectangle2D弧的 RoundRectangle2D
        arcHeight - 设置此 RoundRectangle2D弧的 RoundRectangle2D
        从以下版本开始：
        1.2

      • setRoundRect

        public void setRoundRect​(RoundRectangle2D rr)
        将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。
        参数
        rr - 指定的 RoundRectangle2D
        从以下版本开始：
        1.2

      • setFrame

        public void setFrame​(double x,
                     double y,
                     double w,
                     double h)
        将此 Shape的成帧矩形的位置和大小设置为指定的矩形值。
        Specified by:
        setFrame在 RectangularShape
        参数
        x - 指定矩形左上角的X坐标
        y - 指定矩形左上角的Y坐标
        w - 指定矩形形状的宽度
        h - 指定长方形的高度
        从以下版本开始：
        1.2
        另请参见：
        RectangularShape.getFrame()

      • contains

        public boolean contains​(double x,
                        double y)
        测试指定的坐标是否在 Shape的边界内，如 definition of insideness所述 。
        参数
        x - 要测试的指定X坐标
        y - 要测试的指定Y坐标
        结果
        true如果指定的坐标在Shape边界内; 否则为false 。
        从以下版本开始：
        1.2

      • intersects

        public boolean intersects​(double x,
                          double y,
                          double w,
                          double h)
        测试Shape的内部是否与指定矩形区域的内部相交。 如果任何点都包含在Shape的内部和指定的矩形区域中，则矩形区域被认为与Shape相交。

        Shape.intersects()方法允许Shape实现保守返回true当：

        • 矩形区域与Shape相交的概率很高，但是
        • 准确地确定这个交叉点的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回true即使矩形区域没有相交Shape 。 Area类比大多数Shape对象执行几何交集的更准确的计算，因此如果需要更精确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果Shape的内部和矩形区域的内部相交，或者两者都很可能相交，并且交叉点计算将太昂贵执行; 否则为false 。
        从以下版本开始：
        1.2
        另请参见：
        Area

      • contains

        public boolean contains​(double x,
                        double y,
                        double w,
                        double h)
        测试Shape的内部Shape完全包含指定的矩形区域。 位于矩形区域内的所有坐标必须位于Shape内，因为整个矩形区域将被视为包含在Shape 。

        Shape.contains()方法允许Shape实现保守返回false当时：

        • intersect方法返回true和
        • 确定Shape是否完全包含矩形区域的计算是非常昂贵的。
        这意味着对于某些Shapes这种方法也可能返回false即使Shape包含矩形区域。 Area类比大多数Shape对象执行更精确的几何计算，因此如果需要更准确的答案，则可以使用它。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        true如果内部的Shape完全包含指定的矩形区域; false否则或如果Shape包含矩形区域，并且intersects方法返回true ，并且包含计算将太昂贵，无法执行。
        从以下版本开始：
        1.2
        另请参见：
        Area ， Shape.intersects(double, double, double, double)

      • getPathIterator

        public PathIterator getPathIterator​(AffineTransform at)
        返回一个定义RoundRectangle2D边界的迭代对象。 该类的迭代器是多线程安全的，这意味着这个RoundRectangle2D类保证对这个RoundRectangle2D对象的几何的修改不会影响已经在处理的几何的任何迭代。
        参数
        at - 要在迭代中返回时应用于坐标的可选的 AffineTransform ，如果需要未转换的坐标， null
        结果
        PathIterator对象，返回此 RoundRectangle2D的轮廓的几何，一次一个段。
        从以下版本开始：
        1.2

      • hashCode

        public int hashCode​()
        返回此 RoundRectangle2D的哈希 RoundRectangle2D 。
        重写：
        hashCode在 Object
        结果
        这个 RoundRectangle2D的哈希 RoundRectangle2D 。
        从以下版本开始：
        1.6
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        确定指定的Object是否等于此RoundRectangle2D 。 指定Object等于该RoundRectangle2D ，如果它是一个实例RoundRectangle2D ，如果它的位置，大小和角弧的尺寸是相同的，因为这RoundRectangle2D 。
        重写：
        equals在 Object
        参数
        obj - 一个 Object要与这个 RoundRectangle2D进行比较。
        结果
        true如果obj是的一个实例RoundRectangle2D ，并且具有相同的值; 否则为false 。
        从以下版本开始：
        1.6
        另请参见：
        Object.hashCode() ， HashMap
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RoundRectangle2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class RoundRectangle2D.Double

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.RoundRectangle2D
        • java.awt.geom.RoundRectangle2D.Double
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    RoundRectangle2D

    public static class RoundRectangle2D.Double
extends RoundRectangle2D
implements Serializable
    Double类定义了一个具有圆角的矩形，全部在 double坐标中指定。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.RoundRectangle2D

        RoundRectangle2D.Double, RoundRectangle2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double archeight
      从角落圆弧的高度。
      double arcwidth
      从角落圆弧的宽度。
      double height
      这个高度 RoundRectangle2D 。
      double width
      这个宽度 RoundRectangle2D 。
      double x
      这个X坐标 RoundRectangle2D 。
      double y
      这个Y坐标 RoundRectangle2D 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​()
      构造新的 RoundRectangle2D ，初始化为位置（ RoundRectangle2D ），大小（ RoundRectangle2D ）和半径为0.0的角弧。
      Double​(double x, double y, double w, double h, double arcw, double arch)
      构造并初始化一个 RoundRectangle2D从指定 double坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getArcHeight​()
      获取圆角圆弧的高度。
      double getArcWidth​()
      获取从角落舍入的圆弧的宽度。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      double getHeight​()
      以 double精度返回框架矩形的高度。
      double getWidth​()
      以 double精度返回成帧矩形的宽度。
      double getX​()
      返回 double精度的框架矩形左上角的X坐标。
      double getY​()
      返回 double精度的框架矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      void setRoundRect​(double x, double y, double w, double h, double arcw, double arch)
      将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。
      void setRoundRect​(RoundRectangle2D rr)
      将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

      • Methods inherited from class java.awt.geom.RoundRectangle2D

        contains, contains, equals, getPathIterator, hashCode, intersects, setFrame

    • 字段详细信息

      • x

        public double x
        这个 RoundRectangle2D的X坐标。
        从以下版本开始：
        1.2

      • y

        public double y
        这个 RoundRectangle2D的Y坐标。
        从以下版本开始：
        1.2

      • width

        public double width
        该宽度为 RoundRectangle2D 。
        从以下版本开始：
        1.2

      • height

        public double height
        这个高度 RoundRectangle2D 。
        从以下版本开始：
        1.2

      • arcwidth

        public double arcwidth
        从角落圆弧的宽度。
        从以下版本开始：
        1.2

      • archeight

        public double archeight
        从角落圆弧的高度。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Double

        public Double​()
        构造新的 RoundRectangle2D ，初始化为位置（ RoundRectangle2D ），大小（ RoundRectangle2D ）和半径0.0的角弧。
        从以下版本开始：
        1.2

      • Double

        public Double​(double x,
              double y,
              double w,
              double h,
              double arcw,
              double arch)
        构造并初始化一个 RoundRectangle2D从指定 double坐标。
        参数
        x - 新建的 RoundRectangle2D的X坐标
        y - 新建的 RoundRectangle2D的Y坐标
        w - 设置新构建的 RoundRectangle2D
        h - 设置新建的 RoundRectangle2D
        arcw - 用于舍入新构造的角的弧的宽度 RoundRectangle2D
        arch - 弧形高度用于圆形的新构造的角落 RoundRectangle2D
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        以 double精度返回成帧矩形左上角的X坐标。
        Specified by:
        getX在 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        以 double精度返回成帧矩形左上角的Y坐标。
        Specified by:
        getY在 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        返回 double精度的成帧矩形的宽度。
        Specified by:
        getWidth在 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        以 double精度返回框架矩形的高度。
        Specified by:
        getHeight中的 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • getArcWidth

        public double getArcWidth​()
        获取从角落舍入的圆弧的宽度。
        Specified by:
        getArcWidth在 RoundRectangle2D
        结果
        从 RoundRectangle2D角落圆弧的宽度。
        从以下版本开始：
        1.2

      • getArcHeight

        public double getArcHeight​()
        获取圆角圆弧的高度。
        Specified by:
        getArcHeight的 RoundRectangle2D
        结果
        从 RoundRectangle2D的角落圆弧的高度。
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，它不包含任何区域。
        Specified by:
        isEmpty在 RectangularShape
        结果
        true如果RectangularShape是空的; 否则为false 。
        从以下版本开始：
        1.2

      • setRoundRect

        public void setRoundRect​(double x,
                         double y,
                         double w,
                         double h,
                         double arcw,
                         double arch)
        将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。
        Specified by:
        setRoundRect在 RoundRectangle2D
        参数
        x - 设置此 RoundRectangle2D的位置的X坐标
        y - 要设置此位置的Y坐标 RoundRectangle2D
        w - 要设置的宽度 RoundRectangle2D
        h - 要设置这个 RoundRectangle2D的高度
        arcw - 设置此 RoundRectangle2D的弧的 RoundRectangle2D
        arch - 设置 RoundRectangle2D弧的 RoundRectangle2D
        从以下版本开始：
        1.2

      • setRoundRect

        public void setRoundRect​(RoundRectangle2D rr)
        将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。
        重写：
        setRoundRect在 RoundRectangle2D
        参数
        rr - 指定的 RoundRectangle2D
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape高精度和更准确的边界框，比getBounds方法。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界框通常比getBounds方法返回的getBounds更小，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致shape定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在这些点也未被包含在原始shape 。

        如果point是内部shape根据contains(point)方法，那么它必须是内部返回Rectangle2D界限根据对象contains(point)所述的方法bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RoundRectangle2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.geom

Class RoundRectangle2D.Float

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.RoundRectangle2D
        • java.awt.geom.RoundRectangle2D.Float
  • All Implemented Interfaces:
    Shape ， Serializable ， Cloneable
    Enclosing class:
    RoundRectangle2D

    public static class RoundRectangle2D.Float
extends RoundRectangle2D
implements Serializable
    Float类定义了一个具有圆角的矩形，全部在 float指定。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.geom.RoundRectangle2D

        RoundRectangle2D.Double, RoundRectangle2D.Float

    • Field Summary

      Fields
      Modifier and Type Field 描述
      float archeight
      从角落圆弧的高度。
      float arcwidth
      从角落圆弧的宽度。
      float height
      这个高度 RoundRectangle2D 。
      float width
      这个宽度 RoundRectangle2D 。
      float x
      这个 RoundRectangle2D的X坐标。
      float y
      这个 RoundRectangle2D的Y坐标。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​()
      构造新的 RoundRectangle2D ，初始化为位置（ RoundRectangle2D ），大小（ RoundRectangle2D ）和半径为0.0的角弧。
      Float​(float x, float y, float w, float h, float arcw, float arch)
      构造并初始化一个 RoundRectangle2D从指定 float坐标。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double getArcHeight​()
      获取圆角圆弧的高度。
      double getArcWidth​()
      获取从角落舍入的圆弧的宽度。
      Rectangle2D getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      double getHeight​()
      以 double精度返回框架矩形的高度。
      double getWidth​()
      以 double精度返回成帧矩形的宽度。
      double getX​()
      以 double精度返回成帧矩形左上角的X坐标。
      double getY​()
      以 double精度返回框架矩形左上角的Y坐标。
      boolean isEmpty​()
      确定 RectangularShape是否为空。
      void setRoundRect​(double x, double y, double w, double h, double arcw, double arch)
      将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。
      void setRoundRect​(float x, float y, float w, float h, float arcw, float arch)
      将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 float值。
      void setRoundRect​(RoundRectangle2D rr)
      将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.geom.RectangularShape

        clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

      • Methods inherited from class java.awt.geom.RoundRectangle2D

        contains, contains, equals, getPathIterator, hashCode, intersects, setFrame

    • 字段详细信息

      • x

        public float x
        这个 RoundRectangle2D的X坐标。
        从以下版本开始：
        1.2

      • y

        public float y
        这个Y坐标 RoundRectangle2D 。
        从以下版本开始：
        1.2

      • width

        public float width
        这个宽度 RoundRectangle2D 。
        从以下版本开始：
        1.2

      • height

        public float height
        这个高度这个 RoundRectangle2D 。
        从以下版本开始：
        1.2

      • arcwidth

        public float arcwidth
        从角落圆弧的宽度。
        从以下版本开始：
        1.2

      • archeight

        public float archeight
        从角落圆弧的高度。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • Float

        public Float​()
        构造新的 RoundRectangle2D ，初始化为位置（ RoundRectangle2D ），大小（ RoundRectangle2D ）和半径为0.0的角弧。
        从以下版本开始：
        1.2

      • Float

        public Float​(float x,
             float y,
             float w,
             float h,
             float arcw,
             float arch)
        构造并初始化一个 RoundRectangle2D从指定 float坐标。
        参数
        x - 新建的 RoundRectangle2D的X坐标
        y - 新建的 RoundRectangle2D的Y坐标
        w - 设置新构建的 RoundRectangle2D
        h - 设置新建的 RoundRectangle2D
        arcw - 弧形的宽度，用于围绕新构造的角落 RoundRectangle2D
        arch - 弧形高度用于围绕新构造的角落 RoundRectangle2D
        从以下版本开始：
        1.2

    • 方法详细信息

      • getX

        public double getX​()
        以 double精度返回成帧矩形左上角的X坐标。
        Specified by:
        getX在 RectangularShape
        结果
        框架矩形左上角的X坐标。
        从以下版本开始：
        1.2

      • getY

        public double getY​()
        以 double精度返回框架矩形左上角的Y坐标。
        Specified by:
        getY在 RectangularShape
        结果
        框架矩形左上角的Y坐标。
        从以下版本开始：
        1.2

      • getWidth

        public double getWidth​()
        以 double精度返回框架矩形的宽度。
        Specified by:
        getWidth在 RectangularShape
        结果
        框架矩形的宽度。
        从以下版本开始：
        1.2

      • getHeight

        public double getHeight​()
        返回 double精度的成帧矩形的高度。
        Specified by:
        getHeight中的 RectangularShape
        结果
        框架矩形的高度。
        从以下版本开始：
        1.2

      • getArcWidth

        public double getArcWidth​()
        获取从角落舍入的圆弧的宽度。
        Specified by:
        getArcWidth在 RoundRectangle2D
        结果
        从 RoundRectangle2D角落圆弧的宽度。
        从以下版本开始：
        1.2

      • getArcHeight

        public double getArcHeight​()
        获取圆角圆弧的高度。
        Specified by:
        getArcHeight在 RoundRectangle2D
        结果
        从 RoundRectangle2D的角落圆弧的高度。
        从以下版本开始：
        1.2

      • isEmpty

        public boolean isEmpty​()
        确定RectangularShape是否为空。 当RectangularShape为空时，不包含任何区域。
        Specified by:
        isEmpty类 RectangularShape
        结果
        true如果RectangularShape是空的; 否则为false 。
        从以下版本开始：
        1.2

      • setRoundRect

        public void setRoundRect​(float x,
                         float y,
                         float w,
                         float h,
                         float arcw,
                         float arch)
        将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 float值。
        参数
        x - 要设置此 RoundRectangle2D的位置的X坐标
        y - 设置这个 RoundRectangle2D的位置的Y坐标
        w - 要设置的宽度 RoundRectangle2D
        h - 要设置这个 RoundRectangle2D的高度
        arcw - 设置此 RoundRectangle2D弧的 RoundRectangle2D
        arch - 设置此 RoundRectangle2D弧的 RoundRectangle2D
        从以下版本开始：
        1.2

      • setRoundRect

        public void setRoundRect​(double x,
                         double y,
                         double w,
                         double h,
                         double arcw,
                         double arch)
        将此 RoundRectangle2D的位置，大小和拐角半径 RoundRectangle2D为指定的 double值。
        Specified by:
        setRoundRect在 RoundRectangle2D
        参数
        x - 要设置此 RoundRectangle2D的位置的X坐标
        y - 设置此 RoundRectangle2D位置的Y坐标
        w - 设置这个 RoundRectangle2D的宽度
        h - 设置这个 RoundRectangle2D的高度
        arcw - 设置此 RoundRectangle2D弧的 RoundRectangle2D
        arch - 设置此 RoundRectangle2D弧的 RoundRectangle2D
        从以下版本开始：
        1.2

      • setRoundRect

        public void setRoundRect​(RoundRectangle2D rr)
        将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。
        重写：
        setRoundRect在 RoundRectangle2D
        参数
        rr - 指定的 RoundRectangle2D
        从以下版本开始：
        1.2

      • getBounds2D

        public Rectangle2D getBounds2D​()
        返回Shape比getBounds方法更高精度和更准确的边界框。 请注意，不保证返回的Rectangle2D是封闭的最小边界框Shape ，只表示Shape完全在指定的范围内Rectangle2D 。 此方法返回的边界通常比getBounds方法返回的getBounds更getBounds ，因为溢出问题永远不会失败，因为返回值可以是使用双精度值存储维度的Rectangle2D的实例。

        请注意， definition of insideness可能导致bounds对象定义轮廓上的shape不能被视为包含在返回的bounds对象中的情况，但仅在原始shape中也未考虑这些点的情况下。

        如果一个point是在shape按contains(point)方法，那么它必须在Rectangle2D范围内的对象中，根据contains(point)方法的bounds 。 特别：

        shape.contains(p)需要bounds.contains(p)

        如果一个point不在shape ，那么它可能仍然包含在bounds对象中：

        bounds.contains(p)并不表示shape.contains(p)

        Specified by:
        getBounds2D在接口 Shape
        结果
        的实例 Rectangle2D那是一个高精度边界框 Shape 。
        从以下版本开始：
        1.2
        另请参见：
        Shape.getBounds()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.geom (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.geom

  • Packages that use java.awt.geom
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
  • Classes in java.awt.geom used by java.awt
    Class 描述
    AffineTransform
    AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“直线度”和“平行度”。
    Dimension2D
    Dimension2D类是封装宽度和高度维度。
    PathIterator
    PathIterator接口为实现Shape接口的对象提供了通过允许调用者一次检索该边界的路径来返回其边界的几何的对象的机制。
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
    RectangularShape
    RectangularShape是几何由矩形框架定义的Shape个对象的基类。
  • Classes in java.awt.geom used by java.awt.font
    Class 描述
    AffineTransform
    AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“直线度”和“平行度”。
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
  • Classes in java.awt.geom used by java.awt.geom
    Class 描述
    AffineTransform
    AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“直线度”和“平行度”。
    Arc2D
    Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或 PIE ）。
    Area
    一个 Area对象存储和操纵二维空间的封闭区域的独立于分辨率的描述。
    CubicCurve2D
    CubicCurve2D类定义了 (x,y)坐标空间中的三次参数曲线段。
    Dimension2D
    Dimension2D类是封装宽度和高度维度。
    Ellipse2D
    Ellipse2D类描述了由框架矩形定义的椭圆。
    Line2D
    此 Line2D表示 (x,y)坐标空间中的线段。
    NoninvertibleTransformException
    NoninvertibleTransformException类表示如果执行需要AffineTransform对象的相反的操作但AffineTransform处于非可逆状态的抛出异常。
    Path2D
    Path2D类提供了一个简单而又灵活的形状，表示任意的几何路径。
    Path2D.Float
    Float类定义了一个几何路径，坐标存储在单精度浮点中。
    PathIterator
    PathIterator接口提供了实现Shape接口的对象的机制，通过允许调用者一次检索该边界的路径来返回其边界的几何形状。
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    QuadCurve2D
    QuadCurve2D类定义了 (x,y)坐标空间中的二次参数曲线段。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
    RectangularShape
    RectangularShape是几何由矩形框架定义的Shape个对象的基类。
    RoundRectangle2D
    RoundRectangle2D类定义了一个矩形，其圆角由位置 (x,y)定义，尺寸为 (w x h) ，以及 (w x h)的宽度和高度。
  • Classes in java.awt.geom used by java.awt.image
    Class 描述
    AffineTransform
    AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“平直度”和“平行度”。
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
  • Classes in java.awt.geom used by java.awt.image.renderable
    Class 描述
    AffineTransform
    AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“平直度”和“平行度”。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
  • Classes in java.awt.geom used by javax.swing.plaf
    Class 描述
    Dimension2D
    Dimension2D类是封装宽度和高度维度。
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
  • Classes in java.awt.geom used by javax.swing.plaf.basic
    Class 描述
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
    RectangularShape
    RectangularShape是几何由矩形框架定义的Shape个对象的基类。
  • Classes in java.awt.geom used by javax.swing.plaf.multi
    Class 描述
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
  • Classes in java.awt.geom used by javax.swing.text
    Class 描述
    Point2D
    Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
    Rectangle2D
    Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
    RectangularShape
    RectangularShape是几何由矩形框架定义的Shape个对象的基类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.AffineTransform (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.AffineTransform

  • Packages that use AffineTransform
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of AffineTransform in java.awt

      Methods in java.awt that return AffineTransform
      Modifier and Type 方法 描述
      abstract AffineTransform GraphicsConfiguration.getDefaultTransform​()
      返回默认AffineTransform这个GraphicsConfiguration 。
      abstract AffineTransform GraphicsConfiguration.getNormalizingTransform​()
      返回一个 AffineTransform可以与默认级联 AffineTransform一个的 GraphicsConfiguration ，使得单元72在用户空间等于设备空间的1英寸。
      AffineTransform Font.getTransform​()
      返回与此 Font关联的转换的副本。
      abstract AffineTransform Graphics2D.getTransform​()
      返回 Graphics2D上下文中当前 Transform的 Graphics2D 。
      AffineTransform MultipleGradientPaint.getTransform​()
      返回应用于渐变的变换的副本。
      Methods in java.awt with parameters of type AffineTransform
      Modifier and Type 方法 描述
      PaintContext Color.createContext​(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成纯色字段模式的PaintContext 。
      PaintContext GradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext LinearGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext Paint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成颜色模式的PaintContext 。
      PaintContext RadialGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成圆形径向颜色渐变模式的PaintContext 。
      PaintContext TexturePaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成平铺图像模式的PaintContext 。
      Font Font.deriveFont​(int style, AffineTransform trans)
      通过复制这个 Font对象并应用新的样式和变换来创建一个新的 Font对象。
      Font Font.deriveFont​(AffineTransform trans)
      通过复制当前的 Font对象并应用一个新的变换来创建一个新的 Font对象。
      abstract boolean Graphics2D.drawImage​(Image img, AffineTransform xform, ImageObserver obs)
      渲染图像，在绘制之前将图像空间的变换应用到用户空间中。
      abstract void Graphics2D.drawRenderableImage​(RenderableImage img, AffineTransform xform)
      渲染一个RenderableImage ，在绘制之前将图像空间的变换应用到用户空间中。
      abstract void Graphics2D.drawRenderedImage​(RenderedImage img, AffineTransform xform)
      渲染RenderedImage ，在绘制之前将图像空间的变换应用到用户空间中。
      PathIterator Polygon.getPathIterator​(AffineTransform at)
      返回一个迭代器对象，它沿着这个 Polygon的边界进行迭代，并提供对这个 Polygon的轮廓几何的访问。
      PathIterator Polygon.getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代器对象，它沿着 Shape的边界进行迭代，并提供对 Shape轮廓几何的访问。
      PathIterator Shape.getPathIterator​(AffineTransform at)
      返回一个沿 Shape边界迭代的迭代器对象，并提供对 Shape大纲的几何形状的访问。
      PathIterator Shape.getPathIterator​(AffineTransform at, double flatness)
      返回一个沿 Shape边界进行迭代的迭代器对象，并提供对 Shape外形几何体的扁平化视图的访问。
      abstract void Graphics2D.setTransform​(AffineTransform Tx)
      覆盖 Graphics2D上下文中的变换。
      abstract void Graphics2D.transform​(AffineTransform Tx)
      根据最后指定的规则首先应用的规则，组合 AffineTransform对象 Transform在此 Graphics2D 。
      Constructors in java.awt with parameters of type AffineTransform
      Constructor 描述
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 LinearGradientPaint 。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 RadialGradientPaint 。

    • Uses of AffineTransform in java.awt.font

      Methods in java.awt.font that return AffineTransform
      Modifier and Type 方法 描述
      abstract AffineTransform GlyphVector.getGlyphTransform​(int glyphIndex)
      返回此 GlyphVector指定字形的变换。
      AffineTransform FontRenderContext.getTransform​()
      获取用于将排印点缩放到像素的变换（ FontRenderContext 。
      AffineTransform TransformAttribute.getTransform​()
      返回包装转换的副本。
      Methods in java.awt.font with parameters of type AffineTransform
      Modifier and Type 方法 描述
      Shape GraphicAttribute.getOutline​(AffineTransform tx)
      返回一个Shape ，表示该区域GraphicAttribute呈现。
      Shape ShapeGraphicAttribute.getOutline​(AffineTransform tx)
      返回一个Shape ，表示该区域ShapeGraphicAttribute呈现。
      Shape TextLayout.getOutline​(AffineTransform tx)
      返回一个表示 Shape轮廓的 TextLayout 。
      abstract void GlyphVector.setGlyphTransform​(int glyphIndex, AffineTransform newTX)
      设置此 GlyphVector内指定字形的变换。
      Constructors in java.awt.font with parameters of type AffineTransform
      Constructor 描述
      FontRenderContext​(AffineTransform tx, boolean isAntiAliased, boolean usesFractionalMetrics)
      从可选的AffineTransform和两个boolean值构造一个FontRenderContext对象，以确定新构造的对象是否具有抗锯齿或分数指标。
      FontRenderContext​(AffineTransform tx, Object aaHint, Object fmHint)
      从可选的AffineTransform和两个Object值构造一个FontRenderContext对象，以确定新构建的对象是否具有抗锯齿或小数度量。
      TransformAttribute​(AffineTransform transform)
      包装指定的变换。

    • Uses of AffineTransform in java.awt.geom

      Methods in java.awt.geom that return AffineTransform
      Modifier and Type 方法 描述
      AffineTransform AffineTransform.createInverse​()
      返回表示逆变换的 AffineTransform对象。
      static AffineTransform AffineTransform.getQuadrantRotateInstance​(int numquadrants)
      返回一个将坐标旋转指定数量的象限的变换。
      static AffineTransform AffineTransform.getQuadrantRotateInstance​(int numquadrants, double anchorx, double anchory)
      返回一个转换，该变换将坐标指定指定锚点周围的指定数量的象限旋转。
      static AffineTransform AffineTransform.getRotateInstance​(double theta)
      返回表示旋转变换的变换。
      static AffineTransform AffineTransform.getRotateInstance​(double vecx, double vecy)
      返回一个根据旋转矢量旋转坐标的变换。
      static AffineTransform AffineTransform.getRotateInstance​(double theta, double anchorx, double anchory)
      返回一个在锚点周围旋转坐标的变换。
      static AffineTransform AffineTransform.getRotateInstance​(double vecx, double vecy, double anchorx, double anchory)
      返回一个根据旋转向量旋转锚点周围的坐标点的变换。
      static AffineTransform AffineTransform.getScaleInstance​(double sx, double sy)
      返回表示缩放变换的变换。
      static AffineTransform AffineTransform.getShearInstance​(double shx, double shy)
      返回代表剪切变换的变换。
      static AffineTransform AffineTransform.getTranslateInstance​(double tx, double ty)
      返回表示平移变换的变换。
      Methods in java.awt.geom with parameters of type AffineTransform
      Modifier and Type 方法 描述
      void AffineTransform.concatenate​(AffineTransform Tx)
      将 AffineTransform Tx连接到这个 AffineTransform Cx中是最常用的方式，以提供映射到前一个用户空间的新用户空间 Tx 。
      Area Area.createTransformedArea​(AffineTransform t)
      创建一个新的 Area对象，该对象包含与指定的 AffineTransform转换的 Area相同的几何。
      Shape Path2D.createTransformedShape​(AffineTransform at)
      返回一个新的 Shape代表这个 Path2D的转换版本。
      PathIterator Arc2D.getPathIterator​(AffineTransform at)
      返回定义圆弧边界的迭代对象。
      PathIterator Area.getPathIterator​(AffineTransform at)
      为此Area对象的轮廓创建一个PathIterator 。
      PathIterator Area.getPathIterator​(AffineTransform at, double flatness)
      为此 Area对象的扁平轮廓创建一个 PathIterator 。
      PathIterator CubicCurve2D.getPathIterator​(AffineTransform at)
      返回定义形状边界的迭代对象。
      PathIterator CubicCurve2D.getPathIterator​(AffineTransform at, double flatness)
      返回定义展平形状边界的迭代对象。
      PathIterator Ellipse2D.getPathIterator​(AffineTransform at)
      返回定义 Ellipse2D边界的迭代对象。
      PathIterator Line2D.getPathIterator​(AffineTransform at)
      返回一个定义 Line2D边界的迭代对象。
      PathIterator Line2D.getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代对象，该对象定义了此扁平化的边界 Line2D 。
      PathIterator Path2D.Double.getPathIterator​(AffineTransform at)
      返回一个迭代器对象，它可以沿着 Shape边界进行迭代，并提供对 Shape大纲的几何形状的访问。
      PathIterator Path2D.Float.getPathIterator​(AffineTransform at)
      返回一个迭代器对象，它可以沿 Shape边界进行迭代，并提供对 Shape轮廓几何的访问。
      PathIterator Path2D.getPathIterator​(AffineTransform at, double flatness)
      返回一个沿 Shape边界进行迭代的迭代器对象，并提供对 Shape轮廓几何体的扁平化视图的访问。
      PathIterator QuadCurve2D.getPathIterator​(AffineTransform at)
      返回一个定义 QuadCurve2D形状边界的迭代对象。
      PathIterator QuadCurve2D.getPathIterator​(AffineTransform at, double flatness)
      返回定义此 QuadCurve2D的展平形状边界的迭代对象。
      PathIterator Rectangle2D.getPathIterator​(AffineTransform at)
      返回定义 Rectangle2D边界的迭代对象。
      PathIterator Rectangle2D.getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代对象，该对象定义了展平 Rectangle2D的边界。
      PathIterator RectangularShape.getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代器对象，它沿 Shape对象的边界进行迭代，并提供对 Shape对象的几何体轮廓的平坦化视图的访问。
      PathIterator RoundRectangle2D.getPathIterator​(AffineTransform at)
      返回定义 RoundRectangle2D边界的迭代对象。
      void AffineTransform.preConcatenate​(AffineTransform Tx)
      将 AffineTransform Tx连接到这个 AffineTransform Cx中，以较不常用的方式使 Tx修改相对于绝对像素空间而不是相对于现有用户空间的坐标变换。
      void AffineTransform.setTransform​(AffineTransform Tx)
      将此变换设置为指定的 AffineTransform对象中的变换副本。
      void Area.transform​(AffineTransform t)
      使用指定的AffineTransform转换Area的几何。
      void Path2D.Double.transform​(AffineTransform at)
      使用指定的AffineTransform转换此路径的几何。
      void Path2D.Float.transform​(AffineTransform at)
      使用指定的AffineTransform转换此路径的几何。
      abstract void Path2D.transform​(AffineTransform at)
      使用指定的AffineTransform转换此路径的几何。
      Constructors in java.awt.geom with parameters of type AffineTransform
      Constructor 描述
      AffineTransform​(AffineTransform Tx)
      构造一个新的 AffineTransform ，它是一个指定的 AffineTransform对象的副本。
      Double​(Shape s, AffineTransform at)
      构造一个新的单精度Path2D从任意物体Shape对象，由一个转化AffineTransform对象。
      Float​(Shape s, AffineTransform at)
      构造一个新的单精度Path2D从任意物体Shape对象，由一个转化AffineTransform对象。

    • Uses of AffineTransform in java.awt.image

      Methods in java.awt.image that return AffineTransform
      Modifier and Type 方法 描述
      AffineTransform AffineTransformOp.getTransform​()
      返回此变换操作使用的仿射变换。
      Constructors in java.awt.image with parameters of type AffineTransform
      Constructor 描述
      AffineTransformOp​(AffineTransform xform, int interpolationType)
      构造一个 AffineTransformOp给出仿射变换和插值类型。
      AffineTransformOp​(AffineTransform xform, RenderingHints hints)
      构造一个 AffineTransformOp给出一个仿射变换。

    • Uses of AffineTransform in java.awt.image.renderable

      Methods in java.awt.image.renderable that return AffineTransform
      Modifier and Type 方法 描述
      AffineTransform RenderContext.getTransform​()
      获取当前的用户到设备的AffineTransform。
      Methods in java.awt.image.renderable with parameters of type AffineTransform
      Modifier and Type 方法 描述
      void RenderContext.concatenateTransform​(AffineTransform modTransform)
      通过附加另一个转换来修改当前的用户到设备的转换。
      void RenderContext.concetenateTransform​(AffineTransform modTransform)
      已过时。
      代之以concatenateTransform(AffineTransform) 。
      void RenderContext.preConcatenateTransform​(AffineTransform modTransform)
      通过前置另一个变换来修改当前的用户到设备的变换。
      void RenderContext.preConcetenateTransform​(AffineTransform modTransform)
      已过时。
      替换为preConcatenateTransform(AffineTransform) 。
      void RenderContext.setTransform​(AffineTransform newTransform)
      将RenderContext中包含的当前用户到设备的AffineTransform设置为给定的转换。
      Constructors in java.awt.image.renderable with parameters of type AffineTransform
      Constructor 描述
      RenderContext​(AffineTransform usr2dev)
      构造具有给定变换的RenderContext。
      RenderContext​(AffineTransform usr2dev, RenderingHints hints)
      构造一个具有给定变换和渲染提示的RenderContext。
      RenderContext​(AffineTransform usr2dev, Shape aoi)
      构造一个具有给定变换和感兴趣区域的RenderContext。
      RenderContext​(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
      构造具有给定变换的RenderContext。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Arc2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Arc2D

  • Packages that use Arc2D
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of Arc2D in java.awt.geom

      Subclasses of Arc2D in java.awt.geom
      Modifier and Type Class 描述
      static class  Arc2D.Double
      此类定义了 double精度中指定的弧。
      static class  Arc2D.Float
      此类定义了 float精度中指定的弧。
      Methods in java.awt.geom with parameters of type Arc2D
      Modifier and Type 方法 描述
      void Arc2D.setArc​(Arc2D a)
      将此弧设置为与指定弧相同。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Arc2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Arc2D.Double

No usage of java.awt.geom.Arc2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Arc2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Arc2D.Float

No usage of java.awt.geom.Arc2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Area (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Area

  • Packages that use Area
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of Area in java.awt.geom

      Methods in java.awt.geom that return Area
      Modifier and Type 方法 描述
      Area Area.createTransformedArea​(AffineTransform t)
      创建一个新的 Area对象，其中包含与指定的 AffineTransform转换的 Area相同的几何。
      Methods in java.awt.geom with parameters of type Area
      Modifier and Type 方法 描述
      void Area.add​(Area rhs)
      添加指定的形状 Area这种形状 Area 。
      boolean Area.equals​(Area other)
      测试两个 Area对象的几何是否相等。
      void Area.exclusiveOr​(Area rhs)
      将此 Area的形状设置为其当前形状的组合面积和指定的 Area的形状，减去其交点。
      void Area.intersect​(Area rhs)
      将此 Area的形状设置为其当前形状和指定的形状 Area 。
      void Area.subtract​(Area rhs)
      Subtracts the shape of the specified Area from the shape of this Area.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.CubicCurve2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.CubicCurve2D

  • Packages that use CubicCurve2D
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of CubicCurve2D in java.awt.geom

      Subclasses of CubicCurve2D in java.awt.geom
      Modifier and Type Class 描述
      static class  CubicCurve2D.Double
      用 double坐标指定的三次参数曲线段。
      static class  CubicCurve2D.Float
      用 float坐标指定的三次参数曲线段。
      Methods in java.awt.geom with parameters of type CubicCurve2D
      Modifier and Type 方法 描述
      void CubicCurve2D.setCurve​(CubicCurve2D c)
      将该曲线的终点和控制点的位置设置为与指定的 CubicCurve2D 。
      void CubicCurve2D.subdivide​(CubicCurve2D left, CubicCurve2D right)
      细分此三次曲线并将所得到的两个细分曲线存储在左曲线和右曲线参数中。
      static void CubicCurve2D.subdivide​(CubicCurve2D src, CubicCurve2D left, CubicCurve2D right)
      细分由 src参数指定的三次曲线，并将所得到的两个细分曲线存储到 left和 right曲线参数中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.CubicCurve2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.CubicCurve2D.Double

No usage of java.awt.geom.CubicCurve2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.CubicCurve2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.CubicCurve2D.Float

No usage of java.awt.geom.CubicCurve2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Dimension2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Dimension2D

  • Packages that use Dimension2D
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。

    • Uses of Dimension2D in java.awt

      Subclasses of Dimension2D in java.awt
      Modifier and Type Class 描述
      class  Dimension
      Dimension类封装单个对象中组件的宽度和高度（以整数精度）。

    • Uses of Dimension2D in java.awt.geom

      Methods in java.awt.geom with parameters of type Dimension2D
      Modifier and Type 方法 描述
      void Arc2D.setArc​(Point2D loc, Dimension2D size, double angSt, double angExt, int closure)
      将该弧的位置，大小，角度范围和闭合类型设置为指定的值。
      void RectangularShape.setFrame​(Point2D loc, Dimension2D size)
      将此Shape的框架矩形的位置和大小分别设置为Point2D和Dimension2D 。
      void Dimension2D.setSize​(Dimension2D d)
      设置此 Dimension2D对象的大小以匹配指定的大小。

    • Uses of Dimension2D in javax.swing.plaf

      Subclasses of Dimension2D in javax.swing.plaf
      Modifier and Type Class 描述
      class  DimensionUIResource
      Dimension的子类实现 UIResource 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Ellipse2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Ellipse2D

  • Packages that use Ellipse2D
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of Ellipse2D in java.awt.geom

      Subclasses of Ellipse2D in java.awt.geom
      Modifier and Type Class 描述
      static class  Ellipse2D.Double
      Double类定义了 double精度中指定的椭圆。
      static class  Ellipse2D.Float
      Float类定义了 float精度中指定的椭圆。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Ellipse2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Ellipse2D.Double

No usage of java.awt.geom.Ellipse2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Ellipse2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Ellipse2D.Float

No usage of java.awt.geom.Ellipse2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.FlatteningPathIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.FlatteningPathIterator

No usage of java.awt.geom.FlatteningPathIterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.GeneralPath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.GeneralPath

No usage of java.awt.geom.GeneralPath
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.IllegalPathStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.IllegalPathStateException

No usage of java.awt.geom.IllegalPathStateException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Line2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Line2D

  • Packages that use Line2D
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of Line2D in java.awt.geom

      Subclasses of Line2D in java.awt.geom
      Modifier and Type Class 描述
      static class  Line2D.Double
      用双坐标指定的线段。
      static class  Line2D.Float
      用浮点坐标指定的线段。
      Methods in java.awt.geom with parameters of type Line2D
      Modifier and Type 方法 描述
      boolean Line2D.intersectsLine​(Line2D l)
      测试指定的线段是否与此线段相交。
      boolean Rectangle2D.intersectsLine​(Line2D l)
      测试指定的线段是否与此 Rectangle2D的内部相交。
      void Line2D.setLine​(Line2D l)
      将此 Line2D的终点的位置设置为与指定的 Line2D 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Line2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Line2D.Double

No usage of java.awt.geom.Line2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Line2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Line2D.Float

No usage of java.awt.geom.Line2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.NoninvertibleTransformException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.NoninvertibleTransformException

  • Packages that use NoninvertibleTransformException
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of NoninvertibleTransformException in java.awt.geom

      Methods in java.awt.geom that throw NoninvertibleTransformException
      Modifier and Type 方法 描述
      AffineTransform AffineTransform.createInverse​()
      返回表示逆变换的 AffineTransform对象。
      void AffineTransform.inverseTransform​(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts)
      通过此变换反向转换双精度坐标数组。
      Point2D AffineTransform.inverseTransform​(Point2D ptSrc, Point2D ptDst)
      反转换指定的 ptSrc并将结果存储在 ptDst 。
      void AffineTransform.invert​()
      将此变换设置为本身的倒数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Path2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Path2D

  • Packages that use Path2D
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of Path2D in java.awt.geom

      Subclasses of Path2D in java.awt.geom
      Modifier and Type Class 描述
      class  GeneralPath
      GeneralPath类代表由直线构成的几何路径，以及二次和立方（Bézier）曲线。
      static class  Path2D.Double
      Double类定义了一个几何路径，坐标存储在双精度浮点中。
      static class  Path2D.Float
      Float类定义了具有存储在单精度浮点中的坐标的几何路径。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Path2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Path2D.Double

No usage of java.awt.geom.Path2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Path2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Path2D.Float

  • Packages that use Path2D.Float
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of Path2D.Float in java.awt.geom

      Subclasses of Path2D.Float in java.awt.geom
      Modifier and Type Class 描述
      class  GeneralPath
      GeneralPath类代表由直线构成的几何路径，以及二次和立方（Bézier）曲线。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Point2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Point2D

  • Packages that use Point2D
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Point2D in java.awt

      Subclasses of Point2D in java.awt
      Modifier and Type Class 描述
      class  Point
      表示 (x,y)坐标空间中的位置的点，以整数精度指定。
      Methods in java.awt that return Point2D
      Modifier and Type 方法 描述
      Point2D RadialGradientPaint.getCenterPoint​()
      返回径向渐变中心点的副本。
      Point2D LinearGradientPaint.getEndPoint​()
      返回渐变轴终点的副本。
      Point2D RadialGradientPaint.getFocusPoint​()
      返回径向渐变焦点的副本。
      Point2D GradientPaint.getPoint1​()
      返回锚点第一个颜色的点P1的副本。
      Point2D GradientPaint.getPoint2​()
      返回锚定第二种颜色的点P2的副本。
      Point2D LinearGradientPaint.getStartPoint​()
      返回渐变轴起始点的副本。
      Methods in java.awt with parameters of type Point2D
      Modifier and Type 方法 描述
      boolean Polygon.contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean Shape.contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      Constructors in java.awt with parameters of type Point2D
      Constructor 描述
      GradientPaint​(Point2D pt1, Color color1, Point2D pt2, Color color2)
      构造一个简单的无环 GradientPaint对象。
      GradientPaint​(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
      根据 boolean参数构建循环或非循环 GradientPaint对象。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors)
      构造一个 LinearGradientPaint ，默认为 NO_CYCLE重复方法和 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 LinearGradientPaint ，默认为 SRGB颜色空间。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 LinearGradientPaint 。
      RadialGradientPaint​(Point2D center, float radius, float[] fractions, Color[] colors)
      构造一个 RadialGradientPaint ，具有默认的 NO_CYCLE重复方法和 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint ，使用默认的 SRGB颜色空间，以中心为焦点。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint具有默认 SRGB色彩空间。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 RadialGradientPaint 。

    • Uses of Point2D in java.awt.font

      Methods in java.awt.font that return Point2D
      Modifier and Type 方法 描述
      abstract Point2D GlyphVector.getGlyphPosition​(int glyphIndex)
      返回指定字形相对于该 GlyphVector的原点的 GlyphVector 。
      Methods in java.awt.font with parameters of type Point2D
      Modifier and Type 方法 描述
      void TextLayout.hitToPoint​(TextHitInfo hit, Point2D point)
      将命中转换为标准坐标中的一个点。
      abstract void LayoutPath.pathToPoint​(Point2D location, boolean preceding, Point2D point)
      将相对于路径的位置转换为用户坐标中的某个点。
      abstract boolean LayoutPath.pointToPath​(Point2D point, Point2D location)
      将用户空间中的点转换为相对于路径的位置。
      abstract void GlyphVector.setGlyphPosition​(int glyphIndex, Point2D newPos)
      设置此 GlyphVector指定字形的位置。

    • Uses of Point2D in java.awt.geom

      Subclasses of Point2D in java.awt.geom
      Modifier and Type Class 描述
      static class  Point2D.Double
      Double类定义了 double精度中指定的点。
      static class  Point2D.Float
      Float类定义了浮点精度指定的点。
      Methods in java.awt.geom that return Point2D
      Modifier and Type 方法 描述
      Point2D AffineTransform.deltaTransform​(Point2D ptSrc, Point2D ptDst)
      转换 ptSrc指定的相对距离向量， ptSrc结果存储在 ptDst 。
      Point2D CubicCurve2D.Double.getCtrlP1​()
      返回第一个控制点。
      Point2D CubicCurve2D.Float.getCtrlP1​()
      返回第一个控制点。
      abstract Point2D CubicCurve2D.getCtrlP1​()
      返回第一个控制点。
      Point2D CubicCurve2D.Double.getCtrlP2​()
      返回第二个控制点。
      Point2D CubicCurve2D.Float.getCtrlP2​()
      返回第二个控制点。
      abstract Point2D CubicCurve2D.getCtrlP2​()
      返回第二个控制点。
      Point2D QuadCurve2D.Double.getCtrlPt​()
      返回控制点。
      Point2D QuadCurve2D.Float.getCtrlPt​()
      返回控制点。
      abstract Point2D QuadCurve2D.getCtrlPt​()
      返回控制点。
      Point2D Path2D.getCurrentPoint​()
      返回最近添加到路径末尾的坐标为Point2D对象。
      Point2D Arc2D.getEndPoint​()
      返回圆弧的终点。
      Point2D CubicCurve2D.Double.getP1​()
      返回起始点。
      Point2D CubicCurve2D.Float.getP1​()
      返回起始点。
      abstract Point2D CubicCurve2D.getP1​()
      返回起始点。
      Point2D Line2D.Double.getP1​()
      返回开始 Point2D如此 Line2D 。
      Point2D Line2D.Float.getP1​()
      返回开始 Point2D如此 Line2D 。
      abstract Point2D Line2D.getP1​()
      返回开始 Point2D如此 Line2D 。
      Point2D QuadCurve2D.Double.getP1​()
      返回起始点。
      Point2D QuadCurve2D.Float.getP1​()
      返回起始点。
      abstract Point2D QuadCurve2D.getP1​()
      返回起始点。
      Point2D CubicCurve2D.Double.getP2​()
      返回终点。
      Point2D CubicCurve2D.Float.getP2​()
      返回终点。
      abstract Point2D CubicCurve2D.getP2​()
      返回终点。
      Point2D Line2D.Double.getP2​()
      返回结束 Point2D如此 Line2D 。
      Point2D Line2D.Float.getP2​()
      返回 Point2D的结尾 Line2D 。
      abstract Point2D Line2D.getP2​()
      返回结束 Point2D如此 Line2D 。
      Point2D QuadCurve2D.Double.getP2​()
      返回终点。
      Point2D QuadCurve2D.Float.getP2​()
      返回终点。
      abstract Point2D QuadCurve2D.getP2​()
      返回终点。
      Point2D Arc2D.getStartPoint​()
      返回圆弧的起始点。
      Point2D AffineTransform.inverseTransform​(Point2D ptSrc, Point2D ptDst)
      反转换指定的 ptSrc ，并将结果存储在 ptDst 。
      Point2D AffineTransform.transform​(Point2D ptSrc, Point2D ptDst)
      转换指定的 ptSrc并将结果存储在 ptDst 。
      Methods in java.awt.geom with parameters of type Point2D
      Modifier and Type 方法 描述
      void Rectangle2D.add​(Point2D pt)
      将 Point2D对象 pt添加到此 Rectangle2D 。
      boolean Area.contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean CubicCurve2D.contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean Line2D.contains​(Point2D p)
      测试一个给定的 Point2D是否在这个 Line2D的边界内。
      static boolean Path2D.contains​(PathIterator pi, Point2D p)
      测试指定Point2D是指定的封闭边界内PathIterator 。
      boolean Path2D.contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean QuadCurve2D.contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      boolean RectangularShape.contains​(Point2D p)
      测试指定Point2D是的边界内Shape ，如所描述的definition of insideness 。
      Point2D AffineTransform.deltaTransform​(Point2D ptSrc, Point2D ptDst)
      转换 ptSrc指定的相对距离矢量， ptSrc结果存储在 ptDst 。
      double Point2D.distance​(Point2D pt)
      返回从该 Point2D到指定的 Point2D的距离。
      double Point2D.distanceSq​(Point2D pt)
      返回从该 Point2D到指定的 Point2D的距离的平方。
      Point2D AffineTransform.inverseTransform​(Point2D ptSrc, Point2D ptDst)
      反向转换指定的 ptSrc并将结果存储在 ptDst 。
      int Rectangle2D.outcode​(Point2D p)
      确定指定的Point2D相对于该Rectangle2D 。
      double Line2D.ptLineDist​(Point2D pt)
      返回从 Point2D到此行的距离。
      double Line2D.ptLineDistSq​(Point2D pt)
      返回从指定的 Point2D到此行的距离的平方。
      double Line2D.ptSegDist​(Point2D pt)
      返回从 Point2D到此线段的距离。
      double Line2D.ptSegDistSq​(Point2D pt)
      返回从 Point2D到此线段的距离的平方。
      int Line2D.relativeCCW​(Point2D p)
      返回一个关于指定的 Point2D相对于该线段所在位置的指示符。
      void Arc2D.setAngles​(Point2D p1, Point2D p2)
      使用两点设置此弧的起始角度和角度范围。
      void Arc2D.setAngleStart​(Point2D p)
      将该弧的起始角度设置为指定点相对于该弧的中心定义的角度。
      void Arc2D.setArc​(Point2D loc, Dimension2D size, double angSt, double angExt, int closure)
      将该弧的位置，大小，角度范围和闭合类型设置为指定的值。
      void Arc2D.setArcByTangent​(Point2D p1, Point2D p2, Point2D p3, double radius)
      将该弧的位置，边界和角度范围设置为指定的值。
      void CubicCurve2D.setCurve​(Point2D[] pts, int offset)
      将此曲线的终点和控制点的位置设置为指定数组中指定偏移量处的 Point2D对象的坐标。
      void CubicCurve2D.setCurve​(Point2D p1, Point2D cp1, Point2D cp2, Point2D p2)
      将该曲线的终点和控制点的位置设置为指定的 Point2D坐标。
      void QuadCurve2D.setCurve​(Point2D[] pts, int offset)
      将此 QuadCurve2D的终点和控制点的位置设置为指定数组中指定偏移量的 Point2D对象的坐标。
      void QuadCurve2D.setCurve​(Point2D p1, Point2D cp, Point2D p2)
      将此 QuadCurve2D的终点和控制点的位置设置为指定的 Point2D坐标。
      void RectangularShape.setFrame​(Point2D loc, Dimension2D size)
      将Shape的成帧矩形的位置和大小分别设置为Point2D和Dimension2D 。
      void RectangularShape.setFrameFromCenter​(Point2D center, Point2D corner)
      根据指定的中心 Point2D和角 Point2D设置此 Shape的框架矩形。
      void RectangularShape.setFrameFromDiagonal​(Point2D p1, Point2D p2)
      基于两个指定的 Point2D对象设置 Shape的框架矩形的对角线。
      void Line2D.setLine​(Point2D p1, Point2D p2)
      将此 Line2D的终点位置设置为指定的 Point2D坐标。
      void Point2D.setLocation​(Point2D p)
      将此 Point2D的位置设置为与指定的 Point2D对象相同的坐标。
      void AffineTransform.transform​(Point2D[] ptSrc, int srcOff, Point2D[] ptDst, int dstOff, int numPts)
      通过此转换来转换点对象数组。
      Point2D AffineTransform.transform​(Point2D ptSrc, Point2D ptDst)
      转换指定的 ptSrc ，并将结果存储在 ptDst 。
      Constructors in java.awt.geom with parameters of type Point2D
      Constructor 描述
      Double​(Point2D p1, Point2D p2)
      构造并初始化一个 Line2D从指定 Point2D对象。
      Float​(Point2D p1, Point2D p2)
      构造并初始化一个 Line2D从指定 Point2D对象。

    • Uses of Point2D in java.awt.image

      Methods in java.awt.image that return Point2D
      Modifier and Type 方法 描述
      Point2D AffineTransformOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回在源中给出点的对应目标点的位置。
      Point2D BandCombineOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源 Raster给定点的对应目标点的位置。
      Point2D BufferedImageOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源图像中给定点的对应目标点的位置。
      Point2D ColorConvertOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      Point2D ConvolveOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      Point2D LookupOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      Point2D RasterOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源光栅中给定点的目标点的位置。
      Point2D RescaleOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      Methods in java.awt.image with parameters of type Point2D
      Modifier and Type 方法 描述
      Point2D AffineTransformOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回在源中给出点的对应目标点的位置。
      Point2D BandCombineOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源 Raster给定点的对应目标点的位置。
      Point2D BufferedImageOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源图像中给定点的对应目标点的位置。
      Point2D ColorConvertOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      Point2D ConvolveOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      Point2D LookupOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      Point2D RasterOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源光栅中给定点的目标点的位置。
      Point2D RescaleOp.getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。

    • Uses of Point2D in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type Point2D
      Modifier and Type 方法 描述
      String TextUI.getToolTipText2D​(JTextComponent t, Point2D pt)
      返回要用作传入位置的工具提示的字符串。
      int TextUI.viewToModel2D​(JTextComponent t, Point2D pt, Position.Bias[] biasReturn)
      提供从视图坐标空间到模型的逻辑坐标空间的映射。

    • Uses of Point2D in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type Point2D
      Modifier and Type | 方法 | 描述
      int | BasicTextUI.viewToModel2D​(JTextComponent tc, Point2D pt, Position.Bias[] biasReturn)

    • Uses of Point2D in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type Point2D
      Modifier and Type | 方法 | 描述
      int | MultiTextUI.viewToModel2D​(JTextComponent a, Point2D b, Position.Bias[] c)

    • Uses of Point2D in javax.swing.text

      Methods in javax.swing.text with parameters of type Point2D
      Modifier and Type 方法 描述
      int JTextComponent.viewToModel2D​(Point2D pt)
      将视图坐标系中的给定位置转换为模型中最近的代表位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Point2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Point2D.Double

No usage of java.awt.geom.Point2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Point2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Point2D.Float

No usage of java.awt.geom.Point2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.QuadCurve2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.QuadCurve2D

  • Packages that use QuadCurve2D
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of QuadCurve2D in java.awt.geom

      Subclasses of QuadCurve2D in java.awt.geom
      Modifier and Type Class 描述
      static class  QuadCurve2D.Double
      用 double坐标指定的二次参数曲线段。
      static class  QuadCurve2D.Float
      用 float坐标指定的二次参数曲线段。
      Methods in java.awt.geom with parameters of type QuadCurve2D
      Modifier and Type 方法 描述
      void QuadCurve2D.setCurve​(QuadCurve2D c)
      将此 QuadCurve2D的终点和控制点的位置设置为与指定的 QuadCurve2D的位置相同。
      void QuadCurve2D.subdivide​(QuadCurve2D left, QuadCurve2D right)
      细分此 QuadCurve2D ，并将所得的两条细分曲线存储到 left和 right曲线参数中。
      static void QuadCurve2D.subdivide​(QuadCurve2D src, QuadCurve2D left, QuadCurve2D right)
      细分由 src参数指定的二次曲线，并将所得到的两条细分曲线存储到 left和 right曲线参数中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.QuadCurve2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.QuadCurve2D.Double

No usage of java.awt.geom.QuadCurve2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.QuadCurve2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.QuadCurve2D.Float

No usage of java.awt.geom.QuadCurve2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Rectangle2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Rectangle2D

  • Packages that use Rectangle2D
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Rectangle2D in java.awt

      Subclasses of Rectangle2D in java.awt
      Modifier and Type Class 描述
      class  Rectangle
      A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)在坐标空间，其宽度及其高度中包围的区域。
      Methods in java.awt that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D Rectangle.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D TexturePaint.getAnchorRect​()
      返回锚定矩形的副本，该矩形位置和尺寸纹理图像。
      Rectangle2D Polygon.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D Rectangle.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D Shape.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D Font.getMaxCharBounds​(FontRenderContext frc)
      返回具有指定的 FontRenderContext定义的最大边界的字符的边界。
      Rectangle2D FontMetrics.getMaxCharBounds​(Graphics context)
      返回指定 Graphics上下文中具有最大边界的字符的边界。
      Rectangle2D Font.getStringBounds​(char[] chars, int beginIndex, int limit, FontRenderContext frc)
      返回指定的 FontRenderContext指定的字符数组的逻辑边界。
      Rectangle2D Font.getStringBounds​(String str, int beginIndex, int limit, FontRenderContext frc)
      返回指定的 String中指定的 FontRenderContext的逻辑边界。
      Rectangle2D Font.getStringBounds​(String str, FontRenderContext frc)
      返回指定的 String中指定的 FontRenderContext的逻辑边界。
      Rectangle2D Font.getStringBounds​(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc)
      返回指定索引的字符的逻辑边界CharacterIterator指定FontRenderContext 。
      Rectangle2D FontMetrics.getStringBounds​(char[] chars, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的字符数组的范围。
      Rectangle2D FontMetrics.getStringBounds​(String str, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的 String的边界。
      Rectangle2D FontMetrics.getStringBounds​(String str, Graphics context)
      返回指定的 Graphics上下文中指定的 String的边界。
      Rectangle2D FontMetrics.getStringBounds​(CharacterIterator ci, int beginIndex, int limit, Graphics context)
      返回指定的 Graphics上下文中指定的 CharacterIterator中索引的字符的边界。
      Methods in java.awt with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      boolean Polygon.contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      boolean Shape.contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      PaintContext Color.createContext​(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成纯色字段模式的PaintContext 。
      PaintContext GradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext LinearGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext Paint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成颜色模式的PaintContext 。
      PaintContext RadialGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成圆形径向颜色渐变模式的PaintContext 。
      PaintContext TexturePaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成平铺图像模式的PaintContext 。
      Rectangle2D Rectangle.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      boolean Polygon.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      boolean Shape.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      Constructors in java.awt with parameters of type Rectangle2D
      Constructor 描述
      RadialGradientPaint​(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
      构造一个 RadialGradientPaint具有默认 SRGB色彩空间。
      TexturePaint​(BufferedImage txtr, Rectangle2D anchor)
      构造一个 TexturePaint对象。

    • Uses of Rectangle2D in java.awt.font

      Methods in java.awt.font that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D GraphicAttribute.getBounds​()
      返回一个Rectangle2D ，其中包含由该GraphicAttribute相对于呈现位置绘制的所有位。
      Rectangle2D ImageGraphicAttribute.getBounds​()
      返回一个Rectangle2D ，它包含相对于渲染位置的由此ImageGraphicAttribute呈现的所有位。
      Rectangle2D ShapeGraphicAttribute.getBounds​()
      返回一个Rectangle2D ，其中包含了该ShapeGraphicAttribute相对于渲染位置绘制的所有位。
      Rectangle2D TextLayout.getBounds​()
      返回此 TextLayout的边界。
      Rectangle2D GlyphMetrics.getBounds2D​()
      返回字形的边界。
      abstract Rectangle2D GlyphVector.getLogicalBounds​()
      返回此 GlyphVector的逻辑边界。
      abstract Rectangle2D GlyphVector.getVisualBounds​()
      返回这个 GlyphVector的视觉边界视觉边界是这个 GlyphVector的轮廓的边界框。
      Methods in java.awt.font with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      float[] TextLayout.getCaretInfo​(TextHitInfo hit, Rectangle2D bounds)
      返回与 hit相对应的插入符的信息。
      Shape TextLayout.getCaretShape​(TextHitInfo hit, Rectangle2D bounds)
      返回一个Shape，表示指定边界内指定点的插入符号。
      Shape[] TextLayout.getCaretShapes​(int offset, Rectangle2D bounds)
      返回对应于强和弱插入符号的两个路径。
      Shape[] TextLayout.getCaretShapes​(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy)
      返回对应于强和弱插入符号的两个路径。
      Shape TextLayout.getLogicalHighlightShape​(int firstEndpoint, int secondEndpoint, Rectangle2D bounds)
      返回一个包含在指定范围内的逻辑选择的 Shape ，扩展到指定的 bounds 。
      Shape TextLayout.getVisualHighlightShape​(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds)
      返回包含指定范围内的视觉选择的路径，扩展为 bounds 。
      TextHitInfo TextLayout.hitTestChar​(float x, float y, Rectangle2D bounds)
      返回与指定点对应的 TextHitInfo 。
      Constructors in java.awt.font with parameters of type Rectangle2D
      Constructor 描述
      GlyphMetrics​(boolean horizontal, float advanceX, float advanceY, Rectangle2D bounds, byte glyphType)
      构造一个 GlyphMetrics对象。
      GlyphMetrics​(float advance, Rectangle2D bounds, byte glyphType)
      构造一个 GlyphMetrics对象。

    • Uses of Rectangle2D in java.awt.geom

      Subclasses of Rectangle2D in java.awt.geom
      Modifier and Type Class 描述
      static class  Rectangle2D.Double
      Double类定义了一个以双坐标指定的矩形。
      static class  Rectangle2D.Float
      Float类定义了一个以浮点坐标指定的矩形。
      Methods in java.awt.geom that return Rectangle2D
      Modifier and Type 方法 描述
      abstract Rectangle2D Rectangle2D.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Double.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Float.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      abstract Rectangle2D Rectangle2D.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Double.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Float.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Arc2D.getBounds2D​()
      返回圆弧的高精度框架矩形。
      Rectangle2D Area.getBounds2D​()
      返回一个高精度的边界Rectangle2D完全包围此Area 。
      Rectangle2D CubicCurve2D.Double.getBounds2D​()
      返回 Shape的 getBounds高精度和更准确的边界框。
      Rectangle2D CubicCurve2D.Float.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D Ellipse2D.Double.getBounds2D​()
      返回 Shape比 getBounds方法高精度和更准确的边界框。
      Rectangle2D Ellipse2D.Float.getBounds2D​()
      返回 Shape的 getBounds高精度和更准确的边界框。
      Rectangle2D Line2D.Double.getBounds2D​()
      比 getBounds方法返回 Shape高精度和更准确的边界框。
      Rectangle2D Line2D.Float.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D Path2D.Double.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D Path2D.Float.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更精确的边界框。
      Rectangle2D QuadCurve2D.Double.getBounds2D​()
      返回 Shape的 getBounds高精度和更准确的边界框。
      Rectangle2D QuadCurve2D.Float.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更精确的边界框。
      Rectangle2D Rectangle2D.Double.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D Rectangle2D.Float.getBounds2D​()
      返回 Shape的 getBounds高精度和更准确的边界框。
      Rectangle2D Rectangle2D.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D RoundRectangle2D.Double.getBounds2D​()
      返回 Shape的 getBounds高精度和更准确的边界框。
      Rectangle2D RoundRectangle2D.Float.getBounds2D​()
      返回 Shape比 getBounds方法更高精度和更准确的边界框。
      Rectangle2D RectangularShape.getFrame​()
      返回定义此对象的整体形状的框架Rectangle2D 。
      protected Rectangle2D Arc2D.Double.makeBounds​(double x, double y, double w, double h)
      构造一个适合精度的 Rectangle2D ，以将计算的参数保存为该弧的框架矩形。
      protected Rectangle2D Arc2D.Float.makeBounds​(double x, double y, double w, double h)
      构造一个 Rectangle2D的适当精度，以将计算的参数保持为该弧的框架矩形。
      protected abstract Rectangle2D Arc2D.makeBounds​(double x, double y, double w, double h)
      构造一个 Rectangle2D的适当精度，以将计算的参数保存为该弧的框架矩形。
      Methods in java.awt.geom with parameters of type Rectangle2D
      Modifier and Type 方法 描述
      void Rectangle2D.add​(Rectangle2D r)
      在这个 Rectangle2D添加一个 Rectangle2D对象。
      boolean Arc2D.contains​(Rectangle2D r)
      确定圆弧的内部是否完全包含指定的矩形。
      boolean Area.contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      boolean CubicCurve2D.contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      boolean Line2D.contains​(Rectangle2D r)
      测试这个 Line2D的内部 Line2D完全包含指定的 Rectangle2D 。
      static boolean Path2D.contains​(PathIterator pi, Rectangle2D r)
      测试指定Rectangle2D是完全指定的封闭边界内PathIterator 。
      boolean Path2D.contains​(Rectangle2D r)
      测试 Shape的内部 Shape完全包含指定的 Rectangle2D 。
      boolean QuadCurve2D.contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      boolean RectangularShape.contains​(Rectangle2D r)
      测试 Shape的内部 Shape全部包含指定的 Rectangle2D 。
      abstract Rectangle2D Rectangle2D.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Double.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Float.createIntersection​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示 Rectangle2D与指定的 Rectangle2D 。
      abstract Rectangle2D Rectangle2D.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Double.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      Rectangle2D Rectangle2D.Float.createUnion​(Rectangle2D r)
      返回一个新的 Rectangle2D对象，表示该 Rectangle2D与指定的 Rectangle2D 。
      static void Rectangle2D.intersect​(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest)
      相互对对指定的源 Rectangle2D对象，并将结果放入指定的目的地 Rectangle2D对象。
      boolean Area.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      boolean CubicCurve2D.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      boolean Line2D.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      static boolean Path2D.intersects​(PathIterator pi, Rectangle2D r)
      测试指定的PathIterator的内部是否与指定的内部相交Rectangle2D 。
      boolean Path2D.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      boolean QuadCurve2D.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      boolean RectangularShape.intersects​(Rectangle2D r)
      测试 Shape的内部是否与指定的内部相交 Rectangle2D 。
      void Arc2D.setArc​(Rectangle2D rect, double angSt, double angExt, int closure)
      将该弧的位置，大小，角度范围和闭合类型设置为指定的值。
      void RectangularShape.setFrame​(Rectangle2D r)
      将此 Shape的框架矩形设置为指定的 Rectangle2D 。
      void Rectangle2D.Double.setRect​(Rectangle2D r)
      将此 Rectangle2D设置为与指定的 Rectangle2D相同。
      void Rectangle2D.Float.setRect​(Rectangle2D r)
      将此 Rectangle2D设置为与指定的 Rectangle2D相同。
      void Rectangle2D.setRect​(Rectangle2D r)
      将此 Rectangle2D设置为与指定的 Rectangle2D相同。
      static void Rectangle2D.union​(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest)
      将对的一对源 Rectangle2D ，并将结果放入指定的目的地 Rectangle2D对象中。
      Constructors in java.awt.geom with parameters of type Rectangle2D
      Constructor 描述
      Double​(Rectangle2D ellipseBounds, double start, double extent, int type)
      构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。
      Float​(Rectangle2D ellipseBounds, float start, float extent, int type)
      构造一个新弧，初始化为指定的位置，大小，角度范围和关闭类型。

    • Uses of Rectangle2D in java.awt.image

      Methods in java.awt.image that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D AffineTransformOp.getBounds2D​(BufferedImage src)
      返回已转换目的地的边界框。
      Rectangle2D AffineTransformOp.getBounds2D​(Raster src)
      返回已转换目的地的边界框。
      Rectangle2D BandCombineOp.getBounds2D​(Raster src)
      返回已转换目的地的边界框。
      Rectangle2D BufferedImageOp.getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D ColorConvertOp.getBounds2D​(BufferedImage src)
      给出这个源，返回目的地的边界框。
      Rectangle2D ColorConvertOp.getBounds2D​(Raster src)
      给出这个源，返回目的地的边界框。
      Rectangle2D ConvolveOp.getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D ConvolveOp.getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Rectangle2D LookupOp.getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D LookupOp.getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Rectangle2D RasterOp.getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Rectangle2D RescaleOp.getBounds2D​(BufferedImage src)
      返回重新缩放的目标图像的边框。
      Rectangle2D RescaleOp.getBounds2D​(Raster src)
      返回重新缩放的目标栅格的边框。

    • Uses of Rectangle2D in java.awt.image.renderable

      Methods in java.awt.image.renderable that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D ContextualRenderedImageFactory.getBounds2D​(ParameterBlock paramBlock)
      在独立于渲染的空间中，返回在给定的一组源上执行的操作输出的边界框。

    • Uses of Rectangle2D in javax.swing.plaf

      Methods in javax.swing.plaf that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D TextUI.modelToView2D​(JTextComponent t, int pos, Position.Bias bias)
      将模型中的给定位置转换为视图坐标系中的一个位置。

    • Uses of Rectangle2D in javax.swing.plaf.basic

      Subclasses of Rectangle2D in javax.swing.plaf.basic
      Modifier and Type Class 描述
      static class  BasicTextUI.BasicCaret
      界面默认实现 Caret 。
      Methods in javax.swing.plaf.basic that return Rectangle2D
      Modifier and Type | 方法 | 描述
      Rectangle2D | BasicTextUI.modelToView2D​(JTextComponent tc, int pos, Position.Bias bias)

    • Uses of Rectangle2D in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return Rectangle2D
      Modifier and Type | 方法 | 描述
      Rectangle2D | MultiTextUI.modelToView2D​(JTextComponent a, int b, Position.Bias c)

    • Uses of Rectangle2D in javax.swing.text

      Subclasses of Rectangle2D in javax.swing.text
      Modifier and Type Class 描述
      class  DefaultCaret
      默认的Caret实现。
      Methods in javax.swing.text that return Rectangle2D
      Modifier and Type 方法 描述
      Rectangle2D JTextComponent.modelToView2D​(int pos)
      将模型中的给定位置转换为视图坐标系中的一个位置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Rectangle2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Rectangle2D.Double

No usage of java.awt.geom.Rectangle2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.Rectangle2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.Rectangle2D.Float

No usage of java.awt.geom.Rectangle2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.RectangularShape (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.RectangularShape

  • Packages that use RectangularShape
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of RectangularShape in java.awt

      Subclasses of RectangularShape in java.awt
      Modifier and Type Class 描述
      class  Rectangle
      A Rectangle指定在坐标空间中由 Rectangle对象的左上点 (x,y)的坐标空间中的一个区域，其宽度及其高度。

    • Uses of RectangularShape in java.awt.geom

      Subclasses of RectangularShape in java.awt.geom
      Modifier and Type Class 描述
      class  Arc2D
      Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或 PIE ）。
      static class  Arc2D.Double
      此类定义了 double精度中指定的弧。
      static class  Arc2D.Float
      该类定义了 float精度中指定的弧。
      class  Ellipse2D
      Ellipse2D类描述了由框架矩形定义的椭圆。
      static class  Ellipse2D.Double
      Double类定义了一个 double精度中指定的椭圆。
      static class  Ellipse2D.Float
      Float类定义了 float精度中指定的椭圆。
      class  Rectangle2D
      Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
      static class  Rectangle2D.Double
      Double类定义了一个以双坐标指定的矩形。
      static class  Rectangle2D.Float
      Float类定义了一个在浮点坐标中指定的矩形。
      class  RoundRectangle2D
      RoundRectangle2D类定义了一个矩形，其圆角由位置 (x,y)定义，尺寸为 (w x h) ，以及 (w x h)的宽度和高度。
      static class  RoundRectangle2D.Double
      Double类定义了一个带有圆角的矩形，全部在 double指定。
      static class  RoundRectangle2D.Float
      Float类定义了一个带有圆角的矩形，全部在 float坐标中指定。

    • Uses of RectangularShape in javax.swing.plaf.basic

      Subclasses of RectangularShape in javax.swing.plaf.basic
      Modifier and Type Class 描述
      static class  BasicTextUI.BasicCaret
      默认实现接口 Caret 。

    • Uses of RectangularShape in javax.swing.text

      Subclasses of RectangularShape in javax.swing.text
      Modifier and Type Class 描述
      class  DefaultCaret
      A default implementation of Caret.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.RoundRectangle2D (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.RoundRectangle2D

  • Packages that use RoundRectangle2D
    软件包 描述
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of RoundRectangle2D in java.awt.geom

      Subclasses of RoundRectangle2D in java.awt.geom
      Modifier and Type Class 描述
      static class  RoundRectangle2D.Double
      Double类定义了一个具有圆角的矩形，全部在 double坐标中指定。
      static class  RoundRectangle2D.Float
      Float类定义了一个具有圆角的矩形，全部在 float坐标中指定。
      Methods in java.awt.geom with parameters of type RoundRectangle2D
      Modifier and Type 方法 描述
      void RoundRectangle2D.Double.setRoundRect​(RoundRectangle2D rr)
      将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。
      void RoundRectangle2D.Float.setRoundRect​(RoundRectangle2D rr)
      将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。
      void RoundRectangle2D.setRoundRect​(RoundRectangle2D rr)
      将此 RoundRectangle2D设置为与指定的 RoundRectangle2D相同。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.RoundRectangle2D.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.RoundRectangle2D.Double

No usage of java.awt.geom.RoundRectangle2D.Double
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.geom.RoundRectangle2D.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.geom.RoundRectangle2D.Float

No usage of java.awt.geom.RoundRectangle2D.Float
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.geom.PathIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.geom.PathIterator

  • Packages that use PathIterator
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

    • Uses of PathIterator in java.awt

      Methods in java.awt that return PathIterator
      Modifier and Type 方法 描述
      PathIterator Polygon.getPathIterator​(AffineTransform at)
      返回迭代器对象，沿着这条边界迭代 Polygon ，并提供上网本的轮廓的几何 Polygon 。
      PathIterator Polygon.getPathIterator​(AffineTransform at, double flatness)
      返回一个沿着 Shape的边界进行迭代的迭代器对象，并提供对 Shape轮廓几何的访问。
      PathIterator Shape.getPathIterator​(AffineTransform at)
      返回一个沿着 Shape边界迭代的迭代器对象，并提供对 Shape大纲的几何形状的访问。
      PathIterator Shape.getPathIterator​(AffineTransform at, double flatness)
      返回一个沿着 Shape边界迭代的迭代器对象，并提供对 Shape轮廓几何体的平坦化视图的访问。

    • Uses of PathIterator in java.awt.geom

      Classes in java.awt.geom that implement PathIterator
      Modifier and Type Class 描述
      class  FlatteningPathIterator
      FlatteningPathIterator类返回另一个PathIterator对象的扁平化视图。
      Methods in java.awt.geom that return PathIterator
      Modifier and Type 方法 描述
      PathIterator Arc2D.getPathIterator​(AffineTransform at)
      返回定义圆弧边界的迭代对象。
      PathIterator Area.getPathIterator​(AffineTransform at)
      为此Area对象的轮廓创建一个PathIterator 。
      PathIterator Area.getPathIterator​(AffineTransform at, double flatness)
      为此 Area对象的扁平轮廓创建一个 PathIterator 。
      PathIterator CubicCurve2D.getPathIterator​(AffineTransform at)
      返回定义形状边界的迭代对象。
      PathIterator CubicCurve2D.getPathIterator​(AffineTransform at, double flatness)
      返回定义展平形状边界的迭代对象。
      PathIterator Ellipse2D.getPathIterator​(AffineTransform at)
      返回一个定义 Ellipse2D边界的迭代对象。
      PathIterator Line2D.getPathIterator​(AffineTransform at)
      返回一个定义 Line2D边界的迭代对象。
      PathIterator Line2D.getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代对象，该对象定义了此扁平化的边界 Line2D 。
      PathIterator Path2D.Double.getPathIterator​(AffineTransform at)
      返回一个迭代器对象，它可以沿着 Shape边界进行迭代，并提供对 Shape大纲的几何形状的访问。
      PathIterator Path2D.Float.getPathIterator​(AffineTransform at)
      返回一个沿着 Shape边界进行迭代的迭代器对象，并提供对 Shape轮廓几何的访问。
      PathIterator Path2D.getPathIterator​(AffineTransform at, double flatness)
      返回一个沿着 Shape边界迭代的迭代器对象，并提供对 Shape轮廓几何体的平坦化视图的访问。
      PathIterator QuadCurve2D.getPathIterator​(AffineTransform at)
      返回一个定义 QuadCurve2D形状边界的迭代对象。
      PathIterator QuadCurve2D.getPathIterator​(AffineTransform at, double flatness)
      返回定义此 QuadCurve2D的展平形状边界的迭代对象。
      PathIterator Rectangle2D.getPathIterator​(AffineTransform at)
      返回一个定义 Rectangle2D边界的迭代对象。
      PathIterator Rectangle2D.getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代对象，该对象定义了 Rectangle2D 。
      PathIterator RectangularShape.getPathIterator​(AffineTransform at, double flatness)
      返回一个迭代器对象，它可以沿着 Shape对象的边界进行迭代，并提供对 Shape对象几何轮廓的平坦化视图的访问。
      PathIterator RoundRectangle2D.getPathIterator​(AffineTransform at)
      返回一个定义 RoundRectangle2D边界的迭代对象。
      Methods in java.awt.geom with parameters of type PathIterator
      Modifier and Type 方法 描述
      abstract void Path2D.append​(PathIterator pi, boolean connect)
      将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
      void Path2D.Double.append​(PathIterator pi, boolean connect)
      将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
      void Path2D.Float.append​(PathIterator pi, boolean connect)
      将指定的PathIterator对象的几何附加到路径，可能将新几何体连接到具有线段的现有路径段。
      static boolean Path2D.contains​(PathIterator pi, double x, double y)
      测试指定的坐标是否在指定的PathIterator的封闭边界内。
      static boolean Path2D.contains​(PathIterator pi, double x, double y, double w, double h)
      测试指定的矩形区域是否完全在指定的PathIterator的封闭边界内。
      static boolean Path2D.contains​(PathIterator pi, Point2D p)
      测试指定Point2D是指定的封闭边界内PathIterator 。
      static boolean Path2D.contains​(PathIterator pi, Rectangle2D r)
      测试指定Rectangle2D是完全指定的封闭边界内PathIterator 。
      static boolean Path2D.intersects​(PathIterator pi, double x, double y, double w, double h)
      测试指定的PathIterator的内部是否与指定的一组直角坐标的内部相交。
      static boolean Path2D.intersects​(PathIterator pi, Rectangle2D r)
      测试指定的内部PathIterator是否与指定的内部相交Rectangle2D 。
      Constructors in java.awt.geom with parameters of type PathIterator
      Constructor 描述
      FlatteningPathIterator​(PathIterator src, double flatness)
      构造一个新的 FlatteningPathIterator对象，在对其进行迭代时使其 FlatteningPathIterator 。
      FlatteningPathIterator​(PathIterator src, double flatness, int limit)
      构造一个新的 FlatteningPathIterator对象，在对其进行迭代时使其 FlatteningPathIterator 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


InputContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.im

Class InputContext

  • java.lang.Object
    • java.awt.im.InputContext

  • public class InputContext
extends Object
    提供控制文本输入设备（如输入法和键盘布局）的方法。 两种方法处理输入法和键盘布局：selectInputMethod允许客户端组件通过语言环境选择输入法或键盘布局，getLocale允许客户端组件获取当前输入法或键盘布局的区域设置。 其他方法更具体地支持与输入法的交互：它们允许客户端组件控制输入方法的行为，并将事件从客户端组件分派到输入法。

    默认情况下，每个Window实例创建一个InputContext实例，并且该输入上下文由窗口容器层次结构中的所有组件共享。 但是，这意味着只有一个文本输入操作可以在窗口内的任何一个时间进行，并且当将焦点从一个文本组件移动到另一个文本组件时，需要提交文本。 如果不需要，文本组件可以创建自己的输入上下文实例。

    Java Platform支持使用Java编程语言开发的输入法，使用java.awt.im.spi软件包中的接口，并将其作为扩展安装到Java SE运行时环境中。 实施还可以支持使用他们运行的平台的本机输入方法; 然而，并不是所有的平台和区域设置都提供输入法。 键盘布局由主机平台提供。

    如果（a）用Java编程语言没有任何输入法已经安装和（b）的Java平台实现或基础平台不支持本机输入法输入法是不可用的 。 在这种情况下，仍然可以创建和使用输入上下文; 他们的行为是用以下各种方法指定的。

    从以下版本开始：
    1.2
    另请参见：
    Component.getInputContext() ， Component.enableInputMethods(boolean)

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected InputContext​()
      构造一个InputContext。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void dispatchEvent​(AWTEvent event)
      将事件调度为活动输入法。
      void dispose​()
      释放此输入上下文使用的资源。
      void endComposition​()
      结束本文中可能正在进行的任何输入组合。
      Object getInputMethodControlObject​()
      从当前输入法返回一个控件对象，或者返回null。
      static InputContext getInstance​()
      返回一个新的InputContext实例。
      Locale getLocale​()
      返回当前输入法或键盘布局的当前语言环境。
      boolean isCompositionEnabled​()
      确定组合是否启用当前输入法。
      void reconvert​()
      请求当前输入法从当前客户端组件重新转换文本。
      void removeNotify​(Component client)
      通知输入上下文，客户端组件已从其包含层次结构中删除，或该组件已禁用输入法支持。
      boolean selectInputMethod​(Locale locale)
      尝试选择支持给定区域设置的输入法或键盘布局，并返回一个值，该值指示是否已成功选择此类输入法或键盘布局。
      void setCharacterSubsets​(Character.Subset[] subsets)
      设置输入上下文输入方法的Unicode字符集的子集。
      void setCompositionEnabled​(boolean enable)
      根据参数 enable的值，启用或禁用当前的组合输入方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputContext

        protected InputContext​()
        构造一个InputContext。 此方法受到保护，因此客户端无法直接实例化InputContext。 输入上下文通过调用getInstance()获取 。

    • 方法详细信息

      • getInstance

        public static InputContext getInstance​()
        返回一个新的InputContext实例。
        结果
        一个新的InputContext实例

      • selectInputMethod

        public boolean selectInputMethod​(Locale locale)
        尝试选择支持给定区域设置的输入法或键盘布局，并返回一个值，该值指示是否已成功选择此类输入法或键盘布局。 在选择输入法之前，将采取以下步骤：
        • 如果当前选择的输入法或键盘布局支持所请求的语言环境，则它将保持选中状态。
        • 如果没有可用的支持所请求的语言环境的输入法或键盘布局，则当前输入法或键盘布局仍然被选中。
        • 如果用户先前已经从用户界面为所请求的区域设置选择了输入方法或键盘布局，则重新选择最近选择的这种输入方法或键盘布局。
        • 否则，以实现依赖的方式选择支持所请求的区域设置的输入法或键盘布局。
        在切换输入法之前，提交任何当前未提交的文本。 如果没有支持所请求的区域设置的输入法或键盘布局可用，则返回false。

        并非所有主机操作系统都提供API来确定当前选定的本地输入法或键盘布局的区域设置，并按区域设置选择本地输入法或键盘布局。 对于不提供此API的主机操作系统， selectInputMethod假设主机操作系统提供的本机输入法或键盘布局仅支持系统的默认语言环境。

        文本编辑组件可以调用此方法，例如，当用户更改插入点时，用户可以立即继续输入周围文本的语言。

        参数
        locale - 所需的新区域。
        结果
        如果在此调用后活动的输入法或键盘布局支持所需的语言环境，则为true。
        异常
        NullPointerException - 如果 locale为空

      • getLocale

        public Locale getLocale​()
        返回当前输入法或键盘布局的当前语言环境。 如果输入上下文没有当前输入法或键盘布局，或者当前输入法的InputMethod.getLocale()方法返回null，则返回null。

        并非所有主机操作系统都提供API来确定当前选定的本地输入法或键盘布局的区域设置。 对于主机操作系统不提供这样的API， getLocale假设由主机操作系统提供的所有本机输入方法或键盘布局的当前语言环境是该系统的默认语言环境。

        结果
        当前输入法的当前语言环境或键盘布局
        从以下版本开始：
        1.3

      • setCharacterSubsets

        public void setCharacterSubsets​(Character.Subset[] subsets)
        设置输入上下文输入方法的Unicode字符集的子集。 可以传入空值以表示允许所有字符。 初始值为null。 该设置适用于当前输入方法以及在进行此呼叫后选择的输入方法。 然而，应用程序不能依赖此调用具有所需的效果，因为此设置不能传递到所有主机输入方法 - 应用程序仍然需要应用自己的字符验证。 如果没有可用的输入法，则此方法无效。
        参数
        subsets - 可以输入字符的Unicode字符集的子集

      • setCompositionEnabled

        public void setCompositionEnabled​(boolean enable)
        根据参数enable的值启用或禁用组合的当前输入法。

        允许组合解释组合和控制目的的传入事件的输入法，而禁用的输入法不会解释组合的事件。 但是请注意，无论是否启用事件，事件都将传递给输入法，并且禁用组合的输入方法仍可能将事件解释为控制目的，包括启用或禁用其组合。

        对于由主机操作系统提供的输入方法，并不总是能够确定是否支持该操作。 例如，输入法可以仅为某些区域设置进行组合，而对其他区域设置也不起作用。 对于这样的输入方法，这种方法可能不会抛出UnsupportedOperationException ，而且也不影响组合是否启用。

        参数
        enable - 是否启用当前输入法的组合
        异常
        UnsupportedOperationException - 如果没有可用的当前输入法或当前输入法不支持使能/禁止操作
        从以下版本开始：
        1.3
        另请参见：
        isCompositionEnabled()

      • isCompositionEnabled

        public boolean isCompositionEnabled​()
        确定组合是否启用当前输入法。 允许组合解释组合和控制目的的传入事件的输入法，而禁用的输入法不会解释组合的事件。
        结果
        true如果当前的输入法启用了组合; 否则为false
        异常
        UnsupportedOperationException - 如果没有当前的输入方法可用或当前输入法不支持检查是否启用组合
        从以下版本开始：
        1.3
        另请参见：
        setCompositionEnabled(boolean)

      • reconvert

        public void reconvert​()
        请求当前输入法从当前客户端组件重新转换文本。 输入法使用InputMethodRequests.getSelectedText方法从客户端组件获取要重新转换的文本。 其他InputMethodRequests方法必须准备好通过输入法处理进一步的信息请求。 组合和/或提交的文本将以InputMethodEvent的顺序发送到客户端组件。 如果输入法无法重新转换给定的文本，文本将作为承诺文本返回到InputMethodEvent 。
        异常
        UnsupportedOperationException - 如果没有当前输入方法可用或当前输入法不支持重新转换操作。
        从以下版本开始：
        1.3

      • dispatchEvent

        public void dispatchEvent​(AWTEvent event)
        将事件调度为活动输入法。 由AWT召集。 如果没有可用的输入法，则事件永远不会被消耗。
        参数
        event - 事件
        异常
        NullPointerException - 如果 event为空

      • removeNotify

        public void removeNotify​(Component client)
        通知输入上下文，客户端组件已从其包含层次结构中删除，或该组件已禁用输入法支持。 该方法通常从客户端组件的Component.removeNotify方法调用。 该组件的输入方法的潜在等待输入将被丢弃。 如果没有可用的输入法，则此方法无效。
        参数
        client - 客户端组件
        异常
        NullPointerException - 如果 client为空

      • endComposition

        public void endComposition​()
        结束本文中可能正在进行的任何输入组合。 根据平台和可能的用户偏好，这可能会提交或删除未提交的文本。 使用输入法事件将对文本的任何更改传递给活动组件。 如果没有可用的输入法，则此方法无效。

        文本编辑组件可以在各种情况下调用这一点，例如当用户移动文本内的插入点（但在组合文本之外）时，或者组件的文本保存到文件或复制到剪贴板时。

      • dispose

        public void dispose​()
        释放此输入上下文使用的资源。 由AWT调用每个窗口的默认输入上下文。 如果没有可用的输入法，则此方法无效。

      • getInputMethodControlObject

        public Object getInputMethodControlObject​()
        从当前输入法返回一个控件对象，或者返回null。 控制对象提供了控制输入法行为或从输入法获取信息的方法。 对象的类型是一个输入法特定的类。 客户端必须将结果与已知的输入法控件对象类进行比较，并转换为适当的类以调用所提供的方法。

        如果没有输入方法可用或当前输入法不提供输入法控制对象，则返回null。

        结果
        来自当前输入法的控件对象，或null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputMethodHighlight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.im

Class InputMethodHighlight

  • java.lang.Object
    • java.awt.im.InputMethodHighlight

  • public class InputMethodHighlight
extends Object
    InputMethodHighlight用于描述正在组成的文本的突出显示属性。 描述可以分为两个层次：在抽象级别，它指定转换状态以及文本是否被选择; 在具体级别，它指定用于渲染突出显示的样式属性。 InputMethodHighlight必须在抽象级别提供描述; 它可能或可能不提供具体级别的描述。 如果没有提供具体的样式，则渲染器应使用Toolkit.mapInputMethodHighlight(java.awt.im.InputMethodHighlight)映射到具体样式。

    抽象描述由三个字段组成： selected ， state ，并variation 。 selected指示文本范围是否是输入方法当前工作的范围，例如，当前在菜单中显示转换候选的段。 state表示转换状态。 状态值由输入法框架定义，并应在从抽象到具体样式的所有映射中进行区分。 当前定义的状态值为raw（未转换）并转换。 这些状态值建议在文本构成的主要转换步骤之前和之后使用，例如，在kana-> kanji或pinyin-> hanzi转换之前和之后。 variation字段允许输入方法来表达有关转换结果的其他信息。

    InputMethodHighlight实例通常用作从AttributeCharacterIterator为INPUT_METHOD_HIGHLIGHT属性返回的属性值。 它们可能被包装到Annotation个实例中以指示单独的文本段。

    从以下版本开始：
    1.2
    另请参见：
    AttributedCharacterIterator

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int CONVERTED_TEXT
      转换文本状态的常数。
      static int RAW_TEXT
      原始文本状态不变。
      static InputMethodHighlight SELECTED_CONVERTED_TEXT_HIGHLIGHT
      所选转换文本的默认高亮度的常数。
      static InputMethodHighlight SELECTED_RAW_TEXT_HIGHLIGHT
      所选原始文本的默认突出显示的常数。
      static InputMethodHighlight UNSELECTED_CONVERTED_TEXT_HIGHLIGHT
      未选择转换文本的默认高亮的常数。
      static InputMethodHighlight UNSELECTED_RAW_TEXT_HIGHLIGHT
      未选择的原始文本的默认突出显示的常数。

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputMethodHighlight​(boolean selected, int state)
      构造输入法高亮记录。
      InputMethodHighlight​(boolean selected, int state, int variation)
      构造输入法高亮记录。
      InputMethodHighlight​(boolean selected, int state, int variation, Map<TextAttribute,?> style)
      构造输入法高亮记录。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getState​()
      返回文本范围的转换状态。
      Map<TextAttribute,?> getStyle​()
      返回文本范围的渲染样式属性，或返回null。
      int getVariation​()
      返回文本范围的变化。
      boolean isSelected​()
      返回是否选择文本范围。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • RAW_TEXT

        public static final int RAW_TEXT
        原始文本状态不变。
        另请参见：
        Constant Field Values

      • CONVERTED_TEXT

        public static final int CONVERTED_TEXT
        转换文本状态的常数。
        另请参见：
        Constant Field Values

      • UNSELECTED_RAW_TEXT_HIGHLIGHT

        public static final InputMethodHighlight UNSELECTED_RAW_TEXT_HIGHLIGHT
        未选择的原始文本的默认突出显示的常数。

      • SELECTED_RAW_TEXT_HIGHLIGHT

        public static final InputMethodHighlight SELECTED_RAW_TEXT_HIGHLIGHT
        所选原始文本的默认突出显示的常数。

      • UNSELECTED_CONVERTED_TEXT_HIGHLIGHT

        public static final InputMethodHighlight UNSELECTED_CONVERTED_TEXT_HIGHLIGHT
        未选择转换文本的默认高亮的常数。

      • SELECTED_CONVERTED_TEXT_HIGHLIGHT

        public static final InputMethodHighlight SELECTED_CONVERTED_TEXT_HIGHLIGHT
        所选转换文本的默认高亮度的常数。

    • 构造方法详细信息

      • InputMethodHighlight

        public InputMethodHighlight​(boolean selected,
                            int state)
        构造输入法高亮记录。 变量设置为0，样式为null。
        参数
        selected - 是否选择文本范围
        state - 文本范围的转换状态 - RAW_TEXT或CONVERTED_TEXT
        异常
        IllegalArgumentException - 如果给出了除RAW_TEXT或CONVERTED_TEXT之外的状态
        另请参见：
        RAW_TEXT ， CONVERTED_TEXT

      • InputMethodHighlight

        public InputMethodHighlight​(boolean selected,
                            int state,
                            int variation)
        构造输入法高亮记录。 样式设置为null。
        参数
        selected - 是否选择文本范围
        state - 文本范围的转换状态 - RAW_TEXT或CONVERTED_TEXT
        variation - 文本范围的样式变体
        异常
        IllegalArgumentException - 如果给出了除RAW_TEXT或CONVERTED_TEXT之外的状态
        另请参见：
        RAW_TEXT ， CONVERTED_TEXT

      • InputMethodHighlight

        public InputMethodHighlight​(boolean selected,
                            int state,
                            int variation,
                            Map<TextAttribute,?> style)
        构造输入法高亮记录。 提供的样式属性图必须是不可修改的。
        参数
        selected - 是否选择文本范围
        state - 文本范围的转换状态 - RAW_TEXT或CONVERTED_TEXT
        variation - 文本范围的变化
        style - 文本范围的渲染样式属性，或null
        异常
        IllegalArgumentException - 如果给出了除RAW_TEXT或CONVERTED_TEXT之外的状态
        从以下版本开始：
        1.3
        另请参见：
        RAW_TEXT ， CONVERTED_TEXT

    • 方法详细信息

      • isSelected

        public boolean isSelected​()
        返回是否选择文本范围。
        结果
        是否选择文本范围

      • getState

        public int getState​()
        返回文本范围的转换状态。
        结果
        文本范围的转换状态 - RAW_TEXT或CONVERTED_TEXT。
        另请参见：
        RAW_TEXT ， CONVERTED_TEXT

      • getVariation

        public int getVariation​()
        返回文本范围的变化。
        结果
        文字范围的变化

      • getStyle

        public Map<TextAttribute,?> getStyle​()
        返回文本范围的渲染样式属性，或返回null。
        结果
        文本范围的渲染样式属性，或null
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputMethodRequests (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.im

Interface InputMethodRequests

  • All Known Subinterfaces:
    InputMethodContext

    public interface InputMethodRequests
    InputMethodRequests定义文本编辑组件必须处理的请求，以便使用输入法。 该组件可以实现此接口本身或使用实现它的单独对象。 必须从组件的getInputMethodRequests方法返回实现此接口的对象。

    文本编辑组件还必须提供一个输入法事件侦听器。

    该接口旨在支持两个输入用户界面之一：

    • 现场输入，组合文本显示为文本组件文本体的一部分。
    • 现场输入，其中组合文本显示在单独的合成窗口中，恰好在提交文本时将插入文本的插入点下方。 请注意，如果在组件的文本正文中选择文本，则此文本将在承诺时被承诺文本替换; 因此，它不被视为输入文本的上下文的一部分。
    从以下版本开始：
    1.2
    另请参见：
    Component.getInputMethodRequests() ， InputMethodListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AttributedCharacterIterator cancelLatestCommittedText​(AttributedCharacterIterator.Attribute[] attributes)
      从文本编辑组件获取最新提交的文本，并将其从组件的文本正文中删除。
      AttributedCharacterIterator getCommittedText​(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
      获取一个迭代器，提供对文本编辑组件中包含的整个文本和属性的访问，除了未提交的文本。
      int getCommittedTextLength​()
      获取文本编辑组件中包含的整个文本的长度，但未提交（组合）文本除外）。
      int getInsertPositionOffset​()
      获取文本编辑组件中包含的提交文本中插入位置的偏移量。
      TextHitInfo getLocationOffset​(int x, int y)
      获取屏幕上指定的绝对x和y坐标的组合文本中的偏移量。
      AttributedCharacterIterator getSelectedText​(AttributedCharacterIterator.Attribute[] attributes)
      从文本编辑组件获取当前选定的文本。
      Rectangle getTextLocation​(TextHitInfo offset)
      获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。

    • 方法详细信息

      • getTextLocation

        Rectangle getTextLocation​(TextHitInfo offset)
        获取当前组合文本中指定偏移量的位置，或者在提交文本中获取选择的位置。 例如，该信息用于将候选窗口放置在合成文本附近，或者在将插入提交文本的位置附近的合成窗口。

        如果组件已经组合文本（因为发送给它的最新的InputMethodEvent包含组合文本），则偏移量相对于组合文本 - 偏移0表示组合文本中的第一个字符。 返回的位置应该是这个字符。

        如果组件没有组合文本，偏移量应该被忽略，返回的位置应该反映包含所选文本的最后一行中的高亮显示的开始（沿方向）。 例如，对于水平从左到右的文本（例如英文），返回包含所选文本的最后一行最左侧字符左侧的位置。 对于垂直的从上到下的文本，从右到左继续进行，返回包含所选文本的最左行的顶部位置。

        该位置表示为0-厚度插入符号，即如果文本是水平绘制的，则为0，如果垂直绘制文本，则为0。 其他文字方向需要映射到水平或垂直方向。 矩形使用绝对屏幕坐标。

        参数
        offset - 组合文本中的偏移量，如果有合成文本; 否则为空
        结果
        表示偏移的屏幕位置的矩形

      • getLocationOffset

        TextHitInfo getLocationOffset​(int x,
                              int y)
        获取屏幕上指定的绝对x和y坐标的组合文本中的偏移量。 此信息用于处理鼠标点击和鼠标光标。 偏移量相对于组合文本，因此offset 0表示组合文本的开头。

        如果位置在组合文本占用的区域之外，则返回null。

        参数
        x - 屏幕上的绝对x坐标
        y - 屏幕上的绝对y坐标
        结果
        描述组合文本中的偏移的文本命中信息。

      • getInsertPositionOffset

        int getInsertPositionOffset​()
        获取文本编辑组件中包含的提交文本中插入位置的偏移量。 这是插入通过输入法输入的字符的偏移量。 该信息由输入法使用，例如用于检查插入位置周围的文本。
        结果
        插入位置的偏移

      • getCommittedText

        AttributedCharacterIterator getCommittedText​(int beginIndex,
                                             int endIndex,
                                             AttributedCharacterIterator.Attribute[] attributes)
        获取一个迭代器，提供对文本编辑组件中包含的整个文本和属性的访问，除了未提交的文本。 对于索引计算，应忽略未提交（组合）文本，不能通过迭代器访问。

        输入法可以提供它感兴趣的属性的列表。在这种情况下，实现者可能需要的关于其他属性的信息不需要通过迭代器访问。 如果列表为空，则所有可用属性信息都应该可访问。

        参数
        beginIndex - 第一个字符的索引
        endIndex - 最后一个字符后面的字符的索引
        attributes - 输入法感兴趣的属性列表
        结果
        提供对文本及其属性的访问的迭代器

      • getCommittedTextLength

        int getCommittedTextLength​()
        获取文本编辑组件中包含的整个文本的长度，但未提交（组合）文本除外）。
        结果
        文本的长度除未提交的文本外

      • cancelLatestCommittedText

        AttributedCharacterIterator cancelLatestCommittedText​(AttributedCharacterIterator.Attribute[] attributes)
        从文本编辑组件获取最新提交的文本，并将其从组件的文本正文中删除。 这用于一些输入方法中的“撤消提交”功能，其中提交的文本将恢复到其先前的组合状态。 组合文本将使用InputMethodEvent发送到组件。

        通常，此功能只能在文本提交后立即支持，而不是在用户对文本执行其他操作之后。 当不支持该功能时，返回null。

        输入法可以提供它感兴趣的属性的列表。在这种情况下，实现者可能需要的关于其他属性的信息不需要通过迭代器访问。 如果列表为空，则所有可用属性信息都应该可访问。

        参数
        attributes - 输入法感兴趣的属性列表
        结果
        最新提交的文本，如果不支持“撤消提交”功能，则为空

      • getSelectedText

        AttributedCharacterIterator getSelectedText​(AttributedCharacterIterator.Attribute[] attributes)
        从文本编辑组件获取当前选定的文本。 这可以用于各种目的。 其中一个是一些输入法中的“再转换”功能。 在这种情况下，输入法通常会发送一个输入法事件来替换所选择的文本与组合文本。 根据输入法的功能，这可能是所选文本的原始组合文本，文本中任何位置输入的最新合成文本，或从选定文本转换回来的文本版本。

        输入法可以提供它感兴趣的属性的列表。在这种情况下，实现者可能需要的关于其他属性的信息不需要通过迭代器访问。 如果列表为空，则所有可用属性信息都应该可访问。

        参数
        attributes - 输入法感兴趣的属性列表
        结果
        当前选择的文本
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputSubset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.im

Class InputSubset

  • java.lang.Object
    • java.lang.Character.Subset
      • java.awt.im.InputSubset

  • public final class InputSubset
extends Character.Subset
    定义输入法使用的其他Unicode子集。 与Character.UnicodeBlock类中定义的UnicodeBlock子集不同，这些常量不直接对应于Unicode代码块。
    从以下版本开始：
    1.2

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static InputSubset FULLWIDTH_DIGITS
      Unicode宽度和全宽形式字符块中包含的全宽数字的常数。
      static InputSubset FULLWIDTH_LATIN
      Unicode宽度和全宽形式字符块的全宽ASCII变体子集的常数。
      static InputSubset HALFWIDTH_KATAKANA
      Unicode半宽和全宽形式字符块的半宽片假名子集的常数。
      static InputSubset HANJA
      所有汉字用于韩文的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的韩文汉字。
      static InputSubset KANJI
      所有用于日文的汉字的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的日文汉字。
      static InputSubset LATIN
      所有拉丁字符的常数，包括BASIC_LATIN，LATIN_1_SUPPLEMENT，LATIN_EXTENDED_A，LATIN_EXTENDED_B Unicode字符块中的字符。
      static InputSubset LATIN_DIGITS
      BASIC_LATIN Unicode字符块中包含的数字的常数。
      static InputSubset SIMPLIFIED_HANZI
      所有用于汉语汉字的常数为简体中文，包括CJK统一表意文字的一小部分以及可能被定义为替代字符的简体中文汉字。
      static InputSubset TRADITIONAL_HANZI
      所有汉字使用的汉字常数繁体中文，包括CJK统一表意文字的一部分以及可能被定义为替代字符的繁体中文汉字。

    • 方法摘要

      • Methods inherited from class java.lang.Character.Subset

        equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • LATIN

        public static final InputSubset LATIN
        所有拉丁字符的常数，包括BASIC_LATIN，LATIN_1_SUPPLEMENT，LATIN_EXTENDED_A，LATIN_EXTENDED_B Unicode字符块中的字符。

      • LATIN_DIGITS

        public static final InputSubset LATIN_DIGITS
        BASIC_LATIN Unicode字符块中包含的数字的常数。

      • TRADITIONAL_HANZI

        public static final InputSubset TRADITIONAL_HANZI
        所有汉字使用的汉字常数繁体中文，包括CJK统一表意文字的一部分以及可能被定义为替代字符的繁体中文汉字。

      • SIMPLIFIED_HANZI

        public static final InputSubset SIMPLIFIED_HANZI
        所有用于汉语汉字的常数为简体中文，包括CJK统一表意文字的一小部分以及可能被定义为替代字符的简体中文汉字。

      • KANJI

        public static final InputSubset KANJI
        所有用于日文的汉字的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的日文汉字。

      • HANJA

        public static final InputSubset HANJA
        所有汉字用于韩文的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的韩文汉字。

      • HALFWIDTH_KATAKANA

        public static final InputSubset HALFWIDTH_KATAKANA
        Unicode半宽和全宽形式字符块的半宽片假名子集的常数。

      • FULLWIDTH_LATIN

        public static final InputSubset FULLWIDTH_LATIN
        Unicode宽度和全宽形式字符块的全宽ASCII变体子集的常数。
        从以下版本开始：
        1.3

      • FULLWIDTH_DIGITS

        public static final InputSubset FULLWIDTH_DIGITS
        Unicode宽度和全宽形式字符块中包含的全宽数字的常数。
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.im (Java SE 9 & JDK 9 )

java.awt.im

Interfaces

  • InputMethodRequests

Classes

  • InputContext
  • InputMethodHighlight
  • InputSubset


java.awt.im (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.im

提供输入法框架的类和接口。 该包使文本编辑组件能够通过输入法接收文本输入。 输入法是允许用户以键盘上简单打字以外的方式输入文字的软件组件。 它们通常用于输入日语，中文或韩语 - 使用数千个不同的字符 - 键盘上键少得多的键盘。 然而，该框架还支持其他语言的输入方法和使用完全不同的输入机制，如手写或语音识别。

相关文档

有关概述，教程，示例，指南和工具文档，请参阅Input Method Framework Overview 。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    InputMethodRequests
    InputMethodRequests定义文本编辑组件必须处理的请求，以便使用输入法。
  • 类摘要
    Class 描述
    InputContext
    提供控制文本输入设备（如输入法和键盘布局）的方法。
    InputMethodHighlight
    InputMethodHighlight用于描述正在组成的文本的突出显示属性。
    InputSubset
    定义输入法使用的其他Unicode子集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.im Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.im

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Character.Subset
      • java.awt.im.InputSubset
    • java.awt.im.InputContext
    • java.awt.im.InputMethodHighlight

Interface Hierarchy

  • java.awt.im.InputMethodRequests
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Package java.awt.im (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.im

  • Packages that use java.awt.im
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
  • Classes in java.awt.im used by java.awt
    Class 描述
    InputContext
    提供控制文本输入设备（如输入法和键盘布局）的方法。
    InputMethodHighlight
    InputMethodHighlight用于描述正在组成的文本的突出显示属性。
    InputMethodRequests
    InputMethodRequests定义文本编辑组件必须处理的请求，以便使用输入法。
  • Classes in java.awt.im used by java.awt.im
    Class 描述
    InputContext
    提供控制文本输入设备（如输入法和键盘布局）的方法。
    InputMethodHighlight
    InputMethodHighlight用于描述正在组成的文本的突出显示属性。
    InputSubset
    定义输入法使用的其他Unicode子集。
  • Classes in java.awt.im used by java.awt.im.spi
    Class 描述
    InputMethodRequests
    InputMethodRequests定义文本编辑组件必须处理的请求，以便使用输入法。
  • Classes in java.awt.im used by javafx.embed.swing
    Class 描述
    InputMethodRequests
    InputMethodRequests定义文本编辑组件必须处理的请求，以便使用输入法。
  • Classes in java.awt.im used by javax.swing.text
    Class 描述
    InputMethodRequests
    InputMethodRequests定义文本编辑组件必须处理的请求，以便使用输入法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.im.InputContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.im.InputContext

  • Packages that use InputContext
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.im
    提供输入法框架的类和接口。

    • Uses of InputContext in java.awt

      Methods in java.awt that return InputContext
      Modifier and Type 方法 描述
      InputContext Component.getInputContext​()
      获取此组件使用的输入上下文，以便在此组件中输入文本时处理与输入法的通信。
      InputContext Window.getInputContext​()
      获取此窗口的输入上下文。

    • Uses of InputContext in java.awt.im

      Methods in java.awt.im that return InputContext
      Modifier and Type 方法 描述
      static InputContext InputContext.getInstance​()
      返回一个新的InputContext实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.im.InputMethodHighlight (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.im.InputMethodHighlight

  • Packages that use InputMethodHighlight
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.im
    提供输入法框架的类和接口。

    • Uses of InputMethodHighlight in java.awt

      Methods in java.awt with parameters of type InputMethodHighlight
      Modifier and Type 方法 描述
      abstract Map<TextAttribute,?> Toolkit.mapInputMethodHighlight​(InputMethodHighlight highlight)
      返回给定输入法突出显示的抽象级别描述的可视属性映射，如果没有找到映射，则返回null。

    • Uses of InputMethodHighlight in java.awt.im

      Fields in java.awt.im declared as InputMethodHighlight
      Modifier and Type Field 描述
      static InputMethodHighlight InputMethodHighlight.SELECTED_CONVERTED_TEXT_HIGHLIGHT
      所选转换文本的默认高亮度的常数。
      static InputMethodHighlight InputMethodHighlight.SELECTED_RAW_TEXT_HIGHLIGHT
      所选原始文本的默认突出显示的常数。
      static InputMethodHighlight InputMethodHighlight.UNSELECTED_CONVERTED_TEXT_HIGHLIGHT
      未选择转换文本的默认高亮的常数。
      static InputMethodHighlight InputMethodHighlight.UNSELECTED_RAW_TEXT_HIGHLIGHT
      Constant for the default highlight for unselected raw text.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.im.InputSubset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.im.InputSubset

  • Packages that use InputSubset
    软件包 描述
    java.awt.im
    提供输入法框架的类和接口。

    • Uses of InputSubset in java.awt.im

      Fields in java.awt.im declared as InputSubset
      Modifier and Type Field 描述
      static InputSubset InputSubset.FULLWIDTH_DIGITS
      Unicode宽度和全宽形式字符块中包含的全宽数字的常数。
      static InputSubset InputSubset.FULLWIDTH_LATIN
      Unicode宽度和全宽形式字符块的全宽ASCII变体子集的常数。
      static InputSubset InputSubset.HALFWIDTH_KATAKANA
      Unicode半宽和全宽形式字符块的半宽片假名子集的常数。
      static InputSubset InputSubset.HANJA
      所有汉字用于韩文的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的韩文汉字。
      static InputSubset InputSubset.KANJI
      所有用于日文的汉字的常数，包括CJK统一表意文字的子集以及可能被定义为替代字符的日文汉字。
      static InputSubset InputSubset.LATIN
      所有拉丁字符的常数，包括BASIC_LATIN，LATIN_1_SUPPLEMENT，LATIN_EXTENDED_A，LATIN_EXTENDED_B Unicode字符块中的字符。
      static InputSubset InputSubset.LATIN_DIGITS
      BASIC_LATIN Unicode字符块中包含的数字的常数。
      static InputSubset InputSubset.SIMPLIFIED_HANZI
      所有用于汉语汉字的常数为简体中文，包括CJK统一表意文字的一小部分以及可能被定义为替代字符的简体中文汉字。
      static InputSubset InputSubset.TRADITIONAL_HANZI
      所有汉字使用的汉字常数繁体中文，包括CJK统一表意文字的一部分以及可能被定义为替代字符的繁体中文汉字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.im.InputMethodRequests (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.im.InputMethodRequests

  • Packages that use InputMethodRequests
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of InputMethodRequests in java.awt

      Methods in java.awt that return InputMethodRequests
      Modifier and Type | 方法 | 描述
      InputMethodRequests Component.getInputMethodRequests​()
      获取支持该组件输入法的请求的输入法请求处理程序。
      InputMethodRequests | TextComponent.getInputMethodRequests​()

    • Uses of InputMethodRequests in java.awt.im.spi

      Subinterfaces of InputMethodRequests in java.awt.im.spi
      Modifier and Type 接口 描述
      interface  InputMethodContext
      提供输入方法可用于与其客户端组件通信或请求其他服务的方法。

    • Uses of InputMethodRequests in javafx.embed.swing

      Methods in javafx.embed.swing that return InputMethodRequests
      Modifier and Type | 方法 | 描述
      InputMethodRequests | JFXPanel.getInputMethodRequests​()

    • Uses of InputMethodRequests in javax.swing.text

      Methods in javax.swing.text that return InputMethodRequests
      Modifier and Type | 方法 | 描述
      InputMethodRequests | JTextComponent.getInputMethodRequests​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


InputMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.im.spi

Interface InputMethod

  • public interface InputMethod
    定义支持复杂文本输入的输入法的界面。 输入法传统上支持具有比可以在标准尺寸键盘上表示的字符更多的语言的文本输入，例如中文，日语和韩语。 然而，它们也可以用于支持用于泰语的英文或字符重新排序的语音文本输入。

    InputMethod的子类可以通过输入法框架加载; 然后可以通过API（ InputContext.selectInputMethod ）或用户界面（输入法选择菜单）选择它们。

    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void activate​()
      激活立即输入处理的输入法。
      void deactivate​(boolean isTemporary)
      禁用输入法。
      void dispatchEvent​(AWTEvent event)
      将事件调度到输入法。
      void dispose​()
      释放此输入法使用的资源。
      void endComposition​()
      结束本文中可能正在进行的任何输入组合。
      Object getControlObject​()
      从此输入法返回一个控件对象，或者返回null。
      Locale getLocale​()
      返回当前的输入区域设置。
      void hideWindows​()
      关闭或隐藏由此输入法实例或其类打开的所有窗口。
      boolean isCompositionEnabled​()
      确定是否启用此输入法。
      void notifyClientWindowChange​(Rectangle bounds)
      通知客户端窗口位置或状态的这种输入方式的更改。
      void reconvert​()
      开始重新转换操作。
      void removeNotify​()
      通知输入方法，客户端组件已从其包含层次结构中删除，或该组件已禁用输入法支持。
      void setCharacterSubsets​(Character.Subset[] subsets)
      设置该输入法允许输入的Unicode字符集的子集。
      void setCompositionEnabled​(boolean enable)
      根据参数 enable的值，启用或禁用此输入法。
      void setInputMethodContext​(InputMethodContext context)
      设置输入法上下文，用于将输入法事件分派给客户端组件，并从客户端组件请求信息。
      boolean setLocale​(Locale locale)
      尝试设置输入区域设置。

    • 方法详细信息

      • setInputMethodContext

        void setInputMethodContext​(InputMethodContext context)
        设置输入法上下文，用于将输入法事件分派给客户端组件，并从客户端组件请求信息。

        在实例化此输入法后立即调用此方法。

        参数
        context - 此输入法的输入法上下文
        异常
        NullPointerException - 如果 context为空

      • setLocale

        boolean setLocale​(Locale locale)
        尝试设置输入区域设置。 如果输入法支持所需的语言环境，则会更改其行为以支持语言环境的输入，并返回true。 否则，它返回false并且不会改变其行为。

        调用这个方法

        • 由InputContext.selectInputMethod ，
        • 如果用户指定了区域通过所述用户界面切换到这个输入方法或当如果先前选择的输入方法的getLocale方法返回一个非空值。
        参数
        locale - 区域到输入
        结果
        是否支持指定的区域设置
        异常
        NullPointerException - 如果 locale为空

      • getLocale

        Locale getLocale​()
        返回当前的输入区域设置。 在异常情况下可能返回null。

        调用这个方法

        • 由InputContext.getLocale和
        • 当通过用户界面从该输入法切换到不同的方法时。
        结果
        当前输入区域设置，或null

      • setCharacterSubsets

        void setCharacterSubsets​(Character.Subset[] subsets)
        设置该输入法允许输入的Unicode字符集的子集。 可以传入空值以表示允许所有字符。

        调用这个方法

        • 在实例化这种输入法之后，
        • 当从另一个切换到这个输入法时，和
        • 由InputContext.setCharacterSubsets 。
        参数
        subsets - 可以输入字符的Unicode字符集的子集

      • setCompositionEnabled

        void setCompositionEnabled​(boolean enable)
        根据参数enable的值，启用或禁用此输入法。

        允许组合解释组合和控制目的的传入事件的输入法，而禁用的输入法不会解释组合的事件。 但是请注意，无论是否启用事件，事件都将传递给输入法，并且禁用组合的输入方法仍可能将事件解释为控制目的，包括启用或禁用其组合。

        对于由主机操作系统提供的输入方法，并不总是能够确定是否支持该操作。 例如，输入法可以仅为某些区域设置进行组合，而对其他区域设置也不起作用。 对于这样的输入方法，这种方法可能不会抛出UnsupportedOperationException ，而且也不影响组合是否启用。

        调用这个方法

        • 由InputContext.setCompositionEnabled ，
        • 当使用用户界面或InputContext.selectInputMethod从不同的方法切换到此输入法时，如果先前选择的输入法的isCompositionEnabled方法返回而不会引发异常。
        参数
        enable - 是否启用输入法的组合
        异常
        UnsupportedOperationException - 如果此输入法不支持启用/禁用操作
        另请参见：
        isCompositionEnabled()

      • isCompositionEnabled

        boolean isCompositionEnabled​()
        确定是否启用此输入法。 允许组合解释组合和控制目的的传入事件的输入法，而禁用的输入法不会解释组合的事件。

        调用这个方法

        • 由InputContext.isCompositionEnabled和
        • 当使用用户界面或InputContext.selectInputMethod将此输入法切换到不同的方法时。
        结果
        true如果这个输入法启用了组合; 否则为false 。
        异常
        UnsupportedOperationException - 如果此输入法不支持检查是否启用了组合
        另请参见：
        setCompositionEnabled(boolean)

      • reconvert

        void reconvert​()
        开始重新转换操作。 输入法使用InputMethodRequests.getSelectedText方法从当前客户端组件获取要重新转换的文本。 它可以使用其他InputMethodRequests方法来请求重新转换操作所需的附加信息。 由操作产生的组合和提交的文本作为InputMethodEvent的序列发送到客户端组件。 如果给定的文本无法重新转换，则应将相同的文本作为已提交的文本发送到客户端组件。

        此方法由InputContext.reconvert调用 。

        异常
        UnsupportedOperationException - 如果输入法不支持重新转换操作。

      • dispatchEvent

        void dispatchEvent​(AWTEvent event)
        将事件调度到输入法。 如果为聚焦组件启用了输入法支持，则将某些类型的传入事件分派到该组件的当前输入方法，然后再分派给组件的方法或事件侦听器。 输入法决定是否需要处理事件。 如果是，它也会调用事件的consume方法; 这导致事件不会被分派到组件的事件处理方法或事件监听器。

        如果事件是InputEvent或其子类的实例，则会调度事件。 这包括AWT类KeyEvent和MouseEvent的实例。

        此方法由InputContext.dispatchEvent调用 。

        参数
        event - 将事件分派到输入法
        异常
        NullPointerException - 如果 event为空

      • notifyClientWindowChange

        void notifyClientWindowChange​(Rectangle bounds)
        通知客户端窗口位置或状态的这种输入方式的更改。 调用此方法时，此输入方法是其输入上下文的当前输入方法，并启用其通知（请参阅InputMethodContext.enableClientWindowNotification ）。 如果调用输入上下文的removeNotify方法，则对此方法的调用将暂停，并在为新客户端组件激活输入方法时恢复。 在以下情况下被称为：
        • 当包含当前客户端组件的窗口在位置，大小，可见性，图标化状态或窗口关闭时发生变化。
        • 从enableClientWindowNotification(inputMethod, true)如果当前客户端组件存在，
        • 在调用enableClientWindowNotification(inputMethod, true)之后首次激活输入法时，如果在通话期间没有当前的客户端组件可用，
        • 在调用输入上下文的removeNotify方法之后激活新客户端组件的输入方法。
        参数
        bounds - 客户端窗口的bounds在屏幕上; 如果客户端窗口被图标化或不可见，则为null

      • activate

        void activate​()
        激活立即输入处理的输入法。

        如果一个输入法提供了自己的窗口，那么在这一点上应该确保所有必要的窗口都是可见的。

        调用这个方法

        • 通过InputContext.dispatchEvent当客户端组件接收到FOCUS_GAINED事件时，
        • 当使用用户界面或InputContext.selectInputMethod从不同的方法切换到此输入法时。
        仅当输入法不活动时才调用该方法。 假设新实例化的输入法是无效的。

      • deactivate

        void deactivate​(boolean isTemporary)
        禁用输入法。 isTemporary参数与FocusEvent.isTemporary中的含义相同。

        如果一个输入法提供了自己的窗口，那么现在只能关闭与当前组合相关的窗口（如查找选择窗口）。 可能的是，对于不同的客户端组件，将立即重新启动输入法，并关闭并重新打开更多的持久性窗口（如控制面板）将会产生不必要的屏幕闪烁。 在激活不同输入法类的实例之前，会在当前的输入法中调用hideWindows() 。

        调用这个方法

        • 通过InputContext.dispatchEvent当客户端组件接收到FOCUS_LOST事件时，
        • 当使用用户界面或者InputContext.selectInputMethod从这种输入法切换到不同的方法时，
        • 之前removeNotify如果当前客户端组件被删除。
        该方法仅在输入法有效时才调用。
        参数
        isTemporary - 焦点变化是否是暂时的

      • hideWindows

        void hideWindows​()
        关闭或隐藏由此输入法实例或其类打开的所有窗口。

        调用这个方法

        • 在一个不同的输入法类的实例上调用activate之前，
        • 之前请先输入dispose这个输入法。
        仅当输入法不活动时才调用该方法。

      • removeNotify

        void removeNotify​()
        通知输入方法，客户端组件已从其包含层次结构中删除，或该组件已禁用输入法支持。

        此方法由InputContext.removeNotify调用 。

        仅当输入法不活动时才调用该方法。

      • endComposition

        void endComposition​()
        结束本文中可能正在进行的任何输入组合。 根据平台和可能的用户偏好，这可能会提交或删除未提交的文本。 使用输入法事件将对文本的任何更改传递给活动组件。

        文本编辑组件可以在各种情况下调用这一点，例如当用户移动文本内的插入点（但在组合文本之外）时，或者组件的文本保存到文件或复制到剪贴板时。

        调用这个方法

        • 由InputContext.endComposition ，
        • 通过InputContext.dispatchEvent切换到不同的客户端组件时
        • 当使用用户界面或InputContext.selectInputMethod从此输入法切换到不同的方法时。

      • dispose

        void dispose​()
        释放此输入法使用的资源。 特别地，输入法应该配置窗口并关闭不再需要的文件。

        此方法由InputContext.dispose调用 。

        仅当输入法不活动时才调用该方法。 处理后，此实例没有调用此接口的方法。

      • getControlObject

        Object getControlObject​()
        从此输入法返回一个控件对象，或者返回null。 控制对象提供了控制输入法行为或从输入法获取信息的方法。 对象的类型是一个输入法特定的类。 客户端必须将结果与已知的输入法控件对象类进行比较，并转换为适当的类以调用所提供的方法。

        此方法由InputContext.getInputMethodControlObject调用 。

        结果
        来自此输入法的控件对象，或null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputMethodContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.im.spi

Interface InputMethodContext

  • All Superinterfaces:
    InputMethodRequests

    public interface InputMethodContext
extends InputMethodRequests
    提供输入方法可用于与其客户端组件通信或请求其他服务的方法。 该接口由输入法框架实现，输入法通过InputMethod.setInputMethodContext(java.awt.im.spi.InputMethodContext)调用其接收的实例。 不应该有其他的执行者或呼叫者。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      JFrame createInputMethodJFrame​(String title, boolean attachToInputContext)
      创建一个顶级的Swing JFrame以供输入法使用。
      Window createInputMethodWindow​(String title, boolean attachToInputContext)
      创建一个顶级窗口，供输入法使用。
      void dispatchInputMethodEvent​(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
      从给定的参数创建输入法事件并将其分派到客户端组件。
      void enableClientWindowNotification​(InputMethod inputMethod, boolean enable)
      启用或禁用当前客户端窗口的位置和指定输入法的状态的通知。

      • Methods inherited from interface java.awt.im.InputMethodRequests

        cancelLatestCommittedText, getCommittedText, getCommittedTextLength, getInsertPositionOffset, getLocationOffset, getSelectedText, getTextLocation

    • 方法详细信息

      • dispatchInputMethodEvent

        void dispatchInputMethodEvent​(int id,
                              AttributedCharacterIterator text,
                              int committedCharacterCount,
                              TextHitInfo caret,
                              TextHitInfo visiblePosition)
        从给定的参数创建输入法事件并将其分派到客户端组件。 有关参数，请参阅InputMethodEvent(java.awt.Component, int, java.awt.font.TextHitInfo, java.awt.font.TextHitInfo) 。
        参数
        id - 事件类型
        text - 组合的承诺和合成文本
        committedCharacterCount - 文本中提交的字符数
        caret - 插入符号（又称插入点）; 如果当前组合文本中没有插入符，则为null
        visiblePosition - 最重要的可见位置; 如果在当前合成文本中没有可视位置的建议，则为null

      • createInputMethodWindow

        Window createInputMethodWindow​(String title,
                               boolean attachToInputContext)
        创建一个顶级窗口，供输入法使用。 此窗口的预期行为是：
        • 它漂浮在所有文档窗口和对话框之上
        • 它和它包含的所有组件都没有收到焦点
        • 它具有轻量化的装饰，例如没有标题的减少拖动区域
        但是，这三个项目的实际行为依赖于平台。

        标题可能显示也可能不会显示，具体取决于所创建窗口的实际类型。

        如果attachToInputContext为true，则新窗口将共享与此输入法上下文相对应的输入上下文，以便窗口中组件的事件自动分派到输入法。 此外，当窗口使用setVisible（true）打开时，输入上下文将阻止停用并激活可能导致的输入方法的调用。

        当不再需要时，输入法必须在返回的输入法窗口中调用Window.dispose 。

        参数
        title - 标题显示在窗口的标题栏中，如果有这样的标题栏。 A null值被视为空字符串“”。
        attachToInputContext - 此窗口是否应共享与此输入法上下文相对应的输入上下文
        结果
        一个具有特殊特征的窗口，用于输入法
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回 true

      • createInputMethodJFrame

        JFrame createInputMethodJFrame​(String title,
                               boolean attachToInputContext)
        创建一个顶级的Swing JFrame以供输入法使用。 此窗口的预期行为是：
        • 它漂浮在所有文档窗口和对话框之上
        • 它和它包含的所有组件都没有收到焦点
        • 它具有轻量化的装饰，例如没有标题的减少拖动区域
        但是，这三个项目的实际行为依赖于平台。

        标题可能显示也可能不会显示，具体取决于所创建窗口的实际类型。

        如果attachToInputContext为true，则新窗口将共享与此输入法上下文相对应的输入上下文，以便窗口中组件的事件自动分派到输入法。 此外，当窗口使用setVisible（true）打开时，输入上下文将阻止停用并激活可能导致的输入方法的调用。

        当不再需要时，输入法必须在返回的输入法窗口中调用Window.dispose 。

        参数
        title - 标题显示在窗口的标题栏中，如果有这样的标题栏。 A null值被视为空字符串“”。
        attachToInputContext - 此窗口是否应共享与此输入法上下文相对应的输入上下文
        结果
        一个具有特殊特性的JFrame，用于输入法
        异常
        HeadlessException - 如果 GraphicsEnvironment.isHeadless返回 true
        从以下版本开始：
        1.4

      • enableClientWindowNotification

        void enableClientWindowNotification​(InputMethod inputMethod,
                                    boolean enable)
        启用或禁用当前客户端窗口的位置和指定输入法的状态的通知。 当启用通知时，按照该方法的说明书所述，调用输入法的notifyClientWindowChange方法。 当输入方法处理时，通知将自动禁用。
        参数
        inputMethod - 启用或禁用通知的输入法
        enable - true启用，false禁用
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputMethodDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.im.spi

Interface InputMethodDescriptor

  • public interface InputMethodDescriptor
    定义提供有关输入法的足够信息以启用该输入法的选择和加载的方法。 输入法本身仅在实际使用时加载。
    从以下版本开始：
    1.3

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      InputMethod createInputMethod​()
      创建相应输入法的新实例。
      Locale[] getAvailableLocales​()
      返回相应输入法支持的语言环境。
      String getInputMethodDisplayName​(Locale inputLocale, Locale displayLanguage)
      以显示名称的语言返回给定输入区域设置的相应输入法的用户可见名称。
      Image getInputMethodIcon​(Locale inputLocale)
      返回相应输入法的图标。
      boolean hasDynamicLocaleList​()
      返回可用区域设置的列表是否可以在运行时更改。

    • 方法详细信息

      • getAvailableLocales

        Locale[] getAvailableLocales​()
                      throws AWTException
        返回相应输入法支持的语言环境。 语言环境可以仅描述语言，或者如果需要，还可以包括国家和变体信息。 该信息用于通过语言环境选择输入法（ InputContext.selectInputMethod(Locale) ）。 它也可以用于在用户可见的输入法列表中通过语言环境对输入法进行排序。

        应该只返回输入法的主要区域设置。 例如，如果日语输入法也有罗马字符的直通模式，通常仍然只会返回日语。 因此，返回的语言环境列表通常是相应输入法实现的区域设置的一个子集，为InputMethod.setLocale(java.util.Locale)返回true。

        如果hasDynamicLocaleList()返回true，则每次需要该信息时调用此方法。 这给了输入方法，这取决于网络资源在资源变得可用或不可用时添加或删除区域设置的机会。

        结果
        输入法支持的语言环境
        异常
        AWTException - 如果可以确定输入法是不可操作的，例如，由于安装不完整。

      • hasDynamicLocaleList

        boolean hasDynamicLocaleList​()
        返回可用区域设置的列表是否可以在运行时更改。 例如，适用于通过网络访问实际输入方法的适配器可能是这种情况。
        结果
        可用区域设置的列表是否可以在运行时更改

      • getInputMethodDisplayName

        String getInputMethodDisplayName​(Locale inputLocale,
                                 Locale displayLanguage)
        以显示名称的语言返回给定输入区域设置的相应输入法的用户可见名称。

        inputLocale参数指定输入文本的区域设置。 此参数只能从该描述符的getAvailableLocales()方法获得的值或为null。 如果为null，则应返回输入方法的输入区域设置独立名称。

        如果所需显示语言的名称不可用，则该方法可能会退回到其他语言。

        参数
        inputLocale - 支持文本输入的语言环境，或为空
        displayLanguage - 显示名称的语言
        结果
        给定输入语言环境的相应输入法的用户可见名称，以该名称显示的语言

      • getInputMethodIcon

        Image getInputMethodIcon​(Locale inputLocale)
        返回相应输入法的图标。 该图标可以由用户界面用于选择输入方法。

        inputLocale参数指定输入文本的区域设置。 此参数只能从此描述符的getAvailableLocales()方法获取的值或为null。 如果为空，则应返回输入方法的输入区域设置独立图标。

        该图标的大小应为16×16像素。

        参数
        inputLocale - 支持文本输入的语言环境，或为空
        结果
        相应输入法的图标，或null

      • createInputMethod

        InputMethod createInputMethod​()
                       throws 异常
        创建相应输入法的新实例。
        结果
        一个新的实例相应的输入法
        异常
        异常 - 创建输入法实例时可能发生的任何异常
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.im.spi (Java SE 9 & JDK 9 )

java.awt.im.spi

Interfaces

  • InputMethod
  • InputMethodContext
  • InputMethodDescriptor


java.awt.im.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.im.spi

提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。 输入法是允许用户以键盘上简单打字以外的方式输入文字的软件组件。 它们通常用于输入日语，中文或韩语 - 使用数千个不同的字符 - 键盘上键少得多的键盘。 然而，这个包也允许开发其他语言的输入法，并使用完全不同的输入机制，如手写识别。

包装输入法

可以通过将输入法添加到应用程序的类路径中来获得输入法。 输入法的主JAR文件必须包含文件：
  META-INF/services/java.awt.im.spi.InputMethodDescriptor
该文件应包含一个完全限定类名称，一行一行，实现java.awt.im.spi.InputMethodDescriptor接口的类。 忽略每个名称周围的空格和制表符，以及空白行。 评论人物为'#' （ \u0023 ）; 在每行上，忽略第一个注释字符之后的所有字符。 文件必须以UTF-8编码。

例如，如果为Foo输入法实现java.awt.im.spi.InputMethodDesciptor的类的完全限定名称为com.sun.ime.FooInputMethodDescriptor ，则文件META-INF/services/java.awt.im.spi.InputMethodDescriptor包含一行：

  com.sun.ime.FooInputMethodDescriptor
输入法还必须提供至少两个类：一个实现java.awt.im.spi.InputMethodDescriptor接口的类，一个实现java.awt.im.spi.InputMethod接口的类。 输入法应该分离这些接口的实现，以便实现InputMethod的类的InputMethod可以推迟到实际需要之前。

加载输入法

输入法框架通常会延迟加载输入法类，直到绝对需要。 它仅在AWT初始化期间加载InputMethodDescriptor实现。 当选择输入法时，它会加载一个InputMethod实现。

Java输入法和对等文本组件

Java输入法框架旨在支持输入法（主机输入法和Java输入法）和组件（对等和轻量级）的所有组合。 然而，由于底层平台的局限性，可能并不总是能够启用Java输入法和对等AWT组件之间的通信。 因此，对这种特定组合的支持取决于平台。 在Sun的Java SE运行时环境中，这种组合在Windows上受支持，但不支持Solaris。

相关文档

有关概述，教程，示例，指南和工具文档，请参阅Input Method Framework Overview 。
从以下版本开始：
1.3
  • 接口摘要
    接口 描述
    InputMethod
    定义支持复杂文本输入的输入法的界面。
    InputMethodContext
    提供输入方法可用于与其客户端组件通信或请求其他服务的方法。
    InputMethodDescriptor
    定义提供有关输入法的足够信息以启用该输入法的选择和加载的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.im.spi Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.im.spi

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • java.awt.im.spi.InputMethod
  • java.awt.im.spi.InputMethodDescriptor
  • java.awt.im.InputMethodRequests
    • java.awt.im.spi.InputMethodContext
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Package java.awt.im.spi (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.im.spi

  • Packages that use java.awt.im.spi
    软件包 描述
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
  • Classes in java.awt.im.spi used by java.awt.im.spi
    Class 描述
    InputMethod
    定义支持复杂文本输入的输入法的界面。
    InputMethodContext
    提供输入方法可用于与其客户端组件通信或请求其他服务的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.im.spi.InputMethod (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.im.spi.InputMethod

  • Packages that use InputMethod
    软件包 描述
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。

    • Uses of InputMethod in java.awt.im.spi

      Methods in java.awt.im.spi that return InputMethod
      Modifier and Type 方法 描述
      InputMethod InputMethodDescriptor.createInputMethod​()
      创建相应输入法的新实例。
      Methods in java.awt.im.spi with parameters of type InputMethod
      Modifier and Type 方法 描述
      void InputMethodContext.enableClientWindowNotification​(InputMethod inputMethod, boolean enable)
      启用或禁用当前客户端窗口的位置和指定输入法的状态的通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.im.spi.InputMethodContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.im.spi.InputMethodContext

  • Packages that use InputMethodContext
    软件包 描述
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。

    • Uses of InputMethodContext in java.awt.im.spi

      Methods in java.awt.im.spi with parameters of type InputMethodContext
      Modifier and Type 方法 描述
      void InputMethod.setInputMethodContext​(InputMethodContext context)
      设置输入法上下文，用于将输入法事件分派给客户端组件，并从客户端组件请求信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.im.spi.InputMethodDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.im.spi.InputMethodDescriptor

No usage of java.awt.im.spi.InputMethodDescriptor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AbstractMultiResolutionImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class AbstractMultiResolutionImage

  • java.lang.Object
    • java.awt.Image
      • java.awt.image.AbstractMultiResolutionImage
  • All Implemented Interfaces:
    MultiResolutionImage
    已知直接子类：
    BaseMultiResolutionImage

    public abstract class AbstractMultiResolutionImage
extends Image
implements MultiResolutionImage
    该类为要实现MultiResolutionImage接口的类提供了几个Image方法的默认实现。 例如，
       public class CustomMultiResolutionImage extends AbstractMultiResolutionImage { final Image[] resolutionVariants; public CustomMultiResolutionImage(Image... resolutionVariants) { this.resolutionVariants = resolutionVariants; } public Image getResolutionVariant( double destImageWidth, double destImageHeight) { // return a resolution variant based on the given destination image size } public List<Image> getResolutionVariants() { return Collections.unmodifiableList(Arrays.asList(resolutionVariants)); } protected Image getBaseImage() { return resolutionVariants[0]; } }
    从以下版本开始：
    9
    另请参见：
    Image ， MultiResolutionImage

    • Field Summary

      • Fields inherited from class java.awt.Image

        accelerationPriority, SCALE_AREA_AVERAGING, SCALE_DEFAULT, SCALE_FAST, SCALE_REPLICATE, SCALE_SMOOTH, UndefinedProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      AbstractMultiResolutionImage​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract Image getBaseImage​()
      返回表示最佳版本的图像的基本图像，以便以默认的宽度和高度渲染。
      Graphics getGraphics​()
      根据基地 Image#getGraphics()方法的合同，这个实现将总是抛出 UnsupportedOperationException因为只有离屏图像可以返回一个 Graphics对象。
      int getHeight​(ImageObserver observer)
      该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getHeight(observer) 。
      Object getProperty​(String name, ImageObserver observer)
      该方法简单地委托给基本图像上的相同方法，它等效于： getBaseImage().getProperty(name, observer) 。
      ImageProducer getSource​()
      该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getSource() 。
      int getWidth​(ImageObserver observer)
      该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getWidth(observer) 。

      • Methods inherited from class java.awt.Image

        flush, getAccelerationPriority, getCapabilities, getScaledInstance, setAccelerationPriority

      • Methods inherited from interface java.awt.image.MultiResolutionImage

        getResolutionVariant, getResolutionVariants

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractMultiResolutionImage

        public AbstractMultiResolutionImage​()

    • 方法详细信息

      • getWidth

        public int getWidth​(ImageObserver observer)
        该方法简单地委托给基本映像上相同的方法，它等效于： getBaseImage().getWidth(observer) 。
        Specified by:
        getWidth在 Image
        参数
        observer - 等待图像加载的对象。
        结果
        基本图像的宽度，如果宽度尚未知道，则为-1
        从以下版本开始：
        9
        另请参见：
        getBaseImage()

      • getHeight

        public int getHeight​(ImageObserver observer)
        该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getHeight(observer) 。
        Specified by:
        getHeight在 Image
        参数
        observer - 等待图像加载的对象。
        结果
        基本图像的高度，如果高度尚未知道则为-1
        从以下版本开始：
        9
        另请参见：
        getBaseImage()

      • getSource

        public ImageProducer getSource​()
        该方法简单地委托给基本图像上的相同方法，它等效于： getBaseImage().getSource() 。
        Specified by:
        getSource在 Image
        结果
        产生基本图像的像素的图像生成器
        从以下版本开始：
        9
        另请参见：
        getBaseImage()

      • getGraphics

        public Graphics getGraphics​()
        根据基地 Image#getGraphics()方法的合同，此实现将始终抛出 UnsupportedOperationException因为只有离屏图像可以返回一个 Graphics对象。
        Specified by:
        getGraphics在 Image
        结果
        抛出 UnsupportedOperationException
        异常
        UnsupportedOperationException - 不支持此方法
        另请参见：
        Graphics ， Component.createImage(int, int)

      • getProperty

        public Object getProperty​(String name,
                          ImageObserver observer)
        该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getProperty(name, observer) 。
        Specified by:
        getProperty中的 Image
        参数
        name - 属性名称。
        observer - 等待加载图像的对象。
        结果
        命名属性在基本映像中的值
        从以下版本开始：
        9
        另请参见：
        getBaseImage()

      • getBaseImage

        protected abstract Image getBaseImage​()
        返回表示最佳版本的图像的基本图像，以便以默认的宽度和高度渲染。
        结果
        一组多分辨率图像的基本图像
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AffineTransformOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class AffineTransformOp

  • java.lang.Object
    • java.awt.image.AffineTransformOp
  • All Implemented Interfaces:
    BufferedImageOp ， RasterOp

    public class AffineTransformOp
extends Object
implements BufferedImageOp, RasterOp
    该类使用仿射变换来执行从源图像中的2D坐标或目标图像中的Raster到2D坐标的线性映射或Raster 。 所使用的内插类型通过构造函数来指定，由一个RenderingHints对象或由该类中定义的整数插值类型之一指定。

    如果在RenderingHints函数中指定了一个RenderingHints对象，则使用插值提示和呈现质量提示来设置此操作的插值类型。 当需要颜色转换时，可以使用显色提示和抖动提示。

    请注意，必须满足以下约束：

    • 源和目的地必须不同。
    • 对于Raster对象，源中的频带数必须等于目标中的频带数。
    另请参见：
    AffineTransform ， BufferedImageFilter ， RenderingHints.KEY_INTERPOLATION ， RenderingHints.KEY_RENDERING ， RenderingHints.KEY_COLOR_RENDERING ， RenderingHints.KEY_DITHERING

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TYPE_BICUBIC
      双三次插补类型。
      static int TYPE_BILINEAR
      双线性插值类型。
      static int TYPE_NEAREST_NEIGHBOR
      最近邻插值类型。

    • 构造方法摘要

      构造方法
      Constructor 描述
      AffineTransformOp​(AffineTransform xform, int interpolationType)
      构造一个 AffineTransformOp给出仿射变换和插值类型。
      AffineTransformOp​(AffineTransform xform, RenderingHints hints)
      构造一个 AffineTransformOp给出一个仿射变换。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BufferedImage createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      WritableRaster createCompatibleDestRaster​(Raster src)
      创建带有正确大小和频带数的归零目的地 Raster 。
      BufferedImage filter​(BufferedImage src, BufferedImage dst)
      转换源 BufferedImage并将结果存储在目标 BufferedImage 。
      WritableRaster filter​(Raster src, WritableRaster dst)
      转换源 Raster并将结果存储在目标 Raster 。
      Rectangle2D getBounds2D​(BufferedImage src)
      返回已转换目的地的边界框。
      Rectangle2D getBounds2D​(Raster src)
      返回已转换目的地的边界框。
      int getInterpolationType​()
      返回此op使用的插值类型。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回在源中给出点的对应目标点的位置。
      RenderingHints getRenderingHints​()
      返回此变换操作使用的渲染提示。
      AffineTransform getTransform​()
      返回此变换操作使用的仿射变换。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TYPE_NEAREST_NEIGHBOR

        @Native
public static final int TYPE_NEAREST_NEIGHBOR
        最近邻插值类型。
        另请参见：
        Constant Field Values

      • TYPE_BILINEAR

        @Native
public static final int TYPE_BILINEAR
        双线性插值类型。
        另请参见：
        Constant Field Values

      • TYPE_BICUBIC

        @Native
public static final int TYPE_BICUBIC
        双三次插补类型。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • AffineTransformOp

        public AffineTransformOp​(AffineTransform xform,
                         RenderingHints hints)
        构造一个AffineTransformOp给出一个仿射变换。 插值类型由RenderingHints对象确定。 如果定义了插补提示，将使用它。 否则，如果定义了渲染质量提示，则根据其值确定插值类型。 如果没有指定提示（ hints为空），插值类型为TYPE_NEAREST_NEIGHBOR 。
        参数
        xform - 用于操作的 AffineTransform 。
        hints - 用于指定操作的插补类型的 RenderingHints对象。
        异常
        ImagingOpException - 如果变换是不可逆的。
        另请参见：
        RenderingHints.KEY_INTERPOLATION ， RenderingHints.KEY_RENDERING

      • AffineTransformOp

        public AffineTransformOp​(AffineTransform xform,
                         int interpolationType)
        构造一个 AffineTransformOp给出仿射变换和插值类型。
        参数
        xform - 用于操作的 AffineTransform 。
        interpolationType -一个由这个类定义的整数内插类型的常量： TYPE_NEAREST_NEIGHBOR ， TYPE_BILINEAR ， TYPE_BICUBIC 。
        异常
        ImagingOpException - ImagingOpException - ImagingOpException - ImagingOpException - ImagingOpException - ImagingOpException - ImagingOpException

    • 方法详细信息

      • getInterpolationType

        public final int getInterpolationType​()
        返回此op使用的插值类型。
        结果
        插补类型。
        另请参见：
        TYPE_NEAREST_NEIGHBOR ， TYPE_BILINEAR ， TYPE_BICUBIC

      • filter

        public final BufferedImage filter​(BufferedImage src,
                                  BufferedImage dst)
        转换源BufferedImage并将结果存储在目标BufferedImage 。 如果两个图像的颜色模型不匹配，则执行到目标颜色模型的颜色转换。 如果目标映像为空，则创建一个BufferedImage源，源为ColorModel 。

        由getBounds2D(BufferedImage)返回的矩形的坐标不一定与此方法返回的BufferedImage的坐标相同。 如果矩形的左上角坐标为负，则不绘制矩形的这一部分。 如果矩形的左上角坐标为正，则滤波后的图像将在目标BufferedImage中的该位置绘制。

        如果源与目的地相同，则抛出一个IllegalArgumentException 。

        Specified by:
        filter接口 BufferedImageOp
        参数
        src - 要转化的 BufferedImage 。
        dst - BufferedImage其中存储转换的结果。
        结果
        过滤的 BufferedImage 。
        异常
        IllegalArgumentException - 如果 src和 dst是相同的
        ImagingOpException - 如果由于无效的图像格式，瓦片格式或图像处理操作或任何其他不受支持的操作可能导致的数据处理错误，图像无法转换。

      • filter

        public final WritableRaster filter​(Raster src,
                                   WritableRaster dst)
        转换源Raster并将结果存储在目标Raster 。 该操作按照频带进行变换。

        如果目的地Raster为空，则创建一个新的Raster 。 如果源与目的地相同或者源中的频带数不等于目的地的频带数，则可能会抛出IllegalArgumentException 。

        由getBounds2D(Raster)返回的矩形的坐标不一定与此方法返回的WritableRaster的坐标相同。 如果矩形的左上角坐标为负，则不绘制矩形的这一部分。 如果矩形的坐标为正，则在目标Raster中的该位置绘制滤波图像。

        Specified by:
        filter在接口 RasterOp
        参数
        src - 要转换的 Raster 。
        dst - Raster其中存储转换的结果。
        结果
        转换 Raster 。
        异常
        ImagingOpException - 如果由于可能由无效的图像格式，瓦片格式或图像处理操作引起的数据处理错误或任何其他不受支持的操作导致栅格无法转换。

      • getBounds2D

        public final Rectangle2D getBounds2D​(BufferedImage src)
        返回已转换目的地的边界框。 返回的矩形是转换点的实际边界框。 返回矩形左上角的坐标可能不是（0，0）。
        Specified by:
        getBounds2D在接口 BufferedImageOp
        参数
        src - 要转化的 BufferedImage 。
        结果
        Rectangle2D代表目的地的边界框。

      • getBounds2D

        public final Rectangle2D getBounds2D​(Raster src)
        返回已转换目的地的边界框。 返回的矩形将是转换点的实际边界框。 返回矩形左上角的坐标可能不是（0，0）。
        Specified by:
        getBounds2D在接口 RasterOp
        参数
        src - 要转型的 Raster 。
        结果
        表示目的地的边界框的 Rectangle2D 。

      • createCompatibleDestImage

        public BufferedImage createCompatibleDestImage​(BufferedImage src,
                                               ColorModel destCM)
        创建具有正确大小和频带数的归零目标图像。 如果变换的宽度或高度等于0，则可能会抛出RasterFormatException 。

        如果destCM为空，则使用适当的ColorModel ; 即使源ColorModel是不透明的，该ColorModel可能具有α通道。

        Specified by:
        createCompatibleDestImage在接口 BufferedImageOp
        参数
        src - 要转化的 BufferedImage 。
        destCM - 目的地的ColorModel 。 如果为null，则使用适当的ColorModel 。
        结果
        归零的目标图像。

      • createCompatibleDestRaster

        public WritableRaster createCompatibleDestRaster​(Raster src)
        创建带有正确大小和频带数的零目的地Raster 。 如果变换的宽度或高度等于0，则可能会抛出RasterFormatException 。
        Specified by:
        createCompatibleDestRaster在接口 RasterOp
        参数
        src - 要转化的 Raster 。
        结果
        零目的地 Raster 。

      • getPoint2D

        public final Point2D getPoint2D​(Point2D srcPt,
                                Point2D dstPt)
        返回在源中给出点的对应目标点的位置。 如果指定了dstPt ，则用于保存返回值。
        Specified by:
        getPoint2D在接口 BufferedImageOp
        Specified by:
        getPoint2D在接口 RasterOp
        参数
        srcPt - 代表源点的 Point2D 。
        dstPt - 存储结果的 Point2D 。
        结果
        目标中的 Point2D对应于源中的指定点。

      • getTransform

        public final AffineTransform getTransform​()
        返回此变换操作使用的仿射变换。
        结果
        AffineTransform与此操作相关联。

      • getRenderingHints

        public final RenderingHints getRenderingHints​()
        返回此变换操作使用的渲染提示。
        Specified by:
        getRenderingHints在接口 BufferedImageOp
        Specified by:
        getRenderingHints在接口 RasterOp
        结果
        与此操作相关联的 RenderingHints对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AreaAveragingScaleFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class AreaAveragingScaleFilter

  • java.lang.Object
    • java.awt.image.ImageFilter
      • java.awt.image.ReplicateScaleFilter
        • java.awt.image.AreaAveragingScaleFilter
  • All Implemented Interfaces:
    ImageConsumer ， Cloneable

    public class AreaAveragingScaleFilter
extends ReplicateScaleFilter
    一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。

    该类扩展了基本的ImageFilter类以缩放现有图像，并为包含重新采样图像的新图像提供了一个源。 源图像中的像素被混合以产生用于指定大小的图像的像素。 混合过程类似于使用像素复制将源图像缩放到目标大小的倍数，然后通过简单地平均落在目的地的给定像素内的超图像中的所有像素将其缩小到目标大小图片。 如果来自源的数据未以TopDownLeftRight顺序递送，则过滤器将退回到简单的像素复制行为，并使用requestTopDownLeftRightResend（）方法以更好的方式重新填充像素。

    它意味着与FilteredImageSource对象结合使用，以生成现有图像的缩放版本。 由于实现依赖关系，在不同平台上过滤的图像的像素值可能有差异。

    另请参见：
    FilteredImageSource ， ReplicateScaleFilter ， ImageFilter

    • Field Summary

      • Fields inherited from interface java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

      • Fields inherited from class java.awt.image.ImageFilter

        consumer

      • Fields inherited from class java.awt.image.ReplicateScaleFilter

        destHeight, destWidth, outpixbuf, srccols, srcHeight, srcrows, srcWidth

    • 构造方法摘要

      构造方法
      Constructor 描述
      AreaAveragingScaleFilter​(int width, int height)
      构造一个AreaAveragingScaleFilter，可以根据width和height参数指定的其源图像的像素进行缩放。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void setHints​(int hints)
      检测数据是否具有必要的提示，以允许平均算法执行其工作。
      void setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      将传送的字节像素的组件合并到累加数组中，并发送完整像素行的任何平均数据。
      void setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      将传递的int像素的组件合并到累积数组中，并发送完整像素行的任何平均数据。

      • Methods inherited from class java.awt.image.ImageFilter

        clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setColorModel

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.image.ReplicateScaleFilter

        setDimensions, setProperties

    • 构造方法详细信息

      • AreaAveragingScaleFilter

        public AreaAveragingScaleFilter​(int width,
                                int height)
        构造一个AreaAveragingScaleFilter，可以根据width和height参数指定的其源图像的像素进行缩放。
        参数
        width - 缩放图像的目标宽度
        height - 缩放图像的目标高度

    • 方法详细信息

      • setHints

        public void setHints​(int hints)
        检测数据是否具有必要的提示，以允许平均算法执行其工作。

        注意：此方法的目的是由被过滤像素的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setHints在接口 ImageConsumer
        重写：
        setHints在 ImageFilter
        参数
        hints - ImageConsumer用于处理像素的一组提示
        另请参见：
        ImageConsumer.setHints(int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
        将传送的字节像素的组件合并到累加数组中，并发送完整像素行的任何平均数据。 如果在setHints调用中没有指定正确的提示，那么将工作中继到我们的超类，该类可以缩放像素，而不考虑传递提示。

        注意：此方法的目的是由要ImageProducer像素进行过滤的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels中的 ReplicateScaleFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - pixels阵列的偏移量
        scansize - pixels阵列中从一行像素到下一个像素的距离
        另请参见：
        ReplicateScaleFilter

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
        将传递的int像素的组件合并到累积数组中，并发送完整像素行的任何平均数据。 如果在setHints调用中没有指定正确的提示，那么将工作中继到我们的超类，该类可以缩放像素，而不考虑传递提示。

        注意：此方法的目的是通过其像素被过滤的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels中的 ReplicateScaleFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 对 pixels数组的偏移量
        scansize - pixels数组中的一行像素到下一行的距离
        另请参见：
        ReplicateScaleFilter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BandCombineOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class BandCombineOp

  • java.lang.Object
    • java.awt.image.BandCombineOp
  • All Implemented Interfaces:
    RasterOp

    public class BandCombineOp
extends Object
implements RasterOp
    该类使用指定的矩阵在Raster执行带的任意线性组合。

    矩阵的宽度必须等于源Raster中带的数量，可选地加上一个。 如果矩阵中有多一列比带数多，则表示像素的带样本向量的结尾处隐含1。 矩阵的高度必须等于目的地的频带数。

    例如，3 Raster可能会将以下变换应用于每个像素，以反转Raster的第二个波段。

      [ 1.0   0.0   0.0    0.0  ]     [ b1 ]
   [ 0.0  -1.0   0.0  255.0  ]  x  [ b2 ]
   [ 0.0   0.0   1.0    0.0  ]     [ b3 ]
                                   [ 1 ]

    请注意，源和目的地可以是同一个对象。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BandCombineOp​(float[][] matrix, RenderingHints hints)
      构造具有指定矩阵的 BandCombineOp 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      WritableRaster createCompatibleDestRaster​(Raster src)
      创建带有正确大小和频带数的归零目的地 Raster 。
      WritableRaster filter​(Raster src, WritableRaster dst)
      使用构造函数中指定的矩阵来转换 Raster 。
      Rectangle2D getBounds2D​(Raster src)
      返回已转换目的地的边界框。
      float[][] getMatrix​()
      返回线性组合矩阵的副本。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源 Raster给定点的对应目标点的位置。
      RenderingHints getRenderingHints​()
      返回此操作的呈现提示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BandCombineOp

        public BandCombineOp​(float[][] matrix,
                     RenderingHints hints)
        用指定的矩阵构造一个BandCombineOp 。 矩阵的宽度必须等于源Raster的带的数量，可选地加上一个。 如果矩阵中有多一列比带数多，则表示像素的带样本向量的结尾处隐含1。 矩阵的高度必须等于目的地的频带数。

        第一个下标是行索引，第二个是列索引。 此操作不使用当前定义的渲染提示; RenderingHints参数可以为null。

        参数
        matrix - 用于频带组合操作的矩阵。
        hints - 此操作的RenderingHints对象。 目前不使用，因此可以为null。

    • 方法详细信息

      • getMatrix

        public final float[][] getMatrix​()
        返回线性组合矩阵的副本。
        结果
        与该频带相关联的矩阵组合操作。

      • filter

        public WritableRaster filter​(Raster src,
                             WritableRaster dst)
        使用构造函数中指定的矩阵转换Raster 。 如果源或目的地的频带数与矩阵不兼容，则可能会抛出IllegalArgumentException 。 有关详细信息，请参阅课堂意见。

        如果目的地为空，则将创建具有等于矩阵中行数的频带数。 如果操作导致数据溢出，则不会抛出异常。

        Specified by:
        filter在接口 RasterOp
        参数
        src - 要过滤的 Raster 。
        dst - Raster中存储过滤器操作的结果。
        结果
        过滤后的 Raster 。
        异常
        IllegalArgumentException - 如果源或目的地中的频带数与矩阵不兼容。

      • getBounds2D

        public final Rectangle2D getBounds2D​(Raster src)
        返回已转换目的地的边界框。 由于这不是几何操作，所以边界框对于源和目的地是相同的。 如果源中的频带数与矩阵不兼容，则可能会抛出一个IllegalArgumentException 。 有关详细信息，请参阅课堂意见。
        Specified by:
        getBounds2D在接口 RasterOp
        参数
        src - 要过滤的 Raster 。
        结果
        Rectangle2D代表目的地图像的边界框。
        异常
        IllegalArgumentException - 如果源中的条带数与矩阵不兼容。

      • createCompatibleDestRaster

        public WritableRaster createCompatibleDestRaster​(Raster src)
        创建带有正确大小和频带数的归零目的地Raster 。 如果源中的频带数与矩阵不兼容，则可能会抛出一个IllegalArgumentException 。 有关详细信息，请参阅课堂意见。
        Specified by:
        createCompatibleDestRaster在接口 RasterOp
        参数
        src - 要过滤的 Raster 。
        结果
        零目的地 Raster 。

      • getPoint2D

        public final Point2D getPoint2D​(Point2D srcPt,
                                Point2D dstPt)
        返回源Raster给定点的对应目标点的位置。 如果指定了dstPt ，则用于保存返回值。 由于这不是几何操作，返回的点与指定的srcPt相同。
        Specified by:
        getPoint2D在接口 RasterOp
        参数
        srcPt -该 Point2D表示在源点 Raster
        dstPt - 存储结果的 Point2D 。
        结果
        目标图像中的 Point2D对应于源图像中的指定点。

      • getRenderingHints

        public final RenderingHints getRenderingHints​()
        返回此操作的呈现提示。
        Specified by:
        getRenderingHints在接口 RasterOp
        结果
        The RenderingHints object associated with this operation. Returns null if no hints have been set.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BandedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class BandedSampleModel

  • java.lang.Object
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
        • java.awt.image.BandedSampleModel

  • public final class BandedSampleModel
extends ComponentSampleModel
    该类表示以频带交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。 它对ComponentSampleModel进行子类化，但提供了一种比ComponentSampleModel提供的访问频带交错图像数据更有效的实现。 通常在使用存储DataBuffer不同库中每个频段的样本数据的图像时，应使用该类。 提供访问方法，以便可以直接操纵图像数据。 像素幅度是同一扫描线上同一频带的两个样本之间的数据数组元素数。 BandedSampleModel的像素步幅是一个。 扫描线步幅是给定样本与下一个扫描线同一列中相应样本之间的数据数组元素数。 带偏移表示来自保持每个频带的DataBuffer组的第一数据阵列元素到该频带的第一个样本的数据数组元素的数量。 频带从0到N-1编号。 存储体索引表示数据缓冲器的存储体与图像数据的区段之间的对应关系。 该类支持TYPE_BYTE ， TYPE_USHORT ， TYPE_SHORT ， TYPE_INT ， TYPE_FLOAT ，并TYPE_DOUBLE个数据类型

    • Field Summary

      • Fields inherited from class java.awt.image.ComponentSampleModel

        bandOffsets, bankIndices, numBands, numBanks, pixelStride, scanlineStride

      • Fields inherited from class java.awt.image.SampleModel

        dataType, height, width

    • 构造方法摘要

      构造方法
      Constructor 描述
      BandedSampleModel​(int dataType, int w, int h, int numBands)
      构造带指定参数的BandedSampleModel。
      BandedSampleModel​(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets)
      构造带指定参数的BandedSampleModel。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建一个带有指定宽度和高度的新的BandedSampleModel。
      DataBuffer createDataBuffer​()
      创建对应于此BandedSampleModel的DataBuffer，DataBuffer的数据类型，数量和大小将与此BandedSampleModel一致。
      SampleModel createSubsetSampleModel​(int[] bands)
      创建一个带有BandedSampleModel的带子集的新BandedSampleModel。
      Object getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      int[] getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的所有样本。
      int[] getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的所有样本，每个数据数组元素一个样本。
      int getSample​(int x, int y, int b, DataBuffer data)
      返回为位于（x，y）处的像素的指定带中的样本int。
      double getSampleDouble​(int x, int y, int b, DataBuffer data)
      将位于（x，y）的像素的指定带中的样本返回为双倍。
      float getSampleFloat​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本作为浮点返回。
      int[] getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。
      int hashCode​()
      返回对象的哈希码值。
      void setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。
      void setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用int数组的样本数据来设置DataBuffer中的一个像素。
      void setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void setSample​(int x, int y, int b, double s, DataBuffer data)
      对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。
      void setSample​(int x, int y, int b, float s, DataBuffer data)
      使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。
      void setSample​(int x, int y, int b, int s, DataBuffer data)
      使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。
      void setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。

      • Methods inherited from class java.awt.image.ComponentSampleModel

        equals, getBandOffsets, getBankIndices, getNumDataElements, getOffset, getOffset, getPixelStride, getSampleSize, getSampleSize, getScanlineStride

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.image.SampleModel

        getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSamples, setSamples

    • 构造方法详细信息

      • BandedSampleModel

        public BandedSampleModel​(int dataType,
                         int w,
                         int h,
                         int numBands)
        构造带指定参数的BandedSampleModel。 像素步幅将是一个数据元素。 扫描线步幅将与宽度相同。 每个频带将被存储在一个单独的存储区中，并且所有频带偏移将为零。
        参数
        dataType - 存储样本的数据类型。
        w - 描述的图像数据区域的宽度（以像素为单位）。
        h - 描述的图像数据区域的高度（以像素为单位）。
        numBands - 图像数据的频带数。
        异常
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

      • BandedSampleModel

        public BandedSampleModel​(int dataType,
                         int w,
                         int h,
                         int scanlineStride,
                         int[] bankIndices,
                         int[] bandOffsets)
        构造带指定参数的BandedSampleModel。 频带数将从bandOffsets bankIndices数组的长度推断出来，该数组必须相等。 像素步幅将是一个数据元素。
        参数
        dataType - 存储样品的数据类型。
        w - 描述的图像数据区域的宽度（以像素为单位）。
        h - 描述的图像数据区域的高度（以像素为单位）。
        scanlineStride - 图像数据的行走。
        bankIndices - 每个乐队的银行指数。
        bandOffsets - 每个乐队的乐队偏移。
        异常
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

    • 方法详细信息

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建一个带有指定宽度和高度的新的BandedSampleModel。 新的BandedSampleModel将具有与BandedSampleModel相同数量的频带，存储数据类型和银行索引。 频带偏移将被压缩，使得频带之间的偏移将为w * pixelStride，并且所有频带偏移的最小值为零。
        重写：
        createCompatibleSampleModel在 ComponentSampleModel
        参数
        w - 所得的宽度 BandedSampleModel
        h - 所得的高度 BandedSampleModel
        结果
        一个新的 BandedSampleModel具有指定的宽度和高度。
        异常
        IllegalArgumentException - 如果 w或 h等于 Integer.MAX_VALUE或 Integer.MIN_VALUE
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

      • createSubsetSampleModel

        public SampleModel createSubsetSampleModel​(int[] bands)
        创建一个带有BandedSampleModel的带子集的新BandedSampleModel。 新的BandedSampleModel可以与现有的BandedSampleModel可以一起使用的任何DataBuffer使用。 新的BandedSampleModel / DataBuffer组合将表示具有原始BandedSampleModel / DataBuffer组合的频带子集的图像。
        重写：
        createSubsetSampleModel在 ComponentSampleModel
        参数
        bands - 来自这个 ComponentSampleModel的乐队的一个子集
        结果
        一个 ComponentSampleModel用这个 ComponentSampleModel的带子子集创建。
        异常
        RasterFormatException - 如果带的数量大于此样本模型中的银行数量。
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

      • createDataBuffer

        public DataBuffer createDataBuffer​()
        创建对应于此BandedSampleModel的DataBuffer，DataBuffer的数据类型，数量和大小将与此BandedSampleModel一致。
        重写：
        createDataBuffer在 ComponentSampleModel
        结果
        一个 DataBuffer其数据类型，数量和大小与此 ComponentSampleModel一致。
        异常
        IllegalArgumentException - 如果 dataType不是支持的类型之一。

      • getDataElements

        public Object getDataElements​(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
        返回TransferType类型的原始数组中单个像素的数据。 对于BandedSampleModel，它将与数据类型相同，每个数组元素将返回一个样本。 一般来说，obj应该以null的形式传入，这样Object将被自动创建，并且将是正确的原始数据类型。

        下面的代码说明从DataBuffer中为一个像素的数据db1 ，其存储布局通过的BandedSampleModel描述bsm1到DataBuffer db2 ，其存储布局通过的BandedSampleModel描述bsm2 。 传输通常比使用getPixel / setPixel更有效率。

          BandedSampleModel bsm1, bsm2;
       DataBufferInt db1, db2;
       bsm2.setDataElements(x, y, bsm1.getDataElements(x, y, null, db1),
                            db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        如果obj不为空，则它应该是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界中，或者如果obj不为空且不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        重写：
        getDataElements在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        obj - 如果非空，则返回像素数据的原始数组。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的数据。
        另请参见：
        setDataElements(int, int, Object, DataBuffer)

      • getPixel

        public int[] getPixel​(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
        返回int数组中指定像素的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getPixel在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        iArray - 如果非空，则返回此数组中的样本
        data - 包含图像数据的DataBuffer
        结果
        指定像素的样本。
        另请参见：
        setPixel(int, int, int[], DataBuffer)

      • getPixels

        public int[] getPixels​(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
        返回int数组中指定的像素矩形的所有样本，每个数据数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getPixels在 ComponentSampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        iArray - 如果非空，则返回此数组中的样本
        data - 包含图像数据的DataBuffer
        结果
        指定区域内像素的样本。
        另请参见：
        setPixels(int, int, int, int, int[], DataBuffer)

      • getSample

        public int getSample​(int x,
                     int y,
                     int b,
                     DataBuffer data)
        返回为位于（x，y）处的像素的指定带中的样本int。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getSample在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        data - 包含图像数据的DataBuffer
        结果
        指定像素中指定频带中的样本。
        另请参见：
        setSample(int, int, int, int, DataBuffer)

      • getSampleFloat

        public float getSampleFloat​(int x,
                            int y,
                            int b,
                            DataBuffer data)
        将位于（x，y）处的像素的指定带中的样本作为浮点返回。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getSampleFloat在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        data - 包含图像数据的DataBuffer
        结果
        表示指定像素的指定频带中的样本的浮点值。

      • getSampleDouble

        public double getSampleDouble​(int x,
                              int y,
                              int b,
                              DataBuffer data)
        将位于（x，y）的像素的指定带中的样本返回为双倍。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getSampleDouble在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        data - 包含图像数据的DataBuffer
        结果
        表示指定像素的指定频带中的样本的双重值。

      • getSamples

        public int[] getSamples​(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
        返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getSamples在 ComponentSampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        b - 乐队返回
        iArray - 如果非空，则返回此数组中的样本
        data - 包含图像数据的DataBuffer
        结果
        在指定区域内的像素的样本。
        另请参见：
        setSamples(int, int, int, int, int, int[], DataBuffer)

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
        从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。 对于BandedSampleModel，它将与数据类型相同，并且每个数组元素都会传输一个样本。

        下面的代码说明从DataBuffer中为一个像素的数据db1 ，其存储布局通过的BandedSampleModel描述bsm1到DataBuffer db2 ，其存储布局通过的BandedSampleModel描述bsm2 。 传输通常比使用getPixel / setPixel更有效率。

          BandedSampleModel bsm1, bsm2;
       DataBufferInt db1, db2;
       bsm2.setDataElements(x, y, bsm1.getDataElements(x, y, null, db1),
                            db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        obj必须是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界，或者如果obj不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        重写：
        setDataElements在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        obj - 如果非空，则返回此对象中的原始数组
        data - 包含图像数据的DataBuffer
        另请参见：
        getDataElements(int, int, Object, DataBuffer)

      • setPixel

        public void setPixel​(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
        使用int数组的样本数据来设置DataBuffer中的一个像素。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setPixel在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        iArray - int数组中的输入样本
        data - 包含图像数据的DataBuffer
        另请参见：
        getPixel(int, int, int[], DataBuffer)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
        从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setPixels在 ComponentSampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        iArray - int数组中的输入样本
        data - 包含图像数据的DataBuffer
        另请参见：
        getPixels(int, int, int, int, int[], DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
        使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setSample在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队设定
        s - 输入样本为int
        data - 包含图像数据的DataBuffer
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      float s,
                      DataBuffer data)
        使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setSample在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队设置
        s - 输入样本为浮点数
        data - 包含图像数据的DataBuffer
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      double s,
                      DataBuffer data)
        对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setSample在 ComponentSampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队设置
        s - 输入样本为双倍
        data - 包含图像数据的DataBuffer
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
        从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setSamples在 ComponentSampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        b - 乐队设置
        iArray - 输入样本数组
        data - 包含图像数据的DataBuffer
        另请参见：
        getSamples(int, int, int, int, int, int[], DataBuffer)

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 ComponentSampleModel
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BaseMultiResolutionImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class BaseMultiResolutionImage

  • java.lang.Object
    • java.awt.Image
      • java.awt.image.AbstractMultiResolutionImage
        • java.awt.image.BaseMultiResolutionImage
  • All Implemented Interfaces:
    MultiResolutionImage

    public class BaseMultiResolutionImage
extends AbstractMultiResolutionImage
    这个类是基于数组的AbstractMultiResolutionImage类的实现。 该类将使用简单的算法实现getResolutionVariant(double destImageWidth, double destImageHeight)方法，该算法将返回足够大以满足呈现请求的数组中的第一个图像变体。 如果没有找到与渲染请求一样大的合适图像，则将返回数组中的最后一个图像。

    为了获得最佳效果，图像阵列应该被分类，每个图像都比以前的图像更宽和更高。 基本图像不必是阵列中的第一个图像。 如果图像未按建议排序，则不会抛出异常。

    从以下版本开始：
    9
    另请参见：
    Image ， MultiResolutionImage ， AbstractMultiResolutionImage

    • Field Summary

      • Fields inherited from class java.awt.Image

        accelerationPriority, SCALE_AREA_AVERAGING, SCALE_DEFAULT, SCALE_FAST, SCALE_REPLICATE, SCALE_SMOOTH, UndefinedProperty

    • 构造方法摘要

      构造方法
      Constructor 描述
      BaseMultiResolutionImage​(int baseImageIndex, Image... resolutionVariants)
      使用给定的基本图像索引和分辨率变体创建多分辨率图像。
      BaseMultiResolutionImage​(Image... resolutionVariants)
      使用给定的分辨率变体创建多分辨率图像。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Image getBaseImage​()
      返回表示最佳版本的图像的基本图像，以便以默认的宽度和高度渲染。
      Image getResolutionVariant​(double destImageWidth, double destImageHeight)
      获取一个特定的图像，这是以指定大小表示该逻辑图像的最佳变体。
      List<Image> getResolutionVariants​()
      获取所有分辨率变体的可读列表。

      • Methods inherited from class java.awt.image.AbstractMultiResolutionImage

        getGraphics, getHeight, getProperty, getSource, getWidth

      • Methods inherited from class java.awt.Image

        flush, getAccelerationPriority, getCapabilities, getScaledInstance, setAccelerationPriority

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BaseMultiResolutionImage

        public BaseMultiResolutionImage​(Image... resolutionVariants)
        使用给定的分辨率变体创建多分辨率图像。 第一个分辨率变体用作基本图像。
        参数
        resolutionVariants - 按图像大小排序的分辨率变体数组
        异常
        IllegalArgumentException - 如果null或零长度数组被传递
        NullPointerException - 如果指定的 resolutionVariants包含一个或多个空元素
        从以下版本开始：
        9

      • BaseMultiResolutionImage

        public BaseMultiResolutionImage​(int baseImageIndex,
                                Image... resolutionVariants)
        使用给定的基本图像索引和分辨率变体创建多分辨率图像。
        参数
        baseImageIndex - 分辨率变体数组中基本图像的索引
        resolutionVariants - 按图像大小排序的分辨率变体数组
        异常
        IllegalArgumentException - 如果null或零长度数组被传递
        NullPointerException - 如果指定的 resolutionVariants包含一个或多个空元素
        IndexOutOfBoundsException - 如果 baseImageIndex为负数或大于或等于 resolutionVariants长度。
        从以下版本开始：
        9

    • 方法详细信息

      • getResolutionVariant

        public Image getResolutionVariant​(double destImageWidth,
                                  double destImageHeight)
        描述从接口MultiResolutionImage复制
        获取一个特定的图像，这是以指定大小表示该逻辑图像的最佳变体。
        参数
        destImageWidth - 目标图像的宽度，以像素为单位。
        destImageHeight - 目标图像的高度，以像素为单位。
        结果
        图像分辨率变体。

      • getResolutionVariants

        public List<Image> getResolutionVariants​()
        描述从接口MultiResolutionImage复制
        获取所有分辨率变体的可读列表。 该列表必须非空，并且至少包含一个分辨率变体。

        请注意，许多实现可能会返回一个不可修改的列表。

        结果
        分辨率变体列表。

      • getBaseImage

        protected Image getBaseImage​()
        说明从类别复制： AbstractMultiResolutionImage
        返回表示最佳版本的图像的基本图像，以便以默认的宽度和高度渲染。
        Specified by:
        getBaseImage在 AbstractMultiResolutionImage
        结果
        一组多分辨率图像的基本图像
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferedImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class BufferedImage

  • java.lang.Object
    • java.awt.Image
      • java.awt.image.BufferedImage
  • All Implemented Interfaces:
    RenderedImage ， WritableRenderedImage ， Transparency

    public class BufferedImage
extends Image
implements WritableRenderedImage, Transparency
    BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。 A BufferedImage由ColorModel和Raster的图像数据组成。 Raster的SampleModel中的Raster数量和类型必须与ColorModel要求的数字和类型相匹配，以表示其颜色和Alpha组件。 全部BufferedImage对象的左上角坐标为（0,0）。 Raster用于构建BufferedImage任何Raster必须具有minX = 0和minY = 0。

    这个类依赖的数据获取和设置方法Raster ，并在颜色表征方法ColorModel 。

    另请参见：
    ColorModel ， Raster ， WritableRaster

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int TYPE_3BYTE_BGR
      表示具有8位RGB颜色分量的图像，对应于Windows风格的BGR颜色模型），蓝色，绿色和红色以3个字节存储。
      static int TYPE_4BYTE_ABGR
      表示具有蓝色，绿色和红色的8位RGBA颜色分量的图像，存储在3个字节和1个字节的alpha中。
      static int TYPE_4BYTE_ABGR_PRE
      表示具有蓝色，绿色和红色的8位RGBA颜色分量的图像，存储在3个字节和1个字节的alpha中。
      static int TYPE_BYTE_BINARY
      表示不透明的字节打包的1,2或4位图像。
      static int TYPE_BYTE_GRAY
      表示无符号字节灰度图像，无索引。
      static int TYPE_BYTE_INDEXED
      表示索引的字节图像。
      static int TYPE_CUSTOM
      图像类型无法识别，因此它必须是自定义图像。
      static int TYPE_INT_ARGB
      表示具有8位RGBA颜色成分的整数像素的图像。
      static int TYPE_INT_ARGB_PRE
      表示具有8位RGBA颜色成分的整数像素的图像。
      static int TYPE_INT_BGR
      表示具有8位RGB颜色分量的图像，对应于Windows或Solaris样式的BGR颜色模型，蓝色，绿色和红色颜色打包成整数像素。
      static int TYPE_INT_RGB
      表示具有8位RGB颜色分量的整数像素的图像。
      static int TYPE_USHORT_555_RGB
      表示5-5-5 RGB颜色分量（5位红色，5位绿色，5位蓝色）的图像，无alpha。
      static int TYPE_USHORT_565_RGB
      表示具有5-6-5 RGB颜色分量（5位红色，6位绿色，5位蓝色），无alpha的图像。
      static int TYPE_USHORT_GRAY
      表示无符号短灰度图像，非索引）。

      • Fields inherited from class java.awt.Image

        accelerationPriority, SCALE_AREA_AVERAGING, SCALE_DEFAULT, SCALE_FAST, SCALE_REPLICATE, SCALE_SMOOTH, UndefinedProperty

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferedImage​(int width, int height, int imageType)
      构造一个预定义的图像类型的 BufferedImage 。
      BufferedImage​(int width, int height, int imageType, IndexColorModel cm)
      构造一个预定义的图像类型的一个 BufferedImage ：TYPE_BYTE_BINARY或TYPE_BYTE_INDEXED。
      BufferedImage​(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
      构造一个新的 BufferedImage与指定的 ColorModel和 Raster 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addTileObserver​(TileObserver to)
      添加瓦片观察器。
      void coerceData​(boolean isAlphaPremultiplied)
      强制数据匹配 isAlphaPremultiplied变量中指定的状态。
      WritableRaster copyData​(WritableRaster outRaster)
      计算 BufferedImage的任意矩形区域，并将其复制到指定的 WritableRaster 。
      Graphics2D createGraphics​()
      创建一个 Graphics2D ，可以用来绘制这个 BufferedImage 。
      WritableRaster getAlphaRaster​()
      返回一个 WritableRaster表示 BufferedImage对象的alpha通道，其中 ColorModel对象支持单独的空间Alpha通道，如 ComponentColorModel和 DirectColorModel 。
      ColorModel getColorModel​()
      返回 ColorModel 。
      Raster getData​()
      将图像返回为一个大图块。
      Raster getData​(Rectangle rect)
      计算并返回 BufferedImage的任意区域。
      Graphics getGraphics​()
      此方法返回一个Graphics2D ，但这里是向后兼容性。
      int getHeight​()
      返回 BufferedImage的高度。
      int getHeight​(ImageObserver observer)
      返回 BufferedImage的高度。
      int getMinTileX​()
      返回x方向上的最小拼贴索引。
      int getMinTileY​()
      返回y方向上的最小瓦片索引。
      int getMinX​()
      返回此 BufferedImage的最小x坐标。
      int getMinY​()
      返回此 BufferedImage的最小y坐标。
      int getNumXTiles​()
      返回x方向上的图块数。
      int getNumYTiles​()
      返回y方向上的图块数。
      Object getProperty​(String name)
      按名称返回图像的属性。
      Object getProperty​(String name, ImageObserver observer)
      按名称返回图像的属性。
      String[] getPropertyNames​()
      如果未识别到属性名称，则返回由 getProperty(String)或 null识别的名称数组。
      WritableRaster getRaster​()
      返回WritableRaster 。
      int getRGB​(int x, int y)
      返回默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素。
      int[] getRGB​(int startX, int startY, int w, int h, int[] rgbArray, int offset, int scansize)
      从图像数据的一部分返回默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素数组。
      SampleModel getSampleModel​()
      返回 SampleModel与此相关 BufferedImage 。
      ImageProducer getSource​()
      返回产生图像像素的对象。
      Vector<RenderedImage> getSources​()
      返回Vector的RenderedImage对象是直接来源，而不是这些直接来源的来源，该图像数据的BufferedImage 。
      BufferedImage getSubimage​(int x, int y, int w, int h)
      返回由指定的矩形区域定义的子图像。
      Raster getTile​(int tileX, int tileY)
      返回瓦（ tileX ， tileY ）。
      int getTileGridXOffset​()
      返回瓦片网格相对于原点的x偏移量，例如，tile（0，0）的位置的x坐标。
      int getTileGridYOffset​()
      返回瓦片网格相对于原点的y偏移量，例如，tile（0,0）的位置的y坐标。
      int getTileHeight​()
      返回瓷砖高度（像素）。
      int getTileWidth​()
      返回瓷砖宽度（以像素为单位）
      int getTransparency​()
      返回透明度。
      int getType​()
      返回图像类型。
      int getWidth​()
      返回 BufferedImage的宽度。
      int getWidth​(ImageObserver observer)
      返回 BufferedImage的宽度。
      WritableRaster getWritableTile​(int tileX, int tileY)
      检查一个瓦片写作。
      Point[] getWritableTileIndices​()
      返回一个Point个对象的数组，指示哪些图块被签出用于写入。
      boolean hasTileWriters​()
      返回是否检出任何图块以进行写入。
      boolean isAlphaPremultiplied​()
      返回alpha是否被预乘。
      boolean isTileWritable​(int tileX, int tileY)
      返回是否当前签出拼贴以进行书写。
      void releaseWritableTile​(int tileX, int tileY)
      放弃写入瓦片的权限。
      void removeTileObserver​(TileObserver to)
      移除瓦片观察者。
      void setData​(Raster r)
      将图像的矩形区域设置为指定的 Raster r的内容，假定它与 BufferedImage在同一坐标空间中。
      void setRGB​(int x, int y, int rgb)
      将此 BufferedImage的像素设置为指定的RGB值。
      void setRGB​(int startX, int startY, int w, int h, int[] rgbArray, int offset, int scansize)
      将默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素数组设置为图像数据的一部分。
      String toString​()
      返回此 BufferedImage对象及其值的 String表示。

      • Methods inherited from class java.awt.Image

        flush, getAccelerationPriority, getCapabilities, getScaledInstance, setAccelerationPriority

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TYPE_CUSTOM

        public static final int TYPE_CUSTOM
        图像类型无法识别，因此它必须是自定义图像。 此类型仅用作getType（）方法的返回值。
        另请参见：
        Constant Field Values

      • TYPE_INT_RGB

        public static final int TYPE_INT_RGB
        表示具有8位RGB颜色分量的整数像素的图像。 该图像有一个DirectColorModel没有alpha。 当具有非不透明alpha的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘式格式，并将alpha丢弃，如AlphaComposite文档中所述。
        另请参见：
        Constant Field Values

      • TYPE_INT_ARGB

        public static final int TYPE_INT_ARGB
        表示具有8位RGBA颜色成分的整数像素的图像。 图像有一个DirectColorModel与alpha。 该图像中的颜色数据被认为不被alpha预付。 当此类型用作BufferedImage构造函数的imageType参数时，创建的映像与JDK1.1及更早版本中创建的映像一致。
        另请参见：
        Constant Field Values

      • TYPE_INT_ARGB_PRE

        public static final int TYPE_INT_ARGB_PRE
        表示具有8位RGBA颜色成分的整数像素的图像。 该图像有一个DirectColorModel与alpha。 该图像中的颜色数据被认为是用alpha预乘。
        另请参见：
        Constant Field Values

      • TYPE_INT_BGR

        public static final int TYPE_INT_BGR
        表示具有8位RGB颜色分量的图像，对应于Windows或Solaris样式的BGR颜色模型，蓝色，绿色和红色颜色打包成整数像素。 没有阿尔法 图像有一个DirectColorModel 。 当具有非不透明alpha的数据存储在这种类型的图像中时，颜色数据必须调整为非预乘形式，并将alpha丢弃，如AlphaComposite文档中所述。
        另请参见：
        Constant Field Values

      • TYPE_3BYTE_BGR

        public static final int TYPE_3BYTE_BGR
        表示具有8位RGB颜色分量的图像，对应于Windows风格的BGR颜色模型），蓝色，绿色和红色以3个字节存储。 没有阿尔法 图像有一个ComponentColorModel 。 当具有非不透明alpha的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式，并将alpha丢弃，如AlphaComposite文档中所述。
        另请参见：
        Constant Field Values

      • TYPE_4BYTE_ABGR

        public static final int TYPE_4BYTE_ABGR
        表示具有蓝色，绿色和红色的8位RGBA颜色分量的图像，存储在3个字节和1个字节的alpha中。 图像有一个ComponentColorModel与alpha。 该图像中的颜色数据被认为不被alpha预付。 字节数据按照A，B，G，R中的单字节数组交错，从每个像素内的低字节到高字节地址。
        另请参见：
        Constant Field Values

      • TYPE_4BYTE_ABGR_PRE

        public static final int TYPE_4BYTE_ABGR_PRE
        表示具有蓝色，绿色和红色的8位RGBA颜色分量的图像，存储在3个字节和1个字节的alpha中。 该图像有一个ComponentColorModel与alpha。 该图像中的颜色数据被认为是用alpha预乘。 字节数据按照A，B，G，R中的单字节数组交错，从每个像素内的低字节到高字节地址。
        另请参见：
        Constant Field Values

      • TYPE_USHORT_565_RGB

        public static final int TYPE_USHORT_565_RGB
        表示具有5-6-5 RGB颜色分量（5位红色，6位绿色，5位蓝色），无alpha的图像。 这张图片有一个DirectColorModel 。 当具有非不透明alpha的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式，并将alpha丢弃，如AlphaComposite文档中所述。
        另请参见：
        Constant Field Values

      • TYPE_USHORT_555_RGB

        public static final int TYPE_USHORT_555_RGB
        表示5-5-5 RGB颜色分量（5位红色，5位绿色，5位蓝色）的图像，无alpha。 这张图片有一个DirectColorModel 。 当具有非不透明alpha的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式，并将alpha丢弃，如AlphaComposite文档中所述。
        另请参见：
        Constant Field Values

      • TYPE_BYTE_GRAY

        public static final int TYPE_BYTE_GRAY
        表示无符号字节灰度图像，无索引。 这张图片有一个ComponentColorModel与CS_GRAY ColorSpace 。 当具有非不透明alpha的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃alpha，如AlphaComposite文档中所述。
        另请参见：
        Constant Field Values

      • TYPE_USHORT_GRAY

        public static final int TYPE_USHORT_GRAY
        表示无符号短灰度图像，非索引）。 这张图片有一个ComponentColorModel与CS_GRAY ColorSpace 。 当具有非不透明alpha的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式，并将alpha丢弃，如AlphaComposite文档中所述。
        另请参见：
        Constant Field Values

      • TYPE_BYTE_BINARY

        public static final int TYPE_BYTE_BINARY
        表示不透明的字节打包的1,2或4位图像。 该图像有一个IndexColorModel没有alpha。 当此类型用作BufferedImage构造函数的imageType参数，该参数为imageType参数但不ColorModel参数时，将使用默认sRGB ColorSpace中的两个颜色的IndexColorModel创建1位图像：{0,0,0 {255，255，255}。

        可以通过BufferedImage构造函数构建具有2或4位像素的图像，通过提供ColorModel具有适当的地图大小来获取ColorModel参数。

        每像素8位的图像应使用图像类型TYPE_BYTE_INDEXED或TYPE_BYTE_GRAY具体取决于它们的ColorModel 。

        当颜色数据存储在这种类型的图像中时，色彩映射中最接近的颜色由IndexColorModel确定，并且存储结果索引。 根据IndexColorModel色彩中的颜色，可能会导致Alpha或颜色成分的近似和损失。

        另请参见：
        Constant Field Values

      • TYPE_BYTE_INDEXED

        public static final int TYPE_BYTE_INDEXED
        表示索引的字节图像。 当这种类型的被用作imageType参数传递给BufferedImage构造函数的imageType参数，但没有ColorModel参数，一个IndexColorModel与和颜色从216-255其余部分的256色6/6/6颜色立方体调色板创建在默认sRGB ColorSpace中由灰度值填充。

        当颜色数据存储在这种类型的图像中时，色彩映射中最近的颜色由IndexColorModel确定，并且生成的索引被存储。 根据IndexColorModel色彩中的颜色，可能会导致近似和损失的alpha或颜色成分。

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BufferedImage

        public BufferedImage​(int width,
                     int height,
                     int imageType)
        构造一个预定义图像类型的BufferedImage 。 图像的ColorSpace是默认的sRGB空间。
        参数
        width - 创建的图像的宽度
        height - 创建的图像的高度
        imageType - 创建的图像的类型
        另请参见：
        ColorSpace ， TYPE_INT_RGB ， TYPE_INT_ARGB ， TYPE_INT_ARGB_PRE ， TYPE_INT_BGR ， TYPE_3BYTE_BGR ， TYPE_4BYTE_ABGR ， TYPE_4BYTE_ABGR_PRE ， TYPE_BYTE_GRAY ， TYPE_USHORT_GRAY ， TYPE_BYTE_BINARY ， TYPE_BYTE_INDEXED ， TYPE_USHORT_565_RGB ， TYPE_USHORT_555_RGB

      • BufferedImage

        public BufferedImage​(int width,
                     int height,
                     int imageType,
                     IndexColorModel cm)
        构造一个BufferedImage的预定义图像类型之一：TYPE_BYTE_BINARY或TYPE_BYTE_INDEXED。

        如果图像类型为TYPE_BYTE_BINARY，则颜色模型中的条目数用于确定图像是否应具有每像素1位，2位或4位。 如果颜色模型有1或2个条目，则图像将具有每像素1位。 如果它有3或4个条目，则每个像素具有2位的图像。 如果它有5到16个条目，图像将具有每像素4位。 否则，将抛出IllegalArgumentException。

        参数
        width - 创建的图像的宽度
        height - 创建的图像的高度
        imageType - 创建的图像的类型
        cm - 创建的图像的 IndexColorModel
        异常
        IllegalArgumentException - 如果imageType不是TYPE_BYTE_BINARY或TYPE_BYTE_INDEXED，或者如果imageType是TYPE_BYTE_BINARY，并且颜色映射有超过16个条目。
        另请参见：
        TYPE_BYTE_BINARY ， TYPE_BYTE_INDEXED

      • BufferedImage

        public BufferedImage​(ColorModel cm,
                     WritableRaster raster,
                     boolean isRasterPremultiplied,
                     Hashtable<?,?> properties)
        构造一个新的BufferedImage与指定的ColorModel和Raster 。 如果带在数量和类型SampleModel所述的Raster不匹配的数量和由所要求的类型ColorModel表示其颜色和alpha分量，一个RasterFormatException被抛出。 这种方法可以乘或除的颜色Raster通过阿尔法数据到匹配alphaPremultiplied状态在ColorModel 。 此属性BufferedImage可以通过传递建立Hashtable的String / Object对。
        参数
        cm - ColorModel的新图像
        raster - Raster用于图像数据
        isRasterPremultiplied - 如果是 true ，则栅格中的数据已经被alpha预取。
        properties - Hashtable的 String / Object对。
        异常
        RasterFormatException -如果频带中的数量和类型 SampleModel所述的 Raster不匹配的数量和由所要求的类型 ColorModel表示其颜色和alpha分量。
        IllegalArgumentException - 如果 raster与 cm不兼容
        另请参见：
        ColorModel ， Raster ， WritableRaster

    • 方法详细信息

      • getType

        public int getType​()
        返回图像类型。 如果它不是已知类型之一，则返回TYPE_CUSTOM。
        结果
        该图像类型为 BufferedImage 。
        另请参见：
        TYPE_INT_RGB ， TYPE_INT_ARGB ， TYPE_INT_ARGB_PRE ， TYPE_INT_BGR ， TYPE_3BYTE_BGR ， TYPE_4BYTE_ABGR ， TYPE_4BYTE_ABGR_PRE ， TYPE_BYTE_GRAY ， TYPE_BYTE_BINARY ， TYPE_BYTE_INDEXED ， TYPE_USHORT_GRAY ， TYPE_USHORT_565_RGB ， TYPE_USHORT_555_RGB ， TYPE_CUSTOM

      • getColorModel

        public ColorModel getColorModel​()
        返回 ColorModel 。
        Specified by:
        getColorModel在接口 RenderedImage
        结果
        这 ColorModel的 BufferedImage 。

      • getRaster

        public WritableRaster getRaster​()
        返回WritableRaster 。
        结果
        这 WritableRaster的 BufferedImage 。

      • getAlphaRaster

        public WritableRaster getAlphaRaster​()
        返回一个WritableRaster表示BufferedImage对象的alpha通道，其中ColorModel对象支持单独的空间alpha通道，如ComponentColorModel和DirectColorModel 。 如果没有与此图像中的ColorModel相关联的Alpha通道，则返回null 。 此方法假设所有ColorModel比其他对象IndexColorModel ，如果ColorModel支持alpha，存在被存储为图像数据的最后一个频带的单独alpha通道。 如果图像在查找表中使用了一个IndexColorModel ，该方法返回null因为没有空间上离散的alpha通道。 此方法创建一个新的WritableRaster ，但共享数据数组。
        结果
        一个 WritableRaster或 null如果这 BufferedImage没有alpha通道与其 ColorModel相关联。

      • getRGB

        public int getRGB​(int x,
                  int y)
        返回默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素。 如果此默认模型与图像ColorModel不匹配， ColorModel颜色转换。 使用此方法时，返回数据中每个颜色分量的精度只有8位。

        如果坐标不在边界内，则可能抛出ArrayOutOfBoundsException 。 但是，显式边界检查不能保证。

        参数
        x - 从默认RGB颜色模型和sRGB颜色空间中获取像素的像素的X坐标
        y - 从默认RGB颜色模型和sRGB颜色空间中获取像素的像素的Y坐标
        结果
        默认RGB颜色模型中的整数像素和默认的sRGB颜色空间。
        另请参见：
        setRGB(int, int, int) ， setRGB(int, int, int, int, int[], int, int)

      • getRGB

        public int[] getRGB​(int startX,
                    int startY,
                    int w,
                    int h,
                    int[] rgbArray,
                    int offset,
                    int scansize)
        从图像数据的一部分返回默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素数组。 如果默认型号与图像ColorModel不匹配， ColorModel颜色转换。 使用此方法时，返回数据中每个颜色分量的精度只有8位。 使用图像中的指定坐标（x，y），可以以这种方式访问ARGB像素：
          pixel   = rgbArray[offset + (y-startY)*scansize + (x-startX)];

        如果区域不在边界内，则可能会抛出一个ArrayOutOfBoundsException 。 但是，显式边界检查不能保证。

        参数
        startX - 起始X坐标
        startY - 起始Y坐标
        w - 区域宽度
        h - 区域的高度
        rgbArray - 如果不是 null ，这里写入rgb像素
        offset - 偏移到 rgbArray
        scansize - 扫描线步幅为 rgbArray
        结果
        RGB像素阵列。
        另请参见：
        setRGB(int, int, int) ， setRGB(int, int, int, int, int[], int, int)

      • setRGB

        public void setRGB​(int x,
                   int y,
                   int rgb)
        将此BufferedImage的像素设置为指定的RGB值。 假设像素处于默认RGB颜色模型TYPE_INT_ARGB和默认sRGB颜色空间。 对于具有IndexColorModel图像，选择具有最近颜色的索引。

        如果坐标不在边界内，则可能抛出ArrayOutOfBoundsException 。 但是，显式边界检查不能保证。

        参数
        x - 要设置的像素的X坐标
        y - 要设置的像素的Y坐标
        rgb - RGB值
        另请参见：
        getRGB(int, int) ， getRGB(int, int, int, int, int[], int, int)

      • setRGB

        public void setRGB​(int startX,
                   int startY,
                   int w,
                   int h,
                   int[] rgbArray,
                   int offset,
                   int scansize)
        将默认RGB颜色模型（TYPE_INT_ARGB）和默认sRGB颜色空间中的整数像素数组设置为图像数据的一部分。 如果默认型号与图像ColorModel不匹配， ColorModel颜色转换。 使用此方法时，返回数据中每个颜色分量的精度只有8位。 使用此图像中的指定坐标（x，y），可以以这种方式访问ARGB像素：
          pixel   = rgbArray[offset + (y-startY)*scansize + (x-startX)];
        警告：不发生抖动。

        如果区域不在边界范围内，可能会抛出一个ArrayOutOfBoundsException 。 但是，显式边界检查不能保证。

        参数
        startX - 起始X坐标
        startY - 起始Y坐标
        w - 区域的宽度
        h - 区域的高度
        rgbArray - rgb像素
        offset - 偏移到 rgbArray
        scansize - 扫描线步幅为 rgbArray
        另请参见：
        getRGB(int, int) ， getRGB(int, int, int, int, int[], int, int)

      • getWidth

        public int getWidth​()
        返回 BufferedImage的宽度。
        Specified by:
        getWidth在接口 RenderedImage
        结果
        该宽度为 BufferedImage

      • getHeight

        public int getHeight​()
        返回 BufferedImage的高度。
        Specified by:
        getHeight在接口 RenderedImage
        结果
        这个高度这 BufferedImage

      • getWidth

        public int getWidth​(ImageObserver observer)
        返回 BufferedImage的宽度。
        Specified by:
        getWidth在 Image
        参数
        observer - 忽略
        结果
        该宽度为 BufferedImage
        另请参见：
        Image.getHeight(java.awt.image.ImageObserver) ， ImageObserver

      • getHeight

        public int getHeight​(ImageObserver observer)
        返回 BufferedImage的高度。
        Specified by:
        getHeight在 Image
        参数
        observer - 忽略
        结果
        的高度这 BufferedImage
        另请参见：
        Image.getWidth(java.awt.image.ImageObserver) ， ImageObserver

      • getSource

        public ImageProducer getSource​()
        返回产生图像像素的对象。
        Specified by:
        getSource在 Image
        结果
        用于生成此图像的像素的ImageProducer 。
        另请参见：
        ImageProducer

      • getProperty

        public Object getProperty​(String name,
                          ImageObserver observer)
        按名称返回图像的属性。 单个属性名称由各种图像格式定义。 如果未为特定图像定义属性，则此方法返回UndefinedProperty字段。 如果此图像的属性尚未知道，则此方法返回null ，稍后通知ImageObserver对象。 应该使用属性名称“comment”来存储一个可选的注释，该注释可以作为图像，其来源或作者的描述呈现给用户。
        Specified by:
        getProperty在 Image
        参数
        name - 属性名称
        observer - 接收关于图像信息的通知的 ImageObserver
        结果
        一个Object ，如果该图像的属性尚未知道，则是由指定的name或null的属性。
        异常
        NullPointerException - 如果属性名称为空。
        另请参见：
        ImageObserver ， Image.UndefinedProperty

      • getProperty

        public Object getProperty​(String name)
        按名称返回图像的属性。
        Specified by:
        getProperty在接口 RenderedImage
        参数
        name - 属性名称
        结果
        一个 Object是由指定的属性指定的 name 。
        异常
        NullPointerException - 如果属性名称为空。
        另请参见：
        Image.UndefinedProperty

      • getGraphics

        public Graphics getGraphics​()
        此方法返回一个Graphics2D ，但这里是向后兼容性。 createGraphics更方便，因为它被宣布返回一个Graphics2D 。
        Specified by:
        getGraphics在 Image
        结果
        一个 Graphics2D ，可以用来绘制这个图像。
        另请参见：
        Graphics ， Component.createImage(int, int)

      • createGraphics

        public Graphics2D createGraphics​()
        创建一个 Graphics2D ，可以用来绘制这个 BufferedImage 。
        结果
        一个 Graphics2D ，用于绘制这个图像。

      • getSubimage

        public BufferedImage getSubimage​(int x,
                                 int y,
                                 int w,
                                 int h)
        返回由指定的矩形区域定义的子图像。 返回的BufferedImage共享与原始图像相同的数据数组。
        参数
        x - 指定矩形区域左上角的X坐标
        y - 指定矩形区域左上角的Y坐标
        w - 指定矩形区域的宽度
        h - 指定矩形区域的高度
        结果
        一个 BufferedImage这是这个 BufferedImage的子图像。
        异常
        RasterFormatException - 如果指定的区域不包含在此 BufferedImage 。

      • isAlphaPremultiplied

        public boolean isAlphaPremultiplied​()
        返回alpha是否被预乘。 如果没有alpha，它返回false 。
        结果
        true如果alpha已被预乘; 否则为false 。

      • coerceData

        public void coerceData​(boolean isAlphaPremultiplied)
        强制数据匹配isAlphaPremultiplied变量中指定的状态。 它可以将颜色光栅数据乘以或除以alpha，如果数据处于正确状态，则不执行任何操作。
        参数
        isAlphaPremultiplied - true如果alpha已被预乘， 否则为false 。

      • toString

        public String toString​()
        返回此 BufferedImage对象及其值的 String表示。
        重写：
        toString在 Object
        结果
        一个 String代表这 BufferedImage 。

      • getSources

        public Vector<RenderedImage> getSources​()
        返回Vector的RenderedImage对象是直接来源，而不是这些直接来源的来源，该图像数据的BufferedImage 。 如果BufferedImage没有关于其直接来源的信息，此方法返回null 。 如果BufferedImage没有直接的来源，它将返回一个空的Vector 。
        Specified by:
        getSources在接口 RenderedImage
        结果
        一个 Vector包含此的直接来源 BufferedImage对象的图像的日期，或 null如果此 BufferedImage没有关于其直接来源，或空信息 Vector ，如果这 BufferedImage没有直接来源。

      • getPropertyNames

        public String[] getPropertyNames​()
        如果未识别到属性名称，则返回由 getProperty(String)或 null识别的名称数组。
        Specified by:
        getPropertyNames接口 RenderedImage
        结果
        一个包含getProperty(String)识别的所有属性名称的String数组; 或者如果没有属性名称被识别， null 。

      • getMinX

        public int getMinX​()
        返回此BufferedImage的最小x坐标。 这总是为零。
        Specified by:
        getMinX在接口 RenderedImage
        结果
        这个 BufferedImage的最小x坐标。

      • getMinY

        public int getMinY​()
        返回此BufferedImage的最小y坐标。 这总是为零。
        Specified by:
        getMinY在接口 RenderedImage
        结果
        这个 BufferedImage的最小y坐标。

      • getSampleModel

        public SampleModel getSampleModel​()
        返回 SampleModel与此相关 BufferedImage 。
        Specified by:
        getSampleModel在接口 RenderedImage
        结果
        这 SampleModel的 BufferedImage 。

      • getNumXTiles

        public int getNumXTiles​()
        返回x方向上的图块数。 这总是一个。
        Specified by:
        getNumXTiles在接口 RenderedImage
        结果
        在x方向上的瓦片数量。

      • getNumYTiles

        public int getNumYTiles​()
        返回y方向上的图块数。 这总是一个。
        Specified by:
        getNumYTiles在接口 RenderedImage
        结果
        在y方向上的瓦片数量。

      • getMinTileX

        public int getMinTileX​()
        返回x方向上的最小拼贴索引。 这总是为零。
        Specified by:
        getMinTileX在接口 RenderedImage
        结果
        x方向上的最小瓦片索引。

      • getMinTileY

        public int getMinTileY​()
        返回y方向上的最小瓦片索引。 这总是为零。
        Specified by:
        getMinTileY在接口 RenderedImage
        结果
        y方向上的最小瓦片指数。

      • getTileWidth

        public int getTileWidth​()
        返回瓷砖宽度（以像素为单位）
        Specified by:
        getTileWidth在接口 RenderedImage
        结果
        瓦片宽度（以像素为单位）

      • getTileHeight

        public int getTileHeight​()
        返回瓷砖高度（像素）。
        Specified by:
        getTileHeight在接口 RenderedImage
        结果
        瓷砖高度以像素为单位。

      • getTileGridXOffset

        public int getTileGridXOffset​()
        返回瓦片网格相对于原点的x偏移量，例如，tile（0，0）的位置的x坐标。 这总是为零。
        Specified by:
        getTileGridXOffset在接口 RenderedImage
        结果
        瓦片网格的x偏移量。

      • getTileGridYOffset

        public int getTileGridYOffset​()
        返回瓦片网格相对于原点的y偏移量，例如，tile（0,0）的位置的y坐标。 这总是为零。
        Specified by:
        getTileGridYOffset在接口 RenderedImage
        结果
        瓦片网格的y偏移量。

      • getTile

        public Raster getTile​(int tileX,
                      int tileY)
        返回瓦（ tileX ， tileY ）。 请注意， tileX和tileY是tile数组中的索引，而不是像素位置。 返回的Raster是活的，这意味着如果图像被更改，它将被更新。
        Specified by:
        getTile接口 RenderedImage
        参数
        tileX - tile数组中所请求的tile的x索引
        tileY - tile数组中所请求的tile的y索引
        结果
        Raster是由参数 tileX和 tileY定义的瓦片。
        异常
        ArrayIndexOutOfBoundsException - 如果 tileX和 tileY都不等于0

      • getData

        public Raster getData​()
        将图像返回为一个大图块。 Raster返回的图像数据的副本如果图像更改则不更新。
        Specified by:
        getData在接口 RenderedImage
        结果
        一个 Raster是图像数据的副本。
        另请参见：
        setData(Raster)

      • getData

        public Raster getData​(Rectangle rect)
        计算并返回任意区域的BufferedImage 。 返回的Raster是图像数据的副本，如果图像更改，则不会更新。
        Specified by:
        getData接口 RenderedImage
        参数
        rect - 要返回的地区的 BufferedImage 。
        结果
        一个 Raster是 Raster的指定区域的图像数据的 BufferedImage
        另请参见：
        setData(Raster)

      • copyData

        public WritableRaster copyData​(WritableRaster outRaster)
        计算BufferedImage的任意矩形区域，并将其复制到指定的WritableRaster 。 要计算的区域根据指定的WritableRaster的范围确定。 指定的WritableRaster必须具有与此图像兼容的SampleModel 。 如果outRaster是null ，则会创建一个合适的WritableRaster 。
        Specified by:
        copyData在接口 RenderedImage
        参数
        outRaster - 一个 WritableRaster保存图像的返回部分，或 null
        结果
        参考提供或创建的 WritableRaster 。

      • setData

        public void setData​(Raster r)
        将图像的矩形区域设置为指定的Raster r的内容，该内容被假定为与BufferedImage相同的坐标空间。 该操作被限制在BufferedImage的范围内。
        Specified by:
        setData在接口 WritableRenderedImage
        参数
        r - 指定的 Raster
        另请参见：
        getData() ， getData(Rectangle)

      • addTileObserver

        public void addTileObserver​(TileObserver to)
        添加瓦片观察器。 如果观察者已经存在，它会收到多个通知。
        Specified by:
        addTileObserver在接口 WritableRenderedImage
        参数
        to - 指定的TileObserver

      • removeTileObserver

        public void removeTileObserver​(TileObserver to)
        移除瓦片观察者。 如果观察员没有注册，没有任何反应。 如果观察员注册了多个通知，则现在注册了一个较少的通知。
        Specified by:
        removeTileObserver在接口 WritableRenderedImage
        参数
        to - 指定的 TileObserver 。

      • isTileWritable

        public boolean isTileWritable​(int tileX,
                              int tileY)
        返回是否当前签出拼贴以进行书写。
        Specified by:
        isTileWritable接口 WritableRenderedImage
        参数
        tileX - 图块的x索引。
        tileY - 瓷砖的y指数。
        结果
        true如果指定的索引指定的tile被签出用于写入; 否则为false 。
        异常
        ArrayIndexOutOfBoundsException - 如果 tileX和 tileY都不等于0

      • getWritableTileIndices

        public Point[] getWritableTileIndices​()
        返回一个Point个对象的数组，指示哪些图块被签出用于写入。 如果没有签出，则返回null 。
        Specified by:
        getWritableTileIndices在接口 WritableRenderedImage
        结果
        一个 Point数组，表示被签出用于书写的 null如果没有拼贴被签出写入， null 。

      • hasTileWriters

        public boolean hasTileWriters​()
        返回是否检出任何图块以进行写入。 语义上相当于
          (getWritableTileIndices() != null).
        Specified by:
        hasTileWriters在接口 WritableRenderedImage
        结果
        true如果任何瓦片被签出写入; false否则。

      • getWritableTile

        public WritableRaster getWritableTile​(int tileX,
                                      int tileY)
        检查一个瓦片写作。 所有注册的TileObservers在瓦片从没有作家到拥有一位作家时被通知。
        Specified by:
        getWritableTile在接口 WritableRenderedImage
        参数
        tileX - 图块的x索引
        tileY - 瓷砖的y指数
        结果
        一个 WritableRaster是由指定的索引指示的瓦片，用于书面签出。

      • releaseWritableTile

        public void releaseWritableTile​(int tileX,
                                int tileY)
        放弃写入瓦片的权限。 如果呼叫者继续写入瓦片，结果是未定义的。 对此方法的调用只能在匹配的对中出现，并且调用getWritableTile(int, int) 。 任何其他导致未定义的结果。 当瓦片从一个作家到没有作家时，通知所有注册的TileObservers 。
        Specified by:
        releaseWritableTile在接口 WritableRenderedImage
        参数
        tileX - 图块的x索引
        tileY - 瓷砖的y指数

      • getTransparency

        public int getTransparency​()
        返回透明度。 返回OPAQUE，BITMASK或TRANSLUCENT。
        Specified by:
        getTransparency在接口 Transparency
        结果
        这个透明度这个 BufferedImage 。
        从以下版本开始：
        1.5
        另请参见：
        Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferedImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class BufferedImageFilter

  • java.lang.Object
    • java.awt.image.ImageFilter
      • java.awt.image.BufferedImageFilter
  • All Implemented Interfaces:
    ImageConsumer ， Cloneable

    public class BufferedImageFilter
extends ImageFilter
implements Cloneable
    所述BufferedImageFilter类的子类的ImageFilter是提供一种使用单一源/单一目标图像操作符（的简单方法BufferedImageOp ）以过滤BufferedImage在图像生产者/消费者/观察员范例。 这些图像运营商的实例是： ConvolveOp ， AffineTransformOp和LookupOp 。
    另请参见：
    ImageFilter ， BufferedImage ， BufferedImageOp

    • Field Summary

      • Fields inherited from interface java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

      • Fields inherited from class java.awt.image.ImageFilter

        consumer

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferedImageFilter​(BufferedImageOp op)
      构造具有指定的单源/单目的地址操作符的 BufferedImageFilter 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BufferedImageOp getBufferedImageOp​()
      返回 BufferedImageOp 。
      void imageComplete​(int status)
      过滤 ImageConsumer接口 imageComplete方法中提供的信息。
      void setColorModel​(ColorModel model)
      对 ImageConsumer接口的 setColorModel方法中提供的信息进行过滤。
      void setDimensions​(int width, int height)
      过滤ImageConsumer接口setDimensions 方法中提供的信息。
      void setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      过滤器在所提供的信息 setPixels所述的方法 ImageConsumer接口采用字节的阵列。
      void setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      过滤 ImageConsumer接口的 setPixels方法中提供的信息，该接口采用整数数组。

      • Methods inherited from class java.awt.image.ImageFilter

        clone, getFilterInstance, resendTopDownLeftRight, setHints, setProperties

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BufferedImageFilter

        public BufferedImageFilter​(BufferedImageOp op)
        构造具有指定的单源/单目的地址的操作符的 BufferedImageFilter 。
        参数
        op - 指定的 BufferedImageOp用于过滤 BufferedImage
        异常
        NullPointerException - 如果op为空

    • 方法详细信息

      • getBufferedImageOp

        public BufferedImageOp getBufferedImageOp​()
        返回 BufferedImageOp 。
        结果
        该操作员为 BufferedImageFilter 。

      • setDimensions

        public void setDimensions​(int width,
                          int height)
        对ImageConsumer接口的setDimensions 方法中提供的信息进行过滤。

        注意：该方法的目的是由被过滤像素的Image的Image调用。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setDimensions在接口 ImageConsumer
        重写：
        setDimensions类 ImageFilter
        参数
        width - 要设置此宽度的宽度 BufferedImageFilter
        height - 设置该高度的高度 BufferedImageFilter
        另请参见：
        ImageConsumer.setDimensions(int, int)

      • setColorModel

        public void setColorModel​(ColorModel model)
        过滤ImageConsumer接口setColorModel方法中提供的信息。

        如果model为null ，则此方法将清除此ColorModel的当前BufferedImageFilter 。

        注意：该方法的目的是由被过滤像素的ImageProducer的Image调用。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setColorModel在接口 ImageConsumer
        重写：
        setColorModel在 ImageFilter
        参数
        model - 该ColorModel要设置ColorModel的这个BufferedImageFilter
        另请参见：
        ImageConsumer.setColorModel(java.awt.image.ColorModel)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
        过滤ImageConsumer接口中提供的setPixels方法中提供的信息，该接口采用字节数组。

        注意：此方法的目的是由被过滤像素的ImageProducer的Image调用。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中的一行像素到下一行的距离
        异常
        IllegalArgumentException - 如果宽度或高度小于零。
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, ColorModel, byte[], int, int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
        过滤器在所提供的信息setPixels所述的方法ImageConsumer接口这需要一个整数数组。

        注意：该方法的目的是通过其像素被过滤的ImageProducer的Image调用。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels阵列
        scansize - pixels数组中的一行像素到下一行的距离
        异常
        IllegalArgumentException - 如果宽度或高度小于零。
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, ColorModel, int[], int, int)

      • imageComplete

        public void imageComplete​(int status)
        过滤ImageConsumer接口imageComplete方法中提供的信息。

        注意：该方法的目的是通过ImageProducer的Image其像素被过滤。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        imageComplete在接口 ImageConsumer
        重写：
        imageComplete类 ImageFilter
        参数
        status - 图像加载的状态
        异常
        ImagingOpException - 如果调用与此实例关联的 BufferedImageOp的过滤方法有问题。
        另请参见：
        ImageConsumer.imageComplete(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferedImageOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface BufferedImageOp

  • 所有已知实现类：
    AffineTransformOp ， ColorConvertOp ， ConvolveOp ， LookupOp ， RescaleOp

    public interface BufferedImageOp
    该界面描述了对BufferedImage对象执行的单输入/单输出操作。 它是由执行AffineTransformOp ， ConvolveOp ， ColorConvertOp ， RescaleOp ，并LookupOp 。 这些对象可以被传递到BufferedImageFilter ，以在操作BufferedImage中的ImageProducer-ImageFilter的-ImageConsumer的范例。

    实现此接口的类必须指定是否允许就地过滤 - 源对象等于目标对象的过滤操作。

    此接口不能用于描述更复杂的操作，如那些需要多个源的操作。 请注意，此限制也意味着操作之前的目标像素的值不会用作过滤器操作的输入。

    另请参见：
    BufferedImage ， BufferedImageFilter ， AffineTransformOp ， BandCombineOp ， ColorConvertOp ， ConvolveOp ， LookupOp ， RescaleOp

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BufferedImage createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage filter​(BufferedImage src, BufferedImage dest)
      在 BufferedImage上执行单输入/单输出操作。
      Rectangle2D getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源图像中给定点的对应目标点的位置。
      RenderingHints getRenderingHints​()
      返回此操作的呈现提示。

    • 方法详细信息

      • filter

        BufferedImage filter​(BufferedImage src,
                     BufferedImage dest)
        在BufferedImage上执行单输入/单输出操作。 如果两个图像的颜色模型不匹配，则执行到目标颜色模型的颜色转换。 如果目标图像为空，则会创建一个BufferedImage其中包含适当的ColorModel 。

        如果源和/或目标映像与实现此过滤器的类允许的图像类型不兼容，则可能会抛出IllegalArgumentException 。

        参数
        src - 要过滤的 BufferedImage
        dest - 其中存储结果的 BufferedImage $
        结果
        过滤后的 BufferedImage 。
        异常
        IllegalArgumentException - 如果源和/或目标映像与实现此过滤器的类允许的映像类型不兼容。

      • getBounds2D

        Rectangle2D getBounds2D​(BufferedImage src)
        返回已过滤的目标图像的边界框。 如果源图像与实现此过滤器的类允许的图像类型不兼容，则可能会抛出IllegalArgumentException 。
        参数
        src - 要过滤的 BufferedImage
        结果
        Rectangle2D表示目的地图像的边界框。

      • createCompatibleDestImage

        BufferedImage createCompatibleDestImage​(BufferedImage src,
                                        ColorModel destCM)
        创建具有正确大小和频带数的归零目标图像。 如果源图像与实现此过滤器的类允许的图像类型不兼容，则可能会抛出IllegalArgumentException 。
        参数
        src - 要过滤的 BufferedImage
        destCM - ColorModel的目的地。 如果为null，则使用源的ColorModel 。
        结果
        归零的目标图像。

      • getPoint2D

        Point2D getPoint2D​(Point2D srcPt,
                   Point2D dstPt)
        返回源图像中给定点的对应目标点的位置。 如果指定了dstPt ，则用于保存返回值。
        参数
        srcPt - 代表源图像中的点的 Point2D
        dstPt - 其中存储结果的 Point2D
        结果
        目标图像中的 Point2D对应于源图像中的指定点。

      • getRenderingHints

        RenderingHints getRenderingHints​()
        返回此操作的呈现提示。
        结果
        该RenderingHints对象为这BufferedImageOp 。 如果没有设置提示，则返回null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class BufferStrategy

  • java.lang.Object
    • java.awt.image.BufferStrategy
  • 已知直接子类：
    Component.BltBufferStrategy ， Component.FlipBufferStrategy

    public abstract class BufferStrategy
extends Object
    BufferStrategy类表示在特定的Canvas或Window上组织复杂内存的机制。 硬件和软件的限制决定了是否以及如何实现特定的缓冲策略。 通过在创建Canvas或Window时使用的GraphicsConfiguration的功能可以检测到这些限制。

    值得注意的是， 缓冲区和表面术语意在同义：在视频设备存储器或系统存储器中连续存储器的区域。

    有几种类型的复杂缓冲策略，包括顺序环形缓冲和blit缓冲。 顺序环缓冲（即双缓冲或三缓冲）是最常见的; 应用程序绘制到单个后台缓冲区 ，然后通过复制数据或移动视频指针，将内容移动到前面（显示）。 移动视频指针交换缓冲区，使得绘制的第一个缓冲区成为前缓冲区 ，或当前显示在设备上的内容; 这被称为页面翻转 。

    或者，背面缓冲器的内容可以被复制或者在链中向前弯曲 ，而不是移动视频指针。

       Double buffering: *********** *********** * * ------> * * [To display] <---- * Front B * Show * Back B. * <---- Rendering * * <------ * * *********** *********** Triple buffering: [To *********** *********** *********** display] * * --------+---------+------> * * <---- * Front B * Show * Mid. B. * * Back B. * <---- Rendering * * <------ * * <----- * * *********** *********** ***********

    以下是可以创建和使用缓冲区策略的示例：

       // Check the capabilities of the GraphicsConfiguration ... // Create our component Window w = new Window(gc); // Show our window w.setVisible(true); // Create a general double-buffering strategy w.createBufferStrategy(2); BufferStrategy strategy = w.getBufferStrategy(); // Main loop while (!done) { // Prepare for rendering the next frame // ... // Render single frame do { // The following loop ensures that the contents of the drawing buffer // are consistent in case the underlying surface was recreated do { // Get a new graphics context every time through the loop // to make sure the strategy is validated Graphics graphics = strategy.getDrawGraphics(); // Render to graphics // ... // Dispose the graphics graphics.dispose(); // Repeat the rendering if the drawing buffer contents // were restored } while (strategy.contentsRestored()); // Display the buffer strategy.show(); // Repeat the rendering if the drawing buffer was lost } while (strategy.contentsLost()); } // Dispose the window w.setVisible(false); w.dispose();
    从以下版本开始：
    1.4
    另请参见：
    Window ， Canvas ， GraphicsConfiguration ， VolatileImage

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferStrategy​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract boolean contentsLost​()
      返回自上次调用 getDrawGraphics以来绘图缓冲区是否丢失。
      abstract boolean contentsRestored​()
      返回绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）。
      void dispose​()
      释放此 BufferStrategy目前使用的系统资源，并将其从关联的组件中删除。
      abstract BufferCapabilities getCapabilities​()
      返回 BufferCapabilities为这个 BufferStrategy 。
      abstract Graphics getDrawGraphics​()
      为绘图缓冲区创建图形上下文。
      abstract void show​()
      通过复制内存（blitting）或更改显示指针（翻转），使下一个可用的缓冲区可见。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BufferStrategy

        public BufferStrategy​()

    • 方法详细信息

      • getCapabilities

        public abstract BufferCapabilities getCapabilities​()
        返回 BufferCapabilities此 BufferStrategy 。
        结果
        这个策略的缓冲功能

      • getDrawGraphics

        public abstract Graphics getDrawGraphics​()
        为绘图缓冲区创建图形上下文。 出于性能原因，此方法可能无法同步; 多线程使用此方法应在应用程序级别处理。 获取的图形对象的处理必须由应用程序处理。
        结果
        绘图缓冲区的图形上下文

      • contentsLost

        public abstract boolean contentsLost​()
        返回自上次调用getDrawGraphics以来绘图缓冲区是否丢失。 由于缓冲区策略中的缓冲区通常是类型为VolatileImage ，它们可能会丢失。 有关丢失缓冲区的讨论，请参阅VolatileImage 。
        结果
        自上次调用 getDrawGraphics以来，绘图缓冲区是否丢失。
        另请参见：
        VolatileImage

      • contentsRestored

        public abstract boolean contentsRestored​()
        返回绘图缓冲区是否最近从丢失状态恢复并重新初始化为默认背景颜色（白色）。 由于缓冲区策略中的缓冲区通常是类型为VolatileImage ，它们可能会丢失。 如果自上次调用getDrawGraphics以来，表面最近已经从丢失状态恢复，则可能需要重新绘制。 有关丢失缓冲区的讨论，请参阅VolatileImage 。
        结果
        自上次调用 getDrawGraphics以来，绘图缓冲区是否已恢复。
        另请参见：
        VolatileImage

      • show

        public abstract void show​()
        通过复制内存（blitting）或更改显示指针（翻转），使下一个可用的缓冲区可见。

      • dispose

        public void dispose​()
        释放此BufferStrategy目前使用的系统资源，并将其从关联的组件中删除。 调用此方法后， getBufferStrategy将返回null。 在BufferStrategy之后尝试使用BufferStrategy将导致未定义的行为。
        从以下版本开始：
        1.6
        另请参见：
        Window.createBufferStrategy(int) ，
Canvas.createBufferStrategy(int) ，
Window.getBufferStrategy() ，
Canvas.getBufferStrategy()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ByteLookupTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ByteLookupTable

  • java.lang.Object
    • java.awt.image.LookupTable
      • java.awt.image.ByteLookupTable

  • public class ByteLookupTable
extends LookupTable
    这个类定义了一个查找表对象。 使用此类的对象的查找操作的输出被解释为无符号字节数量。 查找表包含用于图像的一个或多个频带（或组件）的字节数据阵列，并且它包含在索引数组之前将从输入值中减去的偏移量。 这允许为受限输入提供小于本机数据大小的数组。 如果查找表中只有一个数组，它将被应用于所有频带。
    另请参见：
    ShortLookupTable ， LookupOp

    • 构造方法摘要

      构造方法
      Constructor 描述
      ByteLookupTable​(int offset, byte[] data)
      从表示要应用于所有频带的查找表的字节数组构造一个ByteLookupTable对象。
      ByteLookupTable​(int offset, byte[][] data)
      从表示每个频带的查找表的字节数组的数组构造一个ByteLookupTable对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[][] getTable​()
      通过引用返回查找表数据。
      byte[] lookupPixel​(byte[] src, byte[] dst)
      返回用查找表翻译的像素数组。
      int[] lookupPixel​(int[] src, int[] dst)
      返回用查找表翻译的像素数组。

      • Methods inherited from class java.awt.image.LookupTable

        getNumComponents, getOffset

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ByteLookupTable

        public ByteLookupTable​(int offset,
                       byte[][] data)
        从表示每个频带的查找表的字节数组的数组构造一个ByteLookupTable对象。 在索引到数组之前，将从输入值中减去偏移量。 频带数是数据参数的长度。 存储每个频带的数据阵列作为参考。
        参数
        offset - 从索引到数组之前的输入值中减去的值
        data - 表示每个频带的查找表的字节数组数组
        异常
        IllegalArgumentException - 如果 offset小于0或 data的长度小于1

      • ByteLookupTable

        public ByteLookupTable​(int offset,
                       byte[] data)
        从表示要应用于所有频带的查找表的字节数组构造一个ByteLookupTable对象。 在索引到数组之前，将从输入值中减去偏移量。 数据数组作为参考存储。
        参数
        offset - 在索引到数组之前从输入值中减去的值
        data - 一个字节数组
        异常
        IllegalArgumentException - 如果 offset小于0或 data的长度小于1

    • 方法详细信息

      • getTable

        public final byte[][] getTable​()
        通过引用返回查找表数据。 如果使用单字节数组构造ByteLookupTable，则返回的数组的长度为1。
        结果
        这个 ByteLookupTable的数据数组。

      • lookupPixel

        public int[] lookupPixel​(int[] src,
                         int[] dst)
        返回用查找表翻译的像素数组。 源和目标数组可以是同一个数组。 返回数组dst 。
        Specified by:
        lookupPixel在 LookupTable
        参数
        src - 源数组。
        dst - 目标数组。 该数组必须至少等于src 。 如果dst为null ，则将分配与src相同长度的新数组。
        结果
        阵列 dst ，一个 int数组的样本。
        异常
        ArrayIndexOutOfBoundsException -如果 src长于 dst或如果出于任何元件 i的 src ， src[i]-offset是小于零或者大于或等于查找表的长度为任何频带。

      • lookupPixel

        public byte[] lookupPixel​(byte[] src,
                          byte[] dst)
        返回用查找表翻译的像素数组。 源和目标数组可以是同一个数组。 返回数组dst 。
        参数
        src - 源数组。
        dst - 目标数组。 该数组必须至少等于src 。 如果dst为null ，则将分配与src相同长度的新数组。
        结果
        阵列 dst ，一个 int列阵内的样本。
        异常
        ArrayIndexOutOfBoundsException -如果 src长于 dst或如果出于任何元件 i的 src ， (src[i]&0xff)-offset是小于零或者大于或等于查找表的长度为任何频带。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ColorConvertOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ColorConvertOp

  • java.lang.Object
    • java.awt.image.ColorConvertOp
  • All Implemented Interfaces:
    BufferedImageOp ， RasterOp

    public class ColorConvertOp
extends Object
implements BufferedImageOp, RasterOp
    该类对源图像中的数据执行逐像素颜色转换。 所得到的颜色值被缩放到目标图像的精度。 可以通过ColorSpace对象或ICC_Profile对象数组来指定颜色转换。

    如果源是具有预乘α的BufferedImage，则颜色分量在颜色转换之前被alpha分量除。 如果目的地是具有预乘法α的BufferedImage，则颜色分量在转换后乘以alpha分量。 光栅被视为没有alpha通道，即所有的带都是彩色带。

    如果在构造函数中指定了RenderingHints对象，则可以使用颜色渲染提示和抖动提示来控制颜色转换。

    请注意，源和目标可能是相同的对象。

    另请参见：
    RenderingHints.KEY_COLOR_RENDERING ， RenderingHints.KEY_DITHERING

    • 构造方法摘要

      构造方法
      Constructor 描述
      ColorConvertOp​(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
      从两个ColorSpace对象构造一个新的ColorConvertOp。
      ColorConvertOp​(ColorSpace cspace, RenderingHints hints)
      从ColorSpace对象构造一个新的ColorConvertOp。
      ColorConvertOp​(ICC_Profile[] profiles, RenderingHints hints)
      从ICC_Profiles数组构造一个新的ColorConvertOp。
      ColorConvertOp​(RenderingHints hints)
      构造一个新的ColorConvertOp，它将从源颜色空间转换为目标色彩空间。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BufferedImage createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      给出这个来源，创建具有正确大小和频带数的归零目标图像。
      WritableRaster createCompatibleDestRaster​(Raster src)
      给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
      BufferedImage filter​(BufferedImage src, BufferedImage dest)
      ColorConverts源BufferedImage。
      WritableRaster filter​(Raster src, WritableRaster dest)
      Color转换源光栅中的图像数据。
      Rectangle2D getBounds2D​(BufferedImage src)
      给出这个源，返回目的地的边界框。
      Rectangle2D getBounds2D​(Raster src)
      给出这个源，返回目的地的边界框。
      ICC_Profile[] getICC_Profiles​()
      返回用于构造此ColorConvertOp的ICC_Profiles数组。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      RenderingHints getRenderingHints​()
      返回此op使用的渲染提示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ColorConvertOp

        public ColorConvertOp​(RenderingHints hints)
        构造一个新的ColorConvertOp，它将从源颜色空间转换为目标色彩空间。 RenderingHints参数可能为null。 此Op仅可用于BufferedImages，并将直接从源图像的ColorSpace转换为目标的。 filter方法的destination参数不能指定为null。
        参数
        hints - 用于控制颜色转换的 RenderingHints对象，或 null

      • ColorConvertOp

        public ColorConvertOp​(ColorSpace cspace,
                      RenderingHints hints)
        从ColorSpace对象构造一个新的ColorConvertOp。 RenderingHints参数可能为null。 此Op仅可与BufferedImages一起使用，并且在以目标参数为null调用filter方法时主要有用。 在这种情况下，ColorSpace定义了由过滤方法创建的目的地的目标颜色空间。 否则，ColorSpace在转换为目的地空间之前定义了一个中间空间，源将被转换。
        参数
        cspace - 定义目的地 ColorSpace或中间件 ColorSpace
        hints - 用于控制颜色转换的 RenderingHints对象，或 null
        异常
        NullPointerException - 如果cspace为空

      • ColorConvertOp

        public ColorConvertOp​(ColorSpace srcCspace,
                      ColorSpace dstCspace,
                      RenderingHints hints)
        从两个ColorSpace对象构造一个新的ColorConvertOp。 RenderingHints参数可能为null。 此Op主要用于在Raster上调用过滤器方法，在这种情况下，两个ColorSpaces定义要在光栅上执行的操作。 在这种情况下，源光栅中的条带数必须与srcCspace中的组件数量相匹配，目标光栅中的条带数必须与dstCspace中的组件数量相匹配。 对于BufferedImages，两个ColorSpaces定义了在转换为目标空间之前转换源的中间空间。
        参数
        srcCspace - 来源 ColorSpace
        dstCspace - 目的地 ColorSpace
        hints - 用于控制颜色转换的 RenderingHints对象，或 null
        异常
        NullPointerException - 如果srcCspace或dstCspace为空

      • ColorConvertOp

        public ColorConvertOp​(ICC_Profile[] profiles,
                      RenderingHints hints)
        从ICC_Profiles数组构造一个新的ColorConvertOp。 RenderingHints参数可能为null。 配置文件的序列可能包括表示颜色空间的配置文件，表示效果的配置文件等。如果整个序列不表示明确定义的颜色转换，则抛出异常。

        对于BufferedImages，如果源BufferedImage的ColorSpace与阵列中第一个配置文件的要求不匹配，则首次转换为适当的ColorSpace。 如果阵列中最后一个配置文件的要求不被目标BufferedImage的ColorSpace满足，则最后一次转换是到目标的ColorSpace。

        对于光栅，源光栅中的光带数必须与阵列中第一个配置文件的要求相匹配，目标光栅中的光带数必须与阵列中最后一个配置文件的要求相匹配。 数组必须至少有两个元素，或者为Raster调用过滤器方法将抛出一个IllegalArgumentException异常。

        参数
        profiles - ICC_Profile对象的数组
        hints - 用于控制颜色转换的 RenderingHints对象，或 null
        异常
        IllegalArgumentException - 当轮廓序列未指定明确定义的颜色转换时
        NullPointerException - 如果个人资料为空

    • 方法详细信息

      • getICC_Profiles

        public final ICC_Profile[] getICC_Profiles​()
        返回用于构造此ColorConvertOp的ICC_Profiles数组。 如果ColorConvertOp未由此类阵列构造，则返回null。
        结果
        这个 ColorConvertOp的 ICC_Profile对象的数组，或者 null如果这个 ColorConvertOp没有用 ICC_Profile对象的数组构造的 ICC_Profile 。

      • filter

        public final BufferedImage filter​(BufferedImage src,
                                  BufferedImage dest)
        ColorConverts源BufferedImage。 如果目标图像为空，则使用适当的ColorModel创建一个BufferedImage。
        Specified by:
        filter在接口 BufferedImageOp
        参数
        src - 要转换的来源 BufferedImage
        dest - 目的地 BufferedImage或 null
        结果
        dest颜色转换为 src或新转换 BufferedImage如果 dest是 null
        异常
        IllegalArgumentException - 如果dest为空，并且该op是使用仅使用RenderingHints参数的构造函数构造的，因为操作不正确。

      • filter

        public final WritableRaster filter​(Raster src,
                                   WritableRaster dest)
        Color转换源光栅中的图像数据。 如果目标Raster为null，将创建一个新的栅格。 源和目标光栅中的频带数必须满足上述要求。 用于创建此ColorConvertOp的构造函数必须提供足够的信息来定义源和目标颜色空间。 往上看。 否则抛出异常。
        Specified by:
        filter在接口 RasterOp
        参数
        src - 要转换的来源 Raster
        dest - 目的地 WritableRaster或 null
        结果
        dest颜色转换从 src或一个新的，转换 WritableRaster如果 dest是 null
        异常
        IllegalArgumentException - 如果源或目标频带的数量不正确，则源或目标色彩空间未定义，或者该op是使用仅适用于BufferedImages操作的构造函数构造的。

      • getBounds2D

        public final Rectangle2D getBounds2D​(BufferedImage src)
        给出这个源，返回目的地的边界框。 请注意，这将与源的边框相同。
        Specified by:
        getBounds2D在接口 BufferedImageOp
        参数
        src - 来源 BufferedImage
        结果
        一个 Rectangle2D是目的地的边界盒，给定了指定的 src

      • getBounds2D

        public final Rectangle2D getBounds2D​(Raster src)
        给出这个源，返回目的地的边界框。 请注意，这将与源的边框相同。
        Specified by:
        getBounds2D在接口 RasterOp
        参数
        src - 来源 Raster
        结果
        一个 Rectangle2D是目的地的边界框，给定了指定的 src

      • createCompatibleDestImage

        public BufferedImage createCompatibleDestImage​(BufferedImage src,
                                               ColorModel destCM)
        给出这个来源，创建具有正确大小和频带数的归零目标图像。
        Specified by:
        createCompatibleDestImage在接口 BufferedImageOp
        参数
        src - 过滤器操作的源图像。
        destCM - 目的地的ColorModel。 如果为null，将使用适当的ColorModel。
        结果
        一个 BufferedImage具有正确的大小和数量的频带，从指定的 src 。
        异常
        IllegalArgumentException - 如果 destCM是 null而这个 ColorConvertOp是创建的，没有为目标定义任何 ICC_Profile或 ColorSpace

      • createCompatibleDestRaster

        public WritableRaster createCompatibleDestRaster​(Raster src)
        给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
        Specified by:
        createCompatibleDestRaster在接口 RasterOp
        参数
        src - 指定的 Raster
        结果
        一个 WritableRaster具有正确的大小和数量的频带，从指定的 src
        异常
        IllegalArgumentException - 如果这个 ColorConvertOp没有足够的信息创建来定义 dst和 src颜色空间

      • getPoint2D

        public final Point2D getPoint2D​(Point2D srcPt,
                                Point2D dstPt)
        返回源中给定点的目标点的位置。 如果dstPt是非空值，它将用于保存返回值。 请注意，对于此类，目标点将与源点相同。
        Specified by:
        getPoint2D在接口 BufferedImageOp
        Specified by:
        getPoint2D在接口 RasterOp
        参数
        srcPt - 指定的来源 Point2D
        dstPt - 目的地 Point2D
        结果
        dstPt将其位置设置为与 srcPt相同

      • getRenderingHints

        public final RenderingHints getRenderingHints​()
        返回此op使用的渲染提示。
        Specified by:
        getRenderingHints在接口 BufferedImageOp
        Specified by:
        getRenderingHints在接口 RasterOp
        结果
        该 RenderingHints对象 ColorConvertOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ColorModel

  • java.lang.Object
    • java.awt.image.ColorModel
  • All Implemented Interfaces:
    Transparency
    已知直接子类：
    ComponentColorModel ， IndexColorModel ， PackedColorModel

    public abstract class ColorModel
extends Object
implements Transparency
    ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和Alpha组件的方法。 为了将图像呈现到屏幕，打印机或其他图像，像素值必须转换为颜色和alpha组件。 作为这个类的方法的参数或返回值，像素被表示为32位int或者作为原始类型的数组。 ColorModel的颜色分量的数量，顺序和解释由其ColorSpace规定。 与不包含alpha信息的像素数据ColorModel使用的ColorModel将所有像素视为不透明，这是alpha值为1.0。

    这个ColorModel类支持像素值的两个表示。 像素值可以是单个32位int或一个原始数组。 Java（tm）Platform 1.0和1.1 API将像素表示为byte或单个int值。 为了ColorModel类的目的，像素值参数以int形式传递。 Java（tm）2 Platform API引入了用于表示图像的其他类。 使用BufferedImage或RenderedImage对象，基于Raster和SampleModel类，像素值可能无法方便地表示为单个int。 因此， ColorModel现在具有接受表示为原始类型数组的像素值的方法。 特定ColorModel对象使用的原始类型称为其传输类型。

    ColorModel与图像ColorModel使用的对象，当调用单个int像素参数的方法时，像素值不能方便地表示为单个int抛出IllegalArgumentException 。 ColorModel子类必须指定发生这种情况的条件。 这不与DirectColorModel或IndexColorModel对象发生。

    目前，Java 2D（tm）API支持的传输类型是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT和DataBuffer.TYPE_DOUBLE。 当使用ColorModel和基于前三种类型的图像时，大多数渲染操作将执行得更快。 另外，对于ColorModel和基于后三种类型的图像，不支持某些图像过滤操作。 特定的ColorModel对象的传输类型在创建对象时被明确地或默认地被指定。 ColorModel所有子类必须指定可能的传输类型是什么，以及如何确定表示像素的基元数组中的元素数量。

    对于BufferedImages ，其转让类型为Raster和Raster对象的SampleModel （可从这些类的getTransferType方法获得）必须与ColorModel匹配。 表示用于一个像素阵列中的元素的数量Raster和SampleModel （可从getNumDataElements这些类的方法）必须匹配的ColorModel 。

    用于将像素值转换为颜色和α分量的算法因子类而异。 例如，从BufferedImage对象的Raster和颜色/α分量的Raster获得的样本之间SampleModel是BufferedImage的。 即使存在这样的对应关系，样本中的比特数也不一定与相应颜色/α分量中的比特数相同。 每个子类必须指定如何从像素值到颜色/ alpha分量的转换。

    ColorModel类中的方法使用颜色和α分量的两种不同表示 - 标准化形式和非规范化形式。 在标准化形式中，每个组件是一些最小值和最大值之间的一个float值。 对于alpha组件，最小值为0.0，最大值为1.0。 对于颜色分量，可以从ColorSpace对象获取每个组件的最小值和最大值。 这些值通常为0.0和1.0（例如，默认sRGB颜色空间范围为0.0到1.0的标准化组件值），但某些颜色空间具有不同上限和下限的组件值。 这些限制可以使用ColorSpace类的getMinValue和getMaxValue方法获得。 归一化颜色分量值不是预乘。 所有ColorModels必须支持标准化形式。

    在非归一化形式中，每个分量是0和2 n -1之间的无符号积分值，其中n是特定分量的有效位数。 如果特定的ColorModel像素值表示由α样本ColorModel颜色样本，则非标准化颜色分量值也被预乘。 非规范化形式仅用于ColorModel的实例，其ColorSpace对于所有组件的最小组件值为0.0，对于所有组件的最大值为1.0。 颜色和alpha分量的非标准化形式可以为ColorModels的方便表示，其标准化分量值都在0.0和1.0之间。 在这种情况下，积分值0映射到0.0，值2 n -1映射到1.0。 在其他情况下，例如当归一化分量值可以是负数或正数时，非正规化形式是不方便的。 当调用涉及非规范化参数的方法时，这样的ColorModel对象会抛出一个IllegalArgumentException 。 ColorModel子类必须指定出现这种情况的条件。

    另请参见：
    IndexColorModel ， ComponentColorModel ， PackedColorModel ， DirectColorModel ， Image ， BufferedImage ， RenderedImage ， ColorSpace ， SampleModel ， Raster ， DataBuffer

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int pixel_bits
      像素中的总位数。
      protected int transferType
      用于表示像素值的数组的数据类型。

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        ColorModel​(int bits)
      构造一个 ColorModel ，它将指定位数的像素转换为颜色/ alpha分量。
      protected ColorModel​(int pixel_bits, int[] bits, ColorSpace cspace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
      构造一个将像素值转换为颜色/ alpha分量的 ColorModel 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      ColorModel coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设目前 ColorModel正确描述了数据。
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
      WritableRaster createCompatibleWritableRaster​(int w, int h)
      创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。
      boolean equals​(Object obj)
      该方法简单地委托给 Object的默认实现，这与 ==测试相同，因为该类不能在多个独立子类分支之间强制执行适当的等式测试的问题。
      void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      abstract int getAlpha​(int pixel)
      返回指定像素的alpha分量，从0到255。
      int getAlpha​(Object inData)
      返回指定像素的alpha分量，从0到255。
      WritableRaster getAlphaRaster​(WritableRaster raster)
      返回 Raster表示图像的alpha通道，从输入中提取 Raster ，提供此的像素值 ColorModel表示颜色和alpha信息为独立的空间频带（例如
      abstract int getBlue​(int pixel)
      返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。
      int getBlue​(Object inData)
      返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      ColorSpace getColorSpace​()
      返回 ColorSpace与此 ColorModel相关联。
      int[] getComponents​(int pixel, int[] components, int offset)
      在这个 ColorModel给出了一个像素的非归一化颜色/ alpha分量的数组。
      int[] getComponents​(Object pixel, int[] components, int offset)
      在这个 ColorModel给出一个像素，返回一个非标准化的颜色/ alpha分量的数组。
      int[] getComponentSize​()
      返回每个颜色/ alpha分量的位数的数组。
      int getComponentSize​(int componentIdx)
      返回指定颜色/ alpha分量的位数。
      int getDataElement​(float[] normComponents, int normOffset)
      返回表示为一个像素值 int在此 ColorModel ，给定的归一化的颜色/ alpha分量的阵列。
      int getDataElement​(int[] components, int offset)
      返回表示为一个像素值 int在此 ColorModel ，给定非标准化颜色/ alpha分量的阵列。
      Object getDataElements​(float[] normComponents, int normOffset, Object obj)
      给出这个 ColorModel的一个像素的数据元素数组表示，给出了一组归一化的颜色/ alpha分量。
      Object getDataElements​(int[] components, int offset, Object obj)
      给出这个 ColorModel的一个像素的数据元素数组表示，给出了一个非标准化颜色/ alpha分量的数组。
      Object getDataElements​(int rgb, Object pixel)
      返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。
      abstract int getGreen​(int pixel)
      返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。
      int getGreen​(Object inData)
      返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。
      float[] getNormalizedComponents​(int[] components, int offset, float[] normComponents, int normOffset)
      给定一个非规范化的组件数组，以归一化形式返回所有颜色/ alpha分量的数组。
      float[] getNormalizedComponents​(Object pixel, float[] normComponents, int normOffset)
      给出这个 ColorModel一个像素，以归一化形式返回所有颜色/ alpha分量的 ColorModel 。
      int getNumColorComponents​()
      返回此 ColorModel的颜色分量数。
      int getNumComponents​()
      返回此 ColorModel的组件数，包括alpha。
      int getPixelSize​()
      返回此 ColorModel描述的每像素的 ColorModel 。
      abstract int getRed​(int pixel)
      返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。
      int getRed​(Object inData)
      返回指定像素的红色分量，从默认RGB ColorSpace （sRGB）中的0到255。
      int getRGB​(int pixel)
      以默认RGB颜色模型格式返回像素的颜色/ alpha分量。
      int getRGB​(Object inData)
      以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。
      static ColorModel getRGBdefault​()
      返回一个 DirectColorModel ，它描述了AWT图像接口中许多方法中使用的整数RGB值的默认格式，以方便程序员。
      int getTransferType​()
      返回此 ColorModel的传输类型。
      int getTransparency​()
      返回透明度。
      int[] getUnnormalizedComponents​(float[] normComponents, int normOffset, int[] components, int offset)
      给定一个归一化的组件数组，以非规范化形式返回所有颜色/ alpha分量的数组。
      boolean hasAlpha​()
      返回此 ColorModel中是否支持 ColorModel 。
      int hashCode​()
      该方法简单地委派到 Object的默认实现，它返回该类的系统ID。
      boolean isAlphaPremultiplied​()
      返回是否在此 ColorModel要翻译的像素值中预先使用 ColorModel 。
      boolean isCompatibleRaster​(Raster raster)
      如果 raster与 ColorModel和 false兼容，则返回 true 。
      boolean isCompatibleSampleModel​(SampleModel sm)
      检查 SampleModel是否与此 ColorModel兼容。
      String toString​()
      返回 ColorModel对象的内容的 String表示。

      • Methods inherited from class java.lang.Object

        clone, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • pixel_bits

        protected int pixel_bits
        像素中的总位数。

      • transferType

        protected int transferType
        用于表示像素值的数组的数据类型。

    • 构造方法详细信息

      • ColorModel

        public ColorModel​(int bits)
        构造一个ColorModel ，它将指定位数的像素转换为彩色/ alpha分量。 颜色空间是默认的RGB ColorSpace ，这是sRGB。 假设像素值包括alpha信息。 如果在像素值中将颜色和α信息表示为单独的空间频带，则假定色带不与α值预乘。 透明度类型是java.awt.Transparency.TRANSLUCENT。 传输类型将是可容纳单个像素的DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT中最小的数据（如果位大于32，则为DataBuffer.TYPE_UNDEFINED）。 由于该构造函数没有关于每个颜色和alpha组件的位数的信息，所以调用此构造函数的任何子类都应该覆盖任何需要此信息的方法。
        参数
        bits - 像素的位数
        异常
        IllegalArgumentException -如果在比特数 bits小于1

      • ColorModel

        protected ColorModel​(int pixel_bits,
                     int[] bits,
                     ColorSpace cspace,
                     boolean hasAlpha,
                     boolean isAlphaPremultiplied,
                     int transparency,
                     int transferType)
        构造一个将像素值转换为颜色/ alpha组件的ColorModel 。 颜色组件将在指定的ColorSpace 。 pixel_bits是像素值中的位数。 位数组指定每个颜色和alpha分量的有效位数。 它的长度应该是ColorSpace的组件的数量，如果像素值中没有alpha信息，或者如果有alpha信息，则该数目多于此数字。 hasAlpha表示是否存在α信息。 boolean isAlphaPremultiplied指定如何解释将颜色和阿尔法信息表示为单独的空间带的像素值。 如果boolean是true ，假设颜色样本已被乘以α样本。 transparency指定此颜色模型可以表示哪些Alpha值。 传输类型是用于表示像素值的原始数组的类型。 请注意，位数组包含从像素值转换后每个颜色/ alpha分量的有效位数。 例如，对于一个IndexColorModel与pixel_bits等于16，这些比特阵列可能具有与设置为8的每个元素四个元件。
        参数
        pixel_bits - 像素值中的位数
        bits - 指定每个颜色和alpha分量的有效位数的数组
        cspace - 指定的 ColorSpace
        如果存在alpha信息，则为hasAlpha - true ; false否则
        isAlphaPremultiplied - true如果假设颜色样本被alpha样本预乘， 否则为false
        transparency - 这个颜色模型可以表示哪些alpha值
        transferType - 用于表示像素值的数组的类型
        异常
        IllegalArgumentException - 如果位数组的长度小于此 ColorModel的颜色或alpha分量的 ColorModel ，或者透明度不是有效值。
        IllegalArgumentException -如果在比特数的总和 bits小于1，或者如果在任何元件的 bits小于0。
        另请参见：
        Transparency

    • 方法详细信息

      • getRGBdefault

        public static ColorModel getRGBdefault​()
        返回一个DirectColorModel ，它描述了AWT图像接口中许多方法中使用的整数RGB值的默认格式，以方便程序员。 色彩空间是默认的ColorSpace ，sRGB。 RGB值的格式是一个整数，8位，每个alpha，红色，绿色和蓝色颜色分量从最高有效字节到最低有效字节排序，如：0xAARRGGBB。 颜色分量不被alpha分量预乘。 该格式不一定代表特定设备或所有图像的本机或最高效的ColorModel 。 它仅用作常见的颜色模型格式。
        结果
        描述默认RGB值的 DirectColorModel对象。

      • hasAlpha

        public final boolean hasAlpha​()
        返回此 ColorModel中是否支持alpha。
        结果
        true如果alpha支持ColorModel ; false否则。

      • isAlphaPremultiplied

        public final boolean isAlphaPremultiplied​()
        返回Alpha ColorModel要翻译的像素值中是否已ColorModel 。 如果布尔值为true ，则该ColorModel将用于解释其中颜色和阿尔法信息被表示为单独的空间带的像素值，并且假定颜色样本已被乘以α样本。
        结果
        true如果alpha值ColorModel要翻译的像素值; 否则为false 。

      • getTransferType

        public final int getTransferType​()
        返回此ColorModel的传输类型。 传输类型是用于将像素值表示为数组的原始数组的类型。
        结果
        转移类型。
        从以下版本开始：
        1.3

      • getPixelSize

        public int getPixelSize​()
        返回此 ColorModel描述的每像素的 ColorModel 。
        结果
        每像素的位数。

      • getComponentSize

        public int getComponentSize​(int componentIdx)
        返回指定颜色/ alpha分量的位数。 颜色组件按ColorSpace指定的顺序索引。 通常，此顺序反映了颜色空间类型的名称。 例如，对于TYPE_RGB，索引0对应于红色，索引1为绿色，索引2为蓝色。 如果这个ColorModel支持alpha，则alpha组件对应于最后一个颜色分量之后的索引。
        参数
        componentIdx - 颜色/ alpha分量的索引
        结果
        指定索引处的颜色/ alpha分量的位数。
        异常
        ArrayIndexOutOfBoundsException - 如果 componentIdx大于组件数或小于零
        NullPointerException - 如果位数为 null

      • getComponentSize

        public int[] getComponentSize​()
        返回每个颜色/ alpha分量的位数的数组。 该数组包含由ColorSpace指定的顺序的颜色分量，其后是alpha组件（如果存在）。
        结果
        每个颜色/ alpha分量的位数的数组

      • getTransparency

        public int getTransparency​()
        返回透明度。 返回OPAQUE，BITMASK或TRANSLUCENT。
        Specified by:
        getTransparency在接口 Transparency
        结果
        该透明度为 ColorModel 。
        另请参见：
        Transparency.OPAQUE ， Transparency.BITMASK ， Transparency.TRANSLUCENT

      • getNumComponents

        public int getNumComponents​()
        返回此ColorModel的组件数，包括alpha。 这等于颜色分量的数量，可选加一个，如果有一个alpha分量。
        结果
        该组件的数量在这 ColorModel

      • getNumColorComponents

        public int getNumColorComponents​()
        返回此ColorModel中颜色分量的数量。 这是由ColorSpace.getNumComponents()返回的组件数。
        结果
        这个 ColorModel的颜色分量的数量。
        另请参见：
        ColorSpace.getNumComponents()

      • getRed

        public abstract int getRed​(int pixel)
        返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。 必要时进行颜色转换。 像素值被指定为int。 一个IllegalArgumentException如果这个像素值抛出ColorModel不便于表示为一个单个int。 返回的值不是预乘积值。 例如，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，则红色值为0。
        参数
        pixel - 指定像素
        结果
        指定像素的红色分量的值。

      • getGreen

        public abstract int getGreen​(int pixel)
        返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。 必要时进行颜色转换。 像素值被指定为int。 如果这个ColorModel像素值不方便地表示为单个int，则抛出一个IllegalArgumentException 。 返回的值是非预先乘以的值。 例如，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，则绿色值为0。
        参数
        pixel - 指定的像素
        结果
        指定像素的绿色分量的值。

      • getBlue

        public abstract int getBlue​(int pixel)
        返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。 必要时进行颜色转换。 像素值被指定为int。 一个IllegalArgumentException如果这个像素值抛出ColorModel不便于表示为一个单个int。 返回的值是一个非预先乘法的值，例如，如果alpha被预乘，则该方法在返回该值之前将其除数。 如果alpha值为0，则蓝色值为0。
        参数
        pixel - 指定的像素
        结果
        指定像素的蓝色分量的值。

      • getAlpha

        public abstract int getAlpha​(int pixel)
        返回指定像素的alpha分量，从0到255。像素值被指定为int。 一个IllegalArgumentException如果这个像素值抛出ColorModel不便于表示为一个单个int。
        参数
        pixel - 指定的像素
        结果
        指定像素的alpha分量的值。

      • getRGB

        public int getRGB​(int pixel)
        以默认RGB颜色模型格式返回像素的颜色/ alpha分量。 必要时进行颜色转换。 像素值被指定为int。 一个IllegalArgumentException抛出，如果这个像素值ColorModel不便于表示为一个单个int。 返回的值为非预先乘法格式。 例如，如果alpha被预乘，则该方法将其从颜色分量中分离出来。 如果alpha值为0，则颜色值为0。
        参数
        pixel - 指定的像素
        结果
        指定像素的颜色/ alpha分量的RGB值。
        另请参见：
        getRGBdefault()

      • getRed

        public int getRed​(Object inData)
        返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值由作为对象引用传入的transferType类型的数据元素数组指定。 返回的值是非预先乘以的值。 例如，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，则红色值为0.如果inData不是transferType类型的原始数组，则抛出ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 如果transferType不支持，一个UnsupportedOperationException将被抛出。 由于ColorModel是抽象类，任何实例必须是子类的实例。 子类继承此方法的实现，并且如果不重写，如果子类使用此方法抛出异常transferType比其他DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或DataBuffer.TYPE_INT 。
        参数
        inData - 像素值数组
        结果
        指定像素的红色分量的值。
        异常
        ClassCastException -如果 inData不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值
        UnsupportedOperationException - 如果这 transferType不支持此 ColorModel

      • getGreen

        public int getGreen​(Object inData)
        返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值由作为对象引用传入的transferType类型的数据元素数组指定。 返回的值将是非预倍增值。 例如，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，则绿色值为0.如果inData不是transferType类型的原始数组，则抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 如果不支持这个transferType ，将抛出一个UnsupportedOperationException 。 由于ColorModel是一个抽象类，任何实例都必须是一个子类的实例。 子类继承此方法的实现，并且如果不重写，如果子类使用此方法抛出异常transferType比其他DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或DataBuffer.TYPE_INT 。
        参数
        inData - 像素值数组
        结果
        指定像素的绿色分量的值。
        异常
        ClassCastException -如果 inData不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值
        UnsupportedOperationException - 如果这个 transferType不支持这个 ColorModel

      • getBlue

        public int getBlue​(Object inData)
        返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值由作为对象引用传入的transferType类型的数据元素数组指定。 返回的值是非预先乘以的值。 例如，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，蓝色值将为0.如果inData不是transferType类型的原始数组，则抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 如果transferType不支持，一个UnsupportedOperationException将被抛出。 由于ColorModel是一个抽象类，任何实例都必须是一个子类的实例。 子类继承此方法的实现，并且如果不重写，如果子类使用此方法抛出异常transferType比其他DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或DataBuffer.TYPE_INT 。
        参数
        inData - 像素值数组
        结果
        指定像素的蓝色分量的值。
        异常
        ClassCastException -如果 inData不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值
        UnsupportedOperationException - 如果这个 transferType不支持此 ColorModel

      • getAlpha

        public int getAlpha​(Object inData)
        返回指定像素的alpha分量，从0到255。像素值由传入类型transferType的数据元素数组指定为对象引用。 如果inData不是transferType类型的原始数组，则抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 如果transferType不支持，一个UnsupportedOperationException将被抛出。 由于ColorModel是一个抽象类，任何实例都必须是一个子类的实例。 子类继承此方法的实现，并且如果不重写，如果子类使用此方法抛出异常transferType比其他DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或DataBuffer.TYPE_INT 。
        参数
        inData - 指定的像素
        结果
        指定像素的alpha分量，从0到255。
        异常
        ClassCastException -如果 inData不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值
        UnsupportedOperationException - 如果这个 tranferType不支持这个 ColorModel

      • getRGB

        public int getRGB​(Object inData)
        以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。 必要时进行颜色转换。 像素值由作为对象引用传入的transferType类型的数据元素数组指定。 如果inData不是transferType类型的原始数组，则抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 返回的值将是非预先乘法的格式，即如果alpha被预乘，则该方法将其除以颜色分量（如果alpha值为0，则颜色值将为0）。
        参数
        inData - 指定的像素
        结果
        指定像素的颜色和alpha分量。
        另请参见：
        getRGBdefault()

      • getDataElements

        public Object getDataElements​(int rgb,
                              Object pixel)
        返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。 然后可以将该数组传递给WritableRaster对象的WritableRaster.setDataElements(int, int, java.lang.Object)方法。 如果像素变量为null ，则将分配一个新数组。 如果pixel不是null ，它必须是transferType类型的基本数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 返回像素数组。 如果transferType不支持，一个UnsupportedOperationException将被抛出。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法，因为该抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        rgb - 默认RGB颜色模型中的整数像素表示
        pixel - 指定的像素
        结果
        这个 ColorModel指定像素的数组表示。
        异常
        ClassCastException - 如果 pixel不是类型为 transferType的原始数组
        ArrayIndexOutOfBoundsException - 如果 pixel不够大，可以持有这个 ColorModel的像素值
        UnsupportedOperationException - 如果此方法不支持此 ColorModel
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getComponents

        public int[] getComponents​(int pixel,
                           int[] components,
                           int offset)
        在这个ColorModel给出了一个像素的非规范化颜色/ alpha分量的数组。 像素值被指定为int 。 一个IllegalArgumentException如果此像素值将被抛出ColorModel不便于表示为一个单一int或如果此颜色分量值ColorModel不在非标准化形式表示的方便。 例如，该方法可用于检索DirectColorModel特定像素值的DirectColorModel 。 如果组件数组为null ，则会分配一个新数组。 将返回组件数组。 颜色/ Alpha组件存储在从offset开始的组件数组中（即使数组是通过此方法分配的）。 如果组件数组不是null并且不够大，不能容纳所有颜色和alpha组件（从偏移开始），则抛出一个ArrayIndexOutOfBoundsException 。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法，因为此抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        pixel - 指定的像素
        components - 接收指定像素的颜色和alpha分量的数组
        offset - components阵列中的开始存储颜色和alpha组件的偏移量
        结果
        一个数组，包含从指定的偏移开始的指定像素的颜色和alpha分量。
        异常
        UnsupportedOperationException - 如果此方法不支持此 ColorModel

      • getComponents

        public int[] getComponents​(Object pixel,
                           int[] components,
                           int offset)
        在这个ColorModel给出一个像素的非规范化颜色/ alpha分量的数组。 像素值由作为对象引用传入的transferType类型的数据元素数组指定。 如果pixel不是transferType类型的原始数组，则抛出一个ClassCastException 。 如果这个ColorModel颜色分量值不能以非规范化形式方便地表示， IllegalArgumentException将抛出一个IllegalArgumentException 。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 该方法可用于检索任何ColorModel特定像素值的ColorModel 。 如果组件数组是null ，将分配一个新的数组。 将返回组件数组。 颜色/ alpha分量存储中components数组以offset （即使该阵列由这种方法分配的）。 一个ArrayIndexOutOfBoundsException如果components数组是不被抛出null ，不足够大以容纳所有的颜色和alpha分量（开始于offset ）。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法，因为该抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        pixel - 指定的像素
        components - 接收指定像素的颜色和alpha分量的数组
        offset - 索引到 components阵列中，开始存储指定像素的颜色和alpha分量
        结果
        一个数组，包含从指定的偏移开始的指定像素的颜色和alpha分量。
        异常
        UnsupportedOperationException - 如果此方法不支持此 ColorModel

      • getUnnormalizedComponents

        public int[] getUnnormalizedComponents​(float[] normComponents,
                                       int normOffset,
                                       int[] components,
                                       int offset)
        给定一个归一化的组件数组，以非规范化形式返回所有颜色/ alpha分量的数组。 非正则化分量是0和2 n -1之间的无符号积分值，其中n是特定分量的位数。 正规化成分是每分量最小和最大由指定之间的浮点值ColorSpace对象此ColorModel 。 如果该ColorModel颜色分量值不能以非规范化形式方便地表示， IllegalArgumentException将抛出ColorModel 。 如果components数组为null ，则将分配一个新数组。 将返回components数组。 颜色/ alpha分量存储中components数组以offset （即使该阵列由这种方法分配的）。 一个ArrayIndexOutOfBoundsException ，如果被抛出components数组不null ，不足够大以容纳所有的颜色和alpha分量（开始于offset ）。 一个IllegalArgumentException如果抛出normComponents阵列是不是大到足以容纳所有开始在颜色和alpha分量normOffset 。
        参数
        normComponents - 包含归一化组件的数组
        normOffset - 要开始检索归一化组件的 normComponents阵列的偏移量
        components - 从 normComponents接收组件的数组
        offset - 索引为 components ，开始存储标准化组件 normComponents
        结果
        包含非标准化颜色和alpha组件的数组。
        异常
        IllegalArgumentException - 如果此 ColorModel的组件值不方便地以非规范化形式表示。
        IllegalArgumentException - 如果 normComponents减去 normOffset的长度小于 numComponents
        UnsupportedOperationException - 如果这个ColorModel的构造ColorModel称为super(bits)构造函数，但没有覆盖此方法。 参见构造函数， ColorModel(int) 。

      • getNormalizedComponents

        public float[] getNormalizedComponents​(int[] components,
                                       int offset,
                                       float[] normComponents,
                                       int normOffset)
        给定一个非规范化的组件数组，以归一化形式返回所有颜色/ alpha分量的数组。 非正则化分量是0和2 n -1之间的无符号积分值，其中n是特定分量的位数。 正规化成分是每分量最小和最大由指定之间的浮点值ColorSpace对象此ColorModel 。 一个IllegalArgumentException如果这种颜色成分值会被抛出ColorModel不便于用非标准化形式表示。 如果normComponents数组为null ，则将分配一个新数组。 将返回normComponents数组。 颜色/ alpha分量存储中normComponents数组以normOffset （即使该阵列由这种方法分配的）。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents数组不null ，不足够大以容纳所有的颜色和alpha分量（开始于normOffset ）。 一个IllegalArgumentException如果抛出components阵列是不是大到足以容纳所有开始在颜色和alpha分量offset 。

        由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 此抽象类中此方法的默认实现假定此类的组件值可以非规范化形式方便地表示。 因此，可能具有不支持非规范化形式的实例的子类必须覆盖此方法。

        参数
        components - 包含非规范化组件的数组
        offset - components阵列的偏移量，用于开始检索非规范化组件
        normComponents - 接收归一化组件的数组
        normOffset - 索引到 normComponents ，开始存储归一化组件
        结果
        包含归一化颜色和alpha组件的数组。
        异常
        IllegalArgumentException - 如果此 ColorModel的组件值不方便地以非规范化形式表示。
        UnsupportedOperationException - 如果这个ColorModel的构造ColorModel称为super(bits)构造函数，但没有覆盖此方法。 参见构造函数， ColorModel(int) 。
        UnsupportedOperationException - 如果此方法无法确定每个组件的位数

      • getDataElement

        public int getDataElement​(int[] components,
                          int offset)
        返回表示为一个像素值int在此ColorModel ，给定非标准化颜色/ alpha分量的阵列。 此方法将引发IllegalArgumentException ;如果此组件值ColorModel不如便于表示单个int或如果此颜色分量值ColorModel不在非标准化形式表示的方便。 一个ArrayIndexOutOfBoundsException ，如果被抛出components阵列是没有大到足以容纳所有的颜色和alpha分量（开始于offset ）。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须覆盖此方法，因为此抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        components - 非规范化颜色和alpha组件的数组
        offset - 索引到 components开始检索颜色和alpha组件
        结果
        这个 int像素值在这个 ColorModel对应的指定组件。
        异常
        IllegalArgumentException - 如果这个 ColorModel像素值不能方便地表示为一个 int
        IllegalArgumentException - 如果该 ColorModel组件值不方便地以非规范化形式表示
        ArrayIndexOutOfBoundsException - 如果 components阵列不够大，不能保持从 offset开始的所有颜色和alpha组件
        UnsupportedOperationException - 如果此方法不支持此 ColorModel

      • getDataElements

        public Object getDataElements​(int[] components,
                              int offset,
                              Object obj)
        给出这个ColorModel的一个像素的数据元素数组表示，给出了一个非标准化颜色/ alpha分量的数组。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 此方法将抛出IllegalArgumentException如果此颜色分量值ColorModel不便于用非标准化形式表示。 一个ArrayIndexOutOfBoundsException ，如果被抛出components阵列是没有大到足以容纳所有的颜色和alpha分量（开始于offset ）。 如果obj变量为null ，则将分配一个新数组。 如果obj不是null ，它必须是一个类型为transferType的原始数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出obj不够大，不能保存这个像素值ColorModel 。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写这个方法，因为这个抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        components - 非规范化颜色和alpha组件的数组
        offset - 索引到 components ，开始检索颜色和alpha组件
        obj - 表示一系列颜色和alpha组件的 Object
        结果
        一个 Object表示一个颜色和alpha组件的数组。
        异常
        ClassCastException -如果 obj不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 obj不够大，不能容纳 ColorModel的像素值，或者 components阵列不够大，不能容纳所有颜色和alpha组件，从 offset开始
        IllegalArgumentException - 如果该 ColorModel组件值不方便地以非规范化形式表示
        UnsupportedOperationException - 如果此方法不支持此 ColorModel
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getDataElement

        public int getDataElement​(float[] normComponents,
                          int normOffset)
        给出一个归一化的颜色/ alpha分量的数组，返回在这个ColorModel表示为int的像素值。 这个方法会抛出一个IllegalArgumentException如果这个ColorModel像素值不方便地表示为一个int 。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents阵列是没有大到足以容纳所有的颜色和alpha分量（开始于normOffset ）。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 此抽象类中此方法的默认实现首先将规范化形式转换getDataElement(int[], int)规范化形式，然后调用getDataElement(int[], int) 。 可能具有不支持非规范化形式的实例的子类必须覆盖此方法。
        参数
        normComponents - 归一化颜色和alpha组件的数组
        normOffset - 索引到 normComponents ，开始检索颜色和alpha组件
        结果
        这个 int像素值在这个 ColorModel对应的指定组件。
        异常
        IllegalArgumentException - 如果这个 ColorModel像素值不方便地表示为一个 int
        ArrayIndexOutOfBoundsException - 如果 normComponents数组不够大，不能容纳从 normOffset开始的所有颜色和alpha组件
        从以下版本开始：
        1.4

      • getDataElements

        public Object getDataElements​(float[] normComponents,
                              int normOffset,
                              Object obj)
        给出这个ColorModel中的像素的数据元素数组表示，给出了一组归一化的颜色/ alpha分量。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents阵列是没有大到足以容纳所有的颜色和alpha分量（开始于normOffset ）。 如果obj变量为null ，则会分配一个新数组。 如果obj不是null ，它必须是一个类型为transferType的原始数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出obj不够大，不能保存这个像素值ColorModel 。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 此抽象类中此方法的默认实现首先将规范化形式转换getDataElement(int[], int, Object)规范化形式，然后调用getDataElement(int[], int, Object) 。 可能具有不支持非规范化形式的实例的子类必须覆盖此方法。
        参数
        normComponents - 归一化颜色和alpha组件的数组
        normOffset - 索引到 normComponents ，开始检索颜色和alpha组件
        obj - 用于保存返回像素的原始数据数组
        结果
        一个 Object ，它是像素的原始数据阵列表示
        异常
        ClassCastException -如果 obj不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 obj不够大，不足以持有这个 ColorModel的像素值，或者 normComponents阵列不够大，不能容纳所有颜色和alpha分量，从 normOffset开始
        从以下版本开始：
        1.4
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getNormalizedComponents

        public float[] getNormalizedComponents​(Object pixel,
                                       float[] normComponents,
                                       int normOffset)
        给出这个ColorModel一个像素，返回所有颜色/ alpha分量的ColorModel 。 像素值由作为对象引用传入的transferType类型的数据元素数组指定。 如果像素不是transferType类型的原始数组，则抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 正规化成分是每分量最小和最大由指定之间的浮点值ColorSpace对象此ColorModel 。 如果normComponents阵列为null ，则将分配一个新阵列。 将返回normComponents数组。 颜色/ alpha分量存储中normComponents数组以normOffset （即使该阵列由这种方法分配的）。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents数组不null ，不足够大以容纳所有的颜色和alpha分量（开始于normOffset ）。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 此抽象类中此方法的默认实现首先使用getComponents(Object, int[], int)检索非规范化形式的颜色和alpha组件，然后调用getNormalizedComponents(int[], int, float[], int) 。 可能具有不支持非规范化形式的实例的子类必须覆盖此方法。
        参数
        pixel - 指定的像素
        normComponents - 用于接收标准化组件的数组
        normOffset - normComponents阵列中的起始存储归一化分量的偏移量
        结果
        包含归一化颜色和alpha组件的数组。
        异常
        ClassCastException - 如果 pixel不是transferType类型的原始数组
        ArrayIndexOutOfBoundsException - 如果 normComponents不够大，不能容纳所有颜色和alpha组件，从 normOffset开始
        ArrayIndexOutOfBoundsException - 如果 pixel不够大，不能容纳 ColorModel的像素值。
        UnsupportedOperationException - 如果这个ColorModel的构造ColorModel称为super(bits)构造函数，但没有覆盖此方法。 见构造函数， ColorModel(int) 。
        UnsupportedOperationException - 如果此方法无法确定每个组件的位数
        从以下版本开始：
        1.4

      • equals

        public boolean equals​(Object obj)
        该方法简单地委托到Object的默认实现，这与==测试相同，因为该类不能在多个独立子类分支之间强制执行正确的等式测试的问题。 鼓励子类覆盖此方法，并为其自己的属性提供等式测试，以及ColorModel的以下常见基础属性的等式测试：
        • 支持alpha组件。
        • 是alpha预乘。
        • 每像素位数
        • 透明度类型，如不透明度，位掩模或半透明。
        • 像素中的分量数。
        • ColorSpace类型。
        • 用于表示像素值的数组的类型。
        • 每个颜色和alpha分量的有效位数。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        该方法简单地委托给Object的默认实现，它返回该类的系统ID。 鼓励子类覆盖此方法，并为其自己的属性提供散列，除了散列以下公共基本属性的ColorModel ：
        • 支持alpha组件。
        • 是alpha预乘。
        • 每像素位数
        • 透明度类型，如不透明度，位掩模或半透明。
        • 像素中的分量数。
        • ColorSpace类型。
        • 用于表示像素值的数组的类型。
        • 每个颜色和alpha分量的有效位数。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getColorSpace

        public final ColorSpace getColorSpace​()
        返回 ColorSpace与此相关 ColorModel 。
        结果
        这 ColorSpace的 ColorModel 。

      • coerceData

        public ColorModel coerceData​(WritableRaster raster,
                             boolean isAlphaPremultiplied)
        强制光栅数据与isAlphaPremultiplied变量中指定的状态相匹配，假设目前ColorModel正确描述了数据。 它可以将颜色光栅数据乘以或除以alpha，如果数据处于正确状态，则不执行任何操作。 如果需要强制数据，那么这个方法也会返回一个ColorModel一个实例，其中isAlphaPremultiplied标志是适当的。 这个方法会抛出一个UnsupportedOperationException如果这个ColorModel不支持。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法，因为该抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        raster - WritableRaster数据
        isAlphaPremultiplied - true如果alpha是预乘的; 否则为false
        结果
        一个表示强制数据的 ColorModel对象。

      • isCompatibleRaster

        public boolean isCompatibleRaster​(Raster raster)
        如果raster与raster兼容， ColorModel ， false返回true 。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法，因为该抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        raster - 要测试兼容性的Raster对象
        结果
        true如果 raster与此 ColorModel兼容。
        异常
        UnsupportedOperationException - 如果这个方法还没有被实现 ColorModel

      • createCompatibleWritableRaster

        public WritableRaster createCompatibleWritableRaster​(int w,
                                                     int h)
        创建WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容ColorModel 。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法，因为该抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        w - 要应用于新的 WritableRaster的宽度
        h - 适用于新的 WritableRaster的高度
        结果
        一个 WritableRaster具有指定宽度和高度的对象。
        异常
        UnsupportedOperationException - 如果此方法不支持此 ColorModel
        另请参见：
        WritableRaster ， SampleModel

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建SampleModel具有指定的宽度和高度，具有与此兼容的数据布局ColorModel 。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须覆盖此方法，因为该抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        w - 适用于新的 SampleModel的宽度
        h - 适用于新的 SampleModel的高度
        结果
        一个 SampleModel对象具有指定的宽度和高度。
        异常
        UnsupportedOperationException - 如果此方法不支持此 ColorModel
        另请参见：
        SampleModel

      • isCompatibleSampleModel

        public boolean isCompatibleSampleModel​(SampleModel sm)
        检查SampleModel是否与此ColorModel兼容。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法，因为此抽象类中的实现会抛出一个UnsupportedOperationException 。
        参数
        sm - 指定的 SampleModel
        结果
        true如果指定的SampleModel与此兼容ColorModel ; 否则为false 。
        异常
        UnsupportedOperationException - 如果此方法不支持此 ColorModel
        另请参见：
        SampleModel

      • finalize

        @Deprecated(since="9")
public void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        一旦这个 ColorModel不再被引用， ColorModel与这个 ColorModel相关联的系统资源。
        重写：
        finalize在 Object
        另请参见：
        WeakReference ， PhantomReference

      • getAlphaRaster

        public WritableRaster getAlphaRaster​(WritableRaster raster)
        返回Raster表示图像的alpha通道，从输入中提取Raster ，提供此的像素值ColorModel表示颜色和alpha信息为独立的空间频带（例如ComponentColorModel和DirectColorModel ）。 该方法假设与这样的ColorModel相关联的Raster对象存储了α波段（如果存在）作为最后的图像数据带。 返回null ，如果有与此相关的独立空间alpha通道ColorModel 。 如果这是一个IndexColorModel在查找表中有alpha，该方法将返回null因为没有空间离散的alpha通道。 此方法将创建一个新的Raster （但将共享数据数组）。 由于ColorModel是一个抽象类，任何实例都是一个子类的实例。 子类必须重写此方法以获得除了返回null以外的任何行为，因为此抽象类中的实现将返回null 。
        参数
        raster - 指定的 Raster
        结果
        一个 Raster表示图像的alpha通道，从指定的获得 Raster 。

      • toString

        public String toString​()
        返回此 ColorModel对象的内容的 String表示。
        重写：
        toString在 Object
        结果
        一个 String代表这个 ColorModel对象的内容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ComponentColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ComponentColorModel

  • java.lang.Object
    • java.awt.image.ColorModel
      • java.awt.image.ComponentColorModel
  • All Implemented Interfaces:
    Transparency

    public class ComponentColorModel
extends ColorModel
    一个ColorModel类，用于将颜色和alpha信息表示为单独样本的像素值，并将每个样本存储在单独的数据元素中。 这个类可以随意使用ColorSpace 。 像素值中的颜色样本数必须与ColorSpace的颜色成ColorSpace 。 可能有一个单一的α样本。

    对于使用类型为transferType的原始数组像素表示的那些方法，数组长度与颜色和alpha样本的数量相同。 颜色样本首先存储在数组中，然后存储alpha样本。 颜色样本的顺序由ColorSpace指定。 通常，此顺序反映了颜色空间类型的名称。 例如，对于TYPE_RGB ，索引0对应于红色，索引1为绿色，索引2为蓝色。

    从显示或处理目的的像素样本值到颜色/α分量的转换是基于样本与分量的一一对应关系。 根据用于创建ComponentColorModel实例的传输类型，由该实例表示的像素样本值可能是有符号的或无符号的，并且可以是整数类型或浮点或双倍（详见下文）。 从样本值到归一化颜色/α分量的转换必须遵循某些规则。 对于浮点和双样本，转换是一个标识，即归一化分量值等于相应的样本值。 对于积分样本，平移应该只是一个简单的尺度和偏移，其中每个分量的比例和偏移常数可能不同。 应用比例和偏移常数的结果是一组颜色/α分量值，这些值保证在一定范围内。 通常，颜色分量的范围将是由ColorSpace类的getMinValue和getMaxValue方法定义的范围。 Alpha组件的范围应为0.0到1.0。

    的实例ComponentColorModel用传输类型创建DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT和DataBuffer.TYPE_INT具有被视为无符号整数值的像素样本值。 像素值的颜色或alpha样本中的位数可能与传递给ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int)构造函数的相应颜色或alpha样本的ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) 。 在这种情况下，该类假设样本值的最低有效n位保存分量值，其中n是传递给构造函数的分量的有效位数。 它还假定样本值中的任何高阶位都为零。 因此，采样值范围为0到2 n - 1。该类将这些采样值映射到归一化的颜色分量值，使得0映射到从每个分量的ColorSpace's getMinValue方法获得的值，2 n -1映射到从getMaxValue 。 要创建具有不同颜色样本映射的ComponentColorModel ，需要对getNormalizedComponents(Object, float[], int)子类化并覆盖getNormalizedComponents(Object, float[], int)方法。 alpha样本的映射始终将0映射到0.0和2 n - 1到1.0。

    对于具有无符号样本值的实例，仅当两个条件成立时才支持非标准化颜色/ alpha分量表示。 首先，样本值0必须映射到归一化分量值0.0和样本值2 n - 1到1.0。 第二， ColorSpace的所有颜色分量的最小/最大范围必须为0.0到1.0。 在这种情况下，分量表示是相应样本的n个最低有效位。 因此，每个分量是0和2 n -1之间的无符号积分值，其中n是特定分量的有效位数。 如果不满足这些条件，任何采用非规范化组件参数的方法将抛出一个IllegalArgumentException 。

    的实例ComponentColorModel用传输类型创建DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT和DataBuffer.TYPE_DOUBLE具有被视为有符号短，浮点型或双值的像素样本值。 这样的实例不支持非规范化的颜色/ alpha组件表示，所以在这些实例之一IllegalArgumentException时，任何采用这种表示形式作为参数的方法都将抛出一个IllegalArgumentException 。 该类的实例的归一化组件值具有取决于传输类型的范围，如下所示：对于浮动样本，浮点数据类型的全范围; 对于双样本，浮点数据类型的全范围（由铸造双倍浮动） 对于短样本，从大约-maxVal到+ maxVal，其中maxVal是ColorSpace （-32767映射到-maxVal，0映射到0.0，并且32767映射到+ maxVal）的每个分量最大值。 一个子类可以通过覆盖getNormalizedComponents(Object, float[], int)方法来覆盖短样本值到归一化分量值的getNormalizedComponents(Object, float[], int) 。 对于浮动和双样本，归一化分量值取为等于相应的样本值，子类不应尝试为这些传输类型添加任何非标识缩放。

    的实例ComponentColorModel用传输类型创建DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT和DataBuffer.TYPE_DOUBLE使用所有所有采样值的比特。 因此，所有的颜色/ alpha分量使用时具有16个比特DataBuffer.TYPE_SHORT使用时，32位DataBuffer.TYPE_FLOAT使用时，和64位DataBuffer.TYPE_DOUBLE 。 当这些传送类型之一使用ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int)形式的构造函数时，将忽略位数组参数。

    可能会有不能合理地将颜色/ alpha样本值解释为渲染的组件值。 当ComponentColorModel被子类化以覆盖无符号样本值到归一化颜色分量值的映射或使用特定范围之外的带符号样本值时，可能会发生这种情况。 （例如，将α分量指定为范围0到32767之外的带符号短值，归一化范围为0.0到1.0，可能会导致意想不到的结果）。应用程序有责任在渲染之前适当地缩放像素数据，使得颜色组分落在ColorSpace （使用ColorSpace类的getMinValue和getMaxValue方法获得）的归一化范围内，并且α分量在0.0和1.0之间。 如果颜色或α分量值落在这些范围之外，则渲染结果是不确定的。

    使用单个int像素表示形式的方法抛出IllegalArgumentException ，除非成分的用于数ComponentColorModel是一个和成分值是无符号的-使用的传输类型，换句话说，单一颜色分量DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或DataBuffer.TYPE_INT和没有阿尔法

    甲ComponentColorModel可以结合使用具有ComponentSampleModel ，一个BandedSampleModel或PixelInterleavedSampleModel构建BufferedImage 。

    另请参见：
    ColorModel ， ColorSpace ， ComponentSampleModel ， BandedSampleModel ， PixelInterleavedSampleModel ， BufferedImage

    • Field Summary

      • Fields inherited from class java.awt.image.ColorModel

        pixel_bits, transferType

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComponentColorModel​(ColorSpace colorSpace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
      从指定的参数构造一个 ComponentColorModel 。
      ComponentColorModel​(ColorSpace colorSpace, int[] bits, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
      从指定的参数构造一个 ComponentColorModel 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ColorModel coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制栅格数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设此数据目前正由 ColorModel描述。
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建具有指定宽度和高度的 SampleModel ，具有与此 ColorModel兼容的数据布局。
      WritableRaster createCompatibleWritableRaster​(int w, int h)
      创建具有指定宽度和高度的 WritableRaster ，具有与此 ColorModel兼容的数据布局（ SampleModel ）。
      boolean equals​(Object obj)
      测试指定 Object是一个实例 ComponentColorModel和等于这个 ComponentColorModel 。
      int getAlpha​(int pixel)
      返回指定像素的alpha分量，从0到255。
      int getAlpha​(Object inData)
      返回指定像素的alpha分量，从0到255。
      WritableRaster getAlphaRaster​(WritableRaster raster)
      返回 Raster表示从输入 Raster提取的图像的Alpha通道。
      int getBlue​(int pixel)
      返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。
      int getBlue​(Object inData)
      返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      int[] getComponents​(int pixel, int[] components, int offset)
      返回给这个 ColorModel一个像素的非规范化颜色/ alpha分量的数组。
      int[] getComponents​(Object pixel, int[] components, int offset)
      在这个 ColorModel给出一个像素的非规范化颜色/ alpha分量的数组。
      int getDataElement​(float[] normComponents, int normOffset)
      给出一个归一化的颜色/ alpha分量数组，返回 int中 ColorModel表示的像素值。
      int getDataElement​(int[] components, int offset)
      返回一个像这个 ColorModel的int表示的像素值，给出了一个非标准化颜色/ alpha分量的数组。
      Object getDataElements​(float[] normComponents, int normOffset, Object obj)
      给定一个归一化颜色/ alpha分量的数组，返回这个 ColorModel的一个像素的数据元素数组表示。
      Object getDataElements​(int[] components, int offset, Object obj)
      给出这个 ColorModel的一个像素的数据元素数组表示，给出了一个非标准化颜色/ alpha分量的数组。
      Object getDataElements​(int rgb, Object pixel)
      返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。
      int getGreen​(int pixel)
      返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。
      int getGreen​(Object inData)
      返回默认RGB ColorSpace （sRGB）中指定像素的绿色分量，从0到255。
      float[] getNormalizedComponents​(int[] components, int offset, float[] normComponents, int normOffset)
      给定一个非规范化的组件数组，以归一化形式返回所有颜色/ alpha分量的数组。
      float[] getNormalizedComponents​(Object pixel, float[] normComponents, int normOffset)
      给出这个 ColorModel一个像素，返回标准化形式的所有颜色/ alpha分量的 ColorModel 。
      int getRed​(int pixel)
      返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。
      int getRed​(Object inData)
      返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。
      int getRGB​(int pixel)
      以默认RGB颜色模型格式返回像素的颜色/ alpha分量。
      int getRGB​(Object inData)
      以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。
      int[] getUnnormalizedComponents​(float[] normComponents, int normOffset, int[] components, int offset)
      给定一个归一化的组件数组，以非规范化形式返回所有颜色/ alpha分量的数组。
      int hashCode​()
      返回此ComponentColorModel的哈希码。
      boolean isCompatibleRaster​(Raster raster)
      如果raster与此ColorModel兼容，则返回true; 假如不是的话。
      boolean isCompatibleSampleModel​(SampleModel sm)
      检查指定的 SampleModel是否与此 ColorModel兼容。

      • Methods inherited from class java.awt.image.ColorModel

        finalize, getColorSpace, getComponentSize, getComponentSize, getNumColorComponents, getNumComponents, getPixelSize, getRGBdefault, getTransferType, getTransparency, hasAlpha, isAlphaPremultiplied, toString

      • Methods inherited from class java.lang.Object

        clone, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ComponentColorModel

        public ComponentColorModel​(ColorSpace colorSpace,
                           int[] bits,
                           boolean hasAlpha,
                           boolean isAlphaPremultiplied,
                           int transparency,
                           int transferType)
        从指定的参数构造一个ComponentColorModel 。 颜色分量将在规定的ColorSpace 。 支持的传输类型为DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，并DataBuffer.TYPE_DOUBLE 。 如果不为空，则bits数组指定每个颜色和alpha分量的有效位数，如果像素值中没有alpha信息，则其长度应至少为ColorSpace的组件数，或者如果有阿尔法信息。 当transferType是DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或DataBuffer.TYPE_DOUBLE的bits数组参数被忽略。 hasAlpha指示是否存在α信息。 如果hasAlpha为真，则布尔值isAlphaPremultiplied指定如何在像素值中解释颜色和alpha样本。 如果布尔值为真，则假定颜色样本已被乘以α样本。 transparency指定可以通过此颜色模型表示哪些Alpha值。 可接受transparency值是OPAQUE ， BITMASK或TRANSLUCENT 。 transferType是用于表示像素值的原始数组的类型。
        参数
        colorSpace - 与此颜色模型相关联的 ColorSpace 。
        bits - 每个组件的有效位数。 可能为null，在这种情况下，所有组件样本的所有位都将显着。 如果transferType是DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一， DataBuffer.TYPE_SHORT忽略，在这种情况下，所有组件样本的所有位都将显着。
        hasAlpha - 如果为true，此颜色模型支持alpha。
        isAlphaPremultiplied - 如果为真，则为预 isAlphaPremultiplied 。
        transparency - 指定此颜色模型可以表示哪些alpha值。
        transferType - 指定用于表示像素值的基本数组的类型。
        异常
        IllegalArgumentException -如果 bits数组参数不为空，其长度小于颜色和alpha分量的数量，并且是的transferType之一 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT 。
        IllegalArgumentException -如果transferType时不是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。
        另请参见：
        ColorSpace ， Transparency

      • ComponentColorModel

        public ComponentColorModel​(ColorSpace colorSpace,
                           boolean hasAlpha,
                           boolean isAlphaPremultiplied,
                           int transparency,
                           int transferType)
        从指定的参数构造一个ComponentColorModel 。 颜色组件将在指定的ColorSpace 。 支持的传输类型为DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，并DataBuffer.TYPE_DOUBLE 。 每个颜色和alpha分量的有效位数分别为8,16,32,66,32或64。 颜色分量的数量将是ColorSpace中组件的ColorSpace 。 如果hasAlpha是true将会有一个alpha组件。 如果hasAlpha为真，则布尔值isAlphaPremultiplied指定如何在像素值中解释颜色和alpha样本。 如果布尔值为真，则假定颜色样本已被乘以α样本。 transparency指定了此颜色模型可以表示哪些Alpha值。 可接受transparency值是OPAQUE ， BITMASK或TRANSLUCENT 。 transferType是用于表示像素值的原始数组的类型。
        参数
        colorSpace - 与此颜色模型相关联的 ColorSpace 。
        hasAlpha - 如果为true，此颜色模型支持alpha。
        isAlphaPremultiplied - 如果为真， isAlphaPremultiplied alpha预乘。
        transparency - 指定此颜色模型可以表示哪些Alpha值。
        transferType - 指定用于表示像素值的基本数组的类型。
        异常
        IllegalArgumentException -如果transferType时不是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。
        从以下版本开始：
        1.4
        另请参见：
        ColorSpace ， Transparency

    • 方法详细信息

      • getRed

        public int getRed​(int pixel)
        返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。 必要时进行颜色转换。 像素值被指定为int。 返回的值将是非预倍增值。 如果alpha被预乘，则此方法在返回值之前将其除数（如果alpha值为0，则红色值为0）。
        Specified by:
        getRed在 ColorModel
        参数
        pixel - 要从中获取红色分量的像素。
        结果
        指定像素的红色分量，作为int。
        异常
        IllegalArgumentException - 如果这个 ColorModel有多个组件。
        IllegalArgumentException - 如果此 ColorModel的组件值已经签名

      • getGreen

        public int getGreen​(int pixel)
        返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。 必要时进行颜色转换。 像素值被指定为int。 返回的值将是非预倍增值。 如果alpha被预乘，则该方法在返回值之前将其除数（如果alpha值为0，则绿色值为0）。
        Specified by:
        getGreen在 ColorModel
        参数
        pixel - 要从中获取绿色成分的像素。
        结果
        指定像素的绿色分量，作为int。
        异常
        IllegalArgumentException - 如果这个 ColorModel有多个组件。
        IllegalArgumentException - 如果此 ColorModel的组件值已签名

      • getBlue

        public int getBlue​(int pixel)
        返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。 必要时进行颜色转换。 像素值被指定为int。 返回的值将是非预倍增值。 如果alpha被预乘，则该方法在返回值之前将其除数（如果alpha值为0，则蓝色值为0）。
        Specified by:
        getBlue在 ColorModel
        参数
        pixel - 要从中获取蓝色分量的像素。
        结果
        指定像素的蓝色分量，以int为单位。
        异常
        IllegalArgumentException - 如果这个 ColorModel有多个组件。
        IllegalArgumentException -如果此组件值 ColorModel签署

      • getAlpha

        public int getAlpha​(int pixel)
        返回指定像素的alpha分量，从0到255。像素值被指定为int。
        Specified by:
        getAlpha在 ColorModel
        参数
        pixel - 要从中获取alpha分量的像素。
        结果
        指定像素的alpha分量，作为int。
        异常
        IllegalArgumentException - 如果这个 ColorModel有多个组件。
        IllegalArgumentException -如果此组件值 ColorModel签署

      • getRGB

        public int getRGB​(int pixel)
        以默认RGB颜色模型格式返回像素的颜色/ alpha分量。 必要时进行颜色转换。 返回的值将是非预先乘法格式。 如果alpha被预乘，则该方法将其从颜色分量中分离出来（如果alpha值为0，则颜色值将为0）。
        重写：
        getRGB在 ColorModel
        参数
        pixel - 要从中获取颜色/ alpha分量的像素。
        结果
        指定像素的颜色/ alpha分量，作为int。
        异常
        IllegalArgumentException - 如果这个 ColorModel有多个组件。
        IllegalArgumentException - 如果此 ColorModel的组件值已经签名
        另请参见：
        ColorModel.getRGBdefault()

      • getRed

        public int getRed​(Object inData)
        返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。 必要时进行颜色转换。 pixel值由作为对象引用传递的类型为transferType的数据元素数组指定。 返回的值将是非预倍增值。 如果alpha被预乘，则此方法在返回值之前将其除数（如果alpha值为0，则红色值为0）。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。
        重写：
        getRed在 ColorModel
        参数
        inData - 要从中获取红色颜色分量的像素，由 transferType类型的数据元素数组指定。
        结果
        指定像素的红色分量，作为int。
        异常
        ClassCastException - 如果 inData不是类型为 transferType的原始数组。
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能容纳 ColorModel的像素值。
        UnsupportedOperationException -如果此的传输类型 ComponentColorModel是不支持的传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。

      • getGreen

        public int getGreen​(Object inData)
        返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 pixel值由作为对象引用传递的类型为transferType的数据元素数组指定。 返回的值是非预先乘以的值。 如果alpha被预乘，则该方法在返回值之前将其除数（如果alpha值为0，则绿色值为0）。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。
        重写：
        getGreen在 ColorModel
        参数
        inData - 要从中获取绿色分量的像素，由 transferType类型的数据元素数组指定。
        结果
        指定像素的绿色分量，作为int。
        异常
        ClassCastException - 如果 inData不是类型为 transferType的原始数组。
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值。
        UnsupportedOperationException -如果此的传输类型 ComponentColorModel是不支持的传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。

      • getBlue

        public int getBlue​(Object inData)
        返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 pixel值由作为对象引用传递的类型为transferType的数据元素数组指定。 返回的值是非预先乘以的值。 如果alpha被预乘，则该方法在返回值之前将其除数（如果alpha值为0，则蓝色值为0）。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果使用不支持的transferType它们将抛出异常。
        重写：
        getBlue在 ColorModel
        参数
        inData - 要从中获取蓝色分量的像素，由 transferType类型的数据元素数组指定。
        结果
        指定像素的蓝色分量，以int为单位。
        异常
        ClassCastException - 如果 inData不是类型为 transferType的原始数组。
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值。
        UnsupportedOperationException -如果此的传输类型 ComponentColorModel是不支持的传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。

      • getAlpha

        public int getAlpha​(Object inData)
        返回指定像素的alpha分量，从0到255进行比例。像素值由作为对象引用传入的数据元素数组transferType指定。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果使用不支持的transferType它们将抛出异常。
        重写：
        getAlpha在 ColorModel
        参数
        inData - 要从中获取alpha分量的像素，由 transferType类型的数据元素数组指定。
        结果
        指定像素的alpha分量，作为int。
        异常
        ClassCastException - 如果 inData不是类型为 transferType的原始数组。
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能容纳 ColorModel的像素值。
        UnsupportedOperationException -如果此的传输类型 ComponentColorModel是不支持的传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。

      • getRGB

        public int getRGB​(Object inData)
        以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。 必要时进行颜色转换。 像素值由作为对象引用传递的类型为transferType的数据元素数组指定。 返回的值为非预先乘法格式。 如果alpha被预乘，则该方法将其从颜色分量中分离出来（如果alpha值为0，则颜色值将为0）。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果使用不支持的transferType ，则它们将抛出异常。
        重写：
        getRGB在 ColorModel
        参数
        inData - 要从中获取颜色/ alpha分量的像素，由 transferType类型的数据元素数组指定。
        结果
        指定像素的颜色/ alpha分量，作为int。
        异常
        ClassCastException - 如果 inData不是类型为 transferType的原始数组。
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值。
        UnsupportedOperationException -如果此的传输类型 ComponentColorModel是不支持的传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。
        另请参见：
        ColorModel.getRGBdefault()

      • getDataElements

        public Object getDataElements​(int rgb,
                              Object pixel)
        返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 如果pixel参数为空，则分配一个新数组。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，则如果使用不支持的transferType ，则它们会抛出异常。
        重写：
        getDataElements在 ColorModel
        参数
        rgb - RGB颜色模型中像素的整数表示
        pixel - 指定的像素
        结果
        这个 ColorModel中的像素的数据元素数组表示。
        异常
        ClassCastException - 如果 pixel不为空并且不是类型为 transferType的原始数组。
        ArrayIndexOutOfBoundsException - 如果 pixel不够大，不能保持这个 ColorModel的像素值。
        UnsupportedOperationException -如果此的传输类型 ComponentColorModel是不支持的传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getComponents

        public int[] getComponents​(int pixel,
                           int[] components,
                           int offset)
        在这个ColorModel给出一个像素的返回一个非标准化颜色/ alpha分量的数组。 如果该ColorModel的组件值不方便地以非规范化形式表示，则会抛出IllegalArgumentException异常。 颜色/ alpha分量存储中components数组以offset （即使该阵列由这种方法分配的）。
        重写：
        getComponents在 ColorModel
        参数
        pixel - 指定为整数的像素值。
        components - 一个整数数组，用于存储非标准化颜色/ alpha分量。 如果components数组为空，则会分配一个新数组。
        offset - 一个偏移到 components数组。
        结果
        组件数组。
        异常
        IllegalArgumentException - 如果这个 ColorModel有多个组件。
        IllegalArgumentException - 如果这个 ColorModel不支持非规范化形式
        ArrayIndexOutOfBoundsException - 如果 components数组不为空，并且不够大以容纳所有颜色和alpha分量（从偏移开始）。

      • getComponents

        public int[] getComponents​(Object pixel,
                           int[] components,
                           int offset)
        在这个ColorModel给出了一个像素的非规范化颜色/ alpha分量的数组。 像素值由作为对象引用传入的数据元素transferType的数组指定。 如果此ColorModel的组件值不方便地以非规范化形式表示，则会抛出IllegalArgumentException异常。 颜色/ alpha分量存储中components数组以offset （即使该阵列由这种方法分配的）。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，并且如果它们不覆盖它，那么如果使用不支持的方法，则此方法可能会引发异常transferType 。
        重写：
        getComponents在 ColorModel
        参数
        pixel - 由 transferType类型的数据元素数组指定的像素值。
        components - 用于存储非标准化颜色/ alpha分量的整数数组。 如果components数组为空，则会分配一个新数组。
        offset - 一个偏移到 components数组。
        结果
        components阵列。
        异常
        IllegalArgumentException - 如果这个 ComponentColorModel不支持非规范化形式
        UnsupportedOperationException -在某些情况下，当且仅当该移交类型 ComponentColorModel不是以下传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT 。
        ClassCastException - 如果 pixel不是类型为 transferType的原始数组。
        IllegalArgumentException - 如果 components数组不为空，并且不够大，不足以容纳所有颜色和alpha分量（从偏移开始），或者如果 pixel不够大，不能持有该ColorModel的像素值。

      • getUnnormalizedComponents

        public int[] getUnnormalizedComponents​(float[] normComponents,
                                       int normOffset,
                                       int[] components,
                                       int offset)
        给定一个归一化的组件数组，以非规范化形式返回所有颜色/ alpha分量的数组。 非正则化分量是0和2 n -1之间的无符号积分值，其中n是特定分量的位数。 正规化成分是每分量最小和最大由指定之间的浮点值ColorSpace对象此ColorModel 。 如果这个ColorModel颜色分量值不方便地以非规范化形式表示， IllegalArgumentException将抛出一个IllegalArgumentException 。 如果components阵列为null ，则将分配一个新阵列。 将返回components数组。 颜色/ alpha分量存储中components数组以offset （即使该阵列由这种方法分配的）。 一个ArrayIndexOutOfBoundsException ，如果被抛出components数组不null ，不足够大以容纳所有的颜色和alpha分量（开始于offset ）。 一个IllegalArgumentException如果抛出normComponents阵列是不是大到足以容纳所有开始在颜色和alpha分量normOffset 。
        重写：
        getUnnormalizedComponents在 ColorModel
        参数
        normComponents - 包含归一化组件的数组
        normOffset - normComponents数组的偏移量，用于开始检索归一化组件
        components - 从 normComponents接收组件的数组
        offset - 索引到 components开始存储标准化组件从 normComponents
        结果
        包含非标准化颜色和alpha组件的数组。
        异常
        IllegalArgumentException - 如果这个 ComponentColorModel不支持非规范化形式
        IllegalArgumentException - 如果 normComponents减去 normOffset的长度小于 numComponents

      • getNormalizedComponents

        public float[] getNormalizedComponents​(int[] components,
                                       int offset,
                                       float[] normComponents,
                                       int normOffset)
        给定一个非规范化的组件数组，以归一化形式返回所有颜色/ alpha分量的数组。 非正则化分量是0和2 n -1之间的无符号积分值，其中n是特定分量的位数。 正规化成分是每分量最小和最大由指定之间的浮点值ColorSpace对象此ColorModel 。 一个IllegalArgumentException如果这种颜色成分值会被抛出ColorModel不便于用非标准化形式表示。 如果normComponents阵列为null ，则将分配一个新阵列。 将返回normComponents数组。 颜色/ alpha分量存储中normComponents数组以normOffset （即使该阵列由这种方法分配的）。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents数组不null ，不足够大以容纳所有的颜色和alpha分量（开始于normOffset ）。 一个IllegalArgumentException如果抛出components阵列是不是大到足以容纳所有开始在颜色和alpha分量offset 。
        重写：
        getNormalizedComponents在 ColorModel
        参数
        components - 包含非规范化组件的数组
        offset - components阵列的偏移量，用于开始检索非规范化组件
        normComponents - 接收归一化组件的数组
        normOffset - 索引到 normComponents开始存储归一化组件
        结果
        包含归一化颜色和alpha组件的数组。
        异常
        IllegalArgumentException - 如果这个 ComponentColorModel不支持非规范化形式

      • getDataElement

        public int getDataElement​(int[] components,
                          int offset)
        给出一个非标准化颜色/ alpha分量的数组，返回在这个 ColorModel以int表示的像素值。
        重写：
        getDataElement在 ColorModel
        参数
        components - 非规范化颜色/ alpha组件的数组。
        offset - 一个偏移到 components数组。
        结果
        以int形式表示的像素值。
        异常
        IllegalArgumentException - 如果这个 ColorModel有多个组件。
        IllegalArgumentException - 如果这个 ComponentColorModel不支持非规范化形式

      • getDataElements

        public Object getDataElements​(int[] components,
                              int offset,
                              Object obj)
        给出一个非规范化颜色/ alpha分量的数组，返回此ColorModel中的像素的数据元素数组表示。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。
        重写：
        getDataElements在 ColorModel
        参数
        components - 非规范化颜色/ alpha组件的数组。
        offset - components数组中的整数偏移量。
        obj - 存储像素的数据元素数组表示形式的对象。 如果obj变量为null，则会分配一个新数组。 如果obj不为空，则它必须是transferType类型的原始数组。 一个ArrayIndexOutOfBoundsException如果抛出obj不够大，不能保存这个像素值ColorModel 。 由于ComponentColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。
        结果
        这个 ColorModel的一个像素的数据元素数组表示。
        异常
        IllegalArgumentException - 如果组件数组不够大以容纳所有颜色和alpha组件（从偏移开始）。
        ClassCastException - 如果 obj不为空并且不是类型为 transferType的原始数组。
        ArrayIndexOutOfBoundsException - 如果 obj不够大，不能保持这个 ColorModel的像素值。
        IllegalArgumentException - 如果这个 ComponentColorModel不支持非规范化形式
        UnsupportedOperationException -如果该转移型 ComponentColorModel不是以下传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT 。
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getDataElement

        public int getDataElement​(float[] normComponents,
                          int normOffset)
        返回表示为一个像素值int在此ColorModel ，给定的归一化的颜色/ alpha分量的阵列。 这个方法会抛出一个IllegalArgumentException如果这个ColorModel像素值不方便地表示为一个int 。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents阵列是没有大到足以容纳所有的颜色和alpha分量（开始于normOffset ）。
        重写：
        getDataElement在 ColorModel
        参数
        normComponents - 归一化颜色和alpha分量的数组
        normOffset - 索引到 normComponents开始检索颜色和alpha组件
        结果
        这个 int像素值在这个 ColorModel对应的指定组件。
        异常
        IllegalArgumentException - 如果这个 ColorModel像素值不方便地表示为一个 int
        ArrayIndexOutOfBoundsException - 如果 normComponents阵列不够大，不能容纳所有颜色和alpha组件，从 normOffset开始
        从以下版本开始：
        1.4

      • getDataElements

        public Object getDataElements​(float[] normComponents,
                              int normOffset,
                              Object obj)
        给出一个标准化颜色/ alpha分量的数组，返回这个ColorModel像素的数据元素数组表示。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents阵列是没有大到足以容纳所有的颜色和alpha分量（开始于normOffset ）。 如果obj变量为null ，则会分配一个新数组。 如果obj不是null ，它必须是一个类型为transferType的原始数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出obj不够大，不能保存这个像素值ColorModel 。
        重写：
        getDataElements在 ColorModel
        参数
        normComponents - 归一化颜色和alpha组件的数组
        normOffset - 索引到 normComponents ，开始检索颜色和alpha组件
        obj - 用于保存返回像素的原始数据数组
        结果
        一个 Object ，它是像素的原始数据阵列表示
        异常
        ClassCastException -如果 obj不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 obj不够大以容纳 ColorModel的像素值，或 normComponents阵列不够大，不足以容纳所有颜色和alpha分量从 normOffset开始
        从以下版本开始：
        1.4
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getNormalizedComponents

        public float[] getNormalizedComponents​(Object pixel,
                                       float[] normComponents,
                                       int normOffset)
        给出这个ColorModel一个像素，以归一化形式返回所有颜色/ alpha分量的ColorModel 。 像素值由作为对象引用传入的transferType类型的数据元素数组指定。 如果像素不是transferType类型的原始数组，则抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 正规化成分是每分量最小和最大由指定之间的浮点值ColorSpace对象此ColorModel 。 如果normComponents阵列为null ，则将分配一个新阵列。 将返回normComponents阵列。 颜色/ alpha分量存储中normComponents数组以normOffset （即使该阵列由这种方法分配的）。 一个ArrayIndexOutOfBoundsException ，如果被抛出normComponents数组不null ，不足够大以容纳所有的颜色和alpha分量（开始于normOffset ）。

        如果该子类被设计为以非默认方式将像素样本值转换为颜色分量值，则此子类必须被子类覆盖。 该类实现的默认翻译在类注释中描述。 实现非默认翻译的任何子类必须遵循在那里定义的允许翻译的约束。

        重写：
        getNormalizedComponents在 ColorModel
        参数
        pixel - 指定的像素
        normComponents - 一个接收归一化组件的数组
        normOffset - normComponents阵列的偏移量，用于开始存储归一化分量
        结果
        包含归一化颜色和alpha组件的数组。
        异常
        ClassCastException - 如果 pixel不是transferType类型的原始数组
        ArrayIndexOutOfBoundsException - 如果 normComponents不够大，不能容纳所有颜色和alpha组件，从 normOffset开始
        ArrayIndexOutOfBoundsException - 如果 pixel不够大，不能容纳 ColorModel的像素值。
        从以下版本开始：
        1.4

      • coerceData

        public ColorModel coerceData​(WritableRaster raster,
                             boolean isAlphaPremultiplied)
        强制光栅数据与isAlphaPremultiplied变量中指定的状态相匹配，假设目前ColorModel正确描述了数据。 它可以将颜色光栅数据乘以或除以alpha，如果数据处于正确状态，则不执行任何操作。 如果需要强制数据，则该方法还会返回ColorModel一个实例， ColorModel适当地设置了isAlphaPremultiplied标志。 由于ColorModel可以被子类化，子类继承了该方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。
        重写：
        coerceData在 ColorModel
        参数
        raster - WritableRaster数据
        isAlphaPremultiplied - true如果alpha是预乘的; 否则为false
        结果
        一个 ColorModel对象，表示强制数据。
        异常
        NullPointerException - 如果 raster是 null并且需要数据强制。
        UnsupportedOperationException -如果此的传输类型 ComponentColorModel是不支持的传输类型之一： DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ， DataBuffer.TYPE_INT ， DataBuffer.TYPE_SHORT ， DataBuffer.TYPE_FLOAT ，或 DataBuffer.TYPE_DOUBLE 。

      • isCompatibleRaster

        public boolean isCompatibleRaster​(Raster raster)
        如果raster与此ColorModel兼容，则返回true; 假如不是的话。
        重写：
        isCompatibleRaster在 ColorModel
        参数
        raster - 要测试兼容性的 Raster对象。
        结果
        true如果 raster与此兼容 ColorModel ， false ，如果它不是。

      • createCompatibleWritableRaster

        public WritableRaster createCompatibleWritableRaster​(int w,
                                                     int h)
        创建具有指定宽度和高度的 WritableRaster ，具有与此 ColorModel兼容的数据布局（ SampleModel ）。
        重写：
        createCompatibleWritableRaster在 ColorModel
        参数
        w - 您要创建的 WritableRaster的宽度。
        h - 要创建的 WritableRaster的高度。
        结果
        A WritableRaster与此兼容 ColorModel 。
        另请参见：
        WritableRaster ， SampleModel

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建一个具有指定宽度和高度的 SampleModel ，具有与此 ColorModel兼容的数据布局。
        重写：
        createCompatibleSampleModel在 ColorModel
        参数
        w - 您要创建的 SampleModel的宽度。
        h - 要创建的 SampleModel的高度。
        结果
        A SampleModel与此兼容 ColorModel 。
        另请参见：
        SampleModel

      • isCompatibleSampleModel

        public boolean isCompatibleSampleModel​(SampleModel sm)
        检查指定的 SampleModel是否与此 ColorModel兼容。
        重写：
        isCompatibleSampleModel在 ColorModel
        参数
        sm - SampleModel测试兼容性。
        结果
        true如果 SampleModel与此兼容 ColorModel ， false ，如果它不是。
        另请参见：
        SampleModel

      • getAlphaRaster

        public WritableRaster getAlphaRaster​(WritableRaster raster)
        返回Raster表示图像的alpha通道，从输入中提取Raster 。 该方法假设与此ColorModel相关联的Raster对象存储Alpha波段（如果存在）作为最后一个图像数据。 如果没有与此ColorModel相关联的单独的空间alpha通道，则返回null。 此方法创建一个新的Raster ，但将共享数据数组。
        重写：
        getAlphaRaster在 ColorModel
        参数
        raster - WritableRaster提取Alpha通道的 WritableRaster 。
        结果
        A WritableRaster包含图像的Alpha通道。

      • equals

        public boolean equals​(Object obj)
        测试指定 Object是一个实例 ComponentColorModel和等于这个 ComponentColorModel 。
        重写：
        equals在 ColorModel
        参数
        obj - Object测试平等
        结果
        true如果指定Object是的一个实例ComponentColorModel并且等于此ComponentColorModel ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此ComponentColorModel的哈希码。
        重写：
        hashCode在 ColorModel
        结果
        此ComponentColorModel的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ComponentSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ComponentSampleModel

  • java.lang.Object
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
  • 已知直接子类：
    BandedSampleModel ， PixelInterleavedSampleModel

    public class ComponentSampleModel
extends SampleModel
    该类表示存储的图像数据，使得像素的每个样本占据DataBuffer的一个数据元素。 它将组成一个像素的N个样本存储在N个单独的数据数组元素中。 不同的频段可能位于DataBuffer的不同行。 提供访问方法，以便可以直接操纵图像数据。 该类可以支持不同种类的交织，例如频带交织，扫描线交织和像素交错。 像素幅度是同一扫描线上同一频带的两个样本之间的数据数组元素数。 扫描线步幅是给定样本与下一个扫描线同一列中相应样本之间的数据数组元素数。 带偏移表示来自保持每个频带的DataBuffer组的第一数据阵列元素到该频带的第一个样本的数据数组元素的数量。 频带从0到N-1编号。 这个类可以代表图像数据，其中每个样本是（使用可被存储在8位，16位或32位的无符号整数DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或DataBuffer.TYPE_INT ，分别地），数据为每个样本是一个带符号的整数，其可以存储在16位（使用DataBuffer.TYPE_SHORT ）或每个样本是带符号的浮点数或双倍数量的数据（分别为DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE ）。 给定ComponentSampleModel的所有样本以相同的精度存储。 所有步幅和偏移量必须为非负值。 该类支持TYPE_BYTE ， TYPE_USHORT ， TYPE_SHORT ， TYPE_INT ， TYPE_FLOAT ， TYPE_DOUBLE ，
    另请参见：
    PixelInterleavedSampleModel ， BandedSampleModel

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int[] bandOffsets
      数据数组元素中所有频带的偏移量。
      protected int[] bankIndices
      每个存储一个图像数据带的存储体的索引。
      protected int numBands
      这个数字在 ComponentSampleModel 。
      protected int numBanks
      这个银行的数量在这 ComponentSampleModel 。
      protected int pixelStride
      由该ComponentSampleModel描述的图像数据区域的像素（在数据数组元素中）。
      protected int scanlineStride
      由该ComponentSampleModel描述的图像数据区域的线条（在数据数组元素中）。

      • Fields inherited from class java.awt.image.SampleModel

        dataType, height, width

    • 构造方法摘要

      构造方法
      Constructor 描述
      ComponentSampleModel​(int dataType, int w, int h, int pixelStride, int scanlineStride, int[] bandOffsets)
      使用指定的参数构造一个ComponentSampleModel。
      ComponentSampleModel​(int dataType, int w, int h, int pixelStride, int scanlineStride, int[] bankIndices, int[] bandOffsets)
      使用指定的参数构造一个ComponentSampleModel。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建一个新的 ComponentSampleModel具有指定的宽度和高度。
      DataBuffer createDataBuffer​()
      创建一个 DataBuffer对应于这个 ComponentSampleModel 。
      SampleModel createSubsetSampleModel​(int[] bands)
      使用此ComponentSampleModel的带子集创建新的ComponentSampleModel。
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      int[] getBandOffsets​()
      返回所有频段的频偏。
      int[] getBankIndices​()
      返回所有频段的银行指数。
      Object getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回类型为 TransferType的基本数组中单个像素的数据。
      int getNumDataElements​()
      返回使用 getDataElements(int, int, Object, DataBuffer)和 setDataElements(int, int, Object, DataBuffer)方法传输像素所需的数据元素数。
      int getOffset​(int x, int y)
      获取像素（x，y）的第一个带的偏移量。
      int getOffset​(int x, int y, int b)
      获取像素（x，y）的带b的偏移。
      int[] getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的所有样本，每个数组元素一个样本。
      int[] getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。
      int getPixelStride​()
      返回此ComponentSampleModel的像素步幅。
      int getSample​(int x, int y, int b, DataBuffer data)
      返回为位于（x，y）处的像素的指定带中的样本int。
      double getSampleDouble​(int x, int y, int b, DataBuffer data)
      将位于（x，y）的像素的指定带中的样本返回为双倍。
      float getSampleFloat​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本作为浮点返回。
      int[] getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。
      int[] getSampleSize​()
      返回所有频带的每个样本的位数。
      int getSampleSize​(int band)
      返回指定频带的每个样本的位数。
      int getScanlineStride​()
      返回此ComponentSampleModel的扫描线步幅。
      int hashCode​()
      返回对象的哈希码值。
      void setDataElements​(int x, int y, Object obj, DataBuffer data)
      设置在指定的一个单个像素的数据 DataBuffer从类型的基本数组 TransferType 。
      void setPixel​(int x, int y, int[] iArray, DataBuffer data)
      在 DataBuffer使用int数组的样本设置输入的像素。
      void setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void setSample​(int x, int y, int b, double s, DataBuffer data)
      在 DataBuffer中的位置（x，y）处的像素的指定频带中设置一个采样，使用双倍输入。
      void setSample​(int x, int y, int b, float s, DataBuffer data)
      在 DataBuffer使用浮点数为输入设置位于（x，y）处的像素的指定带中的样本。
      void setSample​(int x, int y, int b, int s, DataBuffer data)
      在 DataBuffer使用int输入，为位于（x，y）处的像素的指定波段设置一个样本。
      void setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.image.SampleModel

        getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSamples, setSamples

    • 字段详细信息

      • bandOffsets

        protected int[] bandOffsets
        数据数组元素中所有频带的偏移量。

      • bankIndices

        protected int[] bankIndices
        每个存储一个图像数据带的存储体的索引。

      • numBands

        protected int numBands
        这个 ComponentSampleModel的乐队数。

      • numBanks

        protected int numBanks
        这个银行的数量在这 ComponentSampleModel 。

      • scanlineStride

        protected int scanlineStride
        由该ComponentSampleModel描述的图像数据区域的线条（在数据数组元素中）。

      • pixelStride

        protected int pixelStride
        由该ComponentSampleModel描述的图像数据区域的像素（在数据数组元素中）。

    • 构造方法详细信息

      • ComponentSampleModel

        public ComponentSampleModel​(int dataType,
                            int w,
                            int h,
                            int pixelStride,
                            int scanlineStride,
                            int[] bandOffsets)
        使用指定的参数构造一个ComponentSampleModel。 带宽的数量将由bandOffsets数组的长度给出。 所有频段将被存储在DataBuffer的第一个存储区中。
        参数
        dataType - 存储样本的数据类型
        w - 描述的图像数据区域的宽度（以像素为单位）
        h - 描述的图像数据区域的高度（以像素为单位）
        pixelStride - 所描述的图像数据区域的像素步幅
        scanlineStride - 描述图像数据区域的行 scanlineStride
        bandOffsets - 所有频带的偏移量
        异常
        IllegalArgumentException - 如果 w或 h不大于0
        IllegalArgumentException - 如果 pixelStride小于0
        IllegalArgumentException - 如果 scanlineStride小于0
        IllegalArgumentException - 如果 numBands小于1
        IllegalArgumentException - 如果 w和 h的产品大于 Integer.MAX_VALUE
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

      • ComponentSampleModel

        public ComponentSampleModel​(int dataType,
                            int w,
                            int h,
                            int pixelStride,
                            int scanlineStride,
                            int[] bankIndices,
                            int[] bandOffsets)
        使用指定的参数构造一个ComponentSampleModel。 带宽的数量将由bandOffsets数组的长度给出。 不同的频段可能存储在DataBuffer的不同组中。
        参数
        dataType - 存储样本的数据类型
        w - 描述的图像数据区域的宽度（以像素为单位）
        h - 描述的图像数据区域的高度（以像素为单位）
        pixelStride - 描述的图像数据区域的像素步幅
        scanlineStride - 描述图像数据区域的行走
        bankIndices - 所有乐队的银行指数
        bandOffsets - 所有频带的频带偏移
        异常
        IllegalArgumentException - 如果 w或 h不大于0
        IllegalArgumentException - 如果 pixelStride小于0
        IllegalArgumentException - 如果 scanlineStride小于0
        IllegalArgumentException -如果长度 bankIndices不等于的长度 bankOffsets
        IllegalArgumentException -如有的银行指数 bandIndices小于0
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

    • 方法详细信息

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建一个新的ComponentSampleModel具有指定的宽度和高度。 新SampleModel将具有相同数目的频带，存储数据类型的交织方案，以及像素跨度，因为这SampleModel 。
        Specified by:
        createCompatibleSampleModel在 SampleModel
        参数
        w - 所得的宽度 SampleModel
        h - 由此产生的高度 SampleModel
        结果
        一个新的 ComponentSampleModel具有指定的大小
        异常
        IllegalArgumentException - 如果 w或 h不大于0

      • createSubsetSampleModel

        public SampleModel createSubsetSampleModel​(int[] bands)
        使用此ComponentSampleModel的带子集创建新的ComponentSampleModel。 新的ComponentSampleModel可以与现有的ComponentSampleModel可以一起使用的任何DataBuffer使用。 新的ComponentSampleModel / DataBuffer组合将表示具有原始ComponentSampleModel / DataBuffer组合的带子集的图像。
        Specified by:
        createSubsetSampleModel在 SampleModel
        参数
        bands - 这个 ComponentSampleModel一个子集
        结果
        一个 ComponentSampleModel创建了一个子带从这 ComponentSampleModel 。

      • createDataBuffer

        public DataBuffer createDataBuffer​()
        创建一个DataBuffer对应于这个ComponentSampleModel 。 DataBuffer对象的数据类型，银行数量和大小与此ComponentSampleModel一致。
        Specified by:
        createDataBuffer在 SampleModel
        结果
        一个 DataBuffer的数据类型，银行数量和大小与此 ComponentSampleModel一致。

      • getOffset

        public int getOffset​(int x,
                     int y)
        获取像素（x，y）的第一个带的偏移量。 第一个乐队的样本可以从DataBuffer data ，其中ComponentSampleModel csm为
          data.getElem(csm.getOffset(x, y));
        参数
        x - 像素的X位置
        y - 像素的Y位置
        结果
        指定像素的第一个带的偏移量。

      • getOffset

        public int getOffset​(int x,
                     int y,
                     int b)
        获取像素（x，y）的带b的偏移。 带的样品b可以从被检索DataBuffer data与ComponentSampleModel csm作为
          data.getElem(csm.getOffset(x, y, b));
        参数
        x - 指定像素的X位置
        y - 指定像素的Y位置
        b - 指定的乐队
        结果
        指定像素的指定波段的偏移量。

      • getSampleSize

        public final int[] getSampleSize​()
        返回所有频带的每个样本的位数。
        Specified by:
        getSampleSize在 SampleModel
        结果
        一个数组，其中包含所有带的每个样本的位数，其中阵列中的每个元素表示一个带。

      • getSampleSize

        public final int getSampleSize​(int band)
        返回指定频带的每个样本的位数。
        Specified by:
        getSampleSize在 SampleModel
        参数
        band - 指定的乐队
        结果
        指定频带的每个样本的位数。

      • getBankIndices

        public final int[] getBankIndices​()
        返回所有频段的银行指数。
        结果
        所有乐队的银行指数。

      • getBandOffsets

        public final int[] getBandOffsets​()
        返回所有频段的频偏。
        结果
        所有频带的频带偏移量。

      • getScanlineStride

        public final int getScanlineStride​()
        返回此ComponentSampleModel的扫描线步幅。
        结果
        该扫描线步幅为 ComponentSampleModel 。

      • getPixelStride

        public final int getPixelStride​()
        返回此ComponentSampleModel的像素步幅。
        结果
        这个像素步幅这个 ComponentSampleModel 。

      • getNumDataElements

        public final int getNumDataElements​()
        返回使用getDataElements(int, int, Object, DataBuffer)和setDataElements(int, int, Object, DataBuffer)方法传输像素所需的数据元素数。 对于ComponentSampleModel ，这与频带数相同。
        Specified by:
        getNumDataElements在 SampleModel
        结果
        使用 getDataElements和 setDataElements方法传输像素所需的数据元素数量。
        另请参见：
        SampleModel.getNumDataElements() ， SampleModel.getNumBands()

      • getDataElements

        public Object getDataElements​(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
        返回类型为TransferType的基本数组中的单个像素的数据。 对于ComponentSampleModel ，这与数据类型相同，每个数组元素返回一个样本。 通常， obj应传递作为null ，使得Object被自动创建，并且是右原始数据类型。

        以下代码说明了将DataBuffer db1的存储布局由ComponentSampleModel csm1描述的ComponentSampleModel csm1一个像素的数据传输到DataBuffer db2 ，其存储布局由ComponentSampleModel csm2描述。 转移通常比使用getPixel和setPixel更有效。

          ComponentSampleModel csm1, csm2;
       DataBufferInt db1, db2;
       csm2.setDataElements(x, y,
                            csm1.getDataElements(x, y, null, db1), db2);
        使用getDataElements和setDataElements在两个DataBuffer/SampleModel对之间传输是合法的，如果SampleModel对象具有相同数量的频带，则相应频带具有与每个样本相同的位数，并且TransferType是相同的。

        如果obj不是null ，它应该是一个类型为TransferType的原始数组。 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果坐标不在边界可能被抛出，或者如果obj不null并没有大到足以容纳像素数据。

        Specified by:
        getDataElements在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        obj - 如果非 null ，其中返回像素数据的原始数组
        data - 包含图像数据的 DataBuffer
        结果
        指定像素的数据
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不是边界，或者obj太小，不能容纳输出。
        另请参见：
        setDataElements(int, int, Object, DataBuffer)

      • getPixel

        public int[] getPixel​(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
        返回int数组中指定像素的所有样本，每个数组元素一个样本。 如果坐标不在边界内，可能会抛出ArrayIndexOutOfBoundsException 。
        重写：
        getPixel在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        iArray - 如果非空，则返回此数组中的样本
        data - 包含图像数据的DataBuffer
        结果
        指定像素的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输出。
        另请参见：
        setPixel(int, int, int[], DataBuffer)

      • getPixels

        public int[] getPixels​(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
        返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。 如果坐标不在边界内，可能会抛出一个ArrayIndexOutOfBoundsException 。
        重写：
        getPixels在 SampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        iArray - 如果非空，则返回此数组中的样本
        data - 包含图像数据的DataBuffer
        结果
        指定区域内像素的样本。
        另请参见：
        setPixels(int, int, int, int, int[], DataBuffer)

      • getSample

        public int getSample​(int x,
                     int y,
                     int b,
                     DataBuffer data)
        返回为位于（x，y）处的像素的指定带中的样本int。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        Specified by:
        getSample在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        data - 包含图像数据的 DataBuffer
        结果
        指定像素的指定频带中的样本
        另请参见：
        setSample(int, int, int, int, DataBuffer)

      • getSampleFloat

        public float getSampleFloat​(int x,
                            int y,
                            int b,
                            DataBuffer data)
        将位于（x，y）处的像素的指定带中的样本作为浮点返回。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        重写：
        getSampleFloat在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        data - 包含图像数据的DataBuffer
        结果
        表示指定像素的指定频带中的样本的浮点值。

      • getSampleDouble

        public double getSampleDouble​(int x,
                              int y,
                              int b,
                              DataBuffer data)
        将位于（x，y）的像素的指定带中的样本返回为双倍。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        重写：
        getSampleDouble在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        data - 包含图像数据的DataBuffer
        结果
        表示指定像素的指定频带中的样本的双重值。

      • getSamples

        public int[] getSamples​(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
        返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        重写：
        getSamples在 SampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        b - 乐队返回
        iArray - 如果非 null ，则返回此数组中的样本
        data - 包含图像数据的 DataBuffer
        结果
        指定像素的指定带中的样本
        另请参见：
        setSamples(int, int, int, int, int, int[], DataBuffer)

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
        设置在指定的一个单个像素的数据DataBuffer从类型的基本数组TransferType 。 对于ComponentSampleModel ，这与数据类型相同，每个数组元素都会传送一个样本。

        以下代码说明将DataBuffer db1的存储布局由ComponentSampleModel csm1描述的ComponentSampleModel csm1一个像素的数据传输到DataBuffer db2 ，其存储布局由ComponentSampleModel csm2描述。 转移通常比使用getPixel和setPixel更有效。

          ComponentSampleModel csm1, csm2;
       DataBufferInt db1, db2;
       csm2.setDataElements(x, y, csm1.getDataElements(x, y, null, db1),
                            db2);
        如果SampleModel对象具有相同数量的频带，则使用getDataElements和setDataElements在两个DataBuffer/SampleModel对之间传输是合法的，对应的频带具有与每个采样相同的位数，而TransferType是相同的。

        甲ClassCastException如果被抛出obj不是类型的基本数组TransferType 。 一个ArrayIndexOutOfBoundsException如果坐标不在边界可能被抛出，或者如果obj不够大，无法容纳像素数据。

        Specified by:
        setDataElements在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        obj - 包含像素数据的原始数组
        data - 包含图像数据的DataBuffer
        另请参见：
        getDataElements(int, int, Object, DataBuffer)

      • setPixel

        public void setPixel​(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
        在DataBuffer使用int数组的样本设置一个像素进行输入。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        重写：
        setPixel在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        iArray - int数组中的输入样本
        data - 包含图像数据的DataBuffer
        另请参见：
        getPixel(int, int, int[], DataBuffer)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
        从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        重写：
        setPixels在 SampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        iArray - int数组中的输入样本
        data - 包含图像数据的DataBuffer
        另请参见：
        getPixels(int, int, int, int, int[], DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
        在DataBuffer使用int作为输入，为位于（x，y）处的像素的指定频带设置一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        Specified by:
        setSample在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队设置
        s - 输入样本为int
        data - 包含图像数据的DataBuffer
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      float s,
                      DataBuffer data)
        为DataBuffer位于（x，y）处的像素的指定波段设置采样，使用浮点输入。 如果坐标不在边界内，可能会抛出ArrayIndexOutOfBoundsException 。
        重写：
        setSample在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队设置
        s - 输入样本为浮点数
        data - 包含图像数据的DataBuffer
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      double s,
                      DataBuffer data)
        为DataBuffer位于（x，y）处的像素的指定波段设置一个样本，使用双倍输入。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        重写：
        setSample在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队设置
        s - 输入样本为双倍
        data - 包含图像数据的DataBuffer
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
        从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException 。
        重写：
        setSamples在 SampleModel
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        b - 乐队设置
        iArray - int数组中的输入样本
        data - 包含图像数据的DataBuffer
        另请参见：
        getSamples(int, int, int, int, int, int[], DataBuffer)

      • equals

        public boolean equals​(Object o)
        描述从类复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 一致 ：对于任何非空参考值x和y ，多重调用x.equals(y)一致返回true或始终返回false ，前提是在equals对象中使用的信息进行修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 只要在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法是不相等的，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ConvolveOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ConvolveOp

  • java.lang.Object
    • java.awt.image.ConvolveOp
  • All Implemented Interfaces:
    BufferedImageOp ， RasterOp

    public class ConvolveOp
extends Object
implements BufferedImageOp, RasterOp
    该类实现从源到目的地的卷积。 使用卷积核的卷积是通过将内核与输入像素的环绕相乘来计算来自输入像素的输出像素的空间操作。 这允许输出像素以可以用内核数学指定的方式受直接邻域的影响。

    该类使用BufferedImage数据操作，其中颜色分量与alpha分量预乘。 如果Source BufferedImage有一个alpha组件，并且颜色组件不会与alpha组件预乘，那么在进行卷积之前，数据将被预乘。 如果目的地具有未预乘的颜色分量，则在存储到目的地之前，将α分割（如果alpha为0，则颜色分量设置为0）。 如果目的地没有阿尔法分量，则在首先将其从颜色分量中分离出来后，生成的α被丢弃。

    光栅被视为没有alpha通道。 如果不需要对BufferedImages中的Alpha通道进行上述处理，则可以通过获取源BufferedImage的栅格并使用与Raster一起使用的此类的过滤器方法来避免此类处理。

    如果在构造函数中指定了RenderingHints对象，则在需要颜色转换时，可以使用颜色渲染提示和抖动提示。

    请注意，源和目标可能不是相同的对象。

    另请参见：
    Kernel ， RenderingHints.KEY_COLOR_RENDERING ， RenderingHints.KEY_DITHERING

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int EDGE_NO_OP
      源图像边缘的像素被复制到目的地的相应像素，而不进行修改。
      static int EDGE_ZERO_FILL
      目标图像边缘的像素设置为零。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConvolveOp​(Kernel kernel)
      构造一个给定内核的ConvolveOp。
      ConvolveOp​(Kernel kernel, int edgeCondition, RenderingHints hints)
      构造一个给定内核，边缘条件和RenderingHints对象（可能为null）的ConvolveOp。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BufferedImage createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      WritableRaster createCompatibleDestRaster​(Raster src)
      给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
      BufferedImage filter​(BufferedImage src, BufferedImage dst)
      对BufferedImages执行卷积。
      WritableRaster filter​(Raster src, WritableRaster dst)
      对光栅进行卷积。
      Rectangle2D getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      int getEdgeCondition​()
      返回边缘条件。
      Kernel getKernel​()
      返回内核。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      RenderingHints getRenderingHints​()
      返回此操作的渲染提示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • EDGE_ZERO_FILL

        @Native
public static final int EDGE_ZERO_FILL
        目标图像边缘的像素设置为零。 这是默认值。
        另请参见：
        Constant Field Values

      • EDGE_NO_OP

        @Native
public static final int EDGE_NO_OP
        源图像边缘的像素被复制到目的地的相应像素，而不进行修改。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ConvolveOp

        public ConvolveOp​(Kernel kernel,
                  int edgeCondition,
                  RenderingHints hints)
        构造一个给定内核，边缘条件和RenderingHints对象（可能为null）的ConvolveOp。
        参数
        kernel - 指定的 Kernel
        edgeCondition - 指定的边缘条件
        hints - 指定的 RenderingHints对象
        另请参见：
        Kernel ， EDGE_NO_OP ， EDGE_ZERO_FILL ， RenderingHints

      • ConvolveOp

        public ConvolveOp​(Kernel kernel)
        构造一个给定内核的ConvolveOp。 边缘条件将为EDGE_ZERO_FILL。
        参数
        kernel - 指定的 Kernel
        另请参见：
        Kernel ， EDGE_ZERO_FILL

    • 方法详细信息

      • getEdgeCondition

        public int getEdgeCondition​()
        返回边缘条件。
        结果
        这个边缘条件这个 ConvolveOp 。
        另请参见：
        EDGE_NO_OP ， EDGE_ZERO_FILL

      • getKernel

        public final Kernel getKernel​()
        返回内核。
        结果
        这 Kernel的 ConvolveOp 。

      • filter

        public final BufferedImage filter​(BufferedImage src,
                                  BufferedImage dst)
        对BufferedImages执行卷积。 源图像的每个分量将被卷积（包括alpha分量，如果存在）。 如果源图像中的颜色模型与目标图像中的颜色模型不同，则将在目标中转换像素。 如果目标图像为空，则将使用源ColorModel创建一个BufferedImage。 如果源与目的地相同，则可能会抛出IllegalArgumentException。
        Specified by:
        filter在接口 BufferedImageOp
        参数
        src - 来源 BufferedImage过滤
        dst - 目的地 BufferedImage为过滤的 src
        结果
        过滤后的 BufferedImage
        异常
        NullPointerException - 如果 src是 null
        IllegalArgumentException - 如果 src等于 dst
        ImagingOpException - 如果不能过滤 src

      • filter

        public final WritableRaster filter​(Raster src,
                                   WritableRaster dst)
        对光栅进行卷积。 源光栅的每个波段将被卷积。 源和目的地必须具有相同数量的频带。 如果目标Raster为null，将创建一个新的栅格。 如果源与目的地相同，则可能会抛出IllegalArgumentException。
        Specified by:
        filter在接口 RasterOp
        参数
        src - 来源 Raster进行过滤
        dst - 目的地 WritableRaster为过滤的 src
        结果
        过滤后的 WritableRaster
        异常
        NullPointerException - 如果 src是 null
        ImagingOpException - 如果 src和 dst没有相同数量的频带
        ImagingOpException - 如果不能过滤 src
        IllegalArgumentException - 如果 src等于 dst

      • createCompatibleDestImage

        public BufferedImage createCompatibleDestImage​(BufferedImage src,
                                               ColorModel destCM)
        创建具有正确大小和频带数的归零目标图像。 如果destCM为null，则将使用适当的ColorModel。
        Specified by:
        createCompatibleDestImage在接口 BufferedImageOp
        参数
        src - 过滤器操作的源图像。
        destCM - 目的地的ColorModel。 可以为null。
        结果
        具有正确大小和频带数目的目的地 BufferedImage 。

      • createCompatibleDestRaster

        public WritableRaster createCompatibleDestRaster​(Raster src)
        给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
        Specified by:
        createCompatibleDestRaster在接口 RasterOp
        参数
        src - 来源 Raster
        结果
        一个 WritableRaster ，与 src兼容

      • getBounds2D

        public final Rectangle2D getBounds2D​(BufferedImage src)
        返回已过滤的目标图像的边界框。 由于这不是一个几何操作，边框不会改变。
        Specified by:
        getBounds2D在接口 BufferedImageOp
        参数
        src - 要过滤的 BufferedImage
        结果
        Rectangle2D代表目的地图像的边界框。

      • getBounds2D

        public final Rectangle2D getBounds2D​(Raster src)
        返回已筛选的目标栅格的边框。 由于这不是一个几何操作，边框不会改变。
        Specified by:
        getBounds2D在接口 RasterOp
        参数
        src - 来源 Raster
        结果
        一个 Rectangle2D是由过滤操作产生的 Raster的边框。

      • getPoint2D

        public final Point2D getPoint2D​(Point2D srcPt,
                                Point2D dstPt)
        返回源中给定点的目标点的位置。 如果dstPt不为空，它将用于保存返回值。 由于这不是几何操作，srcPt将等于dstPt。
        Specified by:
        getPoint2D在接口 BufferedImageOp
        Specified by:
        getPoint2D在接口 RasterOp
        参数
        srcPt - 表示源图像中的点的 Point2D
        dstPt - 存储结果的 Point2D
        结果
        目标图像中的 Point2D对应于源图像中的指定点。

      • getRenderingHints

        public final RenderingHints getRenderingHints​()
        返回此操作的渲染提示。
        Specified by:
        getRenderingHints在接口 BufferedImageOp
        Specified by:
        getRenderingHints在接口 RasterOp
        结果
        该RenderingHints对象为这BufferedImageOp 。 如果没有设置提示，则返回null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CropImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class CropImageFilter

  • java.lang.Object
    • java.awt.image.ImageFilter
      • java.awt.image.CropImageFilter
  • All Implemented Interfaces:
    ImageConsumer ， Cloneable

    public class CropImageFilter
extends ImageFilter
    用于裁剪图像的ImageFilter类。 该类扩展了基本的ImageFilter类，以提取现有图像的给定矩形区域，并为仅包含提取区域的新图像提供源。 它意味着与FilteredImageSource对象结合使用以产生现有图像的裁剪版本。
    另请参见：
    FilteredImageSource ， ImageFilter

    • Field Summary

      • Fields inherited from interface java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

      • Fields inherited from class java.awt.image.ImageFilter

        consumer

    • 构造方法摘要

      构造方法
      Constructor 描述
      CropImageFilter​(int x, int y, int w, int h)
      构造一个CropImageFilter，它从x，y，w和h参数指定的源图像中提取像素的绝对矩形区域。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void setDimensions​(int w, int h)
      覆盖源图像的尺寸，并将矩形裁剪区域的尺寸传递给ImageConsumer。
      void setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      确定所传送的字节像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。
      void setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      确定所传递的int像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。
      void setProperties​(Hashtable<?,?> props)
      在添加指定裁剪区域的属性后，沿着源对象的属性传递。

      • Methods inherited from class java.awt.image.ImageFilter

        clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setColorModel, setHints

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CropImageFilter

        public CropImageFilter​(int x,
                       int y,
                       int w,
                       int h)
        构造一个CropImageFilter，它从x，y，w和h参数指定的源图像中提取像素的绝对矩形区域。
        参数
        x - 要提取的矩形顶部的x位置
        y - 要提取的矩形顶部的y位置
        w - 要提取的矩形的宽度
        h - 要提取的矩形的高度

    • 方法详细信息

      • setProperties

        public void setProperties​(Hashtable<?,?> props)
        在添加指定裁剪区域的属性后，沿着源对象的属性传递。 此方法调用super.setProperties ，这可能会导致添加其他属性。

        注意：此方法的目的是通过其像素被过滤的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setProperties在接口 ImageConsumer
        重写：
        setProperties在 ImageFilter
        参数
        props - 源对象的属性

      • setDimensions

        public void setDimensions​(int w,
                          int h)
        覆盖源图像的尺寸，并将矩形裁剪区域的尺寸传递给ImageConsumer。

        注意：此方法的目的是由被过滤像素的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setDimensions在接口 ImageConsumer
        重写：
        setDimensions在 ImageFilter
        参数
        w - 源图像的宽度
        h - 源图像的高度
        另请参见：
        ImageConsumer

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
        确定所传送的字节像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。

        注意：此方法的目的是通过其像素被过滤的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中的一行像素到下一行的距离
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
        确定所传递的int像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。

        注意：此方法的目的是通过其像素被过滤的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中的一行像素到下一行的距离
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DataBuffer

  • java.lang.Object
    • java.awt.image.DataBuffer
  • 已知直接子类：
    DataBufferByte ， DataBufferDouble ， DataBufferFloat ， DataBufferInt ， DataBufferShort ， DataBufferUShort

    public abstract class DataBuffer
extends Object
    此类存在用于包装一个或多个数据数组。 DataBuffer中的每个数据数组都称为存储区。 用于获取和设置DataBuffer的银行元素的访问器方法存在有或没有银行说明符。 没有银行说明符的方法使用默认的第0个银行。 DataBuffer可以选择为每个存储区取一个偏移量，因此即使有趣的数据没有从阵列位置零开始，也可以使用现有阵列中的数据。 获取或设置存储体的第0个元素，使用数组的（0 + offset）元素。 size字段指定可使用多少数据数组。 给定库的大小+偏移量不应大于相关数据数组的长度。 数据缓冲器的数据类型指示数据阵列的类型，并且还可以指示附加语义，例如将无符号8位数据存储在字节数组的元素中。 数据类型可能是TYPE_UNDEFINED或下面定义的类型之一。 其他类型可能会在未来添加。 通常，DataBuffer类的对象将被转换为其数据类型特定子类之一，以访问数据类型特定的方法来提高性能。 目前，Java 2D（tm）API图像类使用TYPE_BYTE，TYPE_USHORT，TYPE_INT，TYPE_SHORT，TYPE_FLOAT和TYPE_DOUBLE DataBuffers来存储图像数据。
    另请参见：
    Raster ， SampleModel

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int banks
      此DataBuffer中的存储区数。
      protected int dataType
      DataBuffer的数据类型。
      protected int offset
      偏移到默认（第一）银行，从中获取第一个元素。
      protected int[] offsets
      抵销所有银行。
      protected int size
      所有银行的可用规模。
      static int TYPE_BYTE
      标记无符号字节数据。
      static int TYPE_DOUBLE
      标记为双数据。
      static int TYPE_FLOAT
      标签浮点数据。
      static int TYPE_INT
      标签为int数据。
      static int TYPE_SHORT
      标记签名的短数据。
      static int TYPE_UNDEFINED
      标记未定义的数据。
      static int TYPE_USHORT
      无符号短数据标签。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected DataBuffer​(int dataType, int size)
      构造一个包含指定数据类型和大小的一行的DataBuffer。
      protected DataBuffer​(int dataType, int size, int numBanks)
      构造一个包含指定数量的存储区的DataBuffer。
      protected DataBuffer​(int dataType, int size, int numBanks, int offset)
      构造包含指定数量的存储区的DataBuffer。
      protected DataBuffer​(int dataType, int size, int numBanks, int[] offsets)
      构造一个包含指定数量的存储区的DataBuffer。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      int getDataType​()
      返回此DataBuffer的数据类型。
      static int getDataTypeSize​(int type)
      给出数据类型标签的数据类型的大小（以位为单位）。
      int getElem​(int i)
      从第一个（默认）库返回所请求的数据数组元素作为整数。
      abstract int getElem​(int bank, int i)
      从指定的库返回所请求的数据数组元素作为整数。
      double getElemDouble​(int i)
      从第一个（默认）库返回所请求的数据数组元素作为双精度。
      double getElemDouble​(int bank, int i)
      将所请求的数据数组元素从指定的库返回为双精度。
      float getElemFloat​(int i)
      作为浮点数从第一个（默认）库返回请求的数据数组元素。
      float getElemFloat​(int bank, int i)
      以浮点形式从指定的库返回所请求的数据数组元素。
      int getNumBanks​()
      返回此DataBuffer中的存储区数。
      int getOffset​()
      返回数组元素中默认库的偏移量。
      int[] getOffsets​()
      返回所有银行的偏移量（在数组元素中）。
      int getSize​()
      返回所有存储区的大小（以数组为单位）。
      void setElem​(int i, int val)
      从给定的整数设置第一个（默认）库中的请求的数据数组元素。
      abstract void setElem​(int bank, int i, int val)
      从给定的整数设置指定库中的请求的数据数组元素。
      void setElemDouble​(int i, double val)
      从给定的双数设置第一个（默认）库中的请求的数据数组元素。
      void setElemDouble​(int bank, int i, double val)
      从给定的双精度设置指定库中的请求数据数组元素。
      void setElemFloat​(int i, float val)
      从给定的浮点数在第一个（默认）库中设置所请求的数据数组元素。
      void setElemFloat​(int bank, int i, float val)
      从给定的浮点数设置指定库中的请求数据数组元素。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TYPE_BYTE

        @Native
public static final int TYPE_BYTE
        标记无符号字节数据。
        另请参见：
        Constant Field Values

      • TYPE_USHORT

        @Native
public static final int TYPE_USHORT
        无符号短数据标签。
        另请参见：
        Constant Field Values

      • TYPE_SHORT

        @Native
public static final int TYPE_SHORT
        标记签名的短数据。 占位符，供将来使用。
        另请参见：
        Constant Field Values

      • TYPE_INT

        @Native
public static final int TYPE_INT
        标签为int数据。
        另请参见：
        Constant Field Values

      • TYPE_FLOAT

        @Native
public static final int TYPE_FLOAT
        标签浮点数据。 占位符，供将来使用。
        另请参见：
        Constant Field Values

      • TYPE_DOUBLE

        @Native
public static final int TYPE_DOUBLE
        标记为双数据。 占位符，供将来使用。
        另请参见：
        Constant Field Values

      • TYPE_UNDEFINED

        @Native
public static final int TYPE_UNDEFINED
        标记未定义的数据。
        另请参见：
        Constant Field Values

      • dataType

        protected int dataType
        DataBuffer的数据类型。

      • banks

        protected int banks
        此DataBuffer中的存储区数。

      • offset

        protected int offset
        偏移到默认（第一）银行，从中获取第一个元素。

      • size

        protected int size
        所有银行的可用规模。

      • offsets

        protected int[] offsets
        抵销所有银行。

    • 构造方法详细信息

      • DataBuffer

        protected DataBuffer​(int dataType,
                     int size)
        构造一个包含指定数据类型和大小的一行的DataBuffer。
        参数
        dataType - 该数据类型 DataBuffer
        size - 银行的规模

      • DataBuffer

        protected DataBuffer​(int dataType,
                     int size,
                     int numBanks)
        构造一个包含指定数量的存储区的DataBuffer。 每个银行都有指定的大小，偏移量为0。
        参数
        dataType - 该数据类型 DataBuffer
        size - 银行的大小
        numBanks - 这个 DataBuffer的银行数量

      • DataBuffer

        protected DataBuffer​(int dataType,
                     int size,
                     int numBanks,
                     int offset)
        构造包含指定数量的存储区的DataBuffer。 每个银行都有指定的数据类型，大小和偏移量。
        参数
        dataType - 该数据类型 DataBuffer
        size - 银行的规模
        numBanks - 这个 DataBuffer的银行数量
        offset - 每个银行的抵销

      • DataBuffer

        protected DataBuffer​(int dataType,
                     int size,
                     int numBanks,
                     int[] offsets)
        构造一个包含指定数量的存储区的DataBuffer。 每个银行都有指定的数据类型和大小。 每个存储体的偏移量由偏移量数组中的相应条目指定。
        参数
        dataType - 该数据类型 DataBuffer
        size - 银行的规模
        numBanks - 这个 DataBuffer的银行数量
        offsets - 一个包含每个银行的偏移量的数组。
        异常
        ArrayIndexOutOfBoundsException - 如果 numBanks不等于 offsets的长度

    • 方法详细信息

      • getDataTypeSize

        public static int getDataTypeSize​(int type)
        给出数据类型标签的数据类型的大小（以位为单位）。
        参数
        type - 其中一个定义的数据类型标签的值
        结果
        数据类型的大小
        异常
        IllegalArgumentException - 如果 type小于零或大于 TYPE_DOUBLE

      • getDataType

        public int getDataType​()
        返回此DataBuffer的数据类型。
        结果
        该数据类型为 DataBuffer 。

      • getSize

        public int getSize​()
        返回所有存储区的大小（以数组为单位）。
        结果
        所有银行的规模。

      • getOffset

        public int getOffset​()
        返回数组元素中默认库的偏移量。
        结果
        默认银行的抵销。

      • getOffsets

        public int[] getOffsets​()
        返回所有银行的偏移量（在数组元素中）。
        结果
        所有银行的抵消。

      • getNumBanks

        public int getNumBanks​()
        返回此DataBuffer中的存储区数。
        结果
        银行数量。

      • getElem

        public int getElem​(int i)
        从第一个（默认）库返回所请求的数据数组元素作为整数。
        参数
        i - 请求的数据数组元素的索引
        结果
        指定索引处的数据数组元素。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • getElem

        public abstract int getElem​(int bank,
                            int i)
        从指定的库返回所请求的数据数组元素作为整数。
        参数
        bank - 指定银行
        i - 请求的数据数组元素的索引
        结果
        指定索引处指定索引处的数据数组元素。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • setElem

        public void setElem​(int i,
                    int val)
        从给定的整数设置第一个（默认）库中的请求的数据数组元素。
        参数
        i - 数据数组中指定的索引
        val - 要在数据数组中指定索引处设置元素的数据
        另请参见：
        getElem(int) ， getElem(int, int)

      • setElem

        public abstract void setElem​(int bank,
                             int i,
                             int val)
        从给定的整数设置指定库中的请求的数据数组元素。
        参数
        bank - 指定银行
        i - 数据数组中指定的索引
        val - 数据在数据数组中的指定索引处设置指定库中的元素
        另请参见：
        getElem(int) ， getElem(int, int)

      • getElemFloat

        public float getElemFloat​(int i)
        作为浮点数从第一个（默认）库返回请求的数据数组元素。 该类中的实现是将getElem（i）转换为float。 如果需要另一个实现，子类可以重写此方法。
        参数
        i - 请求的数据数组元素的索引
        结果
        表示指定索引处的数据数组元素的浮点值。
        另请参见：
        setElemFloat(int, float) ， setElemFloat(int, int, float)

      • getElemFloat

        public float getElemFloat​(int bank,
                          int i)
        以浮点形式从指定的库返回所请求的数据数组元素。 在这个类中的实现是将一个浮点数转成getElem(int, int) 。 如果需要另一个实现，子类可以覆盖此方法。
        参数
        bank - 指定的银行
        i - 请求的数据数组元素的索引
        结果
        一个浮点数值，表示指定库中指定索引的数据数组元素。
        另请参见：
        setElemFloat(int, float) ， setElemFloat(int, int, float)

      • setElemFloat

        public void setElemFloat​(int i,
                         float val)
        从给定的浮点数在第一个（默认）库中设置所请求的数据数组元素。 该类中的实现是将val转换为int并调用setElem(int, int) 。 如果需要另一个实现，子类可以覆盖此方法。
        参数
        i - 指定的索引
        val - 在数据数组中指定索引处设置元素的值
        另请参见：
        getElemFloat(int) ， getElemFloat(int, int)

      • setElemFloat

        public void setElemFloat​(int bank,
                         int i,
                         float val)
        从给定的浮点数设置指定库中的请求数据数组元素。 该类中的实现是将val转换为int并调用setElem(int, int) 。 如果需要另一个实现，子类可以覆盖此方法。
        参数
        bank - 指定银行
        i - 指定的索引
        val - 在数据数组中的指定索引处设置指定库中的元素的值
        另请参见：
        getElemFloat(int) ， getElemFloat(int, int)

      • getElemDouble

        public double getElemDouble​(int i)
        从第一个（默认）库返回所请求的数据数组元素作为双精度。 这个类中的实现是将getElem(int)转换成两倍。 如果需要另一个实现，子类可以覆盖此方法。
        参数
        i - 指定的索引
        结果
        表示数据数组中指定索引处的元素的double值。
        另请参见：
        setElemDouble(int, double) ， setElemDouble(int, int, double)

      • getElemDouble

        public double getElemDouble​(int bank,
                            int i)
        将所请求的数据数组元素从指定的库返回为双精度。 这个类的实现是将getElem（bank，i）转换成一个double。 如果需要另一个实现，子类可以重写此方法。
        参数
        bank - 指定银行
        i - 指定的索引
        结果
        表示来自数据数组中指定索引处的指定库的元素的双精度值。
        另请参见：
        setElemDouble(int, double) ， setElemDouble(int, int, double)

      • setElemDouble

        public void setElemDouble​(int i,
                          double val)
        从给定的双数设置第一个（默认）库中的请求的数据数组元素。 该类中的实现是将val转换为int并调用setElem(int, int) 。 如果需要另一个实现，子类可以覆盖此方法。
        参数
        i - 指定的索引
        val - 在数据数组中指定索引处设置元素的值
        另请参见：
        getElemDouble(int) ， getElemDouble(int, int)

      • setElemDouble

        public void setElemDouble​(int bank,
                          int i,
                          double val)
        从给定的双精度设置指定库中的请求数据数组元素。 该类中的实现是将val转换为int并调用setElem(int, int) 。 如果需要另一个实现，子类可以覆盖此方法。
        参数
        bank - 指定银行
        i - 指定的索引
        val - 在数据数组的指定索引处设置指定库中的元素的值
        另请参见：
        getElemDouble(int) ， getElemDouble(int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataBufferByte (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DataBufferByte

  • java.lang.Object
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferByte

  • public final class DataBufferByte
extends DataBuffer
    该类扩展了DataBuffer并将数据内部存储为字节。 存储在该DataBuffer的字节数组中的值被视为无符号值。

    Note that some implementations may function more efficiently if they can maintain control over how the data for an image is stored. For example, optimizations such as caching an image in video memory require that the implementation track all modifications to that data. Other implementations may operate better if they can store the data in locations other than a Java array. To maintain optimum compatibility with various optimizations it is best to avoid constructors and methods which expose the underlying storage as a Java array, as noted below in the documentation for those methods.

    • Field Summary

      • Fields inherited from class java.awt.image.DataBuffer

        banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataBufferByte​(byte[][] dataArray, int size)
      使用指定的数组构造一个基于字节的 DataBuffer 。
      DataBufferByte​(byte[][] dataArray, int size, int[] offsets)
      构造一个基于字节的 DataBuffer具有指定的数组，大小和偏移量。
      DataBufferByte​(byte[] dataArray, int size)
      使用指定的数组构建一个基于字节的 DataBuffer与单个库。
      DataBufferByte​(byte[] dataArray, int size, int offset)
      使用指定的数组，大小和偏移量，使用单个存储库构造一个基于字节的 DataBuffer 。
      DataBufferByte​(int size)
      构造一个基于字节的 DataBuffer与一个单独的银行和指定的大小。
      DataBufferByte​(int size, int numBanks)
      构造一个基于字节的 DataBuffer ，其中指定数量的库都是指定的大小。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte[][] getBankData​()
      返回所有库的数据数组。
      byte[] getData​()
      返回默认（第一个）字节数据数组。
      byte[] getData​(int bank)
      返回指定库的数据数组。
      int getElem​(int i)
      从第一个（默认）库返回所请求的数据数组元素。
      int getElem​(int bank, int i)
      从指定的库返回所请求的数据数组元素。
      void setElem​(int i, int val)
      将第一个（默认）库中的请求的数据数组元素设置为指定的值。
      void setElem​(int bank, int i, int val)
      从给定的整数设置指定库中的请求的数据数组元素。

      • Methods inherited from class java.awt.image.DataBuffer

        getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataBufferByte

        public DataBufferByte​(int size)
        构造一个基于字节的 DataBuffer与单个银行和指定的大小。
        参数
        size - 大小的 DataBuffer 。

      • DataBufferByte

        public DataBufferByte​(int size,
                      int numBanks)
        构造一个基于字节的 DataBuffer ，其中指定数量的库都是指定的大小。
        参数
        size - 银行的大小在 DataBuffer 。
        numBanks - 一个 DataBuffer的银行数量。

      • DataBufferByte

        public DataBufferByte​(byte[] dataArray,
                      int size)
        使用指定的数组构造一个基于字节的DataBuffer与一个单独的库。 只有第size要素应当由本的访问器只能使用DataBuffer 。 dataArray必须足够大才能容纳size元素。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如缓存视频内存中的关联图像）。

        参数
        dataArray -字节数组为 DataBuffer 。
        size - 大小的 DataBuffer银行。

      • DataBufferByte

        public DataBufferByte​(byte[] dataArray,
                      int size,
                      int offset)
        使用指定的数组，大小和偏移构造一个基于字节的DataBuffer与单个库。 dataArray必须至少有offset + size元素。 只有offset到offset + size元素应该由DataBuffer 。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -字节数组为 DataBuffer 。
        size - DataBuffer银行的大小。
        offset - 偏移到dataArray 。 dataArray必须至少有offset + size元素。

      • DataBufferByte

        public DataBufferByte​(byte[][] dataArray,
                      int size)
        构造一个基于字节的DataBuffer与指定的数组。 银行数量等于dataArray.length 。 这个DataBuffer的访问者只能使用每个数组的第一个size元素。

        请注意，此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的图像）。

        参数
        dataArray -为对的字节数组 DataBuffer 。
        size - 银行规模在 DataBuffer 。

      • DataBufferByte

        public DataBufferByte​(byte[][] dataArray,
                      int size,
                      int[] offsets)
        构造一个基于字节的DataBuffer具有指定的数组，大小和偏移量。 银行数量等于dataArray.length 。 每个阵列必须至少与size +相应的offset一样大。 必须有一个条目offset阵列每个dataArray条目。 对于每个银行，只有元素offset至offset + size应由该DataBuffer 。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        dataArray -为对的字节数组 DataBuffer 。
        size - 银行规模在 DataBuffer 。
        offsets - 每个数组的偏移量。

    • 方法详细信息

      • getData

        public byte[] getData​()
        返回默认（第一个）字节数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        第一个字节数据数组。

      • getData

        public byte[] getData​(int bank)
        返回指定库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        bank - 您想要获取数据数组的银行。
        结果
        指定银行的数据数组。

      • getBankData

        public byte[][] getBankData​()
        返回所有库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        所有的数据阵列。

      • getElem

        public int getElem​(int i)
        从第一个（默认）库返回所请求的数据数组元素。
        重写：
        getElem在 DataBuffer
        参数
        i - 要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • getElem

        public int getElem​(int bank,
                   int i)
        从指定的库返回所请求的数据数组元素。
        Specified by:
        getElem在 DataBuffer
        参数
        bank - 要从中获取数据数组元素的存储区。
        i - 您要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • setElem

        public void setElem​(int i,
                    int val)
        将第一个（默认）库中的请求的数据数组元素设置为指定的值。
        重写：
        setElem在 DataBuffer
        参数
        i - 要设置的数据数组元素。
        val - 要设置数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • setElem

        public void setElem​(int bank,
                    int i,
                    int val)
        从给定的整数设置指定库中的请求的数据数组元素。
        Specified by:
        setElem在 DataBuffer
        参数
        bank - 要在其中设置数据数组元素的存储区。
        i - 要设置的数据数组元素。
        val - 要设置指定数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataBufferDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DataBufferDouble

  • java.lang.Object
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferDouble

  • public final class DataBufferDouble
extends DataBuffer
    该类扩展了DataBuffer并在double内部存储数据。

    Note that some implementations may function more efficiently if they can maintain control over how the data for an image is stored. For example, optimizations such as caching an image in video memory require that the implementation track all modifications to that data. Other implementations may operate better if they can store the data in locations other than a Java array. To maintain optimum compatibility with various optimizations it is best to avoid constructors and methods which expose the underlying storage as a Java array as noted below in the documentation for those methods.

    从以下版本开始：
    1.4

    • Field Summary

      • Fields inherited from class java.awt.image.DataBuffer

        banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataBufferDouble​(double[][] dataArray, int size)
      构造一个基于 double的 DataBuffer与指定的数据数组。
      DataBufferDouble​(double[][] dataArray, int size, int[] offsets)
      构造一个基于 double的 DataBuffer其中包含指定的数据数组，大小和每个组的偏移量。
      DataBufferDouble​(double[] dataArray, int size)
      使用指定的数据数组构造一个基于 double的 DataBuffer 。
      DataBufferDouble​(double[] dataArray, int size, int offset)
      使用指定的数据数组构造一个基于 double的 DataBuffer 。
      DataBufferDouble​(int size)
      构造一个具有指定大小的 double的 DataBuffer 。
      DataBufferDouble​(int size, int numBanks)
      构造一个基于 double的 DataBuffer ，其中指定数量的银行都是指定的大小。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      double[][] getBankData​()
      返回所有存储区的数据数组。
      double[] getData​()
      返回默认（第一个） double数据数组。
      double[] getData​(int bank)
      返回指定库的数据数组。
      int getElem​(int i)
      从第一个（默认）库返回所请求的数据数组元素作为 int 。
      int getElem​(int bank, int i)
      从指定的库返回请求的数据数组元素作为 int 。
      double getElemDouble​(int i)
      从第一个（默认）库返回所请求的数据数组元素作为 double 。
      double getElemDouble​(int bank, int i)
      从指定的库返回请求的数据数组元素作为 double 。
      float getElemFloat​(int i)
      从第一个（默认）库返回所请求的数据数组元素作为 float 。
      float getElemFloat​(int bank, int i)
      从指定的库返回请求的数据数组元素作为 float 。
      void setElem​(int i, int val)
      将所请求的数据数组元素设置在给定的第二个（默认）存储库中的 int 。
      void setElem​(int bank, int i, int val)
      将指定库中的请求数据数组元素设置为给定的 int 。
      void setElemDouble​(int i, double val)
      将请求的数据数组元素设置在第一个（默认）存储区中给定的 double 。
      void setElemDouble​(int bank, int i, double val)
      将指定库中的请求数据数组元素设置为给定的 double 。
      void setElemFloat​(int i, float val)
      将请求的数据数组元素设置在第一个（默认）存储区中给定的 float 。
      void setElemFloat​(int bank, int i, float val)
      将指定库中的请求的数据数组元素设置为给定的 float 。

      • Methods inherited from class java.awt.image.DataBuffer

        getDataType, getDataTypeSize, getNumBanks, getOffset, getOffsets, getSize

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataBufferDouble

        public DataBufferDouble​(int size)
        构造一个具有指定大小的 double的 DataBuffer 。
        参数
        size -中的元素的数量 DataBuffer 。

      • DataBufferDouble

        public DataBufferDouble​(int size,
                        int numBanks)
        构造一个基于 double的 DataBuffer ，其中指定数量的银行都是指定的大小。
        参数
        size -在每个银行元件的数量 DataBuffer 。
        numBanks -银行在数 DataBuffer 。

      • DataBufferDouble

        public DataBufferDouble​(double[] dataArray,
                        int size)
        构造一个基于double的DataBuffer与指定的数据数组。 只有第size元素可供DataBuffer使用。 数组必须足够大，才能容纳size元素。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现使用的performance optimizations不兼容（例如缓存视频内存中的关联图像）。

        参数
        dataArray -数组 double s到用作该第一和唯一的银行 DataBuffer 。
        size - 要使用的数组的元素数。

      • DataBufferDouble

        public DataBufferDouble​(double[] dataArray,
                        int size,
                        int offset)
        使用指定的数据数组构建一个基于double的DataBuffer 。 只有之间的所有元素offset和offset + size - 1都可以通过这种使用DataBuffer 。 阵列必须足够大，可以容纳offset + size元素。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现使用的（例如，缓存视频内存中的关联图像）的performance optimizations不兼容。

        参数
        dataArray -数组 double s到用作该第一和唯一的银行 DataBuffer 。
        size - 要使用的数组的元素数。
        offset - 要使用的数组的第一个元素的偏移量。

      • DataBufferDouble

        public DataBufferDouble​(double[][] dataArray,
                        int size)
        构造一个基于double的DataBuffer与指定的数据数组。 只有每个阵列的第一个size元素可供DataBuffer使用。 银行数量将相当于to dataArray.length 。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现使用的performance optimizations不兼容（例如缓存视频内存中的关联图像）。

        参数
        dataArray -的数组的数组 double s到被用作本的银行 DataBuffer 。
        size - 要使用的每个数组的元素数。

      • DataBufferDouble

        public DataBufferDouble​(double[][] dataArray,
                        int size,
                        int[] offsets)
        构造一个基于double的DataBuffer其中包含指定的数据数组，大小和每个组的偏移量。 存储体的数量等于dataArray.length。 每个阵列必须至少与size一样大，加上相应的偏移量。 offsets数组中的每个数据数组必须有一个条目。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -的数组的数组 double s到被用作本的银行 DataBuffer 。
        size - 要使用的每个数组的元素数。
        offsets - 一个整数偏移数组，每一行一个。

    • 方法详细信息

      • getData

        public double[] getData​()
        返回默认（第一个） double数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实施使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        第一个双数据数组。

      • getData

        public double[] getData​(int bank)
        返回指定库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如缓存视频内存中的关联图像）。

        参数
        bank - 数据数组
        结果
        数据数组由 bank指定。

      • getBankData

        public double[][] getBankData​()
        返回所有存储区的数据数组。

        请注意，调用此方法可能会导致DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        来自该数据缓冲区的所有数据数组。

      • getElem

        public int getElem​(int i)
        从第一个（默认）库返回所请求的数据数组元素作为 int 。
        重写：
        getElem在 DataBuffer
        参数
        i - 所需的数据数组元素。
        结果
        数据输入为 int 。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • getElem

        public int getElem​(int bank,
                   int i)
        以 int从指定的库返回请求的数据数组元素。
        Specified by:
        getElem在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        结果
        数据输入为 int 。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • setElem

        public void setElem​(int i,
                    int val)
        将请求的数据数组元素设置在第一个（默认）存储区中给定的 int 。
        重写：
        setElem在 DataBuffer
        参数
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • setElem

        public void setElem​(int bank,
                    int i,
                    int val)
        将指定库中的请求数据数组元素设置为给定的 int 。
        Specified by:
        setElem在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • getElemFloat

        public float getElemFloat​(int i)
        从第一个（默认）库返回所请求的数据数组元素作为 float 。
        重写：
        getElemFloat在 DataBuffer
        参数
        i - 所需的数据数组元素。
        结果
        数据输入为 float 。
        另请参见：
        setElemFloat(int, float) ， setElemFloat(int, int, float)

      • getElemFloat

        public float getElemFloat​(int bank,
                          int i)
        从指定的库返回请求的数据数组元素作为 float 。
        重写：
        getElemFloat中的 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        结果
        数据输入为 float 。
        另请参见：
        setElemFloat(int, float) ， setElemFloat(int, int, float)

      • setElemFloat

        public void setElemFloat​(int i,
                         float val)
        将第一个（默认）库中的请求的数据数组元素设置为给定的 float 。
        重写：
        setElemFloat在 DataBuffer
        参数
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemFloat(int) ， getElemFloat(int, int)

      • setElemFloat

        public void setElemFloat​(int bank,
                         int i,
                         float val)
        将指定库中的请求数据数组元素设置为给定的 float 。
        重写：
        setElemFloat在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemFloat(int) ， getElemFloat(int, int)

      • getElemDouble

        public double getElemDouble​(int i)
        从第一个（默认）库返回所请求的数据数组元素作为 double 。
        重写：
        getElemDouble在 DataBuffer
        参数
        i - 所需的数据数组元素。
        结果
        数据输入为 double 。
        另请参见：
        setElemDouble(int, double) ， setElemDouble(int, int, double)

      • getElemDouble

        public double getElemDouble​(int bank,
                            int i)
        从指定的库返回请求的数据数组元素作为 double 。
        重写：
        getElemDouble在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        结果
        数据输入为 double 。
        另请参见：
        setElemDouble(int, double) ， setElemDouble(int, int, double)

      • setElemDouble

        public void setElemDouble​(int i,
                          double val)
        设置在所述第一（默认）存储到给定所请求的数据数组元素 double 。
        重写：
        setElemDouble在 DataBuffer
        参数
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemDouble(int) ， getElemDouble(int, int)

      • setElemDouble

        public void setElemDouble​(int bank,
                          int i,
                          double val)
        将指定库中的请求数据数组元素设置为给定的 double 。
        重写：
        setElemDouble在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemDouble(int), getElemDouble(int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataBufferFloat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DataBufferFloat

  • java.lang.Object
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferFloat

  • public final class DataBufferFloat
extends DataBuffer
    此类扩展了DataBuffer并在float内部存储数据。

    Note that some implementations may function more efficiently if they can maintain control over how the data for an image is stored. For example, optimizations such as caching an image in video memory require that the implementation track all modifications to that data. Other implementations may operate better if they can store the data in locations other than a Java array. To maintain optimum compatibility with various optimizations it is best to avoid constructors and methods which expose the underlying storage as a Java array as noted below in the documentation for those methods.

    从以下版本开始：
    1.4

    • Field Summary

      • Fields inherited from class java.awt.image.DataBuffer

        banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataBufferFloat​(float[][] dataArray, int size)
      构造一个基于 float的 DataBuffer与指定的数据数组。
      DataBufferFloat​(float[][] dataArray, int size, int[] offsets)
      构造一个基于 float的 DataBuffer其中包含指定的数据数组，大小和每个组的偏移量。
      DataBufferFloat​(float[] dataArray, int size)
      使用指定的数据数组构建一个基于 float的 DataBuffer 。
      DataBufferFloat​(float[] dataArray, int size, int offset)
      构造一个基于 float的 DataBuffer与指定的数据数组。
      DataBufferFloat​(int size)
      构造一个指定大小的 float基于 DataBuffer 。
      DataBufferFloat​(int size, int numBanks)
      构造一个 float的 DataBuffer ，其中指定数量的银行都是指定的大小。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      float[][] getBankData​()
      返回所有存储区的数据数组。
      float[] getData​()
      返回默认（第一个） float数据数组。
      float[] getData​(int bank)
      返回指定库的数据数组。
      int getElem​(int i)
      从第一个（默认）库返回所请求的数据数组元素作为 int 。
      int getElem​(int bank, int i)
      从指定的库返回请求的数据数组元素作为 int 。
      double getElemDouble​(int i)
      从第一个（默认）库返回所请求的数据数组元素作为 double 。
      double getElemDouble​(int bank, int i)
      从指定的库返回请求的数据数组元素作为 double 。
      float getElemFloat​(int i)
      从第一个（默认）库返回请求的数据数组元素作为 float 。
      float getElemFloat​(int bank, int i)
      从指定的库返回请求的数据数组元素作为 float 。
      void setElem​(int i, int val)
      将第一个（默认）库中的请求的数据数组元素设置为给定的 int 。
      void setElem​(int bank, int i, int val)
      将指定库中的请求数据数组元素设置为给定的 int 。
      void setElemDouble​(int i, double val)
      将请求的数据数组元素设置在给定的 double的第一个（默认）库中。
      void setElemDouble​(int bank, int i, double val)
      将指定库中的请求数据数组元素设置为给定的 double 。
      void setElemFloat​(int i, float val)
      将请求的数据数组元素设置在第一个（默认）存储区中给定的 float 。
      void setElemFloat​(int bank, int i, float val)
      将指定库中的请求数据数组元素设置为给定的 float 。

      • Methods inherited from class java.awt.image.DataBuffer

        getDataType, getDataTypeSize, getNumBanks, getOffset, getOffsets, getSize

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataBufferFloat

        public DataBufferFloat​(int size)
        构造一个 float的 DataBuffer指定大小。
        参数
        size - DataBuffer中的元素数。

      • DataBufferFloat

        public DataBufferFloat​(int size,
                       int numBanks)
        构建一个 float的 DataBuffer ，其中指定数量的银行都是指定的大小。
        参数
        size - size各银行的元 DataBuffer 。
        numBanks -银行在数 DataBuffer 。

      • DataBufferFloat

        public DataBufferFloat​(float[] dataArray,
                       int size)
        构造一个基于float的DataBuffer与指定的数据数组。 只有第size元素可供DataBuffer使用。 该阵列必须足够大以容纳size元素。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -数组 float s到用作该第一和唯一的银行 DataBuffer 。
        size - 要使用的数组的元素数。

      • DataBufferFloat

        public DataBufferFloat​(float[] dataArray,
                       int size,
                       int offset)
        构造一个基于float的DataBuffer与指定的数据数组。 只有之间的所有元素offset和offset + size - 1都可以通过这种使用DataBuffer 。 数组必须足够大才能容纳offset + size元素。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -数组 float s到用作该第一和唯一的银行 DataBuffer 。
        size - 要使用的数组的元素数。
        offset - 要使用的数组的第一个元素的偏移量。

      • DataBufferFloat

        public DataBufferFloat​(float[][] dataArray,
                       int size)
        构造一个基于float的DataBuffer与指定的数据数组。 只有每个阵列的第一个size元素可供DataBuffer使用。 银行数量将相当于dataArray.length 。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的图像）。

        参数
        dataArray -的数组的数组 float s到被用作本的银行 DataBuffer 。
        size - 要使用的每个数组的元素数。

      • DataBufferFloat

        public DataBufferFloat​(float[][] dataArray,
                       int size,
                       int[] offsets)
        构造一个基于float的DataBuffer其中包含指定的数据数组，大小和每个库的偏移量。 银行数量等于dataArray.length 。 每个阵列必须至少与size加上相应的偏移量一样大。 每个数据数组的偏移数组中必须有一个条目。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -的数组的数组 float s到被用作本的银行 DataBuffer 。
        size - 要使用的每个数组的元素数。
        offsets - 一个整数偏移数组，每一行一个。

    • 方法详细信息

      • getData

        public float[] getData​()
        返回默认（第一个） float数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        第一个浮点数据数组。

      • getData

        public float[] getData​(int bank)
        返回指定库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        bank - 数据数组
        结果
        数据数组由 bank指定。

      • getBankData

        public float[][] getBankData​()
        返回所有存储区的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        该数据缓冲区的所有数据数组。

      • getElem

        public int getElem​(int i)
        从第一个（默认）库返回所请求的数据数组元素作为 int 。
        重写：
        getElem在 DataBuffer
        参数
        i - 所需的数据数组元素。
        结果
        数据输入为 int 。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • getElem

        public int getElem​(int bank,
                   int i)
        从指定的库返回所请求的数据数组元素作为 int 。
        Specified by:
        getElem在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        结果
        数据输入为 int 。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • setElem

        public void setElem​(int i,
                    int val)
        将所请求的数据数组元素设置在第一个（默认）存储区中给定的 int 。
        重写：
        setElem在 DataBuffer
        参数
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • setElem

        public void setElem​(int bank,
                    int i,
                    int val)
        将指定库中的请求数据数组元素设置为给定的 int 。
        Specified by:
        setElem在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • getElemFloat

        public float getElemFloat​(int i)
        从第一个（默认）库返回请求的数据数组元素作为 float 。
        重写：
        getElemFloat在 DataBuffer
        参数
        i - 所需的数据数组元素。
        结果
        数据输入为 float 。
        另请参见：
        setElemFloat(int, float) ， setElemFloat(int, int, float)

      • getElemFloat

        public float getElemFloat​(int bank,
                          int i)
        从指定的库返回请求的数据数组元素作为 float 。
        重写：
        getElemFloat在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        结果
        数据输入为 float 。
        另请参见：
        setElemFloat(int, float) ， setElemFloat(int, int, float)

      • setElemFloat

        public void setElemFloat​(int i,
                         float val)
        将第一个（默认）库中的请求的数据数组元素设置为给定的 float 。
        重写：
        setElemFloat在 DataBuffer
        参数
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemFloat(int) ， getElemFloat(int, int)

      • setElemFloat

        public void setElemFloat​(int bank,
                         int i,
                         float val)
        将指定库中的请求数据数组元素设置为给定的 float 。
        重写：
        setElemFloat在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemFloat(int) ， getElemFloat(int, int)

      • getElemDouble

        public double getElemDouble​(int i)
        从第一个（默认）库返回所请求的数据数组元素作为 double 。
        重写：
        getElemDouble在 DataBuffer
        参数
        i - 所需的数据数组元素。
        结果
        数据输入为 double 。
        另请参见：
        setElemDouble(int, double) ， setElemDouble(int, int, double)

      • getElemDouble

        public double getElemDouble​(int bank,
                            int i)
        从指定的库返回请求的数据数组元素作为 double 。
        重写：
        getElemDouble在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        结果
        数据输入为 double 。
        另请参见：
        setElemDouble(int, double) ， setElemDouble(int, int, double)

      • setElemDouble

        public void setElemDouble​(int i,
                          double val)
        将请求的数据数组元素设置在第一个（默认）存储区中给定的 double 。
        重写：
        setElemDouble在 DataBuffer
        参数
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemDouble(int) ， getElemDouble(int, int)

      • setElemDouble

        public void setElemDouble​(int bank,
                          int i,
                          double val)
        将指定库中的请求数据数组元素设置为给定的 double 。
        重写：
        setElemDouble在 DataBuffer
        参数
        bank - 银行号码。
        i - 所需的数据数组元素。
        val - 要设置的值。
        另请参见：
        getElemDouble(int), getElemDouble(int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataBufferInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DataBufferInt

  • java.lang.Object
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferInt

  • public final class DataBufferInt
extends DataBuffer
    该类扩展了DataBuffer并将数据内部存储为整数。

    Note that some implementations may function more efficiently if they can maintain control over how the data for an image is stored. For example, optimizations such as caching an image in video memory require that the implementation track all modifications to that data. Other implementations may operate better if they can store the data in locations other than a Java array. To maintain optimum compatibility with various optimizations it is best to avoid constructors and methods which expose the underlying storage as a Java array as noted below in the documentation for those methods.

    • Field Summary

      • Fields inherited from class java.awt.image.DataBuffer

        banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataBufferInt​(int size)
      构造一个基于整数的 DataBuffer与单个银行和指定的大小。
      DataBufferInt​(int[][] dataArray, int size)
      使用指定的数组构造一个基于整数的 DataBuffer 。
      DataBufferInt​(int[][] dataArray, int size, int[] offsets)
      使用指定的数组，大小和偏移量构造一个基于整数的 DataBuffer 。
      DataBufferInt​(int[] dataArray, int size)
      使用指定的数组构造一个基于整数的 DataBuffer与单个银行。
      DataBufferInt​(int[] dataArray, int size, int offset)
      使用指定的数组，大小和偏移构造一个基于整数的 DataBuffer与单个库。
      DataBufferInt​(int size, int numBanks)
      构造一个基于整数的 DataBuffer ，其中指定的银行数量都是指定的大小。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int[][] getBankData​()
      返回所有库的数据数组。
      int[] getData​()
      返回 DataBuffer中的默认（第一个）int数据数组。
      int[] getData​(int bank)
      返回指定库的数据数组。
      int getElem​(int i)
      从第一个（默认）库返回所请求的数据数组元素。
      int getElem​(int bank, int i)
      从指定的库返回所请求的数据数组元素。
      void setElem​(int i, int val)
      将第一个（默认）库中的请求的数据数组元素设置为指定的值。
      void setElem​(int bank, int i, int val)
      将指定库中的请求数据数组元素设置为整数值 i 。

      • Methods inherited from class java.awt.image.DataBuffer

        getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataBufferInt

        public DataBufferInt​(int size)
        构造一个基于整数的 DataBuffer与单个银行和指定的大小。
        参数
        size - 大小的 DataBuffer 。

      • DataBufferInt

        public DataBufferInt​(int size,
                     int numBanks)
        构造一个基于整数的 DataBuffer ，其中指定的银行数量都是指定的大小。
        参数
        size - 银行的大小在 DataBuffer 。
        numBanks - a a DataBuffer of a a a DataBuffer 。

      • DataBufferInt

        public DataBufferInt​(int[] dataArray,
                     int size)
        使用指定的数组构造一个基于整数的DataBuffer与单个银行。 只有第size要素应当由本的访问器只能使用DataBuffer 。 dataArray必须足够大以容纳size元素。

        请注意，由此构造函数创建的对象DataBuffer可能与某些实现使用的performance optimizations不兼容（例如缓存视频内存中的关联图像）。

        参数
        dataArray -的整数数组为 DataBuffer 。
        size - 大小的 DataBuffer银行。

      • DataBufferInt

        public DataBufferInt​(int[] dataArray,
                     int size,
                     int offset)
        使用指定的数组，大小和偏移量，使用单个库构造一个基于整数的DataBuffer 。 dataArray必须至少有offset + size元素。 这个DataBuffer的访问者只能使用offset到offset + size元素。

        请注意，此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        dataArray -的整数数组为 DataBuffer 。
        size - DataBuffer银行的大小。
        offset - 偏移到 dataArray 。

      • DataBufferInt

        public DataBufferInt​(int[][] dataArray,
                     int size)
        使用指定的数组构造一个基于整数的DataBuffer 。 银行数量将相当于dataArray.length 。 这个DataBuffer的访问者只能使用每个数组的第一个size元素。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现使用的performance optimizations不兼容（例如缓存视频内存中的关联图像）。

        参数
        dataArray -为对所述整数数组 DataBuffer 。
        size - 银行的大小在 DataBuffer 。

      • DataBufferInt

        public DataBufferInt​(int[][] dataArray,
                     int size,
                     int[] offsets)
        使用指定的数组，大小和偏移量构造一个基于整数的DataBuffer 。 银行数量等于dataArray.length 。 每个阵列必须至少与size +相应的偏移量一样大。 每个dataArray条目的偏移数组中必须有一个条目。 对于每个银行，只有元素offset至offset + size应由该DataBuffer 。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -为对所述整数数组 DataBuffer 。
        size - 银行的大小在 DataBuffer 。
        offsets - 每个数组的偏移量。

    • 方法详细信息

      • getData

        public int[] getData​()
        返回DataBuffer中的默认（第一个）int数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        第一个整数数据数组。

      • getData

        public int[] getData​(int bank)
        返回指定库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        bank - 您想要获取数据数组的银行。
        结果
        指定银行的数据数组。

      • getBankData

        public int[][] getBankData​()
        返回所有库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        所有的数据阵列。

      • getElem

        public int getElem​(int i)
        从第一个（默认）库返回所请求的数据数组元素。
        重写：
        getElem在 DataBuffer
        参数
        i - 要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • getElem

        public int getElem​(int bank,
                   int i)
        从指定的库返回所请求的数据数组元素。
        Specified by:
        getElem在 DataBuffer
        参数
        bank - 要从中获取数据数组元素的存储区。
        i - 要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • setElem

        public void setElem​(int i,
                    int val)
        将第一个（默认）库中的请求的数据数组元素设置为指定的值。
        重写：
        setElem在 DataBuffer
        参数
        i - 要设置的数据数组元素。
        val - 要设置数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • setElem

        public void setElem​(int bank,
                    int i,
                    int val)
        将指定库中的请求数据数组元素设置为整数值 i 。
        Specified by:
        setElem在 DataBuffer
        参数
        bank - 要在其中设置数据数组元素的存储区。
        i - 要设置的数据数组元素。
        val - 要设置指定数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataBufferShort (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DataBufferShort

  • java.lang.Object
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferShort

  • public final class DataBufferShort
extends DataBuffer
    该类扩展了DataBuffer并将数据内部存储为DataBuffer 。

    Note that some implementations may function more efficiently if they can maintain control over how the data for an image is stored. For example, optimizations such as caching an image in video memory require that the implementation track all modifications to that data. Other implementations may operate better if they can store the data in locations other than a Java array. To maintain optimum compatibility with various optimizations it is best to avoid constructors and methods which expose the underlying storage as a Java array as noted below in the documentation for those methods.

    • Field Summary

      • Fields inherited from class java.awt.image.DataBuffer

        banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataBufferShort​(int size)
      构建一个基于短期的 DataBuffer与单个银行和指定的大小。
      DataBufferShort​(int size, int numBanks)
      构造一个基于短期的 DataBuffer ，其中指定的银行数量都是指定的大小。
      DataBufferShort​(short[][] dataArray, int size)
      使用指定的数组构造一个基于短期的 DataBuffer 。
      DataBufferShort​(short[][] dataArray, int size, int[] offsets)
      构造具有指定数组，大小和偏移量的基于短基的 DataBuffer 。
      DataBufferShort​(short[] dataArray, int size)
      使用指定的数组构建一个基于短基的 DataBuffer与单个银行。
      DataBufferShort​(short[] dataArray, int size, int offset)
      使用指定的数组，大小和偏移量，使用单个库构建基于短期的 DataBuffer 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      short[][] getBankData​()
      返回所有库的数据数组。
      short[] getData​()
      返回默认（第一个）字节数据数组。
      short[] getData​(int bank)
      返回指定库的数据数组。
      int getElem​(int i)
      从第一个（默认）库返回所请求的数据数组元素。
      int getElem​(int bank, int i)
      从指定的库返回所请求的数据数组元素。
      void setElem​(int i, int val)
      将第一个（默认）库中的请求的数据数组元素设置为指定的值。
      void setElem​(int bank, int i, int val)
      从给定的整数设置指定库中的请求的数据数组元素。

      • Methods inherited from class java.awt.image.DataBuffer

        getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataBufferShort

        public DataBufferShort​(int size)
        构造一个基于短期的 DataBuffer ，具有单个银行和指定的大小。
        参数
        size - 大小的 DataBuffer 。

      • DataBufferShort

        public DataBufferShort​(int size,
                       int numBanks)
        构造一个基于短期的 DataBuffer ，其中指定数量的银行都是指定的大小。
        参数
        size - 银行的大小在 DataBuffer 。
        numBanks - 一个 DataBuffer的银行数量。

      • DataBufferShort

        public DataBufferShort​(short[] dataArray,
                       int size)
        构造一个基于DataBuffer的短基于使用指定数组的单个库。 只有第size要素应当由本的访问器只能使用DataBuffer 。 dataArray必须足够大以容纳size元素。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        dataArray -为对短阵列 DataBuffer 。
        size - 大小的 DataBuffer银行。

      • DataBufferShort

        public DataBufferShort​(short[] dataArray,
                       int size,
                       int offset)
        使用指定的数组，大小和偏移量构建一个基于短基的DataBuffer并使用单个库。 dataArray必须至少有offset + size元素。 只有元件offset通过offset + size - 1应由本的访问器可以使用DataBuffer 。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -为对短阵列 DataBuffer 。
        size - DataBuffer银行的大小。
        offset - 偏移到 dataArray 。

      • DataBufferShort

        public DataBufferShort​(short[][] dataArray,
                       int size)
        使用指定的数组构造一个基于短基的DataBuffer 。 银行数量将相当于dataArray.length 。 这个DataBuffer的访问者只能使用每个数组的第一个size元素。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现使用的performance optimizations不兼容（例如缓存视频内存中的关联图像）。

        参数
        dataArray -为对短阵列 DataBuffer 。
        size - 银行的大小在 DataBuffer 。

      • DataBufferShort

        public DataBufferShort​(short[][] dataArray,
                       int size,
                       int[] offsets)
        构造一个具有指定数组，大小和偏移量的短基于DataBuffer 。 银行数量等于dataArray.length 。 每个阵列必须至少与size +相应的偏移量一样大。 每个dataArray条目的偏移数组中必须有一个条目。 对于每个银行，只有元素offset至offset + size应由该DataBuffer 。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -为对短阵列 DataBuffer 。
        size - 银行的大小在 DataBuffer 。
        offsets - 每个数组的偏移量。

    • 方法详细信息

      • getData

        public short[] getData​()
        返回默认（第一个）字节数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        第一个短数据数组。

      • getData

        public short[] getData​(int bank)
        返回指定库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        bank - 您想要获取数据数组的银行。
        结果
        指定银行的数据数组。

      • getBankData

        public short[][] getBankData​()
        返回所有库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        所有的数据阵列。

      • getElem

        public int getElem​(int i)
        从第一个（默认）库返回所请求的数据数组元素。
        重写：
        getElem在 DataBuffer
        参数
        i - 要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • getElem

        public int getElem​(int bank,
                   int i)
        从指定的库返回所请求的数据数组元素。
        Specified by:
        getElem在 DataBuffer
        参数
        bank - 要从中获取数据数组元素的存储区。
        i - 要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • setElem

        public void setElem​(int i,
                    int val)
        将第一个（默认）库中的请求的数据数组元素设置为指定的值。
        重写：
        setElem在 DataBuffer
        参数
        i - 要设置的数据数组元素。
        val - 要设置数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • setElem

        public void setElem​(int bank,
                    int i,
                    int val)
        从给定的整数设置指定库中的请求的数据数组元素。
        Specified by:
        setElem在 DataBuffer
        参数
        bank - 要在其中设置数据数组元素的库。
        i - 要设置的数据数组元素。
        val - 要设置指定数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataBufferUShort (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DataBufferUShort

  • java.lang.Object
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferUShort

  • public final class DataBufferUShort
extends DataBuffer
    该类扩展了DataBuffer并将数据内部存储为DataBuffer 。 存储在该DataBuffer的短数组中的值被视为无符号值。

    Note that some implementations may function more efficiently if they can maintain control over how the data for an image is stored. For example, optimizations such as caching an image in video memory require that the implementation track all modifications to that data. Other implementations may operate better if they can store the data in locations other than a Java array. To maintain optimum compatibility with various optimizations it is best to avoid constructors and methods which expose the underlying storage as a Java array as noted below in the documentation for those methods.

    • Field Summary

      • Fields inherited from class java.awt.image.DataBuffer

        banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataBufferUShort​(int size)
      构造一个无符号短基于 DataBuffer的单个银行和指定的大小。
      DataBufferUShort​(int size, int numBanks)
      构造一个无符号短基于 DataBuffer与指定数量的银行，所有这些都是指定的大小。
      DataBufferUShort​(short[][] dataArray, int size)
      使用指定的数组构造一个无符号短基的 DataBuffer 。
      DataBufferUShort​(short[][] dataArray, int size, int[] offsets)
      构造一个无符号短基于 DataBuffer具有指定的数组，大小和偏移量。
      DataBufferUShort​(short[] dataArray, int size)
      使用指定的数组构建一个无符号短基于 DataBuffer的单个存储区。
      DataBufferUShort​(short[] dataArray, int size, int offset)
      使用指定的数组，大小和偏移量构建一个无符号短基于 DataBuffer的单个存储区。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      short[][] getBankData​()
      返回所有库的数据数组。
      short[] getData​()
      返回默认（第一个）无符号短数据数组。
      short[] getData​(int bank)
      返回指定库的数据数组。
      int getElem​(int i)
      从第一个（默认）库返回所请求的数据数组元素。
      int getElem​(int bank, int i)
      从指定的库返回所请求的数据数组元素。
      void setElem​(int i, int val)
      将第一个（默认）库中的请求的数据数组元素设置为指定的值。
      void setElem​(int bank, int i, int val)
      从给定的整数设置指定库中的请求的数据数组元素。

      • Methods inherited from class java.awt.image.DataBuffer

        getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataBufferUShort

        public DataBufferUShort​(int size)
        构造一个无符号短基于 DataBuffer的单个银行和指定的大小。
        参数
        size -的的大小 DataBuffer 。

      • DataBufferUShort

        public DataBufferUShort​(int size,
                        int numBanks)
        构造一个无符号短基于 DataBuffer与指定数量的银行，所有这些都是指定的大小。
        参数
        size - 银行的大小在 DataBuffer 。
        numBanks - 一个 DataBuffer的银行数量。

      • DataBufferUShort

        public DataBufferUShort​(short[] dataArray,
                        int size)
        使用指定的数组构建一个无符号短基于DataBuffer的单个库。 只有第size要素应当由本的访问器只能使用DataBuffer 。 dataArray必须足够大才能容纳size元素。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的图像）。

        参数
        dataArray -为对无符号短阵列 DataBuffer 。
        size - DataBuffer银行的大小。

      • DataBufferUShort

        public DataBufferUShort​(short[] dataArray,
                        int size,
                        int offset)
        使用指定的数组，大小和偏移量构建一个无符号短基于DataBuffer的单个存储区。 dataArray必须至少有offset + size元素。 offset到offset + size元素应该由DataBuffer 。

        请注意，由此构造函数创建的DataBuffer对象可能与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的图像）。

        参数
        dataArray -为对无符号短阵列 DataBuffer 。
        size - 大小的 DataBuffer银行。
        offset - 偏移到 dataArray 。

      • DataBufferUShort

        public DataBufferUShort​(short[][] dataArray,
                        int size)
        使用指定的数组构造一个无符号短基的DataBuffer 。 银行数量将相当于dataArray.length 。 这个DataBuffer的访问者只能使用每个数组的第一个size元素。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -为对所述无符号短数组 DataBuffer 。
        size - 银行的大小在 DataBuffer 。

      • DataBufferUShort

        public DataBufferUShort​(short[][] dataArray,
                        int size,
                        int[] offsets)
        构造具有指定数组，大小和偏移的无符号短基于DataBuffer 。 银行数量等于dataArray.length 。 每个阵列必须至少与size +相应的偏移量一样大。 每个dataArray条目的偏移数组中必须有一个条目。 对于每个银行，只有元素offset至offset + size应由该DataBuffer 。

        请注意，此构造函数创建的对象DataBuffer可能与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        参数
        dataArray -为对所述无符号短数组 DataBuffer 。
        size - 银行的大小在 DataBuffer 。
        offsets - 每个阵列的偏移量。

    • 方法详细信息

      • getData

        public short[] getData​()
        返回默认（第一个）无符号短数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        结果
        第一个无符号数据数组。

      • getData

        public short[] getData​(int bank)
        返回指定库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实施使用的performance optimizations不兼容（例如在视频内存中缓存关联的映像）。

        参数
        bank - 您想要获取数据数组的银行。
        结果
        指定银行的数据数组。

      • getBankData

        public short[][] getBankData​()
        返回所有库的数据数组。

        请注意，调用此方法可能会导致此DataBuffer对象与某些实现（例如，缓存视频内存中的关联图像）所使用的performance optimizations不兼容。

        结果
        所有的数据阵列。

      • getElem

        public int getElem​(int i)
        从第一个（默认）库返回所请求的数据数组元素。
        重写：
        getElem在 DataBuffer
        参数
        i - 您要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • getElem

        public int getElem​(int bank,
                   int i)
        从指定的库返回所请求的数据数组元素。
        Specified by:
        getElem在 DataBuffer
        参数
        bank - 要从中获取数据数组元素的存储区。
        i - 要获取的数据数组元素。
        结果
        请求的数据数组元素为整数。
        另请参见：
        setElem(int, int) ， setElem(int, int, int)

      • setElem

        public void setElem​(int i,
                    int val)
        将第一个（默认）库中的请求的数据数组元素设置为指定的值。
        重写：
        setElem在 DataBuffer
        参数
        i - 要设置的数据数组元素。
        val - 要设置数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)

      • setElem

        public void setElem​(int bank,
                    int i,
                    int val)
        从给定的整数设置指定库中的请求的数据数组元素。
        Specified by:
        setElem在 DataBuffer
        参数
        bank - 要在其中设置数据数组元素的存储区。
        i - 要设置的数据数组元素。
        val - 要设置指定数据数组元素的整数值。
        另请参见：
        getElem(int) ， getElem(int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DirectColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class DirectColorModel

  • java.lang.Object
    • java.awt.image.ColorModel
      • java.awt.image.PackedColorModel
        • java.awt.image.DirectColorModel
  • All Implemented Interfaces:
    Transparency

    public class DirectColorModel
extends PackedColorModel
    DirectColorModel课程是一个ColorModel类，适用于将RGB颜色和Alpha信息表示为单独样本的像素值，并将单个像素的所有样本包装为单个int，short或byte数量。 该类只能用于ColorSpace.TYPE_RGB类型的ColorSpaces。 此外，对于ColorSpace的每个组件，通过ColorSpace的getMinValue()方法获得的最小归一化分量值必须为0.0，通过getMaxValue()方法获得的最大值必须为1.0（这些最小值/最大值是RGB空间的典型值） 。 在像素值中必须有三个颜色样本，并且可以有一个单一的α样本。 对于使用类型为transferType的原始数组像素表示的那些方法，数组长度始终为1。 支持的传输类型是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT和DataBuffer.TYPE_INT。 颜色和alpha样本以位掩码表示的位存储在阵列的单个元素中。 每个位掩码必须是连续的，掩码不能重叠。 相同的掩码适用于其他方法使用的单个int像素表示。 面具和颜色/阿尔法样本的对应关系如下：
    • 如果没有alpha，则由0到2的索引识别掩码，如果存在alpha，则为3。
    • 前三个指标是指彩色样本; 索引0对应于红色，索引1为绿色，索引2为蓝色。
    • 索引3对应于α样本（如果存在）。

    从显示或处理目的，从像素值到颜色/α分量的转换是样本与组件的一一对应关系。 A DirectColorModel通常用于使用掩模来定义打包样本的图像数据。 例如， DirectColorModel可以与SinglePixelPackedSampleModel一起使用来构建一个BufferedImage 。 通常， SampleModel和ColorModel使用的掩码将是一样的。 然而，如果它们不同，像素数据的颜色解释将根据ColorModel的掩码进行。

    单个int像素表示对于此类的所有对象是有效的，因为总是可以在单个int中表示与该类一起使用的像素值。 因此，由于无效的像素值，使用此表示的方法不会抛出IllegalArgumentException 。

    此颜色模型与X11 TrueColor视觉相似。 由getRGBdefault方法指定的默认RGB ColorModel是DirectColorModel具有以下参数：

      Number of bits:        32
 Red mask:              0x00ff0000
 Green mask:            0x0000ff00
 Blue mask:             0x000000ff
 Alpha mask:            0xff000000
 Color space:           sRGB
 isAlphaPremultiplied:  False
 Transparency:          Transparency.TRANSLUCENT
 transferType:          DataBuffer.TYPE_INT

    这个类中的很多方法都是最终的。 这是因为底层本机图形代码对该类的布局和操作做出假设，这些假设反映在这里标记为final的方法的实现中。 您可以通过其他原因对此类进行子类化，但不能覆盖或修改这些方法的行为。

    另请参见：
    ColorModel ， ColorSpace ， SinglePixelPackedSampleModel ， BufferedImage ， ColorModel.getRGBdefault()

    • Field Summary

      • Fields inherited from class java.awt.image.ColorModel

        pixel_bits, transferType

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      DirectColorModel​(int bits, int rmask, int gmask, int bmask)
      从指定的掩码构造一个 DirectColorModel ，指示 int像素表示中的哪些位包含红色，绿色和蓝色样本。
      DirectColorModel​(int bits, int rmask, int gmask, int bmask, int amask)
      从指定的掩码构造一个 DirectColorModel ，指示 int像素表示中的哪些位包含红色，绿色和蓝色样本以及alpha样本（如果存在）。
      DirectColorModel​(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int transferType)
      从指定的参数构造一个 DirectColorModel 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ColorModel coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设此 ColorModel正确描述了数据。
      WritableRaster createCompatibleWritableRaster​(int w, int h)
      创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。
      int getAlpha​(int pixel)
      返回指定像素的alpha分量，从0到255。
      int getAlpha​(Object inData)
      返回指定像素的alpha分量，从0到255。
      int getAlphaMask​()
      返回掩码，指示 int像素表示中的哪些位包含alpha组件。
      int getBlue​(int pixel)
      返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      int getBlue​(Object inData)
      返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      int getBlueMask​()
      返回掩码，指示 int像素表示中的哪些位包含蓝色分量。
      int[] getComponents​(int pixel, int[] components, int offset)
      在这个 ColorModel给出一个像素的非规范化颜色/ alpha分量的数组。
      int[] getComponents​(Object pixel, int[] components, int offset)
      返回给这个 ColorModel一个像素的非规范化颜色/ alpha分量的数组。
      int getDataElement​(int[] components, int offset)
      给出一个非标准化颜色/ alpha组件数组，返回 int中 ColorModel表示的像素值。
      Object getDataElements​(int[] components, int offset, Object obj)
      给出这个 ColorModel的一个像素的数据元素数组表示，给出了一个非标准化颜色/ alpha分量的数组。
      Object getDataElements​(int rgb, Object pixel)
      返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。
      int getGreen​(int pixel)
      返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      int getGreen​(Object inData)
      返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      int getGreenMask​()
      返回掩码，指示 int像素表示中的哪些位包含绿色分量。
      int getRed​(int pixel)
      返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      int getRed​(Object inData)
      返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。
      int getRedMask​()
      返回掩码，指示 int像素表示中的哪些位包含红色分量。
      int getRGB​(int pixel)
      以默认RGB颜色模型格式返回像素的颜色/ alpha分量。
      int getRGB​(Object inData)
      以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。
      boolean isCompatibleRaster​(Raster raster)
      如果 raster与 ColorModel和 false兼容，则返回 true 。
      String toString​()
      返回一个 String ，代表这个 DirectColorModel 。

      • Methods inherited from class java.awt.image.ColorModel

        finalize, getColorSpace, getComponentSize, getComponentSize, getDataElement, getDataElements, getNormalizedComponents, getNormalizedComponents, getNumColorComponents, getNumComponents, getPixelSize, getRGBdefault, getTransferType, getTransparency, getUnnormalizedComponents, hasAlpha, isAlphaPremultiplied

      • Methods inherited from class java.lang.Object

        clone, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.awt.image.PackedColorModel

        createCompatibleSampleModel, equals, getAlphaRaster, getMask, getMasks, hashCode, isCompatibleSampleModel

    • 构造方法详细信息

      • DirectColorModel

        public DirectColorModel​(int bits,
                        int rmask,
                        int gmask,
                        int bmask)
        从指定的掩码中构造一个DirectColorModel ，指示int像素表示中的哪些位包含红色，绿色和蓝色样本。 由于像素值不包含alpha信息，因此所有像素都被视为不透明，这意味着alpha = 1.0。 每个掩码中的所有位必须是连续的，并且适合int像素表示的指定数目的最低有效位。 ColorSpace是默认的sRGB空间。 透明度值为Transparency.OPAQUE。 传输类型是可容纳单个像素的DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT中最小的。
        参数
        bits - 像素值中的位数; 例如，掩码中的比特数之和。
        rmask - 指定指示整数像素中的哪些位包含红色分量的掩码
        gmask - 指定指示整数像素中的哪些位包含绿色分量的掩码
        bmask - 指定指示整数像素中的哪些位包含蓝色分量的掩码

      • DirectColorModel

        public DirectColorModel​(int bits,
                        int rmask,
                        int gmask,
                        int bmask,
                        int amask)
        从指定的掩码构造一个DirectColorModel ，指示int像素表示中的哪些位包含红色，绿色和蓝色样本以及alpha样本（如果存在）。 如果amask为0，则像素值不包含alpha信息，所有像素都被视为不透明，这意味着alpha = 1.0。 每个掩码中的所有位必须是连续的，并且适合int像素表示的指定数目的最低有效位。 阿尔法，如果存在，不是预付费。 ColorSpace是默认的sRGB空间。 透明度值是Transparency.OPAQUE，如果不存在alpha，或Transparency.TRANSLUCENT，否则。 传输类型是可容纳单个像素的DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT中最小的。
        参数
        bits - 像素值中的位数; 例如，掩码中的比特数之和。
        rmask - 指定指示整数像素中的哪些位包含红色分量的掩码
        gmask - 指定指示整数像素中的哪些位包含绿色分量的掩码
        bmask - 指定指示整数像素中的哪些位包含蓝色分量的掩码
        amask - 指定指示整数像素中的哪些位包含α分量的掩码

      • DirectColorModel

        public DirectColorModel​(ColorSpace space,
                        int bits,
                        int rmask,
                        int gmask,
                        int bmask,
                        int amask,
                        boolean isAlphaPremultiplied,
                        int transferType)
        从指定的参数构造一个DirectColorModel 。 颜色组件在指定的ColorSpace ，它必须是ColorSpace.TYPE_RGB类型，并且具有最小标准化分量值，全部为0.0，最大值均为1.0。 掩码指定int像素表示中的哪些位包含红色，绿色和蓝色样本以及alpha样本（如果存在）。 如果amask为0，像素值不包含alpha信息，所有像素都被视为不透明，这意味着alpha = 1.0。 每个掩码中的所有位必须是连续的，并且适合int像素表示的指定数目的最低有效位。 如果有alpha， boolean isAlphaPremultiplied指定如何在像素值中解释颜色和alpha样本。 如果boolean是true ，则假设颜色样本已被乘以α样本。 透明度值为Transparency.OPAQUE，如果不存在alpha，或Transparency.TRANSLUCENT则为透明度。 传输类型是用于表示像素值的原始数组的类型，必须是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT之一。
        参数
        space - 指定的 ColorSpace
        bits - 像素值中的位数; 例如，掩码中的比特数之和。
        rmask - 指定一个掩码，指示整数像素中的哪些位包含红色分量
        gmask - 指定一个掩码，指示整数像素中的哪些位包含绿色分量
        bmask - 指定指示整数像素中的哪些位包含蓝色分量的掩码
        amask - 指定指示整数像素中的哪些位包含α分量的掩码
        isAlphaPremultiplied - true如果颜色样本被alpha样本预乘， 否则为false
        transferType - 用于表示像素值的数组类型
        异常
        IllegalArgumentException - 如果 space不是TYPE_RGB空间，或者最小/最大标准化组件值不是0.0 / 1.0。

    • 方法详细信息

      • getRedMask

        public final int getRedMask​()
        返回掩码，指示 int像素表示中的哪些位包含红色成分。
        结果
        该掩码指示 int像素表示的哪个位包含红色样本。

      • getGreenMask

        public final int getGreenMask​()
        返回掩码，指示 int像素表示中的哪些位包含绿色分量。
        结果
        该掩码指示 int像素表示的哪个位包含绿色样本。

      • getBlueMask

        public final int getBlueMask​()
        返回掩码，指示 int像素表示中的哪些位包含蓝色分量。
        结果
        该掩码指示 int像素表示的哪个位包含蓝色样本。

      • getAlphaMask

        public final int getAlphaMask​()
        返回掩码，指示 int像素表示中的哪些位包含alpha分量。
        结果
        该掩码指示 int像素表示的哪个位包含α样本。

      • getRed

        public final int getRed​(int pixel)
        返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值被指定为int 。 返回的值是非预先乘以的值。 因此，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，例如，红色值为0。
        Specified by:
        getRed在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的红色分量，sRGB ColorSpace中的0到255。

      • getGreen

        public final int getGreen​(int pixel)
        返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。 必要时进行颜色转换。 像素值被指定为int 。 返回的值是非预先乘以的值。 因此，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，例如，绿色值为0。
        Specified by:
        getGreen在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的绿色分量，sRGB ColorSpace中的0到255。

      • getBlue

        public final int getBlue​(int pixel)
        返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值被指定为int 。 返回的值是非预先乘以的值。 因此，如果alpha被预乘，则该方法在返回值之前将其分开。 如果alpha值为0，例如，蓝色值为0。
        Specified by:
        getBlue在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的蓝色分量，sRGB ColorSpace中的0到255。

      • getAlpha

        public final int getAlpha​(int pixel)
        返回指定像素的alpha分量，从0到255。像素值指定为 int 。
        Specified by:
        getAlpha在 ColorModel
        参数
        pixel - 指定的像素
        结果
        alpha分量的 pixel从0到255。

      • getRGB

        public final int getRGB​(int pixel)
        以默认RGB颜色模型格式返回像素的颜色/ alpha分量。 必要时进行颜色转换。 像素值被指定为int 。 返回的值为非预先乘法格式。 因此，如果alpha被预乘，则该方法将其从颜色分量中分离出来。 如果alpha值为0，例如，颜色值分别为0。
        重写：
        getRGB在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的颜色/ alpha分量的RGB值。
        另请参见：
        ColorModel.getRGBdefault()

      • getRed

        public int getRed​(Object inData)
        返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值由作为对象引用传入的数据元素transferType的数组指定。 返回的值是非预先乘以的值。 因此，如果alpha被预乘，则该方法在返回值之前将其分开。 如果α值是0，例如，红色值是0。如果inData不是类型的基本数组transferType ，一个ClassCastException被抛出。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 由于DirectColorModel可以被子类化，子类继承了该方法的实现，如果它们不覆盖它们，那么如果它们使用不支持的transferType它们将抛出异常。 一个UnsupportedOperationException如果这是抛出transferType不受此支持ColorModel 。
        重写：
        getRed在 ColorModel
        参数
        inData - 包含像素值的数组
        结果
        指定像素的红色分量的值。
        异常
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能持有该颜色模型的像素值
        ClassCastException -如果 inData不是类型的基本数组 transferType
        UnsupportedOperationException - 如果此颜色模型不支持此 transferType

      • getGreen

        public int getGreen​(Object inData)
        返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值由作为对象引用传入的数据元素transferType的数组指定。 返回的值是非预先乘以的值。 因此，如果alpha被预乘，则该方法在返回值之前将其分开。 如果α值是0，例如，绿色的值为0。如果inData不是类型的基本数组transferType ，一个ClassCastException被抛出。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 由于DirectColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType ，则它们会引发异常。 一个UnsupportedOperationException如果这是抛出transferType不受此支持ColorModel 。
        重写：
        getGreen在 ColorModel
        参数
        inData - 包含像素值的数组
        结果
        指定像素的绿色分量的值。
        异常
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能持有该颜色模型的像素值
        ClassCastException -如果 inData不是类型的基本数组 transferType
        UnsupportedOperationException - 如果此颜色模型不支持此 transferType

      • getBlue

        public int getBlue​(Object inData)
        返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。 必要时进行颜色转换。 像素值由作为对象引用传入的数据元素transferType数组指定。 返回的值是非预先乘以的值。 因此，如果alpha被预乘，则该方法在返回值之前将其分开。 如果α值是0，例如，蓝色值为0。如果inData不是类型的基本数组transferType ，一个ClassCastException被抛出。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 由于DirectColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。 如果这个transferType不支持UnsupportedOperationException则会抛出一个ColorModel 。
        重写：
        getBlue在 ColorModel
        参数
        inData - 包含像素值的数组
        结果
        指定像素的蓝色分量的值。
        异常
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能持有该颜色模型的像素值
        ClassCastException -如果 inData不是类型的基本数组 transferType
        UnsupportedOperationException - 如果此颜色模型不支持此 transferType

      • getAlpha

        public int getAlpha​(Object inData)
        返回指定像素的alpha分量，从0到255进行比例。像素值由作为对象引用传入的数据元素数组transferType指定。 如果inData不是类型的基本数组transferType ，一个ClassCastException被抛出。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 由于DirectColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。 如果不支持此transferType ，则抛出UnsupportedOperationException 。
        重写：
        getAlpha在 ColorModel
        参数
        inData - 指定的像素
        结果
        指定像素的alpha分量，从0到255。
        异常
        ClassCastException -如果 inData不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 inData不够大，不能保持这个 ColorModel的像素值
        UnsupportedOperationException - 此 tranferType不支持此 ColorModel

      • getRGB

        public int getRGB​(Object inData)
        以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。 必要时进行颜色转换。 像素值由作为对象引用传入的数据元素transferType的数组指定。 如果inData不是类型的基本数组transferType ，一个ClassCastException被抛出。 一个ArrayIndexOutOfBoundsException如果抛出inData不够大，不能保存这个像素值ColorModel 。 返回的值为非预先乘法格式。 因此，如果alpha被预乘，则该方法将其从颜色分量中分离出来。 例如，如果alpha值为0，则颜色值为0.由于DirectColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，则如果使用不支持的transferType ，则它们将抛出异常。
        重写：
        getRGB在 ColorModel
        参数
        inData - 指定的像素
        结果
        指定像素的颜色和alpha分量。
        异常
        UnsupportedOperationException - 如果这个 transferType不支持这个 ColorModel
        另请参见：
        ColorModel.getRGBdefault()

      • getDataElements

        public Object getDataElements​(int rgb,
                              Object pixel)
        返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 如果像素变量为null ，则会分配一个新数组。 如果pixel不是null ，它必须是transferType类型的基本数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 返回像素数组。 由于DirectColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。
        重写：
        getDataElements在 ColorModel
        参数
        rgb - 默认RGB颜色模型中的整数像素表示
        pixel - 指定的像素
        结果
        该 ColorModel指定像素的数组表示
        异常
        ClassCastException -如果 pixel不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 pixel不够大，不能保持这个 ColorModel的像素值
        UnsupportedOperationException - 如果这个 transferType不支持此 ColorModel
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getComponents

        public final int[] getComponents​(int pixel,
                                 int[] components,
                                 int offset)
        返回给这个ColorModel一个像素的非规范化颜色/ alpha分量的数组。 像素值被指定为int 。 如果components阵列为null ，则会分配一个新阵列。 将返回components数组。 即使通过此方法分配阵列，颜色/ Alpha组件存储在从components开始的offset阵列中。 一个ArrayIndexOutOfBoundsException如果抛出components数组不null ，而不是大到足以容纳所有的颜色和alpha分量，开始offset 。
        重写：
        getComponents在 ColorModel
        参数
        pixel - 指定的像素
        components - 用于接收指定像素的颜色和alpha分量的数组
        offset - 开始存储颜色和alpha组件的 components阵列的偏移量
        结果
        一个数组，包含从指定的偏移开始的指定像素的颜色和alpha分量。

      • getComponents

        public final int[] getComponents​(Object pixel,
                                 int[] components,
                                 int offset)
        在这个ColorModel给出一个像素，返回一个非规范化颜色/ alpha分量的数组。 像素值由作为对象引用传入的数据元素transferType的数组指定。 如果pixel不是类型的基本数组transferType ，一个ClassCastException被抛出。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 如果components阵列为null ，则会分配一个新阵列。 将返回components数组。 颜色/ alpha分量存储中components数组以offset ，即使阵列通过这种方法分配的。 一个ArrayIndexOutOfBoundsException如果抛出components数组不null ，而不是大到足以容纳所有的颜色和alpha分量，开始offset 。 由于DirectColorModel可以被子类化，子类继承了该方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。
        重写：
        getComponents在 ColorModel
        参数
        pixel - 指定的像素
        components - 接收指定像素的颜色和alpha分量的数组
        offset - 要开始存储颜色和alpha组件的 components阵列的偏移量
        结果
        一个数组，包含从指定的偏移开始的指定像素的颜色和alpha分量。
        异常
        ClassCastException - 如果 pixel不是 transferType类型的原始数组
        ArrayIndexOutOfBoundsException - 如果 pixel不够大以容纳 ColorModel的像素值，或者如果 components不是 null ，并且不够大，不能容纳所有颜色和alpha分量，从 offset开始
        UnsupportedOperationException - 如果此颜色模型不支持此 transferType

      • createCompatibleWritableRaster

        public final WritableRaster createCompatibleWritableRaster​(int w,
                                                           int h)
        创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。
        重写：
        createCompatibleWritableRaster在 ColorModel
        参数
        w - 要应用于新的 WritableRaster的宽度
        h - 适用于新的 WritableRaster的高度
        结果
        一个 WritableRaster对象具有指定的宽度和高度。
        异常
        IllegalArgumentException - 如果 w或 h小于或等于零
        另请参见：
        WritableRaster ， SampleModel

      • getDataElement

        public int getDataElement​(int[] components,
                          int offset)
        返回表示为一个像素值int在此ColorModel ，给定非标准化颜色/ alpha分量的阵列。 一个ArrayIndexOutOfBoundsException如果抛出components阵列是不是大到足以容纳所有的颜色和alpha分量，开始offset 。
        重写：
        getDataElement在 ColorModel
        参数
        components - 非规范化颜色和alpha组件的数组
        offset - 索引到 components ，开始检索颜色和alpha组件
        结果
        一个 int像素值在这 ColorModel对应的指定组件。
        异常
        ArrayIndexOutOfBoundsException - 如果 components数组不够大，不能容纳从 offset开始的所有颜色和alpha组件

      • getDataElements

        public Object getDataElements​(int[] components,
                              int offset,
                              Object obj)
        给出这个ColorModel的一个像素的数据元素数组表示，给出了一个非标准化颜色/ alpha分量的数组。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 一个ArrayIndexOutOfBoundsException ，如果被抛出components阵列是没有大到足以容纳所有的颜色和alpha分量，起始偏移量。 如果obj变量为null ，则会分配一个新数组。 如果obj不是null ，它必须是transferType类型的原始数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出obj不够大，不能保存这个像素值ColorModel 。 由于DirectColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。
        重写：
        getDataElements在 ColorModel
        参数
        components - 非规范化颜色和alpha组件的数组
        offset - 索引到 components ，开始检索颜色和alpha组件
        obj - Object表示颜色和alpha组件的数组
        结果
        一个 Object表示一个颜色和alpha组件的数组。
        异常
        ClassCastException - 如果 obj不是类型为 transferType的原始数组
        ArrayIndexOutOfBoundsException - 如果 obj不够大以容纳 ColorModel的像素值，或 components阵列不够大，不足以容纳所有颜色和alpha分量从 offset开始
        UnsupportedOperationException - 如果此颜色模型不支持此 transferType
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • coerceData

        public final ColorModel coerceData​(WritableRaster raster,
                                   boolean isAlphaPremultiplied)
        强制栅格数据与isAlphaPremultiplied变量中指定的状态相匹配，假定此ColorModel当前正确描述了数据。 它可以将颜色光栅数据乘以或除以alpha，如果数据处于正确状态，则不执行任何操作。 如果需要强制数据，则此方法也将返回ColorModel一个实例，并isAlphaPremultiplied设置isAlphaPremultiplied标志。 如果此UnsupportedOperationException不支持此transferType，则此方法将抛出一个ColorModel 。 由于ColorModel可以被子类化，子类继承了该方法的实现，如果它们不覆盖它，那么如果它们使用不受支持的transferType，它们会引发异常。
        重写：
        coerceData在 ColorModel
        参数
        raster - WritableRaster数据
        isAlphaPremultiplied - true如果alpha被预乘， 否则为false
        结果
        一个表示强制数据的 ColorModel对象。
        异常
        UnsupportedOperationException - 如果此颜色模型不支持此 transferType

      • isCompatibleRaster

        public boolean isCompatibleRaster​(Raster raster)
        返回 true如果 raster是兼容这个 ColorModel和 false如果不是。
        重写：
        isCompatibleRaster在 ColorModel
        参数
        raster - 要测试兼容性的Raster对象
        结果
        true如果raster是兼容这个ColorModel ; false否则。

      • toString

        public String toString​()
        返回 String表示此 DirectColorModel 。
        重写：
        toString在 ColorModel
        结果
        一个 String代表这个 DirectColorModel 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilteredImageSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class FilteredImageSource

  • java.lang.Object
    • java.awt.image.FilteredImageSource
  • All Implemented Interfaces:
    ImageProducer

    public class FilteredImageSource
extends Object
implements ImageProducer
    这个类是ImageProducer接口的一个实现，它接收一个现有的图像和一个过滤器对象，并使用它们来生成原始图像的新过滤版本的图像数据。 这是一个通过交换红色和蓝色组件来过滤图像的示例：
      Image src = getImage("doc:///demo/images/duke/T1.gif");
      ImageFilter colorfilter = new RedBlueSwapFilter();
      Image img = createImage(new FilteredImageSource(src.getSource(),
                                                      colorfilter));
    另请参见：
    ImageProducer

    • 构造方法摘要

      构造方法
      Constructor 描述
      FilteredImageSource​(ImageProducer orig, ImageFilter imgf)
      从现有的ImageProducer和过滤器对象构造一个ImageProducer对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addConsumer​(ImageConsumer ic)
      将指定的 ImageConsumer添加到对过滤图像的数据感兴趣的消费者列表中。
      boolean isConsumer​(ImageConsumer ic)
      确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。
      void removeConsumer​(ImageConsumer ic)
      从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
      void requestTopDownLeftRightResend​(ImageConsumer ic)
      请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
      void startProduction​(ImageConsumer ic)
      开始生成已过滤的图像。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FilteredImageSource

        public FilteredImageSource​(ImageProducer orig,
                           ImageFilter imgf)
        从现有的ImageProducer和过滤器对象构造一个ImageProducer对象。
        参数
        orig - 指定的 ImageProducer
        imgf - 指定的 ImageFilter
        另请参见：
        ImageFilter ， Component.createImage(java.awt.image.ImageProducer)

    • 方法详细信息

      • addConsumer

        public void addConsumer​(ImageConsumer ic)
        将指定的ImageConsumer添加到对过滤图像的数据感兴趣的消费者列表中。 创建原始ImageFilter的实例（使用过滤器的getFilterInstance方法）来处理指定的ImageConsumer的图像数据。 然后将新创建的过滤器实例传递给原始ImageProducer的addConsumer方法。

        这种方法是公共的，这个类实现了这个ImageProducer接口的ImageProducer 。 它不应该从用户代码调用，并且如果从用户代码调用的行为是未指定的。

        Specified by:
        addConsumer在接口 ImageProducer
        参数
        ic - 过滤图像的消费者
        另请参见：
        ImageConsumer

      • isConsumer

        public boolean isConsumer​(ImageConsumer ic)
        确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。

        这种方法是公共的，这个类实现了ImageProducer接口。 它不应该从用户代码调用，并且如果从用户代码调用的行为是未指定的。

        Specified by:
        isConsumer在接口 ImageProducer
        参数
        ic - 指定的 ImageConsumer
        结果
        如果ImageConsumer在列表中，则为true; 否则为假
        另请参见：
        ImageConsumer

      • removeConsumer

        public void removeConsumer​(ImageConsumer ic)
        从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。

        这种方法是公共的，这个类实现了这个ImageProducer接口的ImageProducer 。 它不应该从用户代码调用，并且如果从用户代码调用的行为是未指定的。

        Specified by:
        removeConsumer在接口 ImageProducer
        参数
        ic - 指定的 ImageConsumer
        另请参见：
        ImageConsumer

      • startProduction

        public void startProduction​(ImageConsumer ic)
        开始生成已过滤的图像。 如果指定的ImageConsumer尚未经滤波的图像的一个消费者，原有的实例ImageFilter创建（使用过滤器的getFilterInstance方法），以操作所述图像数据ImageConsumer 。 然后将ImageConsumer的过滤器实例传递给原始ImageProducer的startProduction方法。

        这种方法是公共的，这个类实现了这个ImageProducer接口的一个副作用。 它不应该从用户代码调用，并且如果从用户代码调用的行为是未指定的。

        Specified by:
        startProduction在接口 ImageProducer
        参数
        ic - 过滤图像的消费者
        另请参见：
        ImageConsumer

      • requestTopDownLeftRightResend

        public void requestTopDownLeftRightResend​(ImageConsumer ic)
        请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。 将该请求交给ImageFilter进行进一步处理，因为保留像素排序的能力取决于过滤器。

        这种方法是公共的，这个类实现了ImageProducer接口ImageProducer 。 它不应该从用户代码调用，并且如果从用户代码调用的行为是未指定的。

        Specified by:
        requestTopDownLeftRightResend在接口 ImageProducer
        参数
        ic - 指定的 ImageConsumer
        另请参见：
        ImageConsumer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImageConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface ImageConsumer

  • 所有已知实现类：
    AreaAveragingScaleFilter ， BufferedImageFilter ， CropImageFilter ， GrayFilter ， ImageFilter ， PixelGrabber ， ReplicateScaleFilter ， RGBImageFilter

    public interface ImageConsumer
    通过ImageProducer界面表示对图像数据感兴趣的对象的界面。 当消费者添加到图像制作者时，制作者使用此界面中定义的方法调用方传递有关图像的所有数据。
    另请参见：
    ImageProducer

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int COMPLETESCANLINES
      像素将以完整的扫描线一次传输（倍数）。
      static int IMAGEABORTED
      图像创建过程故意中止。
      static int IMAGEERROR
      生成图像时遇到错误。
      static int RANDOMPIXELORDER
      像素将以随机顺序递送。
      static int SINGLEFRAME
      该图像包含一个静态图像。
      static int SINGLEFRAMEDONE
      图像的一帧是完整的，但是有更多的帧被传送。
      static int SINGLEPASS
      像素将以单次传递方式传送。
      static int STATICIMAGEDONE
      图像是完整的，没有更多的像素或帧要交付。
      static int TOPDOWNLEFTRIGHT
      像素将以自上而下的从左到右的顺序传递。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void imageComplete​(int status)
      当ImageProducer完成传递源图像所包含的所有像素时，或者当多帧动画的单帧已经完成时，或者当加载或生成图像发生错误时，将调用imageComplete方法。
      void setColorModel​(ColorModel model)
      设置使用setPixels方法调用报告的大多数像素使用的ColorModel对象。
      void setDimensions​(int width, int height)
      使用setDimensions方法调用来报告源图像的尺寸。
      void setHints​(int hintflags)
      设置ImageConsumer用于处理ImageProducer传递的像素的提示。
      void setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      通过一次或多次调用该方法来提供图像的像素。
      void setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      使用对setPixels方法的一个或多个调用来传送图像的像素。
      void setProperties​(Hashtable<?,?> props)
      设置与此映像关联的属性的可扩展列表。

    • 字段详细信息

      • RANDOMPIXELORDER

        static final int RANDOMPIXELORDER
        像素将以随机顺序递送。 这告诉ImageConsumer不要使用依赖于像素传递顺序的任何优化，在没有调用setHints方法的情况下，它应该是默认的假设。
        另请参见：
        setHints(int) ， Constant Field Values

      • TOPDOWNLEFTRIGHT

        static final int TOPDOWNLEFTRIGHT
        像素将以自上而下的从左到右的顺序传递。
        另请参见：
        setHints(int) ， Constant Field Values

      • COMPLETESCANLINES

        static final int COMPLETESCANLINES
        像素将以完整的扫描线一次传输（倍数）。
        另请参见：
        setHints(int) ， Constant Field Values

      • SINGLEPASS

        static final int SINGLEPASS
        像素将以单次传递方式传送。 每个像素将只出现在任何一个setPixels方法的一个调用中。 不符合该标准的图像格式的示例是定义多遍中的像素的渐进JPEG图像，每个像素比先前的更精细。
        另请参见：
        setHints(int) ， Constant Field Values

      • SINGLEFRAME

        static final int SINGLEFRAME
        该图像包含一个静态图像。 将在对setPixels方法的调用中定义像素，然后使用STATICIMAGEDONE标志调用imageComplete方法，之后不会再传送更多的图像数据。 不符合这些标准的图像类型的示例将是视频馈送的输出，或由用户操纵的3D呈现的表示。 通过使用SINGLEFRAMEDONE标志调用imageComplete来表示这些类型图像中每帧的结尾。
        另请参见：
        setHints(int) ， imageComplete(int) ， Constant Field Values

      • IMAGEERROR

        static final int IMAGEERROR
        生成图像时遇到错误。
        另请参见：
        imageComplete(int) ， Constant Field Values

      • SINGLEFRAMEDONE

        static final int SINGLEFRAMEDONE
        图像的一帧是完整的，但是有更多的帧被传送。
        另请参见：
        imageComplete(int) ， Constant Field Values

      • STATICIMAGEDONE

        static final int STATICIMAGEDONE
        图像是完整的，没有更多的像素或帧要交付。
        另请参见：
        imageComplete(int) ， Constant Field Values

      • IMAGEABORTED

        static final int IMAGEABORTED
        图像创建过程故意中止。
        另请参见：
        imageComplete(int) ， Constant Field Values

    • 方法详细信息

      • setDimensions

        void setDimensions​(int width,
                   int height)
        使用setDimensions方法调用来报告源图像的尺寸。
        参数
        width - 源图像的宽度
        height - 源图像的高度

      • setProperties

        void setProperties​(Hashtable<?,?> props)
        设置与此映像关联的属性的可扩展列表。
        参数
        props - 要与此映像关联的属性列表

      • setColorModel

        void setColorModel​(ColorModel model)
        设置使用setPixels方法调用报告的大多数像素使用的ColorModel对象。 请注意，使用setPixels传递的每组像素包含其自己的ColorModel对象，因此不应该假设该模型将是唯一用于传递像素值的模型。 可以看到多个ColorModel对象的一个显着的情况是过滤图像，对于其过滤的每个像素集，滤镜确定像素是否可以使用原始ColorModel进行未触摸像素的发送，或者像素是否应被修改（过滤） ）并使用ColorModel传递更方便的过滤过程。
        参数
        model - 指定的 ColorModel
        另请参见：
        ColorModel

      • setHints

        void setHints​(int hintflags)
        设置ImageConsumer用于处理ImageProducer传递的像素的提示。 ImageProducer可以以任何顺序传递像素，但如果ImageConsumer知道有关像素将如何传递的一些信息，则ImageConsumer可能能够更有效地缩放或转换像素到目的地ColorModel。 在对任何一个setPixels方法的调用之前，应该调用setHints方法，该方法具有关于像素将被传递的方式的提示的位掩码。 如果ImageProducer不遵循指示的提示的指导，则结果未定义。
        参数
        hintflags - ImageConsumer用于处理像素的一组提示

      • setPixels

        void setPixels​(int x,
               int y,
               int w,
               int h,
               ColorModel model,
               byte[] pixels,
               int off,
               int scansize)
        通过一次或多次调用该方法来提供图像的像素。 每个调用指定包含在像素数组中的源像素的矩形的位置和大小。 应使用指定的ColorModel对象将像素转换为相应的颜色和alpha组件。 像素（m，n）以索引（n * scansize + m + off）存储在像素阵列中。 使用此方法传送的像素都以字节存储。
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels阵列中从一行像素到下一行的距离
        另请参见：
        ColorModel

      • setPixels

        void setPixels​(int x,
               int y,
               int w,
               int h,
               ColorModel model,
               int[] pixels,
               int off,
               int scansize)
        使用对setPixels方法的一个或多个调用来传送图像的像素。 每个调用指定包含在像素数组中的源像素的矩形的位置和大小。 应使用指定的ColorModel对象将像素转换为相应的颜色和alpha组件。 像素（m，n）以索引（n * scansize + m + off）存储在像素阵列中。 使用此方法传递的像素全部存储为int。 此方法全部存储为int。
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中的一行像素到下一行的距离
        另请参见：
        ColorModel

      • imageComplete

        void imageComplete​(int status)
        当ImageProducer完成传递源图像所包含的所有像素时，或者当多帧动画的单帧已经完成时，或者当加载或生成图像发生错误时，将调用imageComplete方法。 ImageConsumer此时应将其从注册到ImageProducer的消费者列表中删除，除非对连续帧感兴趣。
        参数
        status - 图像加载的状态
        另请参见：
        ImageProducer.removeConsumer(java.awt.image.ImageConsumer)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ImageFilter

  • java.lang.Object
    • java.awt.image.ImageFilter
  • All Implemented Interfaces:
    ImageConsumer ， Cloneable
    已知直接子类：
    BufferedImageFilter ， CropImageFilter ， ReplicateScaleFilter ， RGBImageFilter

    public class ImageFilter
extends Object
implements ImageConsumer, Cloneable
    此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。 这意味着与FilteredImageSource对象结合使用以产生现有图像的过滤版本。 它是一个基类，它提供了实现“Null filter”所需的调用，这对传递的数据没有影响。 过滤器应该对此类进行子类化，并覆盖处理需要过滤的数据的方法，并根据需要进行修改。
    另请参见：
    FilteredImageSource ， ImageConsumer

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ImageConsumer consumer
      ImageFilter的此实例正在过滤数据的特定图像数据流的消费者。

      • Fields inherited from interface java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImageFilter​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      克隆这个对象。
      ImageFilter getFilterInstance​(ImageConsumer ic)
      返回一个ImageFilter对象的唯一实例，该对象实际上将对指定的ImageConsumer进行过滤。
      void imageComplete​(int status)
      过滤ImageConsumer界面的imageComplete方法中提供的信息。
      void resendTopDownLeftRight​(ImageProducer ip)
      对TopDownLeftRight（TDLR）的请求做出响应，命令从 ImageConsumer重新发送像素数据。
      void setColorModel​(ColorModel model)
      过滤ImageConsumer界面的setColorModel方法中提供的信息。
      void setDimensions​(int width, int height)
      过滤ImageConsumer接口的setDimensions方法中提供的信息。
      void setHints​(int hints)
      过滤ImageConsumer界面的setHints方法中提供的信息。
      void setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      过滤ImageConsumer接口的setPixels方法中提供的信息，该接口采用字节数组。
      void setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      对ImageConsumer接口的setPixels方法中提供的信息进行过滤，该接口采用整数数组。
      void setProperties​(Hashtable<?,?> props)
      在添加一个指示已经运行的过滤器流的属性之后，从源对象传递属性。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • consumer

        protected ImageConsumer consumer
        ImageFilter的此实例正在过滤数据的特定图像数据流的消费者。 它在构造函数期间未初始化，而是在FilteredImageSource为特定图像数据流创建此对象的唯一实例期间的getFilterInstance（）方法调用期间调用。
        另请参见：
        getFilterInstance(java.awt.image.ImageConsumer) ， ImageConsumer

    • 构造方法详细信息

      • ImageFilter

        public ImageFilter​()

    • 方法详细信息

      • getFilterInstance

        public ImageFilter getFilterInstance​(ImageConsumer ic)
        返回一个ImageFilter对象的唯一实例，该对象实际上将对指定的ImageConsumer进行过滤。 默认的实现只是克隆这个对象。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        参数
        ic - 指定的 ImageConsumer
        结果
        一个 ImageFilter用于对指定的 ImageConsumer执行过滤。

      • setDimensions

        public void setDimensions​(int width,
                          int height)
        过滤ImageConsumer接口的setDimensions方法中提供的信息。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setDimensions在接口 ImageConsumer
        参数
        width - 源图像的宽度
        height - 源图像的高度
        另请参见：
        ImageConsumer.setDimensions(int, int)

      • setProperties

        public void setProperties​(Hashtable<?,?> props)
        在添加一个指示已经运行的过滤器流的属性之后，从源对象传递属性。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setProperties在接口 ImageConsumer
        参数
        props - 源对象的属性
        异常
        NullPointerException - 如果 props为空

      • setColorModel

        public void setColorModel​(ColorModel model)
        过滤ImageConsumer界面的setColorModel方法中提供的信息。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setColorModel在接口 ImageConsumer
        参数
        model - 指定的 ColorModel
        另请参见：
        ImageConsumer.setColorModel(java.awt.image.ColorModel)

      • setHints

        public void setHints​(int hints)
        过滤ImageConsumer界面的setHints方法中提供的信息。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setHints在接口 ImageConsumer
        参数
        hints - ImageConsumer用于处理像素的一组提示
        另请参见：
        ImageConsumer.setHints(int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
        过滤ImageConsumer接口的setPixels方法中提供的信息，该接口采用字节数组。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels阵列中的一行像素到下一行的距离
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
        对ImageConsumer接口的setPixels方法中提供的信息进行过滤，该接口采用整数数组。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels阵列中的一行像素到下一行的距离
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

      • imageComplete

        public void imageComplete​(int status)
        过滤ImageConsumer界面的imageComplete方法中提供的信息。

        注意：此方法意图由图像的ImageProducer调用其像素被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        imageComplete在接口 ImageConsumer
        参数
        status - 图像加载的状态
        另请参见：
        ImageConsumer.imageComplete(int)

      • resendTopDownLeftRight

        public void resendTopDownLeftRight​(ImageProducer ip)
        响应一个按TopDownLeftRight（TDLR）的请求顺序将像素数据重新发送从ImageConsumer 。 当ImageConsumer由此的实例馈送ImageFilter请求在TDLR顺序的数据的重发，所述FilteredImageSource调用此方法ImageFilter 。

        一个ImageFilter子类可能会覆盖此方法，具体取决于是否以及如何以TDLR顺序发送数据。 存在三种可能性：

        • 不要覆盖此方法。 这使得子类使用默认实现，即将请求转发到使用该过滤器的指定的ImageProducer作为请求ImageConsumer 。 如果滤波器可以确定如果上游生成器对象以TDLR顺序发送它们，则它将以TDLR顺序转发像素，则此行为是适当的。
        • 覆盖简单发送数据的方法。 如果过滤器可以处理请求本身，例如，如果生成的像素已保存在某种缓冲区中，则这是适当的。
        • 覆盖该方法不执行任何操作。 如果滤波器不能以TDLR顺序产生滤波数据，这是适当的。
        参数
        ip - 正在提供此过滤器实例的ImageProducer - 也是ImageProducer，如果需要，请求应转发到
        异常
        NullPointerException - 如果 ip为空
        另请参见：
        ImageProducer.requestTopDownLeftRightResend(java.awt.image.ImageConsumer)

      • clone

        public Object clone​()
        克隆这个对象。
        重写：
        clone在 Object
        结果
        这个实例的一个克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImageObserver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface ImageObserver

  • 所有已知实现类：
    AbstractButton ， AbstractColorChooserPanel ， Applet ， BasicArrowButton ， BasicComboBoxRenderer ， BasicComboBoxRenderer.UIResource ， BasicComboPopup ， BasicInternalFrameTitlePane ， BasicInternalFrameTitlePane.SystemMenuBar ， BasicSplitPaneDivider ， BasicToolBarUI.DragWindow ， Box ， Box.Filler ， Button ， Canvas ， CellRendererPane ， Checkbox ， Choice ， Component ， Container ， DefaultListCellRenderer ， DefaultListCellRenderer.UIResource ， DefaultTableCellRenderer ， DefaultTableCellRenderer.UIResource ， DefaultTreeCellEditor.DefaultTextField ， DefaultTreeCellEditor.EditorContainer ， DefaultTreeCellRenderer ， Dialog ， FileDialog ， Frame ， JApplet ， JButton ， JCheckBox ， JCheckBoxMenuItem ， JColorChooser ， JComboBox ， JComponent ， JDesktopPane ， JDialog ， JEditorPane ， JFileChooser ， JFormattedTextField ， JFrame ， JFXPanel ， JInternalFrame ， JInternalFrame.JDesktopIcon ， JLabel ， JLayer ， JLayeredPane ， JList ， JMenu ， JMenuBar ， JMenuItem ， JOptionPane ， JPanel ， JPasswordField JPasswordField ， JPopupMenu ， JPopupMenu.Separator ， JProgressBar ， JRadioButton ， JRadioButtonMenuItem ， JRootPane ， JScrollBar ， JScrollPane ， JScrollPane.ScrollBar ， JSeparator ， JSlider ， JSpinner ， JSpinner.DateEditor ， JSpinner.DefaultEditor ， JSpinner.ListEditor ， JSpinner.NumberEditor ， JSplitPane ， JTabbedPane ， JTable ， JTableHeader ， JTextArea ， JTextComponent ， JTextField ， JTextPane ， JToggleButton ， JToolBar ， JToolBar.Separator ， JToolTip ， JTree ， JViewport ， JWindow ， Label ， List ， MetalComboBoxButton ， MetalComboBoxUI.MetalComboPopup ， MetalFileChooserUI.FileRenderer ， MetalFileChooserUI.FilterComboBoxRenderer ， MetalInternalFrameTitlePane ， MetalScrollButton ， Panel ， Scrollbar ， ScrollPane ， TextArea ， TextComponent ， TextField ， Window

    public interface ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ABORT
      imageUpdate的infoflags参数中的此标志表示在生成完成之前异步跟踪的图像已中止。
      static int ALLBITS
      imageUpdate的infoflags参数中的此标志表示以前绘制的静态图像现在已完成，可以以其最终形式再次绘制。
      static int ERROR
      imageUpdate的infoflags参数中的此标志表示正在异步跟踪的图像遇到错误。
      static int FRAMEBITS
      imageUpdate的infoflags参数中的此标志表示先前绘制的多帧图像的另一个完整帧现在可以再次绘制。
      static int HEIGHT
      imageUpdate的infoflags参数中的此标志表示基本图像的高度现在可用，可以从imageUpdate回调方法的height参数中获取。
      static int PROPERTIES
      imageUpdate的infoflags参数中的此标志表示图像的属性现在可用。
      static int SOMEBITS
      imageUpdate的infoflags参数中的此标志表示绘制图像缩放变体所需的更多像素可用。
      static int WIDTH
      imageUpdate的infoflags参数中的此标志表示基本图像的宽度现在可用，可以从imageUpdate回调方法的width参数中获取。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean imageUpdate​(Image img, int infoflags, int x, int y, int width, int height)
      当先前使用异步接口请求的图像的信息变得可用时，将调用此方法。

    • 字段详细信息

      • WIDTH

        static final int WIDTH
        imageUpdate的infoflags参数中的此标志表示基本图像的宽度现在可用，可以从imageUpdate回调方法的width参数中获取。
        另请参见：
        Image.getWidth(java.awt.image.ImageObserver) ， imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

      • HEIGHT

        static final int HEIGHT
        imageUpdate的infoflags参数中的此标志表示基本图像的高度现在可用，可以从imageUpdate回调方法的height参数中获取。
        另请参见：
        Image.getHeight(java.awt.image.ImageObserver) ， imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

      • PROPERTIES

        static final int PROPERTIES
        imageUpdate的infoflags参数中的此标志表示图像的属性现在可用。
        另请参见：
        Image.getProperty(java.lang.String, java.awt.image.ImageObserver) ， imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

      • SOMEBITS

        static final int SOMEBITS
        imageUpdate的infoflags参数中的此标志表示绘制图像缩放变体所需的更多像素可用。 新像素的边界框可以从imageUpdate回调方法的x，y，width和height参数中获取。
        另请参见：
        Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver) ， imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

      • FRAMEBITS

        static final int FRAMEBITS
        imageUpdate的infoflags参数中的此标志表示先前绘制的多帧图像的另一个完整帧现在可以再次绘制。 应该忽略imageUpdate回调方法的x，y，width和height参数。
        另请参见：
        Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver) ， imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

      • ALLBITS

        static final int ALLBITS
        imageUpdate的infoflags参数中的此标志表示以前绘制的静态图像现在已完成，可以以其最终形式再次绘制。 应该忽略imageUpdate回调方法的x，y，width和height参数。
        另请参见：
        Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver) ， imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

      • ERROR

        static final int ERROR
        imageUpdate的infoflags参数中的此标志表示正在异步跟踪的图像遇到错误。 没有进一步的信息将可用，绘制图像将失败。 为方便起见，ABORT标志将同时显示，表示图像生产已中止。
        另请参见：
        imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

      • ABORT

        static final int ABORT
        imageUpdate的infoflags参数中的此标志表示在生成完成之前异步跟踪的图像已中止。 没有更多的信息将可用，没有进一步的操作来触发另一个图像制作序列。 如果此图像更新中未设置ERROR标志，则访问图像中的任何数据将重新开始生产，可能从一开始。
        另请参见：
        imageUpdate(java.awt.Image, int, int, int, int, int) ， Constant Field Values

    • 方法详细信息

      • imageUpdate

        boolean imageUpdate​(Image img,
                    int infoflags,
                    int x,
                    int y,
                    int width,
                    int height)
        当先前使用异步接口请求的图像的信息变得可用时，将调用此方法。 异步接口是方法调用，例如getWidth（ImageObserver）和drawImage（img，x，y，ImageObserver），它将ImageObserver对象作为参数。 这些方法将调用者注册为关于整体图像本身的信息（在getWidth（ImageObserver）的情况下）或关于图像的输出版本（在drawImage（img，x，y，[w， h，] ImageObserver）调用）。

        如果需要进一步更新，则此方法应返回true，如果已获取所需信息，则返回false。 正在跟踪的图像使用img参数传入。 组合各种常数以形成infoflags参数，该参数指示关于图像的什么信息现在可用。 x，y，width和height参数的解释取决于infoflags参数的内容。

        该infoflags参数应该是按位下列标志的OR： WIDTH ， HEIGHT ， PROPERTIES ， SOMEBITS ， FRAMEBITS ， ALLBITS ， ERROR ， ABORT 。

        参数
        img - 正在观察的图像。
        infoflags -按位下列标志的OR： WIDTH ， HEIGHT ， PROPERTIES ， SOMEBITS ， FRAMEBITS ， ALLBITS ， ERROR ， ABORT 。
        x - x坐标。
        y - y坐标。
        width - 宽度。
        height - 高度。
        结果
        false如果infoflags指示图像被完全加载; 否则为true 。
        另请参见：
        WIDTH ， HEIGHT ， PROPERTIES ， SOMEBITS ， FRAMEBITS ， ALLBITS ， ERROR ， ABORT ， Image.getWidth(java.awt.image.ImageObserver) ， Image.getHeight(java.awt.image.ImageObserver) ， Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImageProducer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface ImageProducer

  • 所有已知实现类：
    FilteredImageSource ， MemoryImageSource ， RenderableImageProducer

    public interface ImageProducer
    可以为图像生成图像数据的对象的界面。 每个图像包含一个ImageProducer，用于在需要时重建图像，例如，当图像的新尺寸缩放时，或当图像的宽度或高度被请求时。
    另请参见：
    ImageConsumer

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addConsumer​(ImageConsumer ic)
      注册一个 ImageConsumer与 ImageProducer所述的稍后重建期间用于访问图像数据 Image 。
      boolean isConsumer​(ImageConsumer ic)
      确定指定的 ImageConsumer对象当前是否已注册到此 ImageProducer作为其消费者之一。
      void removeConsumer​(ImageConsumer ic)
      从目前已注册接收图像数据的消费者列表中删除指定的 ImageConsumer对象。
      void requestTopDownLeftRightResend​(ImageConsumer ic)
      请求，代表的 ImageConsumer ，该 ImageProducer尝试重新发送图像数据的一个更多的时间在TOPDOWNLEFTRIGHT顺序，以便依赖于按顺序接收像素更高质量的变换算法可以用于产生图像的更好的输出的版本。
      void startProduction​(ImageConsumer ic)
      将指定的 ImageConsumer对象注册为消费者，并开始立即重建图像数据，然后将其传送给该消费者和可能已经向生产者注册的任何其他消费者。

    • 方法详细信息

      • addConsumer

        void addConsumer​(ImageConsumer ic)
        注册一个ImageConsumer与ImageProducer所述的稍后重建期间用于访问图像数据Image 。 ImageProducer可以自行决定立即使用ImageConsumer接口向客户发送图像数据，或者当通过调用startProduction方法触发下一个可用的图像重建时。
        参数
        ic - 指定的 ImageConsumer
        另请参见：
        startProduction(java.awt.image.ImageConsumer)

      • isConsumer

        boolean isConsumer​(ImageConsumer ic)
        确定指定的 ImageConsumer对象当前是否已注册到此 ImageProducer作为其消费者之一。
        参数
        ic - 指定的 ImageConsumer
        结果
        true如果指定的ImageConsumer注册了这个ImageProducer ; false否则。

      • removeConsumer

        void removeConsumer​(ImageConsumer ic)
        从目前注册接收图像数据的消费者列表中删除指定的ImageConsumer对象。 删除不是当前注册的消费者不被认为是错误的。 ImageProducer应尽快停止向消费者发送数据。
        参数
        ic - 指定的 ImageConsumer

      • startProduction

        void startProduction​(ImageConsumer ic)
        将指定的ImageConsumer对象注册为消费者，并开始立即重建图像数据，然后将其传送给该消费者和可能已经向生产者注册的任何其他消费者。 该方法与addConsumer方法的不同之处在于，尽可能快地触发图像数据的再现。
        参数
        ic - 指定的 ImageConsumer
        另请参见：
        addConsumer(java.awt.image.ImageConsumer)

      • requestTopDownLeftRightResend

        void requestTopDownLeftRightResend​(ImageConsumer ic)
        请求，代表的ImageConsumer ，该ImageProducer尝试重新发送图像数据的一个更多的时间在TOPDOWNLEFTRIGHT顺序，以便依赖于按顺序接收像素更高质量的变换算法可以用于产生图像的更好的输出的版本。 如果ImageProducer无法按照该顺序重新发送数据，则可免费忽略此调用。 如果可以重新发送数据，则ImageProducer应通过执行以下最小值ImageConsumer方法调用来进行响应：
           ic.setHints(TOPDOWNLEFTRIGHT | < otherhints >); ic.setPixels(...); // As many times as needed ic.imageComplete();
        参数
        ic - 指定的 ImageConsumer
        另请参见：
        ImageConsumer.setHints(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ImagingOpException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ImagingOpException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.awt.image.ImagingOpException
  • All Implemented Interfaces:
    Serializable

    public class ImagingOpException
extends RuntimeException
    所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ImagingOpException​(String s)
      构造具有指定消息的 ImagingOpException对象。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ImagingOpException

        public ImagingOpException​(String s)
        使用指定的消息构造一个 ImagingOpException对象。
        参数
        s - 抛出 ImagingOpException时生成的消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IndexColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class IndexColorModel

  • java.lang.Object
    • java.awt.image.ColorModel
      • java.awt.image.IndexColorModel
  • All Implemented Interfaces:
    Transparency

    public class IndexColorModel
extends ColorModel
    IndexColorModel类是一个ColorModel类，适用于由单个样本组成的像素值，该样本是默认sRGB颜色空间中固定色彩映射的索引。 颜色映射指定对应于每个索引的红色，绿色，蓝色和可选的alpha组件。 所有组件在色彩映射中表示为8位无符号积分值。 一些构造函数允许调用者通过指定哪些色彩映射条目有效并且通过BigInteger对象中设置的位来表示不可用的颜色来指定色彩映射中的“空洞”。 此颜色模型与X11 PseudoColor视觉相似。

    一些构造函数提供了指定色彩映射中每个像素的alpha分量的方法，而其他构造函数不提供这样的方法，或者在某些情况下提供一个标志来指示色彩映射数据是否包含alpha值。 如果没有向构造函数提供alpha，则会为每个条目假定使用不透明的alpha组件（alpha = 1.0）。 可以提供可选的透明像素值，其指示要完全透明的像素，而不管为该像素值提供或假设的任何α分量。 请注意， IndexColorModel对象的颜色映射中的颜色分量决不会与alpha分量预先乘以。

    The transparency of an IndexColorModel object is determined by examining the alpha components of the colors in the colormap and choosing the most specific value after considering the optional alpha values and any transparent index specified. The transparency value is Transparency.OPAQUE only if all valid colors in the colormap are opaque and there is no valid transparent pixel. If all valid colors in the colormap are either completely opaque (alpha = 1.0) or completely transparent (alpha = 0.0), which typically occurs when a valid transparent pixel is specified, the value is Transparency.BITMASK. Otherwise, the value is Transparency.TRANSLUCENT, indicating that some valid color has an alpha component that is neither completely transparent nor completely opaque (0.0 < alpha < 1.0).

    如果IndexColorModel对象的透明度值为Transparency.OPAQUE ，则hasAlpha和getNumComponents方法（均继承自ColorModel ）分别返回false和3。 对于任何其他透明度值， hasAlpha返回true，而getNumComponents返回4。

    The values used to index into the colormap are taken from the least significant n bits of pixel representations where n is based on the pixel size specified in the constructor. For pixel sizes smaller than 8 bits, n is rounded up to a power of two (3 becomes 4 and 5,6,7 become 8). For pixel sizes between 8 and 16 bits, n is equal to the pixel size. Pixel sizes larger than 16 bits are not supported by this class. Higher order bits beyond n are ignored in pixel representations. Index values greater than or equal to the map size, but less than 2n, are undefined and return 0 for all color and alpha components.

    对于使用transferType型的原始数组像素表示的transferType ，数组长度始终为1。 支持的传输类型为DataBuffer.TYPE_BYTE和DataBuffer.TYPE_USHORT 。 单个int像素表示对于此类的所有对象是有效的，因为总是可以在单个int中表示与该类一起使用的像素值。 因此，由于无效的像素值，使用此表示的方法不会抛出IllegalArgumentException 。

    这个类中的很多方法都是最终的。 原因是底层本机图形代码对这个类的布局和操作做出假设，这些假设反映在这里标记为final的方法的实现中。 您可以通过其他原因对此类进行子类化，但不能覆盖或修改这些方法的行为。

    另请参见：
    ColorModel ， ColorSpace ， DataBuffer

    • Field Summary

      • Fields inherited from class java.awt.image.ColorModel

        pixel_bits, transferType

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      IndexColorModel​(int bits, int size, byte[] r, byte[] g, byte[] b)
      从指定的红色，绿色和蓝色组件阵列构造一个 IndexColorModel 。
      IndexColorModel​(int bits, int size, byte[] r, byte[] g, byte[] b, byte[] a)
      从给定的红色，绿色，蓝色和alpha组件阵列构造一个 IndexColorModel 。
      IndexColorModel​(int bits, int size, byte[] r, byte[] g, byte[] b, int trans)
      从给定的红色，绿色和蓝色组件阵列构造一个 IndexColorModel 。
      IndexColorModel​(int bits, int size, byte[] cmap, int start, boolean hasalpha)
      从单个交错的红色，绿色，蓝色和可选的alpha组件阵列构造一个 IndexColorModel 。
      IndexColorModel​(int bits, int size, byte[] cmap, int start, boolean hasalpha, int trans)
      从单个交错的红色，绿色，蓝色和可选的Alpha组件阵列构造一个 IndexColorModel 。
      IndexColorModel​(int bits, int size, int[] cmap, int start, boolean hasalpha, int trans, int transferType)
      从int数组构造一个 IndexColorModel ，其中每个int由默认RGB颜色模型格式的红色，绿色，蓝色和可选alpha组件组成。
      IndexColorModel​(int bits, int size, int[] cmap, int start, int transferType, BigInteger validBits)
      从 int阵列构造 IndexColorModel ，其中每个 int由默认RGB颜色模型格式的红色，绿色，蓝色和Alpha组件组成。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      BufferedImage convertToIntDiscrete​(Raster raster, boolean forceARGB)
      返回一个新 BufferedImage TYPE_INT_ARGB或TYPE_INT_RGB的具有 Raster通过展开源的索引来计算的与像素数据 Raster使用此的颜色/ alpha分量数组 ColorModel 。
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
      WritableRaster createCompatibleWritableRaster​(int w, int h)
      创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。
      boolean equals​(Object obj)
      如果指定的测试 Object是一个实例 IndexColorModel ，以及它是否该 IndexColorModel
      void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保super.finalize()被调用，如Object.finalize()所述 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      int getAlpha​(int pixel)
      返回指定像素的alpha分量，从0到255。
      void getAlphas​(byte[] a)
      将Alpha透明组件数组复制到指定的数组中。
      int getBlue​(int pixel)
      返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。
      void getBlues​(byte[] b)
      将蓝色组件数组复制到指定的数组中。
      int[] getComponents​(int pixel, int[] components, int offset)
      返回此 ColorModel指定像素的非标准化颜色/ alpha分量 ColorModel 。
      int[] getComponents​(Object pixel, int[] components, int offset)
      返回 ColorModel指定像素的非归一化颜色/ alpha分量 ColorModel 。
      int[] getComponentSize​()
      返回每个颜色/ alpha分量的位数的数组。
      int getDataElement​(int[] components, int offset)
      在给定一个非标准化颜色/ alpha分量的数组的情况下，返回此 ColorModel以int表示的像素值。
      Object getDataElements​(int[] components, int offset, Object pixel)
      返回这个 ColorModel的一个像素的数据元素数组表示，给出一个非标准化颜色/ alpha分量的数组。
      Object getDataElements​(int rgb, Object pixel)
      返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。
      int getGreen​(int pixel)
      返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。
      void getGreens​(byte[] g)
      将绿色组件数组复制到指定的数组中。
      int getMapSize​()
      返回此 IndexColorModel颜色/ alpha组件数组的 IndexColorModel 。
      int getRed​(int pixel)
      返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。
      void getReds​(byte[] r)
      将红色组件数组复制到指定的数组中。
      int getRGB​(int pixel)
      以默认RGB颜色模型格式返回像素的颜色/ alpha分量。
      void getRGBs​(int[] rgb)
      将每个索引的数据从颜色和alpha组件数组转换为默认RGB ColorModel格式的int，并将生成的32位ARGB值复制到指定的数组中。
      int getTransparency​()
      返回透明度。
      int getTransparentPixel​()
      如果没有alpha值为0的像素，则返回此 IndexColorModel中的透明像素的索引或-1。
      BigInteger getValidPixels​()
      返回一个表示颜色映射中有效/无效像素的 BigInteger 。
      int hashCode​()
      返回IndexColorModel的哈希码。
      boolean isCompatibleRaster​(Raster raster)
      返回 true如果 raster与此兼容 ColorModel或者 false如果不是与此兼容 ColorModel 。
      boolean isCompatibleSampleModel​(SampleModel sm)
      检查指定的 SampleModel是否与此 ColorModel兼容。
      boolean isValid​()
      返回所有像素是否有效。
      boolean isValid​(int pixel)
      返回像素是否有效。
      String toString​()
      返回 ColorModel对象的内容的 String表示。

      • Methods inherited from class java.awt.image.ColorModel

        coerceData, getAlpha, getAlphaRaster, getBlue, getColorSpace, getComponentSize, getDataElement, getDataElements, getGreen, getNormalizedComponents, getNormalizedComponents, getNumColorComponents, getNumComponents, getPixelSize, getRed, getRGB, getRGBdefault, getTransferType, getUnnormalizedComponents, hasAlpha, isAlphaPremultiplied

      • Methods inherited from class java.lang.Object

        clone, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • IndexColorModel

        public IndexColorModel​(int bits,
                       int size,
                       byte[] r,
                       byte[] g,
                       byte[] b)
        从指定的红色，绿色和蓝色组件阵列构造一个IndexColorModel 。 由此颜色模型描述的像素都具有255的非标准化（1.0归一化）的α分量，这意味着它们是完全不透明的。 指定颜色分量的所有数组必须至少具有指定数量的条目。 ColorSpace是默认的sRGB空间。 由于此构造函数的任何参数中没有alpha信息，透明度值始终为Transparency.OPAQUE 。 传输类型是可以容纳单个像素的DataBuffer.TYPE_BYTE或DataBuffer.TYPE_USHORT中的最小值。
        参数
        bits - 每个像素占用的位数
        size - 颜色组件数组的大小
        r - 红色组件阵列
        g - 绿色组件阵列
        b - 蓝色组件阵列
        异常
        IllegalArgumentException - 如果 bits小于1或大于16
        IllegalArgumentException - 如果 size小于1

      • IndexColorModel

        public IndexColorModel​(int bits,
                       int size,
                       byte[] r,
                       byte[] g,
                       byte[] b,
                       int trans)
        从给定的红色，绿色和蓝色组件阵列构造一个IndexColorModel 。 由此颜色模型描述的像素都具有255的非标准化（1.0归一化）的alpha分量，这意味着它们是完全不透明的，除了指示的像素被制成透明。 指定颜色分量的所有数组必须至少具有指定数量的条目。 ColorSpace是默认的sRGB空间。 透明度值可能为Transparency.OPAQUE或Transparency.BITMASK具体取决于参数，如上述class description中所述。 传输类型是可以容纳单个像素的DataBuffer.TYPE_BYTE或DataBuffer.TYPE_USHORT中最小的。
        参数
        bits - 每个像素占用的位数
        size - 颜色组件数组的大小
        r - 红色组件阵列
        g - 绿色组件阵列
        b - 蓝色组件阵列
        trans - 透明像素的索引
        异常
        IllegalArgumentException - 如果 bits小于1或大于16
        IllegalArgumentException - 如果 size小于1

      • IndexColorModel

        public IndexColorModel​(int bits,
                       int size,
                       byte[] r,
                       byte[] g,
                       byte[] b,
                       byte[] a)
        从给定的红色，绿色，蓝色和alpha组件阵列构造一个IndexColorModel 。 指定组件的所有数组必须至少具有指定数量的条目。 ColorSpace是默认的sRGB空间。 透明度值可以是任何的Transparency.OPAQUE ， Transparency.BITMASK ，或Transparency.TRANSLUCENT取决于参数，如在指定class description上方。 传输类型是可以容纳单个像素的DataBuffer.TYPE_BYTE或DataBuffer.TYPE_USHORT中最小的。
        参数
        bits - 每个像素占用的位数
        size - 颜色组件数组的大小
        r - 红色组件阵列
        g - 绿色组件阵列
        b - 蓝色组件阵列
        a - alpha值组件数组
        异常
        IllegalArgumentException - 如果 bits小于1或大于16
        IllegalArgumentException - 如果 size小于1

      • IndexColorModel

        public IndexColorModel​(int bits,
                       int size,
                       byte[] cmap,
                       int start,
                       boolean hasalpha)
        从单个交错的红色，绿色，蓝色和可选的alpha组件阵列构造一个IndexColorModel 。 数组必须有足够的值来填充指定大小的所有需要的组件数组。 ColorSpace是默认的sRGB空间。 透明度值可以是任何的Transparency.OPAQUE ， Transparency.BITMASK ，或Transparency.TRANSLUCENT取决于参数，如在指定class description上方。 传输类型是可以容纳单个像素的DataBuffer.TYPE_BYTE或DataBuffer.TYPE_USHORT中的最小值。
        参数
        bits - 每个像素占用的位数
        size - 颜色组件数组的大小
        cmap - 颜色分量阵列
        start - 第一个颜色分量的起始偏移量
        hasalpha - 表示alpha值是否包含在 cmap数组中
        异常
        IllegalArgumentException - 如果 bits小于1或大于16
        IllegalArgumentException - 如果 size小于1

      • IndexColorModel

        public IndexColorModel​(int bits,
                       int size,
                       byte[] cmap,
                       int start,
                       boolean hasalpha,
                       int trans)
        从单个交错的红色，绿色，蓝色和可选的alpha组件阵列构造一个IndexColorModel 。 指定的透明索引表示完全透明的像素，无论为其指定了任何alpha值。 数组必须有足够的值来填充指定大小的所有需要的组件数组。 ColorSpace是默认的sRGB空间。 透明度值可以是任何的Transparency.OPAQUE ， Transparency.BITMASK ，或Transparency.TRANSLUCENT取决于参数，如在指定class description上方。 传输类型是可以容纳单个像素的DataBuffer.TYPE_BYTE或DataBuffer.TYPE_USHORT中最小的。
        参数
        bits - 每个像素占用的位数
        size - 颜色组件数组的大小
        cmap - 颜色分量阵列
        start - 第一个颜色分量的起始偏移量
        hasalpha - 表示alpha值是否包含在 cmap数组中
        trans - 完全透明像素的索引
        异常
        IllegalArgumentException - 如果 bits小于1或大于16
        IllegalArgumentException - 如果 size小于1

      • IndexColorModel

        public IndexColorModel​(int bits,
                       int size,
                       int[] cmap,
                       int start,
                       boolean hasalpha,
                       int trans,
                       int transferType)
        从int数组构造一个IndexColorModel ，其中每个int由默认RGB颜色模型格式的红色，绿色，蓝色和可选alpha组件组成。 指定的透明索引表示完全透明的像素，无论为其指定了任何alpha值。 数组必须有足够的值来填充指定大小的所有需要的组件数组。 ColorSpace是默认的sRGB空间。 透明度值可以是任何的Transparency.OPAQUE ， Transparency.BITMASK ，或Transparency.TRANSLUCENT取决于参数，如在指定class description上方。
        参数
        bits - 每个像素占用的位数
        size - 颜色组件数组的大小
        cmap - 颜色分量阵列
        start - 第一个颜色分量的起始偏移量
        hasalpha - 表示alpha值是否包含在 cmap数组中
        trans - 完全透明像素的索引
        transferType - 用于表示像素值的数组的数据类型。 数据类型必须是DataBuffer.TYPE_BYTE或DataBuffer.TYPE_USHORT 。
        异常
        IllegalArgumentException - 如果 bits小于1或大于16
        IllegalArgumentException - 如果 size小于1
        IllegalArgumentException - 如果 transferType不是 DataBuffer.TYPE_BYTE或 DataBuffer.TYPE_USHORT

      • IndexColorModel

        public IndexColorModel​(int bits,
                       int size,
                       int[] cmap,
                       int start,
                       int transferType,
                       BigInteger validBits)
        从int阵列构造IndexColorModel ，其中每个int由默认RGB颜色模型格式的红色，绿色，蓝色和Alpha组件组成。 数组必须有足够的值来填充指定大小的所有需要的组件数组。 ColorSpace是默认的sRGB空间。 透明度值可以是任何的Transparency.OPAQUE ， Transparency.BITMASK ，或Transparency.TRANSLUCENT取决于参数，如在指定class description上方。 转移类型必须是DataBuffer.TYPE_BYTE DataBuffer.TYPE_USHORT 。 BigInteger对象指定cmap数组中的有效/无效像素。 如果该索引处的BigInteger值被设置，则像素有效，如果该索引处的BigInteger位未设置，则该BigInteger无效。
        参数
        bits - 每个像素占用的位数
        size - 颜色组件数组的大小
        cmap - 颜色分量阵列
        start - 第一个颜色分量的起始偏移量
        transferType - 指定的数据类型
        validBits - a BigInteger对象。 如果在BigInteger中设置了一个位，该索引处的像素是有效的。 如果未设置位，该索引处的像素被认为是无效的。 如果为空，则所有像素均为有效。 只考虑从0到地图大小的位。
        异常
        IllegalArgumentException - 如果 bits小于1或大于16
        IllegalArgumentException - 如果 size小于1
        IllegalArgumentException - 如果 transferType不是 DataBuffer.TYPE_BYTE或 DataBuffer.TYPE_USHORT
        从以下版本开始：
        1.3

    • 方法详细信息

      • getTransparency

        public int getTransparency​()
        返回透明度。 返回OPAQUE，BITMASK或TRANSLUCENT
        Specified by:
        getTransparency在接口 Transparency
        重写：
        getTransparency在 ColorModel
        结果
        这个透明度这个 IndexColorModel
        另请参见：
        Transparency.OPAQUE ， Transparency.BITMASK ， Transparency.TRANSLUCENT

      • getComponentSize

        public int[] getComponentSize​()
        返回每个颜色/ alpha分量的位数的数组。 该阵列包含红色，绿色，蓝色的颜色分量，后面是alpha组件（如果存在）。
        重写：
        getComponentSize在 ColorModel
        结果
        一个包含这个 IndexColorModel的每个颜色和alpha分量的 IndexColorModel

      • getMapSize

        public final int getMapSize​()
        返回此 IndexColorModel颜色/ alpha组件数组的 IndexColorModel 。
        结果
        颜色和alpha组件数组的大小。

      • getTransparentPixel

        public final int getTransparentPixel​()
        如果没有Alpha值为0的像素，则返回此 IndexColorModel中的透明像素的索引或-1。如果透明像素在其中一个构造函数中由其索引显式指定，则该索引将是首选，否则，可能会返回恰好完全透明的任何像素的索引。
        结果
        这个 IndexColorModel对象中的透明像素的索引，如果没有这样的像素，则为-1

      • getReds

        public final void getReds​(byte[] r)
        将红色组件数组复制到指定的数组中。 仅写入由getMapSize指定的数组的初始条目。
        参数
        r - 复制红色组件数组元素的指定数组

      • getGreens

        public final void getGreens​(byte[] g)
        将绿色组件数组复制到指定的数组中。 仅写入由getMapSize指定的数组的初始条目。
        参数
        g - 复制绿色组件数组元素的指定数组

      • getBlues

        public final void getBlues​(byte[] b)
        将蓝色组件数组复制到指定的数组中。 仅写入由getMapSize指定的阵列的初始条目。
        参数
        b - 复制蓝色组件数组元素的指定数组

      • getAlphas

        public final void getAlphas​(byte[] a)
        将Alpha透明组件数组复制到指定的数组中。 仅写入由getMapSize指定的数组的初始条目。
        参数
        a - 复制alpha组件数组元素的指定数组

      • getRGBs

        public final void getRGBs​(int[] rgb)
        将每个索引的数据从颜色和alpha组件数组转换为默认RGB ColorModel格式的int，并将生成的32位ARGB值复制到指定的数组中。 只写入由getMapSize指定的数组的初始条目。
        参数
        rgb - 从该数组的颜色和alpha组件复制转换的ARGB值的指定数组。

      • getRed

        public final int getRed​(int pixel)
        返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。 像素值被指定为int。 仅使用上述class description中规定的像素值的低n位来计算返回值。 返回的值是非预先乘以的值。
        Specified by:
        getRed在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的红色分量的值

      • getGreen

        public final int getGreen​(int pixel)
        返回指定像素的绿色分量，在默认RGB ColorSpace sRGB中从0到255。 像素值被指定为int。 只有上述class description中指定的像素值的较低n位才能用于计算返回值。 返回的值是非预先乘以的值。
        Specified by:
        getGreen在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的绿色分量的值

      • getBlue

        public final int getBlue​(int pixel)
        返回指定像素的蓝色分量，在默认RGB ColorSpace（sRGB）中从0到255。 像素值被指定为int。 仅使用上述class description中规定的像素值的较低n位来计算返回值。 返回的值是非预先乘以的值。
        Specified by:
        getBlue在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的蓝色分量的值

      • getAlpha

        public final int getAlpha​(int pixel)
        返回指定像素的alpha分量，从0到255。像素值被指定为int。 仅使用上述class description中规定的像素值的低n位来计算返回值。
        Specified by:
        getAlpha在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的alpha分量的值

      • getRGB

        public final int getRGB​(int pixel)
        以默认RGB颜色模型格式返回像素的颜色/ alpha分量。 像素值被指定为int。 仅使用上述class description中规定的像素值的低n位来计算返回值。 返回的值为非预先乘法格式。
        重写：
        getRGB在 ColorModel
        参数
        pixel - 指定的像素
        结果
        指定像素的颜色和alpha分量
        另请参见：
        ColorModel.getRGBdefault()

      • getDataElements

        public Object getDataElements​(int rgb,
                              Object pixel)
        返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 如果像素变量为null ，则会分配一个新数组。 如果pixel不是null ，它必须是transferType类型的原始数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 返回像素数组。

        由于IndexColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。

        重写：
        getDataElements在 ColorModel
        参数
        rgb - 默认RGB颜色模型中的整数像素表示
        pixel - 指定的像素
        结果
        该 IndexColorModel指定像素的数组表示 IndexColorModel 。
        异常
        ClassCastException -如果 pixel不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 pixel不够大，不能保持这个 ColorModel的像素值
        UnsupportedOperationException - 如果 transferType无效
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • getComponents

        public int[] getComponents​(int pixel,
                           int[] components,
                           int offset)
        返回ColorModel指定像素的非标准化颜色/ alpha分量ColorModel 。 像素值被指定为int。 如果components数组为null ，则会分配一个包含offset + getNumComponents()元素的新数组。 将返回components数组，只有当hasAlpha返回true时，才会包含alpha组件。 即使数组由此方法分配，颜色/ alpha分量也存储在components阵列中，从offset开始。 一个ArrayIndexOutOfBoundsException如果抛出components数组不null ，是不是大到足以容纳所有开始在颜色和alpha分量offset 。
        重写：
        getComponents在 ColorModel
        参数
        pixel - 指定的像素
        components - 接收指定像素的颜色和alpha分量的数组
        offset - components数组的偏移量，用于开始存储颜色和alpha分量
        结果
        一个数组，包含从指定的偏移开始的指定像素的颜色和alpha分量。
        另请参见：
        ColorModel.hasAlpha() ， ColorModel.getNumComponents()

      • getComponents

        public int[] getComponents​(Object pixel,
                           int[] components,
                           int offset)
        返回ColorModel指定像素的非标准化颜色/ alpha分量ColorModel 。 像素值由作为对象引用传入的数据元素transferType的数组指定。 如果pixel不是类型的基本数组transferType ，一个ClassCastException被抛出。 一个ArrayIndexOutOfBoundsException如果抛出pixel不够大，不能保存这个像素值ColorModel 。 如果components数组为null ，则会分配一个包含offset + getNumComponents()元素的新数组。 将返回components数组，只有当hasAlpha返回true时，才会包含alpha分量。 即使数组由此方法分配，颜色/ alpha分量也存储在components阵列中，从offset开始。 一个ArrayIndexOutOfBoundsException如果也抛出components数组不null ，是不是大到足以容纳所有开始在颜色和alpha分量offset 。

        由于IndexColorModel可以被子类化，子类继承了该方法的实现，如果它们不覆盖它，那么如果它们使用不支持的transferType它们将抛出异常。

        重写：
        getComponents在 ColorModel
        参数
        pixel - 指定的像素
        components - 接收指定像素的颜色和alpha分量的数组
        offset - 要开始存储指定像素的颜色和alpha分量的 components数组中的索引
        结果
        一个数组，包含从指定的偏移开始的指定像素的颜色和alpha分量。
        异常
        ArrayIndexOutOfBoundsException - 如果 pixel不够大以容纳 ColorModel的像素值，或者如果 components阵列不是 null ，并且不够大，不能保持从 offset开始的所有颜色和alpha分量
        ClassCastException -如果 pixel不是类型的基本数组 transferType
        UnsupportedOperationException - 如果 transferType不是支持的传输类型之一
        另请参见：
        ColorModel.hasAlpha() ， ColorModel.getNumComponents()

      • getDataElement

        public int getDataElement​(int[] components,
                          int offset)
        在给定一个非标准化颜色/ alpha分量的数组的情况下，返回此ColorModel以int表示的像素值。 一个ArrayIndexOutOfBoundsException如果抛出components阵列是不是大到足以容纳所有的颜色和alpha分量的开始offset 。 由于ColorModel可以被子类化，子类继承了该方法的实现，如果它们不覆盖它，那么如果它们使用不受支持的transferType，它们将抛出异常。
        重写：
        getDataElement ColorModel
        参数
        components - 非规范化颜色和alpha组件的数组
        offset - 索引到 components ，开始检索颜色和alpha组件
        结果
        这个 int像素值在这个 ColorModel对应的指定组件。
        异常
        ArrayIndexOutOfBoundsException - 如果 components阵列不够大，不能容纳从 offset开始的所有颜色和alpha组件
        UnsupportedOperationException - 如果 transferType无效

      • getDataElements

        public Object getDataElements​(int[] components,
                              int offset,
                              Object pixel)
        在给定一个非标准化颜色/ alpha分量的数组的情况下，返回此ColorModel中的像素的数据元素数组表示。 然后可以将该数组传递给WritableRaster对象的setDataElements方法。 一个ArrayIndexOutOfBoundsException如果抛出components阵列是不是大到足以容纳所有的颜色和alpha分量的开始offset 。 如果像素变量为null ，则会分配一个新数组。 如果pixel不是null ，它必须是transferType类型的原始数组; 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果pixel不是特别大，不能保存此像素值抛出ColorModel 。

        由于IndexColorModel可以被子类化，子类继承了此方法的实现，如果它们不覆盖它，那么如果使用不支持的transferType它们将抛出异常

        重写：
        getDataElements在 ColorModel
        参数
        components - 非规范化颜色和alpha组件的数组
        offset - 索引到 components ，开始检索颜色和alpha组件
        pixel - Object表示颜色和alpha组件的数组
        结果
        一个 Object代表一个颜色和alpha组件的数组。
        异常
        ClassCastException -如果 pixel不是类型的基本数组 transferType
        ArrayIndexOutOfBoundsException - 如果 pixel不够大以容纳 ColorModel的像素值，或者 components阵列不够大，不能容纳从 offset开始的所有颜色和alpha分量
        UnsupportedOperationException - 如果 transferType不是支持的传输类型之一
        另请参见：
        WritableRaster.setDataElements(int, int, java.lang.Object) ， SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

      • createCompatibleWritableRaster

        public WritableRaster createCompatibleWritableRaster​(int w,
                                                     int h)
        创建WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容ColorModel 。 此方法仅适用于每像素16位或更少位的色彩模型。

        由于IndexColorModel可以被子类化，所以支持每像素大于16位的任何子类必须覆盖此方法。

        重写：
        createCompatibleWritableRaster在 ColorModel
        参数
        w - 要应用于新的 WritableRaster的宽度
        h - 适用于新的 WritableRaster的高度
        结果
        一个具有指定宽度和高度的 WritableRaster对象。
        异常
        UnsupportedOperationException - 如果像素中的位数大于16
        另请参见：
        WritableRaster ， SampleModel

      • isCompatibleRaster

        public boolean isCompatibleRaster​(Raster raster)
        返回 true如果 raster与此兼容 ColorModel或者 false如果不是与此兼容 ColorModel 。
        重写：
        isCompatibleRaster在 ColorModel
        参数
        raster - Raster对象测试兼容性
        结果
        true如果raster是兼容这个ColorModel ; false否则。

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
        重写：
        createCompatibleSampleModel在 ColorModel
        参数
        w - 适用于新的 SampleModel的宽度
        h - 适用于新的 SampleModel的高度
        结果
        一个 SampleModel具有指定宽度和高度的对象。
        异常
        IllegalArgumentException - 如果 w或 h不大于0
        另请参见：
        SampleModel

      • isCompatibleSampleModel

        public boolean isCompatibleSampleModel​(SampleModel sm)
        检查指定的SampleModel是否与此ColorModel兼容。 如果sm是null ，此方法返回false 。
        重写：
        isCompatibleSampleModel在 ColorModel
        参数
        sm - 指定的 SampleModel或 null
        结果
        true如果指定的SampleModel与此兼容ColorModel ; 否则为false 。
        另请参见：
        SampleModel

      • convertToIntDiscrete

        public BufferedImage convertToIntDiscrete​(Raster raster,
                                          boolean forceARGB)
        返回一个新BufferedImage TYPE_INT_ARGB或TYPE_INT_RGB的具有Raster通过展开源的索引来计算的与像素数据Raster使用此的颜色/ alpha分量数组ColorModel 。 每个索引值的源只有较低的n位Raster ，在指定的class description以上，用于计算返回的图像中的颜色/α值。 如果forceARGB为true ，则返回TYPE_INT_ARGB图像，无论此ColorModel是否具有Alpha组件数组或透明像素。
        参数
        raster - 指定的 Raster
        forceARGB - 如果是true ，返回的BufferedImage是TYPE_INT_ARGB; 否则为TYPE_INT_RGB
        结果
        一个 BufferedImage具有指定创建 Raster
        异常
        IllegalArgumentException - 如果栅格参数与此IndexColorModel不兼容

      • isValid

        public boolean isValid​(int pixel)
        返回像素是否有效。
        参数
        pixel - 指定的像素值
        结果
        true如果pixel有效; 否则为false 。
        从以下版本开始：
        1.3

      • isValid

        public boolean isValid​()
        返回所有像素是否有效。
        结果
        true如果所有像素都有效; 否则为false 。
        从以下版本开始：
        1.3

      • getValidPixels

        public BigInteger getValidPixels​()
        返回一个BigInteger ，表示BigInteger中的有效/无效像素。 如果该索引处的BigInteger值被设置，则该位有效，如果该索引处的BigInteger值未设置，则该BigInteger无效。 在BigInteger中查询的唯一有效范围是0和地图大小之间。
        结果
        一个表示有效/无效像素的 BigInteger 。
        从以下版本开始：
        1.3

      • finalize

        @Deprecated(since="9")
public void finalize​()
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        一旦这个 ColorModel不再被引用， ColorModel与这个 ColorModel相关联的系统资源。
        重写：
        finalize在 ColorModel
        另请参见：
        WeakReference ， PhantomReference

      • toString

        public String toString​()
        返回此 ColorModel对象的内容的 String表示。
        重写：
        toString在 ColorModel
        结果
        一个 String表示此内容 ColorModel对象。

      • equals

        public boolean equals​(Object obj)
        如果指定的测试 Object是一个实例 IndexColorModel ，以及它是否该 IndexColorModel
        重写：
        equals在 ColorModel
        参数
        obj - Object测试相等
        结果
        true如果指定的Object等于这个IndexColorModel ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回IndexColorModel的哈希码。
        重写：
        hashCode在 ColorModel
        结果
        IndexColorModel的哈希码
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.image (Java SE 9 & JDK 9 )

java.awt.image

Interfaces

  • BufferedImageOp
  • ImageConsumer
  • ImageObserver
  • ImageProducer
  • MultiResolutionImage
  • RasterOp
  • RenderedImage
  • TileObserver
  • WritableRenderedImage

Classes

  • AbstractMultiResolutionImage
  • AffineTransformOp
  • AreaAveragingScaleFilter
  • BandCombineOp
  • BandedSampleModel
  • BaseMultiResolutionImage
  • BufferedImage
  • BufferedImageFilter
  • BufferStrategy
  • ByteLookupTable
  • ColorConvertOp
  • ColorModel
  • ComponentColorModel
  • ComponentSampleModel
  • ConvolveOp
  • CropImageFilter
  • DataBuffer
  • DataBufferByte
  • DataBufferDouble
  • DataBufferFloat
  • DataBufferInt
  • DataBufferShort
  • DataBufferUShort
  • DirectColorModel
  • FilteredImageSource
  • ImageFilter
  • IndexColorModel
  • Kernel
  • LookupOp
  • LookupTable
  • MemoryImageSource
  • MultiPixelPackedSampleModel
  • PackedColorModel
  • PixelGrabber
  • PixelInterleavedSampleModel
  • Raster
  • ReplicateScaleFilter
  • RescaleOp
  • RGBImageFilter
  • SampleModel
  • ShortLookupTable
  • SinglePixelPackedSampleModel
  • VolatileImage
  • WritableRaster

Exceptions

  • ImagingOpException
  • RasterFormatException


java.awt.image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.image

提供创建和修改图像的类。 使用涉及图像生成器，可选图像过滤器和图像消费者的流式框架来处理图像。 该框架使得可以在获取和生成图像的同时逐渐呈现图像。 此外，该框架允许应用程序丢弃图像使用的存储并随时重新生成。 该软件包提供了许多图像生成器，消费者和过滤器，您可以根据图像处理需要进行配置。
从以下版本开始：
1.0
  • 接口摘要
    接口 描述
    BufferedImageOp
    该界面描述了对 BufferedImage对象执行的单输入/单输出操作。
    ImageConsumer
    通过ImageProducer界面表示对图像数据感兴趣的对象的界面。
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
    ImageProducer
    可以为图像生成图像数据的对象的界面。
    MultiResolutionImage
    该接口被设计为一些可选的附加API，由一些Image的实现支持，允许它们为各种渲染分辨率提供备用图像。
    RasterOp
    该界面介绍了对栅格对象执行的单输入/单输出操作。
    RenderedImage
    RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。
    TileObserver
    一个对象的界面，希望在WritableRenderedImage的图块被一些作者通过调用getWritableTile以及当通过最后一次调用releaseWritableTile变得不可修改时被通知。
    WritableRenderedImage
    WritableRenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口，可以修改和/或写入。
  • 类摘要
    Class 描述
    AbstractMultiResolutionImage
    该类为要实现 MultiResolutionImage接口的类提供了几个 Image方法的默认实现。
    AffineTransformOp
    该类使用仿射变换来执行从源图像中的2D坐标或目标图像中的 Raster到2D坐标的线性映射或 Raster 。
    AreaAveragingScaleFilter
    一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。
    BandCombineOp
    该类使用指定的矩阵在 Raster中执行频带的任意线性组合。
    BandedSampleModel
    该类表示以频带交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
    BaseMultiResolutionImage
    这个类是一个基于数组的 AbstractMultiResolutionImage类的实现。
    BufferedImage
    BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
    BufferedImageFilter
    所述BufferedImageFilter类的子类的ImageFilter是提供一种使用单一源/单一目标图像操作符（的简单方法BufferedImageOp ）以过滤BufferedImage在图像生产者/消费者/观察员范例。
    BufferStrategy
    BufferStrategy类表示在特定的 Canvas或 Window上组织复杂内存的机制。
    ByteLookupTable
    这个类定义了一个查找表对象。
    ColorConvertOp
    该类对源图像中的数据执行逐像素颜色转换。
    ColorModel
    ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和Alpha组件的方法。
    ComponentColorModel
    一个 ColorModel类，用于将颜色和alpha信息表示为单独样本的像素值，并将每个样本存储在单独的数据元素中。
    ComponentSampleModel
    该类表示存储的图像数据，使得像素的每个样本占据DataBuffer的一个数据元素。
    ConvolveOp
    该类实现从源到目的地的卷积。
    CropImageFilter
    用于裁剪图像的ImageFilter类。
    DataBuffer
    此类存在用于包装一个或多个数据数组。
    DataBufferByte
    该类扩展了 DataBuffer并将数据内部存储为字节。
    DataBufferDouble
    该类扩展了 DataBuffer并以 double形式存储数据。
    DataBufferFloat
    该类扩展了 DataBuffer并以 float形式存储数据。
    DataBufferInt
    该类扩展了 DataBuffer并将数据内部存储为整数。
    DataBufferShort
    此类扩展 DataBuffer并将数据内部存储为短裤。
    DataBufferUShort
    此类扩展为 DataBuffer并将数据内部存储为 DataBuffer 。
    DirectColorModel
    DirectColorModel类是一个 ColorModel类，适用于将RGB颜色和alpha信息表示为单独样本的像素值，并将单个像素的所有样本包装为单个int，short或byte数量。
    FilteredImageSource
    这个类是ImageProducer接口的一个实现，它接收一个现有的图像和一个过滤器对象，并使用它们来生成原始图像的新过滤版本的图像数据。
    ImageFilter
    此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。
    IndexColorModel
    IndexColorModel类是一个 ColorModel类，适用于由单个样本组成的像素值，该样本是默认sRGB颜色空间中固定色彩映射的索引。
    Kernel
    Kernel类定义了一个矩阵，该矩阵描述了指定像素及其周围像素如何影响对滤波操作的输出图像中像素的位置计算的值。
    LookupOp
    该类实现从源到目标的查找操作。
    LookupTable
    这个抽象类定义了一个查找表对象。
    MemoryImageSource
    该类是ImageProducer接口的一个实现，它使用一个数组为图像生成像素值。
    MultiPixelPackedSampleModel
    MultiPixelPackedSampleModel类表示单带图像，可以将多个单样本像素打包到一个数据元素中。
    PackedColorModel
    PackedColorModel类是一个抽象的ColorModel类，它与像素值一起使用，它们将颜色和alpha信息表示为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。
    PixelGrabber
    PixelGrabber类实现了一个ImageConsumer，它可以附加到Image或ImageProducer对象，以检索该图像中的像素的子集。
    PixelInterleavedSampleModel
    该类表示以像素交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
    Raster
    表示矩形像素阵列的类。
    ReplicateScaleFilter
    一个ImageFilter类，用于使用最简单的算法缩放图像。
    RescaleOp
    该类通过将每个像素的采样值乘以比例因子然后添加偏移来执行源图像中的数据的逐像素重新缩放。
    RGBImageFilter
    该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。
    SampleModel
    这个抽象类定义了一个用于提取图像中像素样本的接口。
    ShortLookupTable
    这个类定义了一个查找表对象。
    SinglePixelPackedSampleModel
    该类表示打包的像素数据，使得构成单个像素的N个采样被存储在单个数据阵列元素中，并且每个数据数据阵列元素仅保存一个像素的采样。
    VolatileImage
    VolatileImage是由于超出应用程序控制的情况（例如由操作系统或其他应用程序引起的情况），可能随时丢失其内容的映像。
    WritableRaster
    该类扩展了Raster，以提供像素写入功能。
  • 异常摘要
    异常 描述
    ImagingOpException
    所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。
    RasterFormatException
    如果RasterFormatException中有无效的布局信息，则会抛出RasterFormatException 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.image Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.image

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.image.AffineTransformOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.BandCombineOp (implements java.awt.image.RasterOp)
    • java.awt.image.BufferStrategy
    • java.awt.image.ColorConvertOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.ColorModel (implements java.awt.Transparency)
      • java.awt.image.ComponentColorModel
      • java.awt.image.IndexColorModel
      • java.awt.image.PackedColorModel
        • java.awt.image.DirectColorModel
    • java.awt.image.ConvolveOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferByte
      • java.awt.image.DataBufferDouble
      • java.awt.image.DataBufferFloat
      • java.awt.image.DataBufferInt
      • java.awt.image.DataBufferShort
      • java.awt.image.DataBufferUShort
    • java.awt.image.FilteredImageSource (implements java.awt.image.ImageProducer)
    • java.awt.Image
      • java.awt.image.AbstractMultiResolutionImage (implements java.awt.image.MultiResolutionImage)
        • java.awt.image.BaseMultiResolutionImage
      • java.awt.image.BufferedImage (implements java.awt.Transparency, java.awt.image.WritableRenderedImage)
      • java.awt.image.VolatileImage (implements java.awt.Transparency)
    • java.awt.image.ImageFilter (implements java.lang.Cloneable, java.awt.image.ImageConsumer)
      • java.awt.image.BufferedImageFilter (implements java.lang.Cloneable)
      • java.awt.image.CropImageFilter
      • java.awt.image.ReplicateScaleFilter
        • java.awt.image.AreaAveragingScaleFilter
      • java.awt.image.RGBImageFilter
    • java.awt.image.Kernel (implements java.lang.Cloneable)
    • java.awt.image.LookupOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.LookupTable
      • java.awt.image.ByteLookupTable
      • java.awt.image.ShortLookupTable
    • java.awt.image.MemoryImageSource (implements java.awt.image.ImageProducer)
    • java.awt.image.PixelGrabber (implements java.awt.image.ImageConsumer)
    • java.awt.image.Raster
      • java.awt.image.WritableRaster
    • java.awt.image.RescaleOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
        • java.awt.image.BandedSampleModel
        • java.awt.image.PixelInterleavedSampleModel
      • java.awt.image.MultiPixelPackedSampleModel
      • java.awt.image.SinglePixelPackedSampleModel
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.awt.image.ImagingOpException
          • java.awt.image.RasterFormatException

Interface Hierarchy

  • java.awt.image.BufferedImageOp
  • java.awt.image.ImageConsumer
  • java.awt.image.ImageObserver
  • java.awt.image.ImageProducer
  • java.awt.image.MultiResolutionImage
  • java.awt.image.RasterOp
  • java.awt.image.RenderedImage
    • java.awt.image.WritableRenderedImage
  • java.awt.image.TileObserver
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Kernel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class Kernel

  • java.lang.Object
    • java.awt.image.Kernel
  • All Implemented Interfaces:
    Cloneable

    public class Kernel
extends Object
implements Cloneable
    Kernel类定义了一个矩阵，描述指定像素及其周围像素如何影响对滤波操作的输出图像中像素的位置计算的值。 X原点和Y原点表示对应于正在计算输出值的像素位置的核心矩阵元素。
    另请参见：
    ConvolveOp

    • 构造方法摘要

      构造方法
      Constructor 描述
      Kernel​(int width, int height, float[] data)
      从浮动数组构造一个 Kernel对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      克隆这个对象。
      int getHeight​()
      返回此 Kernel的高度。
      float[] getKernelData​(float[] data)
      以行主顺序返回内核数据。
      int getWidth​()
      返回此 Kernel的宽度。
      int getXOrigin​()
      返回此 Kernel的X原点。
      int getYOrigin​()
      返回此 Kernel的Y原点。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Kernel

        public Kernel​(int width,
              int height,
              float[] data)
        从浮动数组构造一个Kernel对象。 data阵列的第width * height元素被复制。 如果data数组的长度小于width * height，则抛出IllegalArgumentException 。 X原点为（width-1）/ 2，Y原点为（height-1）/ 2。
        参数
        width - 内核的宽度
        height - 内核的高度
        data - 内核数据行主排序
        异常
        IllegalArgumentException -如果长度 data小于的产物 width和 height

    • 方法详细信息

      • getXOrigin

        public final int getXOrigin​()
        返回此 Kernel的X原点。
        结果
        X起源。

      • getYOrigin

        public final int getYOrigin​()
        返回此 Kernel的Y原点。
        结果
        Y原点。

      • getWidth

        public final int getWidth​()
        返回此 Kernel的宽度。
        结果
        该宽度为 Kernel 。

      • getHeight

        public final int getHeight​()
        返回此 Kernel的高度。
        结果
        这个 Kernel的高度。

      • getKernelData

        public final float[] getKernelData​(float[] data)
        以行主顺序返回内核数据。 将返回data数组。 如果data为null ，则会分配一个新数组。
        参数
        data - 如果非空，则包含返回的内核数据
        结果
        data数组包含行主序列中的内核数据，或者如果 data是 null ，则新分配的数组包含以主排序的内核数据
        异常
        IllegalArgumentException - 如果 data小于这个 Kernel的大小

      • clone

        public Object clone​()
        克隆这个对象。
        重写：
        clone在 Object
        结果
        这个对象的克隆。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LookupOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class LookupOp

  • java.lang.Object
    • java.awt.image.LookupOp
  • All Implemented Interfaces:
    BufferedImageOp ， RasterOp

    public class LookupOp
extends Object
implements BufferedImageOp, RasterOp
    该类实现从源到目标的查找操作。 LookupTable对象可能包含单个数组或多个数组，但需遵守以下限制。

    对于光栅，查找操作在频带上。 查找阵列的数量可以是一个，在这种情况下，相同的阵列应用于所有频带，或者它必须等于源光栅频带的数量。

    对于BufferedImages，查找操作的颜色和alpha组件。 查找阵列的数量可以是一个，在这种情况下，相同的数组应用于所有颜色（但不是alpha）组件。 否则，查找数组的数量可以等于源颜色分量的数量，在这种情况下，不会执行alpha分量的查找（如果存在）。 如果这两种情况都不适用，查找数组的数量必须等于源颜色分量加上alpha分量的数量，在这种情况下，对所有颜色和α分量执行查找。 这允许多频带BufferedImages的非均匀重新缩放。

    具有预乘法α数据的BufferedImage源以与非预乘图像相同的方式被处理以用于查找。 也就是说，在BufferedImage源的原始数据上，每个频段都进行查找，而不考虑数据是否被预乘。 如果目标ColorModel需要颜色转换，则此步骤将考虑源和目的地的预乘法状态。

    不能使用IndexColorModel的图像。

    如果在构造函数中指定了RenderingHints对象，则在需要颜色转换时，可以使用颜色渲染提示和抖动提示。

    该类允许源与目标相同。

    另请参见：
    LookupTable ， RenderingHints.KEY_COLOR_RENDERING ， RenderingHints.KEY_DITHERING

    • 构造方法摘要

      构造方法
      Constructor 描述
      LookupOp​(LookupTable lookup, RenderingHints hints)
      给出一个 LookupOp对象，给出了查找表和一个 RenderingHints对象，可能是 null 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BufferedImage createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      WritableRaster createCompatibleDestRaster​(Raster src)
      创建一个零目的地 Raster具有正确的大小和数量的频带，给定这个来源。
      BufferedImage filter​(BufferedImage src, BufferedImage dst)
      对 BufferedImage执行查找操作。
      WritableRaster filter​(Raster src, WritableRaster dst)
      对 Raster执行查找操作。
      Rectangle2D getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      RenderingHints getRenderingHints​()
      返回此操作的渲染提示。
      LookupTable getTable​()
      返回 LookupTable 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LookupOp

        public LookupOp​(LookupTable lookup,
                RenderingHints hints)
        给定一个 LookupOp对象，给出了查找表和一个 RenderingHints对象，可能是 null 。
        参数
        lookup - 指定的 LookupTable
        hints - 指定的 RenderingHints或 null

    • 方法详细信息

      • getTable

        public final LookupTable getTable​()
        返回 LookupTable 。
        结果
        这 LookupTable的 LookupOp 。

      • filter

        public final BufferedImage filter​(BufferedImage src,
                                  BufferedImage dst)
        对BufferedImage执行查找操作。 如果源图像中的颜色模型与目标图像中的颜色模型不同，则将在目标中转换像素。 如果目标图像是null ，一个BufferedImage将与合适的被创建ColorModel 。 一个IllegalArgumentException如果阵列中的数量可能会抛出LookupTable不符合上述类注释上述的限制，或者源图像有一个IndexColorModel 。
        Specified by:
        filter在接口 BufferedImageOp
        参数
        src - 要过滤的 BufferedImage
        dst - 其中存储过滤器操作的结果的 BufferedImage
        结果
        过滤后的 BufferedImage 。
        异常
        IllegalArgumentException - 如果 LookupTable中的数组数不符合类注释中描述的限制，或源图像是否有 IndexColorModel 。

      • filter

        public final WritableRaster filter​(Raster src,
                                   WritableRaster dst)
        对Raster执行查找操作。 如果目的地Raster为null ，则会创建一个新的Raster 。 该IllegalArgumentException可能，如果源抛出Raster和目标Raster不具有相同的band数，或者如果阵列中的数LookupTable不符合上述类注释中规定的限制。
        Specified by:
        filter在接口 RasterOp
        参数
        src - 来源 Raster进行过滤
        dst - 目的地 WritableRaster为过滤的 src
        结果
        过滤后的 WritableRaster 。
        异常
        IllegalArgumentException - 如果源和目标光栅不具有相同数量的带，或 LookupTable中的阵列数不符合类注释中描述的限制。

      • getBounds2D

        public final Rectangle2D getBounds2D​(BufferedImage src)
        返回已过滤的目标图像的边界框。 由于这不是一个几何操作，边框不会改变。
        Specified by:
        getBounds2D在接口 BufferedImageOp
        参数
        src - 要过滤的 BufferedImage
        结果
        过滤的定义图像的边界。

      • getBounds2D

        public final Rectangle2D getBounds2D​(Raster src)
        返回已筛选的目标栅格的边框。 由于这不是一个几何操作，边框不会改变。
        Specified by:
        getBounds2D在接口 RasterOp
        参数
        src - 要过滤的 Raster
        结果
        过滤定义的界限 Raster 。

      • createCompatibleDestImage

        public BufferedImage createCompatibleDestImage​(BufferedImage src,
                                               ColorModel destCM)
        创建具有正确大小和频带数的归零目标图像。 如果destCM为null ，则将使用适当的ColorModel 。
        Specified by:
        createCompatibleDestImage在接口 BufferedImageOp
        参数
        src - 过滤器操作的源图像。
        destCM - 目的地的 ColorModel ，可以是 null 。
        结果
        被过滤的目的地 BufferedImage 。

      • createCompatibleDestRaster

        public WritableRaster createCompatibleDestRaster​(Raster src)
        创建一个归零目的地 Raster具有正确的大小和数量的频带，给定此源。
        Specified by:
        createCompatibleDestRaster在接口 RasterOp
        参数
        src - 要转化的 Raster
        结果
        零目的地 Raster 。

      • getPoint2D

        public final Point2D getPoint2D​(Point2D srcPt,
                                Point2D dstPt)
        返回源中给定点的目标点的位置。 如果dstPt不是null ，它将用于保存返回值。 由于这不是几何操作，因此srcPt将等于dstPt 。
        Specified by:
        getPoint2D在接口 BufferedImageOp
        Specified by:
        getPoint2D在接口 RasterOp
        参数
        srcPt - 代表源图像中的一个点的 Point2D
        dstPt - 代表目的地的位置的 Point2D
        结果
        目标中的 Point2D对应于源中的指定点。

      • getRenderingHints

        public final RenderingHints getRenderingHints​()
        返回此操作的渲染提示。
        Specified by:
        getRenderingHints在接口 BufferedImageOp
        Specified by:
        getRenderingHints在接口 RasterOp
        结果
        与此操作相关联的 RenderingHints对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LookupTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class LookupTable

  • java.lang.Object
    • java.awt.image.LookupTable
  • 已知直接子类：
    ByteLookupTable ， ShortLookupTable

    public abstract class LookupTable
extends Object
    这个抽象类定义了一个查找表对象。 ByteLookupTable和ShortLookupTable是分别包含字节和短数据的子类。 查找表包含用于图像的一个或多个频带（或组件）的数据阵列（例如，用于R，G和B的单独阵列），并且它包含将在索引到阵列。 这允许为受限输入提供小于本机数据大小的数组。 如果查找表中只有一个数组，它将被应用于所有频带。 所有阵列的大小必须相同。
    另请参见：
    ByteLookupTable ， ShortLookupTable ， LookupOp

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected LookupTable​(int offset, int numComponents)
      从组件数量和查找表中的偏移量构造一个新的LookupTable。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      int getNumComponents​()
      返回查找表中的组件数。
      int getOffset​()
      返回偏移量。
      abstract int[] lookupPixel​(int[] src, int[] dest)
      返回一个像素的 int组件数组。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LookupTable

        protected LookupTable​(int offset,
                      int numComponents)
        从组件数量和查找表中的偏移量构造一个新的LookupTable。
        参数
        offset - 在将索引到数据阵列之前从输入值中减去的偏移量为 LookupTable
        numComponents - 此 LookupTable的数据数组 LookupTable
        异常
        IllegalArgumentException - 如果 offset小于0或如果 numComponents小于1

    • 方法详细信息

      • getNumComponents

        public int getNumComponents​()
        返回查找表中的组件数。
        结果
        这个 LookupTable的组件数量。

      • getOffset

        public int getOffset​()
        返回偏移量。
        结果
        这个 LookupTable的偏移量。

      • lookupPixel

        public abstract int[] lookupPixel​(int[] src,
                                  int[] dest)
        返回一个像素的int组件数组。 dest数组包含查找的结果并返回。 如果dest为null ，则会分配一个新数组。 源和目的地可以相等。
        参数
        src - 一个像素的组件的源数组
        dest - 一个像素的组件的目标数组，用这个 LookupTable翻译
        结果
        an int array of components for one pixel.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemoryImageSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class MemoryImageSource

  • java.lang.Object
    • java.awt.image.MemoryImageSource
  • All Implemented Interfaces:
    ImageProducer

    public class MemoryImageSource
extends Object
implements ImageProducer
    该类是ImageProducer接口的一个实现，它使用一个数组为图像生成像素值。 这是一个例子，它计算出一个100x100的图像，表示沿着X轴从黑色到蓝色的渐变，沿着Y轴从黑色渐变成红色：
       int w = 100; int h = 100; int pix[] = new int[w * h]; int index = 0; for (int y = 0; y < h; y++) { int red = (y * 255) / (h - 1); for (int x = 0; x < w; x++) { int blue = (x * 255) / (w - 1); pix[index++] = (255 << 24) | (red << 16) | blue; } } Image img = createImage(new MemoryImageSource(w, h, pix, 0, w));
    MemoryImageSource还能够管理随时间变化的存储器映像，以允许动画或自定义渲染。 下面是一个示例，显示如何设置数据中的动画源和信号变化（由Gart Dickie的MemoryAnimationSourceDemo改编）：
       int pixels[]; MemoryImageSource source; public void init() { int width = 50; int height = 50; int size = width * height; pixels = new int[size]; int value = getBackground().getRGB(); for (int i = 0; i < size; i++) { pixels[i] = value; } source = new MemoryImageSource(width, height, pixels, 0, width); source.setAnimated(true); image = createImage(source); } public void run() { Thread me = Thread.currentThread( ); me.setPriority(Thread.MIN_PRIORITY); while (true) { try { Thread.sleep(10); } catch( InterruptedException e ) { return; } // Modify the values in the pixels array at (x, y, w, h) // Send the new data to the interested ImageConsumers source.newPixels(x, y, w, h); } }
    另请参见：
    ImageProducer

    • 构造方法摘要

      构造方法
      Constructor 描述
      MemoryImageSource​(int w, int h, int[] pix, int off, int scan)
      构造一个ImageProducer对象，它使用默认RGB ColorModel中的整数数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, int[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，它使用默认RGB ColorModel中的整数数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, byte[] pix, int off, int scan)
      构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, int[] pix, int off, int scan)
      构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addConsumer​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
      boolean isConsumer​(ImageConsumer ic)
      确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。
      void newPixels​()
      向目前对此图像的数据感兴趣的任何ImageConsumers发送一个全新的像素缓冲区，并通知他们动画帧完成。
      void newPixels​(byte[] newpix, ColorModel newmodel, int offset, int scansize)
      更改新的字节数组来保存此图像的像素。
      void newPixels​(int[] newpix, ColorModel newmodel, int offset, int scansize)
      更改一个新的int数组来保存此图像的像素。
      void newPixels​(int x, int y, int w, int h)
      将像素缓冲区的矩形区域发送到当前对该图像的数据感兴趣的任何ImageConsumers，并通知它们动画帧完成。
      void newPixels​(int x, int y, int w, int h, boolean framenotify)
      将像素缓冲区的矩形区域发送到当前对该图像的数据感兴趣的任何ImageConsumers。
      void removeConsumer​(ImageConsumer ic)
      从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
      void requestTopDownLeftRightResend​(ImageConsumer ic)
      请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
      void setAnimated​(boolean animated)
      根据动画参数，将此内存图像更改为多帧动画或单帧静态图像。
      void setFullBufferUpdates​(boolean fullbuffers)
      指定是否应始终通过发送像素的完整缓冲区来更新此动画内存映像。
      void startProduction​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的用户列表中，并通过ImageConsumer界面立即开始传送图像数据。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MemoryImageSource

        public MemoryImageSource​(int w,
                         int h,
                         ColorModel cm,
                         byte[] pix,
                         int off,
                         int scan)
        构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
        参数
        w - 像素矩形的宽度
        h - 像素矩形的高度
        cm - 指定的 ColorModel
        pix - 像素数组
        off - 将阵列的偏移量存储在第一个像素的位置
        scan - 从阵列中的一行像素到下一个像素的距离
        另请参见：
        Component.createImage(java.awt.image.ImageProducer)

      • MemoryImageSource

        public MemoryImageSource​(int w,
                         int h,
                         ColorModel cm,
                         byte[] pix,
                         int off,
                         int scan,
                         Hashtable<?,?> props)
        构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
        参数
        w - 像素矩形的宽度
        h - 像素矩形的高度
        cm - 指定的 ColorModel
        pix - 像素数组
        off - 将阵列的偏移量存储在第一个像素的位置
        scan - 从阵列中的一行像素到下一个像素的距离
        props - ImageProducer用于处理图像的属性列表
        另请参见：
        Component.createImage(java.awt.image.ImageProducer)

      • MemoryImageSource

        public MemoryImageSource​(int w,
                         int h,
                         ColorModel cm,
                         int[] pix,
                         int off,
                         int scan)
        构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。
        参数
        w - 像素矩形的宽度
        h - 像素矩形的高度
        cm - 指定的 ColorModel
        pix - 像素数组
        off - 将阵列的偏移量存储在第一个像素的位置
        scan - 从阵列中的一行像素到下一个像素的距离
        另请参见：
        Component.createImage(java.awt.image.ImageProducer)

      • MemoryImageSource

        public MemoryImageSource​(int w,
                         int h,
                         ColorModel cm,
                         int[] pix,
                         int off,
                         int scan,
                         Hashtable<?,?> props)
        构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。
        参数
        w - 像素矩形的宽度
        h - 像素矩形的高度
        cm - 指定的 ColorModel
        pix - 像素数组
        off - 将阵列的偏移量存储在第一个像素的位置
        scan - 从阵列中的一行像素到下一个像素的距离
        props - ImageProducer用于处理图像的属性列表
        另请参见：
        Component.createImage(java.awt.image.ImageProducer)

      • MemoryImageSource

        public MemoryImageSource​(int w,
                         int h,
                         int[] pix,
                         int off,
                         int scan)
        构造一个ImageProducer对象，它使用默认RGB ColorModel中的整数数组来生成一个Image对象的数据。
        参数
        w - 像素矩形的宽度
        h - 像素矩形的高度
        pix - 像素数组
        off - 将阵列的偏移量存储在第一个像素的位置
        scan - 从阵列中的一行像素到下一个像素的距离
        另请参见：
        Component.createImage(java.awt.image.ImageProducer) ， ColorModel.getRGBdefault()

      • MemoryImageSource

        public MemoryImageSource​(int w,
                         int h,
                         int[] pix,
                         int off,
                         int scan,
                         Hashtable<?,?> props)
        构造一个ImageProducer对象，它使用默认RGB ColorModel中的整数数组来生成一个Image对象的数据。
        参数
        w - 像素矩形的宽度
        h - 像素矩形的高度
        pix - 像素数组
        off - 阵列中存储第一个像素的位置的偏移量
        scan - 阵列中一行像素到下一个像素的距离
        props - ImageProducer用于处理图像的属性列表
        另请参见：
        Component.createImage(java.awt.image.ImageProducer) ， ColorModel.getRGBdefault()

    • 方法详细信息

      • addConsumer

        public void addConsumer​(ImageConsumer ic)
        将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
        Specified by:
        addConsumer在接口 ImageProducer
        参数
        ic - 指定的 ImageConsumer
        异常
        NullPointerException - 如果指定的 ImageConsumer为空
        另请参见：
        ImageConsumer

      • isConsumer

        public boolean isConsumer​(ImageConsumer ic)
        确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。
        Specified by:
        isConsumer在接口 ImageProducer
        参数
        ic - 指定的 ImageConsumer
        结果
        true如果ImageConsumer在列表中; 否则为false 。
        另请参见：
        ImageConsumer

      • removeConsumer

        public void removeConsumer​(ImageConsumer ic)
        从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
        Specified by:
        removeConsumer在接口 ImageProducer
        参数
        ic - 指定的 ImageConsumer
        另请参见：
        ImageConsumer

      • startProduction

        public void startProduction​(ImageConsumer ic)
        将ImageConsumer添加到对该图像的数据感兴趣的用户列表中，并通过ImageConsumer界面立即开始传送图像数据。
        Specified by:
        startProduction在接口 ImageProducer
        参数
        ic - 通过ImageConsumer界面指定的 ImageConsumer图像数据。
        另请参见：
        ImageConsumer

      • requestTopDownLeftRightResend

        public void requestTopDownLeftRightResend​(ImageConsumer ic)
        请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
        Specified by:
        requestTopDownLeftRightResend在接口 ImageProducer
        参数
        ic - 指定的 ImageConsumer
        另请参见：
        ImageConsumer

      • setAnimated

        public void setAnimated​(boolean animated)
        根据动画参数，将此内存图像更改为多帧动画或单帧静态图像。

        应该在构建MemoryImageSource之后立即调用此方法，并在使用它创建映像之前立即调用该方法，以确保所有ImageConsumers都将接收到正确的多帧数据。 如果在设置此标志之前将ImageConsumer添加到此ImageProducer，则该ImageConsumer将仅在连接时可以看到像素数据的快照。

        参数
        animated - true如果图像是多帧动画

      • setFullBufferUpdates

        public void setFullBufferUpdates​(boolean fullbuffers)
        指定是否应始终通过发送像素的完整缓冲区来更新此动画内存映像。 如果没有通过setAnimated（）方法打开动画标志，则忽略此标志。

        应该在构建MemoryImageSource之后立即调用此方法，并在使用它创建映像之前立即调用该方法，以确保所有ImageConsumers都将收到正确的像素传送提示。

        参数
        fullbuffers - true如果始终发送完整的像素缓冲区
        另请参见：
        setAnimated(boolean)

      • newPixels

        public void newPixels​()
        向目前对此图像的数据感兴趣的任何ImageConsumers发送一个全新的像素缓冲区，并通知他们动画帧完成。 该方法只有通过setAnimated（）方法打开动画标志才有效果。
        另请参见：
        newPixels(int, int, int, int, boolean) ， ImageConsumer ， setAnimated(boolean)

      • newPixels

        public void newPixels​(int x,
                      int y,
                      int w,
                      int h)
        将像素缓冲区的矩形区域发送到当前对该图像的数据感兴趣的任何ImageConsumers，并通知它们动画帧完成。 该方法只有通过setAnimated（）方法打开动画标志才有效果。 如果使用setFullBufferUpdates（）方法打开了完整的缓冲区更新标志，则矩形参数将被忽略，并且始终将发送整个缓冲区。
        参数
        x - 要发送的像素矩形的左上角的x坐标
        y - 要发送的像素矩形的左上角的y坐标
        w - 要发送的像素矩形的宽度
        h - 要发送的像素矩形的高度
        另请参见：
        newPixels(int, int, int, int, boolean) ， ImageConsumer ， setAnimated(boolean) ， setFullBufferUpdates(boolean)

      • newPixels

        public void newPixels​(int x,
                      int y,
                      int w,
                      int h,
                      boolean framenotify)
        将像素缓冲区的矩形区域发送到当前对该图像的数据感兴趣的任何ImageConsumers。 如果framenotify参数为true，那么还会通知消费者动画帧已完成。 该方法只有通过setAnimated（）方法打开动画标志才有效果。 如果使用setFullBufferUpdates（）方法打开了完整的缓冲区更新标志，则矩形参数将被忽略，并且始终将发送整个缓冲区。
        参数
        x - 要发送的像素矩形的左上角的x坐标
        y - 要发送的像素矩形的左上角的y坐标
        w - 要发送的像素的矩形的宽度
        h - 要发送的像素矩形的高度
        framenotify - true如果消费者应该发送一个 SINGLEFRAMEDONE通知
        另请参见：
        ImageConsumer ， setAnimated(boolean) ， setFullBufferUpdates(boolean)

      • newPixels

        public void newPixels​(byte[] newpix,
                      ColorModel newmodel,
                      int offset,
                      int scansize)
        更改新的字节数组来保存此图像的像素。 如果通过setAnimated（）方法打开了动画标志，则新像素将立即传递给当前对该图像的数据感兴趣的任何ImageConsumers。
        参数
        newpix - 新的像素阵列
        newmodel - 指定的 ColorModel
        offset - 数组中的偏移量
        scansize - 从阵列中的一行像素到下一个像素的距离
        另请参见：
        newPixels(int, int, int, int, boolean) ， setAnimated(boolean)

      • newPixels

        public void newPixels​(int[] newpix,
                      ColorModel newmodel,
                      int offset,
                      int scansize)
        更改一个新的int数组来保存此图像的像素。 如果通过setAnimated（）方法打开了动画标志，则新像素将立即传递给当前对该图像的数据感兴趣的任何ImageConsumers。
        参数
        newpix - 新的像素阵列
        newmodel - 指定的 ColorModel
        offset - 数组中的偏移量
        scansize - 阵列中一行像素到下一行的距离
        另请参见：
        newPixels(int, int, int, int, boolean) ， setAnimated(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MultiPixelPackedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class MultiPixelPackedSampleModel

  • java.lang.Object
    • java.awt.image.SampleModel
      • java.awt.image.MultiPixelPackedSampleModel

  • public class MultiPixelPackedSampleModel
extends SampleModel
    MultiPixelPackedSampleModel类表示单带图像，可以将多个单样本像素打包到一个数据元素中。 像素不允许跨数据元素。 数据类型可以是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT。 每个像素必须是2个位数的幂，2个像素的数量必须恰好适合于一个数据元素。 像素位步长等于每像素的位数。 扫描线步幅在数据元素中，最后几个数据元素可能用未使用的像素填充。 数据位偏移量是从DataBuffer开始到第一个像素的位偏移量，必须是像素位数的倍数。

    以下代码说明从DataBuffer data提取像素x, y的位并将像素数据存储在类型为dataType数据元素中：

       int dataElementSize = DataBuffer.getDataTypeSize(dataType); int bitnum = dataBitOffset + x*pixelBitStride; int element = data.getElem(y*scanlineStride + bitnum/dataElementSize); int shift = dataElementSize - (bitnum & (dataElementSize-1)) - pixelBitStride; int pixel = (element >> shift) & ((1 << pixelBitStride) - 1);

    • Field Summary

      • Fields inherited from class java.awt.image.SampleModel

        dataType, height, numBands, width

    • 构造方法摘要

      构造方法
      Constructor 描述
      MultiPixelPackedSampleModel​(int dataType, int w, int h, int numberOfBits)
      构造具有指定数据类型，宽度，高度和每像素位数的 MultiPixelPackedSampleModel 。
      MultiPixelPackedSampleModel​(int dataType, int w, int h, int numberOfBits, int scanlineStride, int dataBitOffset)
      构造具有指定数据类型，宽度，高度，每像素位数，扫描线步长和数据位偏移的 MultiPixelPackedSampleModel 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建一个新的 MultiPixelPackedSampleModel具有指定的宽度和高度。
      DataBuffer createDataBuffer​()
      创建一个 DataBuffer对应于这个 MultiPixelPackedSampleModel 。
      SampleModel createSubsetSampleModel​(int[] bands)
      创建一个新的 MultiPixelPackedSampleModel与这个 MultiPixelPackedSampleModel的频带的子集。
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      int getBitOffset​(int x)
      将偏移量（以位为单位）返回到扫描线的 x像素存储的数据元素中。
      int getDataBitOffset​()
      以位为单位返回数据位偏移量。
      Object getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      int getNumDataElements​()
      通过 getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)和 setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)方法返回传输一个像素所需的数据元素数。
      int getOffset​(int x, int y)
      返回数据数组元素中像素（x，y）的偏移量。
      int[] getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回 int数组的第一个元素中指定的单频带像素。
      int getPixelBitStride​()
      返回像素位以位为单位。
      int getSample​(int x, int y, int b, DataBuffer data)
      返回为 int位于（x，y）处的像素的指定带中的样本。
      int[] getSampleSize​()
      返回所有频带的每个样本的位数。
      int getSampleSize​(int band)
      返回指定频带的每个样本的位数。
      int getScanlineStride​()
      返回扫描线步幅。
      int getTransferType​()
      返回用于通过 getDataElements和 setDataElements方法传输像素的TransferType。
      int hashCode​()
      返回对象的哈希码值。
      void setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定的 DataBuffer单个像素的数据。
      void setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用 int阵列设置 DataBuffer的像素进行输入。
      void setSample​(int x, int y, int b, int s, DataBuffer data)
      在 DataBuffer使用 int作为输入，设置位于（x，y）处的像素的指定频带中的样本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.image.SampleModel

        getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getPixels, getSampleDouble, getSampleFloat, getSamples, getSamples, getSamples, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setPixels, setSample, setSample, setSamples, setSamples, setSamples

    • 构造方法详细信息

      • MultiPixelPackedSampleModel

        public MultiPixelPackedSampleModel​(int dataType,
                                   int w,
                                   int h,
                                   int numberOfBits)
        构造具有指定数据类型，宽度，高度和每像素位数的 MultiPixelPackedSampleModel 。
        参数
        dataType - 存储样本的数据类型
        w - 描述的图像数据区域的宽度（以像素为单位）
        h - 描述的图像数据区域的高度（以像素为单位）
        numberOfBits - 每像素的位数
        异常
        IllegalArgumentException -如果 dataType不是非此即彼 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT

      • MultiPixelPackedSampleModel

        public MultiPixelPackedSampleModel​(int dataType,
                                   int w,
                                   int h,
                                   int numberOfBits,
                                   int scanlineStride,
                                   int dataBitOffset)
        构造具有指定数据类型，宽度，高度，每像素位数，扫描线步长和数据位偏移量的 MultiPixelPackedSampleModel 。
        参数
        dataType - 存储样本的数据类型
        w - 描述的图像数据区域的宽度（以像素为单位）
        h - 描述的图像数据区域的高度（以像素为单位）
        numberOfBits - 每像素的位数
        scanlineStride - 图像数据的行走
        dataBitOffset - 描述的图像数据区域的数据位偏移量
        异常
        RasterFormatException - 如果每像素的比特数不是2的幂，或者如果2个像素的数量不适合于一个数据元素。
        IllegalArgumentException - 如果 w或 h不大于0
        IllegalArgumentException -如果 dataType不是非此即彼 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT

    • 方法详细信息

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建一个新的MultiPixelPackedSampleModel具有指定的宽度和高度。 新的MultiPixelPackedSampleModel具有与MultiPixelPackedSampleModel相同的存储数据类型和每像素的MultiPixelPackedSampleModel 。
        Specified by:
        createCompatibleSampleModel在 SampleModel
        参数
        w - 指定的宽度
        h - 指定的高度
        结果
        一个SampleModel，具有指定的宽度和高度，并具有与MultiPixelPackedSampleModel相同的存储数据类型和每像素的MultiPixelPackedSampleModel 。
        异常
        IllegalArgumentException - 如果 w或 h不大于0

      • createDataBuffer

        public DataBuffer createDataBuffer​()
        创建一个DataBuffer对应于这个MultiPixelPackedSampleModel 。 DataBuffer对象的数据类型和大小与此MultiPixelPackedSampleModel一致。 DataBuffer有一个银行。
        Specified by:
        createDataBuffer在 SampleModel
        结果
        一个 DataBuffer具有相同的数据类型和大小，这个 MultiPixelPackedSampleModel 。

      • getNumDataElements

        public int getNumDataElements​()
        返回通过getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)和setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)方法传输一个像素所需的数据元素数。 对于一个MultiPixelPackedSampleModel ，这是一个。
        Specified by:
        getNumDataElements在 SampleModel
        结果
        数据元素的数量。
        另请参见：
        SampleModel.getDataElements(int, int, Object, DataBuffer) ， SampleModel.getDataElements(int, int, int, int, Object, DataBuffer) ， SampleModel.setDataElements(int, int, Object, DataBuffer) ， SampleModel.setDataElements(int, int, int, int, Object, DataBuffer) ， SampleModel.getTransferType()

      • getSampleSize

        public int[] getSampleSize​()
        返回所有频带的每个样本的位数。
        Specified by:
        getSampleSize在 SampleModel
        结果
        每个样本的位数。

      • getSampleSize

        public int getSampleSize​(int band)
        返回指定频带的每个样本的位数。
        Specified by:
        getSampleSize在 SampleModel
        参数
        band - 指定的频带
        结果
        指定频带的每个样本的位数。

      • getOffset

        public int getOffset​(int x,
                     int y)
        返回数据数组元素中像素（x，y）的偏移量。
        参数
        x - 指定像素的X坐标
        y - 指定像素的Y坐标
        结果
        指定像素的偏移量。

      • getBitOffset

        public int getBitOffset​(int x)
        将偏移量（以位为单位）返回到其扫描线的x像素存储的数据元素中。 所有扫描线的偏移量相同。
        参数
        x - 指定的像素
        结果
        指定像素的位偏移。

      • getScanlineStride

        public int getScanlineStride​()
        返回扫描线步幅。
        结果
        该扫描线步幅为 MultiPixelPackedSampleModel 。

      • getPixelBitStride

        public int getPixelBitStride​()
        返回像素位以位为单位。 该值与每像素的位数相同。
        结果
        这 pixelBitStride的 MultiPixelPackedSampleModel 。

      • getDataBitOffset

        public int getDataBitOffset​()
        以位为单位返回数据位偏移量。
        结果
        该 dataBitOffset的这个 MultiPixelPackedSampleModel 。

      • getTransferType

        public int getTransferType​()
        返回用于通过getDataElements和setDataElements方法传输像素的TransferType。 TransferType可能与存储DataType相同也可能不一样。 TransferType是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT之一。
        重写：
        getTransferType在 SampleModel
        结果
        转移类型。
        另请参见：
        SampleModel.getDataElements(int, int, Object, DataBuffer) ， SampleModel.getDataElements(int, int, int, int, Object, DataBuffer) ， SampleModel.setDataElements(int, int, Object, DataBuffer) ， SampleModel.setDataElements(int, int, int, int, Object, DataBuffer) ， SampleModel.getNumDataElements() ， DataBuffer

      • createSubsetSampleModel

        public SampleModel createSubsetSampleModel​(int[] bands)
        创建一个新的MultiPixelPackedSampleModel与这个MultiPixelPackedSampleModel的频带的子集。 由于MultiPixelPackedSampleModel只有一个频段，所以频段参数的长度必须为1，表示第0个频段。
        Specified by:
        createSubsetSampleModel在 SampleModel
        参数
        bands - 指定的乐队
        结果
        一个新的 SampleModel与这个 MultiPixelPackedSampleModel的频带的子集。
        异常
        RasterFormatException - 如果请求的频带数不是一个。
        IllegalArgumentException - 如果 w或 h不大于0

      • getSample

        public int getSample​(int x,
                     int y,
                     int b,
                     DataBuffer data)
        返回为int位于（x，y）处的像素的指定带中的样本。 如果坐标不在边界内，则抛出ArrayIndexOutOfBoundsException 。
        Specified by:
        getSample在 SampleModel
        参数
        x - 指定像素的X坐标
        y - 指定像素的Y坐标
        b - 要返回的频带，假定为0
        data - 包含图像数据的 DataBuffer
        结果
        指定的带包含指定像素的样本。
        异常
        ArrayIndexOutOfBoundsException - 如果指定的坐标不在边界内。
        另请参见：
        setSample(int, int, int, int, DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
        在DataBuffer使用int设置位于（x，y）处的像素的指定频带中的样本。 如果坐标不在边界内，则抛出ArrayIndexOutOfBoundsException 。
        Specified by:
        setSample在类 SampleModel
        参数
        x - 指定像素的X坐标
        y - 指定像素的Y坐标
        b - 要返回的频带，假定为0
        s - 输入样本为 int
        data - 存储图像数据的 DataBuffer
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内。
        另请参见：
        getSample(int, int, int, DataBuffer)

      • getDataElements

        public Object getDataElements​(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
        返回TransferType类型的原始数组中单个像素的数据。 对于MultiPixelPackedSampleModel ，该数组有一个元素，类型是可容纳单个像素的DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT中最小的元素。 一般来说， obj应该传递为null ，以便自动创建Object ，是正确的原始数据类型。

        以下代码说明将DataBuffer db1 （其存储布局由MultiPixelPackedSampleModel描述为MultiPixelPackedSampleModel mppsm1到DataBuffer db2 ，其存储布局由MultiPixelPackedSampleModel mppsm2描述。 转移通常比使用getPixel或setPixel更有效。

          MultiPixelPackedSampleModel mppsm1, mppsm2;
       DataBufferInt db1, db2;
       mppsm2.setDataElements(x, y, mppsm1.getDataElements(x, y, null,
                              db1), db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements或setDataElements在两个DataBuffer/SampleModel对之间传输是合法的，对应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        如果obj不是null ，它应该是TransferType类型的原始数组。 否则，抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果坐标不在边界被抛出，或者如果obj不null并没有大到足以容纳像素数据。

        Specified by:
        getDataElements在 SampleModel
        参数
        x - 指定像素的X坐标
        y - 指定像素的Y坐标
        obj - 要返回像素数据的原始数组，或 null 。
        data - 包含图像数据的 DataBuffer 。
        结果
        一个 Object包含指定像素的数据。
        异常
        ClassCastException - 如果 obj不是TransferType类型的原始数组，或不是 null
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果 obj不是 null或者不够大，不能保持像素数据
        另请参见：
        setDataElements(int, int, Object, DataBuffer)

      • getPixel

        public int[] getPixel​(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
        返回int数组的第一个元素中指定的单频带像素。 如果坐标不在边界内，则抛出ArrayIndexOutOfBoundsException 。
        重写：
        getPixel在 SampleModel
        参数
        x - 指定像素的X坐标
        y - 指定像素的Y坐标
        iArray - 包含要返回的像素的数组或 null
        data - 存储图像数据的 DataBuffer
        结果
        一个包含指定像素的数组。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内
        另请参见：
        setPixel(int, int, int[], DataBuffer)

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
        从指定的DataBuffer的单个像素的数据设置TransferType类型的原始数组。 对于MultiPixelPackedSampleModel ，只有数组的第一个元素保存有效数据，并且类型必须是可容纳单个像素的DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT或DataBuffer.TYPE_INT中最小的数据。

        以下代码说明将DataBuffer db1的存储布局由MultiPixelPackedSampleModel mppsm1描述的MultiPixelPackedSampleModel一个像素的数据传输到DataBuffer db2 ，其存储布局由MultiPixelPackedSampleModel mppsm2描述。 转移通常比使用getPixel或setPixel更有效。

          MultiPixelPackedSampleModel mppsm1, mppsm2;
       DataBufferInt db1, db2;
       mppsm2.setDataElements(x, y, mppsm1.getDataElements(x, y, null,
                              db1), db2);
        如果SampleModel对象具有相同数量的频带，则使用getDataElements或setDataElements在两个DataBuffer/SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        obj必须是TransferType类型的原始数组。 否则，将抛出一个ClassCastException 。 一个ArrayIndexOutOfBoundsException如果坐标不在边界被抛出，或者如果obj不够大，无法容纳像素数据。

        Specified by:
        setDataElements在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        obj - 包含像素数据的原始数组
        data - 包含图像数据的 DataBuffer
        另请参见：
        getDataElements(int, int, Object, DataBuffer)

      • setPixel

        public void setPixel​(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
        使用int数组设置DataBuffer的像素进行输入。 如果坐标不在边界内，则抛出ArrayIndexOutOfBoundsException 。
        重写：
        setPixel在 SampleModel
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        iArray - int数组中的输入像素
        data - 包含图像数据的 DataBuffer
        另请参见：
        getPixel(int, int, int[], DataBuffer)

      • equals

        public boolean equals​(Object o)
        描述从类别复制： Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空引用值x和y ，多重调用x.equals(y)始终返回true或一致返回false ，只要在equals对对象的比较使用的信息进行修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 用于比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那些 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一对象上调用该对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals对比中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MultiResolutionImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface MultiResolutionImage

  • 所有已知实现类：
    AbstractMultiResolutionImage ， BaseMultiResolutionImage

    public interface MultiResolutionImage
    该接口被设计为一些Image的一些实现支持的可选附加API，以允许它们为各种渲染分辨率提供备用图像。 各种Graphics.drawImage(...)变体方法如果在参数Image对象上实现，请参阅此接口的方法，以便为每个渲染操作选择最佳表示。

    所述MultiResolutionImage接口应该由任何亚类来实现java.awt.Image其实例旨在提供对图像分辨率根据给定的图像的宽度和高度的变体。 为了方便起见，从Toolkit.getImage(String name)和Toolkit.getImage(URL url)获得的工具包图像将在支持存储图像介质的分辨率变体的命名约定的平台上实现此接口，并提供AbstractMultiResolutionImage和BaseMultiResolutionImage类，以便于从相关列表中轻松构建自定义多分辨率图像图片。

    从以下版本开始：
    9
    另请参见：
    Image ， AbstractMultiResolutionImage ， BaseMultiResolutionImage ， Toolkit.getImage(java.lang.String filename) ， Toolkit.getImage(java.net.URL url)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Image getResolutionVariant​(double destImageWidth, double destImageHeight)
      获取一个特定的图像，这是以指定大小表示该逻辑图像的最佳变体。
      List<Image> getResolutionVariants​()
      获取所有分辨率变体的可读列表。

    • 方法详细信息

      • getResolutionVariant

        Image getResolutionVariant​(double destImageWidth,
                           double destImageHeight)
        获取一个特定的图像，这是以指定大小表示该逻辑图像的最佳变体。
        参数
        destImageWidth - 目标图像的宽度，以像素为单位。
        destImageHeight - 目标图像的高度（以像素为单位）。
        结果
        图像分辨率变体。
        异常
        IllegalArgumentException - 如果 destImageWidth或 destImageHeight小于或等于零，无穷大或NaN。
        从以下版本开始：
        9

      • getResolutionVariants

        List<Image> getResolutionVariants​()
        获取所有分辨率变体的可读列表。 该列表必须非空，并且至少包含一个分辨率变体。

        请注意，许多实现可能会返回一个不可修改的列表。

        结果
        分辨率变体列表。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PackedColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class PackedColorModel

  • java.lang.Object
    • java.awt.image.ColorModel
      • java.awt.image.PackedColorModel
  • All Implemented Interfaces:
    Transparency
    已知直接子类：
    DirectColorModel

    public abstract class PackedColorModel
extends ColorModel
    PackedColorModel类是一个抽象的ColorModel类，它与像素值一起使用，它们将颜色和alpha信息表示为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。 这个类可以随意使用ColorSpace 。 像素值中的颜色样本数必须与ColorSpace中颜色分量的数量相同。 可以有一个单一的alpha样本。 对于使用transferType类型的原始数组像素表示的方法，数组长度总是为1。 支持的传输类型是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT和DataBuffer.TYPE_INT。 颜色和alpha样本以位掩码表示的位存储在阵列的单个元素中。 每个位掩码必须是连续的，掩码不能重叠。 相同的掩码适用于其他方法使用的单个int像素表示。 面具和颜色/阿尔法样本的对应关系如下：
    • 掩码由0到getNumComponents-1之间的索引识别。
    • 第一个getNumColorComponents指数是指颜色样本。
    • 如果存在α样本，则它对应于最后一个索引。
    • 颜色索引的顺序由ColorSpace指定。 通常，这反映了颜色空间类型的名称（例如，TYPE_RGB），索引0对应于红色，索引1为绿色，索引2为蓝色。

    从显示或处理目的，从像素值到颜色/α分量的转换是样本与组件的一一对应关系。 A PackedColorModel通常用于使用掩模来定义打包样本的图像数据。 例如，一个PackedColorModel可以与一个SinglePixelPackedSampleModel结合使用来构建一个BufferedImage 。 通常， SampleModel和ColorModel使用的掩码将是一样的。 然而，如果它们不同，则像素数据的颜色解释是根据ColorModel的掩码进行的。

    单个int像素表示对于此类的所有对象是有效的，因为总是可以在单个int表示与该类一起使用的像素值。 因此，由于无效的像素值，使用此表示的方法不会抛出IllegalArgumentException 。

    PackedColorModel的子类是DirectColorModel ，类似于X11 TrueColor视觉。

    另请参见：
    DirectColorModel ， SinglePixelPackedSampleModel ， BufferedImage

    • Field Summary

      • Fields inherited from class java.awt.image.ColorModel

        pixel_bits, transferType

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      PackedColorModel​(ColorSpace space, int bits, int[] colorMaskArray, int alphaMask, boolean isAlphaPremultiplied, int trans, int transferType)
      从颜色掩码数组构造一个 PackedColorModel ，它指定 int像素表示中的哪个位包含每个颜色样本和一个alpha掩码。
      PackedColorModel​(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int trans, int transferType)
      从指定的掩码构造一个 PackedColorModel ，指示 int像素表示中的哪些位包含alpha，红，绿和蓝色样本。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
      boolean equals​(Object obj)
      测试指定 Object是一个实例 PackedColorModel和等于这个 PackedColorModel 。
      WritableRaster getAlphaRaster​(WritableRaster raster)
      返回一个WritableRaster，表示从输入WritableRaster提取的图像的Alpha通道。
      int getMask​(int index)
      返回掩码，指示像素中的哪些位包含指定的颜色/ alpha样本。
      int[] getMasks​()
      返回一个掩码数组，指示像素中的哪些位包含颜色和alpha样本。
      int hashCode​()
      返回此PackedColorModel的哈希码。
      boolean isCompatibleSampleModel​(SampleModel sm)
      检查指定的 SampleModel是否与此 ColorModel兼容。

      • Methods inherited from class java.awt.image.ColorModel

        coerceData, createCompatibleWritableRaster, finalize, getAlpha, getAlpha, getBlue, getBlue, getColorSpace, getComponents, getComponents, getComponentSize, getComponentSize, getDataElement, getDataElement, getDataElements, getDataElements, getDataElements, getGreen, getGreen, getNormalizedComponents, getNormalizedComponents, getNumColorComponents, getNumComponents, getPixelSize, getRed, getRed, getRGB, getRGB, getRGBdefault, getTransferType, getTransparency, getUnnormalizedComponents, hasAlpha, isAlphaPremultiplied, isCompatibleRaster, toString

      • Methods inherited from class java.lang.Object

        clone, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PackedColorModel

        public PackedColorModel​(ColorSpace space,
                        int bits,
                        int[] colorMaskArray,
                        int alphaMask,
                        boolean isAlphaPremultiplied,
                        int trans,
                        int transferType)
        从颜色掩码数组构造一个PackedColorModel ，它指定int像素表示中的哪个位包含每个颜色样本和一个alpha掩码。 颜色分量在ColorSpace 。 colorMaskArray的长度应为colorMaskArray中组件的ColorSpace 。 每个掩码中的所有位必须是连续的，并且适合int像素表示的指定数目的最低有效位。 如果alphaMask为0，则不存在alpha。 如果有alpha， boolean isAlphaPremultiplied指定如何解释像素值中的颜色和alpha样本。 如果boolean为true ，则假定颜色样本已被乘以α样本。 透明度， trans ，指定可以通过此颜色模型表示哪些alpha值。 传输类型是用于表示像素值的原始数组的类型。
        参数
        space - 指定的 ColorSpace
        bits - 像素值中的位数
        colorMaskArray - 指定表示表示颜色分量的像素值的位的掩码的数组
        alphaMask - 指定表示表示α分量的像素值的位的掩码
        isAlphaPremultiplied - true如果颜色样品被alpha样品预乘， 否则为false
        trans - 指定可以由此颜色模型表示的alpha值
        transferType - 用于表示像素值的数组类型
        异常
        IllegalArgumentException - 如果 bits小于1或大于32

      • PackedColorModel

        public PackedColorModel​(ColorSpace space,
                        int bits,
                        int rmask,
                        int gmask,
                        int bmask,
                        int amask,
                        boolean isAlphaPremultiplied,
                        int trans,
                        int transferType)
        从指定的掩码构造一个PackedColorModel ，指示int像素表示中的哪个位包含alpha，红，绿和蓝色样本。 颜色组件在指定的ColorSpace ，其颜色必须为ColorSpace.TYPE_RGB。 每个掩码中的所有位必须是连续的，并且适合int像素表示的指定数目的最低有效位。 如果amask为0，则不存在alpha。 如果有alpha，则boolean isAlphaPremultiplied指定如何在像素值中解释颜色和alpha样本。 如果boolean为true ，则假定颜色样本已被乘以α样本。 透明度（ trans ）指定了此颜色模型可以表示哪些alpha值。 传输类型是用于表示像素值的原始数组的类型。
        参数
        space - 指定的 ColorSpace
        bits - 像素值中的位数
        rmask - 指定表示表示红色分量的像素值的位的掩码
        gmask - 指定表示表示绿色分量的像素值的位的掩码
        bmask - 指定表示表示蓝色分量的像素值的位的掩码
        amask - 指定表示表示α分量的像素值的位的掩码
        isAlphaPremultiplied - true如果颜色样品被alpha样品预乘， false否则
        trans - 指定可以由此颜色模型表示的alpha值
        transferType - 用于表示像素值的数组类型
        异常
        IllegalArgumentException - 如果 space不是TYPE_RGB空间
        另请参见：
        ColorSpace

    • 方法详细信息

      • getMask

        public final int getMask​(int index)
        返回掩码，指示像素中的哪些位包含指定的颜色/ alpha样本。 对于颜色样本， index对应于颜色空间中颜色样本名称的位置。 因此，对于CMYK ColorSpace，等于0的index将对应于青色，等于1的index对应于洋红色。 如果有alpha，alpha index将是：
          alphaIndex = numComponents() - 1;
        参数
        index - 指定的颜色或alpha样本
        结果
        该掩码指示 int像素表示的哪些位包含由 index指定的颜色或alpha样本。
        异常
        ArrayIndexOutOfBoundsException - 如果 index大于此 PackedColorModel的组件数减1，或者如果 index小于零

      • getMasks

        public final int[] getMasks​()
        返回一个掩码数组，指示像素中的哪些位包含颜色和alpha样本。
        结果
        掩码阵列，其指示 int像素表示的哪个位包含颜色或α样本。

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
        重写：
        createCompatibleSampleModel在 ColorModel
        参数
        w - 描述的图像数据的区域的宽度（以像素为单位）
        h - 描述的图像数据的区域的高度（以像素为单位）
        结果
        新创 SampleModel 。
        异常
        IllegalArgumentException - 如果 w或 h不大于0
        另请参见：
        SampleModel

      • isCompatibleSampleModel

        public boolean isCompatibleSampleModel​(SampleModel sm)
        检查指定的SampleModel是否与此ColorModel兼容。 如果sm为null ，此方法返回false 。
        重写：
        isCompatibleSampleModel在 ColorModel
        参数
        sm - 指定的 SampleModel或 null
        结果
        true如果指定的SampleModel与此兼容ColorModel ; 否则为false 。
        另请参见：
        SampleModel

      • getAlphaRaster

        public WritableRaster getAlphaRaster​(WritableRaster raster)
        返回WritableRaster表示图像的alpha通道，从输入中提取WritableRaster 。 该方法假定与该ColorModel相关联的WritableRaster对象存储α波段（如果存在）作为最后的图像数据带。 返回null ，如果有与此相关的独立空间alpha通道ColorModel 。 此方法创建一个新的WritableRaster ，但共享数据数组。
        重写：
        getAlphaRaster在 ColorModel
        参数
        raster - 一个包含图像的 WritableRaster
        结果
        一个表示 WritableRaster中包含的图像的Alpha通道的 raster 。

      • equals

        public boolean equals​(Object obj)
        测试指定 Object是一个实例 PackedColorModel和等于这个 PackedColorModel 。
        重写：
        equals在 ColorModel
        参数
        obj - Object测试平等
        结果
        true如果指定Object是的一个实例PackedColorModel并且等于此PackedColorModel ; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此PackedColorModel的哈希码。
        重写：
        hashCode在 ColorModel
        结果
        此PackedColorModel的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PixelGrabber (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class PixelGrabber

  • java.lang.Object
    • java.awt.image.PixelGrabber
  • All Implemented Interfaces:
    ImageConsumer

    public class PixelGrabber
extends Object
implements ImageConsumer
    PixelGrabber类实现了一个ImageConsumer，它可以附加到Image或ImageProducer对象，以检索该图像中的像素的子集。 这是一个例子：
       public void handlesinglepixel(int x, int y, int pixel) { int alpha = (pixel >> 24) & 0xff; int red = (pixel >> 16) & 0xff; int green = (pixel >> 8) & 0xff; int blue = (pixel ) & 0xff; // Deal with the pixel as necessary... } public void handlepixels(Image img, int x, int y, int w, int h) { int[] pixels = new int[w * h]; PixelGrabber pg = new PixelGrabber(img, x, y, w, h, pixels, 0, w); try { pg.grabPixels(); } catch (InterruptedException e) { System.err.println("interrupted waiting for pixels!"); return; } if ((pg.getStatus() & ImageObserver.ABORT) != 0) { System.err.println("image fetch aborted or errored"); return; } for (int j = 0; j < h; j++) { for (int i = 0; i < w; i++) { handlesinglepixel(x+i, y+j, pixels[j * w + i]); } } }
    另请参见：
    ColorModel.getRGBdefault()

    • Field Summary

      • Fields inherited from interface java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

    • 构造方法摘要

      构造方法
      Constructor 描述
      PixelGrabber​(ImageProducer ip, int x, int y, int w, int h, int[] pix, int off, int scansize)
      创建一个PixelGrabber对象，从指定的ImageProducer生成的图像中获取像素的（x，y，w，h）矩形部分到给定的数组中。
      PixelGrabber​(Image img, int x, int y, int w, int h, boolean forceRGB)
      创建一个PixelGrabber对象，从指定的图像中获取像素的（x，y，w，h）矩形部分。
      PixelGrabber​(Image img, int x, int y, int w, int h, int[] pix, int off, int scansize)
      创建一个PixelGrabber对象，将（x，y，w，h）像素的矩形部分从指定的图像进入给定的数组。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void abortGrabbing​()
      请求PixelGrabber中止图像提取。
      ColorModel getColorModel​()
      获取存储在数组中的像素的ColorModel。
      int getHeight​()
      获取像素缓冲区的高度（调整图像高度后）。
      Object getPixels​()
      获取像素缓冲区。
      int getStatus​()
      返回像素的状态。
      int getWidth​()
      获取像素缓冲区的宽度（调整图像宽度后）。
      boolean grabPixels​()
      请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送。
      boolean grabPixels​(long ms)
      请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送，或者直到指定的超时过去。
      void imageComplete​(int status)
      imageComplete方法是ImageConsumer API的一部分，该类必须实现以检索像素。
      void setColorModel​(ColorModel model)
      setColorModel方法是ImageConsumer API的一部分，该类必须实现此方法来检索像素。
      void setDimensions​(int width, int height)
      setDimensions方法是ImageConsumer API的一部分，该类必须实现这个API来检索像素。
      void setHints​(int hints)
      setHints方法是ImageConsumer API的一部分，该类必须实现这个API来检索像素。
      void setPixels​(int srcX, int srcY, int srcW, int srcH, ColorModel model, byte[] pixels, int srcOff, int srcScan)
      setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。
      void setPixels​(int srcX, int srcY, int srcW, int srcH, ColorModel model, int[] pixels, int srcOff, int srcScan)
      setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。
      void setProperties​(Hashtable<?,?> props)
      setProperties方法是ImageConsumer API的一部分，该类必须实现以检索像素。
      void startGrabbing​()
      请求PixelGrabber开始获取像素。
      int status​()
      返回像素的状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PixelGrabber

        public PixelGrabber​(Image img,
                    int x,
                    int y,
                    int w,
                    int h,
                    int[] pix,
                    int off,
                    int scansize)
        创建一个PixelGrabber对象，将（x，y，w，h）像素的矩形部分从指定的图像进入给定的数组。 像素存储在默认RGB ColorModel中的数组中。 其中（i，j）中的（i，j）的像素（i，j）的RGB数据在矩形（x，y，w，h）内存储在pix[(j - y) * scansize + (i - x) + off]的阵列中。
        参数
        img - 从中检索像素的图像
        x - 从图像中检索的像素矩形左上角的x坐标，相对于图像的默认（未缩放）大小
        y - 要从图像中检索的像素矩形的左上角的y坐标
        w - 要检索的像素矩形的宽度
        h - 要检索的像素矩形的高度
        pix - 要用于保存从图像检索的RGB像素的整数数组
        off - 将数组的偏移量存储在第一个像素的位置
        scansize - 从阵列中的一行像素到下一个像素的距离
        另请参见：
        ColorModel.getRGBdefault()

      • PixelGrabber

        public PixelGrabber​(ImageProducer ip,
                    int x,
                    int y,
                    int w,
                    int h,
                    int[] pix,
                    int off,
                    int scansize)
        创建一个PixelGrabber对象，从指定的ImageProducer生成的图像中获取像素的（x，y，w，h）矩形部分到给定的数组中。 像素存储在默认RGB ColorModel中的数组中。 其中（i，j）中的（i，j）的像素（i，j）的RGB数据被存储在矩阵（x，y，w，h）的阵列中，位于pix[(j - y) * scansize + (i - x) + off] 。
        参数
        ip - 产生从中检索像素的图像的 ImageProducer
        x - 从图像中检索的像素矩形左上角的x坐标，相对于图像的默认（未缩放）大小
        y - 要从图像中检索的像素矩形的左上角的y坐标
        w - 要检索的像素矩形的宽度
        h - 要检索的像素矩形的高度
        pix - 要用于保存从图像检索的RGB像素的整数数组
        off - 将阵列中的偏移量保存在第一个像素的位置
        scansize - 从阵列中的一行像素到下一个像素的距离
        另请参见：
        ColorModel.getRGBdefault()

      • PixelGrabber

        public PixelGrabber​(Image img,
                    int x,
                    int y,
                    int w,
                    int h,
                    boolean forceRGB)
        创建一个PixelGrabber对象，从指定的图像中获取像素的（x，y，w，h）矩形部分。 如果每次调用setPixels使用相同的ColorModel，则像素将累积在原始ColorModel中，否则像素将累积在默认的RGB ColorModel中。 如果forceRGB参数为true，则像素将累积在默认的RGB ColorModel中。 PixelGrabber分配一个缓冲区，以保持两种情况下的像素。 如果是(w < 0)或(h < 0) ，那么当传递该信息时，它们将默认为源数据的剩余宽度和高度。
        参数
        img - 从中检索图像数据的图像
        x - 从图像中检索的像素矩形左上角的x坐标，相对于图像的默认（未缩放）尺寸
        y - 要从图像中检索的像素矩形的左上角的y坐标
        w - 要检索的像素矩形的宽度
        h - 要检索的像素矩形的高度
        forceRGB - 如果像素应始终转换为默认的RGB ColorModel， forceRGB true

    • 方法详细信息

      • startGrabbing

        public void startGrabbing​()
        请求PixelGrabber开始获取像素。

      • abortGrabbing

        public void abortGrabbing​()
        请求PixelGrabber中止图像提取。

      • grabPixels

        public boolean grabPixels​()
                   throws InterruptedException
        请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送。
        结果
        如果像素被成功抓住，则为true，在中止，错误或超时时为false
        异常
        InterruptedException - 另一个线程已经中断了这个线程。

      • grabPixels

        public boolean grabPixels​(long ms)
                   throws InterruptedException
        请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送，或者直到指定的超时过去。 此方法的行为方式如下：取决于ms的值：
        • 如果ms == 0 ，等待直到所有像素都被传送
        • 如果ms > 0 ，等待直到所有像素在超时到期时传递。
        • 如果ms < 0 ，返回true如果所有像素都被抓住了， false否则并不会等待。
        参数
        ms - 等待图像像素超时前到达的毫秒数
        结果
        如果像素被成功抓住，则为true，在中止，错误或超时时为false
        异常
        InterruptedException - 另一个线程已经中断了这个线程。

      • getStatus

        public int getStatus​()
        返回像素的状态。 返回表示可用像素信息的ImageObserver标志。
        结果
        所有相关ImageObserver标志的按位OR
        另请参见：
        ImageObserver

      • getWidth

        public int getWidth​()
        获取像素缓冲区的宽度（调整图像宽度后）。 如果没有为要抓取的像素矩形指定宽度，则该信息仅在图像传送维后才可用。
        结果
        用于像素缓冲区的最终宽度，如果宽度尚未知道则为-1
        另请参见：
        getStatus()

      • getHeight

        public int getHeight​()
        获取像素缓冲区的高度（调整图像高度后）。 如果没有为要抓取的像素矩形指定宽度，则该信息仅在图像传送维后才可用。
        结果
        用于像素缓冲区的最终高度，如果高度尚未知道则为-1
        另请参见：
        getStatus()

      • getPixels

        public Object getPixels​()
        获取像素缓冲区。 如果PixelGrabber没有使用显式像素缓冲区来保存像素，那么该方法将返回null，直到图像数据的大小和格式已知。 由于如果源图像使用多个ColorModel传递数据，PixelGrabber可能随时累积默认RGB ColorModel中的数据，否则此方法返回的数组对象可能会随着时间的推移而变化，直到图像抓取完成。
        结果
        一个字节数组或一个int数组
        另请参见：
        getStatus() ， setPixels(int, int, int, int, ColorModel, byte[], int, int) ， setPixels(int, int, int, int, ColorModel, int[], int, int)

      • getColorModel

        public ColorModel getColorModel​()
        获取存储在数组中的像素的ColorModel。 如果PixelGrabber是使用显式像素缓冲区构建的，那么该方法将始终返回默认的RGB ColorModel，否则返回null，直到ImageProducer使用的ColorModel是已知的。 由于如果源图像使用多个ColorModel传送数据，PixelGrabber可能随时累积默认RGB ColorModel中的数据，因此此方法返回的ColorModel对象可能会随时间而变化，直到图像抓取完成，可能不会反映ImageProducer用于传送像素的任何ColorModel对象。
        结果
        用于存储像素的ColorModel对象
        另请参见：
        getStatus() ，
ColorModel.getRGBdefault() ，
setColorModel(ColorModel)

      • setDimensions

        public void setDimensions​(int width,
                          int height)
        setDimensions方法是ImageConsumer API的一部分，该类必须实现这个API来检索像素。

        注意：此方法旨在由图像的ImageProducer调用其像素被抓取。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setDimensions在接口 ImageConsumer
        参数
        width - 维度的宽度
        height - 尺寸的高度

      • setHints

        public void setHints​(int hints)
        setHints方法是ImageConsumer API的一部分，该类必须实现这个API来检索像素。

        注意：此方法旨在由图像的ImageProducer调用其像素被抓取。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setHints在接口 ImageConsumer
        参数
        hints - 一组用于处理像素的提示

      • setProperties

        public void setProperties​(Hashtable<?,?> props)
        setProperties方法是ImageConsumer API的一部分，该类必须实现以检索像素。

        注意：此方法旨在由图像的ImageProducer调用其像素被抓取。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setProperties在接口 ImageConsumer
        参数
        props - 属性列表

      • setColorModel

        public void setColorModel​(ColorModel model)
        setColorModel方法是ImageConsumer API的一部分，该类必须实现此方法来检索像素。

        注意：此方法旨在由图像的ImageProducer调用其像素被抓取。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setColorModel在接口 ImageConsumer
        参数
        model - 指定的 ColorModel
        另请参见：
        getColorModel()

      • setPixels

        public void setPixels​(int srcX,
                      int srcY,
                      int srcW,
                      int srcH,
                      ColorModel model,
                      byte[] pixels,
                      int srcOff,
                      int srcScan)
        setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。

        注意：此方法旨在由图像的ImageProducer调用其像素被抓取。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setPixels在接口 ImageConsumer
        参数
        srcX - 要设置的像素区域的左上角的X坐标
        srcY - 要设置的像素区域的左上角的Y坐标
        srcW - 像素面积的宽度
        srcH - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        srcOff - 像素数组的偏移量
        srcScan - 像素阵列中的一行像素到下一行的距离
        另请参见：
        getPixels()

      • setPixels

        public void setPixels​(int srcX,
                      int srcY,
                      int srcW,
                      int srcH,
                      ColorModel model,
                      int[] pixels,
                      int srcOff,
                      int srcScan)
        setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。

        注意：此方法旨在由图像的ImageProducer调用其像素被抓取。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        setPixels在接口 ImageConsumer
        参数
        srcX - 要设置的像素区域的左上角的X坐标
        srcY - 要设置的像素区域的左上角的Y坐标
        srcW - 像素面积的宽度
        srcH - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        srcOff - 像素数组的偏移量
        srcScan - 像素阵列中一行像素到下一行的距离
        另请参见：
        getPixels()

      • imageComplete

        public void imageComplete​(int status)
        imageComplete方法是ImageConsumer API的一部分，该类必须实现以检索像素。

        注意：此方法旨在由图像的ImageProducer调用其像素被抓取。 使用此类从图像中检索像素的开发人员应避免直接调用此方法，因为该操作可能导致检索所请求的像素时出现问题。

        Specified by:
        imageComplete在接口 ImageConsumer
        参数
        status - 图像加载的状态
        另请参见：
        ImageProducer.removeConsumer(java.awt.image.ImageConsumer)

      • status

        public int status​()
        返回像素的状态。 返回表示可用像素信息的ImageObserver标志。 该方法和getStatus具有相同的实现，但是getStatus是首选方法，因为它符合以“getXXX”形式命名信息检索方法的惯例。
        结果
        所有相关ImageObserver标志的按位OR
        另请参见：
        ImageObserver ， getStatus()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PixelInterleavedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class PixelInterleavedSampleModel

  • java.lang.Object
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
        • java.awt.image.PixelInterleavedSampleModel

  • public class PixelInterleavedSampleModel
extends ComponentSampleModel
    该类表示以像素交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。 它对ComponentSampleModel进行子类化，但是为ComponentSampleModel提供的访问像素交错图像数据提供了更有效的实现。 该类将DataBuffer的单个存储区中的所有频带的样本数据存储起来。 提供访问方法，以便可以直接操纵图像数据。 像素幅度是同一扫描线上同一频带的两个样本之间的数据数组元素数。 扫描线步幅是给定样本与下一个扫描线同一列中相应样本之间的数据数组元素数。 带偏移表示来自保持每个频带的DataBuffer组的第一数据阵列元素到该频带的第一个样本的数据数组元素的数量。 频带从0到N-1编号。 存储体索引表示数据缓冲器的存储体与图像数据的区段之间的对应关系。 该类支持TYPE_BYTE ， TYPE_USHORT ， TYPE_SHORT ， TYPE_INT ， TYPE_FLOAT和TYPE_DOUBLE数据类型。

    • Field Summary

      • Fields inherited from class java.awt.image.ComponentSampleModel

        bandOffsets, bankIndices, numBands, numBanks, pixelStride, scanlineStride

      • Fields inherited from class java.awt.image.SampleModel

        dataType, height, width

    • 构造方法摘要

      构造方法
      Constructor 描述
      PixelInterleavedSampleModel​(int dataType, int w, int h, int pixelStride, int scanlineStride, int[] bandOffsets)
      构造具有指定参数的PixelInterleavedSampleModel。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建一个具有指定宽度和高度的新PixelInterleavedSampleModel。
      SampleModel createSubsetSampleModel​(int[] bands)
      创建一个新的PixelInterleavedSampleModel与PixelInterleavedSampleModel的带子集。
      int hashCode​()
      返回对象的哈希码值。

      • Methods inherited from class java.awt.image.ComponentSampleModel

        createDataBuffer, equals, getBandOffsets, getBankIndices, getDataElements, getNumDataElements, getOffset, getOffset, getPixel, getPixels, getPixelStride, getSample, getSampleDouble, getSampleFloat, getSamples, getSampleSize, getSampleSize, getScanlineStride, setDataElements, setPixel, setPixels, setSample, setSample, setSample, setSamples

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.image.SampleModel

        getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSamples, setSamples

    • 构造方法详细信息

      • PixelInterleavedSampleModel

        public PixelInterleavedSampleModel​(int dataType,
                                   int w,
                                   int h,
                                   int pixelStride,
                                   int scanlineStride,
                                   int[] bandOffsets)
        构造具有指定参数的PixelInterleavedSampleModel。 带宽的数量将由bandOffsets数组的长度给出。
        参数
        dataType - 用于存储样本的数据类型。
        w - 描述的图像数据区域的宽度（以像素为单位）。
        h - 描述的图像数据区域的高度（以像素为单位）。
        pixelStride - 图像数据的像素步幅。
        scanlineStride - 图像数据的行走。
        bandOffsets - 所有乐队的偏移量。
        异常
        IllegalArgumentException - 如果 w或 h不大于0
        IllegalArgumentException - 如果带之间的任何偏移大于扫描线步幅
        IllegalArgumentException - 如果 pixelStride和 w的产品大于 scanlineStride
        IllegalArgumentException - 如果 pixelStride小于频带之间的任何偏移量
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

    • 方法详细信息

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建一个具有指定宽度和高度的新PixelInterleavedSampleModel。 新的PixelInterleavedSampleModel将具有与PixelInterleavedSampleModel相同数量的带，存储数据类型和像素跨度。 频带偏移可以被压缩，使得所有频带偏移的最小值为零。
        重写：
        createCompatibleSampleModel在 ComponentSampleModel
        参数
        w - 所得的宽度 SampleModel
        h - 所得的高度 SampleModel
        结果
        一个新的 SampleModel具有指定的宽度和高度。
        异常
        IllegalArgumentException - 如果 w或 h不大于0

      • createSubsetSampleModel

        public SampleModel createSubsetSampleModel​(int[] bands)
        创建一个新的PixelInterleavedSampleModel与PixelInterleavedSampleModel的带子集。 新的PixelInterleavedSampleModel可以与现有PixelInterleavedSampleModel可以一起使用的任何DataBuffer使用。 新的PixelInterleavedSampleModel / DataBuffer组合将表示具有原始PixelInterleavedSampleModel / DataBuffer组合的带子集的图像。
        重写：
        createSubsetSampleModel在 ComponentSampleModel
        参数
        bands - 这个 ComponentSampleModel一个子集
        结果
        一个 ComponentSampleModel用这个 ComponentSampleModel的带子子集创建。

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap所提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 ComponentSampleModel
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Raster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class Raster

  • java.lang.Object
    • java.awt.image.Raster
  • 已知直接子类：
    WritableRaster

    public class Raster
extends Object
    表示矩形像素阵列的类。 光栅封装存储示例值的DataBuffer和一个描述如何在DataBuffer中定位给定样本值的SampleModel。

    光栅定义占据平面的特定矩形区域的像素的值，不一定包括（0,0）。 被称为光栅的边界矩形并通过getBounds方法可用的矩形由minX，minY，width和height值定义。 minX和minY值定义栅格左上角的坐标。 对边界矩形外的像素的引用可能导致抛出异常，或者可能导致引用栅格相关联的DataBuffer的非预期元素。 用户有责任避免访问这些像素。

    SampleModel描述了栅格的样本如何存储在DataBuffer的基元数组元素中。 样本可以像PixelInterleavedSampleModel或BandedSampleModel中的每个数据元素一样存储，或者将多个数据包装到一个元素中，如在SinglePixelPackedSampleModel或MultiPixelPackedSampleModel中。 SampleModel还控制样本是否进行符号扩展，允许将未签名的数据存储在已签名的Java数据类型（如byte，short和int）中。

    虽然光栅可能存在于飞机上的任何位置，但是SampleModel使用从（0，0）开始的简单坐标系。 因此，栅格包含一个翻译因子，允许在栅格坐标系和SampleModel坐标系之间映射像素位置。 通过getSampleModelTranslateX和getSampleModelTranslateY方法可以从SampleModel坐标系转换为栅格的坐标系。

    栅格可以通过显式构造或通过使用createChild和createTranslatedChild方法与另一个栅格共享DataBuffer。 通过这些方法创建的栅格可以通过getParent方法返回对其创建的栅格的引用。 对于没有通过调用createTranslatedChild或createChild构造的栅格，getParent将返回null。

    createTranslatedChild方法返回一个新的Raster，它共享当前栅格的所有数据，但占用一个相同宽度和高度但具有不同起始点的边界矩形。 例如，如果父栅格占据了区域（10,10）到（100,100），并且被翻译的栅格被定义为在（50,50）处开始，则父像素（像素（20,20） 60，60）在两个Raster共享的DataBuffer中占据相同的位置。 在第一种情况下，应将（-10，-10）添加到像素坐标中以获得相应的SampleModel坐标，并且在第二种情况下（-50，-50）应该被添加。

    父子节点之间的转换光栅可以通过从父节点的子像素中减去子样本的SampleModelTranslateX和sampleModelTranslateY值来确定。

    createChild方法可以用于创建一个新的栅格，它只占据其父层的边界矩形（具有相同或翻译的坐标系）的子集，或者与其父层的子集。

    所有构造函数都受到保护。 创建光栅的正确方法是使用此类中定义的静态创建方法之一。 这些方法创建使用标准交错，带状和打包样品模型的栅格实例，并且可以比通过组合外部生成的SampleModel和DataBuffer创建的栅格更有效地处理栅格。

    另请参见：
    DataBuffer ， SampleModel ， PixelInterleavedSampleModel ， BandedSampleModel ， SinglePixelPackedSampleModel ， MultiPixelPackedSampleModel

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected DataBuffer dataBuffer
      DataBuffer存储图像数据。
      protected int height
      这个光栅的高度。
      protected int minX
      此栅格左上角像素的X坐标。
      protected int minY
      此光栅左上角像素的Y坐标。
      protected int numBands
      光栅中的乐队数。
      protected int numDataElements
      每像素DataBuffer数据元素的数量。
      protected Raster parent
      此栅格的父项，或null。
      protected SampleModel sampleModel
      SampleModel描述了这个栅格的像素如何存储在DataBuffer中。
      protected int sampleModelTranslateX
      从Raster的SampleModel的坐标空间到光栅的X平移。
      protected int sampleModelTranslateY
      从Raster的SampleModel的坐标空间到栅格的坐标空间的Y翻译。
      protected int width
      这个光栅的宽度。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造光栅。
      protected Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
      使用给定的SampleModel，DataBuffer和父构造栅格。
      protected Raster​(SampleModel sampleModel, Point origin)
      使用给定的SampleModel构造光栅。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static WritableRaster createBandedRaster​(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location)
      基于具有指定数据类型，宽度，高度，扫描线步长，银行索引和带偏移的BandedSampleModel创建光栅。
      static WritableRaster createBandedRaster​(int dataType, int w, int h, int bands, Point location)
      根据具有指定数据类型，宽度，高度和频带数的BandedSampleModel创建栅格。
      static WritableRaster createBandedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location)
      根据指定的DataBuffer，width，height，scanline stride，bank index和band offsets创建一个基于BandedSampleModel的光栅。
      Raster createChild​(int parentX, int parentY, int width, int height, int childMinX, int childMinY, int[] bandList)
      返回一个新的Raster，它共享此Raster DataBuffer的全部或部分。
      WritableRaster createCompatibleWritableRaster​()
      创建与此Raster相同大小的兼容WritableRaster，具有相同的SampleModel和新的已初始化的DataBuffer。
      WritableRaster createCompatibleWritableRaster​(int w, int h)
      创建一个具有指定大小的兼容WritableRaster，一个新的SampleModel和一个新的初始化DataBuffer。
      WritableRaster createCompatibleWritableRaster​(int x, int y, int w, int h)
      创建一个兼容的WritableRaster，具有指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。
      WritableRaster createCompatibleWritableRaster​(Rectangle rect)
      创建一个兼容的WritableRaster，它具有由rect指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。
      static WritableRaster createInterleavedRaster​(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location)
      基于具有指定数据类型，宽度，高度，扫描线步长，像素步长和带偏移的PixelInterleavedSampleModel创建光栅。
      static WritableRaster createInterleavedRaster​(int dataType, int w, int h, int bands, Point location)
      基于具有指定数据类型，宽度，高度和频带数的PixelInterleavedSampleModel创建光栅。
      static WritableRaster createInterleavedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长，像素步幅和带偏移的PixelInterleavedSampleModel创建光栅。
      static WritableRaster createPackedRaster​(int dataType, int w, int h, int[] bandMasks, Point location)
      基于具有指定数据类型，宽度，高度和带屏蔽的SinglePixelPackedSampleModel创建光栅。
      static WritableRaster createPackedRaster​(int dataType, int w, int h, int bands, int bitsPerBand, Point location)
      根据指定的数据类型，宽度，高度，频带数和每个频段的位数，打包SampleModel创建光栅。
      static WritableRaster createPackedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长和带屏蔽的SinglePixelPackedSampleModel创建光栅。
      static WritableRaster createPackedRaster​(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location)
      基于具有指定DataBuffer，宽度，高度和每像素位数的MultiPixelPackedSampleModel创建光栅。
      static Raster createRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建光栅。
      Raster createTranslatedChild​(int childMinX, int childMinY)
      创建一个具有相同大小的光栅，SampleModel和DataBuffer，但是具有不同的位置。
      static WritableRaster createWritableRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建WritableRaster。
      static WritableRaster createWritableRaster​(SampleModel sm, Point location)
      使用指定的SampleModel创建WritableRaster。
      Rectangle getBounds​()
      返回此栅格的边界矩形。
      DataBuffer getDataBuffer​()
      返回与此栅格相关联的DataBuffer。
      Object getDataElements​(int x, int y, int w, int h, Object outData)
      返回TransferType类型的原始数组中指定的像素矩形的像素数据。
      Object getDataElements​(int x, int y, Object outData)
      返回TransferType类型的原始数组中单个像素的数据。
      int getHeight​()
      返回栅格的高度（像素）。
      int getMinX​()
      返回栅格的最小有效X坐标。
      int getMinY​()
      返回栅格的最小有效Y坐标。
      int getNumBands​()
      返回此光栅中的带数（每像素的样本数）。
      int getNumDataElements​()
      返回通过getDataElements和setDataElements方法传输一个像素所需的数据元素数。
      Raster getParent​()
      返回此栅格的父栅格（如果有）或null。
      double[] getPixel​(int x, int y, double[] dArray)
      返回指定像素的double数组中的样本。
      float[] getPixel​(int x, int y, float[] fArray)
      返回指定像素的float数组中的样本。
      int[] getPixel​(int x, int y, int[] iArray)
      返回指定像素的int数组中的样本。
      double[] getPixels​(int x, int y, int w, int h, double[] dArray)
      返回一个包含像素矩形的所有样本的双数组，每个数组元素一个样本。
      float[] getPixels​(int x, int y, int w, int h, float[] fArray)
      返回一个float数组，其中包含一个像素矩形的所有样本，每个数组元素一个样本。
      int[] getPixels​(int x, int y, int w, int h, int[] iArray)
      返回一个包含矩形像素的所有样本的int数组，每个数组元素一个样本。
      int getSample​(int x, int y, int b)
      将位于（x，y）处的像素的指定带中的样本返回为int。
      double getSampleDouble​(int x, int y, int b)
      将位于（x，y）的像素的指定带中的样本返回为双倍。
      float getSampleFloat​(int x, int y, int b)
      将位于（x，y）处的像素的指定带中的样本作为浮点返回。
      SampleModel getSampleModel​()
      返回描述图像数据布局的SampleModel。
      int getSampleModelTranslateX​()
      从SampleModel的坐标系返回到Raster的X转换。
      int getSampleModelTranslateY​()
      从SampleModel的坐标系返回到Raster的Y转换。
      double[] getSamples​(int x, int y, int w, int h, int b, double[] dArray)
      返回双阵列中指定的像素矩形的指定波段的样本，每个数组元素一个样本。
      float[] getSamples​(int x, int y, int w, int h, int b, float[] fArray)
      返回浮点数组中指定的像素矩形的指定波段的样本，每个数组元素一个样本。
      int[] getSamples​(int x, int y, int w, int h, int b, int[] iArray)
      返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。
      int getTransferType​()
      返回用于通过getDataElements和setDataElements方法传输像素的TransferType。
      int getWidth​()
      返回栅格宽度（以像素为单位）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • sampleModel

        protected SampleModel sampleModel
        SampleModel描述了这个栅格的像素如何存储在DataBuffer中。

      • dataBuffer

        protected DataBuffer dataBuffer
        DataBuffer存储图像数据。

      • minX

        protected int minX
        此栅格左上角像素的X坐标。

      • minY

        protected int minY
        此光栅左上角像素的Y坐标。

      • width

        protected int width
        这个光栅的宽度。

      • height

        protected int height
        这个光栅的高度。

      • sampleModelTranslateX

        protected int sampleModelTranslateX
        从Raster的SampleModel的坐标空间到光栅的X平移。

      • sampleModelTranslateY

        protected int sampleModelTranslateY
        从Raster的SampleModel的坐标空间到栅格的坐标空间的Y翻译。

      • numBands

        protected int numBands
        光栅中的乐队数。

      • numDataElements

        protected int numDataElements
        每像素DataBuffer数据元素的数量。

      • parent

        protected Raster parent
        此栅格的父项，或null。

    • 构造方法详细信息

      • Raster

        protected Raster​(SampleModel sampleModel,
                 Point origin)
        使用给定的SampleModel构造光栅。 光栅的左上角是原点，它与SampleModel的大小相同。 自动创建一个足够大的描述光栅的DataBuffer。
        参数
        sampleModel - 指定布局的SampleModel
        origin - 指定原点的点
        异常
        RasterFormatException - 如果计算 origin.x + sampleModel.getWidth()或 origin.y + sampleModel.getHeight()导致整数溢出
        NullPointerException - sampleModel或 origin为空

      • Raster

        protected Raster​(SampleModel sampleModel,
                 DataBuffer dataBuffer,
                 Point origin)
        使用给定的SampleModel和DataBuffer构造光栅。 光栅的左上角是原点，它与SampleModel的大小相同。 DataBuffer未初始化，必须与SampleModel兼容。
        参数
        sampleModel - 指定布局的SampleModel
        dataBuffer - 包含图像数据的DataBuffer
        origin - 指定原点的点
        异常
        RasterFormatException - 如果计算 origin.x + sampleModel.getWidth()或 origin.y + sampleModel.getHeight()导致整数溢出
        NullPointerException - sampleModel或 origin为null

      • Raster

        protected Raster​(SampleModel sampleModel,
                 DataBuffer dataBuffer,
                 Rectangle aRegion,
                 Point sampleModelTranslate,
                 Raster parent)
        使用给定的SampleModel，DataBuffer和父构造栅格。 aRegion指定新栅格的边界矩形。 当翻译成基础栅格的坐标系时，aRegion必须由基础栅格包含。 （基础栅格是没有父项的栅格的祖先。）sampleModelTranslate指定新的栅格的sampleModelTranslateX和sampleModelTranslateY值。 请注意，这个构造函数通常应该由其他构造函数调用或创建方法，不应该直接使用。
        参数
        sampleModel - 指定布局的SampleModel
        dataBuffer - 包含图像数据的DataBuffer
        aRegion - 指定图像区域的Rectangle
        sampleModelTranslate - 指定从SampleModel到光栅坐标的转换的点
        parent - 此栅格的父（如果有）
        异常
        NullPointerException -如果任何 sampleModel ， dataBuffer ， aRegion或者 sampleModelTranslate为null
        RasterFormatException - 如果 aRegion宽度或高度小于或等于零，或计算 aRegion.x + aRegion.width或 aRegion.y + aRegion.height导致整数溢出

    • 方法详细信息

      • createInterleavedRaster

        public static WritableRaster createInterleavedRaster​(int dataType,
                                                     int w,
                                                     int h,
                                                     int bands,
                                                     Point location)
        基于具有指定数据类型，宽度，高度和频带数的PixelInterleavedSampleModel创建光栅。

        光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。 dataType参数应该是DataBuffer类中定义的枚举值之一。

        请注意，不支持交织的DataBuffer.TYPE_INT 。 要创建一个类型为DataBuffer.TYPE_INT的1波段光栅，请使用Raster.createPackedRaster（）。

        目前唯一支持的数据类型是TYPE_BYTE和TYPE_USHORT。

        参数
        dataType - 存储样本的数据类型
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        bands - 乐队的数量
        location - Raster
        结果
        具有指定数据类型，宽度，高度和频带数的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出

      • createInterleavedRaster

        public static WritableRaster createInterleavedRaster​(int dataType,
                                                     int w,
                                                     int h,
                                                     int scanlineStride,
                                                     int pixelStride,
                                                     int[] bandOffsets,
                                                     Point location)
        基于具有指定数据类型，宽度，高度，扫描线步长，像素步长和带偏移的PixelInterleavedSampleModel创建光栅。 频带数由bandOffsets.length推断出来。

        光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。 dataType参数应该是DataBuffer类中定义的枚举值之一。

        请注意，不支持交织的DataBuffer.TYPE_INT栅格。 要创建一个类型为DataBuffer.TYPE_INT的1波段光栅，请使用Raster.createPackedRaster（）。

        目前唯一支持的数据类型是TYPE_BYTE和TYPE_USHORT。

        参数
        dataType - 存储样本的数据类型
        w - 图像数据的像素宽度
        h - 图像数据的高度（以像素为单位）
        scanlineStride - 图像数据的行走
        pixelStride - 图像数据的像素步幅
        bandOffsets - 所有频带的偏移量
        location - 左上角的 Raster
        结果
        具有指定数据类型，宽度，高度，扫描线步长，像素步幅和带偏移的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一，即 DataBuffer.TYPE_BYTE或 DataBuffer.TYPE_USHORT 。

      • createBandedRaster

        public static WritableRaster createBandedRaster​(int dataType,
                                                int w,
                                                int h,
                                                int bands,
                                                Point location)
        根据具有指定数据类型，宽度，高度和频带数的BandedSampleModel创建栅格。

        光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。 dataType参数应该是DataBuffer类中定义的枚举值之一。

        目前唯一支持的数据类型是TYPE_BYTE，TYPE_USHORT和TYPE_INT。

        参数
        dataType - 存储样本的数据类型
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        bands - 乐队的数量
        location - 左上角的 Raster
        结果
        具有指定数据类型，宽度，高度和频带数的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        ArrayIndexOutOfBoundsException - 如果 bands小于1

      • createBandedRaster

        public static WritableRaster createBandedRaster​(int dataType,
                                                int w,
                                                int h,
                                                int scanlineStride,
                                                int[] bankIndices,
                                                int[] bandOffsets,
                                                Point location)
        基于具有指定数据类型，宽度，高度，扫描线步长，银行索引和带偏移的BandedSampleModel创建光栅。 band的数量是由bankIndices.length和bandOffsets.length推断的，它们必须相同。

        光栅的左上角由位置参数给出。 dataType参数应该是DataBuffer类中定义的枚举值之一。

        目前唯一支持的数据类型是TYPE_BYTE，TYPE_USHORT和TYPE_INT。

        参数
        dataType - 存储样本的数据类型
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        scanlineStride - 图像数据的行走
        bankIndices - 每个乐队的银行指数
        bandOffsets - 所有频段的偏移量
        location - 左上角的 Raster
        结果
        具有指定数据类型，宽度，高度，扫描线步长，库索引和带偏移的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException -如果 dataType是不支持的数据类型，这是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT或 DataBuffer.TYPE_INT
        ArrayIndexOutOfBoundsException - 如果 bankIndices或 bandOffsets是 null

      • createPackedRaster

        public static WritableRaster createPackedRaster​(int dataType,
                                                int w,
                                                int h,
                                                int[] bandMasks,
                                                Point location)
        基于具有指定数据类型，宽度，高度和带屏蔽的SinglePixelPackedSampleModel创建光栅。 频带的数量是从bandMasks.length推断出来的。

        光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。 dataType参数应该是DataBuffer类中定义的枚举值之一。

        目前唯一支持的数据类型是TYPE_BYTE，TYPE_USHORT和TYPE_INT。

        参数
        dataType - 存储样本的数据类型
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        bandMasks - 包含每个频带的条目的数组
        location - 左上角的 Raster
        结果
        具有指定数据类型，宽度，高度和带掩码的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException -如果 dataType是不支持的数据类型，这是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT或 DataBuffer.TYPE_INT

      • createPackedRaster

        public static WritableRaster createPackedRaster​(int dataType,
                                                int w,
                                                int h,
                                                int bands,
                                                int bitsPerBand,
                                                Point location)
        根据指定的数据类型，宽度，高度，频带数和每个频段的位数，打包SampleModel创建光栅。 如果频带数为1，则SampleModel将为MultiPixelPackedSampleModel。

        如果频带数多于一个，则SampleModel将为SinglePixelPackedSampleModel，每个频带都具有位数位数。 在任何一种情况下，必须满足相应SampleModel对dataType和bitsPerBand的要求。

        光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。 dataType参数应该是DataBuffer类中定义的枚举值之一。

        目前唯一支持的数据类型是TYPE_BYTE，TYPE_USHORT和TYPE_INT。

        参数
        dataType - 存储样本的数据类型
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        bands - 乐队的数量
        bitsPerBand - 每个频段的位数
        location - 左上角的 Raster
        结果
        具有指定数据类型，宽度，高度，频带数和每个频带位的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException - 如果 bitsPerBand和 bands的产品大于持有的位数 dataType
        IllegalArgumentException - 如果 bitsPerBand或 bands不大于零
        IllegalArgumentException -如果 dataType是不支持的数据类型，这是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT或 DataBuffer.TYPE_INT

      • createInterleavedRaster

        public static WritableRaster createInterleavedRaster​(DataBuffer dataBuffer,
                                                     int w,
                                                     int h,
                                                     int scanlineStride,
                                                     int pixelStride,
                                                     int[] bandOffsets,
                                                     Point location)
        基于具有指定DataBuffer，宽度，高度，扫描线步长，像素步幅和带偏移的PixelInterleavedSampleModel创建光栅。 频带数由bandOffsets.length推断出来。 光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。

        请注意，不支持交织的DataBuffer.TYPE_INT栅格。 要创建类型为DataBuffer.TYPE_INT的1波段光栅，请使用Raster.createPackedRaster（）。

        参数
        dataBuffer - 包含图像数据的 DataBuffer
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        scanlineStride - 图像数据的行走
        pixelStride - 图像数据的像素步幅
        bandOffsets - 所有频带的偏移量
        location - 左上角的 Raster
        结果
        具有指定的 DataBuffer的WritableRaster对象，宽度，高度，扫描线步幅，像素步幅和带偏移。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException -如果 dataType是不支持的数据类型，这是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT
        RasterFormatException - 如果 dataBuffer有多个银行。
        NullPointerException - 如果 dataBuffer为空

      • createBandedRaster

        public static WritableRaster createBandedRaster​(DataBuffer dataBuffer,
                                                int w,
                                                int h,
                                                int scanlineStride,
                                                int[] bankIndices,
                                                int[] bandOffsets,
                                                Point location)
        根据指定的DataBuffer，width，height，scanline stride，bank index和band offsets创建一个基于BandedSampleModel的光栅。 band的数量是由bankIndices.length和bandOffsets.length推断的，它们必须相同。 光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。
        参数
        dataBuffer - 包含图像数据的 DataBuffer
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        scanlineStride - 图像数据的行走
        bankIndices - 每个乐队的银行指数
        bandOffsets - 所有频段的偏移量
        location - 左上角的 Raster
        结果
        具有指定的 DataBuffer的WritableRaster对象，宽度，高度，扫描线步长，银行索引和带偏移。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException -如果 dataType是不支持的数据类型，这是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT或 DataBuffer.TYPE_INT
        NullPointerException - 如果 dataBuffer为空

      • createPackedRaster

        public static WritableRaster createPackedRaster​(DataBuffer dataBuffer,
                                                int w,
                                                int h,
                                                int scanlineStride,
                                                int[] bandMasks,
                                                Point location)
        基于具有指定DataBuffer，宽度，高度，扫描线步长和带屏蔽的SinglePixelPackedSampleModel创建光栅。 频带的数量是从bandMasks.length推断出来的。 光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。
        参数
        dataBuffer - 包含图像数据的 DataBuffer
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的高度（像素）
        scanlineStride - 图像数据的行走
        bandMasks - 一个包含每个频带条目的数组
        location - 左上角的 Raster
        结果
        具有指定的 DataBuffer ，宽度，高度，扫描线步幅和带屏蔽的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException -如果 dataType是不支持的数据类型，这是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT或 DataBuffer.TYPE_INT
        RasterFormatException - 如果 dataBuffer有多个银行。
        NullPointerException - 如果 dataBuffer为空

      • createPackedRaster

        public static WritableRaster createPackedRaster​(DataBuffer dataBuffer,
                                                int w,
                                                int h,
                                                int bitsPerPixel,
                                                Point location)
        基于具有指定DataBuffer，宽度，高度和每像素位数的MultiPixelPackedSampleModel创建光栅。 光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。
        参数
        dataBuffer - 包含图像数据的 DataBuffer
        w - 图像数据的宽度（以像素为单位）
        h - 图像数据的像素高度
        bitsPerPixel - 每个像素的位数
        location - 左上角的 Raster
        结果
        具有指定 DataBuffer ，宽度，高度和每像素位数的WritableRaster对象。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 location.x + w或 location.y + h导致整数溢出
        IllegalArgumentException -如果 dataType是不支持的数据类型，这是一个 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT或 DataBuffer.TYPE_INT
        RasterFormatException - 如果 dataBuffer有多个银行。
        NullPointerException - 如果 dataBuffer为空

      • createRaster

        public static Raster createRaster​(SampleModel sm,
                                  DataBuffer db,
                                  Point location)
        使用指定的SampleModel和DataBuffer创建光栅。 光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。
        参数
        sm - 指定的 SampleModel
        db - 指定的 DataBuffer
        location - 左上角的 Raster
        结果
        一个 Raster具有指定 SampleModel ， DataBuffer ，和位置。
        异常
        RasterFormatException - 如果计算 location.x + sm.getWidth()或 location.y + sm.getHeight()导致整数溢出
        RasterFormatException - 如果 db有多个银行，而 sm是PixelInterleavedSampleModel，SinglePixelPackedSampleModel或MultiPixelPackedSampleModel。
        NullPointerException - 如果SampleModel或DataBuffer为null

      • createWritableRaster

        public static WritableRaster createWritableRaster​(SampleModel sm,
                                                  Point location)
        使用指定的SampleModel创建WritableRaster。 光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。
        参数
        sm - 指定的 SampleModel
        location - WritableRaster
        结果
        一个 WritableRaster与指定的 SampleModel和位置。
        异常
        RasterFormatException - 如果计算 location.x + sm.getWidth()或 location.y + sm.getHeight()导致整数溢出

      • createWritableRaster

        public static WritableRaster createWritableRaster​(SampleModel sm,
                                                  DataBuffer db,
                                                  Point location)
        使用指定的SampleModel和DataBuffer创建WritableRaster。 光栅的左上角由位置参数给出。 如果位置为空，则使用（0，0）。
        参数
        sm - 指定的 SampleModel
        db - 指定的 DataBuffer
        location - WritableRaster
        结果
        一个 WritableRaster具有指定 SampleModel ， DataBuffer ，和位置。
        异常
        RasterFormatException - 如果计算 location.x + sm.getWidth()或 location.y + sm.getHeight()导致整数溢出
        RasterFormatException - 如果 db有多个银行，而 sm是PixelInterleavedSampleModel，SinglePixelPackedSampleModel或MultiPixelPackedSampleModel。
        NullPointerException - 如果SampleModel或DataBuffer为null

      • getParent

        public Raster getParent​()
        返回此栅格的父栅格（如果有）或null。
        结果
        父 null或 null 。

      • getSampleModelTranslateX

        public final int getSampleModelTranslateX​()
        从SampleModel的坐标系返回到Raster的X转换。 要将像素的X坐标从光栅坐标系转换为SampleModel坐标系，必须减去此值。
        结果
        从Raster的SampleModel的坐标空间到光栅的X平移。

      • getSampleModelTranslateY

        public final int getSampleModelTranslateY​()
        从SampleModel的坐标系返回到Raster的Y转换。 要将像素的Y坐标从光栅坐标系转换为SampleModel坐标系，必须减去此值。
        结果
        从Raster的SampleModel的坐标空间到Raster的坐标空间的Y翻译。

      • createCompatibleWritableRaster

        public WritableRaster createCompatibleWritableRaster​()
        创建与此Raster相同大小的兼容WritableRaster，具有相同的SampleModel和新的已初始化的DataBuffer。
        结果
        兼容的 WritableRaster具有相同的样本模型和新的数据缓冲区。

      • createCompatibleWritableRaster

        public WritableRaster createCompatibleWritableRaster​(int w,
                                                     int h)
        创建一个具有指定大小的兼容WritableRaster，一个新的SampleModel和一个新的初始化DataBuffer。
        参数
        w - 新的 WritableRaster的指定宽度
        h - 新的 WritableRaster的指定高度
        结果
        具有指定大小的兼容的 WritableRaster和新的样本模型和数据缓冲区。
        异常
        RasterFormatException - 如果宽度或高度小于或等于零。

      • createCompatibleWritableRaster

        public WritableRaster createCompatibleWritableRaster​(Rectangle rect)
        创建一个兼容的WritableRaster，它具有由rect指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。
        参数
        rect - 一个规定 Rectangle的大小和位置的 WritableRaster
        结果
        具有指定大小和位置的兼容的 WritableRaster和新的样本模型和数据缓冲区。
        异常
        RasterFormatException - 如果 rect宽度或高度小于或等于零，或计算 rect.x + rect.width或 rect.y + rect.height导致整数溢出
        NullPointerException - 如果 rect为空

      • createCompatibleWritableRaster

        public WritableRaster createCompatibleWritableRaster​(int x,
                                                     int y,
                                                     int w,
                                                     int h)
        创建一个兼容的WritableRaster，具有指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。
        参数
        x -在X中的左上角坐标 WritableRaster
        y -的Y的左上角坐标 WritableRaster
        w - 指定的宽度为 WritableRaster
        h - 指定的高度为 WritableRaster
        结果
        具有指定大小和位置的兼容的 WritableRaster和新的样本模型和数据缓冲区。
        异常
        RasterFormatException - 如果 w或 h小于或等于零，或计算 x + w或 y + h导致整数溢出

      • createTranslatedChild

        public Raster createTranslatedChild​(int childMinX,
                                    int childMinY)
        创建一个具有相同大小的光栅，SampleModel和DataBuffer，但是具有不同的位置。 新的光栅将具有对当前光栅的引用，可通过其getParent（）方法访问。
        参数
        childMinX - 新的 Raster左上角的X坐标
        childMinY - 新的 Raster左上角的Y坐标
        结果
        一个新的 Raster具有相同的大小，SampleModel和DataBuffer这个 Raster ，但是具有指定的位置。
        异常
        RasterFormatException - 如果计算 childMinX + this.getWidth()或 childMinY + this.getHeight()导致整数溢出

      • createChild

        public Raster createChild​(int parentX,
                          int parentY,
                          int width,
                          int height,
                          int childMinX,
                          int childMinY,
                          int[] bandList)
        返回一个新的Raster，它共享此Raster DataBuffer的全部或部分。 新的光栅将具有对当前光栅的引用，可通过其getParent（）方法访问。

        parentX，parentY，width和height参数在此栅格坐标空间中形成一个Rectangle，指示要共享的像素面积。 如果此Rectangle不包含当前栅格的边界，将抛出一个错误。

        新的光栅可以另外被转换为与当前光栅所使用的平面不同的坐标系。 childMinX和childMinY参数给出返回的Raster的左上角像素的新（x，y）坐标; 新栅格中的坐标（childMinX，childMinY）将映射到与当前栅格中的坐标（parentX，parentY）相同的像素。

        新的栅格可以被定义为仅通过bandList参数仅包含当前栅格的可能重新排序的波段的子集。 如果bandList为null，则将其当前顺序包括当前栅格的所有频带。

        要创建一个包含当前栅格的子区域的新栅格，但共享其坐标系和带，则该方法应该调用childMinX等于parentX，childMinY等于parentY，bandList等于null。

        参数
        parentX - 此栅格坐标中左上角的X坐标
        parentY - 此栅格坐标中左上角的Y坐标
        width - 从（parentX，parentY）开始的区域的宽度
        height - 从（parentX，parentY）开始的区域的高度。
        childMinX - 返回光栅左上角的X坐标
        childMinY - 返回光栅左上角的Y坐标
        bandList - 频带索引的数组，或为空使用所有频带
        结果
        一个新的 Raster 。
        异常
        RasterFormatException - 如果指定的子区域在栅格边界之外。
        RasterFormatException -如果 width或 height小于或等于0，或者计算任何的 parentX + width ， parentY + height ， childMinX + width ，或 childMinY + height导致整数溢出

      • getBounds

        public Rectangle getBounds​()
        返回此栅格的边界矩形。 此函数返回与getMinX / MinY / Width / Height相同的信息。
        结果
        这个 Raster的边框。

      • getMinX

        public final int getMinX​()
        返回栅格的最小有效X坐标。
        结果
        这个 Raster的最小x坐标。

      • getMinY

        public final int getMinY​()
        返回栅格的最小有效Y坐标。
        结果
        这个 Raster的最小y坐标。

      • getWidth

        public final int getWidth​()
        返回栅格宽度（以像素为单位）。
        结果
        该宽度为 Raster 。

      • getHeight

        public final int getHeight​()
        返回栅格的高度（像素）。
        结果
        这个高度这个 Raster 。

      • getNumBands

        public final int getNumBands​()
        返回此光栅中的带数（每像素的样本数）。
        结果
        这个 Raster的乐队的 Raster 。

      • getNumDataElements

        public final int getNumDataElements​()
        返回通过getDataElements和setDataElements方法传输一个像素所需的数据元素数。 当通过这些方法传输像素时，可以根据底层SampleModel的实现，以打包或打包的格式传输它们。 使用这些方法，像素被传递给由getTransferType（）给出的原始类型的getNumDataElements（）元素的数组。 TransferType可能与DataBuffer的存储数据类型相同或不同。
        结果
        数据元素的数量。

      • getTransferType

        public final int getTransferType​()
        返回用于通过getDataElements和setDataElements方法传输像素的TransferType。 当通过这些方法传输像素时，可以根据底层SampleModel的实现，以打包或打包的格式传输它们。 使用这些方法，像素被传递给由getTransferType（）给出的原始类型的getNumDataElements（）元素的数组。 TransferType可能与DataBuffer的存储数据类型相同或不同。 TransferType将是DataBuffer中定义的类型之一。
        结果
        这种转移类型。

      • getDataBuffer

        public DataBuffer getDataBuffer​()
        返回与此栅格相关联的DataBuffer。
        结果
        该 DataBuffer的 Raster 。

      • getSampleModel

        public SampleModel getSampleModel​()
        返回描述图像数据布局的SampleModel。
        结果
        该 SampleModel的这个 Raster 。

      • getDataElements

        public Object getDataElements​(int x,
                              int y,
                              Object outData)
        返回TransferType类型的原始数组中单个像素的数据。 对于Java 2D（tm）API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 数据可以以压缩格式返回，从而提高数据传输的效率。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。 如果输入对象为非空，则引用ClassCastException，并引用除TransferType数组以外的任何内容。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        outData - 由getTransferType（）和length getNumDataElements（）定义的类型数组的对象引用。 如果为null，则将分配适当类型和大小的数组
        结果
        由getTransferType（）与请求的像素数据定义的类型的数组的对象引用。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不是边界，或者outData太小，不能容纳输出。
        另请参见：
        SampleModel.getDataElements(int, int, Object, DataBuffer)

      • getDataElements

        public Object getDataElements​(int x,
                              int y,
                              int w,
                              int h,
                              Object outData)
        返回TransferType类型的原始数组中指定的像素矩形的像素数据。 对于Java 2D API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 数据可以以压缩格式返回，从而提高数据传输的效率。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。 如果输入对象为非空，则引用ClassCastException，并引用除TransferType数组以外的任何内容。
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        outData - 由getTransferType（）和length w * h * getNumDataElements（）定义的类型的数组的对象引用。 如果为null，则将分配适当类型和大小的数组。
        结果
        由getTransferType（）与请求的像素数据定义的类型的数组的对象引用。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者outData太小，不能容纳输出。
        另请参见：
        SampleModel.getDataElements(int, int, int, int, Object, DataBuffer)

      • getPixel

        public int[] getPixel​(int x,
                      int y,
                      int[] iArray)
        返回指定像素的int数组中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        iArray - 可选的预分配int数组
        结果
        指定像素的样本。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输出。

      • getPixel

        public float[] getPixel​(int x,
                        int y,
                        float[] fArray)
        返回指定像素的float数组中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        fArray - 可选的预分配浮点数组
        结果
        指定像素的样本。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果fArray太小，不能容纳输出。

      • getPixel

        public double[] getPixel​(int x,
                         int y,
                         double[] dArray)
        返回指定像素的double数组中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        dArray - 可选的预分配双阵列
        结果
        指定像素的样本。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果dArray太小，不能容纳输出。

      • getPixels

        public int[] getPixels​(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray)
        返回一个包含矩形像素的所有样本的int数组，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        iArray - 可选预先分配的int数组
        结果
        指定像素矩形的样本。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者如果iArray太小，不能容纳输出。

      • getPixels

        public float[] getPixels​(int x,
                         int y,
                         int w,
                         int h,
                         float[] fArray)
        返回一个float数组，其中包含一个像素矩形的所有样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        fArray - 可选预先分配的浮点数组
        结果
        指定像素矩形的样本。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果fArray太小，不能容纳输出。

      • getPixels

        public double[] getPixels​(int x,
                          int y,
                          int w,
                          int h,
                          double[] dArray)
        返回一个包含像素矩形的所有样本的双数组，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        dArray - 可选预先分配的双阵列
        结果
        指定像素矩形的样本。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果dArray太小，不能容纳输出。

      • getSample

        public int getSample​(int x,
                     int y,
                     int b)
        将位于（x，y）处的像素的指定带中的样本返回为int。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        结果
        在指定频带中的样本在指定坐标处的像素。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • getSampleFloat

        public float getSampleFloat​(int x,
                            int y,
                            int b)
        将位于（x，y）处的像素的指定带中的样本作为浮点返回。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        结果
        在指定频带中的样本在指定坐标处的像素。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • getSampleDouble

        public double getSampleDouble​(int x,
                              int y,
                              int b)
        将位于（x，y）的像素的指定带中的样本返回为双倍。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        b - 乐队返回
        结果
        在指定频带中的样本在指定坐标处的像素。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • getSamples

        public int[] getSamples​(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray)
        返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        b - 乐队返回
        iArray - 可选预先分配的int数组
        结果
        指定带宽的样本为指定的像素矩形。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界，或者如果iArray太小而不能容纳输出。

      • getSamples

        public float[] getSamples​(int x,
                          int y,
                          int w,
                          int h,
                          int b,
                          float[] fArray)
        返回浮点数组中指定的像素矩形的指定波段的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        b - 乐队返回
        fArray - 可选预先分配的浮点数组
        结果
        指定带宽的样本为指定的像素矩形。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果fArray太小而不能容纳输出。

      • getSamples

        public double[] getSamples​(int x,
                           int y,
                           int w,
                           int h,
                           int b,
                           double[] dArray)
        返回双阵列中指定的像素矩形的指定波段的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标
        y - 左上角像素位置的Y坐标
        w - 像素矩形的宽度
        h - 像素矩形的高度
        b - 乐队返回
        dArray - 可选预先分配的双阵列
        结果
        指定带宽的样本为指定的像素矩形。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或带索引不在边界，或者如果dArray太小而不能保存输出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RasterFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class RasterFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.awt.image.RasterFormatException
  • All Implemented Interfaces:
    Serializable

    public class RasterFormatException
extends RuntimeException
    如果RasterFormatException中有无效的布局信息，则会抛出RasterFormatException 。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      RasterFormatException​(String s)
      构造一个新的 RasterFormatException与指定的消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • RasterFormatException

        public RasterFormatException​(String s)
        构造一个新的 RasterFormatException与指定的消息。
        参数
        s - 抛出 RasterFormatException时生成的消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RasterOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface RasterOp

  • 所有已知实现类：
    AffineTransformOp ， BandCombineOp ， ColorConvertOp ， ConvolveOp ， LookupOp ， RescaleOp

    public interface RasterOp
    该界面介绍了对栅格对象执行的单输入/单输出操作。 它由AffineTransformOp，ConvolveOp和LookupOp等类实现。 源和目标对象必须包含实现此接口的特定类的适当数量的带。 否则抛出异常。 此接口不能用于描述更复杂的Ops，例如采用多个源的Ops。 实现此接口的每个类将指定是否允许就地过滤操作（即源对象等于目标对象）。 注意，对单输入操作的限制意味着操作之前的目标像素的值不用作过滤器操作的输入。
    另请参见：
    AffineTransformOp ， BandCombineOp ， ColorConvertOp ， ConvolveOp ， LookupOp ， RescaleOp

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      WritableRaster createCompatibleDestRaster​(Raster src)
      创建具有正确大小和频带数的归零目标光栅。
      WritableRaster filter​(Raster src, WritableRaster dest)
      执行从源光栅到目标光栅的单输入/单输出操作。
      Rectangle2D getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源光栅中给定点的目标点的位置。
      RenderingHints getRenderingHints​()
      返回此RasterOp的渲染提示。

    • 方法详细信息

      • filter

        WritableRaster filter​(Raster src,
                      WritableRaster dest)
        执行从源光栅到目标光栅的单输入/单输出操作。 如果目标Raster为null，将创建一个新的栅格。 如果源和/或目标栅格与实现此过滤器的类允许的栅格类型不兼容，则可能会抛出IllegalArgumentException。
        参数
        src - 来源 Raster
        dest - 目的地 WritableRaster
        结果
        一个表示过滤操作结果的 WritableRaster 。

      • getBounds2D

        Rectangle2D getBounds2D​(Raster src)
        返回已筛选的目标栅格的边框。 如果源Raster与实现此过滤器的类允许的类型不兼容，则可能会抛出IllegalArgumentException。
        参数
        src - 来源 Raster
        结果
        一个 Rectangle2D是由过滤操作产生的 Raster的边框。

      • createCompatibleDestRaster

        WritableRaster createCompatibleDestRaster​(Raster src)
        创建具有正确大小和频带数的归零目标光栅。 如果源Raster与实现此过滤器的类允许的类型不兼容，则可能会抛出IllegalArgumentException。
        参数
        src - 来源 Raster
        结果
        一个 WritableRaster ，与 src兼容

      • getPoint2D

        Point2D getPoint2D​(Point2D srcPt,
                   Point2D dstPt)
        返回源光栅中给定点的目标点的位置。 如果dstPt不为空，它将用于保存返回值。
        参数
        srcPt - 来源 Point2D
        dstPt - 目的地 Point2D
        结果
        目的地点的位置。

      • getRenderingHints

        RenderingHints getRenderingHints​()
        返回此RasterOp的渲染提示。 如果没有设置提示，则返回null。
        结果
        该 RenderingHints对象为 RasterOp 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderedImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface RenderedImage

  • All Known Subinterfaces:
    WritableRenderedImage
    所有已知实现类：
    BufferedImage

    public interface RenderedImage
    RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。 图像数据可以被存储/生成为单个瓦片或普通瓦片阵列。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      WritableRaster copyData​(WritableRaster raster)
      计算RenderedImage的任意矩形区域，并将其复制到调用者提供的WritableRaster中。
      ColorModel getColorModel​()
      返回与此图像相关联的ColorModel。
      Raster getData​()
      将图像作为一个大图块返回（对于基于图块的图像，这将需要获取整个图像并复制图像数据）。
      Raster getData​(Rectangle rect)
      计算并返回RenderedImage的任意区域。
      int getHeight​()
      返回RenderedImage的高度。
      int getMinTileX​()
      返回X方向上的最小平铺索引。
      int getMinTileY​()
      返回Y方向上的最小瓦片索引。
      int getMinX​()
      返回RenderedImage的最小X坐标（包括）。
      int getMinY​()
      返回RenderedImage的最小Y坐标（包括）。
      int getNumXTiles​()
      返回X方向上的图块数。
      int getNumYTiles​()
      返回Y方向上的图块数。
      Object getProperty​(String name)
      从该图像的属性集获取属性。
      String[] getPropertyNames​()
      返回由 getProperty(String)或 null识别的名称数组，如果未识别属性名称。
      SampleModel getSampleModel​()
      返回与此图像关联的SampleModel。
      Vector<RenderedImage> getSources​()
      返回RenderedImages的矢量，该矢量是此RenderedImage的图像数据的直接来源。
      Raster getTile​(int tileX, int tileY)
      返回tile（tileX，tileY）。
      int getTileGridXOffset​()
      返回瓦片网格相对于原点的X偏移量，即瓦片（0,0）左上角像素的X坐标。
      int getTileGridYOffset​()
      返回瓦片网格相对于原点的Y偏移量，即瓦片（0,0）左上角像素的Y坐标。
      int getTileHeight​()
      返回瓷砖高度（像素）。
      int getTileWidth​()
      返回瓷砖宽度（以像素为单位）
      int getWidth​()
      返回RenderedImage的宽度。

    • 方法详细信息

      • getSources

        Vector<RenderedImage> getSources​()
        返回RenderedImages的矢量，该矢量是此RenderedImage的图像数据的直接来源。 如果RenderedImage对象没有关于其直接源的信息，则此方法返回null。 如果RenderedImage对象没有即时源，则返回一个空的向量。
        结果
        一个 RenderedImage对象的向量。

      • getProperty

        Object getProperty​(String name)
        从该图像的属性集获取属性。 属性的集合以及它是否是不可变的由实现类决定。 如果未为此RenderedImage定义指定的属性，则此方法返回java.awt.Image.UndefinedProperty。
        参数
        name - 物业的名称
        结果
        由指定名称指定的财产。
        另请参见：
        Image.UndefinedProperty

      • getPropertyNames

        String[] getPropertyNames​()
        如果未识别属性名称，则返回由 getProperty(String)或 null识别的名称数组。
        结果
        一个包含getProperty(String)识别的所有属性名称的String数组; 或者如果没有属性名称被识别， null 。

      • getColorModel

        ColorModel getColorModel​()
        返回与此图像相关联的ColorModel。 从此图像返回的所有栅格将具有它们的ColorModel。 这可以返回null。
        结果
        这个图像的 ColorModel 。

      • getSampleModel

        SampleModel getSampleModel​()
        返回与此图像关联的SampleModel。 从该图像返回的所有栅格将具有它们的SampleModel。
        结果
        这张图片的 SampleModel 。

      • getWidth

        int getWidth​()
        返回RenderedImage的宽度。
        结果
        该宽度为 RenderedImage 。

      • getHeight

        int getHeight​()
        返回RenderedImage的高度。
        结果
        这个高度 RenderedImage 。

      • getMinX

        int getMinX​()
        返回RenderedImage的最小X坐标（包括）。
        结果
        这个 RenderedImage的X坐标。

      • getMinY

        int getMinY​()
        返回RenderedImage的最小Y坐标（包括）。
        结果
        这个 RenderedImage的Y坐标。

      • getNumXTiles

        int getNumXTiles​()
        返回X方向上的图块数。
        结果
        X方向上的瓦片数量。

      • getNumYTiles

        int getNumYTiles​()
        返回Y方向上的图块数。
        结果
        Y方向上的瓦数。

      • getMinTileX

        int getMinTileX​()
        返回X方向上的最小平铺索引。
        结果
        X方向上的最小瓦片指数。

      • getMinTileY

        int getMinTileY​()
        返回Y方向上的最小瓦片索引。
        结果
        X方向上的最小瓦片指数。

      • getTileWidth

        int getTileWidth​()
        返回瓷砖宽度（以像素为单位） 所有瓷砖必须具有相同的宽度。
        结果
        瓦片宽度（以像素为单位）

      • getTileHeight

        int getTileHeight​()
        返回瓷砖高度（像素）。 所有瓷砖必须具有相同的高度。
        结果
        瓷砖高度以像素为单位。

      • getTileGridXOffset

        int getTileGridXOffset​()
        返回瓦片网格相对于原点的X偏移量，即瓦片（0,0）左上角像素的X坐标。 （请注意，tile（0,0）实际上可能不存在）
        结果
        瓦片网格相对于原点的X偏移量。

      • getTileGridYOffset

        int getTileGridYOffset​()
        返回瓦片网格相对于原点的Y偏移量，即瓦片（0,0）左上角像素的Y坐标。 （请注意，tile（0,0）实际上可能不存在）
        结果
        瓦片网格相对于原点的Y偏移。

      • getTile

        Raster getTile​(int tileX,
               int tileY)
        返回tile（tileX，tileY）。 请注意，tileX和tileY是tile数组中的索引，而不是像素位置。 返回的光栅是实时的，如果图像更改，将更新。
        参数
        tileX - 图块数组中所请求的图块的X索引
        tileY - 图块数组中所请求的图块的Y索引
        结果
        给定了指定的索引。

      • getData

        Raster getData​()
        将图像作为一个大图块返回（对于基于图块的图像，这将需要获取整个图像并复制图像数据）。 返回的光栅是图像数据的副本，如果图像更改，则不会更新。
        结果
        图像作为一个大瓷砖。

      • getData

        Raster getData​(Rectangle rect)
        计算并返回RenderedImage的任意区域。 返回的光栅是图像数据的副本，如果图像更改，则不会更新。
        参数
        rect - 要返回的RenderedImage的区域。
        结果
        RenderedImage的区域由指定的 Rectangle指定。

      • copyData

        WritableRaster copyData​(WritableRaster raster)
        计算RenderedImage的任意矩形区域，并将其复制到调用者提供的WritableRaster中。 要计算的区域从提供的WritableRaster的边界确定。 所提供的WritableRaster必须具有与此映像兼容的SampleModel。 如果raster为null，则创建一个适当的WritableRaster。
        参数
        raster - 用于保存图像返回部分的WritableRaster，或null。
        结果
        引用提供或创建的WritableRaster。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReplicateScaleFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ReplicateScaleFilter

  • java.lang.Object
    • java.awt.image.ImageFilter
      • java.awt.image.ReplicateScaleFilter
  • All Implemented Interfaces:
    ImageConsumer ， Cloneable
    已知直接子类：
    AreaAveragingScaleFilter

    public class ReplicateScaleFilter
extends ImageFilter
    一个ImageFilter类，用于使用最简单的算法缩放图像。 该类扩展了基本的ImageFilter类以缩放现有图像，并为包含重新采样图像的新图像提供了一个源。 源图像中的像素被采样以通过复制像素的行和列来放大或省略像素的行和列来缩小规定尺寸的图像的像素。

    它意味着与FilteredImageSource对象结合使用，以生成现有图像的缩放版本。 由于实现依赖关系，在不同平台上过滤的图像的像素值可能有差异。

    另请参见：
    FilteredImageSource ， ImageFilter

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int destHeight
      目标高度来缩放图像。
      protected int destWidth
      缩放图像的目标宽度。
      protected Object outpixbuf
      A byte数组初始化大小为destWidth ，用于将一行像素数据传送到ImageConsumer 。
      protected int[] srccols
      一个包含有关像素列的信息的 int数组。
      protected int srcHeight
      源图像的高度。
      protected int[] srcrows
      一个包含一行像素信息的 int数组。
      protected int srcWidth
      源图像的宽度。

      • Fields inherited from interface java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

      • Fields inherited from class java.awt.image.ImageFilter

        consumer

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReplicateScaleFilter​(int width, int height)
      构造一个ReplicateScaleFilter，可以根据width和height参数指定的其像素的像素进行缩放。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void setDimensions​(int w, int h)
      覆盖源图像的尺寸，并将新的缩放尺寸的尺寸传递给ImageConsumer。
      void setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      选择目标缩放图像所需的传送字节像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。
      void setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      选择目标缩放图像需要交付的int像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。
      void setProperties​(Hashtable<?,?> props)
      在添加指示应用比例的属性后，沿着属性从源对象传递。

      • Methods inherited from class java.awt.image.ImageFilter

        clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setColorModel, setHints

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • srcWidth

        protected int srcWidth
        源图像的宽度。

      • srcHeight

        protected int srcHeight
        源图像的高度。

      • destWidth

        protected int destWidth
        缩放图像的目标宽度。

      • destHeight

        protected int destHeight
        目标高度来缩放图像。

      • srcrows

        protected int[] srcrows
        一个包含一行像素信息的 int数组。

      • srccols

        protected int[] srccols
        一个包含有关像素列的信息的 int数组。

      • outpixbuf

        protected Object outpixbuf
        A byte数组初始化大小为destWidth ，用于将一行像素数据传送到ImageConsumer 。

    • 构造方法详细信息

      • ReplicateScaleFilter

        public ReplicateScaleFilter​(int width,
                            int height)
        构造一个ReplicateScaleFilter，可以根据width和height参数指定的其像素的像素进行缩放。
        参数
        width - 缩放图像的目标宽度
        height - 缩放图像的目标高度
        异常
        IllegalArgumentException - 如果 width等于零或 height等于零

    • 方法详细信息

      • setProperties

        public void setProperties​(Hashtable<?,?> props)
        在添加指示应用比例的属性后，沿着属性从源对象传递。 此方法调用super.setProperties ，这可能会导致添加其他属性。

        注意：此方法的目的是由要ImageProducer像素进行过滤的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setProperties在接口 ImageConsumer
        重写：
        setProperties在 ImageFilter
        参数
        props - 源对象的属性

      • setDimensions

        public void setDimensions​(int w,
                          int h)
        覆盖源图像的尺寸，并将新的缩放尺寸的尺寸传递给ImageConsumer。

        注意：此方法的目的是由要ImageProducer像素进行过滤的ImageProducer的Image调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setDimensions在接口 ImageConsumer
        重写：
        setDimensions在 ImageFilter
        参数
        w - 源图像的宽度
        h - 源图像的高度
        另请参见：
        ImageConsumer

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
        选择目标缩放图像所需的传送字节像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。

        注意：此方法的目的是通过Image像素进行过滤的Image的ImageProducer进行调用。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中的一行像素到下一行的距离
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
        选择目标缩放图像需要交付的int像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。

        注意：此方法的目的是通过ImageProducer的Image其像素进行过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中的一行像素到下一行的距离
        另请参见：
        ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RescaleOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class RescaleOp

  • java.lang.Object
    • java.awt.image.RescaleOp
  • All Implemented Interfaces:
    BufferedImageOp ， RasterOp

    public class RescaleOp
extends Object
implements BufferedImageOp, RasterOp
    该类通过将每个像素的采样值乘以比例因子然后添加偏移来执行源图像中的数据的逐像素重新缩放。 缩放的样本值被剪切到目标图像中可表示的最小/最大值。

    重新定标操作的伪代码如下：

      for each pixel from Source object {
    for each band/component of the pixel {
        dstElement = (srcElement*scaleFactor) + offset
    }
}

    对于光栅，重新缩放操作在频带上。 缩放常数集合的数量可以是一个，在这种情况下，相同的常量应用于所有频带，或者它必须等于源光栅频带的数量。

    对于BufferedImages，重定向在颜色和alpha组件上运行。 缩放常数集合的数量可以是一个，在这种情况下，相同的常量应用于所有颜色（但不是alpha）组件。 否则，缩放常量集合的数量可以等于源颜色分量的数量，在这种情况下，不执行alpha分量（如果存在）的重新缩放。 如果这两种情况都不适用，缩放常数集合的数量必须等于源颜色分量加上alpha分量的数量，在这种情况下，所有颜色和alpha分量都将重新缩放。

    具有预乘法α数据的BufferedImage源以与非预乘图像相同的方式被处理以用于重新缩放。 也就是说，对于BufferedImage源的原始数据，每个频段都进行重新缩放，而不考虑数据是否被预乘。 如果目标ColorModel需要颜色转换，则此步骤将考虑源和目的地的预乘法状态。

    具有IndexColorModel的图像无法重新缩放。

    如果在构造函数中指定了RenderingHints对象，则在需要颜色转换时，可以使用颜色渲染提示和抖动提示。

    请注意，就地操作是允许的（即源和目标可以是同一个对象）。

    另请参见：
    RenderingHints.KEY_COLOR_RENDERING ， RenderingHints.KEY_DITHERING

    • 构造方法摘要

      构造方法
      Constructor 描述
      RescaleOp​(float[] scaleFactors, float[] offsets, RenderingHints hints)
      构建一个具有所需比例因子和偏移量的新RescaleOp。
      RescaleOp​(float scaleFactor, float offset, RenderingHints hints)
      构造一个具有所需比例因子和偏移量的新RescaleOp。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BufferedImage createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      WritableRaster createCompatibleDestRaster​(Raster src)
      创建一个归零目的地 Raster具有正确的大小和频带数，给定此源。
      BufferedImage filter​(BufferedImage src, BufferedImage dst)
      重新调整源BufferedImage。
      WritableRaster filter​(Raster src, WritableRaster dst)
      重新调整源光栅中的像素数据。
      Rectangle2D getBounds2D​(BufferedImage src)
      返回重新缩放的目标图像的边框。
      Rectangle2D getBounds2D​(Raster src)
      返回重新缩放的目标栅格的边框。
      int getNumFactors​()
      返回此RescaleOp中使用的缩放因子和偏移量的数量。
      float[] getOffsets​(float[] offsets)
      返回给定数组中的偏移量。
      Point2D getPoint2D​(Point2D srcPt, Point2D dstPt)
      返回源中给定点的目标点的位置。
      RenderingHints getRenderingHints​()
      返回此操作的渲染提示。
      float[] getScaleFactors​(float[] scaleFactors)
      返回给定数组中的比例因子。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RescaleOp

        public RescaleOp​(float[] scaleFactors,
                 float[] offsets,
                 RenderingHints hints)
        构建一个具有所需比例因子和偏移量的新RescaleOp。 scaleFactor和offset数组的长度必须满足上面类注释中所述的限制。 RenderingHints参数可能为null。
        参数
        scaleFactors - 指定的比例因子
        offsets - 指定的偏移量
        hints - 指定的 RenderingHints或 null

      • RescaleOp

        public RescaleOp​(float scaleFactor,
                 float offset,
                 RenderingHints hints)
        构造一个具有所需比例因子和偏移量的新RescaleOp。 scaleFactor和offset将应用于源栅格中的所有条带以及BufferedImage中的所有颜色（但不是alpha）组件。 RenderingHints参数可能为null。
        参数
        scaleFactor - 指定的比例因子
        offset - 指定的偏移量
        hints - 指定的 RenderingHints或 null

    • 方法详细信息

      • getScaleFactors

        public final float[] getScaleFactors​(float[] scaleFactors)
        返回给定数组中的比例因子。 为方便起见，还会返回数组。 如果scaleFactors为空，则将分配一个新数组。
        参数
        scaleFactors - 包含这个 RescaleOp的比例因子的 RescaleOp
        结果
        这个比例因子这个 RescaleOp 。

      • getOffsets

        public final float[] getOffsets​(float[] offsets)
        返回给定数组中的偏移量。 为方便起见，还会返回数组。 如果offsets为null，则会分配一个新的数组。
        参数
        offsets - 该数组包含该 RescaleOp的偏移量
        结果
        这个 RescaleOp的偏移量。

      • getNumFactors

        public final int getNumFactors​()
        返回此RescaleOp中使用的缩放因子和偏移量的数量。
        结果
        缩放因子的数量和这个 RescaleOp偏移量。

      • filter

        public final BufferedImage filter​(BufferedImage src,
                                  BufferedImage dst)
        重新调整源BufferedImage。 如果源图像中的颜色模型与目标图像中的颜色模型不同，则将在目标中转换像素。 如果目标图像为空，则将使用源ColorModel创建一个BufferedImage。 如果此对象中的缩放因子/偏移量不符合上述类注释中规定的限制，或者源图像具有IndexColorModel，则可能会抛出IllegalArgumentException异常。
        Specified by:
        filter在接口 BufferedImageOp
        参数
        src - 要过滤的 BufferedImage
        dst - 过滤操作的目的地或 null
        结果
        过滤后的 BufferedImage 。
        异常
        IllegalArgumentException -如果 ColorModel的 src是 IndexColorModel ，或者如果缩放因子和偏移在此数 RescaleOp不符合上述类注释中规定的要求。

      • filter

        public final WritableRaster filter​(Raster src,
                                   WritableRaster dst)
        重新调整源光栅中的像素数据。 如果目标Raster为null，将创建一个新的栅格。 源和目的地必须具有相同数量的频带。 否则，将抛出IllegalArgumentException。 请注意，此对象中缩放因子/偏移量的数量必须满足上述类注释中所述的限制。 否则，将抛出IllegalArgumentException。
        Specified by:
        filter在接口 RasterOp
        参数
        src - 要过滤的 Raster
        dst - 过滤操作的目的地或 null
        结果
        过滤后的 WritableRaster 。
        异常
        IllegalArgumentException - 如果 src和 dst不具有相同的频带数，或者 RescaleOp的缩放因子和偏移量不符合类注释中规定的要求。

      • getBounds2D

        public final Rectangle2D getBounds2D​(BufferedImage src)
        返回重新缩放的目标图像的边框。 由于这不是一个几何操作，边框不会改变。
        Specified by:
        getBounds2D在接口 BufferedImageOp
        参数
        src - 要过滤的 BufferedImage
        结果
        Rectangle2D代表目的地图像的边界框。

      • getBounds2D

        public final Rectangle2D getBounds2D​(Raster src)
        返回重新缩放的目标栅格的边框。 由于这不是一个几何操作，边框不会改变。
        Specified by:
        getBounds2D在接口 RasterOp
        参数
        src - 重新缩放的目的地 Raster
        结果
        指定的边界 Raster 。

      • createCompatibleDestImage

        public BufferedImage createCompatibleDestImage​(BufferedImage src,
                                               ColorModel destCM)
        创建具有正确大小和频带数的归零目标图像。
        Specified by:
        createCompatibleDestImage在接口 BufferedImageOp
        参数
        src - 过滤器操作的源镜像。
        destCM - 目的地的ColorModel。 如果为null，将使用源的ColorModel。
        结果
        零目的地图像。

      • createCompatibleDestRaster

        public WritableRaster createCompatibleDestRaster​(Raster src)
        创建一个归零目的地 Raster具有正确的大小和数量的频带，给定这个源。
        Specified by:
        createCompatibleDestRaster在接口 RasterOp
        参数
        src - 来源 Raster
        结果
        零目的地 Raster 。

      • getPoint2D

        public final Point2D getPoint2D​(Point2D srcPt,
                                Point2D dstPt)
        返回源中给定点的目标点的位置。 如果dstPt不为空，它将用于保存返回值。 由于这不是几何操作，srcPt将等于dstPt。
        Specified by:
        getPoint2D在接口 BufferedImageOp
        Specified by:
        getPoint2D在接口 RasterOp
        参数
        srcPt - 源图像中的一个点
        dstPt - 目的地点或 null
        结果
        目的地点的位置。

      • getRenderingHints

        public final RenderingHints getRenderingHints​()
        返回此操作的渲染提示。
        Specified by:
        getRenderingHints在接口 BufferedImageOp
        Specified by:
        getRenderingHints在接口 RasterOp
        结果
        这个 RescaleOp的渲染提示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RGBImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class RGBImageFilter

  • java.lang.Object
    • java.awt.image.ImageFilter
      • java.awt.image.RGBImageFilter
  • All Implemented Interfaces:
    ImageConsumer ， Cloneable
    已知直接子类：
    GrayFilter

    public abstract class RGBImageFilter
extends ImageFilter
    该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。 这意味着与FilteredImageSource对象结合使用以产生现有图像的过滤版本。 它是一个抽象类，它提供通过单个方法来传送所有像素数据所需的调用，该方法可以在默认的RGB ColorModel中一次一个地转换像素，而不管ImageProducer使用的ColorModel如何。 需要定义创建可用图像过滤器的唯一方法是filterRGB方法。 以下是将图像的红色和蓝色分量交换的过滤器定义的示例：
       class RedBlueSwapFilter extends RGBImageFilter { public RedBlueSwapFilter() { // The filter's operation does not depend on the // pixel's location, so IndexColorModels can be // filtered directly. canFilterIndexColorModel = true; } public int filterRGB(int x, int y, int rgb) { return ((rgb & 0xff00ff00) | ((rgb & 0xff0000) >> 16) | ((rgb & 0xff) << 16)); } }
    另请参见：
    FilteredImageSource ， ImageFilter ， ColorModel.getRGBdefault()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected boolean canFilterIndexColorModel
      该布尔值指示是否可以将filterRGB方法的颜色过滤应用于IndexColorModel对象的颜色表条目，以代替逐像素过滤。
      protected ColorModel newmodel
      ColorModel用来取代 origmodel当用户拨打 substituteColorModel 。
      protected ColorModel origmodel
      ColorModel由 newmodel替换时用户拨打 substituteColorModel 。

      • Fields inherited from interface java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

      • Fields inherited from class java.awt.image.ImageFilter

        consumer

    • 构造方法摘要

      构造方法
      Constructor 描述
      RGBImageFilter​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      IndexColorModel filterIndexColorModel​(IndexColorModel icm)
      通过RGBImageFilter子类必须提供的filterRGB函数运行其颜色表中的每个条目来过滤IndexColorModel对象。
      abstract int filterRGB​(int x, int y, int rgb)
      子类必须指定一种将默认RGB ColorModel中的单个输入像素转换为单个输出像素的方法。
      void filterRGBPixels​(int x, int y, int w, int h, int[] pixels, int off, int scansize)
      通过filterRGB方法逐个传递默认RGB ColorModel中的像素缓冲区。
      void setColorModel​(ColorModel model)
      如果ColorModel是IndexColorModel，并且子类将canFilterIndexColorModel标志设置为true，则在此处替换颜色模型的过滤版本，并将原始ColorModel对象出现在setPixels方法中。
      void setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递。
      void setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递，否则将整数像素的缓冲区转换为默认的RGB ColorModel，并将转换后的缓冲区传递给filterRGBPixels方法进行转换一个
      void substituteColorModel​(ColorModel oldcm, ColorModel newcm)
      注册两个ColorModel对象进行替换。

      • Methods inherited from class java.awt.image.ImageFilter

        clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setDimensions, setHints, setProperties

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • origmodel

        protected ColorModel origmodel
        ColorModel由 newmodel替换时用户拨打 substituteColorModel 。

      • newmodel

        protected ColorModel newmodel
        ColorModel用来取代 origmodel当用户拨打 substituteColorModel 。

      • canFilterIndexColorModel

        protected boolean canFilterIndexColorModel
        该布尔值指示是否可以将filterRGB方法的颜色过滤应用于IndexColorModel对象的颜色表条目，以代替逐像素过滤。 子类应在其构造函数中将此变量设置为true，如果其filterRGB方法不依赖于被过滤的像素的坐标。
        另请参见：
        substituteColorModel(java.awt.image.ColorModel, java.awt.image.ColorModel) ， filterRGB(int, int, int) ， IndexColorModel

    • 构造方法详细信息

      • RGBImageFilter

        public RGBImageFilter​()

    • 方法详细信息

      • setColorModel

        public void setColorModel​(ColorModel model)
        如果ColorModel是IndexColorModel，并且子类将canFilterIndexColorModel标志设置为true，则在此处替换颜色模型的过滤版本，并将原始ColorModel对象出现在setPixels方法中。 如果ColorModel不是IndexColorModel或null，则此方法将覆盖ImageProducer使用的默认ColorModel，并指定默认的RGB ColorModel。

        注意：此方法的目的是通过被称为ImageProducer所述的Image其像素正被过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setColorModel在接口 ImageConsumer
        重写：
        setColorModel在 ImageFilter
        参数
        model - 指定的 ColorModel
        另请参见：
        ImageConsumer ， ColorModel.getRGBdefault()

      • substituteColorModel

        public void substituteColorModel​(ColorModel oldcm,
                                 ColorModel newcm)
        注册两个ColorModel对象进行替换。 如果在任何setPixels方法中遇到oldcm，newcm将被替换，并且像素通过不变的（但是使用新的ColorModel对象）。
        参数
        oldcm - 要快速替换的ColorModel对象
        newcm - ColorModel对象即时替换oldcm

      • filterIndexColorModel

        public IndexColorModel filterIndexColorModel​(IndexColorModel icm)
        通过RGBImageFilter子类必须提供的filterRGB函数运行其颜色表中的每个条目来过滤IndexColorModel对象。 使用-1的坐标表示正在过滤颜色表条目，而不是实际的像素值。
        参数
        icm - 要过滤的IndexColorModel对象
        结果
        一个新的IndexColorModel表示过滤的颜色
        异常
        NullPointerException - 如果 icm为空

      • filterRGBPixels

        public void filterRGBPixels​(int x,
                            int y,
                            int w,
                            int h,
                            int[] pixels,
                            int off,
                            int scansize)
        通过filterRGB方法逐个传递默认RGB ColorModel中的像素缓冲区。
        参数
        x - 像素区域左上角的X坐标
        y - 像素区域左上角的Y坐标
        w - 像素区域的宽度
        h - 像素区域的高度
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - 阵列中一行像素到下一行的距离
        另请参见：
        ColorModel.getRGBdefault() ， filterRGB(int, int, int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
        如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递。 否则将字节像素的缓冲区转换为默认的RGB ColorModel，并将转换的缓冲区传递给filterRGBPixels方法以逐个转换。

        注意：此方法的目的是通过ImageProducer的Image其像素进行过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中的一行像素到下一行的距离
        另请参见：
        ColorModel.getRGBdefault() ， filterRGBPixels(int, int, int, int, int[], int, int)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
        如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递，否则将整数像素的缓冲区转换为默认的RGB ColorModel，并将转换后的缓冲区传递给filterRGBPixels方法进行转换一个 将整数像素的缓冲区转换为默认的RGB ColorModel，并将转换的缓冲区传递给filterRGBPixels方法。

        注意：此方法的目的是通过ImageProducer的Image其像素进行过滤。 使用此类过滤图像中的像素的开发人员应避免直接调用此方法，因为该操作可能会干扰过滤操作。

        Specified by:
        setPixels在接口 ImageConsumer
        重写：
        setPixels在 ImageFilter
        参数
        x - 要设置的像素区域的左上角的X坐标
        y - 要设置的像素区域的左上角的Y坐标
        w - 像素面积的宽度
        h - 像素面积的高度
        model - 指定的 ColorModel
        pixels - 像素数组
        off - 偏移到 pixels数组
        scansize - pixels数组中从一行像素到下一行的距离
        另请参见：
        ColorModel.getRGBdefault() ， filterRGBPixels(int, int, int, int, int[], int, int)

      • filterRGB

        public abstract int filterRGB​(int x,
                              int y,
                              int rgb)
        子类必须指定一种将默认RGB ColorModel中的单个输入像素转换为单个输出像素的方法。
        参数
        x - 像素的X坐标
        y - 像素的Y坐标
        rgb - 默认RGB颜色模型中的整数像素表示
        结果
        默认RGB颜色模型中的滤镜像素。
        另请参见：
        ColorModel.getRGBdefault() ， filterRGBPixels(int, int, int, int, int[], int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class SampleModel

  • java.lang.Object
    • java.awt.image.SampleModel
  • 已知直接子类：
    ComponentSampleModel ， MultiPixelPackedSampleModel ， SinglePixelPackedSampleModel

    public abstract class SampleModel
extends Object
    这个抽象类定义了一个用于提取图像中像素样本的接口。 所有图像数据都表示为像素集合。 每个像素由多个样本组成。 样本是图像的一个频带的基准，频带由图像中特定类型的所有样本组成。 例如，像素可能包含三个样本，表示其红色，绿色和蓝色分量。 包含此像素的图像中有三个波段。 一个乐队由图像中所有像素的所有红色样本组成。 第二频带由所有绿色样本组成，剩余频带由所有蓝色样本组成。 像素可以以各种格式存储。 例如，可以连续存储来自特定频带的所有样本，或者可以连续存储来自单个像素的所有样本。

    SampleModel的子类指定可以表示的样本类型（例如无符号8位字节，有符号16位短等），并可以指定样本在内存中的组织方式。 在Java 2D（tm）API中，内置的图像处理操作符可能不会对所有可能的样本类型进行操作，但通常适用于16位或更少的无符号积分样本。 一些操作员支持更多种类的样品。

    像素的集合被表示为光栅，其由DataBuffer和SampleModel组成。 SampleModel允许访问DataBuffer中的样本，并可能提供程序员可以直接操作DataBuffer中的样本和像素的低级信息。

    这个类通常是用于处理图像的倒退方法。 更高效的代码将将SampleModel转换为适当的子类，并提取直接操作DataBuffer中的像素所需的信息。

    另请参见：
    DataBuffer ， Raster ， ComponentSampleModel ， PixelInterleavedSampleModel ， BandedSampleModel ， MultiPixelPackedSampleModel ， SinglePixelPackedSampleModel

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int dataType
      存储像素数据的DataBuffer的数据类型。
      protected int height
      该SampleModel描述的图像数据区域的像素高度。
      protected int numBands
      该SampleModel描述的图像数据的频带数。
      protected int width
      此SampleModel描述的图像数据区域的宽度（以像素为单位）。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SampleModel​(int dataType, int w, int h, int numBands)
      使用指定的参数构造一个SampleModel。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract SampleModel createCompatibleSampleModel​(int w, int h)
      创建一个SampleModel，它描述了SampleModel格式的数据，但是具有不同的宽度和高度。
      abstract DataBuffer createDataBuffer​()
      创建与此SampleModel对应的DataBuffer。
      abstract SampleModel createSubsetSampleModel​(int[] bands)
      使用此SampleModel的一个子带子创建一个新的SampleModel。
      Object getDataElements​(int x, int y, int w, int h, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中指定的像素矩形的像素数据。
      abstract Object getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      int getDataType​()
      返回存储像素数据的DataBuffer的数据类型。
      int getHeight​()
      返回以像素为单位的高度。
      int getNumBands​()
      返回图像数据的总带数。
      abstract int getNumDataElements​()
      返回通过getDataElements和setDataElements方法传输像素所需的数据元素数。
      double[] getPixel​(int x, int y, double[] dArray, DataBuffer data)
      返回double数组中指定像素的样本。
      float[] getPixel​(int x, int y, float[] fArray, DataBuffer data)
      返回float数组中指定像素的样本。
      int[] getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的样本，每个数组元素一个样本。
      double[] getPixels​(int x, int y, int w, int h, double[] dArray, DataBuffer data)
      返回双阵列中像素矩形的所有样本，每个数组元素一个样本。
      float[] getPixels​(int x, int y, int w, int h, float[] fArray, DataBuffer data)
      返回float数组中像素矩形的所有样本，每个数组元素一个样本。
      int[] getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中像素矩形的所有样本，每个数组元素一个样本。
      abstract int getSample​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本返回为int。
      double getSampleDouble​(int x, int y, int b, DataBuffer data)
      将位于（x，y）的像素的指定带中的样本返回为双倍。
      float getSampleFloat​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本作为浮点返回。
      double[] getSamples​(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data)
      返回双阵列中指定的像素矩形的指定波段的样本，每个数组元素一个样本。
      float[] getSamples​(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data)
      返回浮点数组中指定的像素矩形的指定波段的样本，每个数组元素一个样本。
      int[] getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。
      abstract int[] getSampleSize​()
      返回所有频段的采样位数。
      abstract int getSampleSize​(int band)
      返回指定波段的采样位的大小。
      int getTransferType​()
      返回用于通过getDataElements和setDataElements方法传输像素的TransferType。
      int getWidth​()
      返回以像素为单位的宽度。
      void setDataElements​(int x, int y, int w, int h, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中像素矩形的数据。
      abstract void setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。
      void setPixel​(int x, int y, double[] dArray, DataBuffer data)
      在DataBuffer中使用双重样本数组来设置像素。
      void setPixel​(int x, int y, float[] fArray, DataBuffer data)
      使用用于输入的样本的浮点数组来设置DataBuffer中的像素。
      void setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用int数组的样本数据来设置DataBuffer中的一个像素。
      void setPixels​(int x, int y, int w, int h, double[] dArray, DataBuffer data)
      从包含每个数组元素一个样本的双数组中设置一个像素矩形的所有样本。
      void setPixels​(int x, int y, int w, int h, float[] fArray, DataBuffer data)
      从包含每个数组元素一个样本的浮点数组设置一个像素矩形的所有样本。
      void setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void setSample​(int x, int y, int b, double s, DataBuffer data)
      对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。
      void setSample​(int x, int y, int b, float s, DataBuffer data)
      使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。
      abstract void setSample​(int x, int y, int b, int s, DataBuffer data)
      使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。
      void setSamples​(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data)
      从包含每个数组元素一个样本的双阵列的像素的指定矩形中设置样本。
      void setSamples​(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data)
      从包含每个数组元素一个样本的浮点数组中为指定的像素矩形设置指定带中的样本。
      void setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • width

        protected int width
        此SampleModel描述的图像数据区域的宽度（以像素为单位）。

      • height

        protected int height
        该SampleModel描述的图像数据区域的像素高度。

      • numBands

        protected int numBands
        该SampleModel描述的图像数据的频带数。

      • dataType

        protected int dataType
        存储像素数据的DataBuffer的数据类型。
        另请参见：
        DataBuffer

    • 构造方法详细信息

      • SampleModel

        public SampleModel​(int dataType,
                   int w,
                   int h,
                   int numBands)
        使用指定的参数构造一个SampleModel。
        参数
        dataType - 存储像素数据的DataBuffer的数据类型。
        w - 图像数据区域的宽度（以像素为单位）。
        h - 图像数据区域的高度（以像素为单位）。
        numBands - 图像数据的频带数。
        异常
        IllegalArgumentException - 如果 w或 h不大于0
        IllegalArgumentException - 如果 w和 h的产品大于 Integer.MAX_VALUE
        IllegalArgumentException - 如果 dataType不是支持的数据类型之一

    • 方法详细信息

      • getWidth

        public final int getWidth​()
        返回以像素为单位的宽度。
        结果
        SampleModel描述的图像数据区域的宽度（以像素为 SampleModel ）。

      • getHeight

        public final int getHeight​()
        返回以像素为单位的高度。
        结果
        SampleModel描述的图像数据区域的像素高度。

      • getNumBands

        public final int getNumBands​()
        返回图像数据的总带数。
        结果
        SampleModel描述的图像数据的频带数。

      • getNumDataElements

        public abstract int getNumDataElements​()
        返回通过getDataElements和setDataElements方法传输像素所需的数据元素数。 当通过这些方法传输像素时，可能会根据SampleModel的实现方式将其传输成打包或打包的格式。 使用这些方法，像素被传递给由getTransferType（）给出的原始类型的getNumDataElements（）元素的数组。 TransferType可能与存储DataType相同也可能不一样。
        结果
        数据元素的数量。
        另请参见：
        getDataElements(int, int, Object, DataBuffer) ， getDataElements(int, int, int, int, Object, DataBuffer) ， setDataElements(int, int, Object, DataBuffer) ， setDataElements(int, int, int, int, Object, DataBuffer) ， getTransferType()

      • getDataType

        public final int getDataType​()
        返回存储像素数据的DataBuffer的数据类型。
        结果
        数据类型。

      • getTransferType

        public int getTransferType​()
        返回用于通过getDataElements和setDataElements方法传输像素的TransferType。 当通过这些方法传输像素时，可能会根据SampleModel的实现方式将其传输成打包或打包的格式。 使用这些方法，像素被传递给由getTransferType（）给出的原始类型的getNumDataElements（）元素的数组。 TransferType可能与存储DataType相同也可能不一样。 TransferType将是DataBuffer中定义的类型之一。
        结果
        转移类型。
        另请参见：
        getDataElements(int, int, Object, DataBuffer) ， getDataElements(int, int, int, int, Object, DataBuffer) ， setDataElements(int, int, Object, DataBuffer) ， setDataElements(int, int, int, int, Object, DataBuffer) ， getNumDataElements() ， DataBuffer

      • getPixel

        public int[] getPixel​(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
        返回int数组中指定像素的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标
        y - 像素位置的Y坐标
        iArray - 如果非空，则返回此数组中的样本
        data - 包含图像数据的DataBuffer
        结果
        指定像素的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输出。
        另请参见：
        setPixel(int, int, int[], DataBuffer)

      • getDataElements

        public abstract Object getDataElements​(int x,
                                       int y,
                                       Object obj,
                                       DataBuffer data)
        返回TransferType类型的原始数组中单个像素的数据。 对于Java 2D API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 数据可以以压缩格式返回，从而提高数据传输的效率。 一般来说，obj应该以null的形式传入，这样Object将被自动创建，并且将是正确的原始数据类型。

        下面的代码说明从DataBuffer中为一个像素的数据db1 ，其存储布局由SampleModel描述sm1到DataBuffer db2 ，其存储布局由SampleModel描述sm2 。 传输通常比使用getPixel / setPixel更有效率。

          SampleModel sm1, sm2;
       DataBuffer db1, db2;
       sm2.setDataElements(x, y, sm1.getDataElements(x, y, null, db1), db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        如果obj不为空，则它应该是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界中，或者如果obj不为空且不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        obj - 如果非空，则返回像素数据的原始数组。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的数据元素。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不是边界，或者obj太小，不能保存输出。
        另请参见：
        getNumDataElements() ， getTransferType() ， DataBuffer ， setDataElements(int, int, Object, DataBuffer)

      • getDataElements

        public Object getDataElements​(int x,
                              int y,
                              int w,
                              int h,
                              Object obj,
                              DataBuffer data)
        返回TransferType类型的原始数组中指定的像素矩形的像素数据。 对于Java 2D API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 数据可以以压缩格式返回，从而提高数据传输的效率。 一般来说，obj应该以null的形式传入，这样Object将被自动创建，并且将是正确的原始数据类型。

        下面的代码说明从DataBuffer中为像素的矩形区域传送数据db1 ，其存储布局由SampleModel描述sm1到DataBuffer db2 ，其存储布局由SampleModel描述sm2 。 传输通常比使用getPixels / setPixels更有效率。

          SampleModel sm1, sm2;
       DataBuffer db1, db2;
       sm2.setDataElements(x, y, w, h, sm1.getDataElements(x, y, w,
                           h, null, db1), db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        如果obj不为空，则它应该是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界中，或者如果obj不为空且不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        参数
        x - 像素矩形的最小X坐标。
        y - 像素矩形的最小Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        obj - 如果非空，则返回像素数据的原始数组。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素区域的数据元素。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不是边界，或者obj太小，不能容纳输出。
        另请参见：
        getNumDataElements() ， getTransferType() ， setDataElements(int, int, int, int, Object, DataBuffer) ， DataBuffer

      • setDataElements

        public abstract void setDataElements​(int x,
                                     int y,
                                     Object obj,
                                     DataBuffer data)
        从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。 对于Java 2D API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 阵列中的数据可以是压缩格式，从而提高数据传输的效率。

        下面的代码说明从DataBuffer中为一个像素的数据db1 ，其存储布局由SampleModel描述sm1到DataBuffer db2 ，其存储布局由SampleModel描述sm2 。 传输通常比使用getPixel / setPixel更有效率。

          SampleModel sm1, sm2;
       DataBuffer db1, db2;
       sm2.setDataElements(x, y, sm1.getDataElements(x, y, null, db1),
                           db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        obj必须是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界，或者如果obj不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        obj - 包含像素数据的原始数组。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者obj太小而不能容纳输入。
        另请参见：
        getNumDataElements() ， getTransferType() ， getDataElements(int, int, Object, DataBuffer) ， DataBuffer

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            int w,
                            int h,
                            Object obj,
                            DataBuffer data)
        从TransferType类型的原始数组中设置指定DataBuffer中像素矩形的数据。 对于Java 2D API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 阵列中的数据可以是压缩格式，从而提高数据传输的效率。

        下面的代码说明从DataBuffer中为像素的矩形区域传送数据db1 ，其存储布局由SampleModel描述sm1到DataBuffer db2 ，其存储布局由SampleModel描述sm2 。 传输通常比使用getPixels / setPixels更有效率。

          SampleModel sm1, sm2;
       DataBuffer db1, db2;
       sm2.setDataElements(x, y, w, h, sm1.getDataElements(x, y, w, h,
                           null, db1), db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        obj必须是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界，或者如果obj不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        参数
        x - 像素矩形的最小X坐标。
        y - 像素矩形的最小Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        obj - 包含像素数据的原始数组。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不是边界，或者obj太小，不能容纳输入。
        另请参见：
        getNumDataElements() ， getTransferType() ， getDataElements(int, int, int, int, Object, DataBuffer) ， DataBuffer

      • getPixel

        public float[] getPixel​(int x,
                        int y,
                        float[] fArray,
                        DataBuffer data)
        返回float数组中指定像素的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        fArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果fArray太小，不能容纳输出。
        另请参见：
        setPixel(int, int, float[], DataBuffer)

      • getPixel

        public double[] getPixel​(int x,
                         int y,
                         double[] dArray,
                         DataBuffer data)
        返回double数组中指定像素的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        dArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果dArray太小，不能容纳输出。
        另请参见：
        setPixel(int, int, double[], DataBuffer)

      • getPixels

        public int[] getPixels​(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
        返回int数组中像素矩形的所有样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        iArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素区域的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输出。
        另请参见：
        setPixels(int, int, int, int, int[], DataBuffer)

      • getPixels

        public float[] getPixels​(int x,
                         int y,
                         int w,
                         int h,
                         float[] fArray,
                         DataBuffer data)
        返回float数组中像素矩形的所有样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        fArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素区域的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果fArray太小，不能容纳输出。
        另请参见：
        setPixels(int, int, int, int, float[], DataBuffer)

      • getPixels

        public double[] getPixels​(int x,
                          int y,
                          int w,
                          int h,
                          double[] dArray,
                          DataBuffer data)
        返回双阵列中像素矩形的所有样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        dArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素区域的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者如果dArray太小，不能容纳输出。
        另请参见：
        setPixels(int, int, int, int, double[], DataBuffer)

      • getSample

        public abstract int getSample​(int x,
                              int y,
                              int b,
                              DataBuffer data)
        将位于（x，y）处的像素的指定带中的样本返回为int。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队返回。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的指定频带中的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。
        另请参见：
        setSample(int, int, int, int, DataBuffer)

      • getSampleFloat

        public float getSampleFloat​(int x,
                            int y,
                            int b,
                            DataBuffer data)
        将位于（x，y）处的像素的指定带中的样本作为浮点返回。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队返回。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的指定频带中的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • getSampleDouble

        public double getSampleDouble​(int x,
                              int y,
                              int b,
                              DataBuffer data)
        将位于（x，y）的像素的指定带中的样本返回为双倍。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队返回。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的指定频带中的样本。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • getSamples

        public int[] getSamples​(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
        返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队返回。
        iArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        针对指定区域的像素的指定波段的采样。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果iArray太小，不能容纳输出。
        另请参见：
        setSamples(int, int, int, int, int, int[], DataBuffer)

      • getSamples

        public float[] getSamples​(int x,
                          int y,
                          int w,
                          int h,
                          int b,
                          float[] fArray,
                          DataBuffer data)
        返回浮点数组中指定的像素矩形的指定波段的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队返回。
        fArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        针对指定区域的像素的指定波段的采样。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果fArray太小而不能保存输出。
        另请参见：
        setSamples(int, int, int, int, int, float[], DataBuffer)

      • getSamples

        public double[] getSamples​(int x,
                           int y,
                           int w,
                           int h,
                           int b,
                           double[] dArray,
                           DataBuffer data)
        返回双阵列中指定的像素矩形的指定波段的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队返回。
        dArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        针对指定区域的像素的指定波段的采样。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果dArray太小而不能容纳输出。
        另请参见：
        setSamples(int, int, int, int, int, double[], DataBuffer)

      • setPixel

        public void setPixel​(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
        使用int数组的样本数据来设置DataBuffer中的一个像素。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        iArray - int数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果iArray或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输入。
        另请参见：
        getPixel(int, int, int[], DataBuffer)

      • setPixel

        public void setPixel​(int x,
                     int y,
                     float[] fArray,
                     DataBuffer data)
        使用用于输入的样本的浮点数组来设置DataBuffer中的像素。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        fArray - 浮点数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果fArray或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者如果fArray太小，不能容纳输入。
        另请参见：
        getPixel(int, int, float[], DataBuffer)

      • setPixel

        public void setPixel​(int x,
                     int y,
                     double[] dArray,
                     DataBuffer data)
        在DataBuffer中使用双重样本数组来设置像素。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        dArray - 双数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果 NullPointerException或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者如果fArray太小，不能容纳输入。
        另请参见：
        getPixel(int, int, double[], DataBuffer)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
        从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        iArray - int数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果iArray或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输入。
        另请参见：
        getPixels(int, int, int, int, int[], DataBuffer)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      float[] fArray,
                      DataBuffer data)
        从包含每个数组元素一个样本的浮点数组设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        fArray - 在float数组中输入的样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果fArray或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果fArray太小，不能容纳输入。
        另请参见：
        getPixels(int, int, int, int, float[], DataBuffer)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      double[] dArray,
                      DataBuffer data)
        从包含每个数组元素一个样本的双数组中设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        dArray - 双数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果 NullPointerException或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果dArray太小，不能容纳输入。
        另请参见：
        getPixels(int, int, int, int, double[], DataBuffer)

      • setSample

        public abstract void setSample​(int x,
                               int y,
                               int b,
                               int s,
                               DataBuffer data)
        使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队设置。
        s - 输入样本为int。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      float s,
                      DataBuffer data)
        使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。 此方法的默认实现将输入float样本转换为int，然后使用该int值调用setSample(int, int, int, DataBuffer)方法。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队设置。
        s - 输入样本为浮点数。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      double s,
                      DataBuffer data)
        对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。 此方法的默认实现将输入double样本转换为int，然后使用该int值调用setSample(int, int, int, DataBuffer)方法。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队设置。
        s - 输入样本为双倍。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
        从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队设置。
        iArray - int数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果iArray或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果iArray太小而不能容纳输入。
        另请参见：
        getSamples(int, int, int, int, int, int[], DataBuffer)

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       float[] fArray,
                       DataBuffer data)
        从包含每个数组元素一个样本的浮点数组中为指定的像素矩形设置指定带中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队设置。
        fArray - 一个浮点数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果fArray或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果fArray太小而不能容纳输入。
        另请参见：
        getSamples(int, int, int, int, int, float[], DataBuffer)

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       double[] dArray,
                       DataBuffer data)
        从包含每个数组元素一个样本的双阵列的像素的指定矩形中设置样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队设置。
        dArray - 双数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        异常
        NullPointerException - 如果 NullPointerException或数据为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果dArray太小而不能容纳输入。
        另请参见：
        getSamples(int, int, int, int, int, double[], DataBuffer)

      • createCompatibleSampleModel

        public abstract SampleModel createCompatibleSampleModel​(int w,
                                                        int h)
        创建一个SampleModel，它描述了SampleModel格式的数据，但是具有不同的宽度和高度。
        参数
        w - 图像数据的宽度
        h - 图像数据的高度
        结果
        一个 SampleModel描述相同的图像数据，因为这 SampleModel ，但具有不同的尺寸。

      • createSubsetSampleModel

        public abstract SampleModel createSubsetSampleModel​(int[] bands)
        使用此SampleModel的一个子带子创建一个新的SampleModel。
        参数
        bands - 这个 SampleModel的频带子集
        结果
        一个 SampleModel带有这个 SampleModel的频带子集。

      • createDataBuffer

        public abstract DataBuffer createDataBuffer​()
        创建与此SampleModel对应的DataBuffer。 DataBuffer的宽度和高度将与此SampleModel匹配。
        结果
        一个 DataBuffer对应这个 SampleModel 。

      • getSampleSize

        public abstract int[] getSampleSize​()
        返回所有频段的采样位数。
        结果
        所有频段的样本大小。

      • getSampleSize

        public abstract int getSampleSize​(int band)
        返回指定波段的采样位的大小。
        参数
        band - 指定的乐队
        结果
        the size of the samples of the specified band.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ShortLookupTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class ShortLookupTable

  • java.lang.Object
    • java.awt.image.LookupTable
      • java.awt.image.ShortLookupTable

  • public class ShortLookupTable
extends LookupTable
    这个类定义了一个查找表对象。 使用此类的对象的查找操作的输出被解释为无符号短数量。 查找表包含用于图像的一个或多个频带（或组件）的短数据阵列，并且它包含在索引数组之前将从输入值中减去的偏移量。 这允许为受限输入提供小于本机数据大小的数组。 如果查找表中只有一个数组，它将被应用于所有频带。
    另请参见：
    ByteLookupTable ， LookupOp

    • 构造方法摘要

      构造方法
      Constructor 描述
      ShortLookupTable​(int offset, short[] data)
      构造一个ShortLookupTable对象从一个短数组，表示每个频段的查找表。
      ShortLookupTable​(int offset, short[][] data)
      从表示每个频段的查找表的短数组数组构造一个ShortLookupTable对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      short[][] getTable​()
      通过引用返回查找表数据。
      int[] lookupPixel​(int[] src, int[] dst)
      返回用查找表翻译的像素数组。
      short[] lookupPixel​(short[] src, short[] dst)
      返回用查找表翻译的像素数组。

      • Methods inherited from class java.awt.image.LookupTable

        getNumComponents, getOffset

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ShortLookupTable

        public ShortLookupTable​(int offset,
                        short[][] data)
        从表示每个频段的查找表的短数组数组构造一个ShortLookupTable对象。 在索引到数组之前，将从输入值中减去偏移量。 频带数是数据参数的长度。 存储每个频带的数据阵列作为参考。
        参数
        offset - 在索引到数组之前从输入值中减去的值
        data - 表示每个频带的查找表的短阵列数组

      • ShortLookupTable

        public ShortLookupTable​(int offset,
                        short[] data)
        构造一个ShortLookupTable对象从一个短数组，表示每个频段的查找表。 在索引到数组之前，将从输入值中减去偏移量。 数据数组作为参考存储。
        参数
        offset - 在索引到数组之前从输入值中减去的值
        data - 一组短裤

    • 方法详细信息

      • getTable

        public final short[][] getTable​()
        通过引用返回查找表数据。 如果使用单个短数组构建此ShortLookupTable，则返回的数组的长度为1。
        结果
        ShortLookupTable数据数组。

      • lookupPixel

        public int[] lookupPixel​(int[] src,
                         int[] dst)
        返回用查找表翻译的像素数组。 源和目标数组可以是同一个数组。 返回数组dst 。
        Specified by:
        lookupPixel在 LookupTable
        参数
        src - 源数组。
        dst - 目标数组。 该数组必须至少等于src 。 如果dst是null ，则将分配一个与src相同长度的新数组。
        结果
        阵列 dst ，一个 int列阵内的样本。
        异常
        ArrayIndexOutOfBoundsException -如果 src长于 dst或如果出于任何元件 i的 src ， (src[i]&0xffff)-offset是小于零或者大于或等于查找表的长度为任何频带。

      • lookupPixel

        public short[] lookupPixel​(short[] src,
                           short[] dst)
        返回用查找表翻译的像素数组。 源和目标数组可以是同一个数组。 返回数组dst 。
        参数
        src - 源数组。
        dst - 目标数组。 该数组必须至少等于src 。 如果dst是null ，将分配一个与src相同长度的新数组。
        结果
        阵列 dst ，一个 int数组的样本。
        异常
        ArrayIndexOutOfBoundsException -如果 src长于 dst或如果出于任何元件 i的 src ， (src[i]&0xffff)-offset是小于零或者大于或等于查找表的长度为任何频带。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SinglePixelPackedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class SinglePixelPackedSampleModel

  • java.lang.Object
    • java.awt.image.SampleModel
      • java.awt.image.SinglePixelPackedSampleModel

  • public class SinglePixelPackedSampleModel
extends SampleModel
    该类表示打包的像素数据，使得构成单个像素的N个采样被存储在单个数据阵列元素中，并且每个数据数据阵列元素仅保存一个像素的采样。 该类支持TYPE_BYTE ， TYPE_USHORT ， TYPE_INT数据类型。 所有数据数组元素驻留在DataBuffer的第一个存储区中。 提供存取方法，以便可以直接操纵图像数据。 扫描线步幅是给定样本与下一个扫描线同一列中相应样本之间的数据数组元素数。 位掩码是提取表示像素的带的样本所需的掩码。 位偏移是表示像素的带的样本的数据数组元素中的位的偏移量。

    以下代码说明从DataBuffer data提取表示b的像素x,y的样本的比特：

       int sample = data.getElem(y * scanlineStride + x); sample = (sample & bitMasks[b]) >>> bitOffsets[b];

    • Field Summary

      • Fields inherited from class java.awt.image.SampleModel

        dataType, height, numBands, width

    • 构造方法摘要

      构造方法
      Constructor 描述
      SinglePixelPackedSampleModel​(int dataType, int w, int h, int[] bitMasks)
      构造一个具有bitMasks.length带的SinglePixelPackedSampleModel。
      SinglePixelPackedSampleModel​(int dataType, int w, int h, int scanlineStride, int[] bitMasks)
      构造一个SinglePixelPackedSampleModel，其bitMasks.length带和扫描线步长等于scanlineStride数据数组元素。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SampleModel createCompatibleSampleModel​(int w, int h)
      创建一个具有指定宽度和高度的新SinglePixelPackedSampleModel。
      DataBuffer createDataBuffer​()
      创建与此SinglePixelPackedSampleModel对应的DataBuffer。
      SampleModel createSubsetSampleModel​(int[] bands)
      这将创建一个新的SinglePixelPackedSampleModel与该SinglePixelPackedSampleModel的频带的子集。
      boolean equals​(Object o)
      指示一些其他对象是否等于此。
      int[] getBitMasks​()
      返回所有频段的位掩码。
      int[] getBitOffsets​()
      将位偏移返回到表示所有频带的像素的数据数组元素中。
      Object getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      int getNumDataElements​()
      返回通过getDataElements和setDataElements方法传输一个像素所需的数据元素数。
      int getOffset​(int x, int y)
      返回像素（x，y）的偏移（在数据数组元素中）。
      int[] getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的所有样本。
      int[] getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。
      int getSample​(int x, int y, int b, DataBuffer data)
      返回为位于（x，y）处的像素的指定带中的样本int。
      int[] getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。
      int[] getSampleSize​()
      返回所有频带的每个样本的位数。
      int getSampleSize​(int band)
      返回指定频带的每个样本的位数。
      int getScanlineStride​()
      返回此SinglePixelPackedSampleModel的扫描线步幅。
      int hashCode​()
      返回对象的哈希码值。
      void setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。
      void setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用int数组的样本数据来设置DataBuffer中的一个像素。
      void setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void setSample​(int x, int y, int b, int s, DataBuffer data)
      使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。
      void setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.image.SampleModel

        getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSampleDouble, getSampleFloat, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSample, setSample, setSamples, setSamples

    • 构造方法详细信息

      • SinglePixelPackedSampleModel

        public SinglePixelPackedSampleModel​(int dataType,
                                    int w,
                                    int h,
                                    int[] bitMasks)
        构造一个具有bitMasks.length带的SinglePixelPackedSampleModel。 每个样本存储在数据数组元素中位于其相应位掩码的位置。 每个位掩码必须是连续的，掩码不能重叠。 超过数据类型容量的位掩码将被截断。
        参数
        dataType - 存储样本的数据类型。
        w - 描述的图像数据区域的宽度（以像素为单位）。
        h - 描述的图像数据的区域的高度（以像素为单位）。
        bitMasks - 所有频段的位掩码。
        异常
        IllegalArgumentException -如果 dataType不是非此即彼 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT

      • SinglePixelPackedSampleModel

        public SinglePixelPackedSampleModel​(int dataType,
                                    int w,
                                    int h,
                                    int scanlineStride,
                                    int[] bitMasks)
        构造一个SinglePixelPackedSampleModel，其bitMasks.length带和扫描线步长等于scanlineStride数据数组元素。 每个样本存储在数据数组元素中位于其相应位掩码的位置。 每个位掩码必须是连续的，掩码不能重叠。 超过数据类型容量的位掩码将被截断。
        参数
        dataType - 存储样品的数据类型。
        w - 描述的图像数据区域的宽度（以像素为单位）。
        h - 描述的图像数据区域的高度（以像素为单位）。
        scanlineStride - 图像数据的行走。
        bitMasks - 所有频段的位掩码。
        异常
        IllegalArgumentException - 如果 w或 h不大于0
        IllegalArgumentException -如果在任何掩模 bitMask不是连续的
        IllegalArgumentException -如果 dataType不是非此即彼 DataBuffer.TYPE_BYTE ， DataBuffer.TYPE_USHORT ，或 DataBuffer.TYPE_INT

    • 方法详细信息

      • getNumDataElements

        public int getNumDataElements​()
        返回通过getDataElements和setDataElements方法传输一个像素所需的数据元素数。 对于SinglePixelPackedSampleModel，这是一个。
        Specified by:
        getNumDataElements SampleModel
        结果
        数据元素的数量。
        另请参见：
        SampleModel.getDataElements(int, int, Object, DataBuffer) ， SampleModel.getDataElements(int, int, int, int, Object, DataBuffer) ， SampleModel.setDataElements(int, int, Object, DataBuffer) ， SampleModel.setDataElements(int, int, int, int, Object, DataBuffer) ， SampleModel.getTransferType()

      • createCompatibleSampleModel

        public SampleModel createCompatibleSampleModel​(int w,
                                               int h)
        创建一个具有指定宽度和高度的新SinglePixelPackedSampleModel。 新的SinglePixelPackedSampleModel将具有与此SinglePixelPackedSampleModel相同的存储数据类型和位掩码。
        Specified by:
        createCompatibleSampleModel在类 SampleModel
        参数
        w - 所得的宽度 SampleModel
        h - 所得的 SampleModel的高度
        结果
        一个 SinglePixelPackedSampleModel具有指定的宽度和高度。
        异常
        IllegalArgumentException - 如果 w或 h不大于0

      • createDataBuffer

        public DataBuffer createDataBuffer​()
        创建与此SinglePixelPackedSampleModel对应的DataBuffer。 DataBuffer的数据类型和大小将与此SinglePixelPackedSampleModel一致。 DataBuffer将有一个单独的银行。
        Specified by:
        createDataBuffer在 SampleModel
        结果
        一个 DataBuffer对应这个 SampleModel 。

      • getSampleSize

        public int[] getSampleSize​()
        返回所有频带的每个样本的位数。
        Specified by:
        getSampleSize在 SampleModel
        结果
        所有频段的样本大小。

      • getSampleSize

        public int getSampleSize​(int band)
        返回指定频带的每个样本的位数。
        Specified by:
        getSampleSize在 SampleModel
        参数
        band - 指定的乐队
        结果
        指定频段样本的大小。

      • getOffset

        public int getOffset​(int x,
                     int y)
        返回像素（x，y）的偏移（在数据数组元素中）。 可以使用SinglePixelPackedSampleModel sppsm从DataBuffer data检索包含像素x,y的数据元素：
          data.getElem(sppsm.getOffset(x, y));
        参数
        x - 指定像素的X坐标
        y - 指定像素的Y坐标
        结果
        指定像素的偏移量。

      • getBitOffsets

        public int[] getBitOffsets​()
        将位偏移返回到表示所有频带的像素的数据数组元素中。
        结果
        位偏移表示所有频带的像素。

      • getBitMasks

        public int[] getBitMasks​()
        返回所有频段的位掩码。
        结果
        所有乐队的位掩码。

      • getScanlineStride

        public int getScanlineStride​()
        返回此SinglePixelPackedSampleModel的扫描线步幅。
        结果
        该扫描线步幅为 SinglePixelPackedSampleModel 。

      • createSubsetSampleModel

        public SampleModel createSubsetSampleModel​(int[] bands)
        这将创建一个新的SinglePixelPackedSampleModel与该SinglePixelPackedSampleModel的频带的子集。 新的SinglePixelPackedSampleModel可以与现有的SinglePixelPackedSampleModel可以一起使用的任何DataBuffer使用。 新的SinglePixelPackedSampleModel / DataBuffer组合将表示具有原始SinglePixelPackedSampleModel / DataBuffer组合的带子集的图像。
        Specified by:
        createSubsetSampleModel在 SampleModel
        参数
        bands - 这个 SampleModel的频带子集
        结果
        一个 SampleModel与这个 SampleModel的频带的子集。
        异常
        RasterFormatException - 如果频带参数的长度大于样本模型中的频带数。

      • getDataElements

        public Object getDataElements​(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
        返回TransferType类型的原始数组中单个像素的数据。 对于SinglePixelPackedSampleModel，该数组将具有一个元素，该类型将与存储数据类型相同。 一般来说，obj应该以null的形式传入，这样Object将被自动创建，并且将是正确的原始数据类型。

        下面的代码说明从DataBuffer中为一个像素的数据db1 ，其存储布局由SinglePixelPackedSampleModel，它描述sppsm1到DataBuffer db2 ，其存储布局由SinglePixelPackedSampleModel，它描述sppsm2 。 传输通常比使用getPixel / setPixel更有效率。

          SinglePixelPackedSampleModel sppsm1, sppsm2;
       DataBufferInt db1, db2;
       sppsm2.setDataElements(x, y, sppsm1.getDataElements(x, y, null,
                              db1), db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        如果obj不为空，则它应该是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界中，或者如果obj不为空且不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        Specified by:
        getDataElements在 SampleModel
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        obj - 如果非空，则返回像素数据的原始数组。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的数据。
        另请参见：
        setDataElements(int, int, Object, DataBuffer)

      • getPixel

        public int[] getPixel​(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
        返回int数组中指定像素的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getPixel在 SampleModel
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        iArray - 如果非空，则返回此数组中的样本
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的所有样本。
        另请参见：
        setPixel(int, int, int[], DataBuffer)

      • getPixels

        public int[] getPixels​(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
        返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getPixels在 SampleModel
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        iArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素区域的所有样本。
        另请参见：
        setPixels(int, int, int, int, int[], DataBuffer)

      • getSample

        public int getSample​(int x,
                     int y,
                     int b,
                     DataBuffer data)
        返回为位于（x，y）处的像素的指定带中的样本int。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        Specified by:
        getSample在 SampleModel
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队返回。
        data - 包含图像数据的DataBuffer。
        结果
        指定像素的指定频带中的样本。
        另请参见：
        setSample(int, int, int, int, DataBuffer)

      • getSamples

        public int[] getSamples​(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
        返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        getSamples在类 SampleModel
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队返回。
        iArray - 如果非空，则返回此数组中的样本。
        data - 包含图像数据的DataBuffer。
        结果
        针对指定区域的像素的指定波段的采样。
        另请参见：
        setSamples(int, int, int, int, int, int[], DataBuffer)

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
        从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。 对于SinglePixelPackedSampleModel，只有数组的第一个元素将保存有效数据，并且数组的类型必须与SinglePixelPackedSampleModel的存储数据类型相同。

        下面的代码说明从DataBuffer中为一个像素的数据db1 ，其存储布局由SinglePixelPackedSampleModel，它描述sppsm1到DataBuffer db2 ，其存储布局由SinglePixelPackedSampleModel，它描述sppsm2 。 传输通常比使用getPixel / setPixel更有效率。

          SinglePixelPackedSampleModel sppsm1, sppsm2;
       DataBufferInt db1, db2;
       sppsm2.setDataElements(x, y, sppsm1.getDataElements(x, y, null,
                              db1), db2);
        如果SampleModels具有相同数量的频带，则使用getDataElements / setDataElements在两个DataBuffer / SampleModel对之间传输是合法的，相应的频带具有与每个样本相同的位数，TransferTypes是相同的。

        obj必须是TransferType类型的原始数组。 否则，抛出ClassCastException。 如果坐标不在边界，或者如果obj不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。

        Specified by:
        setDataElements在 SampleModel
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        obj - 包含像素数据的原始数组。
        data - 包含图像数据的DataBuffer。
        另请参见：
        getDataElements(int, int, Object, DataBuffer)

      • setPixel

        public void setPixel​(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
        使用int数组的样本数据来设置DataBuffer中的一个像素。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setPixel在 SampleModel
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        iArray - int数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        另请参见：
        getPixel(int, int, int[], DataBuffer)

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
        从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setPixels在 SampleModel
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        iArray - int数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        另请参见：
        getPixels(int, int, int, int, int[], DataBuffer)

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
        使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        Specified by:
        setSample在 SampleModel
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队设置。
        s - 输入样本为int。
        data - 包含图像数据的DataBuffer。
        另请参见：
        getSample(int, int, int, DataBuffer)

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
        从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。
        重写：
        setSamples在 SampleModel
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队设置。
        iArray - int数组中的输入样本。
        data - 包含图像数据的DataBuffer。
        另请参见：
        getSamples(int, int, int, int, int, int[], DataBuffer)

      • equals

        public boolean equals​(Object o)
        描述从类别复制Object
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 一致 ：对于任何非空参考值x和y ，多重调用x.equals(y)始终返回true或一致返回false ，前提是在equals对对象使用的信息进行了修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的通用合同，该方法规定相等的对象必须具有相等的哈希码。

        重写：
        equals在 Object
        参数
        o - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        描述从类别复制Object
        返回对象的哈希码值。 支持这种方法是为了散列表的利益，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果两个对象根据equals(Object)方法相等，则在两个对象中的每一个上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，那么在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TileObserver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface TileObserver

  • public interface TileObserver
    一个对象的界面，希望在WritableRenderedImage的图块被一些作者通过调用getWritableTile以及当通过最后一次调用releaseWritableTile变得不可修改时被通知。
    另请参见：
    WritableRenderedImage

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void tileUpdate​(WritableRenderedImage source, int tileX, int tileY, boolean willBeWritable)
      瓦片即将更新（即将要被书写，或正在从写作中释放）。

    • 方法详细信息

      • tileUpdate

        void tileUpdate​(WritableRenderedImage source,
                int tileX,
                int tileY,
                boolean willBeWritable)
        瓦片即将更新（即将要被书写，或正在从写作中释放）。
        参数
        source - 拥有该图块的图像。
        tileX - 要更新的 tileX的X索引。
        tileY - 正在更新的 tileY的Y索引。
        willBeWritable - 如果是，则瓦片将被抓取写入; 否则正在被释放。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.image (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.image

  • Packages that use java.awt.image
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
  • Classes in java.awt.image used by java.applet
    Class 描述
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
  • Classes in java.awt.image used by java.awt
    Class 描述
    BufferedImage
    BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
    BufferedImageOp
    此接口描述对 BufferedImage对象执行的单输入/单输出操作。
    BufferStrategy
    BufferStrategy类表示在特定的 Canvas或 Window上组织复杂内存的机制。
    ColorModel
    ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和alpha分量的方法。
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
    ImageProducer
    可以为图像生成图像数据的对象的界面。
    MultiResolutionImage
    该接口被设计为一些Image的一些实现支持的可选附加API，以允许它们为各种渲染分辨率提供备用图像。
    Raster
    表示矩形像素阵列的类。
    RenderedImage
    RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。
    VolatileImage
    VolatileImage是由于超出应用程序控制的情况（例如由操作系统或其他应用程序引起的情况），可能随时丢失其内容的映像。
    WritableRaster
    该类扩展了Raster，以提供像素写入功能。
  • Classes in java.awt.image used by java.awt.image
    Class 描述
    AbstractMultiResolutionImage
    该类为要实现 MultiResolutionImage接口的类提供了几个 Image方法的默认实现。
    BufferedImage
    BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
    BufferedImageOp
    该界面描述了对 BufferedImage对象执行的单输入/单输出操作。
    ColorModel
    ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和Alpha组件的方法。
    ComponentSampleModel
    该类表示存储的图像数据，使得像素的每个样本占据DataBuffer的一个数据元素。
    DataBuffer
    此类存在用于包装一个或多个数据数组。
    ImageConsumer
    通过ImageProducer界面表示对图像数据感兴趣的对象的界面。
    ImageFilter
    此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
    ImageProducer
    可以为图像生成图像数据的对象的界面。
    IndexColorModel
    IndexColorModel类是一个 ColorModel类，适用于由单个样本组成的像素值，该样本是默认sRGB颜色空间中固定色彩映射的索引。
    Kernel
    Kernel类定义了一个矩阵，描述指定像素及其周围像素如何影响对滤波操作的输出图像中像素的位置计算的值。
    LookupTable
    这个抽象类定义了一个查找表对象。
    MultiResolutionImage
    该界面被设计为一些Image的一些实现支持的可选附加API，以允许它们为各种渲染分辨率提供备用图像。
    PackedColorModel
    PackedColorModel类是一个抽象的ColorModel类，它与像素值一起使用，它们将颜色和alpha信息表示为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。
    Raster
    表示矩形像素阵列的类。
    RasterOp
    该界面介绍了对栅格对象执行的单输入/单输出操作。
    RenderedImage
    RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。
    ReplicateScaleFilter
    一个ImageFilter类，用于使用最简单的算法缩放图像。
    SampleModel
    这个抽象类定义了一个用于提取图像中像素样本的接口。
    TileObserver
    一个对象的界面，希望在WritableRenderedImage的图块被一些作者通过调用getWritableTile以及当通过最后一次调用releaseWritableTile变得不可修改时被通知。
    WritableRaster
    该类扩展了Raster，以提供像素写入功能。
    WritableRenderedImage
    WritableRenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口，可以修改和/或写入。
  • Classes in java.awt.image used by java.awt.image.renderable
    Class 描述
    ImageConsumer
    通过ImageProducer界面表示对图像数据感兴趣的对象的界面。
    ImageProducer
    可以为图像生成图像数据的对象的界面。
    RenderedImage
    RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。
  • Classes in java.awt.image used by javafx.embed.swing
    Class 描述
    BufferedImage
    BufferedImage子类描述了具有可访问的图像数据缓冲区的Image 。
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
  • Classes in java.awt.image used by javax.imageio
    Class 描述
    BufferedImage
    BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
    ColorModel
    ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和Alpha组件的方法。
    Raster
    表示矩形像素阵列的类。
    RenderedImage
    RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。
    SampleModel
    这个抽象类定义了一个用于提取图像中像素样本的接口。
  • Classes in java.awt.image used by javax.imageio.event
    Class 描述
    BufferedImage
    BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
  • Classes in java.awt.image used by javax.imageio.spi
    Class 描述
    RenderedImage
    RenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口。
  • Classes in java.awt.image used by javax.swing
    Class 描述
    ImageConsumer
    通过ImageProducer界面表示对图像数据感兴趣的对象的界面。
    ImageFilter
    此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
    RGBImageFilter
    该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。
  • Classes in java.awt.image used by javax.swing.colorchooser
    Class 描述
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
  • Classes in java.awt.image used by javax.swing.plaf.basic
    Class 描述
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
  • Classes in java.awt.image used by javax.swing.plaf.metal
    Class 描述
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
  • Classes in java.awt.image used by javax.swing.table
    Class 描述
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
  • Classes in java.awt.image used by javax.swing.text
    Class 描述
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
  • Classes in java.awt.image used by javax.swing.tree
    Class 描述
    ImageObserver
    异步更新界面用于在构建图像时接收关于图像信息的通知。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VolatileImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class VolatileImage

  • java.lang.Object
    • java.awt.Image
      • java.awt.image.VolatileImage
  • All Implemented Interfaces:
    Transparency

    public abstract class VolatileImage
extends Image
implements Transparency
    VolatileImage是由于超出应用程序控制的情况（例如由操作系统或其他应用程序引起的情况），可能随时丢失其内容的映像。 由于具有硬件加速的潜力，因此在某些平台上，VolatileImage对象可以获得显着的性能优势。

    图像（图像内容实际存在的存储器）的绘图面可能会丢失或无效，导致该内存的内容消失。 因此，绘图表面需要被恢复或重建，并且需要重新渲染该表面的内容。 VolatileImage提供了一个界面，允许用户检测到这些问题，并在发生这些问题时进行修复。

    当创建VolatileImage对象时，可以分配诸如视频存储器（VRAM）的有限系统资源以支持图像。 当不再使用VolatileImage对象时，它可能是垃圾回收的，那些系统资源将被返回，但是这个过程在保证的时候不会发生。 创建许多VolatileImage对象的应用程序（例如，调整大小的窗口可能会随着大小的变化而强制重新启动其后端缓冲区）可能会因为旧的对象尚未从系统中删除而耗尽新的VolatileImage对象的最佳系统资源。 （新的VolatileImage对象可能仍然可以创建，但它们可能不如在加速内存中创建的对象）。 可以随时调用flush方法来主动释放由VolatileImage使用的资源，以防止后续的VolatileImage对象被加速。 以这种方式，应用程序可以更好地控制由过时的VolatileImage对象占用的资源的状态。

    此图像不应直接子类化，而应通过使用Component.createVolatileImage或GraphicsConfiguration.createCompatibleVolatileImage(int, int)方法创建。

    使用VolatileImage对象的示例如下：

      // image creation
 VolatileImage vImg = createVolatileImage(w, h);

 // rendering to the image
 void renderOffscreen() {
      do {
          if (vImg.validate(getGraphicsConfiguration()) ==
              VolatileImage.IMAGE_INCOMPATIBLE)
          {
              // old vImg doesn't work with new GraphicsConfig; re-create it
              vImg = createVolatileImage(w, h);
          }
          Graphics2D g = vImg.createGraphics();
          //
          // miscellaneous rendering commands...
          //
          g.dispose();
      } while (vImg.contentsLost());
 }

 // copying from the image (here, gScreen is the Graphics
 // object for the onscreen window)
 do {
      int returnCode = vImg.validate(getGraphicsConfiguration());
      if (returnCode == VolatileImage.IMAGE_RESTORED) {
          // Contents need to be restored
          renderOffscreen();      // restore contents
      } else if (returnCode == VolatileImage.IMAGE_INCOMPATIBLE) {
          // old vImg doesn't work with new GraphicsConfig; re-create it
          vImg = createVolatileImage(w, h);
          renderOffscreen();
      }
      gScreen.drawImage(vImg, 0, 0, this);
 } while (vImg.contentsLost());

    请注意，此类从Image类中的子类，其中包括从可能的ImageProducer接收到的信息的异步通知中使用ImageObserver参数的方法。 由于VolatileImage未从异步源加载，所以采用ImageObserver参数的各种方法将表现为已从ImageProducer获取的ImageProducer 。 具体来说，这意味着这些方法的返回值永远不会指示信息不可用，并且这种方法中使用的ImageObserver将永远不需要记录异步回调通知。

    从以下版本开始：
    1.4

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int IMAGE_INCOMPATIBLE
      验证的图像与提供的 GraphicsConfiguration对象不兼容，并应根据需要重新创建。
      static int IMAGE_OK
      经过验证的图像可以按原样使用。
      static int IMAGE_RESTORED
      已验证的图像已恢复，现在可以使用。
      protected int transparency
      创建此图像的透明度值。

      • Fields inherited from class java.awt.Image

        accelerationPriority, SCALE_AREA_AVERAGING, SCALE_DEFAULT, SCALE_FAST, SCALE_REPLICATE, SCALE_SMOOTH, UndefinedProperty

      • Fields inherited from interface java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      构造方法
      Constructor 描述
      VolatileImage​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract boolean contentsLost​()
      如果自上一次 validate调用以来，如果渲染数据丢失，则返回 true 。
      abstract Graphics2D createGraphics​()
      创建一个 Graphics2D ，可以用来绘制这个 VolatileImage 。
      abstract ImageCapabilities getCapabilities​()
      返回一个ImageCapabilities对象，可以查询该VolatileImage的具体功能。
      Graphics getGraphics​()
      此方法返回一个Graphics2D ，但这里是向后兼容性。
      abstract int getHeight​()
      返回 VolatileImage的高度。
      abstract BufferedImage getSnapshot​()
      返回此对象的静态快照图像。
      ImageProducer getSource​()
      这将为此VolatileImage返回ImageProducer。
      int getTransparency​()
      返回透明度。
      abstract int getWidth​()
      返回 VolatileImage的宽度。
      abstract int validate​(GraphicsConfiguration gc)
      如果自从最后一次 validate调用以来表面已经丢失，则尝试恢复图像的绘图面。

      • Methods inherited from class java.awt.Image

        flush, getAccelerationPriority, getCapabilities, getHeight, getProperty, getScaledInstance, getWidth, setAccelerationPriority

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • IMAGE_OK

        public static final int IMAGE_OK
        经过验证的图像可以按原样使用。
        另请参见：
        Constant Field Values

      • IMAGE_RESTORED

        public static final int IMAGE_RESTORED
        已验证的图像已恢复，现在可以使用。 请注意，恢复会导致图像内容丢失。
        另请参见：
        Constant Field Values

      • IMAGE_INCOMPATIBLE

        public static final int IMAGE_INCOMPATIBLE
        验证的图像与提供的GraphicsConfiguration对象不兼容，并应根据需要重新创建。 从validate收到此返回码后，图像按validate是未定义的。
        另请参见：
        Constant Field Values

      • transparency

        protected int transparency
        创建此图像的透明度值。
        从以下版本开始：
        1.5
        另请参见：
        GraphicsConfiguration.createCompatibleVolatileImage(int, int,int) ， GraphicsConfiguration.createCompatibleVolatileImage(int, int,ImageCapabilities,int) ， Transparency

    • 构造方法详细信息

      • VolatileImage

        public VolatileImage​()

    • 方法详细信息

      • getSnapshot

        public abstract BufferedImage getSnapshot​()
        返回此对象的静态快照图像。 BufferedImage返回的只是当前的VolatileImage当前的请求，并将不会更新与任何将来的更改VolatileImage 。
        结果
        一个BufferedImage这个VolatileImage表示
        另请参见：
        BufferedImage

      • getWidth

        public abstract int getWidth​()
        返回 VolatileImage的宽度。
        结果
        该宽度为 VolatileImage 。

      • getHeight

        public abstract int getHeight​()
        返回 VolatileImage的高度。
        结果
        的高度这 VolatileImage 。

      • getSource

        public ImageProducer getSource​()
        这将为此VolatileImage返回ImageProducer。 请注意，VolatileImage对象针对渲染操作进行了优化，并将其划分到屏幕或其他VolatileImage对象上，而不是读取图像的像素。 因此，诸如getSource操作可能不像不依赖于读取像素的操作那样快。 还要注意，从图像读取的像素值与图像中的像素值仅在它们被检索时才是最新的。 此方法在创建请求时获取映像的快照，并且返回的ImageProducer对象与静态快照映像（不是原始的VolatileImage）配合使用。 调用getSource（）相当于调用getSnapshot（）。getSource（）。
        Specified by:
        getSource中的 Image
        结果
        一个ImageProducer ，可用于生成此图像的BufferedImage表示的像素。
        另请参见：
        ImageProducer ， getSnapshot()

      • getGraphics

        public Graphics getGraphics​()
        此方法返回一个Graphics2D ，但这里是向后兼容性。 createGraphics更方便，因为它被声明返回一个Graphics2D 。
        Specified by:
        getGraphics中的 Image
        结果
        一个 Graphics2D ，可以用来绘制这个图像。
        另请参见：
        Graphics ， Component.createImage(int, int)

      • createGraphics

        public abstract Graphics2D createGraphics​()
        创建一个 Graphics2D ，可以用来绘制这个 VolatileImage 。
        结果
        一个 Graphics2D ，用于绘制这个图像。

      • validate

        public abstract int validate​(GraphicsConfiguration gc)
        如果自上一次validate调用以来曲面已经丢失，则尝试恢复图像的绘图面。 还可以根据给定的GraphicsConfiguration参数验证此映像，以查看从此映像到GraphicsConfiguration的操作是否兼容。 不兼容组合的示例可能是在一个图形设备上创建了VolatileImage对象，然后用于呈现到其他图形设备的情况。 由于VolatileImage对象往往是非常具体的设备，因此此操作可能无法正常工作，因此来自此验证调用的返回代码将注意到不兼容。 gc的空值或不正确的值可能会导致从validate返回错误的值，并可能导致后续的渲染问题。
        参数
        gc - 要验证此图像的GraphicsConfiguration对象。 null gc意味着validate方法应该跳过兼容性测试。
        结果
        IMAGE_OK如果图像不需要验证
        IMAGE_RESTORED如果图像需要恢复。 恢复意味着图像的内容可能已经受到影响，并且可能需要重新渲染图像。
        IMAGE_INCOMPATIBLE如果图像与传递到validate方法的GraphicsConfiguration对象不兼容。 不兼容性意味着图像可能需要使用新的Component或GraphicsConfiguration重新创建，以获得可以成功使用该GraphicsConfiguration 。 不检查不兼容的图像是否需要恢复，因此在返回值为IMAGE_INCOMPATIBLE之后图像的状态不变，并且此返回值对于是否需要还原图像无关。
        另请参见：
        GraphicsConfiguration ， Component ， IMAGE_OK ， IMAGE_RESTORED ， IMAGE_INCOMPATIBLE

      • contentsLost

        public abstract boolean contentsLost​()
        如果自上一次validate调用以来，如果渲染数据丢失，则返回true 。 应该在应用程序的任何一系列渲染操作结束时从图像调用该方法，以查看图像是否需要被验证，并且渲染重做。
        结果
        true如果绘图面需要恢复; 否则为false 。

      • getCapabilities

        public abstract ImageCapabilities getCapabilities​()
        返回一个ImageCapabilities对象，可以查询该VolatileImage的具体功能。 这将允许程序员找到关于他们创建的特定VolatileImage对象的更多运行时信息。 例如，用户可能会创建一个VolatileImage，但系统可能没有可用于创建该大小图像的视频内存，因此尽管该对象是一个VolatileImage，但它并不像该平台上的其他VolatileImage对象那样加速。 用户可能希望该信息找到其他解决方案的问题。
        结果
        一个包含 VolatileImage功能的 ImageCapabilities对象。
        从以下版本开始：
        1.4

      • getTransparency

        public int getTransparency​()
        返回透明度。 返回OPAQUE，BITMASK或TRANSLUCENT。
        Specified by:
        getTransparency在接口 Transparency
        结果
        这个透明度这个 VolatileImage 。
        从以下版本开始：
        1.5
        另请参见：
        Transparency.OPAQUE ， Transparency.BITMASK ， Transparency.TRANSLUCENT
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WritableRaster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Class WritableRaster

  • java.lang.Object
    • java.awt.image.Raster
      • java.awt.image.WritableRaster

  • public class WritableRaster
extends Raster
    该类扩展了Raster，以提供像素写入功能。 有关栅格存储像素的说明，请参阅栅格的类注释。

    这个类的构造函数是受保护的。 要实例化WritableRaster，请在Raster类中使用createWritableRaster工厂方法之一。

    • Field Summary

      • Fields inherited from class java.awt.image.Raster

        dataBuffer, height, minX, minY, numBands, numDataElements, parent, sampleModel, sampleModelTranslateX, sampleModelTranslateY, width

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造WritableRaster。
      protected WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
      使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。
      protected WritableRaster​(SampleModel sampleModel, Point origin)
      使用给定的SampleModel构造WritableRaster。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      WritableRaster createWritableChild​(int parentX, int parentY, int w, int h, int childMinX, int childMinY, int[] bandList)
      返回一个新的WritableRaster，它分享这个WritableRaster的DataBuffer的全部或部分。
      WritableRaster createWritableTranslatedChild​(int childMinX, int childMinY)
      创建一个具有相同大小的WritableRaster，SampleModel和DataBuffer，但是具有不同的位置。
      WritableRaster getWritableParent​()
      返回此WritableRaster的父WritableRaster（如果有），否则返回null。
      void setDataElements​(int x, int y, int w, int h, Object inData)
      从TransferType类型的原始数组中设置一个像素矩形的数据。
      void setDataElements​(int x, int y, Raster inRaster)
      从输入光栅设置像素矩形的数据。
      void setDataElements​(int x, int y, Object inData)
      从TransferType类型的原始数组中设置单个像素的数据。
      void setPixel​(int x, int y, double[] dArray)
      在DataBuffer中使用双重样本数组来设置像素。
      void setPixel​(int x, int y, float[] fArray)
      使用用于输入的样本的浮点数组来设置DataBuffer中的像素。
      void setPixel​(int x, int y, int[] iArray)
      使用int数组的样本数据来设置DataBuffer中的一个像素。
      void setPixels​(int x, int y, int w, int h, double[] dArray)
      从包含每个数组元素一个样本的双数组中设置一个像素矩形的所有样本。
      void setPixels​(int x, int y, int w, int h, float[] fArray)
      从包含每个数组元素一个样本的浮点数组设置一个像素矩形的所有样本。
      void setPixels​(int x, int y, int w, int h, int[] iArray)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void setRect​(int dx, int dy, Raster srcRaster)
      将像素从Raster srcRaster复制到WritableRaster。
      void setRect​(Raster srcRaster)
      将像素从Raster srcRaster复制到WritableRaster。
      void setSample​(int x, int y, int b, double s)
      对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。
      void setSample​(int x, int y, int b, float s)
      使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。
      void setSample​(int x, int y, int b, int s)
      使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。
      void setSamples​(int x, int y, int w, int h, int b, double[] dArray)
      从包含每个数组元素一个样本的双阵列的像素的指定矩形中设置样本。
      void setSamples​(int x, int y, int w, int h, int b, float[] fArray)
      从包含每个数组元素一个样本的浮点数组中为指定的像素矩形设置指定带中的样本。
      void setSamples​(int x, int y, int w, int h, int b, int[] iArray)
      从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.awt.image.Raster

        createBandedRaster, createBandedRaster, createBandedRaster, createChild, createCompatibleWritableRaster, createCompatibleWritableRaster, createCompatibleWritableRaster, createCompatibleWritableRaster, createInterleavedRaster, createInterleavedRaster, createInterleavedRaster, createPackedRaster, createPackedRaster, createPackedRaster, createPackedRaster, createRaster, createTranslatedChild, createWritableRaster, createWritableRaster, getBounds, getDataBuffer, getDataElements, getDataElements, getHeight, getMinX, getMinY, getNumBands, getNumDataElements, getParent, getPixel, getPixel, getPixel, getPixels, getPixels, getPixels, getSample, getSampleDouble, getSampleFloat, getSampleModel, getSampleModelTranslateX, getSampleModelTranslateY, getSamples, getSamples, getSamples, getTransferType, getWidth

    • 构造方法详细信息

      • WritableRaster

        protected WritableRaster​(SampleModel sampleModel,
                         Point origin)
        使用给定的SampleModel构造WritableRaster。 WritableRaster的左上角是原点，与SampleModel的大小相同。 自动创建一个足以描述WritableRaster的DataBuffer。
        参数
        sampleModel - 指定布局的SampleModel。
        origin - 指定原点的点。
        异常
        RasterFormatException - 如果计算 origin.x + sampleModel.getWidth()或 origin.y + sampleModel.getHeight()导致整数溢出

      • WritableRaster

        protected WritableRaster​(SampleModel sampleModel,
                         DataBuffer dataBuffer,
                         Point origin)
        使用给定的SampleModel和DataBuffer构造WritableRaster。 WritableRaster的左上角是原点，与SampleModel的大小相同。 DataBuffer未初始化，必须与SampleModel兼容。
        参数
        sampleModel - 指定布局的SampleModel。
        dataBuffer - 包含图像数据的DataBuffer。
        origin - 指定原点的点。
        异常
        RasterFormatException - 如果计算 origin.x + sampleModel.getWidth()或 origin.y + sampleModel.getHeight()导致整数溢出

      • WritableRaster

        protected WritableRaster​(SampleModel sampleModel,
                         DataBuffer dataBuffer,
                         Rectangle aRegion,
                         Point sampleModelTranslate,
                         WritableRaster parent)
        使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。 aRegion指定新栅格的边界矩形。 当翻译成基础栅格的坐标系时，aRegion必须由基础栅格包含。 （基础栅格是没有父项的栅格的祖先。）sampleModelTranslate指定新的栅格的sampleModelTranslateX和sampleModelTranslateY值。 请注意，这个构造函数通常应该由其他构造函数调用或创建方法，不应该直接使用。
        参数
        sampleModel - 指定布局的SampleModel。
        dataBuffer - 包含图像数据的DataBuffer。
        aRegion - 指定图像区域的Rectangle。
        sampleModelTranslate - 指定从SampleModel到光栅坐标的转换的点。
        parent - 此栅格的父（如果有）。
        异常
        RasterFormatException - 如果 aRegion宽度或高度小于或等于零，或计算 aRegion.x + aRegion.width或 aRegion.y + aRegion.height导致整数溢出

    • 方法详细信息

      • getWritableParent

        public WritableRaster getWritableParent​()
        返回此WritableRaster的父WritableRaster（如果有），否则返回null。
        结果
        这是 WritableRaster的父母，还是 null 。

      • createWritableTranslatedChild

        public WritableRaster createWritableTranslatedChild​(int childMinX,
                                                    int childMinY)
        创建一个具有相同大小的WritableRaster，SampleModel和DataBuffer，但是具有不同的位置。 新的WritableRaster将拥有对当前WritableRaster的引用，可通过其getParent（）和getWritableParent（）方法访问。
        参数
        childMinX - 新栅格左上角的X坐标。
        childMinY - 新栅格左上角的Y坐标。
        结果
        一个 WritableRaster与这个相同，除了指定的位置。
        异常
        RasterFormatException - 如果计算 childMinX + this.getWidth()或 childMinY + this.getHeight()导致整数溢出

      • createWritableChild

        public WritableRaster createWritableChild​(int parentX,
                                          int parentY,
                                          int w,
                                          int h,
                                          int childMinX,
                                          int childMinY,
                                          int[] bandList)
        返回一个新的WritableRaster，它分享这个WritableRaster的DataBuffer的全部或部分。 新的WritableRaster将拥有对当前WritableRaster的引用，可通过其getParent（）和getWritableParent（）方法访问。

        parentX，parentY，width和height参数在此WritableRaster坐标空间中形成一个Rectangle，表示要共享的像素面积。 如果此Rectangle不包含当前WritableRaster的边界，则将抛出一个错误。

        新的WritableRaster可以另外被转换为与当前WritableRaster使用的平面不同的坐标系。 childMinX和childMinY参数给出返回的WritableRaster的左上角像素的新（x，y）坐标; 新的WritableRaster中的坐标（childMinX，childMinY）将映射到与当前WritableRaster中的坐标（parentX，parentY）相同的像素。

        可以通过bandList参数将新的WritableRaster定义为仅包含当前WritableRaster的可能重新排序的带的子集。 如果bandList为null，则将其当前WritableRaster的所有频带包含在当前顺序中。

        要创建一个新的WritableRaster，它包含当前WritableRaster的子区域，但共享其坐标系和带，则该方法应该被调用，childMinX等于parentX，childMinY等于parentY，bandList等于null。

        参数
        parentX - 此WritableRaster坐标中左上角的X坐标。
        parentY - 此WritableRaster坐标中左上角的Y坐标。
        w - 从（parentX，parentY）开始的区域的宽度。
        h - 从（parentX，parentY）开始的区域的高度。
        childMinX - 返回的WritableRaster的左上角的X坐标。
        childMinY - 返回的WritableRaster的左上角的Y坐标。
        bandList - 频带索引数组，或为空，以使用所有频带。
        结果
        一个 WritableRaster共享的全部或部分 DataBuffer如此 WritableRaster 。
        异常
        RasterFormatException - 如果子区域在栅格边界之外。
        RasterFormatException -如果 w或 h小于或等于0，或者计算任何的 parentX + w ， parentY + h ， childMinX + w ，或 childMinY + h导致整数溢出

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            Object inData)
        从TransferType类型的原始数组中设置单个像素的数据。 对于Java 2D（tm）API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 阵列中的数据可以是压缩格式，从而提高数据传输的效率。 如果坐标不在边界，或者inData不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。 如果输入对象不为空，并引用除TransferType数组之外的任何其他内容，则抛出ClassCastException。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        inData - 对由getTransferType（）定义的类型的数组的对象引用和包含要放置在x，y处的像素数据的length getNumDataElements（）的对象引用。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者inData太小，不能容纳输入。
        另请参见：
        SampleModel.setDataElements(int, int, Object, DataBuffer)

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            Raster inRaster)
        从输入光栅设置像素矩形的数据。 输入光栅必须与此WritableRaster兼容，因为它们必须具有相同数量的条带，相应的条带必须具有与每个样本相同的位数，TransferTypes和NumDataElements必须相同，并且getDataElements / setDataElements使用的打包必须相同。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        inRaster - 光栅包含要放置在x，y处的数据。
        异常
        NullPointerException - 如果inRaster为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界内。

      • setDataElements

        public void setDataElements​(int x,
                            int y,
                            int w,
                            int h,
                            Object inData)
        从TransferType类型的原始数组中设置一个像素矩形的数据。 对于Java 2D API支持的图像数据，这将是DataBuffer.TYPE_BYTE，DataBuffer.TYPE_USHORT，DataBuffer.TYPE_INT，DataBuffer.TYPE_SHORT，DataBuffer.TYPE_FLOAT或DataBuffer.TYPE_DOUBLE之一。 阵列中的数据可以是压缩格式，从而提高数据传输的效率。 如果坐标不在边界，或者inData不够大以容纳像素数据，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。 如果输入对象不为空，并引用除TransferType数组之外的任何其他内容，则抛出ClassCastException。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        inData - 由getTransferType（）定义的类型的数组的对象引用，以及包含要放置在x，y和x + w-1，y + h-1之间的像素数据的长度w * h * getNumDataElements（）的对象引用。
        异常
        NullPointerException - 如果inData为空。
        ArrayIndexOutOfBoundsException - 如果坐标不是边界，或者如果inData太小，不能容纳输入。
        另请参见：
        SampleModel.setDataElements(int, int, int, int, Object, DataBuffer)

      • setRect

        public void setRect​(Raster srcRaster)
        将像素从Raster srcRaster复制到WritableRaster。 srcRaster中的每个像素都将复制到该栅格中的相同x，y地址，除非地址超出了此栅格的边界。 srcRaster必须具有与此WritableRaster相同数量的乐队。 该副本是源样本的简单副本到相应的目标样本。

        如果源和目标光栅的所有样本都是整数型，小于或等于32位，则调用此方法相当于对所有x,y地址在两个栅格中有效的地址执行以下代码。

           Raster srcRaster; WritableRaster dstRaster; for (int b = 0; b < srcRaster.getNumBands(); b++) { dstRaster.setSample(x, y, b, srcRaster.getSample(x, y, b)); }
        因此，当将积分型源复制到整体型目的地时，如果源样本大小大于特定频带的目的地采样大小，则源样本的高位将被截断。 如果源样本大小小于特定频带的目的地大小，则目标的高阶位将根据srcRaster的SampleModel将该样本视为有符号或无符号数量进行零扩展或符号扩展。

        将浮点数或双源复制到整数型目的地时，将将每个源样本转换为目标类型。 当将积分类型的源复制到浮点或双目标时，首先将源转换为32位int（如有必要），使用上述的积分类型的规则，然后将int转换为float或double。

        参数
        srcRaster - 复制像素的栅格。
        异常
        NullPointerException - 如果srcRaster为空。

      • setRect

        public void setRect​(int dx,
                    int dy,
                    Raster srcRaster)
        将像素从Raster srcRaster复制到WritableRaster。 对于srcRaster中的每个（x，y）地址，相应的像素将复制到该WritableRaster中的地址（x + dx，y + dy），除非（x + dx，y + dy）超出此栅格的边界。 srcRaster必须具有与此WritableRaster相同数量的乐队。 该副本是源样本的简单副本到相应的目标样本。 详情请参阅setRect(Raster) 。
        参数
        dx - 从src空间到副本的dst空间的X转换因子。
        dy - 从src空间到副本的dst空间的Y翻译因子。
        srcRaster - 复制像素的栅格。
        异常
        NullPointerException - 如果srcRaster为空。

      • setPixel

        public void setPixel​(int x,
                     int y,
                     int[] iArray)
        使用int数组的样本数据来设置DataBuffer中的一个像素。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        iArray - int数组中的输入样本。
        异常
        NullPointerException - 如果iArray为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输入。

      • setPixel

        public void setPixel​(int x,
                     int y,
                     float[] fArray)
        使用用于输入的样本的浮点数组来设置DataBuffer中的像素。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        fArray - 浮点数组中的输入样本。
        异常
        NullPointerException - 如果fArray为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果fArray太小，不能容纳输入。

      • setPixel

        public void setPixel​(int x,
                     int y,
                     double[] dArray)
        在DataBuffer中使用双重样本数组来设置像素。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        dArray - 双数组中的输入样本。
        异常
        NullPointerException - 如果 NullPointerException为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果dArray太小，不能容纳输入。

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray)
        从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        iArray - 输入int像素数组。
        异常
        NullPointerException - 如果iArray为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果iArray太小，不能容纳输入。

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      float[] fArray)
        从包含每个数组元素一个样本的浮点数组设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        fArray - 输入浮点像素数组。
        异常
        NullPointerException - 如果fArray为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果fArray太小，不能容纳输入。

      • setPixels

        public void setPixels​(int x,
                      int y,
                      int w,
                      int h,
                      double[] dArray)
        从包含每个数组元素一个样本的双数组中设置一个像素矩形的所有样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        dArray - 输入双像素阵列。
        异常
        NullPointerException - 如果 NullPointerException为空。
        ArrayIndexOutOfBoundsException - 如果坐标不在边界，或者如果dArray太小，不能容纳输入。

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      int s)
        使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队设置。
        s - 输入样本。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      float s)
        使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队设置。
        s - 输入样本为浮点数。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • setSample

        public void setSample​(int x,
                      int y,
                      int b,
                      double s)
        对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 像素位置的X坐标。
        y - 像素位置的Y坐标。
        b - 乐队设置。
        s - 输入样本为双倍。
        异常
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内。

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray)
        从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队设置。
        iArray - 输入int样本数组。
        异常
        NullPointerException - 如果iArray为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果iArray太小而不能容纳输入。

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       float[] fArray)
        从包含每个数组元素一个样本的浮点数组中为指定的像素矩形设置指定带中的样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队设置。
        fArray - 输入float样本数组。
        异常
        NullPointerException - 如果fArray为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果fArray太小而不能容纳输入。

      • setSamples

        public void setSamples​(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       double[] dArray)
        从包含每个数组元素一个样本的双阵列的像素的指定矩形中设置样本。 如果坐标不在边界内，则可能抛出ArrayIndexOutOfBoundsException。 但是，显式边界检查不能保证。
        参数
        x - 左上角像素位置的X坐标。
        y - 左上角像素位置的Y坐标。
        w - 像素矩形的宽度。
        h - 像素矩形的高度。
        b - 乐队设置。
        dArray - 输入双样本数组。
        异常
        NullPointerException - 如果 NullPointerException为空。
        ArrayIndexOutOfBoundsException - 如果坐标或频带索引不在边界内，或者如果dArray太小而不能容纳输入。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WritableRenderedImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image

Interface WritableRenderedImage

  • All Superinterfaces:
    RenderedImage
    所有已知实现类：
    BufferedImage

    public interface WritableRenderedImage
extends RenderedImage
    WritableRenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口，可以修改和/或写入。 图像数据可以被存储/生成为单个瓦片或普通瓦片阵列。

    WritableRenderedImage在通过签出书签（通过getWritableTile方法）和特定瓦片的最后一个作者放弃其访问（通过调用releaseWritableTile）时，向其他感兴趣的对象提供通知。 另外，它允许任何调用者确定当前是否已经检出了任何图块（通过hasTileWriters），并获得这样的图块列表（通过getWritableTileIndices，以Point对象的向量的形式）。

    希望通知瓦片可写性更改的对象必须实现TileObserver接口，并通过调用addTileObserver来添加。 对同一个对象的多次调用addTileObserver将导致多个通知。 现有的观察者可以通过调用removeTileObserver来减少通知; 如果观察者没有通知，则操作是无效的。

    WritableRenderedImage有必要确保仅当第一个作者获取图块并且最后一个作者发布时才会发生通知。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addTileObserver​(TileObserver to)
      添加观察者
      WritableRaster getWritableTile​(int tileX, int tileY)
      检查一个瓦片写作。
      Point[] getWritableTileIndices​()
      返回一个Point对象数组，指示哪些tile被签出用于写入。
      boolean hasTileWriters​()
      返回是否签出任何图块以进行写入。
      boolean isTileWritable​(int tileX, int tileY)
      返回是否当前签出图块以进行写入。
      void releaseWritableTile​(int tileX, int tileY)
      放弃写入瓦片的权利。
      void removeTileObserver​(TileObserver to)
      删除观察者
      void setData​(Raster r)
      将图像的矩形设置为Raster r的内容，该Raster r假定为与WritableRenderedImage在同一坐标空间。

      • Methods inherited from interface java.awt.image.RenderedImage

        copyData, getColorModel, getData, getData, getHeight, getMinTileX, getMinTileY, getMinX, getMinY, getNumXTiles, getNumYTiles, getProperty, getPropertyNames, getSampleModel, getSources, getTile, getTileGridXOffset, getTileGridYOffset, getTileHeight, getTileWidth, getWidth

    • 方法详细信息

      • addTileObserver

        void addTileObserver​(TileObserver to)
        添加观察者 如果观察者已经存在，它将收到多个通知。
        参数
        to - 指定的 TileObserver

      • removeTileObserver

        void removeTileObserver​(TileObserver to)
        删除观察者 如果观察员没有注册，没有任何反应。 如果观察员注册了多个通知，则现在将被注册少一个。
        参数
        to - 指定的 TileObserver

      • getWritableTile

        WritableRaster getWritableTile​(int tileX,
                               int tileY)
        检查一个瓦片写作。 WritableRenderedImage负责通知所有TileObservers，当一个tile从没有写入器到一个写入器。
        参数
        tileX - 图块的X索引。
        tileY - 瓷砖的Y指数。
        结果
        一个可写的瓷砖。

      • releaseWritableTile

        void releaseWritableTile​(int tileX,
                         int tileY)
        放弃写入瓦片的权利。 如果呼叫者继续写入瓦片，结果是未定义的。 对此方法的调用只能与匹配的getContextTile调用对匹配; 任何其他用途将导致未定义的结果。 WritableRenderedImage负责通知所有TileObserver当一个tile从一个作家到没有写者。
        参数
        tileX - 图块的X索引。
        tileY - 瓷砖的Y指数。

      • isTileWritable

        boolean isTileWritable​(int tileX,
                       int tileY)
        返回是否当前签出图块以进行写入。
        参数
        tileX - 图块的X索引。
        tileY - 瓷砖的Y指数。
        结果
        true如果指定的瓦片被签出写入; 否则为false 。

      • getWritableTileIndices

        Point[] getWritableTileIndices​()
        返回一个Point对象数组，指示哪些tile被签出用于写入。 如果没有签出，则返回null。
        结果
        一个数组，其中包含被签出用于写入的图块的位置。

      • hasTileWriters

        boolean hasTileWriters​()
        返回是否签出任何图块以进行写入。 语义上相当于（getWritableTileIndices（）！= null）。
        结果
        true如果任何瓷砖被签出写作; 否则为false 。

      • setData

        void setData​(Raster r)
        将图像的矩形设置为Raster r的内容，该Raster r假定为与WritableRenderedImage在同一坐标空间。 该操作被剪切到WritableRenderedImage的边界。
        参数
        r - 指定的 Raster
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class java.awt.image.AbstractMultiResolutionImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.AbstractMultiResolutionImage

  • Packages that use AbstractMultiResolutionImage
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of AbstractMultiResolutionImage in java.awt.image

      Subclasses of AbstractMultiResolutionImage in java.awt.image
      Modifier and Type Class 描述
      class  BaseMultiResolutionImage
      这个类是基于数组的 AbstractMultiResolutionImage类的实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.AffineTransformOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.AffineTransformOp

No usage of java.awt.image.AffineTransformOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.AreaAveragingScaleFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.AreaAveragingScaleFilter

No usage of java.awt.image.AreaAveragingScaleFilter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.BandCombineOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.BandCombineOp

No usage of java.awt.image.BandCombineOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.BandedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.BandedSampleModel

No usage of java.awt.image.BandedSampleModel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.BaseMultiResolutionImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.BaseMultiResolutionImage

No usage of java.awt.image.BaseMultiResolutionImage
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.BufferedImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.BufferedImage

  • Packages that use BufferedImage
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。

    • Uses of BufferedImage in java.awt

      Methods in java.awt that return BufferedImage
      Modifier and Type 方法 描述
      BufferedImage GraphicsConfiguration.createCompatibleImage​(int width, int height)
      返回一个BufferedImage与数据布局和颜色模型兼容这个GraphicsConfiguration 。
      BufferedImage GraphicsConfiguration.createCompatibleImage​(int width, int height, int transparency)
      返回支持指定透明度的 BufferedImage ，并具有与此 GraphicsConfiguration兼容的数据布局和颜色模型。
      BufferedImage Robot.createScreenCapture​(Rectangle screenRect)
      创建包含从屏幕读取的像素的图像。
      BufferedImage TexturePaint.getImage​()
      返回用于填充形状的 BufferedImage纹理。
      Methods in java.awt with parameters of type BufferedImage
      Modifier and Type 方法 描述
      abstract Graphics2D GraphicsEnvironment.createGraphics​(BufferedImage img)
      返回一个Graphics2D对象，用于渲染到指定的BufferedImage中 。
      abstract void Graphics2D.drawImage​(BufferedImage img, BufferedImageOp op, int x, int y)
      呈现BufferedImage ，用BufferedImageOp过滤。
      Constructors in java.awt with parameters of type BufferedImage
      Constructor 描述
      TexturePaint​(BufferedImage txtr, Rectangle2D anchor)
      构造一个 TexturePaint对象。

    • Uses of BufferedImage in java.awt.image

      Methods in java.awt.image that return BufferedImage
      Modifier and Type 方法 描述
      BufferedImage IndexColorModel.convertToIntDiscrete​(Raster raster, boolean forceARGB)
      返回一个新 BufferedImage TYPE_INT_ARGB或TYPE_INT_RGB的具有 Raster通过展开源的索引来计算的与像素数据 Raster使用此的颜色/ alpha分量数组 ColorModel 。
      BufferedImage AffineTransformOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage BufferedImageOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage ColorConvertOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      给出这个来源，创建具有正确大小和频带数的归零目标图像。
      BufferedImage ConvolveOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage LookupOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage RescaleOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage AffineTransformOp.filter​(BufferedImage src, BufferedImage dst)
      转换源 BufferedImage并将结果存储在目标 BufferedImage 。
      BufferedImage BufferedImageOp.filter​(BufferedImage src, BufferedImage dest)
      在 BufferedImage上执行单输入/单输出操作。
      BufferedImage ColorConvertOp.filter​(BufferedImage src, BufferedImage dest)
      ColorConverts源BufferedImage。
      BufferedImage ConvolveOp.filter​(BufferedImage src, BufferedImage dst)
      对BufferedImages执行卷积。
      BufferedImage LookupOp.filter​(BufferedImage src, BufferedImage dst)
      对 BufferedImage执行查找操作。
      BufferedImage RescaleOp.filter​(BufferedImage src, BufferedImage dst)
      重新调整源BufferedImage。
      abstract BufferedImage VolatileImage.getSnapshot​()
      返回此对象的静态快照图像。
      BufferedImage BufferedImage.getSubimage​(int x, int y, int w, int h)
      返回由指定的矩形区域定义的子图像。
      Methods in java.awt.image with parameters of type BufferedImage
      Modifier and Type 方法 描述
      BufferedImage AffineTransformOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage BufferedImageOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage ColorConvertOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      给出这个来源，创建具有正确大小和频带数的归零目标图像。
      BufferedImage ConvolveOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage LookupOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage RescaleOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage AffineTransformOp.filter​(BufferedImage src, BufferedImage dst)
      转换源 BufferedImage并将结果存储在目标 BufferedImage 。
      BufferedImage BufferedImageOp.filter​(BufferedImage src, BufferedImage dest)
      在 BufferedImage上执行单输入/单输出操作。
      BufferedImage ColorConvertOp.filter​(BufferedImage src, BufferedImage dest)
      ColorConverts源BufferedImage。
      BufferedImage ConvolveOp.filter​(BufferedImage src, BufferedImage dst)
      对BufferedImages执行卷积。
      BufferedImage LookupOp.filter​(BufferedImage src, BufferedImage dst)
      对 BufferedImage执行查找操作。
      BufferedImage RescaleOp.filter​(BufferedImage src, BufferedImage dst)
      重新调整源BufferedImage。
      Rectangle2D AffineTransformOp.getBounds2D​(BufferedImage src)
      返回已转换目的地的边界框。
      Rectangle2D BufferedImageOp.getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D ColorConvertOp.getBounds2D​(BufferedImage src)
      给出这个源，返回目的地的边界框。
      Rectangle2D ConvolveOp.getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D LookupOp.getBounds2D​(BufferedImage src)
      返回已过滤的目标图像的边界框。
      Rectangle2D RescaleOp.getBounds2D​(BufferedImage src)
      返回重新缩放的目标图像的边框。

    • Uses of BufferedImage in javafx.embed.swing

      Methods in javafx.embed.swing that return BufferedImage
      Modifier and Type 方法 描述
      static BufferedImage SwingFXUtils.fromFXImage​(Image img, BufferedImage bimg)
      快照指定的JavaFX Image对象，并将其像素的副本存储到一个BufferedImage对象中，如果需要，创建一个新对象。
      Methods in javafx.embed.swing with parameters of type BufferedImage
      Modifier and Type 方法 描述
      static BufferedImage SwingFXUtils.fromFXImage​(Image img, BufferedImage bimg)
      快照指定的JavaFX Image对象，并将其像素的副本存储到一个BufferedImage对象中，如果需要创建一个新对象。
      static WritableImage SwingFXUtils.toFXImage​(BufferedImage bimg, WritableImage wimg)
      快照指定的BufferedImage并将其像素的副本存储到JavaFX Image对象中，如果需要，则创建一个新对象。

    • Uses of BufferedImage in javax.imageio

      Fields in javax.imageio declared as BufferedImage
      Modifier and Type Field 描述
      protected BufferedImage ImageReadParam.destination
      当前目的地 BufferedImage ，如果没有设置， null 。
      Fields in javax.imageio with type parameters of type BufferedImage
      Modifier and Type Field 描述
      protected List<? extends BufferedImage> IIOImage.thumbnails
      A List的 BufferedImage缩略图，或 null 。
      Methods in javax.imageio that return BufferedImage
      Modifier and Type 方法 描述
      BufferedImage ImageTypeSpecifier.createBufferedImage​(int width, int height)
      根据此对象中体现的规范，创建一个给定宽度和高度的 BufferedImage 。
      protected static BufferedImage ImageReader.getDestination​(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
      返回应写入解码像素数据的 BufferedImage 。
      BufferedImage ImageReadParam.getDestination​()
      返回 BufferedImage目前由设置 setDestination方法，或者 null ，如果没有设置。
      BufferedImage IIOImage.getThumbnail​(int index)
      返回与主图像相关联的缩略图。
      static BufferedImage ImageIO.read​(File input)
      作为对所提供的 File进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
      static BufferedImage ImageIO.read​(InputStream input)
      作为对所提供的 InputStream进行解码的结果，自动从当前注册的 ImageReader自动选择的结果返回 BufferedImage 。
      static BufferedImage ImageIO.read​(URL input)
      作为对所提供的 URL进行解码的结果，返回 BufferedImage ，其中自动从当前注册的 ImageReader选择。
      static BufferedImage ImageIO.read​(ImageInputStream stream)
      作为对所提供的 ImageInputStream进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
      BufferedImage ImageReader.read​(int imageIndex)
      读取 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用默认值 ImageReadParam 。
      abstract BufferedImage ImageReader.read​(int imageIndex, ImageReadParam param)
      阅读由 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用附带的 ImageReadParam 。
      BufferedImage ImageReader.readThumbnail​(int imageIndex, int thumbnailIndex)
      返回 thumbnailIndex索引的缩略图预览图像，与 ImageIndex作为 BufferedImage索引的图像相关联。
      BufferedImage ImageReader.readTile​(int imageIndex, int tileX, int tileY)
      读取 tileX和 tileY参数指示的 tileX ，将其作为 BufferedImage返回。
      Methods in javax.imageio that return types with arguments of type BufferedImage
      Modifier and Type 方法 描述
      List<? extends BufferedImage> IIOImage.getThumbnails​()
      返回当前 List缩略图 BufferedImage S，或 null ，如果没有设置。
      Methods in javax.imageio with parameters of type BufferedImage
      Modifier and Type 方法 描述
      protected static void ImageReader.computeRegions​(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion)
      计算感兴趣的源区域和感兴趣的目的地区域，考虑源图像的宽度和高度，可选的目标图像和可选的 ImageReadParam 。
      protected void ImageReader.processImageUpdate​(BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      通过调用其 imageUpdate方法将一组样本的更新广播到所有注册的 IIOReadUpdateListener 。
      protected void ImageReader.processPassComplete​(BufferedImage theImage)
      通过拨打他们的 passComplete方法，向所有注册的广播广播结束通过所有注册的 IIOReadUpdateListener 。
      protected void ImageReader.processPassStarted​(BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      广播逐步传递到所有已注册的开头 IIOReadUpdateListener通过调用它们的S passStarted方法。
      protected void ImageReader.processThumbnailPassComplete​(BufferedImage theThumbnail)
      通过调用其 thumbnailPassComplete方法将所有注册的 IIOReadUpdateListener的缩略图 IIOReadUpdateListener通过 thumbnailPassComplete 。
      protected void ImageReader.processThumbnailPassStarted​(BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      通过调用其 thumbnailPassStarted方法，将所有注册的 IIOReadUpdateListener s的缩略图遍历的开始广播。
      protected void ImageReader.processThumbnailUpdate​(BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      通过调用其 thumbnailUpdate方法将缩略图中的一组样本的更新广播到所有注册的 IIOReadUpdateListener 。
      void ImageReadParam.setDestination​(BufferedImage destination)
      提供 BufferedImage作为解码像素数据的目的地。
      Method parameters in javax.imageio with type arguments of type BufferedImage
      Modifier and Type 方法 描述
      void ImageWriter.prepareInsertEmpty​(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将未定义像素值的新图像插入到现有图像流中。
      void ImageWriter.prepareWriteEmpty​(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
      void IIOImage.setThumbnails​(List<? extends BufferedImage> thumbnails)
      将缩略图到一个新的列表 List的 BufferedImage S，或 null 。
      Constructor parameters in javax.imageio with type arguments of type BufferedImage
      Constructor 描述
      IIOImage​(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 Raster ，和缩略图和元数据与之相关联。
      IIOImage​(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 RenderedImage ，和缩略图和元数据与之相关联。

    • Uses of BufferedImage in javax.imageio.event

      Methods in javax.imageio.event with parameters of type BufferedImage
      Modifier and Type 方法 描述
      void IIOReadUpdateListener.imageUpdate​(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      报告图像的给定区域已更新。
      void IIOReadUpdateListener.passComplete​(ImageReader source, BufferedImage theImage)
      报告当前的读取操作已经完成了逐行通过。
      void IIOReadUpdateListener.passStarted​(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      报告当前读取操作即将开始逐行传递。
      void IIOReadUpdateListener.thumbnailPassComplete​(ImageReader source, BufferedImage theThumbnail)
      报告当前缩略图读取操作已经完成了逐行通过。
      void IIOReadUpdateListener.thumbnailPassStarted​(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands)
      报告当前的缩略图读取操作即将开始逐行传递。
      void IIOReadUpdateListener.thumbnailUpdate​(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands)
      报告缩略图的给定区域已更新。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.BufferedImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.BufferedImageFilter

No usage of java.awt.image.BufferedImageFilter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.BufferStrategy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.BufferStrategy

  • Packages that use BufferStrategy
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of BufferStrategy in java.awt

      Subclasses of BufferStrategy in java.awt
      Modifier and Type Class 描述
      protected class  Component.BltBufferStrategy
      内部类别将屏幕外表面喷涂到组件上。
      protected class  Component.FlipBufferStrategy
      内部类用于在组件上翻转缓冲区。
      Methods in java.awt that return BufferStrategy
      Modifier and Type 方法 描述
      BufferStrategy Canvas.getBufferStrategy​()
      返回此组件使用的 BufferStrategy 。
      BufferStrategy Window.getBufferStrategy​()
      返回此组件使用的 BufferStrategy 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ByteLookupTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ByteLookupTable

No usage of java.awt.image.ByteLookupTable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ColorConvertOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ColorConvertOp

No usage of java.awt.image.ColorConvertOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ColorModel

  • Packages that use ColorModel
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of ColorModel in java.awt

      Methods in java.awt that return ColorModel
      Modifier and Type 方法 描述
      ColorModel Component.getColorModel​()
      获取用于在输出设备上显示组件的 ColorModel实例。
      abstract ColorModel GraphicsConfiguration.getColorModel​()
      返回ColorModel与此GraphicsConfiguration相关联。
      abstract ColorModel GraphicsConfiguration.getColorModel​(int transparency)
      返回与支持指定透明度的 ColorModel关联的 GraphicsConfiguration 。
      ColorModel PaintContext.getColorModel​()
      返回 ColorModel的输出。
      abstract ColorModel Toolkit.getColorModel​()
      确定该工具包屏幕的颜色模型。
      Methods in java.awt with parameters of type ColorModel
      Modifier and Type 方法 描述
      CompositeContext AlphaComposite.createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建合成操作的上下文。
      PaintContext Color.createContext​(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成纯色字段模式的PaintContext 。
      CompositeContext Composite.createContext​(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
      创建用于执行合成操作的上下文包含状态。
      PaintContext GradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext LinearGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成线性颜色渐变模式的PaintContext 。
      PaintContext Paint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成颜色模式的PaintContext 。
      PaintContext RadialGradientPaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints)
      创建并返回一个用于生成圆形径向颜色渐变图案的PaintContext 。
      PaintContext TexturePaint.createContext​(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
      创建并返回一个用于生成平铺图像模式的PaintContext 。

    • Uses of ColorModel in java.awt.image

      Subclasses of ColorModel in java.awt.image
      Modifier and Type Class 描述
      class  ComponentColorModel
      一个 ColorModel类，用于将颜色和alpha信息表示为单独样本的像素值，并将每个样本存储在单独的数据元素中。
      class  DirectColorModel
      DirectColorModel类是一个 ColorModel类，用于将RGB颜色和alpha信息表示为单独样本的像素值，并将单个像素的所有样本包装为单个int，short或byte数量。
      class  IndexColorModel
      IndexColorModel类是一个 ColorModel类，适用于由单个样本组成的像素值，该样本是默认sRGB色彩空间中固定色彩映射的索引。
      class  PackedColorModel
      PackedColorModel类是一个抽象的ColorModel类，它与像素值一起使用，它们将颜色和alpha信息表示为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。
      Fields in java.awt.image declared as ColorModel
      Modifier and Type Field 描述
      protected ColorModel RGBImageFilter.newmodel
      ColorModel用于替换 origmodel当用户拨打 substituteColorModel 。
      protected ColorModel RGBImageFilter.origmodel
      ColorModel由 newmodel替换，当用户拨打 substituteColorModel 。
      Methods in java.awt.image that return ColorModel
      Modifier and Type 方法 描述
      ColorModel ColorModel.coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设目前 ColorModel正确描述了数据。
      ColorModel ComponentColorModel.coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设目前 ColorModel正确描述了数据。
      ColorModel DirectColorModel.coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设目前 ColorModel正确描述了数据。
      ColorModel BufferedImage.getColorModel​()
      返回 ColorModel 。
      ColorModel PixelGrabber.getColorModel​()
      获取存储在数组中的像素的ColorModel。
      ColorModel RenderedImage.getColorModel​()
      返回与此图像相关联的ColorModel。
      static ColorModel ColorModel.getRGBdefault​()
      返回一个 DirectColorModel ，它描述了AWT图像接口中许多方法中使用的整数RGB值的默认格式，以方便程序员。
      Methods in java.awt.image with parameters of type ColorModel
      Modifier and Type 方法 描述
      BufferedImage AffineTransformOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage BufferedImageOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage ColorConvertOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      给出这个来源，创建具有正确大小和频带数的归零目标图像。
      BufferedImage ConvolveOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage LookupOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      BufferedImage RescaleOp.createCompatibleDestImage​(BufferedImage src, ColorModel destCM)
      创建具有正确大小和频带数的归零目标图像。
      void MemoryImageSource.newPixels​(byte[] newpix, ColorModel newmodel, int offset, int scansize)
      更改新的字节数组来保存此图像的像素。
      void MemoryImageSource.newPixels​(int[] newpix, ColorModel newmodel, int offset, int scansize)
      更改一个新的int数组来保存此图像的像素。
      void BufferedImageFilter.setColorModel​(ColorModel model)
      对 ImageConsumer接口的 setColorModel方法中提供的信息进行过滤。
      void ImageConsumer.setColorModel​(ColorModel model)
      设置使用setPixels方法调用报告的大多数像素使用的ColorModel对象。
      void ImageFilter.setColorModel​(ColorModel model)
      过滤ImageConsumer界面的setColorModel方法中提供的信息。
      void PixelGrabber.setColorModel​(ColorModel model)
      setColorModel方法是ImageConsumer API的一部分，该类必须实现此方法来检索像素。
      void RGBImageFilter.setColorModel​(ColorModel model)
      如果ColorModel是IndexColorModel，并且子类将canFilterIndexColorModel标志设置为true，则在此处替换颜色模型的过滤版本，并将原始ColorModel对象出现在setPixels方法中。
      void AreaAveragingScaleFilter.setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      将传送的字节像素的组件合并到累加数组中，并发送完整像素行的任何平均数据。
      void AreaAveragingScaleFilter.setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      将传递的int像素的组件合并到累积数组中，并发送完整像素行的任何平均数据。
      void BufferedImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      对 ImageConsumer接口的 setPixels方法中提供的信息进行过滤，该接口采用字节数组。
      void BufferedImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      过滤 ImageConsumer接口的 setPixels方法中提供的信息，该接口采用整数数组。
      void CropImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      确定所传送的字节像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。
      void CropImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      确定所传递的int像素是否与要提取的区域相交，并仅通过出现在输出区域中的像素子集。
      void ImageConsumer.setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      通过一次或多次调用该方法来提供图像的像素。
      void ImageConsumer.setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      使用对setPixels方法的一个或多个调用来传送图像的像素。
      void ImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      过滤ImageConsumer接口的setPixels方法中提供的信息，该接口采用字节数组。
      void ImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      对ImageConsumer接口的setPixels方法中提供的信息进行过滤，该接口采用整数数组。
      void PixelGrabber.setPixels​(int srcX, int srcY, int srcW, int srcH, ColorModel model, byte[] pixels, int srcOff, int srcScan)
      setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。
      void PixelGrabber.setPixels​(int srcX, int srcY, int srcW, int srcH, ColorModel model, int[] pixels, int srcOff, int srcScan)
      setPixels方法是ImageConsumer API的一部分，该类必须实现以检索像素。
      void ReplicateScaleFilter.setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      选择目标缩放图像所需的传送字节像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。
      void ReplicateScaleFilter.setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      选择目标缩放图像需要交付的int像素的行和列，并仅传递所需的那些行和列，并根据需要进行复制。
      void RGBImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize)
      如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递。
      void RGBImageFilter.setPixels​(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize)
      如果ColorModel对象与已经被转换的对象相同，那么只需将像素通过转换的ColorModel传递，否则将整数像素的缓冲区转换为默认的RGB ColorModel，并将转换后的缓冲区传递给filterRGBPixels方法进行转换一个
      void RGBImageFilter.substituteColorModel​(ColorModel oldcm, ColorModel newcm)
      注册两个ColorModel对象进行替换。
      Constructors in java.awt.image with parameters of type ColorModel
      Constructor 描述
      BufferedImage​(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
      构造一个新的 BufferedImage与指定的 ColorModel和 Raster 。
      MemoryImageSource​(int w, int h, ColorModel cm, byte[] pix, int off, int scan)
      构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，它使用一个字节数组来生成一个Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, int[] pix, int off, int scan)
      构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。
      MemoryImageSource​(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
      构造一个ImageProducer对象，该对象使用整数数组来生成Image对象的数据。

    • Uses of ColorModel in javax.imageio

      Fields in javax.imageio declared as ColorModel
      Modifier and Type Field 描述
      protected ColorModel ImageTypeSpecifier.colorModel
      ColorModel作为原型使用。
      Methods in javax.imageio that return ColorModel
      Modifier and Type 方法 描述
      ColorModel ImageTypeSpecifier.getColorModel​()
      返回此对象指定的 ColorModel 。
      Constructors in javax.imageio with parameters of type ColorModel
      Constructor 描述
      ImageTypeSpecifier​(ColorModel colorModel, SampleModel sampleModel)
      Constructs an ImageTypeSpecifier directly from a ColorModel and a SampleModel.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ComponentColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ComponentColorModel

No usage of java.awt.image.ComponentColorModel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ComponentSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ComponentSampleModel

  • Packages that use ComponentSampleModel
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of ComponentSampleModel in java.awt.image

      Subclasses of ComponentSampleModel in java.awt.image
      Modifier and Type Class 描述
      class  BandedSampleModel
      该类表示以频带交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
      class  PixelInterleavedSampleModel
      该类表示以像素交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ConvolveOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ConvolveOp

No usage of java.awt.image.ConvolveOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.CropImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.CropImageFilter

No usage of java.awt.image.CropImageFilter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DataBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DataBuffer

  • Packages that use DataBuffer
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of DataBuffer in java.awt.image

      Subclasses of DataBuffer in java.awt.image
      Modifier and Type Class 描述
      class  DataBufferByte
      该类扩展了 DataBuffer并将数据内部存储为字节。
      class  DataBufferDouble
      该类扩展了 DataBuffer并在 double内部存储数据。
      class  DataBufferFloat
      该类扩展了 DataBuffer并以 float形式存储数据。
      class  DataBufferInt
      该类扩展了 DataBuffer并将数据内部存储为整数。
      class  DataBufferShort
      此类扩展为 DataBuffer并将数据内部存储为短裤。
      class  DataBufferUShort
      该类扩展了 DataBuffer并将数据内部存储为 DataBuffer 。
      Fields in java.awt.image declared as DataBuffer
      Modifier and Type Field 描述
      protected DataBuffer Raster.dataBuffer
      DataBuffer存储图像数据。
      Methods in java.awt.image that return DataBuffer
      Modifier and Type 方法 描述
      DataBuffer BandedSampleModel.createDataBuffer​()
      创建对应于此BandedSampleModel的DataBuffer，DataBuffer的数据类型，数量和大小将与此BandedSampleModel一致。
      DataBuffer ComponentSampleModel.createDataBuffer​()
      创建一个 DataBuffer对应于这个 ComponentSampleModel 。
      DataBuffer MultiPixelPackedSampleModel.createDataBuffer​()
      创建一个 DataBuffer对应于这个 MultiPixelPackedSampleModel 。
      abstract DataBuffer SampleModel.createDataBuffer​()
      创建与此SampleModel对应的DataBuffer。
      DataBuffer SinglePixelPackedSampleModel.createDataBuffer​()
      创建与此SinglePixelPackedSampleModel对应的DataBuffer。
      DataBuffer Raster.getDataBuffer​()
      返回与此栅格相关联的DataBuffer。
      Methods in java.awt.image with parameters of type DataBuffer
      Modifier and Type 方法 描述
      static WritableRaster Raster.createBandedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location)
      根据指定的DataBuffer，width，height，scanline stride，bank index和band offsets创建一个基于BandedSampleModel的光栅。
      static WritableRaster Raster.createInterleavedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长，像素步幅和带偏移的PixelInterleavedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长和带屏蔽的SinglePixelPackedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location)
      基于具有指定DataBuffer，宽度，高度和每像素位数的MultiPixelPackedSampleModel创建光栅。
      static Raster Raster.createRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建光栅。
      static WritableRaster Raster.createWritableRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建WritableRaster。
      Object BandedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      Object ComponentSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回类型为 TransferType的基本数组中单个像素的数据。
      Object MultiPixelPackedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      Object SampleModel.getDataElements​(int x, int y, int w, int h, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中指定的像素矩形的像素数据。
      abstract Object SampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      Object SinglePixelPackedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)
      返回TransferType类型的原始数组中单个像素的数据。
      int[] BandedSampleModel.getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的所有样本。
      int[] ComponentSampleModel.getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的所有样本，每个数组元素一个样本。
      int[] MultiPixelPackedSampleModel.getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回 int数组的第一个元素中指定的单频带像素。
      double[] SampleModel.getPixel​(int x, int y, double[] dArray, DataBuffer data)
      返回double数组中指定像素的样本。
      float[] SampleModel.getPixel​(int x, int y, float[] fArray, DataBuffer data)
      返回float数组中指定像素的样本。
      int[] SampleModel.getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的样本，每个数组元素一个样本。
      int[] SinglePixelPackedSampleModel.getPixel​(int x, int y, int[] iArray, DataBuffer data)
      返回int数组中指定像素的所有样本。
      int[] BandedSampleModel.getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的所有样本，每个数据数组元素一个样本。
      int[] ComponentSampleModel.getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。
      double[] SampleModel.getPixels​(int x, int y, int w, int h, double[] dArray, DataBuffer data)
      返回双阵列中像素矩形的所有样本，每个数组元素一个样本。
      float[] SampleModel.getPixels​(int x, int y, int w, int h, float[] fArray, DataBuffer data)
      返回float数组中像素矩形的所有样本，每个数组元素一个样本。
      int[] SampleModel.getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中像素矩形的所有样本，每个数组元素一个样本。
      int[] SinglePixelPackedSampleModel.getPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的所有样本，每个数组元素一个样本。
      int BandedSampleModel.getSample​(int x, int y, int b, DataBuffer data)
      返回为位于（x，y）处的像素的指定带中的样本int。
      int ComponentSampleModel.getSample​(int x, int y, int b, DataBuffer data)
      返回为位于（x，y）处的像素的指定带中的样本int。
      int MultiPixelPackedSampleModel.getSample​(int x, int y, int b, DataBuffer data)
      对于位于（x，y）的像素，在指定的带中返回 int样本。
      abstract int SampleModel.getSample​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本返回为int。
      int SinglePixelPackedSampleModel.getSample​(int x, int y, int b, DataBuffer data)
      返回为位于（x，y）处的像素的指定带中的样本int。
      double BandedSampleModel.getSampleDouble​(int x, int y, int b, DataBuffer data)
      将位于（x，y）的像素的指定带中的样本返回为双倍。
      double ComponentSampleModel.getSampleDouble​(int x, int y, int b, DataBuffer data)
      将位于（x，y）的像素的指定带中的样本返回为双倍。
      double SampleModel.getSampleDouble​(int x, int y, int b, DataBuffer data)
      将位于（x，y）的像素的指定带中的样本返回为双倍。
      float BandedSampleModel.getSampleFloat​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本作为浮点返回。
      float ComponentSampleModel.getSampleFloat​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本作为浮点返回。
      float SampleModel.getSampleFloat​(int x, int y, int b, DataBuffer data)
      将位于（x，y）处的像素的指定带中的样本作为浮点返回。
      int[] BandedSampleModel.getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。
      int[] ComponentSampleModel.getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带中的样本，每个数据数组元素一个样本。
      double[] SampleModel.getSamples​(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data)
      返回双阵列中指定的像素矩形的指定波段的样本，每个数组元素一个样本。
      float[] SampleModel.getSamples​(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data)
      返回浮点数组中指定的像素矩形的指定波段的样本，每个数组元素一个样本。
      int[] SampleModel.getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。
      int[] SinglePixelPackedSampleModel.getSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      返回int数组中指定的像素矩形的指定带的样本，每个数组元素一个样本。
      void BandedSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。
      void ComponentSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)
      设置在指定的一个单个像素的数据 DataBuffer从类型的基本数组 TransferType 。
      void MultiPixelPackedSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定的 DataBuffer单个像素的数据。
      void SampleModel.setDataElements​(int x, int y, int w, int h, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中像素矩形的数据。
      abstract void SampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。
      void SinglePixelPackedSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)
      从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。
      void BandedSampleModel.setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用int数组的样本数据来设置DataBuffer中的一个像素。
      void ComponentSampleModel.setPixel​(int x, int y, int[] iArray, DataBuffer data)
      在 DataBuffer使用int数组的样本设置一个像素进行输入。
      void MultiPixelPackedSampleModel.setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用 int阵列设置 DataBuffer的像素进行输入。
      void SampleModel.setPixel​(int x, int y, double[] dArray, DataBuffer data)
      在DataBuffer中使用双重样本数组来设置像素。
      void SampleModel.setPixel​(int x, int y, float[] fArray, DataBuffer data)
      使用用于输入的样本的浮点数组来设置DataBuffer中的像素。
      void SampleModel.setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用int数组的样本数据来设置DataBuffer中的一个像素。
      void SinglePixelPackedSampleModel.setPixel​(int x, int y, int[] iArray, DataBuffer data)
      使用int数组的样本数据来设置DataBuffer中的一个像素。
      void BandedSampleModel.setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void ComponentSampleModel.setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void SampleModel.setPixels​(int x, int y, int w, int h, double[] dArray, DataBuffer data)
      从包含每个数组元素一个样本的双数组中设置一个像素矩形的所有样本。
      void SampleModel.setPixels​(int x, int y, int w, int h, float[] fArray, DataBuffer data)
      从包含每个数组元素一个样本的浮点数组设置一个像素矩形的所有样本。
      void SampleModel.setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void SinglePixelPackedSampleModel.setPixels​(int x, int y, int w, int h, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中设置一个像素矩形的所有样本。
      void BandedSampleModel.setSample​(int x, int y, int b, double s, DataBuffer data)
      对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。
      void BandedSampleModel.setSample​(int x, int y, int b, float s, DataBuffer data)
      使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。
      void BandedSampleModel.setSample​(int x, int y, int b, int s, DataBuffer data)
      使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。
      void ComponentSampleModel.setSample​(int x, int y, int b, double s, DataBuffer data)
      在 DataBuffer使用双倍的输入设置位于（x，y）处的像素的指定频带中的样本。
      void ComponentSampleModel.setSample​(int x, int y, int b, float s, DataBuffer data)
      为 DataBuffer位于（x，y）处的像素的指定波段设置采样，使用浮点输入。
      void ComponentSampleModel.setSample​(int x, int y, int b, int s, DataBuffer data)
      在 DataBuffer使用int作为输入，为位于（x，y）处的像素的指定频带设置一个样本。
      void MultiPixelPackedSampleModel.setSample​(int x, int y, int b, int s, DataBuffer data)
      在 DataBuffer使用 int设置位于（x，y）处的像素的指定频带中的样本。
      void SampleModel.setSample​(int x, int y, int b, double s, DataBuffer data)
      对于位于DataBuffer中（x，y）处的像素的指定带中的样本，使用双倍的输入。
      void SampleModel.setSample​(int x, int y, int b, float s, DataBuffer data)
      使用浮点数为DataBuffer设置位于（x，y）处的像素的指定波段的样本。
      abstract void SampleModel.setSample​(int x, int y, int b, int s, DataBuffer data)
      使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。
      void SinglePixelPackedSampleModel.setSample​(int x, int y, int b, int s, DataBuffer data)
      使用int作为输入，为DataBuffer中位于（x，y）处的像素的指定波段设置一个样本。
      void BandedSampleModel.setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。
      void ComponentSampleModel.setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数据数组元素一个样本的int数组中为指定的像素矩形设置样本。
      void SampleModel.setSamples​(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data)
      从包含每个数组元素一个样本的双阵列的像素的指定矩形中设置样本。
      void SampleModel.setSamples​(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data)
      从包含每个数组元素一个样本的浮点数组中为指定的像素矩形设置指定带中的样本。
      void SampleModel.setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。
      void SinglePixelPackedSampleModel.setSamples​(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
      从包含每个数组元素一个样本的int数组中为指定的像素矩形设置指定带中的样本。
      Constructors in java.awt.image with parameters of type DataBuffer
      Constructor 描述
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造光栅。
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
      使用给定的SampleModel，DataBuffer和父构造栅格。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造WritableRaster。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
      使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DataBufferByte (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DataBufferByte

No usage of java.awt.image.DataBufferByte
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DataBufferDouble (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DataBufferDouble

No usage of java.awt.image.DataBufferDouble
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DataBufferFloat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DataBufferFloat

No usage of java.awt.image.DataBufferFloat
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DataBufferInt (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DataBufferInt

No usage of java.awt.image.DataBufferInt
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DataBufferShort (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DataBufferShort

No usage of java.awt.image.DataBufferShort
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DataBufferUShort (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DataBufferUShort

No usage of java.awt.image.DataBufferUShort
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.DirectColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.DirectColorModel

No usage of java.awt.image.DirectColorModel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.FilteredImageSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.FilteredImageSource

No usage of java.awt.image.FilteredImageSource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ImageFilter

  • Packages that use ImageFilter
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of ImageFilter in java.awt.image

      Subclasses of ImageFilter in java.awt.image
      Modifier and Type Class 描述
      class  AreaAveragingScaleFilter
      一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。
      class  BufferedImageFilter
      所述BufferedImageFilter类的子类的ImageFilter是提供一种使用单一源/单一目标图像操作符（的简单方法BufferedImageOp ）以过滤BufferedImage在图像生产者/消费者/观察员范例。
      class  CropImageFilter
      用于裁剪图像的ImageFilter类。
      class  ReplicateScaleFilter
      一个ImageFilter类，用于使用最简单的算法缩放图像。
      class  RGBImageFilter
      该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。
      Methods in java.awt.image that return ImageFilter
      Modifier and Type 方法 描述
      ImageFilter ImageFilter.getFilterInstance​(ImageConsumer ic)
      返回一个ImageFilter对象的唯一实例，该对象实际上将对指定的ImageConsumer进行过滤。
      Constructors in java.awt.image with parameters of type ImageFilter
      Constructor 描述
      FilteredImageSource​(ImageProducer orig, ImageFilter imgf)
      从现有的ImageProducer和过滤器对象构造一个ImageProducer对象。

    • Uses of ImageFilter in javax.swing

      Subclasses of ImageFilter in javax.swing
      Modifier and Type Class 描述
      class  GrayFilter
      通过将图像转换成灰度图像来“禁用”图像并增亮图像中的像素的图像滤镜。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ImagingOpException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ImagingOpException

No usage of java.awt.image.ImagingOpException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.IndexColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.IndexColorModel

  • Packages that use IndexColorModel
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of IndexColorModel in java.awt.image

      Methods in java.awt.image that return IndexColorModel
      Modifier and Type 方法 描述
      IndexColorModel RGBImageFilter.filterIndexColorModel​(IndexColorModel icm)
      通过RGBImageFilter子类必须提供的filterRGB函数运行其颜色表中的每个条目来过滤IndexColorModel对象。
      Methods in java.awt.image with parameters of type IndexColorModel
      Modifier and Type 方法 描述
      IndexColorModel RGBImageFilter.filterIndexColorModel​(IndexColorModel icm)
      通过RGBImageFilter子类必须提供的filterRGB函数运行其颜色表中的每个条目来过滤IndexColorModel对象。
      Constructors in java.awt.image with parameters of type IndexColorModel
      Constructor 描述
      BufferedImage​(int width, int height, int imageType, IndexColorModel cm)
      构造一个预定义的图像类型的一个 BufferedImage ：TYPE_BYTE_BINARY或TYPE_BYTE_INDEXED。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.Kernel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.Kernel

  • Packages that use Kernel
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of Kernel in java.awt.image

      Methods in java.awt.image that return Kernel
      Modifier and Type 方法 描述
      Kernel ConvolveOp.getKernel​()
      返回内核。
      Constructors in java.awt.image with parameters of type Kernel
      Constructor 描述
      ConvolveOp​(Kernel kernel)
      构造一个给定内核的ConvolveOp。
      ConvolveOp​(Kernel kernel, int edgeCondition, RenderingHints hints)
      构造一个给定内核，边缘条件和RenderingHints对象（可能为null）的ConvolveOp。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.LookupOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.LookupOp

No usage of java.awt.image.LookupOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.LookupTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.LookupTable

  • Packages that use LookupTable
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of LookupTable in java.awt.image

      Subclasses of LookupTable in java.awt.image
      Modifier and Type Class 描述
      class  ByteLookupTable
      这个类定义了一个查找表对象。
      class  ShortLookupTable
      这个类定义了一个查找表对象。
      Methods in java.awt.image that return LookupTable
      Modifier and Type 方法 描述
      LookupTable LookupOp.getTable​()
      返回 LookupTable 。
      Constructors in java.awt.image with parameters of type LookupTable
      Constructor 描述
      LookupOp​(LookupTable lookup, RenderingHints hints)
      给出一个 LookupOp对象，给出了查找表和一个 RenderingHints对象，可能是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.MemoryImageSource (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.MemoryImageSource

No usage of java.awt.image.MemoryImageSource
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.MultiPixelPackedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.MultiPixelPackedSampleModel

No usage of java.awt.image.MultiPixelPackedSampleModel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.PackedColorModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.PackedColorModel

  • Packages that use PackedColorModel
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of PackedColorModel in java.awt.image

      Subclasses of PackedColorModel in java.awt.image
      Modifier and Type Class 描述
      class  DirectColorModel
      DirectColorModel课程是一个 ColorModel类，适用于将RGB颜色和Alpha信息表示为单独样本的像素值，并将单个像素的所有样本包装为单个int，short或byte数量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.PixelGrabber (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.PixelGrabber

No usage of java.awt.image.PixelGrabber
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.PixelInterleavedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.PixelInterleavedSampleModel

No usage of java.awt.image.PixelInterleavedSampleModel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.Raster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.Raster

  • Packages that use Raster
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of Raster in java.awt

      Methods in java.awt that return Raster
      Modifier and Type 方法 描述
      Raster PaintContext.getRaster​(int x, int y, int w, int h)
      返回包含为图形操作生成的颜色的 Raster 。
      Methods in java.awt with parameters of type Raster
      Modifier and Type 方法 描述
      void CompositeContext.compose​(Raster src, Raster dstIn, WritableRaster dstOut)
      组合两个源Raster对象，并将结果放在目标WritableRaster中 。

    • Uses of Raster in java.awt.image

      Subclasses of Raster in java.awt.image
      Modifier and Type Class 描述
      class  WritableRaster
      该类扩展了Raster，以提供像素写入功能。
      Fields in java.awt.image declared as Raster
      Modifier and Type Field 描述
      protected Raster Raster.parent
      此栅格的父项，或null。
      Methods in java.awt.image that return Raster
      Modifier and Type 方法 描述
      Raster Raster.createChild​(int parentX, int parentY, int width, int height, int childMinX, int childMinY, int[] bandList)
      返回一个新的Raster，它共享此Raster DataBuffer的全部或部分。
      static Raster Raster.createRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建光栅。
      Raster Raster.createTranslatedChild​(int childMinX, int childMinY)
      创建一个具有相同大小的光栅，SampleModel和DataBuffer，但是具有不同的位置。
      Raster BufferedImage.getData​()
      将图像返回为一个大图块。
      Raster BufferedImage.getData​(Rectangle rect)
      计算并返回 BufferedImage的任意区域。
      Raster RenderedImage.getData​()
      将图像作为一个大图块返回（对于基于图块的图像，这将需要获取整个图像并复制图像数据）。
      Raster RenderedImage.getData​(Rectangle rect)
      计算并返回RenderedImage的任意区域。
      Raster Raster.getParent​()
      返回此栅格的父栅格（如果有）或null。
      Raster BufferedImage.getTile​(int tileX, int tileY)
      返回瓦（ tileX ， tileY ）。
      Raster RenderedImage.getTile​(int tileX, int tileY)
      返回tile（tileX，tileY）。
      Methods in java.awt.image with parameters of type Raster
      Modifier and Type 方法 描述
      BufferedImage IndexColorModel.convertToIntDiscrete​(Raster raster, boolean forceARGB)
      返回一个新 BufferedImage TYPE_INT_ARGB或TYPE_INT_RGB的具有 Raster通过展开源的索引来计算的与像素数据 Raster使用此的颜色/ alpha分量数组 ColorModel 。
      WritableRaster AffineTransformOp.createCompatibleDestRaster​(Raster src)
      创建带有正确大小和频带数的零目的地 Raster 。
      WritableRaster BandCombineOp.createCompatibleDestRaster​(Raster src)
      创建带有正确大小和频带数的归零目的地 Raster 。
      WritableRaster ColorConvertOp.createCompatibleDestRaster​(Raster src)
      给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
      WritableRaster ConvolveOp.createCompatibleDestRaster​(Raster src)
      给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
      WritableRaster LookupOp.createCompatibleDestRaster​(Raster src)
      创建一个零目的地 Raster具有正确的大小和数量的频带，给定这个来源。
      WritableRaster RasterOp.createCompatibleDestRaster​(Raster src)
      创建具有正确大小和频带数的归零目标光栅。
      WritableRaster RescaleOp.createCompatibleDestRaster​(Raster src)
      创建一个零目的地 Raster具有正确的大小和数量的频带，给定这个来源。
      WritableRaster AffineTransformOp.filter​(Raster src, WritableRaster dst)
      转换源 Raster并将结果存储在目标 Raster 。
      WritableRaster BandCombineOp.filter​(Raster src, WritableRaster dst)
      使用构造函数中指定的矩阵来转换 Raster 。
      WritableRaster ColorConvertOp.filter​(Raster src, WritableRaster dest)
      Color转换源光栅中的图像数据。
      WritableRaster ConvolveOp.filter​(Raster src, WritableRaster dst)
      对光栅进行卷积。
      WritableRaster LookupOp.filter​(Raster src, WritableRaster dst)
      对 Raster执行查找操作。
      WritableRaster RasterOp.filter​(Raster src, WritableRaster dest)
      执行从源光栅到目标光栅的单输入/单输出操作。
      WritableRaster RescaleOp.filter​(Raster src, WritableRaster dst)
      重新调整源光栅中的像素数据。
      Rectangle2D AffineTransformOp.getBounds2D​(Raster src)
      返回已转换目的地的边界框。
      Rectangle2D BandCombineOp.getBounds2D​(Raster src)
      返回已转换目的地的边界框。
      Rectangle2D ColorConvertOp.getBounds2D​(Raster src)
      给出这个源，返回目的地的边界框。
      Rectangle2D ConvolveOp.getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Rectangle2D LookupOp.getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Rectangle2D RasterOp.getBounds2D​(Raster src)
      返回已筛选的目标栅格的边框。
      Rectangle2D RescaleOp.getBounds2D​(Raster src)
      返回重新缩放的目标栅格的边框。
      boolean ColorModel.isCompatibleRaster​(Raster raster)
      返回 true如果 raster是兼容这个 ColorModel和 false如果不是。
      boolean ComponentColorModel.isCompatibleRaster​(Raster raster)
      如果raster与此ColorModel兼容，则返回true; 假如不是的话。
      boolean DirectColorModel.isCompatibleRaster​(Raster raster)
      返回 true如果 raster与 raster兼容，如果 raster符合， ColorModel false 。
      boolean IndexColorModel.isCompatibleRaster​(Raster raster)
      返回 true如果 raster与此兼容 ColorModel或者 false如果不是与此兼容 ColorModel 。
      void BufferedImage.setData​(Raster r)
      将图像的矩形区域设置为指定的 Raster r的内容，假定它与 BufferedImage位于相同的坐标空间。
      void WritableRenderedImage.setData​(Raster r)
      将图像的矩形设置为Raster r的内容，该Raster r假定为与WritableRenderedImage在同一坐标空间。
      void WritableRaster.setDataElements​(int x, int y, Raster inRaster)
      从输入光栅设置像素矩形的数据。
      void WritableRaster.setRect​(int dx, int dy, Raster srcRaster)
      将像素从Raster srcRaster复制到WritableRaster。
      void WritableRaster.setRect​(Raster srcRaster)
      将像素从Raster srcRaster复制到WritableRaster。
      Constructors in java.awt.image with parameters of type Raster
      Constructor 描述
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
      使用给定的SampleModel，DataBuffer和父构造栅格。

    • Uses of Raster in javax.imageio

      Fields in javax.imageio declared as Raster
      Modifier and Type Field 描述
      protected Raster IIOImage.raster
      参考的 Raster 。
      Methods in javax.imageio that return Raster
      Modifier and Type 方法 描述
      Raster IIOImage.getRaster​()
      如果只有 RenderedImage可用，则返回当前设置的 Raster或 null 。
      Raster ImageReader.readRaster​(int imageIndex, ImageReadParam param)
      返回一个新的 Raster对象，其中包含来自图像流的原始像素数据，而不应用任何颜色转换。
      Raster ImageReader.readTileRaster​(int imageIndex, int tileX, int tileY)
      返回一个包含来自图块的原始像素数据的新的 Raster对象，而不应用任何颜色转换。
      Methods in javax.imageio with parameters of type Raster
      Modifier and Type 方法 描述
      void ImageWriter.replacePixels​(Raster raster, ImageWriteParam param)
      用给定的 Raster的一部分替换已经存在于输出中的图像的一部分。
      void IIOImage.setRaster​(Raster raster)
      设置当前的 Raster 。
      Constructors in javax.imageio with parameters of type Raster
      Constructor 描述
      IIOImage​(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 Raster ，和缩略图和元数据与之相关联。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.RasterFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.RasterFormatException

No usage of java.awt.image.RasterFormatException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ReplicateScaleFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ReplicateScaleFilter

  • Packages that use ReplicateScaleFilter
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of ReplicateScaleFilter in java.awt.image

      Subclasses of ReplicateScaleFilter in java.awt.image
      Modifier and Type Class 描述
      class  AreaAveragingScaleFilter
      一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.RescaleOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.RescaleOp

No usage of java.awt.image.RescaleOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.RGBImageFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.RGBImageFilter

  • Packages that use RGBImageFilter
    软件包 描述
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of RGBImageFilter in javax.swing

      Subclasses of RGBImageFilter in javax.swing
      Modifier and Type Class 描述
      class  GrayFilter
      通过将图像转换成灰度图像来“禁用”图像并增亮图像中的像素的图像滤镜。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.SampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.SampleModel

  • Packages that use SampleModel
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。
    javax.imageio
    Java Image I / O API的主要包。

    • Uses of SampleModel in java.awt.image

      Subclasses of SampleModel in java.awt.image
      Modifier and Type Class 描述
      class  BandedSampleModel
      该类表示以频带交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
      class  ComponentSampleModel
      该类表示存储的图像数据，使得像素的每个样本占据DataBuffer的一个数据元素。
      class  MultiPixelPackedSampleModel
      MultiPixelPackedSampleModel类表示单带图像，可以将多个单样本像素包装到一个数据元素中。
      class  PixelInterleavedSampleModel
      该类表示以像素交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。
      class  SinglePixelPackedSampleModel
      该类表示打包的像素数据，使得构成单个像素的N个采样被存储在单个数据阵列元素中，并且每个数据数据阵列元素仅保存一个像素的采样。
      Fields in java.awt.image declared as SampleModel
      Modifier and Type Field 描述
      protected SampleModel Raster.sampleModel
      SampleModel描述了这个栅格的像素如何存储在DataBuffer中。
      Methods in java.awt.image that return SampleModel
      Modifier and Type 方法 描述
      SampleModel BandedSampleModel.createCompatibleSampleModel​(int w, int h)
      创建一个带有指定宽度和高度的新的BandedSampleModel。
      SampleModel ColorModel.createCompatibleSampleModel​(int w, int h)
      创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
      SampleModel ComponentColorModel.createCompatibleSampleModel​(int w, int h)
      创建一个具有指定宽度和高度的 SampleModel ，具有与此 ColorModel兼容的数据布局。
      SampleModel ComponentSampleModel.createCompatibleSampleModel​(int w, int h)
      创建一个新的 ComponentSampleModel具有指定的宽度和高度。
      SampleModel IndexColorModel.createCompatibleSampleModel​(int w, int h)
      创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
      SampleModel MultiPixelPackedSampleModel.createCompatibleSampleModel​(int w, int h)
      创建一个新的 MultiPixelPackedSampleModel具有指定的宽度和高度。
      SampleModel PackedColorModel.createCompatibleSampleModel​(int w, int h)
      创建 SampleModel具有指定的宽度和高度，具有与此兼容的数据布局 ColorModel 。
      SampleModel PixelInterleavedSampleModel.createCompatibleSampleModel​(int w, int h)
      创建一个具有指定宽度和高度的新PixelInterleavedSampleModel。
      abstract SampleModel SampleModel.createCompatibleSampleModel​(int w, int h)
      创建一个SampleModel，它描述了SampleModel格式的数据，但是具有不同的宽度和高度。
      SampleModel SinglePixelPackedSampleModel.createCompatibleSampleModel​(int w, int h)
      创建一个具有指定宽度和高度的新SinglePixelPackedSampleModel。
      SampleModel BandedSampleModel.createSubsetSampleModel​(int[] bands)
      创建一个带有BandedSampleModel的带子集的新BandedSampleModel。
      SampleModel ComponentSampleModel.createSubsetSampleModel​(int[] bands)
      使用此ComponentSampleModel的带子集创建新的ComponentSampleModel。
      SampleModel MultiPixelPackedSampleModel.createSubsetSampleModel​(int[] bands)
      创建一个新的 MultiPixelPackedSampleModel与这个 MultiPixelPackedSampleModel的带的一个子集。
      SampleModel PixelInterleavedSampleModel.createSubsetSampleModel​(int[] bands)
      创建一个新的PixelInterleavedSampleModel与PixelInterleavedSampleModel的带子集。
      abstract SampleModel SampleModel.createSubsetSampleModel​(int[] bands)
      使用此SampleModel的一个子带子创建一个新的SampleModel。
      SampleModel SinglePixelPackedSampleModel.createSubsetSampleModel​(int[] bands)
      这将创建一个新的SinglePixelPackedSampleModel与该SinglePixelPackedSampleModel的频带的子集。
      SampleModel BufferedImage.getSampleModel​()
      返回 SampleModel与此相关 BufferedImage 。
      SampleModel Raster.getSampleModel​()
      返回描述图像数据布局的SampleModel。
      SampleModel RenderedImage.getSampleModel​()
      返回与此图像关联的SampleModel。
      Methods in java.awt.image with parameters of type SampleModel
      Modifier and Type 方法 描述
      static Raster Raster.createRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建光栅。
      static WritableRaster Raster.createWritableRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建WritableRaster。
      static WritableRaster Raster.createWritableRaster​(SampleModel sm, Point location)
      使用指定的SampleModel创建WritableRaster。
      boolean ColorModel.isCompatibleSampleModel​(SampleModel sm)
      检查 SampleModel是否与此 ColorModel兼容。
      boolean ComponentColorModel.isCompatibleSampleModel​(SampleModel sm)
      检查指定的 SampleModel是否与此 ColorModel兼容。
      boolean IndexColorModel.isCompatibleSampleModel​(SampleModel sm)
      检查指定的 SampleModel是否与此 ColorModel兼容。
      boolean PackedColorModel.isCompatibleSampleModel​(SampleModel sm)
      检查指定的 SampleModel是否与此 ColorModel兼容。
      Constructors in java.awt.image with parameters of type SampleModel
      Constructor 描述
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造光栅。
      Raster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
      使用给定的SampleModel，DataBuffer和父构造栅格。
      Raster​(SampleModel sampleModel, Point origin)
      使用给定的SampleModel构造光栅。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
      使用给定的SampleModel和DataBuffer构造WritableRaster。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
      使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。
      WritableRaster​(SampleModel sampleModel, Point origin)
      使用给定的SampleModel构造WritableRaster。

    • Uses of SampleModel in javax.imageio

      Fields in javax.imageio declared as SampleModel
      Modifier and Type Field 描述
      protected SampleModel ImageTypeSpecifier.sampleModel
      A SampleModel用作原型。
      Methods in javax.imageio that return SampleModel
      Modifier and Type 方法 描述
      SampleModel ImageTypeSpecifier.getSampleModel​()
      根据此对象中封装的设置返回 SampleModel 。
      SampleModel ImageTypeSpecifier.getSampleModel​(int width, int height)
      根据此对象中封装的设置返回 SampleModel 。
      Constructors in javax.imageio with parameters of type SampleModel
      Constructor 描述
      ImageTypeSpecifier​(ColorModel colorModel, SampleModel sampleModel)
      构造一个 ImageTypeSpecifier直接从 ColorModel和 SampleModel 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.ShortLookupTable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.ShortLookupTable

No usage of java.awt.image.ShortLookupTable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.SinglePixelPackedSampleModel (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.SinglePixelPackedSampleModel

No usage of java.awt.image.SinglePixelPackedSampleModel
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.VolatileImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.VolatileImage

  • Packages that use VolatileImage
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。

    • Uses of VolatileImage in java.awt

      Fields in java.awt declared as VolatileImage
      Modifier and Type Field 描述
      protected VolatileImage[] Component.BltBufferStrategy.backBuffers
      后缓冲
      protected VolatileImage Component.FlipBufferStrategy.drawVBuffer
      绘图缓冲区作为易失性图像
      Methods in java.awt that return VolatileImage
      Modifier and Type 方法 描述
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height)
      返回VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height, int transparency)
      返回一个VolatileImage ，其数据布局和颜色模型与此GraphicsConfiguration兼容。
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps)
      使用指定的图像功能返回VolatileImage，其中包含与此GraphicsConfiguration兼容的数据布局和颜色模型。
      VolatileImage GraphicsConfiguration.createCompatibleVolatileImage​(int width, int height, ImageCapabilities caps, int transparency)
      返回VolatileImage一个数据布局和颜色模型与此相兼容GraphicsConfiguration ，并使用指定图像能力和透明度值。
      VolatileImage Component.createVolatileImage​(int width, int height)
      创建一个用于双缓冲的易失性的屏幕外可绘图像。
      VolatileImage Component.createVolatileImage​(int width, int height, ImageCapabilities caps)
      使用给定的功能创建一个易失的屏幕外可绘制图像。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.WritableRaster (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.WritableRaster

  • Packages that use WritableRaster
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。

    • Uses of WritableRaster in java.awt

      Methods in java.awt with parameters of type WritableRaster
      Modifier and Type 方法 描述
      void CompositeContext.compose​(Raster src, Raster dstIn, WritableRaster dstOut)
      组合两个源Raster对象，并将结果放在目标WritableRaster中 。

    • Uses of WritableRaster in java.awt.image

      Methods in java.awt.image that return WritableRaster
      Modifier and Type 方法 描述
      WritableRaster BufferedImage.copyData​(WritableRaster outRaster)
      计算 BufferedImage的任意矩形区域，并将其复制到指定的 WritableRaster 。
      WritableRaster RenderedImage.copyData​(WritableRaster raster)
      计算RenderedImage的任意矩形区域，并将其复制到调用者提供的WritableRaster中。
      static WritableRaster Raster.createBandedRaster​(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location)
      基于具有指定数据类型，宽度，高度，扫描线步长，银行索引和带偏移的BandedSampleModel创建光栅。
      static WritableRaster Raster.createBandedRaster​(int dataType, int w, int h, int bands, Point location)
      根据具有指定数据类型，宽度，高度和频带数的BandedSampleModel创建栅格。
      static WritableRaster Raster.createBandedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location)
      根据指定的DataBuffer，width，height，scanline stride，bank index和band offsets创建一个基于BandedSampleModel的光栅。
      WritableRaster AffineTransformOp.createCompatibleDestRaster​(Raster src)
      创建带有正确大小和频带数的归零目的地 Raster 。
      WritableRaster BandCombineOp.createCompatibleDestRaster​(Raster src)
      创建具有正确大小和频带数的归零目的地 Raster 。
      WritableRaster ColorConvertOp.createCompatibleDestRaster​(Raster src)
      给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
      WritableRaster ConvolveOp.createCompatibleDestRaster​(Raster src)
      给出这个来源，创建一个具有正确大小和频带数的归零目标光栅。
      WritableRaster LookupOp.createCompatibleDestRaster​(Raster src)
      创建一个零目的地 Raster具有正确的大小和数量的带，给定这个来源。
      WritableRaster RasterOp.createCompatibleDestRaster​(Raster src)
      创建具有正确大小和频带数的归零目标光栅。
      WritableRaster RescaleOp.createCompatibleDestRaster​(Raster src)
      创建一个归零目的地 Raster具有正确的大小和数量的频带，给定此源。
      WritableRaster ColorModel.createCompatibleWritableRaster​(int w, int h)
      创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。
      WritableRaster ComponentColorModel.createCompatibleWritableRaster​(int w, int h)
      创建一个具有指定宽度和高度的 WritableRaster ，具有与此 ColorModel兼容的数据布局（ SampleModel ）。
      WritableRaster DirectColorModel.createCompatibleWritableRaster​(int w, int h)
      创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。
      WritableRaster IndexColorModel.createCompatibleWritableRaster​(int w, int h)
      创建 WritableRaster具有指定的宽度和高度，其具有的数据布局（ SampleModel ）与此兼容 ColorModel 。
      WritableRaster Raster.createCompatibleWritableRaster​()
      创建与此Raster相同大小的兼容WritableRaster，具有相同的SampleModel和新的已初始化的DataBuffer。
      WritableRaster Raster.createCompatibleWritableRaster​(int w, int h)
      创建一个具有指定大小的兼容WritableRaster，一个新的SampleModel和一个新的初始化DataBuffer。
      WritableRaster Raster.createCompatibleWritableRaster​(int x, int y, int w, int h)
      创建一个兼容的WritableRaster，具有指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。
      WritableRaster Raster.createCompatibleWritableRaster​(Rectangle rect)
      创建一个兼容的WritableRaster，它具有由rect指定的位置（minX，minY）和size（width，height），一个新的SampleModel和一个新的初始化的DataBuffer。
      static WritableRaster Raster.createInterleavedRaster​(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location)
      基于具有指定数据类型，宽度，高度，扫描线步长，像素步长和带偏移的PixelInterleavedSampleModel创建光栅。
      static WritableRaster Raster.createInterleavedRaster​(int dataType, int w, int h, int bands, Point location)
      基于具有指定数据类型，宽度，高度和频带数的PixelInterleavedSampleModel创建光栅。
      static WritableRaster Raster.createInterleavedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长，像素步幅和带偏移的PixelInterleavedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(int dataType, int w, int h, int[] bandMasks, Point location)
      基于具有指定数据类型，宽度，高度和带屏蔽的SinglePixelPackedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(int dataType, int w, int h, int bands, int bitsPerBand, Point location)
      根据指定的数据类型，宽度，高度，频带数和每个频段的位数，打包SampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location)
      基于具有指定DataBuffer，宽度，高度，扫描线步长和带屏蔽的SinglePixelPackedSampleModel创建光栅。
      static WritableRaster Raster.createPackedRaster​(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location)
      基于具有指定DataBuffer，宽度，高度和每像素位数的MultiPixelPackedSampleModel创建光栅。
      WritableRaster WritableRaster.createWritableChild​(int parentX, int parentY, int w, int h, int childMinX, int childMinY, int[] bandList)
      返回一个新的WritableRaster，它分享这个WritableRaster的DataBuffer的全部或部分。
      static WritableRaster Raster.createWritableRaster​(SampleModel sm, DataBuffer db, Point location)
      使用指定的SampleModel和DataBuffer创建WritableRaster。
      static WritableRaster Raster.createWritableRaster​(SampleModel sm, Point location)
      使用指定的SampleModel创建WritableRaster。
      WritableRaster WritableRaster.createWritableTranslatedChild​(int childMinX, int childMinY)
      创建一个具有相同大小的WritableRaster，SampleModel和DataBuffer，但是具有不同的位置。
      WritableRaster AffineTransformOp.filter​(Raster src, WritableRaster dst)
      转换源 Raster并将结果存储在目标 Raster 。
      WritableRaster BandCombineOp.filter​(Raster src, WritableRaster dst)
      使用构造函数中指定的矩阵来转换 Raster 。
      WritableRaster ColorConvertOp.filter​(Raster src, WritableRaster dest)
      Color转换源光栅中的图像数据。
      WritableRaster ConvolveOp.filter​(Raster src, WritableRaster dst)
      对光栅进行卷积。
      WritableRaster LookupOp.filter​(Raster src, WritableRaster dst)
      对 Raster执行查找操作。
      WritableRaster RasterOp.filter​(Raster src, WritableRaster dest)
      执行从源光栅到目标光栅的单输入/单输出操作。
      WritableRaster RescaleOp.filter​(Raster src, WritableRaster dst)
      重新调整源光栅中的像素数据。
      WritableRaster BufferedImage.getAlphaRaster​()
      返回 WritableRaster表示用于alpha通道 BufferedImage对象与 ColorModel支持单独空间alpha通道的对象，例如 ComponentColorModel和 DirectColorModel 。
      WritableRaster ColorModel.getAlphaRaster​(WritableRaster raster)
      返回 Raster表示图像的alpha通道，从输入中提取 Raster ，提供此的像素值 ColorModel表示颜色和alpha信息为独立的空间频带（例如
      WritableRaster ComponentColorModel.getAlphaRaster​(WritableRaster raster)
      返回 Raster表示图像的alpha通道，从输入中提取 Raster 。
      WritableRaster PackedColorModel.getAlphaRaster​(WritableRaster raster)
      返回WritableRaster表示图像的alpha通道，从输入中提取WritableRaster 。
      WritableRaster BufferedImage.getRaster​()
      返回WritableRaster 。
      WritableRaster WritableRaster.getWritableParent​()
      返回此WritableRaster的父WritableRaster（如果有），否则返回null。
      WritableRaster BufferedImage.getWritableTile​(int tileX, int tileY)
      检查一个瓦片写作。
      WritableRaster WritableRenderedImage.getWritableTile​(int tileX, int tileY)
      检查一个瓦片写作。
      Methods in java.awt.image with parameters of type WritableRaster
      Modifier and Type 方法 描述
      ColorModel ColorModel.coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设此数据目前由该 ColorModel正确描述。
      ColorModel ComponentColorModel.coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设目前 ColorModel正确描述了数据。
      ColorModel DirectColorModel.coerceData​(WritableRaster raster, boolean isAlphaPremultiplied)
      强制光栅数据与 isAlphaPremultiplied变量中指定的状态相匹配，假设目前 ColorModel正确描述了数据。
      WritableRaster BufferedImage.copyData​(WritableRaster outRaster)
      计算 BufferedImage的任意矩形区域并将其复制到指定的 WritableRaster 。
      WritableRaster RenderedImage.copyData​(WritableRaster raster)
      计算RenderedImage的任意矩形区域，并将其复制到调用者提供的WritableRaster中。
      WritableRaster AffineTransformOp.filter​(Raster src, WritableRaster dst)
      转换源 Raster并将结果存储在目标 Raster 。
      WritableRaster BandCombineOp.filter​(Raster src, WritableRaster dst)
      使用构造函数中指定的矩阵转换 Raster 。
      WritableRaster ColorConvertOp.filter​(Raster src, WritableRaster dest)
      Color转换源光栅中的图像数据。
      WritableRaster ConvolveOp.filter​(Raster src, WritableRaster dst)
      对光栅进行卷积。
      WritableRaster LookupOp.filter​(Raster src, WritableRaster dst)
      对 Raster执行查找操作。
      WritableRaster RasterOp.filter​(Raster src, WritableRaster dest)
      执行从源光栅到目标光栅的单输入/单输出操作。
      WritableRaster RescaleOp.filter​(Raster src, WritableRaster dst)
      重新调整源光栅中的像素数据。
      WritableRaster ColorModel.getAlphaRaster​(WritableRaster raster)
      返回 Raster表示图像的alpha通道，从输入中提取 Raster ，提供此的像素值 ColorModel表示颜色和alpha信息为独立的空间频带（例如
      WritableRaster ComponentColorModel.getAlphaRaster​(WritableRaster raster)
      返回 Raster表示图像的alpha通道，从输入中提取 Raster 。
      WritableRaster PackedColorModel.getAlphaRaster​(WritableRaster raster)
      返回WritableRaster表示图像的alpha通道，从输入中提取WritableRaster 。
      Constructors in java.awt.image with parameters of type WritableRaster
      Constructor 描述
      BufferedImage​(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
      构造一个新的 BufferedImage与指定的 ColorModel和 Raster 。
      WritableRaster​(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
      使用给定的SampleModel，DataBuffer和父构造一个WritableRaster。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.BufferedImageOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.BufferedImageOp

  • Packages that use BufferedImageOp
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。

    • Uses of BufferedImageOp in java.awt

      Methods in java.awt with parameters of type BufferedImageOp
      Modifier and Type 方法 描述
      abstract void Graphics2D.drawImage​(BufferedImage img, BufferedImageOp op, int x, int y)
      呈现BufferedImage ，用BufferedImageOp过滤。

    • Uses of BufferedImageOp in java.awt.image

      Classes in java.awt.image that implement BufferedImageOp
      Modifier and Type Class 描述
      class  AffineTransformOp
      该类使用仿射变换来执行从源图像中的2D坐标或目标图像中的 Raster到2D坐标的线性映射或 Raster 。
      class  ColorConvertOp
      该类对源图像中的数据执行逐像素颜色转换。
      class  ConvolveOp
      该类实现从源到目的地的卷积。
      class  LookupOp
      该类实现从源到目标的查找操作。
      class  RescaleOp
      该类通过将每个像素的采样值乘以比例因子然后添加偏移来执行源图像中的数据的逐像素重新缩放。
      Methods in java.awt.image that return BufferedImageOp
      Modifier and Type 方法 描述
      BufferedImageOp BufferedImageFilter.getBufferedImageOp​()
      返回 BufferedImageOp 。
      Constructors in java.awt.image with parameters of type BufferedImageOp
      Constructor 描述
      BufferedImageFilter​(BufferedImageOp op)
      使用指定的单源/单目的地址运算符构造一个 BufferedImageFilter 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.ImageConsumer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.ImageConsumer

  • Packages that use ImageConsumer
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of ImageConsumer in java.awt.image

      Classes in java.awt.image that implement ImageConsumer
      Modifier and Type Class 描述
      class  AreaAveragingScaleFilter
      一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。
      class  BufferedImageFilter
      所述BufferedImageFilter类的子类的ImageFilter是提供一种使用单一源/单一目标图像操作符（的简单方法BufferedImageOp ）以过滤BufferedImage在图像生产者/消费者/观察员范例。
      class  CropImageFilter
      用于裁剪图像的ImageFilter类。
      class  ImageFilter
      此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。
      class  PixelGrabber
      PixelGrabber类实现了一个ImageConsumer，它可以附加到Image或ImageProducer对象，以检索该图像中的像素的子集。
      class  ReplicateScaleFilter
      一个ImageFilter类，用于使用最简单的算法缩放图像。
      class  RGBImageFilter
      该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。
      Fields in java.awt.image declared as ImageConsumer
      Modifier and Type Field 描述
      protected ImageConsumer ImageFilter.consumer
      ImageFilter的此实例正在过滤数据的特定图像数据流的消费者。
      Methods in java.awt.image with parameters of type ImageConsumer
      Modifier and Type 方法 描述
      void FilteredImageSource.addConsumer​(ImageConsumer ic)
      将指定的 ImageConsumer添加到对过滤图像的数据感兴趣的消费者列表中。
      void ImageProducer.addConsumer​(ImageConsumer ic)
      注册一个 ImageConsumer与 ImageProducer所述的稍后重建期间用于访问图像数据 Image 。
      void MemoryImageSource.addConsumer​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
      ImageFilter ImageFilter.getFilterInstance​(ImageConsumer ic)
      返回一个ImageFilter对象的唯一实例，该对象实际上将对指定的ImageConsumer进行过滤。
      boolean FilteredImageSource.isConsumer​(ImageConsumer ic)
      确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。
      boolean ImageProducer.isConsumer​(ImageConsumer ic)
      确定指定的 ImageConsumer对象当前是否已注册到此 ImageProducer作为其消费者之一。
      boolean MemoryImageSource.isConsumer​(ImageConsumer ic)
      确定ImageConsumer是否在目前对该图像的数据感兴趣的消费者列表中。
      void FilteredImageSource.removeConsumer​(ImageConsumer ic)
      从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
      void ImageProducer.removeConsumer​(ImageConsumer ic)
      从目前注册接收图像数据的消费者列表中删除指定的 ImageConsumer对象。
      void MemoryImageSource.removeConsumer​(ImageConsumer ic)
      从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
      void FilteredImageSource.requestTopDownLeftRightResend​(ImageConsumer ic)
      请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
      void ImageProducer.requestTopDownLeftRightResend​(ImageConsumer ic)
      请求，代表的 ImageConsumer ，该 ImageProducer尝试重新发送图像数据的一个更多的时间在TOPDOWNLEFTRIGHT顺序，以便依赖于按顺序接收像素更高质量的变换算法可以用于产生图像的更好的输出的版本。
      void MemoryImageSource.requestTopDownLeftRightResend​(ImageConsumer ic)
      请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
      void FilteredImageSource.startProduction​(ImageConsumer ic)
      开始生成已过滤的图像。
      void ImageProducer.startProduction​(ImageConsumer ic)
      将指定的 ImageConsumer对象注册为消费者，并启动图像数据的立即重建，然后将其传送给该消费者和可能已经向生产者注册的任何其他消费者。
      void MemoryImageSource.startProduction​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的用户列表中，并通过ImageConsumer界面立即开始传送图像数据。

    • Uses of ImageConsumer in java.awt.image.renderable

      Methods in java.awt.image.renderable with parameters of type ImageConsumer
      Modifier and Type 方法 描述
      void RenderableImageProducer.addConsumer​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
      boolean RenderableImageProducer.isConsumer​(ImageConsumer ic)
      确定ImageConsumer是否位于当前对该图像的数据感兴趣的消费者列表中。
      void RenderableImageProducer.removeConsumer​(ImageConsumer ic)
      从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
      void RenderableImageProducer.requestTopDownLeftRightResend​(ImageConsumer ic)
      请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
      void RenderableImageProducer.startProduction​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的消费者列表中，并通过ImageConsumer界面立即开始传送图像数据。

    • Uses of ImageConsumer in javax.swing

      Classes in javax.swing that implement ImageConsumer
      Modifier and Type Class 描述
      class  GrayFilter
      通过将图像转换成灰度图像来“禁用”图像并增亮图像中的像素的图像滤镜。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.ImageObserver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.ImageObserver

  • Packages that use ImageObserver
    软件包 描述
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of ImageObserver in java.applet

      Classes in java.applet that implement ImageObserver
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of ImageObserver in java.awt

      Classes in java.awt that implement ImageObserver
      Modifier and Type Class 描述
      class  Button
      这个类创建一个标记的按钮。
      class  Canvas
      Canvas组件表示应用程序可以在其上绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。
      class  Checkbox
      复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
      class  Choice
      Choice课程提供了弹出菜单的选择。
      class  Component
      组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
      class  Container
      通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
      class  Dialog
      Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      class  Frame
      A Frame是具有标题和边框的顶级窗口。
      class  Label
      Label对象是用于将文本放置在容器中的组件。
      class  List
      List组件向用户显示文本项的滚动列表。
      class  Panel
      Panel是最简单的容器类。
      class  Scrollbar
      Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。
      class  ScrollPane
      一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。
      class  TextArea
      TextArea对象是显示文本的多行区域。
      class  TextComponent
      TextComponent类是允许编辑某些文本的任何组件的超类。
      class  TextField
      TextField对象是允许编辑单行文本的文本组件。
      class  Window
      一个 Window对象是没有边框的顶级窗口，没有菜单。
      Methods in java.awt with parameters of type ImageObserver
      Modifier and Type 方法 描述
      int Component.checkImage​(Image image, int width, int height, ImageObserver observer)
      返回构造指定图像的屏幕表示的状态。
      int Component.checkImage​(Image image, ImageObserver observer)
      返回构造指定图像的屏幕表示的状态。
      abstract int Toolkit.checkImage​(Image image, int width, int height, ImageObserver observer)
      表示准备显示的指定图像的构造状态。
      abstract boolean Graphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
      abstract boolean Graphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer)
      按照当前可用的方式绘制指定图像的指定区域的大小，即时缩放，以适应目标可绘制表面的指定区域内。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      绘制与已经缩放以适应指定矩形内的指定图像的大小。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, int width, int height, ImageObserver observer)
      绘制与已经缩放以适应指定矩形内的指定图像的大小。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      绘制当前可用的指定图像的大小。
      abstract boolean Graphics.drawImage​(Image img, int x, int y, ImageObserver observer)
      绘制当前可用的指定图像的大小。
      abstract boolean Graphics2D.drawImage​(Image img, AffineTransform xform, ImageObserver obs)
      渲染图像，在绘制之前将图像空间的变换应用到用户空间中。
      abstract int Image.getHeight​(ImageObserver observer)
      确定图像的高度。
      abstract Object Image.getProperty​(String name, ImageObserver observer)
      通过名称获取此图像的属性。
      abstract int Image.getWidth​(ImageObserver observer)
      确定图像的宽度。
      boolean Component.prepareImage​(Image image, int width, int height, ImageObserver observer)
      准备一个图像，以指定的宽度和高度在此组件上渲染。
      boolean Component.prepareImage​(Image image, ImageObserver observer)
      准备用于在此组件上呈现的图像。
      abstract boolean Toolkit.prepareImage​(Image image, int width, int height, ImageObserver observer)
      准备渲染图像。

    • Uses of ImageObserver in java.awt.image

      Methods in java.awt.image with parameters of type ImageObserver
      Modifier and Type 方法 描述
      int AbstractMultiResolutionImage.getHeight​(ImageObserver observer)
      该方法简单地委托给基本图像上相同的方法，它等同于： getBaseImage().getHeight(observer) 。
      int BufferedImage.getHeight​(ImageObserver observer)
      返回 BufferedImage的高度。
      Object AbstractMultiResolutionImage.getProperty​(String name, ImageObserver observer)
      该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getProperty(name, observer) 。
      Object BufferedImage.getProperty​(String name, ImageObserver observer)
      按名称返回图像的属性。
      int AbstractMultiResolutionImage.getWidth​(ImageObserver observer)
      该方法简单地委托给基本图像上的相同方法，它相当于： getBaseImage().getWidth(observer) 。
      int BufferedImage.getWidth​(ImageObserver observer)
      返回 BufferedImage的宽度。

    • Uses of ImageObserver in javafx.embed.swing

      Classes in javafx.embed.swing that implement ImageObserver
      Modifier and Type Class 描述
      class  JFXPanel
      JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。

    • Uses of ImageObserver in javax.swing

      Classes in javax.swing that implement ImageObserver
      Modifier and Type Class 描述
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      static class  Box.Filler
      参与布局但没有视图的轻量级组件的实现。
      class  CellRendererPane
      此类插入到单元格渲染器和使用它们的组件之间。
      class  DefaultListCellRenderer
      渲染列表中的项目。
      static class  DefaultListCellRenderer.UIResource
      实现UIResource的DefaultListCellRenderer的子类。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      class  JButton
      实现“推”按钮。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      class  JColorChooser
      JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      class  JComponent
      除顶级容器之外的所有Swing组件的基类。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      class  JDialog
      创建对话窗口的主要类。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      class  JFileChooser
      JFileChooser为用户提供了一种简单的机制来选择文件。
      class  JFormattedTextField
      JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑了文本就检索了一个特定的对象。
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      static class  JInternalFrame.JDesktopIcon
      该组件代表 JInternalFrame的图标化版本。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并接收其边框内生成的所有 AWTEvent的通知。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。
      class  JMenuBar
      一个菜单栏的实现。
      class  JMenuItem
      菜单中项目的实现。
      class  JOptionPane
      JOptionPane可以轻松地弹出一个标准对话框，提示用户获取值或通知他们某些东西。
      class  JPanel
      JPanel是一个通用的轻量级容器。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示某些内容是键入的，但不显示原始字符。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      static class  JPopupMenu.Separator
      弹出菜单特定的分隔符。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      class  JRootPane
      通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
      class  JScrollBar
      一个滚动条的实现。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
      class  JSeparator
      JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      更专业的编辑器的简单基类，可以使用 JFormattedTextField显示模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      class  JSplitPane
      JSplitPane用于分割两（而且只有两个） Component s。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      class  JTextArea
      A JTextArea是一个多行区域，显示纯文本。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      static class  JToolBar.Separator
      工具栏特定的分隔符。
      class  JToolTip
      用于显示组件的“提示”。
      class  JTree
      将一组分层数据显示为大纲的控件。
      class  JViewport
      您可以通过它查看基础信息的“视口”或“舷窗”。
      class  JWindow
      A JWindow是可以在用户桌面上的任意位置显示的容器。
      Methods in javax.swing that return ImageObserver
      Modifier and Type 方法 描述
      ImageObserver ImageIcon.getImageObserver​()
      返回图像的图像观察者。
      Methods in javax.swing with parameters of type ImageObserver
      Modifier and Type 方法 描述
      boolean DebugGraphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, int width, int height, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      boolean DebugGraphics.drawImage​(Image img, int x, int y, ImageObserver observer)
      覆盖 Graphics.drawImage 。
      void ImageIcon.setImageObserver​(ImageObserver observer)
      设置图像的图像观察者。

    • Uses of ImageObserver in javax.swing.colorchooser

      Classes in javax.swing.colorchooser that implement ImageObserver
      Modifier and Type Class 描述
      class  AbstractColorChooserPanel
      这是颜色选择器的抽象超类。

    • Uses of ImageObserver in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ImageObserver
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
      class  BasicComboBoxRenderer
      ComboBox渲染器
      static class  BasicComboBoxRenderer.UIResource
      BasicComboBoxRenderer的子类实现UIResource。
      class  BasicComboPopup
      这是 ComboPopup接口的基本实现。
      class  BasicInternalFrameTitlePane
      管理基本标题栏的类
      class  BasicInternalFrameTitlePane.SystemMenuBar
      这个类应该被视为一个“受保护”的内部类。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。

    • Uses of ImageObserver in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ImageObserver
      Modifier and Type Class 描述
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalComboBoxUI.MetalComboPopup
      已过时。
      从Java 2平台v1.4开始。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      class  MetalFileChooserUI.FilterComboBoxRenderer
      渲染不同类型的尺寸和样式。
      class  MetalInternalFrameTitlePane
      管理JLF标题栏的类
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。

    • Uses of ImageObserver in javax.swing.table

      Classes in javax.swing.table that implement ImageObserver
      Modifier and Type Class 描述
      class  DefaultTableCellRenderer
      在 JTable渲染（显示）单个单元格的标准类。
      static class  DefaultTableCellRenderer.UIResource
      DefaultTableCellRenderer的子类实现 UIResource 。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。

    • Uses of ImageObserver in javax.swing.text

      Classes in javax.swing.text that implement ImageObserver
      Modifier and Type Class 描述
      class  JTextComponent
      JTextComponent是摆动文本组件的基础类。

    • Uses of ImageObserver in javax.swing.tree

      Classes in javax.swing.tree that implement ImageObserver
      Modifier and Type Class 描述
      class  DefaultTreeCellEditor.DefaultTextField
      当没有提供编辑器时使用 TextField 。
      class  DefaultTreeCellEditor.EditorContainer
      集装箱负责放置 editingComponent 。
      class  DefaultTreeCellRenderer
      在树中显示一个条目。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.ImageProducer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.ImageProducer

  • Packages that use ImageProducer
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of ImageProducer in java.awt

      Methods in java.awt that return ImageProducer
      Modifier and Type 方法 描述
      abstract ImageProducer Image.getSource​()
      获取产生图像像素的对象。
      Methods in java.awt with parameters of type ImageProducer
      Modifier and Type 方法 描述
      Image Component.createImage​(ImageProducer producer)
      从指定的图像制作者创建图像。
      abstract Image Toolkit.createImage​(ImageProducer producer)
      使用指定的图像生成器创建图像。

    • Uses of ImageProducer in java.awt.image

      Classes in java.awt.image that implement ImageProducer
      Modifier and Type Class 描述
      class  FilteredImageSource
      这个类是ImageProducer接口的一个实现，它接收一个现有的图像和一个过滤器对象，并使用它们来生成原始图像的新过滤版本的图像数据。
      class  MemoryImageSource
      该类是ImageProducer接口的一个实现，它使用一个数组为图像生成像素值。
      Methods in java.awt.image that return ImageProducer
      Modifier and Type 方法 描述
      ImageProducer AbstractMultiResolutionImage.getSource​()
      该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getSource() 。
      ImageProducer BufferedImage.getSource​()
      返回产生图像像素的对象。
      ImageProducer VolatileImage.getSource​()
      这将为此VolatileImage返回ImageProducer。
      Methods in java.awt.image with parameters of type ImageProducer
      Modifier and Type 方法 描述
      void ImageFilter.resendTopDownLeftRight​(ImageProducer ip)
      响应一个按TopDownLeftRight（TDLR）的请求顺序将像素数据重新发送从 ImageConsumer 。
      Constructors in java.awt.image with parameters of type ImageProducer
      Constructor 描述
      FilteredImageSource​(ImageProducer orig, ImageFilter imgf)
      从现有的ImageProducer和过滤器对象构造一个ImageProducer对象。
      PixelGrabber​(ImageProducer ip, int x, int y, int w, int h, int[] pix, int off, int scansize)
      创建一个PixelGrabber对象，从指定的ImageProducer生成的图像中获取像素的（x，y，w，h）矩形部分到给定的数组中。

    • Uses of ImageProducer in java.awt.image.renderable

      Classes in java.awt.image.renderable that implement ImageProducer
      Modifier and Type Class 描述
      class  RenderableImageProducer
      一个实现ImageProducer以允许异步生成RenderableImage的适配器类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.MultiResolutionImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.MultiResolutionImage

  • Packages that use MultiResolutionImage
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。

    • Uses of MultiResolutionImage in java.awt

      Methods in java.awt that return MultiResolutionImage
      Modifier and Type 方法 描述
      MultiResolutionImage Robot.createMultiResolutionScreenCapture​(Rectangle screenRect)
      创建包含从屏幕读取的像素的图像。

    • Uses of MultiResolutionImage in java.awt.image

      Classes in java.awt.image that implement MultiResolutionImage
      Modifier and Type Class 描述
      class  AbstractMultiResolutionImage
      该类为要实现 MultiResolutionImage接口的类提供了几个 Image方法的默认实现。
      class  BaseMultiResolutionImage
      这个类是一个基于数组的 AbstractMultiResolutionImage类的实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.RasterOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.RasterOp

  • Packages that use RasterOp
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of RasterOp in java.awt.image

      Classes in java.awt.image that implement RasterOp
      Modifier and Type Class 描述
      class  AffineTransformOp
      该类使用仿射变换来执行从源图像中的2D坐标或目标图像中的 Raster到2D坐标的线性映射或 Raster 。
      class  BandCombineOp
      该类使用指定的矩阵在 Raster执行带的任意线性组合。
      class  ColorConvertOp
      该类对源图像中的数据执行逐像素颜色转换。
      class  ConvolveOp
      该类实现从源到目的地的卷积。
      class  LookupOp
      该类实现从源到目标的查找操作。
      class  RescaleOp
      This class performs a pixel-by-pixel rescaling of the data in the source image by multiplying the sample values for each pixel by a scale factor and then adding an offset.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.RenderedImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.RenderedImage

  • Packages that use RenderedImage
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

    • Uses of RenderedImage in java.awt

      Methods in java.awt with parameters of type RenderedImage
      Modifier and Type 方法 描述
      abstract void Graphics2D.drawRenderedImage​(RenderedImage img, AffineTransform xform)
      渲染一个RenderedImage ，在绘制之前将图像空间的变换应用到用户空间中。

    • Uses of RenderedImage in java.awt.image

      Subinterfaces of RenderedImage in java.awt.image
      Modifier and Type 接口 描述
      interface  WritableRenderedImage
      WritableRenderedImage是包含或可以以Raster形式生成图像数据的对象的通用接口，可以修改和/或写入。
      Classes in java.awt.image that implement RenderedImage
      Modifier and Type Class 描述
      class  BufferedImage
      BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
      Methods in java.awt.image that return types with arguments of type RenderedImage
      Modifier and Type 方法 描述
      Vector<RenderedImage> BufferedImage.getSources​()
      返回Vector的RenderedImage对象是直接来源，而不是这些直接来源的来源，该图像数据的BufferedImage 。
      Vector<RenderedImage> RenderedImage.getSources​()
      返回RenderedImages的矢量，该矢量是此RenderedImage的图像数据的直接来源。

    • Uses of RenderedImage in java.awt.image.renderable

      Methods in java.awt.image.renderable that return RenderedImage
      Modifier and Type 方法 描述
      RenderedImage ContextualRenderedImageFactory.create​(RenderContext renderContext, ParameterBlock paramBlock)
      给定一个渲染，给定一个RenderContext和一个ParameterBlock，其中包含操作的源和参数。
      RenderedImage RenderedImageFactory.create​(ParameterBlock paramBlock, RenderingHints hints)
      创建表示给定ParameterBlock和RenderingHints的成像操作（或操作链）的结果的RenderedImage。
      RenderedImage RenderableImage.createDefaultRendering​()
      返回此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。
      RenderedImage RenderableImageOp.createDefaultRendering​()
      获取此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。
      RenderedImage RenderableImage.createRendering​(RenderContext renderContext)
      创建一个RenderedImage，表示使用给定的RenderContext渲染此图像。
      RenderedImage RenderableImageOp.createRendering​(RenderContext renderContext)
      创建一个RenderedImage，它表示根据给定的RenderContext呈现的RenderableImageOp（包括其Renderable源）。
      RenderedImage RenderableImage.createScaledRendering​(int w, int h, RenderingHints hints)
      以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。
      RenderedImage RenderableImageOp.createScaledRendering​(int w, int h, RenderingHints hints)
      以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。
      RenderedImage ParameterBlock.getRenderedSource​(int index)
      返回一个源为 RenderedImage 。

    • Uses of RenderedImage in javax.imageio

      Fields in javax.imageio declared as RenderedImage
      Modifier and Type Field 描述
      protected RenderedImage IIOImage.image
      RenderedImage被引用。
      Methods in javax.imageio that return RenderedImage
      Modifier and Type 方法 描述
      RenderedImage IIOImage.getRenderedImage​()
      如果只有 Raster可用，则返回当前设置的 RenderedImage ，或 null 。
      RenderedImage ImageReader.readAsRenderedImage​(int imageIndex, ImageReadParam param)
      返回一个 RenderedImage对象，其中包含由 imageIndex索引的图像的内容。
      Methods in javax.imageio with parameters of type RenderedImage
      Modifier and Type 方法 描述
      static ImageTypeSpecifier ImageTypeSpecifier.createFromRenderedImage​(RenderedImage image)
      返回一个 ImageTypeSpecifier ，编码 RenderedImage （可能是 BufferedImage ）的布局。
      void ImageWriter.replacePixels​(RenderedImage image, ImageWriteParam param)
      用给定图像的一部分替换已经存在于输出中的图像的一部分。
      void IIOImage.setRenderedImage​(RenderedImage image)
      设置当前的 RenderedImage 。
      static boolean ImageIO.write​(RenderedImage im, String formatName, File output)
      使用支持给定格式的任意 ImageWriter写入图像到 File 。
      static boolean ImageIO.write​(RenderedImage im, String formatName, OutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 OutputStream 。
      static boolean ImageIO.write​(RenderedImage im, String formatName, ImageOutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 ImageOutputStream 。
      void ImageWriter.write​(RenderedImage image)
      将包含单个图像的完整图像流附加到输出的默认元数据和缩略图。
      Constructors in javax.imageio with parameters of type RenderedImage
      Constructor 描述
      IIOImage​(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
      构造一个 IIOImage含有 RenderedImage ，和缩略图和元数据与之相关联。
      ImageTypeSpecifier​(RenderedImage image)
      构造一个 ImageTypeSpecifier从 RenderedImage 。

    • Uses of RenderedImage in javax.imageio.spi

      Methods in javax.imageio.spi with parameters of type RenderedImage
      Modifier and Type 方法 描述
      boolean ImageWriterSpi.canEncodeImage​(RenderedImage im)
      返回 true如果 ImageWriter与此服务提供者关联实现能够编码给定的 RenderedImage实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.TileObserver (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.TileObserver

  • Packages that use TileObserver
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of TileObserver in java.awt.image

      Methods in java.awt.image with parameters of type TileObserver
      Modifier and Type 方法 描述
      void BufferedImage.addTileObserver​(TileObserver to)
      添加瓦片观察器。
      void WritableRenderedImage.addTileObserver​(TileObserver to)
      添加观察者
      void BufferedImage.removeTileObserver​(TileObserver to)
      移除瓦片观察者。
      void WritableRenderedImage.removeTileObserver​(TileObserver to)
      删除观察者
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.WritableRenderedImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.WritableRenderedImage

  • Packages that use WritableRenderedImage
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。

    • Uses of WritableRenderedImage in java.awt.image

      Classes in java.awt.image that implement WritableRenderedImage
      Modifier and Type Class 描述
      class  BufferedImage
      BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。
      Methods in java.awt.image with parameters of type WritableRenderedImage
      Modifier and Type 方法 描述
      void TileObserver.tileUpdate​(WritableRenderedImage source, int tileX, int tileY, boolean willBeWritable)
      瓦片即将更新（即将要被书写，或正在从写作中释放）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ContextualRenderedImageFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image.renderable

Interface ContextualRenderedImageFactory

  • All Superinterfaces:
    RenderedImageFactory

    public interface ContextualRenderedImageFactory
extends RenderedImageFactory
    ContextualRenderedImageFactory为RenderableImageOp的实例之间的功能提供了一个接口。 因此，通过使用ContextualRenderedImageFactory的多个实例，RenderableImages上的不同操作可以由单个类（如RenderedImageOp）执行。 名称ContextualRenderedImageFactory通常缩写为“CRIF”。

    要在独立渲染的链中使用的所有操作都必须实现ContextualRenderedImageFactory。

    实现此接口的类必须提供一个没有参数的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      RenderedImage create​(RenderContext renderContext, ParameterBlock paramBlock)
      给定一个渲染，给定一个RenderContext和一个ParameterBlock，其中包含操作的源和参数。
      Rectangle2D getBounds2D​(ParameterBlock paramBlock)
      在独立于渲染的空间中，返回在给定的一组源上执行的操作输出的边界框。
      Object getProperty​(ParameterBlock paramBlock, String name)
      获取由name参数指定的属性的适当实例。
      String[] getPropertyNames​()
      返回由getProperty识别的名称列表。
      boolean isDynamic​()
      如果使用相同参数的连续渲染（即，调用create（RenderContext，ParameterBlock）））可能会产生不同的结果，则返回true。
      RenderContext mapRenderContext​(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
      将操作的输出RenderContext映射到每个操作源的RenderContext中。

      • Methods inherited from interface java.awt.image.renderable.RenderedImageFactory

        create

    • 方法详细信息

      • mapRenderContext

        RenderContext mapRenderContext​(int i,
                               RenderContext renderContext,
                               ParameterBlock paramBlock,
                               RenderableImage image)
        将操作的输出RenderContext映射到每个操作源的RenderContext中。 这对于可以全部或部分地简单地表示为RenderContext中的改变（例如仿射映射）或希望获得其源的较低质量渲染以便节省处理工作量或传输带宽的操作是有用的。 一些操作，如模糊，也可以使用这种机制来避免获得比必要的更高质量的来源。
        参数
        i - 源图像的索引。
        renderContext - 应用于操作的RenderContext。
        paramBlock - 包含操作的源和参数的ParameterBlock。
        image - 渲染的RenderableImage。
        结果
        一个 RenderContext的源代码在指定的参数Vector中指定的索引包含在指定的ParameterBlock中。

      • create

        RenderedImage create​(RenderContext renderContext,
                     ParameterBlock paramBlock)
        给定一个渲染，给定一个RenderContext和一个ParameterBlock，其中包含操作的源和参数。 输出是RenderedImage，它考虑到RenderContext以确定其在图像平面上的尺寸和位置。 该方法包含允许独立于渲染的操作适应特定RenderContext的“智能”。
        参数
        renderContext - 指定渲染的RenderContext
        paramBlock - 包含操作的源和参数的ParameterBlock
        结果
        一个 RenderedImage的来源和参数在指定的ParameterBlock中，并根据指定的RenderContext中的渲染指令。

      • getBounds2D

        Rectangle2D getBounds2D​(ParameterBlock paramBlock)
        在独立于渲染的空间中，返回在给定的一组源上执行的操作输出的边界框。 边界返回为Rectangle2D，即具有浮点角坐标的轴对齐矩形。
        参数
        paramBlock - 包含操作的源和参数的ParameterBlock。
        结果
        一个Rectangle2D指定输出的与渲染无关的边界框。

      • getProperty

        Object getProperty​(ParameterBlock paramBlock,
                   String name)
        获取由name参数指定的属性的适当实例。 当有多个源指定属性时，此方法必须确定要返回的属性的哪个实例。
        参数
        paramBlock - 一个包含操作的源和参数的ParameterBlock。
        name - 一个命名所需属性的字符串。
        结果
        一个对象引用的值所请求的属性。

      • getPropertyNames

        String[] getPropertyNames​()
        返回由getProperty识别的名称列表。
        结果
        属性名称列表。

      • isDynamic

        boolean isDynamic​()
        如果使用相同参数的连续渲染（即，调用create（RenderContext，ParameterBlock）））可能会产生不同的结果，则返回true。 该方法可用于确定现有渲染是否可被缓存和重用。 返回真实始终是安全的。
        结果
        true如果具有相同参数的连续渲染可能会产生不同的结果; false否则。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.image.renderable (Java SE 9 & JDK 9 )

java.awt.image.renderable

Interfaces

  • ContextualRenderedImageFactory
  • RenderableImage
  • RenderedImageFactory

Classes

  • ParameterBlock
  • RenderableImageOp
  • RenderableImageProducer
  • RenderContext


java.awt.image.renderable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.image.renderable

提供用于生成与渲染无关的图像的类和接口。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    ContextualRenderedImageFactory
    ContextualRenderedImageFactory为RenderableImageOp的实例之间的功能提供了一个接口。
    RenderableImage
    RenderableImage是渲染无关的图像的通用接口（包含分辨率独立性的概念）。
    RenderedImageFactory
    RenderedImageFactory接口（通常缩写为RIF）旨在由希望充当工厂来生成不同渲染的类实现，例如通过在一组源上执行一系列BufferedImageOps，具体取决于特定的一组参数，属性，并提供提示。
  • 类摘要
    Class 描述
    ParameterBlock
    A ParameterBlock封装了所有关于RenderableImageOp或处理图像的其他类所需的源和参数（对象）的信息。
    RenderableImageOp
    此类通过其关联的ContextualRenderedImageFactory实例的帮助来处理操作的可渲染方面。
    RenderableImageProducer
    一个实现ImageProducer以允许异步生成RenderableImage的适配器类。
    RenderContext
    RenderContext封装了从RenderableImage生成特定渲染所需的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.image.renderable Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.image.renderable

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.image.renderable.ParameterBlock (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.image.renderable.RenderableImageOp (implements java.awt.image.renderable.RenderableImage)
    • java.awt.image.renderable.RenderableImageProducer (implements java.awt.image.ImageProducer, java.lang.Runnable)
    • java.awt.image.renderable.RenderContext (implements java.lang.Cloneable)

Interface Hierarchy

  • java.awt.image.renderable.RenderableImage
  • java.awt.image.renderable.RenderedImageFactory
    • java.awt.image.renderable.ContextualRenderedImageFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ParameterBlock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image.renderable

Class ParameterBlock

  • java.lang.Object
    • java.awt.image.renderable.ParameterBlock
  • All Implemented Interfaces:
    Serializable ， Cloneable

    public class ParameterBlock
extends Object
implements Cloneable, Serializable
    A ParameterBlock封装了所有关于RenderableImageOp或处理图像的其他类所需的源和参数（对象）的信息。

    虽然可以在源向量中放置任意对象，但此类的用户可能会强加语义约束，例如要求所有源都是RenderedImages或RenderableImage。 ParameterBlock本身只是一个容器，不会对源或参数类型进行检查。

    ParameterBlock中的所有参数都是对象; 可以使用方便的添加和设置方法来获取基类型的参数，并构造适当的Number子类（如Integer或Float）。 相应的get方法执行向下转换并具有基本类型的返回值; 如果存储的值没有正确的类型，将抛出异常。 没有办法区分“short s; add（s）”和“add（new Short（s））”的结果。

    请注意，get和set方法对引用进行操作。 因此，当这不合适时，必须小心不要在ParameterBlock之间共享引用。 例如，要创建一个新的ParameterBlock等于一个旧的，除了一个添加的源，可能会诱惑写：

      ParameterBlock addSource(ParameterBlock pb, RenderableImage im) {
     ParameterBlock pb1 = new ParameterBlock(pb.getSources());
     pb1.addSource(im);
     return pb1;
 }

    此代码将具有更改原始ParameterBlock ，因为getSources操作返回对其源向量的引用。 pb和pb1都共享它们的源向量，并且两者中的更改都可见。

    编写addSource函数的正确方法是克隆源Vector：

      ParameterBlock addSource (ParameterBlock pb, RenderableImage im) {
     ParameterBlock pb1 = new ParameterBlock(pb.getSources().clone());
     pb1.addSource(im);
     return pb1;
 }

    ParameterBlock ，已经定义了ParameterBlock的克隆方法来执行源和参数向量的克隆。 一个标准的浅克隆可用作shallowClone。

    addSource，setSource，add和set方法被定义为在添加参数后返回'this'。 这允许使用如下语法：

      ParameterBlock pb = new ParameterBlock();
 op = new RenderableImageOp("operation", pb.add(arg1).add(arg2));
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Vector<Object> parameters
      非源参数向量，存储为任意对象。
      protected Vector<Object> sources
      源的矢量，存储为任意对象。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ParameterBlock​()
      一个虚拟构造函数。
      ParameterBlock​(Vector<Object> sources)
      构造一个具有给 ParameterBlock向量的 ParameterBlock 。
      ParameterBlock​(Vector<Object> sources, Vector<Object> parameters)
      构造一个 ParameterBlock与给定的矢量矢量和参数矢量。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ParameterBlock add​(byte b)
      将一个字节添加到参数列表中。
      ParameterBlock add​(char c)
      在参数列表中添加一个字符。
      ParameterBlock add​(double d)
      向参数列表中添加一个Double。
      ParameterBlock add​(float f)
      将浮点数添加到参数列表中。
      ParameterBlock add​(int i)
      将一个整数添加到参数列表中。
      ParameterBlock add​(long l)
      在参数列表中添加一个Long。
      ParameterBlock add​(short s)
      在参数列表中添加一个Short。
      ParameterBlock add​(Object obj)
      将对象添加到参数列表中。
      ParameterBlock addSource​(Object source)
      将图像添加到源列表的末尾。
      Object clone​()
      创建一个 ParameterBlock的副本。
      byte getByteParameter​(int index)
      一个方便的方法返回一个参数作为一个字节。
      char getCharParameter​(int index)
      一个方便的方法返回参数作为一个char。
      double getDoubleParameter​(int index)
      将参数返回为双精度的方便方法。
      float getFloatParameter​(int index)
      将参数返回为浮点数的方便方法。
      int getIntParameter​(int index)
      以int形式返回参数的方便方法。
      long getLongParameter​(int index)
      一个方便返回参数的方法。
      int getNumParameters​()
      返回参数数量（不包括源图像）。
      int getNumSources​()
      返回源图像的数量。
      Object getObjectParameter​(int index)
      获取参数作为对象。
      Class<?>[] getParamClasses​()
      返回描述参数类型的Class对象数组。
      Vector<Object> getParameters​()
      返回整个参数向量。
      RenderableImage getRenderableSource​(int index)
      作为RenderableImage返回一个源。
      RenderedImage getRenderedSource​(int index)
      作为一个 RenderedImage返回一个源。
      short getShortParameter​(int index)
      一个简单的方法返回一个参数。
      Object getSource​(int index)
      将源作为一般对象返回。
      Vector<Object> getSources​()
      返回整个Vector的Vector。
      void removeParameters​()
      清除参数列表。
      void removeSources​()
      清除源图像列表。
      ParameterBlock set​(byte b, int index)
      使用字节替换参数列表中的对象。
      ParameterBlock set​(char c, int index)
      用Character替换参数列表中的Object。
      ParameterBlock set​(double d, int index)
      用Double替换参数列表中的对象。
      ParameterBlock set​(float f, int index)
      用Float替换参数列表中的对象。
      ParameterBlock set​(int i, int index)
      用Integer替换参数列表中的Object。
      ParameterBlock set​(long l, int index)
      用Long替换参数列表中的对象。
      ParameterBlock set​(short s, int index)
      用Short替换参数列表中的对象。
      ParameterBlock set​(Object obj, int index)
      替换参数列表中的对象。
      void setParameters​(Vector<Object> parameters)
      将参数的整个Vector设置为给定的Vector。
      ParameterBlock setSource​(Object source, int index)
      用源代替源列表中的条目。
      void setSources​(Vector<Object> sources)
      将整个Vector矢量设置为给定的Vector。
      Object shallowClone​()
      创建一个 ParameterBlock的浅拷贝。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • sources

        protected Vector<Object> sources
        源的矢量，存储为任意对象。

      • parameters

        protected Vector<Object> parameters
        非源参数向量，存储为任意对象。

    • 构造方法详细信息

      • ParameterBlock

        public ParameterBlock​()
        一个虚拟构造函数。

      • ParameterBlock

        public ParameterBlock​(Vector<Object> sources)
        构造一个 ParameterBlock与给定矢量的源。
        参数
        sources - 一个 Vector的源图像

      • ParameterBlock

        public ParameterBlock​(Vector<Object> sources,
                      Vector<Object> parameters)
        构造一个 ParameterBlock与给定的矢量矢量和参数矢量。
        参数
        sources - 一个 Vector的源图像
        parameters - 要在渲染操作中使用的参数的 Vector

    • 方法详细信息

      • shallowClone

        public Object shallowClone​()
        创建一个ParameterBlock的浅拷贝。 源和参数向量将被引用复制 - 对这两个版本都可以看到添加或更改。
        结果
        一个对象克隆的 ParameterBlock 。

      • clone

        public Object clone​()
        创建一个ParameterBlock的副本。 源和参数向量被克隆，但实际的源和参数是通过引用复制的。 这允许修改克隆中的源和参数的顺序和数量对于原始的ParameterBlock是不可见的。 对共享源或参数本身的更改仍将可见。
        重写：
        clone在 Object
        结果
        一个对象克隆的 ParameterBlock 。
        另请参见：
        Cloneable

      • addSource

        public ParameterBlock addSource​(Object source)
        将图像添加到源列表的末尾。 图像被存储为对象，以便将来允许新的节点类型。
        参数
        source - 要存储在源列表中的图像对象。
        结果
        一个新的 ParameterBlock包含指定的 source 。

      • getSource

        public Object getSource​(int index)
        将源作为一般对象返回。 来电者必须将其投入适当的类型。
        参数
        index - 要返回的源的索引。
        结果
        一个 Object ，代表位于 sources Vector指定索引的源。
        另请参见：
        setSource(Object, int)

      • setSource

        public ParameterBlock setSource​(Object source,
                                int index)
        用源代替源列表中的条目。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        source - 指定的源图像
        index - 索引入 sources Vector ，其中插入指定的 source
        结果
        一个新的 ParameterBlock ，其中包含指定的 source指定的 index 。
        另请参见：
        getSource(int)

      • getRenderedSource

        public RenderedImage getRenderedSource​(int index)
        返回一个源为RenderedImage 。 这种方法是一种方便的方法。 如果源不是RenderedImage，将抛出异常。
        参数
        index - 要返回的源的索引
        结果
        一个 RenderedImage表示源图像是在指定索引处 sources Vector 。

      • getRenderableSource

        public RenderableImage getRenderableSource​(int index)
        作为RenderableImage返回一个源。 这种方法是一种方便的方法。 如果源不是RenderableImage，将抛出异常。
        参数
        index - 要返回的源的索引
        结果
        一个 RenderableImage表示源图像是在指定索引处 sources Vector 。

      • getNumSources

        public int getNumSources​()
        返回源图像的数量。
        结果
        源图像的数量在 sources Vector 。

      • getSources

        public Vector<Object> getSources​()
        返回整个Vector的Vector。
        结果
        sources Vector 。
        另请参见：
        setSources(Vector)

      • setSources

        public void setSources​(Vector<Object> sources)
        将整个Vector矢量设置为给定的Vector。
        参数
        sources - 源图像的 Vector
        另请参见：
        getSources()

      • removeSources

        public void removeSources​()
        清除源图像列表。

      • getNumParameters

        public int getNumParameters​()
        返回参数数量（不包括源图像）。
        结果
        参数的数量在 parameters Vector 。

      • getParameters

        public Vector<Object> getParameters​()
        返回整个参数向量。
        结果
        parameters Vector 。
        另请参见：
        setParameters(Vector)

      • setParameters

        public void setParameters​(Vector<Object> parameters)
        将参数的整个Vector设置为给定的Vector。
        参数
        parameters - 指定的参数 Vector
        另请参见：
        getParameters()

      • removeParameters

        public void removeParameters​()
        清除参数列表。

      • add

        public ParameterBlock add​(Object obj)
        将对象添加到参数列表中。
        参数
        obj - Object加到 parameters Vector
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • add

        public ParameterBlock add​(byte b)
        将一个字节添加到参数列表中。
        参数
        b - 要添加到 parameters Vector的字节
        结果
        一个新的 ParameterBlock包含指定的参数。

      • add

        public ParameterBlock add​(char c)
        在参数列表中添加一个字符。
        参数
        c - 要添加到 parameters Vector的字符
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • add

        public ParameterBlock add​(short s)
        在参数列表中添加一个Short。
        参数
        s - 短加到 parameters Vector
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • add

        public ParameterBlock add​(int i)
        将一个整数添加到参数列表中。
        参数
        i - 要添加到 parameters Vector的int
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • add

        public ParameterBlock add​(long l)
        在参数列表中添加一个Long。
        参数
        l - 长期添加到 parameters Vector
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • add

        public ParameterBlock add​(float f)
        将浮点数添加到参数列表中。
        参数
        f - 要添加到 parameters Vector
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • add

        public ParameterBlock add​(double d)
        向参数列表中添加一个Double。
        参数
        d - 双加到 parameters Vector
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • set

        public ParameterBlock set​(Object obj,
                          int index)
        替换参数列表中的对象。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        obj - 替换 parameters Vector指定索引处的参数的参数
        index - 用指定参数替换参数的索引
        结果
        一个新的 ParameterBlock包含指定的参数。

      • set

        public ParameterBlock set​(byte b,
                          int index)
        使用字节替换参数列表中的对象。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        b - 用于替换 parameters Vector指定索引处的参数的参数
        index - 要用指定参数替换的参数的索引
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • set

        public ParameterBlock set​(char c,
                          int index)
        用Character替换参数列表中的Object。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        c - 用于替换 parameters Vector指定索引处的参数的参数
        index - 用指定参数替换参数的索引
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • set

        public ParameterBlock set​(short s,
                          int index)
        用Short替换参数列表中的对象。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        s - 替换 parameters Vector指定索引处的参数的参数
        index - 用指定参数替换参数的索引
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • set

        public ParameterBlock set​(int i,
                          int index)
        用Integer替换参数列表中的Object。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        i - 用于替换 parameters Vector指定索引处的参数的参数
        index - 要用指定参数替换的参数的索引
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • set

        public ParameterBlock set​(long l,
                          int index)
        用Long替换参数列表中的对象。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        l - 用于替换 parameters Vector指定索引处的参数的参数
        index - 用指定参数替换参数的索引
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • set

        public ParameterBlock set​(float f,
                          int index)
        用Float替换参数列表中的对象。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        f - 用于替换 parameters Vector指定索引处的参数的参数
        index - 用指定参数替换参数的索引
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • set

        public ParameterBlock set​(double d,
                          int index)
        用Double替换参数列表中的对象。 如果索引超出当前源列表，则列表将根据需要扩展为null。
        参数
        d - 用于替换 parameters Vector指定索引处的参数的参数
        index - 用指定参数替换参数的索引
        结果
        一个包含指定参数的新的 ParameterBlock 。

      • getObjectParameter

        public Object getObjectParameter​(int index)
        获取参数作为对象。
        参数
        index - 要获取的参数的索引
        结果
        一个 Object表示参数在指定的指数 parameters Vector 。

      • getByteParameter

        public byte getByteParameter​(int index)
        一个方便的方法返回一个参数作为一个字节。 如果参数为null或不是Byte则抛出异常。
        参数
        index - 要返回的参数的索引。
        结果
        指定索引处的参数为 byte值。
        异常
        ClassCastException - 如果指定索引处的参数不是 Byte
        NullPointerException - 如果指定索引处的参数为 null
        ArrayIndexOutOfBoundsException - 如果 index为负数或不低于此 ParameterBlock对象的当前大小

      • getCharParameter

        public char getCharParameter​(int index)
        一个方便的方法返回参数作为一个char。 如果参数为null或不是Character则抛出异常。
        参数
        index - 要返回的参数的索引。
        结果
        指定索引处的参数为 char值。
        异常
        ClassCastException - 如果指定索引处的参数不是 Character
        NullPointerException - 如果指定索引处的参数为 null
        ArrayIndexOutOfBoundsException - 如果 index为负数或不小于此 ParameterBlock对象的当前大小

      • getShortParameter

        public short getShortParameter​(int index)
        一个简单的方法返回一个参数。 如果参数为null或不是Short则抛出异常。
        参数
        index - 要返回的参数的索引。
        结果
        指定索引处的参数为 short值。
        异常
        ClassCastException - 如果指定索引处的参数不是 Short
        NullPointerException - 如果指定索引处的参数为 null
        ArrayIndexOutOfBoundsException - 如果 index为负数或不低于此 ParameterBlock对象的当前大小

      • getIntParameter

        public int getIntParameter​(int index)
        以int形式返回参数的方便方法。 如果参数为null或不是Integer则抛出异常。
        参数
        index - 要返回的参数的索引。
        结果
        指定索引处的参数为 int值。
        异常
        ClassCastException - 如果指定索引处的参数不是 Integer
        NullPointerException - 如果指定索引处的参数为 null
        ArrayIndexOutOfBoundsException - 如果 index为负数或不小于此 ParameterBlock对象的当前大小

      • getLongParameter

        public long getLongParameter​(int index)
        一个方便返回参数的方法。 如果参数为null或不是Long则抛出异常。
        参数
        index - 要返回的参数的索引。
        结果
        指定索引处的参数为 long值。
        异常
        ClassCastException - 如果指定索引处的参数不是 Long
        NullPointerException - 如果指定索引处的参数为 null
        ArrayIndexOutOfBoundsException - 如果 index为负数或不低于此 ParameterBlock对象的当前大小

      • getFloatParameter

        public float getFloatParameter​(int index)
        将参数返回为浮点数的方便方法。 如果参数为null或不是Float则抛出异常。
        参数
        index - 要返回的参数的索引。
        结果
        指定索引处的参数为 float 。
        异常
        ClassCastException - 如果指定索引处的参数不是 Float
        NullPointerException - 如果指定索引处的参数为 null
        ArrayIndexOutOfBoundsException - 如果 index为负数或不小于此 ParameterBlock对象的当前大小

      • getDoubleParameter

        public double getDoubleParameter​(int index)
        将参数返回为双精度的方便方法。 如果参数为null或不是Double则抛出异常。
        参数
        index - 要返回的参数的索引。
        结果
        指定索引处的参数为 double值。
        异常
        ClassCastException - 如果指定索引处的参数不是 Double
        NullPointerException - 如果指定索引处的参数为 null
        ArrayIndexOutOfBoundsException - 如果 index为负数或不小于此 ParameterBlock对象的当前大小

      • getParamClasses

        public Class<?>[] getParamClasses​()
        返回描述参数类型的Class对象数组。
        结果
        一个 Class对象的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderableImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image.renderable

Interface RenderableImage

  • 所有已知实现类：
    RenderableImageOp

    public interface RenderableImage
    RenderableImage是渲染无关的图像的通用接口（包含分辨率独立性的概念）。 也就是说，描述的图像并且具有应用于它们的操作，而与图像的任何特定渲染无关。 例如，RenderableImage可以独立于分辨率的条件旋转和裁剪。 然后，可以以各种特定的上下文（例如草稿预览，高质量的屏幕显示或打印机）以最佳方式呈现。

    RenderedImage通过createRendering（）方法从RenderableImage返回，该方法采用RenderContext。 RenderContext指定如何构建RenderedImage。 请注意，不可能直接从RenderableImage中提取像素。

    createDefaultRendering（）和createScaledRendering（）方法是在内部构造适当的RenderContext的便利方法。 所有的渲染方法都可以返回对之前生成的渲染的引用。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String HINTS_OBSERVED
      可以用于标识通过createRendering或createScaledRendering方法获得的RenderedImage上的属性的字符串常量。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      RenderedImage createDefaultRendering​()
      返回此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。
      RenderedImage createRendering​(RenderContext renderContext)
      创建一个RenderedImage，表示使用给定的RenderContext渲染此图像。
      RenderedImage createScaledRendering​(int w, int h, RenderingHints hints)
      以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。
      float getHeight​()
      获取用户坐标空间中的高度。
      float getMinX​()
      获取与渲染无关的图像数据的最小X坐标。
      float getMinY​()
      获取与渲染无关的图像数据的最小Y坐标。
      Object getProperty​(String name)
      从该图像的属性集获取属性。
      String[] getPropertyNames​()
      返回由getProperty识别的名称列表。
      Vector<RenderableImage> getSources​()
      返回作为此RenderableImage的图像数据的源的RenderableImages的向量。
      float getWidth​()
      获取用户坐标空间中的宽度。
      boolean isDynamic​()
      如果连续的渲染（即对createRendering（）或createScaledRendering（））的调用具有相同的参数，则返回true可能会产生不同的结果。

    • 字段详细信息

      • HINTS_OBSERVED

        static final String HINTS_OBSERVED
        可以用于标识通过createRendering或createScaledRendering方法获得的RenderedImage上的属性的字符串常量。 如果这样的属性存在，属性的值将是一个RenderingHints对象，指定在创建渲染时观察到哪些提示。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getSources

        Vector<RenderableImage> getSources​()
        返回作为此RenderableImage的图像数据的源的RenderableImages的向量。 请注意，此方法可能会返回一个空的向量，以指示该图像没有源，或者为空，以指示没有信息可用。
        结果
        一个（可能是空的）RenderableImages的Vector，或者是null。

      • getProperty

        Object getProperty​(String name)
        从该图像的属性集获取属性。 如果属性名称无法识别，将返回java.awt.Image.UndefinedProperty。
        参数
        name - 要获取的属性的名称，作为字符串。
        结果
        对属性Object的引用，或者值java.awt.Image.UndefinedProperty。

      • getPropertyNames

        String[] getPropertyNames​()
        返回由getProperty识别的名称列表。
        结果
        属性名称列表。

      • isDynamic

        boolean isDynamic​()
        如果连续的渲染（即对createRendering（）或createScaledRendering（））的调用具有相同的参数，则返回true可能会产生不同的结果。 该方法可用于确定现有渲染是否可被缓存和重用。 返回真实始终是安全的。
        结果
        true如果具有相同参数的连续渲染可能会产生不同的结果; 否则为false 。

      • getWidth

        float getWidth​()
        获取用户坐标空间中的宽度。 按照惯例，RenderableImage的通常宽度等于图像的宽高比（宽度除以高度）。
        结果
        用户坐标中图像的宽度。

      • getHeight

        float getHeight​()
        获取用户坐标空间中的高度。 按照惯例，RenderedImage的通常高度等于1.0F。
        结果
        用户坐标中图像的高度。

      • getMinX

        float getMinX​()
        获取与渲染无关的图像数据的最小X坐标。
        结果
        渲染无关图像数据的最小X坐标。

      • getMinY

        float getMinY​()
        获取与渲染无关的图像数据的最小Y坐标。
        结果
        渲染无关图像数据的最小Y坐标。

      • createScaledRendering

        RenderedImage createScaledRendering​(int w,
                                    int h,
                                    RenderingHints hints)
        以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。 RenderContext是通过适当的usr2dev变换和完整图像感兴趣的区域自动构建的。 所有的渲染提示来自于传递的提示。

        如果w == 0，将被视为等于Math.round（h *（getWidth（）/ getHeight（）））。 类似地，如果h == 0，将被视为等于Math.round（w *（getHeight（）/ getWidth（）））。 w或h中的一个必须为非零，否则将抛出IllegalArgumentException。

        创建的RenderedImage可能具有由字符串HINTS_OBSERVED标识的属性，以指示哪个RenderingHint用于创建映像。 另外，通过创建的RenderedImage上的getSources（）方法获得的任何RenderedImages可能具有这样的属性。

        参数
        w - 渲染图像的宽度，以像素为单位，或0。
        h - 渲染图像的高度（以像素为单位），或0。
        hints - 包含提示的RenderingHints对象。
        结果
        包含渲染数据的RenderedImage。

      • createDefaultRendering

        RenderedImage createDefaultRendering​()
        返回此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。 RenderContext是通过适当的usr2dev变换和完整图像感兴趣的区域自动构建的。 渲染提示是空的。 createDefaultRendering可以利用存储的渲染速度。
        结果
        包含渲染数据的RenderedImage。

      • createRendering

        RenderedImage createRendering​(RenderContext renderContext)
        创建一个RenderedImage，表示使用给定的RenderContext渲染此图像。 这是获得渲染RenderableImage的最通用的方法。

        创建的RenderedImage可能具有由字符串HINTS_OBSERVED标识的属性，以指示哪些RenderingHint（来自RenderContext）用于创建映像。 另外，通过创建的RenderedImage上的getSources（）方法获得的任何RenderedImages可能具有这样的属性。

        参数
        renderContext - 用于生成渲染的RenderContext。
        结果
        a RenderedImage containing the rendered data.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderableImageOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image.renderable

Class RenderableImageOp

  • java.lang.Object
    • java.awt.image.renderable.RenderableImageOp
  • All Implemented Interfaces:
    RenderableImage

    public class RenderableImageOp
extends Object
implements RenderableImage
    此类通过其关联的ContextualRenderedImageFactory实例的帮助来处理操作的可渲染方面。

    • Field Summary

      • Fields inherited from interface java.awt.image.renderable.RenderableImage

        HINTS_OBSERVED

    • 构造方法摘要

      构造方法
      Constructor 描述
      RenderableImageOp​(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
      构造一个RenderedImageOp给定一个ContextualRenderedImageFactory对象，以及一个包含RenderableImage源和其他参数的ParameterBlock。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      RenderedImage createDefaultRendering​()
      获取此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。
      RenderedImage createRendering​(RenderContext renderContext)
      创建一个RenderedImage，它表示根据给定的RenderContext呈现的RenderableImageOp（包括其Renderable源）。
      RenderedImage createScaledRendering​(int w, int h, RenderingHints hints)
      以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。
      float getHeight​()
      获取用户坐标空间中的高度。
      float getMinX​()
      获取与渲染无关的图像数据的最小X坐标。
      float getMinY​()
      获取与渲染无关的图像数据的最小Y坐标。
      ParameterBlock getParameterBlock​()
      返回对当前参数块的引用。
      Object getProperty​(String name)
      从该图像的属性集获取属性。
      String[] getPropertyNames​()
      返回由getProperty识别的名称列表。
      Vector<RenderableImage> getSources​()
      返回作为此RenderableImage的图像数据的源的RenderableImages的向量。
      float getWidth​()
      获取用户坐标空间中的宽度。
      boolean isDynamic​()
      如果连续的渲染（即对createRendering（）或createScaledRendering（））的调用具有相同的参数，则返回true可能会产生不同的结果。
      ParameterBlock setParameterBlock​(ParameterBlock paramBlock)
      更改操作的当前ParameterBlock，允许编辑图像渲染链。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RenderableImageOp

        public RenderableImageOp​(ContextualRenderedImageFactory CRIF,
                         ParameterBlock paramBlock)
        构造一个RenderedImageOp给定一个ContextualRenderedImageFactory对象，以及一个包含RenderableImage源和其他参数的ParameterBlock。 ParameterBlock引用的任何RenderedImage源将被忽略。
        参数
        CRIF - 一个ContextualRenderedImageFactory对象
        paramBlock - 包含此操作的源图像和运行操作所需的其他参数的ParameterBlock。

    • 方法详细信息

      • getSources

        public Vector<RenderableImage> getSources​()
        返回作为此RenderableImage的图像数据的源的RenderableImages的向量。 请注意，此方法可能会返回一个空的向量，以指示该图像没有源，或者为空，以指示没有信息可用。
        Specified by:
        getSources在接口 RenderableImage
        结果
        一个（可能是空的）RenderableImages的Vector，或者是null。

      • getProperty

        public Object getProperty​(String name)
        从该图像的属性集获取属性。 如果属性名称无法识别，将返回java.awt.Image.UndefinedProperty。
        Specified by:
        getProperty在接口 RenderableImage
        参数
        name - 要获取的属性的名称，作为字符串。
        结果
        对属性Object的引用，或者值java.awt.Image.UndefinedProperty。

      • getPropertyNames

        public String[] getPropertyNames​()
        返回由getProperty识别的名称列表。
        Specified by:
        getPropertyNames在接口 RenderableImage
        结果
        属性名称列表。

      • isDynamic

        public boolean isDynamic​()
        如果连续的渲染（即对createRendering（）或createScaledRendering（））的调用具有相同的参数，则返回true可能会产生不同的结果。 该方法可用于确定现有渲染是否可被缓存和重用。 CRIF的isDynamic方法将被调用。
        Specified by:
        isDynamic在接口 RenderableImage
        结果
        true如果具有相同参数的连续渲染可能会产生不同的结果; 否则为false 。

      • getWidth

        public float getWidth​()
        获取用户坐标空间中的宽度。 按照惯例，RenderableImage的通常宽度等于图像的宽高比（宽度除以高度）。
        Specified by:
        getWidth在接口 RenderableImage
        结果
        用户坐标中图像的宽度。

      • getHeight

        public float getHeight​()
        获取用户坐标空间中的高度。 按照惯例，RenderedImage的通常高度等于1.0F。
        Specified by:
        getHeight在接口 RenderableImage
        结果
        用户坐标中图像的高度。

      • getMinX

        public float getMinX​()
        获取与渲染无关的图像数据的最小X坐标。
        Specified by:
        getMinX在接口 RenderableImage
        结果
        渲染无关图像数据的最小X坐标。

      • getMinY

        public float getMinY​()
        获取与渲染无关的图像数据的最小Y坐标。
        Specified by:
        getMinY在接口 RenderableImage
        结果
        渲染无关图像数据的最小Y坐标。

      • setParameterBlock

        public ParameterBlock setParameterBlock​(ParameterBlock paramBlock)
        更改操作的当前ParameterBlock，允许编辑图像渲染链。 当从此RenderableImageOp或任何依赖的RenderableImageOp创建新的渲染时，这种更改的效果将是可见的。
        参数
        paramBlock - 新的ParameterBlock。
        结果
        旧的ParameterBlock。
        另请参见：
        getParameterBlock()

      • getParameterBlock

        public ParameterBlock getParameterBlock​()
        返回对当前参数块的引用。
        结果
        这 ParameterBlock的 RenderableImageOp 。
        另请参见：
        setParameterBlock(ParameterBlock)

      • createScaledRendering

        public RenderedImage createScaledRendering​(int w,
                                           int h,
                                           RenderingHints hints)
        以宽度w创建此图像的RenderedImage实例，以像素为单位创建高度h。 RenderContext是通过适当的usr2dev变换和完整图像感兴趣的区域自动构建的。 所有的渲染提示来自于传递的提示。

        如果w == 0，将被视为等于Math.round（h *（getWidth（）/ getHeight（）））。 类似地，如果h == 0，将被视为等于Math.round（w *（getHeight（）/ getWidth（）））。 w或h中的一个必须为非零，否则将抛出IllegalArgumentException。

        创建的RenderedImage可能具有由字符串HINTS_OBSERVED标识的属性，以指示哪个RenderingHint用于创建映像。 另外，通过创建的RenderedImage上的getSources（）方法获得的任何RenderedImages可能具有这样的属性。

        Specified by:
        createScaledRendering在接口 RenderableImage
        参数
        w - 渲染图像的宽度，以像素为单位，或0。
        h - 渲染图像的高度，以像素为单位，或0。
        hints - 包含提示的RenderingHints对象。
        结果
        包含渲染数据的RenderedImage。

      • createDefaultRendering

        public RenderedImage createDefaultRendering​()
        获取此图像的RenderedImage实例，其默认宽度和高度（以像素为单位）。 RenderContext是通过适当的usr2dev变换和完整图像感兴趣的区域自动构建的。 所有渲染提示来自传递的提示。此接口的实现者必须确保有一个定义的默认宽度和高度。
        Specified by:
        createDefaultRendering在接口 RenderableImage
        结果
        包含渲染数据的RenderedImage。

      • createRendering

        public RenderedImage createRendering​(RenderContext renderContext)
        创建一个RenderedImage，它表示根据给定的RenderContext呈现的RenderableImageOp（包括其Renderable源）。

        此方法支持链接Renderable或RenderedImage操作。 如果用于构造RenderableImageOp的ParameterBlock中的源是RenderableImages，则会遵循三个步骤：

        1. 在每个RenderableImage源的关联CRIF上调用mapRenderContext（）;
        2. 使用在步骤1中获得的向后映射的RenderContext，在每个RenderableImage源上调用createRendering（），导致每个源的呈现;
        3. ContextualRenderedImageFactory.create（）被调用一个新的ParameterBlock，它包含由createRendering（）调用创建的RenderableImageOp和RenderedImages的参数。

        如果用于构造RenderableImageOp的ParameterBlock的源Vector的元素是RenderedImage的实例，则使用原始的ParameterBlock立即调用CRIF.create（）方法。 这为递归提供了一个基础案例。

        创建的RenderedImage可能具有由字符串HINTS_OBSERVED标识的属性，以指示哪些RenderingHint（来自RenderContext）用于创建映像。 另外，通过创建的RenderedImage上的getSources（）方法获得的任何RenderedImages可能具有这样的属性。

        Specified by:
        createRendering在接口 RenderableImage
        参数
        renderContext - 用于执行渲染的RenderContext。
        结果
        包含所需输出图像的RenderedImage。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderableImageProducer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image.renderable

Class RenderableImageProducer

  • java.lang.Object
    • java.awt.image.renderable.RenderableImageProducer
  • All Implemented Interfaces:
    ImageProducer ， Runnable

    public class RenderableImageProducer
extends Object
implements ImageProducer, Runnable
    一个实现ImageProducer以允许异步生成RenderableImage的适配器类。 ImageConsumer的大小由RenderContext中的usr2dev变换的比例因子决定。 如果RenderContext为null，则使用RenderableImage的默认渲染。 该类实现了以一个分辨率在一个线程中生成图像的异步生产。 该类可以被子类化以实现将使用多个线程呈现图像的版本。 这些线程可以以逐个更好的质量或单个分辨率的图像的不同部分呈现相同的图像。

    • 构造方法摘要

      构造方法
      Constructor 描述
      RenderableImageProducer​(RenderableImage rdblImage, RenderContext rc)
      从RenderableImage和RenderContext构造一个新的RenderableImageProducer。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addConsumer​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
      boolean isConsumer​(ImageConsumer ic)
      确定ImageConsumer是否位于当前对该图像的数据感兴趣的消费者列表中。
      void removeConsumer​(ImageConsumer ic)
      从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
      void requestTopDownLeftRightResend​(ImageConsumer ic)
      请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
      void run​()
      这个类的runnable方法。
      void setRenderContext​(RenderContext rc)
      设置一个新的RenderContext用于下一个startProduction（）调用。
      void startProduction​(ImageConsumer ic)
      将ImageConsumer添加到对该图像的数据感兴趣的消费者列表中，并通过ImageConsumer界面立即开始传送图像数据。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RenderableImageProducer

        public RenderableImageProducer​(RenderableImage rdblImage,
                               RenderContext rc)
        从RenderableImage和RenderContext构造一个新的RenderableImageProducer。
        参数
        rdblImage - 要呈现的RenderableImage。
        rc - 用于生成像素的RenderContext。

    • 方法详细信息

      • setRenderContext

        public void setRenderContext​(RenderContext rc)
        设置一个新的RenderContext用于下一个startProduction（）调用。
        参数
        rc - 新的RenderContext。

      • addConsumer

        public void addConsumer​(ImageConsumer ic)
        将ImageConsumer添加到对该图像的数据感兴趣的用户列表中。
        Specified by:
        addConsumer在接口 ImageProducer
        参数
        ic - 要添加到兴趣列表的ImageConsumer。
        另请参见：
        ImageProducer.startProduction(java.awt.image.ImageConsumer)

      • isConsumer

        public boolean isConsumer​(ImageConsumer ic)
        确定ImageConsumer是否位于当前对该图像的数据感兴趣的消费者列表中。
        Specified by:
        isConsumer在接口 ImageProducer
        参数
        ic - 要检查的ImageConsumer。
        结果
        如果ImageConsumer在列表中，则为true; 否则为假。

      • removeConsumer

        public void removeConsumer​(ImageConsumer ic)
        从对该图像的数据感兴趣的消费者列表中删除一个ImageConsumer。
        Specified by:
        removeConsumer在接口 ImageProducer
        参数
        ic - 要删除的ImageConsumer。

      • startProduction

        public void startProduction​(ImageConsumer ic)
        将ImageConsumer添加到对该图像的数据感兴趣的消费者列表中，并通过ImageConsumer界面立即开始传送图像数据。
        Specified by:
        startProduction在接口 ImageProducer
        参数
        ic - 要添加到消费者列表中的ImageConsumer。
        另请参见：
        ImageProducer.addConsumer(java.awt.image.ImageConsumer)

      • requestTopDownLeftRightResend

        public void requestTopDownLeftRightResend​(ImageConsumer ic)
        请求给定的ImageConsumer具有从上到下的顺序递送多次的图像数据。
        Specified by:
        requestTopDownLeftRightResend在接口 ImageProducer
        参数
        ic - ImageConsumer请求重新发送。
        另请参见：
        ImageConsumer.setHints(int)

      • run

        public void run​()
        这个类的runnable方法。 这将使用当前的RenderableImage和RenderContext生成一个图像，并将其发送到当前注册到此类的所有ImageConsumer。
        Specified by:
        run在接口 Runnable
        另请参见：
        Thread.run()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image.renderable

Class RenderContext

  • java.lang.Object
    • java.awt.image.renderable.RenderContext
  • All Implemented Interfaces:
    Cloneable

    public class RenderContext
extends Object
implements Cloneable
    RenderContext封装了从RenderableImage生成特定渲染所需的信息。 它包含要以渲染独立的术语指定的要渲染的区域，要执行渲染的分辨率以及用于控制渲染过程的提示。

    用户创建RenderContexts并通过createRendering方法将其传递给RenderableImage。 RenderContexts的大部分方法并不意味着被应用程序直接使用，而是由它所传递的RenderableImage和操作符类。

    传入和传出此类的AffineTransform参数被克隆。 RenderingHints和Shape参数不一定是可克隆的，因此仅被引用复制。 更改由RenderContext实例使用的RenderingHints或Shape实例可能会有不良副作用。

    • 构造方法摘要

      构造方法
      Constructor 描述
      RenderContext​(AffineTransform usr2dev)
      构造具有给定变换的RenderContext。
      RenderContext​(AffineTransform usr2dev, RenderingHints hints)
      构造一个具有给定变换和渲染提示的RenderContext。
      RenderContext​(AffineTransform usr2dev, Shape aoi)
      构造一个具有给定变换和感兴趣区域的RenderContext。
      RenderContext​(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
      构造具有给定变换的RenderContext。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      Object clone​()
      制作RenderContext的副本。
      void concatenateTransform​(AffineTransform modTransform)
      通过附加另一个转换来修改当前的用户到设备的转换。
      void concetenateTransform​(AffineTransform modTransform)
      已过时。
      替换为concatenateTransform(AffineTransform) 。
      Shape getAreaOfInterest​()
      获取当前包含在RenderContext中的兴趣。
      RenderingHints getRenderingHints​()
      获取这个 RenderContext的渲染提示。
      AffineTransform getTransform​()
      获取当前的用户到设备的AffineTransform。
      void preConcatenateTransform​(AffineTransform modTransform)
      通过前置另一个变换来修改当前的用户到设备的变换。
      void preConcetenateTransform​(AffineTransform modTransform)
      已过时。
      替换为preConcatenateTransform(AffineTransform) 。
      void setAreaOfInterest​(Shape newAoi)
      设置当前感兴趣的区域。
      void setRenderingHints​(RenderingHints hints)
      设置这个 RenderContext的渲染提示。
      void setTransform​(AffineTransform newTransform)
      将RenderContext中包含的当前用户到设备的AffineTransform设置为给定的转换。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RenderContext

        public RenderContext​(AffineTransform usr2dev,
                     Shape aoi,
                     RenderingHints hints)
        构造具有给定变换的RenderContext。 感兴趣区域作为Shape提供，渲染提示作为RenderingHints对象提供。
        参数
        usr2dev - AffineTransform。
        aoi - 表示感兴趣区域的形状。
        hints - 包含渲染提示的RenderingHints对象。

      • RenderContext

        public RenderContext​(AffineTransform usr2dev)
        构造具有给定变换的RenderContext。 感兴趣的区域被认为是整个可渲染区域。 没有使用渲染提示。
        参数
        usr2dev - AffineTransform。

      • RenderContext

        public RenderContext​(AffineTransform usr2dev,
                     RenderingHints hints)
        构造一个具有给定变换和渲染提示的RenderContext。 感兴趣的区域被认为是整个可渲染区域。
        参数
        usr2dev - AffineTransform。
        hints - 包含渲染提示的RenderingHints对象。

      • RenderContext

        public RenderContext​(AffineTransform usr2dev,
                     Shape aoi)
        构造一个具有给定变换和感兴趣区域的RenderContext。 感兴趣的区域作为形状提供。 没有使用渲染提示。
        参数
        usr2dev - AffineTransform。
        aoi - 表示感兴趣区域的形状。

    • 方法详细信息

      • getRenderingHints

        public RenderingHints getRenderingHints​()
        获取这个 RenderContext的渲染提示。
        结果
        一个 RenderingHints对象，表示这个 RenderContext的渲染提示。
        另请参见：
        setRenderingHints(RenderingHints)

      • setRenderingHints

        public void setRenderingHints​(RenderingHints hints)
        设置这个 RenderContext的渲染提示。
        参数
        hints - 一个 RenderingHints对象，表示要分配给此 RenderContext的呈现提示。
        另请参见：
        getRenderingHints()

      • setTransform

        public void setTransform​(AffineTransform newTransform)
        将RenderContext中包含的当前用户到设备的AffineTransform设置为给定的转换。
        参数
        newTransform - 新的AffineTransform。
        另请参见：
        getTransform()

      • preConcatenateTransform

        public void preConcatenateTransform​(AffineTransform modTransform)
        通过前置另一个变换来修改当前的用户到设备的变换。 在矩阵表示法中，操作是：
          [this] = [modTransform] x [this]
        参数
        modTransform - 将AffineTransform添加到当前的usr2dev转换中。
        从以下版本开始：
        1.3

      • preConcetenateTransform

        @Deprecated
public void preConcetenateTransform​(AffineTransform modTransform)
        已过时。 替换为preConcatenateTransform(AffineTransform) 。
        通过前置另一个变换来修改当前的用户到设备的变换。 在矩阵表示法中，操作是：
          [this] = [modTransform] x [this]
        该方法与preConcatenateTransform方法相同。 这是为了向后兼容以前的版本，拼写方法名称。
        参数
        modTransform - 将AffineTransform添加到当前的usr2dev转换中。

      • concatenateTransform

        public void concatenateTransform​(AffineTransform modTransform)
        通过附加另一个转换来修改当前的用户到设备的转换。 在矩阵表示法中，操作是：
          [this] = [this] x [modTransform]
        参数
        modTransform - AffineTransform附加到当前的usr2dev转换。
        从以下版本开始：
        1.3

      • concetenateTransform

        @Deprecated
public void concetenateTransform​(AffineTransform modTransform)
        已过时。 替换为concatenateTransform(AffineTransform) 。
        通过附加另一个转换来修改当前的用户到设备的转换。 在矩阵表示法中，操作是：
          [this] = [this] x [modTransform]
        此方法与concatenateTransform方法相同。 这是为了向后兼容以前的版本，拼写方法名称。
        参数
        modTransform - AffineTransform附加到当前的usr2dev转换。

      • getTransform

        public AffineTransform getTransform​()
        获取当前的用户到设备的AffineTransform。
        结果
        引用目前的AffineTransform。
        另请参见：
        setTransform(AffineTransform)

      • setAreaOfInterest

        public void setAreaOfInterest​(Shape newAoi)
        设置当前感兴趣的区域。 旧区被丢弃。
        参数
        newAoi - 感兴趣的新领域
        另请参见：
        getAreaOfInterest()

      • getAreaOfInterest

        public Shape getAreaOfInterest​()
        获取当前包含在RenderContext中的兴趣。
        结果
        引用RenderContext的感兴趣区域，如果没有指定，则返回null。
        另请参见：
        setAreaOfInterest(Shape)

      • clone

        public Object clone​()
        制作RenderContext的副本。 感兴趣的区域通过引用复制。 usr2dev AffineTransform和提示是克隆的，而感兴趣的区域是通过引用复制的。
        重写：
        clone在 Object
        结果
        新克隆的RenderContext。
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RenderedImageFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.image.renderable

Interface RenderedImageFactory

  • All Known Subinterfaces:
    ContextualRenderedImageFactory

    public interface RenderedImageFactory
    RenderedImageFactory接口（通常缩写为RIF）旨在由希望充当工厂来生成不同渲染的类实现，例如通过在一组源上执行一系列BufferedImageOps，具体取决于特定的一组参数，属性，并提供提示。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      RenderedImage create​(ParameterBlock paramBlock, RenderingHints hints)
      创建表示给定ParameterBlock和RenderingHints的成像操作（或操作链）的结果的RenderedImage。

    • 方法详细信息

      • create

        RenderedImage create​(ParameterBlock paramBlock,
                     RenderingHints hints)
        创建表示给定ParameterBlock和RenderingHints的成像操作（或操作链）的结果的RenderedImage。 必要时，RIF还可以查询ParameterBlock引用的任何源图像的尺寸，SampleModel，属性等。

        如果RenderedImageFactory不能为给定的源图像和参数集生成输出，则create（）方法可以返回null。 例如，如果RenderedImageFactory仅能够对单带图像数据执行3x3卷积，并且源图像具有多个频带或卷积内核为5x5，则应返回null。

        应注意提示，但可以忽略。 创建的RenderedImage可能具有由字符串HINTS_OBSERVED标识的属性，以指示哪个RenderingHint用于创建映像。 另外，通过创建的RenderedImage上的getSources（）方法获得的任何RenderedImages可能具有这样的属性。

        参数
        paramBlock - 一个包含要创建的RenderedImage的源和参数的ParameterBlock。
        hints - 包含提示的RenderingHints对象。
        结果
        A RenderedImage containing the desired output.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.image.renderable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.image.renderable

  • Packages that use java.awt.image.renderable
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
  • Classes in java.awt.image.renderable used by java.awt
    Class 描述
    RenderableImage
    RenderableImage是渲染无关的图像的通用接口（包含分辨率独立性的概念）。
  • Classes in java.awt.image.renderable used by java.awt.image.renderable
    Class 描述
    ContextualRenderedImageFactory
    ContextualRenderedImageFactory为RenderableImageOp的实例之间的功能提供了一个接口。
    ParameterBlock
    A ParameterBlock封装了所有关于RenderableImageOp或处理图像的其他类所需的源和参数（Objects）的信息。
    RenderableImage
    RenderableImage是渲染无关的图像的通用接口（包含分辨率独立性的概念）。
    RenderContext
    RenderContext封装了从RenderableImage生成特定渲染所需的信息。
    RenderedImageFactory
    RenderedImageFactory接口（通常缩写为RIF）旨在由希望充当工厂来生成不同渲染的类实现，例如通过在一组源上执行一系列BufferedImageOps，具体取决于特定的一组参数，属性，并提供提示。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.renderable.ParameterBlock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.renderable.ParameterBlock

  • Packages that use ParameterBlock
    软件包 描述
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of ParameterBlock in java.awt.image.renderable

      Methods in java.awt.image.renderable that return ParameterBlock
      Modifier and Type 方法 描述
      ParameterBlock ParameterBlock.add​(byte b)
      将一个字节添加到参数列表中。
      ParameterBlock ParameterBlock.add​(char c)
      在参数列表中添加一个字符。
      ParameterBlock ParameterBlock.add​(double d)
      向参数列表中添加一个Double。
      ParameterBlock ParameterBlock.add​(float f)
      将浮点数添加到参数列表中。
      ParameterBlock ParameterBlock.add​(int i)
      将一个整数添加到参数列表中。
      ParameterBlock ParameterBlock.add​(long l)
      在参数列表中添加一个Long。
      ParameterBlock ParameterBlock.add​(short s)
      在参数列表中添加一个Short。
      ParameterBlock ParameterBlock.add​(Object obj)
      将对象添加到参数列表中。
      ParameterBlock ParameterBlock.addSource​(Object source)
      将图像添加到源列表的末尾。
      ParameterBlock RenderableImageOp.getParameterBlock​()
      返回对当前参数块的引用。
      ParameterBlock ParameterBlock.set​(byte b, int index)
      使用字节替换参数列表中的对象。
      ParameterBlock ParameterBlock.set​(char c, int index)
      用Character替换参数列表中的Object。
      ParameterBlock ParameterBlock.set​(double d, int index)
      用Double替换参数列表中的对象。
      ParameterBlock ParameterBlock.set​(float f, int index)
      用Float替换参数列表中的对象。
      ParameterBlock ParameterBlock.set​(int i, int index)
      用Integer替换参数列表中的Object。
      ParameterBlock ParameterBlock.set​(long l, int index)
      用Long替换参数列表中的对象。
      ParameterBlock ParameterBlock.set​(short s, int index)
      用Short替换参数列表中的对象。
      ParameterBlock ParameterBlock.set​(Object obj, int index)
      替换参数列表中的对象。
      ParameterBlock RenderableImageOp.setParameterBlock​(ParameterBlock paramBlock)
      更改操作的当前ParameterBlock，允许编辑图像渲染链。
      ParameterBlock ParameterBlock.setSource​(Object source, int index)
      用源代替源列表中的条目。
      Methods in java.awt.image.renderable with parameters of type ParameterBlock
      Modifier and Type 方法 描述
      RenderedImage ContextualRenderedImageFactory.create​(RenderContext renderContext, ParameterBlock paramBlock)
      给定一个渲染，给定一个RenderContext和一个ParameterBlock，其中包含操作的源和参数。
      RenderedImage RenderedImageFactory.create​(ParameterBlock paramBlock, RenderingHints hints)
      创建表示给定ParameterBlock和RenderingHints的成像操作（或操作链）的结果的RenderedImage。
      Rectangle2D ContextualRenderedImageFactory.getBounds2D​(ParameterBlock paramBlock)
      在独立于渲染的空间中，返回在给定的一组源上执行的操作输出的边界框。
      Object ContextualRenderedImageFactory.getProperty​(ParameterBlock paramBlock, String name)
      获取由name参数指定的属性的适当实例。
      RenderContext ContextualRenderedImageFactory.mapRenderContext​(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
      将操作的输出RenderContext映射到每个操作源的RenderContext中。
      ParameterBlock RenderableImageOp.setParameterBlock​(ParameterBlock paramBlock)
      更改操作的当前ParameterBlock，允许编辑图像渲染链。
      Constructors in java.awt.image.renderable with parameters of type ParameterBlock
      Constructor 描述
      RenderableImageOp​(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
      构造一个RenderedImageOp给定一个ContextualRenderedImageFactory对象，以及一个包含RenderableImage源和其他参数的ParameterBlock。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.renderable.RenderableImageOp (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.renderable.RenderableImageOp

No usage of java.awt.image.renderable.RenderableImageOp
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.renderable.RenderableImageProducer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.renderable.RenderableImageProducer

No usage of java.awt.image.renderable.RenderableImageProducer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.image.renderable.RenderContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.image.renderable.RenderContext

  • Packages that use RenderContext
    软件包 描述
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of RenderContext in java.awt.image.renderable

      Methods in java.awt.image.renderable that return RenderContext
      Modifier and Type 方法 描述
      RenderContext ContextualRenderedImageFactory.mapRenderContext​(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
      将操作的输出RenderContext映射到每个操作源的RenderContext中。
      Methods in java.awt.image.renderable with parameters of type RenderContext
      Modifier and Type 方法 描述
      RenderedImage ContextualRenderedImageFactory.create​(RenderContext renderContext, ParameterBlock paramBlock)
      给定一个渲染，给定一个RenderContext和一个ParameterBlock，其中包含操作的源和参数。
      RenderedImage RenderableImage.createRendering​(RenderContext renderContext)
      创建一个RenderedImage，表示使用给定的RenderContext渲染此图像。
      RenderedImage RenderableImageOp.createRendering​(RenderContext renderContext)
      创建一个RenderedImage，它表示根据给定的RenderContext呈现的RenderableImageOp（包括其Renderable源）。
      RenderContext ContextualRenderedImageFactory.mapRenderContext​(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
      将操作的输出RenderContext映射到每个操作源的RenderContext中。
      void RenderableImageProducer.setRenderContext​(RenderContext rc)
      设置一个新的RenderContext用于下一个startProduction（）调用。
      Constructors in java.awt.image.renderable with parameters of type RenderContext
      Constructor 描述
      RenderableImageProducer​(RenderableImage rdblImage, RenderContext rc)
      从RenderableImage和RenderContext构造一个新的RenderableImageProducer。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.renderable.ContextualRenderedImageFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.renderable.ContextualRenderedImageFactory

  • Packages that use ContextualRenderedImageFactory
    软件包 描述
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of ContextualRenderedImageFactory in java.awt.image.renderable

      Constructors in java.awt.image.renderable with parameters of type ContextualRenderedImageFactory
      Constructor 描述
      RenderableImageOp​(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
      构造一个RenderedImageOp给定一个ContextualRenderedImageFactory对象，以及一个包含RenderableImage源和其他参数的ParameterBlock。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.renderable.RenderableImage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.renderable.RenderableImage

  • Packages that use RenderableImage
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of RenderableImage in java.awt

      Methods in java.awt with parameters of type RenderableImage
      Modifier and Type 方法 描述
      abstract void Graphics2D.drawRenderableImage​(RenderableImage img, AffineTransform xform)
      渲染一个RenderableImage ，在绘制之前将图像空间的变换应用到用户空间。

    • Uses of RenderableImage in java.awt.image.renderable

      Classes in java.awt.image.renderable that implement RenderableImage
      Modifier and Type Class 描述
      class  RenderableImageOp
      此类通过其关联的ContextualRenderedImageFactory实例的帮助来处理操作的可渲染方面。
      Methods in java.awt.image.renderable that return RenderableImage
      Modifier and Type 方法 描述
      RenderableImage ParameterBlock.getRenderableSource​(int index)
      作为RenderableImage返回一个源。
      Methods in java.awt.image.renderable that return types with arguments of type RenderableImage
      Modifier and Type 方法 描述
      Vector<RenderableImage> RenderableImage.getSources​()
      返回作为此RenderableImage的图像数据的源的RenderableImages的向量。
      Vector<RenderableImage> RenderableImageOp.getSources​()
      返回作为此RenderableImage的图像数据的源的RenderableImages的向量。
      Methods in java.awt.image.renderable with parameters of type RenderableImage
      Modifier and Type 方法 描述
      RenderContext ContextualRenderedImageFactory.mapRenderContext​(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
      将操作的输出RenderContext映射到每个操作源的RenderContext中。
      Constructors in java.awt.image.renderable with parameters of type RenderableImage
      Constructor 描述
      RenderableImageProducer​(RenderableImage rdblImage, RenderContext rc)
      从RenderableImage和RenderContext构造一个新的RenderableImageProducer。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.image.renderable.RenderedImageFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.image.renderable.RenderedImageFactory

  • Packages that use RenderedImageFactory
    软件包 描述
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。

    • Uses of RenderedImageFactory in java.awt.image.renderable

      Subinterfaces of RenderedImageFactory in java.awt.image.renderable
      Modifier and Type 接口 描述
      interface  ContextualRenderedImageFactory
      ContextualRenderedImageFactory为RenderableImageOp的实例之间的功能提供了一个接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Book (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Class Book

  • java.lang.Object
    • java.awt.print.Book
  • All Implemented Interfaces:
    Pageable

    public class Book
extends Object
implements Pageable
    Book类提供了一个文档的表示，其中页面可能具有不同的页面格式和页面绘图。 该类使用Pageable接口与PrinterJob进行交互。
    另请参见：
    Pageable ， PrinterJob

    • Field Summary

      • Fields inherited from interface java.awt.print.Pageable

        UNKNOWN_NUMBER_OF_PAGES

    • 构造方法摘要

      构造方法
      Constructor 描述
      Book​()
      创建一个新的，空的 Book 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void append​(Printable painter, PageFormat page)
      追加一页到这个 Book 。
      void append​(Printable painter, PageFormat page, int numPages)
      追加 numPages页到这个 Book 。
      int getNumberOfPages​()
      返回此 Book的页数。
      PageFormat getPageFormat​(int pageIndex)
      返回由pageIndex指定的页面中的pageIndex 。
      Printable getPrintable​(int pageIndex)
      返回负责呈现由pageIndex指定的页面的Printable实例。
      void setPage​(int pageIndex, Printable painter, PageFormat page)
      为指定的页码设置 PageFormat和 Painter 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Book

        public Book​()
        创建一个新的，空的 Book 。

    • 方法详细信息

      • getNumberOfPages

        public int getNumberOfPages​()
        返回此 Book的页数。
        Specified by:
        getNumberOfPages在接口 Pageable
        结果
        这个 Book包含的页面数。

      • getPageFormat

        public PageFormat getPageFormat​(int pageIndex)
                         throws IndexOutOfBoundsException
        返回pageIndex指定页面的pageIndex 。
        Specified by:
        getPageFormat在接口 Pageable
        参数
        pageIndex - 正在请求其 PageFormat的页面的零 PageFormat
        结果
        描述页面的大小和方向的 PageFormat 。
        异常
        IndexOutOfBoundsException - 如果 Pageable不包含请求的页面

      • getPrintable

        public Printable getPrintable​(int pageIndex)
                       throws IndexOutOfBoundsException
        返回Printable实例，负责渲染由pageIndex指定的pageIndex 。
        Specified by:
        getPrintable在接口 Pageable
        参数
        pageIndex - 正在请求其 Printable的页面的零 Printable
        结果
        该页面呈现 Printable 。
        异常
        IndexOutOfBoundsException - 如果 Pageable不包含请求的页面

      • setPage

        public void setPage​(int pageIndex,
                    Printable painter,
                    PageFormat page)
             throws IndexOutOfBoundsException
        为指定的页码设置 PageFormat和 Painter 。
        参数
        pageIndex - 其画家和格式被更改的页面的零 pageIndex引
        painter - 呈现页面的 Printable实例
        page - 页面的大小和方向
        异常
        IndexOutOfBoundsException - 如果指定的页面尚未在此 Book
        NullPointerException - 如果 painter或 page参数是 null

      • append

        public void append​(Printable painter,
                   PageFormat page)
        追加一页到这个 Book 。
        参数
        painter - 呈现页面的 Printable实例
        page - 页面的大小和方向
        异常
        NullPointerException - 如果 painter或 page参数是 null

      • append

        public void append​(Printable painter,
                   PageFormat page,
                   int numPages)
        追加numPages页到这个Book 。 每个页面都与page相关联。
        参数
        painter - 呈现页面的 Printable实例
        page - 页面的大小和方向
        numPages - 要添加到此 Book 。
        异常
        NullPointerException - 如果 painter或 page参数是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.awt.print (Java SE 9 & JDK 9 )

java.awt.print

Interfaces

  • Pageable
  • Printable
  • PrinterGraphics

Classes

  • Book
  • PageFormat
  • Paper
  • PrinterJob

Exceptions

  • PrinterAbortException
  • PrinterException
  • PrinterIOException


java.awt.print (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.awt.print

提供通用打印API的类和接口。 API包括以下功能：
  • 指定文档类型的能力
  • 控制页面设置和页面格式的机制
  • 管理作业控制对话的能力
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    Pageable
    Pageable实现代表一组要打印的页面。
    Printable
    Printable接口由当前页面画家的 print方法实现，该方法由打印系统调用以呈现页面。
    PrinterGraphics
    PrinterGraphics接口由Graphics对象实现，传递给Printable对象以呈现页面。
  • 类摘要
    Class 描述
    Book
    Book课程提供了一个文档的表示，其中页面可能具有不同的页面格式和页面绘画。
    PageFormat
    PageFormat类描述了要打印的页面的大小和方向。
    Paper
    Paper课程描述了一张纸的物理特性。
    PrinterJob
    PrinterJob类是控制打印的主要类。
  • 异常摘要
    异常 描述
    PrinterAbortException
    所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。
    PrinterException
    PrinterException类及其子类用于指示在打印系统中发生异常情况。
    PrinterIOException
    该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.awt.print Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.awt.print

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.print.Book (implements java.awt.print.Pageable)
    • java.awt.print.PageFormat (implements java.lang.Cloneable)
    • java.awt.print.Paper (implements java.lang.Cloneable)
    • java.awt.print.PrinterJob
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.awt.print.PrinterException
          • java.awt.print.PrinterAbortException
          • java.awt.print.PrinterIOException

Interface Hierarchy

  • java.awt.print.Pageable
  • java.awt.print.Printable
  • java.awt.print.PrinterGraphics
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Pageable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Interface Pageable

  • 所有已知实现类：
    Book

    public interface Pageable
    Pageable实现代表一组要打印的页面。 Pageable对象返回集合中的总页数以及指定页面的PageFormat和Printable 。
    另请参见：
    PageFormat ， Printable

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int UNKNOWN_NUMBER_OF_PAGES
      如果 Pageable实现不知道其集合中的页数，则该常量将从 getNumberOfPages方法返回。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getNumberOfPages​()
      返回集合中的页数。
      PageFormat getPageFormat​(int pageIndex)
      返回 PageFormat指定页面的 pageIndex 。
      Printable getPrintable​(int pageIndex)
      返回 Printable实例，负责渲染由 pageIndex指定的 pageIndex 。

    • 字段详细信息

      • UNKNOWN_NUMBER_OF_PAGES

        @Native
static final int UNKNOWN_NUMBER_OF_PAGES
        如果一个 Pageable实现不知道其集合中的页数，则该常量将从 getNumberOfPages方法返回。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getNumberOfPages

        int getNumberOfPages​()
        返回集合中的页数。 要启用高级打印功能，建议Pageable实现返回真实的页数，而不是UNKNOWN_NUMBER_OF_PAGES常量。
        结果
        这个 Pageable的页数。

      • getPageFormat

        PageFormat getPageFormat​(int pageIndex)
                  throws IndexOutOfBoundsException
        返回 PageFormat指定页面的 pageIndex 。
        参数
        pageIndex - 正在请求 PageFormat的页面的零 PageFormat
        结果
        PageFormat描述了大小和方向。
        异常
        IndexOutOfBoundsException - 如果 Pageable不包含请求的页面。

      • getPrintable

        Printable getPrintable​(int pageIndex)
                throws IndexOutOfBoundsException
        返回 Printable实例，负责渲染由 pageIndex指定的 pageIndex 。
        参数
        pageIndex - 正在请求 Printable的页面的零 Printable
        结果
        Printable呈现页面。
        异常
        IndexOutOfBoundsException - if the Pageable does not contain the requested page.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PageFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Class PageFormat

  • java.lang.Object
    • java.awt.print.PageFormat
  • All Implemented Interfaces:
    Cloneable

    public class PageFormat
extends Object
implements Cloneable
    PageFormat类描述了要打印的页面的大小和方向。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int LANDSCAPE
      原点在纸张的左下角，x从底部到顶部运行，y从左到右运行。
      static int PORTRAIT
      原点位于纸张的左上角，x向右移动，y向下移动纸张。
      static int REVERSE_LANDSCAPE
      原点在纸张的右上角，x从上到下运行，y从右到左运行。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PageFormat​()
      创建一个默认的，面向肖像的 PageFormat 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      制作 PageFormat的副本，内容与此 PageFormat相同。
      double getHeight​()
      返回页面的高1/7英寸的高度。
      double getImageableHeight​()
      返回页面可成像区域的高度，以1/72英寸为单位。
      double getImageableWidth​()
      返回页面可成像区域的宽度（以1/72英寸为单位）。
      double getImageableX​()
      返回与该 PageFormat相关联的 Paper对象的可成像区域的左上角的x坐标。
      double getImageableY​()
      返回与该 PageFormat相关联的 Paper对象的可成像区域的左上角的y坐标。
      double[] getMatrix​()
      返回一个转换矩阵，将用户空间渲染转换为页面的请求方向。
      int getOrientation​()
      返回这个 PageFormat的方向。
      Paper getPaper​()
      返回与此PageFormat相关联的Paper对象的副本。
      double getWidth​()
      返回页面宽度的1/7英寸。
      void setOrientation​(int orientation)
      设置页面方向。
      void setPaper​(Paper paper)
      设置 Paper对象为这个 PageFormat 。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LANDSCAPE

        @Native
public static final int LANDSCAPE
        原点在纸张的左下角，x从底部到顶部运行，y从左到右运行。 请注意，这不是Macintosh的风景，而是Window和PostScript的风景。
        另请参见：
        Constant Field Values

      • PORTRAIT

        @Native
public static final int PORTRAIT
        原点位于纸张的左上角，x向右移动，y向下移动纸张。
        另请参见：
        Constant Field Values

      • REVERSE_LANDSCAPE

        @Native
public static final int REVERSE_LANDSCAPE
        原点在纸张的右上角，x从上到下运行，y从右到左运行。 请注意，这是Macintosh景观。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • PageFormat

        public PageFormat​()
        创建一个默认的，面向肖像的 PageFormat 。

    • 方法详细信息

      • clone

        public Object clone​()
        制作 PageFormat的副本，内容与此 PageFormat相同。
        重写：
        clone在 Object
        结果
        这个 PageFormat的副本。
        另请参见：
        Cloneable

      • getWidth

        public double getWidth​()
        返回页面宽度的1/7英寸。 该方法在确定宽度时考虑到页面的方向。
        结果
        页面的宽度。

      • getHeight

        public double getHeight​()
        返回页面的高1/7英寸的高度。 该方法在确定高度时考虑到页面的方向。
        结果
        页面的高度。

      • getImageableX

        public double getImageableX​()
        返回与此PageFormat相关联的Paper对象的可成像区域的左上角的x坐标。 该方法考虑到页面的方向。
        结果
        与该 PageFormat相关联的 Paper对象的可成像区域的左上角的x坐标。

      • getImageableY

        public double getImageableY​()
        返回与该PageFormat相关联的Paper对象的可成像区域的左上角的y坐标。 该方法考虑到页面的方向。
        结果
        与该 PageFormat相关联的 Paper对象的可成像区域的左上角的y坐标。

      • getImageableWidth

        public double getImageableWidth​()
        返回页面可成像区域的宽度（以1/72英寸为单位）。 该方法考虑到页面的方向。
        结果
        页面的宽度。

      • getImageableHeight

        public double getImageableHeight​()
        返回页面可成像区域的高度，以1/72英寸为单位。 该方法考虑到页面的方向。
        结果
        页面的高度。

      • getPaper

        public Paper getPaper​()
        返回与此PageFormat相关联的Paper对象的副本。 对此方法返回的Paper对象所做的更改不会影响此PageFormat的Paper对象。 要更新Paper这个对象PageFormat ，创建一个新的Paper对象，并将其设置到这个PageFormat使用setPaper(Paper)方法。
        结果
        与该 PageFormat相关联的 Paper对象的副本。
        另请参见：
        setPaper(java.awt.print.Paper)

      • setPaper

        public void setPaper​(Paper paper)
        设置 Paper对象为这个 PageFormat 。
        参数
        paper -在 Paper对象，该设置 Paper对象为这个 PageFormat 。
        异常
        NullPointerException - 作为参数传递一个空纸实例。
        另请参见：
        getPaper()

      • setOrientation

        public void setOrientation​(int orientation)
                    throws IllegalArgumentException
        设置页面方向。 orientation必须是常数之一：PORTRAIT，LANDSCAPE或REVERSE_LANDSCAPE。
        参数
        orientation - 页面的新方向
        异常
        IllegalArgumentException - 如果请求未知方向
        另请参见：
        getOrientation()

      • getOrientation

        public int getOrientation​()
        返回这个 PageFormat的方向。
        结果
        这个 PageFormat对象的方向。
        另请参见：
        setOrientation(int)

      • getMatrix

        public double[] getMatrix​()
        返回一个转换矩阵，将用户空间渲染转换为页面的请求方向。 这些值以AffineTransform构造函数所要求的形式作为{m00，m10，m01，m11，m02，m12}放置到数组中。
        结果
        用于将用户空间呈现转换为页面方向的矩阵。
        另请参见：
        AffineTransform
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Paper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Class Paper

  • java.lang.Object
    • java.awt.print.Paper
  • All Implemented Interfaces:
    Cloneable

    public class Paper
extends Object
implements Cloneable
    Paper类描述了一张纸的物理特性。

    创建Paper对象时，应用程序有责任确保纸张尺寸和可成像区域兼容。 例如，如果纸张尺寸从11 x 17更改为8.5 x 11，则应用程序可能需要减少可成像区域，以便打印的任何内容符合页面。

    另请参见：
    setSize(double, double) ， setImageableArea(double, double, double, double)

    • 构造方法摘要

      构造方法
      Constructor 描述
      Paper​()
      创建一个字母大小的纸，一英寸的边距。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建一个 Paper的副本，内容与这个 Paper相同。
      double getHeight​()
      返回页面的高度为1/72英寸。
      double getImageableHeight​()
      返回此 Paper对象的可成像区域的高度。
      double getImageableWidth​()
      返回此 Paper对象的可成像区域的宽度。
      double getImageableX​()
      返回此 Paper对象的可成像区域的左上角的x坐标。
      double getImageableY​()
      返回此 Paper对象的可成像区域的左上角的y坐标。
      double getWidth​()
      返回1 / 72nds英寸的页面宽度。
      void setImageableArea​(double x, double y, double width, double height)
      设置 Paper的可成像区域。
      void setSize​(double width, double height)
      设置此 Paper对象的宽度和高度，该对象表示发生打印的页面的属性。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Paper

        public Paper​()
        创建一个字母大小的纸，一英寸的边距。

    • 方法详细信息

      • clone

        public Object clone​()
        创建一个 Paper的副本，内容与这个 Paper相同。
        重写：
        clone在 Object
        结果
        这张 Paper的副本。
        另请参见：
        Cloneable

      • getHeight

        public double getHeight​()
        返回页面的高度为1/72英寸。
        结果
        该页面描述的页面高度为 Paper 。

      • setSize

        public void setSize​(double width,
                    double height)
        设置此Paper对象的宽度和高度，该对象表示发生打印的页面的属性。 尺寸以1/72英寸提供。
        参数
        width - 设置这个 Paper对象宽度的值
        height - 设置这个 Paper对象的高度的值

      • getWidth

        public double getWidth​()
        返回1 / 72nds英寸的页面宽度。
        结果
        该页面的宽度由此 Paper描述。

      • setImageableArea

        public void setImageableArea​(double x,
                             double y,
                             double width,
                             double height)
        设置Paper的可成像区域。 可成像区域是打印发生在页面上的区域。
        参数
        x - 要设置此可 Paper区域的左上角的X坐标 Paper
        y - 要设置此可成像区域左上角的Y坐标 Paper
        width - 设置此可成像区域的宽度的值 Paper
        height - 设置 Paper可成像区域的高度的 Paper

      • getImageableX

        public double getImageableX​()
        返回此 Paper对象的可成像区域的左上角的x坐标。
        结果
        可成像区域的x坐标。

      • getImageableY

        public double getImageableY​()
        返回此 Paper对象的可成像区域的左上角的y坐标。
        结果
        可成像区域的y坐标。

      • getImageableWidth

        public double getImageableWidth​()
        返回此 Paper对象的可成像区域的宽度。
        结果
        可成像区域的宽度。

      • getImageableHeight

        public double getImageableHeight​()
        返回此 Paper对象的可成像区域的高度。
        结果
        可成像区域的高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Printable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Interface Printable

  • public interface Printable
    Printable接口由当前页面画家的print方法实现，由打印系统调用以呈现页面。 当构建一个Pageable时 ，实现这个接口的PageFormat实例和实例被用来描述每个页面。 调用实现Printable的实例来打印页面的图形。

    A Printable(..)可以设置在PrinterJob 。 当客户端随后通过调用PrinterJob.print(..)控制启动打印

    被传送到打印系统，直到所有页面都被打印出来。 它可以通过调用Printable.print(..)直到打印出文档中的所有页面。 在使用Printable界面时，只要打印系统要求，打印就会对页面的内容进行成像。

    对于Printable.print(..)的参数包括PageFormat ，其描述了用于计算适合该页面的内容所需的页面的可打印区域以及指定所请求页面的基于零的打印流索引的页面索引。

    要正确打印行为，应遵守以下几点：

    • 打印系统可以多次请求页面索引。 每次都会提供相同的PageFormat参数。
    • 打印系统将调用Printable.print(..) ，页面索引单调增加，尽管如上所述， Printable应该期望多次调用页面索引，并且页面索引可能会被跳过，当页面范围由客户端指定时，或者由用户通过打印对话框。
    • 如果请求了文档的多个整理副本，并且打印机本来不能支持这一点，则文档可以被多次成像。 打印将从最低的打印流页面索引页面开始每个副本。
    • 除了对整个文档进行多次整理副本重新成像之外，增加的页面索引顺序意味着当客户端需要计算分页位置时请求页面N时，可以安全地丢弃与页面N相关的任何状态，以及对于第N页进行当前流程。“状态”通常只是文档中与页面开头对应的计算位置。
    • 当打印系统调用时， Printable必须检查并兑现提供的PageFormat参数以及页面索引。 要绘制的页面的格式由提供的PageFormat指定。 因此，页面的大小，方向和可成像区域已经确定，渲染必须在该可成像区域内。 这是纠正打印行为的关键，它意味着客户端有责任跟踪指定页面上所属的内容。
    • 当Printable从客户端提供的Pageable获得时，客户端可以为每个页面索引提供不同的PageFormats。 分页符的计算必须说明这一点。
    另请参见：
    Pageable ， PageFormat ， PrinterJob

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int NO_SUCH_PAGE
      从 print返回，表示 pageIndex太大，请求的页面不存在。
      static int PAGE_EXISTS
      从 print(Graphics, PageFormat, int)返回，表示请求的页面被呈现。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int print​(Graphics graphics, PageFormat pageFormat, int pageIndex)
      以指定的格式将指定索引的页面打印到指定的Graphics上下文中。

    • 字段详细信息

      • PAGE_EXISTS

        static final int PAGE_EXISTS
        从 print(Graphics, PageFormat, int)返回，表示请求的页面被呈现。
        另请参见：
        Constant Field Values

      • NO_SUCH_PAGE

        static final int NO_SUCH_PAGE
        从 print返回，表示 pageIndex太大，请求的页面不存在。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • print

        int print​(Graphics graphics,
          PageFormat pageFormat,
          int pageIndex)
   throws PrinterException
        以指定的格式将指定索引的页面打印到指定的Graphics上下文中。 A PrinterJob调用Printable接口以请求将页面呈现到由graphics指定的graphics 。 要绘制的页面的格式由pageFormat指定。 请求页面的零pageIndex由pageIndex指定。 如果请求的页面不存在，则此方法返回NO_SUCH_PAGE; 否则返回PAGE_EXISTS。 Graphics类或子类实现PrinterGraphics接口提供附加信息。 如果Printable对象中止打印作业，那么它会抛出一个PrinterException 。
        参数
        graphics - 绘制页面的上下文
        pageFormat - 正在绘制的页面的大小和方向
        pageIndex - 要绘制的页面的零 pageIndex引
        结果
        如果页面呈现成功，则 pageIndex或者如果 pageIndex指定不存在的页面， pageIndex NO_SUCH_PAGE。
        异常
        PrinterException - 打印作业终止时抛出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrinterAbortException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Class PrinterAbortException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.print.PrinterException
          • java.awt.print.PrinterAbortException
  • All Implemented Interfaces:
    Serializable

    public class PrinterAbortException
extends PrinterException
    所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrinterAbortException​()
      构造一个新的 PrinterAbortException ，没有详细信息。
      PrinterAbortException​(String msg)
      构造一个新的 PrinterAbortException与指定的详细信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • PrinterAbortException

        public PrinterAbortException​()
        构造一个新的 PrinterAbortException ，没有详细信息。

      • PrinterAbortException

        public PrinterAbortException​(String msg)
        构造一个新的 PrinterAbortException具有指定的详细信息。
        参数
        msg - 抛出 PrinterAbortException时要生成的消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrinterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Class PrinterException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.print.PrinterException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    PrinterAbortException ， PrinterIOException

    public class PrinterException
extends 异常
    PrinterException类及其子类用于指示在打印系统中发生异常情况。
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrinterException​()
      构造一个新的 PrinterException对象，没有详细消息。
      PrinterException​(String msg)
      使用指定的详细消息构造一个新的 PrinterException对象。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • PrinterException

        public PrinterException​()
        构造一个新的 PrinterException对象，没有详细消息。

      • PrinterException

        public PrinterException​(String msg)
        构造具有指定详细消息的新的 PrinterException对象。
        参数
        msg - 抛出 PrinterException时生成的消息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrinterGraphics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Interface PrinterGraphics

  • public interface PrinterGraphics
    PrinterGraphics接口由Graphics对象实现，传递给Printable对象以呈现页面。 它允许应用程序找到正在控制打印的PrinterJob对象。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      PrinterJob getPrinterJob​()
      返回正在控制当前呈现请求的 PrinterJob 。

    • 方法详细信息

      • getPrinterJob

        PrinterJob getPrinterJob​()
        返回正在控制当前呈现请求的 PrinterJob 。
        结果
        控制当前呈现请求的 PrinterJob 。
        另请参见：
        Printable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrinterIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Class PrinterIOException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.awt.print.PrinterException
          • java.awt.print.PrinterIOException
  • All Implemented Interfaces:
    Serializable

    public class PrinterIOException
extends PrinterException
    该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 现在，在建造时提供并通过getIOException()方法访问的“终止打印作业的” IOException “现在被称为原因 ，可以通过Throwable.getCause()方法以及上述”传统方法“访问。

    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrinterIOException​(IOException exception)
      构造一个新的PrinterIOException与指定的IOException的字符串表示。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因（终止打印作业的 IOException ）。
      IOException getIOException​()
      返回终止打印作业的 IOException 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • PrinterIOException

        public PrinterIOException​(IOException exception)
        构造新的PrinterIOException与指定的IOException的字符串表示。
        参数
        exception - 指定的 IOException

    • 方法详细信息

      • getIOException

        public IOException getIOException​()
        返回终止打印作业的IOException 。

        这种方法早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

        结果
        IOException终止了打印作业。
        另请参见：
        IOException

      • getCause

        public Throwable getCause​()
        返回此异常的原因（终止打印作业的 IOException ）。
        重写：
        getCause在 Throwable
        结果
        这个例外的原因。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrinterJob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.awt.print

Class PrinterJob

  • java.lang.Object
    • java.awt.print.PrinterJob

  • public abstract class PrinterJob
extends Object
    PrinterJob课程是控制打印的主要课程。 应用程序调用此类中的方法来设置作业，可选地与用户调用打印对话框，然后打印作业的页面。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrinterJob​()
      应使用静态 getPrinterJob方法创建一个 PrinterJob对象。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void cancel​()
      取消正在进行的打印作业。
      PageFormat defaultPage​()
      创建一个新的 PageFormat实例，并将其设置为默认的大小和方向。
      abstract PageFormat defaultPage​(PageFormat page)
      克隆 PageFormat参数，并更改克隆来描述默认页面大小和方向。
      abstract int getCopies​()
      获取要打印的份数。
      abstract String getJobName​()
      获取要打印的文档的名称。
      PageFormat getPageFormat​(PrintRequestAttributeSet attributes)
      计算一个 PageFormat ，其值与目前的 PrintService支持的值（即 getPrintService()返回的值）和 attributes包含的介质，可打印区域和方向保持 attributes 。
      static PrinterJob getPrinterJob​()
      创建并返回最初与默认打印机相关联的 PrinterJob 。
      PrintService getPrintService​()
      返回此打印机作业的服务（打印机）。
      abstract String getUserName​()
      获取打印用户的名称。
      abstract boolean isCancelled​()
      如果打印作业正在进行中，但如果下次有机会被取消，则返回true ; 否则返回false 。
      static PrintService[] lookupPrintServices​()
      查找2D打印服务的便捷方法。
      static StreamPrintServiceFactory[] lookupStreamPrintServices​(String mimeType)
      一种方便的方法，可以定位可以对2D图形进行图像处理的流打印服务的工厂。
      abstract PageFormat pageDialog​(PageFormat page)
      显示允许修改 PageFormat实例的对话框。
      PageFormat pageDialog​(PrintRequestAttributeSet attributes)
      显示跨平台页面设置对话框的便捷方法。
      abstract void print​()
      打印一组页面。
      void print​(PrintRequestAttributeSet attributes)
      使用属性集中的设置打印一组页面。
      abstract boolean printDialog​()
      向用户呈现一个对话框，用于更改打印作业的属性。
      boolean printDialog​(PrintRequestAttributeSet attributes)
      一种方便的方法，显示可以使用 Pageable界面打印2D图形的所有服务的跨平台打印对话框。
      abstract void setCopies​(int copies)
      设置要打印的份数。
      abstract void setJobName​(String jobName)
      设置要打印的文档的名称。
      abstract void setPageable​(Pageable document)
      查询 document的页数和 PageFormat和 Printable为 Pageable实例中的每个页面， document 。
      abstract void setPrintable​(Printable painter)
      致电 painter以呈现页面。
      abstract void setPrintable​(Printable painter, PageFormat format)
      拨打 painter以指定 format的页面。
      void setPrintService​(PrintService service)
      将此PrinterJob与新的PrintService相关联。
      abstract PageFormat validatePage​(PageFormat page)
      返回 page的克隆，其设置被调整为与该 PrinterJob的当前打印机兼容。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PrinterJob

        public PrinterJob​()
        应使用静态 getPrinterJob方法创建一个 PrinterJob对象。

    • 方法详细信息

      • getPrinterJob

        public static PrinterJob getPrinterJob​()
        创建并返回最初与默认打印机相关联的PrinterJob 。 如果没有可用的打印机在系统上，一个的PrinterJob仍然会从此方法返回，但getPrintService()将返回null ，并呼吁print这个PrinterJob可能产生异常。 在创建PrinterJob之前需要确定是否有合适的打印机的应用程序应确保从lookupPrintServices返回的数组不为空。
        结果
        一个新的 PrinterJob 。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkPrintJobAccess()方法不允许此线程创建打印作业请求

      • lookupPrintServices

        public static PrintService[] lookupPrintServices​()
        查找2D打印服务的便捷方法。 从此方法返回的服务可能安装在支持打印服务的PrinterJob 。 调用此方法相当于调用PrintServiceLookup.lookupPrintServices()并指定一个Pageable DocFlavor。
        结果
        一个可能是空的2D打印服务。
        从以下版本开始：
        1.4

      • lookupStreamPrintServices

        public static StreamPrintServiceFactory[] lookupStreamPrintServices​(String mimeType)
        一种方便的方法，可以定位可以对2D图形进行图像处理的流打印服务的工厂。 样品用量：
           FileOutputStream outstream; StreamPrintService psPrinter; String psMimeType = "application/postscript"; PrinterJob pj = PrinterJob.getPrinterJob(); StreamPrintServiceFactory[] factories = PrinterJob.lookupStreamPrintServices(psMimeType); if (factories.length > 0) { try { outstream = new File("out.ps"); psPrinter = factories[0].getPrintService(outstream); // psPrinter can now be set as the service on a PrinterJob pj.setPrintService(psPrinter) } catch (Exception e) { e.printStackTrace(); } }
        从此方法返回的服务可能安装在支持打印服务的PrinterJob实例上。 调用此方法相当于调用StreamPrintServiceFactory.lookupStreamPrintServiceFactories() 并指定一个Pageable DocFlavor。
        参数
        mimeType - 所需的输出格式，或null表示任何格式。
        结果
        一个可能是空的2D流打印服务工厂。
        从以下版本开始：
        1.4

      • getPrintService

        public PrintService getPrintService​()
        返回此打印机作业的服务（打印机）。 不支持打印服务的此类的实现可能返回null。 如果没有打印机可用，也将返回null。
        结果
        此打印机作业的服务。
        从以下版本开始：
        1.4
        另请参见：
        setPrintService(PrintService) ， getPrinterJob()

      • setPrintService

        public void setPrintService​(PrintService service)
                     throws PrinterException
        将此PrinterJob与新的PrintService相关联。 此方法被支持指定打印服务的子类覆盖。 如果指定的服务不支持支持2D打印所需的Pageable和Printable接口，则抛出PrinterException 。
        参数
        service - 支持2D打印的打印服务
        异常
        PrinterException - 如果指定的服务不支持2D打印，或该PrinterJob类不支持设置2D打印服务，否则指定的服务不是有效的打印服务。
        从以下版本开始：
        1.4
        另请参见：
        getPrintService()

      • setPrintable

        public abstract void setPrintable​(Printable painter)
        致电painter呈现页面。 由PrinterJob打印的文档中的页面由Printable对象， painter 。 每个页面的PageFormat是默认页面格式。
        参数
        painter - 呈现文档的每一页的 Printable 。

      • setPrintable

        public abstract void setPrintable​(Printable painter,
                                  PageFormat format)
        致电painter以指定format的页面。 由PrinterJob打印的文档中的页面由Printable对象， painter 。 该PageFormat每一页是format 。
        参数
        painter - 要求渲染文档的每一页的 Printable
        format - 要打印的每个页面的大小和方向

      • setPageable

        public abstract void setPageable​(Pageable document)
                          throws NullPointerException
        查询 document的页数和 PageFormat和 Printable的每个页面保持在 Pageable实例， document 。
        参数
        document - 要打印的页面。 它不能是null 。
        异常
        NullPointerException - 通过的 Pageable是 null 。
        另请参见：
        PageFormat ， Printable

      • printDialog

        public abstract boolean printDialog​()
                             throws HeadlessException
        向用户呈现一个对话框，用于更改打印作业的属性。 如果选择本机打印服务，则此方法将显示本机对话框，并且打印机的用户选择将仅限于这些本机打印服务。 要呈现所有服务的跨平台打印对话框，包括本机，请使用printDialog(PrintRequestAttributeSet) 。

        可以使用PrintService的PrinterJob实现将更新此PrinterJob的PrintService以反映用户选择的新服务。

        结果
        true如果用户没有取消对话框; false否则。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        另请参见：
        GraphicsEnvironment.isHeadless()

      • printDialog

        public boolean printDialog​(PrintRequestAttributeSet attributes)
                    throws HeadlessException
        一种方便的方法，显示可以使用Pageable界面打印2D图形的所有服务的跨平台打印对话框。 最初显示对话框时所选的打印机将反映当前附加到此打印作业的打印服务。 如果用户更改打印服务，PrinterJob将被更新以反映这一点，除非用户取消对话框。 除了允许用户选择目的地打印机之外，用户还可以选择各种打印请求属性的值。

        输入上的attributes参数将反映在用户对话框中需要的初始选择应用程序。 未指定的属性使用服务的默认值显示。 返回时将反映用户的选择。 可以通过实施来更新选项以与当前选择的打印服务的支持值一致。

        当用户滚动到新的打印服务选择时，复制的值将基于上一个服务的设置以及任何用户更改。 这些值不是基于客户端提供的原始设置。

        除选定的打印机外，PrinterJob状态不会更新以反映用户的更改。 对于影响打印机作业的选择，必须在调用print(PrintRequestAttributeSet)方法中指定属性。 如果使用Pageable界面，则要使用用户选择的媒体的客户端必须创建一个从用户选择中派生的PageFormat。 如果用户取消对话框，属性将不会反映用户所做的任何更改。

        参数
        attributes - 输入是应用程序提供的属性，输出内容更新以反映用户选择。 此参数可能不为空。
        结果
        true如果用户不取消对话框; 否则为false 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        NullPointerException - 如果 attributes参数为空。
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless()

      • pageDialog

        public abstract PageFormat pageDialog​(PageFormat page)
                               throws HeadlessException
        显示允许修改PageFormat实例的对话框。 page参数用于初始化页面设置对话框中的控件。 如果用户取消了对话框，则该方法将未修改原始的page对象。 如果用户确定对话框，则该方法将返回一个新的PageFormat对象，并显示指定的更改。 在任何一种情况下，原始的page对象不被修改。
        参数
        page - 默认 PageFormat提交给用户进行修改
        结果
        原来的page对象如果对话框被取消; 一个新的PageFormat对象，包含如果对话被确认，用户指示的格式。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        从以下版本开始：
        1.2
        另请参见：
        GraphicsEnvironment.isHeadless()

      • pageDialog

        public PageFormat pageDialog​(PrintRequestAttributeSet attributes)
                      throws HeadlessException
        显示跨平台页面设置对话框的便捷方法。 可用的选项将反映当前在此PrinterJob上设置的打印服务。

        输入上的attributes参数将反映用户对话框中客户端所需的初始选择。 未指定的属性使用服务的默认值显示。 返回时将反映用户的选择。 可以通过实施来更新选项以与当前选择的打印服务的支持值一致。

        返回值将是与PrintRequestAttributeSet中的选择等效的PageFormat。 如果用户取消对话框，属性将不会反映用户所做的任何更改，返回值将为空。

        参数
        attributes - 输入是应用程序提供的属性，输出内容更新以反映用户选择。 此参数可能不为空。
        结果
        如果用户不取消对话框的页面格式; 否则为null 。
        异常
        HeadlessException - 如果GraphicsEnvironment.isHeadless（）返回true。
        NullPointerException - 如果 attributes参数为空。
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless()

      • defaultPage

        public abstract PageFormat defaultPage​(PageFormat page)
        克隆 PageFormat参数，并更改克隆以描述默认页面大小和方向。
        参数
        page - 要克隆和修改的 PageFormat
        结果
        克隆 page ，改为描述一个默认的 PageFormat 。

      • defaultPage

        public PageFormat defaultPage​()
        创建一个新的 PageFormat实例，并将其设置为默认的大小和方向。
        结果
        一个 PageFormat设置为默认的大小和方向。

      • getPageFormat

        public PageFormat getPageFormat​(PrintRequestAttributeSet attributes)
        计算一个PageFormat ，其值与当前的PrintService支持的值（即getPrintService()返回的值）和attributes包含的介质，可打印区域和方向的值attributes 。

        调用此方法不会更新作业。 它对于具有从printDialog(PrintRequestAttributeSet attributes)获取的一组属性的客户端是有用的，需要一个PageFormat来打印一个Pageable对象。

        参数
        attributes - 一组打印属性，例如从调用printDialog获取。 如果attributes为空，则返回默认的PageFormat。
        结果
        一个 PageFormat的设置符合当前服务和指定属性的设置。
        从以下版本开始：
        1.6

      • validatePage

        public abstract PageFormat validatePage​(PageFormat page)
        返回page的克隆，其设置被调整为与此PrinterJob的当前打印机兼容。 例如，返回的PageFormat可以将其可成像区域调整为适合当前打印机使用的纸张的物理区域。
        参数
        page - 克隆的 PageFormat ，其设置更改为与当前打印机兼容
        结果
        一个 PageFormat是从克隆 page ，其设置被更改与此相一致 PrinterJob 。

      • print

        public abstract void print​()
                    throws PrinterException
        打印一组页面。
        异常
        PrinterException - 打印系统中的错误导致作业中止。
        另请参见：
        Book ， Pageable ， Printable

      • print

        public void print​(PrintRequestAttributeSet attributes)
           throws PrinterException
        使用属性集中的设置打印一组页面。 默认实现忽略属性集。

        请注意，可以通过等效的方法调用（例如），副本： setCopies(int) ，作业名称： setJobName(String)在PrinterJob上直接设置某些属性，并通过PageFormat对象指定介质尺寸和方向。

        如果在此属性集中指定了支持的属性值，则它将优先于此print（）操作的API设置。 为PageFormat指定了以下行为：如果客户端使用可打印接口，则会针对指定介质（大小），方向和可成像区域的属性来检查此方法的attributes参数，并且这些属性用于构造新的PageFormat它被传递给Printable对象的print（）方法。 有关可打印的所需行为的说明，请参阅Printable ，以确保通过PrinterJob进行最佳打印。 对于Pageable接口的客户端，PageFormat将始终由该接口按照每页提供。

        这些行为允许应用程序将从printDialog(PrintRequestAttributeSet attributes返回的用户设置直接传递给此print（）方法。

        参数
        attributes - 作业的一组属性
        异常
        PrinterException - 打印系统中的错误导致作业中止。
        从以下版本开始：
        1.4
        另请参见：
        Book ， Pageable ， Printable

      • setCopies

        public abstract void setCopies​(int copies)
        设置要打印的份数。
        参数
        copies - 要打印的份数
        另请参见：
        getCopies()

      • getCopies

        public abstract int getCopies​()
        获取要打印的份数。
        结果
        要打印的份数。
        另请参见：
        setCopies(int)

      • getUserName

        public abstract String getUserName​()
        获取打印用户的名称。
        结果
        打印用户的名称
        异常
        SecurityException - 如果安全管理器存在，并且 SecurityException - user.name未在策略文件中给出

      • setJobName

        public abstract void setJobName​(String jobName)
        设置要打印的文档的名称。 文件名称不能为null 。
        参数
        jobName - 要打印的文档的名称
        另请参见：
        getJobName()

      • getJobName

        public abstract String getJobName​()
        获取要打印的文档的名称。
        结果
        要打印的文档的名称。
        另请参见：
        setJobName(java.lang.String)

      • cancel

        public abstract void cancel​()
        取消正在进行的打印作业。 如果已经调用了print，但是没有返回，那么这个方法就表示在下一次机会时应该取消该作业。 如果没有正在进行的打印作业，则此呼叫不会执行任何操作。

      • isCancelled

        public abstract boolean isCancelled​()
        如果打印作业正在进行，但是将在下一次机会被取消时返回true ; 否则返回false 。
        结果
        true如果正在进行的工作将被取消; 否则为false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.awt.print (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.awt.print

  • Packages that use java.awt.print
    软件包 描述
    java.awt.print
    提供通用打印API的类和接口。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
  • Classes in java.awt.print used by java.awt.print
    Class 描述
    Pageable
    Pageable实现代表一组要打印的页面。
    PageFormat
    PageFormat类描述了要打印的页面的大小和方向。
    Paper
    Paper类描述了一张纸的物理特性。
    Printable
    Printable接口由当前页面画家的 print方法实现，该方法由打印系统调用以呈现页面。
    PrinterException
    PrinterException类及其子类用于表示在打印系统中发生异常情况。
    PrinterJob
    PrinterJob类是控制打印的主要类。
  • Classes in java.awt.print used by javax.jnlp
    Class 描述
    Pageable
    Pageable实现代表一组要打印的页面。
    PageFormat
    PageFormat类描述了要打印的页面的大小和方向。
    Printable
    Printable接口由当前页面画家的 print方法实现，该方法由打印系统调用以呈现页面。
  • Classes in java.awt.print used by javax.swing
    Class 描述
    Printable
    Printable接口由当前页面画家的 print方法实现，该方法由打印系统调用以呈现页面。
    PrinterException
    PrinterException类及其子类用于指示在打印系统中发生异常情况。
  • Classes in java.awt.print used by javax.swing.text
    Class 描述
    Printable
    Printable接口由当前页面画家的 print方法实现，该方法由打印系统调用以呈现页面。
    PrinterException
    PrinterException类及其子类用于指示在打印系统中出现异常情况。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.print.Book (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.print.Book

No usage of java.awt.print.Book
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.print.PageFormat (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.print.PageFormat

  • Packages that use PageFormat
    软件包 描述
    java.awt.print
    提供通用打印API的类和接口。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of PageFormat in java.awt.print

      Methods in java.awt.print that return PageFormat
      Modifier and Type 方法 描述
      PageFormat PrinterJob.defaultPage​()
      创建一个新的 PageFormat实例，并将其设置为默认的大小和方向。
      abstract PageFormat PrinterJob.defaultPage​(PageFormat page)
      克隆 PageFormat参数，并更改克隆以描述默认页面大小和方向。
      PageFormat Book.getPageFormat​(int pageIndex)
      返回pageIndex指定页面的pageIndex 。
      PageFormat Pageable.getPageFormat​(int pageIndex)
      返回 PageFormat指定页面的 pageIndex 。
      PageFormat PrinterJob.getPageFormat​(PrintRequestAttributeSet attributes)
      计算一个 PageFormat ，其值与当前的 PrintService支持的值（即 getPrintService()返回的值）以及 attributes包含的介质，可打印区域和方向的值 attributes 。
      abstract PageFormat PrinterJob.pageDialog​(PageFormat page)
      显示允许修改 PageFormat实例的对话框。
      PageFormat PrinterJob.pageDialog​(PrintRequestAttributeSet attributes)
      显示跨平台页面设置对话框的便捷方法。
      abstract PageFormat PrinterJob.validatePage​(PageFormat page)
      返回 page的克隆，其设置被调整为与此 PrinterJob的当前打印机兼容。
      Methods in java.awt.print with parameters of type PageFormat
      Modifier and Type 方法 描述
      void Book.append​(Printable painter, PageFormat page)
      追加一页到这个 Book 。
      void Book.append​(Printable painter, PageFormat page, int numPages)
      追加 numPages页到这个 Book 。
      abstract PageFormat PrinterJob.defaultPage​(PageFormat page)
      克隆 PageFormat参数，并更改克隆以描述默认页面大小和方向。
      abstract PageFormat PrinterJob.pageDialog​(PageFormat page)
      显示允许修改 PageFormat实例的对话框。
      int Printable.print​(Graphics graphics, PageFormat pageFormat, int pageIndex)
      以指定的格式将指定索引的页面打印到指定的Graphics上下文中。
      void Book.setPage​(int pageIndex, Printable painter, PageFormat page)
      为指定的页码设置 PageFormat和 Painter 。
      abstract void PrinterJob.setPrintable​(Printable painter, PageFormat format)
      致电 painter以指定 format的页面。
      abstract PageFormat PrinterJob.validatePage​(PageFormat page)
      返回 page的克隆，其设置被调整为与该 PrinterJob的当前打印机兼容。

    • Uses of PageFormat in javax.jnlp

      Methods in javax.jnlp that return PageFormat
      Modifier and Type 方法 描述
      PageFormat PrintService.getDefaultPage​()
      创建一个新的PageFormat实例，并将其设置为默认的大小和方向。
      PageFormat PrintService.showPageFormatDialog​(PageFormat page)
      显示允许修改 PageFormat实例的对话框。
      Methods in javax.jnlp with parameters of type PageFormat
      Modifier and Type 方法 描述
      PageFormat PrintService.showPageFormatDialog​(PageFormat page)
      显示允许修改 PageFormat实例的对话框。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.print.Paper (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.print.Paper

  • Packages that use Paper
    软件包 描述
    java.awt.print
    提供通用打印API的类和接口。

    • Uses of Paper in java.awt.print

      Methods in java.awt.print that return Paper
      Modifier and Type 方法 描述
      Paper PageFormat.getPaper​()
      返回与此PageFormat相关联的Paper对象的副本。
      Methods in java.awt.print with parameters of type Paper
      Modifier and Type 方法 描述
      void PageFormat.setPaper​(Paper paper)
      设置 Paper对象为这个 PageFormat 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.print.PrinterAbortException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.print.PrinterAbortException

No usage of java.awt.print.PrinterAbortException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.print.PrinterException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.print.PrinterException

  • Packages that use PrinterException
    软件包 描述
    java.awt.print
    提供通用打印API的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of PrinterException in java.awt.print

      Subclasses of PrinterException in java.awt.print
      Modifier and Type Class 描述
      class  PrinterAbortException
      所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。
      class  PrinterIOException
      该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。
      Methods in java.awt.print that throw PrinterException
      Modifier and Type 方法 描述
      int Printable.print​(Graphics graphics, PageFormat pageFormat, int pageIndex)
      以指定的格式将指定索引的页面打印到指定的Graphics上下文中。
      abstract void PrinterJob.print​()
      打印一组页面。
      void PrinterJob.print​(PrintRequestAttributeSet attributes)
      使用属性集中的设置打印一组页面。
      void PrinterJob.setPrintService​(PrintService service)
      将此PrinterJob与新的PrintService相关联。

    • Uses of PrinterException in javax.swing

      Methods in javax.swing that throw PrinterException
      Modifier and Type 方法 描述
      boolean JTable.print​()
      显示打印对话框的便捷方法，然后打印 JTable ，模式为 PrintMode.FIT_WIDTH ，没有页眉或页脚文本。
      boolean JTable.print​(JTable.PrintMode printMode)
      显示打印对话框的方便方法，然后在给定的打印模式下打印 JTable ，没有页眉或页脚文本。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      显示打印对话框的便捷方法，然后以指定的页眉和页脚文本在给定的打印模式下打印此 JTable 。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive)
      按照功能全面的 print方法指定打印此表，默认打印机指定为打印服务。
      boolean JTable.print​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
      打印 JTable 。

    • Uses of PrinterException in javax.swing.text

      Methods in javax.swing.text that throw PrinterException
      Modifier and Type 方法 描述
      boolean JTextComponent.print​()
      一种方便的打印方法，显示打印对话框，然后以无标题或页脚文本的 交互模式打印此 JTextComponent 。
      boolean JTextComponent.print​(MessageFormat headerFormat, MessageFormat footerFormat)
      显示打印对话框的便捷打印方法，然后以指定的页眉和页脚文本的 交互模式打印此 JTextComponent 。
      boolean JTextComponent.print​(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
      打印 JTextComponent的内容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.print.PrinterIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.print.PrinterIOException

No usage of java.awt.print.PrinterIOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.awt.print.PrinterJob (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.awt.print.PrinterJob

  • Packages that use PrinterJob
    软件包 描述
    java.awt.print
    提供通用打印API的类和接口。

    • Uses of PrinterJob in java.awt.print

      Methods in java.awt.print that return PrinterJob
      Modifier and Type 方法 描述
      PrinterJob PrinterGraphics.getPrinterJob​()
      返回正在控制当前呈现请求的 PrinterJob 。
      static PrinterJob PrinterJob.getPrinterJob​()
      创建并返回最初与默认打印机相关联的 PrinterJob 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.print.Pageable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.print.Pageable

  • Packages that use Pageable
    软件包 描述
    java.awt.print
    提供通用打印API的类和接口。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of Pageable in java.awt.print

      Classes in java.awt.print that implement Pageable
      Modifier and Type Class 描述
      class  Book
      Book类提供了一个文档的表示，其中页面可能具有不同的页面格式和页面绘图。
      Methods in java.awt.print with parameters of type Pageable
      Modifier and Type 方法 描述
      abstract void PrinterJob.setPageable​(Pageable document)
      查询 document的页数和 PageFormat和 Printable的每个页面保持在 Pageable实例， document 。

    • Uses of Pageable in javax.jnlp

      Methods in javax.jnlp with parameters of type Pageable
      Modifier and Type 方法 描述
      boolean PrintService.print​(Pageable document)
      使用给定的 Pageable对象打印文档
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.print.Printable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.print.Printable

  • Packages that use Printable
    软件包 描述
    java.awt.print
    提供通用打印API的类和接口。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Printable in java.awt.print

      Methods in java.awt.print that return Printable
      Modifier and Type 方法 描述
      Printable Book.getPrintable​(int pageIndex)
      返回Printable实例，负责渲染由pageIndex指定的pageIndex 。
      Printable Pageable.getPrintable​(int pageIndex)
      返回 Printable实例，负责渲染由 pageIndex指定的 pageIndex 。
      Methods in java.awt.print with parameters of type Printable
      Modifier and Type 方法 描述
      void Book.append​(Printable painter, PageFormat page)
      在这个 Book的末尾添加一个页面。
      void Book.append​(Printable painter, PageFormat page, int numPages)
      追加 numPages页到这个 Book 。
      void Book.setPage​(int pageIndex, Printable painter, PageFormat page)
      设置 PageFormat和 Painter的指定页码。
      abstract void PrinterJob.setPrintable​(Printable painter)
      致电 painter以呈现页面。
      abstract void PrinterJob.setPrintable​(Printable painter, PageFormat format)
      致电 painter以指定 format的页面。

    • Uses of Printable in javax.jnlp

      Methods in javax.jnlp with parameters of type Printable
      Modifier and Type 方法 描述
      boolean PrintService.print​(Printable painter)
      使用给定的 Printable对象打印文档

    • Uses of Printable in javax.swing

      Methods in javax.swing that return Printable
      Modifier and Type 方法 描述
      Printable JTable.getPrintable​(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      返回一个 Printable用于打印此JTable。

    • Uses of Printable in javax.swing.text

      Methods in javax.swing.text that return Printable
      Modifier and Type 方法 描述
      Printable JTextComponent.getPrintable​(MessageFormat headerFormat, MessageFormat footerFormat)
      返回一个 Printable用于打印 JTextComponent的内容。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.awt.print.PrinterGraphics (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.awt.print.PrinterGraphics

No usage of java.awt.print.PrinterGraphics
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AppletInitializer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface AppletInitializer

  • 已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    @Deprecated(since="9")
public interface AppletInitializer
    此接口旨在与java.beans.Beans.instantiate进行勾结。 该接口旨在提供机制，以便在由java.beans.Beans.instantiate（）实例化过程中正确初始化也称为Applet的JavaBean。
    从以下版本开始：
    1.2
    另请参见：
    Beans.instantiate(java.lang.ClassLoader, java.lang.String)

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      void activate​(Applet newApplet)
      已过时。
      激活，和/或标记Applet活动。
      void initialize​(Applet newAppletBean, BeanContext bCtxt)
      已过时。
      如果传递给java.beans.Beans.instantiate的相应变体，则将调用此方法，以便将新实例化的Applet（JavaBean）与其AppletContext，AppletStub和Container关联。

    • 方法详细信息

      • initialize

        void initialize​(Applet newAppletBean,
                BeanContext bCtxt)
        已过时。

        如果传递给java.beans.Beans.instantiate的相应变体，则将调用此方法，以便将新实例化的Applet（JavaBean）与其AppletContext，AppletStub和Container关联。

        一致的实施应：

        1. 将新实例化的Applet与适当的AppletContext关联。
        2. 实例化AppletStub（），并通过调用setStub（）将AppletStub与Applet相关联。
        3. 如果BeanContext参数为null，则它将通过调用add（）将Applet与其适当的容器相关联，将该Applet添加到其Container中。 如果BeanContext参数是非空值，则BeanContext有责任在随后调用其addChildren（）方法时将Applet与其Container关联。
        参数
        newAppletBean - 新实例化的JavaBean
        bCtxt - 用于此Applet的BeanContext，或null。

      • activate

        void activate​(Applet newApplet)
        已过时。

        激活，和/或标记Applet活动。 此接口的实现者应将该Applet标记为活动状态，并可选地调用其start（）方法。

        参数
        newApplet - 新实例化的JavaBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class BeanDescriptor

  • java.lang.Object
    • java.beans.FeatureDescriptor
      • java.beans.BeanDescriptor

  • public class BeanDescriptor
extends FeatureDescriptor
    BeanDescriptor提供有关“bean”的全局信息，包括其Java类，其displayName等。

    这是BeanInfo对象返回的描述符之一，它也返回属性，方法和事件的描述符。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      BeanDescriptor​(Class<?> beanClass)
      为没有自定义程序的bean创建BeanDescriptor。
      BeanDescriptor​(Class<?> beanClass, Class<?> customizerClass)
      为具有自定义程序的bean创建BeanDescriptor。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<?> getBeanClass​()
      获取bean的Class对象。
      Class<?> getCustomizerClass​()
      获取bean的定制器的Class对象。

      • Methods inherited from class java.beans.FeatureDescriptor

        attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BeanDescriptor

        public BeanDescriptor​(Class<?> beanClass)
        为没有自定义程序的bean创建BeanDescriptor。
        参数
        beanClass - 实现bean的Java类的Class对象。 例如sun.beans.OurButton.class。

      • BeanDescriptor

        public BeanDescriptor​(Class<?> beanClass,
                      Class<?> customizerClass)
        为具有自定义程序的bean创建BeanDescriptor。
        参数
        beanClass - 实现bean的Java类的Class对象。 例如sun.beans.OurButton.class。
        customizerClass - 实现bean的Customizer的Java类的Class对象。 例如sun.beans.OurButtonCustomizer.class。

    • 方法详细信息

      • getBeanClass

        public Class<?> getBeanClass​()
        获取bean的Class对象。
        结果
        Bean的Class对象。

      • getCustomizerClass

        public Class<?> getCustomizerClass​()
        获取bean的定制器的Class对象。
        结果
        Bean的定制器的Class对象。 如果bean没有自定义程序，这可能为null。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface BeanInfo

  • All Known Subinterfaces:
    BeanContextServiceProviderBeanInfo
    所有已知实现类：
    SimpleBeanInfo

    public interface BeanInfo
    使用BeanInfo接口创建一个BeanInfo类，并提供关于bean的方法，属性，事件和其他功能的显式信息。

    在开发您的bean时，您可以实现应用任务所需的bean功能，省略其余的BeanInfo功能。 他们将通过自动分析，通过使用低级反射的豆类方法和应用标准设计模式获得。 您有机会通过各种描述符类提供其他bean信息。

    见SimpleBeanInfo类，它是一个方便的基本类BeanInfo类。 您可以覆盖SimpleBeanInfo类的方法和属性来定义特定信息。

    另请参阅Introspector类来了解有关bean行为的更多信息。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ICON_COLOR_16x16
      常数表示16 x 16颜色图标。
      static int ICON_COLOR_32x32
      常数表示32 x 32颜色图标。
      static int ICON_MONO_16x16
      常数表示16 x 16黑白图标。
      static int ICON_MONO_32x32
      常数表示32 x 32黑白图标。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BeanInfo[] getAdditionalBeanInfo​()
      该方法使当前的 BeanInfo对象能够返回任意的其他 BeanInfo对象的集合， BeanInfo对象提供有关当前bean的附加信息。
      BeanDescriptor getBeanDescriptor​()
      返回提供关于该bean的整体信息的bean描述符，例如其显示名称或其定制器。
      int getDefaultEventIndex​()
      一个bean可能有一个默认的事件通常应用在这个bean使用。
      int getDefaultPropertyIndex​()
      当bean定制时，bean可能具有通常更新的默认属性。
      EventSetDescriptor[] getEventSetDescriptors​()
      返回bean定义此bean触发的事件类型的事件描述符。
      Image getIcon​(int iconKind)
      返回可用于在工具箱或工具栏中表示bean的图像。
      MethodDescriptor[] getMethodDescriptors​()
      返回定义此bean支持的外部可见方法的bean的方法描述符。
      PropertyDescriptor[] getPropertyDescriptors​()
      返回bean的所有属性的描述符。

    • 字段详细信息

      • ICON_COLOR_16x16

        static final int ICON_COLOR_16x16
        常数表示16 x 16颜色图标。
        另请参见：
        Constant Field Values

      • ICON_COLOR_32x32

        static final int ICON_COLOR_32x32
        常数表示32 x 32颜色图标。
        另请参见：
        Constant Field Values

      • ICON_MONO_16x16

        static final int ICON_MONO_16x16
        常数表示16 x 16黑白图标。
        另请参见：
        Constant Field Values

      • ICON_MONO_32x32

        static final int ICON_MONO_32x32
        常数表示32 x 32黑白图标。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getBeanDescriptor

        BeanDescriptor getBeanDescriptor​()
        返回提供关于该bean的整体信息的bean描述符，例如其显示名称或其定制器。
        结果
        一个BeanDescriptor对象，如果要通过自动分析获得信息， null

      • getEventSetDescriptors

        EventSetDescriptor[] getEventSetDescriptors​()
        返回bean定义此bean触发的事件类型的事件描述符。
        结果
        一组EventSetDescriptor个对象，如果要通过自动分析获得信息， null

      • getDefaultEventIndex

        int getDefaultEventIndex​()
        一个bean可能有一个默认的事件通常应用在这个bean使用。
        结果
        由 getEventSetDescriptors方法返回的 EventSetDescriptor数组中的默认事件的索引，如果没有默认事件则为-1

      • getPropertyDescriptors

        PropertyDescriptor[] getPropertyDescriptors​()
        返回bean的所有属性的描述符。

        如果属性索引，则其结果阵列中条目属于IndexedPropertyDescriptor子类的PropertyDescriptor类。 getPropertyDescriptors方法的客户端可以使用instanceof运算符来检查给定的PropertyDescriptor是否为IndexedPropertyDescriptor 。

        结果
        一组 PropertyDescriptor对象，如果要通过自动分析获得信息， null

      • getDefaultPropertyIndex

        int getDefaultPropertyIndex​()
        当bean定制时，bean可能具有通常更新的默认属性。
        结果
        由 getPropertyDescriptors方法返回的 PropertyDescriptor数组中的默认属性的索引，如果没有默认属性，则为-1。

      • getMethodDescriptors

        MethodDescriptor[] getMethodDescriptors​()
        返回定义此bean支持的外部可见方法的bean的方法描述符。
        结果
        一组MethodDescriptor个对象，如果要通过自动分析获得信息， null

      • getAdditionalBeanInfo

        BeanInfo[] getAdditionalBeanInfo​()
        此方法使当前的BeanInfo对象能够返回任何其他BeanInfo对象的任意集合， BeanInfo对象提供有关当前bean的附加信息。

        如果BeanInfo对象提供的信息之间存在冲突或重叠，则当前的BeanInfo对象优先于另外的BeanInfo对象。 具有较高索引的数组元素优先于具有较低索引的元素。

        结果
        一个 BeanInfo对象的数组，或者 null如果没有额外的 BeanInfo对象

      • getIcon

        Image getIcon​(int iconKind)
        返回可用于在工具箱或工具栏中表示bean的图像。

        有四种可能的图标类型：16 x 16色，32 x 32色，16 x 16单声道和32 x 32单声道。 如果您实现一个bean，以便它支持一个图标，建议使用16 x 16颜色。 另一个建议是为图标设置透明背景。

        参数
        iconKind - 请求的图标种类
        结果
        表示所请求的图标的图像对象，如果没有合适的图标可用， null
        另请参见：
        ICON_COLOR_16x16 ， ICON_COLOR_32x32 ， ICON_MONO_16x16 ， ICON_MONO_32x32
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.desktop
软件包 java.beans

Annotation Type BeanProperty

  • @Documented
@Target(METHOD)
@Retention(RUNTIME)
public @interface BeanProperty
    用于为自动生成的BeanInfo类指定一些属性相关信息的注释。 如果注释类具有相应的用户定义的BeanInfo类，则不会使用此注释，这并不意味着自动分析。 如果属性的读取和写入方法都被注释，则读取方法注释将具有更多优先级并替换写入方法注释。
    从以下版本开始：
    9
    另请参见：
    BeanInfo.getPropertyDescriptors()

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      boolean bound
      指示注释属性是否可以是 bound属性的值。
      String description
      short description的 descriptor的注释属性。
      String[] enumerationValues
      用于公共静态字段的名称数组，其中包含注释属性的有效值。
      boolean expert
      指示注释属性是否为 expert属性的值。
      boolean hidden
      指示注释属性是否为 hidden属性的值。
      boolean preferred
      指示注释属性是否为 preferred属性的值。
      boolean required
      指示注释属性是否为必需属性的值。
      boolean visualUpdate
      指示在注释属性更改后是否重新绘制相应组件的值。

    • Element Detail

      • bound

        boolean bound
        指示注释属性是否可以是bound属性的值。 此值仅适用于具有propertyChange事件集的bean。
        结果
        true如果注释属性可以是绑定属性; false否则。
        Default:
        真正

      • expert

        boolean expert
        指示注释属性是否为 expert属性的值。
        结果
        true如果注释的属性是expert属性; 否则为false 。
        Default:
        假

      • hidden

        boolean hidden
        指示注释属性是否为 hidden属性的值。
        结果
        true如果注释的属性是一个隐藏的属性; 否则为false 。
        Default:
        假

      • preferred

        boolean preferred
        指示注释属性是否为 preferred属性的值。
        结果
        true如果注释的属性是首选属性; 否则为false 。
        Default:
        假

      • required

        boolean required
        指示注释属性是否为必需属性的值。
        结果
        如果注释属性是必需属性， true ; 否则为false 。
        Default:
        假

      • visualUpdate

        boolean visualUpdate
        指示在注释属性更改后是否重新绘制相应组件的值。
        结果
        true如果相应的组件被重绘; 否则为false 。
        Default:
        假

      • description

        String description
        short description为 descriptor的注释属性。
        结果
        属性描述，如果未设置描述，则为空字符串。
        Default:
        “”

      • enumerationValues

        String[] enumerationValues
        用于公共静态字段的名称数组，其中包含注释属性的有效值。 这些名称用于生成enumerationValues feature attribute ，每个属性值必须包含以下项：属性值的可显示名称，实际属性值和用于代码生成器的Java代码段。
        结果
        注释属性的有效值的名称，如果未提供名称，则为空数组。
        Default:
        {}
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Beans (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class Beans

  • java.lang.Object
    • java.beans.Beans

  • public class Beans
extends Object
    这个类提供了一些通用的bean控制方法。
    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      Beans​()

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static Object getInstanceOf​(Object bean, Class<?> targetType)
      从给定的bean获取表示该源对象的指定类型视图的对象。
      static Object instantiate​(ClassLoader cls, String beanName)
      实例化JavaBean。
      static Object instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)
      实例化JavaBean。
      static Object instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
      已过时。
      建议使用instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      static boolean isDesignTime​()
      测试我们是否处于设计模式。
      static boolean isGuiAvailable​()
      确定bean是否可以承担GUI可用。
      static boolean isInstanceOf​(Object bean, Class<?> targetType)
      检查一个bean是否可以被看作给定的目标类型。
      static void setDesignTime​(boolean isDesignTime)
      用于指示我们是否在应用程序构建器环境中运行。
      static void setGuiAvailable​(boolean isGuiAvailable)
      用于指示我们是否在可以进行GUI交互的环境中运行。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Beans

        public Beans​()

    • 方法详细信息

      • instantiate

        public static Object instantiate​(ClassLoader cls,
                                 String beanName)
                          throws IOException,
                                 ClassNotFoundException

        实例化JavaBean。

        参数
        cls - 我们应该从中创建bean的类加载器。 如果为空，则使用系统类加载器。
        beanName - 类加载器中的bean的名称。 例如“sun.beanbox.foobah”
        结果
        一个JavaBean
        异常
        ClassNotFoundException - 如果无法找到序列化对象的类。
        IOException - 如果发生I / O错误。

      • instantiate

        public static Object instantiate​(ClassLoader cls,
                                 String beanName,
                                 BeanContext beanContext)
                          throws IOException,
                                 ClassNotFoundException

        实例化JavaBean。

        参数
        cls - 我们应该从中创建bean的类加载器。 如果为空，则使用系统类加载器。
        beanName - 类加载器中的bean的名称。 例如“sun.beanbox.foobah”
        beanContext - 嵌套新bean的BeanContext
        结果
        一个JavaBean
        异常
        ClassNotFoundException - 如果找不到序列化对象的类。
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.2

      • instantiate

        @Deprecated(since="9")
public static Object instantiate​(ClassLoader cls,
                                 String beanName,
                                 BeanContext beanContext,
                                 AppletInitializer initializer)
                          throws IOException,
                                 ClassNotFoundException
        已过时。 建议使用instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
        实例化一个bean。

        bean是基于相对于类加载器的名称创建的。 该名称应该是一个点分隔的名称，如“abc”。

        在Bean 1.0中，给定的名称可以指示序列化对象或类。 今后还可能增加其他机制。 在bean 1.0中，我们首先尝试将beanName作为序列化对象名称作为类名称。

        当使用beanName作为序列化对象名称时，我们将给定的beanName转换为资源路径名，并添加尾随的“.ser”后缀。 然后，我们尝试从该资源加载序列化对象。

        例如，给定一个beanName为“xy”，Beans.instantiate将首先尝试从资源“x / y.ser”读取序列化对象，如果失败，它将尝试加载类“xy”并创建一个实例的那个班。

        如果bean是java.applet.Applet的子类型，那么它将被给予一些特殊的初始化。 首先，它提供了一个默认的AppletStub和AppletContext。 其次，如果从类名中实例化，则调用applet的“init”方法。 （如果bean被反序列化，则跳过此步骤。）

        请注意，对于applet的bean来说，调用者的责任是在applet上调用“start”。 为了正确的行为，应该在将小程序添加到可见的AWT容器之后完成。

        请注意，通过beans.instantiate创建的applet在与浏览器中运行的applet稍微不同的环境中运行。 特别是，bean applet无法访问“参数”，所以他们可能希望提供属性get / set方法来设置参数值。 我们建议bean-applet开发人员对JDK appletviewer（参考浏览器环境）和BDK BeanBox（对于引用bean容器）来测试他们的bean-applet。

        参数
        cls - 我们应该从中创建bean的类加载器。 如果为空，则使用系统类加载器。
        beanName - 类加载器中的bean的名称。 例如“sun.beanbox.foobah”
        beanContext - 嵌套新bean的BeanContext
        initializer - 新bean的AppletInitializer
        结果
        一个JavaBean
        异常
        ClassNotFoundException - 如果无法找到序列化对象的类。
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.2

      • getInstanceOf

        public static Object getInstanceOf​(Object bean,
                                   Class<?> targetType)
        从给定的bean获取表示该源对象的指定类型视图的对象。

        结果可能是相同的对象或不同的对象。 如果请求的目标视图不可用，则返回给定的bean。

        此方法在Beans 1.0中作为钩子提供，以便将来可以添加更灵活的bean行为。

        参数
        bean - 要从中获取视图的对象。
        targetType - 我们想要获得的视图类型。
        结果
        表示源对象的指定类型视图的对象

      • isInstanceOf

        public static boolean isInstanceOf​(Object bean,
                                   Class<?> targetType)
        检查一个bean是否可以被看作给定的目标类型。 如果可以在给定的bean上使用Beans.getInstanceof方法来获取表示指定的targetType类型视图的对象，结果将成立。
        参数
        bean - 我们要从中获取一个视图的Bean。
        targetType - 我们想要得到的视图的类型。
        结果
        如果给定的bean支持给定的targetType，则为“true”。

      • isDesignTime

        public static boolean isDesignTime​()
        测试我们是否处于设计模式。
        结果
        如果我们在应用程序构建环境中运行，则为true。
        另请参见：
        DesignMode

      • isGuiAvailable

        public static boolean isGuiAvailable​()
        确定bean是否可以承担GUI可用。
        结果
        如果我们正在一个环境中运行，如果bean可以假定交互式GUI可用，那么它们可以弹出对话框等。这通常会在窗口环境中返回true，并且通常在服务器环境中返回false应用程序作为批处理作业的一部分运行。
        另请参见：
        Visibility

      • setDesignTime

        public static void setDesignTime​(boolean isDesignTime)
                          throws SecurityException
        用于指示我们是否在应用程序构建器环境中运行。

        请注意，此方法是安全检查的，不可用（例如）不可信applet。 更具体地说，如果有安全管理器，则调用其checkPropertiesAccess方法。 这可能会导致SecurityException。

        参数
        isDesignTime - 如果我们在应用程序构建器工具中， isDesignTime真。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许设置系统属性。
        另请参见：
        SecurityManager.checkPropertiesAccess()

      • setGuiAvailable

        public static void setGuiAvailable​(boolean isGuiAvailable)
                            throws SecurityException
        用于指示我们是否在可以进行GUI交互的环境中运行。

        请注意，此方法是安全检查的，不可用（例如）不可信applet。 更具体地说，如果有安全管理器，则调用其checkPropertiesAccess方法。 这可能会导致SecurityException。

        参数
        isGuiAvailable - 如果GUI交互可用， isGuiAvailable真。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许设置系统属性。
        另请参见：
        SecurityManager.checkPropertiesAccess()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ConstructorProperties (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.desktop
软件包 java.beans

Annotation Type ConstructorProperties

  • @Documented
@Target(CONSTRUCTOR)
@Retention(RUNTIME)
public @interface ConstructorProperties

    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。 例如：

       public class Point {
       @ConstructorProperties({"x", "y"})
       public Point(int x, int y) {
           this.x = x;
           this.y = y;
       }

       public int getX() {
           return x;
       }

       public int getY() {
           return y;
       }

       private final int x, y;
   }
    该注释示出了构造函数的第一参数可与被检索getX()方法，并与所述第二getY()方法。 由于参数名称在运行时通常不可用，没有注释，将无法知道参数是否对应于getX()和getY()或者相反。
    从以下版本开始：
    1.6

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String[] value
      吸气剂名称。

    • Element Detail

      • value

        String[] value

        吸气剂名称。

        结果
        与注释构造函数中的参数对应的getter名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Customizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface Customizer

  • public interface Customizer
    定制器类提供了一个完整的自定义GUI来定制目标Java Bean。

    每个定制程序都应该继承自java.awt.Component类，以便可以在AWT对话框或面板中实例化。

    每个定制器应该有一个空构造函数。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(PropertyChangeListener listener)
      注册PropertyChange事件的侦听器。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      删除PropertyChange事件的侦听器。
      void setObject​(Object bean)
      设置要定制的对象。

    • 方法详细信息

      • setObject

        void setObject​(Object bean)
        设置要定制的对象。 在将Customizer添加到任何父AWT容器之前，此方法只应调用一次。
        参数
        bean - 要定制的对象。

      • addPropertyChangeListener

        void addPropertyChangeListener​(PropertyChangeListener listener)
        注册PropertyChange事件的侦听器。 每当它以可能需要刷新显示的属性的方式更改目标bean时，定制程序将触发PropertyChange事件。
        参数
        listener - 触发PropertyChange事件时要调用的对象。

      • removePropertyChangeListener

        void removePropertyChangeListener​(PropertyChangeListener listener)
        删除PropertyChange事件的侦听器。
        参数
        listener - 要删除的PropertyChange监听器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DefaultPersistenceDelegate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class DefaultPersistenceDelegate

  • java.lang.Object
    • java.beans.PersistenceDelegate
      • java.beans.DefaultPersistenceDelegate

  • public class DefaultPersistenceDelegate
extends PersistenceDelegate
    DefaultPersistenceDelegate是抽象的PersistenceDelegate类的具体实现，默认情况下用于没有信息可用的类的委托。 DefaultPersistenceDelegate提供了基于公共API的基于公共API的持久性，用于遵循JavaBeans的惯例而不需要任何类特定配置的类。

    关键的假设是类具有一个无效构造函数，并且它的状态按照由Introspector返回的顺序由“setter”和“getter”对匹配对精确地表示。 除了为JavaBeans提供无代码的持久性之外， DefaultPersistenceDelegate还为具有构造函数的类实现持久存储提供了便利的方法，而构造函数虽然不是空值，但只需要一些属性值作为参数。

    从以下版本开始：
    1.4
    另请参见：
    DefaultPersistenceDelegate(String[]) ， Introspector

    • 构造方法摘要

      构造方法
      Constructor 描述
      DefaultPersistenceDelegate​()
      为具有无效构造函数的类创建持久性委托。
      DefaultPersistenceDelegate​(String[] constructorPropertyNames)
      为具有构造函数的类创建默认持久性委托，该构造函数的参数是由 constructorPropertyNames指定的属性名称的值。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
      这个 initialize方法的默认实现假定这个类型的对象中的所有状态都是通过匹配的“setter”和“getter”方法按Introspector返回的顺序公开的。
      protected Expression instantiate​(Object oldInstance, Encoder out)
      instantiate方法的此默认实现将返回一个表达式，其中包含预定义方法名“new”，表示对具有 DefaultPersistenceDelegate构造函数中指定的参数的构造函数的调用。
      protected boolean mutatesTo​(Object oldInstance, Object newInstance)
      如果指定构造函数中的参数数量不为零，并且类别为 oldInstance显式声明“equals”方法，则此方法返回值为 oldInstance.equals(newInstance) 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.beans.PersistenceDelegate

        writeObject

    • 构造方法详细信息

      • DefaultPersistenceDelegate

        public DefaultPersistenceDelegate​()
        为具有无效构造函数的类创建持久性委托。
        另请参见：
        DefaultPersistenceDelegate(java.lang.String[])

      • DefaultPersistenceDelegate

        public DefaultPersistenceDelegate​(String[] constructorPropertyNames)
        为具有构造函数的类创建默认持久性委托，该构造函数的参数是由constructorPropertyNames指定的属性名称的值。 构造函数参数是通过按照提供的顺序评估属性名来创建的。 要使用此类来指定用于特定类型的序列化的单个首选构造函数，我们将声明组成构造函数参数的属性的名称。 例如，不能定义空值构造函数的Font类可以使用以下持久性委托来处理：
          new DefaultPersistenceDelegate(new String[]{"name", "style", "size"});
        参数
        constructorPropertyNames - 此构造函数的参数的属性名称。
        另请参见：
        instantiate(java.lang.Object, java.beans.Encoder)

    • 方法详细信息

      • mutatesTo

        protected boolean mutatesTo​(Object oldInstance,
                            Object newInstance)
        如果指定构造函数中的参数数量不为零，并且类别为oldInstance显式声明“equals”方法，则此方法返回值为oldInstance.equals(newInstance) 。 否则，此方法使用超类的定义，如果两个实例的类相等，则返回true。
        重写：
        mutatesTo在 PersistenceDelegate
        参数
        oldInstance - 要复制的实例。
        newInstance - 要修改的实例。
        结果
        如果可以通过将一系列突变应用于 oldInstance创建 newInstance的等效副本， newInstance oldInstance 。
        另请参见：
        DefaultPersistenceDelegate(String[])

      • instantiate

        protected Expression instantiate​(Object oldInstance,
                                 Encoder out)
        instantiate方法的此默认实现将返回一个表达式，其中包含预定义方法名“new”，该方法表示对具有 DefaultPersistenceDelegate构造函数中指定的参数的构造函数的调用。
        Specified by:
        instantiate在 PersistenceDelegate
        参数
        oldInstance - 要实例化的实例。
        out - 代码输出流。
        结果
        值为 oldInstance的表达式。
        异常
        NullPointerException - 如果 out是 null并且该值用于该方法
        另请参见：
        DefaultPersistenceDelegate(String[])

      • initialize

        protected void initialize​(Class<?> type,
                          Object oldInstance,
                          Object newInstance,
                          Encoder out)
        这种initialize方法的默认实现假定这种类型的对象中保持的所有状态都是通过匹配的“setter”和“getter”方法按照Introspector返回的顺序公开的。 如果一个属性描述符定义了一个等于Boolean.TRUE的值的“transient”属性，该属性将被该默认实现忽略。 请注意，这种“瞬态”一词的使用与ObjectOutputStream使用的字段修饰符ObjectOutputStream 。

        对于每个非瞬态属性，创建一个表达式，其中使用无效“getter”方法应用于oldInstance 。 此表达式的值是要序列化的实例中的属性值。 如果此表达式的值在克隆环境中的目标值为mutatesTo ，则新值将初始化为使其等同于旧值。 在这种情况下，由于属性值没有改变，所以不需要调用相应的“setter”方法，并且不会发出语句。 如果不是，则该值的表达式将替换为另一个表达式（通常是构造函数），并调用相应的“setter”方法来在对象中安装新的属性值。 此方案从使用此委托的流中生成的输出中删除默认信息。

        在将这些语句传递到输出流中时，它们将被执行，对newInstance产生副作用。 在大多数情况下，这允许其值相互依赖的属性的问题实际上帮助序列化过程，使需要写入输出的语句数量更小。 一般来说，处理相互依赖的属性的问题减少到为一个类中的属性找到顺序的问题，使得没有属性值取决于后续属性的值。

        重写：
        initialize在 PersistenceDelegate
        参数
        type - 实例的类型
        oldInstance - 要复制的实例。
        newInstance - 要修改的实例。
        out - 应写入任何初始化语句的流。
        异常
        NullPointerException - 如果 out是 null
        另请参见：
        Introspector.getBeanInfo(java.lang.Class<?>) ， PropertyDescriptor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DesignMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface DesignMode

  • All Known Subinterfaces:
    BeanContext ， BeanContextServices
    所有已知实现类：
    BeanContextServicesSupport ， BeanContextSupport

    public interface DesignMode

    该接口旨在由java.beans.beancontext.BeanContext的实例实现或委派，以便传播到java.beans.beancontext.BeanContextChild实例（当前的“designTime”）属性的嵌套层次结构。

    JavaBeans¢规范定义了设计时间的概念，就像JavaBeans实例在其组合和定制期间在交互式设计，组合或构建工具中应该运行的模式，而JavaBean是applet，应用程序的一部分，而不是运行时，或其他实时Java可执行文件抽象。

    从以下版本开始：
    1.2
    另请参见：
    BeanContext ， BeanContextChild ， BeanContextMembershipListener ， PropertyChangeEvent

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String PROPERTYNAME
      从BeanContext或PropertyChangeEvents的其他来源触发的propertyName的标准值。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean isDesignTime​()
      值为true表示JavaBeans应该在设计时模式下运行，值为false表示运行时行为。
      void setDesignTime​(boolean designTime)
      设置“designTime”属性的“值”。

    • 字段详细信息

      • PROPERTYNAME

        static final String PROPERTYNAME
        从BeanContext或PropertyChangeEvents的其他来源触发的propertyName的标准值。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • setDesignTime

        void setDesignTime​(boolean designTime)
        设置“designTime”属性的“值”。

        如果实现对象是java.beans.beancontext.BeanContext或其子接口的实例，那么该BeanContext应该将PropertyChangeEvent引发到其注册的BeanContextMembershipListeners，其参数为：

        • propertyName - java.beans.DesignMode.PROPERTYNAME
        • oldValue - 以前的“designTime”值
        • newValue - “designTime”的当前值
        请注意，BeanContextChild调用与嵌套在其中的BeanContext关联的此方法是非法的。
        参数
        designTime - “designTime”属性的当前“值”
        另请参见：
        BeanContext ， BeanContextMembershipListener ， PropertyChangeEvent

      • isDesignTime

        boolean isDesignTime​()
        值为true表示JavaBeans应该在设计时模式下运行，值为false表示运行时行为。
        结果
        当前“值”的“designTime”属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Encoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class Encoder

  • java.lang.Object
    • java.beans.Encoder
  • 已知直接子类：
    XMLEncoder

    public class Encoder
extends Object
    一个Encoder是一个类，可用于创建根据其公共API编写JavaBean集合状态的文件或流。 Encoder与其持久性代表一起负责将对象图分解成一系列可用于创建它的Statement s和Expression s。 子类通常使用一些人类可读的形式（如Java源代码或XML）为这些表达式提供语法。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      Encoder​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object get​(Object oldInstance)
      在此流创建的环境中返回 oldInstance的临时值。
      ExceptionListener getExceptionListener​()
      获取此流的异常处理程序。
      PersistenceDelegate getPersistenceDelegate​(Class<?> type)
      返回给定类型的持久代理。
      Object remove​(Object oldInstance)
      删除此实例的条目，返回旧条目。
      void setExceptionListener​(ExceptionListener exceptionListener)
      将此流的异常处理程序设置为 exceptionListener 。
      void setPersistenceDelegate​(Class<?> type, PersistenceDelegate delegate)
      将指定的持久性委托与给定类型关联。
      void writeExpression​(Expression oldExp)
      该实现首先检查是否已经写入了具有该值的表达式。
      protected void writeObject​(Object o)
      将指定的对象写入输出流。
      void writeStatement​(Statement oldStm)
      写入报告 oldStm到流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Encoder

        public Encoder​()

    • 方法详细信息

      • writeObject

        protected void writeObject​(Object o)
        将指定的对象写入输出流。 序列化形式将表示一系列表达式，其组合效果将在读取输入流时创建一个等效对象。 默认情况下，该对象被假定为具有空值构造函数的JavaBean ，其状态由Introspector返回的匹配的“setter”和“getter”方法对。
        参数
        o - o的对象。
        另请参见：
        XMLDecoder.readObject()

      • setExceptionListener

        public void setExceptionListener​(ExceptionListener exceptionListener)
        将此流的异常处理程序设置为exceptionListener 。 当此流捕获可恢复的异常时，将通知异常处理程序。
        参数
        exceptionListener - 此流的异常处理程序 如果null将使用默认异常侦听器。
        另请参见：
        getExceptionListener()

      • getExceptionListener

        public ExceptionListener getExceptionListener​()
        获取此流的异常处理程序。
        结果
        该流的异常处理程序 如果没有明确设置，将返回默认的异常侦听器。
        另请参见：
        setExceptionListener(java.beans.ExceptionListener)

      • getPersistenceDelegate

        public PersistenceDelegate getPersistenceDelegate​(Class<?> type)
        返回给定类型的持久代理。 持续委托是按顺序应用以下规则计算的：
        1. 如果使用setPersistenceDelegate(java.lang.Class<?>, java.beans.PersistenceDelegate)方法将持久代理与给定类型相关联，则返回它。
        2. 然后，通过由给定类型的完全限定名称和“PersistenceDelegate”后缀组成的名称查找持久代理。 例如， Bean类的持久Bean应该命名为BeanPersistenceDelegate并位于同一个包中。
            public class Bean { ... }
 public class BeanPersistenceDelegate { ... }
          BeanPersistenceDelegate类的实例返回给Bean类。
        3. 如果类型为null ，则返回共享内部持久性委托，编码null值。
        4. 如果该类型是一个枚举声明，那么返回一个共享的内部持久性委托，它将通过名称对该枚举的常量进行编码。
        5. 如果类型是原始类型或相应的包装器，则返回共享内部持久性委托，该委托对给定类型的值进行编码。
        6. 如果类型是数组，则返回共享的内部持久性委托，该委托对相应类型和长度的数组进行编码，并将其每个元素视为属性。
        7. 如果类型是代理，则返回使用Proxy.newProxyInstance(java.lang.ClassLoader, java.lang.Class<?>[], java.lang.reflect.InvocationHandler)方法对代理实例进行编码的共享内部持久性委托。
        8. 如果BeanInfo这种类型有一个BeanDescriptor ，其定义的“persistenceDelegate”属性，则返回这个命名属性的值。
        9. 在所有其他情况下，将返回默认持久代理。 默认持久性委托假定该类型是JavaBean ，这意味着它具有默认构造函数，并且其状态可能由Introspector类返回的匹配的“setter”和“getter”方法进行表征 。 默认构造函数是具有最大数量的参数的构造函数，它具有ConstructorProperties注释。 如果没有一个构造函数具有ConstructorProperties注释，那么将使用nullary构造函数（没有参数的构造函数）。 例如，在下面的代码段，用于在null构造Foo类将被使用，而这两个参数的构造为Bar类将被使用。
            public class Foo {
     public Foo() { ... }
     public Foo(int x) { ... }
 }
 public class Bar {
     public Bar() { ... }
     @ConstructorProperties({"x"})
     public Bar(int x) { ... }
     @ConstructorProperties({"x", "y"})
     public Bar(int x, int y) { ... }
 }
        参数
        type - 对象的类
        结果
        给定类型的持久代理
        另请参见：
        setPersistenceDelegate(java.lang.Class<?>, java.beans.PersistenceDelegate) ，
Introspector.getBeanInfo(java.lang.Class<?>) ，
BeanInfo.getBeanDescriptor()

      • setPersistenceDelegate

        public void setPersistenceDelegate​(Class<?> type,
                                   PersistenceDelegate delegate)
        将指定的持久性委托与给定类型关联。
        参数
        type - 指定的持久性委托应用于的对象类
        delegate - 给定类型的实例的持久 delegate
        另请参见：
        getPersistenceDelegate(java.lang.Class<?>) ，
Introspector.getBeanInfo(java.lang.Class<?>) ，
BeanInfo.getBeanDescriptor()

      • remove

        public Object remove​(Object oldInstance)
        删除此实例的条目，返回旧条目。
        参数
        oldInstance - 应该删除的条目。
        结果
        已删除的条目。
        另请参见：
        get(java.lang.Object)

      • get

        public Object get​(Object oldInstance)
        在此流创建的环境中返回oldInstance的临时值。 持久mutatesTo可以使用其mutatesTo方法来确定该值是否可以被初始化以在输出处形成等效对象，或者是否必须重新实例化一个新对象。 如果流尚未看到此值，则返回null。
        参数
        oldInstance - 要查找的实例。
        结果
        对象，如果对象以前没有被看见，则为null。

      • writeStatement

        public void writeStatement​(Statement oldStm)
        将oldStm写入oldStm 。 oldStm应完全根据调用者环境编写，即目标和所有参数应该是正在写入的对象图的一部分。 这些表达式表示一系列“发生了什么”的表达式，它们告诉输出流如何生成像原始的对象图。

        该方法的实现将产生一个第二个表达式，以便在读取流时将存在的环境中表示相同的表达式。 这通过简单地通过调用目标和所有参数上的writeObject来构建一个新的表达式与结果。

        参数
        oldStm - oldStm的表达式。

      • writeExpression

        public void writeExpression​(Expression oldExp)
        该实现首先检查是否已经写入了具有该值的表达式。 如果不是，则使用与writeStatement相同的过程克隆表达式，并且通过调用writeObject将此表达式的值与克隆表达式的值进行writeObject 。
        参数
        oldExp - oldExp的表达式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class EventHandler

  • java.lang.Object
    • java.beans.EventHandler
  • All Implemented Interfaces:
    InvocationHandler

    public class EventHandler
extends Object
implements InvocationHandler
    EventHandler类提供了动态生成事件侦听器的支持，该侦听器的方法执行一个涉及传入事件对象和目标对象的简单语句。

    EventHandler类旨在由交互式工具（如应用程序构建器）使用，允许开发人员在bean之间建立连接。 通常，连接是从用户界面bean（事件源 ）到应用程序逻辑bean（ 目标 ）进行的。 这种最有效的连接将应用程序逻辑与用户界面隔离开来。 例如， EventHandler用于从一个连接JCheckBox到接受布尔值可以处理提取的复选框的状态，并直接将其传递给该方法，使得该方法是从用户界面层分离的方法。

    内部类是从用户界面处理事件的另一种更通用的方式。 EventHandler类只处理内部类可能使用的一个子集。 然而， EventHandler比内部类更好地与长期持久性方案相比。 此外，在大型应用中使用EventHandler ，其中实现了相同的接口多次可以减少应用程序的磁盘和内存占用。

    听众用EventHandler创建的这样一个小小的原因是EventHandler依赖的Proxy类共享相同接口的实现。 例如，如果您使用EventHandler create方法来使所有ActionListener在应用程序中，则所有操作监听器都将是单个类的实例（由Proxy类创建）。 一般来说，基于Proxy类的监听器需要每个监听器类型 （接口）创建一个监听器类，而内部类方法需要为每个监听器 （实现接口的对象）创建一个类。

    您一般不直接处理EventHandler实例。 相反，您可以使用EventHandler create一个来创建实现给定侦听器接口的对象。 此侦听器对象使用EventHandler对象来封装有关事件的信息，发生事件时要发送消息的对象，要发送的消息（方法）以及方法的任何参数。 以下部分将介绍如何使用create方法创建侦听器对象的create 。

    使用EventHandler的示例

    最简单的使用EventHandler是安装一个侦听器，它调用目标对象上没有参数的方法。 在下面的例子中，我们创建ActionListener调用该toFront上的一个实例方法javax.swing.JFrame 。
    myButton.addActionListener(
    (ActionListener)EventHandler.create(ActionListener.class, frame, "toFront"));
    当myButton被按下时，声明frame.toFront()将被执行。 通过定义ActionListener接口的新实现并向其中添加一个实例，可以获得相同的效果，并具有一些额外的编译时类型安全性：
    //Equivalent code using an inner class instead of EventHandler.
myButton.addActionListener(new ActionListener() {
    public void actionPerformed(ActionEvent e) {
        frame.toFront();
    }
});
    EventHandler的下一个最简单的使用是从侦听器接口（通常是一个事件对象）中的方法的第一个参数中提取一个属性值，并使用它来设置目标对象中的属性的值。 在下面的示例中，我们创建一个ActionListener ，将目标（myButton）对象的nextFocusableComponent属性设置为事件“source”属性的值。
    EventHandler.create(ActionListener.class, myButton, "nextFocusableComponent", "source")
    这将对应于以下内部类实现：
    //Equivalent code using an inner class instead of EventHandler.
new ActionListener() {
    public void actionPerformed(ActionEvent e) {
        myButton.setNextFocusableComponent((Component)e.getSource());
    }
}
    也可以创建一个EventHandler ，将传入的事件对象传递到目标的动作。 如果第四个EventHandler.create参数是一个空字符串，那么事件刚刚传递：
    EventHandler.create(ActionListener.class, target, "doActionEvent", "")
    这将对应于以下内部类实现：
    //Equivalent code using an inner class instead of EventHandler.
new ActionListener() {
    public void actionPerformed(ActionEvent e) {
        target.doActionEvent(e);
    }
}
    EventHandler可能最常见的EventHandler是从事件对象的源中提取属性值，并将此值设置为目标对象属性的值。 在以下示例中，我们创建一个ActionListener ，它将目标对象的“label”属性设置为源的“text”属性（“source”属性的值）的值。
    EventHandler.create(ActionListener.class, myButton, "label", "source.text")
    这将对应于以下内部类实现：
    //Equivalent code using an inner class instead of EventHandler.
new ActionListener {
    public void actionPerformed(ActionEvent e) {
        myButton.setLabel(((JTextField)e.getSource()).getText());
    }
}
    事件属性可以是“合格的”，其中包含用“。”分隔的任意数量的属性前缀。 字符。 出现在“。”之前的“合格”名称。 字符被作为应该应用的属性的名称，最左边首先是事件对象。

    例如，以下动作侦听器

    EventHandler.create(ActionListener.class, target, "a", "b.c.d")
    可以写成以下内部类（假设所有属性都有规范的getter方法并返回适当的类型）：
    //Equivalent code using an inner class instead of EventHandler.
new ActionListener {
    public void actionPerformed(ActionEvent e) {
        target.setA(e.getB().getC().isD());
    }
}
    目标属性也可以是“合格的”，具有用“。”分隔的任意数量的属性前缀。 字符。 例如，以下动作侦听器：
      EventHandler.create(ActionListener.class, target, "a.b", "c.d")
    可以写成以下内部类（假设所有属性都有规范的getter方法并返回适当的类型）：
      //Equivalent code using an inner class instead of EventHandler.
   new ActionListener {
     public void actionPerformed(ActionEvent e) {
         target.getA().setB(e.getC().isD());
    }
}

    由于EventHandler最终依赖反射来调用一种方法，我们建议您针对重载方法。 例如，如果目标是MyTarget类的实例，它被定义为：

      public class MyTarget {
     public void doIt(String);
     public void doIt(Object);
   }
    然后方法doIt过载。 EventHandler将调用基于源的适当方法。 如果源为null，那么任一方法都是合适的，并且调用的方法是未定义的。 因此，我们建议不要使用重载方法。
    从以下版本开始：
    1.4
    另请参见：
    Proxy ， EventObject

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventHandler​(Object target, String action, String eventPropertyName, String listenerMethodName)
      创建一个新的EventHandler对象; 您通常使用create方法之一，而不是直接调用此构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static <T> T create​(Class<T> listenerInterface, Object target, String action)
      创建一个 listenerInterface的实现，其中监听器界面中的 所有方法将处理程序的 action应用于 target 。
      static <T> T create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
      / **创建的实施 listenerInterface ，其中 所有的方法传递事件表达，的值 eventPropertyName ，到最后方法中的发言， action ，其被施加到 target 。
      static <T> T create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
      创建的实施 listenerInterface其中命名方法 listenerMethodName传递事件表达，的值 eventPropertyName ，在语句中的最终方法， action ，其被施加到 target 。
      String getAction​()
      返回此事件处理程序将设置的目标的可写属性的名称，或此事件处理程序将在目标上调用的方法的名称。
      String getEventPropertyName​()
      返回在应用于目标的操作中应该使用的事件的属性。
      String getListenerMethodName​()
      返回将触发操作的方法的名称。
      Object getTarget​()
      返回此事件处理程序将发送消息的对象。
      Object invoke​(Object proxy, 方法 method, Object[] arguments)
      从事件中提取适当的属性值，并将其传递 EventHandler此 EventHandler相关联的操作。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EventHandler

        @ConstructorProperties({"target","action","eventPropertyName","listenerMethodName"})
public EventHandler​(Object target,
                    String action,
                    String eventPropertyName,
                    String listenerMethodName)
        创建一个新的EventHandler对象; 您通常使用create方法之一，而不是直接调用此构造函数。 请参阅the general version of create的完整描述eventPropertyName和listenerMethodName参数。
        参数
        target - 将执行操作的对象
        action - 目标上的（可能合格的）属性或方法的名称
        eventPropertyName - 传入事件的可读属性的（可能限定的）名称
        listenerMethodName - 侦听器界面中触发操作的方法名称
        异常
        NullPointerException - 如果 target为空
        NullPointerException - 如果 action为空
        另请参见：
        EventHandler ， create(Class, Object, String, String, String) ， getTarget() ， getAction() ， getEventPropertyName() ， getListenerMethodName()

    • 方法详细信息

      • getTarget

        public Object getTarget​()
        返回此事件处理程序将发送消息的对象。
        结果
        这个事件处理程序的目标
        另请参见：
        EventHandler(Object, String, String, String)

      • getAction

        public String getAction​()
        返回此事件处理程序将设置的目标的可写属性的名称，或此事件处理程序将在目标上调用的方法的名称。
        结果
        这个事件处理程序的动作
        另请参见：
        EventHandler(Object, String, String, String)

      • getEventPropertyName

        public String getEventPropertyName​()
        返回在应用于目标的操作中应该使用的事件的属性。
        结果
        事件的财产
        另请参见：
        EventHandler(Object, String, String, String)

      • getListenerMethodName

        public String getListenerMethodName​()
        返回将触发操作的方法的名称。 返回值为null表示侦听器接口中的所有方法触发操作。
        结果
        将触发操作的方法的名称
        另请参见：
        EventHandler(Object, String, String, String)

      • invoke

        public Object invoke​(Object proxy,
                     方法 method,
                     Object[] arguments)
        从事件中提取适当的属性值，并将其传递 EventHandler此 EventHandler相关联的操作。
        Specified by:
        invoke在接口 InvocationHandler
        参数
        proxy - 代理对象
        method - 监听器界面中的方法
        arguments - 包含代理实例上方法调用中传递的参数值的对象数组，如果接口方法不带参数， null 。 原始类型的参数包含在适当的原始包装器类的实例中，例如java.lang.Integer或java.lang.Boolean 。
        结果
        将动作应用于目标的结果
        另请参见：
        EventHandler

      • create

        public static <T> T create​(Class<T> listenerInterface,
                           Object target,
                           String action)
        创建一个listenerInterface的实现，其中监听器界面中的所有方法将处理程序的action应用于target 。 这种方法是通过调用另一个更一般的create方法来实现的，而eventPropertyName和listenerMethodName采用值null 。 请参阅the general version of create的完整描述action参数。

        要创建一个ActionListener ，显示JDialog与dialog.show() ，可以写：

        EventHandler.create(ActionListener.class, dialog, "show")
        参数类型
        T - 要创建的类型
        参数
        listenerInterface - 创建代理的侦听器界面
        target - 将执行操作的对象
        action - 目标上的（可能合格的）属性或方法的名称
        结果
        一个实现 listenerInterface的对象
        异常
        NullPointerException - 如果 listenerInterface为空
        NullPointerException - 如果 target为空
        NullPointerException - 如果 action为空
        IllegalArgumentException -如果创建一个代理 listenerInterface失败对于任何由指定的限制 Proxy.newProxyInstance(java.lang.ClassLoader, java.lang.Class<?>[], java.lang.reflect.InvocationHandler)
        另请参见：
        create(Class, Object, String, String) ， Proxy.newProxyInstance(java.lang.ClassLoader, java.lang.Class<?>[], java.lang.reflect.InvocationHandler)

      • create

        public static <T> T create​(Class<T> listenerInterface,
                           Object target,
                           String action,
                           String eventPropertyName)
        / **创建的实施listenerInterface ，其中所有的方法传递事件表达，的值eventPropertyName ，到最后方法中的发言， action ，其被施加到target 。 这种方法是通过调用更一般的，实现的create方法实现的， listenerMethodName取null 。 请参阅the general version of create的完整描述action个eventPropertyName参数。

        要创建一个ActionListener ，将JLabel的文本设置为传入事件的JTextField源的文本值，可以使用以下代码：

        EventHandler.create(ActionListener.class, label, "text", "source.text");
        这相当于以下代码：
        //Equivalent code using an inner class instead of EventHandler.
new ActionListener() {
    public void actionPerformed(ActionEvent event) {
        label.setText(((JTextField)(event.getSource())).getText());
     }
};
        参数类型
        T - 要创建的类型
        参数
        listenerInterface - 创建代理的侦听器界面
        target - 将执行操作的对象
        action - 目标上的（可能合格的）属性或方法的名称
        eventPropertyName - 传入事件的可读属性的（可能限定的）名称
        结果
        一个实现 listenerInterface的对象
        异常
        NullPointerException - 如果 listenerInterface为空
        NullPointerException - 如果 target为空
        NullPointerException - 如果 action为空
        IllegalArgumentException -如果创建一个代理 listenerInterface失败对于任何由指定的限制 Proxy.newProxyInstance(java.lang.ClassLoader, java.lang.Class<?>[], java.lang.reflect.InvocationHandler)
        另请参见：
        create(Class, Object, String, String, String) ， Proxy.newProxyInstance(java.lang.ClassLoader, java.lang.Class<?>[], java.lang.reflect.InvocationHandler)

      • create

        public static <T> T create​(Class<T> listenerInterface,
                           Object target,
                           String action,
                           String eventPropertyName,
                           String listenerMethodName)
        创建的实施listenerInterface其中命名方法listenerMethodName传递事件表达，的值eventPropertyName ，在语句中的最终方法， action ，其被施加到target 。 所有其他侦听器方法什么都不做。

        eventPropertyName字符串用于从传入到目标方法的传入事件对象中提取值。 常见的情况是目标方法没有参数，在这种情况下， eventPropertyName应该使用null值。 或者，如果要将传入的事件对象直接传递到目标方法，则使用空字符串。 eventPropertyName字符串的格式是将每个方法或属性应用于从传入事件对象开始的上一个方法返回的值的一系列方法或属性。 语法是： propertyName{.propertyName}*其中propertyName匹配方法或属性。 例如，提取point从属性MouseEvent ，你可以使用任何"point"或者"getPoint"为eventPropertyName 。 为了提取从“文本”属性MouseEvent与JLabel源使用下列作为eventPropertyName ： "source.text" ， "getSource.text" "getSource.getText"或"source.getText" 。 如果无法找到方法，或者作为调用方法的一部分生成异常，则将在调度时抛出RuntimeException 。 例如，如果传入的事件对象为空，并且eventPropertyName为非空且不为空，则将抛出RuntimeException 。

        action参数与eventPropertyName参数的格式相同，后一个属性名称标识方法名称或可写属性。

        如果listenerMethodName为null接口中的所有方法触发action要在执行target 。

        例如，要创建一个MouseListener ，每当按下鼠标按钮时，将目标对象的origin属性设置为传入的MouseEvent的位置（值为mouseEvent.getPoint() ），则可以写入：

        EventHandler.create(MouseListener.class, target, "origin", "point", "mousePressed");
        这相当于编写一个MouseListener ，其中除mousePressed之外的所有方法都是no-ops：
        //Equivalent code using an inner class instead of EventHandler.
new MouseAdapter() {
    public void mousePressed(MouseEvent e) {
        target.setOrigin(e.getPoint());
    }
};
        参数类型
        T - 要创建的类型
        参数
        listenerInterface - 创建代理的侦听器接口
        target - 将执行操作的对象
        action - 目标上的（可能合格的）属性或方法的名称
        eventPropertyName - 传入事件的可读属性的（可能限定的）名称
        listenerMethodName - 侦听器界面中触发操作的方法的名称
        结果
        一个实现 listenerInterface的对象
        异常
        NullPointerException - 如果 listenerInterface为空
        NullPointerException - 如果 target为空
        NullPointerException - 如果 action为空
        IllegalArgumentException - 如果创建 IllegalArgumentException的代理因 listenerInterface指定的任何限制 失败
        另请参见：
        EventHandler ， Proxy.newProxyInstance(java.lang.ClassLoader, java.lang.Class<?>[], java.lang.reflect.InvocationHandler)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EventSetDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class EventSetDescriptor

  • java.lang.Object
    • java.beans.FeatureDescriptor
      • java.beans.EventSetDescriptor

  • public class EventSetDescriptor
extends FeatureDescriptor
    EventSetDescriptor描述给定的Java Bean触发的一组事件。

    给定的事件组在单个事件侦听器接口上作为方法调用传递，并且可以通过事件源提供的注册方法的调用来注册事件侦听器对象。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
      创建一个 EventSetDescriptor假设您遵循最简单的标准设计模式，其中一个命名事件“fred”（1）作为一个调用方式传递给接口FredListener的单一方法，（2）具有类型为FredEvent的单个参数和（ 3）FredListener可以通过对源组件的addFredListener方法的调用进行注册，并通过removeFredListener方法的调用进行删除。
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
      使用字符串名称从头创建一个 EventSetDescriptor 。
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
      该构造函数使用字符串名称从头开始创建一个EventSetDescriptor。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, 方法 addListenerMethod, 方法 removeListenerMethod)
      创建一个 EventSetDescriptor使用从无到有 java.lang.reflect.MethodDescriptor个 java.lang.Class对象。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod)
      创建一个 EventSetDescriptor使用从无到有 java.lang.reflect.Method个 java.lang.Class对象。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod, 方法 getListenerMethod)
      此构造函数从头开始使用java.lang.reflect.Method和java.lang.Class对象创建一个EventSetDescriptor。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      方法 getAddListenerMethod​()
      获取用于添加事件侦听器的方法。
      方法 getGetListenerMethod​()
      获取用于访问已注册事件侦听器的方法。
      MethodDescriptor[] getListenerMethodDescriptors​()
      获取目标侦听器界面的 MethodDescriptor s。
      方法[] getListenerMethods​()
      获取目标侦听器接口的方法。
      Class<?> getListenerType​()
      获取目标接口的 Class对象。
      方法 getRemoveListenerMethod​()
      获取用于删除事件侦听器的方法。
      boolean isInDefaultEventSet​()
      报告事件集是否在“默认”集中。
      boolean isUnicast​()
      通常情况来源是组播。
      void setInDefaultEventSet​(boolean inDefaultEventSet)
      将事件设置为“默认”集（或不是）。
      void setUnicast​(boolean unicast)
      将事件设置为单播（或不）。

      • Methods inherited from class java.beans.FeatureDescriptor

        attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • EventSetDescriptor

        public EventSetDescriptor​(Class<?> sourceClass,
                          String eventSetName,
                          Class<?> listenerType,
                          String listenerMethodName)
                   throws IntrospectionException
        创建一个 EventSetDescriptor假设您遵循最简单的标准设计模式，其中一个命名事件“fred”（1）作为调用接口FredListener的一个方法传递，（2）具有类型为FredEvent的单个参数， 3）FredListener可以通过对源组件的addFredListener方法的调用进行注册，并通过removeFredListener方法的调用进行删除。
        参数
        sourceClass - 该类触发事件。
        eventSetName - 事件的编程名称。 例如“fred”。 请注意，这通常应以小写字符开头。
        listenerType - 事件将传递到的目标界面。
        listenerMethodName - 当事件传递到其目标侦听器接口时将被调用的方法。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • EventSetDescriptor

        public EventSetDescriptor​(Class<?> sourceClass,
                          String eventSetName,
                          Class<?> listenerType,
                          String[] listenerMethodNames,
                          String addListenerMethodName,
                          String removeListenerMethodName)
                   throws IntrospectionException
        使用字符串名称从头创建一个 EventSetDescriptor 。
        参数
        sourceClass - 该类开火事件。
        eventSetName - 事件集的编程名称。 请注意，这通常应以小写字符开头。
        listenerType - 事件将被传递到的目标接口的类。
        listenerMethodNames - 当事件传递到其目标侦听器接口时将被调用的方法的名称。
        addListenerMethodName - 可用于注册事件侦听器对象的事件源上的方法名称。
        removeListenerMethodName - 可用于取消注册事件侦听器对象的事件源上的方法的名称。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • EventSetDescriptor

        public EventSetDescriptor​(Class<?> sourceClass,
                          String eventSetName,
                          Class<?> listenerType,
                          String[] listenerMethodNames,
                          String addListenerMethodName,
                          String removeListenerMethodName,
                          String getListenerMethodName)
                   throws IntrospectionException
        该构造函数使用字符串名称从头开始创建一个EventSetDescriptor。
        参数
        sourceClass - 该类开火事件。
        eventSetName - 事件集的编程名称。 请注意，这通常应以小写字符开头。
        listenerType - 事件将被传递到的目标接口的类。
        listenerMethodNames - 当事件传递到其目标侦听器接口时将被调用的方法的名称。
        addListenerMethodName - 可用于注册事件侦听器对象的事件源上的方法名称。
        removeListenerMethodName - 可用于取消注册事件侦听器对象的事件源上的方法的名称。
        getListenerMethodName - 可用于访问事件侦听器对象数组的事件源上的方法。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。
        从以下版本开始：
        1.4

      • EventSetDescriptor

        public EventSetDescriptor​(String eventSetName,
                          Class<?> listenerType,
                          方法[] listenerMethods,
                          方法 addListenerMethod,
                          方法 removeListenerMethod)
                   throws IntrospectionException
        使用 java.lang.reflect.Method和 java.lang.Class对象从头开始创建一个 EventSetDescriptor 。
        参数
        eventSetName - 事件集的编程名称。
        listenerType - 侦听器接口的类。
        listenerMethods - 描述目标侦听器中每个事件处理方法的Method对象数组。
        addListenerMethod - 可用于注册事件侦听器对象的事件源上的方法。
        removeListenerMethod - 可用于取消注册事件侦听器对象的事件源上的方法。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • EventSetDescriptor

        public EventSetDescriptor​(String eventSetName,
                          Class<?> listenerType,
                          方法[] listenerMethods,
                          方法 addListenerMethod,
                          方法 removeListenerMethod,
                          方法 getListenerMethod)
                   throws IntrospectionException
        此构造函数从头开始使用java.lang.reflect.Method和java.lang.Class对象创建一个EventSetDescriptor。
        参数
        eventSetName - 事件集的编程名称。
        listenerType - 侦听器接口的类。
        listenerMethods - 描述目标侦听器中每个事件处理方法的Method对象数组。
        addListenerMethod - 可用于注册事件侦听器对象的事件源上的方法。
        removeListenerMethod - 可用于取消注册事件侦听器对象的事件源上的方法。
        getListenerMethod - 可用于访问事件侦听器对象数组的事件源上的方法。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。
        从以下版本开始：
        1.4

      • EventSetDescriptor

        public EventSetDescriptor​(String eventSetName,
                          Class<?> listenerType,
                          MethodDescriptor[] listenerMethodDescriptors,
                          方法 addListenerMethod,
                          方法 removeListenerMethod)
                   throws IntrospectionException
        使用 java.lang.reflect.MethodDescriptor和 java.lang.Class对象从头创建一个 EventSetDescriptor 。
        参数
        eventSetName - 事件集的编程名称。
        listenerType - 侦听器接口的类。
        listenerMethodDescriptors - 描述目标侦听器中每个事件处理方法的MethodDescriptor对象数组。
        addListenerMethod - 可用于注册事件侦听器对象的事件源上的方法。
        removeListenerMethod - 可用于取消注册事件侦听器对象的事件源上的方法。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

    • 方法详细信息

      • getListenerType

        public Class<?> getListenerType​()
        获取目标接口的 Class对象。
        结果
        当触发事件时将被调用的目标接口的Class对象。

      • getListenerMethods

        public 方法[] getListenerMethods​()
        获取目标侦听器接口的方法。
        结果
        一组 方法对象，用于目标侦听器接口中的目标方法，当触发事件时将被调用。

      • getListenerMethodDescriptors

        public MethodDescriptor[] getListenerMethodDescriptors​()
        获取目标侦听器界面的 MethodDescriptor s。
        结果
        一组 MethodDescriptor对象，用于目标侦听器接口中的目标方法，当触发事件时将被调用。

      • getAddListenerMethod

        public 方法 getAddListenerMethod​()
        获取用于添加事件侦听器的方法。
        结果
        用于在事件源处注册侦听器的方法。

      • getRemoveListenerMethod

        public 方法 getRemoveListenerMethod​()
        获取用于删除事件侦听器的方法。
        结果
        用于在事件源处删除侦听器的方法。

      • getGetListenerMethod

        public 方法 getGetListenerMethod​()
        获取用于访问已注册事件侦听器的方法。
        结果
        用于访问事件源上的侦听器数组的方法，如果不存在，则返回null。
        从以下版本开始：
        1.4

      • setUnicast

        public void setUnicast​(boolean unicast)
        将事件设置为单播（或不）。
        参数
        unicast - 如果事件集是单播， unicast真。

      • isUnicast

        public boolean isUnicast​()
        通常情况来源是组播。 但是有一些严格单播的例外。
        结果
        true如果事件集是单播的。 默认为false 。

      • setInDefaultEventSet

        public void setInDefaultEventSet​(boolean inDefaultEventSet)
        将事件设置为“默认”集（或不是）。 默认情况下是true 。
        参数
        inDefaultEventSet - true如果事件集是在“默认”集， false如果不是

      • isInDefaultEventSet

        public boolean isInDefaultEventSet​()
        报告事件集是否在“默认”集中。
        结果
        true如果事件集是在“默认”集。 默认为true 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExceptionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface ExceptionListener

  • public interface ExceptionListener
    通知内部异常的ExceptionListener。
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void exceptionThrown​(异常 e)
      当可捕获的异常被捕获时，调用此方法。

    • 方法详细信息

      • exceptionThrown

        void exceptionThrown​(异常 e)
        当可捕获的异常被捕获时，调用此方法。
        参数
        e - 被捕获的例外。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Expression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class Expression

  • java.lang.Object
    • java.beans.Statement
      • java.beans.Expression

  • public class Expression
extends Statement
    一个Expression对象表示一个原始表达式，其中单个方法应用于目标和一组参数以返回结果 - 如"a.getFoo()" 。

    除了超级类的属性之外， Expression对象提供了一个值 ，该值是评估此表达式时返回的对象。 返回值通常不会由呼叫者提供，而不是通过动态发现的方法和调用它到第一个呼叫时计算getValue制成。

    从以下版本开始：
    1.4
    另请参见：
    getValue() ， setValue(java.lang.Object)

    • 构造方法摘要

      构造方法
      Constructor 描述
      Expression​(Object value, Object target, String methodName, Object[] arguments)
      使用指定的目标对象的指定值创建一个新的Expression对象，以调用由名称和参数数组指定的方法。
      Expression​(Object target, String methodName, Object[] arguments)
      为指定的目标对象创建一个新的Expression对象，以调用由名称和参数数组指定的方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void execute​()
      execute方法查找名称与 methodName属性相同的方法，并调用目标方法。
      Object getValue​()
      如果此实例的value属性尚未设置，则此方法使用这些参数动态地找到具有指定的methodName的方法并调用该实例。
      void setValue​(Object value)
      将此表达式的值设置为 value 。
      String toString​()
      使用Java风格的语法打印此表达式的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.beans.Statement

        getArguments, getMethodName, getTarget

    • 构造方法详细信息

      • Expression

        @ConstructorProperties({"target","methodName","arguments"})
public Expression​(Object target,
                  String methodName,
                  Object[] arguments)
        为指定的目标对象创建一个新的Expression对象，以调用由名称和参数数组指定的方法。

        target和methodName值不应该是null 。 否则尝试执行此Expression将导致一个NullPointerException 。 如果arguments值为null ，则使用空数组作为arguments属性的值。

        参数
        target - 此表达式的目标对象
        methodName - 在指定目标上调用方法的名称
        arguments - 调用指定方法的参数数组
        另请参见：
        getValue()

      • Expression

        public Expression​(Object value,
                  Object target,
                  String methodName,
                  Object[] arguments)
        使用指定的目标对象的指定值创建一个新的Expression对象，以调用由名称和参数数组指定的方法。 value值用作value属性的值，因此getValue()方法将返回，而不执行此Expression 。

        target和methodName值不应该是null 。 否则尝试执行此Expression将导致一个NullPointerException 。 如果arguments值为null ，则使用空数组作为arguments属性的值。

        参数
        value - 此表达式的值
        target - 此表达式的目标对象
        methodName - 在指定目标上调用方法的名称
        arguments - 调用指定方法的参数数组
        另请参见：
        setValue(java.lang.Object)

    • 方法详细信息

      • execute

        public void execute​()
             throws 异常
        execute方法查找名称与methodName属性相同的方法，并调用目标方法。 当目标的类定义了具有给定名称的许多方法时，实现应使用Java语言规范（15.11）中指定的算法选择最具体的方法。 目标和参数的动态类用于代替编译时类型信息，像方法类一样，原始值与其关联的包装器类之间的转换在内部进行处理。

        以下方法类型被处理为特殊情况：

        • 可以通过使用类对象作为目标来调用静态方法。
        • 保留方法名称“new”可以用于调用类的构造函数，就像所有类定义静态“新”方法一样。 构造函数调用通常被认为是Expression而不是Statement因为它们返回一个值。
        • List接口中定义的方法名称“get”和“set”也可以应用于数组实例，映射到Array类中同名的静态方法。

        如果调用的方法正常完成，则返回的值将复制到value属性中。 请注意， value属性设置为null ，如果底层方法的返回类型为void 。

        重写：
        execute在 Statement
        异常
        NullPointerException - 如果 target或 methodName属性的值为 null
        NoSuchMethodException - 如果找不到匹配的方法
        SecurityException - 如果安全管理器存在并且它拒绝方法调用
        异常 - 被调用的方法抛出
        从以下版本开始：
        1.7
        另请参见：
        方法

      • getValue

        public Object getValue​()
                throws 异常
        如果此实例的value属性尚未设置，则此方法使用这些参数动态地找到具有指定的methodName的方法并调用该实例。 方法调用的结果首先被复制到该表达式的value属性中，然后作为getValue的结果返回。 如果value属性已经设置，通过调用setValue或之前的一个调用getValue则返回value属性，而不用查找或调用该方法。

        默认情况下， Expression的value属性设置为唯一的私有（非null ）值，该值用作尚未调用该方法的内部指示。 返回值为null以与其他任何值相同的方式替换此默认值，以确保表达式从不被评估多次。

        有关如何使用目标和参数的动态类型选择方法的详细信息，请参阅execute方法。

        结果
        将此方法应用于这些参数的结果。
        异常
        异常 - 如果具有指定methodName的方法抛出异常
        另请参见：
        Statement.execute() ， setValue(java.lang.Object)

      • setValue

        public void setValue​(Object value)
        将此表达式的值设置为value 。 该值将由getValue方法返回，而不调用与此表达式关联的方法。
        参数
        value - 此表达式的值。
        另请参见：
        getValue()

      • toString

        public String toString​()
        使用Java风格的语法打印此表达式的值。
        重写：
        toString在 Statement
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FeatureDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class FeatureDescriptor

  • java.lang.Object
    • java.beans.FeatureDescriptor
  • 已知直接子类：
    BeanDescriptor ， EventSetDescriptor ， MethodDescriptor ， ParameterDescriptor ， PropertyDescriptor

    public class FeatureDescriptor
extends Object
    FeatureDescriptor类是PropertyDescriptor，EventSetDescriptor和MethodDescriptor等的常见基类。

    它支持一些可以为任何内省描述符设置和检索的常见信息。

    此外，它还提供了一个扩展机制，使得任意的属性/值对可以与设计特征相关联。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      FeatureDescriptor​()
      构造一个 FeatureDescriptor 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Enumeration<String> attributeNames​()
      获取此功能的与区域设置无关的名称的枚举。
      String getDisplayName​()
      获取此功能的本地化显示名称。
      String getName​()
      获取此功能的编程名称。
      String getShortDescription​()
      获取此功能的简短描述。
      Object getValue​(String attributeName)
      使用此功能检索命名属性。
      boolean isExpert​()
      “专家”标志用于区分专门用于专家用户的那些功能，用于普通用户。
      boolean isHidden​()
      “隐藏”标志用于识别仅用于工具使用的功能，不应该暴露于人类。
      boolean isPreferred​()
      “首选”标志用于识别对人类呈现特别重要的特征。
      void setDisplayName​(String displayName)
      设置此功能的本地化显示名称。
      void setExpert​(boolean expert)
      “专家”标志用于将针对专家用户的功能与旨在用于普通用户的功能区分开来。
      void setHidden​(boolean hidden)
      “隐藏”标志用于识别仅用于工具使用的功能，不应该暴露于人类。
      void setName​(String name)
      设置此功能的编程名称。
      void setPreferred​(boolean preferred)
      “首选”标志用于识别对人类呈现特别重要的特征。
      void setShortDescription​(String text)
      您可以将简短描述性字符串与功能相关联。
      void setValue​(String attributeName, Object value)
      将命名属性与此功能相关联。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FeatureDescriptor

        public FeatureDescriptor​()
        构造一个 FeatureDescriptor 。

    • 方法详细信息

      • getName

        public String getName​()
        获取此功能的编程名称。
        结果
        属性/方法/事件的编程名称

      • setName

        public void setName​(String name)
        设置此功能的编程名称。
        参数
        name - 属性/方法/事件的编程名称

      • getDisplayName

        public String getDisplayName​()
        获取此功能的本地化显示名称。
        结果
        属性/方法/事件的本地化显示名称。 这个默认值与其getName中的编程名称相同。

      • setDisplayName

        public void setDisplayName​(String displayName)
        设置此功能的本地化显示名称。
        参数
        displayName - 属性/方法/事件的本地化显示名称。

      • isExpert

        public boolean isExpert​()
        “专家”标志用于区分专门用于专家用户的那些功能，用于普通用户。
        结果
        如果此功能仅供专家使用，则为True。

      • setExpert

        public void setExpert​(boolean expert)
        “专家”标志用于将针对专家用户的功能与旨在用于普通用户的功能区分开来。
        参数
        expert - 如果此功能仅供专家使用， expert True。

      • isHidden

        public boolean isHidden​()
        “隐藏”标志用于识别仅用于工具使用的功能，不应该暴露于人类。
        结果
        如果这个功能应该被人类用户隐藏，就是真的。

      • setHidden

        public void setHidden​(boolean hidden)
        “隐藏”标志用于识别仅用于工具使用的功能，不应该暴露于人类。
        参数
        hidden - 如果此功能应从人类用户隐藏， hidden True。

      • isPreferred

        public boolean isPreferred​()
        “首选”标志用于识别对人类呈现特别重要的特征。
        结果
        如果此功能应优先向人类用户显示，则为真。
        从以下版本开始：
        1.2

      • setPreferred

        public void setPreferred​(boolean preferred)
        “首选”标志用于识别对人类呈现特别重要的特征。
        参数
        preferred - 如果此功能应优先向人类用户显示， preferred真。
        从以下版本开始：
        1.2

      • getShortDescription

        public String getShortDescription​()
        获取此功能的简短描述。
        结果
        与此属性/方法/事件相关联的本地化简短描述。 默认为显示名称。

      • setShortDescription

        public void setShortDescription​(String text)
        您可以将简短描述性字符串与功能相关联。 通常这些描述性字符串应少于40个字符。
        参数
        text - 与本属性/方法/事件相关联的（本地化）简短描述。

      • setValue

        public void setValue​(String attributeName,
                     Object value)
        将命名属性与此功能相关联。
        参数
        attributeName - 属性的区域设置独立名称
        value - 值。

      • getValue

        public Object getValue​(String attributeName)
        使用此功能检索命名属性。
        参数
        attributeName - 属性的与区域无关的名称
        结果
        属性的值。 如果属性未知，则可能为null。

      • attributeNames

        public Enumeration<String> attributeNames​()
        获取此功能的与区域设置无关的名称的枚举。
        结果
        枚举与setValue注册的任何属性的与区域设置无关的名称。

      • toString

        public String toString​()
        返回对象的字符串表示形式。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IndexedPropertyChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class IndexedPropertyChangeEvent

  • java.lang.Object
    • java.util.EventObject
      • java.beans.PropertyChangeEvent
        • java.beans.IndexedPropertyChangeEvent
  • All Implemented Interfaces:
    Serializable

    public class IndexedPropertyChangeEvent
extends PropertyChangeEvent
    只要符合JavaBeans¢规范（“bean”）的组件更改绑定的索引属性，就会传递“IndexedPropertyChange”事件。 此类是PropertyChangeEvent的扩展名，但包含已更改的属性的索引。

    如果旧值和新值未知，它们的真值可能会被提供。

    事件源可以发送一个空对象作为名称，以指示如果其属性已经更改的任意集合。 在这种情况下，旧值和新值也应为null。

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      IndexedPropertyChangeEvent​(Object source, String propertyName, Object oldValue, Object newValue, int index)
      构造一个新的 IndexedPropertyChangeEvent对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getIndex​()
      获取已更改的属性的索引。

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.beans.PropertyChangeEvent

        getNewValue, getOldValue, getPropagationId, getPropertyName, setPropagationId, toString

    • 构造方法详细信息

      • IndexedPropertyChangeEvent

        public IndexedPropertyChangeEvent​(Object source,
                                  String propertyName,
                                  Object oldValue,
                                  Object newValue,
                                  int index)
        构造一个新的 IndexedPropertyChangeEvent对象。
        参数
        source - 触发事件的bean。
        propertyName - 已更改的属性的编程名称。
        oldValue - 物业的旧价值。
        newValue - 物业的新价值。
        index - 已更改的属性元素的索引。

    • 方法详细信息

      • getIndex

        public int getIndex​()
        获取已更改的属性的索引。
        结果
        指定更改的属性元素的索引。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IndexedPropertyDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class IndexedPropertyDescriptor

  • java.lang.Object
    • java.beans.FeatureDescriptor
      • java.beans.PropertyDescriptor
        • java.beans.IndexedPropertyDescriptor

  • public class IndexedPropertyDescriptor
extends PropertyDescriptor
    IndexedPropertyDescriptor描述了一个像数组一样的属性，并且具有索引的读取和/或索引的写入方法来访问数组的特定元素。

    索引属性还可以提供简单的非索引读写方法。 如果这些存在，它们读取和写入由索引读取方法返回的类型的数组。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass)
      该构造函数通过使用getFoo和setFoo访问器方法为索引访问和数组访问来构造遵循标准Java约定的属性的IndexedPropertyDescriptor。
      IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的方法名称，包括索引和非索引。
      IndexedPropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod, 方法 indexedReadMethod, 方法 indexedWriteMethod)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此 PropertyDescriptor与指定对象进行比较。
      Class<?> getIndexedPropertyType​()
      返回索引属性的Java类型信息。
      方法 getIndexedReadMethod​()
      获取应用于读取索引属性值的方法。
      方法 getIndexedWriteMethod​()
      获取应用于编写索引属性值的方法。
      int hashCode​()
      返回对象的哈希码值。
      void setIndexedReadMethod​(方法 readMethod)
      设置应用于读取索引属性值的方法。
      void setIndexedWriteMethod​(方法 writeMethod)
      设置应用于编写索引属性值的方法。

      • Methods inherited from class java.beans.FeatureDescriptor

        attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.beans.PropertyDescriptor

        createPropertyEditor, getPropertyEditorClass, getPropertyType, getReadMethod, getWriteMethod, isBound, isConstrained, setBound, setConstrained, setPropertyEditorClass, setReadMethod, setWriteMethod

    • 构造方法详细信息

      • IndexedPropertyDescriptor

        public IndexedPropertyDescriptor​(String propertyName,
                                 Class<?> beanClass)
                          throws IntrospectionException
        该构造函数通过使用getFoo和setFoo访问器方法为索引访问和数组访问来构造遵循标准Java约定的属性的IndexedPropertyDescriptor。

        因此，如果参数名称为“fred”，则将假设存在索引读取器方法“getFred”，一种非索引（数组）读取器方法，也称为“getFred”，索引的写入器方法“setFred”，最后是非索引作者方法“setFred”。

        参数
        propertyName - 属性的编程名称。
        beanClass - 目标bean的Class对象。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • IndexedPropertyDescriptor

        public IndexedPropertyDescriptor​(String propertyName,
                                 Class<?> beanClass,
                                 String readMethodName,
                                 String writeMethodName,
                                 String indexedReadMethodName,
                                 String indexedWriteMethodName)
                          throws IntrospectionException
        此构造函数使用简单属性的名称，以及用于读取和写入属性的方法名称，包括索引和非索引。
        参数
        propertyName - 属性的编程名称。
        beanClass - 目标bean的Class对象。
        readMethodName - 用于将属性值读取为数组的方法的名称。 如果属性为只写或必须编入索引，则可以为null。
        writeMethodName - 用于将属性值写入数组的方法的名称。 如果属性为只读或必须编入索引，则可以为null。
        indexedReadMethodName - 用于读取索引属性值的方法的名称。 如果属性是只写的，可能为null。
        indexedWriteMethodName - 用于编写索引属性值的方法的名称。 如果属性是只读的，则可以为null。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • IndexedPropertyDescriptor

        public IndexedPropertyDescriptor​(String propertyName,
                                 方法 readMethod,
                                 方法 writeMethod,
                                 方法 indexedReadMethod,
                                 方法 indexedWriteMethod)
                          throws IntrospectionException
        此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
        参数
        propertyName - 属性的编程名称。
        readMethod - 用于将属性值读取为数组的方法。 如果属性为只写或必须编入索引，则可以为null。
        writeMethod - 用于将属性值写入数组的方法。 如果属性为只读或必须编入索引，则可以为null。
        indexedReadMethod - 用于读取索引属性值的方法。 如果属性是只写的，可能为null。
        indexedWriteMethod - 用于编写索引属性值的方法。 如果属性是只读的，则可以为null。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

    • 方法详细信息

      • getIndexedReadMethod

        public 方法 getIndexedReadMethod​()
        获取应用于读取索引属性值的方法。
        结果
        应该用于读取索引属性值的方法。 如果属性未编入索引或是只写，则可能返回null。

      • setIndexedReadMethod

        public void setIndexedReadMethod​(方法 readMethod)
                          throws IntrospectionException
        设置应用于读取索引属性值的方法。
        参数
        readMethod - 新的索引读取方法。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。
        从以下版本开始：
        1.2

      • getIndexedWriteMethod

        public 方法 getIndexedWriteMethod​()
        获取应用于编写索引属性值的方法。
        结果
        应用于编写索引属性值的方法。 如果属性未编入索引或只读，则可能返回null。

      • setIndexedWriteMethod

        public void setIndexedWriteMethod​(方法 writeMethod)
                           throws IntrospectionException
        设置应用于编写索引属性值的方法。
        参数
        writeMethod - 新的索引写入方法。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。
        从以下版本开始：
        1.2

      • getIndexedPropertyType

        public Class<?> getIndexedPropertyType​()
        返回索引属性的Java类型信息。 请注意， Class对象可能会描述原始Java类型，例如int 。 该类型由索引读取方法返回或用作索引写入方法的参数类型。
        结果
        表示Java类型信息的 Class对象，如果类型无法确定， null

      • equals

        public boolean equals​(Object obj)
        将此PropertyDescriptor与指定对象进行比较。 如果对象相同，则返回true。 如果读取，写入，属性类型，属性编辑器和标志等同，则两个PropertyDescriptor是相同的。
        重写：
        equals在 PropertyDescriptor
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        从以下版本开始：
        1.4
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 有关完整的说明，请参阅Object.hashCode() 。
        重写：
        hashCode在 PropertyDescriptor
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.5
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IntrospectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class IntrospectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.beans.IntrospectionException
  • All Implemented Interfaces:
    Serializable

    public class IntrospectionException
extends 异常
    内省时发生异常时抛出。

    典型的原因包括无法将字符串类名称映射到Class对象，无法解析字符串方法名称，或指定其预期用途具有错误类型签名的方法名称。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IntrospectionException​(String mess)
      构造一个 IntrospectionException的详细消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IntrospectionException

        public IntrospectionException​(String mess)
        构造一个 IntrospectionException的详细消息。
        参数
        mess - Descriptive message
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Introspector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class Introspector

  • java.lang.Object
    • java.beans.Introspector

  • public class Introspector
extends Object
    Introspector类提供了一种标准的工具来了解目标Java Bean支持的属性，事件和方法。

    对于这三种信息中的每一种，Introspector将分别分析bean的类和超类，寻找显式或隐式信息，并使用该信息构建一个全面描述目标bean的BeanInfo对象。

    对于每个类“Foo”，如果存在相应的“FooBeanInfo”类，在查询信息时提供非空值，则显式信息可能可用。 我们首先通过获取目标bean类的完整的包限定名称并附加“BeanInfo”来形成一个新的类名称来查找BeanInfo类。 如果失败，那么我们将使用该名称的最终类名组件，并在BeanInfo包搜索路径中指定的每个包中查找该类。

    因此，对于诸如“sun.xyz.OurButton”之类的类，我们将首先查找一个名为“sun.xyz.OurButtonBeanInfo”的BeanInfo类，如果失败，我们将在BeanInfo搜索路径中查找一个OurButtonBeanInfo类的每个包。 使用默认搜索路径，这将意味着寻找“sun.beans.infos.OurButtonBeanInfo”。

    如果一个类提供了关于自身的显式BeanInfo，那么我们将它们添加到从分析任何派生类中获得的BeanInfo信息中，但是我们认为显式信息对于当前类及其基类是确定的，并且不再进一步超级链。

    如果我们没有在类上找到明确的BeanInfo，我们使用低级反射来研究类的方法，并应用标准设计模式来识别属性访问器，事件源或公共方法。 然后，我们继续分析类的超类，并添加其中的信息（也可能在超类链上）。

    有关内省和设计模式的更多信息，请参阅JavaBeans™ specification 。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int IGNORE_ALL_BEANINFO
      标记以表示忽略所有beaninfo。
      static int IGNORE_IMMEDIATE_BEANINFO
      标记表示忽略直接beaninfo。
      static int USE_ALL_BEANINFO
      用来表示使用所有beaninfo的标志。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static String decapitalize​(String name)
      实用方法来取一个字符串并将其转换为正常的Java变量名称大小写。
      static void flushCaches​()
      冲洗所有Introspector的内部缓存。
      static void flushFromCaches​(Class<?> clz)
      刷新内部缓存信息给一个给定的类。
      static BeanInfo getBeanInfo​(Class<?> beanClass)
      内省Java Bean并了解其所有属性，暴露的方法和事件。
      static BeanInfo getBeanInfo​(Class<?> beanClass, int flags)
      对Java bean进行内省，并了解其所有属性，公开方法和事件，并遵守一些控制标志。
      static BeanInfo getBeanInfo​(Class<?> beanClass, Class<?> stopClass)
      内省Java bean并了解其属性，暴露的方法，低于给定的“停止”点。
      static BeanInfo getBeanInfo​(Class<?> beanClass, Class<?> stopClass, int flags)
      内省Java Bean并了解其所有属性，暴露的方法和事件，低于给定的 stopClass点，受到一些控制 flags 。
      static String[] getBeanInfoSearchPath​()
      获取将用于查找BeanInfo类的包名称列表。
      static void setBeanInfoSearchPath​(String[] path)
      更改将用于查找BeanInfo类的包名称列表。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • USE_ALL_BEANINFO

        public static final int USE_ALL_BEANINFO
        用来表示使用所有beaninfo的标志。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • IGNORE_IMMEDIATE_BEANINFO

        public static final int IGNORE_IMMEDIATE_BEANINFO
        标记表示忽略直接beaninfo。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

      • IGNORE_ALL_BEANINFO

        public static final int IGNORE_ALL_BEANINFO
        标记以表示忽略所有beaninfo。
        从以下版本开始：
        1.2
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getBeanInfo

        public static BeanInfo getBeanInfo​(Class<?> beanClass)
                            throws IntrospectionException
        内省Java Bean并了解其所有属性，暴露的方法和事件。

        如果Java Bean的BeanInfo类之前已经被Introspected，那么BeanInfo类将从BeanInfo缓存中检索。

        参数
        beanClass - 要分析的bean类。
        结果
        描述目标bean的BeanInfo对象。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。
        另请参见：
        flushCaches() ， flushFromCaches(java.lang.Class<?>)

      • getBeanInfo

        public static BeanInfo getBeanInfo​(Class<?> beanClass,
                                   int flags)
                            throws IntrospectionException
        对Java bean进行内省，并了解其所有属性，公开方法和事件，并遵守一些控制标志。

        如果Java Bean的BeanInfo类之前已经基于相同的参数进行了Introspected，那么BeanInfo类将从BeanInfo缓存中检索。

        参数
        beanClass - 要分析的bean类。
        flags - 控制内省的标志。 如果flags == USE_ALL_BEANINFO，那么我们使用我们可以发现的所有BeanInfo类。 如果flags == IGNORE_IMMEDIATE_BEANINFO，那么我们忽略与指定的beanClass关联的任何BeanInfo。 如果flags == IGNORE_ALL_BEANINFO，那么我们忽略与指定的beanClass或其任何父类相关联的所有BeanInfo。
        结果
        描述目标bean的BeanInfo对象。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。
        从以下版本开始：
        1.2

      • getBeanInfo

        public static BeanInfo getBeanInfo​(Class<?> beanClass,
                                   Class<?> stopClass)
                            throws IntrospectionException
        内省Java bean并了解其属性，暴露的方法，低于给定的“停止”点。

        如果Java Bean的BeanInfo类之前已经基于相同的参数进行了Introspected，那么BeanInfo类将从BeanInfo缓存中检索。

        参数
        beanClass - 要分析的bean类。
        stopClass - 停止分析的基础。 在分析中将忽略stopClass或其基类中的任何方法/属性/事件。
        结果
        bean的BeanInfo
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • getBeanInfo

        public static BeanInfo getBeanInfo​(Class<?> beanClass,
                                   Class<?> stopClass,
                                   int flags)
                            throws IntrospectionException
        对Java Bean进行内省，并了解其所有属性，暴露的方法和事件，低于给定的stopClass点，受控于一些控件flags 。
        USE_ALL_BEANINFO
        可以使用任何可以发现的BeanInfo。
        IGNORE_IMMEDIATE_BEANINFO
        与指定的beanClass关联的任何BeanInfo将被忽略。
        IGNORE_ALL_BEANINFO
        与指定的beanClass或其任何父类相关联的任何BeanInfo将被忽略。
        在分析中将忽略stopClass或其父类中的任何方法/属性/事件。

        如果Java Bean的BeanInfo类先前已经基于相同的参数进行内省，那么BeanInfo类将从BeanInfo缓存中检索。

        参数
        beanClass - 要分析的bean类
        stopClass - 停止分析的父类
        flags - 控制内省的标志
        结果
        描述目标bean的BeanInfo对象
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常
        从以下版本开始：
        1.7

      • decapitalize

        public static String decapitalize​(String name)
        实用方法来取一个字符串并将其转换为正常的Java变量名称大小写。 这通常意味着将第一个字符从大写字母转换为小写，但是在（异常）特殊情况下，如果有多个字符，并且第一个和第二个字符都是大写字母，我们将其单独放置。

        因此，“FooBah”变为“fooBah”，“X”变成“x”，但是“URL”保持为“URL”。

        参数
        name - 要 name的字符串。
        结果
        字符串的decapitalized版本。

      • getBeanInfoSearchPath

        public static String[] getBeanInfoSearchPath​()
        获取将用于查找BeanInfo类的包名称列表。
        结果
        将搜索的包名称数组，以便找到BeanInfo类。 该数组的默认值是依赖于实现的; 例如，Sun实现最初设置为{“sun.beans.infos”}。

      • setBeanInfoSearchPath

        public static void setBeanInfoSearchPath​(String[] path)
        更改将用于查找BeanInfo类的包名称列表。 如果参数路径为空，则此方法的行为是未定义的。

        首先，如果有安全管理器，则调用其checkPropertiesAccess方法。 这可能会导致SecurityException。

        参数
        path - 包名称数组。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许设置系统属性。
        另请参见：
        SecurityManager.checkPropertiesAccess()

      • flushCaches

        public static void flushCaches​()
        冲洗所有Introspector的内部缓存。 通常不需要这种方法。 通常只需要先进的工具，就地更新现有的“Class”对象，并且需要使Introspector重新分析现有的Class对象。
        从以下版本开始：
        1.2

      • flushFromCaches

        public static void flushFromCaches​(Class<?> clz)
        刷新内部缓存信息给一个给定的类。 通常不需要这种方法。 通常只需要先进的工具，就地更新现有的“Class”对象，并且需要使Introspector重新分析现有的Class对象。 请注意，只有与目标Class对象关联的直接状态才会被刷新。 我们不刷新具有相同名称的其他Class对象的状态，即使它们的状态可能包含从目标Class对象间接获得的信息，我们也不会为任何相关的Class对象（如子类）刷新状态。
        参数
        clz - 要刷新的类对象。
        异常
        NullPointerException - 如果Class对象为空。
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.beans (Java SE 9 & JDK 9 )

java.beans

Interfaces

  • AppletInitializer
  • BeanInfo
  • Customizer
  • DesignMode
  • ExceptionListener
  • PropertyChangeListener
  • PropertyEditor
  • VetoableChangeListener
  • Visibility

Classes

  • BeanDescriptor
  • Beans
  • DefaultPersistenceDelegate
  • Encoder
  • EventHandler
  • EventSetDescriptor
  • Expression
  • FeatureDescriptor
  • IndexedPropertyChangeEvent
  • IndexedPropertyDescriptor
  • Introspector
  • MethodDescriptor
  • ParameterDescriptor
  • PersistenceDelegate
  • PropertyChangeEvent
  • PropertyChangeListenerProxy
  • PropertyChangeSupport
  • PropertyDescriptor
  • PropertyEditorManager
  • PropertyEditorSupport
  • SimpleBeanInfo
  • Statement
  • VetoableChangeListenerProxy
  • VetoableChangeSupport
  • XMLDecoder
  • XMLEncoder

Exceptions

  • IntrospectionException
  • PropertyVetoException

注解类型

  • BeanProperty
  • ConstructorProperties
  • JavaBean
  • Transient


java.beans (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.beans

包含与开发bean相关的类 - 基于JavaBeans架构的组件。 bean中的一些类在应用程序中运行时使用。 例如，事件类被bean使用，该bean会触发属性和可变更改事件（请参阅PropertyChangeEvent ）。 但是，此包中的大多数类都是由bean编辑器（即用于自定义和组合bean以创建应用程序的开发环境）使用的。 特别地，这些类帮助bean编辑器创建一个用户界面来定制该bean。 例如，bean可能包含bean编辑器可能不知道如何处理的特殊类型的属性。 通过使用PropertyEditor接口，bean开发人员可以为此特殊类型提供编辑器。

为了最小化bean使用的资源，bean编辑器使用的类只有在编辑bean时加载。 当bean在应用程序中运行时，并不需要它们，因此不会被加载。 这些信息保存在所谓的bean-info中（参见BeanInfo ）。

除非明确说明，否则空值或空字符串不是此程序包中方法的有效参数。 如果使用这些参数，可能会看到异常。

长期坚持

从v1.4开始， java.beans包为长期持久化提供支持 - 读取和写入一个bean作为其属性值的文本表示形式。 属性值被视为bean，并被递归地读取或写入以捕获它们的公开可用状态。 这种方法适用于长期存储，因为它仅依赖于公共API，而不是可能发生变更的私有实现。
Note: The persistence scheme cannot automatically instantiate custom inner classes, such as you might use for event handlers. By using the EventHandler class instead of inner classes for custom event handlers, you can avoid this problem.

您分别使用XMLDecoder和XMLEncoder类读取和写入XML格式的bean 。 持久性方案的一个显着特征是在bean中读取不需要bean的特殊知识。

另一方面，写出一个bean有时需要bean的类型的特殊知识。 如果bean的状态只能使用无参数构造函数和public getter和setter方法表示，则不需要特殊的知识。 否则，bean需要一个自定义持久性委托 - 负责编写特定类型的bean的对象。 JDK中提供的从java.awt.Component所有类以及其所有属性都将自动具有持久java.awt.Component 。

如果您需要（或选择）为bean提供持久代理 ，则可以使用DefaultPersistenceDelegate实例或创建自己的PersistenceDelegate子类来PersistenceDelegate 。 如果bean需要持久性委托的唯一原因是因为要使用属性值作为参数调用bean的构造函数，则可以使用单参数DefaultPersistenceDelegate构造函数来创建bean的持久性委托。 否则，您需要实现您自己的持久代理，您可能需要以下类：

PersistenceDelegate
200新新新新旗新新200新新新旗新新旗新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200新新200 您的子类应该使用其对bean类型的了解，以提供任何创建bean并恢复其状态的Statement和Expression 。
Statement
X- 包含一组方法参数。
Expression
用于返回值的方法的Statement的子类。

创建持久setPersistenceDelegate ，您可以使用setPersistenceDelegate方法进行XMLEncoder 。

相关文档

有关概述，架构和教程文档，请参阅：
  • JavaBeans ， Java教程中的一个小径。
  • Long-Term Persistence ， Swing Connection中的一篇文章。
  • 接口摘要
    接口 描述
    AppletInitializer Deprecated.
    Applet API已被弃用。
    BeanInfo
    使用 BeanInfo接口创建一个 BeanInfo类，并提供关于bean的方法，属性，事件和其他功能的显式信息。
    Customizer
    定制器类提供了一个完整的自定义GUI来定制目标Java Bean。
    DesignMode
    该接口旨在由java.beans.beancontext.BeanContext的实例实现或委派，以便传播到java.beans.beancontext.BeanContextChild实例（当前的“designTime”）属性的嵌套层次结构。
    ExceptionListener
    通知内部异常的ExceptionListener。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    PropertyEditor
    PropertyEditor类提供对允许用户编辑给定类型的属性值的GUI的支持。
    VetoableChangeListener
    当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
    Visibility
    在某些情况下，可能在GUI不可用的服务器上运行bean。
  • 类摘要
    Class 描述
    BeanDescriptor
    BeanDescriptor提供有关“bean”的全局信息，包括其Java类，其displayName等。
    Beans
    这个类提供了一些通用的bean控制方法。
    DefaultPersistenceDelegate
    DefaultPersistenceDelegate是抽象 PersistenceDelegate类的具体实现，默认情况下用于不提供信息的类的委托。
    Encoder
    一个 Encoder是一个类，可用于创建根据其公共API编码JavaBean集合的状态的文件或流。
    EventHandler
    EventHandler类提供对动态生成事件侦听器的支持，该侦听器的方法执行涉及传入事件对象和目标对象的简单语句。
    EventSetDescriptor
    EventSetDescriptor描述给定的Java Bean触发的一组事件。
    Expression
    一个 Expression对象表示一个原始表达式，其中单个方法应用于目标和一组参数以返回结果 - 如 "a.getFoo()" 。
    FeatureDescriptor
    FeatureDescriptor类是PropertyDescriptor，EventSetDescriptor和MethodDescriptor等的常见基类。
    IndexedPropertyChangeEvent
    只要符合JavaBeans¢规范（“bean”）的组件更改绑定的索引属性，就会传递“IndexedPropertyChange”事件。
    IndexedPropertyDescriptor
    IndexedPropertyDescriptor描述了一个像数组一样的属性，并且具有索引的读取和/或索引的写入方法来访问数组的特定元素。
    Introspector
    Introspector类提供了一种标准的工具来了解目标Java Bean支持的属性，事件和方法。
    MethodDescriptor
    MethodDescriptor描述了Java Bean支持的特定方法，用于从其他组件进行外部访问。
    ParameterDescriptor
    ParameterDescriptor类允许bean实现者提供关于每个参数的附加信息，超出java.lang.reflect.Method类提供的低级类型信息。
    PersistenceDelegate
    PersistenceDelegate类负责根据类的公共API中的方法来表达给定类的实例的状态。
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListenerProxy
    一个类扩展了 EventListenerProxy专门用于添加一个“绑定”属性的 PropertyChangeListener 。
    PropertyChangeSupport
    这是一个可以由支持绑定属性的bean使用的实用程序类。
    PropertyDescriptor
    PropertyDescriptor描述了Java Bean通过一对访问器方法导出的一个属性。
    PropertyEditorManager
    PropertyEditorManager可用于查找任何给定类型名称的属性编辑器。
    PropertyEditorSupport
    这是一个帮助构建属性编辑器的支持类。
    SimpleBeanInfo
    这是一个支持类，使人们更容易提供BeanInfo类。
    Statement
    一个 Statement对象表示一个原始语句，其中单个方法应用于目标和一组参数 - 如 "a.setFoo(b)" 。
    VetoableChangeListenerProxy
    一个类扩展了 EventListenerProxy专门用于添加一个具有“约束”属性的 VetoableChangeListener 。
    VetoableChangeSupport
    这是一个可以由支持约束属性的bean使用的实用程序类。
    XMLDecoder
    XMLDecoder类用于读取使用 XMLEncoder创建的XML文档，并且像 ObjectInputStream那样使用。
    XMLEncoder
    所述 XMLEncoder类是互补替代 ObjectOutputStream ，并且可以用于产生以相同的方式，该一个 JavaBean的文本表示 ObjectOutputStream可以用来创建的二进制表示 Serializable对象。
  • 异常摘要
    异常 描述
    IntrospectionException
    内省时发生异常时抛出。
    PropertyVetoException
    当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
  • 注解类型摘要
    Annotation Type 描述
    BeanProperty
    用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
    JavaBean
    用于为自动生成的BeanInfo类指定一些类相关信息的注释。
    Transient
    表示当Introspector构造与注释代码元素相关联的一个PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明一个名为“transient”的属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.beans Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.beans

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.beans.Beans
    • java.beans.Encoder
      • java.beans.XMLEncoder (implements java.lang.AutoCloseable)
    • java.beans.EventHandler (implements java.lang.reflect.InvocationHandler)
    • java.util.EventListenerProxy<T> (implements java.util.EventListener)
      • java.beans.PropertyChangeListenerProxy (implements java.beans.PropertyChangeListener)
      • java.beans.VetoableChangeListenerProxy (implements java.beans.VetoableChangeListener)
    • java.util.EventObject (implements java.io.Serializable)
      • java.beans.PropertyChangeEvent
        • java.beans.IndexedPropertyChangeEvent
    • java.beans.FeatureDescriptor
      • java.beans.BeanDescriptor
      • java.beans.EventSetDescriptor
      • java.beans.MethodDescriptor
      • java.beans.ParameterDescriptor
      • java.beans.PropertyDescriptor
        • java.beans.IndexedPropertyDescriptor
    • java.beans.Introspector
    • java.beans.PersistenceDelegate
      • java.beans.DefaultPersistenceDelegate
    • java.beans.PropertyChangeSupport (implements java.io.Serializable)
    • java.beans.PropertyEditorManager
    • java.beans.PropertyEditorSupport (implements java.beans.PropertyEditor)
    • java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
    • java.beans.Statement
      • java.beans.Expression
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.beans.IntrospectionException
        • java.beans.PropertyVetoException
    • java.beans.VetoableChangeSupport (implements java.io.Serializable)
    • java.beans.XMLDecoder (implements java.lang.AutoCloseable)

Interface Hierarchy

  • java.beans.AppletInitializer
  • java.beans.BeanInfo
  • java.beans.Customizer
  • java.beans.DesignMode
  • java.util.EventListener
    • java.beans.PropertyChangeListener
    • java.beans.VetoableChangeListener
  • java.beans.ExceptionListener
  • java.beans.PropertyEditor
  • java.beans.Visibility

Annotation Type Hierarchy

  • java.beans.BeanProperty (implements java.lang.annotation.Annotation)
  • java.beans.ConstructorProperties (implements java.lang.annotation.Annotation)
  • java.beans.JavaBean (implements java.lang.annotation.Annotation)
  • java.beans.Transient (implements java.lang.annotation.Annotation)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


JavaBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.desktop
软件包 java.beans

Annotation Type JavaBean

  • @Documented
@Target(TYPE)
@Retention(RUNTIME)
public @interface JavaBean
    用于为自动生成的BeanInfo类指定一些类相关信息的注释。 如果注释类具有相应的用户定义的BeanInfo类，则不使用此注释，这并不意味着自动分析。
    从以下版本开始：
    9
    另请参见：
    BeanInfo.getBeanDescriptor()

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      String defaultEventSet
      默认事件集的名称用于计算在注释类中定义的事件集中的 array中的 index 。
      String defaultProperty
      默认属性的名称被用于计算其 index在 array在注释类中定义的属性。
      String description
      short description为 bean descriptor的注释类。

    • Element Detail

      • description

        String description
        short description为 bean descriptor的注释类。
        结果
        bean描述，如果没有设置描述，则为空字符串。
        Default:
        “”

      • defaultProperty

        String defaultProperty
        默认属性的名称用于计算其在注释类中定义的属性中的array中的index 。 如果未设置名称或注释类未定义具有指定名称的属性，则默认属性索引将由Introspector根据其状态自动计算。
        结果
        默认属性的名称，如果未设置名称，则为空字符串。
        Default:
        “”

      • defaultEventSet

        String defaultEventSet
        默认事件集的名称用于计算在注释类中定义的事件集的array中的index 。 如果未设置名称或注释类未定义具有指定名称的事件集，则默认事件集索引将根据其状态由Introspector自动计算。
        结果
        默认事件集的名称，如果未设置名称，则为空字符串。
        Default:
        “”
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


MethodDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class MethodDescriptor

  • java.lang.Object
    • java.beans.FeatureDescriptor
      • java.beans.MethodDescriptor

  • public class MethodDescriptor
extends FeatureDescriptor
    MethodDescriptor描述了Java Bean支持的特定方法，用于从其他组件进行外部访问。
    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      MethodDescriptor​(方法 method)
      构造一个 MethodDescriptor从 方法 。
      MethodDescriptor​(方法 method, ParameterDescriptor[] parameterDescriptors)
      从 方法构造一个 MethodDescriptor ，为每个方法的参数提供描述性信息。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      方法 getMethod​()
      获取此MethodDescriptor封装的方法。
      ParameterDescriptor[] getParameterDescriptors​()
      获取每个此MethodDescriptor方法参数的ParameterDescriptor。

      • Methods inherited from class java.beans.FeatureDescriptor

        attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MethodDescriptor

        public MethodDescriptor​(方法 method)
        构造一个 MethodDescriptor从 方法 。
        参数
        method - 低级方法信息。

      • MethodDescriptor

        public MethodDescriptor​(方法 method,
                        ParameterDescriptor[] parameterDescriptors)
        从 方法构造一个 MethodDescriptor ，为每个方法的参数提供描述性信息。
        参数
        method - 低级方法信息。
        parameterDescriptors - 每个方法参数的描述性信息。

    • 方法详细信息

      • getMethod

        public 方法 getMethod​()
        获取此MethodDescriptor封装的方法。
        结果
        方法的低级描述

      • getParameterDescriptors

        public ParameterDescriptor[] getParameterDescriptors​()
        获取每个此MethodDescriptor方法参数的ParameterDescriptor。
        结果
        参数的区域设置独立名称。 如果参数名称不知道，可以返回一个空数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ParameterDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class ParameterDescriptor

  • java.lang.Object
    • java.beans.FeatureDescriptor
      • java.beans.ParameterDescriptor

  • public class ParameterDescriptor
extends FeatureDescriptor
    ParameterDescriptor类允许bean实现者提供关于每个参数的附加信息，超出java.lang.reflect.Method类提供的低级类型信息。

    目前我们所有的状态都来自FeatureDescriptor基类。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      ParameterDescriptor​()
      公共默认构造函数。

    • 方法摘要

      • Methods inherited from class java.beans.FeatureDescriptor

        attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ParameterDescriptor

        public ParameterDescriptor​()
        公共默认构造函数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PersistenceDelegate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PersistenceDelegate

  • java.lang.Object
    • java.beans.PersistenceDelegate
  • 已知直接子类：
    DefaultPersistenceDelegate

    public abstract class PersistenceDelegate
extends Object
    PersistenceDelegate类负责根据类的公共API中的方法来表达给定类的实例的状态。 相反关联的持久性与类本身完成，例如，由责任readObject种writeObject由所使用的方法ObjectOutputStream ，溪流像XMLEncoder即采用这种委托模型可以有自己的行为独立控制的类本身。 通常来说，这个班级是在这个授权计划中可以很容易地表达这些信息和惯例的最佳方法。 然而，有时候，单个类中的一个小问题可以防止整个对象图形被写入，并且这可以使应用程序开发人员无需追索权，而是尝试在本地影响有问题的类或使用替代的持久性技术。 在这种情况下，授权模型给应用程序开发人员提供了相对干净的机制来干预序列化过程的所有部分，而不需要对不是应用程序本身的一部分的类的实现进行修改。

    除了使用委托模型之外，该持久性方案与传统的串行化方案不同，需要不具有对应的readObject方法的writeObject方法的模拟。 writeObject模拟器根据其公共API编码每个实例，并且不需要定义readObject模拟，因为用于读取序列化表单的过程由Java语言规范中所阐述的方法调用的语义定义。 打破writeObject和readObject之间的依赖关系，这可能会从版本更改为版本，这是通过此技术生成的归档不受其引用的类的私有实现的变化的关键因素。

    持久代理可以控制对象持久化的所有方面，包括：

    • 决定一个实例是否可以被突变成同一个类的另一个实例。
    • 通过调用公共构造函数或公共工厂方法来实例化对象。
    • 执行对象的初始化。
    从以下版本开始：
    1.4
    另请参见：
    XMLEncoder

    • 构造方法摘要

      构造方法
      Constructor 描述
      PersistenceDelegate​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected void initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
      对 newInstance生成一系列具有副作用的语句，使新实例变为 等同于 oldInstance 。
      protected abstract Expression instantiate​(Object oldInstance, Encoder out)
      返回一个值为 oldInstance的表达式。
      protected boolean mutatesTo​(Object oldInstance, Object newInstance)
      如果通过将一系列语句应用于 newInstance可以创建 oldInstance的 等效副本，则返回true。
      void writeObject​(Object oldInstance, Encoder out)
      writeObject是持久性的单个入口点，由传统的授权模式中的 Encoder使用。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PersistenceDelegate

        public PersistenceDelegate​()

    • 方法详细信息

      • writeObject

        public void writeObject​(Object oldInstance,
                        Encoder out)
        writeObject是持久性的单个入口点，由传统的授权模式中的Encoder使用。 虽然这种方法不是最终的，但在正常情况下不需要进行子类化。

        这个实现首先检查流是否已经遇到这个对象。 接下来， mutatesTo方法来查看从流返回的候选人是否可以突变为oldInstance的准确副本。 如果可以，则调用initialize方法来执行初始化。 如果没有，候选人将从流中删除，并调用instantiate方法为此对象创建新的候选项。

        参数
        oldInstance - 将由此表达式创建的实例。
        out - 将写入此表达式的流。
        异常
        NullPointerException - 如果 out是 null

      • mutatesTo

        protected boolean mutatesTo​(Object oldInstance,
                            Object newInstance)
        如果通过将一系列语句应用于newInstance可以创建oldInstance的等效副本，则返回true。 在这种方法的规范中，我们的意思是相当于修改的实例与其公共API中相关方法的行为不符合oldInstance 。 [注意：我们使用短语相关方法而不是所有方法，因为这是严格正确的，像hashCode和toString这样的方法toString防止大多数类生成真正难以区分的实例副本]。

        如果两个实例的类相同，默认行为将返回true 。

        参数
        oldInstance - 要复制的实例。
        newInstance - 要修改的实例。
        结果
        如果通过将一系列突变应用于 oldInstance可以创建 newInstance的等效副本， newInstance oldInstance 。

      • instantiate

        protected abstract Expression instantiate​(Object oldInstance,
                                          Encoder out)
        返回一个值为oldInstance的表达式。 此方法用于表征应用于创建给定对象的构造函数或工厂方法。 例如， Field类的持久性委托的instantiate方法可以定义如下：
          Field f = (Field)oldInstance;
 return new Expression(f, f.getDeclaringClass(), "getField", new Object[]{f.getName()});
        请注意，我们声明返回的表达式的值，以便表达式的值（由getValue返回）将与oldInstance相同。
        参数
        oldInstance - 将由此表达式创建的实例。
        out - 将写入此表达式的流。
        结果
        值为 oldInstance的表达式。
        异常
        NullPointerException - 如果 out是 null并且该值用于该方法

      • initialize

        protected void initialize​(Class<?> type,
                          Object oldInstance,
                          Object newInstance,
                          Encoder out)
        对newInstance生成一系列具有副作用的语句，以使新实例变为等效于oldInstance 。 在这种方法的规范中，我们的意思是相当于在方法返回之后，修改的实例与其公共API中所有方法的行为不newInstance 。

        实施通常通过产生一系列涉及oldInstance及其公开可用状态的“发生了什么”的声明来实现这一目标。 这些语句使用其writeExpression方法发送到输出流，该方法返回一个涉及在阅读期间模拟输入流状态的克隆环境中的元素的表达式。 返回的每个语句都将使旧环境中的所有实例都替换为新对象。 特别是，这些声明，这开始了作为参考的对象引用oldInstance返回来引用newInstance代替。 执行这些语句会对两个对象的状态进行增量对齐，这是对新环境中对象的一系列修改。 在初始化方法返回之前，应该不可能通过使用它们的公共API来将两个实例分开。 最重要的是，用于使这些对象看起来是等效的步骤序列将被输出流记录，并且当流被刷新时将形成实际的输出。

        默认实现，调用类型的超类的initialize方法。

        参数
        type - 实例的类型
        oldInstance - 要复制的实例。
        newInstance - 要修改的实例。
        out - 应写入任何初始化语句的流。
        异常
        NullPointerException - 如果 out是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PropertyChangeEvent

  • java.lang.Object
    • java.util.EventObject
      • java.beans.PropertyChangeEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    IndexedPropertyChangeEvent

    public class PropertyChangeEvent
extends EventObject
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。 PropertyChangeEvent对象作为参数发送到PropertyChangeListener和VetoableChangeListener方法。

    通常PropertyChangeEvents将附带更改属性的名称和旧值和新值。 如果新值是一个基本类型（如int或boolean），那么它必须被包装为相应的java.lang。*对象类型（如Integer或Boolean）。

    如果旧值和新值未知，它们的真值可能会被提供。

    事件源可以发送一个空对象作为名称，以指示如果其属性已经更改的任意集合。 在这种情况下，旧值和新值也应为null。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyChangeEvent​(Object source, String propertyName, Object oldValue, Object newValue)
      构造一个新的 PropertyChangeEvent 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getNewValue​()
      获取属性的新值，表示为Object。
      Object getOldValue​()
      获取属性的旧值，表示为对象。
      Object getPropagationId​()
      “propagationId”字段保留供将来使用。
      String getPropertyName​()
      获取已更改的属性的编程名称。
      void setPropagationId​(Object propagationId)
      设置事件的propagationId对象。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.util.EventObject

        getSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PropertyChangeEvent

        public PropertyChangeEvent​(Object source,
                           String propertyName,
                           Object oldValue,
                           Object newValue)
        构造新的 PropertyChangeEvent 。
        参数
        source - 触发事件的bean
        propertyName - 已更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 物业的新价值
        异常
        IllegalArgumentException - 如果 source是 null

    • 方法详细信息

      • getPropertyName

        public String getPropertyName​()
        获取已更改的属性的编程名称。
        结果
        已更改的属性的编程名称。 如果多个属性已更改，则可以为null。

      • getNewValue

        public Object getNewValue​()
        获取属性的新值，表示为Object。
        结果
        属性的新值，表示为对象。 如果多个属性已更改，则可以为null。

      • getOldValue

        public Object getOldValue​()
        获取属性的旧值，表示为对象。
        结果
        该属性的旧值表示为Object。 如果多个属性已更改，则可以为null。

      • setPropagationId

        public void setPropagationId​(Object propagationId)
        设置事件的propagationId对象。
        参数
        propagationId - 事件的propagationId对象。

      • getPropagationId

        public Object getPropagationId​()
        “propagationId”字段保留供将来使用。 在Beans 1.0中，唯一的要求是如果一个监听器捕获一个PropertyChangeEvent，然后触发一个PropertyChangeEvent，那么它应该确保它将传播信号从传入事件传播到它的传出事件。
        结果
        与绑定/约束属性更新关联的propagationId对象。

      • toString

        public String toString​()
        返回对象的字符串表示形式。
        重写：
        toString在 EventObject
        结果
        对象的字符串表示形式
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface PropertyChangeListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    BasicButtonListener ， BasicColorChooserUI.PropertyHandler ， BasicComboBoxUI.PropertyChangeHandler ， BasicComboPopup.PropertyChangeHandler ， BasicDirectoryModel ， BasicInternalFrameTitlePane.PropertyChangeHandler ， BasicInternalFrameUI.InternalFramePropertyChangeListener ， BasicLabelUI ， BasicListUI.PropertyChangeHandler ， BasicOptionPaneUI.PropertyChangeHandler ， BasicRootPaneUI ， BasicScrollBarUI.PropertyChangeHandler ， BasicScrollPaneUI.PropertyChangeHandler ， BasicSliderUI.PropertyChangeHandler ， BasicSplitPaneDivider ， BasicSplitPaneUI.PropertyHandler ， BasicTabbedPaneUI.PropertyChangeHandler ， BasicToolBarUI.PropertyListener ， BasicTreeUI.PropertyChangeHandler ， BasicTreeUI.SelectionModelPropertyChangeHandler ， BeanContextServicesSupport ， BeanContextSupport ， DefaultTableColumnModel ， JLayer ， JList.AccessibleJList ， JPopupMenu.AccessibleJPopupMenu ， JScrollPane.AccessibleJScrollPane ， JSpinner.DateEditor ， JSpinner.DefaultEditor ， JSpinner.ListEditor ， JSpinner.NumberEditor ， JTable.AccessibleJTable ， MetalComboBoxUI.MetalPropertyChangeListener ， MetalFileChooserUI.FilterComboBoxModel ， MetalLabelUI ， MetalRootPaneUI ， MetalSliderUI.MetalPropertyListener ， MetalToolBarUI.MetalRolloverListener ， ProgressMonitor.AccessibleProgressMonitor ， PropertyChangeListenerProxy ， SynthButtonUI ， SynthCheckBoxMenuItemUI ， SynthCheckBoxUI ， SynthColorChooserUI ， SynthComboBoxUI ， SynthDesktopIconUI ， SynthDesktopPaneUI ， SynthInternalFrameUI ， SynthLabelUI ， SynthListUI ， SynthMenuBarUI ， SynthMenuItemUI ， SynthMenuUI ， SynthOptionPaneUI ， SynthPanelUI ， SynthPopupMenuUI SynthPopupMenuUI ， SynthProgressBarUI ， SynthRadioButtonMenuItemUI ， SynthRadioButtonUI ， SynthRootPaneUI ， SynthScrollBarUI ， SynthScrollPaneUI ， SynthSeparatorUI ， SynthSliderUI ， SynthSpinnerUI ， SynthSplitPaneUI ， SynthTabbedPaneUI ， SynthTableHeaderUI ， SynthTableUI ， SynthToggleButtonUI ， SynthToolBarUI ， SynthToolTipUI ， SynthTreeUI ， SynthViewportUI

    public interface PropertyChangeListener
extends EventListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。 您可以向源bean注册PropertyChangeListener，以便通知任何绑定的属性更新。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void propertyChange​(PropertyChangeEvent evt)
      当绑定属性更改时，此方法将被调用。

    • 方法详细信息

      • propertyChange

        void propertyChange​(PropertyChangeEvent evt)
        当绑定属性更改时，此方法将被调用。
        参数
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyChangeListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PropertyChangeListenerProxy

  • java.lang.Object
    • java.util.EventListenerProxy<PropertyChangeListener>
      • java.beans.PropertyChangeListenerProxy
  • All Implemented Interfaces:
    PropertyChangeListener ， EventListener

    public class PropertyChangeListenerProxy
extends EventListenerProxy<PropertyChangeListener>
implements PropertyChangeListener
    一个类扩展了EventListenerProxy专门用于添加一个“绑定”属性的PropertyChangeListener 。 此类的实例可以作为PropertyChangeListener添加到支持触发属性更改事件的bean。

    如果对象具有getPropertyChangeListeners方法，则返回的数组可能是PropertyChangeListener和PropertyChangeListenerProxy对象的混合。

    从以下版本开始：
    1.4
    另请参见：
    EventListenerProxy ， PropertyChangeSupport.getPropertyChangeListeners()

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyChangeListenerProxy​(String propertyName, PropertyChangeListener listener)
      构造函数将 PropertyChangeListener绑定到特定属性。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getPropertyName​()
      返回与侦听器关联的命名属性的名称。
      void propertyChange​(PropertyChangeEvent event)
      将属性更改事件转发给侦听器代理。

      • Methods inherited from class java.util.EventListenerProxy

        getListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PropertyChangeListenerProxy

        public PropertyChangeListenerProxy​(String propertyName,
                                   PropertyChangeListener listener)
        构造函数将 PropertyChangeListener绑定到特定属性。
        参数
        propertyName - 要收听的财产的名称
        listener - 侦听器对象

    • 方法详细信息

      • propertyChange

        public void propertyChange​(PropertyChangeEvent event)
        将属性更改事件转发给侦听器代理。
        Specified by:
        propertyChange在接口 PropertyChangeListener
        参数
        event - 物业变更事件

      • getPropertyName

        public String getPropertyName​()
        返回与侦听器关联的命名属性的名称。
        结果
        与侦听器关联的命名属性的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyChangeSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PropertyChangeSupport

  • java.lang.Object
    • java.beans.PropertyChangeSupport
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    SwingPropertyChangeSupport

    public class PropertyChangeSupport
extends Object
implements Serializable
    这是一个可以由支持绑定属性的bean使用的实用程序类。 它管理一个监听器列表，并向他们发送PropertyChangeEvent 。 您可以使用此类的实例作为bean的成员字段，并将这些类型的工作委派给它。 PropertyChangeListener可以注册所有属性或由name指定的属性。

    下面是一个PropertyChangeSupport用法的例子，它们遵循JavaBeans的规范中规定的规则和建议：

      public class MyBean {
     private final PropertyChangeSupport pcs = new PropertyChangeSupport(this);

     public void addPropertyChangeListener(PropertyChangeListener listener) {
         this.pcs.addPropertyChangeListener(listener);
     }

     public void removePropertyChangeListener(PropertyChangeListener listener) {
         this.pcs.removePropertyChangeListener(listener);
     }

     private String value;

     public String getValue() {
         return this.value;
     }

     public void setValue(String newValue) {
         String oldValue = this.value;
         this.value = newValue;
         this.pcs.firePropertyChange("value", oldValue, newValue);
     }

     [...]
 }

    一个PropertyChangeSupport实例是线程安全的。

    这个类是可序列化的。 当它被序列化时，它将保存（并恢复）本身可序列化的任何侦听器。 在序列化期间，任何不可序列化的监听器将被跳过。

    从以下版本开始：
    1.1
    另请参见：
    VetoableChangeSupport ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyChangeSupport​(Object sourceBean)
      构造一个 PropertyChangeSupport对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(PropertyChangeListener listener)
      将一个PropertyChangeListener添加到侦听器列表。
      void addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      为特定属性添加PropertyChangeListener。
      void fireIndexedPropertyChange​(String propertyName, int index, boolean oldValue, boolean newValue)
      向已注册的侦听器报告布尔绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void fireIndexedPropertyChange​(String propertyName, int index, int oldValue, int newValue)
      向已注册的监听器报告整数绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void fireIndexedPropertyChange​(String propertyName, int index, Object oldValue, Object newValue)
      向已注册的监听器报告绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void firePropertyChange​(PropertyChangeEvent event)
      将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
      void firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)
      向已注册的侦听器报告布尔绑定属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void firePropertyChange​(String propertyName, int oldValue, int newValue)
      向已注册的监听器报告整数绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void firePropertyChange​(String propertyName, Object oldValue, Object newValue)
      向已注册的监听器报告绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      PropertyChangeListener[] getPropertyChangeListeners​()
      返回使用addPropertyChangeListener（）添加到PropertyChangeSupport对象的所有侦听器的数组。
      PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      boolean hasListeners​(String propertyName)
      检查是否有特定属性的监听器，包括在所有属性上注册的监听器。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除一个PropertyChangeListener。
      void removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      删除特定属性的PropertyChangeListener。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PropertyChangeSupport

        public PropertyChangeSupport​(Object sourceBean)
        构造一个 PropertyChangeSupport对象。
        参数
        sourceBean - 要给出的bean作为任何事件的源。

    • 方法详细信息

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        将一个PropertyChangeListener添加到侦听器列表。 所有属性都注册了监听器。 同一个侦听器对象可以被多次添加，并且将被调用多次，因为它被添加。 如果listener为null，则不会抛出异常并且不采取任何操作。
        参数
        listener - 要添加的PropertyChangeListener

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener listener)
        从侦听器列表中删除一个PropertyChangeListener。 这会删除为所有属性注册的PropertyChangeListener。 如果listener添加到同一个事件源，则在被删除之后会被通知一次。 如果listener为空，或者从未添加，则不会抛出异常，也不会执行任何操作。
        参数
        listener - 要删除的PropertyChangeListener

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​()
        返回使用addPropertyChangeListener（）添加到PropertyChangeSupport对象的所有侦听器的数组。

        如果一些监听器已经添加了一个named属性，那么返回的数组将是PropertyChangeListeners和PropertyChangeListenerProxy的混合。 如果调用方法有兴趣区分侦听器，那么它必须测试每个元素以查看它是否为PropertyChangeListenerProxy ，执行该转换并检查该参数。

           PropertyChangeListener[] listeners = bean.getPropertyChangeListeners(); for (int i = 0; i < listeners.length; i++) { if (listeners[i] instanceof PropertyChangeListenerProxy) { PropertyChangeListenerProxy proxy = (PropertyChangeListenerProxy)listeners[i]; if (proxy.getPropertyName().equals("foo")) { // proxy is a PropertyChangeListener which was associated // with the property named "foo" } } }
        结果
        如果没有添加任何监听器，则添加所有 PropertyChangeListeners或一个空数组
        从以下版本开始：
        1.4
        另请参见：
        PropertyChangeListenerProxy

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String propertyName,
                                      PropertyChangeListener listener)
        为特定属性添加PropertyChangeListener。 只有当调用firePropertyChange命名该特定属性时，才会调用该侦听器。 可以多次添加相同的侦听器对象。 对于每个属性，侦听器将被调用为该属性添加的次数。 如果propertyName或listener为空，则不会抛出异常，并且不执行任何操作。
        参数
        propertyName - 要收听的财产的名称。
        listener - 要添加的PropertyChangeListener
        从以下版本开始：
        1.2

      • removePropertyChangeListener

        public void removePropertyChangeListener​(String propertyName,
                                         PropertyChangeListener listener)
        删除特定属性的PropertyChangeListener。 如果listener添加到指定属性的同一事件源，则会在被删除之后被通知一次。 如果propertyName为空，则不会抛出任何异常，也不会执行任何操作。 如果listener为空，或者从未为指定的属性添加，则不会抛出异常并且不执行任何操作。
        参数
        propertyName - 收听的财产的名称。
        listener - 要删除的PropertyChangeListener
        从以下版本开始：
        1.2

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners​(String propertyName)
        返回与named属性相关联的所有侦听器的数组。
        参数
        propertyName - 正在收听的财产的名称
        结果
        所有的PropertyChangeListeners与命名属性相关联。 如果没有添加这样的侦听器，或者如果propertyName为null，则返回一个空数组。
        从以下版本开始：
        1.4

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               Object oldValue,
                               Object newValue)
        向已注册的监听器报告绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        如果旧值和新值相等且不为空，则不会触发事件。

        这只是一个方便的包装器，围绕更一般的firePropertyChange(PropertyChangeEvent)方法。

        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 物业的新价值

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               int oldValue,
                               int newValue)
        向已注册的监听器报告整数绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        如果旧值和新值相等，则不会触发任何事件。

        这只是一个方便的包装，围绕更一般的firePropertyChange(String, Object, Object)方法。

        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 物业的旧价值
        newValue - 该物业的新值
        从以下版本开始：
        1.2

      • firePropertyChange

        public void firePropertyChange​(String propertyName,
                               boolean oldValue,
                               boolean newValue)
        向已注册的侦听器报告布尔绑定属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        如果旧值和新值相等，则不会触发任何事件。

        这只是一个方便的包装，围绕更一般的firePropertyChange(String, Object, Object)方法。

        参数
        propertyName - 已更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 该物业的新价值
        从以下版本开始：
        1.2

      • firePropertyChange

        public void firePropertyChange​(PropertyChangeEvent event)
        将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。

        如果给定事件的旧值和新值相等且非空值，则不会触发事件。

        参数
        event - 要解雇的 PropertyChangeEvent
        从以下版本开始：
        1.2

      • fireIndexedPropertyChange

        public void fireIndexedPropertyChange​(String propertyName,
                                      int index,
                                      Object oldValue,
                                      Object newValue)
        向已注册的监听器报告绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        如果旧值和新值相等且不为空，则不会触发事件。

        这只是一个方便的包装，围绕更一般的firePropertyChange(PropertyChangeEvent)方法。

        参数
        propertyName - 已更改的属性的编程名称
        index - 已更改的属性元素的索引
        oldValue - 该物业的旧值
        newValue - 物业的新价值
        从以下版本开始：
        1.5

      • fireIndexedPropertyChange

        public void fireIndexedPropertyChange​(String propertyName,
                                      int index,
                                      int oldValue,
                                      int newValue)
        向已注册的监听器报告整数绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        如果旧值和新值相等，则不会触发任何事件。

        这只是一个方便的包装器，围绕更一般的fireIndexedPropertyChange(String, int, Object, Object)方法。

        参数
        propertyName - 已更改的属性的编程名称
        index - 已更改的属性元素的索引
        oldValue - 物业的旧值
        newValue - 物业的新价值
        从以下版本开始：
        1.5

      • fireIndexedPropertyChange

        public void fireIndexedPropertyChange​(String propertyName,
                                      int index,
                                      boolean oldValue,
                                      boolean newValue)
        向已注册的侦听器报告布尔绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        如果旧值和新值相等，则不会触发任何事件。

        这只是一个方便的包装，围绕更一般的fireIndexedPropertyChange(String, int, Object, Object)方法。

        参数
        propertyName - 已更改的属性的编程名称
        index - 已更改的属性元素的索引
        oldValue - 物业的旧值
        newValue - 该物业的新值
        从以下版本开始：
        1.5

      • hasListeners

        public boolean hasListeners​(String propertyName)
        检查是否有特定属性的监听器，包括在所有属性上注册的监听器。 如果propertyName为null，则只检查在所有属性上注册的侦听器。
        参数
        propertyName - 属性名称。
        结果
        如果给定属性有一个或多个侦听器，则为true
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PropertyDescriptor

  • java.lang.Object
    • java.beans.FeatureDescriptor
      • java.beans.PropertyDescriptor
  • 已知直接子类：
    IndexedPropertyDescriptor

    public class PropertyDescriptor
extends FeatureDescriptor
    PropertyDescriptor描述了Java Bean通过一对访问器方法导出的一个属性。
    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyDescriptor​(String propertyName, Class<?> beanClass)
      通过使用getFoo和setFoo访问器方法，为遵循标准Java约定的属性构造PropertyDescriptor。
      PropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
      该构造函数使用简单属性的名称，以及读取和写入属性的方法名称。
      PropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PropertyEditor createPropertyEditor​(Object bean)
      使用当前的属性编辑器类构造一个属性编辑器的实例。
      boolean equals​(Object obj)
      将此 PropertyDescriptor与指定对象进行比较。
      Class<?> getPropertyEditorClass​()
      获取已为此属性注册的任何显式PropertyEditor类。
      Class<?> getPropertyType​()
      返回属性的Java类型信息。
      方法 getReadMethod​()
      获取应该用于读取属性值的方法。
      方法 getWriteMethod​()
      获取应用于写入属性值的方法。
      int hashCode​()
      返回对象的哈希码值。
      boolean isBound​()
      对“绑定”属性的更新将导致在属性更改时触发“PropertyChange”事件。
      boolean isConstrained​()
      尝试更新“受限制”属性将导致在属性更改时触发“VetoableChange”事件。
      void setBound​(boolean bound)
      对“绑定”属性的更新将导致在属性更改时触发“PropertyChange”事件。
      void setConstrained​(boolean constrained)
      尝试更新“受限制”属性将导致在属性更改时触发“VetoableChange”事件。
      void setPropertyEditorClass​(Class<?> propertyEditorClass)
      通常使用PropertyEditorManager可以找到PropertyEditors。
      void setReadMethod​(方法 readMethod)
      设置应用于读取属性值的方法。
      void setWriteMethod​(方法 writeMethod)
      设置应用于写入属性值的方法。

      • Methods inherited from class java.beans.FeatureDescriptor

        attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PropertyDescriptor

        public PropertyDescriptor​(String propertyName,
                          Class<?> beanClass)
                   throws IntrospectionException
        通过使用getFoo和setFoo访问器方法，为遵循标准Java约定的属性构造PropertyDescriptor。 因此，如果参数名称为“fred”，则将假定writer方法为“setFred”，reader方法为“getFred”（或“isFred”为布尔属性）。 请注意，属性名称应以小写字符开头，它将在方法名称中大写。
        参数
        propertyName - 属性的编程名称。
        beanClass - 目标bean的Class对象。 例如sun.beans.OurButton.class。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • PropertyDescriptor

        public PropertyDescriptor​(String propertyName,
                          Class<?> beanClass,
                          String readMethodName,
                          String writeMethodName)
                   throws IntrospectionException
        该构造函数使用简单属性的名称，以及读取和写入属性的方法名称。
        参数
        propertyName - 属性的编程名称。
        beanClass - 目标bean的Class对象。 例如sun.beans.OurButton.class。
        readMethodName - 用于读取属性值的方法的名称。 如果属性是只写的，可能为null。
        writeMethodName - 用于写入属性值的方法的名称。 如果属性是只读的，则可以为null。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

      • PropertyDescriptor

        public PropertyDescriptor​(String propertyName,
                          方法 readMethod,
                          方法 writeMethod)
                   throws IntrospectionException
        此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
        参数
        propertyName - 属性的编程名称。
        readMethod - 用于读取属性值的方法。 如果属性是只写的，可能为null。
        writeMethod - 用于写入属性值的方法。 如果属性是只读的，则可以为null。
        异常
        IntrospectionException - 如果 IntrospectionException期间发生异常。

    • 方法详细信息

      • getPropertyType

        public Class<?> getPropertyType​()
        返回属性的Java类型信息。 请注意， Class对象可能会描述原始的Java类型，如int 。 这种类型是由read方法返回的，或者用作write方法的参数类型。 如果类型是不支持非索引访问的索引属性，则返回null 。
        结果
        表示Java类型信息的 Class对象，如果类型无法确定， null

      • getReadMethod

        public 方法 getReadMethod​()
        获取应该用于读取属性值的方法。
        结果
        应该用来读取属性值的方法。 如果属性无法读取，可能返回null。

      • setReadMethod

        public void setReadMethod​(方法 readMethod)
                   throws IntrospectionException
        设置应用于读取属性值的方法。
        参数
        readMethod - 新的阅读方法。
        异常
        IntrospectionException - 如果读取方法无效
        从以下版本开始：
        1.2

      • getWriteMethod

        public 方法 getWriteMethod​()
        获取应用于写入属性值的方法。
        结果
        应该用于写入属性值的方法。 如果属性无法写入，则返回null。

      • setWriteMethod

        public void setWriteMethod​(方法 writeMethod)
                    throws IntrospectionException
        设置应用于写入属性值的方法。
        参数
        writeMethod - 新的写入方法。
        异常
        IntrospectionException - 如果写入方法无效
        从以下版本开始：
        1.2

      • isBound

        public boolean isBound​()
        对“绑定”属性的更新将导致在属性更改时触发“PropertyChange”事件。
        结果
        如果这是绑定属性，则为true。

      • setBound

        public void setBound​(boolean bound)
        对“绑定”属性的更新将导致在属性更改时触发“PropertyChange”事件。
        参数
        bound - 如果这是绑定属性， bound真。

      • isConstrained

        public boolean isConstrained​()
        尝试更新“受限制”属性将导致在属性更改时触发“VetoableChange”事件。
        结果
        如果这是受限制的属性，则为真。

      • setConstrained

        public void setConstrained​(boolean constrained)
        尝试更新“受限制”属性将导致在属性更改时触发“VetoableChange”事件。
        参数
        constrained - 如果这是受限属性， constrained真。

      • setPropertyEditorClass

        public void setPropertyEditorClass​(Class<?> propertyEditorClass)
        通常使用PropertyEditorManager可以找到PropertyEditors。 但是，如果由于某种原因想要将特定的PropertyEditor与给定的属性相关联，那么可以使用此方法。
        参数
        propertyEditorClass - 所需PropertyEditor的类。

      • getPropertyEditorClass

        public Class<?> getPropertyEditorClass​()
        获取已为此属性注册的任何显式PropertyEditor类。
        结果
        任何已经为此属性注册的显式PropertyEditor类。 通常这将返回“null”，表示没有注册特殊编辑器，因此应该使用PropertyEditorManager来找到一个合适的PropertyEditor。

      • createPropertyEditor

        public PropertyEditor createPropertyEditor​(Object bean)
        使用当前的属性编辑器类构造一个属性编辑器的实例。

        如果属性编辑器类具有接受Object参数的公共构造函数，那么将使用bean参数作为参数来调用它。 否则，将调用默认构造函数。

        参数
        bean - 源对象
        结果
        属性编辑器实例，如果属性编辑器尚未定义或无法创建，则为null
        从以下版本开始：
        1.5

      • equals

        public boolean equals​(Object obj)
        将此PropertyDescriptor与指定对象进行比较。 如果对象相同，则返回true。 如果读取，写入，属性类型，属性编辑器和标志等同，则两个PropertyDescriptor是相同的。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果此对象与obj参数相同， true ; 否则为false 。
        从以下版本开始：
        1.4
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 有关完整的描述，请参阅Object.hashCode() 。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        从以下版本开始：
        1.5
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyEditor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface PropertyEditor

  • 所有已知实现类：
    PropertyEditorSupport

    public interface PropertyEditor
    PropertyEditor类提供对允许用户编辑给定类型的属性值的GUI的支持。

    PropertyEditor支持各种各样的显示和更新属性值的方式。 大多数PropertyEditor只需要支持该API中可用的不同选项的一个子集。

    简单的PropertyEditor可能只支持getAsText和setAsText方法，并且不需要支持（例如）paintValue或getCustomEditor。 更复杂的类型可能无法支持getAsText和setAsText，而是支持paintValue和getCustomEditor。

    每个propertyEditor必须支持三个简单的显示样式中的一个或多个。 因此，它可以（1）支持isPaintable或（2）都从getTags（）返回一个非空值String []，并从getAsText返回一个非空值，或者（3）只需从getAsText（）返回一个非空字符串， 。

    每个属性编辑器必须支持对setValue的调用，当参数对象是对应的propertyEditor类型时。 另外，每个属性编辑器都必须支持自定义编辑器，或支持setAsText。

    每个PropertyEditor应该有一个空构造函数。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(PropertyChangeListener listener)
      为值更改添加一个侦听器。
      String getAsText​()
      获取属性值作为文本。
      Component getCustomEditor​()
      PropertyEditor可以选择提供编辑其属性值的完整自定义组件。
      String getJavaInitializationString​()
      返回可用于设置属性以匹配编辑器当前状态的Java代码片段。
      String[] getTags​()
      如果属性值必须是一组已知标记值，则该方法应返回一个标记数组。
      Object getValue​()
      获取属性值。
      boolean isPaintable​()
      确定此属性编辑器是否可绘制。
      void paintValue​(Graphics gfx, Rectangle box)
      将值的表示绘制到屏幕不动产的给定区域。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      删除值更改的侦听器。
      void setAsText​(String text)
      通过解析给定的字符串来设置属性值。
      void setValue​(Object value)
      设置（或更改）要编辑的对象。
      boolean supportsCustomEditor​()
      确定此属性编辑器是否支持自定义编辑器。

    • 方法详细信息

      • setValue

        void setValue​(Object value)
        设置（或更改）要编辑的对象。 原始类型（如“int”）必须作为相应的对象类型（如“java.lang.Integer”）进行包装。
        参数
        value - 要编辑的新目标对象。 请注意，该对象不应该被PropertyEditor修改，而是PropertyEditor应该创建一个新对象来保存任何修改的值。

      • getValue

        Object getValue​()
        获取属性值。
        结果
        物业的价值。 诸如“int”的原始类型将被包装为相应的对象类型，例如“java.lang.Integer”。

      • isPaintable

        boolean isPaintable​()
        确定此属性编辑器是否可绘制。
        结果
        如果该类将符合paintValue方法，则为true。

      • paintValue

        void paintValue​(Graphics gfx,
                Rectangle box)
        将值的表示绘制到屏幕不动产的给定区域。 请注意，propertyEditor负责进行自己的剪辑，使其适合给定的矩形。

        如果PropertyEditor不符合paint请求（请参阅isPaintable），此方法应该是一个无声的noop。

        给定的Graphics对象将具有父容器的默认字体，颜色等。 PropertyEditor可能会更改图形属性，如字体和颜色，不需要恢复旧值。

        参数
        gfx - 绘制图形对象。
        box - 我们应该绘制的图形对象内的矩形。

      • getJavaInitializationString

        String getJavaInitializationString​()
        返回可用于设置属性以匹配编辑器当前状态的Java代码片段。 此方法用于生成Java代码以反映通过属性编辑器进行的更改。

        代码片段应该是上下文的，并且必须是由JLS指定的合法的Java表达式。

        具体来说，如果表达式表示一个计算，则所有类和静态成员都应该是完全限定的。 此规则适用于构造函数，静态方法和非原始参数。

        评估表达式时应注意使用，因为它可能会抛出异常。 特别地，代码生成器必须确保生成的代码将在存在可以抛出检查异常的表达式的情况下进行编译。

        示例结果是：

        • 原始表达： 2
        • 类构造函数： new java.awt.Color(127,127,34)
        • 静态字段： java.awt.Color.orange
        • 静态方法： javax.swing.Box.createRigidArea(new java.awt.Dimension(0, 5))
        结果
        代表当前值的初始化器的Java代码片段。 它不应该包含结尾表达式的分号（' ; '）。

      • getAsText

        String getAsText​()
        获取属性值作为文本。
        结果
        属性值作为人类可编辑的字符串。

        如果该值不能表示为可编辑字符串，则返回null。

        如果返回非空值，则PropertyEditor应该准备好在setAsText（）中解析该字符串。

      • setAsText

        void setAsText​(String text)
        throws IllegalArgumentException
        通过解析给定的字符串来设置属性值。 如果String格式不正确或者这种属性不能表示为文本，则可能引发java.lang.IllegalArgumentException异常。
        参数
        text - 要解析的字符串。
        异常
        IllegalArgumentException

      • getTags

        String[] getTags​()
        如果属性值必须是一组已知标记值，则该方法应返回一个标记数组。 这可以用于表示（例如）枚举值。 如果PropertyEditor支持标签，那么它应该支持使用带有标签值的setAsText作为设置值和使用getAsText来标识当前值的方式。
        结果
        此属性的标记值。 如果此属性无法表示为标记值，则可能为null。

      • getCustomEditor

        Component getCustomEditor​()
        PropertyEditor可以选择提供编辑其属性值的完整自定义组件。 PropertyEditor有责任将自身挂钩到编辑器组件本身，并通过触发PropertyChange事件来报告属性值更改。

        调用getCustomEditor的较高级别的代码可能会将Component嵌入到一些较大的属性表中，也可以将其放在自己的单个对话框中，或者...

        结果
        一个java.awt.Component，允许人们直接编辑当前的属性值。 如果不支持，可能为null。

      • supportsCustomEditor

        boolean supportsCustomEditor​()
        确定此属性编辑器是否支持自定义编辑器。
        结果
        如果propertyEditor可以提供自定义编辑器，则为true。

      • addPropertyChangeListener

        void addPropertyChangeListener​(PropertyChangeListener listener)
        为值更改添加一个侦听器。 当属性编辑器改变其价值应该火PropertyChangeEvent所有注册PropertyChangeListener个 S，指定null的属性名称值和本身的来源。
        参数
        listener - 要添加的PropertyChangeListener

      • removePropertyChangeListener

        void removePropertyChangeListener​(PropertyChangeListener listener)
        删除值更改的侦听器。
        参数
        listener - 要删除的PropertyChangeListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyEditorManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PropertyEditorManager

  • java.lang.Object
    • java.beans.PropertyEditorManager

  • public class PropertyEditorManager
extends Object
    PropertyEditorManager可用于查找任何给定类型名称的属性编辑器。 此属性编辑器必须支持用于编辑给定对象的java.beans.PropertyEditor接口。

    PropertyEditorManager使用三种技术来定位给定类型的编辑器。 首先，它提供了一个registerEditor方法，允许编辑器被特定地注册给定类型。 其次，它尝试通过将“Editor”添加到给定类型的全限定类名（例如“foo.bah.FozEditor”）中来找到合适的类。 最后，使用简单的类名（没有包名称）向其添加“编辑器”，并查找匹配类的包的搜索路径。

    所以对于一个输入类foo.bah.Fred，PropertyEditorManager将首先查看它的表，看看是否已经为foo.bah.Fred注册了一个编辑器，如果使用的话。 那么它会寻找一个foo.bah.FredEditor类。 然后它会寻找（说）standardEditorsPackage.FredEditor类。

    将为Java原语类型“boolean”，“byte”，“short”，“int”，“long”，“float”和“double”提供默认PropertyEditors; 对于类java.lang.String。 java.awt.Color和java.awt.Font。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyEditorManager​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static PropertyEditor findEditor​(Class<?> targetType)
      找到给定目标类型的值编辑器。
      static String[] getEditorSearchPath​()
      获取将搜索属性编辑器的包名称。
      static void registerEditor​(Class<?> targetType, Class<?> editorClass)
      注册编辑器类来编辑给定目标类的值。
      static void setEditorSearchPath​(String[] path)
      更改将用于查找属性编辑器的包名称列表。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PropertyEditorManager

        public PropertyEditorManager​()

    • 方法详细信息

      • registerEditor

        public static void registerEditor​(Class<?> targetType,
                                  Class<?> editorClass)
        注册编辑器类来编辑给定目标类的值。 如果编辑器类是null ，那么任何现有的定义将被删除。 因此，该方法可以用于取消注册。 如果目标或编辑器类被卸载，注册将被自动取消。

        如果有安全管理器，则调用其checkPropertiesAccess方法。 这可能会导致一个SecurityException 。

        参数
        targetType - 要编辑的类型的类对象
        editorClass - 编辑器类的类对象
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许设置系统属性
        另请参见：
        SecurityManager.checkPropertiesAccess()

      • findEditor

        public static PropertyEditor findEditor​(Class<?> targetType)
        找到给定目标类型的值编辑器。
        参数
        targetType - 要编辑的类型的Class对象
        结果
        给定目标类的编辑对象。 如果找不到合适的编辑器，结果为null。

      • getEditorSearchPath

        public static String[] getEditorSearchPath​()
        获取将搜索属性编辑器的包名称。
        结果
        将搜索的包名称数组，以便查找属性编辑器。

        该数组的默认值依赖于实现，例如，Sun实现最初设置为{“sun.beans.editors”}。

      • setEditorSearchPath

        public static void setEditorSearchPath​(String[] path)
        更改将用于查找属性编辑器的包名称列表。

        首先，如果有安全管理器，则调用其checkPropertiesAccess方法。 这可能会导致SecurityException。

        参数
        path - 包名称数组。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许设置系统属性。
        另请参见：
        SecurityManager.checkPropertiesAccess()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyEditorSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PropertyEditorSupport

  • java.lang.Object
    • java.beans.PropertyEditorSupport
  • All Implemented Interfaces:
    PropertyEditor

    public class PropertyEditorSupport
extends Object
implements PropertyEditor
    这是一个帮助构建属性编辑器的支持类。

    它可以用作基类或代理。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyEditorSupport​()
      构造一个 PropertyEditorSupport对象。
      PropertyEditorSupport​(Object source)
      构造一个 PropertyEditorSupport对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(PropertyChangeListener listener)
      为值更改添加一个侦听器。
      void firePropertyChange​()
      报告说，我们已被修改为任何感兴趣的听众。
      String getAsText​()
      获取属性值作为适合演示文稿的字符串进行编辑。
      Component getCustomEditor​()
      PropertyEditor可以选择提供编辑其属性值的完整自定义组件。
      String getJavaInitializationString​()
      此方法用于生成Java代码以设置属性值。
      Object getSource​()
      返回用作事件源的bean。
      String[] getTags​()
      如果属性值必须是一组已知标记值之一，则该方法应返回一个标记值的数组。
      Object getValue​()
      获取属性的值。
      boolean isPaintable​()
      确定类是否符合paintValue方法。
      void paintValue​(Graphics gfx, Rectangle box)
      将值的表示绘制到屏幕不动产的给定区域。
      void removePropertyChangeListener​(PropertyChangeListener listener)
      删除值更改的侦听器。
      void setAsText​(String text)
      通过解析给定的字符串来设置属性值。
      void setSource​(Object source)
      设置源bean。
      void setValue​(Object value)
      设置（或更改）要编辑的对象。
      boolean supportsCustomEditor​()
      确定propertyEditor是否可以提供自定义编辑器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PropertyEditorSupport

        public PropertyEditorSupport​()
        构造一个 PropertyEditorSupport对象。
        从以下版本开始：
        1.5

      • PropertyEditorSupport

        public PropertyEditorSupport​(Object source)
        构造一个 PropertyEditorSupport对象。
        参数
        source - 用于事件触发的源
        从以下版本开始：
        1.5

    • 方法详细信息

      • getSource

        public Object getSource​()
        返回用作事件源的bean。 如果源未被显式设置，则返回PropertyEditorSupport实例。
        结果
        源对象或此实例
        从以下版本开始：
        1.5

      • setSource

        public void setSource​(Object source)
        设置源bean。

        源bean用作属性更改的事件源。 该源仅应用于信息目的，不应由PropertyEditor修改。

        参数
        source - 用于事件的源对象
        从以下版本开始：
        1.5

      • setValue

        public void setValue​(Object value)
        设置（或更改）要编辑的对象。
        Specified by:
        setValue在接口 PropertyEditor
        参数
        value - 要编辑的新目标对象。 请注意，该对象不应该被PropertyEditor修改，而是PropertyEditor应该创建一个新对象来保存任何修改的值。

      • getValue

        public Object getValue​()
        获取属性的值。
        Specified by:
        getValue在接口 PropertyEditor
        结果
        物业的价值。

      • isPaintable

        public boolean isPaintable​()
        确定类是否符合paintValue方法。
        Specified by:
        isPaintable在接口 PropertyEditor
        结果
        如果该类将符合paintValue方法，则为true。

      • paintValue

        public void paintValue​(Graphics gfx,
                       Rectangle box)
        将值的表示绘制到屏幕不动产的给定区域。 请注意，propertyEditor负责进行自己的剪辑，使其适合给定的矩形。

        如果PropertyEditor不符合paint请求（请参阅isPaintable），此方法应该是一个无声的noop。

        Specified by:
        paintValue在接口 PropertyEditor
        参数
        gfx - 绘制图形对象。
        box - 我们应该绘制的图形对象内的矩形。

      • getJavaInitializationString

        public String getJavaInitializationString​()
        此方法用于生成Java代码以设置属性值。 它应该返回一个Java代码的片段，可以用来初始化具有当前属性值的变量。

        示例结果为“2”，“新颜色（127,127,34）”，“Color.orange”等

        Specified by:
        getJavaInitializationString接口 PropertyEditor
        结果
        代表当前值的初始化器的Java代码片段。

      • getAsText

        public String getAsText​()
        获取属性值作为适合演示文稿的字符串进行编辑。
        Specified by:
        getAsText接口 PropertyEditor
        结果
        属性值作为适合呈现给人类的字符串进行编辑。

        如果该值不能用字符串表示，则返回null。

        如果返回非空值，则PropertyEditor应该准备好在setAsText（）中解析该字符串。

      • setAsText

        public void setAsText​(String text)
               throws IllegalArgumentException
        通过解析给定的字符串来设置属性值。 如果String格式不正确或者这种属性不能表示为文本，则可能引发java.lang.IllegalArgumentException异常。
        Specified by:
        setAsText在接口 PropertyEditor
        参数
        text - 要解析的字符串。
        异常
        IllegalArgumentException

      • getTags

        public String[] getTags​()
        如果属性值必须是一组已知标记值之一，则该方法应返回一个标记值的数组。 这可以用于表示（例如）枚举值。 如果PropertyEditor支持标签，那么它应该支持使用带有标签值的setAsText作为设置值的方法。
        Specified by:
        getTags在接口 PropertyEditor
        结果
        此属性的标记值。 如果此属性无法表示为标记值，则可能为null。

      • getCustomEditor

        public Component getCustomEditor​()
        PropertyEditor可以选择提供编辑其属性值的完整自定义组件。 PropertyEditor有责任将自身挂钩到编辑器组件本身，并通过触发PropertyChange事件来报告属性值更改。

        调用getCustomEditor的较高级别的代码可能会将Component嵌入到一些较大的属性表中，也可以将其放在自己的单个对话框中，或者...

        Specified by:
        getCustomEditor在接口 PropertyEditor
        结果
        一个java.awt.Component，允许人们直接编辑当前的属性值。 如果不支持，可能为null。

      • supportsCustomEditor

        public boolean supportsCustomEditor​()
        确定propertyEditor是否可以提供自定义编辑器。
        Specified by:
        supportsCustomEditor在接口 PropertyEditor
        结果
        如果propertyEditor可以提供自定义编辑器，则为true。

      • addPropertyChangeListener

        public void addPropertyChangeListener​(PropertyChangeListener listener)
        为值更改添加一个侦听器。 当属性编辑器改变其价值应该火PropertyChangeEvent所有注册PropertyChangeListener个 S，指定null的属性名称值。 如果source属性被设置，它应该被用作事件的源。

        同一个侦听器对象可以被多次添加，并且将被调用多次，因为它被添加。 如果listener是null ，则抛出异常并且不采取任何操作。

        Specified by:
        addPropertyChangeListener在接口 PropertyEditor
        参数
        listener - 要添加的PropertyChangeListener

      • removePropertyChangeListener

        public void removePropertyChangeListener​(PropertyChangeListener listener)
        删除值更改的侦听器。

        如果同一个监听器被添加了多次，它将被删除后一次被通知。 如果listener是null ，或者从未添加过，则不会抛出异常并且不采取任何操作。

        Specified by:
        removePropertyChangeListener在接口 PropertyEditor
        参数
        listener - 要删除的PropertyChangeListener

      • firePropertyChange

        public void firePropertyChange​()
        报告说，我们已被修改为任何感兴趣的听众。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PropertyVetoException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class PropertyVetoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.beans.PropertyVetoException
  • All Implemented Interfaces:
    Serializable

    public class PropertyVetoException
extends 异常
    当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PropertyVetoException​(String mess, PropertyChangeEvent evt)
      构造一个 PropertyVetoException具有详细的消息。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PropertyChangeEvent getPropertyChangeEvent​()
      获得否决权 PropertyChangeEvent 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • PropertyVetoException

        public PropertyVetoException​(String mess,
                             PropertyChangeEvent evt)
        构造一个 PropertyVetoException的详细消息。
        参数
        mess - 描述性消息
        evt - 描述否决变更的PropertyChangeEvent。

    • 方法详细信息

      • getPropertyChangeEvent

        public PropertyChangeEvent getPropertyChangeEvent​()
        获得否决的 PropertyChangeEvent 。
        结果
        描述否决变更的PropertyChangeEvent。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SimpleBeanInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class SimpleBeanInfo

  • java.lang.Object
    • java.beans.SimpleBeanInfo
  • All Implemented Interfaces:
    BeanInfo

    public class SimpleBeanInfo
extends Object
implements BeanInfo
    这是一个支持类，使人们更容易提供BeanInfo类。

    它默认提供“noop”信息，并可以选择性地覆盖以提供有关所选主题的更明确的信息。 当内部审查者看到“noop”值时，它将应用低级内省和设计模式来自动分析目标bean。

    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from interface java.beans.BeanInfo

        ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32

    • 构造方法摘要

      构造方法
      Constructor 描述
      SimpleBeanInfo​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BeanInfo[] getAdditionalBeanInfo​()
      声明没有其他相关的BeanInfo对象。
      BeanDescriptor getBeanDescriptor​()
      拒绝关于bean的类和定制器的知识。
      int getDefaultEventIndex​()
      拒绝默认事件的知识。
      int getDefaultPropertyIndex​()
      拒绝默认属性的知识。
      EventSetDescriptor[] getEventSetDescriptors​()
      否认事件集的知识。
      Image getIcon​(int iconKind)
      声明没有可用的图标。
      MethodDescriptor[] getMethodDescriptors​()
      否认知识的方法。
      PropertyDescriptor[] getPropertyDescriptors​()
      拒绝属性知识。
      Image loadImage​(String resourceName)
      这是一种帮助加载图标图像的实用方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SimpleBeanInfo

        public SimpleBeanInfo​()

    • 方法详细信息

      • getBeanDescriptor

        public BeanDescriptor getBeanDescriptor​()
        拒绝关于bean的类和定制器的知识。 如果您想提供明确的信息，您可以重写此项。
        Specified by:
        getBeanDescriptor在接口 BeanInfo
        结果
        一个BeanDescriptor对象，或null如果信息是通过自动分析获得的

      • getPropertyDescriptors

        public PropertyDescriptor[] getPropertyDescriptors​()
        拒绝属性知识。 如果您希望提供明确的属性信息，您可以覆盖此。
        Specified by:
        getPropertyDescriptors在接口 BeanInfo
        结果
        一个 PropertyDescriptor对象的数组，如果要通过自动分析获得信息， null

      • getDefaultPropertyIndex

        public int getDefaultPropertyIndex​()
        拒绝默认属性的知识。 如果要定义bean的默认属性，可以覆盖此选项。
        Specified by:
        getDefaultPropertyIndex在接口 BeanInfo
        结果
        由 getPropertyDescriptors方法返回的 PropertyDescriptor数组中的默认属性的索引，如果没有默认属性，则为-1。

      • getEventSetDescriptors

        public EventSetDescriptor[] getEventSetDescriptors​()
        否认事件集的知识。 如果您希望提供明确的事件集信息，您可以重写此项。
        Specified by:
        getEventSetDescriptors在接口 BeanInfo
        结果
        一组EventSetDescriptor个对象，如果要通过自动分析获得信息， null

      • getDefaultEventIndex

        public int getDefaultEventIndex​()
        拒绝默认事件的知识。 如果您希望为bean定义一个默认事件，则可以覆盖此值。
        Specified by:
        getDefaultEventIndex在接口 BeanInfo
        结果
        由 getEventSetDescriptors方法返回的 EventSetDescriptor数组中的默认事件的索引，如果没有默认事件则为-1

      • getMethodDescriptors

        public MethodDescriptor[] getMethodDescriptors​()
        否认知识的方法。 如果您希望提供明确的方法信息，您可以重写此项。
        Specified by:
        getMethodDescriptors在接口 BeanInfo
        结果
        一个MethodDescriptor个对象的数组，如果要通过自动分析获得信息， null

      • getAdditionalBeanInfo

        public BeanInfo[] getAdditionalBeanInfo​()
        声明没有其他相关的BeanInfo对象。 如果你想（例如）返回一个基类的BeanInfo，你可以覆盖这个。
        Specified by:
        getAdditionalBeanInfo接口 BeanInfo
        结果
        的阵列 BeanInfo对象或 null ，如果没有附加的 BeanInfo对象

      • getIcon

        public Image getIcon​(int iconKind)
        声明没有可用的图标。 如果你想为你的bean提供图标，你可以重写这个。
        Specified by:
        getIcon在接口 BeanInfo
        参数
        iconKind - 所请求的图标种类
        结果
        表示所请求的图标的图像对象，如果没有合适的图标可用， null
        另请参见：
        BeanInfo.ICON_COLOR_16x16 ， BeanInfo.ICON_COLOR_32x32 ， BeanInfo.ICON_MONO_16x16 ， BeanInfo.ICON_MONO_32x32

      • loadImage

        public Image loadImage​(String resourceName)
        这是一种帮助加载图标图像的实用方法。 它使用与当前对象的类文件相关联的资源文件的名称，并从该文件加载图像对象。 通常图像将是GIF。
        参数
        resourceName - 相对于保存当前类的类文件的目录的路径名。 例如，“wombat.gif”。
        结果
        一个图像对象，如果找不到该资源或资源无法作为图像加载，则为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Statement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class Statement

  • java.lang.Object
    • java.beans.Statement
  • 已知直接子类：
    Expression

    public class Statement
extends Object
    一个Statement对象表示一个原语言，其中单个方法应用于目标和一组参数 - 如"a.setFoo(b)" 。 请注意，此示例使用名称来表示目标及其参数，语句对象不需要名称空间，并且使用值本身构造。 语句对象将named方法与其环境相关联，作为一组简单的值：目标和参数值数组。
    从以下版本开始：
    1.4

    • 构造方法摘要

      构造方法
      Constructor 描述
      Statement​(Object target, String methodName, Object[] arguments)
      为指定的目标对象创建一个新的Statement对象，以调用由名称和参数数组指定的方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void execute​()
      execute方法查找名称与 methodName属性相同的方法，并调用目标方法。
      Object[] getArguments​()
      返回要调用的方法的参数。
      String getMethodName​()
      返回要调用的方法的名称。
      Object getTarget​()
      返回此语句的目标对象。
      String toString​()
      使用Java风格的语法打印此语句的值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Statement

        @ConstructorProperties({"target","methodName","arguments"})
public Statement​(Object target,
                 String methodName,
                 Object[] arguments)
        为指定的目标对象创建一个新的Statement对象，以调用由名称和参数数组指定的方法。

        target和methodName值不应该是null 。 否则尝试执行此Expression将导致一个NullPointerException 。 如果arguments值为null ，则使用空数组作为arguments属性的值。

        参数
        target - 此语句的目标对象
        methodName - 在指定目标上调用的方法的名称
        arguments - 调用指定方法的参数数组

    • 方法详细信息

      • getTarget

        public Object getTarget​()
        返回此语句的目标对象。 如果此方法返回null ，则execute()方法将抛出一个NullPointerException 。
        结果
        此语句的目标对象

      • getMethodName

        public String getMethodName​()
        返回要调用的方法的名称。 如果此方法返回null ，则execute()方法将抛出一个NullPointerException 。
        结果
        方法的名称

      • getArguments

        public Object[] getArguments​()
        返回要调用的方法的参数。 参数的数量及其类型必须与调用的方法相匹配。 null可以用作空数组的同义词。
        结果
        参数数组

      • execute

        public void execute​()
             throws 异常
        execute方法查找名称与methodName属性相同的方法，并调用目标方法。 当目标的类定义了具有给定名称的许多方法时，实现应使用Java语言规范（15.11）中指定的算法选择最具体的方法。 目标和参数的动态类用于代替编译时类型信息，像方法类本身一样，原始值与其关联的包装器类之间的转换在内部进行处理。

        以下方法类型被处理为特殊情况：

        • 可以通过使用类对象作为目标来调用静态方法。
        • 保留方法名称“new”可以用于调用类的构造函数，就像所有类定义静态“新”方法一样。 构造函数调用通常被认为是Expression而不是Statement因为它们返回一个值。
        • List接口中定义的方法名称“get”和“set”也可以应用于数组实例，映射到Array类中同名的静态方法。
        异常
        NullPointerException - 如果 target或 methodName属性的值为 null
        NoSuchMethodException - 如果找不到匹配的方法
        SecurityException - 如果安全管理器存在并且拒绝方法调用
        异常 - 被调用的方法抛出的
        另请参见：
        方法

      • toString

        public String toString​()
        使用Java风格的语法打印此语句的值。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Transient (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.desktop
软件包 java.beans

Annotation Type Transient

  • @Target(METHOD)
@Retention(RUNTIME)
public @interface Transient
    表示当Introspector构造与注释的代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明一个名为“transient”的属性。 “瞬态”属性的true值表示从Encoder派生的编码器应忽略此功能。

    Transient注释可以用于涉及到一个FeatureDescriptor子类的任何方法来标识注释类及其子类中的瞬态特征。 通常，以“get”开头的方法是放置注释的最佳位置，在为同一特征定义多个注释的情况下，该声明优先。

    要在超类声明它的类中声明非瞬态特征，请使用@Transient(false) 。 在所有情况下， Introspector通过参考最具体的超类的注释来决定特征是否是短暂的。 如果任何超类中不存在Transient注释，则该特征不是暂时的。

    从以下版本开始：
    1.7

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      boolean value
      返回 Introspector是否应为注释方法构造工件。

    • Element Detail

      • value

        boolean value
        返回 Introspector是否应为注释方法构造工件。
        结果
        Introspector是否应为注释方法构造工件
        Default:
        真正
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Uses of Package java.beans (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.beans

  • Packages that use java.beans
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.im
    提供输入法框架的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
  • Classes in java.beans used by com.sun.java.accessibility.util
    Class 描述
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    VetoableChangeListener
    当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
  • Classes in java.beans used by com.sun.tools.jconsole
    Class 描述
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
  • Classes in java.beans used by java.awt
    Class 描述
    BeanProperty
    用于指定自动生成的BeanInfo类的某些属性相关信息的注释。
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    PropertyChangeSupport
    这是一个可以由支持绑定属性的bean使用的实用程序类。
    PropertyVetoException
    当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
    Transient
    表示当Introspector构造与注释代码元素关联的类别的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明称为“transient”的属性。
    VetoableChangeListener
    当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
  • Classes in java.beans used by java.awt.geom
    Class 描述
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
    Transient
    表示当Introspector构造与注释的代码元素相关联的一个PropertyDescriptor或EventSetDescriptor类时，应该使用给定的value声明一个名为“transient”的属性。
  • Classes in java.beans used by java.awt.im
    Class 描述
    Transient
    表示当Introspector构造与注释代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明称为“transient”的属性。
  • Classes in java.beans used by java.beans
    Class 描述
    AppletInitializer
    已过时。
    Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
    BeanDescriptor
    BeanDescriptor提供有关“bean”的全局信息，包括其Java类，其displayName等。
    BeanInfo
    使用 BeanInfo界面创建一个 BeanInfo类，并提供关于bean的方法，属性，事件和其他功能的显式信息。
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
    Encoder
    一个 Encoder是一个类，可用于创建根据其公共API编码JavaBean集合的状态的文件或流。
    EventSetDescriptor
    EventSetDescriptor描述给定的Java Bean触发的一组事件。
    ExceptionListener
    通知内部异常的ExceptionListener。
    Expression
    一个 Expression对象表示一个原始表达式，其中单个方法应用于目标和一组参数以返回结果 - 如 "a.getFoo()" 。
    FeatureDescriptor
    FeatureDescriptor类是PropertyDescriptor，EventSetDescriptor和MethodDescriptor等的常见基类。
    IntrospectionException
    内省时发生异常时抛出。
    MethodDescriptor
    MethodDescriptor描述了Java Bean支持的特定方法，用于从其他组件进行外部访问。
    ParameterDescriptor
    ParameterDescriptor类允许bean实现者提供关于每个参数的附加信息，超出java.lang.reflect.Method类提供的低级类型信息。
    PersistenceDelegate
    PersistenceDelegate类负责根据类的公共API中的方法来表达给定类的实例的状态。
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    PropertyDescriptor
    PropertyDescriptor描述了Java Bean通过一对访问器方法导出的一个属性。
    PropertyEditor
    PropertyEditor类提供对允许用户编辑给定类型的属性值的GUI的支持。
    PropertyVetoException
    当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
    Statement
    一个 Statement对象表示一个原语言，其中单个方法应用于目标和一组参数 - 如 "a.setFoo(b)" 。
    VetoableChangeListener
    当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
  • Classes in java.beans used by java.beans.beancontext
    Class 描述
    BeanInfo
    使用 BeanInfo接口创建一个 BeanInfo类，并提供关于bean的方法，属性，事件和其他功能的显式信息。
    DesignMode
    该接口旨在由java.beans.beancontext.BeanContext的实例实现或委派，以便传播到java.beans.beancontext.BeanContextChild实例（当前的“designTime”）属性的嵌套层次结构。
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    PropertyChangeSupport
    这是一个可以由支持绑定属性的bean使用的实用程序类。
    PropertyVetoException
    当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
    VetoableChangeListener
    当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
    VetoableChangeSupport
    这是一个可以由支持约束属性的bean使用的实用程序类。
    Visibility
    在某些情况下，可能在GUI不可用的服务器上运行bean。
  • Classes in java.beans used by javax.accessibility
    Class 描述
    BeanProperty
    用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
    JavaBean
    用于为自动生成的BeanInfo类指定一些类相关信息的注释。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
  • Classes in java.beans used by javax.swing
    Class 描述
    BeanProperty
    用于指定自动生成的BeanInfo类的某些属性相关信息的注释。
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
    JavaBean
    用于为自动生成的BeanInfo类指定一些类相关信息的注释。
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    PropertyChangeSupport
    这是一个可以由支持绑定属性的bean使用的实用程序类。
    PropertyVetoException
    当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
    Transient
    表示当Introspector构造与注释代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明一个名为“transient”的属性。
    VetoableChangeListener
    当一个bean更改“constrained”属性时，VetoableChange事件就被触发。
  • Classes in java.beans used by javax.swing.border
    Class 描述
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
  • Classes in java.beans used by javax.swing.colorchooser
    Class 描述
    BeanProperty
    用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
  • Classes in java.beans used by javax.swing.event
    Class 描述
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeSupport
    这是一个可以由支持绑定属性的bean使用的实用程序类。
  • Classes in java.beans used by javax.swing.plaf
    Class 描述
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
  • Classes in java.beans used by javax.swing.plaf.basic
    Class 描述
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
  • Classes in java.beans used by javax.swing.plaf.metal
    Class 描述
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
  • Classes in java.beans used by javax.swing.plaf.nimbus
    Class 描述
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
  • Classes in java.beans used by javax.swing.plaf.synth
    Class 描述
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
  • Classes in java.beans used by javax.swing.table
    Class 描述
    BeanProperty
    用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
    PropertyChangeEvent
    只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    Transient
    表示当Introspector构造与注释代码元素关联的类别的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明一个名为“transient”的属性。
  • Classes in java.beans used by javax.swing.text
    Class 描述
    BeanProperty
    用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
    JavaBean
    用于为自动生成的BeanInfo类指定一些类相关信息的注释。
    Transient
    表示当Introspector构造与注释代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明称为“transient”的属性。
  • Classes in java.beans used by javax.swing.tree
    Class 描述
    BeanProperty
    用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
    ConstructorProperties
    一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
    PropertyChangeListener
    一旦bean更改“bound”属性，就会触发“PropertyChange”事件。
    Transient
    表示当Introspector构造与注释代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明一个名为“transient”的属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VetoableChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface VetoableChangeListener

  • All Superinterfaces:
    EventListener
    所有已知实现类：
    BeanContextServicesSupport ， BeanContextSupport ， VetoableChangeListenerProxy

    public interface VetoableChangeListener
extends EventListener
    当一个bean更改“constrained”属性时，VetoableChange事件就被触发。 您可以向源bean注册一个VetoableChangeListener，以便通知任何受限的属性更新。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void vetoableChange​(PropertyChangeEvent evt)
      当更改约束属性时调用此方法。

    • 方法详细信息

      • vetoableChange

        void vetoableChange​(PropertyChangeEvent evt)
             throws PropertyVetoException
        当更改约束属性时调用此方法。
        参数
        evt - 描述事件源和已更改的属性的 PropertyChangeEvent对象。
        异常
        PropertyVetoException - 如果收件人希望回滚属性更改。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VetoableChangeListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class VetoableChangeListenerProxy

  • java.lang.Object
    • java.util.EventListenerProxy<VetoableChangeListener>
      • java.beans.VetoableChangeListenerProxy
  • All Implemented Interfaces:
    VetoableChangeListener ， EventListener

    public class VetoableChangeListenerProxy
extends EventListenerProxy<VetoableChangeListener>
implements VetoableChangeListener
    一个类扩展了EventListenerProxy专门用于添加一个“约束”属性的VetoableChangeListener 。 这个类的实例可以被添加为VetoableChangeListener s到支持射击否决更改事件的bean。

    如果对象具有getVetoableChangeListeners方法，则返回的数组可能是VetoableChangeListener和VetoableChangeListenerProxy对象的混合。

    从以下版本开始：
    1.4
    另请参见：
    EventListenerProxy ， VetoableChangeSupport.getVetoableChangeListeners()

    • 构造方法摘要

      构造方法
      Constructor 描述
      VetoableChangeListenerProxy​(String propertyName, VetoableChangeListener listener)
      构造函数将 VetoableChangeListener绑定到特定属性。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getPropertyName​()
      返回与侦听器关联的命名属性的名称。
      void vetoableChange​(PropertyChangeEvent event)
      将属性更改事件转发给侦听器代理。

      • Methods inherited from class java.util.EventListenerProxy

        getListener

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • VetoableChangeListenerProxy

        public VetoableChangeListenerProxy​(String propertyName,
                                   VetoableChangeListener listener)
        构造函数将 VetoableChangeListener绑定到特定属性。
        参数
        propertyName - 要收听的财产的名称
        listener - 侦听器对象

    • 方法详细信息

      • vetoableChange

        public void vetoableChange​(PropertyChangeEvent event)
                    throws PropertyVetoException
        将属性更改事件转发给侦听器代理。
        Specified by:
        vetoableChange在接口 VetoableChangeListener
        参数
        event - 财产变更事件
        异常
        PropertyVetoException - 如果收件人希望回滚属性更改

      • getPropertyName

        public String getPropertyName​()
        返回与侦听器关联的命名属性的名称。
        结果
        与侦听器关联的命名属性的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VetoableChangeSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class VetoableChangeSupport

  • java.lang.Object
    • java.beans.VetoableChangeSupport
  • All Implemented Interfaces:
    Serializable

    public class VetoableChangeSupport
extends Object
implements Serializable
    这是一个可以由支持约束属性的bean使用的实用程序类。 它管理一个监听器列表， 并发送给他们PropertyChangeEvent 。 您可以使用此类的实例作为bean的成员字段，并将这些类型的工作委派给它。 VetoableChangeListener可以注册所有属性或由name指定的属性。

    下面是一个VetoableChangeSupport用法的例子，它们遵循JavaBeans¢规范中规定的规则和建议：

       public class MyBean { private final VetoableChangeSupport vcs = new VetoableChangeSupport(this); public void addVetoableChangeListener(VetoableChangeListener listener) { this.vcs.addVetoableChangeListener(listener); } public void removeVetoableChangeListener(VetoableChangeListener listener) { this.vcs.removeVetoableChangeListener(listener); } private String value; public String getValue() { return this.value; } public void setValue(String newValue) throws PropertyVetoException { String oldValue = this.value; this.vcs.fireVetoableChange("value", oldValue, newValue); this.value = newValue; } [...] }

    一个VetoableChangeSupport实例是线程安全的。

    这个类是可序列化的。 当它被序列化时，它将保存（并恢复）本身可序列化的任何侦听器。 在序列化期间，任何不可序列化的监听器将被跳过。

    从以下版本开始：
    1.1
    另请参见：
    PropertyChangeSupport ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VetoableChangeSupport​(Object sourceBean)
      构造一个 VetoableChangeSupport对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addVetoableChangeListener​(VetoableChangeListener listener)
      将VetoableChangeListener添加到侦听器列表。
      void addVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      为特定属性添加VetoableChangeListener。
      void fireVetoableChange​(PropertyChangeEvent event)
      将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
      void fireVetoableChange​(String propertyName, boolean oldValue, boolean newValue)
      向已注册的监听器报告布尔约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void fireVetoableChange​(String propertyName, int oldValue, int newValue)
      向已注册的监听器报告整数约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void fireVetoableChange​(String propertyName, Object oldValue, Object newValue)
      向已注册的监听器报告受限属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      VetoableChangeListener[] getVetoableChangeListeners​()
      返回使用addVetoableChangeListener（）添加到VetoableChangeSupport对象的所有侦听器的数组。
      VetoableChangeListener[] getVetoableChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      boolean hasListeners​(String propertyName)
      检查是否有特定属性的监听器，包括在所有属性上注册的监听器。
      void removeVetoableChangeListener​(VetoableChangeListener listener)
      从侦听器列表中删除VetoableChangeListener。
      void removeVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      删除特定属性的VetoableChangeListener。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • VetoableChangeSupport

        public VetoableChangeSupport​(Object sourceBean)
        构造一个 VetoableChangeSupport对象。
        参数
        sourceBean - 要作为任何事件来源的bean。

    • 方法详细信息

      • addVetoableChangeListener

        public void addVetoableChangeListener​(VetoableChangeListener listener)
        将VetoableChangeListener添加到侦听器列表。 所有属性都注册了监听器。 同一个侦听器对象可以被多次添加，并且将被调用多次，因为它被添加。 如果listener为空，则不会抛出任何异常，也不会执行任何操作。
        参数
        listener - 要添加的VetoableChangeListener

      • removeVetoableChangeListener

        public void removeVetoableChangeListener​(VetoableChangeListener listener)
        从侦听器列表中删除VetoableChangeListener。 这会删除已为所有属性注册的VetoableChangeListener。 如果listener添加到同一个事件源，则会在被删除之后被通知一次。 如果listener为空，或者从未添加，则不会抛出异常并且不采取任何操作。
        参数
        listener - 要删除的VetoableChangeListener

      • getVetoableChangeListeners

        public VetoableChangeListener[] getVetoableChangeListeners​()
        返回使用addVetoableChangeListener（）添加到VetoableChangeSupport对象的所有侦听器的数组。

        如果一些侦听器已经添加了一个named属性，那么返回的数组将是VetoableChangeListeners和VetoableChangeListenerProxy的混合。 如果调用方法有兴趣区分侦听器，那么它必须测试每个元素以查看它是否为VetoableChangeListenerProxy ，执行该转换并检查该参数。

           VetoableChangeListener[] listeners = bean.getVetoableChangeListeners(); for (int i = 0; i < listeners.length; i++) { if (listeners[i] instanceof VetoableChangeListenerProxy) { VetoableChangeListenerProxy proxy = (VetoableChangeListenerProxy)listeners[i]; if (proxy.getPropertyName().equals("foo")) { // proxy is a VetoableChangeListener which was associated // with the property named "foo" } } }
        结果
        如果没有添加任何监听器，则添加所有 VetoableChangeListeners或一个空数组
        从以下版本开始：
        1.4
        另请参见：
        VetoableChangeListenerProxy

      • addVetoableChangeListener

        public void addVetoableChangeListener​(String propertyName,
                                      VetoableChangeListener listener)
        为特定属性添加VetoableChangeListener。 只有当调用fireVetoableChange命名该特定属性时，才调用该侦听器。 可以多次添加相同的侦听器对象。 对于每个属性，侦听器将被调用为该属性添加的次数。 如果propertyName或listener为空，则不会抛出任何异常并且不采取任何操作。
        参数
        propertyName - 要收听的属性的名称。
        listener - 要添加的VetoableChangeListener
        从以下版本开始：
        1.2

      • removeVetoableChangeListener

        public void removeVetoableChangeListener​(String propertyName,
                                         VetoableChangeListener listener)
        删除特定属性的VetoableChangeListener。 如果listener添加到指定属性的同一事件源，则在被删除之后将被通知一次。 如果propertyName为空，则不会抛出异常并且不采取任何操作。 如果listener为空，或者从未为指定的属性添加，则不会抛出任何异常，也不会执行任何操作。
        参数
        propertyName - 收听的财产的名称。
        listener - 要删除的VetoableChangeListener
        从以下版本开始：
        1.2

      • getVetoableChangeListeners

        public VetoableChangeListener[] getVetoableChangeListeners​(String propertyName)
        返回与named属性相关联的所有侦听器的数组。
        参数
        propertyName - 正在收听的财产的名称
        结果
        所有的VetoableChangeListeners与命名属性相关联。 如果没有添加此类侦听器，或者如果propertyName为空，则返回一个空数组。
        从以下版本开始：
        1.4

      • fireVetoableChange

        public void fireVetoableChange​(String propertyName,
                               Object oldValue,
                               Object newValue)
                        throws PropertyVetoException
        向已注册的监听器报告受限属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        任何听众都可以抛出一个PropertyVetoException否决更新。 如果其中一个听众否决更新，则此方法会传递一个新的“撤消” PropertyChangeEvent ，该旧的值将恢复为已经确认此更新的所有侦听器的旧值，并再次抛出PropertyVetoException 。

        如果旧值和新值相等且不为空，则不会触发事件。

        这只是一个方便的包装，围绕更一般的fireVetoableChange(PropertyChangeEvent)方法。

        参数
        propertyName - 即将更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 该物业的新值
        异常
        PropertyVetoException - 如果其中一个收听者否决属性更新

      • fireVetoableChange

        public void fireVetoableChange​(String propertyName,
                               int oldValue,
                               int newValue)
                        throws PropertyVetoException
        向已注册的监听器报告整数约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        任何听众都可以抛出一个PropertyVetoException否决更新。 如果其中一个收听者否决更新，则此方法会传递一个新的“撤消” PropertyChangeEvent ，该旧的值将恢复为已经确认此更新的所有侦听器的旧值，并再次抛出PropertyVetoException 。

        如果旧值和新值相等，则不会触发任何事件。

        这只是一个方便的包装器，围绕更一般的fireVetoableChange(String, Object, Object)方法。

        参数
        propertyName - 即将更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 该物业的新价值
        异常
        PropertyVetoException - 如果一个监听者否决属性更新
        从以下版本开始：
        1.2

      • fireVetoableChange

        public void fireVetoableChange​(String propertyName,
                               boolean oldValue,
                               boolean newValue)
                        throws PropertyVetoException
        向已注册的监听器报告布尔约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。

        任何听众都可以抛出一个PropertyVetoException否决更新。 如果其中一个收听者否决更新，则此方法会传递一个新的“撤消” PropertyChangeEvent ，该旧的值将恢复为已经确认此更新的所有侦听器的旧值，并再次抛出PropertyVetoException 。

        如果旧值和新值相等，则不会触发任何事件。

        这只是一个方便的包装，围绕更一般的fireVetoableChange(String, Object, Object)方法。

        参数
        propertyName - 即将更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 该物业的新值
        异常
        PropertyVetoException - 如果其中一个收听者否决属性更新
        从以下版本开始：
        1.2

      • fireVetoableChange

        public void fireVetoableChange​(PropertyChangeEvent event)
                        throws PropertyVetoException
        将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。

        任何听众都可以抛出一个PropertyVetoException否决更新。 如果其中一个收听者否决更新，则此方法会传递一个新的“撤消” PropertyChangeEvent ，该旧的值将恢复为已经确认此更新的所有侦听器的旧值，并再次抛出PropertyVetoException 。

        如果给定事件的旧值和新值相等且非空值，则不会触发事件。

        参数
        event - 要解雇的 PropertyChangeEvent
        异常
        PropertyVetoException - 如果其中一个监听器否决属性更新
        从以下版本开始：
        1.2

      • hasListeners

        public boolean hasListeners​(String propertyName)
        检查是否有特定属性的监听器，包括在所有属性上注册的监听器。 如果propertyName为null，则仅检查在所有属性上注册的侦听器。
        参数
        propertyName - 属性名称。
        结果
        如果给定属性有一个或多个侦听器，则为true
        从以下版本开始：
        1.2
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Visibility (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Interface Visibility

  • All Known Subinterfaces:
    BeanContext ， BeanContextServices
    所有已知实现类：
    BeanContextServicesSupport ， BeanContextSupport

    public interface Visibility
    在某些情况下，可能在GUI不可用的服务器上运行bean。 这个接口可以用来查询一个bean，以确定它是否绝对需要一个gui，并建议一个GUI是否可用。

    该界面适用于专业开发人员，并且不需要普通的简单bean。 为避免混淆最终用户，我们避免使用getXXX setXXX设计模式进行这些方法。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean avoidingGui​()
      确定这个bean是否避免使用GUI。
      void dontUseGui​()
      这个方法指示bean不应该使用Gui。
      boolean needsGui​()
      确定这个bean是否需要GUI。
      void okToUseGui​()
      这个方法指示bean可以使用Gui。

    • 方法详细信息

      • needsGui

        boolean needsGui​()
        确定这个bean是否需要GUI。
        结果
        如果bean绝对需要一个可用的GUI来完成工作，那么它就是真的。

      • dontUseGui

        void dontUseGui​()
        这个方法指示bean不应该使用Gui。

      • okToUseGui

        void okToUseGui​()
        这个方法指示bean可以使用Gui。

      • avoidingGui

        boolean avoidingGui​()
        确定这个bean是否避免使用GUI。
        结果
        如果bean当前正在避免使用Gui，则为true。 例如由于对dontUseGui（）的调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


XMLDecoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class XMLDecoder

  • java.lang.Object
    • java.beans.XMLDecoder
  • All Implemented Interfaces:
    AutoCloseable

    public class XMLDecoder
extends Object
implements AutoCloseable
    XMLDecoder类用于读取使用XMLEncoder创建的XML文档，并且像ObjectInputStream那样使用。 例如，可以使用以下片段来读取由XMLEncoder类编写的XML文档中定义的第一个对象：
      XMLDecoder d = new XMLDecoder(
                          new BufferedInputStream(
                              new FileInputStream("Test.xml")));
       Object result = d.readObject();
       d.close();

    有关更多信息，您可能还需要查看Long Term Persistence of JavaBeans Components: XML Schema ， “Swing连接”中的一篇文章。

    从以下版本开始：
    1.4
    另请参见：
    XMLEncoder ， ObjectInputStream

    • 构造方法摘要

      构造方法
      Constructor 描述
      XMLDecoder​(InputStream in)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputStream in, Object owner)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputSource is)
      创建一个新的解码器来解析由 XMLEncoder类创建的XML存档。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      此方法关闭与此流相关联的输入流。
      static DefaultHandler createHandler​(Object owner, ExceptionListener el, ClassLoader cl)
      为SAX解析器创建一个新的处理程序，可用于解析由 XMLEncoder类创建的嵌入式XML存档。
      ExceptionListener getExceptionListener​()
      获取此流的异常处理程序。
      Object getOwner​()
      获取此解码器的所有者。
      Object readObject​()
      从底层输入流读取下一个对象。
      void setExceptionListener​(ExceptionListener exceptionListener)
      将此流的异常处理程序设置为 exceptionListener 。
      void setOwner​(Object owner)
      将该解码器的所有者设置为 owner 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XMLDecoder

        public XMLDecoder​(InputStream in)
        创建一个新的输入流，用于阅读 XMLEncoder类创建的 XMLEncoder 。
        参数
        in - 底层流。
        另请参见：
        XMLEncoder(java.io.OutputStream)

      • XMLDecoder

        public XMLDecoder​(InputStream in,
                  Object owner)
        创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
        参数
        in - 底层流。
        owner - 此流的拥有者。

      • XMLDecoder

        public XMLDecoder​(InputStream in,
                  Object owner,
                  ExceptionListener exceptionListener)
        创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
        参数
        in - 底层流。
        owner - 此流的拥有者。
        exceptionListener - 流的异常处理程序; 如果null将使用默认异常侦听器。

      • XMLDecoder

        public XMLDecoder​(InputStream in,
                  Object owner,
                  ExceptionListener exceptionListener,
                  ClassLoader cl)
        创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
        参数
        in - 底层流。 null可能null地传递，尽管生成的XMLDecoder将无用
        owner - 此流的所有者。 null是一个合法的价值
        exceptionListener - 流的异常处理程序，或 null使用默认值
        cl - 用于实例化对象的类加载器。 null表示应该使用默认的类加载器
        从以下版本开始：
        1.5

      • XMLDecoder

        public XMLDecoder​(InputSource is)
        创建一个新的解码器来解析由XMLEncoder类创建的XML存档。 如果输入源is为null ，则不会抛出异常并且不执行解析。 此行为类似于使用InputStream作为参数的其他构造函数的行为。
        参数
        is - 要解析的输入源
        从以下版本开始：
        1.7

    • 方法详细信息

      • close

        public void close​()
        此方法关闭与此流相关联的输入流。
        Specified by:
        close在接口 AutoCloseable

      • setExceptionListener

        public void setExceptionListener​(ExceptionListener exceptionListener)
        将此流的异常处理程序设置为exceptionListener 。 当此流捕获可恢复的异常时，将通知异常处理程序。
        参数
        exceptionListener - 此流的异常处理程序; 如果将使用默认异常侦听器null 。
        另请参见：
        getExceptionListener()

      • getExceptionListener

        public ExceptionListener getExceptionListener​()
        获取此流的异常处理程序。
        结果
        该流的异常处理程序。 如果没有明确设置，将返回默认的异常侦听器。
        另请参见：
        setExceptionListener(java.beans.ExceptionListener)

      • readObject

        public Object readObject​()
        从底层输入流读取下一个对象。
        结果
        下一个对象读取
        异常
        ArrayIndexOutOfBoundsException - 如果流不包含对象（或不再有对象）
        另请参见：
        XMLEncoder.writeObject(java.lang.Object)

      • setOwner

        public void setOwner​(Object owner)
        将该解码器的所有者设置为 owner 。
        参数
        owner - 该解码器的所有者。
        另请参见：
        getOwner()

      • getOwner

        public Object getOwner​()
        获取此解码器的所有者。
        结果
        这个解码器的所有者。
        另请参见：
        setOwner(java.lang.Object)

      • createHandler

        public static DefaultHandler createHandler​(Object owner,
                                           ExceptionListener el,
                                           ClassLoader cl)
        为SAX解析器创建一个新的处理程序，可用于解析由XMLEncoder类创建的嵌入式XML归档。 如果解析的XML文档包含在<java>元素的上下文中的方法调用，则应使用owner 。 在这种情况下， null值可能会导致非法解析。 如果owner类不包含预期的调用方法，可能会发生同样的问题。 查看详细here 。
        参数
        owner - 可以用作<java>元素值的默认处理程序的所有者
        el - 解析器的异常处理程序，或 null使用默认异常处理程序
        cl - 用于实例化对象的类加载器，或 null使用默认的类加载器
        结果
        SAX解析器的一个实例为 DefaultHandler
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


XMLEncoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans

Class XMLEncoder

  • java.lang.Object
    • java.beans.Encoder
      • java.beans.XMLEncoder
  • All Implemented Interfaces:
    AutoCloseable

    public class XMLEncoder
extends Encoder
implements AutoCloseable
    所述XMLEncoder类是互补替代ObjectOutputStream ，并且可以用于产生以相同的方式，该一个JavaBean的文本表示ObjectOutputStream可以用来创建的二进制表示Serializable对象。 例如，以下片段可用于创建提供的JavaBean及其所有属性的文本表示形式：
      XMLEncoder e = new XMLEncoder(
                          new BufferedOutputStream(
                              new FileOutputStream("Test.xml")));
       e.writeObject(new JButton("Hello, world"));
       e.close();
    尽管它们的API相似，但是XMLEncoder类是专门为将JavaBean的图形归档为其公共属性的文本表示而专门设计的。 像Java源文件一样，以这种方式编写的文档对所涉及的类的实现的变化具有自然的免疫力。 继续推荐ObjectOutputStream用于进程间通信和通用序列化。

    XMLEncoder类提供了JavaBean的默认表示形式，它们被表示为符合XML规范版本1.0的XML文档和Unicode / ISO 10646字符集的UTF-8字符编码。 由XMLEncoder类生成的XML文档有：

    • 便携式和版本弹性 ：它们不依赖于任何类的私有实现，因此，像Java源文件一样，它们可能在可能具有不同版本的某些类和不同供应商的VM之间交换。
    • 结构紧凑 ： XMLEncoder类在内部使用冗余消除算法，以使Bean的属性的默认值不会写入流。
    • 容错 ：文件中的非结构性错误是由文件损坏引起的，或者对归档中的类进行的API更改导致的本地化，以便读者可以报告错误，并继续加载不是文档的部分受到错误的影响。

    以下是包含swing工具包中的一些用户界面组件的XML存档示例：

      <?xml version="1.0" encoding="UTF-8"?>
 <java version="1.0" class="java.beans.XMLDecoder">
 <object class="javax.swing.JFrame">
   <void property="name">
     <string>frame1</string>
   </void>
   <void property="bounds">
     <object class="java.awt.Rectangle">
       <int>0</int>
       <int>0</int>
       <int>200</int>
       <int>200</int>
     </object>
   </void>
   <void property="contentPane">
     <void method="add">
       <object class="javax.swing.JButton">
         <void property="label">
           <string>Hello</string>
         </void>
       </object>
     </void>
   </void>
   <void property="visible">
     <boolean>true</boolean>
   </void>
 </object>
 </java>
    XML语法使用以下约定：
    • 每个元素表示方法调用。
    • “对象”标签表示一个表达式，其值将用作封闭元素的参数。
    • “void”标签表示将被执行的语句 ，但其结果将不会用作封闭方法的参数。
    • 包含元素的元素使用这些元素作为参数，除非它们具有标签：“void”。
    • 方法的名称由“method”属性表示。
    • XML的标准“id”和“idref”属性用于对前面的表达式进行引用，以便处理对象图形中的循环。
    • “类”属性用于明确指定静态方法或构造函数的目标; 其值是该类的完全限定名称。
    • 如果没有由“class”属性定义目标，则使用“void”标签的元素将使用外部上下文作为目标来执行。
    • Java的String类被特别处理，并写入<string> Hello，world </ string>，其中使用UTF-8字符编码将字符串的字符转换为字节。

    尽管所有对象图都可以使用这三个标签来写入，但是包含以下定义可以更简明地表达常见的数据结构：

    • 默认方法名称为“new”。
    • 对java类的引用以<class> javax.swing.JButton </ class>的形式编写。
    • Java原始类型的包装器类的实例使用原始类型的名称作为标签编写。 例如， Integer类的一个实例可以写成：<int> 123 </ int>。 请注意， XMLEncoder类使用Java的反射包，其中Java的原始类型与其关联的“包装器类”之间的转换在内部进行处理。 XMLEncoder类的API本身只涉及Object 。
    • 在一个表示以“get”开头的空值方法的元素中，“method”属性被替换为“property”属性，该属性的值通过删除“get”前缀并对结果进行重新赋值。
    • 在表示以“set”开头的单体方法的元素中，“method”属性被替换为“property”属性，该属性的值通过删除“set”前缀并对结果进行重新赋值来给出。
    • 在一个表示一个名为“get”的方法中使用一个整数参数的元素中，“method”属性被替换为“index”属性，其值为第一个参数的值。
    • 在一个表示一个名为“set”的元素的元素中，它有两个参数，其中第一个是一个整数，“method”属性被替换为“index”属性，其值是第一个参数的值。
    • 使用“array”标签写入数组的引用。 “类”和“长度”属性分别指定数组的子类型及其长度。

    有关更多信息，您可能还需要查看Using XMLEncoder ， “Swing连接”中的一篇文章。

    从以下版本开始：
    1.4
    另请参见：
    XMLDecoder ， ObjectOutputStream

    • 构造方法摘要

      构造方法
      Constructor 描述
      XMLEncoder​(OutputStream out)
      创建一个新的XML编码器，使用XML编码将 JavaBeans写入流 out 。
      XMLEncoder​(OutputStream out, String charset, boolean declaration, int indentation)
      创建一个新的XML编码器 的JavaBeans写出到流 out使用给定 charset从给定的起始 indentation 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      该方法调用 flush ，写入关闭后缀，然后关闭与此流相关联的输出流。
      void flush​()
      如果尚未写入与XML编码相关联的前导码，则该方法会写出自上次调用 flush以来写入流的所有值。
      Object getOwner​()
      获取该编码器的所有者。
      void setOwner​(Object owner)
      将该编码器的所有者设置为 owner 。
      void writeExpression​(Expression oldExp)
      记录表达式，以便当流被刷新时，编码器将产生实际的输出。
      void writeObject​(Object o)
      将指定对象的XML表示形式写入输出。
      void writeStatement​(Statement oldStm)
      记录声明，以便编码器将在流被冲洗时产生实际的输出。

      • Methods inherited from class java.beans.Encoder

        get, getExceptionListener, getPersistenceDelegate, remove, setExceptionListener, setPersistenceDelegate

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XMLEncoder

        public XMLEncoder​(OutputStream out)
        创建一个新的XML编码器，使用XML编码将 JavaBeans写入流 out 。
        参数
        out - 要写入对象的XML表示形式的流
        异常
        IllegalArgumentException - 如果 out是 null
        另请参见：
        XMLDecoder(InputStream)

      • XMLEncoder

        public XMLEncoder​(OutputStream out,
                  String charset,
                  boolean declaration,
                  int indentation)
        创建一个新的XML编码器 的JavaBeans写出到流 out使用给定 charset从给定的起始 indentation 。
        参数
        out - 要写入对象的XML表示形式的流
        charset - 请求的字符集的名称; 可能是规范名称或别名
        declaration - 是否应该生成XML声明; 在将内容嵌入到另一个XML文档中时，请将其设置为false
        indentation - 用于缩进整个XML文档的空格字符数
        异常
        IllegalArgumentException - 如果 out或 charset是 null ，或者如果 indentation小于0
        IllegalCharsetNameException - 如果是 charset名字是非法的
        UnsupportedCharsetException - 如果在Java虚拟机的此实例中不支持命名的字符集
        UnsupportedOperationException - 如果加载的字符集不支持编码
        从以下版本开始：
        1.7
        另请参见：
        Charset.forName(String)

    • 方法详细信息

      • setOwner

        public void setOwner​(Object owner)
        将此编码器的所有者设置为 owner 。
        参数
        owner - 该编码器的所有者。
        另请参见：
        getOwner()

      • getOwner

        public Object getOwner​()
        获取该编码器的所有者。
        结果
        该编码器的所有者。
        另请参见：
        setOwner(java.lang.Object)

      • writeObject

        public void writeObject​(Object o)
        将指定对象的XML表示形式写入输出。
        重写：
        writeObject在 Encoder
        参数
        o - o的对象。
        另请参见：
        XMLDecoder.readObject()

      • writeStatement

        public void writeStatement​(Statement oldStm)
        记录声明，以便编码器将在流被冲洗时产生实际的输出。

        该方法只能在初始化持久性委托的上下文中被调用。

        重写：
        writeStatement在 Encoder
        参数
        oldStm - 将写入流的语句。
        另请参见：
        PersistenceDelegate.initialize(java.lang.Class<?>, java.lang.Object, java.lang.Object, java.beans.Encoder)

      • writeExpression

        public void writeExpression​(Expression oldExp)
        记录表达式，以便当流被刷新时，编码器将产生实际的输出。

        该方法只能在初始化持久代理或设置编码器以从资源束读取的上下文中被调用。

        有关使用资源束与XMLEncoder的更多信息，请参阅Creating Internationalized Applications ，

        重写：
        writeExpression在 Encoder
        参数
        oldExp - 将写入流的表达式。
        另请参见：
        PersistenceDelegate.initialize(java.lang.Class<?>, java.lang.Object, java.lang.Object, java.beans.Encoder)

      • flush

        public void flush​()
        如果尚未写入与XML编码相关联的前导码，则该方法会写出自上次调用flush以来写入流的所有值。 刷新后，将清除写入此流的值的所有内部引用。

      • close

        public void close​()
        该方法调用 flush ，写入关闭后缀，然后关闭与此流相关联的输出流。
        Specified by:
        close in interface AutoCloseable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContext

  • All Superinterfaces:
    BeanContextChild ， Collection ， DesignMode ， Iterable<E> ， Visibility
    All Known Subinterfaces:
    BeanContextServices
    所有已知实现类：
    BeanContextServicesSupport ， BeanContextSupport

    public interface BeanContext
extends BeanContextChild, Collection, DesignMode, Visibility

    BeanContext对JavaBeans起着逻辑分层容器的作用。

    从以下版本开始：
    1.2
    另请参见：
    Beans ， BeanContextChild ， BeanContextMembershipListener ， PropertyChangeEvent ， DesignMode ， Visibility ， Collection

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Object globalHierarchyLock
      这个全局锁由 BeanContext和 BeanContextServices实现者使用，以序列化 BeanContext层次结构中的更改和任何服务请求等。

      • Fields inherited from interface java.beans.DesignMode

        PROPERTYNAME

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      添加指定 BeanContextMembershipListener接收 BeanContextMembershipEvents从这个 BeanContext无论何时添加或删除孩子 Component （S）。
      URL getResource​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。
      InputStream getResourceAsStream​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许一个 BeanContext实现介入孩子 Component和底层的 ClassLoader之间的行为。
      Object instantiateChild​(String beanName)
      实例化命名为此 BeanContext的小孩的javaBean。
      void removeBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      删除指定的 BeanContextMembershipListener以便在添加或删除子项 Component时不再接收 BeanContextMembershipEvent 。

      • Methods inherited from interface java.beans.beancontext.BeanContextChild

        addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext

      • Methods inherited from interface java.util.Collection

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, parallelStream, remove, removeAll, removeIf, retainAll, size, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.beans.DesignMode

        isDesignTime, setDesignTime

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.beans.Visibility

        avoidingGui, dontUseGui, needsGui, okToUseGui

    • 字段详细信息

      • globalHierarchyLock

        static final Object globalHierarchyLock
        这个全局锁由 BeanContext和 BeanContextServices实现者使用，以序列化 BeanContext层次结构和任何服务请求等中的更改。

    • 方法详细信息

      • instantiateChild

        Object instantiateChild​(String beanName)
                 throws IOException,
                        ClassNotFoundException
        实例化命名为此BeanContext的小孩的javaBean。 JavaBean的实现是从beanName参数的值派生的，由java.beans.Beans.instantiate()方法定义。
        参数
        beanName - 要将此实例化的JavaBean的名称作为此 BeanContext的小孩
        结果
        一个javaBean命名为这个 BeanContext的孩子
        异常
        IOException - 如果发生IO问题
        ClassNotFoundException - 如果没有找到由beanName参数标识的类

      • getResourceAsStream

        InputStream getResourceAsStream​(String name,
                                BeanContextChild bcc)
                         throws IllegalArgumentException
        对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。
        参数
        name - 资源名称
        bcc - 指定的孩子
        结果
        一个 InputStream读取资源，或者 null如果资源不能被发现。
        异常
        IllegalArgumentException - 如果资源无效

      • getResource

        URL getResource​(String name,
                BeanContextChild bcc)
         throws IllegalArgumentException
        对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实现介入孩子 Component和底层的 ClassLoader之间的行为。
        参数
        name - 资源名称
        bcc - 指定的孩子
        结果
        一个 URL为指定的子的命名资源
        异常
        IllegalArgumentException - 如果资源无效

      • addBeanContextMembershipListener

        void addBeanContextMembershipListener​(BeanContextMembershipListener bcml)
        添加指定 BeanContextMembershipListener接收 BeanContextMembershipEvents从这个 BeanContext无论何时添加或删除孩子 Component （S）。
        参数
        bcml - 要添加的BeanContextMembershipListener

      • removeBeanContextMembershipListener

        void removeBeanContextMembershipListener​(BeanContextMembershipListener bcml)
        删除指定的 BeanContextMembershipListener以便在添加或删除子项 Component时不再接收 BeanContextMembershipEvent 。
        参数
        bcml - 要删除的 BeanContextMembershipListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextChild

  • All Known Subinterfaces:
    BeanContext ， BeanContextServices
    所有已知实现类：
    BeanContextChildSupport ， BeanContextServicesSupport ， BeanContextSupport

    public interface BeanContextChild

    希望嵌套在JavaBeans中，并且获得对它们的执行环境的引用，或者由BeanContext子接口定义的上下文将实现该接口。

    一致BeanContexts应作为添加BeanContextChild对象的副作用，通过此接口的setBeanContext（）方法传递对自身的引用。

    请注意，BeanContextChild可能会通过抛出PropertyVetoedException作为响应来拒绝状态更改。

    为了使持久性机制能够在各种场景下的BeanContextChild实例上正常运行，实现此接口的类需要定义为可能包含或表示引用嵌套的瞬时，任何或所有字段或实例变量BeanContext实例或从BeanContext通过任何未指定的机制获取的其他资源。

    从以下版本开始：
    1.2
    另请参见：
    BeanContext ， PropertyChangeEvent ， PropertyChangeListener ， PropertyVetoException ， VetoableChangeListener

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(String name, PropertyChangeListener pcl)
      添加一个 PropertyChangeListener到这个 BeanContextChild为了接收一个 PropertyChangeEvent每当指定的属性更改。
      void addVetoableChangeListener​(String name, VetoableChangeListener vcl)
      在此 BeanContextChild添加一个 VetoableChangeListener ，以便在指定的属性更改时接收事件。
      BeanContext getBeanContext​()
      获取 BeanContext与此 BeanContextChild相关联。
      void removePropertyChangeListener​(String name, PropertyChangeListener pcl)
      从 BeanContextChild删除 PropertyChangeListener ，以便在指定的属性更改时不再接收 PropertyChangeEvents 。
      void removeVetoableChangeListener​(String name, VetoableChangeListener vcl)
      从此 BeanContextChild删除 VetoableChangeListener ，以便在指定的属性更改时不再收到事件。
      void setBeanContext​(BeanContext bc)
      实现此接口的对象将使用参数：propertyName“beanContext”，oldValue（先前嵌套的 BeanContext实例或 null ），newValue（当前嵌套的 BeanContext实例或 null ） null 。

    • 方法详细信息

      • setBeanContext

        void setBeanContext​(BeanContext bc)
             throws PropertyVetoException

        实现此接口的对象将使用参数：propertyName“beanContext”，oldValue（先前嵌套的BeanContext实例或null ），newValue（当前嵌套的BeanContext实例或null ） null 。

        BeanContextChild嵌套BeanContext属性值的更改可能会被抛出相应的异常而被否决。

        参数
        bc - BeanContext与此 BeanContextChild关联。
        异常
        PropertyVetoException - 如果添加指定的 BeanContext被拒绝。

      • getBeanContext

        BeanContext getBeanContext​()
        获取 BeanContext与此 BeanContextChild相关联。
        结果
        该 BeanContext与此 BeanContextChild相关联。

      • addPropertyChangeListener

        void addPropertyChangeListener​(String name,
                               PropertyChangeListener pcl)
        添加一个 PropertyChangeListener到这个 BeanContextChild为了接收一个 PropertyChangeEvent每当指定的属性更改。
        参数
        name - 要收听的财产的名称
        pcl - 添加 PropertyChangeListener

      • removePropertyChangeListener

        void removePropertyChangeListener​(String name,
                                  PropertyChangeListener pcl)
        从此 BeanContextChild删除 PropertyChangeListener ，以便在指定的属性更改时不再接收 PropertyChangeEvents 。
        参数
        name - 收听的财产的名称
        pcl - 要删除的 PropertyChangeListener

      • addVetoableChangeListener

        void addVetoableChangeListener​(String name,
                               VetoableChangeListener vcl)
        在此 BeanContextChild添加一个 VetoableChangeListener ，以便在指定的属性更改时接收事件。
        参数
        name - 要收听的财产的名称
        vcl - 添加 VetoableChangeListener

      • removeVetoableChangeListener

        void removeVetoableChangeListener​(String name,
                                  VetoableChangeListener vcl)
        从此 BeanContextChild删除 VetoableChangeListener ，以便在指定的属性更改时不再收到事件。
        参数
        name - 收听的财产的名称。
        vcl - 要删除的 VetoableChangeListener 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextChildComponentProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextChildComponentProxy

  • public interface BeanContextChildComponentProxy

    该接口由BeanContextChildren实现，其具有与它们相关联的AWT Component 。

    从以下版本开始：
    1.2
    另请参见：
    BeanContext ， BeanContextSupport

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Component getComponent​()
      获取 java.awt.Component与此 BeanContextChild相关联。

    • 方法详细信息

      • getComponent

        Component getComponent​()
        获取 java.awt.Component与此 BeanContextChild相关联。
        结果
        在AWT Component与此相关 BeanContextChild
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextChildSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextChildSupport

  • java.lang.Object
    • java.beans.beancontext.BeanContextChildSupport
  • All Implemented Interfaces:
    BeanContextChild ， BeanContextServiceRevokedListener ， BeanContextServicesListener ， Serializable ， EventListener
    已知直接子类：
    BeanContextSupport

    public class BeanContextChildSupport
extends Object
implements BeanContextChild, BeanContextServicesListener, Serializable

    这是一个通用支持类，用于为实现BeanContextChild协议提供支持。 该类可以被直接子类化，或被封装和委派以便为给定的组件实现该接口。

    从以下版本开始：
    1.2
    另请参见：
    BeanContext ， BeanContextServices ， BeanContextChild ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected BeanContext beanContext
      bean上下文。
      BeanContextChild beanContextChildPeer
      该 BeanContext在此 BeanContextChild是嵌套。
      protected PropertyChangeSupport pcSupport
      该 PropertyChangeSupport与此 BeanContextChildSupport相关联。
      protected boolean rejectedSetBCOnce
      指示为尝试的setBeanContext操作抛出至少一个 PropertyChangeVetoException的标志。
      protected VetoableChangeSupport vcSupport
      该 VetoableChangeSupport与此 BeanContextChildSupport相关联。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BeanContextChildSupport​()
      构造一个BeanContextChildSupport，此类已经被子类化，以便实现JavaBean组件本身。
      BeanContextChildSupport​(BeanContextChild bcc)
      构造一个BeanContextChildSupport，其中JavaBean组件自身实现BeanContextChild，并封装了这个，将该接口委派给此实现

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addPropertyChangeListener​(String name, PropertyChangeListener pcl)
      为特定属性添加PropertyChangeListener。
      void addVetoableChangeListener​(String name, VetoableChangeListener vcl)
      为特定属性添加VetoableChangeListener。
      void firePropertyChange​(String name, Object oldValue, Object newValue)
      向任何已注册的监听器报告绑定属性更新。
      void fireVetoableChange​(String name, Object oldValue, Object newValue)
      向任何已注册的听众报告否决权属性更新。
      BeanContext getBeanContext​()
      获取嵌套 BeanContext这个 BeanContextChildSupport 。
      BeanContextChild getBeanContextChildPeer​()
      获取 BeanContextChild与此 BeanContextChildSupport相关联。
      protected void initializeBeanContextResources​()
      该方法可能被子类覆盖，以提供自己的初始化行为。
      boolean isDelegated​()
      报告这个班级是否是另一个班级的代表。
      protected void releaseBeanContextResources​()
      这个方法可能被子类覆盖，以提供自己的释放行为。
      void removePropertyChangeListener​(String name, PropertyChangeListener pcl)
      删除特定属性的PropertyChangeListener。
      void removeVetoableChangeListener​(String name, VetoableChangeListener vcl)
      删除一个 VetoableChangeListener 。
      void serviceAvailable​(BeanContextServiceAvailableEvent bcsae)
      嵌套BeanContext提供了新的服务。
      void serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
      嵌套BeanContext提供的服务已被撤销。
      void setBeanContext​(BeanContext bc)
      设置 BeanContext为这 BeanContextChildSupport 。
      boolean validatePendingSetBeanContext​(BeanContext newValue)
      从setBeanContext调用以验证（或以其他方式）嵌套BeanContext属性值中的挂起更改。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • beanContextChildPeer

        public BeanContextChild beanContextChildPeer
        其中 BeanContext其中 BeanContextChild是嵌套的。

      • pcSupport

        protected PropertyChangeSupport pcSupport
        该 PropertyChangeSupport与此 BeanContextChildSupport相关联。

      • vcSupport

        protected VetoableChangeSupport vcSupport
        该 VetoableChangeSupport与此 BeanContextChildSupport相关联。

      • beanContext

        protected transient BeanContext beanContext
        bean上下文。

      • rejectedSetBCOnce

        protected transient boolean rejectedSetBCOnce
        指示为尝试的setBeanContext操作抛出至少一个 PropertyChangeVetoException的标志。

    • 构造方法详细信息

      • BeanContextChildSupport

        public BeanContextChildSupport​()
        构造一个BeanContextChildSupport，此类已经被子类化，以便实现JavaBean组件本身。

      • BeanContextChildSupport

        public BeanContextChildSupport​(BeanContextChild bcc)
        构造一个BeanContextChildSupport，其中JavaBean组件自身实现BeanContextChild，并封装了这个，将该接口委派给此实现
        参数
        bcc - 底层bean上下文子

    • 方法详细信息

      • setBeanContext

        public void setBeanContext​(BeanContext bc)
                    throws PropertyVetoException
        设置 BeanContext为这 BeanContextChildSupport 。
        Specified by:
        setBeanContext在接口 BeanContextChild
        参数
        bc - 要分配给 BeanContext属性的新值
        异常
        PropertyVetoException - 如果更改被拒绝

      • getBeanContext

        public BeanContext getBeanContext​()
        获取嵌套 BeanContext这个 BeanContextChildSupport 。
        Specified by:
        getBeanContext在接口 BeanContextChild
        结果
        嵌套 BeanContext为这 BeanContextChildSupport 。

      • addPropertyChangeListener

        public void addPropertyChangeListener​(String name,
                                      PropertyChangeListener pcl)
        为特定属性添加PropertyChangeListener。 可以多次添加相同的侦听器对象。 对于每个属性，侦听器将被调用为该属性添加的次数。 如果name或pcl为null，则不会抛出任何异常并且不采取任何操作。
        Specified by:
        addPropertyChangeListener在接口 BeanContextChild
        参数
        name - 要收听的属性的名称
        pcl - 要添加的 PropertyChangeListener

      • removePropertyChangeListener

        public void removePropertyChangeListener​(String name,
                                         PropertyChangeListener pcl)
        删除特定属性的PropertyChangeListener。 如果pcl添加到指定属性的同一事件源，则在被删除之后会被通知一次。 如果name为空，则不会抛出任何异常并且不采取任何操作。 如果pcl为空，或者从未为指定的属性添加，则不会抛出任何异常，也不会执行任何操作。
        Specified by:
        removePropertyChangeListener在接口 BeanContextChild
        参数
        name - 收听的财产的名称
        pcl - 要删除的PropertyChangeListener

      • addVetoableChangeListener

        public void addVetoableChangeListener​(String name,
                                      VetoableChangeListener vcl)
        为特定属性添加VetoableChangeListener。 可以多次添加相同的侦听器对象。 对于每个属性，侦听器将被调用为该属性添加的次数。 如果name或vcl为空，则不会抛出任何异常并且不采取任何操作。
        Specified by:
        addVetoableChangeListener在接口 BeanContextChild
        参数
        name - 要收听的财产的名称
        vcl - 要添加的 VetoableChangeListener

      • removeVetoableChangeListener

        public void removeVetoableChangeListener​(String name,
                                         VetoableChangeListener vcl)
        删除一个VetoableChangeListener 。 如果pcl添加到指定属性的同一事件源，则会在被删除之后被通知一次。 如果name为null，则不会抛出异常并且不采取任何操作。 如果vcl为空，或者从未为指定的属性添加，则不会抛出异常，也不会执行任何操作。
        Specified by:
        removeVetoableChangeListener在接口 BeanContextChild
        参数
        name - 收听的财产的名称
        vcl - 要删除的 VetoableChangeListener

      • serviceRevoked

        public void serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
        嵌套BeanContext提供的服务已被撤销。 子类可以覆盖此方法以实现自己的行为。
        Specified by:
        serviceRevoked在接口 BeanContextServiceRevokedListener
        参数
        bcsre - 由于服务被撤销， BeanContextServiceRevokedEvent被触发

      • serviceAvailable

        public void serviceAvailable​(BeanContextServiceAvailableEvent bcsae)
        嵌套BeanContext提供了新的服务。 200的X- 200 X-
        Specified by:
        serviceAvailable在接口 BeanContextServicesListener
        参数
        bcsae - 由于服务变得可用，BeanContextServiceAvailableEvent被触发

      • getBeanContextChildPeer

        public BeanContextChild getBeanContextChildPeer​()
        获取 BeanContextChild与此 BeanContextChildSupport相关联。
        结果
        新新 BeanContextChild

      • isDelegated

        public boolean isDelegated​()
        报告这个班级是否是另一个班级的代表。
        结果
        如果这个类是另一个的委托，则为true

      • firePropertyChange

        public void firePropertyChange​(String name,
                               Object oldValue,
                               Object newValue)
        向任何已注册的监听器报告绑定属性更新。 如果旧的和新的相等且非空，则不会触发任何事件。
        参数
        name - 已更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - 物业的新价值

      • fireVetoableChange

        public void fireVetoableChange​(String name,
                               Object oldValue,
                               Object newValue)
                        throws PropertyVetoException
        向任何已注册的听众报告否决权属性更新。 如果有人对此进行了修改，然后点击一个新的事件，将每个人都恢复到旧值，然后重新抛出PropertyVetoException。

        如果旧的和新的相等且非空，则不会触发任何事件。

        参数
        name - 即将更改的属性的编程名称
        oldValue - 该物业的旧值
        newValue - - 该属性的新值
        异常
        PropertyVetoException - 如果收件人希望回滚属性更改。

      • validatePendingSetBeanContext

        public boolean validatePendingSetBeanContext​(BeanContext newValue)
        从setBeanContext调用以验证（或以其他方式）嵌套BeanContext属性值中的挂起更改。 返回false将导致setBeanContext抛出PropertyVetoException。
        参数
        newValue - 为BeanContext属性请求的新值
        结果
        true如果变更操作被否决

      • releaseBeanContextResources

        protected void releaseBeanContextResources​()
        这个方法可能被子类覆盖，以提供自己的释放行为。 当调用此实例从其当前BeanContext属性获取的任何资源应该被释放，因为该对象不再嵌套在该BeanContext中。

      • initializeBeanContextResources

        protected void initializeBeanContextResources​()
        该方法可能被子类覆盖，以提供自己的初始化行为。 当调用BeanContextChild所需的任何资源时，应该从当前的BeanContext获取。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextContainerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextContainerProxy

  • public interface BeanContextContainerProxy

    该接口由BeanContexts实现，它们具有与它们相关联的AWT容器。

    从以下版本开始：
    1.2
    另请参见：
    BeanContext ， BeanContextSupport

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Container getContainer​()
      获取 java.awt.Container与此 BeanContext相关联。

    • 方法详细信息

      • getContainer

        Container getContainer​()
        获取 java.awt.Container与此 BeanContext相关联。
        结果
        该 java.awt.Container与此 BeanContext相关联。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextEvent

  • java.lang.Object
    • java.util.EventObject
      • java.beans.beancontext.BeanContextEvent
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    BeanContextMembershipEvent ， BeanContextServiceAvailableEvent ， BeanContextServiceRevokedEvent

    public abstract class BeanContextEvent
extends EventObject

    BeanContextEvent是从BeanContext的语义发出的所有事件的抽象根事件类。 该类引入了一种机制，允许通过BeanContext的层次结构传播BeanContextEvent子类。 setPropagatedFrom()和getPropagatedFrom()方法允许BeanContext将自身标识为传播事件的源。

    从以下版本开始：
    1.2
    另请参见：
    BeanContext ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected BeanContext propagatedFrom
      传播此事件的 BeanContext

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected BeanContextEvent​(BeanContext bc)
      Contruct一个BeanContextEvent

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BeanContext getBeanContext​()
      获得与此事件相关的 BeanContext 。
      BeanContext getPropagatedFrom​()
      获取此事件传播的 BeanContext 。
      boolean isPropagated​()
      报告此事件是否从其他 BeanContext传播。
      void setPropagatedFrom​(BeanContext bc)
      设置传播此事件的 BeanContext 。

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • propagatedFrom

        protected BeanContext propagatedFrom
        传播此事件的 BeanContext

    • 构造方法详细信息

      • BeanContextEvent

        protected BeanContextEvent​(BeanContext bc)
        Contruct一个BeanContextEvent
        参数
        bc - BeanContext源码

    • 方法详细信息

      • getBeanContext

        public BeanContext getBeanContext​()
        获得与此事件关联的 BeanContext 。
        结果
        BeanContext与此事件相关联。

      • setPropagatedFrom

        public void setPropagatedFrom​(BeanContext bc)
        设置传播此事件的 BeanContext 。
        参数
        bc - 传播此事件的 BeanContext

      • getPropagatedFrom

        public BeanContext getPropagatedFrom​()
        获取此事件传播的 BeanContext 。
        结果
        这个事件从此传播的 BeanContext

      • isPropagated

        public boolean isPropagated​()
        报告此事件是否从其他 BeanContext传播。
        结果
        true如果传播， false如果没有
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextMembershipEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextMembershipEvent

  • java.lang.Object
    • java.util.EventObject
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextMembershipEvent
  • All Implemented Interfaces:
    Serializable

    public class BeanContextMembershipEvent
extends BeanContextEvent
    A BeanContextMembershipEvent封装了添加到特定BeanContext的成员资格或从其中删除的子项列表。 在给定的BeanContext实例上调用成功的add（），remove（），retainAll（），removeAll（）或clear（）时，此事件的实例将被触发。 有兴趣接收此类事件的对象必须实现BeanContextMembershipListener接口，并且必须通过BeanContext的addBeanContextMembershipListener(BeanContextMembershipListener bcml)方法注册其意图。
    从以下版本开始：
    1.2
    另请参见：
    BeanContext ， BeanContextEvent ， BeanContextMembershipListener ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Collection children
      受此事件通知影响的小孩列表。

      • Fields inherited from class java.beans.beancontext.BeanContextEvent

        propagatedFrom

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      BeanContextMembershipEvent​(BeanContext bc, Object[] changes)
      引发BeanContextMembershipEvent
      BeanContextMembershipEvent​(BeanContext bc, Collection changes)
      引发BeanContextMembershipEvent

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean contains​(Object child)
      孩子指定是否受到事件的影响？
      Iterator iterator​()
      获取受此事件影响的子项数组。
      int size​()
      获取受通知影响的孩子数量。
      Object[] toArray​()
      获取受此事件影响的子项数组。

      • Methods inherited from class java.beans.beancontext.BeanContextEvent

        getBeanContext, getPropagatedFrom, isPropagated, setPropagatedFrom

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • children

        protected Collection children
        受此事件通知影响的小孩列表。

    • 构造方法详细信息

      • BeanContextMembershipEvent

        public BeanContextMembershipEvent​(BeanContext bc,
                                  Collection changes)
        引发BeanContextMembershipEvent
        参数
        bc - BeanContext源码
        changes - 受影响的儿童
        异常
        NullPointerException - 如果 changes是 null

      • BeanContextMembershipEvent

        public BeanContextMembershipEvent​(BeanContext bc,
                                  Object[] changes)
        引发BeanContextMembershipEvent
        参数
        bc - BeanContext源码
        changes - 儿童受影响
        异常
        NullPointerException - 如果与此事件相关联的更改为空。

    • 方法详细信息

      • size

        public int size​()
        获取受通知影响的孩子数量。
        结果
        受通知影响的儿童人数

      • contains

        public boolean contains​(Object child)
        孩子指定是否受到事件的影响？
        参数
        child - 检查受影响的对象
        结果
        true如果受影响， false如果没有

      • toArray

        public Object[] toArray​()
        获取受此事件影响的子项数组。
        结果
        受影响的儿童阵列

      • iterator

        public Iterator iterator​()
        获取受此事件影响的子项数组。
        结果
        一连串的儿童受到影响
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextMembershipListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextMembershipListener

  • All Superinterfaces:
    EventListener

    public interface BeanContextMembershipListener
extends EventListener

    BeanContext的成员状态发生变化时，BeanContexts会在此界面上触发事件。

    从以下版本开始：
    1.2
    另请参见：
    BeanContext

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void childrenAdded​(BeanContextMembershipEvent bcme)
      当一个孩子或儿童列表被添加到这个听众注册的 BeanContext时调用。
      void childrenRemoved​(BeanContextMembershipEvent bcme)
      当从该注册人注册的 BeanContext中删除了一个小孩或儿童列表时调用。

    • 方法详细信息

      • childrenAdded

        void childrenAdded​(BeanContextMembershipEvent bcme)
        当一个孩子或儿童列表被添加到这个监听者注册的 BeanContext时调用。
        参数
        bcme - 描述发生变化的 BeanContextMembershipEvent 。

      • childrenRemoved

        void childrenRemoved​(BeanContextMembershipEvent bcme)
        当从该注册者注册的 BeanContext中删除了一个小孩或儿童列表时调用。
        参数
        bcme - 描述发生变化的 BeanContextMembershipEvent 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextProxy

  • public interface BeanContextProxy

    该接口由不直接具有与之关联的BeanContext（Child）的JavaBean实现（通过实现该接口或其子接口），但具有从其委托的公共BeanContext（Child）。 例如，java.awt.Container的子类可能具有与之关联的BeanContext，该Container的所有Component子项都将包含在其中。

    一个对象可能不实现这个接口，而且它们是互斥的BeanContextChild接口（或者它们的任何子接口）。

    此接口的调用者将检查返回类型，以获取BeanContextChild的特定子接口，如下所示：

       BeanContextChild bcc = o.getBeanContextProxy(); if (bcc instanceof BeanContext) { // ... }
    要么
       BeanContextChild bcc = o.getBeanContextProxy(); BeanContext bc = null; try { bc = (BeanContext)bcc; } catch (ClassCastException cce) { // cast failed, bcc is not an instanceof BeanContext }

    返回值是实现实例的生命周期的常数

    从以下版本开始：
    1.2
    另请参见：
    BeanContextChild ， BeanContextChildSupport

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BeanContextChild getBeanContextProxy​()
      获取与此对象关联的 BeanContextChild （或子接口）。

    • 方法详细信息

      • getBeanContextProxy

        BeanContextChild getBeanContextProxy​()
        获取与此对象关联的 BeanContextChild （或子接口）。
        结果
        与此对象关联的 BeanContextChild （或子 BeanContextChild ）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServiceAvailableEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextServiceAvailableEvent

  • java.lang.Object
    • java.util.EventObject
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextServiceAvailableEvent
  • All Implemented Interfaces:
    Serializable

    public class BeanContextServiceAvailableEvent
extends BeanContextEvent

    BeanContextServicesListener使用此事件类型来识别正在注册的服务。

    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Class<?> serviceClass
      A Class对新提供的服务的引用

      • Fields inherited from class java.beans.beancontext.BeanContextEvent

        propagatedFrom

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      BeanContextServiceAvailableEvent​(BeanContextServices bcs, Class<?> sc)
      构造一个 BeanContextAvailableServiceEvent 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Iterator<?> getCurrentServiceSelectors​()
      获取服务依赖选择器的列表。
      Class<?> getServiceClass​()
      获取作为此通知主题的服务类。
      BeanContextServices getSourceAsBeanContextServices​()
      获取源为 BeanContextServices型的参考。

      • Methods inherited from class java.beans.beancontext.BeanContextEvent

        getBeanContext, getPropagatedFrom, isPropagated, setPropagatedFrom

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • serviceClass

        protected Class<?> serviceClass
        A Class参考新提供的服务

    • 构造方法详细信息

      • BeanContextServiceAvailableEvent

        public BeanContextServiceAvailableEvent​(BeanContextServices bcs,
                                        Class<?> sc)
        构建一个 BeanContextAvailableServiceEvent 。
        参数
        bcs - 服务已经可用的上下文
        sc - A Class对新提供的服务的引用

    • 方法详细信息

      • getSourceAsBeanContextServices

        public BeanContextServices getSourceAsBeanContextServices​()
        获取源为 BeanContextServices的参考。
        结果
        服务已经可用的上下文

      • getServiceClass

        public Class<?> getServiceClass​()
        获取作为此通知主题的服务类。
        结果
        A Class对新提供的服务的引用

      • getCurrentServiceSelectors

        public Iterator<?> getCurrentServiceSelectors​()
        获取服务依赖选择器的列表。
        结果
        当前选择器可从服务中获得
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextServiceProvider

  • 所有已知实现类：
    BeanContextServicesSupport.BCSSProxyServiceProvider

    public interface BeanContextServiceProvider

    BeanContext的主要功能之一就是作为JavaBeans和BeanContextServiceProviders之间的会合。

    嵌套在BeanContext中的JavaBean可能会要求BeanContext基于对表示该服务的Java Class对象的引用来提供“服务”实例。

    如果这样的服务已被注册到上下文或其嵌套上下文之一，则在上下文委托到其上下文以满足服务请求的情况下，则要求与服务相关联的BeanContextServiceProvider提供该服务的实例。

    ServcieProvider可能总是返回相同的实例，或者可以为每个请求构造一个新的实例。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Iterator<?> getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      此方法由 BeanContextServices调用，获取指定服务的当前服务选择器。
      Object getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)
      这个方法由 BeanContextServices调用，从这个 BeanContextServiceProvider请求一个服务实例。
      void releaseService​(BeanContextServices bcs, Object requestor, Object service)
      此方法由 BeanContextServices调用，释放嵌套的 BeanContextChild （或任何与 BeanContextChild相关的任意对象）对指定服务的引用。

    • 方法详细信息

      • getService

        Object getService​(BeanContextServices bcs,
                  Object requestor,
                  Class<?> serviceClass,
                  Object serviceSelector)
        通过调用 BeanContextServices ，这种方法从这个请求服务的实例 BeanContextServiceProvider 。
        参数
        bcs - 与此特定请求相关联的BeanContextServices 。 此参数使BeanContextServiceProvider能够区分来自多个来源的服务请求。
        requestor - 请求服务的对象
        serviceClass - 请求的服务
        serviceSelector - 特定服务的服务相关参数，如果不适用， null 。
        结果
        对所请求的服务的引用

      • releaseService

        void releaseService​(BeanContextServices bcs,
                    Object requestor,
                    Object service)
        该方法由 BeanContextServices调用，释放嵌套的 BeanContextChild （或任何与 BeanContextChild相关联的任意对象）对指定服务的引用。
        参数
        bcs - 与此特定发布请求相关联的 BeanContextServices
        requestor - 请求释放服务的对象
        service - 要发布的服务

      • getCurrentServiceSelectors

        Iterator<?> getCurrentServiceSelectors​(BeanContextServices bcs,
                                       Class<?> serviceClass)
        该方法由BeanContextServices调用，获取指定服务的当前服务选择器。 服务选择器是一个特定于服务的参数，其典型示例可以包括：服务实现类的构造函数的参数，特定服务属性的值或现有实现的映射的键。
        参数
        bcs - 该请求的 BeanContextServices
        serviceClass - 指定的服务
        结果
        the current service selectors for the specified serviceClass
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServiceProviderBeanInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextServiceProviderBeanInfo

  • All Superinterfaces:
    BeanInfo

    public interface BeanContextServiceProviderBeanInfo
extends BeanInfo
    一个BeanContextServiceProvider实现者希望提供关于他们的bean可能提供的服务的显式信息，应该实现一个实现这个BeanInfo子接口的BeanInfo类，并提供有关其服务的方法，属性，事件等的显式信息。

    • Field Summary

      • Fields inherited from interface java.beans.BeanInfo

        ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      BeanInfo[] getServicesBeanInfo​()
      获取一个 BeanInfo数组，一个针对每个ServiceProvider静态可用的服务类或接口。

      • Methods inherited from interface java.beans.BeanInfo

        getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, getPropertyDescriptors

    • 方法详细信息

      • getServicesBeanInfo

        BeanInfo[] getServicesBeanInfo​()
        获取一个 BeanInfo数组，一个针对每个ServiceProvider静态可用的服务类或接口。
        结果
        BeanInfo阵列
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServiceRevokedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextServiceRevokedEvent

  • java.lang.Object
    • java.util.EventObject
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextServiceRevokedEvent
  • All Implemented Interfaces:
    Serializable

    public class BeanContextServiceRevokedEvent
extends BeanContextEvent

    BeanContextServiceRevokedListener使用此事件类型来识别正在撤销的服务。

    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Class<?> serviceClass
      A Class对正在撤销的服务的引用。

      • Fields inherited from class java.beans.beancontext.BeanContextEvent

        propagatedFrom

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      构造方法
      Constructor 描述
      BeanContextServiceRevokedEvent​(BeanContextServices bcs, Class<?> sc, boolean invalidate)
      构建一个 BeanContextServiceEvent 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<?> getServiceClass​()
      获取作为此通知主题的服务类
      BeanContextServices getSourceAsBeanContextServices​()
      获取来源作为参考类型 BeanContextServices
      boolean isCurrentServiceInvalidNow​()
      报告当前服务是否被强制撤销，在这种情况下，引用现在将无效并且不可用。
      boolean isServiceClass​(Class<?> service)
      检查此事件以确定被撤销的服务是否属于特定类。

      • Methods inherited from class java.beans.beancontext.BeanContextEvent

        getBeanContext, getPropagatedFrom, isPropagated, setPropagatedFrom

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • serviceClass

        protected Class<?> serviceClass
        A Class对正在撤销的服务的引用。

    • 构造方法详细信息

      • BeanContextServiceRevokedEvent

        public BeanContextServiceRevokedEvent​(BeanContextServices bcs,
                                      Class<?> sc,
                                      boolean invalidate)
        构造一个 BeanContextServiceEvent 。
        参数
        bcs - 该服务被撤销的 BeanContextServices
        sc - 正在撤销的服务
        invalidate - true立即撤销

    • 方法详细信息

      • getSourceAsBeanContextServices

        public BeanContextServices getSourceAsBeanContextServices​()
        获取源为 BeanContextServices型的参考
        结果
        该服务被撤销的 BeanContextServices

      • getServiceClass

        public Class<?> getServiceClass​()
        获取作为此通知主题的服务类
        结果
        A Class对正在撤销的服务的引用

      • isServiceClass

        public boolean isServiceClass​(Class<?> service)
        检查此事件以确定被撤销的服务是否属于特定类。
        参数
        service - 感兴趣的服务（应为非空）
        结果
        true如果被撤销的服务与指定的服务具有相同的类

      • isCurrentServiceInvalidNow

        public boolean isCurrentServiceInvalidNow​()
        报告当前服务是否被强制撤销，在这种情况下，引用现在将无效并且不可用。
        结果
        true如果当前服务被强制撤销
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServiceRevokedListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextServiceRevokedListener

  • All Superinterfaces:
    EventListener
    All Known Subinterfaces:
    BeanContextServices ， BeanContextServicesListener
    所有已知实现类：
    BeanContextChildSupport ， BeanContextServicesSupport ， BeanContextServicesSupport.BCSSProxyServiceProvider ， BeanContextSupport

    public interface BeanContextServiceRevokedListener
extends EventListener
    用于接收BeanContextServiceRevokedEvent对象的侦听器接口。 一个有兴趣处理一个BeanContextServiceRevokedEvent实现了这个接口。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
      已命名的服务已被撤销。 此服务的getService请求将不再满足。

    • 方法详细信息

      • serviceRevoked

        void serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
        已命名的服务已被撤销。 此服务的getService请求将不再满足。
        参数
        bcsre - the BeanContextServiceRevokedEvent received by this listener.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServices (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextServices

  • All Superinterfaces:
    BeanContext ， BeanContextChild ， BeanContextServiceRevokedListener ， BeanContextServicesListener ， Collection ， DesignMode ， EventListener ， Iterable<E> ， Visibility
    所有已知实现类：
    BeanContextServicesSupport

    public interface BeanContextServices
extends BeanContext, BeanContextServicesListener

    BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。

    • Field Summary

      • Fields inherited from interface java.beans.beancontext.BeanContext

        globalHierarchyLock

      • Fields inherited from interface java.beans.DesignMode

        PROPERTYNAME

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addBeanContextServicesListener​(BeanContextServicesListener bcsl)
      在此BeanContext中添加一个 BeanContextServicesListener
      boolean addService​(Class<?> serviceClass, BeanContextServiceProvider serviceProvider)
      向这个BeanContext添加一个服务。
      Iterator<?> getCurrentServiceClasses​()
      获取此上下文的当前可用服务。
      Iterator<?> getCurrentServiceSelectors​(Class<?> serviceClass)
      通过调用底层BeanContextServiceProvider上的getCurrentServiceSelectors（），获取指定服务的服务相关服务参数（服务选择器）列表。
      Object getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。
      boolean hasService​(Class<?> serviceClass)
      报告当前是否可以从此上下文获得给定的服务。
      void releaseService​(BeanContextChild child, Object requestor, Object service)
      通过在底层的 BeanContextServiceProvider上调用releaseService（），释放一个 BeanContextChild （或任何与BeanContextChild关联的任意对象）对指定服务的 BeanContextServiceProvider 。
      void removeBeanContextServicesListener​(BeanContextServicesListener bcsl)
      删除一个 BeanContextServicesListener从这个 BeanContext
      void revokeService​(Class<?> serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
      希望从此上下文中删除当前注册的服务的BeanContextServiceProviders可以通过调用此方法来实现。

      • Methods inherited from interface java.beans.beancontext.BeanContext

        addBeanContextMembershipListener, getResource, getResourceAsStream, instantiateChild, removeBeanContextMembershipListener

      • Methods inherited from interface java.beans.beancontext.BeanContextChild

        addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext

      • Methods inherited from interface java.beans.beancontext.BeanContextServiceRevokedListener

        serviceRevoked

      • Methods inherited from interface java.beans.beancontext.BeanContextServicesListener

        serviceAvailable

      • Methods inherited from interface java.util.Collection

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, parallelStream, remove, removeAll, removeIf, retainAll, size, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.beans.DesignMode

        isDesignTime, setDesignTime

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from interface java.beans.Visibility

        avoidingGui, dontUseGui, needsGui, okToUseGui

    • 方法详细信息

      • addService

        boolean addService​(Class<?> serviceClass,
                   BeanContextServiceProvider serviceProvider)
        向这个BeanContext添加一个服务。 BeanContextServiceProvider调用这种方法来注册一个特定的服务与这个上下文。 如果服务先前没有被添加，该BeanContextServices关联与服务BeanContextServiceProvider并触发一个BeanContextServiceAvailableEvent到所有当前已注册BeanContextServicesListeners 。 然后该方法返回true ，表示添加服务成功。 如果给定的服务已经被添加，这个方法只需返回false 。
        参数
        serviceClass - 要添加的服务
        serviceProvider - 与服务相关联的 BeanContextServiceProvider
        结果
        如果服务成功添加，则为true，否则为false

      • revokeService

        void revokeService​(Class<?> serviceClass,
                   BeanContextServiceProvider serviceProvider,
                   boolean revokeCurrentServicesNow)
        希望从此上下文中删除当前注册的服务的BeanContextServiceProviders可以通过调用此方法来实现。 在服务的撤销，该BeanContextServices触发一个BeanContextServiceRevokedEvent其目前注册文件列表BeanContextServiceRevokedListeners和BeanContextServicesListeners 。
        参数
        serviceClass - 从这个BeanContextServices撤销的服务
        serviceProvider - 与正在撤销的特定服务相关联的BeanContextServiceProvider
        revokeCurrentServicesNow -值 true表示特殊情况，其中 BeanContextServiceProvider或者 BeanContextServices希望立即终止服务，指定服务当前所有未完成的引用。

      • hasService

        boolean hasService​(Class<?> serviceClass)
        报告当前是否可以从此上下文获得给定的服务。
        参数
        serviceClass - 有问题的服务
        结果
        如果服务可用，则为true

      • getService

        Object getService​(BeanContextChild child,
                  Object requestor,
                  Class<?> serviceClass,
                  Object serviceSelector,
                  BeanContextServiceRevokedListener bcsrl)
           throws TooManyListenersException
        A BeanContextChild或与BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套BeanContextServices获得对当前注册服务的引用。 调用时，此方法通过调用基础BeanContextServiceProvider上的getService（）方法获取服务。
        参数
        child - 与此请求相关联的 BeanContextChild
        requestor - 请求服务的对象
        serviceClass - 所请求的服务的类
        serviceSelector - 服务相关参数
        bcsrl - BeanContextServiceRevokedListener通知服务是否应该以后被撤销
        结果
        根据请求引用此上下文的命名服务或 null
        异常
        TooManyListenersException - 如果听众太多了

      • releaseService

        void releaseService​(BeanContextChild child,
                    Object requestor,
                    Object service)
        通过在底层的 BeanContextServiceProvider上调用releaseService（），释放一个 BeanContextChild （或任何与BeanContextChild关联的任意对象）对指定服务的 BeanContextServiceProvider 。
        参数
        child - BeanContextChild
        requestor - 请求者
        service - 服务

      • getCurrentServiceClasses

        Iterator<?> getCurrentServiceClasses​()
        获取此上下文的当前可用服务。
        结果
        一个由目前可用的服务组成的 Iterator

      • getCurrentServiceSelectors

        Iterator<?> getCurrentServiceSelectors​(Class<?> serviceClass)
        通过调用底层BeanContextServiceProvider上的getCurrentServiceSelectors（），获取指定服务的服务相关服务参数（服务选择器）列表。
        参数
        serviceClass - 指定的服务
        结果
        名为serviceClass的当前可用的服务选择器

      • addBeanContextServicesListener

        void addBeanContextServicesListener​(BeanContextServicesListener bcsl)
        在此BeanContext中添加一个 BeanContextServicesListener
        参数
        bcsl - 要添加的 BeanContextServicesListener

      • removeBeanContextServicesListener

        void removeBeanContextServicesListener​(BeanContextServicesListener bcsl)
        删除一个 BeanContextServicesListener从这个 BeanContext
        参数
        bcsl - 从这个上下文中删除的 BeanContextServicesListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServicesListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Interface BeanContextServicesListener

  • All Superinterfaces:
    BeanContextServiceRevokedListener ， EventListener
    All Known Subinterfaces:
    BeanContextServices
    所有已知实现类：
    BeanContextChildSupport ， BeanContextServicesSupport ， BeanContextSupport

    public interface BeanContextServicesListener
extends BeanContextServiceRevokedListener
    用于接收BeanContextServiceAvailableEvent对象的侦听器接口。 一个有兴趣处理一个BeanContextServiceAvailableEvent实现了这个接口。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void serviceAvailable​(BeanContextServiceAvailableEvent bcsae)
      已命名的服务已注册。 此服务的getService请求现在可以进行。

      • Methods inherited from interface java.beans.beancontext.BeanContextServiceRevokedListener

        serviceRevoked

    • 方法详细信息

      • serviceAvailable

        void serviceAvailable​(BeanContextServiceAvailableEvent bcsae)
        已命名的服务已注册。 此服务的getService请求现在可以进行。
        参数
        bcsae - the BeanContextServiceAvailableEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServicesSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextServicesSupport

  • java.lang.Object
    • java.beans.beancontext.BeanContextChildSupport
      • java.beans.beancontext.BeanContextSupport
        • java.beans.beancontext.BeanContextServicesSupport
  • All Implemented Interfaces:
    BeanContext ， BeanContextChild ， BeanContextServiceRevokedListener ， BeanContextServices ， BeanContextServicesListener ， DesignMode ， PropertyChangeListener ， VetoableChangeListener ， Visibility ， Serializable ， Iterable<E> ， Collection ， EventListener

    public class BeanContextServicesSupport
extends BeanContextSupport
implements BeanContextServices

    这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。

    由于此类直接实现了BeanContextServices接口，所以该类可以通过对该实现进行子类化，也可以通过BeanContextProxy接口从另一个实例委派这个类来实现。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      protected class  | BeanContextServicesSupport.BCSSChild
      protected class  | BeanContextServicesSupport.BCSSProxyServiceProvider
      protected static class  BeanContextServicesSupport.BCSSServiceProvider
      子类可以将此嵌套类子类化为每个BeanContextServicesProvider添加行为。

      • Nested classes/interfaces inherited from class java.beans.beancontext.BeanContextSupport

        BeanContextSupport.BCSChild, BeanContextSupport.BCSIterator

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ArrayList<BeanContextServicesListener> bcsListeners
      BeanContextServicesListener对象列表。
      protected BeanContextServicesSupport.BCSSProxyServiceProvider proxy
      代表 BeanContextServiceProvider 。
      protected int serializable
      可序列化的实例数 BeanContextServceProvider 。
      protected HashMap<Object,BeanContextServicesSupport.BCSSServiceProvider> services
      对 protected transient HashMap services字段的所有访问应该在该对象上同步

      • Fields inherited from interface java.beans.beancontext.BeanContext

        globalHierarchyLock

      • Fields inherited from class java.beans.beancontext.BeanContextChildSupport

        beanContext, beanContextChildPeer, pcSupport, rejectedSetBCOnce, vcSupport

      • Fields inherited from class java.beans.beancontext.BeanContextSupport

        bcmListeners, children, designTime, locale, okToUseGui

      • Fields inherited from interface java.beans.DesignMode

        PROPERTYNAME

    • 构造方法摘要

      构造方法
      Constructor 描述
      BeanContextServicesSupport​()
      创建一个不是另一个对象的委托的实例
      BeanContextServicesSupport​(BeanContextServices peer)
      与对等体创建一个实例
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle)
      使用指定的区域设置创建一个实例
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle, boolean dtime)
      使用指定的区域设置和设计模式创建一个实例。
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
      构造一个BeanContextServicesSupport实例

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addBeanContextServicesListener​(BeanContextServicesListener bcsl)
      添加一个BeanContextServicesListener
      boolean addService​(Class<?> serviceClass, BeanContextServiceProvider bcsp)
      添加服务
      protected boolean addService​(Class<?> serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
      添加服务
      protected void bcsPreDeserializationHook​(ObjectInputStream ois)
      从BeanContextSupport readObject中调用它反序列化子对象...
      protected void bcsPreSerializationHook​(ObjectOutputStream oos)
      从BeanContextSupport中调用writeObject，然后序列化子对象...
      protected void childJustRemovedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      在孩子被成功删除之后从超类儿童删除操作中调用。 调用与子同步。
      protected BeanContextSupport.BCSChild createBCSChild​(Object targetChild, Object peer)
      子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。
      protected BeanContextServicesSupport.BCSSServiceProvider createBCSSServiceProvider​(Class<?> sc, BeanContextServiceProvider bcsp)
      子类可以覆盖此方法来创建BCSSServiceProvider的新子类，而不必重写addService（）以便实例化。
      protected void fireServiceAdded​(BeanContextServiceAvailableEvent bcssae)
      触发 BeanContextServiceAvailableEvent表示新服务已经可用。
      protected void fireServiceAdded​(Class<?> serviceClass)
      发出 BeanContextServiceEvent通知新服务。
      protected void fireServiceRevoked​(BeanContextServiceRevokedEvent bcsre)
      发出 BeanContextServiceEvent通知正在撤销的服务。
      protected void fireServiceRevoked​(Class<?> serviceClass, boolean revokeNow)
      触发 BeanContextServiceRevokedEvent表示特定服务不再可用。
      BeanContextServices getBeanContextServicesPeer​()
      获取 BeanContextServices与此 BeanContextServicesSupport相关联。
      protected static BeanContextServicesListener getChildBeanContextServicesListener​(Object child)
      获取指定小孩的 BeanContextServicesListener （如果有）。
      Iterator<Object> getCurrentServiceClasses​()
      获取此上下文的当前可用服务。
      Iterator<?> getCurrentServiceSelectors​(Class<?> serviceClass)
      通过调用底层BeanContextServiceProvider上的getCurrentServiceSelectors（），获取指定服务的服务相关服务参数（服务选择器）列表。
      Object getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      获得可能委托的服务
      boolean hasService​(Class<?> serviceClass)
      有一个可以委派的服务
      void initialize​()
      在构造和反序列化期间由BeanContextSupport超类调用以初始化子类暂态。
      protected void initializeBeanContextResources​()
      从setBeanContext调用通知一个BeanContextChild来分配从嵌套BeanContext获取的资源。
      protected void releaseBeanContextResources​()
      从setBeanContext调用，以通知BeanContextChild释放从嵌套BeanContext获取的资源。
      void releaseService​(BeanContextChild child, Object requestor, Object service)
      发布服务
      void removeBeanContextServicesListener​(BeanContextServicesListener bcsl)
      删除一个BeanContextServicesListener
      void revokeService​(Class<?> serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
      删除服务
      void serviceAvailable​(BeanContextServiceAvailableEvent bcssae)
      BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。
      void serviceRevoked​(BeanContextServiceRevokedEvent bcssre)
      BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。

      • Methods inherited from interface java.beans.beancontext.BeanContext

        addBeanContextMembershipListener, getResource, getResourceAsStream, instantiateChild, removeBeanContextMembershipListener

      • Methods inherited from interface java.beans.beancontext.BeanContextChild

        addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext

      • Methods inherited from class java.beans.beancontext.BeanContextChildSupport

        addPropertyChangeListener, addVetoableChangeListener, firePropertyChange, fireVetoableChange, getBeanContext, getBeanContextChildPeer, isDelegated, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext, validatePendingSetBeanContext

      • Methods inherited from class java.beans.beancontext.BeanContextSupport

        add, addAll, addBeanContextMembershipListener, avoidingGui, bcsChildren, childDeserializedHook, childJustAddedHook, classEquals, clear, contains, containsAll, containsKey, copyChildren, deserialize, dontUseGui, fireChildrenAdded, fireChildrenRemoved, getBeanContextPeer, getChildBeanContextChild, getChildBeanContextMembershipListener, getChildPropertyChangeListener, getChildSerializable, getChildVetoableChangeListener, getChildVisibility, getLocale, getResource, getResourceAsStream, instantiateChild, isDesignTime, isEmpty, isSerializing, iterator, needsGui, okToUseGui, propertyChange, readChildren, remove, remove, removeAll, removeBeanContextMembershipListener, retainAll, serialize, setDesignTime, setLocale, size, toArray, toArray, validatePendingAdd, validatePendingRemove, vetoableChange, writeChildren

      • Methods inherited from interface java.util.Collection

        add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, parallelStream, remove, removeAll, removeIf, retainAll, size, spliterator, stream, toArray, toArray

      • Methods inherited from interface java.beans.DesignMode

        isDesignTime, setDesignTime

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.beans.Visibility

        avoidingGui, dontUseGui, needsGui, okToUseGui

    • 字段详细信息

      • services

        protected transient HashMap<Object,BeanContextServicesSupport.BCSSServiceProvider> services
        对 protected transient HashMap services字段的所有访问应该在该对象上同步

      • serializable

        protected transient int serializable
        可序列化的实例数 BeanContextServceProvider 。

      • proxy

        protected transient BeanContextServicesSupport.BCSSProxyServiceProvider proxy
        代表 BeanContextServiceProvider 。

      • bcsListeners

        protected transient ArrayList<BeanContextServicesListener> bcsListeners
        BeanContextServicesListener对象列表。

    • 构造方法详细信息

      • BeanContextServicesSupport

        public BeanContextServicesSupport​(BeanContextServices peer,
                                  Locale lcle,
                                  boolean dTime,
                                  boolean visible)

        构造一个BeanContextServicesSupport实例

        参数
        peer - 对等BeanContext我们提供了一个实现，如果null这个对象是它自己的对等
        lcle - 此BeanContext的当前区域设置。
        dTime - 初始状态，如果在设计模式下为真，如果运行时为false。
        visible - 初始可见度。

      • BeanContextServicesSupport

        public BeanContextServicesSupport​(BeanContextServices peer,
                                  Locale lcle,
                                  boolean dtime)
        使用指定的区域设置和设计模式创建一个实例。
        参数
        peer - 对等BeanContext我们提供了一个实现，如果null，则该对象是其自己的对等体
        lcle - 此BeanContext的当前区域设置。
        dtime - 初始状态，如果在设计模式下为真，如果运行时为false。

      • BeanContextServicesSupport

        public BeanContextServicesSupport​(BeanContextServices peer,
                                  Locale lcle)
        使用指定的区域设置创建一个实例
        参数
        peer - 对等BeanContext我们提供了一个实现，如果null，这个对象是它自己的对等体
        lcle - 此BeanContext的当前区域设置。

      • BeanContextServicesSupport

        public BeanContextServicesSupport​(BeanContextServices peer)
        与对等体创建一个实例
        参数
        peer - 对等体BeanContext我们提供了一个实现，如果null这个对象是它自己的对等体

      • BeanContextServicesSupport

        public BeanContextServicesSupport​()
        创建一个不是另一个对象的委托的实例

    • 方法详细信息

      • initialize

        public void initialize​()
        在构造和反序列化期间由BeanContextSupport超类调用以初始化子类暂态。 子类可以包含此方法，但不应该覆盖它或直接调用它。
        重写：
        initialize在 BeanContextSupport

      • getBeanContextServicesPeer

        public BeanContextServices getBeanContextServicesPeer​()
        获取 BeanContextServices与此 BeanContextServicesSupport相关联。
        结果
        该实例为 BeanContext这个对象提供了实现。

      • createBCSChild

        protected BeanContextSupport.BCSChild createBCSChild​(Object targetChild,
                                                     Object peer)

        子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。

        重写：
        createBCSChild在 BeanContextSupport
        参数
        targetChild - 孩子代表孩子创建
        peer - 如果targetChild和peer由BeanContextProxy关联，则该对等体
        结果
        子类别的子类别，而不用覆盖收集方法

      • createBCSSServiceProvider

        protected BeanContextServicesSupport.BCSSServiceProvider createBCSSServiceProvider​(Class<?> sc,
                                                                                BeanContextServiceProvider bcsp)
        子类可以覆盖此方法来创建BCSSServiceProvider的新子类，而不必重写addService（）以便实例化。
        参数
        sc - 班
        bcsp - 服务提供商
        结果
        一个服务提供商，无需覆盖addService（）

      • addBeanContextServicesListener

        public void addBeanContextServicesListener​(BeanContextServicesListener bcsl)
        添加一个BeanContextServicesListener
        Specified by:
        addBeanContextServicesListener在接口 BeanContextServices
        参数
        bcsl - 添加 BeanContextServicesListener
        异常
        NullPointerException - 如果参数为空

      • removeBeanContextServicesListener

        public void removeBeanContextServicesListener​(BeanContextServicesListener bcsl)
        删除一个BeanContextServicesListener
        Specified by:
        removeBeanContextServicesListener在接口 BeanContextServices
        参数
        bcsl - 要从此上下文中删除的 BeanContextServicesListener

      • addService

        public boolean addService​(Class<?> serviceClass,
                          BeanContextServiceProvider bcsp)
        添加服务
        Specified by:
        addService在接口 BeanContextServices
        参数
        serviceClass - 服务类
        bcsp - 服务提供商
        结果
        如果服务成功添加，则为true，否则为false

      • addService

        protected boolean addService​(Class<?> serviceClass,
                             BeanContextServiceProvider bcsp,
                             boolean fireEvent)
        添加服务
        参数
        serviceClass - 服务类
        bcsp - 服务提供商
        fireEvent - 是否应触发事件
        结果
        如果服务成功添加，则为true

      • revokeService

        public void revokeService​(Class<?> serviceClass,
                          BeanContextServiceProvider bcsp,
                          boolean revokeCurrentServicesNow)
        删除服务
        Specified by:
        revokeService在接口 BeanContextServices
        参数
        serviceClass - 服务类
        bcsp - 服务提供商
        revokeCurrentServicesNow - 是否撤销服务

      • hasService

        public boolean hasService​(Class<?> serviceClass)
        有一个可以委派的服务
        Specified by:
        hasService在接口 BeanContextServices
        参数
        serviceClass - 有关服务
        结果
        如果服务可用，则为true

      • getService

        public Object getService​(BeanContextChild child,
                         Object requestor,
                         Class<?> serviceClass,
                         Object serviceSelector,
                         BeanContextServiceRevokedListener bcsrl)
                  throws TooManyListenersException
        获得可能委托的服务
        Specified by:
        getService在接口 BeanContextServices
        参数
        child - 与此请求相关联的 BeanContextChild
        requestor - 请求服务的对象
        serviceClass - 所请求的服务的类
        serviceSelector - 服务相关参数
        bcsrl - BeanContextServiceRevokedListener通知服务是否应该在以后被撤销
        结果
        根据请求引用此上下文的命名服务或 null
        异常
        TooManyListenersException - 如果听众太多了

      • releaseService

        public void releaseService​(BeanContextChild child,
                           Object requestor,
                           Object service)
        发布服务
        Specified by:
        releaseService在接口 BeanContextServices
        参数
        child - BeanContextChild
        requestor - 请求者
        service - 服务

      • getCurrentServiceClasses

        public Iterator<Object> getCurrentServiceClasses​()
        说明从接口BeanContextServices复制
        获取此上下文的当前可用服务。
        Specified by:
        getCurrentServiceClasses在接口 BeanContextServices
        结果
        所有当前注册的服务类的迭代器。

      • getCurrentServiceSelectors

        public Iterator<?> getCurrentServiceSelectors​(Class<?> serviceClass)
        描述从接口BeanContextServices复制
        通过调用底层BeanContextServiceProvider上的getCurrentServiceSelectors（），获取指定服务的服务相关服务参数（服务选择器）列表。
        Specified by:
        getCurrentServiceSelectors在接口 BeanContextServices
        参数
        serviceClass - 指定的服务
        结果
        所有当前可用的服务选择器（如果有）可用于指定服务的迭代器。

      • serviceAvailable

        public void serviceAvailable​(BeanContextServiceAvailableEvent bcssae)
        BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。 子类可以覆盖或包围该方法来实现自己的传播语义。
        Specified by:
        serviceAvailable在接口 BeanContextServicesListener
        重写：
        serviceAvailable在 BeanContextChildSupport
        参数
        bcssae - 由于服务变得可用，BeanContextServiceAvailableEvent被触发

      • serviceRevoked

        public void serviceRevoked​(BeanContextServiceRevokedEvent bcssre)
        BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。 子类可以覆盖或包围该方法来实现自己的传播语义。
        Specified by:
        serviceRevoked在接口 BeanContextServiceRevokedListener
        重写：
        serviceRevoked在 BeanContextChildSupport
        参数
        bcssre - 由于服务被撤销， BeanContextServiceRevokedEvent被触发

      • getChildBeanContextServicesListener

        protected static final BeanContextServicesListener getChildBeanContextServicesListener​(Object child)
        获取指定小孩的 BeanContextServicesListener （如果有）。
        参数
        child - 指定的孩子
        结果
        指定子对象的BeanContextServicesListener（如果有）

      • childJustRemovedHook

        protected void childJustRemovedHook​(Object child,
                                    BeanContextSupport.BCSChild bcsc)
        在孩子被成功删除之后从超类儿童删除操作中调用。 调用与子同步。 如果该子类是BeanContextChild，则此子类将使用此钩子立即撤销该子级正在使用的任何服务。 子类可以包含这种方法，以便实现他们自己的小孩删除副作用。
        重写：
        childJustRemovedHook在 BeanContextSupport
        参数
        child - 小孩
        bcsc - BCSChild

      • releaseBeanContextResources

        protected void releaseBeanContextResources​()
        从setBeanContext调用，以通知BeanContextChild释放从嵌套BeanContext获取的资源。 此方法撤销从其父级获取的任何服务。 子类可以包含这个方法来实现自己的语义。
        重写：
        releaseBeanContextResources在 BeanContextChildSupport

      • initializeBeanContextResources

        protected void initializeBeanContextResources​()
        从setBeanContext调用通知一个BeanContextChild来分配从嵌套BeanContext获取的资源。 子类可以包含这个方法来实现自己的语义。
        重写：
        initializeBeanContextResources在 BeanContextChildSupport

      • fireServiceAdded

        protected final void fireServiceAdded​(Class<?> serviceClass)
        通知一个新的服务 BeanContextServiceEvent 。
        参数
        serviceClass - 服务类

      • fireServiceAdded

        protected final void fireServiceAdded​(BeanContextServiceAvailableEvent bcssae)
        触发 BeanContextServiceAvailableEvent表示新服务已经可用。
        参数
        bcssae - BeanContextServiceAvailableEvent

      • fireServiceRevoked

        protected final void fireServiceRevoked​(BeanContextServiceRevokedEvent bcsre)
        发出 BeanContextServiceEvent通知正在撤销的服务。
        参数
        bcsre - BeanContextServiceRevokedEvent

      • fireServiceRevoked

        protected final void fireServiceRevoked​(Class<?> serviceClass,
                                        boolean revokeNow)
        触发 BeanContextServiceRevokedEvent表示特定服务不再可用。
        参数
        serviceClass - 服务类
        revokeNow - 现在是否应该撤销事件

      • bcsPreSerializationHook

        protected void bcsPreSerializationHook​(ObjectOutputStream oos)
                                throws IOException
        从BeanContextSupport writeObject中调用它，然后序列化子...这个类将序列化任何Serializable BeanContextServiceProviders。 子类可以包含这个方法来插入自己的序列化处理，这个序列化处理必须在子系统序列化之前发生
        重写：
        bcsPreSerializationHook在 BeanContextSupport
        参数
        oos - 序列化期间使用的 ObjectOutputStream
        异常
        IOException - 如果序列化失败

      • bcsPreDeserializationHook

        protected void bcsPreDeserializationHook​(ObjectInputStream ois)
                                  throws IOException,
                                         ClassNotFoundException
        从BeanContextSupport readObject调用它反序列化子类之前...这个类将反序列化任何Serializable BeanContextServiceProviders序列化，从而使它们可用于孩子们反序列化时。 子类可以包含这个方法来插入自己的序列化处理，这个序列化处理必须在子系统序列化之前发生
        重写：
        bcsPreDeserializationHook在 BeanContextSupport
        参数
        ois - 反序列化期间使用的 ObjectInputStream
        异常
        IOException - 如果反序列化失败
        ClassNotFoundException - 如果没有找到需要的类
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServicesSupport.BCSSChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextServicesSupport.BCSSChild

  • java.lang.Object
    • java.beans.beancontext.BeanContextSupport.BCSChild
      • java.beans.beancontext.BeanContextServicesSupport.BCSSChild
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    BeanContextServicesSupport

    protected class BeanContextServicesSupport.BCSSChild
extends BeanContextSupport.BCSChild
    另请参见：
    Serialized Form

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServicesSupport.BCSSProxyServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextServicesSupport.BCSSProxyServiceProvider

  • java.lang.Object
    • java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider
  • All Implemented Interfaces:
    BeanContextServiceProvider ， BeanContextServiceRevokedListener ， EventListener
    Enclosing class:
    BeanContextServicesSupport

    protected class BeanContextServicesSupport.BCSSProxyServiceProvider
extends Object
implements BeanContextServiceProvider, BeanContextServiceRevokedListener

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Iterator<?> getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      由 BeanContextServices调用，此方法获取指定服务的当前服务选择器。
      Object getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)
      通过调用 BeanContextServices ，这种方法从这个请求服务的实例 BeanContextServiceProvider 。
      void releaseService​(BeanContextServices bcs, Object requestor, Object service)
      该方法由 BeanContextServices调用，释放嵌套的 BeanContextChild （或任何与 BeanContextChild相关联的任意对象）对指定服务的引用。
      void serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
      已命名的服务已被撤销。 此服务的getService请求将不再满足。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getService

        public Object getService​(BeanContextServices bcs,
                         Object requestor,
                         Class<?> serviceClass,
                         Object serviceSelector)
        描述从接口BeanContextServiceProvider复制
        通过调用 BeanContextServices ，这种方法从这个请求服务的实例 BeanContextServiceProvider 。
        Specified by:
        getService在接口 BeanContextServiceProvider
        参数
        bcs - 与此特定请求相关联的BeanContextServices 。 此参数使BeanContextServiceProvider能够区分来自多个来源的服务请求。
        requestor - 请求服务的对象
        serviceClass - 请求的服务
        serviceSelector - 特定服务的服务相关参数，如果不适用， null 。
        结果
        对所请求的服务的引用

      • releaseService

        public void releaseService​(BeanContextServices bcs,
                           Object requestor,
                           Object service)
        描述从接口BeanContextServiceProvider复制
        此方法由 BeanContextServices调用，释放嵌套的 BeanContextChild （或任何与 BeanContextChild相关联的任意对象）对指定服务的引用。
        Specified by:
        releaseService在接口 BeanContextServiceProvider
        参数
        bcs - 与此特定发布请求相关联的 BeanContextServices
        requestor - 请求释放服务的对象
        service - 要发布的服务

      • getCurrentServiceSelectors

        public Iterator<?> getCurrentServiceSelectors​(BeanContextServices bcs,
                                              Class<?> serviceClass)
        描述从接口BeanContextServiceProvider复制
        此方法由BeanContextServices调用，获取指定服务的当前服务选择器。 服务选择器是一个特定于服务的参数，其典型示例可以包括：服务实现类的构造函数的参数，特定服务属性的值或现有实现的映射的键。
        Specified by:
        getCurrentServiceSelectors在接口 BeanContextServiceProvider
        参数
        bcs - 该请求的 BeanContextServices
        serviceClass - 指定的服务
        结果
        当前服务选择器为指定的serviceClass

      • serviceRevoked

        public void serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
        描述从接口BeanContextServiceRevokedListener复制
        已命名的服务已被撤销。 此服务的getService请求将不再满足。
        Specified by:
        serviceRevoked在接口 BeanContextServiceRevokedListener
        参数
        bcsre - 这位 BeanContextServiceRevokedEvent收到的 BeanContextServiceRevokedEvent 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextServicesSupport.BCSSServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextServicesSupport.BCSSServiceProvider

  • java.lang.Object
    • java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    BeanContextServicesSupport

    protected static class BeanContextServicesSupport.BCSSServiceProvider
extends Object
implements Serializable
    子类可以将此嵌套类子类化为每个BeanContextServicesProvider添加行为。
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected BeanContextServiceProvider serviceProvider
      服务提供商。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected BeanContextServiceProvider getServiceProvider​()
      返回服务提供者。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • serviceProvider

        protected BeanContextServiceProvider serviceProvider
        服务提供商。

    • 方法详细信息

      • getServiceProvider

        protected BeanContextServiceProvider getServiceProvider​()
        返回服务提供者。
        结果
        服务提供商
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextSupport

  • java.lang.Object
    • java.beans.beancontext.BeanContextChildSupport
      • java.beans.beancontext.BeanContextSupport
  • All Implemented Interfaces:
    BeanContext ， BeanContextChild ， BeanContextServiceRevokedListener ， BeanContextServicesListener ， DesignMode ， PropertyChangeListener ， VetoableChangeListener ， Visibility ， Serializable ， Iterable<E> ， Collection ， EventListener
    已知直接子类：
    BeanContextServicesSupport

    public class BeanContextSupport
extends BeanContextChildSupport
implements BeanContext, Serializable, PropertyChangeListener, VetoableChangeListener
    这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。

    由于该类直接实现了BeanContext接口，所以该类可以通过将此实现进行子类化，也可以通过对另一个类的实例进行临时委派来使用。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type | Class | 描述
      protected class  | BeanContextSupport.BCSChild
      protected static class  BeanContextSupport.BCSIterator
      受保护的final子类封装了一个迭代器，但实现了一个noop remove（）方法。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected ArrayList<BeanContextMembershipListener> bcmListeners
      对 protected ArrayList bcmListeners字段的所有访问应在该对象上同步。
      protected HashMap<Object,BeanContextSupport.BCSChild> children
      对 protected HashMap children字段的所有访问应在该对象上同步。
      protected boolean designTime
      A boolean指示该对象当前是否处于设计时间模式。
      protected Locale locale
      此BeanContext的当前区域设置。
      protected boolean okToUseGui
      A boolean指示该实例现在是否可以呈现GUI。

      • Fields inherited from interface java.beans.beancontext.BeanContext

        globalHierarchyLock

      • Fields inherited from class java.beans.beancontext.BeanContextChildSupport

        beanContext, beanContextChildPeer, pcSupport, rejectedSetBCOnce, vcSupport

      • Fields inherited from interface java.beans.DesignMode

        PROPERTYNAME

    • 构造方法摘要

      构造方法
      Constructor 描述
      BeanContextSupport​()
      创建一个不是另一个对象的委托的实例
      BeanContextSupport​(BeanContext peer)
      新新200新200新新新新新旗新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新
      BeanContextSupport​(BeanContext peer, Locale lcle)
      使用指定的区域设置创建一个实例
      BeanContextSupport​(BeanContext peer, Locale lcle, boolean dtime)
      使用指定的区域设置和设计模式创建一个实例。
      BeanContextSupport​(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
      200新新新新200新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗200新新旗新新200新

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean add​(Object targetChild)
      在这个 BeanContext内添加/嵌套一个孩子。
      boolean addAll​(Collection c)
      将集合添加到子集（不支持）的集合实现必须在层次结构锁和“children”保护字段上同步
      void addBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      添加一个BeanContextMembershipListener
      boolean avoidingGui​()
      用于确定 BeanContext孩子是否避免使用其GUI。
      protected Iterator<BeanContextSupport.BCSChild> bcsChildren​()
      返回此 BeanContext的所有子项的迭代器。
      protected void bcsPreDeserializationHook​(ObjectInputStream ois)
      通过readObject在defaultReadObject（）之后调用，但在任何孩子反序列化之前。
      protected void bcsPreSerializationHook​(ObjectOutputStream oos)
      在writeWriteObject（）之后但在序列化当前可序列化的孩子之前调用writeObject。
      protected void childDeserializedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      由readObject与新反序列化的小孩和BCSChild调用。
      protected void childJustAddedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      子类可以覆盖此方法，以便在添加子项之后和事件通知发生之前简单地扩展add（）语义。
      protected void childJustRemovedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      子类可以覆盖此方法，以便在子进程已被删除之后和事件通知发生之前简单地扩展remove（）语义。
      protected static boolean classEquals​(Class<?> first, Class<?> second)
      测试两个类对象或其名称是否相等。
      void clear​()
      清除子层（不支持）实现必须在层次结构锁和“children”保护字段上同步
      boolean contains​(Object o)
      确定指定的对象当前是否为此 BeanContext的子 BeanContext 。
      boolean containsAll​(Collection c)
      测试以查看指定的 Collection中的所有对象是否为 Collection的子 BeanContext 。
      boolean containsKey​(Object o)
      确定指定的对象当前是否为此 BeanContext的子 BeanContext 。
      protected Object[] copyChildren​()
      获取这个BeanContext的孩子的副本。
      protected BeanContextSupport.BCSChild createBCSChild​(Object targetChild, Object peer)
      子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。
      protected void deserialize​(ObjectInputStream ois, Collection coll)
      由readObject用于反序列化集合。
      void dontUseGui​()
      通知此实例可能不再呈现GUI。
      protected void fireChildrenAdded​(BeanContextMembershipEvent bcme)
      在BeanContextMembershipListener接口上激活BeanContextshipEvent
      protected void fireChildrenRemoved​(BeanContextMembershipEvent bcme)
      在BeanContextMembershipListener接口上激活BeanContextshipEvent
      BeanContext getBeanContextPeer​()
      获取这个对象提供的实现的 BeanContext的实例。
      protected static BeanContextChild getChildBeanContextChild​(Object child)
      获取指定子节点的BeanContextChild（如果有）
      protected static BeanContextMembershipListener getChildBeanContextMembershipListener​(Object child)
      获取指定子节点的BeanContextMembershipListener（如果有）
      protected static PropertyChangeListener getChildPropertyChangeListener​(Object child)
      获取指定子对象的PropertyChangeListener（如果有）
      protected static Serializable getChildSerializable​(Object child)
      获取与指定的Child相关联的Serializable（如果有）
      protected static VetoableChangeListener getChildVetoableChangeListener​(Object child)
      获取指定子节点的VetoableChangeListener（如果有）
      protected static Visibility getChildVisibility​(Object child)
      获取与指定子项关联的组件（如果有）。
      Locale getLocale​()
      获取此 BeanContext的区域设置。
      URL getResource​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实现介入小孩 Component和底层 ClassLoader之间的行为。
      InputStream getResourceAsStream​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。
      protected void initialize​()
      protected方法从构造函数和readObject调用，初始化BeanContextSupport实例的暂态。
      Object instantiateChild​(String beanName)
      instantiateChild方法是BeanContext中的一个方便的钩子，用于简化将Bean实例化的任务嵌套到一个 BeanContext 。
      boolean isDesignTime​()
      报告此对象是否在当前处于设计时模式。
      boolean isEmpty​()
      报告此 BeanContext是否为空。
      boolean isSerializing​()
      这是 BeanContext在串行化的过程吗？
      Iterator<Object> iterator​()
      获取当前嵌套在此 BeanContext中的所有JavaBean或 BeanContext实例。
      boolean needsGui​()
      通常从环境中调用此方法，以确定实现者是否“需要”GUI。
      void okToUseGui​()
      通知此实例，它现在可以呈现GUI
      void propertyChange​(PropertyChangeEvent pce)
      子类可以包围以监视子属性更改。
      void readChildren​(ObjectInputStream ois)
      当这个类的实例被用作实现BeanContext协议（及其子协议）的委托时，在反序列化期间存在一个'鸡和蛋'问题
      boolean remove​(Object targetChild)
      从此BeanContext中删除一个小孩。
      protected boolean remove​(Object targetChild, boolean callChildSetBC)
      内部删除使用时，由意外的 setBeanContext或 remove()引起的移除。
      boolean removeAll​(Collection c)
      删除所有指定的子（不支持）实现必须在层次结构锁和“children”保护字段上同步
      void removeBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      删除一个BeanContextMembershipListener
      boolean retainAll​(Collection c)
      只保留指定的子级（不支持）实现必须在层次结构锁和“children”保护字段上同步
      protected void serialize​(ObjectOutputStream oos, Collection<?> coll)
      由writeObject用于序列化集合。
      void setDesignTime​(boolean dTime)
      设置此 BeanContext的新设计时间值。
      void setLocale​(Locale newLocale)
      设置此BeanContext的区域设置。
      int size​()
      获取当前嵌套在此BeanContext中的子节点数。
      Object[] toArray​()
      获取当前嵌套在此BeanContext中的所有JavaBean或 BeanContext实例。
      Object[] toArray​(Object[] arry)
      获取一个包含此 BeanContext所有子项的 BeanContext ，与 BeanContext中包含的类型相匹配。
      protected boolean validatePendingAdd​(Object targetChild)
      此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在添加到BeanContext之前立即检查子对象。
      protected boolean validatePendingRemove​(Object targetChild)
      此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在BeanContext从BeanContext中删除之前立即检查子对象。
      void vetoableChange​(PropertyChangeEvent pce)
      子类可以包围以监视否决权子变化。
      void writeChildren​(ObjectOutputStream oos)
      用于序列化这个 BeanContext所有孩子。

      • Methods inherited from interface java.beans.beancontext.BeanContextChild

        addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext

      • Methods inherited from class java.beans.beancontext.BeanContextChildSupport

        addPropertyChangeListener, addVetoableChangeListener, firePropertyChange, fireVetoableChange, getBeanContext, getBeanContextChildPeer, initializeBeanContextResources, isDelegated, releaseBeanContextResources, removePropertyChangeListener, removeVetoableChangeListener, serviceAvailable, serviceRevoked, setBeanContext, validatePendingSetBeanContext

      • Methods inherited from interface java.util.Collection

        equals, hashCode, parallelStream, removeIf, spliterator, stream

      • Methods inherited from interface java.lang.Iterable

        forEach

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • children

        protected transient HashMap<Object,BeanContextSupport.BCSChild> children
        对 protected HashMap children字段的所有访问应在该对象上同步。

      • bcmListeners

        protected transient ArrayList<BeanContextMembershipListener> bcmListeners
        对 protected ArrayList bcmListeners字段的所有访问应在该对象上同步。

      • locale

        protected Locale locale
        此BeanContext的当前区域设置。

      • okToUseGui

        protected boolean okToUseGui
        A boolean指示该实例现在是否可以呈现GUI。

      • designTime

        protected boolean designTime
        A boolean指示该对象当前是否处于设计时间模式。

    • 构造方法详细信息

      • BeanContextSupport

        public BeanContextSupport​(BeanContext peer,
                          Locale lcle,
                          boolean dTime,
                          boolean visible)
        200新新新新200新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗200新新旗新新200新
        参数
        peer - 对等体 BeanContext我们正在提供一个实现，或者 null如果这个对象是它自己的对等
        lcle - 此BeanContext的当前区域设置。 如果lcle为null ，则将默认语言环境分配给BeanContext实例。
        dTime - 初始状态， true如果在设计模式下， false如果运行时。
        visible - 初始可见度。
        另请参见：
        Locale.getDefault() ， Locale.setDefault(java.util.Locale)

      • BeanContextSupport

        public BeanContextSupport​(BeanContext peer,
                          Locale lcle,
                          boolean dtime)
        使用指定的区域设置和设计模式创建一个实例。
        参数
        peer - 对等体 BeanContext我们正在提供一个实现，如果这个对象是自己的对等体， null
        lcle - 此BeanContext的当前语言环境。 如果lcle为null ， null将默认语言环境分配给BeanContext实例。
        dtime - 初始状态， true如果在设计模式下， false如果运行时。
        另请参见：
        Locale.getDefault() ， Locale.setDefault(java.util.Locale)

      • BeanContextSupport

        public BeanContextSupport​(BeanContext peer,
                          Locale lcle)
        使用指定的区域设置创建一个实例
        参数
        peer - 对等BeanContext我们提供了一个实现，或者是 null如果这个对象是它自己的对等
        lcle - 此BeanContext的当前语言环境。 如果lcle为null ，则将默认语言环境分配给BeanContext实例。
        另请参见：
        Locale.getDefault() ， Locale.setDefault(java.util.Locale)

      • BeanContextSupport

        public BeanContextSupport​(BeanContext peer)
        新新200新200新新新新新旗新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新
        参数
        peer - 对等体 BeanContext我们提供了一个实现，如果这个对象是它自己的对等点，或者是 null

      • BeanContextSupport

        public BeanContextSupport​()
        创建一个不是另一个对象的委托的实例

    • 方法详细信息

      • getBeanContextPeer

        public BeanContext getBeanContextPeer​()
        获取 BeanContext的实例，该对象正在为其提供实现。
        结果
        BeanContext实例

      • instantiateChild

        public Object instantiateChild​(String beanName)
                        throws IOException,
                               ClassNotFoundException

        instantiateChild方法是BeanContext中的一个方便的钩子，用于简化将Bean实例化的任务嵌套到一个BeanContext 。

        beanName参数的语义由java.beans.Beans.instantiate定义。

        Specified by:
        instantiateChild在接口 BeanContext
        参数
        beanName - 要在此BeanContext中实例化的Bean的名称
        结果
        新的对象
        异常
        IOException - 当bean被反序列化时是否存在I / O错误
        ClassNotFoundException - 如果没有找到由beanName参数标识的类

      • size

        public int size​()
        获取当前嵌套在此BeanContext中的子节点数。
        Specified by:
        size在接口 Collection
        结果
        儿童人数

      • isEmpty

        public boolean isEmpty​()
        报告此BeanContext是否为空。 如果一个BeanContext包含零个嵌套的子项，那么它被认为是空的。
        Specified by:
        isEmpty在接口 Collection
        结果
        如果没有孩子

      • contains

        public boolean contains​(Object o)
        确定指定的对象当前是否为此 BeanContext的子 BeanContext 。
        Specified by:
        contains在接口 Collection
        参数
        o - 有问题的对象
        结果
        如果这个对象是一个小孩

      • containsKey

        public boolean containsKey​(Object o)
        确定指定对象当前是否为此 BeanContext的子 BeanContext 。
        参数
        o - 有问题的对象
        结果
        如果这个对象是一个小孩

      • iterator

        public Iterator<Object> iterator​()
        获取当前嵌套在此 BeanContext中的所有JavaBean或 BeanContext实例。
        Specified by:
        iterator在接口 Collection
        Specified by:
        iterator在接口 Iterable<E>
        结果
        一个 Iterator的嵌套的孩子

      • toArray

        public Object[] toArray​()
        获取当前嵌套在此BeanContext中的所有JavaBean或 BeanContext实例。
        Specified by:
        toArray在接口 Collection
        结果
        一个包含此集合中所有元素的数组

      • toArray

        public Object[] toArray​(Object[] arry)
        获取一个包含此 BeanContext所有子项的数组，该数组与 BeanContext中包含的类型相匹配。
        Specified by:
        toArray在接口 Collection
        参数
        arry - 感兴趣的对象类型的数组。
        结果
        一群孩子

      • createBCSChild

        protected BeanContextSupport.BCSChild createBCSChild​(Object targetChild,
                                                     Object peer)

        子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。

        参数
        targetChild - 代表孩子创建的孩子
        peer - 对等体如果tragetChild和对等体通过BeanContextProxy的实现相关联
        结果
        子类别的子类别，而不用覆盖收集方法

      • add

        public boolean add​(Object targetChild)
        在这个BeanContext内添加/嵌套一个孩子。

        作为java.beans.Beans.instantiate（）的副作用调用。 如果子对象无法添加，则此方法将抛出IllegalStateException异常。

        Specified by:
        add在接口 Collection
        参数
        targetChild - 该对象嵌套在此 BeanContext
        结果
        如果孩子成功添加，则为true。
        另请参见：
        validatePendingAdd(java.lang.Object)

      • remove

        public boolean remove​(Object targetChild)
        从此BeanContext中删除一个小孩。 如果子对象不用于添加，则此方法将抛出IllegalStateException。
        Specified by:
        remove在接口 Collection
        参数
        targetChild - 子对象要删除
        结果
        true如果元素被删除作为此调用的结果
        另请参见：
        validatePendingRemove(java.lang.Object)

      • remove

        protected boolean remove​(Object targetChild,
                         boolean callChildSetBC)
        内部删除使用时，由意外的 setBeanContext或 remove()调用造成的。
        参数
        targetChild - 要删除的JavaBean，BeanContext或Object
        callChildSetBC - 用于表示应该通知孩子它不再嵌套在这个 BeanContext 。
        结果
        是否存在被删除之前

      • containsAll

        public boolean containsAll​(Collection c)
        测试以查看指定的 Collection中的所有对象是否为 Collection的子 BeanContext 。
        Specified by:
        containsAll在接口 Collection
        参数
        c - 指定的 Collection
        结果
        true如果集合中的所有对象都是这个 BeanContext子对象，如果没有， BeanContext false。
        另请参见：
        Collection.contains(Object)

      • addAll

        public boolean addAll​(Collection c)
        将集合添加到子集（不支持）的集合实现必须在层次结构锁和“children”保护字段上同步
        Specified by:
        addAll在接口 Collection
        参数
        c - 包含要添加到此集合的元素的集合
        结果
        这个实现无条件地抛出 UnsupportedOperationException
        异常
        UnsupportedOperationException - 无条件抛出此实现
        另请参见：
        Collection.add(Object)

      • removeAll

        public boolean removeAll​(Collection c)
        删除所有指定的子（不支持）实现必须在层次结构锁和“children”保护字段上同步
        Specified by:
        removeAll在接口 Collection
        参数
        c - 包含要从此集合中删除的元素的集合
        结果
        这个实现无条件地抛出 UnsupportedOperationException
        异常
        UnsupportedOperationException - 无条件抛出此实现
        另请参见：
        Collection.remove(Object) ， Collection.contains(Object)

      • retainAll

        public boolean retainAll​(Collection c)
        只保留指定的子级（不支持）实现必须在层次结构锁和“children”保护字段上同步
        Specified by:
        retainAll在接口 Collection
        参数
        c - 包含要保留在此集合中的元素的集合
        结果
        这个实现无条件地抛出 UnsupportedOperationException
        异常
        UnsupportedOperationException - 无条件抛出此实现
        另请参见：
        Collection.remove(Object) ， Collection.contains(Object)

      • clear

        public void clear​()
        清除子层（不支持）实现必须在层次结构锁和“children”保护字段上同步
        Specified by:
        clear在接口 Collection
        异常
        UnsupportedOperationException - 无条件抛出此实现

      • addBeanContextMembershipListener

        public void addBeanContextMembershipListener​(BeanContextMembershipListener bcml)
        添加一个BeanContextMembershipListener
        Specified by:
        addBeanContextMembershipListener在接口 BeanContext
        参数
        bcml - 要添加的BeanContextMembershipListener
        异常
        NullPointerException - 如果参数为空

      • removeBeanContextMembershipListener

        public void removeBeanContextMembershipListener​(BeanContextMembershipListener bcml)
        删除一个BeanContextMembershipListener
        Specified by:
        removeBeanContextMembershipListener在接口 BeanContext
        参数
        bcml - 要删除的BeanContextMembershipListener
        异常
        NullPointerException - 如果参数为空

      • getResourceAsStream

        public InputStream getResourceAsStream​(String name,
                                       BeanContextChild bcc)
        说明从界面BeanContext复制
        对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实施介入孩子 Component和底层 ClassLoader之间的行为。
        Specified by:
        getResourceAsStream在接口 BeanContext
        参数
        name - 请求的资源的名称。
        bcc - 提出请求的子对象。
        结果
        所请求的资源作为InputStream
        异常
        NullPointerException - 如果参数为空

      • getResource

        public URL getResource​(String name,
                       BeanContextChild bcc)
        描述从接口BeanContext复制
        对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实现介入孩子 Component和底层的 ClassLoader之间的行为。
        Specified by:
        getResource在接口 BeanContext
        参数
        name - 请求的资源的名称。
        bcc - 提出请求的子对象。
        结果
        所请求的资源作为InputStream

      • setDesignTime

        public void setDesignTime​(boolean dTime)
        设置这个 BeanContext的新设计时间值。
        Specified by:
        setDesignTime在接口 DesignMode
        参数
        dTime - 新的designTime值
        另请参见：
        BeanContext ， BeanContextMembershipListener ， PropertyChangeEvent

      • isDesignTime

        public boolean isDesignTime​()
        报告此对象是否在当前处于设计时模式。
        Specified by:
        isDesignTime在接口 DesignMode
        结果
        true如果在设计时模式下，如果没有 false

      • setLocale

        public void setLocale​(Locale newLocale)
               throws PropertyVetoException
        设置此BeanContext的区域设置。
        参数
        newLocale - 新的地区。 如果newLocale为null则此方法调用将null 。
        异常
        PropertyVetoException - 如果新值被拒绝

      • getLocale

        public Locale getLocale​()
        获取此 BeanContext的区域设置。
        结果
        当前的Locale的 BeanContext

      • needsGui

        public boolean needsGui​()

        通常从环境中调用此方法，以确定实现者是否“需要”GUI。

        本文使用的算法测试BeanContextPeer及其当前的子节点，以确定它们是容器，组件，还是实现可见性并返回needsGui（）== true。

        Specified by:
        needsGui在接口 Visibility
        结果
        true如果实现者需要一个GUI

      • dontUseGui

        public void dontUseGui​()
        通知此实例可能不再呈现GUI。
        Specified by:
        dontUseGui在接口 Visibility

      • okToUseGui

        public void okToUseGui​()
        通知此实例，它现在可以呈现GUI
        Specified by:
        okToUseGui在接口 Visibility

      • avoidingGui

        public boolean avoidingGui​()
        用于确定 BeanContext孩子是否避免使用其GUI。
        Specified by:
        avoidingGui在接口 Visibility
        结果
        这个实例是避免使用GUI吗？
        另请参见：
        Visibility

      • isSerializing

        public boolean isSerializing​()
        这是 BeanContext在序列化的过程中吗？
        结果
        如果这个 BeanContext目前正在序列化

      • bcsChildren

        protected Iterator<BeanContextSupport.BCSChild> bcsChildren​()
        返回此 BeanContext的所有子代的迭代器。
        结果
        所有当前BCSChild值的迭代器

      • bcsPreSerializationHook

        protected void bcsPreSerializationHook​(ObjectOutputStream oos)
                                throws IOException
        在writeWriteObject（）之后但在序列化当前可序列化的孩子之前调用writeObject。 这个方法可能被子类覆盖，以便在这个超类序列化孩子之前执行其状态的自定义序列化。 然而，这个方法不应该被子类用来替换它们自己的writeObject（）的实现（如果有的话）。
        参数
        oos - 序列化期间使用的 ObjectOutputStream
        异常
        IOException - 如果序列化失败

      • bcsPreDeserializationHook

        protected void bcsPreDeserializationHook​(ObjectInputStream ois)
                                  throws IOException,
                                         ClassNotFoundException
        通过readObject在defaultReadObject（）之后调用，但在任何孩子反序列化之前。 这个方法可能会被子类覆盖，以便在这个超类反序列化子进程之前执行其状态的自定义反序列化。 然而，这个方法不应该被子类用来替换它们自己的readObject（）的实现（如果有的话）。
        参数
        ois - 反序列化期间使用的 ObjectInputStream
        异常
        IOException - 如果反序列化失败
        ClassNotFoundException - 如果没有找到需要的类

      • childDeserializedHook

        protected void childDeserializedHook​(Object child,
                                     BeanContextSupport.BCSChild bcsc)
        由readObject与新反序列化的小孩和BCSChild调用。
        参数
        child - 新反序列化的孩子
        bcsc - 新反序列化的BCSChild

      • serialize

        protected final void serialize​(ObjectOutputStream oos,
                               Collection<?> coll)
                        throws IOException
        由writeObject用于序列化集合。
        参数
        oos - 序列化期间使用的 ObjectOutputStream
        coll - Collection要序列化
        异常
        IOException - 如果序列化失败

      • deserialize

        protected final void deserialize​(ObjectInputStream ois,
                                 Collection coll)
                          throws IOException,
                                 ClassNotFoundException
        由readObject用于反序列化集合。
        参数
        ois - 要使用的ObjectInputStream
        coll - 集合
        异常
        IOException - 如果反序列化失败
        ClassNotFoundException - 如果没有找到需要的类

      • writeChildren

        public final void writeChildren​(ObjectOutputStream oos)
                         throws IOException
        用于序列化这个 BeanContext所有孩子。
        参数
        oos - 序列化期间使用的 ObjectOutputStream
        异常
        IOException - 如果序列化失败

      • readChildren

        public final void readChildren​(ObjectInputStream ois)
                        throws IOException,
                               ClassNotFoundException
        当这个类的实例被用作实现BeanContext协议（及其子协议）的委托时，在反序列化期间存在一个'鸡和蛋'问题
        参数
        ois - 要使用的ObjectInputStream
        异常
        IOException - 如果反序列化失败
        ClassNotFoundException - 如果没有找到需要的类

      • vetoableChange

        public void vetoableChange​(PropertyChangeEvent pce)
                    throws PropertyVetoException
        子类可以包围以监视否决权子变化。
        Specified by:
        vetoableChange在接口 VetoableChangeListener
        参数
        pce - 描述事件源和已更改的属性的 PropertyChangeEvent对象。
        异常
        PropertyVetoException - 如果收件人希望回滚属性更改。

      • propertyChange

        public void propertyChange​(PropertyChangeEvent pce)
        子类可以包围以监视子属性更改。
        Specified by:
        propertyChange在接口 PropertyChangeListener
        参数
        pce - 描述事件源和已更改的属性的PropertyChangeEvent对象。

      • validatePendingAdd

        protected boolean validatePendingAdd​(Object targetChild)

        此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在添加到BeanContext之前立即检查子对象。

        参数
        targetChild - 孩子代表孩子创建
        结果
        如果孩子可能被添加到此BeanContext，则为true，否则为false。

      • validatePendingRemove

        protected boolean validatePendingRemove​(Object targetChild)

        此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在BeanContext从BeanContext中删除之前立即检查子对象。

        参数
        targetChild - 代表孩子创建孩子
        结果
        如果小孩可能从此BeanContext中删除，则为true，否则为false。

      • childJustAddedHook

        protected void childJustAddedHook​(Object child,
                                  BeanContextSupport.BCSChild bcsc)
        子类可以覆盖此方法，以便在添加子项之后和事件通知发生之前简单地扩展add（）语义。 该方法与子进程同步调用。
        参数
        child - 小孩
        bcsc - BCSChild

      • childJustRemovedHook

        protected void childJustRemovedHook​(Object child,
                                    BeanContextSupport.BCSChild bcsc)
        子类可以覆盖此方法，以便在子进程已被删除之后和事件通知发生之前简单地扩展remove（）语义。 该方法与子进程同步调用。
        参数
        child - 小孩
        bcsc - BCSChild

      • getChildVisibility

        protected static final Visibility getChildVisibility​(Object child)
        获取与指定子项关联的组件（如果有）。
        参数
        child - 指定的孩子
        结果
        与指定子项相关联的组件（如果有）。

      • getChildSerializable

        protected static final Serializable getChildSerializable​(Object child)
        获取与指定的Child相关联的Serializable（如果有）
        参数
        child - 指定的孩子
        结果
        与指定的Child相关联的Serializable（如果有）

      • getChildPropertyChangeListener

        protected static final PropertyChangeListener getChildPropertyChangeListener​(Object child)
        获取指定子对象的PropertyChangeListener（如果有）
        参数
        child - 指定的孩子
        结果
        指定子的PropertyChangeListener（如果有）

      • getChildVetoableChangeListener

        protected static final VetoableChangeListener getChildVetoableChangeListener​(Object child)
        获取指定子节点的VetoableChangeListener（如果有）
        参数
        child - 指定的小孩
        结果
        指定子代的VetoableChangeListener（如果有）

      • getChildBeanContextMembershipListener

        protected static final BeanContextMembershipListener getChildBeanContextMembershipListener​(Object child)
        获取指定子节点的BeanContextMembershipListener（如果有）
        参数
        child - 指定的孩子
        结果
        指定子对象的BeanContextMembershipListener（如果有）

      • getChildBeanContextChild

        protected static final BeanContextChild getChildBeanContextChild​(Object child)
        获取指定子节点的BeanContextChild（如果有）
        参数
        child - 指定的孩子
        结果
        指定子的BeanContextChild（如果有的话）
        异常
        IllegalArgumentException - 如果子实现了两个BeanContextChild和BeanContextProxy

      • fireChildrenAdded

        protected final void fireChildrenAdded​(BeanContextMembershipEvent bcme)
        在BeanContextMembershipListener接口上激活BeanContextshipEvent
        参数
        bcme - 事件发生

      • fireChildrenRemoved

        protected final void fireChildrenRemoved​(BeanContextMembershipEvent bcme)
        在BeanContextMembershipListener接口上激活BeanContextshipEvent
        参数
        bcme - 事件发生

      • initialize

        protected void initialize​()
        protected方法从构造函数和readObject调用，初始化BeanContextSupport实例的暂态。 此类使用此方法来实例化用于监视子对象的PropertyChange和VetoableChange事件的内部类侦听器。 子类可以包含这个方法来添加自己的初始化行为

      • copyChildren

        protected final Object[] copyChildren​()
        获取这个BeanContext的孩子的副本。
        结果
        当前嵌套的孩子的副本

      • classEquals

        protected static final boolean classEquals​(Class<?> first,
                                           Class<?> second)
        测试两个类对象或其名称是否相等。
        参数
        first - 第一个对象
        second - 第二个对象
        结果
        如果相等则为true，否则为false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextSupport.BCSChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextSupport.BCSChild

  • java.lang.Object
    • java.beans.beancontext.BeanContextSupport.BCSChild
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    BeanContextServicesSupport.BCSSChild
    Enclosing class:
    BeanContextSupport

    protected class BeanContextSupport.BCSChild
extends Object
implements Serializable
    另请参见：
    Serialized Form

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BeanContextSupport.BCSIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.desktop
软件包 java.beans.beancontext

Class BeanContextSupport.BCSIterator

  • java.lang.Object
    • java.beans.beancontext.BeanContextSupport.BCSIterator
  • All Implemented Interfaces:
    Iterator<Object>
    Enclosing class:
    BeanContextSupport

    protected static final class BeanContextSupport.BCSIterator
extends Object
implements Iterator<Object>
    受保护的final子类封装了一个迭代器，但实现了一个noop remove（）方法。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean hasNext​()
      如果迭代具有更多元素，则返回 true 。
      Object next​()
      返回迭代中的下一个元素。
      void remove​()
      从底层集合中删除此迭代器返回的最后一个元素（可选操作）。

      • Methods inherited from interface java.util.Iterator

        forEachRemaining

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • hasNext

        public boolean hasNext​()
        描述从接口Iterator复制
        如果迭代有更多元素，则返回true 。 （换句话说，如果true返回一个元素而不是抛出一个异常，则返回true ）
        Specified by:
        hasNext在接口 Iterator<Object>
        结果
        true如果迭代有更多的元素

      • next

        public Object next​()
        描述从接口Iterator复制
        返回迭代中的下一个元素。
        Specified by:
        next在接口 Iterator<Object>
        结果
        迭代中的下一个元素

      • remove

        public void remove​()
        说明从接口Iterator复制
        从底层集合中删除此迭代器返回的最后一个元素（可选操作）。 该方法只能在每次调用Iterator.next()时调用一次。

        如果在迭代正在进行中，除了通过调用此方法之外的任何方式修改底层集合，否则迭代器的行为是未指定的，除非重写类已指定并发修改策略。

        如果在调用forEachRemaining方法后调用此方法， 则不指定迭代器的行为。

        Specified by:
        remove在接口 Iterator<Object>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.beans.beancontext (Java SE 9 & JDK 9 )

java.beans.beancontext

Interfaces

  • BeanContext
  • BeanContextChild
  • BeanContextChildComponentProxy
  • BeanContextContainerProxy
  • BeanContextMembershipListener
  • BeanContextProxy
  • BeanContextServiceProvider
  • BeanContextServiceProviderBeanInfo
  • BeanContextServiceRevokedListener
  • BeanContextServices
  • BeanContextServicesListener

Classes

  • BeanContextChildSupport
  • BeanContextEvent
  • BeanContextMembershipEvent
  • BeanContextServiceAvailableEvent
  • BeanContextServiceRevokedEvent
  • BeanContextServicesSupport
  • BeanContextServicesSupport.BCSSServiceProvider
  • BeanContextSupport
  • BeanContextSupport.BCSIterator


java.beans.beancontext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.desktop

Package java.beans.beancontext

提供与bean上下文相关的类和接口。 bean上下文是一个bean的容器，并定义了它包含的bean的执行环境。 单个bean上下文中可以有几个bean，而且一个bean上下文可以嵌套在另一个bean上下文中。 此包还包含从bean上下文中添加和删除的bean的事件和侦听器接口。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    BeanContext
    BeanContext对JavaBeans起着逻辑分层容器的作用。
    BeanContextChild
    希望嵌套在JavaBeans中，并且获得对它们的执行环境的引用，或者由BeanContext子接口定义的上下文将实现该接口。
    BeanContextChildComponentProxy
    该接口由 BeanContextChildren实现，其具有与它们相关联的AWT Component 。
    BeanContextContainerProxy
    该接口由BeanContexts实现，它们具有与它们相关联的AWT容器。
    BeanContextMembershipListener
    BeanContext的成员状态发生变化时，BeanContexts会在此界面上触发事件。
    BeanContextProxy
    该接口由不直接具有与之关联的BeanContext（Child）的JavaBean实现（通过实现该接口或其子接口），但具有从其委托的公共BeanContext（Child）。
    BeanContextServiceProvider
    BeanContext的主要功能之一就是作为JavaBeans和BeanContextServiceProviders之间的会合。
    BeanContextServiceProviderBeanInfo
    一个BeanContextServiceProvider实现者希望提供关于他们的bean可能提供的服务的显式信息，应该实现一个实现这个BeanInfo子接口的BeanInfo类，并提供有关其服务的方法，属性，事件等的显式信息。
    BeanContextServiceRevokedListener
    用于接收 BeanContextServiceRevokedEvent对象的侦听器接口。
    BeanContextServices
    BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
    BeanContextServicesListener
    用于接收 BeanContextServiceAvailableEvent对象的侦听器接口。
  • 类摘要
    Class 描述
    BeanContextChildSupport
    这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
    BeanContextEvent
    BeanContextEvent是从 BeanContext的语义发出的所有事件的抽象根事件类。
    BeanContextMembershipEvent
    A BeanContextMembershipEvent封装了添加到特定 BeanContext的成员资格或从其中删除的子项列表。
    BeanContextServiceAvailableEvent
    BeanContextServicesListener使用此事件类型来识别正在注册的服务。
    BeanContextServiceRevokedEvent
    BeanContextServiceRevokedListener使用此事件类型，以识别正在撤销的服务。
    BeanContextServicesSupport
    这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
    BeanContextServicesSupport.BCSSServiceProvider
    子类可以将此嵌套类子类化为每个BeanContextServicesProvider添加行为。
    BeanContextSupport
    这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
    BeanContextSupport.BCSIterator
    受保护的final子类封装了一个迭代器，但实现了一个noop remove（）方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.beans.beancontext Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.beans.beancontext

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.beans.beancontext.BeanContextChildSupport (implements java.beans.beancontext.BeanContextChild, java.beans.beancontext.BeanContextServicesListener, java.io.Serializable)
      • java.beans.beancontext.BeanContextSupport (implements java.beans.beancontext.BeanContext, java.beans.PropertyChangeListener, java.io.Serializable, java.beans.VetoableChangeListener)
        • java.beans.beancontext.BeanContextServicesSupport (implements java.beans.beancontext.BeanContextServices)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider (implements java.beans.beancontext.BeanContextServiceProvider, java.beans.beancontext.BeanContextServiceRevokedListener)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider (implements java.io.Serializable)
    • java.beans.beancontext.BeanContextSupport.BCSChild (implements java.io.Serializable)
      • java.beans.beancontext.BeanContextServicesSupport.BCSSChild
    • java.beans.beancontext.BeanContextSupport.BCSIterator (implements java.util.Iterator<E>)
    • java.util.EventObject (implements java.io.Serializable)
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextMembershipEvent
        • java.beans.beancontext.BeanContextServiceAvailableEvent
        • java.beans.beancontext.BeanContextServiceRevokedEvent

Interface Hierarchy

  • java.beans.beancontext.BeanContextChild
    • java.beans.beancontext.BeanContext (also extends java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
  • java.beans.beancontext.BeanContextChildComponentProxy
  • java.beans.beancontext.BeanContextContainerProxy
  • java.beans.beancontext.BeanContextProxy
  • java.beans.beancontext.BeanContextServiceProvider
  • java.beans.BeanInfo
    • java.beans.beancontext.BeanContextServiceProviderBeanInfo
  • java.beans.DesignMode
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
  • java.util.EventListener
    • java.beans.beancontext.BeanContextMembershipListener
    • java.beans.beancontext.BeanContextServiceRevokedListener
      • java.beans.beancontext.BeanContextServicesListener
        • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext)
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.beans.DesignMode, java.beans.Visibility)
        • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
  • java.beans.Visibility
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Package java.beans.beancontext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.beans.beancontext

  • Packages that use java.beans.beancontext
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
  • Classes in java.beans.beancontext used by java.beans
    Class 描述
    BeanContext
    BeanContext对JavaBeans起着逻辑分层容器的作用。
  • Classes in java.beans.beancontext used by java.beans.beancontext
    Class 描述
    BeanContext
    BeanContext对JavaBeans起着逻辑分层容器的作用。
    BeanContextChild
    希望嵌套在JavaBeans中，并且获得对它们的执行环境的引用，或者由BeanContext子接口定义的上下文将实现该接口。
    BeanContextChildSupport
    这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
    BeanContextEvent
    BeanContextEvent是从 BeanContext的语义发出的所有事件的抽象根事件类。
    BeanContextMembershipEvent
    A BeanContextMembershipEvent封装了添加到特定 BeanContext的成员资格或从其中删除的子项列表。
    BeanContextMembershipListener
    BeanContext的成员状态发生变化时，BeanContexts会在此界面上触发事件。
    BeanContextServiceAvailableEvent
    BeanContextServicesListener使用此事件类型来识别正在注册的服务。
    BeanContextServiceProvider
    BeanContext的主要功能之一就是作为JavaBeans和BeanContextServiceProviders之间的会合。
    BeanContextServiceRevokedEvent
    BeanContextServiceRevokedListener使用此事件类型，以识别正在撤销的服务。
    BeanContextServiceRevokedListener
    用于接收 BeanContextServiceRevokedEvent对象的侦听器接口。
    BeanContextServices
    BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
    BeanContextServicesListener
    用于接收 BeanContextServiceAvailableEvent对象的侦听器接口。
    BeanContextServicesSupport.BCSSProxyServiceProvider
    BeanContextServicesSupport.BCSSServiceProvider
    子类可以将此嵌套类子类化为每个BeanContextServicesProvider添加行为。
    BeanContextSupport
    这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
    BeanContextSupport.BCSChild
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextChildSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextChildSupport

  • Packages that use BeanContextChildSupport
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextChildSupport in java.beans.beancontext

      Subclasses of BeanContextChildSupport in java.beans.beancontext
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextEvent

  • Packages that use BeanContextEvent
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextEvent in java.beans.beancontext

      Subclasses of BeanContextEvent in java.beans.beancontext
      Modifier and Type Class 描述
      class  BeanContextMembershipEvent
      A BeanContextMembershipEvent封装了添加到特定 BeanContext的成员资格或从其中删除的子项列表。
      class  BeanContextServiceAvailableEvent
      BeanContextServicesListener使用此事件类型来识别正在注册的服务。
      class  BeanContextServiceRevokedEvent
      该事件类型由 BeanContextServiceRevokedListener用于识别正在撤销的服务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextMembershipEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextMembershipEvent

  • Packages that use BeanContextMembershipEvent
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextMembershipEvent in java.beans.beancontext

      Methods in java.beans.beancontext with parameters of type BeanContextMembershipEvent
      Modifier and Type 方法 描述
      void BeanContextMembershipListener.childrenAdded​(BeanContextMembershipEvent bcme)
      当一个孩子或孩子列表被添加到这个监听器注册的 BeanContext时调用。
      void BeanContextMembershipListener.childrenRemoved​(BeanContextMembershipEvent bcme)
      当这名听众注册的一个 BeanContext中删除了一个孩子或孩子列表时调用。
      protected void BeanContextSupport.fireChildrenAdded​(BeanContextMembershipEvent bcme)
      在BeanContextMembershipListener接口上激活BeanContextshipEvent
      protected void BeanContextSupport.fireChildrenRemoved​(BeanContextMembershipEvent bcme)
      在BeanContextMembershipListener接口上激活BeanContextshipEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextServiceAvailableEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextServiceAvailableEvent

  • Packages that use BeanContextServiceAvailableEvent
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServiceAvailableEvent in java.beans.beancontext

      Methods in java.beans.beancontext with parameters of type BeanContextServiceAvailableEvent
      Modifier and Type 方法 描述
      protected void BeanContextServicesSupport.fireServiceAdded​(BeanContextServiceAvailableEvent bcssae)
      触发 BeanContextServiceAvailableEvent表示新服务已经可用。
      void BeanContextChildSupport.serviceAvailable​(BeanContextServiceAvailableEvent bcsae)
      嵌套BeanContext提供了新的服务。
      void BeanContextServicesListener.serviceAvailable​(BeanContextServiceAvailableEvent bcsae)
      已命名的服务已注册。 此服务的getService请求现在可以进行。
      void BeanContextServicesSupport.serviceAvailable​(BeanContextServiceAvailableEvent bcssae)
      BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextServiceRevokedEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextServiceRevokedEvent

  • Packages that use BeanContextServiceRevokedEvent
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServiceRevokedEvent in java.beans.beancontext

      Methods in java.beans.beancontext with parameters of type BeanContextServiceRevokedEvent
      Modifier and Type | 方法 | 描述
      protected void BeanContextServicesSupport.fireServiceRevoked​(BeanContextServiceRevokedEvent bcsre)
      发出 BeanContextServiceEvent通知正在撤销的服务。
      void BeanContextChildSupport.serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
      嵌套BeanContext提供的服务已被撤销。
      void BeanContextServiceRevokedListener.serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
      已命名的服务已被撤销。 此服务的getService请求将不再满足。
      void | BeanContextServicesSupport.BCSSProxyServiceProvider.serviceRevoked​(BeanContextServiceRevokedEvent bcsre)
      void BeanContextServicesSupport.serviceRevoked​(BeanContextServiceRevokedEvent bcssre)
      BeanContextServicesListener回调，将事件传播到所有当前注册的监听器和BeanContextServices子节点，如果此BeanContextService尚未实现此服务本身。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextServicesSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextServicesSupport

No usage of java.beans.beancontext.BeanContextServicesSupport
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextServicesSupport.BCSSChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextServicesSupport.BCSSChild

No usage of java.beans.beancontext.BeanContextServicesSupport.BCSSChild
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider

  • Packages that use BeanContextServicesSupport.BCSSProxyServiceProvider
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServicesSupport.BCSSProxyServiceProvider in java.beans.beancontext

      Fields in java.beans.beancontext declared as BeanContextServicesSupport.BCSSProxyServiceProvider
      Modifier and Type Field 描述
      protected BeanContextServicesSupport.BCSSProxyServiceProvider BeanContextServicesSupport.proxy
      代表 BeanContextServiceProvider 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider

  • Packages that use BeanContextServicesSupport.BCSSServiceProvider
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServicesSupport.BCSSServiceProvider in java.beans.beancontext

      Fields in java.beans.beancontext with type parameters of type BeanContextServicesSupport.BCSSServiceProvider
      Modifier and Type Field 描述
      protected HashMap<Object,BeanContextServicesSupport.BCSSServiceProvider> BeanContextServicesSupport.services
      对 protected transient HashMap services字段的所有访问应该在该对象上同步
      Methods in java.beans.beancontext that return BeanContextServicesSupport.BCSSServiceProvider
      Modifier and Type 方法 描述
      protected BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider​(Class<?> sc, BeanContextServiceProvider bcsp)
      子类可以覆盖此方法来创建BCSSServiceProvider的新子类，而不必重写addService（）以便实例化。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextSupport

  • Packages that use BeanContextSupport
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextSupport in java.beans.beancontext

      Subclasses of BeanContextSupport in java.beans.beancontext
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextSupport.BCSChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextSupport.BCSChild

  • Packages that use BeanContextSupport.BCSChild
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextSupport.BCSChild in java.beans.beancontext

      Subclasses of BeanContextSupport.BCSChild in java.beans.beancontext
      Modifier and Type | Class | 描述
      protected class  | BeanContextServicesSupport.BCSSChild
      Fields in java.beans.beancontext with type parameters of type BeanContextSupport.BCSChild
      Modifier and Type Field 描述
      protected HashMap<Object,BeanContextSupport.BCSChild> BeanContextSupport.children
      对 protected HashMap children字段的所有访问应在该对象上同步。
      Methods in java.beans.beancontext that return BeanContextSupport.BCSChild
      Modifier and Type 方法 描述
      protected BeanContextSupport.BCSChild BeanContextServicesSupport.createBCSChild​(Object targetChild, Object peer)
      子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。
      protected BeanContextSupport.BCSChild BeanContextSupport.createBCSChild​(Object targetChild, Object peer)
      子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。
      Methods in java.beans.beancontext that return types with arguments of type BeanContextSupport.BCSChild
      Modifier and Type 方法 描述
      protected Iterator<BeanContextSupport.BCSChild> BeanContextSupport.bcsChildren​()
      返回此 BeanContext的所有子代的迭代器。
      Methods in java.beans.beancontext with parameters of type BeanContextSupport.BCSChild
      Modifier and Type 方法 描述
      protected void BeanContextSupport.childDeserializedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      由readObject与新反序列化的小孩和BCSChild调用。
      protected void BeanContextSupport.childJustAddedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      子类可以覆盖此方法，以便在添加子项之后和事件通知发生之前简单地扩展add（）语义。
      protected void BeanContextServicesSupport.childJustRemovedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      在孩子被成功删除之后从超类儿童删除操作中调用。 调用与子同步。
      protected void BeanContextSupport.childJustRemovedHook​(Object child, BeanContextSupport.BCSChild bcsc)
      子类可以覆盖此方法，以便在子进程已被删除之后和事件通知发生之前简单地扩展remove（）语义。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.beancontext.BeanContextSupport.BCSIterator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.beancontext.BeanContextSupport.BCSIterator

No usage of java.beans.beancontext.BeanContextSupport.BCSIterator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContext

  • Packages that use BeanContext
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContext in java.beans

      Methods in java.beans with parameters of type BeanContext
      Modifier and Type 方法 描述
      void AppletInitializer.initialize​(Applet newAppletBean, BeanContext bCtxt)
      已过时。
      如果传递给java.beans.Beans.instantiate的相应变体，则将调用此方法，以便将新实例化的Applet（JavaBean）与其AppletContext，AppletStub和Container关联。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)
      实例化JavaBean。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
      已过时。
      建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of BeanContext in java.beans.beancontext

      Subinterfaces of BeanContext in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      Classes in java.beans.beancontext that implement BeanContext
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Fields in java.beans.beancontext declared as BeanContext
      Modifier and Type Field 描述
      protected BeanContext BeanContextChildSupport.beanContext
      bean上下文。
      protected BeanContext BeanContextEvent.propagatedFrom
      传播此事件的 BeanContext
      Methods in java.beans.beancontext that return BeanContext
      Modifier and Type 方法 描述
      BeanContext BeanContextChild.getBeanContext​()
      获取 BeanContext与此 BeanContextChild相关联。
      BeanContext BeanContextChildSupport.getBeanContext​()
      获取嵌套 BeanContext这个 BeanContextChildSupport 。
      BeanContext BeanContextEvent.getBeanContext​()
      获取与此事件关联的 BeanContext 。
      BeanContext BeanContextSupport.getBeanContextPeer​()
      获取 BeanContext的实例，该对象正在为其提供实现。
      BeanContext BeanContextEvent.getPropagatedFrom​()
      获取传播此事件的 BeanContext 。
      Methods in java.beans.beancontext with parameters of type BeanContext
      Modifier and Type 方法 描述
      void BeanContextChild.setBeanContext​(BeanContext bc)
      实现此接口的对象将触发java.beans.PropertyChangeEvent，其参数为：propertyName“beanContext”，oldValue（以前的嵌套 BeanContext实例或 null ），newValue（当前嵌套的 BeanContext实例或 null ）。
      void BeanContextChildSupport.setBeanContext​(BeanContext bc)
      设置 BeanContext为这 BeanContextChildSupport 。
      void BeanContextEvent.setPropagatedFrom​(BeanContext bc)
      设置传播此事件的 BeanContext 。
      boolean BeanContextChildSupport.validatePendingSetBeanContext​(BeanContext newValue)
      从setBeanContext调用以验证（或以其他方式）嵌套BeanContext属性值中的挂起更改。
      Constructors in java.beans.beancontext with parameters of type BeanContext
      Constructor 描述
      BeanContextEvent​(BeanContext bc)
      Contruct一个BeanContextEvent
      BeanContextMembershipEvent​(BeanContext bc, Object[] changes)
      引发BeanContextMembershipEvent
      BeanContextMembershipEvent​(BeanContext bc, Collection changes)
      引发BeanContextMembershipEvent
      BeanContextSupport​(BeanContext peer)
      新新200新200新新新新新旗新新200新新200新新200新新200新新200新新200新新200新新200新新新200新新200新新
      BeanContextSupport​(BeanContext peer, Locale lcle)
      使用指定的区域设置创建一个实例
      BeanContextSupport​(BeanContext peer, Locale lcle, boolean dtime)
      使用指定的区域设置和设计模式创建一个实例。
      BeanContextSupport​(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
      200新新新新200新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗200新新旗新新200新
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextChild (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextChild

  • Packages that use BeanContextChild
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextChild in java.beans.beancontext

      Subinterfaces of BeanContextChild in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContext
      BeanContext对JavaBeans起着逻辑分层容器的作用。
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      Classes in java.beans.beancontext that implement BeanContextChild
      Modifier and Type Class 描述
      class  BeanContextChildSupport
      这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Fields in java.beans.beancontext declared as BeanContextChild
      Modifier and Type Field 描述
      BeanContextChild BeanContextChildSupport.beanContextChildPeer
      该 BeanContext在此 BeanContextChild是嵌套。
      Methods in java.beans.beancontext that return BeanContextChild
      Modifier and Type 方法 描述
      BeanContextChild BeanContextChildSupport.getBeanContextChildPeer​()
      获取 BeanContextChild与此 BeanContextChildSupport相关联。
      BeanContextChild BeanContextProxy.getBeanContextProxy​()
      获取与此对象关联的 BeanContextChild （或子接口）。
      protected static BeanContextChild BeanContextSupport.getChildBeanContextChild​(Object child)
      获取指定子节点的BeanContextChild（如果有）
      Methods in java.beans.beancontext with parameters of type BeanContextChild
      Modifier and Type | 方法 | 描述
      URL BeanContext.getResource​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。
      URL | BeanContextSupport.getResource​(String name, BeanContextChild bcc)
      InputStream BeanContext.getResourceAsStream​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。
      InputStream | BeanContextSupport.getResourceAsStream​(String name, BeanContextChild bcc)
      Object BeanContextServices.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。
      Object BeanContextServicesSupport.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      获得可能委托的服务
      void BeanContextServices.releaseService​(BeanContextChild child, Object requestor, Object service)
      通过在底层的 BeanContextServiceProvider上调用releaseService（），释放一个 BeanContextChild （或任何与BeanContextChild关联的任意对象）对指定服务的 BeanContextServiceProvider 。
      void BeanContextServicesSupport.releaseService​(BeanContextChild child, Object requestor, Object service)
      发布服务
      Constructors in java.beans.beancontext with parameters of type BeanContextChild
      Constructor 描述
      BeanContextChildSupport​(BeanContextChild bcc)
      构造一个BeanContextChildSupport，其中JavaBean组件自身实现BeanContextChild，并封装了这个，将该接口委派给此实现
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextChildComponentProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextChildComponentProxy

No usage of java.beans.beancontext.BeanContextChildComponentProxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextContainerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextContainerProxy

No usage of java.beans.beancontext.BeanContextContainerProxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextMembershipListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextMembershipListener

  • Packages that use BeanContextMembershipListener
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextMembershipListener in java.beans.beancontext

      Fields in java.beans.beancontext with type parameters of type BeanContextMembershipListener
      Modifier and Type Field 描述
      protected ArrayList<BeanContextMembershipListener> BeanContextSupport.bcmListeners
      对 protected ArrayList bcmListeners字段的所有访问应在该对象上同步。
      Methods in java.beans.beancontext that return BeanContextMembershipListener
      Modifier and Type 方法 描述
      protected static BeanContextMembershipListener BeanContextSupport.getChildBeanContextMembershipListener​(Object child)
      获取指定子节点的BeanContextMembershipListener（如果有）
      Methods in java.beans.beancontext with parameters of type BeanContextMembershipListener
      Modifier and Type 方法 描述
      void BeanContext.addBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      添加指定 BeanContextMembershipListener接收 BeanContextMembershipEvents从这个 BeanContext无论何时添加或删除孩子 Component （S）。
      void BeanContextSupport.addBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      添加一个BeanContextMembershipListener
      void BeanContext.removeBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      删除指定的 BeanContextMembershipListener以便在添加或删除子项 Component时不再接收 BeanContextMembershipEvent 。
      void BeanContextSupport.removeBeanContextMembershipListener​(BeanContextMembershipListener bcml)
      Removes a BeanContextMembershipListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextProxy

No usage of java.beans.beancontext.BeanContextProxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextServiceProvider (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextServiceProvider

  • Packages that use BeanContextServiceProvider
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServiceProvider in java.beans.beancontext

      Classes in java.beans.beancontext that implement BeanContextServiceProvider
      Modifier and Type | Class | 描述
      protected class  | BeanContextServicesSupport.BCSSProxyServiceProvider
      Fields in java.beans.beancontext declared as BeanContextServiceProvider
      Modifier and Type Field 描述
      protected BeanContextServiceProvider BeanContextServicesSupport.BCSSServiceProvider.serviceProvider
      服务提供商。
      Methods in java.beans.beancontext that return BeanContextServiceProvider
      Modifier and Type 方法 描述
      protected BeanContextServiceProvider BeanContextServicesSupport.BCSSServiceProvider.getServiceProvider​()
      返回服务提供者。
      Methods in java.beans.beancontext with parameters of type BeanContextServiceProvider
      Modifier and Type 方法 描述
      boolean BeanContextServices.addService​(Class<?> serviceClass, BeanContextServiceProvider serviceProvider)
      向这个BeanContext添加一个服务。
      boolean BeanContextServicesSupport.addService​(Class<?> serviceClass, BeanContextServiceProvider bcsp)
      添加服务
      protected boolean BeanContextServicesSupport.addService​(Class<?> serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
      添加服务
      protected BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider​(Class<?> sc, BeanContextServiceProvider bcsp)
      子类可以覆盖此方法来创建BCSSServiceProvider的新子类，而不必重写addService（）以便实例化。
      void BeanContextServices.revokeService​(Class<?> serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
      希望从此上下文中删除当前注册的服务的BeanContextServiceProviders可以通过调用此方法来实现。
      void BeanContextServicesSupport.revokeService​(Class<?> serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
      删除服务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextServiceProviderBeanInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextServiceProviderBeanInfo

No usage of java.beans.beancontext.BeanContextServiceProviderBeanInfo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextServiceRevokedListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextServiceRevokedListener

  • Packages that use BeanContextServiceRevokedListener
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServiceRevokedListener in java.beans.beancontext

      Subinterfaces of BeanContextServiceRevokedListener in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      interface  BeanContextServicesListener
      用于接收 BeanContextServiceAvailableEvent对象的侦听器接口。
      Classes in java.beans.beancontext that implement BeanContextServiceRevokedListener
      Modifier and Type | Class | 描述
      class  BeanContextChildSupport
      这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      protected class  | BeanContextServicesSupport.BCSSProxyServiceProvider
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Methods in java.beans.beancontext with parameters of type BeanContextServiceRevokedListener
      Modifier and Type 方法 描述
      Object BeanContextServices.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。
      Object BeanContextServicesSupport.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      获得可能委托的服务
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextServices (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextServices

  • Packages that use BeanContextServices
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServices in java.beans.beancontext

      Classes in java.beans.beancontext that implement BeanContextServices
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      Methods in java.beans.beancontext that return BeanContextServices
      Modifier and Type 方法 描述
      BeanContextServices BeanContextServicesSupport.getBeanContextServicesPeer​()
      获取 BeanContextServices与此 BeanContextServicesSupport相关联。
      BeanContextServices BeanContextServiceAvailableEvent.getSourceAsBeanContextServices​()
      获取来源作为参考类型 BeanContextServices 。
      BeanContextServices BeanContextServiceRevokedEvent.getSourceAsBeanContextServices​()
      获取来源作为参考类型 BeanContextServices
      Methods in java.beans.beancontext with parameters of type BeanContextServices
      Modifier and Type | 方法 | 描述
      Iterator<?> BeanContextServiceProvider.getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      此方法由 BeanContextServices调用，获取指定服务的当前服务选择器。
      Iterator<?> | BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      Object BeanContextServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)
      通过调用 BeanContextServices ，这种方法从这个请求服务的实例 BeanContextServiceProvider 。
      Object | BeanContextServicesSupport.BCSSProxyServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)
      void BeanContextServiceProvider.releaseService​(BeanContextServices bcs, Object requestor, Object service)
      通过调用 BeanContextServices ，这种方法释放嵌套 BeanContextChild的（或与相关联的任何任意对象 BeanContextChild ）参照指定的服务。
      void | BeanContextServicesSupport.BCSSProxyServiceProvider.releaseService​(BeanContextServices bcs, Object requestor, Object service)
      Constructors in java.beans.beancontext with parameters of type BeanContextServices
      Constructor 描述
      BeanContextServiceAvailableEvent​(BeanContextServices bcs, Class<?> sc)
      构建一个 BeanContextAvailableServiceEvent 。
      BeanContextServiceRevokedEvent​(BeanContextServices bcs, Class<?> sc, boolean invalidate)
      构造一个 BeanContextServiceEvent 。
      BeanContextServicesSupport​(BeanContextServices peer)
      与对等体创建一个实例
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle)
      使用指定的区域设置创建一个实例
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle, boolean dtime)
      使用指定的区域设置和设计模式创建一个实例。
      BeanContextServicesSupport​(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
      构造一个BeanContextServicesSupport实例
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.beancontext.BeanContextServicesListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.beancontext.BeanContextServicesListener

  • Packages that use BeanContextServicesListener
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanContextServicesListener in java.beans.beancontext

      Subinterfaces of BeanContextServicesListener in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      Classes in java.beans.beancontext that implement BeanContextServicesListener
      Modifier and Type Class 描述
      class  BeanContextChildSupport
      这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Fields in java.beans.beancontext with type parameters of type BeanContextServicesListener
      Modifier and Type Field 描述
      protected ArrayList<BeanContextServicesListener> BeanContextServicesSupport.bcsListeners
      BeanContextServicesListener对象列表。
      Methods in java.beans.beancontext that return BeanContextServicesListener
      Modifier and Type 方法 描述
      protected static BeanContextServicesListener BeanContextServicesSupport.getChildBeanContextServicesListener​(Object child)
      获取指定小孩的 BeanContextServicesListener （如果有）。
      Methods in java.beans.beancontext with parameters of type BeanContextServicesListener
      Modifier and Type 方法 描述
      void BeanContextServices.addBeanContextServicesListener​(BeanContextServicesListener bcsl)
      为此BeanContext添加一个 BeanContextServicesListener
      void BeanContextServicesSupport.addBeanContextServicesListener​(BeanContextServicesListener bcsl)
      添加一个BeanContextServicesListener
      void BeanContextServices.removeBeanContextServicesListener​(BeanContextServicesListener bcsl)
      删除一个 BeanContextServicesListener从这个 BeanContext
      void BeanContextServicesSupport.removeBeanContextServicesListener​(BeanContextServicesListener bcsl)
      删除一个BeanContextServicesListener
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.BeanDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.BeanDescriptor

  • Packages that use BeanDescriptor
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of BeanDescriptor in java.beans

      Methods in java.beans that return BeanDescriptor
      Modifier and Type 方法 描述
      BeanDescriptor BeanInfo.getBeanDescriptor​()
      返回提供关于该bean的整体信息的bean描述符，例如其显示名称或其定制器。
      BeanDescriptor SimpleBeanInfo.getBeanDescriptor​()
      拒绝关于bean的类和定制器的知识。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.BeanProperty (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.BeanProperty

  • Packages that use BeanProperty
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of BeanProperty in java.awt

      Methods in java.awt with annotations of type BeanProperty
      Modifier and Type 方法 描述
      AccessibleContext Button.getAccessibleContext​()
      获取 AccessibleContext与此 Button相关联。

    • Uses of BeanProperty in javax.accessibility

      Methods in javax.accessibility with annotations of type BeanProperty
      Modifier and Type 方法 描述
      void AccessibleContext.setAccessibleDescription​(String s)
      设置此对象的可访问描述。
      void AccessibleContext.setAccessibleName​(String s)
      设置此对象的本地化可访问名称。

    • Uses of BeanProperty in javax.swing

      Methods in javax.swing with annotations of type BeanProperty
      Modifier and Type 方法 描述
      void JFileChooser.addChoosableFileFilter​(FileFilter filter)
      将一个过滤器添加到用户可选择的文件过滤器列表中。
      FileFilter JFileChooser.getAcceptAllFileFilter​()
      返回 AcceptAll文件过滤器。
      AccessibleContext Box.getAccessibleContext​()
      获取与此Box关联的AccessibleContext。
      AccessibleContext ImageIcon.getAccessibleContext​()
      获取与此ImageIcon关联的AccessibleContext。
      AccessibleContext JButton.getAccessibleContext​()
      获取 AccessibleContext与此 JButton相关联。
      AccessibleContext JCheckBox.getAccessibleContext​()
      获取与此JCheckBox关联的AccessibleContext。
      AccessibleContext JCheckBoxMenuItem.getAccessibleContext​()
      获取与此JCheckBoxMenuItem关联的AccessibleContext。
      AccessibleContext JColorChooser.getAccessibleContext​()
      获取与此JColorChooser关联的AccessibleContext。
      AccessibleContext JComboBox.getAccessibleContext​()
      获取与此JComboBox关联的AccessibleContext。
      AccessibleContext JDesktopPane.getAccessibleContext​()
      获取 AccessibleContext与此 JDesktopPane相关联。
      AccessibleContext JEditorPane.getAccessibleContext​()
      获取与此JEditorPane关联的AccessibleContext。
      AccessibleContext JFileChooser.getAccessibleContext​()
      获取与此JFileChooser关联的AccessibleContext。
      AccessibleContext JInternalFrame.getAccessibleContext​()
      获取 AccessibleContext与此 JInternalFrame相关联。
      AccessibleContext JLabel.getAccessibleContext​()
      获取此对象的AccessibleContext
      AccessibleContext JLayeredPane.getAccessibleContext​()
      获取与此JLayeredPane关联的AccessibleContext。
      AccessibleContext JList.getAccessibleContext​()
      获取 AccessibleContext与此 JList相关联。
      AccessibleContext JMenu.getAccessibleContext​()
      获取与此JMenu关联的AccessibleContext。
      AccessibleContext JMenuBar.getAccessibleContext​()
      获取与此JMenuBar关联的AccessibleContext。
      AccessibleContext JMenuItem.getAccessibleContext​()
      返回 AccessibleContext与此相关 JMenuItem 。
      AccessibleContext JOptionPane.getAccessibleContext​()
      返回与此JOptionPane关联的 AccessibleContext 。
      AccessibleContext JPanel.getAccessibleContext​()
      获取与此JPanel关联的AccessibleContext。
      AccessibleContext JPasswordField.getAccessibleContext​()
      返回 AccessibleContext与此 JPasswordField相关联。
      AccessibleContext JPopupMenu.getAccessibleContext​()
      获取与此JPopupMenu关联的AccessibleContext。
      AccessibleContext JProgressBar.getAccessibleContext​()
      获取 AccessibleContext与此 JProgressBar相关联。
      AccessibleContext JRadioButton.getAccessibleContext​()
      获取与此JRadioButton关联的AccessibleContext。
      AccessibleContext JRadioButtonMenuItem.getAccessibleContext​()
      获取与此JRadioButtonMenuItem关联的AccessibleContext。
      AccessibleContext JScrollBar.getAccessibleContext​()
      获取与此JScrollBar关联的AccessibleContext。
      AccessibleContext JScrollPane.getAccessibleContext​()
      获取与此JScrollPane关联的AccessibleContext。
      AccessibleContext JSeparator.getAccessibleContext​()
      获取与此JSeparator关联的AccessibleContext。
      AccessibleContext JSlider.getAccessibleContext​()
      获取与此JSlider相关联的AccessibleContext。
      AccessibleContext JSpinner.getAccessibleContext​()
      获得 AccessibleContext的 JSpinner
      AccessibleContext JSplitPane.getAccessibleContext​()
      获取与此JSplitPane关联的AccessibleContext。
      AccessibleContext JTabbedPane.getAccessibleContext​()
      获取与此JTabbedPane关联的AccessibleContext。
      AccessibleContext JTable.getAccessibleContext​()
      获取与此JTable关联的AccessibleContext。
      AccessibleContext JTextArea.getAccessibleContext​()
      获取与此JTextArea关联的AccessibleContext。
      AccessibleContext JTextField.getAccessibleContext​()
      获取 AccessibleContext与此 JTextField相关联。
      AccessibleContext JToggleButton.getAccessibleContext​()
      获取与此JToggleButton关联的AccessibleContext。
      AccessibleContext JToolBar.getAccessibleContext​()
      获取与此JToolBar关联的AccessibleContext。
      AccessibleContext JTree.getAccessibleContext​()
      获取与此JTree关联的AccessibleContext。
      ActionListener[] AbstractButton.getActionListeners​()
      返回使用addActionListener（）添加到此AbstractButton的所有 ActionListener的数组。
      ActionListener[] JComboBox.getActionListeners​()
      返回使用addActionListener（）添加到此JComboBox的所有 ActionListener的数组。
      ActionListener[] JFileChooser.getActionListeners​()
      返回在此文件选择器上注册的所有动作侦听器的数组。
      ActionListener[] JTextField.getActionListeners​()
      返回使用addActionListener（）添加到此JTextField的所有 ActionListener的数组。
      Action[] JFormattedTextField.getActions​()
      获取编辑器的命令列表。
      Action[] JTextField.getActions​()
      获取编辑器的命令列表。
      AdjustmentListener[] JScrollBar.getAdjustmentListeners​()
      返回使用addAdjustmentListener（）添加到此JScrollBar的所有 AdjustmentListener的数组。
      JInternalFrame[] JDesktopPane.getAllFrames​()
      返回目前在桌面上显示的所有 JInternalFrames 。
      AncestorListener[] JComponent.getAncestorListeners​()
      返回在此组件上注册的所有祖先监听器的数组。
      int JList.getAnchorSelectionIndex​()
      返回锚选择索引。
      Component.BaselineResizeBehavior JComponent.getBaselineResizeBehavior​()
      返回一个枚举，指示组件的基线如何随着大小的变化而改变。
      ChangeListener[] AbstractButton.getChangeListeners​()
      返回使用addChangeListener（）添加到此AbstractButton的所有 ChangeListener的数组。
      ChangeListener[] JProgressBar.getChangeListeners​()
      返回所有的数组 ChangeListener加入到这一进度条以s addChangeListener 。
      ChangeListener[] JSlider.getChangeListeners​()
      返回使用addChangeListener（）添加到此JSlider的所有 ChangeListener的数组。
      ChangeListener[] JSpinner.getChangeListeners​()
      返回使用addChangeListener（）添加到此JSpinner的所有 ChangeListener的数组。
      ChangeListener[] JTabbedPane.getChangeListeners​()
      返回所有 ChangeListener的数组，添加到 JTabbedPane与 addChangeListener 。
      AttributeSet JTextPane.getCharacterAttributes​()
      获取在插入符号的当前位置生效的字符属性，或 null 。
      FileFilter[] JFileChooser.getChoosableFileFilters​()
      获取用户可选择的文件过滤器列表。
      int JTable.getColumnCount​()
      返回列模型中的列数。
      JDesktopPane JInternalFrame.getDesktopPane​()
      在 JDesktop实例中搜索祖先层级结构的便捷方法。
      JList.DropLocation JList.getDropLocation​()
      在组件的DnD操作期间返回此组件应该可视地指示为放置位置的位置，如果没有显示当前位置，则返回 null 。
      JTable.DropLocation JTable.getDropLocation​()
      返回在组件中的DnD操作期间该组件应该可视地指示为放置位置的位置，如果没有显示当前位置，则返回 null 。
      JTree.DropLocation JTree.getDropLocation​()
      返回该组件在DnD操作过程中可视化指示为该组件的位置，如果目前未显示任何位置，则返回 null 。
      TreePath JTree.getEditingPath​()
      返回当前正在编辑的元素的路径。
      Component JTable.getEditorComponent​()
      返回处理编辑会话的组件。
      int JList.getFirstVisibleIndex​()
      返回当前可见的最小列表索引。
      Container JInternalFrame.getFocusCycleRootAncestor​()
      始终返回 null因为 JInternalFrame必须始终是焦点遍历循环的根。
      JFormattedTextField.AbstractFormatter JFormattedTextField.getFormatter​()
      返回用于格式化和解析当前值的 AbstractFormatter 。
      Graphics JApplet.getGraphics​()
      已过时。
      为此组件创建图形上下文。
      Graphics JComponent.getGraphics​()
      返回此组件的图形上下文，可用于绘制组件。
      Graphics JDialog.getGraphics​()
      为此组件创建图形上下文。
      Graphics JFrame.getGraphics​()
      为此组件创建图形上下文。
      Graphics JWindow.getGraphics​()
      为此组件创建图形上下文。
      int JComponent.getHeight​()
      返回此组件的当前高度。
      BoundedRangeModel JTextField.getHorizontalVisibility​()
      获取文本字段的可见性。
      HyperlinkListener[] JEditorPane.getHyperlinkListeners​()
      返回使用addHyperlinkListener（）添加到此JEditorPane的所有 HyperLinkListener的数组。
      MutableAttributeSet JTextPane.getInputAttributes​()
      获取窗格的输入属性。
      Insets JComponent.getInsets​()
      如果在此组件上设置了边框，则返回边框的插入; 否则拨打super.getInsets 。
      Insets JViewport.getInsets​(Insets insets)
      返回一个 Insets对象，其中包含这个 JViewport的插入值。
      InternalFrameListener[] JInternalFrame.getInternalFrameListeners​()
      返回所有 InternalFrameListener的数组添加到这个 JInternalFrame与 addInternalFrameListener 。
      int JComboBox.getItemCount​()
      返回列表中的项目数。
      int JMenu.getItemCount​()
      返回菜单上的项目数，包括分隔符。
      ItemListener[] AbstractButton.getItemListeners​()
      返回使用addItemListener（）添加到此AbstractButton的所有 ItemListener的数组。
      ItemListener[] JComboBox.getItemListeners​()
      返回使用addItemListener（）添加到此JComboBox的所有 ItemListener的数组。
      Cursor JInternalFrame.getLastCursor​()
      返回由 setCursor方法设置的最后一个 Cursor ，该方法不是可调整大小的 Cursor 。
      Object JTree.getLastSelectedPathComponent​()
      返回所选路径的最后一个路径组件。
      int JList.getLastVisibleIndex​()
      返回当前可见的最大列表索引。
      int JList.getLeadSelectionIndex​()
      返回引导选择索引。
      int JTree.getLeadSelectionRow​()
      返回与引导路径对应的行索引。
      Component JSplitPane.getLeftComponent​()
      将分量返回到左侧（或上方）。
      int JTextArea.getLineCount​()
      确定该区域中包含的行数。
      ListSelectionListener[] JList.getListSelectionListeners​()
      返回所有的数组 ListSelectionListener加入到这个S JList途经 addListSelectionListener 。
      Insets JPopupMenu.getMargin​()
      返回弹出菜单的边框和容器之间的边距（以像素为单位）。
      int JOptionPane.getMaxCharactersPerLineCount​()
      返回在消息中放置在行上的最大字符数。
      int JSplitPane.getMaximumDividerLocation​()
      从外观实现中返回分隔符的最大位置。
      int JList.getMaxSelectionIndex​()
      返回最大的所选单元 -1引，如果选择为空，则返回 -1 。
      int JTree.getMaxSelectionRow​()
      返回最大的选定行。
      int JMenu.getMenuComponentCount​()
      返回菜单上的组件数。
      Component[] JMenu.getMenuComponents​()
      返回菜单的子组件的 Component的数组。
      int JMenuBar.getMenuCount​()
      返回菜单栏中的项目数。
      MenuDragMouseListener[] JMenuItem.getMenuDragMouseListeners​()
      返回使用addMenuDragMouseListener（）添加到此JMenuItem的所有 MenuDragMouseListener的数组。
      MenuKeyListener[] JMenuItem.getMenuKeyListeners​()
      返回使用addMenuKeyListener（）添加到此JMenuItem中的所有 MenuKeyListener的数组。
      MenuKeyListener[] JPopupMenu.getMenuKeyListeners​()
      返回使用addMenuKeyListener（）添加到此JPopupMenu的所有 MenuKeyListener的数组。
      MenuListener[] JMenu.getMenuListeners​()
      返回使用addMenuListener（）添加到此JMenu的所有 MenuListener的数组。
      int JSplitPane.getMinimumDividerLocation​()
      从外观实现中返回分隔符的最小位置。
      int JList.getMinSelectionIndex​()
      返回最小选择的单元 -1引，如果选择为空，则返回 -1 。
      int JTree.getMinSelectionRow​()
      返回最小的选定行。
      Component JInternalFrame.getMostRecentFocusOwner​()
      返回此 JInternalFrame的子组件，当选择此 JInternalFrame时，该组件将接收焦点。
      Object JSpinner.getNextValue​()
      返回 getValue()返回的对象后面的序列中的对象。
      AttributeSet JTextPane.getParagraphAttributes​()
      获取当前段落属性在插入符号的位置，如果没有， null 。
      char[] JPasswordField.getPassword​()
      返回此 TextComponent包含的文本。
      TreePath JTree.getPathForRow​(int row)
      返回指定行的路径。
      double JProgressBar.getPercentComplete​()
      返回进度条的完成百分比。
      JPopupMenu JMenu.getPopupMenu​()
      返回与此菜单关联的弹出菜单。
      PopupMenuListener[] JComboBox.getPopupMenuListeners​()
      返回使用addPopupMenuListener（）添加到此JComboBox的所有 PopupMenuListener的数组。
      PopupMenuListener[] JPopupMenu.getPopupMenuListeners​()
      返回使用addPopupMenuListener（）添加到此JMenuItem的所有 PopupMenuListener的数组。
      Dimension JList.getPreferredScrollableViewportSize​()
      计算显示 visibleRowCount行所需的视口大小。
      Dimension JTextArea.getPreferredScrollableViewportSize​()
      如果此组件嵌入在JScrollPane中，则返回视口的首选大小。
      Dimension JTree.getPreferredScrollableViewportSize​()
      返回 JTree的首选显示大小。
      Object JSpinner.getPreviousValue​()
      返回 getValue()返回的对象之前的序列中的对象。
      KeyStroke[] JComponent.getRegisteredKeyStrokes​()
      返回将启动注册操作的 KeyStrokes 。
      JRootPane JApplet.getRootPane​()
      已过时。
      返回此applet的rootPane对象。
      JRootPane JComponent.getRootPane​()
      返回此组件的 JRootPane祖先。
      JRootPane JDialog.getRootPane​()
      返回此对话框的 rootPane对象。
      JRootPane JFrame.getRootPane​()
      返回此框架的 rootPane对象。
      JRootPane JInternalFrame.getRootPane​()
      返回此内部框架的 rootPane对象。
      JRootPane JWindow.getRootPane​()
      返回此窗口的 rootPane对象。
      int JTable.getRowCount​()
      返回可以在 JTable显示的行数，给定无限制空间。
      int JTree.getRowCount​()
      返回可见节点的数量。
      boolean JEditorPane.getScrollableTracksViewportHeight​()
      如果视口应始终强制此 Scrollable的高度与视口的高度相匹配，则返回true。
      boolean JList.getScrollableTracksViewportHeight​()
      返回true如果JList显示在JViewport和视口比列表的首选高度更高，或者布局方向为VERTICAL_WRAP和visibleRowCount <= 0 ; 否则返回false 。
      boolean JTable.getScrollableTracksViewportHeight​()
      返回 false以表示视口的高度不会确定表的高度，除非 getFillsViewportHeight为 true并且表的首选高度小于视口的高度。
      boolean JTree.getScrollableTracksViewportHeight​()
      返回false以指示视口的高度不会确定表的高度，除非树的首选高度小于视口高度。
      boolean JEditorPane.getScrollableTracksViewportWidth​()
      如果视口应始终强制此 Scrollable的宽度与视口宽度匹配，则返回true。
      boolean JList.getScrollableTracksViewportWidth​()
      返回true ，如果这JList显示在JViewport和视口比所述列表的优选宽度，或者如果布局方向为HORIZONTAL_WRAP和visibleRowCount <= 0 ; 否则返回false 。
      boolean JTable.getScrollableTracksViewportWidth​()
      如果 autoResizeMode设置为 AUTO_RESIZE_OFF ，则返回false，这表示视口的宽度不会确定表的宽度。
      boolean JTextArea.getScrollableTracksViewportWidth​()
      如果视口应始终强制此Scrollable的宽度与视口的宽度相匹配，则返回true。
      boolean JTree.getScrollableTracksViewportWidth​()
      返回false以指示视口的宽度不会确定表的宽度，除非树的首选宽度小于视口宽度。
      int JTable.getSelectedColumn​()
      返回第一个选定列的索引，如果未选择列，则返回-1。
      int JTable.getSelectedColumnCount​()
      返回所选列的数量。
      int[] JTable.getSelectedColumns​()
      返回所有列的索引。
      Object[] AbstractButton.getSelectedObjects​()
      如果没有选择该按钮，则返回一个包含标签的数组（长度为1）或 null 。
      Object[] JCheckBoxMenuItem.getSelectedObjects​()
      返回一个包含复选框菜单项标签的数组（长度1），如果未选中该复选框，则返回null。
      Object[] JComboBox.getSelectedObjects​()
      返回一个包含所选项目的数组。
      int JTable.getSelectedRow​()
      返回第一个选定行的索引，如果没有选择行，则返回-1。
      int JTable.getSelectedRowCount​()
      返回所选行的数量。
      int[] JTable.getSelectedRows​()
      返回所有选定行的索引。
      E JList.getSelectedValue​()
      返回最小选定单元索引的值; 在列表中仅选择单个项目时的选定值 。
      Object[] JList.getSelectedValues​()
      已过时。
      截至JDK 1.7，由JList.getSelectedValuesList()替代
      List<E> JList.getSelectedValuesList​()
      根据列表中的索引，按照增加的顺序返回所有选定项目的列表。
      int JTree.getSelectionCount​()
      返回所选节点数。
      MenuElement[] JMenu.getSubElements​()
      返回包含此菜单组件子菜单的 MenuElement的数组。
      MenuElement[] JMenuBar.getSubElements​()
      实现为 MenuElement - 返回此菜单栏中的菜单。
      MenuElement[] JMenuItem.getSubElements​()
      此方法返回一个包含此菜单组件的子菜单组件的数组。
      MenuElement[] JPopupMenu.getSubElements​()
      返回一个包含此菜单组件子菜单的 MenuElement的数组。
      int JTabbedPane.getTabCount​()
      返回此 tabbedpane的选项卡数。
      int JTabbedPane.getTabRunCount​()
      返回当前用于显示选项卡的选项卡运行次数。
      Container JComponent.getTopLevelAncestor​()
      返回此组件的顶级祖先（包含 Window或 Applet ），如果此组件尚未添加到任何容器，则 null 。
      TreeExpansionListener[] JTree.getTreeExpansionListeners​()
      返回使用addTreeExpansionListener（）添加到此JTree的所有 TreeExpansionListener的数组。
      TreeSelectionListener[] JTree.getTreeSelectionListeners​()
      返回使用addTreeSelectionListener（）添加到此JTree的所有 TreeSelectionListener的数组。
      TreeWillExpandListener[] JTree.getTreeWillExpandListeners​()
      返回使用addTreeWillExpandListener（）添加到此JTree的所有 TreeWillExpandListener的数组。
      FileChooserUI JFileChooser.getUI​()
      获取实现此组件的L＆F的UI对象。
      ScrollPaneUI JScrollPane.getUI​()
      返回渲染此组件的外观和感觉（L＆F）对象。
      SplitPaneUI JSplitPane.getUI​()
      返回提供当前外观的 SplitPaneUI 。
      String JButton.getUIClassID​()
      返回一个字符串，它指定呈现此组件的L＆F类的名称。
      String JCheckBox.getUIClassID​()
      返回一个字符串，它指定呈现此组件的L＆F类的名称。
      String JCheckBoxMenuItem.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JColorChooser.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JComboBox.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JComponent.getUIClassID​()
      返回 UIDefaults键，用于查找定义该组件外观的 swing.plaf.ComponentUI类的名称。
      String JDesktopPane.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JEditorPane.getUIClassID​()
      获取UI的类ID。
      String JFileChooser.getUIClassID​()
      返回一个字符串，它指定呈现此组件的L＆F类的名称。
      String JFormattedTextField.getUIClassID​()
      获取UI的类ID。
      String JInternalFrame.getUIClassID​()
      返回呈现此组件的look-and-feel类的名称。
      String JLabel.getUIClassID​()
      返回一个字符串，指定呈现此组件的l＆f类的名称。
      String JList.getUIClassID​()
      返回 "ListUI" ，该 UIDefaults用于查找该名关键 javax.swing.plaf.ListUI类定义的外观和感觉这个组件。
      String JMenu.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JMenuBar.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JMenuItem.getUIClassID​()
      返回用于构造用于呈现此组件的L＆F类的名称的后缀。
      String JOptionPane.getUIClassID​()
      返回实现该组件的L＆F的UI类的名称。
      String JPanel.getUIClassID​()
      返回一个字符串，它指定呈现此组件的L＆F类的名称。
      String JPasswordField.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JPopupMenu.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JProgressBar.getUIClassID​()
      返回呈现此组件的look-and-feel类的名称。
      String JRadioButton.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JRadioButtonMenuItem.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JScrollBar.getUIClassID​()
      返回此组件的LookAndFeel类的名称。
      String JScrollPane.getUIClassID​()
      返回用于构造用于呈现此组件的L＆F类的名称的后缀。
      String JSeparator.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JSlider.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JSpinner.getUIClassID​()
      返回用于构造用于渲染此组件的外观（L＆F）类的名称的后缀。
      String JSplitPane.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JTabbedPane.getUIClassID​()
      返回实现该组件的L＆F的UI类的名称。
      String JTable.getUIClassID​()
      返回用于构造用于呈现此组件的L＆F类的名称的后缀。
      String JTextArea.getUIClassID​()
      返回UI的类ID。
      String JTextField.getUIClassID​()
      获取UI的类ID。
      String JTextPane.getUIClassID​()
      返回UI的类ID。
      String JToggleButton.getUIClassID​()
      返回一个字符串，指定呈现此组件的l＆f类的名称。
      String JToolBar.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      String JTree.getUIClassID​()
      返回呈现此组件的L＆F类的名称。
      VetoableChangeListener[] JComponent.getVetoableChangeListeners​()
      返回在此组件上注册的所有可变更改监听器的数组。
      Rectangle JScrollPane.getViewportBorderBounds​()
      返回视口边框的边界。
      Rectangle JComponent.getVisibleRect​()
      返回 Component的“可见矩形” - 该组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight())及其所有祖先的可见矩形的交集。
      String JInternalFrame.getWarningString​()
      获取与此内部框架一起显示的警告字符串。
      int JComponent.getWidth​()
      返回此组件的当前宽度。
      int JComponent.getX​()
      返回组件原点的当前x坐标。
      int JComponent.getY​()
      返回组件原点的当前y坐标。
      boolean JButton.isDefaultButton​()
      获取 defaultButton属性的值，如果是 true ，则表示此按钮是其 JRootPane的当前默认按钮。
      boolean JFileChooser.isDirectorySelectionEnabled​()
      方便电话确定目录是否可以根据当前的文件选择模式进行选择。
      boolean JTable.isEditing​()
      如果正在编辑单元格，则返回true。
      boolean JTree.isEditing​()
      如果正在编辑树，则返回true。
      boolean JFormattedTextField.isEditValid​()
      如果正在编辑的当前值有效，则返回true。
      boolean JFileChooser.isFileSelectionEnabled​()
      方便电话确定文件是否可以基于当前文件选择模式进行选择。
      boolean JTree.isFixedRowHeight​()
      如果每个显示行的高度是固定大小，则返回true。
      boolean JProgressBar.isIndeterminate​()
      返回 indeterminate属性的值。
      boolean JComponent.isManagingFocus​()
      已过时。
      截至1.4，由Component.setFocusTraversalKeys(int, Set)和Container.setFocusCycleRoot(boolean)取代。
      boolean JComponent.isOptimizedDrawingEnabled​()
      如果此组件贴图其子项，则返回true - 即，如果可以保证子项不会重叠。
      boolean JLayeredPane.isOptimizedDrawingEnabled​()
      如果窗格中的组件可以重叠，则返回false，这样使得优化的绘图不可能。
      boolean JComponent.isPaintingForPrint​()
      如果此组件上的当前绘画操作是 print操作的一部分，则返回 true 。
      boolean JComponent.isPaintingTile​()
      如果组件当前正在绘制图块，则返回true。
      boolean JMenuBar.isSelected​()
      如果菜单栏当前已选择一个组件，则返回true。
      boolean JList.isSelectionEmpty​()
      如果没有选择，则返回 true ，否则为 false 。
      boolean JTree.isSelectionEmpty​()
      如果选择当前为空，则返回true。
      boolean JMenu.isTearOff​()
      如果菜单被拆除，则返回true。
      boolean JMenu.isTopLevelMenu​()
      如果菜单是“顶级菜单”，则返回true，即如果它是菜单栏的直接子菜单。
      boolean JScrollPane.isValidateRoot​()
      重写以返回true，这样任何电话 revalidate这个的任何后代 JScrollPane会造成这个开始的整棵树 JScrollPane进行验证。
      boolean JSplitPane.isValidateRoot​()
      返回true，因此对此 revalidate的任何后代的 JSplitPane将导致请求排队，这将验证 JSplitPane及其所有后代。
      boolean JScrollPane.isWheelScrollingEnabled​()
      指示是否会响应于鼠标滚轮进行滚动。
      void JMenuItem.setAccelerator​(KeyStroke keyStroke)
      设置在不导航菜单层次结构的情况下调用菜单项的动作侦听器的组合键。
      void JFileChooser.setAcceptAllFileFilterUsed​(boolean b)
      确定 AcceptAll FileFilter是否用作可选择筛选器列表中的可用选项。
      void JFileChooser.setAccessory​(JComponent newAccessory)
      设置附件组件。
      void AbstractButton.setAction​(Action a)
      设置 Action 。
      void JComboBox.setAction​(Action a)
      设置 Action为 ActionEvent源。
      void JTextField.setAction​(Action a)
      设置 Action为 ActionEvent源。
      void JComponent.setAlignmentX​(float alignmentX)
      设置水平对齐。
      void JComponent.setAlignmentY​(float alignmentY)
      设置垂直对齐。
      void JTree.setAnchorSelectionPath​(TreePath newPath)
      设置标识为锚点的路径。
      void JFileChooser.setApproveButtonMnemonic​(int mnemonic)
      使用数字键码设置批准按钮的助记符。
      void JFileChooser.setApproveButtonText​(String approveButtonText)
      设置 ApproveButton中使用的文字 FileChooserUI 。
      void JFileChooser.setApproveButtonToolTipText​(String toolTipText)
      设置 ApproveButton使用的工具提示文本。
      void JMenuItem.setArmed​(boolean b)
      将菜单项标识为“布防”。
      void JTable.setAutoCreateColumnsFromModel​(boolean autoCreateColumnsFromModel)
      设置此表的 autoCreateColumnsFromModel标志。
      void JTable.setAutoCreateRowSorter​(boolean autoCreateRowSorter)
      指定是否应在表格中创建 RowSorter ，只要其型号发生更改。
      void JTable.setAutoResizeMode​(int mode)
      当表被调整大小时，设置表的自动调整大小模式。
      void JComponent.setAutoscrolls​(boolean autoscrolls)
      设置 autoscrolls属性。
      void JComponent.setBackground​(Color bg)
      设置此组件的背景颜色。
      void JTabbedPane.setBackgroundAt​(int index, Color background)
      将背景颜色设置为 index至 background ，可以为 null ，在这种情况下，标签的背景颜色将默认为 tabbedpane的背景颜色。
      void JScrollBar.setBlockIncrement​(int blockIncrement)
      设置blockIncrement属性。
      void JComponent.setBorder​(Border border)
      设置此组件的边框。
      void AbstractButton.setBorderPainted​(boolean b)
      设置 borderPainted属性。
      void JMenuBar.setBorderPainted​(boolean b)
      设置是否应绘制边框。
      void JPopupMenu.setBorderPainted​(boolean b)
      设置是否应绘制边框。
      void JProgressBar.setBorderPainted​(boolean b)
      设置 borderPainted属性，如果进度条应该绘制其边框，则为 true 。
      void JToolBar.setBorderPainted​(boolean b)
      设置 borderPainted属性，如果要绘制边框，则为 true 。
      void JCheckBox.setBorderPaintedFlat​(boolean b)
      设置 borderPaintedFlat属性，它提供了对复选框边框的外观的看法和感觉。
      void JSplitPane.setBottomComponent​(Component comp)
      设置下面的分量，或分配器的右侧。
      void JTable.setCellEditor​(TableCellEditor anEditor)
      设置活动单元格编辑器。
      void JTree.setCellEditor​(TreeCellEditor cellEditor)
      设置单元格编辑器。
      void JList.setCellRenderer​(ListCellRenderer<? super E> cellRenderer)
      设置用于绘制列表中每个单元格的委托。
      void JTree.setCellRenderer​(TreeCellRenderer x)
      设置将用于绘制每个单元格的 TreeCellRenderer 。
      void JTable.setCellSelectionEnabled​(boolean cellSelectionEnabled)
      设置此表是否同时允许列选择和行选择。
      void JColorChooser.setChooserPanels​(AbstractColorChooserPanel[] panels)
      指定用于选择颜色值的颜色面板。
      void JInternalFrame.setClosable​(boolean b)
      设置这个 JInternalFrame是否可以通过某些用户操作关闭。
      void JInternalFrame.setClosed​(boolean b)
      如果参数为 true则关闭此内部框架。
      void JColorChooser.setColor​(Color color)
      将颜色选择器的当前颜色设置为指定的颜色。
      void JScrollPane.setColumnHeader​(JViewport columnHeader)
      删除旧的columnHeader（如果存在） 如果新的columnHeader不是null ，则将其viewPosition的x坐标与视口同步（如果有），然后将其添加到滚动窗格。
      void JTable.setColumnModel​(TableColumnModel columnModel)
      将此表的列模型设置为 columnModel并从新列模型注册侦听器通知。
      void JTextArea.setColumns​(int columns)
      设置此TextArea的列数。
      void JTextField.setColumns​(int columns)
      设置此 TextField的列数，然后使布局无效。
      void JTable.setColumnSelectionAllowed​(boolean columnSelectionAllowed)
      设置是否可以选择此模型中的列。
      void JToolTip.setComponent​(JComponent c)
      指定工具提示描述的组件。
      void JTabbedPane.setComponentAt​(int index, Component component)
      将组件设置为 index至 component 。
      void JComponent.setComponentPopupMenu​(JPopupMenu popup)
      设置 JPopupMenu为这 JComponent 。
      void AbstractButton.setContentAreaFilled​(boolean b)
      设置 contentAreaFilled属性。
      void JApplet.setContentPane​(Container contentPane)
      已过时。
      设置contentPane属性。
      void JDialog.setContentPane​(Container contentPane)
      设置 contentPane属性。
      void JFrame.setContentPane​(Container contentPane)
      设置 contentPane属性。
      void JInternalFrame.setContentPane​(Container c)
      设置 JInternalFrame的 contentPane属性。
      void JWindow.setContentPane​(Container contentPane)
      设置此窗口的 contentPane属性。
      void JEditorPane.setContentType​(String type)
      设置此编辑器处理的内容类型。
      void JSplitPane.setContinuousLayout​(boolean newContinuousLayout)
      设置 continuousLayout属性的值，该属性必须为 true以便在用户干预期间不断重新显示和布局子组件。
      void JFileChooser.setControlButtonsAreShown​(boolean b)
      设置指示 批准和 取消按钮是否显示在文件选择器中的属性。
      void JFileChooser.setCurrentDirectory​(File dir)
      设置当前目录。
      void JComponent.setDebugGraphicsOptions​(int debugOptions)
      启用或禁用有关组件或其子项之间执行的每个图形操作的诊断信息。
      void JRootPane.setDefaultButton​(JButton defaultButton)
      设置 defaultButton属性，它确定此 JRootPane的当前默认按钮。
      void JButton.setDefaultCapable​(boolean defaultCapable)
      设置 defaultCapable属性，该属性决定此按钮是否可以作为其根窗格的默认按钮。
      void JDialog.setDefaultCloseOperation​(int operation)
      设置用户在此对话框上启动“关闭”时默认执行的操作。
      void JFrame.setDefaultCloseOperation​(int operation)
      设置用户在此框架上启动“关闭”时默认执行的操作。
      void JMenu.setDelay​(int d)
      在菜单的 PopupMenu弹出或关闭之前设置建议的延迟。
      void JInternalFrame.setDesktopIcon​(JInternalFrame.JDesktopIcon d)
      设置 JDesktopIcon与此 JInternalFrame关联。
      void JDesktopPane.setDesktopManager​(DesktopManager d)
      设置将处理桌面专用UI操作的 DesktopManger 。
      void JFileChooser.setDialogTitle​(String dialogTitle)
      设置 JFileChooser窗口标题栏中的字符串。
      void JFileChooser.setDialogType​(int dialogType)
      设置此对话框的类型。
      void AbstractButton.setDisabledIcon​(Icon disabledIcon)
      设置按钮的禁用图标。
      void JLabel.setDisabledIcon​(Icon disabledIcon)
      如果此JLabel为“禁用”（JLabel.setEnabled（false）），请设置要显示的图标。
      void JTabbedPane.setDisabledIconAt​(int index, Icon disabledIcon)
      将禁用图标设置为 index至 icon ，可以是 null 。
      void AbstractButton.setDisabledSelectedIcon​(Icon disabledSelectedIcon)
      设置按钮的禁用选择图标。
      void JLabel.setDisplayedMnemonic​(int key)
      指定一个指示助记键的键码。
      void AbstractButton.setDisplayedMnemonicIndex​(int index)
      提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。
      void JLabel.setDisplayedMnemonicIndex​(int index)
      提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。
      void JTabbedPane.setDisplayedMnemonicIndexAt​(int tabIndex, int mnemonicIndex)
      提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。
      void JSplitPane.setDividerLocation​(double proportionalLocation)
      将分隔符位置设置为 JSplitPane的大小的百分比。
      void JSplitPane.setDividerLocation​(int location)
      设置分频器的位置。
      void JSplitPane.setDividerSize​(int newSize)
      设置分频器的大小。
      void JFormattedTextField.setDocument​(Document doc)
      将编辑器与文本文档相关联。
      void JTextField.setDocument​(Document doc)
      将编辑器与文本文档相关联。
      void JColorChooser.setDragEnabled​(boolean b)
      设置 dragEnabled属性，该属性必须为 true以启用此组件上的自动拖放处理（第一部分拖放）。
      void JFileChooser.setDragEnabled​(boolean b)
      设置 dragEnabled属性，该属性必须为 true以启用此组件上的自动拖放处理（第一部分拖放）。
      void JList.setDragEnabled​(boolean b)
      打开或关闭自动拖动处理。
      void JTable.setDragEnabled​(boolean b)
      打开或关闭自动拖动处理。
      void JTree.setDragEnabled​(boolean b)
      打开或关闭自动拖动处理。
      void JDesktopPane.setDragMode​(int dragMode)
      设置桌面窗格使用的“拖动样式”。
      void JPasswordField.setEchoChar​(char c)
      设置此 JPasswordField的回波字符。
      void JComboBox.setEditable​(boolean aFlag)
      确定 JComboBox字段是否可编辑。
      void JTree.setEditable​(boolean flag)
      确定树是否可编辑。
      void JComboBox.setEditor​(ComboBoxEditor anEditor)
      设置用于在 JComboBox字段中绘制和编辑所选项目的编辑器。
      void JSpinner.setEditor​(JComponent editor)
      更改显示 JComponent的当前值的 SpinnerModel 。
      void JEditorPane.setEditorKit​(EditorKit kit)
      设置当前安装的工具包来处理内容。
      void JComboBox.setEnabled​(boolean b)
      启用组合框，以便可以选择项目。
      void JComponent.setEnabled​(boolean enabled)
      设置是否启用此组件。
      void JMenuItem.setEnabled​(boolean b)
      启用或禁用菜单项。
      void JTree.setExpandsSelectedPaths​(boolean newValue)
      配置 expandsSelectedPaths属性。
      void JSlider.setExtent​(int extent)
      通过旋钮设置“覆盖”范围的大小。
      void JFileChooser.setFileFilter​(FileFilter filter)
      设置当前文件过滤器。
      void JFileChooser.setFileHidingEnabled​(boolean b)
      设置文件隐藏打开或关闭。
      void JFileChooser.setFileSelectionMode​(int mode)
      设置 JFileChooser允许用户只需选择文件，只需选择目录，或选择文件和目录。
      void JFileChooser.setFileSystemView​(FileSystemView fsv)
      设置 JFileChooser用于访问和创建文件系统资源的文件系统视图，例如找到软盘驱动器并获取根驱动器列表。
      void JFileChooser.setFileView​(FileView fileView)
      设置用于检索UI信息的文件视图，例如表示文件的图标或文件的类型说明。
      void JTable.setFillsViewportHeight​(boolean fillsViewportHeight)
      设置此表是否总是足够大以填充封闭视口的高度。
      void JList.setFixedCellHeight​(int height)
      设置要用于列表中每个单元格的高度的固定值。
      void JList.setFixedCellWidth​(int width)
      设置要用于列表中每个单元格宽度的固定值。
      void JToolBar.setFloatable​(boolean b)
      设置 floatable属性，必须为 true才能使用户移动工具栏。
      void JFormattedTextField.setFocusLostBehavior​(int behavior)
      设置焦点丢失时的行为。
      void AbstractButton.setFocusPainted​(boolean b)
      设置 paintFocus属性，对于要绘制的焦点状态，属性必须为 true 。
      void JComponent.setFont​(Font font)
      设置此组件的字体。
      void JComponent.setForeground​(Color fg)
      设置此组件的前景颜色。
      void JTabbedPane.setForegroundAt​(int index, Color foreground)
      将前景颜色设置为 index至 foreground ，其中可以为 null ，在这种情况下，该选项卡的前景色将默认为此 tabbedpane的前景色。
      void JFormattedTextField.setFormatterFactory​(JFormattedTextField.AbstractFormatterFactory tf)
      设置 AbstractFormatterFactory 。
      void JInternalFrame.setFrameIcon​(Icon icon)
      设置要显示在该内部框架的标题栏中的图像（通常位于左上角）。
      void JApplet.setGlassPane​(Component glassPane)
      已过时。
      设置glassPane属性。
      void JDialog.setGlassPane​(Component glassPane)
      设置 glassPane属性。
      void JFrame.setGlassPane​(Component glassPane)
      设置 glassPane属性。
      void JInternalFrame.setGlassPane​(Component glass)
      设置这 JInternalFrame的 glassPane属性。
      void JWindow.setGlassPane​(Component glassPane)
      设置 glassPane属性。
      void JTable.setGridColor​(Color gridColor)
      将用于绘制网格线的颜色设置为 gridColor并重新显示。
      void AbstractButton.setHideActionText​(boolean hideActionText)
      设置 hideActionText属性，它决定按钮是否显示来自 Action文本。
      void AbstractButton.setHorizontalAlignment​(int alignment)
      设置图标和文字的水平对齐方式。
      void JLabel.setHorizontalAlignment​(int alignment)
      设置标签内容沿X轴的对齐方式。
      void JTextField.setHorizontalAlignment​(int alignment)
      设置文本的水平对齐方式。
      void JScrollPane.setHorizontalScrollBar​(JScrollBar horizontalScrollBar)
      将控制视口的水平视图位置的滚动条添加到滚动条。
      void JScrollPane.setHorizontalScrollBarPolicy​(int policy)
      确定水平滚动条何时出现在滚动条中。
      void AbstractButton.setHorizontalTextPosition​(int textPosition)
      设置文本相对于图标的水平位置。
      void JLabel.setHorizontalTextPosition​(int textPosition)
      设置标签文本相对于其图像的水平位置。
      void AbstractButton.setIcon​(Icon defaultIcon)
      设置按钮的默认图标。
      void JInternalFrame.setIcon​(boolean b)
      如果外观和感觉支持图标化，则可以对该内部框架进行图标化或去图标化。
      void JLabel.setIcon​(Icon icon)
      定义该组件将显示的图标。
      void JOptionPane.setIcon​(Icon newIcon)
      设置要显示的图标。
      void JTabbedPane.setIconAt​(int index, Icon icon)
      将图标设置为 index至 icon ，可以是 null 。
      void JInternalFrame.setIconifiable​(boolean b)
      设置 iconable属性，它必须是 true ，以便用户能够使 JInternalFrame成为一个图标。
      void AbstractButton.setIconTextGap​(int iconTextGap)
      如果设置了图标和文本属性，则此属性定义它们之间的空格。
      void JLabel.setIconTextGap​(int iconTextGap)
      如果设置了图标和文本属性，则此属性定义它们之间的空格。
      void JComponent.setInheritsPopupMenu​(boolean value)
      设置 getComponentPopupMenu是否应委托给父级，如果此组件没有分配给它的 JPopupMenu 。
      void JOptionPane.setInitialSelectionValue​(Object newValue)
      将最初显示为选定的输入值设置为用户。
      void JOptionPane.setInitialValue​(Object newInitialValue)
      设置要启用的初始值 - 最初显示窗格时具有焦点的 Component 。
      void JOptionPane.setInputValue​(Object newValue)
      设置用户选择或输入的输入值。
      void JComponent.setInputVerifier​(InputVerifier inputVerifier)
      设置此组件的输入验证器。
      void JTable.setIntercellSpacing​(Dimension intercellSpacing)
      设置 rowMargin和 columnMargin - 单元格之间的空间的高度和宽度 - intercellSpacing 。
      void JSlider.setInverted​(boolean b)
      指定true以反转滑块所显示的值范围，并将false设置为正常顺序的值范围。
      void JPopupMenu.setInvoker​(Component invoker)
      设置此弹出菜单的调用者 - 要显示弹出菜单菜单的组件。
      void JTree.setInvokesStopCellEditing​(boolean newValue)
      确定通过在树中选择另一个节点，树的数据更改或其他方法中断编辑时会发生什么。
      void JApplet.setJMenuBar​(JMenuBar menuBar)
      已过时。
      设置这个applet的菜单。
      void JDialog.setJMenuBar​(JMenuBar menu)
      设置此对话框的菜单栏。
      void JFrame.setJMenuBar​(JMenuBar menubar)
      设置此帧的菜单栏。
      void JInternalFrame.setJMenuBar​(JMenuBar m)
      设置 menuBar属性为 JInternalFrame 。
      void JComboBox.setKeySelectionManager​(JComboBox.KeySelectionManager aManager)
      设置将键盘字符转换为列表选择的对象。
      void AbstractButton.setLabel​(String label)
      已过时。
      - 替换为setText(text)
      void JPopupMenu.setLabel​(String label)
      设置弹出菜单的标签。
      void JLabel.setLabelFor​(Component c)
      设置标签的组件。
      void JSlider.setLabelTable​(Dictionary labels)
      用于指定在任何给定值下绘制什么标签。
      void JTree.setLargeModel​(boolean newValue)
      指定UI是否应该使用大型模型。
      void JSplitPane.setLastDividerLocation​(int newLastLocation)
      设置分频器的最后一个位置为 newLastLocation 。
      void JInternalFrame.setLayer​(int layer)
      设置此组件的图层属性的便利方法。
      void JInternalFrame.setLayer​(Integer layer)
      设置此组件的图层属性的便利方法。
      void JApplet.setLayeredPane​(JLayeredPane layeredPane)
      已过时。
      设置layeredPane属性。
      void JDialog.setLayeredPane​(JLayeredPane layeredPane)
      设置 layeredPane属性。
      void JFrame.setLayeredPane​(JLayeredPane layeredPane)
      设置 layeredPane属性。
      void JInternalFrame.setLayeredPane​(JLayeredPane layered)
      设置这 JInternalFrame的 layeredPane属性。
      void JWindow.setLayeredPane​(JLayeredPane layeredPane)
      设置 layeredPane属性。
      void JList.setLayoutOrientation​(int layoutOrientation)
      定义列表单元格的布局方式。
      void JTree.setLeadSelectionPath​(TreePath newPath)
      将路径标识为引导。
      void JComboBox.setLightWeightPopupEnabled​(boolean aFlag)
      设置 lightWeightPopupEnabled属性，其中提供了一个提示是否应使用轻量级 Component来包含 JComboBox ，而重量级 Component例如 Panel或 Window 。
      void JPopupMenu.setLightWeightPopupEnabled​(boolean aFlag)
      设置 lightWeightPopupEnabled属性的值，默认为 true 。
      void JTextArea.setLineWrap​(boolean wrap)
      设置文本区域的换行策略。
      void JPopupMenu.setLocation​(int x, int y)
      使用x，y坐标设置弹出菜单左上角的位置。
      void JSlider.setMajorTickSpacing​(int n)
      此方法设置主要的刻度间距。
      void AbstractButton.setMargin​(Insets m)
      在按钮的边框和标签之间设置边距空间。
      void JMenuBar.setMargin​(Insets m)
      设置菜单边界和菜单之间的边距。
      void JToolBar.setMargin​(Insets m)
      X- 200 X- 200 200 X- 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X- 200 200 X-
      void JInternalFrame.setMaximizable​(boolean b)
      设置 maximizable属性，它决定是否可以通过某些用户操作最大化 JInternalFrame 。
      void JInternalFrame.setMaximum​(boolean b)
      最大化和恢复这个内部框架。
      void JProgressBar.setMaximum​(int n)
      将进度条的最大值（存储在进度条的数据模型中）设置为 n 。
      void JScrollBar.setMaximum​(int maximum)
      设置模型的最大属性。
      void JSlider.setMaximum​(int maximum)
      将滑块的最大值设置为 maximum 。
      void JComboBox.setMaximumRowCount​(int count)
      设置 JComboBox显示的最大行数。
      void JComponent.setMaximumSize​(Dimension maximumSize)
      将此组件的最大大小设置为常量值。
      void JOptionPane.setMessage​(Object newMessage)
      设置选项窗格的消息对象。
      void JOptionPane.setMessageType​(int newType)
      设置选项窗格的消息类型。
      void JProgressBar.setMinimum​(int n)
      将进度条的最小值（存储在进度条的数据模型中）设置为 n 。
      void JScrollBar.setMinimum​(int minimum)
      设置模型的最小属性。
      void JSlider.setMinimum​(int minimum)
      将滑块的最小值设置为 minimum 。
      void JComponent.setMinimumSize​(Dimension minimumSize)
      将此组件的最小大小设置为常量值。
      void JSlider.setMinorTickSpacing​(int n)
      此方法设置较小的刻度间距。
      void AbstractButton.setMnemonic​(char mnemonic)
      这种方法现在已经过时了，请使用 setMnemonic(int)设置一个按钮的助记符。
      void AbstractButton.setMnemonic​(int mnemonic)
      在当前型号上设置键盘助记符。
      void JTabbedPane.setMnemonicAt​(int tabIndex, int mnemonic)
      设置用于访问指定选项卡的键盘助记符。
      void AbstractButton.setModel​(ButtonModel newModel)
      设置此按钮所代表的模型。
      void JComboBox.setModel​(ComboBoxModel<E> aModel)
      设置 JComboBox用于获取项目列表的数据模型。
      void JList.setModel​(ListModel<E> model)
      设置表示列表的内容或“值”的模型，通知属性更改侦听器，然后清除列表的选择。
      void JProgressBar.setModel​(BoundedRangeModel newModel)
      设置 JProgressBar使用的数据模型。
      void JScrollBar.setModel​(BoundedRangeModel newModel)
      设置处理滚动条的四个基本属性的模型：minimum，maximum，value，extent。
      void JSlider.setModel​(BoundedRangeModel newModel)
      设置 BoundedRangeModel处理滑块的三个基本属性：最小值，最大值，值。
      void JSpinner.setModel​(SpinnerModel model)
      更改表示此微调器值的模型。
      void JTabbedPane.setModel​(SingleSelectionModel model)
      设置要与此选项卡窗格一起使用的模型。
      void JTable.setModel​(TableModel dataModel)
      将该表的数据模型设置为 dataModel并将其注册为来自新数据模型的侦听器通知。
      void JTree.setModel​(TreeModel newModel)
      设置将提供数据的 TreeModel 。
      void JFileChooser.setMultiSelectionEnabled​(boolean b)
      设置文件选择器以允许多个文件选择。
      void JSplitPane.setOneTouchExpandable​(boolean newValue)
      设置 oneTouchExpandable属性的值，其 oneTouchExpandable true ，为 JSplitPane在分隔符上提供UI小部件，以快速扩展/折叠分频器。
      void JComponent.setOpaque​(boolean isOpaque)
      如果为真，组件将绘制其边界内的每个像素。
      void JOptionPane.setOptions​(Object[] newOptions)
      设置该窗格显示的选项。
      void JOptionPane.setOptionType​(int newType)
      设置要显示的选项。
      void JProgressBar.setOrientation​(int newOrientation)
      将进度条的方向设置为 newOrientation ，其值必须为 SwingConstants.VERTICAL或 SwingConstants.HORIZONTAL 。
      void JScrollBar.setOrientation​(int orientation)
      将滚动条的方向设置为VERTICAL或HORIZONTAL。
      void JSeparator.setOrientation​(int orientation)
      设置分隔符的方向。
      void JSlider.setOrientation​(int orientation)
      将滑块的方向设置为 SwingConstants.VERTICAL或 SwingConstants.HORIZONTAL 。
      void JSplitPane.setOrientation​(int orientation)
      设置方向，或分离器的分割方式。
      void JToolBar.setOrientation​(int o)
      设置工具栏的方向。
      void JEditorPane.setPage​(URL page)
      设置显示的当前URL。
      void JSlider.setPaintLabels​(boolean b)
      确定标签是否涂在滑块上。
      void JSlider.setPaintTicks​(boolean b)
      确定刻印标记是否在滑块上绘制。
      void JSlider.setPaintTrack​(boolean b)
      确定轨迹是否在滑块上绘制。
      void JMenu.setPopupMenuVisible​(boolean b)
      设置菜单弹出窗口的可见性。
      void JPopupMenu.setPopupSize​(int width, int height)
      将Popup窗口的大小设置为指定的宽度和高度。
      void JPopupMenu.setPopupSize​(Dimension d)
      使用 Dimension对象设置弹出窗口的大小。
      void JTable.setPreferredScrollableViewportSize​(Dimension size)
      设置此表的视口的首选大小。
      void JComponent.setPreferredSize​(Dimension preferredSize)
      设置此组件的首选大小。
      void AbstractButton.setPressedIcon​(Icon pressedIcon)
      设置按钮的按下图标。
      void JColorChooser.setPreviewPanel​(JComponent preview)
      设置当前预览面板。
      void JList.setPrototypeCellValue​(E prototypeCellValue)
      设置 prototypeCellValue属性，然后（如果新值为 non-null ），则通过从单元格渲染器请求单元格渲染器组件给定值（和索引0），并使用该组件的首选大小来计算 fixedCellWidth和 fixedCellHeight属性。
      void JComboBox.setPrototypeDisplayValue​(E prototypeDisplayValue)
      设置用于计算UI部分显示大小的原型显示值。
      void JComboBox.setRenderer​(ListCellRenderer<? super E> aRenderer)
      设置绘制列表项目的渲染器和从JComboBox字段中的列表中选择的项目。
      void JInternalFrame.setResizable​(boolean b)
      设置 JInternalFrame是否可以通过某些用户操作调整大小。
      void JSplitPane.setResizeWeight​(double value)
      指定当拆分窗格的大小更改时如何分配额外的空间。
      void JSplitPane.setRightComponent​(Component comp)
      将组件设置在右侧（或更低）分隔线。
      void JToolBar.setRollover​(boolean rollover)
      设置此工具栏的翻转状态。
      void AbstractButton.setRolloverEnabled​(boolean b)
      设置 rolloverEnabled属性，必须为 true才能发生翻转效果。
      void AbstractButton.setRolloverIcon​(Icon rolloverIcon)
      设置按钮的翻转图标。
      void AbstractButton.setRolloverSelectedIcon​(Icon rolloverSelectedIcon)
      设置按钮的滚动选择图标。
      protected void JApplet.setRootPaneCheckingEnabled​(boolean enabled)
      已过时。
      设置是否将 add和 setLayout电话转发到 contentPane 。
      protected void JDialog.setRootPaneCheckingEnabled​(boolean enabled)
      设置是否向 add转发到 add和 setLayout的 contentPane 。
      protected void JFrame.setRootPaneCheckingEnabled​(boolean enabled)
      设置是否向 add转发到 add和 setLayout的 contentPane 。
      protected void JInternalFrame.setRootPaneCheckingEnabled​(boolean enabled)
      设置是否将呼叫 add和 setLayout转发到 contentPane 。
      protected void JWindow.setRootPaneCheckingEnabled​(boolean enabled)
      设置是否向 add转发 add和 setLayout的 contentPane 。
      void JTree.setRootVisible​(boolean rootVisible)
      确定 TreeModel中的 TreeModel是否可见。
      void JScrollPane.setRowHeader​(JViewport rowHeader)
      删除旧的行阅读器（如果存在） 如果新的rowHeader不是null ，则将其viewPosition的y坐标与视口同步（如果有），然后将其添加到滚动窗格。
      void JTable.setRowHeight​(int rowHeight)
      将所有单元格的高度（以像素为单位）设置为 rowHeight ，重新验证和重绘。
      void JTable.setRowHeight​(int row, int rowHeight)
      将 row的高度设置为 rowHeight ，重新验证和重绘。
      void JTree.setRowHeight​(int rowHeight)
      设置每个单元格的高度（以像素为单位）。
      void JTable.setRowMargin​(int rowMargin)
      设置相邻行中的单元格之间的空白空间量。
      void JTextArea.setRows​(int rows)
      设置此TextArea的行数。
      void JTable.setRowSelectionAllowed​(boolean rowSelectionAllowed)
      设置是否可以选择此模型中的行。
      void JTable.setRowSorter​(RowSorter<? extends TableModel> sorter)
      设置 RowSorter 。
      void JViewport.setScrollMode​(int mode)
      用于控制滚动视口内容的方法。
      void JTree.setScrollsOnExpand​(boolean newValue)
      设置 scrollsOnExpand属性，它决定树是否可以滚动显示以前隐藏的子项。
      void JInternalFrame.setSelected​(boolean selected)
      如果显示内部框架，请选择或取消选择。
      void JMenu.setSelected​(boolean b)
      设置菜单的选择状态。
      void JPopupMenu.setSelected​(Component sel)
      设置当前选择的组件，这将导致选择模型的更改。
      void JTabbedPane.setSelectedComponent​(Component c)
      设置此选项卡窗格的选定组件。
      void JFileChooser.setSelectedFile​(File file)
      设置所选文件。
      void JFileChooser.setSelectedFiles​(File[] selectedFiles)
      如果文件选择器设置为允许多个选择，则设置所选文件的列表。
      void AbstractButton.setSelectedIcon​(Icon selectedIcon)
      设置按钮的选定图标。
      void JComboBox.setSelectedIndex​(int anIndex)
      选择索引号为 anIndex的项目。
      void JList.setSelectedIndex​(int index)
      选择单个单元格。
      void JTabbedPane.setSelectedIndex​(int index)
      设置此选项卡窗格的所选索引。
      void JComboBox.setSelectedItem​(Object anObject)
      将组合框显示区域中的选定项目设置为参数中的对象。
      void JList.setSelectionBackground​(Color selectionBackground)
      设置用于绘制所选项目背景的颜色，哪些单元格渲染器可以使用填充所选单元格。
      void JTable.setSelectionBackground​(Color selectionBackground)
      设置所选单元格的背景颜色。
      void JList.setSelectionForeground​(Color selectionForeground)
      设置用于绘制所选项目的前景的颜色，哪些单元格渲染器可用于渲染文本和图形。
      void JTable.setSelectionForeground​(Color selectionForeground)
      设置所选单元格的前景色。
      void JList.setSelectionMode​(int selectionMode)
      设置列表的选择模式。
      void JTable.setSelectionMode​(int selectionMode)
      将表的选择模式设置为仅允许单个选择，单个连续间隔或多个间隔。
      void JColorChooser.setSelectionModel​(ColorSelectionModel newModel)
      设置包含所选颜色的模型。
      void JList.setSelectionModel​(ListSelectionModel selectionModel)
      将该列表的 selectionModel设置为非 null ListSelectionModel实现。
      void JMenuBar.setSelectionModel​(SingleSelectionModel model)
      设置模型对象以处理单个选择。
      void JPopupMenu.setSelectionModel​(SingleSelectionModel model)
      设置模型对象以处理单个选择。
      void JTable.setSelectionModel​(ListSelectionModel selectionModel)
      将此表的行选择模型设置为 selectionModel并从新选择模型注册监听器通知。
      void JTree.setSelectionModel​(TreeSelectionModel selectionModel)
      设置树的选择模型。
      void JOptionPane.setSelectionValues​(Object[] newValues)
      设置为用户提供可供选择的项目列表的窗格的输入选择值。
      void JTable.setShowGrid​(boolean showGrid)
      设置表格是否在单元格周围绘制网格线。
      void JTable.setShowHorizontalLines​(boolean showHorizontalLines)
      设置表格是否在单元格之间绘制水平线。
      void JTree.setShowsRootHandles​(boolean newValue)
      设置 showsRootHandles属性的值，该属性指定是否显示节点句柄。
      void JTable.setShowVerticalLines​(boolean showVerticalLines)
      设置表格是否在单元格之间绘制垂直线。
      void JSlider.setSnapToTicks​(boolean b)
      指定true使旋钮（及其代表的数据值）解析为用户放置旋钮位置的最近刻度。
      void JCheckBoxMenuItem.setState​(boolean b)
      设置项目的选择状态。
      void JProgressBar.setString​(String s)
      设置进度字符串的值。
      void JProgressBar.setStringPainted​(boolean b)
      设置 stringPainted属性的值，该属性确定进度条是否应呈现进度字符串。
      void JTabbedPane.setTabComponentAt​(int index, Component component)
      设置负责渲染指定选项卡的标题的组件。
      void JTabbedPane.setTabLayoutPolicy​(int tabLayoutPolicy)
      设置当所有选项卡不适合单个运行时，选项卡窗格将用于布局选项卡的策略。
      void JTable.setTableHeader​(JTableHeader tableHeader)
      设置 tableHeader使用这个 JTable到 newHeader 。
      void JTabbedPane.setTabPlacement​(int tabPlacement)
      设置此标签页窗格的标签位置。
      void JTextArea.setTabSize​(int size)
      设置扩展标签的字符数。
      void AbstractButton.setText​(String text)
      设置按钮的文本。
      void JEditorPane.setText​(String t)
      将此 TextComponent的文本设置为指定的内容，预期其格式为此编辑器的内容类型。
      void JLabel.setText​(String text)
      定义该组件将显示的单行文本。
      void JToolTip.setTipText​(String tipText)
      设置显示工具提示时显示的文本。
      void JInternalFrame.setTitle​(String title)
      设置 JInternalFrame标题。
      void JTabbedPane.setTitleAt​(int index, String title)
      将标题设置为 index至 title ，其中可以为 null 。
      void JTree.setToggleClickCount​(int clickCount)
      设置节点将展开或关闭之前的鼠标点击次数。
      void JComponent.setToolTipText​(String text)
      注册文本以显示在工具提示。
      void JTabbedPane.setToolTipTextAt​(int index, String toolTipText)
      内置的工具提示文本 index至 toolTipText它可以是 null 。
      void JSplitPane.setTopComponent​(Component comp)
      设置上面的分量，或分隔线的左边。
      void JApplet.setTransferHandler​(TransferHandler newHandler)
      已过时。
      设置 transferHandler属性，这是一种支持将数据传输到此组件中的机制。
      void JComponent.setTransferHandler​(TransferHandler newHandler)
      设置 TransferHandler ，它支持通过剪切/复制/粘贴和拖放将数据传入和传出该组件。
      void JDialog.setTransferHandler​(TransferHandler newHandler)
      设置 transferHandler属性，这是一种支持将数据传输到此组件中的机制。
      void JFrame.setTransferHandler​(TransferHandler newHandler)
      设置 transferHandler属性，这是一种支持将数据传输到此组件的机制。
      void JWindow.setTransferHandler​(TransferHandler newHandler)
      设置 transferHandler属性，这是一种支持将数据传输到此组件的机制。
      void AbstractButton.setUI​(ButtonUI ui)
      设置渲染此组件的L＆F对象。
      void JColorChooser.setUI​(ColorChooserUI ui)
      设置渲染此组件的L＆F对象。
      void JComboBox.setUI​(ComboBoxUI ui)
      设置渲染此组件的L＆F对象。
      protected void JComponent.setUI​(ComponentUI newUI)
      设置该组件的外观和感觉委托。
      void JDesktopPane.setUI​(DesktopPaneUI ui)
      设置渲染此组件的L＆F对象。
      void JInternalFrame.setUI​(InternalFrameUI ui)
      设置这个 JInternalFrame的UI JInternalFrame 。
      void JLabel.setUI​(LabelUI ui)
      设置渲染此组件的L＆F对象。
      void JList.setUI​(ListUI ui)
      设置 ListUI ，呈现此组件的外观和感觉对象。
      void JMenuBar.setUI​(MenuBarUI ui)
      设置渲染此组件的L＆F对象。
      void JMenuItem.setUI​(MenuItemUI ui)
      设置呈现此组件的外观和对象。
      void JOptionPane.setUI​(OptionPaneUI ui)
      设置实现该组件的L＆F的UI对象。
      void JPanel.setUI​(PanelUI ui)
      设置渲染此组件的外观和感觉（L＆F）对象。
      void JPopupMenu.setUI​(PopupMenuUI ui)
      设置渲染此组件的L＆F对象。
      void JProgressBar.setUI​(ProgressBarUI ui)
      设置渲染此组件的外观和对象。
      void JRootPane.setUI​(RootPaneUI ui)
      设置渲染此组件的L＆F对象。
      void JScrollBar.setUI​(ScrollBarUI ui)
      设置渲染此组件的L＆F对象。
      void JSeparator.setUI​(SeparatorUI ui)
      设置渲染此组件的L＆F对象。
      void JSlider.setUI​(SliderUI ui)
      设置实现该组件的L＆F的UI对象。
      void JTabbedPane.setUI​(TabbedPaneUI ui)
      设置实现该组件的L＆F的UI对象。
      void JTable.setUI​(TableUI ui)
      设置渲染此组件并重新绘制的L＆F对象。
      void JToolBar.setUI​(ToolBarUI ui)
      设置渲染此组件的L＆F对象。
      void JTree.setUI​(TreeUI ui)
      设置渲染此组件的L＆F对象。
      void JViewport.setUI​(ViewportUI ui)
      设置渲染此组件的L＆F对象。
      void JScrollBar.setUnitIncrement​(int unitIncrement)
      设置unitIncrement属性。
      void JTable.setUpdateSelectionOnSort​(boolean update)
      指定选择是否应在排序后更新。
      void JFormattedTextField.setValue​(Object value)
      设置将通过被格式化的值 AbstractFormatter从当前获得的 AbstractFormatterFactory 。
      void JOptionPane.setValue​(Object newValue)
      设置用户选择的值。
      void JProgressBar.setValue​(int n)
      将进度条的当前值设置为 n 。
      void JScrollBar.setValue​(int value)
      设置滚动条的值。
      void JSlider.setValue​(int n)
      将滑块的当前值设置为 n 。
      void JScrollBar.setValueIsAdjusting​(boolean b)
      设置模型的valueIsAdjusting属性。
      void JSlider.setValueIsAdjusting​(boolean b)
      设置型号的 valueIsAdjusting属性。
      void JComponent.setVerifyInputWhenFocusTarget​(boolean verifyInputWhenFocusTarget)
      设置该值以指示在此组件请求焦点之前是否调用当前焦点所有者的输入验证器。
      void AbstractButton.setVerticalAlignment​(int alignment)
      设置图标和文本的垂直对齐方式。
      void JLabel.setVerticalAlignment​(int alignment)
      设置标签内容沿着Y轴的对齐方式。
      void JScrollPane.setVerticalScrollBar​(JScrollBar verticalScrollBar)
      将控制视口垂直视图位置的滚动条添加到滚动条。
      void JScrollPane.setVerticalScrollBarPolicy​(int policy)
      确定滚动条中何时出现垂直滚动条。
      void AbstractButton.setVerticalTextPosition​(int textPosition)
      设置文本相对于图标的垂直位置。
      void JLabel.setVerticalTextPosition​(int textPosition)
      设置标签文本相对于其图像的垂直位置。
      void JScrollPane.setViewport​(JViewport viewport)
      删除旧的视口（如果有的话）;
迫使新视口的观点位于+ x，+ y象限中;
使用新的视口同步行和列标题（如果有的话）;
最后使用新的视口同步滚动条和标题。
      void JScrollPane.setViewportBorder​(Border viewportBorder)
      在视口周围添加一个边框。
      void JComponent.setVisible​(boolean aFlag)
      使组件可见或不可见。
      void JPopupMenu.setVisible​(boolean b)
      设置弹出菜单的可见性。
      void JScrollBar.setVisibleAmount​(int extent)
      设置模型的扩展属性。
      void JList.setVisibleRowCount​(int visibleRowCount)
      设置visibleRowCount属性，具有不同的含义，具体取决于布局方向：对于VERTICAL布局方向，这将设置要显示的首选行数，而不需要滚动; 对于其他取向，它影响细胞的包裹。
      void JTree.setVisibleRowCount​(int newCount)
      设置要显示的行数。
      void JOptionPane.setWantsInput​(boolean newValue)
      设置 wantsInput属性。
      void JScrollPane.setWheelScrollingEnabled​(boolean handleWheel)
      启用/禁用滚动以响应鼠标滚轮的移动。
      void JRootPane.setWindowDecorationStyle​(int windowDecorationStyle)
      设置 JRootPane应该提供的窗口装饰类型（如边框，关闭窗口的小部件，标题...）。
      void JTextArea.setWrapStyleWord​(boolean word)
      如果文本区域是包装线，则设置使用的包装样式。

    • Uses of BeanProperty in javax.swing.colorchooser

      Methods in javax.swing.colorchooser with annotations of type BeanProperty
      Modifier and Type 方法 描述
      void AbstractColorChooserPanel.setColorTransparencySelectionEnabled​(boolean b)
      设置颜色选择器面板是否允许选择颜色的透明度（alpha值）。

    • Uses of BeanProperty in javax.swing.table

      Methods in javax.swing.table with annotations of type BeanProperty
      Modifier and Type 方法 描述
      void TableColumn.setCellEditor​(TableCellEditor cellEditor)
      设置编辑此列中的单元格时使用的编辑器。
      void TableColumn.setCellRenderer​(TableCellRenderer cellRenderer)
      设置 TableCellRenderer使用的 JTable绘制此列的各个值。
      void JTableHeader.setColumnModel​(TableColumnModel columnModel)
      将此表的列模型设置为 newModel并从新列模型注册侦听器通知。
      void TableColumn.setHeaderRenderer​(TableCellRenderer headerRenderer)
      设置 TableCellRenderer用来牵动 TableColumn的头 headerRenderer 。
      void TableColumn.setHeaderValue​(Object headerValue)
      将 Object的字符串表示形式用作 headerRenderer的值。
      void TableColumn.setIdentifier​(Object identifier)
      将 TableColumn的标识符设置为 anIdentifier 。
      void TableColumn.setMaxWidth​(int maxWidth)
      将 TableColumn的最大宽度设置为 maxWidth或者如果 maxWidth小于最小宽度，则设置为最小宽度。
      void TableColumn.setMinWidth​(int minWidth)
      将 TableColumn的最小宽度设置为 minWidth ，如有必要，请调整新的最小宽度，以确保0 <= minWidth <= maxWidth 。
      void TableColumn.setModelIndex​(int modelIndex)
      设置此列的模型索引。
      void TableColumn.setPreferredWidth​(int preferredWidth)
      将此列的首选宽度设置为 preferredWidth 。
      void JTableHeader.setReorderingAllowed​(boolean reorderingAllowed)
      设置用户是否可以拖动列标题来重新排列列。
      void TableColumn.setResizable​(boolean isResizable)
      设置是否可以调整此列的大小。
      void JTableHeader.setResizingAllowed​(boolean resizingAllowed)
      设置用户是否可以通过在标题之间拖动来调整列的大小。
      void JTableHeader.setTable​(JTable table)
      设置与此标题关联的表。
      void TableColumn.setWidth​(int width)
      该方法不应用于设置 JTable的列的宽度，而是使用 setPreferredWidth 。

    • Uses of BeanProperty in javax.swing.text

      Methods in javax.swing.text with annotations of type BeanProperty
      Modifier and Type | 方法 | 描述
      AccessibleContext JTextComponent.getAccessibleContext​()
      获取 AccessibleContext与此 JTextComponent相关联。
      Action[] JTextComponent.getActions​()
      获取编辑器的命令列表。
      CaretListener[] JTextComponent.getCaretListeners​()
      返回在此文本组件上注册的所有插入符号侦听器的数组。
      JTextComponent.DropLocation JTextComponent.getDropLocation​()
      返回在组件的DnD操作期间该组件应该可视地指示为放置位置的位置，如果没有显示当前位置，则返回 null 。
      InputMethodRequests | JTextComponent.getInputMethodRequests​()
      Dimension JTextComponent.getPreferredScrollableViewportSize​()
      返回视图组件的视口的首选大小。
      boolean JTextComponent.getScrollableTracksViewportHeight​()
      如果视口应始终强制此 Scrollable的高度与视口的高度相匹配，则返回true。
      boolean JTextComponent.getScrollableTracksViewportWidth​()
      如果视口应始终强制此 Scrollable的宽度与视口的宽度相匹配，则返回true。
      String JTextComponent.getSelectedText​()
      返回此 TextComponent包含的选定文本。
      void JTextComponent.setCaret​(Caret c)
      设置要使用的插入符号。
      void JTextComponent.setCaretColor​(Color c)
      设置用于渲染插入符号的当前颜色。
      void JTextComponent.setCaretPosition​(int position)
      设置 TextComponent的文本插入插入符的 TextComponent 。
      void JTextComponent.setDisabledTextColor​(Color c)
      设置用于呈现禁用的文本的当前颜色。
      void JTextComponent.setDocument​(Document doc)
      将编辑器与文本文档相关联。
      void JTextComponent.setDragEnabled​(boolean b)
      打开或关闭自动拖动处理。
      void JTextComponent.setEditable​(boolean b)
      设置指定的布尔值以指示此 TextComponent是否可编辑。
      void JTextComponent.setFocusAccelerator​(char aKey)
      设置将导致接收文本组件获得焦点的关键加速器。
      void JTextComponent.setHighlighter​(Highlighter h)
      设置要使用的荧光笔。
      void JTextComponent.setKeymap​(Keymap map)
      设置用于将事件绑定到操作的键盘映射。
      void JTextComponent.setMargin​(Insets m)
      在文本组件的边框和文本之间设置边距空间。
      void JTextComponent.setSelectedTextColor​(Color c)
      设置用于渲染所选文本的当前颜色。
      void JTextComponent.setSelectionColor​(Color c)
      设置用于渲染选择的当前颜色。
      void JTextComponent.setSelectionEnd​(int selectionEnd)
      将选择结束设置为指定位置。
      void JTextComponent.setSelectionStart​(int selectionStart)
      将选择开始设置为指定位置。
      void JTextComponent.setText​(String t)
      将此 TextComponent的文本设置为指定的文本。

    • Uses of BeanProperty in javax.swing.tree

      Methods in javax.swing.tree with annotations of type BeanProperty
      Modifier and Type 方法 描述
      void DefaultTreeCellEditor.DefaultTextField.setBorder​(Border border)
      设置此组件的边框。
      void VariableHeightLayoutCache.setModel​(TreeModel newModel)
      设置将提供数据的 TreeModel 。
      void AbstractLayoutCache.setRootVisible​(boolean rootVisible)
      确定 TreeModel中的 TreeModel是否可见。
      void VariableHeightLayoutCache.setRootVisible​(boolean rootVisible)
      确定来自 TreeModel是否可见。
      void AbstractLayoutCache.setRowHeight​(int rowHeight)
      设置每个单元格的高度。
      void VariableHeightLayoutCache.setRowHeight​(int rowHeight)
      设置每个单元格的高度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.Beans (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.Beans

No usage of java.beans.Beans
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.ConstructorProperties (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.ConstructorProperties

  • Packages that use ConstructorProperties
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of ConstructorProperties in java.awt

      Constructors in java.awt with annotations of type ConstructorProperties
      Constructor 描述
      BasicStroke​(float width, int cap, int join, float miterlimit, float[] dash, float dash_phase)
      构造具有指定属性的新的 BasicStroke 。
      Color​(int r, int g, int b, int a)
      在范围（0 - 255）范围内创建指定的红，绿，蓝和阿尔法值的sRGB颜色。
      Cursor​(int type)
      创建一个指定类型的新的游标对象。
      GradientPaint​(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
      根据 boolean参数构造循环或非循环 GradientPaint对象。
      LinearGradientPaint​(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 LinearGradientPaint 。
      RadialGradientPaint​(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
      构造一个 RadialGradientPaint 。
      ScrollPane​(int scrollbarDisplayPolicy)
      创建一个新的scrollpane容器。

    • Uses of ConstructorProperties in java.awt.geom

      Constructors in java.awt.geom with annotations of type ConstructorProperties
      Constructor 描述
      AffineTransform​(float m00, float m10, float m01, float m11, float m02, float m12)
      从6个浮点值构造新的 AffineTransform ，表示3x3转换矩阵的6个可指定条目。

    • Uses of ConstructorProperties in java.beans

      Constructors in java.beans with annotations of type ConstructorProperties
      Constructor 描述
      EventHandler​(Object target, String action, String eventPropertyName, String listenerMethodName)
      创建一个新的EventHandler对象; 你通常使用一个create方法，而不是直接调用这个构造函数。
      Expression​(Object target, String methodName, Object[] arguments)
      为指定的目标对象创建一个新的Expression对象，以调用由名称和参数数组指定的方法。
      Statement​(Object target, String methodName, Object[] arguments)
      为指定的目标对象创建一个新的Statement对象，以调用由名称和参数数组指定的方法。

    • Uses of ConstructorProperties in javax.swing

      Constructors in javax.swing with annotations of type ConstructorProperties
      Constructor 描述
      BoxLayout​(Container target, int axis)
      创建一个布局管理器，它将沿着给定的轴布局组件。
      DefaultCellEditor​(JTextField textField)
      构造一个使用文本字段的 DefaultCellEditor 。
      Filler​(Dimension min, Dimension pref, Dimension max)
      创建具有给定大小范围的形状的构造函数。
      ImageIcon​(String filename)
      从指定的文件创建一个ImageIcon。
      JButton​(String text)
      创建一个带文本的按钮。
      JSplitPane​(int newOrientation)
      创建一个新的配置为 JSplitPane的方向。
      JTree​(TreeModel newModel)
      返回显示根节点的 JTree的实例 - 使用指定的数据模型创建树。
      OverlayLayout​(Container target)
      构建一个布局管理器，执行子项的覆盖排列。

    • Uses of ConstructorProperties in javax.swing.border

      Constructors in javax.swing.border with annotations of type ConstructorProperties
      Constructor 描述
      BevelBorder​(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
      创建具有指定类型，高亮和阴影颜色的斜角边框。
      CompoundBorder​(Border outsideBorder, Border insideBorder)
      用指定的外部和内部边框创建复合边框。
      EmptyBorder​(Insets borderInsets)
      使用指定的插图创建空白边框。
      EtchedBorder​(int etchType, Color highlight, Color shadow)
      使用指定的蚀刻类型，高光和阴影颜色创建蚀刻边框。
      LineBorder​(Color color, int thickness, boolean roundedCorners)
      创建具有指定颜色，粗细和拐角形状的线条边框。
      SoftBevelBorder​(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
      创建具有指定类型的斜角边框，突出显示阴影颜色。
      StrokeBorder​(BasicStroke stroke, Paint paint)
      创建指定的 stroke和 paint 。
      TitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      创建带有指定边框，标题，标题对齐，标题位置，标题字体和标题颜色的TitledBorder实例。

    • Uses of ConstructorProperties in javax.swing.plaf

      Constructors in javax.swing.plaf with annotations of type ConstructorProperties
      Constructor 描述
      BevelBorderUIResource​(int bevelType, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      构造一个 BevelBorderUIResource 。
      ColorUIResource​(int r, int g, int b)
      构造一个 ColorUIResource 。
      CompoundBorderUIResource​(Border outsideBorder, Border insideBorder)
      构造一个 CompoundBorderUIResource 。
      EmptyBorderUIResource​(Insets insets)
      构造一个 EmptyBorderUIResource 。
      EtchedBorderUIResource​(int etchType, Color highlight, Color shadow)
      构造一个 EtchedBorderUIResource 。
      LineBorderUIResource​(Color color, int thickness)
      构造一个 LineBorderUIResource 。
      TitledBorderUIResource​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      构造一个 TitledBorderUIResource 。

    • Uses of ConstructorProperties in javax.swing.tree

      Constructors in javax.swing.tree with annotations of type ConstructorProperties
      Constructor 描述
      DefaultTreeModel​(TreeNode root)
      创建一个树，其中任何节点可以拥有子节点。
      TreePath​(Object[] path)
      Creates a TreePath from an array.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.DefaultPersistenceDelegate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.DefaultPersistenceDelegate

No usage of java.beans.DefaultPersistenceDelegate
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.Encoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.Encoder

  • Packages that use Encoder
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of Encoder in java.beans

      Subclasses of Encoder in java.beans
      Modifier and Type Class 描述
      class  XMLEncoder
      所述 XMLEncoder类是互补替代 ObjectOutputStream ，并且可以用于产生以相同的方式，该一个 JavaBean的文本表示 ObjectOutputStream可以用来创建的二进制表示 Serializable对象。
      Methods in java.beans with parameters of type Encoder
      Modifier and Type 方法 描述
      protected void DefaultPersistenceDelegate.initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
      这个 initialize方法的默认实现假定这个类型对象中的所有状态都是通过匹配的“setter”和“getter”方法按Introspector返回的顺序公开的。
      protected void PersistenceDelegate.initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
      对 newInstance生成一系列具有副作用的语句，使新实例变为 等同于 oldInstance 。
      protected Expression DefaultPersistenceDelegate.instantiate​(Object oldInstance, Encoder out)
      instantiate方法的此默认实现将返回一个表达式，其中包含预定义方法名“new”，表示对具有 DefaultPersistenceDelegate构造函数中指定的参数的构造函数的调用。
      protected abstract Expression PersistenceDelegate.instantiate​(Object oldInstance, Encoder out)
      返回值为 oldInstance的表达式。
      void PersistenceDelegate.writeObject​(Object oldInstance, Encoder out)
      The writeObject is a single entry point to the persistence and is used by an Encoder in the traditional mode of delegation.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.EventHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.EventHandler

No usage of java.beans.EventHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.EventSetDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.EventSetDescriptor

  • Packages that use EventSetDescriptor
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of EventSetDescriptor in java.beans

      Methods in java.beans that return EventSetDescriptor
      Modifier and Type 方法 描述
      EventSetDescriptor[] BeanInfo.getEventSetDescriptors​()
      返回bean定义此bean触发的事件类型的事件描述符。
      EventSetDescriptor[] SimpleBeanInfo.getEventSetDescriptors​()
      否认事件集的知识。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.Expression (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.Expression

  • Packages that use Expression
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of Expression in java.beans

      Methods in java.beans that return Expression
      Modifier and Type 方法 描述
      protected Expression DefaultPersistenceDelegate.instantiate​(Object oldInstance, Encoder out)
      instantiate方法的此默认实现将返回一个表达式，其中包含预定义方法名“new”，表示使用 DefaultPersistenceDelegate的构造函数中指定的参数对构造函数进行调用。
      protected abstract Expression PersistenceDelegate.instantiate​(Object oldInstance, Encoder out)
      返回值为 oldInstance的表达式。
      Methods in java.beans with parameters of type Expression
      Modifier and Type 方法 描述
      void Encoder.writeExpression​(Expression oldExp)
      该实现首先检查是否已经写入了具有该值的表达式。
      void XMLEncoder.writeExpression​(Expression oldExp)
      记录表达式，以便当流被刷新时，编码器将产生实际的输出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.FeatureDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.FeatureDescriptor

  • Packages that use FeatureDescriptor
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of FeatureDescriptor in java.beans

      Subclasses of FeatureDescriptor in java.beans
      Modifier and Type Class 描述
      class  BeanDescriptor
      BeanDescriptor提供有关“bean”的全局信息，包括其Java类，其displayName等。
      class  EventSetDescriptor
      EventSetDescriptor描述给定的Java Bean触发的一组事件。
      class  IndexedPropertyDescriptor
      IndexedPropertyDescriptor描述了一个像数组一样的属性，并且具有索引的读取和/或索引的写入方法来访问数组的特定元素。
      class  MethodDescriptor
      MethodDescriptor描述了Java Bean支持的特定方法，用于从其他组件进行外部访问。
      class  ParameterDescriptor
      ParameterDescriptor类允许bean实现者提供关于每个参数的附加信息，超出java.lang.reflect.Method类提供的低级类型信息。
      class  PropertyDescriptor
      A PropertyDescriptor describes one property that a Java Bean exports via a pair of accessor methods.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.IndexedPropertyChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.IndexedPropertyChangeEvent

No usage of java.beans.IndexedPropertyChangeEvent
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.IndexedPropertyDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.IndexedPropertyDescriptor

No usage of java.beans.IndexedPropertyDescriptor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.IntrospectionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.IntrospectionException

  • Packages that use IntrospectionException
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of IntrospectionException in java.beans

      Methods in java.beans that throw IntrospectionException
      Modifier and Type 方法 描述
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass)
      内省Java Bean并了解其所有属性，暴露的方法和事件。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, int flags)
      对Java bean进行内省，并了解其所有属性，公开方法和事件，并遵守一些控制标志。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, Class<?> stopClass)
      内省Java bean并了解其属性，暴露的方法，低于给定的“停止”点。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, Class<?> stopClass, int flags)
      对Java Bean进行内省，并了解其所有属性，暴露的方法和事件，低于给定的 stopClass点，但需要进行一些控制 flags 。
      void IndexedPropertyDescriptor.setIndexedReadMethod​(方法 readMethod)
      设置应用于读取索引属性值的方法。
      void IndexedPropertyDescriptor.setIndexedWriteMethod​(方法 writeMethod)
      设置应用于编写索引属性值的方法。
      void PropertyDescriptor.setReadMethod​(方法 readMethod)
      设置应用于读取属性值的方法。
      void PropertyDescriptor.setWriteMethod​(方法 writeMethod)
      设置应用于写入属性值的方法。
      Constructors in java.beans that throw IntrospectionException
      Constructor 描述
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
      创建一个 EventSetDescriptor假设您遵循最简单的标准设计模式，其中一个命名事件“fred”（1）作为调用接口FredListener的方法传递，（2）具有类型为FredEvent的单个参数， 3）FredListener可以通过对源组件的addFredListener方法的调用进行注册，并通过removeFredListener方法的调用进行删除。
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
      使用字符串名称从头创建一个 EventSetDescriptor 。
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
      该构造函数使用字符串名称从头开始创建一个EventSetDescriptor。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, 方法 addListenerMethod, 方法 removeListenerMethod)
      使用 java.lang.reflect.MethodDescriptor和 java.lang.Class对象从头开始创建一个 EventSetDescriptor 。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod)
      使用 java.lang.reflect.Method和 java.lang.Class对象从零开始创建一个 EventSetDescriptor 。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod, 方法 getListenerMethod)
      此构造函数从头开始使用java.lang.reflect.Method和java.lang.Class对象创建一个EventSetDescriptor。
      IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass)
      该构造函数通过使用getFoo和setFoo访问器方法为索引访问和数组访问来构造遵循标准Java约定的属性的IndexedPropertyDescriptor。
      IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的方法名称，包括索引和非索引。
      IndexedPropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod, 方法 indexedReadMethod, 方法 indexedWriteMethod)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
      PropertyDescriptor​(String propertyName, Class<?> beanClass)
      通过使用getFoo和setFoo访问器方法，为遵循标准Java约定的属性构造PropertyDescriptor。
      PropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
      该构造函数使用简单属性的名称，以及读取和写入属性的方法名称。
      PropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.Introspector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.Introspector

No usage of java.beans.Introspector
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.JavaBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.JavaBean

  • Packages that use JavaBean
    软件包 描述
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of JavaBean in javax.accessibility

      Classes in javax.accessibility with annotations of type JavaBean
      Modifier and Type Class 描述
      class  AccessibleContext
      AccessibleContext表示所有可访问对象返回的最小信息。

    • Uses of JavaBean in javax.swing

      Classes in javax.swing with annotations of type JavaBean
      Modifier and Type Class 描述
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      class  JButton
      实现“推”按钮。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      class  JColorChooser
      JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      class  JComponent
      除顶级容器之外的所有Swing组件的基类。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      class  JDialog
      创建对话窗口的主要类。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      class  JFileChooser
      JFileChooser为用户提供了一种简单的机制来选择文件。
      class  JFormattedTextField
      JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑了文本，就检索了一个特定的对象。
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户选择 JMenuBar上的项目时 JMenuBar 。
      class  JMenuBar
      一个菜单栏的实现。
      class  JMenuItem
      菜单中项目的实现。
      class  JOptionPane
      JOptionPane可以方便地弹出一个标准对话框，提示用户获取值或通知他们某些东西。
      class  JPanel
      JPanel是一个通用的轻量级容器。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示已打字，但不显示原始字符。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      class  JScrollBar
      一个滚动条的实现。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      class  JSeparator
      JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  JSplitPane
      JSplitPane用于分割二（只有两个） Component s。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      class  JTextArea
      A JTextArea是显示纯文本的多行区域。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      class  JTree
      将一组分层数据显示为轮廓的控件。
      class  JWindow
      A JWindow是可以在用户桌面上的任意位置显示的容器。

    • Uses of JavaBean in javax.swing.text

      Classes in javax.swing.text with annotations of type JavaBean
      Modifier and Type Class 描述
      class  JTextComponent
      JTextComponent是摆动文本组件的基础类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.MethodDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.MethodDescriptor

  • Packages that use MethodDescriptor
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of MethodDescriptor in java.beans

      Methods in java.beans that return MethodDescriptor
      Modifier and Type 方法 描述
      MethodDescriptor[] EventSetDescriptor.getListenerMethodDescriptors​()
      获取目标监听器界面的 MethodDescriptor s。
      MethodDescriptor[] BeanInfo.getMethodDescriptors​()
      返回定义此bean支持的外部可见方法的bean的方法描述符。
      MethodDescriptor[] SimpleBeanInfo.getMethodDescriptors​()
      否认知识的方法。
      Constructors in java.beans with parameters of type MethodDescriptor
      Constructor 描述
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, 方法 addListenerMethod, 方法 removeListenerMethod)
      创建一个 EventSetDescriptor使用从无到有 java.lang.reflect.MethodDescriptor个 java.lang.Class对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.ParameterDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.ParameterDescriptor

  • Packages that use ParameterDescriptor
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of ParameterDescriptor in java.beans

      Methods in java.beans that return ParameterDescriptor
      Modifier and Type 方法 描述
      ParameterDescriptor[] MethodDescriptor.getParameterDescriptors​()
      获取每个此MethodDescriptor方法参数的ParameterDescriptor。
      Constructors in java.beans with parameters of type ParameterDescriptor
      Constructor 描述
      MethodDescriptor​(方法 method, ParameterDescriptor[] parameterDescriptors)
      从 方法构造一个 MethodDescriptor ，为每个方法的参数提供描述性信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PersistenceDelegate (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PersistenceDelegate

  • Packages that use PersistenceDelegate
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of PersistenceDelegate in java.beans

      Subclasses of PersistenceDelegate in java.beans
      Modifier and Type Class 描述
      class  DefaultPersistenceDelegate
      DefaultPersistenceDelegate是抽象的 PersistenceDelegate类的具体实现，默认情况下为不使用任何信息的类使用的委托。
      Methods in java.beans that return PersistenceDelegate
      Modifier and Type 方法 描述
      PersistenceDelegate Encoder.getPersistenceDelegate​(Class<?> type)
      返回给定类型的持久代理。
      Methods in java.beans with parameters of type PersistenceDelegate
      Modifier and Type 方法 描述
      void Encoder.setPersistenceDelegate​(Class<?> type, PersistenceDelegate delegate)
      将指定的持久性委托与给定类型关联。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PropertyChangeEvent (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PropertyChangeEvent

  • Packages that use PropertyChangeEvent
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。

    • Uses of PropertyChangeEvent in java.beans

      Subclasses of PropertyChangeEvent in java.beans
      Modifier and Type Class 描述
      class  IndexedPropertyChangeEvent
      只要符合JavaBeans¢规范（“bean”）的组件更改绑定的索引属性，就会传递“IndexedPropertyChange”事件。
      Methods in java.beans that return PropertyChangeEvent
      Modifier and Type 方法 描述
      PropertyChangeEvent PropertyVetoException.getPropertyChangeEvent​()
      获得否决的 PropertyChangeEvent 。
      Methods in java.beans with parameters of type PropertyChangeEvent
      Modifier and Type 方法 描述
      void PropertyChangeSupport.firePropertyChange​(PropertyChangeEvent event)
      将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
      void VetoableChangeSupport.fireVetoableChange​(PropertyChangeEvent event)
      将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
      void PropertyChangeListener.propertyChange​(PropertyChangeEvent evt)
      当绑定属性更改时，此方法将被调用。
      void PropertyChangeListenerProxy.propertyChange​(PropertyChangeEvent event)
      将属性更改事件转发给侦听器代理。
      void VetoableChangeListener.vetoableChange​(PropertyChangeEvent evt)
      当更改约束属性时调用此方法。
      void VetoableChangeListenerProxy.vetoableChange​(PropertyChangeEvent event)
      将属性更改事件转发给侦听器代理。
      Constructors in java.beans with parameters of type PropertyChangeEvent
      Constructor 描述
      PropertyVetoException​(String mess, PropertyChangeEvent evt)
      构造一个 PropertyVetoException的详细信息。

    • Uses of PropertyChangeEvent in java.beans.beancontext

      Methods in java.beans.beancontext with parameters of type PropertyChangeEvent
      Modifier and Type 方法 描述
      void BeanContextSupport.propertyChange​(PropertyChangeEvent pce)
      子类可以包围以监视子属性更改。
      void BeanContextSupport.vetoableChange​(PropertyChangeEvent pce)
      子类可以包围以监视否决权子变化。

    • Uses of PropertyChangeEvent in javax.swing

      Methods in javax.swing with parameters of type PropertyChangeEvent
      Modifier and Type 方法 描述
      void JLayer.propertyChange​(PropertyChangeEvent evt)
      当绑定属性更改时，此方法将被调用。
      void JList.AccessibleJList.propertyChange​(PropertyChangeEvent e)
      属性更改侦听器更改方法。
      void JPopupMenu.AccessibleJPopupMenu.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void JScrollPane.AccessibleJScrollPane.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void JSpinner.DefaultEditor.propertyChange​(PropertyChangeEvent e)
      称为 JFormattedTextField PropertyChangeListener 。
      void JTable.AccessibleJTable.propertyChange​(PropertyChangeEvent e)
      跟踪选择模型，列模型等的更改，以便能够将侦听器重新放置在那些上，以便将信息传递到辅助功能PropertyChange机制
      void ProgressMonitor.AccessibleProgressMonitor.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。

    • Uses of PropertyChangeEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type PropertyChangeEvent
      Modifier and Type 方法 描述
      void SwingPropertyChangeSupport.firePropertyChange​(PropertyChangeEvent evt)
      将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。

    • Uses of PropertyChangeEvent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type PropertyChangeEvent
      Modifier and Type 方法 描述
      void LayerUI.applyPropertyChange​(PropertyChangeEvent evt, JLayer<? extends V> l)
      通知 LayerUI当其任何属性被更改，并允许更新每 JLayer这个 LayerUI实例被设置。

    • Uses of PropertyChangeEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type PropertyChangeEvent
      Modifier and Type | 方法 | 描述
      void | BasicButtonListener.propertyChange​(PropertyChangeEvent e)
      void | BasicColorChooserUI.PropertyHandler.propertyChange​(PropertyChangeEvent e)
      void | BasicComboBoxUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      void | BasicComboPopup.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      void | BasicDirectoryModel.propertyChange​(PropertyChangeEvent e)
      protected void BasicEditorPaneUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      void | BasicInternalFrameTitlePane.PropertyChangeHandler.propertyChange​(PropertyChangeEvent evt)
      void BasicInternalFrameUI.InternalFramePropertyChangeListener.propertyChange​(PropertyChangeEvent evt)
      从JInternalFrame中检测状态的变化并处理动作。
      void | BasicLabelUI.propertyChange​(PropertyChangeEvent e)
      void | BasicListUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      void BasicOptionPaneUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      如果PropertyChangeEvent e的来源等于optionPane，并且是ICON_PROPERTY，MESSAGE_PROPERTY，OPTIONS_PROPERTY或INITIAL_VALUE_PROPERTY之一，则调用validateComponent。
      void BasicRootPaneUI.propertyChange​(PropertyChangeEvent e)
      在根窗格上更改属性时调用。
      void BasicScrollBarUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void BasicScrollPaneUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void BasicSliderUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void BasicSplitPaneDivider.propertyChange​(PropertyChangeEvent e)
      属性更改事件（可能来自JSplitPane）将在必要时发送updateOrientation消息。
      void BasicSplitPaneUI.PropertyHandler.propertyChange​(PropertyChangeEvent e)
      从 JSplitPane消息接收器中包含。
      void | BasicTabbedPaneUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent e)
      protected void BasicTextAreaUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      protected void BasicTextPaneUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      protected void BasicTextUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      void | BasicToolBarUI.PropertyListener.propertyChange​(PropertyChangeEvent e)
      void | BasicTreeUI.PropertyChangeHandler.propertyChange​(PropertyChangeEvent event)
      void | BasicTreeUI.SelectionModelPropertyChangeHandler.propertyChange​(PropertyChangeEvent event)
      protected void BasicScrollPaneUI.updateColumnHeader​(PropertyChangeEvent e)
      更新列标题。
      protected void BasicScrollPaneUI.updateRowHeader​(PropertyChangeEvent e)
      更新行标题。
      protected void BasicScrollPaneUI.updateScrollBarDisplayPolicy​(PropertyChangeEvent e)
      更新滚动条显示策略。
      protected void BasicScrollPaneUI.updateViewport​(PropertyChangeEvent e)
      更新视口。

    • Uses of PropertyChangeEvent in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type PropertyChangeEvent
      Modifier and Type | 方法 | 描述
      protected void MetalComboBoxUI.editablePropertyChanged​(PropertyChangeEvent e)
      已过时。
      从Java 2平台v1.4开始。
      void | MetalComboBoxUI.MetalPropertyChangeListener.propertyChange​(PropertyChangeEvent e)
      void | MetalFileChooserUI.FilterComboBoxModel.propertyChange​(PropertyChangeEvent e)
      void MetalRootPaneUI.propertyChange​(PropertyChangeEvent e)
      当属性更改时调用。
      void | MetalSliderUI.MetalPropertyListener.propertyChange​(PropertyChangeEvent e)
      void MetalTextFieldUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。

    • Uses of PropertyChangeEvent in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus with parameters of type PropertyChangeEvent
      Modifier and Type 方法 描述
      protected boolean NimbusLookAndFeel.shouldUpdateStyleOnEvent​(PropertyChangeEvent ev)
      返回在特定事件发生时，UI是否应更新其样式。

    • Uses of PropertyChangeEvent in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type PropertyChangeEvent
      Modifier and Type | 方法 | 描述
      void SynthButtonUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthColorChooserUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthComboBoxUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void | SynthDesktopIconUI.propertyChange​(PropertyChangeEvent evt)
      void SynthDesktopPaneUI.propertyChange​(PropertyChangeEvent evt)
      当绑定属性更改时，此方法将被调用。
      protected void SynthEditorPaneUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      void SynthInternalFrameUI.propertyChange​(PropertyChangeEvent evt)
      当绑定属性更改时，此方法将被调用。
      void SynthLabelUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthListUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthMenuBarUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthMenuItemUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthMenuUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthOptionPaneUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthPanelUI.propertyChange​(PropertyChangeEvent pce)
      当绑定属性更改时，此方法将被调用。
      void SynthPopupMenuUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthProgressBarUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthRootPaneUI.propertyChange​(PropertyChangeEvent e)
      在根窗格上更改属性时调用。
      void | SynthScrollBarUI.propertyChange​(PropertyChangeEvent e)
      void | SynthScrollPaneUI.propertyChange​(PropertyChangeEvent e)
      void | SynthSeparatorUI.propertyChange​(PropertyChangeEvent evt)
      void SynthSliderUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthSpinnerUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthSplitPaneUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthTabbedPaneUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthTableHeaderUI.propertyChange​(PropertyChangeEvent evt)
      当绑定属性更改时，此方法将被调用。
      void SynthTableUI.propertyChange​(PropertyChangeEvent event)
      当绑定属性更改时，此方法将被调用。
      protected void SynthTextAreaUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      protected void SynthTextFieldUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      protected void SynthTextPaneUI.propertyChange​(PropertyChangeEvent evt)
      当在关联的JTextComponent上更改bound属性时，将调用此方法。
      void SynthToolBarUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthToolTipUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      void SynthTreeUI.propertyChange​(PropertyChangeEvent event)
      当绑定属性更改时，此方法将被调用。
      void SynthViewportUI.propertyChange​(PropertyChangeEvent e)
      当绑定属性更改时，此方法将被调用。
      protected boolean SynthLookAndFeel.shouldUpdateStyleOnEvent​(PropertyChangeEvent ev)
      返回在特定事件发生时，UI是否应更新其样式。

    • Uses of PropertyChangeEvent in javax.swing.table

      Methods in javax.swing.table with parameters of type PropertyChangeEvent
      Modifier and Type 方法 描述
      void DefaultTableColumnModel.propertyChange​(PropertyChangeEvent evt)
      属性更改侦听器更改方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PropertyChangeListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PropertyChangeListenerProxy

No usage of java.beans.PropertyChangeListenerProxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PropertyChangeSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PropertyChangeSupport

  • Packages that use PropertyChangeSupport
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。

    • Uses of PropertyChangeSupport in java.awt

      Fields in java.awt declared as PropertyChangeSupport
      Modifier and Type Field 描述
      protected PropertyChangeSupport Toolkit.desktopPropsSupport
      桌面属性更改支持。

    • Uses of PropertyChangeSupport in java.beans.beancontext

      Fields in java.beans.beancontext declared as PropertyChangeSupport
      Modifier and Type Field 描述
      protected PropertyChangeSupport BeanContextChildSupport.pcSupport
      该 PropertyChangeSupport与此 BeanContextChildSupport相关联。

    • Uses of PropertyChangeSupport in javax.swing

      Methods in javax.swing that return PropertyChangeSupport
      Modifier and Type 方法 描述
      PropertyChangeSupport SwingWorker.getPropertyChangeSupport​()
      返回这个 PropertyChangeSupport的 SwingWorker 。

    • Uses of PropertyChangeSupport in javax.swing.event

      Subclasses of PropertyChangeSupport in javax.swing.event
      Modifier and Type Class 描述
      class  SwingPropertyChangeSupport
      java.beans.PropertyChangeSupport这个子类功能几乎相同。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PropertyDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PropertyDescriptor

  • Packages that use PropertyDescriptor
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of PropertyDescriptor in java.beans

      Subclasses of PropertyDescriptor in java.beans
      Modifier and Type Class 描述
      class  IndexedPropertyDescriptor
      IndexedPropertyDescriptor描述了一个像数组一样的属性，并且具有索引的读取和/或索引的写入方法来访问数组的特定元素。
      Methods in java.beans that return PropertyDescriptor
      Modifier and Type 方法 描述
      PropertyDescriptor[] BeanInfo.getPropertyDescriptors​()
      返回bean的所有属性的描述符。
      PropertyDescriptor[] SimpleBeanInfo.getPropertyDescriptors​()
      拒绝属性知识。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PropertyEditorManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PropertyEditorManager

No usage of java.beans.PropertyEditorManager
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PropertyEditorSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PropertyEditorSupport

No usage of java.beans.PropertyEditorSupport
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.PropertyVetoException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.PropertyVetoException

  • Packages that use PropertyVetoException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of PropertyVetoException in java.awt

      Methods in java.awt that throw PropertyVetoException
      Modifier and Type 方法 描述
      protected void KeyboardFocusManager.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)
      触发PropertyChangeEvent以响应否决权属性的更改。

    • Uses of PropertyVetoException in java.beans

      Methods in java.beans that throw PropertyVetoException
      Modifier and Type 方法 描述
      void VetoableChangeSupport.fireVetoableChange​(PropertyChangeEvent event)
      将属性更改事件触发到已注册的跟踪器，以跟踪所有属性的更新或具有指定名称的属性。
      void VetoableChangeSupport.fireVetoableChange​(String propertyName, boolean oldValue, boolean newValue)
      向已注册的监听器报告布尔约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void VetoableChangeSupport.fireVetoableChange​(String propertyName, int oldValue, int newValue)
      向已注册的监听器报告整数约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void VetoableChangeSupport.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)
      向已注册的监听器报告受限属性更新，以跟踪所有属性的更新或具有指定名称的属性。
      void VetoableChangeListener.vetoableChange​(PropertyChangeEvent evt)
      当更改约束属性时调用此方法。
      void VetoableChangeListenerProxy.vetoableChange​(PropertyChangeEvent event)
      将属性更改事件转发给侦听器代理。

    • Uses of PropertyVetoException in java.beans.beancontext

      Methods in java.beans.beancontext that throw PropertyVetoException
      Modifier and Type 方法 描述
      void BeanContextChildSupport.fireVetoableChange​(String name, Object oldValue, Object newValue)
      向任何已注册的听众报告否决权属性更新。
      void BeanContextChild.setBeanContext​(BeanContext bc)
      实现此接口的对象将触发java.beans.PropertyChangeEvent，其参数为：propertyName“beanContext”，oldValue（以前的嵌套 BeanContext实例或 null ），newValue（当前嵌套的 BeanContext实例或 null ）。
      void BeanContextChildSupport.setBeanContext​(BeanContext bc)
      设置 BeanContext为这个 BeanContextChildSupport 。
      void BeanContextSupport.setLocale​(Locale newLocale)
      设置此BeanContext的区域设置。
      void BeanContextSupport.vetoableChange​(PropertyChangeEvent pce)
      子类可以包围以监视否决权子变化。

    • Uses of PropertyVetoException in javax.swing

      Methods in javax.swing that throw PropertyVetoException
      Modifier and Type 方法 描述
      protected void JComponent.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)
      支持报告受限的属性更改。
      void JInternalFrame.setClosed​(boolean b)
      如果参数为 true则关闭此内部框架。
      void JInternalFrame.setIcon​(boolean b)
      如果外观和感觉支持图标化，则可以对该内部框架进行图标化或去图标化。
      void JInternalFrame.setMaximum​(boolean b)
      最大化和恢复这个内部框架。
      void JInternalFrame.setSelected​(boolean selected)
      如果显示内部框架，请选择或取消选择。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.SimpleBeanInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.SimpleBeanInfo

No usage of java.beans.SimpleBeanInfo
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.Statement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.Statement

  • Packages that use Statement
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of Statement in java.beans

      Subclasses of Statement in java.beans
      Modifier and Type Class 描述
      class  Expression
      一个 Expression对象表示一个原始表达式，其中单个方法应用于目标和一组参数以返回结果 - 如 "a.getFoo()" 。
      Methods in java.beans with parameters of type Statement
      Modifier and Type 方法 描述
      void Encoder.writeStatement​(Statement oldStm)
      向流写入语句 oldStm 。
      void XMLEncoder.writeStatement​(Statement oldStm)
      记录声明，以便编码器将在流被冲洗时产生实际的输出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.Transient (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.Transient

  • Packages that use Transient
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.im
    提供输入法框架的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of Transient in java.awt

      Methods in java.awt with annotations of type Transient
      Modifier and Type 方法 描述
      Color Component.getBackground​()
      获取此组件的背景颜色。
      Rectangle Rectangle.getBounds​()
      获得 Rectangle的边界 Rectangle 。
      Font Component.getFont​()
      获取此组件的字体。
      Color Component.getForeground​()
      获取此组件的前景色。
      Point Point.getLocation​()
      返回这一点的位置。
      Point ScrollPane.getScrollPosition​()
      返回显示在滚动面板视图端口的0,0位置的子项内的当前x，y位置。
      Dimension Dimension.getSize​()
      获取此 Dimension对象的大小。
      boolean Component.isVisible​()
      确定当该组件的父级可见时是否应该可见。

    • Uses of Transient in java.awt.geom

      Methods in java.awt.geom with annotations of type Transient
      Modifier and Type 方法 描述
      Rectangle2D RectangularShape.getFrame​()
      返回定义此对象的整体形状的框架Rectangle2D 。

    • Uses of Transient in java.awt.im

      Methods in java.awt.im with annotations of type Transient
      Modifier and Type 方法 描述
      boolean InputContext.isCompositionEnabled​()
      确定组合是否启用当前输入法。

    • Uses of Transient in javax.swing

      Methods in javax.swing with annotations of type Transient
      Modifier and Type 方法 描述
      int DefaultListSelectionModel.getAnchorSelectionIndex​()
      从最近调用setSelectionInterval（），addSelectionInterval（）或removeSelectionInterval（）返回第一个索引参数。
      ListCellRenderer<? super E> JList.getCellRenderer​()
      返回负责绘画列表项的对象。
      JViewport JScrollPane.getColumnHeader​()
      返回列标题。
      Icon AbstractButton.getDisabledIcon​()
      返回按钮禁用时使用的图标。
      Icon JLabel.getDisabledIcon​()
      返回标签禁用时使用的图标。
      Dimension JViewport.getExtentSize​()
      返回视图坐标中视图的可见部分的大小。
      JMenu JMenuBar.getHelpMenu​()
      获取菜单栏的帮助菜单。
      JScrollBar JScrollPane.getHorizontalScrollBar​()
      返回控制视口水平视图位置的水平滚动条。
      Image ImageIcon.getImage​()
      返回此图标的 Image 。
      ImageObserver ImageIcon.getImageObserver​()
      返回图像的图像观察者。
      int DefaultListSelectionModel.getLeadSelectionIndex​()
      将第二个索引参数从最近的调用返回给setSelectionInterval（），addSelectionInterval（）或removeSelectionInterval（）。
      Dimension JComponent.getMaximumSize​()
      如果最大大小设置为非 null ，则返回值。
      Dimension JComponent.getMinimumSize​()
      如果最小尺寸已设置为非 null值，则返回。
      Dimension JComponent.getPreferredSize​()
      如果 preferredSize已被设置为非 null值，则返回。
      JViewport JScrollPane.getRowHeader​()
      返回行标题。
      Component JTabbedPane.getSelectedComponent​()
      返回此选项卡窗格当前选定的组件。
      int JComboBox.getSelectedIndex​()
      返回列表中与给定项目匹配的第一个项目。
      int JTabbedPane.getSelectedIndex​()
      返回此选项卡窗格的当前选择的索引。
      int[] JList.getSelectedIndices​()
      以递增的顺序返回所有选定索引的数组。
      ComponentUI JComponent.getUI​()
      返回渲染此组件的外观和委托。
      JScrollBar JScrollPane.getVerticalScrollBar​()
      返回控制视口垂直视图位置的垂直滚动条。

    • Uses of Transient in javax.swing.table

      Methods in javax.swing.table with annotations of type Transient
      Modifier and Type 方法 描述
      TableCellRenderer JTableHeader.getDefaultRenderer​()
      返回当 headerRenderer定义为 TableColumn时使用的默认渲染器。

    • Uses of Transient in javax.swing.text

      Methods in javax.swing.text with annotations of type Transient
      Modifier and Type 方法 描述
      Caret JTextComponent.getCaret​()
      获取允许通过视图进行文本导向的插入符号。
      int JTextComponent.getCaretPosition​()
      返回文本组件的文本插入符号的位置。
      int JTextComponent.getSelectionEnd​()
      返回所选文本的结束位置。
      int JTextComponent.getSelectionStart​()
      返回所选文本的起始位置。

    • Uses of Transient in javax.swing.tree

      Methods in javax.swing.tree with annotations of type Transient
      Modifier and Type 方法 描述
      void DefaultMutableTreeNode.setParent​(MutableTreeNode newParent)
      将此节点的父节点设置为 newParent但不会更改父节点的子数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.VetoableChangeListenerProxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.VetoableChangeListenerProxy

No usage of java.beans.VetoableChangeListenerProxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.VetoableChangeSupport (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.VetoableChangeSupport

  • Packages that use VetoableChangeSupport
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of VetoableChangeSupport in java.beans.beancontext

      Fields in java.beans.beancontext declared as VetoableChangeSupport
      Modifier and Type Field 描述
      protected VetoableChangeSupport BeanContextChildSupport.vcSupport
      该 VetoableChangeSupport与此 BeanContextChildSupport相关联。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.XMLDecoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.XMLDecoder

No usage of java.beans.XMLDecoder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.beans.XMLEncoder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.beans.XMLEncoder

No usage of java.beans.XMLEncoder
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.AppletInitializer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.AppletInitializer

  • Packages that use AppletInitializer
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of AppletInitializer in java.beans

      Methods in java.beans with parameters of type AppletInitializer
      Modifier and Type 方法 描述
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
      已过时。
      建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.BeanInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.BeanInfo

  • Packages that use BeanInfo
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of BeanInfo in java.beans

      Classes in java.beans that implement BeanInfo
      Modifier and Type Class 描述
      class  SimpleBeanInfo
      这是一个支持类，使人们更容易提供BeanInfo类。
      Methods in java.beans that return BeanInfo
      Modifier and Type 方法 描述
      BeanInfo[] BeanInfo.getAdditionalBeanInfo​()
      此方法使当前的 BeanInfo对象能够返回任何其他 BeanInfo对象的任意集合， BeanInfo对象提供有关当前bean的其他信息。
      BeanInfo[] SimpleBeanInfo.getAdditionalBeanInfo​()
      声明没有其他相关的BeanInfo对象。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass)
      内省Java Bean并了解其所有属性，暴露的方法和事件。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, int flags)
      对Java bean进行内省，并了解其所有属性，公开方法和事件，并遵守一些控制标志。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, Class<?> stopClass)
      内省Java bean并了解其属性，暴露的方法，低于给定的“停止”点。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, Class<?> stopClass, int flags)
      对Java Bean进行内省，并了解其所有属性，暴露的方法和事件，低于给定的 stopClass点，受控于一些控件 flags 。

    • Uses of BeanInfo in java.beans.beancontext

      Subinterfaces of BeanInfo in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContextServiceProviderBeanInfo
      一个BeanContextServiceProvider实现者希望提供关于他们的bean可能提供的服务的显式信息，应该实现一个实现这个BeanInfo子接口的BeanInfo类，并提供有关其服务的方法，属性，事件等的显式信息。
      Methods in java.beans.beancontext that return BeanInfo
      Modifier and Type 方法 描述
      BeanInfo[] BeanContextServiceProviderBeanInfo.getServicesBeanInfo​()
      获取一个 BeanInfo阵列，一个针对每个服务类或从该ServiceProvider静态提供的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.Customizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.Customizer

No usage of java.beans.Customizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.DesignMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.DesignMode

  • Packages that use DesignMode
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of DesignMode in java.beans.beancontext

      Subinterfaces of DesignMode in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContext
      BeanContext对JavaBeans起着逻辑分层容器的作用。
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      Classes in java.beans.beancontext that implement DesignMode
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.ExceptionListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.ExceptionListener

  • Packages that use ExceptionListener
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of ExceptionListener in java.beans

      Methods in java.beans that return ExceptionListener
      Modifier and Type 方法 描述
      ExceptionListener Encoder.getExceptionListener​()
      获取此流的异常处理程序。
      ExceptionListener XMLDecoder.getExceptionListener​()
      获取此流的异常处理程序。
      Methods in java.beans with parameters of type ExceptionListener
      Modifier and Type 方法 描述
      static DefaultHandler XMLDecoder.createHandler​(Object owner, ExceptionListener el, ClassLoader cl)
      为SAX解析器创建一个新的处理程序，可用于解析由 XMLEncoder类创建的嵌入式XML归档。
      void Encoder.setExceptionListener​(ExceptionListener exceptionListener)
      将此流的异常处理程序设置为 exceptionListener 。
      void XMLDecoder.setExceptionListener​(ExceptionListener exceptionListener)
      将此流的异常处理程序设置为 exceptionListener 。
      Constructors in java.beans with parameters of type ExceptionListener
      Constructor 描述
      XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.PropertyChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.PropertyChangeListener

  • Packages that use PropertyChangeListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of PropertyChangeListener in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      static void AccessibilityEventMonitor.addPropertyChangeListener​(PropertyChangeListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个UI对象实例上接收所有PropertyChange事件。
      static void SwingEventMonitor.addPropertyChangeListener​(PropertyChangeListener l)
      添加指定的侦听器以在Java虚拟机发生时的每个组件实例上接收所有 PROPERTYCHANGE事件。
      void Translator.addPropertyChangeListener​(PropertyChangeListener l)
      添加一个 PropertyChangeListener到监听器列表。
      static void AccessibilityEventMonitor.removePropertyChangeListener​(PropertyChangeListener l)
      删除指定的监听器，使其在发生时不再接收PropertyChange事件。
      static void SwingEventMonitor.removePropertyChangeListener​(PropertyChangeListener l)
      删除指定的侦听器，使其不再接收 PROPERTYCHANGE事件。
      void Translator.removePropertyChangeListener​(PropertyChangeListener l)
      从侦听器列表中删除 PropertyChangeListener 。

    • Uses of PropertyChangeListener in com.sun.tools.jconsole

      Methods in com.sun.tools.jconsole with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void JConsolePlugin.addContextPropertyChangeListener​(PropertyChangeListener listener)
      添加一个PropertyChangeListener至JConsoleContext对象这个插件。
      void JConsoleContext.addPropertyChangeListener​(PropertyChangeListener listener)
      添加一个PropertyChangeListener到监听器列表。
      void JConsolePlugin.removeContextPropertyChangeListener​(PropertyChangeListener listener)
      从此插件的JConsoleContext对象的侦听器列表中删除PropertyChangeListener 。
      void JConsoleContext.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除PropertyChangeListener 。

    • Uses of PropertyChangeListener in java.awt

      Methods in java.awt that return PropertyChangeListener
      Modifier and Type 方法 描述
      PropertyChangeListener[] Component.getPropertyChangeListeners​()
      返回在此组件上注册的所有属性更改侦听器的数组。
      PropertyChangeListener[] Component.getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      PropertyChangeListener[] KeyboardFocusManager.getPropertyChangeListeners​()
      返回在此键盘焦点管理器上注册的所有属性更改侦听器的数组。
      PropertyChangeListener[] KeyboardFocusManager.getPropertyChangeListeners​(String propertyName)
      返回与命名属性相关联的所有 PropertyChangeListener的数组。
      PropertyChangeListener[] SystemTray.getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      PropertyChangeListener[] Toolkit.getPropertyChangeListeners​()
      返回在此工具包上注册的所有属性更改侦听器的数组。
      PropertyChangeListener[] Toolkit.getPropertyChangeListeners​(String propertyName)
      返回与指定的桌面属性名称相关联的所有属性更改侦听器的数组。
      Methods in java.awt with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void Component.AccessibleAWTComponent.addPropertyChangeListener​(PropertyChangeListener listener)
      添加 PropertyChangeListener到侦听器列表。
      void Component.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void Component.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void Container.AccessibleAWTContainer.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void Container.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void Container.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void KeyboardFocusManager.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void KeyboardFocusManager.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void SystemTray.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将 PropertyChangeListener添加到特定属性的侦听器列表中。
      void Toolkit.addPropertyChangeListener​(String name, PropertyChangeListener pcl)
      为指定的桌面属性添加指定的属性更改侦听器。
      void Window.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void Window.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void Component.AccessibleAWTComponent.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除一个PropertyChangeListener。
      void Component.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
      void Component.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      从侦听器列表中删除特定属性的 PropertyChangeListener 。
      void Container.AccessibleAWTContainer.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除一个PropertyChangeListener。
      void KeyboardFocusManager.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
      void KeyboardFocusManager.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      从侦听器列表中为特定属性移除PropertyChangeListener。
      void SystemTray.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      从侦听器列表中删除特定属性的 PropertyChangeListener 。
      void Toolkit.removePropertyChangeListener​(String name, PropertyChangeListener pcl)
      为指定的桌面属性移除指定的属性更改侦听器。

    • Uses of PropertyChangeListener in java.beans

      Classes in java.beans that implement PropertyChangeListener
      Modifier and Type Class 描述
      class  PropertyChangeListenerProxy
      一个类扩展了 EventListenerProxy专门用于添加一个“绑定”属性的 PropertyChangeListener 。
      Methods in java.beans that return PropertyChangeListener
      Modifier and Type 方法 描述
      PropertyChangeListener[] PropertyChangeSupport.getPropertyChangeListeners​()
      返回使用addPropertyChangeListener（）添加到PropertyChangeSupport对象的所有侦听器的数组。
      PropertyChangeListener[] PropertyChangeSupport.getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      Methods in java.beans with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void Customizer.addPropertyChangeListener​(PropertyChangeListener listener)
      注册PropertyChange事件的侦听器。
      void PropertyChangeSupport.addPropertyChangeListener​(PropertyChangeListener listener)
      将一个PropertyChangeListener添加到侦听器列表。
      void PropertyChangeSupport.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      为特定属性添加PropertyChangeListener。
      void PropertyEditor.addPropertyChangeListener​(PropertyChangeListener listener)
      为值更改添加一个侦听器。
      void PropertyEditorSupport.addPropertyChangeListener​(PropertyChangeListener listener)
      为值更改添加一个侦听器。
      void Customizer.removePropertyChangeListener​(PropertyChangeListener listener)
      删除PropertyChange事件的侦听器。
      void PropertyChangeSupport.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除一个PropertyChangeListener。
      void PropertyChangeSupport.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      删除特定属性的PropertyChangeListener。
      void PropertyEditor.removePropertyChangeListener​(PropertyChangeListener listener)
      删除值更改的侦听器。
      void PropertyEditorSupport.removePropertyChangeListener​(PropertyChangeListener listener)
      删除值更改的侦听器。
      Constructors in java.beans with parameters of type PropertyChangeListener
      Constructor 描述
      PropertyChangeListenerProxy​(String propertyName, PropertyChangeListener listener)
      构造函数将 PropertyChangeListener绑定到特定属性。

    • Uses of PropertyChangeListener in java.beans.beancontext

      Classes in java.beans.beancontext that implement PropertyChangeListener
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Methods in java.beans.beancontext that return PropertyChangeListener
      Modifier and Type 方法 描述
      protected static PropertyChangeListener BeanContextSupport.getChildPropertyChangeListener​(Object child)
      获取指定子对象的PropertyChangeListener（如果有）
      Methods in java.beans.beancontext with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void BeanContextChild.addPropertyChangeListener​(String name, PropertyChangeListener pcl)
      为此 BeanContextChild添加一个 PropertyChangeListener ，以便在指定的属性更改时接收 PropertyChangeEvent 。
      void BeanContextChildSupport.addPropertyChangeListener​(String name, PropertyChangeListener pcl)
      为特定属性添加PropertyChangeListener。
      void BeanContextChild.removePropertyChangeListener​(String name, PropertyChangeListener pcl)
      从这个 BeanContextChild删除一个 PropertyChangeListener ，以便在指定的属性更改时不再接收 PropertyChangeEvents 。
      void BeanContextChildSupport.removePropertyChangeListener​(String name, PropertyChangeListener pcl)
      删除特定属性的PropertyChangeListener。

    • Uses of PropertyChangeListener in javax.accessibility

      Methods in javax.accessibility with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void AccessibleContext.addPropertyChangeListener​(PropertyChangeListener listener)
      添加 PropertyChangeListener到侦听器列表。
      void AccessibleContext.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除 PropertyChangeListener 。

    • Uses of PropertyChangeListener in javax.swing

      Classes in javax.swing that implement PropertyChangeListener
      Modifier and Type Class 描述
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并接收在其边框内生成的所有 AWTEvent的通知。
      protected class  JList.AccessibleJList
      这个类实现 JList类的可访问性支持。
      protected class  JPopupMenu.AccessibleJPopupMenu
      该类实现 JPopupMenu类的可访问性支持。
      protected class  JScrollPane.AccessibleJScrollPane
      该类为 JScrollPane类实现可访问性支持。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      一个更专业的编辑器的简单的基础类，它显示了一个 JFormattedTextField的模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      protected class  JTable.AccessibleJTable
      该类实现 JTable类的可访问性支持。
      protected class  ProgressMonitor.AccessibleProgressMonitor
      AccessibleProgressMonitor实现对 ProgressMonitor类的可访问性支持。
      Methods in javax.swing that return PropertyChangeListener
      Modifier and Type 方法 描述
      protected PropertyChangeListener JMenu.createActionChangeListener​(JMenuItem b)
      返回正确配置的 PropertyChangeListener ，更新控件，因为发生 Action更改。
      protected PropertyChangeListener JPopupMenu.createActionChangeListener​(JMenuItem b)
      返回正确配置的 PropertyChangeListener ，更新控件，因为发生 Action更改。
      protected PropertyChangeListener JToolBar.createActionChangeListener​(JButton b)
      返回一个正确配置的 PropertyChangeListener ，当更改 Action时更新控件，如果需要该控件的默认属性更改侦听器，则 null 。
      protected PropertyChangeListener AbstractButton.createActionPropertyChangeListener​(Action a)
      创建并返回一个 PropertyChangeListener ，负责监听从指定的 Action进行的更改并更新相应的属性。
      protected PropertyChangeListener JComboBox.createActionPropertyChangeListener​(Action a)
      创建并返回一个 PropertyChangeListener ，负责监听从指定的 Action进行的更改并更新相应的属性。
      protected PropertyChangeListener JTextField.createActionPropertyChangeListener​(Action a)
      创建并返回一个 PropertyChangeListener ，负责监听从指定的 Action进行的更改并更新相应的属性。
      PropertyChangeListener[] AbstractAction.getPropertyChangeListeners​()
      返回使用addPropertyChangeListener（）添加到此AbstractAction的所有 PropertyChangeListener的数组。
      PropertyChangeListener[] UIDefaults.getPropertyChangeListeners​()
      返回使用addPropertyChangeListener（）添加到此UIDefaults的所有 PropertyChangeListener的数组。
      static PropertyChangeListener[] UIManager.getPropertyChangeListeners​()
      返回使用addPropertyChangeListener（）添加到此UIManager的所有 PropertyChangeListener的数组。
      Methods in javax.swing with parameters of type PropertyChangeListener
      Modifier and Type | 方法 | 描述
      void AbstractAction.addPropertyChangeListener​(PropertyChangeListener listener)
      添加一个 PropertyChangeListener到监听器列表。
      void Action.addPropertyChangeListener​(PropertyChangeListener listener)
      添加一个 PropertyChange监听器。
      void JComponent.AccessibleJComponent.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void | JList.AccessibleJList.AccessibleJListChild.addPropertyChangeListener​(PropertyChangeListener l)
      void JTable.AccessibleJTable.AccessibleJTableCell.addPropertyChangeListener​(PropertyChangeListener l)
      添加一个 PropertyChangeListener到监听器列表。
      void JTree.AccessibleJTree.AccessibleJTreeNode.addPropertyChangeListener​(PropertyChangeListener l)
      将一个PropertyChangeListener添加到侦听器列表。
      void JTree.EmptySelectionModel.addPropertyChangeListener​(PropertyChangeListener listener)
      这样做是无效的 EmptySelectionModel不允许进行选择。
      void SwingWorker.addPropertyChangeListener​(PropertyChangeListener listener)
      添加 PropertyChangeListener到侦听器列表。
      void UIDefaults.addPropertyChangeListener​(PropertyChangeListener listener)
      添加 PropertyChangeListener到侦听器列表。
      static void UIManager.addPropertyChangeListener​(PropertyChangeListener listener)
      添加一个 PropertyChangeListener到监听器列表。
      void AbstractAction.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除 PropertyChangeListener 。
      void Action.removePropertyChangeListener​(PropertyChangeListener listener)
      删除一个 PropertyChange听众。
      void JComponent.AccessibleJComponent.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
      void | JList.AccessibleJList.AccessibleJListChild.removePropertyChangeListener​(PropertyChangeListener l)
      void JTable.AccessibleJTable.AccessibleJTableCell.removePropertyChangeListener​(PropertyChangeListener l)
      从侦听器列表中删除 PropertyChangeListener 。
      void JTree.AccessibleJTree.AccessibleJTreeNode.removePropertyChangeListener​(PropertyChangeListener l)
      从侦听器列表中删除一个PropertyChangeListener。
      void JTree.EmptySelectionModel.removePropertyChangeListener​(PropertyChangeListener listener)
      这样做是无效的 EmptySelectionModel不允许进行选择。
      void SwingWorker.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除 PropertyChangeListener 。
      void UIDefaults.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除 PropertyChangeListener 。
      static void UIManager.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除 PropertyChangeListener 。

    • Uses of PropertyChangeListener in javax.swing.plaf

      Methods in javax.swing.plaf that return PropertyChangeListener
      Modifier and Type 方法 描述
      PropertyChangeListener[] LayerUI.getPropertyChangeListeners​()
      返回在此组件上注册的所有属性更改侦听器的数组。
      PropertyChangeListener[] LayerUI.getPropertyChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      Methods in javax.swing.plaf with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void LayerUI.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void LayerUI.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      将PropertyChangeListener添加到特定属性的侦听器列表中。
      void LayerUI.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
      void LayerUI.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)
      从侦听器列表中删除特定属性的 PropertyChangeListener 。

    • Uses of PropertyChangeListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement PropertyChangeListener
      Modifier and Type Class 描述
      class  BasicButtonListener
      按钮监听器
      class  BasicColorChooserUI.PropertyHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicComboBoxUI.PropertyChangeHandler
      该监听器监视组合框中已更改的绑定属性。
      protected class  BasicComboPopup.PropertyChangeHandler
      该监听器监视组合框中已更改的绑定属性。
      class  BasicDirectoryModel
      文件列表的基本实现。
      class  BasicInternalFrameTitlePane.PropertyChangeHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameUI.InternalFramePropertyChangeListener
      内部框架属性更改侦听器。
      class  BasicLabelUI
      LabelUI的Windows L＆F实现。
      class  BasicListUI.PropertyChangeHandler
      在InstallUI时添加到JList的PropertyChangeListener。
      class  BasicOptionPaneUI.PropertyChangeHandler
      这个类应该被视为一个“受保护”的内部类。
      class  BasicRootPaneUI
      RootPaneUI的基本实现，所有JRootPane实例之间共享一个。
      class  BasicScrollBarUI.PropertyChangeHandler
      属性更改处理程序
      class  BasicScrollPaneUI.PropertyChangeHandler
      属性更改处理程序
      class  BasicSliderUI.PropertyChangeHandler
      属性更改处理程序。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      class  BasicSplitPaneUI.PropertyHandler
      实现JSplitPane UI使用的PropertyChangeListener。
      class  BasicTabbedPaneUI.PropertyChangeHandler
      这个类应该被视为一个“受保护”的内部类。
      protected class  BasicToolBarUI.PropertyListener
      该类监听属性更改的事件。
      class  BasicTreeUI.PropertyChangeHandler
      PropertyChangeListener为树。
      class  BasicTreeUI.SelectionModelPropertyChangeHandler
      在TreeSelectionModel上的侦听器，如果模型的任何属性更改，则重置行选择。
      Fields in javax.swing.plaf.basic declared as PropertyChangeListener
      Modifier and Type Field 描述
      protected PropertyChangeListener BasicColorChooserUI.propertyChangeListener
      实例 PropertyChangeListener 。
      protected PropertyChangeListener BasicComboBoxUI.propertyChangeListener
      此保护字段是实现特定的。
      protected PropertyChangeListener BasicComboPopup.propertyChangeListener
      此保护字段是实现特定的。
      protected PropertyChangeListener BasicInternalFrameTitlePane.propertyChangeListener
      一个 PropertyChangeListener的实例。
      protected PropertyChangeListener BasicInternalFrameUI.propertyChangeListener
      属性更改侦听器
      protected PropertyChangeListener BasicListUI.propertyChangeListener
      PropertyChangeListener附于 JList 。
      protected PropertyChangeListener BasicMenuItemUI.propertyChangeListener
      PropertyChangeListener从 createPropertyChangeListener返回。
      protected PropertyChangeListener BasicOptionPaneUI.propertyChangeListener
      实例 PropertyChangeListener 。
      protected PropertyChangeListener BasicScrollBarUI.propertyChangeListener
      属性更改侦听器
      protected PropertyChangeListener BasicSliderUI.propertyChangeListener
      属性chane监听器
      protected PropertyChangeListener BasicSplitPaneUI.propertyChangeListener
      此JSplitPane的PropertyChangeListener的实例。
      protected PropertyChangeListener BasicTabbedPaneUI.propertyChangeListener
      属性更改侦听器
      protected PropertyChangeListener BasicToolBarUI.propertyListener
      一个 PropertyChangeListener的实例。
      protected PropertyChangeListener BasicScrollPaneUI.spPropertyChangeListener
      PropertyChangeListener安装在滚动窗格上。
      Methods in javax.swing.plaf.basic that return PropertyChangeListener
      Modifier and Type | 方法 | 描述
      protected PropertyChangeListener BasicColorChooserUI.createPropertyChangeListener​()
      返回一个 PropertyChangeListener的实例。
      protected PropertyChangeListener BasicComboBoxUI.createPropertyChangeListener​()
      创建一个 PropertyChangeListener ，它将被添加到组合框中。
      protected PropertyChangeListener BasicComboPopup.createPropertyChangeListener​()
      创建一个将被添加到组合框的 PropertyChangeListener 。
      protected PropertyChangeListener BasicDesktopPaneUI.createPropertyChangeListener​()
      返回 PropertyChangeListener安装在 JDesktopPane 。
      PropertyChangeListener BasicFileChooserUI.createPropertyChangeListener​(JFileChooser fc)
      创建属性更改侦听器。
      protected PropertyChangeListener BasicInternalFrameTitlePane.createPropertyChangeListener​()
      返回一个 PropertyChangeListener的实例。
      protected PropertyChangeListener BasicInternalFrameUI.createPropertyChangeListener​()
      创建属性更改侦听器。
      protected PropertyChangeListener BasicListUI.createPropertyChangeListener​()
      创建的实例 PropertyChangeHandler了加在 JList由 installUI() 。
      protected PropertyChangeListener BasicMenuItemUI.createPropertyChangeListener​(JComponent c)
      创建一个 PropertyChangeListener ，这将被添加到菜单项。
      protected PropertyChangeListener | BasicMenuUI.createPropertyChangeListener​(JComponent c)
      protected PropertyChangeListener BasicOptionPaneUI.createPropertyChangeListener​()
      返回一个 PropertyChangeListener的实例。
      protected PropertyChangeListener BasicScrollBarUI.createPropertyChangeListener​()
      创建属性更改侦听器。
      protected PropertyChangeListener BasicScrollPaneUI.createPropertyChangeListener​()
      创建一个 PropertyChangeListener的实例，它被添加到 JScrollPane由 installUI() 。
      protected PropertyChangeListener BasicSliderUI.createPropertyChangeListener​(JSlider slider)
      创建属性更改侦听器。
      protected PropertyChangeListener BasicSpinnerUI.createPropertyChangeListener​()
      创建一个可以添加到JSpinner本身的 PropertyChangeListener 。
      protected PropertyChangeListener BasicSplitPaneUI.createPropertyChangeListener​()
      创建 PropertyChangeListener为 JSplitPane UI。
      protected PropertyChangeListener BasicTabbedPaneUI.createPropertyChangeListener​()
      创建属性更改侦听器。
      protected PropertyChangeListener BasicTreeUI.createPropertyChangeListener​()
      创建一个监听器，负责根据树的更改更新UI。
      protected PropertyChangeListener BasicToolBarUI.createPropertyListener​()
      返回一个 PropertyChangeListener的实例。
      protected PropertyChangeListener BasicTreeUI.createSelectionModelPropertyChangeListener​()
      创建负责从选择模型获取属性更改事件的监听器。
      PropertyChangeListener[] BasicDirectoryModel.getPropertyChangeListeners​()
      返回在此组件上注册的所有属性更改侦听器的数组。
      Methods in javax.swing.plaf.basic with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void BasicDirectoryModel.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void BasicDirectoryModel.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。

    • Uses of PropertyChangeListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement PropertyChangeListener
      Modifier and Type Class 描述
      class  MetalComboBoxUI.MetalPropertyChangeListener
      这个类应该被视为一个“受保护”的内部类。
      protected class  MetalFileChooserUI.FilterComboBoxModel
      类型面部选择组合框的数据模型。
      class  MetalLabelUI
      LabelUI的Windows L＆F实现。
      class  MetalRootPaneUI
      提供金属外观实现 RootPaneUI 。
      protected class  MetalSliderUI.MetalPropertyListener
      PropertyListener适用于 JSlider.isFilled 。
      protected class  MetalToolBarUI.MetalRolloverListener
      不再使用
      Fields in javax.swing.plaf.metal declared as PropertyChangeListener
      Modifier and Type Field 描述
      protected PropertyChangeListener MetalToolBarUI.rolloverListener
      此保护字段是实现特定的。
      Methods in javax.swing.plaf.metal that return PropertyChangeListener
      Modifier and Type | 方法 | 描述
      PropertyChangeListener | MetalComboBoxUI.createPropertyChangeListener​()
      PropertyChangeListener | MetalFileChooserUI.createPropertyChangeListener​(JFileChooser fc)
      protected PropertyChangeListener | MetalInternalFrameTitlePane.createPropertyChangeListener​()
      protected PropertyChangeListener | MetalScrollBarUI.createPropertyChangeListener​()
      protected PropertyChangeListener MetalSliderUI.createPropertyChangeListener​(JSlider slider)
      构造 MetalPropertyListener 。
      protected PropertyChangeListener MetalToolBarUI.createRolloverListener​()
      创建一个将添加到JToolBar的属性更改侦听器。
      protected PropertyChangeListener MetalScrollPaneUI.createScrollBarSwapListener​()
      为滚动条交换事件返回一个新的 PropertyChangeListener 。

    • Uses of PropertyChangeListener in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement PropertyChangeListener
      Modifier and Type Class 描述
      class  SynthButtonUI
      为JButton提供Synth L＆F UI代表。
      class  SynthCheckBoxMenuItemUI
      为JCheckBoxMenuItem提供Synth L＆F UI代表。
      class  SynthCheckBoxUI
      为JCheckBox提供Synth L＆F UI代表。
      class  SynthColorChooserUI
      为JColorChooser提供Synth L＆F UI代表。
      class  SynthComboBoxUI
      为JComboBox提供Synth L＆F UI代表。
      class  SynthDesktopIconUI
      为桌面上最小化的内部框架提供Synth L＆F UI代理。
      class  SynthDesktopPaneUI
      为JDesktopPane提供Synth L＆F UI代表。
      class  SynthInternalFrameUI
      为JInternalFrame提供Synth L＆F UI代表。
      class  SynthLabelUI
      为JLabel提供Synth L＆F UI代表。
      class  SynthListUI
      为JList提供Synth L＆F UI代表。
      class  SynthMenuBarUI
      为JMenuBar提供Synth L＆F UI代表。
      class  SynthMenuItemUI
      为JMenuItem提供Synth L＆F UI代表。
      class  SynthMenuUI
      为JMenu提供Synth L＆F UI代表。
      class  SynthOptionPaneUI
      为JOptionPane提供Synth L＆F UI代表。
      class  SynthPanelUI
      为JPanel提供Synth L＆F UI代表。
      class  SynthPopupMenuUI
      为JPopupMenu提供Synth L＆F UI代表。
      class  SynthProgressBarUI
      为JProgressBar提供Synth L＆F UI代表。
      class  SynthRadioButtonMenuItemUI
      为JRadioButtonMenuItem提供Synth L＆F UI代表。
      class  SynthRadioButtonUI
      为JRadioButton提供Synth L＆F UI代表。
      class  SynthRootPaneUI
      为JRootPane提供Synth L＆F UI代表。
      class  SynthScrollBarUI
      为JScrollBar提供Synth L＆F UI代表。
      class  SynthScrollPaneUI
      为JScrollPane提供Synth L＆F UI代表。
      class  SynthSeparatorUI
      为JSeparator提供Synth L＆F UI代表。
      class  SynthSliderUI
      为JSlider提供Synth L＆F UI代表。
      class  SynthSpinnerUI
      为JSpinner提供Synth L＆F UI代表。
      class  SynthSplitPaneUI
      为JSplitPane提供Synth L＆F UI代表。
      class  SynthTabbedPaneUI
      为JTabbedPane提供Synth L＆F UI代表。
      class  SynthTableHeaderUI
      为JTableHeader提供Synth L＆F UI代表。
      class  SynthTableUI
      为JTable提供Synth L＆F UI代表。
      class  SynthToggleButtonUI
      为JToggleButton提供Synth L＆F UI代表。
      class  SynthToolBarUI
      为JToolBar提供Synth L＆F UI代表。
      class  SynthToolTipUI
      为JToolTip提供Synth L＆F UI代表。
      class  SynthTreeUI
      为JTree提供Synth L＆F UI代表。
      class  SynthViewportUI
      为JViewport提供Synth L＆F UI代表。

    • Uses of PropertyChangeListener in javax.swing.table

      Classes in javax.swing.table that implement PropertyChangeListener
      Modifier and Type Class 描述
      class  DefaultTableColumnModel
      JTable的标准列处理程序。
      Methods in javax.swing.table that return PropertyChangeListener
      Modifier and Type 方法 描述
      PropertyChangeListener[] TableColumn.getPropertyChangeListeners​()
      返回使用addPropertyChangeListener（）添加到此TableColumn的所有 PropertyChangeListener的数组。
      Methods in javax.swing.table with parameters of type PropertyChangeListener
      Modifier and Type | 方法 | 描述
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addPropertyChangeListener​(PropertyChangeListener l)
      void TableColumn.addPropertyChangeListener​(PropertyChangeListener listener)
      添加一个 PropertyChangeListener到监听器列表。
      void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.removePropertyChangeListener​(PropertyChangeListener l)
      void TableColumn.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中删除 PropertyChangeListener 。

    • Uses of PropertyChangeListener in javax.swing.tree

      Methods in javax.swing.tree that return PropertyChangeListener
      Modifier and Type 方法 描述
      PropertyChangeListener[] DefaultTreeSelectionModel.getPropertyChangeListeners​()
      返回在此 DefaultTreeSelectionModel上注册的所有属性更改监听器的数组。
      Methods in javax.swing.tree with parameters of type PropertyChangeListener
      Modifier and Type 方法 描述
      void DefaultTreeSelectionModel.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void TreeSelectionModel.addPropertyChangeListener​(PropertyChangeListener listener)
      将PropertyChangeListener添加到侦听器列表。
      void DefaultTreeSelectionModel.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
      void TreeSelectionModel.removePropertyChangeListener​(PropertyChangeListener listener)
      从侦听器列表中移除PropertyChangeListener。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.PropertyEditor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.PropertyEditor

  • Packages that use PropertyEditor
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

    • Uses of PropertyEditor in java.beans

      Classes in java.beans that implement PropertyEditor
      Modifier and Type Class 描述
      class  PropertyEditorSupport
      这是一个帮助构建属性编辑器的支持类。
      Methods in java.beans that return PropertyEditor
      Modifier and Type 方法 描述
      PropertyEditor PropertyDescriptor.createPropertyEditor​(Object bean)
      使用当前的属性编辑器类构造一个属性编辑器的实例。
      static PropertyEditor PropertyEditorManager.findEditor​(Class<?> targetType)
      找到给定目标类型的值编辑器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.VetoableChangeListener (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.VetoableChangeListener

  • Packages that use VetoableChangeListener
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of VetoableChangeListener in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util with parameters of type VetoableChangeListener
      Modifier and Type 方法 描述
      static void SwingEventMonitor.addVetoableChangeListener​(VetoableChangeListener l)
      添加指定的侦听器以在Java虚拟机中发生的每个组件实例上接收所有 VETOABLECHANGE事件。
      static void SwingEventMonitor.removeVetoableChangeListener​(VetoableChangeListener l)
      删除指定的侦听器，使其不再接收 VETOABLECHANGE事件。

    • Uses of VetoableChangeListener in java.awt

      Methods in java.awt that return VetoableChangeListener
      Modifier and Type 方法 描述
      VetoableChangeListener[] KeyboardFocusManager.getVetoableChangeListeners​()
      返回在此键盘焦点管理器上注册的所有否决变更监听器的数组。
      VetoableChangeListener[] KeyboardFocusManager.getVetoableChangeListeners​(String propertyName)
      返回与named属性相关联的所有 VetoableChangeListener的数组。
      Methods in java.awt with parameters of type VetoableChangeListener
      Modifier and Type 方法 描述
      void KeyboardFocusManager.addVetoableChangeListener​(VetoableChangeListener listener)
      将VetoableChangeListener添加到侦听器列表。
      void KeyboardFocusManager.addVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      将VetoableChangeListener添加到特定属性的侦听器列表中。
      void KeyboardFocusManager.removeVetoableChangeListener​(VetoableChangeListener listener)
      从侦听器列表中删除VetoableChangeListener。
      void KeyboardFocusManager.removeVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      从侦听器列表中为特定属性删除VetoableChangeListener。

    • Uses of VetoableChangeListener in java.beans

      Classes in java.beans that implement VetoableChangeListener
      Modifier and Type Class 描述
      class  VetoableChangeListenerProxy
      一个类扩展了 EventListenerProxy专门用于添加一个带有“约束”属性的 VetoableChangeListener 。
      Methods in java.beans that return VetoableChangeListener
      Modifier and Type 方法 描述
      VetoableChangeListener[] VetoableChangeSupport.getVetoableChangeListeners​()
      返回使用addVetoableChangeListener（）添加到VetoableChangeSupport对象的所有侦听器的数组。
      VetoableChangeListener[] VetoableChangeSupport.getVetoableChangeListeners​(String propertyName)
      返回与named属性相关联的所有侦听器的数组。
      Methods in java.beans with parameters of type VetoableChangeListener
      Modifier and Type 方法 描述
      void VetoableChangeSupport.addVetoableChangeListener​(VetoableChangeListener listener)
      将VetoableChangeListener添加到侦听器列表。
      void VetoableChangeSupport.addVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      为特定属性添加VetoableChangeListener。
      void VetoableChangeSupport.removeVetoableChangeListener​(VetoableChangeListener listener)
      从侦听器列表中删除VetoableChangeListener。
      void VetoableChangeSupport.removeVetoableChangeListener​(String propertyName, VetoableChangeListener listener)
      删除特定属性的VetoableChangeListener。
      Constructors in java.beans with parameters of type VetoableChangeListener
      Constructor 描述
      VetoableChangeListenerProxy​(String propertyName, VetoableChangeListener listener)
      构造函数将 VetoableChangeListener绑定到特定属性。

    • Uses of VetoableChangeListener in java.beans.beancontext

      Classes in java.beans.beancontext that implement VetoableChangeListener
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Methods in java.beans.beancontext that return VetoableChangeListener
      Modifier and Type 方法 描述
      protected static VetoableChangeListener BeanContextSupport.getChildVetoableChangeListener​(Object child)
      获取指定子节点的VetoableChangeListener（如果有）
      Methods in java.beans.beancontext with parameters of type VetoableChangeListener
      Modifier and Type 方法 描述
      void BeanContextChild.addVetoableChangeListener​(String name, VetoableChangeListener vcl)
      在此 BeanContextChild添加 VetoableChangeListener以在指定的属性更改时接收事件。
      void BeanContextChildSupport.addVetoableChangeListener​(String name, VetoableChangeListener vcl)
      为特定属性添加VetoableChangeListener。
      void BeanContextChild.removeVetoableChangeListener​(String name, VetoableChangeListener vcl)
      从此 BeanContextChild删除 VetoableChangeListener ，以便在指定的属性更改时不再收到事件。
      void BeanContextChildSupport.removeVetoableChangeListener​(String name, VetoableChangeListener vcl)
      删除一个 VetoableChangeListener 。

    • Uses of VetoableChangeListener in javax.swing

      Methods in javax.swing that return VetoableChangeListener
      Modifier and Type 方法 描述
      VetoableChangeListener[] JComponent.getVetoableChangeListeners​()
      返回在此组件上注册的所有可变更改监听器的数组。
      Methods in javax.swing with parameters of type VetoableChangeListener
      Modifier and Type 方法 描述
      void JComponent.addVetoableChangeListener​(VetoableChangeListener listener)
      添加 VetoableChangeListener到侦听器列表。
      void JComponent.removeVetoableChangeListener​(VetoableChangeListener listener)
      Removes a VetoableChangeListener from the listener list.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.beans.Visibility (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.beans.Visibility

  • Packages that use Visibility
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。

    • Uses of Visibility in java.beans.beancontext

      Subinterfaces of Visibility in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContext
      BeanContext对JavaBeans起着逻辑分层容器的作用。
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      Classes in java.beans.beancontext that implement Visibility
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      Methods in java.beans.beancontext that return Visibility
      Modifier and Type 方法 描述
      protected static Visibility BeanContextSupport.getChildVisibility​(Object child)
      获取与指定子项关联的组件（如果有）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


BufferedInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class BufferedInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class BufferedInputStream
extends FilterInputStream
    A BufferedInputStream为另一个输入流添加了功能，即缓冲输入并支持mark和reset方法的功能。 创建BufferedInputStream将创建一个内部缓冲区数组。 当从流中读取或跳过字节时，内部缓冲区将根据需要从所包含的输入流中重新填充，一次很多字节。 mark操作会记住输入流中的一个点，并且reset操作会导致从最近的mark操作读取的所有字节在从包含的输入流中取出新字节之前重新读取。
    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      存储数据的内部缓冲区数组。
      protected int count
      索引一大于缓冲区中最后一个有效字节的索引。
      protected int marklimit
      读取的最大的一个电话后，允许提前 mark后续调用方法之前 reset方法失败。
      protected int markpos
      在最后一个 mark方法的时候， pos字段的值被调用。
      protected int pos
      缓冲区中的当前位置。

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferedInputStream​(InputStream in)
      创建一个 BufferedInputStream并保存其参数，输入流 in供以后使用。
      BufferedInputStream​(InputStream in, int size)
      创建具有指定缓冲区大小的 BufferedInputStream ，并保存其参数，输入流 in供以后使用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void mark​(int readlimit)
      见 mark法 InputStream的一般合同。
      boolean markSupported​()
      测试此输入流是否支持 mark和 reset方法。
      int read​()
      见 read法 InputStream的一般合同。
      int read​(byte[] b, int off, int len)
      从给定的偏移开始，将字节输入流中的字节读入指定的字节数组。
      void reset​()
      见 reset法 InputStream的一般合同。
      long skip​(long n)
      见 skip法 InputStream的一般合同。

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • buf

        protected volatile byte[] buf
        存储数据的内部缓冲区数组。 必要时，可以用不同大小的另一个阵列代替。

      • count

        protected int count
        索引一大于缓冲区中最后一个有效字节的索引。 该值始终在0到buf.length ; 元素buf[0]至buf[count-1]包含从底层输入流获得的缓冲输入数据。

      • pos

        protected int pos
        缓冲区中的当前位置。 这是从buf数组读取的下一个字符的索引。

        该值始终在0到count 。 如果小于count ，则buf[pos]是作为输入提供的下一个字节; 如果它等于count ，则下一个read或skip操作将需要从包含的输入流读取更多的字节。

        另请参见：
        buf

      • markpos

        protected int markpos
        在调用最后一个mark方法时的pos字段的值。

        该值始终在-1到pos 。 如果输入流中没有标记位置，则此字段为-1 。 如果输入流中有一个标记的位置，那么buf[markpos]是reset操作后作为输入提供的第一个字节。 如果markpos不是-1 ，然后从位置的所有字节buf[markpos]通过buf[pos-1]必须保留在缓冲器阵列中（尽管它们可以被移动到缓冲器阵列中的另一个处，与适当的调整的值count ， pos ，和markpos ）; 除非pos与markpos之间的markpos超过marklimit否则不得丢弃。

        另请参见：
        mark(int) ， pos

      • marklimit

        protected int marklimit
        读取的最大的一个电话后，允许提前mark后续调用方法之前reset方法失败。 无论何时pos与markpos之间的pos超过marklimit ，那么通过将markpos设置为-1 ，标记可能会下降。
        另请参见：
        mark(int) ， reset()

    • 构造方法详细信息

      • BufferedInputStream

        public BufferedInputStream​(InputStream in)
        创建一个BufferedInputStream并保存其参数，输入流in供以后使用。 内部缓冲区数组被创建并存储在buf 。
        参数
        in - 底层输入流。

      • BufferedInputStream

        public BufferedInputStream​(InputStream in,
                           int size)
        创建具有指定缓冲区大小的BufferedInputStream ，并保存其参数，输入流in供以后使用。 长度为size的内部缓冲区阵列创建并存储在buf 。
        参数
        in - 底层输入流。
        size - 缓冲区大小。
        异常
        IllegalArgumentException - 如果是 size <= 0 。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        见 read法 InputStream的一般合同。
        重写：
        read在 FilterInputStream
        结果
        数据的下一个字节，如果达到流的末尾， -1 。
        异常
        IOException - 如果此输入流已通过调用其 close()方法已关闭，或发生I / O错误。
        另请参见：
        FilterInputStream.in

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从给定的偏移开始，将字节输入流中的字节读入指定的字节数组。

        该方法执行InputStream类相应的read方法的一般合同。 作为一个额外的方便，它尝试通过重复调用基础流的read方法来读取尽可能多的字节。 继续执行read直到满足下列条件之一为止：

        • 指定的字节数已被读取，
        • 底层流的read方法返回-1 ，表示文件末尾，或
        • 底层流的available方法返回零，表示进一步的输入请求将阻塞。
        如果基础流上的第一个read返回-1以指示文件结束，则此方法返回-1 。 否则，此方法返回实际读取的字节数。

        鼓励这个类的子类，但不是必需的，尝试以相同的方式读取尽可能多的字节。

        重写：
        read在 FilterInputStream
        参数
        b - 目的缓冲区。
        off - 开始存储字节的偏移量。
        len - 要读取的最大字节数。
        结果
        读取的字节数，如果已达到流的末尾， -1 。
        异常
        IOException - 如果此输入流已通过调用其 close()方法已关闭，或发生I / O错误。
        另请参见：
        FilterInputStream.in

      • skip

        public long skip​(long n)
          throws IOException
        见 skip法 InputStream的一般合同。
        重写：
        skip在 FilterInputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果此输入流已通过调用其 close()方法关闭，则 in.skip(n)将抛出IOException或发生I / O错误。

      • available

        public int available​()
              throws IOException
        从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。 下一个调用可能是同一个线程或另一个线程。 这个多个字节的单个读取或跳过将不会被阻塞，但可以读取或跳过较少的字节。

        该方法返回缓冲区中要读取的剩余字节数（ count - pos ）和调用in .available（）的结果。

        重写：
        available在 FilterInputStream
        结果
        可以从该输入流中读取（或跳过）不受阻塞的字节数的估计。
        异常
        IOException - 如果此输入流已通过调用其 close()方法关闭，或发生I / O错误。

      • mark

        public void mark​(int readlimit)
        见 mark法 InputStream的一般合同。
        重写：
        mark在 FilterInputStream
        参数
        readlimit - 标记位置无效之前可以读取的最大字节数。
        另请参见：
        reset()

      • reset

        public void reset​()
           throws IOException
        见reset法InputStream的一般合同。

        如果markpos是-1 （没有设置标记或标记已经无效），则抛出一个IOException 。 否则， pos设置为等于markpos 。

        重写：
        reset在 FilterInputStream
        异常
        IOException - 如果该流未被标记，或者如果该标记已被无效，或流已经通过调用其 close()方法而关闭，或发生I / O错误。
        另请参见：
        mark(int)

      • markSupported

        public boolean markSupported​()
        测试此输入流是否支持mark和reset方法。 该markSupported方法BufferedInputStream回报true 。
        重写：
        markSupported在 FilterInputStream
        结果
        一个 boolean表示这个流类型是否支持 mark和 reset方法。
        另请参见：
        InputStream.mark(int) ， InputStream.reset()

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。 一旦流已关闭，进一步的read（），available（），reset（）或skip（）调用将抛出IOException异常。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterInputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferedOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class BufferedOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.io.BufferedOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class BufferedOutputStream
extends FilterOutputStream
    该类实现缓冲输出流。 通过设置这样的输出流，应用程序可以向底层输出流写入字节，而不必为写入的每个字节导致底层系统的调用。
    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      存储数据的内部缓冲区。
      protected int count
      缓冲区中有效字节的数量。

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferedOutputStream​(OutputStream out)
      创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
      BufferedOutputStream​(OutputStream out, int size)
      创建一个新的缓冲输出流，以便以指定的缓冲区大小将数据写入指定的底层输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void flush​()
      刷新缓冲输出流。
      void write​(byte[] b, int off, int len)
      从偏移量 off开始的指定字节数组写入 len字节到缓冲输出流。
      void write​(int b)
      将指定的字节写入缓冲的输出流。

      • Methods inherited from class java.io.FilterOutputStream

        close, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • buf

        protected byte[] buf
        存储数据的内部缓冲区。

      • count

        protected int count
        缓冲区中有效字节的数量。 该值始终在0到buf.length ; 元素buf[0]至buf[count-1]包含有效的字节数据。

    • 构造方法详细信息

      • BufferedOutputStream

        public BufferedOutputStream​(OutputStream out)
        创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
        参数
        out - 底层输出流。

      • BufferedOutputStream

        public BufferedOutputStream​(OutputStream out,
                            int size)
        创建一个新的缓冲输出流，以便以指定的缓冲区大小将数据写入指定的底层输出流。
        参数
        out - 底层输出流。
        size - 缓冲区大小。
        异常
        IllegalArgumentException - 如果大小<= 0。

    • 方法详细信息

      • write

        public void write​(int b)
           throws IOException
        将指定的字节写入缓冲的输出流。
        重写：
        write在 FilterOutputStream
        参数
        b - 要写入的字节。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        从指定的字节数组写入len个字节，从偏移off开始，输出到缓冲的输出流。

        通常，该方法将给定数组的字节存储到此流的缓冲区中，根据需要将缓冲区刷新到底层输出流。 然而，如果请求的长度至少与此流的缓冲区一样大，那么这个方法将刷新缓冲区并将字节直接写入底层的输出流。 因此，冗余BufferedOutputStream不会不必要地复制数据。

        重写：
        write在 FilterOutputStream
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.write(int)

      • flush

        public void flush​()
           throws IOException
        刷新缓冲输出流。 这将强制任何缓冲输出字节写入底层输出流。
        Specified by:
        flush在接口 Flushable
        重写：
        flush在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferedReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class BufferedReader

  • java.lang.Object
    • java.io.Reader
      • java.io.BufferedReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable
    已知直接子类：
    LineNumberReader

    public class BufferedReader
extends Reader
    从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。

    可以指定缓冲区大小，或者可以使用默认大小。 默认值足够大，可用于大多数用途。

    通常，由读取器做出的每个读取请求将引起对底层字符或字节流的相应读取请求。 因此，建议将BufferedReader包装在其read（）操作可能昂贵的读取器上，例如FileReaders和InputStreamReaders。 例如，

      BufferedReader in
   = new BufferedReader(new FileReader("foo.in"));
    将缓冲指定文件的输入。 没有缓冲，每次调用read（）或readLine（）可能会导致从文件中读取字节，转换成字符，然后返回，这可能非常低效。

    使用DataInputStreams进行文本输入的程序可以通过用适当的BufferedReader替换每个DataInputStream进行本地化。

    从以下版本开始：
    1.1
    另请参见：
    FileReader ， InputStreamReader ， Files.newBufferedReader(java.nio.file.Path, java.nio.charset.Charset)

    • Field Summary

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferedReader​(Reader in)
      创建使用默认大小的输入缓冲区的缓冲字符输入流。
      BufferedReader​(Reader in, int sz)
      创建使用指定大小的输入缓冲区的缓冲字符输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流并释放与之相关联的任何系统资源。
      Stream<String> lines​()
      返回一个 Stream ，其元素是从这个 BufferedReader读取的行。
      void mark​(int readAheadLimit)
      标记流中的当前位置。
      boolean markSupported​()
      告诉这个流是否支持mark（）操作。
      int read​()
      读一个字符
      int read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      String readLine​()
      读一行文字。
      boolean ready​()
      告诉这个流是否准备好被读取。
      void reset​()
      将流重置为最近的标记。
      long skip​(long n)
      跳过字符

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        read, read

    • 构造方法详细信息

      • BufferedReader

        public BufferedReader​(Reader in,
                      int sz)
        创建使用指定大小的输入缓冲区的缓冲字符输入流。
        参数
        in - 读者
        sz - 输入缓冲区大小
        异常
        IllegalArgumentException - 如果是 sz <= 0

      • BufferedReader

        public BufferedReader​(Reader in)
        创建使用默认大小的输入缓冲区的缓冲字符输入流。
        参数
        in - 读者

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        读一个字符
        重写：
        read在 Reader
        结果
        字符读取，作为0到65535（ 0x00-0xffff ）范围内的整数，如果流的末尾已达到-1
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] cbuf,
                int off,
                int len)
         throws IOException
        将字符读入数组的一部分。

        该方法执行Reader类对应的read方法的一般合同。 作为一个额外的方便，它尝试通过重复调用基础流的read方法来读取尽可能多的字符。 这次迭代read继续，直到满足下列条件之一为止：

        • 指定的字符数已被读取，
        • 底层流的read方法返回-1 ，表示文件结束，或
        • 底层流的ready方法返回false ，表示进一步的输入请求将被阻塞。
        如果基础流上的第一个read返回-1以指示文件结束，则此方法返回-1 。 否则，此方法返回实际读取的字符数。

        鼓励这个类的子类，但不是必需的，尝试以相同的方式读取尽可能多的字符。

        通常这种方法从这个流的字符缓冲区中获取字符，并根据需要从底层流中填充它。 但是，如果缓冲区为空，则该标记无效，并且所请求的长度至少与缓冲区一样大，则该方法将直接从基础流中读取字符到给定的数组中。 因此，冗余BufferedReader将不会不必要地复制数据。

        Specified by:
        read在 Reader
        参数
        cbuf - 目标缓冲区
        off - 开始存储字符的偏移量
        len - 要读取的最大字符数
        结果
        读取的字符数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果发生I / O错误

      • readLine

        public String readLine​()
                throws IOException
        读一行文字。 一行被视为由换行符（'\ n'），回车符（'\ r'）中的任意一个，紧跟换行符的回车符或通过到达文件末尾终止（EOF）。
        结果
        一个包含行的内容的字符串，不包括任何行终止字符，如果没有读取任何字符，如果流的结尾已经到达，则为null
        异常
        IOException - 如果发生I / O错误
        另请参见：
        Files.readAllLines(java.nio.file.Path, java.nio.charset.Charset)

      • skip

        public long skip​(long n)
          throws IOException
        跳过字符
        重写：
        skip在 Reader
        参数
        n - 要跳过的字符数
        结果
        实际跳过的字符数
        异常
        IllegalArgumentException - 如果 n为负数。
        IOException - 如果发生I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好被读取。 如果缓冲区不为空，或者底层字符流准备就绪，则缓冲字符流就绪。
        重写：
        ready在 Reader
        结果
        如果下一个read（）保证不阻止输入，则为True，否则为false。 请注意，返回false并不能保证下一次读取将被阻止。
        异常
        IOException - 如果发生I / O错误

      • markSupported

        public boolean markSupported​()
        告诉这个流是否支持mark（）操作。
        重写：
        markSupported在 Reader
        结果
        当且仅当此流支持标记操作时才为真。

      • mark

        public void mark​(int readAheadLimit)
          throws IOException
        标记流中的当前位置。 对reset（）的后续调用将尝试将流重新定位到此位置。
        重写：
        mark在 Reader
        参数
        readAheadLimit - 限制仍然保留标记时可能读取的字符数。 在读取字符到此限制或超出之后尝试重新设置流可能会失败。 大于输入缓冲区大小的限制值将导致新的缓冲区被分配，其大小不小于limit。 因此，应谨慎使用大量值。
        异常
        IllegalArgumentException - 如果是 readAheadLimit < 0
        IOException - 如果发生I / O错误

      • reset

        public void reset​()
           throws IOException
        将流重置为最近的标记。
        重写：
        reset在 Reader
        异常
        IOException - 如果流未被标记，或者标记已被无效

      • close

        public void close​()
           throws IOException
        描述从类复制： Reader
        关闭流并释放与之相关联的任何系统资源。 一旦流已关闭，进一步的read（），ready（），mark（），reset（）或skip（）调用将抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Reader
        异常
        IOException - 如果发生I / O错误

      • lines

        public Stream<String> lines​()
        返回一个Stream ，其元素是从这个BufferedReader读取的行。 Stream是懒惰的人群，即只读在terminal stream operation期间。

        在执行终端流操作期间，读取器不能被操作。 否则，终端流操作的结果未定义。

        在执行终端流操作之后，不能保证读取器将处于从其读取下一个字符或行的特定位置。

        如果在访问底层的BufferedReader时抛出一个IOException ，它将被包裹在一个UncheckedIOException中 ，这将从引起读取的Stream方法抛出。 如果在关闭的BufferedReader中调用该方法，则此方法将返回一个Stream。 该流的任何操作需要在关闭之后从BufferedReader读取，将导致抛出UncheckedIOException异常。

        结果
        一个 Stream<String>提供了这个 BufferedReader描述的文本行
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BufferedWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class BufferedWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.BufferedWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable

    public class BufferedWriter
extends Writer
    将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。

    可以指定缓冲区大小，或者可以接受默认大小。 默认值足够大，可用于大多数用途。

    提供了一个newLine（）方法，它使用平台自己的系统属性line.separator定义的行分隔符概念。 并非所有平台都使用换行符（'\ n'）来终止行。 因此，调用此方法来终止每个输出行，因此优选直接写入换行符。

    一般来说，Writer将其输出立即发送到底层字符或字节流。 除非需要提示输出，否则建议将BufferedWriter包装在其write（）操作可能很昂贵的Writer上，例如FileWriters和OutputStreamWriters。 例如，

      PrintWriter out
   = new PrintWriter(new BufferedWriter(new FileWriter("foo.out")));
    将缓冲PrintWriter的输出到文件。 没有缓冲，每次调用print（）方法都会使字符转换为字节，然后立即写入文件，这可能非常低效。
    从以下版本开始：
    1.1
    另请参见：
    PrintWriter ， FileWriter ， OutputStreamWriter ， Files.newBufferedWriter(java.nio.file.Path, java.nio.charset.Charset, java.nio.file.OpenOption...)

    • Field Summary

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      BufferedWriter​(Writer out)
      创建使用默认大小的输出缓冲区的缓冲字符输出流。
      BufferedWriter​(Writer out, int sz)
      创建一个新的缓冲字符输出流，使用给定大小的输出缓冲区。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流，先刷新。
      void flush​()
      刷新流。
      void newLine​()
      写一行行分隔符。
      void write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void write​(int c)
      写一个字符
      void write​(String s, int off, int len)
      写一个字符串的一部分。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Writer

        append, append, append, write, write

    • 构造方法详细信息

      • BufferedWriter

        public BufferedWriter​(Writer out)
        创建使用默认大小的输出缓冲区的缓冲字符输出流。
        参数
        out - 作家

      • BufferedWriter

        public BufferedWriter​(Writer out,
                      int sz)
        创建一个新的缓冲字符输出流，使用给定大小的输出缓冲区。
        参数
        out - 作家
        sz - 输出缓冲区大小，正整数
        异常
        IllegalArgumentException - 如果是 sz <= 0

    • 方法详细信息

      • write

        public void write​(int c)
           throws IOException
        写一个字符
        重写：
        write在 Writer
        参数
        c - int指定要写入的字符
        异常
        IOException - 如果发生I / O错误

      • write

        public void write​(char[] cbuf,
                  int off,
                  int len)
           throws IOException
        写入字符数组的一部分。

        通常，此方法将给定数组中的字符存储到此流的缓冲区中，根据需要将缓冲区刷新到底层流。 然而，如果请求的长度至少与缓冲区一样大，那么这个方法将刷新缓冲区并将这些字符直接写入底层流。 因此，冗余BufferedWriter不会不必要地复制数据。

        Specified by:
        write在 Writer
        参数
        cbuf - 一个字符数组
        off - 开始读取字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定数组的长度
        IOException - 如果发生I / O错误

      • write

        public void write​(String s,
                  int off,
                  int len)
           throws IOException
        写一个字符串的一部分。
        重写：
        write在 Writer
        实现要求：
        虽然superclass中此方法的规范建议如果len为负数或off + len为负值，则抛出一个IndexOutOfBoundsException ，在此类中的实现不会在这些情况下抛出这样的异常，而只是不写入任何字符。
        参数
        s - 要写入的字符串
        off - 开始读取字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 off + len大于给定字符串的长度
        IOException - 如果发生I / O错误

      • newLine

        public void newLine​()
             throws IOException
        写一行行分隔符。 行分隔符字符串由系统属性line.separator定义，并不一定是单个换行符（'\ n'）字符。
        异常
        IOException - 如果发生I / O错误

      • flush

        public void flush​()
           throws IOException
        刷新流。
        Specified by:
        flush在接口 Flushable
        Specified by:
        flush在类 Writer
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
           throws IOException
        描述从类别复制Writer
        关闭流，先刷新。 一旦流已关闭，进一步的write（）或flush（）调用将导致抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Writer
        异常
        IOException - If an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ByteArrayInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ByteArrayInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.ByteArrayInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class ByteArrayInputStream
extends InputStream
    A ByteArrayInputStream包含一个内部缓冲区，其中包含可以从流中读取的字节。 内部计数器跟踪由read方法提供的下一个字节。

    关闭一个ByteArrayInputStream没有任何效果。 该流中的方法可以在流关闭后调用，而不生成IOException 。

    从以下版本开始：
    1.0
    另请参见：
    StringBufferInputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      由数据流的创建者提供的字节数组。
      protected int count
      索引一大于输入流缓冲区中的最后一个有效字符。
      protected int mark
      流中当前标记的位置。
      protected int pos
      从输入流缓冲区读取的下一个字符的索引。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ByteArrayInputStream​(byte[] buf)
      创建一个 ByteArrayInputStream ，使其使用 buf作为其缓冲区数组。
      ByteArrayInputStream​(byte[] buf, int offset, int length)
      创建 ByteArrayInputStream使用 buf作为其缓冲器阵列。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      返回可从此输入流读取（或跳过）的剩余字节数。
      void close​()
      关闭一个 ByteArrayInputStream没有任何效果。
      void mark​(int readAheadLimit)
      设置流中当前标记的位置。
      boolean markSupported​()
      测试这个 InputStream支持标记/复位。
      int read​()
      从该输入流读取下一个数据字节。
      int read​(byte[] b, int off, int len)
      从该输入流读取最多 len个字节的数据到字节数组。
      void reset​()
      将缓冲区重置为标记位置。
      long skip​(long n)
      跳过此输入流的 n字节输入。

      • Methods inherited from class java.io.InputStream

        read, readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • buf

        protected byte[] buf
        由数据流的创建者提供的字节数组。 元素buf[0]至buf[count-1]是唯一可以从流中读取的字节; 元素buf[pos]是要读取的下一个字节。

      • pos

        protected int pos
        从输入流缓冲区读取的下一个字符的索引。 该值应始终为非负数，不得大于值count 。 要从输入流缓冲区读取的下一个字节将为buf[pos] 。

      • mark

        protected int mark
        流中当前标记的位置。 当构造时，ByteArrayInputStream对象在默认情况下标记为零。 它们可能被mark()方法标记在缓冲区内的另一个位置。 目前的缓冲区位置由reset()方法设置。

        如果没有设置标记，则标记的值是传递给构造函数的偏移量（如果没有提供偏移量，则为0）。

        从以下版本开始：
        1.1

      • count

        protected int count
        索引一大于输入流缓冲区中的最后一个有效字符。 该值应始终为非负数，不得大于buf的长度。 它大于buf中可以从输入流缓冲区读取的最后一个字节的位置。

    • 构造方法详细信息

      • ByteArrayInputStream

        public ByteArrayInputStream​(byte[] buf)
        创建一个ByteArrayInputStream ，使其使用buf作为其缓冲区数组。 缓冲区数组不被复制。 的初始值pos是0和的初始值count是长度buf 。
        参数
        buf - 输入缓冲区。

      • ByteArrayInputStream

        public ByteArrayInputStream​(byte[] buf,
                            int offset,
                            int length)
        创建ByteArrayInputStream使用buf作为其缓冲器阵列。 的初始值pos是offset和的初始值count是最小offset+length和buf.length 。 缓冲区数组不被复制。 缓冲区的标记设置为指定的偏移量。
        参数
        buf - 输入缓冲区。
        offset - 要读取的第一个字节的缓冲区中的偏移量。
        length - 从缓冲区读取的最大字节数。

    • 方法详细信息

      • read

        public int read​()
        从该输入流读取下一个数据字节。 值字节以int范围内的0到255 。 如果没有字节可用，因为已经到达流的末尾，则返回值-1 。

        这个read方法不能阻止。

        Specified by:
        read在 InputStream
        结果
        数据的下一个字节，如果已经达到流的末尾， -1 。

      • read

        public int read​(byte[] b,
                int off,
                int len)
        从该输入流读取最多len个字节的数据到字节数组。 如果pos等于count ，则返回-1以指示文件结束。 否则，读取的字节数k等于len和count-pos的较小者。 如果k为正，则buf[pos]至buf[pos+k-1]字节以由System.arraycopy执行的方式复制到b[off]至b[off+k-1]中。 值k被添加到pos并返回k 。

        这个read方法不能阻止。

        重写：
        read在 InputStream
        参数
        b - 读取数据的缓冲区。
        off - 目标阵列 b的起始偏移量
        len - 读取的最大字节数。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾，那么这个字节是 -1 。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负， len为负数，或 len为 b.length - off
        另请参见：
        InputStream.read()

      • skip

        public long skip​(long n)
        从此输入流跳过n个字节的输入。 如果达到输入流的结尾，则可能会跳过更少的字节。 要跳过的字节的实数为k等于n和count-pos的较小者。 值k被添加到pos并返回k 。
        重写：
        skip在 InputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。

      • available

        public int available​()
        返回可从此输入流读取（或跳过）的剩余字节数。

        返回的值为count - pos ，即从输入缓冲区读取的剩余字节数。

        重写：
        available在 InputStream
        结果
        可以从该输入流中读取（或跳过）而不阻塞的剩余字节数。

      • markSupported

        public boolean markSupported​()
        测试InputStream支持标记/复位。 markSupported方法ByteArrayInputStream总是返回true 。
        重写：
        markSupported InputStream
        结果
        true如果这个流实例支持标记和重置方法; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        InputStream.mark(int) ， InputStream.reset()

      • mark

        public void mark​(int readAheadLimit)
        设置流中当前标记的位置。 当构造时，ByteArrayInputStream对象在默认情况下标记为零。 它们可以通过此方法标记在缓冲区内的另一个位置。

        如果没有设置标记，则标记的值是传递给构造函数的偏移量（如果没有提供偏移量，则为0）。

        注意：这个类的readAheadLimit没有意义。

        重写：
        mark在 InputStream
        参数
        readAheadLimit - 标记位置无效之前可以读取的最大字节数限制。
        从以下版本开始：
        1.1
        另请参见：
        InputStream.reset()

      • reset

        public void reset​()
        将缓冲区重置为标记位置。 标记位置为0，除非在构造函数中指定了另一个位置或者指定了一个偏移量。
        重写：
        reset在 InputStream
        另请参见：
        InputStream.mark(int) ， IOException

      • close

        public void close​()
           throws IOException
        关闭一个ByteArrayInputStream没有任何效果。 可以在流关闭后调用此类中的方法，而不生成IOException 。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 InputStream
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ByteArrayOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ByteArrayOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.ByteArrayOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class ByteArrayOutputStream
extends OutputStream
    该类实现了将数据写入字节数组的输出流。 当数据写入缓冲区时，缓冲区会自动增长。 可以使用toByteArray()和toString()检索数据。

    关闭ByteArrayOutputStream没有任何效果。 在关闭流之后，可以调用此类中的方法，而不生成IOException 。

    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      存储数据的缓冲区。
      protected int count
      缓冲区中有效字节的数量。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ByteArrayOutputStream​()
      创建一个新的字节数组输出流。
      ByteArrayOutputStream​(int size)
      创建一个新的字节数组输出流，具有指定大小的缓冲区容量（以字节为单位）。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void close​()
      关闭一个 ByteArrayOutputStream没有任何效果。
      void reset​()
      将此字节数组输出流的 count字段重置为零，以便丢弃输出流中当前累积的所有输出。
      int size​()
      返回缓冲区的当前大小。
      byte[] toByteArray​()
      创建一个新分配的字节数组。
      String toString​()
      使用平台的默认字符集将缓冲区内容转换为字符串解码字节。
      String toString​(int hibyte)
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1的，要做到这一点的优选方法是通过toString(String enc)方法，它需要一个编码名称参数或toString()方法，它使用平台的默认字符编码。
      String toString​(String charsetName)
      通过使用命名的charset解码字节将缓冲区的内容转换为字符串。
      void write​(byte[] b, int off, int len)
      将 len字节从指定的字节数组开始，从偏移量 off开始写入此字节数组输出流。
      void write​(int b)
      将指定的字节写入此字节数组输出流。
      void writeTo​(OutputStream out)
      将此字节数组输出流的完整内容写入指定的输出流参数，就像使用 out.write(buf, 0, count)调用输出流的写入方法 out.write(buf, 0, count) 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.io.OutputStream

        flush, write

    • 字段详细信息

      • buf

        protected byte[] buf
        存储数据的缓冲区。

      • count

        protected int count
        缓冲区中有效字节的数量。

    • 构造方法详细信息

      • ByteArrayOutputStream

        public ByteArrayOutputStream​()
        创建一个新的字节数组输出流。 缓冲区容量最初为32字节，但如果需要，其容量会增加。

      • ByteArrayOutputStream

        public ByteArrayOutputStream​(int size)
        创建一个新的字节数组输出流，具有指定大小的缓冲区容量（以字节为单位）。
        参数
        size - 初始尺寸。
        异常
        IllegalArgumentException - 如果大小为负。

    • 方法详细信息

      • write

        public void write​(int b)
        将指定的字节写入此字节数组输出流。
        Specified by:
        write在 OutputStream
        参数
        b - 要写入的字节。

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
        从指定的字节数组写入 len字节，从偏移 off开始， off到这个字节数组输出流。
        重写：
        write在 OutputStream
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。

      • writeTo

        public void writeTo​(OutputStream out)
             throws IOException
        将此字节数组输出流的完整内容写入指定的输出流参数，就像使用 out.write(buf, 0, count)调用输出流的写入方法 out.write(buf, 0, count) 。
        参数
        out - 要写入数据的输出流。
        异常
        IOException - 如果发生I / O错误。

      • reset

        public void reset​()
        将此字节数组输出流的count字段重置为零，以便丢弃输出流中当前累积的所有输出。 可以再次使用输出流，重用已经分配的缓冲区空间。
        另请参见：
        ByteArrayInputStream.count

      • toByteArray

        public byte[] toByteArray​()
        创建一个新分配的字节数组。 其大小是此输出流的当前大小，缓冲区的有效内容已被复制到其中。
        结果
        该输出流的当前内容，作为字节数组。
        另请参见：
        size()

      • size

        public int size​()
        返回缓冲区的当前大小。
        结果
        count字段的值，这是此输出流中有效字节的数量。
        另请参见：
        count

      • toString

        public String toString​()
        使用平台的默认字符集将缓冲区内容转换为字符串解码字节。 新的String的长度是字符集的函数，因此可能不等于缓冲区的大小。

        该方法总是使用默认替换字符串替换格式错误的输入和不可映射的字符序列，用于平台的默认字符集。 当需要更多的解码过程控制时，应使用CharsetDecoder类。

        重写：
        toString在 Object
        结果
        从缓冲区的内容中解码字符串。
        从以下版本开始：
        1.1

      • toString

        public String toString​(String charsetName)
                throws UnsupportedEncodingException
        通过使用命名的charset解码字节将缓冲区的内容转换为字符串。 新的String的长度是字符集的函数，因此可能不等于字节数组的长度。

        此方法总是用此字符集的默认替换字符串替换格式错误的输入和不可映射字符序列。 当需要对解码过程进行更多控制时，应使用CharsetDecoder类。

        参数
        charsetName - 支持的名称charset
        结果
        从缓冲区的内容中解码字符串。
        异常
        UnsupportedEncodingException - 如果不支持命名的字符集
        从以下版本开始：
        1.1

      • toString

        @Deprecated
public String toString​(int hibyte)
        已过时。 此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过toString(String enc)方法，它采用encoding-name参数，或toString()方法，该方法使用平台的默认字符编码。
        创建一个新分配的字符串。 其大小是输出流的当前大小，并且缓冲区的有效内容已被复制到其中。 结果字符串中的每个字符c由字节数组中的相应元素b构成 ，使得：

     c == (char)(((hibyte & 0xff) << 8) | (b & 0xff))
        参数
        hibyte - 每个生成的Unicode字符的高字节。
        结果
        输出流的当前内容，作为一个字符串。
        另请参见：
        size() ， toString(String) ， toString()

      • close

        public void close​()
           throws IOException
        关闭一个ByteArrayOutputStream没有任何效果。 在流关闭后可以调用此类中的方法，而不生成IOException 。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 OutputStream
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CharArrayReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class CharArrayReader

  • java.lang.Object
    • java.io.Reader
      • java.io.CharArrayReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable

    public class CharArrayReader
extends Reader
    该类实现了一个字符缓冲区，可以用作字符输入流。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected char[] buf
      字符缓冲区。
      protected int count
      这个缓冲区结束的索引。
      protected int markedPos
      标记在缓冲区中的位置。
      protected int pos
      当前的缓冲位置。

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      CharArrayReader​(char[] buf)
      从指定的字符数组中创建CharArrayReader。
      CharArrayReader​(char[] buf, int offset, int length)
      从指定的字符数组中创建CharArrayReader。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流并释放与之相关联的任何系统资源。
      void mark​(int readAheadLimit)
      标记流中的当前位置。
      boolean markSupported​()
      告诉这个流是否支持mark（）操作。
      int read​()
      读一个字符
      int read​(char[] b, int off, int len)
      将字符读入数组的一部分。
      boolean ready​()
      告诉这个流是否准备好被读取。
      void reset​()
      将流重新设置为最近的标记，或将其重新设置为从未被标记的开始。
      long skip​(long n)
      跳过字符

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        read, read

    • 字段详细信息

      • buf

        protected char[] buf
        字符缓冲区。

      • pos

        protected int pos
        当前的缓冲位置。

      • markedPos

        protected int markedPos
        标记在缓冲区中的位置。

      • count

        protected int count
        这个缓冲区结束的索引。 此索引之外没有有效的数据。

    • 构造方法详细信息

      • CharArrayReader

        public CharArrayReader​(char[] buf)
        从指定的字符数组中创建CharArrayReader。
        参数
        buf - 输入缓冲区（未复制）

      • CharArrayReader

        public CharArrayReader​(char[] buf,
                       int offset,
                       int length)
        从指定的字符数组中创建CharArrayReader。

        得到的读者将在给定的offset开始阅读。 该读卡器可以读取的char个数字将为length或buf.length-offset ，以较小者为准。

        参数
        buf - 输入缓冲区（未复制）
        offset - 要读取的第一个字符的偏移量
        length - 要读取的字符数
        异常
        IllegalArgumentException - 如果 offset为负或大于 buf.length ，或者如果 length为负，或者如果这两个值之和为负。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        读一个字符
        重写：
        read在 Reader
        结果
        字符读取，作为0到65535（ 0x00-0xffff ）范围内的整数，如果已经达到流的末尾， 0x00-0xffff -1。
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] b,
                int off,
                int len)
         throws IOException
        将字符读入数组的一部分。
        Specified by:
        read在 Reader
        参数
        b - 目的缓冲区
        off - 开始存储字符的偏移量
        len - 要读取的最大字符数
        结果
        读取的实际字符数，如果已达到流的末尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果发生I / O错误

      • skip

        public long skip​(long n)
          throws IOException
        跳过字符 返回跳过的字符数。

        n参数可能为负数，即使在这种情况下， Reader超类的skip方法抛出异常。 如果n为负数，则此方法不执行任何操作并返回0 。

        重写：
        skip在 Reader
        参数
        n - 要跳过的字符数
        结果
        实际跳过的字符数
        异常
        IOException - 如果流关闭，或发生I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好被读取。 字符阵列阅读器总是准备好阅读。
        重写：
        ready在 Reader
        结果
        如果下一个read（）保证不阻止输入，则为True，否则为false。 请注意，返回false并不能保证下一次读取将被阻止。
        异常
        IOException - 如果发生I / O错误

      • markSupported

        public boolean markSupported​()
        告诉这个流是否支持mark（）操作。
        重写：
        markSupported在 Reader
        结果
        当且仅当此流支持标记操作时才为真。

      • mark

        public void mark​(int readAheadLimit)
          throws IOException
        标记流中的当前位置。 对reset（）的后续调用将会将流重新定位到此位置。
        重写：
        mark在 Reader
        参数
        readAheadLimit - 限制仍然保留标记时可能读取的字符数。 因为流的输入来自字符数组，没有实际的限制; 因此这个论点被忽略。
        异常
        IOException - 如果发生I / O错误

      • reset

        public void reset​()
           throws IOException
        将流重新设置为最近的标记，或将其重新设置为从未被标记的开始。
        重写：
        reset在 Reader
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
        关闭流并释放与之相关联的任何系统资源。 一旦流已关闭，进一步的read（），ready（），mark（），reset（）或skip（）调用将抛出IOException。 关闭以前关闭的流无效。 当读取器上有另一个线程阻塞时，此方法将阻止。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Reader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CharArrayWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class CharArrayWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.CharArrayWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable

    public class CharArrayWriter
extends Writer
    该类实现了可以用作Writer的字符缓冲区。 当数据写入流时，缓冲区会自动增长。 可以使用toCharArray（）和toString（）检索数据。

    注意：在此类上调用close（）没有任何效果，并且流已关闭而不生成IOException时可以调用此类的方法。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected char[] buf
      存储数据的缓冲区。
      protected int count
      缓冲区中的字符数。

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      CharArrayWriter​()
      创建一个新的CharArrayWriter。
      CharArrayWriter​(int initialSize)
      用指定的初始大小创建一个新的CharArrayWriter。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      CharArrayWriter append​(char c)
      将指定的字符附加到此作者。
      CharArrayWriter append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      CharArrayWriter append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      void close​()
      关闭流。
      void flush​()
      冲洗流。
      void reset​()
      重置缓冲区，以便您可以再次使用它，而不会丢弃已经分配的缓冲区。
      int size​()
      返回缓冲区的当前大小。
      char[] toCharArray​()
      返回输入数据的副本。
      String toString​()
      将输入数据转换为字符串。
      void write​(char[] c, int off, int len)
      将字符写入缓冲区。
      void write​(int c)
      将一个字符写入缓冲区。
      void write​(String str, int off, int len)
      将一部分字符串写入缓冲区。
      void writeTo​(Writer out)
      将缓冲区的内容写入另一个字符流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.io.Writer

        write, write

    • 字段详细信息

      • buf

        protected char[] buf
        存储数据的缓冲区。

      • count

        protected int count
        缓冲区中的字符数。

    • 构造方法详细信息

      • CharArrayWriter

        public CharArrayWriter​()
        创建一个新的CharArrayWriter。

      • CharArrayWriter

        public CharArrayWriter​(int initialSize)
        用指定的初始大小创建一个新的CharArrayWriter。
        参数
        initialSize - 指定初始缓冲区大小的int。
        异常
        IllegalArgumentException - 如果initialSize为负数

    • 方法详细信息

      • write

        public void write​(int c)
        将一个字符写入缓冲区。
        重写：
        write在 Writer
        参数
        c - int指定要写入的字符

      • write

        public void write​(char[] c,
                  int off,
                  int len)
        将字符写入缓冲区。
        Specified by:
        write在 Writer
        参数
        c - 要写入的数据
        off - 数据中的起始偏移量
        len - 写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定数组的长度

      • write

        public void write​(String str,
                  int off,
                  int len)
        将一部分字符串写入缓冲区。
        重写：
        write在 Writer
        参数
        str - 要写入的字符串
        off - 开始读取字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定字符串的长度

      • writeTo

        public void writeTo​(Writer out)
             throws IOException
        将缓冲区的内容写入另一个字符流。
        参数
        out - 要写入的输出流
        异常
        IOException - 如果发生I / O错误。

      • append

        public CharArrayWriter append​(CharSequence csq)
        将指定的字符序列附加到此作者。

        这种out.append(csq)形式的方法的调用与调用的方式完全相同

          out.write(csq.toString())

        取决于规范toString字符序列csq ，整个序列可以不追加。 例如，调用字符缓冲区的toString方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

        Specified by:
        append接口 Appendable
        重写：
        append在 Writer
        参数
        csq - 要附加的字符序列。 如果csq为null ，则该"null"器附加四个字符"null" 。
        结果
        这位作家
        从以下版本开始：
        1.5

      • append

        public CharArrayWriter append​(CharSequence csq,
                              int start,
                              int end)
        将指定字符序列的子序列附加到此作者。

        形式的这种方法的调用out.append(csq, start, end)时csq不是null ，行为以完全相同的方式调用

          out.write(csq.subSequence(start, end).toString())
        Specified by:
        append在接口 Appendable
        重写：
        append在 Writer
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，那么字符将被追加，就像csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        这位作家
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，则 start大于 end ，或 end大于 csq.length()
        从以下版本开始：
        1.5

      • append

        public CharArrayWriter append​(char c)
        将指定的字符附加到此作者。

        调用此方法的形式为out.append(c)行为与调用的方式完全相同

          out.write(c)
        Specified by:
        append在接口 Appendable
        重写：
        append在 Writer
        参数
        c - 要追加的16位字符
        结果
        这位作家
        从以下版本开始：
        1.5

      • reset

        public void reset​()
        重置缓冲区，以便您可以再次使用它，而不会丢弃已经分配的缓冲区。

      • toCharArray

        public char[] toCharArray​()
        返回输入数据的副本。
        结果
        一组从输入数据复制的字符。

      • size

        public int size​()
        返回缓冲区的当前大小。
        结果
        一个表示当前缓冲区大小的int。

      • toString

        public String toString​()
        将输入数据转换为字符串。
        重写：
        toString在 Object
        结果
        字符串。

      • flush

        public void flush​()
        冲洗流。
        Specified by:
        flush接口 Flushable
        Specified by:
        flush在 Writer

      • close

        public void close​()
        关闭流。 此方法不释放缓冲区，因为它的内容可能仍然需要。 注意：在此类中调用此方法将不起作用。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Writer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CharConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class CharConversionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.CharConversionException
  • All Implemented Interfaces:
    Serializable

    public class CharConversionException
extends IOException
    字符转换异常的基类。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CharConversionException​()
      这不提供详细的信息。
      CharConversionException​(String s)
      这提供了详细的信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CharConversionException

        public CharConversionException​()
        这不提供详细的信息。

      • CharConversionException

        public CharConversionException​(String s)
        这提供了详细的信息。
        参数
        s - 与异常关联的详细消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Closeable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface Closeable

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    AsynchronousByteChannel ， AsynchronousChannel ， ByteChannel ， Channel ， DirectoryStream<T> ， GatheringByteChannel ， ImageInputStream ， ImageOutputStream ， InterruptibleChannel ， JavaFileManager ， JMXConnector ， ModuleReader ， MulticastChannel ， NetworkChannel ， ReadableByteChannel ， RMIConnection ， ScatteringByteChannel ， SecureDirectoryStream<T> ， SeekableByteChannel ， StandardJavaFileManager ， WatchService ， WritableByteChannel
    所有已知实现类：
    AbstractInterruptibleChannel ， AbstractSelectableChannel ， AbstractSelector ， AsynchronousFileChannel ， AsynchronousServerSocketChannel ， AsynchronousSocketChannel ， AudioInputStream ， BufferedInputStream ， BufferedOutputStream ， BufferedReader ， BufferedWriter ， ByteArrayInputStream ， ByteArrayOutputStream ， CharArrayReader ， CharArrayWriter ， CheckedInputStream ， CheckedOutputStream ， CipherInputStream ， CipherOutputStream ， DatagramChannel ， DatagramSocket ， DataInputStream ， DataOutputStream ， DeflaterInputStream ， DeflaterOutputStream ， DigestInputStream ， DigestOutputStream ， FileCacheImageInputStream ， FileCacheImageOutputStream ， FileChannel ， FileImageInputStream ， FileImageOutputStream ， FileInputStream ， FileOutputStream ， FileReader ， FileSystem ， FileWriter ， FilterInputStream ， FilterOutputStream ， FilterReader ， FilterWriter ， Formatter ， ForwardingJavaFileManager ， GZIPInputStream ， GZIPOutputStream ， ImageInputStreamImpl ， ImageOutputStreamImpl ， InflaterInputStream ， InflaterOutputStream ， InputStream ， InputStream ， InputStream ， InputStreamReader ， JarFile ， JarInputStream ， JarOutputStream JarOutputStream ， LineNumberInputStream ， LineNumberReader ， LogStream ， MemoryCacheImageInputStream ， MemoryCacheImageOutputStream ， MLet ， MulticastSocket ， ObjectInputStream ， ObjectOutputStream ， OutputStream ， OutputStream ， OutputStream ， OutputStreamWriter ， Pipe.SinkChannel ， Pipe.SourceChannel ， PipedInputStream ， PipedOutputStream ， PipedReader ， PipedWriter ， PrintStream ， PrintWriter ， PrivateMLet ， ProgressMonitorInputStream ， PushbackInputStream ， PushbackReader ， RandomAccessFile ， Reader ， RMIConnectionImpl ， RMIConnectionImpl_Stub ， RMIConnector ， RMIIIOPServerImpl ， RMIJRMPServerImpl ， RMIServerImpl ， Scanner ， SctpChannel ， SctpMultiChannel ， SctpServerChannel ， SelectableChannel ， Selector ， SequenceInputStream ， ServerSocket ， ServerSocketChannel ， Socket ， SocketChannel ， SSLServerSocket ， SSLSocket ， StringBufferInputStream ， StringReader ， StringWriter ， URLClassLoader ， URLReader ， Writer ， ZipFile ， ZipInputStream ， ZipOutputStream

    public interface Closeable
extends AutoCloseable
    A Closeable是可以关闭的数据的源或目的地。 调用close方法来释放对象持有的资源（如打开的文件）。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此流并释放与之相关联的任何系统资源。

    • 方法详细信息

      • close

        void close​()
    throws IOException
        关闭此流并释放与之相关联的任何系统资源。 如果流已经关闭，则调用此方法将不起作用。

        如AutoCloseable.close()所述，关闭可能失败的情况需要仔细注意。 强烈建议放弃相关资源，并将Closeable内部标记为关闭，然后再投入IOException 。

        Specified by:
        close在接口 AutoCloseable
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Console (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class Console

  • java.lang.Object
    • java.io.Console
  • All Implemented Interfaces:
    Flushable

    public final class Console
extends Object
implements Flushable
    访问与当前Java虚拟机关联的基于字符的控制台设备（如果有的话）的方法。

    虚拟机是否具有控制台取决于底层平台以及虚拟机的调用方式。 如果虚拟机从交互式命令行启动，而不重定向标准输入和输出流，则其控制台将存在，并且通常将连接到启动虚拟机的键盘和显示器。 如果虚拟机是自动启动的，例如由后台作业调度程序启动，则通常不具有控制台。

    如果这个虚拟机有一个控制台，那么它由一个这个类的唯一实例表示，可以通过调用System.console()方法获得。 如果没有控制台设备可用，则该方法的调用将返回null 。

    读取和写入操作是同步的，以保证关键操作的原子完成; 因此调用方法readLine() ， readPassword() ， format() ， printf()以及读，格式和写在由返回的对象的操作reader()和writer()在多线程方案可能阻塞。

    对reader()和writer()返回的对象调用close()不会关闭这些对象的底层流。

    当达到控制台输入流的结尾时，控制台读取方法返回null ，例如在Windows上通过在Unix或control-Z上键入control-D。 如果以后在控制台的输入设备上输入其他字符，后续读取操作将成功。

    除非另有说明，否则传递null参数到null中的任何方法将导致抛出NullPointerException 。

    安全注意事项：如果应用程序需要读取密码或其他安全数据，则应使用readPassword()或readPassword(String, Object...)，并在处理后手动归零返回的字符数组，以最小化内存中敏感数据的生命周期。

 Console cons;
 char[] passwd;
 if ((cons = System.console()) != null &&
     (passwd = cons.readPassword("[%s]", "Password:")) != null) {
     ...
     java.util.Arrays.fill(passwd, ' ');
 }
    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void flush​()
      刷新控制台并强制任何缓冲输出立即写入。
      Console format​(String fmt, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流。
      Console printf​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流的便利方法。
      Reader reader​()
      检索与此控制台关联的唯一的Reader对象。
      String readLine​()
      从控制台读取一行文本。
      String readLine​(String fmt, Object... args)
      提供一个格式化的提示，然后从控制台读取一行文本。
      char[] readPassword​()
      从禁用回音的控制台读取密码或密码
      char[] readPassword​(String fmt, Object... args)
      提供一个格式化的提示，然后从禁用回显的控制台读取密码或密码。
      PrintWriter writer​()
      检索与此控制台关联的唯一的PrintWriter对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • writer

        public PrintWriter writer​()
        检索与此控制台关联的唯一的PrintWriter对象。
        结果
        与此控制台关联的打印作者

      • reader

        public Reader reader​()
        检索与此控制台关联的唯一的Reader对象。

        该方法旨在由复杂的应用程序使用，例如， Scanner对象，其利用由Scanner提供的丰富的解析/扫描功能：

         Console con = System.console();
 if (con != null) {
     Scanner sc = new Scanner(con.reader());
     ...
 }

        对于仅需要线性读取的简单应用，请使用readLine(java.lang.String, java.lang.Object...) 。

        批量读取操作read(char[]) ， read(char[], int, int) 和read(java.nio.CharBuffer)对返回的对象不会超出开往每次调用行字符读，即使目标缓冲区有更多字符的空间。 如果在控制台的输入设备上没有输入或到达线路绑定，则Reader的read方法可能会被阻止。 行界限被认为是换行符（ '\n' ），回车（ '\r' ），后跟换行的回车符或流结束中的任何一个。

        结果
        阅读器与此控制台关联

      • format

        public Console format​(String fmt,
                      Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流。
        参数
        fmt - Format string syntax中描述的格式字符串
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        这个控制台
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。

      • printf

        public Console printf​(String format,
                      Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流的便利方法。

        对这种con.printf(format, args)形式的方法的调用与调用的方式完全相同

          con.format(format, args)
        。
        参数
        format -如在描述的格式字符串 Format string syntax 。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        这个控制台
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。

      • readLine

        public String readLine​(String fmt,
                       Object... args)
        提供一个格式化的提示，然后从控制台读取一行文本。
        参数
        fmt -如在描述的格式字符串 Format string syntax 。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。
        结果
        包含从控制台读取的行的字符串，不包括任何行终止字符，如果已达到流结尾， null 。
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        IOError - 如果发生I / O错误。

      • readLine

        public String readLine​()
        从控制台读取一行文本。
        结果
        包含从控制台读取的行的字符串，不包括任何行终止字符，如果已达到流结尾， null 。
        异常
        IOError - 如果发生I / O错误。

      • readPassword

        public char[] readPassword​(String fmt,
                           Object... args)
        提供一个格式化的提示，然后从禁用回显的控制台读取密码或密码。
        参数
        fmt - 针对提示文本的 Format string syntax中所述的格式字符串。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。
        结果
        包含从控制台读取的密码或密码短语的字符数组，不包括任何行终止字符，如果已达到流的末尾， null 。
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        IOError - 如果发生I / O错误。

      • readPassword

        public char[] readPassword​()
        从禁用回音的控制台读取密码或密码
        结果
        包含从控制台读取的密码或密码短语的字符数组，不包括任何行终止字符，如果已达到流结尾， null 。
        异常
        IOError - 如果发生I / O错误。

      • flush

        public void flush​()
        刷新控制台并强制任何缓冲输出立即写入。
        Specified by:
        flush在接口 Flushable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface DataInput

  • All Known Subinterfaces:
    ImageInputStream ， ImageOutputStream ， JNLPRandomAccessFile ， ObjectInput
    所有已知实现类：
    DataInputStream ， FileCacheImageInputStream ， FileCacheImageOutputStream ， FileImageInputStream ， FileImageOutputStream ， ImageInputStreamImpl ， ImageOutputStreamImpl ， MemoryCacheImageInputStream ， MemoryCacheImageOutputStream ， ObjectInputStream ， RandomAccessFile

    public interface DataInput
    DataInput接口提供从二进制流读取字节并从其中重建任何Java原语类型的数据。 还有一个从modified UTF-8格式的数据重建String的设施。

    这个界面中的所有读取程序通常都是如果在读取所需的字节数之前到达文件结尾，则抛出一个EOFException （这是一种IOException ）。 如果由于除文件结尾之外的任何原因而无法读取任何字节，则抛出IOException以外的EOFException 。 特别地，如果输入流已经被关闭，则可以抛出IOException 。

    Modified UTF-8

    DataInput和DataOutput接口的实现表示Unicode字符串，格式是UTF-8的一个修改。 （有关标准UTF-8格式的信息，请参见“Unicode标准版本4.0的 Unicode编码格式” 3.9节）。 请注意，在下表中，最高位显示在最左侧的列中。

    Bit values and bytes
    All characters in the range '\u0001' to '\u007F' are represented by a single byte:
    Bit Values
    Byte 1 | 0 | bits 6-0
    The null character '\u0000' and characters in the range '\u0080' to '\u07FF' are represented by a pair of bytes:
    Bit Values
    Byte 1 | 1 | 1 | 0 | bits 10-6
    Byte 2 | 1 | 0 | bits 5-0
    char values in the range '\u0800' to '\uFFFF' are represented by three bytes:
    Bit Values
    Byte 1 | 1 | 1 | 1 | 0 | bits 15-12
    Byte 2 | 1 | 0 | bits 11-6
    Byte 3 | 1 | 0 | bits 5-0

    此格式与标准UTF-8格式之间的差异如下：

    • 空字节'\u0000'以2字节格式编码，而不是1字节，因此编码字符串从不具有嵌入的空值。
    • 仅使用1字节，2字节和3字节格式。
    • Supplementary characters以代理对的形式表示。
    从以下版本开始：
    1.0
    另请参见：
    DataInputStream ， DataOutput

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean readBoolean​()
      读取一个输入字节，并返回 true如果该字节不为零， false如果该字节是零。
      byte readByte​()
      读取并返回一个输入字节。
      char readChar​()
      读取两个输入字节并返回一个 char值。
      double readDouble​()
      读取八个输入字节并返回一个 double值。
      float readFloat​()
      读取四个输入字节并返回一个 float值。
      void readFully​(byte[] b)
      从输入流读取一些字节，并将它们存储到缓冲器阵列 b 。
      void readFully​(byte[] b, int off, int len)
      从输入流读取 len个字节。
      int readInt​()
      读取四个输入字节并返回一个 int值。
      String readLine​()
      从输入流读取下一行文本。
      long readLong​()
      读取八个输入字节并返回一个 long值。
      short readShort​()
      读取两个输入字节并返回一个 short值。
      int readUnsignedByte​()
      读取一个输入字节，将其扩展为类型 int ，并返回结果，因此在 0至 255 。
      int readUnsignedShort​()
      读取两个输入字节，并返回 0至 65535范围内的 int值。
      String readUTF​()
      读取已使用 modified UTF-8格式编码的字符串。
      int skipBytes​(int n)
      尝试从输入流中跳过 n字节的数据，丢弃跳过的字节。

    • 方法详细信息

      • readFully

        void readFully​(byte[] b)
        throws IOException
        从输入流中读取一些字节，并将其存储到缓冲区b 。 读取的字节数等于b的长度。

        该方法阻塞，直到出现以下情况之一：

        • b.length字节的输入数据可用，在这种情况下会进行正常的返回。
        • 检测到文件结束，在这种情况下抛出一个EOFException 。
        • 发生I / O错误，在这种情况下，抛出IOException以外的EOFException 。

        如果b为null ，则抛出NullPointerException 。 如果b.length为零，则不会读取字节。 否则，读取的第一个字节存储到元素b[0] ，下一个字节存入b[1] ，依此类推。 如果从该方法抛出异常，则可能使用来自输入流的数据更新了b一些但并非全部字节。

        参数
        b - 读取数据的缓冲区。
        异常
        NullPointerException - 如果 b是 null 。
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        void readFully​(byte[] b,
               int off,
               int len)
        throws IOException
        从输入流读取len个字节。

        该方法阻塞，直到出现以下情况之一：

        • len字节的输入数据可用，在这种情况下将进行正常的返回。
        • 检测到文件结束，在这种情况下抛出一个EOFException 。
        • 发生I / O错误，在这种情况下，抛出IOException以外的EOFException 。

        如果b为null ，则抛出NullPointerException 。 如果off为负数，或len为负数，或off+len大于数组b的长度，则抛出IndexOutOfBoundsException 。 如果len为零，则不会读取任何字节。 否则，第一个字节读取存储到元素b[off] ，下一个字节存入b[off+1] ，依此类推。 读取的字节数最多等于len 。

        参数
        b - 读取数据的缓冲区。
        off - 指定数据数组 b的偏移量的int。
        len - 一个int指定要读取的字节数。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 len ，大于 b.length - off 。
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • skipBytes

        int skipBytes​(int n)
       throws IOException
        尝试从输入流中跳过n个字节的数据，丢弃跳过的字节。 但是，它可能跳过一些较小数量的字节，可能会为零。 这可能是由许多条件中的任何一个引起的 在n字节之前已经跳过的文件到达结束只有一种可能性。 这种方法永远不会抛出一个EOFException 。 返回实际跳过的字节数。
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • readBoolean

        boolean readBoolean​()
             throws IOException
        读取一个输入字节，并返回true如果该字节不为零， false如果该字节是零。 该方法适用于读取接口DataOutput的writeBoolean方法写入的字节。
        结果
        boolean值读。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readByte

        byte readByte​()
       throws IOException
        读取并返回一个输入字节。 该字节被视为-128至127范围内的-128符号值。 该方法适用于读取由接口DataOutput的writeByte方法写入的字节。
        结果
        读取8位值。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readUnsignedByte

        int readUnsignedByte​()
              throws IOException
        读取一个输入字节，将其扩展到类型int ，并返回结果，因此在0到255 。 此方法适用于读取由写入的字节writeByte接口的方法DataOutput ，如果参数writeByte的用意是在范围内的值0通过255 。
        结果
        读取无符号的8位值。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readShort

        short readShort​()
         throws IOException
        读取两个输入字节并返回一个short值。 让a成为第一个字节， b是第二个字节。 返回的值为：
          (short)((a << 8) | (b & 0xff))
        该方法适用于读取由接口DataOutput的writeShort方法写入的字节。
        结果
        读取16位值。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readUnsignedShort

        int readUnsignedShort​()
               throws IOException
        读取两个输入字节，并返回0到65535的int值。 让a是第一个字节读取，而b是第二个字节。 返回的值为：
          (((a & 0xff) << 8) | (b & 0xff))
        此方法适用于读取由写入字节writeShort接口的方法DataOutput ，如果参数writeShort的用意是在范围内的值0通过65535 。
        结果
        读取无符号16位值。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readChar

        char readChar​()
       throws IOException
        读取两个输入字节并返回一个char值。 让a是第一个字节读取，而b是第二个字节。 返回的值为：
          (char)((a << 8) | (b & 0xff))
        该方法适用于读取writeChar接口DataOutput编写的字节。
        结果
        char值读取。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readInt

        int readInt​()
     throws IOException
        读取四个输入字节并返回一个int值。 让a-d是第一到第四个字节读取。 返回的值为：
           (((a & 0xff) << 24) | ((b & 0xff) << 16) | ((c & 0xff) << 8) | (d & 0xff))
        该方法适用于读取由接口DataOutput的writeInt方法写入的字节。
        结果
        int值读取。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readLong

        long readLong​()
       throws IOException
        读取八个输入字节并返回一个long值。 让a-h是第一个到第八个字节读取。 返回的值为：
           (((long)(a & 0xff) << 56) | ((long)(b & 0xff) << 48) | ((long)(c & 0xff) << 40) | ((long)(d & 0xff) << 32) | ((long)(e & 0xff) << 24) | ((long)(f & 0xff) << 16) | ((long)(g & 0xff) << 8) | ((long)(h & 0xff)))

        该方法适用于读取writeLong接口DataOutput编写的字节。

        结果
        long值读。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFloat

        float readFloat​()
         throws IOException
        读取四个输入字节并返回一个float值。 这是通过首先按照readInt方法构建一个int值，然后以float的方式将该int值转换为Float.intBitsToFloat 。 该方法适用于读取由writeFloat接口DataOutput编写的字节。
        结果
        float读取值。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readDouble

        double readDouble​()
           throws IOException
        读取八个输入字节并返回一个double值。 它通过首先按照readLong方法的方式构建一个long值，然后以double的方式将该long值转换为Double.longBitsToDouble 。 该方法适用于读取writeDouble接口DataOutput编写的字节。
        结果
        读取 double值。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readLine

        String readLine​()
         throws IOException
        从输入流读取下一行文本。 它读取连续字节，将每个字节分别转换为字符，直到遇到行终止符或文件结尾; 读取的字符然后作为String返回。 请注意，由于此方法处理字节，它不支持输入完整的Unicode字符集。

        如果在甚至可以读取一个字节之前遇到文件结尾，则返回null 。 否则，读取的每个字节将通过零扩展转换为类型char 。 如果遇到字符'\n' ，则会被丢弃，读取停止。 如果遇到字符'\r' ，则会被丢弃，如果以下字节转换为字符'\n' ，则也将被丢弃; 阅读然后停止。 如果在遇到任何一个字符'\n'和'\r'之前遇到文件结尾，则读取停止。 一旦读取停止，将返回一个String ，其中包含所有读取的字符，而不是按照顺序排列。 请注意，此字符串中的每个字符的值都小于\u0100 ，即(char)256 。

        结果
        来自输入流的下一行文本，或 null如果在一个字节可以读取之前遇到文件的结尾。
        异常
        IOException - 如果发生I / O错误。

      • readUTF

        String readUTF​()
        throws IOException
        读取已使用modified UTF-8格式编码的字符串。 readUTF的一般合同是它读取以修改的UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为一个String返回。

        首先，读取并使用两个字节，以完全符合readUnsignedShort方法的方式构造无符号16位整数。 该整数值称为UTF长度，并指定要读取的其他字节数。 然后将这些字节通过组合考虑来转换为字符。 每组的长度根据组的第一个字节的值计算。 组之后的字节（如果有的话）是下一组的第一个字节。

        如果组的第一个字节与位模式0xxxxxxx （其中x表示“可能是0或1 ”） 1 ，则该组仅由该字节组成。 该字节是零扩展形成一个字符。

        如果一组的第一个字节与位模式110xxxxx匹配，则该组由该字节a和第二字节b 。 如果没有字节b （因为字节a是要读取的最后一个字节），或者如果字节b与位模式10xxxxxx不匹配，则抛出UTFDataFormatException 。 否则，该组将转换为字符：

          (char)(((a & 0x1F) << 6) | (b & 0x3F))
        如果一组的第一个字节与位模式1110xxxx匹配，则该组由该字节a和两个多个字节b和c 。 如果没有字节c （因为字节a是要读取的最后两个字节之一），或者字节b或字节c与位模式10xxxxxx不匹配，则抛出UTFDataFormatException 。 否则，该组将转换为字符：
           (char)(((a & 0x0F) << 12) | ((b & 0x3F) << 6) | (c & 0x3F))
        如果组的第一个字节与模式1111xxxx或模式10xxxxxx ，则抛出UTFDataFormatException 。

        如果在整个过程中随时遇到文件结尾，则抛出一个EOFException 。

        通过此过程将每个组转换为一个字符后，以与从输入流中读取相应组相同的顺序收集字符，形成一个返回的String 。

        接口DataOutput的writeUTF方法可以用于通过该方法写入适合于读取的数据。

        结果
        一个Unicode字符串。
        异常
        EOFException - 如果此流在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        UTFDataFormatException - if the bytes do not represent a valid modified UTF-8 encoding of a string.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class DataInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.io.DataInputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， AutoCloseable

    public class DataInputStream
extends FilterInputStream
implements DataInput
    数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。 应用程序使用数据输出流来写入稍后可以被数据输入流读取的数据。

    DataInputStream对于多线程访问来说不一定是安全的。 线程安全是可选的，是本课程中用户的责任。

    从以下版本开始：
    1.0
    另请参见：
    DataOutputStream

    • Field Summary

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataInputStream​(InputStream in)
      创建使用指定的底层InputStream的DataInputStream。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int read​(byte[] b)
      从包含的输入流中读取一些字节数，并将它们存储到缓冲器阵列 b 。
      int read​(byte[] b, int off, int len)
      从包含的输入流读取最多 len个字节的数据到字节数组。
      boolean readBoolean​()
      见 readBoolean方法 DataInput的一般合同。
      byte readByte​()
      见 readByte方法 DataInput的一般合同。
      char readChar​()
      见 readChar法 DataInput的一般合同。
      double readDouble​()
      见 readDouble方法的一般合同 DataInput 。
      float readFloat​()
      见 readFloat法 DataInput的一般合同。
      void readFully​(byte[] b)
      见 readFully法 DataInput的一般合同。
      void readFully​(byte[] b, int off, int len)
      见 readFully法 DataInput的一般合同。
      int readInt​()
      见 readInt法 DataInput的一般合同。
      String readLine​()
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1开始，读取文本行的首选方式是通过BufferedReader.readLine()方法。 使用DataInputStream类读取行的程序可以转换为使用BufferedReader类替换以下形式的代码：
           DataInputStream d = new DataInputStream(in);
      有：
           BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
      long readLong​()
      见 readLong方法 DataInput的一般合同。
      short readShort​()
      见 readShort法 DataInput的一般合同。
      int readUnsignedByte​()
      见 readUnsignedByte法 DataInput的一般合同。
      int readUnsignedShort​()
      见 readUnsignedShort法 DataInput的一般合同。
      String readUTF​()
      见 readUTF法 DataInput的一般合同。
      static String readUTF​(DataInput in)
      从流in读取以modified UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为String返回。
      int skipBytes​(int n)
      见 skipBytes法 DataInput的一般合同。

      • Methods inherited from class java.io.FilterInputStream

        available, close, mark, markSupported, read, reset, skip

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DataInputStream

        public DataInputStream​(InputStream in)
        创建使用指定的底层InputStream的DataInputStream。
        参数
        in - 指定的输入流

    • 方法详细信息

      • read

        public final int read​(byte[] b)
               throws IOException
        从包含的输入流读取一些字节数，并将它们存储到缓冲器阵列b 。 实际读取的字节数作为整数返回。 该方法阻塞直到输入数据可用，检测到文件结束或抛出异常。

        如果b为空，则抛出NullPointerException 。 如果b的长度为零，则不读取字节，返回0 ; 否则，尝试读取至少一个字节。 如果没有字节可用，因为流是文件的-1则返回值-1 ; 否则，读取至少一个字节并将其存储到b 。

        读取的第一个字节存储在元素b[0] ，下一个字节存入b[1] ，依此类推。 读取的字节数最多等于b的长度。 让k是实际读取的字节数; 这些字节将被存储在元素b[0]至b[k-1] ，使元素b[k]至b[b.length-1]不受影响。

        read(b)方法具有如下效果：

         read(b, 0, b.length)
        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的缓冲区。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾， -1 。
        异常
        IOException - 如果由于文件结尾以外的任何原因无法读取第一个字节，则流已关闭，底层输入流不支持关闭后读取，或者发生另一个I / O错误。
        另请参见：
        FilterInputStream.in ， InputStream.read(byte[], int, int)

      • read

        public final int read​(byte[] b,
                      int off,
                      int len)
               throws IOException
        从包含的输入流读取最多len个字节的数据到字节数组。 尝试读取多达len个字节，但可能读取较小的数字，可能为零。 实际读取的字节数作为整数返回。

        该方法阻塞直到输入数据可用，检测到文件结束或抛出异常。

        如果len为零，则不会读取字节并返回0 ; 否则，尝试读取至少一个字节。 如果没有字节可用，因为流在文件结尾，则返回值-1 ; 否则读取至少一个字节并存储到b 。

        读取的第一个字节存储到元素b[off] ，下一个字节存入b[off+1] ，依此类推。 读取的字节数最多等于len 。 令k为实际读取的字节数; 这些字节将被存储在元素b[off]通过b[off+ ķ -1] ，留下元件b[off+ ķ ]通过b[off+len-1]不受影响。

        在每种情况下，元素b[0]至b[off]和元素b[off+len]至b[b.length-1]不受影响。

        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的缓冲区。
        off - 目标数组 b的起始偏移量
        len - 读取的最大字节数。
        结果
        读取到缓冲区中的总字节数，如果没有更多的数据，因为已经到达流的末尾，那么 -1 。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负， len为负数，或 len为大于 b.length - off
        IOException - 如果由于文件结尾以外的任何原因无法读取第一个字节，则流已关闭，底层输入流不支持关闭后读取，或者发生另一个I / O错误。
        另请参见：
        FilterInputStream.in ， InputStream.read(byte[], int, int)

      • readFully

        public final void readFully​(byte[] b)
                     throws IOException
        见readFully法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readFully在接口 DataInput
        参数
        b - 读取数据的缓冲区。
        异常
        NullPointerException - 如果 b是 null 。
        EOFException - 如果此输入流在读取所有字节之前到达结束。
        IOException - 流已关闭，包含的输入流不支持关闭后读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readFully

        public final void readFully​(byte[] b,
                            int off,
                            int len)
                     throws IOException
        见readFully法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readFully在接口 DataInput
        参数
        b - 读取数据的缓冲区。
        off - 数据阵列中的起始偏移量 b 。
        len - 要读取的字节数。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 len ，大于 b.length - off 。
        EOFException - 如果此输入流在读取所有字节之前到达结束。
        IOException - 流已关闭，包含的输入流不支持关闭后读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • skipBytes

        public final int skipBytes​(int n)
                    throws IOException
        见skipBytes法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        skipBytes在接口 DataInput
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果包含的输入流不支持查询，或流已关闭，并且包含的输入流不支持关闭后读取，或者发生另一个I / O错误。

      • readBoolean

        public final boolean readBoolean​()
                          throws IOException
        见readBoolean法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readBoolean在接口 DataInput
        结果
        boolean值读。
        异常
        EOFException - 如果此输入流已到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或者发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readByte

        public final byte readByte​()
                    throws IOException
        见readByte法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readByte在接口 DataInput
        结果
        该输入流的下一个字节为有符号的8位 byte 。
        异常
        EOFException - 如果此输入流已经到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readUnsignedByte

        public final int readUnsignedByte​()
                           throws IOException
        见readUnsignedByte法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readUnsignedByte在接口 DataInput
        结果
        该输入流的下一个字节被解释为无符号的8位数字。
        异常
        EOFException - 如果此输入流已到达结束。
        IOException - 流已关闭，包含的输入流不支持关闭后读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readShort

        public final short readShort​()
                      throws IOException
        见readShort方法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readShort在接口 DataInput
        结果
        该输入流的下两个字节，被解释为一个有符号的16位数字。
        异常
        EOFException - 如果此输入流在读取两个字节之前到达结束。
        IOException - 流已关闭，包含的输入流不支持关闭后读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readUnsignedShort

        public final int readUnsignedShort​()
                            throws IOException
        见readUnsignedShort方法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readUnsignedShort在接口 DataInput
        结果
        该输入流的下两个字节被解释为无符号16位整数。
        异常
        EOFException - 如果此输入流在读取两个字节之前到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或者发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readChar

        public final char readChar​()
                    throws IOException
        见readChar法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readChar在接口 DataInput
        结果
        该输入流的下两个字节，解释为 char 。
        异常
        EOFException - 如果此输入流在读取两个字节之前到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readInt

        public final int readInt​()
                  throws IOException
        见readInt方法的一般合同DataInput 。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readInt在接口 DataInput
        结果
        该输入流的接下来的四个字节，解释为 int 。
        异常
        EOFException - 如果此输入流在读取四个字节之前到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readLong

        public final long readLong​()
                    throws IOException
        见readLong法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readLong在接口 DataInput
        结果
        该输入流的接下来八个字节，解释为 long 。
        异常
        EOFException - 如果此输入流在读取八个字节之前到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或发生另一个I / O错误。
        另请参见：
        FilterInputStream.in

      • readFloat

        public final float readFloat​()
                      throws IOException
        见readFloat法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readFloat在接口 DataInput
        结果
        该输入流的下四个字节，解释为 float 。
        异常
        EOFException - 如果此输入流在读取四个字节之前到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或发生另一个I / O错误。
        另请参见：
        readInt() ， Float.intBitsToFloat(int)

      • readDouble

        public final double readDouble​()
                        throws IOException
        见readDouble法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readDouble在接口 DataInput
        结果
        该输入流的接下来八个字节，解释为 double 。
        异常
        EOFException - 如果此输入流在读取八个字节之前到达结束。
        IOException - 流已关闭，包含的输入流不支持关闭后读取，或发生另一个I / O错误。
        另请参见：
        readLong() ， Double.longBitsToDouble(long)

      • readLine

        @Deprecated
public final String readLine​()
                      throws IOException
        已过时。 此方法无法将字节正确转换为字符。 从JDK 1.1开始，读取文本行的首选方式是通过BufferedReader.readLine()方法。 使用DataInputStream类读取行的程序可以转换为使用BufferedReader类替换以下形式的代码：
             DataInputStream d = new DataInputStream(in);
        有：
             BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
        见readLine法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readLine在接口 DataInput
        结果
        来自此输入流的下一行文本。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        BufferedReader.readLine() ， FilterInputStream.in

      • readUTF

        public final String readUTF​()
                     throws IOException
        见readUTF法DataInput的一般合同。

        从所包含的输入流中读取此操作的字节数。

        Specified by:
        readUTF在接口 DataInput
        结果
        一个Unicode字符串。
        异常
        EOFException - 如果此输入流在读取所有字节之前到达结束。
        IOException - 流已关闭，包含的输入流在关闭后不支持读取，或发生另一个I / O错误。
        UTFDataFormatException - 如果字节不表示字符串的有效修改的UTF-8编码。
        另请参见：
        readUTF(java.io.DataInput)

      • readUTF

        public static final String readUTF​(DataInput in)
                            throws IOException
        从流in读取以modified UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为String返回。 修改的UTF-8表示的细节与readUTF方法DataInput 。
        参数
        in - 数据输入流。
        结果
        一个Unicode字符串。
        异常
        EOFException - 如果输入流在所有字节之前到达结束。
        IOException - 流已关闭，包含的输入流不支持关闭后读取，或发生另一个I / O错误。
        UTFDataFormatException - 如果字节不表示Unicode字符串的有效修改的UTF-8编码。
        另请参见：
        readUnsignedShort()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataOutput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface DataOutput

  • All Known Subinterfaces:
    ImageOutputStream ， JNLPRandomAccessFile ， ObjectOutput
    所有已知实现类：
    DataOutputStream ， FileCacheImageOutputStream ， FileImageOutputStream ， ImageOutputStreamImpl ， MemoryCacheImageOutputStream ， ObjectOutputStream ， RandomAccessFile

    public interface DataOutput
    DataOutput接口提供将数据从任何Java基本类型转换为一系列字节，并将这些字节写入二进制流。 还有一个将String转换为modified UTF-8格式并编写结果字节系列的功能。

    对于这个接口中写入字节的所有方法，一般来说，如果一个字节不能由于任何原因写入， IOException抛出一个IOException 。

    从以下版本开始：
    1.0
    另请参见：
    DataInput ， DataOutputStream

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void write​(byte[] b)
      将输出流写入阵列 b所有字节。
      void write​(byte[] b, int off, int len)
      从阵列 b写入 len字节，以输出流。
      void write​(int b)
      向输出流写入参数 b的八个低位。
      void writeBoolean​(boolean v)
      向此输出流写入一个 boolean值。
      void writeByte​(int v)
      向输出流写入参数 v的八个低位位。
      void writeBytes​(String s)
      将一个字符串写入输出流。
      void writeChar​(int v)
      向输出流写入由两个字节组成的 char值。
      void writeChars​(String s)
      将字符串中的每个字符 s写入输出流，按顺序排列每个字符两个字节。
      void writeDouble​(double v)
      向输出流写入一个由8个字节组成的 double值。
      void writeFloat​(float v)
      向输出流写入由四个字节组成的 float值。
      void writeInt​(int v)
      向输出流写入一个由四个字节组成的 int值。
      void writeLong​(long v)
      向输出流写入一个由8个字节组成的 long值。
      void writeShort​(int v)
      将两个字节写入输出流以表示参数的值。
      void writeUTF​(String s)
      将两个字节的长度信息写入输出流，后跟字符串 s中每个字符的 modified UTF-8表示。

    • 方法详细信息

      • write

        void write​(int b)
    throws IOException
        向输出流写入参数b的八个低位。 b的24位b被忽略。
        参数
        b - 要写入的字节。
        异常
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b)
    throws IOException
        将输出流写入阵列b所有字节。 如果b是null ，则抛出一个NullPointerException 。 如果b.length为零，则不会写入任何字节。 否则，首先写入字节b[0] ，然后写入b[1] ，等等; 写入的最后一个字节是b[b.length-1] 。
        参数
        b - 数据。
        异常
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b,
           int off,
           int len)
    throws IOException
        将len字节从阵列b写入到输出流。 如果b为null ，则抛出NullPointerException 。 如果off为负数，或len为负数，或off+len大于数组b的长度，则抛出IndexOutOfBoundsException 。 如果len为零，则不会写入任何字节。 否则，首先写入字节b[off] ，然后写入b[off+1] ，依此类推; 写入的最后一个字节是b[off+len-1] 。
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。

      • writeBoolean

        void writeBoolean​(boolean v)
           throws IOException
        向此输出流写入一个boolean值。 如果参数v为true ，则写入值(byte)1 ; 如果v为false ，则写入值(byte)0 。 通过此方法写入的字节可以由读取readBoolean接口的方法DataInput ，然后将返回一个boolean等于v 。
        参数
        v - 要写入的布尔值。
        异常
        IOException - 如果发生I / O错误。

      • writeByte

        void writeByte​(int v)
        throws IOException
        向输出流写入参数v的八个低位位。 v的24位v被忽略。 （这意味着writeByte不完全一样的东西作为write为整数参数。）此方法写入的字节可以由读取readByte接口的方法DataInput ，然后将返回一个byte等于(byte)v 。
        参数
        v - 要写入的字节值。
        异常
        IOException - 如果发生I / O错误。

      • writeShort

        void writeShort​(int v)
         throws IOException
        将两个字节写入输出流以表示参数的值。 要写入的字节值按照显示的顺序是：
           (byte)(0xff & (v >> 8)) (byte)(0xff & v)

        由该方法写入的字节可以由接口DataInput的readShort方法读取，然后short将返回short等于(short)v 。

        参数
        v - short值。
        异常
        IOException - 如果发生I / O错误。

      • writeChar

        void writeChar​(int v)
        throws IOException
        向输出流写入一个由两个字节组成的char值。 要写入的字节值按照显示的顺序是：
           (byte)(0xff & (v >> 8)) (byte)(0xff & v)

        由该方法写入的字节可以通过接口DataInput的readChar方法读取，然后char将返回等于(char)v 。

        参数
        v - char值。
        异常
        IOException - 如果发生I / O错误。

      • writeInt

        void writeInt​(int v)
       throws IOException
        向输出流写入由四个字节组成的int值。 要写入的字节值按照显示的顺序是：
           (byte)(0xff & (v >> 24)) (byte)(0xff & (v >> 16)) (byte)(0xff & (v >> 8)) (byte)(0xff & v)

        由该方法写入的字节可以通过接口DataInput的readInt方法读取，然后将返回int等于v 。

        参数
        v - int值。
        异常
        IOException - 如果发生I / O错误。

      • writeLong

        void writeLong​(long v)
        throws IOException
        向输出流写入一个由8个字节组成的long值。 要写入的字节值按照显示的顺序是：
           (byte)(0xff & (v >> 56)) (byte)(0xff & (v >> 48)) (byte)(0xff & (v >> 40)) (byte)(0xff & (v >> 32)) (byte)(0xff & (v >> 24)) (byte)(0xff & (v >> 16)) (byte)(0xff & (v >> 8)) (byte)(0xff & v)

        由该方法写入的字节可以由接口DataInput的readLong方法读取，接着long返回一个等于v 。

        参数
        v - long值。
        异常
        IOException - 如果发生I / O错误。

      • writeFloat

        void writeFloat​(float v)
         throws IOException
        向输出流写入由四个字节组成的float值。 它这样做是因为，如果它首先将这个float值到int在完全相同的方式Float.floatToIntBits方法，然后再写入int在完全相同的方式值writeInt方法。 由该方法写入的字节可以由接口DataInput的readFloat方法读取， readFloat DataInput将返回float等于v 。
        参数
        v - float值。
        异常
        IOException - 如果发生I / O错误。

      • writeDouble

        void writeDouble​(double v)
          throws IOException
        向输出流写入一个由8个字节组成的double值。 它这样做是因为，如果它首先将这个double值到long在完全相同的方式Double.doubleToLongBits方法，然后再写入long在完全相同的方式值writeLong方法。 由该方法写入的字节可以由接口DataInput的readDouble方法读取，然后readDouble方法将返回double等于v 。
        参数
        v - double值。
        异常
        IOException - 如果发生I / O错误。

      • writeBytes

        void writeBytes​(String s)
         throws IOException
        将一个字符串写入输出流。 对于字符串s中的每个字符，按顺序，一个字节被写入输出流。 如果s是null ，则抛出一个NullPointerException 。

        如果s.length为零，则不会写入任何字节。 否则，首先写入字符s[0] ，然后写入s[1] ，等等; 写最后一个字符是s[s.length-1] 。 对于每个字符，写入一个字节，低字节，按照writeByte方法的方式。 字符串中每个字符的高8位被忽略。

        参数
        s - 要写入的字节串。
        异常
        IOException - 如果发生I / O错误。

      • writeChars

        void writeChars​(String s)
         throws IOException
        将字符串中的每个字符s写入输出流，按字符顺序排列两个字节。 如果s是null ，则抛出一个NullPointerException 。 如果s.length为零，则不会写入任何字符。 否则，首先写入字符s[0] ，然后写入s[1] ，等等; 写最后一个字符是s[s.length-1] 。 对于每个字符，两个字节实际上是以writeChar方式的方式写入高位字节。
        参数
        s - 要写入的字符串值。
        异常
        IOException - 如果发生I / O错误。

      • writeUTF

        void writeUTF​(String s)
       throws IOException
        将两个字节的长度信息写入输出流，后跟字符串s中每个字符的modified UTF-8表示。 如果s是null ，则抛出一个NullPointerException 。 字符串s中的每个字符根据字符的值转换为一个，两个或三个字节的组。

        如果字符c在\u0001到\u007f ，则它由一个字节表示：

          (byte)c

        如果字符c是\u0000或者是在\u0080到\u07ff的范围内，那么它由两个字节表示，按照显示的顺序写：

           (byte)(0xc0 | (0x1f & (c >> 6))) (byte)(0x80 | (0x3f & c))

        如果一个字符c在\u0800到uffff ，那么它由三个字节表示，按照显示的顺序写：

           (byte)(0xe0 | (0x0f & (c >> 12))) (byte)(0x80 | (0x3f & (c >> 6))) (byte)(0x80 | (0x3f & c))

        首先，计算表示s所有字符所需的总字节数。 如果这个数字大于65535 ，则抛出一个UTFDataFormatException 。 否则，这个长度以writeShort的方式完全写入输出流; 之后，写入字符串s中每个字符的一字节，二字节或三字节表示。

        由该方法写入的字节可以通过接口DataInput的readUTF方法读取，然后String将返回一个String等于s 。

        参数
        s - 要写入的字符串值。
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DataOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class DataOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.io.DataOutputStream
  • All Implemented Interfaces:
    Closeable ， DataOutput ， Flushable ， AutoCloseable

    public class DataOutputStream
extends FilterOutputStream
implements DataOutput
    数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。 然后应用程序可以使用数据输入流来读取数据。
    从以下版本开始：
    1.0
    另请参见：
    DataInputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int written
      到目前为止写入数据输出流的字节数。

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      DataOutputStream​(OutputStream out)
      创建一个新的数据输出流，以将数据写入指定的底层输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void flush​()
      刷新此数据输出流。
      int size​()
      返回计数器的当前值 written ，到目前为止写入此数据输出流的字节数。
      void write​(byte[] b, int off, int len)
      将从偏移量 off开始的指定字节数组写入 len字节到底层输出流。
      void write​(int b)
      将指定的字节（参数 b的低8位）写入底层输出流。
      void writeBoolean​(boolean v)
      将底层输出流写入 boolean作为1字节值。
      void writeByte​(int v)
      将底层输出流作为1字节值写入 byte 。
      void writeBytes​(String s)
      将字符串作为字节序列写入基础输出流。
      void writeChar​(int v)
      将底层输出流写入 char作为2字节值，高位字节。
      void writeChars​(String s)
      将字符串写入底层输出流作为一系列字符。
      void writeDouble​(double v)
      双参数传递给转换 long使用 doubleToLongBits方法在类 Double ，然后写入该 long值基础输出流作为8字节的数量，高字节。
      void writeFloat​(float v)
      使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后 int值作为4字节数量，高字节优先写入底层输出流。
      void writeInt​(int v)
      将底层输出流写入 int作为四字节，高位字节。
      void writeLong​(long v)
      将底层输出流写入一个 long作为八字节，高字节优先。
      void writeShort​(int v)
      将底层输出流写入 short作为两个字节，高字节优先。
      void writeUTF​(String str)
      使用机器无关的方式使用 modified UTF-8编码将字符串写入底层输出流。

      • Methods inherited from interface java.io.DataOutput

        write

      • Methods inherited from class java.io.FilterOutputStream

        close, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • written

        protected int written
        到目前为止写入数据输出流的字节数。 如果此计数器溢出，它将被包装到Integer.MAX_VALUE。

    • 构造方法详细信息

      • DataOutputStream

        public DataOutputStream​(OutputStream out)
        创建一个新的数据输出流，以将数据写入指定的底层输出流。 计数器written被设置为零。
        参数
        out - 底层输出流，保存供以后使用。
        另请参见：
        FilterOutputStream.out

    • 方法详细信息

      • write

        public void write​(int b)
           throws IOException
        将指定字节（参数b的低8位）写入底层输出流。 如果不抛出异常，则计数器written增加1 。

        实施write方法OutputStream 。

        Specified by:
        write在接口 DataOutput
        重写：
        write在 FilterOutputStream
        参数
        b - byte 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        从指定的字节数组写入len个字节，从偏移off开始到底层输出流。 如果没有异常抛出，计数器written增加len 。
        Specified by:
        write在接口 DataOutput
        重写：
        write在 FilterOutputStream
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • flush

        public void flush​()
           throws IOException
        刷新此数据输出流。 这将强制任何缓冲的输出字节写入流。

        该flush的方法DataOutputStream调用flush其基础输出流的方法。

        Specified by:
        flush在接口 Flushable
        重写：
        flush在 FilterOutputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out ， OutputStream.flush()

      • writeBoolean

        public final void writeBoolean​(boolean v)
                        throws IOException
        将底层输出流作为1字节值写入boolean 。 值true写为值(byte)1 ; 值false写出为值(byte)0 。 如果没有异常抛出，计数器written增加1 。
        Specified by:
        writeBoolean在接口 DataOutput
        参数
        v - 要写入的 boolean值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • writeByte

        public final void writeByte​(int v)
                     throws IOException
        将底层输出流作为1字节值写入byte 。 如果没有异常抛出，计数器written将增加1 。
        Specified by:
        writeByte在接口 DataOutput
        参数
        v - v一个 byte值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • writeShort

        public final void writeShort​(int v)
                      throws IOException
        将底层输出流写入short作为两个字节，高位字节。 如果不抛出异常，计数器written将增加2 。
        Specified by:
        writeShort在接口 DataOutput
        参数
        v - a short待写。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • writeChar

        public final void writeChar​(int v)
                     throws IOException
        将底层输出流写入char作为2字节值，高位字节。 如果不抛出异常，计数器written将增加2 。
        Specified by:
        writeChar在接口 DataOutput
        参数
        v - 要写入的 char值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • writeInt

        public final void writeInt​(int v)
                    throws IOException
        将底层输出流写入int作为四字节，高字节优先。 如果不抛出异常，计数器written将增加4 。
        Specified by:
        writeInt在接口 DataOutput
        参数
        v - int 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • writeLong

        public final void writeLong​(long v)
                     throws IOException
        将底层输出流写入一个long作为八字节，高位字节。 抛出异常，计数器written增加8 。
        Specified by:
        writeLong在接口 DataOutput
        参数
        v - a long待写。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • writeFloat

        public final void writeFloat​(float v)
                      throws IOException
        浮子参数的转换int使用floatToIntBits方法在类Float ，然后写入该int值基础输出流作为一个4字节的数量，高字节。 如果不抛出异常，则计数器written增加4 。
        Specified by:
        writeFloat在接口 DataOutput
        参数
        v - v一个 float值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out ， Float.floatToIntBits(float)

      • writeDouble

        public final void writeDouble​(double v)
                       throws IOException
        使用long中的doubleToLongBits方法将双参数转换为Double ，然后long值作为8字节数量（高字节优先）写入底层输出流。 如果不抛出异常，计数器written将增加8 。
        Specified by:
        writeDouble在接口 DataOutput
        参数
        v - 要写入的 double值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out ， Double.doubleToLongBits(double)

      • writeBytes

        public final void writeBytes​(String s)
                      throws IOException
        将字符串作为字节序列写入基础输出流。 字符串中的每个字符顺序地通过丢弃其高8位来写出。 如果没有抛出异常，计数器written由长度增加s 。
        Specified by:
        writeBytes在接口 DataOutput
        参数
        s - 要写入的字节串。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterOutputStream.out

      • writeChars

        public final void writeChars​(String s)
                      throws IOException
        将字符串写入底层输出流作为一系列字符。 每个字符都被写入数据输出流，就像通过writeChar方法一样。 如果不抛出异常，计数器written将增加written的长度的s 。
        Specified by:
        writeChars在接口 DataOutput
        参数
        s - 要写入的 String值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        writeChar(int) ， FilterOutputStream.out

      • writeUTF

        public final void writeUTF​(String str)
                    throws IOException
        使用机器无关的方式使用modified UTF-8编码将字符串写入底层输出流。

        首先，将两个字节写入输出流，就像通过writeShort方法给出要跟随的字节数。 该值是实际写出的字节数，而不是字符串的长度。 按照长度，字符串的每个字符依次输出，使用修改的UTF-8编码字符。 如果没有异常被抛出，计数器written将增加写入输出流的总字节数。 这将至少是两个加上长度的str ，最多两加三，长度为str 。

        Specified by:
        writeUTF在接口 DataOutput
        参数
        str - 要写入的字符串。
        异常
        IOException - 如果发生I / O错误。

      • size

        public final int size​()
        返回计数器的当前值written ，到目前为止写入此数据输出流的字节数。 如果计数器溢出，它将被包装到Integer.MAX_VALUE。
        结果
        该值为 written字段。
        另请参见：
        written
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EOFException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class EOFException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.EOFException
  • All Implemented Interfaces:
    Serializable

    public class EOFException
extends IOException
    表示在输入过程中意外地到达文件结束或流结束。

    这个异常主要由数据输入流用来表示流的结尾。 请注意，许多其他输入操作在流的末尾返回特殊值，而不是抛出异常。

    从以下版本开始：
    1.0
    另请参见：
    DataInputStream ， IOException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      EOFException​()
      构造 EOFException其中包含 null作为其错误详细消息。
      EOFException​(String s)
      构造具有指定详细消息的 EOFException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • EOFException

        public EOFException​()
        构造 null作为其错误详细信息， EOFException包含 null 。

      • EOFException

        public EOFException​(String s)
        构造具有指定详细消息的EOFException 。 字符串s可以稍后通过类别java.lang.Throwable的Throwable.getMessage()方法来检索。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Externalizable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface Externalizable

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    RemoteRef ， ServerRef
    所有已知实现类：
    ActivationDataFlavor ， DataFlavor ， MimeType ， MLet ， PrivateMLet

    public interface Externalizable
extends Serializable
    只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。 Externalizable接口的writeExternal和readExternal方法由一个类来实现，可以使类完全控制对象及其超类型的流的格式和内容。 这些方法必须明确地与超类型协调来保存其状态。 这些方法取代了writeObject和readObject方法的定制实现。
    对象序列化使用Serializable和Externalizable接口。 对象持久化机制也可以使用它们。 要存储的每个对象都被测试为Externalizable接口。 如果对象支持Externalizable，则调用writeExternal方法。 如果对象不支持Externalizable，并且实现Serializable，则使用ObjectOutputStream保存对象。
    当一个Externalizable对象被重建时，使用public no-arg构造函数创建一个实例，然后调用readExternal方法。 可从ObjectInputStream读取可序列化对象。
    Externalizable实例可以通过Serializable接口中记录的writeReplace和readResolve方法来指定一个替换对象。
    从以下版本开始：
    1.1
    另请参见：
    ObjectOutputStream ， ObjectInputStream ， ObjectOutput ， ObjectInput ， Serializable

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。
      void writeExternal​(ObjectOutput out)
      该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput的对象，字符串和数组的writeObject方法来保存其内容。

    • 方法详细信息

      • writeExternal

        void writeExternal​(ObjectOutput out)
            throws IOException
        该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput的对象，字符串和数组的writeObject方法来保存其内容。
        参数
        out - 将对象写入的流
        异常
        IOException - 包括可能发生的任何I / O异常

      • readExternal

        void readExternal​(ObjectInput in)
           throws IOException,
                  ClassNotFoundException
        该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。 readExternal方法必须以与writeExternal写的相同的顺序读取相同的值。
        参数
        in - 为了恢复对象，读取数据的流
        异常
        IOException - 如果发生I / O错误
        ClassNotFoundException - 如果找不到正在恢复的对象的类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


File (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class File

  • java.lang.Object
    • java.io.File
  • All Implemented Interfaces:
    Serializable ， Comparable<File>

    public class File
extends Object
implements Serializable, Comparable<File>
    文件和目录路径名的抽象表示。

    用户界面和操作系统使用依赖于系统的路径名字符串命名文件和目录。 这个类提供了一个抽象的，独立于系统的层次化路径名的视图。 抽象路径名有两个组件：

    1. 可选的系统相关前缀字符串，例如用于UNIX根目录的磁盘驱动器说明符"/"或Microsoft Windows UNC路径名的"\\\" ，以及
    2. 零个或多个字符串名称的序列。
    抽象路径名中的第一个名称可能是目录名称，或者在Microsoft Windows UNC路径名的情况下是主机名。 抽象路径名中的每个后续名称表示一个目录; 姓氏可以表示目录或文件。 空的抽象路径名没有前缀和空名称序列。

    将路径名字符串转换为抽象路径名或从抽象路径名转换本质上是系统依赖的。 当抽象路径名被转换为路径名字符串时，每个名称与默认分隔符的单个副本与下一个名称分隔开。 默认的名称分隔符由系统属性file.separator定义，并在该类的公共静态字段separator和separatorChar中可用。 当路径名字符串转换为抽象路径名时，其中的名称可能由默认名称分隔符或由底层系统支持的任何其他名称 - 分隔符分隔。

    无论是抽象还是字符串形式，路径名可以是绝对的或相对的 。 绝对路径名是完整的，因为不需要其他信息来定位其表示的文件。 相对路径名必须根据从其他路径名获取的信息进行解释。 默认情况下， java.io包中的类始终根据当前用户目录解析相对路径名。 该目录由系统属性user.dir命名，通常是调用Java虚拟机的目录。

    抽象路径名的父级可以通过调用此类的getParent()方法获得，并由路径名的前缀和路径名的名称序列中的每个名称组成，除了最后一个。 每个目录的绝对路径名是任何File对象的祖先，绝对抽象路径名以目录的绝对路径名开头。 例如，由抽象路径名"/usr"表示的目录是由路径名"/usr/local/bin"表示的目录的祖先。

    前缀概念用于处理UNIX平台上的根目录，并在Microsoft Windows平台上驱动说明符，根目录和UNC路径名，如下所示：

    • 对于UNIX平台，绝对路径名的前缀始终为"/" 。 相对路径名没有前缀。 表示根目录的抽象路径名具有前缀"/"和空名称序列。
    • 对于Microsoft Windows平台，包含驱动器说明符的路径名的前缀包含驱动器":" ，后跟"\\"如果路径名为绝对，可能后跟"\\" 。 UNC路径名的前缀为"\\\" ; 主机名和共享名称是名称序列中的前两个名称。 没有指定驱动器的相对路径名没有前缀。

    该类的实例可以表示或不表示实际的文件系统对象，例如文件或目录。 如果它表示这样一个对象，那么该对象驻留在一个分区中 。 分区是文件系统的特定于操作系统的存储部分。 单个存储设备（例如物理磁盘驱动器，闪存，CD-ROM）可能包含多个分区。 对象（如果有的话）将驻留在由此路径名的绝对形式的一些祖先的分区named上 。

    文件系统可以对实际的文件系统对象上的某些操作实施限制，例如读取，写入和执行。 这些限制统称为访问权限 。 文件系统对单个对象可以具有多组访问权限。 例如，一组可能适用于对象的所有者 ，另一组可能适用于所有其他用户。 对象的访问权限可能会导致此类中的某些方法失败。

    File类的实例是不可变的; 也就是说，一旦创建，由File对象表示的抽象路径名永远不会改变。

    互操作性与java.nio.file包

    java.nio.file包定义了Java虚拟机访问文件，文件属性和文件系统的接口和类。 该API可能被用来克服java.io.File类的许多限制。 可以使用toPath方法来获得Path ，其使用由File对象表示的抽象路径来定位文件。 所产生的Path可能与Files类一起使用，以提供更高效和更广泛的访问附加文件操作，文件属性和I / O异常，以帮助在文件操作失败时诊断错误。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String pathSeparator
      与系统相关的路径分隔符字符，为方便起见，表示为字符串。
      static char pathSeparatorChar
      与系统相关的路径分隔符。
      static String separator
      与系统相关的默认名称 - 分隔符字符，以方便的方式表示为字符串。
      static char separatorChar
      与系统相关的默认名称分隔符。

    • 构造方法摘要

      构造方法
      Constructor 描述
      File​(File parent, String child)
      从父抽象路径名和子路径名字符串创建新的 File实例。
      File​(String pathname)
      通过将给定的路径名字符串转换为抽象路径名来创建新的 File实例。
      File​(String parent, String child)
      从父路径名字符串和子路径名字符串创建新的 File实例。
      File​(URI uri)
      通过将给定的 file: URI转换为抽象路径名来创建新的 File实例。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean canExecute​()
      测试应用程序是否可以执行此抽象路径名表示的文件。
      boolean canRead​()
      测试应用程序是否可以读取由此抽象路径名表示的文件。
      boolean canWrite​()
      测试应用程序是否可以修改由此抽象路径名表示的文件。
      int compareTo​(File pathname)
      比较两个抽象的路径名字典。
      boolean createNewFile​()
      当且仅当具有该名称的文件尚不存在时，原子地创建一个由该抽象路径名命名的新的空文件。
      static File createTempFile​(String prefix, String suffix)
      在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。
      static File createTempFile​(String prefix, String suffix, File directory)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      boolean delete​()
      删除由此抽象路径名表示的文件或目录。
      void deleteOnExit​()
      请求在虚拟机终止时删除由此抽象路径名表示的文件或目录。
      boolean equals​(Object obj)
      测试此抽象路径名与给定对象的相等性。
      boolean exists​()
      测试此抽象路径名表示的文件或目录是否存在。
      File getAbsoluteFile​()
      返回此抽象路径名的绝对形式。
      String getAbsolutePath​()
      返回此抽象路径名的绝对路径名字符串。
      File getCanonicalFile​()
      返回此抽象路径名的规范形式。
      String getCanonicalPath​()
      返回此抽象路径名的规范路径名字符串。
      long getFreeSpace​()
      通过此抽象路径名返回分区 named中未分配字节的数量。
      String getName​()
      返回由此抽象路径名表示的文件或目录的名称。
      String getParent​()
      返回此抽象路径名的父目录的路径名字符串，如果此路径名未命名为父目录，则返回 null 。
      File getParentFile​()
      返回此抽象路径名的父目录的抽象路径名，如果此路径名不指定父目录，则返回 null 。
      String getPath​()
      将此抽象路径名转换为路径名字符串。
      long getTotalSpace​()
      通过此抽象路径名返回分区 named的大小。
      long getUsableSpace​()
      通过此抽象路径名返回分区 named上此虚拟机可用的字节数。
      int hashCode​()
      计算此抽象路径名的哈希码。
      boolean isAbsolute​()
      测试这个抽象路径名是否是绝对的。
      boolean isDirectory​()
      测试此抽象路径名表示的文件是否为目录。
      boolean isFile​()
      测试此抽象路径名表示的文件是否为普通文件。
      boolean isHidden​()
      测试此抽象路径名命名的文件是否为隐藏文件。
      long lastModified​()
      返回此抽象路径名表示的文件上次修改的时间。
      long length​()
      返回由此抽象路径名表示的文件的长度。
      String[] list​()
      返回一个字符串数组，命名由此抽象路径名表示的目录中的文件和目录。
      String[] list​(FilenameFilter filter)
      返回一个字符串数组，命名由此抽象路径名表示的目录中满足指定过滤器的文件和目录。
      File[] listFiles​()
      返回一个抽象路径名数组，表示由该抽象路径名表示的目录中的文件。
      File[] listFiles​(FileFilter filter)
      返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
      File[] listFiles​(FilenameFilter filter)
      返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
      static File[] listRoots​()
      列出可用的文件系统根。
      boolean mkdir​()
      创建由此抽象路径名命名的目录。
      boolean mkdirs​()
      创建由此抽象路径名命名的目录，包括任何必需但不存在的父目录。
      boolean renameTo​(File dest)
      重命名由此抽象路径名表示的文件。
      boolean setExecutable​(boolean executable)
      为此抽象路径名设置所有者的执行权限的便利方法。
      boolean setExecutable​(boolean executable, boolean ownerOnly)
      设置该抽象路径名的所有者或每个人的执行权限。
      boolean setLastModified​(long time)
      设置由此抽象路径名命名的文件或目录的最后修改时间。
      boolean setReadable​(boolean readable)
      一种方便的方法来设置所有者对此抽象路径名的读取权限。
      boolean setReadable​(boolean readable, boolean ownerOnly)
      设置此抽象路径名的所有者或每个人的读取权限。
      boolean setReadOnly​()
      标记由此抽象路径名命名的文件或目录，以便只允许读取操作。
      boolean setWritable​(boolean writable)
      一种方便的方法来设置所有者对此抽象路径名的写入权限。
      boolean setWritable​(boolean writable, boolean ownerOnly)
      设置此抽象路径名的所有者或每个人的写入权限。
      Path toPath​()
      返回从此抽象路径构造的一个java.nio.file.Path对象。
      String toString​()
      返回此抽象路径名的路径名字符串。
      URI toURI​()
      构造一个表示此抽象路径名的 file: URI。
      URL toURL​()
      已过时。
      此方法不会自动转义URL中非法的字符。 建议在新的代码转换的抽象路径到URL通过先转换成URI，经由toURI方法，然后经由转换URI为URL URI.toURL方法。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • separatorChar

        public static final char separatorChar
        与系统相关的默认名称分隔符。 该字段被初始化为包含系统属性值的第一个字符file.separator 。 在UNIX系统上，该字段的值为'/' ; 在Microsoft Windows系统上，它是'\\' 。
        另请参见：
        System.getProperty(java.lang.String)

      • separator

        public static final String separator
        与系统相关的默认名称 - 分隔符字符，以方便的方式表示为字符串。 该字符串包含单个字符，即separatorChar 。

      • pathSeparatorChar

        public static final char pathSeparatorChar
        与系统相关的路径分隔符。 该字段被初始化为包含系统属性值的第一个字符path.separator 。 此字符用于将路径列表中给出的文件序列中的文件名分隔。 在UNIX系统上，这个字符是':' ; 在Microsoft Windows系统上，它是';' 。
        另请参见：
        System.getProperty(java.lang.String)

      • pathSeparator

        public static final String pathSeparator
        与系统相关的路径分隔符字符，为方便起见，表示为字符串。 该字符串包含一个字符，即pathSeparatorChar 。

    • 构造方法详细信息

      • File

        public File​(String pathname)
        通过将给定的路径名字符串转换为抽象路径名来创建新的File实例。 如果给定的字符串是空字符串，则结果是空的抽象路径名。
        参数
        pathname - 路径名字符串
        异常
        NullPointerException - 如果 pathname参数为 null

      • File

        public File​(String parent,
            String child)
        从父路径名字符串和子路径名字符串创建新的File实例。

        如果parent是null则创建新的File实例，就像在给定的child路径名字符串上调用单参数File构造函数child 。

        否则，将使用parent路径名字符串表示目录，并将child路径名字符串用于表示目录或文件。 如果child路径名字符串是绝对的，那么它将以系统相关的方式转换为相对路径名。 如果parent是空字符串，则通过将child转换为抽象路径名并根据系统相关的默认目录解析结果来创建新的File实例。 否则，每个路径名字符串将转换为抽象路径名，并且子抽象路径名将针对父对象进行解析。

        参数
        parent - 父路径名字符串
        child - 子路径名字符串
        异常
        NullPointerException - 如果 child是 null

      • File

        public File​(File parent,
            String child)
        从父抽象路径名和子路径名字符串创建一个新的File实例。

        如果parent是null则创建新的File实例，就像在给定的child路径名字符串上调用单参数File构造函数child 。

        否则，采用parent抽象路径名来表示一个目录，并将child路径名字符串用于表示目录或文件。 如果child路径名字符串是绝对的，那么它将以系统相关的方式转换为相对路径名。 如果parent是空抽象路径名，则通过将child转换为抽象路径名并根据系统相关的默认目录解析结果来创建新的File实例。 否则，每个路径名字符串将转换为抽象路径名，并且子抽象路径名将针对父对象进行解析。

        参数
        parent - 父抽象路径名
        child - 子路径名字符串
        异常
        NullPointerException - 如果 child是 null

      • File

        public File​(URI uri)
        通过将给定的file: URI转换为抽象路径名来创建新的File实例。

        file: URI的确切形式是系统依赖的，因此此构造函数执行的转换也依赖于系统。

        对于给定的抽象路径名f，它是保证的

        new File( f .toURI()).equals( f .getAbsoluteFile())
        只要原始的抽象路径名，URI和新的抽象路径名都在同一个Java虚拟机（可能不同的调用）中创建。 但是，当在一个操作系统上的虚拟机中创建的file: URI在不同的操作系统上的虚拟机中转换为抽象路径名时，这种关系通常不成立。
        参数
        uri - 具有等于 "file"的方案的绝对分层URI，非空路径组件，以及未定义的权限，查询和片段组件
        异常
        NullPointerException - 如果 uri是 null
        IllegalArgumentException - 如果参数的前提条件不成立
        从以下版本开始：
        1.4
        另请参见：
        toURI() ， URI

    • 方法详细信息

      • getName

        public String getName​()
        返回由此抽象路径名表示的文件或目录的名称。 这只是路径名称序列中的最后一个名字。 如果路径名的名称序列为空，则返回空字符串。
        结果
        由此抽象路径名表示的文件或目录的名称，如果此路径名的名称序列为空，则为空字符串

      • getParent

        public String getParent​()
        返回此抽象路径名的父目录的路径名字符串，如果此路径名未命名为父目录，则返回null 。

        抽象路径名的父项由路径名的前缀（如果有）和路径名的名称序列中的每个名称组成，除了最后一个。 如果名称序列为空，则路径名不会指定父目录。

        结果
        由此抽象路径名命名的父目录的路径名字符串，或 null如果此路径名未命名为父

      • getParentFile

        public File getParentFile​()
        返回此抽象路径名的父目录的抽象路径名，如果此路径名未命名为父目录，则返回null 。

        抽象路径名的父项由路径名的前缀（如果有）和路径名的名称序列中的每个名称组成，除了最后一个。 如果名称序列为空，则路径名不会指定父目录。

        结果
        由此抽象路径名命名的父目录的抽象路径名，如果此路径名未命名为父类， null
        从以下版本开始：
        1.2

      • getPath

        public String getPath​()
        将此抽象路径名转换为路径名字符串。 生成的字符串使用default name-separator character以名称顺序分隔名称。
        结果
        这个抽象路径名的字符串形式

      • isAbsolute

        public boolean isAbsolute​()
        测试这个抽象路径名是否是绝对的。 绝对路径名的定义是依赖于系统的。 在UNIX系统上，如果前缀为"/" ，路径名是绝对的。 在Microsoft Windows系统上，路径名是绝对的，如果其前缀是驱动器说明符，后跟"\\" ，或者前缀为"\\\" 。
        结果
        true如果这个抽象路径名是绝对的， false否则

      • getAbsolutePath

        public String getAbsolutePath​()
        返回此抽象路径名的绝对路径名字符串。

        如果这个抽象路径名已经是绝对的，那么路径名字符串就像getPath()方法一样简单地返回。 如果此抽象路径名为空抽象路径名，则返回由系统属性user.dir命名的当前用户目录的路径名字符串。 否则，该路径名以系统相关的方式解决。 在UNIX系统上，通过将相对路径名解析为当前用户目录，使其成为绝对路径。 在Microsoft Windows系统上，相对路径名是绝对的，通过将其与由路径名命名的驱动器的当前目录（如果有的话）解决; 如果没有，则针对当前用户目录进行解析。

        结果
        绝对路径名字符串表示与此抽象路径名相同的文件或目录
        异常
        SecurityException - 如果无法访问所需的系统属性值。
        另请参见：
        isAbsolute()

      • getAbsoluteFile

        public File getAbsoluteFile​()
        返回此抽象路径名的绝对形式。 相当于new File(this.getAbsolutePath()) 。
        结果
        绝对的抽象路径名表示与该抽象路径名相同的文件或目录
        异常
        SecurityException - 如果无法访问所需的系统属性值。
        从以下版本开始：
        1.2

      • getCanonicalPath

        public String getCanonicalPath​()
                        throws IOException
        返回此抽象路径名的规范路径名字符串。

        规范的路径名是绝对的和唯一的。 规范形式的精确定义是系统依赖的。 如果需要，该方法首先将此路径名转换为绝对形式，就像调用getAbsolutePath()方法一样，然后以系统相关的方式将其映射到其唯一形式。 这通常包括从路径名中删除冗余名称，例如"."和".." ，解析符号链接（在UNIX平台上），并将驱动器号转换为标准情况（在Microsoft Windows平台上）。

        表示现有文件或目录的每个路径名都具有唯一的规范形式。 表示不存在的文件或目录的每个路径名也具有唯一的规范形式。 不存在的文件或目录的路径名的规范形式可能与创建文件或目录后的相同路径名的规范形式不同。 类似地，现有文件或目录的路径名的规范形式可能与删除文件或目录后的相同路径名的规范形式不同。

        结果
        规范的路径名字符串表示与该抽象路径名相同的文件或目录
        异常
        IOException - 如果发生I / O错误，这是可能的，因为规范路径名的构造可能需要文件系统查询
        SecurityException - 如果无法访问所需的系统属性值，或者存在安全管理员，并且其 SecurityManager.checkRead(java.io.FileDescriptor)方法拒绝对文件的读取访问
        从以下版本开始：
        1.1
        另请参见：
        Path.toRealPath(java.nio.file.LinkOption...)

      • getCanonicalFile

        public File getCanonicalFile​()
                      throws IOException
        返回此抽象路径名的规范形式。 相当于new File(this.getCanonicalPath()) 。
        结果
        规范的路径名字符串表示与该抽象路径名相同的文件或目录
        异常
        IOException - 如果发生I / O错误，这是可能的，因为规范路径名的构造可能需要文件系统查询
        SecurityException - 如果无法访问所需的系统属性值，或者存在安全管理员，并且其 SecurityManager.checkRead(java.io.FileDescriptor)方法拒绝对文件的读取访问
        从以下版本开始：
        1.2
        另请参见：
        Path.toRealPath(java.nio.file.LinkOption...)

      • toURL

        @Deprecated
public URL toURL​()
          throws MalformedURLException
        已过时。 此方法不会自动转义URL中非法的字符。 建议在新的代码转换的抽象路径到URL通过先转换成URI，经由toURI方法，然后经由转换URI为URL URI.toURL方法。
        将此抽象路径名转换为file:网址。 URL的确切形式依赖于系统。 如果可以确定由此抽象路径名表示的文件是目录，则生成的URL将以斜杠结尾。
        结果
        表示等效文件URL的URL对象
        异常
        MalformedURLException - 如果路径无法解析为URL
        从以下版本开始：
        1.2
        另请参见：
        toURI() ， URI ， URI.toURL() ， URL

      • toURI

        public URI toURI​()
        构造一个表示此抽象路径名的file: URI。

        URI的确切形式是依赖于系统的。 如果可以确定由此抽象路径名表示的文件是目录，则生成的URI将以斜杠结尾。

        对于给定的抽象路径名f ，它是有保证的

        new File( f .toURI()).equals( f .getAbsoluteFile())
        只要原始的抽象路径名，URI和新的抽象路径名都在同一个Java虚拟机（可能不同的调用）中创建。 然而，由于抽象路径名的系统依赖性质，当在一个操作系统上的虚拟机中创建的一个file: URI被转换为不同操作系统上的虚拟机中的抽象路径名时，这种关系通常不成立。

        请注意，当此抽象路径名表示UNC路径名时，UNC的所有组件（包括服务器名称组件）都将编码在URI路径中。 权限组件未定义，表示为null 。 Path类定义了toUri方法对所生成的URI的权限组件中的服务器名进行编码。 toPath方法可用于获取表示此抽象路径名的Path 。

        结果
        绝对的分层URI，方案等于 "file" ，表示此抽象路径名的路径，以及未定义的权限，查询和片段组件
        异常
        SecurityException - 如果无法访问所需的系统属性值。
        从以下版本开始：
        1.4
        另请参见：
        File(java.net.URI) ， URI ， URI.toURL()

      • canRead

        public boolean canRead​()
        测试应用程序是否可以读取由此抽象路径名表示的文件。 在某些平台上，可以使用特殊权限启动Java虚拟机，以允许它读取标记为不可读的文件。 因此，即使该文件没有读取权限，该方法也可能返回true 。
        结果
        true当且仅当此抽象路径名指定的文件存在并且可以由应用程序读取时; 否则为false
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读取访问

      • canWrite

        public boolean canWrite​()
        测试应用程序是否可以修改由此抽象路径名表示的文件。 在某些平台上，可能会启动具有特殊权限的Java虚拟机，以允许它修改标记为只读的文件。 因此，即使文件被标记为只读，该方法也可能返回true 。
        结果
        true当且仅当文件系统实际包含由该抽象路径名表示的文件并允许应用程序写入文件时; 否则为false 。
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对该文件的写访问

      • exists

        public boolean exists​()
        测试此抽象路径名表示的文件或目录是否存在。
        结果
        true当且仅当存在由此抽象路径名表示的文件或目录时; false否则
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件或目录的读取访问

      • isDirectory

        public boolean isDirectory​()
        测试此抽象路径名表示的文件是否为目录。

        在需要区分I / O异常与文件不是目录的情况或同时需要同一文件的几个属性的情况下，可以使用Files.readAttributes方法。

        结果
        true当且仅当该抽象路径名表示的文件存在且为目录时; 否则为false
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读取访问

      • isFile

        public boolean isFile​()
        测试此抽象路径名表示的文件是否为普通文件。 如果文件不是目录，并且另外满足其他依赖于系统的条件，文件是正常的 。 Java应用程序创建的任何非目录文件都保证是一个普通文件。

        在需要区分I / O异常和文件不是正常文件的情况下，或同时需要同一文件的几个属性的情况下，可以使用Files.readAttributes方法。

        结果
        true当且仅当该抽象路径名表示的文件存在并且是正常文件时; 否则为false
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读取访问

      • isHidden

        public boolean isHidden​()
        测试此抽象路径名命名的文件是否为隐藏文件。 隐藏的确切定义是依赖于系统的。 在UNIX系统上，如果文件的名称以句点字符（ '.' ）开头，则该文件被认为是隐藏的。 在Microsoft Windows系统上，如果文件在文件系统中被标记为这样，则文件被认为是隐藏的。
        结果
        true当且仅当该抽象路径名表示的文件根据底层平台的约定被隐藏时
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读取访问
        从以下版本开始：
        1.2

      • lastModified

        public long lastModified​()
        返回此抽象路径名表示的文件上次修改的时间。
        API Note:
        虽然返回值的时间单位为毫秒，但该值的粒度取决于底层文件系统，并且可能较大。 例如，某些文件系统以秒为单位使用时间戳。

        在需要区分I / O异常和返回0L的情况下，或同时需要同一文件的几个属性或需要最后访问时间或创建时间的情况下，可以使用Files.readAttributes方法。 然而，如果仅需要上次修改的时间，则可以使用Files.getLastModifiedTime方法。

        结果
        甲long表示时间的文件的最后修改值，在从epoch（00:00:00 GMT 1月1日，1970），或毫秒时测量0L ，如果文件不存在，或者如果发生I / O错误。 值可以是负数，表示时期之前的毫秒数
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读取访问

      • length

        public long length​()
        返回由此抽象路径名表示的文件的长度。 如果此路径名表示目录，则返回值未指定。

        在需要区分I / O异常与返回0L的情况或同时需要同一文件的几个属性的情况下，可以使用Files.readAttributes方法。

        结果
        由此抽象路径名表示的文件的长度（以字节为单位），如果文件不存在， 0L 。 某些操作系统可能会返回0L用于表示系统依赖实体（如设备或管道）的路径名。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(java.lang.String)方法拒绝对文件的读取访问

      • createNewFile

        public boolean createNewFile​()
                      throws IOException
        当且仅当具有该名称的文件尚不存在时，原子地创建一个由该抽象路径名命名的新的空文件。 检查文件的存在和文件的创建（如果不存在）是对可能影响文件的所有其他文件系统活动是单一的操作。

        注意：此方法不应用于文件锁定，因为生成的协议不能使其可靠地工作。 应该使用FileLock设施。

        结果
        true如果命名文件不存在并被成功创建; false如果命名文件已经存在
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对该文件的写入访问
        从以下版本开始：
        1.2

      • delete

        public boolean delete​()
        删除由此抽象路径名表示的文件或目录。 如果此路径名表示目录，则目录必须为空才能删除。

        请注意， Files类定义了delete方法，当无法删除文件时，会抛出IOException 。 这对于错误报告和诊断文件无法被删除的原因很有用。

        结果
        true当且仅当文件或目录被成功删除时; 否则为false
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkDelete(java.lang.String)方法拒绝对该文件的删除访问

      • deleteOnExit

        public void deleteOnExit​()
        请求在虚拟机终止时删除由此抽象路径名表示的文件或目录。 文件（或目录）按注册的相反顺序进行删除。 调用此方法删除已注册删除的文件或目录无效。 将仅针对Java语言规范定义的虚拟机的正常终止而尝试删除。

        一旦请求删除，就无法取消请求。 因此，该方法应谨慎使用。

        注意：此方法不应用于文件锁定，因为生成的协议不能使其可靠地工作。 应该使用FileLock工具。

        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkDelete(java.lang.String)方法拒绝对该文件的删除访问
        从以下版本开始：
        1.2
        另请参见：
        delete()

      • list

        public String[] list​()
        返回一个字符串数组，命名由此抽象路径名表示的目录中的文件和目录。

        如果此抽象路径名不表示目录，则此方法返回null 。 否则返回一个字符串数组，一个用于目录中的每个文件或目录。 表示目录本身和目录的父目录的名称不包括在结果中。 每个字符串都是一个文件名，而不是完整的路径。

        不保证结果数组中的名称字符串将以任何特定的顺序出现; 他们不是特别保证按字母顺序出现。

        请注意， Files类定义了打开目录的newDirectoryStream方法，并遍历目录中文件的名称。 在使用非常大的目录时，这可能会减少资源，并且在使用远程目录时可能会更加灵活。

        结果
        一组字符串，命名由此抽象路径名表示的目录中的文件和目录。 如果目录为空，则该数组将为空。 如果此抽象路径名不表示目录，或返回I / O错误，则返回null 。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(String)方法拒绝对目录的读取访问

      • list

        public String[] list​(FilenameFilter filter)
        返回一个字符串数组，命名由此抽象路径名表示的目录中满足指定过滤器的文件和目录。 该方法的行为与list()方法的行为相同，只是返回的数组中的字符串必须满足过滤器。 如果给出的filter是null那么所有的名字都被接受。 否则，当且仅当值true在该抽象路径名上调用过滤器的FilenameFilter.accept(File, String)方法以及其所指示的目录中的文件或目录的名称时，该名称满足过滤器。
        参数
        filter - 文件名过滤器
        结果
        一组字符串，命名由该抽象路径名表示的目录中由给定的filter接受的文件和目录。 如果目录为空，或者过滤器没有接受名称，则该数组将为空。 如果此抽象路径名不表示目录，或返回I / O错误，则返回null 。
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(String)方法拒绝对目录的读取访问
        另请参见：
        Files.newDirectoryStream(Path,String)

      • listFiles

        public File[] listFiles​()
        返回一个抽象路径名数组，表示由该抽象路径名表示的目录中的文件。

        如果此抽象路径名不表示目录，则此方法返回null 。 否则返回一个File对象的数组，一个对应目录中的每个文件或目录。 表示目录本身和目录的父目录的路径名不包括在结果中。 每个生成的抽象路径名由使用File(File, String)构造函数的抽象路径名构造。 因此，如果这个路径名是绝对的，那么每个生成的路径名是绝对的; 如果此路径名是相对的，那么每个生成的路径名将相对于相同的目录。

        不保证结果数组中的名称字符串将以任何特定的顺序出现; 他们不是特别保证按字母顺序出现。

        请注意， Files类定义了打开目录的newDirectoryStream方法，并遍历目录中文件的名称。 当使用非常大的目录时，这可能会减少资源。

        结果
        一组抽象路径名，表示由此抽象路径名表示的目录中的文件和目录。 如果目录为空，则该数组将为空。 如果此抽象路径名不表示目录，或返回I / O错误，则返回null 。
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(String)方法拒绝对目录的读取访问
        从以下版本开始：
        1.2

      • listFiles

        public File[] listFiles​(FilenameFilter filter)
        返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。 此方法的行为与listFiles()方法的行为相同，但返回的数组中的路径名必须满足过滤器。 如果给定的filter是null那么所有的路径名都被接受。 否则，如果且仅当值为true的过滤器的FilenameFilter.accept(File, String)方法在此抽象路径名上被调用时，路径名满足过滤器，并且在其所指示的目录中调用文件或目录的名称。
        参数
        filter - 文件名过滤器
        结果
        一组抽象路径名，表示由此抽象路径名表示的目录中的文件和目录。 如果目录为空，则该数组将为空。 如果此抽象路径名不表示目录，或返回I / O错误，则返回null 。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkRead(String)方法拒绝对目录的读取访问
        从以下版本开始：
        1.2
        另请参见：
        Files.newDirectoryStream(Path,String)

      • listFiles

        public File[] listFiles​(FileFilter filter)
        返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。 该方法的行为与listFiles()方法的行为相同，只是返回的数组中的路径名必须满足该过滤器。 如果给定的filter是null那么所有的路径名都被接受。 否则，当且仅当在路径名true的FileFilter.accept(File)方法时导致值为true时，路径名满足过滤器。
        参数
        filter - 文件过滤器
        结果
        一组抽象路径名，表示由此抽象路径名表示的目录中的文件和目录。 如果目录为空，则该数组将为空。 如果此抽象路径名不表示目录，或者发生I / O错误，则返回null 。
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkRead(String)方法拒绝对目录的读取访问
        从以下版本开始：
        1.2
        另请参见：
        Files.newDirectoryStream(Path,java.nio.file.DirectoryStream.Filter)

      • mkdir

        public boolean mkdir​()
        创建由此抽象路径名命名的目录。
        结果
        true当且仅当创建目录时; false否则
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkWrite(java.lang.String)方法不允许创建命名目录

      • mkdirs

        public boolean mkdirs​()
        创建由此抽象路径名命名的目录，包括任何必需但不存在的父目录。 请注意，如果此操作失败，它可能已成功创建一些必需的父目录。
        结果
        true当且仅当创建目录以及所有必需的父目录时; 否则为false
        异常
        SecurityException - 如果安全管理器存在，并且其SecurityManager.checkRead(java.lang.String)方法不允许验证命名目录和所有必需的父目录的存在; 或者如果SecurityManager.checkWrite(java.lang.String)方法不允许创建命名目录和所有必需的父目录

      • renameTo

        public boolean renameTo​(File dest)
        重命名由此抽象路径名表示的文件。

        该方法的行为的许多方面固有地依赖于平台：重命名操作可能无法将文件从一个文件系统移动到另一个文件系统，它可能不是原子的，如果具有目标抽象路径名的文件可能无法成功已经存在。 应始终检查返回值，以确保重命名操作成功。

        请注意， Files类定义了以独立于平台的方式移动或重命名文件的move方法。

        参数
        dest - 命名文件的新抽象路径名
        结果
        true当且仅当重命名成功; false否则
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对旧的或新的路径名的写入权限
        NullPointerException - 如果参数 dest为 null

      • setLastModified

        public boolean setLastModified​(long time)
        设置由此抽象路径名命名的文件或目录的最后修改时间。

        所有平台都支持文件修改时间到最近的秒数，但有些则提供更高的精度。 参数将被截断以适应支持的精度。 如果操作成功，并且不会对文件进行干预操作，则下一次调用lastModified()方法将返回传递给此方法的（可能截断的） time参数。

        参数
        time - 自上个世纪（1970年1月1日00:00:00 GMT）以来，以毫秒计
        结果
        true当且仅当操作成功时; 否则为false
        异常
        IllegalArgumentException - 如果参数为负数
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对命名文件的写入访问
        从以下版本开始：
        1.2

      • setReadOnly

        public boolean setReadOnly​()
        标记由此抽象路径名命名的文件或目录，以便只允许读取操作。 调用此方法后，文件或目录在删除或标记为允许写入访问之前不会更改。 在某些平台上，可能会启动具有特殊权限的Java虚拟机，以允许它修改标记为只读的文件。 是否可以删除只读文件或目录取决于底层系统。
        结果
        true当且仅当操作成功时; 否则为false
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对命名文件的写入访问
        从以下版本开始：
        1.2

      • setWritable

        public boolean setWritable​(boolean writable,
                           boolean ownerOnly)
        设置此抽象路径名的所有者或每个人的写入权限。 在某些平台上，可能会启动具有特殊权限的Java虚拟机，允许它修改不允许写入操作的文件。

        Files类定义了对文件属性（包括文件权限）进行操作的方法。 当需要更精细的文件权限操作时，可以使用这种方法。

        参数
        writable - 如果是true ，则设置允许写操作的访问权限; 如果false禁止写操作
        ownerOnly - 如果是true ，则写入权限仅适用于所有者的写许可; 否则适用于所有人。 如果底层文件系统无法区分所有者的写入权限与其他用户的写入权限，那么该权限将适用于所有人，不管该值如何。
        结果
        true当且仅当操作成功。 如果用户没有权限更改此抽象路径名的访问权限，操作将失败。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对命名文件的写入访问
        从以下版本开始：
        1.6

      • setWritable

        public boolean setWritable​(boolean writable)
        一种方便的方法来设置所有者对此抽象路径名的写入权限。 在某些平台上，可能会启动具有特殊权限的Java虚拟机，允许它修改不允许写入操作的文件。

        这种file.setWritable(arg)形式的方法的调用与调用的方式完全相同

           file.setWritable(arg, true)
        参数
        writable - 如果是true ，设置访问权限允许写操作; 如果false不允许写操作
        结果
        true当且仅当操作成功。 如果用户没有权限更改此抽象路径名的访问权限，操作将失败。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对文件的写入访问
        从以下版本开始：
        1.6

      • setReadable

        public boolean setReadable​(boolean readable,
                           boolean ownerOnly)
        设置此抽象路径名的所有者或每个人的读取权限。 在某些平台上，可以使用特殊权限启动Java虚拟机，以允许它读取标记为不可读的文件。

        Files类定义了对文件属性（包括文件权限）进行操作的方法。 当需要更精细的文件权限操作时，可以使用这种方法。

        参数
        readable - 如果是true ，则设置访问权限以允许读取操作; 如果false不允许读取操作
        ownerOnly - 如果是true ，则读权限仅适用于所有者的读权限; 否则适用于所有人。 如果底层文件系统无法区分所有者的读取权限与其他用户的读取权限，则该权限将适用于所有人，不管该值如何。
        结果
        true当且仅当操作成功。 如果用户没有权限更改此抽象路径名的访问权限，操作将失败。 如果readable为false ，底层文件系统未实现读取权限，则操作将失败。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对该文件的写入访问
        从以下版本开始：
        1.6

      • setReadable

        public boolean setReadable​(boolean readable)
        一种方便的方法来设置所有者对此抽象路径名的读取权限。 在某些平台上，可以使用特殊权限启动Java虚拟机，以允许它读取标记为不可读的文件。

        对这种file.setReadable(arg)形式的方法的调用与调用的方式完全相同

           file.setReadable(arg, true)
        参数
        readable - 如果true ，设置访问权限以允许读取操作; 如果false不允许读操作
        结果
        true当且仅当操作成功。 如果用户没有权限更改此抽象路径名的访问权限，操作将失败。 如果readable为false ，底层文件系统未实现读取权限，则操作将失败。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对文件的写入访问
        从以下版本开始：
        1.6

      • setExecutable

        public boolean setExecutable​(boolean executable,
                             boolean ownerOnly)
        设置该抽象路径名的所有者或每个人的执行权限。 在某些平台上，可能会启动具有特殊权限的Java虚拟机，以允许其执行未标记为可执行文件。

        Files类定义了对文件属性（包括文件权限）进行操作的方法。 当需要更精细的文件权限操作时，可以使用这种方法。

        参数
        executable - 如果是true ，则设置允许执行操作的访问权限; 如果false禁止执行操作
        ownerOnly - 如果是true ，则执行权限仅适用于所有者的执行权限; 否则适用于所有人。 如果底层文件系统无法区分所有者的执行权限与其他人的执行权限，则该权限将适用于所有人，不管该值。
        结果
        true当且仅当操作成功。 如果用户没有权限更改此抽象路径名的访问权限，操作将失败。 如果executable为false ，底层文件系统未实现执行权限，则操作将失败。
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对该文件的写访问
        从以下版本开始：
        1.6

      • setExecutable

        public boolean setExecutable​(boolean executable)
        为此抽象路径名设置所有者的执行权限的便利方法。 在某些平台上，可能会启动具有特殊权限的Java虚拟机，以允许其执行未标记为可执行文件。

        这种file.setExcutable(arg)形式的方法的调用与调用的方式完全相同

           file.setExecutable(arg, true)
        参数
        executable - 如果是true ，则设置允许执行操作的访问权限; 如果false禁止执行操作
        结果
        true当且仅当操作成功。 如果用户没有权限更改此抽象路径名的访问权限，操作将失败。 如果executable为false ，底层文件系统未实现执行权限，则操作将失败。
        异常
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法拒绝对文件的写入访问
        从以下版本开始：
        1.6

      • canExecute

        public boolean canExecute​()
        测试应用程序是否可以执行此抽象路径名表示的文件。 在某些平台上，可能会启动具有特殊权限的Java虚拟机，以允许其执行未标记为可执行文件。 因此，即使该文件没有执行权限，该方法也可能返回true 。
        结果
        true当且仅当存在抽象路径名 并允许应用程序执行文件时
        异常
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkExec(java.lang.String)方法拒绝执行对该文件的访问
        从以下版本开始：
        1.6

      • listRoots

        public static File[] listRoots​()
        列出可用的文件系统根。

        一个特定的Java平台可以支持零个或多个分层组织的文件系统。 每个文件系统都有一个root目录，从该目录可以访问该文件系统中的所有其他文件。 例如，Windows平台具有每个活动驱动器的根目录; UNIX平台有一个根目录，即"/" 。 可用文件系统根的集合受到各种系统级操作的影响，例如插入或弹出可移动介质以及断开或卸载物理或虚拟磁盘驱动器。

        此方法返回一个File对象的数组，它们表示可用文件系统根的根目录。 确保本地机器上物理存在的任何文件的规范路径名将以此方法返回的其中一个根源开始。

        驻留在某个其他机器上并通过远程文件系统协议（如SMB或NFS）访问的文件的规范路径名可能或可能不以此方法返回的根目录之一开始。 如果远程文件的路径名在语法上与本地文件的路径名无法区分，那么它将以此方法返回的其中一个根开始。 因此，例如， File对象表示在Windows平台的映射的网络驱动器的根目录下将通过该方法返回，而File含有UNC路径名的对象将不通过该方法来返回。

        与此类中的大多数方法不同，此方法不会抛出安全异常。 如果安全管理器存在，并且其SecurityManager.checkRead(String)方法拒绝对特定根目录的读取访问，则该目录将不会显示在结果中。

        结果
        一组File对象表示可用的文件系统根，或null如果无法确定根组。 如果没有文件系统根，数组将为空。
        从以下版本开始：
        1.2
        另请参见：
        FileStore

      • getTotalSpace

        public long getTotalSpace​()
        通过此抽象路径名返回分区 named的大小。
        结果
        分区的大小（以字节为单位），如果此抽象路径名不指定分区， 0L
        异常
        SecurityException - 如果已安装安全管理器，并且它拒绝RuntimePermission ("getFileSystemAttributes")或其SecurityManager.checkRead(String)方法拒绝对此抽象路径名命名的文件的读访问权限
        从以下版本开始：
        1.6

      • getFreeSpace

        public long getFreeSpace​()
        通过此抽象路径名返回分区named中未分配字节的数量。

        返回的未分配字节数是一个提示，但不是保证，可以使用大多数或任何这些字节。 在此呼叫之后，未分配字节的数量很可能是准确的。 任何外部I / O操作（包括在该虚拟机之外的系统上进行的操作）都可能导致不准确。 此方法不保证对该文件系统的写入操作将成功。

        结果
        分区上的未分配字节数或0L如果抽象路径名未命名分区。 该值将小于或等于由getTotalSpace()返回的总文件系统大小。
        异常
        SecurityException - 如果已安装安全管理器，并且它拒绝RuntimePermission ("getFileSystemAttributes")或其SecurityManager.checkRead(String)方法拒绝对此抽象路径名命名的文件的读访问权限
        从以下版本开始：
        1.6

      • getUsableSpace

        public long getUsableSpace​()
        通过此抽象路径名返回分区named上此虚拟机可用的字节数。 在可能的情况下，此方法会检查写入权限和其他操作系统限制，因此通常可以提供比getFreeSpace()更实际的写入数据的准确估计。

        返回的可用字节数是一个提示，但不是保证，可以使用大多数或任何这些字节。 在此呼叫之后，未分配字节的数量很可能是准确的。 任何外部I / O操作（包括在该虚拟机之外的系统上进行的操作）都可能导致不准确。 此方法不保证对该文件系统的写入操作将成功。

        结果
        分区上的可用字节数或0L如果抽象路径名未命名分区。 在此信息不可用的系统上，此方法将等同于对getFreeSpace()的调用。
        异常
        SecurityException - 如果已安装安全管理员，并且它拒绝RuntimePermission ("getFileSystemAttributes")或其SecurityManager.checkRead(String)方法拒绝对此抽象路径名命名的文件的读访问权限
        从以下版本开始：
        1.6

      • createTempFile

        public static File createTempFile​(String prefix,
                                  String suffix,
                                  File directory)
                           throws IOException

        在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。 如果此方法成功返回，则可以保证：

        1. 在调用此方法之前，由返回的抽象路径名表示的文件不存在
        2. 该方法和其任何变体都不会在当前虚拟机的调用中再次返回相同的抽象路径名。
        此方法仅提供临时文件设施的一部分。 要安排通过此方法创建的文件被自动删除，请使用deleteOnExit()方法。

        prefix参数必须至少有三个字符长。 建议前缀为短的有意义的字符串，如"hjb"或"mail" 。 suffix参数可以是null ，在这种情况下将使用后缀".tmp" 。

        要创建新文件，可以首先调整前缀和后缀以适应底层平台的限制。 如果前缀太长，那么它将被截断，但它的前三个字符将始终保留。 如果后缀太长，那么它也将被截断，但是如果以句点字符（ '.' ）开头，那么它的周期和前三个字符将始终保留。 一旦进行了这些调整，将通过连接前缀，五个或更多内部生成的字符和后缀来生成新文件的名称。

        如果directory参数为null则系统依赖的默认临时文件目录将被使用。 默认的临时文件目录由系统属性java.io.tmpdir指定。 在UNIX系统上，此属性的默认值通常为"/tmp"或"/var/tmp" ; 在Microsoft Windows系统上通常是"C:\\WINNT\\TEMP" 。 当Java虚拟机被调用时，可以向该系统属性赋予不同的值，但是不能保证对此属性的编程更改对此方法使用的临时目录有任何影响。

        参数
        prefix - 用于生成文件名的前缀字符串; 长度必须至少为3个字符
        suffix - 用于生成文件名称的后缀字符串; 可能是null ，在这种情况下将使用后缀".tmp"
        directory - 要创建文件的目录，如果要使用默认的临时文件目录， null
        结果
        表示新创建的空文件的抽象路径名
        异常
        IllegalArgumentException - 如果 prefix参数包含少于三个字符
        IOException - 如果无法创建文件
        SecurityException - 如果存在安全管理员，并且其 SecurityManager.checkWrite(java.lang.String)方法不允许创建文件
        从以下版本开始：
        1.2

      • createTempFile

        public static File createTempFile​(String prefix,
                                  String suffix)
                           throws IOException
        在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。 调用此方法相当于调用createTempFile(prefix, suffix, null) 。

        Files.createTempFile方法提供了在临时文件目录中创建空文件的替代方法。 由该方法创建的文件可能对由此方法创建的文件具有更多的限制性访问权限，因此可能更适合对安全敏感的应用程序。

        参数
        prefix - 用于生成文件名的前缀字符串; 长度必须至少为3个字符
        suffix - 用于生成文件名称的后缀字符串; 可以是null ，在这种情况下将使用后缀".tmp"
        结果
        表示新创建的空文件的抽象路径名
        异常
        IllegalArgumentException - 如果 prefix参数包含少于三个字符
        IOException - 如果无法创建文件
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkWrite(java.lang.String)方法不允许创建文件
        从以下版本开始：
        1.2
        另请参见：
        Files.createTempDirectory(String,FileAttribute[])

      • compareTo

        public int compareTo​(File pathname)
        比较两个抽象的路径名字典。 该方法定义的顺序取决于底层系统。 在UNIX系统上，字母大小写在比较路径名中是重要的; 在Microsoft Windows系统上它不是。
        Specified by:
        compareTo在接口 Comparable<File>
        参数
        pathname - 要与此抽象路径名进行比较的抽象路径名
        结果
        如果参数等于此抽象路径名，则为零，如果此抽象路径名在字典上小于参数，则小于零的值，或者如果此抽象路径名在词法上大于参数，则该值大于零
        从以下版本开始：
        1.2

      • equals

        public boolean equals​(Object obj)
        测试此抽象路径名与给定对象的相等性。 返回true当且仅当参数不是null并且是一个抽象路径名，表示与此抽象路径名相同的文件或目录。 两个抽象的路径名是否相等取决于底层系统。 在UNIX系统上，字母大小写在比较路径名中是重要的; 在Microsoft Windows系统上它不是。
        重写：
        equals在 Object
        参数
        obj - 要与此抽象路径名进行比较的对象
        结果
        true当且仅当对象相同时; 否则为false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此抽象路径名的哈希码。 因为抽象路径名的相等性固有地依赖于系统，所以它们的哈希码的计算也是如此。 在UNIX系统上，抽象路径名的哈希码等于其路径名字符串和十进制值1234321的排他或哈希码。 在Microsoft Windows系统上，哈希码等于其转换为小写字母的路径名字符串的排他或哈希码，并且小数值为1234321 。 缩小路径名字符串时不考虑区域设置。
        重写：
        hashCode在 Object
        结果
        此抽象路径名的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此抽象路径名的路径名字符串。 这只是getPath()方法返回的字符串。
        重写：
        toString在 Object
        结果
        这个抽象路径名的字符串形式

      • toPath

        public Path toPath​()
        返回从该抽象路径构造的一个java.nio.file.Path对象。 结果Path与default-filesystem相关联。

        该方法的第一次调用的工作原理就像调用它相当于评估表达式：

         FileSystems.getDefault().getPath(this.getPath());
        此方法的后续调用返回相同的Path 。

        如果此抽象路径名为空抽象路径名，则此方法返回可用于访问当前用户目录的Path 。

        结果
        一个从这个抽象路径构建的 Path
        异常
        InvalidPathException - 如果一个 Path对象不能从抽象路径构造（见 FileSystem.getPath ）
        从以下版本开始：
        1.7
        另请参见：
        Path.toFile()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FileDescriptor

  • java.lang.Object
    • java.io.FileDescriptor

  • public final class FileDescriptor
extends Object
    文件描述符类的实例用作表示打开文件，开放套接字或其他字节源或信宿的底层机器特定结构的不透明句柄。 文件描述符的主要实际用途是创建一个FileInputStream或FileOutputStream来包含它。

    应用程序不应创建自己的文件描述符。

    从以下版本开始：
    1.0
    另请参见：
    FileInputStream ， FileOutputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static FileDescriptor err
      标准错误流的句柄。
      static FileDescriptor in
      标准输入流的句柄。
      static FileDescriptor out
      标准输出流的句柄。

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileDescriptor​()
      构造（无效）FileDescriptor对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void sync​()
      强制所有系统缓冲区与底层设备同步。
      boolean valid​()
      测试此文件描述符对象是否有效。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • in

        public static final FileDescriptor in
        标准输入流的句柄。 通常，该文件描述符不直接使用，而是通过称为System.in的输入流。
        另请参见：
        System.in

      • out

        public static final FileDescriptor out
        标准输出流的句柄。 通常，该文件描述符不直接使用，而是通过称为System.out的输出流。
        另请参见：
        System.out

      • err

        public static final FileDescriptor err
        标准错误流的句柄。 通常，该文件描述符不直接使用，而是通过称为System.err的输出流。
        另请参见：
        System.err

    • 构造方法详细信息

      • FileDescriptor

        public FileDescriptor​()
        构造（无效）FileDescriptor对象。

    • 方法详细信息

      • valid

        public boolean valid​()
        测试此文件描述符对象是否有效。
        结果
        true如果文件描述符对象表示有效的打开文件，套接字或其他活动I / O连接; 否则为false 。

      • sync

        public void sync​()
          throws SyncFailedException
        强制所有系统缓冲区与底层设备同步。 该方法在将此FileDescriptor的所有修改数据和属性都写入相关设备后返回。 特别地，如果该FileDescriptor引用诸如文件系统中的文件的物理存储介质，同步将不会返回，直到与该FileDescriptor相关联的缓冲区的所有内存内修改的副本已被写入物理介质。 同步意图由需要物理存储（如文件）的代码用于已知状态例如，提供简单事务处理的类可能会使用sync来确保由给定的文件引起的对文件的所有更改交易记录在存储介质上。 sync只影响此FileDescriptor下游的缓冲区。 如果应用程序正在执行任何内存缓冲（例如，通过BufferedOutputStream对象），那么这些缓冲区必须在数据受同步影响之前刷新到FileDescriptor中（例如调用OutputStream.flush）。
        异常
        SyncFailedException - 当缓冲区无法刷新时抛出，或者系统无法保证所有缓冲区都已与物理介质同步。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface FileFilter

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface FileFilter
    抽象路径名的过滤器。

    该接口的实例可以传递给File类的listFiles(FileFilter)方法。

    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean accept​(File pathname)
      测试指定的抽象路径名是否应包含在路径名列表中。

    • 方法详细信息

      • accept

        boolean accept​(File pathname)
        测试指定的抽象路径名是否应包含在路径名列表中。
        参数
        pathname - 要测试的抽象路径名
        结果
        true if and only if pathname should be included
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FileInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FileInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class FileInputStream
extends InputStream
    A FileInputStream从文件系统中的文件获取输入字节。 什么文件可用取决于主机环境。

    FileInputStream用于读取诸如图像数据的原始字节流。 要阅读字符流，请考虑使用FileReader 。

    从以下版本开始：
    1.0
    另请参见：
    File ， FileDescriptor ， FileOutputStream ， Files.newInputStream(java.nio.file.Path, java.nio.file.OpenOption...)

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileInputStream​(File file)
      通过打开与实际文件的连接来创建一个 FileInputStream ，该文件由文件系统中的 File对象 file命名。
      FileInputStream​(FileDescriptor fdObj)
      通过使用文件描述符 fdObj创建 FileInputStream ，该文件描述符表示与文件系统中的实际文件的现有连接。
      FileInputStream​(String name)
      通过打开与实际文件的连接来创建一个 FileInputStream ，该文件由文件系统中的路径名 name命名。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int available​()
      返回从此输入流中可以读取（或跳过）的剩余字节数的估计值，而不会被下一次调用此输入流的方法阻塞。
      void close​()
      关闭此文件输入流并释放与流相关联的任何系统资源。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      FileChannel getChannel​()
      返回与此文件输入流相关联的唯一的FileChannel对象。
      FileDescriptor getFD​()
      返回表示与此 FileInputStream正在使用的文件系统中的实际文件的连接的 FileDescriptor对象。
      int read​()
      从该输入流读取一个字节的数据。
      int read​(byte[] b)
      从该输入流读取最多 b.length个字节的数据到一个字节数组。
      int read​(byte[] b, int off, int len)
      从该输入流读取最多 len个字节的数据到字节数组。
      long skip​(long n)
      跳过并从输入流中丢弃 n字节的数据。

      • Methods inherited from class java.io.InputStream

        mark, markSupported, readAllBytes, readNBytes, reset, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileInputStream

        public FileInputStream​(String name)
                throws FileNotFoundException
        通过打开与实际文件的连接创建一个FileInputStream ，该文件由文件系统中的路径名称为name命名。 创建一个新的FileDescriptor对象来表示此文件连接。

        首先，如果有一个安全管理器，它的checkRead方法是以name参数作为参数来调用的。

        如果命名文件不存在，是一个目录而不是常规文件，或者由于某些其他原因无法打开读取，因此抛出一个FileNotFoundException 。

        参数
        name - 与系统相关的文件名。
        异常
        FileNotFoundException - 如果文件不存在，是一个目录而不是常规文件，或者由于某些其他原因无法打开阅读。
        SecurityException - 如果安全管理器存在，并且其 checkRead方法拒绝对该文件的读取访问。
        另请参见：
        SecurityManager.checkRead(java.lang.String)

      • FileInputStream

        public FileInputStream​(File file)
                throws FileNotFoundException
        通过打开与实际文件的连接创建一个FileInputStream ，该文件由文件系统中的File对象file命名。 将创建一个新的FileDescriptor对象来表示此文件连接。

        首先，如果有一个安全管理器，它的checkRead方法被调用，由file参数表示的路径作为其参数。

        如果命名文件不存在，则是一个目录而不是常规文件，或者由于某种其他原因无法打开读取，因此抛出一个FileNotFoundException 。

        参数
        file - 要打开阅读的文件。
        异常
        FileNotFoundException - 如果文件不存在，是一个目录而不是常规文件，或者由于某些其他原因无法打开阅读。
        SecurityException - 如果安全管理器存在，并且其 checkRead方法拒绝对该文件的读取访问。
        另请参见：
        File.getPath() ， SecurityManager.checkRead(java.lang.String)

      • FileInputStream

        public FileInputStream​(FileDescriptor fdObj)
        通过使用文件描述符fdObj创建FileInputStream ，该文件描述符表示与文件系统中的实际文件的现有连接。

        如果有一个安全管理器，它的checkRead方法被调用，文件描述符fdObj作为参数来查看是否可以读取文件描述符。 如果读取访问被拒绝到SecurityException则抛出SecurityException 。

        如果fdObj为null，则抛出一个NullPointerException 。

        如果fdObj为invalid，则此构造函数不会抛出异常。 但是，如果在结果流上调用方法来尝试流上的I / O，则抛出一个IOException 。

        参数
        fdObj - 要打开阅读的文件描述符。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkRead方法拒绝对文件描述符的读取访问。
        另请参见：
        SecurityManager.checkRead(java.io.FileDescriptor)

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        从该输入流读取一个字节的数据。 如果没有输入可用，此方法将阻止。
        Specified by:
        read在类 InputStream
        结果
        数据的下一个字节，如果达到文件的末尾， -1 。
        异常
        IOException - 如果发生I / O错误。

      • read

        public int read​(byte[] b)
         throws IOException
        从该输入流读取最多b.length个字节的数据为字节数组。 此方法将阻塞，直到某些输入可用。
        重写：
        read在 InputStream
        参数
        b - 读取数据的缓冲区。
        结果
        读入缓冲区的总字节数，或者如果没有更多的数据，因为文件的结尾已经到达， -1 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        InputStream.read(byte[], int, int)

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从该输入流读取高达len字节的数据到字节数组。 如果len不为零，则该方法将阻塞，直到某些输入可用; 否则，不会读取字节，并返回0 。
        重写：
        read在类 InputStream
        参数
        b - 读取数据的缓冲区。
        off - 目标阵列中的起始偏移量 b
        len - 读取的最大字节数。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为文件的结尾已经到达， -1 。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负数， len为负数，或 len大于 b.length - off
        IOException - 如果发生I / O错误。
        另请参见：
        InputStream.read()

      • skip

        public long skip​(long n)
          throws IOException
        跳过并从输入流中丢弃n字节的数据。

        由于各种原因， skip方法可能会跳过一些较小数量的字节，可能是0 。 如果n为负，则该方法将尝试向后跳。 如果后台文件不支持在当前位置的向后跳过，则抛出IOException 。 返回实际跳过的字节数。 如果它向前跳，它返回一个正值。 如果它向后跳，它返回一个负值。

        该方法可能会跳过比后备文件中剩余的字节更多的字节。 这不会产生异常，并且跳过的字节数可能包括超出后台文件的EOF的一些字节数。 尝试在跳过结束后从流中读取将导致-1表示文件的结尾。

        重写：
        skip在类 InputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果n为负，如果流不支持查询，或者发生I / O错误。

      • available

        public int available​()
              throws IOException
        返回从此输入流中可以读取（或跳过）的剩余字节数的估计值，而不会被下一次调用此输入流的方法阻塞。 当文件位置超出EOF时返回0。 下一个调用可能是同一个线程或另一个线程。 这个多个字节的单个读取或跳过将不会被阻塞，但可以读取或跳过较少的字节。

        在某些情况下，非阻塞读取（或跳过）在缓慢时可能会被阻止，例如在慢速网络中读取大文件时。

        重写：
        available在 InputStream
        结果
        可以从该输入流中读取（或跳过）而不阻塞的剩余字节数的估计。
        异常
        IOException - 如果此文件输入流已通过调用 close关闭或发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此文件输入流并释放与流相关联的任何系统资源。

        如果该流具有相关联的信道，则该信道也被关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 InputStream
        异常
        IOException - 如果发生I / O错误。

      • getFD

        public final FileDescriptor getFD​()
                           throws IOException
        返回表示与此 FileInputStream正在使用的文件系统中的实际文件的连接的 FileDescriptor对象。
        结果
        与此流关联的文件描述符对象。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FileDescriptor

      • getChannel

        public FileChannel getChannel​()
        返回与此文件输入流相关联的唯一的FileChannel对象。

        到目前为止 ，返回通道的初始值为position将等于从文件读取的字节数。 从该流读取字节将增加通道的位置。 通过显式地或通过阅读来改变频道的位置将会改变这个流的文件位置。

        结果
        与此文件输入流关联的文件通道
        从以下版本开始：
        1.4

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws IOException
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        确保当这个文件输入流的 close方法没有更多的引用时被调用。
        重写：
        finalize在 Object
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        close()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilenameFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface FilenameFilter

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface FilenameFilter
    用于实现此接口的类的实例用于过滤文件名。 这些实例都用在过滤目录列表list类的方法File ，以及抽象窗口工具包的文件对话框组件。
    从以下版本开始：
    1.0
    另请参见：
    FileDialog.setFilenameFilter(java.io.FilenameFilter) ， File ， File.list(java.io.FilenameFilter)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean accept​(File dir, String name)
      测试指定文件是否应包含在文件列表中。

    • 方法详细信息

      • accept

        boolean accept​(File dir,
               String name)
        测试指定文件是否应包含在文件列表中。
        参数
        dir - 找到该文件的目录。
        name - 文件的名称。
        结果
        true当且仅当名称应包含在文件列表中时; 否则为false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FileNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.FileNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class FileNotFoundException
extends IOException
    指示尝试打开由指定路径名表示的文件失败。

    此异常将被抛出FileInputStream ， FileOutputStream ，并RandomAccessFile构造函数用指定的路径名的文件不存在。 如果文件确实存在但由于某种原因存在，这些构造函数也将被抛出，例如当尝试打开只读文件进行写入时。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileNotFoundException​()
      构造一个 FileNotFoundException其中包含 null作为其错误详细消息。
      FileNotFoundException​(String s)
      构造具有指定详细消息的 FileNotFoundException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FileNotFoundException

        public FileNotFoundException​()
        构造一个 FileNotFoundException其中包含 null作为其错误详细消息。

      • FileNotFoundException

        public FileNotFoundException​(String s)
        构造具有指定详细消息的FileNotFoundException 。 字符串s可以稍后通过类别java.lang.Throwable的Throwable.getMessage()方法检索。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FileOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FileOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class FileOutputStream
extends OutputStream
    文件输出流是用于将数据写入File或FileDescriptor的输出流。 文件是否可用或可能被创建取决于底层平台。 特别是某些平台允许一次只能打开一个文件来写入一个FileOutputStream （或其他文件写入对象）。 在这种情况下，如果所涉及的文件已经打开，则此类中的构造函数将失败。

    FileOutputStream用于写入诸如图像数据的原始字节流。 要编写字符流，请考虑使用FileWriter 。

    从以下版本开始：
    1.0
    另请参见：
    File ， FileDescriptor ， FileInputStream ， Files.newOutputStream(java.nio.file.Path, java.nio.file.OpenOption...)

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileOutputStream​(File file)
      创建文件输出流以写入由指定的 File对象表示的文件。
      FileOutputStream​(FileDescriptor fdObj)
      创建文件输出流以写入指定的文件描述符，表示与文件系统中实际文件的现有连接。
      FileOutputStream​(File file, boolean append)
      创建文件输出流以写入由指定的 File对象表示的文件。
      FileOutputStream​(String name)
      创建文件输出流以指定的名称写入文件。
      FileOutputStream​(String name, boolean append)
      创建文件输出流以指定的名称写入文件。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此文件输出流并释放与此流相关联的任何系统资源。
      protected void finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      FileChannel getChannel​()
      返回与此文件输出流相关联的唯一的FileChannel对象。
      FileDescriptor getFD​()
      返回与此流相关联的文件描述符。
      void write​(byte[] b)
      将 b.length字节从指定的字节数组写入此文件输出流。
      void write​(byte[] b, int off, int len)
      将 len字节从指定的字节数组开始，从偏移量 off开始写入此文件输出流。
      void write​(int b)
      将指定的字节写入此文件输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.OutputStream

        flush

    • 构造方法详细信息

      • FileOutputStream

        public FileOutputStream​(String name)
                 throws FileNotFoundException
        创建文件输出流以指定的名称写入文件。 将创建一个新的FileDescriptor对象来表示此文件连接。

        首先，如果有一个安全管理器，它的checkWrite方法是以name作为参数来调用的。

        如果文件存在但是是一个目录而不是常规文件，则不存在但不能创建，或者由于任何其他原因无法打开该FileNotFoundException因此抛出一个FileNotFoundException 。

        实现要求：
        使用参数 name调用此构造函数等效于调用 new FileOutputStream(name, false) 。
        参数
        name - 与系统相关的文件名
        异常
        FileNotFoundException - 如果文件存在但是是一个目录而不是常规文件，不存在但不能创建，或者由于任何其他原因无法打开
        SecurityException - 如果安全管理器存在，并且其 checkWrite方法拒绝对该文件的写入访问。
        另请参见：
        SecurityManager.checkWrite(java.lang.String)

      • FileOutputStream

        public FileOutputStream​(String name,
                        boolean append)
                 throws FileNotFoundException
        创建文件输出流以指定的名称写入文件。 如果第二个参数为true ，则字节将写入文件的末尾而不是开头。 将创建一个新的FileDescriptor对象来表示此文件连接。

        首先，如果有一个安全管理器，它的checkWrite方法将以name作为参数来调用。

        如果文件存在但是是一个目录而不是常规文件，不存在但不能创建，或者由于任何其他原因无法打开，则抛出一个FileNotFoundException 。

        参数
        name - 与系统相关的文件名
        append - 如果是 true ，则字节将写入文件的末尾而不是开头
        异常
        FileNotFoundException - 如果文件存在但是是一个目录而不是常规文件，不存在但不能创建，或由于任何其他原因无法打开。
        SecurityException - 如果安全管理器存在，并且其 checkWrite方法拒绝对该文件的写入访问。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkWrite(java.lang.String)

      • FileOutputStream

        public FileOutputStream​(File file)
                 throws FileNotFoundException
        创建文件输出流以写入由指定的File对象表示的文件。 创建一个新的FileDescriptor对象来表示此文件连接。

        首先，如果有一个安全管理器，它的checkWrite方法被调用，由file参数表示的路径作为其参数。

        如果文件存在但是是一个目录而不是常规文件，不存在但不能创建，或者由于任何其他原因无法打开，那么抛出一个FileNotFoundException 。

        参数
        file - 要打开的文件写入。
        异常
        FileNotFoundException - 如果文件存在但是是一个目录而不是常规文件，不存在但不能创建，或由于任何其他原因无法打开
        SecurityException - 如果安全管理器存在，并且其 checkWrite方法拒绝对该文件的写入访问。
        另请参见：
        File.getPath() ， SecurityException ， SecurityManager.checkWrite(java.lang.String)

      • FileOutputStream

        public FileOutputStream​(File file,
                        boolean append)
                 throws FileNotFoundException
        创建文件输出流以写入由指定的File对象表示的文件。 如果第二个参数为true ，则字节将写入文件的末尾而不是开头。 将创建一个新的FileDescriptor对象来表示此文件连接。

        首先，如果有一个安全管理器，它的checkWrite方法被调用，由file参数表示的路径作为其参数。

        如果文件存在但是是一个目录而不是常规文件，则不存在但不能创建，或者由于任何其他原因无法打开，因此抛出一个FileNotFoundException 。

        参数
        file - 要打开的文件进行写入。
        append - 如果是 true ，则字节将写入文件的末尾而不是开头
        异常
        FileNotFoundException - 如果文件存在但是是一个目录而不是常规文件，则不存在但不能创建，或由于任何其他原因无法打开
        SecurityException - 如果安全管理器存在，并且其 checkWrite方法拒绝对该文件的写入访问。
        从以下版本开始：
        1.4
        另请参见：
        File.getPath() ， SecurityException ， SecurityManager.checkWrite(java.lang.String)

      • FileOutputStream

        public FileOutputStream​(FileDescriptor fdObj)
        创建文件输出流以写入指定的文件描述符，表示与文件系统中实际文件的现有连接。

        首先，如果有一个安全管理器，它的checkWrite方法被调用与文件描述符fdObj参数作为其参数。

        如果fdObj为null，则抛出一个NullPointerException 。

        如果fdObj是invalid，这个构造函数不会抛出异常。 但是，如果在结果流上调用方法来尝试流上的I / O， IOException抛出一个IOException 。

        参数
        fdObj - 要打开来写入的文件描述符
        异常
        SecurityException - 如果存在安全管理员，并且其 checkWrite方法拒绝对文件描述符的写入访问
        另请参见：
        SecurityManager.checkWrite(java.io.FileDescriptor)

    • 方法详细信息

      • write

        public void write​(int b)
           throws IOException
        将指定的字节写入此文件输出流。 实现write方法OutputStream 。
        Specified by:
        write在 OutputStream
        参数
        b - 要写入的字节。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b)
           throws IOException
        将 b.length字节从指定的字节数组写入此文件输出流。
        重写：
        write在 OutputStream
        参数
        b - 数据。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        OutputStream.write(byte[], int, int)

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        将 len字节从指定的字节数组开始，从偏移量 off开始写入此文件输出流。
        重写：
        write在 OutputStream
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此文件输出流并释放与此流相关联的任何系统资源。 此文件输出流可能不再用于写入字节。

        如果该流具有相关联的信道，则该信道也被关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 OutputStream
        异常
        IOException - 如果发生I / O错误。

      • getFD

        public final FileDescriptor getFD​()
                           throws IOException
        返回与此流相关联的文件描述符。
        结果
        FileDescriptor对象，表示与该 FileOutputStream对象正在使用的文件系统中的文件的连接。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FileDescriptor

      • getChannel

        public FileChannel getChannel​()
        返回与此文件输出流相关联的唯一的FileChannel对象。

        返回通道的初始值为position将等于写入文件的字节数，除非该流是附加模式，在这种情况下，它将等于文件的大小。 将字节写入此流将相应地增加通道的位置。 通过显式地或通过写入来更改频道的位置将会改变这个流的文件位置。

        结果
        与此文件输出流关联的文件通道
        从以下版本开始：
        1.4

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws IOException
        已过时。 finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
        清理与文件的连接，并确保在 close有对此流的引用时调用此文件输出流的 close方法。
        重写：
        finalize在 Object
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FileInputStream.close()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FilePermission

  • java.lang.Object
    • java.security.Permission
      • java.io.FilePermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class FilePermission
extends Permission
implements Serializable
    此类表示访问文件或目录。 FilePermission由路径名和对该路径名有效的一组操作组成。

    路径名是授予指定操作的文件或目录的路径名。 以“/ *”结尾的路径名（其中“/”是文件分隔符， File.separatorChar ）表示该目录中包含的所有文件和目录。 以“/ - ”结尾的路径名表示（递归）该目录中包含的所有文件和子目录。 这样的路径名称为通配符路径名。 否则，它是一个简单的路径名。

    由特殊令牌“<<所有文件>>”组成的路径名匹配任何文件。

    注意：由单个“*”组成的路径名表示当前目录中的所有文件，而由单个“ - ”组成的路径名表示当前目录中的所有文件，并递归地显示当前目录中包含的所有文件和子目录目录。

    要授予的操作将以包含一个或多个以逗号分隔的关键字的列表的字符串的形式传递给构造函数。 可能的关键字是“读取”，“写入”，“执行”，“删除”和“读取链接”。 其含义定义如下：

    读
    读权限
    写
    写许可
    执行
    执行权限 允许Runtime.exec 。 对应SecurityManager.checkExec 。
    删除
    删除权限。 允许File.delete 。 对应SecurityManager.checkDelete 。
    的readlink
    阅读链接权限 允许通过调用readSymbolicLink 方法读取symbolic link的目标。

    操作字符串在处理之前转换为小写。

    授予FilePermissions时要小心。 考虑授予读取和特别写入访问各种文件和目录的含义。 使用写入操作的“<<所有文件>>”权限特别危险。 这允许写入整个文件系统的权限。 有效的一件事是更换系统二进制文件，包括JVM运行时环境。

    请注意：代码可以随时从同一目录中读取文件（或该目录的子目录）; 它不需要明确的许可这样做。

    从以下版本开始：
    1.2
    另请参见：
    Permission ， Permissions ， PermissionCollection

    • 构造方法摘要

      构造方法
      Constructor 描述
      FilePermission​(String path, String actions)
      使用指定的操作创建一个新的FilePermission对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查两个FilePermission对象是否相等。
      String getActions​()
      返回动作的“规范字符串表示”。
      int hashCode​()
      返回此对象的哈希码值。
      boolean implies​(Permission p)
      检查此FilePermission对象是否“暗示”指定的权限。
      PermissionCollection newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储FilePermission对象。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • FilePermission

        public FilePermission​(String path,
                      String actions)
        使用指定的操作创建一个新的FilePermission对象。 path是文件或目录的路径名， 操作包含在文件或目录上授予的所需操作的逗号分隔列表。 可能的操作是“读取”，“写入”，“执行”，“删除”和“读取链接”。

        以“/ *”结尾的路径名（其中“/”是文件分隔符， File.separatorChar ）表示该目录中包含的所有文件和目录。 以“/ - ”结尾的路径名表示（递归）该目录中包含的所有文件和子目录。 特殊路径名“<<所有文件>>”匹配任何文件。

        由单个“*”组成的路径名表示当前目录中的所有文件，而由单个“ - ”组成的路径名表示当前目录中的所有文件，并递归地显示当前目录中包含的所有文件和子目录。

        包含空字符串的路径名表示空的路径。

        Implementation Note:
        在这个实现中， jdk.io.permissionsUseCanonicalPath系统属性指示如何处理和存储path参数。

        如果系统属性的值设置为true ， path规范化并存储为名为cpath的String对象。 这意味着将相对路径转换为绝对路径，将Windows DOS风格的8.3路径扩展为长路径，并将符号链接解析为其目标等。

        如果系统属性的值被设置为false ， path被转换为Path命名对象npath后normalization 。 不执行规范化，这意味着底层文件系统不被访问。 如果在转换期间抛出InvalidPathException ，则该FilePermission将被标记为无效。

        在任一种情况下，在通配符path的末尾处的“*”或“ - ”字符在规范化或归一化之前被删除。 它存储在单独的通配符标志字段中。

        该默认值jdk.io.permissionsUseCanonicalPath系统属性为false在此实现。

        参数
        path - 文件/目录的路径名。
        actions - 动作字符串。
        异常
        IllegalArgumentException - 如果操作为 null ， null空或包含除指定的可能操作之外的操作。

    • 方法详细信息

      • implies

        public boolean implies​(Permission p)
        检查此FilePermission对象是否“暗示”指定的权限。

        更具体地说，这个方法返回true：

        • p是FilePermission的一个实例，
        • p的动作是这个对象的动作的一个子集，
        • p的路径名由该对象的路径名隐含。 例如，“/ tmp / *”意味着“/ tmp / foo”，因为“/ tmp / *”包含“/ tmp”目录中的所有文件，包括名为“foo”的文件。

        确切地说，一个简单的路径名意味着另一个简单的路径名，当且仅当它们相等时。 一个简单的路径名不会暗示通配符路径名。 通配符路径名意味着另一个通配符路径名，如果且仅当后者隐含的所有简单路径名都由前者隐含。 通配符路径名表示一个简单的路径名，如果且仅当它们

        • 如果通配符标志为“*”，则简单路径名的路径必须在通配符路径名的路径内。
        • 如果通配符标志为“ - ”，则简单路径名的路径必须在通配符路径名的路径中递归。

        “<<所有文件>>”意味着每个其他路径名。 没有路径名，除了“<<所有文件>>”本身，意味着“<<所有文件>>”。

        Specified by:
        implies在 Permission
        Implementation Note:
        如果jdk.io.permissionsUseCanonicalPath是true ，一个简单的cpath在通配符cpath内部，当且仅当从前者中删除基本名称（路径名称序列中的最后一个名称）时，其余部分等于后者，则简单的cpath在通配符cpath当且仅当前者从后者开始。

        如果jdk.io.permissionsUseCanonicalPath是false ，一个简单的npath在通配符npath内部，如果且仅当simple_npath.relativize(wildcard_npath)完全是“..”，一个简单的npath递归地在通配符npath当且仅当simple_npath.relativize(wildcard_npath)是一系列一个或多个“..” 。 这意味着“/ - ”意味着“/ foo”，而不是“foo”。

        无效FilePermission并不意味着除了本身以外的任何对象。 无效FilePermission不包括任何对象，除了自身或“<<所有文件>>”上的FilePermission ，其操作是此无效FilePermission的超集。 即使使用相同的无效路径创建两个FilePermission ，也不意味着另一个。

        参数
        p - 允许检查。
        结果
        true如果指定的权限不是 null并且被该对象暗示，否则为 false 。

      • equals

        public boolean equals​(Object obj)
        检查两个FilePermission对象是否相等。 检查obj是否是FilePermission，并且具有与该对象相同的路径名和操作。
        Specified by:
        equals在 Permission
        Implementation Note:
        更具体地说，当且仅当它们具有相同的通配符标志和它们的cpath （如果jdk.io.permissionsUseCanonicalPath为true ）或npath （如果jdk.io.permissionsUseCanonicalPath为false ）相等则两个路径名相同。 或者他们都是“<<所有文件>>”。

        当jdk.io.permissionsUseCanonicalPath为false ，无效的FilePermission与自身之外的任何对象不相等，即使使用相同的无效路径创建。

        参数
        obj - 我们正在测试与此对象相等的对象。
        结果
        true如果obj是一个的FilePermission，并且具有相同的路径名和动作，因为这的FilePermission对象， false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。
        Specified by:
        hashCode在 Permission
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions​()
        返回动作的“规范字符串表示”。 也就是说，该方法总是按照以下顺序返回当前动作：read，write，execute，delete，readlink。 例如，如果此FilePermission对象允许写入和读取操作，则调用getActions将返回字符串“读取，写入”。
        Specified by:
        getActions在 Permission
        结果
        规范字符串表示的动作。

      • newPermissionCollection

        public PermissionCollection newPermissionCollection​()
        返回一个新的PermissionCollection对象，用于存储FilePermission对象。

        必须以允许以任何顺序将它们插入到集合中的方式存储FilePermission对象，但这也允许以有效（一致）的方式实现PermissionCollection implies方法。

        例如，如果您有两个FilePermissions：

        1. "/tmp/-", "read"
        2. "/tmp/scratch/foo", "write"

        您正在使用FilePermission调用implies方法：

          "/tmp/scratch/foo", "read,write",
        那么implies函数必须考虑“/ tmp / - ”和“/ tmp / scratch / foo”权限，因此有效权限为“读，写”，而implies返回true。 FilePermissions的“暗示”语义由该newPermissionCollection方法返回的PermissionCollection对象正确处理。
        重写：
        newPermissionCollection在 Permission
        结果
        适用于存储FilePermissions的新PermissionCollection对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FileReader

  • java.lang.Object
    • java.io.Reader
      • java.io.InputStreamReader
        • java.io.FileReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable

    public class FileReader
extends InputStreamReader
    阅读字符文件的便利课。 该类的构造函数假定默认字符编码和默认字节缓冲区大小是适当的。 要自己指定这些值，请在FileInputStream上构造一个InputStreamReader。

    FileReader用于读取字符流。 要读取原始字节流，请考虑使用FileInputStream 。

    从以下版本开始：
    1.1
    另请参见：
    InputStreamReader ， FileInputStream

    • Field Summary

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileReader​(File file)
      创建一个新的 FileReader ，给出 File读取。
      FileReader​(FileDescriptor fd)
      创建一个新的 FileReader ，给予 FileDescriptor从中读取。
      FileReader​(String fileName)
      创建一个新的 FileReader ，给定要读取的文件的名称。

    • 方法摘要

      • Methods inherited from class java.io.InputStreamReader

        close, getEncoding, read, read, ready

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        mark, markSupported, read, read, reset, skip

    • 构造方法详细信息

      • FileReader

        public FileReader​(String fileName)
           throws FileNotFoundException
        创建一个新的 FileReader ，给定要读取的文件的名称。
        参数
        fileName - 要读取的文件的名称
        异常
        FileNotFoundException - 如果命名文件不存在，是一个目录，而不是常规文件，或者由于某些其他原因无法打开阅读。

      • FileReader

        public FileReader​(File file)
           throws FileNotFoundException
        创建一个新的 FileReader ，给予 File读取。
        参数
        file - 要阅读的 File
        异常
        FileNotFoundException - 如果文件不存在，是一个目录而不是常规文件，或者由于某些其他原因无法打开阅读。

      • FileReader

        public FileReader​(FileDescriptor fd)
        创建一个新的 FileReader ，给出 FileDescriptor读取。
        参数
        fd - 要读取的FileDescriptor
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FileWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.OutputStreamWriter
        • java.io.FileWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable

    public class FileWriter
extends OutputStreamWriter
    方便课写字符文件。 该类的构造函数假定默认字符编码和默认字节缓冲区大小是可以接受的。 要自己指定这些值，请在FileOutputStream上构造一个OutputStreamWriter。

    文件是否可用或可能被创建取决于底层平台。 特别是某些平台允许一次只能打开一个文件来写入一个FileWriter （或其他文件写入对象）。 在这种情况下，如果所涉及的文件已经打开，则此类中的构造函数将失败。

    FileWriter用于写入字符流。 要编写原始字节流，请考虑使用FileOutputStream 。

    从以下版本开始：
    1.1
    另请参见：
    OutputStreamWriter ， FileOutputStream

    • Field Summary

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      FileWriter​(File file)
      给一个File对象构造一个FileWriter对象。
      FileWriter​(FileDescriptor fd)
      构造与文件描述符关联的FileWriter对象。
      FileWriter​(File file, boolean append)
      给一个File对象构造一个FileWriter对象。
      FileWriter​(String fileName)
      构造一个给定文件名的FileWriter对象。
      FileWriter​(String fileName, boolean append)
      构造一个FileWriter对象，给出一个带有布尔值的文件名，表示是否附加写入的数据。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.OutputStreamWriter

        append, append, close, flush, getEncoding, write, write, write

      • Methods inherited from class java.io.Writer

        append, write, write

    • 构造方法详细信息

      • FileWriter

        public FileWriter​(String fileName)
           throws IOException
        构造一个给定文件名的FileWriter对象。
        参数
        fileName - String系统相关的文件名。
        异常
        IOException - 如果命名文件存在但是是一个目录而不是常规文件，则不存在但不能创建，或由于任何其他原因无法打开

      • FileWriter

        public FileWriter​(String fileName,
                  boolean append)
           throws IOException
        构造一个FileWriter对象，给出一个带有布尔值的文件名，表示是否附加写入的数据。
        参数
        fileName - String系统相关的文件名。
        append - 布尔值如果是 true ，则数据将被写入文件的末尾而不是开头。
        异常
        IOException - 如果命名文件存在但是是一个目录而不是常规文件，则不存在但不能创建，或由于任何其他原因无法打开

      • FileWriter

        public FileWriter​(File file)
           throws IOException
        给一个File对象构造一个FileWriter对象。
        参数
        file - 要写入的File对象。
        异常
        IOException - 如果文件存在但是是一个目录而不是常规文件，不存在但不能创建，或由于任何其他原因无法打开

      • FileWriter

        public FileWriter​(File file,
                  boolean append)
           throws IOException
        给一个File对象构造一个FileWriter对象。 如果第二个参数为true ，则字节将写入文件的末尾而不是开头。
        参数
        file - 要写入的File对象
        append - 如果是 true ，则字节将写入文件的末尾而不是开头
        异常
        IOException - 如果文件存在但是是一个目录而不是常规文件，不存在但不能创建，或由于任何其他原因无法打开
        从以下版本开始：
        1.4

      • FileWriter

        public FileWriter​(FileDescriptor fd)
        构造与文件描述符关联的FileWriter对象。
        参数
        fd - 要写入的FileDescriptor对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilterInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FilterInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    BufferedInputStream ， CheckedInputStream ， CipherInputStream ， DataInputStream ， DeflaterInputStream ， DigestInputStream ， InflaterInputStream ， LineNumberInputStream ， ProgressMonitorInputStream ， PushbackInputStream

    public class FilterInputStream
extends InputStream
    A FilterInputStream包含一些其他输入流，它使用它作为其基本的数据源，可能沿着该方向转换数据或提供附加功能。 类FilterInputStream本身只是简单地重写的所有方法InputStream与传递给所包含输入流的所有请求的版本。 FilterInputStream子类可以进一步覆盖这些方法中的一些，并且还可以提供附加的方法和领域。
    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected InputStream in
      要过滤的输入流。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FilterInputStream​(InputStream in)
      创建 FilterInputStream通过分配参数 in到外地 this.in ，以便记住它供以后使用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      返回从该输入流中可以读取（或跳过）的字节数的估计，而不会被下一个调用者阻塞该输入流的方法。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void mark​(int readlimit)
      标记此输入流中的当前位置。
      boolean markSupported​()
      测试此输入流是否支持 mark和 reset方法。
      int read​()
      从该输入流读取下一个数据字节。
      int read​(byte[] b)
      从该输入流读取高达 b.length字节的数据到字节数组。
      int read​(byte[] b, int off, int len)
      从该输入流读取最多 len字节的数据到一个字节数组。
      void reset​()
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      long skip​(long n)
      跳过并从输入流中丢弃 n个字节的数据。

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • in

        protected volatile InputStream in
        要过滤的输入流。

    • 构造方法详细信息

      • FilterInputStream

        protected FilterInputStream​(InputStream in)
        创建 FilterInputStream通过分配参数 in到外地 this.in ，以便记住它供以后使用。
        参数
        in - 底层输入流，或 null如果此实例要创建没有底层流。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        从该输入流读取下一个数据字节。 值字节被返回作为int范围0到255 。 如果没有字节可用，因为已经到达流的末尾，则返回值-1 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。

        此方法只需执行in.read()并返回结果。

        Specified by:
        read在 InputStream
        结果
        数据的下一个字节，如果达到流的末尾， -1 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        in

      • read

        public int read​(byte[] b)
         throws IOException
        从该输入流读取最多b.length个字节的数据到字节数组。 此方法将阻塞，直到某些输入可用。

        该方法只需执行read(b, 0, b.length)并返回结果。 重要的是不要做in.read(b) ; FilterInputStream某些子类依赖于实际使用的实现策略。

        重写：
        read在 InputStream
        参数
        b - 读取数据的缓冲区。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾，那么 -1 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        read(byte[], int, int)

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从这个输入流读取最多len字节的数据到字节数组。 如果len不为零，该方法将阻塞，直到有些输入可用; 否则，不会读取字节，并返回0 。

        该方法只需执行in.read(b, off, len)并返回结果。

        重写：
        read在 InputStream
        参数
        b - 读取数据的缓冲区。
        off - 目标数组 b的起始偏移量
        len - 读取的最大字节数。
        结果
        读入缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾， -1 。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负， len为负数，或 len大于 b.length - off
        IOException - 如果发生I / O错误。
        另请参见：
        in

      • skip

        public long skip​(long n)
          throws IOException
        跳过并从输入流中丢弃n字节的数据。 由于各种原因， skip方法可能会跳过一些较小数量的字节，可能是0 。 返回实际跳过的字节数。

        这种方法只需执行in.skip(n) 。

        重写：
        skip在类 InputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果 in.skip(n)抛出一个IOException。

      • available

        public int available​()
              throws IOException
        返回从该输入流中可以读取（或跳过）的字节数的估计，而不会被下一个调用者阻塞该输入流的方法。 下一个调用者可能是同一个线程或另一个线程。 这个多个字节的单个读取或跳过将不会被阻塞，但可以读取或跳过较少的字节。

        此方法返回的结果为in .available（）。

        重写：
        available在 InputStream
        结果
        可以从该输入流中读取（或跳过）不受阻塞的字节数的估计。
        异常
        IOException - 如果发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。 该方法简单地执行in.close() 。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在类 InputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        in

      • mark

        public void mark​(int readlimit)
        标记此输入流中的当前位置。 随后调用reset方法将该流重新定位在最后一个标记的位置，以便后续读取重新读取相同的字节。

        readlimit参数告诉这个输入流，允许在标记位置无效之前读取许多字节。

        该方法简单地执行in.mark(readlimit) 。

        重写：
        mark在 InputStream
        参数
        readlimit - 在标记位置无效之前可以读取的最大字节数限制。
        另请参见：
        in ， reset()

      • reset

        public void reset​()
           throws IOException
        将此流重新定位到最后在此输入流上调用mark方法时的位置。

        该方法简单地执行in.reset() 。

        流标记旨在用于您需要先阅读一下以查看流中的内容的情况。 通常这通过调用一些一般的解析器来最容易地完成。 如果流是由解析器处理的类型，那么它就可以快乐地拥抱。 如果流不是该类型，解析器应该在失败时抛出异常。 如果在readlimit字节中发生这种情况，它允许外部代码重置流并尝试另一个解析器。

        重写：
        reset在 InputStream
        异常
        IOException - 如果流未被标记或标记已被无效。
        另请参见：
        in ， mark(int)

      • markSupported

        public boolean markSupported​()
        测试此输入流是否支持mark和reset方法。 这种方法只需执行in.markSupported() 。
        重写：
        markSupported在 InputStream
        结果
        true如果这种流类型支持mark和reset方法; 否则为false 。
        另请参见：
        in ， InputStream.mark(int) ， InputStream.reset()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilterOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FilterOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable
    已知直接子类：
    BufferedOutputStream ， CheckedOutputStream ， CipherOutputStream ， DataOutputStream ， DeflaterOutputStream ， DigestOutputStream ， InflaterOutputStream ， PrintStream

    public class FilterOutputStream
extends OutputStream
    这个类是过滤输出流的所有类的超类。 这些流位于已经存在的输出流（ 底层输出流）之上，它使用它作为数据的基本接收器，但是可能沿着数据方向转换或提供附加功能。

    类FilterOutputStream本身只是简单地重写的所有方法OutputStream与传递到底层输出流的所有请求的版本。 FilterOutputStream子类可以进一步覆盖这些方法中的一些，并提供其他方法和字段。

    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected OutputStream out
      要过滤的底层输出流。

    • 构造方法摘要

      构造方法
      Constructor 描述
      FilterOutputStream​(OutputStream out)
      创建一个基于指定底层输出流的输出流过滤器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此输出流并释放与流相关联的任何系统资源。
      void flush​()
      刷新此输出流，并强制将任何缓冲的输出字节写入流。
      void write​(byte[] b)
      将 b.length字节写入此输出流。
      void write​(byte[] b, int off, int len)
      从指定的 byte阵列写入 len个字节，从偏移量 off开始输出到此输出流。
      void write​(int b)
      将指定的 byte写入此输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • out

        protected OutputStream out
        要过滤的底层输出流。

    • 构造方法详细信息

      • FilterOutputStream

        public FilterOutputStream​(OutputStream out)
        创建一个基于指定底层输出流的输出流过滤器。
        参数
        out - 要分配给字段 this.out以供将来使用的底层输出流，或 null如果此实例将在没有底层流的情况下创建。

    • 方法详细信息

      • write

        public void write​(int b)
           throws IOException
        将指定的byte写入此输出流。

        该write的方法FilterOutputStream调用write其基础输出流的方法，也就是说，它执行out.write(b) 。

        执行摘要write方法OutputStream 。

        Specified by:
        write在 OutputStream
        参数
        b - byte 。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b)
           throws IOException
        将b.length字节写入此输出流。

        该write的方法FilterOutputStream调用它write的三个参数方法与参数b ， 0 ，并b.length 。

        注意，此方法不调用一个参数write其基础输出流的方法与单个参数b 。

        重写：
        write在 OutputStream
        参数
        b - 要写入的数据。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        write(byte[], int, int)

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        从指定的byte阵列写入len字节，从偏移量off开始输出到此输出流。

        该write的方法FilterOutputStream调用write一个参数的每个方法byte输出。

        请注意，此方法不会使用相同的参数调用其底层输出流的write方法。 FilterOutputStream子类应该提供更有效的这种方法的实现。

        重写：
        write在 OutputStream
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        write(int)

      • flush

        public void flush​()
           throws IOException
        刷新此输出流，并强制将任何缓冲的输出字节写入流。

        该flush的方法FilterOutputStream调用flush其基础输出流的方法。

        Specified by:
        flush在接口 Flushable
        重写：
        flush在类 OutputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        out

      • close

        public void close​()
           throws IOException
        关闭此输出流并释放与流相关联的任何系统资源。

        当尚未关闭时， close方法的FilterOutputStream调用其flush方法，然后调用其底层输出流的close方法。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 OutputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        flush() ， out
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilterReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FilterReader

  • java.lang.Object
    • java.io.Reader
      • java.io.FilterReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable
    已知直接子类：
    PushbackReader

    public abstract class FilterReader
extends Reader
    用于读取过滤后的字符流的抽象类。 抽象类FilterReader本身提供了将所有请求传递到包含的流的默认方法。 FilterReader子类应该覆盖这些方法中的一些，并且还可以提供其他方法和字段。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Reader in
      底层字符输入流。

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FilterReader​(Reader in)
      创建一个新的过滤阅读器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流并释放与之相关联的任何系统资源。
      void mark​(int readAheadLimit)
      标记流中的当前位置。
      boolean markSupported​()
      告诉这个流是否支持mark（）操作。
      int read​()
      读一个字符
      int read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      boolean ready​()
      告诉这个流是否准备好被读取。
      void reset​()
      重置流。
      long skip​(long n)
      跳过字符

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        read, read

    • 字段详细信息

      • in

        protected Reader in
        底层字符输入流。

    • 构造方法详细信息

      • FilterReader

        protected FilterReader​(Reader in)
        创建一个新的过滤阅读器。
        参数
        in - 提供基础流的Reader对象。
        异常
        NullPointerException - 如果 in是 null

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        读一个字符
        重写：
        read在 Reader
        结果
        字符读取，作为0到65535（ 0x00-0xffff ）范围内的整数，如果已经达到流的末尾， 0x00-0xffff -1。
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] cbuf,
                int off,
                int len)
         throws IOException
        将字符读入数组的一部分。
        Specified by:
        read中的 Reader
        参数
        cbuf - 目的缓冲区
        off - 开始存储字符的偏移量
        len - 要读取的最大字符数
        结果
        读取的字符数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果发生I / O错误

      • skip

        public long skip​(long n)
          throws IOException
        跳过字符
        重写：
        skip的 Reader
        参数
        n - 要跳过的字符数
        结果
        实际跳过的字符数
        异常
        IOException - 如果发生I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好被读取。
        重写：
        ready在类 Reader
        结果
        如果下一个read（）保证不阻止输入，则为True，否则为false。 请注意，返回false并不能保证下一次读取将被阻止。
        异常
        IOException - 如果发生I / O错误

      • markSupported

        public boolean markSupported​()
        告诉这个流是否支持mark（）操作。
        重写：
        markSupported在类 Reader
        结果
        当且仅当此流支持标记操作时才为真。

      • mark

        public void mark​(int readAheadLimit)
          throws IOException
        标记流中的当前位置。
        重写：
        mark在 Reader
        参数
        readAheadLimit - 限制仍然保留标记时可能读取的字符数。 读了这么多字符后，尝试重置流可能会失败。
        异常
        IOException - 如果发生I / O错误

      • reset

        public void reset​()
           throws IOException
        重置流。
        重写：
        reset在 Reader
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
           throws IOException
        描述从类复制： Reader
        关闭流并释放与之相关联的任何系统资源。 一旦流已关闭，进一步的read（），ready（），mark（），reset（）或skip（）调用将抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Reader
        异常
        IOException - If an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FilterWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class FilterWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.FilterWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable

    public abstract class FilterWriter
extends Writer
    用于编写过滤后的字符流的抽象类。 抽象类FilterWriter本身提供了将所有请求传递到包含的流的默认方法。 FilterWriter子类应该覆盖这些方法中的一些，并且还可以提供其他方法和字段。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Writer out
      底层字符输出流。

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected FilterWriter​(Writer out)
      创建一个新的过滤的作者。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流，先刷新。
      void flush​()
      刷新流。
      void write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void write​(int c)
      写一个字符
      void write​(String str, int off, int len)
      写一个字符串的一部分。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Writer

        append, append, append, write, write

    • 字段详细信息

      • out

        protected Writer out
        底层字符输出流。

    • 构造方法详细信息

      • FilterWriter

        protected FilterWriter​(Writer out)
        创建一个新的过滤的作者。
        参数
        out - 提供底层流的Writer对象。
        异常
        NullPointerException - 如果 out是 null

    • 方法详细信息

      • write

        public void write​(int c)
           throws IOException
        写一个字符
        重写：
        write在类 Writer
        参数
        c - int指定要写入的字符
        异常
        IOException - 如果发生I / O错误

      • write

        public void write​(char[] cbuf,
                  int off,
                  int len)
           throws IOException
        写入字符数组的一部分。
        Specified by:
        write在 Writer
        参数
        cbuf - 要写入的字符缓冲区
        off - 开始读取字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off和 len参数的值导致底层 Writer的相应方法抛出一个 IndexOutOfBoundsException
        IOException - 如果发生I / O错误

      • write

        public void write​(String str,
                  int off,
                  int len)
           throws IOException
        写一个字符串的一部分。
        重写：
        write在 Writer
        参数
        str - 要写入的字符串
        off - 开始读取字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off和 len参数的值导致底层 Writer的相应方法抛出一个 IndexOutOfBoundsException
        IOException - 如果发生I / O错误

      • flush

        public void flush​()
           throws IOException
        刷新流。
        Specified by:
        flush在接口 Flushable
        Specified by:
        flush中的 Writer
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
           throws IOException
        描述从类别复制： Writer
        关闭流，先刷新。 一旦流已关闭，进一步的write（）或flush（）调用将导致抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Writer
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Flushable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface Flushable

  • All Known Subinterfaces:
    JavaFileManager ， StandardJavaFileManager
    所有已知实现类：
    BufferedOutputStream ， BufferedWriter ， ByteArrayOutputStream ， CharArrayWriter ， CheckedOutputStream ， CipherOutputStream ， Console ， DataOutputStream ， DeflaterOutputStream ， DigestOutputStream ， FileOutputStream ， FileWriter ， FilterOutputStream ， FilterWriter ， Formatter ， ForwardingJavaFileManager ， GZIPOutputStream ， InflaterOutputStream ， JarOutputStream ， LogStream ， ObjectOutputStream ， OutputStream ， OutputStream ， OutputStream ， OutputStreamWriter ， PipedOutputStream ， PipedWriter ， PrintStream ， PrintWriter ， StringWriter ， Writer ， ZipOutputStream

    public interface Flushable
    A Flushable是可以刷新的数据的目的地。 调用flush方法将任何缓冲输出写入底层流。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void flush​()
      通过将任何缓冲的输出写入底层流来刷新流。

    • 方法详细信息

      • flush

        void flush​()
    throws IOException
        通过将任何缓冲的输出写入底层流来刷新流。
        异常
        IOException - If an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class InputStream

  • java.lang.Object
    • java.io.InputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    AudioInputStream ， ByteArrayInputStream ， FileInputStream ， FilterInputStream ， InputStream ， ObjectInputStream ， PipedInputStream ， SequenceInputStream ， StringBufferInputStream

    public abstract class InputStream
extends Object
implements Closeable
    这个抽象类是表示输入字节流的所有类的超类。

    需要定义InputStream子类的应用程序必须始终提供一种返回输入的下一个字节的方法。

    从以下版本开始：
    1.0
    另请参见：
    BufferedInputStream ， ByteArrayInputStream ， DataInputStream ， FilterInputStream ， read() ， OutputStream ， PushbackInputStream

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputStream​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void mark​(int readlimit)
      标记此输入流中的当前位置。
      boolean markSupported​()
      测试此输入流是否支持 mark和 reset方法。
      abstract int read​()
      从输入流读取数据的下一个字节。
      int read​(byte[] b)
      从输入流中读取一些字节数，并将它们存储到缓冲器阵列 b 。
      int read​(byte[] b, int off, int len)
      从输入流读取最多 len个字节的数据到字节数组。
      byte[] readAllBytes​()
      从输入流读取所有剩余字节。
      int readNBytes​(byte[] b, int off, int len)
      将所请求的字节数从输入流读入给定的字节数组。
      void reset​()
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      long skip​(long n)
      跳过并丢弃来自此输入流的 n字节的数据。
      long transferTo​(OutputStream out)
      从该输入流中读取所有字节，并按读取的顺序将字节写入给定的输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputStream

        public InputStream​()

    • 方法详细信息

      • read

        public abstract int read​()
                  throws IOException
        从输入流读取数据的下一个字节。 值字节返回为int ，范围为0至255 。 如果没有字节可用，因为已经到达流的末尾，则返回值-1 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。

        一个子类必须提供这个方法的一个实现。

        结果
        数据的下一个字节，如果达到流的末尾， -1 。
        异常
        IOException - 如果发生I / O错误。

      • read

        public int read​(byte[] b)
         throws IOException
        从输入流中读取一些字节数，并将它们存储到缓冲器阵列b 。 实际读取的字节数作为整数返回。 该方法阻塞直到输入数据可用，检测到文件结束或抛出异常。

        如果b的长度为零，则不会读取字节并返回0 ; 否则，尝试读取至少一个字节。 如果没有字节可用，因为流在文件末尾，则返回值-1 ; 否则，读取至少一个字节并将其存储到b 。

        读取的第一个字节存储在元素b[0] ，下一个字节存入b[1] ，依此类推。 读取的字节数最多等于b的长度。 令k为实际读取的字节数; 这些字节将被存储在元素b[0]通过b[ ķ -1] ，留下元件b[ ķ ]通过b[b.length-1]不受影响。

        该read(b)类方法InputStream具有相同的效果为：

           read(b, 0, b.length)
        参数
        b - 读取数据的缓冲区。
        结果
        读入缓冲区的总字节数，如果没有更多的数据，因为已经达到流的结束，则读取的字节数为 -1 。
        异常
        IOException - 如果第一个字节由于除文件结尾之外的任何原因而无法读取，如果输入流已关闭，或者发生其他I / O错误。
        NullPointerException - 如果 b是 null 。
        另请参见：
        read(byte[], int, int)

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从输入流读取最多len个字节的数据到字节数组。 尝试读取多达len个字节，但可以读取较小的数字。 实际读取的字节数作为整数返回。

        该方法阻塞直到输入数据可用，检测到文件结束或抛出异常。

        如果len为零，则不会读取字节，并返回0 ; 否则，尝试读取至少一个字节。 如果没有字节可用，因为流是文件的-1则返回值-1 ; 否则，读取至少一个字节并存储到b 。

        读取的第一个字节存储到元素b[off] ，下一个字节存入b[off+1] ，依此类推。 读取的字节数最多等于len 。 令k为实际读取的字节数; 这些字节将被存储在元素b[off]至b[off+ k -1] ，使得元素b[off+ k ]至b[off+len-1]不受影响。

        在每种情况下，元件b[0]至b[off]和元件b[off+len]至b[b.length-1]不受影响。

        read(b, off, len)方法对于InputStream类，只是重复方法read() 。 如果第一个这样的呼叫产生一个IOException ，则该异常从呼叫返回到read(b, off, len)方法。 如果任何后续调用read()导致一个IOException ，则异常被捕获并被视为文件的结尾; 读取到该点的字节将被存储到b并返回异常发生前读取的字节数。 该方法的默认实现将阻塞，直到已请求的输入数据量len已被读取，文件结束被检测到或异常被抛出。 鼓励子类提供更有效的方法实现。

        参数
        b - 读取数据的缓冲区。
        off - 写入数据的数组 b中的起始偏移量。
        len - 要读取的最大字节数。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾，那么这个字节是 -1 。
        异常
        IOException - 如果第一个字节由于除文件结尾之外的任何原因或输入流已关闭或发生其他I / O错误而无法读取。
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负， len为负数，或 len大于 b.length - off
        另请参见：
        read()

      • readAllBytes

        public byte[] readAllBytes​()
                    throws IOException
        从输入流读取所有剩余字节。 该方法阻塞，直到所有剩余字节都已被读取，并且流检测结束，或抛出异常。 此方法不关闭输入流。

        当此流到达流的末尾时，此方法的进一步调用将返回一个空字节数组。

        请注意，此方法适用于将所有字节读入字节数组的简单情况。 它不是用于读取具有大量数据的输入流。

        输入流异步关闭的情况或读取期间的线程中断的行为是高度输入流特定的，因此未指定。

        如果从输入流读取I / O错误，则可能会在读取一些但不是全部的字节之后执行此操作。 因此，输入流可能不是流的结尾，并且可能处于不一致的状态。 强烈建议如果发生I / O错误，流将被及时关闭。

        结果
        一个包含从该输入流读取的字节的字节数组
        异常
        IOException - 如果发生I / O错误
        OutOfMemoryError - 如果不能分配所需大小的数组。 例如，如果需要大于2GB的数组来存储字节。
        从以下版本开始：
        9

      • readNBytes

        public int readNBytes​(byte[] b,
                      int off,
                      int len)
               throws IOException
        将所请求的字节数从输入流读入给定的字节数组。 该方法阻塞，直到len字节的输入数据被读取，流检测结束或抛出异常。 实际读取的字节数（可能为零）被返回。 此方法不关闭输入流。

        在len字节被读取之前到达流的结束的情况下，将返回读取的实际字节数。 当该流到达流的末尾时，该方法的进一步调用将返回零。

        如果len为零，则不会读取字节并返回0 ; 否则，尝试读取最多len个字节。

        读取的第一个字节存储在元素b[off] ，下一个字节存入b[off+1] ，依此类推。 读取的字节数最多等于len 。 令k为实际读取的字节数; 这些字节将被存储在元素b[off]通过b[off+ ķ -1] ，留下元件b[off+ ķ ]通过b[off+len-1]不受影响。

        输入流异步关闭的情况或读取期间的线程中断的行为是高度输入流特定的，因此未指定。

        如果从输入流读取I / O错误，则可以在b一些但不是全部字节已经使用输入流中的数据更新之后执行此操作。 因此，输入流和b可能处于不一致的状态。 强烈建议如果发生I / O错误，流将被及时关闭。

        参数
        b - 读取数据的字节数组
        off - 写入数据的 b中的起始偏移量
        len - 要读取的最大字节数
        结果
        读入缓冲区的实际字节数
        异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果 b是 null
        IndexOutOfBoundsException - 如果 off为负， len为负数，或 len大于 b.length - off
        从以下版本开始：
        9

      • skip

        public long skip​(long n)
          throws IOException
        跳过并从该输入流中丢弃n个字节的数据。 由于各种原因， skip方法可能会跳过少量的字节，可能是0 。 这可能是由许多条件中的任何一个引起的 在n字节之前已经跳过的文件到达结束只有一种可能。 返回实际跳过的字节数。 如果n是否定的，则skip类方法InputStream总是返回0，并且没有字节被跳过。 子类可以不同地处理负值。

        skip方法实现创建一个字节数组，然后重复读入它，直到已经读取n个字节或已经到达流的结尾。 鼓励子类提供更有效的方法实现。 例如，实施可能取决于寻求的能力。

        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • available

        public int available​()
              throws IOException
        从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。 下一个调用可能是同一个线程或另一个线程。 这个多个字节的单个读取或跳过将不会被阻塞，但可以读取或跳过较少的字节。

        请注意，虽然InputStream一些实现将返回流中的总字节数，但很多不会。 使用此方法的返回值分配用于保存此流中的所有数据的缓冲区是绝对不正确的。

        如果此输入流已通过调用close()方法关闭，则此方法的子类实现可能会选择抛出一个IOException 。

        该available类方法InputStream总是返回0 。

        这个方法应该被子类覆盖。

        结果
        当输入流到达输入流的末尾时，可以从该输入流中读取（或跳过）的字节数，而不会阻塞或 0的字节数。
        异常
        IOException - 如果发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。

        close方法InputStream也没做。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误。

      • mark

        public void mark​(int readlimit)
        标记此输入流中的当前位置。 随后调用reset方法将该流重新定位在最后一个标记的位置，以便后续读取重新读取相同的字节。

        readlimit参数readlimit此输入流，以允许在标记位置无效之前读取许多字节。

        mark的一般合同是，如果方法markSupported返回true ，流可以记住在调用mark之后读取的所有字节，并且如果和无论何时调用方法reset都可以再次提供这些相同的字节。 但是，如果在reset之前从流中读取多达readlimit个字节，则流不需要记住任何数据。

        标记封闭的流对流不应有任何影响。

        mark方法InputStream也没做。

        参数
        readlimit - 在标记位置无效之前可以读取的最大字节数限制。
        另请参见：
        reset()

      • reset

        public void reset​()
           throws IOException
        将此流重新定位到最后在此输入流上调用mark方法时的位置。

        reset的一般合同是：

        • 如果方法markSupported返回true ，则：
          • 如果方法mark自从创建流以来mark调用，或者从最后一次调用的mark起从流读取的字节数大于最后一次调用时的参数mark ，则可能抛出一个IOException 。
          • 如果这样的IOException没有抛出，那么流被重置为一个状态，使得所有字节读取自最近一次调用mark （或自文件开始，如果mark尚未调用）将被重新提供后续呼叫者的read方法，其次是任何字节，否则将是下一个输入数据，在呼叫时间reset 。
        • 如果方法markSupported返回false ，则：
          • 致电reset可能会抛出一个IOException 。
          • 如果没有抛出IOException ，则流将重置为固定状态，这取决于输入流的特定类型及其创建方式。 将提供给read方法的后续呼叫者的read取决于输入流的特定类型。

        该方法reset类InputStream什么也不做只是抛出一个IOException 。

        异常
        IOException - 如果此流未标记或标记已被无效。
        另请参见：
        mark(int) ， IOException

      • markSupported

        public boolean markSupported​()
        测试此输入流是否支持mark和reset方法。 是否支持mark和reset是特定输入流实例的不变属性。 该markSupported方法InputStream回报false 。
        结果
        true如果这个流实例支持标记和重置方法; false否则。
        另请参见：
        mark(int) ， reset()

      • transferTo

        public long transferTo​(OutputStream out)
                throws IOException
        从该输入流中读取所有字节，并按读取的顺序将字节写入给定的输出流。 返回时，此输入流将处于流的末尾。 此方法不关闭任一流。

        该方法可以阻止从输入流无限期地读取，或者写入输出流。 输入和/或输出流异步关闭的情况或传输过程中的线程中断的行为是高度输入和输出流特定的，因此未指定。

        如果从输入流读取或写入输出流发生I / O错误，则可能在读取或写入某些字节后执行此操作。 因此，输入流可能不在流的结尾，并且一个或两个流可能处于不一致的状态。 强烈建议如果发生I / O错误，则两个流都会及时关闭。

        参数
        out - 输出流，非空
        结果
        传输的字节数
        异常
        IOException - 读/写时是否发生I / O错误
        NullPointerException - 如果 out是 null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InputStreamReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class InputStreamReader

  • java.lang.Object
    • java.io.Reader
      • java.io.InputStreamReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable
    已知直接子类：
    FileReader

    public class InputStreamReader
extends Reader
    InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。 它使用的字符集可以由名称指定，也可以被明确指定，或者可以接受平台的默认字符集。

    每个调用InputStreamReader的read（）方法之一可能会导致从底层字节输入流读取一个或多个字节。 为了使字节有效地转换为字符，可以从底层流读取比满足当前读取操作所需的更多字节。

    为了最大的效率，请考虑在BufferedReader中包装一个InputStreamReader。 例如：

      BufferedReader in
   = new BufferedReader(new InputStreamReader(System.in));
    从以下版本开始：
    1.1
    另请参见：
    BufferedReader ， InputStream ， Charset

    • Field Summary

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      InputStreamReader​(InputStream in)
      创建一个使用默认字符集的InputStreamReader。
      InputStreamReader​(InputStream in, String charsetName)
      创建一个使用命名字符集的InputStreamReader。
      InputStreamReader​(InputStream in, Charset cs)
      创建一个使用给定字符集的InputStreamReader。
      InputStreamReader​(InputStream in, CharsetDecoder dec)
      创建一个使用给定字符集解码器的InputStreamReader。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流并释放与之相关联的任何系统资源。
      String getEncoding​()
      返回此流使用的字符编码的名称。
      int read​()
      读一个字符
      int read​(char[] cbuf, int offset, int length)
      将字符读入数组的一部分。
      boolean ready​()
      告诉这个流是否准备好被读取。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        mark, markSupported, read, read, reset, skip

    • 构造方法详细信息

      • InputStreamReader

        public InputStreamReader​(InputStream in)
        创建一个使用默认字符集的InputStreamReader。
        参数
        in - 一个InputStream

      • InputStreamReader

        public InputStreamReader​(InputStream in,
                         String charsetName)
                  throws UnsupportedEncodingException
        创建一个使用命名字符集的InputStreamReader。
        参数
        in - 一个InputStream
        charsetName - 支持的名称charset
        异常
        UnsupportedEncodingException - 如果不支持命名的字符集

      • InputStreamReader

        public InputStreamReader​(InputStream in,
                         Charset cs)
        创建一个使用给定字符集的InputStreamReader。
        参数
        in - 一个InputStream
        cs - 一个字符集
        从以下版本开始：
        1.4

      • InputStreamReader

        public InputStreamReader​(InputStream in,
                         CharsetDecoder dec)
        创建一个使用给定字符集解码器的InputStreamReader。
        参数
        in - 一个InputStream
        dec - 一个字符集解码器
        从以下版本开始：
        1.4

    • 方法详细信息

      • getEncoding

        public String getEncoding​()
        返回此流使用的字符编码的名称。

        如果编码具有历史名称，则返回该名称; 否则返回编码的规范名称。

        如果此实例是使用InputStreamReader(InputStream, String)构造函数创建的，则返回的名称对于编码而言是唯一的，可能与传递给构造函数的名称不同。 如果流已关闭，此方法将返回null 。

        结果
        该编码的历史名称，或 null如果流已关闭
        另请参见：
        Charset

      • read

        public int read​()
         throws IOException
        读一个字符
        重写：
        read在 Reader
        结果
        字符读取，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] cbuf,
                int offset,
                int length)
         throws IOException
        将字符读入数组的一部分。
        Specified by:
        read在 Reader
        参数
        cbuf - 目的缓冲区
        offset - 开始存储字符的偏移量
        length - 要读取的最大字符数
        结果
        读取的字符数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果发生I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好被读取。 如果InputStreamReader的输入缓冲区不为空，或者字节可以从底层字节流读取，则InputStreamReader就绪。
        重写：
        ready在 Reader
        结果
        如果下一个read（）保证不阻止输入，则为True，否则为false。 请注意，返回false并不能保证下一次读取将被阻止。
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
           throws IOException
        描述从类别复制： Reader
        关闭流并释放与之相关联的任何系统资源。 一旦流已关闭，进一步的read（），ready（），mark（），reset（）或skip（）调用将抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Reader
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InterruptedIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class InterruptedIOException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.InterruptedIOException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    SocketTimeoutException

    public class InterruptedIOException
extends IOException
    表示I / O操作已中断。 抛出一个InterruptedIOException ，表示输入或输出传输已被终止，因为执行它的线程被中断。 字段bytesTransferred指示在中断发生之前成功传送了多少个字节。
    从以下版本开始：
    1.0
    另请参见：
    InputStream ， OutputStream ， Thread.interrupt() ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      int bytesTransferred
      报告中断之前作为I / O操作的一部分传输了多少个字节。

    • 构造方法摘要

      构造方法
      Constructor 描述
      InterruptedIOException​()
      构造 InterruptedIOException其中包含 null作为其错误详细消息。
      InterruptedIOException​(String s)
      构造具有指定详细消息的 InterruptedIOException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • bytesTransferred

        public int bytesTransferred
        报告中断之前作为I / O操作的一部分传输了多少个字节。

    • 构造方法详细信息

      • InterruptedIOException

        public InterruptedIOException​()
        构造一个 InterruptedIOException其中包含 null作为其错误详细消息。

      • InterruptedIOException

        public InterruptedIOException​(String s)
        构造具有指定详细消息的InterruptedIOException 。 字符串s可以稍后由检索Throwable.getMessage()类的方法java.lang.Throwable 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidClassException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class InvalidClassException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
            • java.io.InvalidClassException
  • All Implemented Interfaces:
    Serializable

    public class InvalidClassException
extends ObjectStreamException
    当序列化运行时检测到类中的以下问题之一时抛出。
    • 类的串行版本与从流中读取的类描述符的类型不匹配
    • 该类包含未知的数据类型
    • 该类没有可访问的无参数构造函数
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      String classname
      无效类的名称

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidClassException​(String reason)
      针对指定的原因报告InvalidClassException。
      InvalidClassException​(String cname, String reason)
      构造一个InvalidClassException对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getMessage​()
      生成消息并包括类名（如果存在）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • classname

        public String classname
        无效类的名称

    • 构造方法详细信息

      • InvalidClassException

        public InvalidClassException​(String reason)
        针对指定的原因报告InvalidClassException。
        参数
        reason - 描述异常原因的字符串。

      • InvalidClassException

        public InvalidClassException​(String cname,
                             String reason)
        构造一个InvalidClassException对象。
        参数
        cname - 一个命名无效类的字符串。
        reason - 一个描述异常原因的字符串。

    • 方法详细信息

      • getMessage

        public String getMessage​()
        生成消息并包括类名（如果存在）。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能是 null ）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class InvalidObjectException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
            • java.io.InvalidObjectException
  • All Implemented Interfaces:
    Serializable

    public class InvalidObjectException
extends ObjectStreamException
    表示一个或多个反序列化对象失败的验证测试。 这个论点应该是失败的原因。
    从以下版本开始：
    1.1，1.1
    另请参见：
    ObjectInputValidation ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidObjectException​(String reason)
      构造一个 InvalidObjectException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidObjectException

        public InvalidObjectException​(String reason)
        构造一个 InvalidObjectException 。
        参数
        reason - 解释失败原因的详细消息。
        另请参见：
        ObjectInputValidation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IOError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class IOError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.io.IOError
  • All Implemented Interfaces:
    Serializable

    public class IOError
extends Error
    当出现严重I / O错误时抛出。
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IOError​(Throwable cause)
      构造具有指定原因的新的IOError实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IOError

        public IOError​(Throwable cause)
        构造具有指定原因的新的IOError实例。 IOError是通过详细消息(cause==null ? null : cause.toString()) （通常包含原因的类和详细信息）创建的。
        参数
        cause - The cause of this error, or null if the cause is not known
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class IOException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AttachOperationFailedException ， ChangedCharSetException ， CharacterCodingException ， CharConversionException ， ClosedChannelException ， ClosedConnectionException ， EOFException ， FileLockInterruptionException ， FileNotFoundException ， FilerException ， FileSystemException ， HttpRetryException ， HttpTimeoutException ， IIOException ， InterruptedByTimeoutException ， InterruptedIOException ， InvalidPropertiesFormatException ， JMXProviderException ， JMXServerErrorException ， LoadException ， MalformedURLException ， ObjectStreamException ， ProtocolException ， RemoteException ， SaslException ， SocketException ， SSLException ， SyncFailedException ， TransportTimeoutException ， UnknownHostException ， UnknownServiceException ， UnsupportedDataTypeException ， UnsupportedEncodingException ， UserPrincipalNotFoundException ， UTFDataFormatException ， WebSocketHandshakeException ， ZipException

    public class IOException
extends 异常
    表示发生某种类型的I / O异常。 此类是由失败或中断的I / O操作产生的一般异常类。
    从以下版本开始：
    1.0
    另请参见：
    InputStream ， OutputStream ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IOException​()
      构造一个 IOException其中包含 null作为其错误详细消息。
      IOException​(String message)
      构造具有指定详细消息的 IOException 。
      IOException​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的 IOException 。
      IOException​(Throwable cause)
      构造一个 IOException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IOException

        public IOException​()
        构造一个 IOException其中包含 null作为其错误详细消息。

      • IOException

        public IOException​(String message)
        构造具有指定详细消息的 IOException 。
        参数
        message - 详细信息（由 Throwable.getMessage()方法保存供以后检索）

      • IOException

        public IOException​(String message,
                   Throwable cause)
        构造一个具有指定的详细信息和原因的IOException 。

        请注意，与cause相关联的详细信息不会自动并入此异常的详细消息。

        参数
        message - 详细信息（由 Throwable.getMessage()方法保存供以后检索）
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许空值，表示原因不存在或未知。）
        从以下版本开始：
        1.6

      • IOException

        public IOException​(Throwable cause)
        构造一个IOException与指定的原因和详细消息(cause==null ? null : cause.toString()) （它通常包含的类和详细消息cause ）。 这个构造函数对于IO异常非常有用，对于其他的throwable而言，它不仅仅是包装器。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许空值，表示原因不存在或未知。）
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.io (Java SE 9 & JDK 9 )

java.io

Interfaces

  • Closeable
  • DataInput
  • DataOutput
  • Externalizable
  • FileFilter
  • FilenameFilter
  • Flushable
  • ObjectInput
  • ObjectInputFilter
  • ObjectInputFilter.FilterInfo
  • ObjectInputValidation
  • ObjectOutput
  • ObjectStreamConstants
  • Serializable

Classes

  • BufferedInputStream
  • BufferedOutputStream
  • BufferedReader
  • BufferedWriter
  • ByteArrayInputStream
  • ByteArrayOutputStream
  • CharArrayReader
  • CharArrayWriter
  • Console
  • DataInputStream
  • DataOutputStream
  • File
  • FileDescriptor
  • FileInputStream
  • FileOutputStream
  • FilePermission
  • FileReader
  • FileWriter
  • FilterInputStream
  • FilterOutputStream
  • FilterReader
  • FilterWriter
  • InputStream
  • InputStreamReader
  • LineNumberInputStream
  • LineNumberReader
  • ObjectInputFilter.Config
  • ObjectInputStream
  • ObjectInputStream.GetField
  • ObjectOutputStream
  • ObjectOutputStream.PutField
  • ObjectStreamClass
  • ObjectStreamField
  • OutputStream
  • OutputStreamWriter
  • PipedInputStream
  • PipedOutputStream
  • PipedReader
  • PipedWriter
  • PrintStream
  • PrintWriter
  • PushbackInputStream
  • PushbackReader
  • RandomAccessFile
  • Reader
  • SequenceInputStream
  • SerializablePermission
  • StreamTokenizer
  • StringBufferInputStream
  • StringReader
  • StringWriter
  • Writer

Enums

  • ObjectInputFilter.Status

Exceptions

  • CharConversionException
  • EOFException
  • FileNotFoundException
  • InterruptedIOException
  • InvalidClassException
  • InvalidObjectException
  • IOException
  • NotActiveException
  • NotSerializableException
  • ObjectStreamException
  • OptionalDataException
  • StreamCorruptedException
  • SyncFailedException
  • UncheckedIOException
  • UnsupportedEncodingException
  • UTFDataFormatException
  • WriteAbortedException

Errors

  • IOError


java.io (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.io

通过数据流，序列化和文件系统提供系统输入和输出。 除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

包装规格

  • Java Object Serialization Specification

相关文档

有关概述，教程，示例，指南和工具文档，请参阅：
  • The serialver tool
  • Serialization Documentation
从以下版本开始：
1.0
  • 接口摘要
    接口 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    DataInput
    DataInput接口提供从二进制流读取字节并从其中重建任何Java基本类型的数据。
    DataOutput
    DataOutput接口提供将数据从任何Java基本类型转换为一系列字节，并将这些字节写入二进制流。
    Externalizable
    只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。
    FileFilter
    抽象路径名的过滤器。
    FilenameFilter
    用于实现此接口的类的实例用于过滤文件名。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    ObjectInput
    ObjectInput扩展了DataInput接口以包含对象的读取。
    ObjectInputFilter
    反序列化过程中过滤类，数组长度和图形指标。
    ObjectInputFilter.FilterInfo
    FilterInfo提供了有关正在反序列化的当前对象的信息以及ObjectInputStream的状态。
    ObjectInputValidation
    回调界面允许验证图中的对象。
    ObjectOutput
    ObjectOutput扩展了DataOutput接口，包括写入对象。
    ObjectStreamConstants
    写入对象序列化流的常量。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • 类摘要
    Class 描述
    BufferedInputStream
    A BufferedInputStream为另一个输入流添加了功能，即缓冲输入并支持 mark和 reset方法的功能。
    BufferedOutputStream
    该类实现缓冲输出流。
    BufferedReader
    从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
    BufferedWriter
    将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
    ByteArrayInputStream
    A ByteArrayInputStream包含一个内部缓冲区，其中包含可以从流中读取的字节。
    ByteArrayOutputStream
    该类实现了将数据写入字节数组的输出流。
    CharArrayReader
    该类实现了一个字符缓冲区，可以用作字符输入流。
    CharArrayWriter
    该类实现了可以用作Writer的字符缓冲区。
    Console
    访问与当前Java虚拟机关联的基于字符的控制台设备（如果有的话）的方法。
    DataInputStream
    数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
    DataOutputStream
    数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
    File
    文件和目录路径名的抽象表示。
    FileDescriptor
    文件描述符类的实例用作表示打开文件，开放套接字或其他字节源或信宿的底层机器特定结构的不透明句柄。
    FileInputStream
    A FileInputStream从文件系统中的文件获取输入字节。
    FileOutputStream
    文件输出流是用于将数据写入 File或 FileDescriptor的输出流。
    FilePermission
    此类表示访问文件或目录。
    FileReader
    阅读字符文件的便利课。
    FileWriter
    方便课写字符文件。
    FilterInputStream
    A FilterInputStream包含一些其他输入流，它使用它作为其基本的数据源，可能会沿着路径转换数据或提供附加功能。
    FilterOutputStream
    这个类是过滤输出流的所有类的超类。
    FilterReader
    用于读取过滤后的字符流的抽象类。
    FilterWriter
    用于编写过滤后的字符流的抽象类。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    InputStreamReader
    InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。
    LineNumberInputStream Deprecated.
    该类错误地假定字节充分表示字符。
    LineNumberReader
    缓冲字符输入流，跟踪行号。
    ObjectInputFilter.Config
    一个实用程序类，用于设置和获取过程范围的过滤器或从模式字符串创建过滤器。
    ObjectInputStream
    ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
    ObjectInputStream.GetField
    提供对从输入流读取的持久性字段的访问。
    ObjectOutputStream
    ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
    ObjectOutputStream.PutField
    提供对要写入ObjectOutput的持久字段的编程访问。
    ObjectStreamClass
    序列化的类的描述符。
    ObjectStreamField
    Serializable类的Serializable字段的描述。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    OutputStreamWriter
    OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入其的字符编码为字节。
    PipedInputStream
    管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。
    PipedOutputStream
    管道输出流可以连接到管道输入流以创建通信管道。
    PipedReader
    流水字符输入流。
    PipedWriter
    流水字符输出流。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    PushbackInputStream
    A PushbackInputStream通过将推回字节存储在内部缓冲区中，为另一个输入流添加功能，即“推回”或“未读”字节的功能。
    PushbackReader
    一个字符流读取器，允许将字符推回到流中。
    RandomAccessFile
    该类的实例支持读取和写入随机访问文件。
    Reader
    用于读取字符流的抽象类。
    SequenceInputStream
    A SequenceInputStream表示其他输入流的逻辑级联。
    SerializablePermission
    这个类用于Serializable权限。
    StreamTokenizer
    StreamTokenizer类接收输入流并将其解析为“令牌”，允许一次读取令牌。
    StringBufferInputStream Deprecated.
    此类不会将字符正确转换为字节。
    StringReader
    一个字符流，其源是一个字符串。
    StringWriter
    在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。
    Writer
    用于写入字符流的抽象类。
  • 枚举摘要
    Enum 描述
    ObjectInputFilter.Status
    对类的检查状态，数组长度，引用次数，深度和流大小。
  • 异常摘要
    异常 描述
    CharConversionException
    字符转换异常的基类。
    EOFException
    表示在输入过程中意外地到达文件结束或流结束。
    FileNotFoundException
    指示尝试打开由指定路径名表示的文件失败。
    InterruptedIOException
    表示I / O操作已中断。
    InvalidClassException
    当序列化运行时检测到类中的以下问题之一时抛出。
    InvalidObjectException
    表示一个或多个反序列化对象失败的验证测试。
    IOException
    表示发生某种类型的I / O异常。
    NotActiveException
    序列化或反序列化不活跃时抛出。
    NotSerializableException
    抛出一个实例需要一个Serializable接口。
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    OptionalDataException
    表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。
    StreamCorruptedException
    当从对象流读取的控制信息违反内部一致性检查时抛出。
    SyncFailedException
    发出同步操作失败的信号。
    UncheckedIOException
    包装一个IOException与未检查的异常。
    UnsupportedEncodingException
    字符编码不支持。
    UTFDataFormatException
    表示 modified UTF-8格式的格式不正确的字符串已被读入数据输入流或实现数据输入接口的任何类。
    WriteAbortedException
    指示在写入操作期间抛出ObjectStreamExceptions之一。
  • Error Summary
    Error 描述
    IOError
    当出现严重I / O错误时抛出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.io Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.io

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.io.Console (implements java.io.Flushable)
    • java.io.File (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.io.FileDescriptor
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.ByteArrayInputStream
      • java.io.FileInputStream
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
        • java.io.DataInputStream (implements java.io.DataInput)
        • java.io.LineNumberInputStream
        • java.io.PushbackInputStream
      • java.io.ObjectInputStream (implements java.io.ObjectInput, java.io.ObjectStreamConstants)
      • java.io.PipedInputStream
      • java.io.SequenceInputStream
      • java.io.StringBufferInputStream
    • java.io.ObjectInputFilter.Config
    • java.io.ObjectInputStream.GetField
    • java.io.ObjectOutputStream.PutField
    • java.io.ObjectStreamClass (implements java.io.Serializable)
    • java.io.ObjectStreamField (implements java.lang.Comparable<T>)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
      • java.io.FileOutputStream
      • java.io.FilterOutputStream
        • java.io.BufferedOutputStream
        • java.io.DataOutputStream (implements java.io.DataOutput)
        • java.io.PrintStream (implements java.lang.Appendable, java.io.Closeable)
      • java.io.ObjectOutputStream (implements java.io.ObjectOutput, java.io.ObjectStreamConstants)
      • java.io.PipedOutputStream
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.io.SerializablePermission
      • java.io.FilePermission (implements java.io.Serializable)
    • java.io.RandomAccessFile (implements java.io.Closeable, java.io.DataInput, java.io.DataOutput)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
      • java.io.CharArrayReader
      • java.io.FilterReader
        • java.io.PushbackReader
      • java.io.InputStreamReader
        • java.io.FileReader
      • java.io.PipedReader
      • java.io.StringReader
    • java.io.StreamTokenizer
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.io.IOError
      • java.lang.异常
        • java.io.IOException
          • java.io.CharConversionException
          • java.io.EOFException
          • java.io.FileNotFoundException
          • java.io.InterruptedIOException
          • java.io.ObjectStreamException
            • java.io.InvalidClassException
            • java.io.InvalidObjectException
            • java.io.NotActiveException
            • java.io.NotSerializableException
            • java.io.OptionalDataException
            • java.io.StreamCorruptedException
            • java.io.WriteAbortedException
          • java.io.SyncFailedException
          • java.io.UnsupportedEncodingException
          • java.io.UTFDataFormatException
        • java.lang.RuntimeException
          • java.io.UncheckedIOException
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • java.io.BufferedWriter
      • java.io.CharArrayWriter
      • java.io.FilterWriter
      • java.io.OutputStreamWriter
        • java.io.FileWriter
      • java.io.PipedWriter
      • java.io.PrintWriter
      • java.io.StringWriter

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
    • java.io.ObjectInput (also extends java.io.DataInput)
    • java.io.ObjectOutput (also extends java.io.DataOutput)
  • java.io.DataInput
    • java.io.ObjectInput (also extends java.lang.AutoCloseable)
  • java.io.DataOutput
    • java.io.ObjectOutput (also extends java.lang.AutoCloseable)
  • java.io.FileFilter
  • java.io.FilenameFilter
  • java.io.Flushable
  • java.io.ObjectInputFilter
  • java.io.ObjectInputFilter.FilterInfo
  • java.io.ObjectInputValidation
  • java.io.ObjectStreamConstants
  • java.io.Serializable
    • java.io.Externalizable

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.io.ObjectInputFilter.Status
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


LineNumberInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class LineNumberInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.io.LineNumberInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已过时。
    该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。

    @Deprecated
public class LineNumberInputStream
extends FilterInputStream
    这个类是一个输入流过滤器，它提供跟踪当前行号的附加功能。

    行是以回车符（ '\r' ），换行字符（ '\n' ）结尾的字节序列，或紧跟着换行字符的回车符。 在所有三种情况下，行终止字符都作为单个换行符返回。

    行数从0开始，当一个read返回一个换行符时，它增加了1 。

    从以下版本开始：
    1.0
    另请参见：
    LineNumberReader

    • Field Summary

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      LineNumberInputStream​(InputStream in)
      已过时。
      构造从指定输入流读取其输入的换行符输入流。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int available​()
      已过时。
      返回可以从该输入流读取而不阻塞的字节数。
      int getLineNumber​()
      已过时。
      返回当前行号。
      void mark​(int readlimit)
      已过时。
      标记此输入流中的当前位置。
      int read​()
      已过时。
      从该输入流读取下一个数据字节。
      int read​(byte[] b, int off, int len)
      已过时。
      从该输入流读取最多 len个字节的数据到字节数组。
      void reset​()
      已过时。
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      void setLineNumber​(int lineNumber)
      已过时。
      将行号设置为指定的参数。
      long skip​(long n)
      已过时。
      跳过并丢弃来自该输入流的 n字节的数据。

      • Methods inherited from class java.io.FilterInputStream

        close, markSupported, read

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LineNumberInputStream

        public LineNumberInputStream​(InputStream in)
        已过时。
        构造从指定输入流读取其输入的换行符输入流。
        参数
        in - 底层输入流。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        已过时。
        从该输入流读取下一个数据字节。 值字节作为int返回到0到255 。 如果没有字节可用，因为已经到达流的末尾，则返回值-1 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。

        该read的方法LineNumberInputStream调用read基础输入流的方法。 它检查输入中的回车符和换行符，并根据需要修改当前行号。 回车字符或回车符后跟换行符都将转换为单个换行符。

        重写：
        read在 FilterInputStream
        结果
        数据的下一个字节，如果达到此流的末尾， -1 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in ， getLineNumber()

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        已过时。
        从该输入流读取最多len个字节的数据到一个字节数组。 此方法将阻塞，直到某些输入可用。

        该read的方法LineNumberInputStream反复调用read的零个参数方法来填充字节数组英寸

        重写：
        read在 FilterInputStream
        参数
        b - 读取数据的缓冲区。
        off - 数据的起始偏移量。
        len - 读取的最大字节数。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为已经达到这个流的结尾，那么 -1 。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        read()

      • skip

        public long skip​(long n)
          throws IOException
        已过时。
        跳过并丢弃来自此输入流的n字节的数据。 由于各种原因， skip方法可能会跳过一些较小数量的字节，可能是0 。 返回实际跳过的字节数。 如果n为负，则不跳过任何字节。

        该skip的方法LineNumberInputStream创建一个字节数组，然后重复读入，直到n字节已被读出或流的结尾已经到达。

        重写：
        skip在类 FilterInputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in

      • setLineNumber

        public void setLineNumber​(int lineNumber)
        已过时。
        将行号设置为指定的参数。
        参数
        lineNumber - 新的行号。
        另请参见：
        getLineNumber()

      • getLineNumber

        public int getLineNumber​()
        已过时。
        返回当前行号。
        结果
        当前行号。
        另请参见：
        setLineNumber(int)

      • available

        public int available​()
              throws IOException
        已过时。
        返回可以从该输入流读取而不阻塞的字节数。

        请注意，如果底层输入流能够不阻塞地提供k个输入字符，那么LineNumberInputStream可以保证仅提供k / 2个字符而不会阻塞，因为来自底层输入流的k个字符可能包含k / 2对'\r'和'\n' ，它们转换为只有k / 2的'\n'字符。

        重写：
        available在 FilterInputStream
        结果
        可以从此输入流中读取而不阻塞的字节数。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in

      • mark

        public void mark​(int readlimit)
        已过时。
        标记此输入流中的当前位置。 对reset方法的后续调用会将该流重新定位在最后一个标记的位置，以便后续读取重新读取相同的字节。

        该mark的方法LineNumberInputStream记得在一个私有变量的当前行号，然后调用mark基础输入流的方法。

        重写：
        mark在 FilterInputStream
        参数
        readlimit - 标记位置无效之前可以读取的最大字节数。
        另请参见：
        FilterInputStream.in ， reset()

      • reset

        public void reset​()
           throws IOException
        已过时。
        将此流重新定位到最后在此输入流上调用mark方法时的位置。

        该reset的方法LineNumberInputStream复位的行号是在该时间的行号mark方法被调用，然后调用reset基础输入流的方法。

        流标记旨在用于您需要先阅读一下以查看流中的内容的情况。 通常这通过调用一些一般的解析器来最容易地完成。 如果流是由解析器处理的类型，那么它就可以快乐地拥抱。 如果流不是那种类型，解析器应该在失败时抛出一个异常，如果它在readlimit字节中发生，则允许外部代码重置流并尝试另一个解析器。

        重写：
        reset在 FilterInputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in, mark(int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LineNumberReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class LineNumberReader

  • java.lang.Object
    • java.io.Reader
      • java.io.BufferedReader
        • java.io.LineNumberReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable

    public class LineNumberReader
extends BufferedReader
    缓冲字符输入流，跟踪行号。 该类定义用于分别设置和获得当前行号的方法setLineNumber(int)和getLineNumber() 。

    默认情况下，行编号从0开始。读取数据时，该数字将每line terminator递增一次，可通过调用setLineNumber(int)进行更改。 但是请注意， setLineNumber(int)实际上并不改变流中的当前位置; 它只会更改getLineNumber()返回的getLineNumber() 。

    换行符（'\ n'），回车符（'\ r'）中的任一行或随后的换行符都被视为terminated 。

    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      LineNumberReader​(Reader in)
      使用默认的输入缓冲区大小创建一个新的行号阅读器。
      LineNumberReader​(Reader in, int sz)
      创建一个新的行号阅读器，将字符读入给定大小的缓冲区。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getLineNumber​()
      获取当前行号。
      void mark​(int readAheadLimit)
      标记流中的当前位置。
      int read​()
      读一个字符
      int read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      String readLine​()
      读一行文字。
      void reset​()
      将流重新设置为最近的标记。
      void setLineNumber​(int lineNumber)
      设置当前行号。
      long skip​(long n)
      跳过字符

      • Methods inherited from class java.io.BufferedReader

        close, lines, markSupported, ready

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        read, read

    • 构造方法详细信息

      • LineNumberReader

        public LineNumberReader​(Reader in)
        使用默认的输入缓冲区大小创建一个新的行号阅读器。
        参数
        in - 提供底层流的Reader对象

      • LineNumberReader

        public LineNumberReader​(Reader in,
                        int sz)
        创建一个新的行号阅读器，将字符读入给定大小的缓冲区。
        参数
        in - 提供底层流的Reader对象
        sz - 指定缓冲区大小的int

    • 方法详细信息

      • setLineNumber

        public void setLineNumber​(int lineNumber)
        设置当前行号。
        参数
        lineNumber - 指定行号的int
        另请参见：
        getLineNumber()

      • getLineNumber

        public int getLineNumber​()
        获取当前行号。
        结果
        当前行号
        另请参见：
        setLineNumber(int)

      • read

        public int read​()
         throws IOException
        读一个字符 Line terminators被压缩成单个换行符（'\ n'）字符。 每当读取线路终端器时，当前行号增加。
        重写：
        read在 BufferedReader
        结果
        字符读取，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] cbuf,
                int off,
                int len)
         throws IOException
        将字符读入数组的一部分。 每当读取line terminator时 ，当前行号增加。
        重写：
        read在 BufferedReader
        参数
        cbuf - 目的缓冲区
        off - 开始存储字符的偏移量
        len - 要读取的最大字符数
        结果
        读取的字节数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果发生I / O错误

      • readLine

        public String readLine​()
                throws IOException
        读一行文字。 每当读取line terminator时 ，当前行号增加。
        重写：
        readLine在类 BufferedReader
        结果
        包含该行内容的字符串，不包括任何 line termination characters或 null如果已经达到流的末尾）
        异常
        IOException - 如果发生I / O错误
        另请参见：
        Files.readAllLines(java.nio.file.Path, java.nio.charset.Charset)

      • skip

        public long skip​(long n)
          throws IOException
        跳过字符
        重写：
        skip在 BufferedReader
        参数
        n - 要跳过的字符数
        结果
        实际跳过的字符数
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果 n为负数

      • mark

        public void mark​(int readAheadLimit)
          throws IOException
        标记流中的当前位置。 对reset（）的后续调用将尝试将流重新定位到这一点，并且还将适当地重置行号。
        重写：
        mark在 BufferedReader
        参数
        readAheadLimit - 限制仍然保留标记时可能读取的字符数。 读了这么多字符后，尝试重置流可能会失败。
        异常
        IOException - 如果发生I / O错误

      • reset

        public void reset​()
           throws IOException
        将流重新设置为最近的标记。
        重写：
        reset在 BufferedReader
        异常
        IOException - 如果流未被标记，或标记已被无效
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NotActiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class NotActiveException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
            • java.io.NotActiveException
  • All Implemented Interfaces:
    Serializable

    public class NotActiveException
extends ObjectStreamException
    序列化或反序列化不活跃时抛出。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotActiveException​()
      构造函数创建一个新的NotActiveException没有理由。
      NotActiveException​(String reason)
      构造函数创建一个新的NotActiveException与给定的原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotActiveException

        public NotActiveException​(String reason)
        构造函数创建一个新的NotActiveException与给定的原因。
        参数
        reason - 一个描述异常原因的字符串。

      • NotActiveException

        public NotActiveException​()
        构造函数创建一个新的NotActiveException没有理由。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NotSerializableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class NotSerializableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
            • java.io.NotSerializableException
  • All Implemented Interfaces:
    Serializable

    public class NotSerializableException
extends ObjectStreamException
    抛出一个实例需要一个Serializable接口。 序列化运行时或实例的类可能会抛出此异常。 参数应该是类的名称。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NotSerializableException​()
      构造一个NotSerializableException对象。
      NotSerializableException​(String classname)
      构造带有消息字符串的NotSerializableException对象。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NotSerializableException

        public NotSerializableException​(String classname)
        构造带有消息字符串的NotSerializableException对象。
        参数
        classname - 被序列化/反序列化的类的类。

      • NotSerializableException

        public NotSerializableException​()
        构造一个NotSerializableException对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface ObjectInput

  • All Superinterfaces:
    AutoCloseable ， DataInput
    所有已知实现类：
    ObjectInputStream

    public interface ObjectInput
extends DataInput, AutoCloseable
    ObjectInput扩展了DataInput接口以包含对象的读取。 DataInput包括用于输入原始类型的方法，ObjectInput将该接口扩展为包含对象，数组和字符串。
    从以下版本开始：
    1.1
    另请参见：
    InputStream ， ObjectOutputStream ， ObjectInputStream

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int available​()
      返回可以读取而不阻塞的字节数。
      void close​()
      关闭输入流。
      int read​()
      读取一个字节的数据。
      int read​(byte[] b)
      读入一个字节数组。
      int read​(byte[] b, int off, int len)
      读入一个字节数组。
      Object readObject​()
      读取并返回一个对象。
      long skip​(long n)
      跳过n个字节的输入。

      • Methods inherited from interface java.io.DataInput

        readBoolean, readByte, readChar, readDouble, readFloat, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedShort, readUTF, skipBytes

    • 方法详细信息

      • readObject

        Object readObject​()
           throws ClassNotFoundException,
                  IOException
        读取并返回一个对象。 实现此接口的类定义了对象“读取”的位置。
        结果
        该对象从流中读取
        异常
        ClassNotFoundException - 如果无法找到序列化对象的类。
        IOException - 如果发生任何常见的输入/输出相关异常。

      • read

        int read​()
  throws IOException
        读取一个字节的数据。 如果没有输入可用，此方法将阻止。
        结果
        读取字节，如果达到流的结尾，则返回-1。
        异常
        IOException - 如果发生I / O错误。

      • read

        int read​(byte[] b)
  throws IOException
        读入一个字节数组。 该方法将阻塞，直到有些输入可用。
        参数
        b - 读取数据的缓冲区
        结果
        读取的实际字节数，到达流结束时返回-1。
        异常
        IOException - 如果发生I / O错误。

      • read

        int read​(byte[] b,
         int off,
         int len)
  throws IOException
        读入一个字节数组。 该方法将阻塞，直到有些输入可用。
        参数
        b - 读取数据的缓冲区
        off - 数据的起始偏移量
        len - 读取的最大字节数
        结果
        读取的实际字节数，到达流结束时返回-1。
        异常
        IOException - 如果发生I / O错误。

      • skip

        long skip​(long n)
   throws IOException
        跳过n个字节的输入。
        参数
        n - 要跳过的字节数
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • available

        int available​()
       throws IOException
        返回可以读取而不阻塞的字节数。
        结果
        可用字节数。
        异常
        IOException - 如果发生I / O错误。

      • close

        void close​()
    throws IOException
        关闭输入流。 必须调用释放与流相关联的任何资源。
        Specified by:
        close在接口 AutoCloseable
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectInputFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface ObjectInputFilter

  • Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface ObjectInputFilter
    反序列化过程中过滤类，数组长度和图形指标。 如果设置为ObjectInputStream ，则调用checkInput(FilterInfo)方法来验证类，每个数组的长度，从流中读取的对象数，图形的深度以及从流中读取的总字节数。

    可以通过setObjectInputFilter为单个ObjectInputStream设置过滤器。 可以通过Config.setSerialFilter设置一个过滤器，以影响不另外设置过滤器的每个ObjectInputStream 。

    一个过滤器确定参数是ALLOWED还是REJECTED，并返回相应的状态。 如果过滤器无法确定状态，则应返回UNDECIDED 。 过滤器应设计用于特定用例和预期类型。 专为特定用途设计的过滤器可以传递超出过滤器范围的类。 如果过滤器的目的是黑名单，那么它可以拒绝匹配的候选类，并为其他人报告UNDECIDED。 可以用类被称为过滤等于null ， arrayLength等于-1，深度，引用的数量，以及流大小，并返回反映只有一个或只有一些值的状态。 这允许过滤器具体关于其报告的选择，并使用其他过滤器，而不强制允许或拒绝状态。

    通常，自定义过滤器应该检查是否配置了过程范围的过滤器，如果是，则过滤器过滤器被配置。 例如，

       ObjectInputFilter.Status checkInput(FilterInfo info) { ObjectInputFilter serialFilter = ObjectInputFilter.Config.getSerialFilter(); if (serialFilter != null) { ObjectInputFilter.Status status = serialFilter.checkInput(info); if (status != ObjectInputFilter.Status.UNDECIDED) { // The process-wide filter overrides this filter return status; } } if (info.serialClass() != null && Remote.class.isAssignableFrom(info.serialClass())) { return Status.REJECTED; // Do not allow Remote objects } return Status.UNDECIDED; }

    除非另有说明，否则将null参数传递给此接口中的方法及其嵌套类将导致抛出NullPointerException 。

    从以下版本开始：
    9
    另请参见：
    ObjectInputStream.setObjectInputFilter(ObjectInputFilter)

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  ObjectInputFilter.Config
      一个实用程序类，用于设置和获取过程范围的过滤器或从模式字符串创建过滤器。
      static interface  ObjectInputFilter.FilterInfo
      FilterInfo提供了有关正在反序列化的当前对象的信息以及ObjectInputStream的状态。
      static class  ObjectInputFilter.Status
      对类的检查状态，数组长度，引用次数，深度和流大小。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectInputFilter.Status checkInput​(ObjectInputFilter.FilterInfo filterInfo)
      检查类，数组长度，对象引用数，深度，流大小和其他可用过滤信息。

    • 方法详细信息

      • checkInput

        ObjectInputFilter.Status checkInput​(ObjectInputFilter.FilterInfo filterInfo)
        检查类，数组长度，对象引用数，深度，流大小和其他可用过滤信息。 该方法的实现检查反序列化期间创建的对象图的内容。 该过滤器返回Status.ALLOWED ， Status.REJECTED ，或Status.UNDECIDED 。
        参数
        filterInfo - 提供有关反序列化的当前对象的信息（如果有），以及ObjectInputStream的状态
        结果
        Status.ALLOWED如果接受， Status.REJECTED如果拒绝， Status.UNDECIDED如果未决定。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectInputFilter.Config (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectInputFilter.Config

  • java.lang.Object
    • java.io.ObjectInputFilter.Config
  • Enclosing interface:
    ObjectInputFilter

    public static final class ObjectInputFilter.Config
extends Object
    一个实用程序类，用于设置和获取过程范围的过滤器或从模式字符串创建过滤器。 如果设置了一个过程范围的过滤器，它将被用于不设置自己的过滤器的每个ObjectInputStream 。

    设置过滤器时，它应该是无状态的并且是幂等的，当通过相同的参数时报告相同的结果。

    在ObjectInputFilter.Config类的初始化期间配置过滤器。 例如，通过调用Config.getSerialFilter 。 如果定义了系统属性jdk.serialFilter ，则用于配置过滤器。 如果未定义系统属性，并且定义了Security属性jdk.serialFilter ，则用于配置过滤器。 否则，在初始化期间未配置过滤器。 每个属性的语法与createFilter方法相同。 如果未配置过滤器，则可以使用Config.setSerialFilter进行设置。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ObjectInputFilter createFilter​(String pattern)
      从一个模式字符串返回一个ObjectInputFilter。
      static ObjectInputFilter getSerialFilter​()
      如果未配置，则返回过程范围的序列化过滤器或 null 。
      static void setSerialFilter​(ObjectInputFilter filter)
      如果尚未配置或设置过程范围过滤器，请设置该过滤器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getSerialFilter

        public static ObjectInputFilter getSerialFilter​()
        如果未配置，则返回过程范围的序列化过滤器或 null 。
        结果
        过程范围的序列化过滤器或 null如果未配置

      • setSerialFilter

        public static void setSerialFilter​(ObjectInputFilter filter)
        如果尚未配置或设置过程范围过滤器，请设置该过滤器。
        参数
        filter - 将串行化过滤器设置为过程范围过滤器; 不为空
        异常
        SecurityException - 如果有安全管理员，并且没有授予 SerializablePermission("serialFilter")
        IllegalStateException - 如果过滤器已经设置了 non-null

      • createFilter

        public static ObjectInputFilter createFilter​(String pattern)
        从一个模式字符串返回一个ObjectInputFilter。

        模式由“;”分隔 （分号）。 空格是重要的，被认为是模式的一部分。 如果一个模式包含一个等于赋值，“ = ”就设置了一个限制。 如果使用最后一个值多次出现限制。

        • maxdepth = value - 图形的最大深度
        • maxrefs = value - 内部引用的最大数量
        • maxbytes = value - 输入流中的最大字节数
        • maxarray = value - 允许的最大数组长度

        其他模式匹配或拒绝从Class.getName()返回的类或包名称，如果可选模块名称存在class.getModule().getName() 。 请注意，对于数组，元素类型在模式中使用，而不是数组类型。

        • 如果模式以“！”开始，则如果剩余的模式匹配，则该类被拒绝; 否则如果模式匹配，则允许该类。
        • 如果模式包含“/”，则直到“/”的非空前缀是模块名称; 如果模块名称与该类的模块名称相匹配，则剩余模式与类名称相匹配。 如果没有“/”，则不会比较模块名称。
        • 如果模式以“。**”结尾，则它匹配包中的所有类和所有子包。
        • 如果模式以“。*”结尾，则它将与包中的任何类匹配。
        • 如果模式以“*”结尾，则它将匹配任何具有模式的类作为前缀。
        • 如果模式等于类名称，则它匹配。
        • 否则，模式不匹配。

        生成的过滤器执行限制检查，然后尝试匹配类（如果有）。 如果超出任何限制，则过滤器返回Status.REJECTED 。 如果类是数组类型，则要匹配的类是元素类型。 任何数量的维数的数组都与元素类型相同。 例如，“ !example.Foo ”的模式拒绝任何example.Foo实例或数组的example.Foo 。 匹配的第一个模式，从左到右，确定了Status.ALLOWED或Status.REJECTED的结果。 如果不超过限制，没有模式与类匹配，则结果为Status.UNDECIDED 。

        参数
        pattern - 要解析的模式字符串; 不为空
        结果
        一个过滤器，用于检查正在反序列化的类; null如果没有模式
        异常
        IllegalArgumentException - 如果模式字符串非法或格式错误，无法解析。 特别是，如果有以下任何一个：
        • 如果缺少限制，名称或名称不是“maxdepth”，“maxrefs”，“maxbytes”或“maxarray”
        • 如果限制值不能由Long.parseLong解析或为负数
        • 如果模式包含“/”，并且模块名称丢失或剩余的模式为空
        • 如果包中缺少“。*”和“。**”
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectInputFilter.FilterInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface ObjectInputFilter.FilterInfo

  • Enclosing interface:
    ObjectInputFilter

    public static interface ObjectInputFilter.FilterInfo
    FilterInfo提供了有关正在反序列化的当前对象和ObjectInputStream的状态的信息的访问 。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long arrayLength​()
      反序列化类的数组时的数组元素数。
      long depth​()
      当前的深度。
      long references​()
      当前对象引用的数量。
      Class<?> serialClass​()
      被反序列化的对象的类。
      long streamBytes​()
      当前消耗的字节数。

    • 方法详细信息

      • serialClass

        Class<?> serialClass​()
        被反序列化的对象的类。 对于数组，它是数组类型。 例如，二维数组字符串的数组类名为“ [[Ljava.lang.String; ”。 要检查数组的元素类型，迭代地使用Class.getComponentType，而结果是一个数组，然后检查该类。 serialClass is null在新对象未被创建的情况下，并给出过滤器有机会检查深度，对现有对象的引用数量和流大小。
        结果
        反序列化对象的类; 可能为null

      • arrayLength

        long arrayLength​()
        反序列化类的数组时的数组元素数。
        结果
        反序列化数组的数组元素的非负数，否则为-1

      • depth

        long depth​()
        当前的深度。 深度从1开始，每个嵌套对象1增加，每个嵌套对象返回时减少。
        结果
        当前的深度

      • references

        long references​()
        当前对象引用的数量。
        结果
        非负当前数量的对象引用

      • streamBytes

        long streamBytes​()
        当前消耗的字节数。
        实现要求：
        streamBytes是实现特定的，可能不直接与导致回调的流中的对象相关。
        结果
        the non-negative current number of bytes consumed
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectInputFilter.Status (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.io

Enum ObjectInputFilter.Status

  • java.lang.Object
    • java.lang.Enum<ObjectInputFilter.Status>
      • java.io.ObjectInputFilter.Status
  • All Implemented Interfaces:
    Serializable ， Comparable<ObjectInputFilter.Status>
    Enclosing interface:
    ObjectInputFilter

    public static enum ObjectInputFilter.Status
extends Enum<ObjectInputFilter.Status>
    对类的检查状态，数组长度，引用次数，深度和流大小。
    从以下版本开始：
    9

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALLOWED
      状态是允许的。
      REJECTED
      状态被拒绝。
      UNDECIDED
      状态未定，不允许，不予拒绝。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ObjectInputFilter.Status valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ObjectInputFilter.Status[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNDECIDED

        public static final ObjectInputFilter.Status UNDECIDED
        状态未定，不允许，不予拒绝。

      • ALLOWED

        public static final ObjectInputFilter.Status ALLOWED
        状态是允许的。

      • REJECTED

        public static final ObjectInputFilter.Status REJECTED
        状态被拒绝。

    • 方法详细信息

      • values

        public static ObjectInputFilter.Status[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ObjectInputFilter.Status c : ObjectInputFilter.Status.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ObjectInputFilter.Status valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ObjectInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.ObjectInputStream
  • All Implemented Interfaces:
    Closeable ， DataInput ， ObjectInput ， ObjectStreamConstants ， AutoCloseable

    public class ObjectInputStream
extends InputStream
implements ObjectInput, ObjectStreamConstants
    ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。

    ObjectOutputStream和ObjectInputStream可以分别为与FileOutputStream和FileInputStream一起使用的对象图提供持久性存储的应用程序。 ObjectInputStream用于恢复先前序列化的对象。 其他用途包括使用套接字流在主机之间传递对象，或者在远程通信系统中进行封送和解组参数和参数。

    ObjectInputStream确保从流中创建的图中的所有对象的类型与Java虚拟机中存在的类匹配。 根据需要使用标准机制加载类。

    只能从流中读取支持java.io.Serializable或java.io.Externalizable接口的对象。

    方法readObject用于从流中读取对象。 应使用Java的安全铸造来获得所需的类型。 在Java中，字符串和数组是对象，在序列化过程中被视为对象。 读取时，需要将其转换为预期类型。

    可以使用DataInput上的适当方法从流中读取原始数据类型。

    对象的默认反序列化机制将每个字段的内容恢复为写入时的值和类型。 声明为瞬态或静态的字段被反序列化过程忽略。 对其他对象的引用导致根据需要从流中读取这些对象。 使用参考共享机制正确恢复对象的图形。 反序列化时总是分配新对象，这样可以防止现有对象被覆盖。

    读取对象类似于运行新对象的构造函数。 为对象分配内存，并初始化为零（NULL）。 对非可序列化类调用无参数构造函数，然后从最接近java.lang.object的可序列化类开始，从串中还原可序列化类的字段，并使用对象最特定的类完成。

    例如从ObjectOutputStream中的示例中写入的流中读取：

      FileInputStream fis = new FileInputStream("t.tmp");
      ObjectInputStream ois = new ObjectInputStream(fis);

      int i = ois.readInt();
      String today = (String) ois.readObject();
      Date date = (Date) ois.readObject();

      ois.close();

    类通过实现java.io.Serializable或java.io.Externalizable接口来控制它们是如何序列化的。

    实现Serializable接口允许对象序列化保存和恢复对象的整个状态，并允许类在流被写入的时间和读取时间之间演变。 它自动遍历对象之间的引用，保存和恢复整个图形。

    在序列化和反序列化过程中需要特殊处理的可序列化类应实现以下方法：

      private void writeObject(java.io.ObjectOutputStream stream)
     throws IOException;
 private void readObject(java.io.ObjectInputStream stream)
     throws IOException, ClassNotFoundException;
 private void readObjectNoData()
     throws ObjectStreamException;

    readObject方法负责使用通过相应的writeObject方法写入流的数据来读取和恢复其特定类的对象的状态。 该方法不需要关注属于其超类或子类的状态。 通过从ObjectInputStream读取各个字段的数据并对对象的相应字段进行分配来恢复状态。 DataInput支持读取原始数据类型。

    任何尝试读取超过相应writeObject方法写入的自定义数据边界的对象数据将导致使用eof字段值为true抛出OptionalDataException。 超过分配数据结束的非对象读取将以与指示流结尾相同的方式反映数据的结尾：Bytewise读取将返回-1作为字节读取或读取的字节数，并且原语读取将抛出EOFExceptions。 如果没有相应的writeObject方法，则默认序列化数据的结尾标记分配的数据的结尾。

    在readExternal方法中发出的原始和对象读取调用的行为方式相同 - 如果流已经位于由相应的writeExternal方法写入的数据的末尾，则对象读取会将可选数据异常与eof设置为true，Bytewise读取将返回-1，并且原始读取将抛出EOFExceptions。 请注意，这种行为对于使用旧的ObjectStreamConstants.PROTOCOL_VERSION_1协议编写的流不适用，其中由writeExternal方法写入的数据的结尾未划分，因此无法检测。

    如果序列化流未将给定类列为反序列化对象的超类，则readObjectNoData方法负责初始化其特定类的对象的状态。 这可能发生在接收方使用与发送方不同的反序列化实例的类的版本的情况下，并且接收者的版本扩展了不被发送者版本扩展的类。 如果序列化流已被篡改，也可能发生这种情况; 因此，尽管存在“敌对”或不完整的源流，readObjectNoData可用于正确初始化反序列化对象。

    序列化不会读取或赋值任何不实现java.io.Serializable接口的对象的值。 不可序列化的对象的子类可以是可序列化的。 在这种情况下，非可序列化类必须有一个无参数构造函数，以允许其字段被初始化。 在这种情况下，子类有责任保存并恢复不可序列化类的状态。 通常情况下，该类的字段是可访问的（public，package或protected），或者可以使用get和set方法来恢复状态。

    可以在反序列化期间过滤流的内容。 如果filter is set上的ObjectInputStream的，所述ObjectInputFilter可以检查类，阵列的长度，在流，深度和数量从输入流消耗的字节的参考数是允许的，如果没有，可以终止反序列化。 A process-wide filter可以配置为应用于每个ObjectInputStream除非使用setObjectInputFilter替换。

    反序列化对象时发生的任何异常都将被ObjectInputStream捕获并中止读取过程。

    实现Externalizable接口允许对象完全控制对象的序列化表单的内容和格式。 调用Externalizable接口writeExternal和readExternal的方法来保存和恢复对象的状态。 当由类实现时，他们可以使用ObjectOutput和ObjectInput的所有方法来写入和读取自己的状态。 对象处理发生的任何版本控制都是有责任的。

    枚举常数的反序列化与普通可序列化或外部化对象不同。 枚举常数的序列化形式仅由其名称组成; 不传输常数的字段值。 要反序列化枚举常量，ObjectInputStream从流中读取常量名称; 然后通过调用具有枚举常量的基本类型和接收的常量名称作为参数的静态方法Enum.valueOf(Class, String)获得反序列化常数。 像其他可序列化或可外部化的对象一样，枚举常量可以用作序列化流中随后出现的反向引用的目标。 枚举常量被反序列化的过程无法自定义：在反序列化期间将忽略由枚举类型定义的任何特定于类的readObject，readObjectNoData和readResolve方法。 类似地，任何serialPersistentFields或serialVersionUID字段声明也被忽略 - 所有枚举类型都有一个固定的serialVersionUID为0L。

    从以下版本开始：
    1.1
    另请参见：
    DataInput ， ObjectOutputStream ， Serializable ， Object Serialization Specification, Section 3, Object Input Classes

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ObjectInputStream.GetField
      提供对从输入流读取的持久性字段的访问。

    • Field Summary

      • Fields inherited from interface java.io.ObjectStreamConstants

        baseWireHandle, PROTOCOL_VERSION_1, PROTOCOL_VERSION_2, SC_BLOCK_DATA, SC_ENUM, SC_EXTERNALIZABLE, SC_SERIALIZABLE, SC_WRITE_METHOD, SERIAL_FILTER_PERMISSION, STREAM_MAGIC, STREAM_VERSION, SUBCLASS_IMPLEMENTATION_PERMISSION, SUBSTITUTION_PERMISSION, TC_ARRAY, TC_BASE, TC_BLOCKDATA, TC_BLOCKDATALONG, TC_CLASS, TC_CLASSDESC, TC_ENDBLOCKDATA, TC_ENUM, TC_EXCEPTION, TC_LONGSTRING, TC_MAX, TC_NULL, TC_OBJECT, TC_PROXYCLASSDESC, TC_REFERENCE, TC_RESET, TC_STRING

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ObjectInputStream​()
      为完全重新实现ObjectInputStream的子类提供一种方法，不必分配刚刚被ObjectInputStream实现使用的私有数据。
        ObjectInputStream​(InputStream in)
      创建从指定的InputStream读取的ObjectInputStream。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int available​()
      返回可以读取而不阻塞的字节数。
      void close​()
      关闭输入流。
      void defaultReadObject​()
      从此流读取当前类的非静态和非瞬态字段。
      protected boolean enableResolveObject​(boolean enable)
      启用流来替换从流读取的对象。
      ObjectInputFilter getObjectInputFilter​()
      返回此流的序列化过滤器。
      int read​()
      读取一个字节的数据。
      int read​(byte[] buf, int off, int len)
      读入一个字节数组。
      boolean readBoolean​()
      读取布尔值。
      byte readByte​()
      读取一个8位字节。
      char readChar​()
      读一个16位字符。
      protected ObjectStreamClass readClassDescriptor​()
      从序列化流读取类描述符。
      double readDouble​()
      读64位双倍。
      ObjectInputStream.GetField readFields​()
      从流中读取持久性字段，并通过名称使其可用。
      float readFloat​()
      读32位浮点数。
      void readFully​(byte[] buf)
      读取字节，阻塞直到读取所有字节。
      void readFully​(byte[] buf, int off, int len)
      读取字节，阻塞直到读取所有字节。
      int readInt​()
      读取一个32位int。
      String readLine​()
      已过时。
      此方法无法将字节正确转换为字符。 有关详细信息和替代方案，请参阅DataInputStream。
      long readLong​()
      读64位长。
      Object readObject​()
      从ObjectInputStream读取一个对象。
      protected Object readObjectOverride​()
      此方法由ObjectOutputStream的受信任子类调用，该子类使用受保护的无参构造函数构造ObjectOutputStream。
      short readShort​()
      读取16位短。
      protected void readStreamHeader​()
      提供了readStreamHeader方法来允许子类读取和验证自己的流标题。
      Object readUnshared​()
      从ObjectInputStream读取一个“非共享”对象。
      int readUnsignedByte​()
      读取一个无符号的8位字节。
      int readUnsignedShort​()
      读取无符号16位短。
      String readUTF​()
      以 modified UTF-8格式读取字符串。
      void registerValidation​(ObjectInputValidation obj, int prio)
      在返回图之前注册要验证的对象。
      protected Class<?> resolveClass​(ObjectStreamClass desc)
      加载本地类等效的指定流类描述。
      protected Object resolveObject​(Object obj)
      此方法将允许ObjectInputStream的受信任子类在反序列化期间将一个对象替换为另一个对象。
      protected Class<?> resolveProxyClass​(String[] interfaces)
      返回一个代理类，它实现代理类描述符中命名的接口; 子类可以实现此方法从流中读取自定义数据以及动态代理类的描述符，从而允许它们为接口和代理类使用备用加载机制。
      void setObjectInputFilter​(ObjectInputFilter filter)
      为流设置序列化过滤器。
      int skipBytes​(int len)
      跳过字节。

      • Methods inherited from class java.io.InputStream

        mark, markSupported, read, readAllBytes, readNBytes, reset, skip, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.io.ObjectInput

        read, skip

    • 构造方法详细信息

      • ObjectInputStream

        public ObjectInputStream​(InputStream in)
                  throws IOException
        创建从指定的InputStream读取的ObjectInputStream。 从流中读取序列化流头并进行验证。 该构造函数将阻塞，直到相应的ObjectOutputStream已写入并刷新标题。

        序列化过滤器初始化为值the process-wide filter 。

        如果安装了一个安全管理器，那么这个构造函数将会在覆盖ObjectInputStream.readFields或ObjectInputStream.readUnshared方法的子类的构造函数直接或间接调用时检查“enableSubclassImplementation”SerializablePermission。

        参数
        in - 要读取的输入流
        异常
        StreamCorruptedException - 如果流标题不正确
        IOException - 如果在读取流标题时发生I / O错误
        SecurityException - 如果不可信子类非法覆盖安全敏感方法
        NullPointerException - 如果 in是 null
        另请参见：
        ObjectInputStream() ，
readFields() ，
ObjectOutputStream(OutputStream)

      • ObjectInputStream

        protected ObjectInputStream​()
                     throws IOException,
                            SecurityException
        为完全重新实现ObjectInputStream的子类提供一种方法，不必分配刚刚被ObjectInputStream实现使用的私有数据。

        序列化过滤器初始化为the process-wide filter的值。

        如果安装了一个安全管理器，则该方法首先使用SerializablePermission("enableSubclassImplementation")权限调用安全管理器的checkPermission方法，以确保启用子类化。

        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法拒绝启用子类化。
        IOException - 如果在创建此流时发生I / O错误
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， SerializablePermission

    • 方法详细信息

      • readObject

        public final Object readObject​()
                        throws IOException,
                               ClassNotFoundException
        从ObjectInputStream读取一个对象。 读取对象的类，类的签名以及类的非瞬态和非静态字段的值以及其所有超类型。 可以使用writeObject和readObject方法覆盖类的默认反序列化。 这个对象引用的对象被传递性地读取，以便通过readObject重构一个完整的对象图。

        当其所有字段及其引用的对象完全还原时，根对象将被完全还原。 此时，对象验证回调按照它们注册的优先级顺序执行。 回调由对象（在readObject特殊方法中）注册，因为它们被单独还原。

        序列化过滤器（不是null ）被调用为每个对象（常规或类）读取重建根对象。 详见setObjectInputFilter 。

        对于InputStream和不应反序列化的类的问题，抛出异常。 所有异常都是对InputStream致命的，并将其置于不确定状态; 呼叫者可以忽略或恢复流状态。

        Specified by:
        readObject在接口 ObjectInput
        结果
        该对象从流中读取
        异常
        ClassNotFoundException - 无法找到序列化对象的类。
        InvalidClassException - 序列化使用的类错误。
        StreamCorruptedException - 流中的控制信息不一致。
        OptionalDataException - 在流中找到原始数据，而不是对象。
        IOException - 任何常见的输入/输出相关异常。

      • readObjectOverride

        protected Object readObjectOverride​()
                             throws IOException,
                                    ClassNotFoundException
        此方法由ObjectOutputStream的受信任子类调用，该子类使用受保护的无参构造函数构造ObjectOutputStream。 该子类预计将提供一个具有修饰符“final”的覆盖方法。
        结果
        对象从流中读取。
        异常
        ClassNotFoundException - 无法找到序列化对象的类定义。
        OptionalDataException - 在流中找到原始数据，而不是对象。
        IOException - 如果从底层流读取时发生I / O错误
        从以下版本开始：
        1.2
        另请参见：
        ObjectInputStream() ， readObject()

      • readUnshared

        public Object readUnshared​()
                    throws IOException,
                           ClassNotFoundException
        从ObjectInputStream读取一个“非共享”对象。 此方法与readObject相同，只是它阻止对readObject的后续调用和readUnshared返回对通过此调用获取的反序列化实例的其他引用。 特别：
        • 如果调用readUnshared来反序列化一个反向引用（以前已经写入流的对象的流表示），则抛出ObjectStreamException。
        • 如果readUnshared成功返回，则随后尝试反序列化对readUnshared反序列化的流处理的反向引用将导致抛出ObjectStreamException。
        通过readUnshared对对象进行反序列化将使与返回对象关联的流句柄无效。 请注意，这本身并不总是保证readUnshared返回的引用是唯一的; 反序列化对象可以定义一个readResolve方法，该方法返回对其他方可见的对象，或者readUnshared可以返回在流中或通过外部方式在其他地方可获取的Class对象或枚举常量。 如果反序列化对象定义了一个readResolve方法，并且该方法的调用返回一个数组，那么readUnshared返回该数组的浅克隆; 这样可以保证返回的数组对象是唯一的，即使在底层数据流已经被处理的情况下，也不能再从调用readObject或readUnshared在ObjectInputStream上获得。

        序列化过滤器（不是null ）被调用为每个对象（常规或类）读取重建根对象。 详见setObjectInputFilter 。

        覆盖此方法的ObjectInputStream子类只能在拥有“enableSubclassImplementation”SerializablePermission的安全上下文中构建; 任何尝试在没有此权限的情况下实例化此类子类将导致抛出SecurityException。

        结果
        参考反序列化对象
        异常
        ClassNotFoundException - 如果无法找到反序列化对象的类
        StreamCorruptedException - 如果流中的控制信息不一致
        ObjectStreamException - 如果反序列化对象已经出现在流中
        OptionalDataException - 如果原始数据是下一个流
        IOException - 如果在反序列化期间发生I / O错误
        从以下版本开始：
        1.4

      • defaultReadObject

        public void defaultReadObject​()
                       throws IOException,
                              ClassNotFoundException
        从此流读取当前类的非静态和非瞬态字段。 这只能从被反序列化的类的readObject方法调用。 否则将抛出NotActiveException异常。
        异常
        ClassNotFoundException - 如果找不到序列化对象的类。
        IOException - 如果发生I / O错误。
        NotActiveException - 如果流当前未读取对象。

      • readFields

        public ObjectInputStream.GetField readFields​()
                                      throws IOException,
                                             ClassNotFoundException
        从流中读取持久性字段，并通过名称使其可用。
        结果
        表示对象的持久字段被反序列化的 GetField对象
        异常
        ClassNotFoundException - 如果无法找到序列化对象的类。
        IOException - 如果发生I / O错误。
        NotActiveException - 如果流当前未读取对象。
        从以下版本开始：
        1.2

      • registerValidation

        public void registerValidation​(ObjectInputValidation obj,
                               int prio)
                        throws NotActiveException,
                               InvalidObjectException
        在返回图之前注册要验证的对象。 虽然类似于resolveObject这些验证在整个图形重新构建之后被调用。 通常，readObject方法将使用流注册对象，以便当所有对象都被还原时，可以执行最后一组验证。
        参数
        obj - 接收验证回调的对象。
        prio - 控制回调的顺序;零是一个很好的默认值。 使用较高的数字可以提前回调，较低的数字可用于以后的回调。 在优先级中，回调按照特定顺序进行处理。
        异常
        NotActiveException - 流当前未读取对象，因此无法注册回调。
        InvalidObjectException - 验证对象为null。

      • resolveClass

        protected Class<?> resolveClass​(ObjectStreamClass desc)
                         throws IOException,
                                ClassNotFoundException
        加载本地类等效的指定流类描述。 子类可以实现此方法，以允许从备用源获取类。

        ObjectOutputStream的相应方法为annotateClass 。 对于流中的每个唯一类，此方法将仅调用一次。 该方法可以由子类实现，以使用备用加载机制，但必须返回一个Class对象。 一旦返回，如果类不是数组类，其serialVersionUID与序列化类的serialVersionUID进行比较，如果不匹配，则反序列化失败，并抛出一个InvalidClassException 。

        该方法的默认实现在ObjectInputStream返回调用结果

          Class.forName(desc.getName(), false, loader)
        其中loader是当前线程的堆栈（从当前执行的方法开始）的第一个类加载器，既不是platform class loader也不是其祖先; 否则， loader是平台类加载器 。 如果在此调用结果ClassNotFoundException和传递的名称ObjectStreamClass实例的基本类型或void Java语言的关键字，那么Class表示基本类型或void对象将被退回（例如， ObjectStreamClass名称为"int"会解决到Integer.TYPE ）。 否则，将向该方法的调用者抛出ClassNotFoundException 。
        参数
        desc - 类 ObjectStreamClass一个实例
        结果
        一个 Class对象对应 desc
        异常
        IOException - 任何通常的输入/输出异常。
        ClassNotFoundException - 如果无法找到序列化对象的类。

      • resolveProxyClass

        protected Class<?> resolveProxyClass​(String[] interfaces)
                              throws IOException,
                                     ClassNotFoundException
        返回一个代理类，它实现代理类描述符中命名的接口; 子类可以实现此方法从流中读取自定义数据以及动态代理类的描述符，从而允许它们为接口和代理类使用备用加载机制。

        对于流中的每个唯一代理类描述符，该方法被称为一次。

        ObjectOutputStream的相应方法为annotateProxyClass 。 对于覆盖此方法的annotateProxyClass的给定子类， ObjectInputStream对应子类中的ObjectOutputStream必须写入此方法读取的任何数据或对象。

        这种方法的默认实现ObjectInputStream返回调用的结果Proxy.getProxyClass与列表Class对象为在指定接口interfaces参数。 每个接口名称i的Class对象是通过调用返回的值

          Class.forName(i, false, loader)
        其中loader是当前线程的堆栈（从当前执行的方法开始）中的第一个类加载器，既不是platform class loader也不是其祖先; 否则， loader是平台类加载器 。 除非任何解析的界面都是非公开的，否则同样的值为loader也是类加载器传递给Proxy.getProxyClass ; 如果存在非公共接口，则会传递其类加载器（如果遇到多个非公共接口类加载器，则抛出一个IllegalAccessError ）。 如果Proxy.getProxyClass抛出IllegalArgumentException ， resolveProxyClass将抛出ClassNotFoundException包含IllegalArgumentException 。
        参数
        interfaces - 代理类描述符中反序列化的接口名称列表
        结果
        指定接口的代理类
        异常
        IOException - 底层 InputStream抛出的任何异常
        ClassNotFoundException - 如果无法找到代理类或任何命名的接口
        从以下版本开始：
        1.3
        另请参见：
        ObjectOutputStream.annotateProxyClass(Class)

      • resolveObject

        protected Object resolveObject​(Object obj)
                        throws IOException
        此方法将允许ObjectInputStream的受信任子类在反序列化期间将一个对象替换为另一个对象。 在调用enableResolveObject之前，将禁用替换对象。 enableResolveObject方法检查请求解析对象的流可以被信任。 对可序列化对象的每个引用都传递给resolveObject。 为了确保对象的私有状态不会被无意地暴露，只有信任的流可能使用resolveObject。

        在读取对象之后，在从readObject返回之前调用此方法。 默认的resolveObject方法只返回相同的对象。

        当子类替换对象时，必须确保替换对象与引用将被存储的每个字段兼容。 类型不是字段或数组元素类型的子类的对象通过引发异常终止序列化，并且不存储该对象。

        当首次遇到每个对象时，此方法仅调用一次。 对对象的所有后续引用将被重定向到新对象。

        参数
        obj - 要替代的对象
        结果
        替代对象
        异常
        IOException - 任何通常的输入/输出异常。

      • enableResolveObject

        protected boolean enableResolveObject​(boolean enable)
                               throws SecurityException
        启用流来替换从流读取的对象。 启用时，为反序列化的每个对象调用resolveObject(java.lang.Object)方法。

        如果当前未启用对象替换，并且enable为true，并且安装了安全管理器，则该方法首先使用SerializablePermission("enableSubstitution")权限调用安全管理器的checkPermission方法，以确保允许调用者启用流来替换对象从流中读取。

        参数
        enable - 为每个被反序列化的对象使能 resolveObject
        结果
        此方法被调用之前的前一个设置
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法拒绝使流能够更新从流读取的对象。
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， SerializablePermission

      • readStreamHeader

        protected void readStreamHeader​()
                         throws IOException,
                                StreamCorruptedException
        提供了readStreamHeader方法来允许子类读取和验证自己的流标题。 它读取和验证魔术数字和版本号。
        异常
        IOException - 如果从基础 InputStream读取时存在I / O错误
        StreamCorruptedException - 如果流中的控制信息不一致

      • readClassDescriptor

        protected ObjectStreamClass readClassDescriptor​()
                                         throws IOException,
                                                ClassNotFoundException
        从序列化流读取类描述符。 当ObjectInputStream期望类描述符作为序列化流中的下一个项时，调用此方法。 ObjectInputStream的子类可以覆盖此方法以读取已经以非标准格式（由ObjectOutputStream的子类覆盖了writeClassDescriptor方法）的类描述符。 默认情况下，此方法根据对象序列化规范中定义的格式读取类描述符。
        结果
        类描述符读取
        异常
        IOException - 如果发生I / O错误。
        ClassNotFoundException - 如果找不到类描述符表示中使用的序列化对象的类
        从以下版本开始：
        1.3
        另请参见：
        ObjectOutputStream.writeClassDescriptor(java.io.ObjectStreamClass)

      • read

        public int read​()
         throws IOException
        读取一个字节的数据。 如果没有输入可用，此方法将阻止。
        Specified by:
        read在接口 ObjectInput
        Specified by:
        read在 InputStream
        结果
        读取字节，如果达到流的结尾，则返回-1。
        异常
        IOException - 如果发生I / O错误。

      • read

        public int read​(byte[] buf,
                int off,
                int len)
         throws IOException
        读入一个字节数组。 该方法将阻塞，直到有些输入可用。 考虑使用java.io.DataInputStream.readFully来读取“length”字节。
        Specified by:
        read在接口 ObjectInput
        重写：
        read中的 InputStream
        参数
        buf - 读取数据的缓冲区
        off - 目标数组 buf的起始偏移量
        len - 读取的最大字节数
        结果
        读取的实际字节数，到达流结束时返回-1。
        异常
        NullPointerException - 如果 buf是 null 。
        IndexOutOfBoundsException - 如果 off为负数，则 len为负数，或 len大于 buf.length - off 。
        IOException - 如果发生I / O错误。
        另请参见：
        DataInputStream.readFully(byte[],int,int)

      • available

        public int available​()
              throws IOException
        返回可以读取而不阻塞的字节数。
        Specified by:
        available在接口 ObjectInput
        重写：
        available在 InputStream
        结果
        可用字节数。
        异常
        IOException - 如果从底层读取时出现I / O错误 InputStream

      • close

        public void close​()
           throws IOException
        关闭输入流。 必须调用释放与流相关联的任何资源。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ObjectInput
        重写：
        close在 InputStream
        异常
        IOException - 如果发生I / O错误。

      • readBoolean

        public boolean readBoolean​()
                    throws IOException
        读取布尔值。
        Specified by:
        readBoolean在接口 DataInput
        结果
        布尔读取。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readByte

        public byte readByte​()
              throws IOException
        读取一个8位字节。
        Specified by:
        readByte在接口 DataInput
        结果
        读取8位字节。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readUnsignedByte

        public int readUnsignedByte​()
                     throws IOException
        读取一个无符号的8位字节。
        Specified by:
        readUnsignedByte在接口 DataInput
        结果
        读取8位字节。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readChar

        public char readChar​()
              throws IOException
        读一个16位字符。
        Specified by:
        readChar在接口 DataInput
        结果
        16位字符读取。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readShort

        public short readShort​()
                throws IOException
        读取16位短。
        Specified by:
        readShort在接口 DataInput
        结果
        16位短读。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readUnsignedShort

        public int readUnsignedShort​()
                      throws IOException
        读取无符号16位短。
        Specified by:
        readUnsignedShort在接口 DataInput
        结果
        16位短读。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readInt

        public int readInt​()
            throws IOException
        读取一个32位int。
        Specified by:
        readInt在接口 DataInput
        结果
        32位整数读取。
        异常
        EOFException - 如果到达文件结尾。
        IOException - 如果发生其他I / O错误。

      • readLong

        public long readLong​()
              throws IOException
        读64位长。
        Specified by:
        readLong在接口 DataInput
        结果
        读64位长。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readFloat

        public float readFloat​()
                throws IOException
        读32位浮点数。
        Specified by:
        readFloat在接口 DataInput
        结果
        32位浮点读。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readDouble

        public double readDouble​()
                  throws IOException
        读64位双倍。
        Specified by:
        readDouble在接口 DataInput
        结果
        64位双读。
        异常
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readFully

        public void readFully​(byte[] buf)
               throws IOException
        读取字节，阻塞直到读取所有字节。
        Specified by:
        readFully在接口 DataInput
        参数
        buf - 读取数据的缓冲区
        异常
        NullPointerException - 如果 buf是 null 。
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • readFully

        public void readFully​(byte[] buf,
                      int off,
                      int len)
               throws IOException
        读取字节，阻塞直到读取所有字节。
        Specified by:
        readFully在接口 DataInput
        参数
        buf - 读取数据的缓冲区
        off - 数据阵列的起始偏移量 buf
        len - 要读取的最大字节数
        异常
        NullPointerException - 如果 buf是 null 。
        IndexOutOfBoundsException - 如果 off为负， len ，否则为 len ，大于 buf.length - off 。
        EOFException - 如果达到文件结尾。
        IOException - 如果发生其他I / O错误。

      • skipBytes

        public int skipBytes​(int len)
              throws IOException
        跳过字节。
        Specified by:
        skipBytes在接口 DataInput
        参数
        len - 要跳过的字节数
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • readLine

        @Deprecated
public String readLine​()
                throws IOException
        已过时。 此方法无法将字节正确转换为字符。 有关详细信息和替代方案，请参阅DataInputStream。
        在\ n，\ r，\ r \ n或EOF终止的行中读取。
        Specified by:
        readLine在接口 DataInput
        结果
        一行的字符串副本。
        异常
        IOException - 如果从底层 InputStream读取时存在I / O错误

      • readUTF

        public String readUTF​()
               throws IOException
        以 modified UTF-8格式读取字符串。
        Specified by:
        readUTF在接口 DataInput
        结果
        字符串。
        异常
        IOException - 如果从底层 InputStream读取时存在I / O错误
        UTFDataFormatException - 如果读取的字节不表示字符串的有效修改的UTF-8编码

      • getObjectInputFilter

        public final ObjectInputFilter getObjectInputFilter​()
        返回此流的序列化过滤器。 串行化滤波器是在最近的滤波器集合setObjectInputFilter或从最初的进程范围滤波器ObjectInputFilter.Config.getSerialFilter 。
        结果
        流的序列化过滤器; 可能为null
        从以下版本开始：
        9

      • setObjectInputFilter

        public final void setObjectInputFilter​(ObjectInputFilter filter)
        为流设置序列化过滤器。 为流中的每个类和引用调用过滤器的checkInput方法。 过滤器可以检查任何或所有类，数组长度，引用数量，图形的深度和输入流的大小。 深度是嵌套readObject调用的次数，从读取正在反序列化的图的根和当前对象被反序列化开始。 引用的数量是对象的累积数量和对已经从流中读取的对象的引用，包括正在读取的当前对象。 只有从流中读取对象而不是原语时，才会调用该过滤器。

        如果过滤器返回Status.REJECTED ， null或抛出一个RuntimeException ，主动readObject或者readUnshared抛出InvalidClassException ，否则反序列化不间断地继续。

        序列化过滤器被初始化为值ObjectInputFilter.Config.getSerialFilter时ObjectInputStream被构造和只能进行一次设置为自定义过滤器。

        实现要求：
        在readObject和readUnshared中为流中的每个对象（常规或类）调用过滤器（不是null ）。 字符串被视为原语，不调用过滤器。 调用过滤器：
        • 每个对象引用以前从流中反序列化（类为null ，arrayLength为-1）
        • 每个常规类（类不是null ，arrayLength是-1）
        • 每个接口的动态代理和动态代理类本身（类不是null ，arrayLength是-1）
        • 每个数组使用数组类型和数组长度进行过滤（类是数组类型，arrayLength是请求的长度）
        • 每个对象被替换为其类' readResolve方法的是使用替换对象的类进行过滤，如果不是null ，而如果它是一个数组，则arrayLength，否则为-1，
        • 并且使用替换对象的类来过滤使用resolveObject的每个对象，如果不是null ，如果它是一个数组，则arrayLength，否则为-1。
        当调用checkInput方法时，可以访问当前类，数组长度，已从流中读取的当前引用数目，嵌套调用深度为readObject或readUnshared ，以及实现依赖于从输入流。

        每次调用readObject或readUnshared在读取对象之前将深度增加1，并在正常或异常返回之前减少1。 深度开始于1并且每个嵌套对象的增加量和每个嵌套调用返回时递减。 流中的引用数开始于1并在读取对象之前增加。

        参数
        filter - 过滤器可能为null
        异常
        SecurityException - 如果有安全管理员，并且没有授予 SerializablePermission("serialFilter")
        IllegalStateException - 如果 current filter不是 null并且不是进程范围的过滤器
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectInputStream.GetField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectInputStream.GetField

  • java.lang.Object
    • java.io.ObjectInputStream.GetField
  • Enclosing class:
    ObjectInputStream

    public abstract static class ObjectInputStream.GetField
extends Object
    提供对从输入流读取的持久性字段的访问。

    • 构造方法摘要

      构造方法
      Constructor 描述
      GetField​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract boolean defaulted​(String name)
      如果命名字段是默认值，并且此流中没有值，则返回true。
      abstract boolean get​(String name, boolean val)
      从持久化字段获取命名布尔字段的值。
      abstract byte get​(String name, byte val)
      从持久化字段获取命名字节字段的值。
      abstract char get​(String name, char val)
      从持久化字段获取命名的char字段的值。
      abstract double get​(String name, double val)
      从持续字段获取命名的双字段的值。
      abstract float get​(String name, float val)
      从持久化字段获取命名的float字段的值。
      abstract int get​(String name, int val)
      从持久化字段获取命名的int字段的值。
      abstract long get​(String name, long val)
      从持久化字段获取命名的长字段的值。
      abstract short get​(String name, short val)
      从持续字段获取命名的短字段的值。
      abstract Object get​(String name, Object val)
      从持久化字段获取命名的对象字段的值。
      abstract ObjectStreamClass getObjectStreamClass​()
      获取描述流中字段的ObjectStreamClass。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GetField

        public GetField​()

    • 方法详细信息

      • getObjectStreamClass

        public abstract ObjectStreamClass getObjectStreamClass​()
        获取描述流中字段的ObjectStreamClass。
        结果
        描述可序列化字段的描述符类

      • defaulted

        public abstract boolean defaulted​(String name)
                           throws IOException
        如果命名字段是默认值，并且此流中没有值，则返回true。
        参数
        name - 字段的名称
        结果
        true，如果且仅当命名字段是默认的
        异常
        IOException - 从基础 InputStream读取时是否存在I / O错误
        IllegalArgumentException - 如果 name不对应于可序列化字段

      • get

        public abstract boolean get​(String name,
                            boolean val)
                     throws IOException
        从持久化字段获取命名布尔字段的值。
        参数
        name - 字段的名称
        val - name没有值时使用的默认值
        结果
        名称为 boolean字段的值
        异常
        IOException - 如果从底层 InputStream读取时存在I / O错误
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract byte get​(String name,
                         byte val)
                  throws IOException
        从持久化字段获取命名字节字段的值。
        参数
        name - 字段的名称
        val - name没有值时要使用的默认值
        结果
        名称为 byte字段的值
        异常
        IOException - 如果从底层 InputStream读取时存在I / O错误
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract char get​(String name,
                         char val)
                  throws IOException
        从持久化字段获取命名的char字段的值。
        参数
        name - 字段的名称
        val - name没有值时使用的默认值
        结果
        名称为 char字段的值
        异常
        IOException - 从底层 InputStream读取时是否存在I / O错误
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract short get​(String name,
                          short val)
                   throws IOException
        从持续字段获取命名的短字段的值。
        参数
        name - 字段的名称
        val - name没有值时使用的默认值
        结果
        名称为 short字段的值
        异常
        IOException - 如果从底层 InputStream读取时存在I / O错误
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract int get​(String name,
                        int val)
                 throws IOException
        从持久化字段获取命名的int字段的值。
        参数
        name - 字段的名称
        val - name没有值时使用的默认值
        结果
        名称为 int字段的值
        异常
        IOException - 如果从底层的 InputStream读取时存在I / O错误
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract long get​(String name,
                         long val)
                  throws IOException
        从持久化字段获取命名的长字段的值。
        参数
        name - 字段的名称
        val - 如果 name没有值，则使用的默认值
        结果
        名称为 long字段的值
        异常
        IOException - 如果从底层读取时出现I / O错误 InputStream
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract float get​(String name,
                          float val)
                   throws IOException
        从持久化字段获取命名的float字段的值。
        参数
        name - 字段的名称
        val - name没有值时使用的默认值
        结果
        名称为 float的值
        异常
        IOException - 如果从底层 InputStream读取时存在I / O错误
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract double get​(String name,
                           double val)
                    throws IOException
        从持续字段获取命名的双字段的值。
        参数
        name - 字段的名称
        val - 如果 name没有值，则使用的默认值
        结果
        名称为 double字段的值
        异常
        IOException - 如果从底层读取时出现I / O错误 InputStream
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，

      • get

        public abstract Object get​(String name,
                           Object val)
                    throws IOException
        从持久化字段获取命名的对象字段的值。
        参数
        name - 字段的名称
        val - name没有值时使用的默认值
        结果
        名称为 Object字段的值
        异常
        IOException - 如果从底层 InputStream读取时存在I / O错误
        IllegalArgumentException -如果类型 name不是序列化的或者字段类型不正确，
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectInputValidation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface ObjectInputValidation

  • public interface ObjectInputValidation
    回调界面允许验证图中的对象。 允许在对象的完整图反序列化时调用对象。
    从以下版本开始：
    1.1
    另请参见：
    ObjectInputStream ， ObjectInputStream.registerValidation(java.io.ObjectInputValidation, int)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void validateObject​()
      验证对象。

    • 方法详细信息

      • validateObject

        void validateObject​()
             throws InvalidObjectException
        验证对象。
        异常
        InvalidObjectException - 如果对象无法验证自身。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectOutput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface ObjectOutput

  • All Superinterfaces:
    AutoCloseable ， DataOutput
    所有已知实现类：
    ObjectOutputStream

    public interface ObjectOutput
extends DataOutput, AutoCloseable
    ObjectOutput扩展了DataOutput接口，包括写入对象。 DataOutput包括用于输出原始类型的方法，ObjectOutput将该接口扩展为包含对象，数组和字符串。
    从以下版本开始：
    1.1
    另请参见：
    InputStream ， ObjectOutputStream ， ObjectInputStream

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭流。
      void flush​()
      刷新流。
      void write​(byte[] b)
      写入一个字节数组。
      void write​(byte[] b, int off, int len)
      写入一个子字节数组。
      void write​(int b)
      写一个字节。
      void writeObject​(Object obj)
      将对象写入底层存储或流。

      • Methods inherited from interface java.io.DataOutput

        writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeDouble, writeFloat, writeInt, writeLong, writeShort, writeUTF

    • 方法详细信息

      • writeObject

        void writeObject​(Object obj)
          throws IOException
        将对象写入底层存储或流。 实现此接口的类定义对象的写入方式。
        参数
        obj - 要写入的对象
        异常
        IOException - 任何通常的输入/输出相关异常。

      • write

        void write​(int b)
    throws IOException
        写一个字节。 该方法将阻塞，直到字节实际写入。
        Specified by:
        write在接口 DataOutput
        参数
        b - 字节
        异常
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b)
    throws IOException
        写入一个字节数组。 该方法将阻塞直到字节实际写入。
        Specified by:
        write在接口 DataOutput
        参数
        b - 要写入的数据
        异常
        IOException - 如果发生I / O错误。

      • write

        void write​(byte[] b,
           int off,
           int len)
    throws IOException
        写入一个子字节数组。
        Specified by:
        write在接口 DataOutput
        参数
        b - 要写入的数据
        off - 数据中的起始偏移量
        len - 写入的字节数
        异常
        IOException - 如果发生I / O错误。

      • flush

        void flush​()
    throws IOException
        刷新流。 这将写入任何缓冲的输出字节。
        异常
        IOException - 如果发生I / O错误。

      • close

        void close​()
    throws IOException
        关闭流。 必须调用此方法以释放与流相关联的任何资源。
        Specified by:
        close在接口 AutoCloseable
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.ObjectOutputStream
  • All Implemented Interfaces:
    Closeable ， DataOutput ， Flushable ， ObjectOutput ， ObjectStreamConstants ， AutoCloseable

    public class ObjectOutputStream
extends OutputStream
implements ObjectOutput, ObjectStreamConstants
    ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。 可以使用ObjectInputStream读取（重构）对象。 可以通过使用流的文件来实现对象的持久存储。 如果流是网络套接字流，则可以在另一个主机上或另一个进程中重构对象。

    只有支持java.io.Serializable接口的对象才能写入流中。 每个可序列化对象的类被编码，包括类的类名和签名，对象的字段和数组的值以及从初始对象引用的任何其他对象的关闭。

    方法writeObject用于将一个对象写入流中。 任何对象，包括字符串和数组，都是用writeObject编写的。 多个对象或原语可以写入流。 必须从对应的ObjectInputstream读取对象，其类型和写入次序相同。

    原始数据类型也可以使用DataOutput中的适当方法写入流中。 字符串也可以使用writeUTF方法写入。

    对象的默认序列化机制写入对象的类，类签名以及所有非瞬态和非静态字段的值。 引用其他对象（除了在瞬态或静态字段中）也会导致这些对象被写入。 使用引用共享机制对单个对象的多个引用进行编码，以便可以将对象的图形恢复为与原始文件相同的形状。

    例如，要写一个ObjectInputStream中的示例可以读取的对象：

      FileOutputStream fos = new FileOutputStream("t.tmp");
      ObjectOutputStream oos = new ObjectOutputStream(fos);

      oos.writeInt(12345);
      oos.writeObject("Today");
      oos.writeObject(new Date());

      oos.close();

    在序列化和反序列化过程中需要特殊处理的类必须采用具有这些精确签名的特殊方法：

      private void readObject(java.io.ObjectInputStream stream)
     throws IOException, ClassNotFoundException;
 private void writeObject(java.io.ObjectOutputStream stream)
     throws IOException
 private void readObjectNoData()
     throws ObjectStreamException;

    writeObject方法负责为其特定的类编写对象的状态，以便相应的readObject方法可以恢复它。 该方法不需要关心属于对象的超类或子类的状态。 通过使用writeObject方法或通过使用DataOutput支持的原始数据类型的方法将各个字段写入ObjectOutputStream来保存状态。

    序列化不会写出任何不实现java.io.Serializable接口的对象的字段。 不可序列化的对象的子类可以是可序列化的。 在这种情况下，非可序列化类必须有一个无参数构造函数，以允许其字段被初始化。 在这种情况下，子类有责任保存并恢复不可序列化类的状态。 通常情况下，该类的字段是可访问的（public，package或protected），或者可以使用get和set方法来恢复状态。

    可以通过实现抛出NotSerializableException的writeObject和readObject方法来防止对象的序列化。 异常将被ObjectOutputStream捕获并中止序列化过程。

    实现Externalizable接口允许对象完全控制对象的序列化表单的内容和格式。 调用Externalizable接口writeExternal和readExternal的方法来保存和恢复对象的状态。 当由类实现时，他们可以使用ObjectOutput和ObjectInput的所有方法来写入和读取自己的状态。 对象处理发生的任何版本控制都是有责任的。

    枚举常数与普通可序列化或外部化对象不同的是序列化。 枚举常数的序列化形式仅由其名称组成; 不传输常数的字段值。 要序列化一个枚举常量，ObjectOutputStream会写入常数名称方法返回的字符串。 像其他可序列化或可外部化的对象一样，枚举常量可以用作序列化流中随后出现的反向引用的目标。 枚举常数序列化的过程无法定制; 在序列化期间，将忽略由枚举类型定义的任何类特定的writeObject和writeReplace方法。 类似地，任何serialPersistentFields或serialVersionUID字段声明也被忽略 - 所有枚举类型都有一个固定的serialVersionUID为0L。

    原始数据（不包括可序列化字段和外部化数据）在块数据记录中写入ObjectOutputStream。 块数据记录由报头和数据组成。 块数据头由标记和跟随标题的字节数组成。 连续的原始数据写入被合并成一个块数据记录。 用于块数据记录的阻塞因子将是1024字节。 每个块数据记录将被填充到1024个字节，或者每当块数据模式终止时都被写入。 调用ObjectOutputStream方法writeObject，defaultWriteObject和writeFields最初终止任何现有的块数据记录。

    从以下版本开始：
    1.1
    另请参见：
    DataOutput ， ObjectInputStream ， Serializable ， Externalizable ， Object Serialization Specification, Section 2, Object Output Classes

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ObjectOutputStream.PutField
      提供对要写入ObjectOutput的持久字段的编程访问。

    • Field Summary

      • Fields inherited from interface java.io.ObjectStreamConstants

        baseWireHandle, PROTOCOL_VERSION_1, PROTOCOL_VERSION_2, SC_BLOCK_DATA, SC_ENUM, SC_EXTERNALIZABLE, SC_SERIALIZABLE, SC_WRITE_METHOD, SERIAL_FILTER_PERMISSION, STREAM_MAGIC, STREAM_VERSION, SUBCLASS_IMPLEMENTATION_PERMISSION, SUBSTITUTION_PERMISSION, TC_ARRAY, TC_BASE, TC_BLOCKDATA, TC_BLOCKDATALONG, TC_CLASS, TC_CLASSDESC, TC_ENDBLOCKDATA, TC_ENUM, TC_EXCEPTION, TC_LONGSTRING, TC_MAX, TC_NULL, TC_OBJECT, TC_PROXYCLASSDESC, TC_REFERENCE, TC_RESET, TC_STRING

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ObjectOutputStream​()
      为完全重新实现ObjectOutputStream的子类提供一种方法，不必分配刚刚被ObjectOutputStream实现使用的私有数据。
        ObjectOutputStream​(OutputStream out)
      创建一个写入指定的OutputStream的ObjectOutputStream。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void annotateClass​(Class<?> cl)
      子类可以实现此方法，以允许类数据存储在流中。
      protected void annotateProxyClass​(Class<?> cl)
      子类可以实现这种方法来存储流中的自定义数据以及动态代理类的描述符。
      void close​()
      关闭流。
      void defaultWriteObject​()
      将当前类的非静态和非瞬态字段写入此流。
      protected void drain​()
      排除ObjectOutputStream中的缓冲数据。
      protected boolean enableReplaceObject​(boolean enable)
      启用流来替代写入流的对象。
      void flush​()
      刷新流。
      ObjectOutputStream.PutField putFields​()
      检索用于缓冲要写入流的持久性字段的对象。
      protected Object replaceObject​(Object obj)
      该方法将允许ObjectOutputStream的可信子类在序列化期间将一个对象替换为另一个对象。
      void reset​()
      复位将忽略已写入流的任何对象的状态。
      void useProtocolVersion​(int version)
      指定在编写流时使用的流协议版本。
      void write​(byte[] buf)
      写入一个字节数组。
      void write​(byte[] buf, int off, int len)
      写入一个子字节数组。
      void write​(int val)
      写一个字节。
      void writeBoolean​(boolean val)
      写一个布尔值。
      void writeByte​(int val)
      写入一个8位字节。
      void writeBytes​(String str)
      写一个字符串作为字节序列。
      void writeChar​(int val)
      写一个16位的字符。
      void writeChars​(String str)
      写一个字符串作为一系列的字符。
      protected void writeClassDescriptor​(ObjectStreamClass desc)
      将指定的类描述符写入ObjectOutputStream。
      void writeDouble​(double val)
      写一个64位的双倍。
      void writeFields​()
      将缓冲的字段写入流。
      void writeFloat​(float val)
      写一个32位浮点数。
      void writeInt​(int val)
      写一个32位int。
      void writeLong​(long val)
      写一个64位长
      void writeObject​(Object obj)
      将指定的对象写入ObjectOutputStream。
      protected void writeObjectOverride​(Object obj)
      子类使用的方法来覆盖默认的writeObject方法。
      void writeShort​(int val)
      写一个16位短。
      protected void writeStreamHeader​()
      提供了writeStreamHeader方法，因此子类可以在流中附加或预先添加自己的头。
      void writeUnshared​(Object obj)
      将“非共享”对象写入ObjectOutputStream。
      void writeUTF​(String str)
      此字符串的原始数据写入格式为 modified UTF-8 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectOutputStream

        public ObjectOutputStream​(OutputStream out)
                   throws IOException
        创建一个写入指定的OutputStream的ObjectOutputStream。 该构造函数将序列化流头写入底层流; 调用者可能希望立即刷新流，以确保在读取头部时接收ObjectInputStreams的构造函数不会阻塞。

        如果安装了一个安全管理器，那么这个构造函数会在被覆盖ObjectOutputStream.putFields或ObjectOutputStream.writeUnshared方法的子类的构造函数直接或间接调用时检查“enableSubclassImplementation”SerializablePermission。

        参数
        out - 输出流写入
        异常
        IOException - 如果在写入流标题时发生I / O错误
        SecurityException - 如果不可信子类非法覆盖安全敏感方法
        NullPointerException - 如果 out是 null
        从以下版本开始：
        1.4
        另请参见：
        ObjectOutputStream() ，
putFields() ，
ObjectInputStream(InputStream)

      • ObjectOutputStream

        protected ObjectOutputStream​()
                      throws IOException,
                             SecurityException
        为完全重新实现ObjectOutputStream的子类提供一种方法，不必分配刚刚被ObjectOutputStream实现使用的私有数据。

        如果安装了安全管理器，则该方法首先使用SerializablePermission("enableSubclassImplementation")权限调用安全管理器的checkPermission方法，以确保启用子类化。

        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法拒绝启用子类化。
        IOException - 如果在创建此流时发生I / O错误
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， SerializablePermission

    • 方法详细信息

      • useProtocolVersion

        public void useProtocolVersion​(int version)
                        throws IOException
        指定在编写流时使用的流协议版本。

        此例程提供了一个钩子，以使当前版本的Serialization能够以向后兼容流格式的先前版本的格式写入。

        将尽一切努力避免引入额外的后向不兼容性; 然而，有时候别无选择。

        参数
        version - 使用java.io.ObjectStreamConstants中的ProtocolVersion。
        异常
        IllegalStateException - 如果任何对象被序列化后调用。
        IllegalArgumentException - 如果传递无效版本。
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.2
        另请参见：
        ObjectStreamConstants.PROTOCOL_VERSION_1 ， ObjectStreamConstants.PROTOCOL_VERSION_2

      • writeObject

        public final void writeObject​(Object obj)
                       throws IOException
        将指定的对象写入ObjectOutputStream。 写入对象的类，类的签名以及类的非瞬态和非静态字段的值以及其所有超类型。 可以使用writeObject和readObject方法覆盖类的默认序列化。 由该对象引用的对象被传递性地写入，以便可以通过ObjectInputStream重构对象的完整等价图。

        对于OutputStream和不应序列化的类的问题，抛出异常。 所有异常对于OutputStream是致命的，它将处于不确定状态，由呼叫者来忽略或恢复流状态。

        Specified by:
        writeObject在接口 ObjectOutput
        参数
        obj - 要写入的对象
        异常
        InvalidClassException - 序列化使用的类错误。
        NotSerializableException - 要序列化的某些对象不实现java.io.Serializable接口。
        IOException - 底层OutputStream抛出的任何异常。

      • writeObjectOverride

        protected void writeObjectOverride​(Object obj)
                            throws IOException
        子类使用的方法来覆盖默认的writeObject方法。 此方法由ObjectInputStream的受信任子类调用，该子类使用受保护的无参构造函数构造ObjectInputStream。 该子类预计将提供一个具有修饰符“final”的覆盖方法。
        参数
        obj - 要写入底层流的对象
        异常
        IOException - 如果在写入底层流时存在I / O错误
        从以下版本开始：
        1.2
        另请参见：
        ObjectOutputStream() ， writeObject(Object)

      • writeUnshared

        public void writeUnshared​(Object obj)
                   throws IOException
        将“非共享”对象写入ObjectOutputStream。 此方法与writeObject相同，只是它始终将给定对象作为新的唯一对象写入流中（而不是指向之前的序列化实例的反向引用）。 特别：
        • 通过writeUnshared编写的对象总是以与新出现的对象（尚未写入流的对象）相同的方式进行序列化，而不管以前是否已经写过该对象。
        • 如果writeObject用于写入先前使用writeUnshared写入的对象，则先前的writeUnshared操作将被视为单独对象的写入。 换句话说，ObjectOutputStream永远不会生成对由writeUnshared调用写入的对象数据的反向引用。
        当通过writeUnshared编写对象本身不保证对对象进行反序列化时的唯一引用，它允许在流中多次定义单个对象，以便接收器对readUnshared进行多次调用不会发生冲突。 请注意，上述规则仅适用于使用writeUnshared编写的基本级别对象，而不适用于要序列化的对象图中的任何传递性引用的子对象。

        ObjectOutputStream子类覆盖此方法只能在拥有“enableSubclassImplementation”SerializablePermission的安全上下文中构建; 任何尝试在没有此权限的情况下实例化此类子类将导致抛出SecurityException。

        参数
        obj - 要写 obj对象
        异常
        NotSerializableException - 如果要序列化的图中的对象不实现Serializable接口
        InvalidClassException - 如果要序列化的对象的类存在问题
        IOException - 如果序列化期间发生I / O错误
        从以下版本开始：
        1.4

      • defaultWriteObject

        public void defaultWriteObject​()
                        throws IOException
        将当前类的非静态和非瞬态字段写入此流。 这只能从被序列化的类的writeObject方法调用。 否则将抛出NotActiveException异常。
        异常
        IOException - 如果在写入底层的 OutputStream发生I / O错误

      • putFields

        public ObjectOutputStream.PutField putFields​()
                                      throws IOException
        检索用于缓冲要写入流的持久性字段的对象。 当调用writeFields方法时，字段将被写入流。
        结果
        Putfield类的一个实例，它保存了可序列化的字段
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.2

      • writeFields

        public void writeFields​()
                 throws IOException
        将缓冲的字段写入流。
        异常
        IOException - 如果在写入底层流时发生I / O错误
        NotActiveException - 当没有调用类writeObject方法来写入对象的状态时调用。
        从以下版本开始：
        1.2

      • reset

        public void reset​()
           throws IOException
        复位将忽略已写入流的任何对象的状态。 状态被重置为与新的ObjectOutputStream相同。 流中的当前点被标记为重置，所以相应的ObjectInputStream将在同一点被重置。 以前写入流的对象不会被称为已经在流中。 他们将再次写入流。
        异常
        IOException - 如果在序列化对象时调用了reset（）。

      • annotateClass

        protected void annotateClass​(Class<?> cl)
                      throws IOException
        子类可以实现此方法，以允许类数据存储在流中。 默认情况下，此方法什么都不做 ObjectInputStream中的相应方法是resolveClass。 对于流中的每个唯一类，此方法称为一次。 类名和签名已经写入流。 该方法可以免费使用ObjectOutputStream来保存其认为合适的类的任何表示（例如，类文件的字节）。 ObjectInputStream对应子类中的resolveClass方法必须读取并使用annotateClass写入的任何数据或对象。
        参数
        cl - 为自定义数据注释的类
        异常
        IOException - 底层OutputStream抛出的任何异常。

      • annotateProxyClass

        protected void annotateProxyClass​(Class<?> cl)
                           throws IOException
        子类可以实现这种方法来存储流中的自定义数据以及动态代理类的描述符。

        对于流中的每个唯一代理类描述符，该方法被称为一次。 这个方法的默认实现在ObjectOutputStream中什么都不做。

        ObjectInputStream的相应方法为resolveProxyClass 。 对于覆盖此方法的resolveProxyClass的给定子类， ObjectOutputStream的相应子类中的ObjectInputStream必须读取由annotateProxyClass编写的任何数据或对象。

        参数
        cl - 用于注释自定义数据的代理类
        异常
        IOException - 底层 OutputStream抛出的任何异常
        从以下版本开始：
        1.3
        另请参见：
        ObjectInputStream.resolveProxyClass(String[])

      • replaceObject

        protected Object replaceObject​(Object obj)
                        throws IOException
        该方法将允许ObjectOutputStream的可信子类在序列化期间将一个对象替换为另一个对象。 在调用enableReplaceObject之前，将禁用替换对象。 enableReplaceObject方法检查请求做替换的流可以被信任。 写入序列化流的每个对象的第一次出现被传递给replaceObject。 对对象的后续引用将被原始调用replaceObject返回的对象所替代。 为了确保对象的私有状态不会被无意间暴露，只有可信流可能使用replaceObject。

        ObjectOutputStream.writeObject方法接受Object类型的参数（与Serializable类型相反），以允许将非可序列化对象替换为可序列化对象的情况。

        当子类替换对象时，必须确保在反序列化期间必须进行补充替换，或者替换对象与要存储引用的每个字段兼容。 类型不是字段或数组元素类型的子类的对象通过引发异常终止序列化，并且不存储该对象。

        当首次遇到每个对象时，此方法仅调用一次。 对对象的所有后续引用将被重定向到新对象。 该方法应该返回要替换的对象或原始对象。

        Null可以作为要替换的对象返回，但是可能会在包含对原始对象的引用的类中引起NullReferenceException，因为它们可能期望一个对象而不是null。

        参数
        obj - 要替换的对象
        结果
        代替指定的替代对象
        异常
        IOException - 底层OutputStream抛出的任何异常。

      • enableReplaceObject

        protected boolean enableReplaceObject​(boolean enable)
                               throws SecurityException
        启用流来替代写入流的对象。 启用时，为每个被序列化的对象调用replaceObject(java.lang.Object)方法。

        如果对象替换当前未启用，并enable是真实的，并且安装了安全管理器，此方法首先调用安全管理器的checkPermission方法与SerializablePermission("enableSubstitution")权限，以确保调用者被允许使流对象进行替换的写入流。

        参数
        enable - 允许对串行化的每个对象使用 replaceObject
        结果
        此方法被调用之前的前一个设置
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法拒绝使流能够替换写入流的对象。
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， SerializablePermission

      • writeStreamHeader

        protected void writeStreamHeader​()
                          throws IOException
        提供了writeStreamHeader方法，因此子类可以在流中附加或预先添加自己的头。 它将魔术数字和版本写入流。
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeClassDescriptor

        protected void writeClassDescriptor​(ObjectStreamClass desc)
                             throws IOException
        将指定的类描述符写入ObjectOutputStream。 类描述符用于标识写入流的对象类。 ObjectOutputStream的子类可以覆盖此方法来自定义类描述符写入序列化流的方式。 然后应该覆盖ObjectInputStream readClassDescriptor的相应方法， readClassDescriptor从其自定义流表示中重新构建类描述符。 默认情况下，此方法根据对象序列化规范中定义的格式编写类描述符。

        请注意，只有当ObjectOutputStream不使用旧的序列化流格式（通过调用ObjectOutputStream的useProtocolVersion方法设置）时， useProtocolVersion调用useProtocolVersion方法。 如果此序列化流使用旧格式（ PROTOCOL_VERSION_1 ），则类描述符将以不能被覆盖或自定义的方式内部写入。

        参数
        desc - 写入流的类描述符
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.3
        另请参见：
        ObjectInputStream.readClassDescriptor() ， useProtocolVersion(int) ， ObjectStreamConstants.PROTOCOL_VERSION_1

      • write

        public void write​(int val)
           throws IOException
        写一个字节。 该方法将阻塞，直到字节实际写入。
        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ObjectOutput
        Specified by:
        write在 OutputStream
        参数
        val - val的字节
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] buf)
           throws IOException
        写入一个字节数组。 该方法将阻塞直到字节实际写入。
        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ObjectOutput
        重写：
        write在 OutputStream
        参数
        buf - 要写入的数据
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        OutputStream.write(byte[], int, int)

      • write

        public void write​(byte[] buf,
                  int off,
                  int len)
           throws IOException
        写入一个子字节数组。
        Specified by:
        write在接口 DataOutput
        Specified by:
        write在接口 ObjectOutput
        重写：
        write在 OutputStream
        参数
        buf - 要写入的数据
        off - 数据中的起始偏移量
        len - 写入的字节数
        异常
        IOException - 如果发生I / O错误。

      • flush

        public void flush​()
           throws IOException
        刷新流。 这将写入任何缓冲的输出字节并刷新到底层流。
        Specified by:
        flush在接口 Flushable
        Specified by:
        flush在接口 ObjectOutput
        重写：
        flush在 OutputStream
        异常
        IOException - 如果发生I / O错误。

      • drain

        protected void drain​()
              throws IOException
        排除ObjectOutputStream中的缓冲数据。 类似于flush，但不会将flush传播到底层流。
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • close

        public void close​()
           throws IOException
        关闭流。 必须调用此方法以释放与流相关联的任何资源。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在接口 ObjectOutput
        重写：
        close在 OutputStream
        异常
        IOException - 如果发生I / O错误。

      • writeBoolean

        public void writeBoolean​(boolean val)
                  throws IOException
        写一个布尔值。
        Specified by:
        writeBoolean在接口 DataOutput
        参数
        val - 要写入的布尔值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeByte

        public void writeByte​(int val)
               throws IOException
        写入一个8位字节。
        Specified by:
        writeByte接口 DataOutput
        参数
        val - 要写入的字节值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeShort

        public void writeShort​(int val)
                throws IOException
        写一个16位短。
        Specified by:
        writeShort在接口 DataOutput
        参数
        val - val的短价值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeChar

        public void writeChar​(int val)
               throws IOException
        写一个16位的字符。
        Specified by:
        writeChar在接口 DataOutput
        参数
        val - 要写入的char值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeInt

        public void writeInt​(int val)
              throws IOException
        写一个32位int。
        Specified by:
        writeInt在接口 DataOutput
        参数
        val - 要写入的整数值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeLong

        public void writeLong​(long val)
               throws IOException
        写一个64位长
        Specified by:
        writeLong在接口 DataOutput
        参数
        val - val的长的价值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeFloat

        public void writeFloat​(float val)
                throws IOException
        写一个32位浮点数。
        Specified by:
        writeFloat在接口 DataOutput
        参数
        val - 要写入的浮点值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeDouble

        public void writeDouble​(double val)
                 throws IOException
        写一个64位的双倍。
        Specified by:
        writeDouble在接口 DataOutput
        参数
        val - 要写入的双重值
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeBytes

        public void writeBytes​(String str)
                throws IOException
        写一个字符串作为字节序列。
        Specified by:
        writeBytes在接口 DataOutput
        参数
        str - 要写入的字节串
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeChars

        public void writeChars​(String str)
                throws IOException
        写一个字符串作为一系列的字符。
        Specified by:
        writeChars在接口 DataOutput
        参数
        str - 要写入的字符串
        异常
        IOException - 如果在写入底层流时发生I / O错误

      • writeUTF

        public void writeUTF​(String str)
              throws IOException
        此字符串的原始数据写入格式为modified UTF-8 。 请注意，将字符串写入流中作为原始数据或作为对象有重大差异。 由writeObject写的String实例最初作为String写入流中。 未来的writeObject（）会将对字符串的引用调用到流中。
        Specified by:
        writeUTF在接口 DataOutput
        参数
        str - 要写入的字符串
        异常
        IOException - if I/O errors occur while writing to the underlying stream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectOutputStream.PutField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectOutputStream.PutField

  • java.lang.Object
    • java.io.ObjectOutputStream.PutField
  • Enclosing class:
    ObjectOutputStream

    public abstract static class ObjectOutputStream.PutField
extends Object
    提供对要写入ObjectOutput的持久字段的编程访问。
    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      PutField​()

    • 方法摘要

      所有方法 接口方法 抽象方法 弃用的方法
      Modifier and Type 方法 描述
      abstract void put​(String name, boolean val)
      将命名布尔字段的值放入持久字段。
      abstract void put​(String name, byte val)
      将命名字节字段的值放入持久字段。
      abstract void put​(String name, char val)
      将命名的char字段的值放入持久字段。
      abstract void put​(String name, double val)
      将命名的双字段的值放入持久字段。
      abstract void put​(String name, float val)
      将命名的浮动字段的值放入持久字段。
      abstract void put​(String name, int val)
      将命名的int字段的值放入持久字段。
      abstract void put​(String name, long val)
      将命名的长字段的值放入持久字段。
      abstract void put​(String name, short val)
      将命名的短字段的值放入持久字段。
      abstract void put​(String name, Object val)
      将命名的对象字段的值放入持久字段。
      abstract void write​(ObjectOutput out)
      已过时。
      此方法不会以适当的格式写入此PutField对象所包含的值，并可能导致序列化流的损坏。 写PutField数据的正确方法是通过调用ObjectOutputStream.writeFields()方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PutField

        public PutField​()

    • 方法详细信息

      • put

        public abstract void put​(String name,
                         boolean val)
        将命名布尔字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给该字段的值
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 boolean

      • put

        public abstract void put​(String name,
                         byte val)
        将命名字节字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给该字段的值
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 byte

      • put

        public abstract void put​(String name,
                         char val)
        将命名的char字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给该字段的值
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 char

      • put

        public abstract void put​(String name,
                         short val)
        将命名的短字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给字段的值
        异常
        IllegalArgumentException - 如果 name与要写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 short

      • put

        public abstract void put​(String name,
                         int val)
        将命名的int字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给字段的值
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 int

      • put

        public abstract void put​(String name,
                         long val)
        将命名的长字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给该字段的值
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 long

      • put

        public abstract void put​(String name,
                         float val)
        将命名的浮动字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给该字段的值
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 float

      • put

        public abstract void put​(String name,
                         double val)
        将命名的双字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给字段的值
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是 double

      • put

        public abstract void put​(String name,
                         Object val)
        将命名的对象字段的值放入持久字段。
        参数
        name - 可序列化字段的名称
        val - 要分配给字段的值（可能是 null ）
        异常
        IllegalArgumentException - 如果 name与正在写入其字段的类的可序列化字段的名称不匹配，或者如果命名字段的类型不是引用类型

      • write

        @Deprecated
public abstract void write​(ObjectOutput out)
                    throws IOException
        已过时。 此方法不会以适当的格式写入此PutField对象所包含的值，并可能导致序列化流的损坏。 写PutField数据的正确方法是通过调用ObjectOutputStream.writeFields()方法。
        将数据和字段写入指定的ObjectOutput流，该流必须是生成此 PutField对象的流。
        参数
        out - 将数据和字段写入的流
        异常
        IOException - 如果在写入底层流时发生I / O错误
        IllegalArgumentException - if the specified stream is not the same stream that produced this PutField object
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectStreamClass (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectStreamClass

  • java.lang.Object
    • java.io.ObjectStreamClass
  • All Implemented Interfaces:
    Serializable

    public class ObjectStreamClass
extends Object
implements Serializable
    序列化的类的描述符。 它包含该类的名称和serialVersionUID。 可以使用lookup方法查找/创建Java Java中加载的特定类的ObjectStreamClass。

    计算的serialVersionUID该算法中描述Object Serialization Specification, Section 4.6, Stream Unique Identifiers 。

    从以下版本开始：
    1.1
    另请参见：
    ObjectStreamField ， Object Serialization Specification, Section 4, Class Descriptors ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ObjectStreamField[] NO_FIELDS
      serialPersistentFields值，表示无可序列化的字段

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<?> forClass​()
      返回此版本映射到的本地VM中的类。
      ObjectStreamField getField​(String name)
      通过名称获取此类的字段。
      ObjectStreamField[] getFields​()
      返回此可序列化类的字段数组。
      String getName​()
      返回此描述符描述的类的名称。
      long getSerialVersionUID​()
      返回此类的serialVersionUID。
      static ObjectStreamClass lookup​(Class<?> cl)
      找到可以序列化的类的描述符。
      static ObjectStreamClass lookupAny​(Class<?> cl)
      返回任何类的描述符，无论它是否实现Serializable 。
      String toString​()
      返回描述此ObjectStreamClass的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NO_FIELDS

        public static final ObjectStreamField[] NO_FIELDS
        serialPersistentFields值，表示无可序列化的字段

    • 方法详细信息

      • lookup

        public static ObjectStreamClass lookup​(Class<?> cl)
        找到可以序列化的类的描述符。 如果类不存在，则创建一个ObjectStreamClass实例。 如果指定的类不实现java.io.Serializable或java.io.Externalizable，则返回Null。
        参数
        cl - 获取描述符的类
        结果
        指定类的类描述符

      • lookupAny

        public static ObjectStreamClass lookupAny​(Class<?> cl)
        返回任何类的描述符，无论它是否实现Serializable 。
        参数
        cl - 获取描述符的类
        结果
        指定类的类描述符
        从以下版本开始：
        1.6

      • getName

        public String getName​()
        返回此描述符描述的类的名称。 此方法以Class.getName()方法使用的格式返回类的名称。
        结果
        一个表示类的名称的字符串

      • getSerialVersionUID

        public long getSerialVersionUID​()
        返回此类的serialVersionUID。 serialVersionUID定义了一组具有相同名称的类，它们从普通根类发展而来，并且同意使用通用格式进行序列化和反序列化。 NonSerializable类的serialVersionUID为0L。
        结果
        该描述符描述的类的SUID

      • forClass

        public Class<?> forClass​()
        返回此版本映射到的本地VM中的类。 如果没有相应的本地类，则返回空值。
        结果
        该描述符表示的 Class实例

      • getFields

        public ObjectStreamField[] getFields​()
        返回此可序列化类的字段数组。
        结果
        一个包含此类的每个持久字段的元素的数组。 如果没有字段，则返回长度为零的数组。
        从以下版本开始：
        1.2

      • getField

        public ObjectStreamField getField​(String name)
        通过名称获取此类的字段。
        参数
        name - 要查找的数据字段的名称
        结果
        命名字段的ObjectStreamField对象，如果没有这样的命名字段，则返回null。

      • toString

        public String toString​()
        返回描述此ObjectStreamClass的字符串。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectStreamConstants (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface ObjectStreamConstants

  • 所有已知实现类：
    ObjectInputStream ， ObjectOutputStream

    public interface ObjectStreamConstants
    写入对象序列化流的常量。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int baseWireHandle
      要分配的第一根钢丝柄。
      static int PROTOCOL_VERSION_1
      流协议版本。
      static int PROTOCOL_VERSION_2
      流协议版本。
      static byte SC_BLOCK_DATA
      ObjectStreamClass标志的位掩码。
      static byte SC_ENUM
      ObjectStreamClass标志的位掩码。
      static byte SC_EXTERNALIZABLE
      ObjectStreamClass标志的位掩码。
      static byte SC_SERIALIZABLE
      ObjectStreamClass标志的位掩码。
      static byte SC_WRITE_METHOD
      ObjectStreamClass标志的位掩码。
      static SerializablePermission SERIAL_FILTER_PERMISSION
      启用设置过程范围的串行过滤器。
      static short STREAM_MAGIC
      写入流标题的魔数。
      static short STREAM_VERSION
      写入流标题的版本号。
      static SerializablePermission SUBCLASS_IMPLEMENTATION_PERMISSION
      启用覆盖readObject和writeObject。
      static SerializablePermission SUBSTITUTION_PERMISSION
      在序列化/反序列化期间可以使一个对象替换为另一个对象。
      static byte TC_ARRAY
      新数组。
      static byte TC_BASE
      第一个标签值。
      static byte TC_BLOCKDATA
      阻止可选数据。
      static byte TC_BLOCKDATALONG
      长块数据。
      static byte TC_CLASS
      参考类。
      static byte TC_CLASSDESC
      新的类描述符。
      static byte TC_ENDBLOCKDATA
      结束对象的可选块数据块。
      static byte TC_ENUM
      新的枚举常数。
      static byte TC_EXCEPTION
      写入时异常。
      static byte TC_LONGSTRING
      长串
      static byte TC_MAX
      最后一个标签值。
      static byte TC_NULL
      空对象引用。
      static byte TC_OBJECT
      新对象。
      static byte TC_PROXYCLASSDESC
      新的代理类描述符。
      static byte TC_REFERENCE
      引用已写入流的对象。
      static byte TC_RESET
      重新设置流上下文
      static byte TC_STRING
      新的字符串。

    • 字段详细信息

      • STREAM_MAGIC

        static final short STREAM_MAGIC
        写入流标题的魔数。
        另请参见：
        Constant Field Values

      • STREAM_VERSION

        static final short STREAM_VERSION
        写入流标题的版本号。
        另请参见：
        Constant Field Values

      • TC_BASE

        static final byte TC_BASE
        第一个标签值。
        另请参见：
        Constant Field Values

      • TC_NULL

        static final byte TC_NULL
        空对象引用。
        另请参见：
        Constant Field Values

      • TC_REFERENCE

        static final byte TC_REFERENCE
        引用已写入流的对象。
        另请参见：
        Constant Field Values

      • TC_CLASSDESC

        static final byte TC_CLASSDESC
        新的类描述符。
        另请参见：
        Constant Field Values

      • TC_OBJECT

        static final byte TC_OBJECT
        新对象。
        另请参见：
        Constant Field Values

      • TC_STRING

        static final byte TC_STRING
        新的字符串。
        另请参见：
        Constant Field Values

      • TC_ARRAY

        static final byte TC_ARRAY
        新数组。
        另请参见：
        Constant Field Values

      • TC_CLASS

        static final byte TC_CLASS
        参考类。
        另请参见：
        Constant Field Values

      • TC_BLOCKDATA

        static final byte TC_BLOCKDATA
        阻止可选数据。 字节跟随标记表示此块数据中的字节数。
        另请参见：
        Constant Field Values

      • TC_ENDBLOCKDATA

        static final byte TC_ENDBLOCKDATA
        结束对象的可选块数据块。
        另请参见：
        Constant Field Values

      • TC_RESET

        static final byte TC_RESET
        重新设置流上下文 写入流的所有句柄都将重置。
        另请参见：
        Constant Field Values

      • TC_BLOCKDATALONG

        static final byte TC_BLOCKDATALONG
        长块数据。 标签后面的长度表示此块数据中的字节数。
        另请参见：
        Constant Field Values

      • TC_EXCEPTION

        static final byte TC_EXCEPTION
        写入时异常。
        另请参见：
        Constant Field Values

      • TC_LONGSTRING

        static final byte TC_LONGSTRING
        长串
        另请参见：
        Constant Field Values

      • TC_PROXYCLASSDESC

        static final byte TC_PROXYCLASSDESC
        新的代理类描述符。
        另请参见：
        Constant Field Values

      • TC_ENUM

        static final byte TC_ENUM
        新的枚举常数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • TC_MAX

        static final byte TC_MAX
        最后一个标签值。
        另请参见：
        Constant Field Values

      • baseWireHandle

        static final int baseWireHandle
        要分配的第一根钢丝柄。
        另请参见：
        Constant Field Values

      • SC_WRITE_METHOD

        static final byte SC_WRITE_METHOD
        ObjectStreamClass标志的位掩码。 表示Serializable类定义了自己的writeObject方法。
        另请参见：
        Constant Field Values

      • SC_BLOCK_DATA

        static final byte SC_BLOCK_DATA
        ObjectStreamClass标志的位掩码。 表示以块数据模式写入的可外部化数据。 已添加到PROTOCOL_VERSION_2。
        从以下版本开始：
        1.2
        另请参见：
        PROTOCOL_VERSION_2 ， Constant Field Values

      • SC_SERIALIZABLE

        static final byte SC_SERIALIZABLE
        ObjectStreamClass标志的位掩码。 表示类是Serializable。
        另请参见：
        Constant Field Values

      • SC_EXTERNALIZABLE

        static final byte SC_EXTERNALIZABLE
        ObjectStreamClass标志的位掩码。 表示类是Externalizable。
        另请参见：
        Constant Field Values

      • SC_ENUM

        static final byte SC_ENUM
        ObjectStreamClass标志的位掩码。 表示类是枚举类型。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • SUBSTITUTION_PERMISSION

        static final SerializablePermission SUBSTITUTION_PERMISSION
        在序列化/反序列化期间可以使一个对象替换为另一个对象。
        从以下版本开始：
        1.2
        另请参见：
        ObjectOutputStream.enableReplaceObject(boolean) ， ObjectInputStream.enableResolveObject(boolean)

      • SUBCLASS_IMPLEMENTATION_PERMISSION

        static final SerializablePermission SUBCLASS_IMPLEMENTATION_PERMISSION
        启用覆盖readObject和writeObject。
        从以下版本开始：
        1.2
        另请参见：
        ObjectOutputStream.writeObjectOverride(Object) ， ObjectInputStream.readObjectOverride()

      • SERIAL_FILTER_PERMISSION

        static final SerializablePermission SERIAL_FILTER_PERMISSION
        启用设置过程范围的串行过滤器。
        从以下版本开始：
        9
        另请参见：
        ObjectInputFilter.Config.setSerialFilter(ObjectInputFilter)

      • PROTOCOL_VERSION_1

        static final int PROTOCOL_VERSION_1
        流协议版本。

        调用此方法后，所有外部化数据都将以JDK 1.1外部数据格式编写。 需要此版本才能编写包含可由JDK 1.1.6 JVM读取的Externalizable数据的流。

        从以下版本开始：
        1.2
        另请参见：
        ObjectOutputStream.useProtocolVersion(int) ， Constant Field Values

      • PROTOCOL_VERSION_2

        static final int PROTOCOL_VERSION_2
        流协议版本。

        该协议由JVM 1.2编写。 可外部化数据以块数据模式写入，并以TC_ENDBLOCKDATA结束。 Externalizable类描述符标志启用了SC_BLOCK_DATA。 JVM 1.1.6及更高版本可以读取此格式的更改。 允许在流中写入一个nonSerializable类描述符。 nonSerializable类的serialVersionUID设置为0L。

        从以下版本开始：
        1.2
        另请参见：
        ObjectOutputStream.useProtocolVersion(int) ， SC_BLOCK_DATA ， Constant Field Values
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectStreamException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectStreamException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    InvalidClassException ， InvalidObjectException ， NotActiveException ， NotSerializableException ， OptionalDataException ， StreamCorruptedException ， WriteAbortedException

    public abstract class ObjectStreamException
extends IOException
    对象流类别特有的所有异常的超类。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ObjectStreamException​()
      创建一个ObjectStreamException。
      protected ObjectStreamException​(String message)
      使用指定的参数创建一个ObjectStreamException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ObjectStreamException

        protected ObjectStreamException​(String message)
        使用指定的参数创建一个ObjectStreamException。
        参数
        message - 有关异常的详细信息

      • ObjectStreamException

        protected ObjectStreamException​()
        创建一个ObjectStreamException。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ObjectStreamField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class ObjectStreamField

  • java.lang.Object
    • java.io.ObjectStreamField
  • All Implemented Interfaces:
    Comparable<Object>

    public class ObjectStreamField
extends Object
implements Comparable<Object>
    Serializable类的Serializable字段的描述。 ObjectStreamFields的数组用于声明一个类的Serializable字段。
    从以下版本开始：
    1.2
    另请参见：
    ObjectStreamClass

    • 构造方法摘要

      构造方法
      Constructor 描述
      ObjectStreamField​(String name, Class<?> type)
      创建一个具有指定类型的Serializable字段。
      ObjectStreamField​(String name, Class<?> type, boolean unshared)
      创建一个ObjectStreamField，表示具有给定名称和类型的可序列化字段。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(Object obj)
      将此字段与另一个 ObjectStreamField进行比较。
      String getName​()
      获取此字段的名称。
      int getOffset​()
      实例数据内的字段偏移量。
      Class<?> getType​()
      获取字段的类型。
      char getTypeCode​()
      返回字段类型的字符编码。
      String getTypeString​()
      返回JVM类型签名。
      boolean isPrimitive​()
      如果此字段具有原始类型，则返回true。
      boolean isUnshared​()
      返回指示此ObjectStreamField实例表示的可序列化字段是否未共享的布尔值。
      protected void setOffset​(int offset)
      实例数据偏移。
      String toString​()
      返回描述此字段的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ObjectStreamField

        public ObjectStreamField​(String name,
                         Class<?> type)
        创建一个具有指定类型的Serializable字段。 该字段应记录有一个serialField标签。
        参数
        name - 可序列化字段的名称
        type - 可序列化字段的 Class对象

      • ObjectStreamField

        public ObjectStreamField​(String name,
                         Class<?> type,
                         boolean unshared)
        创建一个ObjectStreamField，表示具有给定名称和类型的可序列化字段。 如果unshared为false，则表示的字段的值将以默认方式进行序列化和反序列化，如果该字段为非原始对象，则对象值进行序列化和反序列化，就像已经通过对writeObject和readObject的调用进行写入和读取一样。 如果非共享为真，则表示的字段的值将被序列化和反序列化，就好像它们已经被writeUnshared和readUnshared的调用写入和读取一样。
        参数
        name - 字段名称
        type - 字段类型
        unshared - 如果为false， unshared与writeObject / readObject相同的方式写入/读取字段值; 如果为true，则以与writeUnshared / readUnshared相同的方式写入/读取
        从以下版本开始：
        1.4

    • 方法详细信息

      • getName

        public String getName​()
        获取此字段的名称。
        结果
        一个 String表示可序列化字段的名称

      • getType

        public Class<?> getType​()
        获取字段的类型。 如果该类型是非原始的，并且该ObjectStreamField是从反序列化的ObjectStreamClass实例获得的，则返回Object.class 。 否则，将返回该字段类型的Class对象。
        结果
        表示可序列化字段类型的 Class对象

      • getTypeCode

        public char getTypeCode​()
        返回字段类型的字符编码。 编码如下：
         B            byte
 C            char
 D            double
 F            float
 I            int
 J            long
 L            class or interface
 S            short
 Z            boolean
 [            array
        结果
        可序列化字段的类型代码

      • getTypeString

        public String getTypeString​()
        返回JVM类型签名。
        结果
        如果此字段具有原始类型，则为null。

      • getOffset

        public int getOffset​()
        实例数据内的字段偏移量。
        结果
        该字段的偏移量
        另请参见：
        setOffset(int)

      • setOffset

        protected void setOffset​(int offset)
        实例数据偏移。
        参数
        offset - 字段的偏移量
        另请参见：
        getOffset()

      • isPrimitive

        public boolean isPrimitive​()
        如果此字段具有原始类型，则返回true。
        结果
        当且仅当该字段对应于原始类型时才为真

      • isUnshared

        public boolean isUnshared​()
        返回指示此ObjectStreamField实例表示的可序列化字段是否未共享的布尔值。
        结果
        true如果此字段是非共享的
        从以下版本开始：
        1.4

      • compareTo

        public int compareTo​(Object obj)
        将此字段与另一个ObjectStreamField进行比较。 如果此值较小，返回-1，如果相等则返回0，如果更大则返回1。 原始类型的类型比对象类型“小”。 如果相等，则比较字段名称。
        Specified by:
        compareTo在接口 Comparable<Object>
        参数
        obj - 要比较的对象。
        结果
        负整数，零或正整数，因为该对象小于，等于或大于指定对象。

      • toString

        public String toString​()
        返回描述此字段的字符串。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OptionalDataException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class OptionalDataException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
            • java.io.OptionalDataException
  • All Implemented Interfaces:
    Serializable

    public class OptionalDataException
extends ObjectStreamException
    表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。 可能会在两种情况下抛出此异常：
    • 当流中的下一个元素是原始数据时，尝试读取对象。 在这种情况下，将OptionalDataException的length字段设置为从流中可以立即读取的原始数据的字节数，并将eof字段设置为false。
    • 试图通过类定义的readObject或readExternal方法读取数据可消耗的结束。 在这种情况下，OptionalDataException的eof字段设置为true，长度字段设置为0。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      boolean eof
      如果流的缓冲部分中没有更多数据，则为真。
      int length
      可用于在当前缓冲区中读取的原始数据的字节数。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • length

        public int length
        可用于在当前缓冲区中读取的原始数据的字节数。

      • eof

        public boolean eof
        如果流的缓冲部分中没有更多数据，则为真。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class OutputStream

  • java.lang.Object
    • java.io.OutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable
    已知直接子类：
    ByteArrayOutputStream ， FileOutputStream ， FilterOutputStream ， ObjectOutputStream ， OutputStream ， PipedOutputStream

    public abstract class OutputStream
extends Object
implements Closeable, Flushable
    这个抽象类是表示字节输出流的所有类的超类。 输出流接收输出字节并将其发送到某个接收器。

    需要定义OutputStream子类的应用程序必须至少提供一个写入一个字节输出的方法。

    从以下版本开始：
    1.0
    另请参见：
    BufferedOutputStream ， ByteArrayOutputStream ， DataOutputStream ， FilterOutputStream ， InputStream ， write(int)

    • 构造方法摘要

      构造方法
      Constructor 描述
      OutputStream​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此输出流并释放与此流相关联的任何系统资源。
      void flush​()
      刷新此输出流并强制任何缓冲的输出字节被写出。
      void write​(byte[] b)
      将 b.length字节从指定的字节数组写入此输出流。
      void write​(byte[] b, int off, int len)
      从指定的字节数组写入 len字节，从偏移量 off开始输出到此输出流。
      abstract void write​(int b)
      将指定的字节写入此输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OutputStream

        public OutputStream​()

    • 方法详细信息

      • write

        public abstract void write​(int b)
                    throws IOException
        将指定的字节写入此输出流。 write的一般合同是将一个字节写入输出流。 要写入的字节是参数b的八个低位。 忽略了b的24个高位。

        OutputStream子类必须为此方法提供一个实现。

        参数
        b - byte 。
        异常
        IOException - 如果发生I / O错误。 特别地，如果输出流已经关闭， IOException可能抛出IOException 。

      • write

        public void write​(byte[] b)
           throws IOException
        将b.length字节从指定的字节数组写入此输出流。 write(b)的一般合同是它应该具有与电话write(b, 0, b.length)完全相同的效果。
        参数
        b - 数据。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        write(byte[], int, int)

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        从位于偏移off的指定字节数组写入len字节到此输出流。 write(b, off, len)的一般合同是阵列b中的一些字节按b写入输出流; 元素b[off]是写入的第一个字节， b[off+len-1]是此操作写入的最后一个字节。

        该write的方法OutputStream调用写出在每个字节中的一个参数的写入方法。 鼓励子类覆盖此方法并提供更有效的实现。

        如果b为null ，则抛出NullPointerException 。

        如果off为负数，或len为负数，或off+len大于数组b的长度，则抛出IndexOutOfBoundsException 。

        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。 特别是，如果输出流关闭，则抛出IOException 。

      • flush

        public void flush​()
           throws IOException
        刷新此输出流并强制任何缓冲的输出字节被写出。 flush的一般合同是指出，如果以前写入的字节已经通过实现输出流缓冲，则应立即将这些字节写入到其预定目的地。

        如果此流的预期目标是由底层操作系统（例如文件）提供的抽象，那么刷新流仅保证先前写入流的字节传递到操作系统进行写入; 它并不保证它们实际上被写入物理设备，如磁盘驱动器。

        flush方法OutputStream也没做。

        Specified by:
        flush在接口 Flushable
        异常
        IOException - 如果发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此输出流并释放与此流相关联的任何系统资源。 close的总合同是关闭输出流。 封闭流不能执行输出操作，无法重新打开。

        该close的方法OutputStream什么都不做。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OutputStreamWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class OutputStreamWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.OutputStreamWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable
    已知直接子类：
    FileWriter

    public class OutputStreamWriter
extends Writer
    OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入的字符编码为字节。 它使用的字符集可以由名称指定，也可以被明确指定，或者可以接受平台的默认字符集。

    每次调用write（）方法都会使编码转换器在给定的字符上被调用。 所得到的字节在写入底层输出流之前累积在缓冲区中。 请注意，传递给write（）方法的字符不会缓冲。

    为了最大的效率，请考虑在BufferedWriter中包装一个OutputStreamWriter，以避免频繁的转换器调用。 例如：

      Writer out
   = new BufferedWriter(new OutputStreamWriter(System.out));

    代理对是由两个char值的序列表示的字符：“\ uD800”到“\ uDBFF”范围内的高代理，后跟“\ uDC00”到“\ uDFFF”范围内的低代理。

    一个畸形的替代元素是一个高替代品，其后没有高替代品的低替代品或低替代品。

    这个类总是用字符集的默认替换序列替换格式不正确的代理元素和不可映射的字符序列 。 当需要更多的编码过程控制时，应使用CharsetEncoder类。

    从以下版本开始：
    1.1
    另请参见：
    BufferedWriter ， OutputStream ， Charset

    • Field Summary

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      OutputStreamWriter​(OutputStream out)
      创建一个使用默认字符编码的OutputStreamWriter。
      OutputStreamWriter​(OutputStream out, String charsetName)
      创建一个使用命名字符集的OutputStreamWriter。
      OutputStreamWriter​(OutputStream out, Charset cs)
      创建一个使用给定字符集的OutputStreamWriter。
      OutputStreamWriter​(OutputStream out, CharsetEncoder enc)
      创建一个使用给定字符集编码器的OutputStreamWriter。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Writer append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      Writer append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      void close​()
      关闭流，先刷新。
      void flush​()
      刷新流。
      String getEncoding​()
      返回此流使用的字符编码的名称。
      void write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void write​(int c)
      写一个字符
      void write​(String str, int off, int len)
      写一个字符串的一部分。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Writer

        append, write, write

    • 构造方法详细信息

      • OutputStreamWriter

        public OutputStreamWriter​(OutputStream out,
                          String charsetName)
                   throws UnsupportedEncodingException
        创建一个使用命名字符集的OutputStreamWriter。
        参数
        out - 一个OutputStream
        charsetName - 支持的名称charset
        异常
        UnsupportedEncodingException - 如果不支持命名编码

      • OutputStreamWriter

        public OutputStreamWriter​(OutputStream out)
        创建一个使用默认字符编码的OutputStreamWriter。
        参数
        out - 一个OutputStream

      • OutputStreamWriter

        public OutputStreamWriter​(OutputStream out,
                          Charset cs)
        创建一个使用给定字符集的OutputStreamWriter。
        参数
        out - 一个OutputStream
        cs - 字符集
        从以下版本开始：
        1.4

      • OutputStreamWriter

        public OutputStreamWriter​(OutputStream out,
                          CharsetEncoder enc)
        创建一个使用给定字符集编码器的OutputStreamWriter。
        参数
        out - 一个OutputStream
        enc - 字符集编码器
        从以下版本开始：
        1.4

    • 方法详细信息

      • getEncoding

        public String getEncoding​()
        返回此流使用的字符编码的名称。

        如果编码具有历史名称，则返回该名称; 否则返回编码的规范名称。

        如果此实例是使用OutputStreamWriter(OutputStream, String)构造函数创建的，则返回的名称对于编码而言是唯一的，可能与传递给构造函数的名称不同。 如果流已关闭，此方法可能会返回null 。

        结果
        这个编码的历史名称，或者如果流已经关闭，可能是 null
        另请参见：
        Charset

      • write

        public void write​(int c)
           throws IOException
        写一个字符
        重写：
        write在 Writer
        参数
        c - int指定要写入的字符
        异常
        IOException - 如果发生I / O错误

      • write

        public void write​(char[] cbuf,
                  int off,
                  int len)
           throws IOException
        写入字符数组的一部分。
        Specified by:
        write在 Writer
        参数
        cbuf - 字符缓冲区
        off - 开始编写字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定数组的长度
        IOException - 如果发生I / O错误

      • write

        public void write​(String str,
                  int off,
                  int len)
           throws IOException
        写一个字符串的一部分。
        重写：
        write在 Writer
        参数
        str - 一个字符串
        off - 开始编写字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定字符串的长度
        IOException - 如果发生I / O错误

      • append

        public Writer append​(CharSequence csq,
                     int start,
                     int end)
              throws IOException
        说明从类别复制Writer
        将指定字符序列的子序列附加到此作者。 Appendable 。

        形式的这种方法的调用out.append(csq, start, end)时csq不是null完全相同的方式调用的行为

           out.write(csq.subSequence(start, end).toString())
        Specified by:
        append在接口 Appendable
        重写：
        append在类 Writer
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，则字符将被追加，因为csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        这位作家
        异常
        IOException - 如果发生I / O错误

      • append

        public Writer append​(CharSequence csq)
              throws IOException
        描述从类复制： Writer
        将指定的字符序列附加到此作者。

        这种out.append(csq)形式的方法的调用与调用的方式完全相同

          out.write(csq.toString())

        取决于规范toString字符序列csq ，整个序列可以不追加。 例如，调用字符缓冲区的toString方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

        Specified by:
        append在接口 Appendable
        重写：
        append在 Writer
        参数
        csq - 要附加的字符序列。 如果csq是null ，那么四个字符"null"被附加到该写入器。
        结果
        这位作家
        异常
        IOException - 如果发生I / O错误

      • flush

        public void flush​()
           throws IOException
        刷新流。
        Specified by:
        flush在接口 Flushable
        Specified by:
        flush在类 Writer
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
           throws IOException
        描述从类别复制Writer
        关闭流，先刷新。 一旦流已关闭，进一步的write（）或flush（）调用将导致抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Writer
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PipedInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PipedInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.PipedInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class PipedInputStream
extends InputStream
    管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。 通常，一个线程从PipedInputStream对象读取数据，并且其他线程将数据写入相应的PipedOutputStream 。 不建议尝试从单个线程使用这两个对象，因为它可能会使线程死锁。 管道输入流包含一个缓冲区，在读取操作中将读取操作与限制内的操作相分离。 如果向连接的管道输出流提供数据字节的线程不再存在， 则称管道为broken 。
    从以下版本开始：
    1.0
    另请参见：
    PipedOutputStream

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buffer
      传入数据的循环缓冲区。
      protected int in
      在从连接的管道输出流接收到的数据的下一个字节将被存储的循环缓冲区中的位置的索引。
      protected int out
      循环缓冲区中的位置的索引，在该缓冲区中下一个字节的数据将被该管道输入流读取。
      protected static int PIPE_SIZE
      管道循环输入缓冲区的默认大小。

    • 构造方法摘要

      构造方法
      Constructor 描述
      PipedInputStream​()
      创建一个 PipedInputStream ，使其尚未 connected 。
      PipedInputStream​(int pipeSize)
      创建一个 PipedInputStream ，使其不是 connected并且使用指定的管道大小作为管道的缓冲区。
      PipedInputStream​(PipedOutputStream src)
      创建一个 PipedInputStream ，使其连接到管道输出流 src 。
      PipedInputStream​(PipedOutputStream src, int pipeSize)
      创建一个 PipedInputStream ，使其连接到管道输出流 src并为管道缓冲区使用指定的管道大小。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      返回可以从该输入流读取而不阻塞的字节数。
      void close​()
      关闭此管道输入流，并释放与流相关联的任何系统资源。
      void connect​(PipedOutputStream src)
      使此管道输入流连接到管道输出流 src 。
      int read​()
      从这个管道输入流读取数据的下一个字节。
      int read​(byte[] b, int off, int len)
      从这个管道输入流读取最多 len个字节的数据到字节数组。
      protected void receive​(int b)
      接收一个字节的数据。

      • Methods inherited from class java.io.InputStream

        mark, markSupported, read, readAllBytes, readNBytes, reset, skip, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • PIPE_SIZE

        protected static final int PIPE_SIZE
        管道循环输入缓冲区的默认大小。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • buffer

        protected byte[] buffer
        传入数据的循环缓冲区。
        从以下版本开始：
        1.1

      • in

        protected int in
        在从连接的管道输出流接收到的数据的下一个字节将被存储的循环缓冲区中的位置的索引。 in<0意味着缓冲区是空的， in==out意味着缓冲区已满
        从以下版本开始：
        1.1

      • out

        protected int out
        循环缓冲区中的位置的索引，在该缓冲区中下一个字节的数据将被该管道输入流读取。
        从以下版本开始：
        1.1

    • 构造方法详细信息

      • PipedInputStream

        public PipedInputStream​(PipedOutputStream src)
                 throws IOException
        创建一个PipedInputStream ，使其连接到管道输出流src 。 写入src数据字节将作为此流的输入。
        参数
        src - 要连接的流。
        异常
        IOException - 如果发生I / O错误。

      • PipedInputStream

        public PipedInputStream​(PipedOutputStream src,
                        int pipeSize)
                 throws IOException
        创建一个PipedInputStream ，使其连接到管道输出流src并为管道缓冲区使用指定的管道大小。 写入src数据字节将作为此流的输入。
        参数
        src - 要连接的流。
        pipeSize - 管道缓冲区的大小。
        异常
        IOException - 如果发生I / O错误。
        IllegalArgumentException - 如果是 pipeSize <= 0 。
        从以下版本开始：
        1.6

      • PipedInputStream

        public PipedInputStream​()
        创建一个PipedInputStream ，使其尚未connected 。 使用前必须先connected才能使用PipedOutputStream 。

      • PipedInputStream

        public PipedInputStream​(int pipeSize)
        创建一个PipedInputStream ，使它还不是connected，并使用指定的管道大小作为管道的缓冲区。 在使用前必须是connected到PipedOutputStream 。
        参数
        pipeSize - 管道缓冲区的大小。
        异常
        IllegalArgumentException - 如果是 pipeSize <= 0 。
        从以下版本开始：
        1.6

    • 方法详细信息

      • connect

        public void connect​(PipedOutputStream src)
             throws IOException
        使此管道输入流连接到管道输出流src 。 如果此对象已连接到其他管道输出流，则抛出IOException 。

        如果src是未连接的管道输出流，并且snk是未连接的管道输入流，则可以通过以下任一方式连接它们：

          snk.connect(src)

        或电话：

          src.connect(snk)

        两个电话有相同的效果。

        参数
        src - 连接到管道输出流。
        异常
        IOException - 如果发生I / O错误。

      • receive

        protected void receive​(int b)
                throws IOException
        接收一个字节的数据。 如果没有输入可用，此方法将阻止。
        参数
        b - 正在接收的字节
        异常
        IOException -如果管道是 broken ， unconnected ，关闭，或者如果发生I / O错误。
        从以下版本开始：
        1.1

      • read

        public int read​()
         throws IOException
        从这个管道输入流读取数据的下一个字节。 值字节作为int返回到0到255 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。
        Specified by:
        read在 InputStream
        结果
        数据的下一个字节，如果达到流的末尾， -1 。
        异常
        IOException -如果管道是 unconnected ， broken ，关闭，或者如果发生I / O错误。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从这个管道输入流读取最多len个字节的数据到字节数组。 如果达到数据流的结尾，或者如果len超过了管道的缓冲区大小，则读取少于len个字节。 如果len为零，则不读取字节并返回0; 否则，该方法将阻塞，直到输入的至少1个字节可用，已经检测到流的结尾，或抛出异常。
        重写：
        read在 InputStream
        参数
        b - 读取数据的缓冲区。
        off - 目标阵列 b的起始偏移量
        len - 读取的最大字节数。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾，那么这个字节是 -1 。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负数，则 len为负数，或 len大于 b.length - off
        IOException -如果管道是 broken ， unconnected ，关闭，或者如果发生I / O错误。
        另请参见：
        InputStream.read()

      • available

        public int available​()
              throws IOException
        返回可以从该输入流读取而不阻塞的字节数。
        重写：
        available在类 InputStream
        结果
        可以从该输入流无阻塞读取，或字节数 0该输入流是否已调用它的关闭 close()方法，或者如果管道是 unconnected ，或 broken 。
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.0.2

      • close

        public void close​()
           throws IOException
        关闭此管道输入流，并释放与流相关联的任何系统资源。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 InputStream
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PipedOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PipedOutputStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.PipedOutputStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， AutoCloseable

    public class PipedOutputStream
extends OutputStream
    管道输出流可以连接到管道输入流以创建通信管道。 管道输出流是管道的发送端。 通常，数据由一个线程写入一个PipedOutputStream对象，数据由其他线程从连接的PipedInputStream读取。 不建议尝试从单个线程使用这两个对象，因为它可能会使线程死锁。 如果正在从连接的管道输入流读取数据字节的线程不再存活，则该管道被称为broken 。
    从以下版本开始：
    1.0
    另请参见：
    PipedInputStream

    • 构造方法摘要

      构造方法
      Constructor 描述
      PipedOutputStream​()
      创建一个尚未连接到管道输入流的管道输出流。
      PipedOutputStream​(PipedInputStream snk)
      创建连接到指定管道输入流的管道输出流。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此管道输出流，并释放与此流相关联的任何系统资源。
      void connect​(PipedInputStream snk)
      将此管道输出流连接到接收器。
      void flush​()
      刷新此输出流并强制任何缓冲的输出字节被写出。
      void write​(byte[] b, int off, int len)
      从指定的字节数组写入 len字节，从偏移量 off开始 off到这个管道输出流。
      void write​(int b)
      将指定的 byte写入管道输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.OutputStream

        write

    • 构造方法详细信息

      • PipedOutputStream

        public PipedOutputStream​(PipedInputStream snk)
                  throws IOException
        创建连接到指定管道输入流的管道输出流。 写入此流的数据字节将作为snk输入。
        参数
        snk - 要连接的管道输入流。
        异常
        IOException - 如果发生I / O错误。

      • PipedOutputStream

        public PipedOutputStream​()
        创建一个尚未连接到管道输入流的管道输出流。 在使用之前，它必须由接收器或发送器连接到管道输入流。
        另请参见：
        PipedInputStream.connect(java.io.PipedOutputStream) ， connect(java.io.PipedInputStream)

    • 方法详细信息

      • connect

        public void connect​(PipedInputStream snk)
             throws IOException
        将此管道输出流连接到接收器。 如果此对象已连接到其他管道输入流，则抛出IOException 。

        如果snk是未连接的管道输入流，并且src是未连接的管道输出流，则可以通过以下任一方式连接它们：

         src.connect(snk)
        或电话：
         snk.connect(src)
        两个电话有相同的效果。
        参数
        snk - 要连接的管道输入流。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(int b)
           throws IOException
        将指定的byte写入管道输出流。

        实现write方法OutputStream 。

        Specified by:
        write在 OutputStream
        参数
        b - byte 。
        异常
        IOException -如果管道是 broken ， unconnected ，关闭，或者如果发生I / O错误。

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        从指定的字节数组写入len字节，从偏移量off开始off到这个管道输出流。 该方法阻塞直到所有字节被写入输出流。
        重写：
        write在 OutputStream
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException -如果管道是 broken ， unconnected ，关闭，或者如果发生I / O错误。

      • flush

        public void flush​()
           throws IOException
        刷新此输出流并强制任何缓冲的输出字节被写出。 这将通知任何读者字节在管道中等待。
        Specified by:
        flush在接口 Flushable
        重写：
        flush在 OutputStream
        异常
        IOException - 如果发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此管道输出流，并释放与此流相关联的任何系统资源。 此流可能不再用于写入字节。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 OutputStream
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PipedReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PipedReader

  • java.lang.Object
    • java.io.Reader
      • java.io.PipedReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable

    public class PipedReader
extends Reader
    流水字符输入流。
    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      PipedReader​()
      创建一个 PipedReader ，使其尚未 connected 。
      PipedReader​(int pipeSize)
      创建一个 PipedReader ，使其尚未 connected，并使用指定的管道大小作为管道的缓冲区。
      PipedReader​(PipedWriter src)
      创建一个 PipedReader ，使其连接到管道写入器 src 。
      PipedReader​(PipedWriter src, int pipeSize)
      创建一个 PipedReader ，使其连接到管道写入器 src并使用指定的管道大小作为管道缓冲区。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此管道流，并释放与流相关联的任何系统资源。
      void connect​(PipedWriter src)
      使这个管道读取器连接到管道写入器 src 。
      int read​()
      从这个管道流读取下一个数据字符。
      int read​(char[] cbuf, int off, int len)
      从这个管道流读取最多 len字符的数据字符数组。
      boolean ready​()
      告诉这个流是否准备好阅读。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        mark, markSupported, read, read, reset, skip

    • 构造方法详细信息

      • PipedReader

        public PipedReader​(PipedWriter src)
            throws IOException
        创建一个PipedReader ，使其连接到管道写入器src 。 写入src数据将作为此流的输入。
        参数
        src - 要连接的流。
        异常
        IOException - 如果发生I / O错误。

      • PipedReader

        public PipedReader​(PipedWriter src,
                   int pipeSize)
            throws IOException
        创建一个PipedReader ，使其连接到管道写入器src并为管道缓冲区使用指定的管道大小。 写入src数据将作为此流的输入。
        参数
        src - 要连接的流。
        pipeSize - 管道缓冲区的大小。
        异常
        IOException - 如果发生I / O错误。
        IllegalArgumentException - 如果是 pipeSize <= 0 。
        从以下版本开始：
        1.6

      • PipedReader

        public PipedReader​()
        创建一个PipedReader所以它还不是connected 。 在使用之前，它必须是PipedWriter PipedWriter 。

      • PipedReader

        public PipedReader​(int pipeSize)
        创建一个PipedReader ，使它还不是connected并且使用指定的管道大小作为管道的缓冲区。 在使用前必须是connected到PipedWriter 。
        参数
        pipeSize - 管道缓冲区的大小。
        异常
        IllegalArgumentException - 如果是 pipeSize <= 0 。
        从以下版本开始：
        1.6

    • 方法详细信息

      • connect

        public void connect​(PipedWriter src)
             throws IOException
        使这个管道读取器连接到管道写入器src 。 如果此对象已连接到其他管道写入器，则抛出IOException 。

        如果src是未连接的管道写入器，并且snk是未连接的管道读取器，则可以通过以下任一方式连接它们：

          snk.connect(src)

        或电话：

          src.connect(snk)

        两个电话有相同的效果。

        参数
        src - 连接到管道写入器。
        异常
        IOException - 如果发生I / O错误。

      • read

        public int read​()
         throws IOException
        从这个管道流读取下一个数据字符。 如果没有字符可用，因为流已经到达，则返回值-1 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。
        重写：
        read在 Reader
        结果
        数据的下一个字符，如果达到流的末尾， -1 。
        异常
        IOException -如果管道是 broken ， unconnected ，关闭，或发生I / O错误。

      • read

        public int read​(char[] cbuf,
                int off,
                int len)
         throws IOException
        从这个管道数据流读取最多len字符的字符数组。 如果达到数据流的结尾或者如果len超过了管道的缓冲区大小，则读取少于len字符。 该方法阻塞，直到输入的至少一个字符可用。
        Specified by:
        read在 Reader
        参数
        cbuf - 读取数据的缓冲区。
        off - 数据的起始偏移量。
        len - 读取的最大字符数。
        结果
        读入缓冲区的字符总数，如果没有更多的数据，因为已经到达流的末尾，那么这个字符是 -1 。
        异常
        IOException -如果管道是 broken ， unconnected ，关闭，或发生I / O错误。
        IndexOutOfBoundsException - 如果发生I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好阅读。 如果循环缓冲区不为空，则管道字符流就绪。
        重写：
        ready在 Reader
        结果
        如果下一个read（）保证不阻止输入，则为True，否则为false。 请注意，返回false并不能保证下一次读取将被阻止。
        异常
        IOException -如果管道是 broken ， unconnected ，或关闭。

      • close

        public void close​()
           throws IOException
        关闭此管道流，并释放与流相关联的任何系统资源。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Reader
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PipedWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PipedWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.PipedWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable

    public class PipedWriter
extends Writer
    流水字符输出流。
    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      PipedWriter​()
      创建一个尚未连接到管道读取器的管道写入器。
      PipedWriter​(PipedReader snk)
      创建连接到指定管道读取器的管道写入器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此管道输出流，并释放与此流相关联的任何系统资源。
      void connect​(PipedReader snk)
      将此管道写入器连接到接收器。
      void flush​()
      刷新此输出流并强制任何缓冲的输出字符被写出。
      void write​(char[] cbuf, int off, int len)
      从指定的字符数组写入 len字符，从偏移量 off开始 off到这个管道输出流。
      void write​(int c)
      将指定的 char写入管道输出流。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Writer

        append, append, append, write, write, write

    • 构造方法详细信息

      • PipedWriter

        public PipedWriter​(PipedReader snk)
            throws IOException
        创建连接到指定管道读取器的管道写入器。 写入此流的数据字符将作为snk输入。
        参数
        snk - 连接到管道阅读器。
        异常
        IOException - 如果发生I / O错误。

      • PipedWriter

        public PipedWriter​()
        创建一个尚未连接到管道读取器的管道写入器。 在使用之前，它必须由接收器或发送器连接到管道式读取器。
        另请参见：
        PipedReader.connect(java.io.PipedWriter) ， connect(java.io.PipedReader)

    • 方法详细信息

      • connect

        public void connect​(PipedReader snk)
             throws IOException
        将此管道写入器连接到接收器。 如果此对象已连接到其他管道读取器，则抛出IOException 。

        如果snk是未连接的管道读写器，并且src是未连接的管道写入器，则可以通过以下任一方式连接：

         src.connect(snk)
        或电话：
         snk.connect(src)
        两个电话有相同的效果。
        参数
        snk - 连接到管道阅读器。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(int c)
           throws IOException
        将指定的char写入管道输出流。 如果线程正在从连接的管道输入流中读取数据字符，但线程不再存在，则抛出一个IOException 。

        实现write方法Writer 。

        重写：
        write在 Writer
        参数
        c - char 。
        异常
        IOException - 如果管道为 broken,unconnected ， 则关闭或发生I / O错误。

      • write

        public void write​(char[] cbuf,
                  int off,
                  int len)
           throws IOException
        将len字符从指定的字符数组开始，从偏移量off开始off到这个管道输出流。 该方法阻塞，直到所有字符被写入输出流。 如果一个线程正在从连接的管道输入流中读取数据字符，但线程不再存在，则抛出一个IOException 。
        Specified by:
        write在 Writer
        参数
        cbuf - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字符数。
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定数组的长度
        IOException -如果管道是 broken ， unconnected ，关闭或发生I / O错误。

      • flush

        public void flush​()
           throws IOException
        刷新此输出流并强制任何缓冲的输出字符被写出。 这将通知任何读者字符在管道中等待。
        Specified by:
        flush在接口 Flushable
        Specified by:
        flush在 Writer
        异常
        IOException - 如果管道关闭或发生I / O错误。

      • close

        public void close​()
           throws IOException
        关闭此管道输出流，并释放与此流相关联的任何系统资源。 此流可能不再用于书写字符。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Writer
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrintStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PrintStream

  • java.lang.Object
    • java.io.OutputStream
      • java.io.FilterOutputStream
        • java.io.PrintStream
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable
    已知直接子类：
    LogStream

    public class PrintStream
extends FilterOutputStream
implements Appendable, Closeable
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。 还提供了另外两个功能。 不像其他输出流，一个PrintStream从不抛出一个IOException ; 相反，异常情况只是设置一个可以通过checkError方法测试的内部标志。 可选地，可以创建PrintStream以便自动刷新; 这意味着flush方法在写入字节数组之后自动调用，其中一个println方法被调用，或换行字符（ '\n' ）被写入。

    使用平台的默认字符编码将PrintStream打印的所有字符转换为字节。 PrintWriter类应该在需要写入字符而不是字节的情况下使用。

    从以下版本开始：
    1.0

    • Field Summary

      • Fields inherited from class java.io.FilterOutputStream

        out

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrintStream​(File file)
      使用指定的文件创建一个新的打印流，而不需要自动换行。
      PrintStream​(File file, String csn)
      使用指定的文件和字符集创建新的打印流，而不需要自动换行。
      PrintStream​(OutputStream out)
      创建一个新的打印流。
      PrintStream​(OutputStream out, boolean autoFlush)
      创建一个新的打印流。
      PrintStream​(OutputStream out, boolean autoFlush, String encoding)
      创建一个新的打印流。
      PrintStream​(String fileName)
      使用指定的文件名创建新的打印流，无需自动换行。
      PrintStream​(String fileName, String csn)
      创建一个新的打印流，不需要自动换行，具有指定的文件名和字符集。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PrintStream append​(char c)
      将指定的字符附加到此输出流。
      PrintStream append​(CharSequence csq)
      将指定的字符序列附加到此输出流。
      PrintStream append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此输出流。
      boolean checkError​()
      刷新流并检查其错误状态。
      protected void clearError​()
      清除此流的内部错误状态。
      void close​()
      关闭流。
      void flush​()
      刷新流。
      PrintStream format​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流。
      PrintStream format​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流。
      void print​(boolean b)
      打印布尔值。
      void print​(char c)
      打印一个字符
      void print​(char[] s)
      打印字符数组。
      void print​(double d)
      打印双精度浮点数。
      void print​(float f)
      打印浮点数。
      void print​(int i)
      打印一个整数。
      void print​(long l)
      打印一个长整数。
      void print​(Object obj)
      打印一个对象。
      void print​(String s)
      打印字符串。
      PrintStream printf​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。
      PrintStream printf​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。
      void println​()
      通过写入行分隔符字符串来终止当前行。
      void println​(boolean x)
      打印一个布尔值，然后终止该行。
      void println​(char x)
      打印一个字符，然后终止该行。
      void println​(char[] x)
      打印一个字符数组，然后终止该行。
      void println​(double x)
      打印一次，然后终止行。
      void println​(float x)
      打印一个浮点数，然后终止该行。
      void println​(int x)
      打印一个整数，然后终止行。
      void println​(long x)
      打印很长时间，然后终止行。
      void println​(Object x)
      打印一个对象，然后终止该行。
      void println​(String x)
      打印一个字符串，然后终止行。
      protected void setError​()
      将流的错误状态设置为 true 。
      void write​(byte[] buf, int off, int len)
      将 len字节从指定的字节数组开始，从偏移 off开始写入此流。
      void write​(int b)
      将指定的字节写入此流。

      • Methods inherited from class java.io.FilterOutputStream

        write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PrintStream

        public PrintStream​(OutputStream out)
        创建一个新的打印流。 此流不会自动刷新。
        参数
        out - 要打印值和对象的输出流
        另请参见：
        PrintWriter(java.io.OutputStream)

      • PrintStream

        public PrintStream​(OutputStream out,
                   boolean autoFlush)
        创建一个新的打印流。
        参数
        out - 要打印值和对象的输出流
        autoFlush - 一个布尔值 如果为true，则每当写入一个字节数组时，输出缓冲区将被刷新，其中一个println方法被调用，或换行符或字节（ '\n' ）被写入
        另请参见：
        PrintWriter(java.io.OutputStream, boolean)

      • PrintStream

        public PrintStream​(OutputStream out,
                   boolean autoFlush,
                   String encoding)
            throws UnsupportedEncodingException
        创建一个新的打印流。
        参数
        out - 要打印值和对象的输出流
        autoFlush - 一个布尔值 如果为真，则每当写入一个字节数组时，输出缓冲区将被刷新，其中一个println方法被调用，或换行字符（ '\n' ）被写入
        encoding - 支持的名称 character encoding
        异常
        UnsupportedEncodingException - 如果不支持命名编码
        从以下版本开始：
        1.4

      • PrintStream

        public PrintStream​(String fileName)
            throws FileNotFoundException
        使用指定的文件名创建新的打印流，无需自动换行。 这个方便的构造函数创建必要的中间件OutputStreamWriter ，它将使用Java虚拟机的这个实例使用default charset对字符进行编码。
        参数
        fileName - 要用作此打印流的目标位置的文件的名称。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时出现其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(fileName)否认对该文件的写入访问
        从以下版本开始：
        1.5

      • PrintStream

        public PrintStream​(String fileName,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
        创建一个新的打印流，不需要自动换行，具有指定的文件名和字符集。 这个方便的构造函数创建必要的中间件OutputStreamWriter ，它将使用提供的字符集对字符进行编码。
        参数
        fileName - 要用作此打印流的目标的文件的名称。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时出现其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(fileName)拒绝对该文件的写入访问
        UnsupportedEncodingException - 如果不支持命名的字符集
        从以下版本开始：
        1.5

      • PrintStream

        public PrintStream​(File file)
            throws FileNotFoundException
        使用指定的文件创建一个新的打印流，而不需要自动换行。 这个便利的构造函数创建必要的中间件OutputStreamWriter ，它将使用Java虚拟机的这个实例使用default charset对字符进行编码。
        参数
        file - 用作此打印流目的地的文件。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(file.getPath())拒绝对文件的写入访问
        从以下版本开始：
        1.5

      • PrintStream

        public PrintStream​(File file,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
        使用指定的文件和字符集创建新的打印流，而不需要自动换行。 这个方便的构造函数创建必要的中间件OutputStreamWriter ，它将使用提供的字符集对字符进行编码。
        参数
        file - 用作此打印流的目的地的文件。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(file.getPath())拒绝对文件的写入访问
        UnsupportedEncodingException - 如果不支持命名的字符集
        从以下版本开始：
        1.5

    • 方法详细信息

      • flush

        public void flush​()
        刷新流。 这是通过将任何缓冲的输出字节写入底层输出流，然后刷新该流来完成的。
        Specified by:
        flush在接口 Flushable
        重写：
        flush在 FilterOutputStream
        另请参见：
        OutputStream.flush()

      • close

        public void close​()
        关闭流。 这是通过刷新流，然后关闭底层输出流来完成的。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在类 FilterOutputStream
        另请参见：
        OutputStream.close()

      • checkError

        public boolean checkError​()
        刷新流并检查其错误状态。 内部错误状态设置为true当底层输出流引发IOException而不是InterruptedIOException ，并且当调用setError方法时。 如果底层输出流上的操作会引发一个InterruptedIOException ，那么PrintStream会将异常转换为中断：
           Thread.currentThread().interrupt();
        或等同物。
        结果
        true当且仅当该流遇到 IOException以外 InterruptedIOException ，或 setError方法已被调用

      • setError

        protected void setError​()
        将流的错误状态设置为true 。

        此方法将导致checkError()的后续调用返回true直到调用clearError() 。

        从以下版本开始：
        1.1

      • clearError

        protected void clearError​()
        清除此流的内部错误状态。

        此方法将导致checkError()的后续调用返回false直到另一个写操作失败并调用setError() 。

        从以下版本开始：
        1.6

      • write

        public void write​(int b)
        将指定的字节写入此流。 如果字节是换行符，并且启用自动刷新， flush调用flush方法。

        请注意，该字节写为给定; 编写一个将根据平台的默认字符编码进行翻译的字符，使用print(char)或println(char)方法。

        重写：
        write在 FilterOutputStream
        参数
        b - 要写入的字节
        另请参见：
        print(char) ， println(char)

      • write

        public void write​(byte[] buf,
                  int off,
                  int len)
        从指定的字节数组写入len字节，从偏移量off开始写入此流。 如果启用自动冲洗， flush调用flush方法。

        请注意，字节将按照给定的方式写入; 要根据平台的默认字符编码编写将要翻译的字符，请使用print(char)或println(char)方法。

        重写：
        write在类 FilterOutputStream
        参数
        buf - 一个字节数组
        off - off开始 off字节的偏移量
        len - 要写入的字节数
        另请参见：
        FilterOutputStream.write(int)

      • print

        public void print​(boolean b)
        打印布尔值。 由String.valueOf(boolean)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式按照write(int)的方式进行写入。
        参数
        b - 要打印的 boolean

      • print

        public void print​(char c)
        打印一个字符 该字符根据平台的默认字符编码转换为一个或多个字节，这些字节以write(int)的方式完全写入。
        参数
        c - 要打印的 char

      • print

        public void print​(int i)
        打印一个整数。 由String.valueOf(int)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)的方式写入。
        参数
        i - 要打印的 int
        另请参见：
        Integer.toString(int)

      • print

        public void print​(long l)
        打印一个长整数。 由String.valueOf(long)生成的字符串根据平台的默认字符编码转换为字节，这些字节以write(int)的方式写入。
        参数
        l - 要打印的 long
        另请参见：
        Long.toString(long)

      • print

        public void print​(float f)
        打印浮点数。 由String.valueOf(float)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式按照write(int)的方式进行写入。
        参数
        f - 要打印的 float
        另请参见：
        Float.toString(float)

      • print

        public void print​(double d)
        打印双精度浮点数。 由String.valueOf(double)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)的方式写入。
        参数
        d - 要打印的 double
        另请参见：
        Double.toString(double)

      • print

        public void print​(char[] s)
        打印字符数组。 这些字符根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)的方式写入。
        参数
        s - 要打印的字符数组
        异常
        NullPointerException - 如果 s是 null

      • print

        public void print​(String s)
        打印字符串。 如果参数为null则打印字符串"null" 。 否则，根据平台的默认字符编码，字符串的字符将转换为字节，这些字节的格式完全按照write(int)的方式编写。
        参数
        s - 要打印的 String

      • print

        public void print​(Object obj)
        打印一个对象。 由String.valueOf(Object)方法生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)方法编写。
        参数
        obj - 要打印的 Object
        另请参见：
        Object.toString()

      • println

        public void println​()
        通过写入行分隔符字符串来终止当前行。 行分隔符字符串由系统属性line.separator定义，并不一定是单个换行符（ '\n' ）。

      • println

        public void println​(boolean x)
        打印一个布尔值，然后终止该行。 该方法的行为就像调用print(boolean)然后println()一样 。
        参数
        x - 要打印的 boolean

      • println

        public void println​(char x)
        打印一个字符，然后终止该行。 该方法的行为就像调用print(char)然后println()一样 。
        参数
        x - 要打印的 char 。

      • println

        public void println​(int x)
        打印一个整数，然后终止行。 该方法的行为就好像它调用了print(int) ，然后是println() 。
        参数
        x - 要打印的 int 。

      • println

        public void println​(long x)
        打印很长时间，然后终止行。 这个方法的行为就好像它调用了print(long) ，然后是println() 。
        参数
        x - a要打印的 long 。

      • println

        public void println​(float x)
        打印一个浮点数，然后终止该行。 该方法的行为就像调用print(float)然后println()一样 。
        参数
        x - 要打印的 float 。

      • println

        public void println​(double x)
        打印一次，然后终止行。 该方法的行为就像调用print(double)然后println()一样 。
        参数
        x - 要打印的 double 。

      • println

        public void println​(char[] x)
        打印一个字符数组，然后终止该行。 该方法的行为就像调用print(char[])然后println()一样 。
        参数
        x - 要打印的字符数组。

      • println

        public void println​(String x)
        打印一个字符串，然后终止行。 该方法的行为就像调用print(String) ，然后是println()一样 。
        参数
        x - 要打印的 String 。

      • println

        public void println​(Object x)
        打印一个对象，然后终止该行。 此方法首先调用String.valueOf（x）来获取打印对象的字符串值，然后表现为调用print(String)然后println() 。
        参数
        x - 要打印的 Object 。

      • printf

        public PrintStream printf​(String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。

        对这种out.printf(format, args)形式的方法的调用与调用的方式完全相同

           out.format(format, args)
        参数
        format - Format string syntax中描述的格式字符串
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        这个输出流
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • printf

        public PrintStream printf​(Locale l,
                          String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。

        这种out.printf(l, format, args)形式的方法的调用与调用的方式完全相同

           out.format(l, format, args)
        参数
        l - 格式化期间应用的locale 。 如果l是null则不应用本地化。
        format - Format string syntax中描述的格式字符串
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维数。 一个null参数的行为取决于conversion 。
        结果
        这个输出流
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • format

        public PrintStream format​(String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此输出流。

        始终使用的区域设置是由Locale.getDefault(Locale.Category)返回的， 其中指定了FORMAT类别，而不管以前在此对象上调用其他格式化方法。

        参数
        format - Format string syntax中描述的格式字符串
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维数。 一个null参数的行为取决于conversion 。
        结果
        这个输出流
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • format

        public PrintStream format​(Locale l,
                          String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此输出流。
        参数
        l - 格式化期间应用的locale 。 如果l为null则不应用本地化。
        format - Format string syntax中描述的格式字符串
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        这个输出流
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • append

        public PrintStream append​(CharSequence csq)
        将指定的字符序列附加到此输出流。

        对这种out.append(csq)形式的方法的调用与调用的方式完全相同

           out.print(csq.toString())

        取决于规范toString字符序列csq ，整个序列可以不追加。 例如，调用然后toString一个字符缓冲区的方法将返回一个序列，其内容取决于缓冲区的位置和限制。

        Specified by:
        append在接口 Appendable
        参数
        csq - 要追加的字符序列。 如果csq是null ，那么四个字符"null"附加到该输出流。
        结果
        这个输出流
        从以下版本开始：
        1.5

      • append

        public PrintStream append​(CharSequence csq,
                          int start,
                          int end)
        将指定字符序列的子序列附加到此输出流。

        形式的这种方法的调用out.append(csq, start, end)时csq不是null ，行为以完全相同的方式调用

           out.print(csq.subSequence(start, end).toString())
        Specified by:
        append在接口 Appendable
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，则字符将被追加，就像csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        这个输出流
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，则 start大于 end ，或 end大于 csq.length()
        从以下版本开始：
        1.5

      • append

        public PrintStream append​(char c)
        将指定的字符附加到此输出流。

        对这种out.append(c)形式的方法的调用与调用的方式完全相同

           out.print(c)
        Specified by:
        append在接口 Appendable
        参数
        c - 要追加的16位字符
        结果
        这个输出流
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PrintWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PrintWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.PrintWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable

    public class PrintWriter
extends Writer
    将对象的格式表示打印到文本输出流。 这个类实现所有的print中发现的方法PrintStream 。 它不包含用于编写原始字节的方法，程序应使用未编码的字节流。

    不像PrintStream类，如果启用自动刷新，将只有当一个做println ， printf ，或format被调用的方法，而不是当一个换行符恰好是输出。 这些方法使用平台自己的行分隔符而不是换行符。

    这个类中的方法不会抛出I / O异常，尽管它的一些构造函数可能。 客户可以通过调用checkError()查询是否发生错误。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Writer out
      这个 PrintWriter的底层字符输出流。

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      PrintWriter​(File file)
      使用指定的文件创建一个新的PrintWriter，而不需要自动的线路刷新。
      PrintWriter​(File file, String csn)
      使用指定的文件和字符集创建一个新的PrintWriter，而不需要自动进行线条刷新。
      PrintWriter​(OutputStream out)
      从现有的OutputStream创建一个新的PrintWriter，而不需要自动线路刷新。
      PrintWriter​(OutputStream out, boolean autoFlush)
      从现有的OutputStream创建一个新的PrintWriter。
      PrintWriter​(Writer out)
      创建一个新的PrintWriter，没有自动线冲洗。
      PrintWriter​(Writer out, boolean autoFlush)
      创建一个新的PrintWriter。
      PrintWriter​(String fileName)
      使用指定的文件名创建一个新的PrintWriter，而不需要自动执行行刷新。
      PrintWriter​(String fileName, String csn)
      使用指定的文件名和字符集创建一个新的PrintWriter，而不需要自动线路刷新。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      PrintWriter append​(char c)
      将指定的字符附加到此作者。
      PrintWriter append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      PrintWriter append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      boolean checkError​()
      如果流未关闭，请刷新流并检查其错误状态。
      protected void clearError​()
      清除此流的错误状态。
      void close​()
      关闭流并释放与之相关联的任何系统资源。
      void flush​()
      刷新流。
      PrintWriter format​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此写入程序。
      PrintWriter format​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此写入程序。
      void print​(boolean b)
      打印布尔值。
      void print​(char c)
      打印一个字符
      void print​(char[] s)
      打印字符数组。
      void print​(double d)
      打印双精度浮点数。
      void print​(float f)
      打印浮点数。
      void print​(int i)
      打印一个整数。
      void print​(long l)
      打印一个长整数。
      void print​(Object obj)
      打印一个对象。
      void print​(String s)
      打印字符串。
      PrintWriter printf​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。
      PrintWriter printf​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。
      void println​()
      通过写入行分隔符字符串来终止当前行。
      void println​(boolean x)
      打印一个布尔值，然后终止该行。
      void println​(char x)
      打印一个字符，然后终止该行。
      void println​(char[] x)
      打印字符数组，然后终止行。
      void println​(double x)
      打印双精度浮点数，然后终止行。
      void println​(float x)
      打印一个浮点数，然后终止该行。
      void println​(int x)
      打印一个整数，然后终止该行。
      void println​(long x)
      打印一个长整型，然后终止行。
      void println​(Object x)
      打印一个对象，然后终止该行。
      void println​(String x)
      打印一个字符串，然后终止行。
      protected void setError​()
      表示发生错误。
      void write​(char[] buf)
      写入一个字符数组。
      void write​(char[] buf, int off, int len)
      写一个字符数组的一部分。
      void write​(int c)
      写一个字符
      void write​(String s)
      写一个字符串
      void write​(String s, int off, int len)
      写一个字符串的一部分。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • out

        protected Writer out
        这个 PrintWriter的底层字符输出流。
        从以下版本开始：
        1.2

    • 构造方法详细信息

      • PrintWriter

        public PrintWriter​(Writer out)
        创建一个新的PrintWriter，没有自动线冲洗。
        参数
        out - 字符输出流

      • PrintWriter

        public PrintWriter​(Writer out,
                   boolean autoFlush)
        创建一个新的PrintWriter。
        参数
        out - 字符输出流
        autoFlush - 一个布尔值 如果为真，则println ， printf ，或format方法将刷新输出缓冲区

      • PrintWriter

        public PrintWriter​(OutputStream out)
        从现有的OutputStream创建一个新的PrintWriter，而不需要自动线路刷新。 这个方便的构造函数创建必要的中间OutputStreamWriter，它将使用默认字符编码将字符转换为字节。
        参数
        out - 输出流
        另请参见：
        OutputStreamWriter(java.io.OutputStream)

      • PrintWriter

        public PrintWriter​(OutputStream out,
                   boolean autoFlush)
        从现有的OutputStream创建一个新的PrintWriter。 这个方便的构造函数创建必要的中间OutputStreamWriter，它将使用默认字符编码将字符转换为字节。
        参数
        out - 输出流
        autoFlush - 一个布尔值 如果为真，则println ， printf ，或format方法将刷新输出缓冲区
        另请参见：
        OutputStreamWriter(java.io.OutputStream)

      • PrintWriter

        public PrintWriter​(String fileName)
            throws FileNotFoundException
        使用指定的文件名创建一个新的PrintWriter，而不需要自动执行行刷新。 这个方便的构造函数创建必要的中间件OutputStreamWriter ，它将使用Java虚拟机的这个实例使用default charset对字符进行编码。
        参数
        fileName - 要用作此作者目的地的文件的名称。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        异常
        FileNotFoundException - 如果给定的字符串不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(fileName)拒绝对文件的写入访问
        从以下版本开始：
        1.5

      • PrintWriter

        public PrintWriter​(String fileName,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
        使用指定的文件名和字符集创建一个新的PrintWriter，而不需要自动线路刷新。 这个方便的构造函数创建必要的中间件OutputStreamWriter ，它将使用提供的字符集对字符进行编码。
        参数
        fileName - 要用作此作者目的地的文件的名称。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        异常
        FileNotFoundException - 如果给定的字符串不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(fileName)否认对该文件的写入访问
        UnsupportedEncodingException - 如果不支持命名的字符集
        从以下版本开始：
        1.5

      • PrintWriter

        public PrintWriter​(File file)
            throws FileNotFoundException
        使用指定的文件创建一个新的PrintWriter，而不需要自动的线路刷新。 这个方便的构造函数创建必要的中间件OutputStreamWriter ，它将使用Java虚拟机的这个实例使用default charset对字符进行编码。
        参数
        file - 用作此作者目的地的文件。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(file.getPath())拒绝对该文件的写入权限
        从以下版本开始：
        1.5

      • PrintWriter

        public PrintWriter​(File file,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
        使用指定的文件和字符集创建一个新的PrintWriter，而不需要自动进行线条刷新。 这个方便的构造函数创建必要的中间件OutputStreamWriter ，它将使用提供的字符集对字符进行编码。
        参数
        file - 用作此作者目的地的文件。 如果文件存在，那么它将被截断为零大小; 否则，将创建一个新文件。 输出将被写入文件并进行缓冲。
        csn - 支持的名称charset
        异常
        FileNotFoundException - 如果给定的文件对象不表示现有的可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时出现其他错误
        SecurityException - 如果存在安全管理员，并且 checkWrite(file.getPath())拒绝对文件的写入访问
        UnsupportedEncodingException - 如果不支持命名的字符集
        从以下版本开始：
        1.5

    • 方法详细信息

      • flush

        public void flush​()
        刷新流。
        Specified by:
        flush在接口 Flushable
        Specified by:
        flush在 Writer
        另请参见：
        checkError()

      • close

        public void close​()
        关闭流并释放与之相关联的任何系统资源。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Writer
        另请参见：
        checkError()

      • checkError

        public boolean checkError​()
        如果流未关闭，请刷新流并检查其错误状态。
        结果
        true如果打印流在底层输出流或格式转换时遇到错误。

      • setError

        protected void setError​()
        表示发生错误。

        此方法将导致checkError()的后续调用返回true直到调用clearError() 。

      • clearError

        protected void clearError​()
        清除此流的错误状态。

        此方法将导致checkError()的后续调用返回false直到另一个写操作失败并调用setError() 。

        从以下版本开始：
        1.6

      • write

        public void write​(int c)
        写一个字符
        重写：
        write在 Writer
        参数
        c - int指定要写入的字符。

      • write

        public void write​(char[] buf,
                  int off,
                  int len)
        写一个字符数组的一部分。
        Specified by:
        write在 Writer
        参数
        buf - 字符数组
        off - 开始编写字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off和 len参数的值导致底层 Writer的相应方法抛出一个 IndexOutOfBoundsException

      • write

        public void write​(char[] buf)
        写入一个字符数组。 该方法不能继承Writer类，因为它必须抑制I / O异常。
        重写：
        write在 Writer
        参数
        buf - 要写入的字符数组

      • write

        public void write​(String s,
                  int off,
                  int len)
        写一个字符串的一部分。
        重写：
        write在 Writer
        参数
        s - 字符串
        off - 开始编写字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off和 len参数的值导致底层 Writer的相应方法抛出一个 IndexOutOfBoundsException

      • write

        public void write​(String s)
        写一个字符串 该方法不能继承Writer类，因为它必须抑制I / O异常。
        重写：
        write在类 Writer
        参数
        s - 要写入的字符串

      • print

        public void print​(boolean b)
        打印布尔值。 由String.valueOf(boolean)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)的方式写入。
        参数
        b - 要打印的 boolean

      • print

        public void print​(char c)
        打印一个字符 该字符根据平台的默认字符编码转换为一个或多个字节，这些字节的格式完全按照write(int)的方式编写。
        参数
        c - 要打印的 char

      • print

        public void print​(int i)
        打印一个整数。 由String.valueOf(int)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)的方式写入。
        参数
        i - 要打印的 int
        另请参见：
        Integer.toString(int)

      • print

        public void print​(long l)
        打印一个长整数。 由String.valueOf(long)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全以write(int)的方式写入。
        参数
        l - 要打印的 long
        另请参见：
        Long.toString(long)

      • print

        public void print​(float f)
        打印浮点数。 由String.valueOf(float)生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)方法编写。
        参数
        f - 要打印的 float
        另请参见：
        Float.toString(float)

      • print

        public void print​(double d)
        打印双精度浮点数。 由String.valueOf(double)生成的字符串根据平台的默认字符编码转换为字节，并且这些字节的格式完全按照write(int)的方式写入。
        参数
        d - 要打印的 double
        另请参见：
        Double.toString(double)

      • print

        public void print​(char[] s)
        打印字符数组。 字符根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)的方式写入。
        参数
        s - 要打印的字符数组
        异常
        NullPointerException - 如果 s是 null

      • print

        public void print​(String s)
        打印字符串。 如果参数为null则打印字符串"null" 。 否则，根据平台的默认字符编码将字符串的字符转换为字节，这些字节的格式完全按照write(int)的方式编写。
        参数
        s - 要打印的 String

      • print

        public void print​(Object obj)
        打印一个对象。 由String.valueOf(Object)方法生成的字符串根据平台的默认字符编码转换为字节，这些字节的格式完全按照write(int)的方式写入。
        参数
        obj - 要打印的 Object
        另请参见：
        Object.toString()

      • println

        public void println​()
        通过写入行分隔符字符串来终止当前行。 行分隔符字符串由系统属性line.separator定义，并不一定是单个换行符（ '\n' ）。

      • println

        public void println​(boolean x)
        打印一个布尔值，然后终止该行。 该方法的行为就像调用print(boolean)然后println()一样 。
        参数
        x - 要打印的 boolean值

      • println

        public void println​(char x)
        打印一个字符，然后终止该行。 该方法的行为就像调用print(char)然后println()一样 。
        参数
        x - 要打印的 char值

      • println

        public void println​(int x)
        打印一个整数，然后终止该行。 该方法的行为就像调用print(int)然后println()一样 。
        参数
        x - 要打印的 int值

      • println

        public void println​(long x)
        打印一个长整型，然后终止行。 该方法的行为就像调用print(long)然后println()一样 。
        参数
        x - 要打印的 long值

      • println

        public void println​(float x)
        打印一个浮点数，然后终止该行。 该方法的行为就像调用print(float)然后println()一样 。
        参数
        x - 要打印的 float值

      • println

        public void println​(double x)
        打印双精度浮点数，然后终止行。 该方法的行为就像调用print(double)然后println()一样 。
        参数
        x - 要打印的 double值

      • println

        public void println​(char[] x)
        打印字符数组，然后终止行。 该方法的行为就像调用print(char[])然后println()一样 。
        参数
        x - 要打印的 char数组的数组

      • println

        public void println​(String x)
        打印一个字符串，然后终止行。 该方法的行为就像调用print(String)然后println()一样 。
        参数
        x - 要打印的 String值

      • println

        public void println​(Object x)
        打印一个对象，然后终止该行。 该方法首先调用String.valueOf（x）来获取打印对象的字符串值，然后表现为它调用print(String)然后println() 。
        参数
        x - 要打印的 Object 。

      • printf

        public PrintWriter printf​(String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。 如果启用自动刷新，则调用此方法将刷新输出缓冲区。

        对这种形式out.printf(format, args)的方法的调用与调用的方式完全相同

           out.format(format, args)
        参数
        format -如在描述的格式字符串 Format string syntax 。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维数。 一个null参数的行为取决于conversion 。
        结果
        这位作家
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • printf

        public PrintWriter printf​(Locale l,
                          String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。 如果启用自动刷新，则调用此方法将刷新输出缓冲区。

        对这种out.printf(l, format, args)形式的方法的调用与调用的方式完全相同

           out.format(l, format, args)
        参数
        l - 在格式化期间应用的locale 。 如果l是null则不应用本地化。
        format -如在描述的格式字符串 Format string syntax 。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        这位作家
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • format

        public PrintWriter format​(String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此写入程序。 如果启用自动刷新，则调用此方法将刷新输出缓冲区。

        始终使用的区域设置是由Locale.getDefault()返回的区域 ，无论以前在此对象上调用其他格式化方法。

        参数
        format -如在描述的格式字符串 Format string syntax 。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        这位作家
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅Formatter类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • format

        public PrintWriter format​(Locale l,
                          String format,
                          Object... args)
        使用指定的格式字符串和参数将格式化的字符串写入此写入程序。 如果启用自动刷新，则调用此方法将刷新输出缓冲区。
        参数
        l - 格式化期间应用的locale 。 如果l是null则不应用定位。
        format -如在描述的格式字符串 Format string syntax 。
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        这位作家
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        NullPointerException - 如果 format是 null
        从以下版本开始：
        1.5

      • append

        public PrintWriter append​(CharSequence csq)
        将指定的字符序列附加到此作者。

        这种out.append(csq)形式的方法的调用与调用的方式完全相同

           out.write(csq.toString())

        取决于规范toString字符序列csq ，整个序列可以不追加。 例如，调用字符缓冲区的toString方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

        Specified by:
        append在接口 Appendable
        重写：
        append在 Writer
        参数
        csq - 要附加的字符序列。 如果csq为null ，则该"null"器附加四个字符"null" 。
        结果
        这位作家
        从以下版本开始：
        1.5

      • append

        public PrintWriter append​(CharSequence csq,
                          int start,
                          int end)
        将指定字符序列的子序列附加到此作者。

        形式的这种方法的调用out.append(csq, start, end)时csq不是null ，行为以完全相同的方式调用

           out.write(csq.subSequence(start, end).toString())
        Specified by:
        append在接口 Appendable
        重写：
        append在 Writer
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，那么字符将被追加，因为csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        这位作家
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，则 start大于 end ，或 end大于 csq.length()
        从以下版本开始：
        1.5

      • append

        public PrintWriter append​(char c)
        将指定的字符附加到此作者。

        对这种out.append(c)形式的方法的调用与调用的方式完全相同

           out.write(c)
        Specified by:
        append在接口 Appendable
        重写：
        append在 Writer
        参数
        c - 要追加的16位字符
        结果
        这位作家
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PushbackInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PushbackInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • java.io.PushbackInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class PushbackInputStream
extends FilterInputStream
    A PushbackInputStream通过将推回的字节存储在内部缓冲区中，将功能添加到另一个输入流，即“推回”或“未读”字节的功能。 这在代码片段方便读取由特定字节值分隔的无限数量的数据字节的情况下非常有用; 读取终止字节后，代码段可以“未读”，以便输入流上的下一个读操作将重新读取被推回的字节。 例如，表示构成标识符的字符的字节可以被表示操作符的字节终止; 一个只能读取一个标识符的工作方法可以读取，直到它看到操作者，然后将操作员推回以重新读取。
    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected byte[] buf
      推回缓冲区。
      protected int pos
      推回缓冲区中的位置，从该位置读取下一个字节。

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      构造方法
      Constructor 描述
      PushbackInputStream​(InputStream in)
      创建一个带有1字节后缓冲区的 PushbackInputStream ，并保存其参数，输入流 in供以后使用。
      PushbackInputStream​(InputStream in, int size)
      使用指定的 size的推回缓冲区创建一个 PushbackInputStream ，并保存其参数，输入流 in供以后使用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void mark​(int readlimit)
      标记此输入流中的当前位置。
      boolean markSupported​()
      测试这个输入流是否支持 mark和 reset方法，而不是。
      int read​()
      从该输入流读取下一个数据字节。
      int read​(byte[] b, int off, int len)
      从该输入流读取最多 len个字节的数据到字节数组。
      void reset​()
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      long skip​(long n)
      跳过并从该输入流中丢弃 n个字节的数据。
      void unread​(byte[] b)
      将一个字节数组复制回推回缓冲区的前端。
      void unread​(byte[] b, int off, int len)
      通过将字节数组复制到推回缓冲区的前端来推回一部分数组。
      void unread​(int b)
      通过将其复制到推回缓冲区的前端来推回一个字节。

      • Methods inherited from class java.io.FilterInputStream

        read

      • Methods inherited from class java.io.InputStream

        readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • buf

        protected byte[] buf
        推回缓冲区。
        从以下版本开始：
        1.1

      • pos

        protected int pos
        推回缓冲区中的位置，从该位置读取下一个字节。 当缓冲区为空时， pos等于buf.length ; 当缓冲区满时， pos等于零。
        从以下版本开始：
        1.1

    • 构造方法详细信息

      • PushbackInputStream

        public PushbackInputStream​(InputStream in,
                           int size)
        使用指定的size的推回缓冲区创建一个PushbackInputStream ，并保存其参数，输入流in供以后使用。 最初，推回缓冲区为空。
        参数
        in - 读取字节的输入流。
        size - 推回缓冲区的大小。
        异常
        IllegalArgumentException - 如果是 size <= 0
        从以下版本开始：
        1.1

      • PushbackInputStream

        public PushbackInputStream​(InputStream in)
        创建一个PushbackInputStream与1字节的推回缓冲区，并保存其参数，输入流in供以后使用。 最初，推回缓冲区为空。
        参数
        in - 读取字节的输入流。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        从该输入流读取下一个数据字节。 值字节返回int 0到255 。 如果没有字节可用，因为已达到流的末尾，则返回值-1 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。

        该方法返回最近推送的字节（如果有的话），否则调用其底层输入流的read方法，并返回该方法返回的任何值。

        重写：
        read在 FilterInputStream
        结果
        数据的下一个字节，如果已经达到流的末尾， -1 。
        异常
        IOException - 如果此输入流已通过调用其 close()方法关闭，或发生I / O错误。
        另请参见：
        InputStream.read()

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从该输入流读取最多len个字节的数据到字节数组。 该方法首先读取任何推回的字节; 之后，如果读取少于len个字节，则从底层输入流读取。 如果len不为零，该方法将阻塞，直到输入的至少1个字节可用; 否则，不会读取字节，并返回0 。
        重写：
        read中的 FilterInputStream
        参数
        b - 读取数据的缓冲区。
        off - 目标阵列中的起始偏移量 b
        len - 读取的最大字节数。
        结果
        读取到缓冲区的总字节数，如果没有更多的数据，因为已经到达流的末尾，那么 -1 。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负，则 len为负数，或 len大于 b.length - off
        IOException - 如果此输入流已通过调用其 close()方法关闭，或发生I / O错误。
        另请参见：
        InputStream.read(byte[], int, int)

      • unread

        public void unread​(int b)
            throws IOException
        通过将其复制到推回缓冲区的前端来推回一个字节。 此方法返回后，要读取的下一个字节将具有值(byte)b 。
        参数
        b - int低位字节推回的值为 int 。
        异常
        IOException - 如果该缓冲区中没有足够的空间用于该字节，或者该输入流已通过调用其 close()方法而关闭。

      • unread

        public void unread​(byte[] b,
                   int off,
                   int len)
            throws IOException
        通过将字节数组复制到推回缓冲区的前端来推回一部分数组。 此方法返回后，要读取的下一个字节将具有值b[off] ，之后的字节将具有值b[off+1]等等。
        参数
        b - 要推回的字节数组。
        off - 数据的起始偏移量。
        len - 要推回的字节数。
        异常
        IOException - 如果在 IOException缓冲区中没有足够的空间用于指定的字节数，或者该输入流已通过调用其 close()方法而关闭。
        从以下版本开始：
        1.1

      • unread

        public void unread​(byte[] b)
            throws IOException
        将一个字节数组复制回推回缓冲区的前端。 此方法返回后，要读取的下一个字节将具有值b[0] ，之后的字节将具有值b[1]等等。
        参数
        b - 要推回的字节数组
        异常
        IOException - 如果 IOException缓冲区中没有足够的空间用于指定的字节数，或者通过调用其 close()方法已关闭此输入流。
        从以下版本开始：
        1.1

      • available

        public int available​()
              throws IOException
        从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。 下一个调用可能是同一个线程或另一个线程。 这个多个字节的单个读取或跳过将不会被阻塞，但可以读取或跳过较少的字节。

        该方法返回被推回的字节数和由available返回的值的总和 。

        重写：
        available类 FilterInputStream
        结果
        可以从输入流中读取（或跳过）而不阻塞的字节数。
        异常
        IOException - 如果此输入流已通过调用其 close()方法关闭，或发生I / O错误。
        另请参见：
        FilterInputStream.in ， InputStream.available()

      • skip

        public long skip​(long n)
          throws IOException
        跳过并从该输入流中丢弃n个字节的数据。 由于各种原因， skip方法可能会跳过某些较小数量的字节，可能为零。 如果n为负，则不跳过任何字节。

        该skip方法的PushbackInputStream超过在推回缓冲区中的字节第一跳过，如果有的话。 然后，如果需要跳过更多字节，它将调用底层输入流的skip方法。 返回实际跳过的字节数。

        重写：
        skip在 FilterInputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果流已通过调用其 close()方法关闭，则 in.skip(n)抛出IOException或发生I / O错误。
        从以下版本开始：
        1.2
        另请参见：
        FilterInputStream.in ， InputStream.skip(long n)

      • markSupported

        public boolean markSupported​()
        测试这个输入流是否支持 mark和 reset方法，而不是。
        重写：
        markSupported在 FilterInputStream
        结果
        false ，因为这个类不支持 mark和 reset方法。
        另请参见：
        InputStream.mark(int) ， InputStream.reset()

      • mark

        public void mark​(int readlimit)
        标记此输入流中的当前位置。

        mark方法PushbackInputStream也没做。

        重写：
        mark在 FilterInputStream
        参数
        readlimit - 标记位置无效之前可以读取的最大字节数限制。
        另请参见：
        InputStream.reset()

      • reset

        public void reset​()
           throws IOException
        将此流重新定位到最后在此输入流上调用mark方法时的位置。

        该方法reset类PushbackInputStream什么也不做只是抛出一个IOException 。

        重写：
        reset在 FilterInputStream
        异常
        IOException - 如果调用此方法。
        另请参见：
        InputStream.mark(int) ， IOException

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。 一旦流已关闭，进一步的read（），unread（），available（），reset（）或skip（）调用将抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterInputStream
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FilterInputStream.in
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PushbackReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class PushbackReader

  • java.lang.Object
    • java.io.Reader
      • java.io.FilterReader
        • java.io.PushbackReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable

    public class PushbackReader
extends FilterReader
    一个字符流读取器，允许将字符推回到流中。
    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from class java.io.FilterReader

        in

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      PushbackReader​(Reader in)
      用一个字符的后置缓冲区创建一个新的推回阅读器。
      PushbackReader​(Reader in, int size)
      使用给定大小的推回缓冲区创建一个新的推回阅读器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流并释放与之相关联的任何系统资源。
      void mark​(int readAheadLimit)
      标记流中的当前位置。
      boolean markSupported​()
      告诉这个流是否支持mark（）操作，它不是。
      int read​()
      读一个字符
      int read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      boolean ready​()
      告诉这个流是否准备好被读取。
      void reset​()
      重置流。
      long skip​(long n)
      跳过字符
      void unread​(char[] cbuf)
      将一个字符数组复制回推回缓冲区的前端。
      void unread​(char[] cbuf, int off, int len)
      通过将一部分字符复制到推回缓冲区的前端来推回。
      void unread​(int c)
      将单个字符复制回推回缓冲区的前端。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        read, read

    • 构造方法详细信息

      • PushbackReader

        public PushbackReader​(Reader in,
                      int size)
        使用给定大小的推回缓冲区创建一个新的推回阅读器。
        参数
        in - 从哪个角色读取的读者
        size - 推回缓冲区的大小
        异常
        IllegalArgumentException - 如果是 size <= 0

      • PushbackReader

        public PushbackReader​(Reader in)
        用一个字符的后置缓冲区创建一个新的推回阅读器。
        参数
        in - 从哪个角色读取的读者

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        读一个字符
        重写：
        read在 FilterReader
        结果
        字符读取，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] cbuf,
                int off,
                int len)
         throws IOException
        将字符读入数组的一部分。
        重写：
        read在 FilterReader
        参数
        cbuf - 目标缓冲区
        off - 开始编写字符的偏移量
        len - 要读取的最大字符数
        结果
        读取的字符数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果发生I / O错误

      • unread

        public void unread​(int c)
            throws IOException
        将单个字符复制回推回缓冲区的前端。 此方法返回后，要读取的下一个字符将具有值(char)c 。
        参数
        c - 表示要推回的字符的int值
        异常
        IOException - 如果推回缓冲区已满，或者发生其他I / O错误

      • unread

        public void unread​(char[] cbuf,
                   int off,
                   int len)
            throws IOException
        通过将一部分字符复制到推回缓冲区的前端来推回。 此方法返回后，要读取的下一个字符将具有值cbuf[off] ，之后的字符将具有值cbuf[off+1]等等。
        参数
        cbuf - 字符数组
        off - 要推回的第一个字符的偏移量
        len - 要推回的字符数
        异常
        IOException - 如果推回缓冲区中没有足够的空间，或者发生其他I / O错误

      • unread

        public void unread​(char[] cbuf)
            throws IOException
        将一个字符数组复制回推回缓冲区的前端。 此方法返回后，要读取的下一个字符将具有值cbuf[0] ，之后的字符将具有值cbuf[1]等等。
        参数
        cbuf - 要推回的字符数组
        异常
        IOException - 如果推回缓冲区中没有足够的空间，或者发生其他I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好被读取。
        重写：
        ready在 FilterReader
        结果
        如果下一个read（）保证不阻止输入，则为True，否则为false。 请注意，返回false并不能保证下一次读取将被阻止。
        异常
        IOException - 如果发生I / O错误

      • mark

        public void mark​(int readAheadLimit)
          throws IOException
        标记流中的当前位置。 mark的PushbackReader总是抛出异常。
        重写：
        mark在 FilterReader
        参数
        readAheadLimit - 限制仍然保留标记时可能读取的字符数。 读了这么多字符后，尝试重置流可能会失败。
        异常
        IOException - 始终，因为不支持标记

      • reset

        public void reset​()
           throws IOException
        重置流。 该reset的方法PushbackReader总是抛出异常。
        重写：
        reset在 FilterReader
        异常
        IOException - 始终，因为不支持重置

      • markSupported

        public boolean markSupported​()
        告诉这个流是否支持mark（）操作，它不是。
        重写：
        markSupported在 FilterReader
        结果
        当且仅当此流支持标记操作时才为真。

      • close

        public void close​()
           throws IOException
        关闭流并释放与之相关联的任何系统资源。 一旦流已关闭，进一步的read（），unread（），ready（）或skip（）调用将抛出IOException。 关闭以前关闭的流无效。 当读取器上有另一个线程阻塞时，此方法将阻止。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 FilterReader
        异常
        IOException - 如果发生I / O错误

      • skip

        public long skip​(long n)
          throws IOException
        跳过字符 该方法将阻塞，直到某些字符可用，发生I / O错误或达到流的结尾。
        重写：
        skip在 FilterReader
        参数
        n - 要跳过的字符数
        结果
        实际跳过的字符数
        异常
        IllegalArgumentException - 如果 n为负数。
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RandomAccessFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class RandomAccessFile

  • java.lang.Object
    • java.io.RandomAccessFile
  • All Implemented Interfaces:
    Closeable ， DataInput ， DataOutput ， AutoCloseable

    public class RandomAccessFile
extends Object
implements DataOutput, DataInput, Closeable
    该类的实例支持读取和写入随机访问文件。 随机访问文件的行为类似于存储在文件系统中的大量字节。 有一种游标，或索引到隐含的数组，称为文件指针 ; 输入操作读取从文件指针开始的字节，并使文件指针超过读取的字节。 如果在读/写模式下创建随机访问文件，则输出操作也可用; 输出操作从文件指针开始写入字节，并将文件指针提前到写入的字节。 写入隐式数组的当前端的输出操作会导致扩展数组。 文件指针可以通过读取getFilePointer方法和由设置seek方法。

    这个类中的所有读取例程通常是这样的，如果在读取所需的字节数之前到达文件结尾，则抛出一个EOFException （这是一种IOException ）。 如果任何字节由于除文件末尾之外的任何原因而无法读取，则抛出IOException以外的EOFException 。 特别地，如果流已经关闭，则可以抛出IOException 。

    从以下版本开始：
    1.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      RandomAccessFile​(File file, String mode)
      创建一个随机访问文件流，从File参数指定的文件读取，并可选地写入。
      RandomAccessFile​(String name, String mode)
      创建随机访问文件流，以从中指定名称的文件读取，并可选择写入文件。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭此随机访问文件流并释放与流相关联的任何系统资源。
      FileChannel getChannel​()
      返回与此文件关联的唯一的FileChannel对象。
      FileDescriptor getFD​()
      返回与此流关联的不透明文件描述符对象。
      long getFilePointer​()
      返回此文件中的当前偏移量。
      long length​()
      返回此文件的长度。
      int read​()
      从该文件读取一个字节的数据。
      int read​(byte[] b)
      从该文件读取最多 b.length个字节的数据到一个字节数组。
      int read​(byte[] b, int off, int len)
      从该文件读取最多 len个字节的数据为字节数组。
      boolean readBoolean​()
      从此文件读取一个 boolean 。
      byte readByte​()
      从此文件中读取一个带符号的八位值。
      char readChar​()
      从此文件中读取一个字符。
      double readDouble​()
      从此文件读取一个 double 。
      float readFloat​()
      从这个文件读取一个 float 。
      void readFully​(byte[] b)
      从该文件读取 b.length个字节到字节数组，从当前文件指针开始。
      void readFully​(byte[] b, int off, int len)
      从该文件读取完全 len个字节到字节数组，从当前文件指针开始。
      int readInt​()
      从该文件读取一个带符号的32位整数。
      String readLine​()
      从此文件中读取下一行文本。
      long readLong​()
      从该文件中读取一个带符号的64位整数。
      short readShort​()
      从此文件中读取一个已签名的16位数字。
      int readUnsignedByte​()
      从此文件中读取一个无符号的八位数字。
      int readUnsignedShort​()
      从该文件中读取一个无符号的16位数字。
      String readUTF​()
      从该文件读取字符串。
      void seek​(long pos)
      设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。
      void setLength​(long newLength)
      设置此文件的长度。
      int skipBytes​(int n)
      尝试跳过超过 n个字节的输入丢弃跳过的字节。
      void write​(byte[] b)
      从指定的字节数组写入 b.length个字节到该文件，从当前文件指针开始。
      void write​(byte[] b, int off, int len)
      从指定的字节数组写入 len个字节，从偏移量 off开始写入此文件。
      void write​(int b)
      将指定的字节写入此文件。
      void writeBoolean​(boolean v)
      将 boolean写入文件作为一个字节值。
      void writeByte​(int v)
      将 byte写入文件作为一个字节的值。
      void writeBytes​(String s)
      将字符串作为字节序列写入文件。
      void writeChar​(int v)
      写入一个 char作为一个双字节的值，高字节的第一个文件。
      void writeChars​(String s)
      将一个字符串作为字符序列写入文件。
      void writeDouble​(double v)
      使用 long中的 doubleToLongBits方法将双参数转换为 Double ，然后 long值作为八字节数量，高字节优先写入该文件。
      void writeFloat​(float v)
      使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后 int值作为四字节数量（高字节优先）写入文件。
      void writeInt​(int v)
      将 int写入文件为四个字节，高字节为首。
      void writeLong​(long v)
      将 long写入文件为8个字节，高字节为第一个字节。
      void writeShort​(int v)
      将 short写入文件作为两个字节，高字节优先。
      void writeUTF​(String str)
      使用机器无关的方式使用 modified UTF-8编码将字符串写入文件。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RandomAccessFile

        public RandomAccessFile​(String name,
                        String mode)
                 throws FileNotFoundException
        创建随机访问文件流，以从中指定名称的文件读取，并可选择写入文件。 创建一个新的FileDescriptor对象来表示与文件的连接。

        mode参数指定要打开文件的访问模式。 允许的值及其含义符合RandomAccessFile(File,String)构造函数的规定。

        如果有一个安全管理器，它的checkRead方法是以name参数作为参数来调用，以查看是否允许对该文件的读访问。 如果模式允许写入，则还将调用安全管理器的checkWrite方法，其参数为name ，以查看是否允许对该文件的写访问。

        参数
        name - 与系统相关的文件名
        mode - 访问 mode
        异常
        IllegalArgumentException -如果模式参数不等于之一 "r" ， "rw" ， "rws" ，或 "rwd"
        FileNotFoundException - 如果模式是 "r"但给定的字符串不表示现有的常规文件，或者如果模式以 "rw"开头，但给定的字符串不表示现有的可写的常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时出现其他错误
        SecurityException - 如果存在安全管理员，并且其 checkRead方法拒绝对该文件的读访问，或者该模式是 "rw" ，并且安全管理器的 checkWrite方法拒绝对文件的写访问
        另请参见：
        SecurityException ， SecurityManager.checkRead(java.lang.String) ， SecurityManager.checkWrite(java.lang.String)

      • RandomAccessFile

        public RandomAccessFile​(File file,
                        String mode)
                 throws FileNotFoundException
        创建一个随机访问文件流，从File参数指定的文件中读取，并可选择写入。 将创建一个新的FileDescriptor对象来表示此文件连接。

        mode参数指定要打开文件的访问模式。 允许的值及其含义是：

        Access mode permitted values and meanings Value Meaning "r" Open for reading only. Invoking any of the write methods of the resulting object will cause an IOException to be thrown. "rw" Open for reading and writing. If the file does not already exist then an attempt will be made to create it. "rws" Open for reading and writing, as with "rw", and also require that every update to the file's content or metadata be written synchronously to the underlying storage device. "rwd" Open for reading and writing, as with "rw", and also require that every update to the file's content be written synchronously to the underlying storage device.
        "rws"和"rwd"模式的工作方式类似于FileChannel类的force(boolean)方法，分别传递了true和false参数，但它们总是适用于每个I / O操作，因此通常更有效。 如果文件驻留在本地存储设备上，则当该类的方法的调用返回时，将保证通过该调用对文件所做的所有更改都将被写入该设备。 这对于确保系统崩溃时不会丢失关键信息非常有用。 如果文件不在本地设备上，则不会提供此类保证。

        可以使用"rwd"模式来减少执行的I / O操作的数量。 使用"rwd"只需要更新要写入存储的文件内容; 使用"rws"需要更新要写入的文件的内容及其元数据，通常需要至少一个低级I / O操作。

        如果有一个安全管理器，它的checkRead方法被调用，路径名为file参数作为参数，以查看是否允许对该文件的读取访问。 如果模式允许写入，则还使用path参数调用安全管理器的checkWrite方法，以查看是否允许对该文件的写访问。

        参数
        file - 文件对象
        mode - 访问模式，如 above所述
        异常
        IllegalArgumentException -如果模式参数不等于之一 "r" ， "rw" ， "rws" ，或 "rwd"
        FileNotFoundException - 如果模式是 "r"但给定的文件对象不表示现有的常规文件，或者如果模式以 "rw"开头，但给定的文件对象不表示现有的可写常规文件，并且该名称的新常规文件不能或者在打开或创建文件时发生其他错误
        SecurityException - 如果存在安全管理员，并且其 checkRead方法拒绝对该文件的读取访问，或者该模式为 "rw" ，并且安全管理器的 checkWrite方法拒绝对文件的写入访问
        另请参见：
        SecurityManager.checkRead(java.lang.String) ，
SecurityManager.checkWrite(java.lang.String) ，
FileChannel.force(boolean)

    • 方法详细信息

      • getFD

        public final FileDescriptor getFD​()
                           throws IOException
        返回与此流关联的不透明文件描述符对象。
        结果
        与此流关联的文件描述符对象。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        FileDescriptor

      • getChannel

        public final FileChannel getChannel​()
        返回与此文件关联的唯一的FileChannel对象。

        返回的通道的position将始终等于该对象的文件指针偏移量，由getFilePointer方法返回。 改变此对象的文件指针偏移量，无论是显式地还是通过读取或写入字节，都会改变通道的位置，反之亦然。 通过该对象更改文件的长度将改变通过文件通道看到的长度，反之亦然。

        结果
        与此文件关联的文件通道
        从以下版本开始：
        1.4

      • read

        public int read​()
         throws IOException
        从该文件读取一个字节的数据。 该字节以0到255（ 0x00-0x0ff ）范围内的整数返回。 如果没有输入可用，此方法将阻止。

        尽管RandomAccessFile不是RandomAccessFile的子类， InputStream该方法的行为方式与InputStream的InputStream.read()方法InputStream 。

        结果
        数据的下一个字节，如果文件的结尾已经到达， -1 。
        异常
        IOException - 如果发生I / O错误。 如果达到文件结尾，则不会抛出。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从该文件读取最多len个字节的数据为字节数组。 该方法阻塞，直到输入的至少一个字节可用。

        虽然RandomAccessFile不是RandomAccessFile的子类， InputStream该方法的行为方式与InputStream的InputStream.read(byte[], int, int)方法InputStream 。

        参数
        b - 读取数据的缓冲区。
        off - 写入数据的数组 b中的起始偏移量。
        len - 读取的最大字节数。
        结果
        读入缓冲区的总字节数，如果没有更多的数据，因为文件的结尾已经到达， -1 。
        异常
        IOException - 如果第一个字节由于除文件结尾之外的任何原因或随机访问文件已关闭或发生其他I / O错误而无法读取。
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负数， len为负数，或 len大于 b.length - off

      • read

        public int read​(byte[] b)
         throws IOException
        从该文件读取最多b.length个字节的数据到字节数组。 该方法阻塞，直到输入的至少一个字节可用。

        虽然RandomAccessFile不是RandomAccessFile的子类， InputStream该方法的行为与InputStream的InputStream.read(byte[])方法InputStream 。

        参数
        b - 读取数据的缓冲区。
        结果
        读取到缓冲区中的总字节数，或 -1如果没有更多的数据，因为该文件的结尾已经到达。
        异常
        IOException - 如果第一个字节由于除文件结尾之外的任何原因或随机访问文件已关闭或发生其他I / O错误而无法读取。
        NullPointerException - 如果 b是 null 。

      • readFully

        public final void readFully​(byte[] b)
                     throws IOException
        从该文件读取b.length个字节到字节数组，从当前文件指针开始。 该方法从文件中重复读取，直到读取所请求的字节数。 该方法阻塞，直到读取所请求的字节数，检测到流的结尾，或抛出异常。
        Specified by:
        readFully在接口 DataInput
        参数
        b - 读取数据的缓冲区。
        异常
        NullPointerException - 如果 b是 null 。
        EOFException - 如果此文件在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFully

        public final void readFully​(byte[] b,
                            int off,
                            int len)
                     throws IOException
        从当前文件指针开始，从该文件读取完整的len个字节到字节数组中。 该方法从文件中重复读取，直到读取所请求的字节数。 该方法阻塞，直到读取所请求的字节数，检测到流的结尾，或抛出异常。
        Specified by:
        readFully在接口 DataInput
        参数
        b - 读取数据的缓冲区。
        off - 数据阵列 b的起始偏移量。
        len - 要读取的字节数。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负，则 len为负数，或 len大于 b.length - off 。
        EOFException - 如果此文件在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。

      • skipBytes

        public int skipBytes​(int n)
              throws IOException
        尝试跳过n字节的输入丢弃跳过的字节。

        该方法可能跳过一些较小数量的字节，可能为零。 这可能是由许多条件中的任何一个引起的 在n字节之前已经跳过的文件到达结束只有一种可能。 这种方法永远不会抛出一个EOFException 。 返回实际跳过的字节数。 如果n为负，则不跳过任何字节。

        Specified by:
        skipBytes在接口 DataInput
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(int b)
           throws IOException
        将指定的字节写入此文件。 写入从当前文件指针开始。
        Specified by:
        write在接口 DataOutput
        参数
        b - byte 。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b)
           throws IOException
        从指定的字节数组写入 b.length个字节到该文件，从当前文件指针开始。
        Specified by:
        write在接口 DataOutput
        参数
        b - 数据。
        异常
        IOException - 如果发生I / O错误。

      • write

        public void write​(byte[] b,
                  int off,
                  int len)
           throws IOException
        从指定的字节数组写入 len字节，从偏移量 off开始写入该文件。
        Specified by:
        write在接口 DataOutput
        参数
        b - 数据。
        off - 数据中的起始偏移量。
        len - 要写入的字节数。
        异常
        IOException - 如果发生I / O错误。

      • getFilePointer

        public long getFilePointer​()
                    throws IOException
        返回此文件中的当前偏移量。
        结果
        从文件开头的偏移量（以字节为单位），下一次读取或写入发生。
        异常
        IOException - 如果发生I / O错误。

      • seek

        public void seek​(long pos)
          throws IOException
        设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。 偏移可以设置为超出文件的末尾。 设置超出文件末尾的偏移量不会更改文件长度。 文件长度只有在偏移设置超出文件结尾之后才会通过写入进行更改。
        参数
        pos - 从文件开始测量的偏移位置，用于设置文件指针。
        异常
        IOException - 如果 pos小于 0或发生I / O错误。

      • length

        public long length​()
            throws IOException
        返回此文件的长度。
        结果
        该文件的长度，以字节为单位。
        异常
        IOException - 如果发生I / O错误。

      • setLength

        public void setLength​(long newLength)
               throws IOException
        设置此文件的长度。

        如果length方法返回的文件的当前长度大于newLength参数，则该文件将被截断。 在这种情况下，如果由getFilePointer方法返回的文件偏移量大于newLength则此方法返回后的偏移量将等于newLength 。

        如果length方法返回的文件的当前长度小于newLength参数，则文件将被扩展。 在这种情况下，文件的扩展部分的内容未定义。

        参数
        newLength - 文件所需的长度
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.2

      • close

        public void close​()
           throws IOException
        关闭此随机访问文件流并释放与流相关联的任何系统资源。 封闭的随机存取文件无法执行输入或输出操作，无法重新打开。

        如果此文件具有关联的通道，则通道也将关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误。

      • readBoolean

        public final boolean readBoolean​()
                          throws IOException
        从此文件读取一个boolean 。 该方法从文件中读取单个字节，从当前文件指针开始。 值0代表false 。 任何其他值代表true 。 该方法阻塞直到字节被读取，流的结束被检测到或抛出异常。
        Specified by:
        readBoolean在接口 DataInput
        结果
        boolean值读取。
        异常
        EOFException - 如果此文件已到达结束。
        IOException - 如果发生I / O错误。

      • readByte

        public final byte readByte​()
                    throws IOException
        从此文件中读取一个带符号的八位值。 该方法从当前文件指针开始从文件读取一个字节。 如果读取的字节是b ，其中0 <= b <= 255 ，那么结果是：
             (byte)(b)

        该方法阻塞直到字节被读取，流的结束被检测到或抛出异常。

        Specified by:
        readByte在接口 DataInput
        结果
        该文件的下一个字节为有符号的8位 byte 。
        异常
        EOFException - 如果此文件已到达结束。
        IOException - 如果发生I / O错误。

      • readUnsignedByte

        public final int readUnsignedByte​()
                           throws IOException
        从此文件中读取一个无符号的八位数字。 此方法从该文件读取一个字节，从当前文件指针开始，并返回该字节。

        该方法阻塞直到字节被读取，流的结束被检测到或抛出异常。

        Specified by:
        readUnsignedByte在接口 DataInput
        结果
        该文件的下一个字节被解释为无符号的8位数字。
        异常
        EOFException - 如果此文件已到达结束。
        IOException - 如果发生I / O错误。

      • readShort

        public final short readShort​()
                      throws IOException
        从此文件中读取一个已签名的16位数字。 该方法从该文件读取两个字节，从当前文件指针开始。 如果按顺序读取的两个字节是b1和b2 ，其中两个值中的每一个都在0和255之间，其中的结果等于：
             (short)((b1 << 8) | b2)

        此方法将阻塞，直到读取两个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readShort在接口 DataInput
        结果
        该文件的下两个字节被解释为一个有符号的16位数字。
        异常
        EOFException - 如果此文件在读取两个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readUnsignedShort

        public final int readUnsignedShort​()
                            throws IOException
        从该文件中读取一个无符号的16位数字。 该方法从文件中读取两个字节，从当前文件指针开始。 如果读取的字节顺序为b1和b2 ，其中0 <= b1, b2 <= 255 ，则结果等于：
             (b1 << 8) | b2

        此方法将阻塞，直到读取两个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readUnsignedShort在接口 DataInput
        结果
        该文件的下两个字节被解释为无符号16位整数。
        异常
        EOFException - 如果此文件在读取两个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readChar

        public final char readChar​()
                    throws IOException
        从此文件中读取一个字符。 该方法从文件中读取两个字节，从当前文件指针开始。 如果读取的字节顺序为b1和b2 ，其中0 <= b1, b2 <= 255 ，则结果等于：
             (char)((b1 << 8) | b2)

        此方法将阻塞，直到读取两个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readChar在接口 DataInput
        结果
        该文件的下两个字节，解释为 char 。
        异常
        EOFException - 如果此文件在读取两个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readInt

        public final int readInt​()
                  throws IOException
        从该文件读取一个带符号的32位整数。 该方法从当前文件指针开始从文件读取4个字节。 如果读取的字节依次是b1 ， b2 ， b3 ，和b4 ，其中0 <= b1, b2, b3, b4 <= 255 ，则结果等于：
             (b1 << 24) | (b2 << 16) + (b3 << 8) + b4

        该方法阻塞，直到读取四个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readInt在接口 DataInput
        结果
        该文件的下四个字节，解释为 int 。
        异常
        EOFException - 如果此文件在读取四个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readLong

        public final long readLong​()
                    throws IOException
        从该文件中读取一个带符号的64位整数。 该方法从文件中读取八个字节，从当前文件指针开始。 如果读取的字节依次是b1 ， b2 ， b3 ， b4 ， b5 ， b6 ， b7 ，并b8,其中：
             0 <= b1, b2, b3, b4, b5, b6, b7, b8 <=255,

        那么结果等于：

             ((long)b1 << 56) + ((long)b2 << 48)
     + ((long)b3 << 40) + ((long)b4 << 32)
     + ((long)b5 << 24) + ((long)b6 << 16)
     + ((long)b7 << 8) + b8

        该方法阻塞，直到读取8个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readLong在接口 DataInput
        结果
        该文件的接下来的八个字节，解释为 long 。
        异常
        EOFException - 如果此文件在读取八个字节之前到达结束。
        IOException - 如果发生I / O错误。

      • readFloat

        public final float readFloat​()
                      throws IOException
        从此文件读取float 。 此方法读取一个int值，并从当前文件指针，就好像由readInt方法，然后转换该int为float使用intBitsToFloat在类方法Float 。

        该方法阻塞，直到读取四个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readFloat在接口 DataInput
        结果
        该文件的下四个字节，解释为 float 。
        异常
        EOFException - 如果此文件在读取四个字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        readInt() ， Float.intBitsToFloat(int)

      • readDouble

        public final double readDouble​()
                        throws IOException
        从此文件读取一个double 。 此方法读取一个long值，并从当前文件指针，就好像由readLong方法，然后转换该long为double使用longBitsToDouble在类方法Double 。

        该方法阻塞，直到读取8个字节，检测到流的结尾，或抛出异常。

        Specified by:
        readDouble在接口 DataInput
        结果
        该文件的接下来的八个字节，解释为 double 。
        异常
        EOFException - 如果此文件在读取八个字节之前到达结束。
        IOException - 如果发生I / O错误。
        另请参见：
        readLong() ， Double.longBitsToDouble(long)

      • readLine

        public final String readLine​()
                      throws IOException
        从此文件中读取下一行文本。 该方法从文件开始依次读取字节，从当前文件指针开始，直到到达行终止符或文件末尾。 通过将字符的低8位的字节值设置为零，将字符的高8位设置为零，将每个字节转换为字符。 因此，此方法不支持完整的Unicode字符集。

        一行文本由回车字符（ '\r' ），换行符（ '\n' ），紧跟换行符的回车字符或文件结尾终止。 行终止字符被丢弃，不包括返回的字符串的一部分。

        该方法阻塞，直到读取换行字符，回车并读取其后的字节（以查看它是否为换行符），到达文件的结尾或抛出异常。

        Specified by:
        readLine在接口 DataInput
        结果
        该文件的下一行文本，如果在读取一个字节之前遇到文件结尾，则返回null。
        异常
        IOException - 如果发生I / O错误。

      • readUTF

        public final String readUTF​()
                     throws IOException
        从该文件读取字符串。 该字符串已使用modified UTF-8格式编码。

        从当前文件指针开始读取前两个字节，如readUnsignedShort 。 该值给出编码字符串中的以下字节数，而不是生成字符串的长度。 然后，以下字节将被解释为以修改的UTF-8格式编码字符的字节，并将其转换为字符。

        该方法阻塞，直到读取所有字节，检测到流的结尾，或抛出异常。

        Specified by:
        readUTF在接口 DataInput
        结果
        一个Unicode字符串。
        异常
        EOFException - 如果此文件在读取所有字节之前到达结束。
        IOException - 如果发生I / O错误。
        UTFDataFormatException - 如果字节不表示Unicode字符串的有效修改的UTF-8编码。
        另请参见：
        readUnsignedShort()

      • writeBoolean

        public final void writeBoolean​(boolean v)
                        throws IOException
        将boolean写入文件作为一个字节的值。 值true写为值(byte)1 ; 值false写出为值(byte)0 。 写入从文件指针的当前位置开始。
        Specified by:
        writeBoolean在接口 DataOutput
        参数
        v - 要写入的 boolean值。
        异常
        IOException - 如果发生I / O错误。

      • writeByte

        public final void writeByte​(int v)
                     throws IOException
        将byte写入文件作为一个字节值。 写入从文件指针的当前位置开始。
        Specified by:
        writeByte在接口 DataOutput
        参数
        v - 要写入的 byte值。
        异常
        IOException - 如果发生I / O错误。

      • writeShort

        public final void writeShort​(int v)
                      throws IOException
        将short写入文件作为两个字节，高字节优先。 写入从文件指针的当前位置开始。
        Specified by:
        writeShort在接口 DataOutput
        参数
        v - short 。
        异常
        IOException - 如果发生I / O错误。

      • writeChar

        public final void writeChar​(int v)
                     throws IOException
        将char写入文件作为双字节值，高位字节。 写入从文件指针的当前位置开始。
        Specified by:
        writeChar在接口 DataOutput
        参数
        v - 要写入的 char值。
        异常
        IOException - 如果发生I / O错误。

      • writeInt

        public final void writeInt​(int v)
                    throws IOException
        向文件写入一个int作为四字节，高字节优先。 写入从文件指针的当前位置开始。
        Specified by:
        writeInt在接口 DataOutput
        参数
        v - int 。
        异常
        IOException - 如果发生I / O错误。

      • writeLong

        public final void writeLong​(long v)
                     throws IOException
        向文件写入一个long为八字节，高字节为首。 写入从文件指针的当前位置开始。
        Specified by:
        writeLong在接口 DataOutput
        参数
        v - a long待写。
        异常
        IOException - 如果发生I / O错误。

      • writeFloat

        public final void writeFloat​(float v)
                      throws IOException
        使用int中的floatToIntBits方法将float参数转换为Float ，然后int值作为四字节数量，高字节优先写入文件。 写入从文件指针的当前位置开始。
        Specified by:
        writeFloat在接口 DataOutput
        参数
        v - 要写入的 float值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        Float.floatToIntBits(float)

      • writeDouble

        public final void writeDouble​(double v)
                       throws IOException
        使用long中的doubleToLongBits方法将双参数转换为Double ，然后long值作为八字节数量（高字节）写入文件。 写入从文件指针的当前位置开始。
        Specified by:
        writeDouble在接口 DataOutput
        参数
        v - 一个要写入的 double值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        Double.doubleToLongBits(double)

      • writeBytes

        public final void writeBytes​(String s)
                      throws IOException
        将字符串作为字节序列写入文件。 字符串中的每个字符顺序地通过丢弃其高8位来写出。 写入从文件指针的当前位置开始。
        Specified by:
        writeBytes在接口 DataOutput
        参数
        s - 要写入的字节串。
        异常
        IOException - 如果发生I / O错误。

      • writeChars

        public final void writeChars​(String s)
                      throws IOException
        将一个字符串作为字符序列写入文件。 每个字符都被写入数据输出流，就好像通过writeChar方法。 写入从文件指针的当前位置开始。
        Specified by:
        writeChars在接口 DataOutput
        参数
        s - 要写入的 String值。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        writeChar(int)

      • writeUTF

        public final void writeUTF​(String str)
                    throws IOException
        使用机器无关的方式使用modified UTF-8编码将字符串写入文件。

        首先，从当前文件指针开始，将两个字节写入文件，就像通过writeShort方法给出要跟随的字节数。 该值是实际写出的字节数，而不是字符串的长度。 按照长度，字符串的每个字符顺序地使用每个字符的修改的UTF-8编码输出。

        Specified by:
        writeUTF在接口 DataOutput
        参数
        str - 要写入的字符串。
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Reader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class Reader

  • java.lang.Object
    • java.io.Reader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable
    已知直接子类：
    BufferedReader ， CharArrayReader ， FilterReader ， InputStreamReader ， PipedReader ， StringReader ， URLReader

    public abstract class Reader
extends Object
implements Readable, Closeable
    用于读取字符流的抽象类。 子类必须实现的唯一方法是read（char []，int，int）和close（）。 然而，大多数子类将覆盖这里定义的一些方法，以便提供更高的效率，附加的功能或两者。
    从以下版本开始：
    1.1
    另请参见：
    BufferedReader ， LineNumberReader ， CharArrayReader ， InputStreamReader ， FileReader ， FilterReader ， PushbackReader ， PipedReader ， StringReader ， Writer

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Object lock
      用于同步此流上的操作的对象。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Reader​()
      创建一个新的字符流阅读器，其关键部分将在阅读器本身上同步。
      protected Reader​(Object lock)
      创建一个新的字符流阅读器，其关键部分将在给定对象上同步。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void close​()
      关闭流并释放与之相关联的任何系统资源。
      void mark​(int readAheadLimit)
      标记流中的当前位置。
      boolean markSupported​()
      告诉这个流是否支持mark（）操作。
      int read​()
      读一个字符
      int read​(char[] cbuf)
      将字符读入数组。
      abstract int read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      int read​(CharBuffer target)
      尝试将字符读入指定的字符缓冲区。
      boolean ready​()
      告诉这个流是否准备好被读取。
      void reset​()
      重置流。
      long skip​(long n)
      跳过字符

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • lock

        protected Object lock
        用于同步此流上的操作的对象。 为了效率，字符流对象可以使用自身以外的对象来保护关键部分。 因此，子类应该使用此字段中的对象，而不是this或同步方法。

    • 构造方法详细信息

      • Reader

        protected Reader​()
        创建一个新的字符流阅读器，其关键部分将在阅读器本身上同步。

      • Reader

        protected Reader​(Object lock)
        创建一个新的字符流阅读器，其关键部分将在给定对象上同步。
        参数
        lock - 要同步的对象。

    • 方法详细信息

      • read

        public int read​(CharBuffer target)
         throws IOException
        尝试将字符读入指定的字符缓冲区。 缓冲区用作字符存储库：唯一的更改是put操作的结果。 不执行缓冲器的翻转或倒带。
        Specified by:
        read在接口 Readable
        参数
        target - 读取字符的缓冲区
        结果
        添加到缓冲区的字符数，如果此字符源结束，则为-1
        异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果target为null
        ReadOnlyBufferException - 如果目标是只读缓冲区
        从以下版本开始：
        1.5

      • read

        public int read​()
         throws IOException
        读一个字符 该方法将阻塞，直到字符可用，发生I / O错误或达到流的结尾。

        旨在支持高效单字符输入的子类应该覆盖此方法。

        结果
        字符读取，作为0到65535（ 0x00-0xffff ）范围内的整数，如果已经达到流的末尾，则 0x00-0xffff -1。
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] cbuf)
         throws IOException
        将字符读入数组。 该方法将阻塞，直到某些输入可用，发生I / O错误或达到流的结尾。
        参数
        cbuf - 目的缓冲区
        结果
        读取的字符数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误

      • read

        public abstract int read​(char[] cbuf,
                         int off,
                         int len)
                  throws IOException
        将字符读入数组的一部分。 该方法将阻塞，直到某些输入可用，发生I / O错误或达到流的结尾。
        参数
        cbuf - 目的缓冲区
        off - 开始存储字符的偏移量
        len - 要读取的最大字符数
        结果
        读取的字符数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 len大于 cbuf.length - off

      • skip

        public long skip​(long n)
          throws IOException
        跳过字符 该方法将阻塞，直到某些字符可用，发生I / O错误或达到流的结尾。
        参数
        n - 要跳过的字符数
        结果
        实际跳过的字符数
        异常
        IllegalArgumentException - 如果 n为负数。
        IOException - 如果发生I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好被读取。
        结果
        如果下一个read（）保证不阻止输入，则为True，否则为false。 请注意，返回false并不能保证下一次读取将被阻止。
        异常
        IOException - 如果发生I / O错误

      • markSupported

        public boolean markSupported​()
        告诉这个流是否支持mark（）操作。 默认实现始终返回false。 子类应该覆盖此方法。
        结果
        当且仅当此流支持标记操作时才为真。

      • mark

        public void mark​(int readAheadLimit)
          throws IOException
        标记流中的当前位置。 对reset（）的后续调用将尝试将流重新定位到此位置。 并非所有字符输入流都支持mark（）操作。
        参数
        readAheadLimit - 限制仍然保留标记时可能读取的字符数。 读了这么多字符后，尝试重置流可能会失败。
        异常
        IOException - 如果流不支持mark（），或者发生其他I / O错误

      • reset

        public void reset​()
           throws IOException
        重置流。 如果流已被标记，则尝试在标记处重新定位。 如果流未被标记，则尝试以某种方式将其重置为特定流，例如通过将其重新定位到其起始点。 并不是所有的字符输入流都支持reset（）操作，有些支持reset（），而不支持mark（）。
        异常
        IOException - 如果流未被标记，或标记已被无效，或者流不支持reset（），或者发生其他I / O错误

      • close

        public abstract void close​()
                    throws IOException
        关闭流并释放与之相关联的任何系统资源。 一旦流已关闭，进一步的read（），ready（），mark（），reset（）或skip（）调用将抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SequenceInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class SequenceInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.SequenceInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class SequenceInputStream
extends InputStream
    A SequenceInputStream表示其他输入流的逻辑级联。 它从一个有序的输入流集合开始，从第一个读取到文件的结尾，然后从第二个文件读取，依此类推，直到最后一个输入流达到文件的结尾。
    从以下版本开始：
    1.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      SequenceInputStream​(InputStream s1, InputStream s2)
      通过记住两个参数来初始化一个新创建的 SequenceInputStream ，这两个参数将按顺序读取，第一个是 s1 ，然后是 s2 ，以提供从该 SequenceInputStream读取的字节。
      SequenceInputStream​(Enumeration<? extends InputStream> e)
      初始化新创建 SequenceInputStream通过记住参数，它必须是一个 Enumeration产生对象，它们的运行时类型是 InputStream 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int available​()
      返回当前底层输入流可以读取（或跳过）的字节数，而不会被下一次调用当前底层输入流的方法阻塞。
      void close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      int read​()
      从该输入流读取下一个数据字节。
      int read​(byte[] b, int off, int len)
      从该输入流读取最多 len个字节的数据为字节数组。

      • Methods inherited from class java.io.InputStream

        mark, markSupported, read, readAllBytes, readNBytes, reset, skip, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SequenceInputStream

        public SequenceInputStream​(Enumeration<? extends InputStream> e)
        通过记住该参数来初始化新创建的SequenceInputStream ，该参数必须是Enumeration ，其生成运行时类型为InputStream 。 由枚举产生的输入流将按顺序读取，以提供要从此SequenceInputStream读取的字节。 从枚举的每个输入流耗尽后，通过调用其close方法关闭。
        参数
        e - 输入流的枚举。
        另请参见：
        Enumeration

      • SequenceInputStream

        public SequenceInputStream​(InputStream s1,
                           InputStream s2)
        通过记住两个参数来初始化新创建的 SequenceInputStream ，这两个参数将按顺序读取，首先是 s1 ，然后是 s2 ，以提供要从此 SequenceInputStream读取的字节。
        参数
        s1 - 要读取的第一个输入流。
        s2 - 要读取的第二个输入流。

    • 方法详细信息

      • available

        public int available​()
              throws IOException
        返回当前底层输入流可以读取（或跳过）的字节数，而不会被下一次调用当前底层输入流的方法阻塞。 下一个调用可能是同一个线程或另一个线程。 这个多个字节的单个读取或跳过将不会被阻塞，但可以读取或跳过较少的字节。

        该方法简单地调用当前底层输入流的available并返回结果。

        重写：
        available在 InputStream
        结果
        从当前底层输入流中可以读取（或跳过）的字节数，不阻塞的 0如果该输入流已通过调用其 close()方法关闭， 则为0
        异常
        IOException - 如果发生I / O错误。
        从以下版本开始：
        1.1

      • read

        public int read​()
         throws IOException
        从该输入流读取下一个数据字节。 该字节作为int返回0到255 。 如果没有字节可用，因为流已经到达，则返回值为-1 。 该方法阻塞直到输入数据可用，检测到流的结尾，或抛出异常。

        此方法尝试从当前子流中读取一个字符。 如果它到达流的末尾，它调用当前子流的close方法，并从下一个子流开始读取。

        Specified by:
        read在 InputStream
        结果
        数据的下一个字节，如果达到流的末尾， -1 。
        异常
        IOException - 如果发生I / O错误。

      • read

        public int read​(byte[] b,
                int off,
                int len)
         throws IOException
        从该输入流读取最多len个字节的数据为字节数组。 如果len不为零，则该方法将阻塞，直到输入的至少1个字节可用; 否则，不会读取字节，并返回0 。

        该read的方法SequenceInputStream试图从当前子流读取数据。 如果由于子流已达到流的末尾而无法读取任何字符，则会调用当前子流的close方法，并从下一个子流开始读取。

        重写：
        read在 InputStream
        参数
        b - 读取数据的缓冲区。
        off - 写入数据的数组 b中的起始偏移量。
        len - 读取的最大字节数。
        结果
        int读取的字节数。
        异常
        NullPointerException - 如果 b是 null 。
        IndexOutOfBoundsException - 如果 off为负数， len为负数，或 len大于 b.length - off
        IOException - 如果发生I / O错误。
        另请参见：
        InputStream.read()

      • close

        public void close​()
           throws IOException
        关闭此输入流并释放与流相关联的任何系统资源。 关闭的SequenceInputStream无法执行输入操作，无法重新打开。

        如果此流是从枚举创建的，则所有剩余元素都将从枚举中请求，并在close方法返回之前关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        重写：
        close在 InputStream
        异常
        IOException - 如果发生I / O错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Serializable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Interface Serializable

  • All Known Subinterfaces:
    AdapterActivator ， Attribute ， Attribute ， Attributes ， BindingIterator ， CertPathValidatorException.Reason ， ClientRequestInfo ， ClientRequestInterceptor ， Codec ， CodecFactory ， Connector.Argument ， Connector.BooleanArgument ， Connector.IntegerArgument ， Connector.SelectedArgument ， Connector.StringArgument ， Control ， Current ， Current ， Current ， CustomValue ， DataInputStream ， DataOutputStream ， Descriptor ， DHPrivateKey ， DHPublicKey ， DocAttribute ， DomainManager ， DSAPrivateKey ， DSAPublicKey ， DynAny ， DynAnyFactory ， DynArray ， DynEnum ， DynFixed ， DynSequence ， DynStruct ， DynUnion ， DynValue ， DynValueBox ， DynValueCommon ， ECPrivateKey ， ECPublicKey ， ExtendedRequest ， ExtendedResponse ， Externalizable ， IdAssignmentPolicy ， IDLEntity ， IDLType ， IdUniquenessPolicy ， ImplicitActivationPolicy ， Interceptor ， IORInfo ， IORInterceptor ， IORInterceptor_3_0 ， IRObject ， Key Key ， LifespanPolicy ， Name ， NamingContext ， NamingContextExt ， NotificationFilter ， ObjectReferenceFactory ， ObjectReferenceTemplate ， ORBInitializer ， ORBInitInfo ， PBEKey ， POA ， POAManager ， Policy ， PolicyFactory ， PrintJobAttribute ， PrintRequestAttribute ， PrintServiceAttribute ， PrivateKey ， PublicKey ， QueryExp ， RelationType ， RemoteRef ， RequestInfo ， RequestProcessingPolicy ， RSAMultiPrimePrivateCrtKey ， RSAPrivateCrtKey ， RSAPrivateKey ， RSAPublicKey ， RunTime ， SecretKey ， ServantActivator ， ServantLocator ， ServantManager ， ServantRetentionPolicy ， ServerRef ， ServerRequestInfo ， ServerRequestInterceptor ， StreamableValue ， SupportedValuesAttribute ， ThreadPolicy ， UnsolicitedNotification ， ValueBase ， ValueExp

    public interface Serializable
    类的序列化由实现java.io.Serializable接口的类启用。 不实现此接口的类将不会使任何状态序列化或反序列化。 可序列化类的所有子类型都是可序列化的。 序列化接口没有方法或字段，仅用于标识可串行化的语义。

    为了允许序列化不可序列化的子类型，子类型可能承担保存和恢复超类型的公共，受保护和（如果可访问）包字段的状态的责任。 子类型可以承担此责任，只有当它扩展的类具有可访问的无参数构造函数来初始化类的状态。 如果不是这样，声明一个类Serializable是一个错误。 错误将在运行时检测到。

    在反序列化期间，非可序列化类的字段将使用该类的public或protected no-arg构造函数进行初始化。 对于可序列化的子类，必须可以访问no-arg构造函数。 可序列化子类的字段将从流中恢复。

    当遍历图形时，可能会遇到不支持Serializable接口的对象。 在这种情况下，将抛出NotSerializableException，并将标识不可序列化对象的类。

    在序列化和反序列化过程中需要特殊处理的类必须采用具有这些精确签名的特殊方法：

      private void writeObject(java.io.ObjectOutputStream out)
     throws IOException
 private void readObject(java.io.ObjectInputStream in)
     throws IOException, ClassNotFoundException;
 private void readObjectNoData()
     throws ObjectStreamException;

    writeObject方法负责为其特定的类编写对象的状态，以便相应的readObject方法可以恢复它。 可以通过调用out.defaultWriteObject来调用保存对象字段的默认机制。 该方法不需要关注属于其超类或子类的状态。 通过使用writeObject方法或通过使用DataOutput支持的原始数据类型的方法将各个字段写入ObjectOutputStream来保存状态。

    readObject方法负责从流中读取并恢复类字段。 它可以调用in.defaultReadObject来调用恢复对象的非静态和非瞬态字段的默认机制。 defaultReadObject方法使用流中的信息将保存在流中的对象的字段分配给当前对象中相应命名的字段。 当处理类进化到添加新字段时，这将处理这种情况。 该方法不需要关注属于其超类或子类的状态。 通过从ObjectInputStream读取各个字段的数据并对对象的相应字段进行分配来恢复状态。 DataInput支持读取原始数据类型。

    如果序列化流未将给定类列为反序列化对象的超类，则readObjectNoData方法负责初始化其特定类的对象的状态。 这可能发生在接收方使用与发送方不同的反序列化实例的类的版本的情况下，并且接收者的版本扩展了不被发送者版本扩展的类。 如果序列化流已被篡改，也可能发生这种情况; 因此，尽管存在“敌对”或不完整的源流，readObjectNoData可用于正确初始化反序列化对象。

    在将对象写入流时，需要指定要使用的替代对象的可序列化类应实现具有确切签名的特殊方法：

      ANY-ACCESS-MODIFIER Object writeReplace() throws ObjectStreamException;

    如果该方法存在并且可以通过在正在序列化的对象的类中定义的方法来访问该writeReplace方法，则通过序列化来调用该writeReplace方法。 因此，该方法可以具有私有，受保护和包私有访问。 子类访问此方法遵循java可访问性规则。

    当从流中读取实例时需要指定替换的类应实现具有确切签名的特殊方法。

      ANY-ACCESS-MODIFIER Object readResolve() throws ObjectStreamException;

    此readResolve方法遵循与writeReplace相同的调用规则和可访问性规则。

    序列化运行时与每个可序列化的类关联一个版本号，称为serialVersionUID，它在反序列化过程中使用，以验证序列化对象的发送者和接收者是否加载了与序列化兼容的对象的类。 如果接收者已经为具有与对应发件人类别不同的serialVersionUID的对象加载了一个类，则反序列化将导致一个InvalidClassException 。 一个可序列化的类可以通过声明一个名为"serialVersionUID"的字段来显式地声明它自己的serialVersionUID，该字段必须是static，final和long类型：

      ANY-ACCESS-MODIFIER static final long serialVersionUID = 42L;
    如果可序列化类没有显式声明serialVersionUID，则序列化运行时将根据Java（TM）对象序列化规范中所述的类的各个方面计算该类的默认serialVersionUID值。 然而， 强烈建议所有可序列化的类显式声明serialVersionUID值，因为默认的serialVersionUID计算对类细节非常敏感，这些细节可能因编译器实现而异，因此可能会在反序列化期间导致意外的InvalidClassException 。 因此，为了保证不同Java编译器实现之间的一致的serialVersionUID值，一个可序列化的类必须声明一个显式的serialVersionUID值。 还强烈建议，显式的serialVersionUID声明在可能的情况下使用private修饰符，因为这种声明仅适用于立即声明的类 - serialVersionUID字段作为继承成员无效。 数组类不能声明一个显式的serialVersionUID，所以它们总是具有默认的计算值，但是对于数组类，放弃了匹配serialVersionUID值的要求。
    从以下版本开始：
    1.1
    另请参见：
    ObjectOutputStream ， ObjectInputStream ， ObjectOutput ， ObjectInput ， Externalizable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SerializablePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class SerializablePermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.io.SerializablePermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class SerializablePermission
extends BasicPermission
    这个类用于Serializable权限。 SerializablePermission包含一个名称（也称为“目标名称”），但没有操作列表; 你有指定的权限，或者你没有。

    目标名称是Serializable权限的名称（见下文）。

    下表列出了标准的SerializablePermission目标名称，每个都提供了许可允许的描述，并讨论授予代码授权的风险。

    Permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission enableSubclassImplementation Subclass implementation of ObjectOutputStream or ObjectInputStream to override the default serialization or deserialization, respectively, of objects Code can use this to serialize or deserialize classes in a purposefully malfeasant manner. For example, during serialization, malicious code can use this to purposefully store confidential private field data in a way easily accessible to attackers. Or, during deserialization it could, for example, deserialize a class with all its private fields zeroed out. enableSubstitution Substitution of one object for another during serialization or deserialization This is dangerous because malicious code can replace the actual object with one which has incorrect or malignant data. serialFilter Setting a filter for ObjectInputStreams. Code could remove a configured filter and remove protections already established.
    从以下版本开始：
    1.2
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SerializablePermission​(String name)
      创建一个具有指定名称的新SerializablePermission。
      SerializablePermission​(String name, String actions)
      创建一个具有指定名称的新SerializablePermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • SerializablePermission

        public SerializablePermission​(String name)
        创建一个具有指定名称的新SerializablePermission。 该名称是SerializablePermission的符号名称，例如“enableSubstitution”等。
        参数
        name - SerializablePermission的名称。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • SerializablePermission

        public SerializablePermission​(String name,
                              String actions)
        创建一个具有指定名称的新SerializablePermission对象。 该名称是SerializablePermission的符号名称，并且操作String当前未使用，应为null。
        参数
        name - SerializablePermission的名称。
        actions - 当前未使用，必须设置为null
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StreamCorruptedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class StreamCorruptedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
            • java.io.StreamCorruptedException
  • All Implemented Interfaces:
    Serializable

    public class StreamCorruptedException
extends ObjectStreamException
    当从对象流读取的控制信息违反内部一致性检查时抛出。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StreamCorruptedException​()
      创建一个StreamCorruptedException并列出抛出的原因。
      StreamCorruptedException​(String reason)
      创建一个StreamCorruptedException并列出抛出的原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • StreamCorruptedException

        public StreamCorruptedException​(String reason)
        创建一个StreamCorruptedException并列出抛出的原因。
        参数
        reason - 描述异常原因的字符串。

      • StreamCorruptedException

        public StreamCorruptedException​()
        创建一个StreamCorruptedException并列出抛出的原因。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StreamTokenizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class StreamTokenizer

  • java.lang.Object
    • java.io.StreamTokenizer

  • public class StreamTokenizer
extends Object
    StreamTokenizer类接收输入流并将其解析为“令牌”，允许一次读取一个令牌。 解析过程由表和多个可以设置为各种状态的标志来控制。 流标记器可以识别标识符，数字，引用的字符串和各种注释样式。

    从输入流读取的每个字节被视为'\u0000'至'\u00FF' 。 字符值用于查找字符的五个可能属性： 空格 ， 字母 ， 数字 ， 字符串引号和注释字符 。 每个角色都可以有零个或多个这些属性。

    另外，一个实例有四个标志。 这些标志表示：

    • 线路终端器是否作为令牌返回或被视为仅分隔令牌的空白区域。
    • C风格的评论是否被识别和跳过。
    • C ++风格的评论是否被识别和跳过。
    • 标识符的字符是否转换为小写。

    一个典型的应用程序首先构造一个这个类的一个实例，设置语法表，然后在循环的每个迭代中重复循环调用nextToken方法，直到它返回值为TT_EOF 。

    从以下版本开始：
    1.0
    另请参见：
    nextToken() ， TT_EOF

    • Field Summary

      Fields
      Modifier and Type Field 描述
      double nval
      如果当前令牌是一个数字，则此字段包含该数字的值。
      String sval
      如果当前令牌是一个单词标记，则该字段包含一个字符串，给出单词令牌的字符。
      static int TT_EOF
      指示流的末尾已被读取的常量。
      static int TT_EOL
      一个常量，指示行的末尾已被读取。
      static int TT_NUMBER
      指示已读取数字令牌的常量。
      static int TT_WORD
      一个表示已经读取了单词标记的常量。
      int ttype
      在调用 nextToken方法后，此字段包含刚刚读取的令牌的类型。

    • 构造方法摘要

      构造方法
      Constructor 描述
      StreamTokenizer​(InputStream is)
      已过时。
      从JDK版本1.1开始，将输入流标记化的首选方法是将其转换为字符流，例如：
         Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
      StreamTokenizer​(Reader r)
      创建一个解析给定字符流的tokenizer。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void commentChar​(int ch)
      指定字符参数启动单行注释。
      void eolIsSignificant​(boolean flag)
      确定行尾是否被视为令牌。
      int lineno​()
      返回当前行号。
      void lowerCaseMode​(boolean fl)
      确定字标记是否自动降低。
      int nextToken​()
      从此分类器的输入流中解析下一个令牌。
      void ordinaryChar​(int ch)
      指定此标记器中的字符参数为“普通”。
      void ordinaryChars​(int low, int hi)
      指定此分类器中 low <= c <= high范围内的所有字符 c均为“普通”。
      void parseNumbers​()
      指定数字应由此分段器解析。
      void pushBack​()
      导致下一次调用此令牌化器的 nextToken方法以返回 ttype字段中的当前值，而不修改 nval或 sval字段中的值。
      void quoteChar​(int ch)
      指定此字符串的匹配对在此分段器中分隔字符串常量。
      void resetSyntax​()
      重置这个tokenizer的语法表，使所有的字符都是“普通的”。
      void slashSlashComments​(boolean flag)
      确定tokenizer是否识别C ++风格的注释。
      void slashStarComments​(boolean flag)
      确定标记器是否识别C风格的注释。
      String toString​()
      返回当前流令牌的字符串表示形式及其发生的行号。
      void whitespaceChars​(int low, int hi)
      指定 low <= c <= high范围内的所有字符 c都是空白字符。
      void wordChars​(int low, int hi)
      指定 low <= c <= high范围内的所有字符 c都是单词组成。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ttype

        public int ttype
        在调用nextToken方法后，此字段包含刚刚读取的令牌的类型。 对于单个字符令牌，其值是单个字符，转换为整数。 对于引用的字符串令牌，其值是引号字符。 否则，其值为以下之一：
        • TT_WORD表示令牌是一个单词。
        • TT_NUMBER表示令牌是一个数字。
        • TT_EOL表示已经读取了行尾。 如果使用参数true调用了eolIsSignificant方法，则该字段只能具有此值。
        • TT_EOF表示已经达到了输入流的结尾。

        该字段的初始值为-4。

        另请参见：
        eolIsSignificant(boolean) ， nextToken() ， quoteChar(int) ， TT_EOF ， TT_EOL ， TT_NUMBER ， TT_WORD

      • TT_EOF

        public static final int TT_EOF
        指示流的末尾已被读取的常量。
        另请参见：
        Constant Field Values

      • TT_EOL

        public static final int TT_EOL
        一个常量，指示行的末尾已被读取。
        另请参见：
        Constant Field Values

      • TT_NUMBER

        public static final int TT_NUMBER
        指示已读取数字令牌的常量。
        另请参见：
        Constant Field Values

      • TT_WORD

        public static final int TT_WORD
        一个表示已经读取了单词标记的常量。
        另请参见：
        Constant Field Values

      • sval

        public String sval
        如果当前令牌是一个单词标记，则该字段包含一个字符串，给出单词令牌的字符。 当前的令牌是带引号的字符串令牌时，此字段包含字符串的正文。

        当ttype字段的值为TT_WORD时，当前令牌是一个字。 当ttype字段的值为引号时，当前令牌是带引号的字符串令牌。

        该字段的初始值为null。

        另请参见：
        quoteChar(int) ， TT_WORD ， ttype

      • nval

        public double nval
        如果当前令牌是一个数字，则此字段包含该数字的值。 当ttype字段的值为TT_NUMBER时，当前令牌是一个数字。

        该字段的初始值为0.0。

        另请参见：
        TT_NUMBER ， ttype

    • 构造方法详细信息

      • StreamTokenizer

        @Deprecated
public StreamTokenizer​(InputStream is)
        已过时。 从JDK版本1.1开始，将输入流标记化的首选方法是将其转换为字符流，例如：
           Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
        创建解析指定输入流的流标记器。 流标记器初始化为以下默认状态：
        • 所有字节值'A'通过'Z' ， 'a'通过'z' ，并'\u00A0'通过'\u00FF'被认为是字母。
        • 所有字节值'\u0000'至'\u0020'被认为是空格。
        • '/'是一个注释字符。
        • 单引号'\''和双引号'"'是字符串引号字符。
        • 数字被解析。
        • 行尾被视为空白区域，而不是单独的标记。
        • C风格和C ++风格的评论不能被识别。
        参数
        is - 输入流。
        另请参见：
        BufferedReader ， InputStreamReader ， StreamTokenizer(java.io.Reader)

      • StreamTokenizer

        public StreamTokenizer​(Reader r)
        创建一个解析给定字符流的tokenizer。
        参数
        r - 提供输入流的Reader对象。
        从以下版本开始：
        1.1

    • 方法详细信息

      • resetSyntax

        public void resetSyntax​()
        重置这个tokenizer的语法表，使所有的字符都是“普通的”。 有关一般字符的更多信息，请参阅ordinaryChar方法。
        另请参见：
        ordinaryChar(int)

      • wordChars

        public void wordChars​(int low,
                      int hi)
        指定low <= c <= high范围内的所有字符c都是单词组成。 单词令牌由一个单词组成，后跟零个或多个单词组成或数字组成。
        参数
        low - 范围的低端。
        hi - 高端的范围。

      • whitespaceChars

        public void whitespaceChars​(int low,
                            int hi)
        指定low <= c <= high范围内的所有字符c都是空白字符。 白色空格字符仅用于在输入流中分隔标记。

        指定范围内字符的任何其他属性设置都将被清除。

        参数
        low - 范围的低端。
        hi - 高端的范围。

      • ordinaryChars

        public void ordinaryChars​(int low,
                          int hi)
        指定此分类器中low <= c <= high范围内的所有字符c均为“普通”。 有关一般字符的更多信息，请参阅ordinaryChar方法。
        参数
        low - 范围的低端。
        hi - 高端的范围。
        另请参见：
        ordinaryChar(int)

      • ordinaryChar

        public void ordinaryChar​(int ch)
        指定此标记器中的字符参数为“普通”。 它消除了字符作为注释字符，单词组件，字符串分隔符，空格或数字字符的任何特殊意义。 当解析器遇到这样的字符时，解析器将其视为单字符令牌，并将ttype字段设置为字符值。

        线路终端符字符“普通”可能会影响StreamTokenizer计数行的能力。 lineno方法可能不再反映在其行计数中存在这样的终止符字符。

        参数
        ch - 字符。
        另请参见：
        ttype

      • commentChar

        public void commentChar​(int ch)
        指定字符参数启动单行注释。 该流标记器将忽略从注释字符到行尾的所有字符。

        清除指定字符的任何其他属性设置。

        参数
        ch - 字符。

      • quoteChar

        public void quoteChar​(int ch)
        指定此字符串的匹配对在此分段器中分隔字符串常量。

        当nextToken方法遇到字符串常量时， ttype字段设置为字符串分隔符，并将sval字段设置为字符串的正文。

        如果遇到字符串引用字符，则会识别一个字符串，由字符串引用字符（但不包括）之后的所有字符组成，直到（但不包括）相同字符串引号字符的下一个出现或行终止符，或文件结尾。 当解析字符串时，通常的转义序列如"\n"和"\t"被识别并转换为单个字符。

        清除指定字符的任何其他属性设置。

        参数
        ch - 字符。
        另请参见：
        nextToken() ， sval ， ttype

      • parseNumbers

        public void parseNumbers​()
        指定数字应由此分段器解析。 修改此分类器的语法表，以便十二个字符中的每一个：
              0 1 2 3 4 5 6 7 8 9 . -

        具有“数值”属性。

        当解析器遇到具有双精度浮点数格式的单词令牌时，它将该令牌视为一个数字而不是一个单词，通过将ttype字段设置为值TT_NUMBER ，并将令牌的数字值的nval字段。

        另请参见：
        nval ， TT_NUMBER ， ttype

      • eolIsSignificant

        public void eolIsSignificant​(boolean flag)
        确定行尾是否被视为令牌。 如果标志参数为true，则该标记器将行尾作为令牌处理; 当读取行结尾时， nextToken方法返回TT_EOL ，并将ttype字段设置为此值。

        行是以回车符（ '\r' ）或换行字符（ '\n' ）结尾的字符'\n' 。 另外，一个换行符后跟随一个换行字符被视为一个单一的行尾标记。

        如果flag为假，则行尾字符将被视为空格，仅用于分隔标记。

        参数
        flag - true表示行尾字符是独立的标记; false表示行尾字符是空格。
        另请参见：
        nextToken() ， ttype ， TT_EOL

      • slashStarComments

        public void slashStarComments​(boolean flag)
        确定标记器是否识别C风格的注释。 如果标志参数是true ，则该流标记器识别C风格的注释。 连续出现/*和*/之间的所有文本都将被丢弃。

        如果flag参数是false ，那么C风格的注释不会被特别处理。

        参数
        flag - true表示识别和忽略C风格的评论。

      • slashSlashComments

        public void slashSlashComments​(boolean flag)
        确定tokenizer是否识别C ++风格的注释。 如果标志参数是true ，则该流标记器识别C ++风格的注释。 任何两个连续的斜杠字符（ '/' ）的出现被视为延伸到行尾的注释开头。

        如果flag参数是false ，那么C ++风格的注释不会被特别处理。

        参数
        flag - true表示识别和忽略C ++风格的注释。

      • lowerCaseMode

        public void lowerCaseMode​(boolean fl)
        确定字标记是否自动降低。 如果标志参数是true ，然后在该值sval每当返回一个字令牌字段被小写（该ttype字段具有值TT_WORD由nextToken此标记生成器的方法。

        如果标志参数为false ，则不修改sval字段。

        参数
        fl - true表示所有单词标记应该 true 。
        另请参见：
        nextToken() ， ttype ， TT_WORD

      • nextToken

        public int nextToken​()
              throws IOException
        从此分类器的输入流中解析下一个令牌。 ttype字段中返回下一个令牌的类型。 有关令牌的附加信息可能位于此分类器的nval字段或sval字段中。

        此类的典型客户端首先设置语法表，然后坐在一个循环中调用nextToken来解析连续的令牌，直到返回TT_EOF。

        结果
        该值为 ttype字段。
        异常
        IOException - 如果发生I / O错误。
        另请参见：
        nval ， sval ， ttype

      • pushBack

        public void pushBack​()
        导致下一次调用此tokenizer的 nextToken方法以返回 ttype字段中的当前值，而不修改 nval或 sval字段中的值。
        另请参见：
        nextToken() ， nval ， sval ， ttype

      • lineno

        public int lineno​()
        返回当前行号。
        结果
        该流标记器的当前行号。

      • toString

        public String toString​()
        返回当前流令牌的字符串表示形式及其发生的行号。

        返回的精确字符串是未指定的，虽然以下示例可以被认为是典型的：

        Token['a'], line 10
        重写：
        toString在 Object
        结果
        令牌的字符串表示形式
        另请参见：
        nval ， sval ， ttype
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringBufferInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class StringBufferInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.StringBufferInputStream
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已过时。
    此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。

    @Deprecated
public class StringBufferInputStream
extends InputStream
    该类允许应用程序创建一个输入流，其中读取的字节由字符串的内容提供。 应用程序还可以通过使用ByteArrayInputStream从字节数组读取字节。

    只有字符串中每个字符的低8位被该类使用。

    从以下版本开始：
    1.0
    另请参见：
    ByteArrayInputStream ， StringReader

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected String buffer
      已过时。
      读取字节的字符串。
      protected int count
      已过时。
      输入流缓冲区中有效字符的数量。
      protected int pos
      已过时。
      从输入流缓冲区读取的下一个字符的索引。

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringBufferInputStream​(String s)
      已过时。
      创建一个字符串输入流，以从指定的字符串读取数据。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int available​()
      已过时。
      返回无阻塞地从输入流中读取的字节数。
      int read​()
      已过时。
      从该输入流读取下一个数据字节。
      int read​(byte[] b, int off, int len)
      已过时。
      从该输入流读取最多 len字节的数据到一个字节数组。
      void reset​()
      已过时。
      重置输入流以开始从该输入流的底层缓冲区的第一个字符读取。
      long skip​(long n)
      已过时。
      从此输入流跳过 n个字节的输入。

      • Methods inherited from class java.io.InputStream

        close, mark, markSupported, read, readAllBytes, readNBytes, transferTo

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • buffer

        protected String buffer
        已过时。
        读取字节的字符串。

      • pos

        protected int pos
        已过时。
        从输入流缓冲区读取的下一个字符的索引。
        另请参见：
        buffer

      • count

        protected int count
        已过时。
        输入流缓冲区中有效字符的数量。
        另请参见：
        buffer

    • 构造方法详细信息

      • StringBufferInputStream

        public StringBufferInputStream​(String s)
        已过时。
        创建一个字符串输入流，以从指定的字符串读取数据。
        参数
        s - 底层输入缓冲区。

    • 方法详细信息

      • read

        public int read​()
        已过时。
        从该输入流读取下一个数据字节。 值字节作为int返回，范围为0至255 。 如果没有字节可用，因为流已经到达，则返回值-1 。

        该read的方法StringBufferInputStream不能阻止。 它返回此输入流缓冲区中下一个字符的低8位。

        Specified by:
        read在 InputStream
        结果
        数据的下一个字节，如果达到流的末尾， -1 。

      • read

        public int read​(byte[] b,
                int off,
                int len)
        已过时。
        从该输入流读取最多len个字节的数据为字节数组。

        该read的方法StringBufferInputStream不能阻止。 它将低8位从该输入流的缓冲区中的字符复制到字节数组参数中。

        重写：
        read在 InputStream
        参数
        b - 读取数据的缓冲区。
        off - 数据的起始偏移量。
        len - 读取的最大字节数。
        结果
        读入缓冲区的总字节数，如果没有更多的数据，因为已经达到了流的结尾，那么这个字节是 -1 。
        另请参见：
        InputStream.read()

      • skip

        public long skip​(long n)
        已过时。
        从此输入流跳过n个字节的输入。 如果达到输入流的结尾，则可能会跳过更少的字节。
        重写：
        skip在类 InputStream
        参数
        n - 要跳过的字节数。
        结果
        实际跳过的字节数。

      • available

        public int available​()
        已过时。
        返回无阻塞地从输入流中读取的字节数。
        重写：
        available在 InputStream
        结果
        值为 count - pos ，即从输入缓冲区读取的剩余字节数。

      • reset

        public void reset​()
        已过时。
        重置输入流以开始从该输入流的底层缓冲区的第一个字符读取。
        重写：
        reset在 InputStream
        另请参见：
        InputStream.mark(int) ， IOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class StringReader

  • java.lang.Object
    • java.io.Reader
      • java.io.StringReader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable ， Readable

    public class StringReader
extends Reader
    一个字符流，其源是一个字符串。
    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from class java.io.Reader

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringReader​(String s)
      创建一个新的字符串阅读器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void close​()
      关闭流并释放与之相关联的任何系统资源。
      void mark​(int readAheadLimit)
      标记流中的当前位置。
      boolean markSupported​()
      告诉这个流是否支持mark（）操作。
      int read​()
      读一个字符
      int read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      boolean ready​()
      告诉这个流是否准备好被读取。
      void reset​()
      将流重新设置为最近的标记，如果从未被标记，则将其重置到字符串的开头。
      long skip​(long ns)
      跳过流中指定数量的字符。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.io.Reader

        read, read

    • 构造方法详细信息

      • StringReader

        public StringReader​(String s)
        创建一个新的字符串阅读器。
        参数
        s - 提供字符流的字符串。

    • 方法详细信息

      • read

        public int read​()
         throws IOException
        读一个字符
        重写：
        read在 Reader
        结果
        字符读取，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误

      • read

        public int read​(char[] cbuf,
                int off,
                int len)
         throws IOException
        将字符读入数组的一部分。
        Specified by:
        read在 Reader
        参数
        cbuf - 目的缓冲区
        off - 开始写入字符的偏移量
        len - 要读取的最大字符数
        结果
        读取的字符数，如果已经达到流的结尾，则为-1
        异常
        IOException - 如果发生I / O错误
        IndexOutOfBoundsException - 如果发生I / O错误

      • skip

        public long skip​(long ns)
          throws IOException
        跳过流中指定数量的字符。 返回跳过的字符数。

        ns参数可能为负，即使Reader超类的skip方法在这种情况下抛出异常。 ns导致流向后跳。 负值返回值表示向后跳。 不可能从字符串的开头向后跳过。

        如果整个字符串已被读取或跳过，则该方法不起作用，并始终返回0。

        重写：
        skip在 Reader
        参数
        ns - 要跳过的字符数
        结果
        实际跳过的字符数
        异常
        IOException - 如果发生I / O错误

      • ready

        public boolean ready​()
              throws IOException
        告诉这个流是否准备好被读取。
        重写：
        ready在 Reader
        结果
        如果下一个read（）保证不阻止输入，则为True
        异常
        IOException - 如果流关闭

      • markSupported

        public boolean markSupported​()
        告诉这个流是否支持mark（）操作。
        重写：
        markSupported在 Reader
        结果
        当且仅当此流支持标记操作时才为真。

      • mark

        public void mark​(int readAheadLimit)
          throws IOException
        标记流中的当前位置。 对reset（）的后续调用将会将流重新定位到此位置。
        重写：
        mark在 Reader
        参数
        readAheadLimit - 限制仍然保留标记时可能读取的字符数。 因为流的输入来自一个字符串，所以没有实际的限制，所以这个参数不能是负数，而是被忽略。
        异常
        IllegalArgumentException - 如果是 readAheadLimit < 0
        IOException - 如果发生I / O错误

      • reset

        public void reset​()
           throws IOException
        将流重新设置为最近的标记，如果从未被标记，则将其重置到字符串的开头。
        重写：
        reset在 Reader
        异常
        IOException - 如果发生I / O错误

      • close

        public void close​()
        关闭流并释放与之相关联的任何系统资源。 一旦流已经关闭，进一步的read（），ready（），mark（）或reset（）调用将抛出一个IOException。 关闭以前关闭的流无效。 当读取器上有另一个线程阻塞时，此方法将阻止。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Reader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class StringWriter

  • java.lang.Object
    • java.io.Writer
      • java.io.StringWriter
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable

    public class StringWriter
extends Writer
    在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。

    关闭StringWriter没有任何效果。 该流中的方法可以在流关闭后调用，而不生成IOException 。

    从以下版本开始：
    1.1

    • Field Summary

      • Fields inherited from class java.io.Writer

        lock

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringWriter​()
      使用默认的初始字符串缓冲区大小创建一个新的字符串写入器。
      StringWriter​(int initialSize)
      使用指定的初始字符串缓冲区大小创建一个新的字符串写入器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringWriter append​(char c)
      将指定的字符附加到此作者。
      StringWriter append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      StringWriter append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      void close​()
      关闭一个 StringWriter没有任何效果。
      void flush​()
      冲洗流。
      StringBuffer getBuffer​()
      返回字符串缓冲区本身。
      String toString​()
      以缓冲区的当前值作为字符串返回。
      void write​(char[] cbuf, int off, int len)
      写一个字符数组的一部分。
      void write​(int c)
      写一个字符
      void write​(String str)
      写一个字符串
      void write​(String str, int off, int len)
      写一个字符串的一部分

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.io.Writer

        write

    • 构造方法详细信息

      • StringWriter

        public StringWriter​()
        使用默认的初始字符串缓冲区大小创建一个新的字符串写入器。

      • StringWriter

        public StringWriter​(int initialSize)
        使用指定的初始字符串缓冲区大小创建一个新的字符串写入器。
        参数
        initialSize - 自动展开之前将适合此缓冲区的 char值的数量
        异常
        IllegalArgumentException - 如果 initialSize为负数

    • 方法详细信息

      • write

        public void write​(int c)
        写一个字符
        重写：
        write在 Writer
        参数
        c - int指定要写入的字符

      • write

        public void write​(char[] cbuf,
                  int off,
                  int len)
        写一个字符数组的一部分。
        Specified by:
        write在类 Writer
        参数
        cbuf - 字符数组
        off - 开始编写字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定数组的长度

      • write

        public void write​(String str)
        写一个字符串
        重写：
        write在 Writer
        参数
        str - 要写入的字符串

      • write

        public void write​(String str,
                  int off,
                  int len)
        写一个字符串的一部分
        重写：
        write在 Writer
        参数
        str - 要写入的字符串
        off - 开始写入字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数，或 len为负数，或 off + len为负数或大于给定字符串的长度

      • append

        public StringWriter append​(CharSequence csq)
        将指定的字符序列附加到此作者。

        对这种out.append(csq)形式的方法的调用与调用的方式完全相同

          out.write(csq.toString())

        取决于规范toString字符序列csq ，整个序列可以不追加。 例如，调用字符缓冲区的toString方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

        Specified by:
        append在接口 Appendable
        重写：
        append在类 Writer
        参数
        csq - 要追加的字符序列。 如果csq为null ，则该"null"器附加四个字符"null" 。
        结果
        这位作家
        从以下版本开始：
        1.5

      • append

        public StringWriter append​(CharSequence csq,
                           int start,
                           int end)
        将指定字符序列的子序列附加到此作者。

        形式的这种方法的调用out.append(csq, start, end)时csq不是null ，行为以完全相同的方式调用

           out.write(csq.subSequence(start, end).toString())
        Specified by:
        append在接口 Appendable
        重写：
        append在类 Writer
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，那么字符将被追加，就像csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        这位作家
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，则 start大于 end ，或 end大于 csq.length()
        从以下版本开始：
        1.5

      • append

        public StringWriter append​(char c)
        将指定的字符附加到此作者。

        调用此方法的形式为out.append(c)行为方式与调用完全相同

          out.write(c)
        Specified by:
        append在接口 Appendable
        重写：
        append在 Writer
        参数
        c - 要追加的16位字符
        结果
        这位作家
        从以下版本开始：
        1.5

      • toString

        public String toString​()
        以缓冲区的当前值作为字符串返回。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • getBuffer

        public StringBuffer getBuffer​()
        返回字符串缓冲区本身。
        结果
        StringBuffer保存当前缓冲区值。

      • flush

        public void flush​()
        冲洗流。
        Specified by:
        flush在接口 Flushable
        Specified by:
        flush在 Writer

      • close

        public void close​()
           throws IOException
        关闭StringWriter没有任何效果。 该流中的方法可以在流关闭后调用，而不生成IOException 。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        Specified by:
        close在 Writer
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SyncFailedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class SyncFailedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.SyncFailedException
  • All Implemented Interfaces:
    Serializable

    public class SyncFailedException
extends IOException
    发出同步操作失败的信号。
    从以下版本开始：
    1.1
    另请参见：
    FileDescriptor.sync() ， IOException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SyncFailedException​(String desc)
      构造具有详细消息的SyncFailedException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SyncFailedException

        public SyncFailedException​(String desc)
        构造具有详细消息的SyncFailedException。 详细消息是描述此特定异常的字符串。
        参数
        desc - a String describing the exception.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UncheckedIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class UncheckedIOException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.io.UncheckedIOException
  • All Implemented Interfaces:
    Serializable

    public class UncheckedIOException
extends RuntimeException
    包装一个IOException与未检查的异常。
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UncheckedIOException​(IOException cause)
      构造这个类的一个实例。
      UncheckedIOException​(String message, IOException cause)
      构造这个类的一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      IOException getCause​()
      返回此异常的原因。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UncheckedIOException

        public UncheckedIOException​(String message,
                            IOException cause)
        构造这个类的一个实例。
        参数
        message - 详细信息，可以为null
        cause - IOException
        异常
        NullPointerException - 如果原因是 null

      • UncheckedIOException

        public UncheckedIOException​(IOException cause)
        构造这个类的一个实例。
        参数
        cause - IOException
        异常
        NullPointerException - 如果原因是 null

    • 方法详细信息

      • getCause

        public IOException getCause​()
        返回此异常的原因。
        重写：
        getCause在 Throwable
        结果
        这是 IOException这个例外的原因。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnsupportedEncodingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class UnsupportedEncodingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.UnsupportedEncodingException
  • All Implemented Interfaces:
    Serializable

    public class UnsupportedEncodingException
extends IOException
    字符编码不支持。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedEncodingException​()
      构造一个UnsupportedEncodingException而不显示详细消息。
      UnsupportedEncodingException​(String s)
      构造具有详细消息的UnsupportedEncodingException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedEncodingException

        public UnsupportedEncodingException​()
        构造一个UnsupportedEncodingException而不显示详细消息。

      • UnsupportedEncodingException

        public UnsupportedEncodingException​(String s)
        构造具有详细消息的UnsupportedEncodingException。
        参数
        s - 描述异常的原因。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.io (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.io

  • Packages that use java.io
    软件包 描述
    com.sun.jarsigner
    该包包括用于定义 jarsigner工具使用的签名机制的接口和类。
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.connect.spi
    该包包括用于开发新的TransportService实现的接口和类。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.security.auth
    提供Principal的实现。
    com.sun.security.auth.callback
    提供CallbackHandler的实现。
    com.sun.security.jgss
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。
    com.sun.tools.javac
    该包提供了 javac工具的传统入口点。
    com.sun.tools.javadoc
    此软件包及其内容已被弃用，可能会在将来的版本中删除。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.net
    提供实现网络应用程序的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.spi
    java.util包中类的服务提供者类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.application
    提供应用程序生命周期类。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javafx.util
    包含各种实用程序和助手类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.activation
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.jws
    javax.jws.soap
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.management.timer
    提供定时器MBean的定义。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming包以提供访问目录服务的功能。
    javax.naming.event
    访问命名和目录服务时，提供对事件通知的支持。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.naming.spi
    提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.print.event
    程序包javax.print.event包含事件类和侦听器接口。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.cert
    提供公钥证书类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.filechooser
    包含 JFileChooser组件使用的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    javax.transaction.xa
    提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.namespace
    定义XML命名空间处理。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.stream.events
    定义Streaming API for XML（StAX）的事件接口。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.transform.stream
    提供流和URI特定的转换类。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler
    新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
    javax.xml.ws.http
    该包定义了特定于HTTP绑定的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    java.net和 java.nio.channels套接字类的平台特定套接字选项。
    jdk.security.jarsigner
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能的对象请求代理（ORB）。
    org.omg.CORBA.DynAnyPackage
    提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。
    org.omg.CORBA.ORBPackage
    提供异常 InvalidName ，这是由方法抛出 ORB.resolve_initial_references和异常 InconsistentTypeCode ，这是由动态的ORB类中的任何创建方法抛出。
    org.omg.CORBA.TypeCodePackage
    提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.omg.CORBA_2_3.portable
    提供输入和输出值类型的方法，并包含 org/omg/CORBA/portable包的其他更新。
    org.omg.CosNaming
    为Java IDL提供命名服务。
    org.omg.CosNaming.NamingContextExtPackage
    此包装包含以下类别，用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress
    org.omg.CosNaming.NamingContextPackage
    该包包含 org.omg.CosNaming包的异常类。
    org.omg.Dynamic
    该软件包包含OMG便携式拦截器规范 ptc/2000-08-06第21.9节中指定的 Dynamic模块。
    org.omg.DynamicAny
    提供类和接口，可以在运行时遍历与 any相关联的数据值，并提取数据值的原始组成部分。
    org.omg.DynamicAny.DynAnyFactoryPackage
    该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。
    org.omg.DynamicAny.DynAnyPackage
    该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。
    org.omg.IOP
    该包包含OMG文档 “通用对象请求代理：体系结构和规范 ” formal/99-10-07 ，第13.6节中指定的 IOP模块。
    org.omg.IOP.CodecFactoryPackage
    该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。
    org.omg.IOP.CodecPackage
    该包是从IOP :: Codec IDL接口定义生成的。
    org.omg.PortableInterceptor
    提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。
    org.omg.PortableInterceptor.ORBInitInfoPackage
    该包包含OMG便携式拦截器规范 ptc/2000-08-06 ，第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。
    org.omg.PortableServer
    提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
    org.omg.PortableServer.CurrentPackage
    提供方法实现，访问方法被调用的对象的标识。
    org.omg.PortableServer.POAManagerPackage
    封装与之相关的POA的处理状态。
    org.omg.PortableServer.POAPackage
    允许程序员构建可在不同ORB产品之间移植的对象实现。
    org.omg.SendingContext
    为组合值类型提供支持。
    org.omg.stub.java.rmi
    包含 java.rmi软件包中出现的远程类型的RMI-IIOP存根。
    org.w3c.dom
    提供文档对象模型（DOM）的接口。
    org.w3c.dom.events
    提供DOM Level 2事件的接口。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.w3c.dom.ranges
    提供DOM Level 2范围的界面。
    org.w3c.dom.xpath
    提供DOM Level 3 XPath规范的接口。
    org.xml.sax
    提供核心SAX API。
    org.xml.sax.ext
    提供与符合SAX驱动程序不一定支持的SAX2设施的接口。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。
  • Classes in java.io used by com.sun.jarsigner
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by com.sun.javadoc
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.jdi
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.jdi.connect
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.jdi.connect.spi
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.jdi.request
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.management
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.net.httpserver
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
  • Classes in java.io used by com.sun.net.httpserver.spi
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by com.sun.nio.sctp
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.security.auth
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.security.auth.callback
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by com.sun.security.jgss
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.source.doctree
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.source.tree
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.source.util
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.tools.attach
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by com.sun.tools.attach.spi
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by com.sun.tools.javac
    Class 描述
    PrintWriter
    将对象的格式表示打印到文本输出流。
  • Classes in java.io used by com.sun.tools.javadoc
    Class 描述
    PrintWriter
    将对象的格式表示打印到文本输出流。
  • Classes in java.io used by com.sun.tools.jconsole
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.applet
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt
    Class 描述
    File
    文件和目录路径名的抽象表示。
    FilenameFilter
    用于实现此接口的类的实例用于过滤文件名。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectOutputStream
    ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.color
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.datatransfer
    Class 描述
    Externalizable
    只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。
    IOException
    表示发生某种类型的I / O异常。
    ObjectInput
    ObjectInput扩展了DataInput接口以包含对象的读取。
    ObjectOutput
    ObjectOutput扩展了DataOutput接口，包括写入对象。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.desktop
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.dnd
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.event
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.font
    Class 描述
    InvalidObjectException
    表示一个或多个反序列化对象失败的验证测试。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.geom
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.image
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.image.renderable
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.awt.print
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.beans
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.beans.beancontext
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectInputStream
    ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
    ObjectOutputStream
    ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.io
    Class 描述
    BufferedReader
    从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
    CharArrayWriter
    该类实现了可以用作Writer的字符缓冲区。
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    Console
    访问与当前Java虚拟机关联的基于字符的控制台设备（如果有的话）的方法。
    DataInput
    DataInput接口提供从二进制流读取字节并从其中重建任何Java基本类型的数据。
    DataOutput
    DataOutput接口提供将数据从任何Java基本类型转换为一系列字节，并将这些字节写入二进制流。
    File
    文件和目录路径名的抽象表示。
    FileDescriptor
    文件描述符类的实例用作表示打开文件，开放套接字或其他字节源或信宿的底层机器特定结构的不透明句柄。
    FileFilter
    抽象路径名的过滤器。
    FilenameFilter
    用于实现此接口的类的实例用于过滤文件名。
    FileNotFoundException
    指示尝试打开由指定路径名表示的文件失败。
    FilterInputStream
    A FilterInputStream包含一些其他输入流，它用作其基本的数据源，可能会沿着路径转换数据或提供附加功能。
    FilterOutputStream
    这个类是过滤输出流的所有类的超类。
    FilterReader
    用于读取过滤后的字符流的抽象类。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    InputStreamReader
    InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。
    InvalidObjectException
    表示一个或多个反序列化对象失败的验证测试。
    IOException
    表示发生某种类型的I / O异常。
    NotActiveException
    序列化或反序列化不活跃时抛出。
    ObjectInput
    ObjectInput扩展了DataInput接口以包含对象的读取。
    ObjectInputFilter
    反序列化过程中过滤类，数组长度和图形指标。
    ObjectInputFilter.FilterInfo
    FilterInfo提供对反序列化当前对象和ObjectInputStream的状态的信息的访问 。
    ObjectInputFilter.Status
    对类的检查状态，数组长度，引用次数，深度和流大小。
    ObjectInputStream.GetField
    提供对从输入流读取的持久性字段的访问。
    ObjectInputValidation
    回调界面允许验证图中的对象。
    ObjectOutput
    ObjectOutput扩展了DataOutput接口，包括写入对象。
    ObjectOutputStream.PutField
    提供对要写入ObjectOutput的持久字段的编程访问。
    ObjectStreamClass
    序列化的类的描述符。
    ObjectStreamConstants
    写入对象序列化流的常量。
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    ObjectStreamField
    Serializable类的Serializable字段的描述。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    OutputStreamWriter
    OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入其的字符编码为字节。
    PipedInputStream
    管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。
    PipedOutputStream
    管道输出流可以连接到管道输入流以创建通信管道。
    PipedReader
    流水字符输入流。
    PipedWriter
    流水字符输出流。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    SerializablePermission
    这个类用于Serializable权限。
    StreamCorruptedException
    当从对象流读取的控制信息违反内部一致性检查时抛出。
    StringWriter
    在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。
    SyncFailedException
    发出同步操作失败的信号。
    UnsupportedEncodingException
    字符编码不支持。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by java.lang
    Class 描述
    Console
    访问与当前Java虚拟机关联的基于字符的控制台设备（如果有的话）的方法。
    File
    文件和目录路径名的抽象表示。
    FileDescriptor
    文件描述符类的实例用作表示打开文件，开放套接字或其他字节源或信宿的底层机器特定结构的不透明句柄。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    UnsupportedEncodingException
    字符编码不支持。
  • Classes in java.io used by java.lang.annotation
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.lang.instrument
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.lang.invoke
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.lang.management
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.lang.module
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.lang.reflect
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.math
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.net
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    FileDescriptor
    文件描述符类的实例用作表示打开文件，开放套接字或其他字节源或信宿的底层机器特定结构的不透明句柄。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    InterruptedIOException
    表示I / O操作已中断。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    UnsupportedEncodingException
    字符编码不支持。
  • Classes in java.io used by java.nio
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.nio.channels
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by java.nio.channels.spi
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by java.nio.charset
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.nio.file
    Class 描述
    BufferedReader
    从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
    BufferedWriter
    将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.nio.file.attribute
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.nio.file.spi
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
  • Classes in java.io used by java.rmi
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.rmi.activation
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.rmi.dgc
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.rmi.server
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    DataInput
    DataInput接口提供从二进制流读取字节，并从其中重建任何Java基元类型的数据。
    DataOutput
    DataOutput接口提供了将数据从任何Java基本类型转换为一系列字节，并将这些字节写入二进制流。
    Externalizable
    只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。
    FilterOutputStream
    这个类是过滤输出流的所有类的超类。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    IOException
    表示发生某种类型的I / O异常。
    ObjectInput
    ObjectInput扩展了DataInput接口以包含对象的读取。
    ObjectInputFilter
    反序列化过程中过滤类，数组长度和图形指标。
    ObjectOutput
    ObjectOutput扩展了DataOutput接口，包括写入对象。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    StreamCorruptedException
    当从对象流读取的控制信息违反内部一致性检查时抛出。
  • Classes in java.io used by java.security
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    FilterInputStream
    A FilterInputStream包含一些其他输入流，它使用它作为其基本的数据源，可能会沿途转换数据或提供附加功能。
    FilterOutputStream
    这个类是过滤输出流的所有类的超类。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.security.acl
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.security.cert
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.security.interfaces
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.security.spec
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.sql
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    PrintStream
    A PrintStream向另一个输出流添加功能，即方便地打印各种数据值的表示的能力。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by java.text
    Class 描述
    InvalidObjectException
    表示一个或多个反序列化对象失败的验证测试。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.time
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.time.chrono
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.time.format
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.time.temporal
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.time.zone
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    FileNotFoundException
    指示尝试打开由指定路径名表示的文件失败。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    UnsupportedEncodingException
    字符编码不支持。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by java.util.concurrent
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util.concurrent.atomic
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util.concurrent.locks
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util.jar
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    FilterInputStream
    A FilterInputStream包含一些其他输入流，它用作其基本的数据源，可能会沿着路径转换数据或提供附加功能。
    FilterOutputStream
    这个类是过滤输出流的所有类的超类。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util.logging
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    UnsupportedEncodingException
    字符编码不支持。
  • Classes in java.io used by java.util.prefs
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util.regex
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util.spi
    Class 描述
    PrintStream
    A PrintStream向另一个输出流添加功能，即可方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
  • Classes in java.io used by java.util.stream
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by java.util.zip
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    FilterInputStream
    A FilterInputStream包含一些其他输入流，它用作数据的基本来源，可能会沿着数据方向转换或提供附加功能。
    FilterOutputStream
    这个类是过滤输出流的所有类的超类。
    Flushable
    A Flushable是可以刷新的数据的目标。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.animation
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.application
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.concurrent
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.css
    Class 描述
    DataInputStream
    数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
    DataOutputStream
    数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
    File
    文件和目录路径名的抽象表示。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.css.converter
    Class 描述
    DataInputStream
    数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
    DataOutputStream
    数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by javafx.embed.swing
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.event
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.fxml
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.geometry
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.print
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.chart
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.control
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.control.skin
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.effect
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.image
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.input
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.layout
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.media
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.paint
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.shape
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.text
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.transform
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.scene.web
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.stage
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javafx.util
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.accessibility
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
  • Classes in java.io used by javax.activation
    Class 描述
    Externalizable
    只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectInput
    ObjectInput扩展了DataInput接口以包含对象的读取。
    ObjectOutput
    ObjectOutput扩展了DataOutput接口，包括写入对象。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.activity
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.annotation
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.annotation.processing
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.crypto
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    FilterInputStream
    A FilterInputStream包含一些其他输入流，它使用它作为其基本的数据源，可能会沿着路径转换数据或提供附加功能。
    FilterOutputStream
    这个类是过滤输出流的所有类的超类。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.crypto.interfaces
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.crypto.spec
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.imageio
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.imageio.metadata
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.imageio.spi
    Class 描述
    File
    文件和目录路径名的抽象表示。
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by javax.imageio.stream
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    DataInput
    DataInput接口提供从二进制流读取字节并从其中重建任何Java原语类型的数据。
    DataOutput
    DataOutput接口提供将数据从任何Java基本类型转换为一系列字节，并将这些字节写入二进制流。
    File
    文件和目录路径名的抽象表示。
    FileNotFoundException
    指示尝试打开由指定路径名表示的文件失败。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    RandomAccessFile
    该类的实例支持读取和写入随机访问文件。
  • Classes in java.io used by javax.jnlp
    Class 描述
    DataInput
    DataInput接口提供从二进制流读取字节并从其中重建任何Java原语类型的数据。
    DataOutput
    DataOutput接口提供将数据从任何Java基本类型转换为一系列字节，并将这些字节写入二进制流。
    File
    文件和目录路径名的抽象表示。
    FileNotFoundException
    指示尝试打开由指定路径名表示的文件失败。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.jws
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.jws.soap
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.lang.model
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.lang.model.element
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.lang.model.type
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.lang.model.util
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.management
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    ObjectInputStream
    ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.loading
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    Externalizable
    只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectInput
    ObjectInput扩展了DataInput接口以包含对象的读取。
    ObjectOutput
    ObjectOutput扩展了DataOutput接口，包括写入对象。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.modelmbean
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.monitor
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.openmbean
    Class 描述
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.relation
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.remote
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.remote.rmi
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.management.timer
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.naming
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.naming.directory
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.naming.event
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.naming.ldap
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.naming.spi
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.net
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by javax.net.ssl
    Class 描述
    Closeable
    A Closeable是可以关闭的数据源或目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.print
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.print.attribute
    Class 描述
    ObjectStreamException
    对象流类别特有的所有异常的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.print.attribute.standard
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.print.event
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.rmi.CORBA
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    ObjectInputStream
    ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
    ObjectOutputStream
    ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.rmi.ssl
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.script
    Class 描述
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.security.auth
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.security.auth.callback
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.security.auth.kerberos
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.security.auth.login
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.security.auth.x500
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.security.cert
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.security.sasl
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.smartcardio
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.sound.midi
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.sound.midi.spi
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
  • Classes in java.io used by javax.sound.sampled
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.sound.sampled.spi
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
  • Classes in java.io used by javax.sql
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.sql.rowset
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.sql.rowset.serial
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.sql.rowset.spi
    Class 描述
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.swing
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    FilterInputStream
    A FilterInputStream包含一些其他输入流，它用作数据的基本来源，可能会沿着数据转换或提供附加功能。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.border
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.colorchooser
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.event
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.filechooser
    Class 描述
    File
    文件和目录路径名的抽象表示。
    FileNotFoundException
    指示尝试打开由指定路径名表示的文件失败。
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by javax.swing.plaf
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.plaf.basic
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.plaf.metal
    Class 描述
    File
    文件和目录路径名的抽象表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.plaf.multi
    Class 描述
    File
    文件和目录路径名的抽象表示。
  • Classes in java.io used by javax.swing.plaf.nimbus
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.plaf.synth
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.table
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.text
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectInputStream
    ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
    ObjectOutputStream
    ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    PrintStream
    A PrintStream为另一个输出流添加了功能，即方便地打印各种数据值的表示的能力。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.swing.text.html
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.swing.text.html.parser
    Class 描述
    DataInputStream
    数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
    IOException
    表示发生某种类型的I / O异常。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.text.rtf
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.swing.tree
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.swing.undo
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.tools
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    File
    文件和目录路径名的抽象表示。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.transaction
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.transaction.xa
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.bind
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.xml.bind.annotation
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.bind.helpers
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    UnsupportedEncodingException
    字符编码不支持。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.xml.catalog
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.crypto
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.crypto.dsig
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.datatype
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.namespace
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.parsers
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.soap
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.stream
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.xml.stream.events
    Class 描述
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.xml.transform
    Class 描述
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.transform.stream
    Class 描述
    File
    文件和目录路径名的抽象表示。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by javax.xml.validation
    Class 描述
    File
    文件和目录路径名的抽象表示。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.ws
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.ws.handler
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.ws.http
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.ws.soap
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by javax.xml.ws.spi.http
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
  • Classes in java.io used by javax.xml.xpath
    Class 描述
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    PrintWriter
    将对象的格式表示打印到文本输出流。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.dynalink
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.dynalink.beans
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.dynalink.linker
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.incubator.http
    Class 描述
    FileNotFoundException
    指示尝试打开由指定路径名表示的文件失败。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.javadoc.doclet
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.jshell
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.jshell.execution
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    ObjectInput
    ObjectInput扩展了DataInput接口以包含对象的读取。
    ObjectOutput
    ObjectOutput扩展了DataOutput接口，包括写入对象。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
  • Classes in java.io used by jdk.jshell.spi
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    PrintStream
    A PrintStream向另一个输出流添加功能，即方便地打印各种数据值的表示的能力。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.jshell.tool
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    PrintStream
    A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
  • Classes in java.io used by jdk.nashorn.api.scripting
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    IOException
    表示发生某种类型的I / O异常。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.nashorn.api.tree
    Class 描述
    File
    文件和目录路径名的抽象表示。
    IOException
    表示发生某种类型的I / O异常。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.net
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by jdk.security.jarsigner
    Class 描述
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by netscape.javascript
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.ietf.jgss
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CORBA
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CORBA.DynAnyPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CORBA.ORBPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CORBA.TypeCodePackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CORBA.portable
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CORBA_2_3.portable
    Class 描述
    Closeable
    A Closeable是可以关闭的数据的源或目的地。
    Flushable
    A Flushable是可以刷新的数据的目的地。
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CosNaming
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CosNaming.NamingContextExtPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.CosNaming.NamingContextPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.Dynamic
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.DynamicAny
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.DynamicAny.DynAnyFactoryPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.DynamicAny.DynAnyPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.IOP
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.IOP.CodecFactoryPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.IOP.CodecPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.PortableInterceptor
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.PortableInterceptor.ORBInitInfoPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.PortableServer
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.PortableServer.CurrentPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.PortableServer.POAManagerPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.PortableServer.POAPackage
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.SendingContext
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.omg.stub.java.rmi
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.w3c.dom
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.w3c.dom.events
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.w3c.dom.ls
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    OutputStream
    这个抽象类是表示字节输出流的所有类的超类。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
    Writer
    用于写入字符流的抽象类。
  • Classes in java.io used by org.w3c.dom.ranges
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.w3c.dom.xpath
    Class 描述
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.xml.sax
    Class 描述
    InputStream
    这个抽象类是表示输入字节流的所有类的超类。
    IOException
    表示发生某种类型的I / O异常。
    Reader
    用于读取字符流的抽象类。
    Serializable
    类的序列化由实现java.io.Serializable接口的类启用。
  • Classes in java.io used by org.xml.sax.ext
    Class 描述
    IOException
    表示发生某种类型的I / O异常。
  • Classes in java.io used by org.xml.sax.helpers
    Class 描述
    IOException
    Signals that an I/O exception of some sort has occurred.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


UTFDataFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class UTFDataFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.UTFDataFormatException
  • All Implemented Interfaces:
    Serializable

    public class UTFDataFormatException
extends IOException
    表示modified UTF-8格式的格式不正确的字符串已被读入数据输入流或实现数据输入接口的任何类。 有关读取和写入修改的UTF-8字符串的格式，请参阅DataInput类描述。
    从以下版本开始：
    1.0
    另请参见：
    DataInput ， DataInputStream.readUTF(java.io.DataInput) ， IOException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UTFDataFormatException​()
      构造 UTFDataFormatException其中包含 null作为其错误详细消息。
      UTFDataFormatException​(String s)
      构造具有指定详细消息的 UTFDataFormatException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UTFDataFormatException

        public UTFDataFormatException​()
        构造一个 UTFDataFormatException其中包含 null作为其错误详细消息。

      • UTFDataFormatException

        public UTFDataFormatException​(String s)
        构造具有指定详细消息的UTFDataFormatException 。 字符串s可以稍后由检索Throwable.getMessage()类的方法java.lang.Throwable 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WriteAbortedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class WriteAbortedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.ObjectStreamException
            • java.io.WriteAbortedException
  • All Implemented Interfaces:
    Serializable

    public class WriteAbortedException
extends ObjectStreamException
    指示在写入操作期间抛出ObjectStreamExceptions之一。 在写入操作期间抛出ObjectStreamExceptions之一时，在读取操作期间抛出。 在详细信息字段中可以找到终止写入的异常。 流被重置为它的初始状态，并且所有对已经反序列化的对象的引用都被丢弃。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 在建造时提供并通过公共detail字段访问的“异常导致中止”现在被称为原因 ，并且可以通过Throwable.getCause()方法以及前述的“遗留字段”来访问。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      异常 detail
      写入ObjectStream时被捕获的异常。

    • 构造方法摘要

      构造方法
      Constructor 描述
      WriteAbortedException​(String s, 异常 ex)
      构造一个WriteAbortedException，其中包含一个描述异常的字符串，异常导致中止。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回终止操作的异常（ 原因 ）。
      String getMessage​()
      生成消息并将嵌套异常中的消息包含在内。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 字段详细信息

      • detail

        public 异常 detail
        写入ObjectStream时被捕获的异常。

        该领域早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

    • 构造方法详细信息

      • WriteAbortedException

        public WriteAbortedException​(String s,
                             异常 ex)
        构造一个WriteAbortedException，其中包含一个描述异常的字符串，异常导致中止。
        参数
        s - 描述异常的字符串。
        ex - 异常导致中止。

    • 方法详细信息

      • getMessage

        public String getMessage​()
        生成消息并将嵌套异常中的消息包含在内。
        重写：
        getMessage在 Throwable
        结果
        该 Throwable实例的详细消息字符串（可能为 null ）。

      • getCause

        public Throwable getCause​()
        返回终止操作的异常（ 原因 ）。
        重写：
        getCause在类 Throwable
        结果
        终止操作的异常（ 原因 ），可能为null。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Writer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.io

Class Writer

  • java.lang.Object
    • java.io.Writer
  • All Implemented Interfaces:
    Closeable ， Flushable ， Appendable ， AutoCloseable
    已知直接子类：
    BufferedWriter ， CharArrayWriter ， FilterWriter ， OutputStreamWriter ， PipedWriter ， PrintWriter ， StringWriter

    public abstract class Writer
extends Object
implements Appendable, Closeable, Flushable
    用于写入字符流的抽象类。 子类必须实现的唯一方法是write（char []，int，int），flush（）和close（）。 然而，大多数子类将覆盖这里定义的一些方法，以便提供更高的效率，附加的功能或两者。
    从以下版本开始：
    1.1
    另请参见：
    BufferedWriter ， CharArrayWriter ， FilterWriter ， OutputStreamWriter ， FileWriter ， PipedWriter ， PrintWriter ， StringWriter ， Reader

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected Object lock
      用于同步此流上的操作的对象。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Writer​()
      创建一个新的人物流作家，其关键部分将在作者本身上同步。
      protected Writer​(Object lock)
      创建一个新的字符流写入器，其关键部分将在给定对象上进行同步。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Writer append​(char c)
      将指定的字符附加到此作者。
      Writer append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      Writer append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      abstract void close​()
      关闭流，先刷新。
      abstract void flush​()
      刷新流。
      void write​(char[] cbuf)
      写入一个字符数组。
      abstract void write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void write​(int c)
      写一个字符
      void write​(String str)
      写一个字符串
      void write​(String str, int off, int len)
      写一个字符串的一部分。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • lock

        protected Object lock
        用于同步此流上的操作的对象。 为了效率，字符流对象可以使用自身以外的对象来保护关键部分。 因此，子类应该使用此字段中的对象，而不是使用this或同步方法。

    • 构造方法详细信息

      • Writer

        protected Writer​()
        创建一个新的人物流作家，其关键部分将在作者本身上同步。

      • Writer

        protected Writer​(Object lock)
        创建一个新的字符流写入器，其关键部分将在给定对象上进行同步。
        参数
        lock - 要同步的对象

    • 方法详细信息

      • write

        public void write​(int c)
           throws IOException
        写一个字符 要写入的字符包含在给定整数值的16个低位中; 16个高位被忽略。

        旨在支持高效单字符输出的子类应该覆盖此方法。

        参数
        c - int指定要写入的字符
        异常
        IOException - 如果发生I / O错误

      • write

        public void write​(char[] cbuf)
           throws IOException
        写入一个字符数组。
        参数
        cbuf - 要写入的字符数组
        异常
        IOException - 如果发生I / O错误

      • write

        public abstract void write​(char[] cbuf,
                           int off,
                           int len)
                    throws IOException
        写入字符数组的一部分。
        参数
        cbuf - 字符数组
        off - 开始写入字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负数或 len为负数或 off + len为负数或大于给定数组的长度， IndexOutOfBoundsException执行此异常
        IOException - 如果发生I / O错误

      • write

        public void write​(String str)
           throws IOException
        写一个字符串
        参数
        str - 要写入的字符串
        异常
        IOException - 如果发生I / O错误

      • write

        public void write​(String str,
                  int off,
                  int len)
           throws IOException
        写一个字符串的一部分。
        实现要求：
        该类的IndexOutOfBoundsException为指定的条件抛出一个IndexOutOfBoundsException ; 压倒一切的方法可能会选择其他方式。
        参数
        str - 一个字符串
        off - 开始写入字符的偏移量
        len - 要写入的字符数
        异常
        IndexOutOfBoundsException - 如果 off为负，或者 len为负，则实现应抛出此异常，或 off + len为负或大于给定字符串的长度
        IOException - 如果发生I / O错误

      • append

        public Writer append​(CharSequence csq)
              throws IOException
        将指定的字符序列附加到此作者。

        这种out.append(csq)形式的方法的调用与调用的方式完全相同

          out.write(csq.toString())

        取决于规范toString字符序列csq ，整个序列可以不追加。 例如，调用字符缓冲区的toString方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

        Specified by:
        append在接口 Appendable
        参数
        csq - 要追加的字符序列。 如果csq是null ，则这个写入器附加四个字符"null" 。
        结果
        这位作家
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.5

      • append

        public Writer append​(CharSequence csq,
                     int start,
                     int end)
              throws IOException
        将指定字符序列的子序列附加到此作者。 Appendable 。

        形式的这种方法的调用out.append(csq, start, end)时csq不是null完全相同的方式调用的行为

           out.write(csq.subSequence(start, end).toString())
        Specified by:
        append在接口 Appendable
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，那么字符将被追加，就像csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        这位作家
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，则 start大于 end ，或 end大于 csq.length()
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.5

      • append

        public Writer append​(char c)
              throws IOException
        将指定的字符附加到此作者。

        调用此方法的形式为out.append(c)行为与调用的方式完全相同

          out.write(c)
        Specified by:
        append在接口 Appendable
        参数
        c - 要追加的16位字符
        结果
        这位作家
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.5

      • flush

        public abstract void flush​()
                    throws IOException
        刷新流。 如果流已经从缓冲区中的各种write（）方法保存了任何字符，请将它们立即写入到其预期目的地。 然后，如果该目的地是另一个字符或字节流，请将其刷新。 因此，一个flush（）调用将刷新Writers和OutputStreams链中的所有缓冲区。

        如果此流的预期目标是由底层操作系统（例如文件）提供的抽象，那么刷新流仅保证先前写入流的字节传递到操作系统进行写入; 它并不保证它们实际上被写入物理设备，如磁盘驱动器。

        Specified by:
        flush在接口 Flushable
        异常
        IOException - 如果发生I / O错误

      • close

        public abstract void close​()
                    throws IOException
        关闭流，先刷新。 一旦流已关闭，进一步的write（）或flush（）调用将导致抛出IOException。 关闭以前关闭的流无效。
        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class java.io.BufferedInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.BufferedInputStream

No usage of java.io.BufferedInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.BufferedOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.BufferedOutputStream

No usage of java.io.BufferedOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.BufferedReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.BufferedReader

  • Packages that use BufferedReader
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of BufferedReader in java.io

      Subclasses of BufferedReader in java.io
      Modifier and Type Class 描述
      class  LineNumberReader
      缓冲字符输入流，跟踪行号。

    • Uses of BufferedReader in java.nio.file

      Methods in java.nio.file that return BufferedReader
      Modifier and Type 方法 描述
      static BufferedReader Files.newBufferedReader​(Path path)
      打开一个文件进行阅读，返回一个 BufferedReader以高效的方式从文件读取文本。
      static BufferedReader Files.newBufferedReader​(Path path, Charset cs)
      打开一个文件进行阅读，返回一个 BufferedReader ，可以用来以高效的方式从文件读取文本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.BufferedWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.BufferedWriter

  • Packages that use BufferedWriter
    软件包 描述
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

    • Uses of BufferedWriter in java.nio.file

      Methods in java.nio.file that return BufferedWriter
      Modifier and Type 方法 描述
      static BufferedWriter Files.newBufferedWriter​(Path path, Charset cs, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter ，可以用来以有效的方式将文本写入文件。
      static BufferedWriter Files.newBufferedWriter​(Path path, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter以高效的方式写入文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ByteArrayInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ByteArrayInputStream

No usage of java.io.ByteArrayInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ByteArrayOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ByteArrayOutputStream

No usage of java.io.ByteArrayOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.CharArrayReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.CharArrayReader

No usage of java.io.CharArrayReader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.CharArrayWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.CharArrayWriter

  • Packages that use CharArrayWriter
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of CharArrayWriter in java.io

      Methods in java.io that return CharArrayWriter
      Modifier and Type 方法 描述
      CharArrayWriter CharArrayWriter.append​(char c)
      将指定的字符附加到此作者。
      CharArrayWriter CharArrayWriter.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      CharArrayWriter CharArrayWriter.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.CharConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.CharConversionException

No usage of java.io.CharConversionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.Console (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.Console

  • Packages that use Console
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of Console in java.io

      Methods in java.io that return Console
      Modifier and Type 方法 描述
      Console Console.format​(String fmt, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流。
      Console Console.printf​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流的便利方法。

    • Uses of Console in java.lang

      Methods in java.lang that return Console
      Modifier and Type 方法 描述
      static Console System.console​()
      返回与当前Java虚拟机关联的唯一的Console对象（如果有）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.DataInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.DataInputStream

  • Packages that use DataInputStream
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。

    • Uses of DataInputStream in javafx.css

      Methods in javafx.css with parameters of type DataInputStream
      Modifier and Type | 方法 | 描述
      static StyleConverter<?,?> StyleConverter.readBinary​(DataInputStream is, String[] strings)
      读取二进制数据流。
      static String[] | StyleConverter.StringStore.readBinary​(DataInputStream is)

    • Uses of DataInputStream in javafx.css.converter

      Methods in javafx.css.converter with parameters of type DataInputStream
      Modifier and Type | 方法 | 描述
      static StyleConverter<?,?> | EnumConverter.readBinary​(DataInputStream is, String[] strings)

    • Uses of DataInputStream in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser with parameters of type DataInputStream
      Modifier and Type 方法 描述
      void DTD.read​(DataInputStream in)
      从归档格式重新创建DTD。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.DataOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.DataOutputStream

  • Packages that use DataOutputStream
    软件包 描述
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。

    • Uses of DataOutputStream in javafx.css

      Methods in javafx.css with parameters of type DataOutputStream
      Modifier and Type | 方法 | 描述
      protected void | CompoundSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      protected void | Selector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      protected void | SimpleSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      void | StyleConverter.StringStore.writeBinary​(DataOutputStream os)
      void StyleConverter.writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)
      写二进制数据。

    • Uses of DataOutputStream in javafx.css.converter

      Methods in javafx.css.converter with parameters of type DataOutputStream
      Modifier and Type | 方法 | 描述
      void | EnumConverter.writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.EOFException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.EOFException

No usage of java.io.EOFException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.File (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.File

  • Packages that use File
    软件包 描述
    com.sun.javadoc
    注意：该包装中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javax.activation
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.filechooser
    包含 JFileChooser组件使用的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.transform.stream
    提供流和URI特定的转换类。
    javax.xml.validation
    提供用于验证XML文档的API。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

    • Uses of File in com.sun.javadoc

      Methods in com.sun.javadoc that return File
      Modifier and Type 方法 描述
      File SourcePosition.file​()
      已过时。
      源文件。

    • Uses of File in java.awt

      Methods in java.awt that return File
      Modifier and Type 方法 描述
      File[] FileDialog.getFiles​()
      返回用户选择的文件。
      Methods in java.awt with parameters of type File
      Modifier and Type 方法 描述
      void Desktop.browseFileDirectory​(File file)
      打开包含 file的文件夹，并在默认的系统文件管理器中选择它。
      static Font Font.createFont​(int fontFormat, File fontFile)
      使用指定的字体类型和指定的字体文件返回新的 Font 。
      static Font[] Font.createFonts​(File fontFile)
      返回从指定文件解码的新数组 Font 。
      void Desktop.edit​(File file)
      启动相关的编辑器应用程序并打开一个文件进行编辑。
      boolean Desktop.moveToTrash​(File file)
      将指定的文件移动到垃圾桶。
      void Desktop.open​(File file)
      启动相关应用程序以打开文件。
      void Desktop.print​(File file)
      使用相关应用程序的打印命令打印本机桌面打印设备的文件。

    • Uses of File in java.awt.desktop

      Methods in java.awt.desktop that return types with arguments of type File
      Modifier and Type 方法 描述
      List<File> FilesEvent.getFiles​()
      获取文件列表
      Constructor parameters in java.awt.desktop with type arguments of type File
      Constructor 描述
      OpenFilesEvent​(List<File> files, String searchTerm)
      构造一个 OpenFilesEvent
      PrintFilesEvent​(List<File> files)
      构造一个 PrintFilesEvent

    • Uses of File in java.io

      Methods in java.io that return File
      Modifier and Type 方法 描述
      static File File.createTempFile​(String prefix, String suffix)
      在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。
      static File File.createTempFile​(String prefix, String suffix, File directory)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      File File.getAbsoluteFile​()
      返回此抽象路径名的绝对形式。
      File File.getCanonicalFile​()
      返回此抽象路径名的规范形式。
      File File.getParentFile​()
      返回此抽象路径名的父对象的抽象路径名，如果此路径名未指定父目录，则返回 null 。
      File[] File.listFiles​()
      返回一个抽象路径名数组，表示由该抽象路径名表示的目录中的文件。
      File[] File.listFiles​(FileFilter filter)
      返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
      File[] File.listFiles​(FilenameFilter filter)
      返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
      static File[] File.listRoots​()
      列出可用的文件系统根。
      Methods in java.io with parameters of type File
      Modifier and Type 方法 描述
      boolean FileFilter.accept​(File pathname)
      测试指定的抽象路径名是否应包含在路径名列表中。
      boolean FilenameFilter.accept​(File dir, String name)
      测试指定文件是否应包含在文件列表中。
      int File.compareTo​(File pathname)
      比较两个抽象的路径名字典。
      static File File.createTempFile​(String prefix, String suffix, File directory)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      boolean File.renameTo​(File dest)
      重命名由此抽象路径名表示的文件。
      Constructors in java.io with parameters of type File
      Constructor 描述
      File​(File parent, String child)
      从父抽象路径名和子路径名字符串创建新的 File实例。
      FileInputStream​(File file)
      通过打开与实际文件的连接来创建一个 FileInputStream ，该文件由文件系统中的 File对象 file命名。
      FileOutputStream​(File file)
      创建文件输出流以写入由指定的 File对象表示的文件。
      FileOutputStream​(File file, boolean append)
      创建文件输出流以写入由指定的 File对象表示的文件。
      FileReader​(File file)
      创建一个新的 FileReader ，给出 File读取。
      FileWriter​(File file)
      给一个File对象构造一个FileWriter对象。
      FileWriter​(File file, boolean append)
      给一个File对象构造一个FileWriter对象。
      PrintStream​(File file)
      使用指定的文件创建一个新的打印流，而不需要自动换行。
      PrintStream​(File file, String csn)
      使用指定的文件和字符集创建新的打印流，而不需要自动换行。
      PrintWriter​(File file)
      使用指定的文件创建一个新的PrintWriter，而不需要自动的线路刷新。
      PrintWriter​(File file, String csn)
      使用指定的文件和字符集创建一个新的PrintWriter，而不需要自动进行线条刷新。
      RandomAccessFile​(File file, String mode)
      创建一个随机访问文件流，从File参数指定的文件读取，并可选择写入。

    • Uses of File in java.lang

      Methods in java.lang that return File
      Modifier and Type 方法 描述
      File ProcessBuilder.directory​()
      返回此进程构建器的工作目录。
      File ProcessBuilder.Redirect.file​()
      返回File源或目标与此重定向或相关null ，如果没有这样的文件。
      Methods in java.lang with parameters of type File
      Modifier and Type 方法 描述
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.appendTo​(File file)
      返回重定向以附加到指定的文件。
      ProcessBuilder ProcessBuilder.directory​(File directory)
      设置此进程构建器的工作目录。
      Process Runtime.exec​(String[] cmdarray, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的命令和参数。
      Process Runtime.exec​(String command, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的字符串命令。
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.from​(File file)
      返回从指定文件读取的重定向。
      ProcessBuilder ProcessBuilder.redirectError​(File file)
      将此流程构建器的标准错误目标设置为文件。
      ProcessBuilder ProcessBuilder.redirectInput​(File file)
      将此流程构建器的标准输入源设置为文件。
      ProcessBuilder ProcessBuilder.redirectOutput​(File file)
      将此流程构建器的标准输出目标设置为文件。
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.to​(File file)
      返回写入指定文件的重定向。

    • Uses of File in java.nio.file

      Methods in java.nio.file that return File
      Modifier and Type 方法 描述
      default File Path.toFile​()
      返回表示此路径的File对象。

    • Uses of File in java.security

      Methods in java.security with parameters of type File
      Modifier and Type 方法 描述
      static KeyStore KeyStore.getInstance​(File file, char[] password)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。
      static KeyStore.Builder KeyStore.Builder.newInstance​(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
      返回一个新的Builder对象。

    • Uses of File in java.util

      Constructors in java.util with parameters of type File
      Constructor 描述
      Formatter​(File file)
      使用指定的文件构造一个新的格式化程序。
      Formatter​(File file, String csn)
      使用指定的文件和字符集构造一个新的格式化程序。
      Formatter​(File file, String csn, Locale l)
      使用指定的文件，字符集和区域设置构造一个新的格式化程序。
      Scanner​(File source)
      构造一个新的 Scanner ，产生从指定文件扫描的值。
      Scanner​(File source, String charsetName)
      构造一个新的 Scanner ，产生从指定文件扫描的值。

    • Uses of File in java.util.jar

      Methods in java.util.jar with parameters of type File
      Modifier and Type 方法 描述
      void Pack200.Unpacker.unpack​(File in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。
      Constructors in java.util.jar with parameters of type File
      Constructor 描述
      JarFile​(File file)
      创建一个新的 JarFile从指定的 File读取对象。
      JarFile​(File file, boolean verify)
      创建一个新的 JarFile从指定的 File对象读取。
      JarFile​(File file, boolean verify, int mode)
      创建新的 JarFile以指定的方式从指定的 File对象中读取。
      JarFile​(File file, boolean verify, int mode, Runtime.Version version)
      创建新的 JarFile以指定的模式从指定的 File对象读取。

    • Uses of File in java.util.zip

      Constructors in java.util.zip with parameters of type File
      Constructor 描述
      ZipFile​(File file)
      打开一个ZIP文件，读取指定的File对象。
      ZipFile​(File file, int mode)
      打开新的 ZipFile以指定的方式读取指定的 File对象。
      ZipFile​(File file, int mode, Charset charset)
      打开一个新的 ZipFile以指定的方式读取指定的 File对象。
      ZipFile​(File file, Charset charset)
      打开一个ZIP文件，读取指定的File对象。

    • Uses of File in javafx.css

      Methods in javafx.css with parameters of type File
      Modifier and Type 方法 描述
      static void Stylesheet.convertToBinary​(File source, File destination)
      将urlIn引用的.css文件转换为二进制格式并写入urlOut。

    • Uses of File in javafx.scene.input

      Methods in javafx.scene.input that return types with arguments of type File
      Modifier and Type 方法 描述
      List<File> Clipboard.getFiles​()
      从先前已注册的剪贴板获取文件列表。
      List<File> ClipboardContent.getFiles​()
      从以前已经放置的 ClipboardContent获取文件列表。
      Method parameters in javafx.scene.input with type arguments of type File
      Modifier and Type 方法 描述
      boolean ClipboardContent.putFiles​(List<File> files)
      将文件列表放入 ClipboardContent 。

    • Uses of File in javafx.scene.web

      Methods in javafx.scene.web that return File
      Modifier and Type 方法 描述
      File WebEngine.getUserDataDirectory​()
      获取属性userDataDirectory的值。
      Methods in javafx.scene.web that return types with arguments of type File
      Modifier and Type 方法 描述
      ObjectProperty<File> WebEngine.userDataDirectoryProperty​()
      指定此 WebEngine用于存储本地用户数据的目录。
      Methods in javafx.scene.web with parameters of type File
      Modifier and Type 方法 描述
      void WebEngine.setUserDataDirectory​(File value)
      设置属性userDataDirectory的值。

    • Uses of File in javafx.stage

      Methods in javafx.stage that return File
      Modifier and Type 方法 描述
      File DirectoryChooser.getInitialDirectory​()
      获取属性initialDirectory的值。
      File FileChooser.getInitialDirectory​()
      获取属性initialDirectory的值。
      File DirectoryChooser.showDialog​(Window ownerWindow)
      显示新的目录选择对话框。
      File FileChooser.showOpenDialog​(Window ownerWindow)
      显示一个新的文件打开对话框。
      File FileChooser.showSaveDialog​(Window ownerWindow)
      显示一个新的文件保存对话框。
      Methods in javafx.stage that return types with arguments of type File
      Modifier and Type 方法 描述
      ObjectProperty<File> DirectoryChooser.initialDirectoryProperty​()
      显示对话框的初始目录。
      ObjectProperty<File> FileChooser.initialDirectoryProperty​()
      显示文件对话框的初始目录。
      List<File> FileChooser.showOpenMultipleDialog​(Window ownerWindow)
      显示一个新的文件打开对话框，其中可以选择多个文件。
      Methods in javafx.stage with parameters of type File
      Modifier and Type 方法 描述
      void DirectoryChooser.setInitialDirectory​(File value)
      设置属性initialDirectory的值。
      void FileChooser.setInitialDirectory​(File value)
      设置属性initialDirectory的值。

    • Uses of File in javax.activation

      Methods in javax.activation that return File
      Modifier and Type 方法 描述
      File FileDataSource.getFile​()
      返回与此FileDataSource对应的File对象。
      Methods in javax.activation with parameters of type File
      Modifier and Type 方法 描述
      abstract String FileTypeMap.getContentType​(File file)
      返回文件对象的类型。
      String MimetypesFileTypeMap.getContentType​(File f)
      返回文件对象的MIME类型。
      Constructors in javax.activation with parameters of type File
      Constructor 描述
      FileDataSource​(File file)
      从File对象创建FileDataSource。

    • Uses of File in javax.imageio

      Methods in javax.imageio that return File
      Modifier and Type 方法 描述
      static File ImageIO.getCacheDirectory​()
      返回当前值设置由 setCacheDirectory ，或 null如果没有明确的设定已经取得进展。
      Methods in javax.imageio with parameters of type File
      Modifier and Type 方法 描述
      static BufferedImage ImageIO.read​(File input)
      作为对所提供的 File进行解码的结果，返回 BufferedImage ，其中自动从当前注册的 ImageReader选择。
      static void ImageIO.setCacheDirectory​(File cacheDirectory)
      设置要创建缓存文件的目录。
      static boolean ImageIO.write​(RenderedImage im, String formatName, File output)
      使用支持给定格式的任意 ImageWriter写入图像到 File 。

    • Uses of File in javax.imageio.spi

      Methods in javax.imageio.spi with parameters of type File
      Modifier and Type 方法 描述
      abstract ImageInputStream ImageInputStreamSpi.createInputStreamInstance​(Object input, boolean useCache, File cacheDir)
      返回与此服务提供商相关联的 ImageInputStream实现的实例。
      abstract ImageOutputStream ImageOutputStreamSpi.createOutputStreamInstance​(Object output, boolean useCache, File cacheDir)
      返回与该服务提供商相关联的 ImageOutputStream实现的实例。

    • Uses of File in javax.imageio.stream

      Constructors in javax.imageio.stream with parameters of type File
      Constructor 描述
      FileCacheImageInputStream​(InputStream stream, File cacheDir)
      构造一个 FileCacheImageInputStream ，它将从给定的 InputStream读取。
      FileCacheImageOutputStream​(OutputStream stream, File cacheDir)
      构造一个 FileCacheImageOutputStream ，它将写入给定的 outputStream 。
      FileImageInputStream​(File f)
      构造一个 FileImageInputStream ，它将从给定的 File读取。
      FileImageOutputStream​(File f)
      构造一个 FileImageOutputStream ，它将写入给定的 File 。

    • Uses of File in javax.jnlp

      Methods in javax.jnlp with parameters of type File
      Modifier and Type 方法 描述
      FileContents ExtendedService.openFile​(File file)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
      FileContents[] ExtendedService.openFiles​(File[] files)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。

    • Uses of File in javax.security.auth.kerberos

      Methods in javax.security.auth.kerberos with parameters of type File
      Modifier and Type 方法 描述
      static KeyTab KeyTab.getInstance​(File file)
      从绑定到未知服务主体的 File对象返回 KeyTab实例。
      static KeyTab KeyTab.getInstance​(KerberosPrincipal princ, File file)
      从绑定到指定服务主体的 File对象返回一个 KeyTab实例。
      static KeyTab KeyTab.getUnboundInstance​(File file)
      从 File对象返回未绑定的 KeyTab实例。

    • Uses of File in javax.sound.midi

      Methods in javax.sound.midi with parameters of type File
      Modifier and Type 方法 描述
      static MidiFileFormat MidiSystem.getMidiFileFormat​(File file)
      获取指定的 File的MIDI文件格式。
      static Sequence MidiSystem.getSequence​(File file)
      从指定的 File获取MIDI序列。
      static Soundbank MidiSystem.getSoundbank​(File file)
      构造一个 Soundbank通过从指定的阅读它 File 。
      static int MidiSystem.write​(Sequence in, int type, File out)
      写入表示所提供外部文件的MIDI文件类型的文件的字节流。

    • Uses of File in javax.sound.midi.spi

      Methods in javax.sound.midi.spi with parameters of type File
      Modifier and Type 方法 描述
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat​(File file)
      获得提供的 File的MIDI文件格式。
      abstract Sequence MidiFileReader.getSequence​(File file)
      从提供的 File获取MIDI序列。
      abstract Soundbank SoundbankReader.getSoundbank​(File file)
      从提供的 File获取一个 File库对象。
      abstract int MidiFileWriter.write​(Sequence in, int fileType, File out)
      写入表示所提供外部文件的文件类型的MIDI文件的字节流。

    • Uses of File in javax.sound.sampled

      Methods in javax.sound.sampled with parameters of type File
      Modifier and Type 方法 描述
      static AudioFileFormat AudioSystem.getAudioFileFormat​(File file)
      获取指定的 File的音频文件格式。
      static AudioInputStream AudioSystem.getAudioInputStream​(File file)
      从提供的 File获取音频输入流。
      static int AudioSystem.write​(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      将指定文件类型的音频文件的字节流写入提供的外部文件。

    • Uses of File in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi with parameters of type File
      Modifier and Type 方法 描述
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat​(File file)
      获得提供的 File的音频文件格式。
      abstract AudioInputStream AudioFileReader.getAudioInputStream​(File file)
      从提供的 File获取音频输入流。
      abstract int AudioFileWriter.write​(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      将表示所提供的外部文件的文件格式的音频文件的字节流写入。

    • Uses of File in javax.swing

      Methods in javax.swing that return File
      Modifier and Type 方法 描述
      File JFileChooser.getCurrentDirectory​()
      返回当前目录。
      File JFileChooser.getSelectedFile​()
      返回所选文件。
      File[] JFileChooser.getSelectedFiles​()
      如果文件选择器设置为允许多个选择，则返回所选文件的列表。
      Methods in javax.swing with parameters of type File
      Modifier and Type 方法 描述
      boolean JFileChooser.accept​(File f)
      如果文件应该显示，则返回true。
      void JFileChooser.ensureFileIsVisible​(File f)
      确保指定的文件是可见的，而不是隐藏。
      String JFileChooser.getDescription​(File f)
      返回文件描述。
      Icon JFileChooser.getIcon​(File f)
      返回此文件或文件类型的图标，具体取决于系统。
      String JFileChooser.getName​(File f)
      返回文件名。
      String JFileChooser.getTypeDescription​(File f)
      返回文件类型。
      boolean JFileChooser.isTraversable​(File f)
      如果可以访问文件（目录），则返回true。
      void JFileChooser.setCurrentDirectory​(File dir)
      设置当前目录。
      void JFileChooser.setSelectedFile​(File file)
      设置所选文件。
      void JFileChooser.setSelectedFiles​(File[] selectedFiles)
      如果文件选择器设置为允许多个选择，则设置所选文件的列表。
      Constructors in javax.swing with parameters of type File
      Constructor 描述
      JFileChooser​(File currentDirectory)
      构造一个 JFileChooser使用给定的 File作为路径。
      JFileChooser​(File currentDirectory, FileSystemView fsv)
      构造一个 JFileChooser使用给定的当前目录和 FileSystemView 。

    • Uses of File in javax.swing.filechooser

      Methods in javax.swing.filechooser that return File
      Modifier and Type | 方法 | 描述
      File FileSystemView.createFileObject​(File dir, String filename)
      返回从给定文件名在dir中构造的File对象。
      File FileSystemView.createFileObject​(String path)
      返回从给定的路径字符串构造的File对象。
      protected File FileSystemView.createFileSystemRoot​(File f)
      为 f创建一个新的 File对象，具有文件系统根目录的正确行为。
      abstract File FileSystemView.createNewFolder​(File containingDir)
      创建一个具有默认文件夹名称的新文件夹。
      File | FileSystemView.getChild​(File parent, String fileName)
      File[] FileSystemView.getChooserComboBoxFiles​()
      返回一个表示要在文件选择器选择器中默认显示的值的文件数组。
      File FileSystemView.getDefaultDirectory​()
      返回用户的文件选择器的默认启动目录。
      File[] FileSystemView.getFiles​(File dir, boolean useFileHiding)
      获取显示的列表（即不隐藏）文件。
      File FileSystemView.getHomeDirectory​()
      返回主目录。
      File FileSystemView.getLinkLocation​(File file)
      如果指定的文件是shell解释链接，则返回指定链接文件引用的常规文件。
      File FileSystemView.getParentDirectory​(File dir)
      返回父目录 dir 。
      File[] FileSystemView.getRoots​()
      返回此系统上的所有根分区。
      Methods in javax.swing.filechooser with parameters of type File
      Modifier and Type | 方法 | 描述
      abstract boolean FileFilter.accept​(File f)
      该过滤器是否接受给定的文件。
      boolean FileNameExtensionFilter.accept​(File f)
      测试指定的文件，如果文件被接受则返回true，否则返回false。
      File FileSystemView.createFileObject​(File dir, String filename)
      返回从给定文件名在dir中构造的File对象。
      protected File FileSystemView.createFileSystemRoot​(File f)
      为 f创建一个新的 File对象，具有文件系统根目录的正确行为。
      abstract File FileSystemView.createNewFolder​(File containingDir)
      创建一个具有默认文件夹名称的新文件夹。
      File | FileSystemView.getChild​(File parent, String fileName)
      String FileView.getDescription​(File f)
      该文件的人类可读描述。
      File[] FileSystemView.getFiles​(File dir, boolean useFileHiding)
      获取显示的列表（即不隐藏）文件。
      Icon FileView.getIcon​(File f)
      在 JFileChooser中表示此文件的 JFileChooser 。
      File FileSystemView.getLinkLocation​(File file)
      如果指定的文件是shell解释链接，则返回指定链接文件引用的常规文件。
      String FileView.getName​(File f)
      文件的名称。
      File FileSystemView.getParentDirectory​(File dir)
      返回父目录 dir 。
      String FileSystemView.getSystemDisplayName​(File f)
      在系统文件浏览器中显示的文件，目录或文件夹的名称。
      Icon FileSystemView.getSystemIcon​(File f)
      文件，目录或文件夹的图标，将显示在系统文件浏览器中。
      String FileSystemView.getSystemTypeDescription​(File f)
      键入在系统文件浏览器中显示的文件，目录或文件夹的描述。
      String FileView.getTypeDescription​(File f)
      对文件类型的可读描述。
      boolean FileSystemView.isComputerNode​(File dir)
      由UI类用于决定是否显示计算机节点的特殊图标，例如
      boolean FileSystemView.isDrive​(File dir)
      由UI类用于决定是否显示驱动器或分区的特殊图标，例如“硬盘”图标。
      boolean FileSystemView.isFileSystem​(File f)
      检查是否 f代表一个真正的目录或文件，而不是一个特殊的文件夹，如 "Desktop" 。
      boolean FileSystemView.isFileSystemRoot​(File dir)
      dir是文件系统中树的根，例如驱动器或分区。
      boolean FileSystemView.isFloppyDrive​(File dir)
      由UI类用于决定是否显示软盘的特殊图标。
      boolean FileSystemView.isHiddenFile​(File f)
      返回文件是否被隐藏。
      boolean FileSystemView.isLink​(File file)
      返回指定的文件是否表示可以通过 FileSystemView.getLinkLocation(File)获取的shell解释链接。
      boolean FileSystemView.isParent​(File folder, File file)
      在Windows上，文件可以出现在多个文件夹中，而不是文件系统中的父目录。
      boolean FileSystemView.isRoot​(File f)
      确定给定文件是否是可导航树中的根。
      Boolean FileSystemView.isTraversable​(File f)
      如果可以访问文件（目录），则返回true。
      Boolean FileView.isTraversable​(File f)
      该目录是否可遍历。

    • Uses of File in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type File
      Modifier and Type 方法 描述
      abstract void FileChooserUI.ensureFileIsVisible​(JFileChooser fc, File f)
      确保有问题的文件是可见的。

    • Uses of File in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic with type parameters of type File
      Modifier and Type Field 描述
      protected Hashtable<File,Icon> BasicFileChooserUI.BasicFileView.iconCache
      图标缓存
      Methods in javax.swing.plaf.basic that return File
      Modifier and Type 方法 描述
      protected File BasicFileChooserUI.getDirectory​()
      要记住UI中当前选择的目录的属性。
      Methods in javax.swing.plaf.basic that return types with arguments of type File
      Modifier and Type 方法 描述
      Vector<File> BasicDirectoryModel.getDirectories​()
      返回目录列表。
      Vector<File> BasicDirectoryModel.getFiles​()
      返回文件列表。
      Methods in javax.swing.plaf.basic with parameters of type File
      Modifier and Type 方法 描述
      boolean BasicFileChooserUI.AcceptAllFileFilter.accept​(File f)
      返回true。
      void BasicFileChooserUI.BasicFileView.cacheIcon​(File f, Icon i)
      缓存文件的图标。
      void BasicFileChooserUI.ensureFileIsVisible​(JFileChooser fc, File f)
      确保有问题的文件是可见的。
      Icon BasicFileChooserUI.BasicFileView.getCachedIcon​(File f)
      返回文件的缓存图标。
      String BasicFileChooserUI.BasicFileView.getDescription​(File f)
      该文件的人类可读描述。
      Icon BasicFileChooserUI.BasicFileView.getIcon​(File f)
      在 JFileChooser中代表此文件的 JFileChooser 。
      String BasicFileChooserUI.BasicFileView.getName​(File f)
      文件的名称。
      String BasicFileChooserUI.BasicFileView.getTypeDescription​(File f)
      对文件类型的可读描述。
      Boolean BasicFileChooserUI.BasicFileView.isHidden​(File f)
      返回是否隐藏文件。
      protected boolean BasicDirectoryModel.lt​(File a, File b)
      已过时 - 未使用
      boolean BasicDirectoryModel.renameFile​(File oldFile, File newFile)
      重命名底层文件系统中的文件。
      protected void BasicFileChooserUI.setDirectory​(File f)
      要记住UI中当前选择的目录的属性。
      Method parameters in javax.swing.plaf.basic with type arguments of type File
      Modifier and Type 方法 描述
      protected void BasicDirectoryModel.sort​(Vector<? extends File> v)
      排序文件列表。

    • Uses of File in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type File
      Modifier and Type | 方法 | 描述
      void | MetalFileChooserUI.ensureFileIsVisible​(JFileChooser fc, File f)

    • Uses of File in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type File
      Modifier and Type 方法 描述
      void MultiFileChooserUI.ensureFileIsVisible​(JFileChooser a, File b)
      在此对象处理的每个UI上调用 ensureFileIsVisible方法。

    • Uses of File in javax.tools

      Methods in javax.tools that return types with arguments of type File
      Modifier and Type 方法 描述
      Iterable<? extends File> StandardJavaFileManager.getLocation​(JavaFileManager.Location location)
      返回与给定位置相关联的搜索路径。
      Methods in javax.tools with parameters of type File
      Modifier and Type 方法 描述
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects​(File... files)
      返回表示给定文件的文件对象。
      Method parameters in javax.tools with type arguments of type File
      Modifier and Type 方法 描述
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromFiles​(Iterable<? extends File> files)
      返回表示给定文件的文件对象。
      void StandardJavaFileManager.setLocation​(JavaFileManager.Location location, Iterable<? extends File> files)
      将给定的搜索路径与给定位置相关联。

    • Uses of File in javax.xml.bind

      Methods in javax.xml.bind with parameters of type File
      Modifier and Type 方法 描述
      static void JAXB.marshal​(Object jaxbObject, File xml)
      将Java对象树写入XML并将其存储到指定的位置。
      void Marshaller.marshal​(Object jaxbElement, File output)
      将根据 jaxbElement的内容树 jaxbElement到一个文件中。
      static <T> T JAXB.unmarshal​(File xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      Object Unmarshaller.unmarshal​(File f)
      从指定的文件解组XML数据并返回生成的内容树。

    • Uses of File in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type File
      Modifier and Type | 方法 | 描述
      void | AbstractMarshallerImpl.marshal​(Object jaxbElement, File output)
      Object | AbstractUnmarshallerImpl.unmarshal​(File f)

    • Uses of File in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type File
      Modifier and Type 方法 描述
      Document DocumentBuilder.parse​(File f)
      将给定文件的内容解析为XML文档，并返回一个新的DOM Document对象。
      void SAXParser.parse​(File f, HandlerBase hb)
      使用指定的HandlerBase解析指定为XML的文件的内容。
      void SAXParser.parse​(File f, DefaultHandler dh)
      使用指定的DefaultHandler解析指定为XML的文件的内容。

    • Uses of File in javax.xml.transform.stream

      Methods in javax.xml.transform.stream with parameters of type File
      Modifier and Type 方法 描述
      void StreamResult.setSystemId​(File f)
      从 File参考设置系统ID。
      void StreamSource.setSystemId​(File f)
      从文件引用设置系统ID。
      Constructors in javax.xml.transform.stream with parameters of type File
      Constructor 描述
      StreamResult​(File f)
      从文件构造一个StreamResult。
      StreamSource​(File f)
      从文件构造一个StreamSource。

    • Uses of File in javax.xml.validation

      Methods in javax.xml.validation with parameters of type File
      Modifier and Type 方法 描述
      Schema SchemaFactory.newSchema​(File schema)
      将指定的 File解析为模式，并将其作为 Schema返回。

    • Uses of File in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree with parameters of type File
      Modifier and Type 方法 描述
      CompilationUnitTree Parser.parse​(File file, DiagnosticListener listener)
      解析源文件并返回编译单元树
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FileDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FileDescriptor

  • Packages that use FileDescriptor
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。

    • Uses of FileDescriptor in java.io

      Fields in java.io declared as FileDescriptor
      Modifier and Type Field 描述
      static FileDescriptor FileDescriptor.err
      标准错误流的句柄。
      static FileDescriptor FileDescriptor.in
      标准输入流的句柄。
      static FileDescriptor FileDescriptor.out
      标准输出流的句柄。
      Methods in java.io that return FileDescriptor
      Modifier and Type 方法 描述
      FileDescriptor FileInputStream.getFD​()
      返回表示与该 FileInputStream正在使用的文件系统中的实际文件的连接的 FileDescriptor对象。
      FileDescriptor FileOutputStream.getFD​()
      返回与此流相关联的文件描述符。
      FileDescriptor RandomAccessFile.getFD​()
      返回与此流关联的不透明文件描述符对象。
      Constructors in java.io with parameters of type FileDescriptor
      Constructor 描述
      FileInputStream​(FileDescriptor fdObj)
      通过使用文件描述符 fdObj创建 FileInputStream ，该文件描述符表示与文件系统中的实际文件的现有连接。
      FileOutputStream​(FileDescriptor fdObj)
      创建文件输出流以写入指定的文件描述符，表示与文件系统中实际文件的现有连接。
      FileReader​(FileDescriptor fd)
      创建一个新的 FileReader ，给出 FileDescriptor从中读取。
      FileWriter​(FileDescriptor fd)
      构造与文件描述符关联的FileWriter对象。

    • Uses of FileDescriptor in java.lang

      Methods in java.lang with parameters of type FileDescriptor
      Modifier and Type 方法 描述
      void SecurityManager.checkRead​(FileDescriptor fd)
      如果调用线程不允许从指定的文件描述符读取，则抛出一个 SecurityException 。
      void SecurityManager.checkWrite​(FileDescriptor fd)
      如果调用线程不允许写入指定的 SecurityException则抛出一个 SecurityException 。

    • Uses of FileDescriptor in java.net

      Fields in java.net declared as FileDescriptor
      Modifier and Type Field 描述
      protected FileDescriptor DatagramSocketImpl.fd
      文件描述符对象。
      protected FileDescriptor SocketImpl.fd
      该套接字的文件描述符对象。
      Methods in java.net that return FileDescriptor
      Modifier and Type 方法 描述
      protected FileDescriptor DatagramSocketImpl.getFileDescriptor​()
      获取数据报套接字文件描述符。
      protected FileDescriptor SocketImpl.getFileDescriptor​()
      Returns the value of this socket's fd field.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FileInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FileInputStream

No usage of java.io.FileInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FileNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FileNotFoundException

  • Packages that use FileNotFoundException
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.swing.filechooser
    包含 JFileChooser组件使用的类和接口。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of FileNotFoundException in java.io

      Constructors in java.io that throw FileNotFoundException
      Constructor 描述
      FileInputStream​(File file)
      通过打开与实际文件的连接来创建一个 FileInputStream ，该文件由文件系统中的 File对象 file命名。
      FileInputStream​(String name)
      通过打开与实际文件的连接来创建一个 FileInputStream ，该文件由文件系统中的路径名 name命名。
      FileOutputStream​(File file)
      创建文件输出流以写入由指定的 File对象表示的文件。
      FileOutputStream​(File file, boolean append)
      创建文件输出流以写入由指定的 File对象表示的文件。
      FileOutputStream​(String name)
      创建文件输出流以指定的名称写入文件。
      FileOutputStream​(String name, boolean append)
      创建文件输出流以指定的名称写入文件。
      FileReader​(File file)
      创建一个新的 FileReader ，给出 File读取。
      FileReader​(String fileName)
      创建一个新的 FileReader ，给定要读取的文件的名称。
      PrintStream​(File file)
      使用指定的文件创建一个新的打印流，而不需要自动换行。
      PrintStream​(File file, String csn)
      使用指定的文件和字符集创建新的打印流，而不需要自动换行。
      PrintStream​(String fileName)
      使用指定的文件名创建新的打印流，无需自动换行。
      PrintStream​(String fileName, String csn)
      创建一个新的打印流，不需要自动换行，具有指定的文件名和字符集。
      PrintWriter​(File file)
      使用指定的文件创建一个新的PrintWriter，而不需要自动的线路刷新。
      PrintWriter​(File file, String csn)
      使用指定的文件和字符集创建一个新的PrintWriter，而不需要自动进行线条刷新。
      PrintWriter​(String fileName)
      使用指定的文件名创建一个新的PrintWriter，而不需要自动执行行刷新。
      PrintWriter​(String fileName, String csn)
      使用指定的文件名和字符集创建一个新的PrintWriter，而不需要自动线路刷新。
      RandomAccessFile​(File file, String mode)
      创建一个随机访问文件流，从File参数指定的文件读取，并可选择写入。
      RandomAccessFile​(String name, String mode)
      创建随机访问文件流，以从中指定名称的文件读取，并可选择写入文件。

    • Uses of FileNotFoundException in java.util

      Constructors in java.util that throw FileNotFoundException
      Constructor 描述
      Formatter​(File file)
      使用指定的文件构造一个新的格式化程序。
      Formatter​(File file, String csn)
      使用指定的文件和字符集构造一个新的格式化程序。
      Formatter​(File file, String csn, Locale l)
      使用指定的文件，字符集和区域设置构造一个新的格式化程序。
      Formatter​(String fileName)
      构造具有指定文件名的新格式化程序。
      Formatter​(String fileName, String csn)
      构造具有指定文件名和字符集的新格式化程序。
      Formatter​(String fileName, String csn, Locale l)
      构造具有指定文件名，字符集和区域设置的新格式化程序。
      Scanner​(File source)
      构造一个新的 Scanner ，产生从指定文件扫描的值。
      Scanner​(File source, String charsetName)
      构造一个新的 Scanner ，产生从指定文件扫描的值。

    • Uses of FileNotFoundException in javax.imageio.stream

      Constructors in javax.imageio.stream that throw FileNotFoundException
      Constructor 描述
      FileImageInputStream​(File f)
      构造一个 FileImageInputStream ，它将从给定的 File读取。
      FileImageOutputStream​(File f)
      构造一个 FileImageOutputStream ，它将写入给定的 File 。

    • Uses of FileNotFoundException in javax.jnlp

      Methods in javax.jnlp that throw FileNotFoundException
      Modifier and Type 方法 描述
      FileContents PersistenceService.get​(URL url)
      返回表示此文件内容的 FileContents对象。

    • Uses of FileNotFoundException in javax.swing.filechooser

      Methods in javax.swing.filechooser that throw FileNotFoundException
      Modifier and Type 方法 描述
      File FileSystemView.getLinkLocation​(File file)
      如果指定的文件是shell解释链接，则返回指定链接文件引用的常规文件。

    • Uses of FileNotFoundException in jdk.incubator.http

      Methods in jdk.incubator.http that throw FileNotFoundException
      Modifier and Type 方法 描述
      static HttpRequest.BodyProcessor HttpRequest.BodyProcessor.fromFile​(Path path)
      A request body processor that takes data from the contents of a File.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FileOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FileOutputStream

No usage of java.io.FileOutputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FilePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FilePermission

No usage of java.io.FilePermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FileReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FileReader

No usage of java.io.FileReader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FileWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FileWriter

No usage of java.io.FileWriter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FilterInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FilterInputStream

  • Packages that use FilterInputStream
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.security
    提供安全框架的类和接口。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.crypto
    提供加密操作的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of FilterInputStream in java.io

      Subclasses of FilterInputStream in java.io
      Modifier and Type Class 描述
      class  BufferedInputStream
      A BufferedInputStream为另一个输入流添加了功能，即缓冲输入并支持 mark和 reset方法的功能。
      class  DataInputStream
      数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
      class  LineNumberInputStream
      已过时。
      该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。
      class  PushbackInputStream
      A PushbackInputStream通过将后推式字节存储在内部缓冲区中，为另一输入流添加功能，即“推回”或“未读”字节的功能。

    • Uses of FilterInputStream in java.security

      Subclasses of FilterInputStream in java.security
      Modifier and Type Class 描述
      class  DigestInputStream
      透明流，使用通过流的位更新关联的消息摘要。

    • Uses of FilterInputStream in java.util.jar

      Subclasses of FilterInputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarInputStream
      JarInputStream类用于从任何输入流读取JAR文件的内容。

    • Uses of FilterInputStream in java.util.zip

      Subclasses of FilterInputStream in java.util.zip
      Modifier and Type Class 描述
      class  CheckedInputStream
      也保持正在读取的数据的校验和的输入流。
      class  DeflaterInputStream
      实现用于压缩“放气”压缩格式的数据的输入流过滤器。
      class  GZIPInputStream
      该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。
      class  InflaterInputStream
      该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。
      class  ZipInputStream
      该类实现了以ZIP文件格式读取文件的输入流过滤器。

    • Uses of FilterInputStream in javax.crypto

      Subclasses of FilterInputStream in javax.crypto
      Modifier and Type Class 描述
      class  CipherInputStream
      CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。

    • Uses of FilterInputStream in javax.swing

      Subclasses of FilterInputStream in javax.swing
      Modifier and Type Class 描述
      class  ProgressMonitorInputStream
      监视从一些InputStream读取进度。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FilterOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FilterOutputStream

  • Packages that use FilterOutputStream
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.crypto
    提供加密操作的类和接口。

    • Uses of FilterOutputStream in java.io

      Subclasses of FilterOutputStream in java.io
      Modifier and Type Class 描述
      class  BufferedOutputStream
      该类实现缓冲输出流。
      class  DataOutputStream
      数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
      class  PrintStream
      A PrintStream将功能添加到另一个输出流，即可以方便地打印各种数据值的表示。

    • Uses of FilterOutputStream in java.rmi.server

      Subclasses of FilterOutputStream in java.rmi.server
      Modifier and Type Class 描述
      class  LogStream
      已过时。
      没有替换

    • Uses of FilterOutputStream in java.security

      Subclasses of FilterOutputStream in java.security
      Modifier and Type Class 描述
      class  DigestOutputStream
      透明流，使用通过流的位更新关联的消息摘要。

    • Uses of FilterOutputStream in java.util.jar

      Subclasses of FilterOutputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarOutputStream
      JarOutputStream类用于将JAR文件的内容写入任何输出流。

    • Uses of FilterOutputStream in java.util.zip

      Subclasses of FilterOutputStream in java.util.zip
      Modifier and Type Class 描述
      class  CheckedOutputStream
      一个输出流，它还维护正在写入的数据的校验和。
      class  DeflaterOutputStream
      该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
      class  GZIPOutputStream
      该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
      class  InflaterOutputStream
      实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。
      class  ZipOutputStream
      该类实现了以ZIP文件格式写入文件的输出流过滤器。

    • Uses of FilterOutputStream in javax.crypto

      Subclasses of FilterOutputStream in javax.crypto
      Modifier and Type Class 描述
      class  CipherOutputStream
      A CipherOutputStream is composed of an OutputStream and a Cipher so that write() methods first process the data before writing them out to the underlying OutputStream.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FilterReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FilterReader

  • Packages that use FilterReader
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of FilterReader in java.io

      Subclasses of FilterReader in java.io
      Modifier and Type Class 描述
      class  PushbackReader
      一个字符流读取器，允许将字符推回到流中。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.FilterWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.FilterWriter

No usage of java.io.FilterWriter
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.InputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.InputStream

  • Packages that use InputStream
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.activation
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.cert
    提供公钥证书类。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.rtf
    提供一个类（ RTFEditorKit ）用于创建Rich-Text-Format文本编辑器。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform.stream
    提供流和URI特定的转换类。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
    org.omg.CORBA_2_3.portable
    提供值类型的输入和输出方法，并包含其他更新的 org/omg/CORBA/portable包。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.xml.sax
    提供核心SAX API。

    • Uses of InputStream in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return InputStream
      Modifier and Type 方法 描述
      abstract InputStream HttpExchange.getRequestBody​()
      返回可以从中读取请求主体的流。
      Methods in com.sun.net.httpserver with parameters of type InputStream
      Modifier and Type 方法 描述
      abstract void HttpExchange.setStreams​(InputStream i, OutputStream o)
      Filter使用这个交换器的InputStream和OutputStream（或两者）与给定的已滤波流，以便随后对HttpExchange.getRequestBody()的调用将返回给定的InputStream ，并且调用HttpExchange.getResponseBody()将返回给定的OutputStream 。

    • Uses of InputStream in java.applet

      Methods in java.applet that return InputStream
      Modifier and Type 方法 描述
      InputStream AppletContext.getStream​(String key)
      已过时。
      返回指定键在此applet上下文中相关联的流。
      Methods in java.applet with parameters of type InputStream
      Modifier and Type 方法 描述
      void AppletContext.setStream​(String key, InputStream stream)
      已过时。
      将指定的流与此applet上下文中的指定关键字相关联。

    • Uses of InputStream in java.awt

      Methods in java.awt with parameters of type InputStream
      Modifier and Type 方法 描述
      static Font Font.createFont​(int fontFormat, InputStream fontStream)
      使用指定的字体类型和输入数据返回一个新的 Font 。
      static Font[] Font.createFonts​(InputStream fontStream)
      返回从指定的流解码的新数组 Font 。

    • Uses of InputStream in java.awt.color

      Methods in java.awt.color with parameters of type InputStream
      Modifier and Type 方法 描述
      static ICC_Profile ICC_Profile.getInstance​(InputStream s)
      构造一个与InputStream中数据对应的ICC_Profile。

    • Uses of InputStream in java.beans

      Constructors in java.beans with parameters of type InputStream
      Constructor 描述
      XMLDecoder​(InputStream in)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputStream in, Object owner)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener)
      创建一个新的输入流，以读取 XMLEncoder类创建的 XMLEncoder 。
      XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。

    • Uses of InputStream in java.beans.beancontext

      Methods in java.beans.beancontext that return InputStream
      Modifier and Type | 方法 | 描述
      InputStream BeanContext.getResourceAsStream​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实现介入孩子 Component和底层的 ClassLoader之间的行为。
      InputStream | BeanContextSupport.getResourceAsStream​(String name, BeanContextChild bcc)

    • Uses of InputStream in java.io

      Subclasses of InputStream in java.io
      Modifier and Type Class 描述
      class  BufferedInputStream
      A BufferedInputStream为另一个输入流添加了功能，即缓冲输入并支持 mark和 reset方法的功能。
      class  ByteArrayInputStream
      A ByteArrayInputStream包含一个内部缓冲区，其中包含可以从流中读取的字节。
      class  DataInputStream
      数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
      class  FileInputStream
      A FileInputStream从文件系统中的文件获取输入字节。
      class  FilterInputStream
      A FilterInputStream包含一些其他输入流，它使用它作为其基本的数据源，可能沿着该方向转换数据或提供附加功能。
      class  LineNumberInputStream
      已过时。
      该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。
      class  ObjectInputStream
      ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
      class  PipedInputStream
      管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。
      class  PushbackInputStream
      A PushbackInputStream通过将推回的字节存储在内部缓冲区中，向另一个输入流添加功能，即“推回”或“未读”字节的功能。
      class  SequenceInputStream
      A SequenceInputStream表示其他输入流的逻辑级联。
      class  StringBufferInputStream
      已过时。
      此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。
      Fields in java.io declared as InputStream
      Modifier and Type Field 描述
      protected InputStream FilterInputStream.in
      要过滤的输入流。
      Constructors in java.io with parameters of type InputStream
      Constructor 描述
      BufferedInputStream​(InputStream in)
      创建一个 BufferedInputStream并保存其参数，输入流 in供以后使用。
      BufferedInputStream​(InputStream in, int size)
      创建具有指定缓冲区大小的 BufferedInputStream ，并保存其参数，输入流 in供以后使用。
      DataInputStream​(InputStream in)
      创建使用指定的底层InputStream的DataInputStream。
      FilterInputStream​(InputStream in)
      通过将参数 in分配给字段 this.in创建 FilterInputStream ，以便记住它以供以后使用。
      InputStreamReader​(InputStream in)
      创建一个使用默认字符集的InputStreamReader。
      InputStreamReader​(InputStream in, String charsetName)
      创建一个使用命名字符集的InputStreamReader。
      InputStreamReader​(InputStream in, Charset cs)
      创建一个使用给定字符集的InputStreamReader。
      InputStreamReader​(InputStream in, CharsetDecoder dec)
      创建一个使用给定字符集解码器的InputStreamReader。
      LineNumberInputStream​(InputStream in)
      已过时。
      构造从指定输入流读取其输入的换行符输入流。
      ObjectInputStream​(InputStream in)
      创建从指定的InputStream读取的ObjectInputStream。
      PushbackInputStream​(InputStream in)
      创建一个 PushbackInputStream与1字节的推回缓冲区，并保存其参数，输入流 in供以后使用。
      PushbackInputStream​(InputStream in, int size)
      使用指定的 size的推回缓冲区创建一个 PushbackInputStream ，并保存其参数，输入流 in供以后使用。
      SequenceInputStream​(InputStream s1, InputStream s2)
      通过记住两个参数来初始化新创建的 SequenceInputStream ，这两个参数将按顺序读取，首先是 s1 ，然后是 s2 ，以提供要从此 SequenceInputStream读取的字节。
      StreamTokenizer​(InputStream is)
      已过时。
      从JDK版本1.1开始，将输入流标记化的首选方法是将其转换为字符流，例如：
         Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
      Constructor parameters in java.io with type arguments of type InputStream
      Constructor 描述
      SequenceInputStream​(Enumeration<? extends InputStream> e)
      通过记住该参数来初始化一个新创建的 SequenceInputStream ，该参数必须是 Enumeration ，它生成运行时类型为 InputStream 。

    • Uses of InputStream in java.lang

      Fields in java.lang declared as InputStream
      Modifier and Type Field 描述
      static InputStream System.in
      “标准”输入流。
      Methods in java.lang that return InputStream
      Modifier and Type 方法 描述
      abstract InputStream Process.getErrorStream​()
      返回连接到进程的错误输出的输入流。
      abstract InputStream Process.getInputStream​()
      返回连接到进程正常输出的输入流。
      InputStream Runtime.getLocalizedInputStream​(InputStream in)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1开始，将本地编码中的字节流转换为Unicode中的字符流的首选方式是通过InputStreamReader和BufferedReader类。 此方法在将来的Java SE版本中可能会被删除。
      InputStream Class.getResourceAsStream​(String name)
      查找具有给定名称的资源。
      InputStream ClassLoader.getResourceAsStream​(String name)
      返回用于读取指定资源的输入流。
      InputStream Module.getResourceAsStream​(String name)
      返回用于读取此模块中资源的输入流。
      static InputStream ClassLoader.getSystemResourceAsStream​(String name)
      打开阅读，从用于加载类的搜索路径中指定名称的资源。
      Methods in java.lang with parameters of type InputStream
      Modifier and Type 方法 描述
      InputStream Runtime.getLocalizedInputStream​(InputStream in)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1开始，将本地编码中的字节流转换为Unicode中的字符流的首选方法是通过InputStreamReader和BufferedReader类。 此方法在将来的Java SE版本中可能会被删除。
      static void System.setIn​(InputStream in)
      重新分配“标准”输入流。

    • Uses of InputStream in java.lang.module

      Methods in java.lang.module that return types with arguments of type InputStream
      Modifier and Type 方法 描述
      default Optional<InputStream> ModuleReader.open​(String name)
      打开资源，返回输入流以读取模块中的资源。
      Methods in java.lang.module with parameters of type InputStream
      Modifier and Type 方法 描述
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in, Supplier<Set<String>> packageFinder)
      从输入流读取模块声明的二进制形式作为模块描述符。

    • Uses of InputStream in java.net

      Methods in java.net that return InputStream
      Modifier and Type 方法 描述
      abstract InputStream CacheResponse.getBody​()
      将响应体作为InputStream返回。
      InputStream HttpURLConnection.getErrorStream​()
      如果连接失败但服务器发送有用的数据，则返回错误流。
      InputStream Socket.getInputStream​()
      返回此套接字的输入流。
      protected abstract InputStream SocketImpl.getInputStream​()
      返回此套接字的输入流。
      InputStream URLConnection.getInputStream​()
      返回从此打开的连接读取的输入流。
      InputStream URLClassLoader.getResourceAsStream​(String name)
      返回用于读取指定资源的输入流。
      InputStream URL.openStream​()
      打开与这个 URL的连接，并返回一个 InputStream用于从该连接读取。
      Methods in java.net with parameters of type InputStream
      Modifier and Type 方法 描述
      static String URLConnection.guessContentTypeFromStream​(InputStream is)
      根据输入流开头的字符，尝试确定输入流的类型。

    • Uses of InputStream in java.nio.channels

      Methods in java.nio.channels that return InputStream
      Modifier and Type 方法 描述
      static InputStream Channels.newInputStream​(AsynchronousByteChannel ch)
      构造从给定通道读取字节的流。
      static InputStream Channels.newInputStream​(ReadableByteChannel ch)
      构造从给定通道读取字节的流。
      Methods in java.nio.channels with parameters of type InputStream
      Modifier and Type 方法 描述
      static ReadableByteChannel Channels.newChannel​(InputStream in)
      构造从给定流读取字节的通道。

    • Uses of InputStream in java.nio.file

      Methods in java.nio.file that return InputStream
      Modifier and Type 方法 描述
      static InputStream Files.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      Methods in java.nio.file with parameters of type InputStream
      Modifier and Type 方法 描述
      static long Files.copy​(InputStream in, Path target, CopyOption... options)
      将输入流中的所有字节复制到文件。

    • Uses of InputStream in java.nio.file.spi

      Methods in java.nio.file.spi that return InputStream
      Modifier and Type 方法 描述
      InputStream FileSystemProvider.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。

    • Uses of InputStream in java.security

      Subclasses of InputStream in java.security
      Modifier and Type Class 描述
      class  DigestInputStream
      透明流，使用通过流的位更新关联的消息摘要。
      Methods in java.security with parameters of type InputStream
      Modifier and Type 方法 描述
      void Certificate.decode​(InputStream stream)
      已过时。
      从输入流解码证书。
      abstract void KeyStoreSpi.engineLoad​(InputStream stream, char[] password)
      从给定的输入流加载密钥库。
      boolean KeyStoreSpi.engineProbe​(InputStream stream)
      探测指定的输入流以确定它是否包含此实现支持的密钥库。
      void KeyStore.load​(InputStream stream, char[] password)
      从给定的输入流加载此KeyStore。
      void Provider.load​(InputStream inStream)
      从输入流读取属性列表（键和元素对）。
      Constructors in java.security with parameters of type InputStream
      Constructor 描述
      DigestInputStream​(InputStream stream, MessageDigest digest)
      使用指定的输入流和消息摘要创建摘要输入流。

    • Uses of InputStream in java.security.cert

      Methods in java.security.cert with parameters of type InputStream
      Modifier and Type 方法 描述
      abstract Certificate CertificateFactorySpi.engineGenerateCertificate​(InputStream inStream)
      生成证书对象并使用从输入流 inStream读取的数据进行初始化。
      abstract Collection<? extends Certificate> CertificateFactorySpi.engineGenerateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      CertPath CertificateFactorySpi.engineGenerateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactorySpi.engineGenerateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      abstract CRL CertificateFactorySpi.engineGenerateCRL​(InputStream inStream)
      生成证书撤销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      abstract Collection<? extends CRL> CertificateFactorySpi.engineGenerateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。
      Certificate CertificateFactory.generateCertificate​(InputStream inStream)
      生成证书对象，并使用从输入流 inStream读取的数据进行初始化。
      Collection<? extends Certificate> CertificateFactory.generateCertificates​(InputStream inStream)
      返回从给定输入流 inStream读取的证书的（可能为空的）集合视图。
      CertPath CertificateFactory.generateCertPath​(InputStream inStream)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CertPath CertificateFactory.generateCertPath​(InputStream inStream, String encoding)
      生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。
      CRL CertificateFactory.generateCRL​(InputStream inStream)
      生成证书吊销列表（CRL）对象，并使用从输入流 inStream读取的数据进行初始化。
      Collection<? extends CRL> CertificateFactory.generateCRLs​(InputStream inStream)
      返回从给定输入流 inStream读取的CRL的（可能为空的）集合视图。

    • Uses of InputStream in java.sql

      Methods in java.sql that return InputStream
      Modifier and Type 方法 描述
      InputStream Clob.getAsciiStream​()
      检索由 Clob对象指定的 CLOB值作为ASCII码流。
      InputStream ResultSet.getAsciiStream​(int columnIndex)
      将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。
      InputStream ResultSet.getAsciiStream​(String columnLabel)
      检索此 ResultSet对象的当前行中指定列的值作为ASCII字符流。
      InputStream Blob.getBinaryStream​()
      检索由该 Blob实例指定的 BLOB值作为流。
      InputStream Blob.getBinaryStream​(long pos, long length)
      返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为长度字节。
      InputStream ResultSet.getBinaryStream​(int columnIndex)
      将此 ResultSet对象的当前行中的指定列的值作为未解释的字节流 ResultSet 。
      InputStream ResultSet.getBinaryStream​(String columnLabel)
      将此 ResultSet对象的当前行中的指定列的值作为未解释的 byte s的流 byte 。
      InputStream SQLXML.getBinaryStream​()
      检索此SQLXML实例指定的XML值作为流。
      InputStream ResultSet.getUnicodeStream​(int columnIndex)
      已过时。
      使用getCharacterStream代替getUnicodeStream
      InputStream ResultSet.getUnicodeStream​(String columnLabel)
      已过时。
      改用getCharacterStream
      InputStream SQLInput.readAsciiStream​()
      读取流中的下一个属性并将其作为ASCII字符流返回。
      InputStream SQLInput.readBinaryStream​()
      读取流中的下一个属性并将其作为未解释的字节流返回。
      Methods in java.sql with parameters of type InputStream
      Modifier and Type 方法 描述
      void CallableStatement.setAsciiStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void CallableStatement.setAsciiStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void CallableStatement.setAsciiStream​(String parameterName, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void PreparedStatement.setAsciiStream​(int parameterIndex, InputStream x)
      将指定的参数设置为给定的输入流。
      void PreparedStatement.setAsciiStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void PreparedStatement.setAsciiStream​(int parameterIndex, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void CallableStatement.setBinaryStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void CallableStatement.setBinaryStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void CallableStatement.setBinaryStream​(String parameterName, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void PreparedStatement.setBinaryStream​(int parameterIndex, InputStream x)
      将指定的参数设置为给定的输入流。
      void PreparedStatement.setBinaryStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void PreparedStatement.setBinaryStream​(int parameterIndex, InputStream x, long length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void CallableStatement.setBlob​(String parameterName, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void CallableStatement.setBlob​(String parameterName, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void PreparedStatement.setBlob​(int parameterIndex, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void PreparedStatement.setBlob​(int parameterIndex, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void PreparedStatement.setUnicodeStream​(int parameterIndex, InputStream x, int length)
      已过时。
      使用setCharacterStream
      void ResultSet.updateAsciiStream​(int columnIndex, InputStream x)
      使用ascii流值更新指定的列。
      void ResultSet.updateAsciiStream​(int columnIndex, InputStream x, int length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateAsciiStream​(int columnIndex, InputStream x, long length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateAsciiStream​(String columnLabel, InputStream x)
      使用ascii流值更新指定的列。
      void ResultSet.updateAsciiStream​(String columnLabel, InputStream x, int length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateAsciiStream​(String columnLabel, InputStream x, long length)
      使用ascii流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBinaryStream​(int columnIndex, InputStream x)
      使用二进制流值更新指定的列。
      void ResultSet.updateBinaryStream​(int columnIndex, InputStream x, int length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBinaryStream​(int columnIndex, InputStream x, long length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBinaryStream​(String columnLabel, InputStream x)
      使用二进制流值更新指定的列。
      void ResultSet.updateBinaryStream​(String columnLabel, InputStream x, int length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBinaryStream​(String columnLabel, InputStream x, long length)
      使用二进制流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateBlob​(int columnIndex, InputStream inputStream)
      使用给定的输入流更新指定的列。
      void ResultSet.updateBlob​(int columnIndex, InputStream inputStream, long length)
      使用给定的输入流更新指定列，该输入流将具有指定的字节数。
      void ResultSet.updateBlob​(String columnLabel, InputStream inputStream)
      使用给定的输入流更新指定的列。
      void ResultSet.updateBlob​(String columnLabel, InputStream inputStream, long length)
      使用给定的输入流更新指定列，该输入流将具有指定的字节数。
      void SQLOutput.writeAsciiStream​(InputStream x)
      将下一个属性作为ASCII字符串写入流。
      void SQLOutput.writeBinaryStream​(InputStream x)
      将下一个属性写入流作为未解释字节流。

    • Uses of InputStream in java.util

      Methods in java.util that return InputStream
      Modifier and Type 方法 描述
      InputStream Base64.Decoder.wrap​(InputStream is)
      返回用于解码Base64编码字节流的输入流。
      Methods in java.util with parameters of type InputStream
      Modifier and Type 方法 描述
      void Properties.load​(InputStream inStream)
      从输入字节流读取属性列表（键和元素对）。
      void Properties.loadFromXML​(InputStream in)
      将指定输入流中的XML文档表示的所有属性加载到此属性表中。
      InputStream Base64.Decoder.wrap​(InputStream is)
      返回用于解码Base64编码字节流的输入流。
      Constructors in java.util with parameters of type InputStream
      Constructor 描述
      PropertyResourceBundle​(InputStream stream)
      从一个InputStream创建一个属性资源束。
      Scanner​(InputStream source)
      构造一个新的 Scanner ，产生从指定的输入流扫描的值。
      Scanner​(InputStream source, String charsetName)
      构造一个新的 Scanner ，产生从指定的输入流扫描的值。

    • Uses of InputStream in java.util.jar

      Subclasses of InputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarInputStream
      JarInputStream类用于从任何输入流读取JAR文件的内容。
      Methods in java.util.jar that return InputStream
      Modifier and Type 方法 描述
      InputStream JarFile.getInputStream​(ZipEntry ze)
      返回用于读取指定zip文件条目内容的输入流。
      Methods in java.util.jar with parameters of type InputStream
      Modifier and Type 方法 描述
      void Manifest.read​(InputStream is)
      从指定的InputStream读取清单。
      void Pack200.Unpacker.unpack​(InputStream in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。
      Constructors in java.util.jar with parameters of type InputStream
      Constructor 描述
      JarInputStream​(InputStream in)
      创建一个新的 JarInputStream并读取可选清单。
      JarInputStream​(InputStream in, boolean verify)
      创建一个新的 JarInputStream并读取可选的清单。
      Manifest​(InputStream is)
      从指定的输入流构造一个新的清单。

    • Uses of InputStream in java.util.logging

      Methods in java.util.logging with parameters of type InputStream
      Modifier and Type 方法 描述
      void LogManager.readConfiguration​(InputStream ins)
      从给定的输入流读取和初始化日志记录配置。
      void LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。

    • Uses of InputStream in java.util.prefs

      Methods in java.util.prefs with parameters of type InputStream
      Modifier and Type 方法 描述
      static void Preferences.importPreferences​(InputStream is)
      在指定的输入流中导入由XML文档表示的所有首选项。

    • Uses of InputStream in java.util.zip

      Subclasses of InputStream in java.util.zip
      Modifier and Type Class 描述
      class  CheckedInputStream
      也保持正在读取的数据的校验和的输入流。
      class  DeflaterInputStream
      实现用于压缩“放气”压缩格式的数据的输入流过滤器。
      class  GZIPInputStream
      该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。
      class  InflaterInputStream
      该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。
      class  ZipInputStream
      该类实现了以ZIP文件格式读取文件的输入流过滤器。
      Methods in java.util.zip that return InputStream
      Modifier and Type 方法 描述
      InputStream ZipFile.getInputStream​(ZipEntry entry)
      返回用于读取指定zip文件条目内容的输入流。
      Constructors in java.util.zip with parameters of type InputStream
      Constructor 描述
      CheckedInputStream​(InputStream in, Checksum cksum)
      使用指定的校验和创建输入流。
      DeflaterInputStream​(InputStream in)
      创建一个具有默认压缩器和缓冲区大小的新输入流。
      DeflaterInputStream​(InputStream in, Deflater defl)
      使用指定的压缩器和默认缓冲区大小创建新的输入流。
      DeflaterInputStream​(InputStream in, Deflater defl, int bufLen)
      创建具有指定压缩器和缓冲区大小的新输入流。
      GZIPInputStream​(InputStream in)
      创建一个默认缓冲区大小的新输入流。
      GZIPInputStream​(InputStream in, int size)
      创建具有指定缓冲区大小的新输入流。
      InflaterInputStream​(InputStream in)
      使用默认解压缩器和缓冲区大小创建新的输入流。
      InflaterInputStream​(InputStream in, Inflater inf)
      使用指定的解压缩器和默认缓冲区大小创建新的输入流。
      InflaterInputStream​(InputStream in, Inflater inf, int size)
      使用指定的解压缩器和缓冲区大小创建新的输入流。
      ZipInputStream​(InputStream in)
      创建一个新的ZIP输入流。
      ZipInputStream​(InputStream in, Charset charset)
      创建一个新的ZIP输入流。

    • Uses of InputStream in javafx.fxml

      Methods in javafx.fxml with parameters of type InputStream
      Modifier and Type 方法 描述
      <T> T FXMLLoader.load​(InputStream inputStream)
      从FXML文档加载对象层次结构。

    • Uses of InputStream in javafx.scene.image

      Constructors in javafx.scene.image with parameters of type InputStream
      Constructor 描述
      Image​(InputStream is)
      构造一个 Image ，内容从指定的输入流中加载。
      Image​(InputStream is, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)
      使用指定的参数构造一个新的 Image 。

    • Uses of InputStream in javafx.scene.text

      Methods in javafx.scene.text with parameters of type InputStream
      Modifier and Type 方法 描述
      static Font Font.loadFont​(InputStream in, double size)
      从指定的输入流加载字体资源。
      static Font[] Font.loadFonts​(InputStream in, double size)
      从指定的输入流中加载字体资源。

    • Uses of InputStream in javax.accessibility

      Methods in javax.accessibility that return InputStream
      Modifier and Type 方法 描述
      InputStream AccessibleStreamable.getStream​(DataFlavor flavor)
      返回一个 InputStream为 DataFlavor 。

    • Uses of InputStream in javax.activation

      Methods in javax.activation that return InputStream
      Modifier and Type 方法 描述
      InputStream DataHandler.getInputStream​()
      获取此对象的InputStream。
      InputStream DataSource.getInputStream​()
      此方法返回表示数据的 InputStream ，如果不能这样做，则返回相应的异常。
      InputStream FileDataSource.getInputStream​()
      此方法将返回一个表示数据的InputStream，如果不能执行此操作将抛出IOException。
      InputStream URLDataSource.getInputStream​()
      来自URL的getInputStream方法。
      Constructors in javax.activation with parameters of type InputStream
      Constructor 描述
      MailcapCommandMap​(InputStream is)
      构造函数允许调用者指定一个包含mailcap文件的 InputStream 。
      MimetypesFileTypeMap​(InputStream is)
      构造一个MimetypesFileTypeMap，其中包含从InputStream中添加的程序化条目。

    • Uses of InputStream in javax.crypto

      Subclasses of InputStream in javax.crypto
      Modifier and Type Class 描述
      class  CipherInputStream
      CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。
      Constructors in javax.crypto with parameters of type InputStream
      Constructor 描述
      CipherInputStream​(InputStream is)
      从InputStream构造CipherInputStream，而不指定密码。
      CipherInputStream​(InputStream is, Cipher c)
      从InputStream和Cipher构造一个CipherInputStream。

    • Uses of InputStream in javax.imageio

      Methods in javax.imageio with parameters of type InputStream
      Modifier and Type 方法 描述
      static BufferedImage ImageIO.read​(InputStream input)
      作为对所提供的 InputStream进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。

    • Uses of InputStream in javax.imageio.stream

      Constructors in javax.imageio.stream with parameters of type InputStream
      Constructor 描述
      FileCacheImageInputStream​(InputStream stream, File cacheDir)
      构造一个 FileCacheImageInputStream将从给定的读取 InputStream 。
      MemoryCacheImageInputStream​(InputStream stream)
      构造一个 MemoryCacheImageInputStream ，它将从给定的 InputStream读取。

    • Uses of InputStream in javax.jnlp

      Methods in javax.jnlp that return InputStream
      Modifier and Type 方法 描述
      InputStream FileContents.getInputStream​()
      从文件获取 InputStream 。
      Methods in javax.jnlp with parameters of type InputStream
      Modifier and Type 方法 描述
      FileContents FileSaveService.saveFileDialog​(String pathHint, String[] extensions, InputStream stream, String name)
      要求用户保存文件。

    • Uses of InputStream in javax.management.loading

      Methods in javax.management.loading that return InputStream
      Modifier and Type 方法 描述
      InputStream MLetMBean.getResourceAsStream​(String name)
      返回用于读取指定资源的输入流。

    • Uses of InputStream in javax.net.ssl

      Methods in javax.net.ssl with parameters of type InputStream
      Modifier and Type 方法 描述
      Socket SSLSocketFactory.createSocket​(Socket s, InputStream consumed, boolean autoClose)
      创建服务器模式Socket在现有连接的套接字上分层，并且能够读取已经从Socket的底层InputStream中消耗/删除的数据 。

    • Uses of InputStream in javax.print

      Methods in javax.print that return InputStream
      Modifier and Type 方法 描述
      InputStream Doc.getStreamForBytes​()
      获取从该文档中提取字节打印数据的输入流。
      InputStream SimpleDoc.getStreamForBytes​()
      获取从该文档中提取字节打印数据的输入流。

    • Uses of InputStream in javax.security.auth.x500

      Constructors in javax.security.auth.x500 with parameters of type InputStream
      Constructor 描述
      X500Principal​(InputStream is)
      从包含ASN.1 DER编码格式的可分辨名称的 InputStream创建一个 X500Principal 。

    • Uses of InputStream in javax.security.cert

      Methods in javax.security.cert with parameters of type InputStream
      Modifier and Type 方法 描述
      static X509Certificate X509Certificate.getInstance​(InputStream inStream)
      已过时。
      实例化一个X509Certificate对象，并使用从输入流 inStream读取的数据进行初始化。

    • Uses of InputStream in javax.sound.midi

      Methods in javax.sound.midi with parameters of type InputStream
      Modifier and Type 方法 描述
      static MidiFileFormat MidiSystem.getMidiFileFormat​(InputStream stream)
      获取指定输入流中数据的MIDI文件格式。
      static Sequence MidiSystem.getSequence​(InputStream stream)
      从指定的输入流中获取MIDI序列。
      static Soundbank MidiSystem.getSoundbank​(InputStream stream)
      通过从指定的流中读取来构建MIDI声音库。
      void Sequencer.setSequence​(InputStream stream)
      设置序列发生器工作的当前序列。

    • Uses of InputStream in javax.sound.midi.spi

      Methods in javax.sound.midi.spi with parameters of type InputStream
      Modifier and Type 方法 描述
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat​(InputStream stream)
      获取所提供的输入流的MIDI文件格式。
      abstract Sequence MidiFileReader.getSequence​(InputStream stream)
      从提供的输入流中获取MIDI序列。
      abstract Soundbank SoundbankReader.getSoundbank​(InputStream stream)
      从提供的 InputStream获取一个 InputStream对象。

    • Uses of InputStream in javax.sound.sampled

      Subclasses of InputStream in javax.sound.sampled
      Modifier and Type Class 描述
      class  AudioInputStream
      音频输入流是具有指定音频格式和长度的输入流。
      Methods in javax.sound.sampled with parameters of type InputStream
      Modifier and Type 方法 描述
      static AudioFileFormat AudioSystem.getAudioFileFormat​(InputStream stream)
      获取提供的输入流的音频文件格式。
      static AudioInputStream AudioSystem.getAudioInputStream​(InputStream stream)
      从提供的输入流中获取音频输入流。
      Constructors in javax.sound.sampled with parameters of type InputStream
      Constructor 描述
      AudioInputStream​(InputStream stream, AudioFormat format, long length)
      使用来自指定输入流的音频数据构建音频输入流，该音频输入流在采样帧中具有请求的格式和长度。

    • Uses of InputStream in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi with parameters of type InputStream
      Modifier and Type 方法 描述
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat​(InputStream stream)
      获取提供的输入流的音频文件格式。
      abstract AudioInputStream AudioFileReader.getAudioInputStream​(InputStream stream)
      从提供的输入流中获取音频输入流。

    • Uses of InputStream in javax.sql

      Methods in javax.sql with parameters of type InputStream
      Modifier and Type 方法 描述
      void RowSet.setAsciiStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void RowSet.setAsciiStream​(int parameterIndex, InputStream x, int length)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.io.InputStream值。
      void RowSet.setAsciiStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void RowSet.setAsciiStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void RowSet.setBinaryStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void RowSet.setBinaryStream​(int parameterIndex, InputStream x, int length)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.io.InputStream值。
      void RowSet.setBinaryStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void RowSet.setBinaryStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void RowSet.setBlob​(int parameterIndex, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void RowSet.setBlob​(int parameterIndex, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void RowSet.setBlob​(String parameterName, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void RowSet.setBlob​(String parameterName, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。

    • Uses of InputStream in javax.sql.rowset

      Fields in javax.sql.rowset declared as InputStream
      Modifier and Type Field 描述
      protected InputStream BaseRowSet.asciiStream
      InputStream对象将由方法 getAsciiStream返回，这是在 ResultSet界面中指定的。
      protected InputStream BaseRowSet.binaryStream
      InputStream对象将由方法 getBinaryStream返回，这是在 ResultSet接口中指定的。
      protected InputStream BaseRowSet.unicodeStream
      InputStream对象将通过方法 getUnicodeStream返回，这是在 ResultSet界面中指定的。
      Methods in javax.sql.rowset with parameters of type InputStream
      Modifier and Type 方法 描述
      void WebRowSet.readXml​(InputStream iStream)
      读取基于流的XML输入来填充此 WebRowSet对象。
      void BaseRowSet.setAsciiStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void BaseRowSet.setAsciiStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的 java.io.InputStream对象，该对象将具有指定的字节数。
      void BaseRowSet.setAsciiStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void BaseRowSet.setAsciiStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void BaseRowSet.setBinaryStream​(int parameterIndex, InputStream x)
      将此 RowSet对象的命令中的指定参数设置为给定的输入流。
      void BaseRowSet.setBinaryStream​(int parameterIndex, InputStream x, int length)
      将指定的参数设置为给定的 java.io.InputStream对象，该对象将具有指定的字节数。
      void BaseRowSet.setBinaryStream​(String parameterName, InputStream x)
      将指定的参数设置为给定的输入流。
      void BaseRowSet.setBinaryStream​(String parameterName, InputStream x, int length)
      将指定的参数设置为给定的输入流，它将具有指定的字节数。
      void BaseRowSet.setBlob​(int parameterIndex, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setBlob​(int parameterIndex, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setBlob​(String parameterName, InputStream inputStream)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setBlob​(String parameterName, InputStream inputStream, long length)
      将指定的参数设置为 InputStream对象。
      void BaseRowSet.setUnicodeStream​(int parameterIndex, InputStream x, int length)
      已过时。
      getCharacterStream应该用于它的位置

    • Uses of InputStream in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return InputStream
      Modifier and Type 方法 描述
      InputStream SerialClob.getAsciiStream​()
      检索由 SerialClob对象指定的 CLOB值作为ASCII码流。
      InputStream SerialBlob.getBinaryStream​()
      返回此 SerialBlob对象作为输入流。
      InputStream SerialBlob.getBinaryStream​(long pos, long length)
      返回一个包含部分 Blob值的 InputStream对象，从pos指定的字节开始，长度为长度字节。
      InputStream SQLInputImpl.readAsciiStream​()
      将此 SQLInputImpl对象中的下一个属性作为ASCII字符流返回。
      InputStream SQLInputImpl.readBinaryStream​()
      将此 SQLInputImpl对象中的下一个属性返回为未解释的字节流。
      Methods in javax.sql.rowset.serial with parameters of type InputStream
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeAsciiStream​(InputStream x)
      将ASCII码字符串写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBinaryStream​(InputStream x)
      将一串未解释的字节写入此 SQLOutputImpl对象。

    • Uses of InputStream in javax.swing

      Subclasses of InputStream in javax.swing
      Modifier and Type Class 描述
      class  ProgressMonitorInputStream
      监视从一些InputStream读取进度。
      Methods in javax.swing that return InputStream
      Modifier and Type 方法 描述
      protected InputStream JEditorPane.getStream​(URL page)
      获取给定URL的流，即将由 setPage方法加载。
      Methods in javax.swing with parameters of type InputStream
      Modifier and Type 方法 描述
      void JEditorPane.read​(InputStream in, Object desc)
      此方法从流初始化。
      Constructors in javax.swing with parameters of type InputStream
      Constructor 描述
      ProgressMonitorInputStream​(Component parentComponent, Object message, InputStream in)
      构造一个对象来监视输入流的进度。

    • Uses of InputStream in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type InputStream
      Modifier and Type 方法 描述
      void SynthLookAndFeel.load​(InputStream input, Class<?> resourceBase)
      载入 SynthStyle将使用的一组 SynthLookAndFeel 。

    • Uses of InputStream in javax.swing.text

      Methods in javax.swing.text with parameters of type InputStream
      Modifier and Type 方法 描述
      void DefaultEditorKit.read​(InputStream in, Document doc, int pos)
      插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
      abstract void EditorKit.read​(InputStream in, Document doc, int pos)
      插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。

    • Uses of InputStream in javax.swing.text.rtf

      Methods in javax.swing.text.rtf with parameters of type InputStream
      Modifier and Type 方法 描述
      void RTFEditorKit.read​(InputStream in, Document doc, int pos)
      从给定的流中插入内容，该内容预期为适合此类内容处理程序的格式。

    • Uses of InputStream in javax.tools

      Methods in javax.tools that return InputStream
      Modifier and Type | 方法 | 描述
      InputStream FileObject.openInputStream​()
      返回此文件对象的InputStream。
      InputStream | ForwardingFileObject.openInputStream​()
      InputStream SimpleJavaFileObject.openInputStream​()
      这个实现总是抛出UnsupportedOperationException 。
      Methods in javax.tools with parameters of type InputStream
      Modifier and Type 方法 描述
      int Tool.run​(InputStream in, OutputStream out, OutputStream err, String... arguments)
      使用给定的I / O通道和参数运行该工具。

    • Uses of InputStream in javax.xml.bind

      Methods in javax.xml.bind with parameters of type InputStream
      Modifier and Type 方法 描述
      static <T> T JAXB.unmarshal​(InputStream xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      Object Unmarshaller.unmarshal​(InputStream is)
      从指定的InputStream中解组XML数据，并返回生成的内容树。

    • Uses of InputStream in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type InputStream
      Modifier and Type | 方法 | 描述
      Object | AbstractUnmarshallerImpl.unmarshal​(InputStream is)

    • Uses of InputStream in javax.xml.catalog

      Methods in javax.xml.catalog that return InputStream
      Modifier and Type 方法 描述
      InputStream CatalogResolver.resolveEntity​(String publicId, String systemId, String baseUri, String namespace)
      实现XMLResolver 。

    • Uses of InputStream in javax.xml.crypto

      Methods in javax.xml.crypto that return InputStream
      Modifier and Type 方法 描述
      InputStream OctetStreamData.getOctetStream​()
      返回此 OctetStreamData的输入流。
      Constructors in javax.xml.crypto with parameters of type InputStream
      Constructor 描述
      OctetStreamData​(InputStream octetStream)
      创建一个新的 OctetStreamData 。
      OctetStreamData​(InputStream octetStream, String uri, String mimeType)
      创建一个新的 OctetStreamData 。

    • Uses of InputStream in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return InputStream
      Modifier and Type 方法 描述
      InputStream SignedInfo.getCanonicalizedData​()
      在签名或验证操作后返回规范化的已签名信息字节。
      InputStream Reference.getDigestInputStream​()
      如果启用了 reference caching ，则返回预消化的输入流。

    • Uses of InputStream in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type InputStream
      Modifier and Type 方法 描述
      Document DocumentBuilder.parse​(InputStream is)
      将给定的InputStream的内容解析为XML文档并返回一个新的DOM Document对象。
      Document DocumentBuilder.parse​(InputStream is, String systemId)
      将给定的InputStream的内容解析为XML文档并返回一个新的DOM Document对象。
      void SAXParser.parse​(InputStream is, HandlerBase hb)
      使用指定的HandlerBase将给定的InputStream实例的内容解析为XML。
      void SAXParser.parse​(InputStream is, HandlerBase hb, String systemId)
      使用指定的HandlerBase将给定的InputStream实例的内容解析为XML。
      void SAXParser.parse​(InputStream is, DefaultHandler dh)
      使用指定的DefaultHandler将给定的InputStream实例的内容解析为XML。
      void SAXParser.parse​(InputStream is, DefaultHandler dh, String systemId)
      使用指定的DefaultHandler将给定的InputStream实例的内容解析为XML。

    • Uses of InputStream in javax.xml.soap

      Methods in javax.xml.soap that return InputStream
      Modifier and Type 方法 描述
      abstract InputStream AttachmentPart.getBase64Content​()
      返回一个 InputStream ，可以用来获取 AttachmentPart的内容作为Base64编码的字符数据，此方法将base64编码附件的原始字节并返回。
      abstract InputStream AttachmentPart.getRawContent​()
      获取此内容 AttachmentPart对象作为InputStream仿佛调用了到 getContent ，没有 DataContentHandler已经登记为 content-type这一点 AttachmentPart 。
      Methods in javax.xml.soap with parameters of type InputStream
      Modifier and Type 方法 描述
      abstract SOAPMessage MessageFactory.createMessage​(MimeHeaders headers, InputStream in)
      将给定的 InputStream对象的内容内化为一个新的 SOAPMessage对象，并返回 SOAPMessage对象。
      abstract void AttachmentPart.setBase64Content​(InputStream content, String contentType)
      将此附件部分从所述的Base64源的内容 InputStream和设置的值 Content-Type头中包含的值 contentType ，此方法将首先解码的base64输入并写入到附接所得的原始字节。
      abstract void AttachmentPart.setRawContent​(InputStream content, String contentType)
      将此附件部分以使得由包含的内容 InputStream content并设定的值 Content-Type头中所包含的值 contentType 。

    • Uses of InputStream in javax.xml.stream

      Methods in javax.xml.stream with parameters of type InputStream
      Modifier and Type 方法 描述
      abstract XMLEventReader XMLInputFactory.createXMLEventReader​(InputStream stream)
      从java.io.InputStream创建一个新的XMLEventReader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader​(InputStream stream, String encoding)
      从java.io.InputStream创建一个新的XMLEventReader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader​(String systemId, InputStream stream)
      从java.io.InputStream创建一个新的XMLEventReader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader​(InputStream stream)
      从java.io.InputStream创建一个新的XMLStreamReader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader​(InputStream stream, String encoding)
      从java.io.InputStream创建一个新的XMLStreamReader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader​(String systemId, InputStream stream)
      从java.io.InputStream创建一个新的XMLStreamReader

    • Uses of InputStream in javax.xml.transform.stream

      Methods in javax.xml.transform.stream that return InputStream
      Modifier and Type 方法 描述
      InputStream StreamSource.getInputStream​()
      获取使用setByteStream设置的字节流。
      Methods in javax.xml.transform.stream with parameters of type InputStream
      Modifier and Type 方法 描述
      void StreamSource.setInputStream​(InputStream inputStream)
      设置要用作输入的字节流。
      Constructors in javax.xml.transform.stream with parameters of type InputStream
      Constructor 描述
      StreamSource​(InputStream inputStream)
      从字节流构造一个StreamSource。
      StreamSource​(InputStream inputStream, String systemId)
      从字节流构造一个StreamSource。

    • Uses of InputStream in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return InputStream
      Modifier and Type 方法 描述
      abstract InputStream HttpExchange.getRequestBody​()
      返回可以从中读取请求主体的流。

    • Uses of InputStream in jdk.incubator.http

      Method parameters in jdk.incubator.http with type arguments of type InputStream
      Modifier and Type 方法 描述
      static HttpRequest.BodyProcessor HttpRequest.BodyProcessor.fromInputStream​(Supplier<? extends InputStream> streamSupplier)
      一个从InputStream读取数据的请求体处理器。

    • Uses of InputStream in jdk.jshell

      Methods in jdk.jshell with parameters of type InputStream
      Modifier and Type 方法 描述
      JShell.Builder JShell.Builder.in​(InputStream in)
      设置运行评估的输入（它是 System.in ）。

    • Uses of InputStream in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type InputStream
      Modifier and Type 方法 描述
      static void Util.forwardExecutionControlAndIO​(ExecutionControl ec, InputStream inStream, OutputStream outStream, Map<String,Consumer<OutputStream>> outputStreamMap, Map<String,Consumer<InputStream>> inputStreamMap)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。

    • Uses of InputStream in jdk.jshell.spi

      Methods in jdk.jshell.spi that return InputStream
      Modifier and Type 方法 描述
      InputStream ExecutionEnv.userIn​()
      返回用户的输入流。

    • Uses of InputStream in jdk.jshell.tool

      Methods in jdk.jshell.tool with parameters of type InputStream
      Modifier and Type 方法 描述
      JavaShellToolBuilder JavaShellToolBuilder.in​(InputStream cmdIn, InputStream userIn)
      设置输入通道。

    • Uses of InputStream in org.ietf.jgss

      Methods in org.ietf.jgss with parameters of type InputStream
      Modifier and Type 方法 描述
      void GSSContext.acceptSecContext​(InputStream inStream, OutputStream outStream)
      由上下文接收方调用，使用流处理来自对等体的令牌。
      void GSSContext.getMIC​(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      使用流来生成包含所提供消息的加密MIC的令牌，以传送到对等应用程序。
      int GSSContext.initSecContext​(InputStream inStream, OutputStream outStream)
      由上下文发起者调用以启动上下文创建阶段， acceptSecContext对等体的 acceptSecContext方法使用流生成的任何令牌。
      void GSSContext.unwrap​(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      在上下文的另一边使用流来处理由 wrap方法生成的令牌。
      void GSSContext.verifyMIC​(InputStream tokStream, InputStream msgStream, MessageProp msgProp)
      通过提供的消息使用流来验证包含在令牌参数中的加密MIC。
      void GSSContext.wrap​(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      使用流在已建立的安全上下文中应用每消息安全服务。
      Constructors in org.ietf.jgss with parameters of type InputStream
      Constructor 描述
      Oid​(InputStream derOid)
      从其ASN.1 DER编码创建一个Oid对象。

    • Uses of InputStream in org.omg.CORBA_2_3.portable

      Subclasses of InputStream in org.omg.CORBA_2_3.portable
      Modifier and Type Class 描述
      class  InputStream
      InputStream提供从流中读取所有映射的IDL类型。

    • Uses of InputStream in org.omg.CORBA.portable

      Subclasses of InputStream in org.omg.CORBA.portable
      Modifier and Type Class 描述
      class  InputStream
      InputStream是用于从CDR元数据流读取IDL类型的Java API。

    • Uses of InputStream in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return InputStream
      Modifier and Type 方法 描述
      InputStream LSInput.getByteStream​()
      表示字节流的语言和绑定依赖类型的属性。
      Methods in org.w3c.dom.ls with parameters of type InputStream
      Modifier and Type 方法 描述
      void LSInput.setByteStream​(InputStream byteStream)
      表示字节流的语言和绑定依赖类型的属性。

    • Uses of InputStream in org.xml.sax

      Methods in org.xml.sax that return InputStream
      Modifier and Type 方法 描述
      InputStream InputSource.getByteStream​()
      获取此输入源的字节流。
      Methods in org.xml.sax with parameters of type InputStream
      Modifier and Type 方法 描述
      void InputSource.setByteStream​(InputStream byteStream)
      设置此输入源的字节流。
      Constructors in org.xml.sax with parameters of type InputStream
      Constructor 描述
      InputSource​(InputStream byteStream)
      创建一个带有字节流的新输入源。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.InputStreamReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.InputStreamReader

  • Packages that use InputStreamReader
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of InputStreamReader in java.io

      Subclasses of InputStreamReader in java.io
      Modifier and Type Class 描述
      class  FileReader
      阅读字符文件的便利课。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.InterruptedIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.InterruptedIOException

  • Packages that use InterruptedIOException
    软件包 描述
    java.net
    提供实现网络应用程序的类。

    • Uses of InterruptedIOException in java.net

      Subclasses of InterruptedIOException in java.net
      Modifier and Type Class 描述
      class  SocketTimeoutException
      指示在套接字上发生超时时读取或接受。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.InvalidClassException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.InvalidClassException

No usage of java.io.InvalidClassException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.InvalidObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.InvalidObjectException

  • Packages that use InvalidObjectException
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of InvalidObjectException in java.awt.font

      Methods in java.awt.font that throw InvalidObjectException
      Modifier and Type 方法 描述
      protected Object TextAttribute.readResolve​()
      解析反序列化为预定义常量的实例。

    • Uses of InvalidObjectException in java.io

      Methods in java.io that throw InvalidObjectException
      Modifier and Type 方法 描述
      void ObjectInputStream.registerValidation​(ObjectInputValidation obj, int prio)
      在返回图之前注册要验证的对象。
      void ObjectInputValidation.validateObject​()
      验证对象。

    • Uses of InvalidObjectException in java.text

      Methods in java.text that throw InvalidObjectException
      Modifier and Type 方法 描述
      protected Object AttributedCharacterIterator.Attribute.readResolve​()
      解析反序列化为预定义常量的实例。
      protected Object DateFormat.Field.readResolve​()
      解析反序列化为预定义常量的实例。
      protected Object MessageFormat.Field.readResolve​()
      解析反序列化为预定义常量的实例。
      protected Object NumberFormat.Field.readResolve​()
      解析反序列化为预定义常量的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.IOError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.IOError

No usage of java.io.IOError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.IOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.IOException

  • Packages that use IOException
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.connect.spi
    这个包包括用于开发新的TransportService实现的接口和类。
    com.sun.management
    此软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.security.auth.callback
    提供CallbackHandler的实现。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels软件包的服务提供程序类。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.activation
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.filechooser
    包含 JFileChooser组件使用的类和接口。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.xml.sax
    提供核心SAX API。
    org.xml.sax.ext
    提供与符合SAX驱动程序不一定支持的SAX2设施的接口。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of IOException in com.sun.jarsigner

      Methods in com.sun.jarsigner that throw IOException
      Modifier and Type 方法 描述
      abstract byte[] ContentSigner.generateSignedData​(ContentSignerParameters parameters, boolean omitContent, boolean applyTimestamp)
      已过时。
      生成PKCS＃7签名的数据消息。

    • Uses of IOException in com.sun.jdi

      Methods in com.sun.jdi that throw IOException
      Modifier and Type 方法 描述
      VirtualMachine VirtualMachineManager.createVirtualMachine​(Connection connection)
      创建一个新的虚拟机。
      VirtualMachine VirtualMachineManager.createVirtualMachine​(Connection connection, Process process)
      为目标虚拟机创建虚拟机镜像。

    • Uses of IOException in com.sun.jdi.connect

      Subclasses of IOException in com.sun.jdi.connect
      Modifier and Type Class 描述
      class  TransportTimeoutException
      当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。
      Methods in com.sun.jdi.connect that throw IOException
      Modifier and Type 方法 描述
      VirtualMachine ListeningConnector.accept​(Map<String,? extends Connector.Argument> arguments)
      等待目标VM附加到此连接器。
      VirtualMachine AttachingConnector.attach​(Map<String,? extends Connector.Argument> arguments)
      附加到正在运行的应用程序并返回其虚拟机的镜像。
      VirtualMachine LaunchingConnector.launch​(Map<String,? extends Connector.Argument> arguments)
      启动应用程序并连接到其VM。
      String ListeningConnector.startListening​(Map<String,? extends Connector.Argument> arguments)
      侦听由目标虚拟机发起的一个或多个连接。
      void ListeningConnector.stopListening​(Map<String,? extends Connector.Argument> arguments)
      取消侦听连接。

    • Uses of IOException in com.sun.jdi.connect.spi

      Subclasses of IOException in com.sun.jdi.connect.spi
      Modifier and Type Class 描述
      class  ClosedConnectionException
      由于在进行I / O操作时异步关闭Connection可能会抛出此异常。
      Methods in com.sun.jdi.connect.spi that throw IOException
      Modifier and Type 方法 描述
      abstract Connection TransportService.accept​(TransportService.ListenKey listenKey, long acceptTimeout, long handshakeTimeout)
      接受来自目标虚拟机的连接。
      abstract Connection TransportService.attach​(String address, long attachTimeout, long handshakeTimeout)
      附加到指定的地址。
      abstract void Connection.close​()
      关闭此连接。
      abstract byte[] Connection.readPacket​()
      从目标虚拟机读取数据包。
      abstract TransportService.ListenKey TransportService.startListening​()
      侦听由运输服务选择的地址。
      abstract TransportService.ListenKey TransportService.startListening​(String address)
      侦听入站连接的指定地址。
      abstract void TransportService.stopListening​(TransportService.ListenKey listenKey)
      停止监听入站连接。
      abstract void Connection.writePacket​(byte[] pkt)
      将数据包写入目标虚拟机。

    • Uses of IOException in com.sun.management

      Methods in com.sun.management that throw IOException
      Modifier and Type 方法 描述
      void HotSpotDiagnosticMXBean.dumpHeap​(String outputFile, boolean live)
      以与hprof堆转储相同的格式将堆转储到 outputFile文件。

    • Uses of IOException in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that throw IOException
      Modifier and Type 方法 描述
      abstract void HttpServer.bind​(InetSocketAddress addr, int backlog)
      将当前未绑定的HttpServer绑定到给定的地址和端口号。
      static HttpServer HttpServer.create​()
      创建一个最初没有绑定到任何本地地址/端口的HttpServer实例。
      static HttpServer HttpServer.create​(InetSocketAddress addr, int backlog)
      创建一个HttpServer实例，它将绑定到指定的InetSocketAddress （IP地址和端口号）也可以指定最大的积压。
      static HttpsServer HttpsServer.create​()
      创建一个最初没有绑定到任何本地地址/端口的HttpsServer实例。
      static HttpsServer HttpsServer.create​(InetSocketAddress addr, int backlog)
      创建将绑定到指定的InetSocketAddress （IP地址和端口号）的HttpsServer实例也可以指定最大的积压。
      void Filter.Chain.doFilter​(HttpExchange exchange)
      调用链中的下一个过滤器，否则用户交换处理程序，如果这是链中的最终过滤器。
      abstract void Filter.doFilter​(HttpExchange exchange, Filter.Chain chain)
      要求此过滤器预先/后处理给定的交换。
      void HttpHandler.handle​(HttpExchange exchange)
      处理给定的请求并产生适当的响应。
      abstract void HttpExchange.sendResponseHeaders​(int rCode, long responseLength)
      开始使用本方法中指定的当前响应头和数字响应代码将响应发送回客户端。

    • Uses of IOException in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi that throw IOException
      Modifier and Type 方法 描述
      abstract HttpServer HttpServerProvider.createHttpServer​(InetSocketAddress addr, int backlog)
      从此提供程序创建一个HttpServer
      abstract HttpsServer HttpServerProvider.createHttpsServer​(InetSocketAddress addr, int backlog)
      从此提供程序创建一个HttpsServer

    • Uses of IOException in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that throw IOException
      Modifier and Type 方法 描述
      abstract SctpChannel SctpServerChannel.accept​()
      在此频道的套接字上接受关联。
      abstract Association SctpChannel.association​()
      返回此通道的套接字上的关联。
      abstract Set<Association> SctpMultiChannel.associations​()
      返回此通道的套接字上的打开关联。
      abstract SctpChannel SctpChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      SctpMultiChannel SctpMultiChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SctpMultiChannel SctpMultiChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      SctpServerChannel SctpServerChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract SctpServerChannel SctpServerChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以侦听关联。
      abstract SctpChannel SctpChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpMultiChannel SctpMultiChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpServerChannel SctpServerChannel.bindAddress​(InetAddress address)
      将给定地址添加到通道插座的绑定地址。
      abstract SctpChannel SctpMultiChannel.branch​(Association association)
      分支协会。
      abstract boolean SctpChannel.connect​(SocketAddress remote)
      连接此通道的插座。
      abstract boolean SctpChannel.connect​(SocketAddress remote, int maxOutStreams, int maxInStreams)
      连接此通道的插座。
      abstract boolean SctpChannel.finishConnect​()
      完成连接SCTP通道的过程。
      abstract Set<SocketAddress> SctpChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpMultiChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract Set<SocketAddress> SctpServerChannel.getAllLocalAddresses​()
      返回此通道的套接字所绑定的所有套接字地址。
      abstract <T> T SctpChannel.getOption​(SctpSocketOption<T> name)
      返回套接字选项的值。
      abstract <T> T SctpMultiChannel.getOption​(SctpSocketOption<T> name, Association association)
      返回套接字选项的值。
      abstract <T> T SctpServerChannel.getOption​(SctpSocketOption<T> name)
      返回套接字选项的值。
      abstract Set<SocketAddress> SctpChannel.getRemoteAddresses​()
      返回此通道的套接字所连接的所有远程地址。
      abstract Set<SocketAddress> SctpMultiChannel.getRemoteAddresses​(Association association)
      返回此通道的套接字连接给定关联的所有远程地址。
      static SctpChannel SctpChannel.open​()
      打开SCTP通道。
      static SctpChannel SctpChannel.open​(SocketAddress remote, int maxOutStreams, int maxInStreams)
      打开SCTP通道并将其连接到远程地址。
      static SctpMultiChannel SctpMultiChannel.open​()
      打开SCTP多通道。
      static SctpServerChannel SctpServerChannel.open​()
      打开SCTP服务器通道。
      abstract <T> MessageInfo SctpChannel.receive​(ByteBuffer dst, T attachment, NotificationHandler<T> handler)
      在给定的缓冲区中接收消息和/或处理通知。
      abstract <T> MessageInfo SctpMultiChannel.receive​(ByteBuffer buffer, T attachment, NotificationHandler<T> handler)
      接收消息和/或通过此频道处理通知。
      abstract int SctpChannel.send​(ByteBuffer src, MessageInfo messageInfo)
      通过此频道发送消息。
      abstract int SctpMultiChannel.send​(ByteBuffer buffer, MessageInfo messageInfo)
      通过此频道发送消息。
      abstract <T> SctpChannel SctpChannel.setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
      abstract <T> SctpMultiChannel SctpMultiChannel.setOption​(SctpSocketOption<T> name, T value, Association association)
      设置套接字选项的值。
      abstract <T> SctpServerChannel SctpServerChannel.setOption​(SctpSocketOption<T> name, T value)
      设置套接字选项的值。
      abstract SctpChannel SctpChannel.shutdown​()
      关闭连接而不关闭通道。
      abstract SctpMultiChannel SctpMultiChannel.shutdown​(Association association)
      关闭关联而不关闭通道。
      abstract SctpChannel SctpChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
      abstract SctpMultiChannel SctpMultiChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。
      abstract SctpServerChannel SctpServerChannel.unbindAddress​(InetAddress address)
      从通道的套接字的绑定地址中删除给定的地址。

    • Uses of IOException in com.sun.security.auth.callback

      Methods in com.sun.security.auth.callback that throw IOException
      Modifier and Type 方法 描述
      void TextCallbackHandler.handle​(Callback[] callbacks)
      处理指定的一组回调。

    • Uses of IOException in com.sun.source.util

      Methods in com.sun.source.util that throw IOException
      Modifier and Type 方法 描述
      abstract Iterable<? extends Element> JavacTask.analyze​()
      完成所有分析。
      abstract Iterable<? extends JavaFileObject> JavacTask.generate​()
      生成代码。
      abstract DocCommentTree DocTrees.getDocCommentTree​(Element e, String relativePath)
      返回相对于给定元素指定路径的给定文件的doc注释树。
      abstract Iterable<? extends CompilationUnitTree> JavacTask.parse​()
      解析指定的文件，返回抽象语法树列表。

    • Uses of IOException in com.sun.tools.attach

      Subclasses of IOException in com.sun.tools.attach
      Modifier and Type Class 描述
      class  AttachOperationFailedException
      异常类型表示目标虚拟机中附着操作失败。
      Methods in com.sun.tools.attach that throw IOException
      Modifier and Type 方法 描述
      static VirtualMachine VirtualMachine.attach​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      static VirtualMachine VirtualMachine.attach​(String id)
      附加到Java虚拟机。
      abstract void VirtualMachine.detach​()
      脱离虚拟机。
      abstract Properties VirtualMachine.getAgentProperties​()
      返回目标虚拟机中的当前 代理属性 。
      abstract Properties VirtualMachine.getSystemProperties​()
      返回目标虚拟机中的当前系统属性。
      void VirtualMachine.loadAgent​(String agent)
      加载代理
      abstract void VirtualMachine.loadAgent​(String agent, String options)
      加载代理
      void VirtualMachine.loadAgentLibrary​(String agentLibrary)
      加载代理库。
      abstract void VirtualMachine.loadAgentLibrary​(String agentLibrary, String options)
      加载代理库。
      void VirtualMachine.loadAgentPath​(String agentPath)
      以完整路径名加载本地代理库。
      abstract void VirtualMachine.loadAgentPath​(String agentPath, String options)
      以完整路径名加载本地代理库。
      abstract String VirtualMachine.startLocalManagementAgent​()
      启动目标虚拟机中的本地JMX管理代理。
      abstract void VirtualMachine.startManagementAgent​(Properties agentProperties)
      启动目标虚拟机中的JMX管理代理。

    • Uses of IOException in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that throw IOException
      Modifier and Type 方法 描述
      VirtualMachine AttachProvider.attachVirtualMachine​(VirtualMachineDescriptor vmd)
      附加到Java虚拟机。
      abstract VirtualMachine AttachProvider.attachVirtualMachine​(String id)
      附加到Java虚拟机。

    • Uses of IOException in java.applet

      Methods in java.applet that throw IOException
      Modifier and Type 方法 描述
      void AppletContext.setStream​(String key, InputStream stream)
      已过时。
      将指定的流与此applet上下文中的指定关键字相关联。

    • Uses of IOException in java.awt

      Methods in java.awt that throw IOException
      Modifier and Type 方法 描述
      void Desktop.browse​(URI uri)
      启动默认浏览器以显示一个 URI 。
      static Font Font.createFont​(int fontFormat, File fontFile)
      使用指定的字体类型和指定的字体文件返回一个新的 Font 。
      static Font Font.createFont​(int fontFormat, InputStream fontStream)
      使用指定的字体类型和输入数据返回一个新的 Font 。
      static Font[] Font.createFonts​(File fontFile)
      返回从指定文件解码的新数组 Font 。
      static Font[] Font.createFonts​(InputStream fontStream)
      返回从指定的流解码的新数组 Font 。
      void Desktop.edit​(File file)
      启动相关的编辑器应用程序并打开一个文件进行编辑。
      void Desktop.mail​()
      启动用户默认邮件客户端的邮件组合窗口。
      void Desktop.mail​(URI mailtoURI)
      启动用户默认邮件客户端的邮件组合窗口，填写由 mailto: URI指定的邮件字段。
      void Desktop.open​(File file)
      启动相关应用程序以打开文件。
      void Desktop.print​(File file)
      使用相关应用程序的打印命令打印本机桌面打印设备的文件。
      protected static void AWTEventMulticaster.save​(ObjectOutputStream s, String k, EventListener l)
      将可序列化的监听器链保存到序列化流。
      protected void AWTEventMulticaster.saveInternal​(ObjectOutputStream s, String k)
      序列化支持。
      void SplashScreen.setImageURL​(URL imageURL)
      更改启动屏幕图像。

    • Uses of IOException in java.awt.color

      Methods in java.awt.color that throw IOException
      Modifier and Type 方法 描述
      static ICC_Profile ICC_Profile.getInstance​(InputStream s)
      构造一个与InputStream中数据对应的ICC_Profile。
      static ICC_Profile ICC_Profile.getInstance​(String fileName)
      构造与文件中数据对应的ICC_Profile。
      void ICC_Profile.write​(OutputStream s)
      将此ICC_Profile写入OutputStream。
      void ICC_Profile.write​(String fileName)
      将此ICC_Profile写入文件。

    • Uses of IOException in java.awt.datatransfer

      Methods in java.awt.datatransfer that throw IOException
      Modifier and Type 方法 描述
      Object Clipboard.getData​(DataFlavor flavor)
      在指定的 DataFlavor返回表示此剪贴板当前内容的对象。
      Reader DataFlavor.getReaderForText​(Transferable transferable)
      获取一个文本风味的阅读器，如有必要，解码为预期的字符集（编码）。
      Object StringSelection.getTransferData​(DataFlavor flavor)
      返回 Transferable所请求的数据 DataFlavor如果可能的话。
      Object Transferable.getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。
      void DataFlavor.readExternal​(ObjectInput is)
      从序列化状态恢复此 DataFlavor 。
      void DataFlavor.writeExternal​(ObjectOutput os)
      序列化这个 DataFlavor 。

    • Uses of IOException in java.awt.dnd

      Methods in java.awt.dnd that throw IOException
      Modifier and Type 方法 描述
      Object DropTargetContext.TransferableProxy.getTransferData​(DataFlavor df)
      返回一个对象，该对象表示由所请求的数据风格的可封装转移提供的数据。

    • Uses of IOException in java.awt.print

      Methods in java.awt.print that return IOException
      Modifier and Type 方法 描述
      IOException PrinterIOException.getIOException​()
      返回终止打印作业的 IOException 。
      Constructors in java.awt.print with parameters of type IOException
      Constructor 描述
      PrinterIOException​(IOException exception)
      构造一个新PrinterIOException用指定的字符串表示IOException 。

    • Uses of IOException in java.beans

      Methods in java.beans that throw IOException
      Modifier and Type 方法 描述
      static Object Beans.instantiate​(ClassLoader cls, String beanName)
      实例化JavaBean。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)
      实例化JavaBean。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
      已过时。
      建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of IOException in java.beans.beancontext

      Methods in java.beans.beancontext that throw IOException
      Modifier and Type 方法 描述
      protected void BeanContextServicesSupport.bcsPreDeserializationHook​(ObjectInputStream ois)
      从BeanContextSupport readObject中调用它反序列化子对象...
      protected void BeanContextSupport.bcsPreDeserializationHook​(ObjectInputStream ois)
      通过readObject在defaultReadObject（）之后调用，但在任何孩子反序列化之前。
      protected void BeanContextServicesSupport.bcsPreSerializationHook​(ObjectOutputStream oos)
      从BeanContextSupport中调用writeObject，然后序列化子对象...
      protected void BeanContextSupport.bcsPreSerializationHook​(ObjectOutputStream oos)
      在writeWriteObject（）之后但在序列化当前可序列化的孩子之前调用writeObject。
      protected void BeanContextSupport.deserialize​(ObjectInputStream ois, Collection coll)
      由readObject用于反序列化集合。
      Object BeanContext.instantiateChild​(String beanName)
      实例化命名为此 BeanContext的小孩的javaBean。
      Object BeanContextSupport.instantiateChild​(String beanName)
      instantiateChild方法是BeanContext中的一个方便的钩子，用于简化将Bean实例化的任务嵌套到一个 BeanContext 。
      void BeanContextSupport.readChildren​(ObjectInputStream ois)
      当这个类的实例被用作实现BeanContext协议（及其子协议）的委托时，在反序列化期间存在一个'鸡和蛋'问题
      protected void BeanContextSupport.serialize​(ObjectOutputStream oos, Collection<?> coll)
      由writeObject用于序列化集合。
      void BeanContextSupport.writeChildren​(ObjectOutputStream oos)
      用于序列化这个 BeanContext所有孩子。

    • Uses of IOException in java.io

      Subclasses of IOException in java.io
      Modifier and Type Class 描述
      class  CharConversionException
      字符转换异常的基类。
      class  EOFException
      表示在输入过程中意外地到达文件结束或流结束。
      class  FileNotFoundException
      指示尝试打开由指定路径名表示的文件失败。
      class  InterruptedIOException
      表示I / O操作已中断。
      class  InvalidClassException
      当序列化运行时检测到类中的以下问题之一时抛出。
      class  InvalidObjectException
      表示一个或多个反序列化对象失败的验证测试。
      class  NotActiveException
      序列化或反序列化不活跃时抛出。
      class  NotSerializableException
      抛出一个实例需要一个Serializable接口。
      class  ObjectStreamException
      对象流类别特有的所有异常的超类。
      class  OptionalDataException
      表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。
      class  StreamCorruptedException
      当从对象流读取的控制信息违反内部一致性检查时抛出。
      class  SyncFailedException
      发出同步操作失败的信号。
      class  UnsupportedEncodingException
      字符编码不支持。
      class  UTFDataFormatException
      表示 modified UTF-8格式的格式不正确的字符串已被读入数据输入流或实现数据输入接口的任何类。
      class  WriteAbortedException
      指示在写入操作期间抛出ObjectStreamExceptions之一。
      Methods in java.io that return IOException
      Modifier and Type 方法 描述
      IOException UncheckedIOException.getCause​()
      返回此异常的原因。
      Methods in java.io that throw IOException
      Modifier and Type | 方法 | 描述
      protected void ObjectOutputStream.annotateClass​(Class<?> cl)
      子类可以实现此方法，以允许类数据存储在流中。
      protected void ObjectOutputStream.annotateProxyClass​(Class<?> cl)
      子类可以实现这种方法来存储流中的自定义数据以及动态代理类的描述符。
      Writer | OutputStreamWriter.append​(CharSequence csq)
      Writer | OutputStreamWriter.append​(CharSequence csq, int start, int end)
      Writer Writer.append​(char c)
      将指定的字符附加到此作者。
      Writer Writer.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      Writer Writer.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      int BufferedInputStream.available​()
      从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
      int FileInputStream.available​()
      返回从此输入流中可以读取（或跳过）的剩余字节数的估计值，而不会被下一次调用此输入流的方法阻塞。
      int FilterInputStream.available​()
      返回从该输入流中可以读取（或跳过）的字节数的估计，而不会被下一个调用者阻塞该输入流的方法。
      int InputStream.available​()
      从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
      int LineNumberInputStream.available​()
      已过时。
      返回可以从该输入流读取而不阻塞的字节数。
      int ObjectInput.available​()
      返回可以读取而不阻塞的字节数。
      int ObjectInputStream.available​()
      返回可以读取而不阻塞的字节数。
      int PipedInputStream.available​()
      返回可以从该输入流读取而不阻塞的字节数。
      int PushbackInputStream.available​()
      从下一次调用此输入流的方法返回可从该输入流读取（或跳过）的字节数，而不会阻塞。
      int SequenceInputStream.available​()
      返回当前底层输入流可以读取（或跳过）的字节数，而不会被下一次调用当前底层输入流的方法阻塞。
      void BufferedInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void | BufferedReader.close​()
      void | BufferedWriter.close​()
      void ByteArrayInputStream.close​()
      关闭 ByteArrayInputStream没有任何效果。
      void ByteArrayOutputStream.close​()
      关闭 ByteArrayOutputStream没有任何效果。
      void Closeable.close​()
      关闭此流并释放与之相关联的任何系统资源。
      void FileInputStream.close​()
      关闭此文件输入流并释放与流相关联的任何系统资源。
      void FileOutputStream.close​()
      关闭此文件输出流并释放与此流相关联的任何系统资源。
      void FilterInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void FilterOutputStream.close​()
      关闭此输出流并释放与流相关联的任何系统资源。
      void | FilterReader.close​()
      void | FilterWriter.close​()
      void InputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void | InputStreamReader.close​()
      void ObjectInput.close​()
      关闭输入流。
      void ObjectInputStream.close​()
      关闭输入流。
      void ObjectOutput.close​()
      关闭流。
      void ObjectOutputStream.close​()
      关闭流。
      void OutputStream.close​()
      关闭此输出流并释放与此流相关联的任何系统资源。
      void | OutputStreamWriter.close​()
      void PipedInputStream.close​()
      关闭此管道输入流，并释放与流相关联的任何系统资源。
      void PipedOutputStream.close​()
      关闭此管道输出流，并释放与此流相关联的任何系统资源。
      void PipedReader.close​()
      关闭此管道流，并释放与流相关联的任何系统资源。
      void PipedWriter.close​()
      关闭此管道输出流，并释放与此流相关联的任何系统资源。
      void PushbackInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void PushbackReader.close​()
      关闭流并释放与之相关联的任何系统资源。
      void RandomAccessFile.close​()
      关闭此随机访问文件流并释放与流相关联的任何系统资源。
      abstract void Reader.close​()
      关闭流并释放与之相关联的任何系统资源。
      void SequenceInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void StringWriter.close​()
      关闭一个 StringWriter没有任何效果。
      abstract void Writer.close​()
      关闭流，先刷新。
      void PipedInputStream.connect​(PipedOutputStream src)
      使此管道输入流连接到管道输出流 src 。
      void PipedOutputStream.connect​(PipedInputStream snk)
      将此管道输出流连接到接收器。
      void PipedReader.connect​(PipedWriter src)
      使这个管道读取器连接到管道写入器 src 。
      void PipedWriter.connect​(PipedReader snk)
      将此管道写入器连接到接收器。
      boolean File.createNewFile​()
      当且仅当具有该名称的文件尚不存在时，原子地创建一个由该抽象路径名命名的新的空文件。
      static File File.createTempFile​(String prefix, String suffix)
      在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。
      static File File.createTempFile​(String prefix, String suffix, File directory)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      abstract boolean ObjectInputStream.GetField.defaulted​(String name)
      如果命名字段是默认值，并且此流中没有值，则返回true。
      void ObjectInputStream.defaultReadObject​()
      从此流读取当前类的非静态和非瞬态字段。
      void ObjectOutputStream.defaultWriteObject​()
      将当前类的非静态和非瞬态字段写入此流。
      protected void ObjectOutputStream.drain​()
      排除ObjectOutputStream中的缓冲数据。
      protected void FileInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void FileOutputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      void BufferedOutputStream.flush​()
      刷新缓冲输出流。
      void BufferedWriter.flush​()
      刷新流。
      void DataOutputStream.flush​()
      刷新此数据输出流。
      void FilterOutputStream.flush​()
      刷新此输出流，并强制将任何缓冲的输出字节写入流。
      void FilterWriter.flush​()
      刷新流。
      void Flushable.flush​()
      通过将任何缓冲的输出写入底层流来刷新流。
      void ObjectOutput.flush​()
      刷新流。
      void ObjectOutputStream.flush​()
      刷新流。
      void OutputStream.flush​()
      刷新此输出流并强制任何缓冲的输出字节被写出。
      void OutputStreamWriter.flush​()
      刷新流。
      void PipedOutputStream.flush​()
      刷新此输出流并强制任何缓冲的输出字节被写出。
      void PipedWriter.flush​()
      刷新此输出流并强制任何缓冲的输出字符被写出。
      abstract void Writer.flush​()
      刷新流。
      abstract boolean ObjectInputStream.GetField.get​(String name, boolean val)
      从持久化字段获取命名布尔字段的值。
      abstract byte ObjectInputStream.GetField.get​(String name, byte val)
      从持久化字段获取命名字节字段的值。
      abstract char ObjectInputStream.GetField.get​(String name, char val)
      从持久化字段获取命名的char字段的值。
      abstract double ObjectInputStream.GetField.get​(String name, double val)
      从持续字段获取命名的双字段的值。
      abstract float ObjectInputStream.GetField.get​(String name, float val)
      从持久化字段获取命名的float字段的值。
      abstract int ObjectInputStream.GetField.get​(String name, int val)
      从持久化字段获取命名的int字段的值。
      abstract long ObjectInputStream.GetField.get​(String name, long val)
      从持久化字段获取命名的长字段的值。
      abstract short ObjectInputStream.GetField.get​(String name, short val)
      从持续字段获取命名的短字段的值。
      abstract Object ObjectInputStream.GetField.get​(String name, Object val)
      从持久化字段获取命名的对象字段的值。
      File File.getCanonicalFile​()
      返回此抽象路径名的规范形式。
      String File.getCanonicalPath​()
      返回此抽象路径名的规范路径名字符串。
      FileDescriptor FileInputStream.getFD​()
      返回 FileDescriptor对象，表示与该 FileInputStream正在使用的文件系统中的实际文件的连接。
      FileDescriptor FileOutputStream.getFD​()
      返回与此流相关联的文件描述符。
      FileDescriptor RandomAccessFile.getFD​()
      返回与此流关联的不透明文件描述符对象。
      long RandomAccessFile.getFilePointer​()
      返回此文件中的当前偏移量。
      long RandomAccessFile.length​()
      返回此文件的长度。
      void BufferedReader.mark​(int readAheadLimit)
      标记流中的当前位置。
      void CharArrayReader.mark​(int readAheadLimit)
      标记流中的当前位置。
      void FilterReader.mark​(int readAheadLimit)
      标记流中的当前位置。
      void LineNumberReader.mark​(int readAheadLimit)
      标记流中的当前位置。
      void PushbackReader.mark​(int readAheadLimit)
      标记流中的当前位置。
      void Reader.mark​(int readAheadLimit)
      标记流中的当前位置。
      void StringReader.mark​(int readAheadLimit)
      标记流中的当前位置。
      void BufferedWriter.newLine​()
      写一行行分隔符。
      int StreamTokenizer.nextToken​()
      从此分类器的输入流中解析下一个令牌。
      ObjectOutputStream.PutField ObjectOutputStream.putFields​()
      检索用于缓冲要写入流的持久性字段的对象。
      int BufferedInputStream.read​()
      见 read法 InputStream的一般合同。
      int BufferedInputStream.read​(byte[] b, int off, int len)
      从给定的偏移开始，将字节输入流中的字节读入指定的字节数组。
      int BufferedReader.read​()
      读一个字符
      int BufferedReader.read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      int CharArrayReader.read​()
      读一个字符
      int CharArrayReader.read​(char[] b, int off, int len)
      将字符读入数组的一部分。
      int DataInputStream.read​(byte[] b)
      从包含的输入流读取一些字节数，并将它们存储到缓冲器阵列 b 。
      int DataInputStream.read​(byte[] b, int off, int len)
      从包含的输入流读取高达 len字节的数据到字节数组。
      int FileInputStream.read​()
      从该输入流读取一个字节的数据。
      int FileInputStream.read​(byte[] b)
      从该输入流读取高达 b.length字节的数据到一个字节数组。
      int FileInputStream.read​(byte[] b, int off, int len)
      从这个输入流读取最多 len字节的数据到字节数组。
      int FilterInputStream.read​()
      从该输入流读取下一个数据字节。
      int FilterInputStream.read​(byte[] b)
      从该输入流读取最多 b.length个字节的数据为字节数组。
      int FilterInputStream.read​(byte[] b, int off, int len)
      从该输入流读取高达 len字节的数据到一个字节数组。
      int FilterReader.read​()
      读一个字符
      int FilterReader.read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      abstract int InputStream.read​()
      从输入流读取数据的下一个字节。
      int InputStream.read​(byte[] b)
      从输入流读取一些数量的字节，并将它们存储到缓冲器阵列 b 。
      int InputStream.read​(byte[] b, int off, int len)
      从输入流读取高达 len字节的数据到字节数组。
      int InputStreamReader.read​()
      读一个字符
      int InputStreamReader.read​(char[] cbuf, int offset, int length)
      将字符读入数组的一部分。
      int LineNumberInputStream.read​()
      已过时。
      从该输入流读取下一个数据字节。
      int LineNumberInputStream.read​(byte[] b, int off, int len)
      已过时。
      从该输入流读取高达 len字节的数据到字节数组。
      int LineNumberReader.read​()
      读一个字符
      int LineNumberReader.read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      int ObjectInput.read​()
      读取一个字节的数据。
      int ObjectInput.read​(byte[] b)
      读入一个字节数组。
      int ObjectInput.read​(byte[] b, int off, int len)
      读入一个字节数组。
      int ObjectInputStream.read​()
      读取一个字节的数据。
      int ObjectInputStream.read​(byte[] buf, int off, int len)
      读入一个字节数组。
      int PipedInputStream.read​()
      从这个管道输入流读取数据的下一个字节。
      int PipedInputStream.read​(byte[] b, int off, int len)
      从这个管道输入流读取高达 len字节的数据到字节数组。
      int PipedReader.read​()
      从这个管道流读取下一个数据字符。
      int PipedReader.read​(char[] cbuf, int off, int len)
      从这个管道数据流读取最多 len字符的字符数组。
      int PushbackInputStream.read​()
      从该输入流读取下一个数据字节。
      int PushbackInputStream.read​(byte[] b, int off, int len)
      从该输入流读取最多 len个字节的数据到一个字节数组。
      int PushbackReader.read​()
      读一个字符
      int PushbackReader.read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      int RandomAccessFile.read​()
      从该文件读取一个字节的数据。
      int RandomAccessFile.read​(byte[] b)
      从该文件读取最多 b.length个字节的数据到一个字节数组。
      int RandomAccessFile.read​(byte[] b, int off, int len)
      从该文件读取最多 len个字节的数据到字节数组。
      int Reader.read​()
      读一个字符
      int Reader.read​(char[] cbuf)
      将字符读入数组。
      abstract int Reader.read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      int Reader.read​(CharBuffer target)
      尝试将字符读入指定的字符缓冲区。
      int SequenceInputStream.read​()
      从该输入流读取下一个数据字节。
      int SequenceInputStream.read​(byte[] b, int off, int len)
      从这个输入流读取最多 len字节的数据到字节数组。
      int StringReader.read​()
      读一个字符
      int StringReader.read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      byte[] InputStream.readAllBytes​()
      从输入流读取所有剩余字节。
      boolean DataInput.readBoolean​()
      读取一个输入字节，并返回 true如果该字节不为零， false如果该字节是零。
      boolean DataInputStream.readBoolean​()
      见 readBoolean法 DataInput的一般合同。
      boolean ObjectInputStream.readBoolean​()
      读取布尔值。
      boolean RandomAccessFile.readBoolean​()
      从此文件读取一个 boolean 。
      byte DataInput.readByte​()
      读取并返回一个输入字节。
      byte DataInputStream.readByte​()
      见 readByte法 DataInput的一般合同。
      byte ObjectInputStream.readByte​()
      读取一个8位字节。
      byte RandomAccessFile.readByte​()
      从此文件中读取一个带符号的八位值。
      char DataInput.readChar​()
      新新新新新新200新 char
      char DataInputStream.readChar​()
      见 readChar方法的一般合同 DataInput 。
      char ObjectInputStream.readChar​()
      读一个16位字符。
      char RandomAccessFile.readChar​()
      从此文件中读取一个字符。
      protected ObjectStreamClass ObjectInputStream.readClassDescriptor​()
      从序列化流读取类描述符。
      double DataInput.readDouble​()
      读取八个输入字节并返回一个 double值。
      double DataInputStream.readDouble​()
      见 readDouble法 DataInput的一般合同。
      double ObjectInputStream.readDouble​()
      读64位双倍。
      double RandomAccessFile.readDouble​()
      从此文件读取一个 double 。
      void Externalizable.readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。
      ObjectInputStream.GetField ObjectInputStream.readFields​()
      从流中读取持久性字段，并通过名称使其可用。
      float DataInput.readFloat​()
      读取四个输入字节并返回一个 float值。
      float DataInputStream.readFloat​()
      见 readFloat法 DataInput的一般合同。
      float ObjectInputStream.readFloat​()
      读32位浮点数。
      float RandomAccessFile.readFloat​()
      从此文件读取一个 float 。
      void DataInput.readFully​(byte[] b)
      从输入流读取一些字节并将其存储到缓冲区阵列 b 。
      void DataInput.readFully​(byte[] b, int off, int len)
      从输入流读取 len个字节。
      void DataInputStream.readFully​(byte[] b)
      见 readFully法 DataInput的一般合同。
      void DataInputStream.readFully​(byte[] b, int off, int len)
      见 readFully法 DataInput的一般合同。
      void ObjectInputStream.readFully​(byte[] buf)
      读取字节，阻塞直到读取所有字节。
      void ObjectInputStream.readFully​(byte[] buf, int off, int len)
      读取字节，阻塞直到读取所有字节。
      void RandomAccessFile.readFully​(byte[] b)
      从该文件读取 b.length个字节到字节数组，从当前文件指针开始。
      void RandomAccessFile.readFully​(byte[] b, int off, int len)
      从这个文件读取完全 len个字节到字节数组，从当前文件指针开始。
      int DataInput.readInt​()
      读取四个输入字节并返回一个 int值。
      int DataInputStream.readInt​()
      见 readInt法 DataInput的一般合同。
      int ObjectInputStream.readInt​()
      读取一个32位int。
      int RandomAccessFile.readInt​()
      从该文件读取一个带符号的32位整数。
      String BufferedReader.readLine​()
      读一行文字。
      String DataInput.readLine​()
      从输入流读取下一行文本。
      String DataInputStream.readLine​()
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1开始，读取文本行的首选方式是通过BufferedReader.readLine()方法。 使用DataInputStream类读取行的程序可以转换为使用BufferedReader类替换以下形式的代码：
           DataInputStream d = new DataInputStream(in);
      有：
           BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
      String LineNumberReader.readLine​()
      读一行文字。
      String ObjectInputStream.readLine​()
      已过时。
      此方法无法将字节正确转换为字符。 有关详细信息和替代方案，请参阅DataInputStream。
      String RandomAccessFile.readLine​()
      从此文件中读取下一行文本。
      long DataInput.readLong​()
      读取八个输入字节并返回一个 long值。
      long DataInputStream.readLong​()
      见 readLong法 DataInput的一般合同。
      long ObjectInputStream.readLong​()
      读64位长。
      long RandomAccessFile.readLong​()
      从该文件中读取一个带符号的64位整数。
      int InputStream.readNBytes​(byte[] b, int off, int len)
      将所请求的字节数从输入流读入给定的字节数组。
      Object ObjectInput.readObject​()
      读取并返回一个对象。
      Object ObjectInputStream.readObject​()
      从ObjectInputStream读取一个对象。
      protected Object ObjectInputStream.readObjectOverride​()
      此方法由ObjectOutputStream的受信任子类调用，该子类使用受保护的无参构造函数构造ObjectOutputStream。
      short DataInput.readShort​()
      读取两个输入字节并返回一个 short值。
      short DataInputStream.readShort​()
      见 readShort法 DataInput的一般合同。
      short ObjectInputStream.readShort​()
      读取16位短。
      short RandomAccessFile.readShort​()
      从此文件中读取一个已签名的16位数字。
      protected void ObjectInputStream.readStreamHeader​()
      提供了readStreamHeader方法来允许子类读取和验证自己的流标题。
      Object ObjectInputStream.readUnshared​()
      从ObjectInputStream读取一个“非共享”对象。
      int DataInput.readUnsignedByte​()
      读取一个输入字节，将其扩展到类型 int ，并返回结果，因此在 0到 255 。
      int DataInputStream.readUnsignedByte​()
      见 readUnsignedByte法 DataInput的一般合同。
      int ObjectInputStream.readUnsignedByte​()
      读取一个无符号的8位字节。
      int RandomAccessFile.readUnsignedByte​()
      从此文件中读取一个无符号的八位数字。
      int DataInput.readUnsignedShort​()
      读取两个输入字节，并返回一个 int范围值 0通过 65535 。
      int DataInputStream.readUnsignedShort​()
      见 readUnsignedShort法 DataInput的一般合同。
      int ObjectInputStream.readUnsignedShort​()
      读取无符号16位短。
      int RandomAccessFile.readUnsignedShort​()
      从该文件中读取一个无符号的16位数字。
      String DataInput.readUTF​()
      读取已使用 modified UTF-8格式编码的字符串。
      String DataInputStream.readUTF​()
      见 readUTF法 DataInput的一般合同。
      static String DataInputStream.readUTF​(DataInput in)
      从流in读取一个以modified UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为String返回。
      String ObjectInputStream.readUTF​()
      以 modified UTF-8格式读取字符串。
      String RandomAccessFile.readUTF​()
      从该文件读取字符串。
      boolean BufferedReader.ready​()
      告诉这个流是否准备好被读取。
      boolean CharArrayReader.ready​()
      告诉这个流是否准备好被读取。
      boolean FilterReader.ready​()
      告诉这个流是否准备好被读取。
      boolean InputStreamReader.ready​()
      告诉这个流是否准备好被读取。
      boolean PipedReader.ready​()
      告诉这个流是否准备好阅读。
      boolean PushbackReader.ready​()
      告诉这个流是否准备好被读取。
      boolean Reader.ready​()
      告诉这个流是否准备好被读取。
      boolean StringReader.ready​()
      告诉这个流是否准备好被读取。
      protected void PipedInputStream.receive​(int b)
      接收一个字节的数据。
      protected Object ObjectOutputStream.replaceObject​(Object obj)
      该方法将允许ObjectOutputStream的可信子类在序列化期间将一个对象替换为另一个对象。
      void BufferedInputStream.reset​()
      见 reset法 InputStream的一般合同。
      void BufferedReader.reset​()
      将流重置为最近的标记。
      void CharArrayReader.reset​()
      将流重新设置为最近的标记，或将其重新设置为从未被标记的开始。
      void FilterInputStream.reset​()
      将此流重新定位到最近在此输入流上调用 mark方法时的位置。
      void FilterReader.reset​()
      重置流。
      void InputStream.reset​()
      将此流重新定位到最近在此输入流上调用 mark方法时的位置。
      void LineNumberInputStream.reset​()
      已过时。
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      void LineNumberReader.reset​()
      将流重新设置为最近的标记。
      void ObjectOutputStream.reset​()
      复位将忽略已写入流的任何对象的状态。
      void PushbackInputStream.reset​()
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      void PushbackReader.reset​()
      重置流。
      void Reader.reset​()
      重置流。
      void StringReader.reset​()
      将流重新设置为最近的标记，如果从未被标记，则将其重置到字符串的开头。
      protected Class<?> ObjectInputStream.resolveClass​(ObjectStreamClass desc)
      加载本地类等效的指定流类描述。
      protected Object ObjectInputStream.resolveObject​(Object obj)
      此方法将允许ObjectInputStream的受信任子类在反序列化期间将一个对象替换为另一个对象。
      protected Class<?> ObjectInputStream.resolveProxyClass​(String[] interfaces)
      返回一个代理类，它实现代理类描述符中命名的接口; 子类可以实现此方法从流中读取自定义数据以及动态代理类的描述符，从而允许它们为接口和代理类使用备用加载机制。
      void RandomAccessFile.seek​(long pos)
      设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。
      void RandomAccessFile.setLength​(long newLength)
      设置此文件的长度。
      long BufferedInputStream.skip​(long n)
      见 skip法 InputStream的一般合同。
      long BufferedReader.skip​(long n)
      跳过字符
      long CharArrayReader.skip​(long n)
      跳过字符
      long FileInputStream.skip​(long n)
      跳过并从输入流中丢弃 n字节的数据。
      long FilterInputStream.skip​(long n)
      跳过并从输入流中丢弃 n字节的数据。
      long FilterReader.skip​(long n)
      跳过字符
      long InputStream.skip​(long n)
      跳过并丢弃来自此输入流的 n字节的数据。
      long LineNumberInputStream.skip​(long n)
      已过时。
      跳过并从该输入流中丢弃 n字节的数据。
      long LineNumberReader.skip​(long n)
      跳过字符
      long ObjectInput.skip​(long n)
      跳过n个字节的输入。
      long PushbackInputStream.skip​(long n)
      跳过并丢弃来自此输入流的 n字节的数据。
      long PushbackReader.skip​(long n)
      跳过字符
      long Reader.skip​(long n)
      跳过字符
      long StringReader.skip​(long ns)
      跳过流中指定数量的字符。
      int DataInput.skipBytes​(int n)
      尝试从输入流中跳过 n个字节的数据，丢弃跳过的字节。
      int DataInputStream.skipBytes​(int n)
      见 skipBytes法 DataInput的一般合同。
      int ObjectInputStream.skipBytes​(int len)
      跳过字节。
      int RandomAccessFile.skipBytes​(int n)
      尝试跳过 n字节的输入丢弃跳过的字节。
      long InputStream.transferTo​(OutputStream out)
      从该输入流中读取所有字节，并按读取的顺序将字节写入给定的输出流。
      void PushbackInputStream.unread​(byte[] b)
      将一个字节数组复制回推回缓冲区的前端。
      void PushbackInputStream.unread​(byte[] b, int off, int len)
      通过将字节数组复制到推回缓冲区的前端来推回一部分数组。
      void PushbackInputStream.unread​(int b)
      通过将其复制到推回缓冲区的前端来推回一个字节。
      void PushbackReader.unread​(char[] cbuf)
      将一个字符数组复制回推回缓冲区的前端。
      void PushbackReader.unread​(char[] cbuf, int off, int len)
      通过将一部分字符复制到推回缓冲区的前端来推回。
      void PushbackReader.unread​(int c)
      将单个字符复制回推回缓冲区的前端。
      void ObjectOutputStream.useProtocolVersion​(int version)
      指定在编写流时使用的流协议版本。
      void BufferedOutputStream.write​(byte[] b, int off, int len)
      从偏移量 off开始的指定字节数组写入 len字节到缓冲输出流。
      void BufferedOutputStream.write​(int b)
      将指定的字节写入缓冲的输出流。
      void BufferedWriter.write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void BufferedWriter.write​(int c)
      写一个字符
      void BufferedWriter.write​(String s, int off, int len)
      写一个字符串的一部分。
      void DataOutput.write​(byte[] b)
      将输出流写入数组 b所有字节。
      void DataOutput.write​(byte[] b, int off, int len)
      从阵列 b写入 len个字节，以输出流。
      void DataOutput.write​(int b)
      向输出流写入参数 b的八个低位。
      void DataOutputStream.write​(byte[] b, int off, int len)
      从指定的字节数组写入 len个字节，从偏移 off开始到底层输出流。
      void DataOutputStream.write​(int b)
      将指定的字节（参数 b的低8位）写入底层输出流。
      void FileOutputStream.write​(byte[] b)
      将 b.length字节从指定的字节数组写入此文件输出流。
      void FileOutputStream.write​(byte[] b, int off, int len)
      从偏移 off开始的指定字节数组写入 len字节到该文件输出流。
      void FileOutputStream.write​(int b)
      将指定的字节写入此文件输出流。
      void FilterOutputStream.write​(byte[] b)
      将 b.length字节写入此输出流。
      void FilterOutputStream.write​(byte[] b, int off, int len)
      写入 len从指定的字节 byte数组以抵消 off此输出流。
      void FilterOutputStream.write​(int b)
      将指定的 byte写入此输出流。
      void FilterWriter.write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void FilterWriter.write​(int c)
      写一个字符
      void FilterWriter.write​(String str, int off, int len)
      写一个字符串的一部分。
      void ObjectOutput.write​(byte[] b)
      写入一个字节数组。
      void ObjectOutput.write​(byte[] b, int off, int len)
      写入一个子字节数组。
      void ObjectOutput.write​(int b)
      写一个字节。
      abstract void ObjectOutputStream.PutField.write​(ObjectOutput out)
      已过时。
      此方法不会以适当的格式写入此PutField对象所包含的值，并可能导致序列化流的损坏。 写PutField数据的正确方法是通过调用ObjectOutputStream.writeFields()方法。
      void ObjectOutputStream.write​(byte[] buf)
      写入一个字节数组。
      void ObjectOutputStream.write​(byte[] buf, int off, int len)
      写入一个子字节数组。
      void ObjectOutputStream.write​(int val)
      写一个字节。
      void OutputStream.write​(byte[] b)
      将 b.length字节从指定的字节数组写入此输出流。
      void OutputStream.write​(byte[] b, int off, int len)
      从偏移 off开始的指定字节数组写入 len字节到此输出流。
      abstract void OutputStream.write​(int b)
      将指定的字节写入此输出流。
      void OutputStreamWriter.write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void OutputStreamWriter.write​(int c)
      写一个字符
      void OutputStreamWriter.write​(String str, int off, int len)
      写一个字符串的一部分。
      void PipedOutputStream.write​(byte[] b, int off, int len)
      从指定的字节数组写入 len字节，从偏移量 off开始 off到这个管道输出流。
      void PipedOutputStream.write​(int b)
      将指定的 byte写入管道输出流。
      void PipedWriter.write​(char[] cbuf, int off, int len)
      从指定的字符数组写入 len字符，从偏移量 off开始 off到这个管道输出流。
      void PipedWriter.write​(int c)
      将指定的 char写入管道输出流。
      void RandomAccessFile.write​(byte[] b)
      从指定的字节数组写入 b.length字节到该文件，从当前文件指针开始。
      void RandomAccessFile.write​(byte[] b, int off, int len)
      从指定的字节数组写入 len字节，从偏移量 off开始写入此文件。
      void RandomAccessFile.write​(int b)
      将指定的字节写入此文件。
      void Writer.write​(char[] cbuf)
      写入一个字符数组。
      abstract void Writer.write​(char[] cbuf, int off, int len)
      写入字符数组的一部分。
      void Writer.write​(int c)
      写一个字符
      void Writer.write​(String str)
      写一个字符串
      void Writer.write​(String str, int off, int len)
      写一个字符串的一部分。
      void DataOutput.writeBoolean​(boolean v)
      向此输出流写入一个 boolean值。
      void DataOutputStream.writeBoolean​(boolean v)
      将底层输出流写入 boolean作为1字节值。
      void ObjectOutputStream.writeBoolean​(boolean val)
      写一个布尔值。
      void RandomAccessFile.writeBoolean​(boolean v)
      将 boolean写入文件作为单字节值。
      void DataOutput.writeByte​(int v)
      向输出流写入参数 v的八个低位位。
      void DataOutputStream.writeByte​(int v)
      将底层输出流作为1字节值写入 byte 。
      void ObjectOutputStream.writeByte​(int val)
      写入一个8位字节。
      void RandomAccessFile.writeByte​(int v)
      将 byte写入文件作为单字节值。
      void DataOutput.writeBytes​(String s)
      将一个字符串写入输出流。
      void DataOutputStream.writeBytes​(String s)
      将字符串作为字节序列写入基础输出流。
      void ObjectOutputStream.writeBytes​(String str)
      写一个字符串作为字节序列。
      void RandomAccessFile.writeBytes​(String s)
      将字符串作为字节序列写入文件。
      void DataOutput.writeChar​(int v)
      向输出流写入由两个字节组成的 char值。
      void DataOutputStream.writeChar​(int v)
      将底层输出流写入 char作为2字节值，高字节优先。
      void ObjectOutputStream.writeChar​(int val)
      写一个16位的字符。
      void RandomAccessFile.writeChar​(int v)
      将 char写入文件作为双字节值，高位字节。
      void DataOutput.writeChars​(String s)
      将字符串 s中的每个字符写入输出流，按顺序排列每个字符两个字节。
      void DataOutputStream.writeChars​(String s)
      将字符串写入底层输出流作为一系列字符。
      void ObjectOutputStream.writeChars​(String str)
      写一个字符串作为一系列的字符。
      void RandomAccessFile.writeChars​(String s)
      将一个字符串作为字符序列写入文件。
      protected void ObjectOutputStream.writeClassDescriptor​(ObjectStreamClass desc)
      将指定的类描述符写入ObjectOutputStream。
      void DataOutput.writeDouble​(double v)
      向输出流写入一个由八个字节组成的 double值。
      void DataOutputStream.writeDouble​(double v)
      使用 long中的 doubleToLongBits方法将双参数转换为 Double ，然后将 long值写入底层输出流，为8字节数量，高字节为首。
      void ObjectOutputStream.writeDouble​(double val)
      写一个64位的双倍。
      void RandomAccessFile.writeDouble​(double v)
      使用 long中的 doubleToLongBits方法将双参数转换为 Double ，然后 long值作为八字节数量（高字节优先）写入该文件。
      void Externalizable.writeExternal​(ObjectOutput out)
      该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput的对象，字符串和数组的writeObject方法来保存其内容。
      void ObjectOutputStream.writeFields​()
      将缓冲的字段写入流。
      void DataOutput.writeFloat​(float v)
      向输出流写入由四个字节组成的 float值。
      void DataOutputStream.writeFloat​(float v)
      使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后将 int值写入底层输出流，为4字节数量，高字节。
      void ObjectOutputStream.writeFloat​(float val)
      写一个32位浮点数。
      void RandomAccessFile.writeFloat​(float v)
      使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后 int值作为四字节数量，高字节先写入该文件。
      void DataOutput.writeInt​(int v)
      向输出流写入一个由四个字节组成的 int值。
      void DataOutputStream.writeInt​(int v)
      将基础输出流 int写入四字节，高位字节。
      void ObjectOutputStream.writeInt​(int val)
      写一个32位int。
      void RandomAccessFile.writeInt​(int v)
      将 int写入文件为四个字节，高字节为首。
      void DataOutput.writeLong​(long v)
      向输出流写入一个由8个字节组成的 long值。
      void DataOutputStream.writeLong​(long v)
      将底层输出流写入一个 long作为八字节，高位字节。
      void ObjectOutputStream.writeLong​(long val)
      写一个64位长
      void RandomAccessFile.writeLong​(long v)
      写入一个 long到文件为八个字节，高字节第一。
      void ObjectOutput.writeObject​(Object obj)
      将对象写入底层存储或流。
      void ObjectOutputStream.writeObject​(Object obj)
      将指定的对象写入ObjectOutputStream。
      protected void ObjectOutputStream.writeObjectOverride​(Object obj)
      子类使用的方法来覆盖默认的writeObject方法。
      void DataOutput.writeShort​(int v)
      将两个字节写入输出流以表示参数的值。
      void DataOutputStream.writeShort​(int v)
      将底层输出流写入 short作为两个字节，高字节优先。
      void ObjectOutputStream.writeShort​(int val)
      写一个16位短。
      void RandomAccessFile.writeShort​(int v)
      将 short写入文件作为两个字节，高字节优先。
      protected void ObjectOutputStream.writeStreamHeader​()
      提供了writeStreamHeader方法，因此子类可以在流中附加或预先添加自己的头。
      void ByteArrayOutputStream.writeTo​(OutputStream out)
      将此字节数组输出流的完整内容写入指定的输出流参数，就像使用 out.write(buf, 0, count)调用输出流的写入方法 out.write(buf, 0, count) 。
      void CharArrayWriter.writeTo​(Writer out)
      将缓冲区的内容写入另一个字符流。
      void ObjectOutputStream.writeUnshared​(Object obj)
      将“非共享”对象写入ObjectOutputStream。
      void DataOutput.writeUTF​(String s)
      将两个字节的长度信息写入输出流，其后是字符串 s中每个字符的 modified UTF-8表示。
      void DataOutputStream.writeUTF​(String str)
      使用机器无关的方式使用 modified UTF-8编码将字符串写入底层输出流。
      void ObjectOutputStream.writeUTF​(String str)
      此字符串的原始数据写入格式为 modified UTF-8 。
      void RandomAccessFile.writeUTF​(String str)
      使用机器无关的方式使用 modified UTF-8编码将字符串写入文件。
      Constructors in java.io with parameters of type IOException
      Constructor 描述
      UncheckedIOException​(IOException cause)
      构造这个类的一个实例。
      UncheckedIOException​(String message, IOException cause)
      构造这个类的一个实例。
      Constructors in java.io that throw IOException
      Constructor 描述
      FileWriter​(File file)
      给一个File对象构造一个FileWriter对象。
      FileWriter​(File file, boolean append)
      给一个File对象构造一个FileWriter对象。
      FileWriter​(String fileName)
      构造一个给定文件名的FileWriter对象。
      FileWriter​(String fileName, boolean append)
      构造一个FileWriter对象，给出一个带有布尔值的文件名，表示是否附加写入的数据。
      ObjectInputStream​()
      为完全重新实现ObjectInputStream的子类提供一种方法，不必分配刚刚被ObjectInputStream实现使用的私有数据。
      ObjectInputStream​(InputStream in)
      创建从指定的InputStream读取的ObjectInputStream。
      ObjectOutputStream​()
      为完全重新实现ObjectOutputStream的子类提供一种方法，不必分配刚刚被ObjectOutputStream实现使用的私有数据。
      ObjectOutputStream​(OutputStream out)
      创建一个写入指定的OutputStream的ObjectOutputStream。
      PipedInputStream​(PipedOutputStream src)
      创建 PipedInputStream ，使其连接到管道输出流 src 。
      PipedInputStream​(PipedOutputStream src, int pipeSize)
      创建一个 PipedInputStream ，使其连接到管道输出流 src并为管道缓冲区使用指定的管道大小。
      PipedOutputStream​(PipedInputStream snk)
      创建连接到指定管道输入流的管道输出流。
      PipedReader​(PipedWriter src)
      创建一个 PipedReader ，使其连接到管道写入器 src 。
      PipedReader​(PipedWriter src, int pipeSize)
      创建一个 PipedReader ，使其连接到管道写入器 src并使用指定的管道大小作为管道的缓冲区。
      PipedWriter​(PipedReader snk)
      创建连接到指定管道读取器的管道写入器。

    • Uses of IOException in java.lang

      Methods in java.lang that throw IOException
      Modifier and Type 方法 描述
      Appendable Appendable.append​(char c)
      将指定的字符追加到此 Appendable 。
      Appendable Appendable.append​(CharSequence csq)
      将指定的字符序列追加到此 Appendable 。
      Appendable Appendable.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列追加到此 Appendable 。
      Process Runtime.exec​(String command)
      在单独的进程中执行指定的字符串命令。
      Process Runtime.exec​(String[] cmdarray)
      在单独的进程中执行指定的命令和参数。
      Process Runtime.exec​(String[] cmdarray, String[] envp)
      在指定环境的单独进程中执行指定的命令和参数。
      Process Runtime.exec​(String[] cmdarray, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的命令和参数。
      Process Runtime.exec​(String command, String[] envp)
      在具有指定环境的单独进程中执行指定的字符串命令。
      Process Runtime.exec​(String command, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的字符串命令。
      protected URL ClassLoader.findResource​(String moduleName, String name)
      返回一个URL定义到此类加载器的模块中的资源。
      protected Enumeration<URL> ClassLoader.findResources​(String name)
      返回枚举URL对象，表示具有给定名称的所有资源。
      InputStream Module.getResourceAsStream​(String name)
      返回用于读取此模块中资源的输入流。
      Enumeration<URL> ClassLoader.getResources​(String name)
      查找具有给定名称的所有资源。
      static Enumeration<URL> ClassLoader.getSystemResources​(String name)
      从用于加载类的搜索路径中查找指定名称的所有资源。
      static Channel System.inheritedChannel​()
      返回从创建此Java虚拟机的实体继承的通道。
      int Readable.read​(CharBuffer cb)
      尝试将字符读入指定的字符缓冲区。
      Process ProcessBuilder.start​()
      使用此流程构建器的属性启动新进程。
      static List<Process> ProcessBuilder.startPipeline​(List<ProcessBuilder> builders)
      为每个ProcessBuilder启动流程，创建一个由其标准输出流和标准输入流链接的流程。

    • Uses of IOException in java.lang.management

      Methods in java.lang.management that throw IOException
      Modifier and Type 方法 描述
      static <T extends PlatformManagedObject>
      T             		ManagementFactory.getPlatformMXBean​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回 mxbeanInterface的平台MXBean代理，该代理被指定为在Java虚拟机中具有一个实例，代理将通过给定的 MBeanServerConnection转发方法调用。
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回平台MXBean代理的列表，用于通过给定的 MBeanServerConnection转发 mxbeanInterface的方法调用。
      static <T> T ManagementFactory.newPlatformMXBeanProxy​(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
      返回给定的平台MXBean接口的代理 MXBean name转发其方法调用通过给定 MBeanServerConnection 。

    • Uses of IOException in java.lang.module

      Methods in java.lang.module that throw IOException
      Modifier and Type 方法 描述
      void ModuleReader.close​()
      关闭模块阅读器。
      Optional<URI> ModuleReader.find​(String name)
      查找资源，将URI返回给模块中的资源。
      Stream<String> ModuleReader.list​()
      列出模块的内容，返回作为模块中所有资源名称的元素流。
      default Optional<InputStream> ModuleReader.open​(String name)
      打开资源，返回输入流以读取模块中的资源。
      abstract ModuleReader ModuleReference.open​()
      打开模块内容进行阅读。
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in, Supplier<Set<String>> packageFinder)
      从输入流读取模块声明的二进制形式作为模块描述符。
      default Optional<ByteBuffer> ModuleReader.read​(String name)
      读取资源，返回一个具有资源内容的字节缓冲区。

    • Uses of IOException in java.net

      Subclasses of IOException in java.net
      Modifier and Type Class 描述
      class  BindException
      指示尝试将套接字绑定到本地地址和端口时发生错误。
      class  ConnectException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  HttpRetryException
      抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。
      class  MalformedURLException
      抛出以表示发生格式不正确的网址。
      class  NoRouteToHostException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  PortUnreachableException
      指示在连接的数据报上收到了ICMP端口不可达消息。
      class  ProtocolException
      抛出以表示底层协议有错误，如TCP错误。
      class  SocketException
      抛出以表示创建或访问Socket时出错。
      class  SocketTimeoutException
      指示在套接字上发生超时时读取或接受。
      class  UnknownHostException
      抛出以表示无法确定主机的IP地址。
      class  UnknownServiceException
      抛出以表示发生未知服务异常。
      Methods in java.net with parameters of type IOException
      Modifier and Type 方法 描述
      abstract void ProxySelector.connectFailed​(URI uri, SocketAddress sa, IOException ioe)
      被称为表示连接不能建立到代理/袜子服务器。
      Methods in java.net that throw IOException
      Modifier and Type | 方法 | 描述
      Socket ServerSocket.accept​()
      侦听要连接到此套接字并接受它。
      protected abstract void SocketImpl.accept​(SocketImpl s)
      接受连接。
      protected abstract int SocketImpl.available​()
      返回可从该套接字读取而不阻塞的字节数。
      void ServerSocket.bind​(SocketAddress endpoint)
      将 ServerSocket绑定到特定地址（IP地址和端口号）。
      void ServerSocket.bind​(SocketAddress endpoint, int backlog)
      将 ServerSocket绑定到特定地址（IP地址和端口号）。
      void Socket.bind​(SocketAddress bindpoint)
      将套接字绑定到本地地址。
      protected abstract void SocketImpl.bind​(InetAddress host, int port)
      将此套接字绑定到指定的本地IP地址和端口号。
      void ServerSocket.close​()
      关闭此套接字。
      void Socket.close​()
      关闭此套接字。
      protected abstract void SocketImpl.close​()
      关闭此套接字。
      void URLClassLoader.close​()
      关闭此URLClassLoader，以使其不能再用于加载由此加载程序定义的新类或资源。
      void Socket.connect​(SocketAddress endpoint)
      将此套接字连接到服务器。
      void Socket.connect​(SocketAddress endpoint, int timeout)
      将此套接字连接到具有指定超时值的服务器。
      protected abstract void SocketImpl.connect​(String host, int port)
      将此套接字连接到指定主机上的指定端口。
      protected abstract void SocketImpl.connect​(InetAddress address, int port)
      将此套接字连接到指定主机上的指定端口号。
      protected abstract void SocketImpl.connect​(SocketAddress address, int timeout)
      将此套接字连接到指定主机上的指定端口号。
      abstract void URLConnection.connect​()
      打开与此URL引用的资源的通信链接，如果此类连接尚未建立。
      protected abstract void SocketImpl.create​(boolean stream)
      创建流或数据报套接字。
      Enumeration<URL> URLClassLoader.findResources​(String name)
      返回表示URL搜索路径上具有指定名称的所有资源的URL的枚举。
      abstract Map<String,List<String>> CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      Map<String,List<String>> | CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)
      abstract CacheResponse ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
      根据请求的uri，请求方法和请求标头检索缓存的响应。
      Attributes JarURLConnection.getAttributes​()
      如果该连接的URL指向JAR文件条目，则返回此连接的Attributes对象，否则返回null。
      abstract OutputStream CacheRequest.getBody​()
      返回一个可以写入响应体的OutputStream。
      abstract InputStream CacheResponse.getBody​()
      将响应体作为InputStream返回。
      Certificate[] JarURLConnection.getCertificates​()
      如果它的URL指向JAR文件条目，则返回此连接的证书对象，否则返回null。
      abstract Object ContentHandler.getContent​(URLConnection urlc)
      给定位于对象表示开头的URL连接流，该方法读取该流并从中创建一个对象。
      Object ContentHandler.getContent​(URLConnection urlc, Class[] classes)
      给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。
      Object URL.getContent​()
      获取此URL的内容。
      Object URL.getContent​(Class<?>[] classes)
      获取此URL的内容。
      Object URLConnection.getContent​()
      检索此URL连接的内容。
      Object URLConnection.getContent​(Class<?>[] classes)
      检索此URL连接的内容。
      abstract Map<String,List<String>> CacheResponse.getHeaders​()
      将响应标头作为Map返回。
      InputStream Socket.getInputStream​()
      返回此套接字的输入流。
      protected abstract InputStream SocketImpl.getInputStream​()
      返回此套接字的输入流。
      InputStream URLConnection.getInputStream​()
      返回从此打开的连接读取的输入流。
      JarEntry JarURLConnection.getJarEntry​()
      返回此连接的JAR条目对象（如果有）。
      abstract JarFile JarURLConnection.getJarFile​()
      返回此连接的JAR文件。
      Attributes JarURLConnection.getMainAttributes​()
      返回此连接的JAR文件的主要属性。
      Manifest JarURLConnection.getManifest​()
      返回此连接的清单，否则返回null。
      <T> T DatagramSocket.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      protected <T> T DatagramSocketImpl.getOption​(SocketOption<T> name)
      被称为获取套接字选项。
      <T> T ServerSocket.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      <T> T Socket.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      protected <T> T SocketImpl.getOption​(SocketOption<T> name)
      被称为获取套接字选项。
      OutputStream Socket.getOutputStream​()
      返回此套接字的输出流。
      protected abstract OutputStream SocketImpl.getOutputStream​()
      返回此套接字的输出流。
      OutputStream URLConnection.getOutputStream​()
      返回写入此连接的输出流。
      Permission HttpURLConnection.getPermission​()
      返回一个SocketPermission对象，表示连接到目标主机和端口所需的权限。
      Permission URLConnection.getPermission​()
      返回一个权限对象，该对象表示创建此对象所表示的连接所需的权限。
      int HttpURLConnection.getResponseCode​()
      从HTTP响应消息获取状态代码。
      String HttpURLConnection.getResponseMessage​()
      获取与服务器的响应代码一起返回的HTTP响应消息（如果有）。
      int ServerSocket.getSoTimeout​()
      检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。
      protected abstract int DatagramSocketImpl.getTimeToLive​()
      检索TTL（生存时间）选项。
      int MulticastSocket.getTimeToLive​()
      获取在套接字上发送的组播数据包的默认生存时间。
      protected abstract byte DatagramSocketImpl.getTTL​()
      已过时。
      使用getTimeToLive代替。
      byte MulticastSocket.getTTL​()
      已过时。
      使用getTimeToLive方法，它返回一个int而不是一个字节 。
      static String URLConnection.guessContentTypeFromStream​(InputStream is)
      根据输入流开头的字符，尝试确定输入流的类型。
      protected void ServerSocket.implAccept​(Socket s)
      ServerSocket的子类使用这个方法来覆盖accept（）来返回自己的套接字子类。
      boolean InetAddress.isReachable​(int timeout)
      测试该地址是否可达。
      boolean InetAddress.isReachable​(NetworkInterface netif, int ttl, int timeout)
      测试该地址是否可达。
      protected abstract void DatagramSocketImpl.join​(InetAddress inetaddr)
      加入组播组。
      protected abstract void DatagramSocketImpl.joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      加入组播组。
      void MulticastSocket.joinGroup​(InetAddress mcastaddr)
      加入组播组。
      void MulticastSocket.joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的接口加入指定的组播组。
      protected abstract void DatagramSocketImpl.leave​(InetAddress inetaddr)
      离开组播组。
      protected abstract void DatagramSocketImpl.leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      离开组播组。
      void MulticastSocket.leaveGroup​(InetAddress mcastaddr)
      离开多播组。
      void MulticastSocket.leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的本地接口上留下组播组。
      protected abstract void SocketImpl.listen​(int backlog)
      将传入连接指示（请求连接）的最大队列长度设置为 count参数。
      URLConnection URL.openConnection​()
      返回一个URLConnection实例表示由所引用的远程对象的连接URL 。
      URLConnection URL.openConnection​(Proxy proxy)
      与URL.openConnection()相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      protected abstract URLConnection URLStreamHandler.openConnection​(URL u)
      打开与 URL参数引用的对象的连接。
      protected URLConnection URLStreamHandler.openConnection​(URL u, Proxy p)
      与openConnection（URL）相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      InputStream URL.openStream​()
      打开与此 URL的连接，并返回一个 InputStream用于从该连接读取。
      protected abstract int DatagramSocketImpl.peek​(InetAddress i)
      仔细看看它是从哪里来的。
      protected abstract int DatagramSocketImpl.peekData​(DatagramPacket p)
      仔细看看它是从哪里来的。
      abstract void CookieHandler.put​(URI uri, Map<String,List<String>> responseHeaders)
      设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
      void | CookieManager.put​(URI uri, Map<String,List<String>> responseHeaders)
      abstract CacheRequest ResponseCache.put​(URI uri, URLConnection conn)
      协议处理程序在检索到资源后调用此方法，ResponseCache必须决定是否将资源存储在其缓存中。
      void DatagramSocket.receive​(DatagramPacket p)
      从此套接字接收数据报包。
      protected abstract void DatagramSocketImpl.receive​(DatagramPacket p)
      接收数据报包。
      void DatagramSocket.send​(DatagramPacket p)
      从此套接字发送数据报包。
      protected abstract void DatagramSocketImpl.send​(DatagramPacket p)
      发送数据报包。
      void MulticastSocket.send​(DatagramPacket p, byte ttl)
      已过时。
      使用以下代码或其等价物：...... int ttl = mcastSocket.getTimeToLive（）;
mcastSocket.setTimeToLive（newttl）;
mcastSocket.send（P）;
mcastSocket.setTimeToLive（TTL）;
......
      void Socket.sendUrgentData​(int data)
      在套接字上发送一个字节的紧急数据。
      protected abstract void SocketImpl.sendUrgentData​(int data)
      在套接字上发送一个字节的紧急数据。
      static void DatagramSocket.setDatagramSocketImplFactory​(DatagramSocketImplFactory fac)
      设置应用程序的数据报套接字实现工厂。
      <T> DatagramSocket DatagramSocket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      protected <T> void DatagramSocketImpl.setOption​(SocketOption<T> name, T value)
      调用设置套接字选项。
      <T> ServerSocket ServerSocket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      <T> Socket Socket.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      protected <T> void SocketImpl.setOption​(SocketOption<T> name, T value)
      调用设置套接字选项。
      static void ServerSocket.setSocketFactory​(SocketImplFactory fac)
      设置应用程序的服务器套接字实现工厂。
      static void Socket.setSocketImplFactory​(SocketImplFactory fac)
      设置应用程序的客户端套接字实现工厂。
      protected abstract void DatagramSocketImpl.setTimeToLive​(int ttl)
      设置TTL（生存时间）选项。
      void MulticastSocket.setTimeToLive​(int ttl)
      为此 MulticastSocket发送的组播数据包的默认生存时间为了控制组播的范围。
      protected abstract void DatagramSocketImpl.setTTL​(byte ttl)
      已过时。
      使用setTimeToLive代替。
      void MulticastSocket.setTTL​(byte ttl)
      已过时。
      使用setTimeToLive方法，它使用int而不是byte作为ttl的类型。
      void Socket.shutdownInput​()
      将此套接字的输入流放置在“流的末尾”。
      protected void SocketImpl.shutdownInput​()
      将此套接字的输入流放置在“流的末尾”。
      void Socket.shutdownOutput​()
      禁用此套接字的输出流。
      protected void SocketImpl.shutdownOutput​()
      禁用此套接字的输出流。
      Constructors in java.net that throw IOException
      Constructor 描述
      MulticastSocket​()
      创建组播套接字。
      MulticastSocket​(int port)
      创建组播套接字并将其绑定到特定端口。
      MulticastSocket​(SocketAddress bindaddr)
      创建一个绑定到指定套接字地址的MulticastSocket。
      ServerSocket​()
      创建未绑定的服务器套接字。
      ServerSocket​(int port)
      创建绑定到指定端口的服务器套接字。
      ServerSocket​(int port, int backlog)
      创建服务器套接字并将其绑定到指定的本地端口号，并指定了积压。
      ServerSocket​(int port, int backlog, InetAddress bindAddr)
      创建一个具有指定端口的服务器，侦听backlog和本地IP地址绑定。
      Socket​(String host, int port)
      创建流套接字并将其连接到指定主机上的指定端口号。
      Socket​(String host, int port, boolean stream)
      已过时。
      使用DatagramSocket代替UDP传输。
      Socket​(String host, int port, InetAddress localAddr, int localPort)
      创建套接字并将其连接到指定远程端口上的指定远程主机。
      Socket​(InetAddress address, int port)
      创建流套接字并将其连接到指定IP地址的指定端口号。
      Socket​(InetAddress host, int port, boolean stream)
      已过时。
      使用DatagramSocket代替UDP传输。
      Socket​(InetAddress address, int port, InetAddress localAddr, int localPort)
      创建套接字并将其连接到指定的远程端口上指定的远程地址。

    • Uses of IOException in java.nio

      Methods in java.nio that throw IOException
      Modifier and Type 方法 描述
      int CharBuffer.read​(CharBuffer target)
      尝试将字符读入指定的字符缓冲区。

    • Uses of IOException in java.nio.channels

      Subclasses of IOException in java.nio.channels
      Modifier and Type Class 描述
      class  AsynchronousCloseException
      当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
      class  ClosedByInterruptException
      另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。
      class  ClosedChannelException
      当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。
      class  FileLockInterruptionException
      另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。
      class  InterruptedByTimeoutException
      在异步操作完成之前经过一段时间后线程接收到的异常检查。
      Methods in java.nio.channels that throw IOException
      Modifier and Type | 方法 | 描述
      abstract SocketChannel ServerSocketChannel.accept​()
      接受与此频道套接字的连接。
      AsynchronousServerSocketChannel AsynchronousServerSocketChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract AsynchronousServerSocketChannel AsynchronousServerSocketChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract AsynchronousSocketChannel | AsynchronousSocketChannel.bind​(SocketAddress local)
      abstract DatagramChannel | DatagramChannel.bind​(SocketAddress local)
      NetworkChannel NetworkChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址。
      ServerSocketChannel ServerSocketChannel.bind​(SocketAddress local)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract ServerSocketChannel ServerSocketChannel.bind​(SocketAddress local, int backlog)
      将通道的套接字绑定到本地地址，并配置套接字以监听连接。
      abstract SocketChannel | SocketChannel.bind​(SocketAddress local)
      abstract MembershipKey MembershipKey.block​(InetAddress source)
      阻止来自给定源地址的组播数据报。
      void AsynchronousChannel.close​()
      关闭此频道。
      void Channel.close​()
      关闭此频道。
      void FileLock.close​()
      此方法调用 FileLock.release()方法。
      void InterruptibleChannel.close​()
      关闭此频道。
      void MulticastChannel.close​()
      关闭此频道。
      abstract void Selector.close​()
      关闭此选择器。
      abstract SelectableChannel SelectableChannel.configureBlocking​(boolean block)
      调整此频道的屏蔽模式。
      abstract DatagramChannel DatagramChannel.connect​(SocketAddress remote)
      连接此通道的插座。
      abstract boolean SocketChannel.connect​(SocketAddress remote)
      连接此通道的插座。
      abstract DatagramChannel DatagramChannel.disconnect​()
      断开此通道的插座。
      abstract boolean SocketChannel.finishConnect​()
      完成连接插座通道的过程。
      abstract void AsynchronousFileChannel.force​(boolean metaData)
      强制将此通道文件的任何更新写入包含该通道的存储设备。
      abstract void FileChannel.force​(boolean metaData)
      强制将此通道文件的任何更新写入包含该通道的存储设备。
      abstract SocketAddress AsynchronousServerSocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress AsynchronousSocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress DatagramChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      SocketAddress NetworkChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress ServerSocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      abstract SocketAddress SocketChannel.getLocalAddress​()
      返回此通道的套接字所绑定的套接字地址。
      <T> T NetworkChannel.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      abstract SocketAddress AsynchronousSocketChannel.getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      abstract SocketAddress DatagramChannel.getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      abstract SocketAddress SocketChannel.getRemoteAddress​()
      返回此通道的插座所连接的远程地址。
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf)
      加入组播组，开始接收发送到组的所有数据报，返回成员密钥。
      MembershipKey MulticastChannel.join​(InetAddress group, NetworkInterface interf, InetAddress source)
      加入组播组，开始从给定的源地址接收发送到组的数据报。
      FileLock FileChannel.lock​()
      获取此通道文件的排他锁。
      abstract FileLock FileChannel.lock​(long position, long size, boolean shared)
      获取此通道文件的给定区域的锁定。
      abstract MappedByteBuffer FileChannel.map​(FileChannel.MapMode mode, long position, long size)
      将此频道文件的区域直接映射到内存中。
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, OpenOption... options)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static AsynchronousFileChannel AsynchronousFileChannel.open​(Path file, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      static AsynchronousServerSocketChannel AsynchronousServerSocketChannel.open​()
      打开异步服务器套接字通道。
      static AsynchronousServerSocketChannel AsynchronousServerSocketChannel.open​(AsynchronousChannelGroup group)
      打开异步服务器套接字通道。
      static AsynchronousSocketChannel AsynchronousSocketChannel.open​()
      打开异步套接字通道。
      static AsynchronousSocketChannel AsynchronousSocketChannel.open​(AsynchronousChannelGroup group)
      打开异步套接字通道。
      static DatagramChannel DatagramChannel.open​()
      打开数据报通道。
      static DatagramChannel DatagramChannel.open​(ProtocolFamily family)
      打开数据报通道。
      static FileChannel FileChannel.open​(Path path, OpenOption... options)
      打开或创建文件，返回文件通道以访问该文件。
      static FileChannel FileChannel.open​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回文件通道以访问该文件。
      static Pipe Pipe.open​()
      打开管道。
      static Selector Selector.open​()
      打开选择器。
      static ServerSocketChannel ServerSocketChannel.open​()
      打开服务器插槽通道。
      static SocketChannel SocketChannel.open​()
      打开套接字通道。
      static SocketChannel SocketChannel.open​(SocketAddress remote)
      打开套接字通道并将其连接到远程地址。
      abstract long FileChannel.position​()
      返回此频道的文件位置。
      abstract FileChannel FileChannel.position​(long newPosition)
      设置此通道的文件位置。
      long SeekableByteChannel.position​()
      返回此频道的位置。
      SeekableByteChannel SeekableByteChannel.position​(long newPosition)
      设置此频道的位置。
      abstract int DatagramChannel.read​(ByteBuffer dst)
      从此频道读取数据报。
      long DatagramChannel.read​(ByteBuffer[] dsts)
      从此频道读取数据报。
      abstract long DatagramChannel.read​(ByteBuffer[] dsts, int offset, int length)
      从此频道读取数据报。
      abstract int FileChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      long FileChannel.read​(ByteBuffer[] dsts)
      从该通道读取到给定缓冲区的字节序列。
      abstract long FileChannel.read​(ByteBuffer[] dsts, int offset, int length)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract int FileChannel.read​(ByteBuffer dst, long position)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      int ReadableByteChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      long ScatteringByteChannel.read​(ByteBuffer[] dsts)
      从该通道读取到给定缓冲区的字节序列。
      long ScatteringByteChannel.read​(ByteBuffer[] dsts, int offset, int length)
      从该通道读取字节序列到给定缓冲区的子序列中。
      int SeekableByteChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      abstract int | SocketChannel.read​(ByteBuffer dst)
      long | SocketChannel.read​(ByteBuffer[] dsts)
      abstract long | SocketChannel.read​(ByteBuffer[] dsts, int offset, int length)
      abstract SocketAddress DatagramChannel.receive​(ByteBuffer dst)
      通过该频道接收数据报。
      abstract void FileLock.release​()
      释放这个锁
      abstract int Selector.select​()
      选择一组其相应通道准备好进行I / O操作的键。
      abstract int Selector.select​(long timeout)
      选择一组其相应通道准备好进行I / O操作的键。
      abstract int Selector.selectNow​()
      选择一组其相应通道准备好进行I / O操作的键。
      abstract int DatagramChannel.send​(ByteBuffer src, SocketAddress target)
      通过此频道发送数据报。
      abstract <T> AsynchronousServerSocketChannel | AsynchronousServerSocketChannel.setOption​(SocketOption<T> name, T value)
      abstract <T> AsynchronousSocketChannel | AsynchronousSocketChannel.setOption​(SocketOption<T> name, T value)
      abstract <T> DatagramChannel | DatagramChannel.setOption​(SocketOption<T> name, T value)
      <T> NetworkChannel NetworkChannel.setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      abstract <T> ServerSocketChannel | ServerSocketChannel.setOption​(SocketOption<T> name, T value)
      abstract <T> SocketChannel | SocketChannel.setOption​(SocketOption<T> name, T value)
      abstract AsynchronousSocketChannel AsynchronousSocketChannel.shutdownInput​()
      关闭连接进行阅读，不关闭频道。
      abstract SocketChannel SocketChannel.shutdownInput​()
      关闭连接进行阅读，不关闭频道。
      abstract void AsynchronousChannelGroup.shutdownNow​()
      关闭组并关闭组中的所有打开的通道。
      abstract AsynchronousSocketChannel AsynchronousSocketChannel.shutdownOutput​()
      关闭连接以进行写入，而不关闭通道。
      abstract SocketChannel SocketChannel.shutdownOutput​()
      关闭连接以进行写入，而不关闭通道。
      abstract long AsynchronousFileChannel.size​()
      返回此通道文件的当前大小。
      abstract long FileChannel.size​()
      返回此通道文件的当前大小。
      long SeekableByteChannel.size​()
      返回此通道连接到的实体的当前大小。
      abstract long FileChannel.transferFrom​(ReadableByteChannel src, long position, long count)
      从给定的可读字节通道将字节传输到该通道的文件中。
      abstract long FileChannel.transferTo​(long position, long count, WritableByteChannel target)
      将该通道文件的字节传输到给定的可写字节通道。
      abstract AsynchronousFileChannel AsynchronousFileChannel.truncate​(long size)
      将此频道的文件截断为给定大小。
      abstract FileChannel FileChannel.truncate​(long size)
      将此频道的文件截断为给定大小。
      SeekableByteChannel SeekableByteChannel.truncate​(long size)
      将连接此通道的实体截断为给定的大小。
      FileLock AsynchronousFileChannel.tryLock​()
      尝试获取此频道文件的排他锁。
      abstract FileLock AsynchronousFileChannel.tryLock​(long position, long size, boolean shared)
      尝试获取此通道文件的给定区域的锁定。
      FileLock FileChannel.tryLock​()
      尝试获取此频道文件的排他锁。
      abstract FileLock FileChannel.tryLock​(long position, long size, boolean shared)
      尝试获取此通道文件的给定区域的锁定。
      static AsynchronousChannelGroup AsynchronousChannelGroup.withCachedThreadPool​(ExecutorService executor, int initialSize)
      创建具有给定线程池的异步通道组，根据需要创建新线程。
      static AsynchronousChannelGroup AsynchronousChannelGroup.withFixedThreadPool​(int nThreads, ThreadFactory threadFactory)
      创建具有固定线程池的异步通道组。
      static AsynchronousChannelGroup AsynchronousChannelGroup.withThreadPool​(ExecutorService executor)
      使用给定的线程池创建异步通道组。
      abstract int DatagramChannel.write​(ByteBuffer src)
      将数据报写入此通道。
      long DatagramChannel.write​(ByteBuffer[] srcs)
      将数据报写入此通道。
      abstract long DatagramChannel.write​(ByteBuffer[] srcs, int offset, int length)
      将数据报写入此通道。
      abstract int FileChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      long FileChannel.write​(ByteBuffer[] srcs)
      从给定的缓冲区向该通道写入一系列字节。
      abstract long FileChannel.write​(ByteBuffer[] srcs, int offset, int length)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      abstract int FileChannel.write​(ByteBuffer src, long position)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      long GatheringByteChannel.write​(ByteBuffer[] srcs)
      从给定的缓冲区向该通道写入一系列字节。
      long GatheringByteChannel.write​(ByteBuffer[] srcs, int offset, int length)
      从给定缓冲区的子序列将一个字节序列写入该通道。
      int SeekableByteChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract int | SocketChannel.write​(ByteBuffer src)
      long | SocketChannel.write​(ByteBuffer[] srcs)
      abstract long | SocketChannel.write​(ByteBuffer[] srcs, int offset, int length)
      int WritableByteChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。

    • Uses of IOException in java.nio.channels.spi

      Methods in java.nio.channels.spi that throw IOException
      Modifier and Type 方法 描述
      void AbstractInterruptibleChannel.close​()
      关闭此频道。
      void AbstractSelector.close​()
      关闭此选择器。
      SelectableChannel AbstractSelectableChannel.configureBlocking​(boolean block)
      调整此频道的屏蔽模式。
      protected abstract void AbstractInterruptibleChannel.implCloseChannel​()
      关闭此频道。
      protected void AbstractSelectableChannel.implCloseChannel​()
      关闭此频道。
      protected abstract void AbstractSelectableChannel.implCloseSelectableChannel​()
      关闭此可选择的频道。
      protected abstract void AbstractSelector.implCloseSelector​()
      关闭此选择器。
      protected abstract void AbstractSelectableChannel.implConfigureBlocking​(boolean block)
      调整此频道的屏蔽模式。
      Channel SelectorProvider.inheritedChannel​()
      返回从创建此Java虚拟机的实体继承的通道。
      abstract AsynchronousChannelGroup AsynchronousChannelProvider.openAsynchronousChannelGroup​(int nThreads, ThreadFactory threadFactory)
      构造一个具有固定线程池的新的异步通道组。
      abstract AsynchronousChannelGroup AsynchronousChannelProvider.openAsynchronousChannelGroup​(ExecutorService executor, int initialSize)
      使用给定的线程池构造新的异步通道组。
      abstract AsynchronousServerSocketChannel AsynchronousChannelProvider.openAsynchronousServerSocketChannel​(AsynchronousChannelGroup group)
      打开异步服务器套接字通道。
      abstract AsynchronousSocketChannel AsynchronousChannelProvider.openAsynchronousSocketChannel​(AsynchronousChannelGroup group)
      打开异步套接字通道。
      abstract DatagramChannel SelectorProvider.openDatagramChannel​()
      打开数据报通道。
      abstract DatagramChannel SelectorProvider.openDatagramChannel​(ProtocolFamily family)
      打开数据报通道。
      abstract Pipe SelectorProvider.openPipe​()
      打开管道。
      abstract AbstractSelector SelectorProvider.openSelector​()
      打开选择器。
      abstract ServerSocketChannel SelectorProvider.openServerSocketChannel​()
      打开服务器插槽通道。
      abstract SocketChannel SelectorProvider.openSocketChannel​()
      打开套接字通道。

    • Uses of IOException in java.nio.charset

      Subclasses of IOException in java.nio.charset
      Modifier and Type Class 描述
      class  CharacterCodingException
      发生字符编码或解码错误时抛出的检查异常。
      class  MalformedInputException
      当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
      class  UnmappableCharacterException
      输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。

    • Uses of IOException in java.nio.file

      Subclasses of IOException in java.nio.file
      Modifier and Type Class 描述
      class  AccessDeniedException
      文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。
      class  AtomicMoveNotSupportedException
      当文件不能作为原子文件系统操作移动时，检查的异常抛出。
      class  DirectoryNotEmptyException
      由于目录不为空，文件系统操作失败时抛出的检查异常。
      class  FileAlreadyExistsException
      尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
      class  FileSystemException
      在一个或两个文件上的文件系统操作失败时抛出。
      class  FileSystemLoopException
      当遇到文件系统循环或循环时抛出的检查异常。
      class  NoSuchFileException
      当尝试访问不存在的文件时抛出检查的异常。
      class  NotDirectoryException
      当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
      class  NotLinkException
      由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
      Methods in java.nio.file that return IOException
      Modifier and Type 方法 描述
      IOException DirectoryIteratorException.getCause​()
      返回此异常的原因。
      Methods in java.nio.file with parameters of type IOException
      Modifier and Type 方法 描述
      FileVisitResult FileVisitor.postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult SimpleFileVisitor.postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult FileVisitor.visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。
      FileVisitResult SimpleFileVisitor.visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。
      Methods in java.nio.file that throw IOException
      Modifier and Type 方法 描述
      boolean DirectoryStream.Filter.accept​(T entry)
      决定是否接受或过滤给定的目录条目。
      abstract void FileSystem.close​()
      关闭此文件系统。
      void WatchService.close​()
      关闭这个手表服务。
      static long Files.copy​(InputStream in, Path target, CopyOption... options)
      将输入流中的所有字节复制到文件。
      static long Files.copy​(Path source, OutputStream out)
      将文件中的所有字节复制到输出流。
      static Path Files.copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      static Path Files.createDirectories​(Path dir, FileAttribute<?>... attrs)
      首先创建所有不存在的父目录来创建目录。
      static Path Files.createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      static Path Files.createFile​(Path path, FileAttribute<?>... attrs)
      创建一个新的和空的文件，如果该文件已存在失败。
      static Path Files.createLink​(Path link, Path existing)
      为现有文件创建新的链接（目录条目） （可选操作） 。
      static Path Files.createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建到目标的符号链接 （可选操作） 。
      static Path Files.createTempDirectory​(String prefix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path Files.createTempDirectory​(Path dir, String prefix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新目录，使用给定的前缀生成其名称。
      static Path Files.createTempFile​(String prefix, String suffix, FileAttribute<?>... attrs)
      在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。
      static Path Files.createTempFile​(Path dir, String prefix, String suffix, FileAttribute<?>... attrs)
      在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
      static void Files.delete​(Path path)
      删除文件。
      void SecureDirectoryStream.deleteDirectory​(T path)
      删除目录。
      void SecureDirectoryStream.deleteFile​(T path)
      删除文件。
      static boolean Files.deleteIfExists​(Path path)
      删除文件（如果存在）。
      static Stream<Path> Files.find​(Path start, int maxDepth, BiPredicate<Path,BasicFileAttributes> matcher, FileVisitOption... options)
      返回一个 Stream ，它通过搜索基于给定起始文件的文件树中的文件来懒惰地填充 Path 。
      static Object Files.getAttribute​(Path path, String attribute, LinkOption... options)
      读取文件属性的值。
      abstract Object FileStore.getAttribute​(String attribute)
      读取文件存储属性的值。
      static FileStore Files.getFileStore​(Path path)
      返回表示文件所在文件存储区的FileStore 。
      static FileTime Files.getLastModifiedTime​(Path path, LinkOption... options)
      返回文件的上次修改时间。
      static UserPrincipal Files.getOwner​(Path path, LinkOption... options)
      返回文件的所有者。
      static Set<PosixFilePermission> Files.getPosixFilePermissions​(Path path, LinkOption... options)
      返回文件的POSIX文件权限。
      abstract long FileStore.getTotalSpace​()
      返回文件存储的大小（以字节为单位）。
      abstract long FileStore.getUnallocatedSpace​()
      返回文件存储区中未分配字节的数量。
      abstract long FileStore.getUsableSpace​()
      返回文件存储上此Java虚拟机可用的字节数。
      static boolean Files.isHidden​(Path path)
      告知文件是否被 隐藏 。
      static boolean Files.isSameFile​(Path path, Path path2)
      测试两个路径是否找到相同的文件。
      static Stream<String> Files.lines​(Path path)
      从 Stream读取文件中的所有行。
      static Stream<String> Files.lines​(Path path, Charset cs)
      从文件中读取所有行作为 Stream 。
      static Stream<Path> Files.list​(Path dir)
      返回一个懒惰的填充 Stream ，其元素是目录中的条目。
      static Path Files.move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
      void SecureDirectoryStream.move​(T srcpath, SecureDirectoryStream<T> targetdir, T targetpath)
      将文件从该目录移动到另一个目录。
      static BufferedReader Files.newBufferedReader​(Path path)
      打开一个文件进行阅读，返回一个 BufferedReader以高效的方式从文件读取文本。
      static BufferedReader Files.newBufferedReader​(Path path, Charset cs)
      打开一个文件进行阅读，返回一个 BufferedReader ，可以用来以有效的方式从文件读取文本。
      static BufferedWriter Files.newBufferedWriter​(Path path, Charset cs, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter ，可以用来以有效的方式将文本写入文件。
      static BufferedWriter Files.newBufferedWriter​(Path path, OpenOption... options)
      打开或创建一个写入文件，返回一个 BufferedWriter以高效的方式写入文件。
      static SeekableByteChannel Files.newByteChannel​(Path path, OpenOption... options)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      static SeekableByteChannel Files.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      SeekableByteChannel SecureDirectoryStream.newByteChannel​(T path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      在此目录中打开或创建一个文件，返回可访问的字节通道以访问该文件。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir)
      打开一个目录，返回一个DirectoryStream以迭代目录中的所有条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, String glob)
      打开一个目录，返回一个DirectoryStream以遍历目录中的条目。
      static DirectoryStream<Path> Files.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个DirectoryStream来迭代目录中的条目。
      SecureDirectoryStream<T> SecureDirectoryStream.newDirectoryStream​(T path, LinkOption... options)
      打开由给定路径标识的目录，返回 SecureDirectoryStream以遍历目录中的条目。
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env)
      构造一个由URI标识的新文件系统
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env, ClassLoader loader)
      构造一个由URI标识的新文件系统
      static FileSystem FileSystems.newFileSystem​(Path path, ClassLoader loader)
      构造新的 FileSystem作为文件系统访问文件的内容。
      static InputStream Files.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      static OutputStream Files.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      abstract WatchService FileSystem.newWatchService​()
      构造新的WatchService （可选操作） 。
      FileVisitResult FileVisitor.postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult SimpleFileVisitor.postVisitDirectory​(T dir, IOException exc)
      在目录中的条目之后调用目录，并且已经访问了所有的后代。
      FileVisitResult FileVisitor.preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      FileVisitResult SimpleFileVisitor.preVisitDirectory​(T dir, BasicFileAttributes attrs)
      在目录中的条目被访问之前调用一个目录。
      static String Files.probeContentType​(Path path)
      探测文件的内容类型。
      static byte[] Files.readAllBytes​(Path path)
      读取文件中的所有字节。
      static List<String> Files.readAllLines​(Path path)
      从文件中读取所有行。
      static List<String> Files.readAllLines​(Path path, Charset cs)
      从文件中读取所有行。
      static <A extends BasicFileAttributes>
      A             		Files.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      static Map<String,Object> Files.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      static Path Files.readSymbolicLink​(Path link)
      读取符号链接的目标 （可选操作） 。
      default WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      使用手表服务注册此路径所在的文件。
      WatchKey Path.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      使用手表服务注册此路径所在的文件。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>... events)
      用手表服务注册一个对象。
      WatchKey Watchable.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)
      用手表服务注册一个对象。
      static Path Files.setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。
      static Path Files.setLastModifiedTime​(Path path, FileTime time)
      更新文件上次修改的时间属性。
      static Path Files.setOwner​(Path path, UserPrincipal owner)
      更新文件所有者。
      static Path Files.setPosixFilePermissions​(Path path, Set<PosixFilePermission> perms)
      设置文件的POSIX权限。
      static long Files.size​(Path path)
      返回文件的大小（以字节为单位）。
      Path Path.toRealPath​(LinkOption... options)
      返回现有文件的 真实路径。
      FileVisitResult FileVisitor.visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      FileVisitResult SimpleFileVisitor.visitFile​(T file, BasicFileAttributes attrs)
      为目录中的文件调用。
      FileVisitResult FileVisitor.visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。
      FileVisitResult SimpleFileVisitor.visitFileFailed​(T file, IOException exc)
      为无法访问的文件调用。
      static Stream<Path> Files.walk​(Path start, int maxDepth, FileVisitOption... options)
      返回一个 Stream ，它通过走在一个给定的起始文件的根文件树上， Path 。
      static Stream<Path> Files.walk​(Path start, FileVisitOption... options)
      返回一个 Stream ，它是通过走根据给定的起始文件的文件树懒惰地填充 Path 。
      static Path Files.walkFileTree​(Path start, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.walkFileTree​(Path start, Set<FileVisitOption> options, int maxDepth, FileVisitor<? super Path> visitor)
      走一个文件树。
      static Path Files.write​(Path path, byte[] bytes, OpenOption... options)
      将字节写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, OpenOption... options)
      将文本行写入文件。
      Constructors in java.nio.file with parameters of type IOException
      Constructor 描述
      DirectoryIteratorException​(IOException cause)
      构造这个类的一个实例。

    • Uses of IOException in java.nio.file.attribute

      Subclasses of IOException in java.nio.file.attribute
      Modifier and Type Class 描述
      class  UserPrincipalNotFoundException
      当查找UserPrincipal失败，因为主体不存在时抛出的检查异常。
      Methods in java.nio.file.attribute that throw IOException
      Modifier and Type | 方法 | 描述
      void UserDefinedFileAttributeView.delete​(String name)
      删除用户定义的属性。
      List<AclEntry> AclFileAttributeView.getAcl​()
      读取访问控制列表。
      UserPrincipal FileOwnerAttributeView.getOwner​()
      阅读文件所有者。
      List<String> UserDefinedFileAttributeView.list​()
      返回包含用户定义属性名称的列表。
      abstract GroupPrincipal UserPrincipalLookupService.lookupPrincipalByGroupName​(String group)
      按组名查找组主体。
      abstract UserPrincipal UserPrincipalLookupService.lookupPrincipalByName​(String name)
      按名称查找用户主体。
      int UserDefinedFileAttributeView.read​(String name, ByteBuffer dst)
      将用户定义属性的值读入缓冲区。
      BasicFileAttributes BasicFileAttributeView.readAttributes​()
      读取大量操作的基本文件属性。
      DosFileAttributes | DosFileAttributeView.readAttributes​()
      PosixFileAttributes | PosixFileAttributeView.readAttributes​()
      void AclFileAttributeView.setAcl​(List<AclEntry> acl)
      更新（替换）访问控制列表。
      void DosFileAttributeView.setArchive​(boolean value)
      更新归档属性的值。
      void PosixFileAttributeView.setGroup​(GroupPrincipal group)
      更新文件组所有者。
      void DosFileAttributeView.setHidden​(boolean value)
      更新隐藏属性的值。
      void FileOwnerAttributeView.setOwner​(UserPrincipal owner)
      更新文件所有者。
      void PosixFileAttributeView.setPermissions​(Set<PosixFilePermission> perms)
      更新文件权限。
      void DosFileAttributeView.setReadOnly​(boolean value)
      更新只读属性的值。
      void DosFileAttributeView.setSystem​(boolean value)
      更新系统属性的值。
      void BasicFileAttributeView.setTimes​(FileTime lastModifiedTime, FileTime lastAccessTime, FileTime createTime)
      更新文件的最后修改时间，上次访问时间和创建时间属性的任何或全部。
      int UserDefinedFileAttributeView.size​(String name)
      返回用户定义属性值的大小。
      int UserDefinedFileAttributeView.write​(String name, ByteBuffer src)
      从缓冲区写入用户定义属性的值。

    • Uses of IOException in java.nio.file.spi

      Methods in java.nio.file.spi that throw IOException
      Modifier and Type 方法 描述
      abstract void FileSystemProvider.checkAccess​(Path path, AccessMode... modes)
      检查文件的存在，以及可选的可访问性。
      abstract void FileSystemProvider.copy​(Path source, Path target, CopyOption... options)
      将文件复制到目标文件。
      abstract void FileSystemProvider.createDirectory​(Path dir, FileAttribute<?>... attrs)
      创建一个新的目录。
      void FileSystemProvider.createLink​(Path link, Path existing)
      为现有文件创建一个新的链接（目录条目）。
      void FileSystemProvider.createSymbolicLink​(Path link, Path target, FileAttribute<?>... attrs)
      创建一个到目标的符号链接。
      abstract void FileSystemProvider.delete​(Path path)
      删除文件。
      boolean FileSystemProvider.deleteIfExists​(Path path)
      删除文件（如果存在）。
      abstract FileStore FileSystemProvider.getFileStore​(Path path)
      返回表示文件所在文件存储区的FileStore 。
      abstract boolean FileSystemProvider.isHidden​(Path path)
      告知文件是否被 隐藏 。
      abstract boolean FileSystemProvider.isSameFile​(Path path, Path path2)
      测试两个路径是否找到相同的文件。
      abstract void FileSystemProvider.move​(Path source, Path target, CopyOption... options)
      将文件移动或重命名为目标文件。
      AsynchronousFileChannel FileSystemProvider.newAsynchronousFileChannel​(Path path, Set<? extends OpenOption> options, ExecutorService executor, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回异步文件通道以访问该文件。
      abstract SeekableByteChannel FileSystemProvider.newByteChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建文件，返回可访问的字节通道以访问该文件。
      abstract DirectoryStream<Path> FileSystemProvider.newDirectoryStream​(Path dir, DirectoryStream.Filter<? super Path> filter)
      打开一个目录，返回一个 DirectoryStream以遍历目录中的条目。
      FileChannel FileSystemProvider.newFileChannel​(Path path, Set<? extends OpenOption> options, FileAttribute<?>... attrs)
      打开或创建用于读取和/或写入的文件，返回文件通道以访问该文件。
      abstract FileSystem FileSystemProvider.newFileSystem​(URI uri, Map<String,?> env)
      构造由URI标识的新的 FileSystem对象。
      FileSystem FileSystemProvider.newFileSystem​(Path path, Map<String,?> env)
      构造一个新的 FileSystem作为文件系统访问文件的内容。
      InputStream FileSystemProvider.newInputStream​(Path path, OpenOption... options)
      打开一个文件，返回输入流以从文件中读取。
      OutputStream FileSystemProvider.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      abstract String FileTypeDetector.probeContentType​(Path path)
      探测给定的文件来猜测其内容类型。
      abstract <A extends BasicFileAttributes>
      A             		FileSystemProvider.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      abstract Map<String,Object> FileSystemProvider.readAttributes​(Path path, String attributes, LinkOption... options)
      读取一组文件属性作为批量操作。
      Path FileSystemProvider.readSymbolicLink​(Path link)
      读取符号链接的目标。
      abstract void FileSystemProvider.setAttribute​(Path path, String attribute, Object value, LinkOption... options)
      设置文件属性的值。

    • Uses of IOException in java.rmi

      Subclasses of IOException in java.rmi
      Modifier and Type Class 描述
      class  AccessException
      一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
      class  ConnectException
      如果连接拒绝远程主机进行远程方法调用，则抛出 ConnectException 。
      class  ConnectIOException
      如果在与远程主机进行远程方法调用的连接时发生 ConnectIOException则抛出 IOException 。
      class  MarshalException
      如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。
      class  NoSuchObjectException
      如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
      class  RemoteException
      A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
      class  ServerError
      作为远程方法调用的结果抛出 ServerError ，当在处理服务器上的调用时抛出 Error ，无论是在解组参数，执行远程方法本身还是编组返回值时。
      class  ServerException
      在处理服务器上的调用时抛出 RemoteException ，或者在解组参数或执行远程方法本身时，抛出 ServerException作为远程方法调用的结果。
      class  ServerRuntimeException
      已过时。
      没有替换
      class  StubNotFoundException
      如果远程对象导出时无法找到有效的存根类，则抛出 StubNotFoundException 。
      class  UnexpectedException
      如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口中的方法的 throws子句中声明的检查的异常类型中。
      class  UnknownHostException
      如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
      class  UnmarshalException
      如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出一个 UnmarshalException ：如果发生异常时 java.io.IOException调用头，如果返回值的协议如果 java.io.IOException发生解组参数（on服务器端）或返回值（在客户端）。
      Methods in java.rmi that throw IOException
      Modifier and Type 方法 描述
      T MarshalledObject.get​()
      返回包含的编组对象的新副本。
      Constructors in java.rmi that throw IOException
      Constructor 描述
      MarshalledObject​(T obj)
      创建一个新的 MarshalledObject ，其中包含所提供对象的当前状态的序列化表示。

    • Uses of IOException in java.rmi.activation

      Subclasses of IOException in java.rmi.activation
      Modifier and Type Class 描述
      class  ActivateFailedException
      在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。

    • Uses of IOException in java.rmi.server

      Subclasses of IOException in java.rmi.server
      Modifier and Type Class 描述
      class  ExportException
      如果尝试导出远程对象失败，则 ExportException是抛出 RemoteException 。
      class  SkeletonMismatchException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SkeletonNotFoundException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SocketSecurityException
      已过时。
      这个班已经过时了 改用ExportException 。
      Methods in java.rmi.server that throw IOException
      Modifier and Type 方法 描述
      ServerSocket RMIServerSocketFactory.createServerSocket​(int port)
      在指定端口上创建服务器套接字（端口0表示匿名端口）。
      abstract ServerSocket RMISocketFactory.createServerSocket​(int port)
      在指定端口上创建服务器套接字（端口0表示匿名端口）。
      Socket RMIClientSocketFactory.createSocket​(String host, int port)
      创建连接到指定主机和端口的客户端套接字。
      abstract Socket RMISocketFactory.createSocket​(String host, int port)
      创建连接到指定主机和端口的客户端套接字。
      void RemoteCall.done​()
      已过时。
      没有替换
      ObjectInput RemoteCall.getInputStream​()
      已过时。
      没有替换
      ObjectOutput RemoteCall.getOutputStream​()
      已过时。
      没有替换
      ObjectOutput RemoteCall.getResultStream​(boolean success)
      已过时。
      没有替换
      static ObjID ObjID.read​(ObjectInput in)
      构造并返回一个新的 ObjID实例，通过从 ObjectInput实例解组二进制表示。
      static UID UID.read​(DataInput in)
      构造并返回一个新的 UID实例，通过从 DataInput实例解组二进制表示。
      void RemoteCall.releaseInputStream​()
      已过时。
      没有替换
      void RemoteCall.releaseOutputStream​()
      已过时。
      没有替换
      static void RMISocketFactory.setSocketFactory​(RMISocketFactory fac)
      设置RMI获取套接字的全局套接字工厂（如果远程对象与特定客户端和/或服务器套接字工厂没有关联）。
      void ObjID.write​(ObjectOutput out)
      将这个 ObjID的二进制表示法 ObjID交给 ObjectOutput实例。
      void UID.write​(DataOutput out)
      将这个 UID的二进制表示法 UID交给 DataOutput实例。

    • Uses of IOException in java.security

      Methods in java.security that throw IOException
      Modifier and Type 方法 描述
      void Certificate.decode​(InputStream stream)
      已过时。
      从输入流解码证书。
      void Certificate.encode​(OutputStream stream)
      已过时。
      将证书以 decode方法解码的格式将证书编码为输出流。
      protected abstract byte[] AlgorithmParametersSpi.engineGetEncoded​()
      返回其主要编码格式的参数。
      protected abstract byte[] AlgorithmParametersSpi.engineGetEncoded​(String format)
      返回以指定格式编码的参数。
      protected abstract void AlgorithmParametersSpi.engineInit​(byte[] params)
      导入指定的参数，并根据参数的主要解码格式进行解码。
      protected abstract void AlgorithmParametersSpi.engineInit​(byte[] params, String format)
      从 params导入参数，并根据指定的解码格式进行解码。
      abstract void KeyStoreSpi.engineLoad​(InputStream stream, char[] password)
      从给定的输入流加载密钥库。
      void KeyStoreSpi.engineLoad​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParameter加载密钥库。
      boolean KeyStoreSpi.engineProbe​(InputStream stream)
      探测指定的输入流以确定它是否包含此实现支持的密钥库。
      abstract void KeyStoreSpi.engineStore​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStoreSpi.engineStore​(KeyStore.LoadStoreParameter param)
      使用给定的 KeyStore.LoadStoreParmeter存储此密钥库。
      byte[] AlgorithmParameters.getEncoded​()
      返回其主要编码格式的参数。
      byte[] AlgorithmParameters.getEncoded​(String format)
      返回在指定方案中编码的参数。
      static KeyStore KeyStore.getInstance​(File file, char[] password)
      返回相应密钥库类型的加载密钥库对象。
      static KeyStore KeyStore.getInstance​(File file, KeyStore.LoadStoreParameter param)
      返回相应密钥库类型的加载密钥库对象。
      Object SignedObject.getObject​()
      检索封装对象。
      void AlgorithmParameters.init​(byte[] params)
      导入指定的参数，并根据参数的主要解码格式进行解码。
      void AlgorithmParameters.init​(byte[] params, String format)
      从 params导入参数，并根据指定的解码方案进行解码。
      void KeyStore.load​(InputStream stream, char[] password)
      从给定的输入流加载此KeyStore。
      void KeyStore.load​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter加载此密钥库。
      void Provider.load​(InputStream inStream)
      从输入流读取属性列表（键和元素对）。
      int DigestInputStream.read​()
      读取一个字节，并更新消息摘要（如果摘要功能打开）。
      int DigestInputStream.read​(byte[] b, int off, int len)
      读取一个字节数组，并更新消息摘要（如果摘要功能打开）。
      void KeyStore.store​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStore.store​(KeyStore.LoadStoreParameter param)
      使用给定的 LoadStoreParameter存储此密钥存储 LoadStoreParameter 。
      void DigestOutputStream.write​(byte[] b, int off, int len)
      使用指定的子阵列更新消息摘要（如果摘要功能打开），并且无论如何将子阵列写入输出流。
      void DigestOutputStream.write​(int b)
      使用指定的字节更新消息摘要（如果摘要功能打开），并且无论如何将该字节写入输出流。
      Constructors in java.security that throw IOException
      Constructor 描述
      SignedObject​(Serializable object, PrivateKey signingKey, Signature signingEngine)
      从任何可序列化对象构造一个SignedObject。

    • Uses of IOException in java.security.cert

      Methods in java.security.cert that throw IOException
      Modifier and Type 方法 描述
      void X509CRLSelector.addIssuerName​(byte[] name)
      向issuerNames条件添加一个名称。
      void X509CRLSelector.addIssuerName​(String name)
      诋毁 ，使用 X509CRLSelector.addIssuer(X500Principal)或者 X509CRLSelector.addIssuerName(byte[])代替。
      void X509CertSelector.addPathToName​(int type, byte[] name)
      在pathToNames条件中添加一个名称。
      void X509CertSelector.addPathToName​(int type, String name)
      在pathToNames条件中添加一个名称。
      void X509CertSelector.addSubjectAlternativeName​(int type, byte[] name)
      在subjectAlternativeNames条件中添加一个名称。
      void X509CertSelector.addSubjectAlternativeName​(int type, String name)
      在subjectAlternativeNames条件中添加一个名称。
      void Extension.encode​(OutputStream out)
      生成扩展的DER编码，并将其写入输出流。
      byte[] X509CertSelector.getIssuerAsBytes​()
      作为字节数组返回发行方标准。
      byte[] X509CertSelector.getSubjectAsBytes​()
      以字节数组形式返回主题标准。
      void X509CertSelector.setExtendedKeyUsage​(Set<String> keyPurposeSet)
      设置extendedKeyUsage标准。
      void X509CertSelector.setIssuer​(byte[] issuerDN)
      设定发行人标准。
      void X509CertSelector.setIssuer​(String issuerDN)
      诋毁 ，使用 X509CertSelector.setIssuer(X500Principal)或者 X509CertSelector.setIssuer(byte[])代替。
      void X509CRLSelector.setIssuerNames​(Collection<?> names)
      注意：使用 X509CRLSelector.setIssuers(Collection)或使用此方法时，仅指定可分辨名称的字节数组形式。
      void X509CertSelector.setNameConstraints​(byte[] bytes)
      设置名称约束条件。
      void X509CertSelector.setPathToNames​(Collection<List<?>> names)
      设置pathToNames条件。
      void X509CertSelector.setPolicy​(Set<String> certPolicySet)
      设置策略约束。
      void X509CertSelector.setSubject​(byte[] subjectDN)
      设置主题标准。
      void X509CertSelector.setSubject​(String subjectDN)
      诋毁 ，使用 X509CertSelector.setSubject(X500Principal)或者 X509CertSelector.setSubject(byte[])代替。
      void X509CertSelector.setSubjectAlternativeNames​(Collection<List<?>> names)
      设置subjectAlternativeNames标准。
      void X509CertSelector.setSubjectPublicKey​(byte[] key)
      设置subjectPublicKey标准。
      void X509CertSelector.setSubjectPublicKeyAlgID​(String oid)
      设置subjectPublicKeyAlgID标准。
      Constructors in java.security.cert that throw IOException
      Constructor 描述
      PolicyQualifierInfo​(byte[] encoded)
      从编码字节创建一个 PolicyQualifierInfo的实例。

    • Uses of IOException in java.util

      Subclasses of IOException in java.util
      Modifier and Type Class 描述
      class  InvalidPropertiesFormatException
      抛出以表示操作无法完成，因为输入符合Properties规范的属性集合的相应XML文档类型。
      Methods in java.util that return IOException
      Modifier and Type 方法 描述
      IOException Formatter.ioException​()
      返回IOException最后通过此格式的抛出Appendable 。
      IOException Scanner.ioException​()
      返回 IOException最后通过此抛出 Scanner的基本 Readable 。
      Methods in java.util that throw IOException
      Modifier and Type 方法 描述
      void Properties.load​(InputStream inStream)
      从输入字节流读取属性列表（键和元素对）。
      void Properties.load​(Reader reader)
      以简单的线性格式从输入字符流读取属性列表（关键字和元素对）。
      void Properties.loadFromXML​(InputStream in)
      将指定输入流中的XML文档表示的所有属性加载到此属性表中。
      ResourceBundle ResourceBundle.Control.newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
      为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。
      void Properties.store​(OutputStream out, String comments)
      将 Properties表中的此属性列表（键和元素对）写入适用于使用 load(InputStream)方法加载到 Properties表的格式的输出流。
      void Properties.store​(Writer writer, String comments)
      将 Properties表中的此属性列表（键和元素对）写入适合使用 load(Reader)方法的格式的输出字符流。
      void Properties.storeToXML​(OutputStream os, String comment)
      发出表示此表中包含的所有属性的XML文档。
      void Properties.storeToXML​(OutputStream os, String comment, String encoding)
      使用指定的编码发出表示此表中包含的所有属性的XML文档。
      Constructors in java.util that throw IOException
      Constructor 描述
      PropertyResourceBundle​(InputStream stream)
      从一个InputStream创建一个属性资源束。
      PropertyResourceBundle​(Reader reader)
      从Reader创建属性资源包。
      Scanner​(Path source)
      构造一个新的 Scanner ，产生从指定文件扫描的值。
      Scanner​(Path source, String charsetName)
      构造一个新的 Scanner ，产生从指定文件扫描的值。

    • Uses of IOException in java.util.jar

      Subclasses of IOException in java.util.jar
      Modifier and Type Class 描述
      class  JarException
      表示在读取或写入JAR文件时发生了某种错误。
      Methods in java.util.jar that throw IOException
      Modifier and Type 方法 描述
      Attributes JarEntry.getAttributes​()
      返回 Manifest Attributes此条，或 null如果没有。
      InputStream JarFile.getInputStream​(ZipEntry ze)
      返回用于读取指定zip文件条目内容的输入流。
      Manifest JarFile.getManifest​()
      返回jar文件清单，如果没有，则返回 null 。
      ZipEntry JarInputStream.getNextEntry​()
      读取下一个ZIP文件条目，并将流定位在条目数据的开头。
      JarEntry JarInputStream.getNextJarEntry​()
      读取下一个JAR文件条目，并将流定位在条目数据的开头。
      void Pack200.Packer.pack​(JarFile in, OutputStream out)
      使用JarFile并将其转换为Pack200存档。
      void Pack200.Packer.pack​(JarInputStream in, OutputStream out)
      使用JarInputStream并将其转换为Pack200归档文件。
      void JarOutputStream.putNextEntry​(ZipEntry ze)
      开始编写一个新的JAR文件条目，并将流定位到入口数据的开头。
      int JarInputStream.read​(byte[] b, int off, int len)
      从当前的JAR文件条目读入一个字节数组。
      void Manifest.read​(InputStream is)
      从指定的InputStream读取清单。
      void Pack200.Unpacker.unpack​(File in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。
      void Pack200.Unpacker.unpack​(InputStream in, JarOutputStream out)
      读取Pack200存档，并将编码的JAR写入JarOutputStream。
      void Manifest.write​(OutputStream out)
      将清单写入指定的OutputStream。
      Constructors in java.util.jar that throw IOException
      Constructor 描述
      JarFile​(File file)
      创建一个新的 JarFile从指定的 File对象读取。
      JarFile​(File file, boolean verify)
      创建一个新的 JarFile从指定的 File对象读取。
      JarFile​(File file, boolean verify, int mode)
      创建一个新的 JarFile以指定的方式读取指定的 File对象。
      JarFile​(File file, boolean verify, int mode, Runtime.Version version)
      创建新的 JarFile以指定的方式从指定的 File对象中读取。
      JarFile​(String name)
      创建一个新的 JarFile从指定的文件 name 。
      JarFile​(String name, boolean verify)
      创建一个新的 JarFile从指定的文件 name 。
      JarInputStream​(InputStream in)
      创建一个新的 JarInputStream并读取可选的清单。
      JarInputStream​(InputStream in, boolean verify)
      创建一个新的 JarInputStream并读取可选的清单。
      JarOutputStream​(OutputStream out)
      创建一个新的 JarOutputStream没有清单。
      JarOutputStream​(OutputStream out, Manifest man)
      创建一个新的 JarOutputStream与指定的 Manifest 。
      Manifest​(InputStream is)
      从指定的输入流构造一个新的清单。

    • Uses of IOException in java.util.logging

      Methods in java.util.logging that throw IOException
      Modifier and Type 方法 描述
      void LogManager.readConfiguration​()
      读取并初始化日志记录配置。
      void LogManager.readConfiguration​(InputStream ins)
      从给定的输入流读取和初始化日志记录配置。
      void LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。
      void LogManager.updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)
      更新日志记录配置。
      Constructors in java.util.logging that throw IOException
      Constructor 描述
      FileHandler​()
      构造默认值 FileHandler 。
      FileHandler​(String pattern)
      初始化 FileHandler以写入给定的文件名。
      FileHandler​(String pattern, boolean append)
      初始化一个 FileHandler写入给定的文件名，可选附加。
      FileHandler​(String pattern, int limit, int count)
      初始化一个 FileHandler写入一组文件。
      FileHandler​(String pattern, int limit, int count, boolean append)
      初始化 FileHandler以写入一组可选附件的文件。
      FileHandler​(String pattern, long limit, int count, boolean append)
      初始化一个 FileHandler写入一组可选附加的文件。
      SocketHandler​()
      创建一个 SocketHandler ，仅使用 LogManager属性（或其默认值）。
      SocketHandler​(String host, int port)
      使用指定的主机和端口构造一个 SocketHandler 。

    • Uses of IOException in java.util.prefs

      Methods in java.util.prefs that throw IOException
      Modifier and Type 方法 描述
      void AbstractPreferences.exportNode​(OutputStream os)
      实现 exportNode方法按照在本说明书中 Preferences.exportNode(OutputStream) 。
      abstract void Preferences.exportNode​(OutputStream os)
      在指定的输出流上发出一个XML文档，表示此节点中包含的所有首选项（而不是其后代）。
      void AbstractPreferences.exportSubtree​(OutputStream os)
      实现 exportSubtree方法按照在本说明书中 Preferences.exportSubtree(OutputStream) 。
      abstract void Preferences.exportSubtree​(OutputStream os)
      发出表示此节点及其所有后代中包含的所有首选项的XML文档。
      static void Preferences.importPreferences​(InputStream is)
      在指定的输入流中导入由XML文档表示的所有首选项。

    • Uses of IOException in java.util.zip

      Subclasses of IOException in java.util.zip
      Modifier and Type Class 描述
      class  ZipException
      表示发生了某种类型的Zip异常。
      Methods in java.util.zip that throw IOException
      Modifier and Type 方法 描述
      int DeflaterInputStream.available​()
      到达EOF后返回0，否则总是返回1。
      int InflaterInputStream.available​()
      到达EOF后返回0，否则总是返回1。
      int ZipInputStream.available​()
      EOF到达当前条目数据后返回0，否则返回1。
      void DeflaterInputStream.close​()
      关闭此输入流及其底层输入流，丢弃任何待处理的未压缩数据。
      void DeflaterOutputStream.close​()
      将剩余的压缩数据写入输出流并关闭底层流。
      void GZIPInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void InflaterInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void InflaterOutputStream.close​()
      将任何剩余的未压缩数据写入输出流并关闭底层输出流。
      void ZipFile.close​()
      关闭ZIP文件。
      void ZipInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void ZipOutputStream.close​()
      关闭ZIP输出流以及正在过滤的流。
      void ZipInputStream.closeEntry​()
      关闭当前的ZIP条目，并定位流以读取下一个条目。
      void ZipOutputStream.closeEntry​()
      关闭当前的ZIP条目，并定位流以写入下一个条目。
      protected void DeflaterOutputStream.deflate​()
      将下一个压缩数据块写入输出流。
      protected void InflaterInputStream.fill​()
      填写输入缓冲区以获得更多的数据解压缩。
      protected void ZipFile.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      void DeflaterOutputStream.finish​()
      完成将压缩数据写入输出流，而不关闭底层流。
      void GZIPOutputStream.finish​()
      完成将压缩数据写入输出流，而不关闭底层流。
      void InflaterOutputStream.finish​()
      完成将未压缩数据写入输出流，而不关闭底层流。
      void ZipOutputStream.finish​()
      完成编写ZIP输出流的内容，而不关闭底层流。
      void DeflaterOutputStream.flush​()
      刷新压缩的输出流。
      void InflaterOutputStream.flush​()
      刷新此输出流，强制任何待处理的缓冲输出字节被写入。
      InputStream ZipFile.getInputStream​(ZipEntry entry)
      返回用于读取指定zip文件条目内容的输入流。
      ZipEntry ZipInputStream.getNextEntry​()
      读取下一个ZIP文件条目，并将流定位在条目数据的开头。
      void ZipOutputStream.putNextEntry​(ZipEntry e)
      开始编写新的ZIP文件条目，并将流定位到条目数据的开头。
      int CheckedInputStream.read​()
      读一个字节。
      int CheckedInputStream.read​(byte[] buf, int off, int len)
      读入一个字节数组。
      int DeflaterInputStream.read​()
      从输入流读取一个字节的压缩数据。
      int DeflaterInputStream.read​(byte[] b, int off, int len)
      将压缩数据读入字节数组。
      int GZIPInputStream.read​(byte[] buf, int off, int len)
      将未压缩的数据读入字节数组。
      int InflaterInputStream.read​()
      读取一个字节的未压缩数据。
      int InflaterInputStream.read​(byte[] b, int off, int len)
      将未压缩的数据读入字节数组。
      int ZipInputStream.read​(byte[] b, int off, int len)
      从当前ZIP条目读取到字节数组。
      void DeflaterInputStream.reset​()
      不支持此操作 。
      void InflaterInputStream.reset​()
      将此流重新定位到最后在此输入流上调用 mark方法时的位置。
      long CheckedInputStream.skip​(long n)
      跳过指定的输入字节数。
      long DeflaterInputStream.skip​(long n)
      跳过并丢弃输入流中的数据。
      long InflaterInputStream.skip​(long n)
      跳过未压缩数据的指定字节数。
      long ZipInputStream.skip​(long n)
      跳过当前ZIP条目中指定的字节数。
      void CheckedOutputStream.write​(byte[] b, int off, int len)
      写入一个字节数组。
      void CheckedOutputStream.write​(int b)
      写一个字节。
      void DeflaterOutputStream.write​(byte[] b, int off, int len)
      将一个字节数组写入压缩的输出流。
      void DeflaterOutputStream.write​(int b)
      将一个字节写入压缩的输出流。
      void GZIPOutputStream.write​(byte[] buf, int off, int len)
      将字节数组写入压缩输出流。
      void InflaterOutputStream.write​(byte[] b, int off, int len)
      将一组字节写入未压缩的输出流。
      void InflaterOutputStream.write​(int b)
      将一个字节写入未压缩的输出流。
      void ZipOutputStream.write​(byte[] b, int off, int len)
      将一个字节数组写入当前的ZIP条目数据。
      Constructors in java.util.zip that throw IOException
      Constructor 描述
      GZIPInputStream​(InputStream in)
      创建一个默认缓冲区大小的新输入流。
      GZIPInputStream​(InputStream in, int size)
      创建具有指定缓冲区大小的新输入流。
      GZIPOutputStream​(OutputStream out)
      创建一个具有默认缓冲区大小的新输出流。
      GZIPOutputStream​(OutputStream out, boolean syncFlush)
      创建具有默认缓冲区大小和指定刷新模式的新输出流。
      GZIPOutputStream​(OutputStream out, int size)
      创建具有指定缓冲区大小的新输出流。
      GZIPOutputStream​(OutputStream out, int size, boolean syncFlush)
      创建具有指定缓冲区大小和刷新模式的新输出流。
      ZipFile​(File file)
      打开一个ZIP文件，读取指定的File对象。
      ZipFile​(File file, int mode)
      打开一个新的 ZipFile以指定的方式读取指定的 File对象。
      ZipFile​(File file, int mode, Charset charset)
      打开新的 ZipFile ，在指定的模式下从指定的 File对象中读取。
      ZipFile​(File file, Charset charset)
      打开一个ZIP文件，读取指定的File对象。
      ZipFile​(String name)
      打开一个zip文件进行阅读。
      ZipFile​(String name, Charset charset)
      打开一个zip文件进行阅读。

    • Uses of IOException in javafx.css

      Methods in javafx.css that throw IOException
      Modifier and Type | 方法 | 描述
      static void Stylesheet.convertToBinary​(File source, File destination)
      将urlIn引用的.css文件转换为二进制格式并写入urlOut。
      static Stylesheet Stylesheet.loadBinary​(URL url)
      从输入流加载二进制样式表文件。
      Stylesheet CssParser.parse​(String docbase, String stylesheetText)
      使用docbase作为解析样式表中的引用的基本URL从CSS文档字符串创建样式表。
      Stylesheet CssParser.parse​(URL url)
      通过从URL读取CSS文档来更新给定的样式表，假设UTF-8编码。
      static StyleConverter<?,?> StyleConverter.readBinary​(DataInputStream is, String[] strings)
      读取二进制数据流。
      static String[] | StyleConverter.StringStore.readBinary​(DataInputStream is)
      protected void | CompoundSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      protected void | Selector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      protected void | SimpleSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)
      void | StyleConverter.StringStore.writeBinary​(DataOutputStream os)
      void StyleConverter.writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)
      写二进制数据。

    • Uses of IOException in javafx.css.converter

      Methods in javafx.css.converter that throw IOException
      Modifier and Type | 方法 | 描述
      static StyleConverter<?,?> | EnumConverter.readBinary​(DataInputStream is, String[] strings)
      void | EnumConverter.writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)

    • Uses of IOException in javafx.fxml

      Subclasses of IOException in javafx.fxml
      Modifier and Type Class 描述
      class  LoadException
      在加载操作期间遇到错误时抛出。
      Methods in javafx.fxml that throw IOException
      Modifier and Type 方法 描述
      <T> T FXMLLoader.load​()
      从FXML文档加载对象层次结构。
      <T> T FXMLLoader.load​(InputStream inputStream)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。

    • Uses of IOException in javax.activation

      Subclasses of IOException in javax.activation
      Modifier and Type Class 描述
      class  UnsupportedDataTypeException
      表示请求的操作不支持请求的数据类型。
      Methods in javax.activation that throw IOException
      Modifier and Type 方法 描述
      Object CommandInfo.getCommandObject​(DataHandler dh, ClassLoader loader)
      返回实例化的JavaBean组件。
      Object DataContentHandler.getContent​(DataSource ds)
      以最优选的形式返回表示数据的对象。
      Object DataHandler.getContent​()
      以其首选对象形式返回数据。
      InputStream DataHandler.getInputStream​()
      获取此对象的InputStream。
      InputStream DataSource.getInputStream​()
      此方法返回表示数据的 InputStream ，如果不能这样做，则返回相应的异常。
      InputStream FileDataSource.getInputStream​()
      此方法将返回一个表示数据的InputStream，如果不能执行此操作将抛出IOException。
      InputStream URLDataSource.getInputStream​()
      来自URL的getInputStream方法。
      OutputStream DataHandler.getOutputStream​()
      获取此DataHandler的OutputStream以允许覆盖底层数据。
      OutputStream DataSource.getOutputStream​()
      该方法返回一个 OutputStream ，其中可以写入数据，如果不能这样做，则抛出相应的异常。
      OutputStream FileDataSource.getOutputStream​()
      此方法将返回一个表示数据的OutputStream，如果不能执行此操作将抛出IOException。
      OutputStream URLDataSource.getOutputStream​()
      来自URL的getOutputStream方法。
      Object DataContentHandler.getTransferData​(DataFlavor df, DataSource ds)
      返回表示要传输的数据的对象。
      Object DataHandler.getTransferData​(DataFlavor flavor)
      返回表示要传输的数据的对象。
      void MimeType.readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。
      void CommandObject.setCommandContext​(String verb, DataHandler dh)
      使用要处理的动词来初始化命令，以及描述将要操作的数据的DataHandler。
      void MimeType.writeExternal​(ObjectOutput out)
      该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput对象，字符串和数组的writeObject方法来保存其内容。
      void DataContentHandler.writeTo​(Object obj, String mimeType, OutputStream os)
      将对象转换为指定MIME类型的字节流，并将其写入输出流。
      void DataHandler.writeTo​(OutputStream os)
      将数据写入 OutputStream 。
      Constructors in javax.activation that throw IOException
      Constructor 描述
      MailcapCommandMap​(String fileName)
      构造函数允许调用者指定 mailcap文件的路径。
      MimetypesFileTypeMap​(String mimeTypeFileName)
      构造MimetypesFileTypeMap，并从命名文件中添加程序化条目。

    • Uses of IOException in javax.activity

      Subclasses of IOException in javax.activity
      Modifier and Type Class 描述
      class  ActivityCompletedException
      可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。
      class  ActivityRequiredException
      如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。
      class  InvalidActivityException
      可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。

    • Uses of IOException in javax.annotation.processing

      Subclasses of IOException in javax.annotation.processing
      Modifier and Type Class 描述
      class  FilerException
      表示一个Filer检测到尝试打开一个文件将违反Filer提供的保证。
      Methods in javax.annotation.processing that throw IOException
      Modifier and Type 方法 描述
      JavaFileObject Filer.createClassFile​(CharSequence name, Element... originatingElements)
      创建一个新的类文件，并返回一个对象以允许写入它。
      FileObject Filer.createResource​(JavaFileManager.Location location, CharSequence moduleAndPkg, CharSequence relativeName, Element... originatingElements)
      创建一个新的辅助资源文件进行写入并返回一个文件对象。
      JavaFileObject Filer.createSourceFile​(CharSequence name, Element... originatingElements)
      创建一个新的源文件并返回一个对象以允许写入它。
      FileObject Filer.getResource​(JavaFileManager.Location location, CharSequence moduleAndPkg, CharSequence relativeName)
      返回一个读取现有资源的对象。

    • Uses of IOException in javax.crypto

      Methods in javax.crypto that throw IOException
      Modifier and Type 方法 描述
      int CipherInputStream.available​()
      返回可以从该输入流读取而不阻塞的字节数。
      void CipherInputStream.close​()
      关闭此输入流并释放与流相关联的任何系统资源。
      void CipherOutputStream.close​()
      关闭此输出流并释放与此流相关联的任何系统资源。
      void CipherOutputStream.flush​()
      通过强制已经由封装的密码对象处理的任何缓冲的输出字节被写出来刷新输出流。
      byte[] EncryptedPrivateKeyInfo.getEncoded​()
      返回此对象的ASN.1编码。
      Object SealedObject.getObject​(Key key)
      检索原始（封装）对象。
      Object SealedObject.getObject​(Key key, String provider)
      检索原始（封装）对象。
      Object SealedObject.getObject​(Cipher c)
      检索原始（封装）对象。
      int CipherInputStream.read​()
      从该输入流读取下一个数据字节。
      int CipherInputStream.read​(byte[] b)
      从该输入流读取最多 b.length字节的数据到一个字节数组。
      int CipherInputStream.read​(byte[] b, int off, int len)
      从该输入流读取最多 len个字节的数据到字节数组。
      long CipherInputStream.skip​(long n)
      跳过 n字节的字节，可从该输入流中读取而不阻塞。
      void CipherOutputStream.write​(byte[] b)
      将 b.length字节从指定的字节数组写入此输出流。
      void CipherOutputStream.write​(byte[] b, int off, int len)
      从偏移量 off开始的指定字节数组写入 len字节到此输出流。
      void CipherOutputStream.write​(int b)
      将指定的字节写入此输出流。
      Constructors in javax.crypto that throw IOException
      Constructor 描述
      EncryptedPrivateKeyInfo​(byte[] encoded)
      从其ASN.1编码构造（即解析）一个 EncryptedPrivateKeyInfo 。
      SealedObject​(Serializable object, Cipher c)
      从任何可序列化对象构造一个SealedObject。

    • Uses of IOException in javax.imageio

      Subclasses of IOException in javax.imageio
      Modifier and Type Class 描述
      class  IIOException
      用于发信号读取和写入操作失败的异常类。
      Methods in javax.imageio that throw IOException
      Modifier and Type 方法 描述
      boolean ImageWriter.canInsertEmpty​(int imageIndex)
      如果作者支持在给定索引处插入新的空图像，则返回 true 。
      boolean ImageWriter.canInsertImage​(int imageIndex)
      如果作者支持在给定索引处插入新图像，则返回 true 。
      boolean ImageWriter.canRemoveImage​(int imageIndex)
      如果作者支持在给定索引处删除现有图像，则返回 true 。
      boolean ImageWriter.canReplaceImageMetadata​(int imageIndex)
      返回 true ，如果它是可以替换与现有的图像与索引相关联的图像元数据 imageIndex 。
      boolean ImageWriter.canReplacePixels​(int imageIndex)
      如果作者允许使用 replacePixels方法替换给定图像的像素，则返回 true 。
      boolean ImageWriter.canReplaceStreamMetadata​()
      如果可以替换输出中已经存在的流元数据，则返回 true 。
      boolean ImageWriter.canWriteEmpty​()
      如果作者支持写入一个包含未定义像素值的单个图像的完整图像流，并将相关的元数据和缩略图写入输出，则返回 true 。
      static ImageInputStream ImageIO.createImageInputStream​(Object input)
      返回一个 ImageInputStream ，它将从给定的 Object输入。
      static ImageOutputStream ImageIO.createImageOutputStream​(Object output)
      返回一个 ImageOutputStream ，将其输出发送给给定的 Object 。
      void ImageWriter.endInsertEmpty​()
      完成插入一个以前调用 prepareInsertEmpty开始的新映像。
      void ImageWriter.endReplacePixels​()
      终止一个调用序列到 replacePixels 。
      void ImageWriter.endWriteEmpty​()
      完成一个新的图像的写作，该图像是在以前调用 prepareWriteEmpty 。
      void ImageWriter.endWriteSequence​()
      完成从 prepareWriteSequence开始的一系列图像的 prepareWriteSequence 。
      float ImageReader.getAspectRatio​(int imageIndex)
      将给定图像的宽高比（即其宽度除以其高度）作为 float 。
      String ImageReader.getFormatName​()
      返回一个 String标识输入源的格式。
      abstract int ImageReader.getHeight​(int imageIndex)
      返回输入源中给定图像的高度（以像素为单位）。
      abstract IIOMetadata ImageReader.getImageMetadata​(int imageIndex)
      返回一个 IIOMetadata与给定图像，或相关联的对象包含元数据 null如果读取器不支持读取元数据，被设置为忽略元数据，或者，如果没有元数据可用。
      IIOMetadata ImageReader.getImageMetadata​(int imageIndex, String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata表示与给定图像，或相关联的元数据对象 null如果读取器不支持读取元数据或没有可用的。
      abstract Iterator<ImageTypeSpecifier> ImageReader.getImageTypes​(int imageIndex)
      返回一个 Iterator其中包含给定图像可能被解码的可能的图像类型，形式为 ImageTypeSpecifiers s。
      abstract int ImageReader.getNumImages​(boolean allowSearch)
      返回当前输入源可用的图像数量，不包括缩略图。
      int ImageReader.getNumThumbnails​(int imageIndex)
      返回与给定图像相关联的缩略图预览图像的数量。
      ImageTypeSpecifier ImageReader.getRawImageType​(int imageIndex)
      返回一个 ImageTypeSpecifier表示 SampleModel和 ColorModel ，其最接近地表示图像的“原始”内部格式。
      abstract IIOMetadata ImageReader.getStreamMetadata​()
      返回表示与整个输入源相关联的元数据（即与任何特定图像 null ）的 null如果阅读器不支持读取元数据，则返回 IIOMetadata对象，如果没有元数据可用，则 null 。
      IIOMetadata ImageReader.getStreamMetadata​(String formatName, Set<String> nodeNames)
      返回一个 IIOMetadata对象，表示与整个输入源相关联的元数据（即，不与任何特定图像相关联）。
      int ImageReader.getThumbnailHeight​(int imageIndex, int thumbnailIndex)
      返回索引的缩略图预览图像的高度 thumbnailIndex ，通过索引的图像关联 ImageIndex 。
      int ImageReader.getThumbnailWidth​(int imageIndex, int thumbnailIndex)
      返回由索引的缩略图的预览图像的宽度 thumbnailIndex ，与由索引的图像相关联 ImageIndex 。
      int ImageReader.getTileGridXOffset​(int imageIndex)
      返回给定图像中瓦片（0，0）左上角的X坐标。
      int ImageReader.getTileGridYOffset​(int imageIndex)
      返回给定图像中瓦片（0，0）左上角的Y坐标。
      int ImageReader.getTileHeight​(int imageIndex)
      返回给定图像中图块的高度。
      int ImageReader.getTileWidth​(int imageIndex)
      返回给定图像中图块的宽度。
      abstract int ImageReader.getWidth​(int imageIndex)
      返回输入源中给定图像的宽度（以像素为单位）。
      boolean ImageReader.hasThumbnails​(int imageIndex)
      如果给定的图像具有与其相关联的缩略图预览图像，则返回 true 。
      boolean ImageReader.isImageTiled​(int imageIndex)
      如果图像被组织成 瓦片 ，即相等大小的非重叠矩形，则返回 true 。
      boolean ImageReader.isRandomAccessEasy​(int imageIndex)
      返回 true如果给定图像的存储格式不会对随机访问像素造成固有的障碍。
      void ImageWriter.prepareInsertEmpty​(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将未定义像素值的新图像插入到现有图像流中。
      void ImageWriter.prepareReplacePixels​(int imageIndex, Rectangle region)
      准备作者处理一系列对 replacePixels方法的调用。
      void ImageWriter.prepareWriteEmpty​(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param)
      开始将一个完整的图像流写入到包含未定义像素值的单个图像和关联的元数据和缩略图中。
      void ImageWriter.prepareWriteSequence​(IIOMetadata streamMetadata)
      使用提供的流元数据对象准备流以接受一系列后续的 writeToSequence调用。
      static BufferedImage ImageIO.read​(File input)
      作为对所提供的 File进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
      static BufferedImage ImageIO.read​(InputStream input)
      作为对所提供的 InputStream进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
      static BufferedImage ImageIO.read​(URL input)
      作为对所提供的 URL进行解码的结果，返回 BufferedImage ，其中自动从当前注册的那些中选择一个 ImageReader 。
      static BufferedImage ImageIO.read​(ImageInputStream stream)
      作为 BufferedImage解码的结果，返回 ImageInputStream ，其中 ImageReader自动从当前注册的那些中自动选择。
      BufferedImage ImageReader.read​(int imageIndex)
      读取 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用默认值 ImageReadParam 。
      abstract BufferedImage ImageReader.read​(int imageIndex, ImageReadParam param)
      读取 imageIndex索引的图像，并将其作为完整的 BufferedImage返回，使用附带的 ImageReadParam 。
      IIOImage ImageReader.readAll​(int imageIndex, ImageReadParam param)
      读取由索引的图像 imageIndex并返回一个 IIOImage包含图像，缩略图和相关联的图像元数据，使用所提供的 ImageReadParam 。
      Iterator<IIOImage> ImageReader.readAll​(Iterator<? extends ImageReadParam> params)
      返回 Iterator包含所有图像，缩略图和元数据，开始由下式给出的指数在 getMinIndex ，从形式的输入源 IIOImage对象。
      RenderedImage ImageReader.readAsRenderedImage​(int imageIndex, ImageReadParam param)
      返回一个 RenderedImage对象，其中包含由 imageIndex索引的图像的内容。
      Raster ImageReader.readRaster​(int imageIndex, ImageReadParam param)
      返回一个新的 Raster对象，其中包含来自图像流的原始像素数据，而不应用任何颜色转换。
      BufferedImage ImageReader.readThumbnail​(int imageIndex, int thumbnailIndex)
      返回由 thumbnailIndex索引的缩略图预览图像，与 ImageIndex索引的图像相关联，为 BufferedImage 。
      BufferedImage ImageReader.readTile​(int imageIndex, int tileX, int tileY)
      读取 tileX和 tileY参数指示的 tileX ，将其作为 BufferedImage返回。
      Raster ImageReader.readTileRaster​(int imageIndex, int tileX, int tileY)
      返回一个新的 Raster对象，其中包含来自图块的原始像素数据，而不应用任何颜色转换。
      void ImageWriter.removeImage​(int imageIndex)
      从流中删除图像。
      void ImageWriter.replaceImageMetadata​(int imageIndex, IIOMetadata imageMetadata)
      替换与现有图像相关联的图像元数据。
      void ImageWriter.replacePixels​(Raster raster, ImageWriteParam param)
      用给定的 Raster的一部分替换已经存在于输出中的图像的一部分。
      void ImageWriter.replacePixels​(RenderedImage image, ImageWriteParam param)
      用给定图像的一部分替换已经存在于输出中的图像的一部分。
      void ImageWriter.replaceStreamMetadata​(IIOMetadata streamMetadata)
      用新信息替换输出中的流元数据。
      static boolean ImageIO.write​(RenderedImage im, String formatName, File output)
      使用支持给定格式的任意 ImageWriter写入图像到 File 。
      static boolean ImageIO.write​(RenderedImage im, String formatName, OutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 OutputStream 。
      static boolean ImageIO.write​(RenderedImage im, String formatName, ImageOutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 ImageOutputStream 。
      void ImageWriter.write​(RenderedImage image)
      将包含单个图像的完整图像流附加到输出的默认元数据和缩略图。
      void ImageWriter.write​(IIOImage image)
      将含有默认元数据和缩略图的单个图像的完整图像流附加到输出。
      abstract void ImageWriter.write​(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param)
      将包含单个图像和关联流以及图像元数据和缩略图的完整图像流附加到输出。
      void ImageWriter.writeInsert​(int imageIndex, IIOImage image, ImageWriteParam param)
      将新图像插入到现有图像流中。
      void ImageWriter.writeToSequence​(IIOImage image, ImageWriteParam param)
      将单个图像和可能关联的元数据和缩略图附加到输出。

    • Uses of IOException in javax.imageio.metadata

      Subclasses of IOException in javax.imageio.metadata
      Modifier and Type Class 描述
      class  IIOInvalidTreeException
      一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。

    • Uses of IOException in javax.imageio.spi

      Methods in javax.imageio.spi that throw IOException
      Modifier and Type 方法 描述
      abstract boolean ImageReaderSpi.canDecodeInput​(Object source)
      如果提供的源对象看起来是这个读者支持的格式，则返回 true 。
      ImageInputStream ImageInputStreamSpi.createInputStreamInstance​(Object input)
      返回与此服务提供商关联的 ImageInputStream实现的实例。
      abstract ImageInputStream ImageInputStreamSpi.createInputStreamInstance​(Object input, boolean useCache, File cacheDir)
      返回与该服务提供商相关联的 ImageInputStream实现的实例。
      ImageOutputStream ImageOutputStreamSpi.createOutputStreamInstance​(Object output)
      返回与此服务提供商关联的 ImageOutputStream实现的实例。
      abstract ImageOutputStream ImageOutputStreamSpi.createOutputStreamInstance​(Object output, boolean useCache, File cacheDir)
      返回与此服务提供商关联的 ImageOutputStream实现的实例。
      ImageReader ImageReaderSpi.createReaderInstance​()
      返回与此服务提供程序相关联的 ImageReader实现的实例。
      abstract ImageReader ImageReaderSpi.createReaderInstance​(Object extension)
      返回与该服务提供商相关联的 ImageReader实现的实例。
      ImageWriter ImageWriterSpi.createWriterInstance​()
      返回与此服务提供程序相关联的 ImageWriter实现的实例。
      abstract ImageWriter ImageWriterSpi.createWriterInstance​(Object extension)
      返回与此服务提供程序相关联的 ImageWriter实现的实例。

    • Uses of IOException in javax.imageio.stream

      Methods in javax.imageio.stream that throw IOException
      Modifier and Type | 方法 | 描述
      protected void ImageInputStreamImpl.checkClosed​()
      如果流已关闭，则抛出一个 IOException 。
      void FileCacheImageInputStream.close​()
      关闭此 FileCacheImageInputStream ，关闭并删除缓存文件。
      void FileCacheImageOutputStream.close​()
      关闭此 FileCacheImageOutputStream 。
      void | FileImageInputStream.close​()
      void | FileImageOutputStream.close​()
      void ImageInputStream.close​()
      关闭流。
      void | ImageInputStreamImpl.close​()
      void MemoryCacheImageInputStream.close​()
      关闭这个 MemoryCacheImageInputStream ，释放缓存。
      void MemoryCacheImageOutputStream.close​()
      关闭此 MemoryCacheImageOutputStream 。
      void ImageInputStream.flush​()
      在当前流位置之前丢弃流的初始位置。
      void | ImageInputStreamImpl.flush​()
      void | FileCacheImageOutputStream.flushBefore​(long pos)
      void ImageInputStream.flushBefore​(long pos)
      在指示的位置之前丢弃流的初始部分。
      void | ImageInputStreamImpl.flushBefore​(long pos)
      void ImageOutputStream.flushBefore​(long pos)
      将给定位置之前的所有数据刷新到底层目标，例如 OutputStream或 File 。
      void | MemoryCacheImageInputStream.flushBefore​(long pos)
      void | MemoryCacheImageOutputStream.flushBefore​(long pos)
      protected void ImageOutputStreamImpl.flushBits​()
      如果位偏移量不为零，则强制当前字节中的剩余位为0，并将流位置提前一位。
      int ImageInputStream.getBitOffset​()
      返回当前的位偏移量，为0到7之间的整数，包括0和7。
      int | ImageInputStreamImpl.getBitOffset​()
      long ImageInputStream.getStreamPosition​()
      返回流的当前字节位置。
      long | ImageInputStreamImpl.getStreamPosition​()
      long ImageInputStream.length​()
      如果已知，返回流的总长度。
      int | FileCacheImageInputStream.read​()
      int | FileCacheImageInputStream.read​(byte[] b, int off, int len)
      int | FileCacheImageOutputStream.read​()
      int | FileCacheImageOutputStream.read​(byte[] b, int off, int len)
      int | FileImageInputStream.read​()
      int | FileImageInputStream.read​(byte[] b, int off, int len)
      int | FileImageOutputStream.read​()
      int | FileImageOutputStream.read​(byte[] b, int off, int len)
      int ImageInputStream.read​()
      从流中读取一个字节，并将其作为0到255之间的整数返回。
      int ImageInputStream.read​(byte[] b)
      从流中读取最多 b.length个字节，并将其从索引0开始存储到 b 。
      int ImageInputStream.read​(byte[] b, int off, int len)
      读取到 len从流字节，并将其存储到 b开始于索引 off 。
      abstract int ImageInputStreamImpl.read​()
      从流中读取一个字节，并将其作为 int返回0到255之间。
      int ImageInputStreamImpl.read​(byte[] b)
      一个方便的方法，调用 read(b, 0, b.length) 。
      abstract int ImageInputStreamImpl.read​(byte[] b, int off, int len)
      读取到 len从流字节，并将其存储到 b开始于索引 off 。
      int | MemoryCacheImageInputStream.read​()
      int | MemoryCacheImageInputStream.read​(byte[] b, int off, int len)
      int | MemoryCacheImageOutputStream.read​()
      int | MemoryCacheImageOutputStream.read​(byte[] b, int off, int len)
      int ImageInputStream.readBit​()
      从流中读取一个位，并将其作为 int返回，值为 0或 1 。
      int | ImageInputStreamImpl.readBit​()
      long ImageInputStream.readBits​(int numBits)
      从流读取bitstring并将其作为 long返回，第一位读取成为输出的最高有效位。
      long | ImageInputStreamImpl.readBits​(int numBits)
      boolean ImageInputStream.readBoolean​()
      从该流读取一个字节，并返回一个 boolean的值 true ，如果它是非零， false ，如果它是零。
      boolean | ImageInputStreamImpl.readBoolean​()
      byte ImageInputStream.readByte​()
      从流中读取一个字节，并将其作为 byte值返回。
      byte | ImageInputStreamImpl.readByte​()
      void ImageInputStream.readBytes​(IIOByteBuffer buf, int len)
      从流中读取最多 len个字节，并修改提供的 IIOByteBuffer以指示可能找到数据的字节数组，偏移量和长度。
      void | ImageInputStreamImpl.readBytes​(IIOByteBuffer buf, int len)
      char ImageInputStream.readChar​()
      等同于 readUnsignedShort ，但使用 char数据类型返回结果。
      char | ImageInputStreamImpl.readChar​()
      double ImageInputStream.readDouble​()
      从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 double返回。
      double | ImageInputStreamImpl.readDouble​()
      float ImageInputStream.readFloat​()
      从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 float返回。
      float | ImageInputStreamImpl.readFloat​()
      void ImageInputStream.readFully​(byte[] b)
      读取 b.length从流字节，并将其存储到 b开始于索引 0 。
      void ImageInputStream.readFully​(byte[] b, int off, int len)
      从流中读取 len个字节，并将其存储到 b ，索引号为 off 。
      void ImageInputStream.readFully​(char[] c, int off, int len)
      读取 len从根据当前字节顺序的流字符（无符号的16位整数），并将其存储到 c开始于索引 off 。
      void ImageInputStream.readFully​(double[] d, int off, int len)
      读取 len根据当前字节顺序从流双打（64位IEEE双精度浮点值），并且将它们存储到 d开始于索引 off 。
      void ImageInputStream.readFully​(float[] f, int off, int len)
      读取 len根据当前字节顺序从流浮标（32位IEEE单精度浮点值），并且将它们存储到 f开始于索引 off 。
      void ImageInputStream.readFully​(int[] i, int off, int len)
      读取 len从根据当前字节顺序的流整数（带符号的32位整数），并将其存储到 i开始于索引 off 。
      void ImageInputStream.readFully​(long[] l, int off, int len)
      读取 len从根据当前字节顺序的流long（有符号的64位整数），并将其存储到 l开始于索引 off 。
      void ImageInputStream.readFully​(short[] s, int off, int len)
      读取 len从根据当前字节顺序的流短裤（带符号的16位整数），并将其存储到 s开始于索引 off 。
      void | ImageInputStreamImpl.readFully​(byte[] b)
      void | ImageInputStreamImpl.readFully​(byte[] b, int off, int len)
      void | ImageInputStreamImpl.readFully​(char[] c, int off, int len)
      void | ImageInputStreamImpl.readFully​(double[] d, int off, int len)
      void | ImageInputStreamImpl.readFully​(float[] f, int off, int len)
      void | ImageInputStreamImpl.readFully​(int[] i, int off, int len)
      void | ImageInputStreamImpl.readFully​(long[] l, int off, int len)
      void | ImageInputStreamImpl.readFully​(short[] s, int off, int len)
      int ImageInputStream.readInt​()
      从流中读取4个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 int返回。
      int | ImageInputStreamImpl.readInt​()
      String ImageInputStream.readLine​()
      从输入流读取下一行文本。
      String | ImageInputStreamImpl.readLine​()
      long ImageInputStream.readLong​()
      从流中读取8个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 long返回。
      long | ImageInputStreamImpl.readLong​()
      short ImageInputStream.readShort​()
      从流中读取两个字节，（在概念上）根据当前字节顺序连接它们，并将结果作为 short值返回。
      short | ImageInputStreamImpl.readShort​()
      int ImageInputStream.readUnsignedByte​()
      从流中读取一个字节，（在概念上）将其转换为int，使用 0xff进行掩码，以剥离任何符号扩展位，并将其作为 byte值返回。
      int | ImageInputStreamImpl.readUnsignedByte​()
      long ImageInputStream.readUnsignedInt​()
      从流中读取4个字节，并且（在概念上）根据当前字节顺序连接它们，将结果转换为长，将其用 0xffffffffL ，以便剥离任何符号扩展位，并将结果作为无符号 long返回值。
      long | ImageInputStreamImpl.readUnsignedInt​()
      int ImageInputStream.readUnsignedShort​()
      中读取两个字节从该流，并根据当前字节顺序（概念上）将其连接，将得到的值转换为 int ，口罩它 0xffff为了去掉所有符号扩展位，并返回结果以无符号价值 int 。
      int | ImageInputStreamImpl.readUnsignedShort​()
      String ImageInputStream.readUTF​()
      读取已使用 modified UTF-8格式编码的字符串。
      String | ImageInputStreamImpl.readUTF​()
      void ImageInputStream.reset​()
      在最近不匹配的调用 mark时，返回到前一位置的流指针，包括位偏移量。
      void ImageInputStreamImpl.reset​()
      从标记位置的堆栈中重置当前流字节和位位置。
      void FileCacheImageOutputStream.seek​(long pos)
      设置当前流位置，并将位偏移重置为0。
      void | FileImageInputStream.seek​(long pos)
      void FileImageOutputStream.seek​(long pos)
      设置当前流位置，并将位偏移重置为0。
      void ImageInputStream.seek​(long pos)
      将当前流位置设置为所需位置。
      void | ImageInputStreamImpl.seek​(long pos)
      void ImageInputStream.setBitOffset​(int bitOffset)
      将位偏移设置为0到7之间的整数，包括0和7。
      void | ImageInputStreamImpl.setBitOffset​(int bitOffset)
      int ImageInputStream.skipBytes​(int n)
      将流位置向前移动给定的字节数。
      long ImageInputStream.skipBytes​(long n)
      将流位置向前移动给定的字节数。
      int ImageInputStreamImpl.skipBytes​(int n)
      通过致电 seek(getStreamPosition() + n)提高当前的流位置。
      long ImageInputStreamImpl.skipBytes​(long n)
      通过致电 seek(getStreamPosition() + n)当前流的位置。
      void | FileCacheImageOutputStream.write​(byte[] b, int off, int len)
      void | FileCacheImageOutputStream.write​(int b)
      void | FileImageOutputStream.write​(byte[] b, int off, int len)
      void | FileImageOutputStream.write​(int b)
      void ImageOutputStream.write​(byte[] b)
      在当前位置写入一串字节。
      void ImageOutputStream.write​(byte[] b, int off, int len)
      在当前位置写入一串字节。
      void ImageOutputStream.write​(int b)
      将当前位置的单个字节写入流。
      void | ImageOutputStreamImpl.write​(byte[] b)
      abstract void | ImageOutputStreamImpl.write​(byte[] b, int off, int len)
      abstract void | ImageOutputStreamImpl.write​(int b)
      void | MemoryCacheImageOutputStream.write​(byte[] b, int off, int len)
      void | MemoryCacheImageOutputStream.write​(int b)
      void ImageOutputStream.writeBit​(int bit)
      将由参数的最低有效位给出的单个位写入当前字节位置中当前位偏移量的流。
      void | ImageOutputStreamImpl.writeBit​(int bit)
      void ImageOutputStream.writeBits​(long bits, int numBits)
      将 numBits的 bits参数的最低有效位（ bits的顺序）给出的位序列写入当前字节位置当前位偏移量的流。
      void | ImageOutputStreamImpl.writeBits​(long bits, int numBits)
      void ImageOutputStream.writeBoolean​(boolean v)
      向流中写入一个 boolean值。
      void | ImageOutputStreamImpl.writeBoolean​(boolean v)
      void ImageOutputStream.writeByte​(int v)
      将 v的8位低位写入流。
      void | ImageOutputStreamImpl.writeByte​(int v)
      void ImageOutputStream.writeBytes​(String s)
      将一个字符串写入输出流。
      void | ImageOutputStreamImpl.writeBytes​(String s)
      void ImageOutputStream.writeChar​(int v)
      该方法是 writeShort的同义词。
      void | ImageOutputStreamImpl.writeChar​(int v)
      void ImageOutputStream.writeChars​(char[] c, int off, int len)
      在当前位置将一串字符写入流。
      void ImageOutputStream.writeChars​(String s)
      将一个字符串写入输出流。
      void | ImageOutputStreamImpl.writeChars​(char[] c, int off, int len)
      void | ImageOutputStreamImpl.writeChars​(String s)
      void ImageOutputStream.writeDouble​(double v)
      向输出流写入一个由四个字节组成的 double值。
      void | ImageOutputStreamImpl.writeDouble​(double v)
      void ImageOutputStream.writeDoubles​(double[] d, int off, int len)
      将当前位置的一系列双精度写入流。
      void | ImageOutputStreamImpl.writeDoubles​(double[] d, int off, int len)
      void ImageOutputStream.writeFloat​(float v)
      向输出流写入由四个字节组成的 float值。
      void | ImageOutputStreamImpl.writeFloat​(float v)
      void ImageOutputStream.writeFloats​(float[] f, int off, int len)
      在当前位置将一系列浮点写入流。
      void | ImageOutputStreamImpl.writeFloats​(float[] f, int off, int len)
      void ImageOutputStream.writeInt​(int v)
      将 v的32位写入流。
      void | ImageOutputStreamImpl.writeInt​(int v)
      void ImageOutputStream.writeInts​(int[] i, int off, int len)
      在当前位置写入流的序列。
      void | ImageOutputStreamImpl.writeInts​(int[] i, int off, int len)
      void ImageOutputStream.writeLong​(long v)
      将 v的64位写入流。
      void | ImageOutputStreamImpl.writeLong​(long v)
      void ImageOutputStream.writeLongs​(long[] l, int off, int len)
      在当前位置写入流的序列。
      void | ImageOutputStreamImpl.writeLongs​(long[] l, int off, int len)
      void ImageOutputStream.writeShort​(int v)
      将 v的16位低位写入流。
      void | ImageOutputStreamImpl.writeShort​(int v)
      void ImageOutputStream.writeShorts​(short[] s, int off, int len)
      在当前位置写入流的序列。
      void | ImageOutputStreamImpl.writeShorts​(short[] s, int off, int len)
      void ImageOutputStream.writeUTF​(String s)
      以网络字节顺序将两个字节的长度信息写入输出流，其后是字符串 s中每个字符的 modified UTF-8表示。
      void | ImageOutputStreamImpl.writeUTF​(String s)
      Constructors in javax.imageio.stream that throw IOException
      Constructor 描述
      FileCacheImageInputStream​(InputStream stream, File cacheDir)
      构造一个 FileCacheImageInputStream ，将从给定的 InputStream读取。
      FileCacheImageOutputStream​(OutputStream stream, File cacheDir)
      构造一个 FileCacheImageOutputStream ，它将写入给定的 outputStream 。
      FileImageInputStream​(File f)
      构造一个 FileImageInputStream ，它将从给定的 File读取。
      FileImageOutputStream​(File f)
      构造一个 FileImageOutputStream ，它将写入给定的 File 。

    • Uses of IOException in javax.jnlp

      Methods in javax.jnlp that throw IOException
      Modifier and Type 方法 描述
      boolean FileContents.canRead​()
      返回是否可以读取文件。
      boolean FileContents.canWrite​()
      返回是否可以写入文件。
      void JNLPRandomAccessFile.close​()
      关闭此随机访问文件流并释放与流相关联的任何系统资源。
      long PersistenceService.create​(URL url, long maxsize)
      在客户端创建一个以给定的URL命名的永久存储条目。
      void PersistenceService.delete​(URL url)
      从客户端日期持久性存储中删除与给定URL相关联的流。
      FileContents PersistenceService.get​(URL url)
      返回表示此文件内容的 FileContents对象。
      long JNLPRandomAccessFile.getFilePointer​()
      返回此文件中的当前偏移量。
      InputStream FileContents.getInputStream​()
      从文件获取 InputStream 。
      long FileContents.getLength​()
      获取文件的长度。
      long FileContents.getMaxLength​()
      获取文件的最大文件长度，由此对象的创建者设置。
      String FileContents.getName​()
      获取文件名为 String 。
      String[] PersistenceService.getNames​(URL url)
      返回一个字符串数组，其中包含给定URL的所有条目的名称。
      OutputStream FileContents.getOutputStream​(boolean overwrite)
      获取文件的 OutputStream 。
      JNLPRandomAccessFile FileContents.getRandomAccessFile​(String mode)
      返回一个 JNLPRandomAccessFile表示文件内容的随机访问接口。
      int PersistenceService.getTag​(URL url)
      返回对应于与给定URL相关联的持久性数据存储条目的标记的当前值的 int 。
      DownloadService2.ResourceSpec[] DownloadService2.getUpdateAvailableResources​(DownloadService2.ResourceSpec spec)
      返回缓存中与指定的资源规范之一匹配的所有资源，并具有从其服务器可用的更新。
      long JNLPRandomAccessFile.length​()
      返回此文件的长度。
      void DownloadService.loadExtensionPart​(URL ref, String version, String[] parts, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部件和扩展名，请下载给定扩展的给定部分。
      void DownloadService.loadExtensionPart​(URL ref, String version, String part, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了部分和扩展名，请下载给定扩展的给定部分。
      void DownloadService.loadPart​(String[] parts, DownloadServiceListener progress)
      如果在应用程序的JNLP文件中提到了这些部分，请下载给定的部分。
      void DownloadService.loadPart​(String part, DownloadServiceListener progress)
      下载给定的部分，如果该部分在应用程序的JNLP文件中被提到。
      void DownloadService.loadResource​(URL ref, String version, DownloadServiceListener progress)
      如果在调用的应用程序JNLP文件中提到资源，请下载给定的资源，是在调用应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
      FileContents ExtendedService.openFile​(File file)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
      FileContents FileOpenService.openFileDialog​(String pathHint, String[] extensions)
      要求用户选择一个文件。
      FileContents[] ExtendedService.openFiles​(File[] files)
      允许应用程序打开指定的文件，即使应用程序在不受信任的执行环境中运行。
      FileContents[] FileOpenService.openMultiFileDialog​(String pathHint, String[] extensions)
      要求用户选择一个或多个文件。
      int JNLPRandomAccessFile.read​()
      从该文件读取一个字节的数据。
      int JNLPRandomAccessFile.read​(byte[] b)
      从该文件读取最多 b.length字节的数据到字节数组。
      int JNLPRandomAccessFile.read​(byte[] b, int off, int len)
      从该文件读取最多 len个字节的数据到一个字节数组。
      boolean JNLPRandomAccessFile.readBoolean​()
      从此文件读取一个 boolean 。
      byte JNLPRandomAccessFile.readByte​()
      从此文件中读取一个带符号的八位值。
      char JNLPRandomAccessFile.readChar​()
      从此文件中读取Unicode字符。
      double JNLPRandomAccessFile.readDouble​()
      从此文件读取一个 double 。
      float JNLPRandomAccessFile.readFloat​()
      从此文件读取一个 float 。
      void JNLPRandomAccessFile.readFully​(byte[] b)
      从该文件读取 b.length个字节到字节数组，从当前文件指针开始。
      void JNLPRandomAccessFile.readFully​(byte[] b, int off, int len)
      从该文件读取完全 len字节的字节数组，从当前文件指针开始。
      int JNLPRandomAccessFile.readInt​()
      从该文件读取一个带符号的32位整数。
      String JNLPRandomAccessFile.readLine​()
      从此文件中读取下一行文本。
      long JNLPRandomAccessFile.readLong​()
      从该文件中读取一个带符号的64位整数。
      short JNLPRandomAccessFile.readShort​()
      从此文件中读取一个已签名的16位数字。
      int JNLPRandomAccessFile.readUnsignedByte​()
      从此文件中读取一个无符号的八位数字。
      int JNLPRandomAccessFile.readUnsignedShort​()
      从该文件中读取一个无符号的16位数字。
      String JNLPRandomAccessFile.readUTF​()
      从该文件读取字符串。
      void DownloadService.removeExtensionPart​(URL ref, String version, String part)
      如果在应用程序的JNLP文件中提到了部分和扩展名，则从缓存中删除给定扩展的给定部分。
      void DownloadService.removeExtensionPart​(URL ref, String version, String[] parts)
      如果在应用程序的JNLP文件中提到了部件和扩展名，则从缓存中删除给定扩展的给定部分。
      void DownloadService.removePart​(String part)
      如果在应用程序的JNLP文件中提到了该部分，则从缓存中删除给定的部分。
      void DownloadService.removePart​(String[] parts)
      如果在应用程序的JNLP文件中提到了这些部分，则从缓存中删除给定的部分。
      void DownloadService.removeResource​(URL ref, String version)
      如果在调用应用程序JNLP文件中提到资源，则从缓存中删除给定的资源，在调用的应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。
      FileContents FileSaveService.saveAsFileDialog​(String pathHint, String[] extensions, FileContents contents)
      要求用户保存文件。
      FileContents FileSaveService.saveFileDialog​(String pathHint, String[] extensions, InputStream stream, String name)
      要求用户保存文件。
      void JNLPRandomAccessFile.seek​(long pos)
      设置文件指针偏移，从该文件的开头测量，发生下一次读取或写入。
      void JNLPRandomAccessFile.setLength​(long newLength)
      设置此文件的长度。
      long FileContents.setMaxLength​(long maxlength)
      设置文件的最大文件长度。
      void PersistenceService.setTag​(URL url, int tag)
      使用给定的标签值标记与给定URL相关联的持久数据存储条目。
      int JNLPRandomAccessFile.skipBytes​(int n)
      尝试跳过 n字节的输入丢弃跳过的字节。
      void JNLPRandomAccessFile.write​(byte[] b)
      从指定的字节数组写入 b.length字节到该文件，从当前文件指针开始。
      void JNLPRandomAccessFile.write​(byte[] b, int off, int len)
      从指定的字节数组写入 len字节，从偏移量 off开始写入该文件。
      void JNLPRandomAccessFile.write​(int b)
      将指定的字节写入此文件。
      void JNLPRandomAccessFile.writeBoolean​(boolean v)
      将 boolean写入文件作为一个字节的值。
      void JNLPRandomAccessFile.writeByte​(int v)
      向文件写入一个 byte作为一个字节的值。
      void JNLPRandomAccessFile.writeBytes​(String s)
      将字符串作为字节序列写入文件。
      void JNLPRandomAccessFile.writeChar​(int v)
      将 char写入文件作为双字节值，高字节为先。
      void JNLPRandomAccessFile.writeChars​(String s)
      将一个字符串作为字符序列写入文件。
      void JNLPRandomAccessFile.writeDouble​(double v)
      使用 long中的 doubleToLongBits方法将双参数转换为 Double ，然后 long值作为八字节数量，高字节优先写入文件。
      void JNLPRandomAccessFile.writeFloat​(float v)
      使用 int中的 floatToIntBits方法将float参数转换为 Float ，然后 int值作为四字节数量，高字节先写入该文件。
      void JNLPRandomAccessFile.writeInt​(int v)
      将 int写入文件为四个字节，高字节为首。
      void JNLPRandomAccessFile.writeLong​(long v)
      向文件写入一个 long作为八字节，高字节优先。
      void JNLPRandomAccessFile.writeShort​(int v)
      将 short写入文件作为两个字节，高字节优先。
      void JNLPRandomAccessFile.writeUTF​(String str)
      使用UTF-8编码以机器无关方式将字符串写入文件。

    • Uses of IOException in javax.management

      Methods in javax.management that throw IOException
      Modifier and Type 方法 描述
      void MBeanServerConnection.addNotificationListener​(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      将一个监听器添加到注册的MBean。
      void MBeanServerConnection.addNotificationListener​(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      将一个监听器添加到注册的MBean。
      ObjectInstance MBeanServerConnection.createMBean​(String className, ObjectName name)
      在MBean服务器中实例化并注册一个MBean。
      ObjectInstance MBeanServerConnection.createMBean​(String className, ObjectName name, Object[] params, String[] signature)
      在MBean服务器中实例化并注册一个MBean。
      ObjectInstance MBeanServerConnection.createMBean​(String className, ObjectName name, ObjectName loaderName)
      在MBean服务器中实例化并注册一个MBean。
      ObjectInstance MBeanServerConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
      在MBean服务器中实例化并注册一个MBean。
      Object MBeanServerConnection.getAttribute​(ObjectName name, String attribute)
      获取命名MBean的特定属性的值。
      AttributeList MBeanServerConnection.getAttributes​(ObjectName name, String[] attributes)
      检索命名MBean的几个属性的值。
      String MBeanServerConnection.getDefaultDomain​()
      返回用于命名MBean的默认域。
      String[] MBeanServerConnection.getDomains​()
      返回任何MBean当前注册的域列表。
      Integer MBeanServerConnection.getMBeanCount​()
      返回在MBean服务器中注册的MBeans数。
      MBeanInfo MBeanServerConnection.getMBeanInfo​(ObjectName name)
      此方法可以发现MBean公开管理的属性和操作。
      ObjectInstance MBeanServerConnection.getObjectInstance​(ObjectName name)
      获取为MBean服务器注册的给定MBean的 ObjectInstance 。
      Object MBeanServerConnection.invoke​(ObjectName name, String operationName, Object[] params, String[] signature)
      调用MBean上的操作。
      boolean MBeanServerConnection.isInstanceOf​(ObjectName name, String className)
      如果指定的MBean是指定类的实例，则返回true，否则返回false。
      boolean MBeanServerConnection.isRegistered​(ObjectName name)
      检查由其对象名称标识的MBean是否已经向MBean服务器注册。
      Set<ObjectInstance> MBeanServerConnection.queryMBeans​(ObjectName name, QueryExp query)
      获取由MBean服务器控制的MBean。
      Set<ObjectName> MBeanServerConnection.queryNames​(ObjectName name, QueryExp query)
      获取由MBean服务器控制的MBean的名称。
      void MBeanServerConnection.removeNotificationListener​(ObjectName name, NotificationListener listener)
      从注册的MBean中删除一个监听器。
      void MBeanServerConnection.removeNotificationListener​(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      从注册的MBean中删除一个监听器。
      void MBeanServerConnection.removeNotificationListener​(ObjectName name, ObjectName listener)
      从注册的MBean中删除一个监听器。
      void MBeanServerConnection.removeNotificationListener​(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      从注册的MBean中删除一个监听器。
      void MBeanServerConnection.setAttribute​(ObjectName name, Attribute attribute)
      设置命名MBean的特定属性的值。
      AttributeList MBeanServerConnection.setAttributes​(ObjectName name, AttributeList attributes)
      设置一个命名MBean的几个属性的值。
      void MBeanServerConnection.unregisterMBean​(ObjectName name)
      从MBean服务器取消注册MBean。

    • Uses of IOException in javax.management.loading

      Methods in javax.management.loading that throw IOException
      Modifier and Type 方法 描述
      Enumeration<URL> MLetMBean.getResources​(String name)
      查找具有给定名称的所有资源。
      void MLet.readExternal​(ObjectInput in)
      从给定的ObjectInput恢复这个MLet的内容。
      void MLet.writeExternal​(ObjectOutput out)
      将此MLet的内容保存到给定的ObjectOutput 。

    • Uses of IOException in javax.management.remote

      Subclasses of IOException in javax.management.remote
      Modifier and Type Class 描述
      class  JMXProviderException
      JMXConnectorFactory和JMXConnectorServerFactory当提供者存在所需协议但由于某种原因不能使用时出现异常。
      class  JMXServerErrorException
      在处理远程MBean服务器中的调用时抛出Error时，抛出异常作为远程MBeanServer方法调用的结果。
      Methods in javax.management.remote that throw IOException
      Modifier and Type 方法 描述
      void JMXConnector.close​()
      关闭与其服务器的客户端连接。
      void JMXConnector.connect​()
      建立与连接器服务器的连接。
      void JMXConnector.connect​(Map<String,?> env)
      建立与连接器服务器的连接。
      static JMXConnector JMXConnectorFactory.connect​(JMXServiceURL serviceURL)
      创建与给定地址的连接器服务器的连接。
      static JMXConnector JMXConnectorFactory.connect​(JMXServiceURL serviceURL, Map<String,?> environment)
      创建与给定地址的连接器服务器的连接。
      String JMXConnector.getConnectionId​()
      从连接器服务器获取此连接的ID。
      MBeanServerConnection JMXConnector.getMBeanServerConnection​()
      返回表示远程MBean服务器的 MBeanServerConnection对象。
      MBeanServerConnection JMXConnector.getMBeanServerConnection​(Subject delegationSubject)
      返回一个表示远程MBean服务器的 MBeanServerConnection对象，代表所提供的委托主体执行操作。
      static JMXConnector JMXConnectorFactory.newJMXConnector​(JMXServiceURL serviceURL, Map<String,?> environment)
      在给定的地址创建连接器服务器的连接器客户端。
      JMXConnector JMXConnectorProvider.newJMXConnector​(JMXServiceURL serviceURL, Map<String,?> environment)
      创建一个新的连接器客户端，可以在给定的地址连接到连接器服务器。
      static JMXConnectorServer JMXConnectorServerFactory.newJMXConnectorServer​(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      在给定的地址创建一个连接器服务器。
      JMXConnectorServer JMXConnectorServerProvider.newJMXConnectorServer​(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      在给定的地址创建一个新的连接器服务器。
      void JMXConnectorServerMBean.start​()
      激活连接器服务器，即开始侦听客户端连接。
      void JMXConnectorServerMBean.stop​()
      停用连接器服务器，即停止侦听客户端连接。
      JMXConnector JMXConnectorServer.toJMXConnector​(Map<String,?> env)
      返回此连接器服务器的客户端存根。
      JMXConnector JMXConnectorServerMBean.toJMXConnector​(Map<String,?> env)
      返回此连接器服务器的客户端存根。

    • Uses of IOException in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that throw IOException
      Modifier and Type | 方法 | 描述
      void RMIConnection.addNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      处理方法 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 。
      void | RMIConnectionImpl_Stub.addNotificationListener​(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl.addNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Integer[] RMIConnection.addNotificationListeners​(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      处理方法 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 。
      Integer[] | RMIConnectionImpl_Stub.addNotificationListeners​(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
      Integer[] | RMIConnectionImpl.addNotificationListeners​(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      protected void RMIServerImpl.clientClosed​(RMIConnection client)
      makeClient创建的客户端连接关闭时调用的方法。
      void RMIConnection.close​()
      关闭此连接。
      void | RMIConnectionImpl_Stub.close​()
      void | RMIConnectionImpl.close​()
      void | RMIConnector.close​()
      void RMIServerImpl.close​()
      关闭此连接服务器。
      protected void RMIIIOPServerImpl.closeClient​(RMIConnection client)
      已过时。
      protected void | RMIJRMPServerImpl.closeClient​(RMIConnection client)
      protected abstract void RMIServerImpl.closeClient​(RMIConnection client)
      关闭 makeClient建立的客户端连接。
      protected void RMIIIOPServerImpl.closeServer​()
      已过时。
      protected void RMIJRMPServerImpl.closeServer​()
      由 RMIServerImpl.close()调用，通过 取消导出该对象来关闭连接器服务器。
      protected abstract void RMIServerImpl.closeServer​()
      调用 RMIServerImpl.close()关闭连接器服务器。
      void | RMIConnector.connect​()
      void | RMIConnector.connect​(Map<String,?> environment)
      ObjectInstance RMIConnection.createMBean​(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      处理方法 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 。
      ObjectInstance RMIConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      处理方法 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 。
      ObjectInstance RMIConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      处理方法 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 。
      ObjectInstance RMIConnection.createMBean​(String className, ObjectName name, Subject delegationSubject)
      处理方法 MBeanServerConnection.createMBean(String, ObjectName) 。
      ObjectInstance | RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      ObjectInstance | RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
      ObjectInstance | RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
      ObjectInstance | RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, Subject delegationSubject)
      protected void RMIIIOPServerImpl.export​()
      已过时。
      protected void | RMIJRMPServerImpl.export​()
      protected abstract void RMIServerImpl.export​()
      导出此RMI对象。
      NotificationResult RMIConnection.fetchNotifications​(long clientSequenceNumber, int maxNotifications, long timeout)
      从连接器服务器检索通知。
      NotificationResult | RMIConnectionImpl_Stub.fetchNotifications​(long $param_long_1, int $param_int_2, long $param_long_3)
      NotificationResult | RMIConnectionImpl.fetchNotifications​(long clientSequenceNumber, int maxNotifications, long timeout)
      Object RMIConnection.getAttribute​(ObjectName name, String attribute, Subject delegationSubject)
      处理方法 MBeanServerConnection.getAttribute(ObjectName, String) 。
      Object | RMIConnectionImpl_Stub.getAttribute​(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      Object | RMIConnectionImpl.getAttribute​(ObjectName name, String attribute, Subject delegationSubject)
      AttributeList RMIConnection.getAttributes​(ObjectName name, String[] attributes, Subject delegationSubject)
      处理方法 MBeanServerConnection.getAttributes(ObjectName, String[]) 。
      AttributeList | RMIConnectionImpl_Stub.getAttributes​(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.getAttributes​(ObjectName name, String[] attributes, Subject delegationSubject)
      String RMIConnection.getConnectionId​()
      返回连接ID。
      String | RMIConnectionImpl_Stub.getConnectionId​()
      String | RMIConnectionImpl.getConnectionId​()
      String | RMIConnector.getConnectionId​()
      String RMIConnection.getDefaultDomain​(Subject delegationSubject)
      处理方法 MBeanServerConnection.getDefaultDomain() 。
      String | RMIConnectionImpl_Stub.getDefaultDomain​(Subject $param_Subject_1)
      String | RMIConnectionImpl.getDefaultDomain​(Subject delegationSubject)
      String[] RMIConnection.getDomains​(Subject delegationSubject)
      处理方法 MBeanServerConnection.getDomains() 。
      String[] | RMIConnectionImpl_Stub.getDomains​(Subject $param_Subject_1)
      String[] | RMIConnectionImpl.getDomains​(Subject delegationSubject)
      Integer RMIConnection.getMBeanCount​(Subject delegationSubject)
      处理方法 MBeanServerConnection.getMBeanCount() 。
      Integer | RMIConnectionImpl_Stub.getMBeanCount​(Subject $param_Subject_1)
      Integer | RMIConnectionImpl.getMBeanCount​(Subject delegationSubject)
      MBeanInfo RMIConnection.getMBeanInfo​(ObjectName name, Subject delegationSubject)
      处理方法 MBeanServerConnection.getMBeanInfo(ObjectName) 。
      MBeanInfo | RMIConnectionImpl_Stub.getMBeanInfo​(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      MBeanInfo | RMIConnectionImpl.getMBeanInfo​(ObjectName name, Subject delegationSubject)
      MBeanServerConnection | RMIConnector.getMBeanServerConnection​()
      MBeanServerConnection | RMIConnector.getMBeanServerConnection​(Subject delegationSubject)
      ObjectInstance RMIConnection.getObjectInstance​(ObjectName name, Subject delegationSubject)
      处理方法 MBeanServerConnection.getObjectInstance(ObjectName) 。
      ObjectInstance | RMIConnectionImpl_Stub.getObjectInstance​(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      ObjectInstance | RMIConnectionImpl.getObjectInstance​(ObjectName name, Subject delegationSubject)
      Object RMIConnection.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      处理方法 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 。
      Object | RMIConnectionImpl_Stub.invoke​(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      Object | RMIConnectionImpl.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      boolean RMIConnection.isInstanceOf​(ObjectName name, String className, Subject delegationSubject)
      处理方法 MBeanServerConnection.isInstanceOf(ObjectName, String) 。
      boolean | RMIConnectionImpl_Stub.isInstanceOf​(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      boolean | RMIConnectionImpl.isInstanceOf​(ObjectName name, String className, Subject delegationSubject)
      boolean RMIConnection.isRegistered​(ObjectName name, Subject delegationSubject)
      处理方法 MBeanServerConnection.isRegistered(ObjectName) 。
      boolean | RMIConnectionImpl_Stub.isRegistered​(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      boolean | RMIConnectionImpl.isRegistered​(ObjectName name, Subject delegationSubject)
      protected RMIConnection RMIIIOPServerImpl.makeClient​(String connectionId, Subject subject)
      已过时。
      protected RMIConnection RMIJRMPServerImpl.makeClient​(String connectionId, Subject subject)
      创建一个新的客户端连接作为通过JRMP导出的RMI对象。
      protected abstract RMIConnection RMIServerImpl.makeClient​(String connectionId, Subject subject)
      创建一个新的客户端连接。
      RMIConnection RMIServer.newClient​(Object credentials)
      通过此RMI连接器进行新的连接。
      RMIConnection | RMIServerImpl_Stub.newClient​(Object $param_Object_1)
      RMIConnection RMIServerImpl.newClient​(Object credentials)
      创建一个新的客户端连接。
      Set<ObjectInstance> RMIConnection.queryMBeans​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      处理方法 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 。
      Set | RMIConnectionImpl_Stub.queryMBeans​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectInstance> | RMIConnectionImpl.queryMBeans​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectName> RMIConnection.queryNames​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      处理方法 MBeanServerConnection.queryNames(ObjectName, QueryExp) 。
      Set | RMIConnectionImpl_Stub.queryNames​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectName> | RMIConnectionImpl.queryNames​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      void RMIConnection.removeNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      处理方法 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 。
      void RMIConnection.removeNotificationListener​(ObjectName name, ObjectName listener, Subject delegationSubject)
      处理方法 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 。
      void | RMIConnectionImpl_Stub.removeNotificationListener​(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl_Stub.removeNotificationListener​(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.removeNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      void | RMIConnectionImpl.removeNotificationListener​(ObjectName name, ObjectName listener, Subject delegationSubject)
      void RMIConnection.removeNotificationListeners​(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      处理 removeNotificationListener(ObjectName, NotificationListener)和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)方法。
      void | RMIConnectionImpl_Stub.removeNotificationListeners​(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.removeNotificationListeners​(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      void RMIConnection.setAttribute​(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      处理方法 MBeanServerConnection.setAttribute(ObjectName, Attribute) 。
      void | RMIConnectionImpl_Stub.setAttribute​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.setAttribute​(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      AttributeList RMIConnection.setAttributes​(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      处理方法 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 。
      AttributeList | RMIConnectionImpl_Stub.setAttributes​(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.setAttributes​(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      void RMIConnectorServer.start​()
      激活连接器服务器，即开始侦听客户端连接。
      void RMIConnectorServer.stop​()
      停用连接器服务器，即停止侦听客户端连接。
      JMXConnector RMIConnectorServer.toJMXConnector​(Map<String,?> env)
      返回此连接器服务器的客户端存根。
      Remote RMIIIOPServerImpl.toStub​()
      已过时。
      Remote RMIJRMPServerImpl.toStub​()
      返回此RMIServer对象的可序列存根。
      abstract Remote RMIServerImpl.toStub​()
      返回此服务器对象的远程存根。
      void RMIConnection.unregisterMBean​(ObjectName name, Subject delegationSubject)
      处理方法 MBeanServerConnection.unregisterMBean(ObjectName) 。
      void | RMIConnectionImpl_Stub.unregisterMBean​(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      void | RMIConnectionImpl.unregisterMBean​(ObjectName name, Subject delegationSubject)
      Constructors in javax.management.remote.rmi that throw IOException
      Constructor 描述
      RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment)
      做一个 RMIConnectorServer 。
      RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
      为给定的MBean服务器创建一个 RMIConnectorServer 。
      RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
      为给定的MBean服务器创建一个 RMIConnectorServer 。
      RMIIIOPServerImpl​(Map<String,?> env)
      已过时。
      抛出UnsupportedOperationException
      RMIJRMPServerImpl​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
      创建一个新的RMIServer对象，该对象将使用给定的套接字工厂在给定端口上导出。

    • Uses of IOException in javax.naming.ldap

      Methods in javax.naming.ldap that throw IOException
      Modifier and Type 方法 描述
      abstract void StartTlsResponse.close​()
      妥善地关闭TLS连接并恢复到底层连接。
      abstract SSLSession StartTlsResponse.negotiate​()
      使用默认的SSL套接字工厂协商TLS会话。
      abstract SSLSession StartTlsResponse.negotiate​(SSLSocketFactory factory)
      使用SSL套接字工厂协商TLS会话。
      Constructors in javax.naming.ldap that throw IOException
      Constructor 描述
      PagedResultsControl​(int pageSize, boolean criticality)
      构造一个控件以设置每页结果返回的条目数。
      PagedResultsControl​(int pageSize, byte[] cookie, boolean criticality)
      构造一个控件以设置每页结果返回的条目数。
      PagedResultsResponseControl​(String id, boolean criticality, byte[] value)
      构建分页结果响应控件。
      SortControl​(String[] sortBy, boolean criticality)
      构造一个控件以按升序对属性列表进行排序。
      SortControl​(String sortBy, boolean criticality)
      构造一个控件以按升序对单个属性进行排序。
      SortControl​(SortKey[] sortBy, boolean criticality)
      构造一个控件以对排序键列表进行排序。
      SortResponseControl​(String id, boolean criticality, byte[] value)
      构造一个控件来指示排序请求的结果。

    • Uses of IOException in javax.net

      Methods in javax.net that throw IOException
      Modifier and Type 方法 描述
      ServerSocket ServerSocketFactory.createServerSocket​()
      返回未绑定的服务器套接字。
      abstract ServerSocket ServerSocketFactory.createServerSocket​(int port)
      返回绑定到指定端口的服务器套接字。
      abstract ServerSocket ServerSocketFactory.createServerSocket​(int port, int backlog)
      返回绑定到指定端口的服务器套接字，并使用指定的连接积压。
      abstract ServerSocket ServerSocketFactory.createServerSocket​(int port, int backlog, InetAddress ifAddress)
      返回绑定到指定端口的服务器套接字，具有指定的listen backlog和本地IP。
      Socket SocketFactory.createSocket​()
      创建一个未连接的套接字。
      abstract Socket SocketFactory.createSocket​(String host, int port)
      创建套接字并将其连接到指定的远程端口上的指定远程主机。
      abstract Socket SocketFactory.createSocket​(String host, int port, InetAddress localHost, int localPort)
      创建套接字并将其连接到指定远程端口上的指定远程主机。
      abstract Socket SocketFactory.createSocket​(InetAddress host, int port)
      创建套接字并将其连接到指定地址处的指定端口号。
      abstract Socket SocketFactory.createSocket​(InetAddress address, int port, InetAddress localAddress, int localPort)
      创建套接字并将其连接到指定远程端口上指定的远程地址。

    • Uses of IOException in javax.net.ssl

      Subclasses of IOException in javax.net.ssl
      Modifier and Type Class 描述
      class  SSLException
      表示由SSL子系统检测到的某种错误。
      class  SSLHandshakeException
      表示客户端和服务器无法协商所需的安全级别。
      class  SSLKeyException
      报告错误的SSL密钥。
      class  SSLPeerUnverifiedException
      表示对等体的身份尚未验证。
      class  SSLProtocolException
      报告SSL协议操作中的错误。
      Methods in javax.net.ssl that throw IOException
      Modifier and Type 方法 描述
      Socket SSLSocketFactory.createSocket​(Socket s, InputStream consumed, boolean autoClose)
      创建服务器模式Socket分层在现有连接的套接字上，并且能够读取已从Socket的底层InputStream中消耗/删除的数据 。
      abstract Socket SSLSocketFactory.createSocket​(Socket s, String host, int port, boolean autoClose)
      返回在给定端口上分层连接到指定主机的现有套接字上的套接字。
      abstract void SSLSocket.startHandshake​()
      在此连接上启动SSL握手。
      Constructors in javax.net.ssl that throw IOException
      Constructor 描述
      SSLServerSocket​()
      仅由子类使用。
      SSLServerSocket​(int port)
      仅由子类使用。
      SSLServerSocket​(int port, int backlog)
      仅由子类使用。
      SSLServerSocket​(int port, int backlog, InetAddress address)
      仅由子类使用。
      SSLSocket​(String host, int port)
      仅由子类使用。
      SSLSocket​(String host, int port, InetAddress clientAddress, int clientPort)
      仅由子类使用。
      SSLSocket​(InetAddress address, int port)
      仅由子类使用。
      SSLSocket​(InetAddress address, int port, InetAddress clientAddress, int clientPort)
      仅由子类使用。

    • Uses of IOException in javax.print

      Methods in javax.print that throw IOException
      Modifier and Type | 方法 | 描述
      Doc MultiDoc.getDoc​()
      获取当前的doc对象。
      Object Doc.getPrintData​()
      以与支持的文档风格相对应的格式获取包含此文档对象的打印数据的打印数据表示对象。
      Object | SimpleDoc.getPrintData​()
      Reader Doc.getReaderForText​()
      获取从该文档中提取字符打印数据的读取器。
      Reader SimpleDoc.getReaderForText​()
      获取从该文档中提取字符打印数据的读取器。
      InputStream Doc.getStreamForBytes​()
      获取从该文档中提取字节打印数据的输入流。
      InputStream SimpleDoc.getStreamForBytes​()
      获取从该文档中提取字节打印数据的输入流。
      MultiDoc MultiDoc.next​()
      转到包含doc对象序列中的下一个doc对象的多对象对象。

    • Uses of IOException in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that throw IOException
      Modifier and Type 方法 描述
      void StubDelegate.readObject​(Stub self, ObjectInputStream s)
      代表团要求 Stub.readObject(java.io.ObjectInputStream) 。
      void StubDelegate.writeObject​(Stub self, ObjectOutputStream s)
      代表团要求 Stub.writeObject(java.io.ObjectOutputStream) 。

    • Uses of IOException in javax.rmi.ssl

      Methods in javax.rmi.ssl that throw IOException
      Modifier and Type 方法 描述
      ServerSocket SslRMIServerSocketFactory.createServerSocket​(int port)
      创建一个服务器套接字，接受根据本工厂的SSL套接字配置参数配置的SSL连接。
      Socket SslRMIClientSocketFactory.createSocket​(String host, int port)
      创建一个SSL套接字。

    • Uses of IOException in javax.security.auth.callback

      Methods in javax.security.auth.callback that throw IOException
      Modifier and Type 方法 描述
      void CallbackHandler.handle​(Callback[] callbacks)
      检索或显示提供的回调中请求的信息。

    • Uses of IOException in javax.security.sasl

      Subclasses of IOException in javax.security.sasl
      Modifier and Type Class 描述
      class  AuthenticationException
      由SASL机制实现引发此异常，以指示SASL交换机由于与认证有关的原因（例如无效的身份，密码或密钥）而失败。
      class  SaslException
      此类表示使用SASL时发生的错误。

    • Uses of IOException in javax.sound.midi

      Methods in javax.sound.midi that throw IOException
      Modifier and Type 方法 描述
      static MidiFileFormat MidiSystem.getMidiFileFormat​(File file)
      获取指定的 File的MIDI文件格式。
      static MidiFileFormat MidiSystem.getMidiFileFormat​(InputStream stream)
      获取指定输入流中数据的MIDI文件格式。
      static MidiFileFormat MidiSystem.getMidiFileFormat​(URL url)
      获取指定URL中数据的MIDI文件格式。
      static Sequence MidiSystem.getSequence​(File file)
      从指定的 File获取MIDI序列。
      static Sequence MidiSystem.getSequence​(InputStream stream)
      从指定的输入流中获取MIDI序列。
      static Sequence MidiSystem.getSequence​(URL url)
      从指定的URL获取MIDI序列。
      static Soundbank MidiSystem.getSoundbank​(File file)
      构造一个 Soundbank通过从指定的阅读它 File 。
      static Soundbank MidiSystem.getSoundbank​(InputStream stream)
      通过从指定的流中读取来构建MIDI声音库。
      static Soundbank MidiSystem.getSoundbank​(URL url)
      通过从指定的URL读取它构建一个 Soundbank 。
      void Sequencer.setSequence​(InputStream stream)
      设置序列发生器工作的当前序列。
      static int MidiSystem.write​(Sequence in, int type, File out)
      写入表示所提供外部文件的MIDI文件类型的文件的字节流。
      static int MidiSystem.write​(Sequence in, int fileType, OutputStream out)
      写入表示所提供的输出流的MIDI文件类型的文件的字节流。

    • Uses of IOException in javax.sound.midi.spi

      Methods in javax.sound.midi.spi that throw IOException
      Modifier and Type 方法 描述
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat​(File file)
      获得提供的 File的MIDI文件格式。
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat​(InputStream stream)
      获取所提供的输入流的MIDI文件格式。
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat​(URL url)
      获取提供的URL的MIDI文件格式。
      abstract Sequence MidiFileReader.getSequence​(File file)
      从提供的 File获取MIDI序列。
      abstract Sequence MidiFileReader.getSequence​(InputStream stream)
      从提供的输入流中获取MIDI序列。
      abstract Sequence MidiFileReader.getSequence​(URL url)
      从提供的URL获取MIDI序列。
      abstract Soundbank SoundbankReader.getSoundbank​(File file)
      从提供的 File获取一个 File库对象。
      abstract Soundbank SoundbankReader.getSoundbank​(InputStream stream)
      从提供的 InputStream获取一个 InputStream库对象。
      abstract Soundbank SoundbankReader.getSoundbank​(URL url)
      从提供的URL获取声音库对象。
      abstract int MidiFileWriter.write​(Sequence in, int fileType, File out)
      写入表示所提供外部文件的文件类型的MIDI文件的字节流。
      abstract int MidiFileWriter.write​(Sequence in, int fileType, OutputStream out)
      写入表示所提供的输出流的文件类型的MIDI文件的字节流。

    • Uses of IOException in javax.sound.sampled

      Methods in javax.sound.sampled that throw IOException
      Modifier and Type 方法 描述
      int AudioInputStream.available​()
      返回从该音频输入流中可以读取（或跳过）的最大字节数，而不会阻塞。
      void AudioInputStream.close​()
      关闭此音频输入流并释放与流相关联的任何系统资源。
      static AudioFileFormat AudioSystem.getAudioFileFormat​(File file)
      获取指定的 File的音频文件格式。
      static AudioFileFormat AudioSystem.getAudioFileFormat​(InputStream stream)
      获取提供的输入流的音频文件格式。
      static AudioFileFormat AudioSystem.getAudioFileFormat​(URL url)
      获取指定URL的音频文件格式。
      static AudioInputStream AudioSystem.getAudioInputStream​(File file)
      从提供的 File获取音频输入流。
      static AudioInputStream AudioSystem.getAudioInputStream​(InputStream stream)
      从提供的输入流中获取音频输入流。
      static AudioInputStream AudioSystem.getAudioInputStream​(URL url)
      从提供的URL获取音频输入流。
      void Clip.open​(AudioInputStream stream)
      以提供的音频输入流中存在的格式和音频数据打开剪辑。
      int AudioInputStream.read​()
      从音频输入流读取数据的下一个字节。
      int AudioInputStream.read​(byte[] b)
      从音频输入流读取一些字节数，并将它们存储到缓冲器阵列 b 。
      int AudioInputStream.read​(byte[] b, int off, int len)
      从音频流读取指定的最大数据字节数，将它们放入给定的字节数组。
      void AudioInputStream.reset​()
      将此音频输入流重新定位到上次调用其 mark方法时的位置。
      long AudioInputStream.skip​(long n)
      跳过并丢弃该音频输入流中指定数量的字节。
      static int AudioSystem.write​(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      将指定文件类型的音频文件的字节流写入提供的外部文件。
      static int AudioSystem.write​(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      将指定文件类型的音频文件的字节流写入提供的输出流。

    • Uses of IOException in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that throw IOException
      Modifier and Type 方法 描述
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat​(File file)
      获得提供的 File的音频文件格式。
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat​(InputStream stream)
      获取提供的输入流的音频文件格式。
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat​(URL url)
      获取提供的URL的音频文件格式。
      abstract AudioInputStream AudioFileReader.getAudioInputStream​(File file)
      从提供的 File获取音频输入流。
      abstract AudioInputStream AudioFileReader.getAudioInputStream​(InputStream stream)
      从提供的输入流中获取音频输入流。
      abstract AudioInputStream AudioFileReader.getAudioInputStream​(URL url)
      从提供的URL获取音频输入流。
      abstract int AudioFileWriter.write​(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      将表示所提供的外部文件的文件格式的音频文件的字节流写入。
      abstract int AudioFileWriter.write​(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      写入表示所提供的输出流的文件类型的音频文件的字节流。

    • Uses of IOException in javax.sql.rowset

      Methods in javax.sql.rowset that throw IOException
      Modifier and Type 方法 描述
      void WebRowSet.readXml​(InputStream iStream)
      读取基于流的XML输入来填充此 WebRowSet对象。
      void WebRowSet.writeXml​(OutputStream oStream)
      将此 WebRowSet对象的数据，属性和元数据以XML格式写入给定的 OutputStream对象。
      void WebRowSet.writeXml​(ResultSet rs, OutputStream oStream)
      使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 OutputStream对象。

    • Uses of IOException in javax.swing

      Methods in javax.swing that throw IOException
      Modifier and Type 方法 描述
      void ProgressMonitorInputStream.close​()
      覆盖 FilterInputStream.close以关闭进度监视器以及流。
      protected InputStream JEditorPane.getStream​(URL page)
      获取给定URL的流，即将由 setPage方法加载。
      void JEditorPane.read​(InputStream in, Object desc)
      此方法从流初始化。
      int ProgressMonitorInputStream.read​()
      覆盖 FilterInputStream.read以便在读取后更新进度监视器。
      int ProgressMonitorInputStream.read​(byte[] b)
      覆盖 FilterInputStream.read以便在读取后更新进度监视器。
      int ProgressMonitorInputStream.read​(byte[] b, int off, int len)
      覆盖 FilterInputStream.read以便在读取后更新进度监视器。
      void ProgressMonitorInputStream.reset​()
      覆盖 FilterInputStream.reset以重置进度监视器以及流。
      void JEditorPane.setPage​(String url)
      设置显示的当前URL。
      void JEditorPane.setPage​(URL page)
      设置显示的当前URL。
      long ProgressMonitorInputStream.skip​(long n)
      覆盖 FilterInputStream.skip以便在跳过后更新进度监视器。
      Constructors in javax.swing that throw IOException
      Constructor 描述
      JEditorPane​(String url)
      基于包含URL规范的字符串创建一个 JEditorPane 。
      JEditorPane​(URL initialPage)
      根据指定的URL创建 JEditorPane以进行输入。

    • Uses of IOException in javax.swing.filechooser

      Methods in javax.swing.filechooser that throw IOException
      Modifier and Type 方法 描述
      abstract File FileSystemView.createNewFolder​(File containingDir)
      创建一个具有默认文件夹名称的新文件夹。

    • Uses of IOException in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that throw IOException
      Modifier and Type 方法 描述
      void SynthLookAndFeel.load​(URL url)
      加载 SynthStyle将使用的一组 SynthLookAndFeel 。

    • Uses of IOException in javax.swing.text

      Subclasses of IOException in javax.swing.text
      Modifier and Type Class 描述
      class  ChangedCharSetException
      ChangedCharSetException作为名称指示是在更改字符集时抛出的异常。
      Methods in javax.swing.text that throw IOException
      Modifier and Type 方法 描述
      protected void AbstractWriter.indent​()
      缩进
      protected void AbstractWriter.output​(char[] content, int start, int length)
      写出内容的最后一站。
      void DefaultEditorKit.read​(InputStream in, Document doc, int pos)
      插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
      void DefaultEditorKit.read​(Reader in, Document doc, int pos)
      插入来自给定流的内容，将被视为纯文本。
      abstract void EditorKit.read​(InputStream in, Document doc, int pos)
      插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
      abstract void EditorKit.read​(Reader in, Document doc, int pos)
      插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
      void JTextComponent.read​(Reader in, Object desc)
      从流初始化。
      void StyleContext.readAttributes​(ObjectInputStream in, MutableAttributeSet a)
      属性中阅读的上下文特定处理
      static void StyleContext.readAttributeSet​(ObjectInputStream in, MutableAttributeSet a)
      从以前用 writeAttributeSet写出的给定对象输入流中读取一组属性。
      protected void AbstractWriter.text​(Element elem)
      写出文字。
      protected abstract void AbstractWriter.write​()
      这个抽象方法需要由子类实现。
      protected void AbstractWriter.write​(char ch)
      写出一个字符
      protected void AbstractWriter.write​(char[] chars, int startIndex, int length)
      所有写入方法都调用到这一个中。
      protected void AbstractWriter.write​(String content)
      写出一个字符串。
      void DefaultEditorKit.write​(OutputStream out, Document doc, int pos, int len)
      以适合此类内容处理程序的格式将内容从文档写入给定流。
      void DefaultEditorKit.write​(Writer out, Document doc, int pos, int len)
      将内容从文档写入给定的流作为纯文本。
      abstract void EditorKit.write​(OutputStream out, Document doc, int pos, int len)
      以适合此类内容处理程序的格式将内容从文档写入给定流。
      abstract void EditorKit.write​(Writer out, Document doc, int pos, int len)
      以适合此类内容处理程序的格式将内容从文档写入给定流。
      void JTextComponent.write​(Writer out)
      将模型的内容存储到给定的流中。
      protected void AbstractWriter.writeAttributes​(AttributeSet attr)
      将属性集写入“<name> = <value>”对。
      void StyleContext.writeAttributes​(ObjectOutputStream out, AttributeSet a)
      编写属性的上下文特定处理
      static void StyleContext.writeAttributeSet​(ObjectOutputStream out, AttributeSet a)
      将一组属性写入给定的对象流以进行序列化。
      protected void AbstractWriter.writeLineSeparator​()
      写行分隔符。

    • Uses of IOException in javax.swing.text.html

      Methods in javax.swing.text.html that throw IOException
      Modifier and Type 方法 描述
      protected void HTMLWriter.closeOutUnwantedEmbeddedTags​(AttributeSet attr)
      搜索属性集和存储在标签向量中的每个标签。
      protected void HTMLWriter.comment​(Element elem)
      写出评论。
      protected void HTMLWriter.emptyTag​(Element elem)
      写出所有空的元素（所有没有相应的结束标签的标签）。
      protected void MinimalHTMLWriter.endFontTag​()
      这不再使用，而是会写出<span>。
      protected void HTMLWriter.endTag​(Element elem)
      写出元素的结束标签。
      void HTMLDocument.insertAfterEnd​(Element elem, String htmlText)
      在给定元素结束后插入指定为字符串的HTML。
      void HTMLDocument.insertAfterStart​(Element elem, String htmlText)
      在元素的开始处插入指定为字符串的HTML。
      void HTMLDocument.insertBeforeEnd​(Element elem, String htmlText)
      在元素的末尾插入指定为字符串的HTML。
      void HTMLDocument.insertBeforeStart​(Element elem, String htmlText)
      在给定元素开始之前插入指定为字符串的HTML。
      void HTMLEditorKit.insertHTML​(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
      将HTML插入到现有文档中。
      void StyleSheet.loadRules​(Reader in, URL ref)
      加载一组以CSS1语法指定的规则。
      protected void HTMLWriter.output​(char[] chars, int start, int length)
      该方法被覆盖以映射任何字符实体，例如<到＆lt;。
      abstract void HTMLEditorKit.Parser.parse​(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      解析给定的流，并使用解析的结果驱动给定的回调。
      void HTMLEditorKit.read​(Reader in, Document doc, int pos)
      从给定的流插入内容。
      protected void HTMLWriter.selectContent​(AttributeSet attr)
      写出SELECT表单元素的内容。
      void HTMLDocument.setInnerHTML​(Element elem, String htmlText)
      用指定为HTML字符串的内容替换给定元素的子元素。
      void HTMLDocument.setOuterHTML​(Element elem, String htmlText)
      用指定为HTML字符串的内容替换父项中的给定元素。
      protected void MinimalHTMLWriter.startFontTag​(String style)
      这不再使用，而是会写出<span>。
      protected void HTMLWriter.startTag​(Element elem)
      写出元素的开始标签。
      protected void HTMLWriter.text​(Element elem)
      写出文字。
      protected void MinimalHTMLWriter.text​(Element elem)
      写出文字。
      protected void HTMLWriter.textAreaContent​(AttributeSet attr)
      写出TEXTAREA表单元素中包含的文本。
      void HTMLEditorKit.write​(Writer out, Document doc, int pos, int len)
      将内容从文档以适合此类内容处理程序的格式写入给定流。
      void HTMLWriter.write​()
      迭代元素树，并控制所有标签及其属性的写入。
      void MinimalHTMLWriter.write​()
      从StyledDocument生成HTML输出。
      protected void HTMLWriter.writeAttributes​(AttributeSet attr)
      写出属性集。
      protected void MinimalHTMLWriter.writeAttributes​(AttributeSet attr)
      写出以下类型的所有属性：StyleConstants.ParagraphConstants，StyleConstants.CharacterConstants，StyleConstants.FontConstants，StyleConstants.ColorConstants。
      protected void MinimalHTMLWriter.writeBody​()
      迭代文档中的元素，并基于它们是分支元素还是叶元素来处理元素。
      protected void MinimalHTMLWriter.writeComponent​(Element elem)
      负责处理元件; 故意未实施。
      protected void MinimalHTMLWriter.writeContent​(Element elem, boolean needsIndenting)
      以符合HTML的方式写入属性集。
      protected void HTMLWriter.writeEmbeddedTags​(AttributeSet attr)
      在AttributeSet中搜索嵌入式标签并将其写入。
      protected void MinimalHTMLWriter.writeEndParagraph​()
      发出<p>标签的结束标记。
      protected void MinimalHTMLWriter.writeEndTag​(String endTag)
      写出一个适合缩进的结束标签。
      protected void MinimalHTMLWriter.writeHeader​()
      写出<head>和<style>标签，然后调用writeStyles（）将所有命名样式写成<style>标签的内容。
      protected void MinimalHTMLWriter.writeHTMLTags​(AttributeSet attr)
      根据其属性设置为文本生成粗体<b>，斜体<i>和<u>标签。
      protected void MinimalHTMLWriter.writeImage​(Element elem)
      负责处理图标元素; 故意未实施。
      protected void MinimalHTMLWriter.writeLeaf​(Element elem)
      负责写出其他非文本元素。
      protected void HTMLWriter.writeLineSeparator​()
      写行分隔符。
      protected void MinimalHTMLWriter.writeNonHTMLAttributes​(AttributeSet attr)
      以符合HTML的方式写出剩余的字符级属性（粗体，斜体和下划线之外的属性）。
      protected void HTMLWriter.writeOption​(Option option)
      写出选项表单元素的内容。
      protected void MinimalHTMLWriter.writeStartParagraph​(Element elem)
      发出段落的起始标记。
      protected void MinimalHTMLWriter.writeStartTag​(String tag)
      写出一个适当缩进的开始标签。
      protected void MinimalHTMLWriter.writeStyles​()
      将所有命名的样式写成<style>标签的内容。

    • Uses of IOException in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that throw IOException
      Modifier and Type | 方法 | 描述
      static DTD DTD.getDTD​(String name)
      返回指定的 name的DTD。
      void DocumentParser.parse​(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
      解析一个HTML流，给出一个DTD。
      void Parser.parse​(Reader in)
      解析一个HTML流，给出一个DTD。
      void | ParserDelegator.parse​(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      String Parser.parseDTDMarkup​()
      解析文档类型声明标记声明。
      protected boolean Parser.parseMarkupDeclarations​(StringBuffer strBuff)
      解析标记声明。
      void DTD.read​(DataInputStream in)
      从归档格式重新创建DTD。

    • Uses of IOException in javax.swing.text.rtf

      Methods in javax.swing.text.rtf that throw IOException
      Modifier and Type 方法 描述
      void RTFEditorKit.read​(InputStream in, Document doc, int pos)
      从给定的流中插入内容，该内容预期为适合此类内容处理程序的格式。
      void RTFEditorKit.read​(Reader in, Document doc, int pos)
      从给定的流中插入内容，将被视为纯文本。
      void RTFEditorKit.write​(OutputStream out, Document doc, int pos, int len)
      将内容从文档以适合此类内容处理程序的格式写入给定流。
      void RTFEditorKit.write​(Writer out, Document doc, int pos, int len)
      将内容从文档写入给定流作为纯文本。

    • Uses of IOException in javax.tools

      Methods in javax.tools that throw IOException
      Modifier and Type | 方法 | 描述
      void | ForwardingJavaFileManager.close​()
      void JavaFileManager.close​()
      释放此文件管理器直接或间接打开的任何资源。
      boolean | ForwardingJavaFileManager.contains​(JavaFileManager.Location location, FileObject fo)
      default boolean JavaFileManager.contains​(JavaFileManager.Location location, FileObject fo)
      确定给定的文件对象是否“包含在”指定的位置。
      void | ForwardingJavaFileManager.flush​()
      void JavaFileManager.flush​()
      刷新此文件管理器直接或间接打开输出的任何资源。
      CharSequence FileObject.getCharContent​(boolean ignoreEncodingErrors)
      返回此文件对象的字符内容（如果可用）。
      CharSequence | ForwardingFileObject.getCharContent​(boolean ignoreEncodingErrors)
      CharSequence SimpleJavaFileObject.getCharContent​(boolean ignoreEncodingErrors)
      这个实现总是抛出UnsupportedOperationException 。
      FileObject | ForwardingJavaFileManager.getFileForInput​(JavaFileManager.Location location, String packageName, String relativeName)
      FileObject JavaFileManager.getFileForInput​(JavaFileManager.Location location, String packageName, String relativeName)
      返回file object用于表示指定的输入relative name中指定的包在给定的取向包位置。
      FileObject | ForwardingJavaFileManager.getFileForOutput​(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      FileObject JavaFileManager.getFileForOutput​(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      返回file object用于表示指定的输出relative name中指定的包在给定的位置。
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      JavaFileObject JavaFileManager.getJavaFileForInput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      返回一个file object，用于在给定的面向包的位置中表示指定类型的指定类的输入。
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      JavaFileObject JavaFileManager.getJavaFileForOutput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      返回一个file object，用于在给定的面向对象的位置中表示指定类型的指定类的输出。
      JavaFileManager.Location | ForwardingJavaFileManager.getLocationForModule​(JavaFileManager.Location location, String moduleName)
      JavaFileManager.Location | ForwardingJavaFileManager.getLocationForModule​(JavaFileManager.Location location, JavaFileObject fo)
      default JavaFileManager.Location JavaFileManager.getLocationForModule​(JavaFileManager.Location location, String moduleName)
      在位置中获取命名模块的位置，该位置可以是面向模块的位置或输出位置。
      default JavaFileManager.Location JavaFileManager.getLocationForModule​(JavaFileManager.Location location, JavaFileObject fo)
      获取包含要在一个位置找到的特定文件的模块的位置，该位置可以是面向模块的位置或输出位置。
      <S> ServiceLoader<S> | ForwardingJavaFileManager.getServiceLoader​(JavaFileManager.Location location, Class<S> service)
      default <S> ServiceLoader<S> JavaFileManager.getServiceLoader​(JavaFileManager.Location location, Class<S> service)
      从给定位置获取特定服务类的服务加载程序。
      String | ForwardingJavaFileManager.inferModuleName​(JavaFileManager.Location location)
      default String JavaFileManager.inferModuleName​(JavaFileManager.Location location)
      从其位置输入模块的名称，如 getLocationForModule或 listModuleLocations 。
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Iterable<JavaFileObject> JavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      列出与给定的面向对象位置匹配的所有文件对象。
      Iterable<Set<JavaFileManager.Location>> | ForwardingJavaFileManager.listLocationsForModules​(JavaFileManager.Location location)
      default Iterable<Set<JavaFileManager.Location>> JavaFileManager.listLocationsForModules​(JavaFileManager.Location location)
      列出面向模块的位置或输出位置中所有模块的位置。
      InputStream FileObject.openInputStream​()
      返回此文件对象的InputStream。
      InputStream | ForwardingFileObject.openInputStream​()
      InputStream SimpleJavaFileObject.openInputStream​()
      这个实现总是抛出UnsupportedOperationException 。
      OutputStream FileObject.openOutputStream​()
      返回此文件对象的OutputStream。
      OutputStream | ForwardingFileObject.openOutputStream​()
      OutputStream SimpleJavaFileObject.openOutputStream​()
      这个实现总是抛出UnsupportedOperationException 。
      Reader FileObject.openReader​(boolean ignoreEncodingErrors)
      返回此对象的读取器。
      Reader | ForwardingFileObject.openReader​(boolean ignoreEncodingErrors)
      Reader SimpleJavaFileObject.openReader​(boolean ignoreEncodingErrors)
      将 SimpleJavaFileObject.getCharContent(boolean)的结果 包装在阅读器中。
      Writer FileObject.openWriter​()
      返回此文件对象的Writer。
      Writer | ForwardingFileObject.openWriter​()
      Writer SimpleJavaFileObject.openWriter​()
      在Writer中将openOutputStream的结果包起来。
      void StandardJavaFileManager.setLocation​(JavaFileManager.Location location, Iterable<? extends File> files)
      将给定的搜索路径与给定位置相关联。
      default void StandardJavaFileManager.setLocationForModule​(JavaFileManager.Location location, String moduleName, Collection<? extends Path> paths)
      将给定的搜索路径与给定的模块和位置相关联，该模块和位置必须是面向模块或输出位置。
      default void StandardJavaFileManager.setLocationFromPaths​(JavaFileManager.Location location, Collection<? extends Path> paths)
      将给定的搜索路径与给定位置相关联。

    • Uses of IOException in javax.transaction

      Subclasses of IOException in javax.transaction
      Modifier and Type Class 描述
      class  InvalidTransactionException
      此异常表示请求携带无效的事务上下文。
      class  TransactionRequiredException
      此异常指示请求携带空事务上下文，但目标对象需要激活事务。
      class  TransactionRolledbackException
      此异常表示与请求的处理关联的事务已回滚，或标记为回滚。

    • Uses of IOException in javax.xml.bind

      Methods in javax.xml.bind that throw IOException
      Modifier and Type 方法 描述
      abstract Result SchemaOutputResolver.createOutput​(String namespaceUri, String suggestedFileName)
      决定模式文件（给定的命名空间URI）将被写入的位置，并将其作为Result对象返回。
      void JAXBContext.generateSchema​(SchemaOutputResolver outputResolver)
      生成此上下文的模式文档。

    • Uses of IOException in javax.xml.parsers

      Methods in javax.xml.parsers that throw IOException
      Modifier and Type 方法 描述
      Document DocumentBuilder.parse​(File f)
      将给定文件的内容解析为XML文档并返回一个新的DOM Document对象。
      Document DocumentBuilder.parse​(InputStream is)
      将给定的InputStream的内容解析为XML文档并返回一个新的DOM Document对象。
      Document DocumentBuilder.parse​(InputStream is, String systemId)
      将给定的InputStream的内容解析为XML文档，并返回一个新的DOM Document对象。
      Document DocumentBuilder.parse​(String uri)
      将给定URI的内容解析为XML文档，并返回一个新的DOM Document对象。
      abstract Document DocumentBuilder.parse​(InputSource is)
      将给定输入源的内容解析为XML文档，并返回一个新的DOM Document对象。
      void SAXParser.parse​(File f, HandlerBase hb)
      使用指定的HandlerBase解析指定为XML的文件的内容。
      void SAXParser.parse​(File f, DefaultHandler dh)
      使用指定的DefaultHandler解析指定为XML的文件的内容。
      void SAXParser.parse​(InputStream is, HandlerBase hb)
      使用指定的HandlerBase将给定的InputStream实例的内容解析为XML。
      void SAXParser.parse​(InputStream is, HandlerBase hb, String systemId)
      使用指定的HandlerBase将给定的InputStream实例的内容解析为XML。
      void SAXParser.parse​(InputStream is, DefaultHandler dh)
      使用指定的DefaultHandler将给定的InputStream实例的内容解析为XML。
      void SAXParser.parse​(InputStream is, DefaultHandler dh, String systemId)
      使用指定的DefaultHandler将给定的InputStream实例的内容解析为XML。
      void SAXParser.parse​(String uri, HandlerBase hb)
      使用指定的HandlerBase解析使用给定统一资源标识符（URI）作为XML描述的内容。
      void SAXParser.parse​(String uri, DefaultHandler dh)
      使用指定的DefaultHandler解析给出使用统一资源标识符（URI）作为XML的内容 。
      void SAXParser.parse​(InputSource is, HandlerBase hb)
      解析给出的内容InputSource使用指定为XML HandlerBase 。
      void SAXParser.parse​(InputSource is, DefaultHandler dh)
      解析给出的内容InputSource使用指定为XML DefaultHandler 。

    • Uses of IOException in javax.xml.soap

      Methods in javax.xml.soap that throw IOException
      Modifier and Type 方法 描述
      abstract SOAPMessage MessageFactory.createMessage​(MimeHeaders headers, InputStream in)
      将给定的 InputStream对象的内容内化为一个新的 SOAPMessage对象，并返回 SOAPMessage对象。
      abstract void SOAPMessage.writeTo​(OutputStream out)
      将此 SOAPMessage对象写入给定的输出流。

    • Uses of IOException in javax.xml.validation

      Methods in javax.xml.validation that throw IOException
      Modifier and Type 方法 描述
      void Validator.validate​(Source source)
      验证指定的输入。
      abstract void Validator.validate​(Source source, Result result)
      验证指定的输入并将增强的验证结果发送到指定的输出。

    • Uses of IOException in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that throw IOException
      Modifier and Type 方法 描述
      abstract void HttpExchange.close​()
      必须调用这个结束交换。
      abstract InputStream HttpExchange.getRequestBody​()
      返回可以从中读取请求主体的流。
      abstract OutputStream HttpExchange.getResponseBody​()
      返回响应主体必须写入的流。
      abstract void HttpHandler.handle​(HttpExchange exchange)
      处理给定的请求并生成适当的响应。

    • Uses of IOException in jdk.incubator.http

      Subclasses of IOException in jdk.incubator.http
      Modifier and Type Class 描述
      class  HttpTimeoutException
      在指定时间段内没有收到回应时抛出。
      class  WebSocketHandshakeException
      用于表示开启握手的异常失败。
      Methods in jdk.incubator.http that throw IOException
      Modifier and Type 方法 描述
      void WebSocket.abort​()
      突然关闭了 WebSocket 。
      abstract <T> HttpResponse<T> HttpClient.send​(HttpRequest req, HttpResponse.BodyHandler<T> responseBodyHandler)
      使用此客户端发送给定的请求，如有必要，阻止获取响应。

    • Uses of IOException in jdk.jshell.execution

      Methods in jdk.jshell.execution that throw IOException
      Modifier and Type | 方法 | 描述
      static void Util.forwardExecutionControlAndIO​(ExecutionControl ec, InputStream inStream, OutputStream outStream, Map<String,Consumer<OutputStream>> outputStreamMap, Map<String,Consumer<InputStream>> inputStreamMap)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
      ExecutionControl | JdiExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。

    • Uses of IOException in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that throw IOException
      Modifier and Type | 方法 | 描述
      void | URLReader.close​()
      int | URLReader.read​(char[] cbuf, int off, int len)

    • Uses of IOException in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree that throw IOException
      Modifier and Type 方法 描述
      CompilationUnitTree Parser.parse​(File file, DiagnosticListener listener)
      解析源文件并返回编译单元树
      CompilationUnitTree Parser.parse​(String name, Reader reader, DiagnosticListener listener)
      解读读者并返回编译单元树
      CompilationUnitTree Parser.parse​(URL url, DiagnosticListener listener)
      解析源URL并返回编译单元树
      CompilationUnitTree Parser.parse​(Path path, DiagnosticListener listener)
      解析源路径并返回编译单元树

    • Uses of IOException in jdk.net

      Methods in jdk.net that throw IOException
      Modifier and Type 方法 描述
      static <T> T Sockets.getOption​(DatagramSocket s, SocketOption<T> name)
      从DatagramSocket或MulticastSocket返回套接字选项的值
      static <T> T Sockets.getOption​(ServerSocket s, SocketOption<T> name)
      从ServerSocket返回套接字选项的值
      static <T> T Sockets.getOption​(Socket s, SocketOption<T> name)
      从Socket返回套接字选项的值
      static <T> void Sockets.setOption​(DatagramSocket s, SocketOption<T> name, T value)
      在DatagramSocket或MulticastSocket上设置套接字选项的值
      static <T> void Sockets.setOption​(ServerSocket s, SocketOption<T> name, T value)
      在ServerSocket上设置套接字选项的值
      static <T> void Sockets.setOption​(Socket s, SocketOption<T> name, T value)
      在Socket上设置套接字选项的值

    • Uses of IOException in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that throw IOException
      Modifier and Type | 方法 | 描述
      int | InputStream.read​()
      void OutputStream.write​(int b)
      将一个整数（数组长度）写入此流。

    • Uses of IOException in org.xml.sax

      Methods in org.xml.sax that throw IOException
      Modifier and Type 方法 描述
      void Parser.parse​(String systemId)
      已过时。
      从系统标识符（URI）解析XML文档。
      void Parser.parse​(InputSource source)
      已过时。
      解析一个XML文档。
      void XMLReader.parse​(String systemId)
      从系统标识符（URI）解析XML文档。
      void XMLReader.parse​(InputSource input)
      解析一个XML文档。
      InputSource EntityResolver.resolveEntity​(String publicId, String systemId)
      允许应用程序解析外部实体。

    • Uses of IOException in org.xml.sax.ext

      Methods in org.xml.sax.ext that throw IOException
      Modifier and Type 方法 描述
      InputSource DefaultHandler2.getExternalSubset​(String name, String baseURI)
      告诉解析器，如果在文档文本中没有声明外部子集，则不应使用任何外部子集。
      InputSource EntityResolver2.getExternalSubset​(String name, String baseURI)
      允许应用程序为未明确定义的文档提供外部子集。
      InputSource DefaultHandler2.resolveEntity​(String publicId, String systemId)
      使用空实体名称和基本URI调用 EntityResolver2.resolveEntity() 。
      InputSource DefaultHandler2.resolveEntity​(String name, String publicId, String baseURI, String systemId)
      告诉解析器根据baseURI解析systemId，并从该结果的绝对URI中读取实体文本。
      InputSource EntityResolver2.resolveEntity​(String name, String publicId, String baseURI, String systemId)
      允许应用程序将对外部实体的引用映射到输入源中，或者告诉解析器它应该使用传统的URI解析。

    • Uses of IOException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw IOException
      Modifier and Type 方法 描述
      void ParserAdapter.parse​(String systemId)
      解析一个XML文档。
      void ParserAdapter.parse​(InputSource input)
      解析一个XML文档。
      void XMLFilterImpl.parse​(String systemId)
      解析文件
      void XMLFilterImpl.parse​(InputSource input)
      解析文件
      void XMLReaderAdapter.parse​(String systemId)
      解析文件。
      void XMLReaderAdapter.parse​(InputSource input)
      解析文件。
      InputSource DefaultHandler.resolveEntity​(String publicId, String systemId)
      解决外部实体。
      InputSource XMLFilterImpl.resolveEntity​(String publicId, String systemId)
      Filter an external entity resolution.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.LineNumberInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.LineNumberInputStream

No usage of java.io.LineNumberInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.LineNumberReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.LineNumberReader

No usage of java.io.LineNumberReader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.NotActiveException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.NotActiveException

  • Packages that use NotActiveException
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of NotActiveException in java.io

      Methods in java.io that throw NotActiveException
      Modifier and Type 方法 描述
      void ObjectInputStream.registerValidation​(ObjectInputValidation obj, int prio)
      在返回图之前注册要验证的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.NotSerializableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.NotSerializableException

No usage of java.io.NotSerializableException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectInputFilter.Config (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectInputFilter.Config

No usage of java.io.ObjectInputFilter.Config
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectInputFilter.Status (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectInputFilter.Status

  • Packages that use ObjectInputFilter.Status
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectInputFilter.Status in java.io

      Methods in java.io that return ObjectInputFilter.Status
      Modifier and Type 方法 描述
      ObjectInputFilter.Status ObjectInputFilter.checkInput​(ObjectInputFilter.FilterInfo filterInfo)
      检查类，数组长度，对象引用数，深度，流大小和其他可用过滤信息。
      static ObjectInputFilter.Status ObjectInputFilter.Status.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ObjectInputFilter.Status[] ObjectInputFilter.Status.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectInputStream

  • Packages that use ObjectInputStream
    软件包 描述
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of ObjectInputStream in java.beans.beancontext

      Methods in java.beans.beancontext with parameters of type ObjectInputStream
      Modifier and Type 方法 描述
      protected void BeanContextServicesSupport.bcsPreDeserializationHook​(ObjectInputStream ois)
      从BeanContextSupport readObject中调用它反序列化子对象...
      protected void BeanContextSupport.bcsPreDeserializationHook​(ObjectInputStream ois)
      通过readObject在defaultReadObject（）之后调用，但在任何孩子反序列化之前。
      protected void BeanContextSupport.deserialize​(ObjectInputStream ois, Collection coll)
      由readObject用于反序列化集合。
      void BeanContextSupport.readChildren​(ObjectInputStream ois)
      当这个类的实例被用作实现BeanContext协议（及其子协议）的委托时，在反序列化期间存在一个'鸡和蛋'问题

    • Uses of ObjectInputStream in javax.management

      Methods in javax.management that return ObjectInputStream
      Modifier and Type 方法 描述
      default ObjectInputStream MBeanServer.deserialize​(String className, byte[] data)
      已过时。
      使用MBeanServer.getClassLoaderRepository()获取类加载器存储库并将其用于反序列化。
      default ObjectInputStream MBeanServer.deserialize​(String className, ObjectName loaderName, byte[] data)
      已过时。
      使用getClassLoader获取反序列化的类加载器。
      default ObjectInputStream MBeanServer.deserialize​(ObjectName name, byte[] data)
      已过时。
      使用getClassLoaderFor获取适当的反序列化类加载器。

    • Uses of ObjectInputStream in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type ObjectInputStream
      Modifier and Type 方法 描述
      void StubDelegate.readObject​(Stub self, ObjectInputStream s)
      代表团要求 Stub.readObject(java.io.ObjectInputStream) 。

    • Uses of ObjectInputStream in javax.swing.text

      Methods in javax.swing.text with parameters of type ObjectInputStream
      Modifier and Type 方法 描述
      void StyleContext.readAttributes​(ObjectInputStream in, MutableAttributeSet a)
      属性中阅读的上下文特定处理
      static void StyleContext.readAttributeSet​(ObjectInputStream in, MutableAttributeSet a)
      从给定的对象输入流读取一组属性，这些属性先前已经用 writeAttributeSet 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectInputStream.GetField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectInputStream.GetField

  • Packages that use ObjectInputStream.GetField
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectInputStream.GetField in java.io

      Methods in java.io that return ObjectInputStream.GetField
      Modifier and Type 方法 描述
      ObjectInputStream.GetField ObjectInputStream.readFields​()
      从流中读取持久性字段，并通过名称使其可用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectOutputStream

  • Packages that use ObjectOutputStream
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of ObjectOutputStream in java.awt

      Methods in java.awt with parameters of type ObjectOutputStream
      Modifier and Type 方法 描述
      protected static void AWTEventMulticaster.save​(ObjectOutputStream s, String k, EventListener l)
      将可序列化的监听器链保存到序列化流。
      protected void AWTEventMulticaster.saveInternal​(ObjectOutputStream s, String k)
      序列化支持。

    • Uses of ObjectOutputStream in java.beans.beancontext

      Methods in java.beans.beancontext with parameters of type ObjectOutputStream
      Modifier and Type 方法 描述
      protected void BeanContextServicesSupport.bcsPreSerializationHook​(ObjectOutputStream oos)
      从BeanContextSupport中调用writeObject，然后序列化子对象...
      protected void BeanContextSupport.bcsPreSerializationHook​(ObjectOutputStream oos)
      在writeWriteObject（）之后但在序列化当前可序列化的孩子之前调用writeObject。
      protected void BeanContextSupport.serialize​(ObjectOutputStream oos, Collection<?> coll)
      由writeObject用于序列化集合。
      void BeanContextSupport.writeChildren​(ObjectOutputStream oos)
      用于序列化这个 BeanContext所有孩子。

    • Uses of ObjectOutputStream in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type ObjectOutputStream
      Modifier and Type 方法 描述
      void StubDelegate.writeObject​(Stub self, ObjectOutputStream s)
      代表团要求 Stub.writeObject(java.io.ObjectOutputStream) 。

    • Uses of ObjectOutputStream in javax.swing.text

      Methods in javax.swing.text with parameters of type ObjectOutputStream
      Modifier and Type 方法 描述
      void StyleContext.writeAttributes​(ObjectOutputStream out, AttributeSet a)
      编写属性的上下文特定处理
      static void StyleContext.writeAttributeSet​(ObjectOutputStream out, AttributeSet a)
      Writes a set of attributes to the given object stream for the purpose of serialization.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectOutputStream.PutField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectOutputStream.PutField

  • Packages that use ObjectOutputStream.PutField
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectOutputStream.PutField in java.io

      Methods in java.io that return ObjectOutputStream.PutField
      Modifier and Type 方法 描述
      ObjectOutputStream.PutField ObjectOutputStream.putFields​()
      检索用于缓冲要写入流的持久性字段的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectStreamClass (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectStreamClass

  • Packages that use ObjectStreamClass
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectStreamClass in java.io

      Methods in java.io that return ObjectStreamClass
      Modifier and Type 方法 描述
      abstract ObjectStreamClass ObjectInputStream.GetField.getObjectStreamClass​()
      获取描述流中字段的ObjectStreamClass。
      static ObjectStreamClass ObjectStreamClass.lookup​(Class<?> cl)
      找到可以序列化的类的描述符。
      static ObjectStreamClass ObjectStreamClass.lookupAny​(Class<?> cl)
      返回任何类的描述符，无论它是否实现Serializable 。
      protected ObjectStreamClass ObjectInputStream.readClassDescriptor​()
      从序列化流读取类描述符。
      Methods in java.io with parameters of type ObjectStreamClass
      Modifier and Type 方法 描述
      protected Class<?> ObjectInputStream.resolveClass​(ObjectStreamClass desc)
      加载本地类等效的指定流类描述。
      protected void ObjectOutputStream.writeClassDescriptor​(ObjectStreamClass desc)
      Write the specified class descriptor to the ObjectOutputStream.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectStreamException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectStreamException

  • Packages that use ObjectStreamException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。

    • Uses of ObjectStreamException in java.awt

      Methods in java.awt that throw ObjectStreamException
      Modifier and Type 方法 描述
      protected Object AWTKeyStroke.readResolve​()
      返回的缓存实例 AWTKeyStroke （或子类 AWTKeyStroke ），这是此实例相等。

    • Uses of ObjectStreamException in java.awt.color

      Methods in java.awt.color that throw ObjectStreamException
      Modifier and Type 方法 描述
      protected Object ICC_Profile.readResolve​()
      将被反序列化的实例解析为使用CMM注册的实例。

    • Uses of ObjectStreamException in java.io

      Subclasses of ObjectStreamException in java.io
      Modifier and Type Class 描述
      class  InvalidClassException
      当序列化运行时检测到类中的以下问题之一时抛出。
      class  InvalidObjectException
      表示一个或多个反序列化对象失败的验证测试。
      class  NotActiveException
      序列化或反序列化不活跃时抛出。
      class  NotSerializableException
      抛出一个实例需要一个Serializable接口。
      class  OptionalDataException
      表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。
      class  StreamCorruptedException
      当从对象流读取的控制信息违反内部一致性检查时抛出。
      class  WriteAbortedException
      指示在写入操作期间抛出ObjectStreamExceptions之一。

    • Uses of ObjectStreamException in java.security

      Methods in java.security that throw ObjectStreamException
      Modifier and Type 方法 描述
      protected Object KeyRep.readResolve​()
      解决Key对象。

    • Uses of ObjectStreamException in java.security.cert

      Methods in java.security.cert that throw ObjectStreamException
      Modifier and Type 方法 描述
      protected Object Certificate.CertificateRep.readResolve​()
      解决证书对象。
      protected Object CertPath.CertPathRep.readResolve​()
      返回从类型和数据构造的 CertPath 。
      protected Object Certificate.writeReplace​()
      更换要序列化的证书。
      protected Object CertPath.writeReplace​()
      替换 CertPath成与被序列 CertPathRep对象。

    • Uses of ObjectStreamException in javax.management.openmbean

      Methods in javax.management.openmbean that throw ObjectStreamException
      Modifier and Type 方法 描述
      Object SimpleType.readResolve​()
      使用该值的唯一实例替换从ObjectInputStream读取的对象。

    • Uses of ObjectStreamException in javax.print.attribute

      Methods in javax.print.attribute that throw ObjectStreamException
      Modifier and Type 方法 描述
      protected Object EnumSyntax.readResolve​()
      在对象输入期间，将此反序列化枚举实例转换为枚举属性类中定义的适当枚举值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.ObjectStreamField (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.ObjectStreamField

  • Packages that use ObjectStreamField
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectStreamField in java.io

      Fields in java.io declared as ObjectStreamField
      Modifier and Type Field 描述
      static ObjectStreamField[] ObjectStreamClass.NO_FIELDS
      serialPersistentFields值，表示无可序列化的字段
      Methods in java.io that return ObjectStreamField
      Modifier and Type 方法 描述
      ObjectStreamField ObjectStreamClass.getField​(String name)
      通过名称获取此类的字段。
      ObjectStreamField[] ObjectStreamClass.getFields​()
      返回此可序列化类的字段数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.OptionalDataException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.OptionalDataException

No usage of java.io.OptionalDataException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.OutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.OutputStream

  • Packages that use OutputStream
    软件包 描述
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    java.awt.color
    提供颜色空间的类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    服务提供者类为 java.nio.file包。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.activation
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为某些 javax.xml.bind接口提供部分默认实现。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform.stream
    提供流和URI特定的转换类。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.security.jarsigner
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
    org.omg.CORBA_2_3.portable
    提供输入和输出值类型的方法，并包含 org/omg/CORBA/portable包的其他更新。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。

    • Uses of OutputStream in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return OutputStream
      Modifier and Type 方法 描述
      abstract OutputStream HttpExchange.getResponseBody​()
      返回响应主体必须写入的流。
      Methods in com.sun.net.httpserver with parameters of type OutputStream
      Modifier and Type 方法 描述
      abstract void HttpExchange.setStreams​(InputStream i, OutputStream o)
      过滤器使用该包交换器的InputStream和OutputStream（或两者）与给定的过滤流，以便后续调用HttpExchange.getRequestBody()将返回给定的InputStream ，并且调用HttpExchange.getResponseBody()将返回给定的OutputStream 。

    • Uses of OutputStream in java.awt.color

      Methods in java.awt.color with parameters of type OutputStream
      Modifier and Type 方法 描述
      void ICC_Profile.write​(OutputStream s)
      将此ICC_Profile写入OutputStream。

    • Uses of OutputStream in java.beans

      Constructors in java.beans with parameters of type OutputStream
      Constructor 描述
      XMLEncoder​(OutputStream out)
      创建一个新的XML编码器，使用XML编码将 JavaBeans写入流 out 。
      XMLEncoder​(OutputStream out, String charset, boolean declaration, int indentation)
      创建一个新的XML编码器 的JavaBeans写出到流 out使用给定 charset从给定的起始 indentation 。

    • Uses of OutputStream in java.io

      Subclasses of OutputStream in java.io
      Modifier and Type Class 描述
      class  BufferedOutputStream
      该类实现缓冲输出流。
      class  ByteArrayOutputStream
      该类实现了将数据写入字节数组的输出流。
      class  DataOutputStream
      数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
      class  FileOutputStream
      文件输出流是用于将数据写入到 File或 FileDescriptor的输出流。
      class  FilterOutputStream
      这个类是过滤输出流的所有类的超类。
      class  ObjectOutputStream
      ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
      class  PipedOutputStream
      管道输出流可以连接到管道输入流以创建通信管道。
      class  PrintStream
      A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
      Fields in java.io declared as OutputStream
      Modifier and Type Field 描述
      protected OutputStream FilterOutputStream.out
      要过滤的底层输出流。
      Methods in java.io with parameters of type OutputStream
      Modifier and Type 方法 描述
      long InputStream.transferTo​(OutputStream out)
      从该输入流中读取所有字节，并按读取的顺序将字节写入给定的输出流。
      void ByteArrayOutputStream.writeTo​(OutputStream out)
      将此字节数组输出流的完整内容写入指定的输出流参数，就像使用 out.write(buf, 0, count)调用输出流的写入方法 out.write(buf, 0, count) 。
      Constructors in java.io with parameters of type OutputStream
      Constructor 描述
      BufferedOutputStream​(OutputStream out)
      创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
      BufferedOutputStream​(OutputStream out, int size)
      创建一个新的缓冲输出流，以便以指定的缓冲区大小将数据写入指定的底层输出流。
      DataOutputStream​(OutputStream out)
      创建一个新的数据输出流，以将数据写入指定的底层输出流。
      FilterOutputStream​(OutputStream out)
      创建一个基于指定底层输出流的输出流过滤器。
      ObjectOutputStream​(OutputStream out)
      创建一个写入指定的OutputStream的ObjectOutputStream。
      OutputStreamWriter​(OutputStream out)
      创建一个使用默认字符编码的OutputStreamWriter。
      OutputStreamWriter​(OutputStream out, String charsetName)
      创建一个使用命名字符集的OutputStreamWriter。
      OutputStreamWriter​(OutputStream out, Charset cs)
      创建一个使用给定字符集的OutputStreamWriter。
      OutputStreamWriter​(OutputStream out, CharsetEncoder enc)
      创建一个使用给定字符集编码器的OutputStreamWriter。
      PrintStream​(OutputStream out)
      创建一个新的打印流。
      PrintStream​(OutputStream out, boolean autoFlush)
      创建一个新的打印流。
      PrintStream​(OutputStream out, boolean autoFlush, String encoding)
      创建一个新的打印流。
      PrintWriter​(OutputStream out)
      从现有的OutputStream创建一个新的PrintWriter，而不需要自动线路刷新。
      PrintWriter​(OutputStream out, boolean autoFlush)
      从现有的OutputStream创建一个新的PrintWriter。

    • Uses of OutputStream in java.lang

      Methods in java.lang that return OutputStream
      Modifier and Type 方法 描述
      OutputStream Runtime.getLocalizedOutputStream​(OutputStream out)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。
      abstract OutputStream Process.getOutputStream​()
      返回连接到进程正常输入的输出流。
      Methods in java.lang with parameters of type OutputStream
      Modifier and Type 方法 描述
      OutputStream Runtime.getLocalizedOutputStream​(OutputStream out)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。

    • Uses of OutputStream in java.net

      Methods in java.net that return OutputStream
      Modifier and Type 方法 描述
      abstract OutputStream CacheRequest.getBody​()
      返回一个可以写入响应体的OutputStream。
      OutputStream Socket.getOutputStream​()
      返回此套接字的输出流。
      protected abstract OutputStream SocketImpl.getOutputStream​()
      返回此套接字的输出流。
      OutputStream URLConnection.getOutputStream​()
      返回写入此连接的输出流。

    • Uses of OutputStream in java.nio.channels

      Methods in java.nio.channels that return OutputStream
      Modifier and Type 方法 描述
      static OutputStream Channels.newOutputStream​(AsynchronousByteChannel ch)
      构造将字节写入给定通道的流。
      static OutputStream Channels.newOutputStream​(WritableByteChannel ch)
      构造将字节写入给定通道的流。
      Methods in java.nio.channels with parameters of type OutputStream
      Modifier and Type 方法 描述
      static WritableByteChannel Channels.newChannel​(OutputStream out)
      构造一个向给定流写入字节的通道。

    • Uses of OutputStream in java.nio.file

      Methods in java.nio.file that return OutputStream
      Modifier and Type 方法 描述
      static OutputStream Files.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。
      Methods in java.nio.file with parameters of type OutputStream
      Modifier and Type 方法 描述
      static long Files.copy​(Path source, OutputStream out)
      将文件中的所有字节复制到输出流。

    • Uses of OutputStream in java.nio.file.spi

      Methods in java.nio.file.spi that return OutputStream
      Modifier and Type 方法 描述
      OutputStream FileSystemProvider.newOutputStream​(Path path, OpenOption... options)
      打开或创建文件，返回可用于向文件写入字节的输出流。

    • Uses of OutputStream in java.rmi.server

      Subclasses of OutputStream in java.rmi.server
      Modifier and Type Class 描述
      class  LogStream
      已过时。
      没有替换
      Methods in java.rmi.server that return OutputStream
      Modifier and Type 方法 描述
      OutputStream LogStream.getOutputStream​()
      已过时。
      没有替换
      Methods in java.rmi.server with parameters of type OutputStream
      Modifier and Type 方法 描述
      static void RemoteServer.setLog​(OutputStream out)
      将RMI调用记录到输出流 out 。
      void LogStream.setOutputStream​(OutputStream out)
      已过时。
      没有替换

    • Uses of OutputStream in java.security

      Subclasses of OutputStream in java.security
      Modifier and Type Class 描述
      class  DigestOutputStream
      透明流，使用通过流的位更新关联的消息摘要。
      Methods in java.security with parameters of type OutputStream
      Modifier and Type 方法 描述
      void Certificate.encode​(OutputStream stream)
      已过时。
      将证书编码为可以通过 decode方法解码的格式的输出流。
      abstract void KeyStoreSpi.engineStore​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      void KeyStore.store​(OutputStream stream, char[] password)
      将此密钥库存储到给定的输出流，并使用给定的密码保护其完整性。
      Constructors in java.security with parameters of type OutputStream
      Constructor 描述
      DigestOutputStream​(OutputStream stream, MessageDigest digest)
      使用指定的输出流和消息摘要创建摘要输出流。

    • Uses of OutputStream in java.security.cert

      Methods in java.security.cert with parameters of type OutputStream
      Modifier and Type 方法 描述
      void Extension.encode​(OutputStream out)
      生成扩展的DER编码，并将其写入输出流。

    • Uses of OutputStream in java.sql

      Methods in java.sql that return OutputStream
      Modifier and Type 方法 描述
      OutputStream Clob.setAsciiStream​(long pos)
      检索用于将Ascii字符写入 Clob对象所代表的 CLOB值的流，从位置 pos开始。
      OutputStream Blob.setBinaryStream​(long pos)
      检索可用于写入 Blob对象所代表的值的 BLOB值的流。
      OutputStream SQLXML.setBinaryStream​()
      检索可用于编写此SQLXML实例所代表的XML值的流。

    • Uses of OutputStream in java.util

      Methods in java.util that return OutputStream
      Modifier and Type 方法 描述
      OutputStream Base64.Encoder.wrap​(OutputStream os)
      使用Base64编码方案包装用于编码字节数据的输出流。
      Methods in java.util with parameters of type OutputStream
      Modifier and Type 方法 描述
      void Properties.save​(OutputStream out, String comments)
      已过时。
      如果在保存属性列表时发生I / O错误，此方法不会抛出IOException。 保存属性列表的首选方法是通过store(OutputStream out, String comments)方法或storeToXML(OutputStream os, String comment)方法。
      void Properties.store​(OutputStream out, String comments)
      将此属性列表（键和元素对）写入此 Properties表中，以适合于使用 load(InputStream)方法加载到 Properties表的格式的输出流。
      void Properties.storeToXML​(OutputStream os, String comment)
      发出表示此表中包含的所有属性的XML文档。
      void Properties.storeToXML​(OutputStream os, String comment, String encoding)
      使用指定的编码发出表示此表中包含的所有属性的XML文档。
      OutputStream Base64.Encoder.wrap​(OutputStream os)
      使用Base64编码方案包装用于编码字节数据的输出流。
      Constructors in java.util with parameters of type OutputStream
      Constructor 描述
      Formatter​(OutputStream os)
      使用指定的输出流构造一个新的格式化程序。
      Formatter​(OutputStream os, String csn)
      使用指定的输出流和字符集构造一个新的格式化程序。
      Formatter​(OutputStream os, String csn, Locale l)
      使用指定的输出流，字符集和区域设置构造一个新的格式化程序。

    • Uses of OutputStream in java.util.jar

      Subclasses of OutputStream in java.util.jar
      Modifier and Type Class 描述
      class  JarOutputStream
      JarOutputStream类用于将JAR文件的内容写入任何输出流。
      Methods in java.util.jar with parameters of type OutputStream
      Modifier and Type 方法 描述
      void Pack200.Packer.pack​(JarFile in, OutputStream out)
      使用JarFile并将其转换为Pack200存档。
      void Pack200.Packer.pack​(JarInputStream in, OutputStream out)
      使用JarInputStream并将其转换为Pack200归档文件。
      void Manifest.write​(OutputStream out)
      将清单写入指定的OutputStream。
      Constructors in java.util.jar with parameters of type OutputStream
      Constructor 描述
      JarOutputStream​(OutputStream out)
      创建一个没有清单的新的 JarOutputStream 。
      JarOutputStream​(OutputStream out, Manifest man)
      创建一个新的 JarOutputStream与指定的 Manifest 。

    • Uses of OutputStream in java.util.logging

      Methods in java.util.logging with parameters of type OutputStream
      Modifier and Type 方法 描述
      protected void StreamHandler.setOutputStream​(OutputStream out)
      更改输出流。
      Constructors in java.util.logging with parameters of type OutputStream
      Constructor 描述
      StreamHandler​(OutputStream out, Formatter formatter)
      创建一个 StreamHandler与给定的 Formatter和输出流。

    • Uses of OutputStream in java.util.prefs

      Methods in java.util.prefs with parameters of type OutputStream
      Modifier and Type 方法 描述
      void AbstractPreferences.exportNode​(OutputStream os)
      实现 exportNode方法按照在本说明书中 Preferences.exportNode(OutputStream) 。
      abstract void Preferences.exportNode​(OutputStream os)
      在指定的输出流上发出一个XML文档，表示此节点中包含的所有首选项（而不是其后代）。
      void AbstractPreferences.exportSubtree​(OutputStream os)
      实现 exportSubtree方法按照在本说明书中 Preferences.exportSubtree(OutputStream) 。
      abstract void Preferences.exportSubtree​(OutputStream os)
      发出表示此节点及其所有后代中包含的所有首选项的XML文档。

    • Uses of OutputStream in java.util.zip

      Subclasses of OutputStream in java.util.zip
      Modifier and Type Class 描述
      class  CheckedOutputStream
      一个输出流，它还维护正在写入的数据的校验和。
      class  DeflaterOutputStream
      该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
      class  GZIPOutputStream
      该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
      class  InflaterOutputStream
      实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。
      class  ZipOutputStream
      该类实现了以ZIP文件格式写入文件的输出流过滤器。
      Constructors in java.util.zip with parameters of type OutputStream
      Constructor 描述
      CheckedOutputStream​(OutputStream out, Checksum cksum)
      使用指定的校验和创建输出流。
      DeflaterOutputStream​(OutputStream out)
      创建具有默认压缩器和缓冲区大小的新输出流。
      DeflaterOutputStream​(OutputStream out, boolean syncFlush)
      使用默认压缩器，默认缓冲区大小和指定的刷新模式创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def)
      使用指定的压缩器和默认缓冲区大小创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, boolean syncFlush)
      使用指定的压缩器，刷新模式和默认缓冲区大小创建新的输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, int size)
      创建具有指定压缩器和缓冲区大小的新输出流。
      DeflaterOutputStream​(OutputStream out, Deflater def, int size, boolean syncFlush)
      创建具有指定压缩器，缓冲区大小和冲洗模式的新输出流。
      GZIPOutputStream​(OutputStream out)
      创建一个具有默认缓冲区大小的新输出流。
      GZIPOutputStream​(OutputStream out, boolean syncFlush)
      创建具有默认缓冲区大小和指定刷新模式的新输出流。
      GZIPOutputStream​(OutputStream out, int size)
      创建具有指定缓冲区大小的新输出流。
      GZIPOutputStream​(OutputStream out, int size, boolean syncFlush)
      创建具有指定缓冲区大小和刷新模式的新输出流。
      InflaterOutputStream​(OutputStream out)
      使用默认解压缩器和缓冲区大小创建新的输出流。
      InflaterOutputStream​(OutputStream out, Inflater infl)
      使用指定的解压缩器和默认缓冲区大小创建新的输出流。
      InflaterOutputStream​(OutputStream out, Inflater infl, int bufLen)
      使用指定的解压缩器和缓冲区大小创建新的输出流。
      ZipOutputStream​(OutputStream out)
      创建一个新的ZIP输出流。
      ZipOutputStream​(OutputStream out, Charset charset)
      创建一个新的ZIP输出流。

    • Uses of OutputStream in javax.activation

      Methods in javax.activation that return OutputStream
      Modifier and Type 方法 描述
      OutputStream DataHandler.getOutputStream​()
      获取此DataHandler的OutputStream以允许覆盖底层数据。
      OutputStream DataSource.getOutputStream​()
      该方法返回一个 OutputStream ，其中可以写入数据，如果不能这样做，则抛出相应的异常。
      OutputStream FileDataSource.getOutputStream​()
      此方法将返回一个表示数据的OutputStream，如果不能执行此操作将抛出IOException。
      OutputStream URLDataSource.getOutputStream​()
      来自URL的getOutputStream方法。
      Methods in javax.activation with parameters of type OutputStream
      Modifier and Type 方法 描述
      void DataContentHandler.writeTo​(Object obj, String mimeType, OutputStream os)
      将对象转换为指定MIME类型的字节流，并将其写入输出流。
      void DataHandler.writeTo​(OutputStream os)
      将数据写入 OutputStream 。

    • Uses of OutputStream in javax.crypto

      Subclasses of OutputStream in javax.crypto
      Modifier and Type Class 描述
      class  CipherOutputStream
      CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。
      Constructors in javax.crypto with parameters of type OutputStream
      Constructor 描述
      CipherOutputStream​(OutputStream os)
      在不指定密码的情况下，从OutputStream构造CipherOutputStream。
      CipherOutputStream​(OutputStream os, Cipher c)
      从OutputStream和Cipher构造一个CipherOutputStream。

    • Uses of OutputStream in javax.imageio

      Methods in javax.imageio with parameters of type OutputStream
      Modifier and Type 方法 描述
      static boolean ImageIO.write​(RenderedImage im, String formatName, OutputStream output)
      使用支持给定格式的任意 ImageWriter写入图像到 OutputStream 。

    • Uses of OutputStream in javax.imageio.stream

      Constructors in javax.imageio.stream with parameters of type OutputStream
      Constructor 描述
      FileCacheImageOutputStream​(OutputStream stream, File cacheDir)
      构造一个 FileCacheImageOutputStream ，它将写入给定的 outputStream 。
      MemoryCacheImageOutputStream​(OutputStream stream)
      构造一个 MemoryCacheImageOutputStream ，它将写入给定的 OutputStream 。

    • Uses of OutputStream in javax.jnlp

      Methods in javax.jnlp that return OutputStream
      Modifier and Type 方法 描述
      OutputStream FileContents.getOutputStream​(boolean overwrite)
      获取文件的 OutputStream 。

    • Uses of OutputStream in javax.print

      Methods in javax.print that return OutputStream
      Modifier and Type 方法 描述
      OutputStream StreamPrintService.getOutputStream​()
      获取输出流。
      Methods in javax.print with parameters of type OutputStream
      Modifier and Type 方法 描述
      abstract StreamPrintService StreamPrintServiceFactory.getPrintService​(OutputStream out)
      返回可以打印到指定的输出流的 StreamPrintService 。
      Constructors in javax.print with parameters of type OutputStream
      Constructor 描述
      StreamPrintService​(OutputStream out)
      构造一个StreamPrintService对象。

    • Uses of OutputStream in javax.sound.midi

      Methods in javax.sound.midi with parameters of type OutputStream
      Modifier and Type 方法 描述
      static int MidiSystem.write​(Sequence in, int fileType, OutputStream out)
      写入表示所提供的输出流的MIDI文件类型的文件的字节流。

    • Uses of OutputStream in javax.sound.midi.spi

      Methods in javax.sound.midi.spi with parameters of type OutputStream
      Modifier and Type 方法 描述
      abstract int MidiFileWriter.write​(Sequence in, int fileType, OutputStream out)
      写入表示所提供的输出流的文件类型的MIDI文件的字节流。

    • Uses of OutputStream in javax.sound.sampled

      Methods in javax.sound.sampled with parameters of type OutputStream
      Modifier and Type 方法 描述
      static int AudioSystem.write​(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      将指定文件类型的音频文件的字节流写入提供的输出流。

    • Uses of OutputStream in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi with parameters of type OutputStream
      Modifier and Type 方法 描述
      abstract int AudioFileWriter.write​(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      写入表示所提供的输出流的文件类型的音频文件的字节流。

    • Uses of OutputStream in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type OutputStream
      Modifier and Type 方法 描述
      void WebRowSet.writeXml​(OutputStream oStream)
      将此 WebRowSet对象的数据，属性和元数据以XML格式写入给定的 OutputStream对象。
      void WebRowSet.writeXml​(ResultSet rs, OutputStream oStream)
      使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 OutputStream对象。

    • Uses of OutputStream in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return OutputStream
      Modifier and Type 方法 描述
      OutputStream SerialClob.setAsciiStream​(long pos)
      检索流用于写入ASCII字符的 CLOB值，这 SerialClob对象表示，起始于位置 pos 。
      OutputStream SerialBlob.setBinaryStream​(long pos)
      检索可用于写入此 Blob对象所代表的值的 BLOB的流。

    • Uses of OutputStream in javax.swing.text

      Methods in javax.swing.text with parameters of type OutputStream
      Modifier and Type 方法 描述
      void DefaultEditorKit.write​(OutputStream out, Document doc, int pos, int len)
      以适合此类内容处理程序的格式将内容从文档写入给定流。
      abstract void EditorKit.write​(OutputStream out, Document doc, int pos, int len)
      以适合此类内容处理程序的格式将内容从文档写入给定流。

    • Uses of OutputStream in javax.swing.text.rtf

      Methods in javax.swing.text.rtf with parameters of type OutputStream
      Modifier and Type 方法 描述
      void RTFEditorKit.write​(OutputStream out, Document doc, int pos, int len)
      将内容从文档以适合此类内容处理程序的格式写入给定流。

    • Uses of OutputStream in javax.tools

      Methods in javax.tools that return OutputStream
      Modifier and Type | 方法 | 描述
      OutputStream FileObject.openOutputStream​()
      返回此文件对象的OutputStream。
      OutputStream | ForwardingFileObject.openOutputStream​()
      OutputStream SimpleJavaFileObject.openOutputStream​()
      这个实现总是抛出UnsupportedOperationException 。
      Methods in javax.tools with parameters of type OutputStream
      Modifier and Type 方法 描述
      int Tool.run​(InputStream in, OutputStream out, OutputStream err, String... arguments)
      使用给定的I / O通道和参数运行该工具。

    • Uses of OutputStream in javax.xml.bind

      Methods in javax.xml.bind with parameters of type OutputStream
      Modifier and Type 方法 描述
      static void JAXB.marshal​(Object jaxbObject, OutputStream xml)
      将Java对象树写入XML并将其存储到指定的位置。
      void Marshaller.marshal​(Object jaxbElement, OutputStream os)
      将根据 jaxbElement的内容树 jaxbElement到输出流中。

    • Uses of OutputStream in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type OutputStream
      Modifier and Type | 方法 | 描述
      void | AbstractMarshallerImpl.marshal​(Object obj, OutputStream os)

    • Uses of OutputStream in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type OutputStream
      Modifier and Type 方法 描述
      Data Transform.transform​(Data data, XMLCryptoContext context, OutputStream os)
      使用底层变换算法转换指定的数据。

    • Uses of OutputStream in javax.xml.soap

      Methods in javax.xml.soap with parameters of type OutputStream
      Modifier and Type 方法 描述
      abstract void SOAPMessage.writeTo​(OutputStream out)
      将此 SOAPMessage对象写入给定的输出流。

    • Uses of OutputStream in javax.xml.stream

      Methods in javax.xml.stream with parameters of type OutputStream
      Modifier and Type 方法 描述
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter​(OutputStream stream)
      创建一个写入流的新XMLEventWriter
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter​(OutputStream stream, String encoding)
      创建一个写入流的新XMLEventWriter
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter​(OutputStream stream)
      创建一个写入流的新XMLStreamWriter
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter​(OutputStream stream, String encoding)
      创建一个写入流的新XMLStreamWriter

    • Uses of OutputStream in javax.xml.transform.stream

      Methods in javax.xml.transform.stream that return OutputStream
      Modifier and Type 方法 描述
      OutputStream StreamResult.getOutputStream​()
      获取使用setOutputStream设置的字节流。
      Methods in javax.xml.transform.stream with parameters of type OutputStream
      Modifier and Type 方法 描述
      void StreamResult.setOutputStream​(OutputStream outputStream)
      设置要写入的ByteStream。
      Constructors in javax.xml.transform.stream with parameters of type OutputStream
      Constructor 描述
      StreamResult​(OutputStream outputStream)
      从字节流构造一个StreamResult。

    • Uses of OutputStream in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return OutputStream
      Modifier and Type 方法 描述
      abstract OutputStream HttpExchange.getResponseBody​()
      返回响应主体必须写入的流。

    • Uses of OutputStream in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type OutputStream
      Modifier and Type 方法 描述
      static void Util.forwardExecutionControlAndIO​(ExecutionControl ec, InputStream inStream, OutputStream outStream, Map<String,Consumer<OutputStream>> outputStreamMap, Map<String,Consumer<InputStream>> inputStreamMap)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。
      Method parameters in jdk.jshell.execution with type arguments of type OutputStream
      Modifier and Type 方法 描述
      static void Util.forwardExecutionControlAndIO​(ExecutionControl ec, InputStream inStream, OutputStream outStream, Map<String,Consumer<OutputStream>> outputStreamMap, Map<String,Consumer<InputStream>> inputStreamMap)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。

    • Uses of OutputStream in jdk.security.jarsigner

      Methods in jdk.security.jarsigner with parameters of type OutputStream
      Modifier and Type 方法 描述
      void JarSigner.sign​(ZipFile file, OutputStream os)
      将文件标记为OutputStream 。

    • Uses of OutputStream in org.ietf.jgss

      Methods in org.ietf.jgss with parameters of type OutputStream
      Modifier and Type 方法 描述
      void GSSContext.acceptSecContext​(InputStream inStream, OutputStream outStream)
      由上下文接收方调用，使用流处理来自对等体的令牌。
      void GSSContext.getMIC​(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      使用流来生成包含所提供消息的加密MIC的令牌，以传送到对等应用程序。
      int GSSContext.initSecContext​(InputStream inStream, OutputStream outStream)
      由上下文发起者调用以启动上下文创建阶段， acceptSecContext对等体的 acceptSecContext方法使用流生成的任何令牌。
      void GSSContext.unwrap​(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      在上下文的另一边使用流来处理由 wrap方法生成的令牌。
      void GSSContext.wrap​(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      使用流在已建立的安全上下文中应用每消息安全服务。

    • Uses of OutputStream in org.omg.CORBA_2_3.portable

      Subclasses of OutputStream in org.omg.CORBA_2_3.portable
      Modifier and Type Class 描述
      class  OutputStream
      OutputStream提供了将所有映射的IDL类型写入流的接口。

    • Uses of OutputStream in org.omg.CORBA.portable

      Subclasses of OutputStream in org.omg.CORBA.portable
      Modifier and Type Class 描述
      class  OutputStream
      OuputStream是用于将IDL类型写入CDR元数据流的Java API。

    • Uses of OutputStream in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return OutputStream
      Modifier and Type 方法 描述
      OutputStream LSOutput.getByteStream​()
      表示可写入字节流的语言和绑定依赖类型的属性。
      Methods in org.w3c.dom.ls with parameters of type OutputStream
      Modifier and Type 方法 描述
      void LSOutput.setByteStream​(OutputStream byteStream)
      An attribute of a language and binding dependent type that represents a writable stream of bytes.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.OutputStreamWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.OutputStreamWriter

  • Packages that use OutputStreamWriter
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of OutputStreamWriter in java.io

      Subclasses of OutputStreamWriter in java.io
      Modifier and Type Class 描述
      class  FileWriter
      方便课写字符文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PipedInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PipedInputStream

  • Packages that use PipedInputStream
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of PipedInputStream in java.io

      Methods in java.io with parameters of type PipedInputStream
      Modifier and Type 方法 描述
      void PipedOutputStream.connect​(PipedInputStream snk)
      将此管道输出流连接到接收器。
      Constructors in java.io with parameters of type PipedInputStream
      Constructor 描述
      PipedOutputStream​(PipedInputStream snk)
      创建连接到指定管道输入流的管道输出流。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PipedOutputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PipedOutputStream

  • Packages that use PipedOutputStream
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of PipedOutputStream in java.io

      Methods in java.io with parameters of type PipedOutputStream
      Modifier and Type 方法 描述
      void PipedInputStream.connect​(PipedOutputStream src)
      使此管道输入流连接到管道输出流 src 。
      Constructors in java.io with parameters of type PipedOutputStream
      Constructor 描述
      PipedInputStream​(PipedOutputStream src)
      创建 PipedInputStream ，使其连接到管道输出流 src 。
      PipedInputStream​(PipedOutputStream src, int pipeSize)
      创建一个 PipedInputStream ，使其连接到管道输出流 src并为管道缓冲区使用指定的管道大小。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PipedReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PipedReader

  • Packages that use PipedReader
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of PipedReader in java.io

      Methods in java.io with parameters of type PipedReader
      Modifier and Type 方法 描述
      void PipedWriter.connect​(PipedReader snk)
      将此管道写入器连接到接收器。
      Constructors in java.io with parameters of type PipedReader
      Constructor 描述
      PipedWriter​(PipedReader snk)
      创建连接到指定管道读取器的管道写入器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PipedWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PipedWriter

  • Packages that use PipedWriter
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of PipedWriter in java.io

      Methods in java.io with parameters of type PipedWriter
      Modifier and Type 方法 描述
      void PipedReader.connect​(PipedWriter src)
      使这个管道读取器连接到管道写入器 src 。
      Constructors in java.io with parameters of type PipedWriter
      Constructor 描述
      PipedReader​(PipedWriter src)
      创建一个 PipedReader ，使其连接到管道写入器 src 。
      PipedReader​(PipedWriter src, int pipeSize)
      创建一个 PipedReader ，使其连接到管道写入器 src并为管道缓冲区使用指定的管道大小。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PrintStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PrintStream

  • Packages that use PrintStream
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.spi
    java.util包中类的服务提供者类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。

    • Uses of PrintStream in java.awt

      Methods in java.awt with parameters of type PrintStream
      Modifier and Type 方法 描述
      void Component.list​(PrintStream out)
      将此组件的列表打印到指定的输出流。
      void Component.list​(PrintStream out, int indent)
      从指定的缩进开始列出指定的打印流的列表。
      void Container.list​(PrintStream out, int indent)
      将此容器的列表打印到指定的输出流。

    • Uses of PrintStream in java.io

      Methods in java.io that return PrintStream
      Modifier and Type 方法 描述
      PrintStream PrintStream.append​(char c)
      将指定的字符附加到此输出流。
      PrintStream PrintStream.append​(CharSequence csq)
      将指定的字符序列附加到此输出流。
      PrintStream PrintStream.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此输出流。
      PrintStream PrintStream.format​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流。
      PrintStream PrintStream.format​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流。
      PrintStream PrintStream.printf​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。
      PrintStream PrintStream.printf​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。

    • Uses of PrintStream in java.lang

      Fields in java.lang declared as PrintStream
      Modifier and Type Field 描述
      static PrintStream System.err
      “标准”错误输出流。
      static PrintStream System.out
      “标准”输出流。
      Methods in java.lang with parameters of type PrintStream
      Modifier and Type 方法 描述
      void Throwable.printStackTrace​(PrintStream s)
      将此throwable和其追溯打印到指定的打印流。
      static void System.setErr​(PrintStream err)
      重新分配“标准”错误输出流。
      static void System.setOut​(PrintStream out)
      重新分配“标准”输出流。

    • Uses of PrintStream in java.rmi.server

      Subclasses of PrintStream in java.rmi.server
      Modifier and Type Class 描述
      class  LogStream
      已过时。
      没有替换
      Methods in java.rmi.server that return PrintStream
      Modifier and Type 方法 描述
      static PrintStream LogStream.getDefaultStream​()
      已过时。
      没有替换
      static PrintStream RemoteServer.getLog​()
      返回RMI通话记录的流。
      Methods in java.rmi.server with parameters of type PrintStream
      Modifier and Type 方法 描述
      static void LogStream.setDefaultStream​(PrintStream newDefault)
      已过时。
      没有替换

    • Uses of PrintStream in java.sql

      Methods in java.sql that return PrintStream
      Modifier and Type 方法 描述
      static PrintStream DriverManager.getLogStream​()
      已过时。
      使用getLogWriter
      Methods in java.sql with parameters of type PrintStream
      Modifier and Type 方法 描述
      static void DriverManager.setLogStream​(PrintStream out)
      已过时。
      使用setLogWriter

    • Uses of PrintStream in java.util

      Methods in java.util with parameters of type PrintStream
      Modifier and Type 方法 描述
      void Properties.list​(PrintStream out)
      将此属性列表打印到指定的输出流。
      Constructors in java.util with parameters of type PrintStream
      Constructor 描述
      Formatter​(PrintStream ps)
      使用指定的打印流构造新的格式化程序。

    • Uses of PrintStream in java.util.spi

      Methods in java.util.spi with parameters of type PrintStream
      Modifier and Type 方法 描述
      default int ToolProvider.run​(PrintStream out, PrintStream err, String... args)
      运行该工具的实例，返回零以成功运行。

    • Uses of PrintStream in javax.swing

      Methods in javax.swing that return PrintStream
      Modifier and Type 方法 描述
      static PrintStream DebugGraphics.logStream​()
      返回DebugGraphics记录绘图操作的流。
      Methods in javax.swing with parameters of type PrintStream
      Modifier and Type 方法 描述
      static void DebugGraphics.setLogStream​(PrintStream stream)
      设置DebugGraphics记录绘图操作的流。

    • Uses of PrintStream in javax.swing.text

      Methods in javax.swing.text with parameters of type PrintStream
      Modifier and Type 方法 描述
      void AbstractDocument.AbstractElement.dump​(PrintStream psOut, int indentAmount)
      转储元素层次结构的调试表示。
      void AbstractDocument.dump​(PrintStream out)
      提供诊断转储。

    • Uses of PrintStream in javax.xml.bind

      Methods in javax.xml.bind with parameters of type PrintStream
      Modifier and Type 方法 描述
      void JAXBException.printStackTrace​(PrintStream s)
      打印此JAXBException及其堆栈跟踪（包括链接异常的堆栈跟踪（如果非空））到PrintStream。
      void TypeConstraintException.printStackTrace​(PrintStream s)
      将PrintCryptException及其堆栈跟踪（包括linkedException的堆栈跟踪（如果非空））打印到PrintStream。

    • Uses of PrintStream in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type PrintStream
      Modifier and Type 方法 描述
      void KeySelectorException.printStackTrace​(PrintStream s)
      打印 KeySelectorException ，其回溯和原因回溯到指定的打印流。
      void MarshalException.printStackTrace​(PrintStream s)
      打印 MarshalException ，其回溯和原因回溯到指定的打印流。
      void NoSuchMechanismException.printStackTrace​(PrintStream s)
      打印 NoSuchMechanismException ，其回溯和原因回溯到指定的打印流。
      void URIReferenceException.printStackTrace​(PrintStream s)
      打印 URIReferenceException ，其回溯和原因回溯到指定的打印流。

    • Uses of PrintStream in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type PrintStream
      Modifier and Type 方法 描述
      void TransformException.printStackTrace​(PrintStream s)
      打印 TransformException ，其回溯和原因回溯到指定的打印流。
      void XMLSignatureException.printStackTrace​(PrintStream s)
      打印 XMLSignatureException ，其回溯和原因回溯到指定的打印流。

    • Uses of PrintStream in javax.xml.transform

      Methods in javax.xml.transform with parameters of type PrintStream
      Modifier and Type 方法 描述
      void TransformerException.printStackTrace​(PrintStream s)
      从出现错误的地方打印出痕迹的方法。

    • Uses of PrintStream in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type PrintStream
      Modifier and Type 方法 描述
      void XPathException.printStackTrace​(PrintStream s)
      打印堆栈跟踪到指定的 PrintStream 。

    • Uses of PrintStream in jdk.jshell

      Methods in jdk.jshell with parameters of type PrintStream
      Modifier and Type 方法 描述
      JShell.Builder JShell.Builder.err​(PrintStream err)
      设置运行评估的错误输出（它是 System.err ）。
      JShell.Builder JShell.Builder.out​(PrintStream out)
      设置运行评估的输出（它是 System.out ）。

    • Uses of PrintStream in jdk.jshell.spi

      Methods in jdk.jshell.spi that return PrintStream
      Modifier and Type 方法 描述
      PrintStream ExecutionEnv.userErr​()
      返回用户的错误流。
      PrintStream ExecutionEnv.userOut​()
      返回用户的输出流。

    • Uses of PrintStream in jdk.jshell.tool

      Methods in jdk.jshell.tool with parameters of type PrintStream
      Modifier and Type 方法 描述
      JavaShellToolBuilder JavaShellToolBuilder.err​(PrintStream error)
      设置错误通道。
      JavaShellToolBuilder JavaShellToolBuilder.err​(PrintStream cmdErr, PrintStream userErr)
      设置错误通道。
      JavaShellToolBuilder JavaShellToolBuilder.out​(PrintStream output)
      设置输出通道。
      JavaShellToolBuilder JavaShellToolBuilder.out​(PrintStream cmdOut, PrintStream console, PrintStream userOut)
      设置输出通道。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PrintWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PrintWriter

  • Packages that use PrintWriter
    软件包 描述
    com.sun.tools.javac
    该包提供了 javac工具的传统入口点。
    com.sun.tools.javadoc
    此软件包及其内容已被弃用，可能会在将来的版本中删除。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.spi
    java.util包中类的服务提供者类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。

    • Uses of PrintWriter in com.sun.tools.javac

      Methods in com.sun.tools.javac with parameters of type PrintWriter
      Modifier and Type 方法 描述
      static int Main.compile​(String[] args, PrintWriter out)
      Java编程语言编程器的编程接口javac。

    • Uses of PrintWriter in com.sun.tools.javadoc

      Methods in com.sun.tools.javadoc with parameters of type PrintWriter
      Modifier and Type 方法 描述
      static int Main.execute​(String programName, PrintWriter errWriter, PrintWriter warnWriter, PrintWriter noticeWriter, String defaultDocletClassName, ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int Main.execute​(String programName, PrintWriter errWriter, PrintWriter warnWriter, PrintWriter noticeWriter, String defaultDocletClassName, String... args)
      已过时。
      程式化界面。

    • Uses of PrintWriter in java.awt

      Methods in java.awt with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void Component.list​(PrintWriter out)
      将列表打印到指定的打印作者。
      void Component.list​(PrintWriter out, int indent)
      从指定的缩进开始列出指定的打印作者的列表。
      void Container.list​(PrintWriter out, int indent)
      从指定的缩进开始列出指定的打印作者的列表。

    • Uses of PrintWriter in java.io

      Methods in java.io that return PrintWriter
      Modifier and Type 方法 描述
      PrintWriter PrintWriter.append​(char c)
      将指定的字符附加到此作者。
      PrintWriter PrintWriter.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      PrintWriter PrintWriter.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      PrintWriter PrintWriter.format​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此写入程序。
      PrintWriter PrintWriter.format​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入此写入程序。
      PrintWriter PrintWriter.printf​(String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。
      PrintWriter PrintWriter.printf​(Locale l, String format, Object... args)
      使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。
      PrintWriter Console.writer​()
      检索与此控制台关联的唯一的PrintWriter对象。

    • Uses of PrintWriter in java.lang

      Methods in java.lang with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void Throwable.printStackTrace​(PrintWriter s)
      将此throwable和其追溯打印到指定的打印作者。

    • Uses of PrintWriter in java.sql

      Methods in java.sql that return PrintWriter
      Modifier and Type 方法 描述
      static PrintWriter DriverManager.getLogWriter​()
      检索日志记录器。
      Methods in java.sql with parameters of type PrintWriter
      Modifier and Type 方法 描述
      static void DriverManager.setLogWriter​(PrintWriter out)
      设置 DriverManager和所有驱动程序使用的记录/跟踪 PrintWriter对象。

    • Uses of PrintWriter in java.util

      Methods in java.util with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void Properties.list​(PrintWriter out)
      将此属性列表打印到指定的输出流。

    • Uses of PrintWriter in java.util.spi

      Methods in java.util.spi with parameters of type PrintWriter
      Modifier and Type 方法 描述
      int ToolProvider.run​(PrintWriter out, PrintWriter err, String... args)
      运行该工具的实例，返回零以成功运行。

    • Uses of PrintWriter in javax.sql

      Methods in javax.sql that return PrintWriter
      Modifier and Type 方法 描述
      PrintWriter CommonDataSource.getLogWriter​()
      检索此 DataSource对象的日志记录器。
      PrintWriter ConnectionPoolDataSource.getLogWriter​()
      检索此 DataSource对象的日志记录器。
      PrintWriter DataSource.getLogWriter​()
      检索此 DataSource对象的日志记录器。
      PrintWriter XADataSource.getLogWriter​()
      检索此 DataSource对象的日志记录器。
      Methods in javax.sql with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void CommonDataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。
      void ConnectionPoolDataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。
      void DataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。
      void XADataSource.setLogWriter​(PrintWriter out)
      将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。

    • Uses of PrintWriter in javax.xml.bind

      Methods in javax.xml.bind with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void JAXBException.printStackTrace​(PrintWriter s)
      打印此JAXBException及其堆栈跟踪（包括链接异常的堆栈跟踪（如果非空））到PrintWriter。

    • Uses of PrintWriter in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void KeySelectorException.printStackTrace​(PrintWriter s)
      打印 KeySelectorException ，它的回溯和原因的回溯到指定的打印作者。
      void MarshalException.printStackTrace​(PrintWriter s)
      打印 MarshalException ，其回溯和原因回溯到指定的打印作者。
      void NoSuchMechanismException.printStackTrace​(PrintWriter s)
      打印 NoSuchMechanismException ，其回溯和原因回溯到指定的打印作者。
      void URIReferenceException.printStackTrace​(PrintWriter s)
      打印 URIReferenceException ，其回溯和原因回溯到指定的打印作者。

    • Uses of PrintWriter in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void TransformException.printStackTrace​(PrintWriter s)
      打印 TransformException ，其回溯和原因的回溯到指定的打印作者。
      void XMLSignatureException.printStackTrace​(PrintWriter s)
      打印 XMLSignatureException ，其回溯和原因回溯到指定的打印作者。

    • Uses of PrintWriter in javax.xml.transform

      Methods in javax.xml.transform with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void TransformerException.printStackTrace​(PrintWriter s)
      从出现错误的地方打印出痕迹的方法。

    • Uses of PrintWriter in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type PrintWriter
      Modifier and Type 方法 描述
      void XPathException.printStackTrace​(PrintWriter s)
      打印堆栈跟踪到指定的 PrintWriter 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PushbackInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PushbackInputStream

No usage of java.io.PushbackInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.PushbackReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.PushbackReader

No usage of java.io.PushbackReader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.RandomAccessFile (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.RandomAccessFile

  • Packages that use RandomAccessFile
    软件包 描述
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

    • Uses of RandomAccessFile in javax.imageio.stream

      Constructors in javax.imageio.stream with parameters of type RandomAccessFile
      Constructor 描述
      FileImageInputStream​(RandomAccessFile raf)
      构造一个 FileImageInputStream ，它将从给定的 RandomAccessFile读取。
      FileImageOutputStream​(RandomAccessFile raf)
      构造一个 FileImageOutputStream ，它将写入给定的 RandomAccessFile 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.Reader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.Reader

  • Packages that use Reader
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform.stream
    提供流和URI特定的转换类。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方法。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.xml.sax
    提供核心SAX API。

    • Uses of Reader in java.awt.datatransfer

      Methods in java.awt.datatransfer that return Reader
      Modifier and Type 方法 描述
      Reader DataFlavor.getReaderForText​(Transferable transferable)
      获取一个文本风味的阅读器，如有必要，解码为预期的字符集（编码）。

    • Uses of Reader in java.io

      Subclasses of Reader in java.io
      Modifier and Type Class 描述
      class  BufferedReader
      从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
      class  CharArrayReader
      该类实现了一个字符缓冲区，可以用作字符输入流。
      class  FileReader
      阅读字符文件的便利课。
      class  FilterReader
      用于读取过滤后的字符流的抽象类。
      class  InputStreamReader
      InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。
      class  LineNumberReader
      缓冲字符输入流，跟踪行号。
      class  PipedReader
      流水字符输入流。
      class  PushbackReader
      一个字符流读取器，允许将字符推回到流中。
      class  StringReader
      一个字符流，其源是一个字符串。
      Fields in java.io declared as Reader
      Modifier and Type Field 描述
      protected Reader FilterReader.in
      底层字符输入流。
      Methods in java.io that return Reader
      Modifier and Type 方法 描述
      Reader Console.reader​()
      检索与此控制台关联的唯一的Reader对象。
      Constructors in java.io with parameters of type Reader
      Constructor 描述
      BufferedReader​(Reader in)
      创建使用默认大小的输入缓冲区的缓冲字符输入流。
      BufferedReader​(Reader in, int sz)
      创建使用指定大小的输入缓冲区的缓冲字符输入流。
      FilterReader​(Reader in)
      创建一个新的过滤阅读器。
      LineNumberReader​(Reader in)
      使用默认的输入缓冲区大小创建一个新的行号阅读器。
      LineNumberReader​(Reader in, int sz)
      创建一个新的行号阅读器，将字符读入给定大小的缓冲区。
      PushbackReader​(Reader in)
      用一个字符的后置缓冲区创建一个新的推回阅读器。
      PushbackReader​(Reader in, int size)
      使用给定大小的推回缓冲区创建一个新的推回阅读器。
      StreamTokenizer​(Reader r)
      创建一个解析给定字符流的tokenizer。

    • Uses of Reader in java.nio.channels

      Methods in java.nio.channels that return Reader
      Modifier and Type 方法 描述
      static Reader Channels.newReader​(ReadableByteChannel ch, String csName)
      构造一个读取器，根据命名的字符集解码来自给定通道的字节。
      static Reader Channels.newReader​(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap)
      构造一个读取器，使用给定的解码器解码来自给定通道的字节。

    • Uses of Reader in java.sql

      Methods in java.sql that return Reader
      Modifier and Type 方法 描述
      Reader CallableStatement.getCharacterStream​(int parameterIndex)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader CallableStatement.getCharacterStream​(String parameterName)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader Clob.getCharacterStream​()
      检索 CLOB由该指定值 Clob对象作为 java.io.Reader对象（或作为字符流）。
      Reader Clob.getCharacterStream​(long pos, long length)
      返回包含部分 Clob值的 Reader对象，以pos指定的字符开头，长度为长度字符。
      Reader ResultSet.getCharacterStream​(int columnIndex)
      检索 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。
      Reader ResultSet.getCharacterStream​(String columnLabel)
      以 ResultSet对象的形式 java.io.Reader此 ResultSet对象的当前行中指定列的值。
      Reader SQLXML.getCharacterStream​()
      将此SQLXML实例指定的XML值作为java.io.Reader对象检索。
      Reader CallableStatement.getNCharacterStream​(int parameterIndex)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader CallableStatement.getNCharacterStream​(String parameterName)
      以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。
      Reader ResultSet.getNCharacterStream​(int columnIndex)
      检索 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。
      Reader ResultSet.getNCharacterStream​(String columnLabel)
      检索 ResultSet对象当前行中指定列的值作为 java.io.Reader对象。
      Reader SQLInput.readCharacterStream​()
      读取流中的下一个属性，并将其作为Unicode字符流返回。
      Methods in java.sql with parameters of type Reader
      Modifier and Type 方法 描述
      void CallableStatement.setCharacterStream​(String parameterName, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void CallableStatement.setCharacterStream​(String parameterName, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void CallableStatement.setCharacterStream​(String parameterName, Reader reader, long length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void PreparedStatement.setCharacterStream​(int parameterIndex, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void PreparedStatement.setCharacterStream​(int parameterIndex, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void PreparedStatement.setCharacterStream​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void CallableStatement.setClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNCharacterStream​(String parameterName, Reader value)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNCharacterStream​(String parameterName, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNCharacterStream​(int parameterIndex, Reader value)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNCharacterStream​(int parameterIndex, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void CallableStatement.setNClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void PreparedStatement.setNClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void ResultSet.updateCharacterStream​(int columnIndex, Reader x)
      使用字符流值更新指定的列。
      void ResultSet.updateCharacterStream​(int columnIndex, Reader x, int length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateCharacterStream​(int columnIndex, Reader x, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateCharacterStream​(String columnLabel, Reader reader)
      使用字符流值更新指定的列。
      void ResultSet.updateCharacterStream​(String columnLabel, Reader reader, int length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateCharacterStream​(String columnLabel, Reader reader, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateClob​(int columnIndex, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void ResultSet.updateClob​(int columnIndex, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符数。
      void ResultSet.updateClob​(String columnLabel, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void ResultSet.updateClob​(String columnLabel, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的字符长度。
      void ResultSet.updateNCharacterStream​(int columnIndex, Reader x)
      使用字符流值更新指定的列。
      void ResultSet.updateNCharacterStream​(int columnIndex, Reader x, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateNCharacterStream​(String columnLabel, Reader reader)
      使用字符流值更新指定的列。
      void ResultSet.updateNCharacterStream​(String columnLabel, Reader reader, long length)
      使用字符流值更新指定的列，该值将具有指定的字节数。
      void ResultSet.updateNClob​(int columnIndex, Reader reader)
      使用给定的 Reader更新指定的列。根据需要将从流中读取数据，直到达到流出端。
      void ResultSet.updateNClob​(int columnIndex, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的长度的字符数。
      void ResultSet.updateNClob​(String columnLabel, Reader reader)
      使用给定的 Reader对象更新指定的列。
      void ResultSet.updateNClob​(String columnLabel, Reader reader, long length)
      使用给定的 Reader对象更新指定的列，这是给定的长度的字符数。
      void SQLOutput.writeCharacterStream​(Reader x)
      将下一个属性作为Unicode字符流写入流。

    • Uses of Reader in java.util

      Methods in java.util with parameters of type Reader
      Modifier and Type 方法 描述
      void Properties.load​(Reader reader)
      以简单的线性格式从输入字符流读取属性列表（关键字和元素对）。
      Constructors in java.util with parameters of type Reader
      Constructor 描述
      PropertyResourceBundle​(Reader reader)
      从Reader创建属性资源包。

    • Uses of Reader in javax.print

      Methods in javax.print that return Reader
      Modifier and Type 方法 描述
      Reader Doc.getReaderForText​()
      获取从该文档中提取字符打印数据的读取器。
      Reader SimpleDoc.getReaderForText​()
      获取从该文档中提取字符打印数据的读取器。

    • Uses of Reader in javax.script

      Fields in javax.script declared as Reader
      Modifier and Type Field 描述
      protected Reader SimpleScriptContext.reader
      这是用于从脚本输入的读者。
      Methods in javax.script that return Reader
      Modifier and Type 方法 描述
      Reader ScriptContext.getReader​()
      返回一个 Reader ，由脚本用来读取输入。
      Reader SimpleScriptContext.getReader​()
      返回一个 Reader ，由脚本用来读取输入。
      Methods in javax.script with parameters of type Reader
      Modifier and Type 方法 描述
      CompiledScript Compilable.compile​(Reader script)
      编译脚本（源码为 Reader ）供以后执行。
      Object AbstractScriptEngine.eval​(Reader reader)
      eval(Reader)调用摘要 eval(Reader, ScriptContext)传递的值为 context字段。
      Object AbstractScriptEngine.eval​(Reader reader, Bindings bindings)
      eval(Reader, Bindings)打电话给抽象的 eval(Reader, ScriptContext)方法，传递一个 ScriptContext ，其中 ScriptContext的读者，作者和绑定，其他 ENGINE_SCOPE与受保护的 context字段的成员相同。
      Object ScriptEngine.eval​(Reader reader)
      相同 eval(String)除了将脚本的源被提供为 Reader
      Object ScriptEngine.eval​(Reader reader, Bindings n)
      同 eval(String, Bindings)除了脚本的源是以提供 Reader 。
      Object ScriptEngine.eval​(Reader reader, ScriptContext context)
      与 eval(String, ScriptContext)相同，其中脚本的来源从 Reader读取。
      void ScriptContext.setReader​(Reader reader)
      设置 Reader的脚本来读取输入。
      void SimpleScriptContext.setReader​(Reader reader)
      设置 Reader脚本以读取输入。

    • Uses of Reader in javax.sql

      Methods in javax.sql with parameters of type Reader
      Modifier and Type 方法 描述
      void RowSet.setCharacterStream​(int parameterIndex, Reader reader)
      将此 RowSet对象的命令中的指定参数设置为给定的 Reader对象。
      void RowSet.setCharacterStream​(int parameterIndex, Reader reader, int length)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.io.Reader值。
      void RowSet.setCharacterStream​(String parameterName, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void RowSet.setCharacterStream​(String parameterName, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void RowSet.setClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNCharacterStream​(int parameterIndex, Reader value)
      将此 RowSet对象的命令中的指定参数设置为 Reader对象。
      void RowSet.setNCharacterStream​(int parameterIndex, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNCharacterStream​(String parameterName, Reader value)
      将指定的参数设置为 Reader对象。
      void RowSet.setNCharacterStream​(String parameterName, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void RowSet.setNClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。

    • Uses of Reader in javax.sql.rowset

      Fields in javax.sql.rowset declared as Reader
      Modifier and Type Field 描述
      protected Reader BaseRowSet.charStream
      Reader对象将通过方法 getCharacterStream返回，这是在 ResultSet界面中指定的。
      Methods in javax.sql.rowset with parameters of type Reader
      Modifier and Type 方法 描述
      void WebRowSet.readXml​(Reader reader)
      读取 WebRowSet在从给定的XML格式对象 Reader对象。
      void BaseRowSet.setCharacterStream​(int parameterIndex, Reader reader)
      将此 RowSet对象的命令中的指定参数设置为给定的 Reader对象。
      void BaseRowSet.setCharacterStream​(int parameterIndex, Reader reader, int length)
      将指定的参数设置为给定的 java.io.Reader对象，该对象将具有指定的字符数。
      void BaseRowSet.setCharacterStream​(String parameterName, Reader reader)
      将指定的参数设置为给定的 Reader对象。
      void BaseRowSet.setCharacterStream​(String parameterName, Reader reader, int length)
      将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。
      void BaseRowSet.setClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNCharacterStream​(int parameterIndex, Reader value)
      将此 RowSet对象的命令中的指定参数设置为 Reader对象。
      void BaseRowSet.setNCharacterStream​(int parameterIndex, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNCharacterStream​(String parameterName, Reader value)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNCharacterStream​(String parameterName, Reader value, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(int parameterIndex, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(int parameterIndex, Reader reader, long length)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(String parameterName, Reader reader)
      将指定的参数设置为 Reader对象。
      void BaseRowSet.setNClob​(String parameterName, Reader reader, long length)
      将指定的参数设置为 Reader对象。

    • Uses of Reader in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return Reader
      Modifier and Type 方法 描述
      Reader SerialClob.getCharacterStream​()
      将此 SerialClob对象的数据作为Unicode字符流返回。
      Reader SerialClob.getCharacterStream​(long pos, long length)
      返回一个包含部分 SerialClob值的 Reader对象，以pos指定的字符开头，长度为长度字符。
      Reader SQLInputImpl.readCharacterStream​()
      将此 SQLInputImpl对象中的下一个属性作为Unicode字符流检索。
      Methods in javax.sql.rowset.serial with parameters of type Reader
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeCharacterStream​(Reader x)
      将Unicode字符串写入此 SQLOutputImpl对象。

    • Uses of Reader in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi with parameters of type Reader
      Modifier and Type 方法 描述
      void XmlReader.readXML​(WebRowSet caller, Reader reader)
      从XML格式的给定输入流中读取和解析给定的 WebRowSet对象。

    • Uses of Reader in javax.swing.text

      Methods in javax.swing.text with parameters of type Reader
      Modifier and Type 方法 描述
      void DefaultEditorKit.read​(Reader in, Document doc, int pos)
      插入来自给定流的内容，将被视为纯文本。
      abstract void EditorKit.read​(Reader in, Document doc, int pos)
      插入来自给定流的内容，该内容预计以适合此类内容处理程序的格式。
      void JTextComponent.read​(Reader in, Object desc)
      从流初始化。

    • Uses of Reader in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Reader
      Modifier and Type 方法 描述
      void StyleSheet.loadRules​(Reader in, URL ref)
      加载一组以CSS1语法指定的规则。
      abstract void HTMLEditorKit.Parser.parse​(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      解析给定的流，并使用解析的结果驱动给定的回调。
      void HTMLEditorKit.read​(Reader in, Document doc, int pos)
      从给定的流插入内容。

    • Uses of Reader in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser with parameters of type Reader
      Modifier and Type | 方法 | 描述
      void DocumentParser.parse​(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
      解析一个HTML流，给出一个DTD。
      void Parser.parse​(Reader in)
      解析一个HTML流，给出一个DTD。
      void | ParserDelegator.parse​(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)

    • Uses of Reader in javax.swing.text.rtf

      Methods in javax.swing.text.rtf with parameters of type Reader
      Modifier and Type 方法 描述
      void RTFEditorKit.read​(Reader in, Document doc, int pos)
      从给定的流中插入内容，将被视为纯文本。

    • Uses of Reader in javax.tools

      Methods in javax.tools that return Reader
      Modifier and Type | 方法 | 描述
      Reader FileObject.openReader​(boolean ignoreEncodingErrors)
      返回此对象的读取器。
      Reader | ForwardingFileObject.openReader​(boolean ignoreEncodingErrors)
      Reader SimpleJavaFileObject.openReader​(boolean ignoreEncodingErrors)
      将 SimpleJavaFileObject.getCharContent(boolean)的结果 包装在阅读器中。

    • Uses of Reader in javax.xml.bind

      Methods in javax.xml.bind with parameters of type Reader
      Modifier and Type 方法 描述
      static <T> T JAXB.unmarshal​(Reader xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      Object Unmarshaller.unmarshal​(Reader reader)
      从指定的Reader中解组XML数据并返回生成的内容树。

    • Uses of Reader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type Reader
      Modifier and Type | 方法 | 描述
      Object | AbstractUnmarshallerImpl.unmarshal​(Reader reader)

    • Uses of Reader in javax.xml.stream

      Methods in javax.xml.stream with parameters of type Reader
      Modifier and Type 方法 描述
      abstract XMLEventReader XMLInputFactory.createXMLEventReader​(Reader reader)
      从阅读器创建一个新的XMLEventReader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader​(String systemId, Reader reader)
      从阅读器创建一个新的XMLEventReader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader​(Reader reader)
      从阅读器创建一个新的XMLStreamReader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader​(String systemId, Reader reader)
      从java.io.InputStream创建一个新的XMLStreamReader

    • Uses of Reader in javax.xml.transform.stream

      Methods in javax.xml.transform.stream that return Reader
      Modifier and Type 方法 描述
      Reader StreamSource.getReader​()
      获取用setReader设置的字符流。
      Methods in javax.xml.transform.stream with parameters of type Reader
      Modifier and Type 方法 描述
      void StreamSource.setReader​(Reader reader)
      将输入设置为字符读取器。
      Constructors in javax.xml.transform.stream with parameters of type Reader
      Constructor 描述
      StreamSource​(Reader reader)
      从字符读取器构造一个StreamSource。
      StreamSource​(Reader reader, String systemId)
      从字符读取器构造一个StreamSource。

    • Uses of Reader in jdk.nashorn.api.scripting

      Subclasses of Reader in jdk.nashorn.api.scripting
      Modifier and Type Class 描述
      class  URLReader
      从URL读取的读者。
      Methods in jdk.nashorn.api.scripting with parameters of type Reader
      Modifier and Type | 方法 | 描述
      CompiledScript | NashornScriptEngine.compile​(Reader reader)
      Object | NashornScriptEngine.eval​(Reader reader, ScriptContext ctxt)

    • Uses of Reader in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree with parameters of type Reader
      Modifier and Type 方法 描述
      CompilationUnitTree Parser.parse​(String name, Reader reader, DiagnosticListener listener)
      解读读者并返回编译单元树

    • Uses of Reader in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Reader
      Modifier and Type 方法 描述
      Reader LSInput.getCharacterStream​()
      一种表示16位单位流的语言和绑定依赖类型的属性。
      Methods in org.w3c.dom.ls with parameters of type Reader
      Modifier and Type 方法 描述
      void LSInput.setCharacterStream​(Reader characterStream)
      一种表示16位单位流的语言和绑定依赖类型的属性。

    • Uses of Reader in org.xml.sax

      Methods in org.xml.sax that return Reader
      Modifier and Type 方法 描述
      Reader InputSource.getCharacterStream​()
      获取此输入源的字符流。
      Methods in org.xml.sax with parameters of type Reader
      Modifier and Type 方法 描述
      void InputSource.setCharacterStream​(Reader characterStream)
      设置此输入源的字符流。
      Constructors in org.xml.sax with parameters of type Reader
      Constructor 描述
      InputSource​(Reader characterStream)
      创建一个带有字符流的新输入源。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.SequenceInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.SequenceInputStream

No usage of java.io.SequenceInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.SerializablePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.SerializablePermission

  • Packages that use SerializablePermission
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of SerializablePermission in java.io

      Fields in java.io declared as SerializablePermission
      Modifier and Type Field 描述
      static SerializablePermission ObjectStreamConstants.SERIAL_FILTER_PERMISSION
      启用设置过程范围的串行过滤器。
      static SerializablePermission ObjectStreamConstants.SUBCLASS_IMPLEMENTATION_PERMISSION
      启用覆盖readObject和writeObject。
      static SerializablePermission ObjectStreamConstants.SUBSTITUTION_PERMISSION
      在序列化/反序列化期间可以使一个对象替换为另一个对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.StreamCorruptedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.StreamCorruptedException

  • Packages that use StreamCorruptedException
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of StreamCorruptedException in java.io

      Methods in java.io that throw StreamCorruptedException
      Modifier and Type 方法 描述
      protected void ObjectInputStream.readStreamHeader​()
      提供了readStreamHeader方法来允许子类读取和验证自己的流标题。

    • Uses of StreamCorruptedException in java.rmi.server

      Methods in java.rmi.server that throw StreamCorruptedException
      Modifier and Type 方法 描述
      ObjectOutput RemoteCall.getResultStream​(boolean success)
      已过时。
      没有替换
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.StreamTokenizer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.StreamTokenizer

No usage of java.io.StreamTokenizer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.StringBufferInputStream (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.StringBufferInputStream

No usage of java.io.StringBufferInputStream
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.StringReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.StringReader

No usage of java.io.StringReader
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.StringWriter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.StringWriter

  • Packages that use StringWriter
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of StringWriter in java.io

      Methods in java.io that return StringWriter
      Modifier and Type 方法 描述
      StringWriter StringWriter.append​(char c)
      将指定的字符附加到此作者。
      StringWriter StringWriter.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      StringWriter StringWriter.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.SyncFailedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.SyncFailedException

  • Packages that use SyncFailedException
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of SyncFailedException in java.io

      Methods in java.io that throw SyncFailedException
      Modifier and Type 方法 描述
      void FileDescriptor.sync​()
      强制所有系统缓冲区与底层设备同步。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.UncheckedIOException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.UncheckedIOException

No usage of java.io.UncheckedIOException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.UnsupportedEncodingException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.UnsupportedEncodingException

  • Packages that use UnsupportedEncodingException
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。

    • Uses of UnsupportedEncodingException in java.io

      Methods in java.io that throw UnsupportedEncodingException
      Modifier and Type 方法 描述
      String ByteArrayOutputStream.toString​(String charsetName)
      通过使用命名为charset对字节进行解码，将缓冲区的内容转换为字符串。
      Constructors in java.io that throw UnsupportedEncodingException
      Constructor 描述
      InputStreamReader​(InputStream in, String charsetName)
      创建一个使用命名字符集的InputStreamReader。
      OutputStreamWriter​(OutputStream out, String charsetName)
      创建一个使用命名字符集的OutputStreamWriter。
      PrintStream​(File file, String csn)
      使用指定的文件和字符集创建新的打印流，而不需要自动换行。
      PrintStream​(OutputStream out, boolean autoFlush, String encoding)
      创建一个新的打印流。
      PrintStream​(String fileName, String csn)
      创建一个新的打印流，不需要自动换行，具有指定的文件名和字符集。
      PrintWriter​(File file, String csn)
      使用指定的文件和字符集创建一个新的PrintWriter，而不需要自动进行线条刷新。
      PrintWriter​(String fileName, String csn)
      使用指定的文件名和字符集创建一个新的PrintWriter，而不需要自动线路刷新。

    • Uses of UnsupportedEncodingException in java.lang

      Methods in java.lang that throw UnsupportedEncodingException
      Modifier and Type 方法 描述
      byte[] String.getBytes​(String charsetName)
      使用命名的charset将此 String编码为字节序列，将结果存储到新的字节数组中。
      Constructors in java.lang that throw UnsupportedEncodingException
      Constructor 描述
      String​(byte[] bytes, int offset, int length, String charsetName)
      通过使用指定的字符集对指定的字节 String进行解码来构造新的 String 。
      String​(byte[] bytes, String charsetName)
      构造一个新的String由指定用指定的字节的数组解码charset 。

    • Uses of UnsupportedEncodingException in java.net

      Methods in java.net that throw UnsupportedEncodingException
      Modifier and Type 方法 描述
      static String URLDecoder.decode​(String s, String enc)
      使用特定的编码方案解码 application/x-www-form-urlencoded字符串。
      static String URLEncoder.encode​(String s, String enc)
      使用特定的编码方案将字符串转换为 application/x-www-form-urlencoded格式。

    • Uses of UnsupportedEncodingException in java.util

      Constructors in java.util that throw UnsupportedEncodingException
      Constructor 描述
      Formatter​(File file, String csn)
      使用指定的文件和字符集构造一个新的格式化程序。
      Formatter​(File file, String csn, Locale l)
      使用指定的文件，字符集和区域设置构造一个新的格式化程序。
      Formatter​(OutputStream os, String csn)
      使用指定的输出流和字符集构造一个新的格式化程序。
      Formatter​(OutputStream os, String csn, Locale l)
      使用指定的输出流，字符集和区域设置构造一个新的格式化程序。
      Formatter​(String fileName, String csn)
      构造具有指定文件名和字符集的新格式化程序。
      Formatter​(String fileName, String csn, Locale l)
      构造具有指定文件名，字符集和区域设置的新格式化程序。

    • Uses of UnsupportedEncodingException in java.util.logging

      Methods in java.util.logging that throw UnsupportedEncodingException
      Modifier and Type 方法 描述
      void Handler.setEncoding​(String encoding)
      设置此 Handler使用的字符编码。
      void StreamHandler.setEncoding​(String encoding)
      设置（或更改）此 Handler使用的字符编码。

    • Uses of UnsupportedEncodingException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that throw UnsupportedEncodingException
      Modifier and Type 方法 描述
      protected String AbstractMarshallerImpl.getJavaEncoding​(String encoding)
      从IANA名称获取相应的Java编码名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.UTFDataFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.UTFDataFormatException

No usage of java.io.UTFDataFormatException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.WriteAbortedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.WriteAbortedException

No usage of java.io.WriteAbortedException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.io.Writer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.io.Writer

  • Packages that use Writer
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供者使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.stream.events
    定义Streaming API for XML（StAX）的事件接口。
    javax.xml.transform.stream
    提供流和URI特定的转换类。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。

    • Uses of Writer in java.io

      Subclasses of Writer in java.io
      Modifier and Type Class 描述
      class  BufferedWriter
      将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
      class  CharArrayWriter
      该类实现了可以用作Writer的字符缓冲区。
      class  FileWriter
      方便课写字符文件。
      class  FilterWriter
      用于编写过滤后的字符流的抽象类。
      class  OutputStreamWriter
      OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入的字符编码为字节。
      class  PipedWriter
      流水字符输出流。
      class  PrintWriter
      将对象的格式表示打印到文本输出流。
      class  StringWriter
      在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。
      Fields in java.io declared as Writer
      Modifier and Type Field 描述
      protected Writer FilterWriter.out
      底层字符输出流。
      protected Writer PrintWriter.out
      这个 PrintWriter的底层字符输出流。
      Methods in java.io that return Writer
      Modifier and Type | 方法 | 描述
      Writer | OutputStreamWriter.append​(CharSequence csq)
      Writer | OutputStreamWriter.append​(CharSequence csq, int start, int end)
      Writer Writer.append​(char c)
      将指定的字符附加到此作者。
      Writer Writer.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      Writer Writer.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      Methods in java.io with parameters of type Writer
      Modifier and Type 方法 描述
      void CharArrayWriter.writeTo​(Writer out)
      将缓冲区的内容写入另一个字符流。
      Constructors in java.io with parameters of type Writer
      Constructor 描述
      BufferedWriter​(Writer out)
      创建使用默认大小的输出缓冲区的缓冲字符输出流。
      BufferedWriter​(Writer out, int sz)
      创建一个新的缓冲字符输出流，使用给定大小的输出缓冲区。
      FilterWriter​(Writer out)
      创建一个新的过滤的作者。
      PrintWriter​(Writer out)
      创建一个新的PrintWriter，没有自动线冲洗。
      PrintWriter​(Writer out, boolean autoFlush)
      创建一个新的PrintWriter。

    • Uses of Writer in java.nio.channels

      Methods in java.nio.channels that return Writer
      Modifier and Type 方法 描述
      static Writer Channels.newWriter​(WritableByteChannel ch, String csName)
      构造一个根据命名的字符集对字符进行编码的写入程序，并将生成的字节写入给定的通道。
      static Writer Channels.newWriter​(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap)
      构造一个使用给定编码器编码字符的写入器，并将生成的字节写入给定的通道。

    • Uses of Writer in java.sql

      Methods in java.sql that return Writer
      Modifier and Type 方法 描述
      Writer Clob.setCharacterStream​(long pos)
      检索要用于将Unicode字符流写入 Clob对象表示的位置 pos处的 CLOB值的流。
      Writer SQLXML.setCharacterStream​()
      检索要用于写入此SQLXML实例所代表的XML值的流。

    • Uses of Writer in java.util

      Methods in java.util with parameters of type Writer
      Modifier and Type 方法 描述
      void Properties.store​(Writer writer, String comments)
      将此属性列表（键和元素对）写入此 Properties表格中，以适合使用 load(Reader)方法的格式输出到输出字符流。

    • Uses of Writer in javax.lang.model.util

      Methods in javax.lang.model.util with parameters of type Writer
      Modifier and Type 方法 描述
      void Elements.printElements​(Writer w, Element... elements)
      以指定的顺序将元素的表示打印到给定的作者。

    • Uses of Writer in javax.script

      Fields in javax.script declared as Writer
      Modifier and Type Field 描述
      protected Writer SimpleScriptContext.errorWriter
      这是用于从脚本输出错误的作者。
      protected Writer SimpleScriptContext.writer
      这是用于从脚本输出的作者。
      Methods in javax.script that return Writer
      Modifier and Type 方法 描述
      Writer ScriptContext.getErrorWriter​()
      返回 Writer用于显示错误输出。
      Writer SimpleScriptContext.getErrorWriter​()
      返回 Writer用于显示错误输出。
      Writer ScriptContext.getWriter​()
      返回显示输出时要使用的脚本的 Writer 。
      Writer SimpleScriptContext.getWriter​()
      返回 Writer用于显示输出时使用的脚本。
      Methods in javax.script with parameters of type Writer
      Modifier and Type 方法 描述
      void ScriptContext.setErrorWriter​(Writer writer)
      设置 Writer用于显示错误输出。
      void SimpleScriptContext.setErrorWriter​(Writer writer)
      设置 Writer用于显示错误输出。
      void ScriptContext.setWriter​(Writer writer)
      设置显示输出时要使用的脚本的 Writer 。
      void SimpleScriptContext.setWriter​(Writer writer)
      设置显示输出时要使用的脚本的 Writer 。

    • Uses of Writer in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type Writer
      Modifier and Type 方法 描述
      void WebRowSet.writeXml​(Writer writer)
      将此 WebRowSet对象的数据，属性和元数据以XML格式写入给定的 Writer对象。
      void WebRowSet.writeXml​(ResultSet rs, Writer writer)
      使用给定的 ResultSet对象的内容填充此 WebRowSet对象，并将其数据，属性和元数据以XML格式写入给定的 Writer对象。

    • Uses of Writer in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return Writer
      Modifier and Type 方法 描述
      Writer SerialClob.setCharacterStream​(long pos)
      检索要用于将Unicode字符流写入 SerialClob对象表示的位置 pos处的 CLOB值的流。

    • Uses of Writer in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi with parameters of type Writer
      Modifier and Type 方法 描述
      void XmlWriter.writeXML​(WebRowSet caller, Writer writer)
      将给定的 WebRowSet对象写入指定的 java.io.Writer输出流作为XML文档。

    • Uses of Writer in javax.swing.text

      Methods in javax.swing.text that return Writer
      Modifier and Type 方法 描述
      protected Writer AbstractWriter.getWriter​()
      返回用于输出内容的Writer。
      Methods in javax.swing.text with parameters of type Writer
      Modifier and Type 方法 描述
      void DefaultEditorKit.write​(Writer out, Document doc, int pos, int len)
      将内容从文档写入给定的流作为纯文本。
      abstract void EditorKit.write​(Writer out, Document doc, int pos, int len)
      以适合此类内容处理程序的格式将内容从文档写入给定流。
      void JTextComponent.write​(Writer out)
      将模型的内容存储到给定的流中。
      Constructors in javax.swing.text with parameters of type Writer
      Constructor 描述
      AbstractWriter​(Writer w, Document doc)
      创建一个新的AbstractWriter。
      AbstractWriter​(Writer w, Document doc, int pos, int len)
      创建一个新的AbstractWriter。
      AbstractWriter​(Writer w, Element root)
      创建一个新的AbstractWriter。
      AbstractWriter​(Writer w, Element root, int pos, int len)
      创建一个新的AbstractWriter。

    • Uses of Writer in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Writer
      Modifier and Type 方法 描述
      void HTMLEditorKit.write​(Writer out, Document doc, int pos, int len)
      将内容从文档以适合此类内容处理程序的格式写入给定流。
      Constructors in javax.swing.text.html with parameters of type Writer
      Constructor 描述
      HTMLWriter​(Writer w, HTMLDocument doc)
      创建一个新的HTMLWriter。
      HTMLWriter​(Writer w, HTMLDocument doc, int pos, int len)
      创建一个新的HTMLWriter。
      MinimalHTMLWriter​(Writer w, StyledDocument doc)
      创建一个新的MinimalHTMLWriter。
      MinimalHTMLWriter​(Writer w, StyledDocument doc, int pos, int len)
      创建一个新的MinimalHTMLWriter。

    • Uses of Writer in javax.swing.text.rtf

      Methods in javax.swing.text.rtf with parameters of type Writer
      Modifier and Type 方法 描述
      void RTFEditorKit.write​(Writer out, Document doc, int pos, int len)
      将内容从文档写入给定流作为纯文本。

    • Uses of Writer in javax.tools

      Methods in javax.tools that return Writer
      Modifier and Type | 方法 | 描述
      Writer FileObject.openWriter​()
      返回此文件对象的Writer。
      Writer | ForwardingFileObject.openWriter​()
      Writer SimpleJavaFileObject.openWriter​()
      在Writer中将openOutputStream的结果包起来。
      Methods in javax.tools with parameters of type Writer
      Modifier and Type 方法 描述
      DocumentationTool.DocumentationTask DocumentationTool.getTask​(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      使用给定的组件和参数为文档任务创建未来。
      JavaCompiler.CompilationTask JavaCompiler.getTask​(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      使用给定的组件和参数创建编译任务的未来。

    • Uses of Writer in javax.xml.bind

      Methods in javax.xml.bind with parameters of type Writer
      Modifier and Type 方法 描述
      static void JAXB.marshal​(Object jaxbObject, Writer xml)
      将Java对象树写入XML并将其存储到指定的位置。
      void Marshaller.marshal​(Object jaxbElement, Writer writer)
      将根据 jaxbElement的内容树 jaxbElement成一个作家。

    • Uses of Writer in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type Writer
      Modifier and Type | 方法 | 描述
      void | AbstractMarshallerImpl.marshal​(Object obj, Writer w)

    • Uses of Writer in javax.xml.stream

      Methods in javax.xml.stream with parameters of type Writer
      Modifier and Type 方法 描述
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter​(Writer stream)
      创建一个写入作者的新的XMLEventWriter
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter​(Writer stream)
      创建一个写入作者的新XMLStreamWriter

    • Uses of Writer in javax.xml.stream.events

      Methods in javax.xml.stream.events with parameters of type Writer
      Modifier and Type 方法 描述
      void XMLEvent.writeAsEncodedUnicode​(Writer writer)
      该方法将按照XML 1.0规范将XMLEvent写为Unicode字符。

    • Uses of Writer in javax.xml.transform.stream

      Methods in javax.xml.transform.stream that return Writer
      Modifier and Type 方法 描述
      Writer StreamResult.getWriter​()
      获取使用setWriter设置的字符流。
      Methods in javax.xml.transform.stream with parameters of type Writer
      Modifier and Type 方法 描述
      void StreamResult.setWriter​(Writer writer)
      设置要接收结果的作者。
      Constructors in javax.xml.transform.stream with parameters of type Writer
      Constructor 描述
      StreamResult​(Writer writer)
      从字符流构造一个StreamResult。

    • Uses of Writer in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Writer
      Modifier and Type 方法 描述
      Writer LSOutput.getCharacterStream​()
      表示可输出16位单位的可写入流的语言和绑定依赖类型的属性。
      Methods in org.w3c.dom.ls with parameters of type Writer
      Modifier and Type 方法 描述
      void LSOutput.setCharacterStream​(Writer characterStream)
      表示可输出16位单位的可写入流的语言和绑定依赖类型的属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.Closeable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.Closeable

  • Packages that use Closeable
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    java.nio.channels包的服务提供商类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.net.ssl
    为安全套接字包提供类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方法。
    org.omg.CORBA_2_3.portable
    提供输入和输出值类型的方法，并包含其他更新的 org/omg/CORBA/portable包。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。

    • Uses of Closeable in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement Closeable
      Modifier and Type Class 描述
      class  SctpChannel
      用于面向消息的连接SCTP套接字的可选通道。
      class  SctpMultiChannel
      用于面向消息的SCTP套接字的可选通道。
      class  SctpServerChannel
      用于面向消息的侦听SCTP插座的可选通道。

    • Uses of Closeable in java.io

      Classes in java.io that implement Closeable
      Modifier and Type Class 描述
      class  BufferedInputStream
      A BufferedInputStream为另一个输入流添加了功能，即缓冲输入并支持 mark和 reset方法的功能。
      class  BufferedOutputStream
      该类实现缓冲输出流。
      class  BufferedReader
      从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
      class  BufferedWriter
      将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
      class  ByteArrayInputStream
      A ByteArrayInputStream包含一个内部缓冲区，其中包含可以从流中读取的字节。
      class  ByteArrayOutputStream
      该类实现了将数据写入字节数组的输出流。
      class  CharArrayReader
      该类实现了一个字符缓冲区，可以用作字符输入流。
      class  CharArrayWriter
      该类实现了可以用作Writer的字符缓冲区。
      class  DataInputStream
      数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
      class  DataOutputStream
      数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
      class  FileInputStream
      A FileInputStream从文件系统中的文件获取输入字节。
      class  FileOutputStream
      文件输出流是用于将数据写入 File或 FileDescriptor的输出流。
      class  FileReader
      阅读字符文件的便利课。
      class  FileWriter
      方便课写字符文件。
      class  FilterInputStream
      A FilterInputStream包含一些其他输入流，它用作其基本的数据源，可能会沿着数据方向转换或提供附加功能。
      class  FilterOutputStream
      这个类是过滤输出流的所有类的超类。
      class  FilterReader
      用于读取过滤后的字符流的抽象类。
      class  FilterWriter
      用于编写过滤后的字符流的抽象类。
      class  InputStream
      这个抽象类是表示输入字节流的所有类的超类。
      class  InputStreamReader
      InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。
      class  LineNumberInputStream
      已过时。
      该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。
      class  LineNumberReader
      缓冲字符输入流，跟踪行号。
      class  ObjectInputStream
      ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
      class  ObjectOutputStream
      ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
      class  OutputStream
      这个抽象类是表示字节输出流的所有类的超类。
      class  OutputStreamWriter
      OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入的字符编码为字节。
      class  PipedInputStream
      管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。
      class  PipedOutputStream
      管道输出流可以连接到管道输入流以创建通信管道。
      class  PipedReader
      流水字符输入流。
      class  PipedWriter
      流水字符输出流。
      class  PrintStream
      A PrintStream为另一个输出流添加了功能，即能够方便地打印各种数据值的表示。
      class  PrintWriter
      将对象的格式表示打印到文本输出流。
      class  PushbackInputStream
      A PushbackInputStream通过将推回的字节存储在内部缓冲区中，将功能添加到另一个输入流，即“推回”或“未读”字节的功能。
      class  PushbackReader
      一个字符流读取器，允许将字符推回到流中。
      class  RandomAccessFile
      该类的实例支持读取和写入随机访问文件。
      class  Reader
      用于读取字符流的抽象类。
      class  SequenceInputStream
      A SequenceInputStream表示其他输入流的逻辑级联。
      class  StringBufferInputStream
      已过时。
      此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。
      class  StringReader
      一个字符流，其源是一个字符串。
      class  StringWriter
      在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。
      class  Writer
      用于写入字符流的抽象类。

    • Uses of Closeable in java.lang.module

      Subinterfaces of Closeable in java.lang.module
      Modifier and Type 接口 描述
      interface  ModuleReader
      提供访问模块的内容。

    • Uses of Closeable in java.net

      Classes in java.net that implement Closeable
      Modifier and Type Class 描述
      class  DatagramSocket
      此类表示用于发送和接收数据报数据包的套接字。
      class  MulticastSocket
      组播数据报套接字类对发送和接收IP组播数据包很有用。
      class  ServerSocket
      这个类实现了服务器套接字。
      class  Socket
      该类实现客户端套接字（也称为“套接字”）。
      class  URLClassLoader
      此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。

    • Uses of Closeable in java.nio.channels

      Subinterfaces of Closeable in java.nio.channels
      Modifier and Type 接口 描述
      interface  AsynchronousByteChannel
      一个可以读写字节的异步通道。
      interface  AsynchronousChannel
      支持异步I / O操作的通道。
      interface  ByteChannel
      一个可以读写字节的通道。
      interface  Channel
      I / O操作的联系。
      interface  GatheringByteChannel
      可以从缓冲区序列中写入字节的通道。
      interface  InterruptibleChannel
      可以异步关闭和中断的通道。
      interface  MulticastChannel
      支持互联网协议（IP）组播的网络通道。
      interface  NetworkChannel
      到网络插座的通道。
      interface  ReadableByteChannel
      一个可以读取字节的通道。
      interface  ScatteringByteChannel
      可以将字节读入缓冲区序列的通道。
      interface  SeekableByteChannel
      保持当前 位置并允许更改 位置的字节通道。
      interface  WritableByteChannel
      一个可以写字节的通道。
      Classes in java.nio.channels that implement Closeable
      Modifier and Type Class 描述
      class  AsynchronousFileChannel
      用于读取，写入和操作文件的异步通道。
      class  AsynchronousServerSocketChannel
      用于面向流的侦听套接字的异步通道。
      class  AsynchronousSocketChannel
      用于面向流的连接插座的异步通道。
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      static class  Pipe.SourceChannel
      表示Pipe的可读端的通道 。
      class  SelectableChannel
      可通过Selector复用的频道 。
      class  Selector
      SelectableChannel对象的多路复用器。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。

    • Uses of Closeable in java.nio.channels.spi

      Classes in java.nio.channels.spi that implement Closeable
      Modifier and Type Class 描述
      class  AbstractInterruptibleChannel
      可中断通道的基本实现类。
      class  AbstractSelectableChannel
      可选通道的基本实现类。
      class  AbstractSelector
      选择器的基本实现类。

    • Uses of Closeable in java.nio.file

      Subinterfaces of Closeable in java.nio.file
      Modifier and Type 接口 描述
      interface  DirectoryStream<T>
      一个对象来迭代目录中的条目。
      interface  SecureDirectoryStream<T>
      A DirectoryStream ，它定义相对于打开的目录定位的文件的操作。
      interface  WatchService
      手表服务， 手表已注册的对象的变化和事件。
      Classes in java.nio.file that implement Closeable
      Modifier and Type Class 描述
      class  FileSystem
      提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。

    • Uses of Closeable in java.rmi.server

      Classes in java.rmi.server that implement Closeable
      Modifier and Type Class 描述
      class  LogStream
      已过时。
      没有替换

    • Uses of Closeable in java.security

      Classes in java.security that implement Closeable
      Modifier and Type Class 描述
      class  DigestInputStream
      透明流，使用通过流的位更新关联的消息摘要。
      class  DigestOutputStream
      透明流，使用通过流的位更新关联的消息摘要。

    • Uses of Closeable in java.util

      Classes in java.util that implement Closeable
      Modifier and Type Class 描述
      class  Formatter
      printf风格格式字符串的解释器。
      class  Scanner
      一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。

    • Uses of Closeable in java.util.jar

      Classes in java.util.jar that implement Closeable
      Modifier and Type Class 描述
      class  JarFile
      JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。
      class  JarInputStream
      JarInputStream类用于从任何输入流读取JAR文件的内容。
      class  JarOutputStream
      JarOutputStream类用于将JAR文件的内容写入任何输出流。

    • Uses of Closeable in java.util.zip

      Classes in java.util.zip that implement Closeable
      Modifier and Type Class 描述
      class  CheckedInputStream
      也保持正在读取的数据的校验和的输入流。
      class  CheckedOutputStream
      一个输出流，它还维护正在写入的数据的校验和。
      class  DeflaterInputStream
      实现用于压缩“放气”压缩格式的数据的输入流过滤器。
      class  DeflaterOutputStream
      该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
      class  GZIPInputStream
      该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。
      class  GZIPOutputStream
      该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
      class  InflaterInputStream
      该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。
      class  InflaterOutputStream
      实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。
      class  ZipFile
      此类用于从zip文件读取条目。
      class  ZipInputStream
      该类实现了以ZIP文件格式读取文件的输入流过滤器。
      class  ZipOutputStream
      该类实现了以ZIP文件格式写入文件的输出流过滤器。

    • Uses of Closeable in javax.crypto

      Classes in javax.crypto that implement Closeable
      Modifier and Type Class 描述
      class  CipherInputStream
      CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。
      class  CipherOutputStream
      CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。

    • Uses of Closeable in javax.imageio.stream

      Subinterfaces of Closeable in javax.imageio.stream
      Modifier and Type 接口 描述
      interface  ImageInputStream
      一个可寻求的输入流接口，供 ImageReader使用。
      interface  ImageOutputStream
      一个可寻求的输出流接口，供 ImageWriter使用。
      Classes in javax.imageio.stream that implement Closeable
      Modifier and Type Class 描述
      class  FileCacheImageInputStream
      一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
      class  FileCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
      class  FileImageInputStream
      一个 ImageInputStream的实现，从 File或 RandomAccessFile获得它的输入。
      class  FileImageOutputStream
      实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
      class  ImageInputStreamImpl
      一个实现 ImageInputStream接口的抽象类。
      class  ImageOutputStreamImpl
      实现 ImageOutputStream接口的抽象类。
      class  MemoryCacheImageInputStream
      从 ImageInputStream获得其输入的 InputStream 。
      class  MemoryCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。

    • Uses of Closeable in javax.management.loading

      Classes in javax.management.loading that implement Closeable
      Modifier and Type Class 描述
      class  MLet
      允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
      class  PrivateMLet
      未添加到ClassLoaderRepository的MLet。

    • Uses of Closeable in javax.management.remote

      Subinterfaces of Closeable in javax.management.remote
      Modifier and Type 接口 描述
      interface  JMXConnector
      JMX API连接器的客户端。

    • Uses of Closeable in javax.management.remote.rmi

      Subinterfaces of Closeable in javax.management.remote.rmi
      Modifier and Type 接口 描述
      interface  RMIConnection
      用于将MBeanServer请求从客户端转发到其在服务器端的MBeanServer实现的RMI对象。
      Classes in javax.management.remote.rmi that implement Closeable
      Modifier and Type | Class | 描述
      class  RMIConnectionImpl
      实现RMIConnection接口。
      class  | RMIConnectionImpl_Stub
      class  RMIConnector
      与远程RMI连接器的连接。
      class  RMIIIOPServerImpl
      已过时。
      此运输已不再受支持。
      class  RMIJRMPServerImpl
      一个RMIServer对象，通过JRMP导出并将客户端连接创建为通过JRMP导出的RMI对象。
      class  RMIServerImpl
      表示连接器服务器的RMI对象。

    • Uses of Closeable in javax.net.ssl

      Classes in javax.net.ssl that implement Closeable
      Modifier and Type Class 描述
      class  SSLServerSocket
      此类扩展了 ServerSocket并使用安全套接字层（SSL）或传输层安全（TLS）协议等协议提供安全的服务器套接字。
      class  SSLSocket
      此类扩展了 Socket并使用诸如“安全套接字层”（SSL）或IETF“传输层安全”（TLS）协议之类的协议提供安全套接字。

    • Uses of Closeable in javax.sound.sampled

      Classes in javax.sound.sampled that implement Closeable
      Modifier and Type Class 描述
      class  AudioInputStream
      音频输入流是具有指定音频格式和长度的输入流。

    • Uses of Closeable in javax.swing

      Classes in javax.swing that implement Closeable
      Modifier and Type Class 描述
      class  ProgressMonitorInputStream
      监视从一些InputStream读取进度。

    • Uses of Closeable in javax.tools

      Subinterfaces of Closeable in javax.tools
      Modifier and Type 接口 描述
      interface  JavaFileManager
      用于Java编程语言源和类文件的工具的文件管理器。
      interface  StandardJavaFileManager
      文件管理器基于java.io.File和java.nio.file.Path 。
      Classes in javax.tools that implement Closeable
      Modifier and Type Class 描述
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      转发给给定的文件管理器。

    • Uses of Closeable in jdk.nashorn.api.scripting

      Classes in jdk.nashorn.api.scripting that implement Closeable
      Modifier and Type Class 描述
      class  URLReader
      从URL读取的读者。

    • Uses of Closeable in org.omg.CORBA_2_3.portable

      Classes in org.omg.CORBA_2_3.portable that implement Closeable
      Modifier and Type Class 描述
      class  InputStream
      InputStream提供从流中读取所有映射的IDL类型。
      class  OutputStream
      OutputStream提供了将所有映射的IDL类型写入流的接口。

    • Uses of Closeable in org.omg.CORBA.portable

      Classes in org.omg.CORBA.portable that implement Closeable
      Modifier and Type Class 描述
      class  InputStream
      InputStream是用于从CDR元数据流读取IDL类型的Java API。
      class  OutputStream
      OuputStream是用于将IDL类型写入CDR元数据流的Java API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.DataInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.DataInput

  • Packages that use DataInput
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of DataInput in java.io

      Subinterfaces of DataInput in java.io
      Modifier and Type 接口 描述
      interface  ObjectInput
      ObjectInput扩展了DataInput接口以包含对象的读取。
      Classes in java.io that implement DataInput
      Modifier and Type Class 描述
      class  DataInputStream
      数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
      class  ObjectInputStream
      ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
      class  RandomAccessFile
      该类的实例支持读取和写入随机访问文件。
      Methods in java.io with parameters of type DataInput
      Modifier and Type 方法 描述
      static String DataInputStream.readUTF​(DataInput in)
      从流in读取以modified UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为一个String返回。

    • Uses of DataInput in java.rmi.server

      Methods in java.rmi.server with parameters of type DataInput
      Modifier and Type 方法 描述
      static UID UID.read​(DataInput in)
      构造并返回一个新 UID通过从解组二进制表示实例 DataInput实例。

    • Uses of DataInput in javax.imageio.stream

      Subinterfaces of DataInput in javax.imageio.stream
      Modifier and Type 接口 描述
      interface  ImageInputStream
      一个可寻求的输入流接口，供 ImageReader使用。
      interface  ImageOutputStream
      一个可寻求的输出流接口，供 ImageWriter使用。
      Classes in javax.imageio.stream that implement DataInput
      Modifier and Type Class 描述
      class  FileCacheImageInputStream
      一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
      class  FileCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
      class  FileImageInputStream
      一个 ImageInputStream的实现，从 File或 RandomAccessFile获取它的输入。
      class  FileImageOutputStream
      一个 ImageOutputStream的实现将其输出直接写入 File或 RandomAccessFile 。
      class  ImageInputStreamImpl
      一个实现 ImageInputStream接口的抽象类。
      class  ImageOutputStreamImpl
      一个实现 ImageOutputStream接口的抽象类。
      class  MemoryCacheImageInputStream
      一个 ImageInputStream的实现，从常规的 InputStream获得它的输入。
      class  MemoryCacheImageOutputStream
      实现 ImageOutputStream将其输出写入常规 OutputStream 。

    • Uses of DataInput in javax.jnlp

      Subinterfaces of DataInput in javax.jnlp
      Modifier and Type 接口 描述
      interface  JNLPRandomAccessFile
      该类的实例支持读取和写入随机访问文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.DataOutput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.DataOutput

  • Packages that use DataOutput
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

    • Uses of DataOutput in java.io

      Subinterfaces of DataOutput in java.io
      Modifier and Type 接口 描述
      interface  ObjectOutput
      ObjectOutput扩展了DataOutput接口，包括写入对象。
      Classes in java.io that implement DataOutput
      Modifier and Type Class 描述
      class  DataOutputStream
      数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
      class  ObjectOutputStream
      ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
      class  RandomAccessFile
      该类的实例支持读取和写入随机访问文件。

    • Uses of DataOutput in java.rmi.server

      Methods in java.rmi.server with parameters of type DataOutput
      Modifier and Type 方法 描述
      void UID.write​(DataOutput out)
      将 UID的二进制表示法 UID交给 DataOutput实例。

    • Uses of DataOutput in javax.imageio.stream

      Subinterfaces of DataOutput in javax.imageio.stream
      Modifier and Type 接口 描述
      interface  ImageOutputStream
      一个可寻求的输出流接口，供 ImageWriter使用。
      Classes in javax.imageio.stream that implement DataOutput
      Modifier and Type Class 描述
      class  FileCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
      class  FileImageOutputStream
      实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
      class  ImageOutputStreamImpl
      一个实现 ImageOutputStream接口的抽象类。
      class  MemoryCacheImageOutputStream
      ImageOutputStream一个实现，将其输出写入常规的 OutputStream 。

    • Uses of DataOutput in javax.jnlp

      Subinterfaces of DataOutput in javax.jnlp
      Modifier and Type 接口 描述
      interface  JNLPRandomAccessFile
      该类的实例支持读取和写入随机访问文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.Externalizable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.Externalizable

  • Packages that use Externalizable
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.activation
    javax.management.loading
    提供实现高级动态加载的类。

    • Uses of Externalizable in java.awt.datatransfer

      Classes in java.awt.datatransfer that implement Externalizable
      Modifier and Type Class 描述
      class  DataFlavor
      A DataFlavor提供有关数据的元信息。

    • Uses of Externalizable in java.rmi.server

      Subinterfaces of Externalizable in java.rmi.server
      Modifier and Type 接口 描述
      interface  RemoteRef
      RemoteRef表示远程对象的句柄。
      interface  ServerRef
      已过时。
      没有替换 此接口未使用，已过时。

    • Uses of Externalizable in javax.activation

      Classes in javax.activation that implement Externalizable
      Modifier and Type Class 描述
      class  ActivationDataFlavor
      ActivationDataFlavor类是 java.awt.datatransfer.DataFlavor的特殊子类。
      class  MimeType
      多功能Internet邮件扩展（MIME）类型，如RFC 2045和2046中所定义。

    • Uses of Externalizable in javax.management.loading

      Classes in javax.management.loading that implement Externalizable
      Modifier and Type Class 描述
      class  MLet
      允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
      class  PrivateMLet
      未添加到ClassLoaderRepository的MLet。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.FileFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.FileFilter

  • Packages that use FileFilter
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of FileFilter in java.io

      Methods in java.io with parameters of type FileFilter
      Modifier and Type 方法 描述
      File[] File.listFiles​(FileFilter filter)
      返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.FilenameFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.FilenameFilter

  • Packages that use FilenameFilter
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of FilenameFilter in java.awt

      Methods in java.awt that return FilenameFilter
      Modifier and Type 方法 描述
      FilenameFilter FileDialog.getFilenameFilter​()
      确定此文件对话框的文件名过滤器。
      Methods in java.awt with parameters of type FilenameFilter
      Modifier and Type 方法 描述
      void FileDialog.setFilenameFilter​(FilenameFilter filter)
      将此文件对话窗口的文件名过滤器设置为指定的过滤器。

    • Uses of FilenameFilter in java.io

      Methods in java.io with parameters of type FilenameFilter
      Modifier and Type 方法 描述
      String[] File.list​(FilenameFilter filter)
      返回一个字符串数组，命名由此抽象路径名表示的目录中满足指定过滤器的文件和目录。
      File[] File.listFiles​(FilenameFilter filter)
      返回一个抽象路径名数组，表示由此抽象路径名表示的满足指定过滤器的目录中的文件和目录。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.Flushable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.Flushable

  • Packages that use Flushable
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.crypto
    提供加密操作的类和接口。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    org.omg.CORBA_2_3.portable
    提供值类型的输入和输出方法，并包含其他更新的 org/omg/CORBA/portable包。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。

    • Uses of Flushable in java.io

      Classes in java.io that implement Flushable
      Modifier and Type Class 描述
      class  BufferedOutputStream
      该类实现缓冲输出流。
      class  BufferedWriter
      将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
      class  ByteArrayOutputStream
      该类实现了将数据写入字节数组的输出流。
      class  CharArrayWriter
      该类实现了可以用作Writer的字符缓冲区。
      class  Console
      访问与当前Java虚拟机关联的基于字符的控制台设备（如果有的话）的方法。
      class  DataOutputStream
      数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
      class  FileOutputStream
      文件输出流是用于将数据写入到 File或 FileDescriptor的输出流。
      class  FileWriter
      方便课写字符文件。
      class  FilterOutputStream
      这个类是过滤输出流的所有类的超类。
      class  FilterWriter
      用于编写过滤后的字符流的抽象类。
      class  ObjectOutputStream
      ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
      class  OutputStream
      这个抽象类是表示字节输出流的所有类的超类。
      class  OutputStreamWriter
      OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入的字符编码为字节。
      class  PipedOutputStream
      管道输出流可以连接到管道输入流以创建通信管道。
      class  PipedWriter
      流水字符输出流。
      class  PrintStream
      A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
      class  PrintWriter
      将对象的格式表示打印到文本输出流。
      class  StringWriter
      在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。
      class  Writer
      用于写入字符流的抽象类。

    • Uses of Flushable in java.rmi.server

      Classes in java.rmi.server that implement Flushable
      Modifier and Type Class 描述
      class  LogStream
      已过时。
      没有替换

    • Uses of Flushable in java.security

      Classes in java.security that implement Flushable
      Modifier and Type Class 描述
      class  DigestOutputStream
      透明流，使用通过流的位更新关联的消息摘要。

    • Uses of Flushable in java.util

      Classes in java.util that implement Flushable
      Modifier and Type Class 描述
      class  Formatter
      printf风格格式字符串的解释器。

    • Uses of Flushable in java.util.jar

      Classes in java.util.jar that implement Flushable
      Modifier and Type Class 描述
      class  JarOutputStream
      JarOutputStream类用于将JAR文件的内容写入任何输出流。

    • Uses of Flushable in java.util.zip

      Classes in java.util.zip that implement Flushable
      Modifier and Type Class 描述
      class  CheckedOutputStream
      一个输出流，它还维护正在写入的数据的校验和。
      class  DeflaterOutputStream
      该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
      class  GZIPOutputStream
      该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
      class  InflaterOutputStream
      实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。
      class  ZipOutputStream
      该类实现了以ZIP文件格式写入文件的输出流过滤器。

    • Uses of Flushable in javax.crypto

      Classes in javax.crypto that implement Flushable
      Modifier and Type Class 描述
      class  CipherOutputStream
      CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。

    • Uses of Flushable in javax.tools

      Subinterfaces of Flushable in javax.tools
      Modifier and Type 接口 描述
      interface  JavaFileManager
      用于Java编程语言源和类文件的工具的文件管理器。
      interface  StandardJavaFileManager
      文件管理器基于java.io.File和java.nio.file.Path 。
      Classes in javax.tools that implement Flushable
      Modifier and Type Class 描述
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      转发给给定的文件管理器。

    • Uses of Flushable in org.omg.CORBA_2_3.portable

      Classes in org.omg.CORBA_2_3.portable that implement Flushable
      Modifier and Type Class 描述
      class  OutputStream
      OutputStream提供了将所有映射的IDL类型写入流的接口。

    • Uses of Flushable in org.omg.CORBA.portable

      Classes in org.omg.CORBA.portable that implement Flushable
      Modifier and Type Class 描述
      class  OutputStream
      OuputStream是用于将IDL类型写入CDR元数据流的Java API。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.ObjectInput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.ObjectInput

  • Packages that use ObjectInput
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.activation
    javax.management.loading
    提供实现高级动态加载的类。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of ObjectInput in java.awt.datatransfer

      Methods in java.awt.datatransfer with parameters of type ObjectInput
      Modifier and Type 方法 描述
      void DataFlavor.readExternal​(ObjectInput is)
      从序列化状态恢复此 DataFlavor 。

    • Uses of ObjectInput in java.io

      Classes in java.io that implement ObjectInput
      Modifier and Type Class 描述
      class  ObjectInputStream
      ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
      Methods in java.io with parameters of type ObjectInput
      Modifier and Type 方法 描述
      void Externalizable.readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。

    • Uses of ObjectInput in java.rmi.server

      Methods in java.rmi.server that return ObjectInput
      Modifier and Type 方法 描述
      ObjectInput RemoteCall.getInputStream​()
      已过时。
      没有替换
      Methods in java.rmi.server with parameters of type ObjectInput
      Modifier and Type 方法 描述
      static ObjID ObjID.read​(ObjectInput in)
      构造并返回一个新 ObjID通过从解组二进制表示实例 ObjectInput实例。

    • Uses of ObjectInput in javax.activation

      Methods in javax.activation with parameters of type ObjectInput
      Modifier and Type 方法 描述
      void MimeType.readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。

    • Uses of ObjectInput in javax.management.loading

      Methods in javax.management.loading with parameters of type ObjectInput
      Modifier and Type 方法 描述
      void MLet.readExternal​(ObjectInput in)
      从给定的ObjectInput恢复这个MLet的内容。

    • Uses of ObjectInput in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type ObjectInput
      Modifier and Type 方法 描述
      static void Util.forwardExecutionControl​(ExecutionControl ec, ObjectInput in, ObjectOutput out)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
      Method parameters in jdk.jshell.execution with type arguments of type ObjectInput
      Modifier and Type 方法 描述
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。
      Constructors in jdk.jshell.execution with parameters of type ObjectInput
      Constructor 描述
      JdiExecutionControl​(ObjectOutput out, ObjectInput in)
      创建一个实例。
      StreamingExecutionControl​(ObjectOutput out, ObjectInput in)
      创建一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.ObjectInputFilter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.ObjectInputFilter

  • Packages that use ObjectInputFilter
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。

    • Uses of ObjectInputFilter in java.io

      Methods in java.io that return ObjectInputFilter
      Modifier and Type 方法 描述
      static ObjectInputFilter ObjectInputFilter.Config.createFilter​(String pattern)
      从一个模式字符串返回一个ObjectInputFilter。
      ObjectInputFilter ObjectInputStream.getObjectInputFilter​()
      返回此流的序列化过滤器。
      static ObjectInputFilter ObjectInputFilter.Config.getSerialFilter​()
      如果未配置，则返回过程范围的序列化过滤器或 null 。
      Methods in java.io with parameters of type ObjectInputFilter
      Modifier and Type 方法 描述
      void ObjectInputStream.setObjectInputFilter​(ObjectInputFilter filter)
      为流设置序列化过滤器。
      static void ObjectInputFilter.Config.setSerialFilter​(ObjectInputFilter filter)
      如果尚未配置或设置过程范围过滤器，请设置该过滤器。

    • Uses of ObjectInputFilter in java.rmi.server

      Methods in java.rmi.server with parameters of type ObjectInputFilter
      Modifier and Type 方法 描述
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, ObjectInputFilter filter)
      使用特定提供的端口和filter导出远程对象以使其可用于接收来电。
      static Remote UnicastRemoteObject.exportObject​(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, ObjectInputFilter filter)
      导出远程对象以使其可用于接收来电，使用由给定的套接字工厂指定的传输和filter 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.ObjectInputFilter.FilterInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.ObjectInputFilter.FilterInfo

  • Packages that use ObjectInputFilter.FilterInfo
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectInputFilter.FilterInfo in java.io

      Methods in java.io with parameters of type ObjectInputFilter.FilterInfo
      Modifier and Type 方法 描述
      ObjectInputFilter.Status ObjectInputFilter.checkInput​(ObjectInputFilter.FilterInfo filterInfo)
      检查类，数组长度，对象引用数，深度，流大小和其他可用过滤信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.ObjectInputValidation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.ObjectInputValidation

  • Packages that use ObjectInputValidation
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectInputValidation in java.io

      Methods in java.io with parameters of type ObjectInputValidation
      Modifier and Type 方法 描述
      void ObjectInputStream.registerValidation​(ObjectInputValidation obj, int prio)
      在返回图之前注册要验证的对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.ObjectOutput (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.ObjectOutput

  • Packages that use ObjectOutput
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.activation
    javax.management.loading
    提供实现高级动态加载的类。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of ObjectOutput in java.awt.datatransfer

      Methods in java.awt.datatransfer with parameters of type ObjectOutput
      Modifier and Type 方法 描述
      void DataFlavor.writeExternal​(ObjectOutput os)
      序列化这个 DataFlavor 。

    • Uses of ObjectOutput in java.io

      Classes in java.io that implement ObjectOutput
      Modifier and Type Class 描述
      class  ObjectOutputStream
      ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
      Methods in java.io with parameters of type ObjectOutput
      Modifier and Type 方法 描述
      abstract void ObjectOutputStream.PutField.write​(ObjectOutput out)
      已过时。
      此方法不会以适当的格式写入此PutField对象所包含的值，并可能导致序列化流的损坏。 编写PutField数据的正确方法是通过调用ObjectOutputStream.writeFields()方法。
      void Externalizable.writeExternal​(ObjectOutput out)
      该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput的对象，字符串和数组的writeObject方法来保存其内容。

    • Uses of ObjectOutput in java.rmi.server

      Methods in java.rmi.server that return ObjectOutput
      Modifier and Type 方法 描述
      ObjectOutput RemoteCall.getOutputStream​()
      已过时。
      没有替换
      ObjectOutput RemoteCall.getResultStream​(boolean success)
      已过时。
      没有替换
      Methods in java.rmi.server with parameters of type ObjectOutput
      Modifier and Type 方法 描述
      String RemoteRef.getRefClass​(ObjectOutput out)
      将要序列化的引用类型的类名返回到流“out”。
      void ObjID.write​(ObjectOutput out)
      将此 ObjID的二进制表示法 ObjID交给 ObjectOutput实例。

    • Uses of ObjectOutput in javax.activation

      Methods in javax.activation with parameters of type ObjectOutput
      Modifier and Type 方法 描述
      void MimeType.writeExternal​(ObjectOutput out)
      该对象实现了writeExternal方法来通过调用DataOutput的原始值或调用ObjectOutput对象，字符串和数组的writeObject方法来保存其内容。

    • Uses of ObjectOutput in javax.management.loading

      Methods in javax.management.loading with parameters of type ObjectOutput
      Modifier and Type 方法 描述
      void MLet.writeExternal​(ObjectOutput out)
      将此MLet的内容保存到给定的ObjectOutput 。

    • Uses of ObjectOutput in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type ObjectOutput
      Modifier and Type 方法 描述
      static void Util.forwardExecutionControl​(ExecutionControl ec, ObjectInput in, ObjectOutput out)
      将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。
      Method parameters in jdk.jshell.execution with type arguments of type ObjectOutput
      Modifier and Type 方法 描述
      static ExecutionControl Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)
      为给定的分组化输入和输出创建一个ExecutionControl。
      Constructors in jdk.jshell.execution with parameters of type ObjectOutput
      Constructor 描述
      JdiExecutionControl​(ObjectOutput out, ObjectInput in)
      创建一个实例。
      StreamingExecutionControl​(ObjectOutput out, ObjectInput in)
      创建一个实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.ObjectStreamConstants (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.ObjectStreamConstants

  • Packages that use ObjectStreamConstants
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。

    • Uses of ObjectStreamConstants in java.io

      Classes in java.io that implement ObjectStreamConstants
      Modifier and Type Class 描述
      class  ObjectInputStream
      ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
      class  ObjectOutputStream
      ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.io.Serializable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.io.Serializable

  • Packages that use Serializable
    软件包 描述
    com.sun.javadoc
    注意：该包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.connect.spi
    该包包括用于开发新的TransportService实现的接口和类。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.security.auth
    提供Principal的实现。
    com.sun.security.jgss
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.net
    提供实现网络应用程序的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.application
    提供应用程序生命周期类。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javafx.util
    包含各种实用程序和助手类。
    javax.activation
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.jws
    javax.jws.soap
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.management.timer
    提供定时器MBean的定义。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming软件包以提供访问目录服务的功能。
    javax.naming.event
    访问命名和目录服务时，提供对事件通知的支持。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.naming.spi
    提供通过 javax.naming及相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.print.event
    程序包javax.print.event包含事件类和侦听器接口。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.cert
    提供公钥证书类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    javax.transaction.xa
    提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.namespace
    定义XML命名空间处理。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler
    新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
    javax.xml.ws.http
    该包定义了特定于HTTP绑定的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。
    jdk.security.jarsigner
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能对象请求代理（ORB）。
    org.omg.CORBA_2_3.portable
    提供输入和输出值类型的方法，并包含 org/omg/CORBA/portable包的其他更新。
    org.omg.CORBA.DynAnyPackage
    提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。
    org.omg.CORBA.ORBPackage
    提供异常 InvalidName ，由方法 ORB.resolve_initial_references和异常 InconsistentTypeCode抛出，由ORB类中的动态任何创建方法抛出。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.omg.CORBA.TypeCodePackage
    提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。
    org.omg.CosNaming
    为Java IDL提供命名服务。
    org.omg.CosNaming.NamingContextExtPackage
    此包包含以下类别，其用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress
    org.omg.CosNaming.NamingContextPackage
    该包包含 org.omg.CosNaming包的异常类。
    org.omg.Dynamic
    该包包含OMG便携式拦截器规范 ptc/2000-08-06第21.9节中指定的 Dynamic模块。
    org.omg.DynamicAny
    提供类和接口，可以在运行时遍历与 any相关联的数据值，并提取数据值的原始组成部分。
    org.omg.DynamicAny.DynAnyFactoryPackage
    该包包含OMG “公共对象请求代理：体系结构和规范 ” formal/99-10-07第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。
    org.omg.DynamicAny.DynAnyPackage
    这个软件包包含从类和例外 DynAny所述的接口 DynamicAny在OMG指定 的公共对象请求代理模块 ：体系结构和规格 ， formal/99-10-07 ，第9.2节。
    org.omg.IOP
    该包包含OMG文档 “通用对象请求代理：体系结构和规范 ” formal/99-10-07第13.6节中指定的 IOP模块。
    org.omg.IOP.CodecFactoryPackage
    该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。
    org.omg.IOP.CodecPackage
    该包是从IOP :: Codec IDL接口定义生成的。
    org.omg.PortableInterceptor
    提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。
    org.omg.PortableInterceptor.ORBInitInfoPackage
    此包包含OMG便携式拦截器规范 ptc/2000-08-06第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。
    org.omg.PortableServer
    提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
    org.omg.PortableServer.CurrentPackage
    提供方法实现，访问方法被调用的对象的标识。
    org.omg.PortableServer.POAManagerPackage
    封装与之相关的POA的处理状态。
    org.omg.PortableServer.POAPackage
    允许程序员构建可在不同ORB产品之间移植的对象实现。
    org.omg.SendingContext
    为组合值类型提供支持。
    org.omg.stub.java.rmi
    包含 java.rmi软件包中出现的远程类型的RMI-IIOP存根。
    org.w3c.dom
    提供文档对象模型（DOM）的接口。
    org.w3c.dom.events
    提供DOM Level 2事件的接口。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.w3c.dom.ranges
    提供DOM Level 2范围的界面。
    org.w3c.dom.xpath
    提供DOM Level 3 XPath规范的接口。
    org.xml.sax
    提供核心SAX API。

    • Uses of Serializable in com.sun.javadoc

      Classes in com.sun.javadoc that implement Serializable
      Modifier and Type Class 描述
      class  LanguageVersion
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    • Uses of Serializable in com.sun.jdi

      Classes in com.sun.jdi that implement Serializable
      Modifier and Type Class 描述
      class  AbsentInformationException
      抛出以表示行号或变量信息不可用。
      class  ClassNotLoadedException
      抛出，表示请求的类尚未通过适当的类加载器加载。
      class  ClassNotPreparedException
      抛出以指示由于指定的类尚未准备而请求的操作无法完成。
      class  IncompatibleThreadStateException
      抛出以指示所请求的操作在指定线程处于当前状态时无法完成。
      class  InconsistentDebugInfoException
      被抛出以表明目标VM提供的调试信息有不一致之处。
      class  InternalException
      抛出，表示出现意外的内部错误。
      class  InvalidCodeIndexException
      已过时。
      不再抛出此异常
      class  InvalidLineNumberException
      已过时。
      不再抛出此异常
      class  InvalidModuleException
      抛出以表明所请求的模块在卸载模块后无效或无效。
      class  InvalidStackFrameException
      抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。
      class  InvalidTypeException
      抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。
      class  InvocationException
      抛出以指示目标VM中的调用方法中发生异常。
      class  JDIPermission
      JDIPermission类代表对 VirtualMachineManager访问权限。
      class  NativeMethodException
      抛出表示操作无法完成，因为它对本机方法无效。
      class  ObjectCollectedException
      抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。
      class  VMCannotBeModifiedException
      抛出以表示操作无效，因为它会修改VM，VM是只读的。
      class  VMDisconnectedException
      抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。
      class  VMMismatchException
      抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。
      class  VMOutOfMemoryException
      抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。

    • Uses of Serializable in com.sun.jdi.connect

      Subinterfaces of Serializable in com.sun.jdi.connect
      Modifier and Type 接口 描述
      static interface  Connector.Argument
      Connector参数的规范和值。
      static interface  Connector.BooleanArgument
      Connector参数的规范和值，其值为布尔值。
      static interface  Connector.IntegerArgument
      Connector参数的规格和值，其值为整数。
      static interface  Connector.SelectedArgument
      Connector参数的规范和值，其值是从选择列表中选择的String。
      static interface  Connector.StringArgument
      Connector参数的规范和值，其值为String。
      Classes in com.sun.jdi.connect that implement Serializable
      Modifier and Type Class 描述
      class  IllegalConnectorArgumentsException
      抛出表示无效参数或不一致传递给Connector 。
      class  TransportTimeoutException
      当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。
      class  VMStartException
      目标VM已成功启动，但在建立连接之前会发生错误。

    • Uses of Serializable in com.sun.jdi.connect.spi

      Classes in com.sun.jdi.connect.spi that implement Serializable
      Modifier and Type Class 描述
      class  ClosedConnectionException
      由于在进行I / O操作时异步关闭Connection可能会抛出此异常。

    • Uses of Serializable in com.sun.jdi.request

      Classes in com.sun.jdi.request that implement Serializable
      Modifier and Type Class 描述
      class  DuplicateRequestException
      抛出以表示重复的事件请求。
      class  InvalidRequestStateException
      抛出以表示所请求的事件由于启用而无法修改。

    • Uses of Serializable in com.sun.management

      Classes in com.sun.management that implement Serializable
      Modifier and Type Class 描述
      static class  VMOption.Origin
      VM选项的值的起源。

    • Uses of Serializable in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement Serializable
      Modifier and Type Class 描述
      static class  AssociationChangeNotification.AssocChangeEvent
      定义关联发生的变更事件的类型。
      class  HandlerResult
      定义通知处理程序结果。
      class  IllegalReceiveException
      当试图调用未经检查的异常receive的方法SctpChannel或SctpMultiChannel从通知处理程序。
      class  IllegalUnbindException
      尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。
      class  InvalidStreamException
      尝试将消息发送到无效流时抛出未检查的异常。
      static class  PeerAddressChangeNotification.AddressChangeEvent
      定义在多宿主对等体遇到更改接口详细信息时发生到目标地址的地址更改事件的类型。

    • Uses of Serializable in com.sun.security.auth

      Classes in com.sun.security.auth that implement Serializable
      Modifier and Type Class 描述
      class  LdapPrincipal
      由专有名称标识的主体，由 RFC 2253指定。
      class  NTDomainPrincipal
      该类实现了 Principal接口，并表示用户认证的Windows NT域的名称。
      class  NTSid
      该类实现了 Principal接口，并表示有关Windows NT用户，组或领域的信息。
      class  NTSidDomainPrincipal
      此类扩展为 NTSid ，表示Windows NT用户的域SID。
      class  NTSidGroupPrincipal
      此类扩展为 NTSid ，表示Windows NT用户所属的组之一。
      class  NTSidPrimaryGroupPrincipal
      此类扩展为 NTSid ，表示Windows NT用户的主组SID。
      class  NTSidUserPrincipal
      此类扩展为 NTSid ，表示Windows NT用户的SID。
      class  NTUserPrincipal
      该类实现了 Principal接口，代表Windows NT用户。
      class  SolarisNumericGroupPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixNumericGroupPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  SolarisNumericUserPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixNumericUserPrincipal取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  SolarisPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  UnixNumericGroupPrincipal
      该类实现了 Principal接口，代表了用户的Unix组标识号（GID）。
      class  UnixNumericUserPrincipal
      该类实现了 Principal接口，代表用户的Unix标识号（UID）。
      class  UnixPrincipal
      该类实现了 Principal接口，代表了Unix用户。
      class  UserPrincipal
      由用户名或帐户名称标识的用户主体。
      class  X500Principal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。

    • Uses of Serializable in com.sun.security.jgss

      Classes in com.sun.security.jgss that implement Serializable
      Modifier and Type Class 描述
      class  InquireSecContextPermission
      该类用于保护可以使用 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立GSS安全上下文的各种属性。
      class  InquireType
      可以指定为参数 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)的属性类型

    • Uses of Serializable in com.sun.source.doctree

      Classes in com.sun.source.doctree that implement Serializable
      Modifier and Type Class 描述
      static class  AttributeTree.ValueKind
      属性值的种类。
      static class  DocTree.Kind
      列举各种树木。

    • Uses of Serializable in com.sun.source.tree

      Classes in com.sun.source.tree that implement Serializable
      Modifier and Type Class 描述
      static class  LambdaExpressionTree.BodyKind
      Lambda表达式有两种形式：表达式lambdas，其主体是表达式，语句lambdas，其主体是块
      static class  MemberReferenceTree.ReferenceMode
      有两种成员引用：（i）方法引用和（ii）构造函数引用
      static class  ModuleTree.ModuleKind
      模块的种类。
      static class  Tree.Kind
      列举各种树木。

    • Uses of Serializable in com.sun.source.util

      Classes in com.sun.source.util that implement Serializable
      Modifier and Type Class 描述
      static class  TaskEvent.Kind
      种类的任务事件。

    • Uses of Serializable in com.sun.tools.attach

      Classes in com.sun.tools.attach that implement Serializable
      Modifier and Type Class 描述
      class  AgentInitializationException
      当代理程序无法在目标Java虚拟机中初始化时抛出异常。
      class  AgentLoadException
      代理无法加载到目标Java虚拟机时抛出的异常。
      class  AttachNotSupportedException
      在尝试附加到兼容的AttachProvider的Java虚拟机时抛出VirtalMachine.attach 。
      class  AttachOperationFailedException
      异常类型表示目标虚拟机中附着操作失败。
      class  AttachPermission
      当一个SecurityManager集合，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。

    • Uses of Serializable in com.sun.tools.jconsole

      Classes in com.sun.tools.jconsole that implement Serializable
      Modifier and Type Class 描述
      static class  JConsoleContext.ConnectionState
      ConnectionState绑定属性的值。

    • Uses of Serializable in java.applet

      Classes in java.applet that implement Serializable
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      protected class  Applet.AccessibleApplet
      已过时。
      这个类实现 Applet类的可访问性支持。

    • Uses of Serializable in java.awt

      Classes in java.awt that implement Serializable
      Modifier and Type Class 描述
      class  AWTError
      当出现严重的抽象窗口工具包错误时抛出。
      class  AWTEvent
      所有AWT事件的根事件类。
      class  AWTException
      表示发生抽象窗口工具包异常。
      class  AWTKeyStroke
      AWTKeyStroke表示键盘或等效输入设备上的关键动作。
      class  AWTPermission
      此类用于AWT权限。
      class  BorderLayout
      边界布局设置了一个容器，安排和调整其组件，以适应五个区域：北，南，东，西和中心。
      class  Button
      这个类创建一个标记的按钮。
      protected class  Button.AccessibleAWTButton
      这个类实现 Button类的可访问性支持。
      class  Canvas
      A Canvas组件表示应用程序可以绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。
      protected class  Canvas.AccessibleAWTCanvas
      该类实现 Canvas类的可访问性支持。
      class  CardLayout
      A CardLayout对象是容器的布局管理器。
      class  Checkbox
      复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。
      protected class  Checkbox.AccessibleAWTCheckbox
      这个类实现 Checkbox类的可访问性支持。
      class  CheckboxGroup
      CheckboxGroup类用于组合一组 Checkbox按钮。
      class  CheckboxMenuItem
      此类表示可以包含在菜单中的复选框。
      protected class  CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
      用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。
      class  Choice
      Choice课程提供了一个弹出菜单的选择。
      protected class  Choice.AccessibleAWTChoice
      该类为 Choice类实现可访问性支持。
      class  Color
      Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。
      class  Component
      组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。
      protected class  Component.AccessibleAWTComponent
      组件的内部类用于为辅助功能提供默认支持。
      static class  Component.BaselineResizeBehavior
      枚举组件的基准线随着大小变化而改变的常见方式。
      class  ComponentOrientation
      ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。
      class  Container
      通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。
      protected class  Container.AccessibleAWTContainer
      Container的内部类用于为辅助功能提供默认支持。
      class  ContainerOrderFocusTraversalPolicy
      FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
      class  Cursor
      封装鼠标光标位图表示的类。
      class  DefaultFocusTraversalPolicy
      FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。
      static class  Desktop.Action
      表示动作类型。
      class  Dialog
      Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。
      protected class  Dialog.AccessibleAWTDialog
      这个类实现 Dialog类的可访问性支持。
      static class  Dialog.ModalExclusionType
      任何顶级窗口都可以标记为不被模态对话框阻止。
      static class  Dialog.ModalityType
      模态对话框阻止某些顶级窗口的所有输入。
      class  Dimension
      Dimension类封装了单个对象中组件的宽度和高度（以整数精度）。
      class  Event
      已过时。
      建议使用AWTEvent及其子类
      class  FileDialog
      FileDialog类显示一个对话窗口，用户可以从中选择一个文件。
      class  FlowLayout
      流程布局将组件布置在定向流中，与段落中的文本行类似。
      class  Font
      Font类表示字体，用于以可见的方式呈现文本。
      class  FontFormatException
      在 Font类中通过方法createFont抛出，表示指定的字体不好。
      class  FontMetrics
      FontMetrics类定义了一个字体度量对象，该对象封装了有关在特定屏幕上呈现特定字体的信息。
      class  Frame
      A Frame是具有标题和边框的顶级窗口。
      protected class  Frame.AccessibleAWTFrame
      该类为 Frame类实现可访问性支持。
      class  GraphicsConfigTemplate
      GraphicsConfigTemplate类用于获取有效的GraphicsConfiguration 。
      static class  GraphicsDevice.WindowTranslucency
      底层系统支持的半透明度。
      class  GridBagConstraints
      GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。
      class  GridBagLayout
      GridBagLayout类是一种灵活的布局管理器，可以垂直，水平或沿其基准对齐组件，而不需要组件的大小相同。
      class  GridBagLayoutInfo
      GridBagLayoutInfo是 GridBagLayout布局管理器的实用程序类。
      class  GridLayout
      GridLayout类是一个布局管理器，它将一个容器的组件放在一个矩形网格中。
      class  HeadlessException
      在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
      class  IllegalComponentStateException
      表示AWT组件对于请求的操作不在适当的状态。
      class  Insets
      一个 Insets对象是容器边框的表示。
      class  Label
      Label对象是用于将文本放置在容器中的组件。
      protected class  Label.AccessibleAWTLabel
      这个类实现 Label类的可访问性支持。
      class  List
      List组件向用户显示文本项目的滚动列表。
      protected class  List.AccessibleAWTList
      这个类实现 List类的可访问性支持。
      protected class  List.AccessibleAWTList.AccessibleAWTListChild
      此类实现对List子项的可访问性支持。
      class  MediaTracker
      MediaTracker类是用于跟踪多个媒体对象的状态的实用程序类。
      class  Menu
      Menu对象是从菜单栏部署的下拉菜单组件。
      protected class  Menu.AccessibleAWTMenu
      菜单的内部类用于提供对辅助功能的默认支持。
      class  MenuBar
      MenuBar类封装了平台的框架结构的菜单栏的概念。
      protected class  MenuBar.AccessibleAWTMenuBar
      MenuBar的内部类用于为辅助功能提供默认支持。
      class  MenuComponent
      抽象类 MenuComponent是所有菜单相关组件的超类。
      protected class  MenuComponent.AccessibleAWTMenuComponent
      内部类 MenuComponent用于提供对辅助功能的默认支持。
      class  MenuItem
      菜单中的所有项目必须属于类别 MenuItem或其子类之一。
      protected class  MenuItem.AccessibleAWTMenuItem
      MenuItem的内部类用于为辅助功能提供默认支持。
      class  MenuShortcut
      MenuShortcut类代表一个MenuItem的键盘加速器。
      static class  MultipleGradientPaint.ColorSpaceType
      执行渐变插值的颜色空间。
      static class  MultipleGradientPaint.CycleMethod
      绘画之外使用的方法边界渐变。
      class  Panel
      Panel是最简单的容器类。
      protected class  Panel.AccessibleAWTPanel
      该类为 Panel类实现可访问性支持。
      class  Point
      表示 (x,y)坐标空间中的位置的点，以整数精度指定。
      class  Polygon
      Polygon类封装了坐标空间内封闭的二维区域的描述。
      class  PopupMenu
      一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。
      protected class  PopupMenu.AccessibleAWTPopupMenu
      PopupMenu的内部类用于提供对辅助功能的默认支持。
      class  Rectangle
      A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的区域，其坐标空间，其宽度及其高度。
      class  Scrollbar
      Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。
      protected class  Scrollbar.AccessibleAWTScrollBar
      这个类实现 Scrollbar类的可访问性支持。
      class  ScrollPane
      一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。
      protected class  ScrollPane.AccessibleAWTScrollPane
      这个类实现 ScrollPane类的可访问性支持。
      class  ScrollPaneAdjustable
      此类表示 ScrollPane的水平或垂直滚动条的 ScrollPane 。
      class  SystemColor
      封装代表系统上本地GUI对象颜色的符号颜色的类。
      static class  Taskbar.Feature
      提供功能列表
      static class  Taskbar.State
      可用窗口进度的种类状态。
      class  TextArea
      TextArea对象是显示文本的多行区域。
      protected class  TextArea.AccessibleAWTTextArea
      该类为 TextArea类实现可访问性支持。
      class  TextComponent
      TextComponent类是允许编辑某些文本的任何组件的超类。
      protected class  TextComponent.AccessibleAWTTextComponent
      该类为 TextComponent类实现可访问性支持。
      class  TextField
      一个 TextField对象是允许编辑单行文本的文本组件。
      protected class  TextField.AccessibleAWTTextField
      该类为 TextField类实现可访问性支持。
      static class  TrayIcon.MessageType
      消息类型确定在消息的标题中将显示哪个图标，以及在显示时消息可能产生的可能的系统声音。
      class  Window
      一个 Window对象是没有边框的顶级窗口，没有菜单。
      protected class  Window.AccessibleAWTWindow
      这个类实现 Window类的可访问性支持。
      static class  Window.Type
      枚举可用的 窗口类型 。

    • Uses of Serializable in java.awt.color

      Classes in java.awt.color that implement Serializable
      Modifier and Type Class 描述
      class  CMMException
      如果本机CMM返回错误，则抛出此异常。
      class  ColorSpace
      该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。
      class  ICC_ColorSpace
      ICC_ColorSpace类是抽象ColorSpace类的一个实现。
      class  ICC_Profile
      基于国际色彩联盟规范ICC.1：2001-12，颜色配置文件的格式（见 http://www.color.org ），用于与设备无关的设备相关色彩空间的颜色配置文件数据的表示。
      class  ICC_ProfileGray
      ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为TYPE_GRAY，配置文件包含grayTRCTag和mediaWhitePointTag标签。
      class  ICC_ProfileRGB
      ICC_ProfileRGB类是ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为RGB。 该配置文件包含redColorantTag ， greenColorantTag ， blueColorantTag ， redTRCTag ， greenTRCTag ， blueTRCTag ，并mediaWhitePointTag标签。 当满足这些条件时， ICC_Profile getInstance方法将返回一个ICC_ProfileRGB对象。
      class  ProfileDataException
      在访问或处理ICC_Profile对象时发生错误时抛出此异常。

    • Uses of Serializable in java.awt.datatransfer

      Classes in java.awt.datatransfer that implement Serializable
      Modifier and Type Class 描述
      class  DataFlavor
      A DataFlavor提供有关数据的元信息。
      class  FlavorEvent
      FlavorEvent用于通知有关方面Clipboard （事件源）中可用的DataFlavor已更改。
      class  MimeTypeParseException
      封装MimeType解析相关异常的类。
      class  UnsupportedFlavorException
      表示在此风格中不支持请求的数据。

    • Uses of Serializable in java.awt.desktop

      Classes in java.awt.desktop that implement Serializable
      Modifier and Type Class 描述
      class  AboutEvent
      当应用程序被要求打开窗口时发送事件。
      class  AppEvent
      AppEvent被发送到安装在Desktop上的监听器和处理程序。
      class  AppForegroundEvent
      当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。
      class  AppHiddenEvent
      应用程序隐藏或显示时发送的事件。
      class  AppReopenedEvent
      当应用程序被要求重新打开时发送事件。
      class  FilesEvent
      辅助事件包含文件列表。
      class  OpenFilesEvent
      当应用程序被要求打开文件列表时发送事件。
      class  OpenURIEvent
      当应用程序被要求打开一个 URI时发送的事件。
      class  PreferencesEvent
      当请求应用程序打开其首选项窗口时发送事件。
      class  PrintFilesEvent
      当应用程序被要求打印文件列表时发送事件。
      class  QuitEvent
      当应用程序被要求退出时发送事件。
      class  QuitStrategy
      如果未启用“突发终止”，则用于关闭应用程序的策略。
      class  ScreenSleepEvent
      当系统显示器进入并退出省电睡眠时发送事件。
      class  SystemSleepEvent
      系统进入和退出省电休眠时发送的事件。
      class  UserSessionEvent
      用户会话更改时发送的事件。
      static class  UserSessionEvent.Reason
      用户会话更改的可能原因的种类。

    • Uses of Serializable in java.awt.dnd

      Classes in java.awt.dnd that implement Serializable
      Modifier and Type Class 描述
      class  DragGestureEvent
      当特定的 DragGestureRecognizer检测到正在跟踪的 Component发生平台相关的拖动启动手势时， DragGestureEvent将传递给 DragGestureListener的dragGestureRecognized（）方法。
      class  DragGestureRecognizer
      DragGestureRecognizer是一个用于规范平台相关的监听器的抽象基类，可以与特定的 Component相关联，以便识别平台相关的拖动启动手势。
      class  DragSource
      DragSource是负责启动拖放操作的实体，可用于多种情况：在该JVM的生命周期中，每个JVM使用1个默认实例。
      class  DragSourceContext
      DragSourceContext类负责管理拖放协议的发起方。
      class  DragSourceDragEvent
      该 DragSourceDragEvent是从 DragSourceContextPeer通过 DragSourceContext发送到 DragSourceListener注册 DragSourceContext及其相关联的 DragSource 。
      class  DragSourceDropEvent
      DragSourceDropEvent由 DragSourceContextPeer通过 DragSourceContext发送到 dragDropEnd方法，该 DragSourceListener注册了该 DragSourceContext及其相关联的 DragSource 。
      class  DragSourceEvent
      这个类是 DragSourceDragEvent和 DragSourceDropEvent的基类。
      class  DropTarget
      该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。
      class  DropTargetContext
      甲 DropTargetContext每当用拖放操作相关联的逻辑光标用的可见几何一致创建 Component与相关联 DropTarget 。
      class  DropTargetDragEvent
      所述 DropTargetDragEvent被输送到 DropTargetListener经由其dragEnter事件（）和的dragover（）方法。
      class  DropTargetDropEvent
      DropTargetDropEvent是通过 DropTargetListener drop（）方法提供的。
      class  DropTargetEvent
      DropTargetEvent是 DropTargetDragEvent和 DropTargetDropEvent的基础类。
      class  InvalidDnDOperationException
      java.awt.dnd包中的各种方法抛出此异常。
      class  MouseDragGestureRecognizer
      DragGestureRecognizer这个抽象子类定义了一个基于鼠标的手势的 DragGestureRecognizer 。

    • Uses of Serializable in java.awt.event

      Classes in java.awt.event that implement Serializable
      Modifier and Type Class 描述
      class  ActionEvent
      指示组件定义的动作发生的语义事件。
      class  AdjustmentEvent
      可调整对象发出的调整事件，如Scrollbar和ScrollPane 。
      class  ComponentEvent
      指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。
      class  ContainerEvent
      低级别事件，表示容器的内容因添加或删除组件而发生更改。
      class  FocusEvent
      指示组件已经获得或丢失了输入焦点的低级事件。
      static class  FocusEvent.Cause
      这个枚举代表一个 FocusEvent的原因 - 它发生的原因。
      class  HierarchyEvent
      指示 Component属于 Component层次结构的更改的事件。
      class  InputEvent
      所有组件级输入事件的根事件类。
      class  InputMethodEvent
      输入法事件包含使用输入法组合的文本信息。
      class  InvocationEvent
      在由AWT事件调度程序线程调度时，在 Runnable执行 run()方法的事件。
      class  ItemEvent
      表示选择或取消选择项目的语义事件。
      class  KeyEvent
      指示组件中发生击键的事件。
      class  MouseEvent
      指示组件中发生鼠标操作的事件。
      class  MouseWheelEvent
      指示鼠标轮在组件中旋转的事件。
      class  PaintEvent
      组件级paint事件。
      class  TextEvent
      表示对象的文本改变的语义事件。
      class  WindowEvent
      指示窗口已更改其状态的低级别事件。

    • Uses of Serializable in java.awt.font

      Classes in java.awt.font that implement Serializable
      Modifier and Type Class 描述
      class  NumericShaper
      NumericShaper类用于将Latin-1（欧洲）数字转换为其他Unicode十进制数字。
      static class  NumericShaper.Range
      A NumericShaper.Range表示具有其自己的十进制数字的脚本的Unicode范围。
      class  TextAttribute
      TextAttribute类定义用于文本呈现的属性键和属性值。
      class  TransformAttribute
      TransformAttribute类为变换提供了一个不可变的包装器，以便作为属性使用是安全的。

    • Uses of Serializable in java.awt.geom

      Classes in java.awt.geom that implement Serializable
      Modifier and Type Class 描述
      class  AffineTransform
      AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“直线度”和“平行度”。
      static class  Arc2D.Double
      此类定义了 double精度中指定的弧。
      static class  Arc2D.Float
      此类定义了 float精度中指定的弧。
      static class  CubicCurve2D.Double
      用 double坐标指定的三次参数曲线段。
      static class  CubicCurve2D.Float
      用 float坐标指定的三次参数曲线段。
      static class  Ellipse2D.Double
      Double类定义了 double精度中指定的椭圆。
      static class  Ellipse2D.Float
      Float类定义了 float精度中指定的椭圆。
      class  GeneralPath
      GeneralPath类代表由直线构成的几何路径，二次和立方（Bézier）曲线。
      class  IllegalPathStateException
      如果在相对于执行的特定操作处于非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段附加到GeneralPath 。
      static class  Line2D.Double
      用双坐标指定的线段。
      static class  Line2D.Float
      用浮点坐标指定的线段。
      class  NoninvertibleTransformException
      NoninvertibleTransformException类表示如果执行需要AffineTransform对象的反向但AffineTransform处于非可逆状态的操作时抛出的异常。
      static class  Path2D.Double
      Double类定义了一个几何路径，坐标存储在双精度浮点中。
      static class  Path2D.Float
      Float类定义了坐标存储在单精度浮点中的几何路径。
      static class  Point2D.Double
      Double类定义了 double精度中指定的点。
      static class  Point2D.Float
      Float类定义了浮点精度指定的点。
      static class  QuadCurve2D.Double
      用 double坐标指定的二次参数曲线段。
      static class  QuadCurve2D.Float
      用 float坐标指定的二次参数曲线段。
      static class  Rectangle2D.Double
      Double类定义了一个以双坐标指定的矩形。
      static class  Rectangle2D.Float
      Float类定义了一个以浮点坐标指定的矩形。
      static class  RoundRectangle2D.Double
      Double类定义了一个带有圆角的矩形，全部在 double坐标中指定。
      static class  RoundRectangle2D.Float
      Float类定义了一个具有圆角的矩形，全部在 float坐标中指定。

    • Uses of Serializable in java.awt.image

      Classes in java.awt.image that implement Serializable
      Modifier and Type Class 描述
      class  ImagingOpException
      所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。
      class  RasterFormatException
      如果RasterFormatException中有无效的布局信息，则会抛出RasterFormatException 。

    • Uses of Serializable in java.awt.image.renderable

      Classes in java.awt.image.renderable that implement Serializable
      Modifier and Type Class 描述
      class  ParameterBlock
      A ParameterBlock封装了所有关于RenderableImageOp或处理图像的其他类所需的源和参数（Objects）的信息。

    • Uses of Serializable in java.awt.print

      Classes in java.awt.print that implement Serializable
      Modifier and Type Class 描述
      class  PrinterAbortException
      所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。
      class  PrinterException
      PrinterException类及其子类用于指示在打印系统中发生异常情况。
      class  PrinterIOException
      该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。

    • Uses of Serializable in java.beans

      Classes in java.beans that implement Serializable
      Modifier and Type Class 描述
      class  IndexedPropertyChangeEvent
      只要符合JavaBeans¢规范（“bean”）的组件更改绑定的索引属性，就会传递“IndexedPropertyChange”事件。
      class  IntrospectionException
      内省时发生异常时抛出。
      class  PropertyChangeEvent
      只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。
      class  PropertyChangeSupport
      这是一个可以由支持绑定属性的bean使用的实用程序类。
      class  PropertyVetoException
      当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
      class  VetoableChangeSupport
      这是一个可以由支持约束属性的bean使用的实用程序类。

    • Uses of Serializable in java.beans.beancontext

      Classes in java.beans.beancontext that implement Serializable
      Modifier and Type | Class | 描述
      class  BeanContextChildSupport
      这是一个通用支持类，用于为实现BeanContextChild协议提供支持。
      class  BeanContextEvent
      BeanContextEvent是从 BeanContext的语义发出的所有事件的抽象根事件类。
      class  BeanContextMembershipEvent
      A BeanContextMembershipEvent封装了添加到特定 BeanContext的成员资格或从其中删除的子项列表。
      class  BeanContextServiceAvailableEvent
      BeanContextServicesListener使用此事件类型来识别正在注册的服务。
      class  BeanContextServiceRevokedEvent
      该事件类型由 BeanContextServiceRevokedListener用于识别正在撤销的服务。
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      protected class  | BeanContextServicesSupport.BCSSChild
      protected static class  BeanContextServicesSupport.BCSSServiceProvider
      子类可以将此嵌套类子类化为每个BeanContextServicesProvider添加行为。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。
      protected class  | BeanContextSupport.BCSChild
      Methods in java.beans.beancontext that return Serializable
      Modifier and Type 方法 描述
      protected static Serializable BeanContextSupport.getChildSerializable​(Object child)
      获取与指定的Child相关联的Serializable（如果有）

    • Uses of Serializable in java.io

      Subinterfaces of Serializable in java.io
      Modifier and Type 接口 描述
      interface  Externalizable
      只有Externalizable实例的类的身份才能写入序列化流中，并且该类负责保存和恢复其实例的内容。
      Classes in java.io that implement Serializable
      Modifier and Type Class 描述
      class  CharConversionException
      字符转换异常的基类。
      class  EOFException
      表示在输入过程中意外地到达文件结束或流结束。
      class  File
      文件和目录路径名的抽象表示。
      class  FileNotFoundException
      指示尝试打开由指定路径名表示的文件失败。
      class  FilePermission
      此类表示访问文件或目录。
      class  InterruptedIOException
      表示I / O操作已中断。
      class  InvalidClassException
      当序列化运行时检测到类中的以下问题之一时抛出。
      class  InvalidObjectException
      表示一个或多个反序列化对象失败的验证测试。
      class  IOError
      当出现严重I / O错误时抛出。
      class  IOException
      表示发生某种类型的I / O异常。
      class  NotActiveException
      序列化或反序列化不活跃时抛出。
      class  NotSerializableException
      抛出一个实例需要一个Serializable接口。
      static class  ObjectInputFilter.Status
      对类的检查状态，数组长度，引用次数，深度和流大小。
      class  ObjectStreamClass
      序列化的类的描述符。
      class  ObjectStreamException
      对象流类别特有的所有异常的超类。
      class  OptionalDataException
      表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。
      class  SerializablePermission
      这个类用于Serializable权限。
      class  StreamCorruptedException
      当从对象流读取的控制信息违反内部一致性检查时抛出。
      class  SyncFailedException
      发出同步操作失败的信号。
      class  UncheckedIOException
      包含一个IOException与未检查的异常。
      class  UnsupportedEncodingException
      字符编码不支持。
      class  UTFDataFormatException
      表示 modified UTF-8格式的格式不正确的字符串已被读入数据输入流或实现数据输入接口的任何类。
      class  WriteAbortedException
      指示在写入操作期间抛出ObjectStreamExceptions之一。

    • Uses of Serializable in java.lang

      Classes in java.lang that implement Serializable
      Modifier and Type Class 描述
      class  AbstractMethodError
      当应用程序尝试调用抽象方法时抛出。
      class  ArithmeticException
      抛出异常算术条件时抛出。
      class  ArrayIndexOutOfBoundsException
      抛出以表示使用非法索引访问数组。
      class  ArrayStoreException
      抛出以表示尝试将错误类型的对象存储到对象数组中。
      class  AssertionError
      抛出以表明断言失败。
      class  Boolean
      布尔类将对象中的基元类型 boolean的值进行包装。
      class  BootstrapMethodError
      抛出以表明invokedynamic指令未能找到其引导方法，或引导方法未能提供call site target正确的method type 。
      class  Byte
      Byte类在一个对象中包含一个基本类型 byte的值。
      class  Character
      Character类包装一个对象中的原始类型 char的值。
      static class  Character.UnicodeScript
      一系列字符子集，表示 Unicode Standard Annex #24: Script Names中定义的字符脚本。
      class  Class<T>
      类 Class实例表示正在运行的Java应用程序中的类和接口。
      class  ClassCastException
      抛出表示代码尝试将对象转换为不属于实例的子类。
      class  ClassCircularityError
      当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。
      class  ClassFormatError
      当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
      class  ClassNotFoundException
      的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
      class  CloneNotSupportedException
      抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
      class  Double
      Double类包装一个对象中的原始类型 double的值。
      class  Enum<E extends Enum<E>>
      这是所有Java语言枚举类型的公共基类。
      class  EnumConstantNotPresentException
      当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。
      class  Error
      一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
      class  异常
      异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
      class  ExceptionInInitializerError
      表示在静态初始化程序中发生意外异常。
      class  Float
      Float类在一个对象中包含一个基本类型 float的值。
      class  IllegalAccessError
      如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。
      class  IllegalAccessException
      当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
      class  IllegalArgumentException
      抛出表示一种方法已经通过了非法或不正确的参数。
      class  IllegalCallerException
      被抛出来表示一个方法已被不适当的调用者调用。
      class  IllegalMonitorStateException
      抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。
      class  IllegalStateException
      表示在非法或不适当的时间调用了一种方法。
      class  IllegalThreadStateException
      抛出以指示线程不处于所请求操作的适当状态。
      class  IncompatibleClassChangeError
      当一些类定义发生不兼容的类更改时抛出。
      class  IndexOutOfBoundsException
      抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
      class  InstantiationError
      当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。
      class  InstantiationException
      当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但是指定的类对象不能被实例化。
      class  Integer
      Integer类包装一个对象中的原始类型 int的值。
      class  InternalError
      在Java虚拟机中引发了一些意外的内部错误。
      class  InterruptedException
      线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
      class  LayerInstantiationException
      创建module layer时抛出失败。
      class  LinkageError
      LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
      class  Long
      Long类包装一个对象中的原始类型 long的值。
      class  NegativeArraySizeException
      抛出一个应用程序尝试创建一个负数大小的数组。
      class  NoClassDefFoundError
      如果Java虚拟机或 ClassLoader实例尝试加载类的定义（作为正常方法调用的一部分或作为使用 new表达式创建新实例的 new ），则不会发现类的定义。
      class  NoSuchFieldError
      如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。
      class  NoSuchFieldException
      表示该类没有指定名称的字段。
      class  NoSuchMethodError
      如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。
      class  NoSuchMethodException
      当无法找到特定方法时抛出。
      class  NullPointerException
      当应用程序在需要对象的情况下尝试使用 null时抛出。
      class  Number
      抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
      class  NumberFormatException
      抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
      class  OutOfMemoryError
      当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。
      static class  ProcessBuilder.Redirect.Type
      类型为ProcessBuilder.Redirect 。
      class  ReflectiveOperationException
      核心反射中的反射操作抛出的异常的常见超类。
      class  RuntimeException
      RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
      class  RuntimePermission
      此类用于运行时权限。
      class  SecurityException
      由安全管理员抛出，表示安全违规。
      class  Short
      Short类在一个对象中包含一个原始类型 short的值。
      class  StackOverflowError
      当堆栈溢出发生时抛出一个应用程序递归太深。
      class  StackTraceElement
      一个堆栈跟踪中的一个元素，由 Throwable.getStackTrace()返回。
      static class  StackWalker.Option
      堆栈步行器选项配置stack frame获取的信息由StackWalker 。
      class  String
      String类代表字符串。
      class  StringBuffer
      线程安全，可变的字符序列。
      class  StringBuilder
      一个可变的字符序列。
      class  StringIndexOutOfBoundsException
      抛出 String方法来指示索引为负或大于字符串的大小。
      static class  System.Logger.Level
      系统loggers级别。
      static class  Thread.State
      线程状态。
      class  ThreadDeath
      当调用（不推荐使用）的 Thread.stop()方法时， ThreadDeath的实例被抛出在受害者线程中。
      class  Throwable
      Throwable类是Java语言中所有错误和异常的超类。
      class  TypeNotPresentException
      当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。
      class  UnknownError
      当Java虚拟机中出现未知但严重的异常时抛出。
      class  UnsatisfiedLinkError
      如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。
      class  UnsupportedClassVersionError
      当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
      class  UnsupportedOperationException
      抛出以表示不支持请求的操作。
      class  VerifyError
      当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。
      class  VirtualMachineError
      抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。

    • Uses of Serializable in java.lang.annotation

      Classes in java.lang.annotation that implement Serializable
      Modifier and Type Class 描述
      class  AnnotationFormatError
      当注释解析器尝试从类文件读取注释并确定注释格式错误时抛出。
      class  AnnotationTypeMismatchException
      抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。
      class  ElementType
      这个枚举类型的常量提供了在Java程序中可能出现注释的句法位置的简单分类。
      class  IncompleteAnnotationException
      抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。
      class  RetentionPolicy
      注释保留政策。

    • Uses of Serializable in java.lang.instrument

      Classes in java.lang.instrument that implement Serializable
      Modifier and Type Class 描述
      class  IllegalClassFormatException
      当其输入参数无效时，实施 ClassFileTransformer.transform抛出。
      class  UnmodifiableClassException
      抛出一个执行 Instrumentation.redefineClasses当其中一个指定的类不能被修改。
      class  UnmodifiableModuleException
      抛出以表示模块无法修改。

    • Uses of Serializable in java.lang.invoke

      Classes in java.lang.invoke that implement Serializable
      Modifier and Type Class 描述
      class  LambdaConversionException
      LambdaConversionException
      class  MethodType
      方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。
      class  SerializedLambda
      lambda表达式的序列化形式。
      class  StringConcatException
      当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。
      static class  VarHandle.AccessMode
      指定如何访问由VarHandle引用的变量的访问模式集。
      class  WrongMethodTypeException
      抛出以表示代码尝试通过错误的方法类型调用方法句柄。

    • Uses of Serializable in java.lang.management

      Classes in java.lang.management that implement Serializable
      Modifier and Type Class 描述
      class  ManagementPermission
      当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。
      class  MemoryType
      类型memory pools 。

    • Uses of Serializable in java.lang.module

      Classes in java.lang.module that implement Serializable
      Modifier and Type Class 描述
      class  FindException
      抛出一个ModuleFinder当发现错误发现一个模块。
      class  InvalidModuleDescriptorException
      读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。
      static class  ModuleDescriptor.Exports.Modifier
      导出包上的修饰符。
      static class  ModuleDescriptor.Modifier
      模块上的修饰符。
      static class  ModuleDescriptor.Opens.Modifier
      打开包装上的修饰符。
      static class  ModuleDescriptor.Requires.Modifier
      模块依赖的修饰符。
      class  ResolutionException
      在解析一组模块或解析一组具有服务绑定的模块时抛出失败。

    • Uses of Serializable in java.lang.reflect

      Classes in java.lang.reflect that implement Serializable
      Modifier and Type Class 描述
      class  GenericSignatureFormatError
      当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。
      class  InaccessibleObjectException
      Java语言访问检查无法被抑制时抛出。
      class  InvocationTargetException
      InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
      class  MalformedParameterizedTypeException
      当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。
      class  MalformedParametersException
      当 the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。
      class  Proxy
      Proxy提供了静态方法来创建类似于接口实例的对象，但允许自定义的方法调用。
      class  ReflectPermission
      反思操作的权限类。
      class  UndeclaredThrowableException
      通过方法调用代理实例时抛出的调用处理程序的 invoke方法抛出检查异常（一 Throwable不是分配给 RuntimeException或者 Error ）是不能分配给任何中声明的异常类型 throws方法的条款，在代理实例上调用并分派到调用处理程序。

    • Uses of Serializable in java.math

      Classes in java.math that implement Serializable
      Modifier and Type Class 描述
      class  BigDecimal
      不变的，任意精度的带符号的十进制数字。
      class  BigInteger
      不可变的任意精度整数。
      class  MathContext
      封装描述数值运算符某些规则的上下文设置的不可变对象，例如由BigDecimal类实现的那些规则。
      class  RoundingMode
      指定能够丢弃精度的数值运算的 舍入行为 。

    • Uses of Serializable in java.net

      Classes in java.net that implement Serializable
      Modifier and Type Class 描述
      static class  Authenticator.RequestorType
      请求认证的实体的类型。
      class  BindException
      指示尝试将套接字绑定到本地地址和端口时发生错误。
      class  ConnectException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  HttpRetryException
      抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。
      class  Inet4Address
      该类表示Internet协议版本4（IPv4）地址。
      class  Inet6Address
      该类表示Internet协议版本6（IPv6）地址。
      class  InetAddress
      此类表示Internet协议（IP）地址。
      class  InetSocketAddress
      该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。
      class  MalformedURLException
      抛出以表示发生格式不正确的网址。
      class  NetPermission
      此类用于各种网络权限。
      class  NoRouteToHostException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  PortUnreachableException
      指示在连接的数据报上收到了ICMP端口不可达消息。
      class  ProtocolException
      抛出以表示底层协议有错误，如TCP错误。
      static class  Proxy.Type
      代表代理类型。
      class  SocketAddress
      这个类代表一个没有协议附件的Socket地址。
      class  SocketException
      抛出以表示创建或访问Socket时出错。
      class  SocketPermission
      此类表示通过套接字访问网络。
      class  SocketTimeoutException
      指示在套接字上发生超时时读取或接受。
      class  StandardProtocolFamily
      定义通信协议的标准系列。
      class  UnknownHostException
      抛出以表示无法确定主机的IP地址。
      class  UnknownServiceException
      抛出以表示发生未知服务异常。
      class  URI
      表示统一资源标识符（URI）参考。
      class  URISyntaxException
      检查的异常抛出以指示不能将字符串解析为URI引用。
      class  URL
      URL表示统一资源定位符，指向万维网上“资源”的指针。
      class  URLPermission
      表示访问由给定网址定义的资源或资源集的权限，以及给定的一组用户可设置的请求方法和请求标头。

    • Uses of Serializable in java.nio

      Classes in java.nio that implement Serializable
      Modifier and Type Class 描述
      class  BufferOverflowException
      相对 放置操作达到目标缓冲区限制时抛出的未检查异常。
      class  BufferUnderflowException
      当相对 get操作达到源缓冲区的限制时抛出未检查的异常。
      class  InvalidMarkException
      当未定义其标记时尝试复位缓冲区时抛出未检查的异常。
      class  ReadOnlyBufferException
      在只读缓冲区中调用诸如 put或 compact类的内容突变方法时抛出的未检查异常。

    • Uses of Serializable in java.nio.channels

      Classes in java.nio.channels that implement Serializable
      Modifier and Type Class 描述
      class  AcceptPendingException
      尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
      class  AlreadyBoundException
      尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
      class  AlreadyConnectedException
      尝试连接已连接的SocketChannel时 ，会抛出未检查的异常。
      class  AsynchronousCloseException
      当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
      class  CancelledKeyException
      当试图使用不再有效的选择键时抛出未检查的异常。
      class  ClosedByInterruptException
      另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。
      class  ClosedChannelException
      当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。
      class  ClosedSelectorException
      尝试在闭合选择器上调用I / O操作时抛出未检查的异常。
      class  ConnectionPendingException
      尝试连接未阻塞连接操作的SocketChannel时，会引发未检查的异常。
      class  FileLockInterruptionException
      另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。
      class  IllegalBlockingModeException
      当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。
      class  IllegalChannelGroupException
      尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。
      class  IllegalSelectorException
      当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。
      class  InterruptedByTimeoutException
      在异步操作完成之前经过一段时间后线程接收到的异常检查。
      class  NoConnectionPendingException
      当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
      class  NonReadableChannelException
      尝试从最初打开阅读的频道中读取时未抛出的异常。
      class  NonWritableChannelException
      尝试写入最初未打开的通道进行写入时抛出未检查的异常。
      class  NotYetBoundException
      尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
      class  NotYetConnectedException
      当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
      class  OverlappingFileLockException
      当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
      class  ReadPendingException
      尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
      class  ShutdownChannelGroupException
      当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。
      class  UnresolvedAddressException
      尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
      class  UnsupportedAddressTypeException
      尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。
      class  WritePendingException
      尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。

    • Uses of Serializable in java.nio.charset

      Classes in java.nio.charset that implement Serializable
      Modifier and Type Class 描述
      class  CharacterCodingException
      发生字符编码或解码错误时抛出的检查异常。
      class  CoderMalfunctionError
      错误抛出当decodeLoop方法的CharsetDecoder ，或encodeLoop一个的方法CharsetEncoder ，抛出意外的异常。
      class  IllegalCharsetNameException
      当使用不是 legal charset name的字符串时抛出未检查的异常。
      class  MalformedInputException
      当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
      class  UnmappableCharacterException
      输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。
      class  UnsupportedCharsetException
      对于请求的字符集，当没有可用的支持时抛出未检查的异常。

    • Uses of Serializable in java.nio.file

      Classes in java.nio.file that implement Serializable
      Modifier and Type Class 描述
      class  AccessDeniedException
      文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。
      class  AccessMode
      定义用于测试文件可访问性的访问模式。
      class  AtomicMoveNotSupportedException
      当文件不能作为原子文件系统操作移动时，检查的异常抛出。
      class  ClosedDirectoryStreamException
      尝试在关闭的目录流上调用操作时抛出未检查的异常。
      class  ClosedFileSystemException
      尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。
      class  ClosedWatchServiceException
      尝试在关闭的手表服务上调用操作时抛出未检查的异常。
      class  DirectoryIteratorException
      如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。
      class  DirectoryNotEmptyException
      由于目录不为空，文件系统操作失败时抛出的检查异常。
      class  FileAlreadyExistsException
      尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
      class  FileSystemAlreadyExistsException
      新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新
      class  FileSystemException
      在一个或两个文件上的文件系统操作失败时抛出。
      class  FileSystemLoopException
      当遇到文件系统循环或循环时抛出的检查异常。
      class  FileSystemNotFoundException
      无法找到文件系统时抛出的运行时异常。
      class  FileVisitOption
      定义文件树遍历选项。
      class  FileVisitResult
      结果类型为FileVisitor 。
      class  InvalidPathException
      当路径字符串无法转换为Path时，由于路径字符串包含无效字符或路径字符串对其他文件系统特定的原因无效，因此抛出未检查的异常。
      class  LinkOption
      定义如何处理符号链接的选项。
      class  LinkPermission
      Permission类链接创建操作。
      class  NoSuchFileException
      当尝试访问不存在的文件时抛出检查的异常。
      class  NotDirectoryException
      当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
      class  NotLinkException
      由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
      class  ProviderMismatchException
      当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。
      class  ProviderNotFoundException
      无法找到所需类型的提供者时抛出的运行时异常。
      class  ReadOnlyFileSystemException
      当尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。
      class  StandardCopyOption
      定义标准复制选项。
      class  StandardOpenOption
      定义标准的开放选项。

    • Uses of Serializable in java.nio.file.attribute

      Classes in java.nio.file.attribute that implement Serializable
      Modifier and Type Class 描述
      class  AclEntryFlag
      定义ACL entry的标志组件使用的标志。
      class  AclEntryPermission
      定义与ACL entry的权限组件一起使用的权限。
      class  AclEntryType
      访问控制条目类型的类型安全枚举。
      class  PosixFilePermission
      定义与 permissions属性一起使用的位。
      class  UserPrincipalNotFoundException
      当查询UserPrincipal失败，因为主体不存在时抛出的检查异常。

    • Uses of Serializable in java.rmi

      Classes in java.rmi that implement Serializable
      Modifier and Type Class 描述
      class  AccessException
      一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
      class  AlreadyBoundException
      如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出一个 AlreadyBoundException 。
      class  ConnectException
      如果连接被拒绝到远程主机进行远程方法调用，则抛出 ConnectException 。
      class  ConnectIOException
      如果在与远程主机进行远程方法调用的连接时发生 ConnectIOException则抛出 IOException 。
      class  MarshalException
      如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。
      class  MarshalledObject<T>
      A MarshalledObject包含一个字节流，其中包含给它的构造函数的对象的序列化表示。
      class  NoSuchObjectException
      如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
      class  NotBoundException
      如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出 NotBoundException 。
      class  RemoteException
      A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
      class  RMISecurityException
      已过时。
      改用SecurityException 。 应用程式代码永远不要直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。
      class  ServerError
      甲 ServerError被抛出作为远程方法调用的结果，当一个 Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。
      class  ServerException
      在处理服务器上的调用时抛出一个 RemoteException ，或者在解组参数或执行远程方法本身时，抛出 ServerException作为远程方法调用的结果。
      class  ServerRuntimeException
      已过时。
      没有替换
      class  StubNotFoundException
      如果远程对象导出时无法找到有效的存根类，则抛出 StubNotFoundException 。
      class  UnexpectedException
      如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口的方法的 throws子句中声明的检查的异常类型中。
      class  UnknownHostException
      如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
      class  UnmarshalException
      如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出 UnmarshalException ：如果发生异常时 java.io.IOException调用头，如果返回值的协议无效，如果 java.io.IOException发生解组参数（on服务器端）或返回值（在客户端）。

    • Uses of Serializable in java.rmi.activation

      Classes in java.rmi.activation that implement Serializable
      Modifier and Type Class 描述
      class  Activatable
      Activatable类为需要持续访问的远程对象提供支持，并且可以由系统激活。
      class  ActivateFailedException
      在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。
      class  ActivationDesc
      激活描述符包含激活对象所需的信息：对象的组标识符，对象的全限定类名，对象的代码位置（类的位置），代码库URL路径，对象的重新启动“模式”，以及，一个可以包含对象特定初始化数据的“编组”对象。
      class  ActivationException
      激活界面使用的常规异常。
      class  ActivationGroup
      一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor ：其对象变为活动或非活动，或组作为整体变为不活动。
      class  ActivationGroup_Stub
      ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup的子类的存根类。
      class  ActivationGroupDesc
      激活组描述符包含创建/重新创建激活对象的激活组所需的信息。
      static class  ActivationGroupDesc.CommandEnvironment
      ActivationGroup实现的启动选项。
      class  ActivationGroupID
      注册激活组的标识符有几个目的：在激活系统中唯一标识组，并包含对组的激活系统的引用，以便组可以在必要时联系其激活系统。
      class  ActivationID
      激活使用特殊标识符来表示可以随时间激活的远程对象。
      class  UnknownGroupException
      一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。
      class  UnknownObjectException
      当方法的 ActivationID参数被确定为无效时，通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。

    • Uses of Serializable in java.rmi.dgc

      Classes in java.rmi.dgc that implement Serializable
      Modifier and Type Class 描述
      class  Lease
      租赁包含唯一的VM标识符和租期。
      class  VMID
      VMID是所有Java虚拟机中唯一的标识符。

    • Uses of Serializable in java.rmi.server

      Subinterfaces of Serializable in java.rmi.server
      Modifier and Type 接口 描述
      interface  RemoteRef
      RemoteRef表示远程对象的句柄。
      interface  ServerRef
      已过时。
      没有替换 此接口未使用，已过时。
      Classes in java.rmi.server that implement Serializable
      Modifier and Type Class 描述
      class  ExportException
      一个 ExportException是 RemoteException如果导出远程对象的尝试失败抛出。
      class  ObjID
      ObjID用于标识导出到RMI运行时的远程对象。
      class  RemoteObject
      RemoteObject类实现了远程对象的 java.lang.Object行为。
      class  RemoteObjectInvocationHandler
      用于Java Remote Method Invocation（Java RMI）的 InvocationHandler接口的实现。
      class  RemoteServer
      RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。
      class  RemoteStub
      已过时。
      静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
      class  ServerCloneException
      甲 ServerCloneException如果一个的克隆过程中发生远程抛出异常 UnicastRemoteObject 。
      class  ServerNotActiveException
      如果在服务远程方法调用之外调用getClientHost方法，那么 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。
      class  SkeletonMismatchException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SkeletonNotFoundException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SocketSecurityException
      已过时。
      这个班已经过时了 改用ExportException 。
      class  UID
      A UID表示相对于其在其上生成的主机或其中 16个 “知名”标识符之一的随着时间而言是唯一的标识符。
      class  UnicastRemoteObject
      用于使用JRMP导出远程对象并获取与远程对象通信的存根。

    • Uses of Serializable in java.security

      Subinterfaces of Serializable in java.security
      Modifier and Type 接口 描述
      interface  Key
      Key界面是所有键的顶级界面。
      interface  PrivateKey
      私钥。
      interface  PublicKey
      公钥
      Classes in java.security that implement Serializable
      Modifier and Type Class 描述
      class  AccessControlException
      AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
      class  AllPermission
      AllPermission是一个隐含所有其他权限的权限。
      class  AuthProvider
      此类为提供程序定义登录和注销方法。
      class  BasicPermission
      BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。
      class  CodeSigner
      该类封装了有关代码签名者的信息。
      class  CodeSource
      该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。
      class  CryptoPrimitive
      加密原语的枚举。
      class  DigestException
      这是通用的消息摘要异常。
      static class  DrbgParameters.Capability
      DRBG的可重新预测和预测抵抗能力。
      class  GeneralSecurityException
      GeneralSecurityException类是一种通用的安全性异常类，它为所有与其扩展的与安全性相关的异常类提供了类型安全性。
      class  GuardedObject
      GuardedObject是一个用于保护对另一个对象的访问的对象。
      class  Identity
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  IdentityScope
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  InvalidAlgorithmParameterException
      这是无效或不合适的算法参数的例外。
      class  InvalidKeyException
      这是无效键（无效编码，长度错误，未初始化等）的例外。
      class  InvalidParameterException
      当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
      class  KeyException
      这是基本的关键例外。
      class  KeyManagementException
      这是处理密钥管理的所有操作的一般密钥管理例外。
      class  KeyPair
      这个类是密钥对（一个公钥和一个私钥）的简单持有者。
      class  KeyRep
      序列化关键对象的标准化表示。
      static class  KeyRep.Type
      钥匙类型
      class  KeyStoreException
      这是通用的KeyStore异常。
      class  NoSuchAlgorithmException
      当请求特定的加密算法但在环境中不可用时抛出此异常。
      class  NoSuchProviderException
      当特定安全提供程序被请求但在环境中不可用时抛出此异常。
      class  Permission
      用于表示访问系统资源的抽象类。
      class  PermissionCollection
      代表Permission对象集合的抽象类。
      class  Permissions
      此类表示许多权限的异构集合。
      class  PrivilegedActionException
      这个异常是由 doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)抛出的，表示正在执行的操作会抛出一个被检查的异常。
      class  Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。
      class  ProviderException
      提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。
      class  SecureRandom
      这个类提供了一个密码强的随机数生成器（RNG）。
      class  SecureRandomSpi
      该类定义了SecureRandom类的 （ SPI ）。
      class  SecurityPermission
      此类用于安全权限。
      class  SignatureException
      这是一般的签名异常。
      class  SignedObject
      SignedObject是一个类，用于创建可靠的运行时对象，其完整性不会受到威胁，而不会被检测到。
      class  Signer
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  Timestamp
      此类封装了有关已签名时间戳的信息。
      class  UnrecoverableEntryException
      如果密钥库中的条目无法恢复，则抛出此异常。
      class  UnrecoverableKeyException
      如果密钥存储库中的密钥无法恢复，则抛出此异常。
      class  UnresolvedPermission
      UnresolvedPermission类用于保存初始化策略时“未解决”的权限。
      Constructors in java.security with parameters of type Serializable
      Constructor 描述
      SignedObject​(Serializable object, PrivateKey signingKey, Signature signingEngine)
      从任何可序列化对象构造一个SignedObject。

    • Uses of Serializable in java.security.acl

      Classes in java.security.acl that implement Serializable
      Modifier and Type Class 描述
      class  AclNotFoundException
      已过时。
      自1.2以来，该软件包已被java.security.Policy及相关课程所取代。
      class  LastOwnerException
      已过时。
      自1.2版本以来，该软件已经被java.security.Policy和相关类替代了。
      class  NotOwnerException
      已过时。
      自1.2以来，该软件包已被java.security.Policy及相关课程所取代。

    • Uses of Serializable in java.security.cert

      Subinterfaces of Serializable in java.security.cert
      Modifier and Type 接口 描述
      static interface  CertPathValidatorException.Reason
      验证算法失败的原因。
      Classes in java.security.cert that implement Serializable
      Modifier and Type Class 描述
      class  Certificate
      用于管理各种身份证件的抽象类。
      protected static class  Certificate.CertificateRep
      用于序列化的替代证书类。
      class  CertificateEncodingException
      证书编码异常。
      class  CertificateException
      此异常表示各种证书问题之一。
      class  CertificateExpiredException
      证书过期例外
      class  CertificateNotYetValidException
      证书还没有有效的例外。
      class  CertificateParsingException
      证书解析异常。
      class  CertificateRevokedException
      表示X.509证书的异常被撤销。
      class  CertPath
      证书的不可变序列（认证路径）。
      protected static class  CertPath.CertPathRep
      候补 CertPath类用于序列化。
      class  CertPathBuilderException
      一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。
      class  CertPathValidatorException
      表示验证认证路径时遇到的各种问题之一的异常。
      static class  CertPathValidatorException.BasicReason
      BasicReason列举了任何类型的认证路径可能无效的潜在原因。
      class  CertStoreException
      一个例外，指出从 CertStore检索证书和CRL的各种问题。
      class  CRLException
      CRL（证书撤销列表）异常。
      class  CRLReason
      CRLReason枚举指定了撤销证书的原因，如 RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile中所定义。
      class  PKIXReason
      PKIXReason列举了PKIX特有的原因，即根据PKIX（RFC 5280）标准，X.509认证路径可能无效。
      static class  PKIXRevocationChecker.Option
      可以为吊销检查机制指定的各种撤销选项。
      class  X509Certificate
      X.509证书的抽象类。

    • Uses of Serializable in java.security.interfaces

      Subinterfaces of Serializable in java.security.interfaces
      Modifier and Type 接口 描述
      interface  DSAPrivateKey
      DSA私钥的标准接口。
      interface  DSAPublicKey
      DSA公钥的接口。
      interface  ECPrivateKey
      椭圆曲线（EC）私钥的界面。
      interface  ECPublicKey
      椭圆曲线（EC）公钥的界面。
      interface  RSAMultiPrimePrivateCrtKey
      与PKCS＃1 v2.1中定义的使用 中国剩余定理 （CRT）信息值的RSA多权限私钥的接口。
      interface  RSAPrivateCrtKey
      使用 中国剩余定理 （CRT）信息值的PKCS＃1标准中定义的RSA私钥的接口。
      interface  RSAPrivateKey
      RSA私钥的接口。
      interface  RSAPublicKey
      与RSA公钥的接口。

    • Uses of Serializable in java.security.spec

      Classes in java.security.spec that implement Serializable
      Modifier and Type Class 描述
      class  InvalidKeySpecException
      这是无效密钥规范的例外。
      class  InvalidParameterSpecException
      这是无效参数规范的例外。

    • Uses of Serializable in java.sql

      Classes in java.sql that implement Serializable
      Modifier and Type Class 描述
      class  BatchUpdateException
      在批量更新操作期间发生错误时，抛出SQLException的子类。
      class  ClientInfoStatus
      通过拨打 Connection.setClientInfo无法设置属性的状态的枚举
      class  DataTruncation
      由于 DataTruncation异常超出 MaxFieldSize数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取）。
      class  Date
      一个 DATE包装器绕着一个毫秒值，允许JDBC将其识别为SQL DATE值。
      class  JDBCType
      定义用于标识通用SQL类型（称为JDBC类型）的常量。
      class  PseudoColumnUsage
      伪/隐藏列使用枚举。
      class  RowIdLifetime
      RowId寿命值的枚举。
      class  SQLClientInfoException
      当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。
      class  SQLDataException
      当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLException
      提供有关数据库访问错误或其他错误的信息的异常。
      class  SQLFeatureNotSupportedException
      当SQLState类的值为' 0A '（值为'零'A）时，抛出SQLException的子类。
      class  SQLIntegrityConstraintViolationException
      当SQLState类值为' 23 '时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLInvalidAuthorizationSpecException
      当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLNonTransientConnectionException
      为SQLState类值“ 08 ”或在供应商指定的条件下抛出的子类为SQLException 。
      class  SQLNonTransientException
      当一个重试相同操作的实例将失败的情况下抛出SQLException的子类，除非修正了SQLException的原因。
      class  SQLPermission
      SecurityManager将在启用 SecurityManager运行应用程序的代码时检查的权限，调用 DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （弃用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或 Connection.abort方法。
      class  SQLRecoverableException
      如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，先前失败的操作可能能够成功的情况下抛出SQLException的子类。
      class  SQLSyntaxErrorException
      当SQLState类值为' 42 '时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTimeoutException
      的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。
      class  SQLTransactionRollbackException
      当SQLState类值为' 40 '时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTransientConnectionException
      SQLState类值为“ 08 ”的SQLException的子类，或供应商指定的条件。
      class  SQLTransientException
      SQLException的子类在以前失败的操作可能能够在没有应用程序级功能的任何干预的情况下重试操作时能够成功的情况下抛出。
      class  SQLWarning
      提供有关数据库访问警告的信息的异常。
      class  Time
      围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
      class  Timestamp
      一个围绕 java.util.Date的薄包装，允许JDBC API将其识别为SQL TIMESTAMP值。

    • Uses of Serializable in java.text

      Classes in java.text that implement Serializable
      Modifier and Type Class 描述
      static class  AttributedCharacterIterator.Attribute
      定义用于标识文本属性的属性键。
      class  ChoiceFormat
      A ChoiceFormat允许您将格式附加到一系列数字。
      class  DateFormat
      DateFormat是一种用于日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
      static class  DateFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
      class  DateFormatSymbols
      DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，星期几的名称和时区数据。
      class  DecimalFormat
      DecimalFormat是格式为十进制数的 NumberFormat的具体子类。
      class  DecimalFormatSymbols
      此类表示 DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。
      class  Format
      Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
      static class  Format.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。
      class  MessageFormat
      MessageFormat提供了一种以语言中立的方式产生级联消息的方法。
      static class  MessageFormat.Field
      定义从 MessageFormat.formatToCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。
      static class  Normalizer.Form
      此枚举提供了 Unicode Standard Annex #15 — Unicode Normalization Forms中描述的四个Unicode归一化表单的常量，以及访问它们的两种方法。
      class  NumberFormat
      NumberFormat是所有数字格式的抽象基类。
      static class  NumberFormat.Field
      定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。
      class  ParseException
      表示解析时意外出现错误。
      class  SimpleDateFormat
      SimpleDateFormat是一个具体的类，用于以区域设置敏感的方式格式化和解析日期。

    • Uses of Serializable in java.time

      Classes in java.time that implement Serializable
      Modifier and Type Class 描述
      class  DateTimeException
      用于在计算日期时间时指示问题的异常。
      class  DayOfWeek
      星期几，如“星期二”。
      class  Duration
      基于时间的时间量，如'34.5秒'。
      class  Instant
      在时间线上的瞬间点。
      class  LocalDate
      在ISO- 2007-12-03 ，如 2007-12-03 。
      class  LocalDateTime
      在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
      class  LocalTime
      在ISO- 10:15:30 ，如 10:15:30 。
      class  Month
      一个月，如“七月”。
      class  MonthDay
      ISO- --12-03 ，如 --12-03 。
      class  OffsetDateTime
      在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
      class  OffsetTime
      在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
      class  Period
      ISO-8601日历系统中的日期时间，例如“2年3个月4天”。
      class  Year
      一年在ISO- 2007 ，如 2007 。
      class  YearMonth
      ISO- 2007-12 ，如 2007-12 。
      class  ZonedDateTime
      ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
      class  ZoneId
      时区ID，如 Europe/Paris 。
      class  ZoneOffset
      与格林威治/ UTC的时区偏移，如 +02:00 。

    • Uses of Serializable in java.time.chrono

      Classes in java.time.chrono that implement Serializable
      Modifier and Type Class 描述
      class  HijrahChronology
      Hijrah日历是支持伊斯兰教日历的农历。
      class  HijrahDate
      日期在Hijrah日历系统。
      class  HijrahEra
      Hijrah日历系统中的一个时代。
      class  IsoChronology
      ISO日历系统。
      class  IsoEra
      ISO日历系统中的一个时代。
      class  JapaneseChronology
      日本帝国历法系统。
      class  JapaneseDate
      在日本帝国日历系统的日期。
      class  JapaneseEra
      日本帝国日历系统的一个时代。
      class  MinguoChronology
      国际日历系统。
      class  MinguoDate
      在日语系统中的日期。
      class  MinguoEra
      国际日历系统中的一个时代。
      class  ThaiBuddhistChronology
      泰国佛教日历系统。
      class  ThaiBuddhistDate
      在泰国佛教日历系统的日期。
      class  ThaiBuddhistEra
      泰国佛教日历系统的时代。

    • Uses of Serializable in java.time.format

      Classes in java.time.format that implement Serializable
      Modifier and Type Class 描述
      class  DateTimeParseException
      解析期间发生错误时抛出异常。
      class  FormatStyle
      枚举本地化日期，时间或日期时间格式化的风格。
      class  ResolverStyle
      列举不同的方式来解决日期和时间。
      class  SignStyle
      列举处理正/负号的方法。
      class  TextStyle
      枚举文本格式和解析的风格。

    • Uses of Serializable in java.time.temporal

      Classes in java.time.temporal that implement Serializable
      Modifier and Type Class 描述
      class  ChronoField
      一套标准的字段。
      class  ChronoUnit
      一组标准的日期单位。
      class  UnsupportedTemporalTypeException
      UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。
      class  ValueRange
      日期时间字段的有效值的范围。
      class  WeekFields
      星期几，星期周和周末字段的本地化定义。

    • Uses of Serializable in java.time.zone

      Classes in java.time.zone that implement Serializable
      Modifier and Type Class 描述
      class  ZoneOffsetTransition
      由本地时间线不连续性引起的两个偏移之间的转换。
      class  ZoneOffsetTransitionRule
      表达如何创建转换的规则。
      static class  ZoneOffsetTransitionRule.TimeDefinition
      本地时间可以转换为实际转换日期时间的方式的定义。
      class  ZoneRules
      定义区域偏移对于单个时区的变化的规则。
      class  ZoneRulesException
      抛出指示时区配置的问题。

    • Uses of Serializable in java.util

      Classes in java.util that implement Serializable
      Modifier and Type Class 描述
      static class  AbstractMap.SimpleEntry<K,V>
      保存密钥和值的条目。
      static class  AbstractMap.SimpleImmutableEntry<K,V>
      保持一个不变的钥匙和价值的条目。
      class  ArrayDeque<E>
      Deque接口的可调整大小的数组实现。
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  BitSet
      该类实现了根据需要增长的位向量。
      class  Calendar
      所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
      class  ConcurrentModificationException
      当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。
      class  Currency
      代表货币。
      class  Date
      Date类代表了一个特定的时间，以毫秒的精度。
      class  DuplicateFormatFlagsException
      在格式说明符中提供重复标志时抛出未经检查的异常。
      class  EmptyStackException
      由 Stack类中的方法抛出，表示堆栈为空。
      class  EnumMap<K extends Enum<K>,V>
      专门用于枚举类型键的Map实现。
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      class  EventObject
      所有事件状态对象应从其派生的根类。
      class  FormatFlagsConversionMismatchException
      转换和标志不兼容时抛出未经检查的异常。
      static class  Formatter.BigDecimalLayoutForm
      枚举为 BigDecimal格式化。
      class  FormatterClosedException
      格式化程序已关闭时抛出未检查的异常。
      class  GregorianCalendar
      GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。
      class  HashMap<K,V>
      基于哈希表的实现的 Map接口。
      class  HashSet<E>
      该类实现 Set接口，由哈希表（实际为 HashMap实例）支持。
      class  Hashtable<K,V>
      该类实现了一个哈希表，它将键映射到值。
      class  IdentityHashMap<K,V>
      该类使用哈希表实现 Map接口，在比较键（和值）时使用引用相等代替对象相等。
      class  IllegalFormatCodePointException
      当由Character.isValidCodePoint(int)定义的具有无效Unicode代码的字符的字符传递给Formatter时，会抛出未经检查的异常。
      class  IllegalFormatConversionException
      当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。
      class  IllegalFormatException
      当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。
      class  IllegalFormatFlagsException
      提供非法组合标志时抛出未检查的异常。
      class  IllegalFormatPrecisionException
      当精度为 -1以外的负值时，抛出未经检查的异常，转换不支持精度，否则不支持该值。
      class  IllegalFormatWidthException
      当格式宽度为 -1以外的否定值时，抛出未经检查的异常，否则不受支持。
      class  IllformedLocaleException
      通过Locale和Locale.Builder中的方法抛出，以表明参数不是一个格式正确的BCP 47标签。
      class  InputMismatchException
      由 Scanner抛出，以指示所检索的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。
      class  InvalidPropertiesFormatException
      抛出以表示操作无法完成，因为输入符合Properties规范的属性集合的相应XML文档类型。
      class  LinkedHashMap<K,V>
      哈希表和链表实现的 Map接口，具有可预测的迭代次序。
      class  LinkedHashSet<E>
      哈希表和链表实现的 Set接口，具有可预测的迭代次序。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  Locale
      一个 Locale对象代表一个具体的地理，政治或文化地区。
      static class  Locale.Category
      枚举地区类别。
      static class  Locale.FilteringMode
      此枚举提供常量来选择区域设置匹配的过滤模式。
      static class  Locale.IsoCountryCode
      用于指定ISO 3166中定义的类型的枚举。
      class  MissingFormatArgumentException
      当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
      class  MissingFormatWidthException
      需要格式宽度时抛出未检查的异常。
      class  MissingResourceException
      表示资源丢失。
      class  NoSuchElementException
      被各种访问器方法抛出，表示被请求的元素不存在。
      class  PriorityQueue<E>
      基于优先级堆的无限优先级queue 。
      class  Properties
      Properties类表示一组持久的属性。
      class  PropertyPermission
      此类用于属性权限。
      class  Random
      该类的实例用于生成伪随机数的流。
      class  ServiceConfigurationError
      在查找，加载或实例化服务提供商时发生错误时发生错误。
      class  SimpleTimeZone
      SimpleTimeZone是一个具体子类 TimeZone ，表示一个使用格里高利历的时区。
      class  Stack<E>
      Stack类代表了先进先出（LIFO）的堆栈。
      class  TimeZone
      TimeZone代表时区偏移，也可以计算出夏令时。
      class  TooManyListenersException
      TooManyListenersException异常用作Java事件模型的一部分，用于注释和实现组播事件源的单播特殊情况。
      class  TreeMap<K,V>
      一个基于红黑树的NavigableMap实现。
      class  TreeSet<E>
      一个NavigableSet实现基于一个TreeMap 。
      class  UnknownFormatConversionException
      给出未知转换时抛出未检查的异常。
      class  UnknownFormatFlagsException
      给定未知标志时抛出未检查的异常。
      class  UUID
      一个表示不可变的通用唯一标识符（UUID）的类。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。

    • Uses of Serializable in java.util.concurrent

      Classes in java.util.concurrent that implement Serializable
      Modifier and Type Class 描述
      class  ArrayBlockingQueue<E>
      有限的blocking queue由数组支持。
      class  BrokenBarrierException
      当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。
      class  CancellationException
      异常表示由于任务被取消，无法检索生成值的任务（如FutureTask）的结果。
      class  CompletionException
      在完成结果或任务的过程中遇到错误或其他异常时抛出异常。
      class  ConcurrentHashMap<K,V>
      支持检索的完全并发性和更新的高预期并发性的哈希表。
      static class  ConcurrentHashMap.KeySetView<K,V>
      ConcurrentHashMap视图为Set的键，其中可以通过映射到公共值来选择添加。
      class  ConcurrentLinkedDeque<E>
      基于链接节点的无界并发deque 。
      class  ConcurrentLinkedQueue<E>
      基于链接节点的无界线程安全queue 。
      class  ConcurrentSkipListMap<K,V>
      一个可扩展的并发ConcurrentNavigableMap实现。
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      class  CopyOnWriteArrayList<E>
      的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。
      class  CopyOnWriteArraySet<E>
      A Set 对其所有操作使用内部CopyOnWriteArrayList 。
      class  CountedCompleter<T>
      A ForkJoinTask ，当触发时执行完成操作，并且没有剩余的待处理操作。
      class  ExecutionException
      尝试检索通过抛出异常中止的任务的结果时抛出的异常。
      class  ForkJoinTask<V>
      ForkJoinPool中运行的任务的抽象基类。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
      class  LinkedBlockingQueue<E>
      基于链接节点的可选限定的blocking queue 。
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
      class  PriorityBlockingQueue<E>
      无限blocking queue使用与类别PriorityQueue相同的排序规则，并提供阻止检索操作。
      class  RecursiveAction
      一个递归结果ForkJoinTask 。
      class  RecursiveTask<V>
      递归结果ForkJoinTask 。
      class  RejectedExecutionException
      当一个任务不能被接受执行时，由一个Executor抛出的异常。
      class  Semaphore
      一个计数信号量。
      class  SynchronousQueue<E>
      A blocking queue其中每个插入操作必须等待另一个线程进行相应的删除操作，反之亦然。
      class  ThreadLocalRandom
      与当前线程隔离的随机数生成器。
      class  TimeoutException
      阻塞操作超时时抛出异常。
      class  TimeUnit
      A TimeUnit表示给定的粒度单位的持续时间，并提供了跨单元转换的实用方法，并在这些单元中执行定时和延迟操作。

    • Uses of Serializable in java.util.concurrent.atomic

      Classes in java.util.concurrent.atomic that implement Serializable
      Modifier and Type Class 描述
      class  AtomicBoolean
      可能原子更新的值为 boolean 。
      class  AtomicInteger
      可能原子更新的值为 int 。
      class  AtomicIntegerArray
      一个 int阵列，其中元素可以原子更新。
      class  AtomicLong
      A long可能原子更新的值。
      class  AtomicLongArray
      其中元素可以原子更新的 long阵列。
      class  AtomicReference<V>
      可以原子更新的对象引用。
      class  AtomicReferenceArray<E>
      可以以原子方式更新元素的对象引用数组。
      class  DoubleAccumulator
      一个或多个变量，它们一起保持运行 double使用所提供的功能更新值。
      class  DoubleAdder
      一个或多个变量一起保持初始为零 double和。
      class  LongAccumulator
      使用提供的功能更新一个或多个变量，共同维护正在运行的 long值。
      class  LongAdder
      一个或多个变量一起保持初始为零 long总和。

    • Uses of Serializable in java.util.concurrent.locks

      Classes in java.util.concurrent.locks that implement Serializable
      Modifier and Type Class 描述
      class  AbstractOwnableSynchronizer
      可以由线程专有的同步器。
      class  AbstractQueuedLongSynchronizer
      的一个版本AbstractQueuedSynchronizer ，其中同步状态保持为long 。
      class  AbstractQueuedLongSynchronizer.ConditionObject
      条件实施为AbstractQueuedLongSynchronizer作为Lock实施的基础。
      class  AbstractQueuedSynchronizer
      提供一个框架，用于实现依赖先进先出（FIFO）等待队列的阻塞锁和相关同步器（信号量，事件等）。
      class  AbstractQueuedSynchronizer.ConditionObject
      条件实施AbstractQueuedSynchronizer作为Lock实施的基础。
      class  ReentrantLock
      一个可重入的互斥Lock具有与使用synchronized方法和语句访问的隐式监视锁相同的基本行为和语义，但具有扩展功能。
      class  ReentrantReadWriteLock
      ReadWriteLock的实现支持类似的语义到ReentrantLock 。
      static class  ReentrantReadWriteLock.ReadLock
      方法 ReentrantReadWriteLock.readLock()返回的锁。
      static class  ReentrantReadWriteLock.WriteLock
      该锁由方法 ReentrantReadWriteLock.writeLock()返回。
      class  StampedLock
      一种基于能力的锁，具有三种模式用于控制读/写访问。

    • Uses of Serializable in java.util.jar

      Classes in java.util.jar that implement Serializable
      Modifier and Type Class 描述
      class  JarException
      表示在读取或写入JAR文件时发生了某种错误。

    • Uses of Serializable in java.util.logging

      Classes in java.util.logging that implement Serializable
      Modifier and Type Class 描述
      class  Level
      Level类定义了一组可用于控制日志输出的标准日志记录级别。
      class  LoggingPermission
      当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。
      class  LogRecord
      LogRecord对象用于在日志框架和各个日志处理程序之间传递日志请求。

    • Uses of Serializable in java.util.prefs

      Classes in java.util.prefs that implement Serializable
      Modifier and Type Class 描述
      class  BackingStoreException
      抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。
      class  InvalidPreferencesFormatException
      被抛出以表示操作无法完成，因为输入符合Preferences规范的偏好集合的相应XML文档类型。
      class  NodeChangeEvent
      由 Preferences节点发出的一个事件，指示已添加或删除该节点的子节点。
      class  PreferenceChangeEvent
      由 Preferences节点发出的一个事件，表示已添加，删除或已更改其值的首选项。

    • Uses of Serializable in java.util.regex

      Classes in java.util.regex that implement Serializable
      Modifier and Type Class 描述
      class  Pattern
      正则表达式的编译表示。
      class  PatternSyntaxException
      抛出未经检查的异常，以指示正则表达式模式中的语法错误。

    • Uses of Serializable in java.util.stream

      Classes in java.util.stream that implement Serializable
      Modifier and Type Class 描述
      static class  Collector.Characteristics
      指示 Collector属性的特性，可用于优化还原实现。

    • Uses of Serializable in java.util.zip

      Classes in java.util.zip that implement Serializable
      Modifier and Type Class 描述
      class  DataFormatException
      发出数据格式错误的信号。
      class  ZipError
      表示发生了不可恢复的错误。
      class  ZipException
      表示发生了某种类型的Zip异常。

    • Uses of Serializable in javafx.animation

      Classes in javafx.animation that implement Serializable
      Modifier and Type Class 描述
      static class  Animation.Status
      可能的状态为 status 。
      static class  PathTransition.OrientationType
      指定 node沿 path的直立方向。

    • Uses of Serializable in javafx.application

      Classes in javafx.application that implement Serializable
      Modifier and Type Class 描述
      class  ConditionalFeature
      定义一组条件（可选）功能。
      static class  Preloader.StateChangeNotification.Type
      枚举，定义与此通知相关联的更改类型

    • Uses of Serializable in javafx.concurrent

      Classes in javafx.concurrent that implement Serializable
      Modifier and Type Class 描述
      static class  Worker.State
      工人的状态。
      class  WorkerStateEvent
      当一个工人状态发生变化时发生的事件。

    • Uses of Serializable in javafx.css

      Classes in javafx.css that implement Serializable
      Modifier and Type Class 描述
      class  SizeUnits
      表示特定单位中指定的大小，例如14px或0.2em。
      class  StyleOrigin
      枚举样式表和样式的可能来源或来源。

    • Uses of Serializable in javafx.embed.swing

      Classes in javafx.embed.swing that implement Serializable
      Modifier and Type Class 描述
      class  JFXPanel
      JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。

    • Uses of Serializable in javafx.event

      Classes in javafx.event that implement Serializable
      Modifier and Type Class 描述
      class  ActionEvent
      一个Event代表一些类型的动作。
      class  Event
      FX事件的基础类。
      class  EventType<T extends Event>
      此类表示与 Event相关联的特定事件类型。

    • Uses of Serializable in javafx.fxml

      Classes in javafx.fxml that implement Serializable
      Modifier and Type Class 描述
      class  LoadException
      在加载操作期间遇到错误时抛出。

    • Uses of Serializable in javafx.geometry

      Classes in javafx.geometry that implement Serializable
      Modifier and Type Class 描述
      class  HorizontalDirection
      表示水平方向的枚举。
      class  HPos
      用于描述水平定位和对齐的一组值。
      class  NodeOrientation
      一组用于描述节点视觉数据流的值。
      class  Orientation
      方向
      class  Pos
      一组用于描述垂直和水平定位和对齐的值。
      class  Side
      枚举哪个方面应该是一个矩形。
      class  VerticalDirection
      表示垂直方向的枚举。
      class  VPos
      一组用于描述垂直定位和对齐的值。

    • Uses of Serializable in javafx.print

      Classes in javafx.print that implement Serializable
      Modifier and Type Class 描述
      class  Collation
      排序规则指定作业中打印文档的每个副本的介质页是否是顺序的。
      class  PageOrientation
      指定打印页面的介质页的方向。
      class  PrintColor
      描述打印是单色还是彩色的类。
      static class  Printer.MarginType
      MarginType用于确定PageLayout的可打印区域。
      static class  PrinterJob.JobStatus
      用于报告打印作业状态的枚举类。
      class  PrintQuality
      分类打印质量设置。
      class  PrintSides
      列举可能的双面（双面）打印模式的类。

    • Uses of Serializable in javafx.scene

      Classes in javafx.scene that implement Serializable
      Modifier and Type Class 描述
      class  AccessibleAction
      该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。
      class  AccessibleAttribute
      该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
      class  AccessibleRole
      X-4545 X-4545 X-4545 X-4545 X-4545 X-4545 X-4545 X-4545 X-4545 X-4545 X-45 X-4545 X-
      class  CacheHint
      缓存提示与 Node.cacheHint一起使用
      class  DepthTest
      该枚举定义了节点中depthTest标志的可能状态。

    • Uses of Serializable in javafx.scene.chart

      Classes in javafx.scene.chart that implement Serializable
      Modifier and Type Class 描述
      static class  LineChart.SortingPolicy
      此枚举定义了一个 LineChart.axisSortingPolicyProperty()的策略。

    • Uses of Serializable in javafx.scene.control

      Classes in javafx.scene.control that implement Serializable
      Modifier and Type Class 描述
      static class  Alert.AlertType
      包含Alert类可用于预先填充各种属性的可用的预构建警报类型的枚举 。
      static class  ButtonBar.ButtonData
      枚举所有可用的按钮数据注释。
      static class  CheckBoxTreeItem.TreeModificationEvent<T>
      一个TreeModificationEvent类，与类似于TreeItem.TreeModificationEvent类的工作类似，因为该事件将引发 CheckBoxTreeItem层次结构，直到父节点为空。
      class  ContentDisplay
      将内容放置在标签内的位置。
      class  DialogEvent
      与对话框显示/隐藏操作相关的事件。
      static class  ListView.EditEvent<T>
      一个Event用于表示编辑相关事件的ListView中特别使用的子类。
      class  OverrunStyle
      当渲染文本的空间小于渲染整个字符串所需的空间时，定义标记的控件的行为。
      static class  ScrollPane.ScrollBarPolicy
      表示可滚动控件在决定是否显示滚动条时使用的策略的枚举。
      class  ScrollToEvent<T>
      事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。
      class  SelectionMode
      用于指定在MultipleSelectionModel中可以选择多少项的枚举 。
      class  SortEvent<C>
      事件涉及TableView和TreeTableView排序。
      static class  TableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TableColumn.SortType
      枚举，指定应用于特定列的排序类型。
      static class  TabPane.TabClosingPolicy
      这指定了TabPane如何处理从最终用户角度看待标签关闭。
      static class  TreeItem.TreeModificationEvent<T>
      一个包含所有形式的TreeItem修改的相关信息的Event 。
      class  TreeSortMode
      指定如何对树状UI控件中的树项进行排序。
      static class  TreeTableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TreeTableColumn.SortType
      枚举，指定应用于特定列的排序类型。
      static class  TreeTableView.EditEvent<S>
      一个Event用于表示编辑相关事件的TreeTableView中使用的子类。
      static class  TreeView.EditEvent<T>
      一个Event在TreeView中专门用于表示编辑相关事件的子类。

    • Uses of Serializable in javafx.scene.control.skin

      Classes in javafx.scene.control.skin that implement Serializable
      Modifier and Type Class 描述
      static class  TextInputControlSkin.Direction
      方向名称用于插入符号移动。
      static class  TextInputControlSkin.TextUnit
      照相机运动的单位名称。

    • Uses of Serializable in javafx.scene.effect

      Classes in javafx.scene.effect that implement Serializable
      Modifier and Type Class 描述
      class  BlendMode
      混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
      class  BlurType
      表示用于软化 Shadow效果的模糊算法的类型。

    • Uses of Serializable in javafx.scene.image

      Classes in javafx.scene.image that implement Serializable
      Modifier and Type Class 描述
      static class  PixelFormat.Type
      一个枚举，描述由PixelFormat管理的单个像素的阵列存储格式。

    • Uses of Serializable in javafx.scene.input

      Classes in javafx.scene.input that implement Serializable
      Modifier and Type Class 描述
      class  ClipboardContent
      数据容器Clipboard数据。
      class  ContextMenuEvent
      当用户请求上下文菜单时，会发生此事件。
      class  DragEvent
      拖动事件在拖放手势时替换鼠标事件。
      class  GestureEvent
      表示手势输入的事件。
      class  InputEvent
      指示用户输入的事件。
      class  InputMethodEvent
      一个表示底层输入法在Node中通知其文本更改的事件 。
      class  InputMethodHighlight
      包含输入法文本的枚举突出显示。
      class  InputMethodTextRun
      表示单个运行，其中字符在输入法文本中具有相同的高亮集。
      class  KeyCode
      KeyEvent对象的关键代码集。
      static class  KeyCombination.ModifierValue
      ModifierValue指定修饰键的状态。
      class  KeyEvent
      一个事件，表示一个击键发生在一个Node 。
      class  MouseButton
      按钮名称映射
      class  MouseDragEvent
      鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
      class  MouseEvent
      当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。
      class  RotateEvent
      旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
      class  ScrollEvent
      滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
      static class  ScrollEvent.HorizontalTextScrollUnits
      水平文本滚动单元。
      static class  ScrollEvent.VerticalTextScrollUnits
      垂直的基于文本的滚动单元。
      class  SwipeEvent
      滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
      class  TouchEvent
      触摸事件表示触摸屏操作。
      class  TouchPoint
      触摸点表示多点触摸动作的单个点，通常一个手指触摸屏幕。
      static class  TouchPoint.State
      表示触摸点的当前状态
      class  TransferMode
      描述了相对于拖放手势的数据传输模式。
      class  ZoomEvent
      缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。

    • Uses of Serializable in javafx.scene.layout

      Classes in javafx.scene.layout that implement Serializable
      Modifier and Type Class 描述
      class  BackgroundRepeat
      枚举在背景中重复图像的选项
      class  BorderRepeat
      枚举指示边框图像的重复规则。
      class  Priority
      用于确定给定节点的布局区域在其区域具有更多（或更少）空间可用并且多个节点竞争该空间时的增长（或收缩）优先级的枚举。

    • Uses of Serializable in javafx.scene.media

      Classes in javafx.scene.media that implement Serializable
      Modifier and Type Class 描述
      class  MediaErrorEvent
      Event表示处理介质时发生错误。
      class  MediaException
      甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。
      static class  MediaException.Type
      描述错误类别的枚举。
      class  MediaMarkerEvent
      代表媒体标记的ActionEvent 。
      static class  MediaPlayer.Status
      描述MediaPlayer的不同状态值的枚举 。

    • Uses of Serializable in javafx.scene.paint

      Classes in javafx.scene.paint that implement Serializable
      Modifier and Type Class 描述
      class  CycleMethod
      该枚举定义了以下方法梯度边界之外绘制时使用的一个： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。

    • Uses of Serializable in javafx.scene.shape

      Classes in javafx.scene.shape that implement Serializable
      Modifier and Type Class 描述
      class  ArcType
      ArcType指定Arc对象的关闭类型。
      class  CullFace
      面部剔除设置，用于 Shape3D.cullFace
      class  DrawMode
      定义与 Shape3D.drawMode使用时如何绘制多边形
      class  FillRule
      用于确定路径内部的填充规则。
      class  StrokeLineCap
      定义 Shape的端帽样式。
      class  StrokeLineJoin
      定义一个 Shape的线连接样式。
      class  StrokeType
      定义在Shape节点的边界周围画画的位置。

    • Uses of Serializable in javafx.scene.text

      Classes in javafx.scene.text that implement Serializable
      Modifier and Type Class 描述
      class  FontPosture
      指定字体是否为斜体
      class  FontSmoothingType
      FontSmoothingType枚举用于指定用于平滑屏幕文本字体边缘的首选机制。
      class  FontWeight
      指定在系统上搜索字体时可以使用的不同字体权重。
      class  TextAlignment
      TextAlignment枚举表示水平文本对齐。
      class  TextBoundsType
      指定由 Text节点报告的边界的行为。

    • Uses of Serializable in javafx.scene.transform

      Classes in javafx.scene.transform that implement Serializable
      Modifier and Type Class 描述
      class  MatrixType
      指定转换矩阵的类型。
      class  NonInvertibleTransformException
      NonInvertibleTransformException类表示如果执行的操作需要处于非可逆状态的 Transform对象的倒数时抛出异常。
      class  TransformChangedEvent
      当它的任何属性发生变化时，这个事件被触发。

    • Uses of Serializable in javafx.scene.web

      Classes in javafx.scene.web that implement Serializable
      Modifier and Type Class 描述
      static class  HTMLEditorSkin.Command
      表示可以传递到HTMLEditor Web引擎的命令。
      class  WebErrorEvent
      一个事件指示WebEngine错误。
      class  WebEvent<T>
      WebEvent实例被传递到EventHandler ，注册小号WebEngine由JavaScript的网页上运行。

    • Uses of Serializable in javafx.stage

      Classes in javafx.stage that implement Serializable
      Modifier and Type Class 描述
      class  Modality
      该枚举定义了一个 Stage的可能的模式类型。
      static class  PopupWindow.AnchorLocation
      锚定点选择的锚位置常数。
      class  StageStyle
      此枚举定义了 Stage的可能样式。
      class  WindowEvent
      与窗口显示/隐藏操作相关的事件。

    • Uses of Serializable in javafx.util

      Classes in javafx.util that implement Serializable
      Modifier and Type Class 描述
      class  Duration
      定义持续时间的类。
      class  FXPermission
      此类用于JavaFX权限。
      class  Pair<K,V>
      一个方便的类来表示名称 - 值对。

    • Uses of Serializable in javax.activation

      Classes in javax.activation that implement Serializable
      Modifier and Type Class 描述
      class  ActivationDataFlavor
      ActivationDataFlavor类是 java.awt.datatransfer.DataFlavor的特殊子类。
      class  MimeType
      多功能Internet邮件扩展（MIME）类型，如RFC 2045和2046中所定义。
      class  MimeTypeParseException
      封装MimeType解析相关异常的类。
      class  UnsupportedDataTypeException
      表示请求的操作不支持请求的数据类型。

    • Uses of Serializable in javax.activity

      Classes in javax.activity that implement Serializable
      Modifier and Type Class 描述
      class  ActivityCompletedException
      可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。
      class  ActivityRequiredException
      如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。
      class  InvalidActivityException
      可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。

    • Uses of Serializable in javax.annotation

      Classes in javax.annotation that implement Serializable
      Modifier and Type Class 描述
      static class  Resource.AuthenticationType
      资源的两种可能的认证类型。

    • Uses of Serializable in javax.annotation.processing

      Classes in javax.annotation.processing that implement Serializable
      Modifier and Type Class 描述
      class  FilerException
      表示Filer检测到尝试打开将违反Filer提供的担保的Filer 。

    • Uses of Serializable in javax.crypto

      Subinterfaces of Serializable in javax.crypto
      Modifier and Type 接口 描述
      interface  SecretKey
      一个秘密（对称）键。
      Classes in javax.crypto that implement Serializable
      Modifier and Type Class 描述
      class  AEADBadTagException
      当以AEAD模式运行的Cipher （例如GCM / CCM）无法验证提供的认证标签时，会抛出此异常。
      class  BadPaddingException
      当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
      class  ExemptionMechanismException
      这是通用的ExemptionMechanism异常。
      class  IllegalBlockSizeException
      当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。
      class  NoSuchPaddingException
      当请求特定的填充机制但在环境中不可用时抛出此异常。
      class  SealedObject
      该类使程序员能够使用加密算法创建对象并保护其机密性。
      class  ShortBufferException
      当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。
      Constructors in javax.crypto with parameters of type Serializable
      Constructor 描述
      SealedObject​(Serializable object, Cipher c)
      从任何可序列化对象构造一个SealedObject。

    • Uses of Serializable in javax.crypto.interfaces

      Subinterfaces of Serializable in javax.crypto.interfaces
      Modifier and Type 接口 描述
      interface  DHPrivateKey
      与Diffie-Hellman私钥的接口。
      interface  DHPublicKey
      与Diffie-Hellman公钥的接口。
      interface  PBEKey
      与PBE密钥的接口。

    • Uses of Serializable in javax.crypto.spec

      Classes in javax.crypto.spec that implement Serializable
      Modifier and Type Class 描述
      class  SecretKeySpec
      该类以独立于提供商的方式指定密钥。

    • Uses of Serializable in javax.imageio

      Classes in javax.imageio that implement Serializable
      Modifier and Type Class 描述
      class  IIOException
      用于发信号读取和写入操作失败的异常类。

    • Uses of Serializable in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement Serializable
      Modifier and Type Class 描述
      class  IIOInvalidTreeException
      一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。

    • Uses of Serializable in javax.jnlp

      Classes in javax.jnlp that implement Serializable
      Modifier and Type Class 描述
      class  UnavailableServiceException
      当 UnavailableServiceException不存在或不可用的服务时， UnavailableServiceException被抛出 ServiceManager 。

    • Uses of Serializable in javax.jws

      Classes in javax.jws that implement Serializable
      Modifier and Type | Class | 描述
      static class  | WebParam.Mode

    • Uses of Serializable in javax.jws.soap

      Classes in javax.jws.soap that implement Serializable
      Modifier and Type | Class | 描述
      static class  | SOAPBinding.ParameterStyle
      static class  | SOAPBinding.Style
      static class  | SOAPBinding.Use

    • Uses of Serializable in javax.lang.model

      Classes in javax.lang.model that implement Serializable
      Modifier and Type Class 描述
      class  SourceVersion
      源代码版本的Java编程语言。
      class  UnknownEntityException
      例外的超类，表示遇到一个未知类型的实体。

    • Uses of Serializable in javax.lang.model.element

      Classes in javax.lang.model.element that implement Serializable
      Modifier and Type Class 描述
      class  ElementKind
      一个元素的 kind 。
      class  Modifier
      表示程序元素（如类，方法或字段）上的修饰符。
      static class  ModuleElement.DirectiveKind
      一个指令的 kind 。
      class  NestingKind
      一种类型元素的 嵌套类型。
      class  UnknownAnnotationValueException
      表示遇到未知类型的注释值。
      class  UnknownDirectiveException
      表示遇到未知类型的模块指令。
      class  UnknownElementException
      表示遇到未知类型的元素。

    • Uses of Serializable in javax.lang.model.type

      Classes in javax.lang.model.type that implement Serializable
      Modifier and Type Class 描述
      class  MirroredTypeException
      当应用程序尝试访问对应于TypeMirror的Class对象时抛出 。
      class  MirroredTypesException
      当应用程序试图访问的序列抛出Class个每一个对应于对象TypeMirror 。
      class  TypeKind
      一种类型的镜子。
      class  UnknownTypeException
      表示遇到未知类型的类型。

    • Uses of Serializable in javax.lang.model.util

      Classes in javax.lang.model.util that implement Serializable
      Modifier and Type Class 描述
      static class  Elements.Origin
      元素或其他语言模型项目的 起源 。

    • Uses of Serializable in javax.management

      Subinterfaces of Serializable in javax.management
      Modifier and Type 接口 描述
      interface  Descriptor
      JMX元素的附加元数据。
      interface  NotificationFilter
      由任何作为通知过滤器的类来实现。
      interface  QueryExp
      表示与数据库查询“where子句”类似的关系约束。
      interface  ValueExp
      表示可以作为参数传递给关系表达式的值。
      Classes in javax.management that implement Serializable
      Modifier and Type Class 描述
      class  Attribute
      通过将其名称与其值相关联来表示MBean属性。
      class  AttributeChangeNotification
      提供MBean发送的属性更改通知的定义。
      class  AttributeChangeNotificationFilter
      该类实现NotificationFilter接口为attribute change notification 。
      class  AttributeList
      表示MBean属性值的列表。
      class  AttributeNotFoundException
      指定的属性不存在或无法检索。
      class  AttributeValueExp
      表示用作关系约束的参数的属性。
      class  BadAttributeValueExpException
      当无效的MBean属性传递给查询构造方法时抛出。
      class  BadBinaryOpValueExpException
      当无效表达式传递给构造查询的方法时抛出。
      class  BadStringOperationException
      当无效的字符串操作传递给构造查询的方法时抛出。
      class  ImmutableDescriptor
      一个不可变的描述符。
      class  InstanceAlreadyExistsException
      MBean已经在存储库中注册。
      class  InstanceNotFoundException
      存储库中不存在指定的MBean。
      class  IntrospectionException
      在MBean的内省期间发生了一个例外。
      class  InvalidApplicationException
      当尝试应用以下任一操作时抛出：将MBean的子查询表达式或对错误类的MBean的限定属性表达式。
      class  InvalidAttributeValueException
      指定的值对属性无效。
      class  JMException
      JMX实现抛出异常。
      class  JMRuntimeException
      JMX实现发出的运行时异常。
      class  ListenerNotFoundException
      存储库中不存在指定的MBean侦听器。
      class  MalformedObjectNameException
      字符串的格式不对应于有效的ObjectName。
      class  MBeanAttributeInfo
      描述为管理而公开的MBean属性。
      class  MBeanConstructorInfo
      描述由MBean公开的构造函数。
      class  MBeanException
      表示代理中MBean方法抛出的“用户定义”异常。
      class  MBeanFeatureInfo
      提供MBean描述符对象的一般信息。
      class  MBeanInfo
      描述MBean暴露的管理界面; 即可用于管理操作的一组属性和操作。
      class  MBeanNotificationInfo
      MBeanNotificationInfo类用于描述针对给定Java类通知的MBean发出的不同通知实例的特征。
      class  MBeanOperationInfo
      描述MBean公开的管理操作。
      class  MBeanParameterInfo
      描述MBean暴露的操作的参数。
      class  MBeanPermission
      控制访问MBeanServer操作的权限。
      class  MBeanRegistrationException
      包含由预寄存器（），preDeregister（）方法抛出的异常的 MBeanRegistration接口。
      class  MBeanServerNotification
      表示MBean服务器通过MBeanServerDelegate MBean发出的通知。
      class  MBeanServerPermission
      A执行与MBeanServers有关的操作的权限。
      class  MBeanTrustPermission
      此权限在签名者或代码库中表示“信任”。
      class  NotCompliantMBeanException
      尝试在不符合JMX的MBean的MBean服务器中注册对象时发生的异常。
      class  Notification
      Notification类表示由MBean发出的通知。
      class  NotificationFilterSupport
      提供NotificationFilter接口的实现。
      class  ObjectInstance
      用于表示MBean的对象名称及其类名。
      class  ObjectName
      表示MBean的对象名称，或可匹配多个MBean名称的模式。
      class  OperationsException
      表示对MBean执行操作时MBean服务器中抛出的异常。
      class  QueryEval
      允许在特定MBean服务器的上下文中执行查询。
      class  ReflectionException
      表示在使用java.lang.reflect类调用MBean方法时，MBean服务器中抛出的异常。
      class  RuntimeErrorException
      当 java.lang.Error发生 java.lang.Error时，应该被捕获并重新抛出为 RuntimeErrorException 。
      class  RuntimeMBeanException
      表示代理中MBean方法抛出的运行时异常。
      class  RuntimeOperationsException
      表示在对MBean执行操作时在代理中抛出的运行时异常。
      class  ServiceNotFoundException
      表示不支持请求的服务时引发的异常。
      class  StringValueExp
      表示作为关系约束的参数的字符串。

    • Uses of Serializable in javax.management.loading

      Classes in javax.management.loading that implement Serializable
      Modifier and Type Class 描述
      class  MLet
      允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
      class  PrivateMLet
      没有添加到ClassLoaderRepository的MLet。

    • Uses of Serializable in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement Serializable
      Modifier and Type Class 描述
      class  DescriptorSupport
      此类表示一个ModelMBean元素的元数据集。
      class  InvalidTargetObjectTypeException
      指定无效目标对象类型时抛出异常。
      class  ModelMBeanAttributeInfo
      ModelMBeanAttributeInfo对象描述了ModelMBean的属性。
      class  ModelMBeanConstructorInfo
      ModelMBeanConstructorInfo对象描述了ModelMBean的构造函数。
      class  ModelMBeanInfoSupport
      此类表示ModelMBeans的元数据。
      class  ModelMBeanNotificationInfo
      ModelMBeanNotificationInfo对象描述了由ModelMBean发出的通知。
      class  ModelMBeanOperationInfo
      ModelMBeanOperationInfo对象描述了ModelMBean的管理操作。
      class  XMLParseException
      当将XML格式化的字符串解析为ModelMBean对象或从ModelMBean对象创建XML格式的字符串时，将抛出此异常。

    • Uses of Serializable in javax.management.monitor

      Classes in javax.management.monitor that implement Serializable
      Modifier and Type Class 描述
      class  MonitorNotification
      提供监视器MBean发送的通知的定义。
      class  MonitorSettingException
      监视器设置在监视器运行时无效时由监视器抛出异常。

    • Uses of Serializable in javax.management.openmbean

      Classes in javax.management.openmbean that implement Serializable
      Modifier and Type Class 描述
      class  ArrayType<T>
      所述 ArrayType类是 开放类型类，其实例描述了作为 开放数据值的n维阵列所有 打开的 数据值。
      class  CompositeDataSupport
      CompositeDataSupport类是实现 CompositeData接口的 开放数据类。
      class  CompositeType
      CompositeType类是其实例描述CompositeData值的类型的开放式类。
      class  InvalidKeyException
      抛出此运行时异常以指示预期为 复合数据的项名称或 表格数据的行索引的方法参数无效。
      class  InvalidOpenTypeException
      抛出此运行时异常以指示 打开的类型的 打开数据值不是预期的。
      class  KeyAlreadyExistsException
      抛出此运行时异常以指示要添加到 表格数据实例的行的索引已被用于引用此 表格数据实例中的另一行。
      class  OpenDataException
      当 打开类型 ， 打开数据或 打开的MBean元数据信息实例无法构造时，抛出此检查的异常，因为一个或多个有效性约束不被满足。
      class  OpenMBeanAttributeInfoSupport
      描述一个打开的MBean的属性。
      class  OpenMBeanConstructorInfoSupport
      描述一个开放MBean的构造函数。
      class  OpenMBeanInfoSupport
      OpenMBeanInfoSupport类描述了一个开放的MBean的管理信息：它是一个MBeanInfo的子类，它实现了OpenMBeanInfo接口。
      class  OpenMBeanOperationInfoSupport
      描述一个Open MBean的操作。
      class  OpenMBeanParameterInfoSupport
      描述在开放MBean的一个或多个操作或构造函数中使用的参数。
      class  OpenType<T>
      OpenType类是描述开放数据值的实际 开放类型的所有类的父抽象类。
      class  SimpleType<T>
      SimpleType类是开放式类，其实例描述了既不是数组，也不是CompositeData值的所有打开数据值，也不包括TabularData值。
      class  TabularDataSupport
      TabularDataSupport类是 开放数据类，它实现 TabularData和 Map接口，内部是基于哈希映射数据结构的。
      class  TabularType
      TabularType类是开放类，其实例描述了TabularData的类型。

    • Uses of Serializable in javax.management.relation

      Subinterfaces of Serializable in javax.management.relation
      Modifier and Type 接口 描述
      interface  RelationType
      RelationType接口必须由预期表示关系类型的任何类来实现。
      Classes in javax.management.relation that implement Serializable
      Modifier and Type Class 描述
      class  InvalidRelationIdException
      当已经使用关系id提供给关系时，引发异常。
      class  InvalidRelationServiceException
      当提供无效的关系服务时，引发异常。
      class  InvalidRelationTypeException
      关系类型无效
      class  InvalidRoleInfoException
      当在角色信息中，其最小度大于其最大度时，会引发此异常。
      class  InvalidRoleValueException
      角色值无效。
      class  MBeanServerNotificationFilter
      过滤MBeanServerNotification 。
      class  RelationException
      这个类是在关系管理期间可以提出的任何异常的超类。
      class  RelationNotFoundException
      当关系服务中的给定关系ID没有关系时，会引发此异常。
      class  RelationNotification
      关系服务变更通知。
      class  RelationServiceNotRegisteredException
      当对关系服务进行访问并且没有注册时，会引发此异常。
      class  RelationTypeNotFoundException
      当在关系服务中没有给定名称的关系类型时，引发异常。
      class  RelationTypeSupport
      RelationTypeSupport对象实现RelationType接口。
      class  Role
      表示角色：包括角色名称和引用的MBean（通过其ObjectNames）。
      class  RoleInfo
      RoleInfo对象总结了关系类型中的角色。
      class  RoleInfoNotFoundException
      当给定的关系类型中没有给定名称的角色信息时，会引发此异常。
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleNotFoundException
      当关系中的角色不存在或不可读或不可设置时，引发此异常。
      class  RoleResult
      表示多次访问关系的几个角色（用于阅读或写入）的结果。
      class  RoleUnresolved
      代表一个未解决的角色：由于问题而无法从关系中检索到的角色。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。

    • Uses of Serializable in javax.management.remote

      Classes in javax.management.remote that implement Serializable
      Modifier and Type Class 描述
      class  JMXConnectionNotification
      客户端连接打开或关闭或通知丢失时发出的通知。
      class  JMXPrincipal
      JMX Remote API的远程客户端的身份。
      class  JMXProviderException
      当提供者存在所需的协议但由于某种原因不能使用时，由JMXConnectorFactory和JMXConnectorServerFactory抛出异常。
      class  JMXServerErrorException
      在处理远程MBean服务器中的调用时抛出一个Error时抛出的异常作为远程MBeanServer方法调用的结果。
      class  JMXServiceURL
      JMX API连接器服务器的地址。
      class  NotificationResult
      对缓冲通知的查询结果。
      class  SubjectDelegationPermission
      认证身份所需的权限代表授权身份执行操作。
      class  TargetedNotification
      A（通知，听众ID）对。

    • Uses of Serializable in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement Serializable
      Modifier and Type | Class | 描述
      class  | RMIConnectionImpl_Stub
      class  RMIConnector
      与远程RMI连接器的连接。
      class  | RMIServerImpl_Stub

    • Uses of Serializable in javax.management.timer

      Classes in javax.management.timer that implement Serializable
      Modifier and Type Class 描述
      class  TimerNotification
      此类提供了定时器MBeans发送的通知的定义。

    • Uses of Serializable in javax.naming

      Subinterfaces of Serializable in javax.naming
      Modifier and Type 接口 描述
      interface  Name
      Name接口表示通用名称 - 组件的有序序列。
      Classes in javax.naming that implement Serializable
      Modifier and Type Class 描述
      class  AuthenticationException
      访问命名或目录服务时发生身份验证错误时抛出此异常。
      class  AuthenticationNotSupportedException
      当不支持所请求的身份验证的特定风格时，会抛出此异常。
      class  BinaryRefAddr
      该类表示通信端点的地址的二进制形式。
      class  Binding
      此类表示在上下文中找到的名称对对象绑定。
      class  CannotProceedException
      抛出此异常以指示操作达到操作无法继续进行的名称中的一个点。
      class  CommunicationException
      当客户端无法与目录或命名服务通信时，抛出此异常。
      class  CompositeName
      此类表示组合名称 - 跨多个命名空间的组件名称序列。
      class  CompoundName
      该类表示复合名称 - 来自分层名称空间的名称。
      class  ConfigurationException
      出现配置问题时抛出此异常。
      class  ContextNotEmptyException
      尝试销毁不为空的上下文时抛出此异常。
      class  InsufficientResourcesException
      当资源不可用来完成请求的操作时，抛出此异常。
      class  InterruptedNamingException
      正在调用的命名操作已被中断时抛出此异常。
      class  InvalidNameException
      此异常表示指定的名称不符合命名系统的命名语法。
      class  LimitExceededException
      当方法由于用户或系统指定的限制而异常终止时，会抛出此异常。
      class  LinkException
      此异常用于描述解决链接时遇到的问题。
      class  LinkLoopException
      当尝试解析链接时检测到一个循环，或者达到链接计数的实现特定限制时，会抛出此异常。
      class  LinkRef
      此类表示一个引用，其内容是名称，称为链接名称，该名称绑定到上下文中的原子名称。
      class  MalformedLinkException
      当解决或构建链接时遇到格式错误的链接时抛出此异常。
      class  NameAlreadyBoundException
      通过方法抛出此异常，表示无法添加绑定，因为该名称已被绑定到另一个对象。
      class  NameClassPair
      此类表示在上下文中找到的绑定的对象名称和类名称对。
      class  NameNotFoundException
      当名称的组件由于未绑定而无法解析时抛出此异常。
      class  NamingException
      这是Context和DirContext接口中的操作抛出的所有异常的超类。
      class  NamingSecurityException
      这是Context和DirContext接口中的操作抛出的与安全相关异常的超类。
      class  NoInitialContextException
      当不能创建初始上下文实现时，抛出此异常。
      class  NoPermissionException
      尝试执行客户端没有权限的操作时抛出此异常。
      class  NotContextException
      当命名操作进行到需要上下文以继续操作的点时抛出此异常，但解析的对象不是上下文。
      class  OperationNotSupportedException
      当上下文实现不支持正在调用的操作时，抛出此异常。
      class  PartialResultException
      抛出此异常以指示到目前为止返回或返回的结果是部分的，并且该操作无法完成。
      class  RefAddr
      该类表示通信端点的地址。
      class  Reference
      此类表示对在命名/目录系统外部找到的对象的引用。
      class  ReferralException
      此抽象类用于表示引用异常，该引用异常是响应于LDAP v3服务器返回的 引用而生成的。
      class  ServiceUnavailableException
      尝试与目录或命名服务通信并且该服务不可用时，会抛出此异常。
      class  SizeLimitExceededException
      当方法产生超过大小相关限制的结果时，抛出此异常。
      class  StringRefAddr
      此类表示通信端点的地址的字符串形式。
      class  TimeLimitExceededException
      当方法不在指定的时间限制内终止时，抛出此异常。

    • Uses of Serializable in javax.naming.directory

      Subinterfaces of Serializable in javax.naming.directory
      Modifier and Type 接口 描述
      interface  Attribute
      此接口表示与命名对象关联的属性。
      interface  Attributes
      此接口表示属性的集合。
      Classes in javax.naming.directory that implement Serializable
      Modifier and Type Class 描述
      class  AttributeInUseException
      当操作尝试添加已经存在的属性时，抛出此异常。
      class  AttributeModificationException
      当尝试添加，删除或修改与属性（模式）定义或属性状态相冲突的属性，其标识符或其值时，将抛出此异常。
      class  BasicAttribute
      这个类提供了 Attribute接口的基本实现。
      class  BasicAttributes
      该类提供了Attributes界面的基本实现。
      class  InvalidAttributeIdentifierException
      当尝试添加以创建具有无效属性标识符的属性时，会抛出此异常。
      class  InvalidAttributesException
      尝试添加或修改不完整或不正确指定的属性集时，会抛出此异常。
      class  InvalidAttributeValueException
      当尝试向属性添加与属性的模式定义冲突的值时，将抛出此类。
      class  InvalidSearchControlsException
      当搜索操作的SearchControls的规范无效时，抛出此异常。
      class  InvalidSearchFilterException
      当搜索过滤器的规范无效时抛出此异常。
      class  ModificationItem
      此类表示修改项。
      class  NoSuchAttributeException
      尝试访问不存在的属性时抛出此异常。
      class  SchemaViolationException
      当某种方法违反模式时，抛出此异常。
      class  SearchControls
      该类封装了确定搜索范围和搜索结果返回的因素。
      class  SearchResult
      该类表示由DirContext.search（）方法返回的NamingEnumeration中的一个项目。

    • Uses of Serializable in javax.naming.event

      Classes in javax.naming.event that implement Serializable
      Modifier and Type Class 描述
      class  NamingEvent
      此类表示由命名/目录服务触发的事件。
      class  NamingExceptionEvent
      此类代表当用于收集通知听众的信息的过程/过程 NamingEvent抛出一个 NamingException 。

    • Uses of Serializable in javax.naming.ldap

      Subinterfaces of Serializable in javax.naming.ldap
      Modifier and Type 接口 描述
      interface  Control
      此接口表示 RFC 2251中定义的LDAPv3控件。
      interface  ExtendedRequest
      此接口表示 RFC 2251中定义的LDAPv3扩展操作请求。
      interface  ExtendedResponse
      此接口表示 RFC 2251中定义的LDAP扩展操作响应。
      interface  UnsolicitedNotification
      此接口表示 RFC 2251中定义的非请求通知。
      Classes in javax.naming.ldap that implement Serializable
      Modifier and Type Class 描述
      class  BasicControl
      该类提供了 Control接口的基本实现。
      class  LdapName
      此类表示由 RFC 2253指定的专有名称。
      class  LdapReferralException
      此抽象类用于表示LDAP引用异常。
      class  ManageReferralControl
      请求将引用和其他特殊LDAP对象作为普通LDAP对象进行操作。
      class  PagedResultsControl
      请求LDAP服务器以指定大小的批量返回搜索操作的结果。
      class  PagedResultsResponseControl
      表示一批搜索结果的结束。
      class  Rdn
      该类表示相对可分辨名称，或RDN，它是由 RFC 2253指定的专有名称的组成部分。
      class  SortControl
      请求在返回之前由LDAP服务器对搜索操作的结果进行排序。
      class  SortResponseControl
      指示所请求的搜索结果是否成功。
      class  StartTlsRequest
      该类实现了针对StartTLS的LDAPv3扩展请求，如 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security中定义的 。StartTLS的对象标识符为1.3.6.1.4.1.1466.20037，未定义扩展请求值。
      class  StartTlsResponse
      此类实现了针对StartTLS的LDAPv3扩展响应，如 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security中定义的 。StartTLS的对象标识符为1.3.6.1.4.1.1466.20037，未定义扩展响应值。
      class  UnsolicitedNotificationEvent
      此类表示响应LDAP服务器发送的未经请求的通知触发的事件。

    • Uses of Serializable in javax.naming.spi

      Classes in javax.naming.spi that implement Serializable
      Modifier and Type Class 描述
      class  ResolveResult
      该类代表解析名称的结果。

    • Uses of Serializable in javax.net.ssl

      Classes in javax.net.ssl that implement Serializable
      Modifier and Type Class 描述
      class  HandshakeCompletedEvent
      此事件表示在给定SSL连接上完成SSL握手。
      static class  SSLEngineResult.HandshakeStatus
      一个 SSLEngineResult枚举描述了这个 SSLEngine的当前握手状态。
      static class  SSLEngineResult.Status
      一个 SSLEngineResult枚举描述了 SSLEngine操作的总体结果。
      class  SSLException
      表示由SSL子系统检测到的某种错误。
      class  SSLHandshakeException
      表示客户端和服务器无法协商所需的安全级别。
      class  SSLKeyException
      报告错误的SSL密钥。
      class  SSLPeerUnverifiedException
      表示对等体的身份尚未验证。
      class  SSLPermission
      此类用于各种网络权限。
      class  SSLProtocolException
      报告SSL协议操作中的错误。
      class  SSLSessionBindingEvent
      此事件传播到SSLSessionBindingListener。

    • Uses of Serializable in javax.print

      Classes in javax.print that implement Serializable
      Modifier and Type Class 描述
      class  DocFlavor
      DocFlavor类封装了一个对象，该对象指定了将打印数据提供给的格式DocPrintJob 。
      static class  DocFlavor.BYTE_ARRAY
      DocFlavor.BYTE_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字节数组（ byte[] ）作为打印数据表示类的doc风格。
      static class  DocFlavor.CHAR_ARRAY
      DocFlavor.CHAR_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字符数组（ char[] ）作为打印数据表示类的doc风格。
      static class  DocFlavor.INPUT_STREAM
      DocFlavor.INPUT_STREAM类提供了预定义的静态常量DocFlavor对象，例如使用字节流（ java.io.InputStream ）作为打印数据表示类的doc 口音 。
      static class  DocFlavor.READER
      DocFlavor.READER类提供预定义的静态常量DocFlavor对象，例如使用字符流（ java.io.Reader ）作为打印数据表示类的doc风格。
      static class  DocFlavor.SERVICE_FORMATTED
      DocFlavor.SERVICE_FORMATTED类提供了预定义的静态常量DocFlavor对象，例如用于服务格式化打印数据的doc风格。
      static class  DocFlavor.STRING
      DocFlavor.STRING类提供了预定义的静态常量DocFlavor对象，例如使用字符串（ java.lang.String ）作为打印数据表示类的doc风格。
      static class  DocFlavor.URL
      DocFlavor.URL类提供了预定义的静态常量DocFlavor对象。
      class  PrintException
      PrintException类封装了在使用Print Service实例时发生的与打印相关的错误条件。

    • Uses of Serializable in javax.print.attribute

      Subinterfaces of Serializable in javax.print.attribute
      Modifier and Type 接口 描述
      interface  Attribute
      接口属性是由任何和每个打印属性类实现的基本接口，以指示该类表示打印属性。
      interface  DocAttribute
      接口DocAttribute是打印属性类实现的标记接口，用于指示属性表示文档的设置。
      interface  PrintJobAttribute
      PrintJobAttribute是打印属性类实现的标记界面，用于指示属性描述打印作业的状态或打印作业的其他一些特性。
      interface  PrintRequestAttribute
      接口PrintRequestAttribute是打印属性类实现的标记接口，用于指示属性表示打印作业的请求设置。
      interface  PrintServiceAttribute
      接口PrintServiceAttribute是打印属性类实现的标记接口，用于指示属性描述打印服务的状态或打印服务的其他特性。
      interface  SupportedValuesAttribute
      Interface SupportedValuesAttribute是打印属性类实现的标记接口，用于指示属性描述了另一个属性的支持值。
      Classes in javax.print.attribute that implement Serializable
      Modifier and Type Class 描述
      class  DateTimeSyntax
      类DateTimeSyntax是一个抽象基类，提供值为日期和时间的所有属性的常见实现。
      class  EnumSyntax
      类EnumSyntax是提供所有“类型安全枚举”对象的通用实现的抽象基类。
      class  HashAttributeSet
      HashAttributeSet类提供了具有哈希映射特征的 AttributeSet实现。
      class  HashDocAttributeSet
      HashDocAttributeSet类提供了一个从HashAttributeSet类继承其实现的属性集，并强制接口DocAttributeSet的语义限制。
      class  HashPrintJobAttributeSet
      HashPrintJobAttributeSet类提供了一个从HashAttributeSet类继承其实现的属性集，并强制接口PrintJobAttributeSet的语义限制。
      class  HashPrintRequestAttributeSet
      HashPrintRequestAttributeSet类从HashAttributeSet类继承其实现，并强制接口PrintRequestAttributeSet的语义限制。
      class  HashPrintServiceAttributeSet
      HashPrintServiceAttributeSet类提供了一个从HashAttributeSet类继承其实现的属性集，并强制接口PrintServiceAttributeSet的语义限制。
      class  IntegerSyntax
      Class IntegerSyntax是一个抽象基类，提供了具有整数值的所有属性的通用实现。
      class  ResolutionSyntax
      Class ResolutionSyntax是一个抽象基类，提供表示打印机分辨率的所有属性的常见实现。
      class  SetOfIntegerSyntax
      类SetOfIntegerSyntax是一个抽象基类，提供了所有属性的常见实现，其值是一组非负整数。
      class  Size2DSyntax
      Class Size2DSyntax是一个抽象基类，提供表示二维大小的所有属性的常见实现。
      class  TextSyntax
      Class TextSyntax是一个抽象基类，提供了值为字符串的所有属性的常见实现。
      class  UnmodifiableSetException
      抛出以表示所请求的操作无法执行，因为该集合是不可修改的。
      class  URISyntax
      类URISyntax是一个抽象基类，提供其值为统一资源标识符（URI）的所有属性的常见实现。

    • Uses of Serializable in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement Serializable
      Modifier and Type Class 描述
      class  Chromaticity
      Class Chromaticity是一个打印属性类，一个枚举，用于指定单色或彩色打印。
      class  ColorSupported
      ColorSupported类是一个打印属性类，一个枚举，用于标识设备是否能够进行任何类型的彩色打印，包括突出显示颜色以及全过程颜色。
      class  Compression
      类压缩是打印属性类，枚举，用于指定打印数据的压缩方式。
      class  Copies
      Class Copies是一个整数值的打印属性类，它指定要打印的份数。
      class  CopiesSupported
      CopiesSupported类是一个打印属性类，一组整数，它为Copies属性提供支持的值。
      class  DateTimeAtCompleted
      类DateTimeAtCompleted是打印属性类，日期时间属性，指示打印作业完成（或被取消或中止）的日期和时间。
      class  DateTimeAtCreation
      类DateTimeAtCreation是一个打印属性类，一个日期时间属性，表示创建打印作业的日期和时间。
      class  DateTimeAtProcessing
      类DateTimeAtProcessing是打印属性类，日期时间属性，表示打印作业首次开始处理的日期和时间。
      class  Destination
      类目标是打印属性类（URI），用于指示假脱机打印机格式化数据的备用目标。
      class  DialogTypeSelection
      DialogTypeSelection类是一个打印属性类，一个枚举，指示用于指定打印选项的用户对话框类型。
      class  DocumentName
      DocumentName类是一个打印属性类，一个指定文档名称的文本属性。
      class  Fidelity
      类Fidelity是打印属性类，枚举，指示是否需要对客户端提供的打印请求属性的总保真度。
      class  Finishings
      类完成是打印属性类，枚举，用于标识打印机是否对作业中每个打印文档的每个副本执行某种类型的装订操作。
      class  JobHoldUntil
      JobHoldUntil类是一个打印属性类，一个日期时间属性，用于指定作业必须成为打印候选者的确切日期和时间。
      class  JobImpressions
      JobImpress类是一个整数值打印属性类，它指定要提交的文档的展示次数的总大小。
      class  JobImpressionsCompleted
      JobImpressionsCompleted类是一个整数值的打印属性类，用于指定目前为该作业完成的展示次数。
      class  JobImpressionsSupported
      JobImpressions类支持是一个打印属性类，一组整数，它为JobImpressions属性提供支持的值。
      class  JobKOctets
      JobKOctets类是一个整数值打印属性类，用于指定以K个八位字节为单位的文档的总大小，即以作业中请求处理的1024个八位字节为单位。
      class  JobKOctetsProcessed
      JobKOctetsProcessed类是一个整数值打印属性类，它指定了目前以K个八位字节处理的打印数据八位字节的总数，即1024个八位字节的单位。
      class  JobKOctetsSupported
      JobKOctetsSupported类是一个打印属性类，一组整数，它为JobKOctets属性提供支持的值。
      class  JobMediaSheets
      JobMediaSheets类是一个整数值打印属性类，它指定要为此作业生成的介质页的总数。
      class  JobMediaSheetsCompleted
      JobMediaSheetsCompleted类是一个整数值的打印属性类，它指定了到目前为止整个作业已经完成标记和堆叠的介质页数，无论这些工作表是在一边还是两者上进行处理。
      class  JobMediaSheetsSupported
      类JobMediaSheetsSupported是一个打印属性类，一组整数，为JobMediaSheets属性提供支持的值。
      class  JobMessageFromOperator
      JobMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示对作业执行修改或其他管理操作的原因。
      class  JobName
      JobName类是一个打印属性类，一个指定打印作业名称的文本属性。
      class  JobOriginatingUserName
      JobOriginatingUserName类是一个打印属性类，一个文本属性，其中包含提交打印作业的最终用户的名称。
      class  JobPriority
      JobPriority类是一个整数值打印属性类，用于指定打印作业的优先级。
      class  JobPrioritySupported
      JobPrioritySupported类是一个整数值打印属性类，用于指定打印服务实例是否支持JobPriority属性以及支持的不同作业优先级的数量。
      class  JobSheets
      JobSheets类是打印属性类（枚举），用于确定必须使用作业打印哪些作业开始和结束工作表（如果有）。
      class  JobState
      JobState是一个打印属性类，一个枚举，用于标识打印作业的当前状态。
      class  JobStateReason
      JobStateReason类是打印属性类，枚举，提供有关作业当前状态的其他信息，即增加作业JobState属性值的信息。
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
      class  Media
      Class Media是一个打印属性类，用于指定要打印的介质。
      class  MediaName
      MediaName类是Media的子类，它是打印属性类（枚举），用于将打印作业的媒体指定为名称。
      class  MediaPrintableArea
      MediaPrintableArea类是用于区分可打印区域和不可打印区域的打印属性。
      class  MediaSize
      MediaSize类是一种二维尺寸值的打印属性类，它以纵向方向指示介质的尺寸，X尺寸沿着底边缘运行，Y尺寸沿着左边缘运行。
      class  MediaSizeName
      MediaSizeName类是Media的子类。
      class  MediaTray
      MediaTray类是Media的一个子类。
      class  MultipleDocumentHandling
      MultipleDocumentHandling类是一个打印属性类，一个枚举，用于控制整理操作，以及将一个或多个打印流页面放置到展示位置和介质页面上。
      class  NumberOfDocuments
      类NumberOfDocuments是一个整数值打印属性，表示打印机已接受此作业的单个文档的数量，无论文档的打印数据是否到达打印机。
      class  NumberOfInterveningJobs
      Class NumberOfInterveningJobs是一个整数值打印属性，它以预期完成时间（即当前调度顺序）的相对时间顺序指示该作业前面的作业数。
      class  NumberUp
      类NumberUp是一个整数值打印属性类，它指定要在所选介质的实例的单侧施加的打印流页数。
      class  NumberUpSupported
      ClassUpSupported是一个打印属性类，一组整数，它给出了NumberUp属性的支持值。
      class  OrientationRequested
      类OrientationRequested是打印属性类，枚举，指示打印的打印流页面的所需方向; 它不描述客户端提供的打印流页面的方向。
      class  OutputDeviceAssigned
      类OutputDeviceAssigned是一个打印属性类，一个文本属性，用于标识服务分配了此作业的输出设备。
      class  PageRanges
      Class PageRanges是一个打印属性类，一组整数，用于标识打印机对象用于打印每个文档的每个副本的打印流页面的范围。
      class  PagesPerMinute
      Class PagesPerMinute是一个整数值打印属性，它表示可能由此打印机生成的最接近的整数的每分钟的标称页数（例如单面，黑白）。
      class  PagesPerMinuteColor
      Class PagesPerMinuteColor是一个整数值打印属性，表示当打印颜色（例如，单色，颜色）时可能由此打印机生成的最近整数的每分钟的标称页数。
      class  PDLOverrideSupported
      类PDLOverrideSupported是打印属性类，枚举，表示打印机尝试覆盖嵌入在文档打印数据中的处理指令的能力，处理指令指定为打印数据之外的属性。
      class  PresentationDirection
      类PresentationDirection是与NumberUp属性结合使用的打印属性类（枚举），用于指示多个打印流页面在所选介质的实例的单侧上施加的布局。
      class  PrinterInfo
      PrinterInfo类是一个打印属性类，一个文本属性，它提供有关打印机的描述信息。
      class  PrinterIsAcceptingJobs
      PrinterIsAcceptingJobs类是打印属性类，枚举，指示打印机当前是否能够接受作业。
      class  PrinterLocation
      PrinterLocation类是打印属性类，一个文本属性，用于标识设备的位置。
      class  PrinterMakeAndModel
      PrinterMakeAndModel类是打印属性类，文本属性，即打印机的制造商和型号。
      class  PrinterMessageFromOperator
      PrinterMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示打印机的信息或状态，例如为什么不可用或何时预计可用。
      class  PrinterMoreInfo
      PrinterMoreInfo类是打印属性类（URI），用于获取有关此特定打印机的更多信息。
      class  PrinterMoreInfoManufacturer
      PrinterMoreInfoManufacturer类是打印属性类（URI），用于获取有关此类设备的更多信息。
      class  PrinterName
      PrinterName类是一个打印属性类，一个指定打印机名称的文本属性。
      class  PrinterResolution
      PrinterResolution类是一个打印属性类，它指定打印机支持的准确分辨率或用于打印作业。
      class  PrinterState
      PrinterState类是打印属性类，枚举，用于标识打印机的当前状态。
      class  PrinterStateReason
      PrinterStateReason类是一个打印属性类，枚举，提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
      class  PrinterStateReasons
      PrinterStateReasons类是打印属性类，一组枚举值，提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
      class  PrinterURI
      PrinterURI类是一个打印属性类，一个URI，它指定打印机的全局唯一名称。
      class  PrintQuality
      PrintQuality类是打印属性类（枚举），用于指定打印机用于作业的打印质量。
      class  QueuedJobCount
      Class QueuedJobCount是一个整数值打印属性，表示打印机中的作业数，其中JobState为PENDING，PENDING_HELD，PROCESSING或PROCESSING_STOPPED。
      class  ReferenceUriSchemesSupported
      Class ReferenceUriSchemesSupported是打印属性类，表示打印机可用于检索存储在URI位置的打印数据的“URI方案”（例如“http：”或“ftp：”）的枚举。
      class  RequestingUserName
      Class RequestingUserName是一个打印属性类，一个文本属性，指定提交打印作业的最终用户的名称。
      class  Severity
      Class Severity是一个打印属性类，一个枚举，表示PrinterStateReason属性的严重性。
      class  SheetCollate
      SheetCollate类是一个打印属性类，一个枚举，用于指定当Copies属性指定文档的多个副本时，作业中每个打印文档的每个副本的介质页是否按顺序排列。
      class  Sides
      Class Sides是一个打印属性类，一个枚举，它指定打印流页面如何被施加到所选介质实例的侧面，即一个印象。

    • Uses of Serializable in javax.print.event

      Classes in javax.print.event that implement Serializable
      Modifier and Type Class 描述
      class  PrintEvent
      PrintEvent类是所有Print Service API事件的超类。
      class  PrintJobAttributeEvent
      PrintJobAttributeEvent类封装PrintService报告的事件，让客户端知道PrintJob的一个或多个打印属性已更改。
      class  PrintJobEvent
      PrintJobEvent类封装了打印作业报告的常见事件，让听众知道处理DocPrintJob的进度 。
      class  PrintServiceAttributeEvent
      PrintServiceAttributeEvent类封装Print Service实例报告的事件，让客户端了解打印服务状态的变化。

    • Uses of Serializable in javax.rmi.CORBA

      Classes in javax.rmi.CORBA that implement Serializable
      Modifier and Type Class 描述
      class  ClassDesc
      此类用于通过IIOP来组织java.lang.Class对象。
      class  Stub
      所有RMI-IIOP存根都必须从其继承的基类。
      Methods in javax.rmi.CORBA that return Serializable
      Modifier and Type 方法 描述
      Serializable ValueHandler.readValue​(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
      使用Java语义从流读取值。
      Serializable ValueHandler.writeReplace​(Serializable value)
      如果值包含一个 writeReplace方法，则返回结果。
      Methods in javax.rmi.CORBA with parameters of type Serializable
      Modifier and Type 方法 描述
      Serializable ValueHandler.writeReplace​(Serializable value)
      如果值包含一个 writeReplace方法，则返回结果。
      void ValueHandler.writeValue​(OutputStream out, Serializable value)
      使用Java语义将值写入流。
      void ValueHandlerMultiFormat.writeValue​(OutputStream out, Serializable value, byte streamFormatVersion)
      允许ORB传递RMI / IDL自定义值类型的流格式版本。

    • Uses of Serializable in javax.rmi.ssl

      Classes in javax.rmi.ssl that implement Serializable
      Modifier and Type Class 描述
      class  SslRMIClientSocketFactory
      一个 SslRMIClientSocketFactory实例由RMI运行时使用，以便通过SSL获取RMI调用的客户端套接字。

    • Uses of Serializable in javax.script

      Classes in javax.script that implement Serializable
      Modifier and Type Class 描述
      class  ScriptException
      脚本API的通用 异常类。

    • Uses of Serializable in javax.security.auth

      Classes in javax.security.auth that implement Serializable
      Modifier and Type Class 描述
      class  AuthPermission
      此类用于验证权限。
      class  DestroyFailedException
      表示 destroy操作失败。
      class  PrivateCredentialPermission
      此类用于保护对属于特定 Subject私有凭据的访问。
      class  RefreshFailedException
      表示 refresh操作失败。
      class  Subject
      A Subject表示单个实体（例如人）的相关信息的分组。

    • Uses of Serializable in javax.security.auth.callback

      Classes in javax.security.auth.callback that implement Serializable
      Modifier and Type Class 描述
      class  ChoiceCallback
      基础安全服务实例，并通过一个 ChoiceCallback至 handle一个方法 CallbackHandler ，以显示选项列表并获取选中的选项（S）。
      class  ConfirmationCallback
      基础安全服务实例，并通过一个 ConfirmationCallback至 handle一个方法 CallbackHandler ，以请求YES / NO，确定/取消，YES / NO / CANCEL或其他类似的确认。
      class  LanguageCallback
      基础安全服务实例，并通过一个 LanguageCallback至 handle一个方法 CallbackHandler检索 Locale用于本地化的文本。
      class  NameCallback
      基础安全服务实例，并通过一个 NameCallback至 handle一个方法 CallbackHandler ，以获取名称信息。
      class  PasswordCallback
      基础安全服务实例，并通过一个 PasswordCallback至 handle一个方法 CallbackHandler ，以获取密码信息。
      class  TextInputCallback
      基础安全服务实例，并通过一个 TextInputCallback至 handle一个方法 CallbackHandler检索普通的文本信息。
      class  TextOutputCallback
      基础安全服务实例，并通过一个 TextOutputCallback至 handle一个方法 CallbackHandler ，以显示信息消息，警告消息和错误消息。
      class  UnsupportedCallbackException
      信号一个 CallbackHandler不识别一个特定的 Callback 。

    • Uses of Serializable in javax.security.auth.kerberos

      Classes in javax.security.auth.kerberos that implement Serializable
      Modifier and Type Class 描述
      class  DelegationPermission
      此类用于限制Kerberos授权模型的使用，即：可转发和可预售的机票。
      class  EncryptionKey
      此类封装了Kerberos中使用的EncryptionKey。
      class  KerberosKey
      该类封装了Kerberos主体的长期密钥。
      class  KerberosPrincipal
      这个类封装了一个Kerberos主体。
      class  KerberosTicket
      从客户端的角度来看，该类封装了Kerberos票证和相关信息。
      class  ServicePermission
      此类用于保护Kerberos服务和访问这些服务所必需的凭据。

    • Uses of Serializable in javax.security.auth.login

      Classes in javax.security.auth.login that implement Serializable
      Modifier and Type Class 描述
      class  AccountException
      通用帐户异常。
      class  AccountExpiredException
      表示用户帐户已过期。
      class  AccountLockedException
      指示帐户被锁定。
      class  AccountNotFoundException
      表示找不到帐户。
      class  CredentialException
      通用凭证异常。
      class  CredentialExpiredException
      表示 Credential已过期。
      class  CredentialNotFoundException
      表示没有找到凭据。
      class  FailedLoginException
      表示用户身份验证失败。
      class  LoginException
      这是基本的登录异常。

    • Uses of Serializable in javax.security.auth.x500

      Classes in javax.security.auth.x500 that implement Serializable
      Modifier and Type Class 描述
      class  X500Principal
      这个类代表一个X.500 Principal 。

    • Uses of Serializable in javax.security.cert

      Classes in javax.security.cert that implement Serializable
      Modifier and Type Class 描述
      class  CertificateEncodingException
      已过时。
      使用java.security.cert的类。
      class  CertificateException
      已过时。
      使用java.security.cert的类。
      class  CertificateExpiredException
      已过时。
      使用java.security.cert的类。
      class  CertificateNotYetValidException
      已过时。
      使用java.security.cert的类。
      class  CertificateParsingException
      已过时。
      使用java.security.cert的类。

    • Uses of Serializable in javax.security.sasl

      Classes in javax.security.sasl that implement Serializable
      Modifier and Type Class 描述
      class  AuthenticationException
      由SASL机制实现引发此异常，以指示SASL交换机由于与认证有关的原因（例如无效的身份，密码或密钥）而失败。
      class  AuthorizeCallback
      SaslServer使用此回调来确定一个实体（通过认证的身份验证身份标识）是否可以代表另一个实体（由授权标识标识）。
      class  RealmCallback
      该回调由 SaslClient和 SaslServer用于检索领域信息。
      class  RealmChoiceCallback
      这个回调由 SaslClient和 SaslServer使用，以获得有关领域选择列表的领域。
      class  SaslException
      此类表示使用SASL时发生的错误。

    • Uses of Serializable in javax.smartcardio

      Classes in javax.smartcardio that implement Serializable
      Modifier and Type Class 描述
      class  ATR
      智能卡的应答复位字节。
      class  CardException
      在与智能卡堆栈或卡本身通信期间发生的错误异常。
      class  CardNotPresentException
      当应用程序尝试与没有存在卡的终端建立连接时抛出异常。
      class  CardPermission
      智能卡操作的许可。
      static class  CardTerminals.State
      枚举CardTerminal的属性。
      class  CommandAPDU
      遵循ISO / IEC 7816-4中定义的结构的命令APDU。
      class  ResponseAPDU
      符合ISO / IEC 7816-4规定的响应APDU。

    • Uses of Serializable in javax.sound.midi

      Classes in javax.sound.midi that implement Serializable
      Modifier and Type Class 描述
      class  InvalidMidiDataException
      一个 InvalidMidiDataException表示遇到不适当的MIDI数据。
      class  MidiUnavailableException
      当请求的MIDI组件由于不可用而无法打开或创建时，将抛出 MidiUnavailableException 。

    • Uses of Serializable in javax.sound.sampled

      Classes in javax.sound.sampled that implement Serializable
      Modifier and Type Class 描述
      class  AudioPermission
      AudioPermission类代表对音频系统资源的访问权限。
      class  LineEvent
      LineEvent类封装了线路打开，关闭，启动或停止时线路发送监听器的信息。
      class  LineUnavailableException
      A LineUnavailableException是一个例外，指示由于不可用而无法打开该行。
      class  UnsupportedAudioFileException
      一个 UnsupportedAudioFileException是一个例外，指示操作失败，因为文件不包含已识别的文件类型和格式的有效数据。

    • Uses of Serializable in javax.sql

      Classes in javax.sql that implement Serializable
      Modifier and Type Class 描述
      class  ConnectionEvent
      一个 Event对象，提供有关连接相关事件源的信息。
      class  RowSetEvent
      当 Event对象发生事件时生成的对象为 RowSet 。
      class  StatementEvent
      A StatementEvent发送到所有 StatementEventListener s，其中注册了一个 PooledConnection 。

    • Uses of Serializable in javax.sql.rowset

      Classes in javax.sql.rowset that implement Serializable
      Modifier and Type Class 描述
      class  BaseRowSet
      一个抽象类，提供一个 RowSet对象及其基本功能。
      class  RowSetMetaDataImpl
      提供有关设置和获取关于 RowSet对象的列的元数据信息的方法的实现。
      class  RowSetWarning
      SQLException的扩展名，它提供了有关在 RowSet对象上设置的数据库警告的信息。

    • Uses of Serializable in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Serializable
      Modifier and Type Class 描述
      class  SerialArray
      一个 Array对象的序列化版本，它是Java编程语言中的一个SQL ARRAY值的映射。
      class  SerialBlob
      在Java编程语言中的序列化映射SQL BLOB值。
      class  SerialClob
      在Java编程语言中的序列化映射SQL CLOB值。
      class  SerialDatalink
      一个序列化映射的Java编程语言中的一个SQL DATALINK值。
      class  SerialException
      表示SQL BLOB, CLOB, STRUCT or ARRAY的序列化或 BLOB, CLOB, STRUCT or ARRAY序列化的错误，如 BLOB, CLOB, STRUCT or ARRAY以及SQL类型，如 DATALINK and JAVAOBJECT
      class  SerialJavaObject
      SQL编程语言中的序列化映射SQL JAVA_OBJECT值。
      class  SerialRef
      一个 Ref对象的序列化映射，它是Java编程语言中的一个SQL REF值的映射。
      class  SerialStruct
      SQL编程语言中的SQL结构化类型的序列化映射。

    • Uses of Serializable in javax.sql.rowset.spi

      Classes in javax.sql.rowset.spi that implement Serializable
      Modifier and Type Class 描述
      class  SyncFactoryException
      表示出现 SyncFactory机制的错误。
      class  SyncProviderException
      表示 SyncProvider机制出现错误。

    • Uses of Serializable in javax.swing

      Classes in javax.swing that implement Serializable
      Modifier and Type Class 描述
      class  AbstractAction
      该类提供了JFC Action接口的默认实现。
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      protected class  AbstractButton.AccessibleAbstractButton
      该类实现 AbstractButton类的可访问性支持。
      protected class  AbstractButton.ButtonChangeListener
      扩展 ChangeListener可串行化。
      class  AbstractCellEditor
      CellEditors的基类，为 CellEditor接口除 getCellEditorValue()之外的方法提供默认实现。
      class  AbstractListModel<E>
      数据模型的抽象定义为其内容提供了一个 List 。
      class  AbstractSpinnerModel
      此类提供了SpinnerModel接口的ChangeListener部分，该接口应适用于大多数具体的SpinnerModel实现。
      class  ActionMap
      ActionMap提供从 Object s（称为 密钥或 Action名称 ）到 Action 。
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      protected class  Box.AccessibleBox
      该类为 Box类实现可访问性支持。
      static class  Box.Filler
      参与布局但没有视图的轻量级组件的实现。
      protected class  Box.Filler.AccessibleBoxFiller
      这个类实现 Box.Filler类的可访问性支持。
      class  BoxLayout
      一个布局管理器，可以将多个组件垂直或水平放置。
      class  ButtonGroup
      此类用于为一组按钮创建多重排除范围。
      class  CellRendererPane
      此类插入到单元格渲染器和使用它们的组件之间。
      protected class  CellRendererPane.AccessibleCellRendererPane
      这个类实现 CellRendererPane类的可访问性支持。
      class  ComponentInputMap
      甲 ComponentInputMap是 InputMap与特定关联 JComponent 。
      class  DefaultBoundedRangeModel
      BoundedRangeModel的一般实现。
      class  DefaultButtonModel
      默认实现的一个 Button组件的数据模型。
      class  DefaultCellEditor
      表和树单元格的默认编辑器。
      protected class  DefaultCellEditor.EditorDelegate
      受保护的 EditorDelegate类。
      class  DefaultComboBoxModel<E>
      组合框的默认模型。
      class  DefaultDesktopManager
      这是一个 DesktopManager的实现。
      class  DefaultListCellRenderer
      渲染列表中的项目。
      static class  DefaultListCellRenderer.UIResource
      实现UIResource的DefaultListCellRenderer的子类。
      class  DefaultListModel<E>
      该类松散地实现了 java.util.Vector API，因为它实现了1.1.x版本的 java.util.Vector ，没有收集类支持，并在发生更改时通知 ListDataListener 。
      class  DefaultListSelectionModel
      列表选择的默认数据模型。
      class  DefaultSingleSelectionModel
      SingleSelectionModel的一般实现。
      class  DropMode
      拖放模式，用于确定组件在拖放过程中跟踪并指示放置位置的方法。
      static class  GroupLayout.Alignment
      枚举可能的方式 ParallelGroup可以对齐其孩子。
      class  ImageIcon
      从图像绘制图标的图标界面的实现。
      protected class  ImageIcon.AccessibleImageIcon
      这个类实现 ImageIcon类的可访问性支持。
      class  InputMap
      InputMap提供输入事件之间的绑定（目前仅使用 KeyStroke ）和 Object 。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      protected class  JApplet.AccessibleJApplet
      已过时。
      这个类实现 JApplet类的可访问性支持。
      class  JButton
      实现“推”按钮。
      protected class  JButton.AccessibleJButton
      这个类实现 JButton类的可访问性支持。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      protected class  JCheckBox.AccessibleJCheckBox
      这个类实现 JCheckBox类的可访问性支持。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      该类实现 JCheckBoxMenuItem类的可访问性支持。
      class  JColorChooser
      JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
      protected class  JColorChooser.AccessibleJColorChooser
      这个类实现 JColorChooser类的可访问性支持。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      protected class  JComboBox.AccessibleJComboBox
      这个类实现 JComboBox类的可访问性支持。
      class  JComponent
      除顶级容器之外的所有Swing组件的基类。
      class  JComponent.AccessibleJComponent
      JComponent的内部类用于为辅助功能提供默认支持。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      protected class  JDesktopPane.AccessibleJDesktopPane
      该类为 JDesktopPane类实现可访问性支持。
      class  JDialog
      创建对话窗口的主要类。
      protected class  JDialog.AccessibleJDialog
      这个类实现 JDialog类的可访问性支持。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      protected class  JEditorPane.AccessibleJEditorPane
      这个类实现 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText 。
      class  JFileChooser
      JFileChooser为用户提供了一种简单的机制来选择文件。
      protected class  JFileChooser.AccessibleJFileChooser
      该类为 JFileChooser类实现可访问性支持。
      class  JFormattedTextField
      JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑文本，就检索特定的对象。
      static class  JFormattedTextField.AbstractFormatter
      AbstractFormatter实例由 JFormattedTextField用于处理从对象到字符串的转换，并从字符串返回到对象。
      class  JFrame
      扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。
      protected class  JFrame.AccessibleJFrame
      该类实现 JFrame类的可访问性支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      这个类实现 JInternalFrame类的可访问性支持。
      static class  JInternalFrame.JDesktopIcon
      该组件代表 JInternalFrame的图标化版本。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      这个类实现 JInternalFrame.JDesktopIcon类的可访问性支持。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并接收在其边框内生成的所有 AWTEvent的通知。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      protected class  JLayeredPane.AccessibleJLayeredPane
      这个类实现 JLayeredPane类的可访问性支持。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      protected class  JList.AccessibleJList
      这个类实现 JList类的可访问性支持。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。
      protected class  JMenu.AccessibleJMenu
      这个类实现 JMenu类的可访问性支持。
      protected class  JMenu.WinListener
      监听一个弹出窗口关闭的监听器类。
      class  JMenuBar
      一个菜单栏的实现。
      protected class  JMenuBar.AccessibleJMenuBar
      该类为 JMenuBar类实现可访问性支持。
      class  JMenuItem
      菜单中项目的实现。
      protected class  JMenuItem.AccessibleJMenuItem
      这个类实现 JMenuItem类的可访问性支持。
      class  JOptionPane
      JOptionPane可以方便地弹出一个标准对话框，提示用户输入一个值，或者通知他们某些东西。
      protected class  JOptionPane.AccessibleJOptionPane
      该类实现 JOptionPane类的可访问性支持。
      class  JPanel
      JPanel是一个通用的轻量级容器。
      protected class  JPanel.AccessibleJPanel
      该类为 JPanel类实现可访问性支持。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示已打字，但不显示原始字符。
      protected class  JPasswordField.AccessibleJPasswordField
      这个类实现 JPasswordField类的可访问性支持。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      protected class  JPopupMenu.AccessibleJPopupMenu
      该类为 JPopupMenu类实现可访问性支持。
      static class  JPopupMenu.Separator
      弹出菜单特定的分隔符。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      protected class  JProgressBar.AccessibleJProgressBar
      该类为 JProgressBar类实现可访问性支持。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      protected class  JRadioButton.AccessibleJRadioButton
      该类为 JRadioButton类实现可访问性支持。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现 JRadioButtonMenuItem类的可访问性支持。
      class  JRootPane
      通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
      protected class  JRootPane.AccessibleJRootPane
      该类为 JRootPane类实现可访问性支持。
      protected class  JRootPane.RootLayout
      一个自定义布局管理器，负责分层面，玻璃面和菜单栏的布局。
      class  JScrollBar
      一个滚动条的实现。
      protected class  JScrollBar.AccessibleJScrollBar
      该类为 JScrollBar类实现可访问性支持。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      protected class  JScrollPane.AccessibleJScrollPane
      这个类实现 JScrollPane类的可访问性支持。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
      class  JSeparator
      JSeparator提供了用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      protected class  JSeparator.AccessibleJSeparator
      这个类实现 JSeparator类的可访问性支持。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      protected class  JSlider.AccessibleJSlider
      该类实现 JSlider类的可访问性支持。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner为 JSpinner类实现了可访问性支持。
      static class  JSpinner.DateEditor
      一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。
      static class  JSpinner.DefaultEditor
      更专业的编辑器的简单基础，通过 JFormattedTextField显示模型当前值的 JFormattedTextField 。
      static class  JSpinner.ListEditor
      一个 JSpinner的编辑器，其型号是 SpinnerListModel 。
      static class  JSpinner.NumberEditor
      一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。
      class  JSplitPane
      JSplitPane用于分割两个（也只有两个） Component s。
      protected class  JSplitPane.AccessibleJSplitPane
      这个类实现 JSplitPane类的可访问性支持。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      protected class  JTabbedPane.AccessibleJTabbedPane
      该类为 JTabbedPane类实现可访问性支持。
      protected class  JTabbedPane.ModelListener
      我们通过 ModelChanged （而不是模型本身）将 ModelChanged事件传递给听众，作为事件源。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      protected class  JTable.AccessibleJTable
      该类实现 JTable类的辅助功能支持。
      static class  JTable.PrintMode
      打印模式，用于打印 JTable s。
      class  JTextArea
      A JTextArea是显示纯文本的多行区域。
      protected class  JTextArea.AccessibleJTextArea
      该类为 JTextArea类实现可访问性支持。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      protected class  JTextField.AccessibleJTextField
      这个类实现 JTextField类的可访问性支持。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      protected class  JToggleButton.AccessibleJToggleButton
      该类为 JToggleButton类实现可访问性支持。
      static class  JToggleButton.ToggleButtonModel
      ToggleButton模型
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      protected class  JToolBar.AccessibleJToolBar
      该类实现 JToolBar类的可访问性支持。
      static class  JToolBar.Separator
      工具栏特定的分隔符。
      class  JToolTip
      用于显示组件的“提示”。
      protected class  JToolTip.AccessibleJToolTip
      这个类实现 JToolTip类的可访问性支持。
      class  JTree
      作为轮廓显示一组分层数据的控件。
      protected class  JTree.AccessibleJTree
      这个类实现 JTree类的可访问性支持。
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode可以包装向量/哈希表/数组/字符串，并根据需要创建适当的子树节点。
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel是一个 TreeSelectionModel ，不允许任何东西被选择。
      protected class  JTree.TreeSelectionRedirector
      手柄创建一个新的 TreeSelectionEvent与 JTree作为来源，并将其传递给所有的听众。
      class  JViewport
      您可以通过它查看基础信息的“视口”或“舷窗”。
      protected class  JViewport.AccessibleJViewport
      这个类实现 JViewport类的可访问性支持。
      protected class  JViewport.ViewListener
      视图的监听器。
      class  JWindow
      A JWindow是可以在用户桌面上的任何位置显示的容器。
      protected class  JWindow.AccessibleJWindow
      这个类实现 JWindow类的可访问性支持。
      class  KeyStroke
      KeyStroke表示键盘或等效输入设备上的关键操作。
      class  LayoutFocusTraversalPolicy
      一个SortingFocusTraversalPolicy，它根据大小，位置和方向对组件进行排序。
      static class  LayoutStyle.ComponentPlacement
      ComponentPlacement是可以相对于彼此放置两个组件的可能方式的列举。
      class  OverlayLayout
      布局管理器将组件排列在彼此的顶部。
      static class  RowFilter.ComparisonType
      枚举可能的比较值，由一些默认的 RowFilter支持。
      class  ScrollPaneLayout
      由 JScrollPane使用的布局管理器。
      static class  ScrollPaneLayout.UIResource
      UI资源版本为 ScrollPaneLayout 。
      class  SizeRequirements
      为了方便布局管理器，计算有关组件的大小和位置的信息。
      class  SortOrder
      SortOrder是可能的排序顺序的枚举。
      class  SpinnerDateModel
      A SpinnerModel用于 Date s的序列。
      class  SpinnerListModel
      SpinnerModel的简单实现，其值由数组或 List定义。
      class  SpinnerNumberModel
      A SpinnerModel数字序列。
      static class  SwingWorker.StateValue
      state绑定属性的值。
      class  Timer
      以指定的间隔触发一个或多个 ActionEvent s。
      class  TransferHandler
      这个类用于处理从Swing组件 Transferable 。
      class  UIDefaults
      Swing组件的默认表。
      class  UIManager
      UIManager管理目前的外观和感觉，一组可用的外观和感觉， PropertyChangeListeners ，当外观和感觉变化，外观和感觉默认值以及获取各种默认值的便利方法时通知。
      class  UnsupportedLookAndFeelException
      表示所请求的外观和感觉管理类的异常不在用户系统上。
      class  ViewportLayout
      默认布局管理器为 JViewport 。

    • Uses of Serializable in javax.swing.border

      Classes in javax.swing.border that implement Serializable
      Modifier and Type Class 描述
      class  AbstractBorder
      实现无大小空白边框的类。
      class  BevelBorder
      一个实现一个简单的两行斜角边框的类。
      class  CompoundBorder
      一个复合的Border类，用于通过在Border对象的外部嵌套内嵌一个Border对象来将两个Border对象组合成一个单一的边框。
      class  EmptyBorder
      一个提供一个空的透明边框的类，占用空间但不绘图。
      class  EtchedBorder
      一个实现一个简单蚀刻边界的课程，可以被蚀刻或蚀刻出来。
      class  LineBorder
      实现任意厚度和单一颜色的线边框的类。
      class  MatteBorder
      一个提供纯色或平铺图标的无光泽边框的课程。
      class  SoftBevelBorder
      实现具有软化拐角的凸起或降低的斜面的课程。
      class  StrokeBorder
      实现任意笔画边框的课程。
      class  TitledBorder
      一个实现一个任意边框的类，在一个指定的位置添加一个String标题和对齐。

    • Uses of Serializable in javax.swing.colorchooser

      Classes in javax.swing.colorchooser that implement Serializable
      Modifier and Type Class 描述
      class  AbstractColorChooserPanel
      这是颜色选择器的抽象超类。
      class  DefaultColorSelectionModel
      通用实现 ColorSelectionModel 。

    • Uses of Serializable in javax.swing.event

      Classes in javax.swing.event that implement Serializable
      Modifier and Type Class 描述
      class  AncestorEvent
      向组件层级中的祖先发送的子组件的事件。
      class  CaretEvent
      CaretEvent用于通知有关方面事件源文本插入符已更改。
      class  ChangeEvent
      ChangeEvent用于通知有关方面事件来源状态已更改。
      class  EventListenerList
      一个持有EventListener列表的类。
      class  HyperlinkEvent
      HyperlinkEvent用于通知有关方面，超文本链接发生了一些事情。
      class  InternalFrameEvent
      一个 AWTEvent ，添加了对 JInternalFrame对象的支持作为事件源。
      class  ListDataEvent
      定义将更改封装到列表的事件。
      class  ListSelectionEvent
      表征选择变化的事件。
      class  MenuDragMouseEvent
      MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。
      class  MenuEvent
      MenuEvent用于通知有关方面，事件源的菜单已经过滤，选择或取消。
      class  MenuKeyEvent
      MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。
      class  PopupMenuEvent
      PopupMenuEvent仅包含发送事件的JPopupMenu事件的源
      class  RowSorterEvent
      RowSorterEvent提供改变到的通知 RowSorter 。
      static class  RowSorterEvent.Type
      枚举类型 RowSorterEvent s。
      class  SwingPropertyChangeSupport
      java.beans.PropertyChangeSupport这个子类功能几乎相同。
      class  TableColumnModelEvent
      TableColumnModelEvent用于通知侦听器表列模型已更改，例如添加，删除或移动列。
      class  TableModelEvent
      TableModelEvent用于通知侦听器表模型已更改。
      class  TreeExpansionEvent
      用于标识树中单个路径的事件。
      class  TreeModelEvent
      将描述更改的信息封装到树模型，并用于通知树型模型侦听器的更改。
      class  TreeSelectionEvent
      表示当前选择的变化的事件。
      class  UndoableEditEvent
      发生可以撤消的操作的事件。

    • Uses of Serializable in javax.swing.plaf

      Classes in javax.swing.plaf that implement Serializable
      Modifier and Type Class 描述
      class  ActionMapUIResource
      实现UIResource的javax.swing.ActionMap的子类。
      class  BorderUIResource
      实现UIResource的边界包装类。
      static class  BorderUIResource.BevelBorderUIResource
      斜角边界UI资源。
      static class  BorderUIResource.CompoundBorderUIResource
      复合边界UI资源。
      static class  BorderUIResource.EmptyBorderUIResource
      一个空的边界UI资源。
      static class  BorderUIResource.EtchedBorderUIResource
      蚀刻的边界UI资源。
      static class  BorderUIResource.LineBorderUIResource
      线边界UI资源。
      static class  BorderUIResource.MatteBorderUIResource
      无边界的UI资源。
      static class  BorderUIResource.TitledBorderUIResource
      标题边界UI资源。
      class  ColorUIResource
      实现UIResource的Color子类。
      class  ComponentInputMapUIResource
      实现UIResource的javax.swing.ComponentInputMap的子类。
      class  DimensionUIResource
      实现 UIResource的 Dimension的子类。
      class  FontUIResource
      实现UIResource的java.awt.Font的子类。
      class  IconUIResource
      一个实现UIResource的图标包装类。
      class  InputMapUIResource
      实现UIResource的javax.swing.InputMap的子类。
      class  InsetsUIResource
      Insets实现UIResource的子类。
      class  LayerUI<V extends Component>
      所有JLayer的UI代表的基类。

    • Uses of Serializable in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Serializable
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
      static class  BasicBorders.ButtonBorder
      画一个按钮周围的边框。
      static class  BasicBorders.FieldBorder
      绘制一个字段周围的边框。
      static class  BasicBorders.MarginBorder
      围绕支持边距的组件绘制边框。
      static class  BasicBorders.MenuBarBorder
      绘制菜单栏周围的边框。
      static class  BasicBorders.RadioButtonBorder
      绘制单选按钮周围的边框。
      static class  BasicBorders.RolloverButtonBorder
      特殊的细边框，用于翻转工具栏按钮。
      static class  BasicBorders.ToggleButtonBorder
      绘制切换按钮周围的边框。
      class  BasicComboBoxRenderer
      ComboBox渲染器
      static class  BasicComboBoxRenderer.UIResource
      BasicComboBoxRenderer的子类实现UIResource。
      class  BasicComboPopup
      这是 ComboPopup接口的基本实现。
      protected class  BasicDesktopPaneUI.CloseAction
      处理关闭内部框架。
      protected class  BasicDesktopPaneUI.MaximizeAction
      处理最大化内部框架。
      protected class  BasicDesktopPaneUI.MinimizeAction
      处理最小化内部框架。
      protected class  BasicDesktopPaneUI.NavigateAction
      处理导航到下一个内部框架。
      protected class  BasicDesktopPaneUI.OpenAction
      处理恢复最小化或最大化的内部框架。
      class  BasicDirectoryModel
      文件列表的基本实现。
      protected class  BasicFileChooserUI.ApproveSelectionAction
      响应打开或保存请求
      protected class  BasicFileChooserUI.CancelSelectionAction
      回复取消请求。
      protected class  BasicFileChooserUI.ChangeToParentDirectoryAction
      更改为父目录操作。
      protected class  BasicFileChooserUI.GoHomeAction
      在“家”键事件或等效事件上行事。
      protected class  BasicFileChooserUI.NewFolderAction
      创建一个新文件夹。
      protected class  BasicFileChooserUI.UpdateAction
      重新扫描当前目录中的文件
      class  BasicIconFactory
      工厂对象可以将图标适用于基本的L＆F
      class  BasicInternalFrameTitlePane
      管理基本标题栏的类
      class  BasicInternalFrameTitlePane.CloseAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.IconifyAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MaximizeAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MoveAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.RestoreAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.SizeAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.SystemMenuBar
      这个类应该被视为一个“受保护”的内部类。
      class  BasicLookAndFeel
      用于创建Swing的外观的基础类。
      class  BasicSliderUI.ActionScroller
      从Java 2平台v1.3开始，这个未记录的类就不再使用了。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      static class  BasicTextUI.BasicCaret
      接口默认实现 Caret 。
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener在执行操作时调用cancelEditing。
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction用于处理结束/ home操作。
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction用于处理上/下动作。
      class  BasicTreeUI.TreePageAction
      TreePageAction处理页面向上和向下翻页事件。
      class  BasicTreeUI.TreeToggleAction
      对于第一个选定的行展开将被切换。
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction是用于左/右键的动作。
      class  DefaultMenuLayout
      弹出菜单和菜单栏的默认布局管理器。

    • Uses of Serializable in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement Serializable
      Modifier and Type | Class | 描述
      static class  MetalBorders.ButtonBorder
      该类代表 JButton的边界。
      static class  MetalBorders.Flush3DBorder
      该类代表3D边框。
      static class  MetalBorders.InternalFrameBorder
      该类代表一个 JInternalFrame的边界。
      static class  MetalBorders.MenuBarBorder
      该类代表一个 JMenuBar的边界。
      static class  MetalBorders.MenuItemBorder
      该类代表一个 JMenuItem的边界。
      static class  MetalBorders.OptionDialogBorder
      该类表示选项对话框的边框。
      static class  MetalBorders.PaletteBorder
      边框的调色板。
      static class  MetalBorders.PopupMenuBorder
      该类代表一个 JPopupMenu的边界。
      static class  MetalBorders.RolloverButtonBorder
      该类代表翻转的边界 Button 。
      static class  MetalBorders.ScrollPaneBorder
      该类代表一个 JScrollPane的边界。
      static class  MetalBorders.TableHeaderBorder
      表头的边框
      static class  MetalBorders.TextFieldBorder
      该类代表一个 JTestField的边界。
      static class  | MetalBorders.ToggleButtonBorder
      static class  MetalBorders.ToolBarBorder
      该类代表一个 JToolBar的边界。
      class  MetalCheckBoxIcon
      OrganicCheckBoxUI的CheckboxIcon实现
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalComboBoxIcon
      此实用程序类绘制指示MetalComboBox的水平条
      class  MetalComboBoxUI.MetalComboPopup
      已过时。
      从Java 2平台v1.4开始。
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      当DirectoryComboBox更改所选项目时使用。
      protected class  MetalFileChooserUI.DirectoryComboBoxModel
      类型面部选择组合框的数据模型。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      protected class  MetalFileChooserUI.FilterComboBoxModel
      类型面部选择组合框的数据模型。
      class  MetalFileChooserUI.FilterComboBoxRenderer
      渲染不同类型的尺寸和样式。
      class  MetalIconFactory
      工厂对象为Java“¢”外观（金属）提供 Icon秒。
      static class  MetalIconFactory.FileIcon16
      警告：此类的序列化对象与将来的Swing版本不兼容。
      static class  MetalIconFactory.FolderIcon16
      警告：此类的序列化对象与将来的Swing版本不兼容。
      static class  MetalIconFactory.PaletteCloseIcon
      定义调色板关闭的图标
      static class  MetalIconFactory.TreeControlIcon
      警告：此类的序列化对象与将来的Swing版本不兼容。
      static class  MetalIconFactory.TreeFolderIcon
      警告：此类的序列化对象与将来的Swing版本不兼容。
      static class  MetalIconFactory.TreeLeafIcon
      该类代表树叶图标。
      class  MetalInternalFrameTitlePane
      管理JLF标题栏的类
      class  MetalLookAndFeel
      Java外观和感觉，也称为金属。
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。

    • Uses of Serializable in javax.swing.plaf.nimbus

      Classes in javax.swing.plaf.nimbus that implement Serializable
      Modifier and Type Class 描述
      protected static class  AbstractRegionPainter.PaintContext.CacheMode
      缓存模式。
      class  NimbusLookAndFeel
      NimbusLookAndFeel类。

    • Uses of Serializable in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement Serializable
      Modifier and Type Class 描述
      class  SynthLookAndFeel
      SynthLookAndFeel提供了创建自定义外观的基础。

    • Uses of Serializable in javax.swing.table

      Classes in javax.swing.table that implement Serializable
      Modifier and Type Class 描述
      class  AbstractTableModel
      这个抽象类为 TableModel接口中的大多数方法提供了默认实现。
      class  DefaultTableCellRenderer
      在 JTable渲染（显示）单个单元格的标准类。
      static class  DefaultTableCellRenderer.UIResource
      DefaultTableCellRenderer的子类实现 UIResource 。
      class  DefaultTableColumnModel
      JTable的标准列处理程序。
      class  DefaultTableModel
      这是一个 TableModel的实现，它使用 Vector Vectors来存储单元格值对象。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。
      protected class  JTableHeader.AccessibleJTableHeader
      该类实现 JTableHeader类的可访问性支持。
      class  TableColumn
      甲 TableColumn表示在所述列的所有属性 JTable ，诸如宽度，可调整大小，最小和最大宽度。

    • Uses of Serializable in javax.swing.text

      Classes in javax.swing.text that implement Serializable
      Modifier and Type Class 描述
      class  AbstractDocument
      实现文档界面，作为实施各种文件的基础。
      class  AbstractDocument.AbstractElement
      实现元素的抽象部分。
      class  AbstractDocument.BranchElement
      实现一个包含其他元素的复合元素。
      class  AbstractDocument.DefaultDocumentEvent
      正在修改文档时存储文档更改。
      static class  AbstractDocument.ElementEdit
      可以添加到文档事件中的ElementChange的实现。
      class  AbstractDocument.LeafElement
      实现直接表示某种内容的元素。
      class  BadLocationException
      此异常是报告文档模型中的不良位置（即尝试引用不存在的位置）。
      class  ChangedCharSetException
      ChangedCharSetException作为名称指示是在更改字符集时抛出的异常。
      class  DateFormatter
      DateFormatter是一个 InternationalFormatter ，它通过 java.text.DateFormat的实例进行 java.text.DateFormat 。
      class  DefaultCaret
      默认的Caret实现。
      class  DefaultEditorKit
      这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。
      static class  DefaultEditorKit.BeepAction
      发出哔声
      static class  DefaultEditorKit.CopyAction
      复制所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.CutAction
      剪切所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.DefaultKeyTypedAction
      如果接收到 键入类型的事件并且没有键映射条目，则默认执行的操作。
      static class  DefaultEditorKit.InsertBreakAction
      在文档中放置一个行/段落。
      static class  DefaultEditorKit.InsertContentAction
      将内容放入相关的文档。
      static class  DefaultEditorKit.InsertTabAction
      将标签字符放在文档中。
      static class  DefaultEditorKit.PasteAction
      将系统剪贴板的内容粘贴到所选区域中，或者如果没有选择任何内容，则将其插入插入符号之前。
      class  DefaultFormatter
      DefaultFormatter格式化任意对象。
      class  DefaultFormatterFactory
      执行 JFormattedTextField.AbstractFormatterFactory 。
      class  DefaultStyledDocument
      可以以与RTF格式相似的方式标记字符和段落样式的文档。
      static class  DefaultStyledDocument.AttributeUndoableEdit
      一个UndoableEdit用于记住对元素的AttributeSet更改。
      class  DefaultStyledDocument.ElementBuffer
      用于管理元素层次结构更改的类。
      protected class  DefaultStyledDocument.SectionElement
      文档的默认根元素...映射包含的段落/行。
      class  EditorKit
      将文本组件所需的一组事物建立为某种 类型的文本内容的合理功能的编辑器。
      class  GapContent
      AbstractDocument.Content接口的实现使用与emacs使用的类似的间隙缓冲区来实现。
      class  InternationalFormatter
      InternationalFormatter延伸 DefaultFormatter ，使用的实例 java.text.Format来处理转换为字符串，并从字符串的转换。
      class  JTextComponent
      JTextComponent是swing文本组件的基类。
      class  JTextComponent.AccessibleJTextComponent
      该类实现 JTextComponent类的辅助功能支持。
      class  MaskFormatter
      MaskFormatter用于格式化和编辑字符串。
      class  NumberFormatter
      NumberFormatter子类 InternationalFormatter为数字添加特殊行为。
      class  PlainDocument
      一个不保留字符属性的简单文档。
      class  SimpleAttributeSet
      使用哈希表直接实现MutableAttributeSet。
      class  StringContent
      AbstractDocument.Content接口的实现是一种强大的强制实现，对于较小的文档和/或调试很有用。
      class  StyleContext
      一组风格及其相关资源。
      class  StyleContext.NamedStyle
      属性集合，通常用于表示字符和段落样式。
      class  StyledEditorKit
      这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。
      static class  StyledEditorKit.AlignmentAction
      设置段落对齐的动作。
      static class  StyledEditorKit.BoldAction
      用于切换粗体属性的操作。
      static class  StyledEditorKit.FontFamilyAction
      在关联的JEditorPane中设置字体系列的操作。
      static class  StyledEditorKit.FontSizeAction
      在关联的JEditorPane中设置字体大小的操作。
      static class  StyledEditorKit.ForegroundAction
      设置前景色的动作。
      static class  StyledEditorKit.ItalicAction
      切换斜体属性的动作。
      static class  StyledEditorKit.StyledTextAction
      一个假定它被安装在一个带有StyledEditorKit（或子类）的JEditorPane上被触发的动作。
      static class  StyledEditorKit.UnderlineAction
      切换下划线属性的动作。
      class  TabSet
      TabSet由许多TabStops组成。
      class  TabStop
      这个类封装了一个制表符停止（基本上就是标签停止被RTF认为）。
      class  TextAction
      对于跨多个不同文本组件共享的键绑定的Action实现。

    • Uses of Serializable in javax.swing.text.html

      Classes in javax.swing.text.html that implement Serializable
      Modifier and Type Class 描述
      class  CSS
      将一组 CSS attributes定义为类型安全枚举。
      class  FormSubmitEvent
      FormSubmitEvent用于通知有关方面提交表单。
      static class  FormSubmitEvent.MethodType
      表示HTML表单方法类型。
      static class  HTML.UnknownTag
      类代表未知的HTML标签。
      class  HTMLDocument
      建立HTML的文档。
      class  HTMLDocument.BlockElement
      表示HTML的结构 块的元素。
      class  HTMLDocument.RunElement
      表示一组文本的元素，该文本块分配有一组HTML字符级属性。
      class  HTMLEditorKit
      Swing JEditorPane文本组件通过称为EditorKit的插件机制来支持不同类型的内容。
      static class  HTMLEditorKit.HTMLTextAction
      一个抽象的Action提供了一些方便的方法，可能有助于将HTML插入到现有文档中。
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction可用于将HTML的任意字符串插入到现有的HTML文档中。
      static class  HTMLEditorKit.LinkController
      在适当的时候，类可以观看相关组件并在其上触发超链接事件。
      class  HTMLFrameHyperlinkEvent
      HTMLFrameHyperlinkEvent用于通知相关方链接已在一帧中激活。
      class  Option
      用于表示<option>元素的ListModel的值。
      class  StyleSheet
      支持定义正在渲染的HTML视图的视觉特征。
      static class  StyleSheet.BoxPainter
      课程执行CSS格式的一些职责。
      static class  StyleSheet.ListPainter
      课程执行CSS列表格式的一些职责。

    • Uses of Serializable in javax.swing.text.html.parser

      Classes in javax.swing.text.html.parser that implement Serializable
      Modifier and Type Class 描述
      class  AttributeList
      该类使用ATTLIST构造在DTD中描述了SGML元素的属性。
      class  ContentModel
      内容模型的表示。
      class  Element
      使用ELEMENT构造在DTD中描述的元素。
      class  ParserDelegator
      每次调用它的解析方法时，负责启动一个新的DocumentParser。

    • Uses of Serializable in javax.swing.text.rtf

      Classes in javax.swing.text.rtf that implement Serializable
      Modifier and Type Class 描述
      class  RTFEditorKit
      这是RTF编辑功能的默认实现。

    • Uses of Serializable in javax.swing.tree

      Classes in javax.swing.tree that implement Serializable
      Modifier and Type Class 描述
      class  DefaultMutableTreeNode
      A DefaultMutableTreeNode是树状数据结构中的通用节点。
      class  DefaultTreeCellEditor.DefaultTextField
      当没有提供编辑器时使用 TextField 。
      class  DefaultTreeCellEditor.EditorContainer
      集装箱负责放置 editingComponent 。
      class  DefaultTreeCellRenderer
      在树中显示一个条目。
      class  DefaultTreeModel
      一个使用TreeNodes的简单树数据模型。
      class  DefaultTreeSelectionModel
      TreeSelectionModel的默认实现。
      class  ExpandVetoException
      用于阻止扩展/崩溃的异常发生。
      class  TreePath
      TreePath表示唯一标识树中某个节点的路径的对象数组。

    • Uses of Serializable in javax.swing.undo

      Classes in javax.swing.undo that implement Serializable
      Modifier and Type Class 描述
      class  AbstractUndoableEdit
      UndoableEdit的抽象实现，实现对该接口中所有布尔方法的简单响应。
      class  CannotRedoException
      当UndoableEdit被告知到 redo()并且不能被抛出。
      class  CannotUndoException
      抛出一个UndoableEdit被告知到 undo()而不能。
      class  CompoundEdit
      AbstractUndoableEdit的一个具体子类，用于将小的UndoableEdits组合成大型的。
      class  StateEdit
      StateEdit是更改状态的对象的一般编辑。
      class  UndoManager
      UndoManager管理列表 UndoableEdits ，提供了一种方法来撤消或恢复适当的编辑。

    • Uses of Serializable in javax.tools

      Classes in javax.tools that implement Serializable
      Modifier and Type Class 描述
      static class  Diagnostic.Kind
      诊断的种类，例如错误或警告。
      static class  DocumentationTool.Location
      特定于DocumentationTool的地点。
      static class  JavaFileObject.Kind
      种类的JavaFileObjects。
      class  StandardLocation
      文件对象的标准位置。

    • Uses of Serializable in javax.transaction

      Classes in javax.transaction that implement Serializable
      Modifier and Type Class 描述
      class  InvalidTransactionException
      此异常表示请求携带无效的事务上下文。
      class  TransactionRequiredException
      此异常指示请求携带空事务上下文，但目标对象需要激活事务。
      class  TransactionRolledbackException
      此异常表示与请求的处理关联的事务已回滚，或标记为回滚。

    • Uses of Serializable in javax.transaction.xa

      Classes in javax.transaction.xa that implement Serializable
      Modifier and Type Class 描述
      class  XAException
      资源管理器（RM）抛出XAException，以通知事务管理器涉及的事务遇到的错误。

    • Uses of Serializable in javax.xml.bind

      Classes in javax.xml.bind that implement Serializable
      Modifier and Type Class 描述
      class  DataBindingException
      表示JAXB操作失败的异常。
      class  JAXBElement<T>
      一个Xml元素的JAXB表示。
      class  JAXBException
      这是所有JAXB异常的根异常类。
      class  JAXBPermission
      此类用于JAXB权限。
      class  MarshalException
      此异常表示在执行提供程序无法恢复的组织操作时发生错误。
      class  PropertyException
      此异常表示获取或设置属性时遇到错误。
      class  TypeConstraintException
      此异常表示检测到违反动态检查的类型约束。
      class  UnmarshalException
      此异常表示执行卸载操作时发生错误，阻止JAXB提供程序完成操作。
      class  ValidationException
      此异常表示执行验证操作时发生错误。

    • Uses of Serializable in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation that implement Serializable
      Modifier and Type Class 描述
      class  XmlAccessOrder
      由XmlAccessorOrder用于控制JAXB绑定类中的属性和字段的排序。
      class  XmlAccessType
      由XmlAccessorType用于控制字段或属性的序列化。
      class  XmlNsForm
      枚举XML Schema命名空间资格。

    • Uses of Serializable in javax.xml.catalog

      Classes in javax.xml.catalog that implement Serializable
      Modifier and Type Class 描述
      class  CatalogException
      异常类处理在处理或使用目录时可能发生的错误。
      static class  CatalogFeatures.Feature
      特征类型，如 Catalog Features table所定义。

    • Uses of Serializable in javax.xml.crypto

      Classes in javax.xml.crypto that implement Serializable
      Modifier and Type Class 描述
      class  KeySelectorException
      表示由KeySelector抛出的异常情况。
      class  MarshalException
      表示在XML编组或解组过程中发生的异常情况。
      class  NoSuchMechanismException
      当请求特定的XML机制但在环境中不可用时抛出此异常。
      class  URIReferenceException
      表示在取消引用URIReference时抛出异常情况。

    • Uses of Serializable in javax.xml.crypto.dsig

      Classes in javax.xml.crypto.dsig that implement Serializable
      Modifier and Type Class 描述
      class  TransformException
      表示执行变换算法时发生的异常情况。
      class  XMLSignatureException
      表示在XML签名生成或验证过程中发生的特殊情况。

    • Uses of Serializable in javax.xml.datatype

      Classes in javax.xml.datatype that implement Serializable
      Modifier and Type Class 描述
      class  DatatypeConfigurationException
      表示严重的配置错误。

    • Uses of Serializable in javax.xml.namespace

      Classes in javax.xml.namespace that implement Serializable
      Modifier and Type Class 描述
      class  QName
      QName表示如在XML规范中定义一个 限定名 ： XML Schema Part2: Datatypes specification ， Namespaces in XML ， Namespaces in XML Errata 。

    • Uses of Serializable in javax.xml.parsers

      Classes in javax.xml.parsers that implement Serializable
      Modifier and Type Class 描述
      class  FactoryConfigurationError
      当与Parser工厂存在配置问题时抛出。
      class  ParserConfigurationException
      表示严重的配置错误。

    • Uses of Serializable in javax.xml.soap

      Classes in javax.xml.soap that implement Serializable
      Modifier and Type Class 描述
      class  SOAPException
      发生SOAP异常发生的异常。

    • Uses of Serializable in javax.xml.stream

      Classes in javax.xml.stream that implement Serializable
      Modifier and Type Class 描述
      class  FactoryConfigurationError
      报告工厂配置错误的错误类。
      class  XMLStreamException
      基于异常的意外处理错误。

    • Uses of Serializable in javax.xml.transform

      Classes in javax.xml.transform that implement Serializable
      Modifier and Type Class 描述
      class  TransformerConfigurationException
      表示严重的配置错误。
      class  TransformerException
      此类指定在转换过程中发生的异常情况。
      class  TransformerFactoryConfigurationError
      当Transformer工厂存在配置问题时抛出。

    • Uses of Serializable in javax.xml.validation

      Classes in javax.xml.validation that implement Serializable
      Modifier and Type Class 描述
      class  SchemaFactoryConfigurationError
      当存在具有Schema工厂的配置问题时抛出。

    • Uses of Serializable in javax.xml.ws

      Classes in javax.xml.ws that implement Serializable
      Modifier and Type Class 描述
      class  Holder<T>
      持有值类型 T 。
      class  ProtocolException
      ProtocolException类是与特定协议绑定相关的异常的基类。
      static class  Service.Mode
      动态客户端或服务的方向。
      class  WebServiceException
      WebServiceException类是所有JAX-WS API运行时异常的基本异常类。
      class  WebServicePermission
      此类定义Web服务权限。

    • Uses of Serializable in javax.xml.ws.handler

      Classes in javax.xml.ws.handler that implement Serializable
      Modifier and Type Class 描述
      static class  MessageContext.Scope
      财产范围

    • Uses of Serializable in javax.xml.ws.http

      Classes in javax.xml.ws.http that implement Serializable
      Modifier and Type Class 描述
      class  HTTPException
      HTTPException异常表示XML / HTTP故障。

    • Uses of Serializable in javax.xml.ws.soap

      Classes in javax.xml.ws.soap that implement Serializable
      Modifier and Type Class 描述
      static class  AddressingFeature.Responses
      如果启用寻址，则此属性确定端点是否仅需要使用匿名响应，或仅使用非匿名响应或全部。
      class  SOAPFaultException
      SOAPFaultException异常表示SOAP 1.1或1.2故障。

    • Uses of Serializable in javax.xml.xpath

      Classes in javax.xml.xpath that implement Serializable
      Modifier and Type Class 描述
      static class  XPathEvaluationResult.XPathResultType
      XPathResultType表示XPath评估的可能的返回类型。
      class  XPathException
      XPathException表示通用的XPath异常。
      class  XPathExpressionException
      XPathExpressionException表示XPath表达式中的错误。
      class  XPathFactoryConfigurationException
      XPathFactoryConfigurationException表示 XPathFactory环境中的配置错误。
      class  XPathFunctionException
      XPathFunctionException表示XPath函数的错误。

    • Uses of Serializable in jdk.dynalink

      Classes in jdk.dynalink that implement Serializable
      Modifier and Type Class 描述
      class  NoSuchDynamicMethodException
      如果呼叫站点无法通过任何可用的GuardingDynamicLinker链接，则在调用时抛出。
      class  StandardNamespace
      Dynalink定义的标准命名空间的枚举。
      class  StandardOperation
      定义标准动态操作。

    • Uses of Serializable in jdk.dynalink.beans

      Classes in jdk.dynalink.beans that implement Serializable
      Modifier and Type Class 描述
      class  StaticClass
      允许访问类的静态成员（其静态方法，属性和字段）的对象，以及使用 StandardOperation.NEW操作构建实例的 对象 。

    • Uses of Serializable in jdk.dynalink.linker

      Classes in jdk.dynalink.linker that implement Serializable
      Modifier and Type Class 描述
      static class  ConversionComparator.Comparison
      列举将一个转换与另一个转换进行比较的可能结果。

    • Uses of Serializable in jdk.incubator.http

      Classes in jdk.incubator.http that implement Serializable
      Modifier and Type Class 描述
      static class  HttpClient.Redirect
      定义自动重定向策略。
      static class  HttpClient.Version
      HTTP协议版本。
      class  HttpTimeoutException
      在指定时间段内没有收到回应时抛出。
      static class  WebSocket.MessagePart
      WebSocket.Listener在可能收到部分消息的情况下使用的标记。
      class  WebSocketHandshakeException
      用于表示开启握手的异常失败。

    • Uses of Serializable in jdk.javadoc.doclet

      Classes in jdk.javadoc.doclet that implement Serializable
      Modifier and Type | Class | 描述
      static class  Doclet.Option.Kind
      这种选择。
      static class  | DocletEnvironment.ModuleMode
      static class  Taglet.Location
      可以使用标签的位置。

    • Uses of Serializable in jdk.jshell

      Classes in jdk.jshell that implement Serializable
      Modifier and Type Class 描述
      class  EvalException
      封装在远程执行客户机中抛出的异常。
      class  JShellException
      JShell的超类生成异常
      static class  Snippet.Kind
      描述一般的片段。
      static class  Snippet.Status
      描述代码段的当前状态。
      static class  Snippet.SubKind
      一个片段的详细种类。
      static class  SourceCodeAnalysis.Completeness
      描述给定输入的完整性。
      class  UnresolvedReferenceException
      在尝试执行一个 RECOVERABLE_DEFINED片段时报告了异常。

    • Uses of Serializable in jdk.jshell.spi

      Classes in jdk.jshell.spi that implement Serializable
      Modifier and Type Class 描述
      static class  ExecutionControl.ClassBytecodes
      使用类字节码捆绑类名。
      static class  ExecutionControl.ClassInstallException
      类安装（加载或重新定义）遇到问题。
      static class  ExecutionControl.EngineTerminationException
      未执行引擎终止已发生。
      static class  ExecutionControl.ExecutionControlException
      所有 ExecutionControl例外的抽象基础。
      static class  ExecutionControl.InternalException
      发生内部问题。
      static class  ExecutionControl.NotImplementedException
      该命令未实现。
      static class  ExecutionControl.ResolutionException
      一个异常，表示遇到了未解决的引用的一个 DeclarationSnippet 。
      static class  ExecutionControl.RunException
      特定于运行用户代码的异常的抽象基础。
      static class  ExecutionControl.StoppedException
       表示
ExecutionControl.invoke(java.lang.String, java.lang.String) （或理论上为
ExecutionControl.varValue(java.lang.String, java.lang.String) ）已被
ExecutionControl.stop()中断的
异常 。
      static class  ExecutionControl.UserException
      发生“正常”用户异常。
      class  SPIResolutionException
      此异常的构造和抛出嵌入在JShell核心实现中生成的代码中，以便在执行 RECOVERABLE_DEFINED用户方法时抛出此异常。

    • Uses of Serializable in jdk.nashorn.api.scripting

      Classes in jdk.nashorn.api.scripting that implement Serializable
      Modifier and Type Class 描述
      class  NashornException
      这是所有Nashorn异常的基础例外。

    • Uses of Serializable in jdk.nashorn.api.tree

      Classes in jdk.nashorn.api.tree that implement Serializable
      Modifier and Type Class 描述
      static class  Diagnostic.Kind
      诊断的种类，例如错误或警告。
      static class  Tree.Kind
      列举各种树木。
      class  UnknownTreeException
      表示遇到了一种未知类型的树。

    • Uses of Serializable in jdk.net

      Classes in jdk.net that implement Serializable
      Modifier and Type Class 描述
      class  NetworkPermission
      表示访问jdk.net包中定义的扩展网络功能的权限。
      static class  SocketFlow.Status
      从SO_FLOW_SLA套接字选项枚举返回值。

    • Uses of Serializable in jdk.security.jarsigner

      Classes in jdk.security.jarsigner that implement Serializable
      Modifier and Type Class 描述
      class  JarSignerException
      当 JarSigner.sign(java.util.zip.ZipFile, java.io.OutputStream)失败时抛出此异常。

    • Uses of Serializable in netscape.javascript

      Classes in netscape.javascript that implement Serializable
      Modifier and Type Class 描述
      class  JSException
      在JavaScript引擎中引发异常时抛出。

    • Uses of Serializable in org.ietf.jgss

      Classes in org.ietf.jgss that implement Serializable
      Modifier and Type Class 描述
      class  GSSException
      发生GSS-API错误时会抛出此异常，包括任何机制特定的错误。

    • Uses of Serializable in org.omg.CORBA

      Subinterfaces of Serializable in org.omg.CORBA
      Modifier and Type 接口 描述
      interface  Current
      从 Current接口派生的接口使ORB和CORBA服务可以访问与运行线程相关联的信息（上下文）。
      interface  DataInputStream
      定义用于从输入流读取原始数据类型的方法，以解除对自定义值类型的调整。
      interface  DataOutputStream
      定义用于将原始数据类型写入到编组自定义值类型的输出流中的方法。
      interface  DomainManager
      提供建立和导航关系到上级和下级域以及创建和访问策略的机制。
      interface  IDLType
      由代表OMG IDL类型的所有Interface Repository（IR）对象继承的抽象接口。
      interface  IRObject
      IRObject IDL接口代表所有其他接口存储库接口派生的最通用接口，即使是Repository本身。
      interface  Policy
      从 Policy接口派生的接口允许ORB或CORBA服务访问影响其操作的某些选择。
      Classes in org.omg.CORBA that implement Serializable
      Modifier and Type Class 描述
      class  _IDLTypeStub
      存根为 IDLType 。
      class  _PolicyStub
      存根为 Policy 。
      class  ACTIVITY_COMPLETED
      可以在任何访问Activity上下文的方法上引发 ACTIVITY_COMPLETED系统异常。
      class  ACTIVITY_REQUIRED
      可能会在需要Activity上下文的任何方法上引发 ACTIVITY_REQUIRED系统异常。
      class  Any
      作为可以在IDL或任何IDL原语类型中描述的任何数据的容器。
      class  BAD_CONTEXT
      当客户端调用操作时抛出异常，但传递的上下文不包含操作所需的上下文值。
      class  BAD_INV_ORDER
      这个异常表示调用者以错误的顺序调用了操作。
      class  BAD_OPERATION
      当对象引用表示现有对象但该对象不支持被调用的操作时抛出异常。
      class  BAD_PARAM
      传递给调用的参数超出范围或以其他方式被视为非法时引发的异常。
      class  BAD_QOS
      当对象不能支持具有与其相关联的服务质量语义的调用参数所需的服务质量时，引发 BAD_QOS异常。
      class  BAD_TYPECODE
      当ORB遇到格式错误的代码（例如， TCKind值无效的类型代码）时抛出异常。
      class  Bounds
      当参数不在方法尝试访问的对象的合法范围内时抛出用户异常。
      class  CODESET_INCOMPATIBLE
      无论客户端和服务器本机代码集之间无法进行有意义的通信，都会引发此异常。
      class  COMM_FAILURE
      在客户端发送请求后，服务器的回复已经返回到客户端之前，在进行中的通信丢失时发生异常。
      class  CompletionStatus
      指示当抛出 SystemException时方法是否已完成运行的对象。
      class  DATA_CONVERSION
      如果ORB无法将封送的数据的表示形式转换为其本机表示形式，反之亦然，则会引发此异常。
      class  DefinitionKind
      提供用于标识Interface Repository对象类型的常量的类。
      class  FREE_MEM
      ORB在尝试释放动态内存时失败，例如由于堆损坏或内存段被锁定而导致异常。
      class  IMP_LIMIT
      此异常表示在ORB运行时间中超出了实施限制。
      class  INITIALIZE
      当ORB在其初始化期间遇到故障（例如无法获取网络资源或检测到配置错误）时抛出异常。
      class  INTERNAL
      此异常指示ORB中的内部故障，例如，如果ORB检测到其内部数据结构的损坏。
      class  INTF_REPOS
      当ORB无法到达接口存储库或检测到与接口存储库相关的某些其他故障时引发异常。
      class  INV_FLAG
      当一个无效标志传递给一个操作时（例如创建一个DII请求）时抛出异常。
      class  INV_IDENT
      此异常表示IDL标识符在语法上无效。
      class  INV_OBJREF
      此异常表示对象引用在内部格式错误。
      class  INV_POLICY
      当由于 Policy覆盖不适用于特定调用而导致不能进行调用时，抛出标准异常。
      class  INVALID_ACTIVITY
      如果事务或活动在与其挂起的环境不同的上下文中恢复，则可能会在“活动”或“事务”服务的恢复方法中引发 INVALID_ACTIVITY系统异常。
      class  INVALID_TRANSACTION
      当请求携带无效的事务上下文时抛出异常。
      class  MARSHAL
      来自网络的请求或回复在结构上是无效的。
      class  NameValuePair
      将名称与作为IDL结构体的属性的值相关联，并在 DynStruct API中使用。
      class  NO_IMPLEMENT
      此异常表示即使已调用的操作存在（它具有IDL定义），也不存在该操作的实现。
      class  NO_MEMORY
      ORB运行时内存不足时抛出异常。
      class  NO_PERMISSION
      调用失败时引发异常，因为调用者的权限不足。
      class  NO_RESOURCES
      当ORB遇到一些一般资源限制时抛出异常。
      class  NO_RESPONSE
      如果客户端尝试检索延迟同步调用的结果，但该请求的响应尚不可用，则会引发此异常。
      class  OBJ_ADAPTER
      此异常通常表示管理不匹配，例如，服务器可能尝试以已经在使用的名称或对存储库未知的实现存储库注册自身。
      class  OBJECT_NOT_EXIST
      每当执行对被删除对象的调用时，就会引发异常。
      class  ParameterMode
      枚举参数的参数模式。
      class  PERSIST_STORE
      此异常表示持续存储故障，例如，无法建立数据库连接或数据库损坏。
      class  PolicyError
      发生策略错误时抛出的用户异常。
      class  REBIND
      REBIND上升时电流有效RebindPolicy，具有NO_REBIND或NO_RECONNECT的值和上一个绑定的对象引用在消息LocateReply具有状态OBJECT_FORWARD或状态为LOCATION_FORWARD一个应答消息的调用。
      class  ServiceDetail
      表示ORB服务的对象：其 service_detail_type字段包含ORB服务的类型，其 service_detail字段包含ORB服务的描述。
      class  ServiceInformation
      CORBA模块中的IDL结构，用于存储有关ORB实现中可用的CORBA服务的信息，并从 ORB.get_service_information获取。
      class  SetOverrideType
      CORBA 枚举标记 SET_OVERRIDE和 ADD_OVERRIDE ，其指示策略是否应替换现有策略为 Object或被添加到它们。
      class  StructMember
      描述了一种IDL的成员 struct在接口库，包括名称 struct构件，所述的类型 struct构件，和表示的IDL类型的typedef struct构件描述的 struct成员对象。
      class  SystemException
      所有CORBA标准异常的根类。
      class  TIMEOUT
      TIMEOUT在没有交货并且超出了指定的生存时间段时被提出。
      class  TRANSACTION_MODE
      如果检测到IOR中的InvocationPolicy和所选择的调用路径（即，直接或路由调用）之间的不匹配，则客户端ORB抛出CORBA TRANSACTION_MODE异常。
      class  TRANSACTION_REQUIRED
      异常表示请求携带一个空事务上下文，但需要一个活动事务。
      class  TRANSACTION_ROLLEDBACK
      与请求相关联的事务已经回滚或标记回滚时抛出异常。
      class  TRANSACTION_UNAVAILABLE
      由于ORB与事务服务的连接已异常终止，所以ORB无法处理事务服务上下文时抛出CORBA TRANSACTION_UNAVAILABLE异常。
      class  TRANSIENT
      当ORB尝试到达对象并失败时抛出异常。
      class  TypeCode
      有关特定CORBA数据类型的信息的容器。
      class  UnionMember
      IDL联盟成员的Interface Repository中的描述。
      class  UNKNOWN
      如果操作实现抛出非CORBA异常（例如特定于实现的编程语言的异常），或者操作引发不在操作的引用表达式中出现的用户异常，则会引发此异常。
      class  UnknownUserException
      包含服务器返回的用户异常的类。
      class  UserException
      CORBA IDL定义用户异常的根类。
      class  ValueMember
      value对象的成员的Interface Repository中的描述。
      class  WrongTransaction
      CORBA WrongTransaction用户定义的异常。
      Fields in org.omg.CORBA declared as Serializable
      Modifier and Type Field 描述
      Serializable ValueBaseHolder.value
      这个 ValueBaseHolder对象持有的 java.io.Serializable值。
      Methods in org.omg.CORBA that return Serializable
      Modifier and Type | 方法 | 描述
      static Serializable | ValueBaseHelper.extract​(Any a)
      abstract Serializable Any.extract_Value​()
      在此 Any对象的 value字段中提取 java.io.Serializable对象。
      Serializable DynAny.get_val​()
      已过时。
      检索此 java.io.Serializable对象中包含的 DynAny对象。
      static Serializable | ValueBaseHelper.read​(InputStream istream)
      Serializable | StringValueHelper.read_value​(InputStream istream)
      Serializable | WStringValueHelper.read_value​(InputStream istream)
      Serializable DataInputStream.read_Value​()
      从输入流读取IDL值类型。
      Methods in org.omg.CORBA with parameters of type Serializable
      Modifier and Type | 方法 | 描述
      static void | ValueBaseHelper.insert​(Any a, Serializable that)
      void DynAny.insert_val​(Serializable value)
      已过时。
      插入给定的 java.io.Serializable对象作为此 DynAny对象的值。
      abstract void Any.insert_Value​(Serializable v)
      将给定的 java.io.Serializable对象插入到此 Any对象的 value字段中。
      abstract void Any.insert_Value​(Serializable v, TypeCode t)
      将给定的 java.io.Serializable对象插入到这个 Any对象的 value字段中。
      static void | ValueBaseHelper.write​(OutputStream ostream, Serializable value)
      void | StringValueHelper.write_value​(OutputStream ostream, Serializable value)
      void | WStringValueHelper.write_value​(OutputStream ostream, Serializable value)
      void DataOutputStream.write_Value​(Serializable value)
      将IDL值类型值写入输出流。
      Constructors in org.omg.CORBA with parameters of type Serializable
      Constructor 描述
      ValueBaseHolder​(Serializable initial)
      构造一个新的 ValueBaseHolder对象，其 value字段初始化为给定的 java.io.Serializable 。

    • Uses of Serializable in org.omg.CORBA_2_3.portable

      Methods in org.omg.CORBA_2_3.portable that return Serializable
      Modifier and Type 方法 描述
      Serializable InputStream.read_value​()
      从输入流解组值类型。
      Serializable InputStream.read_value​(Serializable value)
      从输入流解组值类型。
      Serializable InputStream.read_value​(Class clz)
      从输入流解组值类型。
      Serializable InputStream.read_value​(String rep_id)
      从输入流解组值类型。
      Serializable InputStream.read_value​(BoxedValueHelper factory)
      从输入流解组值类型。
      Methods in org.omg.CORBA_2_3.portable with parameters of type Serializable
      Modifier and Type 方法 描述
      Serializable InputStream.read_value​(Serializable value)
      从输入流解组值类型。
      void OutputStream.write_value​(Serializable value)
      为输出流调度值类型。
      void OutputStream.write_value​(Serializable value, Class clz)
      为输出流调度值类型。
      void OutputStream.write_value​(Serializable value, String repository_id)
      为输出流调度值类型。
      void OutputStream.write_value​(Serializable value, BoxedValueHelper factory)
      为输出流调度值类型。

    • Uses of Serializable in org.omg.CORBA.DynAnyPackage

      Classes in org.omg.CORBA.DynAnyPackage that implement Serializable
      Modifier and Type | Class | 描述
      class  Invalid
      当传递错误的 DynAny或 Any作为参数时，动态的任何操作都会抛出无效。
      class  InvalidSeq
      InvalidSeq异常被所有操作抛出，在动态任务中，当序列无效时，它将一个序列（Java数组）作为参数。
      class  | InvalidValue
      class  TypeMismatch
      当实际内容的类型与尝试访问的内容不匹配时，TypeMismatch将被动态的任何访问器方法抛出。

    • Uses of Serializable in org.omg.CORBA.ORBPackage

      Classes in org.omg.CORBA.ORBPackage that implement Serializable
      Modifier and Type Class 描述
      class  InconsistentTypeCode
      尝试使用不匹配 DynAny特定子类的类型代码创建动态任务时，会抛出 DynAny 。
      class  InvalidName
      当 ORB.resolve_initial_references传递一个没有初始引用的名称时， ORB.resolve_initial_references InvalidName异常。

    • Uses of Serializable in org.omg.CORBA.portable

      Subinterfaces of Serializable in org.omg.CORBA.portable
      Modifier and Type 接口 描述
      interface  CustomValue
      由自定义值类型实现的扩展名为 ValueBase 。
      interface  IDLEntity
      没有成员的界面，其唯一目的是作为标记，指示实现类是具有相应助手类的IDL的Java值类型。
      interface  StreamableValue
      定义不是自定义封送的所有非盒装IDL值类型的基本类型。
      interface  ValueBase
      对应于类型IDL类型的生成的Java类实现此接口。
      Classes in org.omg.CORBA.portable that implement Serializable
      Modifier and Type Class 描述
      class  ApplicationException
      此类用于报告ORB和存根之间的应用程序级异常。
      class  IndirectionException
      间接异常是一个Java特定的系统异常。
      class  RemarshalException
      该类用于将向前的异常和对象前向GIOP消息定位回ORB。
      class  UnknownException
      org.omg.CORBA.portable.UnknownException用于报告关系和ORB之间以及ORB和存根之间的未知异常。
      Methods in org.omg.CORBA.portable that return Serializable
      Modifier and Type | 方法 | 描述
      Serializable | BoxedValueHelper.read_value​(InputStream is)
      Serializable ValueFactory.read_value​(InputStream is)
      在解组数值类型的过程中，由ORB运行时调用。
      Methods in org.omg.CORBA.portable with parameters of type Serializable
      Modifier and Type | 方法 | 描述
      void | BoxedValueHelper.write_value​(OutputStream os, Serializable value)

    • Uses of Serializable in org.omg.CORBA.TypeCodePackage

      Classes in org.omg.CORBA.TypeCodePackage that implement Serializable
      Modifier and Type Class 描述
      class  BadKind
      当在 TypeCode对象上调用不正确的操作时，抛出异常 BadKind 。
      class  Bounds
      提供 TypeCode操作 member_name() ， member_type() ，并 member_label 。

    • Uses of Serializable in org.omg.CosNaming

      Subinterfaces of Serializable in org.omg.CosNaming
      Modifier and Type 接口 描述
      interface  BindingIterator
      BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
      interface  NamingContext
      命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
      interface  NamingContextExt
      NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
      Classes in org.omg.CosNaming that implement Serializable
      Modifier and Type | Class | 描述
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。
      class  _NamingContextExtStub
      NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。
      class  | _NamingContextImplBase
      class  _NamingContextStub
      命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。
      class  Binding
      org / omg / CosNaming / Binding.java。
      class  BindingType
      指定给定的绑定是针对对象（不是命名上下文）还是用于命名上下文。
      class  NameComponent
      org / omg / CosNaming / NameComponent.java。

    • Uses of Serializable in org.omg.CosNaming.NamingContextExtPackage

      Classes in org.omg.CosNaming.NamingContextExtPackage that implement Serializable
      Modifier and Type Class 描述
      class  InvalidAddress
      org / omg / CosNaming / NamingContextExtPackage / InvalidAddress.java。

    • Uses of Serializable in org.omg.CosNaming.NamingContextPackage

      Classes in org.omg.CosNaming.NamingContextPackage that implement Serializable
      Modifier and Type Class 描述
      class  AlreadyBound
      org / omg / CosNaming / NamingContextPackage / AlreadyBound.java。
      class  CannotProceed
      org / omg / CosNaming / NamingContextPackage / CannotProceed.java。
      class  InvalidName
      org / omg / CosNaming / NamingContextPackage / InvalidName.java。
      class  NotEmpty
      org / omg / CosNaming / NamingContextPackage / NotEmpty.java。
      class  NotFound
      org / omg / CosNaming / NamingContextPackage / NotFound.java。
      class  NotFoundReason
      表示无法解决的原因。

    • Uses of Serializable in org.omg.Dynamic

      Classes in org.omg.Dynamic that implement Serializable
      Modifier and Type Class 描述
      class  Parameter
      org / omg / Dynamic / Parameter.java。

    • Uses of Serializable in org.omg.DynamicAny

      Subinterfaces of Serializable in org.omg.DynamicAny
      Modifier and Type 接口 描述
      interface  DynAny
      任何值都可以动态解释（遍历）并通过DynAny对象构造。
      interface  DynAnyFactory
      可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。
      interface  DynArray
      DynArray对象支持IDL数组的操作。
      interface  DynEnum
      DynEnum对象支持对IDL枚举值的操作。
      interface  DynFixed
      DynFixed对象支持IDL固定值的操作。
      interface  DynSequence
      DynSequence对象支持IDL序列的操作。
      interface  DynStruct
      DynStruct对象支持IDL结构和异常值的操作。
      interface  DynUnion
      DynUnion对象支持IDL联盟的操纵。
      interface  DynValue
      DynValue对象支持IDL非盒装值类型的操作。
      interface  DynValueBox
      DynValueBox对象支持IDL框值类型的操作。
      interface  DynValueCommon
      DynValueCommon提供由DynValue和DynValueBox接口支持的操作。
      Classes in org.omg.DynamicAny that implement Serializable
      Modifier and Type Class 描述
      class  _DynAnyFactoryStub
      可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。
      class  _DynAnyStub
      任何值都可以动态解释（遍历）并通过DynAny对象构造。
      class  _DynArrayStub
      DynArray对象支持IDL数组的操作。
      class  _DynEnumStub
      DynEnum对象支持对IDL枚举值的操作。
      class  _DynFixedStub
      DynFixed对象支持IDL固定值的操作。
      class  _DynSequenceStub
      DynSequence对象支持IDL序列的操作。
      class  _DynStructStub
      DynStruct对象支持IDL结构和异常值的操作。
      class  _DynUnionStub
      DynUnion对象支持IDL联盟的操纵。
      class  _DynValueStub
      DynValue对象支持IDL非盒装值类型的操作。
      class  NameDynAnyPair
      org / omg / DynamicAny / NameDynAnyPair.java。
      class  NameValuePair
      org / omg / DynamicAny / NameValuePair.java。
      Methods in org.omg.DynamicAny that return Serializable
      Modifier and Type 方法 描述
      Serializable _DynAnyStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable _DynArrayStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable _DynEnumStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable _DynFixedStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable _DynSequenceStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable _DynStructStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable _DynUnionStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable _DynValueStub.get_val​()
      从此DynAny中提取可序列化的对象。
      Serializable DynAnyOperations.get_val​()
      从此DynAny中提取可序列化的对象。
      Methods in org.omg.DynamicAny with parameters of type Serializable
      Modifier and Type 方法 描述
      void _DynAnyStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void _DynArrayStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void _DynEnumStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void _DynFixedStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void _DynSequenceStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void _DynStructStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void _DynUnionStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void _DynValueStub.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。
      void DynAnyOperations.insert_val​(Serializable value)
      将可序列化对象的引用插入此DynAny。

    • Uses of Serializable in org.omg.DynamicAny.DynAnyFactoryPackage

      Classes in org.omg.DynamicAny.DynAnyFactoryPackage that implement Serializable
      Modifier and Type Class 描述
      class  InconsistentTypeCode
      org / omg / DynamicAny / DynAnyFactoryPackage / InconsistentTypeCode.java。

    • Uses of Serializable in org.omg.DynamicAny.DynAnyPackage

      Classes in org.omg.DynamicAny.DynAnyPackage that implement Serializable
      Modifier and Type Class 描述
      class  InvalidValue
      org / omg / DynamicAny / DynAnyPackage / InvalidValue.java。
      class  TypeMismatch
      org / omg / DynamicAny / DynAnyPackage / TypeMismatch.java。

    • Uses of Serializable in org.omg.IOP

      Subinterfaces of Serializable in org.omg.IOP
      Modifier and Type 接口 描述
      interface  Codec
      ORB服务使用的IOR组件和服务上下文数据的格式通常定义为编码IDL定义数据类型实例的CDR封装。
      interface  CodecFactory
      Codecs是从 CodecFactory获得的。
      Classes in org.omg.IOP that implement Serializable
      Modifier and Type Class 描述
      class  Encoding
      org / omg / IOP / Encoding.java。
      class  IOR
      org / omg / IOP / IOR.java。
      class  ServiceContext
      org / omg / IOP / ServiceContext.java。
      class  TaggedComponent
      org / omg / IOP / TaggedComponent.java。
      class  TaggedProfile
      org / omg / IOP / TaggedProfile.java。

    • Uses of Serializable in org.omg.IOP.CodecFactoryPackage

      Classes in org.omg.IOP.CodecFactoryPackage that implement Serializable
      Modifier and Type Class 描述
      class  UnknownEncoding
      org / omg / IOP / CodecFactoryPackage / UnknownEncoding.java。

    • Uses of Serializable in org.omg.IOP.CodecPackage

      Classes in org.omg.IOP.CodecPackage that implement Serializable
      Modifier and Type Class 描述
      class  FormatMismatch
      org / omg / IOP / CodecPackage / FormatMismatch.java。
      class  InvalidTypeForEncoding
      org / omg / IOP / CodecPackage / InvalidTypeForEncoding.java。
      class  TypeMismatch
      org / omg / IOP / CodecPackage / TypeMismatch.java。

    • Uses of Serializable in org.omg.PortableInterceptor

      Subinterfaces of Serializable in org.omg.PortableInterceptor
      Modifier and Type 接口 描述
      interface  ClientRequestInfo
      请求信息，客户端请求拦截器可访问。
      interface  ClientRequestInterceptor
      客户端请求拦截器。
      interface  Current
      便携式拦截器当前（也称为 PICurrent ）仅仅是一个时隙表，每个服务的时隙表都用于在其上下文和请求或应答的服务上下文之间传送其上下文数据。
      interface  Interceptor
      所有便携式拦截器实施拦截器。
      interface  IORInfo
      在IOR构造期间提供服务器端ORB服务访问适用的策略以及添加组件的能力。
      interface  IORInterceptor
      拦截器用于在IOR中的配置文件中建立标记的组件。
      interface  IORInterceptor_3_0
      org / omg / PortableInterceptor / IORInterceptor_3_0.java。
      interface  ObjectReferenceFactory
      对象引用工厂。
      interface  ObjectReferenceTemplate
      对象引用模板。
      interface  ORBInitializer
      方便拦截器注册和ORB初始化。
      interface  ORBInitInfo
      传递给每个 ORBInitializer ，允许它在ORB初始化时注册拦截器并执行其他任务。
      interface  PolicyFactory
      启用使用 CORBA.ORB.create_policy构建的策略类型。
      interface  RequestInfo
      请求信息，拦截器可访问。
      interface  ServerRequestInfo
      请求信息，可由服务器端请求拦截器访问。
      interface  ServerRequestInterceptor
      服务器端请求拦截器。
      Classes in org.omg.PortableInterceptor that implement Serializable
      Modifier and Type Class 描述
      class  ForwardRequest
      org / omg / PortableInterceptor / ForwardRequest.java。
      class  InvalidSlot
      org / omg / PortableInterceptor / InvalidSlot.java。

    • Uses of Serializable in org.omg.PortableInterceptor.ORBInitInfoPackage

      Classes in org.omg.PortableInterceptor.ORBInitInfoPackage that implement Serializable
      Modifier and Type Class 描述
      class  DuplicateName
      org / omg / PortableInterceptor / ORBInitInfoPackage / DuplicateName.java。
      class  InvalidName
      org / omg / PortableInterceptor / ORBInitInfoPackage / InvalidName.java。

    • Uses of Serializable in org.omg.PortableServer

      Subinterfaces of Serializable in org.omg.PortableServer
      Modifier and Type 接口 描述
      interface  AdapterActivator
      适配器激活器为POA提供了根据需要创建儿童POA的能力，作为接收命名儿童POA（或其一个孩子）的请求的副作用，或者当使用activate参数值为TRUE时调用find_POA时。
      interface  Current
      从CORBA :: Current派生的PortableServer :: Current接口提供了访问方法被调用的对象的身份的方法实现。
      interface  IdAssignmentPolicy
      IdAssignmentPolicy指定创建的POA中的对象Id是由应用程序还是由ORB生成。
      interface  IdUniquenessPolicy
      IdUniquenessPolicy指定在创建的POA中激活的服务器是否必须具有唯一对象i身份。
      interface  ImplicitActivationPolicy
      此策略指定在创建的POA中是否支持仆人的隐式激活。
      interface  LifespanPolicy
      LifespanPolicy指定在创建的POA中实现的对象的使用寿命。
      interface  POA
      POA对象管理对象集合的实现。
      interface  POAManager
      每个POA对象都有一个关联的POAManager对象。
      interface  RequestProcessingPolicy
      此策略指定创建的POA如何处理请求。
      interface  ServantActivator
      当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。
      interface  ServantLocator
      当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。
      interface  ServantManager
      当POA接收到针对非活动对象的请求时，仆人经理为POA提供激活对象的能力。
      interface  ServantRetentionPolicy
      此策略指定创建的POA是否在活动对象映射中保留活动服务器。
      interface  ThreadPolicy
      ThreadPolicy指定与创建的POA一起使用的线程模型。
      Classes in org.omg.PortableServer that implement Serializable
      Modifier and Type Class 描述
      class  _ServantActivatorStub
      当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。
      class  _ServantLocatorStub
      当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。
      class  ForwardRequest
      org / omg / PortableServer / ForwardRequest.java。
      class  IdAssignmentPolicyValue
      IdAssignmentPolicyValue可以具有以下值。
      class  IdUniquenessPolicyValue
      IdUniquenessPolicyValue可以具有以下值。
      class  ImplicitActivationPolicyValue
      ImplicitActivationPolicyValue具有以下语义。
      class  LifespanPolicyValue
      LifespanPolicyValue可以具有以下值。
      class  RequestProcessingPolicyValue
      RequestProcessingPolicyValue可以具有以下值。
      class  ServantRetentionPolicyValue
      ServantRetentionPolicyValue可以具有以下值。
      class  ThreadPolicyValue
      ThreadPolicyValue可以具有以下值。

    • Uses of Serializable in org.omg.PortableServer.CurrentPackage

      Classes in org.omg.PortableServer.CurrentPackage that implement Serializable
      Modifier and Type Class 描述
      class  NoContext
      org / omg / PortableServer / CurrentPackage / NoContext.java。

    • Uses of Serializable in org.omg.PortableServer.POAManagerPackage

      Classes in org.omg.PortableServer.POAManagerPackage that implement Serializable
      Modifier and Type Class 描述
      class  AdapterInactive
      org / omg / PortableServer / POAManagerPackage / AdapterInactive.java。
      class  State
      指定POAManager的状态

    • Uses of Serializable in org.omg.PortableServer.POAPackage

      Classes in org.omg.PortableServer.POAPackage that implement Serializable
      Modifier and Type Class 描述
      class  AdapterAlreadyExists
      org / omg / PortableServer / POAPackage / AdapterAlreadyExists.java。
      class  AdapterNonExistent
      org / omg / PortableServer / POAPackage / AdapterNonExistent.java。
      class  InvalidPolicy
      org / omg / PortableServer / POAPackage / InvalidPolicy.java。
      class  NoServant
      org / omg / PortableServer / POAPackage / NoServant.java。
      class  ObjectAlreadyActive
      org / omg / PortableServer / POAPackage / ObjectAlreadyActive.java。
      class  ObjectNotActive
      org / omg / PortableServer / POAPackage / ObjectNotActive.java。
      class  ServantAlreadyActive
      org / omg / PortableServer / POAPackage / ServantAlreadyActive.java。
      class  ServantNotActive
      org / omg / PortableServer / POAPackage / ServantNotActive.java。
      class  WrongAdapter
      org / omg / PortableServer / POAPackage / WrongAdapter.java。
      class  WrongPolicy
      org / omg / PortableServer / POAPackage / WrongPolicy.java。

    • Uses of Serializable in org.omg.SendingContext

      Subinterfaces of Serializable in org.omg.SendingContext
      Modifier and Type 接口 描述
      interface  RunTime
      定义表示请求的发送上下文的基类。

    • Uses of Serializable in org.omg.stub.java.rmi

      Classes in org.omg.stub.java.rmi that implement Serializable
      Modifier and Type Class 描述
      class  _Remote_Stub
      该类提供了远程类型的存根。

    • Uses of Serializable in org.w3c.dom

      Classes in org.w3c.dom that implement Serializable
      Modifier and Type Class 描述
      class  DOMException
      DOM操作只会在“异常”情况下引发异常，即当操作无法执行时（出于逻辑原因，因为数据丢失，或者由于实现变得不稳定））。

    • Uses of Serializable in org.w3c.dom.events

      Classes in org.w3c.dom.events that implement Serializable
      Modifier and Type Class 描述
      class  EventException
      事件操作可能会 EventException其方法描述中指定的 EventException 。

    • Uses of Serializable in org.w3c.dom.ls

      Classes in org.w3c.dom.ls that implement Serializable
      Modifier and Type Class 描述
      class  LSException
      如果处理停止，解析器或写入操作可能会抛出 LSException 。

    • Uses of Serializable in org.w3c.dom.ranges

      Classes in org.w3c.dom.ranges that implement Serializable
      Modifier and Type Class 描述
      class  RangeException
      范围操作可能会抛出其方法说明中指定的 RangeException 。

    • Uses of Serializable in org.w3c.dom.xpath

      Classes in org.w3c.dom.xpath that implement Serializable
      Modifier and Type Class 描述
      class  XPathException
      为这些XPath接口特定的异常创建了一个新的异常。

    • Uses of Serializable in org.xml.sax

      Classes in org.xml.sax that implement Serializable
      Modifier and Type Class 描述
      class  SAXException
      封装一般的SAX错误或警告。
      class  SAXNotRecognizedException
      无法识别的标识符的异常类。
      class  SAXNotSupportedException
      不受支持的操作的异常类。
      class  SAXParseException
      封装XML解析错误或警告。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AbstractMethodError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class AbstractMethodError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.IncompatibleClassChangeError
            • java.lang.AbstractMethodError
  • All Implemented Interfaces:
    Serializable

    public class AbstractMethodError
extends IncompatibleClassChangeError
    当应用程序尝试调用抽象方法时抛出。 通常，该错误被编译器捕获; 如果某些类的定义自上次编译当前执行的方法以来不兼容地更改，则此错误只能在运行时发生。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AbstractMethodError​()
      构造一个没有详细信息的 AbstractMethodError 。
      AbstractMethodError​(String s)
      构造具有指定详细消息的 AbstractMethodError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AbstractMethodError

        public AbstractMethodError​()
        构造一个没有详细消息的 AbstractMethodError 。

      • AbstractMethodError

        public AbstractMethodError​(String s)
        构造具有指定详细消息的 AbstractMethodError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Appendable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface Appendable

  • 所有已知实现类：
    BufferedWriter ， CharArrayWriter ， CharBuffer ， FileWriter ， FilterWriter ， LogStream ， OutputStreamWriter ， PipedWriter ， PrintStream ， PrintWriter ， StringBuffer ， StringBuilder ， StringWriter ， Writer

    public interface Appendable
    可附加char序列和值的对象。 Appendable接口必须由其实例旨在从Formatter接收格式化输出的任何类实现。

    要附加的字符应为Unicode Character Representation中描述的有效Unicode字符。 请注意，补充字符可以由多个16位char值组成。

    对于多线程访问，附加功能不一定是安全的。 线程安全是扩展和实现这个接口的类的责任。

    由于此接口可能由具有不同样式的错误处理的现有类实现，因此不能保证将错误传播到调用者。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Appendable append​(char c)
      将指定的字符追加到此 Appendable 。
      Appendable append​(CharSequence csq)
      将指定的字符序列追加到此 Appendable 。
      Appendable append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列追加到此 Appendable 。

    • 方法详细信息

      • append

        Appendable append​(CharSequence csq)
           throws IOException
        将指定的字符序列追加到此Appendable 。

        根据哪个类实现字符序列csq ，整个序列可能不被附加。 例如，如果csq是一个CharBuffer，则附加的子序列由缓冲区的位置和限制来定义。

        参数
        csq - 要附加的字符序列。 如果csq为null ，则该"null"可附加四个字符"null" 。
        结果
        参考这个 Appendable
        异常
        IOException - 如果发生I / O错误

      • append

        Appendable append​(CharSequence csq,
                  int start,
                  int end)
           throws IOException
        将指定字符序列的子序列追加到此Appendable 。

        形式的这种方法的调用out.append(csq, start, end)时csq不是null ，行为以完全相同的方式调用

          out.append(csq.subSequence(start, end))
        参数
        csq - 附加子序列的字符序列。 如果csq是null ，那么字符将被追加，如果csq包含四个字符"null" 。
        start - 子序列中第一个字符的索引
        end - 子序列中最后一个字符后面的字符的索引
        结果
        参考这个 Appendable
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，则 start大于 end ，或 end大于 csq.length()
        IOException - 如果发生I / O错误

      • append

        Appendable append​(char c)
           throws IOException
        将指定的字符追加到此 Appendable 。
        参数
        c - 要追加的字符
        结果
        参考这个 Appendable
        异常
        IOException - 如果发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ArithmeticException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ArithmeticException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.ArithmeticException
  • All Implemented Interfaces:
    Serializable

    public class ArithmeticException
extends RuntimeException
    抛出异常算术条件时抛出。 例如，“除以零”的整数会抛出此类的一个实例。 ArithmeticException对象可以由虚拟机构建，如同suppression were disabled and/or the stack trace was not writable一样 。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ArithmeticException​()
      构造一个 ArithmeticException ，没有详细信息。
      ArithmeticException​(String s)
      构造具有指定详细消息的 ArithmeticException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ArithmeticException

        public ArithmeticException​()
        构造一个 ArithmeticException ，没有详细消息。

      • ArithmeticException

        public ArithmeticException​(String s)
        构造具有指定详细消息的 ArithmeticException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ArrayIndexOutOfBoundsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ArrayIndexOutOfBoundsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IndexOutOfBoundsException
            • java.lang.ArrayIndexOutOfBoundsException
  • All Implemented Interfaces:
    Serializable

    public class ArrayIndexOutOfBoundsException
extends IndexOutOfBoundsException
    抛出以表示使用非法索引访问数组。 索引为负数或大于或等于数组的大小。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ArrayIndexOutOfBoundsException​()
      构造一个 ArrayIndexOutOfBoundsException ，没有详细信息。
      ArrayIndexOutOfBoundsException​(int index)
      构造一个新的 ArrayIndexOutOfBoundsException类，其中包含指示非法索引的参数。
      ArrayIndexOutOfBoundsException​(String s)
      构造具有指定详细消息的 ArrayIndexOutOfBoundsException类。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ArrayIndexOutOfBoundsException

        public ArrayIndexOutOfBoundsException​()
        构造一个 ArrayIndexOutOfBoundsException ，没有详细信息。

      • ArrayIndexOutOfBoundsException

        public ArrayIndexOutOfBoundsException​(String s)
        构造具有指定的详细消息的 ArrayIndexOutOfBoundsException类。
        参数
        s - 详细信息。

      • ArrayIndexOutOfBoundsException

        public ArrayIndexOutOfBoundsException​(int index)
        构造一个新的ArrayIndexOutOfBoundsException类，其中包含指示非法索引的参数。

        该索引包含在此异常的详细消息中。 详细信息的确切显示格式未指定。

        参数
        index - 非法索引。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ArrayStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ArrayStoreException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.ArrayStoreException
  • All Implemented Interfaces:
    Serializable

    public class ArrayStoreException
extends RuntimeException
    抛出以表示尝试将错误类型的对象存储到对象数组中。 例如，以下代码生成一个ArrayStoreException ：
         Object x[] = new String[3];
     x[0] = new Integer(0);
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ArrayStoreException​()
      构造一个 ArrayStoreException ，没有详细消息。
      ArrayStoreException​(String s)
      构造具有指定详细消息的 ArrayStoreException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ArrayStoreException

        public ArrayStoreException​()
        构造一个没有详细消息的 ArrayStoreException 。

      • ArrayStoreException

        public ArrayStoreException​(String s)
        构造具有指定详细消息的 ArrayStoreException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AssertionError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class AssertionError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.AssertionError
  • All Implemented Interfaces:
    Serializable

    public class AssertionError
extends Error
    抛出以表明断言失败。

    此类提供的七个单参数公共构造函数确保调用返回的断言错误：

      new AssertionError(expression)
    具有作为其详细消息表达的字符串的转换 （如在The Java™ Language Specification部15.18.1.1定义），而不管表达的类型。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AssertionError​()
      构造一个没有详细消息的AssertionError。
      AssertionError​(boolean detailMessage)
      构造具有从指定其详细消息派生一个AssertionError boolean ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
      AssertionError​(char detailMessage)
      构造具有从指定其详细消息派生一个AssertionError char ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
      AssertionError​(double detailMessage)
      构造具有从指定其详细消息派生一个AssertionError double ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
      AssertionError​(float detailMessage)
      构造具有从指定其详细消息派生一个AssertionError float ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
      AssertionError​(int detailMessage)
      构造具有从指定其详细消息派生一个AssertionError int ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
      AssertionError​(long detailMessage)
      构造具有从指定其详细消息派生一个AssertionError long ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
      AssertionError​(Object detailMessage)
      构造具有从指定的对象派生其详细消息，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串一个AssertionError。
      AssertionError​(String message, Throwable cause)
      构造一个新的 AssertionError与指定的详细信息和原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AssertionError

        public AssertionError​()
        构造一个没有详细消息的AssertionError。

      • AssertionError

        public AssertionError​(Object detailMessage)
        构造具有从指定的对象派生其详细消息，如在The Java™ Language Specification部15.18.1.1的定义转换为字符串一个AssertionError。

        如果指定的对象是一个实例Throwable ，它成为新构造的断言错误的原因 。

        参数
        detailMessage - 用于构建详细消息的值
        另请参见：
        Throwable.getCause()

      • AssertionError

        public AssertionError​(boolean detailMessage)
        构造具有从指定其详细消息派生一个AssertionError boolean ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
        参数
        detailMessage - 用于构建详细消息的值

      • AssertionError

        public AssertionError​(char detailMessage)
        构造具有从指定其详细消息派生一个AssertionError char ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
        参数
        detailMessage - 用于构建详细消息的值

      • AssertionError

        public AssertionError​(int detailMessage)
        构造具有从指定其详细消息派生一个AssertionError int ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
        参数
        detailMessage - 用于构建详细消息的值

      • AssertionError

        public AssertionError​(long detailMessage)
        构造具有从指定其详细消息派生一个AssertionError long ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
        参数
        detailMessage - 用于构建详细消息的值

      • AssertionError

        public AssertionError​(float detailMessage)
        构造具有从指定其详细消息派生一个AssertionError float ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
        参数
        detailMessage - 用于构建详细消息的值

      • AssertionError

        public AssertionError​(double detailMessage)
        构造具有从指定其详细消息派生一个AssertionError double ，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串。
        参数
        detailMessage - 用于构建详细消息的值

      • AssertionError

        public AssertionError​(String message,
                      Throwable cause)
        构造一个新的AssertionError与指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此错误的详细消息。

        参数
        message - 详细信息，可能是 null
        cause - 原因，可能是 null
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AutoCloseable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface AutoCloseable

  • All Known Subinterfaces:
    AsynchronousByteChannel ， AsynchronousChannel ， BaseStream<T,S> ， ByteChannel ， CachedRowSet ， CallableStatement ， Channel ， Clip ， Closeable ， Connection ， DataLine ， DirectoryStream<T> ， DoubleStream ， ExecutionControl ， FilteredRowSet ， GatheringByteChannel ， ImageInputStream ， ImageOutputStream ， InterruptibleChannel ， IntStream ， JavaFileManager ， JdbcRowSet ， JMXConnector ， JoinRowSet ， Line ， LongStream ， MidiDevice ， MidiDeviceReceiver ， MidiDeviceTransmitter ， Mixer ， ModuleReader ， MulticastChannel ， NetworkChannel ， ObjectInput ， ObjectOutput ， Port ， PreparedStatement ， ReadableByteChannel ， Receiver ， ResultSet ， RMIConnection ， RowSet ， ScatteringByteChannel ， SecureDirectoryStream<T> ， SeekableByteChannel ， Sequencer ， SourceDataLine ， StandardJavaFileManager ， Statement ， Stream<T> ， SyncResolver ， Synthesizer ， TargetDataLine ， Transmitter ， WatchService ， WebRowSet WebRowSet ， WritableByteChannel
    所有已知实现类：
    AbstractInterruptibleChannel ， AbstractSelectableChannel ， AbstractSelector ， AsynchronousFileChannel ， AsynchronousServerSocketChannel ， AsynchronousSocketChannel ， AudioInputStream ， BufferedInputStream ， BufferedOutputStream ， BufferedReader ， BufferedWriter ， ByteArrayInputStream ， ByteArrayOutputStream ， CharArrayReader ， CharArrayWriter ， CheckedInputStream ， CheckedOutputStream ， CipherInputStream ， CipherOutputStream ， DatagramChannel ， DatagramSocket ， DataInputStream ， DataOutputStream ， DeflaterInputStream ， DeflaterOutputStream ， DigestInputStream ， DigestOutputStream ， DirectExecutionControl ， FileCacheImageInputStream ， FileCacheImageOutputStream ， FileChannel ， FileImageInputStream ， FileImageOutputStream ， FileInputStream ， FileLock ， FileOutputStream ， FileReader ， FileSystem ， FileWriter ， FilterInputStream ， FilterOutputStream ， FilterReader ， FilterWriter ， Formatter ， ForwardingJavaFileManager ， GZIPInputStream ， GZIPOutputStream ， ImageInputStreamImpl ， ImageOutputStreamImpl ， InflaterInputStream ， InflaterOutputStream ， InputStream ， InputStream ， InputStream ， InputStreamReader ， JarFile JarFile ， JarInputStream ， JarOutputStream ， JdiDefaultExecutionControl ， JdiExecutionControl ， JShell ， LineNumberInputStream ， LineNumberReader ， LocalExecutionControl ， LogStream ， MemoryCacheImageInputStream ， MemoryCacheImageOutputStream ， MLet ， MulticastSocket ， ObjectInputStream ， ObjectOutputStream ， OutputStream ， OutputStream ， OutputStream ， OutputStreamWriter ， Pipe.SinkChannel ， Pipe.SourceChannel ， PipedInputStream ， PipedOutputStream ， PipedReader ， PipedWriter ， PrintStream ， PrintWriter ， PrivateMLet ， ProgressMonitorInputStream ， PushbackInputStream ， PushbackReader ， RandomAccessFile ， Reader ， RemoteExecutionControl ， RMIConnectionImpl ， RMIConnectionImpl_Stub ， RMIConnector ， RMIIIOPServerImpl ， RMIJRMPServerImpl ， RMIServerImpl ， Scanner ， SctpChannel ， SctpMultiChannel ， SctpServerChannel ， SelectableChannel ， Selector ， SequenceInputStream ， ServerSocket ， ServerSocketChannel ， Socket ， SocketChannel ， SSLServerSocket ， SSLSocket ， StreamingExecutionControl ， StringBufferInputStream ， StringReader StringReader ， StringWriter ， SubmissionPublisher ， URLClassLoader ， URLReader ， Writer ， XMLDecoder ， XMLEncoder ， ZipFile ， ZipInputStream ， ZipOutputStream

    public interface AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。 AutoCloseable对象的close()方法在退出已在资源规范头中声明对象的try资源块时自动调用。 这种结构确保迅速释放，避免资源耗尽异常和可能发生的错误。
    API Note:

    实际上，基类实现自动关闭是可能的，实际上是可行的，尽管不是所有的子类或实例都将保存可释放的资源。 对于必须以完全一般性运行的代码，或者当知道AutoCloseable实例需要资源释放时，建议使用try -with-resources构造。 然而，使用设施，例如当Stream同时支持I / O基和非I / O基的形式， try -with资源块是一般不必要使用非I / O基形式时。

    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void close​()
      关闭此资源，放弃任何基础资源。

    • 方法详细信息

      • close

        void close​()
    throws 异常
        关闭此资源，放弃任何基础资源。 这个方法是在由try -with-resources语句管理的对象上自动调用的。

        虽然这个接口方法被声明为抛出异常 ， 强烈建议实现者声明close方法的具体实现来抛出更多的特定异常，或者如果关闭操作不能失败，则完全不抛出任何异常。

        关闭操作可能失败的情况需要执行人员的注意。 强烈建议放弃基础资源，并将资源内部标记为封闭资源，然后再投出异常。 close方法不太可能被多次调用，因此可以确保资源及时释放。 此外，它减少了当资源包裹或被另一资源包装时可能出现的问题。

        此接口的实施者也强烈建议没有close方法抛出InterruptedException 。 此异常与线程的中断状态相互作用，如果InterruptedException为suppressed，则可能会发生运行时行为不当。 更一般来说，如果这将导致异常被抑制的问题，那么AutoCloseable.close方法不应该抛出异常。

        请注意，与close的方法Closeable ，这close 不需要方法为幂等。 换句话说， close调用这个close方法可能会有一些可见的副作用，不像Closeable.close ，如果多次调用，则不需要任何效果。 然而，强烈建议这个接口的实现者使他们的close方法是幂等的。

        异常
        异常 - 如果此资源无法关闭
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Boolean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Boolean

  • java.lang.Object
    • java.lang.Boolean
  • All Implemented Interfaces:
    Serializable ， Comparable<Boolean>

    public final class Boolean
extends Object
implements Serializable, Comparable<Boolean>
    布尔类包装一个对象中的基元类型boolean的值。 类型为Boolean的对象包含一个单一字段，其类型为boolean 。

    此外，该类还提供了许多将boolean转换为String和String转换为boolean ，以及在处理boolean时有用的其他常数和方法。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Boolean FALSE
      Boolean对象对应于原始值 false 。
      static Boolean TRUE
      Boolean对象对应于原始值 true 。
      static Class<Boolean> TYPE
      表示原始类型的类对象布尔值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Boolean​(boolean value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(boolean)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。 还可以考虑使用最终字段TRUE和FALSE 。
      Boolean​(String s)
      已过时。
      很少使用这个构造函数。 使用parseBoolean(String)将字符串转换为boolean原语，或使用valueOf(String)将字符串转换为Boolean对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean booleanValue​()
      将此 Boolean对象的值作为 Boolean元返回。
      static int compare​(boolean x, boolean y)
      比较两个 boolean值。
      int compareTo​(Boolean b)
      将此 Boolean实例与另一个实例进行比较。
      boolean equals​(Object obj)
      返回 true当且仅当参数不是 null并且是一个 Boolean对象，该对象表示与此对象相同的值时， boolean值为 boolean 。
      static boolean getBoolean​(String name)
      返回 true当且仅当由参数命名的系统属性存在且等于忽略大小写时，字符串为 "true" 。
      int hashCode​()
      返回此 Boolean对象的哈希码。
      static int hashCode​(boolean value)
      返回一个boolean值的哈希码; 兼容Boolean.hashCode() 。
      static boolean logicalAnd​(boolean a, boolean b)
      返回将逻辑AND运算符应用于指定的 boolean操作数的结果。
      static boolean logicalOr​(boolean a, boolean b)
      返回将逻辑OR运算符应用于指定的 boolean操作数的结果。
      static boolean logicalXor​(boolean a, boolean b)
      返回将逻辑XOR运算符应用于指定的 boolean操作数的结果。
      static boolean parseBoolean​(String s)
      将字符串参数解析为布尔值。
      String toString​()
      返回表示此布尔值的一个 String对象。
      static String toString​(boolean b)
      返回表示指定布尔值的 String对象。
      static Boolean valueOf​(boolean b)
      返回表示 boolean值的 Boolean实例。
      static Boolean valueOf​(String s)
      返回一个 Boolean ，其值由指定的字符串表示。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TRUE

        public static final Boolean TRUE
        Boolean对象对应于原始值 true 。

      • FALSE

        public static final Boolean FALSE
        Boolean对象对应于原始值 false 。

      • TYPE

        public static final Class<Boolean> TYPE
        表示原始类型的类对象布尔值。
        从以下版本开始：
        1.1

    • 构造方法详细信息

      • Boolean

        @Deprecated(since="9")
public Boolean​(boolean value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(boolean)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。 还可以考虑使用最终的字段TRUE和FALSE 。
        分配一个表示 value参数的 Boolean对象。
        参数
        value - 的价值 Boolean 。

      • Boolean

        @Deprecated(since="9")
public Boolean​(String s)
        已过时。 很少使用这个构造函数。 使用parseBoolean(String)将字符串转换为boolean原语，或使用valueOf(String)将字符串转换为Boolean对象。
        如果字符串参数不是null并且等于忽略大小写，则分配一个Boolean对象，表示值为true ，表示为字符串"true" 。 否则，分配一个Boolean对象，代表值false 。
        参数
        s - 要转换为 Boolean的字符串。

    • 方法详细信息

      • parseBoolean

        public static boolean parseBoolean​(String s)
        将字符串参数解析为布尔值。 返回的boolean表示值为true如果字符串参数不是null ，并且等于，忽略大小写， "true"字符串"true" 。 否则返回false值，包括空参数。

        示例： Boolean.parseBoolean("True")返回true 。
        示例： Boolean.parseBoolean("yes")返回false 。

        参数
        s - 包含要解析的布尔表示的 String
        结果
        由字符串参数表示的布尔值
        从以下版本开始：
        1.5

      • booleanValue

        public boolean booleanValue​()
        将此 Boolean对象的值作为 Boolean元返回。
        结果
        这个对象的原始值为 boolean 。

      • valueOf

        public static Boolean valueOf​(boolean b)
        返回表示boolean值的Boolean实例。 如果指定的boolean值为true ，此方法返回Boolean.TRUE ; 如果是false ，此方法返回Boolean.FALSE 。 如果不需要新的Boolean实例，则该方法通常应优先于构造函数Boolean(boolean)使用 ，因为该方法可能会产生明显更好的空间和时间性能。
        参数
        b - 一个布尔值。
        结果
        一个 Boolean实例，代表 b 。
        从以下版本开始：
        1.4

      • valueOf

        public static Boolean valueOf​(String s)
        返回一个Boolean ，其值由指定的字符串表示。 如果字符串参数不是null ，并且等于忽略大小写，则返回的Boolean返回的值代表字符串"true" 。 否则返回false值，包括空参数。
        参数
        s - 一个字符串。
        结果
        由字符串表示的 Boolean值。

      • toString

        public static String toString​(boolean b)
        返回表示指定布尔值的String对象。 如果指定的Boolean是true ，那么字符串"true"将被退回，否则该字符串"false"将被退回。
        参数
        b - 要转换的布尔值
        结果
        指定的字符串表示为 boolean
        从以下版本开始：
        1.4

      • toString

        public String toString​()
        返回表示此布尔值的一个String对象。 如果此对象表示值true ，则返回等于"true"的字符串。 否则返回等于"false"的字符串。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式。

      • hashCode

        public int hashCode​()
        返回此 Boolean对象的哈希码。
        重写：
        hashCode在 Object
        结果
        整数1231如果这个对象代表true ; 返回整数1237如果该对象表示false 。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(boolean value)
        返回值为boolean的哈希码; 兼容Boolean.hashCode() 。
        参数
        value - 要进行散列的值
        结果
        一个哈希码值为 boolean值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        返回 true当且仅当参数不是 null ，是 Boolean对象，表示同样 boolean值与此对象。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果布尔对象表示相同的值; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • getBoolean

        public static boolean getBoolean​(String name)
        返回true当且仅当由参数命名的系统属性存在且等于忽略大小写时，字符串为"true" 。 系统属性可通过getProperty ，该方法由System类定义。

        如果没有指定名称的属性，或者指定的名称为空或为空，则返回false 。

        参数
        name - 系统属性名称。
        结果
        系统属性的值为 boolean 。
        异常
        SecurityException - 原因与 System.getProperty相同
        另请参见：
        System.getProperty(java.lang.String) ， System.getProperty(java.lang.String, java.lang.String)

      • compareTo

        public int compareTo​(Boolean b)
        将此 Boolean与另一个实例进行比较。
        Specified by:
        compareTo在接口 Comparable<Boolean>
        参数
        b - 要比较的 Boolean实例
        结果
        如果此对象表示与参数相同的布尔值，则为零; 如果此对象表示true并且该参数表示false，则为正值; 如果此对象表示false并且该参数表示为true，则为负值
        异常
        NullPointerException - 如果参数是 null
        从以下版本开始：
        1.5
        另请参见：
        Comparable

      • compare

        public static int compare​(boolean x,
                          boolean y)
        比较两个boolean值。 返回的值与以下内容相同：
          Boolean.valueOf(x).compareTo(Boolean.valueOf(y))
        参数
        x - 第一个 boolean进行比较
        y - 第二个 boolean进行比较
        结果
        值0如果是x == y ;
一个值小于0如果是!x && y ;
和值大于0如果x && !y
        从以下版本开始：
        1.7

      • logicalAnd

        public static boolean logicalAnd​(boolean a,
                                 boolean b)
        返回将逻辑AND运算符应用于指定的 boolean操作数的结果。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        逻辑AND为 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • logicalOr

        public static boolean logicalOr​(boolean a,
                                boolean b)
        返回将逻辑OR运算符应用于指定的 boolean操作数的结果。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        逻辑OR为 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • logicalXor

        public static boolean logicalXor​(boolean a,
                                 boolean b)
        返回将逻辑XOR运算符应用于指定的 boolean操作数的结果。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        逻辑XOR为 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BootstrapMethodError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class BootstrapMethodError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.BootstrapMethodError
  • All Implemented Interfaces:
    Serializable

    public class BootstrapMethodError
extends LinkageError
    抛出以表示invokedynamic指令未能找到其引导方法，或引导方法未能提供call site的target正确的method type 。
    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BootstrapMethodError​()
      构造一个 BootstrapMethodError ，没有详细信息。
      BootstrapMethodError​(String s)
      构造具有指定详细消息的 BootstrapMethodError 。
      BootstrapMethodError​(String s, Throwable cause)
      构造一个 BootstrapMethodError具有指定的详细信息和原因。
      BootstrapMethodError​(Throwable cause)
      构造具有指定原因的 BootstrapMethodError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BootstrapMethodError

        public BootstrapMethodError​()
        构造一个 BootstrapMethodError ，没有详细信息。

      • BootstrapMethodError

        public BootstrapMethodError​(String s)
        构造具有指定详细消息的 BootstrapMethodError 。
        参数
        s - 详细信息。

      • BootstrapMethodError

        public BootstrapMethodError​(String s,
                            Throwable cause)
        构造一个 BootstrapMethodError具有指定的详细信息和原因。
        参数
        s - 详细信息。
        cause - 原因，可能是 null 。

      • BootstrapMethodError

        public BootstrapMethodError​(Throwable cause)
        构造具有指定原因的 BootstrapMethodError 。
        参数
        cause - 原因，可能是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Byte (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Byte

  • java.lang.Object
    • java.lang.Number
      • java.lang.Byte
  • All Implemented Interfaces:
    Serializable ， Comparable<Byte>

    public final class Byte
extends Number
implements Comparable<Byte>
    Byte类包装一个对象中的原始类型byte的值。 类型为Byte的对象包含单个字段，其类型为byte 。

    此外，该类还提供了多种将byte转换为String和String转换为byte ，以及在处理byte时有用的其他常数和方法。

    从以下版本开始：
    1.1
    另请参见：
    Number ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BYTES
      用于表示二进制补码二进制形式的 byte值的字节数。
      static byte MAX_VALUE
      一个持有最大值一个 byte可以有2 7 -1。
      static byte MIN_VALUE
      的常量保持的最小值的 byte可以具有，-2 7。
      static int SIZE
      用于表示二进制补码二进制形式中的 byte值的位数。
      static Class<Byte> TYPE
      代表原始类型 byte的 Class实例。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Byte​(byte value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(byte)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Byte​(String s)
      已过时。
      很少使用这个构造函数。 使用parseByte(String)将字符串转换为byte原语，或使用valueOf(String)将字符串转换为Byte对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte byteValue​()
      返回 Byte的值作为 byte 。
      static int compare​(byte x, byte y)
      数值比较两个 byte 。
      int compareTo​(Byte anotherByte)
      数字比较两个 Byte对象。
      static int compareUnsigned​(byte x, byte y)
      将两个 byte值进行比较， byte数值方式将值视为无符号。
      static Byte decode​(String nm)
      将 String解码成 Byte 。
      double doubleValue​()
      返回此值 Byte为 double一个宽元转换后。
      boolean equals​(Object obj)
      将此对象与指定的对象进行比较。
      float floatValue​()
      在扩展原始转换后，返回 Byte的值作为 float 。
      int hashCode​()
      返回这个Byte的哈希码; 等于调用intValue()的结果。
      static int hashCode​(byte value)
      返回一个byte值的哈希码; 兼容Byte.hashCode() 。
      int intValue​()
      在扩展原始转换后，返回 Byte的值作为 int 。
      long longValue​()
      返回此值 Byte为 long一个宽元转换后。
      static byte parseByte​(String s)
      解析字符串参数为带符号的二进制 byte 。
      static byte parseByte​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的带符号的 byte 。
      short shortValue​()
      返回此值 Byte为 short一个宽元转换后。
      String toString​()
      返回一个表示 Byte的值的 String对象。
      static String toString​(byte b)
      返回一个新 String表示指定对象 byte 。
      static int toUnsignedInt​(byte x)
      通过无符号转换将参数转换为 int 。
      static long toUnsignedLong​(byte x)
      通过无符号转换将参数转换为 long 。
      static Byte valueOf​(byte b)
      返回表示 byte值的 Byte实例。
      static Byte valueOf​(String s)
      返回一个 Byte对象，保存由指定的 String给出的值。
      static Byte valueOf​(String s, int radix)
      返回一个 Byte对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN_VALUE

        public static final byte MIN_VALUE
        一个常数保持最小值a byte可以有-2 -7 。
        另请参见：
        Constant Field Values

      • MAX_VALUE

        public static final byte MAX_VALUE
        一个持有最大值一个 byte可以有2 7 -1。
        另请参见：
        Constant Field Values

      • TYPE

        public static final Class<Byte> TYPE
        Class实例代表原始类型 byte 。

      • SIZE

        public static final int SIZE
        用于表示二进制补码二进制形式的 byte值的位数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • BYTES

        public static final int BYTES
        用于表示二进制补码二进制形式的 byte值的字节数。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Byte

        @Deprecated(since="9")
public Byte​(byte value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(byte)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
        构造新分配的 Byte对象，该对象表示指定的 byte值。
        参数
        value - 要由 Byte表示的值。

      • Byte

        @Deprecated(since="9")
public Byte​(String s)
     throws NumberFormatException
        已过时。 很少使用这个构造函数。 使用parseByte(String)将字符串转换为byte原语，或使用valueOf(String)将字符串转换为Byte对象。
        构造一个新分配的Byte对象，表示由String参数指示的byte值。 字符串转换为byte值，正好与基数为parseByte方法一样。
        参数
        s -的 String转换为一个 Byte
        异常
        NumberFormatException - 如果 String不包含可解析的 byte 。

    • 方法详细信息

      • toString

        public static String toString​(byte b)
        返回一个新的String对象，代表指定的byte 。 基数假定为10。
        参数
        b - 要转换的 byte
        结果
        指定的字符串表示形式为 byte
        另请参见：
        Integer.toString(int)

      • valueOf

        public static Byte valueOf​(byte b)
        返回表示byte值的Byte实例。 如果不需要新的Byte实例，则该方法通常优先于构造函数Byte(byte)使用 ，因为所有字节值都被缓存，因此该方法可能会产生明显更好的空间和时间性能。
        参数
        b - 一个字节值。
        结果
        一个 Byte实例，代表 b 。
        从以下版本开始：
        1.5

      • parseByte

        public static byte parseByte​(String s,
                             int radix)
                      throws NumberFormatException
        将字符串参数解析为第二个参数指定的基数中的带符号的byte 。 字符串中的字符必须全部是指定基数的数字（由Character.digit(char, int)是否返回非负值确定），除了第一个字符可能是ASCII减号'-' （ '\u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）以表示正值。 返回产生的byte值。

        如果发生以下任何一种情况，则抛出类型为NumberFormatException的异常：

        • 第一个参数是null或是长度为零的字符串。
        • 基数小于Character.MIN_RADIX或大于Character.MAX_RADIX 。
        • 字符串的任何字符不是指定基数的数字，除了第一个字符可能是负号'-' （ '\u002D' ）或加号'+' （ '\u002B' ），前提是字符串长于长度1。
        • 由字符串表示的值不是byte类型的值。
        参数
        s -所述 String含有 byte表示被解析
        radix - 解析时使用的基数 s
        结果
        byte值由指定基数中的字符串参数表示
        异常
        NumberFormatException - 如果字符串不包含可解析的 byte 。

      • parseByte

        public static byte parseByte​(String s)
                      throws NumberFormatException
        解析字符串参数为带符号的二进制byte 。 字符串中的字符都必须是十进制数字，除了第一个字符可能是ASCII减号'-' （ '\u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）表示正值。 返回的结果为byte ，就像参数和小数 10作为parseByte(java.lang.String, int)方法的参数一样 。
        参数
        s - 一个 String其中包含要解析的 byte表示
        结果
        byte值由参数以十进制表示
        异常
        NumberFormatException - 如果字符串不包含可解析的 byte 。

      • valueOf

        public static Byte valueOf​(String s,
                           int radix)
                    throws NumberFormatException
        返回一个Byte对象，该对象保存从指定的String提取的值，并使用第二个参数给出的基数进行解析。 第一个参数被解释为表示由第二个参数指定的基数中的带符号的byte ，就像该参数被赋予parseByte(java.lang.String, int)方法一样。 结果是一个Byte对象，表示由字符串指定的byte值。

        换句话说，该方法返回一个Byte对象的值等于：

        new Byte(Byte.parseByte(s, radix))
        参数
        s - 要解析的字符串
        radix - 用于解释的基数 s
        结果
        一个 Byte对象，其持有由指定基数中的字符串参数表示的值。
        异常
        NumberFormatException - 如果 String不包含可解析的 byte 。

      • valueOf

        public static Byte valueOf​(String s)
                    throws NumberFormatException
        返回一个Byte对象，保存由指定的String给出的值。 该参数被解释为表示一个有符号的二进制byte ，完全一样，这个参数被赋予了parseByte(java.lang.String)方法。 结果是一个Byte对象，表示由字符串指定的byte值。

        换句话说，此方法返回一个Byte对象的值等于：

        new Byte(Byte.parseByte(s))
        参数
        s - 要解析的字符串
        结果
        一个 Byte对象，保存由string参数表示的值
        异常
        NumberFormatException - 如果 String不包含可解析的 byte 。

      • decode

        public static Byte decode​(String nm)
                   throws NumberFormatException
        将String解码为Byte 。 接受以下语法给出的十进制，十六进制和八进制数：
        DecodableString:
        Signopt DecimalNumeral
        Signopt 0x HexDigits
        Signopt 0X HexDigits
        Signopt # HexDigits
        Signopt 0 OctalDigits
        Sign:
        -
        +
        DecimalNumeral，HexDigits，和OctalDigits如在The Java™ Language Specification 3.10.1部分所定义，所不同的是下划线不数字之间接受。

        可选符号和/或基数说明符（“ 0x ”，“ 0X ”，“ # ”或前导零）之后的Byte.parseByte由具有指示的基数（10,16或8）的Byte.parseByte方法进行解析。 这个字符序列必须表示一个正值，或者会抛出一个NumberFormatException 。 如果指定的String第一个字符为负号，则结果为否定。 在String中不允许使用空格字符。

        参数
        nm - String进行解码。
        结果
        一个 Byte对象持有 byte值代表 nm
        异常
        NumberFormatException - 如果 String不包含可解析的 byte 。
        另请参见：
        parseByte(java.lang.String, int)

      • byteValue

        public byte byteValue​()
        返回 Byte的值作为 byte 。
        重写：
        byteValue在 Number
        结果
        该对象在转换为 byte之后表示的数值。

      • shortValue

        public short shortValue​()
        返回此值 Byte为 short一个宽元转换后。
        重写：
        shortValue在 Number
        结果
        该对象在转换为 short之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • intValue

        public int intValue​()
        在扩展原始转换后，返回 Byte的值作为 int 。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • longValue

        public long longValue​()
        在扩展原始转换后，返回 Byte的值作为 long 。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • floatValue

        public float floatValue​()
        返回此值 Byte为 float一个宽元转换后。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • doubleValue

        public double doubleValue​()
        返回此值 Byte为 double一个宽元转换后。
        Specified by:
        doubleValue在 Number
        结果
        该对象在转换为 double之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • toString

        public String toString​()
        返回表示该Byte值的String对象。 该值将转换为带符号的十进制表示形式，并作为字符串返回，就像byte值作为toString(byte)方法的参数一样 。
        重写：
        toString在 Object
        结果
        这个对象在基数10中的值的字符串表示。

      • hashCode

        public int hashCode​()
        返回这个Byte的哈希码; 等于调用intValue()的结果。
        重写：
        hashCode在类 Object
        结果
        一个哈希码值为这个 Byte
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(byte value)
        返回一个byte值的哈希码; 兼容Byte.hashCode() 。
        参数
        value - 哈希值
        结果
        一个 byte值的哈希码值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        将此对象与指定的对象进行比较。 结果是true当且仅当该参数不是null并且是一个Byte对象，其中包含与该对象相同的byte值。
        重写：
        equals在类 Object
        参数
        obj - 与之比较的对象
        结果
        true如果对象是一样的; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(Byte anotherByte)
        数值比较两个 Byte对象。
        Specified by:
        compareTo在接口 Comparable<Byte>
        参数
        anotherByte - 要比较的 Byte 。
        结果
        值0如果这个Byte等于参数Byte ; 小于0的值，如果这个Byte数值小于参数Byte ; 和大于一个值0 ，如果这Byte在数值上大于该参数Byte （带符号的比较）。
        从以下版本开始：
        1.2

      • compare

        public static int compare​(byte x,
                          byte y)
        数值比较两个byte数值。 返回的值与以下内容相同：
          Byte.valueOf(x).compareTo(Byte.valueOf(y))
        参数
        x - 第一个 byte进行比较
        y - 第二个 byte进行比较
        结果
        值0如果是x == y ; 一个值小于0如果是x < y ; 和值大于0如果x > y
        从以下版本开始：
        1.7

      • compareUnsigned

        public static int compareUnsigned​(byte x,
                                  byte y)
        比较两个 byte值，以数值方式将值视为无符号。
        参数
        x - 第一个 byte进行比较
        y - 第二个 byte进行比较
        结果
        值0如果是x == y ; 如果x < y为无符号值，则小于0 ; 并且如果x > y为无符号值，则值大于0
        从以下版本开始：
        9

      • toUnsignedInt

        public static int toUnsignedInt​(byte x)
        通过无符号转换将参数转换为int 。 在无符号转换为一个int ，所述的高阶24位int是零和低位8位都等于的比特byte参数。 因此，零和正值byte值被映射到数字上相等的int值，而负byte值被映射到等于输入加上2 8的int值。
        参数
        x - 转换为无符号 int的值
        结果
        该参数通过无符号转换转换为 int
        从以下版本开始：
        1.8

      • toUnsignedLong

        public static long toUnsignedLong​(byte x)
        通过无符号转换将参数转换为long 。 在一个无符号转换为long ，所述的高阶56位long是零和低位8位都等于的比特byte参数。 因此，零和正值byte值被映射到数字上相等的long值，负byte值被映射到等于输入加上2 8的long值。
        参数
        x - 转换为无符号 long的值
        结果
        该参数通过无符号转换转换为 long
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Character (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Character

  • java.lang.Object
    • java.lang.Character
  • All Implemented Interfaces:
    Serializable ， Comparable<Character>

    public final class Character
extends Object
implements Serializable, Comparable<Character>
    Character类包装一个对象中的原始类型char的值。 类型为Character的对象包含一个单一字段，其类型为char 。

    此外，该类还提供了几种方法来确定字符的类别（小写字母，数字等），并将字符从大写转换为小写，反之亦然。

    字符信息基于Unicode标准版本8.0.0。

    的方法和类的数据Character通过在UnicodeData文件的是由Unicode Consortium维护的Unicode字符数据库的一部分的信息来定义。 该文件为每个定义的Unicode代码点或字符范围指定各种属性，包括名称和常规类别。

    该文件及其描述可从Unicode Consortium获得：

    • http://www.unicode.org

    Unicode Character Representations

    char数据类型（因此Character对象封装的值）基于原始Unicode规范，其将字符定义为固定宽度的16位实体。 Unicode标准已经被更改为允许其表示需要超过16位的字符。 法定代码点的范围现在是U + 0000到U + 10FFFF，称为Unicode标量值 。 （请参阅Unicode标准中U + n符号的 definition。 ）

    The set of characters from U+0000 to U+FFFF有时被称为基本多语言平面（BMP） 。 其代码点大于U + FFFF的Characters称为补充字符 s。 Java平台在char阵列和String和StringBuffer类中使用UTF-16表示形式。 在该表示中，补充字符表示为char值，第一个来自高替代范围（\ uD800- \ uDBFF），第二个来自低代理范围（\ uDC00- \ uDFFF）。

    因此，值char表示基本多语言平面（BMP）代码点，包括代码代码点或UTF-16编码的代码单元。 一个int值代表所有Unicode代码点，包括补充代码点。 int的较低（最低有效）21位用于表示Unicode码点，而高（最高有效）11位必须为零。 除非另有说明，关于补充字符和char值的行为如下：

    • 仅接受char值的方法不能支持补充字符。 他们将char值从代理范围视为未定义的字符。 例如， Character.isLetter('\uD840')返回false ，即使这个特定值如果后面是字符串中的任何低代理值都将代表一个字母。
    • 接受int值的方法支持所有Unicode字符，包括补充字符。 例如， Character.isLetter(0x2F81A)返回true因为代码点值代表一个字母（CJK表意文字）。

    在Java SE API文档中， Unicode代码点用于U + 0000和U + 10FFFF之间范围内的字符值， Unicode代码单元用于作为UTF-16编码的代码单位的16位char值。 有关Unicode术语的更多信息，请参阅Unicode Glossary 。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Character.Subset
      该类的实例表示Unicode字符集的特定子集。
      static class  Character.UnicodeBlock
      一系列字符子集，表示Unicode规范中的字符块。
      static class  Character.UnicodeScript
      一组字符子集，表示 Unicode Standard Annex #24: Script Names中定义的字符脚本。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BYTES
      用于以无符号二进制形式表示 char值的字节数。
      static byte COMBINING_SPACING_MARK
      Unicode规范中的一般类别“Mc”。
      static byte CONNECTOR_PUNCTUATION
      Unicode规范中的通用类别“Pc”。
      static byte CONTROL
      Unicode规范中的一般类别“Cc”。
      static byte CURRENCY_SYMBOL
      Unicode规范中的一般类别“Sc”。
      static byte DASH_PUNCTUATION
      Unicode规范中的一般类别“Pd”。
      static byte DECIMAL_DIGIT_NUMBER
      Unicode规范中的一般类别“Nd”。
      static byte DIRECTIONALITY_ARABIC_NUMBER
      Unicode规范中的弱双向字符类型“AN”。
      static byte DIRECTIONALITY_BOUNDARY_NEUTRAL
      Unicode规范中的双向字符类型“BN”弱。
      static byte DIRECTIONALITY_COMMON_NUMBER_SEPARATOR
      Unicode规范中的双向字符类型“CS”弱。
      static byte DIRECTIONALITY_EUROPEAN_NUMBER
      Unicode规范中的弱双向字符类型“EN”。
      static byte DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR
      Unicode规范中的双向字符类型为“ES”较弱。
      static byte DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR
      Unicode规范中的双向字符类型“ET”较弱。
      static byte DIRECTIONALITY_FIRST_STRONG_ISOLATE
      Unicode规范中的弱双向字符类型“FSI”。
      static byte DIRECTIONALITY_LEFT_TO_RIGHT
      Unicode规范中的强双向字符类型“L”。
      static byte DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING
      Unicode规范中的强双向字符类型“LRE”。
      static byte DIRECTIONALITY_LEFT_TO_RIGHT_ISOLATE
      Unicode规范中的双向字符类型“LRI”弱。
      static byte DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE
      Unicode规范中的强双向字符类型“LRO”。
      static byte DIRECTIONALITY_NONSPACING_MARK
      Unicode规范中的弱双向字符类型“NSM”。
      static byte DIRECTIONALITY_OTHER_NEUTRALS
      Unicode规范中的中立双向字符类型“ON”。
      static byte DIRECTIONALITY_PARAGRAPH_SEPARATOR
      Unicode规范中的中立双向字符类型“B”。
      static byte DIRECTIONALITY_POP_DIRECTIONAL_FORMAT
      Unicode规范中的双向字符类型为“PDF”。
      static byte DIRECTIONALITY_POP_DIRECTIONAL_ISOLATE
      Unicode规范中的双向字符类型为“PDI”。
      static byte DIRECTIONALITY_RIGHT_TO_LEFT
      Unicode规范中的强双向字符类型“R”。
      static byte DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC
      Unicode规范中的强双向字符类型“AL”。
      static byte DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING
      Unicode规范中的强双向字符类型“RLE”。
      static byte DIRECTIONALITY_RIGHT_TO_LEFT_ISOLATE
      Unicode规范中的弱双向字符类型“RLI”。
      static byte DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE
      Unicode规范中的强双向字符类型“RLO”。
      static byte DIRECTIONALITY_SEGMENT_SEPARATOR
      Unicode规范中的中立双向字符类型“S”。
      static byte DIRECTIONALITY_UNDEFINED
      未定义的双向字符类型。
      static byte DIRECTIONALITY_WHITESPACE
      Unicode规范中的中立双向字符类型“WS”。
      static byte ENCLOSING_MARK
      Unicode规范中的一般类别“Me”。
      static byte END_PUNCTUATION
      Unicode规范中的一般类别“Pe”。
      static byte FINAL_QUOTE_PUNCTUATION
      Unicode规范中的一般类别“Pf”。
      static byte FORMAT
      Unicode规范中的一般类别“Cf”。
      static byte INITIAL_QUOTE_PUNCTUATION
      Unicode规范中的一般类别“Pi”。
      static byte LETTER_NUMBER
      Unicode规范中的一般类别“Nl”。
      static byte LINE_SEPARATOR
      Unicode规范中的一般类别“Zl”。
      static byte LOWERCASE_LETTER
      Unicode规范中的一般类别“L1”。
      static byte MATH_SYMBOL
      Unicode规范中的通用类别“Sm”。
      static int MAX_CODE_POINT
      最大值为 Unicode code point ，常数为 U+10FFFF 。
      static char MAX_HIGH_SURROGATE
      最大值为 Unicode high-surrogate code unit ，在UTF-16编码中，常数为 '\uDBFF' 。
      static char MAX_LOW_SURROGATE
      一个 Unicode low-surrogate code unit的最大值在UTF-16编码中，常数为 '\uDFFF' 。
      static int MAX_RADIX
      用于转换到字符串和从字符串转换的最大基数。
      static char MAX_SURROGATE
      UTF-16编码中的Unicode代理代码单元的最大值，常数为 '\uDFFF' 。
      static char MAX_VALUE
      该字段的常数值是 char '\uFFFF' 。
      static int MIN_CODE_POINT
      最小值为 Unicode code point ，常数为 U+0000 。
      static char MIN_HIGH_SURROGATE
      一个 Unicode high-surrogate code unit的最小值在UTF-16编码中，常数为 '\uD800' 。
      static char MIN_LOW_SURROGATE
      一个 Unicode low-surrogate code unit的最小值在UTF-16编码中，常数为 '\uDC00' 。
      static int MIN_RADIX
      可用于转换到字符串和从字符串转换的最小基数。
      static int MIN_SUPPLEMENTARY_CODE_POINT
      最小值为 Unicode supplementary code point ，常数为 U+10000 。
      static char MIN_SURROGATE
      UTF-16编码中的Unicode代理代码单元的最小值，常数为 '\uD800' 。
      static char MIN_VALUE
      该字段的常量值是 char '\u0000' 。
      static byte MODIFIER_LETTER
      Unicode规范中的一般类别“Lm”。
      static byte MODIFIER_SYMBOL
      Unicode规范中的一般类别“Sk”。
      static byte NON_SPACING_MARK
      Unicode规范中的一般类别“Mn”。
      static byte OTHER_LETTER
      Unicode规范中的一般类别“Lo”。
      static byte OTHER_NUMBER
      Unicode规范中的常规类别“否”。
      static byte OTHER_PUNCTUATION
      Unicode规范中的一般类别“Po”。
      static byte OTHER_SYMBOL
      Unicode规范中的一般类别“So”。
      static byte PARAGRAPH_SEPARATOR
      Unicode规范中的一般类别“Zp”。
      static byte PRIVATE_USE
      Unicode规范中的一般类别“Co”。
      static int SIZE
      用于以无符号二进制形式表示 char值的位数，常数为 16 。
      static byte SPACE_SEPARATOR
      Unicode规范中的一般类别“Zs”。
      static byte START_PUNCTUATION
      Unicode规范中的一般类别“Ps”。
      static byte SURROGATE
      Unicode规范中的常规类别“Cs”。
      static byte TITLECASE_LETTER
      Unicode规范中的常规类别“Lt”。
      static Class<Character> TYPE
      Class实例代表原始类型 char 。
      static byte UNASSIGNED
      Unicode规范中的一般类别“Cn”。
      static byte UPPERCASE_LETTER
      Unicode规范中的一般类别“Lu”。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Character​(char value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(char)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static int charCount​(int codePoint)
      确定表示指定字符（Unicode代码点）所需的 char值。
      char charValue​()
      返回此 Character对象的值。
      static int codePointAt​(char[] a, int index)
      返回 char数组的给定索引处的代码点。
      static int codePointAt​(char[] a, int index, int limit)
      返回 char数组的给定索引处的代码点，其中只能使用 index小于 limit数组元素。
      static int codePointAt​(CharSequence seq, int index)
      返回 CharSequence给定索引处的代码点。
      static int codePointBefore​(char[] a, int index)
      返回 char数组的给定索引之前的代码点。
      static int codePointBefore​(char[] a, int index, int start)
      返回 char数组的给定索引之前的代码点，其中只能使用 index大于或等于 start数组元素。
      static int codePointBefore​(CharSequence seq, int index)
      返回 CharSequence给定索引之前的代码点。
      static int codePointCount​(char[] a, int offset, int count)
      返回 char数组参数的子阵列中的Unicode代码点数。
      static int codePointCount​(CharSequence seq, int beginIndex, int endIndex)
      返回指定字符序列的文本范围内的Unicode代码点数。
      static int codePointOf​(String name)
      返回由给定的Unicode字符名称指定的Unicode字符的代码点值。
      static int compare​(char x, char y)
      数值比较两个 char数值。
      int compareTo​(Character anotherCharacter)
      数字比较两个 Character对象。
      static int digit​(char ch, int radix)
      返回指定基数中的字符 ch的数值。
      static int digit​(int codePoint, int radix)
      返回指定基数中指定字符（Unicode代码点）的数值。
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      static char forDigit​(int digit, int radix)
      确定指定基数中特定数字的字符表示。
      static byte getDirectionality​(char ch)
      返回给定字符的Unicode方向属性。
      static byte getDirectionality​(int codePoint)
      返回给定字符的Unicode方向性属性（Unicode代码点）。
      static String getName​(int codePoint)
      返回指定字符 codePoint的Unicode名称，如果代码点为 unassigned ，则返回null。
      static int getNumericValue​(char ch)
      返回指定的Unicode字符表示的值为 int 。
      static int getNumericValue​(int codePoint)
      返回指定字符（Unicode代码点）表示的值为 int 。
      static int getType​(char ch)
      返回一个值，表示一个字符的一般类别。
      static int getType​(int codePoint)
      返回一个值，表示一个字符的一般类别。
      int hashCode​()
      返回此Character的哈希码; 等于调用charValue()的结果。
      static int hashCode​(char value)
      返回一个char值的哈希码; 兼容Character.hashCode() 。
      static char highSurrogate​(int codePoint)
      返回表示UTF-16编码中指定的补充字符（Unicode代码点）的 surrogate pair的 首字母代理（ high surrogate code unit ）。
      static boolean isAlphabetic​(int codePoint)
      确定指定的字符（Unicode代码点）是否是字母表。
      static boolean isBmpCodePoint​(int codePoint)
      确定指定字符（Unicode代码点）是否在 Basic Multilingual Plane (BMP)中 。
      static boolean isDefined​(char ch)
      确定字符是否以Unicode定义。
      static boolean isDefined​(int codePoint)
      确定Unicode中是否定义了一个字符（Unicode代码点）。
      static boolean isDigit​(char ch)
      确定指定的字符是否是数字。
      static boolean isDigit​(int codePoint)
      确定指定的字符（Unicode代码点）是否为数字。
      static boolean isHighSurrogate​(char ch)
      确定给定的 char值是否为 Unicode high-surrogate code unit （也称为 引导代理单元 ）。
      static boolean isIdentifierIgnorable​(char ch)
      确定指定的字符是否应被视为Java标识符或Unicode标识符中的可忽略字符。
      static boolean isIdentifierIgnorable​(int codePoint)
      确定指定字符（Unicode代码点）是否应被视为Java标识符或Unicode标识符中的可忽略字符。
      static boolean isIdeographic​(int codePoint)
      确定指定字符（Unicode代码点）是否是Unicode标准定义的CJKV（中文，日文，韩文和越南文）表意文字。
      static boolean isISOControl​(char ch)
      确定指定的字符是否是ISO控制字符。
      static boolean isISOControl​(int codePoint)
      确定引用的字符（Unicode代码点）是否是ISO控制字符。
      static boolean isJavaIdentifierPart​(char ch)
      确定指定的字符是否可以是Java标识符的一部分，而不是第一个字符。
      static boolean isJavaIdentifierPart​(int codePoint)
      确定字符（Unicode代码点）可能是Java标识符的一部分，而不是第一个字符。
      static boolean isJavaIdentifierStart​(char ch)
      确定指定字符是否允许作为Java标识符中的第一个字符。
      static boolean isJavaIdentifierStart​(int codePoint)
      确定字符（Unicode代码点）是否允许作为Java标识符中的第一个字符。
      static boolean isJavaLetter​(char ch)
      已过时。
      替换为isJavaIdentifierStart（char）。
      static boolean isJavaLetterOrDigit​(char ch)
      已过时。
      由isJavaIdentifierPart（char）替代。
      static boolean isLetter​(char ch)
      确定指定的字符是否是一个字母。
      static boolean isLetter​(int codePoint)
      确定指定的字符（Unicode代码点）是否是一个字母。
      static boolean isLetterOrDigit​(char ch)
      确定指定的字符是字母还是数字。
      static boolean isLetterOrDigit​(int codePoint)
      确定指定的字符（Unicode代码点）是字母还是数字。
      static boolean isLowerCase​(char ch)
      确定指定的字符是否是小写字符。
      static boolean isLowerCase​(int codePoint)
      确定指定的字符（Unicode代码点）是否是小写字符。
      static boolean isLowSurrogate​(char ch)
      确定给定的 char值是否为 Unicode low-surrogate code unit （也称为 尾随代理单元 ）。
      static boolean isMirrored​(char ch)
      根据Unicode规范确定字符是否镜像。
      static boolean isMirrored​(int codePoint)
      确定是否根据Unicode规范镜像指定的字符（Unicode代码点）。
      static boolean isSpace​(char ch)
      已过时。
      替换为isWhitespace（char）。
      static boolean isSpaceChar​(char ch)
      确定指定的字符是否是Unicode空格字符。
      static boolean isSpaceChar​(int codePoint)
      确定指定字符（Unicode代码点）是否为Unicode空格字符。
      static boolean isSupplementaryCodePoint​(int codePoint)
      确定指定字符（Unicode代码点）是否在 supplementary character范围内。
      static boolean isSurrogate​(char ch)
      确定给定的 char值是否是Unicode 代理代码单元 。
      static boolean isSurrogatePair​(char high, char low)
      确定指定的一对 char值是否为有效的 Unicode surrogate pair 。
      static boolean isTitleCase​(char ch)
      确定指定的字符是否是一个titlecase字符。
      static boolean isTitleCase​(int codePoint)
      确定指定的字符（Unicode代码点）是否是一个titlecase字符。
      static boolean isUnicodeIdentifierPart​(char ch)
      确定指定的字符是否可以是Unicode标识符的一部分，而不是第一个字符。
      static boolean isUnicodeIdentifierPart​(int codePoint)
      确定指定的字符（Unicode代码点）是否可能是Unicode标识符的一部分，而不是第一个字符。
      static boolean isUnicodeIdentifierStart​(char ch)
      确定指定字符是否允许为Unicode标识符中的第一个字符。
      static boolean isUnicodeIdentifierStart​(int codePoint)
      确定Unicode标识符中的第一个字符是否允许指定的字符（Unicode代码点）。
      static boolean isUpperCase​(char ch)
      确定指定的字符是否为大写字符。
      static boolean isUpperCase​(int codePoint)
      确定指定的字符（Unicode代码点）是否为大写字符。
      static boolean isValidCodePoint​(int codePoint)
      确定指定的代码点是否有效 Unicode code point value 。
      static boolean isWhitespace​(char ch)
      根据Java确定指定的字符是否为空格。
      static boolean isWhitespace​(int codePoint)
      根据Java确定指定字符（Unicode代码点）是否为空格。
      static char lowSurrogate​(int codePoint)
      返回表示UTF-16编码中指定的补充字符（Unicode代码点）的 surrogate pair的 后续代理（ low surrogate code unit ）。
      static int offsetByCodePoints​(char[] a, int start, int count, int index, int codePointOffset)
      返回给定的 char子阵列中与 index由 codePointOffset代码点偏移的索引。
      static int offsetByCodePoints​(CharSequence seq, int index, int codePointOffset)
      返回给定的char序列中与 index由 codePointOffset代码点偏移的索引。
      static char reverseBytes​(char ch)
      返回通过反转指定的 char值中的字节顺序获得的值。
      static char[] toChars​(int codePoint)
      将指定的字符（Unicode代码点）转换为存储在 char数组中的UTF-16表示形式。
      static int toChars​(int codePoint, char[] dst, int dstIndex)
      将指定的字符（Unicode代码点）转换为其UTF-16表示形式。
      static int toCodePoint​(char high, char low)
      将指定的代理对转换为其补充代码点值。
      static char toLowerCase​(char ch)
      使用UnicodeData文件中的大小写映射信息将字符参数转换为小写。
      static int toLowerCase​(int codePoint)
      使用UnicodeData文件中的大小写映射信息将字符（Unicode代码点）参数转换为小写。
      String toString​()
      返回一个表示 Character的值的 String对象。
      static String toString​(char c)
      返回 String表示指定对象 char 。
      static char toTitleCase​(char ch)
      使用UnicodeData文件中的案例映射信息将字符参数转换为titlecase。
      static int toTitleCase​(int codePoint)
      使用UnicodeData文件中的案例映射信息将字符（Unicode代码点）参数转换为titlecase。
      static char toUpperCase​(char ch)
      使用UnicodeData文件中的案例映射信息将字符参数转换为大写。
      static int toUpperCase​(int codePoint)
      使用UnicodeData文件中的案例映射信息将字符（Unicode代码点）参数转换为大写。
      static Character valueOf​(char c)
      返回表示 char值的 Character实例。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN_RADIX

        public static final int MIN_RADIX
        可用于转换到字符串和从字符串转换的最小基数。 该字段的常数值是基数转换方法中的基数参数允许的最小值，如digit方法， forDigit方法和toString类别Integer的toString方法。
        另请参见：
        digit(char, int) ，
forDigit(int, int) ，
Integer.toString(int, int) ，
Integer.valueOf(String) ，
Constant Field Values

      • MAX_RADIX

        public static final int MAX_RADIX
        用于转换到字符串和从字符串转换的最大基数。 该字段的常数值是基数转换方法中的基数参数允许的digit ，如digit方法， forDigit方法和toString类别Integer的toString方法。
        另请参见：
        digit(char, int) ，
forDigit(int, int) ，
Integer.toString(int, int) ，
Integer.valueOf(String) ，
Constant Field Values

      • MIN_VALUE

        public static final char MIN_VALUE
        该字段的常量值是 char '\u0000' 。
        从以下版本开始：
        1.0.2
        另请参见：
        Constant Field Values

      • MAX_VALUE

        public static final char MAX_VALUE
        该字段的常数值是 char '\uFFFF' 。
        从以下版本开始：
        1.0.2
        另请参见：
        Constant Field Values

      • TYPE

        public static final Class<Character> TYPE
        Class表示原始类型 char实例。
        从以下版本开始：
        1.1

      • UNASSIGNED

        public static final byte UNASSIGNED
        Unicode规范中的一般类别“Cn”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • UPPERCASE_LETTER

        public static final byte UPPERCASE_LETTER
        Unicode规范中的一般类别“Lu”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • LOWERCASE_LETTER

        public static final byte LOWERCASE_LETTER
        Unicode规范中的一般类别“L1”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • TITLECASE_LETTER

        public static final byte TITLECASE_LETTER
        Unicode规范中的常规类别“Lt”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • MODIFIER_LETTER

        public static final byte MODIFIER_LETTER
        Unicode规范中的一般类别“Lm”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • OTHER_LETTER

        public static final byte OTHER_LETTER
        Unicode规范中的一般类别“Lo”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • NON_SPACING_MARK

        public static final byte NON_SPACING_MARK
        Unicode规范中的一般类别“Mn”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • ENCLOSING_MARK

        public static final byte ENCLOSING_MARK
        Unicode规范中的一般类别“Me”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • COMBINING_SPACING_MARK

        public static final byte COMBINING_SPACING_MARK
        Unicode规范中的一般类别“Mc”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • DECIMAL_DIGIT_NUMBER

        public static final byte DECIMAL_DIGIT_NUMBER
        Unicode规范中的一般类别“Nd”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • LETTER_NUMBER

        public static final byte LETTER_NUMBER
        Unicode规范中的一般类别“Nl”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • OTHER_NUMBER

        public static final byte OTHER_NUMBER
        Unicode规范中的常规类别“否”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SPACE_SEPARATOR

        public static final byte SPACE_SEPARATOR
        Unicode规范中的一般类别“Zs”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • LINE_SEPARATOR

        public static final byte LINE_SEPARATOR
        Unicode规范中的一般类别“Zl”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • PARAGRAPH_SEPARATOR

        public static final byte PARAGRAPH_SEPARATOR
        Unicode规范中的一般类别“Zp”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • CONTROL

        public static final byte CONTROL
        Unicode规范中的一般类别“Cc”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • FORMAT

        public static final byte FORMAT
        Unicode规范中的一般类别“Cf”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • PRIVATE_USE

        public static final byte PRIVATE_USE
        Unicode规范中的一般类别“Co”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • SURROGATE

        public static final byte SURROGATE
        Unicode规范中的常规类别“Cs”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • DASH_PUNCTUATION

        public static final byte DASH_PUNCTUATION
        Unicode规范中的一般类别“Pd”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • START_PUNCTUATION

        public static final byte START_PUNCTUATION
        Unicode规范中的一般类别“Ps”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • END_PUNCTUATION

        public static final byte END_PUNCTUATION
        Unicode规范中的一般类别“Pe”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • CONNECTOR_PUNCTUATION

        public static final byte CONNECTOR_PUNCTUATION
        Unicode规范中的通用类别“Pc”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • OTHER_PUNCTUATION

        public static final byte OTHER_PUNCTUATION
        Unicode规范中的一般类别“Po”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • MATH_SYMBOL

        public static final byte MATH_SYMBOL
        Unicode规范中的通用类别“Sm”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • CURRENCY_SYMBOL

        public static final byte CURRENCY_SYMBOL
        Unicode规范中的一般类别“Sc”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • MODIFIER_SYMBOL

        public static final byte MODIFIER_SYMBOL
        Unicode规范中的一般类别“Sk”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • OTHER_SYMBOL

        public static final byte OTHER_SYMBOL
        Unicode规范中的一般类别“So”。
        从以下版本开始：
        1.1
        另请参见：
        Constant Field Values

      • INITIAL_QUOTE_PUNCTUATION

        public static final byte INITIAL_QUOTE_PUNCTUATION
        Unicode规范中的一般类别“Pi”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • FINAL_QUOTE_PUNCTUATION

        public static final byte FINAL_QUOTE_PUNCTUATION
        Unicode规范中的一般类别“Pf”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_UNDEFINED

        public static final byte DIRECTIONALITY_UNDEFINED
        未定义的双向字符类型。 未定义的char值在Unicode规范中具有未定义的方向性。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_LEFT_TO_RIGHT

        public static final byte DIRECTIONALITY_LEFT_TO_RIGHT
        Unicode规范中的强双向字符类型“L”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_RIGHT_TO_LEFT

        public static final byte DIRECTIONALITY_RIGHT_TO_LEFT
        Unicode规范中的强双向字符类型“R”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC

        public static final byte DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC
        Unicode规范中的强双向字符类型“AL”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_EUROPEAN_NUMBER

        public static final byte DIRECTIONALITY_EUROPEAN_NUMBER
        Unicode规范中的弱双向字符类型“EN”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR

        public static final byte DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR
        Unicode规范中的双向字符类型为“ES”较弱。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR

        public static final byte DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR
        Unicode规范中的双向字符类型“ET”较弱。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_ARABIC_NUMBER

        public static final byte DIRECTIONALITY_ARABIC_NUMBER
        Unicode规范中的弱双向字符类型“AN”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_COMMON_NUMBER_SEPARATOR

        public static final byte DIRECTIONALITY_COMMON_NUMBER_SEPARATOR
        Unicode规范中的双向字符类型“CS”弱。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_NONSPACING_MARK

        public static final byte DIRECTIONALITY_NONSPACING_MARK
        Unicode规范中的弱双向字符类型“NSM”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_BOUNDARY_NEUTRAL

        public static final byte DIRECTIONALITY_BOUNDARY_NEUTRAL
        Unicode规范中的双向字符类型“BN”弱。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_PARAGRAPH_SEPARATOR

        public static final byte DIRECTIONALITY_PARAGRAPH_SEPARATOR
        Unicode规范中的中立双向字符类型“B”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_SEGMENT_SEPARATOR

        public static final byte DIRECTIONALITY_SEGMENT_SEPARATOR
        Unicode规范中的中立双向字符类型“S”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_WHITESPACE

        public static final byte DIRECTIONALITY_WHITESPACE
        Unicode规范中的中立双向字符类型“WS”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_OTHER_NEUTRALS

        public static final byte DIRECTIONALITY_OTHER_NEUTRALS
        Unicode规范中的中立双向字符类型“ON”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING

        public static final byte DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING
        Unicode规范中的强双向字符类型“LRE”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE

        public static final byte DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE
        Unicode规范中的强双向字符类型“LRO”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING

        public static final byte DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING
        Unicode规范中的强双向字符类型“RLE”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE

        public static final byte DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE
        Unicode规范中的强双向字符类型“RLO”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_POP_DIRECTIONAL_FORMAT

        public static final byte DIRECTIONALITY_POP_DIRECTIONAL_FORMAT
        Unicode规范中的双向字符类型为“PDF”。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_LEFT_TO_RIGHT_ISOLATE

        public static final byte DIRECTIONALITY_LEFT_TO_RIGHT_ISOLATE
        Unicode规范中的双向字符类型“LRI”弱。
        从以下版本开始：
        9
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_RIGHT_TO_LEFT_ISOLATE

        public static final byte DIRECTIONALITY_RIGHT_TO_LEFT_ISOLATE
        Unicode规范中的弱双向字符类型“RLI”。
        从以下版本开始：
        9
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_FIRST_STRONG_ISOLATE

        public static final byte DIRECTIONALITY_FIRST_STRONG_ISOLATE
        Unicode规范中的弱双向字符类型“FSI”。
        从以下版本开始：
        9
        另请参见：
        Constant Field Values

      • DIRECTIONALITY_POP_DIRECTIONAL_ISOLATE

        public static final byte DIRECTIONALITY_POP_DIRECTIONAL_ISOLATE
        Unicode规范中的双向字符类型为“PDI”。
        从以下版本开始：
        9
        另请参见：
        Constant Field Values

      • MIN_HIGH_SURROGATE

        public static final char MIN_HIGH_SURROGATE
        一个Unicode high-surrogate code unit的最小值在UTF-16编码中，常数为'\uD800' 。 高代数也被称为领先代理 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MAX_HIGH_SURROGATE

        public static final char MAX_HIGH_SURROGATE
        一个Unicode high-surrogate code unit的最大值在UTF-16编码中，常数为'\uDBFF' 。 高代数也被称为领先代理 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MIN_LOW_SURROGATE

        public static final char MIN_LOW_SURROGATE
        最小值为Unicode low-surrogate code unit ，在UTF-16编码中，常数为'\uDC00' 。 低代数也被称为拖尾代理 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MAX_LOW_SURROGATE

        public static final char MAX_LOW_SURROGATE
        一个Unicode low-surrogate code unit的最大值在UTF-16编码中，常数为'\uDFFF' 。 低代数也被称为拖尾代理 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MIN_SURROGATE

        public static final char MIN_SURROGATE
        UTF-16编码中的Unicode代理代码单元的最小值，常数为 '\uD800' 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MAX_SURROGATE

        public static final char MAX_SURROGATE
        UTF-16编码中的Unicode代理代码单元的最大值，常数为 '\uDFFF' 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MIN_SUPPLEMENTARY_CODE_POINT

        public static final int MIN_SUPPLEMENTARY_CODE_POINT
        最小值为 Unicode supplementary code point ，常数为 U+10000 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MIN_CODE_POINT

        public static final int MIN_CODE_POINT
        最小值为 Unicode code point ，常数为 U+0000 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • MAX_CODE_POINT

        public static final int MAX_CODE_POINT
        最大值为 Unicode code point ，常数为 U+10FFFF 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • SIZE

        public static final int SIZE
        用于以无符号二进制形式表示 char值的位数，常数为 16 。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • BYTES

        public static final int BYTES
        用于以无符号二进制形式表示 char值的字节数。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Character

        @Deprecated(since="9")
public Character​(char value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(char)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
        构造新分配的 Character对象，该对象表示指定的 char值。
        参数
        value - 要由 Character对象表示的值。

    • 方法详细信息

      • valueOf

        public static Character valueOf​(char c)
        返回表示指定的char值的Character实例。 如果不需要新的Character实例，则该方法通常应优先于构造函数Character(char)使用 ，因为该方法可能通过缓存经常请求的值而产生明显更好的空间和时间性能。 此方法将始终将值范围'\u0000'缓存到'\u007F' （包括该值），并且可能会超出此范围之外的其他值。
        参数
        c - 一个char值。
        结果
        一个代表 c的 Character实例。
        从以下版本开始：
        1.5

      • charValue

        public char charValue​()
        返回此 Character对象的值。
        结果
        由该对象表示的原始值 char 。

      • hashCode

        public int hashCode​()
        返回这个Character的哈希码; 等于调用charValue()的结果。
        重写：
        hashCode在 Object
        结果
        这个 Character的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(char value)
        返回一个char值的哈希码; 兼容Character.hashCode() 。
        参数
        value - 用于返回哈希码的 char 。
        结果
        一个哈希码值为 char值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 结果是true当且仅当参数不是null并且是一个Character对象，表示与此对象相同的值为char 。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回一个表示Character的值的String对象。 结果是长度为1的字符串，其唯一组件是由该Character对象表示的基元char值。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式。

      • toString

        public static String toString​(char c)
        返回String表示指定对象char 。 结果是长度为1的字符串，仅由指定的char 。
        参数
        c - 要转换的 char
        结果
        指定的字符串表示为 char
        从以下版本开始：
        1.4

      • isValidCodePoint

        public static boolean isValidCodePoint​(int codePoint)
        确定指定的代码点是否有效 Unicode code point value 。
        参数
        codePoint - 要测试的Unicode代码点
        结果
        true如果指定的代码点值在MIN_CODE_POINT和MAX_CODE_POINT之间; 否则为false 。
        从以下版本开始：
        1.5

      • isBmpCodePoint

        public static boolean isBmpCodePoint​(int codePoint)
        确定指定字符（Unicode代码点）是否在Basic Multilingual Plane (BMP)中 。 这样的代码点可以使用单个char来表示。
        参数
        codePoint - 要测试的字符（Unicode码点）
        结果
        true如果指定的代码点在MIN_VALUE和MAX_VALUE之间; 否则为false 。
        从以下版本开始：
        1.7

      • isSupplementaryCodePoint

        public static boolean isSupplementaryCodePoint​(int codePoint)
        确定指定字符（Unicode代码点）是否在 supplementary character范围内。
        参数
        codePoint - 要测试的字符（Unicode代码点）
        结果
        true如果指定的代码点在MIN_SUPPLEMENTARY_CODE_POINT和MAX_CODE_POINT之间; 否则为false 。
        从以下版本开始：
        1.5

      • isHighSurrogate

        public static boolean isHighSurrogate​(char ch)
        确定给定的char值是否为Unicode high-surrogate code unit （也称为引导代理单元 ）。

        这些值本身并不表示字符，而是用于表示UTF-16编码中的supplementary characters 。

        参数
        ch - 要测试的 char值。
        结果
        true如果char值在MIN_HIGH_SURROGATE和MAX_HIGH_SURROGATE之间; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isLowSurrogate(char) ， Character.UnicodeBlock.of(int)

      • isLowSurrogate

        public static boolean isLowSurrogate​(char ch)
        确定给定的char值是否为Unicode low-surrogate code unit （也称为尾随代理单元 ）。

        这些值本身并不表示字符，而是用于表示UTF-16编码中的supplementary characters 。

        参数
        ch - 要测试的 char值。
        结果
        true如果char值在MIN_LOW_SURROGATE和MAX_LOW_SURROGATE之间; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isHighSurrogate(char)

      • isSurrogate

        public static boolean isSurrogate​(char ch)
        确定给定的char值是否是Unicode 代理代码单元 。

        这些值本身并不表示字符，而是用于表示UTF-16编码中的supplementary characters 。

        如果且仅当它是low-surrogate code unit或high-surrogate code unit ，则char值是代理代码单元。

        参数
        ch - 要测试的 char值。
        结果
        true如果char值在MIN_SURROGATE和MAX_SURROGATE之间; 否则为false 。
        从以下版本开始：
        1.7

      • isSurrogatePair

        public static boolean isSurrogatePair​(char high,
                                      char low)
        确定指定的一对char值是否为有效的Unicode surrogate pair 。

        此方法等效于表达式：

 isHighSurrogate(high) && isLowSurrogate(low)
        参数
        high - 待测试的高替代代码值
        low - 要测试的低代理代码值
        结果
        true如果指定的高和低代理代码值代表有效的代理对; 否则为false 。
        从以下版本开始：
        1.5

      • charCount

        public static int charCount​(int codePoint)
        确定代表指定字符（Unicode代码点）所需的char值。 如果指定的字符等于或大于0x10000，则该方法返回2.否则，该方法返回1。

        此方法不会将指定的字符验证为有效的Unicode代码点。 如果需要，来电者必须使用isValidCodePoint验证字符值。

        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        2如果字符是有效的补充字符; 1否则。
        从以下版本开始：
        1.5
        另请参见：
        isSupplementaryCodePoint(int)

      • toCodePoint

        public static int toCodePoint​(char high,
                              char low)
        将指定的代理对转换为其补充代码点值。 此方法不验证指定的代理对。 如果需要，来电者必须使用isSurrogatePair进行验证。
        参数
        high - 高 high代码单位
        low - 低代码单位
        结果
        由指定代理对组成的补充代码点。
        从以下版本开始：
        1.5

      • codePointAt

        public static int codePointAt​(CharSequence seq,
                              int index)
        返回CharSequence给定索引处的代码点。 如果char给定索引处的值CharSequence处于高代理项范围，下列指数小于所述长度CharSequence和char以下索引处的值是在低代理项范围内，则所述辅助返回与该替代对对应的代码点。 否则，返回给定索引处的char值。
        参数
        seq - char值的序列（Unicode代码单位）
        index - 要转换的 char值（Unicode码单位）的 seq
        结果
        在指定的索引处的Unicode代码点
        异常
        NullPointerException - 如果 seq为空。
        IndexOutOfBoundsException - 如果值 index为负数或不小于 seq.length() 。
        从以下版本开始：
        1.5

      • codePointAt

        public static int codePointAt​(char[] a,
                              int index)
        返回char数组的给定索引处的代码点。 如果char阵列中给定指数的char值处于高替代范围，则以下指数小于char阵列的长度，而下列指标的char值处于低char范围，则返回与该替代对对应的补码。 否则，返回给定索引处的char值。
        参数
        a - char阵列
        index - 要转换的 char数组中的 char值（Unicode代码单位）的 char
        结果
        在指定的索引处的Unicode代码点
        异常
        NullPointerException - 如果 a为空。
        IndexOutOfBoundsException - 如果值 index为负数或不小于 char阵列的长度。
        从以下版本开始：
        1.5

      • codePointAt

        public static int codePointAt​(char[] a,
                              int index,
                              int limit)
        返回char数组的给定索引处的代码点，其中只能使用index小于limit数组元素。 如果char阵列中给定指数的char值处于高代理范围内，则以下指数小于limit ，下列指数中的char值处于低代理范围，则补码代码点相应的这个代理对被退回。 否则，返回给定索引处的char值。
        参数
        a - char数组
        index - 要转换的 char数组中的 char值（Unicode代码单位）的 char
        limit - 可以在 char数组中使用的最后一个数组元素后的索引
        结果
        在指定的索引处的Unicode代码点
        异常
        NullPointerException - 如果 a为空。
        IndexOutOfBoundsException - 如果 index参数为负数或不小于 limit参数，或者如果 limit参数为负数或大于 char数组的长度。
        从以下版本开始：
        1.5

      • codePointBefore

        public static int codePointBefore​(CharSequence seq,
                                  int index)
        返回CharSequence给定索引之前的代码点。 如果char在值(index - 1)在CharSequence处于低代理项范围， (index - 2)不为负，并且char在值(index - 2)在CharSequence处于高代理项范围内，则对应于该代理对的增补代码点是回。 否则，返回(index - 1)的char值。
        参数
        seq - CharSequence实例
        index - 应该返回的代码点后面的索引
        结果
        Unicode代码点值在给定索引之前。
        异常
        NullPointerException - 如果 seq为空。
        IndexOutOfBoundsException - 如果 index参数小于1或大于 seq.length() 。
        从以下版本开始：
        1.5

      • codePointBefore

        public static int codePointBefore​(char[] a,
                                  int index)
        返回char数组的给定索引之前的代码点。 如果char在值(index - 1)中char阵列是在低代理项范围， (index - 2)不为负，并且char在值(index - 2)中char阵列在高代理项范围内，则对应于该替代的增补代码点对被退回。 否则，返回(index - 1)的char值。
        参数
        a - char数组
        index - 应该返回的代码点之后的索引
        结果
        Unicode代码点值在给定索引之前。
        异常
        NullPointerException - 如果 a为空。
        IndexOutOfBoundsException - 如果 index参数小于1或大于 char数组的长度
        从以下版本开始：
        1.5

      • codePointBefore

        public static int codePointBefore​(char[] a,
                                  int index,
                                  int start)
        返回char数组的给定索引之前的代码点，其中只能使用index大于或等于start数组元素。 如果char (index - 1)在char阵列的char阵列处于低(index - 2)范围内，则(index - 2)不得低于start ，而char (index - 2)中的char在char阵列中处于高替代范围内，则补码代码点对应这个代理对被退回。 否则，返回(index - 1)的char值。
        参数
        a - char数组
        index - 应该返回的代码点后面的索引
        start - char数组中第一个数组元素的 char
        结果
        Unicode代码点值在给定索引之前。
        异常
        NullPointerException - 如果 a为空。
        IndexOutOfBoundsException - 如果 index参数不大于 start参数或大于 char数组的长度，或者如果 start参数为负数或不小于 char数组的长度。
        从以下版本开始：
        1.5

      • highSurrogate

        public static char highSurrogate​(int codePoint)
        返回主导替代（一个high surrogate code unit所述的） surrogate pair表示在UTF-16编码指定的补充的字符（Unicode代码点）。 如果指定的字符不是supplementary character ，则返回未指定的char 。

        如果isSupplementaryCodePoint(x)是true ，则isHighSurrogate (highSurrogate(x))和toCodePoint (highSurrogate(x), lowSurrogate (x)) == x也总是true 。

        参数
        codePoint - 补充字符（Unicode码点）
        结果
        用于表示UTF-16编码中的字符的首选代理单元
        从以下版本开始：
        1.7

      • lowSurrogate

        public static char lowSurrogate​(int codePoint)
        返回表示UTF-16编码中指定的补充字符（Unicode代码点）的surrogate pair的后续代理（ low surrogate code unit ）。 如果指定的字符不是supplementary character ，则返回未指定的char 。

        如果isSupplementaryCodePoint(x)是true ，则isLowSurrogate (lowSurrogate(x))和toCodePoint ( highSurrogate (x), lowSurrogate(x)) == x也总是true 。

        参数
        codePoint - 补充字符（Unicode码点）
        结果
        用于表示UTF-16编码中的字符的尾随代理单元
        从以下版本开始：
        1.7

      • toChars

        public static int toChars​(int codePoint,
                          char[] dst,
                          int dstIndex)
        将指定的字符（Unicode代码点）转换为其UTF-16表示形式。 如果指定的代码点是BMP（基本多语言平面或平面0）值，则相同的值存储在dst[dstIndex] ，并返回1。 如果指定的代码点是补充字符，则其代理值存储在dst[dstIndex] （高代码）和dst[dstIndex+1] （低代理）中，并返回2。
        参数
        codePoint - 要转换的字符（Unicode代码点）。
        dst -的阵列 char其中 codePoint的UTF-16值被存储。
        dstIndex - 将转换后的值存储到 dst数组中的起始索引。
        结果
        1，如果代码点是BMP代码点，2代码点是补码。
        异常
        IllegalArgumentException - 如果指定的 codePoint不是有效的Unicode代码点。
        NullPointerException - 如果指定的 dst为空。
        IndexOutOfBoundsException - 如果dstIndex为负数或不小于dst.length ，或者如果dst中的dstIndex没有足够的数组元素来存储产生的char值。 （如果dstIndex等于dst.length-1 ，并且指定的codePoint是补充字符，则高代理值不存储在dst[dstIndex] 。）
        从以下版本开始：
        1.5

      • toChars

        public static char[] toChars​(int codePoint)
        将指定的字符（Unicode代码点）转换为存储在char数组中的UTF-16表示形式。 如果指定的代码点是BMP（基本多语言平面或平面0）值，则生成的char数组的值与codePoint相同。 如果指定的代码点是补充代码点，则产生的char阵列具有相应的代理对。
        参数
        codePoint - 一个Unicode代码点
        结果
        一个具有 codePoint的UTF-16表示的 char阵列。
        异常
        IllegalArgumentException - 如果指定的 codePoint不是有效的Unicode代码点。
        从以下版本开始：
        1.5

      • codePointCount

        public static int codePointCount​(CharSequence seq,
                                 int beginIndex,
                                 int endIndex)
        返回指定字符序列的文本范围内的Unicode代码点数。 文本范围从指定的beginIndex开始，并扩展到char ，索引号为endIndex - 1 。 因此，文本范围的长度（ char s）为endIndex-beginIndex 。 文本范围内的非配对替代品，每一个代码点都是一样的。
        参数
        seq - 字符序列
        beginIndex - 索引到第一个 char的文本范围。
        endIndex - 索引在最后一个 char的文本范围之后。
        结果
        指定文本范围内的Unicode代码点数
        异常
        NullPointerException - 如果 seq为空。
        IndexOutOfBoundsException - 如果 beginIndex为负数，或 endIndex大于给定序列的长度，或者 beginIndex大于 endIndex 。
        从以下版本开始：
        1.5

      • codePointCount

        public static int codePointCount​(char[] a,
                                 int offset,
                                 int count)
        返回char数组参数的子阵列中的Unicode代码点数。 offset参数是子阵列的第一个char的索引，而count参数指定了char s char阵列的长度。 子代码中的非配对代理计数为每个代码点。
        参数
        a - char数组
        offset - 在给定的 char数组中的第一个 char的指数
        count - 子阵列的长度在 char s
        结果
        指定子阵列中的Unicode代码点数
        异常
        NullPointerException - 如果 a为空。
        IndexOutOfBoundsException - 如果 offset或 count为负数，或者如果 offset + count大于给定数组的长度。
        从以下版本开始：
        1.5

      • offsetByCodePoints

        public static int offsetByCodePoints​(CharSequence seq,
                                     int index,
                                     int codePointOffset)
        返回给定char序列中的索引，该索引与给定的index由codePointOffset代码点偏移。 由index和codePointOffset给出的文本范围内的非配对替代品作为一个代码点。
        参数
        seq - 字符序列
        index - 要偏移的索引
        codePointOffset - 代码点的偏移量
        结果
        char序列中的索引
        异常
        NullPointerException - 如果 seq为空。
        IndexOutOfBoundsException - 如果 index为负或大于char序列的长度，或者如果 codePointOffset为正，并且从 index开始的子 index具有少于 codePointOffset码点，或者如果 codePointOffset为负，并且 index之前的子 index小于绝对值的 codePointOffset代码点。
        从以下版本开始：
        1.5

      • offsetByCodePoints

        public static int offsetByCodePoints​(char[] a,
                                     int start,
                                     int count,
                                     int index,
                                     int codePointOffset)
        返回给定的char子阵列中的索引，该子阵列与给定的index由codePointOffset代码点偏移。 start和count参数指定char数组的子阵列。 由index和codePointOffset给出的文本范围内的非配对替代品每个作为一个代码点。
        参数
        a - char数组
        start - 该子阵列第一个 char的索引
        count - 子阵列的长度在 char s
        index - 要偏移的索引
        codePointOffset - 代码点的偏移量
        结果
        子阵列中的索引
        异常
        NullPointerException - 如果 a为空。
        IndexOutOfBoundsException -如果 start或 count是否定的，或者如果 start + count大于给定阵列的长度大，或如果 index小于 start更大或然后 start + count ，或者如果 codePointOffset为正和文本范围开始 index ，结束时用 start + count - 1有少于 codePointOffset代码点，或者如果 codePointOffset为负且文本范围开始 start ，结束时用 index - 1具有比的绝对值较少 codePointOffset代码点。
        从以下版本开始：
        1.5

      • isLowerCase

        public static boolean isLowerCase​(char ch)
        确定指定的字符是否是小写字符。

        如果由Character.getType(ch)提供的一般类别类型为LOWERCASE_LETTER ，或者符合Unicode标准定义的其他Character.getType(ch) ，则字符为小写。

        以下是小写字符的示例：

         a b c d e f g h i j k l m n o p q r s t u v w x y z
 '\u00DF' '\u00E0' '\u00E1' '\u00E2' '\u00E3' '\u00E4' '\u00E5' '\u00E6'
 '\u00E7' '\u00E8' '\u00E9' '\u00EA' '\u00EB' '\u00EC' '\u00ED' '\u00EE'
 '\u00EF' '\u00F0' '\u00F1' '\u00F2' '\u00F3' '\u00F4' '\u00F5' '\u00F6'
 '\u00F8' '\u00F9' '\u00FA' '\u00FB' '\u00FC' '\u00FD' '\u00FE' '\u00FF'

        许多其他Unicode字符也是小写的。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isLowerCase(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是小写的; 否则为false 。
        另请参见：
        isLowerCase(char) ， isTitleCase(char) ， toLowerCase(char) ， getType(char)

      • isLowerCase

        public static boolean isLowerCase​(int codePoint)
        确定指定的字符（Unicode代码点）是否是小写字符。

        如果由getType(codePoint)提供的一般类别类型是LOWERCASE_LETTER ，或者它具有由Unicode标准定义的贡献属性Other_Lowercase，那么一个字符是小写的。

        以下是小写字符的示例：

         a b c d e f g h i j k l m n o p q r s t u v w x y z
 '\u00DF' '\u00E0' '\u00E1' '\u00E2' '\u00E3' '\u00E4' '\u00E5' '\u00E6'
 '\u00E7' '\u00E8' '\u00E9' '\u00EA' '\u00EB' '\u00EC' '\u00ED' '\u00EE'
 '\u00EF' '\u00F0' '\u00F1' '\u00F2' '\u00F3' '\u00F4' '\u00F5' '\u00F6'
 '\u00F8' '\u00F9' '\u00FA' '\u00FB' '\u00FC' '\u00FD' '\u00FE' '\u00FF'

        许多其他Unicode字符也是小写的。

        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是小写的; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isLowerCase(int) ， isTitleCase(int) ， toLowerCase(int) ， getType(int)

      • isUpperCase

        public static boolean isUpperCase​(char ch)
        确定指定的字符是否为大写字符。

        如果其一般类别类型由Character.getType(ch)提供，则字符为大写，为UPPERCASE_LETTER 。 或者它具有由Unicode标准定义的贡献属性Other_Uppercase。

        以下是大写字符的示例：

         A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
 '\u00C0' '\u00C1' '\u00C2' '\u00C3' '\u00C4' '\u00C5' '\u00C6' '\u00C7'
 '\u00C8' '\u00C9' '\u00CA' '\u00CB' '\u00CC' '\u00CD' '\u00CE' '\u00CF'
 '\u00D0' '\u00D1' '\u00D2' '\u00D3' '\u00D4' '\u00D5' '\u00D6' '\u00D8'
 '\u00D9' '\u00DA' '\u00DB' '\u00DC' '\u00DD' '\u00DE'

        许多其他Unicode字符也是大写字母。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用isUpperCase(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是大写字母; false否则。
        从以下版本开始：
        1.0
        另请参见：
        isLowerCase(char) ， isTitleCase(char) ， toUpperCase(char) ， getType(char)

      • isUpperCase

        public static boolean isUpperCase​(int codePoint)
        确定指定的字符（Unicode代码点）是否为大写字符。

        如果由getType(codePoint)提供的一般类别类型是UPPERCASE_LETTER ，或者它具有由Unicode标准定义的贡献属性Other_Uppercase，那么一个字符是大写的。

        以下是大写字符的示例：

         A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
 '\u00C0' '\u00C1' '\u00C2' '\u00C3' '\u00C4' '\u00C5' '\u00C6' '\u00C7'
 '\u00C8' '\u00C9' '\u00CA' '\u00CB' '\u00CC' '\u00CD' '\u00CE' '\u00CF'
 '\u00D0' '\u00D1' '\u00D2' '\u00D3' '\u00D4' '\u00D5' '\u00D6' '\u00D8'
 '\u00D9' '\u00DA' '\u00DB' '\u00DC' '\u00DD' '\u00DE'

        许多其他Unicode字符也是大写字母。

        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是大写字母; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isLowerCase(int) ， isTitleCase(int) ， toUpperCase(int) ， getType(int)

      • isTitleCase

        public static boolean isTitleCase​(char ch)
        确定指定的字符是否是一个titlecase字符。

        如果其一般类别类型由Character.getType(ch)提供，则字符为titlecase字符，为TITLECASE_LETTER 。

        一些字符看起来像拉丁字母对。 例如，有一个大写字母，看起来像“LJ”，并有相应的小写字母，看起来像“lj”。 看起来像“Lj”的第三种形式是使用初始大写字母小写的单词时使用的适当形式，如书名。

        这些是这个方法返回的一些Unicode字符true ：

        • LATIN CAPITAL LETTER D WITH SMALL LETTER Z WITH CARON
        • LATIN CAPITAL LETTER L WITH SMALL LETTER J
        • LATIN CAPITAL LETTER N WITH SMALL LETTER J
        • LATIN CAPITAL LETTER D WITH SMALL LETTER Z

        许多其他Unicode字符也是titlecase。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isTitleCase(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是titlecase; 否则为false 。
        从以下版本开始：
        1.0.2
        另请参见：
        isLowerCase(char) ， isUpperCase(char) ， toTitleCase(char) ， getType(char)

      • isTitleCase

        public static boolean isTitleCase​(int codePoint)
        确定指定的字符（Unicode代码点）是否是一个titlecase字符。

        如果其一般类别类型由getType(codePoint)提供，则字符为titlecase字符，为TITLECASE_LETTER 。

        一些字符看起来像拉丁字母对。 例如，有一个大写字母，看起来像“LJ”，并有相应的小写字母，看起来像“lj”。 看起来像“Lj”的第三种形式是使用初始大写字母小写的单词时使用的适当形式，如书名。

        这些是这个方法返回的一些Unicode字符true ：

        • LATIN CAPITAL LETTER D WITH SMALL LETTER Z WITH CARON
        • LATIN CAPITAL LETTER L WITH SMALL LETTER J
        • LATIN CAPITAL LETTER N WITH SMALL LETTER J
        • LATIN CAPITAL LETTER D WITH SMALL LETTER Z

        许多其他Unicode字符也是titlecase。

        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是titlecase; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isLowerCase(int) ， isUpperCase(int) ， toTitleCase(int) ， getType(int)

      • isDigit

        public static boolean isDigit​(char ch)
        确定指定的字符是否是数字。

        如果其一般类别类型由Character.getType(ch)提供，则字符为数字，为DECIMAL_DIGIT_NUMBER 。

        一些包含数字的Unicode字符范围：

        • '\u0030'至'\u0039' ，ISO-LATIN-1位数字（ '0'至'9' ）
        • '\u0660'至'\u0669' ，阿拉伯语 - 印度数字
        • '\u06F0'至'\u06F9' ，扩展阿拉伯语 - 印度数字
        • '\u0966'通过'\u096F' ，梵文数字
        • '\uFF10'到'\uFF19' ，全宽数字
        许多其他字符范围也包含数字。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用isDigit(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是数字; 否则为false 。
        另请参见：
        digit(char, int) ，
forDigit(int, int) ，
getType(char)

      • isDigit

        public static boolean isDigit​(int codePoint)
        确定指定的字符（Unicode代码点）是否为数字。

        如果其一般类别类型由getType(codePoint)提供， 则为字符数字，为DECIMAL_DIGIT_NUMBER 。

        一些包含数字的Unicode字符范围：

        • '\u0030'至'\u0039' ，ISO-LATIN-1位数字（ '0'至'9' ）
        • '\u0660'至'\u0669' ，阿拉伯语 - 印度数字
        • '\u06F0'至'\u06F9' ，扩展阿拉伯语 - 印度数字
        • '\u0966'至'\u096F' ，梵文数字
        • '\uFF10'通过'\uFF19' ，全宽数字
        许多其他字符范围也包含数字。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是数字; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        forDigit(int, int) ， getType(int)

      • isDefined

        public static boolean isDefined​(char ch)
        确定字符是否以Unicode定义。

        如果至少有以下条件之一成立，则定义一个字符：

        • 它在UnicodeData文件中有一个条目。
        • 它具有由UnicodeData文件定义的范围内的值。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isDefined(int)方法。

        参数
        ch - 要测试的字符
        结果
        如果字符在Unicode中具有定义的含义， true ; 否则为false 。
        从以下版本开始：
        1.0.2
        另请参见：
        isDigit(char) ， isLetter(char) ， isLetterOrDigit(char) ， isLowerCase(char) ， isTitleCase(char) ， isUpperCase(char)

      • isDefined

        public static boolean isDefined​(int codePoint)
        确定Unicode中是否定义了一个字符（Unicode代码点）。

        如果至少有以下条件之一成立，则定义一个字符：

        • 它在UnicodeData文件中有一个条目。
        • 它具有由UnicodeData文件定义的范围内的值。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        如果字符在Unicode中具有定义的含义， true ; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isDigit(int) ， isLetter(int) ， isLetterOrDigit(int) ， isLowerCase(int) ， isTitleCase(int) ， isUpperCase(int)

      • isLetter

        public static boolean isLetter​(char ch)
        确定指定的字符是否是一个字母。

        如果由Character.getType(ch)提供的一般类别类型是以下任何一种，则该字符被视为信件：

        • UPPERCASE_LETTER
        • LOWERCASE_LETTER
        • TITLECASE_LETTER
        • MODIFIER_LETTER
        • OTHER_LETTER
        不是所有的信都有情况。 许多人物都是字母，但既不是大写也不是小写字母，也不是titlecase。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用isLetter(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是一个字母; 否则为false 。
        另请参见：
        isDigit(char) ， isJavaIdentifierStart(char) ， isJavaLetter(char) ， isJavaLetterOrDigit(char) ， isLetterOrDigit(char) ， isLowerCase(char) ， isTitleCase(char) ， isUnicodeIdentifierStart(char) ， isUpperCase(char)

      • isLetter

        public static boolean isLetter​(int codePoint)
        确定指定的字符（Unicode代码点）是否是一个字母。

        如果由getType(codePoint)提供的一般类别类型是以下任何一种，则字符被视为信件：

        • UPPERCASE_LETTER
        • LOWERCASE_LETTER
        • TITLECASE_LETTER
        • MODIFIER_LETTER
        • OTHER_LETTER
        不是所有的信都有情况。 许多人物都是字母，但既不是大写也不是小写字母，也不是titlecase。
        参数
        codePoint - 要测试的字符（Unicode码点）。
        结果
        true如果字符是一个字母; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isDigit(int) ， isJavaIdentifierStart(int) ， isLetterOrDigit(int) ， isLowerCase(int) ， isTitleCase(int) ， isUnicodeIdentifierStart(int) ， isUpperCase(int)

      • isLetterOrDigit

        public static boolean isLetterOrDigit​(char ch)
        确定指定的字符是字母还是数字。

        如果Character.isLetter(char ch)或Character.isDigit(char ch)为该字符返回true ，则字符被视为字母或数字。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isLetterOrDigit(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是字母或数字; 否则为false 。
        从以下版本开始：
        1.0.2
        另请参见：
        isDigit(char) ， isJavaIdentifierPart(char) ， isJavaLetter(char) ， isJavaLetterOrDigit(char) ， isLetter(char) ， isUnicodeIdentifierPart(char)

      • isLetterOrDigit

        public static boolean isLetterOrDigit​(int codePoint)
        确定指定的字符（Unicode代码点）是字母还是数字。

        如果isLetter(codePoint)或isDigit(codePoint)为该字符返回true ，则字符被视为字母或数字。

        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是字母或数字; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isDigit(int) ， isJavaIdentifierPart(int) ， isLetter(int) ， isUnicodeIdentifierPart(int)

      • isJavaLetter

        @Deprecated(since="1.1")
public static boolean isJavaLetter​(char ch)
        已过时。 替换为isJavaIdentifierStart（char）。
        确定指定字符是否允许作为Java标识符中的第一个字符。

        当且仅当以下之一为真时，字符才能启动Java标识符：

        • isLetter(ch)返回true
        • getType(ch)返回LETTER_NUMBER
        • ch是货币符号（如'$' ）
        • ch是连接标点符号（如'_' ）。
        参数
        ch - 要测试的字符。
        结果
        true如果字符可能启动Java标识符; 否则为false 。
        从以下版本开始：
        1.0.2
        另请参见：
        isJavaLetterOrDigit(char) ， isJavaIdentifierStart(char) ， isJavaIdentifierPart(char) ， isLetter(char) ， isLetterOrDigit(char) ， isUnicodeIdentifierStart(char)

      • isJavaLetterOrDigit

        @Deprecated(since="1.1")
public static boolean isJavaLetterOrDigit​(char ch)
        已过时。 由isJavaIdentifierPart（char）替代。
        确定指定的字符是否可以是Java标识符的一部分，而不是第一个字符。

        当且仅当以下任何一项为真时，字符可能是Java标识符的一部分：

        • 这是一封信
        • 它是货币符号（如'$' ）
        • 它是一个连接的标点符号（如'_' ）
        • 它是一个数字
        • 它是一个数字字母（如罗马数字字符）
        • 它是一个组合标记
        • 它是一个非间距标记
        • isIdentifierIgnorable返回true的字符。
        参数
        ch - 要测试的字符。
        结果
        true如果字符可能是Java标识符的一部分; 否则为false 。
        从以下版本开始：
        1.0.2
        另请参见：
        isJavaLetter(char) ， isJavaIdentifierStart(char) ， isJavaIdentifierPart(char) ， isLetter(char) ， isLetterOrDigit(char) ， isUnicodeIdentifierPart(char) ， isIdentifierIgnorable(char)

      • isAlphabetic

        public static boolean isAlphabetic​(int codePoint)
        确定指定的字符（Unicode代码点）是否是字母表。

        如果由getType(codePoint)提供的一般类别类型是以下任何一种，则字符被视为字母：

        • UPPERCASE_LETTER
        • LOWERCASE_LETTER
        • TITLECASE_LETTER
        • MODIFIER_LETTER
        • OTHER_LETTER
        • LETTER_NUMBER
        或者它具有由Unicode标准定义的Other_Alphabetic的贡献属性。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是Unicode字母字符，否则为 false 。
        从以下版本开始：
        1.7

      • isIdeographic

        public static boolean isIdeographic​(int codePoint)
        确定指定字符（Unicode代码点）是否是Unicode标准定义的CJKV（中文，日文，韩文和越南文）表意文字。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是Unicode表意文字字符，否则为 false 。
        从以下版本开始：
        1.7

      • isJavaIdentifierStart

        public static boolean isJavaIdentifierStart​(char ch)
        确定指定字符是否允许作为Java标识符中的第一个字符。

        当且仅当以下条件之一为真时，字符可能启动Java标识符：

        • isLetter(ch)返回true
        • getType(ch)返回LETTER_NUMBER
        • ch是货币符号（如'$' ）
        • ch是一个连接的标点符号（如'_' ）。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isJavaIdentifierStart(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符可能启动Java标识符; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        isJavaIdentifierPart(char) ， isLetter(char) ， isUnicodeIdentifierStart(char) ， SourceVersion.isIdentifier(CharSequence)

      • isJavaIdentifierStart

        public static boolean isJavaIdentifierStart​(int codePoint)
        确定字符（Unicode代码点）是否允许作为Java标识符中的第一个字符。

        当且仅当以下条件之一为真时，字符可能启动Java标识符：

        • isLetter(codePoint)返回true
        • getType(codePoint)返回LETTER_NUMBER
        • 引用的字符是货币符号（如'$' ）
        • 引用的字符是连接的标点符号（如'_' ）。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符可能启动Java标识符; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isJavaIdentifierPart(int) ， isLetter(int) ， isUnicodeIdentifierStart(int) ， SourceVersion.isIdentifier(CharSequence)

      • isJavaIdentifierPart

        public static boolean isJavaIdentifierPart​(char ch)
        确定指定的字符是否可以是Java标识符的一部分，而不是第一个字符。

        如果以下任何一项为真，则字符可能是Java标识符的一部分：

        • 这是一封信
        • 它是货币符号（如'$' ）
        • 它是一个连接的标点符号（如'_' ）
        • 它是一个数字
        • 它是一个数字字母（如罗马数字字符）
        • 它是一个组合标记
        • 它是一个非间距标记
        • isIdentifierIgnorable回报true的字符

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用isJavaIdentifierPart(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果该字符可能是Java标识符的一部分; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        isIdentifierIgnorable(char) ， isJavaIdentifierStart(char) ， isLetterOrDigit(char) ， isUnicodeIdentifierPart(char) ， SourceVersion.isIdentifier(CharSequence)

      • isJavaIdentifierPart

        public static boolean isJavaIdentifierPart​(int codePoint)
        确定字符（Unicode代码点）可能是Java标识符的一部分，而不是第一个字符。

        如果以下任何一项为真，则字符可能是Java标识符的一部分：

        • 这是一封信
        • 它是货币符号（如'$' ）
        • 它是一个连接的标点符号（如'_' ）
        • 它是一个数字
        • 它是一个数字字母（如罗马数字字符）
        • 它是一个组合标记
        • 它是一个非间距标记
        • isIdentifierIgnorable(codePoint)返回true的字符
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果该字符可能是Java标识符的一部分; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isIdentifierIgnorable(int) ， isJavaIdentifierStart(int) ， isLetterOrDigit(int) ， isUnicodeIdentifierPart(int) ， SourceVersion.isIdentifier(CharSequence)

      • isUnicodeIdentifierStart

        public static boolean isUnicodeIdentifierStart​(char ch)
        确定指定字符是否允许为Unicode标识符中的第一个字符。

        如果且仅当以下条件之一为真时，字符可能会启动Unicode标识符：

        • isLetter(ch)返回true
        • getType(ch)返回LETTER_NUMBER 。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isUnicodeIdentifierStart(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符可能启动Unicode标识符; false否则。
        从以下版本开始：
        1.1
        另请参见：
        isJavaIdentifierStart(char) ， isLetter(char) ， isUnicodeIdentifierPart(char)

      • isUnicodeIdentifierStart

        public static boolean isUnicodeIdentifierStart​(int codePoint)
        确定Unicode标识符中的第一个字符是否允许指定的字符（Unicode代码点）。

        如果且仅当以下条件之一为真时，字符可能会启动Unicode标识符：

        • isLetter(codePoint)返回true
        • getType(codePoint)返回LETTER_NUMBER 。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符可能启动Unicode标识符; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isJavaIdentifierStart(int) ， isLetter(int) ， isUnicodeIdentifierPart(int)

      • isUnicodeIdentifierPart

        public static boolean isUnicodeIdentifierPart​(char ch)
        确定指定的字符是否可以是Unicode标识符的一部分，而不是第一个字符。

        当且仅当以下语句之一为真时，字符可能是Unicode标识符的一部分：

        • 这是一封信
        • 它是一个连接的标点符号（如'_' ）
        • 它是一个数字
        • 它是一个数字字母（如罗马数字字符）
        • 它是一个组合标记
        • 它是一个非间距标记
        • isIdentifierIgnorable为这个字符返回true 。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isUnicodeIdentifierPart(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符可能是Unicode标识符的一部分; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        isIdentifierIgnorable(char) ， isJavaIdentifierPart(char) ， isLetterOrDigit(char) ， isUnicodeIdentifierStart(char)

      • isUnicodeIdentifierPart

        public static boolean isUnicodeIdentifierPart​(int codePoint)
        确定指定的字符（Unicode代码点）是否可能是Unicode标识符的一部分，而不是第一个字符。

        当且仅当以下语句之一为真时，字符可能是Unicode标识符的一部分：

        • 这是一封信
        • 它是一个连接的标点符号（如'_' ）
        • 它是一个数字
        • 它是一个数字字母（如罗马数字字符）
        • 它是一个组合标记
        • 它是一个非间距标记
        • isIdentifierIgnorable为这个字符返回true 。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符可能是Unicode标识符的一部分; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isIdentifierIgnorable(int) ， isJavaIdentifierPart(int) ， isLetterOrDigit(int) ， isUnicodeIdentifierStart(int)

      • isIdentifierIgnorable

        public static boolean isIdentifierIgnorable​(char ch)
        确定指定的字符是否应被视为Java标识符或Unicode标识符中的可忽略字符。

        以下Unicode字符在Java标识符或Unicode标识符中是可忽略的：

        • 不是空格的ISO控制字符
          • '\u0000'通过'\u0008'
          • '\u000E'至'\u001B'
          • '\u007F'至'\u009F'
        • 所有字符都具有FORMAT一般类别值

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用isIdentifierIgnorable(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是可能是Java或Unicode标识符的一部分的可忽略的控制字符; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        isJavaIdentifierPart(char) ， isUnicodeIdentifierPart(char)

      • isIdentifierIgnorable

        public static boolean isIdentifierIgnorable​(int codePoint)
        确定指定字符（Unicode代码点）是否应被视为Java标识符或Unicode标识符中的可忽略字符。

        以下Unicode字符在Java标识符或Unicode标识符中是可忽略的：

        • 不是空格的ISO控制字符
          • '\u0000'至'\u0008'
          • '\u000E'至'\u001B'
          • '\u007F'至'\u009F'
        • 所有字符都具有FORMAT一般类别值
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是可能是Java或Unicode标识符的一部分的可忽略的控制字符; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isJavaIdentifierPart(int) ， isUnicodeIdentifierPart(int)

      • toLowerCase

        public static char toLowerCase​(char ch)
        使用UnicodeData文件中的大小写映射信息将字符参数转换为小写。

        请注意， Character.isLowerCase(Character.toLowerCase(ch))并不总是为某些字符范围返回true ，特别是那些符号或表意文字。

        一般来说， String.toLowerCase()应该用来将字符映射成小写。 String案例映射方法比Character案例映射方法有好几个好处。 String案例映射方法可以执行区域设置敏感的映射，上下文相关映射和1：M字符映射，而Character案例映射方法不能。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用toLowerCase(int)方法。

        参数
        ch - 要转换的字符。
        结果
        字符的小写等价物（如果有的话） 否则，字符本身。
        另请参见：
        isLowerCase(char) ， String.toLowerCase()

      • toLowerCase

        public static int toLowerCase​(int codePoint)
        使用UnicodeData文件中的大小写映射信息将字符（Unicode代码点）参数转换为小写。

        请注意， Character.isLowerCase(Character.toLowerCase(codePoint))并不总是为某些字符范围返回true ，特别是那些符号或表意文字。

        一般来说， String.toLowerCase()应该用来将字符映射成小写。 String案例映射方法比Character案例映射方法有好几个好处。 String案例映射方法可以执行区域设置敏感的映射，上下文相关的映射和1：M字符映射，而Character案例映射方法不能。

        参数
        codePoint - 要转换的字符（Unicode代码点）。
        结果
        字符的小写等价物（Unicode代码点），如果有的话; 否则，字符本身。
        从以下版本开始：
        1.5
        另请参见：
        isLowerCase(int) ， String.toLowerCase()

      • toUpperCase

        public static char toUpperCase​(char ch)
        使用UnicodeData文件中的案例映射信息将字符参数转换为大写。

        请注意， Character.isUpperCase(Character.toUpperCase(ch))并不总是为某些字符范围返回true ，特别是那些符号或表意文字。

        一般来说， String.toUpperCase()应该用于将字符映射到大写。 String案例映射方法比Character案例映射方法有好几个好处。 String案例映射方法可以执行区域设置敏感映射，上下文敏感映射和1：M字符映射，而Character案例映射方法不能。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用toUpperCase(int)方法。

        参数
        ch - 要转换的字符。
        结果
        字符的大写字母（如果有的话） 否则，字符本身。
        另请参见：
        isUpperCase(char) ， String.toUpperCase()

      • toUpperCase

        public static int toUpperCase​(int codePoint)
        使用UnicodeData文件中的案例映射信息将字符（Unicode代码点）参数转换为大写。

        请注意， Character.isUpperCase(Character.toUpperCase(codePoint))并不总是为某些字符范围返回true ，特别是那些符号或表意文字。

        一般来说， String.toUpperCase()应该用来将字符映射成大写。 String案例映射方法比Character案例映射方法有好几个好处。 String案例映射方法可以执行区域设置敏感映射，上下文相关映射和1：M字符映射，而Character案例映射方法不能。

        参数
        codePoint - 要转换的字符（Unicode代码点）。
        结果
        字符的大写字母（如果有的话） 否则，字符本身。
        从以下版本开始：
        1.5
        另请参见：
        isUpperCase(int) ， String.toUpperCase()

      • toTitleCase

        public static char toTitleCase​(char ch)
        使用UnicodeData文件中的案例映射信息将字符参数转换为titlecase。 如果一个字符没有明确的titlecase映射，并且本身不是根据UnicodeData的titlecase char，则大写映射作为等效的titlecase映射返回。 如果char参数已经是一个titlecase char ，相同的char值将被返回。

        请注意， Character.isTitleCase(Character.toTitleCase(ch))并不总是为某些范围的字符返回true 。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用toTitleCase(int)方法。

        参数
        ch - 要转换的字符。
        结果
        如果有的话，相当于这个字符的titlecase; 否则，字符本身。
        从以下版本开始：
        1.0.2
        另请参见：
        isTitleCase(char) ， toLowerCase(char) ， toUpperCase(char)

      • toTitleCase

        public static int toTitleCase​(int codePoint)
        使用UnicodeData文件中的案例映射信息将字符（Unicode代码点）参数转换为titlecase。 如果一个字符没有明确的titlecase映射，并且本身不是根据UnicodeData的titlecase char，则大写映射作为等效的titlecase映射返回。 如果字符参数已经是一个titlecase字符，则返回相同的字符值。

        请注意， Character.isTitleCase(Character.toTitleCase(codePoint))并不总是为某些字符范围返回true 。

        参数
        codePoint - 要转换的字符（Unicode代码点）。
        结果
        如果有的话，相当于这个字符的titlecase; 否则，字符本身。
        从以下版本开始：
        1.5
        另请参见：
        isTitleCase(int) ， toLowerCase(int) ， toUpperCase(int)

      • digit

        public static int digit​(char ch,
                        int radix)
        返回指定基数中的字符ch的数值。

        如果基数不在范围MIN_RADIX â‰¤ radix â‰¤ MAX_RADIX或者价值ch不是指定基数的有效数字， -1返回。 如果以下至少一项为真，则字符为有效数字：

        • 方法isDigit是字符的true ，字符（或其单字符分解）的Unicode十进制数字值小于指定的基数。 在这种情况下，返回十进制数值。
        • 该字符是大写拉丁字母'A'至'Z' ，其代码小于radix + 'A' - 10 。 在这种情况下，返回ch - 'A' + 10 。
        • 该字符是小写拉丁字母'a'至'z' ，其代码小于radix + 'a' - 10 。 在这种情况下，返回ch - 'a' + 10 。
        • 该字符是通过Z（ '\uFF3A' ）的全'\uFF21'写拉丁字母A（ '\uFF21' ） '\uFF3A' ，其代码小于radix + '\uFF21' - 10 。 在这种情况下，返回ch - '\uFF21' + 10 。
        • 该字符是通过z（ '\uFF5A' ）的全宽小写拉丁字母a（ '\uFF41' ） '\uFF5A' ，其代码小于radix + '\uFF41' - 10 。 在这种情况下，返回ch - '\uFF41' + 10 。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用digit(int, int)方法。

        参数
        ch - 要转换的字符。
        radix - 基数。
        结果
        由指定基数中的字符表示的数值。
        另请参见：
        forDigit(int, int) ， isDigit(char)

      • digit

        public static int digit​(int codePoint,
                        int radix)
        返回指定基数中指定字符（Unicode代码点）的数值。

        如果基数不在范围MIN_RADIX â‰¤ radix â‰¤ MAX_RADIX ，或者如果字符不是指定基数的有效数字， -1返回。 如果以下至少一项为真，则字符为有效数字：

        • 方法isDigit(codePoint)是字符的true ，字符（或其单字符分解）的Unicode十进制数字值小于指定的基数。 在这种情况下，返回十进制数值。
        • 该字符是大写拉丁字母'A'至'Z' ，其代码小于radix + 'A' - 10 。 在这种情况下，返回codePoint - 'A' + 10 。
        • 该字符是小写拉丁字母'a'至'z' ，其代码小于radix + 'a' - 10 。 在这种情况下，返回codePoint - 'a' + 10 。
        • 该字符是通过Z（ '\uFF3A' ）的全'\uFF21'写拉丁字母A（ '\uFF21' ） '\uFF3A' ，其代码小于radix + '\uFF21' - 10 。 在这种情况下，返回codePoint - '\uFF21' + 10 。
        • 字符是通过z（ '\uFF5A' ）的全宽小写拉丁字母a（ '\uFF41' ） '\uFF5A' ，其代码小于radix + '\uFF41'- 10 。 在这种情况下，返回codePoint - '\uFF41' + 10 。
        参数
        codePoint - 要转换的字符（Unicode代码点）。
        radix - 基数。
        结果
        由指定基数中的字符表示的数值。
        从以下版本开始：
        1.5
        另请参见：
        forDigit(int, int) ， isDigit(int)

      • getNumericValue

        public static int getNumericValue​(char ch)
        返回指定的Unicode字符代表的值为int 。 例如，字符'\u216C' （罗马数字50）将返回一个值为50的int。

        大写字母（ '\u0041'至'\u005A' ），小写字母（ '\u0061'至'\u007A' ）和全宽变体（ '\uFF21'至'\uFF3A'至'\uFF41'至'\uFF5A' ）中的字母AZ具有10至35的数值。这与Unicode规范无关，其中不为这些char值分配数值。

        如果字符没有数值，则返回-1。 如果字符的数值不能表示为非负整数（例如，小数值），则返回-2。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用getNumericValue(int)方法。

        参数
        ch - 要转换的字符。
        结果
        字符的数值，作为非负值int值; -2如果字符具有数值，但该值不能表示为非负值int值; -1，如果字符没有数值。
        从以下版本开始：
        1.1
        另请参见：
        forDigit(int, int) ， isDigit(char)

      • getNumericValue

        public static int getNumericValue​(int codePoint)
        返回指定字符（Unicode代码点）表示的值为int 。 例如，字符'\u216C' （罗马数字五十）将返回值为50的int 。

        大写字母（ '\u0041'至'\u005A' ），小写（ '\u0061'至'\u007A' ）以及全宽变体（ '\uFF21'至'\uFF3A'和'\uFF41'至'\uFF5A' ）的字母AZ都具有从10到35的数值。这与Unicode规范无关，其中不为这些char值分配数值。

        如果字符没有数值，则返回-1。 如果字符的数值不能表示为非负整数（例如，小数值），则返回-2。

        参数
        codePoint - 要转换的字符（Unicode代码点）。
        结果
        字符的数值，作为非负值int值; -2如果字符具有数值，但该值不能表示为非负int值; -1，如果字符没有数值。
        从以下版本开始：
        1.5
        另请参见：
        forDigit(int, int) ， isDigit(int)

      • isSpace

        @Deprecated(since="1.1")
public static boolean isSpace​(char ch)
        已过时。 替换为isWhitespace（char）。
        确定指定的字符是否为ISO-LATIN-1空格。 此方法仅返回true以下五个字符： truechars '\t' U+0009 HORIZONTAL TABULATION '\n' U+000A NEW LINE '\f' U+000C FORM FEED '\r' U+000D CARRIAGE RETURN ' ' U+0020 SPACE
        参数
        ch - 要测试的字符。
        结果
        true如果字符是ISO-LATIN-1空格; false否则。
        另请参见：
        isSpaceChar(char) ， isWhitespace(char)

      • isSpaceChar

        public static boolean isSpaceChar​(char ch)
        确定指定的字符是否是Unicode空格字符。 当且仅当Unicode标准被指定为空格字符时，才将该字符视为空格字符。 如果字符的一般类别类型是以下任何一种，则此方法返回true：
        • SPACE_SEPARATOR
        • LINE_SEPARATOR
        • PARAGRAPH_SEPARATOR

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用isSpaceChar(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是空格字符; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        isWhitespace(char)

      • isSpaceChar

        public static boolean isSpaceChar​(int codePoint)
        确定指定字符（Unicode代码点）是否为Unicode空格字符。 当且仅当Unicode标准被指定为空格字符时，才将该字符视为空格字符。 如果字符的一般类别类型是以下任何一种，则此方法返回true：
        • SPACE_SEPARATOR
        • LINE_SEPARATOR
        • PARAGRAPH_SEPARATOR
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是空格字符; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isWhitespace(int)

      • isWhitespace

        public static boolean isWhitespace​(char ch)
        根据Java确定指定的字符是否为空格。 当且仅当满足以下条件之一时，字符是Java空格字符：
        • 它是Unicode空格字符（ SPACE_SEPARATOR ， LINE_SEPARATOR ，或PARAGRAPH_SEPARATOR ），但不也是非打破空间（ '\u00A0' ， '\u2007' ， '\u202F' ）。
        • 是'\t' ，U + 0009水平仪。
        • 是'\n' ，U + 000A LINE FEED。
        • 是'\u000B' ，U + 000B垂直式。
        • 是'\f' ，U + 000C FORM FEED。
        • 是'\r' ，U + 000D '\r' RETURN。
        • 是'\u001C' ，U + 001C文件分离器。
        • 是'\u001D' ，U + 001D GROUP '\u001D' 。
        • 是'\u001E' ，U + 001E RECORD分隔器。
        • 是'\u001F' ，U + 001F UNIT SEPARATOR。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isWhitespace(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是Java空格字符; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        isSpaceChar(char)

      • isWhitespace

        public static boolean isWhitespace​(int codePoint)
        根据Java确定指定字符（Unicode代码点）是否为空格。 当且仅当满足以下条件之一时，字符是Java空格字符：
        • 它是Unicode空格字符（ SPACE_SEPARATOR ， LINE_SEPARATOR ，或PARAGRAPH_SEPARATOR ），但不也是非打破空间（ '\u00A0' ， '\u2007' ， '\u202F' ）。
        • 是'\t' ，U + 0009水平仪。
        • 是'\n' ，U + 000A LINE FEED。
        • 是'\u000B' ，U + 000B垂直'\u000B' 。
        • 是'\f' ，U + 000C FORM FEED。
        • 是'\r' ，U + 000D运输返回。
        • 是'\u001C' ，U + 001C文件分离器。
        • 是'\u001D' ，U + 001D GROUP '\u001D' 。
        • 是'\u001E' ，U + 001E RECORD分隔器。
        • 是'\u001F' ，U + 001F UNIT SEPARATOR。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是Java空格字符; false否则。
        从以下版本开始：
        1.5
        另请参见：
        isSpaceChar(int)

      • isISOControl

        public static boolean isISOControl​(char ch)
        确定指定的字符是否是ISO控制字符。 一个字符被认为如果其代码是在范围为ISO控制字符'\u0000'通过'\u001F'或在范围'\u007F'通过'\u009F' 。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用isISOControl(int)方法。

        参数
        ch - 要测试的字符。
        结果
        true如果字符是ISO控制字符; 否则为false 。
        从以下版本开始：
        1.1
        另请参见：
        isSpaceChar(char) ， isWhitespace(char)

      • isISOControl

        public static boolean isISOControl​(int codePoint)
        确定引用的字符（Unicode代码点）是否是ISO控制字符。 一个字符被认为如果其代码是在范围为ISO控制字符'\u0000'通过'\u001F'或在范围'\u007F'通过'\u009F' 。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符是ISO控制字符; 否则为false 。
        从以下版本开始：
        1.5
        另请参见：
        isSpaceChar(int) ， isWhitespace(int)

      • getType

        public static int getType​(char ch)
        返回一个值，表示一个字符的一般类别。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用getType(int)方法。

        参数
        ch - 要测试的字符。
        结果
        表示字符的一般类别的类型为 int的值。
        从以下版本开始：
        1.1
        另请参见：
        COMBINING_SPACING_MARK ， CONNECTOR_PUNCTUATION ， CONTROL ， CURRENCY_SYMBOL ， DASH_PUNCTUATION ， DECIMAL_DIGIT_NUMBER ， ENCLOSING_MARK ， END_PUNCTUATION ， FINAL_QUOTE_PUNCTUATION ， FORMAT ， INITIAL_QUOTE_PUNCTUATION ， LETTER_NUMBER ， LINE_SEPARATOR ， LOWERCASE_LETTER ， MATH_SYMBOL ， MODIFIER_LETTER ， MODIFIER_SYMBOL ， NON_SPACING_MARK ， OTHER_LETTER ， OTHER_NUMBER ， OTHER_PUNCTUATION ， OTHER_SYMBOL ， PARAGRAPH_SEPARATOR ， PRIVATE_USE ， SPACE_SEPARATOR ， START_PUNCTUATION ， SURROGATE ， TITLECASE_LETTER ， UNASSIGNED ， UPPERCASE_LETTER

      • getType

        public static int getType​(int codePoint)
        返回一个值，表示一个字符的一般类别。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        表示字符的一般类别的类型为 int的值。
        从以下版本开始：
        1.5
        另请参见：
        COMBINING_SPACING_MARK ， CONNECTOR_PUNCTUATION ， CONTROL ， CURRENCY_SYMBOL ， DASH_PUNCTUATION ， DECIMAL_DIGIT_NUMBER ， ENCLOSING_MARK ， END_PUNCTUATION ， FINAL_QUOTE_PUNCTUATION ， FORMAT ， INITIAL_QUOTE_PUNCTUATION ， LETTER_NUMBER ， LINE_SEPARATOR ， LOWERCASE_LETTER ， MATH_SYMBOL ， MODIFIER_LETTER ， MODIFIER_SYMBOL ， NON_SPACING_MARK ， OTHER_LETTER ， OTHER_NUMBER ， OTHER_PUNCTUATION ， OTHER_SYMBOL ， PARAGRAPH_SEPARATOR ， PRIVATE_USE ， SPACE_SEPARATOR ， START_PUNCTUATION ， SURROGATE ， TITLECASE_LETTER ， UNASSIGNED ， UPPERCASE_LETTER

      • forDigit

        public static char forDigit​(int digit,
                            int radix)
        确定指定基数中特定数字的字符表示。 如果radix的值不是有效的基数，或者digit的值不是指定基数中的有效数字，则返回空字符（ '\u0000' ）。

        该radix参数是有效的，如果它是大于或等于MIN_RADIX且小于或等于MAX_RADIX 。 digit参数是有效的，如果是0 <= digit < radix 。

        如果数字小于10，则返回'0' + digit 。 否则返回值'a' + digit - 10 。

        参数
        digit - 转换为字符的数字。
        radix - 基数。
        结果
        指定基数的指定数字的 char表示。
        另请参见：
        MIN_RADIX ， MAX_RADIX ， digit(char, int)

      • getDirectionality

        public static byte getDirectionality​(char ch)
        返回给定字符的Unicode方向属性。 字符方向性用于计算文本的视觉排序。 未定义char值的方向性值为DIRECTIONALITY_UNDEFINED 。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符（包括补充字符），请使用getDirectionality(int)方法。

        参数
        ch - char ，其要求方向属性。
        结果
        方向性属性为 char价值。
        从以下版本开始：
        1.4
        另请参见：
        DIRECTIONALITY_UNDEFINED ， DIRECTIONALITY_LEFT_TO_RIGHT ， DIRECTIONALITY_RIGHT_TO_LEFT ， DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC ， DIRECTIONALITY_EUROPEAN_NUMBER ， DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR ， DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR ， DIRECTIONALITY_ARABIC_NUMBER ， DIRECTIONALITY_COMMON_NUMBER_SEPARATOR ， DIRECTIONALITY_NONSPACING_MARK ， DIRECTIONALITY_BOUNDARY_NEUTRAL ， DIRECTIONALITY_PARAGRAPH_SEPARATOR ， DIRECTIONALITY_SEGMENT_SEPARATOR ， DIRECTIONALITY_WHITESPACE ， DIRECTIONALITY_OTHER_NEUTRALS ， DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING ， DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE ， DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING ， DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE ， DIRECTIONALITY_POP_DIRECTIONAL_FORMAT ， DIRECTIONALITY_LEFT_TO_RIGHT_ISOLATE ， DIRECTIONALITY_RIGHT_TO_LEFT_ISOLATE ， DIRECTIONALITY_FIRST_STRONG_ISOLATE ， DIRECTIONALITY_POP_DIRECTIONAL_ISOLATE

      • getDirectionality

        public static byte getDirectionality​(int codePoint)
        返回给定字符的Unicode方向性属性（Unicode代码点）。 字符方向性用于计算文本的视觉排序。 未定义字符的方向性值为DIRECTIONALITY_UNDEFINED 。
        参数
        codePoint - 请求方向属性的字符（Unicode代码点）。
        结果
        角色的方向性。
        从以下版本开始：
        1.5
        另请参见：
        DIRECTIONALITY_UNDEFINED ， DIRECTIONALITY_LEFT_TO_RIGHT ， DIRECTIONALITY_RIGHT_TO_LEFT ， DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC ， DIRECTIONALITY_EUROPEAN_NUMBER ， DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR ， DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR ， DIRECTIONALITY_ARABIC_NUMBER ， DIRECTIONALITY_COMMON_NUMBER_SEPARATOR ， DIRECTIONALITY_NONSPACING_MARK ， DIRECTIONALITY_BOUNDARY_NEUTRAL ， DIRECTIONALITY_PARAGRAPH_SEPARATOR ， DIRECTIONALITY_SEGMENT_SEPARATOR ， DIRECTIONALITY_WHITESPACE ， DIRECTIONALITY_OTHER_NEUTRALS ， DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING ， DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE ， DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING ， DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE ， DIRECTIONALITY_POP_DIRECTIONAL_FORMAT ， DIRECTIONALITY_LEFT_TO_RIGHT_ISOLATE ， DIRECTIONALITY_RIGHT_TO_LEFT_ISOLATE ， DIRECTIONALITY_FIRST_STRONG_ISOLATE ， DIRECTIONALITY_POP_DIRECTIONAL_ISOLATE

      • isMirrored

        public static boolean isMirrored​(char ch)
        根据Unicode规范确定字符是否镜像。 当从右到左的文本中显示时，镜像字符应具有水平镜像的字形。 例如， '\u0028' LEFT PARENTHESIS在语义上被定义为一个开始的括号 。 在右到左的文本中，这将显示为“（”在文本中是从左到右，但作为“）”。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用isMirrored(int)方法。

        参数
        ch - char ，请求镜像属性
        结果
        true如果char被镜像，则 false如果 char未镜像或未定义。
        从以下版本开始：
        1.4

      • isMirrored

        public static boolean isMirrored​(int codePoint)
        确定是否根据Unicode规范镜像指定的字符（Unicode代码点）。 当从右到左的文本中显示时，镜像字符应具有水平镜像的字形。 例如， '\u0028' LEFT PARENTHESIS在语义上被定义为开始的括号 。 在右到左的文本中，这将显示为“（”在文本中是从左到右，但作为“）”。
        参数
        codePoint - 要测试的字符（Unicode代码点）。
        结果
        true如果字符被镜像， false如果字符未镜像或未定义。
        从以下版本开始：
        1.5

      • compareTo

        public int compareTo​(Character anotherCharacter)
        数字比较两个 Character对象。
        Specified by:
        compareTo在接口 Comparable<Character>
        参数
        anotherCharacter - 要比较的 Character 。
        结果
        值0如果参数Character等于这个Character ; 一个值小于0如果这个Character在数字上小于Character参数; 和大于一个值0 ，如果这Character在数值上比越大Character参数（无符号比较）。 请注意，这是严格的数值比较; 它不是区域设置相关的。
        从以下版本开始：
        1.2

      • compare

        public static int compare​(char x,
                          char y)
        数值比较两个char 。 返回的值与以下内容相同：
          Character.valueOf(x).compareTo(Character.valueOf(y))
        参数
        x char
        y - 第二个 char进行比较
        结果
        价值0如果是x == y ; 一个值小于0如果是x < y ; 新新0 x > y
        从以下版本开始：
        1.7

      • reverseBytes

        public static char reverseBytes​(char ch)
        返回通过反转指定的 char值中的字节顺序获得的值。
        参数
        ch - 其中的 char反转字节顺序。
        结果
        通过在指定的 char值中反转（或等效地交换）字节获得的值。
        从以下版本开始：
        1.5

      • getName

        public static String getName​(int codePoint)
        返回指定字符的Unicode名称codePoint ，如果代码点为unassigned ，则返回null。

        注意：如果指定的字符未由UnicodeData文件（Unicode Consortium维护的Unicode字符数据库的一部分）分配名称，则返回的名称与表达式的结果相同。

        Character.UnicodeBlock.of(codePoint).toString().replace('_', ' ') + " " + Integer.toHexString(codePoint).toUpperCase(Locale.ROOT);
        参数
        codePoint - 字符（Unicode码点）
        结果
        指定字符的Unicode名称，如果代码点未分配，则为null。
        异常
        IllegalArgumentException - 如果指定的 codePoint不是有效的Unicode代码点。
        从以下版本开始：
        1.7

      • codePointOf

        public static int codePointOf​(String name)
        返回由给定的Unicode字符名称指定的Unicode字符的代码点值。

        注意：如果UnicodeData文件（由Unicode Consortium维护的Unicode字符数据库的一部分）未分配字符，则其名称将被定义为表达式的结果

        Character.UnicodeBlock.of(codePoint).toString().replace('_', ' ') + " " + Integer.toHexString(codePoint).toUpperCase(Locale.ROOT);

        name匹配不区分大小写，删除任何前导和尾随空格。

        参数
        name - Unicode字符名称
        结果
        由其名称指定的字符的代码点值。
        异常
        IllegalArgumentException - 如果指定的 name不是有效的Unicode字符名称。
        NullPointerException - 如果 name是 null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Character.Subset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Character.Subset

  • java.lang.Object
    • java.lang.Character.Subset
  • 已知直接子类：
    Character.UnicodeBlock ， InputSubset
    Enclosing class:
    Character

    public static class Character.Subset
extends Object
    该类的实例表示Unicode字符集的特定子集。 Character类中唯一定义的子集是Character.UnicodeBlock 。 Java API的其他部分可以为自己的目的定义其他子集。
    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Subset​(String name)
      构造一个新的 Subset实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      比较两个 Subset对象的相等性。
      int hashCode​()
      返回由 Object.hashCode()方法定义的标准哈希码。
      String toString​()
      返回此子集的名称。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Subset

        protected Subset​(String name)
        构造一个新的 Subset实例。
        参数
        name - 此子集的名称
        异常
        NullPointerException - 如果名字是 null

    • 方法详细信息

      • equals

        public final boolean equals​(Object obj)
        比较两个Subset对象的相等性。 当且仅当this和参数引用相同的对象时，此方法返回true ; 由于此方法为final ，因此该保证适用于所有子类。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public final int hashCode​()
        返回由Object.hashCode()方法定义的标准哈希码。 这种方法是final ，以确保equals和hashCode方法在所有子类中都是一致的。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public final String toString​()
        返回此子集的名称。
        重写：
        toString在类 Object
        结果
        对象的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Character.UnicodeBlock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Character.UnicodeBlock

  • java.lang.Object
    • java.lang.Character.Subset
      • java.lang.Character.UnicodeBlock
  • Enclosing class:
    Character

    public static final class Character.UnicodeBlock
extends Character.Subset
    一系列字符子集，表示Unicode规范中的字符块。 字符块通常定义用于特定脚本或目的的字符。 一个字符最多包含一个Unicode块。
    从以下版本开始：
    1.2

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Character.UnicodeBlock AEGEAN_NUMBERS
      “爱琴海数字”Unicode字符块的常数。
      static Character.UnicodeBlock AHOM
      “Ahom”Unicode字符块的常数。
      static Character.UnicodeBlock ALCHEMICAL_SYMBOLS
      常数为“Alchemical Symbols”Unicode字符块。
      static Character.UnicodeBlock ALPHABETIC_PRESENTATION_FORMS
      “字母表示形式”Unicode字符块的常量。
      static Character.UnicodeBlock ANATOLIAN_HIEROGLYPHS
      “安纳托利亚象形文字”Unicode字符块的常数。
      static Character.UnicodeBlock ANCIENT_GREEK_MUSICAL_NOTATION
      常规为“古希腊音乐符号”Unicode字符块。
      static Character.UnicodeBlock ANCIENT_GREEK_NUMBERS
      常数为“古希腊数字”Unicode字符块。
      static Character.UnicodeBlock ANCIENT_SYMBOLS
      “古代符号”Unicode字符块的常数。
      static Character.UnicodeBlock ARABIC
      “阿拉伯语”Unicode字符块的常量。
      static Character.UnicodeBlock ARABIC_EXTENDED_A
      “阿拉伯语扩展A”Unicode字符块的常量。
      static Character.UnicodeBlock ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS
      常数为“阿拉伯数学字母符号”Unicode字符块。
      static Character.UnicodeBlock ARABIC_PRESENTATION_FORMS_A
      “阿拉伯文表达式A”Unicode字符块的常量。
      static Character.UnicodeBlock ARABIC_PRESENTATION_FORMS_B
      “阿拉伯语表达式B”Unicode字符块的常量。
      static Character.UnicodeBlock ARABIC_SUPPLEMENT
      “阿拉伯语补充”Unicode字符块的常量。
      static Character.UnicodeBlock ARMENIAN
      “亚美尼亚”Unicode字符块的常数。
      static Character.UnicodeBlock ARROWS
      常量为“箭头”Unicode字符块。
      static Character.UnicodeBlock AVESTAN
      “Avestan”Unicode字符块的常数。
      static Character.UnicodeBlock BALINESE
      “巴厘岛”Unicode字符块的常数。
      static Character.UnicodeBlock BAMUM
      “Bamum”Unicode字符块的常量。
      static Character.UnicodeBlock BAMUM_SUPPLEMENT
      “Bamum Supplement”Unicode字符块的常量。
      static Character.UnicodeBlock BASIC_LATIN
      Unicode基本字符块的常数。
      static Character.UnicodeBlock BASSA_VAH
      常数为“Bassa Vah”Unicode字符块。
      static Character.UnicodeBlock BATAK
      “Batak”Unicode字符块的常量。
      static Character.UnicodeBlock BENGALI
      “孟加拉语”Unicode字符块的常数。
      static Character.UnicodeBlock BLOCK_ELEMENTS
      常量为“块元素”Unicode字符块。
      static Character.UnicodeBlock BOPOMOFO
      “Bopomofo”Unicode字符块的常量。
      static Character.UnicodeBlock BOPOMOFO_EXTENDED
      “Bopomofo Extended”Unicode字符块的常量。
      static Character.UnicodeBlock BOX_DRAWING
      常量为“框图”Unicode字符块。
      static Character.UnicodeBlock BRAHMI
      “Brahmi”Unicode字符块的常量。
      static Character.UnicodeBlock BRAILLE_PATTERNS
      “盲文图案”Unicode字符块的常数。
      static Character.UnicodeBlock BUGINESE
      “Buginese”Unicode字符块的常数。
      static Character.UnicodeBlock BUHID
      “Buhid”Unicode字符块的常量。
      static Character.UnicodeBlock BYZANTINE_MUSICAL_SYMBOLS
      常数为“拜占庭式音乐符号”Unicode字符块。
      static Character.UnicodeBlock CARIAN
      “Carian”Unicode字符块的常量。
      static Character.UnicodeBlock CAUCASIAN_ALBANIAN
      “阿尔巴尼亚白人”Unicode字符块的常数。
      static Character.UnicodeBlock CHAKMA
      “Chakma”Unicode字符块的常量。
      static Character.UnicodeBlock CHAM
      “Cham”Unicode字符块的常量。
      static Character.UnicodeBlock CHEROKEE
      常数为“切诺基”Unicode字符块。
      static Character.UnicodeBlock CHEROKEE_SUPPLEMENT
      常数为“切诺基补充”Unicode字符块。
      static Character.UnicodeBlock CJK_COMPATIBILITY
      常量为“CJK兼容性”Unicode字符块。
      static Character.UnicodeBlock CJK_COMPATIBILITY_FORMS
      “CJK兼容性表单”Unicode字符块的常量。
      static Character.UnicodeBlock CJK_COMPATIBILITY_IDEOGRAPHS
      “CJK兼容性表意符号”Unicode字符块的常量。
      static Character.UnicodeBlock CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT
      “CJK兼容性表意文字补充”Unicode字符块的常数。
      static Character.UnicodeBlock CJK_RADICALS_SUPPLEMENT
      常数为“CJK Radicals Supplement”Unicode字符块。
      static Character.UnicodeBlock CJK_STROKES
      常量为“CJK笔画”Unicode字符块。
      static Character.UnicodeBlock CJK_SYMBOLS_AND_PUNCTUATION
      常量为“CJK符号和标点符号”Unicode字符块。
      static Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS
      “CJK统一表意符号”Unicode字符块的常数。
      static Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A
      “CJK统一表意扩展A”Unicode字符块的常数。
      static Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B
      “CJK统一表意扩展B”Unicode字符块的常数。
      static Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C
      “CJK统一表意扩展C”Unicode字符块的常数。
      static Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D
      “CJK统一表意扩展D”Unicode字符块的常数。
      static Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_E
      “CJK统一表意扩展E”Unicode字符块的常数。
      static Character.UnicodeBlock COMBINING_DIACRITICAL_MARKS
      “组合变音符号”Unicode字符块的常数。
      static Character.UnicodeBlock COMBINING_DIACRITICAL_MARKS_EXTENDED
      Unicode字符块的“组合变音符号扩展”的常数。
      static Character.UnicodeBlock COMBINING_DIACRITICAL_MARKS_SUPPLEMENT
      Unicode字符块的“组合变音符号补充”的常数。
      static Character.UnicodeBlock COMBINING_HALF_MARKS
      Unicode字符块的“组合半标记”的常量。
      static Character.UnicodeBlock COMBINING_MARKS_FOR_SYMBOLS
      Unicode字符块的“组合符号变音符号”的常量。
      static Character.UnicodeBlock COMMON_INDIC_NUMBER_FORMS
      “常用印数字”表示Unicode字符块的常数。
      static Character.UnicodeBlock CONTROL_PICTURES
      “控制图片”Unicode字符块的常量。
      static Character.UnicodeBlock COPTIC
      “科普特”Unicode字符块的常数。
      static Character.UnicodeBlock COPTIC_EPACT_NUMBERS
      常规为“科普特数字”Unicode字符块。
      static Character.UnicodeBlock COUNTING_ROD_NUMERALS
      常数为“计数杆号”Unicode字符块。
      static Character.UnicodeBlock CUNEIFORM
      “Cuneiform”Unicode字符块的常数。
      static Character.UnicodeBlock CUNEIFORM_NUMBERS_AND_PUNCTUATION
      “Cuneiform数字和标点符号”Unicode字符块的常数。
      static Character.UnicodeBlock CURRENCY_SYMBOLS
      Unicode字符块的“货币符号”的常量。
      static Character.UnicodeBlock CYPRIOT_SYLLABARY
      “塞浦路字母”Unicode字符块的常数。
      static Character.UnicodeBlock CYRILLIC
      “西里尔”Unicode字符块的常数。
      static Character.UnicodeBlock CYRILLIC_EXTENDED_A
      “西里尔扩展A”Unicode字符块的常量。
      static Character.UnicodeBlock CYRILLIC_EXTENDED_B
      “西里尔扩展B”Unicode字符块的常量。
      static Character.UnicodeBlock CYRILLIC_SUPPLEMENTARY
      “西里尔语补充”Unicode字符块的常数。
      static Character.UnicodeBlock DESERET
      “Deseret”Unicode字符块的常量。
      static Character.UnicodeBlock DEVANAGARI
      “Devanagari”Unicode字符块的常量。
      static Character.UnicodeBlock DEVANAGARI_EXTENDED
      “梵文扩展”Unicode字符块的常量。
      static Character.UnicodeBlock DINGBATS
      “Dingbats”Unicode字符块的常量。
      static Character.UnicodeBlock DOMINO_TILES
      “Domino Tiles”Unicode字符块的常量。
      static Character.UnicodeBlock DUPLOYAN
      “Duployan”Unicode字符块的常量。
      static Character.UnicodeBlock EARLY_DYNASTIC_CUNEIFORM
      常数为“早期楔形文字”Unicode字符块。
      static Character.UnicodeBlock EGYPTIAN_HIEROGLYPHS
      “埃及象形文字”Unicode字符块的常数。
      static Character.UnicodeBlock ELBASAN
      常数为“Elbasan”Unicode字符块。
      static Character.UnicodeBlock EMOTICONS
      常量为“表情符号”Unicode字符块。
      static Character.UnicodeBlock ENCLOSED_ALPHANUMERIC_SUPPLEMENT
      “封闭的字母数字补充”Unicode字符块的常量。
      static Character.UnicodeBlock ENCLOSED_ALPHANUMERICS
      “封闭字母数字”Unicode字符块的常数。
      static Character.UnicodeBlock ENCLOSED_CJK_LETTERS_AND_MONTHS
      “封闭的CJK字母和月”Unicode字符块的常量。
      static Character.UnicodeBlock ENCLOSED_IDEOGRAPHIC_SUPPLEMENT
      “封闭式表意补充”Unicode字符块的常量。
      static Character.UnicodeBlock ETHIOPIC
      “埃塞俄比亚”Unicode字符块的常数。
      static Character.UnicodeBlock ETHIOPIC_EXTENDED
      “埃塞俄比亚扩展”Unicode字符块的常量。
      static Character.UnicodeBlock ETHIOPIC_EXTENDED_A
      “埃塞俄比亚扩展A”Unicode字符块的常量。
      static Character.UnicodeBlock ETHIOPIC_SUPPLEMENT
      “埃塞俄比亚补编”Unicode字符块的常数。
      static Character.UnicodeBlock GENERAL_PUNCTUATION
      常规为“一般标点符号”Unicode字符块。
      static Character.UnicodeBlock GEOMETRIC_SHAPES
      “几何形状”Unicode字符块的常量。
      static Character.UnicodeBlock GEOMETRIC_SHAPES_EXTENDED
      “几何形状扩展”Unicode字符块的常数。
      static Character.UnicodeBlock GEORGIAN
      “格式”Unicode字符块的常数。
      static Character.UnicodeBlock GEORGIAN_SUPPLEMENT
      “格鲁吉亚补编”Unicode字符块的常数。
      static Character.UnicodeBlock GLAGOLITIC
      “Glagolitic”Unicode字符块的常量。
      static Character.UnicodeBlock GOTHIC
      “哥特式”Unicode字符块的常数。
      static Character.UnicodeBlock GRANTHA
      “Grantha”Unicode字符块的常量。
      static Character.UnicodeBlock GREEK
      “希腊和科普特”Unicode字符块的常数。
      static Character.UnicodeBlock GREEK_EXTENDED
      “希腊语扩展”Unicode字符块的常量。
      static Character.UnicodeBlock GUJARATI
      “古吉拉特文”Unicode字符块的常数。
      static Character.UnicodeBlock GURMUKHI
      常数为“古尔穆基”Unicode字符块。
      static Character.UnicodeBlock HALFWIDTH_AND_FULLWIDTH_FORMS
      Unicode字符块的“半宽和全宽”的常量。
      static Character.UnicodeBlock HANGUL_COMPATIBILITY_JAMO
      “Hanul兼容性Jamo”Unicode字符块的常量。
      static Character.UnicodeBlock HANGUL_JAMO
      “Hanul Jamo”Unicode字符块的常数。
      static Character.UnicodeBlock HANGUL_JAMO_EXTENDED_A
      “Hanul Jamo Extended-A”Unicode字符块的常数。
      static Character.UnicodeBlock HANGUL_JAMO_EXTENDED_B
      “Hanul Jamo Extended-B”Unicode字符块的常数。
      static Character.UnicodeBlock HANGUL_SYLLABLES
      “汉字音节”Unicode字符块的常数。
      static Character.UnicodeBlock HANUNOO
      “Hanunoo”Unicode字符块的常量。
      static Character.UnicodeBlock HATRAN
      “Hatran”Unicode字符块的常量。
      static Character.UnicodeBlock HEBREW
      “希伯来语”Unicode字符块的常量。
      static Character.UnicodeBlock HIGH_PRIVATE_USE_SURROGATES
      “高私人使用代理”Unicode字符块的常量。
      static Character.UnicodeBlock HIGH_SURROGATES
      常数为“高代理”Unicode字符块。
      static Character.UnicodeBlock HIRAGANA
      “Hiragana”Unicode字符块的常量。
      static Character.UnicodeBlock IDEOGRAPHIC_DESCRIPTION_CHARACTERS
      Unicode字符块的“表意描述字符”的常量。
      static Character.UnicodeBlock IMPERIAL_ARAMAIC
      “皇家阿拉姆语”Unicode字符块的常数。
      static Character.UnicodeBlock INSCRIPTIONAL_PAHLAVI
      常数为“Inscriptional Pahlavi”Unicode字符块。
      static Character.UnicodeBlock INSCRIPTIONAL_PARTHIAN
      “Inscriptional Parthian”Unicode字符块的常数。
      static Character.UnicodeBlock IPA_EXTENSIONS
      “IPA扩展”Unicode字符块的常量。
      static Character.UnicodeBlock JAVANESE
      “爪哇”Unicode字符块的常量。
      static Character.UnicodeBlock KAITHI
      “Kaithi”Unicode字符块的常数。
      static Character.UnicodeBlock KANA_SUPPLEMENT
      “假名补充”Unicode字符块的常数。
      static Character.UnicodeBlock KANBUN
      “Kanbun”Unicode字符块的常量。
      static Character.UnicodeBlock KANGXI_RADICALS
      常数为“康熙激进”Unicode字符块。
      static Character.UnicodeBlock KANNADA
      “Kannada”Unicode字符块的常量。
      static Character.UnicodeBlock KATAKANA
      “片假名”Unicode字符块的常数。
      static Character.UnicodeBlock KATAKANA_PHONETIC_EXTENSIONS
      “片假名语音扩展”Unicode字符块的常数。
      static Character.UnicodeBlock KAYAH_LI
      常数为“Kayah Li”Unicode字符块。
      static Character.UnicodeBlock KHAROSHTHI
      “Kharoshthi”Unicode字符块的常数。
      static Character.UnicodeBlock KHMER
      “高棉”Unicode字符块的常数。
      static Character.UnicodeBlock KHMER_SYMBOLS
      “高棉符号”Unicode字符块的常数。
      static Character.UnicodeBlock KHOJKI
      “Khojki”Unicode字符块的常数。
      static Character.UnicodeBlock KHUDAWADI
      “Khudawadi”Unicode字符块的常量。
      static Character.UnicodeBlock LAO
      常数为“老挝”Unicode字符块。
      static Character.UnicodeBlock LATIN_1_SUPPLEMENT
      “Latin-1 Supplement”Unicode字符块的常数。
      static Character.UnicodeBlock LATIN_EXTENDED_A
      “Latin Extended-A”Unicode字符块的常量。
      static Character.UnicodeBlock LATIN_EXTENDED_ADDITIONAL
      “拉丁扩展附加”Unicode字符块的常量。
      static Character.UnicodeBlock LATIN_EXTENDED_B
      “拉丁扩展B”Unicode字符块的常量。
      static Character.UnicodeBlock LATIN_EXTENDED_C
      “拉丁扩展C”Unicode字符块的常量。
      static Character.UnicodeBlock LATIN_EXTENDED_D
      “拉丁扩展D”Unicode字符块的常数。
      static Character.UnicodeBlock LATIN_EXTENDED_E
      “拉丁扩展E”Unicode字符块的常量。
      static Character.UnicodeBlock LEPCHA
      “Lepcha”Unicode字符块的常数。
      static Character.UnicodeBlock LETTERLIKE_SYMBOLS
      Unicode字符块的“字母符号”的常量。
      static Character.UnicodeBlock LIMBU
      “Limbu”Unicode字符块的常量。
      static Character.UnicodeBlock LINEAR_A
      “线性A”Unicode字符块的常量。
      static Character.UnicodeBlock LINEAR_B_IDEOGRAMS
      “线性B表意符号”Unicode字符块的常数。
      static Character.UnicodeBlock LINEAR_B_SYLLABARY
      “线性B音节”Unicode字符块的常数。
      static Character.UnicodeBlock LISU
      “Lisu”Unicode字符块的常量。
      static Character.UnicodeBlock LOW_SURROGATES
      “低代理”Unicode字符块的常数。
      static Character.UnicodeBlock LYCIAN
      “Lycian”Unicode字符块的常数。
      static Character.UnicodeBlock LYDIAN
      常数为“Lydian”Unicode字符块。
      static Character.UnicodeBlock MAHAJANI
      “Mahajani”Unicode字符块的常数。
      static Character.UnicodeBlock MAHJONG_TILES
      “麻将瓷砖”Unicode字符块的常数。
      static Character.UnicodeBlock MALAYALAM
      “马拉雅拉姆”Unicode字符块的常量。
      static Character.UnicodeBlock MANDAIC
      常数为“Mandaic”Unicode字符块。
      static Character.UnicodeBlock MANICHAEAN
      “Manichaean”Unicode字符块的常量。
      static Character.UnicodeBlock MATHEMATICAL_ALPHANUMERIC_SYMBOLS
      “数学字母数字符号”Unicode字符块的常数。
      static Character.UnicodeBlock MATHEMATICAL_OPERATORS
      常数为“数学运算符”Unicode字符块。
      static Character.UnicodeBlock MEETEI_MAYEK
      “Meetei Mayek”Unicode字符块的常数。
      static Character.UnicodeBlock MEETEI_MAYEK_EXTENSIONS
      “Meetei Mayek Extensions”Unicode字符块的常数。
      static Character.UnicodeBlock MENDE_KIKAKUI
      常数为“Mende Kikakui”Unicode字符块。
      static Character.UnicodeBlock MEROITIC_CURSIVE
      “Meroitic Cursive”Unicode字符块的常量。
      static Character.UnicodeBlock MEROITIC_HIEROGLYPHS
      “Meroitic象形文字”Unicode字符块的常数。
      static Character.UnicodeBlock MIAO
      常量为“Miao”Unicode字符块。
      static Character.UnicodeBlock MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A
      “Miscellaneous Mathematical Symbols-A”Unicode字符块的常数。
      static Character.UnicodeBlock MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B
      “Miscellaneous Mathematical Symbols-B”Unicode字符块的常数。
      static Character.UnicodeBlock MISCELLANEOUS_SYMBOLS
      “杂项符号”Unicode字符块的常量。
      static Character.UnicodeBlock MISCELLANEOUS_SYMBOLS_AND_ARROWS
      “杂项符号和箭头”Unicode字符块的常量。
      static Character.UnicodeBlock MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS
      “Miscellaneous Symbols and Pictographs”Unicode字符块的常数。
      static Character.UnicodeBlock MISCELLANEOUS_TECHNICAL
      “杂项技术”Unicode字符块的常数。
      static Character.UnicodeBlock MODI
      “Modi”Unicode字符块的常量。
      static Character.UnicodeBlock MODIFIER_TONE_LETTERS
      “Modifier Tone Letters”Unicode字符块的常数。
      static Character.UnicodeBlock MONGOLIAN
      “蒙古”Unicode字符块的常数。
      static Character.UnicodeBlock MRO
      “Mro”Unicode字符块的常量。
      static Character.UnicodeBlock MULTANI
      “Multani”Unicode字符块的常量。
      static Character.UnicodeBlock MUSICAL_SYMBOLS
      常数为“音符”Unicode字符块。
      static Character.UnicodeBlock MYANMAR
      常数为“缅甸”Unicode字符块。
      static Character.UnicodeBlock MYANMAR_EXTENDED_A
      “Myanmar Extended-A”Unicode字符块的常数。
      static Character.UnicodeBlock MYANMAR_EXTENDED_B
      “缅甸扩展B”Unicode字符块的常量。
      static Character.UnicodeBlock NABATAEAN
      “Nabataean”Unicode字符块的常数。
      static Character.UnicodeBlock NEW_TAI_LUE
      “新泰乐”Unicode字符块的常数。
      static Character.UnicodeBlock NKO
      “NKo”Unicode字符块的常数。
      static Character.UnicodeBlock NUMBER_FORMS
      “数字形式”Unicode字符块的常量。
      static Character.UnicodeBlock OGHAM
      “Ogham”Unicode字符块的常量。
      static Character.UnicodeBlock OL_CHIKI
      “Ol Chiki”Unicode字符块的常量。
      static Character.UnicodeBlock OLD_HUNGARIAN
      “古匈牙利”Unicode字符块的常数。
      static Character.UnicodeBlock OLD_ITALIC
      “旧斜体”Unicode字符块的常量。
      static Character.UnicodeBlock OLD_NORTH_ARABIAN
      常数为“旧北阿拉伯”Unicode字符块。
      static Character.UnicodeBlock OLD_PERMIC
      “Old Permic”Unicode字符块的常量。
      static Character.UnicodeBlock OLD_PERSIAN
      “老波斯”Unicode字符块的常数。
      static Character.UnicodeBlock OLD_SOUTH_ARABIAN
      “旧南阿拉伯”Unicode字符块的常数。
      static Character.UnicodeBlock OLD_TURKIC
      常数为“古突厥语”Unicode字符块。
      static Character.UnicodeBlock OPTICAL_CHARACTER_RECOGNITION
      Unicode字符块的“光学字符识别”常数。
      static Character.UnicodeBlock ORIYA
      “Oriya”Unicode字符块的常量。
      static Character.UnicodeBlock ORNAMENTAL_DINGBATS
      “Ornamental Dingbats”Unicode字符块的常数。
      static Character.UnicodeBlock OSMANYA
      常量为“Osmanya”Unicode字符块。
      static Character.UnicodeBlock PAHAWH_HMONG
      “Pahawh Hmong”Unicode字符块的常量。
      static Character.UnicodeBlock PALMYRENE
      常数为“棕榈”Unicode字符块。
      static Character.UnicodeBlock PAU_CIN_HAU
      “Pau Cin Hau”Unicode字符块的常数。
      static Character.UnicodeBlock PHAGS_PA
      “Phags-pa”Unicode字符块的常数。
      static Character.UnicodeBlock PHAISTOS_DISC
      “Phaistos Disc”Unicode字符块的常量。
      static Character.UnicodeBlock PHOENICIAN
      “腓尼基”Unicode字符块的常数。
      static Character.UnicodeBlock PHONETIC_EXTENSIONS
      常量为“语音扩展”Unicode字符块。
      static Character.UnicodeBlock PHONETIC_EXTENSIONS_SUPPLEMENT
      “语音扩展补充”Unicode字符块的常数。
      static Character.UnicodeBlock PLAYING_CARDS
      常规为“纸牌”Unicode字符块。
      static Character.UnicodeBlock PRIVATE_USE_AREA
      “私用区域”Unicode字符块的常量。
      static Character.UnicodeBlock PSALTER_PAHLAVI
      “Psalter Pahlavi”Unicode字符块的常数。
      static Character.UnicodeBlock REJANG
      “Rejang”Unicode字符块的常量。
      static Character.UnicodeBlock RUMI_NUMERAL_SYMBOLS
      常数为“Rumi数字符号”Unicode字符块。
      static Character.UnicodeBlock RUNIC
      “Runic”Unicode字符块的常量。
      static Character.UnicodeBlock SAMARITAN
      “Samaritan”Unicode字符块的常数。
      static Character.UnicodeBlock SAURASHTRA
      “Saurashtra”Unicode字符块的常量。
      static Character.UnicodeBlock SHARADA
      “Sharada”Unicode字符块的常数。
      static Character.UnicodeBlock SHAVIAN
      “Shavian”Unicode字符块的常量。
      static Character.UnicodeBlock SHORTHAND_FORMAT_CONTROLS
      “速写格式控件”Unicode字符块的常量。
      static Character.UnicodeBlock SIDDHAM
      常数为“Siddham”Unicode字符块。
      static Character.UnicodeBlock SINHALA
      “Sinhala”Unicode字符块的常量。
      static Character.UnicodeBlock SINHALA_ARCHAIC_NUMBERS
      常数为“僧伽罗古代数字”Unicode字符块。
      static Character.UnicodeBlock SMALL_FORM_VARIANTS
      常量为“小型变体”Unicode字符块。
      static Character.UnicodeBlock SORA_SOMPENG
      常数为“Sora Sompeng”Unicode字符块。
      static Character.UnicodeBlock SPACING_MODIFIER_LETTERS
      “间隔修饰符字母”的常量Unicode字符块。
      static Character.UnicodeBlock SPECIALS
      “特殊”Unicode字符块的常数。
      static Character.UnicodeBlock SUNDANESE
      “Sundanese”Unicode字符块的常数。
      static Character.UnicodeBlock SUNDANESE_SUPPLEMENT
      “Sundanese Supplement”Unicode字符块的常数。
      static Character.UnicodeBlock SUPERSCRIPTS_AND_SUBSCRIPTS
      常数为“上标和下标”Unicode字符块。
      static Character.UnicodeBlock SUPPLEMENTAL_ARROWS_A
      “补充箭头A”Unicode字符块的常量。
      static Character.UnicodeBlock SUPPLEMENTAL_ARROWS_B
      “补充箭头B”Unicode字符块的常数。
      static Character.UnicodeBlock SUPPLEMENTAL_ARROWS_C
      “补充箭头-C”Unicode字符块的常量。
      static Character.UnicodeBlock SUPPLEMENTAL_MATHEMATICAL_OPERATORS
      常数为“补充数学运算符”Unicode字符块。
      static Character.UnicodeBlock SUPPLEMENTAL_PUNCTUATION
      “补充标点符号”Unicode字符块的常量。
      static Character.UnicodeBlock SUPPLEMENTAL_SYMBOLS_AND_PICTOGRAPHS
      “补充符号和象形图”Unicode字符块的常数。
      static Character.UnicodeBlock SUPPLEMENTARY_PRIVATE_USE_AREA_A
      “补充私用区域A”Unicode字符块的常量。
      static Character.UnicodeBlock SUPPLEMENTARY_PRIVATE_USE_AREA_B
      “补充私用区域B”Unicode字符块的常量。
      static Character.UnicodeBlock SURROGATES_AREA
      已过时。
      取而代之的SURROGATES_AREA ，使用HIGH_SURROGATES ， HIGH_PRIVATE_USE_SURROGATES ，并LOW_SURROGATES 。 这些常量符合Unicode标准的块定义。 of(char)和of(int)方法返回标准常数。
      static Character.UnicodeBlock SUTTON_SIGNWRITING
      “Sutton SignWriting”Unicode字符块的常量。
      static Character.UnicodeBlock SYLOTI_NAGRI
      “Syloti Nagri”Unicode字符块的常量。
      static Character.UnicodeBlock SYRIAC
      “Syriac”Unicode字符块的常数。
      static Character.UnicodeBlock TAGALOG
      “Tagalog”Unicode字符块的常量。
      static Character.UnicodeBlock TAGBANWA
      “Tagbanwa”Unicode字符块的常量。
      static Character.UnicodeBlock TAGS
      常量为“标签”Unicode字符块。
      static Character.UnicodeBlock TAI_LE
      常数为“大乐”Unicode字符块。
      static Character.UnicodeBlock TAI_THAM
      “泰泰”Unicode字符块的常数。
      static Character.UnicodeBlock TAI_VIET
      常数为“Tai Viet”的Unicode字符块。
      static Character.UnicodeBlock TAI_XUAN_JING_SYMBOLS
      常数为“大选京符号”Unicode字符块。
      static Character.UnicodeBlock TAKRI
      “Takri”Unicode字符块的常量。
      static Character.UnicodeBlock TAMIL
      “泰米尔语”Unicode字符块的常量。
      static Character.UnicodeBlock TELUGU
      常数为“泰卢固语”Unicode字符块。
      static Character.UnicodeBlock THAANA
      “Thaana”Unicode字符块的常量。
      static Character.UnicodeBlock THAI
      “泰语”Unicode字符块的常量。
      static Character.UnicodeBlock TIBETAN
      “西藏”Unicode字符块的常数。
      static Character.UnicodeBlock TIFINAGH
      “Tifinagh”Unicode字符块的常数。
      static Character.UnicodeBlock TIRHUTA
      “Tirhuta”Unicode字符块的常量。
      static Character.UnicodeBlock TRANSPORT_AND_MAP_SYMBOLS
      Unicode字符块的“传输和映射符号”的常量。
      static Character.UnicodeBlock UGARITIC
      “Ugaritic”Unicode字符块的常数。
      static Character.UnicodeBlock UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS
      统一的“统一加拿大原住民音节”Unicode字符块。
      static Character.UnicodeBlock UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED
      统一的“统一加拿大原住民音节扩展”Unicode字符块。
      static Character.UnicodeBlock VAI
      “Vai”Unicode字符块的常量。
      static Character.UnicodeBlock VARIATION_SELECTORS
      “变异选择器”Unicode字符块的常量。
      static Character.UnicodeBlock VARIATION_SELECTORS_SUPPLEMENT
      “变体选择器补充”Unicode字符块的常数。
      static Character.UnicodeBlock VEDIC_EXTENSIONS
      “Vedic Extensions”Unicode字符块的常量。
      static Character.UnicodeBlock VERTICAL_FORMS
      “垂直格式”Unicode字符块的常量。
      static Character.UnicodeBlock WARANG_CITI
      常数为“Warang Citi”Unicode字符块。
      static Character.UnicodeBlock YI_RADICALS
      “Yi Radicals”Unicode字符块的常数。
      static Character.UnicodeBlock YI_SYLLABLES
      “Yi Syllables”Unicode字符块的常数。
      static Character.UnicodeBlock YIJING_HEXAGRAM_SYMBOLS
      “Yijing Hexagram符号”Unicode字符块的常数。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Character.UnicodeBlock forName​(String blockName)
      返回具有给定名称的UnicodeBlock。
      static Character.UnicodeBlock of​(char c)
      返回表示包含给定字符的Unicode块的对象，如果字符不是定义块的成员，则返回 null 。
      static Character.UnicodeBlock of​(int codePoint)
      返回表示包含给定字符（Unicode代码点）的Unicode块的对象，如果字符不是定义块的成员，则 null 。

      • Methods inherited from class java.lang.Character.Subset

        equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • BASIC_LATIN

        public static final Character.UnicodeBlock BASIC_LATIN
        Unicode基本字符块的常数。
        从以下版本开始：
        1.2

      • LATIN_1_SUPPLEMENT

        public static final Character.UnicodeBlock LATIN_1_SUPPLEMENT
        “Latin-1 Supplement”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • LATIN_EXTENDED_A

        public static final Character.UnicodeBlock LATIN_EXTENDED_A
        “Latin Extended-A”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • LATIN_EXTENDED_B

        public static final Character.UnicodeBlock LATIN_EXTENDED_B
        “拉丁扩展B”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • IPA_EXTENSIONS

        public static final Character.UnicodeBlock IPA_EXTENSIONS
        “IPA扩展”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • SPACING_MODIFIER_LETTERS

        public static final Character.UnicodeBlock SPACING_MODIFIER_LETTERS
        “间隔修饰符字母”的常量Unicode字符块。
        从以下版本开始：
        1.2

      • COMBINING_DIACRITICAL_MARKS

        public static final Character.UnicodeBlock COMBINING_DIACRITICAL_MARKS
        “组合变音符号”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • GREEK

        public static final Character.UnicodeBlock GREEK
        “希腊和科普特”Unicode字符块的常数。

        这个块以前被称为“希腊语”块。

        从以下版本开始：
        1.2

      • CYRILLIC

        public static final Character.UnicodeBlock CYRILLIC
        “西里尔”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • ARMENIAN

        public static final Character.UnicodeBlock ARMENIAN
        “亚美尼亚”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • HEBREW

        public static final Character.UnicodeBlock HEBREW
        “希伯来语”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • ARABIC

        public static final Character.UnicodeBlock ARABIC
        “阿拉伯语”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • DEVANAGARI

        public static final Character.UnicodeBlock DEVANAGARI
        “Devanagari”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • BENGALI

        public static final Character.UnicodeBlock BENGALI
        “孟加拉语”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • GURMUKHI

        public static final Character.UnicodeBlock GURMUKHI
        常数为“古尔穆基”Unicode字符块。
        从以下版本开始：
        1.2

      • GUJARATI

        public static final Character.UnicodeBlock GUJARATI
        “古吉拉特文”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • ORIYA

        public static final Character.UnicodeBlock ORIYA
        “Oriya”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • TAMIL

        public static final Character.UnicodeBlock TAMIL
        “泰米尔语”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • TELUGU

        public static final Character.UnicodeBlock TELUGU
        常数为“泰卢固语”Unicode字符块。
        从以下版本开始：
        1.2

      • KANNADA

        public static final Character.UnicodeBlock KANNADA
        “Kannada”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • MALAYALAM

        public static final Character.UnicodeBlock MALAYALAM
        “马拉雅拉姆”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • THAI

        public static final Character.UnicodeBlock THAI
        “泰语”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • LAO

        public static final Character.UnicodeBlock LAO
        常数为“老挝”Unicode字符块。
        从以下版本开始：
        1.2

      • TIBETAN

        public static final Character.UnicodeBlock TIBETAN
        “西藏”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • GEORGIAN

        public static final Character.UnicodeBlock GEORGIAN
        “格式”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • HANGUL_JAMO

        public static final Character.UnicodeBlock HANGUL_JAMO
        “Hanul Jamo”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • LATIN_EXTENDED_ADDITIONAL

        public static final Character.UnicodeBlock LATIN_EXTENDED_ADDITIONAL
        “拉丁扩展附加”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • GREEK_EXTENDED

        public static final Character.UnicodeBlock GREEK_EXTENDED
        “希腊语扩展”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • GENERAL_PUNCTUATION

        public static final Character.UnicodeBlock GENERAL_PUNCTUATION
        常规为“一般标点符号”Unicode字符块。
        从以下版本开始：
        1.2

      • SUPERSCRIPTS_AND_SUBSCRIPTS

        public static final Character.UnicodeBlock SUPERSCRIPTS_AND_SUBSCRIPTS
        常数为“上标和下标”Unicode字符块。
        从以下版本开始：
        1.2

      • CURRENCY_SYMBOLS

        public static final Character.UnicodeBlock CURRENCY_SYMBOLS
        Unicode字符块的“货币符号”的常量。
        从以下版本开始：
        1.2

      • COMBINING_MARKS_FOR_SYMBOLS

        public static final Character.UnicodeBlock COMBINING_MARKS_FOR_SYMBOLS
        Unicode字符块的“组合符号变音符号”的常量。

        此块以前称为“组合符号标记”。

        从以下版本开始：
        1.2

      • LETTERLIKE_SYMBOLS

        public static final Character.UnicodeBlock LETTERLIKE_SYMBOLS
        Unicode字符块的“字母符号”的常量。
        从以下版本开始：
        1.2

      • NUMBER_FORMS

        public static final Character.UnicodeBlock NUMBER_FORMS
        “数字形式”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • ARROWS

        public static final Character.UnicodeBlock ARROWS
        常量为“箭头”Unicode字符块。
        从以下版本开始：
        1.2

      • MATHEMATICAL_OPERATORS

        public static final Character.UnicodeBlock MATHEMATICAL_OPERATORS
        常数为“数学运算符”Unicode字符块。
        从以下版本开始：
        1.2

      • MISCELLANEOUS_TECHNICAL

        public static final Character.UnicodeBlock MISCELLANEOUS_TECHNICAL
        “杂项技术”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • CONTROL_PICTURES

        public static final Character.UnicodeBlock CONTROL_PICTURES
        “控制图片”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • OPTICAL_CHARACTER_RECOGNITION

        public static final Character.UnicodeBlock OPTICAL_CHARACTER_RECOGNITION
        Unicode字符块的“光学字符识别”常数。
        从以下版本开始：
        1.2

      • ENCLOSED_ALPHANUMERICS

        public static final Character.UnicodeBlock ENCLOSED_ALPHANUMERICS
        “封闭字母数字”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • BOX_DRAWING

        public static final Character.UnicodeBlock BOX_DRAWING
        常量为“框图”Unicode字符块。
        从以下版本开始：
        1.2

      • BLOCK_ELEMENTS

        public static final Character.UnicodeBlock BLOCK_ELEMENTS
        常量为“块元素”Unicode字符块。
        从以下版本开始：
        1.2

      • GEOMETRIC_SHAPES

        public static final Character.UnicodeBlock GEOMETRIC_SHAPES
        “几何形状”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • MISCELLANEOUS_SYMBOLS

        public static final Character.UnicodeBlock MISCELLANEOUS_SYMBOLS
        “杂项符号”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • DINGBATS

        public static final Character.UnicodeBlock DINGBATS
        “Dingbats”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • CJK_SYMBOLS_AND_PUNCTUATION

        public static final Character.UnicodeBlock CJK_SYMBOLS_AND_PUNCTUATION
        常量为“CJK符号和标点符号”Unicode字符块。
        从以下版本开始：
        1.2

      • HIRAGANA

        public static final Character.UnicodeBlock HIRAGANA
        “Hiragana”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • KATAKANA

        public static final Character.UnicodeBlock KATAKANA
        “片假名”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • BOPOMOFO

        public static final Character.UnicodeBlock BOPOMOFO
        “Bopomofo”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • HANGUL_COMPATIBILITY_JAMO

        public static final Character.UnicodeBlock HANGUL_COMPATIBILITY_JAMO
        “Hanul兼容性Jamo”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • KANBUN

        public static final Character.UnicodeBlock KANBUN
        “Kanbun”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • ENCLOSED_CJK_LETTERS_AND_MONTHS

        public static final Character.UnicodeBlock ENCLOSED_CJK_LETTERS_AND_MONTHS
        “封闭的CJK字母和月”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • CJK_COMPATIBILITY

        public static final Character.UnicodeBlock CJK_COMPATIBILITY
        常量为“CJK兼容性”Unicode字符块。
        从以下版本开始：
        1.2

      • CJK_UNIFIED_IDEOGRAPHS

        public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS
        “CJK统一表意符号”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • HANGUL_SYLLABLES

        public static final Character.UnicodeBlock HANGUL_SYLLABLES
        “汉字音节”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • PRIVATE_USE_AREA

        public static final Character.UnicodeBlock PRIVATE_USE_AREA
        “私用区域”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • CJK_COMPATIBILITY_IDEOGRAPHS

        public static final Character.UnicodeBlock CJK_COMPATIBILITY_IDEOGRAPHS
        “CJK兼容性表意符号”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • ALPHABETIC_PRESENTATION_FORMS

        public static final Character.UnicodeBlock ALPHABETIC_PRESENTATION_FORMS
        “字母表示形式”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • ARABIC_PRESENTATION_FORMS_A

        public static final Character.UnicodeBlock ARABIC_PRESENTATION_FORMS_A
        “阿拉伯文表达式A”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • COMBINING_HALF_MARKS

        public static final Character.UnicodeBlock COMBINING_HALF_MARKS
        Unicode字符块的“组合半标记”的常量。
        从以下版本开始：
        1.2

      • CJK_COMPATIBILITY_FORMS

        public static final Character.UnicodeBlock CJK_COMPATIBILITY_FORMS
        “CJK兼容性表单”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • SMALL_FORM_VARIANTS

        public static final Character.UnicodeBlock SMALL_FORM_VARIANTS
        常量为“小型变体”Unicode字符块。
        从以下版本开始：
        1.2

      • ARABIC_PRESENTATION_FORMS_B

        public static final Character.UnicodeBlock ARABIC_PRESENTATION_FORMS_B
        “阿拉伯语表达式B”Unicode字符块的常量。
        从以下版本开始：
        1.2

      • HALFWIDTH_AND_FULLWIDTH_FORMS

        public static final Character.UnicodeBlock HALFWIDTH_AND_FULLWIDTH_FORMS
        Unicode字符块的“半宽和全宽”的常量。
        从以下版本开始：
        1.2

      • SPECIALS

        public static final Character.UnicodeBlock SPECIALS
        “特殊”Unicode字符块的常数。
        从以下版本开始：
        1.2

      • SURROGATES_AREA

        @Deprecated(since="1.5")
public static final Character.UnicodeBlock SURROGATES_AREA
        已过时。 取而代之的SURROGATES_AREA ，使用HIGH_SURROGATES ， HIGH_PRIVATE_USE_SURROGATES ，并LOW_SURROGATES 。 这些常量符合Unicode标准的块定义。 of(char)和of(int)方法返回标准常数。

      • SYRIAC

        public static final Character.UnicodeBlock SYRIAC
        “Syriac”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • THAANA

        public static final Character.UnicodeBlock THAANA
        “Thaana”Unicode字符块的常量。
        从以下版本开始：
        1.4

      • SINHALA

        public static final Character.UnicodeBlock SINHALA
        “Sinhala”Unicode字符块的常量。
        从以下版本开始：
        1.4

      • MYANMAR

        public static final Character.UnicodeBlock MYANMAR
        常数为“缅甸”Unicode字符块。
        从以下版本开始：
        1.4

      • ETHIOPIC

        public static final Character.UnicodeBlock ETHIOPIC
        “埃塞俄比亚”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • CHEROKEE

        public static final Character.UnicodeBlock CHEROKEE
        常数为“切诺基”Unicode字符块。
        从以下版本开始：
        1.4

      • UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS

        public static final Character.UnicodeBlock UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS
        统一的“统一加拿大原住民音节”Unicode字符块。
        从以下版本开始：
        1.4

      • OGHAM

        public static final Character.UnicodeBlock OGHAM
        “Ogham”Unicode字符块的常量。
        从以下版本开始：
        1.4

      • RUNIC

        public static final Character.UnicodeBlock RUNIC
        “Runic”Unicode字符块的常量。
        从以下版本开始：
        1.4

      • KHMER

        public static final Character.UnicodeBlock KHMER
        “高棉”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • MONGOLIAN

        public static final Character.UnicodeBlock MONGOLIAN
        “蒙古”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • BRAILLE_PATTERNS

        public static final Character.UnicodeBlock BRAILLE_PATTERNS
        “盲文图案”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • CJK_RADICALS_SUPPLEMENT

        public static final Character.UnicodeBlock CJK_RADICALS_SUPPLEMENT
        常数为“CJK Radicals Supplement”Unicode字符块。
        从以下版本开始：
        1.4

      • KANGXI_RADICALS

        public static final Character.UnicodeBlock KANGXI_RADICALS
        常数为“康熙激进”Unicode字符块。
        从以下版本开始：
        1.4

      • IDEOGRAPHIC_DESCRIPTION_CHARACTERS

        public static final Character.UnicodeBlock IDEOGRAPHIC_DESCRIPTION_CHARACTERS
        Unicode字符块的“表意描述字符”的常量。
        从以下版本开始：
        1.4

      • BOPOMOFO_EXTENDED

        public static final Character.UnicodeBlock BOPOMOFO_EXTENDED
        “Bopomofo Extended”Unicode字符块的常量。
        从以下版本开始：
        1.4

      • CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A

        public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A
        “CJK统一表意扩展A”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • YI_SYLLABLES

        public static final Character.UnicodeBlock YI_SYLLABLES
        “Yi Syllables”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • YI_RADICALS

        public static final Character.UnicodeBlock YI_RADICALS
        “Yi Radicals”Unicode字符块的常数。
        从以下版本开始：
        1.4

      • CYRILLIC_SUPPLEMENTARY

        public static final Character.UnicodeBlock CYRILLIC_SUPPLEMENTARY
        “西里尔语补充”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • TAGALOG

        public static final Character.UnicodeBlock TAGALOG
        “Tagalog”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • HANUNOO

        public static final Character.UnicodeBlock HANUNOO
        “Hanunoo”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • BUHID

        public static final Character.UnicodeBlock BUHID
        “Buhid”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • TAGBANWA

        public static final Character.UnicodeBlock TAGBANWA
        “Tagbanwa”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • LIMBU

        public static final Character.UnicodeBlock LIMBU
        “Limbu”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • TAI_LE

        public static final Character.UnicodeBlock TAI_LE
        常数为“大乐”Unicode字符块。
        从以下版本开始：
        1.5

      • KHMER_SYMBOLS

        public static final Character.UnicodeBlock KHMER_SYMBOLS
        “高棉符号”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • PHONETIC_EXTENSIONS

        public static final Character.UnicodeBlock PHONETIC_EXTENSIONS
        常量为“语音扩展”Unicode字符块。
        从以下版本开始：
        1.5

      • MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A

        public static final Character.UnicodeBlock MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A
        “Miscellaneous Mathematical Symbols-A”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • SUPPLEMENTAL_ARROWS_A

        public static final Character.UnicodeBlock SUPPLEMENTAL_ARROWS_A
        “补充箭头A”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • SUPPLEMENTAL_ARROWS_B

        public static final Character.UnicodeBlock SUPPLEMENTAL_ARROWS_B
        “补充箭头B”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B

        public static final Character.UnicodeBlock MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B
        “Miscellaneous Mathematical Symbols-B”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • SUPPLEMENTAL_MATHEMATICAL_OPERATORS

        public static final Character.UnicodeBlock SUPPLEMENTAL_MATHEMATICAL_OPERATORS
        常数为“补充数学运算符”Unicode字符块。
        从以下版本开始：
        1.5

      • MISCELLANEOUS_SYMBOLS_AND_ARROWS

        public static final Character.UnicodeBlock MISCELLANEOUS_SYMBOLS_AND_ARROWS
        “杂项符号和箭头”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • KATAKANA_PHONETIC_EXTENSIONS

        public static final Character.UnicodeBlock KATAKANA_PHONETIC_EXTENSIONS
        “片假名语音扩展”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • YIJING_HEXAGRAM_SYMBOLS

        public static final Character.UnicodeBlock YIJING_HEXAGRAM_SYMBOLS
        “Yijing Hexagram符号”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • VARIATION_SELECTORS

        public static final Character.UnicodeBlock VARIATION_SELECTORS
        “变异选择器”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • LINEAR_B_SYLLABARY

        public static final Character.UnicodeBlock LINEAR_B_SYLLABARY
        “线性B音节”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • LINEAR_B_IDEOGRAMS

        public static final Character.UnicodeBlock LINEAR_B_IDEOGRAMS
        “线性B表意符号”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • AEGEAN_NUMBERS

        public static final Character.UnicodeBlock AEGEAN_NUMBERS
        “爱琴海数字”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • OLD_ITALIC

        public static final Character.UnicodeBlock OLD_ITALIC
        “旧斜体”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • GOTHIC

        public static final Character.UnicodeBlock GOTHIC
        “哥特式”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • UGARITIC

        public static final Character.UnicodeBlock UGARITIC
        “Ugaritic”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • DESERET

        public static final Character.UnicodeBlock DESERET
        “Deseret”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • SHAVIAN

        public static final Character.UnicodeBlock SHAVIAN
        “Shavian”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • OSMANYA

        public static final Character.UnicodeBlock OSMANYA
        常量为“Osmanya”Unicode字符块。
        从以下版本开始：
        1.5

      • CYPRIOT_SYLLABARY

        public static final Character.UnicodeBlock CYPRIOT_SYLLABARY
        “塞浦路字母”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • BYZANTINE_MUSICAL_SYMBOLS

        public static final Character.UnicodeBlock BYZANTINE_MUSICAL_SYMBOLS
        常数为“拜占庭式音乐符号”Unicode字符块。
        从以下版本开始：
        1.5

      • MUSICAL_SYMBOLS

        public static final Character.UnicodeBlock MUSICAL_SYMBOLS
        常数为“音符”Unicode字符块。
        从以下版本开始：
        1.5

      • TAI_XUAN_JING_SYMBOLS

        public static final Character.UnicodeBlock TAI_XUAN_JING_SYMBOLS
        常数为“大选京符号”Unicode字符块。
        从以下版本开始：
        1.5

      • MATHEMATICAL_ALPHANUMERIC_SYMBOLS

        public static final Character.UnicodeBlock MATHEMATICAL_ALPHANUMERIC_SYMBOLS
        “数学字母数字符号”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B

        public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B
        “CJK统一表意扩展B”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT

        public static final Character.UnicodeBlock CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT
        “CJK兼容性表意文字补充”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • TAGS

        public static final Character.UnicodeBlock TAGS
        常量为“标签”Unicode字符块。
        从以下版本开始：
        1.5

      • VARIATION_SELECTORS_SUPPLEMENT

        public static final Character.UnicodeBlock VARIATION_SELECTORS_SUPPLEMENT
        “变体选择器补充”Unicode字符块的常数。
        从以下版本开始：
        1.5

      • SUPPLEMENTARY_PRIVATE_USE_AREA_A

        public static final Character.UnicodeBlock SUPPLEMENTARY_PRIVATE_USE_AREA_A
        “补充私用区域A”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • SUPPLEMENTARY_PRIVATE_USE_AREA_B

        public static final Character.UnicodeBlock SUPPLEMENTARY_PRIVATE_USE_AREA_B
        “补充私用区域B”Unicode字符块的常量。
        从以下版本开始：
        1.5

      • HIGH_SURROGATES

        public static final Character.UnicodeBlock HIGH_SURROGATES
        常数为“高代理”Unicode字符块。 该块表示高替代范围的代码点值：U + D800至U + DB7F
        从以下版本开始：
        1.5

      • HIGH_PRIVATE_USE_SURROGATES

        public static final Character.UnicodeBlock HIGH_PRIVATE_USE_SURROGATES
        “高私人使用代理”Unicode字符块的常量。 该块表示私人使用高代理范围中的代码点值：U + DB80到U + DBFF
        从以下版本开始：
        1.5

      • LOW_SURROGATES

        public static final Character.UnicodeBlock LOW_SURROGATES
        “低代理”Unicode字符块的常数。 该块表示低代理范围中的代码点值：U + DC00到U + DFFF
        从以下版本开始：
        1.5

      • ARABIC_SUPPLEMENT

        public static final Character.UnicodeBlock ARABIC_SUPPLEMENT
        “阿拉伯语补充”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • NKO

        public static final Character.UnicodeBlock NKO
        “NKo”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • SAMARITAN

        public static final Character.UnicodeBlock SAMARITAN
        “Samaritan”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • MANDAIC

        public static final Character.UnicodeBlock MANDAIC
        常数为“Mandaic”Unicode字符块。
        从以下版本开始：
        1.7

      • ETHIOPIC_SUPPLEMENT

        public static final Character.UnicodeBlock ETHIOPIC_SUPPLEMENT
        “埃塞俄比亚补编”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED

        public static final Character.UnicodeBlock UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED
        统一的“统一加拿大原住民音节扩展”Unicode字符块。
        从以下版本开始：
        1.7

      • NEW_TAI_LUE

        public static final Character.UnicodeBlock NEW_TAI_LUE
        “新泰乐”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • BUGINESE

        public static final Character.UnicodeBlock BUGINESE
        “Buginese”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • TAI_THAM

        public static final Character.UnicodeBlock TAI_THAM
        “泰泰”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • BALINESE

        public static final Character.UnicodeBlock BALINESE
        “巴厘岛”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • SUNDANESE

        public static final Character.UnicodeBlock SUNDANESE
        “Sundanese”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • BATAK

        public static final Character.UnicodeBlock BATAK
        “Batak”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • LEPCHA

        public static final Character.UnicodeBlock LEPCHA
        “Lepcha”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • OL_CHIKI

        public static final Character.UnicodeBlock OL_CHIKI
        “Ol Chiki”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • VEDIC_EXTENSIONS

        public static final Character.UnicodeBlock VEDIC_EXTENSIONS
        “Vedic Extensions”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • PHONETIC_EXTENSIONS_SUPPLEMENT

        public static final Character.UnicodeBlock PHONETIC_EXTENSIONS_SUPPLEMENT
        “语音扩展补充”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • COMBINING_DIACRITICAL_MARKS_SUPPLEMENT

        public static final Character.UnicodeBlock COMBINING_DIACRITICAL_MARKS_SUPPLEMENT
        Unicode字符块的“组合变音符号补充”的常数。
        从以下版本开始：
        1.7

      • GLAGOLITIC

        public static final Character.UnicodeBlock GLAGOLITIC
        “Glagolitic”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • LATIN_EXTENDED_C

        public static final Character.UnicodeBlock LATIN_EXTENDED_C
        “拉丁扩展C”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • COPTIC

        public static final Character.UnicodeBlock COPTIC
        “科普特”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • GEORGIAN_SUPPLEMENT

        public static final Character.UnicodeBlock GEORGIAN_SUPPLEMENT
        “格鲁吉亚补编”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • TIFINAGH

        public static final Character.UnicodeBlock TIFINAGH
        “Tifinagh”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • ETHIOPIC_EXTENDED

        public static final Character.UnicodeBlock ETHIOPIC_EXTENDED
        “埃塞俄比亚扩展”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • CYRILLIC_EXTENDED_A

        public static final Character.UnicodeBlock CYRILLIC_EXTENDED_A
        “西里尔扩展A”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • SUPPLEMENTAL_PUNCTUATION

        public static final Character.UnicodeBlock SUPPLEMENTAL_PUNCTUATION
        “补充标点符号”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • CJK_STROKES

        public static final Character.UnicodeBlock CJK_STROKES
        常量为“CJK笔画”Unicode字符块。
        从以下版本开始：
        1.7

      • LISU

        public static final Character.UnicodeBlock LISU
        “Lisu”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • VAI

        public static final Character.UnicodeBlock VAI
        “Vai”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • CYRILLIC_EXTENDED_B

        public static final Character.UnicodeBlock CYRILLIC_EXTENDED_B
        “西里尔扩展B”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • BAMUM

        public static final Character.UnicodeBlock BAMUM
        “Bamum”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • MODIFIER_TONE_LETTERS

        public static final Character.UnicodeBlock MODIFIER_TONE_LETTERS
        “Modifier Tone Letters”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • LATIN_EXTENDED_D

        public static final Character.UnicodeBlock LATIN_EXTENDED_D
        “拉丁扩展D”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • SYLOTI_NAGRI

        public static final Character.UnicodeBlock SYLOTI_NAGRI
        “Syloti Nagri”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • COMMON_INDIC_NUMBER_FORMS

        public static final Character.UnicodeBlock COMMON_INDIC_NUMBER_FORMS
        “常用印数字”表示Unicode字符块的常数。
        从以下版本开始：
        1.7

      • PHAGS_PA

        public static final Character.UnicodeBlock PHAGS_PA
        “Phags-pa”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • SAURASHTRA

        public static final Character.UnicodeBlock SAURASHTRA
        “Saurashtra”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • DEVANAGARI_EXTENDED

        public static final Character.UnicodeBlock DEVANAGARI_EXTENDED
        “梵文扩展”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • KAYAH_LI

        public static final Character.UnicodeBlock KAYAH_LI
        常数为“Kayah Li”Unicode字符块。
        从以下版本开始：
        1.7

      • REJANG

        public static final Character.UnicodeBlock REJANG
        “Rejang”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • HANGUL_JAMO_EXTENDED_A

        public static final Character.UnicodeBlock HANGUL_JAMO_EXTENDED_A
        “Hanul Jamo Extended-A”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • JAVANESE

        public static final Character.UnicodeBlock JAVANESE
        “爪哇”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • CHAM

        public static final Character.UnicodeBlock CHAM
        “Cham”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • MYANMAR_EXTENDED_A

        public static final Character.UnicodeBlock MYANMAR_EXTENDED_A
        “Myanmar Extended-A”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • TAI_VIET

        public static final Character.UnicodeBlock TAI_VIET
        常数为“Tai Viet”的Unicode字符块。
        从以下版本开始：
        1.7

      • ETHIOPIC_EXTENDED_A

        public static final Character.UnicodeBlock ETHIOPIC_EXTENDED_A
        “埃塞俄比亚扩展A”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • MEETEI_MAYEK

        public static final Character.UnicodeBlock MEETEI_MAYEK
        “Meetei Mayek”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • HANGUL_JAMO_EXTENDED_B

        public static final Character.UnicodeBlock HANGUL_JAMO_EXTENDED_B
        “Hanul Jamo Extended-B”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • VERTICAL_FORMS

        public static final Character.UnicodeBlock VERTICAL_FORMS
        “垂直格式”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • ANCIENT_GREEK_NUMBERS

        public static final Character.UnicodeBlock ANCIENT_GREEK_NUMBERS
        常数为“古希腊数字”Unicode字符块。
        从以下版本开始：
        1.7

      • ANCIENT_SYMBOLS

        public static final Character.UnicodeBlock ANCIENT_SYMBOLS
        “古代符号”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • PHAISTOS_DISC

        public static final Character.UnicodeBlock PHAISTOS_DISC
        “Phaistos Disc”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • LYCIAN

        public static final Character.UnicodeBlock LYCIAN
        “Lycian”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • CARIAN

        public static final Character.UnicodeBlock CARIAN
        “Carian”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • OLD_PERSIAN

        public static final Character.UnicodeBlock OLD_PERSIAN
        “老波斯”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • IMPERIAL_ARAMAIC

        public static final Character.UnicodeBlock IMPERIAL_ARAMAIC
        “皇家阿拉姆语”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • PHOENICIAN

        public static final Character.UnicodeBlock PHOENICIAN
        “腓尼基”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • LYDIAN

        public static final Character.UnicodeBlock LYDIAN
        常数为“Lydian”Unicode字符块。
        从以下版本开始：
        1.7

      • KHAROSHTHI

        public static final Character.UnicodeBlock KHAROSHTHI
        “Kharoshthi”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • OLD_SOUTH_ARABIAN

        public static final Character.UnicodeBlock OLD_SOUTH_ARABIAN
        “旧南阿拉伯”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • AVESTAN

        public static final Character.UnicodeBlock AVESTAN
        “Avestan”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • INSCRIPTIONAL_PARTHIAN

        public static final Character.UnicodeBlock INSCRIPTIONAL_PARTHIAN
        “Inscriptional Parthian”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • INSCRIPTIONAL_PAHLAVI

        public static final Character.UnicodeBlock INSCRIPTIONAL_PAHLAVI
        常数为“Inscriptional Pahlavi”Unicode字符块。
        从以下版本开始：
        1.7

      • OLD_TURKIC

        public static final Character.UnicodeBlock OLD_TURKIC
        常数为“古突厥语”Unicode字符块。
        从以下版本开始：
        1.7

      • RUMI_NUMERAL_SYMBOLS

        public static final Character.UnicodeBlock RUMI_NUMERAL_SYMBOLS
        常数为“Rumi数字符号”Unicode字符块。
        从以下版本开始：
        1.7

      • BRAHMI

        public static final Character.UnicodeBlock BRAHMI
        “Brahmi”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • KAITHI

        public static final Character.UnicodeBlock KAITHI
        “Kaithi”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • CUNEIFORM

        public static final Character.UnicodeBlock CUNEIFORM
        “Cuneiform”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • CUNEIFORM_NUMBERS_AND_PUNCTUATION

        public static final Character.UnicodeBlock CUNEIFORM_NUMBERS_AND_PUNCTUATION
        “Cuneiform数字和标点符号”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • EGYPTIAN_HIEROGLYPHS

        public static final Character.UnicodeBlock EGYPTIAN_HIEROGLYPHS
        “埃及象形文字”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • BAMUM_SUPPLEMENT

        public static final Character.UnicodeBlock BAMUM_SUPPLEMENT
        “Bamum Supplement”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • KANA_SUPPLEMENT

        public static final Character.UnicodeBlock KANA_SUPPLEMENT
        “假名补充”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • ANCIENT_GREEK_MUSICAL_NOTATION

        public static final Character.UnicodeBlock ANCIENT_GREEK_MUSICAL_NOTATION
        常规为“古希腊音乐符号”Unicode字符块。
        从以下版本开始：
        1.7

      • COUNTING_ROD_NUMERALS

        public static final Character.UnicodeBlock COUNTING_ROD_NUMERALS
        常数为“计数杆号”Unicode字符块。
        从以下版本开始：
        1.7

      • MAHJONG_TILES

        public static final Character.UnicodeBlock MAHJONG_TILES
        “麻将瓷砖”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • DOMINO_TILES

        public static final Character.UnicodeBlock DOMINO_TILES
        “Domino Tiles”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • PLAYING_CARDS

        public static final Character.UnicodeBlock PLAYING_CARDS
        常规为“纸牌”Unicode字符块。
        从以下版本开始：
        1.7

      • ENCLOSED_ALPHANUMERIC_SUPPLEMENT

        public static final Character.UnicodeBlock ENCLOSED_ALPHANUMERIC_SUPPLEMENT
        “封闭的字母数字补充”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • ENCLOSED_IDEOGRAPHIC_SUPPLEMENT

        public static final Character.UnicodeBlock ENCLOSED_IDEOGRAPHIC_SUPPLEMENT
        “封闭式表意补充”Unicode字符块的常量。
        从以下版本开始：
        1.7

      • MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS

        public static final Character.UnicodeBlock MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS
        “Miscellaneous Symbols and Pictographs”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • EMOTICONS

        public static final Character.UnicodeBlock EMOTICONS
        常量为“表情符号”Unicode字符块。
        从以下版本开始：
        1.7

      • TRANSPORT_AND_MAP_SYMBOLS

        public static final Character.UnicodeBlock TRANSPORT_AND_MAP_SYMBOLS
        Unicode字符块的“传输和映射符号”的常量。
        从以下版本开始：
        1.7

      • ALCHEMICAL_SYMBOLS

        public static final Character.UnicodeBlock ALCHEMICAL_SYMBOLS
        常数为“Alchemical Symbols”Unicode字符块。
        从以下版本开始：
        1.7

      • CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C

        public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C
        “CJK统一表意扩展C”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D

        public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D
        “CJK统一表意扩展D”Unicode字符块的常数。
        从以下版本开始：
        1.7

      • ARABIC_EXTENDED_A

        public static final Character.UnicodeBlock ARABIC_EXTENDED_A
        “阿拉伯语扩展A”Unicode字符块的常量。
        从以下版本开始：
        1.8

      • SUNDANESE_SUPPLEMENT

        public static final Character.UnicodeBlock SUNDANESE_SUPPLEMENT
        “Sundanese Supplement”Unicode字符块的常数。
        从以下版本开始：
        1.8

      • MEETEI_MAYEK_EXTENSIONS

        public static final Character.UnicodeBlock MEETEI_MAYEK_EXTENSIONS
        “Meetei Mayek Extensions”Unicode字符块的常数。
        从以下版本开始：
        1.8

      • MEROITIC_HIEROGLYPHS

        public static final Character.UnicodeBlock MEROITIC_HIEROGLYPHS
        “Meroitic象形文字”Unicode字符块的常数。
        从以下版本开始：
        1.8

      • MEROITIC_CURSIVE

        public static final Character.UnicodeBlock MEROITIC_CURSIVE
        “Meroitic Cursive”Unicode字符块的常量。
        从以下版本开始：
        1.8

      • SORA_SOMPENG

        public static final Character.UnicodeBlock SORA_SOMPENG
        常数为“Sora Sompeng”Unicode字符块。
        从以下版本开始：
        1.8

      • CHAKMA

        public static final Character.UnicodeBlock CHAKMA
        “Chakma”Unicode字符块的常量。
        从以下版本开始：
        1.8

      • SHARADA

        public static final Character.UnicodeBlock SHARADA
        “Sharada”Unicode字符块的常数。
        从以下版本开始：
        1.8

      • TAKRI

        public static final Character.UnicodeBlock TAKRI
        “Takri”Unicode字符块的常量。
        从以下版本开始：
        1.8

      • MIAO

        public static final Character.UnicodeBlock MIAO
        常量为“Miao”Unicode字符块。
        从以下版本开始：
        1.8

      • ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS

        public static final Character.UnicodeBlock ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS
        常数为“阿拉伯数学字母符号”Unicode字符块。
        从以下版本开始：
        1.8

      • COMBINING_DIACRITICAL_MARKS_EXTENDED

        public static final Character.UnicodeBlock COMBINING_DIACRITICAL_MARKS_EXTENDED
        Unicode字符块的“组合变音符号扩展”的常数。
        从以下版本开始：
        9

      • MYANMAR_EXTENDED_B

        public static final Character.UnicodeBlock MYANMAR_EXTENDED_B
        “缅甸扩展B”Unicode字符块的常量。
        从以下版本开始：
        9

      • LATIN_EXTENDED_E

        public static final Character.UnicodeBlock LATIN_EXTENDED_E
        “拉丁扩展E”Unicode字符块的常量。
        从以下版本开始：
        9

      • COPTIC_EPACT_NUMBERS

        public static final Character.UnicodeBlock COPTIC_EPACT_NUMBERS
        常规为“科普特数字”Unicode字符块。
        从以下版本开始：
        9

      • OLD_PERMIC

        public static final Character.UnicodeBlock OLD_PERMIC
        “Old Permic”Unicode字符块的常量。
        从以下版本开始：
        9

      • ELBASAN

        public static final Character.UnicodeBlock ELBASAN
        常数为“Elbasan”Unicode字符块。
        从以下版本开始：
        9

      • CAUCASIAN_ALBANIAN

        public static final Character.UnicodeBlock CAUCASIAN_ALBANIAN
        “阿尔巴尼亚白人”Unicode字符块的常数。
        从以下版本开始：
        9

      • LINEAR_A

        public static final Character.UnicodeBlock LINEAR_A
        “线性A”Unicode字符块的常量。
        从以下版本开始：
        9

      • PALMYRENE

        public static final Character.UnicodeBlock PALMYRENE
        常数为“棕榈”Unicode字符块。
        从以下版本开始：
        9

      • NABATAEAN

        public static final Character.UnicodeBlock NABATAEAN
        “Nabataean”Unicode字符块的常数。
        从以下版本开始：
        9

      • OLD_NORTH_ARABIAN

        public static final Character.UnicodeBlock OLD_NORTH_ARABIAN
        常数为“旧北阿拉伯”Unicode字符块。
        从以下版本开始：
        9

      • MANICHAEAN

        public static final Character.UnicodeBlock MANICHAEAN
        “Manichaean”Unicode字符块的常量。
        从以下版本开始：
        9

      • PSALTER_PAHLAVI

        public static final Character.UnicodeBlock PSALTER_PAHLAVI
        “Psalter Pahlavi”Unicode字符块的常数。
        从以下版本开始：
        9

      • MAHAJANI

        public static final Character.UnicodeBlock MAHAJANI
        “Mahajani”Unicode字符块的常数。
        从以下版本开始：
        9

      • SINHALA_ARCHAIC_NUMBERS

        public static final Character.UnicodeBlock SINHALA_ARCHAIC_NUMBERS
        常数为“僧伽罗古代数字”Unicode字符块。
        从以下版本开始：
        9

      • KHOJKI

        public static final Character.UnicodeBlock KHOJKI
        “Khojki”Unicode字符块的常数。
        从以下版本开始：
        9

      • KHUDAWADI

        public static final Character.UnicodeBlock KHUDAWADI
        “Khudawadi”Unicode字符块的常量。
        从以下版本开始：
        9

      • GRANTHA

        public static final Character.UnicodeBlock GRANTHA
        “Grantha”Unicode字符块的常量。
        从以下版本开始：
        9

      • TIRHUTA

        public static final Character.UnicodeBlock TIRHUTA
        “Tirhuta”Unicode字符块的常量。
        从以下版本开始：
        9

      • SIDDHAM

        public static final Character.UnicodeBlock SIDDHAM
        常数为“Siddham”Unicode字符块。
        从以下版本开始：
        9

      • MODI

        public static final Character.UnicodeBlock MODI
        “Modi”Unicode字符块的常量。
        从以下版本开始：
        9

      • WARANG_CITI

        public static final Character.UnicodeBlock WARANG_CITI
        常数为“Warang Citi”Unicode字符块。
        从以下版本开始：
        9

      • PAU_CIN_HAU

        public static final Character.UnicodeBlock PAU_CIN_HAU
        “Pau Cin Hau”Unicode字符块的常数。
        从以下版本开始：
        9

      • MRO

        public static final Character.UnicodeBlock MRO
        “Mro”Unicode字符块的常量。
        从以下版本开始：
        9

      • BASSA_VAH

        public static final Character.UnicodeBlock BASSA_VAH
        常数为“Bassa Vah”Unicode字符块。
        从以下版本开始：
        9

      • PAHAWH_HMONG

        public static final Character.UnicodeBlock PAHAWH_HMONG
        “Pahawh Hmong”Unicode字符块的常量。
        从以下版本开始：
        9

      • DUPLOYAN

        public static final Character.UnicodeBlock DUPLOYAN
        “Duployan”Unicode字符块的常量。
        从以下版本开始：
        9

      • SHORTHAND_FORMAT_CONTROLS

        public static final Character.UnicodeBlock SHORTHAND_FORMAT_CONTROLS
        “速写格式控件”Unicode字符块的常量。
        从以下版本开始：
        9

      • MENDE_KIKAKUI

        public static final Character.UnicodeBlock MENDE_KIKAKUI
        常数为“Mende Kikakui”Unicode字符块。
        从以下版本开始：
        9

      • ORNAMENTAL_DINGBATS

        public static final Character.UnicodeBlock ORNAMENTAL_DINGBATS
        “Ornamental Dingbats”Unicode字符块的常数。
        从以下版本开始：
        9

      • GEOMETRIC_SHAPES_EXTENDED

        public static final Character.UnicodeBlock GEOMETRIC_SHAPES_EXTENDED
        “几何形状扩展”Unicode字符块的常数。
        从以下版本开始：
        9

      • SUPPLEMENTAL_ARROWS_C

        public static final Character.UnicodeBlock SUPPLEMENTAL_ARROWS_C
        “补充箭头-C”Unicode字符块的常量。
        从以下版本开始：
        9

      • CHEROKEE_SUPPLEMENT

        public static final Character.UnicodeBlock CHEROKEE_SUPPLEMENT
        常数为“切诺基补充”Unicode字符块。
        从以下版本开始：
        9

      • HATRAN

        public static final Character.UnicodeBlock HATRAN
        “Hatran”Unicode字符块的常量。
        从以下版本开始：
        9

      • OLD_HUNGARIAN

        public static final Character.UnicodeBlock OLD_HUNGARIAN
        “古匈牙利”Unicode字符块的常数。
        从以下版本开始：
        9

      • MULTANI

        public static final Character.UnicodeBlock MULTANI
        “Multani”Unicode字符块的常量。
        从以下版本开始：
        9

      • AHOM

        public static final Character.UnicodeBlock AHOM
        “Ahom”Unicode字符块的常数。
        从以下版本开始：
        9

      • EARLY_DYNASTIC_CUNEIFORM

        public static final Character.UnicodeBlock EARLY_DYNASTIC_CUNEIFORM
        常数为“早期楔形文字”Unicode字符块。
        从以下版本开始：
        9

      • ANATOLIAN_HIEROGLYPHS

        public static final Character.UnicodeBlock ANATOLIAN_HIEROGLYPHS
        “安纳托利亚象形文字”Unicode字符块的常数。
        从以下版本开始：
        9

      • SUTTON_SIGNWRITING

        public static final Character.UnicodeBlock SUTTON_SIGNWRITING
        “Sutton SignWriting”Unicode字符块的常量。
        从以下版本开始：
        9

      • SUPPLEMENTAL_SYMBOLS_AND_PICTOGRAPHS

        public static final Character.UnicodeBlock SUPPLEMENTAL_SYMBOLS_AND_PICTOGRAPHS
        “补充符号和象形图”Unicode字符块的常数。
        从以下版本开始：
        9

      • CJK_UNIFIED_IDEOGRAPHS_EXTENSION_E

        public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_E
        “CJK统一表意扩展E”Unicode字符块的常数。
        从以下版本开始：
        9

    • 方法详细信息

      • of

        public static Character.UnicodeBlock of​(char c)
        返回表示包含给定字符的Unicode块的对象，如果字符不是定义块的成员，则返回null 。

        注意：此方法无法处理supplementary characters 。 要支持所有Unicode字符，包括补充字符，请使用of(int)方法。

        参数
        c - 有问题的人物
        结果
        表示此字符 null成员的Unicode块的 UnicodeBlock实例，如果该字符不是任何Unicode块的成员， null

      • of

        public static Character.UnicodeBlock of​(int codePoint)
        返回表示包含给定字符（Unicode代码点）的Unicode块的对象，如果字符不是定义块的成员，则 null 。
        参数
        codePoint - 有问题的字符（Unicode代码点）。
        结果
        表示该字符为其成员的Unicode块的 UnicodeBlock实例，如果该字符不是任何Unicode块的成员， null
        异常
        IllegalArgumentException - 如果指定的 codePoint是无效的Unicode代码点。
        从以下版本开始：
        1.5
        另请参见：
        Character.isValidCodePoint(int)

      • forName

        public static final Character.UnicodeBlock forName​(String blockName)
        返回具有给定名称的UnicodeBlock。 块名称由Unicode标准确定。 文件Blocks-<version>.txt定义了标准的特定版本的块。 Character类指定了它支持的标准版本。

        此方法接受以下形式的块名称：

        1. 规范块名称由Unicode标准定义。 例如，该标准定义了一个“基本拉丁文”块。 因此，该方法接受“基本拉丁文”作为有效的块名称。 每个UnicodeBlock的文档提供了规范名称。
        2. 所有空间被删除的规范块名称。 例如，“BasicLatin”是“基本拉丁”块的有效块名称。
        3. 每个常量UnicodeBlock标识符的文本表示。 例如，如果提供了“BASIC_LATIN”名称，此方法将返回BASIC_LATIN块。 此表单将使用下划线替换规范名称中的所有空格和连字符。
        最后，对于所有有效的块名称形式，字符大小写将被忽略。 例如，“BASIC_LATIN”和“basic_latin”都是有效的块名称。 en_US语言环境的案例映射规则用于为块名称验证提供不区分大小写的字符串比较。

        如果Unicode标准更改块名称，则将接受上一个和当前的名称。

        参数
        blockName - A UnicodeBlock名字。
        结果
        该 UnicodeBlock通过鉴定实例 blockName
        异常
        IllegalArgumentException - 如果 blockName是无效的名称
        NullPointerException - 如果 blockName为空
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Character.UnicodeScript (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang

Enum Character.UnicodeScript

  • java.lang.Object
    • java.lang.Enum<Character.UnicodeScript>
      • java.lang.Character.UnicodeScript
  • All Implemented Interfaces:
    Serializable ， Comparable<Character.UnicodeScript>
    Enclosing class:
    Character

    public static enum Character.UnicodeScript
extends Enum<Character.UnicodeScript>
    一系列字符子集，表示Unicode Standard Annex #24: Script Names中定义的字符脚本。 每Unicode字符被分配给单个Unicode脚本，无论是特定的脚本，例如Latin ，或以下三个特殊值中的一个， Inherited ， Common或Unknown 。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      AHOM
      Unicode脚本“Ahom”。
      ANATOLIAN_HIEROGLYPHS
      Unicode脚本“安纳托利亚象形文字”。
      ARABIC
      Unicode脚本“阿拉伯语”。
      ARMENIAN
      Unicode脚本“亚美尼亚”。
      AVESTAN
      Unicode脚本“Avestan”。
      BALINESE
      Unicode脚本“巴厘岛”。
      BAMUM
      Unicode脚本“Bamum”。
      BASSA_VAH
      Unicode脚本“Bassa Vah”。
      BATAK
      Unicode脚本“Batak”。
      BENGALI
      Unicode脚本“孟加拉语”。
      BOPOMOFO
      Unicode脚本“Bopomofo”。
      BRAHMI
      Unicode脚本“Brahmi”。
      BRAILLE
      Unicode脚本“盲文”。
      BUGINESE
      Unicode脚本“Buginese”。
      BUHID
      Unicode脚本“Buhid”。
      CANADIAN_ABORIGINAL
      Unicode脚本“Canadian_Aboriginal”。
      CARIAN
      Unicode脚本“Carian”。
      CAUCASIAN_ALBANIAN
      Unicode脚本“白种人阿尔巴尼亚人”。
      CHAKMA
      Unicode脚本“Chakma”。
      CHAM
      Unicode脚本“Cham”。
      CHEROKEE
      Unicode脚本“切诺基”。
      COMMON
      Unicode脚本“常用”。
      COPTIC
      Unicode脚本“科普特”。
      CUNEIFORM
      Unicode脚本“楔形文字”。
      CYPRIOT
      Unicode脚本“塞浦路斯”。
      CYRILLIC
      Unicode脚本“西里尔文”。
      DESERET
      Unicode脚本“Deseret”。
      DEVANAGARI
      Unicode脚本“Devanagari”。
      DUPLOYAN
      Unicode脚本“Duployan”。
      EGYPTIAN_HIEROGLYPHS
      Unicode脚本“Egyptian_Hieroglyphs”。
      ELBASAN
      Unicode脚本“Elbasan”。
      ETHIOPIC
      Unicode脚本“埃塞俄比亚”。
      GEORGIAN
      Unicode脚本“格鲁吉亚”。
      GLAGOLITIC
      Unicode脚本“Glagolitic”。
      GOTHIC
      Unicode脚本“哥特式”。
      GRANTHA
      Unicode脚本“Grantha”。
      GREEK
      Unicode脚本“希腊语”。
      GUJARATI
      Unicode脚本“古吉拉特”。
      GURMUKHI
      Unicode脚本“Gurmukhi”。
      HAN
      Unicode脚本“汉”。
      HANGUL
      Unicode脚本“Hangul”。
      HANUNOO
      Unicode脚本“Hanunoo”。
      HATRAN
      Unicode脚本“Hatran”。
      HEBREW
      Unicode脚本“希伯来语”。
      HIRAGANA
      Unicode脚本“平假名”。
      IMPERIAL_ARAMAIC
      Unicode脚本“Imperial_Aramaic”。
      INHERITED
      Unicode脚本“Inherited”。
      INSCRIPTIONAL_PAHLAVI
      Unicode脚本“Inscriptional_Pahlavi”。
      INSCRIPTIONAL_PARTHIAN
      Unicode脚本“Inscriptional_Parthian”。
      JAVANESE
      Unicode脚本“爪哇”。
      KAITHI
      Unicode脚本“Kaithi”。
      KANNADA
      Unicode脚本“Kannada”。
      KATAKANA
      Unicode脚本“片假名”。
      KAYAH_LI
      Unicode脚本“Kayah_Li”。
      KHAROSHTHI
      Unicode脚本“Kharoshthi”。
      KHMER
      Unicode脚本“高棉”。
      KHOJKI
      Unicode脚本“Khojki”。
      KHUDAWADI
      Unicode脚本“Khudawadi”。
      LAO
      Unicode脚本“老挝”。
      LATIN
      Unicode脚本“拉丁文”。
      LEPCHA
      Unicode脚本“Lepcha”。
      LIMBU
      Unicode脚本“Limbu”。
      LINEAR_A
      Unicode脚本“线性A”。
      LINEAR_B
      Unicode脚本“Linear_B”。
      LISU
      Unicode脚本“Lisu”。
      LYCIAN
      Unicode脚本“Lycian”。
      LYDIAN
      Unicode脚本“Lydian”。
      MAHAJANI
      Unicode脚本“Mahajani”。
      MALAYALAM
      Unicode脚本“马拉雅拉姆”。
      MANDAIC
      Unicode脚本“Mandaic”。
      MANICHAEAN
      Unicode脚本“Manichaean”。
      MEETEI_MAYEK
      Unicode脚本“Meetei_Mayek”。
      MENDE_KIKAKUI
      Unicode脚本“Mende Kikakui”。
      MEROITIC_CURSIVE
      Unicode脚本“Meroitic Cursive”。
      MEROITIC_HIEROGLYPHS
      Unicode脚本“Meroitic象形文字”。
      MIAO
      Unicode脚本“苗”。
      MODI
      Unicode脚本“Modi”。
      MONGOLIAN
      Unicode脚本“蒙古语”。
      MRO
      Unicode脚本“Mro”。
      MULTANI
      Unicode脚本“Multani”。
      MYANMAR
      Unicode脚本“缅甸”。
      NABATAEAN
      Unicode脚本“Nabataean”。
      NEW_TAI_LUE
      Unicode脚本“New_Tai_Lue”。
      NKO
      Unicode脚本“Nko”。
      OGHAM
      Unicode脚本“Ogham”。
      OL_CHIKI
      Unicode脚本“Ol_Chiki”。
      OLD_HUNGARIAN
      Unicode脚本“古匈牙利”。
      OLD_ITALIC
      Unicode脚本“Old_Italic”。
      OLD_NORTH_ARABIAN
      Unicode脚本“老北阿拉伯”。
      OLD_PERMIC
      Unicode脚本“Old Permic”。
      OLD_PERSIAN
      Unicode脚本“Old_Persian”。
      OLD_SOUTH_ARABIAN
      Unicode脚本“Old_South_Arabian”。
      OLD_TURKIC
      Unicode脚本“Old_Turkic”。
      ORIYA
      Unicode脚本“Oriya”。
      OSMANYA
      Unicode脚本“Osmanya”。
      PAHAWH_HMONG
      Unicode脚本“Pahawh Hmong”。
      PALMYRENE
      Unicode脚本“棕榈”。
      PAU_CIN_HAU
      Unicode脚本“Pau Cin Hau”。
      PHAGS_PA
      Unicode脚本“Phags_Pa”。
      PHOENICIAN
      Unicode脚本“腓尼基”。
      PSALTER_PAHLAVI
      Unicode脚本“Psalter Pahlavi”。
      REJANG
      Unicode脚本“Rejang”。
      RUNIC
      Unicode脚本“符文”。
      SAMARITAN
      Unicode脚本“撒玛利亚人”。
      SAURASHTRA
      Unicode脚本“Saurashtra”。
      SHARADA
      Unicode脚本“Sharada”。
      SHAVIAN
      Unicode脚本“Shavian”。
      SIDDHAM
      Unicode脚本“Siddham”。
      SIGNWRITING
      Unicode脚本“SignWriting”。
      SINHALA
      Unicode脚本“僧伽罗”。
      SORA_SOMPENG
      Unicode脚本“Sora Sompeng”。
      SUNDANESE
      Unicode脚本“Sundanese”。
      SYLOTI_NAGRI
      Unicode脚本“Syloti_Nagri”。
      SYRIAC
      Unicode脚本“Syriac”。
      TAGALOG
      Unicode脚本“他加禄语”。
      TAGBANWA
      Unicode脚本“Tagbanwa”。
      TAI_LE
      Unicode脚本“Tai_Le”。
      TAI_THAM
      Unicode脚本“Tai_Tham”。
      TAI_VIET
      Unicode脚本“Tai_Viet”。
      TAKRI
      Unicode脚本“Takri”。
      TAMIL
      Unicode脚本“Tamil”。
      TELUGU
      Unicode脚本“泰卢固语”。
      THAANA
      Unicode脚本“Thaana”。
      THAI
      Unicode脚本“泰语”。
      TIBETAN
      Unicode脚本“藏族”。
      TIFINAGH
      Unicode脚本“Tifinagh”。
      TIRHUTA
      Unicode脚本“Tirhuta”。
      UGARITIC
      Unicode脚本“Ugaritic”。
      UNKNOWN
      Unicode脚本“未知”。
      VAI
      Unicode脚本“Vai”。
      WARANG_CITI
      Unicode脚本“Warang花旗”。
      YI
      Unicode脚本“彝”。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Character.UnicodeScript forName​(String scriptName)
      使用给定的Unicode脚本名称或脚本名称别名返回UnicodeScript常量。
      static Character.UnicodeScript of​(int codePoint)
      返回表示给定字符（Unicode代码点）分配给的Unicode脚本的枚举常量。
      static Character.UnicodeScript valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Character.UnicodeScript[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • COMMON

        public static final Character.UnicodeScript COMMON
        Unicode脚本“常用”。

      • LATIN

        public static final Character.UnicodeScript LATIN
        Unicode脚本“拉丁文”。

      • GREEK

        public static final Character.UnicodeScript GREEK
        Unicode脚本“希腊语”。

      • CYRILLIC

        public static final Character.UnicodeScript CYRILLIC
        Unicode脚本“西里尔文”。

      • ARMENIAN

        public static final Character.UnicodeScript ARMENIAN
        Unicode脚本“亚美尼亚”。

      • HEBREW

        public static final Character.UnicodeScript HEBREW
        Unicode脚本“希伯来语”。

      • ARABIC

        public static final Character.UnicodeScript ARABIC
        Unicode脚本“阿拉伯语”。

      • SYRIAC

        public static final Character.UnicodeScript SYRIAC
        Unicode脚本“Syriac”。

      • THAANA

        public static final Character.UnicodeScript THAANA
        Unicode脚本“Thaana”。

      • DEVANAGARI

        public static final Character.UnicodeScript DEVANAGARI
        Unicode脚本“Devanagari”。

      • BENGALI

        public static final Character.UnicodeScript BENGALI
        Unicode脚本“孟加拉语”。

      • GURMUKHI

        public static final Character.UnicodeScript GURMUKHI
        Unicode脚本“Gurmukhi”。

      • GUJARATI

        public static final Character.UnicodeScript GUJARATI
        Unicode脚本“古吉拉特”。

      • ORIYA

        public static final Character.UnicodeScript ORIYA
        Unicode脚本“Oriya”。

      • TAMIL

        public static final Character.UnicodeScript TAMIL
        Unicode脚本“Tamil”。

      • TELUGU

        public static final Character.UnicodeScript TELUGU
        Unicode脚本“泰卢固语”。

      • KANNADA

        public static final Character.UnicodeScript KANNADA
        Unicode脚本“Kannada”。

      • MALAYALAM

        public static final Character.UnicodeScript MALAYALAM
        Unicode脚本“马拉雅拉姆”。

      • SINHALA

        public static final Character.UnicodeScript SINHALA
        Unicode脚本“僧伽罗”。

      • THAI

        public static final Character.UnicodeScript THAI
        Unicode脚本“泰语”。

      • LAO

        public static final Character.UnicodeScript LAO
        Unicode脚本“老挝”。

      • TIBETAN

        public static final Character.UnicodeScript TIBETAN
        Unicode脚本“藏族”。

      • MYANMAR

        public static final Character.UnicodeScript MYANMAR
        Unicode脚本“缅甸”。

      • GEORGIAN

        public static final Character.UnicodeScript GEORGIAN
        Unicode脚本“格鲁吉亚”。

      • HANGUL

        public static final Character.UnicodeScript HANGUL
        Unicode脚本“Hangul”。

      • ETHIOPIC

        public static final Character.UnicodeScript ETHIOPIC
        Unicode脚本“埃塞俄比亚”。

      • CHEROKEE

        public static final Character.UnicodeScript CHEROKEE
        Unicode脚本“切诺基”。

      • CANADIAN_ABORIGINAL

        public static final Character.UnicodeScript CANADIAN_ABORIGINAL
        Unicode脚本“Canadian_Aboriginal”。

      • OGHAM

        public static final Character.UnicodeScript OGHAM
        Unicode脚本“Ogham”。

      • RUNIC

        public static final Character.UnicodeScript RUNIC
        Unicode脚本“符文”。

      • KHMER

        public static final Character.UnicodeScript KHMER
        Unicode脚本“高棉”。

      • MONGOLIAN

        public static final Character.UnicodeScript MONGOLIAN
        Unicode脚本“蒙古语”。

      • HIRAGANA

        public static final Character.UnicodeScript HIRAGANA
        Unicode脚本“平假名”。

      • KATAKANA

        public static final Character.UnicodeScript KATAKANA
        Unicode脚本“片假名”。

      • BOPOMOFO

        public static final Character.UnicodeScript BOPOMOFO
        Unicode脚本“Bopomofo”。

      • HAN

        public static final Character.UnicodeScript HAN
        Unicode脚本“汉”。

      • YI

        public static final Character.UnicodeScript YI
        Unicode脚本“彝”。

      • OLD_ITALIC

        public static final Character.UnicodeScript OLD_ITALIC
        Unicode脚本“Old_Italic”。

      • GOTHIC

        public static final Character.UnicodeScript GOTHIC
        Unicode脚本“哥特式”。

      • DESERET

        public static final Character.UnicodeScript DESERET
        Unicode脚本“Deseret”。

      • INHERITED

        public static final Character.UnicodeScript INHERITED
        Unicode脚本“Inherited”。

      • TAGALOG

        public static final Character.UnicodeScript TAGALOG
        Unicode脚本“他加禄语”。

      • HANUNOO

        public static final Character.UnicodeScript HANUNOO
        Unicode脚本“Hanunoo”。

      • BUHID

        public static final Character.UnicodeScript BUHID
        Unicode脚本“Buhid”。

      • TAGBANWA

        public static final Character.UnicodeScript TAGBANWA
        Unicode脚本“Tagbanwa”。

      • LIMBU

        public static final Character.UnicodeScript LIMBU
        Unicode脚本“Limbu”。

      • TAI_LE

        public static final Character.UnicodeScript TAI_LE
        Unicode脚本“Tai_Le”。

      • LINEAR_B

        public static final Character.UnicodeScript LINEAR_B
        Unicode脚本“Linear_B”。

      • UGARITIC

        public static final Character.UnicodeScript UGARITIC
        Unicode脚本“Ugaritic”。

      • SHAVIAN

        public static final Character.UnicodeScript SHAVIAN
        Unicode脚本“Shavian”。

      • OSMANYA

        public static final Character.UnicodeScript OSMANYA
        Unicode脚本“Osmanya”。

      • CYPRIOT

        public static final Character.UnicodeScript CYPRIOT
        Unicode脚本“塞浦路斯”。

      • BRAILLE

        public static final Character.UnicodeScript BRAILLE
        Unicode脚本“盲文”。

      • BUGINESE

        public static final Character.UnicodeScript BUGINESE
        Unicode脚本“Buginese”。

      • COPTIC

        public static final Character.UnicodeScript COPTIC
        Unicode脚本“科普特”。

      • NEW_TAI_LUE

        public static final Character.UnicodeScript NEW_TAI_LUE
        Unicode脚本“New_Tai_Lue”。

      • GLAGOLITIC

        public static final Character.UnicodeScript GLAGOLITIC
        Unicode脚本“Glagolitic”。

      • TIFINAGH

        public static final Character.UnicodeScript TIFINAGH
        Unicode脚本“Tifinagh”。

      • SYLOTI_NAGRI

        public static final Character.UnicodeScript SYLOTI_NAGRI
        Unicode脚本“Syloti_Nagri”。

      • OLD_PERSIAN

        public static final Character.UnicodeScript OLD_PERSIAN
        Unicode脚本“Old_Persian”。

      • KHAROSHTHI

        public static final Character.UnicodeScript KHAROSHTHI
        Unicode脚本“Kharoshthi”。

      • BALINESE

        public static final Character.UnicodeScript BALINESE
        Unicode脚本“巴厘岛”。

      • CUNEIFORM

        public static final Character.UnicodeScript CUNEIFORM
        Unicode脚本“楔形文字”。

      • PHOENICIAN

        public static final Character.UnicodeScript PHOENICIAN
        Unicode脚本“腓尼基”。

      • PHAGS_PA

        public static final Character.UnicodeScript PHAGS_PA
        Unicode脚本“Phags_Pa”。

      • NKO

        public static final Character.UnicodeScript NKO
        Unicode脚本“Nko”。

      • SUNDANESE

        public static final Character.UnicodeScript SUNDANESE
        Unicode脚本“Sundanese”。

      • BATAK

        public static final Character.UnicodeScript BATAK
        Unicode脚本“Batak”。

      • LEPCHA

        public static final Character.UnicodeScript LEPCHA
        Unicode脚本“Lepcha”。

      • OL_CHIKI

        public static final Character.UnicodeScript OL_CHIKI
        Unicode脚本“Ol_Chiki”。

      • VAI

        public static final Character.UnicodeScript VAI
        Unicode脚本“Vai”。

      • SAURASHTRA

        public static final Character.UnicodeScript SAURASHTRA
        Unicode脚本“Saurashtra”。

      • KAYAH_LI

        public static final Character.UnicodeScript KAYAH_LI
        Unicode脚本“Kayah_Li”。

      • REJANG

        public static final Character.UnicodeScript REJANG
        Unicode脚本“Rejang”。

      • LYCIAN

        public static final Character.UnicodeScript LYCIAN
        Unicode脚本“Lycian”。

      • CARIAN

        public static final Character.UnicodeScript CARIAN
        Unicode脚本“Carian”。

      • LYDIAN

        public static final Character.UnicodeScript LYDIAN
        Unicode脚本“Lydian”。

      • CHAM

        public static final Character.UnicodeScript CHAM
        Unicode脚本“Cham”。

      • TAI_THAM

        public static final Character.UnicodeScript TAI_THAM
        Unicode脚本“Tai_Tham”。

      • TAI_VIET

        public static final Character.UnicodeScript TAI_VIET
        Unicode脚本“Tai_Viet”。

      • AVESTAN

        public static final Character.UnicodeScript AVESTAN
        Unicode脚本“Avestan”。

      • EGYPTIAN_HIEROGLYPHS

        public static final Character.UnicodeScript EGYPTIAN_HIEROGLYPHS
        Unicode脚本“Egyptian_Hieroglyphs”。

      • SAMARITAN

        public static final Character.UnicodeScript SAMARITAN
        Unicode脚本“撒玛利亚人”。

      • MANDAIC

        public static final Character.UnicodeScript MANDAIC
        Unicode脚本“Mandaic”。

      • LISU

        public static final Character.UnicodeScript LISU
        Unicode脚本“Lisu”。

      • BAMUM

        public static final Character.UnicodeScript BAMUM
        Unicode脚本“Bamum”。

      • JAVANESE

        public static final Character.UnicodeScript JAVANESE
        Unicode脚本“爪哇”。

      • MEETEI_MAYEK

        public static final Character.UnicodeScript MEETEI_MAYEK
        Unicode脚本“Meetei_Mayek”。

      • IMPERIAL_ARAMAIC

        public static final Character.UnicodeScript IMPERIAL_ARAMAIC
        Unicode脚本“Imperial_Aramaic”。

      • OLD_SOUTH_ARABIAN

        public static final Character.UnicodeScript OLD_SOUTH_ARABIAN
        Unicode脚本“Old_South_Arabian”。

      • INSCRIPTIONAL_PARTHIAN

        public static final Character.UnicodeScript INSCRIPTIONAL_PARTHIAN
        Unicode脚本“Inscriptional_Parthian”。

      • INSCRIPTIONAL_PAHLAVI

        public static final Character.UnicodeScript INSCRIPTIONAL_PAHLAVI
        Unicode脚本“Inscriptional_Pahlavi”。

      • OLD_TURKIC

        public static final Character.UnicodeScript OLD_TURKIC
        Unicode脚本“Old_Turkic”。

      • BRAHMI

        public static final Character.UnicodeScript BRAHMI
        Unicode脚本“Brahmi”。

      • KAITHI

        public static final Character.UnicodeScript KAITHI
        Unicode脚本“Kaithi”。

      • MEROITIC_HIEROGLYPHS

        public static final Character.UnicodeScript MEROITIC_HIEROGLYPHS
        Unicode脚本“Meroitic象形文字”。
        从以下版本开始：
        1.8

      • MEROITIC_CURSIVE

        public static final Character.UnicodeScript MEROITIC_CURSIVE
        Unicode脚本“Meroitic Cursive”。
        从以下版本开始：
        1.8

      • SORA_SOMPENG

        public static final Character.UnicodeScript SORA_SOMPENG
        Unicode脚本“Sora Sompeng”。
        从以下版本开始：
        1.8

      • CHAKMA

        public static final Character.UnicodeScript CHAKMA
        Unicode脚本“Chakma”。
        从以下版本开始：
        1.8

      • SHARADA

        public static final Character.UnicodeScript SHARADA
        Unicode脚本“Sharada”。
        从以下版本开始：
        1.8

      • TAKRI

        public static final Character.UnicodeScript TAKRI
        Unicode脚本“Takri”。
        从以下版本开始：
        1.8

      • MIAO

        public static final Character.UnicodeScript MIAO
        Unicode脚本“苗”。
        从以下版本开始：
        1.8

      • CAUCASIAN_ALBANIAN

        public static final Character.UnicodeScript CAUCASIAN_ALBANIAN
        Unicode脚本“白种人阿尔巴尼亚人”。
        从以下版本开始：
        9

      • BASSA_VAH

        public static final Character.UnicodeScript BASSA_VAH
        Unicode脚本“Bassa Vah”。
        从以下版本开始：
        9

      • DUPLOYAN

        public static final Character.UnicodeScript DUPLOYAN
        Unicode脚本“Duployan”。
        从以下版本开始：
        9

      • ELBASAN

        public static final Character.UnicodeScript ELBASAN
        Unicode脚本“Elbasan”。
        从以下版本开始：
        9

      • GRANTHA

        public static final Character.UnicodeScript GRANTHA
        Unicode脚本“Grantha”。
        从以下版本开始：
        9

      • PAHAWH_HMONG

        public static final Character.UnicodeScript PAHAWH_HMONG
        Unicode脚本“Pahawh Hmong”。
        从以下版本开始：
        9

      • KHOJKI

        public static final Character.UnicodeScript KHOJKI
        Unicode脚本“Khojki”。
        从以下版本开始：
        9

      • LINEAR_A

        public static final Character.UnicodeScript LINEAR_A
        Unicode脚本“线性A”。
        从以下版本开始：
        9

      • MAHAJANI

        public static final Character.UnicodeScript MAHAJANI
        Unicode脚本“Mahajani”。
        从以下版本开始：
        9

      • MANICHAEAN

        public static final Character.UnicodeScript MANICHAEAN
        Unicode脚本“Manichaean”。
        从以下版本开始：
        9

      • MENDE_KIKAKUI

        public static final Character.UnicodeScript MENDE_KIKAKUI
        Unicode脚本“Mende Kikakui”。
        从以下版本开始：
        9

      • MODI

        public static final Character.UnicodeScript MODI
        Unicode脚本“Modi”。
        从以下版本开始：
        9

      • MRO

        public static final Character.UnicodeScript MRO
        Unicode脚本“Mro”。
        从以下版本开始：
        9

      • OLD_NORTH_ARABIAN

        public static final Character.UnicodeScript OLD_NORTH_ARABIAN
        Unicode脚本“老北阿拉伯”。
        从以下版本开始：
        9

      • NABATAEAN

        public static final Character.UnicodeScript NABATAEAN
        Unicode脚本“Nabataean”。
        从以下版本开始：
        9

      • PALMYRENE

        public static final Character.UnicodeScript PALMYRENE
        Unicode脚本“棕榈”。
        从以下版本开始：
        9

      • PAU_CIN_HAU

        public static final Character.UnicodeScript PAU_CIN_HAU
        Unicode脚本“Pau Cin Hau”。
        从以下版本开始：
        9

      • OLD_PERMIC

        public static final Character.UnicodeScript OLD_PERMIC
        Unicode脚本“Old Permic”。
        从以下版本开始：
        9

      • PSALTER_PAHLAVI

        public static final Character.UnicodeScript PSALTER_PAHLAVI
        Unicode脚本“Psalter Pahlavi”。
        从以下版本开始：
        9

      • SIDDHAM

        public static final Character.UnicodeScript SIDDHAM
        Unicode脚本“Siddham”。
        从以下版本开始：
        9

      • KHUDAWADI

        public static final Character.UnicodeScript KHUDAWADI
        Unicode脚本“Khudawadi”。
        从以下版本开始：
        9

      • TIRHUTA

        public static final Character.UnicodeScript TIRHUTA
        Unicode脚本“Tirhuta”。
        从以下版本开始：
        9

      • WARANG_CITI

        public static final Character.UnicodeScript WARANG_CITI
        Unicode脚本“Warang花旗”。
        从以下版本开始：
        9

      • AHOM

        public static final Character.UnicodeScript AHOM
        Unicode脚本“Ahom”。
        从以下版本开始：
        9

      • ANATOLIAN_HIEROGLYPHS

        public static final Character.UnicodeScript ANATOLIAN_HIEROGLYPHS
        Unicode脚本“安纳托利亚象形文字”。
        从以下版本开始：
        9

      • HATRAN

        public static final Character.UnicodeScript HATRAN
        Unicode脚本“Hatran”。
        从以下版本开始：
        9

      • MULTANI

        public static final Character.UnicodeScript MULTANI
        Unicode脚本“Multani”。
        从以下版本开始：
        9

      • OLD_HUNGARIAN

        public static final Character.UnicodeScript OLD_HUNGARIAN
        Unicode脚本“古匈牙利”。
        从以下版本开始：
        9

      • SIGNWRITING

        public static final Character.UnicodeScript SIGNWRITING
        Unicode脚本“SignWriting”。
        从以下版本开始：
        9

      • UNKNOWN

        public static final Character.UnicodeScript UNKNOWN
        Unicode脚本“未知”。

    • 方法详细信息

      • values

        public static Character.UnicodeScript[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Character.UnicodeScript c : Character.UnicodeScript.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Character.UnicodeScript valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • of

        public static Character.UnicodeScript of​(int codePoint)
        返回表示给定字符（Unicode代码点）分配给的Unicode脚本的枚举常量。
        参数
        codePoint - 有问题的字符（Unicode代码点）。
        结果
        表示此字符分配给的Unicode脚本的 UnicodeScript常量。
        异常
        IllegalArgumentException - 如果指定的 codePoint是无效的Unicode代码点。
        另请参见：
        Character.isValidCodePoint(int)

      • forName

        public static final Character.UnicodeScript forName​(String scriptName)
        使用给定的Unicode脚本名称或脚本名称别名返回UnicodeScript常量。 脚本名称及其别名由Unicode标准确定。 文件Scripts<version>.txt和PropertyValueAliases<version>.txt为标准的特定版本定义脚本名称和脚本名称别名。 Character类指定其支持的标准版本。

        所有有效的脚本名称都会忽略字符大小写。 en_US语言环境的案例映射规则用于为脚本名称验证提供不区分大小写的字符串比较。

        参数
        scriptName - A UnicodeScript名字。
        结果
        UnicodeScript常数由 scriptName确定
        异常
        IllegalArgumentException - 如果 scriptName是无效的名称
        NullPointerException - if scriptName is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


CharSequence (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface CharSequence

  • All Known Subinterfaces:
    Name
    所有已知实现类：
    CharBuffer ， Segment ， String ， StringBuffer ， StringBuilder

    public interface CharSequence
    A CharSequence是char值的可读序列。 该接口提供对许多不同类型的char序列的统一的只读访问。 A char值表示基本多语言平面（BMP）或代理中的字符。 详见Unicode Character Representation 。

    此接口不会改进equals和hashCode方法的一般合同。 因此，比较实现CharSequence两个对象的结果CharSequence是未定义的。 每个对象可以由不同的类实现，并且不能保证每个类都能够测试其实例以与另一个类相同。 因此，使用任意CharSequence实例作为集合中的元素或映射中的键是不合适的。

    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      char charAt​(int index)
      返回指定索引处的 char值。
      default IntStream chars​()
      返回一个 int的流，从这个序列中扩展 char值。
      default IntStream codePoints​()
      从此序列返回码流值。
      int length​()
      返回此字符序列的长度。
      CharSequence subSequence​(int start, int end)
      返回一个 CharSequence ，这是这个序列的一个子序列。
      String toString​()
      以与此顺序相同的顺序返回包含此序列中的字符的字符串。

    • 方法详细信息

      • length

        int length​()
        返回此字符序列的长度。 长度是序列中16位char的数量。
        结果
        这个序列中的数字为 char

      • charAt

        char charAt​(int index)
        返回指定索引处的char值。 索引范围从零到length() - 1 。 序列的第一个char值在索引为零，下一个索引为1，依此类推，就像数组索引一样。

        如果索引指定的char值为surrogate ，则返回替代值。

        参数
        index - 要返回的 char值的索引
        结果
        指定 char值
        异常
        IndexOutOfBoundsException - 如果 index参数为负数或不小于 length()

      • subSequence

        CharSequence subSequence​(int start,
                         int end)
        返回一个CharSequence ，这是这个序列的子序列。 该子序列与所述启动char指定索引处值和与所述结束char在索引值end - 1 。 返回序列的长度（ char s）为end - start ，因此如果start == end返回一个空序列。
        参数
        start - 开始索引（含）
        end - 结束索引，独占
        结果
        指定的子序列
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，如果 end大于 length() ，或者如果 start大于 end

      • toString

        String toString​()
        以与此顺序相同的顺序返回包含此序列中的字符的字符串。 字符串的长度将是此序列的长度。
        重写：
        toString在类 Object
        结果
        一个由这个字符序列组成的字符串

      • chars

        default IntStream chars​()
        返回一个int的数据流，从这个序列中扩展char值。 映射到surrogate code point的任何字符都通过未解释的方式传递。

        当终端流操作开始时（特别地，对于可变序列，流的分流器是late-binding ），流与该序列绑定。 如果序列在该操作期间被修改，则结果是未定义的。

        结果
        这个序列中的char值的IntStream
        从以下版本开始：
        1.8

      • codePoints

        default IntStream codePoints​()
        从此序列返回码流值。 在序列中遇到的任何代理对被组合，如同通过Character.toCodePoint一样 ，并将结果传递给流。 任何其他代码单元，包括普通的BMP字符，未配对代理和未定义的代码单元，都将零扩展到int值，然后传递给流。

        当终端流操作开始时（特别地，对于可变序列，流的分流器是late-binding ），流与该序列绑定。 如果序列在该操作期间被修改，则结果是未定义的。

        结果
        Unicode序列的IntStream从这个序列中指向
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Class (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Class<T>

  • java.lang.Object
    • java.lang.Class<T>
  • 参数类型
    T - 由此Class对象建模的类的类型。 例如， String.class的类型是Class<String> 。 如果被建模的类是未知的，请使用Class<?> 。
    All Implemented Interfaces:
    Serializable ， AnnotatedElement ， GenericDeclaration ， Type

    public final class Class<T>
extends Object
implements Serializable, GenericDeclaration, Type, AnnotatedElement
    Class类的实例表示正在运行的Java应用程序中的类和接口。 枚举是一种类，一个注释是一种界面。 每个数组也属于一个类，它被反映为具有相同元素类型和维数的所有数组共享的Class对象。 原始Java类型（ boolean ， byte ， char ， short ， int ， long ， float ，和double ），以及关键字void也表示为Class对象。

    Class没有公共建设者。 相反， Class对象由Java虚拟机自动构建，因为类已加载，并通过调用类加载器中的defineClass方法。

    以下示例使用Class对象打印对象的类名：

         void printClassName(Object obj) {
         System.out.println("The class of " + obj +
                            " is " + obj.getClass().getName());
     }

    也可以使用类文字获取Class对象作为命名类型（或为void）。 参见The Java™ Language Specification第15.8.2节。 例如：

    System.out.println("The name of class Foo is: "+Foo.class.getName());
    从以下版本开始：
    1.0
    另请参见：
    ClassLoader.defineClass(byte[], int, int) ， Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      <U> Class<? extends U> asSubclass​(Class<U> clazz)
      Class这个 Class对象来表示由指定的类对象表示的类的子类。
      T cast​(Object obj)
      将对象 Class到由此 Class对象表示的类或接口上。
      boolean desiredAssertionStatus​()
      如果要在调用此方法时初始化该类，则返回将分配给此类的断言状态。
      static Class<?> forName​(Module module, String name)
      返回 Class给定 binary name给定的模块中。
      static Class<?> forName​(String className)
      返回与给定字符串名称的类或接口相关联的 Class对象。
      static Class<?> forName​(String name, boolean initialize, ClassLoader loader)
      使用给定的类加载器返回与给定字符串名称的类或接口相关联的 Class对象。
      AnnotatedType[] getAnnotatedInterfaces​()
      返回一个 AnnotatedType对象的数组，它们表示使用类型来指定由该 Class对象表示的实体的 Class 。
      AnnotatedType getAnnotatedSuperclass​()
      返回一个 AnnotatedType对象，表示使用类型来指定由该 Class对象表示的实体的超类。
      <A extends Annotation>
      A             		getAnnotation​(Class<A> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getAnnotations​()
      返回此元素上 存在的注释。
      <A extends Annotation>
      A[]             		getAnnotationsByType​(Class<A> annotationClass)
      返回与此元素 相关联的注释。
      String getCanonicalName​()
      返回由Java语言规范定义的基础类的规范名称。
      Class<?>[] getClasses​()
      返回一个数组，其中包含 Class对象，该对象表示由该 Class对象表示的类的成员的所有公共类和接口。
      ClassLoader getClassLoader​()
      返回类的类加载器。
      Class<?> getComponentType​()
      返回表示数组的组件类型的 Class 。
      Constructor<T> getConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由该 Class对象表示的类的指定公共构造函数。
      Constructor<?>[] getConstructors​()
      返回一个包含 Constructor对象的数组， Constructor对象反映了由该 Class对象表示的类的所有公共构造函数。
      <A extends Annotation>
      A             		getDeclaredAnnotation​(Class<A> annotationClass)
      如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      <A extends Annotation>
      A[]             		getDeclaredAnnotationsByType​(Class<A> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      Class<?>[] getDeclaredClasses​()
      返回一个 Class对象的数组，反映了所有被声明为由 Class对象表示的类的成员的类和接口。
      Constructor<T> getDeclaredConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由此 Class对象表示的类或接口的指定构造函数。
      Constructor<?>[] getDeclaredConstructors​()
      返回反映由该 Class对象表示的类声明的所有构造函数的 Constructor对象的数组。
      Field getDeclaredField​(String name)
      返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定声明字段。
      Field[] getDeclaredFields​()
      返回一个 Field对象的数组，反映了由该 Class对象表示的类或接口声明的所有字段。
      方法 getDeclaredMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，它反映此表示的类或接口的指定声明的方法 Class对象。
      方法[] getDeclaredMethods​()
      返回一个包含 方法对象的数组， 方法对象反映由 Class对象表示的类或接口的所有声明方法，包括public，protected，default（package）访问和私有方法，但不包括继承方法。
      Class<?> getDeclaringClass​()
      如果由此 Class对象表示的类或接口是另一个类的成员，则返回表示其声明的类的 Class对象。
      Class<?> getEnclosingClass​()
      返回底层类的即时封闭类。
      Constructor<?> getEnclosingConstructor​()
      如果这个Class对象表示构造函数中的本地或匿名类，则返回一个Constructor对象，该对象表示底层类的立即封闭构造函数。
      方法 getEnclosingMethod​()
      如果此Class对象表示方法中的本地或匿名类，则返回表示基础类的即时封闭方法的方法对象。
      T[] getEnumConstants​()
      返回此枚举类的元素，如果此Class对象不表示枚举类型，则返回null。
      Field getField​(String name)
      返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定公共成员字段。
      Field[] getFields​()
      返回一个包含 Field对象的数组， Field对象反映由该 Class对象表示的类或接口的所有可访问的公共字段。
      Type[] getGenericInterfaces​()
      返回表示由该对象表示的类或接口直接实现的接口的 Type 。
      Type getGenericSuperclass​()
      返回表示由 Type表示的实体的直接超类（类，接口，原始类型或空白）的 Class 。
      Class<?>[] getInterfaces​()
      返回由该对象表示的类或接口直接实现的接口。
      方法 getMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，该对象反映由该 Class对象表示的类或接口的指定公共成员方法。
      方法[] getMethods​()
      返回一个包含 方法对象的数组， 方法对象反映由该 Class对象表示的类或接口的所有公共方法，包括由类或接口声明的对象以及从超类和超级接口继承的类。
      int getModifiers​()
      返回此类或接口的Java语言修饰符，以整数编码。
      Module getModule​()
      返回此类或接口所属的模块。
      String getName​()
      返回由该 Class对象表示的实体（类，接口，数组类，原始类型或无效）的 Class ，作为 String 。
      软件包 getPackage​()
      获取此类的包。
      String getPackageName​()
      返回完全限定的包名称。
      ProtectionDomain getProtectionDomain​()
      返回 ProtectionDomain 。
      URL getResource​(String name)
      查找具有给定名称的资源。
      InputStream getResourceAsStream​(String name)
      查找具有给定名称的资源。
      Object[] getSigners​()
      获得这个类的签名者。
      String getSimpleName​()
      返回源代码中给出的基础类的简单名称。
      Class<? super T> getSuperclass​()
      返回表示由 Class表示的实体的直接超类（类，接口，原语类型或空白）的 Class 。
      String getTypeName​()
      为此类型的名称返回一个内容丰富的字符串。
      TypeVariable<Class<T>>[] getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。
      boolean isAnnotation​()
      如果此 Class对象表示注释类型，则返回true。
      boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      boolean isAnonymousClass​()
      返回 true当且仅当基础类是匿名类时。
      boolean isArray​()
      确定此 Class对象是否表示数组类。
      boolean isAssignableFrom​(Class<?> cls)
      确定由此 Class对象表示的类或接口是否与指定的 Class参数表示的类或接口相同，或者是超类或超级接口。
      boolean isEnum​()
      当且仅当该类在源代码中被声明为枚举时才返回true。
      boolean isInstance​(Object obj)
      确定指定的 Object是否与此 Class表示的对象分配兼容。
      boolean isInterface​()
      确定指定的 Class对象是否表示接口类型。
      boolean isLocalClass​()
      如果且仅当底层类是本地类时返回 true 。
      boolean isMemberClass​()
      如果且仅当底层类是成员类，则返回 true 。
      boolean isPrimitive​()
      确定指定的 Class对象是否表示原始类型。
      boolean isSynthetic​()
      如果这个类是一个合成类，返回true ; 否则返回false 。
      T newInstance​()
      已过时。
      此方法传播由nullary构造函数抛出的任何异常，包括已检查的异常。 使用此方法有效地绕过编译器异常检查，否则将由编译器执行。 Constructor.newInstance方法通过在（已检查） InvocationTargetException中包含构造函数抛出的任何异常来避免此问题。

      电话

         clazz.newInstance()
      可以替换
         clazz.getDeclaredConstructor().newInstance()
      后一个调用序列被推断为能够抛出额外的异常类型InvocationTargetException和NoSuchMethodException 。 这两种异常类型都是ReflectiveOperationException的子类。
      String toGenericString​()
      返回描述此 Class的字符串，包括有关修饰符和类型参数的信息。
      String toString​()
      将对象转换为字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • toString

        public String toString​()
        将对象转换为字符串。 字符串表示是字符串“class”或“interface”，后跟一个空格，然后由类的完全限定名称以getName返回的格式。 如果此Class对象表示原始类型，则此方法返回基元类型的名称。 如果这个Class对象表示void，则此方法返回“void”。 如果此Class对象表示数组类型，则此方法返回“类”，后跟getName 。
        重写：
        toString在 Object
        结果
        这个类对象的字符串表示形式。

      • toGenericString

        public String toGenericString​()
        返回描述此Class的字符串，包括有关修饰符和类型参数的信息。 该字符串格式类型修饰符列表，如果有的话，后面的那种类型（基本类型和空字符串class ， 枚举 ， interface ，或@ interface ，如适用），其次是类型的名称，然后是角色括号的类型参数的逗号分隔列表（如果有）。 一个空格用于将修饰符彼此分离，并将任何修饰符与该类型分隔开。 修饰符以规范的顺序发生。 如果没有类型参数，则类型参数列表将被删除。 对于数组类型，字符串以类型名称开头，后跟一个带角括号的逗号分隔的类型参数类型参数列表（如果有的话），后跟一个[]字符序列，每个数组的每个维的一组括号。

        请注意，由于正在生成关于类型的运行时间表示的信息，因此可能会存在始发源代码上不存在的修饰符或源于源代码的非修饰符。

        结果
        一个描述这个 Class的字符串，包括有关修饰符和类型参数的信息
        从以下版本开始：
        1.8

      • forName

        public static Class<?> forName​(String className)
                        throws ClassNotFoundException
        返回与给定字符串名称的类或接口相关联的Class对象。 调用此方法相当于：
        Class.forName(className, true, currentLoader)
        其中currentLoader表示当前类的定义类加载器。

        例如，以下代码片段返回名为java.lang.Thread的类的运行时Class描述符：

        Class t = Class.forName("java.lang.Thread")

        对forName("X")的调用导致初始化名为X的类。

        参数
        className - 所需类的完全限定名称。
        结果
        具有指定名称的类的 Class对象。
        异常
        LinkageError - 如果链接失败
        ExceptionInInitializerError - 如果由此方法引发的初始化失败
        ClassNotFoundException - 如果该类无法找到

      • forName

        public static Class<?> forName​(String name,
                               boolean initialize,
                               ClassLoader loader)
                        throws ClassNotFoundException
        使用给定的类加载器返回与给定字符串名称的类或接口相关联的Class对象。 给定类或接口的完全限定名称（ getName返回的格式相同），此方法尝试查找，加载和链接类或接口。 指定的类加载器用于加载类或接口。 如果参数loader为空，则通过引导类加载器加载该类。 仅当initialize参数为true并且尚未初始化时，才会初始化true 。

        如果name表示原始类型或空白，将尝试在名称为name的未命名包中定位用户定义的类。 因此，该方法不能用于获取表示原始类型或空白的任何Class对象。

        如果name表示数组类，则会加载数组类的组件类型，但不进行初始化。

        例如，在一个实例方法中，表达式：

        Class.forName("Foo")
        相当于：
        Class.forName("Foo", true, this.getClass().getClassLoader())
        请注意，该方法会引发与Java语言规范的第12.2,12.3和12.4节中指定的加载，链接或初始化相关的错误。 请注意，此方法不检查请求的类是否可由其调用者访问。
        参数
        name - 所需类的完全限定名称
        initialize - 如果true该类将被初始化。 请参见Java语言规范的第12.4节。
        loader - 类加载器，从该类加载
        结果
        表示所需类的类对象
        异常
        LinkageError - 如果连接失败
        ExceptionInInitializerError - 如果由此方法引发的初始化失败
        ClassNotFoundException - 如果类不能由指定的类加载器定位
        SecurityException - 如果存在安全管理员，并且loader是null ，并且呼叫者的类加载程序不是null ，并且呼叫者没有RuntimePermission ("getClassLoader")
        从以下版本开始：
        1.2
        另请参见：
        forName(String) ， ClassLoader

      • forName

        public static Class<?> forName​(Module module,
                               String name)
        返回Class给定binary name给定的模块中。

        此方法尝试查找，加载和链接类或接口。 它不运行类初始化器。 如果没有找到该类，该方法返回null 。

        如果给定模块的类加载器定义了其他模块，给定的名称是在不同模块中定义的类，该方法在加载类后返回null 。

        此方法不检查请求的类是否可由其调用者访问。

        API Note:
        该方法返回null失败，而不是抛出一个ClassNotFoundException ，这是由forName(String, boolean, ClassLoader)方法完成的。 安全检查是一个基于堆栈的权限检查，如果调用者在另一个模块中加载一个类。
        参数
        module - 一个模块
        name - 该类的 binary name
        结果
        给定名称中定义的给定名称的对象Class ; null如果没有找到。
        异常
        NullPointerException - 如果给定的模块或名称是 null
        LinkageError - 如果链接失败
        SecurityException -
        • 如果呼叫者不是指定的模块， RuntimePermission("getClassLoader")被拒绝的RuntimePermission("getClassLoader")是RuntimePermission("getClassLoader") ; 要么
        • 对模块内容的访问被拒绝。 例如，当类加载程序调用ModuleReader.open(String)读取模块中的类文件的字节时，将执行权限检查。
        从以下版本开始：
        9

      • newInstance

        @Deprecated(since="9")
public T newInstance​()
              throws InstantiationException,
                     IllegalAccessException
        已过时。 此方法传播由nullary构造函数抛出的任何异常，包括已检查的异常。 使用此方法有效地绕过编译器异常检查，否则将由编译器执行。 Constructor.newInstance方法通过在（检查的） InvocationTargetException中包含构造函数抛出的任何异常来避免此问题。

        电话

           clazz.newInstance()
        可以替换
           clazz.getDeclaredConstructor().newInstance()
        推断后一个调用序列能够抛出额外的异常类型InvocationTargetException和NoSuchMethodException 。 这两个异常类型都是ReflectiveOperationException的子类。
        创建由该Class对象表示的类的新实例。 该类被实例化为一个具有空参数列表的new表达式。 如果类尚未初始化，则初始化该类。
        结果
        由该对象表示的新分配的类的实例。
        异常
        IllegalAccessException - 如果类或其nullary构造函数不可访问。
        InstantiationException - 如果这个Class表示抽象类，接口，数组类，基元类型或void; 或者类没有空值构造函数; 或者由于某种其他原因，实例化失败。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。

      • isInstance

        public boolean isInstance​(Object obj)
        确定指定的Object是否与此Class表示的对象分配兼容。 这种方法是Java语言instanceof操作符的动态等价物。 该方法返回true如果指定Object参数为非空并且可以转换为通过此表示的引用类型Class对象不提高一个ClassCastException.它返回false否则。

        具体来说，如果这个Class对象表示一个声明的类，如果指定的Object参数是所表示的类（或其任何子类）的实例，则此方法返回true ; 否则返回false 。 如果此Class对象表示数组类，则如果指定的Object参数可以通过标识转换或扩展引用转换转换为数组类的对象，则此方法返回true ; 否则返回false 。 如果这个Class对象表示一个接口，如果类或指定的Object参数的任何超类实现此接口，则此方法返回true ; 否则返回false 。 如果这个Class对象表示一个原始类型，此方法返回false 。

        参数
        obj - 要检查的对象
        结果
        如果 obj是 obj的实例， obj true
        从以下版本开始：
        1.1

      • isAssignableFrom

        public boolean isAssignableFrom​(Class<?> cls)
        确定由此Class对象表示的类或接口是否与由指定的Class参数表示的类或接口相同，或者是超类或超级接口。 如果是，则返回true ; 否则返回false 。 如果此Class对象表示原始类型，则如果指定的Class参数正好是Class对象，则此方法返回true ; 否则返回false 。

        具体来说，该方法通过标识转换或扩展参考转换来测试由指定的Class参数表示的类型是否可以转换为由该Class对象表示的类型。 有关详细信息 ，请参阅Java语言规范 5.1.1和5.1.4节。

        参数
        cls - 要检查的 Class对象
        结果
        boolean值表示可以将类型为 cls对象分配给此类的对象
        异常
        NullPointerException - 如果指定的Class参数为空。
        从以下版本开始：
        1.1

      • isInterface

        public boolean isInterface​()
        确定指定的 Class对象是否表示接口类型。
        结果
        true如果此对象表示一个接口; 否则为false 。

      • isArray

        public boolean isArray​()
        确定此 Class对象是否表示数组类。
        结果
        true如果此对象表示数组类; 否则为false 。
        从以下版本开始：
        1.1

      • isPrimitive

        public boolean isPrimitive​()
        确定指定的Class对象是否表示原始类型。

        有九个预定义的Class对象来表示八个基本类型和void。 这些是由Java虚拟机创建，并且具有相同的名称为他们所代表的基本类型，即boolean ， byte ， char ， short ， int ， long ， float ，并double 。

        这些对象只能通过以下公共静态最终变量访问，并且是该方法返回的唯一的Class对象true 。

        结果
        当且仅当此类表示原始类型时才为true
        从以下版本开始：
        1.1
        另请参见：
        Boolean.TYPE ， Character.TYPE ， Byte.TYPE ， Short.TYPE ， Integer.TYPE ， Long.TYPE ， Float.TYPE ， Double.TYPE ， Void.TYPE

      • isAnnotation

        public boolean isAnnotation​()
        如果此Class对象表示注释类型，则返回true。 请注意，如果此方法返回true，则isInterface()也将返回true，因为所有注释类型也是接口。
        结果
        true如果此类对象表示注释类型; 否则为false
        从以下版本开始：
        1.5

      • isSynthetic

        public boolean isSynthetic​()
        如果这个类是一个合成类，返回true ; 否则返回false 。
        结果
        true当且仅当该类是由Java语言规范定义的合成类时。
        从以下版本开始：
        1.5
        See The Java™ Language Specification:
        13.1二进制形式

      • getName

        public String getName​()
        返回由该Class对象表示的实体（类，接口，数组类，原始类型或无效）的Class ，作为String 。

        如果此类对象表示不是数组类型的引用类型，则返回类的二进制名称，如The Java™ Language Specification所指定。

        如果此类对象表示原始类型或空值，则返回的名称是等同于基本类型或void的Java语言关键字的String 。

        如果此类对象表示一个数组类型，那么该名称的内部形式将由一个或多个表示数组嵌套深度的“ [ ”字符前面的元素类型的名称组成。 元素类型名称的编码如下：

        Element types and encodings
        Element Type | Encoding
        boolean | Z
        byte | B
        char | C
        class or interface | Lclassname;
        double | D
        float | F
        int | I
        long | J
        short | S

        类或接口名称classname是上面指定的类的二进制名称。

        例子：

         String.class.getName()
     returns "java.lang.String"
 byte.class.getName()
     returns "byte"
 (new Object[3]).getClass().getName()
     returns "[Ljava.lang.Object;"
 (new int[3][4][5][6][7][8][9]).getClass().getName()
     returns "[[[[[[[I"
        结果
        由该对象表示的类或接口的名称。

      • getClassLoader

        public ClassLoader getClassLoader​()
        返回类的类加载器。 一些实现可能使用null来表示引导类加载器。 如果此类由引导类加载器加载，则此方法将在此类实现中返回null。

        如果此对象表示原始类型或空值，则返回null。

        结果
        加载由该对象表示的类或接口的类加载器。
        异常
        SecurityException - 如果存在安全管理员，并且调用者的类加载器不是null ，并且与请求类加载器的类的类加载器不同或者是祖先，并且主叫方没有RuntimePermission ("getClassLoader")
        另请参见：
        ClassLoader ， SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission

      • getModule

        public Module getModule​()
        返回此类或接口所属的模块。 如果此类表示数组类型，则此方法将返回元素类型的Module 。 如果此类表示原始类型或空值，则返回java.base模块的Module对象。 如果这个类是一个未命名的模块，那么返回这个类的类加载器的unnamed Module 。
        结果
        该类或接口是其成员的模块
        从以下版本开始：
        9

      • getTypeParameters

        public TypeVariable<Class<T>>[] getTypeParameters​()
        返回一个TypeVariable对象的数组，表示由该GenericDeclaration对象表示的通用声明声明的类型变量，以声明顺序。 如果底层通用声明不声明类型变量，则返回长度为0的数组。
        Specified by:
        getTypeParameters在接口 GenericDeclaration
        结果
        一个 TypeVariable对象的数组，表示此通用声明声明的类型变量
        异常
        GenericSignatureFormatError - 如果此通用声明的通用签名不符合 The Java™ Virtual Machine Specification中指定的格式
        从以下版本开始：
        1.5

      • getSuperclass

        public Class<? super T> getSuperclass​()
        返回表示由Class表示的实体的直接超类（类，接口，原始类型或空白）的Class 。 如果这个Class表示Object类，一个接口，一个原始类型或者Object ，那么返回null。 如果此对象表示数组类，则返回表示Object类的Class对象。
        结果
        由该对象表示的类的直接超类

      • getGenericSuperclass

        public Type getGenericSuperclass​()
        返回表示由Type表示的实体的直接超类（类，接口，原语类型或void）的Class 。

        如果超类是参数化类型，则返回的Type对象必须准确反映源代码中使用的实际类型参数。 如果以前没有创建表示超类的参数化类型。 有关参数化类型创建过程的语义，请参见ParameterizedType的声明。 如果这个Class代表Object类，接口，原始类型或void，则返回null。 如果此对象表示数组类，则返回表示Object类的Class对象。

        结果
        由该对象表示的类的直接超类
        异常
        GenericSignatureFormatError - 如果通用类签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果通用超类引用不存在的类型声明
        MalformedParameterizedTypeException - 如果通用超类引用了由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • getPackage

        public 软件包 getPackage​()
        获取此类的包。

        如果此类表示数组类型， null原始类型或void，此方法返回null 。

        结果
        这个类的包。

      • getPackageName

        public String getPackageName​()
        返回完全限定的包名称。

        如果此类是顶级类，则此方法返回类为其成员的包的完全限定名称，如果该类位于未命名的包中，则返回空字符串。

        如果这个类是一个成员类，那么这个方法相当于在getPackageName()上调用getPackageName() 。

        如果该类是local class或anonymous class ，则此方法等效于调用getPackageName()上declaring class所述的enclosing method或enclosing constructor 。

        如果此类表示数组类型，则此方法返回元素类型的包名称。 如果此类表示原始类型或空值，则返回包名称“ java.lang ”。

        结果
        完全合格的包名称
        从以下版本开始：
        9
        See The Java™ Language Specification:
        6.7完全合格的名称

      • getInterfaces

        public Class<?>[] getInterfaces​()
        返回由该对象表示的类或接口直接实现的接口。

        如果此对象表示一个类，则返回值是包含表示由类直接实现的所有接口的对象的数组。 数组中接口对象的顺序对应于由该对象表示的类的声明的implements子句中的接口名称的顺序。 例如，给出声明：

        class Shimmer implements FloorWax, DessertTopping { ... }
        假设的值s是实例Shimmer ; 表达式的值：
        s.getClass().getInterfaces()[0]
        是表示FloorWax接口的Class对象; 和的价值：
        s.getClass().getInterfaces()[1]
        是表示接口DessertTopping的Class对象。

        如果此对象表示一个接口，则该数组包含表示接口直接扩展的所有接口的对象。 数组中接口对象的顺序对应于由该对象表示的接口的声明的extends子句中接口名称的顺序。

        如果此对象表示不实现接口的类或接口，则该方法返回长度为0的数组。

        如果此对象表示原始类型或void，则该方法返回长度为0的数组。

        如果此Class对象表示数组类型，则按照该顺序返回接口Cloneable和java.io.Serializable 。

        结果
        由这个类直接实现的接口数组

      • getGenericInterfaces

        public Type[] getGenericInterfaces​()
        返回表示由该对象表示的类或接口直接实现的接口的Type 。

        如果超级接口是参数化类型，则Type返回的Type对象必须准确反映源代码中使用的实际类型参数。 如果以前没有创建表示每个超级接口的参数化类型。 有关参数化类型的创建过程的语义，请参阅ParameterizedType的声明。

        如果此对象表示一个类，则返回值是包含表示由类直接实现的所有接口的对象的数组。 数组中接口对象的顺序对应于由该对象表示的类的声明的implements子句中的接口名称的顺序。

        如果此对象表示一个接口，则该数组包含表示接口直接扩展的所有接口的对象。 数组中接口对象的顺序对应于由该对象表示的接口的声明的extends子句中的接口名称的顺序。

        如果此对象表示不实现接口的类或接口，则该方法返回长度为0的数组。

        如果此对象表示原始类型或void，则该方法返回长度为0的数组。

        如果此Class对象表示数组类型，则按照该顺序返回接口Cloneable和java.io.Serializable 。

        结果
        由这个类直接实现的接口数组
        异常
        GenericSignatureFormatError - 如果通用类签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果任何通用超级接口引用不存在的类型声明
        MalformedParameterizedTypeException - 如果任何一个通用超级接口引用了由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • getComponentType

        public Class<?> getComponentType​()
        返回表示数组的组件类型的Class 。 如果此类不表示数组类，则此方法返回null。
        结果
        Class表示 Class的组件类型，如果此类是数组
        从以下版本开始：
        1.1
        另请参见：
        Array

      • getModifiers

        public int getModifiers​()
        返回此类或接口的Java语言修饰符，以整数编码。 修饰符由Java虚拟机的常数为public ， protected ， private ， final ， static ， abstract和interface ; 应使用Modifier类的方法进行解码。

        如果底层类是一个数组类，则其public ， private和protected改性剂是相同的组分的类型。 如果此Class表示原始类型或空白，则其public修饰符始终为true ，其protected和private修饰符始终为false 。 如果此对象表示数组类型， final原始类型或空值，则其final修饰符始终为true并且其接口修饰符始终为false 。 其他修饰符的值不由本规范确定。

        修改器编码在Java虚拟机规范表4.1中定义。

        结果
        int代表这个类的修饰符
        从以下版本开始：
        1.1
        另请参见：
        Modifier

      • getSigners

        public Object[] getSigners​()
        获得这个类的签名者。
        结果
        该类的签名者，如果没有签名者，则为null。 特别地，如果此对象表示基本类型或void，则此方法返回null。
        从以下版本开始：
        1.1

      • getEnclosingMethod

        public 方法 getEnclosingMethod​()
                          throws SecurityException
        如果此Class对象表示方法中的本地或匿名类，则返回表示基础类的即时封闭方法的方法对象。 否则返回null 。 特别地，如果基础类是立即由类型声明，实例初始化器或静态初始化器包围的本地或匿名类，则此方法返回null 。
        结果
        底层类的即时封闭方法，如果该类是本地或匿名类; 否则null 。
        异常
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与封闭类的类加载器不相同，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问封闭类中的方法
        • 调用者的类加载器与封装类的类加载器的祖先不相同，并且调用s.checkPackageAccess()拒绝访问封装类的包
        从以下版本开始：
        1.5

      • getEnclosingConstructor

        public Constructor<?> getEnclosingConstructor​()
                                       throws SecurityException
        如果此Class对象表示构造函数中的本地或匿名类，则返回表示基础类的立即封闭构造函数的Constructor对象。 否则返回null 。 特别地，如果基础类是立即由类型声明，实例初始化器或静态初始化器包围的本地或匿名类，则此方法返回null 。
        结果
        如果该类是本地或匿名类，那么基础类的立即包含构造函数; 否则null 。
        异常
        SecurityException - 如果安全管理员s存在，并符合以下任何条件：
        • 调用者的类加载器与封闭类的类加载器不一样，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问封闭类中的构造函数
        • 调用者的类加载器与封闭类的类加载器的祖先不相同，并且调用s.checkPackageAccess()拒绝访问封闭类的包
        从以下版本开始：
        1.5

      • getDeclaringClass

        public Class<?> getDeclaringClass​()
                           throws SecurityException
        如果由此Class对象表示的类或接口是另一个类的成员，则返回表示其声明的类的Class对象。 如果此类或接口不是任何其他类的成员，则此方法返回null。 如果这个Class对象表示一个数组类，一个原始类型或者void，那么这个方法返回null。
        结果
        这个类的声明类
        异常
        SecurityException - 如果安全管理员 s存在，并且调用者的类加载器与声明类的类加载器不相同或者是祖先，并且调用 s.checkPackageAccess()否认访问声明类的包
        从以下版本开始：
        1.1

      • getEnclosingClass

        public Class<?> getEnclosingClass​()
                           throws SecurityException
        返回底层类的即时封闭类。 如果底层类是顶级类，则此方法返回null 。
        结果
        底层类的立即封闭类
        异常
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的封装类和调用的祖先 s.checkPackageAccess()拒绝该包的封装类的访问
        从以下版本开始：
        1.5

      • getSimpleName

        public String getSimpleName​()
        返回源代码中给出的基础类的简单名称。 如果基础类是匿名的，则返回一个空字符串。

        数组的简单名称是附加了“[]”的组件类型的简单名称。 特别是组件类型为匿名的数组的简单名称是“[]”。

        结果
        底层类的简单名称
        从以下版本开始：
        1.5

      • getTypeName

        public String getTypeName​()
        为此类型的名称返回一个内容丰富的字符串。
        Specified by:
        getTypeName在接口 Type
        结果
        一个用于此类型名称的信息字符串
        从以下版本开始：
        1.8

      • getCanonicalName

        public String getCanonicalName​()
        返回由Java语言规范定义的基础类的规范名称。 如果基础类没有规范名称（即，如果它是本地或匿名类或其组件类型不具有规范名称的数组），则返回null。
        结果
        底层类的规范名称，如果存在，另外 null 。
        从以下版本开始：
        1.5

      • isAnonymousClass

        public boolean isAnonymousClass​()
        如果且仅当底层类是匿名类时返回 true 。
        结果
        true当且仅当这个类是一个匿名类。
        从以下版本开始：
        1.5

      • isLocalClass

        public boolean isLocalClass​()
        返回 true当且仅当基础类是本地类时。
        结果
        true当且仅当此类是本地类时。
        从以下版本开始：
        1.5

      • isMemberClass

        public boolean isMemberClass​()
        返回 true当且仅当基础类是成员类时。
        结果
        true当且仅当此类是成员类时。
        从以下版本开始：
        1.5

      • getClasses

        public Class<?>[] getClasses​()
        返回一个数组，其中包含Class对象，该对象表示由该Class对象表示的类的成员的所有公共类和接口。 这包括继承自类的公共类和接口成员以及该类声明的公共类和接口成员。 如果此Class对象没有公共成员类或接口，则此方法返回长度为0的数组。 如果这个Class对象表示一个原始类型，一个数组类或者void，该方法也返回一个长度为0的数组。
        结果
        代表这个类的公共成员的 Class对象的数组
        异常
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。
        从以下版本开始：
        1.1

      • getFields

        public Field[] getFields​()
                  throws SecurityException
        返回一个包含Field对象的数组， Field对象反映由该Class对象表示的类或接口的所有可访问的公共字段。

        如果此Class对象表示没有可访问的公共字段的类或接口，则此方法返回长度为0的数组。

        如果这个Class对象表示一个类，那么这个方法返回该类及其所有超类和超级接口的公共字段。

        如果这个Class对象表示一个接口，那么这个方法返回接口和其所有超级接口的字段。

        如果此Class对象表示数组类型， Class原始类型或void，则此方法返回长度为0的数组。

        返回的数组中的元素不会被排序，并且不是以任何特定的顺序。

        结果
        表示公共字段的 Field对象的数组
        异常
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.3现场声明

      • getMethods

        public 方法[] getMethods​()
                    throws SecurityException
        返回一个包含方法对象的数组， 方法对象反映由该Class对象表示的类或接口的所有公共方法，包括由类或接口声明的对象，以及从超类和超级接口继承的类。

        如果此Class对象表示一个数组类型，则返回的阵列具有方法对于每个由阵列类型从继承的公共方法对象Object 。 它不包含方法对象clone() 。

        如果此Class对象表示一个接口，则返回的数组不包含任何隐含声明的方法，来自Object 。 因此，如果在此接口或其任何超级接口中没有显式声明方法，则返回的数组的长度为0.（注意，表示类的一个Class对象始终具有公共方法，继承自Object 。

        返回的数组从不包含名称为“ <init> ”或“ <clinit> ”的方法。

        返回的数组中的元素不会被排序，并且不是以任何特定的顺序。

        通常，结果与以下4步算法一样计算。 让C是由这个Class对象表示的类或接口：

        1. 方法联合组成：
          1. C所声明的公共实例和静态方法由getDeclaredMethods()返回， 并被过滤以仅包括公共方法。
          2. 如果C是一个不是Object的类，那么包括在C的超类上递归调用这个算法的结果。
          3. 包括在C的所有直接超级接口上递归调用该算法的结果，但仅包括实例方法。
        2. 来自步骤1的联盟被划分为具有相同签名（名称，参数类型）和返回类型的方法的子集。
        3. 在每个这样的子集中，仅选择最具体的方法。 让方法M是一组具有相同签名和返回类型的方法的方法。 如果没有相同集合的这种方法N！= M，则M是最具体的，使得N比M更具体。如果：
          1. N由一个类声明，M由一个接口声明; 要么
          2. N和M都由类或两者通过接口声明，N的声明类型与M的声明类型相同或子类型（显然，如果M和N的声明类型是相同的类型，则M和N是相同的方法） 。
        4. 该算法的结果是来自步骤3的所有选定方法的并集。
        API Note:
        在一个类中可能有多个具有特定名称和参数类型的方法，因为当Java语言禁止一个类声明具有相同签名但返回类型不同的多个方法时，Java虚拟机不会。 虚拟机中增加的灵活性可以用于实现各种语言特征。 例如，协变回报可以用bridge methods实现; 桥接方法和重写方法将具有相同的签名但不同的返回类型。
        结果
        代表这个类的公共方法的 方法对象的数组
        异常
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.4方法声明

      • getConstructors

        public Constructor<?>[] getConstructors​()
                                 throws SecurityException
        返回一个包含Constructor对象的数组， Constructor对象反映由该Class对象表示的类的所有公共构造函数。 如果类没有公共构造函数，或者类是数组类，或类反映原始类型或void时，返回长度为0的数组。 请注意，虽然此方法返回一个Constructor<T>对象（这是该类的构造函数数组）的数组，但此方法的返回类型为Constructor<?>[]而不是 Constructor<T>[] 。 这种信息较少的返回类型是必需的，因为从该方法返回后，可以修改数组以容纳不同类的Constructor对象，这将违反Constructor<T>[]的类型保证。
        结果
        表示 Constructor的公共构造函数的 Constructor对象的数组
        异常
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。
        从以下版本开始：
        1.1

      • getField

        public Field getField​(String name)
               throws NoSuchFieldException,
                      SecurityException
        返回一个Field对象，该对象反映由该Class对象表示的类或接口的指定公共成员字段。 name参数是一个String指定所需字段的简单名称。

        要反映的字段由以下算法确定。 让C成为由该对象表示的类或接口：

        1. 如果C声明一个具有指定名称的公共字段，那就是要反映的字段。
        2. 如果在上述步骤1中没有找到字段，则将该算法递归地应用于C的每个直接超级接口。直接超级接口按照它们被声明的顺序被搜索。
        3. 如果在上述步骤1和2中没有找到字段，并且C具有超类S，则该算法在S上递归调用。如果C没有超类，则抛出一个NoSuchFieldException 。

        如果此Class对象表示数组类型，则此方法不会找到数组类型的length字段。

        参数
        name - 字段名称
        结果
        Field对象由 name指定
        异常
        NoSuchFieldException - 如果找不到指定名称的字段。
        NullPointerException - 如果 name是 null
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.3现场声明

      • getMethod

        public 方法 getMethod​(String name,
                        Class<?>... parameterTypes)
                 throws NoSuchMethodException,
                        SecurityException
        返回一个方法对象，该对象反映由此Class对象表示的类或接口的指定公共成员方法。 name参数是一个String指定所需方法的简单名称。 parameterTypes参数是一个Class对象的数组，以声明顺序标识方法的形式参数类型。 如果parameterTypes为null ，则将其视为空数组。

        如果此Class对象表示数组类型，则该方法找到以阵列型从继承的任何公有方法Object除了方法clone() 。

        如果这个Class对象表示一个接口，那么这个方法没有从Object找到任何隐式声明的方法。 因此，如果在此接口或其任何超级接口中没有显式声明方法，则此方法不会找到任何方法。

        此方法找不到名称为“ <init> ”或“ <clinit> ”的任何方法。

        一般来说，要反映的方法由以下4步算法确定。 让C是由这个Class对象表示的类或接口：

        1. 方法联合组成：
          1. C所声明的公共实例和静态方法由getDeclaredMethods()返回， 并被过滤以仅包括匹配给予的公共方法name和parameterTypes
          2. 如果C是一个不是Object的类，那么包含在C的超类上递归调用这个算法的结果。
          3. 包括在C的所有直接超级接口上递归调用该算法的结果，但仅包括实例方法。
        2. 该联合被分割成具有相同返回类型的方法子集（步骤1中的方法选择也保证它们具有相同的方法名称和参数类型）。
        3. 在每个这样的子集中，仅选择最具体的方法。 让方法M是一组具有相同VM签名（返回类型，名称，参数类型）的方法。 如果没有相同集合的这种方法N！= M，则M是最具体的，使得N比M更具体。如果：
          1. N由一个类声明，M由一个接口声明; 要么
          2. N和M都由类或两者通过接口声明，N的声明类型与M的声明类型相同或子类型（显然，如果M和N的声明类型是相同的类型，则M和N是相同的方法） 。
        4. 该算法的结果是从步骤3的所有选定方法中具有最特定返回类型的方法中任意选择。令R是来自步骤3的所有选定方法的集合中的方法M的返回类型.M是具有最具体的返回类型，如果没有这样的方法N！= M来自同一集合，具有返回类型S！= R，使得S是由R.class确定的R的子类型。 isAssignableFrom(java.lang.Class<?>) （S.class）。
        API Note:
        在类中可能有多个匹配名称和参数类型的方法，因为Java语言禁止一个类声明具有相同签名但不同返回类型的多个方法，但是Java虚拟机不会。 虚拟机中增加的灵活性可以用于实现各种语言特征。 例如，协变回报可以用bridge methods来实现; 桥接方法和重写方法将具有相同的签名但不同的返回类型。 该方法将返回重写方法，因为它将具有更具体的返回类型。
        参数
        name - 方法的名称
        parameterTypes - 参数列表
        结果
        与指定的 name和 parameterTypes匹配的 方法对象
        异常
        NoSuchMethodException - 如果找不到匹配的方法，或者名称是“<init>”还是“<clinit>”。
        NullPointerException - 如果 name是 null
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.4方法声明

      • getConstructor

        public Constructor<T> getConstructor​(Class<?>... parameterTypes)
                              throws NoSuchMethodException,
                                     SecurityException
        返回一个Constructor对象，该对象反映由此Class对象表示的类的指定公共构造函数。 parameterTypes参数是以声明顺序标识构造函数的形式参数类型的Class对象的数组。 如果此Class对象表示在非静态上下文中声明的内部类，则形式参数类型将显式包围实例作为第一个参数。

        要反映的构造函数是由该Class对象表示的类的公共构造函数，其形式参数类型与parameterTypes指定的类型匹配。

        参数
        parameterTypes - 参数数组
        结果
        公共构造函数的 Constructor对象与指定的 parameterTypes匹配
        异常
        NoSuchMethodException - 如果找不到匹配的方法。
        SecurityException -如果安全管理器 ，S存在，并且调用者的类加载器是不一样或类加载器的当前类和调用的祖先 s.checkPackageAccess()拒绝访问包这个类的。
        从以下版本开始：
        1.1

      • getDeclaredClasses

        public Class<?>[] getDeclaredClasses​()
                              throws SecurityException
        返回一个Class对象的数组，反映了所有被声明为由这个Class对象表示的类的成员的类和接口。 这包括public，protected，default（package）访问以及该类声明的私有类和接口，但不包括继承的类和接口。 该方法返回一个长度为0的数组，如果该类不声明任何类或接口作为成员，或者这个Class对象表示一个原始类型，一个数组类，或者是void。
        结果
        表示 Class所有声明成员的 Class对象的数组
        异常
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与此类的类加载器不同，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问此类中声明的类
        • 调用者的类加载器与当前类的类加载器不同或者是祖先，并且调用s.checkPackageAccess()否认访问该类的包
        从以下版本开始：
        1.1

      • getDeclaredFields

        public Field[] getDeclaredFields​()
                          throws SecurityException
        返回一个Field对象的数组，反映了由该Class对象表示的类或接口声明的所有字段。 这包括公共，受保护，默认（包）访问和私有字段，但不包括继承的字段。

        如果此Class对象表示没有声明字段的类或接口，则此方法返回长度为0的数组。

        如果这个Class对象表示一个数组类型，一个原始类型或者void，那么这个方法返回一个长度为0的数组。

        返回的数组中的元素不会被排序，并且不是以任何特定的顺序。

        结果
        表示 Field所有声明字段的 Field对象的数组
        异常
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与此类的类加载器不同，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问此类中声明的字段
        • 调用者的类加载器与当前类的类加载器的祖先不同，并且调用s.checkPackageAccess()拒绝访问此类的包
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.3现场声明

      • getDeclaredMethods

        public 方法[] getDeclaredMethods​()
                            throws SecurityException
        返回一个包含方法对象的数组， 方法对象反映由Class对象表示的类或接口的所有声明的方法，包括public，protected，default（package）访问和私有方法，但不包括继承方法。

        如果此Class对象表示具有多个具有相同名称和参数类型但具有不同返回类型的声明方法的类型，那么返回的数组对于每个此类方法都有一个方法对象。

        如果此Class对象表示具有类初始化方法的类型<clinit> ，则返回的阵列不具有相应的方法对象。

        如果此Class对象表示没有声明方法的类或接口，则返回的数组的长度为0。

        如果此Class对象表示数组类型， Class原始类型或void，则返回的数组的长度为0。

        返回的数组中的元素不会被排序，并且不是以任何特定的顺序。

        结果
        表示 方法所有声明方法的 方法对象的数组
        异常
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与此类的类加载器不同，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问此类中声明的方法
        • 调用者的类加载器与当前类的类加载器的祖先不同，并且调用s.checkPackageAccess()拒绝访问此类的包
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.4方法声明

      • getDeclaredConstructors

        public Constructor<?>[] getDeclaredConstructors​()
                                         throws SecurityException
        返回一个Constructor对象的数组，反映由该Class对象表示的类声明的所有构造函数。 这些是public，protected，default（package）访问和私有构造函数。 返回的数组中的元素不会排序，并且不是任何特定的顺序。 如果类有一个默认构造函数，它将包含在返回的数组中。 此方法返回一个长度为0的数组，如果该对象表示一个接口，一个原始类型，一个数组类或者Class 。

        请参阅Java语言规范 ，第8.2节。

        结果
        代表这个类的所有声明的构造函数的 Constructor对象的数组
        异常
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与此类的类加载器不同，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问此类中声明的构造函数
        • 调用者的类加载器与当前类的类加载器不同或者是祖先，并且调用s.checkPackageAccess()拒绝访问该类的包
        从以下版本开始：
        1.1

      • getDeclaredField

        public Field getDeclaredField​(String name)
                       throws NoSuchFieldException,
                              SecurityException
        返回一个Field对象，该对象反映由此Class对象表示的类或接口的指定声明字段。 name参数是一个String ，它指定了所需字段的简单名称。

        如果这个Class对象代表一个数组类型，那么这个方法找不到数组类型的length字段。

        参数
        name - 字段的名称
        结果
        Field中指定字段的对象为 Field
        异常
        NoSuchFieldException - 如果找不到指定名称的字段。
        NullPointerException - 如果 name是 null
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与此类的类加载器不一样，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问已声明的字段
        • 调用者的类加载器不同于当前类的类加载器的祖先，并且调用s.checkPackageAccess()拒绝访问此类的包
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.3现场声明

      • getDeclaredMethod

        public 方法 getDeclaredMethod​(String name,
                                Class<?>... parameterTypes)
                         throws NoSuchMethodException,
                                SecurityException
        返回一个方法对象，该对象反映由此Class对象表示的类或接口的指定声明方法。 name参数是一个String ，它指定了所需方法的简单名称， parameterTypes参数是一个Class对象的数组，以声明顺序标识方法的形式参数类型。 如果在一个类中声明具有相同参数类型的多个方法，并且其中一个方法的返回类型比其他任何方法更具体，返回该方法; 否则其中一种方法是任意选择的。 如果名字是“<init>”或“<clinit>”， NoSuchMethodException一个NoSuchMethodException 。

        如果这个Class对象表示一个数组类型，那么这个方法找不到clone()方法。

        参数
        name - 方法的名称
        parameterTypes - 参数数组
        结果
        方法对象为该类的方法匹配指定的名称和参数
        异常
        NoSuchMethodException - 如果找不到匹配方法。
        NullPointerException - 如果 name是 null
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与此类的类加载器不一样，并调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问声明的方法
        • 调用者的类加载器与当前类的类加载器的祖先不相同，并且调用s.checkPackageAccess()拒绝访问此类的包
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        8.2类成员，8.4方法声明

      • getDeclaredConstructor

        public Constructor<T> getDeclaredConstructor​(Class<?>... parameterTypes)
                                      throws NoSuchMethodException,
                                             SecurityException
        返回一个Constructor对象，该对象反映由该Class对象表示的类或接口的指定构造函数。 parameterTypes参数是一个Class对象的数组，以声明的顺序标识构造函数的形式参数类型。 如果此Class对象表示在非静态上下文中声明的内部类，则形式参数类型将显式包围实例作为第一个参数。
        参数
        parameterTypes - 参数数组
        结果
        Constructor对象为具有指定参数列表的构造函数
        异常
        NoSuchMethodException - 如果找不到匹配方法。
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 调用者的类加载器与此类的类加载器不同，并且调用s.checkPermission方法与RuntimePermission("accessDeclaredMembers")拒绝访问声明的构造函数
        • 调用者的类加载器与当前类的类加载器的祖先不同，并且调用s.checkPackageAccess()拒绝访问此类的包
        从以下版本开始：
        1.1

      • getResourceAsStream

        public InputStream getResourceAsStream​(String name)
        查找具有给定名称的资源。

        如果这个类名为Module，则该方法将尝试在模块中查找资源。 这是通过委托给模块的类加载器findResource(String,String)方法，使用模块名称和资源的绝对名称进行调用来完成的。 命名模块中的资源受到Module getResourceAsStream方法中指定的封装规则的Module ，因此，当资源是未对调用者模块打开的软件包中的非“ .class ”资源时，此方法返回null 。

        否则，如果此类不在命名模块中，那么用于搜索与给定类相关联的资源的规则由类定义的class loader实现。 此方法委托给该对象的类加载器。 如果此对象由引导类加载器加载，则该方法委托为ClassLoader.getSystemResourceAsStream(java.lang.String) 。

        在委派之前，使用此算法从给定资源名称构建绝对资源名称：

        • 如果name以'/' （ '\u002f' ）开头，那么资源的绝对名称是name之后的'/' 。
        • 否则，绝对名称的格式如下：
          modified_package_name/name

          其中modified_package_name是该对象的包名称，其中'/'替换为'.' （ '\u002e' ）。

        参数
        name - 所需资源的名称
        结果
        A InputStream对象; null如果没有找到具有此名称的资源，则该资源至少为一个调用者模块的包不是open ，否则安全管理器将拒绝该资源的访问。
        异常
        NullPointerException - 如果 name是 null
        从以下版本开始：
        1.1
        另请参见：
        Module.getResourceAsStream(String)

      • getResource

        public URL getResource​(String name)
        查找具有给定名称的资源。

        如果这个类名为Module，那么这个方法将尝试在模块中找到资源。 这是通过委托给模块的类加载器findResource(String,String)方法，使用模块名称和资源的绝对名称进行调用。 命名模块中的资源受到Module getResourceAsStream方法中指定的封装规则的Module ，因此，当资源为未对调用方模块开放的软件包中的非“ .class ”资源时，此方法返回null 。

        否则，如果此类不在命名模块中，则用于搜索与给定类相关联的资源的规则由该类的定义class loader实现。 此方法委托给该对象的类加载器。 如果此对象由引导类加载器加载，则该方法委托为ClassLoader.getSystemResource(java.lang.String) 。

        在委派之前，使用此算法从给定资源名称构建绝对资源名称：

        • 如果name以'/' （ '\u002f' ）开头，那么资源的绝对名称是name之后的'/' 。
        • 否则，绝对名称的格式如下：
          modified_package_name/name

          其中modified_package_name是该对象的包名，其中'/'替换为'.' （ '\u002e' ）。

        参数
        name - 所需资源的名称
        结果
        一个URL对象; null如果没有找到具有此名称的资源，则该资源不能由URL定位，该资源至少为呼叫者模块的包不是open ，否则安全管理器将拒绝该资源的访问。
        异常
        NullPointerException - 如果 name是 null
        从以下版本开始：
        1.1

      • getProtectionDomain

        public ProtectionDomain getProtectionDomain​()
        返回ProtectionDomain 。 如果安装了一个安全管理员，该方法首先调用安全管理员的checkPermission方法，以获得RuntimePermission("getProtectionDomain")权限，以确保获得ProtectionDomain 。
        结果
        该类的ProtectionDomain
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许获取ProtectionDomain。
        从以下版本开始：
        1.2
        另请参见：
        ProtectionDomain ， SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission

      • desiredAssertionStatus

        public boolean desiredAssertionStatus​()
        如果要在调用此方法时初始化该类，则返回将分配给此类的断言状态。 如果此类已设置其断言状态，则将返回最近的设置; 否则，如果任何包默认断言状态属于此类，则返回最具体的相关包默认断言状态的最新设置; 否则，如果此类不是系统类（即它有一个类加载器），则返回其类加载器的默认断言状态; 否则返回系统类默认断言状态。

        几乎没有程序员需要这种方法; 它为JRE本身的利益而提供。 （它允许类在当时确定它是否被初始化是否应该启用断言。）请注意，该方法不能保证返回与（或将）与指定类相关联的实际断言状态，或将被）初始化。

        结果
        指定类的所需断言状态。
        从以下版本开始：
        1.4
        另请参见：
        ClassLoader.setClassAssertionStatus(java.lang.String, boolean) ，
ClassLoader.setPackageAssertionStatus(java.lang.String, boolean) ，
ClassLoader.setDefaultAssertionStatus(boolean)

      • isEnum

        public boolean isEnum​()
        当且仅当该类在源代码中被声明为枚举时才返回true。
        结果
        当且仅当该类在源代码中被声明为枚举时才为真
        从以下版本开始：
        1.5

      • getEnumConstants

        public T[] getEnumConstants​()
        返回此枚举类的元素，如果此Class对象不表示枚举类型，则返回null。
        结果
        一个数组，它包含按照它们声明的顺序由此Class对象表示的枚举类的值，如果此Class对象不表示枚举类型，则为空
        从以下版本开始：
        1.5

      • cast

        public T cast​(Object obj)
        将对象 Class在由此 Class对象表示的类或接口上。
        参数
        obj - 要投射的对象
        结果
        转换后的对象，如果obj为空则为null
        异常
        ClassCastException - 如果对象不为空并且不能分配给类型T.
        从以下版本开始：
        1.5

      • asSubclass

        public <U> Class<? extends U> asSubclass​(Class<U> clazz)
        Class这个Class对象来表示由指定的类对象表示的类的子类。 检查演员是否有效，如果不是，则抛出一个ClassCastException 。 如果此方法成功，它将始终返回此类对象的引用。

        当客户端需要“缩小” Class对象的类型以将其传递给限制其愿意接受的Class对象的API时，此方法非常有用。 转换将生成编译时警告，因为在运行时无法检查转换的正确性（因为通用类型通过擦除来实现）。

        参数类型
        U - 将此类对象转换为的类型
        参数
        clazz - 将此类对象转换为类的类
        结果
        这个 Class对象，转换为表示指定类对象的子类。
        异常
        ClassCastException - 如果这个 Class对象不表示指定类的子类（这里“子类”包括该类本身）。
        从以下版本开始：
        1.5

      • getAnnotation

        public <A extends Annotation> A getAnnotation​(Class<A> annotationClass)
        描述从接口AnnotatedElement复制
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        参数类型
        A - 查询的注释的类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • isAnnotationPresent

        public boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
        如果此元素上存在指定类型的注释，则返回true，否则返回false。 该方法主要用于方便访问标记注释。

        此方法返回的真值相当于： getAnnotation(annotationClass) != null

        默认方法的主体被指定为上述代码。

        Specified by:
        isAnnotationPresent在接口 AnnotatedElement
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果此元素上存在指定注释类型的注释，则为true，否则为false
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getAnnotationsByType

        public <A extends Annotation> A[] getAnnotationsByType​(Class<A> annotationClass)
        描述从接口AnnotatedElement复制
        返回与此元素相关联的注释。 如果没有与此元素相关联的注释，则返回值为长度为0的数组。此方法与AnnotatedElement.getAnnotation(Class)之间的区别在于该方法检测其参数是否是可重复注释类型 （JLS 9.6），如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotationsByType在接口 AnnotatedElement
        参数类型
        A - 查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果与此元素相关联，则指定注释类型的所有元素注释，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getAnnotations

        public Annotation[] getAnnotations​()
        描述从界面AnnotatedElement复制
        返回此元素上存在的注释。 如果没有存在于此元素上注解，返回值是长度为0这种方法的调用者可以随意修改返回的数组的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotations在接口 AnnotatedElement
        结果
        此元素上出现的注释
        从以下版本开始：
        1.5

      • getDeclaredAnnotation

        public <A extends Annotation> A getDeclaredAnnotation​(Class<A> annotationClass)
        说明从界面AnnotatedElement复制
        如果这样的注释直接存在 ，则返回指定类型的元素注释，否则返回null。 此方法忽略继承的注释。 （如果此元素上没有注释，则返回null）
        Specified by:
        getDeclaredAnnotation在接口 AnnotatedElement
        参数类型
        A - 要查询的注释类型，如果直接出现则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果直接出现在该元素上，则指定注释类型的元素注释，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotationsByType

        public <A extends Annotation> A[] getDeclaredAnnotationsByType​(Class<A> annotationClass)
        说明从界面AnnotatedElement复制
        如果此类注释直接存在或间接存在，则返回该元素的注释（指定类型）。 此方法忽略继承的注释。 如果在该元素上没有直接或间接存在的指定注释，则返回值是长度为0的数组。此方法与AnnotatedElement.getDeclaredAnnotation(Class)之间的区别在于该方法检测其参数是否是可重复注释类型 （JLS 9.6），以及如果是，尝试通过“查看”容器注释（如果存在）来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotationsByType在接口 AnnotatedElement
        参数类型
        A - 直接或间接出现的查询和返回的注释类型
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        指定注释类型的所有这些元素的注释，如果直接或间接地存在于该元素上，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        描述从接口AnnotatedElement复制
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        结果
        此元素上直接显示的注释
        从以下版本开始：
        1.5

      • getAnnotatedSuperclass

        public AnnotatedType getAnnotatedSuperclass​()
        返回一个AnnotatedType对象，表示使用类型来指定由该Class对象表示的实体的超类。 （ 使用 Foo类型指定“...扩展Foo”中的超类与Foo类型的声明不同）

        如果此Class对象表示其声明未明确指示已注释超类的类型，则返回值为表示没有注释的元素的AnnotatedType对象。

        如果这个Class表示Object类，接口类型，数组类型，基元类型或空值，则返回值为null 。

        结果
        表示超类的对象
        从以下版本开始：
        1.8

      • getAnnotatedInterfaces

        public AnnotatedType[] getAnnotatedInterfaces​()
        返回一个AnnotatedType对象的数组，表示使用类型指定由该Class对象表示的实体的超Class 。 （在“...实现Foo”中使用 Foo类型指定一个超级接口与Foo类型的声明不同）

        如果这个Class对象表示一个类，则返回值是一个数组，其中包含表示使用接口类型的对象来指定类实现的接口。 数组中对象的顺序对应于此Class对象的声明的'implements'子句中使用的接口类型的顺序。

        如果此Class对象表示一个接口，则返回值是一个数组，其中包含表示使用接口类型的对象来指定接口直接扩展的接口。 数组中对象的顺序对应于此Class对象的声明的'extends'子句中使用的接口类型的顺序。

        如果此Class对象表示其声明未明确指示任何带注释的超级接口的类或接口，返回值为长度为0的数组。

        如果此Class对象表示Object类，数组类型，原始类型或空值，则返回值为长度为0的数组。

        结果
        表示超级接口的数组
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassCastException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ClassCastException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.ClassCastException
  • All Implemented Interfaces:
    Serializable

    public class ClassCastException
extends RuntimeException
    抛出表示代码尝试将对象转换为不属于实例的子类。 例如，以下代码生成一个ClassCastException ：
         Object x = new Integer(0);
     System.out.println((String)x);
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClassCastException​()
      构造一个 ClassCastException ，没有详细消息。
      ClassCastException​(String s)
      构造具有指定详细消息的 ClassCastException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClassCastException

        public ClassCastException​()
        构造一个没有详细信息的 ClassCastException 。

      • ClassCastException

        public ClassCastException​(String s)
        构造具有指定详细消息的 ClassCastException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassCircularityError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ClassCircularityError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.ClassCircularityError
  • All Implemented Interfaces:
    Serializable

    public class ClassCircularityError
extends LinkageError
    当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClassCircularityError​()
      构造一个没有详细消息的 ClassCircularityError 。
      ClassCircularityError​(String s)
      构造具有指定详细消息的 ClassCircularityError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClassCircularityError

        public ClassCircularityError​()
        构造一个 ClassCircularityError ，没有详细信息。

      • ClassCircularityError

        public ClassCircularityError​(String s)
        构造具有指定详细消息的 ClassCircularityError 。
        参数
        s - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassFormatError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ClassFormatError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.ClassFormatError
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    GenericSignatureFormatError ， UnsupportedClassVersionError

    public class ClassFormatError
extends LinkageError
    当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClassFormatError​()
      构造一个没有详细消息的 ClassFormatError 。
      ClassFormatError​(String s)
      构造具有指定详细消息的 ClassFormatError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClassFormatError

        public ClassFormatError​()
        构造一个没有详细消息的 ClassFormatError 。

      • ClassFormatError

        public ClassFormatError​(String s)
        构造具有指定详细消息的 ClassFormatError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ClassLoader

  • java.lang.Object
    • java.lang.ClassLoader
  • 已知直接子类：
    SecureClassLoader

    public abstract class ClassLoader
extends Object
    类加载器是负责加载类的对象。 ClassLoader是一个抽象类。 给定一个类的binary name ，类加载器应该尝试定位或生成构成类的定义的数据。 典型的策略是将名称转换为文件名，然后从文件系统中读取该名称的“类文件”。

    每个Class对象包含一个reference的ClassLoader定义它。

    Class数组类的对象不是由类加载器创建的，而是根据Java运行时的要求自动创建。 Class.getClassLoader()返回的数组类的类加载器与其类型的类加载器相同; 如果元素类型是原始类型，则数组类没有类加载器。

    应用程序实现ClassLoader子类，以便扩展Java虚拟机动态加载类的方式。

    安全管理员通常可以使用类加载器来指示安全域。

    除了加载类之外，类加载器还负责定位资源。 资源是一些用抽象'/'分隔的路径名称标识的数据（例如“ .class ”文件，配置数据或图像）。 资源通常与应用程序或库一起打包，以便它们可以通过应用程序或库中的代码来定位。 在某些情况下，包括资源，以便它们可以由其他库定位。

    ClassLoader类使用委派模型来搜索类和资源。 每个ClassLoader实例都有一个关联的父类加载器。 当请求查找类或资源时， ClassLoader实例通常会在尝试查找类或资源本身之前将搜索类或资源委托给其父类加载器。

    支持并发加载类的类加载器称为parallel capable类加载器，并且需要通过调用ClassLoader.registerAsParallelCapable方法在其类初始化时注册自身。 请注意，默认情况下， ClassLoader类注册为并行。 然而，它的子类仍然需要注册自己，如果它们是并行的能力。 在委托模式不是严格层次化的环境中，类装载器需要并行才能，否则加载类可能导致死锁，因为加载程序锁定在类加载过程中保持（见loadClass方法）。

    Run-time Built-in Class Loaders

    Java运行时具有以下内置类加载器：

    • Bootstrap类加载器。 它是虚拟机的内置类加载器，通常表示为null ，并且没有父null 。

    • Platform class loader 。 平台类加载器可以看到所有平台类 ，可以将其用作ClassLoader实例的父ClassLoader 。 平台类包括由平台类加载器或其祖先定义的Java SE平台API，其实现类和JDK特定的运行时类。

      为了允许对定义到平台类加载器的模块进行升级/覆盖，并且升级后的模块读取定义到除了平台类加载器及其祖先之外的类加载器的模块，则平台类加载器可能必须委派给其他类加载器例如应用程序类加载器。 换句话说，除了平台类加载器及其祖先之外，定义为类加载器的命名模块中的类可能对平台类加载器是可见的。

    • System class loader 。 它也被称为应用程序类加载器 ，与平台类加载器不同。 系统类加载器通常用于定义应用程序类路径，模块路径和JDK特定工具上的类。 平台类加载器是所有平台类对其可见的系统类加载器的父级或祖先。

    通常，Java虚拟机以平台相关的方式从本地文件系统加载类。 然而，一些类可能不是源于文件; 它们可以来自诸如网络的其他来源，或者它们可以由应用构建。 方法defineClass将字节数组转换为类别Class的实例。 这个新定义的类的实例可以使用Class.newInstance创建。

    类加载器创建的对象的方法和构造函数可以引用其他类。 要确定所引用的类，Java虚拟机调用最初创建该类的类加载器的loadClass方法。

    例如，应用程序可以创建一个网络类加载器来从服务器下载类文件。 示例代码可能如下所示：

       ClassLoader loader = new NetworkClassLoader(host, port);
   Object main = loader.loadClass("Main", true).newInstance();
        . . .

    网络类加载器子类必须定义方法findClass和loadClassData以从网络加载类。 一旦下载构成类的字节，它应该使用方法defineClass创建一个类实例。 示例实现是：

         class NetworkClassLoader extends ClassLoader {
         String host;
         int port;

         public Class findClass(String name) {
             byte[] b = loadClassData(name);
             return defineClass(name, b, 0, b.length);
         }

         private byte[] loadClassData(String name) {
             // load the class data from the connection
              . . .
         }
     }

    Binary names

    提供为任何类名String在参数的方法ClassLoader必须是The Java™ Language Specification的如上定义的二进制名称。

    有效的类名的示例包括：

       "java.lang.String"
   "javax.swing.JSpinner$DefaultEditor"
   "java.security.KeyStore$Builder$FileBuilder$1"
   "java.net.URLClassLoader$3$1"

    提供为任何包名称String在参数的方法ClassLoader必须是空字符串（表示一个未指定的包），或作为由The Java™ Language Specification定义的完全合格的名称。

    从以下版本开始：
    1.0
    另请参见：
    resolveClass(Class)
    See The Java™ Language Specification:
    6.7完全合格的名字，13.1二进制形式

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ClassLoader​()
      创建使用一个新的类加载器 ClassLoader该方法返回 getSystemClassLoader()作为父类加载器。
      protected ClassLoader​(ClassLoader parent)
      使用指定的父类加载器创建一个新的类加载器进行委派。
      protected ClassLoader​(String name, ClassLoader parent)
      创建指定名称的新类加载器，并使用指定的父类加载器进行委派。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void clearAssertionStatus​()
      将此类加载器的默认断言状态设置为 false并丢弃与类加载器相关联的任何包默认值或类断言状态设置。
      protected Class<?> defineClass​(byte[] b, int off, int len)
      已过时。
      由defineClass(String, byte[], int, int)取代
      protected Class<?> defineClass​(String name, byte[] b, int off, int len)
      将字节数组转换为类别 Class的实例。
      protected Class<?> defineClass​(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
      将字节数组转换为类别 Class的实例，并给出 ProtectionDomain 。
      protected Class<?> defineClass​(String name, ByteBuffer b, ProtectionDomain protectionDomain)
      一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。
      protected 软件包 definePackage​(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
      在这个 ClassLoader定义了一个 name的包。
      protected Class<?> findClass​(String name)
      查找具有指定的 类别binary name 。
      protected Class<?> findClass​(String moduleName, String name)
      在定义到此类加载器的模块中找到给定的类别 binary name 。
      protected String findLibrary​(String libname)
      返回本机库的绝对路径名。
      protected Class<?> findLoadedClass​(String name)
      如果这个装载程序已被Java虚拟机记录为具有该类别的启动加载程序，则返回具有给定的 binary name的类 binary name 。
      protected URL findResource​(String name)
      找到具有给定名称的资源。
      protected URL findResource​(String moduleName, String name)
      返回一个URL定义到此类加载器的模块中的资源。
      protected Enumeration<URL> findResources​(String name)
      返回表示具有给定名称的所有资源的URL对象的枚举。
      protected Class<?> findSystemClass​(String name)
      查找具有指定的 类别binary name ，如有必要，加载它。
      protected Object getClassLoadingLock​(String className)
      返回类加载操作的锁定对象。
      软件包 getDefinedPackage​(String name)
      返回 软件包给定的 name已经被这个类加载器定义。
      软件包[] getDefinedPackages​()
      返回此类加载器定义的所有 软件包 s。
      String getName​()
      如果此类加载器未命名，则返回此类加载器的名称或 null 。
      protected 软件包 getPackage​(String name)
      已过时。
      如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，那么由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使注释存在于由子加载器定义的package-info.class文件中。 更健壮的方法是使用getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
      protected 软件包[] getPackages​()
      返回此类加载器及其祖先定义的所有 软件包 。
      ClassLoader getParent​()
      返回父类加载器进行委派。
      static ClassLoader getPlatformClassLoader​()
      返回用于委派的平台类加载器。
      URL getResource​(String name)
      找到具有给定名称的资源。
      InputStream getResourceAsStream​(String name)
      返回用于读取指定资源的输入流。
      Enumeration<URL> getResources​(String name)
      查找具有给定名称的所有资源。
      static ClassLoader getSystemClassLoader​()
      返回用于委派的系统类加载器。
      static URL getSystemResource​(String name)
      从用于加载类的搜索路径中查找指定名称的资源。
      static InputStream getSystemResourceAsStream​(String name)
      打开阅读，从用于加载类的搜索路径中指定名称的资源。
      static Enumeration<URL> getSystemResources​(String name)
      从用于加载类的搜索路径中查找指定名称的所有资源。
      Module getUnnamedModule​()
      返回此类加载器的未命名的 Module 。
      boolean isRegisteredAsParallelCapable​()
      返回 true如果这个类加载器被注册为 parallel capable ，否则 false 。
      Class<?> loadClass​(String name)
      加载指定的 类别binary name 。
      protected Class<?> loadClass​(String name, boolean resolve)
      加载指定的 类别binary name 。
      protected static boolean registerAsParallelCapable​()
      注册呼叫者为 parallel capable 。
      protected void resolveClass​(Class<?> c)
      链接指定的类。
      Stream<URL> resources​(String name)
      返回一个流，其元素是具有给定名称的所有资源的URL。
      void setClassAssertionStatus​(String className, boolean enabled)
      为此类加载器中指定的顶级类和其中包含的任何嵌套类设置所需的断言状态。
      void setDefaultAssertionStatus​(boolean enabled)
      设置此类加载器的默认断言状态。
      void setPackageAssertionStatus​(String packageName, boolean enabled)
      设置命名包的包默认断言状态。
      protected void setSigners​(Class<?> c, Object[] signers)
      设置一个类的签名者。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ClassLoader

        protected ClassLoader​(String name,
                      ClassLoader parent)
        创建指定名称的新类加载器，并使用指定的父类加载器进行委派。
        API Note:
        如果父级指定为 null （对于引导类加载器），则不能保证所有平台类都可见。
        参数
        name - 类加载器名称; 或null如果没有命名
        parent - 父类加载器
        异常
        IllegalArgumentException - 如果给定的名称为空。
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkCreateClassLoader()方法不允许创建新的类加载器。
        从以下版本开始：
        9

      • ClassLoader

        protected ClassLoader​(ClassLoader parent)
        使用指定的父类加载器创建一个新的类加载器进行委派。

        如果有安全管理员，则调用其checkCreateClassLoader方法。 这可能会导致安全例外。

        API Note:
        如果父项指定为 null （对于引导类加载器），则不能保证所有平台类都可见。
        参数
        parent - 父类加载器
        异常
        SecurityException - 如果安全管理器存在，并且其 checkCreateClassLoader方法不允许创建新的类加载器。
        从以下版本开始：
        1.2

      • ClassLoader

        protected ClassLoader​()
        创建使用一个新的类加载器ClassLoader该方法返回getSystemClassLoader()作为父类加载器。

        如果有安全管理员，则调用其checkCreateClassLoader方法。 这可能会导致安全例外。

        异常
        SecurityException - 如果存在安全管理员，并且其 checkCreateClassLoader方法不允许创建新的类加载器。

    • 方法详细信息

      • getName

        public String getName​()
        如果此类加载器未命名，则返回此类加载器的名称或 null 。
        API Note:
        这种方法是非最终的兼容性。 如果此方法被覆盖，则此方法必须返回与实例化此类加载器时指定的相同的名称。
        结果
        这个类加载器的名称 或者如果此类加载器未命名， null 。
        从以下版本开始：
        9

      • loadClass

        public Class<?> loadClass​(String name)
                   throws ClassNotFoundException
        加载指定的类别binary name 。 该方法以与loadClass(String, boolean)方法相同的方式搜索类。 它由Java虚拟机调用来解析类引用。 调用此方法相当于调用loadClass(name, false) 。
        参数
        name - 该类的 binary name
        结果
        由此产生的 Class对象
        异常
        ClassNotFoundException - 如果没有找到该类

      • loadClass

        protected Class<?> loadClass​(String name,
                             boolean resolve)
                      throws ClassNotFoundException
        加载指定的类别binary name 。 此方法的默认实现按以下顺序搜索类：

        1. 调用findLoadedClass(String)以检查类是否已经加载。

        2. 在父类加载器上调用loadClass方法。 如果父级是null ，则使用内置到虚拟机中的类加载器。

        3. 调用findClass(String)方法来查找类。

        如果使用上述步骤找到该类，并且resolve标志为真，则该方法将调用resolveClass(Class)方法对所生成的Class对象。

        鼓励ClassLoader子类覆盖findClass(String) ，而不是这种方法。

        除非被覆盖，否则该方法在整个类加载过程中同步getClassLoadingLock方法的结果。

        参数
        name - 该类的 binary name
        resolve - 如果 true然后解析该类
        结果
        由此产生的 Class对象
        异常
        ClassNotFoundException - 如果找不到该类

      • getClassLoadingLock

        protected Object getClassLoadingLock​(String className)
        返回类加载操作的锁定对象。 为了向后兼容，此方法的默认实现如下。 如果此ClassLoader对象注册为并行能力，则该方法返回与指定的类名称关联的专用对象。 否则，该方法返回此ClassLoader对象。
        参数
        className - 要加载的类的名称
        结果
        锁类加载操作
        异常
        NullPointerException - 如果注册为并行功能，并且 className为空
        从以下版本开始：
        1.7
        另请参见：
        loadClass(String, boolean)

      • findClass

        protected Class<?> findClass​(String name)
                      throws ClassNotFoundException
        查找具有指定的类别binary name 。 该方法应该被加载类的委托模型后面的类加载器实现所覆盖，并且在检查所请求的类的父类加载器之后将被loadClass方法调用。
        实现要求：
        默认实现抛出 ClassNotFoundException 。
        参数
        name - 该类的 binary name
        结果
        产生的 Class对象
        异常
        ClassNotFoundException - 如果找不到该类
        从以下版本开始：
        1.2

      • findClass

        protected Class<?> findClass​(String moduleName,
                             String name)
        在定义到此类加载器的模块中找到给定的类别binary name 。 支持从模块加载的类加载器实现应该覆盖此方法。
        API Note:
        该方法返回 null而不是抛出 ClassNotFoundException如果该类无法找到。
        实现要求：
        当moduleName是null时，默认实现会通过调用findClass(String)来查找该类。 否则返回null 。
        参数
        moduleName - 模块名称; 或null找到这个类加载器的unnamed module中的类
        name - 该类的 binary name
        结果
        由此产生的 Class对象，或 null如果该类无法找到。
        从以下版本开始：
        9

      • defineClass

        @Deprecated(since="1.1")
protected final Class<?> defineClass​(byte[] b,
                                     int off,
                                     int len)
                              throws ClassFormatError
        已过时。 替换为defineClass(String, byte[], int, int)
        将字节数组转换为类别Class的实例。 在Class之前可以使用它必须解决。 这种方法不赞成使用binary name作为其第一个参数的版本，更安全。
        参数
        b - 构成类数据的字节。 位置off至off+len-1的字节应具有由The Java™ Virtual Machine Specification定义的有效类文件的格式。
        off - 类数据中的起始偏移量为 b
        len - 类数据的长度
        结果
        从指定的类数据创建的 Class对象
        异常
        ClassFormatError - 如果数据不包含有效的类
        IndexOutOfBoundsException - 如果 off或 len为负数，或者如果 off+len大于 b.length 。
        SecurityException - 如果尝试将此类添加到包含由不同于该类的不同证书集签名的类的包中，或者尝试在具有完全限定名称的包中定义类时，以“ java. ”开头。
        另请参见：
        loadClass(String, boolean) ， resolveClass(Class)

      • defineClass

        protected final Class<?> defineClass​(String name,
                                     byte[] b,
                                     int off,
                                     int len)
                              throws ClassFormatError
        将字节数组转换为类别Class的实例。 在Class可以使用之前必须解决。

        此方法为新定义的类分配默认值ProtectionDomain 。 ProtectionDomain被有效地授予当调用Policy.getPolicy().getPermissions(new CodeSource(null, null))时返回的相同权限集。 默认保护域是在第一次调用defineClass时创建的，并在随后的调用中重新使用。

        要指定一个特定的ProtectionDomain到类，使用defineClass方法，它接受ProtectionDomain作为它的一个参数。

        这个方法定义了一个在这个类加载器中的包对应于Class的包（如果这样的包在这个类加载器中还没有被定义）。 所定义的包的名称是从衍生binary name由字节数组指定的类的b 。 定义包的其他属性由软件包指定。

        参数
        name - 期望的 binary name的类，或 null如果不知道
        b - 构成类数据的字节。 位置off至off+len-1的字节应具有由The Java™ Virtual Machine Specification定义的有效类文件的格式。
        off - 类数据中的起始偏移量为 b
        len - 类数据的长度
        结果
        从指定的类数据创建的 Class对象。
        异常
        ClassFormatError - 如果数据不包含有效的类
        IndexOutOfBoundsException - 如果 off或 len为负数，或者如果 off+len大于 b.length 。
        SecurityException - 如果尝试将此类添加到包含由不同于该类（未签名）的不同证书集合签署的类的包中，或者如果 name以“ java. ”开头。
        从以下版本开始：
        1.1
        另请参见：
        loadClass(String, boolean) ， resolveClass(Class) ， CodeSource ， SecureClassLoader

      • defineClass

        protected final Class<?> defineClass​(String name,
                                     byte[] b,
                                     int off,
                                     int len,
                                     ProtectionDomain protectionDomain)
                              throws ClassFormatError
        将字节数组转换为类别Class的实例，并给出ProtectionDomain 。

        如果给定的ProtectionDomain是null ，则默认保护域将分配给defineClass(String, byte[], int, int)的文档中指定的类。 在课堂可以使用之前，必须解决。

        包中定义的第一个类决定了该包中定义的所有后续类必须包含的确切的证书集。 一组课程的证书是从课程ProtectionDomain中的ProtectionDomain获得的。 添加到该包中的任何类必须包含相同的证书集，或者抛出一个SecurityException 。 请注意，如果name为null ，则不执行此检查。 你应该总是传递你所定义的类的binary name以及字节。 这确保你所定义的类确实是你认为的类。

        如果指定的name以“ java. ”开头，则只能由platform class loader或其祖先定义; 否则将抛出SecurityException 。 如果name不是null ，它必须等于binary name由字节数组指定的类的b ，否则NoClassDefFoundError将被抛出。

        这个方法定义了一个在这个类加载器中的一个包，该包与Class的包（如果这样一个包在这个类加载器中还没有定义）。 所定义的包的名称是从衍生binary name由字节数组指定的类的b 。 定义包的其他属性由软件包指定。

        参数
        name - 预期的 binary name的类，或 null如果不知道
        b - 构成类数据的字节。 位置off至off+len-1的字节应具有由The Java™ Virtual Machine Specification定义的有效类文件的格式。
        off - 类数据中的起始偏移量为 b
        len - 类数据的长度
        protectionDomain - 该类的 ProtectionDomain
        结果
        从数据创建的 Class对象，和 ProtectionDomain 。
        异常
        ClassFormatError - 如果数据不包含有效的类
        NoClassDefFoundError - 如果 name不是 null而不等于 b指定的类别的 b
        IndexOutOfBoundsException - 如果 off或 len为负数，或者如果 off+len大于 b.length 。
        SecurityException - 如果尝试将此类添加到包含由不同于该类的不同证书集签名的包的包中，或者如果 name以“ java. ”开头，并且此类加载器不是平台类加载器或其祖先。

      • defineClass

        protected final Class<?> defineClass​(String name,
                                     ByteBuffer b,
                                     ProtectionDomain protectionDomain)
                              throws ClassFormatError
        一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。 如果给定的ProtectionDomain是null ，则默认保护域将被分配给defineClass(String, byte[], int, int)的文档中指定的类。 在课堂可以使用之前，必须解决。

        关于包中定义的第一个类的规则，确定包的证书集，类名的限制和类的定义包与defineClass(String, byte[], int, int, ProtectionDomain)的文档中指定的相同。

        调用此方法的形式为cl .defineClass( 名称 , bBuffer , pd )产生与语句完全相同的结果

        ...
        byte[] temp = new byte[bBuffer.remaining()];
        bBuffer.get(temp);
        return cl.defineClass(name, temp, 0, temp.length, pd);

        参数
        name - 预期binary name 。 的课程，或null如果不知道
        b - 构成类数据的字节。 位置b.position()至b.position() + b.limit() -1的字节应具有由The Java™ Virtual Machine Specification定义的有效类文件的格式。
        protectionDomain - 该类的 ProtectionDomain ，或 null 。
        结果
        从数据创建的 Class对象，和 ProtectionDomain 。
        异常
        ClassFormatError - 如果数据不包含有效的类。
        NoClassDefFoundError - 如果 name不是 null而不等于 b指定的类别的 b
        SecurityException - 如果尝试将此类添加到包含由该类别的不同证书签名的类的包中，或者如果 name以“ java. ”开头。
        从以下版本开始：
        1.5
        另请参见：
        defineClass(String, byte[], int, int, ProtectionDomain)

      • resolveClass

        protected final void resolveClass​(Class<?> c)
        链接指定的类。 这个（误导性的）方法可能被类加载器用来链接一个类。 如果c类已经被链接，那么这个方法只是返回。 否则，课程将按照The Java™ Language Specification的“执行”一章中所述进行链接 。
        参数
        c - 要链接的课程
        异常
        NullPointerException - 如果 c是 null 。
        另请参见：
        defineClass(String, byte[], int, int)

      • findSystemClass

        protected final Class<?> findSystemClass​(String name)
                                  throws ClassNotFoundException
        找到一个指定的类别binary name ，如果需要加载。

        此方法通过系统类加载器加载类（请参阅getSystemClassLoader() ）。 返回的Class对象可能有多个ClassLoader关联。 ClassLoader子类通常不需要调用此方法，因为大多数类加载器只需要覆盖findClass(String) 。

        参数
        name - 该类的 binary name
        结果
        Class对象为指定的 name
        异常
        ClassNotFoundException - 如果找不到该类
        另请参见：
        ClassLoader(ClassLoader) ， getParent()

      • findLoadedClass

        protected final Class<?> findLoadedClass​(String name)
        如果这个装载程序已被Java虚拟机记录为具有该类别的启动加载程序，则返回具有给定的binary name的类binary name 。 否则返回null 。
        参数
        name - 该类的 binary name
        结果
        Class对象，或 null如果该类尚未加载
        从以下版本开始：
        1.1

      • setSigners

        protected final void setSigners​(Class<?> c,
                                Object[] signers)
        设置一个类的签名者。 在定义一个类之后应该调用这个。
        参数
        c - Class对象
        signers - 该类的签名者
        从以下版本开始：
        1.1

      • findResource

        protected URL findResource​(String moduleName,
                           String name)
                    throws IOException
        返回一个URL定义到此类加载器的模块中的资源。 支持从模块加载的类加载器实现应该覆盖此方法。
        API Note:
        此方法是在基础Class.getResource ， Class.getResourceAsStream ，并Module.getResourceAsStream方法。 它不受Module.getResourceAsStream规定的封装规则的Module.getResourceAsStream 。
        实现要求：
        当moduleName为null时，默认实现会通过调用findResource(String)来查找资源。 否则返回null 。
        参数
        moduleName - 模块名称; 或null找到在资源unnamed module这个类加载器
        name - 资源名称
        结果
        资源的URL; null如果无法找到资源，则无法构造URL来定位资源，安全管理器将拒绝对资源的访问，或者没有为类加载器定义给定名称的模块。
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        9
        另请参见：
        ModuleReader.find(String)

      • getResource

        public URL getResource​(String name)
        找到具有给定名称的资源。 资源是可以通过独立于代码位置的方式由类代码访问的一些数据（图像，音频，文本等）。

        资源的名称是标识资源的' / ' - /路径名。

        命名模块中的资源受Module.getResourceAsStream规定的封装规则约束 。 另外，除了资源名称以“ .class ”结尾的特殊情况除外，该方法将无条件地在程序包为opened （即使此方法的调用者在同一模块中）时，只能在命名模块的包中找到资源作为资源）。

        API Note:
        在将多个模块定义到同一个类装载器的情况下，如果多个模块包含具有给定名称的资源，则不会指定搜索模块的顺序，并且可能非常不可预测。 当覆盖此方法时，建议实现确保任何委托与getResources(String)方法一致。
        实现要求：
        默认实现将首先搜索父类加载器的资源; 如果父代是null ，则会搜索内置到虚拟机中的类加载器的路径。 如果找不到，此方法将调用findResource(String)查找资源。
        参数
        name - 资源名称
        结果
        URL读取资源的对象; null如果无法找到资源，则无法构建一个URL来定位资源，该资源处于未被无条件打开的包中，或该资源的访问被安全管理器拒绝。
        异常
        NullPointerException - 如果 name是 null
        从以下版本开始：
        1.1

      • getResources

        public Enumeration<URL> getResources​(String name)
                              throws IOException
        查找具有给定名称的所有资源。 资源是可以通过独立于代码位置的方式由类代码访问的一些数据（图像，音频，文本等）。

        资源的名称是标识资源的/路径名。

        命名模块中的资源受Module.getResourceAsStream规定的封装规则约束 。 另外，除了资源名称以“ .class ”结尾的特殊情况除外，该方法将无条件地在程序包为opened （即使该方法的调用者在同一模块中）时，只能在命名模块的包中找到资源作为资源）。

        API Note:
        在将多个模块定义到同一个类装载器的情况下，并且多个模块中包含具有给定名称的资源时，则未指定顺序，可能非常不可预测。 当覆盖此方法时，建议实现确保任何委托与getResource(String)方法一致。 这应该确保枚举的nextElement方法返回的第一个元素是与getResource(String)方法返回的资源相同的。
        实现要求：
        默认实现将首先搜索父类加载器的资源; 如果父级是null ，则搜索内置到虚拟机中的类加载器的路径。 然后，它调用findResources(String)在该类加载器中找到具有名称的资源。 它返回一个枚举，其元素是通过搜索父类加载器找到的URL，后跟使用findResources找到的元素。
        参数
        name - 资源名称
        结果
        枚举URL资源的对象。 如果找不到资源，枚举将为空。 无法构建URL资源，无法无条件打包，或者安全管理员拒绝对资源的访问，不会在枚举中返回。
        异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果 name是 null
        从以下版本开始：
        1.2

      • resources

        public Stream<URL> resources​(String name)
        返回一个流，其元素是具有给定名称的所有资源的URL。 资源是可以通过独立于代码位置的方式由类代码访问的一些数据（图像，音频，文本等）。

        资源的名称是标识资源的/路径名。

        当返回的流被评估时，资源将被定位。 如果评估结果为IOException则I / O异常被包装在一个UncheckedIOException中 ，然后抛出该异常。

        命名模块中的资源受到Module.getResourceAsStream指定的封装规则的约束 。 另外，除了资源名称以“ .class ”结尾的特殊情况外，该方法将无条件地在程序包为opened （即使此方法的调用者在同一模块中）时，将仅在命名模块的包中找到资源作为资源）。

        API Note:
        当覆盖此方法时，建议实现确保任何委托与getResource(String)方法一致。 这应该确保流返回的第一个元素与getResource(String)方法返回的资源相同。
        实现要求：
        默认实现调用 getResources查找具有给定名称的所有资源，并以枚举中的元素作为源返回流。
        参数
        name - 资源名称
        结果
        资源流URL对象。 如果找不到资源，流将为空。 无法构建URL资源在不能无条件打开的包中，或安全管理员拒绝对资源的访问，不会在流中。
        异常
        NullPointerException - 如果 name是 null
        从以下版本开始：
        9

      • findResource

        protected URL findResource​(String name)
        找到具有给定名称的资源。 类加载器实现应该覆盖此方法。

        对于命名模块中的资源，该方法必须实现Module getResourceAsStream方法中指定的封装规则。 另外，它不能在命名模块的包中找到非“ .class ”资源，除非该包是无条件的opened 。

        实现要求：
        默认实现返回 null 。
        参数
        name - 资源名称
        结果
        URL读取资源的对象; null如果无法找到资源，则无法构建一个URL来定位资源，该资源在一个未被无条件打开的包中，或该资源的访问被安全管理器拒绝。
        从以下版本开始：
        1.2

      • findResources

        protected Enumeration<URL> findResources​(String name)
                                  throws IOException
        返回表示具有给定名称的所有资源的URL对象的枚举。 类加载器实现应该覆盖此方法。

        对于命名模块中的资源，该方法必须实现Module getResourceAsStream方法中指定的封装规则。 另外，它不能在命名模块的包中找到非“ .class ”资源，除非该软件包是无条件的opened 。

        实现要求：
        默认实现返回一个不包含元素的枚举。
        参数
        name - 资源名称
        结果
        枚举该资源的URL个对象。 如果找不到资源，枚举将为空。 无法构建URL资源在不能无条件打开的包中，或安全管理员拒绝对资源的访问，不会在枚举中返回。
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.2

      • registerAsParallelCapable

        protected static boolean registerAsParallelCapable​()
        注册呼叫者为parallel capable 。 当且仅当满足以下所有条件时，注册才能成功：
        1. 没有创建调用者的实例
        2. 调用者的所有超类（除对象类）都被注册为并行的

        请注意，一旦类加载器被注册为并行功能，则无法将其更改。

        结果
        true如果呼叫者成功注册为并行功能， false否则为 false 。
        从以下版本开始：
        1.7
        另请参见：
        isRegisteredAsParallelCapable()

      • isRegisteredAsParallelCapable

        public final boolean isRegisteredAsParallelCapable​()
        返回 true如果这个类加载器被注册为 parallel capable ，否则 false 。
        结果
        true如果这个类加载器是并行的，否则 false 。
        从以下版本开始：
        9
        另请参见：
        registerAsParallelCapable()

      • getSystemResource

        public static URL getSystemResource​(String name)
        从用于加载类的搜索路径中查找指定名称的资源。 该方法通过系统类加载器定位资源（参见getSystemClassLoader() ）。

        命名模块中的资源需遵守Module.getResourceAsStream规定的封装规则。 另外，除了资源名称以“ .class ”结尾的特殊情况除外，该方法将无条件地在程序包为opened时查找命名模块的包中的资源 。

        参数
        name - 资源名称
        结果
        A资源的一个URL ; null如果无法找到资源，则无法构建一个URL来定位资源，该资源在一个未被无条件打开的包中，或该资源的访问被安全管理器拒绝。
        从以下版本开始：
        1.1

      • getSystemResources

        public static Enumeration<URL> getSystemResources​(String name)
                                           throws IOException
        从用于加载类的搜索路径中查找指定名称的所有资源。 所找到的资源将作为URL对象的Enumeration返回。

        搜索顺序在getSystemResource(String)的文档中有描述。

        命名模块中的资源遵循Module.getResourceAsStream规定的封装规则。 另外，除了资源名称以“ .class ”结尾的特殊情况除外，该方法将无条件地在程序包为opened时查找命名模块的包中的资源 。

        参数
        name - 资源名称
        结果
        枚举资源的URL个对象。 如果找不到资源，枚举将为空。 无法构建URL资源位于未经无条件打开的包中，或安全管理员拒绝对资源的访问，不会在枚举中返回。
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.2

      • getResourceAsStream

        public InputStream getResourceAsStream​(String name)
        返回用于读取指定资源的输入流。

        getResource(String)的文档中描述了搜索顺序。

        命名模块中的资源需遵守Module.getResourceAsStream规定的封装规则。 另外，除了资源的名称以“ .class ”结尾的特殊情况除外，该方法将无条件地在程序包为opened时查找命名模块的包中的资源 。

        参数
        name - 资源名称
        结果
        用于读取资源的输入流; null如果找不到该资源，该资源是在一个未被无条件打开的包中，或该资源的访问被安全管理器拒绝。
        异常
        NullPointerException - 如果 name是 null
        从以下版本开始：
        1.1

      • getSystemResourceAsStream

        public static InputStream getSystemResourceAsStream​(String name)
        打开阅读，从用于加载类的搜索路径中指定名称的资源。 此方法通过系统类加载器定位资源（参见getSystemClassLoader() ）。

        命名模块中的资源受Module.getResourceAsStream规定的封装规则约束 。 另外，除了资源名称以“ .class ”结尾的特殊情况外，该方法将无条件地在程序包为opened时查找命名模块的包中的资源 。

        参数
        name - 资源名称
        结果
        用于读取资源的输入流; null如果找不到该资源，该资源在一个未被无条件打开的包中，或该资源的访问被安全管理器拒绝。
        从以下版本开始：
        1.1

      • getParent

        public final ClassLoader getParent​()
        返回父类加载器进行委派。 一些实现可以使用null来表示引导类加载器。 如果此类加载器的父级是引导类加载器，则此方法将返回null 。
        结果
        父母 ClassLoader
        异常
        SecurityException - 如果安全管理器存在，并且调用者的类加载器不是null并且不是此类加载器的祖先，并且主叫方没有RuntimePermission ("getClassLoader")
        从以下版本开始：
        1.2

      • getUnnamedModule

        public final Module getUnnamedModule​()
        返回此类加载器的未命名的 Module 。
        结果
        这个类加载器的未命名模块
        从以下版本开始：
        9
        另请参见：
        Module.isNamed()

      • getPlatformClassLoader

        public static ClassLoader getPlatformClassLoader​()
        返回用于委派的平台类加载器。 所有的platform classes都可以看到平台类加载器。
        Implementation Note:
        内置平台类加载器的名称为 "platform" 。
        结果
        平台 ClassLoader 。
        异常
        SecurityException - 如果存在安全管理员，并且调用者的类加载程序不是null ，并且调用者的类加载程序与平台类加载程序的祖先不一致，并且主叫方没有RuntimePermission ("getClassLoader")
        从以下版本开始：
        9

      • getSystemClassLoader

        public static ClassLoader getSystemClassLoader​()
        返回用于委派的系统类加载器。 这是新的ClassLoader实例的默认委派父，通常是用于启动应用程序的类加载器。

        该方法首先在运行时的启动顺序中早期被调用，此时它将创建系统类加载器。 这个类加载器将是主应用程序线程的上下文类加载器（例如，调用主类的main方法的线程）。

        默认的系统类加载器是此类的实现相关实例。

        如果在首次调用此方法时定义系统属性“ java.system.class.loader ”，那么该属性的值将被视为将作为系统类加载器返回的类的名称。 该类使用默认的系统类加载器加载，并且必须定义一个公共构造函数，该构造函数使用一个类型为ClassLoader参数作为委托父代。 然后使用该构造函数创建一个实例，并使用默认的系统类加载器作为参数。 所生成的类加载器被定义为系统类加载器。 在施工过程中，类装载器应小心避免调用getSystemClassLoader() 。 如果检测到系统类加载器的循环初始化，则抛出未指定的错误或异常。

        Implementation Note:
        在VM几乎完全初始化之前，系统属性才能覆盖系统类加载器。 在启动期间执行此方法的代码应注意不要缓存返回值，直到系统完全初始化为止。

        内置系统类加载器的名称为"app" 。 内置系统类加载器使用的类路径由VM初始化期间的系统属性“ java.class.path ”确定。 如果系统属性未定义，或其值为空字符串，那么当初始模块是应用程序模块路径上的模块即命名模块时，没有类路径。 如果初始模块不在应用程序模块路径上，则类路径默认为当前工作目录。

        结果
        系统 ClassLoader用于委派
        异常
        SecurityException - 如果存在安全管理员，并且主叫方的类加载程序不是null ，与系统类加载程序的祖先不一致，并且主叫方没有RuntimePermission ("getClassLoader")
        IllegalStateException - 如果在构建由“ java.system.class.loader ”属性指定的类加载器时递归调用。
        Error - 如果定义了系统属性“ java.system.class.loader ”，但是无法加载命名类，则提供程序类不会定义所需的构造函数，或者该构造函数在调用时抛出异常。 错误的根本原因可以通过Throwable.getCause()方法检索。

      • definePackage

        protected 软件包 definePackage​(String name,
                                String specTitle,
                                String specVersion,
                                String specVendor,
                                String implTitle,
                                String implVersion,
                                String implVendor,
                                URL sealBase)
        通过定义一个包name在这个ClassLoader 。

        Package names在类加载器中必须是唯一的，创建后不能重新定义或更改。

        如果一个类加载器希望定义具有特殊性能，如版本信息的包，那么类装载器应该调用此definePackage之前调用方法defineClass 。 否则， defineClass方法将在该类加载器中定义一个对应于新定义类的包的包; 该定义包的属性由软件包指定。

        API Note:
        希望为JAR中的类定义包的类加载器通常使用JAR清单中的规范和实现标题，版本和供应商。 如果包被指定为sealed JAR的清单，该URL的JAR文件通常用作sealBase 。 如果包中类'p'由此类加载器定义从多个JAR加载， 软件包对象可以根据第一类包的包含不同的信息'p'定义且JAR的清单被首先读明确定义包'p' 。

        强烈建议类加载器不调用此方法来明确定义命名模块中的包; 相反，当类是being defined时，包将被自动定义。 如果需要明确定义软件包 ，则应确保命名模块中的所有包均由软件包指定的属性定义。 否则，命名模块中的一些软件包对象可以例如用不同的密封基座密封。

        参数
        name - package name
        specTitle - 规格标题
        specVersion - 规格版本
        specVendor - 规格供应商
        implTitle - 实施标题
        implVersion - 实现版本
        implVendor - 实施供应商
        sealBase - 如果不是null ，则该封装相对于给定代码源URL对象是密封的。 否则，包装没有密封。
        结果
        新定义的 软件包对象
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果给定的 name的包已经由此类加载器定义
        从以下版本开始：
        1.2
        另请参见：
        The JAR File Specification: Package Sealing

      • getDefinedPackage

        public final 软件包 getDefinedPackage​(String name)
        返回 软件包给定的 name已经被这个类加载器定义。
        参数
        name - package name
        结果
        该 软件包给定名字的这个类加载器定义，或者 null ;如果未找到
        异常
        NullPointerException - 如果 name是 null 。
        从以下版本开始：
        9

      • getDefinedPackages

        public final 软件包[] getDefinedPackages​()
        返回此类加载器定义的所有软件包 s。 返回的数组没有重复的软件包 。
        API Note:
        该方法返回数组而不是 Set或 Stream ，以与现有的 getPackages()方法保持一致。
        结果
        由该类加载器定义的软件包对象的数组; 或者如果没有由此类加载器定义包，则为零长度数组。
        从以下版本开始：
        9

      • getPackage

        @Deprecated(since="9")
protected 软件包 getPackage​(String name)
        已过时。 如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使子载入程序定义的package-info.class文件中存在注释。 更健壮的方法是使用getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
        在这个类加载器及其祖先中找到一个由name提供的包。

        如果这个类装载器定义软件包给定的名称，该软件包返回。 否则，对于给定名称的软件包 ，这个类加载器的祖先被递归地搜索（父代父代）。

        API Note:
        platform class loader可以委托给应用程序类加载器，但应用程序类加载器不是其祖先。 当在平台类加载器上调用时，此方法将找不到定义到应用程序类加载器的包。
        参数
        name - package name
        结果
        软件包对应于由此类加载器或其祖先定义的给定名称，如果未找到， null 。
        异常
        NullPointerException - 如果 name是 null 。
        从以下版本开始：
        1.2

      • getPackages

        protected 软件包[] getPackages​()
        返回此类加载器及其祖先定义的所有软件包 。 返回的阵列可以包含多个软件包同一包名称的对象，每一个由在类装载器层次不同的类加载器定义。
        API Note:
        platform class loader可以委托给应用程序类加载器。 换句话说，定义到应用程序类加载器的模块中的包可能对平台类加载器是可见的。 另一方面，应用程序类加载器不是其祖先，因此在平台类加载器上调用时，此方法将不会返回定义到应用程序类加载器的任何包。
        结果
        由此类加载器及其祖先定义的 软件包对象的数组
        从以下版本开始：
        1.2

      • findLibrary

        protected String findLibrary​(String libname)
        返回本机库的绝对路径名。 VM调用此方法来查找属于此类加载器加载的类的本机库。 如果此方法返回null ，VM将沿着指定为“ java.library.path ”属性的路径搜索库。
        参数
        libname - 图书馆名称
        结果
        本土图书馆的绝对路径
        从以下版本开始：
        1.2
        另请参见：
        System.loadLibrary(String) ， System.mapLibraryName(String)

      • setDefaultAssertionStatus

        public void setDefaultAssertionStatus​(boolean enabled)
        设置此类加载器的默认断言状态。 此设置确定此类加载器加载的类是否将来将被初始化，默认情况下将启用或禁用断言。 可以通过调用setPackageAssertionStatus(String, boolean)或setClassAssertionStatus(String, boolean)在每个包或每个类的基础上覆盖此设置。
        参数
        enabled - true如果此类加载器加载的类将在以后默认启用断言，如果默认情况下禁用断言， false 。
        从以下版本开始：
        1.4

      • setPackageAssertionStatus

        public void setPackageAssertionStatus​(String packageName,
                                      boolean enabled)
        设置命名包的包默认断言状态。 软件包默认的断言状态确定将来属于命名软件包或其任何“子包”的类初始化的类的断言状态。

        名为p的包的子包是以“ p. ”开头的任何包。 例如， javax.swing.text是的一个子包javax.swing ，并且两个java.util和java.lang.reflect是子包java 。

        如果多个包默认值适用于给定的类，则与最特定包相关的包默认优先于其他包。 例如，如果javax.lang和javax.lang.reflect都具有与它们相关联的包默认值，则后者的包默认值适用于javax.lang.reflect类。

        软件包默认值优先于类加载器的默认断言状态，并且可以通过调用setClassAssertionStatus(String, boolean)在每个类的基础上覆盖 。

        参数
        packageName - 要设置其包默认断言状态的包的名称。 A null值表示未命名的包为“current”（参见The Java™ Language Specification的 7.4.2节）。
        enabled - true如果这个类加载器加载并属于命名的包或其任何子包的类将默认启用断言，如果默认情况下禁用断言， false 。
        从以下版本开始：
        1.4

      • setClassAssertionStatus

        public void setClassAssertionStatus​(String className,
                                    boolean enabled)
        为此类加载器中指定的顶级类和其中包含的任何嵌套类设置所需的断言状态。 此设置优先于类加载器的默认断言状态，并优先于任何适用的每个包的默认值。 如果已经初始化命名类，则此方法不起作用。 （一旦初始化了一个类，它的断言状态就不能改变了。）

        如果命名类不是顶级类，则此调用对任何类的实际断言状态都不起作用。

        参数
        className - 要设置其断言状态的顶级类的完全限定类名。
        enabled - true如果命名类要在初始化（和））时启用断言，如果该类禁用了断言， false 。
        从以下版本开始：
        1.4

      • clearAssertionStatus

        public void clearAssertionStatus​()
        将此类加载器的默认断言状态设置为false并丢弃与类加载器相关联的任何包默认值或类断言状态设置。 提供了这种方法，使得类加载器可以被忽略任何命令行或持续断言状态设置，并且“以干净的平板开始”。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ClassNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.ReflectiveOperationException
          • java.lang.ClassNotFoundException
  • All Implemented Interfaces:
    Serializable

    public class ClassNotFoundException
extends ReflectiveOperationException
    当应用程序尝试通过其字符串名称加载到类中时抛出：
    • forName方法在类Class 。
    • findSystemClass方法在类ClassLoader 。
    • loadClass方法在类ClassLoader 。

    但是没有找到具有指定名称的类的定义。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 可在施工时提供和访问经由所述“加载类时引发可选异常” getException()方法现在被称为原因 ，并且可以经由被访问Throwable.getCause()方法，以及前面提到的“传统方法。 “

    从以下版本开始：
    1.0
    另请参见：
    Class.forName(java.lang.String) ，
ClassLoader.findSystemClass(java.lang.String) ，
ClassLoader.loadClass(java.lang.String, boolean) ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClassNotFoundException​()
      构造一个 ClassNotFoundException ，没有详细信息。
      ClassNotFoundException​(String s)
      构造具有指定详细消息的 ClassNotFoundException 。
      ClassNotFoundException​(String s, Throwable ex)
      构造一个 ClassNotFoundException其中包含指定的详细消息和加载类时引发的可选异常。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因（尝试加载类时发生错误时引发的异常;否则为 null ）。
      Throwable getException​()
      返回在尝试加载类时发生错误时引发的异常。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ClassNotFoundException

        public ClassNotFoundException​()
        构造一个没有详细消息的 ClassNotFoundException 。

      • ClassNotFoundException

        public ClassNotFoundException​(String s)
        构造具有指定详细消息的 ClassNotFoundException 。
        参数
        s - 详细信息。

      • ClassNotFoundException

        public ClassNotFoundException​(String s,
                              Throwable ex)
        构造一个具有指定的详细消息的 ClassNotFoundException和加载类时引发的可选异常。
        参数
        s - 详细信息
        ex - 加载类时引发的异常
        从以下版本开始：
        1.2

    • 方法详细信息

      • getException

        public Throwable getException​()
        返回在尝试加载类时发生错误时引发的异常。 否则返回null 。

        这种方法早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

        结果
        在加载课程时提出的 异常
        从以下版本开始：
        1.2

      • getCause

        public Throwable getCause​()
        返回此异常的原因（尝试加载类时发生错误时引发的异常;否则为 null ）。
        重写：
        getCause在 Throwable
        结果
        这个例外的原因。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ClassValue<T>

  • java.lang.Object
    • java.lang.ClassValue<T>

  • public abstract class ClassValue<T>
extends Object
    将计算的值与（潜在地）每种类型相关联。 例如，如果动态语言需要为在消息发送呼叫站点遇到的每个类构造消息分派表，则可以使用ClassValue来缓存为每个遇到的类快速发送消息所需的信息。
    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ClassValue​()
      唯一的构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract T computeValue​(Class<?> type)
      计算给定类的派生值为 ClassValue 。
      T get​(Class<?> type)
      返回给定类的值。
      void remove​(Class<?> type)
      删除给定类的关联值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ClassValue

        protected ClassValue​()
        唯一的构造函数。 （用于子类构造函数的调用，通常是隐式的。）

    • 方法详细信息

      • computeValue

        protected abstract T computeValue​(Class<?> type)
        计算给定类的派生值为这个ClassValue 。

        该方法将在使用get方法访问该值的第一个线程中调用。

        通常，每个类最多调用一次此方法，但是如果已经调用了remove ，则可以再次调用此方法。

        如果此方法引发异常，则相应调用get会异常终止该异常，并且不会记录类值。

        参数
        type - 必须计算其类值的类型
        结果
        与该 ClassValue相关联的新计算值，用于给定的类或接口
        另请参见：
        get(java.lang.Class<?>) ， remove(java.lang.Class<?>)

      • get

        public T get​(Class<?> type)
        返回给定类的值。 如果尚未计算值，则通过调用computeValue方法获得。

        类的实际安装是以原子方式执行的。 在这一点上，如果几个赛车线程已经计算出值，则选择一个，并返回所有赛车线程。

        type参数通常是一个类，但它可以是任何类型，例如接口，基本类型（如int.class ）或void.class 。

        在没有remove调用的情况下，类值有一个简单的状态图：未初始化和初始化。 当进行remove调用时，值观察的规则更为复杂。 有关详细信息，请参阅remove的文档。

        参数
        type - 必须计算或检索类值的类型
        结果
        与此 ClassValue相关联的当前值，针对给定的类或接口
        异常
        NullPointerException - 如果参数为空
        另请参见：
        remove(java.lang.Class<?>) ， computeValue(java.lang.Class<?>)

      • remove

        public void remove​(Class<?> type)
        删除给定类的关联值。 如果同一类的值为read ，则其值将通过调用其computeValue方法重新初始化。 这可能导致额外调用给定类的computeValue方法。

        为了解释get和remove调用之间的交互，我们必须对类值的状态转换建模，以考虑未初始化和初始化状态之间的交替。 为了做到这一点，这些状态从零开始顺序排列，并且注意到未初始化（或去除）状态用偶数编号，而初始化（或重新初始化）状态具有奇数。

        当一个线程T消除状态类值2N ，什么都不会发生，因为类值已经初始化。 否则，国家原子级2N+1 。

        当线程T查询状态2N的类值时，线程首先尝试通过调用computeValue并安装结果值将类值初始化为状态2N+1 。

        当T尝试安装新计算的值时，如果状态仍处于2N ，则类值将使用计算值进行初始化，并将其2N+1送到状态2N+1 。

        否则，新状态是偶数还是奇数，则T将丢弃新计算值get试get操作。

        丢弃和重试的一个重要条件，否则T可能会安装一个灾难性的失效值。 例如：

        • T致电CV.get(C)并看到状态2N
        • T快速计算时间依赖值V0并准备安装它
        • T受到不幸的分页或调度事件的打击，并长时间睡觉
        • ...同时， T2也叫CV.get(C) ，看到状态2N
        • T2快速计算类似的时间依赖值V1并将其安装在CV.get(C)
        • T2 （或第三个线程）然后调用CV.remove(C) ，撤消T2的工作
        • 以前的动作T2重复了几次
        • 同时，相关的计算值随时间而变化： V1 ， V2 ，...
        • ...同时， T醒来，试图安装V0 ; 这必须失败
        我们可以假定在上述情况下， CV.computeValue使用锁来适当地观察时间依赖状态，因为它计算V1等。这并不能消除陈旧价值的威胁，因为在返回computeValue之间有时间窗口T和安装的新值。 在此期间无法进行用户同步。
        参数
        type - 必须删除其类值的类型
        异常
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Cloneable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface Cloneable

  • All Known Subinterfaces:
    AclEntry ， Attribute ， AttributedCharacterIterator ， Attributes ， CertPathBuilderResult ， CertPathParameters ， CertPathValidatorResult ， CertSelector ， CertStoreParameters ， CharacterIterator ， CRLSelector ， Descriptor ， ExtendedGSSCredential ， GSSCredential ， Name

    public interface Cloneable
    一个类实现Cloneable接口来指示Object.clone()方法，该方法对于该类的实例进行字段的字段复制是合法的。

    在不实现Cloneable接口的实例上调用对象的克隆方法会导致异常CloneNotSupportedException被抛出。

    按照惯例，实现此接口的类应使用公共方法来覆盖Object.clone （受保护）。 有关覆盖此方法的详细信息，请参阅Object.clone() 。

    注意，此接口不包含clone方法。 因此，只能通过实现该接口的事实来克隆对象是不可能的。 即使克隆方法被反射地调用，也不能保证它成功。

    从以下版本开始：
    1.0
    另请参见：
    CloneNotSupportedException ， Object.clone()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CloneNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class CloneNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.CloneNotSupportedException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ServerCloneException

    public class CloneNotSupportedException
extends 异常
    抛出，表明该clone类方法Object被称为克隆对象，但该对象的类无法实现Cloneable接口。

    覆盖clone方法的应用程序也可以抛出此异常，以指示对象无法或不应克隆。

    从以下版本开始：
    1.0
    另请参见：
    Cloneable ， Object.clone() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      CloneNotSupportedException​()
      构造一个没有详细消息的 CloneNotSupportedException 。
      CloneNotSupportedException​(String s)
      构造具有指定详细消息的 CloneNotSupportedException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • CloneNotSupportedException

        public CloneNotSupportedException​()
        构造一个没有详细消息的 CloneNotSupportedException 。

      • CloneNotSupportedException

        public CloneNotSupportedException​(String s)
        构造具有指定详细消息的 CloneNotSupportedException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Comparable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface Comparable<T>

  • 参数类型
    T - 可以将此对象与之进行比较的对象的类型
    All Known Subinterfaces:
    AnnotationTypeDoc ， AnnotationTypeElementDoc ， ArrayType ， ByteValue ， CharValue ， ChronoLocalDate ， ChronoLocalDateTime<D> ， Chronology ， ChronoZonedDateTime<D> ， ClassDoc ， ClassType ， ConstructorDoc ， Delayed ， Doc ， DoubleValue ， ExecutableMemberDoc ， Field ， FieldDoc ， FloatValue ， IntegerValue ， InterfaceType ， LocalVariable ， Location ， LongValue ， MemberDoc ， 方法 ， MethodDoc ， Name ， PackageDoc ， Path ， ProcessHandle ， ProgramElementDoc ， ReferenceType ， RootDoc ， RunnableScheduledFuture<V> ， ScheduledFuture<V> ， SerialFieldTag ， ShortValue
    所有已知实现类：
    AbstractChronology ， AbstractRegionPainter.PaintContext.CacheMode ， AccessibleAction ， AccessibleAttribute ， AccessibleRole ， AccessMode ， AclEntryFlag ， AclEntryPermission ， AclEntryType ， AddressingFeature.Responses ， Alert.AlertType ， Animation.Status ， ArcType ， AssociationChangeNotification.AssocChangeEvent ， AttributeTree.ValueKind ， Authenticator.RequestorType ， BackgroundRepeat ， BigDecimal ， BigInteger ， BlendMode ， BlurType ， Boolean ， BorderRepeat ， ButtonBar.ButtonData ， Byte ， ByteBuffer ， CacheHint ， Calendar ， CardTerminals.State ， CatalogFeatures.Feature ， CertPathValidatorException.BasicReason ， Character ， Character.UnicodeScript ， CharBuffer ， Charset ， ChronoField ， ChronoUnit ， ClientInfoStatus ， Collation ， CollationKey ， Collector.Characteristics ， Component.BaselineResizeBehavior ， CompositeName ， CompoundName ， ConditionalFeature ， ContentDisplay ， ConversionComparator.Comparison ， CRLReason ， CryptoPrimitive ， CullFace ， CycleMethod ， Date ， Date ， DayOfWeek ， DepthTest ， Desktop.Action Desktop.Action ， Diagnostic.Kind ， Diagnostic.Kind ， Dialog.ModalExclusionType ， Dialog.ModalityType ， Doclet.Option.Kind ， DocletEnvironment.ModuleMode ， DocTree.Kind ， DocumentationTool.Location ， Double ， DoubleBuffer ， DrawMode ， DrbgParameters.Capability ， DropMode ， Duration ， Duration ， ElementKind ， Elements.Origin ， ElementType ， Enum ， File ， FileTime ， FileVisitOption ， FileVisitResult ， FillRule ， Float ， FloatBuffer ， FocusEvent.Cause ， FontPosture ， FontSmoothingType ， FontWeight ， FormatStyle ， Formatter.BigDecimalLayoutForm ， FormSubmitEvent.MethodType ， GraphicsDevice.WindowTranslucency ， GregorianCalendar ， GroupLayout.Alignment ， HandlerResult ， HijrahChronology ， HijrahDate ， HijrahEra ， HorizontalDirection ， HPos ， HTMLEditorSkin.Command ， HttpClient.Redirect ， HttpClient.Version ， InputMethodHighlight ， InquireType ， Instant ， IntBuffer ， Integer ， IsoChronology ， IsoEra ， JapaneseChronology ， JapaneseDate ， JavaFileObject.Kind ， JConsoleContext.ConnectionState JConsoleContext.ConnectionState ， JDBCType ， JTable.PrintMode ， KeyCode ， KeyCombination.ModifierValue ， KeyRep.Type ， LambdaExpressionTree.BodyKind ， LanguageVersion ， LayoutStyle.ComponentPlacement ， LdapName ， LineChart.SortingPolicy ， LinkOption ， LocalDate ， LocalDateTime ， Locale.Category ， Locale.FilteringMode ， Locale.IsoCountryCode ， LocalTime ， Long ， LongBuffer ， MappedByteBuffer ， Match ， MatrixType ， MediaException.Type ， MediaPlayer.Status ， MemberReferenceTree.ReferenceMode ， MemoryType ， MessageContext.Scope ， MinguoChronology ， MinguoDate ， MinguoEra ， Modality ， Modifier ， ModuleDescriptor ， ModuleDescriptor.Exports ， ModuleDescriptor.Exports.Modifier ， ModuleDescriptor.Modifier ， ModuleDescriptor.Opens ， ModuleDescriptor.Opens.Modifier ， ModuleDescriptor.Provides ， ModuleDescriptor.Requires ， ModuleDescriptor.Requires.Modifier ， ModuleDescriptor.Version ， ModuleElement.DirectiveKind ， ModuleTree.ModuleKind ， Month ， MonthDay ， MouseButton ， MultipleGradientPaint.ColorSpaceType ， MultipleGradientPaint.CycleMethod ， NestingKind ， NodeOrientation ， Normalizer.Form ， NumericShaper.Range ， ObjectInputFilter.Status ， ObjectName ObjectName ， ObjectStreamField ， OffsetDateTime ， OffsetTime ， Orientation ， OverrunStyle ， PageOrientation ， PathTransition.OrientationType ， PeerAddressChangeNotification.AddressChangeEvent ， PixelFormat.Type ， PKIXReason ， PKIXRevocationChecker.Option ， PopupWindow.AnchorLocation ， Pos ， PosixFilePermission ， Preloader.StateChangeNotification.Type ， PrintColor ， Printer.MarginType ， PrinterJob.JobStatus ， PrintQuality ， PrintSides ， Priority ， ProcessBuilder.Redirect.Type ， Proxy.Type ， PseudoColumnUsage ， QuitStrategy ， Rdn ， ResolverStyle ， Resource.AuthenticationType ， RetentionPolicy ， RoundingMode ， RowFilter.ComparisonType ， RowIdLifetime ， RowSorterEvent.Type ， Runtime.Version ， ScrollEvent.HorizontalTextScrollUnits ， ScrollEvent.VerticalTextScrollUnits ， ScrollPane.ScrollBarPolicy ， SelectionMode ， Service.Mode ， Short ， ShortBuffer ， Side ， SignStyle ， SizeUnits ， Snippet.Kind ， Snippet.Status ， Snippet.SubKind ， SOAPBinding.ParameterStyle ， SOAPBinding.Style ， SOAPBinding.Use ， SocketFlow.Status ， SortOrder ， SourceCodeAnalysis.Completeness ， SourceVersion ， SSLEngineResult.HandshakeStatus ， SSLEngineResult.Status SSLEngineResult.Status ， StackWalker.Option ， StageStyle ， StandardCopyOption ， StandardLocation ， StandardNamespace ， StandardOpenOption ， StandardOperation ， StandardProtocolFamily ， String ， StrokeLineCap ， StrokeLineJoin ， StrokeType ， StyleOrigin ， SwingWorker.StateValue ， System.Logger.Level ， TableColumn.SortType ， TabPane.TabClosingPolicy ， Taglet.Location ， Taskbar.Feature ， Taskbar.State ， TaskEvent.Kind ， TextAlignment ， TextBoundsType ， TextInputControlSkin.Direction ， TextInputControlSkin.TextUnit ， TextStyle ， ThaiBuddhistChronology ， ThaiBuddhistDate ， ThaiBuddhistEra ， Thread.State ， Time ， Timestamp ， TimeUnit ， TouchPoint.State ， TransferMode ， TrayIcon.MessageType ， Tree.Kind ， Tree.Kind ， TreeSortMode ， TreeTableColumn.SortType ， TypeKind ， URI ， UserSessionEvent.Reason ， UUID ， VarHandle.AccessMode ， VerticalDirection ， VMOption.Origin ， VPos ， WebParam.Mode ， WebSocket.MessagePart ， Window.Type ， Worker.State ， XmlAccessOrder ， XmlAccessType ， XmlNsForm XmlNsForm ， XPathEvaluationResult.XPathResultType ， Year ， YearMonth ， ZonedDateTime ， ZoneOffset ， ZoneOffsetTransition ， ZoneOffsetTransitionRule.TimeDefinition

    public interface Comparable<T>
    该接口对实现它的每个类的对象强加一个整体排序。 这个排序被称为类的自然排序 ，类的compareTo方法被称为其自然比较方法 。

    实现此接口的对象的列表（和数组）可以自动排序Collections.sort （和Arrays.sort ）。 实现该接口的对象，可以使用如在键sorted map或作为在元件sorted set ，而不需要指定一个comparator 。

    一类的自然排序C被说成是与equals一致 ，当且仅当e1.compareTo(e2) == 0具有相同的布尔值e1.equals(e2) ，每e1和e2类C 。 注意， null不是任何类的实例，而e.compareTo(null)应该抛出一个NullPointerException即使e.equals(null)返回false 。

    强烈建议（尽管不需要）自然排序与等于一致。 这是因为，当没有显式比较器的排序集（和排序映射）与其自然排序与equals不一致的元素（或键）一起使用时会“奇怪地”。 特别地，这种排序集合（或排序映射）违反了用于设定（或映射）的通用合同，其按照equals方法定义。

    例如，如果加上两个键a和b使得(!a.equals(b) && a.compareTo(b) == 0)到有序集合不使用显式的比较器，所述第二add （有序集合不增加的大小和）操作返回false因为a和b是等价从排序集的角度。

    实际上，实现Comparable所有Java核心类都具有与等于一致的自然排序。 一个例外是java.math.BigDecimal ，其自然排序等于BigDecimal具有相等值和不同精度（例如4.0和4.00）的对象。

    对于数学倾斜，定义给定类C的自然排序的关系是：

       {(x, y) such that x.compareTo(y) <= 0}.
    这个总订单的商是：
       {(x, y) such that x.compareTo(y) == 0}.
    它从合同紧跟compareTo ，该商数是一个等价关系 C ，那自然排序是一个总的顺序 C 。 当我们说一个类的自然排序与equals一致时 ，我们意味着自然排序的商是由类的equals(Object)方法定义的等价关系：
      {(x, y) such that x.equals(y)}.

    此接口是Java Collections Framework的成员。

    从以下版本开始：
    1.2
    另请参见：
    Comparator

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int compareTo​(T o)
      将此对象与指定的对象进行比较以进行排序。

    • 方法详细信息

      • compareTo

        int compareTo​(T o)
        将此对象与指定的对象进行比较以进行排序。 返回一个负整数，零或正整数，因为该对象小于，等于或大于指定对象。

        实现程序必须确保sgn(x.compareTo(y)) == -sgn(y.compareTo(x))所有x和y 。 （这意味着x.compareTo(y)必须抛出异常iff y.compareTo(x)引发异常。）

        实施者还必须确保关系是可传递的： (x.compareTo(y) > 0 && y.compareTo(z) > 0)意味着x.compareTo(z) > 0 。

        最后，实施者必须确保x.compareTo(y)==0意味着sgn(x.compareTo(z)) == sgn(y.compareTo(z)) ，全部为z 。

        强烈建议，但不要严格要求(x.compareTo(y)==0) == (x.equals(y)) 。 一般来说，任何实现Comparable接口并违反这种情况的类都应该清楚地表明这一点。 推荐的语言是“注意：此类具有与equals不一致的自然排序”。

        在前面的描述中，符号sgn( 表达 )表示数学符号函数，其被定义为返回之一-1 ， 0 ，或1分别根据表达式的值是否为负，零或正。

        参数
        o - 要比较的对象。
        结果
        负整数，零或正整数，因为该对象小于，等于或大于指定对象。
        异常
        NullPointerException - 如果指定的对象为空
        ClassCastException - 如果指定的对象的类型阻止它与该对象进行比较。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Compiler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Compiler

  • java.lang.Object
    • java.lang.Compiler
  • 不推荐用于删除：此API元素将在以后的版本中被删除。
    JIT编译器及其技术变化太大，可以通过标准化界面有效地进行控制。 因此，许多JIT编译器实现忽略此接口，而是由特定于实现的机制（如命令行选项）控制。 此类可能在将来的Java SE版本中被删除。

    @Deprecated(since="9",
            forRemoval=true)
public final class Compiler
extends Object
    提供Compiler类来支持Java到本地代码编译器和相关服务。 按设计， Compiler课没有做; 它用作JIT编译器实现的占位符。 如果没有编译器可用，这些方法什么都不做。
    从以下版本开始：
    1.0

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static Object command​(Object any)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      检查参数类型及其字段并执行一些文档化操作。
      static boolean compileClass​(Class<?> clazz)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      编译指定的类。
      static boolean compileClasses​(String string)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      编译名称与指定字符串匹配的所有类。
      static void disable​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      导致编译器停止操作。
      static void enable​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      导致编译器恢复运行。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • compileClass

        public static boolean compileClass​(Class<?> clazz)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        编译指定的类。
        参数
        clazz - A类
        结果
        true如果编译成功; false如果编译失败或没有编译器可用
        异常
        NullPointerException - 如果 clazz是 null

      • compileClasses

        public static boolean compileClasses​(String string)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        编译名称与指定字符串匹配的所有类。
        参数
        string - 要编译的类的名称
        结果
        true如果编译成功; false如果编译失败或没有编译器可用
        异常
        NullPointerException - 如果 string是 null

      • command

        public static Object command​(Object any)
        不推荐用于删除：此API元素将在以后的版本中被删除。
        检查参数类型及其字段并执行一些文档化操作。 不需要具体的操作。
        参数
        any - 一个争论
        结果
        编译器特定的值，如果没有编译器可用， null
        异常
        NullPointerException - 如果 any是 null

      • enable

        public static void enable​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        导致编译器恢复运行。

      • disable

        public static void disable​()
        不推荐用于删除：此API元素将在以后的版本中被删除。
        导致编译器停止操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Deprecated (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang

Annotation Type Deprecated

  • @Documented
@Retention(RUNTIME)
@Target({CONSTRUCTOR,字段,LOCAL_VARIABLE,METHOD,PACKAGE,MODULE,PARAMETER,TYPE})
public @interface 已过时的
    注释@Deprecated的程序元素是不鼓励程序员使用的程序元素。 由于以下几个原因，元素可能会被弃用，例如，其使用可能会导致错误; 在未来版本中可能会更改不相容或已删除; 它已被一个较新的，通常较好的选择所取代; 或者它已经过时了。

    当不推荐的程序元素被使用或覆盖在不被废弃的代码中时，编译器会发出警告。 对本地变量声明或参数声明或包声明使用@Deprecated注释对编译器发出的警告没有影响。

    当模块被弃用时，在requires使用该模块，而不是在exports或opens子句中使用该模块会导致发出警告。 被废弃模块不会导致该模块中的类型的用途要发出警告。

    该注释类型具有字符串值元素since 。 该元素的值表示注释的程序元素首次被弃用的版本。

    此注释类型具有布尔值元素forRemoval 。 值为true表示在将来的版本中删除注释的程序元素的意图。 值为false表示不鼓励使用注释的程序元素，但是在程序元素注释时，没有特定的意图删除它。

    API Note:
    强烈建议使用@deprecated javadoc标签在文档中说明弃用程序元素的原因。 文档还应建议并链接到推荐的替代API（如果适用）。 替代API通常具有不同的语义，因此也应该讨论这样的问题。

    建议为所有新注释的程序元素提供since值。 请注意， since不能是强制性的，因为有许多现有的注释缺少此元素值。

    注释元素中没有定义的顺序。 作为一个风格， since元素应该放在第一位。

    如果存在@deprecated javadoc标记，那么@Deprecated注释应始终存在，反之亦然。

    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    9.6.4.6 @已弃用

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element 描述
      boolean forRemoval
      指示注释元素是否在将来的版本中被删除。
      String since
      返回注释元素已被弃用的版本。

    • Element Detail

      • since

        String since
        返回注释元素已被弃用的版本。 版本字符串的格式和命名空间与@since javadoc标记的值相同。 默认值为空字符串。
        结果
        版本字符串
        从以下版本开始：
        9
        Default:
        “”

      • forRemoval

        boolean forRemoval
        指示注释元素是否在将来的版本中被删除。 默认值为false 。
        结果
        该元素是否被删除
        从以下版本开始：
        9
        Default:
        假
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Double

  • java.lang.Object
    • java.lang.Number
      • java.lang.Double
  • All Implemented Interfaces:
    Serializable ， Comparable<Double>

    public final class Double
extends Number
implements Comparable<Double>
    Double类包装一个对象中的基元类型double的值。 类型为Double的对象包含一个单一字段，其类型为double 。

    此外，该类还提供了多种将double转换为String和String转换为double ，以及处理double时其他常量和方法有用的方法。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BYTES
      用于表示 double值的字节数。
      static int MAX_EXPONENT
      最大指数有限的 double变量可能有。
      static double MAX_VALUE
      的常量保持型的最大正的有限值 double ，（2-2 -52）A·2 1023。
      static int MIN_EXPONENT
      最小指数归一化 double变量可能有。
      static double MIN_NORMAL
      一个常数保持 double类型的最小正正常值，2 -1022 。
      static double MIN_VALUE
      一个常数保持最小的正非零值，类型为 double -1074 。
      static double NaN
      一个常数，持有 double类型的非数字（NaN）值。
      static double NEGATIVE_INFINITY
      持有 double型的无穷大的 double 。
      static double POSITIVE_INFINITY
      持有 double型正无穷大的 double 。
      static int SIZE
      用于表示 double值的位数。
      static Class<Double> TYPE
      Class实例表示原始类型 double 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Double​(double value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(double)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Double​(String s)
      已过时。
      很少使用这个构造函数。 使用parseDouble(String)将字符串转换为double原语，或使用valueOf(String)将字符串转换为Double对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte byteValue​()
      返回此值 Double为 byte的基本收缩转换后。
      static int compare​(double d1, double d2)
      比较两个指定的 double值。
      int compareTo​(Double anotherDouble)
      以数字方式比较两个 Double对象。
      static long doubleToLongBits​(double value)
      根据IEEE 754浮点“双格式”位布局返回指定浮点值的表示。
      static long doubleToRawLongBits​(double value)
      根据IEEE 754浮点“双格式”位布局返回指定浮点值的表示，保留非数字（NaN）值。
      double doubleValue​()
      返回此 Double对象的 double值。
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      float floatValue​()
      在缩小原始转换后，返回 Double的值作为 float 。
      int hashCode​()
      返回此 Double对象的哈希码。
      static int hashCode​(double value)
      返回一个double值的哈希码; 兼容Double.hashCode() 。
      int intValue​()
      在缩小原始转换后，返回 Double的值作为 int 。
      static boolean isFinite​(double d)
      如果参数是有限浮点值，则返回true ; 返回false否则（对于NaN和无穷大参数）。
      boolean isInfinite​()
      返回 true如果这个 Double值是无限大的，否则为 false 。
      static boolean isInfinite​(double v)
      返回 true如果指定的数是无限大， false否则。
      boolean isNaN​()
      返回 true如果此 Double值是不是非数字（NAN）， false否则。
      static boolean isNaN​(double v)
      返回 true如果指定的号码是一个不一个数字（NaN）值， false否则。
      static double longBitsToDouble​(long bits)
      返回与给定位表示相对应的 double值。
      long longValue​()
      返回此值 Double为 long的基本收缩转换后。
      static double max​(double a, double b)
      返回两个 double中的较大值，就像通过调用 Math.max一样 。
      static double min​(double a, double b)
      返回两个 double中的较小值，就像通过调用 Math.min一样 。
      static double parseDouble​(String s)
      返回一个新 double初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Double 。
      short shortValue​()
      返回此值 Double为 short的基本收缩转换后。
      static double sum​(double a, double b)
      根据+运算符将两个 double值相加。
      static String toHexString​(double d)
      返回 double参数的十六进制字符串表示形式。
      String toString​()
      返回此 Double对象的字符串表示形式。
      static String toString​(double d)
      返回 double参数的字符串表示形式。
      static Double valueOf​(double d)
      返回一个表示 double值的 Double实例。
      static Double valueOf​(String s)
      返回一个 Double对象，该对象保存由参数字符串 s表示的 double值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • POSITIVE_INFINITY

        public static final double POSITIVE_INFINITY
        持有double类型的正无穷大的double 。 它等于Double.longBitsToDouble(0x7ff0000000000000L)返回的值。
        另请参见：
        Constant Field Values

      • NEGATIVE_INFINITY

        public static final double NEGATIVE_INFINITY
        持有double类型的负无穷大的double 。 它等于由Double.longBitsToDouble(0xfff0000000000000L)返回的值。
        另请参见：
        Constant Field Values

      • NaN

        public static final double NaN
        一个持有非数字（NaN）值的常数，类型为double 。 相当于由Double.longBitsToDouble(0x7ff8000000000000L)返回的值。
        另请参见：
        Constant Field Values

      • MAX_VALUE

        public static final double MAX_VALUE
        的常量保持型的最大正的有限值double ，（2-2 -52）A·2 1023。 它等于十六进制浮点0x1.fffffffffffffP+1023 ，也等于Double.longBitsToDouble(0x7fefffffffffffffL) 。
        另请参见：
        Constant Field Values

      • MIN_NORMAL

        public static final double MIN_NORMAL
        常数保持double类型的最小正正常值，2 -1022 。 它等于十六进制浮点0x1.0p-1022 ，也等于Double.longBitsToDouble(0x0010000000000000L) 。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • MIN_VALUE

        public static final double MIN_VALUE
        一个常数保持最小的正非零值，类型为double -1074 。 它等于十六进制浮点0x0.0000000000001P-1022 ，也等于Double.longBitsToDouble(0x1L) 。
        另请参见：
        Constant Field Values

      • MAX_EXPONENT

        public static final int MAX_EXPONENT
        最大指数有限的double变量可能有。 它等于Math.getExponent(Double.MAX_VALUE)返回的值。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • MIN_EXPONENT

        public static final int MIN_EXPONENT
        最小指数归一化double变量可能有。 它等于Math.getExponent(Double.MIN_NORMAL)返回的值。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • SIZE

        public static final int SIZE
        用于表示 double值的位数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • BYTES

        public static final int BYTES
        用于表示 double值的字节数。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

      • TYPE

        public static final Class<Double> TYPE
        Class实例代表原始类型 double 。
        从以下版本开始：
        1.1

    • 构造方法详细信息

      • Double

        @Deprecated(since="9")
public Double​(double value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(double)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
        构造一个新分配的 Double对象，该对象表示基元 double参数。
        参数
        value - 要由 Double表示的值。

      • Double

        @Deprecated(since="9")
public Double​(String s)
       throws NumberFormatException
        已过时。 很少使用这个构造函数。 使用parseDouble(String)将字符串转换为double原语，或使用valueOf(String)将字符串转换为Double对象。
        构造一个新分配的Double对象，该对象表示由字符串表示的类型为double的浮点值。 该字符串转换为double值，如同通过valueOf方法一样。
        参数
        s - 要转换为 Double的字符串。
        异常
        NumberFormatException - 如果字符串不包含可解析的数字。

    • 方法详细信息

      • toString

        public static String toString​(double d)
        返回double参数的字符串表示形式。 下面提到的所有字符都是ASCII字符。
        • 如果参数是NaN，结果是字符串“ NaN ”。
        • 否则，结果是表示参数的符号和大小（绝对值）的字符串。 如果符号为负，则结果的第一个字符为“ - ”（ '\u002D' ）; 如果符号为正，则结果中不会出现符号字符。 至于幅度m ：
          • 如果m是无穷大，它由字符"Infinity"表示; 因此，正无穷大产生结果"Infinity"和负无穷大产生结果"-Infinity" 。
          • 如果m为零，则由字符"0.0"表示; 因此，负零产生结果"-0.0" ，正零产生结果"0.0" 。
          • 如果m大于或等于10 -3但小于10 7 ，则表示为m的整数部分，以十进制形式表示，不带前导零，后跟“ . ”（ '\u002E' ），后跟一个或多个表示m的小数部分的十进制数字。
          • 如果m小于10 -3或大于或等于10 7 ，则表示为所谓的“计算机科学记数法”。 设n是唯一的整数，使得10N的‰¤ 米 <10 N + 1; 然后让一个是m的精确算术商和10 牛顿 ，使1个â‰¤ 一个 <10.然后将大小被表示为a的整数部分，作为一个单一的十进制数字，后跟“ . ”（ '\u002E' ），再后面是表示一个小数部分十进制数字，后面跟有字母“ E ”（ '\u0045' ），接着为十进制整数n的表示，作为由该方法制备Integer.toString(int) 。
        必须多少位为m或a的小数部分？ 必须有至少一个数字来表示小数部分，并且除了必须唯一区分参数值和类型double相邻值所需要的数量之外，还需要数量多的数字。 也就是说，假设x是由用于有限非零参数d的该方法生成的十进制表示形式表示的精确数学值。 那么d必须是最接近x的double值。 或者如果两个double值同样接近x，那么d必须它们中的一个和d的有效数的至少显著位必须为0 。

        要创建浮点值的本地化字符串表示，请使用NumberFormat的子类。

        参数
        d - 要转换的 double 。
        结果
        参数的字符串表示形式。

      • toHexString

        public static String toHexString​(double d)
        返回double参数的十六进制字符串表示形式。 下面提到的所有字符都是ASCII字符。
        • 如果参数是NaN，结果是字符串“ NaN ”。
        • 否则，结果是一个表示参数的符号和大小的字符串。 如果符号为负，则结果的第一个字符为“ - ”（ '\u002D' ）; 如果符号为正，则结果中不会出现符号字符。 至于幅度m ：
          • 如果m是无穷大，它由字符串"Infinity"表示; 因此，正无穷大产生结果"Infinity"和负无穷大产生结果"-Infinity" 。
          • 如果m为零，则由字符串"0x0.0p0"表示; 因此，负零产生结果"-0x0.0p0" ，正零产生结果"0x0.0p0" 。
          • 如果m是具有归一化表示的double值，则使用子字符串来表示有效double和指数字段。 有效"0x1."由字符"0x1."表示，后面是有效"0x1."的其余部分的小写十六进制表示，作为分数。 删除十六进制表示中的尾随零，除非所有数字都为零，在这种情况下使用单个零。 接下来，指数由"p"表示，后跟无偏差指数的十进制字符串，就像通过对指数值的调用Integer.toString产生的。
          • 如果m是具有亚正态表示的double值，则有效"0x0."由字符"0x0."表示，后面是有效"0x0."的其余部分的十六进制表示作为分数。 删除十六进制表示中的尾随零。 接下来，指数由"p-1022"表示。 请注意，在异常有效位数中必须至少有一个非零数字。
        Examples Floating-point Value Hexadecimal String 1.0 0x1.0p0 -1.0 -0x1.0p0 2.0 0x1.0p1 3.0 0x1.8p1 0.5 0x1.0p-1 0.25 0x1.0p-2 Double.MAX_VALUE 0x1.fffffffffffffp1023 Minimum Normal Value 0x1.0p-1022 Maximum Subnormal Value 0x0.fffffffffffffp-1022 Double.MIN_VALUE 0x0.0000000000001p-1022
        参数
        d - 要转换的 double 。
        结果
        参数的十六进制字符串表示形式。
        从以下版本开始：
        1.5

      • valueOf

        public static Double valueOf​(String s)
                      throws NumberFormatException
        返回一个Double对象，该对象保存由参数字符串s表示的double值。

        如果s为null ，则抛出NullPointerException 。

        s中的前导和尾随空格字符s被忽略。 空格如String.trim()方法被删除; 也就是说，ASCII空间和控制字符都被删除。 s的其余部分应构成一个FloatValue ，如词法语法规则所述：

        FloatValue:
        Signopt NaN
        Signopt Infinity
        Signopt FloatingPointLiteral
        Signopt HexFloatingPointLiteral
        SignedInteger
        HexFloatingPointLiteral:
        HexSignificand BinaryExponent FloatTypeSuffixopt
        HexSignificand:
        HexNumeral
        HexNumeral .
        0x HexDigitsopt . HexDigits
        0X HexDigitsopt . HexDigits
        BinaryExponent:
        BinaryExponentIndicator SignedInteger
        BinaryExponentIndicator:
        p
        P
        其中Sign ， FloatingPointLiteral ， HexNumeral ， HexDigits ， SignedInteger和FloatTypeSuffix在The Java™ Language Specification的词法结构部分中定义 ，除非数字之间不接受下划线。 如果s不具有的floatValue的形式，那么NumberFormatException被抛出。 否则， s被认为是在通常的“计算机科学符号”中表示精确的十进制值，或者作为精确的十六进制值; 这个精确的数值然后在概念上转换为“无限精确”二进制值，然后通过IEEE 754浮点运算的通常的圆到最近的规则进行四舍五入，形式为double ，其包括保留零值的符号。 注意，round-to-nearest规则也意味着溢出和下溢行为; 如果s的精确值足够大（大于或等于（ MAX_VALUE + ulp(MAX_VALUE)/2 ）），则舍入到double将导致无穷大，如果s的精确值足够小（小于或等于到MIN_VALUE/2 ），舍入到浮动将导致零。最后，在舍入后，返回表示此double值的Double对象。

        要解释浮点值的本地化字符串表示，请使用NumberFormat的子类。

        注意，尾部格式说明，即确定一个浮点文字的类型说明符（ 1.0f是float值; 1.0d是double值）， 不影响该方法的结果。 换句话说，输入字符串的数值直接转换为目标浮点类型。 转换的两步序列，字符串到float后跟float到double ， 不等同于将字符串直接转换为double 。 例如， float字面值0.1f等于double值0.10000000149011612 ; 所述float字面0.1f表示不同的数值比double字面0.1 。 （数值0.1不能用二进制浮点数精确表示。）

        要避免在无效字符串上调用此方法并抛出NumberFormatException ，可以使用下面的正则表达式来屏蔽输入字符串：

           final String Digits = "(\\p{Digit}+)"; final String HexDigits = "(\\p{XDigit}+)"; // an exponent is 'e' or 'E' followed by an optionally // signed decimal integer. final String Exp = "[eE][+-]?"+Digits; final String fpRegex = ("[\\x00-\\x20]*"+ // Optional leading "whitespace" "[+-]?(" + // Optional sign character "NaN|" + // "NaN" string "Infinity|" + // "Infinity" string // A decimal floating-point string representing a finite positive // number without a leading sign has at most five basic pieces: // Digits . Digits ExponentPart FloatTypeSuffix // // Since this method allows integer-only strings as input // in addition to strings of floating-point literals, the // two sub-patterns below are simplifications of the grammar // productions from section 3.10.2 of // The Java Language Specification. // Digits ._opt Digits_opt ExponentPart_opt FloatTypeSuffix_opt "((("+Digits+"(\\.)?("+Digits+"?)("+Exp+")?)|"+ // . Digits ExponentPart_opt FloatTypeSuffix_opt "(\\.("+Digits+")("+Exp+")?)|"+ // Hexadecimal strings "((" + // 0[xX] HexDigits ._opt BinaryExponent FloatTypeSuffix_opt "(0[xX]" + HexDigits + "(\\.)?)|" + // 0[xX] HexDigits_opt . HexDigits BinaryExponent FloatTypeSuffix_opt "(0[xX]" + HexDigits + "?(\\.)" + HexDigits + ")" + ")[pP][+-]?" + Digits + "))" + "[fFdD]?))" + "[\\x00-\\x20]*");// Optional trailing "whitespace" if (Pattern.matches(fpRegex, myString)) Double.valueOf(myString); // Will not throw NumberFormatException else { // Perform suitable alternative action }
        参数
        s - 要解析的字符串。
        结果
        一个 Double对象保存由 String参数表示的值。
        异常
        NumberFormatException - 如果字符串不包含可解析的数字。

      • valueOf

        public static Double valueOf​(double d)
        返回一个表示double值的Double实例。 如果不需要新的Double实例，则该方法通常优先于构造函数Double(double)使用 ，因为该方法可能通过缓存经常请求的值而产生明显更好的空间和时间性能。
        参数
        d - 一个双重值。
        结果
        一个 Double实例，代表 d 。
        从以下版本开始：
        1.5

      • parseDouble

        public static double parseDouble​(String s)
                          throws NumberFormatException
        返回一个新 double初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Double 。
        参数
        s - 要解析的字符串。
        结果
        由字符串参数表示的 double值。
        异常
        NullPointerException - 如果字符串为空
        NumberFormatException - 如果字符串不包含可解析的 double 。
        从以下版本开始：
        1.2
        另请参见：
        valueOf(String)

      • isNaN

        public static boolean isNaN​(double v)
        返回 true如果指定的号码是一个不一个数字（NaN）值， false否则。
        参数
        v - 要测试的值。
        结果
        true如果参数的值为NaN; false否则。

      • isInfinite

        public static boolean isInfinite​(double v)
        返回 true如果指定的数是无限大， false否则。
        参数
        v - 要测试的值。
        结果
        true如果参数的值是正无穷大或负无穷大; 否则为false 。

      • isFinite

        public static boolean isFinite​(double d)
        如果参数是有限浮点值，则返回true ; 返回false （对于NaN和无穷大参数）。
        参数
        d - 要测试的 double值
        结果
        true如果参数是一个有限浮点值，否则为 false 。
        从以下版本开始：
        1.8

      • isNaN

        public boolean isNaN​()
        返回 true如果此 Double值是不是非数字（NAN）， false否则。
        结果
        true如果该对象表示的值为NaN; 否则为false 。

      • isInfinite

        public boolean isInfinite​()
        如果这个 Double值是无限大的，则返回 true ，否则为 false 。
        结果
        true如果由该对象表示的值是正无穷大或负无穷大; 否则为false 。

      • toString

        public String toString​()
        返回此Double对象的字符串表示形式。 由该对象表示的原语double值将转换为完全一样的字符串，如同通过一个参数的方法toString 。
        重写：
        toString在 Object
        结果
        这个对象的 String表示。
        另请参见：
        toString(double)

      • byteValue

        public byte byteValue​()
        返回此值 Double为 byte的基本收缩转换后。
        重写：
        byteValue在 Number
        结果
        由该对象表示的 double值转换为 byte型
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • shortValue

        public short shortValue​()
        返回此值 Double为 short的基本收缩转换后。
        重写：
        shortValue在 Number
        结果
        由该对象表示的 double值转换为 short型
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • intValue

        public int intValue​()
        在缩小原始转换后，返回 Double的值作为 int 。
        Specified by:
        intValue在 Number
        结果
        由该对象表示的 double值转换为 int型
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • longValue

        public long longValue​()
        返回此值 Double为 long的基本收缩转换后。
        Specified by:
        longValue在 Number
        结果
        该对象代表的 double值转换为 long型
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • floatValue

        public float floatValue​()
        返回此值 Double为 float的基本收缩转换后。
        Specified by:
        floatValue在 Number
        结果
        该对象代表的 double值转换为 float型
        从以下版本开始：
        1.0
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • doubleValue

        public double doubleValue​()
        返回此 Double对象的 double值。
        Specified by:
        doubleValue在 Number
        结果
        由该对象表示的 double值

      • hashCode

        public int hashCode​()
        返回此Double对象的哈希码。 结果是long整数位表示的两半的异或，与由Double对象表示的原语double值的方法doubleToLongBits(double)的方法完全相同 。 也就是说，哈希码是表达式的值：
        (int)(v^(v>>>32))
        其中v由以下定义：
        long v = Double.doubleToLongBits(this.doubleValue());
        重写：
        hashCode在 Object
        结果
        这个对象的值为 hash code 。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(double value)
        返回一个double值的哈希码; 兼容Double.hashCode() 。
        参数
        value - 哈希值
        结果
        一个 double值的哈希码值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 其结果是true当且仅当该参数不是null并且是Double对象，它表示一个double具有相同的值作为double该对象表示。 为此，当且仅当方法doubleToLongBits(double)在应用于每个值时返回相同的long值时，两个double值被认为是相同的。

        请注意，在大多数情况下，类的两个实例Double ， d1和d2 ，价值d1.equals(d2)为true当且仅当

        d1.doubleValue() == d2.doubleValue()

        也有值true 。 但是，有两个例外：

        • 如果d1和d2都表示Double.NaN ，则equals方法返回true ，即使Double.NaN==Double.NaN的值为false 。
        • 如果d1代表+0.0而d2代表-0.0 ，反之亦然， equal测试值为false ，即使+0.0==-0.0的值为true 。
        此定义允许哈希表正常运行。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        doubleToLongBits(double)

      • doubleToLongBits

        public static long doubleToLongBits​(double value)
        根据IEEE 754浮点“双格式”位布局返回指定浮点值的表示。

        位63（由掩码0x8000000000000000L选择的位）表示浮点数的符号。 位62-52（由掩码0x7ff0000000000000L选择的位）表示指数。 位51-0（由掩码0x000fffffffffffffL选择的位）表示0x000fffffffffffffL的有效数（有时称为尾数）。

        如果参数为无穷大，结果为0x7ff0000000000000L 。

        如果参数为负无穷大，则结果为0xfff0000000000000L 。

        如果参数是NaN，结果是0x7ff8000000000000L 。

        在所有情况下，结果是一个long整数，当给予longBitsToDouble(long)方法时，将产生与doubleToLongBits的参数相同的浮点值（除了所有NaN值都折叠为单个“规范”NaN值）。

        参数
        value - 一个 double精度浮点数。
        结果
        表示浮点数的位。

      • doubleToRawLongBits

        public static long doubleToRawLongBits​(double value)
        根据IEEE 754浮点“双格式”位布局返回指定浮点值的表示，保留非数字（NaN）值。

        位63（由掩码0x8000000000000000L选择的位）表示浮点数的符号。 位62-52（由掩码0x7ff0000000000000L选择的位）表示指数。 位51-0（由掩码0x000fffffffffffffL选择的位）表示0x000fffffffffffffL的有效数（有时称为尾数）。

        如果参数为无穷大，结果为0x7ff0000000000000L 。

        如果参数为负无穷大，则结果为0xfff0000000000000L 。

        如果参数是NaN，则结果是表示实际NaN值的long整数。 与doubleToLongBits方法不同， doubleToRawLongBits不会将编码NaN的所有位模式折叠到单个“规范”NaN值。

        在所有情况下，结果是一个long整数，当给予longBitsToDouble(long)方法时，将产生一个与doubleToRawLongBits的参数相同的浮点值。

        参数
        value - 一个 double精度浮点数。
        结果
        表示浮点数的位。
        从以下版本开始：
        1.3

      • longBitsToDouble

        public static double longBitsToDouble​(long bits)
        返回与给定位表示相对应的double值。 该参数被认为是根据IEEE 754浮点“双格式”位布局的浮点值的表示。

        如果参数为0x7ff0000000000000L ，结果为无穷大。

        如果参数为0xfff0000000000000L ，结果为负无穷大。

        如果参数在上述范围内的任何值0x7ff0000000000001L通过0x7fffffffffffffffL或在范围0xfff0000000000001L通过0xffffffffffffffffL ，结果是NaN。 Java提供的IEEE 754浮点运算不能用不同的位模式区分同一类型的两个NaN值。 NaN的不同值只能通过使用Double.doubleToRawLongBits方法区分开来。

        在所有其他情况下，令s ， e和m是可以从参数计算的三个值：

 int s = ((bits >> 63) == 0) ? 1 : -1;
 int e = (int)((bits >> 52) & 0x7ffL);
 long m = (e == 0) ?
                 (bits & 0xfffffffffffffL) << 1 :
                 (bits & 0xfffffffffffffL) | 0x10000000000000L;
        那么浮点结果等于数学表达式s · m ·2 e -1075的值 。

        请注意，该方法可能无法返回与long参数完全相同的位模式的double NaN。 IEEE 754区分了两种NaN，安静的NaN和信号NaN 。 两种NaN之间的区别通常在Java中不可见。 信号NaN的算术运算将它们变成具有不同但通常相似的位模式的安静的NaN。 然而，在某些处理器上，仅仅复制信号NaN也执行该转换。 特别地，复制信令NaN以将其返回到调用方法可以执行该转换。 所以longBitsToDouble可能无法返回一个double的信号NaN位模式。 因此，对于long值， doubleToRawLongBits(longBitsToDouble(start))可能不等于start 。 此外，哪些特定位模式表示信令NaN是平台依赖的; 尽管所有NaN位模式，安静或信令都必须位于上面确定的NaN范围内。

        参数
        bits - 任何 long整数。
        结果
        double具有相同位模式的浮点值。

      • compareTo

        public int compareTo​(Double anotherDouble)
        以数字比较两个Double对象。 使用此方法进行比较的方法与应用于原语double值时由Java语言数值比较运算符（ <, <=, ==, >=, > ）执行的比较有两种方式：
        • Double.NaN被认为是等于自己和大于所有其他double值（包括Double.POSITIVE_INFINITY ）。
        • 0.0d被这种方法认为大于-0.0d 。
        这确保了的自然顺序 Double受此方法影响的对象是与equals一致 。
        Specified by:
        compareTo在接口 Comparable<Double>
        参数
        anotherDouble - 要比较的 Double 。
        结果
        值0如果anotherDouble在数字上等于这个Double ; 一个值小于0如果这个Double在数字上小于anotherDouble ; 和大于一个值0 ，如果这Double在数值上大于anotherDouble 。
        从以下版本开始：
        1.2

      • compare

        public static int compare​(double d1,
                          double d2)
        比较两个指定的double值。 返回的整数值的符号与调用返回的整数的符号相同：
          new Double(d1).compareTo(new Double(d2))
        参数
        d1 - 第一个 double进行比较
        d2 - 第二个 double进行比较
        结果
        值0如果d1在数字上等于d2 ; 的值小于0如果d1是数值上小于d2 ; 且大于值0如果d1在数值上大于d2 。
        从以下版本开始：
        1.4

      • sum

        public static double sum​(double a,
                         double b)
        按照+运算符将两个 double值一起添加。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        总和 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator
        See The Java™ Language Specification:
        4.2.4浮点运算

      • max

        public static double max​(double a,
                         double b)
        返回两个 double值中的较大值，如同通过调用 Math.max一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较大的 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • min

        public static double min​(double a,
                         double b)
        返回两个 double中的较小值，就像调用 Math.min一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较小的 a和 b 。
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Enum (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Enum<E extends Enum<E>>

  • java.lang.Object
    • java.lang.Enum<E>
  • 参数类型
    E - 枚举类型的子类
    All Implemented Interfaces:
    Serializable ， Comparable<E>

    public abstract class Enum<E extends Enum<E>>
extends Object
implements Comparable<E>, Serializable
    这是所有Java语言枚举类型的公共基类。 有关枚举的更多信息，包括由编译器合成的隐式声明的方法的描述，可以在The Java™ Language Specification的 8.9节中找到 。

    请注意，当使用枚举类型作为集合的类型或作为映射中的键的类型时，可以使用专门且高效的set和map实现。

    从以下版本开始：
    1.5
    另请参见：
    Class.getEnumConstants() ， EnumSet ， EnumMap ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Enum​(String name, int ordinal)
      唯一的构造函数。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected Object clone​()
      抛出CloneNotSupportedException。
      int compareTo​(E o)
      将此枚举与指定的对象进行比较以进行订购。
      boolean equals​(Object other)
      如果指定的对象等于此枚举常量，则返回true。
      protected void finalize​()
      枚举类不能有finalize方法。
      Class<E> getDeclaringClass​()
      返回与此枚举常量的枚举类型相对应的Class对象。
      int hashCode​()
      返回此枚举常量的哈希码。
      String name​()
      返回此枚举常量的名称，与其枚举声明中声明的完全相同。
      int ordinal​()
      返回此枚举常数的序数（其枚举声明中的位置，其中初始常数的序数为零）。
      String toString​()
      返回声明中包含的此枚举常量的名称。
      static <T extends Enum<T>>
      T             		valueOf​(Class<T> enumType, String name)
      返回具有指定名称的指定枚举类型的枚举常量。

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Enum

        protected Enum​(String name,
               int ordinal)
        唯一的构造函数。 程序员无法调用此构造函数。 它由编译器响应枚举类型声明发出的代码使用。
        参数
        name - - 此枚举常量的名称，它是用于声明它的标识符。
        ordinal - - 这个枚举常数的序数（它在枚举声明中的位置，其中初始常数被分配为零的序数）。

    • 方法详细信息

      • name

        public final String name​()
        返回此枚举常量的名称，与其枚举声明中声明的完全相同。 大多数程序员应该使用toString()方法，因为toString方法可能会返回一个更加用户友好的名称。 该方法主要用于专门的情况，其中正确性取决于获得确切的名称，这从发布到发布不会有所不同。
        结果
        这个枚举常数的名称

      • ordinal

        public final int ordinal​()
        返回此枚举常数的序数（其枚举声明中的位置，其中初始常数的序数为零）。 大多数程序员将不会使用这种方法。 它被设计用于基于枚举的复杂数据结构，例如EnumSet和EnumMap 。
        结果
        这个枚举常数的序数

      • toString

        public String toString​()
        返回声明中包含的此枚举常量的名称。 该方法可以被覆盖，尽管它通常不是必需或不可取的。 当一个更“程序员友好”的字符串形式存在时，枚举类型应该覆盖此方法。
        重写：
        toString在 Object
        结果
        这个枚举常数的名称

      • equals

        public final boolean equals​(Object other)
        如果指定的对象等于此枚举常量，则返回true。
        重写：
        equals在 Object类
        参数
        other - 要与此对象相等的对象进行比较。
        结果
        如果指定的对象等于此枚举常量，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public final int hashCode​()
        返回此枚举常量的哈希码。
        重写：
        hashCode在 Object
        结果
        这个枚举常数的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • clone

        protected final Object clone​()
                      throws CloneNotSupportedException
        抛出CloneNotSupportedException。 这样可以确保枚举从未被克隆，这对保持“单身”状态是必要的。
        重写：
        clone在类 Object
        结果
        （永远不回报）
        异常
        CloneNotSupportedException - 如果对象的类不支持Cloneable接口。 覆盖clone方法的子类也可以抛出此异常以指示实例无法克隆。
        另请参见：
        Cloneable

      • compareTo

        public final int compareTo​(E o)
        将此枚举与指定的对象进行比较以进行订购。 返回一个负整数，零或正整数，因为该对象小于，等于或大于指定对象。 枚举常数仅与相同枚举类型的其他枚举常量相当。 该方法实现的自然顺序是声明常量的顺序。
        Specified by:
        compareTo在接口 Comparable<E extends Enum<E>>
        参数
        o - 要比较的对象。
        结果
        负整数，零或正整数，因为该对象小于，等于或大于指定对象。

      • getDeclaringClass

        public final Class<E> getDeclaringClass​()
        返回与此枚举常量的枚举类型相对应的Class对象。 当且仅当e1.getDeclaringClass（）== e2.getDeclaringClass（））时，两个枚举常量e1和e2具有相同的枚举类型。 （此方法返回的值可能与使用常量特定类体的枚举常量的Object.getClass()方法返回的值不同）
        结果
        该类对象对应于此枚举常量的枚举类型

      • valueOf

        public static <T extends Enum<T>> T valueOf​(Class<T> enumType,
                                            String name)
        返回具有指定名称的指定枚举类型的枚举常量。 该名称必须与用于声明此类型的枚举常量的标识符完全一致。 （不允许使用外来空白字符。）

        请注意，对于特定的枚举类型T ，可以使用该枚举上隐式声明的public static T valueOf(String)方法，而不是使用此方法将名称映射到相应的枚举常量。 枚举类型的所有常量可以通过调用该类型的隐式public static T[] values()方法获得。

        参数类型
        T - 要返回其常量的枚举类型
        参数
        enumType - Class返回常量的枚举类型的 Class对象
        name - 要返回的常量的名称
        结果
        具有指定名称的指定枚举类型的枚举常量
        异常
        IllegalArgumentException - 如果指定的枚举类型没有指定名称的常量，或者指定的类对象不表示枚举类型
        NullPointerException - 如果 enumType或 name为空
        从以下版本开始：
        1.5

      • finalize

        protected final void finalize​()
        枚举类不能有finalize方法。
        重写：
        finalize在类 Object
        另请参见：
        WeakReference ， PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


EnumConstantNotPresentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class EnumConstantNotPresentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.EnumConstantNotPresentException
  • All Implemented Interfaces:
    Serializable

    public class EnumConstantNotPresentException
extends RuntimeException
    当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。 这个异常可以抛出API used to read annotations reflectively 。
    从以下版本开始：
    1.5
    另请参见：
    AnnotatedElement ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      EnumConstantNotPresentException​(Class<? extends Enum> enumType, String constantName)
      为指定的常量构造一个 EnumConstantNotPresentException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String constantName​()
      返回缺少的枚举常量的名称。
      Class<? extends Enum> enumType​()
      返回缺少的枚举常量的类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • EnumConstantNotPresentException

        public EnumConstantNotPresentException​(Class<? extends Enum> enumType,
                                       String constantName)
        为指定的常量构造一个 EnumConstantNotPresentException 。
        参数
        enumType - 缺少枚举常量的类型
        constantName - 缺少枚举常量的名称

    • 方法详细信息

      • enumType

        public Class<? extends Enum> enumType​()
        返回缺少的枚举常量的类型。
        结果
        缺少的枚举常数的类型

      • constantName

        public String constantName​()
        返回缺少的枚举常量的名称。
        结果
        缺少枚举常数的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Error (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Error

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AnnotationFormatError ， AssertionError ， AWTError ， CoderMalfunctionError ， FactoryConfigurationError ， FactoryConfigurationError ， IOError ， LinkageError ， SchemaFactoryConfigurationError ， ServiceConfigurationError ， ThreadDeath ， TransformerFactoryConfigurationError ， VirtualMachineError

    public class Error
extends Throwable
    一个Error是的子类Throwable表示严重的问题，合理的应用程序不应该试图捕获。 大多数这样的错误是异常情况。 ThreadDeath错误，虽然是“正常”条件，也是Error一个子类，因为大多数应用程序不应该试图抓住它。

    一个方法不需要在其throws子句中声明在执行方法期间可能抛出的Error子类，但是没有被捕获，因为这些错误是不应该发生的异常条件。 也就是说， Error及其子类被视为未经检查的异常，用于编译时检查异常。

    从以下版本开始：
    1.0
    另请参见：
    ThreadDeath ， Serialized Form
    See The Java™ Language Specification:
    11.2编译时检查异常

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        Error​()
      构造一个新的错误 null作为其详细信息。
        Error​(String message)
      使用指定的详细信息构造新的错误。
        Error​(String message, Throwable cause)
      构造一个新的错误与指定的详细信息和原因。
      protected Error​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个新的错误指定的详细信息，原因，抑制启用或禁用，可写栈跟踪启用或禁用。
        Error​(Throwable cause)
      构造具有指定原因的新错误和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息为 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • Error

        public Error​()
        构造一个新的错误null作为其详细信息。 原因未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。

      • Error

        public Error​(String message)
        使用指定的详细信息构造新的错误。 原因未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。
        参数
        message - 详细信息。 保存详细信息以供稍后通过Throwable.getMessage()检索。

      • Error

        public Error​(String message,
             Throwable cause)
        构造一个新的错误与指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此错误的详细消息。

        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • Error

        public Error​(Throwable cause)
        构造具有指定的原因和详细消息的新的错误(cause==null ? null : cause.toString()) （它通常包含的类和详细消息cause ）。 该构造函数对于其他可抛出的封装的错误很有用。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • Error

        protected Error​(String message,
                Throwable cause,
                boolean enableSuppression,
                boolean writableStackTrace)
        构造一个新的错误指定的详细信息，原因，抑制启用或禁用，可写栈跟踪启用或禁用。
        参数
        message - 详细信息。
        cause - 原因。 （A null值是允许的，并且表示原因不存在或未知。）
        enableSuppression - 是否启用或禁用抑制
        writableStackTrace - 堆栈跟踪是否应该可写
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Exception (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Exception

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AbsentInformationException ， AclNotFoundException ， ActivationException ， AgentInitializationException ， AgentLoadException ， AlreadyBoundException ， ApplicationException ， AttachNotSupportedException ， AWTException ， BackingStoreException ， BadAttributeValueExpException ， BadBinaryOpValueExpException ， BadLocationException ， BadStringOperationException ， BrokenBarrierException ， CardException ， CertificateException ， ClassNotLoadedException ， CloneNotSupportedException ， DataFormatException ， DatatypeConfigurationException ， DestroyFailedException ， ExecutionControl.ExecutionControlException ， ExecutionException ， ExpandVetoException ， FontFormatException ， GeneralSecurityException ， GSSException ， IllegalClassFormatException ， IllegalConnectorArgumentsException ， IncompatibleThreadStateException ， InterruptedException ， IntrospectionException ， InvalidApplicationException ， InvalidMidiDataException ， InvalidPreferencesFormatException ， InvalidTargetObjectTypeException ， InvalidTypeException ， InvocationException ， IOException ， JAXBException ， JMException ， JShellException ， KeySelectorException ， LambdaConversionException ， LastOwnerException ， LineUnavailableException ， MarshalException ， MidiUnavailableException ， MimeTypeParseException ， MimeTypeParseException ， NamingException ， NoninvertibleTransformException ， NonInvertibleTransformException ， NotBoundException ， NotOwnerException NotOwnerException ， ParseException ， ParserConfigurationException ， PrinterException ， PrintException ， PrivilegedActionException ， PropertyVetoException ， ReflectiveOperationException ， RefreshFailedException ， RemarshalException ， RuntimeException ， SAXException ， ScriptException ， ServerNotActiveException ， SOAPException ， SQLException ， StringConcatException ， TimeoutException ， TooManyListenersException ， TransformerException ， TransformException ， UnavailableServiceException ， UnmodifiableClassException ， UnsupportedAudioFileException ， UnsupportedCallbackException ， UnsupportedFlavorException ， UnsupportedLookAndFeelException ， URIReferenceException ， URISyntaxException ， UserException ， VMStartException ， XAException ， XMLParseException ， XMLSignatureException ， XMLStreamException ， XPathException

    public class 异常
extends Throwable
    异常及其子类是Throwable的形式，表示合理应用程序可能想要捕获的条件。

    异常类和不是RuntimeException的子类的任何子类都是检查异常 。 检查的异常需要在方法或构造函数的throws子句中声明，如果它们可以通过执行方法或构造函数抛出，并在方法或构造函数边界之外传播。

    从以下版本开始：
    1.0
    另请参见：
    Error ， Serialized Form
    See The Java™ Language Specification:
    11.2编译时检查异常

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        异常​()
      构造一个新的异常，以 null作为其详细信息。
        异常​(String message)
      使用指定的详细消息构造新的异常。
        异常​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      protected 异常​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个新的异常，指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
        异常​(Throwable cause)
      构造具有指定原因的新异常和详细消息为 (cause==null ? null : cause.toString()) （通常包含类和详细消息为 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • 异常

        public Exception​()
        构造一个新的异常，以null作为其详细信息。 原因未初始化，并可能随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。

      • 异常

        public Exception​(String message)
        使用指定的详细消息构造新的异常。 原因未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。
        参数
        message - 详细信息。 保存详细信息以供稍后通过Throwable.getMessage()检索。

      • 异常

        public Exception​(String message,
                 Throwable cause)
        构造一个新的异常与指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此异常的详细消息。

        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • 异常

        public Exception​(Throwable cause)
        构造具有指定原因的新异常和详细消息为(cause==null ? null : cause.toString()) （通常包含类别和详细信息为cause ）。 这个构造函数对于除了其他throwable的包装外的异常（例如， PrivilegedActionException ） 很有用 。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null值为null ，表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • 异常

        protected Exception​(String message,
                    Throwable cause,
                    boolean enableSuppression,
                    boolean writableStackTrace)
        构造一个新的异常，指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
        参数
        message - 详细信息。
        cause - 原因。 （A null允许值，表示原因不存在或未知。）
        enableSuppression - 是否启用或禁用抑制
        writableStackTrace - 堆栈跟踪是否应该可写
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ExceptionInInitializerError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ExceptionInInitializerError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.ExceptionInInitializerError
  • All Implemented Interfaces:
    Serializable

    public class ExceptionInInitializerError
extends LinkageError
    表示在静态初始化程序中发生意外异常。 抛出一个ExceptionInInitializerError以指示在静态初始化程序或静态变量的初始化程序的评估期间发生异常。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 可以在施工时提供并通过getException()方法访问的“保存的可投掷物体”现在被称为原因 ，并且可以通过Throwable.getCause()方法以及前述的“传统方法”来访问。

    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ExceptionInInitializerError​()
      构造 ExceptionInInitializerError其中包含 null作为其详细消息字符串，没有保存的可抛物体。
      ExceptionInInitializerError​(String s)
      构造具有指定的详细消息字符串的ExceptionInInitializerError。
      ExceptionInInitializerError​(Throwable thrown)
      构造一个新的 ExceptionInInitializerError类，保存对 Throwable对象的引用，以供稍后通过 getException()方法检索。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此错误的原因（导致此错误创建的静态初始化期间发生的异常）。
      Throwable getException​()
      返回在静态初始化期间发生的异常，导致此错误被创建。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ExceptionInInitializerError

        public ExceptionInInitializerError​()
        构造一个ExceptionInInitializerError其中包含null作为其详细消息字符串，并且没有保存的可抛物体。 详细消息是描述此特定异常的字符串。

      • ExceptionInInitializerError

        public ExceptionInInitializerError​(Throwable thrown)
        构造一个新的ExceptionInInitializerError类，保存对Throwable对象的引用，以供稍后通过getException()方法检索。 详细信息字符串设置为null 。
        参数
        thrown - 抛出的异常

      • ExceptionInInitializerError

        public ExceptionInInitializerError​(String s)
        构造具有指定的详细消息字符串的ExceptionInInitializerError。 详细消息是描述此特定异常的字符串。 保存详细信息字符串，以便稍后通过Throwable.getMessage()方法检索。 没有保存的可抛物体。
        参数
        s - 详细信息

    • 方法详细信息

      • getException

        public Throwable getException​()
        返回在静态初始化期间发生的异常，导致此错误被创建。

        这种方法早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

        结果
        该 ExceptionInInitializerError的保存的可 ExceptionInInitializerError物体，或 null如果这个 ExceptionInInitializerError没有保存的可 ExceptionInInitializerError物体。

      • getCause

        public Throwable getCause​()
        返回此错误的原因（导致此错误创建的静态初始化期间发生的异常）。
        重写：
        getCause在类 Throwable
        结果
        造成此错误的原因或 null如果原因不存在或未知。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Float

  • java.lang.Object
    • java.lang.Number
      • java.lang.Float
  • All Implemented Interfaces:
    Serializable ， Comparable<Float>

    public final class Float
extends Number
implements Comparable<Float>
    Float类在一个对象中包含一个原始类型float的值。 类型为Float的对象包含单个字段，其类型为float 。

    此外，该类还提供了几种将float转换为String和String转换为float ，以及其他常数和方法在处理float时非常有用。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BYTES
      用于表示 float值的字节数。
      static int MAX_EXPONENT
      最大指数有限的 float变量可能有。
      static float MAX_VALUE
      的常量保持型的最大正的有限值 float ，（2-2 -23）A·2 127。
      static int MIN_EXPONENT
      最小指数归一化 float变量可能有。
      static float MIN_NORMAL
      一个常数保持类型为 float的最小正常值，2 -126 。
      static float MIN_VALUE
      一个持有最小正非零值的常数，类型为 float -149 。
      static float NaN
      一个持有非数字（NaN）值的常数，类型为 float 。
      static float NEGATIVE_INFINITY
      一个持有 float型的负无穷大的 float 。
      static float POSITIVE_INFINITY
      持有 float型的正无穷大的 float 。
      static int SIZE
      用于表示 float值的位数。
      static Class<Float> TYPE
      Class实例，表示原始类型 float 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Float​(double value)
      已过时。
      很少使用这个构造函数。 相反，使用静态工厂方法valueOf(float)方法如下： Float.valueOf((float)value) 。
      Float​(float value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(float)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Float​(String s)
      已过时。
      很少使用这个构造函数。 使用parseFloat(String)将字符串转换为float原语，或使用valueOf(String)将字符串转换为Float对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte byteValue​()
      在缩小原始转换后，返回 Float的值作为 byte 。
      static int compare​(float f1, float f2)
      比较两个指定的 float值。
      int compareTo​(Float anotherFloat)
      数字比较两个 Float对象。
      double doubleValue​()
      返回此值 Float为 double一个宽元转换后。
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      static int floatToIntBits​(float value)
      根据IEEE 754浮点“单格式”位布局返回指定浮点值的表示。
      static int floatToRawIntBits​(float value)
      根据IEEE 754浮点“单格式”位布局返回指定浮点值的表示，保留非数字（NaN）值。
      float floatValue​()
      返回此 Float对象的 float值。
      int hashCode​()
      返回此 Float对象的哈希码。
      static int hashCode​(float value)
      返回一个float值的哈希码; 兼容Float.hashCode() 。
      static float intBitsToFloat​(int bits)
      返回对应给定位表示的 float值。
      int intValue​()
      在缩小原始转换后，返回 Float的值作为 int 。
      static boolean isFinite​(float f)
      如果参数是有限浮点值，则返回true ; 返回false （对于NaN和无穷大参数）。
      boolean isInfinite​()
      如果这个 Float价值无限大，则返回 true ，否则为 false 。
      static boolean isInfinite​(float v)
      返回 true如果指定的数是无限大， false否则。
      boolean isNaN​()
      返回 true如果此 Float值是不是非数字（NAN）， false否则。
      static boolean isNaN​(float v)
      返回 true如果指定的号码是一个不一个数字（NaN）值， false否则。
      long longValue​()
      在缩小原始转换后，返回 Float值作为 long 。
      static float max​(float a, float b)
      返回两个 float值中的较大值，就像通过调用 Math.max一样 。
      static float min​(float a, float b)
      返回两个 float中的较小值，就像通过调用 Math.min一样 。
      static float parseFloat​(String s)
      返回一个新 float初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Float 。
      short shortValue​()
      返回此值 Float为 short的基本收缩转换后。
      static float sum​(float a, float b)
      根据+运算符，将两个 float值一起添加。
      static String toHexString​(float f)
      返回 float参数的十六进制字符串表示形式。
      String toString​()
      返回此 Float对象的字符串表示形式。
      static String toString​(float f)
      返回 float参数的字符串表示形式。
      static Float valueOf​(float f)
      返回一个表示 float值的 Float实例。
      static Float valueOf​(String s)
      返回一个 Float对象，保存由参数字符串 s表示的 float值。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • POSITIVE_INFINITY

        public static final float POSITIVE_INFINITY
        持有float型正无穷大的float 。 它等于由Float.intBitsToFloat(0x7f800000)返回的值。
        另请参见：
        Constant Field Values

      • NEGATIVE_INFINITY

        public static final float NEGATIVE_INFINITY
        一个持有float型的负无穷大的float 。 它等于Float.intBitsToFloat(0xff800000)返回的值。
        另请参见：
        Constant Field Values

      • NaN

        public static final float NaN
        一个持有非数字（NaN）值的常数，类型为float 。 它相当于由Float.intBitsToFloat(0x7fc00000)返回的值。
        另请参见：
        Constant Field Values

      • MAX_VALUE

        public static final float MAX_VALUE
        的常量保持型的最大正的有限值float ，（2-2 -23）A·2 127。 它等于十六进制浮点0x1.fffffeP+127f ，也等于Float.intBitsToFloat(0x7f7fffff) 。
        另请参见：
        Constant Field Values

      • MIN_NORMAL

        public static final float MIN_NORMAL
        常数保持类型为float的最小正常值，2 -126 。 它等于十六进制浮点数文字0x1.0p-126f ，也等于Float.intBitsToFloat(0x00800000) 。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • MIN_VALUE

        public static final float MIN_VALUE
        一个常数保持最小的正非零值，类型为float -149 。 它等于十六进制浮点0x0.000002P-126f ，也等于Float.intBitsToFloat(0x1) 。
        另请参见：
        Constant Field Values

      • MAX_EXPONENT

        public static final int MAX_EXPONENT
        最大指数有限的float变量可能有。 它等于Math.getExponent(Float.MAX_VALUE)返回的值。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • MIN_EXPONENT

        public static final int MIN_EXPONENT
        最小指数一个归一化的float变量可能有。 它等于由Math.getExponent(Float.MIN_NORMAL)返回的值。
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • SIZE

        public static final int SIZE
        用于表示 float值的位数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • BYTES

        public static final int BYTES
        用于表示 float值的字节数。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

      • TYPE

        public static final Class<Float> TYPE
        代表原始类型 float的 Class实例。
        从以下版本开始：
        1.1

    • 构造方法详细信息

      • Float

        @Deprecated(since="9")
public Float​(float value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(float)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
        构造一个新分配的 Float对象，该对象表示原语 float参数。
        参数
        value - 值由 Float表示。

      • Float

        @Deprecated(since="9")
public Float​(double value)
        已过时。 很少使用这个构造函数。 相反，使用静态工厂方法valueOf(float)方法如下： Float.valueOf((float)value) 。
        构造新分配的 Float对象，该对象表示转换为类型为 float的参数。
        参数
        value - 要由 Float表示的值。

      • Float

        @Deprecated(since="9")
public Float​(String s)
      throws NumberFormatException
        已过时。 很少使用这个构造函数。 使用parseFloat(String)将字符串转换为float原语，或使用valueOf(String)将字符串转换为Float对象。
        构造新分配的Float对象，该对象表示由字符串表示的类型为float的浮点值。 该字符串转换为float值，如同通过valueOf方法一样。
        参数
        s - 要转换为 Float的字符串。
        异常
        NumberFormatException - 如果字符串不包含可解析的数字。

    • 方法详细信息

      • toString

        public static String toString​(float f)
        返回float参数的字符串表示形式。 下面提到的所有字符都是ASCII字符。
        • 如果参数是NaN，结果是字符串“ NaN ”。
        • 否则，结果是表示参数的符号和大小（绝对值）的字符串。 如果符号为负，则结果的第一个字符为“ - ”（ '\u002D' ）; 如果符号为正，则结果中不会出现符号字符。 至于幅度m ：
          • 如果m是无穷大，它由字符"Infinity"表示; 因此，正无穷大产生结果"Infinity"和负无穷大产生结果"-Infinity" 。
          • 如果m为零，则由字符"0.0"表示; 因此，负零产生结果"-0.0" ，正零产生结果"0.0" 。
          • 如果m大于或等于10 -3但小于10 7 ，则表示为m的整数部分，十进制形式，不带前导零，后跟“ . ”（ '\u002E' ），后跟一个或多个表示m的小数部分的十进制数字。
          • 如果m小于10 -3或大于或等于10 7 ，则表示为所谓的“计算机科学记数法”。 设n是唯一的整数，使得10N的‰¤ 米 <10 N + 1; 然后让一个是m的精确算术商和10 牛顿 ，使1个â‰¤ 一个 <10.然后将大小被表示为a的整数部分，作为一个单一的十进制数字，后跟“ . ”（ '\u002E' ），再后面是表示一个小数部分十进制数字，后面跟有字母“ E ”（ '\u0045' ），接着为十进制整数n的表示，作为由该方法制备Integer.toString(int) 。
        m或a的小数部分必须打印多少位数？ 必须有至少一个数字来表示小数部分，并且除了必须唯一区分参数值和类型float相邻值所需要的数量之外，还需要多达数位数。 也就是说，假设x是由用于有限非零参数f的此方法生成的十进制表示形式表示的确切数学值。 那么f必须是最接近x的float值; 或者如果两个float值同样接近于x ，则f必须是其中之一，并且f的有效数的最低有效位必须为0 。

        要创建浮点值的本地化字符串表示，请使用NumberFormat的子类。

        参数
        f - 要转换的浮点数。
        结果
        参数的字符串表示形式。

      • toHexString

        public static String toHexString​(float f)
        返回float参数的十六进制字符串表示形式。 下面提到的所有字符都是ASCII字符。
        • 如果参数是NaN，结果是字符串“ NaN ”。
        • 否则，结果是表示参数的符号和大小（绝对值）的字符串。 如果符号为负，则结果的第一个字符为“ - ”（ '\u002D' ）; 如果符号为正，则结果中不会出现符号字符。 至于幅度m ：
          • 如果m是无穷大，它由字符串"Infinity"表示; 因此，正无穷大产生结果"Infinity"和负无穷大产生结果"-Infinity" 。
          • 如果m为零，则由字符串"0x0.0p0"表示; 因此，负零产生结果"-0x0.0p0" ，正零产生结果"0x0.0p0" 。
          • 如果m是具有归一化表示的float值，则使用子字符串来表示有效float和指数字段。 有效数字由字符"0x1."表示，后面是有意义数据的其余部分的小写十六进制表示形式作为分数。 删除十六进制表示中的尾随零，除非所有数字都为零，在这种情况下使用单个零。 接下来，指数由"p"表示，后跟无偏差指数的十进制字符串，就像通过对指数值调用Integer.toString产生的。
          • 如果m是具有亚正态表示的float值，则有效"0x0."由字符"0x0."表示，后面是有效数的其余部分的十六进制表示作为分数。 删除十六进制表示中的尾随零。 接下来，指数由"p-126"表示。 请注意，在异常有效位数中必须至少有一个非零数字。
        Examples Floating-point Value Hexadecimal String 1.0 0x1.0p0 -1.0 -0x1.0p0 2.0 0x1.0p1 3.0 0x1.8p1 0.5 0x1.0p-1 0.25 0x1.0p-2 Float.MAX_VALUE 0x1.fffffep127 Minimum Normal Value 0x1.0p-126 Maximum Subnormal Value 0x0.fffffep-126 Float.MIN_VALUE 0x0.000002p-126
        参数
        f - 要转换的 float 。
        结果
        参数的十六进制字符串表示形式。
        从以下版本开始：
        1.5

      • valueOf

        public static Float valueOf​(String s)
                     throws NumberFormatException
        返回一个Float对象，其持有由参数字符串s表示的float值。

        如果s是null ，那么抛出一个NullPointerException 。

        s中的前导和尾随空格字符s被忽略。 空格如String.trim()方法被删除; 也就是说，ASCII空间和控制字符都被删除。 s的其余部分应构成一个FloatValue ，如词法语法规则所述：

        FloatValue:
        Signopt NaN
        Signopt Infinity
        Signopt FloatingPointLiteral
        Signopt HexFloatingPointLiteral
        SignedInteger
        HexFloatingPointLiteral:
        HexSignificand BinaryExponent FloatTypeSuffixopt
        HexSignificand:
        HexNumeral
        HexNumeral .
        0x HexDigitsopt . HexDigits
        0X HexDigitsopt . HexDigits
        BinaryExponent:
        BinaryExponentIndicator SignedInteger
        BinaryExponentIndicator:
        p
        P
        其中Sign ， FloatingPointLiteral ， HexNumeral ， HexDigits ， SignedInteger和FloatTypeSuffix在The Java™ Language Specification的词法结构部分中定义 ，但数字之间不接受下划线。 如果s不具有的floatValue的形式，那么NumberFormatException被抛出。 否则， s被认为是在通常的“计算机科学记谱法”中以精确的十六进制值表示精确的十进制值; 这个精确的数值然后在概念上转换为“无限精确”二进制值，然后通过IEEE 754浮点运算的通常的圆到最近的规则进行舍入，以类型float ，其包括保留零值的符号。 注意，round-to-nearest规则也意味着溢出和下溢行为; 如果s的精确值足够大（大于或等于（ MAX_VALUE + ulp(MAX_VALUE)/2 ）），则舍入到float将导致无穷大，如果s的精确值足够小（小于或等于到MIN_VALUE/2 ），舍入到浮点数将导致零。最后，返回一个Float对象，表示此值为float值。

        要解释浮点值的本地化字符串表示，请使用NumberFormat的子类。

        注意，尾部格式说明，即确定一个浮点文字的类型说明符（ 1.0f是float值; 1.0d是double值）， 不影响该方法的结果。 换句话说，输入字符串的数值直接转换为目标浮点类型。 一般来说，转换的两步序列，字符串到double后跟double到float ， 不等同于将字符串直接转换为float 。 例如，如果首先转换为中间值double ，然后转换为float ，则字符串
        "1.00000017881393421514957253748434595763683319091796875001d"
        结果在float值1.0000002f ; 如果将字符串直接转换为float ， 1.0000001f结果为float 。

        避免调用上无效字符串这种方法和具有NumberFormatException被抛出，该文档Double.valueOf名列表正则表达式可用于筛选的输入端。

        参数
        s - 要解析的字符串。
        结果
        一个 Float对象保存由 String参数表示的值。
        异常
        NumberFormatException - 如果字符串不包含可解析的数字。

      • valueOf

        public static Float valueOf​(float f)
        返回表示指定的float值的Float实例。 如果不需要新的Float实例，则该方法通常优先于构造函数Float(float)使用 ，因为该方法可能通过缓存经常请求的值而产生明显更好的空间和时间性能。
        参数
        f - 一个浮点值。
        结果
        一个 Float实例，代表 f 。
        从以下版本开始：
        1.5

      • parseFloat

        public static float parseFloat​(String s)
                        throws NumberFormatException
        返回一个新 float初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Float 。
        参数
        s - 要解析的字符串。
        结果
        由字符串参数表示的 float值。
        异常
        NullPointerException - 如果字符串为空
        NumberFormatException - 如果字符串不包含可解析的 float 。
        从以下版本开始：
        1.2
        另请参见：
        valueOf(String)

      • isNaN

        public static boolean isNaN​(float v)
        返回 true如果指定的号码是一个不一个数字（NaN）值， false否则。
        参数
        v - 要测试的值。
        结果
        true如果参数是NaN; 否则为false 。

      • isInfinite

        public static boolean isInfinite​(float v)
        如果指定的数字无限大，则返回 true ，否则为 false 。
        参数
        v - 要测试的值。
        结果
        true如果参数是正无穷大或负无穷大; 否则为false 。

      • isFinite

        public static boolean isFinite​(float f)
        如果参数是有限浮点值，则返回true ; 返回false （对于NaN和无穷大参数）。
        参数
        f - 要测试的 float值
        结果
        true如果参数是一个有限的浮点值， false否则。
        从以下版本开始：
        1.8

      • isNaN

        public boolean isNaN​()
        返回 true如果此 Float值是不是非数字（NAN）， false否则。
        结果
        true如果该对象表示的值是NaN; 否则为false 。

      • isInfinite

        public boolean isInfinite​()
        返回 true如果这个 Float值是无限大的，否则为 false 。
        结果
        true如果由该对象表示的值是正无穷大或负无穷大; 否则为false 。

      • toString

        public String toString​()
        返回此Float对象的字符串表示形式。 由该对象表示的原语float值将转换为String正如一个参数的方法toString 。
        重写：
        toString在 Object
        结果
        这个对象的 String表示。
        另请参见：
        toString(float)

      • byteValue

        public byte byteValue​()
        返回此值 Float为 byte的基本收缩转换后。
        重写：
        byteValue在 Number
        结果
        由该对象表示的 float值转换为 byte型
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • shortValue

        public short shortValue​()
        在缩小原始转换后，返回 Float的值作为 short 。
        重写：
        shortValue在类 Number
        结果
        由该对象表示的 float值转换为 short型
        从以下版本开始：
        1.1
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • intValue

        public int intValue​()
        返回此的值 Float作为 int的基本收缩转换之后。
        Specified by:
        intValue在类 Number
        结果
        由该对象表示的 float值转换为类型 int
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • longValue

        public long longValue​()
        在缩小原始转换后，将此 Float值作为 long返回。
        Specified by:
        longValue在类 Number
        结果
        由该对象表示的 float值转换为 long型
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • floatValue

        public float floatValue​()
        返回此 Float对象的 float值。
        Specified by:
        floatValue在类 Number
        结果
        这个对象代表的 float值

      • doubleValue

        public double doubleValue​()
        在扩展原始转换后，返回 Float的值作为 double 。
        Specified by:
        doubleValue在 Number
        结果
        由该对象表示的 float值转换为 double型
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • hashCode

        public int hashCode​()
        返回此Float对象的哈希码。 结果是完全由方法floatToIntBits(float)产生的由该Float对象表示的原语float值的整数位表示。
        重写：
        hashCode在类 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(float value)
        返回一个float值的哈希码; 兼容Float.hashCode() 。
        参数
        value - 哈希值
        结果
        一个 float值的哈希码值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 结果是true如果且仅当该参数不是null并且是一个Float对象，该对象表示与此对象表示的float具有相同值的float 。 为此，当且仅当方法floatToIntBits(float)在应用于每个值时返回相同的int值，则两个float值被认为是相同的。

        请注意，在大多数情况下，类的两个实例Float ， f1和f2 ，价值f1.equals(f2)为true当且仅当

           f1.floatValue() == f2.floatValue()

        也有值true 。 但是，有两个例外：

        • 如果f1和f2均为Float.NaN ，则equals方法返回true ，即使Float.NaN==Float.NaN的值为false 。
        • 如果f1代表+0.0f而f2表示-0.0f ，反之亦然， equal测试值为false ，即使0.0f==-0.0f的值为true 。
        此定义允许哈希表正常运行。
        重写：
        equals在类 Object
        参数
        obj - 要比较的对象
        结果
        true如果对象是一样的; false否则。
        另请参见：
        floatToIntBits(float)

      • floatToIntBits

        public static int floatToIntBits​(float value)
        根据IEEE 754浮点“单格式”位布局返回指定浮点值的表示。

        位31（由掩码0x80000000选择的位）表示浮点数的符号。 位30-23（由掩码0x7f800000选择的位）表示指数。 位22-0（由掩码0x007fffff选择的位）表示0x007fffff的有效数（有时称为尾数）。

        如果参数为无穷大，结果为0x7f800000 。

        如果参数为负无穷大，则结果为0xff800000 。

        如果参数是NaN，结果是0x7fc00000 。

        在所有情况下，结果是一个整数，当给予intBitsToFloat(int)方法时，将产生与floatToIntBits的参数相同的浮点值（除了所有NaN值都折叠为单个“规范”NaN值）。

        参数
        value - 一个浮点数。
        结果
        表示浮点数的位。

      • floatToRawIntBits

        public static int floatToRawIntBits​(float value)
        根据IEEE 754浮点“单格式”位布局返回指定浮点值的表示，保留非数字（NaN）值。

        位31（由掩码0x80000000选择的位）表示浮点数的符号。 位30-23（由掩码0x7f800000选择的位）表示指数。 位22-0（由掩码0x007fffff选择的位）表示0x007fffff的有效数（有时称为尾数）。

        如果参数为无穷大，结果为0x7f800000 。

        如果参数为负无穷大，则结果为0xff800000 。

        如果参数是NaN，则结果是表示实际NaN值的整数。 与floatToIntBits方法不同， floatToRawIntBits不会将编码NaN的所有位模式折叠到单个“规范”NaN值。

        在所有情况下，结果是一个整数，当给予intBitsToFloat(int)方法时，将产生与floatToRawIntBits的参数相同的浮点值。

        参数
        value - 一个浮点数。
        结果
        表示浮点数的位。
        从以下版本开始：
        1.3

      • intBitsToFloat

        public static float intBitsToFloat​(int bits)
        返回与给定位表示相对应的float值。 根据IEEE 754浮点“单格式”位布局，该参数被认为是浮点值的表示。

        如果参数为0x7f800000 ，结果为正无穷大。

        如果参数为0xff800000 ，结果为负无穷大。

        如果参数是0x7f800001到0x7fffffff任何值，或者在0xff800001到0xffffffff的范围内，结果是一个NaN。 Java提供的IEEE 754浮点运算不能用不同的位模式区分同一类型的两个NaN值。 NaN的不同值只能通过使用Float.floatToRawIntBits方法区分开来。

        在所有其他情况下，令s ， e和m是可以从参数计算的三个值：

 int s = ((bits >> 31) == 0) ? 1 : -1;
 int e = ((bits >> 23) & 0xff);
 int m = (e == 0) ?
                 (bits & 0x7fffff) << 1 :
                 (bits & 0x7fffff) | 0x800000;
        那么浮点结果等于数学表达式s · m ·2 e -150的值 。

        请注意，该方法可能无法返回与int参数完全相同的位模式的float NaN。 IEEE 754区分了两种NaN，安静的NaN和信号NaN 。 两种NaN之间的区别通常在Java中不可见。 信号NaN的算术运算将它们变成具有不同但通常相似的位模式的安静的NaN。 然而，在某些处理器上，仅仅复制信号NaN也执行该转换。 特别地，复制信令NaN以将其返回到调用方法可以执行该转换。 所以intBitsToFloat可能无法返回一个float的信号NaN位模式。 因此，对于int值， floatToRawIntBits(intBitsToFloat(start))可能不等于start 。 此外，哪些特定位模式表示信令NaN是平台依赖的; 尽管所有NaN位模式，安静或信令都必须位于上面确定的NaN范围内。

        参数
        bits - 一个整数。
        结果
        float具有相同位模式的浮点值。

      • compareTo

        public int compareTo​(Float anotherFloat)
        数字比较两个Float对象。 当应用于原始的float值时，通过此方法执行的比较有两种方式与Java语言数值比较运算符（ <, <=, ==, >=, > ）执行的比较不同：
        • Float.NaN被认为是等于自己和大于所有其他float值（包括Float.POSITIVE_INFINITY ）。
        • 0.0f被这种方法考虑大于-0.0f 。
        这确保了这种方法施加的Float对象的自然排序 与equals一致 。
        Specified by:
        compareTo在接口 Comparable<Float>
        参数
        anotherFloat - 要比较的 Float 。
        结果
        值0如果anotherFloat在数字上等于这个Float ; 的值小于0 ，如果这Float是数值上小于anotherFloat ; 和大于一个值0 ，如果这Float在数值上大于anotherFloat 。
        从以下版本开始：
        1.2
        另请参见：
        Comparable.compareTo(Object)

      • compare

        public static int compare​(float f1,
                          float f2)
        比较两个指定的float值。 返回的整数值的符号与调用返回的整数的符号相同：
          new Float(f1).compareTo(new Float(f2))
        参数
        f1 - 第一个 float进行比较。
        f2 - 第二个 float进行比较。
        结果
        值0如果f1在数字上等于f2 ; 的值小于0如果f1是数值上小于f2 ; 且大于值0如果f1在数值上大于f2 。
        从以下版本开始：
        1.4

      • sum

        public static float sum​(float a,
                        float b)
        根据+运算符将两个 float值一起添加。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        总和为 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator
        See The Java™ Language Specification:
        4.2.4浮点运算

      • max

        public static float max​(float a,
                        float b)
        返回两个 float中的较大值，如同通过调用 Math.max一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较大的 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • min

        public static float min​(float a,
                        float b)
        返回两个 float中的较小值，就像通过调用 Math.min一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较小的 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FunctionalInterface (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang

Annotation Type FunctionalInterface

  • @Documented
@Retention(RUNTIME)
@Target(TYPE)
public @interface FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的功能接口的信息性注释类型。 在概念上，功能界面只有一个抽象方法。 由于default methods有一个实现，它们不是抽象的。 如果接口声明了一个抽象方法覆盖的公共方法之一java.lang.Object ，也不会向接口的抽象方法计数统计以来的接口的任何实施都会有一个实现从java.lang.Object或其他地方。

    请注意，可以使用lambda表达式，方法引用或构造函数引用创建函数接口的实例。

    如果使用此注释类型注释类型，则编译器需要生成错误消息，除非：

    • 类型是接口类型，而不是注释类型，枚举或类。
    • 注释类型满足功能界面的要求。

    但是，无论接口声明中是否存在FunctionalInterface注释，编译器将将满足功能接口定义的任何接口视为功能接口。

    从以下版本开始：
    1.8
    See The Java™ Language Specification:
    4.3.2。 类对象，9.8功能接口，9.4.3接口方法体，9.6.4.9 @功能接口
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


IllegalAccessError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IllegalAccessError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.IncompatibleClassChangeError
            • java.lang.IllegalAccessError
  • All Implemented Interfaces:
    Serializable

    public class IllegalAccessError
extends IncompatibleClassChangeError
    如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。

    通常，该错误被编译器捕获; 此错误只能在运行时发生，如果类的定义已经不相容地更改。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalAccessError​()
      构造一个没有详细消息的 IllegalAccessError 。
      IllegalAccessError​(String s)
      构造具有指定详细消息的 IllegalAccessError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalAccessError

        public IllegalAccessError​()
        构造一个 IllegalAccessError ，没有详细信息。

      • IllegalAccessError

        public IllegalAccessError​(String s)
        构造具有指定详细消息的 IllegalAccessError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalAccessException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IllegalAccessException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.ReflectiveOperationException
          • java.lang.IllegalAccessException
  • All Implemented Interfaces:
    Serializable

    public class IllegalAccessException
extends ReflectiveOperationException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    从以下版本开始：
    1.0
    另请参见：
    Class.newInstance() ，
Field.set(Object, Object) ，
Field.setBoolean(Object, boolean) ，
Field.setByte(Object, byte) ，
Field.setShort(Object, short) ，
Field.setChar(Object, char) ，
Field.setInt(Object, int) ，
Field.setLong(Object, long) ，
Field.setFloat(Object, float) ，
Field.setDouble(Object, double) ，
Field.get(Object) ，
Field.getBoolean(Object) ，
Field.getByte(Object) ，
Field.getShort(Object) ，
Field.getChar(Object) ，
Field.getInt(Object) ，
Field.getLong(Object) ，
Field.getFloat(Object) ，
Field.getDouble(Object) ，
Method.invoke(Object, Object[]) ，
Constructor.newInstance(Object[]) ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalAccessException​()
      构造一个 IllegalAccessException而没有详细信息。
      IllegalAccessException​(String s)
      构造一个 IllegalAccessException的详细消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalAccessException

        public IllegalAccessException​()
        构造一个 IllegalAccessException没有详细消息。

      • IllegalAccessException

        public IllegalAccessException​(String s)
        构造一个 IllegalAccessException的详细信息。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalArgumentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IllegalArgumentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    IllegalChannelGroupException ， IllegalCharsetNameException ， IllegalFormatException ， IllegalSelectorException ， IllegalThreadStateException ， InvalidKeyException ， InvalidOpenTypeException ， InvalidParameterException ， InvalidPathException ， InvalidStreamException ， KeyAlreadyExistsException ， NumberFormatException ， PatternSyntaxException ， ProviderMismatchException ， UnresolvedAddressException ， UnsupportedAddressTypeException ， UnsupportedCharsetException

    public class IllegalArgumentException
extends RuntimeException
    抛出表示一种方法已经通过了非法或不正确的参数。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalArgumentException​()
      构造一个没有详细消息的 IllegalArgumentException 。
      IllegalArgumentException​(String s)
      构造具有指定详细消息的 IllegalArgumentException 。
      IllegalArgumentException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      IllegalArgumentException​(Throwable cause)
      构造具有指定原因的新异常和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息为 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalArgumentException

        public IllegalArgumentException​()
        构造一个没有详细信息的 IllegalArgumentException 。

      • IllegalArgumentException

        public IllegalArgumentException​(String s)
        构造具有指定详细信息的 IllegalArgumentException 。
        参数
        s - 详细信息。

      • IllegalArgumentException

        public IllegalArgumentException​(String message,
                                Throwable cause)
        构造一个新的异常与指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此异常的详细消息。

        参数
        message - 详细信息（由 Throwable.getMessage()方法保存供以后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • IllegalArgumentException

        public IllegalArgumentException​(Throwable cause)
        构造具有指定原因的新异常和详细消息(cause==null ? null : cause.toString()) （通常包含类和详细消息为cause ）。 此构造函数对于其他可抛出的封装的异常（例如， PrivilegedActionException ）非常有用。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalCallerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IllegalCallerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalCallerException
  • All Implemented Interfaces:
    Serializable

    public class IllegalCallerException
extends RuntimeException
    被抛出来表示一个方法已被不适当的调用者调用。
    从以下版本开始：
    9
    另请参见：
    StackWalker.getCallerClass() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalCallerException​()
      构造一个没有详细消息的IllegalCallerException。
      IllegalCallerException​(String s)
      构造具有指定详细消息的IllegalCallerException。
      IllegalCallerException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      IllegalCallerException​(Throwable cause)
      构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalCallerException

        public IllegalCallerException​()
        构造一个没有详细消息的IllegalCallerException。

      • IllegalCallerException

        public IllegalCallerException​(String s)
        构造具有指定详细消息的IllegalCallerException。
        参数
        s - 包含详细消息的字符串（可以为null）

      • IllegalCallerException

        public IllegalCallerException​(String message,
                              Throwable cause)
        构造一个新的异常与指定的详细信息和原因。
        参数
        message - 详细信息（可以为null）
        cause - 原因（可以为null）

      • IllegalCallerException

        public IllegalCallerException​(Throwable cause)
        构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（可以为null）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalMonitorStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IllegalMonitorStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalMonitorStateException
  • All Implemented Interfaces:
    Serializable

    public class IllegalMonitorStateException
extends RuntimeException
    抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。
    从以下版本开始：
    1.0
    另请参见：
    Object.notify() ，
Object.notifyAll() ，
Object.wait() ，
Object.wait(long) ，
Object.wait(long, int) ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalMonitorStateException​()
      构造一个没有详细消息的 IllegalMonitorStateException 。
      IllegalMonitorStateException​(String s)
      构造具有指定详细消息的 IllegalMonitorStateException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalMonitorStateException

        public IllegalMonitorStateException​()
        构造一个没有详细消息的 IllegalMonitorStateException 。

      • IllegalMonitorStateException

        public IllegalMonitorStateException​(String s)
        构造具有指定详细消息的 IllegalMonitorStateException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IllegalStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AcceptPendingException ， AlreadyBoundException ， AlreadyConnectedException ， CancellationException ， CancelledKeyException ， ClosedDirectoryStreamException ， ClosedFileSystemException ， ClosedSelectorException ， ClosedWatchServiceException ， ConnectionPendingException ， FormatterClosedException ， IllegalBlockingModeException ， IllegalComponentStateException ， IllegalReceiveException ， IllegalUnbindException ， InvalidDnDOperationException ， InvalidMarkException ， NoConnectionPendingException ， NonReadableChannelException ， NonWritableChannelException ， NotYetBoundException ， NotYetConnectedException ， OverlappingFileLockException ， ReadPendingException ， ShutdownChannelGroupException ， WritePendingException

    public class IllegalStateException
extends RuntimeException
    表示在非法或不适当的时间调用了一种方法。 换句话说，Java环境或Java应用程序对于请求的操作并不处于适当的状态。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalStateException​()
      构造一个没有详细消息的IllegalStateException。
      IllegalStateException​(String s)
      构造具有指定详细消息的IllegalStateException。
      IllegalStateException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      IllegalStateException​(Throwable cause)
      构造具有指定原因的新异常和详细消息为 (cause==null ? null : cause.toString()) （通常包含类和详细消息为 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalStateException

        public IllegalStateException​()
        构造一个没有详细消息的IllegalStateException。 详细消息是描述此特定异常的字符串。

      • IllegalStateException

        public IllegalStateException​(String s)
        构造具有指定详细消息的IllegalStateException。 详细消息是描述此特定异常的字符串。
        参数
        s - 包含详细消息的字符串

      • IllegalStateException

        public IllegalStateException​(String message,
                             Throwable cause)
        构造一个新的异常与指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此异常的详细消息。

        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • IllegalStateException

        public IllegalStateException​(Throwable cause)
        构造具有指定原因的新异常和详细信息(cause==null ? null : cause.toString()) （通常包含类别和详细信息为cause ）。 这个构造函数对于除了其他可抛弃物的封装外（例如PrivilegedActionException ）的异常更有用。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalThreadStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IllegalThreadStateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.lang.IllegalThreadStateException
  • All Implemented Interfaces:
    Serializable

    public class IllegalThreadStateException
extends IllegalArgumentException
    抛出以指示线程不处于所请求操作的适当状态。 见，例如， suspend种resume类方法Thread 。
    从以下版本开始：
    1.0
    另请参见：
    Thread.resume() ， Thread.suspend() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalThreadStateException​()
      构造一个 IllegalThreadStateException ，没有详细消息。
      IllegalThreadStateException​(String s)
      构造具有指定详细消息的 IllegalThreadStateException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalThreadStateException

        public IllegalThreadStateException​()
        构造一个没有详细消息的 IllegalThreadStateException 。

      • IllegalThreadStateException

        public IllegalThreadStateException​(String s)
        构造具有指定详细消息的 IllegalThreadStateException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IncompatibleClassChangeError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IncompatibleClassChangeError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.IncompatibleClassChangeError
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AbstractMethodError ， IllegalAccessError ， InstantiationError ， NoSuchFieldError ， NoSuchMethodError

    public class IncompatibleClassChangeError
extends LinkageError
    当一些类定义发生不兼容的类更改时抛出。 当前执行方法所依赖的某些类的定义已经改变了。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IncompatibleClassChangeError​()
      构造一个没有详细消息的 IncompatibleClassChangeError 。
      IncompatibleClassChangeError​(String s)
      构造具有指定详细消息的 IncompatibleClassChangeError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IncompatibleClassChangeError

        public IncompatibleClassChangeError​()
        构造一个 IncompatibleClassChangeError ，没有详细信息。

      • IncompatibleClassChangeError

        public IncompatibleClassChangeError​(String s)
        构造具有指定详细消息的 IncompatibleClassChangeError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IndexOutOfBoundsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class IndexOutOfBoundsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IndexOutOfBoundsException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ArrayIndexOutOfBoundsException ， StringIndexOutOfBoundsException

    public class IndexOutOfBoundsException
extends RuntimeException
    抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。

    应用程序可以将此类子类化以指示类似的异常。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IndexOutOfBoundsException​()
      构造一个没有详细消息的 IndexOutOfBoundsException 。
      IndexOutOfBoundsException​(int index)
      构造一个新的 IndexOutOfBoundsException类，其中包含非法索引的参数。
      IndexOutOfBoundsException​(String s)
      构造具有指定详细信息的 IndexOutOfBoundsException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IndexOutOfBoundsException

        public IndexOutOfBoundsException​()
        构造一个 IndexOutOfBoundsException ，没有详细信息。

      • IndexOutOfBoundsException

        public IndexOutOfBoundsException​(String s)
        构造具有指定详细消息的 IndexOutOfBoundsException 。
        参数
        s - 详细信息

      • IndexOutOfBoundsException

        public IndexOutOfBoundsException​(int index)
        构造一个新的IndexOutOfBoundsException类，其中包含指示非法索引的参数。

        该索引包含在此异常的详细消息中。 详细信息的确切显示格式未指定。

        参数
        index - 非法索引。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InheritableThreadLocal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class InheritableThreadLocal<T>

  • java.lang.Object
    • java.lang.ThreadLocal<T>
      • java.lang.InheritableThreadLocal<T>

  • public class InheritableThreadLocal<T>
extends ThreadLocal<T>
    该类扩展了ThreadLocal以提供从父线程到子线程的值的继承：当子线程被创建时，子接收到父值具有值的所有可继承的线程局部变量的初始值。 孩子的价值通常与父母的价值相同; 然而，通过覆盖本childValue中的childValue方法，孩子的价值可以作为父母的任意函数。

    当维护变量中的每个线程属性（例如，用户ID，事务ID）必须自动发送到创建的任何子线程时，可以使用可继承的线程局部变量。

    注意：在创建新的thread期间 ，可以选择不接收可继承的线程局部变量的初始值。

    从以下版本开始：
    1.2
    另请参见：
    ThreadLocal

    • 构造方法摘要

      构造方法
      Constructor 描述
      InheritableThreadLocal​()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected T childValue​(T parentValue)
      在子线程创建时，根据父值的值计算该可继承线程局部变量的子级初始值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.lang.ThreadLocal

        get, initialValue, remove, set, withInitial

    • 构造方法详细信息

      • InheritableThreadLocal

        public InheritableThreadLocal​()

    • 方法详细信息

      • childValue

        protected T childValue​(T parentValue)
        在子线程创建时，根据父值的值计算该可继承线程局部变量的子级初始值。 这个方法是在孩子启动之前从父线程中调用的。

        该方法只返回其输入参数，如果需要不同的行为，应该被覆盖。

        参数
        parentValue - 父线程的值
        结果
        the child thread's initial value
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InstantiationError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class InstantiationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.IncompatibleClassChangeError
            • java.lang.InstantiationError
  • All Implemented Interfaces:
    Serializable

    public class InstantiationError
extends IncompatibleClassChangeError
    当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。

    通常，该错误被编译器捕获; 此错误只能在运行时发生，如果类的定义已经不相容地更改。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InstantiationError​()
      构造一个 InstantiationError ，没有详细信息。
      InstantiationError​(String s)
      构造具有指定的详细消息的 InstantiationError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InstantiationError

        public InstantiationError​()
        构造一个 InstantiationError ，没有详细消息。

      • InstantiationError

        public InstantiationError​(String s)
        构造具有指定详细消息的 InstantiationError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InstantiationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class InstantiationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.ReflectiveOperationException
          • java.lang.InstantiationException
  • All Implemented Interfaces:
    Serializable

    public class InstantiationException
extends ReflectiveOperationException
    当应用程序试图创建使用一个类的实例抛出newInstance方法在类Class ，而指定的类对象不能被实例化。 实例化可能由于各种原因而失败，包括但不限于：
    • 类对象表示抽象类，接口，数组类，基元类型，或void
    • 该类没有空值构造函数
    从以下版本开始：
    1.0
    另请参见：
    Class.newInstance() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InstantiationException​()
      构造一个 InstantiationException ，没有详细信息。
      InstantiationException​(String s)
      构造具有指定详细消息的 InstantiationException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InstantiationException

        public InstantiationException​()
        构造一个 InstantiationException ，没有详细信息。

      • InstantiationException

        public InstantiationException​(String s)
        构造具有指定详细消息的 InstantiationException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Integer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Integer

  • java.lang.Object
    • java.lang.Number
      • java.lang.Integer
  • All Implemented Interfaces:
    Serializable ， Comparable<Integer>

    public final class Integer
extends Number
implements Comparable<Integer>
    Integer类包装一个对象中的原始类型int的值。 类型为Integer的对象包含一个单一字段，其类型为int 。

    此外，该类还提供了几种将int转换为String和String转换为int ，以及其他常量和方法在处理int时非常有用。

    实施说明：“bit twiddling”方法（如highestOneBit和numberOfTrailingZeros ）的实现基于Henry S. Warren，Jr.的Hacker's Delight （Addison Wesley，2002）的材料。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BYTES
      用于表示二进制补码二进制形式的 int值的字节数。
      static int MAX_VALUE
      保持最大值一个 int可以有2 31 -1。
      static int MIN_VALUE
      持有最小值的常数为 int可以为-2 31 。
      static int SIZE
      用于表示二进制补码二进制形式的 int值的位数。
      static Class<Integer> TYPE
      所述 Class实例表示基本类型 int 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Integer​(int value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(int)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Integer​(String s)
      已过时。
      很少使用这个构造函数。 使用parseInt(String)将字符串转换为int原语，或使用valueOf(String)将字符串转换为Integer对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static int bitCount​(int i)
      返回指定的 int值的二进制补码二进制表示中的 int 。
      byte byteValue​()
      返回此值 Integer为 byte的基本收缩转换后。
      static int compare​(int x, int y)
      数值比较两个 int值。
      int compareTo​(Integer anotherInteger)
      以数字方式比较两个 Integer对象。
      static int compareUnsigned​(int x, int y)
      比较两个 int数值以数值方式处理为无符号的值。
      static Integer decode​(String nm)
      将 String解码成 Integer 。
      static int divideUnsigned​(int dividend, int divisor)
      返回将第一个参数除以秒的无符号商，其中每个参数和结果被解释为无符号值。
      double doubleValue​()
      返回此值 Integer为 double一个宽元转换后。
      boolean equals​(Object obj)
      将此对象与指定的对象进行比较。
      float floatValue​()
      返回此值 Integer为 float一个宽元转换后。
      static Integer getInteger​(String nm)
      确定具有指定名称的系统属性的整数值。
      static Integer getInteger​(String nm, int val)
      确定具有指定名称的系统属性的整数值。
      static Integer getInteger​(String nm, Integer val)
      返回具有指定名称的系统属性的整数值。
      int hashCode​()
      返回此 Integer的哈希码。
      static int hashCode​(int value)
      返回一个int值的哈希码; 兼容Integer.hashCode() 。
      static int highestOneBit​(int i)
      在指定的 int值中，最高位（最左侧）为1位，最多 int返回一个 int值。
      int intValue​()
      返回 Integer的值作为 int 。
      long longValue​()
      在扩展原始转换后，返回 Integer的值作为 long 。
      static int lowestOneBit​(int i)
      在指定的 int值中，最低位（最右边）为1位，最多 int返回一个 int值。
      static int max​(int a, int b)
      返回两个 int中的较大值，就像调用 Math.max一样 。
      static int min​(int a, int b)
      返回两个 int中的较小值，如同通过调用 Math.min一样 。
      static int numberOfLeadingZeros​(int i)
      返回指定的 int值的二进制补码二进制表示中最高位（“最左”）1位之前的零位数。
      static int numberOfTrailingZeros​(int i)
      返回在指定的 int值的二进制补码二进制表示中的最低位（“最右”）1位之后的零位数。
      static int parseInt​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数作为有符号int指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
      static int parseInt​(String s)
      将字符串参数解析为带符号的十进制整数。
      static int parseInt​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的有符号整数。
      static int parseUnsignedInt​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数为一个无符号int在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
      static int parseUnsignedInt​(String s)
      将字符串参数解析为无符号十进制整数。
      static int parseUnsignedInt​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的无符号整数。
      static int remainderUnsigned​(int dividend, int divisor)
      返回无符号余数，将第一个参数除以秒，其中每个参数和结果被解释为无符号值。
      static int reverse​(int i)
      返回通过反转指定的 int值的二进制补码二进制表示中的位的顺序获得的值。
      static int reverseBytes​(int i)
      返回通过反转指定的 int值的二进制补码表示中的字节顺序获得的值。
      static int rotateLeft​(int i, int distance)
      返回通过旋转指定的 int剩下的指定的 int值的二进制补码二进制表示获得的值。
      static int rotateRight​(int i, int distance)
      返回通过将指定的 int值的二进制补码二进制表达式右 int指定的位数而 int值。
      short shortValue​()
      在缩小原始转换后，返回 Integer的值作为 short 。
      static int signum​(int i)
      返回指定的 int值的signum函数。
      static int sum​(int a, int b)
      根据+运算符将两个整数相加。
      static String toBinaryString​(int i)
      在基数2中返回整数参数的字符串表示形式为无符号整数。
      static String toHexString​(int i)
      返回整数参数的字符串表示形式，作为16位中的无符号整数。
      static String toOctalString​(int i)
      在基数8中返回整数参数的字符串表示形式为无符号整数。
      String toString​()
      返回一个表示 Integer的值的 String对象。
      static String toString​(int i)
      返回表示指定整数的 String对象。
      static String toString​(int i, int radix)
      返回由第二个参数指定的基数中的第一个参数的字符串表示形式。
      static long toUnsignedLong​(int x)
      通过无符号转换将参数转换为 long 。
      static String toUnsignedString​(int i)
      将参数的字符串表示形式返回为无符号十进制值。
      static String toUnsignedString​(int i, int radix)
      以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。
      static Integer valueOf​(int i)
      返回表示指定的 int值的 Integer实例。
      static Integer valueOf​(String s)
      返回一个保存指定值的 Integer对象 String 。
      static Integer valueOf​(String s, int radix)
      返回一个 Integer对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN_VALUE

        @Native
public static final int MIN_VALUE
        持有最小值的常数为 int可以为-2 31 。
        另请参见：
        Constant Field Values

      • MAX_VALUE

        @Native
public static final int MAX_VALUE
        持有最大值的常数为 int可以为2 31 -1。
        另请参见：
        Constant Field Values

      • TYPE

        public static final Class<Integer> TYPE
        所述 Class实例表示基本类型 int 。
        从以下版本开始：
        1.1

      • SIZE

        @Native
public static final int SIZE
        用于表示二进制补码二进制形式的 int值的位数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • BYTES

        public static final int BYTES
        用于表示二进制补码二进制形式的 int值的字节数。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Integer

        @Deprecated(since="9")
public Integer​(int value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(int)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
        构造新分配的 Integer对象，该对象表示指定的 int值。
        参数
        value - 要由 Integer对象表示的值。

      • Integer

        @Deprecated(since="9")
public Integer​(String s)
        throws NumberFormatException
        已过时。 很少使用这个构造函数。 使用parseInt(String)将字符串转换为int原语，或使用valueOf(String)将字符串转换为Integer对象。
        构造一个新分配的Integer对象，表示由String参数指示的int值。 字符串转换为int值，正好是基数为parseInt方法使用的方式。
        参数
        s -的 String被转换为 Integer 。
        异常
        NumberFormatException - 如果 String不包含可解析整数。

    • 方法详细信息

      • toString

        public static String toString​(int i,
                              int radix)
        返回由第二个参数指定的基数中的第一个参数的字符串表示形式。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则使用基数10 。

        如果第一个参数为负，则结果的第一个元素是ASCII减号字符'-' （ '\u002D' ）。 如果第一个参数不为负，则结果中不会出现符号字符。

        结果的剩余字符表示第一个参数的大小。 如果幅度为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，幅度的表示的第一个字符将不是零字符。 以下ASCII字符用作数字：

        0123456789abcdefghijklmnopqrstuvwxyz
        这些是'\u0030'至'\u0039'和'\u0061'至'\u007A' 。 如果radix是N ，则这些字符的前N个按照所示顺序用作小数N位。 因此，十六进制数字（ 0123456789abcdef 16）为0123456789abcdef 。 如果需要大写字母，则可以对结果调用String.toUpperCase()方法：
        Integer.toString(n, 16).toUpperCase()
        参数
        i - 要转换为字符串的整数。
        radix - 在字符串表示中使用的基数。
        结果
        指定基数中的参数的字符串表示形式。
        另请参见：
        Character.MAX_RADIX ， Character.MIN_RADIX

      • toUnsignedString

        public static String toUnsignedString​(int i,
                                      int radix)
        以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则使用基数10 。

        请注意，由于第一个参数被视为无符号值，因此不会打印前导符号。

        如果幅度为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，幅度的表示的第一个字符将不是零字符。

        基数的行为和用作数字的字符与toString相同。

        参数
        i - 要转换为无符号字符串的整数。
        radix - 在字符串表示中使用的基数。
        结果
        指定基数中的参数的无符号字符串表示形式。
        从以下版本开始：
        1.8
        另请参见：
        toString(int, int)

      • toHexString

        public static String toHexString​(int i)
        返回整数参数的字符串表示形式，作为16位中的无符号整数。

        如果参数为负，则无符号整数值为参数加2 32 ; 否则，它等于论证。 该值转换为十六进制（基数16）的ASCII数字字符串，无额外的引导0 s。

        可以通过调用Integer.parseUnsignedInt(s, 16)从返回的字符串s恢复参数的值。

        如果无符号大小为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，无符号大小的表示的第一个字符将不是零字符。 以下字符用作十六进制数字：

        0123456789abcdef
        这些是'\u0030'至'\u0039'和'\u0061'至'\u0066' 。 如果需要大写字母，可能会对结果调用String.toUpperCase()方法：
        Integer.toHexString(n).toUpperCase()
        参数
        i - 要转换为字符串的整数。
        结果
        由参数以十六进制表示的无符号整数值的字符串表示（16位）。
        从以下版本开始：
        1.0.2
        另请参见：
        parseUnsignedInt(String, int) ， toUnsignedString(int, int)

      • toOctalString

        public static String toOctalString​(int i)
        在基数8中返回整数参数的字符串表示形式为无符号整数。

        如果参数为负，则无符号整数值为参数加2 32 ; 否则，它等于论证。 该值被转换为八进制（基数8）中的ASCII数字字符串，没有额外的前导0 s。

        可以通过调用Integer.parseUnsignedInt(s, 8)从返回的字符串s恢复参数的值。

        如果无符号大小为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，无符号大小的表示的第一个字符将不是零字符。 以下字符用作八进制数字：

        01234567
        这些是'\u0030'到'\u0037'的字符。
        参数
        i - 要转换为字符串的整数。
        结果
        由参数以八进制表示的无符号整数值的字符串表示（基数8）。
        从以下版本开始：
        1.0.2
        另请参见：
        parseUnsignedInt(String, int) ， toUnsignedString(int, int)

      • toBinaryString

        public static String toBinaryString​(int i)
        在基数2中返回整数参数的字符串表示形式为无符号整数。

        如果参数为负，则无符号整数值为参数加2 32 ; 否则就等于论证。 该值转换为二进制（基本2）中的ASCII数字字符串，没有额外的前导0 s。

        可以通过调用Integer.parseUnsignedInt(s, 2)从返回的字符串s恢复参数的值。

        如果无符号幅度为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，无符号大小的表示的第一个字符将不是零字符。 字符'0' （ '\u0030' ）和'1' （ '\u0031' ）被用作二进制数字。

        参数
        i - 要转换为字符串的整数。
        结果
        由二进制（基数2）中的参数表示的无符号整数值的字符串表示形式。
        从以下版本开始：
        1.0.2
        另请参见：
        parseUnsignedInt(String, int) ， toUnsignedString(int, int)

      • toString

        public static String toString​(int i)
        返回表示指定整数的String对象。 该参数被转换为带符号的十进制表示形式，并作为字符串返回，就好像参数和小数10被赋予toString(int, int)方法的参数一样 。
        参数
        i - 要转换的整数。
        结果
        基数10中的参数的字符串表示形式。

      • toUnsignedString

        public static String toUnsignedString​(int i)
        将参数的字符串表示形式返回为无符号十进制值。 参数转换为无符号十进制表示形式，并作为字符串返回，完全如同参数和小数10作为toUnsignedString(int, int)方法的参数。
        参数
        i - 要转换为无符号字符串的整数。
        结果
        参数的无符号字符串表示形式。
        从以下版本开始：
        1.8
        另请参见：
        toUnsignedString(int, int)

      • parseInt

        public static int parseInt​(String s,
                           int radix)
                    throws NumberFormatException
        将字符串参数解析为第二个参数指定的基数中的有符号整数。 字符串中的字符必须全部是指定基数的数字（由Character.digit(char, int)是否返回非负值确定），除了第一个字符可能是ASCII减号'-' （ '\u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）以表示正值。 返回所得到的整数值。

        如果发生以下任何一种情况，则抛出类型为NumberFormatException的异常：

        • 第一个参数是null或是长度为零的字符串。
        • 基数小于Character.MIN_RADIX或大于Character.MAX_RADIX 。
        • 字符串的任何字符不是指定基数的数字，除了第一个字符可能是负号'-' （ '\u002D' ）或加号'+' （ '\u002B' ），前提是字符串长于长度1。
        • 由字符串表示的值不是int类型的值。

        例子：

         parseInt("0", 10) returns 0
 parseInt("473", 10) returns 473
 parseInt("+42", 10) returns 42
 parseInt("-0", 10) returns 0
 parseInt("-FF", 16) returns -255
 parseInt("1100110", 2) returns 102
 parseInt("2147483647", 10) returns 2147483647
 parseInt("-2147483648", 10) returns -2147483648
 parseInt("2147483648", 10) throws a NumberFormatException
 parseInt("99", 8) throws a NumberFormatException
 parseInt("Kona", 10) throws a NumberFormatException
 parseInt("Kona", 27) returns 411787
        参数
        s - 包含要解析的整数表示的 String
        radix - 解析时使用的基数 s 。
        结果
        由指定基数中的字符串参数表示的整数。
        异常
        NumberFormatException - 如果 String不包含可解析的 int 。

      • parseInt

        public static int parseInt​(CharSequence s,
                           int beginIndex,
                           int endIndex,
                           int radix)
                    throws NumberFormatException
        解析CharSequence参数作为有符号int指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。

        该方法没有采取措施来防范CharSequence在解析时被突变。

        参数
        s -所述 CharSequence含有 int表示被解析
        beginIndex - 开始索引，包括。
        endIndex - 结束索引，独家。
        radix - 解析时使用的基数 s 。
        结果
        由指定基数的子 int表示的带符号的 int 。
        异常
        NullPointerException - 如果 s为空。
        IndexOutOfBoundsException - 如果 beginIndex为负数，或者如果 beginIndex大于 endIndex或者如果 endIndex大于 s.length() 。
        NumberFormatException - 如果 int在指定的 CharSequence中不包含可解析的 radix ，或者如果 radix小于 Character.MIN_RADIX或大于 Character.MAX_RADIX 。
        从以下版本开始：
        9

      • parseInt

        public static int parseInt​(String s)
                    throws NumberFormatException
        将字符串参数解析为带符号的十进制整数。 字符串中的字符都必须是十进制数字，除了第一个字符可能是ASCII减号'-' （ '\u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）表示正值。 返回所得到的整数值，就像参数和小数 10被赋予parseInt(java.lang.String, int)方法的参数一样 。
        参数
        s - 一个 String包含要解析的 int表示
        结果
        由参数以十进制表示的整数值。
        异常
        NumberFormatException - 如果字符串不包含可解析整数。

      • parseUnsignedInt

        public static int parseUnsignedInt​(String s,
                                   int radix)
                            throws NumberFormatException
        将字符串参数解析为第二个参数指定的基数中的无符号整数。 无符号整数将通常与负数关联的值映射到大于MAX_VALUE正数。 字符串中的字符必须全部是指定基数的数字（由Character.digit(char, int)是否返回非负值确定），但第一个字符可能是ASCII加号'+' （ '\u002B' ）。 返回所得到的整数值。

        如果发生以下任何一种情况，抛出类型为NumberFormatException的异常：

        • 第一个参数是null或是长度为零的字符串。
        • 基数小于Character.MIN_RADIX或大于Character.MAX_RADIX 。
        • 字符串的任何字符不是指定基数的数字，除了第一个字符可能是加号'+' （ '\u002B' ），条件是字符串长于长度1。
        • 由字符串所表示的值大于最大的无符号的较大int ，2 32 -1。
        参数
        s - 包含要解析的无符号整数表示的 String
        radix - 解析时使用的基数 s 。
        结果
        由指定基数中的字符串参数表示的整数。
        异常
        NumberFormatException - 如果 String不包含可解析的 int 。
        从以下版本开始：
        1.8

      • parseUnsignedInt

        public static int parseUnsignedInt​(CharSequence s,
                                   int beginIndex,
                                   int endIndex,
                                   int radix)
                            throws NumberFormatException
        解析CharSequence参数为一个无符号int在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。

        该方法在解析时不采取措施来防范CharSequence被突变。

        参数
        s -所述 CharSequence含有无符号 int表示被解析
        beginIndex - 包含起始索引。
        endIndex - 结束索引，排他。
        radix - 解析时使用的基数 s 。
        结果
        无符号的 int由指定基数中的子 int表示。
        异常
        NullPointerException - 如果 s为空。
        IndexOutOfBoundsException - 如果 beginIndex为负数，或者如果 beginIndex大于 endIndex或 endIndex大于 s.length() 。
        NumberFormatException - 如果 int在指定的 CharSequence中不包含可解析的无符号 radix ，或者如果 radix小于 Character.MIN_RADIX或大于 Character.MAX_RADIX 。
        从以下版本开始：
        9

      • parseUnsignedInt

        public static int parseUnsignedInt​(String s)
                            throws NumberFormatException
        将字符串参数解析为无符号十进制整数。 字符串中的字符必须都是十进制数字，除了第一个字符可能是ASCII加号'+' （ '\u002B' ）。 返回所得到的整数值，就像参数和小数 10被赋予parseUnsignedInt(java.lang.String, int)方法的参数一样 。
        参数
        s - a String其中包含要解析的无符号 int表示
        结果
        由参数以十进制表示的无符号整数值。
        异常
        NumberFormatException - 如果字符串不包含可分析的无符号整数。
        从以下版本开始：
        1.8

      • valueOf

        public static Integer valueOf​(String s,
                              int radix)
                       throws NumberFormatException
        返回一个Integer对象，该对象保存从指定的String提取的值，并使用第二个参数给出的基数进行解析。 第一个参数被解释为表示由第二个参数指定的基数中的有符号整数，就好像向parseInt(java.lang.String, int)方法给出了参数。 结果是一个表示由字符串指定的整数值的Integer对象。

        换句话说，该方法返回一个Integer对象的值等于：

        new Integer(Integer.parseInt(s, radix))
        参数
        s - 要解析的字符串。
        radix - 用于解释的基数 s
        结果
        一个 Integer对象，保存由指定基数中的字符串参数表示的值。
        异常
        NumberFormatException - 如果 String不包含可解析的 int 。

      • valueOf

        public static Integer valueOf​(String s)
                       throws NumberFormatException
        返回一个保存指定值的Integer对象String 。 该参数被解释为表示一个有符号的十进制整数，就好像这个参数被赋予了parseInt(java.lang.String)方法一样。 结果是表示由字符串指定的整数值的Integer对象。

        换句话说，该方法返回一个Integer对象的值等于：

        new Integer(Integer.parseInt(s))
        参数
        s - 要解析的字符串。
        结果
        一个 Integer对象，保存由string参数表示的值。
        异常
        NumberFormatException - 如果字符串不能被解析为整数。

      • valueOf

        public static Integer valueOf​(int i)
        返回表示指定的int值的Integer实例。 如果不需要新的Integer实例，则该方法通常应优先于构造函数Integer(int)使用 ，因为该方法可能通过缓存经常请求的值而产生明显更好的空间和时间性能。 此方法将始终缓存-128到127（含）范围内的值，并可能会超出此范围之外的其他值。
        参数
        i - 一个 int价值。
        结果
        一个 Integer实例，代表 i 。
        从以下版本开始：
        1.5

      • byteValue

        public byte byteValue​()
        返回此值 Integer为 byte的基本收缩转换后。
        重写：
        byteValue在 Number
        结果
        该对象在转换为 byte之后表示的数值。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • shortValue

        public short shortValue​()
        在缩小原始转换后，返回 Integer的值作为 short 。
        重写：
        shortValue在 Number
        结果
        该对象在转换为 short之后表示的数值。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • intValue

        public int intValue​()
        返回 Integer的值作为 int 。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。

      • longValue

        public long longValue​()
        在扩展原始转换后，返回 Integer的值作为 long 。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long之后表示的数值。
        另请参见：
        toUnsignedLong(int)
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • floatValue

        public float floatValue​()
        返回此值 Integer为 float一个宽元转换后。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • doubleValue

        public double doubleValue​()
        在扩展原始转换后，返回 Integer的值作为 double 。
        Specified by:
        doubleValue在类 Number
        结果
        该对象在转换为 double之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • toString

        public String toString​()
        返回一个表示Integer的值的String对象。 该值将转换为带符号的十进制表示形式，并作为字符串返回，就像整数值作为toString(int)方法的参数给出。
        重写：
        toString在类 Object
        结果
        这个对象在基数10中的值的字符串表示。

      • hashCode

        public int hashCode​()
        返回此 Integer的哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值等于由该 Integer对象表示的基元 int值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(int value)
        返回一个int值的哈希码; 兼容Integer.hashCode() 。
        参数
        value - 哈希值
        结果
        一个 int值的哈希码值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        将此对象与指定的对象进行比较。 如果且仅当参数不是null并且是包含与此对象相同的int值的Integer对象时，结果为true 。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • getInteger

        public static Integer getInteger​(String nm)
        确定具有指定名称的系统属性的整数值。

        第一个参数被视为系统属性的名称。 系统属性可通过System.getProperty(java.lang.String)方法访问。 然后，使用decode支持的语法将该属性的字符串值解释为整数值，并返回表示此值的Integer对象。

        如果没有指定名称的属性，如果指定的名称为空或null ，或者该属性没有正确的数字格式，则返回null 。

        换句话说，该方法返回一个Integer对象的值等于：

        getInteger(nm, null)
        参数
        nm - 属性名称。
        结果
        该 Integer价值 Integer 。
        异常
        SecurityException - 原因与 System.getProperty相同
        另请参见：
        System.getProperty(java.lang.String) ， System.getProperty(java.lang.String, java.lang.String)

      • getInteger

        public static Integer getInteger​(String nm,
                                 int val)
        确定具有指定名称的系统属性的整数值。

        第一个参数被视为系统属性的名称。 系统属性可通过System.getProperty(java.lang.String)方法访问。 然后，使用decode支持的语法将该属性的字符串值解释为整数值，并返回表示此值的Integer对象。

        第二个参数是默认值。 如果没有指定名称的属性，如果该属性没有正确的数字格式，或者指定的名称为空，则返回表示第二个参数的值的Integer对象，或者是null 。

        换句话说，该方法返回一个Integer对象的值等于：

        getInteger(nm, new Integer(val))
        但实际上可以以下列方式实现：
         Integer result = getInteger(nm, null);
 return (result == null) ? new Integer(val) : result;
        以避免在不需要默认值时不必要地分配Integer对象。
        参数
        nm - 属性名称。
        val - 默认值。
        结果
        该 Integer价值 Integer 。
        异常
        SecurityException - 原因与 System.getProperty相同
        另请参见：
        System.getProperty(java.lang.String) ， System.getProperty(java.lang.String, java.lang.String)

      • getInteger

        public static Integer getInteger​(String nm,
                                 Integer val)
        返回具有指定名称的系统属性的整数值。 第一个参数被视为系统属性的名称。 系统属性可通过System.getProperty(java.lang.String)方法访问。 然后将该属性的字符串值解释为decode方法的整数值，并返回表示此值的Integer对象; 综上所述：
        • 如果属性值以两个ASCII字符0x或ASCII字符# ，而不是后面加上减号，则其余部分将按照与基数16的方法valueOf(java.lang.String, int)完全一样的十六进制整数进行解析。
        • 如果属性值以ASCII字符0开头，后跟另一个字符，则将其解析为与基数8的方法valueOf(java.lang.String, int)完全一致的八进制整数。
        • 否则，属性值将被解析为十进制整数，与使用基数10的方法valueOf(java.lang.String, int)完全相同。

        第二个参数是默认值。 如果没有指定名称的属性，如果该属性没有正确的数字格式，或者指定的名称为空或者是null ，则返回默认值。

        参数
        nm - 房产名称。
        val - 默认值。
        结果
        该 Integer价值 Integer 。
        异常
        SecurityException - 原因与 System.getProperty相同
        另请参见：
        System.getProperty(java.lang.String) ， System.getProperty(java.lang.String, java.lang.String)

      • decode

        public static Integer decode​(String nm)
                      throws NumberFormatException
        将String解码成Integer 。 接受以下语法给出的十进制，十六进制和八进制数：
        DecodableString:
        Signopt DecimalNumeral
        Signopt 0x HexDigits
        Signopt 0X HexDigits
        Signopt # HexDigits
        Signopt 0 OctalDigits
        Sign:
        -
        +
        DecimalNumeral，HexDigits，和OctalDigits如在The Java™ Language Specification 3.10.1部分所定义，所不同的是下划线不数字之间接受。

        可选符号和/或基数说明符（“ 0x ”，“ 0X ”，“ # ”或前导零）之后的Integer.parseInt由具有指示的基数（10,16或8）的Integer.parseInt方法进行解析。 这个字符序列必须表示一个正值，或者将抛出一个NumberFormatException 。 如果指定的String第一个字符为负号，则结果将被取消。 在String中不允许使用空格字符。

        参数
        nm - 要解码的 String 。
        结果
        一个 Integer对象，持有 int值代表 nm
        异常
        NumberFormatException - 如果 String不包含可解析整数。
        另请参见：
        parseInt(java.lang.String, int)

      • compareTo

        public int compareTo​(Integer anotherInteger)
        以数字方式比较两个 Integer对象。
        Specified by:
        compareTo在接口 Comparable<Integer>
        参数
        anotherInteger - 要比较的 Integer 。
        结果
        值0如果这个Integer等于参数Integer ; 小于0的值，如果这个Integer数值小于参数Integer ; 和大于一个值0 ，如果这Integer在数值上大于该参数Integer （带符号的比较）。
        从以下版本开始：
        1.2

      • compare

        public static int compare​(int x,
                          int y)
        数值比较两个int 。 返回的值与以下内容相同：
          Integer.valueOf(x).compareTo(Integer.valueOf(y))
        参数
        x - 第一个 int进行比较
        y - 第二个 int进行比较
        结果
        值0如果是x == y ; 一个值小于0如果是x < y ; 和值大于0如果x > y
        从以下版本开始：
        1.7

      • compareUnsigned

        public static int compareUnsigned​(int x,
                                  int y)
        比较两个 int值以数字方式将值视为无符号。
        参数
        x - 第一个 int进行比较
        y - 第二个 int进行比较
        结果
        值0如果是x == y ; 如果x < y为无符号值，则小于0 ; 如果x > y为无符号值，则值大于0
        从以下版本开始：
        1.8

      • toUnsignedLong

        public static long toUnsignedLong​(int x)
        通过无符号转换将参数转换为long 。 在一个无符号转换为long ，所述的高阶32位long是零和低32位等于整数参数的比特。 因此，零和正值int值被映射到数字上相等的long值，而负int值被映射到等于输入加上2 32的long值。
        参数
        x - 转换为无符号 long的值
        结果
        该参数通过无符号转换转换为 long
        从以下版本开始：
        1.8

      • divideUnsigned

        public static int divideUnsigned​(int dividend,
                                 int divisor)
        返回将第一个参数除以秒的无符号商，其中每个参数和结果被解释为无符号值。

        注意，在二进制补码算术中，如果两个操作数被认为是被签名的或者两个都是无符号的，则加法，减法和乘法的三个其他基本算术运算是逐位相同的。 因此不提供addUnsigned等方法。

        参数
        dividend - 要划分的值
        divisor - 做分割的值
        结果
        第一个参数的无符号商除以第二个参数
        从以下版本开始：
        1.8
        另请参见：
        remainderUnsigned(int, int)

      • remainderUnsigned

        public static int remainderUnsigned​(int dividend,
                                    int divisor)
        返回无符号余数，将第一个参数除以秒，其中每个参数和结果被解释为无符号值。
        参数
        dividend - 要分割的值
        divisor - 做分割的值
        结果
        第一个参数的无符号余数除以第二个参数
        从以下版本开始：
        1.8
        另请参见：
        divideUnsigned(int, int)

      • highestOneBit

        public static int highestOneBit​(int i)
        在指定的int值中，最高位（最左侧）为1位，最多返回一个int值，最多只有一个1位。 如果指定的值在其二进制补码二进制表示中没有1位，也就是说，如果它等于零，则返回零。
        参数
        i - 要计算其最高一位的值
        结果
        一个 int值，单位为1位，位于指定值中的最高位1位，如果指定值本身等于零，则为零。
        从以下版本开始：
        1.5

      • lowestOneBit

        public static int lowestOneBit​(int i)
        在指定的int值中以最低位（最右）的位置返回int值，最多只有一个1位。 如果指定的值在其二进制补码二进制表示中没有1位，也就是说，如果它等于零，则返回零。
        参数
        i - 要计算最低一位的值
        结果
        一个 int值，单位为1位，位于指定值中的最低位1位，如果指定值本身等于零，则为零。
        从以下版本开始：
        1.5

      • numberOfLeadingZeros

        public static int numberOfLeadingZeros​(int i)
        返回指定的int值的二进制补码二进制表示中的最高位（“最左”）1位之前的零位数。 如果指定的值在其二进制补码表示中没有1位，换句话说如果它等于零则返回32。

        请注意，该方法与对数基数2密切相关。对于所有正值int值x：

        • floor（log 2 （x））= 31 - numberOfLeadingZeros(x)
        • ceil（log 2 （x））= 32 - numberOfLeadingZeros(x - 1)
        参数
        i - 要计算前导零数的值
        结果
        在指定的 int值的二进制补码二进制表示中的最高位（“最左”）1位之前的零位数，如果该值等于零，则为32。
        从以下版本开始：
        1.5

      • numberOfTrailingZeros

        public static int numberOfTrailingZeros​(int i)
        返回在指定的int值的二进制补码二进制表示中的最低位（“最右”）1位之后的零位数。 如果指定的值在其二进制补码表示中没有1位，换句话说如果它等于零则返回32。
        参数
        i - 要计算尾数零的值
        结果
        在指定的 int值的二进制补码二进制表示中的最低位（“最右”）1位后的零位数，如果该值等于零，则为32位。
        从以下版本开始：
        1.5

      • bitCount

        public static int bitCount​(int i)
        返回指定的int值的二进制补码二进制表示中的int 。 此功能有时称为人口数量 。
        参数
        i - 要对其位进行计数的值
        结果
        二进制数的二进制补码二进制表示的指定值为 int 。
        从以下版本开始：
        1.5

      • rotateLeft

        public static int rotateLeft​(int i,
                             int distance)
        返回通过将指定的int值的二进制补码二进制表示旋转指定的int值。 （左侧移位的位或右侧的高位侧重新输入，或低位）。

        请注意，具有负距离的左旋转相当于右旋： rotateLeft(val, -distance) == rotateRight(val, distance) 。 还要注意，32的任意倍数的旋转是无操作的，所以除旋转距离的最后五位之外，除了距离为负数外，也可以忽略旋转距离的最后5位： rotateLeft(val, distance) == rotateLeft(val, distance & 0x1F) 。

        参数
        i - 其位要向左旋转的值
        distance - 向左旋转的位位数
        结果
        通过将指定的 int值的二进制补码二进制表示旋转指定的 int值。
        从以下版本开始：
        1.5

      • rotateRight

        public static int rotateRight​(int i,
                              int distance)
        返回通过将指定的int值的二进制补码二进制表达式右int指定的位数而int值。 （右侧移位的位或左侧的低位侧重新输入，或高位）。

        注意，具有负距离的右旋转相当于左旋： rotateRight(val, -distance) == rotateLeft(val, distance) 。 还要注意，32的任意倍数的旋转是无操作的，因此除旋转距离的最后五位以外，除了距离为负值外，也可以忽略旋转距离的最后5位： rotateRight(val, distance) == rotateRight(val, distance & 0x1F) 。

        参数
        i - 其位要向右旋转的值
        distance - 要向右旋转的位位数
        结果
        通过将指定的 int值的二进制补码二进制表达式转换为指定的 int值。
        从以下版本开始：
        1.5

      • reverse

        public static int reverse​(int i)
        返回通过反转指定的 int值的二进制补码二进制表示中的位的顺序获得的值。
        参数
        i - 要反转的值
        结果
        通过在指定的 int值中反转位的顺序获得的值。
        从以下版本开始：
        1.5

      • signum

        public static int signum​(int i)
        返回指定的int值的signum函数。 （如果指定的值为负，返回值为-1;如果指定的值为零，返回值为0;如果指定的值为正，返回值为1）。
        参数
        i - 要计算其符号的值
        结果
        指定功能的指定值为 int 。
        从以下版本开始：
        1.5

      • reverseBytes

        public static int reverseBytes​(int i)
        返回通过反转指定的 int值的二进制补码表示中的字节顺序获得的值。
        参数
        i - 要颠倒其字节的值
        结果
        通过反转指定的 int字节的值获得的值。
        从以下版本开始：
        1.5

      • sum

        public static int sum​(int a,
                      int b)
        根据+运算符将两个整数相加。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        总和为 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • max

        public static int max​(int a,
                      int b)
        返回两个 int中的较大值，就像通过调用 Math.max一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较大的 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • min

        public static int min​(int a,
                      int b)
        返回两个 int中的较小值，如同通过调用 Math.min一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较小的 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InternalError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class InternalError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.VirtualMachineError
          • java.lang.InternalError
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ZipError

    public class InternalError
extends VirtualMachineError
    在Java虚拟机中引发了一些意外的内部错误。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InternalError​()
      构造一个 InternalError ，没有详细消息。
      InternalError​(String message)
      构造具有指定详细消息的 InternalError 。
      InternalError​(String message, Throwable cause)
      构造一个具有指定的详细消息和原因的 InternalError 。
      InternalError​(Throwable cause)
      构造一个 InternalError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InternalError

        public InternalError​()
        构造一个没有详细消息的 InternalError 。

      • InternalError

        public InternalError​(String message)
        构造具有指定详细消息的 InternalError 。
        参数
        message - 详细信息。

      • InternalError

        public InternalError​(String message,
                     Throwable cause)
        构造一个具有指定的详细信息和原因的InternalError 。

        请注意，与cause相关联的详细信息不会自动并入此错误的详细消息。

        参数
        message - 详细信息（由 Throwable.getMessage()方法保存供以后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.8

      • InternalError

        public InternalError​(Throwable cause)
        构造一个 InternalError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （A null允许值，并表示原因不存在或未知。）
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InterruptedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class InterruptedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.InterruptedException
  • All Implemented Interfaces:
    Serializable

    public class InterruptedException
extends 异常
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。 偶尔，一个方法可能希望测试当前线程是否已被中断，如果是，立即抛出该异常。 可以使用以下代码来实现这一效果：
      if (Thread.interrupted())  // Clears interrupted status!
      throw new InterruptedException();
    从以下版本开始：
    1.0
    另请参见：
    Object.wait() ，
Object.wait(long) ，
Object.wait(long, int) ，
Thread.sleep(long) ，
Thread.interrupt() ，
Thread.interrupted() ，
Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InterruptedException​()
      构造一个 InterruptedException ，没有详细消息。
      InterruptedException​(String s)
      构造具有指定详细消息的 InterruptedException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InterruptedException

        public InterruptedException​()
        构造一个没有详细消息的 InterruptedException 。

      • InterruptedException

        public InterruptedException​(String s)
        构造具有指定详细消息的 InterruptedException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Iterable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface Iterable<T>

  • 参数类型
    T - 迭代器返回的元素的类型
    All Known Subinterfaces:
    BeanContext ， BeanContextServices ， BlockingDeque<E> ， BlockingQueue<E> ， Collection<E> ， Deque<E> ， DirectoryStream<T> ， EventSet ， List<E> ， NavigableSet<E> ， NodeSetData<T> ， ObservableList<E> ， ObservableListValue<E> ， ObservableSet<E> ， ObservableSetValue<E> ， Path ， Queue<E> ， SecureDirectoryStream<T> ， Set<E> ， SortedSet<E> ， TransferQueue<E> ， WritableListValue<E> ， WritableSetValue<E> ， XPathNodes
    所有已知实现类：
    AbstractCollection ， AbstractList ， AbstractQueue ， AbstractSequentialList ， AbstractSet ， ArrayBlockingQueue ， ArrayDeque ， ArrayList ， AttributeList ， BatchUpdateException ， BeanContextServicesSupport ， BeanContextSupport ， ConcurrentHashMap.KeySetView ， ConcurrentLinkedDeque ， ConcurrentLinkedQueue ， ConcurrentSkipListSet ， CopyOnWriteArrayList ， CopyOnWriteArraySet ， DataTruncation ， DelayQueue ， DocTreePath ， EnumSet ， FilteredList ， HashSet ， JobStateReasons ， LinkedBlockingDeque ， LinkedBlockingQueue ， LinkedHashSet ， LinkedList ， LinkedTransferQueue ， ListBinding ， ListExpression ， ListProperty ， ListPropertyBase ， ModifiableObservableListBase ， ObservableListBase ， PriorityBlockingQueue ， PriorityQueue ， ReadOnlyListProperty ， ReadOnlyListPropertyBase ， ReadOnlyListWrapper ， ReadOnlySetProperty ， ReadOnlySetPropertyBase ， ReadOnlySetWrapper ， RoleList ， RoleUnresolvedList ， RowSetWarning ， SerialException ， ServiceLoader ， SetBinding ， SetExpression ， SetProperty ， SetPropertyBase ， SimpleListProperty ， SimpleSetProperty ， SortedList SortedList ， SQLClientInfoException ， SQLDataException ， SQLException ， SQLFeatureNotSupportedException ， SQLIntegrityConstraintViolationException ， SQLInvalidAuthorizationSpecException ， SQLNonTransientConnectionException ， SQLNonTransientException ， SQLRecoverableException ， SQLSyntaxErrorException ， SQLTimeoutException ， SQLTransactionRollbackException ， SQLTransientConnectionException ， SQLTransientException ， SQLWarning ， Stack ， SyncFactoryException ， SynchronousQueue ， SyncProviderException ， TransformationList ， TreePath ， TreeSet ， Vector

    public interface Iterable<T>
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    14.14.2增强的 for声明

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default void forEach​(Consumer<? super T> action)
      对 Iterable每个元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      Iterator<T> iterator​()
      返回类型为 T元素的迭代器。
      default Spliterator<T> spliterator​()
      在Iterable描述的元素上创建一个Iterable 。

    • 方法详细信息

      • iterator

        Iterator<T> iterator​()
        返回类型为 T元素的迭代器。
        结果
        一个迭代器

      • forEach

        default void forEach​(Consumer<? super T> action)
        对Iterable每个元素执行给定的操作，直到所有元素都被处理或者动作引发异常。 如果指定了该顺序，则按迭代的顺序执行操作。 动作抛出的异常被转发给呼叫者。

        如果操作执行修改元素的基础源的副作用，则该方法的行为是未指定的，除非重写类已指定并发修改策略。

        实现要求：

        默认实现的行为如下：

           for (T t : this) action.accept(t);
        参数
        action - 要为每个元素执行的操作
        异常
        NullPointerException - 如果指定的操作为空
        从以下版本开始：
        1.8

      • spliterator

        default Spliterator<T> spliterator​()
        在Iterable描述的元素上创建一个Iterable 。
        实现要求：
        默认实现从iterable的Iterator创建了一个early-binding拼接Iterator 。 Spliter继承了iterable的迭代器的fail-fast属性。
        Implementation Note:
        通常应该覆盖默认的实现。 由默认实现返回的分割器具有差的分割能力，未定义，并且不报告任何分割器特征。 实施课程几乎总能提供更好的实现。
        结果
        一个 Spliterator在由此描述的元件 Iterable 。
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.lang (Java SE 9 & JDK 9 )

java.lang

Interfaces

  • Appendable
  • AutoCloseable
  • CharSequence
  • Cloneable
  • Comparable
  • Iterable
  • ProcessHandle
  • ProcessHandle.Info
  • Readable
  • Runnable
  • StackWalker.StackFrame
  • System.Logger
  • Thread.UncaughtExceptionHandler

Classes

  • Boolean
  • Byte
  • Character
  • Character.Subset
  • Character.UnicodeBlock
  • Class
  • ClassLoader
  • ClassValue
  • Compiler
  • Double
  • Enum
  • Float
  • InheritableThreadLocal
  • Integer
  • Long
  • Math
  • Module
  • ModuleLayer
  • ModuleLayer.Controller
  • Number
  • Object
  • 软件包
  • Process
  • ProcessBuilder
  • ProcessBuilder.Redirect
  • Runtime
  • Runtime.Version
  • RuntimePermission
  • SecurityManager
  • Short
  • StackTraceElement
  • StackWalker
  • StrictMath
  • String
  • StringBuffer
  • StringBuilder
  • System
  • System.LoggerFinder
  • Thread
  • ThreadGroup
  • ThreadLocal
  • Throwable
  • Void

Enums

  • Character.UnicodeScript
  • ProcessBuilder.Redirect.Type
  • StackWalker.Option
  • System.Logger.Level
  • Thread.State

Exceptions

  • ArithmeticException
  • ArrayIndexOutOfBoundsException
  • ArrayStoreException
  • ClassCastException
  • ClassNotFoundException
  • CloneNotSupportedException
  • EnumConstantNotPresentException
  • 异常
  • IllegalAccessException
  • IllegalArgumentException
  • IllegalCallerException
  • IllegalMonitorStateException
  • IllegalStateException
  • IllegalThreadStateException
  • IndexOutOfBoundsException
  • InstantiationException
  • InterruptedException
  • LayerInstantiationException
  • NegativeArraySizeException
  • NoSuchFieldException
  • NoSuchMethodException
  • NullPointerException
  • NumberFormatException
  • ReflectiveOperationException
  • RuntimeException
  • SecurityException
  • StringIndexOutOfBoundsException
  • TypeNotPresentException
  • UnsupportedOperationException

Errors

  • AbstractMethodError
  • AssertionError
  • BootstrapMethodError
  • ClassCircularityError
  • ClassFormatError
  • Error
  • ExceptionInInitializerError
  • IllegalAccessError
  • IncompatibleClassChangeError
  • InstantiationError
  • InternalError
  • LinkageError
  • NoClassDefFoundError
  • NoSuchFieldError
  • NoSuchMethodError
  • OutOfMemoryError
  • StackOverflowError
  • ThreadDeath
  • UnknownError
  • UnsatisfiedLinkError
  • UnsupportedClassVersionError
  • VerifyError
  • VirtualMachineError

注解类型

  • 已过时的
  • FunctionalInterface
  • Override
  • SafeVarargs
  • SuppressWarnings


java.lang (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.lang

提供对Java编程语言设计至关重要的类。 最重要的类是Object ，它是类层次结构的根， Class ，其实例在运行时代表类。

通常需要表示原始类型的值，就像它是一个对象一样。 该包装类Boolean ， Character ， Integer ， Long ， Float ，并Double达到这个目的。 例如，类型为Double的对象包含一个类型为double的字段，表示该值可以将引用的值存储在引用类型的变量中。 这些类还提供了一些用于在原始值之间转换的方法，以及支持像equals和hashCode这样的标准方法。 Void类是一个不可实例化的类，它保存对表示类型为void的Class对象的引用。

Math提供常用的数学函数，如正弦，余弦和平方根。 该班String ， StringBuffer ，并StringBuilder同样提供字符串常用的操作。

类ClassLoader ， Process ， ProcessBuilder ， Runtime ， SecurityManager ，并System提供了管理类的动态加载，创造外部进程中，主机环境查询，如一天中的时间，以及安全策略的执行“系统操作”。

Throwable类包含throw语句可能抛出的对象。 Throwable子类表示错误和异常。

字符编码

java.nio.charset.Charset类的规范描述了字符编码的命名约定以及Java平台的每个实现必须支持的一组标准编码。
从以下版本开始：
1.0
  • 接口摘要
    接口 描述
    Appendable
    可附加 char序列和值的对象。
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    CharSequence
    A CharSequence是 char值的可读序列。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable<T>
    该接口对实现它的每个类的对象强加一个整体排序。
    Iterable<T>
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    ProcessHandle
    ProcessHandle识别并提供对本机进程的控制。
    ProcessHandle.Info
    关于流程的信息快照。
    Readable
    A Readable是一个字符的来源。
    Runnable
    Runnable接口应由实例由线程执行的任何类实现。
    StackWalker.StackFrame
    A StackFrame对象表示由StackWalker返回的方法调用。
    System.Logger
    System.Logger实例日志消息将路由到底层日志框架LoggerFinder使用。
    Thread.UncaughtExceptionHandler
    当由于未捕获的异常而导致 Thread突然终止时，处理程序的接口被调用。
  • 类摘要
    Class 描述
    Boolean
    布尔类在对象中包含基元类型 boolean的值。
    Byte
    Byte类在一个对象中包含一个基本类型 byte的值。
    Character
    Character类包装一个对象中的原始类型 char的值。
    Character.Subset
    该类的实例表示Unicode字符集的特定子集。
    Character.UnicodeBlock
    一系列字符子集，表示Unicode规范中的字符块。
    Class<T>
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassValue<T>
    将计算的值与（潜在地）每种类型相关联。
    Compiler Deprecated, for removal: This API element is subject to removal in a future version.
    JIT编译器及其技术变化太大，可以通过标准化界面有效地进行控制。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Enum<E extends Enum<E>>
    这是所有Java语言枚举类型的公共基类。
    Float
    Float类在一个对象中包装了一个原始类型 float的值。
    InheritableThreadLocal<T>
    该类扩展了 ThreadLocal以提供从父线程到子线程的值的继承：当子线程被创建时，子接收到父值具有值的所有可继承的线程局部变量的初始值。
    Integer
    Integer类包装一个对象中的基元类型 int的值。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Math
    Math类包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。
    Module
    表示运行时模块，无论是 named还是未命名。
    ModuleLayer
    Java虚拟机中的一层模块。
    ModuleLayer.Controller
    控制模块层。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    软件包
    表示与类加载器关联的运行时包的元数据。
    Process
    Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。
    ProcessBuilder
    此类用于创建操作系统进程。
    ProcessBuilder.Redirect
    表示子进程输入的源或子进程输出的目的地。
    Runtime
    每个Java应用程序都有一个 Runtime类的 Runtime ，允许应用程序与运行应用程序的环境进行接口。
    Runtime.Version
    用于实现Java SE平台的版本字符串的表示。
    RuntimePermission
    此类用于运行时权限。
    SecurityManager
    安全管理器是允许应用程序实施安全策略的类。
    Short
    Short类在一个对象中包含一个原始类型 short的值。
    StackTraceElement
    堆栈跟踪中的一个元素，如 Throwable.getStackTrace()所示 。
    StackWalker
    堆栈步行者。
    StrictMath
    类 StrictMath包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。
    String
    String类代表字符串。
    StringBuffer
    线程安全，可变的字符序列。
    StringBuilder
    一个可变的字符序列。
    System
    System类包含几个有用的类字段和方法。
    System.LoggerFinder
    LoggerFinder服务负责创建，管理和配置记录器到其使用的基础框架。
    Thread
    线程是程序中执行的线程。
    ThreadGroup
    线程组代表一组线程。
    ThreadLocal<T>
    这个类提供线程局部变量。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • 枚举摘要
    Enum 描述
    Character.UnicodeScript
    一系列字符子集，表示 Unicode Standard Annex #24: Script Names中定义的字符脚本。
    ProcessBuilder.Redirect.Type
    类型为ProcessBuilder.Redirect 。
    StackWalker.Option
    堆栈步行器选项配置stack frame获取的信息由StackWalker 。
    System.Logger.Level
    系统loggers级别。
    Thread.State
    线程状态。
  • 异常摘要
    异常 描述
    ArithmeticException
    抛出异常算术条件时抛出。
    ArrayIndexOutOfBoundsException
    抛出以表示使用非法索引访问数组。
    ArrayStoreException
    抛出以表示尝试将错误类型的对象存储到对象数组中。
    ClassCastException
    抛出表示代码尝试将对象转换为不属于实例的子类。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    EnumConstantNotPresentException
    当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IllegalCallerException
    被抛出来表示一个方法已被不适当的调用者调用。
    IllegalMonitorStateException
    抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    IllegalThreadStateException
    抛出以指示线程不处于所请求操作的适当状态。
    IndexOutOfBoundsException
    抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
    InstantiationException
    当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但是指定的类对象不能被实例化。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    LayerInstantiationException
    创建module layer时抛出失败。
    NegativeArraySizeException
    抛出一个应用程序尝试创建一个负数大小的数组。
    NoSuchFieldException
    表示该类没有指定名称的字段。
    NoSuchMethodException
    当无法找到特定方法时抛出。
    NullPointerException
    当应用程序在需要对象的情况下尝试使用 null时抛出。
    NumberFormatException
    抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
    ReflectiveOperationException
    核心反射中的反射操作抛出的异常的常见超类。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    SecurityException
    由安全管理员抛出，表示安全违规。
    StringIndexOutOfBoundsException
    抛出 String方法来指示索引为负或大于字符串的大小。
    TypeNotPresentException
    当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Error Summary
    Error 描述
    AbstractMethodError
    当应用程序尝试调用抽象方法时抛出。
    AssertionError
    抛出以表明断言失败。
    BootstrapMethodError
    抛出，表明一个invokedynamic指令未能找到它的引导方法，或引导方法未能提供call site用target正确的method type 。
    ClassCircularityError
    当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。
    ClassFormatError
    当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    ExceptionInInitializerError
    表示在静态初始化程序中发生意外异常。
    IllegalAccessError
    如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。
    IncompatibleClassChangeError
    当一些类定义发生不兼容的类更改时抛出。
    InstantiationError
    当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。
    InternalError
    在Java虚拟机中引发了一些意外的内部错误。
    LinkageError
    LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
    NoClassDefFoundError
    如果Java虚拟机或 ClassLoader实例尝试加载类的定义（作为普通方法调用的一部分或作为使用 new表达式创建新实例的 new ），则不会发现类的定义。
    NoSuchFieldError
    如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。
    NoSuchMethodError
    如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。
    OutOfMemoryError
    当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。
    StackOverflowError
    当堆栈溢出发生时抛出一个应用程序递归太深。
    ThreadDeath
    当调用（不建议使用的） Thread.stop()方法时，将在受害者线程中抛出一个 ThreadDeath的实例。
    UnknownError
    当Java虚拟机中出现未知但严重的异常时抛出。
    UnsatisfiedLinkError
    如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。
    UnsupportedClassVersionError
    当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
    VerifyError
    当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。
    VirtualMachineError
    抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。
  • 注解类型摘要
    Annotation Type 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    SafeVarargs
    程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Boolean (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Character (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Character.Subset
      • java.lang.Character.UnicodeBlock
    • java.lang.Class<T> (implements java.lang.reflect.AnnotatedElement, java.lang.reflect.GenericDeclaration, java.io.Serializable, java.lang.reflect.Type)
    • java.lang.ClassLoader
    • java.lang.ClassValue<T>
    • java.lang.Compiler
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Math
    • java.lang.Module (implements java.lang.reflect.AnnotatedElement)
    • java.lang.ModuleLayer
    • java.lang.ModuleLayer.Controller
    • java.lang.Number (implements java.io.Serializable)
      • java.lang.Byte (implements java.lang.Comparable<T>)
      • java.lang.Double (implements java.lang.Comparable<T>)
      • java.lang.Float (implements java.lang.Comparable<T>)
      • java.lang.Integer (implements java.lang.Comparable<T>)
      • java.lang.Long (implements java.lang.Comparable<T>)
      • java.lang.Short (implements java.lang.Comparable<T>)
    • java.lang.软件包 (implements java.lang.reflect.AnnotatedElement)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.lang.RuntimePermission
    • java.lang.Process
    • java.lang.ProcessBuilder
    • java.lang.ProcessBuilder.Redirect
    • java.lang.Runtime
    • java.lang.Runtime.Version (implements java.lang.Comparable<T>)
    • java.lang.SecurityManager
    • java.lang.StackTraceElement (implements java.io.Serializable)
    • java.lang.StackWalker
    • java.lang.StrictMath
    • java.lang.String (implements java.lang.CharSequence, java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.StringBuffer (implements java.lang.CharSequence, java.io.Serializable)
    • java.lang.StringBuilder (implements java.lang.CharSequence, java.io.Serializable)
    • java.lang.System
    • java.lang.System.LoggerFinder
    • java.lang.Thread (implements java.lang.Runnable)
    • java.lang.ThreadGroup (implements java.lang.Thread.UncaughtExceptionHandler)
    • java.lang.ThreadLocal<T>
      • java.lang.InheritableThreadLocal<T>
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.AssertionError
        • java.lang.LinkageError
          • java.lang.BootstrapMethodError
          • java.lang.ClassCircularityError
          • java.lang.ClassFormatError
            • java.lang.UnsupportedClassVersionError
          • java.lang.ExceptionInInitializerError
          • java.lang.IncompatibleClassChangeError
            • java.lang.AbstractMethodError
            • java.lang.IllegalAccessError
            • java.lang.InstantiationError
            • java.lang.NoSuchFieldError
            • java.lang.NoSuchMethodError
          • java.lang.NoClassDefFoundError
          • java.lang.UnsatisfiedLinkError
          • java.lang.VerifyError
        • java.lang.ThreadDeath
        • java.lang.VirtualMachineError
          • java.lang.InternalError
          • java.lang.OutOfMemoryError
          • java.lang.StackOverflowError
          • java.lang.UnknownError
      • java.lang.异常
        • java.lang.CloneNotSupportedException
        • java.lang.InterruptedException
        • java.lang.ReflectiveOperationException
          • java.lang.ClassNotFoundException
          • java.lang.IllegalAccessException
          • java.lang.InstantiationException
          • java.lang.NoSuchFieldException
          • java.lang.NoSuchMethodException
        • java.lang.RuntimeException
          • java.lang.ArithmeticException
          • java.lang.ArrayStoreException
          • java.lang.ClassCastException
          • java.lang.EnumConstantNotPresentException
          • java.lang.IllegalArgumentException
            • java.lang.IllegalThreadStateException
            • java.lang.NumberFormatException
          • java.lang.IllegalCallerException
          • java.lang.IllegalMonitorStateException
          • java.lang.IllegalStateException
          • java.lang.IndexOutOfBoundsException
            • java.lang.ArrayIndexOutOfBoundsException
            • java.lang.StringIndexOutOfBoundsException
          • java.lang.LayerInstantiationException
          • java.lang.NegativeArraySizeException
          • java.lang.NullPointerException
          • java.lang.SecurityException
          • java.lang.TypeNotPresentException
          • java.lang.UnsupportedOperationException
    • java.lang.Void

Interface Hierarchy

  • java.lang.Appendable
  • java.lang.AutoCloseable
  • java.lang.CharSequence
  • java.lang.Cloneable
  • java.lang.Comparable<T>
    • java.lang.ProcessHandle
  • java.lang.Iterable<T>
  • java.lang.ProcessHandle.Info
  • java.lang.Readable
  • java.lang.Runnable
  • java.lang.StackWalker.StackFrame
  • java.lang.System.Logger
  • java.lang.Thread.UncaughtExceptionHandler

Annotation Type Hierarchy

  • java.lang.已过时的 (implements java.lang.annotation.Annotation)
  • java.lang.FunctionalInterface (implements java.lang.annotation.Annotation)
  • java.lang.Override (implements java.lang.annotation.Annotation)
  • java.lang.SafeVarargs (implements java.lang.annotation.Annotation)
  • java.lang.SuppressWarnings (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.Character.UnicodeScript
      • java.lang.ProcessBuilder.Redirect.Type
      • java.lang.StackWalker.Option
      • java.lang.System.Logger.Level
      • java.lang.Thread.State
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


LayerInstantiationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class LayerInstantiationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.LayerInstantiationException
  • All Implemented Interfaces:
    Serializable

    public class LayerInstantiationException
extends RuntimeException
    创建module layer时抛出失败。
    从以下版本开始：
    9
    另请参见：
    ModuleLayer ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LayerInstantiationException​()
      构造一个 LayerInstantiationException ，没有详细信息。
      LayerInstantiationException​(String msg)
      构造具有给定详细信息的 LayerInstantiationException 。
      LayerInstantiationException​(String msg, Throwable cause)
      构造一个 LayerInstantiationException与给定的详细信息和原因。
      LayerInstantiationException​(Throwable cause)
      构造一个 LayerInstantiationException与给定的原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • LayerInstantiationException

        public LayerInstantiationException​()
        构造一个 LayerInstantiationException ，没有详细信息。

      • LayerInstantiationException

        public LayerInstantiationException​(String msg)
        构造具有给定详细信息的 LayerInstantiationException 。
        参数
        msg - 详细信息; 可以是null

      • LayerInstantiationException

        public LayerInstantiationException​(Throwable cause)
        构造一个 LayerInstantiationException与给定的原因。
        参数
        cause - 原因; 可以是null

      • LayerInstantiationException

        public LayerInstantiationException​(String msg,
                                   Throwable cause)
        构造一个 LayerInstantiationException与给定的详细信息和原因。
        参数
        msg - 详细信息; 可以是null
        cause - 原因; 可以是null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LinkageError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class LinkageError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    BootstrapMethodError ， ClassCircularityError ， ClassFormatError ， ExceptionInInitializerError ， IncompatibleClassChangeError ， NoClassDefFoundError ， UnsatisfiedLinkError ， VerifyError

    public class LinkageError
extends Error
    LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LinkageError​()
      构造一个 LinkageError ，没有详细信息。
      LinkageError​(String s)
      构造具有指定详细消息的 LinkageError 。
      LinkageError​(String s, Throwable cause)
      构造一个具有指定的详细信息和原因的 LinkageError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • LinkageError

        public LinkageError​()
        构造一个没有详细消息的 LinkageError 。

      • LinkageError

        public LinkageError​(String s)
        构造具有指定详细消息的 LinkageError 。
        参数
        s - 详细信息。

      • LinkageError

        public LinkageError​(String s,
                    Throwable cause)
        构造一个具有指定的详细信息和原因的 LinkageError 。
        参数
        s - 详细信息。
        cause - 原因，可能是 null
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Long (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Long

  • java.lang.Object
    • java.lang.Number
      • java.lang.Long
  • All Implemented Interfaces:
    Serializable ， Comparable<Long>

    public final class Long
extends Number
implements Comparable<Long>
    Long类包装一个对象中的原始类型long的值。 类型为Long的对象包含一个单一字段，其类型为long 。

    此外，该类还提供了一些将long转换为String和String转换为long ，以及在处理long时有用的其他常数和方法。

    实施说明：“bit twiddling”方法（例如highestOneBit和numberOfTrailingZeros ）的实现基于Henry S. Warren，Jr.的Hacker's Delight （Addison Wesley，2002）的材料。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BYTES
      用于表示二进制补码二进制形式的 long值的字节数。
      static long MAX_VALUE
      一个持有最大值的常数a long可以有2 63 -1。
      static long MIN_VALUE
      的常量保持的最小值的 long可以具有-2 63。
      static int SIZE
      用于表示二进制补码二进制形式的 long值的位数。
      static Class<Long> TYPE
      所述 Class实例表示基本类型 long 。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Long​(long value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(long)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Long​(String s)
      已过时。
      很少使用这个构造函数。 使用parseLong(String)将字符串转换为long原语，或使用valueOf(String)将字符串转换为Long对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static int bitCount​(long i)
      返回指定的 long值的二进制补码二进制表示中的 long 。
      byte byteValue​()
      在缩小原始转换后，返回 Long的值作为 byte 。
      static int compare​(long x, long y)
      数值比较两个 long 。
      int compareTo​(Long anotherLong)
      数值比较两个 Long对象。
      static int compareUnsigned​(long x, long y)
      比较两个 long值，以数值方式将值视为无符号。
      static Long decode​(String nm)
      将 String解码成 Long 。
      static long divideUnsigned​(long dividend, long divisor)
      返回将第一个参数除以秒的无符号商，其中每个参数和结果被解释为无符号值。
      double doubleValue​()
      返回此值 Long为 double一个宽元转换后。
      boolean equals​(Object obj)
      将此对象与指定的对象进行比较。
      float floatValue​()
      返回此值 Long为 float一个宽元转换后。
      static Long getLong​(String nm)
      确定具有指定名称的系统属性的值为 long 。
      static Long getLong​(String nm, long val)
      确定具有指定名称的系统属性的值为 long 。
      static Long getLong​(String nm, Long val)
      返回具有指定名称的系统属性的值为 long 。
      int hashCode​()
      返回此 Long的哈希码。
      static int hashCode​(long value)
      返回一个long值的哈希码; 兼容Long.hashCode() 。
      static long highestOneBit​(long i)
      在指定的 long值中，最高位（最左边）为1位，最多返回一个 long值，最多只有一个1位。
      int intValue​()
      在缩小的原始转换后，返回 Long的值作为 int 。
      long longValue​()
      返回此值 Long为 long值。
      static long lowestOneBit​(long i)
      在指定的 long值中以最低位（最右边）为1位返回一个 long值，最多只有一个1位。
      static long max​(long a, long b)
      返回两个 long中的较大值，就像调用 Math.max一样 。
      static long min​(long a, long b)
      返回两个 long中的较小值，就像调用 Math.min一样 。
      static int numberOfLeadingZeros​(long i)
      返回指定的 long值的二进制补码二进制表示中最高位（“最左”）1位之前的零位数。
      static int numberOfTrailingZeros​(long i)
      返回在指定的 long值的二进制补码二进制表示中的最低位（“最右”）1位之后的零位数。
      static long parseLong​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数作为有符号long指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
      static long parseLong​(String s)
      将字符串参数解析为有符号的二进制 long 。
      static long parseLong​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的带符号的 long 。
      static long parseUnsignedLong​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数为一个无符号long在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
      static long parseUnsignedLong​(String s)
      将字符串参数解析为无符号小数 long 。
      static long parseUnsignedLong​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的无符号 long 。
      static long remainderUnsigned​(long dividend, long divisor)
      返回无符号余数，将第一个参数除以秒，其中每个参数和结果被解释为无符号值。
      static long reverse​(long i)
      返回通过反转指定的 long值的二进制补码二进制表示中的位的顺序获得的值。
      static long reverseBytes​(long i)
      返回通过反转指定的 long值的二进制补码表示中的字节顺序获得的值。
      static long rotateLeft​(long i, int distance)
      返回通过将指定的 long值的二进制补码二进制表示旋转指定 long值。
      static long rotateRight​(long i, int distance)
      返回通过将指定的 long值的二进制补码二进制表示旋转指定 long值。
      short shortValue​()
      在缩小原始转换后，返回 Long的值作为 short 。
      static int signum​(long i)
      返回指定的 long值的signum函数。
      static long sum​(long a, long b)
      根据+操作符将两个 long值添加 long一起。
      static String toBinaryString​(long i)
      返回 long参数的字符串表示形式为基数2中的无符号整数。
      static String toHexString​(long i)
      返回 long参数的字符串表示形式，作为16位中的无符号整数。
      static String toOctalString​(long i)
      在基数8中返回 long参数的字符串表示形式为无符号整数。
      String toString​()
      返回一个表示 Long的值的 String对象。
      static String toString​(long i)
      返回 String表示指定对象 long 。
      static String toString​(long i, int radix)
      返回由第二个参数指定的基数中的第一个参数的字符串表示形式。
      static String toUnsignedString​(long i)
      将参数的字符串表示形式返回为无符号十进制值。
      static String toUnsignedString​(long i, int radix)
      以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。
      static Long valueOf​(long l)
      返回表示指定的 long值的 Long实例。
      static Long valueOf​(String s)
      返回一个保存指定值的 Long对象 String 。
      static Long valueOf​(String s, int radix)
      返回一个 Long对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN_VALUE

        @Native
public static final long MIN_VALUE
        的常量保持的最小值的 long可以具有-2 63。
        另请参见：
        Constant Field Values

      • MAX_VALUE

        @Native
public static final long MAX_VALUE
        一个持有最大值a的常数a long可以有2 63 -1。
        另请参见：
        Constant Field Values

      • TYPE

        public static final Class<Long> TYPE
        所述 Class实例表示基本类型 long 。
        从以下版本开始：
        1.1

      • SIZE

        @Native
public static final int SIZE
        用于表示二进制补码二进制形式的 long值的位数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • BYTES

        public static final int BYTES
        用于表示二进制补码二进制形式的 long值的字节数。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Long

        @Deprecated(since="9")
public Long​(long value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(long)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
        构造一个新分配的 Long对象，该对象表示指定的 long参数。
        参数
        value - 要由 Long对象表示的值。

      • Long

        @Deprecated(since="9")
public Long​(String s)
     throws NumberFormatException
        已过时。 很少使用这个构造函数。 使用parseLong(String)将字符串转换为long原语，或使用valueOf(String)将字符串转换为Long对象。
        构造一个新分配的Long对象，表示由String参数指示的long值。 字符串转换为long值，正好与基数为parseLong方法一样。
        参数
        s -的 String转换为一个 Long 。
        异常
        NumberFormatException - 如果 String不包含可解析的 long 。

    • 方法详细信息

      • toString

        public static String toString​(long i,
                              int radix)
        返回由第二个参数指定的基数中的第一个参数的字符串表示形式。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则使用基数10 。

        如果第一个参数为负，则结果的第一个元素为ASCII减号'-' （ '\u002d' ）。 如果第一个参数不为负，则结果中不会出现符号字符。

        结果的剩余字符表示第一个参数的大小。 如果幅度为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，幅度的表示的第一个字符将不是零字符。 以下ASCII字符用作数字：

        0123456789abcdefghijklmnopqrstuvwxyz
        这些是'\u0030'至'\u0039'和'\u0061'至'\u007a' 。 如果radix是N ，则这些字符的前N个按照所示顺序用作小数N位。 因此，十六进制（ 0123456789abcdef 16）的数字是0123456789abcdef 。 如果需要大写字母，可以对结果调用String.toUpperCase()方法：
        Long.toString(n, 16).toUpperCase()
        参数
        i - 要转换为字符串的 long 。
        radix - 在字符串表示中使用的基数。
        结果
        指定基数中的参数的字符串表示形式。
        另请参见：
        Character.MAX_RADIX ， Character.MIN_RADIX

      • toUnsignedString

        public static String toUnsignedString​(long i,
                                      int radix)
        以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。

        如果基数小于Character.MIN_RADIX或大于Character.MAX_RADIX ，则使用基数10 。

        请注意，由于第一个参数被视为无符号值，因此不会打印前导符号。

        如果幅度为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，幅度的表示的第一个字符将不是零字符。

        基数的行为和用作数字的字符与toString相同。

        参数
        i - 要转换为无符号字符串的整数。
        radix - 在字符串表示中使用的基数。
        结果
        指定基数中的参数的无符号字符串表示形式。
        从以下版本开始：
        1.8
        另请参见：
        toString(long, int)

      • toHexString

        public static String toHexString​(long i)
        返回long参数的字符串表示形式，作为基数16中的无符号整数。

        无符号的long值是参数加上2 64，如果参数为负数; 否则，它等于论证。 该值转换为十六进制（基数16）的ASCII数字字符串，无额外引导0 s。

        可以通过调用Long.parseUnsignedLong(s, 16)从返回的字符串s恢复参数的值。

        如果无符号大小为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，无符号大小的表示的第一个字符将不是零字符。 以下字符用作十六进制数字：

        0123456789abcdef
        这些是'\u0030'至'\u0039'和'\u0061'至'\u0066' 。 如果需要大写字母，可以对结果调用String.toUpperCase()方法：
        Long.toHexString(n).toUpperCase()
        参数
        i - 一个 long要转换成一个字符串。
        结果
        由十六进制参数（基数16）表示的无符号 long值的字符串表示。
        从以下版本开始：
        1.0.2
        另请参见：
        parseUnsignedLong(String, int) ， toUnsignedString(long, int)

      • toOctalString

        public static String toOctalString​(long i)
        在基数8中返回long参数的字符串表示形式为无符号整数。

        无符号的long值是参数加上2 64，如果参数为负数; 否则，它等于论证。 该值转换为八进制（基数8）中的ASCII数字字符串，没有额外的前导0 s。

        可以通过调用Long.parseUnsignedLong(s, 8)从返回的字符串s恢复参数的值。

        如果无符号幅度为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，无符号大小的表示的第一个字符将不是零字符。 以下字符用作八进制数字：

        01234567
        这些是'\u0030'至'\u0037' 。
        参数
        i - 一个 long要转换成一个字符串。
        结果
        由参数以八进制表示的无符号 long值的字符串表示（基数8）。
        从以下版本开始：
        1.0.2
        另请参见：
        parseUnsignedLong(String, int) ， toUnsignedString(long, int)

      • toBinaryString

        public static String toBinaryString​(long i)
        返回long参数的字符串表示形式为基数2中的无符号整数。

        无符号的long值是参数加上2 64，如果参数为负数; 否则，它等于论证。 该值转换为二进制（基数2）的ASCII数字字符串，没有额外的前导0 s。

        可以通过调用Long.parseUnsignedLong(s, 2)从返回的字符串s恢复参数的值。

        如果无符号大小为零，则由单个零字符'0' （ '\u0030' ）表示; 否则，无符号大小的表示的第一个字符将不是零字符。 字符'0' （ '\u0030' ）和'1' （ '\u0031' ）用作二进制数字。

        参数
        i - 一个 long要转换为字符串。
        结果
        由二进制（基数2）中的参数表示的无符号 long值的字符串表示。
        从以下版本开始：
        1.0.2
        另请参见：
        parseUnsignedLong(String, int) ， toUnsignedString(long, int)

      • toString

        public static String toString​(long i)
        返回String表示指定对象long 。 参数被转换为带符号的十进制表示形式，并作为字符串返回，就好像参数和基数10作为toString(long, int)方法的参数。
        参数
        i - a long待转换。
        结果
        基数10中的参数的字符串表示形式。

      • toUnsignedString

        public static String toUnsignedString​(long i)
        将参数的字符串表示形式返回为无符号十进制值。 参数转换为无符号十进制表示形式，并作为字符串返回，正如参数和小数10作为toUnsignedString(long, int)方法的参数一样 。
        参数
        i - 要转换为无符号字符串的整数。
        结果
        参数的无符号字符串表示形式。
        从以下版本开始：
        1.8
        另请参见：
        toUnsignedString(long, int)

      • parseLong

        public static long parseLong​(String s,
                             int radix)
                      throws NumberFormatException
        在第二个参数指定的基数中将字符串参数解析为带符号的long 。 字符串中的字符必须全部是指定基数的数字（由Character.digit(char, int)是否返回非负值确定），除了第一个字符可能是ASCII减号'-' （ '\u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）以表示正值。 返回产生的long值。

        请注意，字符L （ '\u004C' ）和L （ '\u004C' ）以及l （ '\u006C' ）均不允许出现在字符串的末尾作为类型指示符，如Java编程语言源代码中允许的那样，除了L或l可能显示为数字为大于或等于22的基数。

        如果发生以下任何一种情况，则抛出类型为NumberFormatException的异常：

        • 第一个参数是null或是长度为零的字符串。
        • radix或小于Character.MIN_RADIX或大于Character.MAX_RADIX 。
        • 字符串的任何字符不是指定基数的数字，除了第一个字符可能是负号'-' （ '\u002d' ）或加号'+' （ '\u002B' ），前提是字符串长于长度1。
        • 由字符串表示的值不是long类型的值。

        例子：

         parseLong("0", 10) returns 0L
 parseLong("473", 10) returns 473L
 parseLong("+42", 10) returns 42L
 parseLong("-0", 10) returns 0L
 parseLong("-FF", 16) returns -255L
 parseLong("1100110", 2) returns 102L
 parseLong("99", 8) throws a NumberFormatException
 parseLong("Hazelnut", 10) throws a NumberFormatException
 parseLong("Hazelnut", 36) returns 1356099454469L
        参数
        s -所述 String含有 long表示来进行解析。
        radix - 解析时使用的基数 s 。
        结果
        由指定基数中的字符串参数表示的 long 。
        异常
        NumberFormatException - 如果字符串不包含可解析的 long 。

      • parseLong

        public static long parseLong​(CharSequence s,
                             int beginIndex,
                             int endIndex,
                             int radix)
                      throws NumberFormatException
        解析CharSequence参数作为有符号long指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。

        该方法在解析时不采取措施来防范CharSequence被突变。

        参数
        s -所述 CharSequence含有 long表示被解析
        beginIndex - 包含起始索引。
        endIndex - 结束索引，独占。
        radix - 解析时使用的基数 s 。
        结果
        由指定基数的子 long表示的带符号的 long 。
        异常
        NullPointerException - 如果 s为空。
        IndexOutOfBoundsException - 如果 beginIndex为负数，或者如果 beginIndex大于 endIndex或者如果 endIndex大于 s.length() 。
        NumberFormatException - 如果 int在指定的 CharSequence中不包含可解析的 radix ，或者如果 radix小于 Character.MIN_RADIX或大于 Character.MAX_RADIX 。
        从以下版本开始：
        9

      • parseLong

        public static long parseLong​(String s)
                      throws NumberFormatException
        解析字符串参数作为带符号的二进制long 。 字符串中的字符必须都是十进制数字，除了第一个字符可能是ASCII减号'-' （ \u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）表示正值。 返回的结果为long ，就像参数和基数10作为parseLong(java.lang.String, int)方法的参数一样 。

        注意字符L （ '\u004C' ）和L （ '\u004C' ）以及l （ '\u006C' ）都不允许作为类型指示符出现在字符串的末尾，如在Java编程语言源代码中允许的那样。

        参数
        s - a String包含要解析的 long表示
        结果
        long由参数以十进制表示。
        异常
        NumberFormatException - 如果字符串不包含可解析的 long 。

      • parseUnsignedLong

        public static long parseUnsignedLong​(String s,
                                     int radix)
                              throws NumberFormatException
        在第二个参数指定的基数中将字符串参数解析为无符号的long 。 无符号整数将通常与负数相关联的值映射到大于MAX_VALUE正数。 字符串中的字符必须全部是指定基数的数字（由Character.digit(char, int)是否返回非负值确定），但第一个字符可能是ASCII加号'+' （ '\u002B' ）。 返回所得到的整数值。

        如果发生以下任何一种情况，则抛出类型为NumberFormatException的异常：

        • 第一个参数是null或是长度为零的字符串。
        • 基数小于Character.MIN_RADIX或大于Character.MAX_RADIX 。
        • 字符串的任何字符不是指定基数的数字，除了第一个字符可能是加号'+' （ '\u002B' ），条件是字符串长于长度1。
        • 由字符串表示的值大于最大无符号long 64 -1。
        参数
        s - 包含要解析的无符号整数表示的 String
        radix - 解析时使用的基数 s 。
        结果
        未 long由指定基数中的字符串参数表示。
        异常
        NumberFormatException - 如果 String不包含可解析的 long 。
        从以下版本开始：
        1.8

      • parseUnsignedLong

        public static long parseUnsignedLong​(CharSequence s,
                                     int beginIndex,
                                     int endIndex,
                                     int radix)
                              throws NumberFormatException
        解析CharSequence参数为一个无符号long在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。

        该方法没有采取措施来防止CharSequence在解析时被突变。

        参数
        s -所述 CharSequence含有无符号 long表示被解析
        beginIndex - 包含起始索引。
        endIndex - 结束索引，独家。
        radix - 解析时使用的基数 s 。
        结果
        无符号的 long由指定基数的子 long表示。
        异常
        NullPointerException - 如果 s为空。
        IndexOutOfBoundsException - 如果 beginIndex为负数，或者如果 beginIndex大于 endIndex或者如果 endIndex大于 s.length() 。
        NumberFormatException - 如果 long在指定的 CharSequence中不包含可解析的无符号 radix ，或者如果 radix小于 Character.MIN_RADIX或大于 Character.MAX_RADIX 。
        从以下版本开始：
        9

      • parseUnsignedLong

        public static long parseUnsignedLong​(String s)
                              throws NumberFormatException
        将字符串参数解析为无符号小数long 。 字符串中的字符必须都是十进制数字，除了第一个字符可能是ASCII加号'+' （ '\u002B' ）。 返回所得到的整数值，就像参数和小数 10被赋予parseUnsignedLong(java.lang.String, int)方法的参数一样 。
        参数
        s - a String其中包含要解析的无符号 long表示
        结果
        无符号的 long值由十进制字符串参数表示
        异常
        NumberFormatException - 如果字符串不包含可分析的无符号整数。
        从以下版本开始：
        1.8

      • valueOf

        public static Long valueOf​(String s,
                           int radix)
                    throws NumberFormatException
        当使用第二个参数给出的基数进行解析时，返回一个保存从指定的String提取的值的Long对象。 第一个参数被解释为表示由第二个参数指定的基数中的带符号的long ，就像向parseLong(java.lang.String, int)方法给出的参数一样 。 结果是一个Long对象，表示由字符串指定的long值。

        换句话说，该方法返回一个Long对象等于的值：

        new Long(Long.parseLong(s, radix))
        参数
        s - 要解析的字符串
        radix - 用于解释的基数 s
        结果
        一个 Long对象，其持有由指定基数中的字符串参数表示的值。
        异常
        NumberFormatException - 如果 String不包含可解析的 long 。

      • valueOf

        public static Long valueOf​(String s)
                    throws NumberFormatException
        返回一个持有指定值的Long对象String 。 该参数被解释为表示一个有符号的二进制long ，完全相同于parseLong(java.lang.String)方法的参数。 结果是一个表示由字符串指定的整数值的Long对象。

        换句话说，此方法返回一个Long对象的值等于：

        new Long(Long.parseLong(s))
        参数
        s - 要解析的字符串。
        结果
        一个 Long对象保存由string参数表示的值。
        异常
        NumberFormatException - 如果字符串不能被解析为 long 。

      • valueOf

        public static Long valueOf​(long l)
        返回表示指定的long值的Long实例。 如果不需要新的Long实例，则该方法通常应优先于构造函数Long(long)使用 ，因为该方法可能通过缓存经常请求的值而产生明显更好的空间和时间性能。 请注意，与corresponding method在Integer类，这种方法不需要缓存值的特定范围内。
        参数
        l - 一个长的值。
        结果
        一个 Long实例，代表 l 。
        从以下版本开始：
        1.5

      • decode

        public static Long decode​(String nm)
                   throws NumberFormatException
        将String解码成Long 。 接受以下语法给出的十进制，十六进制和八进制数：
        DecodableString:
        Signopt DecimalNumeral
        Signopt 0x HexDigits
        Signopt 0X HexDigits
        Signopt # HexDigits
        Signopt 0 OctalDigits
        Sign:
        -
        +
        DecimalNumeral，HexDigits，和OctalDigits如在The Java™ Language Specification 3.10.1部分所定义，所不同的是下划线不数字之间接受。

        可选符号和/或基数说明符（“ 0x ”，“ 0X ”，“ # ”或前导零）之后的Long.parseLong由具有指示的基数（10,16或8）的Long.parseLong方法进行解析。 这个字符序列必须表示正值，或者将抛出一个NumberFormatException 。 如果指定的String第一个字符为负号，则结果为否定。 在String中不允许使用空格字符。

        参数
        nm - 要解码的 String 。
        结果
        一个 Long对象持有 long值由 nm
        异常
        NumberFormatException - 如果 String不包含可解析的 long 。
        从以下版本开始：
        1.2
        另请参见：
        parseLong(String, int)

      • byteValue

        public byte byteValue​()
        在缩小原始转换后，返回 Long的值作为 byte 。
        重写：
        byteValue在 Number
        结果
        该对象在转换为 byte之后表示的数值。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • shortValue

        public short shortValue​()
        返回此值 Long为 short的基本收缩转换后。
        重写：
        shortValue在 Number
        结果
        该对象在转换为 short之后表示的数值。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • intValue

        public int intValue​()
        在缩小原始转换后，返回 Long的值作为 int 。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • longValue

        public long longValue​()
        返回此值 Long为 long值。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long之后表示的数值。

      • floatValue

        public float floatValue​()
        返回此值 Long为 float一个宽元转换后。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • doubleValue

        public double doubleValue​()
        返回此值 Long为 double一个宽元转换后。
        Specified by:
        doubleValue在 Number
        结果
        该对象在转换为 double之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • toString

        public String toString​()
        返回一个表示Long的值的String对象。 该值将转换为带符号的十进制表示形式，并作为字符串返回，就像long值作为toString(long)方法的参数一样 。
        重写：
        toString在 Object
        结果
        这个对象在基数10中的值的字符串表示。

      • hashCode

        public int hashCode​()
        返回此Long的哈希码。 结果是这个Long对象持有的原始值long的两半的异或。 也就是说，hashcode是表达式的值：
        (int)(this.longValue()^(this.longValue()>>>32))
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(long value)
        返回一个long值的哈希码; 兼容Long.hashCode() 。
        参数
        value - 哈希值
        结果
        一个 long值的哈希码值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        将此对象与指定的对象进行比较。 如果且仅当参数不是null并且是包含与此对象相同的long值的Long对象时，结果为true 。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • getLong

        public static Long getLong​(String nm)
        确定具有指定名称的系统属性的值为long 。

        第一个参数被视为系统属性的名称。 系统属性可通过System.getProperty(java.lang.String)方法访问。 然后，使用long支持的语法将该属性的字符串值解释为long，并返回表示此值的Long对象。

        如果没有指定名称的属性，如果指定的名称为空或null ，或者该属性没有正确的数字格式，则返回null 。

        换句话说，该方法返回一个Long对象的值等于：

        getLong(nm, null)
        参数
        nm - 属性名称。
        结果
        该 Long价值 Long 。
        异常
        SecurityException - 原因与 System.getProperty相同
        另请参见：
        System.getProperty(java.lang.String) ， System.getProperty(java.lang.String, java.lang.String)

      • getLong

        public static Long getLong​(String nm,
                           long val)
        确定具有指定名称的系统属性的值为long 。

        第一个参数被视为系统属性的名称。 系统属性可通过System.getProperty(java.lang.String)方法访问。 然后，使用long支持的语法将该属性的字符串值解释为long，并返回表示此值的Long对象。

        第二个参数是默认值。 如果没有指定名称的属性，如果该属性没有正确的数字格式，或者指定的名称为空或为空，则返回表示第二个参数的值的Long对象。

        换句话说，该方法返回一个Long对象的值等于：

        getLong(nm, new Long(val))
        但实际上可以以下列方式实现：
         Long result = getLong(nm, null);
 return (result == null) ? new Long(val) : result;
        以避免在不需要默认值时不必要地分配Long对象。
        参数
        nm - 属性名称。
        val - 默认值。
        结果
        该 Long价值为 Long 。
        异常
        SecurityException - 原因与 System.getProperty相同
        另请参见：
        System.getProperty(java.lang.String) ， System.getProperty(java.lang.String, java.lang.String)

      • getLong

        public static Long getLong​(String nm,
                           Long val)
        返回具有指定名称的系统属性的值为long 。 第一个参数被视为系统属性的名称。 系统属性可通过System.getProperty(java.lang.String)方法访问。 然后将该属性的字符串值解释为long值，按照decode方法，并返回表示此值的Long对象; 综上所述：
        • 如果属性值以两个ASCII字符0x或ASCII字符# ，而不是后跟减号，则其余部分将被解析为与基数16的方法valueOf(java.lang.String, int)完全一致的十六进制整数。
        • 如果属性值以ASCII字符0后跟另一个字符开头，则将其解析为与基数8的方法valueOf(java.lang.String, int)完全一致的八进制整数。
        • 否则，属性值将被解析为十进制整数，与使用基数10的方法valueOf(java.lang.String, int)完全相同。

        注意，在每种情况下， L （ '\u004C' ）和l （ '\u006C' ）作为类型指示符出现在属性值的末尾，如Java编程语言源代码中允许的那样。

        第二个参数是默认值。 如果没有指定名称的属性，如果该属性没有正确的数字格式，或者指定的名称为空，则返回默认值，或者是null 。

        参数
        nm - 属性名称。
        val - 默认值。
        结果
        该 Long价值 Long 。
        异常
        SecurityException - 原因与 System.getProperty相同
        另请参见：
        System.getProperty(java.lang.String) ， System.getProperty(java.lang.String, java.lang.String)

      • compareTo

        public int compareTo​(Long anotherLong)
        以数字方式比较两个 Long对象。
        Specified by:
        compareTo在接口 Comparable<Long>
        参数
        anotherLong - 要比较的 Long 。
        结果
        值0如果这个Long等于参数Long ; 的值小于0 ，如果这Long在数值上小于该参数Long ; 和大于一个值0 ，如果这Long在数值上大于该参数Long （带符号的比较）。
        从以下版本开始：
        1.2

      • compare

        public static int compare​(long x,
                          long y)
        数值比较两个long 。 返回的值与以下内容相同：
          Long.valueOf(x).compareTo(Long.valueOf(y))
        参数
        x - 第一个 long进行比较
        y - 第二个 long进行比较
        结果
        值0如果是x == y ; 一个值小于0如果是x < y ; 和值大于0如果x > y
        从以下版本开始：
        1.7

      • compareUnsigned

        public static int compareUnsigned​(long x,
                                  long y)
        比较两个 long值，以数值方式将值视为无符号。
        参数
        x - 第一个 long进行比较
        y - 第二个 long进行比较
        结果
        值0如果是x == y ; 一个值小于0如果x < y为无符号值; 并且如果x > y为无符号值，则值大于0
        从以下版本开始：
        1.8

      • divideUnsigned

        public static long divideUnsigned​(long dividend,
                                  long divisor)
        返回将第一个参数除以秒的无符号商，其中每个参数和结果被解释为无符号值。

        注意，在二进制补码算术中，如果两个操作数被认为是被签名的或者两个都是无符号的，则加法，减法和乘法的三个其他基本算术运算是逐位相同的。 因此不提供addUnsigned等方法。

        参数
        dividend - 要划分的值
        divisor - 做分割的值
        结果
        第一个参数的无符号商除以第二个参数
        从以下版本开始：
        1.8
        另请参见：
        remainderUnsigned(long, long)

      • remainderUnsigned

        public static long remainderUnsigned​(long dividend,
                                     long divisor)
        返回无符号余数，将第一个参数除以秒，其中每个参数和结果被解释为无符号值。
        参数
        dividend - 要划分的值
        divisor - 做分割的价值
        结果
        第一个参数的无符号余数除以第二个参数
        从以下版本开始：
        1.8
        另请参见：
        divideUnsigned(long, long)

      • highestOneBit

        public static long highestOneBit​(long i)
        返回一个long值至多一个单个1位，在最高阶（“最左侧”）的位置在指定的一比特long值。 如果指定的值在其二进制补码二进制表示中没有1位，也就是说，如果它等于零，则返回零。
        参数
        i - 要计算其最高一位的值
        结果
        具有单个1位的 long值，在指定值中的最高位1位的位置，如果指定的值本身等于零，则为零。
        从以下版本开始：
        1.5

      • lowestOneBit

        public static long lowestOneBit​(long i)
        在指定的long值中以最低位（最右）的位置返回long值，最多只有一个1位。 如果指定的值在其二进制补码二进制表示中没有1位，也就是说，如果它等于零，则返回零。
        参数
        i - 要计算最低一位的值
        结果
        具有单个1位的 long值，在指定值中的最低位1位的位置，如果指定的值本身等于零，则为零。
        从以下版本开始：
        1.5

      • numberOfLeadingZeros

        public static int numberOfLeadingZeros​(long i)
        返回指定的long值的二进制补码二进制表示中最高位（“最左”）1位之前的零位数。 如果指定的值在其二进制补码表示中没有一位，换句话说如果它等于零则返回64。

        请注意，该方法与对数基数2密切相关。对于所有正值long值x：

        • floor（log 2 （x））= 63 - numberOfLeadingZeros(x)
        • ceil（log 2 （x））= 64 - numberOfLeadingZeros(x - 1)
        参数
        i - 要计算前导零数的值
        结果
        在指定的 long值的二进制补码二进制表示中的最高位（“最左”）1位之前的零位数，如果该值等于零，则为64。
        从以下版本开始：
        1.5

      • numberOfTrailingZeros

        public static int numberOfTrailingZeros​(long i)
        返回在指定的long值的二进制补码二进制表示中的最低位（“最右”）1位之后的零位数。 如果指定的值在其二进制补码表示中没有一位，换句话说如果它等于零则返回64。
        参数
        i - 要计算尾数零的值
        结果
        在指定的 long值的二进制补码二进制表示中的最低位（“最右”）1位后的零位数，如果该值等于零，则为64位。
        从以下版本开始：
        1.5

      • bitCount

        public static int bitCount​(long i)
        返回指定的long值的二进制补码二进制表示中的long 。 此功能有时称为人口数量 。
        参数
        i - 要对其位进行计数的值
        结果
        二进制数的二进制补码二进制表示为指定的 long值。
        从以下版本开始：
        1.5

      • rotateLeft

        public static long rotateLeft​(long i,
                              int distance)
        返回通过将指定的long值的二进制补码二进制表示旋转指定的long值。 （左侧移位的位或右侧的高位侧重新输入，或低位）。

        请注意，具有负距离的左旋转相当于右旋： rotateLeft(val, -distance) == rotateRight(val, distance) 。 由64多个任何还需要注意的是旋转是一个空操作，所以所有，但旋转距离的后6位可以忽略，即使距离为负： rotateLeft(val, distance) == rotateLeft(val, distance & 0x3F) 。

        参数
        i - 其位要向左旋转的值
        distance - 向左旋转的位位数
        结果
        通过将指定的 long值的二进制补码二进制表示旋转指定的 long值。
        从以下版本开始：
        1.5

      • rotateRight

        public static long rotateRight​(long i,
                               int distance)
        返回通过将指定的long值的二进制补码二进制表示旋转指定long值。 （右侧移位的位或左侧的低位侧重新输入，或高位）。

        注意，具有负距离的右旋转相当于左旋： rotateRight(val, -distance) == rotateLeft(val, distance) 。 还要注意，64的任意倍数的旋转是无操作的，因此除旋转距离的最后六位之外，除了距离为负值外，也可以忽略旋转距离的最后六位之外的所有旋转： rotateRight(val, distance) == rotateRight(val, distance & 0x3F) 。

        参数
        i - 其位要向右旋转的值
        distance - 要向右旋转的位位数
        结果
        通过将指定的 long值的二进制补码二进制表示旋转指定的 long值。
        从以下版本开始：
        1.5

      • reverse

        public static long reverse​(long i)
        返回通过反转指定的 long值的二进制补码二进制表示中的位的顺序获得的值。
        参数
        i - 要反转的值
        结果
        通过在指定的 long值中反转位的顺序获得的值。
        从以下版本开始：
        1.5

      • signum

        public static int signum​(long i)
        返回指定的long值的signum函数。 （如果指定的值为负，返回值为-1;如果指定的值为零，返回值为0;如果指定的值为正，返回值为1）。
        参数
        i - 要计算其符号的值
        结果
        指定功能的指定值为 long 。
        从以下版本开始：
        1.5

      • reverseBytes

        public static long reverseBytes​(long i)
        返回通过反转指定的 long值的二进制补码表示中的字节顺序获得的值。
        参数
        i - 要颠倒其字节的值
        结果
        通过在指定的 long值中反转字节获得的值。
        从以下版本开始：
        1.5

      • sum

        public static long sum​(long a,
                       long b)
        根据+运算符将两个 long值相加。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        总和为 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • max

        public static long max​(long a,
                       long b)
        返回两个 long值中的较大值，如同通过调用 Math.max一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较大的 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator

      • min

        public static long min​(long a,
                       long b)
        返回两个 long中的较小值，就像调用 Math.min一样 。
        参数
        a - 第一个操作数
        b - 第二个操作数
        结果
        较小的 a和 b
        从以下版本开始：
        1.8
        另请参见：
        BinaryOperator
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Math (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Math

  • java.lang.Object
    • java.lang.Math

  • public final class Math
extends Object
    Math包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。

    不像一些类的数值方法StrictMath ，类相当于所有功能的实现Math没有定义返回位对位相同的结果。 这种放松允许在不需要严格再现性的情况下执行更好的实现。

    默认情况下，许多Math方法只需调用中的对应方法是StrictMath组织落实。 鼓励代码生成器使用特定于平台的本地库或微处理器指令（如果可用），以提供更高性能的实现方法Math 。 这种更高性能的实现仍然必须符合Math的规范。

    实施规范的质量有两个属性，返回结果的准确性和方法的单调性。 的浮点精度Math方法在ULPS，单位在最后的地方来衡量。 对于给定的浮点格式，特定实数值的ulp是包含该数值的两个浮点值之间的距离。 当讨论整个方法的准确性而不是一个具体的参数时，引用的ulps的数量是任何参数的最坏情况错误。 如果方法总是出现小于0.5 ulps的错误，则该方法总是返回最接近精确结果的浮点数; 这种方法是正确的四舍五入 。 一个正确舍入的方法通常是一个最好的浮点近似可以; 然而，对于许多浮点方法来说，这是不切实际的。 相反，对于Math类，某些方法允许更大的1或2 Math误差范围。 非正式地，使用1 ul的错误限制，当确切的结果是可表示的数字时，应该将精确的结果作为计算结果返回; 否则，可以返回包含确切结果的两个浮点值之一。 对于大量的精确结果，支架的端点之一可能是无限大的。 除了个人论证的准确性之外，维持不同论点的方法之间的适当关系也很重要。 因此，绝大多数0.5 ulp误差的方法都是半单调的 ：每当数学函数不减小时 ，数学函数也是不减少的，同样地，当数学函数不增加时，浮点数近似也是如此点近似。 并非所有具有1 ulp精度的近似值将自动满足单调性要求。

    该平台使用带有int和long基元类型的带符号二进制补码整数运算。 开发人员应该选择原始类型，以确保算术运算始终产生正确的结果，这在某些情况下意味着操作不会溢出计算值的范围。 最佳做法是选择原始类型和算法以避免溢出。 在情况下，大小为int或者long ，需要检测溢出错误，方法addExact ， subtractExact ， multiplyExact ，并toIntExact抛出ArithmeticException当结果溢出。 对于其他算术运算，如除法，绝对值，递增1，递减1，否定，溢出仅在特定的最小值或最大值发生，并且应根据最小值或最大值进行检查。

    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double E
      double价值比其他任何一个更接近 e ，自然对数的基础。
      static double PI
      比其他任何一个更接近 pi的 double值，圆周长与其直径的比率。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static double abs​(double a)
      返回值为 double绝对值。
      static float abs​(float a)
      返回值为 float绝对值。
      static int abs​(int a)
      返回一个 int绝对值。
      static long abs​(long a)
      返回值为 long绝对值。
      static double acos​(double a)
      返回值的反余弦值; 返回的角度在0.0到pi的范围内。
      static int addExact​(int x, int y)
      返回其参数的总和，如果结果溢出 int ，则抛出异常。
      static long addExact​(long x, long y)
      返回其参数的总和，如果结果溢出一个 long ，则抛出异常。
      static double asin​(double a)
      返回值的正弦值; 返回角度在pi / 2到pi / 2的范围内。
      static double atan​(double a)
      返回值的反正切值; 返回角度在pi / 2到pi / 2的范围内。
      static double atan2​(double y, double x)
      返回从直角坐标（转换角度 theta x ， y ）为极坐标 （R，θ-）。
      static double cbrt​(double a)
      返回 double值的多维数据集根。
      static double ceil​(double a)
      返回最小的（最接近负无穷大） double值，该值大于或等于该参数，并等于某个整数。
      static double copySign​(double magnitude, double sign)
      使用第二个浮点参数的符号返回第一个浮点参数。
      static float copySign​(float magnitude, float sign)
      使用第二个浮点参数的符号返回第一个浮点参数。
      static double cos​(double a)
      返回角度的三角余弦。
      static double cosh​(double x)
      返回 double值的双曲余弦值。
      static int decrementExact​(int a)
      返回一个递减1的参数，如果结果溢出一个 int ，则抛出异常。
      static long decrementExact​(long a)
      返回一个递减1的参数，如果结果溢出一个 long ，则抛出异常。
      static double exp​(double a)
      返回欧拉的数字 e提高到 double价值。
      static double expm1​(double x)
      返回 e x -1。
      static double floor​(double a)
      返回小于或等于参数的最大（最接近正无穷大） double值，等于数学整数。
      static int floorDiv​(int x, int y)
      返回小于或等于代数商的最大（最接近正无穷大） int值。
      static long floorDiv​(long x, int y)
      返回小于或等于代数商的最大（最接近正无穷大） long值。
      static long floorDiv​(long x, long y)
      返回小于或等于代数商的最大（最接近正无穷大） long值。
      static int floorMod​(int x, int y)
      返回 int参数的底模数。
      static int floorMod​(long x, int y)
      返回 long和 int参数的底模。
      static long floorMod​(long x, long y)
      返回 long参数的底模数。
      static double fma​(double a, double b, double c)
      返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的double 。
      static float fma​(float a, float b, float c)
      返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的float 。
      static int getExponent​(double d)
      返回在 double的表示中使用的无偏指数。
      static int getExponent​(float f)
      返回在 float的表示中使用的无偏指数。
      static double hypot​(double x, double y)
      返回sqrt（ x 2 + y 2 ），没有中间溢出或下溢。
      static double IEEEremainder​(double f1, double f2)
      根据IEEE 754标准计算两个参数的余数运算。
      static int incrementExact​(int a)
      返回一个增加1的参数，如果结果溢出一个 int ，则抛出一个异常。
      static long incrementExact​(long a)
      返回自变量1，如果结果溢出一个 long ，则抛出异常。
      static double log​(double a)
      返回 double值的自然对数（基数 e ）。
      static double log10​(double a)
      返回值为 double的基数10对数。
      static double log1p​(double x)
      返回参数和1的和的自然对数。
      static double max​(double a, double b)
      返回两个 double中的较大值。
      static float max​(float a, float b)
      返回两个 float中的较大值。
      static int max​(int a, int b)
      返回两个 int中的较大值。
      static long max​(long a, long b)
      返回两个 long中的较大值。
      static double min​(double a, double b)
      返回两个 double中的较小值。
      static float min​(float a, float b)
      返回两个 float中的较小值。
      static int min​(int a, int b)
      返回两个 int中的较小值。
      static long min​(long a, long b)
      返回两个 long中的较小值。
      static int multiplyExact​(int x, int y)
      返回参数的乘积，如果结果溢出一个 int ，则抛出异常。
      static long multiplyExact​(long x, int y)
      返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
      static long multiplyExact​(long x, long y)
      返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
      static long multiplyFull​(int x, int y)
      返回参数的确切数学积。
      static long multiplyHigh​(long x, long y)
      作为 long返回的两个64位因子的128位产品中最重要的64位。
      static int negateExact​(int a)
      返回参数的否定，如果结果溢出一个 int ，则抛出异常。
      static long negateExact​(long a)
      返回参数的否定，如果结果溢出一个 long ，则抛出异常。
      static double nextAfter​(double start, double direction)
      返回与第二个参数方向相邻的第一个参数的浮点数。
      static float nextAfter​(float start, double direction)
      返回与第二个参数方向相邻的第一个参数的浮点数。
      static double nextDown​(double d)
      返回与负无穷大方向相邻的 d的浮点值。
      static float nextDown​(float f)
      返回与负无穷大方向相邻的 f的浮点值。
      static double nextUp​(double d)
      返回与正无穷大方向相邻的 d的浮点值。
      static float nextUp​(float f)
      返回与正无穷大方向相邻的 f的浮点值。
      static double pow​(double a, double b)
      将第一个参数的值返回到第二个参数的幂。
      static double random​()
      返回值为 double的正值，大于等于 0.0 ，小于 1.0 。
      static double rint​(double a)
      返回值与参数最接近的值为 double ，等于数学整数。
      static long round​(double a)
      返回最接近 long的参数，其中 long四舍五入为正无穷大。
      static int round​(float a)
      返回最接近的参数 int ，其中 int四舍五入为正无穷大。
      static double scalb​(double d, int scaleFactor)
      返回 d 2 scaleFactor四舍五入，好像由单个正确四舍五入的浮点乘以双重值集合的成员执行。
      static float scalb​(float f, int scaleFactor)
      返回 f 2 scaleFactor舍入，如同由一个正确圆形的浮点数乘以浮点值集合的成员执行的。
      static double signum​(double d)
      返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0，如果参数小于零，则为-1.0。
      static float signum​(float f)
      返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0f，如果参数小于零，则为-1.0f。
      static double sin​(double a)
      返回角度的三角正弦。
      static double sinh​(double x)
      返回一个 double的双曲正弦值。
      static double sqrt​(double a)
      返回 double值的正确舍入的正平方根。
      static int subtractExact​(int x, int y)
      返回参数的差异，如果结果溢出一个 int ，则抛出异常。
      static long subtractExact​(long x, long y)
      返回参数的差异，如果结果溢出一个 long ，则抛出异常。
      static double tan​(double a)
      返回角度的三角正切。
      static double tanh​(double x)
      返回 double值的双曲正切值。
      static double toDegrees​(double angrad)
      将以弧度测量的角度转换为以度为单位的近似等效角度。
      static int toIntExact​(long value)
      返回值为long参数; 如果值溢出int则抛出异常。
      static double toRadians​(double angdeg)
      将以度为单位的角度转换为以弧度测量的大致相等的角度。
      static double ulp​(double d)
      返回参数的ulp的大小。
      static float ulp​(float f)
      返回参数的ulp的大小。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • E

        public static final double E
        double价值比其他任何一个更接近 e ，自然对数的基础。
        另请参见：
        Constant Field Values

      • PI

        public static final double PI
        double值比任何其他的更接近 pi ，圆周长与其直径的比率。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • sin

        public static double sin​(double a)
        返回角度的三角正弦。 特殊情况：
        • 如果参数为NaN或无穷大，则结果为NaN。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 以弧度表示的角度。
        结果
        论证的正义。

      • cos

        public static double cos​(double a)
        返回角度的三角余弦。 特殊情况：
        • 如果参数为NaN或无穷大，则结果为NaN。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 以弧度表示的角度。
        结果
        论证的余弦。

      • tan

        public static double tan​(double a)
        返回角度的三角正切。 特殊情况：
        • 如果参数为NaN或无穷大，则结果为NaN。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 以弧度表示的角度。
        结果
        争论的切线。

      • asin

        public static double asin​(double a)
        返回值的正弦值; 返回角度在pi / 2到pi / 2的范围内。 特殊情况：
        • 如果参数为NaN或其绝对值大于1，则结果为NaN。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 要返回正弦的值。
        结果
        争论的正弦。

      • acos

        public static double acos​(double a)
        返回值的反余弦值; 返回的角度在0.0到pi的范围内。 特例：
        • 如果参数为NaN或其绝对值大于1，则结果为NaN。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 要返回的余弦值。
        结果
        论证的反余弦。

      • atan

        public static double atan​(double a)
        返回值的反正切值; 返回角度在pi / 2到pi / 2的范围内。 特殊情况：
        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 要返回的反正切值。
        结果
        论点的反正切。

      • toRadians

        public static double toRadians​(double angdeg)
        将以度为单位的角度转换为以弧度测量的大致相等的角度。 从度数到弧度的转换通常是不准确的。
        参数
        angdeg - 以度为单位的角度
        结果
        测量角度 angdeg （弧度）。
        从以下版本开始：
        1.2

      • toDegrees

        public static double toDegrees​(double angrad)
        将以弧度测量的角度转换为以度为单位的近似等效角度。 从弧度到度的转换通常是不准确的; 用户不应该指望cos(toRadians(90.0))到正好等于0.0 。
        参数
        angrad - 以弧度表示的角度
        结果
        测量角度为 angrad度。
        从以下版本开始：
        1.2

      • exp

        public static double exp​(double a)
        返回欧拉的数字e提高到double价值。 特殊情况：
        • 如果参数是NaN，结果是NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为负无穷大，则结果为正零。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 提高 e的指数。
        结果
        值 e a ，其中 e是自然对数的基数。

      • log

        public static double log​(double a)
        返回double值的自然对数（基数e ）。 特殊情况：
        • 如果参数为NaN或小于零，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为正零或负零，则结果为负无穷大。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 一个值
        结果
        值ln a ，自然对数为 a 。

      • log10

        public static double log10​(double a)
        返回double值的基数10对数。 特殊情况：
        • 如果参数为NaN或小于零，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为正零或负零，则结果为负无穷大。
        • 如果参数等于10 n，用于整数n，则结果为n。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 一个值
        结果
        基数10对数为 a 。
        从以下版本开始：
        1.5

      • sqrt

        public static double sqrt​(double a)
        返回double值的正确舍入的正平方根。 特殊情况：
        • 如果参数为NaN或小于零，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为正零或负零，则结果与参数相同。
        否则，结果是最接近参数值的真数学平方根的double值。
        参数
        a - 一个值。
        结果
        正平方根为a 。 如果参数为NaN或小于零，则结果为NaN。

      • cbrt

        public static double cbrt​(double a)
        返回double值的多维数据集根。 对于正有限x ， cbrt(-x) == -cbrt(x) ; 也就是说，负值的多边形根是该值的大小的立方根的负数。 特殊情况：
        • 如果参数是NaN，那么结果是NaN。
        • 如果参数是无限的，则结果是与参数具有相同符号的无穷大。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果的1 ulp之内。

        参数
        a - 一个值。
        结果
        立方根 a 。
        从以下版本开始：
        1.5

      • IEEEremainder

        public static double IEEEremainder​(double f1,
                                   double f2)
        根据IEEE 754标准计算两个参数的余数运算。 余数的算术值等于f1 - f2 A-n，其中n是最接近商的精确算术值的数学整数f1/f2 ，并且如果两个整数都同样接近f1/f2 ，那么n是其中的偶数。 如果余数为零，其符号与第一个参数的符号相同。 特殊情况：
        • 如果任一参数为NaN，或第一个参数为无穷大，或第二个参数为正零或负零，则结果为NaN。
        • 如果第一个参数是有限的，第二个参数是无穷大的，那么结果与第一个参数相同。
        参数
        f1 - 股息。
        f2 - 除数。
        结果
        剩余时间为 f1除以 f2 。

      • ceil

        public static double ceil​(double a)
        返回最小的（最接近负无穷大） double值，该值大于或等于该参数，并等于某个整数。 特殊情况：
        • 如果参数值已经等于数学整数，则结果与参数相同。
        • 如果参数为NaN或无穷大或正零或负零，则结果与参数相同。
        • 如果参数值小于零但大于-1.0，则结果为负零。
        需要注意的是价值Math.ceil(x)正是价值-Math.floor(-x) 。
        参数
        a - 一个值。
        结果
        最大（最接近负无穷大）的浮点值大于或等于参数，并且等于一个数学整数。

      • floor

        public static double floor​(double a)
        返回小于或等于参数的最大（最接近正无穷大） double值，等于一个数学整数。 特殊情况：
        • 如果参数值已经等于数学整数，则结果与参数相同。
        • 如果参数为NaN或无穷大或正零或负零，则结果与参数相同。
        参数
        a - 一个值。
        结果
        小于或等于参数的最大（最接近正无穷大）浮点值，等于数学整数。

      • rint

        public static double rint​(double a)
        返回值与参数最接近的值为double ，等于数学整数。 如果作为数学整数的两个double值同样接近，则结果为均匀的整数值。 特殊情况：
        • 如果参数值已经等于数学整数，则结果与参数相同。
        • 如果参数为NaN或无穷大或正零或负零，则结果与参数相同。
        参数
        a - 一个 double价值。
        结果
        最接近的浮点值为 a等于一个数学整数。

      • atan2

        public static double atan2​(double y,
                           double x)
        返回从直角坐标（转换角度theta x ， y ）为极坐标（R，θ-）。 该方法通过计算在pi到pi的范围内的y/x反正切来计算相位θ 。 特殊情况：
        • 如果任一参数为NaN，则结果为NaN。
        • 如果第一个参数为正零，第二个参数为正，或第一个参数为正和有限，第二个参数为正无穷大，则结果为正零。
        • 如果第一个参数为负零，第二个参数为正，或第一个参数为负，有限，第二个参数为正无穷大，则结果为负零。
        • 如果第一个参数为正零，第二个参数为负，或第一个参数为正和有限，第二个参数为负无穷大，则结果为最接近pi的double值。
        • 如果第一个参数为负零，第二个参数为负数，或者第一个参数为负，有限，第二个参数为负无穷大，则结果为最接近pi的double值。
        • 如果第一个参数为正，第二个参数为正零或负零，或第一个参数为正无穷大，第二个参数为有限，则结果为最接近pi / 2的double值。
        • 如果第一个参数是负的，第二个参数是正的零或负零，或者第一参数是负无穷大，并且第二个参数是有限的，那么结果是double最接近的值到- PI / 2。
        • 如果两个参数均为无穷大，则结果为最接近pi / 4的double值。
        • 如果第一个参数为正无穷大，第二个参数为负无穷大，则结果为最接近3 * pi / 4的double值。
        • 如果第一个参数为负无穷大，第二个参数为正无穷大，则结果为最接近 - pi / 4的double值。
        • 如果两个参数均为负无穷大，则结果为最接近-3 * pi / 4的double值。

        计算结果必须在精确结果的2 ulps之内。 结果必须是半单调的。

        参数
        y - 坐标坐标
        x - 横坐标坐标
        结果
        极坐标中点（ r ， theta ）的 theta分量对应于笛卡尔坐标中的点（ x ， y ）。

      • pow

        public static double pow​(double a,
                         double b)
        将第一个参数的值返回到第二个参数的幂。 特殊情况：
        • 如果第二个参数为正或负零，则结果为1.0。
        • 如果第二个参数为1.0，则结果与第一个参数相同。
        • 如果第二个参数是NaN，那么结果是NaN。
        • 如果第一个参数是NaN，第二个参数是非零，那么结果是NaN。
        • 如果
          • 第一个参数的绝对值大于1，第二个参数为正无穷大，或
          • 第一个参数的绝对值小于1，第二个参数为负无穷大，
          那么结果是正无穷大。
        • 如果
          • 第一个参数的绝对值大于1，第二个参数为负无穷大，或
          • 第一个参数的绝对值小于1，第二个参数为正无穷大，
          那么结果是正零。
        • 如果第一个参数的绝对值等于1，第二个参数为无穷大，则结果为NaN。
        • 如果
          • 第一个参数是正零，第二个参数大于零，或者
          • 第一个参数是正无穷大，第二个参数小于零，
          那么结果是正零。
        • 如果
          • 第一个参数是正零，第二个参数小于零，或者
          • 第一个参数是正无穷大，第二个参数大于零，
          那么结果是正无穷大。
        • 如果
          • 第一个参数是负零，第二个参数大于零，但不是有限的奇整数，或者
          • 第一个参数是负无穷大，第二个参数小于零，但不是有限奇整数，
          那么结果是正零。
        • 如果
          • 第一个参数为负零，第二个参数为正有限奇数整数，或
          • 第一个参数为负无穷大，第二个参数为负有限奇数整数，
          那么结果是负零。
        • 如果
          • 第一个参数为负零，第二个参数小于零，但不是有限奇整数
          • 第一个参数为负无穷大，第二个参数大于零但不是有限奇整数，
          那么结果是正无穷大。
        • 如果
          • 第一个参数为负零，第二个参数为负有限奇数整数，或
          • 第一个参数是负无穷大，第二个参数是正有限奇数整数，
          那么结果是负无穷大。
        • 如果第一个参数是有限的并且小于零
          • 如果第二个参数是有限均匀整数，结果等于将第一个参数的绝对值提高到第二个参数的幂的结果
          • 如果第二个参数是有限的奇整数，则结果等于将第一个参数的绝对值提高到第二个参数的幂的结果的负数
          • 如果第二个参数是有限的，而不是一个整数，则结果是NaN。
        • 如果两个参数都是整数，则结果完全等于将第一个参数提升为第二个参数的幂的数学结果，如果该结果事实上可以精确地表示为double值。

        （在前述的说明中，一个浮点值被认为是一个整数，当且仅当它是有限的，并且该方法的一个固定点ceil或等价地，该方法的一个固定点floor 。的值是一个固定的点的唯一方法，当且仅当将该方法应用于该值的结果等于该值时）。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        a - 基地。
        b - 指数。
        结果
        值 a b 。

      • round

        public static int round​(float a)
        返回参数最接近的int ，其中int四舍五入为正无穷大。

        特殊情况：

        • 如果参数是NaN，结果为0。
        • 如果参数为负无穷大或小于或等于值Integer.MIN_VALUE的值，则结果等于值Integer.MIN_VALUE 。
        • 如果参数为正无穷大或大于或等于Integer.MAX_VALUE的值，则结果等于值Integer.MAX_VALUE 。
        参数
        a - 要舍入为整数的浮点值。
        结果
        参数的值四舍五入到最接近的 int值。
        另请参见：
        Integer.MAX_VALUE ， Integer.MIN_VALUE

      • round

        public static long round​(double a)
        返回最接近的参数long ，其中long四舍五入为正无穷大。

        特殊情况：

        • 如果参数是NaN，结果为0。
        • 如果参数为负无穷大或小于或等于值Long.MIN_VALUE的值，则结果等于值Long.MIN_VALUE 。
        • 如果参数为正无穷大或大于或等于Long.MAX_VALUE的值，则结果等于值Long.MAX_VALUE 。
        参数
        a - 要舍入为 long的浮点值。
        结果
        参数的值四舍五入到最接近的 long值。
        另请参见：
        Long.MAX_VALUE ， Long.MIN_VALUE

      • random

        public static double random​()
        返回值为double的正值，大于等于0.0 ，小于1.0 。 返回的值是从该范围（大约）均匀分布的伪随机选择的。

        首先调用此方法时，它将创建一个新的伪随机数生成器，就像表达式一样

        new java.util.Random()
        此新的伪随机数生成器此后用于对该方法的所有调用，并在其他地方使用。

        该方法正确同步，以允许多个线程正确使用。 然而，如果许多线程需要以很高的速率产生伪随机数，则可以减少每个线程的争用以拥有自己的伪随机数发生器。

        API Note:
        作为最大的double值小于1.0是Math.nextDown(1.0) ，值x在闭合范围[x1,x2]其中x1<=x2可以由语句来定义

 double f = Math.random()/Math.nextDown(1.0);
 double x = x1*(1.0 - f) + x2*f;
        结果
        一个伪随机数 double大于等于 0.0 ，小于 1.0 。
        另请参见：
        nextDown(double) ， Random.nextDouble()

      • addExact

        public static int addExact​(int x,
                           int y)
        返回其参数的总和，如果结果溢出一个 int ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8

      • addExact

        public static long addExact​(long x,
                            long y)
        返回其参数的总和，如果结果溢出一个 long ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了一个长的
        从以下版本开始：
        1.8

      • subtractExact

        public static int subtractExact​(int x,
                                int y)
        返回参数的差异，如果结果溢出一个 int ，则抛出异常。
        参数
        x - 第一个值
        y - 从第一个值减去的第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8

      • subtractExact

        public static long subtractExact​(long x,
                                 long y)
        返回参数的差异，如果结果溢出一个 long ，则抛出异常。
        参数
        x - 第一个值
        y - 从第一个值减去的第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出很长
        从以下版本开始：
        1.8

      • multiplyExact

        public static int multiplyExact​(int x,
                                int y)
        返回参数的乘积，如果结果溢出一个 int ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8

      • multiplyExact

        public static long multiplyExact​(long x,
                                 int y)
        返回参数的乘积，如果结果溢出 long ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        9

      • multiplyExact

        public static long multiplyExact​(long x,
                                 long y)
        返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        1.8

      • incrementExact

        public static int incrementExact​(int a)
        返回自变量1，如果结果溢出一个 int ，则抛出异常。
        参数
        a - 增量的值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8

      • incrementExact

        public static long incrementExact​(long a)
        返回自变量1，如果结果溢出一个 long ，则抛出异常。
        参数
        a - 增量的值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        1.8

      • decrementExact

        public static int decrementExact​(int a)
        返回一个递减1的参数，如果结果溢出一个 int ，则抛出异常。
        参数
        a - 减值的值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8

      • decrementExact

        public static long decrementExact​(long a)
        返回一个递减1的参数，如果结果溢出一个 long ，则抛出异常。
        参数
        a - 减值的值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        1.8

      • negateExact

        public static int negateExact​(int a)
        返回参数的否定，如果结果溢出一个 int ，则抛出异常。
        参数
        a - 否定的值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8

      • negateExact

        public static long negateExact​(long a)
        返回参数的否定，如果结果溢出一个 long ，则抛出异常。
        参数
        a - 否定的值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        1.8

      • toIntExact

        public static int toIntExact​(long value)
        返回值为long参数; 如果值溢出int则抛出异常。
        参数
        value - 长价值
        结果
        作为int的参数
        异常
        ArithmeticException - 如果 argument溢出一个int
        从以下版本开始：
        1.8

      • multiplyFull

        public static long multiplyFull​(int x,
                                int y)
        返回参数的确切数学积。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        从以下版本开始：
        9

      • multiplyHigh

        public static long multiplyHigh​(long x,
                                long y)
        作为 long返回的两个64位因子的128位产品的最高64位。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        从以下版本开始：
        9

      • floorDiv

        public static int floorDiv​(int x,
                           int y)
        返回小于或等于代数商的最大（最接近正无穷大） int值。 有一个特殊情况，如果股息为Integer.MIN_VALUE ，除数为-1 ，则发生整数溢出，结果等于Integer.MIN_VALUE 。

        正常整数除法在四舍五入方式（截断）下运行。 这个操作代替在向下的无穷大（倒圆）舍入模式下。 当精确结果为负时，地板舍入模式会产生截断的不同结果。

        • 如果参数的符号相同，则floorDiv和/运算符的结果是一样的。
          例如， floorDiv(4, 3) == 1和(4 / 3) == 1 。
        • 如果参数的符号不同，则商为负，并且floorDiv返回小于或等于商的整数，而/运算符返回最接近零的整数。
          例如， floorDiv(-4, 3) == -2 ，而(-4 / 3) == -1 。
        参数
        x - 股息
        y - 除数
        结果
        小于或等于代数商的最大（最接近正无穷大） int值。
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        floorMod(int, int) ， floor(double)

      • floorDiv

        public static long floorDiv​(long x,
                            int y)
        返回小于或等于代数商的最大（最接近正无穷大） long值。 有一个特殊情况，如果股息为Long.MIN_VALUE ，除数为-1 ，则发生整数溢出，结果等于Long.MIN_VALUE 。

        正常整数除法在四舍五入方式（截断）下运行。 这个操作代替在向下的无穷大（倒圆）舍入模式下。 当精确结果为负时，地板舍入模式会产生截断的不同结果。

        例如，请参阅floorDiv(int, int) 。

        参数
        x - 股息
        y - 除数
        结果
        小于或等于代数商的最大（最接近正无穷大） int值。
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        9
        另请参见：
        floorMod(long, int) ， floor(double)

      • floorDiv

        public static long floorDiv​(long x,
                            long y)
        返回小于或等于代数商的最大（最接近正无穷大） long值。 有一个特殊情况，如果股息为Long.MIN_VALUE ，除数为-1 ，则发生整数溢出，结果等于Long.MIN_VALUE 。

        正常整数除法在四舍五入方式（截断）下运行。 这个操作代替在向下的无穷大（倒圆）舍入模式下。 当精确结果为负时，地板舍入模式会产生截断的不同结果。

        例如，参见floorDiv(int, int) 。

        参数
        x - 股息
        y - 除数
        结果
        小于或等于代数商的最大（最接近正无穷大） long值。
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        floorMod(long, long) ， floor(double)

      • floorMod

        public static int floorMod​(int x,
                           int y)
        返回int参数的底模。

        地板模量为x - (floorDiv(x, y) * y) ，具有相同的符号作为除数y ，并且在范围内-abs(y) < r < +abs(y) 。

        floorDiv和floorMod之间的关系是这样的：

        • floorDiv(x, y) * y + floorMod(x, y) == x

        在之间的值的差floorMod和%操作者是由于之间的差floorDiv返回小于或等于商和整数/操作者返回最接近零的整数。

        例子：

        • 如果参数的符号相同，则floorMod和%操作符的结果相同。
          • floorMod(4, 3) == 1 ; 和(4 % 3) == 1
        • 如果参数的符号不同，结果与%运算符不同。
          • floorMod(+4, -3) == -2 ; 和(+4 % -3) == +1
          • floorMod(-4, +3) == +2 ; 和(-4 % +3) == -1
          • floorMod(-4, -3) == -1 ; 和(-4 % -3) == -1

        如果参数的符号是未知的，并且需要正模数，则可以计算为(floorMod(x, y) + abs(y)) % abs(y) 。

        参数
        x - 股息
        y - 除数
        结果
        地板模数 x - (floorDiv(x, y) * y)
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        floorDiv(int, int)

      • floorMod

        public static int floorMod​(long x,
                           int y)
        返回long和int参数的底模。

        地板模量为x - (floorDiv(x, y) * y) ，具有相同的符号作为除数y ，并且在范围内-abs(y) < r < +abs(y) 。

        floorDiv和floorMod之间的关系是这样的：

        • floorDiv(x, y) * y + floorMod(x, y) == x

        例如，参见floorMod(int, int) 。

        参数
        x - 股息
        y - 除数
        结果
        地板模数 x - (floorDiv(x, y) * y)
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        9
        另请参见：
        floorDiv(long, int)

      • floorMod

        public static long floorMod​(long x,
                            long y)
        新新新long

        地板模量为x - (floorDiv(x, y) * y) ，具有相同的符号作为除数y ，并且在范围内-abs(y) < r < +abs(y) 。

        floorDiv和floorMod之间的关系是这样的：

        • floorDiv(x, y) * y + floorMod(x, y) == x

        例如，参见floorMod(int, int) 。

        参数
        x - 股息
        y - 除数
        结果
        地板模数 x - (floorDiv(x, y) * y)
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        floorDiv(long, long)

      • abs

        public static int abs​(int a)
        返回值为int绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。

        注意，如果参数等于值Integer.MIN_VALUE ，最负表示的int值，结果是相同的值，且为负。

        参数
        a - 绝对值要确定的参数
        结果
        参数的绝对值。

      • abs

        public static long abs​(long a)
        返回值为long绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。

        注意，如果参数等于Long.MIN_VALUE的值，则最负值可表示为long值，结果是相同的值，即为负数。

        参数
        a - 绝对值要确定的参数
        结果
        参数的绝对值。

      • abs

        public static float abs​(float a)
        返回值为float绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。 特殊情况：
        • 如果参数为正零或负零，结果为正零。
        • 如果论证是无限的，结果是正无穷大。
        • 如果参数是NaN，结果是NaN。
        API Note:
        如上所述，该方法的一个有效实现由以下表达式给出，其计算具有与参数相同的指数和有效数的 float ，但具有指示正值的保证零符号位：
        Float.intBitsToFloat(0x7fffffff & Float.floatToRawIntBits(a))
        参数
        a - 绝对值要确定的参数
        结果
        参数的绝对值。

      • abs

        public static double abs​(double a)
        返回值为double绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。 特殊情况：
        • 如果参数为正零或负零，结果为正零。
        • 如果论证是无限的，结果是正无穷大。
        • 如果参数是NaN，结果是NaN。
        API Note:
        如上所述，该方法的一个有效实现由以下表达式给出，其计算具有与参数相同的指数和有效数的 double ，但具有指示正值的保证零符号位：
        Double.longBitsToDouble((Double.doubleToRawLongBits(a)<<1)>>>1)
        参数
        a - 绝对值要确定的参数
        结果
        参数的绝对值。

      • max

        public static int max​(int a,
                      int b)
        返回两个int值中的较大值。 也就是说，结果是更接近Integer.MAX_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较大的 a和 b 。

      • max

        public static long max​(long a,
                       long b)
        返回两个long值中的较大值。 也就是说，结果是更接近Long.MAX_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较大的 a和 b 。

      • max

        public static float max​(float a,
                        float b)
        返回两个float中的较大值。 也就是说，结果是更接近正无穷大的论据。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负，结果为正零。
        参数
        a - 一个论点。
        b - 另一个参数。
        结果
        较大的 a和 b 。

      • max

        public static double max​(double a,
                         double b)
        返回两个double中的较大值。 也就是说，结果是更接近正无穷大的论据。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负，结果为正零。
        参数
        a - 一个论据。
        b - 另一个论点。
        结果
        较大的 a和 b 。

      • min

        public static int min​(int a,
                      int b)
        返回两个int中的较小值。 也就是说，结果是更接近Integer.MIN_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较小的 a和 b 。

      • min

        public static long min​(long a,
                       long b)
        返回两个long中的较小值。 也就是说，结果是更接近Long.MIN_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较小的 a和 b 。

      • min

        public static float min​(float a,
                        float b)
        返回两个float中的较小值。 也就是说，结果是更接近负无穷大的值。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负零，结果为负零。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较小的 a和 b 。

      • min

        public static double min​(double a,
                         double b)
        返回两个double中的较小值。 也就是说，结果是更接近负无穷大的值。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负零，结果为负零。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较小的 a和 b 。

      • fma

        public static double fma​(double a,
                         double b,
                         double c)
        返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的double 。 舍入是使用round to nearest even rounding mode完成的。 相比之下，如果将a * b + c作为常规浮点表达式求值，则涉及两个舍入误差，第一个用于乘法运算，第二个用于加法运算。

        特殊情况：

        • 如果任何参数是NaN，结果是NaN。
        • 如果前两个参数之一是无穷大，另一个为零，则结果为NaN。
        • 如果前两个参数的确切乘积是无穷大的（换句话说，至少有一个参数是无穷大的，另一个不是零，也不是NaN），而第三个参数是相反符号的无穷大，结果是NaN。

        请注意， fma(a, 1.0, c)返回与（ a + c ）相同的结果。 然而， fma(a, b, +0.0) 并不总是返回相同的结果（ a * b ），因为fma(-0.0, +0.0, +0.0)为+0.0 ，而（ -0.0 * +0.0 ）为-0.0 ; fma(a, b, -0.0)相当于（ a * b ）。

        API Note:
        该方法对应于IEEE 754-2008中定义的fusedMultiplyAdd操作。
        参数
        a - 一个值
        b - 一个值
        c - 一个值
        结果
        （A A- B + C）来计算，因为如果具有无限范围和精度，并且一旦四舍五入到最近的 double值
        从以下版本开始：
        9

      • fma

        public static float fma​(float a,
                        float b,
                        float c)
        返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的float 。 舍入是使用round to nearest even rounding mode完成的。 相比之下，如果将a * b + c评估为常规浮点表达式，则涉及两个舍入误差，第一个用于乘法运算，第二个用于加法运算。

        特殊情况：

        • 如果任何参数是NaN，结果是NaN。
        • 如果前两个参数之一是无穷大，另一个为零，则结果为NaN。
        • 如果前两个参数的确切乘积是无穷大的（换句话说，至少有一个参数是无穷大的，另一个不是零，也不是NaN），而第三个参数是相反符号的无穷大，结果是NaN。

        请注意， fma(a, 1.0f, c)返回与（ a + c ）相同的结果。 然而， fma(a, b, +0.0f) 并不总是返回相同的结果（ a * b ），因为fma(-0.0f, +0.0f, +0.0f)为+0.0f ，而（ -0.0f * +0.0f ）为-0.0f ; fma(a, b, -0.0f)相当于（ a * b ）。

        API Note:
        该方法对应于IEEE 754-2008中定义的fusedMultiplyAdd操作。
        参数
        a - 一个值
        b - 一个值
        c - 一个值
        结果
        （A A- B + C）来计算，因为如果具有无限范围和精度，并且一旦四舍五入到最近的 float值
        从以下版本开始：
        9

      • ulp

        public static double ulp​(double d)
        返回参数的ulp的大小。 最后一个位置的一个ulp单位是double值，这个浮点值与double值之间的正距离越大。 请注意，对于非NaN x ， ulp(-x) == ulp(x) 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正或负无穷大，则结果为正无穷大。
        • 如果参数为正或负零，则结果为Double.MIN_VALUE 。
        • 如果参数为± Double.MAX_VALUE ，则结果等于2 971 。
        参数
        d - 要返回ulp的浮点值
        结果
        参数的ulp的大小
        从以下版本开始：
        1.5

      • ulp

        public static float ulp​(float f)
        返回参数的ulp的大小。 最后一个位置的ulp单位是float值，这个浮点值与float值之间的正距离越大。 请注意，对于非NaN x ， ulp(-x) == ulp(x) 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正或负无穷大，则结果为正无穷大。
        • 如果参数为正或负零，则结果为Float.MIN_VALUE 。
        • 如果参数为± Float.MAX_VALUE ，则结果等于2 104 。
        参数
        f - 要返回ulp的浮点值
        结果
        参数的ulp的大小
        从以下版本开始：
        1.5

      • signum

        public static double signum​(double d)
        返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0，如果参数小于零，则为-1.0。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正零或负零，则结果与参数相同。
        参数
        d - 要返回其符号的浮点值
        结果
        参数的signum函数
        从以下版本开始：
        1.5

      • signum

        public static float signum​(float f)
        返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0f，如果参数小于零，则为-1.0f。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正零或负零，则结果与参数相同。
        参数
        f - 要返回其符号的浮点值
        结果
        参数的signum函数
        从以下版本开始：
        1.5

      • sinh

        public static double sinh​(double x)
        返回一个double的双曲正弦值。 x的双曲正弦被定义为（ e x -e -x ）/ 2，其中e是Euler's number 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数是无限的，则结果是与参数具有相同符号的无穷大。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果2.5 ul以内。

        参数
        x - 要返回双曲正弦的数字。
        结果
        双曲正弦为 x 。
        从以下版本开始：
        1.5

      • cosh

        public static double cosh​(double x)
        返回一个double值的双曲余弦值。 x的双曲余弦被定义为（ e x + e -x ）/ 2，其中e是Euler's number 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数是无穷大的，则结果是正无穷大。
        • 如果参数为零，则结果为1.0 。

        计算结果必须在精确结果2.5 ul以内。

        参数
        x - 要返回双曲余弦的数字。
        结果
        双曲余弦 x 。
        从以下版本开始：
        1.5

      • tanh

        public static double tanh​(double x)
        返回double值的双曲正切值。 x的双曲正切定义为（E X -电子-x）/（E X + E -x），换句话说， 二七�鑫迦�七二一二四�銎叨�三一 / 二百七十�鐾蛭迩�三百七十二亿一千二百四十一万五千五百二十一 。 请注意，确切的tanh的绝对值始终小于1。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为零，则结果为与参数相同符号的零。
        • 如果参数为无穷大，则结果为+1.0 。
        • 如果参数为负无穷大，则结果为-1.0 。

        计算结果必须在精确结果2.5 ul以内。 任何有限输入的tanh的结果必须具有小于或等于1的绝对值。注意，一旦tanh的精确结果在±1的极限值的ulp的1/2内，正确签名± 1.0应该退回

        参数
        x - 要返回其双曲正切的数字。
        结果
        双曲正切值为 x 。
        从以下版本开始：
        1.5

      • hypot

        public static double hypot​(double x,
                           double y)
        返回sqrt（ x 2 + y 2 ），没有中间溢出或下溢。

        特殊情况：

        • 如果任一参数为无穷大，则结果为无穷大。
        • 如果任一参数为NaN，且两个参数都不是无穷大，则结果为NaN。

        计算结果必须在精确结果的1 ulp之内。 如果一个参数保持不变，则其他参数的结果必须是半单调的。

        参数
        x - 一个值
        y - 一个值
        结果
        sqrt（ x 2 + y 2 ），没有中间溢出或下溢
        从以下版本开始：
        1.5

      • expm1

        public static double expm1​(double x)
        返回e x -1。 请注意，对于接近0 的x值的确切数额expm1(x) + 1更接近E X比的真实结果exp(x) 。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为负无穷大，则结果为-1.0。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。 任何有限输入的expm1的结果必须大于或等于-1.0 。 注意，一旦e x的确切结果在限制值-1的1/2 ulp内，则应返回-1.0 。

        参数
        x - 在 e x -1的计算中提高 e的指数。
        结果
        值 e x - 1。
        从以下版本开始：
        1.5

      • log1p

        public static double log1p​(double x)
        返回参数之和1注的自然对数，对于小值x ，结果log1p(x)更接近LN（1 +的真实结果x ），比的浮点评价log(1.0+x) 。

        特殊情况：

        • 如果参数为NaN或小于-1，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为负，则结果为负无穷大。
        • 如果参数为零，则结果为与参数相同符号的零。

        计算结果必须在精确结果的1 ulp之内。 结果必须是半单调的。

        参数
        x - 一个值
        结果
        值ln（ x + 1），自然日志为 x + 1
        从以下版本开始：
        1.5

      • copySign

        public static double copySign​(double magnitude,
                              double sign)
        使用第二个浮点参数的符号返回第一个浮点参数。 请注意，与StrictMath.copySign方法不同，此方法不需要将NaN sign参数视为正值; 允许实现将一些NaN参数视为正值，其他NaN参数为负，以允许更高的性能。
        参数
        magnitude - 提供结果大小的参数
        sign - 提供结果符号的参数
        结果
        价值 magnitude ，标志为 sign 。
        从以下版本开始：
        1.6

      • copySign

        public static float copySign​(float magnitude,
                             float sign)
        使用第二个浮点参数的符号返回第一个浮点参数。 请注意，与StrictMath.copySign方法不同，此方法不需要将NaN sign参数视为正值; 允许实现将一些NaN参数视为正值，其他NaN参数为负，以允许更高的性能。
        参数
        magnitude - 提供结果大小的参数
        sign - 提供结果符号的参数
        结果
        价值 magnitude ，符号 sign 。
        从以下版本开始：
        1.6

      • getExponent

        public static int getExponent​(float f)
        返回float表示中使用的无偏指数。 特殊情况：
        • 如果参数为NaN或无限，则结果为Float.MAX_EXPONENT + 1。
        • 如果参数为零或非正常，则结果为Float.MIN_EXPONENT -1。
        参数
        f - a float价值
        结果
        参数的无偏指数
        从以下版本开始：
        1.6

      • getExponent

        public static int getExponent​(double d)
        返回在double的表示中使用的无偏指数。 特殊情况：
        • 如果参数为NaN或无限，则结果为Double.MAX_EXPONENT + 1。
        • 如果参数为零或次正常，则结果为Double.MIN_EXPONENT -1。
        参数
        d - 一个 double价值
        结果
        参数的无偏指数
        从以下版本开始：
        1.6

      • nextAfter

        public static double nextAfter​(double start,
                               double direction)
        返回与第二个参数方向相邻的第一个参数的浮点数。 如果两个参数都相等，则返回第二个参数。

        特殊情况：

        • 如果任一参数是NaN，则返回NaN。
        • 如果两个参数都是带符号的零， direction将返回不变（如果参数比较相等则返回第二个参数的要求）。
        • 如果start为± Double.MIN_VALUE，并且direction具有使结果应具有较小幅度的值，则返回与start相同符号的零。
        • 如果start是无限的， direction具有这样的结果应该有一个小幅度的值Double.MAX_VALUE用相同的符号start返回。
        • 如果start等于± Double.MAX_VALUE，并且direction具有使得结果应该具有较大幅度的值，则返回与start相同符号的无穷大。
        参数
        start - 起始浮点值
        direction - 表示 start的邻居或 start应返回的值
        结果
        邻近浮点数 start中的方向 direction 。
        从以下版本开始：
        1.6

      • nextAfter

        public static float nextAfter​(float start,
                              double direction)
        返回与第二个参数方向相邻的第一个参数的浮点数。 如果两个参数都相等，则返回等于第二个参数的值。

        特殊情况：

        • 如果任一参数是NaN，则返回NaN。
        • 如果两个参数均为带符号的零，则返回值为direction的值。
        • 如果start为± Float.MIN_VALUE，并且direction具有使结果应具有较小幅度的值，则返回与start相同符号的零。
        • 如果start是无限的， direction具有这样的结果应该有一个小幅度的值Float.MAX_VALUE用相同的符号start返回。
        • 如果start等于± Float.MAX_VALUE，并且direction具有使得结果应该具有较大幅度的值，则返回与start相同符号的无穷大。
        参数
        start - 起始浮点值
        direction - 表示 start的邻居或 start应该返回的值
        结果
        邻近浮点数 start中的方向 direction 。
        从以下版本开始：
        1.6

      • nextUp

        public static double nextUp​(double d)
        返回与正无穷大方向相邻的d的浮点值。 这种方法在语义上相当于nextAfter(d, Double.POSITIVE_INFINITY) ; 但是，一个nextUp实现可能比其等效的nextAfter调用运行得更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果论证是正无穷大，结果是正无穷大。
        • 如果参数为零，则结果为Double.MIN_VALUE
        参数
        d - 起始浮点值
        结果
        相邻浮点值接近正无穷大。
        从以下版本开始：
        1.6

      • nextUp

        public static float nextUp​(float f)
        在正无穷大的方向上返回与f相邻的浮点值。 这种方法在语义上相当于nextAfter(f, Float.POSITIVE_INFINITY) ; 但是，一个nextUp实现可能比其等效的nextAfter调用运行得更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果论证是正无穷大，结果是正无穷大。
        • 如果参数为零，则结果为Float.MIN_VALUE
        参数
        f - 起始浮点值
        结果
        相邻浮点值接近正无穷大。
        从以下版本开始：
        1.6

      • nextDown

        public static double nextDown​(double d)
        返回与负无穷大方向相邻的d的浮点值。 这种方法在语义上相当于nextAfter(d, Double.NEGATIVE_INFINITY) ; 但是，一个nextDown实现可能比其等效的nextAfter调用运行得更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果参数为负无穷大，则结果为负无穷大。
        • 如果参数为零，结果为-Double.MIN_VALUE
        参数
        d - 起始浮点值
        结果
        相邻浮点值接近负无穷大。
        从以下版本开始：
        1.8

      • nextDown

        public static float nextDown​(float f)
        在负无穷大的方向上返回与f相邻的浮点值。 这种方法在语义上相当于nextAfter(f, Float.NEGATIVE_INFINITY) ; 然而，一个nextDown实现可能比其等效的nextAfter调用运行的更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果参数为负无穷大，则结果为负无穷大。
        • 如果参数为零，结果为-Float.MIN_VALUE
        参数
        f - 起始浮点值
        结果
        相邻浮点值接近负无穷大。
        从以下版本开始：
        1.8

      • scalb

        public static double scalb​(double d,
                           int scaleFactor)
        返回d 2 scaleFactor舍入，如同通过单个正确四舍五入的浮点乘以双重值集合的成员执行的。 有关浮点值集的讨论，请参阅Java语言规范。 如果结果的指数在Double.MIN_EXPONENT和Double.MAX_EXPONENT之间，则答案将被精确计算。 如果结果的指数大于Double.MAX_EXPONENT ，则返回无限大。 请注意，如果结果异常，则精度可能会丢失; 也就是说，当scalb(x, n)是次正常时， scalb(scalb(x, n), -n)可能不等于x 。 当结果为非NaN时，结果与d具有相同的符号。

        特殊情况：

        • 如果第一个参数是NaN，则返回NaN。
        • 如果第一个参数为无穷大，则返回相同符号的无穷大。
        • 如果第一个参数为零，则返回相同符号的零。
        参数
        d - d两个幂来缩放的数字。
        scaleFactor - 2的功率用于缩放 d
        结果
        d 2 scaleFactor
        从以下版本开始：
        1.6

      • scalb

        public static float scalb​(float f,
                          int scaleFactor)
        返回f 2 scaleFactor四舍五入就好像由一个正确圆形的浮点数乘以浮点值的一个成员。 有关浮点值集的讨论，请参阅Java语言规范。 如果结果的指数在Float.MIN_EXPONENT和Float.MAX_EXPONENT之间，那么答案是准确计算的。 如果结果的指数大于Float.MAX_EXPONENT ，则返回无穷大。 请注意，如果结果异常，则精度可能会丢失; 也就是说，当scalb(x, n)是次正常时， scalb(scalb(x, n), -n)可能不等于x 。 当结果为非NaN时，结果与f具有相同的符号。

        特殊情况：

        • 如果第一个参数是NaN，则返回NaN。
        • 如果第一个参数为无穷大，则返回相同符号的无穷大。
        • 如果第一个参数为零，则返回相同符号的零。
        参数
        f - f两个幂来缩放的数字。
        scaleFactor - 2的功率用于缩放 f
        结果
        f 2 scaleFactor
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Module (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Module

  • java.lang.Object
    • java.lang.Module
  • All Implemented Interfaces:
    AnnotatedElement

    public final class Module
extends Object
implements AnnotatedElement
    代表一个运行时模块，无论是named还是未命名的。

    命名的模块有一个name ，并由Java虚拟机构建时，将模块图定义为Java虚拟机以创建一个module layer 。

    未命名的模块没有名称。 每个ClassLoader都有一个未命名的模块，通过调用其getUnnamedModule方法获得。 不在命名模块中的所有类型都是其定义类加载器的未命名模块的成员。

    作为参数或由此类定义的方法返回的包名称是The Java™ Language Specification第6.5.3节中定义的包的完全限定名称，例如"java.lang" 。

    除非另有说明，否则将null参数传递给null中的方法将导致抛出NullPointerException 。

    从以下版本开始：
    9
    另请参见：
    Class.getModule()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Module addExports​(String pn, Module other)
      如果调用者的模块是此模块，则更新此模块以将给定的包导出到给定的模块。
      Module addOpens​(String pn, Module other)
      如果该模块已经至少 打开了一个包到调用者模块，然后更新该模块以将包打开到给定的模块。
      Module addReads​(Module other)
      如果调用者的模块是该模块，则更新该模块以读取给定的模块。
      Module addUses​(Class<?> service)
      如果调用者模块是此模块，则更新此模块以添加对给定服务类型的服务依赖。
      boolean canRead​(Module other)
      指示此模块是否读取给定的模块。
      boolean canUse​(Class<?> service)
      指示此模块是否具有对给定服务类型的服务依赖性。
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getAnnotations​()
      返回此元素上 存在的注释。
      ClassLoader getClassLoader​()
      返回此模块的 ClassLoader 。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      ModuleDescriptor getDescriptor​()
      如果此模块是未命名模块，则返回此模块的模块描述符或 null 。
      ModuleLayer getLayer​()
      如果此模块不在模块层中，则返回包含此模块的模块层或 null 。
      String getName​()
      如果此模块是未命名的模块，则返回模块名称或 null 。
      Set<String> getPackages​()
      返回此模块中软件包的软件包名称集。
      InputStream getResourceAsStream​(String name)
      返回用于读取此模块中资源的输入流。
      boolean isExported​(String pn)
      如果此模块无条件导出给定的包，则返回 true 。
      boolean isExported​(String pn, Module other)
      如果此模块将给定的包导出至少给定的模块，则返回 true 。
      boolean isNamed​()
      如果此模块是命名模块，则返回 true 。
      boolean isOpen​(String pn)
      如果此模块无条件 打开包，则返回 true 。
      boolean isOpen​(String pn, Module other)
      如果此模块至少 打开了给定的模块，则返回 true 。
      String toString​()
      返回此模块的字符串表示形式。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • isNamed

        public boolean isNamed​()
        如果此模块是命名模块，则返回 true 。
        结果
        true如果这是一个命名的模块
        另请参见：
        ClassLoader.getUnnamedModule()

      • getName

        public String getName​()
        如果此模块是未命名模块，则返回模块名称或 null 。
        结果
        模块名称

      • getClassLoader

        public ClassLoader getClassLoader​()
        返回此模块的ClassLoader 。

        如果有一个安全管理器，那么它的checkPermission方法，如果首先调用一个RuntimePermission("getClassLoader")权限来检查调用者是否被允许访问类加载器。

        结果
        该模块的类加载器
        异常
        SecurityException - 如果安全经理否认

      • getDescriptor

        public ModuleDescriptor getDescriptor​()
        如果此模块是未命名的模块，则返回此模块的模块描述符或 null 。
        结果
        该模块的模块描述符

      • getLayer

        public ModuleLayer getLayer​()
        如果此模块不在模块层中，则返回包含此模块的模块层或null 。 模块层包含命名的模块，因此当在未命名模块上调用时，此方法总是返回null 。

        Dynamic modules是在运行时生成的命名模块。 动态模块可以是模块层也可以不在模块层中。

        结果
        包含此模块的模块层
        另请参见：
        Proxy

      • canRead

        public boolean canRead​(Module other)
        指示此模块是否读取给定的模块。 如果调用此方法测试此模块是否读取本身，则此方法返回true 。 如果在未命名的模块上调用（ true命名的模块读取所有模块），它也会返回true 。
        参数
        other - 另一个模块
        结果
        true如果此模块读取 other
        另请参见：
        addReads(Module)

      • addReads

        public Module addReads​(Module other)
        如果调用者的模块是该模块，则更新该模块以读取给定的模块。 此方法是一种无操作如果other是此模块（所有模块读本身），这个模块未命名的模块（如模块无名读所有模块），或者该模块已经读取other 。
        Implementation Note:
        读取通过此方法添加的 边缘 较弱，并且不可阻止当该模块强力可达时，将其 other为 other 。
        参数
        other - 另一个模块
        结果
        这个模块
        异常
        IllegalCallerException - 如果这是一个命名模块，并且调用者的模块不是此模块
        另请参见：
        canRead(java.lang.Module)

      • isExported

        public boolean isExported​(String pn,
                          Module other)
        如果此模块将给定的包导出到至少给定的模块，则返回true 。

        如果调用此方法来测试此模块中的包是否导出到本身，则此方法返回true 。 当在未命名的模块上调用时，它总是返回true 。 给定模块的一个包是open被认为是在运行时导出到该模块，因此如果程序包对给定的模块打开，该方法返回true 。

        该方法不检查给定的模块是否读取此模块。

        参数
        pn - 包名称
        other - 另一个模块
        结果
        true如果此模块将包至少导出给定的模块
        另请参见：
        ModuleDescriptor.exports() ， addExports(String,Module)

      • isOpen

        public boolean isOpen​(String pn,
                      Module other)
        返回true如果这个模块已经开了一个包至少给定的模块。

        如果调用此方法测试此模块中的包是否对其自身打开，则此方法返回true 。 在模块中使用包装的open模块调用时，它返回true 。 当在未命名的模块上调用时，它总是返回true 。

        该方法不检查给定的模块是否读取此模块。

        参数
        pn - 包名称
        other - 另一个模块
        结果
        true如果该模块已经 打开包至少给定的模块
        另请参见：
        ModuleDescriptor.opens() ， addOpens(String,Module) ， AccessibleObject#setAccessible(boolean) ， MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • isExported

        public boolean isExported​(String pn)
        如果此模块无条件导出给定的包，则返回true 。

        当在未命名的模块上调用时，此方法总是返回true 。 一个无条件的包是opened，在运行时无条件导出，所以如果程序包无条件地打开，这个方法返回true 。

        该方法不检查给定的模块是否读取此模块。

        参数
        pn - 包名称
        结果
        true如果此模块无条件导出包
        另请参见：
        ModuleDescriptor.exports()

      • isOpen

        public boolean isOpen​(String pn)
        如果此模块无条件打开包，则返回true 。

        当在未命名的模块上调用时，此方法总是返回true 。 此外，当在模块中使用包装的open模块调用时，它总是返回true 。

        该方法不检查给定的模块是否读取此模块。

        参数
        pn - 包名称
        结果
        true如果该模块无条件 打开软件包
        另请参见：
        ModuleDescriptor.opens()

      • addExports

        public Module addExports​(String pn,
                         Module other)
        如果调用者的模块是此模块，则更新此模块以将给定的包导出到给定的模块。

        如果程序包已经导出（或打开 ）给给定的模块，则此方法不起作用。

        API Note:
        如 The Java™ Virtual Machine Specification第5.4.3节所述，如果由于链接错误而尝试解析符号引用失败，则解析引用的后续尝试将始终失败，因为初始解析尝试导致抛出的错误。
        参数
        pn - 包名称
        other - 模块
        结果
        这个模块
        异常
        IllegalArgumentException - 如果 pn是 null ，或者这是一个命名模块，并且包 pn不是此模块中的包
        IllegalCallerException - 如果这是一个命名模块，并且调用者的模块不是此模块
        另请参见：
        isExported(String,Module)
        See The Java™ Virtual Machine Specification:
        5.4.3决议

      • addOpens

        public Module addOpens​(String pn,
                       Module other)
        如果该模块已经至少打开了一个包到调用者模块，然后更新该模块以将包打开到给定的模块。 使用此方法打开包可以允许包中的所有类型，并且其所有成员（不仅仅是公共类型及其公共成员）在使用支持私有访问的API或绕过或抑制默认方式时被给定模块反映出来Java语言访问控制检查。

        如果包已经打开给定模块，则此方法不起作用。

        API Note:
        此方法可用于消费者模块使用限定打开以将包打包到API模块的情况，但是将消费者模块中的类成员的反射访问委托给另一个模块中的代码。 API模块中的代码可以使用此方法将消费者模块中的包打开到另一个模块。
        参数
        pn - 包名称
        other - 模块
        结果
        这个模块
        异常
        IllegalArgumentException - 如果 pn是 null ，或者这是一个命名模块，并且包 pn不是此模块中的包
        IllegalCallerException - 如果这是一个命名的模块，并且该模块至少没有打开包到主叫方的模块
        另请参见：
        isOpen(String,Module) ， AccessibleObject#setAccessible(boolean) ， MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • addUses

        public Module addUses​(Class<?> service)
        如果调用者模块是此模块，则更新此模块以添加对给定服务类型的服务依赖。 该方法适用于代表其他模块调用ServiceLoader的框架，或者框架通过其他代码传递给服务类型的引用。 在未命名的模块或自动模块上调用时，此方法是无操作的。

        此方法不会导致resolveAndBind重新运行。

        参数
        service - 服务类型
        结果
        这个模块
        异常
        IllegalCallerException - 如果这是一个命名模块，并且调用者的模块不是此模块
        另请参见：
        canUse(Class) ， ModuleDescriptor.uses()

      • canUse

        public boolean canUse​(Class<?> service)
        指示此模块是否具有对给定服务类型的服务依赖性。 当在未命名的模块或自动模块上调用时，此方法总是返回true 。
        参数
        service - 服务类型
        结果
        true如果此模块使用服务类型 st
        另请参见：
        addUses(Class)

      • getPackages

        public Set<String> getPackages​()
        返回此模块中软件包的软件包名称集。

        对于命名模块，返回的集合包含模块中每个包的元素。

        对于未命名的模块，此方法相当于调用此模块的类加载器的getDefinedPackages方法并返回一组包名称。

        结果
        该模块中包的包名称集

      • getAnnotation

        public <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        返回该元素的，如果这样的注释，否则返回null指定类型的注释。 该方法在未命名的模块上调用时返回null 。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        参数类型
        T - 查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null

      • getAnnotations

        public Annotation[] getAnnotations​()
        返回此元素上存在的注释。 如果没有存在于此元素上注解，返回值是长度为0这种方法的调用者可以随意修改返回的数组的数组; 它将对返回给其他调用者的数组没有影响。 此方法在未命名的模块上调用时返回一个空数组。
        Specified by:
        getAnnotations在接口 AnnotatedElement
        结果
        此元素上出现的注释

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。 此方法在未命名的模块上调用时返回一个空数组。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        结果
        此元素上直接显示的注释

      • getResourceAsStream

        public InputStream getResourceAsStream​(String name)
                                throws IOException
        返回用于读取此模块中资源的输入流。 name参数是标识资源的'/'路径名。 与Class.getResourceAsStream一样 ，该方法委托给模块的类加载器findResource(String,String)方法，使用模块名称调用它（或者当模块未命名时为null ）和资源的名称。 如果资源名称具有主导斜杠，则在委派之前将其删除。

        命名模块中的资源可能被封装，以便它不能被其他模块中的代码定位。 是否可以找到资源是否确定如下：

        • 如果资源名称以“ .class ”结尾，则不会被封装。
        • 包名称是从资源名称派生的。 如果软件包名称是模块中的一个package ，那么当软件包至少为主叫方的模块时，资源只能由该方法的调用者定位。 如果资源不在模块中的包中，则资源不被封装。

        在上文中，对资源包的名称是从最后一个之前的字符的子序列衍生'/'在名称，然后替换每个'/'与在子序列字符'.' 。 导出包名时，将忽略主斜杠。 作为示例，为名称为“ a/b/c/foo.properties ”的资源导出的包名称为“ a.b.c ”。 名称为“ META-INF/MANIFEST.MF ”的资源名称不会被封装，因为“ META-INF ”不是合法的包名称。

        如果资源不在此模块中，则该方法返回null ，资源被封装，并且调用者无法找到该资源，或者访问资源被安全管理器拒绝。

        参数
        name - 资源名称
        结果
        用于读取资源的输入流或 null
        异常
        IOException - 如果发生I / O错误
        另请参见：
        Class.getResourceAsStream(String)

      • toString

        public String toString​()
        返回此模块的字符串表示形式。 对于一个命名模块，表示是字符串"module" ，后跟一个空格，然后是模块名称。 对于一个未命名的模块，表示是字符串"unnamed module" ，后跟一个空格，然后是一个实现特定的字符串，标识未命名的模块。
        重写：
        toString在 Object
        结果
        该模块的字符串表示形式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleLayer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ModuleLayer

  • java.lang.Object
    • java.lang.ModuleLayer

  • public final class ModuleLayer
extends Object
    Java虚拟机中的一层模块。

    从Configuration中的模块图形创建一个图层，并将每个模块映射到一个ClassLoader 。 创建一个层可以向Java虚拟机通知可能从模块加载的类，以便Java虚拟机知道每个类是哪一个模块。

    创建图层将为配置中的每个ResolvedModule创建一个Module对象。 对于每个解决模块是read时， Module reads相应的运行时Module ，其可以是在同一层或parent层。

    defineModulesWithOneLoader和defineModulesWithManyLoaders方法提供了创建模块层的方便方法，其中所有模块都映射到单个类加载器或每个模块映射到其自己的类加载器。 defineModules方法用于通过对该方法指定的函数将模块映射到自定义类加载器的更高级情况。 这些方法中的每一个都有一个实例和静态变体。 实例方法创建一个层，接收方作为父层。 静态方法适用于可能有多于一个父层或需要Controller来控制层中的模块的更高级情况

    Java虚拟机至少有一个非空层，即在启动Java虚拟机时创建的boot层。 引导层包含模块java.base ，是Java虚拟机中唯一一个名为“ java.base ”模块的层。 引导层中的模块映射到引导类加载器和其他类型加载器，它们是built-in到Java虚拟机中。 创建附加图层时，引导层通常将为parent 。

    每个Module中的一个图层是创建的，因此它的exports和opens由其描述的包装ModuleDescriptor 。 在创建图层时，合格的导出（其中将软件包导出到一组目标模块而不是所有模块）被归纳如下：

    • 如果模块X将软件包导出到Y ，如果运行时Module X读取Module Y ，则软件包将导出为Module Y （可能与X或父层相同）。
    • 如果模块X将包导出到Y ，并且如果运行时Module X未读取Y则目标Y位于仿佛通过调用findModule以查找该层或其父层中的模块。 如果找到了Y ，那么包将被导出到找到的Y的实例。 如果Y那么合格的导出将被忽略。

    合格的打开以与合格出口相同的方式处理。

    当创建Configuration ， automatic模块在创建图层时会受到特殊处理。 自动模块在Java虚拟机中创建为Module ，它读取Java虚拟机中的每个未命名的Module 。

    除非另有说明，否则将null参数传递给null中的方法将导致抛出NullPointerException 。

    使用示例

    此示例通过解析名为“ myapp ”的模块来创建配置，引导层的配置为父级。 然后在此配置中使用模块创建一个新层。 所有模块都定义为同一个类加载器。

       ModuleFinder finder = ModuleFinder.of(dir1, dir2, dir3); ModuleLayer parent = ModuleLayer.boot(); Configuration cf = parent.configuration().resolve(finder, ModuleFinder.of(), Set.of("myapp")); ClassLoader scl = ClassLoader.getSystemClassLoader(); ModuleLayer layer = parent.defineModulesWithOneLoader(cf, scl); Class<?> c = layer.findLoader("myapp").loadClass("app.Main");
    从以下版本开始：
    9
    另请参见：
    Module.getLayer()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ModuleLayer.Controller
      控制模块层。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static ModuleLayer boot​()
      返回引导层。
      Configuration configuration​()
      返回此图层的配置。
      ModuleLayer defineModules​(Configuration cf, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      ModuleLayer defineModulesWithManyLoaders​(Configuration cf, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller defineModulesWithManyLoaders​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过在给定的Java虚拟机的 Configuration定义模块来创建新的模块层。
      ModuleLayer defineModulesWithOneLoader​(Configuration cf, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller defineModulesWithOneLoader​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static ModuleLayer empty​()
      返回 空层。
      ClassLoader findLoader​(String name)
      返回具有给定名称的模块的 ClassLoader 。
      Optional<Module> findModule​(String name)
      在此层中返回具有给定名称的模块，或者如果不在此层中，则 返回parent层。
      Set<Module> modules​()
      返回此图层中的模块集。
      List<ModuleLayer> parents​()
      返回此图层的父母的列表，除非是 empty layer ，它没有父母，因此返回空列表。
      String toString​()
      返回描述此模块层的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • defineModulesWithOneLoader

        public ModuleLayer defineModulesWithOneLoader​(Configuration cf,
                                              ClassLoader parentLoader)
        通过将给定的Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。 该方法创建一个类加载器并将所有模块定义到该类加载器。 每个类加载器的parent是给定的父类加载器。 当该层作为父级调用时，此方法的工作原理与静态的defineModulesWithOneLoader方法所指定。 换句话说，如果这个层是thisLayer那么这个方法就等于调用：
           ModuleLayer.defineModulesWithOneLoader(cf, List.of(thisLayer), parentLoader).layer();
        参数
        cf - 图层的配置
        parentLoader - 通过此方法创建的类加载器的父类加载器; 可以是引导类加载器的null
        结果
        新创建的图层
        异常
        IllegalArgumentException - 如果给定配置的父 IllegalArgumentException不是此层的配置
        LayerInstantiationException - 如果由静态 defineModulesWithOneLoader方法指定的任何原因无法创建 defineModulesWithOneLoader
        SecurityException - 如果 RuntimePermission("createClassLoader")或 RuntimePermission("getClassLoader")被安全管理员拒绝
        另请参见：
        findLoader(java.lang.String)

      • defineModulesWithManyLoaders

        public ModuleLayer defineModulesWithManyLoaders​(Configuration cf,
                                                ClassLoader parentLoader)
        通过将给定的Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。 每个模块都被定义为它自己的ClassLoader创建的这种方法。 每个类加载器的parent是给定的父类加载器。 当以此层作为父类调用时，此方法与静态的defineModulesWithManyLoaders方法一样工作。 换句话说，如果这个层是thisLayer那么这个方法就等于调用：
           ModuleLayer.defineModulesWithManyLoaders(cf, List.of(thisLayer), parentLoader).layer();
        参数
        cf - 层的配置
        parentLoader - 通过此方法创建的每个类加载器的父类加载器; 可以是引导类加载器的null
        结果
        新创建的图层
        异常
        IllegalArgumentException - 如果给定配置的父级不是此层的配置
        LayerInstantiationException - 如果由静态 defineModulesWithManyLoaders方法指定的任何原因无法创建 defineModulesWithManyLoaders
        SecurityException - 如果 RuntimePermission("createClassLoader")或 RuntimePermission("getClassLoader")被安全管理员拒绝
        另请参见：
        findLoader(java.lang.String)

      • defineModules

        public ModuleLayer defineModules​(Configuration cf,
                                 Function<String,ClassLoader> clf)
        通过将给定的Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。 每个模块通过给定的功能按名称映射到其类加载器。 当以此层作为父级调用时，此方法的工作原理与静态的defineModules方法一样。 换句话说，如果这个层是thisLayer那么这个方法相当于调用：
           ModuleLayer.defineModules(cf, List.of(thisLayer), clf).layer();
        参数
        cf - 图层的配置
        clf - 将模块名称映射到类加载器的功能
        结果
        新创建的图层
        异常
        IllegalArgumentException - 如果给定配置的父 IllegalArgumentException不是此层的配置
        LayerInstantiationException - 如果由静态 defineModules方法指定的任何原因无法创建 defineModules
        SecurityException - 如果安全管理员拒绝了 RuntimePermission("getClassLoader")

      • defineModulesWithOneLoader

        public static ModuleLayer.Controller defineModulesWithOneLoader​(Configuration cf,
                                                                List<ModuleLayer> parentLayers,
                                                                ClassLoader parentLoader)
        通过将给定的Configuration的模块定义到Java虚拟机来创建新的模块层。 该方法创建一个类加载器并将所有模块定义到该类加载器。

        通过此方法创建的类加载器在从模块加载类时实现直接委派 。 如果调用了loadClass方法来加载类，那么它将使用该类的包名将其映射到一个模块。 这可能是此层中的一个模块，因此定义为同一类加载器。 它可能是父层中的模块中的一个包，该包将导出到该层中的一个或多个模块。 类加载器委托给模块的类加载器，如果该类加载器找不到，则抛出ClassNotFoundException 。 当调用loadClass加载不映射到模块的类时，它将委托给父类加载器。

        通过这种方法创建的类加载器定位资源（ getResource ， getResources搜索父类加载器之前在层中的所有模块和其它资源的方法）。

        尝试创建具有定义到同一类加载器的所有模块的图层可能会失败，原因如下：

        • 重叠包 ：配置中的两个或多个模块具有相同的包。

        • 拆分委托 ：生成的类加载器需要委托给多个类加载器才能加载特定包中的类。

        另外，如果配置包含名为“ java.base ”的模块，或模块包含名为“ java ”的软件包或名称以“ java. ”开头的软件包，则无法创建java. 。

        如果有一个安全管理器，那么这个方法创建的类加载器将加载受该方法调用上下文限制的权限的类和资源。

        参数
        cf - 图层的配置
        parentLayers - 搜索顺序中的父层列表
        parentLoader - 通过此方法创建的类加载器的父类加载器; 可以是引导类加载器的null
        结果
        控制新创建的图层的控制器
        异常
        IllegalArgumentException - 如果父配置与父层的配置不匹配，包括顺序
        LayerInstantiationException - 如果由于上述任何原因，所有模块都不能被定义到同一个类加载器
        SecurityException - 如果 RuntimePermission("createClassLoader")或 RuntimePermission("getClassLoader")被安全管理员拒绝
        另请参见：
        findLoader(java.lang.String)

      • defineModulesWithManyLoaders

        public static ModuleLayer.Controller defineModulesWithManyLoaders​(Configuration cf,
                                                                  List<ModuleLayer> parentLayers,
                                                                  ClassLoader parentLoader)
        通过将给定的Configuration的模块定义到Java虚拟机来创建新的模块层。 每个模块都被定义为自己创建的这个方法的ClassLoader 。 每个类加载器的parent是给定的父类加载器。

        通过此方法创建的类加载器在从模块加载类时实现直接委派 。 如果调用了loadClass方法来加载类，那么它将使用该类的包名将其映射到一个模块。 该包可能在定义为类加载器的模块中。 该包可以由此层中的另一个模块导出到定义到类加载器的模块。 它可能在由父层中的模块导出的包中。 类加载器委托给模块的类加载器，如果该类加载器找不到，则抛出ClassNotFoundException 。 当调用loadClass加载不映射到模块的类时，它将委托给父类加载器。

        通过这种方法创建的类加载器定位资源（ getResource ， getResources搜索父类加载器之前定义的类加载器模块中，和其他资源的方法）。

        如果有一个安全管理器，那么这个方法创建的类加载器将加载受该方法调用上下文限制的权限的类和资源。

        参数
        cf - 图层的配置
        parentLayers - 搜索顺序中的父层列表
        parentLoader - 通过此方法创建的每个类加载器的父类加载器; 可以是引导类加载器的null
        结果
        控制新创建的图层的控制器
        异常
        IllegalArgumentException - 如果父配置与父层的配置不匹配，包括顺序
        LayerInstantiationException - 如果由于配置包含名为“ java.base ”的模块或模块包含名为“ java ”的软件包或名称以“ java. ”开头的软件包，则无法创建该图层
        SecurityException - 如果 RuntimePermission("createClassLoader")或 RuntimePermission("getClassLoader")被安全管理员拒绝
        另请参见：
        findLoader(java.lang.String)

      • defineModules

        public static ModuleLayer.Controller defineModules​(Configuration cf,
                                                   List<ModuleLayer> parentLayers,
                                                   Function<String,ClassLoader> clf)
        通过将给定的Configuration的模块定义到Java虚拟机来创建新的模块层。 给定的功能将配置中的每个模块按名称映射到类加载器。 创建图层通知Java虚拟机有关可能加载的类，以便Java虚拟机知道每个类是其成员的哪个模块。

        类加载器实现的类装载器委派必须遵守模块的可读性。 类加载器应为parallel-capable ，以避免在加载类时出现死锁。 此外，使用此方法创建新层的实体应该安排在加载类或资源的任何尝试之前，类加载器都可以从这些模块加载。

        创建图层可能会失败，原因如下：

        • 具有相同包的两个或多个模块映射到相同的类加载器。

        • 一个模块被映射到已经具有与其定义的相同名称的模块的类加载器。

        • 模块被映射到在模块中的任何包中已经定义了类型的类加载器。

        此外，一个层不能如果配置包含一个名为模块创建“ java.base ”时，配置包含与命名封装的模块“ java ”或包名称开头“ java. ”，或功能的模块名称映射到一个类加载器返回null或platform class loader 。

        如果将模块名称映射到类加载器的功能会引发错误或运行时异常，则将其传播给此方法的调用者。

        API Note:
        关于使用此方法创建图层是否为原子操作的具体实现方式。 因此，这种方法有可能失败，并为Java虚拟机定义了一些模块，但不是全部。
        参数
        cf - 图层的配置
        parentLayers - 搜索顺序中的父层列表
        clf - 将模块名称映射到类加载器的功能
        结果
        控制新创建的图层的控制器
        异常
        IllegalArgumentException - 如果父配置与父层的配置不匹配，包括顺序
        LayerInstantiationException - 如果由于上述任何原因创建图层失败
        SecurityException - 如果安全管理员拒绝了 RuntimePermission("getClassLoader")

      • configuration

        public Configuration configuration​()
        返回此图层的配置。
        结果
        该层的配置

      • parents

        public List<ModuleLayer> parents​()
        返回此图层的父母的列表，除非是 empty layer ，它没有父母，因此返回空列表。
        结果
        这一层的父母的名单

      • modules

        public Set<Module> modules​()
        返回此图层中的模块集。
        结果
        这个层可能是空的不可修改的模块集

      • findModule

        public Optional<Module> findModule​(String name)
        在此层中返回具有给定名称的模块，或者如果不在此层中，则返回parent层。 在父层中查找模块等同于以搜索顺序为每个父项调用findModule ，直到找到该模块或者已经搜索了所有父母。 在一层树中，这相当于深度优先搜索。
        参数
        name - 要查找的模块的名称
        结果
        具有给定名称的模块或空的 Optional如果在该层或任何父层中没有此名称的模块

      • findLoader

        public ClassLoader findLoader​(String name)
        返回具有给定名称的模块的ClassLoader 。 如果给定的名字的一个模块是不是在该层则parent层中搜索在由指定的方式findModule 。

        如果有一个安全管理员，那么它的checkPermission方法被调用一个RuntimePermission("getClassLoader")权限来检查调用者是否被允许访问类加载器。

        API Note:
        此方法不返回 Optional<ClassLoader>因为`null`必须用于表示引导类加载器。
        参数
        name - 要查找的模块的名称
        结果
        该模块被定义为的ClassLoader
        异常
        IllegalArgumentException - 如果该层或该层的任何父层没有定义给定名称的模块
        SecurityException - 如果安全管理员否认

      • toString

        public String toString​()
        返回描述此模块层的字符串。
        重写：
        toString在 Object
        结果
        描述此模块层的可能空字符串

      • empty

        public static ModuleLayer empty​()
        返回空层。 空层中没有模块。 没有父母
        结果
        空层

      • boot

        public static ModuleLayer boot​()
        返回引导层。 引导层至少包含一个模块java.base 。 它的父母是empty层。
        API Note:
        此方法在启动期间和引导层完全初始化之前返回 null 。
        结果
        The boot layer
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleLayer.Controller (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ModuleLayer.Controller

  • java.lang.Object
    • java.lang.ModuleLayer.Controller
  • Enclosing class:
    ModuleLayer

    public static final class ModuleLayer.Controller
extends Object
    控制模块层。 由ModuleLayer定义的创建模块层的静态方法返回一个Controller ，可用于控制图层中的模块。

    除非另有说明，否则将null参数传递给null中的方法将导致抛出NullPointerException 。

    API Note:
    应注意 Controller对象，不应该与不受信任的代码共享。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ModuleLayer.Controller addExports​(Module source, String pn, Module target)
      更新模块 source在图层中导出包到模块 target 。
      ModuleLayer.Controller addOpens​(Module source, String pn, Module target)
      更新模块 source在图层中打开一个包到模块 target 。
      ModuleLayer.Controller addReads​(Module source, Module target)
      更新模块 source在图层中读取模块 target 。
      ModuleLayer layer​()
      返回此对象控制的图层。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • layer

        public ModuleLayer layer​()
        返回此对象控制的图层。
        结果
        模块层

      • addReads

        public ModuleLayer.Controller addReads​(Module source,
                                       Module target)
        更新模块source在图层中读取模块target 。 如果source已经读取target此方法是target 。
        Implementation Note:
        读取通过此方法添加的 边缘 较弱，并且不能阻止 target在 source强烈可达时被GC'ed。
        参数
        source - 源模块
        target - 要读取的目标模块
        结果
        这个控制器
        异常
        IllegalArgumentException - 如果 source不在模块层
        另请参见：
        Module.addReads(java.lang.Module)

      • addExports

        public ModuleLayer.Controller addExports​(Module source,
                                         String pn,
                                         Module target)
        更新模块source在图层中导出包到模块target 。 如果source已经将包导出至少target此方法是target 。
        参数
        source - 源模块
        pn - 包名称
        target - 目标模块
        结果
        这个控制器
        异常
        IllegalArgumentException - 如果 source不在模块层或包不在源模块中
        另请参见：
        Module.addExports(java.lang.String, java.lang.Module)

      • addOpens

        public ModuleLayer.Controller addOpens​(Module source,
                                       String pn,
                                       Module target)
        更新模块source在图层中打开一个包到模块target 。 这种方法是无操作的，如果source已经打开包至少target 。
        参数
        source - 源模块
        pn - 包名称
        target - 目标模块
        结果
        这个控制器
        异常
        IllegalArgumentException - 如果 source不在模块层或包不在源模块中
        另请参见：
        Module.addOpens(java.lang.String, java.lang.Module)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NegativeArraySizeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NegativeArraySizeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.NegativeArraySizeException
  • All Implemented Interfaces:
    Serializable

    public class NegativeArraySizeException
extends RuntimeException
    抛出一个应用程序尝试创建一个负数大小的数组。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NegativeArraySizeException​()
      构造一个 NegativeArraySizeException ，没有详细消息。
      NegativeArraySizeException​(String s)
      构造具有指定详细消息的 NegativeArraySizeException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NegativeArraySizeException

        public NegativeArraySizeException​()
        构造一个 NegativeArraySizeException ，没有详细信息。

      • NegativeArraySizeException

        public NegativeArraySizeException​(String s)
        构造具有指定详细消息的 NegativeArraySizeException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NoClassDefFoundError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NoClassDefFoundError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.NoClassDefFoundError
  • All Implemented Interfaces:
    Serializable

    public class NoClassDefFoundError
extends LinkageError
    如果Java虚拟机或ClassLoader实例尝试加载类的定义（作为普通方法调用的一部分或作为使用new表达式创建新实例的new ），则new并且不能找到该类的定义。

    搜索的类定义存在于当前正在执行的类被编译时，但不能再找到该定义。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoClassDefFoundError​()
      构造一个 NoClassDefFoundError ，没有详细信息。
      NoClassDefFoundError​(String s)
      构造具有指定详细消息的 NoClassDefFoundError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoClassDefFoundError

        public NoClassDefFoundError​()
        构造一个 NoClassDefFoundError ，没有详细消息。

      • NoClassDefFoundError

        public NoClassDefFoundError​(String s)
        构造具有指定详细消息的 NoClassDefFoundError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NoSuchFieldError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NoSuchFieldError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.IncompatibleClassChangeError
            • java.lang.NoSuchFieldError
  • All Implemented Interfaces:
    Serializable

    public class NoSuchFieldError
extends IncompatibleClassChangeError
    如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。

    通常，该错误被编译器捕获; 此错误只能在运行时发生，如果类的定义已经不相容地更改。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchFieldError​()
      构造一个 NoSuchFieldError ，没有详细消息。
      NoSuchFieldError​(String s)
      构造具有指定详细消息的 NoSuchFieldError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchFieldError

        public NoSuchFieldError​()
        构造一个没有详细消息的 NoSuchFieldError 。

      • NoSuchFieldError

        public NoSuchFieldError​(String s)
        构造具有指定详细消息的 NoSuchFieldError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NoSuchFieldException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NoSuchFieldException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.ReflectiveOperationException
          • java.lang.NoSuchFieldException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchFieldException
extends ReflectiveOperationException
    表示该类没有指定名称的字段。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchFieldException​()
      构造函数。
      NoSuchFieldException​(String s)
      具有详细消息的构造方法。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchFieldException

        public NoSuchFieldException​()
        构造函数。

      • NoSuchFieldException

        public NoSuchFieldException​(String s)
        具有详细消息的构造方法。
        参数
        s - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NoSuchMethodError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NoSuchMethodError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.IncompatibleClassChangeError
            • java.lang.NoSuchMethodError
  • All Implemented Interfaces:
    Serializable

    public class NoSuchMethodError
extends IncompatibleClassChangeError
    如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。

    通常，该错误被编译器捕获; 此错误只能在运行时发生，如果类的定义已经不相容地更改。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchMethodError​()
      构造一个 NoSuchMethodError ，没有详细消息。
      NoSuchMethodError​(String s)
      构造具有指定详细消息的 NoSuchMethodError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchMethodError

        public NoSuchMethodError​()
        构造一个 NoSuchMethodError ，没有详细信息。

      • NoSuchMethodError

        public NoSuchMethodError​(String s)
        构造具有指定详细消息的 NoSuchMethodError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NoSuchMethodException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NoSuchMethodException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.ReflectiveOperationException
          • java.lang.NoSuchMethodException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchMethodException
extends ReflectiveOperationException
    当无法找到特定方法时抛出。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoSuchMethodException​()
      构造一个 NoSuchMethodException没有详细消息。
      NoSuchMethodException​(String s)
      构造一个 NoSuchMethodException的详细消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoSuchMethodException

        public NoSuchMethodException​()
        构造一个 NoSuchMethodException没有详细信息。

      • NoSuchMethodException

        public NoSuchMethodException​(String s)
        构造一个 NoSuchMethodException的详细信息。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NullPointerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NullPointerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.NullPointerException
  • All Implemented Interfaces:
    Serializable

    public class NullPointerException
extends RuntimeException
    当应用程序在需要对象的情况下尝试使用null时抛出。 这些包括：
    • 调用一个null对象的实例方法。
    • 访问或修改null对象的字段。
    • 以null的长度，好像是一个数组。
    • 访问或修改null的插槽，就像它是一个阵列一样。
    • 抛出null ，好像是一个Throwable价值。

    应用程序应该抛出此类的实例以指示其他非法使用null对象。 NullPointerException对象可以由虚拟机构建，如同suppression were disabled and/or the stack trace was not writable一样 。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NullPointerException​()
      构造一个 NullPointerException ，没有详细信息。
      NullPointerException​(String s)
      构造具有指定详细消息的 NullPointerException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NullPointerException

        public NullPointerException​()
        构造一个 NullPointerException ，没有详细消息。

      • NullPointerException

        public NullPointerException​(String s)
        构造具有指定详细消息的 NullPointerException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Number (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Number

  • java.lang.Object
    • java.lang.Number
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AtomicInteger ， AtomicLong ， BigDecimal ， BigInteger ， Byte ， Double ， DoubleAccumulator ， DoubleAdder ， Float ， Integer ， Long ， LongAccumulator ， LongAdder ， Short

    public abstract class Number
extends Object
implements Serializable
    抽象类Number是表示数字值可转换为基本数据类型平台类的超类byte ， double ， float ， int ， long ，和short 。 从特定的Number实现的数值到给定的基元类型的转换的具体语义由所Number实现定义。 对于平台类，转换通常类似于The Java™ Language Specification中定义的缩小原语转换或扩展原语转换，用于在原始类型之间进行转换。 因此，转换可能会丢失有关数值的总体大小的信息，可能会失去精度，甚至可能会返回与输入不同的符号结果。 有关转换详情，请参阅给定的Number实现的文档。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form
    See The Java™ Language Specification:
    5.1.2扩大原始转换，5.1.3缩小原始转换

    • 构造方法摘要

      构造方法
      Constructor 描述
      Number​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      byte byteValue​()
      返回指定数字的值作为 byte 。
      abstract double doubleValue​()
      返回指定数字的值作为 double 。
      abstract float floatValue​()
      返回指定数字的值作为 float 。
      abstract int intValue​()
      返回指定数字的值作为 int 。
      abstract long longValue​()
      返回指定数字的值作为 long 。
      short shortValue​()
      返回指定数字的值作为 short 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Number

        public Number​()

    • 方法详细信息

      • intValue

        public abstract int intValue​()
        返回指定数字的值作为 int 。
        结果
        该对象在转换为 int之后表示的数值。

      • longValue

        public abstract long longValue​()
        返回指定数字的值作为 long 。
        结果
        该对象在转换为 long之后表示的数值。

      • floatValue

        public abstract float floatValue​()
        返回指定数字的值作为 float 。
        结果
        该对象在转换为 float之后表示的数值。

      • doubleValue

        public abstract double doubleValue​()
        返回指定数字的值作为 double 。
        结果
        该对象在转换为 double之后表示的数值。

      • byteValue

        public byte byteValue​()
        返回指定数字的值作为byte 。

        此实现将intValue()的结果返回给一个byte 。

        结果
        该对象在转换为 byte之后表示的数值。
        从以下版本开始：
        1.1

      • shortValue

        public short shortValue​()
        返回指定数字的值作为short 。

        此实现将intValue()的结果返回给一个short 。

        结果
        该对象在转换为 short之后表示的数值。
        从以下版本开始：
        1.1
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NumberFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class NumberFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.lang.NumberFormatException
  • All Implemented Interfaces:
    Serializable

    public class NumberFormatException
extends IllegalArgumentException
    抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
    从以下版本开始：
    1.0
    另请参见：
    Integer.parseInt(String) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NumberFormatException​()
      构造一个没有详细信息的 NumberFormatException 。
      NumberFormatException​(String s)
      构造具有指定详细消息的 NumberFormatException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NumberFormatException

        public NumberFormatException​()
        构造一个 NumberFormatException没有详细消息。

      • NumberFormatException

        public NumberFormatException​(String s)
        构造具有指定详细信息的 NumberFormatException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Object (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Object

  • java.lang.Object

  • public class Object
    类Object是类层次结构的根。 每个类都有Object作为超类。 所有对象（包括数组）都实现了这个类的方法。
    从以下版本开始：
    1.0
    另请参见：
    Class

    • 构造方法摘要

      构造方法
      Constructor 描述
      Object​()
      构造一个新对象。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected Object clone​()
      创建并返回此对象的副本。
      boolean equals​(Object obj)
      指示一些其他对象是否等于此。
      protected void finalize​()
      已过时。
      定稿机制本质上是有问题的。 定稿可能导致性能问题，死锁和挂起。 敲定错误可能导致资源泄漏; 如果不再需要，无法取消定稿; 并且在不同对象的finalize方法的调用中没有指定排序。 此外，关于定稿的时间并不保证。 只有在无限期延迟之后，才能在可终止对象上调用finalize方法（如果有的话）。 其实例持有非堆资源的类应提供一种方法来实现这些资源的显式释放，如果合适，它们还应实现AutoCloseable 。 当对象变得不可达时， Cleaner和PhantomReference提供了更灵活和更有效的方式来释放资源。
      Class<?> getClass​()
      返回此 Object的运行时类。
      int hashCode​()
      返回对象的哈希码值。
      void notify​()
      唤醒正在等待对象监视器的单个线程。
      void notifyAll​()
      唤醒正在等待对象监视器的所有线程。
      String toString​()
      返回对象的字符串表示形式。
      void wait​()
      导致当前线程等待，直到另一个线程调用该对象的 notify()方法或 notifyAll()方法。
      void wait​(long timeout)
      导致当前线程等待，直到另一个线程调用该对象的 notify()方法或 notifyAll()方法，或指定的时间已过。
      void wait​(long timeout, int nanos)
      导致当前线程等待，直到另一个线程调用该对象的 notify()方法或 notifyAll()方法，或者某些其他线程中断当前线程，或者已经过了一定量的实时时间。

    • 构造方法详细信息

      • Object

        public Object​()
        构造一个新对象。

    • 方法详细信息

      • getClass

        public final Class<?> getClass​()
        返回此Object的运行时类。 返回的Class对象是被表示类的static synchronized方法锁定的对象。

        实际的结果类型是Class<? extends |X|> ，其中|X|是被称为getClass的表达式的静态类型的擦除。 例如，在此代码片段中不需要转换：

        Number n = 0;
        Class<? extends Number> c = n.getClass();

        结果
        表示该对象的运行时类的 Class对象。
        See The Java™ Language Specification:
        15.8.2类文字

      • hashCode

        public int hashCode​()
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次调用同一对象， hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据equals(java.lang.Object)方法不相等，则在两个对象中的每一个上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        结果
        该对象的哈希码值。
        另请参见：
        equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        指示一些其他对象是否等于此。

        equals方法在非空对象引用上实现等价关系：

        • 自反性 ：对于任何非空的参考值x ， x.equals(x)应该返回true 。
        • 它是对称的 ：对于任何非空引用值x和y ， x.equals(y)应该返回true当且仅当y.equals(x)回报true 。
        • 传递性 ：对于任何非空引用值x ， y ，并z ，如果x.equals(y)回报true和y.equals(z)回报true ，然后x.equals(z)应该返回true 。
        • 它是一致的 ：对于任何非空参考值x和y ，多重调用x.equals(y)一致返回true或一致返回false ，前提是在equals对对象进行比较的信息被修改。
        • 对于任何非空的参考值x ， x.equals(null)应该返回false 。

        该equals类方法Object实现对象上差别可能性最大的相等关系; 也就是说，对于任何非空参考值x和y ，当且仅当x和y引用相同对象（ x == y具有值true ）时，该方法返回true 。

        请注意，无论何时覆盖此方法，通常需要覆盖hashCode方法，以便维护hashCode方法的一般合同，该方法规定相等的对象必须具有相等的哈希码。

        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        hashCode() ， HashMap

      • clone

        protected Object clone​()
                throws CloneNotSupportedException
        创建并返回此对象的副本。 “复制”的精确含义可能取决于对象的类。 一般意图是，对于任何对象x ，表达式：
         x.clone() != x
        将是真实的，而且表达：
         x.clone().getClass() == x.getClass()
        将是true ，但这些都不是绝对的要求。 通常情况是：
         x.clone().equals(x)
        将是true ，这不是一个绝对的要求。

        按照惯例，返回的对象应该通过调用super.clone获得。 如果一个类和它的所有超类（除了Object ）遵守这个惯例，那就是x.clone().getClass() == x.getClass()的情况。

        按照惯例，此方法返回的对象应该与此对象（正被克隆）无关。 为了实现这种独立性，可能需要修改super.clone返回的对象的一个或多个字段。 通常，这意味着复制构成被克隆的对象的内部“深层结构”的任何可变对象，并通过引用该副本替换对这些对象的引用。 如果一个类仅包含原始字段或对不可变对象的引用，则通常情况下， super.clone返回的对象中的字段通常不需要修改。

        该方法clone类Object执行特定克隆操作。 首先，如果此对象的类不实现接口Cloneable ，则抛出CloneNotSupportedException 。 请注意，所有阵列被认为是实现该接口Cloneable并且所述的返回类型clone数组类型的方法T[]是T[]其中T是任何引用或原始类型。 否则，该方法将创建该对象的类的新实例，并将其所有字段初始化为该对象的相应字段的内容，就像通过赋值一样。 这些字段的内容本身不被克隆。 因此，该方法执行该对象的“浅拷贝”，而不是“深度拷贝”操作。

        类Object本身并不实现接口Cloneable ，因此在类为Object的对象上调用clone方法将导致在运行时抛出异常。

        结果
        这个实例的一个克隆。
        异常
        CloneNotSupportedException - 如果对象的类不支持Cloneable接口。 覆盖clone方法的子类也可以抛出此异常以指示实例无法克隆。
        另请参见：
        Cloneable

      • toString

        public String toString​()
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        结果
        对象的字符串表示形式。

      • notify

        public final void notify​()
        唤醒正在等待对象监视器的单个线程。 如果任何线程正在等待这个对象，其中一个被选择被唤醒。 选择是任意的，并且由实施的判断发生。 线程通过调用wait方法之一等待对象的监视器。

        唤醒的线程将无法继续，直到当前线程放弃此对象上的锁定为止。 唤醒的线程将以通常的方式与任何其他线程竞争，这些线程可能正在积极地竞争在该对象上进行同步; 例如，唤醒的线程在下一个锁定该对象的线程中没有可靠的权限或缺点。

        该方法只能由作为该对象监视器的所有者的线程调用。 线程以三种方式之一成为对象监视器的所有者：

        • 通过执行该对象的同步实例方法。
        • 通过执行在对象上同步的synchronized语句的主体。
        • 对于类型为Class,的对象，通过执行该类的同步静态方法。

        一次只能有一个线程可以拥有一个对象的显示器。

        异常
        IllegalMonitorStateException - 如果当前线程不是此对象的监视器的所有者。
        另请参见：
        notifyAll() ， wait()

      • notifyAll

        public final void notifyAll​()
        唤醒正在等待对象监视器的所有线程。 线程通过调用其中一个wait方法等待对象的监视器。

        唤醒的线程将无法继续，直到当前线程释放该对象上的锁。 唤醒的线程将以通常的方式与任何其他线程竞争，这些线程可能正在积极地竞争在该对象上进行同步; 例如，唤醒的线程在下一个锁定该对象的线程中不会有可靠的特权或缺点。

        该方法只能由作为该对象监视器的所有者的线程调用。 有关线程可以成为监视器所有者的方式的描述，请参阅notify方法。

        异常
        IllegalMonitorStateException - 如果当前线程不是此对象的监视器的所有者。
        另请参见：
        notify() ， wait()

      • wait

        public final void wait​(long timeout)
                throws InterruptedException
        导致当前线程等待，直到另一个线程调用此对象的notify()方法或notifyAll()方法，或指定的时间已过。

        当前的线程必须拥有该对象的显示器。

        此方法使当前线程（称为T ）将其放置在该对象的等待集中，然后放弃对该对象的任何和所有同步声明。 线程T变得禁用线程调度目的，并且休眠，直到发生四件事情之一：

        • 一些其他线程调用该对象的notify方法，并且线程T恰好被任意选择为被唤醒的线程。
        • 一些其他线程调用此对象的notifyAll方法。
        • 一些其他线程interrupts线程T。
        • 指定的实时数量已经过去，或多或少。 然而，如果timeout为零，则不考虑实时，并且线程等待直到通知。
        然后从该对象的等待集中删除线程T，并重新启用线程调度。 然后它以通常的方式与其他线程竞争在对象上进行同步的权限; 一旦获得了对象的控制，对对象的所有同步声明就恢复到现状 - 也就是在调用wait方法时的情况。 线程T然后从调用wait方法返回。 因此，从wait方法返回时，对象和线程T的同步状态与调用wait方法时的状态wait 。

        线程也可以唤醒，而不会被通知，中断或超时，即所谓的虚假唤醒 。 虽然这在实践中很少会发生，但应用程序必须通过测试应该使线程被唤醒的条件来防范，并且如果条件不满足则继续等待。 换句话说，等待应该总是出现在循环中，就像这样：

          synchronized (obj) {
         while (<condition does not hold>)
             obj.wait(timeout);
         ... // Perform action appropriate to condition
     }
        （有关此主题的更多信息，请参阅Brian Goetz中的第14.2节“条件队列”以及其他人在“Java并发实践”（Addison-Wesley，2006）或Joshua Bloch的“Effective Java（Second Edition）”（Addison -Wesley，2008）。

        如果当前线程在等待之前或之中任何线程是interrupted ，则抛出一个InterruptedException 。 如上所述，在该对象的锁定状态已恢复之前，不会抛出此异常。

        请注意， wait方法，因为它将当前线程放置到此对象的等待集中，仅解锁此对象; 当前线程可以同步的任何其他对象在线程等待时保持锁定。

        该方法只能由作为该对象监视器的所有者的线程调用。 有关线程可以成为监视器所有者的方法的说明，请参阅notify方法。

        参数
        timeout - 以毫秒为单位等待的最长时间。
        异常
        IllegalArgumentException - 如果超时值为负值。
        IllegalMonitorStateException - 如果当前线程不是对象监视器的所有者。
        InterruptedException - 如果任何线程在当前线程等待通知之前或当前线程中断当前线程。 当抛出此异常时，当前线程的中断状态将被清除。
        另请参见：
        notify() ， notifyAll()

      • wait

        public final void wait​(long timeout,
                       int nanos)
                throws InterruptedException
        导致当前线程等待，直到另一个线程调用该对象的notify()方法或notifyAll()方法，或其他一些线程中断当前线程或一定量的实时时间。

        这种方法类似于一个参数的wait方法，但它允许对放弃之前等待通知的时间进行更精细的控制。 以纳秒为单位的实时数量由下式给出：

         1000000*timeout+nanos

        在所有其他方面，该方法与一个参数的方法wait(long)相同。 特别是wait(0, 0)意味着同样的事情wait(0) 。

        当前的线程必须拥有该对象的显示器。 线程释放此监视器的所有权，并等待直到发生以下两种情况之一：

        • 另一个线程通知等待该对象监视器的线程通过调用notify方法或notifyAll方法notifyAll 。
        • 由timeout毫秒加上nanos纳秒参数指定的超时时间已过。

        然后线程等待，直到它可以重新获得监视器的所有权并恢复执行。

        像在一个参数版本中，中断和虚假唤醒是可能的，并且该方法应该始终在循环中使用：

          synchronized (obj) {
         while (<condition does not hold>)
             obj.wait(timeout, nanos);
         ... // Perform action appropriate to condition
     }
        该方法只能由作为该对象监视器的所有者的线程调用。 有关线程可以成为监视器所有者的方式的描述，请参阅notify方法。
        参数
        timeout - 以毫秒为单位等待的最长时间。
        nanos - 额外的时间，以纳秒范围0-999999。
        异常
        IllegalArgumentException - 如果超时值为负值或 IllegalArgumentException值不在0-999999范围内。
        IllegalMonitorStateException - 如果当前线程不是此对象的监视器的所有者。
        InterruptedException - 如果任何线程在当前线程等待通知之前或当前线程中断当前线程。 当抛出此异常时，当前线程的中断状态将被清除。

      • wait

        public final void wait​()
                throws InterruptedException
        导致当前线程等到另一个线程调用该对象的notify()方法或notifyAll()方法。 换句话说，这个方法的行为就好像简单地执行调用wait(0) 。

        当前的线程必须拥有该对象的显示器。 该线程释放此监视器的所有权，并等待直到另一个线程通知等待该对象的监视器的线程通过调用notify方法或notifyAll方法来唤醒。 然后线程等待，直到它可以重新获得监视器的所有权并恢复执行。

        像在一个参数版本中，中断和虚假唤醒是可能的，并且该方法应该始终在循环中使用：

          synchronized (obj) {
         while (<condition does not hold>)
             obj.wait();
         ... // Perform action appropriate to condition
     }
        该方法只能由作为该对象监视器的所有者的线程调用。 有关线程可以成为监视器所有者的方式的说明，请参阅notify方法。
        异常
        IllegalMonitorStateException - 如果当前线程不是对象监视器的所有者。
        InterruptedException - 如果任何线程在当前线程等待通知之前或当前线程中断当前线程。 当抛出此异常时，当前线程的中断状态将被清除。
        另请参见：
        notify() ， notifyAll()

      • finalize

        @Deprecated(since="9")
protected void finalize​()
                 throws Throwable
        已过时。 定稿机制本质上是有问题的。 定稿可能导致性能问题，死锁和挂起。 敲定错误可能导致资源泄漏; 如果不再需要，无法取消定稿; 并且在不同对象的finalize方法的调用中没有指定排序。 此外，关于定稿的时间并不保证。 只有在无限期延迟之后，才能在可终止对象上调用finalize方法（如果有的话）。 其实例持有非堆资源的类应提供一种方法来实现这些资源的显式释放，如果适用，它们还应实现AutoCloseable 。 Cleaner和PhantomReference在对象变得不可达时提供更灵活和更有效的方式来释放资源。
        当垃圾收集确定不再有对该对象的引用时，垃圾收集器在对象上调用该对象。 一个子类覆盖finalize方法来处理系统资源或执行其他清理。

        finalize的一般合同是，如果Java¢虚拟机已经确定不再有任何方法可以由任何尚未死亡的线程访问该对象的方法被调用，除非是由于最后确定的其他对象或类的准备工作所采取的行动。 finalize方法可能会采取任何行动，包括使此对象再次可用于其他线程; 然而， finalize的通常目的是在对象不可撤销地丢弃之前执行清除操作。 例如，表示输入/输出连接的对象的finalize方法可能会在对象被永久丢弃之前执行显式I / O事务来中断连接。

        finalize类的finalize方法Object执行特殊操作; 它只是返回正常。 Object子类可以覆盖此定义。

        Java编程语言不能保证哪个线程将为任何给定对象调用finalize方法。 但是，确保调用finalize的线程在调用finalize时不会持有任何用户可见的同步锁。 如果finalize方法抛出未捕获的异常，则会忽略该异常，并终止该对象的定类。

        在为对象调用了finalize方法之后，在Java虚拟机再次确定不再有任何方法可以使任何尚未死亡的线程访问此对象的任何方法之前，还将采取进一步措施，包括可能的操作由准备完成的其他对象或类别，此时可以丢弃对象。

        任何给定对象，Java虚拟机不会多次调用finalize方法。

        finalize方法引发的任何异常finalize导致该对象的终止被暂停，否则被忽略。

        API Note:
        嵌入非堆资源的类具有许多清除这些资源的选项。 该类必须确保每个实例的生命周期比其嵌入的任何资源的寿命长。 可以使用Reference.reachabilityFence(java.lang.Object)来确保对象保持可访问，同时嵌入在对象中的资源正在使用中。

        一个子类应该避免覆盖finalize方法，除非子类嵌入在收集实例之前必须清理的非堆资源。 Finalizer调用不会自动链接，与构造函数不同。 如果一个子类覆盖了finalize那么它必须明确地调用超类终结器。 为了防止异常提前终止终结链，子类应该使用一个try-finally块来确保总是调用super.finalize() 。 例如，

           @Override protected void finalize() throws Throwable { try { ... // cleanup subclass state } finally { super.finalize(); } }
        异常
        Throwable - 这个方法提出的 异常
        另请参见：
        WeakReference ， PhantomReference
        See The Java™ Language Specification:
        12.6 Finalization of Class Instances
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OutOfMemoryError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class OutOfMemoryError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.VirtualMachineError
          • java.lang.OutOfMemoryError
  • All Implemented Interfaces:
    Serializable

    public class OutOfMemoryError
extends VirtualMachineError
    当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。 OutOfMemoryError对象可以由虚拟机构成，如同suppression were disabled and/or the stack trace was not writable一样 。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      OutOfMemoryError​()
      构造一个 OutOfMemoryError ，没有详细信息。
      OutOfMemoryError​(String s)
      构造具有指定详细消息的 OutOfMemoryError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • OutOfMemoryError

        public OutOfMemoryError​()
        构造一个没有详细消息的 OutOfMemoryError 。

      • OutOfMemoryError

        public OutOfMemoryError​(String s)
        构造具有指定详细消息的 OutOfMemoryError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Override (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang

Annotation Type Override

  • @Target(METHOD)
@Retention(SOURCE)
public @interface Override
    表示方法声明旨在覆盖超类型中的方法声明。 如果使用此注释类型注释方法，则需要编译器才能生成错误消息，除非至少满足以下条件之一：
    • 该方法将覆盖或实现在超类型中声明的方法。
    • 该方法具有与Object中声明的任何公共方法的覆盖相同的签名。
    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    8.4.8继承，覆盖和隐藏，9.4.1继承和覆盖，9.6.4.4 @Override
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Package (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Package

  • java.lang.Object
    • java.lang.Package
  • All Implemented Interfaces:
    AnnotatedElement

    public class 软件包
extends Object
implements AnnotatedElement
    表示与类加载器关联的运行时包的元数据。 元数据包括注释，版本控制和密封。

    与运行时程序包中的类相同的代码源，从package-info.class读取运行时程序包的注释。

    构成运行时程序包的一组类可以实现特定的规范。 当定义软件包时，可以提供规范标题，版本和供应商（指示规范的所有者/维护者）。 应用程序可以通过使用Package.isCompatibleWith(String)方法询问软件包是否与特定规范版本兼容。 另外，当定义包时，可以提供有关构成运行时包的实际类的信息。 该信息包括实现标题，版本和供应商（指示类的供应商）。

    A 软件包可以使用ClassLoader.definePackage(String, String, String, String, String, String, String, URL)方法显式定义。 呼叫者提供规范和实现标题，版本和供应商。 来电还指示包裹是否为sealed 。 如果软件包没有明确的运行包定义在运行时包中的类定义时，那么一个软件包自动地被类的定义类加载器定义，如下所示。

    为命名模块中的类自动定义的一个软件包具有以下属性：

    • 该包的名称源自binary names的类。 由于命名模块中的类必须在命名的包中，所以派生的名称永远不会为空。
    • 如果已知的话，该封装将以module location作为代码来源。
    • 规格和实现标题，版本和供应商未指定。
    • 软件包上的任何注释从上述package-info.class读取。

    对于未命名模块中的类自动定义的软件包具有以下属性：

    • 包的名称是"" （对于未命名包中的类），或派生自类的类（针对命名包中的类）的binary names 。
    • 包装没有密封。
    • 规格和实现标题，版本和供应商未指定。
    • 软件包上的任何注释从上述package-info.class读取。

    A 软件包可以用Package.getPackage(String)和ClassLoader.getDefinedPackage(String)方法获得。 由类加载器定义的每个软件包都可以通过Package.getPackages()和ClassLoader.getDefinedPackages()方法获得。

    Implementation Note:
    builtin class loaders不会在命名模块中显式定义软件包对象。 而是自动定义这些包，并且没有规范和实现版本信息。
    从以下版本开始：
    1.2
    另请参见：
    The JAR File Specification: Package Sealing ， ClassLoader.definePackage(String, String, String, String, String, String, String, URL)
    See The Java™ Virtual Machine Specification:
    5.3运行时包

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      <A extends Annotation>
      A             		getAnnotation​(Class<A> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getAnnotations​()
      返回此元素上 存在的注释。
      <A extends Annotation>
      A[]             		getAnnotationsByType​(Class<A> annotationClass)
      返回与此元素 相关联的注释。
      <A extends Annotation>
      A             		getDeclaredAnnotation​(Class<A> annotationClass)
      如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      <A extends Annotation>
      A[]             		getDeclaredAnnotationsByType​(Class<A> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      String getImplementationTitle​()
      返回此包的标题。
      String getImplementationVendor​()
      返回实现此软件包的供应商，如果不知道则返回 null 。
      String getImplementationVersion​()
      返回这个实现的版本。
      String getName​()
      返回此包的名称。
      static 软件包 getPackage​(String name)
      已过时。
      如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使注释存在于由子加载器定义的package-info.class文件中。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
      static 软件包[] getPackages​()
      返回由调用者的类加载器及其祖先定义的所有 软件包 。
      String getSpecificationTitle​()
      返回此程序包实现的规范的标题。
      String getSpecificationVendor​()
      返回拥有和维护实现此程序包的类的规范的组织，供应商或公司的名称。
      String getSpecificationVersion​()
      返回此程序包实现的规范的版本号。
      int hashCode​()
      返回从包名称计算的哈希码。
      boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      boolean isCompatibleWith​(String desired)
      将该软件包的规格版本与所需版本进行比较。
      boolean isSealed​()
      如果封装密封，则返回true。
      boolean isSealed​(URL url)
      如果此封装相对于指定的代码源 url进行了密封，则返回true。
      String toString​()
      返回此包的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getName

        public String getName​()
        返回此包的名称。
        结果
        该包的完全限定名称，如 The Java™ Language Specification第6.5.3节所定义，例如 java.lang

      • getSpecificationTitle

        public String getSpecificationTitle​()
        返回此程序包实现的规范的标题。
        结果
        如果不知道，则返回规范标题 null 。

      • getSpecificationVersion

        public String getSpecificationVersion​()
        返回此程序包实现的规范的版本号。 此版本字符串必须是由“。”分隔的非负十进制整数序列，并且可能具有前导零。 当比较版本字符串时，比较最显着的数字。

        规格版本号使用由句点“。”分隔的非负十进制整数组成的语法，例如“2.0”或“1.2.3.4.5.6.7”。 这允许使用可扩展数字来表示主要，次要，微型等版本。 版本规范由以下形式语法描述：

        SpecificationVersion:
        Digits RefinedVersionopt
        RefinedVersion:
        . Digits
        . Digits RefinedVersion
        Digits:
        Digit
        Digits
        Digit:
        any character for which Character.isDigit(char) returns true, e.g. 0, 1, 2, ...
        结果
        如果不知道规格版本，则返回 null 。

      • getSpecificationVendor

        public String getSpecificationVendor​()
        返回拥有和维护实现此程序包的类的规范的组织，供应商或公司的名称。
        结果
        如果不知道规范供应商，则返回 null 。

      • getImplementationTitle

        public String getImplementationTitle​()
        返回此包的标题。
        结果
        如果不知道实现的标题，则返回 null 。

      • getImplementationVersion

        public String getImplementationVersion​()
        返回这个实现的版本。 它由此实现的供应商分配的任何字符串组成，并且没有Java运行时指定或预期的任何特定语法。 对于此程序包，该供应商用于此实现的其他软件包版本字符串可以进行比较。
        结果
        如果不知道该版本的实现，则返回 null 。

      • getImplementationVendor

        public String getImplementationVendor​()
        返回实现此软件包的供应商，如果不知道则返回 null 。
        结果
        如果不知道实现此包的供应商，则返回 null 。

      • isSealed

        public boolean isSealed​()
        如果封装密封，则返回true。
        结果
        如果包装密封，则为真，否则为false

      • isSealed

        public boolean isSealed​(URL url)
        如果此包是针对指定的代码源 url进行了密封，则返回true。
        参数
        url - 代码源URL
        结果
        如果这个包装相对于给定的 url是密封的， url

      • isCompatibleWith

        public boolean isCompatibleWith​(String desired)
                         throws NumberFormatException
        将该软件包的规格版本与所需版本进行比较。 如果此包规范版本号大于或等于所需版本号，则返回true。

        通过顺序比较期望和规格字符串的相应组件来比较版本号。 每个组件都被转换为十进制整数，并将值进行比较。 如果规格值大于所需值，则返回true。 如果返回值小于false。 如果值相等，则会跳过周期，并比较下一对组件。

        参数
        desired - 所需版本的版本字符串。
        结果
        如果此软件包的版本号大于或等于所需的版本号，则为true
        异常
        NumberFormatException - 如果当前版本不知道或者所需或当前版本不是正确的点缀形式。

      • getPackage

        @Deprecated(since="9")
public static 软件包 getPackage​(String name)
        已过时。 如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件的注释，即使子载入程序定义的package-info.class文件中存在注释。 更强大的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
        在调用者的类加载器及其祖先中通过名称查找包。

        如果调用者的类加载器定义软件包给定的名称，该软件包返回。 否则，对于给定名称的软件包 ，调用者的类加载器的祖先被递归地搜索（由父母父代）。

        调用此方法相当于在调用者的类加载器的一个ClassLoader实例上调用ClassLoader.getPackage(java.lang.String) 。

        参数
        name - 包名称，如“ java.lang ”。
        结果
        给定名称的 软件包由调用者的类加载器或其祖先定义，如果未找到， null 。
        异常
        NullPointerException - 如果 name是 null 。
        另请参见：
        ClassLoader.getDefinedPackage(java.lang.String)

      • getPackages

        public static 软件包[] getPackages​()
        返回由调用者的类加载器及其祖先定义的所有软件包 。 返回的数组可能包含多个相同程序包名称的软件包对象，每个对象由类加载器层次结构中的不同类加载器定义。

        调用此方法相当于在调用者的类加载器的一个ClassLoader实例上调用ClassLoader.getPackages() 。

        结果
        由此类加载器及其祖先定义的 软件包对象的数组
        另请参见：
        ClassLoader.getDefinedPackages()

      • hashCode

        public int hashCode​()
        返回从包名称计算的哈希码。
        重写：
        hashCode在 Object
        结果
        从包名称计算的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此包的字符串表示形式。 它的值是字符串“package”和包名称。 如果定义了包标题，则将其附加。 如果定义了包版本，则会附加它。
        重写：
        toString在 Object
        结果
        包的字符串表示形式。

      • getAnnotation

        public <A extends Annotation> A getAnnotation​(Class<A> annotationClass)
        描述从接口AnnotatedElement复制
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        参数类型
        A - 查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • isAnnotationPresent

        public boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
        如果此元素上存在指定类型的注释，则返回true，否则返回false。 该方法主要用于方便访问标记注释。

        该方法返回的真值等价于： getAnnotation(annotationClass) != null

        默认方法的主体被指定为上述代码。

        Specified by:
        isAnnotationPresent在接口 AnnotatedElement
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果此元素上存在指定注释类型的注释，则为true，否则为false
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getAnnotationsByType

        public <A extends Annotation> A[] getAnnotationsByType​(Class<A> annotationClass)
        说明从界面AnnotatedElement复制
        返回与此元素相关联的注释。 如果没有与此元素相关联的注释，则返回值是长度为0.的数组。此方法与AnnotatedElement.getAnnotation(Class)之间的区别在于该方法检测其参数是否是可重复注释类型 （JLS 9.6），如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotationsByType在接口 AnnotatedElement
        参数类型
        A - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果与此元素相关联，则指定注释类型的所有元素注释，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getAnnotations

        public Annotation[] getAnnotations​()
        描述从接口AnnotatedElement复制
        返回此元素上存在的注释。 如果没有存在于此元素上注解，返回值是长度为0这种方法的调用者可以随意修改返回的数组的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotations在接口 AnnotatedElement
        结果
        此元素上出现的注释
        从以下版本开始：
        1.5

      • getDeclaredAnnotation

        public <A extends Annotation> A getDeclaredAnnotation​(Class<A> annotationClass)
        描述从接口AnnotatedElement复制
        如果这样的注释直接存在 ，则返回指定类型的元素注释，否则返回null。 此方法忽略继承的注释。 （如果此元素上没有注释，则返回null）
        Specified by:
        getDeclaredAnnotation在接口 AnnotatedElement
        参数类型
        A - 查询的注释类型，如果直接出现则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果直接出现在该元素上，则指定注释类型的元素注释，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotationsByType

        public <A extends Annotation> A[] getDeclaredAnnotationsByType​(Class<A> annotationClass)
        说明从界面AnnotatedElement复制
        如果此类注释直接存在或间接存在，则返回该元素的注释（指定类型）。 此方法忽略继承的注释。 如果没有直接或间接出现在此元素上的指定注释，则返回值为长度为0.的数组。此方法与AnnotatedElement.getDeclaredAnnotation(Class)之间的区别在于该方法检测其参数是否为可重复注释类型 （JLS 9.6），以及如果是，尝试通过“查看”容器注释（如果存在）来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotationsByType在接口 AnnotatedElement
        参数类型
        A - 直接或间接出现时查询和返回的注释类型
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        指定注释类型的所有这些元素的注释，如果直接或间接地存在于该元素上，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        描述从接口AnnotatedElement复制
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        结果
        此元素上直接显示的注释
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Process (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Process

  • java.lang.Object
    • java.lang.Process

  • public abstract class Process
extends Object
    Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。 该类提供了用于执行进程的输入，对进程的输出，等待进程完成，检查进程的退出状态以及销毁（杀死）进程的方法。 ProcessBuilder.start()和Runtime.exec方法创建一个本机进程并返回一个Process子类的Process ，可以用于控制进程并获取有关它的信息。

    创建进程的方法可能不适用于某些本机平台上的特殊进程，例如本机窗口进程，守护进程，Microsoft Windows上的Win16 / DOS进程或shell脚本。

    默认情况下，创建的进程没有自己的终端或控制台。 其所有的标准I / O（即标准输入，标准输出，标准错误）操作将被重定向到父进程，在那里他们可以经由使用所述方法获得的流进行访问getOutputStream() ， getInputStream() ，和getErrorStream() 。 父进程使用这些流将进程输入并从进程获取输出。 因为一些本地平台仅为标准输入和输出流提供有限的缓冲区大小，因此无法及时写入输入流或读取进程的输出流可能会导致进程阻塞甚至死锁。

    在需要的地方， process I/O can also be redirected使用ProcessBuilder类的方法。

    当没有更多的引用Process对象时，进程不会被杀死，而是进程继续异步执行。

    不要求Process对象表示的进程与拥有Process对象的Java进程异步执行或并发。

    从1.5开始， ProcessBuilder.start()是创建Process的首选方式。

    过程的子类应覆盖onExit()种toHandle()方法，以提供一个全功能的过程包括process id ， information about the process ， direct children和direct children plus descendants of those children的过程。 委托基础Process或ProcessHandle通常是最简单和最有效的。

    从以下版本开始：
    1.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      Process​()
      Process的默认构造函数。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Stream<ProcessHandle> children​()
      返回进程的直接子节点的快照。
      Stream<ProcessHandle> descendants​()
      返回进程后代的快照。
      abstract void destroy​()
      杀死这个过程。
      Process destroyForcibly​()
      强制杀死进程。
      abstract int exitValue​()
      返回进程的退出值。
      abstract InputStream getErrorStream​()
      返回连接到进程的错误输出的输入流。
      abstract InputStream getInputStream​()
      返回连接到进程正常输出的输入流。
      abstract OutputStream getOutputStream​()
      返回连接到进程正常输入的输出流。
      ProcessHandle.Info info​()
      返回有关进程信息的快照。
      boolean isAlive​()
      测试这个 Process代表的过程是否活着。
      CompletableFuture<Process> onExit​()
      返回一个 CompletableFuture<Process>终止进程。
      long pid​()
      返回进程的本机进程ID。
      boolean supportsNormalTermination​()
      返回 true如果执行 destroy()是正常终止进程，返回 false如果执行 destroy强制立即终止进程。
      ProcessHandle toHandle​()
      返回进程的ProcessHandle。
      abstract int waitFor​()
      导致当前线程等待，如有必要，直到由此 Process对象表示的进程已终止。
      boolean waitFor​(long timeout, TimeUnit unit)
      导致当前线程等待，如有必要，直到由此 Process对象表示的进程已终止，或指定的等待时间过去。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Process

        public Process​()
        Process的默认构造函数。

    • 方法详细信息

      • getOutputStream

        public abstract OutputStream getOutputStream​()
        返回连接到进程正常输入的输出流。 输出到流被管道输入到由该Process对象表示的进程的标准输入。

        如果使用ProcessBuilder.redirectInput重定向过程的标准输入，则此方法将返回一个null output stream 。

        实现注意事项：缓冲返回的输出流是一个好主意。

        结果
        输出流连接到进程的正常输入

      • getInputStream

        public abstract InputStream getInputStream​()
        返回连接到进程正常输出的输入流。 流从该Process对象表示的进程的标准输出中获取数据。

        如果进程的标准输出已使用ProcessBuilder.redirectOutput重定向，则此方法将返回一个null input stream 。

        否则，如果使用ProcessBuilder.redirectErrorStream重定向过程的标准错误，则此方法返回的输入流将接收合并的标准输出和进程的标准错误。

        实现注意事项：缓冲返回的输入流是一个好主意。

        结果
        输入流连接到正常输出的进程

      • getErrorStream

        public abstract InputStream getErrorStream​()
        返回连接到进程的错误输出的输入流。 流从该Process对象表示的进程的错误输出中获取数据。

        如果使用ProcessBuilder.redirectError或ProcessBuilder.redirectErrorStream重定向过程的标准错误，则此方法将返回一个null input stream 。

        实现注意事项：缓冲返回的输入流是一个好主意。

        结果
        输入流连接到进程的错误输出

      • waitFor

        public abstract int waitFor​()
                     throws InterruptedException
        导致当前线程等待，如有必要，直到此Process对象表示的进程已终止。 如果进程已经终止，此方法立即返回。 如果进程尚未终止，调用线程将被阻塞，直到进程退出。
        结果
        由该Process对象表示的进程的退出值。 按照约定，值0表示正常终止。
        异常
        InterruptedException - 如果当前线程正在等待时由另一个线程处理interrupted ，则等待结束，并抛出一个InterruptedException 。

      • waitFor

        public boolean waitFor​(long timeout,
                       TimeUnit unit)
                throws InterruptedException
        导致当前线程等待，如有必要，直到此Process对象表示的进程已终止，或指定的等待时间过去。

        如果进程已经终止，那么该方法将立即返回值为true 。 如果进程尚未终止，超时值小于或等于零，则此方法将立即返回值为false 。

        此方法的默认实现轮询exitValue以检查进程是否已终止。 强烈建议此类的具体实现用更有效的实现来覆盖此方法。

        参数
        timeout - 等待的最长时间
        unit - timeout参数的时间单位
        结果
        true如果进程已经退出，并且 false如果在进程退出之前经过了等待时间。
        异常
        InterruptedException - 如果当前线程在等待时中断。
        NullPointerException - 如果单位为空
        从以下版本开始：
        1.8

      • exitValue

        public abstract int exitValue​()
        返回进程的退出值。
        结果
        由该Process对象表示的进程的退出值。 按照惯例，值0表示正常终止。
        异常
        IllegalThreadStateException - 如果此 Process对象表示的进程尚未终止

      • destroy

        public abstract void destroy​()
        杀死这个过程。 这个Process对象所表示的进程是否为normally terminated是否依赖于实现。 强制流程破坏被定义为流程的即时终止，而正常的终止允许流程干净地关闭。 如果该过程不存在，则不采取任何行动。

        所述CompletableFuture从onExit()是completed时的处理已终止。

      • destroyForcibly

        public Process destroyForcibly​()
        强制杀死进程。 此Process对象表示的进程被强制终止。 强制流程破坏被定义为流程的即时终止，而正常的终止允许流程干净地关闭。 如果该过程不存在，则不采取任何行动。

        CompletableFuture从onExit()是completed当进程已经终止。

        由ProcessBuilder.start()和Runtime.exec(java.lang.String)返回的Process对象调用此方法强制终止进程。

        API Note:
        该过程可能不会立即终止。 即isAlive()可能会在destroyForcibly()被调用后的destroyForcibly()返回true。 如果需要，该方法可以链接到waitFor() 。
        实现要求：
        此方法的默认实现将调用 destroy() ，因此可能不会强制终止进程。
        Implementation Note:
        强烈建议使用此类的具体实现来使用兼容实现覆盖此方法。
        结果
        代表进程强制销毁的 Process对象
        从以下版本开始：
        1.8

      • supportsNormalTermination

        public boolean supportsNormalTermination​()
        返回true如果执行destroy()是正常终止进程，返回false如果执行destroy强制立即终止进程。

        根据ProcessBuilder.start()和Runtime.exec(java.lang.String)返回的Process对象调用此方法返回true或false具体取决于平台实现。

        实现要求：
        此实现将引发一个UnsupportedOperationException的实例，并且不执行其他操作。
        结果
        true如果执行destroy()是正常终止进程; 否则， destroy()强制终止进程
        异常
        UnsupportedOperationException - 如果Process实现不支持此操作
        从以下版本开始：
        9

      • isAlive

        public boolean isAlive​()
        测试此 Process表示的过程是否存活。
        结果
        true如果此 Process对象表示的进程尚未终止。
        从以下版本开始：
        1.8

      • pid

        public long pid​()
        返回进程的本机进程ID。 本地进程ID是操作系统分配给进程的标识号。
        实现要求：
        该方法的实现将进程ID返回为： toHandle().pid() 。
        结果
        进程的本机进程标识
        异常
        UnsupportedOperationException - 如果Process实现不支持此操作
        从以下版本开始：
        9

      • onExit

        public CompletableFuture<Process> onExit​()
        返回一个CompletableFuture<Process>的终止进程。 CompletableFuture提供了在进程终止时触发可以同步或异步运行的从属功能或动作的功能。 当进程终止时，无论进程的退出状态如何，CompletableFuture为completed 。

        调用onExit().get()等待进程终止并返回进程。 未来可以用来检查进程是否为done或wait ，以便终止。 Cancelling的CompletableFuture不会影响进程。

        从ProcessBuilder.start()返回的进程重写默认实现，以提供一个有效的机制来等待进程退出。

        API Note:
        使用onExit是一种替代waitFor ，使两个额外的并发和所述处理的结果的方便访问。 Lambda表达式可用于评估流程执行的结果。 如果在使用该值之前要进行其他处理，则onExit是一种方便的机制，用于释放当前线程，只有当需要该值时才阻塞。
        例如，启动一个进程来比较两个文件，并得到一个布尔值，如果它们是相同的：
           Process p = new ProcessBuilder("cmp", "f1", "f2").start(); Future<Boolean> identical = p.onExit().thenApply(p1 -> p1.exitValue() == 0); ... if (identical.get()) { ... }
        在ComputableFuture完成并调用依赖操作之前，该过程可能会被观察到已终止于isAlive() 。
        实现要求：
        该实现重复执行waitFor() ，直到它成功返回。 如果执行waitFor中断，线程的中断状态将被保留。

        当waitFor()成功返回时，无论进程的退出状态如何，CompletableFuture为completed 。 如果同时等待大量进程，则该实现可能会消耗大量的线程堆栈内存。

        外部实现应该覆盖此方法并提供更有效的实现。 例如，要委托给基础进程，它可以执行以下操作：

           public CompletableFuture<Process> onExit() { return delegate.onExit().thenApply(p -> this); }
        结果
        一个新的 CompletableFuture<Process>的过程
        从以下版本开始：
        9

      • toHandle

        public ProcessHandle toHandle​()
        返回进程的ProcessHandle。 Process通过返回的对象ProcessBuilder.start()和Runtime.exec(java.lang.String)实施toHandle为相当于ProcessHandle.of(pid)包括在检查了SecurityManager和RuntimePermission("manageProcess") 。
        实现要求：
        此实现引发了一个UnsupportedOperationException的实例，并且不执行其他操作。 子类应该覆盖此方法以为该进程提供一个ProcessHandle。 该方法pid() ， info() ， children() ，并descendants() ，除非被覆盖，操作上ProcessHandle。
        结果
        返回进程的ProcessHandle
        异常
        UnsupportedOperationException - 如果Process实现不支持此操作
        SecurityException - 如果已安装安全管理器，并拒绝RuntimePermission（“manageProcess”）
        从以下版本开始：
        9

      • info

        public ProcessHandle.Info info​()
        返回有关进程信息的快照。

        一个ProcessHandle.Info实例具有访问器方法，返回有关进程的信息（如果可用）。

        实现要求：
        此实现返回有关进程的信息： toHandle().info() 。
        结果
        关于进程的信息的快照，始终为非空
        异常
        UnsupportedOperationException - 如果Process实现不支持此操作
        从以下版本开始：
        9

      • children

        public Stream<ProcessHandle> children​()
        返回进程的直接子节点的快照。 直接子进程的父进程是进程。 通常， not alive的进程没有孩子。

        请注意，进程被创建并异步终止。 不能保证一个进程是alive 。

        实现要求：
        这个实现返回直接的孩子： toHandle().children() 。
        结果
        一个连续的ProcessHandles Stream，用于流程的直接子进程
        异常
        UnsupportedOperationException - 如果Process实现不支持此操作
        SecurityException - 如果已安装安全管理器，并且它拒绝RuntimePermission（“manageProcess”）
        从以下版本开始：
        9

      • descendants

        public Stream<ProcessHandle> descendants​()
        返回进程后代的快照。 一个进程的后代是进程的孩子加上那些孩子的后裔，递归地。 通常，一个进程是not alive没有孩子。

        请注意，进程被创建并异步终止。 不能保证一个进程是alive 。

        实现要求：
        这个实现返回所有的孩子，如： toHandle().descendants() 。
        结果
        用于进程的连续流ProcessHandles作为进程的后代
        异常
        UnsupportedOperationException - 如果Process实现不支持此操作
        SecurityException - 如果安全管理器已经安装，并且它拒绝RuntimePermission（“manageProcess”）
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProcessBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ProcessBuilder

  • java.lang.Object
    • java.lang.ProcessBuilder

  • public final class ProcessBuilder
extends Object
    此类用于创建操作系统进程。

    每个ProcessBuilder实例管理进程属性的集合。 start()方法使用这些属性创建一个新的Process实例。 可以从同一实例重复调用start()方法来创建具有相同或相关属性的新子进程 。

    可以调用startPipeline方法来创建一个新进程的管道，将每个进程的输出直接发送到下一个进程。 每个进程都有其各自的ProcessBuilder的属性。

    每个进程构建器管理这些进程属性：

    • 命令 ，表示要调用的外部程序文件的字符串列表及其参数（如果有）。 哪些字符串表示有效的操作系统命令是系统相关的。 例如，每个概念参数是这个列表中的一个元素是常见的，但是有一些操作系统，其中程序期望令命令行字符串本身 - 在这样的系统上，Java实现可能需要命令来包含两个元素。
    • 一个环境 ，它是从变量到值的系统依赖映射。 初始值是当前进程的环境的副本（参见System.getenv() ）。
    • 一个工作目录 。 默认值是当前进程的当前工作目录，通常由系统属性user.dir命名的目录。
    • a source of standard input 。 默认情况下，子进程从管道读取输入。 Java代码可以通过Process.getOutputStream()返回的输出流访问此管道。 然而，标准输入可以使用redirectInput重定向到另一个源。 在这种情况下， Process.getOutputStream()将返回一个空输出流 ，为此：
      • write方法总是抛出IOException
      • close方法什么都不做
    • a destination for standard output and standard error 。 默认情况下，子进程将标准输出和标准错误写入管道。 Java代码可以通过Process.getOutputStream()和Process.getErrorStream()返回的输入流访问这些管道。 然而，标准输出和标准错误可能会使用redirectOutput和redirectError重定向到其他目的地。 在这种情况下， Process.getInputStream()和/或Process.getErrorStream()将返回一个空输入流 ，其中：
      • read方法总是返回-1
      • available方法总是返回0
      • close方法什么都不做
    • 一个redirectErrorStream属性。 最初，此属性为false ，这意味着子过程的标准输出和错误输出将发送到两个独立的流，可以使用Process.getInputStream()和Process.getErrorStream()方法访问。

      如果该值设置为true ，则：

      • 标准错误与标准输出合并，并始终发送到同一目的地（这使得更容易将错误消息与相应的输出相关联）
      • 标准错误和标准输出的公共目的地可以使用redirectOutput重定向
      • 在创建子进程时，将忽略redirectError方法设置的任何重定向
      • 从Process.getErrorStream()返回的流将始终是一个null input stream

    修改流程构建器的属性将影响随后由该对象的start()方法启动的进程，但不会影响以前启动的进程或Java进程本身。

    大多数错误检查由start()方法执行。 可以修改对象的状态，使start()失败。 例如，将命令属性设置为空列表将不会抛出异常，除非调用了start() 。

    请注意，此类不同步。 如果多个线程并发访问ProcessBuilder实例，并且至少有一个线程在结构上修改其中一个属性，则必须在外部进行同步。

    启动使用默认工作目录和环境的新进程很容易：

       Process p = new ProcessBuilder("myCommand", "myArg").start();

    以下是启动具有修改的工作目录和环境的进程的示例，并将要附加到日志文件的标准输出和错误重定向：

       ProcessBuilder pb = new ProcessBuilder("myCommand", "myArg1", "myArg2"); Map<String, String> env = pb.environment(); env.put("VAR1", "myValue"); env.remove("OTHERVAR"); env.put("VAR2", env.get("VAR1") + "suffix"); pb.directory(new File("myDir")); File log = new File("log"); pb.redirectErrorStream(true); pb.redirectOutput(Redirect.appendTo(log)); Process p = pb.start(); assert pb.redirectInput() == Redirect.PIPE; assert pb.redirectOutput().file() == log; assert p.getInputStream().read() == -1;

    要使用一组显式环境变量启动进程，首先在添加环境变量之前调用Map.clear() 。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ProcessBuilder.Redirect
      表示子进程输入的源或子进程输出的目的地。

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProcessBuilder​(String... command)
      构造具有指定操作系统程序和参数的进程构建器。
      ProcessBuilder​(List<String> command)
      构造具有指定操作系统程序和参数的进程构建器。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      List<String> command​()
      返回此流程构建器的操作系统程序和参数。
      ProcessBuilder command​(String... command)
      设置此流程构建器的操作系统程序和参数。
      ProcessBuilder command​(List<String> command)
      设置此流程构建器的操作系统程序和参数。
      File directory​()
      返回此进程构建器的工作目录。
      ProcessBuilder directory​(File directory)
      设置此进程构建器的工作目录。
      Map<String,String> environment​()
      返回此流程构建器环境的字符串映射视图。
      ProcessBuilder inheritIO​()
      将子进程标准I / O的源和目标设置为与当前Java进程相同。
      ProcessBuilder.Redirect redirectError​()
      返回此流程构建器的标准错误目标。
      ProcessBuilder redirectError​(File file)
      将此流程构建器的标准错误目标设置为文件。
      ProcessBuilder redirectError​(ProcessBuilder.Redirect destination)
      设置此流程构建器的标准错误目标。
      boolean redirectErrorStream​()
      告诉这个进程构建器是否合并标准错误和标准输出。
      ProcessBuilder redirectErrorStream​(boolean redirectErrorStream)
      设置此过程构建器的 redirectErrorStream属性。
      ProcessBuilder.Redirect redirectInput​()
      返回此流程构建器的标准输入源。
      ProcessBuilder redirectInput​(File file)
      将此流程构建器的标准输入源设置为文件。
      ProcessBuilder redirectInput​(ProcessBuilder.Redirect source)
      设置此流程构建器的标准输入源。
      ProcessBuilder.Redirect redirectOutput​()
      返回此流程构建器的标准输出目标。
      ProcessBuilder redirectOutput​(File file)
      将此流程构建器的标准输出目标设置为文件。
      ProcessBuilder redirectOutput​(ProcessBuilder.Redirect destination)
      设置此流程构建器的标准输出目标。
      Process start​()
      使用此流程构建器的属性启动新进程。
      static List<Process> startPipeline​(List<ProcessBuilder> builders)
      为每个ProcessBuilder启动流程，创建一个由其标准输出流和标准输入流链接的流程。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ProcessBuilder

        public ProcessBuilder​(List<String> command)
        构造具有指定操作系统程序和参数的进程构建器。 此构造不会使副本command列表。 列表的后续更新将反映在流程构建器的状态。 不检查command是否对应于有效的操作系统命令。
        参数
        command - 包含程序及其参数的列表

      • ProcessBuilder

        public ProcessBuilder​(String... command)
        构造具有指定操作系统程序和参数的进程构建器。 这是一个方便的构造函数，它以相同的顺序将流程构建器的命令设置为包含与command数组相同的字符串的字符串列表。 不检查command是否对应于有效的操作系统命令。
        参数
        command - 包含程序及其参数的字符串数组

    • 方法详细信息

      • command

        public ProcessBuilder command​(List<String> command)
        设置此流程构建器的操作系统程序和参数。 这种方法不会使副本command列表。 列表的后续更新将反映在流程构建器的状态。 不检查command是否对应于有效的操作系统命令。
        参数
        command - 包含程序及其参数的列表
        结果
        这个流程生成器

      • command

        public ProcessBuilder command​(String... command)
        设置此流程构建器的操作系统程序和参数。 这是一个方便的方法，将命令设置为包含与command数组相同的字符串的字符串列表，顺序相同。 不检查command是否对应于有效的操作系统命令。
        参数
        command - 包含程序及其参数的字符串数组
        结果
        这个流程生成器

      • command

        public List<String> command​()
        返回此流程构建器的操作系统程序和参数。 返回的列表不是副本。 列表的后续更新将反映在此流程构建器的状态中。
        结果
        这个流程制造商的计划及其论据

      • environment

        public Map<String,String> environment​()
        返回此流程构建器环境的字符串映射视图。 无论何时创建流程构建器，环境都将初始化为当前进程环境的副本（请参阅System.getenv() ）。 随后由该对象的start()方法开始的子处理将使用此映射作为其环境。

        可以使用普通的Map操作修改返回的对象。 这些修改对于通过start()方法启动的子进程将是可见的。 两个ProcessBuilder实例总是包含独立的进程环境，因此对返回的映射的更改将永远不会反映在任何其他ProcessBuilder实例或System.getenv返回的值中。

        如果系统不支持环境变量，则返回空的地图。

        返回的映射不允许空值或值。 尝试插入或查询空键或值的存在将抛出一个NullPointerException 。 尝试查询是否存在不属于类型String的键或值将抛出一个ClassCastException 。

        返回地图的行为依赖于系统。 系统可能不允许修改环境变量或禁止某些变量名称或值。 因此，如果操作系统不允许修改，则尝试修改映射可能会因为UnsupportedOperationException或IllegalArgumentException而失败。

        由于环境变量名称和值的外部格式与系统相关，因此可能与Java的Unicode字符串之间不存在一对一的映射。 然而，地图的实现方式是，未被Java代码修改的环境变量将在子进程中具有未修改的本地表示。

        返回的地图及其收藏意见可能不符合Object.equals(java.lang.Object)和Object.hashCode()方法的一般合同。

        返回的地图通常在所有平台上都区分大小写。

        如果存在安全管理员，则其checkPermission方法被调用，具有RuntimePermission ("getenv.*")权限。 这可能会导致抛出SecurityException 。

        将信息传递给Java子进程时 ，通常比环境变量更喜欢system properties 。

        结果
        这个过程建设者的环境
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许访问进程环境
        另请参见：
        Runtime.exec(String[],String[],java.io.File) ， System.getenv()

      • directory

        public File directory​()
        返回此进程构建器的工作目录。 这个对象的start()方法随后启动的子进程将使用它作为它们的工作目录。 返回值可能是null - 这意味着使用当前Java进程的工作目录，通常由系统属性user.dir命名的目录作为子进程的工作目录。
        结果
        这个进程构建器的工作目录

      • directory

        public ProcessBuilder directory​(File directory)
        设置此进程构建器的工作目录。 随后由此对象的start()方法启动的子进程将使用此作为其工作目录。 参数可以是null - 这意味着使用当前Java进程的工作目录，通常是由系统属性user.dir命名的目录作为子进程的工作目录。
        参数
        directory - 新的工作目录
        结果
        这个流程生成器

      • redirectInput

        public ProcessBuilder redirectInput​(ProcessBuilder.Redirect source)
        设置此流程构建器的标准输入源。 子进程随后由该对象的start()方法启动，从该源获取其标准输入。

        如果源为Redirect.PIPE （初始值），则可以使用Process.getOutputStream()返回的输出流将子进程的标准输入写入。 如果源设置为任何其他值，那么Process.getOutputStream()将返回一个null output stream 。

        参数
        source - 新的标准输入源
        结果
        这个流程生成器
        异常
        IllegalArgumentException - 如果重定向不对应于有效的数据源，即具有类型 WRITE或 APPEND
        从以下版本开始：
        1.7

      • redirectOutput

        public ProcessBuilder redirectOutput​(ProcessBuilder.Redirect destination)
        设置此流程构建器的标准输出目标。 子程序随后由该对象的start()方法启动，将其标准输出发送到此目标。

        如果目的地是Redirect.PIPE （初始值），则使用Process.getInputStream()返回的输入流可以读取子过程的标准输出。 如果目的地设置为任何其他值，那么Process.getInputStream()将返回一个null input stream 。

        参数
        destination - 新的标准输出目的地
        结果
        这个流程生成器
        异常
        IllegalArgumentException - 如果重定向不对应于有效的数据目的地，即具有类型 READ
        从以下版本开始：
        1.7

      • redirectError

        public ProcessBuilder redirectError​(ProcessBuilder.Redirect destination)
        设置此流程构建器的标准错误目标。 子进程随后由该对象的start()方法启动，将其标准错误发送到此目标。

        如果目的地是Redirect.PIPE （初始值），则使用Process.getErrorStream()返回的输入流可以读取子进程的错误输出。 如果目的地设置为任何其他值，那么Process.getErrorStream()将返回一个null input stream 。

        如果redirectErrorStream属性已设置为true ，则此方法设置的重定向无效。

        参数
        destination - 新的标准错误目的地
        结果
        这个流程生成器
        异常
        IllegalArgumentException - 如果重定向不对应于数据的有效目的地，即具有类型 READ
        从以下版本开始：
        1.7

      • redirectInput

        public ProcessBuilder redirectInput​(File file)
        将此流程构建器的标准输入源设置为文件。

        这是一种方便的方法。 调用表单redirectInput(file)行为方式与调用redirectInput (Redirect.from(file)) 。

        参数
        file - 新的标准输入源
        结果
        这个流程生成器
        从以下版本开始：
        1.7

      • redirectOutput

        public ProcessBuilder redirectOutput​(File file)
        将此流程构建器的标准输出目标设置为文件。

        这是一种方便的方法。 表单redirectOutput(file)的调用与调用redirectOutput (Redirect.to(file)) 。

        参数
        file - 新的标准输出目的地
        结果
        这个流程生成器
        从以下版本开始：
        1.7

      • redirectError

        public ProcessBuilder redirectError​(File file)
        将此流程构建器的标准错误目标设置为文件。

        这是一种方便的方法。 调用表单redirectError(file)行为方式与调用redirectError (Redirect.to(file)) 。

        参数
        file - 新的标准错误目的地
        结果
        这个流程生成器
        从以下版本开始：
        1.7

      • redirectInput

        public ProcessBuilder.Redirect redirectInput​()
        返回此流程构建器的标准输入源。 子进程随后由该对象的start()方法启动，从该源获取其标准输入。 初始值为Redirect.PIPE 。
        结果
        这个流程制造商的标准输入源
        从以下版本开始：
        1.7

      • redirectOutput

        public ProcessBuilder.Redirect redirectOutput​()
        返回此流程构建器的标准输出目标。 子进程随后由该对象的start()方法启动，将其标准输出重定向到此目标。 初始值为Redirect.PIPE 。
        结果
        该流程制造商的标准输出目的地
        从以下版本开始：
        1.7

      • redirectError

        public ProcessBuilder.Redirect redirectError​()
        返回此流程构建器的标准错误目标。 子进程随后由该对象的start()方法启动，将其标准错误重定向到此目标。 初始值为Redirect.PIPE 。
        结果
        此流程构建器的标准错误目标
        从以下版本开始：
        1.7

      • inheritIO

        public ProcessBuilder inheritIO​()
        将子进程标准I / O的源和目标设置为与当前Java进程相同。

        这是一种方便的方法。 调用表单

           pb.inheritIO()
        行为与调用完全相同
           pb.redirectInput(Redirect.INHERIT) .redirectOutput(Redirect.INHERIT) .redirectError(Redirect.INHERIT)
        这给出了与大多数操作系统命令解释器相同的行为，或标准C库函数system() 。
        结果
        这个流程生成器
        从以下版本开始：
        1.7

      • redirectErrorStream

        public boolean redirectErrorStream​()
        告诉这个进程构建器是否合并标准错误和标准输出。

        如果此属性为true ，则由该对象的start()方法随后启动的子处理生成的任何错误输出将与标准输出合并，以便可以使用Process.getInputStream()方法读取。 这使得更容易将错误消息与相应的输出相关联。 初始值为false 。

        结果
        这个过程建设者的 redirectErrorStream属性

      • redirectErrorStream

        public ProcessBuilder redirectErrorStream​(boolean redirectErrorStream)
        设置此流程构建器的redirectErrorStream属性。

        如果此属性为true ，则由该对象的start()方法随后启动的子处理生成的任何错误输出将与标准输出合并，以便可以使用Process.getInputStream()方法读取。 这使得更容易将错误消息与相应的输出相关联。 初始值为false 。

        参数
        redirectErrorStream - 新的属性值
        结果
        这个流程生成器

      • start

        public Process start​()
              throws IOException
        使用此流程构建器的属性启动新进程。

        新进程将调用由指定的命令和参数command()按以下给出，在工作目录directory() ，有一个过程的环境被给出environment() 。

        该方法检查该命令是否为有效的操作系统命令。 哪些命令有效是依赖于系统的，但至少该命令必须是非空字符串的非空列表。

        在某些操作系统上启动一个进程可能需要一小部分与系统相关的环境变量。 因此，子进程可能会继承其他环境变量设置，而不是进程生成器的environment() 。

        如果有一个安全管理器，它的checkExec方法被调用，该对象的command数组的第一个组件作为其参数。 这可能会导致抛出SecurityException 。

        启动操作系统进程与系统相关。 许多可能出错的事情是：

        • 找不到操作系统程序文件。
        • 对程序文件的访问被拒绝。
        • 工作目录不存在。
        • 命令参数中的字符无效，如NUL。

        在这种情况下，会抛出异常。 异常的确切性质是系统依赖的，但它始终是IOException的子类。

        如果操作系统不支持创建进程，则会抛出一个UnsupportedOperationException 。

        此过程构建器的后续修改不会影响返回的Process 。

        结果
        一个用于管理子进程的新的Process对象
        异常
        NullPointerException - 如果命令列表的元素为空
        IndexOutOfBoundsException - 如果命令是空列表（具有大小 0 ）
        SecurityException - 如果存在安全管理员，
        • 它的checkExec方法不允许创建子进程 ，或者
        • 子流程的标准输入为redirected from a file ，安全管理员的checkRead方法拒绝对该文件的读访问，或
        • 子进程的标准输出或标准错误为redirected to a file ，安全管理员的checkWrite方法拒绝对文件的写入访问
        UnsupportedOperationException - 如果操作系统不支持创建进程。
        IOException - 如果发生I / O错误
        另请参见：
        Runtime.exec(String[], String[], java.io.File)

      • startPipeline

        public static List<Process> startPipeline​(List<ProcessBuilder> builders)
                                   throws IOException
        为每个ProcessBuilder启动流程，创建一个由其标准输出流和标准输入流链接的流程。 每个ProcessBuilder的属性用于启动相应的进程，除了在每个进程启动时，其标准输出都定向到下一个进程的标准输入。 使用相应ProcessBuilder的重定向设置初始化第一个进程的标准输入和最后一个进程的标准输出的重定向。 所有其他ProcessBuilder重定向应为Redirect.PIPE 。

        中间进程之间的所有输入和输出流都不可访问。 除第一个进程之外的所有进程的standard input是空输出流除最后一个进程之外的所有进程的standard output都是空输入流 。

        每个ProcessBuilder的redirectErrorStream适用于相应的过程。 如果设置为true ，错误流将被写入与标准输出相同的流。

        如果启动任何进程抛出异常，所有进程都被强制销毁。

        startPipeline方法对每个ProcessBuilder执行相同的检查，与start()方法一样。 新进程将调用由指定的命令和参数command()按以下给出，在工作目录directory() ，有一个过程的环境被给出environment() 。

        该方法检查该命令是否为有效的操作系统命令。 哪些命令有效是依赖于系统的，但至少该命令必须是非空字符串的非空列表。

        在某些操作系统上启动一个进程可能需要一小部分与系统相关的环境变量。 因此，子进程可能会继承其他环境变量设置，而不是进程生成器的environment() 。

        如果有一个安全管理器，它的checkExec方法被调用与该对象的command数组的第一个组件作为其参数。 这可能会导致抛出SecurityException 。

        启动操作系统进程与系统相关。 许多可能出错的事情是：

        • 找不到操作系统程序文件。
        • 对程序文件的访问被拒绝。
        • 工作目录不存在。
        • 命令参数中的字符无效，如NUL。

        在这种情况下，会抛出异常。 异常的确切性质是系统依赖的，但它始终是IOException的子类。

        如果操作系统不支持创建进程，则会抛出一个UnsupportedOperationException 。

        对此流程构建器的后续修改不会影响返回的Process 。

        API Note:
        例如，要计算Unix兼容平台上文件层次结构中所有文件的唯一导入：
           String directory = "/home/duke/src"; ProcessBuilder[] builders = { new ProcessBuilder("find", directory, "-type", "f"), new ProcessBuilder("xargs", "grep", "-h", "^import "), new ProcessBuilder("awk", "{print $2;}"), new ProcessBuilder("sort", "-u")}; List<Process> processes = ProcessBuilder.startPipeline( Arrays.asList(builders)); Process last = processes.get(processes.size()-1); try (InputStream is = last.getInputStream(); Reader isr = new InputStreamReader(is); BufferedReader r = new BufferedReader(isr)) { long count = r.lines().count(); }
        参数
        builders - ProcessBuilders列表
        结果
        一个 List<Process>从相应的ProcessBuilder开始
        异常
        IllegalArgumentException - 除了第一个构建器的标准输入和最后一个构建器的标准输出之外的任何重定向不是 ProcessBuilder.Redirect.PIPE 。
        NullPointerException - 如果命令列表的元素为空，或者ProcessBuilder列表的元素为空或者构建器参数为空
        IndexOutOfBoundsException - 如果命令是空列表（具有大小 0 ）
        SecurityException - 如果存在安全管理员，
        • 它的checkExec方法不允许创建子进程 ，或者
        • 子流程的标准输入为redirected from a file ，安全管理员的checkRead方法拒绝对该文件的读取访问，或
        • 子进程的标准输出或标准错误为redirected to a file ，安全管理员的checkWrite方法拒绝对文件的写入访问
        UnsupportedOperationException - 如果操作系统不支持创建进程
        IOException - 如果发生I / O错误
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProcessBuilder.Redirect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ProcessBuilder.Redirect

  • java.lang.Object
    • java.lang.ProcessBuilder.Redirect
  • Enclosing class:
    ProcessBuilder

    public abstract static class ProcessBuilder.Redirect
extends Object
    表示子进程输入的源或子进程输出的目的地。 每个Redirect实例是以下之一：
    • 特殊值Redirect.PIPE
    • 特价Redirect.INHERIT
    • 特价Redirect.DISCARD
    • 从文件读取的重定向，通过调用Redirect.from(File)创建
    • 通过调用Redirect.to(File)创建的用于写入文件的重定向
    • 通过调用Redirect.appendTo(File)创建的用于追加到文件的重定向

    以上每个类别都有一个关联的唯一的Type 。

    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ProcessBuilder.Redirect.Type
      一种ProcessBuilder.Redirect的类型。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static ProcessBuilder.Redirect DISCARD
      表示子进程输出将被丢弃。
      static ProcessBuilder.Redirect INHERIT
      表示子进程I / O源或目标将与当前进程的相同。
      static ProcessBuilder.Redirect PIPE
      表示子流程I / O将通过管道连接到当前的Java进程。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      static ProcessBuilder.Redirect appendTo​(File file)
      返回重定向以附加到指定的文件。
      boolean equals​(Object obj)
      将指定的对象与此 Redirect进行比较以获得相等性。
      File file​()
      返回File源或目标与此重定向或相关null ，如果没有这样的文件。
      static ProcessBuilder.Redirect from​(File file)
      返回从指定文件读取的重定向。
      int hashCode​()
      返回此 Redirect的哈希码值。
      static ProcessBuilder.Redirect to​(File file)
      返回写入指定文件的重定向。
      abstract ProcessBuilder.Redirect.Type type​()
      返回此 Redirect的类型。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • PIPE

        public static final ProcessBuilder.Redirect PIPE
        表示子流程I / O将通过管道连接到当前的Java进程。 这是子进程标准I / O的默认处理。

        这永远是真的

           Redirect.PIPE.file() == null && Redirect.PIPE.type() == Redirect.Type.PIPE

      • INHERIT

        public static final ProcessBuilder.Redirect INHERIT
        表示子进程I / O源或目标将与当前进程的相同。 这是大多数操作系统命令解释器（shell）的正常行为。

        这永远是真的

           Redirect.INHERIT.file() == null && Redirect.INHERIT.type() == Redirect.Type.INHERIT

      • DISCARD

        public static final ProcessBuilder.Redirect DISCARD
        表示子进程输出将被丢弃。 典型的实现通过写入操作系统特定的“空文件”来丢弃输出。

        这永远是真的

           Redirect.DISCARD.file() is the filename appropriate for the operating system and may be null && Redirect.DISCARD.type() == Redirect.Type.WRITE
        从以下版本开始：
        9

    • 方法详细信息

      • type

        public abstract ProcessBuilder.Redirect.Type type​()
        返回此 Redirect的类型。
        结果
        这种类型的 Redirect

      • file

        public File file​()
        返回File源或目标与此重定向或相关null ，如果没有这样的文件。
        结果
        与此重定向相关联的文件，如果没有这样的文件， null

      • from

        public static ProcessBuilder.Redirect from​(File file)
        返回从指定文件读取的重定向。

        这永远是真的

           Redirect.from(file).file() == file && Redirect.from(file).type() == Redirect.Type.READ
        参数
        file - File为 Redirect 。
        结果
        从指定文件读取的重定向

      • to

        public static ProcessBuilder.Redirect to​(File file)
        返回写入指定文件的重定向。 如果指定的文件存在子进程启动时，其先前的内容将被丢弃。

        这永远是真的

           Redirect.to(file).file() == file && Redirect.to(file).type() == Redirect.Type.WRITE
        参数
        file - File为 Redirect 。
        结果
        重定向写入指定的文件

      • appendTo

        public static ProcessBuilder.Redirect appendTo​(File file)
        返回重定向以附加到指定的文件。 每个写入操作首先将位置提前到文件的末尾，然后写入所请求的数据。 在单一原子操作中是否提升位置和写入数据是依赖于系统的，因此是未指定的。

        这永远是真的

           Redirect.appendTo(file).file() == file && Redirect.appendTo(file).type() == Redirect.Type.APPEND
        参数
        file - File为 Redirect 。
        结果
        重定向到附加到指定的文件

      • equals

        public boolean equals​(Object obj)
        将指定的对象与此Redirect进行比较以获得相等性。 返回true当且仅当两个对象相同或两个对象是Redirect与非空相等的相同类型的实例相等于File实例时。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 Redirect的哈希码值。
        重写：
        hashCode在 Object
        结果
        这个 Redirect的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProcessBuilder.Redirect.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang

Enum ProcessBuilder.Redirect.Type

  • java.lang.Object
    • java.lang.Enum<ProcessBuilder.Redirect.Type>
      • java.lang.ProcessBuilder.Redirect.Type
  • All Implemented Interfaces:
    Serializable ， Comparable<ProcessBuilder.Redirect.Type>
    Enclosing class:
    ProcessBuilder.Redirect

    public static enum ProcessBuilder.Redirect.Type
extends Enum<ProcessBuilder.Redirect.Type>
    类型为ProcessBuilder.Redirect 。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      APPEND
      从 Redirect.appendTo(File)返回的重定向类型。
      INHERIT
      类型 Redirect.INHERIT 。
      PIPE
      类型 Redirect.PIPE 。
      READ
      从 Redirect.from(File)返回的重定向类型。
      WRITE
      从 Redirect.to(File)返回的重定向类型。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ProcessBuilder.Redirect.Type valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ProcessBuilder.Redirect.Type[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PIPE

        public static final ProcessBuilder.Redirect.Type PIPE
        类型 Redirect.PIPE 。

      • INHERIT

        public static final ProcessBuilder.Redirect.Type INHERIT
        类型 Redirect.INHERIT 。

      • READ

        public static final ProcessBuilder.Redirect.Type READ
        从 Redirect.from(File)返回的重定向类型。

      • WRITE

        public static final ProcessBuilder.Redirect.Type WRITE
        从 Redirect.to(File)返回的重定向类型。

      • APPEND

        public static final ProcessBuilder.Redirect.Type APPEND
        从 Redirect.appendTo(File)返回的重定向类型。

    • 方法详细信息

      • values

        public static ProcessBuilder.Redirect.Type[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ProcessBuilder.Redirect.Type c : ProcessBuilder.Redirect.Type.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ProcessBuilder.Redirect.Type valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ProcessHandle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface ProcessHandle

  • All Superinterfaces:
    Comparable<ProcessHandle>

    public interface ProcessHandle
extends Comparable<ProcessHandle>
    ProcessHandle识别并提供对本机进程的控制。 可以对每个单独的过程进行监控，以查看活动，列出其子项，获取有关流程的信息或将其消除。 相比之下，当前进程启动了Process个实例，并且还提供对进程输入，输出和错误流的访问。

    本地进程ID是操作系统分配给进程的标识号。 进程ID值的范围取决于操作系统。 例如，嵌入式系统可能使用16位值。 从本机系统检索有关进程的状态信息，可能会异步更改; 过程可能会自动创建或终止。 进程终止之间的时间和进程ID被重新用于新进程是不可预测的。 在检查过程的状态并对其进行操作之间可以存在种族条件。 使用ProcessHandles时，可以避免对基础过程的活动或身份的假设。

    每个ProcessHandle标识并允许控制本机系统中的进程。 ProcessHandles从工厂方法返回current() ， of(long) ， children() ， descendants() ， parent()和allProcesses() 。

    可以查询由ProcessBuilder创建的Process实例，以提供有关进程的信息的ProcessHandle。 ProcessHandle引用不应该免费分发。

    可以使用可从onExit()获得的CompletableFuture等待进程终止，并可能触发依赖操作。

    工厂方法使用SecurityManager检查RuntimePermission("manageProcess")限制对ProcessHandles的访问 。 控制进程的能力也受到本地系统的限制，因此ProcessHandle不比本机应用程序允许的更多地访问或控制本机进程。

    实现要求：
    在ProcessHandles不能被支持的情况下，工厂方法必须始终抛出UnsupportedOperationException 。 该类的方法抛出UnsupportedOperationException，如果操作系统不允许访问查询或杀死进程。

    ProcessHandle静态工厂方法返回的实例是value-based ，不可变且线程安全。 对这些ProcessHandle实例的使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能会产生不可预测的结果，应该避免使用。 使用equals或compareTo方法来比较ProcessHandles。

    从以下版本开始：
    9
    另请参见：
    Process

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static interface  ProcessHandle.Info
      关于流程的信息快照。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      static Stream<ProcessHandle> allProcesses​()
      返回当前进程可见的所有进程的快照。
      Stream<ProcessHandle> children​()
      返回进程当前直接子节点的快照。
      int compareTo​(ProcessHandle other)
      将此ProcessHandle与指定的ProcessHandle进行比较。
      static ProcessHandle current​()
      返回当前进程的ProcessHandle。
      Stream<ProcessHandle> descendants​()
      返回进程后代的快照。
      boolean destroy​()
      请求进程被杀死。
      boolean destroyForcibly​()
      要求进程被强行杀死。
      boolean equals​(Object other)
      返回true如果other对象是非空的，是同一个实现，并且代表相同的系统进程; 否则返回false 。
      int hashCode​()
      返回此ProcessHandle的哈希码值。
      ProcessHandle.Info info​()
      返回有关进程信息的快照。
      boolean isAlive​()
      测试此 ProcessHandle代表的过程是否存活。
      static Optional<ProcessHandle> of​(long pid)
      返回现有本机进程的 Optional<ProcessHandle> 。
      CompletableFuture<ProcessHandle> onExit​()
      返回一个 CompletableFuture<ProcessHandle>的终止进程。
      Optional<ProcessHandle> parent​()
      返回父进程的一个 Optional<ProcessHandle> 。
      long pid​()
      返回进程的本机进程ID。
      boolean supportsNormalTermination​()
      返回 true如果执行 destroy()正常终止进程。

    • 方法详细信息

      • pid

        long pid​()
        返回进程的本机进程ID。 本地进程ID是操作系统分配给进程的标识号。 操作系统可以在进程终止之后重用进程ID。 使用equals或compareTo来比较ProcessHandles。
        结果
        进程的本机进程ID
        异常
        UnsupportedOperationException - 如果实现不支持此操作

      • of

        static Optional<ProcessHandle> of​(long pid)
        返回现有本机进程的 Optional<ProcessHandle> 。
        参数
        pid - 本机进程ID
        结果
        一个Optional<ProcessHandle>的PID进程; 如果进程不存在，则Optional为空
        异常
        SecurityException - 如果已安装安全管理器，并拒绝RuntimePermission（“manageProcess”）
        UnsupportedOperationException - 如果实现不支持此操作

      • current

        static ProcessHandle current​()
        返回当前进程的ProcessHandle。 ProcessHandle不能用于销毁当前进程，而是使用System.exit 。
        结果
        当前进程的ProcessHandle
        异常
        SecurityException - 如果已安装安全管理器，并且它拒绝RuntimePermission（“manageProcess”）
        UnsupportedOperationException - 如果实现不支持此操作

      • parent

        Optional<ProcessHandle> parent​()
        返回父进程的一个Optional<ProcessHandle> 。 请注意，僵尸状态下的进程通常没有父进程。
        结果
        一个Optional<ProcessHandle>的父进程; 如果子进程没有父进程或者父进程不可用，则Optional为空，可能是由于操作系统限制
        异常
        SecurityException - 如果已安装安全管理器，并拒绝RuntimePermission（“manageProcess”）

      • children

        Stream<ProcessHandle> children​()
        返回进程当前直接子节点的快照。 直接子进程的parent()是进程。 通常，进程是not alive没有孩子。

        请注意，进程被创建并异步终止。 不能保证进程是alive 。

        结果
        一个连续的ProcessHandles Stream，用于流程的直接子进程
        异常
        SecurityException - 如果已安装安全管理器，并拒绝RuntimePermission（“manageProcess”）

      • descendants

        Stream<ProcessHandle> descendants​()
        返回进程后代的快照。 一个进程的后代是进程的孩子加上那些孩子的后裔，递归地。 通常，一个进程是not alive没有孩子。

        请注意，进程被创建并异步终止。 不能保证一个进程是alive 。

        结果
        用于进程的连续流ProcessHandles作为进程的后代
        异常
        SecurityException - 如果已安装安全管理器，并拒绝RuntimePermission（“manageProcess”）

      • allProcesses

        static Stream<ProcessHandle> allProcesses​()
        返回当前进程可见的所有进程的快照。

        请注意，进程被创建并异步终止。 不保证流中的进程是活着的，或者自快照开始以来，不能创建其他进程。

        结果
        所有流程的ProcessHandles流
        异常
        SecurityException - 如果已安装安全管理器，并且它拒绝RuntimePermission（“manageProcess”）
        UnsupportedOperationException - 如果实现不支持此操作

      • info

        ProcessHandle.Info info​()
        返回有关进程信息的快照。

        一个ProcessHandle.Info实例具有访问器方法，返回有关进程的信息（如果可用）。

        结果
        关于进程的信息的快照，始终为非空

      • onExit

        CompletableFuture<ProcessHandle> onExit​()
        返回一个CompletableFuture<ProcessHandle>终止进程。 CompletableFuture提供了在进程终止时触发可以同步或异步运行的从属功能或动作的功能。 当进程已经终止时，无论进程的退出状态如何，CompletableFuture为completed 。 当进程退出时，可以多次调用onExit方法来调用独立动作。

        调用onExit().get()等待进程终止并返回ProcessHandle。 未来可以用来检查过程是否为done或wait ，以便终止。 Cancelling CompleteableFuture不会影响进程。

        API Note:
        在ComputableFuture完成并调用依赖操作之前，可以观察到该过程已终止于 isAlive() 。
        结果
        一个新的 CompletableFuture<ProcessHandle>为ProcessHandle
        异常
        IllegalStateException - 如果进程是当前进程

      • supportsNormalTermination

        boolean supportsNormalTermination​()
        返回true如果执行destroy()正常终止进程。 返回false如果执行destroy强制立即终止进程。
        结果
        true如果执行destroy()正常终止进程; 否则， destroy()强制终止进程

      • destroy

        boolean destroy​()
        请求进程被杀死。 由此ProcessHandle对象表示的进程是否为normally terminated否是实现依赖。 强制流程破坏被定义为流程的即时终止，而正常的终止允许流程干净地关闭。 如果该过程不存在，则不采取任何行动。 操作系统访问控制可能会阻止进程被杀死。

        CompletableFuture从onExit()是completed当进程已经终止。

        注意：进程可能不会立即终止。 例如， isAlive()可能会在destroy()被调用后的destroy()返回true。

        结果
        true如果成功请求终止，否则为 false
        异常
        IllegalStateException - 如果进程是当前进程

      • destroyForcibly

        boolean destroyForcibly​()
        要求进程被强行杀死。 此ProcessHandle对象表示的进程被强制终止。 强制流程破坏被定义为流程的即时终止，而正常的终止允许流程干净地关闭。 如果该过程不存在，则不采取任何行动。 操作系统访问控制可能会阻止进程被杀死。

        CompletableFuture从onExit()是completed当进程已经终止。

        注意：进程可能不会立即终止。 例如， isAlive()可能会在destroyForcibly()被调用后的destroyForcibly()返回true。

        结果
        true如果成功请求终止，否则为 false
        异常
        IllegalStateException - 如果进程是当前进程

      • isAlive

        boolean isAlive​()
        测试此ProcessHandle表示的过程是否存活。 流程终止是具体的实现和操作系统。 只要PID有效，该过程就被认为是活着的。
        结果
        true如果由此 ProcessHandle对象表示的进程尚未终止

      • hashCode

        int hashCode​()
        返回此ProcessHandle的哈希码值。 哈希码值遵循Object.hashCode()的一般合同。 该值是pid()值的函数，可以是唯一标识过程的附加信息的函数。 如果根据equals方法两个ProcessHandles相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        boolean equals​(Object other)
        如果other对象为非空，则返回true ，具有相同的实现，并表示相同的系统进程; 否则返回false 。
        重写：
        equals在类 Object
        Implementation Note:
        具有相同PID的ProcessHandles表示相同的系统进程是具体的实现。 ProcessHandle实现应包含唯一标识进程的附加信息。 例如，可以使用该过程的开始时间来确定PID是否已被重新使用。 对于具有相同PID的两个ProcessHandles， equals的实现应该返回true ，除非有信息来区分它们。
        参数
        other - 另一个对象
        结果
        true如果other对象是非空的，是同一个实现类并表示相同的系统进程; 否则返回false
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        int compareTo​(ProcessHandle other)
        将此ProcessHandle与指定的ProcessHandle进行比较。 订单未指定，但与Object.equals(java.lang.Object)一致，当且仅当ProcessHandle的两个实例具有相同的实现并且表示相同的系统进程时，该值将返回true 。 只有相同实现的对象之间才支持比较。 如果尝试相互比较ProcessHandle的两个不同实现，则抛出ClassCastException 。
        Specified by:
        compareTo在接口 Comparable<ProcessHandle>
        参数
        other - 要比较的ProcessHandle
        结果
        负整数，零或正整数，因为该对象小于，等于或大于指定对象。
        异常
        NullPointerException - 如果指定的对象为空
        ClassCastException - if the specified object is not of same class as this object
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProcessHandle.Info (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface ProcessHandle.Info

  • Enclosing interface:
    ProcessHandle

    public static interface ProcessHandle.Info
    关于流程的信息快照。 过程的属性因操作系统而异，并且在所有实现中都不可用。 有关进程的信息受到发出请求的进程的操作系统特权的限制。 返回类型为Optional<T>允许显式测试和操作（如果该值可用）。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Optional<String[]> arguments​()
      返回进程参数的Strings数组。
      Optional<String> command​()
      返回进程的可执行路径名。
      Optional<String> commandLine​()
      返回进程的命令行。
      Optional<Instant> startInstant​()
      返回进程的开始时间。
      Optional<Duration> totalCpuDuration​()
      返回进程累积的总计。
      Optional<String> user​()
      返回进程的用户。

    • 方法详细信息

      • command

        Optional<String> command​()
        返回进程的可执行路径名。
        结果
        一个 Optional<String>的可执行路径名的进程

      • commandLine

        Optional<String> commandLine​()
        返回进程的命令行。

        如果command()和arguments()返回非空的可选项，这只是一个方便的方法，连接两个空格分隔的函数的值。 否则，它将返回命令行的尽力而为的依赖于平台的表示。

        API Note:
        请注意，由于系统限制，返回的可执行路径名和参数可能会在某些平台上被截断。

        可执行路径名可能只包含可执行文件的名称，而不包含完整的路径信息。 白色空间是否分开不同的参数或是单个参数的一部分是不可取的。

        结果
        一个 Optional<String>的命令行的进程

      • arguments

        Optional<String[]> arguments​()
        返回进程参数的Strings数组。
        API Note:
        在某些平台上，本地应用程序可以在启动后自由更改arguments数组，并且此方法只能显示更改的值。
        结果
        一个 Optional<String[]>的过程论点

      • startInstant

        Optional<Instant> startInstant​()
        返回进程的开始时间。
        结果
        一个 Optional<Instant>的开始时间的过程

      • totalCpuDuration

        Optional<Duration> totalCpuDuration​()
        返回进程累积的总计。
        结果
        一个 Optional<Duration>累计总put。

      • user

        Optional<String> user​()
        返回进程的用户。
        结果
        一个 Optional<String>为用户的进程
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Readable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface Readable

  • 所有已知实现类：
    BufferedReader ， CharArrayReader ， CharBuffer ， FileReader ， FilterReader ， InputStreamReader ， LineNumberReader ， PipedReader ， PushbackReader ， Reader ， StringReader ， URLReader

    public interface Readable
    A Readable是字符源。 来自Readable字符通过Readable向读取方法的呼叫者提供 。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int read​(CharBuffer cb)
      尝试将字符读入指定的字符缓冲区。

    • 方法详细信息

      • read

        int read​(CharBuffer cb)
  throws IOException
        尝试将字符读入指定的字符缓冲区。 缓冲区用作字符存储库：唯一的更改是put操作的结果。 不执行缓冲器的翻转或倒带。
        参数
        cb - 读取字符的缓冲区
        结果
        添加到缓冲区的值为 char ，如果此字符源结束，则为-1
        异常
        IOException - 如果发生I / O错误
        NullPointerException - 如果cb为空
        ReadOnlyBufferException - 如果cb是只读缓冲区
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReflectiveOperationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ReflectiveOperationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.ReflectiveOperationException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    ClassNotFoundException ， IllegalAccessException ， InstantiationException ， InvocationTargetException ， NoSuchFieldException ， NoSuchMethodException

    public class ReflectiveOperationException
extends 异常
    核心反射中的反射操作抛出的异常的常见超类。
    从以下版本开始：
    1.7
    另请参见：
    LinkageError ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReflectiveOperationException​()
      构造一个新的异常，以 null作为其详细信息。
      ReflectiveOperationException​(String message)
      使用指定的详细消息构造新的异常。
      ReflectiveOperationException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      ReflectiveOperationException​(Throwable cause)
      构造一个具有指定原因的新异常和一个详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ReflectiveOperationException

        public ReflectiveOperationException​()
        构造一个新的异常，以null作为其详细信息。 原因未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。

      • ReflectiveOperationException

        public ReflectiveOperationException​(String message)
        使用指定的详细消息构造新的异常。 原因未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。
        参数
        message - 详细信息。 保存详细信息，以便稍后通过Throwable.getMessage()检索。

      • ReflectiveOperationException

        public ReflectiveOperationException​(String message,
                                    Throwable cause)
        构造一个新的异常与指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此异常的详细消息。

        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值为null ，表示原因不存在或未知。）

      • ReflectiveOperationException

        public ReflectiveOperationException​(Throwable cause)
        构造具有指定原因的新异常和详细信息 (cause==null ? null : cause.toString()) （通常包含类别和详细信息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，表示原因不存在或未知。）
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Runnable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface Runnable

  • All Known Subinterfaces:
    RunnableFuture<V> ， RunnableScheduledFuture<V>
    所有已知实现类：
    AsyncBoxView.ChildState ， ForkJoinWorkerThread ， FutureTask ， RenderableImageProducer ， SwingWorker ， Task ， Thread ， TimerTask
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public interface Runnable
    Runnable接口应由任何类实现，其实例将由线程执行。 该类必须定义一个无参数的方法，称为run 。

    该接口旨在为希望在活动时执行代码的对象提供一个通用协议。 例如， Runnable由类Thread实现。 活跃的只是意味着一个线程已经启动，还没有被停止。

    此外， Runnable提供了一个类是活动的手段，而不是子类化Thread 。 实现Runnable类Thread通过实例化一个Thread实例并将其自身作为目标来运行，而无需子类化Thread 。 在大多数情况下，如果您仅计划覆盖run()方法，而不使用其他Thread方法，则应使用Runnable接口。 这是重要的，因为类不应该被子类化，除非程序员打算修改或增强类的基本行为。

    从以下版本开始：
    1.0
    另请参见：
    Thread ， Callable

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void run​()
      当使用实现接口 Runnable的对象来创建线程时，启动线程将使该对象的 run方法在单独执行的线程中被调用。

    • 方法详细信息

      • run

        void run​()
        当使用实现接口Runnable的对象来创建线程时，启动线程将使该对象的run方法在单独执行的线程中被调用。

        方法run的一般合同是它可以采取任何行动。

        另请参见：
        Thread.run()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Runtime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Runtime

  • java.lang.Object
    • java.lang.Runtime

  • public class Runtime
extends Object
    每个Java应用程序都有一个Runtime类的Runtime ，允许应用程序与运行应用程序的环境进行接口。 当前运行时可以从getRuntime获取。

    应用程序无法创建自己的此类的实例。

    从以下版本开始：
    1.0
    另请参见：
    getRuntime()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Runtime.Version
      用于实现Java SE平台的版本字符串的表示。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void addShutdownHook​(Thread hook)
      注册一个新的虚拟机关机挂钩。
      int availableProcessors​()
      返回可用于Java虚拟机的处理器数量。
      Process exec​(String command)
      在单独的进程中执行指定的字符串命令。
      Process exec​(String[] cmdarray)
      在单独的进程中执行指定的命令和参数。
      Process exec​(String[] cmdarray, String[] envp)
      在指定环境的单独进程中执行指定的命令和参数。
      Process exec​(String[] cmdarray, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的命令和参数。
      Process exec​(String command, String[] envp)
      在具有指定环境的单独进程中执行指定的字符串命令。
      Process exec​(String command, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的字符串命令。
      void exit​(int status)
      通过启动其关闭序列来终止当前正在运行的Java虚拟机。
      long freeMemory​()
      返回Java虚拟机中的可用内存量。
      void gc​()
      运行垃圾回收器。
      InputStream getLocalizedInputStream​(InputStream in)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1开始，将本地编码中的字节流转换为Unicode中的字符流的首选方法是通过InputStreamReader和BufferedReader类。 此方法在将来的Java SE版本中可能会被删除。
      OutputStream getLocalizedOutputStream​(OutputStream out)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。
      static Runtime getRuntime​()
      返回与当前Java应用程序关联的运行时对象。
      void halt​(int status)
      强制终止当前正在运行的Java虚拟机。
      void load​(String filename)
      加载由filename参数指定的本机库。
      void loadLibrary​(String libname)
      加载由 libname参数指定的本机库。
      long maxMemory​()
      返回Java虚拟机将尝试使用的最大内存量。
      boolean removeShutdownHook​(Thread hook)
      取消注册以前注册的虚拟机关闭挂接。
      void runFinalization​()
      运行任何对象等待定稿的最终化方法。
      static void runFinalizersOnExit​(boolean value)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
      long totalMemory​()
      返回Java虚拟机中的内存总量。
      void traceInstructions​(boolean on)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法旨在控制指令跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
      void traceMethodCalls​(boolean on)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此方法旨在控制方法调用跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
      static Runtime.Version version​()
      以Runtime.Version返回Java运行时环境的版本 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getRuntime

        public static Runtime getRuntime​()
        返回与当前Java应用程序关联的运行时对象。 Runtime类的大多数方法都是实例方法，必须针对当前的运行时对象进行调用。
        结果
        与当前Java应用程序相关联的 Runtime对象。

      • exit

        public void exit​(int status)
        通过启动其关闭序列来终止当前正在运行的Java虚拟机。 此方法从不正常返回。 该参数作为状态代码; 按照惯例，非零状态码表示异常终止。

        虚拟机的关机顺序由两个阶段组成。 在第一阶段，所有注册的shutdown hooks （如果有的话）以某种未指定的顺序启动，并允许同时运行，直到完成。 在第二阶段，如果已启用了finalization-on-exit，则所有未归端的终结器都将运行。 一旦完成，虚拟机halts 。

        如果在虚拟机已经开始关闭序列之后调用此方法，那么如果关闭挂钩正在运行，则此方法将无限期地阻止。 如果关闭挂钩已经运行，并且已启用了退出完成，那么如果状态为非零，则此方法将使用给定状态代码暂停虚拟机; 否则，它将无限期地阻止。

        System.exit方法是调用此方法的常规方便方法。

        参数
        status - 终止状态。 按照惯例，非零状态码表示异常终止。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExit方法不允许以指定状态退出
        另请参见：
        SecurityException ， SecurityManager.checkExit(int) ， addShutdownHook(java.lang.Thread) ， removeShutdownHook(java.lang.Thread) ， runFinalizersOnExit(boolean) ， halt(int)

      • addShutdownHook

        public void addShutdownHook​(Thread hook)
        注册一个新的虚拟机关机挂钩。

        Java虚拟机关闭两种事件：

        • 在程序正常退出 ，当最后一个非守护线程退出时，或者当exit （等同于System.exit ）方法被调用，或
        • 响应于用户中断（例如键入^C ）或系统范围的事件（例如用户注销或系统关闭） 终止虚拟机。

        一个关机钩子只是一个初始化但未启动的线程。 当虚拟机开始关闭序列时，它将以一些未指定的顺序启动所有注册的关闭挂钩，并让它们同时运行。 当所有的钩子都完成后，如果已经启用了最终确定的退出，它将运行所有未被终止的终结器。 最后，虚拟机将停止。 请注意，守护程序线程将在关闭序列期间继续运行，非守护线程如果通过调用exit方法启动关闭，则该守护程序线程也将继续。

        一旦关闭序列开始，只能通过调用强制终止虚拟机的halt方法来停止它。

        一旦关闭序列已经开始，就不可能注册新的关机挂钩或者取消注册先前注册的钩子。 尝试这些操作之一将导致抛出IllegalStateException 。

        关机钩子在虚拟机的生命周期中的微妙时间运行，因此应该进行防御性编码。 特别是应该写成线程安全的，并尽可能避免死锁。 他们也不应盲目依赖可能已经注册自己的关闭挂钩的服务，因此本身可能会关闭。 例如，尝试使用其他基于线程的服务（例如AWT事件发送线程）可能会导致死锁。

        关闭挂钩也应该快速完成工作。 当程序调用exit时 ，期望虚拟机将及时关闭并退出。 当虚拟机由于用户注销或系统关闭而终止时，底层操作系统可能只允许一段固定的时间关闭和退出。 因此，不要在关机挂钩中尝试任何用户交互或执行长时间运行的计算。

        通过调用线程的ThreadGroup对象的uncaughtException方法，关闭钩子中的未捕获异常与其他任何线程一样处理。 此方法的默认实现将异常的堆栈跟踪打印到System.err并终止线程; 它不会导致虚拟机退出或停止。

        在极少数情况下，虚拟机可能会中止 ，也就是停止运行而不会完全关闭。 当虚拟机从外部终止时，例如使用Unix上的SIGKILL信号或Microsoft Windows上的TerminateProcess调用，就会发生这种情况。 如果本机方法例如破坏内部数据结构或尝试访问不存在的内存，虚拟机也可能中止。 如果虚拟机中止，则不能保证是否关闭挂钩将被运行。

        参数
        hook - 已初始化但未启动的Thread对象
        异常
        IllegalArgumentException - 如果指定的钩子已经被注册，或者如果可以确定挂钩已经在运行或已经运行
        IllegalStateException - 如果虚拟机已经处于关闭状态
        SecurityException - 如果安全管理器存在，并且它拒绝RuntimePermission （“shutdownHooks”）
        从以下版本开始：
        1.3
        另请参见：
        removeShutdownHook(java.lang.Thread) ， halt(int) ， exit(int)

      • removeShutdownHook

        public boolean removeShutdownHook​(Thread hook)
        取消注册以前注册的虚拟机关闭挂接。
        参数
        hook - 要删除的钩子
        结果
        true如果指定的钩子先前已经注册并被成功注销，否则为 false 。
        异常
        IllegalStateException - 如果虚拟机已经处于关闭状态
        SecurityException - 如果安全管理员存在，并且它拒绝RuntimePermission （“shutdownHooks”）
        从以下版本开始：
        1.3
        另请参见：
        addShutdownHook(java.lang.Thread) ， exit(int)

      • halt

        public void halt​(int status)
        强制终止当前正在运行的Java虚拟机。 此方法从不正常返回。

        这种方法应该非常小心。 与exit方法不同，此方法不会导致关闭挂钩启动，如果已启用完成终止，则不会运行未命名的终结器。 如果关闭序列已经被启动，则该方法不等待任何运行的关闭挂钩或终结器完成其工作。

        参数
        status - 终止状态。 按照惯例，非零状态码表示异常终止。 如果已经调用了exit （等效的， System.exit ）方法，则该状态代码将覆盖传递给该方法的状态代码。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExit方法不允许具有指定状态的退出
        从以下版本开始：
        1.3
        另请参见：
        exit(int) ， addShutdownHook(java.lang.Thread) ， removeShutdownHook(java.lang.Thread)

      • runFinalizersOnExit

        @Deprecated(since="1.2",
            forRemoval=true)
public static void runFinalizersOnExit​(boolean value)
        不推荐用于删除：此API元素将在以后的版本中被删除。 这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
        退出时启用或禁用最终化; 这样做指定了具有尚未自动调用的finalizer的所有对象的finalizer将在Java运行时退出之前运行。 默认情况下，退出时终止。

        如果有一个安全管理器，它的checkExit方法首先被调用为0作为参数，以确保退出是允许的。 这可能会导致SecurityException。

        参数
        value - true可在退出时启用完成，false禁用
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExit方法不允许退出。
        从以下版本开始：
        1.1
        另请参见：
        exit(int) ， gc() ， SecurityManager.checkExit(int)

      • exec

        public Process exec​(String command)
             throws IOException
        在单独的进程中执行指定的字符串命令。

        这是一种方便的方法。 表单exec(command)的调用方式与调用exec (command, null, null) 。

        参数
        command - 指定的系统命令。
        结果
        用于管理子进程的新的Process对象
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExec方法不允许创建子 进程
        IOException - 如果发生I / O错误
        NullPointerException - 如果 command是 null
        IllegalArgumentException - 如果 command为空
        另请参见：
        exec(String[], String[], File) ， ProcessBuilder

      • exec

        public Process exec​(String command,
                    String[] envp)
             throws IOException
        在具有指定环境的单独进程中执行指定的字符串命令。

        这是一种方便的方法。 表单exec(command, envp)的调用与调用exec (command, envp, null) 。

        参数
        command - 指定的系统命令。
        envp - 字符串数组，每个元素的数组具有格式为 name = value的环境变量设置，如果子进程应该继承当前进程的环境， null 。
        结果
        用于管理子进程的新的Process对象
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExec方法不允许创建子 进程
        IOException - 如果发生I / O错误
        NullPointerException -如果 command是 null ，或所述元件中的一个 envp是 null
        IllegalArgumentException - 如果 command为空
        另请参见：
        exec(String[], String[], File) ， ProcessBuilder

      • exec

        public Process exec​(String command,
                    String[] envp,
                    File dir)
             throws IOException
        在指定的环境和工作目录的单独进程中执行指定的字符串命令。

        这是一种方便的方法。 调用表单exec(command, envp, dir)行为方式与调用exec (cmdarray, envp, dir) ，其中cmdarray是cmdarray中所有令牌的command 。

        更准确地说， command字符串使用由调用new {@link StringTokenizer}(command)创建的StringTokenizer分解成令牌，而不再进一步修改字符类别。 然后，令牌化器生成的令牌以相同的顺序放置在新的字符串数组cmdarray中。

        参数
        command - 指定的系统命令。
        envp - 字符串数组，其每个元素具有格式为 name = value的环境变量设置，如果子进程应该继承当前进程的环境， null 。
        dir - 子 dir的工作目录，如果子进程应继承当前进程的工作目录， null 。
        结果
        用于管理子进程的新的Process对象
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExec方法不允许创建子 进程
        IOException - 如果发生I / O错误
        NullPointerException -如果 command是 null ，或所述元件中的一个 envp是 null
        IllegalArgumentException - 如果 command为空
        从以下版本开始：
        1.3
        另请参见：
        ProcessBuilder

      • exec

        public Process exec​(String[] cmdarray)
             throws IOException
        在单独的进程中执行指定的命令和参数。

        这是一种方便的方法。 表单exec(cmdarray)的调用的行为方式与调用exec (cmdarray, null, null) 。

        参数
        cmdarray - 包含调用命令及其参数的数组。
        结果
        用于管理子进程的新的Process对象
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExec方法不允许创建子 进程
        IOException - 如果发生I / O错误
        NullPointerException -如果 cmdarray是 null ，或所述元件中的一个 cmdarray是 null
        IndexOutOfBoundsException - 如果 cmdarray是一个空数组（长度为 0 ）
        另请参见：
        ProcessBuilder

      • exec

        public Process exec​(String[] cmdarray,
                    String[] envp)
             throws IOException
        在指定环境的单独进程中执行指定的命令和参数。

        这是一种方便的方法。 表单exec(cmdarray, envp)的调用的行为方式与调用exec (cmdarray, envp, null) 。

        参数
        cmdarray - 包含调用命令及其参数的数组。
        envp - 字符串数组，其每个元素的格式为 name = value都具有环境变量设置，如果子进程应该继承当前进程的环境， null 。
        结果
        用于管理子进程的新的Process对象
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExec方法不允许创建子 进程
        IOException - 如果发生I / O错误
        NullPointerException -如果 cmdarray是 null ，或所述元件中的一个 cmdarray是 null ，或所述元件中的一个 envp是 null
        IndexOutOfBoundsException - 如果 cmdarray是一个空数组（长度为 0 ）
        另请参见：
        ProcessBuilder

      • exec

        public Process exec​(String[] cmdarray,
                    String[] envp,
                    File dir)
             throws IOException
        在指定的环境和工作目录的单独进程中执行指定的命令和参数。

        给定的字符串数组cmdarray ，表示命令行的令牌，和一个字符串数组envp ，代表“环境”变量设置，此方法创建在其中执行指定的命令的新方法。

        此方法检查cmdarray是一个有效的操作系统命令。 哪些命令有效是依赖于系统的，但至少该命令必须是非空字符串的非空列表。

        如果envp为null ，则子进程继承当前进程的环境设置。

        在某些操作系统上启动一个进程可能需要一小部分与系统相关的环境变量。 因此，子进程可以继承除指定环境中的更多环境变量设置。

        ProcessBuilder.start()现在是启动具有修改环境的进程的首选方式。

        新的子dir的工作目录由dir指定。 如果dir是null ，则子进程继承当前进程的当前工作目录。

        如果存在安全管理器，则使用阵列cmdarray的第一个组件作为参数来调用其checkExec方法。 这可能会导致抛出SecurityException 。

        启动操作系统进程与系统相关。 许多可能出错的事情是：

        • 找不到操作系统程序文件。
        • 对程序文件的访问被拒绝。
        • 工作目录不存在。

        在这种情况下，会抛出异常。 异常的确切性质是系统依赖的，但它将始终是IOException的子类。

        如果操作系统不支持创建进程，则会抛出一个UnsupportedOperationException 。

        参数
        cmdarray - 包含调用命令及其参数的数组。
        envp - 字符串数组，每个元素的格式具有格式为 name = value的环境变量设置，如果子进程应该继承当前进程的环境， null 。
        dir - 子 dir的工作目录，如果子进程继承当前进程的工作目录， null 。
        结果
        用于管理子进程的新的Process对象
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExec方法不允许创建子 进程
        UnsupportedOperationException - 如果操作系统不支持创建进程。
        IOException - 如果发生I / O错误
        NullPointerException -如果 cmdarray是 null ，或所述元件中的一个 cmdarray是 null ，或所述元件中的一个 envp是 null
        IndexOutOfBoundsException - 如果 cmdarray是一个空数组（长度为 0 ）
        从以下版本开始：
        1.3
        另请参见：
        ProcessBuilder

      • availableProcessors

        public int availableProcessors​()
        返回可用于Java虚拟机的处理器数量。

        在虚拟机的特定调用期间，此值可能会更改。 因此，对可用处理器数量敏感的应用程序应偶尔轮询此属性并适当调整其资源使用情况。

        结果
        虚拟机可用的最大处理器数量; 从不小于一个
        从以下版本开始：
        1.4

      • freeMemory

        public long freeMemory​()
        返回Java虚拟机中的可用内存量。 调用gc方法可能会导致返回值返回freeMemory.
        结果
        近似于当前可用于未来分配对象的总内存量，以字节为单位。

      • totalMemory

        public long totalMemory​()
        返回Java虚拟机中的内存总量。 此方法返回的值可能随时间而变化，具体取决于主机环境。

        请注意，保存任何给定类型的对象所需的内存量可能取决于实现。

        结果
        目前可用于当前和未来对象的内存总量，以字节为单位。

      • maxMemory

        public long maxMemory​()
        返回Java虚拟机将尝试使用的最大内存量。 如果没有固有的限制，则返回值Long.MAX_VALUE 。
        结果
        虚拟机将尝试使用的最大内存量，以字节为单位
        从以下版本开始：
        1.4

      • gc

        public void gc​()
        运行垃圾回收器。 调用此方法表明，Java虚拟机花费了回收未使用对象的努力，以使其当前占用的内存可用于快速重用。 当控制从方法调用返回时，虚拟机已尽全力回收所有丢弃的对象。

        名称gc代表“垃圾收集器”。 虚拟机在一个单独的线程中根据需要自动执行此回收过程，即使未明确地调用gc方法。

        方法System.gc()是调用该方法的常规和方便的手段。

      • runFinalization

        public void runFinalization​()
        运行任何对象等待定稿的最终化方法。 调用该方法表明，对运行在Java虚拟机的努力finalize已发现物体的方法被废弃，但其finalize方法还没有被运行。 当控制从方法调用返回时，虚拟机已尽力完成所有未完成的定稿。

        如果未明确地调用runFinalization方法，虚拟机将根据需要在单独的线程中自动执行完成过程。

        方法System.runFinalization()是调用该方法的常规和方便的手段。

        另请参见：
        Object.finalize()

      • traceInstructions

        @Deprecated(since="9",
            forRemoval=true)
public void traceInstructions​(boolean on)
        不推荐用于删除：此API元素将在以后的版本中被删除。 该方法旨在控制指令跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
        没有执行，什么也没做。
        参数
        on - 忽略

      • traceMethodCalls

        @Deprecated(since="9",
            forRemoval=true)
public void traceMethodCalls​(boolean on)
        不推荐用于删除：此API元素将在以后的版本中被删除。 此方法旨在控制方法调用跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
        没有执行，什么也没做。
        参数
        on - 忽略

      • load

        public void load​(String filename)
        加载由filename参数指定的本机库。 filename参数必须是绝对路径名。 （例如Runtime.getRuntime().load("/home/avh/lib/libX11.so"); ）。 如果文件名参数在剥离任何特定于平台的库前缀，路径和文件扩展名时，表示名称为例如L的库，并且名为L的本地库与VM静态链接，则JNI_OnLoad_L函数调用库导出而不是尝试加载动态库。 与参数匹配的文件名不必存在于文件系统中。 有关详细信息，请参阅JNI规范。 否则，文件名参数以实现相关的方式映射到本机库映像。

        首先，如果有一个安全管理员，它的checkLink方法是以filename作为参数来调用的。 这可能会导致安全例外。

        这类似于方法loadLibrary(String) ，但它接受通用文件名作为参数，而不仅仅是库名称，允许加载任何本地代码的文件。

        方法System.load(String)是调用该方法的常规和方便的手段。

        参数
        filename - 要加载的文件。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkLink方法不允许加载指定的动态库
        UnsatisfiedLinkError - 如果文件名不是绝对路径名，则本地库不会与VM静态链接，或者该库不能由主机系统映射到本机库映像。
        NullPointerException - 如果 filename是 null
        另请参见：
        getRuntime() ， SecurityException ， SecurityManager.checkLink(java.lang.String)

      • loadLibrary

        public void loadLibrary​(String libname)
        加载由libname参数指定的本机库。 libname参数不能包含任何平台特定的前缀，文件扩展名或路径。 如果名为libname的本地库与VM静态链接，则调用库导出的JNI_OnLoad_ libname函数。 有关详细信息，请参阅JNI规范。 否则，libname参数从系统库位置加载，并以实现相关的方式映射到本机库映像。

        首先，如果有一个安全管理员，它的checkLink方法是以libname作为参数来调用的。 这可能会导致安全例外。

        方法System.loadLibrary(String)是调用该方法的常规和方便的手段。 如果本机方法用于实现类，则标准策略是将本机代码放入库文件（称为LibFile ），然后放入静态初始化程序：

         static { System.loadLibrary("LibFile"); }
        在班级声明内。 当类被加载和初始化时，本地方法的必要本机代码实现也将被加载。

        如果使用相同的库名称多次调用此方法，则忽略第二个和后续的调用。

        参数
        libname - 图书馆的名称。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkLink方法不允许加载指定的动态库
        UnsatisfiedLinkError - 如果libname参数包含文件路径，本机库不会与VM静态链接，或者该库不能由主机系统映射到本机库映像。
        NullPointerException - 如果 libname是 null
        另请参见：
        SecurityException ， SecurityManager.checkLink(java.lang.String)

      • getLocalizedInputStream

        @Deprecated(since="1.1",
            forRemoval=true)
public InputStream getLocalizedInputStream​(InputStream in)
        不推荐用于删除：此API元素将在以后的版本中被删除。 从JDK 1.1开始，通过InputStreamReader和BufferedReader类将本地编码中的字节流转换为Unicode字符流的首选方法。 此方法在将来的Java SE版本中可能会被删除。
        创建输入流的本地化版本。 该方法需要一个InputStream并返回一个InputStream等效于所有方面的参数，除了它是本地化的：由于从流中读取本地字符集中的字符，它们将自动从本地字符集转换为Unicode。

        如果参数已经是本地化的流，则可能会返回结果。

        参数
        in - InputStream本地化
        结果
        一个本地化的输入流
        另请参见：
        InputStream ， BufferedReader(java.io.Reader) ， InputStreamReader(java.io.InputStream)

      • getLocalizedOutputStream

        @Deprecated(since="1.1",
            forRemoval=true)
public OutputStream getLocalizedOutputStream​(OutputStream out)
        不推荐用于删除：此API元素将在以后的版本中被删除。 从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。
        创建输出流的本地化版本。 该方法需要一个OutputStream并返回一个OutputStream等效于所有方面的参数，除了它被本地化：因为Unicode字符被写入流，它们被自动转换为本地字符集。

        如果参数已经是本地化的流，则可能会返回结果。

        参数
        out - 将本地化的OutputStream
        结果
        一个本地化的输出流
        另请参见：
        OutputStream ， BufferedWriter(java.io.Writer) ， OutputStreamWriter(java.io.OutputStream) ， PrintWriter(java.io.OutputStream)

      • version

        public static Runtime.Version version​()
        以Runtime.Version的形式返回Java运行时环境的版本 。
        结果
        Java运行时环境的Runtime.Version
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Runtime.Version (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Runtime.Version

  • java.lang.Object
    • java.lang.Runtime.Version
  • All Implemented Interfaces:
    Comparable<Runtime.Version>
    Enclosing class:
    Runtime

    public static final class Runtime.Version
extends Object
implements Comparable<Runtime.Version>
    用于实现Java SE平台的版本字符串的表示。 一个版本字符串由一个版本号组成，可以随后预发行和构建信息。

    Version numbers

    版本号 $VNUM是由句点字符（U + 002E）分隔的元素的非空序列。 一个元素是零，或者一个无符号整数，不带前导零。 版本号中的最后一个元素不能为零。 格式为：

         [1-9][0-9]*((\.0)*\.[1-9][0-9]*)*

    序列可以是任意长度，但前三个元素被赋予具体含义，如下所示：

         $MAJOR.$MINOR.$SECURITY

    • $MAJOR ---主要版本号，增加了主要版本，其中包含新版本的Java SE平台规范中指定的重要新功能， 例如 ，用于Java SE 8的JSR 337。特定功能可能会在主要版本中删除，给定提前通知至少一个主要版本，并且在合理的情况下可以进行不相容的更改。 $MAJOR版本号的JDK 8是8 ; $MAJOR版本的JDK 9是9 。 当增加$MAJOR ，将删除所有后续元素。

    • $MINOR ---次要版本号，可能包含兼容的错误修复，相关平台规范的Maintenance Release规定的标准API的修订版本以及该规范范围之外的实现功能（例如新的JDK-特定API，附加服务提供商，新的垃圾收集器以及新的硬件体系结构的端口。

    • $SECURITY ---对于包含重要修复程序的安全更新版本，其安全级别增加，包括为提高安全性所必需的修复。 $SECURITY时不复位$MINOR递增。 对于给定的$MAJOR值，较高的值为$SECURITY ，因此，总是表示更安全的发行，无论$MINOR的值$MINOR 。

    版本号的第四个和后来的元素可免费下载到这个代码库的消费者身上。 除了相应的安全版本中的安全修复之外，这样的消费者可以例如使用第四个元件来识别包含少量关键非安全性修补程序的补丁版本。

    版本号不包括尾随零元素; 即 $SECURITY省略其是否具有零值，和$MINOR如果两个被省略$MINOR和$SECURITY具有零值。

    将版本号中的数字序列与数字，逐点方式中的另一个这样的序列进行比较; 例如 ， 9.9.1小于9.10.3 。 如果一个序列比另一个序列短，则较短序列的丢失元素被认为小于较长序列的相应元素; 例如 ， 9.1.2小于9.1.2.1 。

    Version strings

    版本字符串 $VSTR由如上所述的版本号$VNUM组成，可选地遵循以下格式之一的预发布和构建信息：

         $VNUM(-$PRE)?\+$BUILD(-$OPT)?
     $VNUM-$PRE(-$OPT)?
     $VNUM(+-$OPT)?

    哪里：

    • $PRE ，匹配([a-zA-Z0-9]+) ---预发行标识符。 通常ea ，对于正在积极开发一个潜在不稳定的早期释放的访问，或internal ，用于内部开发版本。

    • $BUILD ，匹配(0|[1-9][0-9]*) ---构建号，每个升级版本增加。 $BUILD复位为1时的任何部分$VNUM递增。

    • $OPT ，匹配([-a-zA-Z0-9.]+) ---附加构建信息，如果需要的话。 在构建internal的情况下，这通常会包含生成的日期和时间。

    版本字符串10-ea匹配$VNUM = "10"和$PRE = "ea" 。 版本字符串10+-ea匹配$VNUM = "10"和$OPT = "ea" 。

    当比较两个版本字符串时，根据所选择的比较方法， $OPT的值（如果存在）可能或可能不显着。 比较方法compareTo()和compareToIgnoreOptional()应与对应的方法equals()和equalsIgnoreOptional()一致使用。

    通常在较不正式的上下文中有用的简短版本字符串 $SVSTR是可选地遵循预发行标识符的版本号：

         $VNUM(-$PRE)?

    这是一个value-based类; 对于Version实例，使用身份敏感操作（包括引用等式（ == ），身份哈希码或同步）可能具有不可预测的结果，应该避免。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Optional<Integer> build​()
      返回 build number 。
      int compareTo​(Runtime.Version obj)
      将此版本与另一版本进行比较。
      int compareToIgnoreOptional​(Runtime.Version obj)
      将此版本与其他版本进行比较，忽略可选构建信息。
      boolean equals​(Object obj)
      确定此 Version是否等于另一个对象。
      boolean equalsIgnoreOptional​(Object obj)
      确定此 Version是否等于另一个忽略可选构建信息。
      int hashCode​()
      返回此版本的哈希码。
      int major​()
      返回 major版本号。
      int minor​()
      如果没有设置，返回 minor版本号或零。
      Optional<String> optional​()
      返回 optional附加识别构建信息。
      static Runtime.Version parse​(String s)
      将给定的字符串解析为有效的 version string，其中包含一个 version number，其后是预发布和构建信息。
      Optional<String> pre​()
      返回可选的 pre-release信息。
      int security​()
      返回 security版本号，如果未设置则返回零。
      String toString​()
      返回此版本的字符串表示形式。
      List<Integer> version​()
      返回version number中包含的整数的不可修改的List 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • parse

        public static Runtime.Version parse​(String s)
        将给定的字符串解析为有效的 version string，其中包含一个 version number，之后是预发布和构建信息。
        参数
        s - 要解释为版本的字符串
        结果
        给定字符串的版本
        异常
        IllegalArgumentException - 如果给定的字符串不能被解释为有效的版本
        NullPointerException - 如果给定的字符串是 null
        NumberFormatException - 如果版本号或版本号的元素不能表示为Integer

      • major

        public int major​()
        返回 major版本号。
        结果
        主要版本号

      • minor

        public int minor​()
        如果没有设置，返回 minor版本号，否则返回零。
        结果
        次要版本号，如果未设置则为零

      • security

        public int security​()
        返回 security版本号，如果未设置则返回零。
        结果
        安全版本号，如果未设置则为零

      • version

        public List<Integer> version​()
        返回version number中包含的整数数字的不可修改的List 。 List总是包含至少一个对应于major version number的元素。
        结果
        包含在版本号中的不可修改的整数数字列表

      • pre

        public Optional<String> pre​()
        返回可选的 pre-release信息。
        结果
        可选的预发布信息作为字符串

      • build

        public Optional<Integer> build​()
        返回 build number 。
        结果
        可选内置号。

      • optional

        public Optional<String> optional​()
        返回 optional附加识别构建信息。
        结果
        附加构建信息作为字符串

      • compareTo

        public int compareTo​(Runtime.Version obj)
        将此版本与另一版本进行比较。

        将version中的每个组件按照以下优先顺序进行比较：版本号，预发布标识符，版本号，可选构建信息。

        比较开始于检查版本号的顺序。 如果一个序列比另一个序列短，则较短序列的缺失元素被认为小于较长序列的相应元素。

        具有预发行标识符的版本始终被认为小于没有版本的版本。 预发行标识符仅在数字组成时才进行数字比较，而按字典顺序排列。 数字标识符被认为小于非数字标识符。

        没有编号的版本总是小于一个具有构建号的版本; 否则建立数字在数字上进行比较。

        可选构建信息在字典上进行比较。 在此比较期间，具有可选构建信息的版本被认为大于没有版本的版本。

        Specified by:
        compareTo在接口 Comparable<Runtime.Version>
        参数
        obj - 要比较的对象
        结果
        负整数，零或正整数，如果这个 Version小于，等于或大于给定的 Version
        异常
        NullPointerException - 如果给定的对象是 null

      • compareToIgnoreOptional

        public int compareToIgnoreOptional​(Runtime.Version obj)
        将此版本与其他版本进行比较，忽略可选构建信息。

        通过检查compareTo(Version)中描述的版本字符串比较两个版本，但始终忽略可选的构建信息。

        该方法提供与equalsIgnoreOptional()一致的equalsIgnoreOptional() 。

        参数
        obj - 要比较的对象
        结果
        如果这个 Version小于，等于或大于给定的 Version负整数，零或正整数
        异常
        NullPointerException - 如果给定的对象是 null

      • toString

        public String toString​()
        返回此版本的字符串表示形式。
        重写：
        toString在 Object
        结果
        版本字符串

      • equals

        public boolean equals​(Object obj)
        确定此Version是否等于另一个对象。

        当且仅当它们表示相同的版本字符串时，两个Version s是相等的。

        重写：
        equals在 Object
        参数
        obj -对象对此 Version是待比较
        结果
        true如果，并且只有当给定的对象是一个 Version与 Version相同
        另请参见：
        Object.hashCode() ， HashMap

      • equalsIgnoreOptional

        public boolean equalsIgnoreOptional​(Object obj)
        确定此Version是否等于另一个忽略可选构建信息。

        当且仅当它们代表相同的版本字符串而忽略可选构建信息时，两个Version才是相同的。

        参数
        obj - 要比较此 Version的对象
        结果
        true如果，并且只有给定的对象是 Version与 Version相同，忽略可选的构建信息

      • hashCode

        public int hashCode​()
        返回此版本的哈希码。
        重写：
        hashCode在 Object
        结果
        这个版本的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RuntimeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class RuntimeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AnnotationTypeMismatchException ， ArithmeticException ， ArrayStoreException ， BufferOverflowException ， BufferUnderflowException ， CannotRedoException ， CannotUndoException ， CatalogException ， ClassCastException ， ClassNotPreparedException ， CMMException ， CompletionException ， ConcurrentModificationException ， DataBindingException ， DateTimeException ， DOMException ， DuplicateRequestException ， EmptyStackException ， EnumConstantNotPresentException ， EventException ， FileSystemAlreadyExistsException ， FileSystemNotFoundException ， FindException ， IllegalArgumentException ， IllegalCallerException ， IllegalMonitorStateException ， IllegalPathStateException ， IllegalStateException ， IllformedLocaleException ， ImagingOpException ， InaccessibleObjectException ， IncompleteAnnotationException ， InconsistentDebugInfoException ， IndexOutOfBoundsException ， InternalException ， InvalidCodeIndexException ， InvalidLineNumberException ， InvalidModuleDescriptorException ， InvalidModuleException ， InvalidRequestStateException ， InvalidStackFrameException ， JarSignerException ， JMRuntimeException ， JSException ， LayerInstantiationException ， LSException ， MalformedParameterizedTypeException ， MalformedParametersException ， MediaException ， MirroredTypesException ， MissingResourceException ， NashornException ， NativeMethodException ， NegativeArraySizeException ， NoSuchDynamicMethodException ， NoSuchElementException NoSuchElementException ， NoSuchMechanismException ， NullPointerException ， ObjectCollectedException ， ProfileDataException ， ProviderException ， ProviderNotFoundException ， RangeException ， RasterFormatException ， RejectedExecutionException ， ResolutionException ， SecurityException ， SPIResolutionException ， SystemException ， TypeConstraintException ， TypeNotPresentException ， UncheckedIOException ， UndeclaredThrowableException ， UnknownEntityException ， UnknownTreeException ， UnmodifiableModuleException ， UnmodifiableSetException ， UnsupportedOperationException ， VMDisconnectedException ， VMMismatchException ， VMOutOfMemoryException ， WebServiceException ， WrongMethodTypeException ， XPathException

    public class RuntimeException
extends 异常
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。

    RuntimeException及其子类是未经检查的异常 。 unchecked异常不需要在方法或构造函数的拟申报throws条款，如果他们可以通过该方法或构造函数的执行被抛出和方法或构造边界之外传播。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form
    See The Java™ Language Specification:
    11.2编译时检查异常

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        RuntimeException​()
      构造新的运行时异常，其中包含 null作为其详细消息。
        RuntimeException​(String message)
      使用指定的详细消息构造新的运行时异常。
        RuntimeException​(String message, Throwable cause)
      构造一个新的运行时异常与指定的详细信息和原因。
      protected RuntimeException​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个新的运行时异常，其中包含指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
        RuntimeException​(Throwable cause)
      构造具有指定原因的新运行时异常和详细信息 (cause==null ? null : cause.toString()) （通常包含类别和详细信息为 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • RuntimeException

        public RuntimeException​()
        构造一个新的运行时异常，其中包含null作为其详细消息。 原因未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。

      • RuntimeException

        public RuntimeException​(String message)
        使用指定的详细消息构造新的运行时异常。 原因未初始化，可以随后通过调用Throwable.initCause(java.lang.Throwable)进行初始化。
        参数
        message - 详细信息。 保存详细信息以供稍后通过Throwable.getMessage()方法检索。

      • RuntimeException

        public RuntimeException​(String message,
                        Throwable cause)
        构造一个新的运行时异常与指定的详细信息和原因。

        请注意，与cause相关联的详细消息不会自动并入此运行时异常的详细消息。

        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • RuntimeException

        public RuntimeException​(Throwable cause)
        构造具有指定cause和详细消息的新的运行时异常(cause==null ? null : cause.toString()) （它通常包含的类和详细消息cause ）。 这个构造函数对于运行时异常非常有用，对于其他throwable来说，它不仅仅是包装器。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • RuntimeException

        protected RuntimeException​(String message,
                           Throwable cause,
                           boolean enableSuppression,
                           boolean writableStackTrace)
        构造一个新的运行时异常，其中包含指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
        参数
        message - 详细信息。
        cause - 原因。 （允许A null值，并表示原因不存在或未知。）
        enableSuppression - 是否启用抑制功能
        writableStackTrace - 堆栈跟踪是否可写
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RuntimePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class RuntimePermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.lang.RuntimePermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class RuntimePermission
extends BasicPermission
    此类用于运行时权限。 A RuntimePermission包含一个名称（也称为“目标名称”），但没有操作列表; 你有指定的权限，或者你没有。

    目标名称是运行时权限的名称（见下文）。 命名约定遵循层次化属性命名约定。 此外，星号可能会出现在名称的末尾，遵循“。”或本身表示通配符匹配。 例如：“loadLibrary。*”和“*”表示通配符匹配，而“* loadLibrary”和“a * b”则不表示。

    下表列出了标准的RuntimePermission目标名称，每个都提供了许可允许的描述，并讨论授予代码授权的风险。

    permission target name, what the target allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission createClassLoader Creation of a class loader This is an extremely dangerous permission to grant. Malicious applications that can instantiate their own class loaders could then load their own rogue classes into the system. These newly loaded classes could be placed into any protection domain by the class loader, thereby automatically granting the classes the permissions for that domain. getClassLoader Retrieval of a class loader (e.g., the class loader for the calling class) This would grant an attacker permission to get the class loader for a particular class. This is dangerous because having access to a class's class loader allows the attacker to load other classes available to that class loader. The attacker would typically otherwise not have access to those classes. setContextClassLoader Setting of the context class loader used by a thread The context class loader is used by system code and extensions when they need to lookup resources that might not exist in the system class loader. Granting setContextClassLoader permission would allow code to change which context class loader is used for a particular thread, including system threads. enableContextClassLoaderOverride Subclass implementation of the thread context class loader methods The context class loader is used by system code and extensions when they need to lookup resources that might not exist in the system class loader. Granting enableContextClassLoaderOverride permission would allow a subclass of Thread to override the methods that are used to get or set the context class loader for a particular thread. closeClassLoader Closing of a ClassLoader Granting this permission allows code to close any URLClassLoader that it has a reference to. setSecurityManager Setting of the security manager (possibly replacing an existing one) The security manager is a class that allows applications to implement a security policy. Granting the setSecurityManager permission would allow code to change which security manager is used by installing a different, possibly less restrictive security manager, thereby bypassing checks that would have been enforced by the original security manager. createSecurityManager Creation of a new security manager This gives code access to protected, sensitive methods that may disclose information about other classes or the execution stack. getenv.{variable name} Reading of the value of the specified environment variable This would allow code to read the value, or determine the existence, of a particular environment variable. This is dangerous if the variable contains confidential data. exitVM.{exit status} Halting of the Java Virtual Machine with the specified exit status This allows an attacker to mount a denial-of-service attack by automatically forcing the virtual machine to halt. Note: The "exitVM.*" permission is automatically granted to all code loaded from the application class path, thus enabling applications to terminate themselves. Also, the "exitVM" permission is equivalent to "exitVM.*". shutdownHooks Registration and cancellation of virtual-machine shutdown hooks This allows an attacker to register a malicious shutdown hook that interferes with the clean shutdown of the virtual machine. setFactory Setting of the socket factory used by ServerSocket or Socket, or of the stream handler factory used by URL This allows code to set the actual implementation for the socket, server socket, stream handler, or RMI socket factory. An attacker may set a faulty implementation which mangles the data stream. setIO Setting of System.out, System.in, and System.err This allows changing the value of the standard system streams. An attacker may change System.in to monitor and steal user input, or may set System.err to a "null" OutputStream, which would hide any error messages sent to System.err. modifyThread Modification of threads, e.g., via calls to Thread interrupt, stop, suspend, resume, setDaemon, setPriority, setName and setUncaughtExceptionHandler methods This allows an attacker to modify the behaviour of any thread in the system. stopThread Stopping of threads via calls to the Thread stop method This allows code to stop any thread in the system provided that it is already granted permission to access that thread. This poses as a threat, because that code may corrupt the system by killing existing threads. modifyThreadGroup modification of thread groups, e.g., via calls to ThreadGroup destroy, getParent, resume, setDaemon, setMaxPriority, stop, and suspend methods This allows an attacker to create thread groups and set their run priority. getProtectionDomain Retrieval of the ProtectionDomain for a class This allows code to obtain policy information for a particular code source. While obtaining policy information does not compromise the security of the system, it does give attackers additional information, such as local file names for example, to better aim an attack. getFileSystemAttributes Retrieval of file system attributes This allows code to obtain file system information such as disk usage or disk space available to the caller. This is potentially dangerous because it discloses information about the system hardware configuration and some information about the caller's privilege to write files. readFileDescriptor Reading of file descriptors This would allow code to read the particular file associated with the file descriptor read. This is dangerous if the file contains confidential data. writeFileDescriptor Writing to file descriptors This allows code to write to a particular file associated with the descriptor. This is dangerous because it may allow malicious code to plant viruses or at the very least, fill up your entire disk. loadLibrary.{library name} Dynamic linking of the specified library It is dangerous to allow an applet permission to load native code libraries, because the Java security architecture is not designed to and does not prevent malicious behavior at the level of native code. accessClassInPackage.{package name} Access to the specified package via a class loader's loadClass method when that class loader calls the SecurityManager checkPackageAccess method This gives code access to classes in packages to which it normally does not have access. Malicious code may use these classes to help in its attempt to compromise security in the system. defineClassInPackage.{package name} Definition of classes in the specified package, via a class loader's defineClass method when that class loader calls the SecurityManager checkPackageDefinition method. This grants code permission to define a class in a particular package. This is dangerous because malicious code with this permission may define rogue classes in trusted packages like java.security or java.lang, for example. defineClass Define a class with Lookup.defineClass. This grants code with a suitably privileged Lookup object permission to define classes in the same package as the Lookup's lookup class. accessDeclaredMembers Access to the declared members of a class This grants code permission to query a class for its public, protected, default (package) access, and private fields and/or methods. Although the code would have access to the private and protected field and method names, it would not have access to the private/protected field data and would not be able to invoke any private methods. Nevertheless, malicious code may use this information to better aim an attack. Additionally, it may invoke any public methods and/or access public fields in the class. This could be dangerous if the code would normally not be able to invoke those methods and/or access the fields because it can't cast the object to the class/interface with those methods and fields. queuePrintJob Initiation of a print job request This could print sensitive information to a printer, or simply waste paper. getStackTrace Retrieval of the stack trace information of another thread. This allows retrieval of the stack trace information of another thread. This might allow malicious code to monitor the execution of threads and discover vulnerabilities in applications. getStackWalkerWithClassReference Get a stack walker that can retrieve stack frames with class reference. This allows retrieval of Class objects from stack walking. This might allow malicious code to access Class objects on the stack outside its own context. setDefaultUncaughtExceptionHandler Setting the default handler to be used when a thread terminates abruptly due to an uncaught exception This allows an attacker to register a malicious uncaught exception handler that could interfere with termination of a thread preferences Represents the permission required to get access to the java.util.prefs.Preferences implementations user or system root which in turn allows retrieval or update operations within the Preferences persistent backing store.) This permission allows the user to read from or write to the preferences backing store if the user running the code has sufficient OS privileges to read/write to that backing store. The actual backing store may reside within a traditional filesystem directory or within a registry depending on the platform OS manageProcess Native process termination and information about processes ProcessHandle. Allows code to identify and terminate processes that it did not create. localeServiceProvider This RuntimePermission is required to be granted to classes which subclass and implement java.util.spi.LocaleServiceProvider. The permission is checked during invocation of the abstract base class constructor. This permission ensures trust in classes which implement this security-sensitive provider mechanism. See java.util.spi.LocaleServiceProvider for more information. loggerFinder This RuntimePermission is required to be granted to classes which subclass or call methods on java.lang.System.LoggerFinder. The permission is checked during invocation of the abstract base class constructor, as well as on the invocation of its public methods. This permission ensures trust in classes which provide loggers to system classes. See java.lang.System.LoggerFinder for more information. accessSystemModules Access system modules in the runtime image. This grants the permission to access resources in the system modules in the runtime image.
    Implementation Note:
    实现可能会定义其他目标名称，但应使用命名约定（如反向域名符号）来避免名称冲突。
    从以下版本开始：
    1.2
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      RuntimePermission​(String name)
      创建一个新的具有指定名称的RuntimePermission。
      RuntimePermission​(String name, String actions)
      创建一个具有指定名称的新RuntimePermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • RuntimePermission

        public RuntimePermission​(String name)
        创建一个新的具有指定名称的RuntimePermission。 该名称是RuntimePermission的符号名称，例如“exit”，“setFactory”等。星号可能会出现在名称的末尾，跟随“。”或本身表示通配符匹配。
        参数
        name - RuntimePermission的名称。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • RuntimePermission

        public RuntimePermission​(String name,
                         String actions)
        创建一个具有指定名称的新RuntimePermission对象。 该名称是RuntimePermission的符号名称，并且actions String当前未使用，并且应为null。
        参数
        name - RuntimePermission的名称。
        actions - 应为null。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SafeVarargs (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang

Annotation Type SafeVarargs

  • @Documented
@Retention(RUNTIME)
@Target({CONSTRUCTOR,METHOD})
public @interface SafeVarargs
    程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。 将此注释应用于方法或构造函数可抑制关于不可重新引用的变量arity（vararg）类型的未经检查的警告，并禁止在调用站点创建参数化数组的未检查警告。

    除了其@Target元注释的使用限制外，还需要编译器对此注释类型实施其他使用限制; 如果使用@SafeVarargs注释注释方法或构造函数声明，则它是编译时错误，并且：

    • 声明是一种固定的方法或构造函数
    • 声明是一个可变参数数量方法既不是static也不final也不private 。

    当这种注释类型应用于方法或构造函数声明时，鼓励编译器发出警告：

    • 可变参数参数具有可重新定义的元素类型，其中包含基本类型， Object和String 。 （可注释元素类型不会发生此注释类型禁止的未选中的警告。）
    • 方法或构造函数声明的正文执行潜在的不安全操作，例如对生成未经检查的警告的变量arity参数数组的元素的赋值。 某些不安全的操作不会触发未检查的警告。 例如，
       @SafeVarargs // Not actually safe!
 static void m(List<String>... stringLists) {
   Object[] array = stringLists;
   List<Integer> tmpList = Arrays.asList(42);
   array[0] = tmpList; // Semantically invalid, but compiles without warnings
   String s = stringLists[0].get(0); // Oh no, ClassCastException at runtime!
 }
      在运行时导致ClassCastException 。

      该平台的未来版本可能要求对这种不安全操作的编译器错误。

    从以下版本开始：
    1.7
    See The Java™ Language Specification:
    4.7可重用类型，8.4.1正式参数，9.6.4.7 @SafeVarargs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


SecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class SecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.SecurityException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    AccessControlException ， RMISecurityException

    public class SecurityException
extends RuntimeException
    由安全管理员抛出，表示安全违规。
    从以下版本开始：
    1.0
    另请参见：
    SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SecurityException​()
      构造一个 SecurityException ，没有详细信息。
      SecurityException​(String s)
      构造具有指定详细消息的 SecurityException 。
      SecurityException​(String message, Throwable cause)
      创建一个 SecurityException与指定的详细信息和原因。
      SecurityException​(Throwable cause)
      创建 SecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SecurityException

        public SecurityException​()
        构造一个 SecurityException ，没有详细信息。

      • SecurityException

        public SecurityException​(String s)
        构造具有指定详细消息的 SecurityException 。
        参数
        s - 详细信息。

      • SecurityException

        public SecurityException​(String message,
                         Throwable cause)
        创建一个 SecurityException与指定的详细信息和原因。
        参数
        message - 详细信息（保存以供稍后通过 Throwable.getMessage()方法检索）。
        cause - 原因（保存以供Throwable.getCause()方法后续检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • SecurityException

        public SecurityException​(Throwable cause)
        创建 SecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null值是允许的，并且表明原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SecurityManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class SecurityManager

  • java.lang.Object
    • java.lang.SecurityManager
  • 已知直接子类：
    RMISecurityManager

    public class SecurityManager
extends Object
    安全管理器是允许应用程序实施安全策略的类。 它允许应用程序在执行可能不安全或敏感的操作之前确定操作是什么以及是否在允许执行操作的安全上下文中尝试。 应用程序可以允许或禁止操作。

    SecurityManager类包含许多以“ check开头的名称的方法。 在这些方法执行某些潜在的敏感操作之前，这些方法在Java库中被各种方法所调用。 这种check方法的调用通常如下所示：

         SecurityManager security = System.getSecurityManager();
     if (security != null) {
         security.checkXXX(argument,  . . . );
     }

    因此，安全经理有机会通过抛出异常来防止操作完成。 如果允许操作，安全管理员例程将返回，但如果不允许操作，则抛出一个SecurityException 。

    当前的安全管理由设置setSecurityManager类方法System 。 目前的安全管理员是通过getSecurityManager方法获得的。

    特殊方法checkPermission(java.security.Permission)确定是否应该授予或拒绝由指定的权限指示的访问请求。 默认实现调用

      AccessController.checkPermission(perm);

    如果允许请求的访问权限， checkPermission静静地返回。 如果被拒绝，则抛出一个SecurityException 。

    从Java 2 SDK v1.2开始，每个其他的默认实现check的方法SecurityManager是调用SecurityManager checkPermission方法来确定调用线程具有执行所请求的操作的权限。

    请注意，仅具有单个权限参数的checkPermission方法始终在当前正在执行的线程的上下文中执行安全检查。 有时，在特定上下文中应该进行的安全检查实际上需要在不同的上下文（例如，从工作线程中）完成。 为这种情况提供了包含上下文参数的getSecurityContext方法和checkPermission方法。 getSecurityContext方法返回当前调用上下文的“快照”。 （默认实现返回一个AccessControlContext对象。）示例调用如下：

      Object context = null;
   SecurityManager sm = System.getSecurityManager();
   if (sm != null) context = sm.getSecurityContext();

    除了权限之外，还需要一个上下文对象的checkPermission方法使得基于该上下文而不是当前执行线程的访问决策。 因此，不同上下文中的代码可以调用该方法，传递权限和先前保存的上下文对象。 使用前面示例中获得的SecurityManager sm示例呼叫如下所示：

      if (sm != null) sm.checkPermission(permission, context);

    权限属于这些类别：文件，套接字，网络，安全，运行时，属性，AWT，反射和可序列化。 管理这些不同的权限类别类是java.io.FilePermission ， java.net.SocketPermission ， java.net.NetPermission ， java.security.SecurityPermission ， java.lang.RuntimePermission ， java.util.PropertyPermission ， java.awt.AWTPermission ， java.lang.reflect.ReflectPermission ，并java.io.SerializablePermission 。

    除了前两个（FilePermission和SocketPermission）之外的所有内容都是java.security.BasicPermission子类，它本身是顶级类的权限的抽象子类，它是java.security.Permission 。 BasicPermission定义了包含层次化属性命名约定（例如“exitVM”，“setFactory”，“queuePrintJob”等）之后的名称的所有权限所需的功能。 名称后面可能会出现一个星号，后跟“。”，或本身表示通配符匹配。 例如：“a。*”或“*”有效，“* a”或“a * b”无效。

    FilePermission和SocketPermission是用于权限的顶级类的子类（ java.security.Permission ）。 类似于这些类，它们的名称语法比BasicPermission子类直接来自Permission而不是BasicPermission所使用的语法更复杂。 例如，对于java.io.FilePermission对象，权限名称是文件（或目录）的路径名。

    一些权限类有一个“操作”列表，用于告知对象允许的操作。 例如，对于java.io.FilePermission对象，操作列表（例如“读取，写入”）指定为指定文件（或指定目录中的文件）授予哪些操作。

    其他许可类用于“命名”权限 - 包含名称但不包含操作列表的权限类; 你有指定的权限，或者你没有。

    注意：还有一个java.security.AllPermission所有权限的java.security.AllPermission权限。 它存在以简化可能需要执行需要所有（或多个）权限的多个任务的系统管理员的工作。

    有关权限相关信息，请参阅Permissions in the Java Development Kit (JDK) 。 本文档包括例如列出各种SecurityManager check方法的表以及每种此类方法的默认实现所需的权限。 它还包含需要权限的所有版本1.2方法的表，并且对于每个这样的方法来说明它需要哪个权限。

    从以下版本开始：
    1.0
    另请参见：
    ClassLoader ， SecurityException ， getSecurityManager ， setSecurityManager ， AccessController ， AccessControlContext ， AccessControlException ， Permission ， BasicPermission ， FilePermission ， SocketPermission ， PropertyPermission ， RuntimePermission ， AWTPermission ， Policy ， SecurityPermission ， ProtectionDomain

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected boolean inCheck
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此字段在将来的Java SE版本中可能会被删除。

    • 构造方法摘要

      构造方法
      Constructor 描述
      SecurityManager​()
      构造新的 SecurityManager 。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      void checkAccept​(String host, int port)
      如果调用线程不允许从指定的主机和端口号接受套接字连接，则抛出一个 SecurityException 。
      void checkAccess​(Thread t)
      如果调用线程不允许修改线程参数，则抛出一个 SecurityException 。
      void checkAccess​(ThreadGroup g)
      如果调用线程不允许修改线程组参数，则抛出一个 SecurityException 。
      void checkAwtEventQueueAccess​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此方法最初用于检查调用线程是否可以访问AWT事件队列。 该方法已被废弃，代码应使用checkPermission(java.security.Permission)检查AWTPermission("accessEventQueue") 。 此方法在将来的Java SE版本中可能会被删除。
      void checkConnect​(String host, int port)
      如果调用线程不允许打开与指定主机和端口号的套接字连接，则抛出一个 SecurityException 。
      void checkConnect​(String host, int port, Object context)
      如果指定的安全上下文不允许打开到指定的主机和端口号的套接字连接，则抛出一个 SecurityException 。
      void checkCreateClassLoader​()
      如果调用线程不允许创建新的类加载器，则抛出一个 SecurityException 。
      void checkDelete​(String file)
      如果调用线程不允许删除指定的文件，则抛出一个 SecurityException 。
      void checkExec​(String cmd)
      如果调用线程不允许创建子进程，则抛出一个 SecurityException 。
      void checkExit​(int status)
      如果调用线程不允许Java虚拟机停止指定的状态代码，则抛出一个 SecurityException 。
      void checkLink​(String lib)
      如果调用线程不允许动态链接由字符串参数文件指定的库代码，则抛出一个 SecurityException 。
      void checkListen​(int port)
      如果调用线程不允许在指定的本地端口号上等待连接请求，则抛出一个 SecurityException 。
      void checkMemberAccess​(Class<?> clazz, int which)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法依赖于调用者的堆栈深度为4，容易出错，并且不能由运行时执行。 该方法的用户应直接调用checkPermission(java.security.Permission) 。 此方法在将来的Java SE版本中可能会被删除。
      void checkMulticast​(InetAddress maddr)
      如果调用线程不允许使用（加入/离开/发送/接收）IP组播，则抛出一个 SecurityException 。
      void checkMulticast​(InetAddress maddr, byte ttl)
      已过时。
      请改用#checkPermission（java.security.Permission）
      void checkPackageAccess​(String pkg)
      如果调用线程不允许访问指定的包，则抛出一个 SecurityException 。
      void checkPackageDefinition​(String pkg)
      如果调用线程不允许在指定的包中定义类，则抛出一个 SecurityException 。
      void checkPermission​(Permission perm)
      如果根据当前有效的安全策略不允许由给定的权限指定的请求访问，则抛出一个 SecurityException 。
      void checkPermission​(Permission perm, Object context)
      如果指定的安全上下文被拒绝访问指定权限指定的资源，则抛出一个 SecurityException 。
      void checkPrintJobAccess​()
      如果调用线程不允许启动打印作业请求，则抛出一个 SecurityException 。
      void checkPropertiesAccess​()
      如果调用线程不允许访问或修改系统属性，则抛出一个 SecurityException 。
      void checkPropertyAccess​(String key)
      如果调用线程不允许访问具有指定的 key名称的系统属性，则抛出一个 SecurityException 。
      void checkRead​(FileDescriptor fd)
      如果调用线程不允许从指定的文件描述符读取，则抛出一个 SecurityException 。
      void checkRead​(String file)
      如果调用线程不允许读取由字符串参数指定的文件，则抛出一个 SecurityException 。
      void checkRead​(String file, Object context)
      如果指定的安全上下文不允许读取由字符串参数指定的文件，则抛出一个 SecurityException 。
      void checkSecurityAccess​(String target)
      确定是否应授予或拒绝具有指定权限目标名称的权限。
      void checkSetFactory​()
      抛出 SecurityException如果调用线程不允许设置由使用的套接字工厂 ServerSocket或者 Socket ，或使用的流处理程序工厂 URL 。
      void checkSystemClipboardAccess​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法最初用于检查调用线程是否可以访问系统剪贴板。 该方法已经过时，代码应该使用checkPermission(java.security.Permission)来检查AWTPermission("accessClipboard") 。 此方法在将来的Java SE版本中可能会被删除。
      boolean checkTopLevelWindow​(Object window)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法最初用于检查调用线程是否被信任以启动顶级窗口。 该方法已被废弃，代码应该使用checkPermission(java.security.Permission)来检查AWTPermission("showWindowWithoutWarningBanner") 。 此方法在将来的Java SE版本中可能会被删除。
      void checkWrite​(FileDescriptor fd)
      如果调用线程不允许写入指定的 SecurityException则抛出一个 SecurityException 。
      void checkWrite​(String file)
      如果调用线程不允许写入由字符串参数指定的文件，则抛出一个 SecurityException 。
      protected int classDepth​(String name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      protected int classLoaderDepth​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      protected ClassLoader currentClassLoader​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      protected Class<?> currentLoadedClass​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      protected Class<?>[] getClassContext​()
      将当前执行堆栈作为一个类的数组返回。
      boolean getInCheck​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      Object getSecurityContext​()
      创建封装当前执行环境的对象。
      ThreadGroup getThreadGroup​()
      返回要在其被调用时实例化任何正在创建的新线程的线程组。
      protected boolean inClass​(String name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      protected boolean inClassLoader​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • inCheck

        @Deprecated(since="1.2",
            forRemoval=true)
protected boolean inCheck
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此字段在将来的Java SE版本中可能会被删除。
        如果正在进行安全检查，该字段为true ; false否则。

    • 构造方法详细信息

      • SecurityManager

        public SecurityManager​()
        构造新的SecurityManager 。

        如果已经安装了安全管理器，则该方法首先使用RuntimePermission("createSecurityManager")权限调用安全管理器的checkPermission方法，以确保调用线程有权创建新的安全管理器。 这可能会导致抛出一个SecurityException 。

        异常
        SecurityException - 如果安全管理器已经存在，并且其 checkPermission方法不允许创建新的安全管理器。
        另请参见：
        System.getSecurityManager() ， checkPermission ， RuntimePermission

    • 方法详细信息

      • getInCheck

        @Deprecated(since="1.2",
            forRemoval=true)
public boolean getInCheck​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission呼叫。 此方法在将来的Java SE版本中可能会被删除。
        测试是否有正在进行的安全检查。
        结果
        该值为inCheck字段。 如果安全检查正在进行中，则此字段应包含true ，否则为false 。
        另请参见：
        inCheck

      • getClassContext

        protected Class<?>[] getClassContext​()
        将当前执行堆栈作为一个类的数组返回。

        数组的长度是执行堆栈上的方法数。 索引0为0的元素是当前执行方法的类，索引1为1的元素是该方法的调用者的类，依此类推。

        结果
        执行堆栈。

      • currentClassLoader

        @Deprecated(since="1.2",
            forRemoval=true)
protected ClassLoader currentClassLoader​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
        从使用非系统类加载器定义的类返回最近执行的方法的类加载器。 非系统类加载器被定义为不等于系统类加载器（由ClassLoader.getSystemClassLoader()返回）或其祖先之一的类加载器。

        在以下三种情况下，此方法将返回null ：

        1. 执行堆栈上的所有方法都是使用系统类加载器或其祖先之一定义的类。
        2. 执行堆栈上的所有方法直到第一个“特权”调用者（见AccessController.doPrivileged(java.security.PrivilegedAction<T>) ）都是使用系统类加载器或其祖先之一定义的类。
        3. 调用checkPermission与java.security.AllPermission不会导致SecurityException。
        结果
        类加载器最近发生的堆栈中的方法来自使用非系统类加载器定义的类。
        另请参见：
        getSystemClassLoader ， checkPermission

      • currentLoadedClass

        @Deprecated(since="1.2",
            forRemoval=true)
protected Class<?> currentLoadedClass​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
        从使用非系统类加载器定义的类中返回最近执行的方法的类。 非系统类加载器被定义为不等于系统类加载器（由ClassLoader.getSystemClassLoader()返回）或其祖先之一的类加载器。

        在以下三种情况下，此方法将返回null ：

        1. 执行堆栈上的所有方法都是使用系统类加载器或其祖先之一定义的类。
        2. 执行堆栈上的所有方法直到第一个“特权”调用者（见AccessController.doPrivileged(java.security.PrivilegedAction<T>) ）都是使用系统类加载器或其祖先之一定义的类。
        3. 对checkPermission与java.security.AllPermission调用不会导致SecurityException。
        结果
        来自使用非系统类加载器定义的类的方法的堆栈上最近出现的类。
        另请参见：
        getSystemClassLoader ， checkPermission

      • classDepth

        @Deprecated(since="1.2",
            forRemoval=true)
protected int classDepth​(String name)
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
        返回指定类的堆栈深度。
        参数
        name - 要搜索的类的完全限定名称。
        结果
        第一次发生堆栈框架的深度来自具有指定名称的类的方法; -1如果没有找到这样的框架。

      • classLoaderDepth

        @Deprecated(since="1.2",
            forRemoval=true)
protected int classLoaderDepth​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
        从使用非系统类加载器定义的类中返回最近执行的方法的堆栈深度。 非系统类加载器被定义为不等于系统类加载器（由ClassLoader.getSystemClassLoader()返回）或其祖先之一的类加载器。

        在以下三种情况下，此方法将返回-1：

        1. 执行堆栈上的所有方法都是使用系统类加载器或其祖先之一定义的类。
        2. 第一个“特权”调用者（见AccessController.doPrivileged(java.security.PrivilegedAction<T>) ）的执行堆栈上的所有方法来自使用系统类加载器或其祖先之一定义的类。
        3. 对checkPermission与java.security.AllPermission调用不会导致SecurityException。
        结果
        最近发生的堆栈框架中的深度来自使用非系统类加载器定义的类的方法。
        另请参见：
        getSystemClassLoader ， checkPermission

      • inClass

        @Deprecated(since="1.2",
            forRemoval=true)
protected boolean inClass​(String name)
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
        测试来自具有指定名称的类的方法是否在执行堆栈上。
        参数
        name - 类的完全限定名称。
        结果
        true如果来自具有指定名称的类的方法在执行堆栈上; 否则为false 。

      • inClassLoader

        @Deprecated(since="1.2",
            forRemoval=true)
protected boolean inClassLoader​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
        基本上，测试来自使用类加载器定义的类的方法是否在执行堆栈上。
        结果
        true如果对 currentClassLoader的调用具有非空返回值。
        另请参见：
        currentClassLoader

      • getSecurityContext

        public Object getSecurityContext​()
        创建封装当前执行环境的对象。 该方法的结果例如由三参数checkConnect方法和双参数checkRead方法使用。 需要这些方法，因为可以调用可信方法来读取文件或代替其他方法打开套接字。 可信方法需要确定是否允许其他（可能不受信任的）方法自行执行该操作。

        此方法的默认实现是返回一个AccessControlContext对象。

        结果
        一个依赖于实现的对象，封装了有关当前执行环境的足够信息，以便稍后执行一些安全检查。
        另请参见：
        checkConnect ， checkRead ， AccessControlContext

      • checkPermission

        public void checkPermission​(Permission perm)
        如果根据当前有效的安全策略不允许指定的权限指定的请求访问，则抛出一个SecurityException 。

        此方法通过给定的权限调用AccessController.checkPermission 。

        参数
        perm - 请求的权限。
        异常
        SecurityException - 如果不允许基于当前安全策略访问。
        NullPointerException - 如果权限参数是 null 。
        从以下版本开始：
        1.2

      • checkPermission

        public void checkPermission​(Permission perm,
                            Object context)
        如果指定的安全上下文被拒绝访问由给定权限指定的资源，则抛出一个SecurityException 。 上下文必须是先前调用getSecurityContext返回的安全上下文，并且访问控制决定基于针对该安全上下文的配置的安全策略。

        如果context是实例AccessControlContext则AccessControlContext.checkPermission方法被调用与指定的权限。

        如果context不是一个实例AccessControlContext然后SecurityException被抛出。

        参数
        perm - 指定的权限
        context - 依赖于系统的安全上下文。
        异常
        SecurityException - 如果指定的安全上下文不是 AccessControlContext的实例（例如，是 null ），或者被拒绝访问由给定权限指定的资源。
        NullPointerException - 如果权限参数是 null 。
        从以下版本开始：
        1.2
        另请参见：
        getSecurityContext() ， AccessControlContext.checkPermission(java.security.Permission)

      • checkCreateClassLoader

        public void checkCreateClassLoader​()
        如果调用线程不允许创建新的类加载器，则抛出一个SecurityException 。

        此方法调用checkPermission的权限RuntimePermission("createClassLoader") 。

        如果你重写这个方法，那么你应该调用super.checkCreateClassLoader ，这样一来，被覆盖的方法通常会引发异常。

        异常
        SecurityException - 如果调用线程没有创建新类加载器的权限。
        另请参见：
        ClassLoader() ， checkPermission

      • checkAccess

        public void checkAccess​(Thread t)
        如果调用线程不允许修改线程参数，则抛出一个SecurityException 。

        此方法被调用为当前的安全管理stop ， suspend ， resume ， setPriority ， setName ，并setDaemon类的方法Thread 。

        如果线程参数是系统线程（属于具有null父进程的线程组），则该方法调用checkPermission与RuntimePermission("modifyThread")权限。 如果线程参数不是系统线程，则该方法只是静默地返回。

        想要更严格政策的应用程序应该覆盖此方法。 如果该方法被覆盖，则覆盖它的方法还应该检查调用线程是否具有RuntimePermission("modifyThread")权限，如果是，则默认返回。 这是为了确保授予该权限的代码（如JDK本身）被允许操纵任何线程。

        如果这个方法被覆盖，那么super.checkAccess应该被覆盖方法中的第一个语句调用，或者等效的安全检查应该放在被覆盖的方法中。

        参数
        t - 要检查的线程。
        异常
        SecurityException - 如果调用线程没有修改线程的权限。
        NullPointerException - 如果线程参数是 null 。
        另请参见：
        resume ， setDaemon ， setName ， setPriority ， stop ， suspend ， checkPermission

      • checkAccess

        public void checkAccess​(ThreadGroup g)
        如果调用线程不允许修改线程组参数，则抛出一个SecurityException 。

        这种方法被调用为当前的安全管理器创建一个新的子线程或子线程组时，以及由setDaemon ， setMaxPriority ， stop ， suspend ， resume ，并destroy类的方法ThreadGroup 。

        如果线程组参数是系统线程组（有一个null父级），则该方法调用checkPermission与RuntimePermission("modifyThreadGroup")权限。 如果线程组参数不是系统线程组，则此方法只是静默地返回。

        想要更严格政策的应用程序应该覆盖此方法。 如果该方法被覆盖，则覆盖它的方法还应该检查调用线程是否具有RuntimePermission("modifyThreadGroup")权限，如果是，则默认返回。 这是为了确保授予该权限的代码（如JDK本身）被允许操纵任何线程。

        如果这个方法被覆盖，那么super.checkAccess应该被覆盖方法中的第一个语句调用，或者等效的安全检查应该被放在被覆盖的方法中。

        参数
        g - 要检查的线程组。
        异常
        SecurityException - 如果调用线程没有修改线程组的权限。
        NullPointerException - 如果线程组参数是 null 。
        另请参见：
        destroy ， resume ， setDaemon ， setMaxPriority ， stop ， suspend ， checkPermission

      • checkExit

        public void checkExit​(int status)
        如果不允许调用线程使Java虚拟机停止指定的状态代码，则抛出一个SecurityException 。

        此方法被调用为当前的安全管理exit类的方法Runtime 。 状态0表示成功; 其他值表示各种错误。

        此方法调用checkPermission与RuntimePermission("exitVM."+status)权限。

        如果您重写此方法，那么您应该调用super.checkExit ，在重写方法通常会引发异常的时候。

        参数
        status - 退出状态。
        异常
        SecurityException - 如果调用线程没有权限停止具有指定状态的Java虚拟机。
        另请参见：
        exit ， checkPermission

      • checkExec

        public void checkExec​(String cmd)
        如果调用线程不允许创建子进程，则抛出一个SecurityException 。

        此方法被调用为当前的安全管理exec类的方法Runtime 。

        如果cmd是绝对路径，此方法调用checkPermission的FilePermission(cmd,"execute")权限，否则调用checkPermission与FilePermission("<<ALL FILES>>","execute") 。

        如果您重写此方法，那么您应该调用super.checkExec ，这样一来，覆盖方法通常会引发异常。

        参数
        cmd - 指定的系统命令。
        异常
        SecurityException - 如果调用线程没有创建子进程的权限。
        NullPointerException - 如果 cmd参数是 null 。
        另请参见：
        Runtime.exec(java.lang.String) ，
Runtime.exec(java.lang.String, java.lang.String[]) ，
Runtime.exec(java.lang.String[]) ，
Runtime.exec(java.lang.String[], java.lang.String[]) ，
checkPermission

      • checkLink

        public void checkLink​(String lib)
        如果调用线程不允许动态链接由字符串参数文件指定的库代码，则抛出一个SecurityException 。 参数是简单的库名称或完整的文件名。

        该方法通过load和loadLibrary的类别为Runtime方法为当前安全管理器调用。

        此方法调用checkPermission与RuntimePermission("loadLibrary."+lib)权限。

        如果您重写此方法，那么您应该拨打super.checkLink ，这样一来，覆盖方法通常会引发异常。

        参数
        lib - 图书馆的名称。
        异常
        SecurityException - 如果调用线程没有动态链接库的权限。
        NullPointerException - 如果 lib参数是 null 。
        另请参见：
        Runtime.load(java.lang.String) ， Runtime.loadLibrary(java.lang.String) ， checkPermission

      • checkRead

        public void checkRead​(FileDescriptor fd)
        如果调用线程不允许从指定的文件描述符读取，则抛出一个SecurityException 。

        此方法调用checkPermission与RuntimePermission("readFileDescriptor")权限。

        如果您重写此方法，那么您应该在覆盖方法通常会引发异常的时候调用super.checkRead 。

        参数
        fd - 依赖系统的文件描述符。
        异常
        SecurityException - 如果调用线程没有权限访问指定的文件描述符。
        NullPointerException - 如果文件描述符参数是 null 。
        另请参见：
        FileDescriptor ， checkPermission

      • checkRead

        public void checkRead​(String file)
        如果调用线程不允许读取由字符串参数指定的文件，则抛出一个SecurityException 。

        此方法调用checkPermission与FilePermission(file,"read")权限。

        如果您重写此方法，那么您应该拨打super.checkRead ，因为重写方法通常会引发异常。

        参数
        file - 与系统相关的文件名。
        异常
        SecurityException - 如果调用线程没有访问指定文件的权限。
        NullPointerException - 如果 file参数是 null 。
        另请参见：
        checkPermission

      • checkRead

        public void checkRead​(String file,
                      Object context)
        如果指定的安全上下文不允许读取由字符串参数指定的文件，则抛出一个SecurityException 。 上下文必须是由先前调用getSecurityContext返回的安全上下文。

        如果context是实例AccessControlContext那么AccessControlContext.checkPermission方法将与被调用FilePermission(file,"read")许可。

        如果context不是一个实例AccessControlContext然后SecurityException被抛出。

        如果您重写此方法，那么您应该调用super.checkRead ，这样重写方法通常会引发异常。

        参数
        file - 与系统相关的文件名。
        context - 依赖于系统的安全上下文。
        异常
        SecurityException - 如果指定的安全上下文不是 AccessControlContext的实例（例如，是 null ），或者没有读取指定文件的权限。
        NullPointerException - 如果 file参数是 null 。
        另请参见：
        getSecurityContext() ， AccessControlContext.checkPermission(java.security.Permission)

      • checkWrite

        public void checkWrite​(FileDescriptor fd)
        如果调用线程不允许写入指定的SecurityException则抛出一个SecurityException 。

        此方法调用checkPermission与RuntimePermission("writeFileDescriptor")权限。

        如果您重写此方法，那么您应该调用super.checkWrite ，这样一来，重写方法通常会引发异常。

        参数
        fd - 依赖系统的文件描述符。
        异常
        SecurityException - 如果调用线程没有访问指定文件描述符的权限。
        NullPointerException - 如果文件描述符参数是 null 。
        另请参见：
        FileDescriptor ， checkPermission

      • checkWrite

        public void checkWrite​(String file)
        如果调用线程不允许写入由字符串参数指定的文件，则抛出一个SecurityException 。

        此方法调用checkPermission与FilePermission(file,"write")权限。

        如果你重写这个方法，那么你应该调用super.checkWrite ，这样一来，被覆盖的方法通常会引发异常。

        参数
        file - 系统相关的文件名。
        异常
        SecurityException - 如果调用线程没有访问指定文件的权限。
        NullPointerException - 如果 file参数是 null 。
        另请参见：
        checkPermission

      • checkDelete

        public void checkDelete​(String file)
        如果调用线程不允许删除指定的文件，则抛出一个SecurityException 。

        此方法被调用为当前的安全管理delete类的方法File 。

        此方法调用checkPermission与FilePermission(file,"delete")权限。

        如果您重写此方法，那么您应该拨打super.checkDelete ，因为重写方法通常会引发异常。

        参数
        file - 与系统相关的文件名。
        异常
        SecurityException - 如果调用线程没有删除该文件的权限。
        NullPointerException - 如果 file参数是 null 。
        另请参见：
        File.delete() ， checkPermission

      • checkConnect

        public void checkConnect​(String host,
                         int port)
        如果调用线程不允许打开与指定主机和端口号的套接字连接，则抛出一个SecurityException 。

        端口号-1表示调用方法正在尝试确定指定主机名的IP地址。

        如果端口不等于-1，则此方法调用checkPermission的SocketPermission(host+":"+port,"connect")权限。 如果端口等于-1，则通过SocketPermission(host,"resolve")权限调用checkPermission 。

        如果你重写这个方法，那么你应该调用super.checkConnect ，这样一来，被覆盖的方法通常会抛出异常。

        参数
        host - 要连接到的主机名端口。
        port - 要连接的协议端口。
        异常
        SecurityException - 如果调用线程没有权限打开到指定的 host和 port的套接字连接。
        NullPointerException - 如果 host参数是 null 。
        另请参见：
        checkPermission

      • checkConnect

        public void checkConnect​(String host,
                         int port,
                         Object context)
        如果指定的安全上下文不允许打开到指定的主机和端口号的套接字连接，则抛出一个SecurityException 。

        端口号-1表示调用方法正在尝试确定指定主机名的IP地址。

        如果context不是一个实例AccessControlContext然后SecurityException被抛出。

        否则，将检查端口号。 如果不等于-1，则context的checkPermission方法通过SocketPermission(host+":"+port,"connect")权限进行调用。 如果端口等于-1，则context的checkPermission方法被调用，具有SocketPermission(host,"resolve")权限。

        如果您重写此方法，那么您应该在覆盖方法通常会引发异常的时候调用super.checkConnect 。

        参数
        host - 要连接的主机名端口。
        port - 要连接的协议端口。
        context - 依赖于系统的安全上下文。
        异常
        SecurityException - 如果指定的安全上下文不是 AccessControlContext的实例（例如，是 null ），或者没有权限打开到指定的 host和 port的套接字连接。
        NullPointerException - 如果 host参数是 null 。
        另请参见：
        getSecurityContext() ， AccessControlContext.checkPermission(java.security.Permission)

      • checkListen

        public void checkListen​(int port)
        如果调用线程不允许在指定的本地端口号上等待连接请求，则抛出一个SecurityException 。

        此方法调用checkPermission与SocketPermission("localhost:"+port,"listen") 。

        如果您重写此方法，那么您应该拨打super.checkListen ，在重写方法通常会引发异常的时候。

        参数
        port - 当地港口。
        异常
        SecurityException - 如果调用线程没有在指定端口上侦听的权限。
        另请参见：
        checkPermission

      • checkAccept

        public void checkAccept​(String host,
                        int port)
        如果调用线程不允许从指定的主机和端口号接受套接字连接，则抛出一个SecurityException 。

        此方法被调用为当前的安全管理accept类的方法ServerSocket 。

        此方法调用checkPermission与SocketPermission(host+":"+port,"accept")权限。

        如果您重写此方法，那么您应该拨打super.checkAccept ，这样一来，覆盖方法通常会引发异常。

        参数
        host - 套接字连接的主机名。
        port - 套接字连接的端口号。
        异常
        SecurityException - 如果调用线程没有权限接受连接。
        NullPointerException - 如果 host参数是 null 。
        另请参见：
        ServerSocket.accept() ， checkPermission

      • checkMulticast

        public void checkMulticast​(InetAddress maddr)
        如果调用线程不允许使用（加入/离开/发送/接收）IP组播，则抛出一个SecurityException 。

        这个方法调用checkPermission与java.net.SocketPermission(maddr.getHostAddress(), "accept,connect")权限。

        如果你重写这个方法，那么你应该调用super.checkMulticast ，这样一来，被覆盖的方法通常会抛出异常。

        参数
        maddr - 要使用的互联网组地址。
        异常
        SecurityException - 如果调用线程不允许使用（加入/离开/发送/接收）IP组播。
        NullPointerException - 如果地址参数是 null 。
        从以下版本开始：
        1.1
        另请参见：
        checkPermission

      • checkMulticast

        @Deprecated(since="1.4")
public void checkMulticast​(InetAddress maddr,
                           byte ttl)
        已过时。 请改用#checkPermission（java.security.Permission）
        如果调用线程不允许使用（加入/离开/发送/接收）IP组播，则抛出一个SecurityException 。

        此方法调用checkPermission与java.net.SocketPermission(maddr.getHostAddress(), "accept,connect")权限。

        如果您重写此方法，那么您应该拨打super.checkMulticast ，这样一来，覆盖的方法通常会引发异常。

        参数
        maddr - 要使用的互联网组地址。
        ttl - 正在使用的值，如果是多播发送。 注意：这个特定的实现不使用ttl参数。
        异常
        SecurityException - 如果调用线程不允许使用（加入/离开/发送/接收）IP多播。
        NullPointerException - 如果地址参数是 null 。
        从以下版本开始：
        1.1
        另请参见：
        checkPermission

      • checkPropertiesAccess

        public void checkPropertiesAccess​()
        如果调用线程不允许访问或修改系统属性，则抛出一个SecurityException 。

        这种方法是由getProperties和setProperties方法用于System 。

        此方法调用checkPermission与PropertyPermission("*", "read,write")权限。

        如果您重写此方法，那么您应该拨打super.checkPropertiesAccess ，这样一来，覆盖的方法通常会引发异常。

        异常
        SecurityException - 如果调用线程没有访问或修改系统属性的权限。
        另请参见：
        System.getProperties() ， System.setProperties(java.util.Properties) ， checkPermission

      • checkPropertyAccess

        public void checkPropertyAccess​(String key)
        如果调用线程不允许访问具有指定的key名称的系统属性，则抛出一个SecurityException 。

        此方法由使用的getProperty类的方法System 。

        该方法调用checkPermission与PropertyPermission(key, "read")权限。

        如果您覆盖此方法，那么您应该拨打super.checkPropertyAccess ，因为覆盖的方法通常会引发异常。

        参数
        key - 系统属性键。
        异常
        SecurityException - 如果调用线程没有访问指定的系统属性的权限。
        NullPointerException - 如果 key参数是 null 。
        IllegalArgumentException - 如果 key为空。
        另请参见：
        System.getProperty(java.lang.String) ， checkPermission

      • checkTopLevelWindow

        @Deprecated(since="1.8",
            forRemoval=true)
public boolean checkTopLevelWindow​(Object window)
        不推荐用于删除：此API元素将在以后的版本中被删除。 该方法最初用于检查调用线程是否被信任以启动顶级窗口。 该方法已被废弃，代码应该使用checkPermission(java.security.Permission)来检查AWTPermission("showWindowWithoutWarningBanner") 。 此方法在将来的Java SE版本中可能会被删除。
        返回 true如果调用线程具有 AllPermission 。
        参数
        window - 未使用，除了检查是否是 null 。
        结果
        true如果调用线程有 AllPermission 。
        异常
        NullPointerException - 如果 window参数是 null 。
        另请参见：
        checkPermission

      • checkPrintJobAccess

        public void checkPrintJobAccess​()
        如果调用线程不允许启动打印作业请求，则抛出一个SecurityException 。

        此方法调用checkPermission与RuntimePermission("queuePrintJob")权限。

        如果您重写此方法，那么您应该调用super.checkPrintJobAccess ，这样一来，覆盖的方法通常会引发异常。

        异常
        SecurityException - 如果调用线程没有启动打印作业请求的权限。
        从以下版本开始：
        1.1
        另请参见：
        checkPermission

      • checkSystemClipboardAccess

        @Deprecated(since="1.8",
            forRemoval=true)
public void checkSystemClipboardAccess​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 该方法最初用于检查调用线程是否可以访问系统剪贴板。 该方法已经过时，代码应该使用checkPermission(java.security.Permission)来检查AWTPermission("accessClipboard") 。 此方法在将来的Java SE版本中可能会被删除。
        如果调用线程没有 SecurityException则抛出 AllPermission 。
        异常
        SecurityException - 如果调用线程没有 AllPermission
        从以下版本开始：
        1.1
        另请参见：
        checkPermission

      • checkAwtEventQueueAccess

        @Deprecated(since="1.8",
            forRemoval=true)
public void checkAwtEventQueueAccess​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 此方法最初用于检查调用线程是否可以访问AWT事件队列。 该方法已经过时，代码应该使用checkPermission(java.security.Permission)来检查AWTPermission("accessEventQueue") 。 此方法在将来的Java SE版本中可能会被删除。
        如果调用线程没有 SecurityException则抛出 AllPermission 。
        异常
        SecurityException - 如果调用线程没有 AllPermission
        从以下版本开始：
        1.1
        另请参见：
        checkPermission

      • checkPackageAccess

        public void checkPackageAccess​(String pkg)
        如果调用线程不允许访问指定的包，则抛出一个SecurityException 。

        在加载类时，此方法可以由类加载器和Java虚拟机的loadClass方法调用，以确保允许调用者访问正在加载的类的包。

        此方法检查指定的包是否以package.access安全属性中的任何包开始或等于任何包。 实施方案还可以根据下面所述的限制包的附加列表检查包裹。 如果包裹受到限制， checkPermission(Permission)被授权用RuntimePermission("accessClassInPackage."+pkg) 。

        如果该方法被覆盖，那么super.checkPackageAccess应该被调用为覆盖方法的第一行。

        Implementation Note:
        此实现还限制了由the platform class loader或其祖先加载的所有未导出的模块包。 “未导出的包”是指未导出到所有模块的包。 具体来说，它指的是一个包不被其包含的模块导出，或者通过其包含模块以合格的方式导出的包。
        参数
        pkg - 包名称。
        异常
        SecurityException - 如果调用线程没有访问指定包的权限。
        NullPointerException - 如果包名参数是 null 。
        另请参见：
        loadClass ， getProperty ， checkPermission

      • checkPackageDefinition

        public void checkPackageDefinition​(String pkg)
        如果调用线程不允许在指定的包中定义类，则抛出一个SecurityException 。

        这种方法被某些类加载器的loadClass方法调用。

        此方法检查指定的包是否以package.definition安全属性中的任何包开始或等于任何包。 实施方案还可以根据下面所述的限制包的附加列表检查包裹。 如果包裹受到限制， checkPermission(Permission)被授权与一个RuntimePermission("defineClassInPackage."+pkg)权限。

        如果这个方法被覆盖，那么super.checkPackageDefinition应该被调用为覆盖方法的第一行。

        Implementation Note:
        此实现还限制了由the platform class loader或其祖先加载的所有未导出的模块包。 “未导出的包”是指未导出到所有模块的包。 具体来说，它指的是一个包不被其包含的模块导出，或者通过其包含模块以合格的方式导出的包。
        参数
        pkg - 包名称。
        异常
        SecurityException - 如果调用线程没有在指定的包中定义类的权限。
        NullPointerException - 如果包名参数是 null 。
        另请参见：
        ClassLoader.loadClass(String, boolean) ， getProperty ， checkPermission

      • checkSetFactory

        public void checkSetFactory​()
        抛出SecurityException如果调用线程不允许设置由使用的套接字工厂ServerSocket或者Socket ，或使用的流处理程序工厂URL 。

        此方法调用checkPermission与RuntimePermission("setFactory")权限。

        如果您重写此方法，那么您应该拨打super.checkSetFactory ，因为重写方法通常会引发异常。

        异常
        SecurityException - 如果调用线程没有指定套接字工厂或流处理程序工厂的权限。
        另请参见：
        setSocketFactory ， setSocketImplFactory ， setURLStreamHandlerFactory ， checkPermission

      • checkMemberAccess

        @Deprecated(since="1.8",
            forRemoval=true)
public void checkMemberAccess​(Class<?> clazz,
                              int which)
        不推荐用于删除：此API元素将在以后的版本中被删除。 该方法依赖于调用者的堆栈深度为4，容易出错，并且不能由运行时执行。 该方法的用户应直接调用checkPermission(java.security.Permission) 。 此方法在将来的Java SE版本中可能会被删除。
        如果调用线程不允许访问成员，则抛出一个SecurityException 。

        默认策略是允许访问PUBLIC成员，以及访问与调用者具有相同类加载器的类。 在所有其他情况下，此方法调用checkPermission与RuntimePermission("accessDeclaredMembers")权限。

        如果该方法被覆盖，则无法进行super.checkMemberAccess的调用，因为checkMemberAccess的默认实现依赖于堆栈深度为4的被检查代码。

        参数
        clazz - 要执行反射的类。
        which - 访问类型，PUBLIC或DECLARED。
        异常
        SecurityException - 如果来电者没有访问成员的权限。
        NullPointerException - 如果 clazz参数是 null 。
        从以下版本开始：
        1.1
        另请参见：
        Member ， checkPermission

      • checkSecurityAccess

        public void checkSecurityAccess​(String target)
        确定是否应授予或拒绝具有指定权限目标名称的权限。

        如果允许请求的权限，该方法静默地返回。 如果被拒绝，则会引发SecurityException。

        此方法为给定的权限目标名称创建一个SecurityPermission对象，并使用它调用checkPermission 。

        有关可能的许可目标名称的列表，请参阅SecurityPermission的文档。

        如果您重写此方法，那么您应该调用super.checkSecurityAccess ，这样一来，重写方法通常会引发异常。

        参数
        target - 目标名称为 SecurityPermission 。
        异常
        SecurityException - 如果调用线程没有对请求的访问权限。
        NullPointerException - 如果 target为空。
        IllegalArgumentException - 如果 target为空。
        从以下版本开始：
        1.1
        另请参见：
        checkPermission

      • getThreadGroup

        public ThreadGroup getThreadGroup​()
        返回要在其被调用时实例化任何正在创建的新线程的线程组。 默认情况下，它返回当前线程的线程组。 这应由特定的安全管理员覆盖，以返回相应的线程组。
        结果
        新线程被实例化的ThreadGroup
        从以下版本开始：
        1.1
        另请参见：
        ThreadGroup
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Short (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Short

  • java.lang.Object
    • java.lang.Number
      • java.lang.Short
  • All Implemented Interfaces:
    Serializable ， Comparable<Short>

    public final class Short
extends Number
implements Comparable<Short>
    Short类包装一个对象中的原始类型short的值。 类型为Short的对象包含单个字段，其类型为short 。

    此外，该类还提供了一些将short转换为String和String转换为short ，以及在处理short时有用的其他常量和方法。

    从以下版本开始：
    1.1
    另请参见：
    Number ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int BYTES
      用于表示二进制补码二进制形式的 short值的字节数。
      static short MAX_VALUE
      持有最大值a的常数a short可以具有2 15 -1。
      static short MIN_VALUE
      的常量保持的最小值的 short可以具有，-2 15。
      static int SIZE
      用于表示二进制补码二进制形式的 short值的位数。
      static Class<Short> TYPE
      代表原始类型 short的 Class实例。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Short​(short value)
      已过时。
      很少使用这个构造函数。 静态工厂valueOf(short)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Short​(String s)
      已过时。
      很少使用这个构造函数。 使用parseShort(String)将字符串转换为short原语，或使用valueOf(String)将字符串转换为Short对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      byte byteValue​()
      在缩小原始转换后，返回 Short的值作为 byte 。
      static int compare​(short x, short y)
      数值比较两个 short数值。
      int compareTo​(Short anotherShort)
      数值比较两个 Short对象。
      static int compareUnsigned​(short x, short y)
      比较两个 short值以数值方式将值视为无符号。
      static Short decode​(String nm)
      将 String解码成 Short 。
      double doubleValue​()
      在扩展原始转换后，返回 Short的值作为 double 。
      boolean equals​(Object obj)
      将此对象与指定的对象进行比较。
      float floatValue​()
      在扩展原始转换后，返回 Short的值作为 float 。
      int hashCode​()
      返回这个Short的哈希码; 等于调用intValue()的结果。
      static int hashCode​(short value)
      返回一个short值的哈希码; 兼容Short.hashCode() 。
      int intValue​()
      返回此的值 Short作为 int加宽原始转换之后。
      long longValue​()
      在扩展原始转换后，返回 Short的值作为 long 。
      static short parseShort​(String s)
      解析字符串参数为带符号的二进制 short 。
      static short parseShort​(String s, int radix)
      将字符串参数解析为由第二个参数指定的基数中的带符号的 short 。
      static short reverseBytes​(short i)
      返回通过反转指定的 short值的二进制补码表示中的字节顺序获得的值。
      short shortValue​()
      返回 Short的值作为 short 。
      String toString​()
      返回表示该 Short的值的 String对象。
      static String toString​(short s)
      返回一个新的 String对象，表示指定的 short 。
      static int toUnsignedInt​(short x)
      通过无符号转换将参数转换为 int 。
      static long toUnsignedLong​(short x)
      通过无符号转换将参数转换为 long 。
      static Short valueOf​(short s)
      返回表示指定的 short值的 Short实例。
      static Short valueOf​(String s)
      返回一个 Short对象，保存由指定的 String给出的值。
      static Short valueOf​(String s, int radix)
      返回一个 Short对象，该对象保存从指定的 String提取的值，当用第二个参数给出的基数进行解析时。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN_VALUE

        public static final short MIN_VALUE
        的常量保持的最小值的 short可以具有，-2 15。
        另请参见：
        Constant Field Values

      • MAX_VALUE

        public static final short MAX_VALUE
        持有最大值a的常数a short可以具有2 15 -1。
        另请参见：
        Constant Field Values

      • TYPE

        public static final Class<Short> TYPE
        所述 Class实例表示基本类型 short 。

      • SIZE

        public static final int SIZE
        用于表示二进制补码二进制形式的 short值的位数。
        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • BYTES

        public static final int BYTES
        用于表示二进制补码二进制形式的 short值的字节数。
        从以下版本开始：
        1.8
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Short

        @Deprecated(since="9")
public Short​(short value)
        已过时。 很少使用这个构造函数。 静态工厂valueOf(short)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
        构造新分配的 Short对象，该对象表示指定的 short值。
        参数
        value - 要由 Short表示的值。

      • Short

        @Deprecated(since="9")
public Short​(String s)
      throws NumberFormatException
        已过时。 很少使用这个构造函数。 使用parseShort(String)将字符串转换为short原语，或使用valueOf(String)将字符串转换为Short对象。
        构造新分配的Short对象，表示由String参数指示的short值。 字符串转换为short值，完全符合基数10的parseShort方法使用的方式。
        参数
        s -的 String转换为一个 Short
        异常
        NumberFormatException - 如果 String不包含可解析的 short 。

    • 方法详细信息

      • toString

        public static String toString​(short s)
        返回一个新的String对象，表示指定的short 。 基数假定为10。
        参数
        s - 要转换的 short
        结果
        指定的字符串表示形式为 short
        另请参见：
        Integer.toString(int)

      • parseShort

        public static short parseShort​(String s,
                               int radix)
                        throws NumberFormatException
        将字符串参数解析为第二个参数指定的基数中的带符号的short 。 字符串中的字符必须全部是指定基数的数字（由Character.digit(char, int)是否返回非负值确定），除了第一个字符可能是ASCII减号'-' （ '\u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）以表示正值。 返回产生的short值。

        如果发生以下任何一种情况，抛出类型为NumberFormatException的异常：

        • 第一个参数是null或是长度为零的字符串。
        • 基数小于Character.MIN_RADIX或大于Character.MAX_RADIX 。
        • 字符串的任何字符不是指定基数的数字，除了第一个字符可能是负号'-' （ '\u002D' ）或加号'+' （ '\u002B' ），前提是该字符串长于长度1。
        • 由字符串表示的值不是类型为short的值。
        参数
        s -所述 String含有 short表示被解析
        radix - 解析时使用的基数 s
        结果
        由指定基数中的字符串参数表示的 short 。
        异常
        NumberFormatException - 如果 String不包含可解析的 short 。

      • parseShort

        public static short parseShort​(String s)
                        throws NumberFormatException
        将字符串参数解析为带符号的二进制short 。 字符串中的字符必须都是十进制数字，除了第一个字符可能是ASCII减号'-' （ '\u002D' ）以指示负值或ASCII加号'+' （ '\u002B' ）以指示正值。 产生的short值将返回，就像参数和小数 10作为parseShort(java.lang.String, int)方法的参数一样 。
        参数
        s - a String其中包含要解析的 short表示
        结果
        short值由参数以十进制表示。
        异常
        NumberFormatException - 如果字符串不包含可解析的 short 。

      • valueOf

        public static Short valueOf​(String s,
                            int radix)
                     throws NumberFormatException
        返回一个Short对象，该对象保存从指定的String提取的值，并使用第二个参数给出的基数进行解析。 第一个参数被解释为在第二个参数指定的基数中表示一个带符号的符号short ，就好像该参数被赋予了parseShort(java.lang.String, int)方法一样。 结果是一个Short对象，表示由字符串指定的short值。

        换句话说，该方法返回一个Short对象的值等于：

        new Short(Short.parseShort(s, radix))
        参数
        s - 要解析的字符串
        radix - 用于解释的基数 s
        结果
        一个 Short对象，其持有由指定基数中的字符串参数表示的值。
        异常
        NumberFormatException - 如果 String不包含可解析的 short 。

      • valueOf

        public static Short valueOf​(String s)
                     throws NumberFormatException
        返回一个持有由指定的String给出的值的Short对象。 该参数被解释为表示一个有符号的二进制short ，就好像这个参数被赋予了parseShort(java.lang.String)方法一样。 结果是一个Short对象，表示由字符串指定的short值。

        换句话说，该方法返回一个Short对象的值等于：

        new Short(Short.parseShort(s))
        参数
        s - 要解析的字符串
        结果
        一个 Short对象，保存由string参数表示的值
        异常
        NumberFormatException - 如果 String不包含可解析的 short 。

      • valueOf

        public static Short valueOf​(short s)
        返回表示short值的Short实例。 如果不需要新的Short实例，则该方法通常优先于构造函数Short(short)使用 ，因为该方法可能通过缓存经常请求的值而产生明显更好的空间和时间性能。 此方法将始终缓存-128到127（含）范围内的值，并可能会超出此范围之外的其他值。
        参数
        s - 一个很短的价值。
        结果
        一个 Short实例，代表 s 。
        从以下版本开始：
        1.5

      • decode

        public static Short decode​(String nm)
                    throws NumberFormatException
        将String解码成Short 。 接受以下语法给出的十进制，十六进制和八进制数：
        DecodableString:
        Signopt DecimalNumeral
        Signopt 0x HexDigits
        Signopt 0X HexDigits
        Signopt # HexDigits
        Signopt 0 OctalDigits
        Sign:
        -
        +
        DecimalNumeral，HexDigits，和OctalDigits如在The Java™ Language Specification 3.10.1部分所定义，所不同的是下划线不数字之间接受。

        可选符号和/或基数说明符（“ 0x ”，“ 0X ”，“ # ”或前导零）之后的Short.parseShort由具有指定基数（10,16或8）的Short.parseShort方法解析。 这个字符序列必须表示一个正值，或者会抛出一个NumberFormatException 。 如果指定的String第一个字符为负号，则结果将被取消。 在String中不允许使用空格字符。

        参数
        nm - 要解码的 String 。
        结果
        一个 Short对象持有 short值代表 nm
        异常
        NumberFormatException - 如果 String不包含可解析的 short 。
        另请参见：
        parseShort(java.lang.String, int)

      • byteValue

        public byte byteValue​()
        返回此值 Short为 byte的基本收缩转换后。
        重写：
        byteValue在 Number
        结果
        该对象在转换为 byte之后表示的数值。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • shortValue

        public short shortValue​()
        返回 Short的值作为 short 。
        重写：
        shortValue在 Number
        结果
        该对象在转换为 short之后表示的数值。

      • intValue

        public int intValue​()
        在扩展原始转换后，返回 Short的值作为 int 。
        Specified by:
        intValue在 Number
        结果
        该对象在转换为 int之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • longValue

        public long longValue​()
        返回此值 Short为 long一个宽元转换后。
        Specified by:
        longValue在 Number
        结果
        该对象在转换为 long之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • floatValue

        public float floatValue​()
        在扩展原始转换后，返回 Short的值作为 float 。
        Specified by:
        floatValue在 Number
        结果
        该对象在转换为 float之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • doubleValue

        public double doubleValue​()
        返回此值 Short为 double一个宽元转换后。
        Specified by:
        doubleValue在 Number
        结果
        该对象在转换为 double之后表示的数值。
        See The Java™ Language Specification:
        5.1.2扩大原始转换

      • toString

        public String toString​()
        返回一个表示Short的值的String对象。 该值被转换为带符号的十进制表示形式，并作为字符串返回，正如short值被赋予toString(short)方法的参数一样 。
        重写：
        toString在 Object
        结果
        这个对象在基数10中的值的字符串表示。

      • hashCode

        public int hashCode​()
        返回此Short的哈希码; 等于调用intValue()的结果。
        重写：
        hashCode在 Object
        结果
        这个 Short的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • hashCode

        public static int hashCode​(short value)
        返回一个short值的哈希码; 兼容Short.hashCode() 。
        参数
        value - 哈希值
        结果
        一个哈希码值为 short值。
        从以下版本开始：
        1.8

      • equals

        public boolean equals​(Object obj)
        将此对象与指定的对象进行比较。 结果是true当且仅当参数不是null并且是一个Short对象，其中包含与此对象相同的值为short 。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象
        结果
        true如果对象是相同的; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • compareTo

        public int compareTo​(Short anotherShort)
        以数字比较两个 Short对象。
        Specified by:
        compareTo在接口 Comparable<Short>
        参数
        anotherShort - 要比较的 Short 。
        结果
        值0如果这个Short等于参数Short ; 小于0的值，如果这个Short数值小于参数Short ; 和大于一个值0 ，如果这Short在数值上大于该参数Short （带符号的比较）。
        从以下版本开始：
        1.2

      • compare

        public static int compare​(short x,
                          short y)
        数值比较两个short数值。 返回的值与以下内容相同：
          Short.valueOf(x).compareTo(Short.valueOf(y))
        参数
        x - 第一个 short进行比较
        y - 第二个 short进行比较
        结果
        价值0如果是x == y ; 一个值小于0如果是x < y ; 和值大于0如果x > y
        从以下版本开始：
        1.7

      • compareUnsigned

        public static int compareUnsigned​(short x,
                                  short y)
        比较两个 short值，以数值方式将值视为无符号。
        参数
        x - 第一个 short进行比较
        y - 第二个 short进行比较
        结果
        价值0如果是x == y ; 一个值小于0如果x < y为无符号值; 并且如果x > y为无符号值，则值大于0
        从以下版本开始：
        9

      • reverseBytes

        public static short reverseBytes​(short i)
        返回通过反转指定的 short值的二进制补码表示中的字节顺序获得的值。
        参数
        i - 要颠倒其字节的值
        结果
        通过在指定的 short值中反转（或等效地交换）字节获得的值。
        从以下版本开始：
        1.5

      • toUnsignedInt

        public static int toUnsignedInt​(short x)
        通过无符号转换将参数转换为int 。 在无符号转换为一个int ，所述的高阶16位int是零和低阶16个比特都等于的比特short参数。 因此，零和正数short值被映射到数字上相等的int值，负short值映射到等于输入加上2 16的int值。
        参数
        x - 转换为无符号 int的值
        结果
        该参数通过无符号转换转换为 int
        从以下版本开始：
        1.8

      • toUnsignedLong

        public static long toUnsignedLong​(short x)
        通过无符号转换将参数转换为long 。 在一个无符号转换为long ，所述的高阶48位long是零和低阶16个比特都等于的比特short参数。 因此，零和正值short值被映射到数字上相等的long值，而负short值被映射到等于输入加上2 16的long值。
        参数
        x - 转换为无符号 long的值
        结果
        该参数通过无符号转换转换为 long
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StackOverflowError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class StackOverflowError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.VirtualMachineError
          • java.lang.StackOverflowError
  • All Implemented Interfaces:
    Serializable

    public class StackOverflowError
extends VirtualMachineError
    当堆栈溢出发生时抛出一个应用程序递归太深。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StackOverflowError​()
      构造一个没有详细消息的 StackOverflowError 。
      StackOverflowError​(String s)
      构造具有指定详细消息的 StackOverflowError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • StackOverflowError

        public StackOverflowError​()
        构造一个 StackOverflowError ，没有详细信息。

      • StackOverflowError

        public StackOverflowError​(String s)
        构造具有指定详细消息的 StackOverflowError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StackTraceElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class StackTraceElement

  • java.lang.Object
    • java.lang.StackTraceElement
  • All Implemented Interfaces:
    Serializable

    public final class StackTraceElement
extends Object
implements Serializable
    堆栈跟踪中的一个元素，由Throwable.getStackTrace()返回。 每个元素表示单个堆栈帧。 堆栈顶部除堆栈之外的所有堆栈都表示方法调用。 堆栈顶部的帧表示生成堆栈跟踪的执行点。 通常，这是创建与堆栈跟踪相对应的throwable的点。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StackTraceElement​(String declaringClass, String methodName, String fileName, int lineNumber)
      创建表示指定执行点的堆栈跟踪元素。
      StackTraceElement​(String classLoaderName, String moduleName, String moduleVersion, String declaringClass, String methodName, String fileName, int lineNumber)
      创建表示指定执行点的堆栈跟踪元素。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      如果指定的对象是另一个表示与该实例相同的执行点的 StackTraceElement实例，则返回true。
      String getClassLoaderName​()
      返回包含由此堆栈跟踪元素表示的执行点的类的类加载器的名称。
      String getClassName​()
      返回包含由该堆栈跟踪元素表示的执行点的类的完全限定名称。
      String getFileName​()
      返回包含由该堆栈跟踪元素表示的执行点的源文件的名称。
      int getLineNumber​()
      返回包含由该堆栈跟踪元素表示的执行点的源行的行号。
      String getMethodName​()
      返回包含由该堆栈跟踪元素表示的执行点的方法的名称。
      String getModuleName​()
      返回包含由该堆栈跟踪元素表示的执行点的模块的模块名称。
      String getModuleVersion​()
      返回包含由该堆栈跟踪元素表示的执行点的模块的模块版本。
      int hashCode​()
      返回此堆栈跟踪元素的哈希码值。
      boolean isNativeMethod​()
      如果包含由此堆栈跟踪元素表示的执行点的方法是本机方法，则返回true。
      String toString​()
      返回此堆栈跟踪元素的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StackTraceElement

        public StackTraceElement​(String declaringClass,
                         String methodName,
                         String fileName,
                         int lineNumber)
        创建表示指定执行点的堆栈跟踪元素。 堆栈跟踪元素的module name和module version将为null 。
        参数
        declaringClass - 包含由堆栈跟踪元素表示的执行点的类的完全限定名称
        methodName - 包含由堆栈跟踪元素表示的执行点的方法的名称
        fileName - 包含由堆栈跟踪元素表示的执行点的文件的名称，如果此信息不可用， null
        lineNumber - 包含由此堆栈跟踪元素表示的执行点的源行的行号，如果此信息不可用，则为负数。 值-2表示包含执行点的方法是本地方法
        异常
        NullPointerException - 如果 declaringClass或 methodName为空
        从以下版本开始：
        1.5

      • StackTraceElement

        public StackTraceElement​(String classLoaderName,
                         String moduleName,
                         String moduleVersion,
                         String declaringClass,
                         String methodName,
                         String fileName,
                         int lineNumber)
        创建表示指定执行点的堆栈跟踪元素。
        参数
        classLoaderName - 类加载器名称，如果包含由堆栈跟踪表示的执行点的类的类加载器被命名; 否则null
        moduleName - 如果包含由堆栈跟踪表示的执行点的类在一个命名模块中的模块名称; 否则null
        moduleVersion - 模块版本如果包含由堆栈跟踪表示的执行点的类在具有版本的命名模块中; 否则null
        declaringClass - 包含由堆栈跟踪元素表示的执行点的类的完全限定名称
        methodName - 包含由堆栈跟踪元素表示的执行点的方法的名称
        fileName - 包含由堆栈跟踪元素表示的执行点的文件的名称，如果此信息不可用， null
        lineNumber - 包含由此堆栈跟踪元素表示的执行点的源行的行号，如果此信息不可用，则为负数。 值-2表示包含执行点的方法是本地方法
        异常
        NullPointerException - 如果 declaringClass是 null或 methodName是 null
        从以下版本开始：
        9

    • 方法详细信息

      • getFileName

        public String getFileName​()
        返回包含由该堆栈跟踪元素表示的执行点的源文件的名称。 通常，这对应于相关class文件的SourceFile属性（ 根据Java虚拟机规范 4.7.7节）。 在某些系统中，名称可能指的是文件之外的一些源代码单元，例如源存储库中的条目。
        结果
        包含此堆栈跟踪元素表示的执行点的文件的名称，如果此信息不可用， null 。

      • getLineNumber

        public int getLineNumber​()
        返回包含由该堆栈跟踪元素表示的执行点的源行的行号。 一般来说，这是源自相关class文件的LineNumberTable属性（ 根据Java虚拟机规范 ，第4.7.8节）。
        结果
        包含由此堆栈跟踪元素表示的执行点的源行的行号，如果此信息不可用，则为负数。

      • getModuleName

        public String getModuleName​()
        返回包含由该堆栈跟踪元素表示的执行点的模块的模块名称。
        结果
        包含由该堆栈跟踪元素表示的执行点的Module的模块名称; null如果模块名称不可用。
        从以下版本开始：
        9
        另请参见：
        Module.getName()

      • getModuleVersion

        public String getModuleVersion​()
        返回包含由该堆栈跟踪元素表示的执行点的模块的模块版本。
        结果
        Module的模块版本包含由该堆栈跟踪元素表示的执行点; null如果模块版本不可用。
        从以下版本开始：
        9
        另请参见：
        ModuleDescriptor.Version

      • getClassLoaderName

        public String getClassLoaderName​()
        返回包含由此堆栈跟踪元素表示的执行点的类的类加载器的名称。
        结果
        包含由该堆栈跟踪元素表示的执行点的类的类加载器的名称; 如果类加载器未命名， null 。
        从以下版本开始：
        9
        另请参见：
        ClassLoader.getName()

      • getClassName

        public String getClassName​()
        返回包含由该堆栈跟踪元素表示的执行点的类的完全限定名称。
        结果
        包含由此堆栈跟踪元素表示的执行点的 Class的完全限定名称。

      • getMethodName

        public String getMethodName​()
        返回包含由该堆栈跟踪元素表示的执行点的方法的名称。 如果执行点包含在实例或类初始化程序中，则该方法将返回相应的特殊方法名称 <init>或<clinit> ，如“Java虚拟机规范”第3.9节所述。
        结果
        包含由该堆栈跟踪元素表示的执行点的方法的名称。

      • isNativeMethod

        public boolean isNativeMethod​()
        如果包含由此堆栈跟踪元素表示的执行点的方法是本机方法，则返回true。
        结果
        如果包含由该堆栈跟踪元素表示的执行点的方法是本机方法， true 。

      • toString

        public String toString​()
        返回此堆栈跟踪元素的字符串表示形式。
        重写：
        toString在 Object
        API Note:
        此字符串的格式取决于实现，但以下示例可能被视为典型的：
        • “ com.foo.loader/foo@9.0/com.foo.Main.run(Main.java:101) ” - 见下面的描述。
        • “ com.foo.loader/foo@9.0/com.foo.Main.run(Main.java) ” - 行号不可用。
        • “ com.foo.loader/foo@9.0/com.foo.Main.run(Unknown Source) ” - 文件名和行号都不可用。
        • “ com.foo.loader/foo@9.0/com.foo.Main.run(Native Method) ” - 包含执行点的方法是本地方法。
        • “ com.foo.loader//com.foo.bar.App.run(App.java:12) ” - 执行点的类在名为com.foo.loader的类加载器的未命名模块中定义。
        • “ acme@2.1/org.acme.Lib.test(Lib.java:80) ” - 执行点的类定义在acme模块中，由一个内置的类加载器（如应用程序类加载器）加载。
        • “ MyClass.mash(MyClass.java:9) ” - MyClass类是在应用程序类路径上。

        第一个示例显示了由三个元素组成的堆栈跟踪元素，每个元素由"/"分隔，后跟源文件名和包含执行点的源代码行的行号。 第一个元素“ com.foo.loader ”是类加载器的名称。 第二个元素“ foo@9.0 ”是模块名称和版本。 第三个元素是包含执行点的方法; “ com.foo.Main" ”是完全限定的类名，“ run ”是方法的名称。 “ Main.java ”是源文件名，“ 101 ”是行号。

        如果在未命名的模块中定义了一个类，那么第二个元素被省略，如“ com.foo.loader//com.foo.bar.App.run(App.java:12) ”所示。

        如果类加载器是一个built-in class loader或者没有命名，那么第一个元素及其以下的"/"被省略，如“ acme@2.1/org.acme.Lib.test(Lib.java:80) ”所示。 如果省略第一个元素，并且模块是未命名的模块，则第二个元素及其以下的"/"也被省略，如“ MyClass.mash(MyClass.java:9) ”所示。

        该toString方法可以在两个返回两个不同的值StackTraceElement实例是equal ，例如一种通过构造创建，并且从获得的一个Throwable或StackWalker.StackFrame ，其中一个实现可以选择省略一些元件返回的字符串英寸

        结果
        对象的字符串表示形式。
        另请参见：
        Throwable.printStackTrace()

      • equals

        public boolean equals​(Object obj)
        如果指定的对象是另一个表示与该实例相同的执行点的StackTraceElement实例，则返回true。 当且仅当以下情况下，两个堆栈跟踪元素a和b是相等的
           equals(a.getClassLoaderName(), b.getClassLoaderName()) && equals(a.getModuleName(), b.getModuleName()) && equals(a.getModuleVersion(), b.getModuleVersion()) && equals(a.getClassName(), b.getClassName()) && equals(a.getMethodName(), b.getMethodName()) equals(a.getFileName(), b.getFileName()) && a.getLineNumber() == b.getLineNumber()
        其中equals的语义为Objects.equals 。
        重写：
        equals在 Object
        参数
        obj - 要与此堆栈跟踪元素进行比较的对象。
        结果
        如果指定的对象是另一个表示与该实例相同的执行点的 StackTraceElement实例，则为true。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此堆栈跟踪元素的哈希码值。
        重写：
        hashCode在类 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StackWalker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class StackWalker

  • java.lang.Object
    • java.lang.StackWalker

  • public final class StackWalker
extends Object
    堆栈步行者。

    walk方法为当前线程打开StackFrame s的顺序流，然后应用给定的函数来StackFrame流。 流从堆栈生成到最底层的执行点的最上面的帧起按顺序报告堆栈帧元素。 StackFrame流程在walk方法返回时关闭。 如果尝试重新使用封闭流，则将抛出IllegalStateException 。

    所述stack walking options一个的StackWalker确定的信息StackFrame级要返回的对象。 默认情况下，反射API和实现类的堆栈帧为hidden，而StackFrame具有可用的类名称和方法名称，但不包括Class reference 。

    StackWalker是线程安全的。 多个线程可以共享一个StackWalker对象来遍历其自己的堆栈。 根据其请求的选项创建StackWalker时，将执行许可检查。 在堆栈步行时间内不进行进一步的权限检查。

    API Note:
    例子

    1.找到第一个调用者过滤一个已知的实现类列表：

       StackWalker walker = StackWalker.getInstance(Option.RETAIN_CLASS_REFERENCE); Optional<Class<?>> callerClass = walker.walk(s -> s.map(StackFrame::getDeclaringClass) .filter(interestingClasses::contains) .findFirst());

    2.要快照当前线程的前十个堆栈帧，

       List<StackFrame> stack = StackWalker.getInstance().walk(s -> s.limit(10).collect(Collectors.toList()));
    除非另有说明，否则将null参数传递给此StackWalker类中的构造函数或方法将导致抛出NullPointerException 。
    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  StackWalker.Option
      堆栈步行器选项配置stack frame获取的信息由StackWalker 。
      static interface  StackWalker.StackFrame
      A StackFrame对象表示由StackWalker返回的方法调用。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void forEach​(Consumer<? super StackWalker.StackFrame> action)
      对当前线程的 StackFrame流的每个元素执行给定的动作，从堆栈的顶部框架遍历，这是调用此 forEach方法的方法。
      Class<?> getCallerClass​()
      获取调用者调用 getCallerClass的方法的调用者的 Class对象。
      static StackWalker getInstance​()
      返回一个 StackWalker实例。
      static StackWalker getInstance​(StackWalker.Option option)
      返回一个具有给定选项的 StackWalker实例，指定可以访问的堆栈帧信息。
      static StackWalker getInstance​(Set<StackWalker.Option> options)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。
      static StackWalker getInstance​(Set<StackWalker.Option> options, int estimateDepth)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。
      <T> T walk​(Function<? super Stream<StackWalker.StackFrame>,? extends T> function)
      将给定的函数应用于当前线程的 StackFrame的流，从堆栈的顶部框架遍历，这是调用此 walk方法的方法。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getInstance

        public static StackWalker getInstance​()
        返回一个StackWalker实例。

        这个StackWalker被配置为跳过所有hidden frames并且不保留class reference 。

        结果
        一个 StackWalker配置为跳过所有 hidden frames ，而不保留 class reference 。

      • getInstance

        public static StackWalker getInstance​(StackWalker.Option option)
        返回一个具有给定选项的StackWalker实例，指定可以访问的堆栈帧信息。

        如果存在安全管理员，并且给定的option是Option.RETAIN_CLASS_REFERENCE ，则它将其checkPermission方法RuntimePermission("getStackWalkerWithClassReference") 。

        参数
        option - stack walking option
        结果
        一个 StackWalker配置了给定的选项
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法拒绝访问。

      • getInstance

        public static StackWalker getInstance​(Set<StackWalker.Option> options)
        返回一个StackWalker实例，给定的options指定可以访问的堆栈帧信息。 如果给定的options为空，则此StackWalker配置为跳过所有hidden frames，并且不保留class reference 。

        如果存在安全管理员，并且给定的options包含Option.RETAIN_CLASS_REFERENCE ，则它将其checkPermission方法RuntimePermission("getStackWalkerWithClassReference") 。

        参数
        options - stack walking option
        结果
        一个 StackWalker配置了给定的选项
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法拒绝访问。

      • getInstance

        public static StackWalker getInstance​(Set<StackWalker.Option> options,
                                      int estimateDepth)
        返回一个StackWalker实例，给定的options指定可以访问的堆栈帧信息。 如果给定的options为空，则此StackWalker配置为跳过所有hidden frames，并且不保留class reference 。

        如果存在安全管理员，并且给定的options包含Option.RETAIN_CLASS_REFERENCE ，则它将其checkPermission方法RuntimePermission("getStackWalkerWithClassReference") 。

        estimateDepth指定StackWalker将通过StackWalker可用作缓冲区大小提示的堆栈帧的估计数。

        参数
        options - stack walking options
        estimateDepth - 估计要运行的堆栈帧数。
        结果
        一个 StackWalker配置了给定的选项
        异常
        IllegalArgumentException - 如果是 estimateDepth <= 0
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法拒绝访问。

      • walk

        public <T> T walk​(Function<? super Stream<StackWalker.StackFrame>,? extends T> function)
        将给定的函数应用于当前线程的StackFrame s的流，从堆栈的顶部框架遍历，这是调用此walk方法的方法。

        当此方法返回时， StackFrame流将关闭。 当关闭的Stream<StackFrame>对象被重用时，将抛出IllegalStateException 。

        API Note:
        例如，要查找前10个调用帧，首先跳过声明类在包com.foo那些帧：

 List<StackFrame> frames = StackWalker.getInstance().walk(s ->
     s.dropWhile(f -> f.getClassName().startsWith("com.foo."))
      .limit(10)
      .collect(Collectors.toList()));

        该方法需要Function接受Stream<StackFrame> ，而不是返回一个Stream<StackFrame>并允许调用者直接操纵流。 Java虚拟机可以自由地重组线程的控制堆栈，例如通过去优化。 通过获取一个Function参数，该方法允许通过线程的控制堆栈的稳定视图访问堆栈帧。

        有效地禁止并行执行，流管道执行只会在当前线程上发生。

        Implementation Note:
        该实现通过锚定特定于堆栈行走的框架来稳定堆栈，并确保在锚定框架上执行堆栈行走。 当流对象关闭或重新使用时，将抛出IllegalStateException 。
        参数类型
        T - 将函数应用于流的结果的类型stack frame 。
        参数
        function - 一个接收stack frames流并返回结果的函数。
        结果
        将功能应用于stack frame的流的结果 。

      • forEach

        public void forEach​(Consumer<? super StackWalker.StackFrame> action)
        对当前线程的StackFrame流的每个元素执行给定的动作，从堆栈的顶部框架遍历，这是调用这个forEach方法的方法。

        这个方法相当于调用

        walk(s -> { s.forEach(action); return null; });
        参数
        action - 当前线程的堆栈中每个 StackFrame执行的操作

      • getCallerClass

        public Class<?> getCallerClass​()
        获取调用者调用getCallerClass的方法的调用者的Class对象。

        该方法过滤reflection frames ， MethodHandle ，和hidden frames不管SHOW_REFLECT_FRAMES个SHOW_HIDDEN_FRAMES这个选项StackWalker已配置。

        当调用者帧存在时，应该调用此方法。 如果从堆栈的最底层调用，将抛出IllegalCallerException 。

        如果此StackWalker未配置RETAIN_CLASS_REFERENCE选项，则此方法将抛出UnsupportedOperationException 。

        API Note:
        例如， Util::getResourceBundle代表调用者加载资源束。 它调用getCallerClass来标识其方法叫做Util::getResourceBundle的类。 然后，它获取该类的类加载器，并使用类加载器加载资源束。 此示例中的调用者类为MyTool 。
           class Util { private final StackWalker walker = StackWalker.getInstance(Option.RETAIN_CLASS_REFERENCE); public ResourceBundle getResourceBundle(String bundleName) { Class<?> caller = walker.getCallerClass(); return ResourceBundle.getBundle(bundleName, Locale.getDefault(), caller.getClassLoader()); } } class MyTool { private final Util util = new Util(); private void init() { ResourceBundle rb = util.getResourceBundle("mybundle"); } }
        使用walk方法查找呼叫者类的方法如下（过滤反射帧， MethodHandle和隐藏帧，如下所示）：
           Optional<Class<?>> caller = walker.walk(s -> s.map(StackFrame::getDeclaringClass) .skip(2) .findFirst());
        当getCallerClass方法是从在堆叠的底部最帧的方法调用，例如， static public void main方法由推出java发射器，或从JNI附线程上调用的方法， IllegalCallerException被抛出。
        结果
        调用方调用此方法的对象为 Class 。
        异常
        UnsupportedOperationException - 如果这个 StackWalker没有配置 Option.RETAIN_CLASS_REFERENCE 。
        IllegalCallerException - 如果没有调用方框，即当从堆栈中最后一帧的方法调用此 getCallerClass方法时。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StackWalker.Option (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang

Enum StackWalker.Option

  • java.lang.Object
    • java.lang.Enum<StackWalker.Option>
      • java.lang.StackWalker.Option
  • All Implemented Interfaces:
    Serializable ， Comparable<StackWalker.Option>
    Enclosing class:
    StackWalker

    public static enum StackWalker.Option
extends Enum<StackWalker.Option>
    堆栈步行器选项配置stack frame获取的信息由StackWalker 。
    从以下版本开始：
    9

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      RETAIN_CLASS_REFERENCE
      保留 Class对象在 StackFrame s走过这个 StackWalker 。
      SHOW_HIDDEN_FRAMES
      显示所有隐藏的帧。
      SHOW_REFLECT_FRAMES
      显示所有反射帧。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StackWalker.Option valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StackWalker.Option[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • RETAIN_CLASS_REFERENCE

        public static final StackWalker.Option RETAIN_CLASS_REFERENCE
        保留Class对象在StackFrame s走过这个StackWalker 。

        一个StackWalker使用该选项配置将支持StackWalker.getCallerClass()和StackFrame.getDeclaringClass() 。

      • SHOW_REFLECT_FRAMES

        public static final StackWalker.Option SHOW_REFLECT_FRAMES
        显示所有反射帧。

        默认情况下，反射框被隐藏。 一个StackWalker这种配置SHOW_REFLECT_FRAMES选项将显示所有的反射框架，其中包括Method.invoke(java.lang.Object, java.lang.Object...)和Constructor.newInstance(Object...)及其反射实现类。

        SHOW_HIDDEN_FRAMES选项也可用于显示所有反射帧，并且还将显示其他特定于实现的隐藏帧。

        API Note:
        此选项包括代表调用方法和Constructor的堆栈帧。 任何相当于调用Method.invoke或Constructor.newInstance例如Class.newInstance实用程序方法都不会被任何堆栈行走选项过滤或控制。

      • SHOW_HIDDEN_FRAMES

        public static final StackWalker.Option SHOW_HIDDEN_FRAMES
        显示所有隐藏的帧。

        除了reflection frames之外，Java虚拟机实现可能会隐藏实现特定的帧。 A StackWalker与此SHOW_HIDDEN_FRAMES选项将显示所有隐藏的帧（包括反射帧）。

    • 方法详细信息

      • values

        public static StackWalker.Option[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StackWalker.Option c : StackWalker.Option.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StackWalker.Option valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


StackWalker.StackFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface StackWalker.StackFrame

  • Enclosing class:
    StackWalker

    public static interface StackWalker.StackFrame
    A StackFrame对象表示由StackWalker返回的方法调用。

    getDeclaringClass()方法可能不受stack walker的stack walking options确定 。

    从以下版本开始：
    9
    See The Java™ Virtual Machine Specification:
    2.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getByteCodeIndex​()
      返回包含由该堆栈帧表示的执行点的 Code属性的代码数组的索引。
      String getClassName​()
      获取由该堆栈帧表示的方法的声明类的 binary name 。
      Class<?> getDeclaringClass​()
      获取由此堆栈帧表示的方法声明 Class 。
      String getFileName​()
      返回包含由该堆栈帧表示的执行点的源文件的名称。
      int getLineNumber​()
      返回包含由该堆栈帧表示的执行点的源行的行号。
      String getMethodName​()
      获取由该堆栈帧表示的方法的名称。
      boolean isNativeMethod​()
      如果包含由此堆栈帧表示的执行点的方法是本地方法，则返回 true 。
      StackTraceElement toStackTraceElement​()
      获取此堆栈帧的 StackTraceElement 。

    • 方法详细信息

      • getClassName

        String getClassName​()
        获取由该堆栈帧表示的方法的声明类的 binary name 。
        结果
        由此堆栈框架表示的方法的声明类的二进制名称
        See The Java™ Language Specification:
        13.1二进制形式

      • getMethodName

        String getMethodName​()
        获取由该堆栈帧表示的方法的名称。
        结果
        由此堆栈框架表示的方法的名称

      • getDeclaringClass

        Class<?> getDeclaringClass​()
        获取由此堆栈帧表示的方法声明 Class 。
        结果
        声明由此堆栈框架表示的方法的 Class
        异常
        UnsupportedOperationException - 如果这个 StackWalker没有配置 Option.RETAIN_CLASS_REFERENCE 。

      • getByteCodeIndex

        int getByteCodeIndex​()
        返回包含由该堆栈帧表示的执行点的Code属性的代码数组的索引。 代码数组给出实现该方法的Java虚拟机代码的实际字节数。
        结果
        包含由此堆栈帧表示的执行点的 Code属性的代码数组的索引，如果该方法是本机，则为负数。
        See The Java™ Virtual Machine Specification:
        4.7.3 Code属性

      • getFileName

        String getFileName​()
        返回包含由该堆栈帧表示的执行点的源文件的名称。 一般地，这对应于SourceFile相关的属性class文件由The Java Virtual Machine Specification所定义的。 在某些系统中，该名称可以指代除文件之外的一些源代码单元，例如源存储库中的条目。
        结果
        包含此堆栈帧表示的执行点的文件的名称，如果此信息不可用， null 。
        See The Java™ Virtual Machine Specification:
        4.7.10 SourceFile属性

      • getLineNumber

        int getLineNumber​()
        返回包含由该堆栈帧表示的执行点的源行的行号。 通常，这是从衍生LineNumberTable相关的属性class文件由The Java Virtual Machine Specification所定义的。
        结果
        包含由该堆栈帧表示的执行点的源行的行号，如果该信息不可用，则为负数。
        See The Java™ Virtual Machine Specification:
        4.7.12 LineNumberTable属性

      • isNativeMethod

        boolean isNativeMethod​()
        如果包含由此堆栈帧表示的执行点的方法是本机方法，则返回 true 。
        结果
        如果包含由此堆栈帧表示的执行点的方法是本机方法， true 。

      • toStackTraceElement

        StackTraceElement toStackTraceElement​()
        获取此堆栈帧的 StackTraceElement 。
        结果
        StackTraceElement用于此堆栈帧。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StrictMath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class StrictMath

  • java.lang.Object
    • java.lang.StrictMath

  • public final class StrictMath
extends Object
    类StrictMath包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。

    为了确保Java程序的可移植性，该包中某些数字函数的定义要求它们产生与某些已发布算法相同的结果。 这些算法可从众所周知的网络库netlib作为包“Freely Distributable Math Library”， fdlibm 。 这些以C编程语言编写的算法然后被理解为遵循Java浮点运算规则的所有浮点运算来执行。

    Java数学库是针对fdlibm版本5.3定义的。 其中fdlibm为一个功能提供了多个定义（如acos ），请使用“IEEE 754核心功能”版本（驻留在名称以字母e开头的文件中）。 这需要方法fdlibm语义是sin ， cos ， tan ， asin ， acos ， atan ， exp ， log ， log10 ， cbrt ， atan2 ， pow ， sinh ， cosh ， tanh ， hypot ， expm1 ，并log1p 。

    该平台使用带有int和long基元类型的带符号二进制补码整数运算。 开发人员应该选择原始类型，以确保算术运算始终产生正确的结果，这在某些情况下意味着操作不会溢出计算值的范围。 最佳做法是选择原始类型和算法以避免溢出。 在情况下，大小为int或者long ，需要检测溢出错误，方法addExact ， subtractExact ， multiplyExact ，并toIntExact抛出ArithmeticException当结果溢出。 对于其他算术运算，如除法，绝对值，递增1，递减1，否定溢出仅在特定的最小值或最大值发生，并且应根据最小值或最大值进行检查。

    从以下版本开始：
    1.3

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static double E
      double值比任何其他的更接近 e ，自然对数的基础。
      static double PI
      比其他任何 pi更接近的值为 double ，圆周长与其直径的比率。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static double abs​(double a)
      返回值为 double绝对值。
      static float abs​(float a)
      返回值为 float绝对值。
      static int abs​(int a)
      返回值为 int绝对值。
      static long abs​(long a)
      返回值为 long绝对值。
      static double acos​(double a)
      返回值的反余弦值; 返回的角度在0.0到pi的范围内。
      static int addExact​(int x, int y)
      返回其参数的总和，如果结果溢出一个 int ，则抛出异常。
      static long addExact​(long x, long y)
      返回其参数的总和，如果结果溢出一个 long ，则抛出异常。
      static double asin​(double a)
      返回值的正弦值; 返回角度在pi / 2到pi / 2的范围内。
      static double atan​(double a)
      返回值的反正切值; 返回角度在pi / 2到pi / 2的范围内。
      static double atan2​(double y, double x)
      返回从直角坐标（转换角度 theta x ， y ）为极坐标 （R，θ-）。
      static double cbrt​(double a)
      返回 double值的多维数据集根。
      static double ceil​(double a)
      返回最小的（最接近负无穷大） double值，该值大于或等于该参数，并等于某个整数。
      static double copySign​(double magnitude, double sign)
      使用第二个浮点参数的符号返回第一个浮点参数。
      static float copySign​(float magnitude, float sign)
      使用第二个浮点参数的符号返回第一个浮点参数。
      static double cos​(double a)
      返回角度的三角余弦。
      static double cosh​(double x)
      返回 double值的双曲余弦值。
      static double exp​(double a)
      返回欧拉的数字 e提高到 double价值。
      static double expm1​(double x)
      返回 e x -1。
      static double floor​(double a)
      返回小于或等于参数的最大（最接近正无穷大）的 double值，并且等于数学整数。
      static int floorDiv​(int x, int y)
      返回小于或等于代数商的最大（最接近正无穷大） int值。
      static long floorDiv​(long x, int y)
      返回小于或等于代数商的最大（最接近正无穷大）的数值 long 。
      static long floorDiv​(long x, long y)
      返回小于或等于代数商的最大（最接近正无穷大） long值。
      static int floorMod​(int x, int y)
      返回 int参数的底模数。
      static int floorMod​(long x, int y)
      返回 long和 int参数的底模。
      static long floorMod​(long x, long y)
      返回 long参数的底模数。
      static double fma​(double a, double b, double c)
      返回三个参数的融合乘法加法; 也就是说，返回与第三个参数求和的前两个参数的确切乘积，然后舍入一次到最接近的double 。
      static float fma​(float a, float b, float c)
      返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的float 。
      static int getExponent​(double d)
      返回在 double的表示中使用的无偏指数。
      static int getExponent​(float f)
      返回 float的表示中使用的无偏指数。
      static double hypot​(double x, double y)
      返回sqrt（ x 2 + y 2 ），没有中间溢出或下溢。
      static double IEEEremainder​(double f1, double f2)
      根据IEEE 754标准计算两个参数的余数运算。
      static double log​(double a)
      返回 double值的自然对数（基数 e ）。
      static double log10​(double a)
      返回 double值的基数10对数。
      static double log1p​(double x)
      返回参数和1的和的自然对数。
      static double max​(double a, double b)
      返回两个 double值中的较大值。
      static float max​(float a, float b)
      返回两个 float值中的较大值。
      static int max​(int a, int b)
      返回两个 int中的较大值。
      static long max​(long a, long b)
      返回两个 long中的较大值。
      static double min​(double a, double b)
      返回两个 double中的较小值。
      static float min​(float a, float b)
      返回两个 float中的较小值。
      static int min​(int a, int b)
      返回两个 int中的较小值。
      static long min​(long a, long b)
      返回两个 long中的较小值。
      static int multiplyExact​(int x, int y)
      返回参数的乘积，如果结果溢出一个 int ，则抛出异常。
      static long multiplyExact​(long x, int y)
      返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
      static long multiplyExact​(long x, long y)
      返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
      static long multiplyFull​(int x, int y)
      返回参数的确切数学积。
      static long multiplyHigh​(long x, long y)
      作为 long返回的两个64位因子的128位乘积中最显着的64位。
      static double nextAfter​(double start, double direction)
      返回与第二个参数方向相邻的第一个参数的浮点数。
      static float nextAfter​(float start, double direction)
      返回与第二个参数方向相邻的第一个参数的浮点数。
      static double nextDown​(double d)
      返回与负无穷大方向相邻的 d的浮点值。
      static float nextDown​(float f)
      返回与负无穷大方向相邻的 f的浮点值。
      static double nextUp​(double d)
      返回与正无穷大方向相邻的 d的浮点值。
      static float nextUp​(float f)
      返回与正无穷大方向相邻的 f的浮点值。
      static double pow​(double a, double b)
      将第一个参数的值返回到第二个参数的幂。
      static double random​()
      返回值为 double的正值，大于等于 0.0 ，小于 1.0 。
      static double rint​(double a)
      返回值与参数最接近的值为 double ，并且等于数学整数。
      static long round​(double a)
      返回参数中最接近的 long ，其中 long四舍五入为正无穷大。
      static int round​(float a)
      返回参数最接近的 int ，其中 int四舍五入为正无穷大。
      static double scalb​(double d, int scaleFactor)
      返回 d 2 scaleFactor舍入，就好像由单个正确四舍五入的浮点数乘以双重值组的成员。
      static float scalb​(float f, int scaleFactor)
      返回 f 2 scaleFactor四舍五入，如同由一个正确四舍五入的浮点数乘以浮点值集合的成员一样。
      static double signum​(double d)
      返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0，如果参数小于零，则为-1.0。
      static float signum​(float f)
      返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0f，如果参数小于零，则为-1.0f。
      static double sin​(double a)
      返回角度的三角正弦。
      static double sinh​(double x)
      返回一个 double的双曲正弦值。
      static double sqrt​(double a)
      返回 double值的正确舍入的正平方根。
      static int subtractExact​(int x, int y)
      返回参数的差异，如果结果溢出一个 int ，则抛出异常。
      static long subtractExact​(long x, long y)
      返回参数的差异，如果结果溢出一个 long ，则抛出异常。
      static double tan​(double a)
      返回角度的三角正切。
      static double tanh​(double x)
      返回 double值的双曲正切值。
      static double toDegrees​(double angrad)
      将以弧度测量的角度转换为以度为单位的近似等效角度。
      static int toIntExact​(long value)
      返回long参数的值; 如果值溢出一个int则抛出异常。
      static double toRadians​(double angdeg)
      将以度为单位的角度转换为以弧度测量的大致相等的角度。
      static double ulp​(double d)
      返回参数的ulp的大小。
      static float ulp​(float f)
      返回参数的ulp的大小。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • E

        public static final double E
        double值比任何其他的更接近 e ，自然对数的基础。
        另请参见：
        Constant Field Values

      • PI

        public static final double PI
        double值比任何其他 pi更接近，圆周长与其直径的比率。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • sin

        public static double sin​(double a)
        返回角度的三角正弦。 特殊情况：
        • 如果参数为NaN或无穷大，则结果为NaN。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        a - 以弧度表示的角度。
        结果
        论证的正义。

      • cos

        public static double cos​(double a)
        返回角度的三角余弦。 特殊情况：
        • 如果参数为NaN或无穷大，则结果为NaN。
        参数
        a - 以弧度表示的角度。
        结果
        论证的余弦。

      • tan

        public static double tan​(double a)
        返回角度的三角正切。 特殊情况：
        • 如果参数为NaN或无穷大，则结果为NaN。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        a - 以弧度表示的角度。
        结果
        争论的切线。

      • asin

        public static double asin​(double a)
        返回值的正弦值; 返回角度在pi / 2到pi / 2的范围内。 特殊情况：
        • 如果参数为NaN或其绝对值大于1，则结果为NaN。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        a - 要返回正弦的值。
        结果
        争论的正弦。

      • acos

        public static double acos​(double a)
        返回值的反余弦值; 返回的角度在0.0到pi的范围内。 特例：
        • 如果参数为NaN或其绝对值大于1，则结果为NaN。
        参数
        a - 要返回的余弦值。
        结果
        论证的反余弦。

      • atan

        public static double atan​(double a)
        返回值的反正切值; 返回角度在pi / 2到pi / 2的范围内。 特殊情况：
        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        a - 要返回的反正切值。
        结果
        论点的反正切。

      • toRadians

        public static double toRadians​(double angdeg)
        将以度为单位的角度转换为以弧度测量的大致相等的角度。 从度数到弧度的转换通常是不准确的。
        参数
        angdeg - 以度为单位的角度
        结果
        角度的测量值为 angdeg ，单位为弧度。

      • toDegrees

        public static double toDegrees​(double angrad)
        将以弧度测量的角度转换为以度为单位的近似等效角度。 从弧度到度的转换通常是不准确的; 用户不应该指望cos(toRadians(90.0))到正好等于0.0 。
        参数
        angrad - 以弧度表示的角度
        结果
        测量角度为 angrad度。

      • exp

        public static double exp​(double a)
        返回欧拉的数字e提高到一个double价值。 特殊情况：
        • 如果参数是NaN，结果是NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为负无穷大，则结果为正零。
        参数
        a - 提高 e的指数。
        结果
        值 e a ，其中 e是自然对数的基数。

      • log

        public static double log​(double a)
        返回double值的自然对数（基数e ）。 特殊情况：
        • 如果参数为NaN或小于零，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为正零或负零，则结果为负无穷大。
        参数
        a - 一个值
        结果
        值ln a ，自然对数为 a 。

      • log10

        public static double log10​(double a)
        返回double值的基数10对数。 特殊情况：
        • 如果参数为NaN或小于零，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为正零或负零，则结果为负无穷大。
        • 如果参数等于10 n，用于整数n，则结果为n。
        参数
        a - 一个值
        结果
        基数10对数为 a 。
        从以下版本开始：
        1.5

      • sqrt

        public static double sqrt​(double a)
        返回double值的正确舍入的正平方根。 特殊情况：
        • 如果参数为NaN或小于零，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为正零或负零，则结果与参数相同。
        否则，结果是最接近参数值的真数学平方根的double值。
        参数
        a - 一个值。
        结果
        正平方根 a 。

      • cbrt

        public static double cbrt​(double a)
        返回double值的double根。 对于正有限x ， cbrt(-x) == -cbrt(x) ; 也就是说，负值的多边形根是该值的大小的立方根的负数。 特殊情况：
        • 如果参数是NaN，那么结果是NaN。
        • 如果参数是无限的，则结果是与参数具有相同符号的无穷大。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        a - 一个值。
        结果
        立方根 a 。
        从以下版本开始：
        1.5

      • IEEEremainder

        public static double IEEEremainder​(double f1,
                                   double f2)
        根据IEEE 754标准计算两个参数的余数运算。 余数的算术值等于f1 - f2 A-n，其中n是最接近商的精确算术值的数学整数f1/f2 ，并且如果两个整数都同样接近f1/f2 ，那么n是其中的偶数。 如果余数为零，其符号与第一个参数的符号相同。 特殊情况：
        • 如果任一参数为NaN，或第一个参数为无穷大，或第二个参数为正零或负零，则结果为NaN。
        • 如果第一个参数是有限的，第二个参数是无穷大的，那么结果与第一个参数相同。
        参数
        f1 - 股息。
        f2 - 除数。
        结果
        剩余时间为 f1除以 f2 。

      • ceil

        public static double ceil​(double a)
        返回最小的（最接近负无穷大） double值，该值大于或等于该参数，并等于某个整数。 特殊情况：
        • 如果参数值已经等于数学整数，则结果与参数相同。
        • 如果参数为NaN或无穷大或正零或负零，则结果与参数相同。
        • 如果参数值小于零但大于-1.0，则结果为负零。
        需要注意的是价值StrictMath.ceil(x)正是价值-StrictMath.floor(-x) 。
        参数
        a - 一个值。
        结果
        最大（最接近负无穷大）的浮点值大于或等于参数，并且等于一个数学整数。

      • floor

        public static double floor​(double a)
        返回小于或等于参数的最大（最接近正无穷大）的double值，并且等于数学整数。 特殊情况：
        • 如果参数值已经等于数学整数，则结果与参数相同。
        • 如果参数为NaN或无穷大或正零或负零，则结果与参数相同。
        参数
        a - 一个值。
        结果
        小于或等于参数的最大（最接近正无穷大）浮点值，等于数学整数。

      • rint

        public static double rint​(double a)
        返回值与参数最接近的值为double ，等于数学整数。 如果两个double数值是数学整数，则与参数的值相等，则结果为均匀的整数值。 特殊情况：
        • 如果参数值已经等于数学整数，则结果与参数相同。
        • 如果参数为NaN或无穷大或正零或负零，则结果与参数相同。
        参数
        a - 一个值。
        结果
        最接近的浮点值为 a ，等于一个数学整数。

      • atan2

        public static double atan2​(double y,
                           double x)
        返回从直角坐标（转换角度theta x ， y ）为极坐标（R，θ-）。 该方法通过计算在pi到pi的范围内计算y/x反正切值来计算相位θ 。 特殊情况：
        • 如果任一参数为NaN，则结果为NaN。
        • 如果第一个参数为正零，第二个参数为正，或第一个参数为正和有限，第二个参数为正无穷大，则结果为正零。
        • 如果第一个参数为负零，第二个参数为正，或第一个参数为负，有限，第二个参数为正无穷大，则结果为负零。
        • 如果第一个参数为正零，第二个参数为负，或第一个参数为正和有限，第二个参数为负无穷大，则结果为最接近pi的double值。
        • 如果第一个参数为负零，第二个参数为负，或者第一个参数为负，有限，第二个参数为负无穷大，则结果为最接近pi的double值。
        • 如果第一个参数为正，第二个参数为正零或负零，或第一个参数为正无穷大，第二个参数为有限，则结果为最接近pi / 2的double值。
        • 如果第一个参数是负的，第二个参数是正的零或负零，或者第一参数是负无穷大，并且第二个参数是有限的，那么结果是double最接近的值到- PI / 2。
        • 如果两个参数均为无穷大，则结果为最接近pi / 4的double值。
        • 如果第一个参数为正无穷大，第二个参数为负无穷大，则结果为最接近3 * pi / 4的double值。
        • 如果第一个参数为负无穷大，第二个参数为正无穷大，则结果为最接近 - pi / 4的double值。
        • 如果两个参数均为负无穷大，则结果为最接近-3 * pi / 4的double值。
        参数
        y - 纵坐标坐标
        x - 横坐标坐标
        结果
        极坐标中点（ r ， theta ）的 theta分量对应于笛卡尔坐标中的点（ x ， y ）。

      • pow

        public static double pow​(double a,
                         double b)
        将第一个参数的值返回到第二个参数的幂。 特殊情况：
        • 如果第二个参数为正或负零，则结果为1.0。
        • 如果第二个参数为1.0，则结果与第一个参数相同。
        • 如果第二个参数是NaN，那么结果是NaN。
        • 如果第一个参数是NaN，第二个参数是非零，那么结果是NaN。
        • 如果
          • 第一个参数的绝对值大于1，第二个参数为正无穷大，或
          • 第一个参数的绝对值小于1，第二个参数为负无穷大，
          那么结果是正无穷大。
        • 如果
          • 第一个参数的绝对值大于1，第二个参数为负无穷大，或
          • 第一个参数的绝对值小于1，第二个参数为正无穷大，
          那么结果是正零。
        • 如果第一个参数的绝对值等于1，第二个参数为无穷大，则结果为NaN。
        • 如果
          • 第一个参数是正零，第二个参数大于零，或者
          • 第一个参数是正无穷大，第二个参数小于零，
          那么结果是正零。
        • 如果
          • 第一个参数是正零，第二个参数小于零，或者
          • 第一个参数是正无穷大，第二个参数大于零，
          那么结果是正无穷大。
        • 如果
          • 第一个参数是负零，第二个参数大于零，但不是有限的奇整数，或者
          • 第一个参数是负无穷大，第二个参数小于零，但不是有限奇整数，
          那么结果是正零。
        • 如果
          • 第一个参数为负零，第二个参数为正有限奇数整数，或
          • 第一个参数为负无穷大，第二个参数为负有限奇数整数，
          那么结果是负零。
        • 如果
          • 第一个参数为负零，第二个参数小于零，但不是有限奇整数
          • 第一个参数为负无穷大，第二个参数大于零但不是有限奇整数，
          那么结果是正无穷大。
        • 如果
          • 第一个参数为负零，第二个参数为负有限奇数整数，或
          • 第一个参数是负无穷大，第二个参数是正有限奇数整数，
          那么结果是负无穷大。
        • 如果第一个参数是有限的并且小于零
          • 如果第二个参数是有限均匀整数，结果等于将第一个参数的绝对值提高到第二个参数的幂的结果
          • 如果第二个参数是有限的奇整数，则结果等于将第一个参数的绝对值提高到第二个参数的幂的结果的负数
          • 如果第二个参数是有限的，而不是一个整数，则结果是NaN。
        • 如果两个参数都是整数，则结果完全等于将第一个参数提升为第二个参数的幂的数学结果，如果该结果事实上可以精确地表示为double值。

        （在前述的说明中，一个浮点值被认为是一个整数，当且仅当它是有限的，并且该方法的一个固定点ceil或等价地，该方法的一个固定点floor 。的值是一个固定的点的唯一方法，当且仅当将该方法应用于该值的结果等于该值时）。

        参数
        a - 基地。
        b - 指数。
        结果
        值 a b 。

      • round

        public static int round​(float a)
        返回参数中最接近的int ，其中int四舍五入为正无穷大。

        特殊情况：

        • 如果参数是NaN，结果为0。
        • 如果参数为负无穷大或小于或等于Integer.MIN_VALUE的值，则结果等于值Integer.MIN_VALUE 。
        • 如果参数为正无穷大或大于或等于Integer.MAX_VALUE的值，则结果等于值Integer.MAX_VALUE 。
        参数
        a - 要舍入为整数的浮点值。
        结果
        参数的值四舍五入到最接近的 int值。
        另请参见：
        Integer.MAX_VALUE ， Integer.MIN_VALUE

      • round

        public static long round​(double a)
        返回参数最接近的long ，其中long四舍五入为正无穷大。

        特殊情况：

        • 如果参数是NaN，结果为0。
        • 如果参数为负无穷大或小于或等于值Long.MIN_VALUE的值，则结果等于值Long.MIN_VALUE 。
        • 如果参数为正无穷大或大于或等于Long.MAX_VALUE的值，则结果等于Long.MAX_VALUE的值。
        参数
        a - 要舍入为 long的浮点值。
        结果
        参数的值四舍五入到最接近的 long值。
        另请参见：
        Long.MAX_VALUE ， Long.MIN_VALUE

      • random

        public static double random​()
        返回值为double值为正号，大于等于0.0 ，小于1.0 。 返回的值是从该范围（大约）均匀分布的伪随机选择的。

        首先调用此方法时，它将创建一个新的伪随机数生成器，就像表达式一样

        new java.util.Random()
        此新的伪随机数生成器此后用于对该方法的所有调用，并在其他地方使用。

        该方法正确同步，以允许多个线程正确使用。 然而，如果许多线程需要以很高的速率产生伪随机数，则可以减少每个线程的争用以拥有自己的伪随机数发生器。

        结果
        伪随机 double大于或等于 0.0且小于 1.0 。
        另请参见：
        Random.nextDouble()

      • addExact

        public static int addExact​(int x,
                           int y)
        返回其参数的总和，如果结果溢出一个 int ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8
        另请参见：
        Math.addExact(int,int)

      • addExact

        public static long addExact​(long x,
                            long y)
        返回其参数的总和，如果结果溢出一个 long ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        1.8
        另请参见：
        Math.addExact(long,long)

      • subtractExact

        public static int subtractExact​(int x,
                                int y)
        返回参数的差异，如果结果溢出一个 int ，则抛出异常。
        参数
        x - 第一个值
        y - 从第一个值减去的第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8
        另请参见：
        Math.subtractExact(int,int)

      • subtractExact

        public static long subtractExact​(long x,
                                 long y)
        返回参数的差异，如果结果溢出一个 long ，则抛出异常。
        参数
        x - 第一个值
        y - 从第一个值中减去的第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        1.8
        另请参见：
        Math.subtractExact(long,long)

      • multiplyExact

        public static int multiplyExact​(int x,
                                int y)
        返回参数的乘积，如果结果溢出一个 int ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出一个int
        从以下版本开始：
        1.8
        另请参见：
        Math.multiplyExact(int,int)

      • multiplyExact

        public static long multiplyExact​(long x,
                                 int y)
        返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        9
        另请参见：
        Math.multiplyExact(long,int)

      • multiplyExact

        public static long multiplyExact​(long x,
                                 long y)
        返回参数的乘积，如果结果溢出一个 long ，则抛出异常。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        异常
        ArithmeticException - 如果结果溢出了很长时间
        从以下版本开始：
        1.8
        另请参见：
        Math.multiplyExact(long,long)

      • toIntExact

        public static int toIntExact​(long value)
        返回值为long参数; 如果值溢出int则抛出异常。
        参数
        value - 长值
        结果
        作为int的参数
        异常
        ArithmeticException - 如果 argument溢出一个int
        从以下版本开始：
        1.8
        另请参见：
        Math.toIntExact(long)

      • multiplyFull

        public static long multiplyFull​(int x,
                                int y)
        返回参数的确切数学积。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        从以下版本开始：
        9
        另请参见：
        Math.multiplyFull(int,int)

      • multiplyHigh

        public static long multiplyHigh​(long x,
                                long y)
        作为 long返回的两个64位因子的128位产品中最显着的64位。
        参数
        x - 第一个值
        y - 第二个值
        结果
        结果
        从以下版本开始：
        9
        另请参见：
        Math.multiplyHigh(long,long)

      • floorDiv

        public static int floorDiv​(int x,
                           int y)
        返回小于或等于代数商的最大（最接近正无穷大） int值。 有一个特殊情况，如果股息为Integer.MIN_VALUE ，除数为-1 ，则发生整数溢出，结果等于Integer.MIN_VALUE 。

        参见Math.floorDiv的例子和与整数除法/算子的比较。

        参数
        x - 股息
        y - 除数
        结果
        小于或等于代数商的最大（最接近正无穷大） int值。
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        Math.floorDiv(int, int) ， Math.floor(double)

      • floorDiv

        public static long floorDiv​(long x,
                            int y)
        返回小于或等于代数商的最大（最接近正无穷大） long值。 有一个特殊情况，如果股息为Long.MIN_VALUE ，除数为-1 ，则发生整数溢出，结果等于Long.MIN_VALUE 。

        参见Math.floorDiv的例子和与整数除法/算子的比较。

        参数
        x - 股息
        y - 除数
        结果
        小于或等于代数商的最大（最接近正无穷大） int值。
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        9
        另请参见：
        Math.floorDiv(long, int) ， Math.floor(double)

      • floorDiv

        public static long floorDiv​(long x,
                            long y)
        返回小于或等于代数商的最大（最接近正无穷大） long值。 有一个特殊情况，如果股息为Long.MIN_VALUE ，除数为-1 ，则发生整数溢出，结果等于Long.MIN_VALUE 。

        参见Math.floorDiv的例子，并与整数除法/运算符进行比较。

        参数
        x - 股息
        y - 除数
        结果
        小于或等于代数商的最大（最接近正无穷大） long值。
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        Math.floorDiv(long, long) ， Math.floor(double)

      • floorMod

        public static int floorMod​(int x,
                           int y)
        返回int参数的底模数。

        地板模数为x - (floorDiv(x, y) * y) ，与除数y具有相同的符号，并在-abs(y) < r < +abs(y)的范围内。

        floorDiv和floorMod之间的关系是这样的：

        • floorDiv(x, y) * y + floorMod(x, y) == x

        有关示例和%操作符的比较，请参阅Math.floorMod 。

        参数
        x - 股息
        y - 除数
        结果
        地板模数 x - (floorDiv(x, y) * y)
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        Math.floorMod(int, int) ， floorDiv(int, int)

      • floorMod

        public static int floorMod​(long x,
                           int y)
        返回long和int参数的底模。

        地板模量为x - (floorDiv(x, y) * y) ，具有相同的符号作为除数y ，并且在范围内-abs(y) < r < +abs(y) 。

        floorDiv和floorMod之间的关系是这样的：

        • floorDiv(x, y) * y + floorMod(x, y) == x

        有关示例和%操作符的比较，请参阅Math.floorMod 。

        参数
        x - 股息
        y - 除数
        结果
        地板模数 x - (floorDiv(x, y) * y)
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        9
        另请参见：
        Math.floorMod(long, int) ， floorDiv(long, int)

      • floorMod

        public static long floorMod​(long x,
                            long y)
        返回long参数的底模数。

        地板模量为x - (floorDiv(x, y) * y) ，具有相同的符号作为除数y ，并且在范围内-abs(y) < r < +abs(y) 。

        floorDiv和floorMod之间的关系是这样的：

        • floorDiv(x, y) * y + floorMod(x, y) == x

        有关示例和%操作符的比较，请参阅Math.floorMod 。

        参数
        x - 股息
        y - 除数
        结果
        地板模数 x - (floorDiv(x, y) * y)
        异常
        ArithmeticException - 如果除数 y为零
        从以下版本开始：
        1.8
        另请参见：
        Math.floorMod(long, long) ， floorDiv(long, long)

      • abs

        public static int abs​(int a)
        返回值为int绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。

        注意，如果参数等于Integer.MIN_VALUE的值，则最负值可表示为int ，结果是相同的值，即为负数。

        参数
        a - 绝对值要确定的参数。
        结果
        参数的绝对值。

      • abs

        public static long abs​(long a)
        返回值为long绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。

        注意，如果参数等于Long.MIN_VALUE的值，则最负数可表示为long ，结果是相同的值，即为负数。

        参数
        a - 绝对值要确定的参数。
        结果
        参数的绝对值。

      • abs

        public static float abs​(float a)
        返回值为float绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。 特殊情况：
        • 如果参数为正零或负零，结果为正零。
        • 如果论证是无限的，结果是正无穷大。
        • 如果参数是NaN，结果是NaN。
        API Note:
        如上所述，该方法的一个有效实现由下面的表达式给出，其计算具有与参数相同的指数和有效数的 float ，但是具有指示正值的保证零符号位：
        Float.intBitsToFloat(0x7fffffff & Float.floatToRawIntBits(a))
        参数
        a - 绝对值要确定的参数
        结果
        参数的绝对值。

      • abs

        public static double abs​(double a)
        返回double值的绝对值。 如果参数不为负，则返回参数。 如果参数为负，则返回参数的否定。 特殊情况：
        • 如果参数为正零或负零，结果为正零。
        • 如果论证是无限的，结果是正无穷大。
        • 如果参数是NaN，结果是NaN。
        API Note:
        如上所述，该方法的一个有效实现由以下表达式给出，其计算具有与参数相同的指数和有效 double ，但是具有指示正值的保证零符号位：
        Double.longBitsToDouble((Double.doubleToRawLongBits(a)<<1)>>>1)
        参数
        a - 绝对值要确定的参数
        结果
        参数的绝对值。

      • max

        public static int max​(int a,
                      int b)
        返回两个int值中的较大值。 也就是说，结果是更接近Integer.MAX_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论据。
        b - 另一个论点。
        结果
        较大的 a和 b 。

      • max

        public static long max​(long a,
                       long b)
        返回两个long中的较大值。 也就是说，结果是更接近Long.MAX_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论据。
        b - 另一个论点。
        结果
        较大的 a和 b 。

      • max

        public static float max​(float a,
                        float b)
        返回两个float值中的较大值。 也就是说，结果是更接近正无穷大的论据。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负，结果为正零。
        参数
        a - 一个论据。
        b - 另一个论点。
        结果
        较大的 a和 b 。

      • max

        public static double max​(double a,
                         double b)
        返回两个double中的较大值。 也就是说，结果是更接近正无穷大的论据。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负，结果为正零。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较大的 a和 b 。

      • min

        public static int min​(int a,
                      int b)
        返回两个int中的较小值。 也就是说，结果是更接近Integer.MIN_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论据。
        b - 另一个论点。
        结果
        较小的 a和 b 。

      • min

        public static long min​(long a,
                       long b)
        返回两个long值中的较小值。 也就是说，结果是更接近Long.MIN_VALUE的值。 如果参数的值相同，结果是相同的值。
        参数
        a - 一个论点。
        b - 另一个论点。
        结果
        较小的 a和 b 。

      • min

        public static float min​(float a,
                        float b)
        返回两个float中的较小值。 也就是说，结果是更接近负无穷大的值。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负零，结果为负零。
        参数
        a - 一个论据。
        b - 另一个论点。
        结果
        较小的 a和 b.

      • min

        public static double min​(double a,
                         double b)
        返回两个double中的较小值。 也就是说，结果是更接近负无穷大的值。 如果参数的值相同，结果是相同的值。 如果任一值为NaN，则结果为NaN。 与数值比较运算符不同，该方法认为负零严格小于正零。 如果一个参数为正零，另一个为负零，结果为负零。
        参数
        a - 一个参数。
        b - 另一个参数。
        结果
        较小的 a和 b 。

      • fma

        public static double fma​(double a,
                         double b,
                         double c)
        返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的double 。 舍入是使用round to nearest even rounding mode完成的。 相比之下，如果将a * b + c评估为常规浮点表达式，则涉及两个舍入误差，第一个用于乘法运算，第二个用于加法运算。

        特殊情况：

        • 如果任何参数是NaN，结果是NaN。
        • 如果前两个参数之一是无穷大，另一个为零，则结果为NaN。
        • 如果前两个参数的确切乘积是无穷大的（换句话说，至少有一个参数是无穷大的，另一个不是零，也不是NaN），而第三个参数是相反符号的无穷大，结果是NaN。

        请注意， fusedMac(a, 1.0, c)返回与（ a + c ）相同的结果。 然而， fusedMac(a, b, +0.0) 并不总是返回相同的结果（ a * b ），因为fusedMac(-0.0, +0.0, +0.0)为+0.0 ，而（ -0.0 * +0.0 ）为-0.0 ; fusedMac(a, b, -0.0)相当于（ a * b ）。

        API Note:
        该方法对应于IEEE 754-2008中定义的fusedMultiplyAdd操作。
        参数
        a - 一个值
        b - 一个值
        c - 一个值
        结果
        （ a × b + c ）计算，好像无限范围和精度，并舍入一次到最接近的 double值
        从以下版本开始：
        9

      • fma

        public static float fma​(float a,
                        float b,
                        float c)
        返回三个参数的融合乘法加法; 也就是说，返回与第三个参数相加的前两个参数的确切乘积，然后舍入一次到最接近的float 。 舍入是使用round to nearest even rounding mode完成的。 相比之下，如果将a * b + c评估为常规浮点表达式，则涉及两个舍入误差，第一个用于乘法运算，第二个用于加法运算。

        特殊情况：

        • 如果任何参数是NaN，结果是NaN。
        • 如果前两个参数之一是无穷大，另一个为零，则结果为NaN。
        • 如果前两个参数的确切乘积是无穷大的（换句话说，至少有一个参数是无穷大的，另一个不是零，也不是NaN），而第三个参数是相反符号的无穷大，结果是NaN。

        请注意， fma(a, 1.0f, c)返回与（ a + c ）相同的结果。 然而， fma(a, b, +0.0f) 并不总是返回相同的结果（ a * b ），因为fma(-0.0f, +0.0f, +0.0f)为+0.0f ，而（ -0.0f * +0.0f ）为-0.0f ; fma(a, b, -0.0f)相当于（ a * b ）。

        API Note:
        该方法对应于IEEE 754-2008中定义的fusedMultiplyAdd操作。
        参数
        a - 一个值
        b - 一个值
        c - 一个值
        结果
        （A A- B + C）来计算，因为如果具有无限范围和精度，并且一旦四舍五入到最近的 float值
        从以下版本开始：
        9

      • ulp

        public static double ulp​(double d)
        返回参数的ulp的大小。 最后一个位置的ulp单位是double值，这个浮点值与double值之间的正距离越大。 请注意，对于非NaN x ， ulp(-x) == ulp(x) 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正或负无穷大，则结果为正无穷大。
        • 如果参数为正或负为零，则结果为Double.MIN_VALUE 。
        • 如果参数为± Double.MAX_VALUE ，则结果等于2 971 。
        参数
        d - 要返回ulp的浮点值
        结果
        参数的ulp的大小
        从以下版本开始：
        1.5

      • ulp

        public static float ulp​(float f)
        返回参数的ulp的大小。 最后一个位置的ulp单位是float值，这个浮点值与float值之间的正距离越大。 请注意，对于非NaN x ， ulp(-x) == ulp(x) 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正或负无穷大，则结果为正无穷大。
        • 如果参数为正或负零，则结果为Float.MIN_VALUE 。
        • 如果参数为± Float.MAX_VALUE ，则结果等于2 104 。
        参数
        f - 要返回ulp的浮点值
        结果
        参数的ulp的大小
        从以下版本开始：
        1.5

      • signum

        public static double signum​(double d)
        返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0，如果参数小于零，则为-1.0。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正零或负零，则结果与参数相同。
        参数
        d - 要返回其符号的浮点值
        结果
        参数的signum函数
        从以下版本开始：
        1.5

      • signum

        public static float signum​(float f)
        返回参数的signum函数; 如果参数为零，则为零，如果参数大于零则为1.0f，如果参数小于零，则为-1.0f。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为正零或负零，则结果与参数相同。
        参数
        f - 要返回其符号的浮点值
        结果
        参数的signum函数
        从以下版本开始：
        1.5

      • sinh

        public static double sinh​(double x)
        返回一个double的双曲正弦值。 x的双曲正弦被定义为（ e x -e -x ）/ 2，其中e是Euler's number 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数是无限的，则结果是与参数具有相同符号的无穷大。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        x - 要返回双曲正弦的数字。
        结果
        双曲正弦为 x 。
        从以下版本开始：
        1.5

      • cosh

        public static double cosh​(double x)
        返回double值的双曲余弦值。 x的双曲余弦被定义为（ e x + e -x ）/ 2，其中e是Euler's number 。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数是无穷大的，则结果是正无穷大。
        • 如果参数为零，则结果为1.0 。
        参数
        x - 要返回双曲余弦的数字。
        结果
        双曲余弦 x 。
        从以下版本开始：
        1.5

      • tanh

        public static double tanh​(double x)
        返回double值的双曲正切值。 x的双曲正切定义为（E X -电子-x）/（E X + E -x），换句话说， 二七○五四五九九六八九○四九四 / 二百七万五千四百五十九亿九千六百八十九万八千三百八十九 。 请注意，确切的tanh的绝对值始终小于1。

        特殊情况：

        • 如果参数是NaN，那么结果是NaN。
        • 如果参数为零，则结果为与参数相同符号的零。
        • 如果参数为无穷大，则结果为+1.0 。
        • 如果参数为负无穷大，则结果为-1.0 。
        参数
        x - 要返回其双曲正切的数字。
        结果
        双曲正切 x 。
        从以下版本开始：
        1.5

      • hypot

        public static double hypot​(double x,
                           double y)
        返回sqrt（ x 2 + y 2 ），没有中间溢出或下溢。

        特殊情况：

        • 如果任一参数为无穷大，则结果为无穷大。
        • 如果任一参数为NaN，且两个参数都不是无穷大，则结果为NaN。
        参数
        x - 一个值
        y - 一个值
        结果
        sqrt（ x 2 + y 2 ），没有中间溢出或下溢
        从以下版本开始：
        1.5

      • expm1

        public static double expm1​(double x)
        返回e x -1。 请注意，对于接近0 的x值的确切数额expm1(x) + 1更接近E X比的真实结果exp(x) 。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为负无穷大，则结果为-1.0。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        x - e e计算中的指数 e x -1。
        结果
        值 e x - 1。
        从以下版本开始：
        1.5

      • log1p

        public static double log1p​(double x)
        返回参数之和1注的自然对数，对于小值x ，结果log1p(x)更接近LN（1 +的真实结果x ），比的浮点评价log(1.0+x) 。

        特殊情况：

        • 如果参数为NaN或小于-1，则结果为NaN。
        • 如果参数为无穷大，则结果为正无穷大。
        • 如果参数为负，则结果为负无穷大。
        • 如果参数为零，则结果为与参数相同符号的零。
        参数
        x - 一个值
        结果
        值ln（ x + 1），自然日志为 x + 1
        从以下版本开始：
        1.5

      • copySign

        public static double copySign​(double magnitude,
                              double sign)
        使用第二个浮点参数的符号返回第一个浮点参数。 对于这种方法，NaN sign参数总是被视为正面。
        参数
        magnitude - 提供结果大小的参数
        sign - 提供结果符号的参数
        结果
        价值为 magnitude ，标志为 sign 。
        从以下版本开始：
        1.6

      • copySign

        public static float copySign​(float magnitude,
                             float sign)
        使用第二个浮点参数的符号返回第一个浮点参数。 对于这种方法，NaN sign参数总是被视为正面。
        参数
        magnitude - 提供结果大小的参数
        sign - 提供结果符号的参数
        结果
        大小为 magnitude ，符号为 sign 。
        从以下版本开始：
        1.6

      • getExponent

        public static int getExponent​(float f)
        返回在float的表示中使用的无偏指数。 特殊情况：
        • 如果参数为NaN或无限，则结果为Float.MAX_EXPONENT + 1。
        • 如果参数为零或次正常，则结果为Float.MIN_EXPONENT -1。
        参数
        f - 一个 float价值
        结果
        参数的无偏指数
        从以下版本开始：
        1.6

      • getExponent

        public static int getExponent​(double d)
        返回在double的表示中使用的无偏指数。 特殊情况：
        • 如果参数为NaN或无限，则结果为Double.MAX_EXPONENT + 1。
        • 如果参数为零或次正常，则结果为Double.MIN_EXPONENT -1。
        参数
        d - 一个 double价值
        结果
        参数的无偏指数
        从以下版本开始：
        1.6

      • nextAfter

        public static double nextAfter​(double start,
                               double direction)
        返回与第二个参数方向相邻的第一个参数的浮点数。 如果两个参数都相等，则返回第二个参数。

        特殊情况：

        • 如果任一参数是NaN，则返回NaN。
        • 如果两个参数都是带符号的零， direction被不变地返回（如果参数比较为相等则返回第二个参数的要求）。
        • 如果start为± Double.MIN_VALUE，而direction具有使结果应具有较小幅度的值，则返回与start相同符号的零。
        • 如果start是无限的， direction具有这样的结果应该有一个小幅度的值Double.MAX_VALUE用相同的符号start返回。
        • 如果start等于± Double.MAX_VALUE，并且direction具有使得结果应该具有较大幅度的值，则返回与start具有相同符号的无穷大。
        参数
        start - 起始浮点值
        direction - 应该返回 start的邻居或 start哪一个的值
        结果
        邻近浮点数 start中的方向 direction 。
        从以下版本开始：
        1.6

      • nextAfter

        public static float nextAfter​(float start,
                              double direction)
        返回与第二个参数方向相邻的第一个参数的浮点数。 如果两个参数都相等，则返回等于第二个参数的值。

        特殊情况：

        • 如果任一参数是NaN，则返回NaN。
        • 如果两个参数都是带符号的零，则返回值为direction的值。
        • 如果start是± Float.MIN_VALUE，并且direction具有使得结果应该具有较小幅度的值，则返回与start具有相同符号的零。
        • 如果start是无限的， direction具有这样的结果应该有一个小幅度的值Float.MAX_VALUE用相同的符号start返回。
        • 如果start等于± Float.MAX_VALUE，并且direction具有使得结果应该具有较大幅度的值，则返回与start相同符号的无穷大。
        参数
        start - 起始浮点值
        direction - 应该返回 start的邻居或 start哪一个的值
        结果
        邻近浮点数 start中的方向 direction 。
        从以下版本开始：
        1.6

      • nextUp

        public static double nextUp​(double d)
        返回与正无穷大方向相邻的d的浮点值。 这种方法在语义上相当于nextAfter(d, Double.POSITIVE_INFINITY) ; 然而，一个nextUp实现可能会比其等效的nextAfter调用运行得更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果论证是正无穷大，结果是正无穷大。
        • 如果参数为零，结果为Double.MIN_VALUE
        参数
        d - 起始浮点值
        结果
        相邻浮点值接近正无穷大。
        从以下版本开始：
        1.6

      • nextUp

        public static float nextUp​(float f)
        返回与正无穷大方向相邻的f的浮点值。 这种方法在语义上相当于nextAfter(f, Float.POSITIVE_INFINITY) ; 但是，一个nextUp实现可能比其等效的nextAfter调用运行速度更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果论证是正无穷大，结果是正无穷大。
        • 如果参数为零，结果为Float.MIN_VALUE
        参数
        f - 起始浮点值
        结果
        相邻浮点值接近正无穷大。
        从以下版本开始：
        1.6

      • nextDown

        public static double nextDown​(double d)
        返回与负无穷大方向相邻的d的浮点值。 这种方法在语义上相当于nextAfter(d, Double.NEGATIVE_INFINITY) ; 然而， nextDown实现可能比其等效的nextAfter调用运行速度更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果参数为负无穷大，则结果为负无穷大。
        • 如果参数为零，结果为-Double.MIN_VALUE
        参数
        d - 起始浮点值
        结果
        相邻浮点值接近负无穷大。
        从以下版本开始：
        1.8

      • nextDown

        public static float nextDown​(float f)
        返回与负无穷大方向相邻的f的浮点值。 这种方法在语义上相当于nextAfter(f, Float.NEGATIVE_INFINITY) ; 然而，一个nextDown实现可能比其等效的nextAfter调用运行速度更快。

        特殊情况：

        • 如果参数是NaN，结果是NaN。
        • 如果参数为负无穷大，则结果为负无穷大。
        • 如果参数为零，结果为-Float.MIN_VALUE
        参数
        f - 起始浮点值
        结果
        相邻浮点值接近负无穷大。
        从以下版本开始：
        1.8

      • scalb

        public static double scalb​(double d,
                           int scaleFactor)
        返回d 2 scaleFactor四舍五入，就像一个正确四舍五入的浮点数乘以双重值集合的成员一样。 有关浮点值集的讨论，请参阅Java语言规范。 如果结果的指数在Double.MIN_EXPONENT和Double.MAX_EXPONENT之间，那么答案将被精确计算。 如果结果的指数大于Double.MAX_EXPONENT ，则返回无限大。 请注意，如果结果异常，则精度可能会丢失; 也就是说，当scalb(x, n)是次正常时， scalb(scalb(x, n), -n)可能不等于x 。 当结果为非NaN时，结果与d具有相同的符号。

        特殊情况：

        • 如果第一个参数是NaN，则返回NaN。
        • 如果第一个参数为无穷大，则返回相同符号的无穷大。
        • 如果第一个参数为零，则返回相同符号的零。
        参数
        d - d两个幂来缩放的数字。
        scaleFactor - 2的功率用于缩放 d
        结果
        d 2 scaleFactor
        从以下版本开始：
        1.6

      • scalb

        public static float scalb​(float f,
                          int scaleFactor)
        返回f 2 scaleFactor四舍五入，如同由一个正确四舍五入的浮点数乘以浮点值集合的成员一样。 有关浮点值集的讨论，请参阅Java语言规范。 如果结果的指数在Float.MIN_EXPONENT和Float.MAX_EXPONENT之间，那么答案是准确计算的。 如果结果的指数大于Float.MAX_EXPONENT ，则返回无穷大。 请注意，如果结果异常，则精度可能会丢失; 也就是说，当scalb(x, n)是次正常时， scalb(scalb(x, n), -n)可能不等于x 。 当结果为非NaN时，结果与f具有相同的符号。

        特殊情况：

        • 如果第一个参数是NaN，则返回NaN。
        • 如果第一个参数为无穷大，则返回相同符号的无穷大。
        • 如果第一个参数为零，则返回相同符号的零。
        参数
        f - f两个幂来缩放的数字。
        scaleFactor - 2的功率用于缩放 f
        结果
        f 2 scaleFactor
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


String (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class String

  • java.lang.Object
    • java.lang.String
  • All Implemented Interfaces:
    Serializable ， CharSequence ， Comparable<String>

    public final class String
extends Object
implements Serializable, Comparable<String>, CharSequence
    String类代表字符串。 Java程序中的所有字符串文字（例如"abc" ）都被实现为此类的实例。

    字符串不变; 它们的值在创建后不能被更改。 字符串缓冲区支持可变字符串。 因为String对象是不可变的，它们可以被共享。 例如：

         String str = "abc";

    相当于：

         char data[] = {'a', 'b', 'c'};
     String str = new String(data);

    以下是一些如何使用字符串的示例：

         System.out.println("abc");
     String cde = "cde";
     System.out.println("abc" + cde);
     String c = "abc".substring(2,3);
     String d = cde.substring(1, 2);

    类String包括用于检查序列的各个字符的方法，用于比较字符串，用于搜索字符串，用于提取子字符串以及用于创建具有翻译为大写或小写的所有字符的字符串的副本。 案例映射基于由Character类指定的Unicode标准版本。

    Java语言为字符串连接运算符（+）提供特殊支持，并为其他对象转换为字符串。 有关字符串连接和转换的其他信息，请参阅Java语言规范 。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    A String表示UTF-16格式的字符串，其中补充字符由代理对表示（有关详细信息，请参阅Character课程中的Character部分）。 索引值是指char代码单元，所以补充字符在String使用两个位置。

    String类提供了处理Unicode代码点（即字符）的方法，以及处理Unicode代码单元（即， char值）的方法。

    除非另有说明，比较字符串的方法不考虑区域设置。 Collator类提供了更精细，区域设置敏感的字符串比较的方法。

    Implementation Note:
    字符串连接运算符的实现由Java编译器自行决定，只要编译器最终符合Java语言规范 。 例如， javac编译器可实现运营商StringBuffer ， StringBuilder ，或java.lang.invoke.StringConcatFactory取决于JDK版本。 字符串转换的实现通常是由Object定义并由Java中的所有类继承的方法toString 。
    从以下版本开始：
    1.0
    另请参见：
    Object.toString() ， StringBuffer ， StringBuilder ， Charset ， Serialized Form
    See The Java™ Language Specification:
    15.18.1字符串连接操作符+

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Comparator<String> CASE_INSENSITIVE_ORDER
      一个比较器，可以按 compareToIgnoreCase命令 String对象。

    • 构造方法摘要

      构造方法
      Constructor 描述
      String​()
      初始化新创建的 String对象，以使其表示空字符序列。
      String​(byte[] bytes)
      通过使用平台的默认字符集解码指定的字节数组来构造新的 String 。
      String​(byte[] ascii, int hibyte)
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过使用Charset ，字符集名称的String构造函数，或者使用平台的默认字符集。
      String​(byte[] bytes, int offset, int length)
      通过使用平台的默认字符集解码指定的字节子阵列来构造新的 String 。
      String​(byte[] ascii, int hibyte, int offset, int count)
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过String构造函数获取Charset ，字符集名称，或者使用平台的默认字符集。
      String​(byte[] bytes, int offset, int length, String charsetName)
      通过使用指定的字符集解码指定的字节 String构造新的 String 。
      String​(byte[] bytes, int offset, int length, Charset charset)
      构造一个新的String通过使用指定的指定字节子阵列解码charset 。
      String​(byte[] bytes, String charsetName)
      构造一个新的String由指定用指定的字节的数组解码charset 。
      String​(byte[] bytes, Charset charset)
      构造一个新的String由指定用指定的字节的数组解码charset 。
      String​(char[] value)
      分配一个新的 String以便它表示当前包含在字符数组参数中的字符序列。
      String​(char[] value, int offset, int count)
      分配一个新的 String ，其中包含字符数组参数的子阵列中的字符。
      String​(int[] codePoints, int offset, int count)
      分配一个新的 String ，其中包含 Unicode code point数组参数的子阵列中的 字符 。
      String​(String original)
      初始化新创建的String对象，使其表示与参数相同的字符序列; 换句话说，新创建的字符串是参数字符串的副本。
      String​(StringBuffer buffer)
      分配一个新的字符串，其中包含当前包含在字符串缓冲区参数中的字符序列。
      String​(StringBuilder builder)
      分配一个新的字符串，其中包含当前包含在字符串构建器参数中的字符序列。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      char charAt​(int index)
      返回指定索引处的 char值。
      IntStream chars​()
      返回一个 int的流，从这个序列中扩展 char值。
      int codePointAt​(int index)
      返回指定索引处的字符（Unicode代码点）。
      int codePointBefore​(int index)
      返回指定索引之前的字符（Unicode代码点）。
      int codePointCount​(int beginIndex, int endIndex)
      返回此 String的指定文本范围内的Unicode代码点数。
      IntStream codePoints​()
      从此序列返回码流值。
      int compareTo​(String anotherString)
      按字典顺序比较两个字符串。
      int compareToIgnoreCase​(String str)
      按字典顺序比较两个字符串，忽略病例差异。
      String concat​(String str)
      将指定的字符串连接到该字符串的末尾。
      boolean contains​(CharSequence s)
      当且仅当此字符串包含指定的char值序列时才返回true。
      boolean contentEquals​(CharSequence cs)
      将此字符串与指定的 CharSequence 。
      boolean contentEquals​(StringBuffer sb)
      将此字符串与指定的 StringBuffer 。
      static String copyValueOf​(char[] data)
      相当于 valueOf(char[]) 。
      static String copyValueOf​(char[] data, int offset, int count)
      相当于 valueOf(char[], int, int) 。
      boolean endsWith​(String suffix)
      测试此字符串是否以指定的后缀结尾。
      boolean equals​(Object anObject)
      将此字符串与指定对象进行比较。
      boolean equalsIgnoreCase​(String anotherString)
      将此 String与另一个 String比较，忽略案例注意事项。
      static String format​(String format, Object... args)
      使用指定的格式字符串和参数返回格式化的字符串。
      static String format​(Locale l, String format, Object... args)
      使用指定的区域设置，格式字符串和参数返回格式化的字符串。
      byte[] getBytes​()
      使用平台的默认字符集将该 String编码为一系列字节，将结果存储到新的字节数组中。
      void getBytes​(int srcBegin, int srcEnd, byte[] dst, int dstBegin)
      已过时。
      此方法无法将字符正确转换为字节。 从JDK 1.1开始，首选的方法是通过getBytes()方法，该方法使用平台的默认字符集。
      byte[] getBytes​(String charsetName)
      使用命名的字符集将该 String编码为一系列字节，将结果存储到新的字节数组中。
      byte[] getBytes​(Charset charset)
      使用给定的charset将该String编码为字节序列，将结果存储到新的字节数组中。
      void getChars​(int srcBegin, int srcEnd, char[] dst, int dstBegin)
      将此字符串中的字符复制到目标字符数组中。
      int hashCode​()
      返回此字符串的哈希码。
      int indexOf​(int ch)
      返回指定字符第一次出现的字符串内的索引。
      int indexOf​(int ch, int fromIndex)
      返回指定字符第一次出现的字符串内的索引，以指定的索引开始搜索。
      int indexOf​(String str)
      返回指定子字符串第一次出现的字符串内的索引。
      int indexOf​(String str, int fromIndex)
      返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。
      String intern​()
      返回字符串对象的规范表示。
      boolean isEmpty​()
      返回 true如果，且仅当 length()为 0 。
      static String join​(CharSequence delimiter, CharSequence... elements)
      返回一个由连接在一起的 CharSequence elements副本组成的新字符串，并附带指定的 delimiter的副本。
      static String join​(CharSequence delimiter, Iterable<? extends CharSequence> elements)
      返回一个新 String的副本组成 CharSequence elements与指定的副本一起加入 delimiter 。
      int lastIndexOf​(int ch)
      返回指定字符的最后一次出现的字符串中的索引。
      int lastIndexOf​(int ch, int fromIndex)
      返回指定字符的最后一次出现的字符串中的索引，从指定的索引开始向后搜索。
      int lastIndexOf​(String str)
      返回指定子字符串最后一次出现的字符串中的索引。
      int lastIndexOf​(String str, int fromIndex)
      返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。
      int length​()
      返回此字符串的长度。
      boolean matches​(String regex)
      告诉这个字符串是否匹配给定的 regular expression 。
      int offsetByCodePoints​(int index, int codePointOffset)
      返回这个 String中的索引，它与给定的 index由 codePointOffset代码点偏移。
      boolean regionMatches​(boolean ignoreCase, int toffset, String other, int ooffset, int len)
      测试两个字符串区域是否相等。
      boolean regionMatches​(int toffset, String other, int ooffset, int len)
      测试两个字符串区域是否相等。
      String replace​(char oldChar, char newChar)
      返回从替换所有出现的导致一个字符串 oldChar ，在这个字符串 newChar 。
      String replace​(CharSequence target, CharSequence replacement)
      将与字面目标序列匹配的字符串的每个子字符串替换为指定的文字替换序列。
      String replaceAll​(String regex, String replacement)
      用给定的替换替换与给定的 regular expression匹配的此字符串的每个子字符串。
      String replaceFirst​(String regex, String replacement)
      用给定的替换替换与给定的 regular expression匹配的此字符串的第一个子字符串。
      String[] split​(String regex)
      将此字符串拆分为给定的 regular expression的匹配。
      String[] split​(String regex, int limit)
      将此字符串拆分为给定的 regular expression的匹配。
      boolean startsWith​(String prefix)
      测试此字符串是否以指定的前缀开头。
      boolean startsWith​(String prefix, int toffset)
      测试在指定索引处开始的此字符串的子字符串是否以指定的前缀开头。
      CharSequence subSequence​(int beginIndex, int endIndex)
      返回一个字符序列，该序列是该序列的子序列。
      String substring​(int beginIndex)
      返回一个字符串，该字符串是此字符串的子字符串。
      String substring​(int beginIndex, int endIndex)
      返回一个字符串，该字符串是此字符串的子字符串。
      char[] toCharArray​()
      将此字符串转换为新的字符数组。
      String toLowerCase​()
      使用默认语言环境的规则将此 String所有字符转换为小写。
      String toLowerCase​(Locale locale)
      将此 String所有字符转换为小写，使用给定的 Locale的规则。
      String toString​()
      这个对象（已经是一个字符串！）
      String toUpperCase​()
      将此 String所有字符转换为大写，使用默认语言环境的规则。
      String toUpperCase​(Locale locale)
      将此 String所有字符转换为大写，使用给定的 Locale的规则。
      String trim​()
      返回一个字符串，其值为此字符串，并删除任何前导和尾随空格。
      static String valueOf​(boolean b)
      返回 boolean参数的字符串表示形式。
      static String valueOf​(char c)
      返回 char参数的字符串表示形式。
      static String valueOf​(char[] data)
      返回 char数组参数的字符串表示形式。
      static String valueOf​(char[] data, int offset, int count)
      返回 char数组参数的特定子阵列的字符串表示形式。
      static String valueOf​(double d)
      返回 double参数的字符串表示形式。
      static String valueOf​(float f)
      返回 float参数的字符串表示形式。
      static String valueOf​(int i)
      返回 int参数的字符串表示形式。
      static String valueOf​(long l)
      返回 long参数的字符串表示形式。
      static String valueOf​(Object obj)
      返回 Object参数的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • CASE_INSENSITIVE_ORDER

        public static final Comparator<String> CASE_INSENSITIVE_ORDER
        该订单比较String对象由compareToIgnoreCase 。 该比较器可串行化。

        请注意，此比较器不会考虑区域设置，并将导致对某些区域设置的排序不满意。 Collator类提供区域设置敏感的比较。

        从以下版本开始：
        1.2
        另请参见：
        Collator

    • 构造方法详细信息

      • String

        public String​()
        初始化新创建的String对象，使其表示空字符序列。 请注意，使用此构造函数是不必要的，因为Strings是不可变的。

      • String

        public String​(String original)
        初始化新创建的String对象，使其表示与参数相同的字符序列; 换句话说，新创建的字符串是参数字符串的副本。 除非需要显示original副本， original使用此构造函数是不必要的，因为Strings是不可变的。
        参数
        original - A String

      • String

        public String​(char[] value)
        分配一个新的String以便它表示当前包含在字符数组参数中的字符序列。 字符数组的内容被复制; 字符数组的后续修改不会影响新创建的字符串。
        参数
        value - 字符串的初始值

      • String

        public String​(char[] value,
              int offset,
              int count)
        分配一个新的String ，其中包含字符数组参数的子阵列中的字符。 offset参数是子阵列的第一个字符的索引， count参数指定子阵列的长度。 副本的内容被复制; 字符数组的后续修改不会影响新创建的字符串。
        参数
        value - 作为字符源的数组
        offset - 初始偏移量
        count - 长度
        异常
        IndexOutOfBoundsException - 如果 offset为负数， count为负数，或 offset大于 value.length - count

      • String

        public String​(int[] codePoints,
              int offset,
              int count)
        分配一个新的String ，其中包含Unicode code point数组参数的子阵列中的字符 。 offset参数是子阵列的第一个代码点的索引，而count参数指定子阵列的长度。 子阵列的内容转换为char s; int数组的后续修改不会影响新创建的字符串。
        参数
        codePoints - 作为Unicode代码点的源的数组
        offset - 初始偏移量
        count - 长度
        异常
        IllegalArgumentException - 如果在 codePoints找到任何无效的Unicode代码点
        IndexOutOfBoundsException - 如果 offset为负， count为负数，或 offset为大于 codePoints.length - count
        从以下版本开始：
        1.5

      • String

        @Deprecated(since="1.1")
public String​(byte[] ascii,
              int hibyte,
              int offset,
              int count)
        已过时。 此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过使用Charset ，字符集名称的String构造函数，或者使用平台的默认字符集。
        从一个8位整数值数组的子阵列中分配一个新的String 。

        offset参数是子阵列的第一个字节的索引，而count参数指定子阵列的长度。

        子阵列中的每个byte转换为char中的String(byte[],int)构造函数。

        参数
        ascii - 要转换为字符的字节
        hibyte - 每个16位Unicode代码单元的前8位
        offset - 初始偏移量
        count - 长度
        异常
        IndexOutOfBoundsException - 如果 offset为负数， count ，否则为 offset ，或 offset大于 ascii.length - count
        另请参见：
        String(byte[], int) ，
String(byte[], int, int, java.lang.String) ，
String(byte[], int, int, java.nio.charset.Charset) ，
String(byte[], int, int) ，
String(byte[], java.lang.String) ，
String(byte[], java.nio.charset.Charset) ，
String(byte[])

      • String

        @Deprecated(since="1.1")
public String​(byte[] ascii,
              int hibyte)
        已过时。 此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过String构造函数获取Charset ，字符集名称，或者使用平台的默认字符集。
        分配一个新的String其中包含由8位整数值数组String的字符。 结果字符串中的每个字符c由字节数组中的相应组件b构成 ，使得：
             c == (char)(((hibyte & 0xff) << 8)
                         | (b & 0xff))
        参数
        ascii - 要转换为字符的字节
        hibyte - 每个16位Unicode代码单元的前8位
        另请参见：
        String(byte[], int, int, java.lang.String) ，
String(byte[], int, int, java.nio.charset.Charset) ，
String(byte[], int, int) ，
String(byte[], java.lang.String) ，
String(byte[], java.nio.charset.Charset) ，
String(byte[])

      • String

        public String​(byte[] bytes,
              int offset,
              int length,
              String charsetName)
       throws UnsupportedEncodingException
        通过使用指定的字符集解码指定的字节String构造新的String 。 新的String的长度是字符集的函数，因此可能不等于子阵列的长度。

        给定字节在给定字符集中无效时，此构造函数的行为是未指定的。 当需要更多的解码过程控制时，应使用CharsetDecoder类。

        参数
        bytes - 要解码为字符的字节
        offset - 要解码的第一个字节的索引
        length - 要解码的字节数
        charsetName - 支持的名称charset
        异常
        UnsupportedEncodingException - 如果不支持命名的字符集
        IndexOutOfBoundsException - 如果 offset为负数， length为负数，或 offset大于 bytes.length - length
        从以下版本开始：
        1.1

      • String

        public String​(byte[] bytes,
              int offset,
              int length,
              Charset charset)
        构造一个新的String通过使用指定的指定字节子阵列解码charset 。 新的String的长度是字符集的函数，因此可能不等于子String的长度。

        此方法总是用此字符集的默认替换字符串替换格式错误的输入和不可映射字符序列。 当需要更多的解码过程控制时，应使用CharsetDecoder类。

        参数
        bytes - 要解码为字符的字节
        offset - 要解码的第一个字节的索引
        length - 要解码的字节数
        charset -该charset被用来解码bytes
        异常
        IndexOutOfBoundsException - 如果 offset为负数， length为负数，或 offset大于 bytes.length - length
        从以下版本开始：
        1.6

      • String

        public String​(byte[] bytes,
              String charsetName)
       throws UnsupportedEncodingException
        构造一个新的String由指定用指定的字节的数组解码charset 。 新的String的长度是字符集的函数，因此可能不等于字节数组的长度。

        给定字节在给定字符集中无效时，此构造函数的行为是未指定的。 当需要更多的解码过程控制时，应使用CharsetDecoder类。

        参数
        bytes - 要解码为字符的字节
        charsetName - 支持的名称charset
        异常
        UnsupportedEncodingException - 如果不支持命名的字符集
        从以下版本开始：
        1.1

      • String

        public String​(byte[] bytes,
              Charset charset)
        构造一个新的String由指定用指定的字节的数组解码charset 。 新的String的长度是字符集的函数，因此可能不等于字节数组的长度。

        此方法总是用此字符集的默认替换字符串替换格式错误的输入和不可映射字符序列。 当需要更多的解码过程控制时，应使用CharsetDecoder类。

        参数
        bytes - 要解码为字符的字节
        charset -该charset被用来解码bytes
        从以下版本开始：
        1.6

      • String

        public String​(byte[] bytes,
              int offset,
              int length)
        通过使用平台的默认字符集解码指定的字节子阵列，构造新的String 。 新的String的长度是字符集的函数，因此可能不等于子String的长度。

        指定字节在默认字符集中无效时，此构造函数的行为是未指定的。 当需要更多的解码过程控制时，应使用CharsetDecoder类。

        参数
        bytes - 要解码为字符的字节
        offset - 要解码的第一个字节的索引
        length - 要解码的字节数
        异常
        IndexOutOfBoundsException - 如果 offset为负数， length ，否则为 offset ，大于 bytes.length - length
        从以下版本开始：
        1.1

      • String

        public String​(byte[] bytes)
        通过使用平台的默认字符集解码指定的字节数组来构造新的String 。 新的String的长度是字符集的函数，因此可能不等于字节数组的长度。

        指定字节在默认字符集中无效时，此构造函数的行为是未指定的。 当需要更多的解码过程控制时，应使用CharsetDecoder类。

        参数
        bytes - 要解码为字符的字节
        从以下版本开始：
        1.1

      • String

        public String​(StringBuffer buffer)
        分配一个新的字符串，其中包含当前包含在字符串缓冲区参数中的字符序列。 字符串缓冲区的内容被复制; 字符串缓冲区的后续修改不会影响新创建的字符串。
        参数
        buffer - A StringBuffer

      • String

        public String​(StringBuilder builder)
        分配一个新的字符串，其中包含当前包含在字符串构建器参数中的字符序列。 字符串构建器的内容被复制; 字符串构建器的后续修改不会影响新创建的字符串。

        提供此构造函数以便迁移到StringBuilder 。 通过toString方法从字符串构建器获取字符串可能运行速度更快，通常是首选。

        参数
        builder - A StringBuilder
        从以下版本开始：
        1.5

    • 方法详细信息

      • length

        public int length​()
        返回此字符串的长度。 长度等于字符串中的数字Unicode code units 。
        Specified by:
        length在接口 CharSequence
        结果
        由该对象表示的字符序列的长度。

      • isEmpty

        public boolean isEmpty​()
        返回 true如果，且仅当 length()为 0 。
        结果
        true如果 length()是 0 ，否则 false
        从以下版本开始：
        1.6

      • charAt

        public char charAt​(int index)
        返回指定索引处的char值。 指数范围从0到length() - 1 。 序列的第一个char值是索引0 ，下一个索引为1 ，依此类推，就像数组索引一样。

        如果由索引指定的char值为surrogate ，则返回替代值。

        Specified by:
        charAt在接口 CharSequence
        参数
        index - 指数 char价值。
        结果
        该字符串的指定索引处的值为char 。 第一个char值是索引0 。
        异常
        IndexOutOfBoundsException - 如果 index参数为负数或不小于此字符串的长度。

      • codePointAt

        public int codePointAt​(int index)
        返回指定索引处的字符（Unicode代码点）。 该索引指的是char值（Unicode码单位），范围从0到length() - 1 。

        如果给定指数中指定的char值处于高代理范围内，则以下指数小于此String的长度，并且下列指数的char值处于低代理范围，则补码代码点相应的这个代理对被退回。 否则，返回给定索引处的char值。

        参数
        index - 指数为 char值
        结果
        字符的代码点值在 index
        异常
        IndexOutOfBoundsException - 如果 index参数为负数或不小于此字符串的长度。
        从以下版本开始：
        1.5

      • codePointBefore

        public int codePointBefore​(int index)
        返回指定索引之前的字符（Unicode代码点）。 该索引是指char值（Unicode代码单位），范围从1到length 。

        如果char为(index - 1) ， (index - 2)为(index - 2)为char值为(index - 2) ，则返回替代对的(index - 2)点值。 如果char在值index - 1是未配对的低代理或一个高代理，则返回所述替代值。

        参数
        index - 应该返回的代码点后面的索引
        结果
        Unicode代码点值在给定索引之前。
        异常
        IndexOutOfBoundsException - 如果 index参数小于1或大于此字符串的长度。
        从以下版本开始：
        1.5

      • codePointCount

        public int codePointCount​(int beginIndex,
                          int endIndex)
        返回此String的指定文本范围内的Unicode代码点数。 文本范围始于指定beginIndex并延伸到char在索引endIndex - 1 。 因此文本范围的长度（ char s）为endIndex-beginIndex 。 文本范围内的非配对替代品，每一个代码点都是一样的。
        参数
        beginIndex - 索引到第一个 char的文本范围。
        endIndex - 最后一个 char之后的索引文字范围。
        结果
        指定文本范围内的Unicode代码点数
        异常
        IndexOutOfBoundsException - 如果 beginIndex为负数，或 endIndex大于此 String的长度，或 beginIndex大于 endIndex 。
        从以下版本开始：
        1.5

      • offsetByCodePoints

        public int offsetByCodePoints​(int index,
                              int codePointOffset)
        返回该String内的索引，该索引与给定的index由codePointOffset代码点偏移。 由index和codePointOffset给出的文本范围内的非index codePointOffset作为一个代码点。
        参数
        index - 要偏移的索引
        codePointOffset - 代码点的偏移量
        结果
        该指数在此 String
        异常
        IndexOutOfBoundsException - 如果 index为负或大于该 String的长度，或者如果 codePointOffset为正，并且以 index开头的子串 index为 codePointOffset ，或者如果 codePointOffset为负，并且 index之前的子字符串的数目少于绝对值 codePointOffset代码点。
        从以下版本开始：
        1.5

      • getChars

        public void getChars​(int srcBegin,
                     int srcEnd,
                     char[] dst,
                     int dstBegin)
        将此字符串中的字符复制到目标字符数组中。

        要复制的第一个字符是索引srcBegin ; 要复制的最后一个字符是索引srcEnd-1 （因此要复制的字符总数为srcEnd-srcBegin ）。 字符被复制到dst的子阵列，从索引dstBegin开始，并以索引结尾：

             dstBegin + (srcEnd-srcBegin) - 1
        参数
        srcBegin - 要复制的字符串中的第一个字符的索引。
        srcEnd - 要复制的字符串中的最后一个字符之后的索引。
        dst - 目标数组。
        dstBegin - 目标数组中的起始偏移量。
        异常
        IndexOutOfBoundsException - 如果满足以下条件：
        • srcBegin是否定的。
        • srcBegin大于srcEnd
        • srcEnd大于此字符串的长度
        • dstBegin为负数
        • dstBegin+(srcEnd-srcBegin)大于dst.length

      • getBytes

        @Deprecated(since="1.1")
public void getBytes​(int srcBegin,
                     int srcEnd,
                     byte[] dst,
                     int dstBegin)
        已过时。 此方法无法将字符正确转换为字节。 从JDK 1.1开始，首选的方法是通过使用平台默认字符集的getBytes()方法。
        将此字符串中的字符复制到目标字节数组中。 每个字节接收相应字符的8个低位。 每个字符的八个高位不被复制，也不以任何方式参与转移。

        要复制的第一个字符是索引srcBegin ; 要复制的最后一个字符是索引srcEnd-1 。 要复制的字符总数为srcEnd-srcBegin 。 转换为字节的字符将被复制到dst的子阵列，从索引dstBegin开始，并以索引结尾：

             dstBegin + (srcEnd-srcBegin) - 1
        参数
        srcBegin - 要复制的字符串中第一个字符的索引
        srcEnd - 要复制的字符串中最后一个字符后的索引
        dst - 目的地阵列
        dstBegin - 目标数组中的起始偏移量
        异常
        IndexOutOfBoundsException - 如果满足以下条件：
        • srcBegin是否定的
        • srcBegin大于srcEnd
        • srcEnd大于此String的长度
        • dstBegin为负数
        • dstBegin+(srcEnd-srcBegin)大于dst.length

      • getBytes

        public byte[] getBytes​(String charsetName)
                throws UnsupportedEncodingException
        使用命名的字符集将这个String编码成一个字节序列，将结果存储到一个新的字节数组中。

        当该字符串不能在给定的字符集中编码时，此方法的行为是未指定的。 当需要对编码过程进行更多控制时，应使用CharsetEncoder类。

        参数
        charsetName - 支持的名称charset
        结果
        结果字节数组
        异常
        UnsupportedEncodingException - 如果不支持命名的字符集
        从以下版本开始：
        1.1

      • getBytes

        public byte[] getBytes​(Charset charset)
        使用给定的charset将该String编码为字节序列，将结果存储到新的字节数组中。

        此方法总是用此字符集的默认替换字节数组替换格式错误的输入和不可映射字符序列。 当需要对编码过程进行更多控制时，应使用CharsetEncoder类。

        参数
        charset -该Charset被用于编码String
        结果
        结果字节数组
        从以下版本开始：
        1.6

      • getBytes

        public byte[] getBytes​()
        使用平台的默认字符集将该String编码为一系列字节，将结果存储到新的字节数组中。

        当该字符串不能在默认字符集中编码时，此方法的行为是未指定的。 当需要对编码过程进行更多控制时，应使用CharsetEncoder类。

        结果
        结果字节数组
        从以下版本开始：
        1.1

      • equals

        public boolean equals​(Object anObject)
        将此字符串与指定对象进行比较。 如果且仅当参数不是null且是表示与该对象相同的字符序列的String对象时，结果为true 。

        有关更细粒度的字符串比较，请参阅Collator 。

        重写：
        equals在 Object
        参数
        anObject - 对比这个 String对象
        结果
        true如果给定的对象表示一个 String相当于此字符串， false否则
        另请参见：
        compareTo(String) ， equalsIgnoreCase(String)

      • contentEquals

        public boolean contentEquals​(StringBuffer sb)
        将此字符串与指定的StringBuffer 。 结果是true当且仅当这个String表示与指定的StringBuffer相同的字符序列。 该方法在StringBuffer上同步。

        有关更细粒度的字符串比较，请参阅Collator 。

        参数
        sb - 该 StringBuffer比较这个 String对
        结果
        true ，如果这 String代表字符的相同序列与指定 StringBuffer ， false否则
        从以下版本开始：
        1.4

      • contentEquals

        public boolean contentEquals​(CharSequence cs)
        将此字符串与指定的CharSequence 。 结果是true当且仅当该String表示与指定序列相同的字符值序列时。 注意，如果CharSequence是一个StringBuffer那么该方法就可以同步它。

        有关更细粒度的字符串比较，请参阅Collator 。

        参数
        cs - 比较这个 String的序列
        结果
        true如果这个 String表示与指定序列相同的char值序列， false否则
        从以下版本开始：
        1.5

      • equalsIgnoreCase

        public boolean equalsIgnoreCase​(String anotherString)
        将此String比较为另一个String ，忽略案例注意事项。 如果两个字符串的长度相同，并且两个字符串中的相应字符等于忽略大小写，则两个字符串被认为是相等的。

        如果以下至少一个为真，则两个字符c1和c2被认为是相同的忽略情况：

        • 两个字符相同（与==操作符相比）
        • 在每个字符上调用Character.toLowerCase(Character.toUpperCase(char))产生相同的结果

        请注意，此方法不场所考虑，并会导致特定的语言环境不令人满意的结果。 Collator类提供区域设置敏感的比较。

        参数
        anotherString - String比较这个 String对
        结果
        true如果参数不是null ，它代表等效的String忽略大小写; 否则为false
        另请参见：
        equals(Object)

      • compareTo

        public int compareTo​(String anotherString)
        按字典顺序比较两个字符串。 比较是基于字符串中每个字符的Unicode值。 由该String对象表示的字符序列在字典上与由参数字符串表示的字符序列进行比较。 结果是一个负整数，如果这个String对象按字典顺序String在参数字符串之前。 结果是一个正整数，如果这个String对象按字典顺序跟随参数字符串。 如果字符串相等，结果为零; compareTo返回0当equals(Object)方法将返回true 。

        这是字典排序的定义。 如果两个字符串不同，则它们在某些索引处具有不同的字符，这两个字符串是两个字符串的有效索引，或者它们的长度不同，或两者都是不同的。 如果它们在一个或多个索引位置具有不同的字符，则令k为最小的索引; 那么通过使用<运算符确定位置k的字符具有较小值的字符串，其字符串在另一个字符串之前。 在这种情况下， compareTo返回两个字符串中位置k处的两个字符值的k ，即值：

         this.charAt(k)-anotherString.charAt(k)
        如果没有它们不同的索引位置，则较短的字符串按字典顺序位于较长的字符串之前。 在这种情况下， compareTo返回字符串长度的差异 - 即值：
         this.length()-anotherString.length()

        有关更细粒度的字符串比较，请参阅Collator 。

        Specified by:
        compareTo在接口 Comparable<String>
        参数
        anotherString - 要比较的 String 。
        结果
        如果参数字符串等于此字符串，则值为0 ; 小于0的值，如果该字符串的字典字符串小于字符串参数; 如果该字符串的字符串字符串大于字符串参数，则该值大于0 。

      • compareToIgnoreCase

        public int compareToIgnoreCase​(String str)
        按字典顺序比较两个字符串，忽略病例差异。 该方法返回一个整数，其符号是调用compareTo的字符串的标准化版本，通过调用每个字符Character.toLowerCase(Character.toUpperCase(character))已经消除了差异。

        请注意，此方法不场所考虑，并会导致特定的语言环境不满意的排序。 Collator类提供区域设置敏感的比较。

        参数
        str - 要比较的 String 。
        结果
        指定的String大于等于或小于此String的负整数，零或正整数，忽略大小写注意事项。
        从以下版本开始：
        1.2
        另请参见：
        Collator

      • regionMatches

        public boolean regionMatches​(int toffset,
                             String other,
                             int ooffset,
                             int len)
        测试两个字符串区域是否相等。

        这个String对象的子字符串与其他参数的子字符串进行比较。 如果这些子串表示相同的字符序列，结果是真的。 要比较的String对象的子串从索引toffset开始，长度为len 。 其他要比较的子ooffset始于索引ooffset ，长度为len 。 结果是false当且仅当以下至少有一个是真的：

        • toffset是否定的。
        • ooffset为负数。
        • toffset+len大于此String对象的长度。
        • ooffset+len大于其他参数的长度。
        • 有一些非负整数k小于len ，使得： this.charAt(toffset + k ) != other.charAt(ooffset + k )

        请注意，此方法不场所考虑。 Collator类提供区域设置敏感的比较。

        参数
        toffset - 该字符串 toffset区域的起始偏移量。
        other - 字符串参数。
        ooffset - 字符串参数 ooffset区域的起始偏移量。
        len - 要比较的字符数。
        结果
        true如果此字符串的指定子区域与字符串参数的指定子区域完全匹配; 否则为false 。

      • regionMatches

        public boolean regionMatches​(boolean ignoreCase,
                             int toffset,
                             String other,
                             int ooffset,
                             int len)
        测试两个字符串区域是否相等。

        将此String对象的子字符串与参数other的子字符串进行other 。 如果这些子字符串表示相同的字符序列，则结果为true ，如果且仅当ignoreCase为真时忽略大小写。 要比较的String对象的子串从索引toffset开始，长度为len 。 要比较的other的子other始于索引ooffset ，长度为len 。 结果是false当且仅当以下至少有一个是真的：

        • toffset是否定的。
        • ooffset是否定的。
        • toffset+len大于此String对象的长度。
        • ooffset+len大于其他参数的长度。
        • ignoreCase是false ，有一些非负整数k小于len ，使得：
           this.charAt(toffset+k) != other.charAt(ooffset+k)
        • ignoreCase是true并且有一些非负整数k小于len ，使得：
           Character.toLowerCase(Character.toUpperCase(this.charAt(toffset+k))) !=
     Character.toLowerCase(Character.toUpperCase(other.charAt(ooffset+k)))

        请注意，此方法不场所考虑，并会导致特定的语言环境不理想结果时ignoreCase为true 。 Collator类提供区域设置敏感的比较。

        参数
        ignoreCase - 如果是 true ，比较字符时忽略大小写。
        toffset - 该字符串 toffset区域的起始偏移量。
        other - 字符串参数。
        ooffset - 字符串参数 ooffset区域的起始偏移量。
        len - 要比较的字符数。
        结果
        true如果此字符串的指定子区域匹配字符串参数的指定子区域; 否则为false 。 匹配是否精确或不区分大小写取决于ignoreCase参数。

      • startsWith

        public boolean startsWith​(String prefix,
                          int toffset)
        测试在指定索引处开始的此字符串的子字符串是否以指定的前缀开头。
        参数
        prefix - 前缀。
        toffset - 在哪里开始查找这个字符串。
        结果
        true如果由参数表示的字符序列是从索引toffset开始的此对象的子字符串的前缀; false否则。 结果是false如果toffset为负或大于此String对象的长度; 否则结果与表达式的结果相同
          this.substring(toffset).startsWith(prefix)

      • startsWith

        public boolean startsWith​(String prefix)
        测试此字符串是否以指定的前缀开头。
        参数
        prefix - 前缀。
        结果
        true如果由参数表示的字符序列是由该字符串表示的字符序列的前缀; 否则为false 。 还需要注意的是true如果参数为空字符串或等于该将被返回String如由所确定的对象equals(Object)方法。
        从以下版本开始：
        1.0

      • endsWith

        public boolean endsWith​(String suffix)
        测试此字符串是否以指定的后缀结尾。
        参数
        suffix - 后缀。
        结果
        true如果由参数表示的字符序列是由该对象表示的字符序列的后缀; 否则为false 。 注意，结果将是true如果参数是空字符串或等于该String如由所确定的对象equals(Object)方法。

      • hashCode

        public int hashCode​()
        返回此字符串的哈希码。 String对象的哈希码计算为
         s[0]*31^(n-1) + s[1]*31^(n-2) + ... + s[n-1]
        使用int算术，其中s[i]是字符串的第i个字符， n是字符串的长度， ^表示取幂。 （空字符串的哈希值为零）
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • indexOf

        public int indexOf​(int ch)
        返回指定字符第一次出现的字符串内的索引。 如果由String对象表示的字符序列中出现值为ch的字符，则返回首次发生的索引（以Unicode码为单位）。 对于从0到0xFFFF（含）范围内的ch值，这是最小值k ，使得：
         this.charAt(k) == ch
        是真的。 对于ch其他值，它是最小值k ，使得：
         this.codePointAt(k) == ch
        是真的。 在这两种情况下，如果此字符串中没有这样的字符，则返回-1 。
        参数
        ch - 一个字符（Unicode代码点）。
        结果
        由该对象表示的字符序列中第一次出现字符的索引，如果字符不发生， -1 。

      • indexOf

        public int indexOf​(int ch,
                   int fromIndex)
        返回指定字符第一次出现的字符串内的索引，以指定的索引开始搜索。

        如果在该String对象所表示的字符序列中的值为ch的字符发生在不小于fromIndex的索引上，则返回首次发生的索引。 对于从0到0xFFFF（含）范围内的ch值，这是最小值k ，使得：

         (this.charAt(k) == ch) && (k >= fromIndex)
        是真的。 对于ch其他值，它是最小值k ，使得：
         (this.codePointAt(k) == ch) && (k >= fromIndex)
        是真的。 在这两种情况下，如果这个字符串在位置fromIndex或之后没有发生这样的字符，则返回-1 。

        对fromIndex的价值没有限制。 如果它是否定的，它具有与零一样的效果：可以搜索整个字符串。 如果它大于此字符串的长度，它具有与该字符串的长度相等的效果：返回-1 。

        所有索引均以char值（Unicode代码单位）指定。

        参数
        ch - 一个字符（Unicode代码点）。
        fromIndex - 开始搜索的索引。
        结果
        由该对象表示的字符序列中第一次出现的字符数大于或等于 fromIndex ，如果字符不发生， -1 。

      • lastIndexOf

        public int lastIndexOf​(int ch)
        返回指定字符的最后一次出现的字符串中的索引。 对于从0到0xFFFF（含）范围内的ch值， ch的索引（以Unicode代码为单位）是最大的值k ，使得：
         this.charAt(k) == ch
        是真的。 对于ch其他值，它是最大的值k ，使得：
         this.codePointAt(k) == ch
        是真的。 在这两种情况下，如果此字符串中没有此类字符，则返回-1 。 String从最后一个字符开始向后搜索。
        参数
        ch - 一个字符（Unicode代码点）。
        结果
        由该对象表示的字符序列中的最后一次出现的索引，如果该字符不发生， -1 。

      • lastIndexOf

        public int lastIndexOf​(int ch,
                       int fromIndex)
        返回指定字符的最后一次出现的字符串中的索引，从指定的索引开始向后搜索。 对于从0到0xFFFF（含）范围内的值为ch ，返回的索引是最大值k ，使得：
         (this.charAt(k) == ch) && (k <= fromIndex)
        是真的。 对于ch其他值，它是最大的值k ，使得：
         (this.codePointAt(k) == ch) && (k <= fromIndex)
        是真的。 在这两种情况下，如果此字符串在位置fromIndex处或之前没有发生此字符串，则返回-1 。

        所有索引在char值（Unicode代码单位）中指定。

        参数
        ch - 一个字符（Unicode代码点）。
        fromIndex - 开始搜索的索引。 对fromIndex的价值没有限制。 如果它大于或等于此字符串的长度，它具有与等于该字符串长度小于1的效果相同的效果：可以搜索整个字符串。 如果它是负的，它具有与-1：-1相同的效果。
        结果
        由该对象表示的字符序列的最后一次出现的索引小于或等于 fromIndex ，如果字符不在此点之前发生， -1 。

      • indexOf

        public int indexOf​(String str)
        返回指定子字符串第一次出现的字符串内的索引。

        返回的索引是最小值k ，其中：

           this.startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        结果
        指定子字符串的首次出现的索引，如果没有这种情况， -1 。

      • indexOf

        public int indexOf​(String str,
                   int fromIndex)
        返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。

        返回的索引是最小值k ，其中：

           k >= Math.min(fromIndex, this.length()) && this.startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        fromIndex - 从中开始搜索的索引。
        结果
        指定的子字符串的第一次出现的索引，从指定的索引开始，如果没有此类事件， -1 。

      • lastIndexOf

        public int lastIndexOf​(String str)
        返回指定子字符串最后一次出现的字符串中的索引。 空字符串“”的最后一次出现被认为发生在索引值this.length() 。

        返回的指数是最大值k ，其中：

           this.startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        结果
        指定子字符串的最后一次出现的索引，如果没有这种情况， -1 。

      • lastIndexOf

        public int lastIndexOf​(String str,
                       int fromIndex)
        返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。

        返回的指数是k ：

           k <= Math.min(fromIndex, this.length()) && this.startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        fromIndex - 开始搜索的索引。
        结果
        指定的子字符串的最后一次出现的索引，从指定的索引向后搜索，如果没有这种情况， -1 。

      • substring

        public String substring​(int beginIndex)
        返回一个字符串，该字符串是此字符串的子字符串。 子字符串以指定索引处的字符开头，并扩展到此字符串的末尾。

        例子：

         "unhappy".substring(2) returns "happy"
 "Harbison".substring(3) returns "bison"
 "emptiness".substring(9) returns "" (an empty string)
        参数
        beginIndex - 包含起始索引。
        结果
        指定的子字符串。
        异常
        IndexOutOfBoundsException - 如果 beginIndex为负或大于此 String对象的长度。

      • substring

        public String substring​(int beginIndex,
                        int endIndex)
        返回一个字符串，该字符串是此字符串的子字符串。 子串从指定的beginIndex开始，并扩展到索引号为endIndex - 1的字符。 因此子串的长度为endIndex-beginIndex 。

        例子：

         "hamburger".substring(4, 8) returns "urge"
 "smiles".substring(1, 5) returns "mile"
        参数
        beginIndex - 开始索引，包括。
        endIndex - 结束索引，独占。
        结果
        指定的子字符串。
        异常
        IndexOutOfBoundsException - 如果 beginIndex为负数，或 endIndex大于该 String对象的长度，或 beginIndex大于 endIndex 。

      • subSequence

        public CharSequence subSequence​(int beginIndex,
                                int endIndex)
        返回一个字符序列，该序列是该序列的子序列。

        调用此方法的形式

         str.subSequence(begin, end)
        行为与调用完全相同
         str.substring(begin, end)
        Specified by:
        subSequence在接口 CharSequence
        API Note:
        该方法定义为String类可以实现CharSequence接口。
        参数
        beginIndex - 开始索引，包括。
        endIndex - 结束索引，排他。
        结果
        指定的子序列。
        异常
        IndexOutOfBoundsException - 如果 beginIndex或 endIndex为负数，如果 endIndex大于 length() ，或者如果 beginIndex大于 endIndex
        从以下版本开始：
        1.4

      • concat

        public String concat​(String str)
        将指定的字符串连接到该字符串的末尾。

        如果参数字符串的长度为0 ，则返回此String对象。 否则，返回一个String对象，表示一个字符序列，该字符序列是由该String对象表示的字符序列与由参数字符串表示的字符序列的级联。

        例子：

         "cares".concat("s") returns "caress"
 "to".concat("get").concat("her") returns "together"
        参数
        str -在 String被连结到这个月底 String 。
        结果
        一个字符串，表示此对象的字符后跟字符串参数的字符的并置。

      • replace

        public String replace​(char oldChar,
                      char newChar)
        返回从替换所有出现的导致一个字符串oldChar ，在这个字符串newChar 。

        如果字符oldChar不通过此表示的字符序列发生String对象，则该基准String对象被返回。 否则，返回表示与该String对象所表示的字符序列相同的字符序列的String对象，除了oldChar每次出现被替换为newChar的出现。

        例子：

         "mesquite in your cellar".replace('e', 'o')
         returns "mosquito in your collar"
 "the war of baronets".replace('r', 'y')
         returns "the way of bayonets"
 "sparring with a purple porpoise".replace('p', 't')
         returns "starring with a turtle tortoise"
 "JonL".replace('q', 'x') returns "JonL" (no change)
        参数
        oldChar - 老字。
        newChar - 新角色。
        结果
        通过替换的每次出现从这个串衍生出的字符串 oldChar与 newChar 。

      • matches

        public boolean matches​(String regex)
        告诉这个字符串是否匹配给定的regular expression 。

        这种形式为str .matches( 正则表达式 )的这种方法的调用产生与表达式完全相同的结果

        Pattern. matches(regex, str)
        参数
        regex - 要匹配此字符串的正则表达式
        结果
        true如果并且只有这个字符串与给定的正则表达式匹配
        异常
        PatternSyntaxException - 如果正则表达式的语法无效
        从以下版本开始：
        1.4
        另请参见：
        Pattern

      • contains

        public boolean contains​(CharSequence s)
        当且仅当此字符串包含指定的char值序列时才返回true。
        参数
        s - 搜索的顺序
        结果
        如果此字符串包含 s ， s true，否则为false
        从以下版本开始：
        1.5

      • replaceFirst

        public String replaceFirst​(String regex,
                           String replacement)
        用给定的替换替换与给定的regular expression匹配的此字符串的第一个子字符串。

        这种方式的调用str .replaceFirst( 正则表达式 , repl )产生与表达式完全相同的结果

        Pattern.compile(regex).matcher(str).replaceFirst(repl)

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与被视为文字替换字符串时的结果不同; 见Matcher.replaceFirst(java.lang.String) 。 如果需要，可以使用Matcher.quoteReplacement(java.lang.String)来抑制这些字符的特殊含义。

        参数
        regex - 要匹配此字符串的正则表达式
        replacement - 要替换第一个匹配的字符串
        结果
        结果 String
        异常
        PatternSyntaxException - 如果正则表达式的语法无效
        从以下版本开始：
        1.4
        另请参见：
        Pattern

      • replaceAll

        public String replaceAll​(String regex,
                         String replacement)
        用给定的替换替换与给定的regular expression匹配的此字符串的每个子字符串。

        这种方法的调用str .replaceAll( 正则表达式 , repl )产生与表达式完全相同的结果

        Pattern.compile(regex).matcher(str).replaceAll(repl)

        请注意，替换字符串中的反斜杠（ \ ）和美元符号（ $ ）可能会导致结果与被视为文字替换字符串时的结果不同; 见Matcher.replaceAll 。 如果需要，可以使用Matcher.quoteReplacement(java.lang.String)来抑制这些字符的特殊含义。

        参数
        regex - 要匹配此字符串的正则表达式
        replacement - 要替换每个匹配的字符串
        结果
        结果 String
        异常
        PatternSyntaxException - 如果正则表达式的语法无效
        从以下版本开始：
        1.4
        另请参见：
        Pattern

      • replace

        public String replace​(CharSequence target,
                      CharSequence replacement)
        将与字面目标序列匹配的字符串的每个子字符串替换为指定的文字替换序列。 替换从字符串开始到结束，例如，在字符串“aaa”中用“b”替换“aa”将导致“ba”而不是“ab”。
        参数
        target - 要替换的char值的序列
        replacement - char值的替换顺序
        结果
        生成的字符串
        从以下版本开始：
        1.5

      • split

        public String[] split​(String regex,
                      int limit)
        将此字符串拆分为给定的regular expression的匹配项 。

        此方法返回的数组包含此字符串的每个子字符串，由与给定表达式匹配的另一个子字符串终止，或由字符串的结尾终止。 数组中的子字符串按照它们在此字符串中的顺序排列。 如果表达式与输入的任何部分不匹配，则生成的数组只有一个元素，即这个字符串。

        当在此字符串的开始处存在正宽度匹配时，在结果数组的开始处包含空的前导子字符串。 开始时的零宽度匹配不会产生这样的空的前导子串。

        limit参数控制应用模式的次数，因此影响生成的数组的长度。 如果极限n大于0，则模式最多应用n -1次，数组的长度不大于n ，数组的最后一个条目将包含超出最后一个匹配分隔符的所有输入。 如果n是非正的，那么模式将被应用到尽可能多的次数，并且数组可以有任何长度。 如果n为0，则模式将被应用尽可能多次，数组可以有任何长度，并且尾随的空字符串将被丢弃。

        例如，字符串"boo:and:foo"通过这些参数产生以下结果：

        Split example showing regex, limit, and result
        Regex | Limit | Result
        : 2 { "boo", "and:foo" }
        : 5 { "boo", "and", "foo" }
        : -2 { "boo", "and", "foo" }
        o | 5 | { "b", "", ":and:f", "", "" }
        o | -2 | { "b", "", ":and:f", "", "" }
        o | 0 | { "b", "", ":and:f" }

        调用此方法的形式str。 split( 正则表达式 , n )得到与表达式相同的结果

        Pattern.compile(regex).split(str, n)
        参数
        regex - 分隔正则表达式
        limit - 结果阈值，如上所述
        结果
        通过将该字符串围绕给定的正则表达式的匹配来计算的字符串数组
        异常
        PatternSyntaxException - 如果正则表达式的语法无效
        从以下版本开始：
        1.4
        另请参见：
        Pattern

      • split

        public String[] split​(String regex)
        将此字符串拆分为给定的regular expression的匹配。

        该方法的工作原理是通过使用给定的表达式和极限参数为零调用双参数split方法。 因此，尾随的空字符串不会包含在结果数组中。

        例如，字符串"boo:and:foo"使用以下表达式得到以下结果：

        Split examples showing regex and result
        Regex | Result
        : { "boo", "and", "foo" }
        o | { "b", "", ":and:f" }
        参数
        regex - 分隔正则表达式
        结果
        通过将该字符串围绕给定的正则表达式的匹配来计算的字符串数组
        异常
        PatternSyntaxException - 如果正则表达式的语法无效
        从以下版本开始：
        1.4
        另请参见：
        Pattern

      • join

        public static String join​(CharSequence delimiter,
                          CharSequence... elements)
        返回一个由连接在一起的CharSequence elements的副本组成的新的字符串，并附有指定的delimiter的副本。
        For example,

     String message = String.join("-", "Java", "is", "cool");
     // message returned is: "Java-is-cool"
        请注意，如果元素为空，则添加"null" 。
        参数
        delimiter - 分隔每个元素的分隔符
        elements - 要加入的元素。
        结果
        一个新的 String ，其由所述的 elements由分离 delimiter
        异常
        NullPointerException - 如果 delimiter或 elements是 null
        从以下版本开始：
        1.8
        另请参见：
        StringJoiner

      • join

        public static String join​(CharSequence delimiter,
                          Iterable<? extends CharSequence> elements)
        返回一个新String的副本组成CharSequence elements与指定的副本一起加入delimiter 。
        For example,

     List<String> strings = List.of("Java", "is", "cool");
     String message = String.join(" ", strings);
     //message returned is: "Java is cool"

     Set<String> strings =
         new LinkedHashSet<>(List.of("Java", "is", "very", "cool"));
     String message = String.join("-", strings);
     //message returned is: "Java-is-very-cool"
        请注意，如果单个元素为null ，则添加"null" 。
        参数
        delimiter - 一个字符序列，用于分离 elements中的每一个 String
        elements - 一个 Iterable ，将其 elements连接在一起。
        结果
        一个新的 String由 elements参数组成
        异常
        NullPointerException - 如果 delimiter或 elements是 null
        从以下版本开始：
        1.8
        另请参见：
        join(CharSequence,CharSequence...) ， StringJoiner

      • toLowerCase

        public String toLowerCase​(Locale locale)
        将此String所有字符转换为小写，使用给定的Locale的规则。 案例映射基于由Character类指定的Unicode标准版本。 由于情况映射并不总是1：1的字符映射，所以产生的String可能与原来的String 。

        小写映射示例如下表所示：

        Lowercase mapping examples showing language code of locale, upper case, lower case, and description Language Code of Locale Upper Case Lower Case Description tr (Turkish) \u0130 \u0069 capital letter I with dot above -> small letter i tr (Turkish) \u0049 \u0131 capital letter I -> small letter dotless i (all) French Fries french fries lowercased all chars in String (all) capiota capchi captheta capupsil capsigma iota chi theta upsilon sigma lowercased all chars in String
        参数
        locale - 使用此区域设置的案例转换规则
        结果
        String ，转换为小写。
        从以下版本开始：
        1.1
        另请参见：
        toLowerCase() ，
toUpperCase() ，
toUpperCase(Locale)

      • toLowerCase

        public String toLowerCase​()
        将此String所有字符转换为小写，使用默认语言环境的规则。 这相当于调用toLowerCase(Locale.getDefault()) 。

        注意：此方法是区域设置敏感的，如果用于单独解释区域设置的字符串，可能会产生意外的结果。 示例是编程语言标识符，协议密钥和HTML标签。 例如， "TITLE".toLowerCase()在土耳其语言环境返回"t\u0131tle" ，其中“\ u0131”是拉丁小写字母无点我的性格。 要获取不区分大小写字符串的正确结果，请使用toLowerCase(Locale.ROOT) 。

        结果
        String ，转换为小写。
        另请参见：
        toLowerCase(Locale)

      • toUpperCase

        public String toUpperCase​(Locale locale)
        将此String所有字符转换为大写，使用给定的Locale的规则。 案例映射基于由Character类指定的Unicode标准版本。 由于情况映射并不总是1：1的字符映射，所以产生的String可能与原来的String 。

        区域设置敏感和1：M情况映射的示例如下表所示。

        Examples of locale-sensitive and 1:M case mappings. Shows Language code of locale, lower case, upper case, and description. Language Code of Locale Lower Case Upper Case Description tr (Turkish) \u0069 \u0130 small letter i -> capital letter I with dot above tr (Turkish) \u0131 \u0049 small letter dotless i -> capital letter I (all) \u00df \u0053 \u0053 small letter sharp s -> two letters: SS (all) Fahrvergnügen FAHRVERGNÜGEN
        参数
        locale - 使用此区域设置的案例转换规则
        结果
        String转换成大写字母。
        从以下版本开始：
        1.1
        另请参见：
        toUpperCase() ，
toLowerCase() ，
toLowerCase(Locale)

      • toUpperCase

        public String toUpperCase​()
        使用默认语言环境的规则将此String所有字符转换为大写。 此方法相当于toUpperCase(Locale.getDefault()) 。

        注意：此方法是区域设置敏感的，如果用于单独解释区域设置的字符串，可能会产生意外的结果。 示例是编程语言标识符，协议密钥和HTML标签。 例如， "title".toUpperCase()在土耳其语言环境返回"T\u0130TLE" ，其中“\ u0130”是拉丁文大写字母我带点上述特征。 要获取区域设置不敏感字符串的正确结果，请使用toUpperCase(Locale.ROOT) 。

        结果
        String ，转换成大写字母。
        另请参见：
        toUpperCase(Locale)

      • trim

        public String trim​()
        返回一个字符串，其值为此字符串，并删除任何前导和尾随空格。

        如果此String对象表示一个空字符序列，或由该代表字符序列的第一个和最后一个字符String对象都具有代码大于'\u0020' （空格字符），则此参考String被返回对象。

        否则，如果字符串中没有字符大于'\u0020'的字符，则返回表示空字符串的String对象。

        否则，令k为代码大于'\u0020'的字符串中第一个字符的索引，并且m为代码大于'\u0020'的字符串中最后一个字符的索引。 将返回一个String对象，表示此字符串的子字符串，以索引k处的字符开始，以索引m this.substring(k, m + 1)的字符结束，结果为this.substring(k, m + 1) 。

        此方法可用于从字符串的开始和结尾修剪空格（如上定义）。

        结果
        一个字符串，其值是此字符串，除去任何前导和尾随空格，或者如果该字符串没有前导或尾随的空格，则为该字符串。

      • toString

        public String toString​()
        此对象（已经是字符串！）本身已被返回。
        Specified by:
        toString在接口 CharSequence
        重写：
        toString在类 Object
        结果
        字符串本身。

      • chars

        public IntStream chars​()
        返回一个int的数据流，从这个序列中扩展char值。 映射到surrogate code point的任何字符通过未解释的方式传递。
        Specified by:
        chars在接口 CharSequence
        结果
        这个序列中的char值的IntStream

      • codePoints

        public IntStream codePoints​()
        从此序列返回码流值。 在序列中遇到的任何代理对被组合，如同通过Character.toCodePoint一样 ，并将结果传递给流。 任何其他代码单元，包括普通的BMP字符，未配对的代理和未定义的代码单元，都被零扩展到int值，然后传递给流。
        Specified by:
        codePoints在接口 CharSequence
        结果
        Unicode序列的IntStream从这个序列中指向

      • toCharArray

        public char[] toCharArray​()
        将此字符串转换为新的字符数组。
        结果
        一个新分配的字符数组，其长度是该字符串的长度，其内容被初始化为包含由该字符串表示的字符序列。

      • format

        public static String format​(String format,
                            Object... args)
        使用指定的格式字符串和参数返回格式化的字符串。

        始终使用的地区是由Locale.getDefault(Locale.Category)返回的， 其中指定了FORMAT类别。

        参数
        format - A format string
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        格式化的字符串
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分。
        从以下版本开始：
        1.5
        另请参见：
        Formatter

      • format

        public static String format​(Locale l,
                            String format,
                            Object... args)
        使用指定的区域设置，格式字符串和参数返回格式化的字符串。
        参数
        l - 格式化期间应用的locale 。 如果l是null则不应用本地化。
        format - A format string
        args - 格式字符串中格式说明符引用的参数。 如果比格式说明符更多的参数，额外的参数将被忽略。 参数的数量是可变的，可能为零。 参数的最大数量受限于由The Java™ Virtual Machine Specification定义的Java数组的最大维度。 一个null参数的行为取决于conversion 。
        结果
        格式化的字符串
        异常
        IllegalFormatException - 如果格式字符串包含非法语法，则与给定参数不兼容的格式说明符，给定格式字符串的参数不足或其他非法条件。 有关所有可能的格式化错误的规范，请参阅格式化程序类规范的Details部分
        从以下版本开始：
        1.5
        另请参见：
        Formatter

      • valueOf

        public static String valueOf​(Object obj)
        返回 Object参数的字符串表示形式。
        参数
        obj - 一个 Object 。
        结果
        如果参数是null ，那么一个字符串等于"null" ; 否则返回值为obj.toString() 。
        另请参见：
        Object.toString()

      • valueOf

        public static String valueOf​(char[] data)
        返回char数组参数的字符串表示形式。 字符数组的内容被复制; 字符数组的后续修改不会影响返回的字符串。
        参数
        data - 字符数组。
        结果
        一个包含字符数组的字符的 String 。

      • valueOf

        public static String valueOf​(char[] data,
                             int offset,
                             int count)
        返回char数组参数的特定子阵列的字符串表示形式。

        offset参数是子阵列的第一个字符的索引。 count参数指定子count的长度。 副本的内容被复制; 字符数组的后续修改不会影响返回的字符串。

        参数
        data - 字符数组。
        offset - 子阵列的初始偏移量。
        count - 子阵列的长度。
        结果
        一个 String ，其中包含字符数组的指定子阵列的字符。
        异常
        IndexOutOfBoundsException - 如果 offset为负数，或 count为负数，或 offset+count大于 data.length 。

      • copyValueOf

        public static String copyValueOf​(char[] data,
                                 int offset,
                                 int count)
        相当于 valueOf(char[], int, int) 。
        参数
        data - 字符数组。
        offset - 子阵列的初始偏移量。
        count - 子阵列的长度。
        结果
        一个 String ，其中包含字符数组的指定子阵列的字符。
        异常
        IndexOutOfBoundsException - 如果 offset为负数，或 count为负数，或 offset+count大于 data.length 。

      • copyValueOf

        public static String copyValueOf​(char[] data)
        相当于 valueOf(char[]) 。
        参数
        data - 字符数组。
        结果
        一个包含字符数组的字符的 String 。

      • valueOf

        public static String valueOf​(boolean b)
        返回 boolean参数的字符串表示形式。
        参数
        b - a boolean 。
        结果
        如果参数为true ，则返回等于"true"的字符串; 否则返回等于"false"的字符串。

      • valueOf

        public static String valueOf​(char c)
        返回 char参数的字符串表示形式。
        参数
        c - a char 。
        结果
        长度为 1的字符串包含其单个字符的参数 c 。

      • valueOf

        public static String valueOf​(int i)
        返回int参数的字符串表示形式。

        该表示恰好是一个参数的Integer.toString方法返回的表示。

        参数
        i - a int 。
        结果
        一个字符串表示的 int参数。
        另请参见：
        Integer.toString(int, int)

      • valueOf

        public static String valueOf​(long l)
        返回long参数的字符串表示形式。

        该表示恰好是一个参数的Long.toString方法返回的表示。

        参数
        l - a long 。
        结果
        一个字符串表示的 long参数。
        另请参见：
        Long.toString(long)

      • valueOf

        public static String valueOf​(float f)
        返回float参数的字符串表示形式。

        该表示恰好是一个参数的Float.toString方法返回的表示。

        参数
        f - a float 。
        结果
        一个字符串表示的 float参数。
        另请参见：
        Float.toString(float)

      • valueOf

        public static String valueOf​(double d)
        返回double参数的字符串表示形式。

        该表示恰好是一个参数的Double.toString方法返回的表示。

        参数
        d - a double 。
        结果
        一个字符串表示的 double参数。
        另请参见：
        Double.toString(double)

      • intern

        public String intern​()
        返回字符串对象的规范表示。

        最初是空的字符串池，由类别String私下维护。

        当调用intern方法时，如果池已经包含与equals(Object)方法确定的等于String对象的字符串，则返回来自池的字符串。 否则，此String对象将添加到池中，并返回对此String对象的引用。

        由此可见，对于任何两个字符串s和t ， s.intern() == t.intern()为true当且仅当s.equals(t)为true 。

        所有文字字符串和字符串值常量表达式都被实体化。 字符串文字在The Java™ Language Specification的 3.10.5节中定义。

        结果
        一个字符串与该字符串具有相同的内容，但保证来自一个唯一的字符串池。
        See The Java™ Language Specification:
        3.10.5字符串字面量
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class StringBuffer

  • java.lang.Object
    • java.lang.StringBuffer
  • All Implemented Interfaces:
    Serializable ， Appendable ， CharSequence

    public final class StringBuffer
extends Object
implements Serializable, CharSequence
    线程安全，可变的字符序列。 字符串缓冲区就像一个String ，但可以修改。 在任何时间点，它包含一些特定的字符序列，但可以通过某些方法调用来更改序列的长度和内容。

    字符串缓冲区可以安全地被多个线程使用。 这些方法在必要时进行同步，以便任何特定实例上的所有操作都按照与所涉及的各个线程所执行的方法调用顺序一致的顺序发生。

    一个StringBuffer的主要操作是append和insert方法，它们是重载的，以便接受任何类型的数据。 每个都有效地将给定的数据转换为字符串，然后将该字符串的字符附加或插入到字符串缓冲区。 append方法总是在缓冲区的末尾添加这些字符; insert方法将字符添加到指定点。

    例如，如果z引用当前内容为"start"的字符串缓冲对象，则调用z.append("le")的方法将导致字符串缓冲区包含"startle" ，而z.insert(4, "le")会将字符串缓冲区更改为包含"starlet" 。

    一般情况下，如果某人是指的一个实例StringBuffer ，然后sb.append(x)具有相同的效果sb.insert(sb.length(), x) 。

    每当涉及源序列（例如从源序列追加或插入）的操作发生时，该类仅在执行操作的字符串缓冲器上进行同步，而不在源上。 请注意，虽然StringBuffer被设计为可以安全地从多个线程并发使用，但如果构造函数或append或insert操作通过跨线程共享的源序列，则调用代码必须确保该操作具有一致且不变的视图的源序列在操作的持续时间。 呼叫者通过使用不可变的源序列，或者不跨线程共享源序列，可以在呼叫期间持有锁来满足这一点。

    每个字符串缓冲区有一个容量。 只要字符串缓冲区中包含的字符序列的长度不超过容量，就不必分配新的内部缓冲区数组。 如果内部缓冲区溢出，则会自动变大。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    从版本JDK 5开始，这个类已经被一个等同的类补充了，它被设计为使用一个线程， StringBuilder 。 通常应该使用StringBuilder类，因为它支持所有相同的操作，但它更快，因为它不执行同步。

    从以下版本开始：
    1.0
    另请参见：
    StringBuilder ， String ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringBuffer​()
      构造一个没有字符的字符串缓冲区，初始容量为16个字符。
      StringBuffer​(int capacity)
      构造一个没有字符的字符串缓冲区和指定的初始容量。
      StringBuffer​(CharSequence seq)
      构造一个字符串缓冲区，其中包含与指定的 CharSequence相同的字符。
      StringBuffer​(String str)
      构造一个初始化为指定字符串内容的字符串缓冲区。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringBuffer append​(boolean b)
      将 boolean参数的字符串表示追加到序列中。
      StringBuffer append​(char c)
      将 char参数的字符串表示追加到此序列。
      StringBuffer append​(char[] str)
      将 char数组参数的字符串表示追加到此序列。
      StringBuffer append​(char[] str, int offset, int len)
      将 char数组参数的子阵列的字符串表示追加到此序列。
      StringBuffer append​(double d)
      将 double参数的字符串表示追加到此序列。
      StringBuffer append​(float f)
      将 float参数的字符串表示法附加到此序列。
      StringBuffer append​(int i)
      将 int参数的字符串表示法附加到此序列。
      StringBuffer append​(long lng)
      将 long参数的字符串表示法附加到此序列。
      StringBuffer append​(CharSequence s)
      追加指定的 CharSequence到这个序列。
      StringBuffer append​(CharSequence s, int start, int end)
      追加指定的序列 CharSequence序列。
      StringBuffer append​(Object obj)
      追加 Object参数的字符串表示形式。
      StringBuffer append​(String str)
      将指定的字符串附加到此字符序列。
      StringBuffer append​(StringBuffer sb)
      追加指定的 StringBuffer到这个序列。
      StringBuffer appendCodePoint​(int codePoint)
      将 codePoint参数的字符串表示追加到此序列。
      int capacity​()
      返回当前容量。
      char charAt​(int index)
      返回指定索引处的此序列中的 char值。
      IntStream chars​()
      返回一个 int的数据流， int零序扩展 char值。
      int codePointAt​(int index)
      返回指定索引处的字符（Unicode代码点）。
      int codePointBefore​(int index)
      返回指定索引之前的字符（Unicode代码点）。
      int codePointCount​(int beginIndex, int endIndex)
      返回此序列指定文本范围内的Unicode代码点数。
      IntStream codePoints​()
      从此序列返回码流值。
      StringBuffer delete​(int start, int end)
      删除此序列的子字符串中的字符。
      StringBuffer deleteCharAt​(int index)
      按照该顺序删除指定位置的 char 。
      void ensureCapacity​(int minimumCapacity)
      确保容量至少等于规定的最小值。
      void getChars​(int srcBegin, int srcEnd, char[] dst, int dstBegin)
      字符从此序列复制到目标字符数组 dst 。
      int indexOf​(String str)
      返回指定子字符串第一次出现的字符串内的索引。
      int indexOf​(String str, int fromIndex)
      返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。
      StringBuffer insert​(int offset, boolean b)
      将 boolean参数的字符串表示插入到此序列中。
      StringBuffer insert​(int offset, char c)
      将 char参数的字符串表示插入到此序列中。
      StringBuffer insert​(int offset, char[] str)
      在此序列中插入 char数组参数的字符串表示形式。
      StringBuffer insert​(int index, char[] str, int offset, int len)
      将 str数组参数的子阵列的字符串表示插入到此序列中。
      StringBuffer insert​(int offset, double d)
      将 double参数的字符串表示插入到此序列中。
      StringBuffer insert​(int offset, float f)
      将 float参数的字符串表示插入到此序列中。
      StringBuffer insert​(int offset, int i)
      将第二个 int参数的字符串表示插入到此序列中。
      StringBuffer insert​(int offset, long l)
      将 long参数的字符串表示插入到此序列中。
      StringBuffer insert​(int dstOffset, CharSequence s)
      在此序列中插入指定的 CharSequence 。
      StringBuffer insert​(int dstOffset, CharSequence s, int start, int end)
      在此序列中插入指定的 CharSequence序列。
      StringBuffer insert​(int offset, Object obj)
      将 Object参数的字符串表示插入到此字符序列中。
      StringBuffer insert​(int offset, String str)
      将字符串插入到此字符序列中。
      int lastIndexOf​(String str)
      返回指定子字符串最后一次出现的字符串中的索引。
      int lastIndexOf​(String str, int fromIndex)
      返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。
      int length​()
      返回长度（字符数）。
      int offsetByCodePoints​(int index, int codePointOffset)
      返回该序列中与 index codePointOffset码点的索引。
      StringBuffer replace​(int start, int end, String str)
      将此序列的子字符串中的字符替换为指定的 String字符。
      StringBuffer reverse​()
      导致该字符序列被序列的相反代替。
      void setCharAt​(int index, char ch)
      指定索引处的字符设置为 ch 。
      void setLength​(int newLength)
      设置字符序列的长度。
      CharSequence subSequence​(int start, int end)
      返回一个新的字符序列，该序列是该序列的子序列。
      String substring​(int start)
      返回一个新的 String ，其中包含此字符序列中当前包含的字符的子序列。
      String substring​(int start, int end)
      返回一个新的 String ，其中包含此序列中当前包含的字符的子序列。
      String toString​()
      返回表示此顺序中的数据的字符串。
      void trimToSize​()
      尝试减少用于字符序列的存储。

      • Methods inherited from interface java.lang.CharSequence

        chars, codePoints

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StringBuffer

        public StringBuffer​()
        构造一个没有字符的字符串缓冲区，初始容量为16个字符。

      • StringBuffer

        public StringBuffer​(int capacity)
        构造一个没有字符的字符串缓冲区和指定的初始容量。
        参数
        capacity - 初始容量。
        异常
        NegativeArraySizeException - 如果 capacity参数小于 0 。

      • StringBuffer

        public StringBuffer​(String str)
        构造一个初始化为指定字符串内容的字符串缓冲区。 字符串缓冲区的初始容量为16加上字符串参数的长度。
        参数
        str - 缓冲区的初始内容。

      • StringBuffer

        public StringBuffer​(CharSequence seq)
        构造一个包含与指定的相同字符的字符串缓冲区CharSequence 。 字符串缓冲区的初始容量为16加上CharSequence参数的长度。

        如果指定的CharSequence的长度小于或等于零，则返回容量为16的空缓冲区。

        参数
        seq - 要复制的顺序。
        从以下版本开始：
        1.5

    • 方法详细信息

      • length

        public int length​()
        返回长度（字符数）。
        Specified by:
        length在接口 CharSequence
        结果
        当前由此对象表示的字符序列的长度

      • capacity

        public int capacity​()
        返回当前容量。 容量是新插入字符可用的存储量，超过此值将进行分配。
        结果
        当前的容量

      • ensureCapacity

        public void ensureCapacity​(int minimumCapacity)
        确保容量至少等于规定的最小值。 如果当前容量小于参数，则会分配一个新的内部数组，容量更大。 新产能较大：
        • minimumCapacity论证。
        • 两倍的旧容量，加上2 。
        如果minimumCapacity参数为非正态，则此方法不执行任何操作，只需返回。 请注意，此对象的后续操作可以将实际容量降低到低于此处所请求的容量。
        参数
        minimumCapacity - 最低所需容量。

      • trimToSize

        public void trimToSize​()
        尝试减少用于字符序列的存储。 如果缓冲区大于保持其当前字符序列所需的缓冲区，则可以将其调整大小以变得更加空间有效。 调用此方法可能但不是要求影响后续调用capacity()方法返回的值。
        从以下版本开始：
        1.5

      • setLength

        public void setLength​(int newLength)
        设置字符序列的长度。 该序列被更改为一个新的字符序列，其长度由参数指定。 对于小于每非负索引k newLength ，在新的字符序列的索引k处的字符是相同的在旧序列索引k如果k小于原字符序列的长度的字符; 否则为空字符'\u0000' 。 换句话说，如果newLength参数小于当前长度，则长度将更改为指定的长度。

        如果newLength参数大于或等于当前长度，则会附加足够的空字符（ '\u0000' ），以使长度成为newLength参数。

        newLength参数必须大于或等于0 。

        参数
        newLength - 新的长度
        异常
        IndexOutOfBoundsException - 如果 newLength参数为负数。
        另请参见：
        length()

      • charAt

        public char charAt​(int index)
        返回指定索引处的此序列中的char值。 第一个char值是索引0 ，下一个索引为1 ，依此类推，就像在数组索引中一样。

        索引参数必须大于或等于0 ，并小于此序列的长度。

        如果由索引指定的char值为surrogate ，则返回替代值。

        Specified by:
        charAt在接口 CharSequence
        参数
        index - index的指数 char 。
        结果
        指定的指数为 char 。
        异常
        IndexOutOfBoundsException - 如果 index为负数或大于或等于 length() 。
        另请参见：
        length()

      • codePointAt

        public int codePointAt​(int index)
        返回指定索引处的字符（Unicode代码点）。 该索引指的是char值（Unicode码单位），范围从0到length() - 1 。

        如果在给定索引处指定的char值处于高代理范围内，则以下索引小于该序列的长度，并且下列索引处的char值处于低代理范围内，则补码代码点相应的这个代理对被退回。 否则返回给定索引处的char值。

        参数
        index - 指数为 char值
        结果
        字符的代码点值在 index
        异常
        IndexOutOfBoundsException - 如果 index参数为负数或不小于此序列的长度。
        从以下版本开始：
        1.5

      • codePointBefore

        public int codePointBefore​(int index)
        返回指定索引之前的字符（Unicode代码点）。 索引指的是char值（Unicode代码单位），范围从1到length() 。

        如果char在值(index - 1)处于低代理项范围， (index - 2)不为负，并且char在值(index - 2)处于高代理项范围，则返回代理对的补充代码点值。 如果char在值index - 1是未配对的低代理或一个高代理，则返回所述替代值。

        参数
        index - 应该返回的代码点后面的索引
        结果
        Unicode代码点值在给定索引之前。
        异常
        IndexOutOfBoundsException - 如果 index参数小于1或大于此序列的长度。
        从以下版本开始：
        1.5

      • codePointCount

        public int codePointCount​(int beginIndex,
                          int endIndex)
        返回此序列指定文本范围内的Unicode代码点数。 文本范围始于指定beginIndex并延伸到char在索引endIndex - 1 。 因此，文本范围的长度（ char s）为endIndex-beginIndex 。 该序列中的未配对代理计数为每个代码点。
        参数
        beginIndex - 索引到第一个 char的文本范围。
        endIndex - 指数最后一个 char之后的文字范围。
        结果
        指定文本范围内的Unicode代码点数
        异常
        IndexOutOfBoundsException - 如果 beginIndex为负数，或 endIndex大于此序列的长度，或 beginIndex大于 endIndex 。
        从以下版本开始：
        1.5

      • offsetByCodePoints

        public int offsetByCodePoints​(int index,
                              int codePointOffset)
        返回此序列中的索引，该索引与给定的index codePointOffset代码点。 由index和codePointOffset给出的文本范围内的非配对替代品每个作为一个代码点。
        参数
        index - 要偏移的索引
        codePointOffset - 代码点的偏移量
        结果
        该序列中的索引
        异常
        IndexOutOfBoundsException - 如果 index为负或大于该序列的长度，或者如果 codePointOffset为正，并且从 index开始的子 index具有少于 codePointOffset码点，或者如果 codePointOffset为负，并且 index之前的子 index小于绝对值 codePointOffset代码点。
        从以下版本开始：
        1.5

      • getChars

        public void getChars​(int srcBegin,
                     int srcEnd,
                     char[] dst,
                     int dstBegin)
        字符从该序列复制到目标字符阵列dst 。 要复制的第一个字符是索引srcBegin ; 要复制的最后一个字符在索引srcEnd-1 。 要复制的字符总数为srcEnd-srcBegin 。 字符被复制到dst的子阵列，从索引dstBegin开始，并以索引结尾：
           dstbegin + (srcEnd-srcBegin) - 1
        参数
        srcBegin - 在这个偏移开始复制。
        srcEnd - 在此偏移处停止复制。
        dst - 将数据复制到的数组。
        dstBegin - 偏移到 dst 。
        异常
        IndexOutOfBoundsException - 如果满足以下条件：
        • srcBegin是否定的
        • dstBegin为负数
        • srcBegin参数大于srcEnd参数。
        • srcEnd大于this.length() 。
        • dstBegin+srcEnd-srcBegin大于dst.length

      • setCharAt

        public void setCharAt​(int index,
                      char ch)
        指定索引处的字符设置为ch 。 该序列被改变以表示一个新的字符序列，其是相同的原字符序列，不同之处在于它包含字符ch在位置index 。

        索引参数必须大于或等于0 ，并且小于此序列的长度。

        参数
        index - 要修改的字符的索引。
        ch - 新角色。
        异常
        IndexOutOfBoundsException - 如果 index为负数或大于或等于 length() 。
        另请参见：
        length()

      • append

        public StringBuffer append​(Object obj)
        追加Object参数的字符串表示形式。

        整体效果就好像通过方法String.valueOf(Object)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        obj - 一个 Object 。
        结果
        对这个对象的引用。

      • append

        public StringBuffer append​(String str)
        将指定的字符串附加到此字符序列。

        附加String参数的字符，以便String参数的长度增加此序列的长度。 如果str为null ，则附加四个字符"null" 。

        在执行append方法之前，让n为该字符序列的长度。 那么如果k小于n ，则新字符序列中索引k处的字符等于旧字符序列中索引k处的字符; 否则，它等于参数str中的索引kn处的字符。

        参数
        str - 一个字符串。
        结果
        对这个对象的引用。

      • append

        public StringBuffer append​(StringBuffer sb)
        追加指定的StringBuffer到这个序列。

        StringBuffer参数的字符按顺序追加到StringBuffer的内容，将该StringBuffer的长度增加StringBuffer的长度。 如果sb是null ，那么四个字符"null"附加到这个StringBuffer 。

        令n为旧字符序列的长度，即StringBuffer之前的append方法中的一个。 那么如果k小于n ，则新字符序列中索引k处的字符等于旧字符序列中索引k处的字符; 否则，它等于参数sb中的索引kn处的字符。

        此方法可同步this目标对象，但不会在源上同步（ sb ）。

        参数
        sb - 附加的 StringBuffer 。
        结果
        对这个对象的引用。
        从以下版本开始：
        1.4

      • append

        public StringBuffer append​(CharSequence s)
        追加指定的CharSequence到这个序列。

        附加CharSequence参数的字符，以便CharSequence参数的长度增加此序列的长度。

        该方法的结果与调用this.append（s，0，s.length（））完全相同;

        此方法可同步this目标对象，但不会在源上同步（ s ）。

        如果s为null ，则附加四个字符"null" 。

        Specified by:
        append在接口 Appendable
        参数
        s - 要追加的 CharSequence 。
        结果
        对这个对象的引用。
        从以下版本开始：
        1.5

      • append

        public StringBuffer append​(CharSequence s,
                           int start,
                           int end)
        追加指定的序列CharSequence序列。

        从索引start开始的参数s字符顺序附加到该序列的内容直到（排他）索引end 。 该序列的长度增加值为end - start 。

        在执行append方法之前，让n为该字符序列的长度。 那么如果k小于n ，则该字符序列中的索引k处的字符变得等于该序列中索引k处的字符; 否则，它等于参数s中索引k + start-n处的s 。

        如果s为null ，则该方法会附加字符，就像s参数是包含四个字符"null"的序列"null" 。

        Specified by:
        append在接口 Appendable
        参数
        s - 要追加的顺序。
        start - 要附加的子序列的起始索引。
        end - 要附加的子序列的结束索引。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果 start为负数，或 start大于 end或 end大于 s.length()
        从以下版本开始：
        1.5

      • append

        public StringBuffer append​(char[] str)
        将char数组参数的字符串表示追加到此序列。

        数组参数的字符按顺序附加到此序列的内容。 该序列的长度增加参数的长度。

        整体效果就好像通过方法String.valueOf(char[])将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        str - 要附加的字符。
        结果
        对这个对象的引用。

      • append

        public StringBuffer append​(char[] str,
                           int offset,
                           int len)
        将char数组参数的子阵列的字符串表示追加到此序列。

        从索引offset开始的char阵列str字符按顺序附加到该序列的内容。 该序列的长度增加值为len 。

        总体效果就好像通过方法String.valueOf(char[],int,int)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        str - 要附加的字符。
        offset -第一的指数 char追加。
        len - 要追加的 char的数量。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果是 offset < 0或 len < 0或 offset+len > str.length

      • append

        public StringBuffer append​(boolean b)
        将boolean参数的字符串表示附加到序列中。

        整体效果就好像通过方法String.valueOf(boolean)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        b - a boolean 。
        结果
        对这个对象的引用。

      • append

        public StringBuffer append​(char c)
        将char参数的字符串表示追加到此序列。

        该参数附加到此序列的内容。 该序列的长度增加1 。

        整体效果就好像通过方法String.valueOf(char)将参数转换为字符串，并且该字符串中的字符然后是该字符序列的appended 。

        Specified by:
        append在接口 Appendable
        参数
        c - a char 。
        结果
        对这个对象的引用。

      • append

        public StringBuffer append​(int i)
        将int参数的字符串表示法附加到此序列。

        整体效果就好像通过方法String.valueOf(int)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        i - a int 。
        结果
        对这个对象的引用。

      • appendCodePoint

        public StringBuffer appendCodePoint​(int codePoint)
        将codePoint参数的字符串表示法附加到此序列。

        该参数附加到此序列的内容。 该序列的长度增加Character.charCount(codePoint) 。

        整体效果就好像通过方法Character.toChars(int)将参数转换为char数组，并且该数组中的字符然后是该字符序列的appended 。

        参数
        codePoint - 一个Unicode代码点
        结果
        对这个对象的引用。
        从以下版本开始：
        1.5

      • append

        public StringBuffer append​(long lng)
        将long参数的字符串表示追加到此序列。

        整体效果就好像通过方法String.valueOf(long)将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        lng - a long 。
        结果
        对这个对象的引用。

      • append

        public StringBuffer append​(float f)
        将float参数的字符串表示附加到此序列。

        整体效果就好像通过方法String.valueOf(float)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        f - a float 。
        结果
        对这个对象的引用。

      • append

        public StringBuffer append​(double d)
        将double参数的字符串表示法附加到此序列。

        整体效果就好像通过方法String.valueOf(double)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        d - a double 。
        结果
        对这个对象的引用。

      • delete

        public StringBuffer delete​(int start,
                           int end)
        删除此序列的子字符串中的字符。 子串从指定的start开始，并且扩展到索引号为end - 1的字符，如果不存在这样的字符，则扩展到序列的末尾。 如果start等于end ，则不作任何更改。
        参数
        start - 开始索引，包括。
        end - 结束索引，独家。
        结果
        这个对象。
        异常
        StringIndexOutOfBoundsException - 如果 start为负数，大于 length() ，或大于 end 。
        从以下版本开始：
        1.2

      • deleteCharAt

        public StringBuffer deleteCharAt​(int index)
        按照该顺序删除指定位置的char 。 该序列缩短了一个char 。

        注意：如果给定索引处的字符是补充字符，则此方法不会删除整个字符。 如果需要的准确处理增补字符，确定数量char通过调用删除Character.charCount(thisSequence.codePointAt(index)) ，其中thisSequence是此序列。

        参数
        index - 索引 char删除
        结果
        这个对象。
        异常
        StringIndexOutOfBoundsException - 如果 index为负数或大于或等于 length() 。
        从以下版本开始：
        1.2

      • replace

        public StringBuffer replace​(int start,
                            int end,
                            String str)
        将此序列的子字符串中的字符替换为指定的String字符。 子start始于指定的start并扩展到索引号为end - 1的字符，如果不存在这样的字符，则扩展到序列的末尾。 首先删除子串中的字符，然后在String插入指定的start 。 （如果需要，此序列将被延长以容纳指定的字符串。）
        参数
        start - 开始索引，包括。
        end - 结束索引，独家。
        str - 将替换以前内容的字符串。
        结果
        这个对象。
        异常
        StringIndexOutOfBoundsException - 如果 start为负，大于 length()或大于 end 。
        从以下版本开始：
        1.2

      • substring

        public String substring​(int start)
        返回一个新的String ，其中包含此字符序列中当前包含的字符的子序列。 子串从指定的索引开始，并延伸到该序列的末尾。
        参数
        start - 开始索引，包括。
        结果
        新的字符串。
        异常
        StringIndexOutOfBoundsException - 如果 start小于零或大于此对象的长度。
        从以下版本开始：
        1.2

      • subSequence

        public CharSequence subSequence​(int start,
                                int end)
        返回一个新的字符序列，该序列是该序列的子序列。

        调用此方法的形式

           sb.subSequence(begin,&nbsp;end)
        行为与调用完全相同
           sb.substring(begin,&nbsp;end)
        提供这种方法，使该类可以实现CharSequence接口。
        Specified by:
        subSequence在接口 CharSequence
        参数
        start - 起始索引（含）。
        end - 结束索引，排他。
        结果
        指定的子序列。
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，如果 end大于 length() ，或者如果 start大于 end
        从以下版本开始：
        1.4

      • substring

        public String substring​(int start,
                        int end)
        返回一个新的String ，其中包含此序列中当前包含的字符的子序列。 子串从指定的start开始，并扩展到索引号为end - 1的字符。
        参数
        start - 开始索引，包括。
        end - 结束索引，独家。
        结果
        新的字符串。
        异常
        StringIndexOutOfBoundsException - 如果 start或 end为负数或大于 length() ，或 start大于 end 。
        从以下版本开始：
        1.2

      • insert

        public StringBuffer insert​(int index,
                           char[] str,
                           int offset,
                           int len)
        将str数组参数的子阵列的字符串表示插入到此序列中。 子阵列从指定的offset开始，并扩展len char s。 子阵列的字符在index所示的位置被插入到该序列中。 该序列的长度增加len char s。
        参数
        index - 插入子阵列的位置。
        str - A char数组。
        offset - 要插入的子阵列中的第一个 char的索引。
        len - 要插入的子阵列中的 char的数量。
        结果
        这个对象
        异常
        StringIndexOutOfBoundsException - 如果 index为负数或大于 length() ，或 offset或 len为负数，或 (offset+len)大于 str.length 。
        从以下版本开始：
        1.2

      • insert

        public StringBuffer insert​(int offset,
                           Object obj)
        将Object参数的字符串表示插入到此字符序列中。

        整体效果就好像第二个参数通过方法String.valueOf(Object)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于该序列的length 。

        参数
        offset - 偏移。
        obj - a Object 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuffer insert​(int offset,
                           String str)
        将字符串插入到此字符序列中。

        String参数的字符按顺序插入到指定偏移量的该序列中，向上移动原始位于该位置的任何字符，并将该序列的长度增加到参数的长度。 如果str为null ，则四个字符"null"插入到该序列中。

        新字符序列中索引k处的字符等于：

        • 旧字符序列中索引k处的字符，如果k小于offset
        • 参数str中索引k -offset处的字符，如果k不小于offset但小于offset+str.length()
        • 在旧字符序列中的索引k -str.length()处的字符，如果k不小于offset+str.length()

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移。
        str - 一个字符串。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移无效。

      • insert

        public StringBuffer insert​(int offset,
                           char[] str)
        在此序列中插入char数组参数的字符串表示形式。

        数组参数的字符在offset所示的位置被插入到该序列的内容中。 该序列的长度增加参数的长度。

        整体效果就好像第二个参数通过方法String.valueOf(char[])转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移量。
        str - 一个字符数组。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuffer insert​(int dstOffset,
                           CharSequence s)
        在此序列中插入指定的CharSequence 。

        CharSequence参数的字符CharSequence插入到指定偏移量的该序列中，向上移动原始位于该位置的任何字符，并将该序列的长度增加到参数s的长度。

        该方法的结果与调用该对象的insert （dstOffset，s，0，s.length（））方法完全相同 。

        如果s为null ，则四个字符"null"插入到该序列中。

        参数
        dstOffset - 偏移量。
        s - 要插入的序列
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果偏移量无效。
        从以下版本开始：
        1.5

      • insert

        public StringBuffer insert​(int dstOffset,
                           CharSequence s,
                           int start,
                           int end)
        在此序列中插入指定的CharSequence序列。

        参数的子序列s通过指定start和end被插入，以便成在指定的目的地偏移该序列中，该位置上述最初向上运动的任何字符。 该序列的长度增加end - start 。

        该序列中索引k处的字符等于：

        • 如果k小于dstOffset ，则该序列中索引k处的字符
        • 在索引k处的字符+start-dstOffset在参数s ，如果k大于或等于dstOffset但小于dstOffset+end-start
        • 在该序列中的索引k -(end-start)处的字符，如果k大于或等于dstOffset+end-start

        dstOffset参数必须大于或等于0 ，小于或等于此序列的length 。

        起始参数必须是非负数，不得大于end 。

        结束参数必须大于或等于start ，小于或等于s的长度。

        如果s为null ，则该方法插入字符，就像s参数是包含四个字符"null"的序列"null" 。

        参数
        dstOffset - 此序列中的偏移量。
        s - 要插入的序列。
        start - 要插入的子序列的起始索引。
        end - 要插入的子序列的结束索引。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果 dstOffset为负数或大于 this.length() ，或 start或 end为负数，或 start为大于 end或 end大于 s.length()
        从以下版本开始：
        1.5

      • insert

        public StringBuffer insert​(int offset,
                           boolean b)
        将boolean参数的字符串表示插入到此序列中。

        总体效果就好像第二个参数通过方法String.valueOf(boolean)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移量。
        b - a boolean 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移无效。

      • insert

        public StringBuffer insert​(int offset,
                           char c)
        将char参数的字符串表示插入到此序列中。

        总体效果就好像第二个参数通过方法String.valueOf(char)转换为一个字符串，并且该字符串中的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于该序列的length 。

        参数
        offset - 偏移。
        c - a char 。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuffer insert​(int offset,
                           int i)
        将第二个int参数的字符串表示插入到此序列中。

        整体效果就好像第二个参数通过方法String.valueOf(int)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于该序列的length 。

        参数
        offset - 偏移。
        i - a int 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuffer insert​(int offset,
                           long l)
        将long参数的字符串表示插入到此序列中。

        总体效果就好像第二个参数通过方法String.valueOf(long)转换为一个字符串，然后该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于该序列的length 。

        参数
        offset - 偏移。
        l - a long 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuffer insert​(int offset,
                           float f)
        将float参数的字符串表示插入到此序列中。

        整体效果就好像第二个参数通过方法String.valueOf(float)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，并且小于或等于此序列的length 。

        参数
        offset - 偏移。
        f - a float 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuffer insert​(int offset,
                           double d)
        将double参数的字符串表示插入到此序列中。

        整体效果就好像第二个参数通过方法String.valueOf(double)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于该序列的length 。

        参数
        offset - 偏移量。
        d - a double 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移无效。

      • indexOf

        public int indexOf​(String str)
        返回指定子字符串第一次出现的字符串内的索引。

        返回的索引是最小值k ，其中：

           this.toString().startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        结果
        指定子字符串的首次出现的索引，如果没有这种情况， -1 。
        从以下版本开始：
        1.4

      • indexOf

        public int indexOf​(String str,
                   int fromIndex)
        返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。

        返回的索引是最小值k ，其中：

           k >= Math.min(fromIndex, this.length()) && this.toString().startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        fromIndex - 从 fromIndex开始搜索的索引。
        结果
        指定子串的第一次出现的索引，从指定的索引开始，如果没有此类事件， -1 。
        从以下版本开始：
        1.4

      • lastIndexOf

        public int lastIndexOf​(String str)
        返回指定子字符串最后一次出现的字符串中的索引。 空字符串“”的最后一次出现被认为发生在索引值this.length() 。

        返回的指数是k ，其中：

           this.toString().startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        结果
        指定子字符串的最后一次出现的索引，如果没有发生这种情况， -1 。
        从以下版本开始：
        1.4

      • lastIndexOf

        public int lastIndexOf​(String str,
                       int fromIndex)
        返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。

        返回的索引是k ：

           k <= Math.min(fromIndex, this.length()) && this.toString().startsWith(str, k)
        如果没有这样的价值k存在，那么-1返回。
        参数
        str - 要搜索的子字符串。
        fromIndex - 开始搜索的索引。
        结果
        指定子字符串的最后一次出现的索引，从指定的索引向后搜索，如果没有此类事件， -1 。
        从以下版本开始：
        1.4

      • reverse

        public StringBuffer reverse​()
        导致该字符序列被序列的相反代替。 如果序列中包含任何替代对，则将它们视为单个字符进行反向操作。 因此，高低替代品的顺序从未被扭转过。 在执行reverse方法之前，让n为该字符序列的字符长度（不是char的长度）。 那么新字符序列中的索引k处的字符等于旧字符序列中的索引nk-1处的字符。

        请注意，相反的操作可能会导致在手术之前产生不配对的低代谢和高代谢的替代对。 例如，反转“\ uDC00 \ uD800”会生成“\ uD800 \ uDC00”，它是一个有效的代理对。

        结果
        对这个对象的引用。
        从以下版本开始：
        1.0.2

      • toString

        public String toString​()
        返回表示此顺序中的数据的字符串。 新的String对象被分配并初始化为包含当前由该对象表示的字符序列。 然后返回String 。 此序列的后续更改不影响String的内容。
        Specified by:
        toString在接口 CharSequence
        结果
        这个字符序列的字符串表示。

      • chars

        public IntStream chars​()
        返回一个int的数据流，从这个序列中扩展char值。 映射到surrogate code point的任何字符都是通过未解释的。

        当终端流操作开始时（特别地，对于可变序列，流的分流器是late-binding ），流与该序列绑定。 如果序列在该操作期间被修改，则结果是未定义的。

        Specified by:
        chars在接口 CharSequence
        结果
        这个序列中的char值的IntStream
        从以下版本开始：
        9

      • codePoints

        public IntStream codePoints​()
        从此序列返回码流值。 在序列中遇到的任何代理对被组合，如同通过Character.toCodePoint ，并将结果传递给流。 任何其他代码单元，包括普通的BMP字符，未配对代理和未定义的代码单元，都将零扩展到int值，然后传递给流。

        当终端流操作开始时（特别地，对于可变序列，流的分流器是late-binding ），流与该序列绑定。 如果序列在该操作期间被修改，则结果是未定义的。

        Specified by:
        codePoints在接口 CharSequence
        结果
        Unicode序列的IntStream从这个序列中指向
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class StringBuilder

  • java.lang.Object
    • java.lang.StringBuilder
  • All Implemented Interfaces:
    Serializable ， Appendable ， CharSequence

    public final class StringBuilder
extends Object
implements Serializable, CharSequence
    一个可变的字符序列。 该类提供了一个与StringBuffer兼容的API，但不能保证同步。 该类被设计为在字符串缓冲区被单个线程使用的地方（作为一般情况）用作StringBuffer替代替代。 在可能的情况下，建议使用这个类别优先于StringBuffer因为它在大多数实施中将更快。

    一个StringBuilder的主要操作是append和insert方法，它们是重载的，以便接受任何类型的数据。 每个都有效地将给定的数据转换为字符串，然后将该字符串的字符附加或插入字符串构建器。 append方法总是在构建器的末尾添加这些字符; insert方法将字符添加到指定点。

    例如，如果z引用当前内容为“ start ”的字符串构建器对象，那么方法调用z.append("le")将导致字符串构建器包含“ startle ”，而z.insert(4, "le")会将字符串构建器更改为包含“ starlet ”。

    一般情况下，如果某人是指的一个实例StringBuilder ，然后sb.append(x)具有相同的效果sb.insert(sb.length(), x) 。

    每个字符串构建器都具有容量。 只要字符串构建器中包含的字符序列的长度不超过容量，则不需要分配新的内部缓冲区。 如果内部缓冲区溢出，则会自动变大。

    StringBuilder实例不能安全使用多线程。 如果需要同步，那么建议使用StringBuffer 。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.5
    另请参见：
    StringBuffer ， String ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringBuilder​()
      构造一个没有字符的字符串构建器，初始容量为16个字符。
      StringBuilder​(int capacity)
      构造一个没有字符的字符串构建器，以及由 capacity参数指定的初始容量。
      StringBuilder​(CharSequence seq)
      构造一个字符串构建器，其中包含与指定的 CharSequence相同的字符。
      StringBuilder​(String str)
      构造一个初始化为指定字符串内容的字符串构建器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      StringBuilder append​(boolean b)
      将 boolean参数的字符串表示附加到序列中。
      StringBuilder append​(char c)
      将 char参数的字符串表示追加到此序列。
      StringBuilder append​(char[] str)
      将 char数组参数的字符串表示追加到此序列。
      StringBuilder append​(char[] str, int offset, int len)
      将 char数组参数的子阵列的字符串表示追加到此序列。
      StringBuilder append​(double d)
      将 double参数的字符串表示法附加到此序列。
      StringBuilder append​(float f)
      将 float参数的字符串表示法附加到此序列。
      StringBuilder append​(int i)
      将 int参数的字符串表示法附加到此序列。
      StringBuilder append​(long lng)
      将 long参数的字符串表示追加到此序列。
      StringBuilder append​(CharSequence s)
      将指定的字符序列追加到此 Appendable 。
      StringBuilder append​(CharSequence s, int start, int end)
      追加指定的序列 CharSequence序列。
      StringBuilder append​(Object obj)
      追加 Object参数的字符串表示形式。
      StringBuilder append​(String str)
      将指定的字符串附加到此字符序列。
      StringBuilder append​(StringBuffer sb)
      追加指定的 StringBuffer到这个序列。
      StringBuilder appendCodePoint​(int codePoint)
      将 codePoint参数的字符串表示法附加到此序列。
      int capacity​()
      返回当前容量。
      char charAt​(int index)
      返回指定索引处的此序列中的 char值。
      IntStream chars​()
      返回一个 int的数据流，从这个序列中扩展 char值。
      int codePointAt​(int index)
      返回指定索引处的字符（Unicode代码点）。
      int codePointBefore​(int index)
      返回指定索引之前的字符（Unicode代码点）。
      int codePointCount​(int beginIndex, int endIndex)
      返回此序列指定文本范围内的Unicode代码点数。
      IntStream codePoints​()
      从此序列返回码流值。
      StringBuilder delete​(int start, int end)
      删除此序列的子字符串中的字符。
      StringBuilder deleteCharAt​(int index)
      在此序列中的指定位置移除 char 。
      void ensureCapacity​(int minimumCapacity)
      确保容量至少等于规定的最小值。
      void getChars​(int srcBegin, int srcEnd, char[] dst, int dstBegin)
      字符从该序列复制到目标字符数组 dst 。
      int indexOf​(String str)
      返回指定子字符串第一次出现的字符串内的索引。
      int indexOf​(String str, int fromIndex)
      返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。
      StringBuilder insert​(int offset, boolean b)
      将 boolean参数的字符串表示插入到此序列中。
      StringBuilder insert​(int offset, char c)
      将 char参数的字符串表示插入到此序列中。
      StringBuilder insert​(int offset, char[] str)
      在此序列中插入 char数组参数的字符串表示形式。
      StringBuilder insert​(int index, char[] str, int offset, int len)
      将 str数组参数的子阵列的字符串表示插入到此序列中。
      StringBuilder insert​(int offset, double d)
      将 double参数的字符串表示插入到此序列中。
      StringBuilder insert​(int offset, float f)
      将 float参数的字符串表示插入到此序列中。
      StringBuilder insert​(int offset, int i)
      将第二个 int参数的字符串表示插入到此序列中。
      StringBuilder insert​(int offset, long l)
      将 long参数的字符串表示插入到此序列中。
      StringBuilder insert​(int dstOffset, CharSequence s)
      将指定的 CharSequence插入到此序列中。
      StringBuilder insert​(int dstOffset, CharSequence s, int start, int end)
      在此序列中插入指定的 CharSequence序列。
      StringBuilder insert​(int offset, Object obj)
      将 Object参数的字符串表示插入到此字符序列中。
      StringBuilder insert​(int offset, String str)
      将字符串插入到此字符序列中。
      int lastIndexOf​(String str)
      返回指定子字符串最后一次出现的字符串中的索引。
      int lastIndexOf​(String str, int fromIndex)
      返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。
      int length​()
      返回长度（字符数）。
      int offsetByCodePoints​(int index, int codePointOffset)
      返回此序列中与 index由 codePointOffset代码点偏移的索引。
      StringBuilder replace​(int start, int end, String str)
      用指定的 String的字符替换此序列的子字符串中的字符。
      StringBuilder reverse​()
      导致该字符序列被序列的相反代替。
      void setCharAt​(int index, char ch)
      指定索引处的字符设置为 ch 。
      void setLength​(int newLength)
      设置字符序列的长度。
      CharSequence subSequence​(int start, int end)
      返回一个新的字符序列，该序列是该序列的子序列。
      String substring​(int start)
      返回一个新的 String ，其中包含此字符序列中当前包含的字符的子序列。
      String substring​(int start, int end)
      返回一个新的 String ，其中包含此序列中当前包含的字符的子序列。
      String toString​()
      返回表示此顺序中的数据的字符串。
      void trimToSize​()
      尝试减少用于字符序列的存储。

      • Methods inherited from interface java.lang.CharSequence

        charAt, chars, codePoints, length, subSequence

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StringBuilder

        public StringBuilder​()
        构造一个没有字符的字符串构建器，初始容量为16个字符。

      • StringBuilder

        public StringBuilder​(int capacity)
        构造一个没有字符的字符串构建器，以及由 capacity参数指定的初始容量。
        参数
        capacity - 初始容量。
        异常
        NegativeArraySizeException - 如果 capacity参数小于 0 。

      • StringBuilder

        public StringBuilder​(String str)
        构造一个初始化为指定字符串内容的字符串构建器。 字符串构建器的初始容量为16加上字符串参数的长度。
        参数
        str - 缓冲区的初始内容。

      • StringBuilder

        public StringBuilder​(CharSequence seq)
        构造一个字符串构建器，其中包含与指定的CharSequence相同的字符。 字符串构建器的初始容量为16加上CharSequence参数的长度。
        参数
        seq - 要复制的顺序。

    • 方法详细信息

      • append

        public StringBuilder append​(Object obj)
        追加Object参数的字符串表示形式。

        整体效果就好像通过方法String.valueOf(Object)将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        obj - 一个 Object 。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(String str)
        将指定的字符串附加到此字符序列。

        附加String参数的字符，以便String参数的长度增加此序列的长度。 如果str为null ，则附加四个字符"null" 。

        在执行append方法之前，让n为该字符序列的长度。 那么如果k小于n ，则新字符序列中索引k处的字符等于旧字符序列中索引k处的字符; 否则，它等于参数str中的索引kn处的字符。

        参数
        str - 一个字符串。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(StringBuffer sb)
        追加指定的StringBuffer到这个序列。

        按照序列的顺序追加StringBuffer参数的字符，将该序列的长度增加到参数的长度。 如果sb为null ，则该序列附加四个字符"null" 。

        在执行append方法之前，让n为该字符序列的长度。 那么如果k小于n ，则新字符序列中索引k处的字符等于旧字符序列中索引k处的字符; 否则，它等于参数sb中的索引kn处的字符。

        参数
        sb - 附加的 StringBuffer 。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(CharSequence s)
        描述从接口Appendable复制
        将指定的字符序列追加到此Appendable 。

        根据哪个类实现字符序列csq ，整个序列可能不被附加。 例如，如果csq是一个CharBuffer，则附加的子序列由缓冲区的位置和限制来定义。

        Specified by:
        append在接口 Appendable
        参数
        s - 要追加的字符序列。 如果csq为null ，则该"null"可附加四个字符"null" 。
        结果
        参考这个 Appendable

      • append

        public StringBuilder append​(CharSequence s,
                            int start,
                            int end)
        追加指定的序列CharSequence序列。

        从索引start开始的参数s字符按顺序附加到该序列的内容，直到（排他）索引end 。 该序列的长度增加了end - start的值。

        在执行append方法之前，让n为该字符序列的长度。 那么如果k小于n ，则该字符序列中的索引k处的字符变得等于该序列中索引k处的字符; 否则，它等于参数s中的索引k + start-n处的s 。

        如果s为null ，则该方法将字符附加为s参数是包含四个字符"null"的序列。

        Specified by:
        append在接口 Appendable
        参数
        s - 要追加的序列。
        start - 要追加的子序列的起始索引。
        end - 要追加的子序列的结束索引。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果 start为负数，或 start大于 end或 end大于 s.length()

      • append

        public StringBuilder append​(char[] str)
        将char数组参数的字符串表示追加到此序列。

        数组参数的字符按顺序附加到此序列的内容。 该序列的长度增加参数的长度。

        整体效果就好像通过方法String.valueOf(char[])将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        str - 要附加的字符。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(char[] str,
                            int offset,
                            int len)
        将char数组参数的子阵列的字符串表示附加到此序列。

        从索引offset开始的char阵列str字符按顺序附加到该序列的内容。 该序列的长度增加值为len 。

        总体效果就好像通过方法String.valueOf(char[],int,int)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        str - 要附加的字符。
        offset -第一的指数 char追加。
        len - 要追加的 char的数量。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果是 offset < 0或 len < 0或 offset+len > str.length

      • append

        public StringBuilder append​(boolean b)
        将boolean参数的字符串表示追加到序列中。

        整体效果就好像通过方法String.valueOf(boolean)将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        b - a boolean 。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(char c)
        将char参数的字符串表示附加到此序列。

        该参数附加到此序列的内容。 该序列的长度增加1 。

        整体效果就好像通过方法String.valueOf(char)将参数转换为字符串，该字符串中的字符然后是这个字符序列的appended 。

        Specified by:
        append在接口 Appendable
        参数
        c - a char 。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(int i)
        将int参数的字符串表示追加到此序列。

        整体效果就好像通过方法String.valueOf(int)将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        i - 一个 int 。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(long lng)
        将long参数的字符串表示附加到此序列。

        整体效果就好像通过方法String.valueOf(long)将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        lng - a long 。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(float f)
        将float参数的字符串表示法附加到此序列。

        整体效果就好像通过方法String.valueOf(float)将参数转换为字符串，并且该字符串的字符然后是这个字符序列的appended 。

        参数
        f - a float 。
        结果
        对这个对象的引用。

      • append

        public StringBuilder append​(double d)
        将double参数的字符串表示追加到此序列。

        整体效果就好像通过方法String.valueOf(double)将参数转换为字符串，并且该字符串的字符然后是该字符序列的appended 。

        参数
        d - a double 。
        结果
        对这个对象的引用。

      • appendCodePoint

        public StringBuilder appendCodePoint​(int codePoint)
        将codePoint参数的字符串表示追加到此序列。

        该参数附加到此序列的内容。 该序列的长度增加Character.charCount(codePoint) 。

        整体效果就好像通过方法Character.toChars(int)将参数转换为char数组，并且该数组中的字符然后是该字符序列的appended 。

        参数
        codePoint - 一个Unicode代码点
        结果
        对这个对象的引用。
        从以下版本开始：
        1.5

      • delete

        public StringBuilder delete​(int start,
                            int end)
        删除此序列的子字符串中的字符。 子字符串从指定的start开始，并扩展到索引号为end - 1的字符，如果不存在这样的字符，则扩展到序列的末尾。 如果start等于end ，则不作任何更改。
        参数
        start - 开始索引，包括。
        end - 结束索引，独家。
        结果
        这个对象。
        异常
        StringIndexOutOfBoundsException - 如果 start为负数，大于 length()或大于 end 。

      • deleteCharAt

        public StringBuilder deleteCharAt​(int index)
        按照此顺序删除指定位置的char 。 该序列缩短了一个char 。

        注意：如果给定索引处的字符是补充字符，则此方法不会删除整个字符。 如果需要正确处理补充字符，请通过致电Character.charCount(thisSequence.codePointAt(index))确定char的Character.charCount(thisSequence.codePointAt(index)) ，其中thisSequence为该序列。

        参数
        index - 索引 char删除
        结果
        这个对象。
        异常
        StringIndexOutOfBoundsException - 如果 index为负数或大于或等于 length() 。

      • replace

        public StringBuilder replace​(int start,
                             int end,
                             String str)
        将此序列的子字符串中的字符替换为指定的String字符。 子字符串从指定的start开始，并扩展到索引号为end - 1的字符，如果不存在这样的字符，则扩展到序列的末尾。 首先删除子字符串中的字符，然后在String插入指定的start 。 （如果需要，此序列将被延长以容纳指定的字符串。）
        参数
        start - 开始索引，包括。
        end - 结束索引，独家。
        str - 将替换以前内容的字符串。
        结果
        这个对象。
        异常
        StringIndexOutOfBoundsException - 如果 start为负，大于 length() ，或大于 end 。

      • insert

        public StringBuilder insert​(int index,
                            char[] str,
                            int offset,
                            int len)
        将str数组参数的子阵列的字符串表示插入到此序列中。 子阵列从指定的offset开始，扩展len char s。 子阵列的字符在index所示的位置被插入到该序列中。 该序列的长度增加len char s。
        参数
        index - 插入子阵列的位置。
        str - A char数组。
        offset - 要插入的子阵列中的第一个 char的索引。
        len - 要插入的子阵列中的 char的数量。
        结果
        这个对象
        异常
        StringIndexOutOfBoundsException - 如果 index为负数或大于 length() ，或 offset或 len为负数，或 (offset+len)大于 str.length 。

      • insert

        public StringBuilder insert​(int offset,
                            Object obj)
        将Object参数的字符串表示插入到此字符序列中。

        整体效果就好像第二个参数通过方法String.valueOf(Object)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移。
        obj - a Object 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移无效。

      • insert

        public StringBuilder insert​(int offset,
                            String str)
        将字符串插入到此字符序列中。

        String参数的字符按顺序插入到指定偏移量的该序列中，向上移动原始位于该位置的任何字符，并将该序列的长度增加到参数的长度。 如果str为null ，则四个字符"null"被插入到该序列中。

        新字符序列中索引k处的字符等于：

        • 如果k小于offset ，则旧字符序列中的索引k处的字符
        • 在索引k处的字符-offset在参数str ，如果k不小于offset但小于offset+str.length()
        • 在旧字符序列中的索引k -str.length()处的字符，如果k不小于offset+str.length()

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移。
        str - 一个字符串。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuilder insert​(int offset,
                            char[] str)
        在此序列中插入char数组参数的字符串表示形式。

        数组参数的字符在offset指示的位置插入到该序列的内容中。 该序列的长度增加参数的长度。

        总体效果就好像第二个参数通过方法String.valueOf(char[])转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移量。
        str - 一个字符数组。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移无效。

      • insert

        public StringBuilder insert​(int dstOffset,
                            CharSequence s)
        在此序列中插入指定的CharSequence 。

        CharSequence参数的字符按顺序插入到指定偏移量的该序列中，向上移动原始位于该位置的任何字符，并将该序列的长度增加到参数s的长度。

        该方法的结果与调用该对象的insert （dstOffset，s，0，s.length（））方法完全相同 。

        如果s为null ，则四个字符"null"被插入到该序列中。

        参数
        dstOffset - 偏移量。
        s - 要插入的序列
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果偏移无效。

      • insert

        public StringBuilder insert​(int dstOffset,
                            CharSequence s,
                            int start,
                            int end)
        在该序列中插入指定的CharSequence序列。

        参数的子序列s通过指定start和end被插入，以便成在指定的目的地偏移该序列中，该位置上述最初向上运动的任何字符。 该序列的长度增加end - start 。

        该序列中索引k处的字符等于：

        • 如果k小于dstOffset ，则该序列中索引k处的字符
        • 参数s中索引k +start-dstOffset处的字符，如果k大于或等于dstOffset但小于dstOffset+end-start
        • 在该序列中的索引k -(end-start)处的字符，如果k大于或等于dstOffset+end-start

        dstOffset参数必须大于或等于0 ，小于或等于该序列的length 。

        起始参数必须是非负数，不得大于end 。

        结束参数必须大于或等于start ，小于或等于s的长度。

        如果s是null ，则该方法插入字符，就像s参数是包含四个字符"null"的序列"null" 。

        参数
        dstOffset - 此序列中的偏移量。
        s - 要插入的序列。
        start - 插入子序列的起始索引。
        end - 要插入的子序列的结束索引。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果 dstOffset为负数或大于 this.length() ，或 start或 end为负数，或 start大于 end或 end大于 s.length()

      • insert

        public StringBuilder insert​(int offset,
                            boolean b)
        将boolean参数的字符串表示插入到此序列中。

        整体效果就好像第二个参数通过方法String.valueOf(boolean)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移。
        b - a boolean 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuilder insert​(int offset,
                            char c)
        将char参数的字符串表示插入到此序列中。

        总体效果就好像第二个参数通过方法String.valueOf(char)转换为一个字符串，并且该字符串中的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，并小于或等于此序列的length 。

        参数
        offset - 偏移。
        c - a char 。
        结果
        对这个对象的引用。
        异常
        IndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuilder insert​(int offset,
                            int i)
        将第二个int参数的字符串表示插入到此序列中。

        整体效果就好像通过方法String.valueOf(int)将第二个参数转换为字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移量。
        i - a int 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移无效。

      • insert

        public StringBuilder insert​(int offset,
                            long l)
        在此序列中插入long参数的字符串表示形式。

        总体效果就好像第二个参数通过方法String.valueOf(long)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移量。
        l - a long 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • insert

        public StringBuilder insert​(int offset,
                            float f)
        将float参数的字符串表示插入到此序列中。

        总体效果就好像第二个参数通过方法String.valueOf(float)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，并且小于或等于此序列的length 。

        参数
        offset - 偏移。
        f - a float 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移无效。

      • insert

        public StringBuilder insert​(int offset,
                            double d)
        将double参数的字符串表示插入到此序列中。

        总体效果就好像第二个参数通过方法String.valueOf(double)转换为一个字符串，并且该字符串的字符然后是inserted到指定的偏移量的这个字符序列。

        offset参数必须大于或等于0 ，小于或等于此序列的length 。

        参数
        offset - 偏移。
        d - a double 。
        结果
        对这个对象的引用。
        异常
        StringIndexOutOfBoundsException - 如果偏移量无效。

      • indexOf

        public int indexOf​(String str)
        返回指定子字符串第一次出现的字符串内的索引。

        返回的索引是最小值k ，其中：

           this.toString().startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        结果
        第一次发生指定子串的索引，如果没有这种情况， -1 。

      • indexOf

        public int indexOf​(String str,
                   int fromIndex)
        返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。

        返回的索引是最小值k ，其中：

           k >= Math.min(fromIndex, this.length()) && this.toString().startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        fromIndex - 从中开始搜索的索引。
        结果
        指定的子字符串的第一次出现的索引，从指定的索引开始，如果没有这种情况， -1 。

      • lastIndexOf

        public int lastIndexOf​(String str)
        返回指定子字符串最后一次出现的字符串中的索引。 空字符串“”的最后一次出现被认为发生在索引值this.length() 。

        返回的指数是k ，其中：

           this.toString().startsWith(str, k)
        如果没有这样的价值k存在，那么-1返回。
        参数
        str - 要搜索的子字符串。
        结果
        指定子字符串的最后一次出现的索引，如果没有这种情况， -1 。

      • lastIndexOf

        public int lastIndexOf​(String str,
                       int fromIndex)
        返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。

        返回的指数是k ：

           k <= Math.min(fromIndex, this.length()) && this.toString().startsWith(str, k)
        如果没有k值，则返回-1 。
        参数
        str - 要搜索的子字符串。
        fromIndex - 开始搜索的索引。
        结果
        指定子字符串的最后一次出现的索引，从指定的索引向后搜索，如果没有发生这种情况， -1 。

      • reverse

        public StringBuilder reverse​()
        导致该字符序列被序列的相反代替。 如果序列中包含任何替代对，则将它们视为单个字符进行反向操作。 因此，高低替代品的顺序从未被扭转过。 在执行reverse方法之前，让n为该字符序列的字符长度（不是char的长度）。 那么新字符序列中的索引k处的字符等于旧字符序列中的索引nk-1处的字符。

        请注意，相反的操作可能会导致在手术之前产生不配对的低代谢和高代谢的替代对。 例如，反转“\ uDC00 \ uD800”会生成“\ uD800 \ uDC00”，它是一个有效的代理对。

        结果
        对这个对象的引用。

      • toString

        public String toString​()
        返回表示此顺序中的数据的字符串。 新的String对象被分配和初始化以包含此对象当前表示的字符序列。 然后返回String 。 对此序列的后续更改不影响String的内容。
        Specified by:
        toString在接口 CharSequence
        结果
        这个字符序列的字符串表示。

      • length

        public int length​()
        返回长度（字符数）。
        Specified by:
        length在接口 CharSequence
        结果
        当前由此对象表示的字符序列的长度

      • capacity

        public int capacity​()
        返回当前容量。 容量是新插入字符可用的存储量，超过此值将进行分配。
        结果
        当前的容量

      • ensureCapacity

        public void ensureCapacity​(int minimumCapacity)
        确保容量至少等于规定的最小值。 如果当前容量小于参数，则会分配一个新的内部数组，容量更大。 新产能较大：
        • minimumCapacity论证。
        • 两倍的旧容量，加上2 。
        如果minimumCapacity参数为非正态，则此方法不执行任何操作，只需返回。 请注意，此对象的后续操作可以将实际容量降低到低于此处所请求的容量。
        参数
        minimumCapacity - 最小所需容量。

      • trimToSize

        public void trimToSize​()
        尝试减少用于字符序列的存储。 如果缓冲区大于保持其当前字符序列所需的缓冲区，则可以将其调整大小以变得更加空间有效。 调用此方法可能但不是要求影响后续调用capacity()方法返回的值。

      • setLength

        public void setLength​(int newLength)
        设置字符序列的长度。 该序列被更改为一个新的字符序列，其长度由参数指定。 对于小于每非负索引k newLength ，在新的字符序列的索引k处的字符是相同的在旧序列索引k如果k小于原字符序列的长度的字符; 否则，它是空字符'\u0000' 。 换句话说，如果newLength参数小于当前长度，则长度将更改为指定的长度。

        如果newLength参数大于或等于当前长度，则会附加足够的空字符（ '\u0000' ），以使长度成为newLength参数。

        newLength参数必须大于或等于0 。

        参数
        newLength - 新的长度
        异常
        IndexOutOfBoundsException - 如果 newLength参数为负数。

      • charAt

        public char charAt​(int index)
        返回指定索引处的此序列中的char值。 第一个char值是索引0 ，下一个索引为1 ，依此类推，就像在数组索引中一样。

        索引参数必须大于或等于0 ，并小于此序列的长度。

        如果索引指定的char值为surrogate ，则返回替代值。

        Specified by:
        charAt在接口 CharSequence
        参数
        index - index的指数 char 。
        结果
        指定的指数为 char 。
        异常
        IndexOutOfBoundsException - 如果 index为负数或大于或等于 length() 。

      • codePointAt

        public int codePointAt​(int index)
        返回指定索引处的字符（Unicode代码点）。 索引指的是char值（Unicode代码单位），范围从0到length() - 1 。

        如果在给定索引处指定的char值处于高代理范围内，则以下索引小于该序列的长度，并且以下索引处的char值处于低代理范围内，则补码代码点相应的这个代理对被退回。 否则，返回给定索引处的char值。

        参数
        index - 索引为 char值
        结果
        字符的代码点值在 index
        异常
        IndexOutOfBoundsException - 如果 index参数为负数或不小于此序列的长度。

      • codePointBefore

        public int codePointBefore​(int index)
        返回指定索引之前的字符（Unicode代码点）。 索引指的是char值（Unicode代码单位），范围从1到length() 。

        如果char的(index - 1)处于低代理区间，则(index - 2)不为负，而char为(index - 2) ，处于高替代范围，则返回替代对的补码代码值。 如果char在值index - 1是未配对的低代理或一个高代理，则返回所述替代值。

        参数
        index - 应该返回的代码点之后的索引
        结果
        Unicode代码点值在给定索引之前。
        异常
        IndexOutOfBoundsException - 如果 index参数小于1或大于此序列的长度。

      • codePointCount

        public int codePointCount​(int beginIndex,
                          int endIndex)
        返回此序列指定文本范围内的Unicode代码点数。 文本范围始于指定beginIndex并延伸到char在索引endIndex - 1 。 因此，文本范围的长度（ char秒）为endIndex-beginIndex 。 该序列中的未配对代理计数为每个代码点。
        参数
        beginIndex - 索引到第一个 char的文本范围。
        endIndex - 最后一个 char之后的索引文本范围。
        结果
        指定文本范围内的Unicode代码点数
        异常
        IndexOutOfBoundsException - 如果 beginIndex为负数，或 endIndex大于此序列的长度，或 beginIndex大于 endIndex 。

      • offsetByCodePoints

        public int offsetByCodePoints​(int index,
                              int codePointOffset)
        返回该序列中与index由codePointOffset代码点偏移的索引。 由index和codePointOffset给出的文本范围内的非配对替代品作为每个代码点。
        参数
        index - 要偏移的索引
        codePointOffset - 代码点的偏移量
        结果
        该序列中的索引
        异常
        IndexOutOfBoundsException - 如果 index为负或大于该序列的长度，或者如果 codePointOffset为正，并且由 index开始的子 index具有少于 codePointOffset码点，或者如果 codePointOffset为负，并且 index之前的子 index小于绝对值 codePointOffset代码点。

      • getChars

        public void getChars​(int srcBegin,
                     int srcEnd,
                     char[] dst,
                     int dstBegin)
        字符从该序列复制到目标字符数组dst 。 要复制的第一个字符是索引srcBegin ; 要复制的最后一个字符在索引srcEnd-1 。 要复制的字符总数为srcEnd-srcBegin 。 字符被复制到dst的子阵列，从索引dstBegin开始，以索引结尾：
           dstbegin + (srcEnd-srcBegin) - 1
        参数
        srcBegin - 以此偏移量开始复制。
        srcEnd - 在此偏移处停止复制。
        dst - 将数据复制到的数组。
        dstBegin - 偏移到 dst 。
        异常
        IndexOutOfBoundsException - 如果满足以下条件：
        • srcBegin为负数
        • dstBegin是否定的
        • srcBegin参数大于srcEnd参数。
        • srcEnd大于this.length() 。
        • dstBegin+srcEnd-srcBegin大于dst.length

      • setCharAt

        public void setCharAt​(int index,
                      char ch)
        指定索引处的字符设置为ch 。 该序列被改变以表示一个新的字符序列，其是相同的原字符序列，不同之处在于它包含字符ch在位置index 。

        索引参数必须大于或等于0 ，并小于此序列的长度。

        参数
        index - 要修改的字符的索引。
        ch - 新角色。
        异常
        IndexOutOfBoundsException - 如果 index为负数或大于或等于 length() 。

      • substring

        public String substring​(int start)
        返回一个新的String ，其中包含此字符序列中当前包含的字符的子序列。 子串从指定的索引开始，并延伸到该序列的末尾。
        参数
        start - 开始索引，包括。
        结果
        新的字符串。
        异常
        StringIndexOutOfBoundsException - 如果 start小于零或大于此对象的长度。

      • subSequence

        public CharSequence subSequence​(int start,
                                int end)
        返回一个新的字符序列，该序列是该序列的子序列。

        调用此方法的形式

           sb.subSequence(begin,&nbsp;end)
        行为与调用完全相同
           sb.substring(begin,&nbsp;end)
        提供这种方法，使该类可以实现CharSequence接口。
        Specified by:
        subSequence在接口 CharSequence
        参数
        start - 开始索引，包括。
        end - 结束索引，独家。
        结果
        指定的子序列。
        异常
        IndexOutOfBoundsException - 如果 start或 end为负数，如果 end大于 length() ，或者如果 start大于 end

      • substring

        public String substring​(int start,
                        int end)
        返回一个新的String ，其中包含此序列中当前包含的字符的子序列。 子串从指定的start开始，并扩展到索引号为end - 1的字符。
        参数
        start - 开始索引，包括。
        end - 结束索引，独家。
        结果
        新的字符串。
        异常
        StringIndexOutOfBoundsException - 如果 start或 end为负数或大于 length() ，或 start大于 end 。

      • chars

        public IntStream chars​()
        返回一个int的数据流， int零序扩展char值。 映射到surrogate code point的任何字符通过未解释的方式传递。

        当终端流操作开始时（特别地，对于可变序列，流的分流器是late-binding ），流与该序列绑定。 如果序列在该操作期间被修改，则结果是未定义的。

        Specified by:
        chars在接口 CharSequence
        结果
        这个序列中的char值的IntStream
        从以下版本开始：
        9

      • codePoints

        public IntStream codePoints​()
        从此序列返回码流值。 在序列中遇到的任何替代对被组合，如同通过Character.toCodePoint ，并将结果传递给流。 任何其他代码单元，包括普通的BMP字符，未配对的代理和未定义的代码单元，都将零扩展到int值，然后传递给流。

        当终端流操作开始时（具体来说，对于可变序列，流的分流器是late-binding ），流与该序列绑定。 如果序列在该操作期间被修改，则结果是未定义的。

        Specified by:
        codePoints在接口 CharSequence
        结果
        Unicode序列的IntStream从这个序列中指向
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringIndexOutOfBoundsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class StringIndexOutOfBoundsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IndexOutOfBoundsException
            • java.lang.StringIndexOutOfBoundsException
  • All Implemented Interfaces:
    Serializable

    public class StringIndexOutOfBoundsException
extends IndexOutOfBoundsException
    抛出String方法来指示索引为负或大于字符串的大小。 对于某些方法，如charAt方法，当索引等于字符串的大小时，也会抛出此异常。
    从以下版本开始：
    1.0
    另请参见：
    String.charAt(int) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringIndexOutOfBoundsException​()
      构造一个没有详细消息的 StringIndexOutOfBoundsException 。
      StringIndexOutOfBoundsException​(int index)
      构造一个新的 StringIndexOutOfBoundsException类，其中包含指示非法索引的参数。
      StringIndexOutOfBoundsException​(String s)
      构造具有指定详细消息的 StringIndexOutOfBoundsException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • StringIndexOutOfBoundsException

        public StringIndexOutOfBoundsException​()
        构造一个 StringIndexOutOfBoundsException ，没有详细信息。

      • StringIndexOutOfBoundsException

        public StringIndexOutOfBoundsException​(String s)
        构造具有指定详细消息的 StringIndexOutOfBoundsException 。
        参数
        s - 详细信息。

      • StringIndexOutOfBoundsException

        public StringIndexOutOfBoundsException​(int index)
        构造一个新的StringIndexOutOfBoundsException类，其中包含非法索引的参数。

        该索引包含在此异常的详细消息中。 详细信息的确切显示格式未指定。

        参数
        index - 非法索引。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SuppressWarnings (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang

Annotation Type SuppressWarnings

  • @Target({TYPE,字段,METHOD,PARAMETER,CONSTRUCTOR,LOCAL_VARIABLE,MODULE})
@Retention(SOURCE)
public @interface SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。 请注意，给定元素中抑制的一组警告是所有包含元素中抑制的警告的超集。 例如，如果您注释一个类来抑制一个警告并注释方法来抑制另一个警告，则两个警告将在该方法中被抑制。 但是，请注意，如果在module-info文件中抑制了警告，则抑制应用于文件中的元素， 而不适用于模块中包含的类型。

    作为一种风格，程序员应该始终将这个注释用于最有效的嵌套元素。 如果要在特定方法中抑制警告，则应该注释该方法而不是其类。

    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    4.8原始类型，4.12.2参考类型的变量，5.1.9未经检查的转换，5.5.2检查的角色和未被检查的角色，9.6.4.5 @SuppressWarnings

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      String[] value
      在注释元素中由编译器抑制的一组警告。

    • Element Detail

      • value

        String[] value
        在注释元素中由编译器抑制的一组警告。 允许重复的名称。 忽略名称的第二次和连续出现。 无法识别的警告名称的存在不是错误：编译器必须忽略他们无法识别的任何警告名称。 但是，如果注释包含无法识别的警告名称，则它们可以自由发出警告。

        字符串"unchecked"用于抑制未经检查的警告。 编译器供应商应该记录它们与此注释类型一起支持的附加警告名称。 我们鼓励他们合作，确保同一个名字在多个编译器上工作。

        结果
        一组警告被压制
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


System (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class System

  • java.lang.Object
    • java.lang.System

  • public final class System
extends Object
    System类包含几个有用的类字段和方法。 它不能被实例化。

    System类提供的设施包括标准输入，标准输出和错误输出流; 访问外部定义的属性和环境变量; 一种加载文件和库的方法; 以及用于快速复制阵列的一部分的实用方法。

    从以下版本开始：
    1.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  System.Logger
      System.Logger实例日志消息将路由到底层日志框架LoggerFinder使用。
      static class  System.LoggerFinder
      LoggerFinder服务负责创建，管理和配置记录器到其使用的基础框架。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static PrintStream err
      “标准”错误输出流。
      static InputStream in
      “标准”输入流。
      static PrintStream out
      “标准”输出流。

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static void arraycopy​(Object src, int srcPos, Object dest, int destPos, int length)
      将指定源数组中的数组从指定位置复制到目标数组的指定位置。
      static String clearProperty​(String key)
      删除指定键指定的系统属性。
      static Console console​()
      返回与当前Java虚拟机相关联的唯一的Console对象（如果有）。
      static long currentTimeMillis​()
      返回当前时间（以毫秒为单位）。
      static void exit​(int status)
      终止当前运行的Java虚拟机。
      static void gc​()
      运行垃圾回收器。
      static Map<String,String> getenv​()
      返回当前系统环境的不可修改的字符串映射视图。
      static String getenv​(String name)
      获取指定环境变量的值。
      static System.Logger getLogger​(String name)
      返回一个Logger的调用者使用的实例。
      static System.Logger getLogger​(String name, ResourceBundle bundle)
      返回一个本地化的实例Logger，以供来电者使用。
      static Properties getProperties​()
      确定当前的系统属性。
      static String getProperty​(String key)
      获取指定键指示的系统属性。
      static String getProperty​(String key, String def)
      获取指定键指示的系统属性。
      static SecurityManager getSecurityManager​()
      获取系统安全界面。
      static int identityHashCode​(Object x)
      返回与默认方法hashCode（）返回的给定对象相同的哈希码，无论给定对象的类是否覆盖了hashCode（）。
      static Channel inheritedChannel​()
      返回从创建此Java虚拟机的实体继承的通道。
      static String lineSeparator​()
      返回与系统相关的行分隔符字符串。
      static void load​(String filename)
      加载由filename参数指定的本机库。
      static void loadLibrary​(String libname)
      加载由 libname参数指定的本机库。
      static String mapLibraryName​(String libname)
      将库名称映射到表示本地库的平台特定字符串。
      static long nanoTime​()
      以纳秒为单位返回正在运行的Java虚拟机的高分辨率时间源的当前值。
      static void runFinalization​()
      运行任何对象等待定稿的最终化方法。
      static void runFinalizersOnExit​(boolean value)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
      static void setErr​(PrintStream err)
      重新分配“标准”错误输出流。
      static void setIn​(InputStream in)
      重新分配“标准”输入流。
      static void setOut​(PrintStream out)
      重新分配“标准”输出流。
      static void setProperties​(Properties props)
      将系统属性设置为 Properties参数。
      static String setProperty​(String key, String value)
      设置由指定键指示的系统属性。
      static void setSecurityManager​(SecurityManager s)
      设置系统安全性。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • in

        public static final InputStream in
        “标准”输入流。 该流已经打开，准备提供输入数据。 通常，该流对应于键盘输入或由主机环境或用户指定的另一个输入源。

      • out

        public static final PrintStream out
        “标准”输出流。 此流已经打开并准备好接受输出数据。 通常，此流对应于显示输出或由主机环境或用户指定的另一个输出目标。

        对于简单的独立Java应用程序，编写一行输出数据的典型方法是：

             System.out.println(data)

        见println类方法PrintStream 。

        另请参见：
        PrintStream.println() ，
PrintStream.println(boolean) ，
PrintStream.println(char) ，
PrintStream.println(char[]) ，
PrintStream.println(double) ，
PrintStream.println(float) ，
PrintStream.println(int) ，
PrintStream.println(long) ，
PrintStream.println(java.lang.Object) ，
PrintStream.println(java.lang.String)

      • err

        public static final PrintStream err
        “标准”错误输出流。 此流已经打开并准备好接受输出数据。

        通常，此流对应于显示输出或由主机环境或用户指定的另一个输出目标。 按照惯例，该输出流用于显示错误消息或其他信息，这些信息应该立即引起用户的注意，即使主要输出流（变量out的值）已被重定向到文件或其他目的地，即通常不会持续监控。

    • 方法详细信息

      • setIn

        public static void setIn​(InputStream in)
        重新分配“标准”输入流。

        首先，如果有一个安全管理器，它的checkPermission方法被调用一个RuntimePermission("setIO")权限来查看是否可以重新分配“标准”输入流。

        参数
        in - 新的标准输入流。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许重新分配标准输入流。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission

      • setOut

        public static void setOut​(PrintStream out)
        重新分配“标准”输出流。

        首先，如果有一个安全管理器，它的checkPermission方法被调用一个RuntimePermission("setIO")权限，看看是否可以重新分配“标准”输出流。

        参数
        out - 新的标准输出流
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许重新分配标准输出流。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission

      • setErr

        public static void setErr​(PrintStream err)
        重新分配“标准”错误输出流。

        首先，如果有一个安全管理器，它的checkPermission方法被调用一个RuntimePermission("setIO")权限来查看是否可以重新分配“标准”错误输出流。

        参数
        err - 新的标准错误输出流。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许重新分配标准错误输出流。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission

      • console

        public static Console console​()
        返回与当前Java虚拟机关联的唯一的Console对象（如果有）。
        结果
        系统控制台（如有），否则为 null 。
        从以下版本开始：
        1.6

      • inheritedChannel

        public static Channel inheritedChannel​()
                                throws IOException
        返回从创建此Java虚拟机的实体继承的通道。

        此方法返回通过调用系统范围默认的SelectorProvider对象的inheritedChannel方法获得的通道。

        除了inheritedChannel中描述的面向网络的通道之外 ，此方法可能会在将来返回其他类型的通道。

        结果
        继承的渠道，如果有的话，否则 null 。
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果存在安全管理员，并且不允许访问该通道。
        从以下版本开始：
        1.5

      • setSecurityManager

        public static void setSecurityManager​(SecurityManager s)
        设置系统安全性。

        如果已经安装了安全管理器，则该方法首先使用RuntimePermission("setSecurityManager")权限调用安全管理器的checkPermission方法，以确保替换现有安全管理器。 这可能会导致抛出一个SecurityException 。

        否则，该参数被建立为当前的安全管理器。 如果参数是null并且没有建立安全管理器，则不采取任何操作，并且该方法简单地返回。

        参数
        s - 安全管理员。
        异常
        SecurityException - 如果安全管理器已经设置，并且其 checkPermission方法不允许替换它。
        另请参见：
        getSecurityManager() ， SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission

      • getSecurityManager

        public static SecurityManager getSecurityManager​()
        获取系统安全界面。
        结果
        200新200新新旗新新新旗新新旗旗新新旗新新旗旗新新旗旗新新旗旗新新旗旗新新旗新新旗新新旗新新旗新新旗新新旗新新旗新新200新新旗新新200新新旗新新200新新旗新新旗新新款： 否则返回null 。
        另请参见：
        setSecurityManager(java.lang.SecurityManager)

      • currentTimeMillis

        public static long currentTimeMillis​()
        返回当前时间（以毫秒为单位）。 请注意，虽然返回值的时间单位为毫秒，但该值的粒度取决于底层操作系统，并且可能较大。 例如，许多操作系统以几十毫秒为单位测量时间。

        有关“计算机时间”和协调世界时间（UTC）之间可能出现的轻微差异的讨论，请参阅类别Date的说明。

        结果
        在1970年1月1日UTC之间的当前时间和午夜之间的差异，以毫秒为单位。
        另请参见：
        Date

      • nanoTime

        public static long nanoTime​()
        以纳秒为单位返回正在运行的Java虚拟机的高分辨率时间源的当前值。

        该方法只能用于测量经过时间，与系统或挂钟时间的任何其他概念无关。 返回的值表示纳秒，因为一些固定但任意的起始时间（可能在将来，所以值可能是负数）。 在Java虚拟机的实例中，该方法的所有调用都使用相同的来源; 其他虚拟机实例可能会使用不同的来源。

        该方法提供纳秒精度，但不一定是纳秒分辨率（即，值的变化频率） - 除了分辨率至少与currentTimeMillis()相同，不作任何保证。

        跨越大约292年（2 63纳秒）的连续呼叫的差异将无法正确计算由于数字溢出所造成的时间。

        仅当在Java虚拟机的同一实例中获得的两个此类值之间的差异被计算时，此方法返回的值才会变得有意义。

        例如，测量代码执行多长时间：

           long startTime = System.nanoTime(); // ... the code being measured ... long elapsedNanos = System.nanoTime() - startTime;

        要比较经过的时间与超时时间，请使用

           if (System.nanoTime() - startTime >= timeoutNanos) ...
        代替
           if (System.nanoTime() >= startTime + timeoutNanos) ...
        由于数值溢出的可能性。
        结果
        运行Java虚拟机的高分辨率时间源的当前值，以纳秒为单位
        从以下版本开始：
        1.5

      • arraycopy

        public static void arraycopy​(Object src,
                             int srcPos,
                             Object dest,
                             int destPos,
                             int length)
        将指定源数组中的数组从指定位置复制到目标数组的指定位置。 阵列组件的一个子序列被从通过引用的源阵列复制src通过引用的目标阵列dest 。 复制的组件数等于length参数。 源阵列中位置srcPos至srcPos+length-1的组件分别复制到目标阵列的位置destPos至destPos+length-1 。

        如果src和dest参数指向相同的数组对象，则执行复制，就好像srcPos至srcPos+length-1位置的组件首次复制到具有length组件的临时阵列，然后将临时阵列的内容复制到位置destPos通过destPos+length-1的目的地阵列。

        如果dest是null ，那么抛出一个NullPointerException 。

        如果src是null ，则NullPointerException被抛出，并且目标阵列不被修改。

        否则，如果满足以下条件之一，则抛出ArrayStoreException并且ArrayStoreException目的地：

        • src参数是指不是数组的对象。
        • dest参数是指不是数组的对象。
        • src参数和dest参数是指其组件类型是不同的基本类型的数组。
        • src参数是指具有原始组件类型的数组，而dest参数是指具有引用组件类型的数组。
        • src参数是指具有引用组件类型的数组，而dest参数是指具有原始组件类型的数组。

        否则，如果满足以下条件之一，则抛出IndexOutOfBoundsException并且IndexOutOfBoundsException目的地：

        • srcPos论点是否定的。
        • destPos参数为负数。
        • length论点是否定的。
        • srcPos+length大于src.length ，源数组的长度。
        • destPos+length大于dest.length ，目标数组的长度。

        否则，如果来自位置srcPos至srcPos+length-1的源数组的任何实际组件无法通过转换转换为目标数组的组件类型，则抛出ArrayStoreException 。 在这种情况下，令k是小于长度的最小非负整数， src[srcPos+无法将src[srcPos+ k ]转换为目标数组的组件类型; 当抛出异常时，来自位置srcPos至srcPos+ k -1源阵列组件将已经被复制到目的地阵列位置destPos至destPos+ k -1并且目标阵列的其他位置将不被修改。 （由于限制已经列出，本段仅适用于两个数组都具有引用类型的组件类型的情况。）

        参数
        src - 源数组。
        srcPos - 源数组中的起始位置。
        dest - 目标数组。
        destPos - 目的地数据中的起始位置。
        length - 要复制的数组元素的数量。
        异常
        IndexOutOfBoundsException - 如果复制将导致数据外部数据界限的访问。
        ArrayStoreException - 如果由于类型不匹配， src数组中的元素无法存储到 dest数组中。
        NullPointerException - 如果 src或 dest是 null 。

      • identityHashCode

        public static int identityHashCode​(Object x)
        返回与默认方法hashCode（）返回的给定对象相同的哈希码，无论给定对象的类是否覆盖了hashCode（）。 空引用的哈希码为零。
        参数
        x - 要计算hashCode的对象
        结果
        的hashCode
        从以下版本开始：
        1.1

      • getProperties

        public static Properties getProperties​()
        确定当前的系统属性。

        首先，如果有一个安全管理器，它的checkPropertiesAccess方法被调用没有参数。 这可能会导致安全例外。

        getProperty(String)方法使用的当前系统属性集作为Properties对象返回。 如果没有当前的系统属性集，则首先创建和初始化一组系统属性。 此组系统属性始终包含以下键的值：

        Shows property keys and associated values Key Description of Associated Value java.version Java Runtime Environment version which may be interpreted as a Runtime.Version java.vendor Java Runtime Environment vendor java.vendor.url Java vendor URL java.home Java installation directory java.vm.specification.version Java Virtual Machine specification version which may be interpreted as a Runtime.Version java.vm.specification.vendor Java Virtual Machine specification vendor java.vm.specification.name Java Virtual Machine specification name java.vm.version Java Virtual Machine implementation version which may be interpreted as a Runtime.Version java.vm.vendor Java Virtual Machine implementation vendor java.vm.name Java Virtual Machine implementation name java.specification.version Java Runtime Environment specification version which may be interpreted as a Runtime.Version java.specification.vendor Java Runtime Environment specification vendor java.specification.name Java Runtime Environment specification name java.class.version Java class format version number java.class.path Java class path java.library.path List of paths to search when loading libraries java.io.tmpdir Default temp file path java.compiler Name of JIT compiler to use os.name Operating system name os.arch Operating system architecture os.version Operating system version file.separator File separator ("/" on UNIX) path.separator Path separator (":" on UNIX) line.separator Line separator ("\n" on UNIX) user.name User's account name user.home User's home directory user.dir User's current working directory

        系统属性值中的多个路径由平台的路径分隔符分隔。

        请注意，即使安全管理员不允许getProperties操作，也可以选择允许getProperty(String)操作。

        Implementation Note:
        除了标准系统属性之外，系统属性可能包括以下密钥： Shows property keys and associated values Key Description of Associated Value jdk.module.path The application module path jdk.module.upgrade.path The upgrade module path jdk.module.main The module name of the initial/main module jdk.module.main.class The main class name of the initial module
        结果
        系统属性
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPropertiesAccess方法不允许访问系统属性。
        另请参见：
        setProperties(java.util.Properties) ， SecurityException ， SecurityManager.checkPropertiesAccess() ， Properties

      • lineSeparator

        public static String lineSeparator​()
        返回与系统相关的行分隔符字符串。 它总是返回相同的值 - 初始值为system property line.separator 。

        在UNIX系统上，它返回"\n" ; 在Microsoft Windows系统上，它返回"\r\n" 。

        结果
        系统相关的行分隔符串
        从以下版本开始：
        1.7

      • setProperties

        public static void setProperties​(Properties props)
        将系统属性设置为Properties参数。

        首先，如果有一个安全管理器，它的checkPropertiesAccess方法被调用没有参数。 这可能会导致安全例外。

        该参数成为getProperty(String)方法使用的当前系统属性集。 如果参数为null ，则系统属性的当前集合被遗忘。

        参数
        props - 新的系统属性。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPropertiesAccess方法不允许访问系统属性。
        另请参见：
        getProperties() ， Properties ， SecurityException ， SecurityManager.checkPropertiesAccess()

      • getProperty

        public static String getProperty​(String key)
        获取指定键指示的系统属性。

        首先，如果有一个安全管理器，它的checkPropertyAccess方法将以密钥作为参数来调用。 这可能会导致SecurityException。

        如果没有当前的系统属性集，则首先以与getProperties方法相同的方式创建和初始化一组系统属性。

        参数
        key - 系统属性的名称。
        结果
        系统属性的字符串值，如果没有该密钥的属性， null 。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPropertyAccess方法不允许访问指定的系统属性。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key为空。
        另请参见：
        setProperty(java.lang.String, java.lang.String) ， SecurityException ， SecurityManager.checkPropertyAccess(java.lang.String) ， getProperties()

      • getProperty

        public static String getProperty​(String key,
                                 String def)
        获取指定键指示的系统属性。

        首先，如果有一个安全管理器，它的checkPropertyAccess方法是以key作为参数来调用的。

        如果没有当前的系统属性集，则首先以与getProperties方法相同的方式创建和初始化一组系统属性。

        参数
        key - 系统属性的名称。
        def - 默认值。
        结果
        系统属性的字符串值，如果没有该键的属性，则为默认值。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertyAccess方法不允许访问指定的系统属性。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key为空。
        另请参见：
        setProperty(java.lang.String, java.lang.String) ，
SecurityManager.checkPropertyAccess(java.lang.String) ，
getProperties()

      • setProperty

        public static String setProperty​(String key,
                                 String value)
        设置由指定键指示的系统属性。

        首先，如果一个安全管理器存在，它的SecurityManager.checkPermission方法被调用一个PropertyPermission(key, "write")权限。 这可能导致抛出SecurityException。 如果没有引发异常，则将指定的属性设置为给定值。

        参数
        key - 系统属性的名称。
        value - 系统属性的值。
        结果
        系统属性的前一个值，如果没有， null 。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许设置指定的属性。
        NullPointerException - 如果 key或 value是 null 。
        IllegalArgumentException - 如果 key为空。
        从以下版本开始：
        1.2
        另请参见：
        getProperty(java.lang.String) ， getProperty(java.lang.String) ， getProperty(java.lang.String, java.lang.String) ， PropertyPermission ， SecurityManager.checkPermission(java.security.Permission)

      • clearProperty

        public static String clearProperty​(String key)
        删除指定键指定的系统属性。

        首先，如果一个安全管理器存在，它的SecurityManager.checkPermission方法被调用与一个PropertyPermission(key, "write")权限。 这可能导致抛出SecurityException。 如果没有异常抛出，指定的属性将被删除。

        参数
        key - 要删除的系统属性的名称。
        结果
        系统属性的前一个字符串值，如果没有该键的属性， null 。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertyAccess方法不允许访问指定的系统属性。
        NullPointerException - 如果 key是 null 。
        IllegalArgumentException - 如果 key为空。
        从以下版本开始：
        1.5
        另请参见：
        getProperty(java.lang.String) ， setProperty(java.lang.String, java.lang.String) ， Properties ， SecurityException ， SecurityManager.checkPropertiesAccess()

      • getenv

        public static String getenv​(String name)
        获取指定环境变量的值。 环境变量是系统相关的外部命名值。

        如果存在安全管理员，则其checkPermission方法将被调用，具有RuntimePermission("getenv."+name)权限。 这可能会导致抛出SecurityException 。 如果不抛出异常，则返回变量name的值。

        System properties and environment variables都是概念上的名称和值之间的映射。 这两种机制都可以用于将用户定义的信息传递给Java进程。 环境变量具有更全面的效果，因为它们对于定义它们的进程的所有后代都是可见的，而不仅仅是直接的Java子进程。 在不同的操作系统上，它们可能具有微妙的不同语义，例如不区分大小写。 由于这些原因，环境变量更有可能产生意想不到的副作用。 最好在可能的情况下使用系统属性。 当需要全局效果时，或外部系统接口需要环境变量（如PATH ）时，应使用环境变量。

        在UNIX系统上， name的字母name通常是重要的，而在Microsoft Windows系统上通常不是。 例如，表达式System.getenv("FOO").equals(System.getenv("foo"))在Microsoft Windows上可能是真实的。

        参数
        name - 环境变量的名称
        结果
        变量的字符串值，如果变量未在系统环境中定义， null
        异常
        NullPointerException - 如果 name是 null
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许访问环境变量 name
        另请参见：
        getenv() ， ProcessBuilder.environment()

      • getenv

        public static Map<String,String> getenv​()
        返回当前系统环境的不可修改的字符串映射视图。 环境是从名称到从父进程传递到子进程的值的系统相关映射。

        如果系统不支持环境变量，则返回空的地图。

        返回的地图永远不会包含空值或值。 尝试查询空值或值的存在将抛出一个NullPointerException 。 尝试查询是否存在不是String型号的键或值将抛出一个ClassCastException 。

        返回的地图及其收藏意见可能不符合Object.equals(java.lang.Object)和Object.hashCode()方法的一般合同。

        返回的地图通常在所有平台上都区分大小写。

        如果存在安全管理员，则其checkPermission方法RuntimePermission("getenv.*")权限进行调用。 这可能会导致抛出SecurityException 。

        当传递信息到Java子进程时 ，通常比环境变量更喜欢system properties 。

        结果
        环境作为变量名称映射到值
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许访问进程环境
        从以下版本开始：
        1.5
        另请参见：
        getenv(String) ， ProcessBuilder.environment()

      • getLogger

        public static System.Logger getLogger​(String name)
        返回一个Logger的调用者使用的实例。
        API Note:
        此方法可能会延迟调用 LoggerFinder.getLogger方法来创建由日志后端提供的实际记录器，例如允许在系统初始化时间内获取记录器。
        实现要求：
        通过此方法返回的实例将通过调用LoggerFinder.getLogger(name, module)获得的记录器发送消息，其中module是呼叫者的模块。 在箱子System.getLogger从上下文其中在堆栈上没有呼叫者帧调用（例如，当从JNI附螺纹直接调用）， IllegalCallerException被抛出。 要在这样的上下文中获取记录器，请使用将隐式标识为调用者的辅助类，或使用系统LoggerFinder来获取记录器。 请注意，做后者可能会迫切地初始化底层日志记录系统。
        参数
        name - 记录器的名称。
        结果
        一个可以由调用类使用的System.Logger的实例。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalCallerException - 如果堆栈上没有Java调用者帧。
        从以下版本开始：
        9

      • getLogger

        public static System.Logger getLogger​(String name,
                                      ResourceBundle bundle)
        返回一个可本地化的实例，为呼叫者使用Logger 。 返回的记录器将使用提供的资源束进行消息定位。
        API Note:
        该方法旨在在系统完全初始化后使用。 该方法可能会触发System.LoggerFinder服务的即时加载和初始化，如果Java运行时尚未准备好初始化具体的服务实现，则可能会导致问题。 可能在引导顺序早期加载并需要记录本地化消息的系统类应使用getLogger(java.lang.String)创建记录器，然后使用将资源束作为参数的日志方法。
        实现要求：
        返回的记录器将执行由LoggerFinder.getLocalizedLogger(name, bundle, module)指定的消息定位，其中module是呼叫者的模块。 在从堆栈中没有调用者帧的上下文调用System.getLogger的情况下（例如，当直接从JNI连接的线程调用）时，将抛出IllegalCallerException 。 要在这样的上下文中获取记录器，请使用将隐式标识为调用者的辅助类，或使用系统LoggerFinder来获取记录器。 请注意，做后者可能会迫切地初始化底层日志记录系统。
        参数
        name - 记录器的名称。
        bundle - 资源束。
        结果
        一个System.Logger的实例，它将使用提供的资源束进行消息定位。
        异常
        NullPointerException - 如果 name是 null或 bundle是 null 。
        IllegalCallerException - 如果堆栈上没有Java调用者帧。
        从以下版本开始：
        9

      • exit

        public static void exit​(int status)
        终止当前运行的Java虚拟机。 该参数作为状态代码; 按照惯例，非零状态码表示异常终止。

        该方法在类Runtime调用exit方法。 此方法从不正常返回。

        呼叫System.exit(n)有效地等效于呼叫：

         Runtime.getRuntime().exit(n)
        参数
        status - 退出状态。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExit方法不允许以指定状态退出。
        另请参见：
        Runtime.exit(int)

      • gc

        public static void gc​()
        运行垃圾回收器。

        调用gc方法表明，Java虚拟机花费了回收未使用对象的努力，以使其当前占用的内存可用于快速重用。 当控件从方法调用返回时，Java虚拟机已经尽力从所有丢弃的对象中回收空间。

        电话System.gc()有效地等效于呼叫：

         Runtime.getRuntime().gc()
        另请参见：
        Runtime.gc()

      • runFinalization

        public static void runFinalization​()
        运行任何对象等待定稿的最终化方法。

        调用该方法表明，对运行在Java虚拟机的努力finalize已发现物体的方法被废弃，但其finalize方法还没有被运行。 当控件从方法调用返回时，Java虚拟机已尽力完成所有未完成的定稿。

        呼叫System.runFinalization()有效地等效于呼叫：

         Runtime.getRuntime().runFinalization()
        另请参见：
        Runtime.runFinalization()

      • runFinalizersOnExit

        @Deprecated(since="1.2",
            forRemoval=true)
public static void runFinalizersOnExit​(boolean value)
        不推荐用于删除：此API元素将在以后的版本中被删除。 这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
        退出时启用或禁用最终化; 这样做指定了具有尚未自动调用的finalizer的所有对象的finalizer将在Java运行时退出之前运行。 默认情况下，退出时终止。

        如果有一个安全管理器，它的checkExit方法首先被调用为0作为参数，以确保退出是允许的。 这可能会导致SecurityException。

        参数
        value - 指示启用或禁用完成
        异常
        SecurityException - 如果存在安全管理员，并且其 checkExit方法不允许退出。
        从以下版本开始：
        1.1
        另请参见：
        Runtime.exit(int) ，
Runtime.gc() ，
SecurityManager.checkExit(int)

      • load

        public static void load​(String filename)
        加载由filename参数指定的本机库。 filename参数必须是绝对路径名。 如果文件名参数在剥离任何特定于平台的库前缀，路径和文件扩展名时，表示名称为例如L的库，并且名为L的本地库与VM静态链接，则JNI_OnLoad_L函数调用库导出而不是尝试加载动态库。 与参数匹配的文件名不必存在于文件系统中。 有关详细信息，请参阅JNI规范。 否则，文件名参数以实现相关的方式映射到本机库映像。

        呼叫System.load(name)有效地等效于呼叫：

         Runtime.getRuntime().load(name)
        参数
        filename - 要加载的文件。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkLink方法不允许加载指定的动态库
        UnsatisfiedLinkError - 如果文件名不是绝对路径名，则本地库不会与VM静态链接，或者该库不能由主机系统映射到本机库映像。
        NullPointerException - 如果 filename是 null
        另请参见：
        Runtime.load(java.lang.String) ， SecurityManager.checkLink(java.lang.String)

      • loadLibrary

        public static void loadLibrary​(String libname)
        加载由libname参数指定的本机库。 libname参数不能包含任何平台特定的前缀，文件扩展名或路径。 如果一个名为libname的本机库与VM静态链接，则调用库导出的JNI_OnLoad_ libname函数。 有关详细信息，请参阅JNI规范。 否则，libname参数从系统库位置加载，并以实现相关的方式映射到本机库映像。

        呼叫System.loadLibrary(name)有效地等同于呼叫

         Runtime.getRuntime().loadLibrary(name)
        参数
        libname - 图书馆的名称。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkLink方法不允许加载指定的动态库
        UnsatisfiedLinkError - 如果libname参数包含文件路径，本机库不会与VM静态链接，或者该库不能由主机系统映射到本机库映像。
        NullPointerException - 如果 libname是 null
        另请参见：
        Runtime.loadLibrary(java.lang.String) ， SecurityManager.checkLink(java.lang.String)

      • mapLibraryName

        public static String mapLibraryName​(String libname)
        将库名称映射到表示本地库的平台特定字符串。
        参数
        libname - 图书馆的名称。
        结果
        平台依赖的本机库名称。
        异常
        NullPointerException - 如果 libname是 null
        从以下版本开始：
        1.2
        另请参见：
        loadLibrary(java.lang.String) ， ClassLoader.findLibrary(java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


System.Logger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface System.Logger

  • Enclosing class:
    System

    public static interface System.Logger
    System.Logger实例日志消息将路由到底层日志框架LoggerFinder使用。

    System.Logger实例通常是从System类获得的，通过调用System.getLogger(loggerName)或System.getLogger(loggerName, bundle) 。

    从以下版本开始：
    9
    另请参见：
    System.getLogger(java.lang.String) ， System.getLogger(java.lang.String, java.util.ResourceBundle) ， System.LoggerFinder

    • Nested Class Summary

      Nested Classes
      Modifier and Type 接口 描述
      static class  System.Logger.Level
      系统loggers级别。

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      String getName​()
      返回此记录器的名称。
      boolean isLoggable​(System.Logger.Level level)
      检查该记录器是否记录给定级别的消息。
      default void log​(System.Logger.Level level, Object obj)
      记录从给定对象生成的消息。
      default void log​(System.Logger.Level level, String msg)
      记录消息。
      default void log​(System.Logger.Level level, String format, Object... params)
      使用可选参数列表记录消息。
      default void log​(System.Logger.Level level, String msg, Throwable thrown)
      记录与给定的可抛弃关联的消息。
      default void log​(System.Logger.Level level, Supplier<String> msgSupplier)
      记录一个懒惰的提供的消息。
      default void log​(System.Logger.Level level, Supplier<String> msgSupplier, Throwable thrown)
      记录与给定的可抛物线相关联的延迟提供的消息。
      void log​(System.Logger.Level level, ResourceBundle bundle, String format, Object... params)
      使用资源束和可选的参数列表记录消息。
      void log​(System.Logger.Level level, ResourceBundle bundle, String msg, Throwable thrown)
      记录与给定的可抛物线相关联的本地化消息。

    • 方法详细信息

      • getName

        String getName​()
        返回此记录器的名称。
        结果
        记录器名称。

      • isLoggable

        boolean isLoggable​(System.Logger.Level level)
        检查该记录器是否记录给定级别的消息。
        参数
        level - 日志消息级别。
        结果
        true如果给定的日志消息级别当前正在被记录。
        异常
        NullPointerException - 如果 level是 null 。

      • log

        default void log​(System.Logger.Level level,
                 String msg)
        记录消息。
        实现要求：
        此方法的默认实现调用 this.log(level, (ResourceBundle)null, msg, (Object[])null);
        参数
        level - 日志消息级别。
        msg - 字符串消息（或消息目录中的一个键，如果此记录器是localized logger ）; 可以是null 。
        异常
        NullPointerException - 如果 level是 null 。

      • log

        default void log​(System.Logger.Level level,
                 Supplier<String> msgSupplier)
        记录一个懒惰的提供的消息。

        如果当前对于给定的日志消息级别启用了记录器，则记录一个消息，该消息是由给定供应商功能产生的结果。 否则，供应商不能运行。

        实现要求：
        当给定级别启用日志记录时，此方法的默认实现将调用 this.log(level, (ResourceBundle)null, msgSupplier.get(), (Object[])null);
        参数
        level - 日志消息级别。
        msgSupplier - 产生消息的供应商功能。
        异常
        NullPointerException -如果 level为 null ，或 msgSupplier为 null 。

      • log

        default void log​(System.Logger.Level level,
                 Object obj)
        记录从给定对象生成的消息。

        如果当前对于给定的日志消息级别启用了记录器，则会记录一条消息，默认情况下是通过在给定对象上调用toString而产生的结果。 否则，对象不能运行。

        实现要求：
        当给定级别启用日志记录时，此方法的默认实现将调用 this.log(level, (ResourceBundle)null, obj.toString(), (Object[])null);
        参数
        level - 日志消息级别。
        obj - 要记录的对象。
        异常
        NullPointerException -如果 level为 null ，或 obj为 null 。

      • log

        default void log​(System.Logger.Level level,
                 String msg,
                 Throwable thrown)
        记录与给定的可抛弃关联的消息。
        实现要求：
        此方法的默认实现调用 this.log(level, (ResourceBundle)null, msg, thrown);
        参数
        level - 日志消息级别。
        msg - 字符串消息（或消息目录中的键，如果此记录器是localized logger ）; 可以是null 。
        thrown - 与日志消息相关联的Throwable ; 可以是null 。
        异常
        NullPointerException - 如果 level是 null 。

      • log

        default void log​(System.Logger.Level level,
                 Supplier<String> msgSupplier,
                 Throwable thrown)
        记录与给定的可抛物线相关联的延迟提供的消息。

        如果当前对于给定的日志消息级别启用了记录器，则记录一个消息，该消息是由给定供应商功能产生的结果。 否则，供应商不能运行。

        实现要求：
        当给定级别启用日志记录时，此方法的默认实现将调用 this.log(level, (ResourceBundle)null, msgSupplier.get(), thrown);
        参数
        level - 其中一个日志消息级标识符。
        msgSupplier - 产生消息的供应商功能。
        thrown - 与日志消息相关联的Throwable ; 可以是null 。
        异常
        NullPointerException -如果 level为 null ，或 msgSupplier为 null 。

      • log

        default void log​(System.Logger.Level level,
                 String format,
                 Object... params)
        使用可选参数列表记录消息。
        实现要求：
        此方法的默认实现调用 this.log(level, (ResourceBundle)null, format, params);
        参数
        level - 其中一个日志消息级标识符。
        format - MessageFormat格式的字符串消息格式（或消息目录中的一个键，如果此记录器是localized logger ）; 可以是null 。
        params - 消息的可选参数列表（可能不是）。
        异常
        NullPointerException - 如果 level是 null 。

      • log

        void log​(System.Logger.Level level,
         ResourceBundle bundle,
         String msg,
         Throwable thrown)
        记录与给定的可抛物线相关联的本地化消息。

        如果给定的资源束不是null ，则使用给定的资源束来对msg字符串进行本地化。 否则msg字符串未本地化。

        参数
        level - 日志消息级别。
        bundle - 本地化的资源包msg ; 可以是null 。
        msg - 字符串消息（或消息目录中的键，如果bundle不是null ）; 可以是null 。
        thrown - 与日志消息相关联的Throwable ; 可以是null 。
        异常
        NullPointerException - 如果 level是 null 。

      • log

        void log​(System.Logger.Level level,
         ResourceBundle bundle,
         String format,
         Object... params)
        使用资源束和可选的参数列表记录消息。

        如果给定的资源束不是null ，则使用给定的资源束来对format字符串进行本地化。 否则format字符串未本地化。

        参数
        level - 日志消息级别。
        bundle - 本地化的资源束format ; 可以是null 。
        format - MessageFormat格式的字符串消息格式（或消息目录中的一个键，如果bundle不是null ）; 可以是null 。
        params - 消息的可选参数列表（可能不是）。
        异常
        NullPointerException - 如果 level是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


System.Logger.Level (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang

Enum System.Logger.Level

  • java.lang.Object
    • java.lang.Enum<System.Logger.Level>
      • java.lang.System.Logger.Level
  • All Implemented Interfaces:
    Serializable ， Comparable<System.Logger.Level>
    Enclosing interface:
    System.Logger

    public static enum System.Logger.Level
extends Enum<System.Logger.Level>
    系统loggers级别。

    A级有name和severity 。 等级值是ALL ， TRACE ， DEBUG ， INFO ， WARNING ， ERROR ， OFF ，通过增加的严重性顺序。
    ALL和OFF是分别映射到Integer.MIN_VALUE和Integer.MAX_VALUE的简单标记。

    严重性值和映射到java.util.logging.Level 。

    System logger levels被映射到java.util.logging levels对应的严重性。
    映射如下：

    System.Logger Severity Level Mapping System.Logger Levels ALL TRACE DEBUG INFO WARNING ERROR OFF java.util.logging Levels ALL FINER FINE INFO WARNING SEVERE OFF
    从以下版本开始：
    9
    另请参见：
    System.LoggerFinder ， System.Logger

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ALL
      指示所有级别都启用的标记。
      DEBUG
      DEBUG级别：通常用于记录调试信息跟踪。
      ERROR
      ERROR级别：通常用于记录错误消息。
      INFO
      INFO级别：通常用于记录信息消息。
      OFF
      指示所有级别都被禁用的标记。
      TRACE
      TRACE级别：通常用于记录诊断信息。
      WARNING
      WARNING级别：通常用于记录警告消息。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getName​()
      返回此级别的名称。
      int getSeverity​()
      返回此级别的严重性。
      static System.Logger.Level valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static System.Logger.Level[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ALL

        public static final System.Logger.Level ALL
        指示所有级别都启用的标记。 该级别severity为Integer.MIN_VALUE 。

      • TRACE

        public static final System.Logger.Level TRACE
        TRACE级别：通常用于记录诊断信息。 该级别severity为400 。

      • DEBUG

        public static final System.Logger.Level DEBUG
        DEBUG级别：通常用于记录调试信息跟踪。 该级别severity为500 。

      • INFO

        public static final System.Logger.Level INFO
        INFO级别：通常用于记录信息消息。 该级别severity为800 。

      • WARNING

        public static final System.Logger.Level WARNING
        WARNING级别：通常用于记录警告消息。 该级别severity是900 。

      • ERROR

        public static final System.Logger.Level ERROR
        ERROR级别：通常用于记录错误消息。 该级别severity是1000 。

      • OFF

        public static final System.Logger.Level OFF
        指示所有级别都被禁用的标记。 该级别severity为Integer.MAX_VALUE 。

    • 方法详细信息

      • values

        public static System.Logger.Level[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (System.Logger.Level c : System.Logger.Level.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static System.Logger.Level valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • getName

        public final String getName​()
        返回此级别的名称。
        结果
        这个级别 Enum.name() 。

      • getSeverity

        public final int getSeverity​()
        返回此级别的严重性。 更严重的意味着更严重的情况。
        结果
        这个级别严重性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


System.LoggerFinder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class System.LoggerFinder

  • java.lang.Object
    • java.lang.System.LoggerFinder
  • Enclosing class:
    System

    public abstract static class System.LoggerFinder
extends Object
    LoggerFinder服务负责创建，管理和配置记录器到其使用的基础框架。

    logger finder是一个具有零参数构造函数的类的具体实现，并实现了该类定义的抽象方法。 从记录器查找器返回的记录器能够将日志消息路由到该提供商支持的日志记录后端。 给定的Java运行时调用维护一个单一的系统范围的LoggerFinder实例，其加载如下：

    • 首先，它找到任何自定义的LoggerFinder提供商使用ServiceLoader工具与system class loader 。
    • 如果没有找到LoggerFinder提供程序，系统将默认使用LoggerFinder实现。

    即使存在java.logging模块 ，应用程序也可以通过简单地提供和声明System.LoggerFinder服务的实现来替换日志后端。

    默认实现

    当java.logging模块出现时，系统默认LoggerFinder实现使用java.util.logging作为后端框架。 它返回一个将日志消息路由到一个java.util.logging.Logger的logger实例。 否则，如果不存在java.logging ，则默认实现将返回一个简单的记录器实例，将将INFO及以上级别的日志消息路由到控制台（ System.err ）。

    日志记录配置

    Logger从LoggerFinder工厂获取的实例不能直接由应用程序配置。 配置是底层日志后端的责任，通常需要使用特定于该后端的API。

    对于使用java.util.logging作为其后端的默认LoggerFinder实现，有关日志配置，请参阅java.util.logging 。 对于缺少java.logging模块的默认LoggerFinder实现返回简单的记录器，配置依赖于实现。

    通常，使用日志框架的应用程序将通过该框架定义（或支持）的记录器外观来记录消息。 希望使用外部框架的应用程序应该登录与该框架相关联的立面。

    需要记录消息的系统类通常将获取System.Logger实例，将消息路由到应用程序选择的日志记录框架。

    只需要记录器来生成日志消息的库和类不应该自己配置记录器，因为这将使它们依赖于特定的LoggerFinder服务的实现。

    此外，当存在安全管理员时，提供给系统类的记录器不应该通过日志后端直接配置，而不需要权限。
    具体的LoggerFinder实现的提供者有责任确保这些LoggerFinder记录器不被不受信任的代码配置，而没有适当的权限检查，因为在这样的记录器上执行的配置通常会影响同一Java运行时的所有应用程序。

    消息级别和映射到后端级别

    记录器查找器负责从System.Logger.Level映射到其使用的日志记录后端支持的级别。
    默认LoggerFinder使用java.util.logging作为后端映射System.Logger级别到java.util.logging级别的相应严重性 - 如Logger.Level中所述 。

    从以下版本开始：
    9
    另请参见：
    System ， System.Logger

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected LoggerFinder​()
      创建一个新的实例 LoggerFinder 。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      System.Logger getLocalizedLogger​(String name, ResourceBundle bundle, Module module)
      返回一个本地化的实例Logger对于给定module 。
      abstract System.Logger getLogger​(String name, Module module)
      为给定的module返回一个Logger的实例。
      static System.LoggerFinder getLoggerFinder​()
      返回 LoggerFinder实例。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LoggerFinder

        protected LoggerFinder​()
        创建一个新的实例 LoggerFinder 。
        Implementation Note:
        建议 LoggerFinder服务实现在其构造函数中不执行任何重的初始化，以避免服务提供商实例化过程中死锁或类加载周期的可能风险。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许 RuntimePermission("loggerFinder") 。

    • 方法详细信息

      • getLogger

        public abstract System.Logger getLogger​(String name,
                                        Module module)
        为给定的module返回一个Logger的实例。
        参数
        name - 记录器的名称。
        module - 正在请求记录器的模块。
        结果
        一个适合在给定模块内使用的logger 。
        异常
        NullPointerException - 如果 name是 null或 module是 null 。
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许 RuntimePermission("loggerFinder") 。

      • getLocalizedLogger

        public System.Logger getLocalizedLogger​(String name,
                                        ResourceBundle bundle,
                                        Module module)
        返回一个本地化的实例Logger对于给定module 。 返回的记录器将使用提供的资源束进行消息定位。
        实现要求：
        默认情况下，此方法调用this.getLogger(name, module)获取记录器，然后将该记录器包装在一个System.Logger实例中，其中所有不采用ResourceBundle作为参数的方法都将重定向到通过给定的bundle进行本地化的方法。 因此，例如，呼叫Logger.log(Level.INFO, msg)将在打包的记录器实例上调用Logger.log(Level.INFO, bundle, msg, (Object[])null) 。 请注意，默认情况下，由Supplier<String>返回的字符串消息将不会本地化，因为假定这样的字符串是已经构建的消息，而不是资源束中的键。

        LoggerFinder的实现可能会覆盖此方法，例如，当底层日志记录后端提供自己的本地化日志消息的机制时，那么这样一个LoggerFinder可以自由返回一个直接使用后端提供的机制的记录器。

        参数
        name - 记录器的名称。
        bundle - 资源束; 可以是null 。
        module - 正在请求记录器的模块。
        结果
        一个Logger的实例，它将使用提供的资源束进行消息定位。
        异常
        NullPointerException - 如果 name为 null或 module为 null 。
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许 RuntimePermission("loggerFinder") 。

      • getLoggerFinder

        public static System.LoggerFinder getLoggerFinder​()
        返回LoggerFinder实例。 Java运行时中有一个单一的系统范围的LoggerFinder实例。 请参阅LoggerFinder实现的位置和加载类的规范。
        结果
        LoggerFinder实例。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许 RuntimePermission("loggerFinder") 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Thread (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Thread

  • java.lang.Object
    • java.lang.Thread
  • All Implemented Interfaces:
    Runnable
    已知直接子类：
    ForkJoinWorkerThread

    public class Thread
extends Object
implements Runnable
    线程是程序中执行的线程。 Java虚拟机允许应用程序同时执行多个执行线程。

    每个线程都有优先权。 具有较高优先级的线程优先于优先级较低的线程执行。 每个线程可能也可能不会被标记为守护程序。 当在一些线程中运行的代码创建一个新的Thread对象时，新线程的优先级最初设置为等于创建线程的优先级，并且当且仅当创建线程是守护进程时才是守护线程。

    当Java虚拟机启动时，通常有一个非守护进程线程（通常调用某个指定类的名称为main的方法）。 Java虚拟机将继续执行线程，直到发生以下任一情况：

    • 该exit类的方法Runtime已经被调用并且安全管理器允许退出操作发生。
    • 不是守护进程线程的所有线程都已经死亡，无论是从调用返回到run方法还是抛出异常，传播超出了run方法。

    创建一个新的执行线程有两种方法。 一个是将一个类声明为一个Thread的子类。 这个子类应该重写run类的方法Thread 。 然后可以分配并启动子类的实例。 例如，计算大于规定值的素数的线程可以写成如下：

         class PrimeThread extends Thread {
         long minPrime;
         PrimeThread(long minPrime) {
             this.minPrime = minPrime;
         }

         public void run() {
             // compute primes larger than minPrime
              . . .
         }
     }

    然后，以下代码将创建一个线程并启动它运行：

         PrimeThread p = new PrimeThread(143);
     p.start();

    创建线程的另一种方法是声明一个实现Runnable接口的类。 那个类然后实现了run方法。 然后可以分配类的实例，在创建Thread时作为参数传递，并启动。 这种其他风格的同一个例子如下所示：

         class PrimeRun implements Runnable {
         long minPrime;
         PrimeRun(long minPrime) {
             this.minPrime = minPrime;
         }

         public void run() {
             // compute primes larger than minPrime
              . . .
         }
     }

    然后，以下代码将创建一个线程并启动它运行：

         PrimeRun p = new PrimeRun(143);
     new Thread(p).start();

    每个线程都有一个用于识别目的的名称。 多个线程可能具有相同的名称。 如果在创建线程时未指定名称，则会为其生成一个新名称。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    从以下版本开始：
    1.0
    另请参见：
    Runnable ， Runtime.exit(int) ， run() ， stop()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Thread.State
      线程状态。
      static interface  Thread.UncaughtExceptionHandler
      当由于未捕获的异常而导致 Thread突然终止时，处理程序的接口被调用。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int MAX_PRIORITY
      线程可以拥有的最大优先级。
      static int MIN_PRIORITY
      线程可以拥有的最小优先级。
      static int NORM_PRIORITY
      分配给线程的默认优先级。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Thread​()
      分配一个新的 Thread对象。
      Thread​(Runnable target)
      分配一个新的 Thread对象。
      Thread​(Runnable target, String name)
      分配一个新的 Thread对象。
      Thread​(String name)
      分配一个新的 Thread对象。
      Thread​(ThreadGroup group, Runnable target)
      分配一个新的 Thread对象。
      Thread​(ThreadGroup group, Runnable target, String name)
      分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于 group引用的线程组。
      Thread​(ThreadGroup group, Runnable target, String name, long stackSize)
      分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，并且属于 group引用的线程组，并具有指定的 堆栈大小 。
      Thread​(ThreadGroup group, Runnable target, String name, long stackSize, boolean inheritThreadLocals)
      分配一个新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于group引用的线程组，具有指定的stackSize ，如果inheritThreadLocals为true ，则继承inheritable thread-local变量的初始值。
      Thread​(ThreadGroup group, String name)
      分配一个新的 Thread对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static int activeCount​()
      返回当前线程的thread group及其子组中活动线程数的估计。
      void checkAccess​()
      确定当前正在运行的线程是否有权限修改此线程。
      protected Object clone​()
      将CloneNotSupportedException作为线程抛出无法有意义地克隆。
      int countStackFrames​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此呼叫的定义取决于suspend() ，该消息已被弃用。 此外，此呼叫的结果从未明确。 此方法在将来的Java SE版本中可能会被删除。
      static Thread currentThread​()
      返回对当前正在执行的线程对象的引用。
      void destroy​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      这种方法最初是为了销毁这个线程而没有任何清理。 它所持有的任何监视器都将保持锁定。 但是，该方法从未实现。 如果要实施，这将是suspend()的方式是非常容易死锁的。 如果目标线程在销毁时保护关键系统资源的锁，则无法再次访问该资源。 如果另一个线程曾尝试锁定此资源，将导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
      static void dumpStack​()
      将当前线程的堆栈跟踪打印到标准错误流。
      static int enumerate​(Thread[] tarray)
      将当前线程的线程组及其子组中的每个活动线程复制到指定的数组中。
      static Map<Thread,StackTraceElement[]> getAllStackTraces​()
      返回所有活动线程的堆栈跟踪图。
      ClassLoader getContextClassLoader​()
      返回此线程的上下文 ClassLoader 。
      static Thread.UncaughtExceptionHandler getDefaultUncaughtExceptionHandler​()
      返回当线程由于未捕获异常突然终止而调用的默认处理程序。
      long getId​()
      返回此线程的标识符。
      String getName​()
      返回此线程的名称。
      int getPriority​()
      返回此线程的优先级。
      StackTraceElement[] getStackTrace​()
      返回表示此线程的堆栈转储的堆栈跟踪元素数组。
      Thread.State getState​()
      返回此线程的状态。
      ThreadGroup getThreadGroup​()
      返回此线程所属的线程组。
      Thread.UncaughtExceptionHandler getUncaughtExceptionHandler​()
      返回由于未捕获的异常，此线程突然终止时调用的处理程序。
      static boolean holdsLock​(Object obj)
      当且仅当当前线程持有指定对象上的监视器锁时，才返回 true 。
      void interrupt​()
      中断这个线程。
      static boolean interrupted​()
      测试当前线程是否已中断。
      boolean isAlive​()
      测试这个线程是否活着。
      boolean isDaemon​()
      测试这个线程是否是守护线程。
      boolean isInterrupted​()
      测试这个线程是否被中断。
      void join​()
      等待这个线程死亡。
      void join​(long millis)
      等待这个线程死亡 millis毫秒。
      void join​(long millis, int nanos)
      等待最多 millis毫秒加上这个线程死亡的 nanos纳秒。
      static void onSpinWait​()
      表示呼叫方暂时无法进行，直到发生其他活动的一个或多个动作。
      void resume​()
      已过时。
      该方法仅适用于suspend() ，由于它是死锁倾向，因此已被弃用。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
      void run​()
      如果这个线程是使用单独的Runnable运行对象构造的，那么这个Runnable对象的run方法被调用; 否则，此方法不执行任何操作并返回。
      void setContextClassLoader​(ClassLoader cl)
      设置此线程的上下文ClassLoader。
      void setDaemon​(boolean on)
      将此线程标记为 daemon线程或用户线程。
      static void setDefaultUncaughtExceptionHandler​(Thread.UncaughtExceptionHandler eh)
      设置当线程由于未捕获的异常突然终止而调用的默认处理程序，并且没有为该线程定义其他处理程序。
      void setName​(String name)
      将此线程的名称更改为等于参数 name 。
      void setPriority​(int newPriority)
      更改此线程的优先级。
      void setUncaughtExceptionHandler​(Thread.UncaughtExceptionHandler eh)
      设置当该线程由于未捕获的异常而突然终止时调用的处理程序。
      static void sleep​(long millis)
      使当前正在执行的线程停留（暂停执行）指定的毫秒数，这取决于系统定时器和调度程序的精度和准确性。
      static void sleep​(long millis, int nanos)
      导致正在执行的线程以指定的毫秒数加上指定的纳秒数来暂停（临时停止执行），这取决于系统定时器和调度器的精度和准确性。
      void start​()
      导致此线程开始执行; Java虚拟机调用此线程的run方法。
      void stop​()
      已过时。
      这种方法本质上是不安全的。 使用Thread.stop停止线程可以解锁所有已锁定的监视器（由于未检查的ThreadDeath异常在堆栈中传播的自然结果）。 如果先前受这些监视器保护的任何对象处于不一致的状态，则损坏的对象将变得对其他线程可见，可能导致任意行为。 stop许多用途应该被替换为只是修改一些变量以指示目标线程应该停止运行的代码。 目标线程应该定期检查此变量，如果变量表示要停止运行，则以有序方式从其运行方法返回。 如果目标线程长时间等待（例如，在条件变量上），则应使用interrupt方法来中断等待。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
      void stop​(Throwable obj)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此方法最初设计为强制线程停止并抛出给定的Throwable作为例外。 它本质上是不安全的（有关详细信息，请参阅stop() ），此外还可用于生成目标线程未准备处理的异常。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
      void suspend​()
      已过时。
      这种方法已被弃用，因为它本身就是死锁的。 如果目标线程在挂起时保护关键系统资源的监视器上的锁定，则在目标线程恢复之前，线程不能访问该资源。 如果要恢复目标线程的线程尝试在调用resume之前锁定此监视器， resume导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
      String toString​()
      返回此线程的字符串表示，包括线程的名称，优先级和线程组。
      static void yield​()
      对调度程序的一个暗示，即当前线程愿意产生当前使用的处理器。

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MIN_PRIORITY

        public static final int MIN_PRIORITY
        线程可以拥有的最小优先级。
        另请参见：
        Constant Field Values

      • NORM_PRIORITY

        public static final int NORM_PRIORITY
        分配给线程的默认优先级。
        另请参见：
        Constant Field Values

      • MAX_PRIORITY

        public static final int MAX_PRIORITY
        线程可以拥有的最大优先级。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Thread

        public Thread​()
        分配一个新的Thread对象。 此构造函数与Thread (null, null, gname)具有相同的效果，其中， gname是新生成的名称。 自动生成的名称的格式为"Thread-"+ n ，其中n是整数。

      • Thread

        public Thread​(Runnable target)
        分配一个新的Thread对象。 此构造函数具有与Thread (null, target, gname)相同的效果，其中， gname是新生成的名称。 自动生成的名称的格式为"Thread-"+ n ，其中n是整数。
        参数
        target - 启动此线程时调用其run方法的对象。 如果null ，这个类run方法什么也没做。

      • Thread

        public Thread​(ThreadGroup group,
              Runnable target)
        分配一个新的Thread对象。 此构造函数具有与Thread (group, target, gname)相同的效果，其中， gname是新生成的名称。 自动生成的名称的格式为"Thread-"+ n ，其中n是整数。
        参数
        group - 线程组。 如果是null并且有一个安全管理员，该组由SecurityManager.getThreadGroup()决定。 如果没有安全管理员或SecurityManager.getThreadGroup()返回null ，该组将设置为当前线程的线程组。
        target - 启动此线程时调用其run方法的对象。 如果是null ，这个线程的run方法被调用。
        异常
        SecurityException - 如果当前线程无法在指定的线程组中创建线程

      • Thread

        public Thread​(String name)
        分配一个新的Thread对象。 此构造函数与Thread (null, null, name)具有相同的效果。
        参数
        name - 新线程的名称

      • Thread

        public Thread​(ThreadGroup group,
              String name)
        分配一个新的Thread对象。 该构造函数与Thread (group, null, name)具有相同的效果。
        参数
        group - 线程组。 如果是null ，还有一个安全管理员，该组由SecurityManager.getThreadGroup()决定。 如果没有安全管理员或SecurityManager.getThreadGroup()返回null ，该组将设置为当前线程的线程组。
        name - 新线程的名称
        异常
        SecurityException - 如果当前线程无法在指定的线程组中创建线程

      • Thread

        public Thread​(Runnable target,
              String name)
        分配一个新的Thread对象。 该构造函数与Thread (null, target, name)具有相同的效果。
        参数
        target - 启动此线程时调用其run方法的对象。 如果是null ，这个线程的run方法被调用。
        name - 新线程的名称

      • Thread

        public Thread​(ThreadGroup group,
              Runnable target,
              String name)
        分配新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于group引用的线程组。

        如果有安全管理器，则使用ThreadGroup作为参数调用其checkAccess方法。

        此外，其checkPermission方法被调用与RuntimePermission("enableContextClassLoaderOverride")时通过将覆盖一个子类的构造直接或间接调用许可getContextClassLoader或setContextClassLoader方法。

        新创建的线程的优先级设置为等于创建线程的优先级，即当前正在运行的线程。 方法setPriority可以用于将优先级改变为新值。

        当且仅当创建它的线程当前被标记为守护线程时，新创建的线程才被初始化为守护线程。 方法setDaemon可以用于改变线程是否是守护进程。

        参数
        group - 线程组。 如果是null并且有一个安全管理器，该组由SecurityManager.getThreadGroup()决定。 如果没有安全管理员或SecurityManager.getThreadGroup()返回null ，则该组将设置为当前线程的线程组。
        target - 启动此线程时调用其run方法的对象。 如果是null ，则调用此线程的run方法。
        name - 新线程的名称
        异常
        SecurityException - 如果当前线程不能在指定的线程组中创建线程，或者不能覆盖上下文类加载器方法。

      • Thread

        public Thread​(ThreadGroup group,
              Runnable target,
              String name,
              long stackSize)
        分配一个新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于由group引用的线程组，并具有指定的堆栈大小 。

        该构造函数与Thread(ThreadGroup,Runnable,String)相同，除了允许指定线程堆栈大小的事实之外。 堆栈大小是虚拟机为该线程的堆栈分配的大致的地址空间字节数。 stackSize参数的影响（如果有的话）与平台有关。

        在某些平台上，为stackSize参数指定较高的值可能允许线程在抛出StackOverflowError之前实现更大的递归深度。 类似地，指定较低的值可能允许更多数量的线程同时存在，而不会抛出OutOfMemoryError （或其他内部错误）。 stackSize参数的值与最大递归深度和并发级别之间的关系的细节与平台相关。 在某些平台上， stackSize参数的值可能没有任何影响。

        虚拟机可以自由地将stackSize参数视为建议。 如果平台的指定值不合理地低，则虚拟机可能会改为使用一些平台特定的最小值; 如果指定的值不合理地高，虚拟机可能会使用一些平台特定的最大值。 同样，虚拟机可以自由地按照合适的方式向上或向下舍入指定的值（或完全忽略它）。

        为stackSize参数指定一个值将导致此构造函数的行为完全像Thread(ThreadGroup, Runnable, String)构造函数。

        由于该构造函数的行为依赖于平台依赖性，因此在使用时应特别小心。 执行给定计算所需的线程栈大小可能会因JRE实现而异。 鉴于这种变化，可能需要仔细调整堆栈大小参数，并且可能需要对要运行应用程序的每个JRE实现重复调整。

        实现说明：鼓励Java平台实现者记录其对stackSize参数的实现行为。

        参数
        group - 线程组。 如果是null并且有一个安全管理员，该组由SecurityManager.getThreadGroup()决定。 如果没有安全管理员或SecurityManager.getThreadGroup()返回null ，该组将设置为当前线程的线程组。
        target - 启动此线程时调用其run方法的对象。 如果是null ，这个线程的run方法被调用。
        name - 新线程的名称
        stackSize - 新线程所需的堆栈大小，或为零表示此参数将被忽略。
        异常
        SecurityException - 如果当前线程无法在指定的线程组中创建线程
        从以下版本开始：
        1.4

      • Thread

        public Thread​(ThreadGroup group,
              Runnable target,
              String name,
              long stackSize,
              boolean inheritThreadLocals)
        分配一个新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于由group引用的线程组，具有指定的stackSize ，并且如果inheritThreadLocals为true ，则继承inheritable thread-local变量的初始值。

        这个构造函数与Thread(ThreadGroup,Runnable,String,long)相同，增加了从构造线程中继承可继承的线程局部变量的初始值的能力。 这允许对可继承线程进行更精细的粒度控制。 传递值为false对于inheritThreadLocals必须小心，因为如果新线程执行期望特定线程本地值的代码可能会导致意外行为。

        为inheritThreadLocals参数指定值为true将导致此构造函数的行为与Thread(ThreadGroup, Runnable, String, long)构造函数完全相同。

        参数
        group - 线程组。 如果是null ，还有一个安全管理员，该组由SecurityManager.getThreadGroup()决定。 如果没有安全管理员或SecurityManager.getThreadGroup()返回null ，则该组将设置为当前线程的线程组。
        target - 启动此线程时调用其run方法的对象。 如果是null ，这个线程的run方法被调用。
        name - 新线程的名称
        stackSize - 新线程所需的堆栈大小，或零表示此参数将被忽略
        inheritThreadLocals - 如果 true从构造线程继承可继承的线程 true初始值，否则不继承初始值
        异常
        SecurityException - 如果当前线程无法在指定的线程组中创建线程
        从以下版本开始：
        9

    • 方法详细信息

      • currentThread

        public static Thread currentThread​()
        返回对当前正在执行的线程对象的引用。
        结果
        当前正在执行的线程。

      • yield

        public static void yield​()
        对调度程序的一个暗示，即当前线程愿意产生当前使用的处理器。 调度程序可以自由地忽略这个提示。

        产量是一种启发式尝试，以改善否则会过度利用CPU的线程之间的相对进度。 其使用应与详细的分析和基准相结合，以确保其具有预期的效果。

        很少使用这种方法。 它可能对调试或测试有用，可能有助于根据竞争条件重现错误。 在设计并发控制结构时，例如java.util.concurrent.locks包中的结构也可能很有用。

      • sleep

        public static void sleep​(long millis)
                  throws InterruptedException
        使当前正在执行的线程停留（暂停执行）指定的毫秒数，这取决于系统定时器和调度程序的精度和准确性。 线程不会丢失任何显示器的所有权。
        参数
        millis - 以毫秒为单位的睡眠时间长度
        异常
        IllegalArgumentException - 如果值为 millis为负数
        InterruptedException - 如果任何线程中断了当前线程。 当抛出此异常时，当前线程的中断状态将被清除。

      • sleep

        public static void sleep​(long millis,
                         int nanos)
                  throws InterruptedException
        导致正在执行的线程以指定的毫秒数加上指定的纳秒数来暂停（临时停止执行），这取决于系统定时器和调度器的精度和准确性。 线程不会丢失任何显示器的所有权。
        参数
        millis - 以毫秒为单位的睡眠时间长度
        nanos - 0-999999额外的纳秒睡眠
        异常
        IllegalArgumentException -如果值 millis是否定的，或的值 nanos不在范围 0-999999
        InterruptedException - 如果任何线程中断了当前线程。 当抛出此异常时，当前线程的中断状态将被清除。

      • onSpinWait

        public static void onSpinWait​()
        表示呼叫方暂时无法进行，直到发生其他活动的一个或多个动作。 通过在自旋等待循环结构的每次迭代中调用此方法，调用线程向运行时指示它正在忙等待。 运行时可能采取措施来提高调用自旋等待循环结构的性能。

        API Note:
        作为一个例子，考虑一个类中的一个方法，旋转一个循环，直到某个标志设置在该方法之外。 应该在旋转循环内部调用onSpinWait方法。
           class EventHandler { volatile boolean eventNotificationNotReceived; void waitForEventAndHandleIt() { while ( eventNotificationNotReceived ) { java.lang.Thread.onSpinWait(); } readAndProcessEvent(); } void readAndProcessEvent() { // Read event from some source and process it . . . } }

        上面的代码将保持正确，即使没有调用onSpinWait方法。 然而，在某些架构上，Java虚拟机可能会以更有益的方式发布处理器指令来解决这些代码模式。

        从以下版本开始：
        9

      • clone

        protected Object clone​()
                throws CloneNotSupportedException
        将CloneNotSupportedException作为线程抛出无法有意义地克隆。 构造一个新的线程。
        重写：
        clone在类 Object
        结果
        这个实例的一个克隆。
        异常
        CloneNotSupportedException - 永远
        另请参见：
        Cloneable

      • start

        public void start​()
        导致此线程开始执行; Java虚拟机调用此线程的run方法。

        结果是两个线程同时运行：当前线程（从调用返回到start方法）和另一个线程（执行其run方法）。

        不止一次启动线程是不合法的。 特别地，一旦线程完成执行，可能不会重启线程。

        异常
        IllegalThreadStateException - 如果线程已经启动。
        另请参见：
        run() ， stop()

      • run

        public void run​()
        如果这个线程使用单独的Runnable运行对象构造，那么这个Runnable对象的run方法被调用; 否则，此方法不执行任何操作并返回。

        Thread子类应该覆盖此方法。

        Specified by:
        run在接口 Runnable
        另请参见：
        start() ，
stop() ，
Thread(ThreadGroup, Runnable, String)

      • stop

        @Deprecated(since="1.2")
public final void stop​()
        已过时。 这种方法本质上是不安全的。 使用Thread.stop停止线程会使其解锁所有已锁定的监视器（由于未检查的ThreadDeath异常在堆栈中传播的自然结果）。 如果先前受这些监视器保护的任何对象处于不一致的状态，则损坏的对象将变得对其他线程可见，可能导致任意行为。 stop许多用途应该被代码简单地修改一些变量来表示目标线程应该停止运行。 目标线程应该定期检查此变量，如果变量表示要停止运行，则以有序方式从其运行方法返回。 如果目标线程等待很长时间（例如，在条件变量上），则应该使用interrupt方法来中断等待。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
        强制线程停止执行。

        如果安装了一个安全管理器，它的checkAccess方法将以this作为参数来调用。 这可能会导致一个SecurityException被提升（在当前线程中）。

        如果此线程与当前线程不同（即当前线程正试图停止除本身线程之外的线程），则另外还会调用安全管理器的checkPermission方法（带有RuntimePermission("stopThread")参数）。 再次，这可能会导致抛出一个SecurityException （在当前线程中）。

        此线程代表的线程都被迫停止不管它是异常做，并抛出一个新创建ThreadDeath对象，作为异常。

        允许停止尚未启动的线程。 如果线程最终启动，它将立即终止。

        应用程序通常不应试图捕获ThreadDeath ，除非它必须做一些特殊的清理操作（注意，投掷ThreadDeath原因finally的条款try要执行的语句在线程正式死亡之前）。 如果一个catch子句捕获一个ThreadDeath对象，重要的是重新抛出该对象，使线程实际上死亡。

        如果未捕获的异常是ThreadDeath一个实例， ThreadDeath顶层错误处理程序对其他未捕获的异常做出反应不会打印出消息或以其他方式通知应用程序。

        异常
        SecurityException - 如果当前线程不能修改此线程。
        另请参见：
        interrupt() ， checkAccess() ， run() ， start() ， ThreadDeath ， ThreadGroup.uncaughtException(Thread,Throwable) ， SecurityManager.checkAccess(Thread) ， SecurityManager.checkPermission(java.security.Permission)

      • stop

        @Deprecated(since="1.2",
            forRemoval=true)
public final void stop​(Throwable obj)
        不推荐用于删除：此API元素将在以后的版本中被删除。 该方法最初设计为强制线程停止并抛出给定的Throwable作为例外。 它本质上是不安全的（有关详细信息，请参阅stop() ），此外还可用于生成目标线程未准备处理的异常。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
        抛出 UnsupportedOperationException 。
        参数
        obj - 忽略

      • interrupt

        public void interrupt​()
        中断这个线程。

        除非当前的线程中断自身，这是始终允许的，所以调用此线程的checkAccess方法，这可能会导致抛出SecurityException 。

        如果该线程阻塞的调用wait() ， wait(long) ，或wait(long, int)的方法Object类，或者在join() ， join(long) ， join(long, int) ， sleep(long) ，或sleep(long, int) ，这个类的方法，那么它的中断状态将被清除，并且将收到一个InterruptedException 。

        如果这个线程在一个InterruptibleChannel的I / O操作中被阻塞，那么通道将被关闭，线程的中断状态将被设置，线程将接收一个ClosedByInterruptException 。

        如果该线程在Selector中被阻塞，则线程的中断状态将被设置，并且它将从选择操作立即返回，可能具有非零值，就像调用了选择器的wakeup方法一样。

        如果以前的条件都不成立，则该线程的中断状态将被设置。

        中断不存在的线程不需要任何效果。

        异常
        SecurityException - 如果当前线程不能修改此线程

      • interrupted

        public static boolean interrupted​()
        测试当前线程是否已中断。 该方法可以清除线程的中断状态 。 换句话说，如果这个方法被连续调用两次，那么第二个调用将返回false（除非当前线程再次中断，在第一个调用已经清除其中断状态之后，在第二个调用之前已经检查过）。

        忽略线程中断，因为线程在中断时不存在将被该方法返回false所反映。

        结果
        true如果当前线程已被中断; 否则为false 。
        另请参见：
        isInterrupted()

      • isInterrupted

        public boolean isInterrupted​()
        测试这个线程是否被中断。 线程的中断状态不受此方法的影响。

        忽略线程中断，因为线程在中断时不存在将被该方法返回false所反映。

        结果
        true如果这个线程已被中断; 否则为false 。
        另请参见：
        interrupted()

      • destroy

        @Deprecated(since="1.5",
            forRemoval=true)
public void destroy​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 这种方法最初是为了销毁这个线程而没有任何清理。 它所持有的任何监视器都将保持锁定。 但是，该方法从未实现。 如果要实施，这将是suspend()的方式是死锁的 。 如果目标线程在销毁时保护关键系统资源的锁，则无法再次访问该资源。 如果另一个线程曾尝试锁定此资源，将导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
        投掷NoSuchMethodError 。
        异常
        NoSuchMethodError - 永远

      • isAlive

        public final boolean isAlive​()
        测试这个线程是否活着。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。
        结果
        true如果这个线程还活着; 否则为false 。

      • suspend

        @Deprecated(since="1.2")
public final void suspend​()
        已过时。 这种方法已被弃用，因为它本身就是死锁的。 如果目标线程在挂起时保护关键系统资源的监视器上的锁定，则在目标线程恢复之前，线程不能访问该资源。 如果要恢复目标线程的线程在调用resume之前尝试锁定此监视器， resume导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
        暂停这个线程。

        首先，这个线程的checkAccess方法被调用，没有参数。 这可能会导致抛出一个SecurityException （在当前线程中）。

        如果线程活着，它将被暂停，并且不会进一步进行，除非和直到恢复。

        异常
        SecurityException - 如果当前线程不能修改此线程。
        另请参见：
        checkAccess()

      • resume

        @Deprecated(since="1.2")
public final void resume​()
        已过时。 此方法仅适用于suspend() ，由于它是死锁倾向，因此已被弃用。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
        恢复挂起的线程。

        首先，这个线程的checkAccess方法被调用没有参数。 这可能会导致抛出一个SecurityException （在当前线程中）。

        如果线程存活但被暂停，则它被恢复并被允许在其执行中取得进展。

        异常
        SecurityException - 如果当前线程不能修改此线程。
        另请参见：
        checkAccess() ， suspend()

      • setPriority

        public final void setPriority​(int newPriority)
        更改此线程的优先级。

        首先，这个线程的checkAccess方法被调用没有参数。 这可能会导致抛出SecurityException 。

        否则，该线程的优先级设置为指定的newPriority较小的线程和线程组的最大允许优先级。

        参数
        newPriority - 设置此线程的优先级
        异常
        IllegalArgumentException - 如果优先级不在 MIN_PRIORITY到 MAX_PRIORITY范围内。
        SecurityException - 如果当前线程不能修改此线程。
        另请参见：
        getPriority() ，
checkAccess() ，
getThreadGroup() ，
MAX_PRIORITY ，
MIN_PRIORITY ，
ThreadGroup.getMaxPriority()

      • getPriority

        public final int getPriority​()
        返回此线程的优先级。
        结果
        这个线程的优先级。
        另请参见：
        setPriority(int)

      • setName

        public final void setName​(String name)
        将此线程的名称更改为等于参数name 。

        首先，这个线程的checkAccess方法被调用没有参数。 这可能会导致抛出一个SecurityException 。

        参数
        name - 这个线程的新名称。
        异常
        SecurityException - 如果当前线程不能修改此线程。
        另请参见：
        getName() ， checkAccess()

      • getName

        public final String getName​()
        返回此线程的名称。
        结果
        这个线程的名字。
        另请参见：
        setName(String)

      • getThreadGroup

        public final ThreadGroup getThreadGroup​()
        返回此线程所属的线程组。 如果线程已经死机（停止），此方法返回null。
        结果
        这个线程的线程组。

      • activeCount

        public static int activeCount​()
        返回当前线程的thread group及其子组中活动线程数的估计。 递归地遍历当前线程的线程组中的所有子组。

        返回的值只是一个估计，因为线程数可能会在此方法遍历内部数据结构时动态更改，并可能受某些系统线程的影响。 此方法主要用于调试和监视。

        结果
        对当前线程的线程组和任何其他线程组中当前线程的线程组作为祖先的活动线程数的估计

      • enumerate

        public static int enumerate​(Thread[] tarray)
        将当前线程的线程组及其子组中的每个活动线程复制到指定的数组中。 该方法简单地调用当前线程的线程组的ThreadGroup.enumerate(Thread[])方法。

        应用程序可能会使用activeCount方法来估计数组的大小，但是如果数组太短而不能容纳所有线程，则会忽略额外的线程。 如果获取当前线程组及其子组中的每个活动线程至关重要，则调用者应验证返回的int值是否严格小于tarray的长度。

        由于本方法中固有的竞争条件，建议该方法仅用于调试和监控。

        参数
        tarray - 放置线程列表的数组
        结果
        放入数组的线程数
        异常
        SecurityException - 如果 ThreadGroup.checkAccess()确定当前线程不能访问其线程组

      • countStackFrames

        @Deprecated(since="1.2",
            forRemoval=true)
public int countStackFrames​()
        不推荐用于删除：此API元素将在以后的版本中被删除。 此呼叫的定义取决于suspend() ，已被弃用。 此外，此呼叫的结果从未明确。 此方法在将来的Java SE版本中可能会被删除。
        计算此线程中的堆栈帧数。 线程必须暂停。
        结果
        此线程中的堆栈帧数。
        异常
        IllegalThreadStateException - 如果此线程未挂起。
        另请参见：
        StackWalker

      • join

        public final void join​(long millis)
                throws InterruptedException
        等待这个线程死亡最多millis毫秒。 超时时间为0意味着永远等待。

        这个实现使用一个this.wait调用的循环，条件是this.isAlive 。 当线程终止时，将调用this.notifyAll方法。 建议应用程序不使用wait ， notify ，或notifyAll上Thread实例。

        参数
        millis - 以毫秒为单位等待的时间
        异常
        IllegalArgumentException - 如果值为 millis为负数
        InterruptedException - 如果任何线程中断当前线程。 当抛出此异常时，当前线程的中断状态将被清除。

      • join

        public final void join​(long millis,
                       int nanos)
                throws InterruptedException
        等待最多millis毫秒加上这个线程死亡的nanos纳秒。

        这个实现使用了一个this.wait调用的循环，条件是this.isAlive 。 当线程终止时，将调用this.notifyAll方法。 建议应用程序不使用wait ， notify ，或notifyAll上Thread实例。

        参数
        millis - 以毫秒为单位等待的时间
        nanos - 0-999999等待的额外纳秒
        异常
        IllegalArgumentException -如果值 millis是否定的，或的值 nanos不在范围 0-999999
        InterruptedException - 如果任何线程中断当前线程。 当抛出此异常时，当前线程的中断状态将被清除。

      • join

        public final void join​()
                throws InterruptedException
        等待这个线程死亡。

        调用此方法的行为方式与调用完全相同

        join (0)
        异常
        InterruptedException - 如果任何线程中断了当前线程。 当抛出此异常时，当前线程的中断状态将被清除。

      • dumpStack

        public static void dumpStack​()
        将当前线程的堆栈跟踪打印到标准错误流。 此方法仅用于调试。

      • setDaemon

        public final void setDaemon​(boolean on)
        将此线程标记为daemon线程或用户线程。 当运行的唯一线程都是守护进程线程时，Java虚拟机将退出。

        线程启动前必须调用此方法。

        参数
        on - 如果是 true ，将此线程标记为守护线程
        异常
        IllegalThreadStateException - 如果这个线程是 alive
        SecurityException - 如果 checkAccess()确定当前线程不能修改此线程

      • isDaemon

        public final boolean isDaemon​()
        测试这个线程是否是守护线程。
        结果
        true如果这个线程是一个守护线程; 否则为false 。
        另请参见：
        setDaemon(boolean)

      • checkAccess

        public final void checkAccess​()
        确定当前正在运行的线程是否有权限修改此线程。

        如果有一个安全管理器，它的checkAccess方法被调用这个线程作为它的参数。 这可能会导致抛出一个SecurityException 。

        异常
        SecurityException - 如果当前线程不允许访问此线程。
        另请参见：
        SecurityManager.checkAccess(Thread)

      • toString

        public String toString​()
        返回此线程的字符串表示，包括线程的名称，优先级和线程组。
        重写：
        toString在 Object
        结果
        这个线程的字符串表示形式。

      • getContextClassLoader

        public ClassLoader getContextClassLoader​()
        返回此线程的上下文ClassLoader 。 上下文ClassLoader由加载类和资源的在线程中运行的代码使用的线程的创建者提供。 如果不是set ，默认是父线程的ClassLoader上下文。 原始线程的上下文ClassLoader通常设置为用于加载应用程序的类加载器。
        结果
        该线程的上下文为 ClassLoader ，或 null指示系统类加载器（或者，失败的是引导类加载器）
        异常
        SecurityException - 如果存在安全管理员，并且调用者的类加载器不是null并且与上下文类加载器的祖先不相同或不存在，并且主叫方不具有RuntimePermission ("getClassLoader")
        从以下版本开始：
        1.2

      • setContextClassLoader

        public void setContextClassLoader​(ClassLoader cl)
        设置此线程的上下文ClassLoader。 当创建线程时，可以设置上下文ClassLoader，并允许线程的创建者通过getContextClassLoader提供适当的类加载器，以便在加载类和资源时在线程中运行的代码。

        如果存在安全管理员，则其checkPermission方法将被调用，具有RuntimePermission ("setContextClassLoader")权限，以查看是否允许设置上下文ClassLoader。

        参数
        cl - 此线程的上下文ClassLoader，或指示系统类加载器的空值（或者，失败的是引导类加载器）
        异常
        SecurityException - 如果当前线程不能设置上下文ClassLoader
        从以下版本开始：
        1.2

      • holdsLock

        public static boolean holdsLock​(Object obj)
        当且仅当当前线程保存指定对象上的监视器锁时，返回true 。

        该方法旨在允许程序断言当前线程已经保存指定的锁：

          assert Thread.holdsLock(obj);
        参数
        obj - 测试锁拥有权的对象
        结果
        true如果当前线程保持指定对象上的监视器锁定。
        异常
        NullPointerException - 如果obj是 null
        从以下版本开始：
        1.4

      • getStackTrace

        public StackTraceElement[] getStackTrace​()
        返回表示此线程的堆栈转储的堆栈跟踪元素数组。 该方法将返回一个零长度的数组，如果该线程尚未启动，已启动但尚未被计划运行，或已终止。 如果返回的数组非零长度，则数组的第一个元素表示堆栈的顶部，这是序列中最近的方法调用。 数组的最后一个元素表示堆栈的底部，这是序列中最近最少的方法调用。

        如果有一个安全管理器，并且这个线程不是当前的线程，那么安全管理器的checkPermission方法被调用一个RuntimePermission("getStackTrace")权限来查看是否可以获取堆栈跟踪。

        在某些情况下，某些虚拟机可能从堆栈跟踪中省略一个或多个堆栈帧。 在极端情况下，允许没有关于该线程的堆栈跟踪信息的虚拟机从该方法返回零长度数组。

        结果
        一个 StackTraceElement的数组，每个代表一个堆栈帧。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许获取线程的堆栈跟踪。
        从以下版本开始：
        1.5
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission ， Throwable.getStackTrace()

      • getAllStackTraces

        public static Map<Thread,StackTraceElement[]> getAllStackTraces​()
        返回所有活动线程的堆栈跟踪图。 映射键是线程，每个映射值是一个StackTraceElement的数组，表示相应的Thread的堆栈转储。 返回的堆栈跟踪的格式为getStackTrace方法指定的格式。

        线程可能正在执行，而此方法被调用。 每个线程的堆栈跟踪仅表示快照，并且可以在不同时间获取每个堆栈跟踪。 如果虚拟机没有关于线程的堆栈跟踪信息，则将在地图值中返回零长度的数组。

        如果有安全管理员，那么安全管理员的checkPermission方法将被调用，具有RuntimePermission("getStackTrace")权限以及RuntimePermission("modifyThreadGroup")权限，以查看是否可以获取所有线程的堆栈跟踪。

        结果
        一个 Map从 Thread到阵列 StackTraceElement表示相应线程的堆栈跟踪。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许获取线程的堆栈跟踪。
        从以下版本开始：
        1.5
        另请参见：
        getStackTrace() ， SecurityManager.checkPermission(java.security.Permission) ， RuntimePermission ， Throwable.getStackTrace()

      • getId

        public long getId​()
        返回此线程的标识符。 线程ID是创建此线程时生成的正数long号。 线程ID是唯一的，并且在其生命周期内保持不变。 当线程被终止时，该线程ID可以被重用。
        结果
        这个线程的ID。
        从以下版本开始：
        1.5

      • getState

        public Thread.State getState​()
        返回此线程的状态。 该方法设计用于监视系统状态，不用于同步控制。
        结果
        这个线程的状态。
        从以下版本开始：
        1.5

      • setDefaultUncaughtExceptionHandler

        public static void setDefaultUncaughtExceptionHandler​(Thread.UncaughtExceptionHandler eh)
        设置当线程由于未捕获的异常突然终止而调用的默认处理程序，并且没有为该线程定义其他处理程序。

        未捕获的异常处理首先由线程控制，然后由线程的ThreadGroup对象控制，最后由默认的未捕获异常处理程序控制 。 如果线程没有明确的未捕获异常处理程序集，并且线程的线程组（包括父线程组）不专门化其uncaughtException方法，则将调用默认处理程序的uncaughtException方法。

        通过设置默认未捕获的异常处理程序，应用程序可以更改未被捕获的异常处理方式（如日志记录到特定设备或文件），这些线程将已经接受了系统提供的任何“默认”行为。

        请注意，默认未捕获的异常处理程序通常不会延迟到线程的ThreadGroup对象，因为这可能导致无限递归。

        参数
        eh - 用作默认未捕获异常处理程序的对象。 如果null那么没有默认处理程序。
        异常
        SecurityException - 如果安全管理员存在并且它拒绝RuntimePermission ("setDefaultUncaughtExceptionHandler")
        从以下版本开始：
        1.5
        另请参见：
        setUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler) ，
getUncaughtExceptionHandler() ，
ThreadGroup.uncaughtException(java.lang.Thread, java.lang.Throwable)

      • getDefaultUncaughtExceptionHandler

        public static Thread.UncaughtExceptionHandler getDefaultUncaughtExceptionHandler​()
        返回当线程由于未捕获异常突然终止而调用的默认处理程序。 如果返回值为null ，则没有默认值。
        结果
        所有线程的默认未捕获的异常处理程序
        从以下版本开始：
        1.5
        另请参见：
        setDefaultUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler)

      • getUncaughtExceptionHandler

        public Thread.UncaughtExceptionHandler getUncaughtExceptionHandler​()
        返回由于未捕获的异常，此线程突然终止时调用的处理程序。 如果此线程没有明确设置未捕获的异常处理程序，则返回此线程的ThreadGroup对象，除非此线程已终止，否则返回null 。
        结果
        该线程的未捕获的异常处理程序
        从以下版本开始：
        1.5

      • setUncaughtExceptionHandler

        public void setUncaughtExceptionHandler​(Thread.UncaughtExceptionHandler eh)
        设置当该线程由于未捕获的异常而突然终止时调用的处理程序。

        线程可以完全控制如何通过明确设置其未捕获的异常处理来响应未捕获的异常。 如果没有设置这样的处理程序，那么线程的ThreadGroup对象就会作为它的处理程序。

        参数
        eh - 用作此线程未捕获的异常处理程序的对象。 如果null那么这个线程没有明确的处理程序。
        异常
        SecurityException - 如果当前线程不允许修改此线程。
        从以下版本开始：
        1.5
        另请参见：
        setDefaultUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler) ， ThreadGroup.uncaughtException(java.lang.Thread, java.lang.Throwable)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Thread.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang

Enum Thread.State

  • java.lang.Object
    • java.lang.Enum<Thread.State>
      • java.lang.Thread.State
  • All Implemented Interfaces:
    Serializable ， Comparable<Thread.State>
    Enclosing class:
    Thread

    public static enum Thread.State
extends Enum<Thread.State>
    线程状态。 线程可以处于以下状态之一：
    • NEW
      尚未启动的线程处于此状态。
    • RUNNABLE
      在Java虚拟机中执行的线程处于此状态。
    • BLOCKED
      被阻塞等待监视器锁定的线程处于此状态。
    • WAITING
      正在等待另一个线程执行特定动作的线程处于此状态。
    • TIMED_WAITING
      正在等待另一个线程执行动作达到指定等待时间的线程处于此状态。
    • TERMINATED
      已退出的线程处于此状态。

    一个线程可以在给定时间点处于一个状态。 这些状态是不反映任何操作系统线程状态的虚拟机状态。

    从以下版本开始：
    1.5
    另请参见：
    Thread.getState()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      BLOCKED
      一个线程的线程状态阻塞等待监视器锁定。
      NEW
      线程尚未启动的线程状态。
      RUNNABLE
      可运行线程的线程状态。
      TERMINATED
      终止线程的线程状态。
      TIMED_WAITING
      具有指定等待时间的等待线程的线程状态。
      WAITING
      等待线程的线程状态

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Thread.State valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Thread.State[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NEW

        public static final Thread.State NEW
        线程尚未启动的线程状态。

      • RUNNABLE

        public static final Thread.State RUNNABLE
        可运行线程的线程状态。 可运行状态的线程正在Java虚拟机中执行，但它可能正在等待来自操作系统（例如处理器）的其他资源。

      • BLOCKED

        public static final Thread.State BLOCKED
        一个线程的线程状态阻塞等待监视器锁定。 处于阻塞状态的线程正在等待监视器锁定进入同步块/方法，或者在调用Object.wait后重新输入同步的块/方法。

      • WAITING

        public static final Thread.State WAITING
        等待线程的线程状态 由于调用以下方法之一，线程处于等待状态：
        • Object.wait没有超时
        • Thread.join没有超时
        • LockSupport.park

        等待状态的线程正在等待另一个线程执行特定的动作。 例如，一个已调用线程Object.wait()的对象上正在等待另一个线程来调用Object.notify()或Object.notifyAll()该对象上。 一个调用Thread.join()线程正在等待指定的线程终止。

      • TIMED_WAITING

        public static final Thread.State TIMED_WAITING
        具有指定等待时间的等待线程的线程状态。 线程处于定时等待状态，因为在指定的正等待时间内调用以下方法之一：
        • Thread.sleep
        • Object.wait与超时
        • Thread.join与超时
        • LockSupport.parkNanos
        • LockSupport.parkUntil

      • TERMINATED

        public static final Thread.State TERMINATED
        终止线程的线程状态。 线程已完成执行。

    • 方法详细信息

      • values

        public static Thread.State[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Thread.State c : Thread.State.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Thread.State valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Thread.UncaughtExceptionHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Interface Thread.UncaughtExceptionHandler

  • 所有已知实现类：
    ThreadGroup
    Enclosing class:
    Thread
    Functional Interface:
    这是一个功能界面，因此可以用作lambda表达式或方法引用的赋值对象。

    @FunctionalInterface
public static interface Thread.UncaughtExceptionHandler
    当由于未捕获的异常而导致Thread突然终止时，处理程序的接口被调用。

    当一个线程要终止由于未捕获到异常的Java虚拟机将查询线程其UncaughtExceptionHandler使用Thread.getUncaughtExceptionHandler() ，将调用处理程序的uncaughtException方法，将线程和异常作为参数。 如果一个线程一直没有其UncaughtExceptionHandler明确设置，那么它ThreadGroup对象充当其UncaughtExceptionHandler 。 如果ThreadGroup对象没有处理异常的特殊要求，则可以将调用转发到default uncaught exception handler 。

    从以下版本开始：
    1.5
    另请参见：
    Thread.setDefaultUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler) ，
Thread.setUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler) ，
ThreadGroup.uncaughtException(java.lang.Thread, java.lang.Throwable)

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void uncaughtException​(Thread t, Throwable e)
      当给定的线程由于给定的未捕获异常而终止时调用方法。

    • 方法详细信息

      • uncaughtException

        void uncaughtException​(Thread t,
                       Throwable e)
        当给定的线程由于给定的未捕获异常而终止时调用方法。

        Java虚拟机将忽略此方法抛出的任何异常。

        参数
        t - 线程
        e - 例外
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadDeath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ThreadDeath

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.ThreadDeath
  • All Implemented Interfaces:
    Serializable

    public class ThreadDeath
extends Error
    当调用（不推荐使用）的Thread.stop()方法时， ThreadDeath的实例被抛出在受害者线程中。

    应用程序只能在异步终止之后清除该类的实例。 如果ThreadDeath被一个方法所捕获，那么重要的是它被重新引导，使得线程实际上死亡。

    该top-level error handler如果没有打印出一条消息ThreadDeath是从来没有抓到。

    类ThreadDeath具体的子类Error而不是异常 ，即使它是一个“正常现象”，因为许多应用程序赶上所有出现异常 ，然后丢弃异常。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ThreadDeath​()

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ThreadDeath

        public ThreadDeath​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ThreadGroup

  • java.lang.Object
    • java.lang.ThreadGroup
  • All Implemented Interfaces:
    Thread.UncaughtExceptionHandler

    public class ThreadGroup
extends Object
implements Thread.UncaughtExceptionHandler
    线程组代表一组线程。 此外，线程组还可以包括其他线程组。 线程组形成一个树，除了初始线程组之外，每个线程组都有一个父进程。

    允许线程访问有关其线程组的信息，但不能访问有关其线程组的父线程组或任何其他线程组的信息。

    从以下版本开始：
    1.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      ThreadGroup​(String name)
      构造一个新的线程组。
      ThreadGroup​(ThreadGroup parent, String name)
      创建一个新的线程组。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      int activeCount​()
      返回此线程组及其子组中活动线程数的估计。
      int activeGroupCount​()
      返回此线程组及其子组中活动组数的估计。
      boolean allowThreadSuspension​(boolean b)
      已过时。
      此呼叫的定义取决于suspend() ，已被弃用。 此外，从未指定此调用的行为。
      void checkAccess​()
      确定当前运行的线程是否有权限修改此线程组。
      void destroy​()
      销毁此线程组及其所有子组。
      int enumerate​(Thread[] list)
      将此线程组及其子组中的每个活动线程复制到指定的数组中。
      int enumerate​(Thread[] list, boolean recurse)
      将此线程组中的每个活动线程复制到指定的数组中。
      int enumerate​(ThreadGroup[] list)
      复制到该线程组及其子组中每个活动子组的指定数组引用。
      int enumerate​(ThreadGroup[] list, boolean recurse)
      复制到该线程组中每个活动子组的指定数组引用。
      int getMaxPriority​()
      返回此线程组的最大优先级。
      String getName​()
      返回此线程组的名称。
      ThreadGroup getParent​()
      返回此线程组的父级。
      void interrupt​()
      中断此线程组中的所有线程。
      boolean isDaemon​()
      测试此线程组是否是守护线程组。
      boolean isDestroyed​()
      测试此线程组是否已被破坏。
      void list​()
      将有关此线程组的信息打印到标准输出。
      boolean parentOf​(ThreadGroup g)
      测试此线程组是线程组参数还是其祖先线程组之一。
      void resume​()
      已过时。
      这种方法仅与Thread.suspend和ThreadGroup.suspend一起使用，因为它们本质上是死锁易发生的，因为它们已经被弃用。 详见Thread.suspend() 。
      void setDaemon​(boolean daemon)
      更改此线程组的守护程序状态。
      void setMaxPriority​(int pri)
      设置组的最大优先级。
      void stop​()
      已过时。
      这种方法本质上是不安全的。 详见Thread.stop() 。
      void suspend​()
      已过时。
      这种方法本质上是死锁的。 详见Thread.suspend() 。
      String toString​()
      返回此Thread组的字符串表示形式。
      void uncaughtException​(Thread t, Throwable e)
      当该线程组中的线程由于未捕获的异常而停止时，由Java虚拟机调用，并且线程没有安装特定的Thread.UncaughtExceptionHandler 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ThreadGroup

        public ThreadGroup​(String name)
        构造一个新的线程组。 此新组的父项是当前正在运行的线程的线程组。

        checkAccess父线程组的checkAccess方法，无参数; 这可能会导致安全异常。

        参数
        name - 新线程组的名称。
        异常
        SecurityException - 如果当前线程无法在指定的线程组中创建线程。
        从以下版本开始：
        1.0
        另请参见：
        checkAccess()

      • ThreadGroup

        public ThreadGroup​(ThreadGroup parent,
                   String name)
        创建一个新的线程组。 这个新组的父对象是指定的线程组。

        checkAccess父线程组的checkAccess方法，没有参数; 这可能会导致安全异常。

        参数
        parent - 父线程组。
        name - 新线程组的名称。
        异常
        NullPointerException - 如果线程组参数是 null 。
        SecurityException - 如果当前线程无法在指定的线程组中创建线程。
        从以下版本开始：
        1.0
        另请参见：
        SecurityException ， checkAccess()

    • 方法详细信息

      • getName

        public final String getName​()
        返回此线程组的名称。
        结果
        该线程组的名称。
        从以下版本开始：
        1.0

      • getParent

        public final ThreadGroup getParent​()
        返回此线程组的父级。

        首先，如果父对象不是null ，则调用父线程组的checkAccess方法，不带参数; 这可能会导致安全异常。

        结果
        这个线程组的父项。 顶级线程组是唯一的线程组，其父级为null 。
        异常
        SecurityException - 如果当前线程不能修改此线程组。
        从以下版本开始：
        1.0
        另请参见：
        checkAccess() ， SecurityException ， RuntimePermission

      • getMaxPriority

        public final int getMaxPriority​()
        返回此线程组的最大优先级。 作为此组的一部分的线程的优先级不能高于最大优先级。
        结果
        此线程组中的线程可以具有的最大优先级。
        从以下版本开始：
        1.0
        另请参见：
        setMaxPriority(int)

      • isDaemon

        public final boolean isDaemon​()
        测试此线程组是否是守护线程组。 守护进程线程组最后一个线程停止或最后一个线程组被销毁时自动销毁。
        结果
        true如果这个线程组是守护线程组; 否则为false 。
        从以下版本开始：
        1.0

      • isDestroyed

        public boolean isDestroyed​()
        测试此线程组是否已被破坏。
        结果
        如果此对象被销毁，则为true
        从以下版本开始：
        1.1

      • setDaemon

        public final void setDaemon​(boolean daemon)
        更改此线程组的守护程序状态。

        首先，这个线程组的checkAccess方法被调用，没有参数; 这可能会导致安全异常。

        守护进程线程组最后一个线程停止或最后一个线程组被销毁时自动销毁。

        参数
        daemon - 如果是true ，将该线程组标记为守护线程组; 否则，将该线程组标记为正常。
        异常
        SecurityException - 如果当前线程不能修改此线程组。
        从以下版本开始：
        1.0
        另请参见：
        SecurityException ， checkAccess()

      • setMaxPriority

        public final void setMaxPriority​(int pri)
        设置组的最大优先级。 线程组中具有较高优先级的线程不受影响。

        首先，这个线程组的checkAccess方法被调用，没有参数; 这可能会导致安全异常。

        如果pri参数小于Thread.MIN_PRIORITY或大于Thread.MAX_PRIORITY ，则组的最大优先级保持不变。

        否则，此ThreadGroup对象的优先级设置为指定的pri的较小者以及此线程组的父级的最大允许优先级。 （如果该线程组是没有父级的系统线程组，则其最大优先级被简单地设置为pri 。然后，这个方法被递归地调用，对于属于此线程组的每个线程组，以pri作为参数。

        参数
        pri - 线程组的新优先级。
        异常
        SecurityException - 如果当前线程不能修改此线程组。
        从以下版本开始：
        1.0
        另请参见：
        getMaxPriority() ， SecurityException ， checkAccess()

      • parentOf

        public final boolean parentOf​(ThreadGroup g)
        测试此线程组是线程组参数还是其祖先线程组之一。
        参数
        g - 一个线程组。
        结果
        true如果此线程组是线程组参数或其祖先线程组之一; 否则为false 。
        从以下版本开始：
        1.0

      • checkAccess

        public final void checkAccess​()
        确定当前运行的线程是否有权限修改此线程组。

        如果有安全管理器，则使用该线程组作为参数调用其checkAccess方法。 这可能会导致抛出一个SecurityException 。

        异常
        SecurityException - 如果当前线程不允许访问此线程组。
        从以下版本开始：
        1.0
        另请参见：
        SecurityManager.checkAccess(java.lang.ThreadGroup)

      • activeCount

        public int activeCount​()
        返回此线程组及其子组中活动线程数的估计。 递归迭代此线程组中的所有子组。

        返回的值只是一个估计，因为线程数可能会在此方法遍历内部数据结构时动态更改，并可能受某些系统线程的影响。 此方法主要用于调试和监视。

        结果
        对该线程组以及将该线程组作为祖先的任何其他线程组中的活动线程数的估计
        从以下版本开始：
        1.0

      • enumerate

        public int enumerate​(Thread[] list)
        将此线程组及其子组中的每个活动线程复制到指定的数组中。

        调用此方法的行为方式与调用完全相同

        enumerate (list, true)
        参数
        list - 放置线程列表的数组
        结果
        放入数组的线程数
        异常
        SecurityException - 如果 checkAccess确定当前线程无法访问此线程组
        从以下版本开始：
        1.0

      • enumerate

        public int enumerate​(Thread[] list,
                     boolean recurse)
        将此线程组中的每个活动线程复制到指定的数组中。 如果recurse为true ，则此方法递归枚举此线程组的所有子组，并且还包括对这些子组中每个活动线程的引用。 如果数组太短而不能容纳所有线程，则会忽略额外的线程。

        应用程序可能会使用activeCount方法来估计数组的大小，但是如果数组太短而不能容纳所有线程，则会忽略额外的线程。 如果在此线程组中获取每个活动线程至关重要，则调用者应验证返回的int值是否严格小于list的长度。

        由于本方法中固有的竞争条件，建议该方法仅用于调试和监控。

        参数
        list - 放置线程列表的数组
        recurse - 如果是 true ，递归枚举该线程组的所有子组
        结果
        放入数组的线程数
        异常
        SecurityException - 如果 checkAccess确定当前线程无法访问此线程组
        从以下版本开始：
        1.0

      • activeGroupCount

        public int activeGroupCount​()
        返回此线程组及其子组中活动组数的估计。 递归迭代此线程组中的所有子组。

        返回的值只是一个估计，因为线程组的数量可能会在此方法遍历内部数据结构时动态更改。 此方法主要用于调试和监视。

        结果
        此线程组作为祖先的活动线程组数
        从以下版本开始：
        1.0

      • enumerate

        public int enumerate​(ThreadGroup[] list)
        复制到该线程组及其子组中每个活动子组的指定数组引用。

        调用此方法的行为方式与调用完全相同

        enumerate (list, true)
        参数
        list - 将线程组列表放入的数组
        结果
        线程组的数量放入数组
        异常
        SecurityException - 如果 checkAccess确定当前线程无法访问此线程组
        从以下版本开始：
        1.0

      • enumerate

        public int enumerate​(ThreadGroup[] list,
                     boolean recurse)
        复制到该线程组中每个活动子组的指定数组引用。 如果recurse是true ，则该方法递归枚举该线程组的所有子组，并且还包括对这些子组中每个活动线程组的引用。

        应用程序可能会使用activeGroupCount方法来估计数组的大小，但是如果数组太短而不能容纳所有线程组，则会忽略额外的线程组。 如果在此线程组中获取每个活动子组非常重要，则调用者应验证返回的int值是否严格小于list的长度。

        由于本方法中固有的竞争条件，建议该方法仅用于调试和监控。

        参数
        list - 放置线程组列表的数组
        recurse - 如果是 true ，递归枚举所有子组
        结果
        线程组的数量放入数组
        异常
        SecurityException - 如果 checkAccess确定当前线程无法访问此线程组
        从以下版本开始：
        1.0

      • stop

        @Deprecated(since="1.2")
public final void stop​()
        已过时。 这种方法本质上是不安全的。 详见Thread.stop() 。
        停止此线程组中的所有线程。

        首先，这个线程组的checkAccess方法被调用，没有参数; 这可能会导致安全异常。

        然后，该方法在该线程组及其所有子组中的所有线程上调用stop方法。

        异常
        SecurityException - 如果当前线程不允许访问此线程组或线程组中的任何线程。
        从以下版本开始：
        1.0
        另请参见：
        SecurityException ， Thread.stop() ， checkAccess()

      • interrupt

        public final void interrupt​()
        中断此线程组中的所有线程。

        首先，这个线程组的checkAccess方法被调用，没有参数; 这可能会导致安全异常。

        然后，该方法在该线程组及其所有子组中的所有线程上调用interrupt方法。

        异常
        SecurityException - 如果当前线程不允许访问此线程组或线程组中的任何线程。
        从以下版本开始：
        1.2
        另请参见：
        Thread.interrupt() ， SecurityException ， checkAccess()

      • suspend

        @Deprecated(since="1.2")
public final void suspend​()
        已过时。 这种方法本质上是死锁的。 详见Thread.suspend() 。
        暂停此线程组中的所有线程。

        首先，这个线程组的checkAccess方法被调用，没有参数; 这可能会导致安全异常。

        然后，该方法在该线程组及其所有子组中的所有线程上调用suspend方法。

        异常
        SecurityException - 如果当前线程不允许访问此线程组或线程组中的任何线程。
        从以下版本开始：
        1.0
        另请参见：
        Thread.suspend() ， SecurityException ， checkAccess()

      • resume

        @Deprecated(since="1.2")
public final void resume​()
        已过时。 这种方法仅与Thread.suspend和ThreadGroup.suspend一起使用，这两种都已被弃用，因为它们本身就是死锁的。 详见Thread.suspend() 。
        恢复此线程组中的所有线程。

        首先，这个线程组的checkAccess方法被调用，没有参数; 这可能会导致安全异常。

        然后，该方法在该线程组及其所有子组中的所有线程上调用resume方法。

        异常
        SecurityException - 如果当前线程不允许访问此线程组或线程组中的任何线程。
        从以下版本开始：
        1.0
        另请参见：
        SecurityException ， Thread.resume() ， checkAccess()

      • destroy

        public final void destroy​()
        销毁此线程组及其所有子组。 此线程组必须为空，表示此线程组中的所有线程已停止。

        首先，这个线程组的checkAccess方法被调用，没有参数; 这可能会导致安全异常。

        异常
        IllegalThreadStateException - 如果线程组不为空或线程组已被破坏。
        SecurityException - 如果当前线程不能修改此线程组。
        从以下版本开始：
        1.0
        另请参见：
        checkAccess()

      • list

        public void list​()
        将有关此线程组的信息打印到标准输出。 此方法仅适用于调试。
        从以下版本开始：
        1.0

      • uncaughtException

        public void uncaughtException​(Thread t,
                              Throwable e)
        当该线程组中的线程由于未捕获的异常而停止时，由Java虚拟机调用，并且该线程没有安装特定的Thread.UncaughtExceptionHandler 。

        该uncaughtException的方法ThreadGroup执行以下操作：

        • 如果此线程组具有父线程组，则使用相同的两个参数调用该父进程的uncaughtException方法。
        • 否则，此方法检查是否安装了一个default uncaught exception handler ，如果是，则使用相同的两个参数调用其uncaughtException方法。
        • 否则，该方法确定是否Throwable参数是的一个实例ThreadDeath 。 如果是这样，没有什么特别之处。 否则，将使用Throwable的printStackTrace方法将包含线程名称的消息（从线程的getName方法返回）和堆栈回溯打印到standard error stream 。

        应用程序可以在ThreadGroup子类中覆盖此方法，以提供未捕获异常的替代处理。

        Specified by:
        uncaughtException在接口 Thread.UncaughtExceptionHandler
        参数
        t - 即将退出的线程。
        e - 未捕获的异常。
        从以下版本开始：
        1.0

      • allowThreadSuspension

        @Deprecated(since="1.2")
public boolean allowThreadSuspension​(boolean b)
        已过时。 此呼叫的定义取决于不推荐使用的suspend() 。 此外，从未指定此调用的行为。
        由VM用于控制lowmem隐式暂停。
        参数
        b - 允许或不允许暂停的布尔值
        结果
        真正的成功
        从以下版本开始：
        1.1

      • toString

        public String toString​()
        返回此Thread组的字符串表示形式。
        重写：
        toString在 Object
        结果
        该线程组的字符串表示形式。
        从以下版本开始：
        1.0
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadLocal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class ThreadLocal<T>

  • java.lang.Object
    • java.lang.ThreadLocal<T>
  • 已知直接子类：
    InheritableThreadLocal

    public class ThreadLocal<T>
extends Object
    这个类提供线程局部变量。 这些变量与其正常的对应方式不同，因为访问一个的每个线程（通过其get或set方法）都有自己的独立初始化的变量副本。 ThreadLocal实例通常是希望将状态与线程关联的类中的私有静态字段（例如，用户ID或事务ID）。

    例如，下面的类生成每个线程本地的唯一标识符。 线程的ID首次被调用ThreadId.get()并在后续调用时保持不变。

      import java.util.concurrent.atomic.AtomicInteger;

 public class ThreadId {
     // Atomic integer containing the next thread ID to be assigned
     private static final AtomicInteger nextId = new AtomicInteger(0);

     // Thread local variable containing each thread's ID
     private static final ThreadLocal<Integer> threadId =
         new ThreadLocal<Integer>() {
             @Override protected Integer initialValue() {
                 return nextId.getAndIncrement();
         }
     };

     // Returns the current thread's unique ID, assigning it if necessary
     public static int get() {
         return threadId.get();
     }
 }

    只要线程存活并且ThreadLocal实例可访问，每个线程都会保存对其线程局部变量副本的隐含引用; 线程消失后，线程本地实例的所有副本都将被垃圾收集（除非存在对这些副本的其他引用）。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      ThreadLocal​()
      创建线程局部变量。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T get​()
      返回当前线程的此线程局部变量的副本中的值。
      protected T initialValue​()
      返回此线程局部变量的当前线程的“初始值”。
      void remove​()
      删除此线程局部变量的当前线程的值。
      void set​(T value)
      将当前线程的此线程局部变量的副本设置为指定的值。
      static <S> ThreadLocal<S> withInitial​(Supplier<? extends S> supplier)
      创建线程局部变量。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ThreadLocal

        public ThreadLocal​()
        创建线程局部变量。
        另请参见：
        withInitial(java.util.function.Supplier)

    • 方法详细信息

      • initialValue

        protected T initialValue​()
        返回此线程局部变量的当前线程的“初始值”。 该方法将在第一次使用get()方法访问变量时被调用，除非线程先前调用了set(T)方法，在这种情况下，该线程不会调用initialValue方法。 通常，每个线程最多调用此方法一次，但是在随后调用remove()后跟get()的情况下，可以再次调用此方法。

        这个实现只是返回null ; 如果程序员希望线程局部变量具有null以外的初始值，则ThreadLocal必须被子类化，并且该方法被覆盖。 通常，将使用匿名内部类。

        结果
        这个线程本地的初始值

      • withInitial

        public static <S> ThreadLocal<S> withInitial​(Supplier<? extends S> supplier)
        创建线程局部变量。 变量的初始值通过调用get上的Supplier方法来Supplier 。
        参数类型
        S - 线程本地值的类型
        参数
        supplier - 用于确定初始值的供应商
        结果
        一个新的线程局部变量
        异常
        NullPointerException - 如果指定的供应商为空
        从以下版本开始：
        1.8

      • get

        public T get​()
        返回当前线程的此线程局部变量的副本中的值。 如果变量没有当前线程的值，则首先将其初始化为通过调用initialValue()方法返回的值。
        结果
        当前线程的线程本身的值

      • set

        public void set​(T value)
        将当前线程的此线程局部变量的副本设置为指定的值。 大多数子类将无需重写此方法，仅依靠initialValue()方法设置线程本地值的值。
        参数
        value - 要存储在当前线程的该线程本地的副本中的值。

      • remove

        public void remove​()
        删除此线程局部变量的当前线程的值。 如果该线程本地变量随后是当前线程的read ，则其值将通过调用其initialValue()方法重新初始化，除非其临时当前线程的值为set 。 这可能导致当前线程中的initialValue方法的多次调用。
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Throwable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Throwable

  • java.lang.Object
    • java.lang.Throwable
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    Error ， 异常

    public class Throwable
extends Object
implements Serializable
    Throwable类是Java语言中所有错误和异常的超类。 只有作为此类（或其一个子类）的实例的对象由Java虚拟机抛出，或者可以由Java throw语句抛出。 类似地，只有这个类或其子类可以是catch子句中的参数类型。 对于异常，编译时检查的目的Throwable和任何子类Throwable ，是不是也无论是子类RuntimeException或者Error被视为检查的异常。

    两个子类的实例Error和异常通常用于表示出现异常情况。 通常，这些实例是在特殊情况的上下文中新创建的，以便包括相关信息（如堆栈跟踪数据）。

    throwable在创建时包含其线程的执行堆栈的快照。 它还可以包含一个消息字符串，其中提供有关错误的更多信息。 随着时间的推移，一个可抛出的suppress其他可抛弃物被传播。 最后，throwable也可能包含一个原因 ：另一个可抛出的，导致这个可抛出的构造。 这种因果信息的记录被称为链接的异常设施，因为原因本身可能有原因等等，导致“链”的异常，每个异常都由另一个导致。

    抛出一个原因的一个原因是抛出它的类被构建在较低层次的抽象之上，上层的操作由于下层的故障而失败。 让下层投掷的投掷物向外传播是不好的设计，因为它通常与上层提供的抽象无关。 此外，这样做会将上层的API与其实现的细节相结合，假设较低层的异常是被检查的异常。 抛出“包装异常”（即，包含原因的异常）允许上层将故障的细节传达给其呼叫者，而不会导致这些缺点之一。 它保留了更改上层实现的灵活性，而不改变其API（特别是其方法抛出的一组异常）。

    throwable可能有一个原因的第二个原因是抛出它的方法必须符合通用接口，该接口不允许该方法直接引用原因。 例如，假设持久集合符合Collection接口，并且其持久性实现在java.io 。 假设add方法的内部可以抛出一个IOException 。 该实现可以通过将IOException在适当的未检查异常中，符合Collection接口，将IOException的详细信息IOException给其来电者。 （持久集合的规范应该表明它能够抛出这种异常。）

    一个原因可以通过两种方式与一个可抛出的关联：通过构造函数将原因作为参数，或通过initCause(Throwable)方法。 希望允许原因与他们相关联的新的可抛出类可以提供构造函数，该构造函数将原因和Throwable （可能间接地）提供给引起某种原因的构建器之一。 因为initCause方法是公开的，它允许一个原因与任何可抛出的，甚至是“传统的可抛出”相关联， Throwable异常链接机制添加到Throwable 。

    按照约定，类Throwable及其子类有两个构造函数，一个不包含参数，另一个String函数可以使用String参数来生成详细消息。 此外，那些可能具有与其关联的原因的子类应该有两个构造函数，一个是Throwable （原因），另一个构造函数是String （详细信息）和一个Throwable （原因）。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form
    See The Java™ Language Specification:
    11.2编译时检查异常

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        Throwable​()
      构造一个新的可抛出的 null作为其详细信息。
        Throwable​(String message)
      构造一个具有指定的详细消息的新的throwable。
        Throwable​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      protected Throwable​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个具有指定的详细消息的新的throwable，因为启用或禁用 suppression ，并启用或禁用可写栈跟踪。
        Throwable​(Throwable cause)
      构造一个具有指定原因的新throwable和一个详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void addSuppressed​(Throwable exception)
      将指定的异常附加到为了传递此异常而被抑制的异常。
      Throwable fillInStackTrace​()
      填写执行堆栈跟踪。
      Throwable getCause​()
      如果原因不存在或未知，则返回此throwable的原因或 null 。
      String getLocalizedMessage​()
      创建此可抛出的本地化描述。
      String getMessage​()
      返回此throwable的详细消息字符串。
      StackTraceElement[] getStackTrace​()
      提供对 printStackTrace()打印的堆栈跟踪信息的编程访问。
      Throwable[] getSuppressed​()
      通过 try -with-resources语句返回一个包含所有被抑制的异常的数组，以便传递这个异常。
      Throwable initCause​(Throwable cause)
      将此throwable的 原因初始化为指定值。
      void printStackTrace​()
      将此throwable和其追溯打印到标准错误流。
      void printStackTrace​(PrintStream s)
      将此throwable和其追溯打印到指定的打印流。
      void printStackTrace​(PrintWriter s)
      将此throwable和其追溯打印到指定的打印作者。
      void setStackTrace​(StackTraceElement[] stackTrace)
      设置将被返回的堆栈微量元素 getStackTrace()和由印刷 printStackTrace()和相关方法。
      String toString​()
      返回此可抛出的简短描述。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Throwable

        public Throwable​()
        构建一个新的可抛出的null作为其详细信息。 原因未初始化，可以随后通过调用initCause(java.lang.Throwable)进行初始化。

        调用fillInStackTrace()方法来初始化新创建的throwable中的堆栈跟踪数据。

      • Throwable

        public Throwable​(String message)
        构造一个具有指定的详细消息的新的throwable。 原因未初始化，可能随后通过调用initCause(java.lang.Throwable)进行初始化。

        调用fillInStackTrace()方法来初始化新创建的throwable中的堆栈跟踪数据。

        参数
        message - 详细信息。 保存详细信息以供以后通过getMessage()方法检索。

      • Throwable

        public Throwable​(String message,
                 Throwable cause)
        构造一个新的可抛出指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此可抛出的详细消息。

        调用fillInStackTrace()方法来初始化新创建的throwable中的堆栈跟踪数据。

        参数
        message - 详细信息（由 getMessage()方法保存供以后检索）。
        cause - 原因（保存以供getCause()方法稍后检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • Throwable

        public Throwable​(Throwable cause)
        构造一个具有指定原因的新throwable和一个详细信息(cause==null ? null : cause.toString()) （通常包含类和详细信息cause ）。 这个构造函数对于对于其他可抛出物（比如PrivilegedActionException ）的包装器来说只是一点点的throwable是有用的。

        调用fillInStackTrace()方法来初始化新创建的throwable中的堆栈跟踪数据。

        参数
        cause - 原因（由getCause()方法保存供以后检索）。 （允许A null值，并表示原因不存在或未知。）
        从以下版本开始：
        1.4

      • Throwable

        protected Throwable​(String message,
                    Throwable cause,
                    boolean enableSuppression,
                    boolean writableStackTrace)
        构造一个具有指定的详细信息的新的throwable，原因是启用或禁用suppression ，并启用或禁用可写栈跟踪。 如果禁用抑制， 则此对象的getSuppressed()将返回零长度数组，并调用否则将向禁用列表附加异常的addSuppressed(java.lang.Throwable)将不起作用。 如果可写栈跟踪为false，该构造函数不会调用fillInStackTrace() ，一个null将被写入stackTrace字段，后续调用fillInStackTrace和setStackTrace(StackTraceElement[])将不会设置堆栈跟踪。 如果可写栈跟踪为假，则getStackTrace()将返回零长度数组。

        注意Throwable的其他构造Throwable将抑制视为启用，并将堆栈跟踪视为可写。 Throwable子类应记录禁用抑制的任何条件和堆栈跟踪不可写的文档条件。 禁止抑制只应在特殊情况下存在特殊要求，例如虚拟机在低内存情况下重用异常对象。 给定异常对象被重复捕获并重新引导的情况，例如在两个子系统之间实现控制流的情况是另一种情况，即不可变的可抛出对象是合适的。

        参数
        message - 详细信息。
        cause - 原因。 （允许A null值，表示原因不存在或未知。）
        enableSuppression - 是否启用抑制功能
        writableStackTrace - 堆栈跟踪是否应该可写
        从以下版本开始：
        1.7
        另请参见：
        OutOfMemoryError ， NullPointerException ， ArithmeticException

    • 方法详细信息

      • getMessage

        public String getMessage​()
        返回此throwable的详细消息字符串。
        结果
        该 Throwable实例的详细消息字符串（可能是 null ）。

      • getLocalizedMessage

        public String getLocalizedMessage​()
        创建此可抛出的本地化描述。 子类可以覆盖此方法，以生成特定于区域的消息。 对于不覆盖此方法的子类，默认实现将返回与getMessage()相同的结果。
        结果
        本投稿的本地化描述。
        从以下版本开始：
        1.1

      • getCause

        public Throwable getCause​()
        如果原因不存在或未知，则返回此throwable的原因或null 。 （原因是引发这个可抛掷物的抛掷物）

        此实现返回通过需要Throwable的构造函数之一提供的Throwable ，或者使用initCause(Throwable)方法创建后设置的原因 。 虽然通常不必重写此方法，但是子类可以覆盖它以返回通过其他方法设置的原因。 这是适用于“传统链接可抛出”，它将链接异常添加到Throwable 。 注意， 没有必要覆盖任何PrintStackTrace方法，所有这些方法都调用getCause方法来确定可抛出的原因。

        结果
        这个可能的原因或 null如果原因不存在或未知。
        从以下版本开始：
        1.4

      • initCause

        public Throwable initCause​(Throwable cause)
        将此throwable的原因初始化为指定值。 （原因是引发这个可抛掷物的抛掷物）

        这个方法最多可以调用一次。 它通常从构造函数中调用，或者在创建throwable之后立即调用。 如果这个throwable是用Throwable(Throwable)或Throwable(String,Throwable)创建的， 那么这个方法也不能被调用一次。

        在没有其他支持设置原因的情况下，以传统可抛弃类型使用此方法的示例是：

          try {
     lowLevelOp();
 } catch (LowLevelException le) {
     throw (HighLevelException)
           new HighLevelException().initCause(le); // Legacy constructor
 }
        参数
        cause - 原因（由getCause()方法保存供以后检索）。 （允许A null值，表示原因不存在或未知。）
        结果
        参考这个 Throwable例子。
        异常
        IllegalArgumentException - 如果cause是这个可抛出的。 （一个可以不是自己的事业）
        IllegalStateException - 如果这个throwable是用 Throwable(Throwable)或 Throwable(String,Throwable)创建的，或者这个方法已经在这个throwable上被调用了。
        从以下版本开始：
        1.4

      • toString

        public String toString​()
        返回此可抛出的简短描述。 结果是：
        • 这个对象的类的name
        • “：”（一个冒号和一个空格）
        • 调用该对象的结果getLocalizedMessage()的方法
        如果getLocalizedMessage返回null ，那么只返回类名。
        重写：
        toString在 Object
        结果
        这个throwable的字符串表示形式。

      • printStackTrace

        public void printStackTrace​()
        将此throwable和其追溯打印到标准错误流。 此方法在错误输出流上打印Throwable对象的堆栈跟踪，该值为字段System.err的值。 第一行输出包含该对象的toString()方法的结果。 剩余行表示先前由方法fillInStackTrace()记录的数据。 该信息的格式取决于实现，但以下示例可能被认为是典型的：
         java.lang.NullPointerException
         at MyClass.mash(MyClass.java:9)
         at MyClass.crunch(MyClass.java:6)
         at MyClass.main(MyClass.java:3)
        此示例通过运行程序生成：
          class MyClass {
     public static void main(String[] args) {
         crunch(null);
     }
     static void crunch(int[] a) {
         mash(a);
     }
     static void mash(int[] b) {
         System.out.println(b[0]);
     }
 }
        对于具有初始化的非空原因的throwable的回溯通常应包括原因的回溯。 该信息的格式取决于实现，但以下示例可能被认为是典型的：
          HighLevelException: MidLevelException: LowLevelException
         at Junk.a(Junk.java:13)
         at Junk.main(Junk.java:4)
 Caused by: MidLevelException: LowLevelException
         at Junk.c(Junk.java:23)
         at Junk.b(Junk.java:17)
         at Junk.a(Junk.java:11)
         ... 1 more
 Caused by: LowLevelException
         at Junk.e(Junk.java:30)
         at Junk.d(Junk.java:27)
         at Junk.c(Junk.java:21)
         ... 3 more
        注意存在包含字符"..." 。 这些行表示该异常的堆栈跟踪的其余部分与由异常引起的异常的堆栈跟踪的底部（“包围”异常）相匹配的指定数量的帧。 这种简写可以大大减少输出的长度，在常见的情况下，从“相同的异常”被捕获到的方法抛出一个包装的异常。 上面的例子是通过运行程序生成的：
          public class Junk {
     public static void main(String args[]) {
         try {
             a();
         } catch(HighLevelException e) {
             e.printStackTrace();
         }
     }
     static void a() throws HighLevelException {
         try {
             b();
         } catch(MidLevelException e) {
             throw new HighLevelException(e);
         }
     }
     static void b() throws MidLevelException {
         c();
     }
     static void c() throws MidLevelException {
         try {
             d();
         } catch(LowLevelException e) {
             throw new MidLevelException(e);
         }
     }
     static void d() throws LowLevelException {
        e();
     }
     static void e() throws LowLevelException {
         throw new LowLevelException();
     }
 }

 class HighLevelException extends Exception {
     HighLevelException(Throwable cause) { super(cause); }
 }

 class MidLevelException extends Exception {
     MidLevelException(Throwable cause)  { super(cause); }
 }

 class LowLevelException extends Exception {
 }
        从版本7开始，该平台支持抑制异常的概念（结合try -with-resources语句）。 为了传递异常而被抑制的任何异常都打印在堆栈跟踪之下。 该信息的格式取决于实现，但以下示例可能被认为是典型的：
          Exception in thread "main" java.lang.Exception: Something happened
  at Foo.bar(Foo.java:10)
  at Foo.main(Foo.java:5)
  Suppressed: Resource$CloseFailException: Resource ID = 0
          at Resource.close(Resource.java:26)
          at Foo.bar(Foo.java:9)
          ... 1 more
        请注意，“... n个更多”符号被用于抑制异常，因为它被用于原因。 与原因不同，被禁止的异常超出了它们的“包含异常”。

        异常可以同时导致一个或多个抑制异常：

          Exception in thread "main" java.lang.Exception: Main block
  at Foo3.main(Foo3.java:7)
  Suppressed: Resource$CloseFailException: Resource ID = 2
          at Resource.close(Resource.java:26)
          at Foo3.main(Foo3.java:5)
  Suppressed: Resource$CloseFailException: Resource ID = 1
          at Resource.close(Resource.java:26)
          at Foo3.main(Foo3.java:5)
 Caused by: java.lang.Exception: I did it
  at Foo3.main(Foo3.java:8)
        同样，被抑制的异常可能有一个原因：
          Exception in thread "main" java.lang.Exception: Main block
  at Foo4.main(Foo4.java:6)
  Suppressed: Resource2$CloseFailException: Resource ID = 1
          at Resource2.close(Resource2.java:20)
          at Foo4.main(Foo4.java:5)
  Caused by: java.lang.Exception: Rats, you caught me
          at Resource2$CloseFailException.<init>(Resource2.java:45)
          ... 2 more

      • printStackTrace

        public void printStackTrace​(PrintStream s)
        将此throwable和其追溯打印到指定的打印流。
        参数
        s - PrintStream用于输出

      • printStackTrace

        public void printStackTrace​(PrintWriter s)
        将此throwable和其追溯打印到指定的打印作者。
        参数
        s - PrintWriter用于输出
        从以下版本开始：
        1.1

      • fillInStackTrace

        public Throwable fillInStackTrace​()
        填写执行堆栈跟踪。 此方法记录此Throwable对象信息，了解当前线程的堆栈帧的当前状态。

        如果这个Throwable的堆栈跟踪is not writable ，调用这个方法没有任何效果。

        结果
        参考这个 Throwable例子。
        另请参见：
        printStackTrace()

      • getStackTrace

        public StackTraceElement[] getStackTrace​()
        提供对printStackTrace()打印的堆栈跟踪信息的编程访问。 返回一个堆栈跟踪元素数组，每个数组代表一个堆栈帧。 数组的第零个元素（假定数组的长度不为零）表示堆栈的顶部，这是序列中最后一个方法的调用。 通常，这是创建和抛出此throwable的点。 数组的最后一个元素（假定数组的长度不为零）表示堆栈的底部，这是序列中的第一个方法调用。

        在某些情况下，某些虚拟机可能从堆栈跟踪中省略一个或多个堆栈帧。 在极端情况下，允许没有关于该throwable的堆栈跟踪信息的虚拟机从该方法返回零长度数组。 一般来说，这个方法返回的数组将包含printStackTrace打印的每一帧的一个元素。 写入返回的数组不影响将来调用此方法。

        结果
        表示与此可抛出的堆栈跟踪相关的堆栈跟踪元素数组。
        从以下版本开始：
        1.4

      • setStackTrace

        public void setStackTrace​(StackTraceElement[] stackTrace)
        设置将被返回的堆栈微量元素getStackTrace()和由印刷printStackTrace()和相关方法。 该方法是为RPC框架和其他高级系统使用而设计的，允许客户端覆盖当从序列化流中读取可抛出数据时构造或反序列化时由fillInStackTrace()生成的默认堆栈跟踪。

        如果这个Throwable is not writable的堆栈跟踪，调用这个方法没有效果，除了验证其参数。

        参数
        stackTrace - 要与此Throwable关联的堆栈跟踪元素。 该调用复制指定的数组; 方法调用返回后指定数组的更改对这个Throwable的堆栈跟踪没有影响。
        异常
        NullPointerException -如果 stackTrace是 null ，或者如果任何的元件的 stackTrace是 null
        从以下版本开始：
        1.4

      • addSuppressed

        public final void addSuppressed​(Throwable exception)
        将指定的异常附加到为了传递此异常而被抑制的异常。 这种方法是线程安全的，通常由try -with-resources语句调用（自动和隐式）。

        抑制行为启用， 除非禁用via a constructor 。 当禁用抑制时，该方法除了验证其参数之外什么都不做。

        注意当一个异常causes异常时，第一个异常通常被捕获，然后第二个异常被抛出来作为响应。 换句话说，这两个例外之间有因果关系。 与此相反，存在两个独立的异常可以在同级代码块在被抛出，在特定情况下try一个的块try -with资源语句和编译器生成的finally块封闭该资源。 在这些情况下，只能传播一个抛出的异常。 在try -with-resources语句，当有两个这样的例外，从始发异常try块被传播，并从异常finally块添加到从异常抑制例外列表try块。 作为一个例外展开堆栈，它可以累积多个抑制异常。

        异常可能会抑制异常，同时也是由另一个异常引起的。 异常是否有原因在创建时是语义上已知的，与异常是否会抑制通常仅在抛出异常之后确定的其他异常不同。

        请注意，程序员编写的代码还可以利用在存在多个兄弟异常并且只能传播一个异常的情况下调用此方法。

        参数
        exception - 被添加到抑制异常列表中的异常
        异常
        IllegalArgumentException - 如果exception是这个可抛出的; 一个可耻的不能压制自己。
        NullPointerException - 如果 exception是 null
        从以下版本开始：
        1.7

      • getSuppressed

        public final Throwable[] getSuppressed​()
        通过try -with-resources语句返回一个包含所有被抑制的异常的数组，以便传递这个异常。 如果没有例外被抑制或suppression is disabled ，返回一个空数组。 这种方法是线程安全的。 写入返回的数组不影响将来调用此方法。
        结果
        一个数组，其中包含所有被抑制以提供此异常的异常。
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TypeNotPresentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class TypeNotPresentException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.TypeNotPresentException
  • All Implemented Interfaces:
    Serializable

    public class TypeNotPresentException
extends RuntimeException
    当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。 该异常与ClassNotFoundException的不同之处在于， ClassNotFoundException是一个检查的异常，而此例外是未选中的。

    请注意，当访问未定义的类型变量以及加载类型（例如类，接口或注释类型）时，可能会使用此异常。 特别是，这个异常可以抛出API used to read annotations reflectively 。

    从以下版本开始：
    1.5
    另请参见：
    AnnotatedElement ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      TypeNotPresentException​(String typeName, Throwable cause)
      构造具有指定原因的命名类型的 TypeNotPresentException 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String typeName​()
      返回不可用类型的完全限定名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • TypeNotPresentException

        public TypeNotPresentException​(String typeName,
                               Throwable cause)
        构造具有指定原因的命名类型的 TypeNotPresentException 。
        参数
        typeName - 不可用类型的完全限定名称
        cause - 系统尝试加载命名类型时抛出的异常，如果不可用或不适用， null

    • 方法详细信息

      • typeName

        public String typeName​()
        返回不可用类型的完全限定名称。
        结果
        不可用类型的完全限定名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnknownError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class UnknownError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.VirtualMachineError
          • java.lang.UnknownError
  • All Implemented Interfaces:
    Serializable

    public class UnknownError
extends VirtualMachineError
    当Java虚拟机中出现未知但严重的异常时抛出。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownError​()
      构造一个 UnknownError ，没有详细消息。
      UnknownError​(String s)
      构造具有指定详细消息的 UnknownError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownError

        public UnknownError​()
        构造一个 UnknownError ，没有详细消息。

      • UnknownError

        public UnknownError​(String s)
        构造具有指定详细消息的 UnknownError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnsatisfiedLinkError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class UnsatisfiedLinkError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.UnsatisfiedLinkError
  • All Implemented Interfaces:
    Serializable

    public class UnsatisfiedLinkError
extends LinkageError
    如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。
    从以下版本开始：
    1.0
    另请参见：
    Runtime ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsatisfiedLinkError​()
      构造一个 UnsatisfiedLinkError ，没有详细信息。
      UnsatisfiedLinkError​(String s)
      构造具有指定详细消息的 UnsatisfiedLinkError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsatisfiedLinkError

        public UnsatisfiedLinkError​()
        构造一个 UnsatisfiedLinkError ，没有详细信息。

      • UnsatisfiedLinkError

        public UnsatisfiedLinkError​(String s)
        构造具有指定详细消息的 UnsatisfiedLinkError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnsupportedClassVersionError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class UnsupportedClassVersionError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.ClassFormatError
            • java.lang.UnsupportedClassVersionError
  • All Implemented Interfaces:
    Serializable

    public class UnsupportedClassVersionError
extends ClassFormatError
    当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedClassVersionError​()
      构造一个 UnsupportedClassVersionError ，没有详细信息。
      UnsupportedClassVersionError​(String s)
      构造具有指定详细消息的 UnsupportedClassVersionError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedClassVersionError

        public UnsupportedClassVersionError​()
        构造一个 UnsupportedClassVersionError ，没有详细信息。

      • UnsupportedClassVersionError

        public UnsupportedClassVersionError​(String s)
        构造具有指定详细消息的 UnsupportedClassVersionError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnsupportedOperationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class UnsupportedOperationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.UnsupportedOperationException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    HeadlessException ， ReadOnlyBufferException ， ReadOnlyFileSystemException ， VMCannotBeModifiedException

    public class UnsupportedOperationException
extends RuntimeException
    抛出以表示不支持请求的操作。

    这个班是Java Collections Framework的会员。

    从以下版本开始：
    1.2
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnsupportedOperationException​()
      构造一个没有详细消息的UnsupportedOperationException。
      UnsupportedOperationException​(String message)
      构造具有指定详细消息的UnsupportedOperationException。
      UnsupportedOperationException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      UnsupportedOperationException​(Throwable cause)
      构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnsupportedOperationException

        public UnsupportedOperationException​()
        构造一个没有详细消息的UnsupportedOperationException。

      • UnsupportedOperationException

        public UnsupportedOperationException​(String message)
        构造具有指定详细消息的UnsupportedOperationException。
        参数
        message - 详细信息

      • UnsupportedOperationException

        public UnsupportedOperationException​(String message,
                                     Throwable cause)
        构造一个新的异常与指定的详细信息和原因。

        请注意，与cause相关联的详细信息不会自动并入此异常的详细消息。

        参数
        message - 详细信息（保存以供以后通过 Throwable.getMessage()方法检索）。
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5

      • UnsupportedOperationException

        public UnsupportedOperationException​(Throwable cause)
        构造具有指定原因的新异常和详细消息为(cause==null ? null : cause.toString()) （通常包含类别和详细信息为cause ）。 这个构造函数对于除了其他可抛弃的封装的异常（例如， PrivilegedActionException ） 很有用 。
        参数
        cause - 原因（保存以供Throwable.getCause()方法稍后检索）。 （允许A null值，表示原因不存在或未知。）
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.lang (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang

  • Packages that use java.lang
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.connect.spi
    该包包含用于开发新的TransportService实现的接口和类。
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.net.httpserver.spi
    提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.security.auth
    提供Principal的实现。
    com.sun.security.auth.callback
    提供CallbackHandler的实现。
    com.sun.security.auth.login
    提供Configuration的实现。
    com.sun.security.auth.module
    提供LoginModule的实现。
    com.sun.security.jgss
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.attach.spi
    只有定义新附加提供商的开发者才需要直接使用这个包。
    com.sun.tools.doclets
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets.standard
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.javac
    该包提供了 javac工具的传统入口点。
    com.sun.tools.javadoc
    此软件包及其内容已被弃用，可能会在将来的版本中删除。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.net
    提供实现网络应用程序的类。
    java.net.spi
    服务提供商类为 java.net包。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.charset.spi
    服务提供商类为 java.nio.charset包。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.nio.file.spi
    服务提供商类为 java.nio.file包。
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.text.spi
    java.text包中类的服务提供者类。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.spi
    java.util包中类的服务提供者类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.application
    提供应用程序生命周期类。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.embed.swing
    提供一组在Swing应用程序中使用JavaFX的类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.canvas
    为canvas提供一组类，即渲染API的立即模式样式。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javafx.util
    包含各种实用程序和助手类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.activation
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.crypto
    提供加密操作的类和接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.event
    一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.plugins.bmp
    包含内置BMP插件使用的公共类的软件包。
    javax.imageio.plugins.jpeg
    支持内置JPEG插件的类。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.jws
    javax.jws.soap
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.management.timer
    提供定时器MBean的定义。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming软件包以提供访问目录服务的功能。
    javax.naming.event
    访问命名和目录服务时，提供对事件通知的支持。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.naming.spi
    提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.net
    提供网络应用程序的类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.print.event
    程序包javax.print.event包含事件类和侦听器接口。
    javax.rmi
    包含RMI-IIOP的用户API。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.security.auth.kerberos
    此包包含与Kerberos网络身份验证协议相关的实用程序类。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.auth.spi
    该包提供了用于实现可插拔认证模块的接口。
    javax.security.auth.x500
    该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。
    javax.security.cert
    提供公钥证书类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.midi.spi
    为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sound.sampled.spi
    为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.filechooser
    包含 JFileChooser组件使用的类和接口。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    javax.transaction.xa
    提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。
    javax.xml
    定义XML处理的常量。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.bind.annotation.adapters
    XmlAdapter及其规范定义的子类，允许任意Java类与JAXB一起使用。
    javax.xml.bind.attachment
    该包由基于MIME的包处理器实现，可以在基于MIME的包格式中解释和创建优化的二进制数据。
    javax.xml.bind.helpers
    仅限JAXB提供者使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.bind.util
    有用的客户端工具类。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dom
    DOM特定的类为 javax.xml.crypto包。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.crypto.dsig.dom
    DOM特定的类为 javax.xml.crypto.dsig包。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理元素和结构的类别KeyInfo 。
    javax.xml.crypto.dsig.spec
    XML数字签名的参数类。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.namespace
    定义XML命名空间处理。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.stream.events
    定义Streaming API for XML（StAX）的事件接口。
    javax.xml.stream.util
    为Streaming API for XML（StAX）提供实用程序类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.transform.dom
    提供DOM特定的转换类。
    javax.xml.transform.sax
    提供SAX特定的转换类。
    javax.xml.transform.stax
    提供StAX特定的转换类。
    javax.xml.transform.stream
    提供流和URI特定的转换类。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler
    新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
    javax.xml.ws.handler.soap
    此包定义SOAP消息处理程序的API。
    javax.xml.ws.http
    该包定义了特定于HTTP绑定的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    javax.xml.ws.spi.http
    提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。
    javax.xml.ws.wsaddressing
    此包定义与WS-Addressing相关的API。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.dynalink.support
    包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方法。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。
    jdk.packager.services
    定义Java Packager工具使用的服务。
    jdk.security.jarsigner
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能的对象请求代理（ORB）。
    org.omg.CORBA.DynAnyPackage
    提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。
    org.omg.CORBA.ORBPackage
    提供异常 InvalidName ，由方法 ORB.resolve_initial_references抛出，异常 InconsistentTypeCode由ORB类中的动态任何创建方法抛出。
    org.omg.CORBA.TypeCodePackage
    提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.omg.CORBA_2_3
    CORBA_2_3包定义了Java [tm]标准版6中现有CORBA接口的添加。这些更改发生在由OMG定义的CORBA API的最新修订版本中。 将新方法添加到从CORBA包中相应接口派生的接口。 这提供向后兼容性，并避免破坏JCK测试。
    org.omg.CORBA_2_3.portable
    提供输入和输出值类型的方法，并包含 org/omg/CORBA/portable包的其他更新。
    org.omg.CosNaming
    为Java IDL提供命名服务。
    org.omg.CosNaming.NamingContextExtPackage
    此软件包包含以下类别，其用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress
    org.omg.CosNaming.NamingContextPackage
    该包包含 org.omg.CosNaming包的异常类。
    org.omg.Dynamic
    该包包含OMG便携式拦截器规范 ptc/2000-08-06第21.9节中指定的 Dynamic模块。
    org.omg.DynamicAny
    提供类和接口，可以在运行时遍历与 any相关联的数据值，并提取数据值的原始组成部分。
    org.omg.DynamicAny.DynAnyFactoryPackage
    该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。
    org.omg.DynamicAny.DynAnyPackage
    该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。
    org.omg.IOP
    该包包含OMG文档 “通用对象请求代理：体系结构和规范 ” formal/99-10-07第13.6节中指定的 IOP模块。
    org.omg.IOP.CodecFactoryPackage
    该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。
    org.omg.IOP.CodecPackage
    该包是从IOP :: Codec IDL接口定义生成的。
    org.omg.Messaging
    此软件包包含OMG CORBA消息传递规范 formal/99-10-07中指定的 Messaging模块。
    org.omg.PortableInterceptor
    提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。
    org.omg.PortableInterceptor.ORBInitInfoPackage
    该包包含OMG便携式拦截器规范 ptc/2000-08-06第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。
    org.omg.PortableServer
    提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
    org.omg.PortableServer.CurrentPackage
    提供方法实现，访问方法被调用的对象的标识。
    org.omg.PortableServer.POAManagerPackage
    封装与之相关的POA的处理状态。
    org.omg.PortableServer.POAPackage
    允许程序员构建可在不同ORB产品之间移植的对象实现。
    org.omg.PortableServer.ServantLocatorPackage
    提供用于定位仆人的类和接口。
    org.omg.PortableServer.portable
    提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
    org.omg.stub.java.rmi
    包含 java.rmi包中出现的远程类型的RMI-IIOP存根。
    org.w3c.dom
    提供文档对象模型（DOM）的接口。
    org.w3c.dom.bootstrap
    提供一个工厂来获取 DOMImplementation实例。
    org.w3c.dom.css
    提供DOM Level 2 Style Specification的界面。
    org.w3c.dom.events
    提供DOM Level 2事件的接口。
    org.w3c.dom.html
    提供DOM Level 2 HTML规范的接口。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.w3c.dom.ranges
    提供DOM Level 2范围的界面。
    org.w3c.dom.stylesheets
    提供DOM Level 2 Style Specification的界面。
    org.w3c.dom.xpath
    提供DOM Level 3 XPath规范的接口。
    org.xml.sax
    提供核心SAX API。
    org.xml.sax.ext
    提供与符合SAX驱动程序不一定支持的SAX2设施的接口。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。
  • Classes in java.lang used by com.sun.jarsigner
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    Object类是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.java.accessibility.util
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by com.sun.javadoc
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.jdi
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Process
    Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by com.sun.jdi.connect
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Process
    Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by com.sun.jdi.connect.spi
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by com.sun.jdi.event
    Class 描述
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Iterable
    实现此接口允许对象成为增强型 for语句的目标（有时称为“for-each loop”语句）。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.jdi.request
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by com.sun.management
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.net.httpserver
    Class 描述
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.net.httpserver.spi
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by com.sun.nio.sctp
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by com.sun.security.auth
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.security.auth.callback
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by com.sun.security.auth.login
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类表示字符串。
  • Classes in java.lang used by com.sun.security.auth.module
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by com.sun.security.jgss
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.source.doctree
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.source.tree
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.source.util
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.tools.attach
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by com.sun.tools.attach.spi
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.tools.doclets
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.tools.doclets.standard
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.tools.javac
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by com.sun.tools.javadoc
    Class 描述
    ClassLoader
    类加载器是负责加载类的对象。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类表示字符串。
  • Classes in java.lang used by com.sun.tools.jconsole
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.applet
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类表示字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by java.awt
    Class 描述
    Character
    Character类包装一个对象中的原始类型 char的值。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段 - 字段复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    IndexOutOfBoundsException
    抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    NullPointerException
    在需要对象的情况下，当应用程序尝试使用 null时抛出。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    NumberFormatException
    抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应由任何类实现，其实例将由线程执行。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    SecurityException
    由安全管理员抛出，表示安全违规。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by java.awt.color
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类表示字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.awt.datatransfer
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.awt.desktop
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.awt.dnd
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.awt.event
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Runnable
    Runnable接口应由实例由线程执行的任何类实现。
    String
    String类表示字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.awt.font
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Float
    Float类包装一个对象中的原始类型 float的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.awt.geom
    Class 描述
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.awt.im
    Class 描述
    Character.Subset
    该类的实例表示Unicode字符集的特定子集。
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by java.awt.im.spi
    Class 描述
    Character.Subset
    该类的实例表示Unicode字符集的特定子集。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.awt.image
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.awt.image.renderable
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    Runnable
    Runnable接口应由实例由线程执行的任何类实现。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by java.awt.print
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理的应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IndexOutOfBoundsException
    抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
    NullPointerException
    当应用程序在需要对象的情况下尝试使用 null时抛出。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.beans
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    SecurityException
    由安全管理员抛出，表示安全违规。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.beans.beancontext
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by java.io
    Class 描述
    Appendable
    可附加 char序列和值的对象。
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是程序员不鼓励使用的程序元素。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Readable
    A Readable是一个字符的来源。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    SecurityException
    由安全管理员抛出，表示安全违规。
    String
    String类表示字符串。
    StringBuffer
    线程安全，可变的字符序列。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.lang
    Class 描述
    Appendable
    可附加 char序列和值的对象。
    Boolean
    布尔类在对象中包含基元类型 boolean的值。
    Byte
    Byte类在一个对象中包装了一个原始类型 byte的值。
    Character
    Character类包装一个对象中的原始类型 char的值。
    Character.Subset
    该类的实例表示Unicode字符集的特定子集。
    Character.UnicodeBlock
    一系列字符子集，表示Unicode规范中的字符块。
    Character.UnicodeScript
    一系列字符子集，表示 Unicode Standard Annex #24: Script Names中定义的字符脚本。
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassFormatError
    当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Enum
    这是所有Java语言枚举类型的公共基类。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Float
    Float类在一个对象中包装了一个基本类型 float的值。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IncompatibleClassChangeError
    当一些类定义发生不兼容的类更改时抛出。
    IndexOutOfBoundsException
    抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
    InstantiationException
    当应用程序试图创建使用一个类的实例抛出 newInstance方法在类 Class ，而指定的类对象不能被实例化。
    Integer
    Integer类包装一个对象中的基元类型 int的值。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Iterable
    实现此接口允许对象成为增强型 for语句的目标（有时称为“for-each loop”语句）。
    LinkageError
    LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Module
    代表运行时模块，无论是 named还是未命名。
    ModuleLayer
    Java虚拟机中的一层模块。
    ModuleLayer.Controller
    控制模块层。
    NoSuchFieldException
    表示该类没有指定名称的字段。
    NoSuchMethodException
    当无法找到特定方法时抛出。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    NumberFormatException
    抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    软件包
    表示与类加载器关联的运行时包的元数据。
    Process
    Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。
    ProcessBuilder
    此类用于创建操作系统进程。
    ProcessBuilder.Redirect
    表示子进程输入的源或子进程输出的目的地。
    ProcessBuilder.Redirect.Type
    一种ProcessBuilder.Redirect的类型。
    ProcessHandle
    ProcessHandle识别并提供对本机进程的控制。
    ProcessHandle.Info
    关于流程的信息快照。
    ReflectiveOperationException
    核心反射中的反射操作抛出的异常的常见超类。
    Runnable
    Runnable接口应由实例由线程执行的任何类实现。
    Runtime
    每个Java应用程序都有一个 Runtime类的 Runtime ，允许应用程序与运行应用程序的环境进行接口。
    Runtime.Version
    用于实现Java SE平台的版本字符串的表示。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    SecurityException
    由安全管理员抛出，表示安全违规。
    SecurityManager
    安全管理器是允许应用程序实施安全策略的类。
    Short
    Short类在一个对象中包含一个原始类型 short的值。
    StackTraceElement
    堆栈跟踪中的元素，由 Throwable.getStackTrace()返回。
    StackWalker
    堆栈步行者。
    StackWalker.Option
    堆栈步行器选项配置stack frame获取的信息由一个StackWalker 。
    StackWalker.StackFrame
    一个StackFrame对象表示由StackWalker返回的方法调用。
    String
    String类代表字符串。
    StringBuffer
    线程安全，可变的字符序列。
    StringBuilder
    一个可变的字符序列。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    System.Logger
    System.Logger实例日志消息将路由到底层日志框架LoggerFinder使用。
    System.Logger.Level
    系统loggers级别。
    System.LoggerFinder
    LoggerFinder服务负责创建，管理和配置记录器到其使用的基础框架。
    Thread
    线程是程序中执行的线程。
    Thread.State
    线程状态。
    Thread.UncaughtExceptionHandler
    当 Thread由于未捕获的异常突然终止而调用处理程序的接口。
    ThreadGroup
    线程组代表一组线程。
    ThreadLocal
    这个类提供线程局部变量。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    VirtualMachineError
    抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • Classes in java.lang used by java.lang.annotation
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.lang.instrument
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Module
    代表一个运行时模块，无论是 named还是未命名的。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.lang.invoke
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    NoSuchFieldException
    表示该类没有指定名称的字段。
    NoSuchMethodException
    当无法找到特定方法时抛出。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    TypeNotPresentException
    当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。
  • Classes in java.lang used by java.lang.management
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    StackTraceElement
    堆栈跟踪中的一个元素，由 Throwable.getStackTrace()返回。
    String
    String类代表字符串。
    Thread.State
    线程状态。
  • Classes in java.lang used by java.lang.module
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.lang.ref
    Class 描述
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Object
    类 Object是类层次结构的根。
    Runnable
    Runnable接口应该由实例旨在由线程执行的任何类来实现。
  • Classes in java.lang used by java.lang.reflect
    Class 描述
    ArrayIndexOutOfBoundsException
    抛出以表示使用非法索引访问数组。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassFormatError
    当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
    ClassLoader
    类加载器是负责加载类的对象。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    InstantiationException
    当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但是指定的类对象不能被实例化。
    LinkageError
    LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
    NegativeArraySizeException
    抛出一个应用程序尝试创建一个负数大小的数组。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    ReflectiveOperationException
    核心反射中的反射操作抛出的异常的常见超类。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.math
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by java.net
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    软件包
    表示与类加载器关联的运行时包的元数据。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.net.spi
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by java.nio
    Class 描述
    Appendable
    可附加 char序列和值的对象。
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Readable
    A Readable是一个字符的来源。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by java.nio.channels
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    Integer
    Integer类包含一个对象中的原始类型 int的值。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • Classes in java.lang used by java.nio.channels.spi
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by java.nio.charset
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.nio.charset.spi
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.nio.file
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by java.nio.file.attribute
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.nio.file.spi
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.rmi
    Class 描述
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    SecurityException
    由安全管理员抛出，表示安全违规。
    SecurityManager
    安全管理器是允许应用程序实施安全策略的类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.rmi.activation
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.rmi.dgc
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.rmi.registry
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by java.rmi.server
    Class 描述
    Appendable
    可附加 char序列和值的对象。
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    SecurityException
    由安全管理员抛出，表示安全违规。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.security
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段字段的副本是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    SecurityException
    由安全管理员抛出，表示安全违规。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.security.acl
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.security.cert
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.security.spec
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.sql
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.text
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    StringBuffer
    线程安全，可变的字符序列。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.text.spi
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by java.time
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是可以在Java虚拟机的正常操作期间抛出的异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.time.chrono
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by java.time.format
    Class 描述
    Appendable
    可附加 char序列和值的对象。
    Boolean
    布尔类将对象中的 boolean类型为 boolean 。
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是可以在Java虚拟机的正常操作期间抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.time.temporal
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Long
    Long类包装一个对象中的基元类型 long的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.time.zone
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.util
    Class 描述
    Appendable
    可附加 char序列和值的对象。
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Character
    Character类将对象中的原始类型 char的值进行包装。
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是程序员不鼓励使用的程序元素。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Enum
    这是所有Java语言枚举类型的公共基类。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    InstantiationException
    当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但是指定的类对象不能被实例化。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Module
    表示运行时模块，无论是 named还是未命名。
    ModuleLayer
    Java虚拟机中的一层模块。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Readable
    A Readable是一个字符的来源。
    Runnable
    Runnable接口应由任何类实现，其实例将由线程执行。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    SafeVarargs
    程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.util.concurrent
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型为 boolean的值。
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段 - 字段的复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应该由实例旨在由线程执行的任何类来实现。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Thread
    线程是程序中执行的线程。
    Thread.UncaughtExceptionHandler
    当 Thread由于未捕获的异常而突然终止时，处理程序的接口被调用。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • Classes in java.lang used by java.util.concurrent.atomic
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by java.util.concurrent.locks
    Class 描述
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Thread
    线程是程序中执行的线程。
  • Classes in java.lang used by java.util.function
    Class 描述
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by java.util.jar
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Runtime.Version
    用于实现Java SE平台的版本字符串的表示。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.util.logging
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应由任何类实现，其实例将由线程执行。
    SecurityException
    由安全管理员抛出，表示安全违规。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.util.prefs
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.util.regex
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    StringBuffer
    线程安全，可变的字符序列。
    StringBuilder
    一个可变的字符序列。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by java.util.spi
    Class 描述
    Integer
    Integer类包装一个对象中的原始类型为 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by java.util.stream
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型为 boolean 。
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Double
    Double类包装一个对象中的基元类型 double的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应该由实例旨在由线程执行的任何类来实现。
    SafeVarargs
    程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by java.util.zip
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    InternalError
    在Java虚拟机中引发了一些意外的内部错误。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    VirtualMachineError
    抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。
  • Classes in java.lang used by javafx.animation
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.application
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应由任何类实现，其实例将由线程执行。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javafx.beans
    Class 描述
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
  • Classes in java.lang used by javafx.beans.binding
    Class 描述
    Boolean
    布尔类包装一个对象中的基元类型 boolean的值。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Float
    Float类在一个对象中包含一个基本类型 float的值。
    Integer
    Integer类将一个对象中的原始类型 int的值包起来。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.beans.property
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值包起来。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Float
    Float类包装一个对象中的原始类型为 float的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类表示字符串。
  • Classes in java.lang used by javafx.beans.property.adapter
    Class 描述
    Boolean
    Boolean类将对象中的基元类型 boolean的值进行包装。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    NoSuchMethodException
    当无法找到特定方法时抛出。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.beans.value
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
  • Classes in java.lang used by javafx.collections
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.collections.transformation
    Class 描述
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.concurrent
    Class 描述
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应该由实例旨在由线程执行的任何类实现。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javafx.css
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Enum
    这是所有Java语言枚举类型的公共基类。
    Float
    Float类包装一个对象中的原始类型为 float的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Long
    Long类包装一个对象中的基元类型 long的值。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.css.converter
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Enum
    这是所有Java语言枚举类型的公共基类。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.embed.swing
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
  • Classes in java.lang used by javafx.event
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段 - 字段的复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.fxml
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javafx.geometry
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.print
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene
    Class 描述
    Boolean
    布尔类将对象中的基元类型为 boolean 。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应由实例由线程执行的任何类实现。
    String
    String类代表字符串。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • Classes in java.lang used by javafx.scene.canvas
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类表示字符串。
  • Classes in java.lang used by javafx.scene.chart
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.control
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    CharSequence
    A CharSequence是 char值的可读序列。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.scene.control.cell
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    SafeVarargs
    程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
    String
    String类表示字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.scene.control.skin
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.effect
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.image
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.input
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.layout
    Class 描述
    Boolean
    布尔类将对象中的原始类型 boolean的值进行包装。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javafx.scene.media
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是程序员不鼓励使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应该由实例由线程执行的任何类实现。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javafx.scene.paint
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.shape
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.text
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.scene.transform
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javafx.scene.web
    Class 描述
    Boolean
    布尔类包含一个对象中的基元类型 boolean的值。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段对字段的复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    IndexOutOfBoundsException
    抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
    Object
    Object类是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • Classes in java.lang used by javafx.stage
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以向 Object.clone()方法指出，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.util
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javafx.util.converter
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Byte
    Byte类包含一个对象中的原始类型 byte的值。
    Character
    Character类包装一个对象中的原始类型 char的值。
    Double
    Double类包装一个对象中的原始类型 double的值。
    Float
    Float类包装一个对象中的原始类型 float的值。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Long
    Long类包装一个对象中的基元类型 long的值。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Short
    Short类在一个对象中包含一个原始类型 short的值。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.accessibility
    Class 描述
    已过时的
    @Deprecated
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.activation
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.activity
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.annotation
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.annotation.processing
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.crypto
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.crypto.spec
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.imageio
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by javax.imageio.event
    Class 描述
    String
    String类代表字符串。
  • Classes in java.lang used by javax.imageio.metadata
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.imageio.plugins.bmp
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by javax.imageio.plugins.jpeg
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.imageio.plugins.tiff
    Class 描述
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    Integer
    Integer类包装一个对象中的基元类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.imageio.spi
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.imageio.stream
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.jnlp
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.jws
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    String
    String类表示字符串。
  • Classes in java.lang used by javax.jws.soap
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    String
    String类表示字符串。
  • Classes in java.lang used by javax.lang.model
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.lang.model.element
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.lang.model.type
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.lang.model.util
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.management
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段 - 字段的复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Integer
    Integer类将对象中的原始类型 int的值进行包装。
    Iterable
    实现此接口允许对象成为增强型 for语句的目标（有时称为“for-each loop”语句）。
    NullPointerException
    当应用程序在需要对象的情况下尝试使用 null时抛出。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.management.loading
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by javax.management.modelmbean
    Class 描述
    Boolean
    布尔类在对象中包含基元类型 boolean的值。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.management.monitor
    Class 描述
    Boolean
    布尔类包装一个对象中的基元类型 boolean的值。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.management.openmbean
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Byte
    Byte类包装一个对象中的原始类型为 byte的值。
    Character
    Character类包装一个对象中的原始类型 char的值。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Double
    Double类包装一个对象中的原始类型 double的值。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Float
    Float类在一个对象中包含一个原始类型 float的值。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    Short
    Short类在一个对象中包含一个原始类型 short的值。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • Classes in java.lang used by javax.management.relation
    Class 描述
    Boolean
    布尔类将对象中的基元类型为 boolean 。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IndexOutOfBoundsException
    抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
    Integer
    Integer类包装一个对象中的基元类型 int的值。
    Iterable
    实现此接口允许对象成为增强型 for语句的目标（有时称为“for-each loop”语句）。
    NoSuchMethodException
    当无法找到特定方法时抛出。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.management.remote
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.management.remote.rmi
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    ClassLoader
    类加载器是负责加载类的对象。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.management.timer
    Class 描述
    Boolean
    布尔类包含一个对象中的基元类型 boolean的值。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Long
    Long类包装一个对象中的原始类型 long的值。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.naming
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.naming.directory
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.naming.event
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.naming.ldap
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.naming.spi
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.net
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.net.ssl
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应由实例由线程执行的任何类实现。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.print
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表明合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.print.attribute
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.print.attribute.standard
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段 - 字段的复制是合法的。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.print.event
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类表示字符串。
  • Classes in java.lang used by javax.rmi
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassCastException
    抛出表示代码尝试将对象转换为不属于实例的子类。
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by javax.rmi.CORBA
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassCastException
    抛出表示代码尝试将对象转换为不属于实例的子类。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.rmi.ssl
    Class 描述
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.script
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    NoSuchMethodException
    当无法找到特定方法时抛出。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.security.auth
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.security.auth.callback
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.security.auth.kerberos
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.security.auth.login
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.security.auth.spi
    Class 描述
    String
    String类代表字符串。
  • Classes in java.lang used by javax.security.auth.x500
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.security.cert
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.security.sasl
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.smartcardio
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.sound.midi
    Class 描述
    ArrayIndexOutOfBoundsException
    抛出以表示使用非法索引访问数组。
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.sound.midi.spi
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by javax.sound.sampled
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.sound.sampled.spi
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by javax.sql
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.sql.rowset
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.sql.rowset.serial
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段的字段复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    String
    String类表示字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.sql.rowset.spi
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.swing
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类在对象中包含基元类型 boolean的值。
    Character
    Character类包装一个对象中的原始类型 char的值。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段的字段复制是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    InstantiationException
    当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但是指定的类对象不能被实例化。
    Integer
    Integer类包装一个对象中的基元类型 int的值。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应该由实例旨在由线程执行的任何类来实现。
    SafeVarargs
    程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
    SecurityException
    由安全管理员抛出，表示安全违规。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.swing.border
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.colorchooser
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.event
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.filechooser
    Class 描述
    Boolean
    布尔类在对象中包含基元类型 boolean的值。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.swing.plaf
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.plaf.basic
    Class 描述
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行字段的字段复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Integer
    Integer类将一个对象中的原始类型为 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.plaf.metal
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.plaf.multi
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.plaf.nimbus
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.plaf.synth
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.table
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.text
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Runnable
    Runnable接口应由实例由线程执行的任何类实现。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Thread
    线程是程序中执行的线程。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.swing.text.html
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.text.html.parser
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    StringBuffer
    线程安全，可变的字符序列。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.text.rtf
    Class 描述
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by javax.swing.tree
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例的字段字段的副本是合法的。
    CloneNotSupportedException
    抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.swing.undo
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理的应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.tools
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Boolean
    布尔类将对象中的基元类型 boolean的值进行包装。
    CharSequence
    A CharSequence是 char值的可读序列。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.transaction
    Class 描述
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.transaction.xa
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.bind
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.bind.annotation
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.bind.annotation.adapters
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.bind.attachment
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类表示字符串。
  • Classes in java.lang used by javax.xml.bind.helpers
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.bind.util
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by javax.xml.catalog
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.crypto
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.crypto.dom
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.crypto.dsig
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.crypto.dsig.dom
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by javax.xml.crypto.dsig.keyinfo
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.crypto.dsig.spec
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.datatype
    Class 描述
    ClassLoader
    类加载器是负责加载类的对象。
    Cloneable
    一个类实现了 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Number
    抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.namespace
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.parsers
    Class 描述
    ClassLoader
    类加载器是负责加载类的对象。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.soap
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by javax.xml.stream
    Class 描述
    ClassLoader
    类加载器是负责加载类的对象。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类表示字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.stream.events
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.stream.util
    Class 描述
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    String
    String类表示字符串。
  • Classes in java.lang used by javax.xml.transform
    Class 描述
    ClassLoader
    类加载器是负责加载类的对象。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.transform.dom
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.transform.sax
    Class 描述
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类表示字符串。
  • Classes in java.lang used by javax.xml.transform.stax
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.transform.stream
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类表示字符串。
  • Classes in java.lang used by javax.xml.validation
    Class 描述
    ClassLoader
    类加载器是负责加载类的对象。
    Error
    一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.ws
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.ws.handler
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.ws.handler.soap
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.ws.http
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.ws.soap
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by javax.xml.ws.spi
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.ws.spi.http
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.ws.wsaddressing
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by javax.xml.xpath
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by jdk.dynalink
    Class 描述
    ClassLoader
    类加载器是负责加载类的对象。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    StackTraceElement
    堆栈跟踪中的元素，由 Throwable.getStackTrace()返回。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by jdk.dynalink.beans
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by jdk.dynalink.linker
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by jdk.dynalink.linker.support
    Class 描述
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Iterable
    实现此接口允许对象成为增强型 for语句的目标（有时称为“for-each loop”语句）。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
  • Classes in java.lang used by jdk.dynalink.support
    Class 描述
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
  • Classes in java.lang used by jdk.incubator.http
    Class 描述
    CharSequence
    A CharSequence是 char值的可读序列。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    InterruptedException
    线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
    Iterable
    实现此接口允许对象成为增强型 for语句（有时称为“for-each loop”语句）的目标。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    Void
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
  • Classes in java.lang used by jdk.javadoc.doclet
    Class 描述
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by jdk.jshell
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    IllegalStateException
    表示在非法或不适当的时间调用了一种方法。
    Integer
    Integer类包装一个对象中的原始类型 int的值。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by jdk.jshell.execution
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Process
    Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by jdk.jshell.spi
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    StackTraceElement
    一个堆栈跟踪中的一个元素，由 Throwable.getStackTrace()返回。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by jdk.jshell.tool
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    String
    String类代表字符串。
  • Classes in java.lang used by jdk.nashorn.api.scripting
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    ClassLoader
    类加载器是负责加载类的对象。
    已过时的
    注释的程序元素 @Deprecated是程序员不鼓励使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    NoSuchMethodException
    当无法找到特定方法时抛出。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    Readable
    A Readable是一个字符的来源。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    StackTraceElement
    堆栈跟踪中的一个元素，由 Throwable.getStackTrace()返回。
    String
    String类表示字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
    UnsupportedOperationException
    抛出以表示不支持请求的操作。
  • Classes in java.lang used by jdk.nashorn.api.tree
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    FunctionalInterface
    用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
    IllegalArgumentException
    抛出表示一种方法已经通过了非法或不正确的参数。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by jdk.net
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Comparable
    该接口对实现它的每个类的对象强加一个整体排序。
    Object
    类 Object是类层次结构的根。
    Override
    表示方法声明旨在覆盖超类型中的方法声明。
    String
    String类代表字符串。
  • Classes in java.lang used by jdk.packager.services
    Class 描述
    String
    String类代表字符串。
  • Classes in java.lang used by jdk.security.jarsigner
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by netscape.javascript
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是程序员不鼓励使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.ietf.jgss
    Class 描述
    Cloneable
    一个类实现 Cloneable接口，以指示 Object.clone()方法，该方法对于该类的实例进行现场复制是合法的。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.CORBA
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.CORBA.DynAnyPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.CORBA.ORBPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.CORBA.TypeCodePackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.CORBA.portable
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    Class类的实例表示正在运行的Java应用程序中的类和接口。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    Object类是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.CORBA_2_3
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.omg.CORBA_2_3.portable
    Class 描述
    AutoCloseable
    可以保存资源的对象（如文件或套接字句柄），直到它关闭。
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.omg.CosNaming
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.omg.CosNaming.NamingContextExtPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.CosNaming.NamingContextPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.Dynamic
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by org.omg.DynamicAny
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.omg.DynamicAny.DynAnyFactoryPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.DynamicAny.DynAnyPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.IOP
    Class 描述
    Object
    Object类是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.omg.IOP.CodecFactoryPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.IOP.CodecPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.Messaging
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.omg.PortableInterceptor
    Class 描述
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.PortableInterceptor.ORBInitInfoPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.PortableServer
    Class 描述
    Class
    类 Class实例表示正在运行的Java应用程序中的类和接口。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.PortableServer.CurrentPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.PortableServer.POAManagerPackage
    Class 描述
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.PortableServer.POAPackage
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.omg.PortableServer.ServantLocatorPackage
    Class 描述
    Object
    类 Object是类层次结构的根。
  • Classes in java.lang used by org.omg.PortableServer.portable
    Class 描述
    String
    String类代表字符串。
  • Classes in java.lang used by org.omg.stub.java.rmi
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.w3c.dom
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.w3c.dom.bootstrap
    Class 描述
    ClassCastException
    抛出表示代码尝试将对象转换为不属于实例的子类。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    InstantiationException
    当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但是指定的类对象不能被实例化。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.w3c.dom.css
    Class 描述
    String
    String类代表字符串。
  • Classes in java.lang used by org.w3c.dom.events
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.w3c.dom.html
    Class 描述
    String
    String类代表字符串。
  • Classes in java.lang used by org.w3c.dom.ls
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.w3c.dom.ranges
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.w3c.dom.stylesheets
    Class 描述
    String
    String类表示字符串。
  • Classes in java.lang used by org.w3c.dom.xpath
    Class 描述
    异常
    异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    RuntimeException
    RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
    String
    String类代表字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.xml.sax
    Class 描述
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    异常
    类 异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
    Object
    类 Object是类层次结构的根。
    String
    String类表示字符串。
    Throwable
    Throwable类是Java语言中所有错误和异常的超类。
  • Classes in java.lang used by org.xml.sax.ext
    Class 描述
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
  • Classes in java.lang used by org.xml.sax.helpers
    Class 描述
    ClassCastException
    抛出表示代码尝试将对象转换为不属于实例的子类。
    ClassNotFoundException
    的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
    已过时的
    注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
    IllegalAccessException
    当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
    InstantiationException
    当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但是指定的类对象不能被实例化。
    NullPointerException
    在需要对象的情况下，当应用程序尝试使用 null时抛出。
    Object
    类 Object是类层次结构的根。
    String
    String类代表字符串。
    SuppressWarnings
    表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VerifyError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class VerifyError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.VerifyError
  • All Implemented Interfaces:
    Serializable

    public class VerifyError
extends LinkageError
    当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VerifyError​()
      构造一个 VerifyError没有详细消息。
      VerifyError​(String s)
      构造具有指定详细消息的 VerifyError 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • VerifyError

        public VerifyError​()
        构造一个 VerifyError ，没有详细消息。

      • VerifyError

        public VerifyError​(String s)
        构造具有指定详细消息的 VerifyError 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VirtualMachineError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class VirtualMachineError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.VirtualMachineError
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    InternalError ， OutOfMemoryError ， StackOverflowError ， UnknownError

    public abstract class VirtualMachineError
extends Error
    抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      VirtualMachineError​()
      构造一个没有详细消息的 VirtualMachineError 。
      VirtualMachineError​(String message)
      构造具有指定详细消息的 VirtualMachineError 。
      VirtualMachineError​(String message, Throwable cause)
      构造具有指定的详细信息和原因的 VirtualMachineError 。
      VirtualMachineError​(Throwable cause)
      构造一个一个 VirtualMachineError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • VirtualMachineError

        public VirtualMachineError​()
        构造一个 VirtualMachineError ，没有详细信息。

      • VirtualMachineError

        public VirtualMachineError​(String message)
        构造具有指定详细消息的 VirtualMachineError 。
        参数
        message - 详细信息。

      • VirtualMachineError

        public VirtualMachineError​(String message,
                           Throwable cause)
        构造一个具有指定的详细信息和原因的VirtualMachineError 。

        请注意，与cause相关联的详细信息不会自动并入此错误的详细消息。

        参数
        message - 详细信息（保存以供 Throwable.getMessage()方法稍后检索）。
        cause - 原因（保存以供Throwable.getCause()方法后续检索）。 （A null值是允许的，并且表示原因不存在或未知。）
        从以下版本开始：
        1.8

      • VirtualMachineError

        public VirtualMachineError​(Throwable cause)
        构造一个一个 VirtualMachineError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（由Throwable.getCause()方法保存供以后检索）。 （A null允许值，表示原因不存在或未知。）
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Void (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang

Class Void

  • java.lang.Object
    • java.lang.Void

  • public final class Void
extends Object
    Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Class<Void> TYPE
      Class对象表示对应于关键字 void的伪类型。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TYPE

        public static final Class<Void> TYPE
        表示对应于关键字 void的伪类型的 Class对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.annotation

Interface Annotation

  • 所有已知实现类：
    Action ， Addressing ， BeanProperty ， BindingType ， ConstructorParameters ， ConstructorProperties ， DefaultProperty ， 已过时的 ， DescriptorKey ， Documented ， FaultAction ， FunctionalInterface ， FXML ， Generated ， Generated ， HandlerChain ， Inherited ， InitParam ， JavaBean ， MTOM ， MXBean ， NamedArg ， Native ， Oneway ， Override ， PostConstruct ， PreDestroy ， Repeatable ， RequestWrapper ， Resource ， Resources ， RespectBinding ， ResponseWrapper ， Retention ， SafeVarargs ， ServiceMode ， SOAPBinding ， SOAPMessageHandler ， SOAPMessageHandlers ， SupportedAnnotationTypes ， SupportedOptions ， SupportedSourceVersion ， SuppressWarnings ， SwingContainer ， Target ， Transient ， WebEndpoint ， WebFault ， WebMethod ， WebParam ， WebResult ， WebService ， WebServiceClient ， WebServiceFeatureAnnotation ， WebServiceProvider ， WebServiceRef WebServiceRef ， WebServiceRefs ， XmlAccessorOrder ， XmlAccessorType ， XmlAnyAttribute ， XmlAnyElement ， XmlAttachmentRef ， XmlAttribute ， XmlElement ， XmlElementDecl ， XmlElementRef ， XmlElementRefs ， XmlElements ， XmlElementWrapper ， XmlEnum ， XmlEnumValue ， XmlID ， XmlIDREF ， XmlInlineBinaryData ， XmlJavaTypeAdapter ， XmlJavaTypeAdapters ， XmlList ， XmlMimeType ， XmlMixed ， XmlNs ， XmlRegistry ， XmlRootElement ， XmlSchema ， XmlSchemaType ， XmlSchemaTypes ， XmlSeeAlso ， XmlTransient ， XmlType ， XmlValue

    public interface Annotation
    所有注释类型扩展的公共接口。 注意，手动扩展这个接口不限定注释类型。 还要注意，此接口本身并不定义注释类型。 有关注释类型的更多信息，请参见第The Java™ Language Specification的 9.6 节 。 AnnotatedElement接口讨论了将注释类型从不可重复性转变为可重复时的兼容性问题。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Class<? extends Annotation> annotationType​()
      返回此注释的注释类型。
      boolean equals​(Object obj)
      如果指定的对象表示在逻辑上等同于该注释的注释，则返回true。
      int hashCode​()
      返回此注释的哈希码，定义如下：
      String toString​()
      返回此注释的字符串表示形式。

    • 方法详细信息

      • equals

        boolean equals​(Object obj)
        如果指定的对象表示在逻辑上等同于该注释的注释，则返回true。 换句话说，如果指定的对象是与该实例相同的注释类型的实例，则返回true，所有这些实例的所有成员都等于此注释的相应成员，定义如下：
        • 两个相应的原语类型的成员的值是x和y被视为相等如果x == y ，除非它们的类型是float或double 。
        • 两个对应float成员，其值是x和y被认为是如果相等Float.valueOf(x).equals(Float.valueOf(y)) 。 （与==运算符不同，NaN被认为等于自身，而0.0f不等于-0.0f ）
        • 两个对应double成员，其值是x和y被认为是如果相等Double.valueOf(x).equals(Double.valueOf(y)) 。 （与==运算符不同，NaN被认为等于自身，而0.0不等于-0.0 ）
        • 两个相应的String ， Class ，enum或annotation类型的成员的值是x和y被认为是相等如果x.equals(y) 。 （请注意，此定义对于注释类型的成员是递归的。）
        • 两个对应的数组类型的成员x和y被认为是相等的，如果是Arrays.equals(x, y) ，为适当的超载Arrays.equals(long[], long[]) 。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        如果指定的对象表示逻辑上等同于该注释的注释，则为true，否则为false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        int hashCode​()
        返回此注释的哈希码，定义如下：

        注释的哈希码是其成员的哈希码（包括具有默认值的哈希码）的和，如下所定义：注释成员的哈希码是（127位的成员名称的哈希码，由String.hashCode() ）XOR是成员值的哈希码，如下定义：

        成员值的哈希码取决于其类型：

        • 原始值的哈希码v等于WrapperType.valueOf(v).hashCode() ，其中WrapperType是相应于原语类型的包装类型v （ Byte ， Character ， Double ， Float ， Integer ， Long ， Short ，或Boolean ）。
        • 字符串，枚举，类或注释成员值I v的哈希码通过调用v.hashCode()计算。 （在注释成员值的情况下，这是递归定义。）
        • 数组成员值的哈希码是通过调用的适当重载计算Arrays.hashCode上的值。 （每个基本类型有一个重载，一个用于对象引用类型）。
        重写：
        hashCode在 Object
        结果
        该注释的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        String toString​()
        返回此注释的字符串表示形式。 表示的细节依赖于实现，但以下可能被认为是典型的：
          @com.acme.util.Name(first=Alfred, middle=E., last=Neuman)
        重写：
        toString在 Object
        结果
        此注释的字符串表示形式

      • annotationType

        Class<? extends Annotation> annotationType​()
        返回此注释的注释类型。
        结果
        此注释的注释类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationFormatError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.annotation

Class AnnotationFormatError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.annotation.AnnotationFormatError
  • All Implemented Interfaces:
    Serializable

    public class AnnotationFormatError
extends Error
    当注释解析器尝试从类文件读取注释并确定注释格式错误时抛出。 这个错误可以抛出API used to read annotations reflectively 。
    从以下版本开始：
    1.5
    另请参见：
    AnnotatedElement ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AnnotationFormatError​(String message)
      构造一个新的 AnnotationFormatError与指定的详细信息。
      AnnotationFormatError​(String message, Throwable cause)
      构造一个新的 AnnotationFormatError与指定的详细信息和原因。
      AnnotationFormatError​(Throwable cause)
      构造一个新的 AnnotationFormatError与指定的原因和详细消息 (cause == null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AnnotationFormatError

        public AnnotationFormatError​(String message)
        构造一个新的 AnnotationFormatError与指定的详细信息。
        参数
        message - 详细信息。

      • AnnotationFormatError

        public AnnotationFormatError​(String message,
                             Throwable cause)
        构造一个新的AnnotationFormatError与指定的详细信息和原因。 请注意，与cause相关联的详细信息不会自动并入此错误的详细消息。
        参数
        message - 详细信息
        cause - 原因（允许A null值，表示原因不存在或未知）。

      • AnnotationFormatError

        public AnnotationFormatError​(Throwable cause)
        构造一个新的 AnnotationFormatError与指定的原因和详细消息 (cause == null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
        参数
        cause - 原因（允许为A null ，表示原因不存在或未知）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotationTypeMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.annotation

Class AnnotationTypeMismatchException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.annotation.AnnotationTypeMismatchException
  • All Implemented Interfaces:
    Serializable

    public class AnnotationTypeMismatchException
extends RuntimeException
    抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。 这个异常可以抛出API used to read annotations reflectively 。
    从以下版本开始：
    1.5
    另请参见：
    AnnotatedElement ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      AnnotationTypeMismatchException​(方法 element, String foundType)
      为指定的注释类型元素构造AnnotationTypeMismatchException，并找到数据类型。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      方法 element​()
      返回错误类型元素的 方法对象。
      String foundType​()
      返回错误类型元素中找到的数据类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • AnnotationTypeMismatchException

        public AnnotationTypeMismatchException​(方法 element,
                                       String foundType)
        为指定的注释类型元素构造AnnotationTypeMismatchException，并找到数据类型。
        参数
        element - 注释元素的 方法对象，可能是 null
        foundType - 注释中发现的（错误的）数据类型。 该字符串也可以，但不是必需的，也包含该值。 字符串的确切格式未指定，可能为null 。

    • 方法详细信息

      • element

        public 方法 element​()
        返回错误类型元素的方法对象。 如果此异常已被序列化，然后再读入，该值可能不可用。
        结果
        方法对象的错误类型元素，如果不可用， null

      • foundType

        public String foundType​()
        返回错误类型元素中找到的数据类型。 返回的字符串也可以，但不是必需的，也包含该值。 字符串的确切格式未指定，字符串可能为null 。
        结果
        在错误类型的元素中找到的数据类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Documented (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang.annotation

Annotation Type Documented

  • @Documented
@Retention(RUNTIME)
@Target(ANNOTATION_TYPE)
public @interface Documented
    如果在注释类型A的声明上存在注释@Documented ，则元素上的任何@A注释将被视为元素的公共合同的一部分。 更详细地，当注释类型A被标注为Documented ，存在和类型A的注释的值是A注释元素的公共合同的一部分。 相反，如果注释类型B 没有用Documented注释，则B注释的存在和值不是元素B注释的公共合同的一部分。 具体来说，如果注释类型用Documented注释，默认情况下，像javadoc这样的工具会在其输出中显示该类型的注释，而不会显示不带Documented的注释类型的注释。
    从以下版本开始：
    1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


ElementType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang.annotation

Enum ElementType

  • java.lang.Object
    • java.lang.Enum<ElementType>
      • java.lang.annotation.ElementType
  • All Implemented Interfaces:
    Serializable ， Comparable<ElementType>

    public enum ElementType
extends Enum<ElementType>
    这个枚举类型的常量提供了在Java程序中可能出现注释的句法位置的简单分类。 这些常数用于Target元注释，以指定写入给定类型注释的合法位置。

    注释可能出现的句法位置分为声明上下文 ，其中注释适用于声明，并键入上下文 ，其中注释适用于声明和表达式中使用的类型。

    常量ANNOTATION_TYPE ， CONSTRUCTOR ， 字段 ， LOCAL_VARIABLE ， METHOD ， PACKAGE ， MODULE ， PARAMETER ， TYPE ，并TYPE_PARAMETER对应于JLS 9.6.4.1声明上下文。

    例如，其类型用@Target(ElementType.FIELD)元注释的注释只能被写为字段声明的修饰符。

    常数TYPE_USE对应于JLS 4.11中的类型上下文，以及两个声明上下文：类型声明（包括注释类型声明）和类型参数声明。

    例如，其类型用@Target(ElementType.TYPE_USE)进行元注释的注释可以写入字段的类型（或者在字段的类型中，如果它是嵌套的，参数化的或数组类型），并且也可以表示为修饰语，说，一个类声明。

    TYPE_USE常数包括类型声明和类型参数声明，以便为给注释类型赋予语义的类型检查器的设计者方便。 例如，如果在注释类型NonNull是间注解为@Target(ElementType.TYPE_USE) ，然后@NonNull class C {...}可以由类型检查器被视为指示类的所有变量C非空，同时仍然允许其他类的变量是非空或者基于是否在变量的声明中出现@NonNull否则不为非空。

    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    9.6.4.1 @Target，4.1类型和值的种类

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      ANNOTATION_TYPE
      注解类型声明
      CONSTRUCTOR
      构造函数声明
      字段
      字段声明（包括枚举常数）
      LOCAL_VARIABLE
      局部变量声明
      METHOD
      方法声明
      MODULE
      模块声明。
      PACKAGE
      包装声明
      PARAMETER
      正式参数声明
      TYPE
      类，接口（包括注释类型）或枚举声明
      TYPE_PARAMETER
      键入参数声明
      TYPE_USE
      使用类型

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ElementType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ElementType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TYPE

        public static final ElementType TYPE
        类，接口（包括注释类型）或枚举声明

      • 字段

        public static final ElementType FIELD
        字段声明（包括枚举常数）

      • METHOD

        public static final ElementType METHOD
        方法声明

      • PARAMETER

        public static final ElementType PARAMETER
        正式参数声明

      • CONSTRUCTOR

        public static final ElementType CONSTRUCTOR
        构造函数声明

      • LOCAL_VARIABLE

        public static final ElementType LOCAL_VARIABLE
        局部变量声明

      • ANNOTATION_TYPE

        public static final ElementType ANNOTATION_TYPE
        注解类型声明

      • PACKAGE

        public static final ElementType PACKAGE
        包装声明

      • TYPE_PARAMETER

        public static final ElementType TYPE_PARAMETER
        键入参数声明
        从以下版本开始：
        1.8

      • TYPE_USE

        public static final ElementType TYPE_USE
        使用类型
        从以下版本开始：
        1.8

      • MODULE

        public static final ElementType MODULE
        模块声明。
        从以下版本开始：
        9

    • 方法详细信息

      • values

        public static ElementType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ElementType c : ElementType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ElementType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


IncompleteAnnotationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.annotation

Class IncompleteAnnotationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.annotation.IncompleteAnnotationException
  • All Implemented Interfaces:
    Serializable

    public class IncompleteAnnotationException
extends RuntimeException
    抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。 如果新元素具有默认值，则不会抛出此异常。 这个异常可以抛出API used to read annotations reflectively 。
    从以下版本开始：
    1.5
    另请参见：
    AnnotatedElement ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IncompleteAnnotationException​(Class<? extends Annotation> annotationType, String elementName)
      构造一个IncompleteAnnotationException来指示指定的元素在指定的注释类型中丢失。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<? extends Annotation> annotationType​()
      返回缺少元素的注释类型的Class对象。
      String elementName​()
      返回缺少元素的名称。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IncompleteAnnotationException

        public IncompleteAnnotationException​(Class<? extends Annotation> annotationType,
                                     String elementName)
        构造一个IncompleteAnnotationException来指示指定的元素在指定的注释类型中丢失。
        参数
        annotationType - 注释类型的Class对象
        elementName - 缺少元素的名称
        异常
        NullPointerException - 如果任一参数是 null

    • 方法详细信息

      • annotationType

        public Class<? extends Annotation> annotationType​()
        返回缺少元素的注释类型的Class对象。
        结果
        具有缺少元素的注释类型的Class对象

      • elementName

        public String elementName​()
        返回缺少元素的名称。
        结果
        缺少元素的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Inherited (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang.annotation

Annotation Type Inherited

  • @Documented
@Retention(RUNTIME)
@Target(ANNOTATION_TYPE)
public @interface Inherited
    表示注释类型自动继承。 如果在注释类型声明中存在继承的元注释，并且用户在类声明上查询注释类型，并且类声明没有此类型的注释，则该类的超类将自动查询注释类型。 将重复此过程，直到找到此类型的注释，或者达到类层次结构（Object）的顶部。 如果没有超类具有此类型的注释，则查询将指示所讨论的类没有这样的注释。

    请注意，如果使用注释类型来注释除类之外的任何内容，则此元注释类型不起作用。 还要注意，这个元注释只会导致从超类继承注释; 已实现的接口上的注释无效。

    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    9.6.4.3 @Inherited
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


java.lang.annotation (Java SE 9 & JDK 9 )

java.lang.annotation

Interfaces

  • Annotation

Enums

  • ElementType
  • RetentionPolicy

Exceptions

  • AnnotationTypeMismatchException
  • IncompleteAnnotationException

Errors

  • AnnotationFormatError

注解类型

  • Documented
  • Inherited
  • Native
  • Repeatable
  • Retention
  • Target


java.lang.annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.lang.annotation

为Java编程语言注释工具提供库支持。
从以下版本开始：
1.5
  • 接口摘要
    接口 描述
    Annotation
    所有注释类型扩展的公共接口。
  • 枚举摘要
    Enum 描述
    ElementType
    这个枚举类型的常量提供了在Java程序中可能出现注释的句法位置的简单分类。
    RetentionPolicy
    注释保留政策。
  • 异常摘要
    异常 描述
    AnnotationTypeMismatchException
    抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。
    IncompleteAnnotationException
    抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。
  • Error Summary
    Error 描述
    AnnotationFormatError
    当注释解析器尝试从类文件读取注释并确定注释格式错误时抛出。
  • 注解类型摘要
    Annotation Type 描述
    Documented
    如果批注 @Documented在注释类型 A的声明中存在，则元素上的任何 @A注释将被视为元素的公共合同的一部分。
    Inherited
    表示注释类型自动继承。
    Native
    表示定义常量值的字段可以从本地代码引用。
    Repeatable
    注释类型 java.lang.annotation.Repeatable用于表示其（meta-）注释声明的注释类型是 可重复的 。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    Indicates the contexts in which an annotation type is applicable.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang.annotation Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang.annotation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.annotation.AnnotationFormatError
      • java.lang.异常
        • java.lang.RuntimeException
          • java.lang.annotation.AnnotationTypeMismatchException
          • java.lang.annotation.IncompleteAnnotationException

Interface Hierarchy

  • java.lang.annotation.Annotation

Annotation Type Hierarchy

  • java.lang.annotation.Documented (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Inherited (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Native (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Repeatable (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Retention (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Target (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.annotation.ElementType
      • java.lang.annotation.RetentionPolicy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Native (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang.annotation

Annotation Type Native

  • @Documented
@Target(字段)
@Retention(SOURCE)
public @interface Native
    表示定义常量值的字段可以从本地代码引用。 注释可以用作生成本机头文件以确定是否需要头文件的工具的提示，如果是，则应该包含哪些声明。
    从以下版本开始：
    1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Repeatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang.annotation

Annotation Type Repeatable

  • @Documented
@Retention(RUNTIME)
@Target(ANNOTATION_TYPE)
public @interface Repeatable
    注释类型java.lang.annotation.Repeatable用于表示其（meta-）注释声明的注释类型是可重复的 。 @Repeatable的值表示可重复注释类型的包含注释类型。
    从以下版本开始：
    1.8
    See The Java™ Language Specification:
    9.6.3可重复注释类型，9.7.5相同类型的多重注释

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      Class<? extends Annotation> value
      表示可重复注释类型的 包含注释类型。

    • Element Detail

      • value

        Class<? extends Annotation> value
        表示可重复注释类型的 包含注释类型。
        结果
        包含注释类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Retention (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang.annotation

Annotation Type Retention

  • @Documented
@Retention(RUNTIME)
@Target(ANNOTATION_TYPE)
public @interface Retention
    指示要注释具有注释类型的注释的保留时间。 如果在注释类型声明中没有保留注释，则保留策略默认为RetentionPolicy.CLASS 。

    保留元注释仅在元注释类型直接用于注释时才起作用。 如果元注释类型用作另一注释类型的成员类型，则它不起作用。

    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    9.6.4.2 @Retention

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      RetentionPolicy value
      返回保留策略。

    • Element Detail

      • value

        RetentionPolicy value
        返回保留策略。
        结果
        保留政策
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


RetentionPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang.annotation

Enum RetentionPolicy

  • java.lang.Object
    • java.lang.Enum<RetentionPolicy>
      • java.lang.annotation.RetentionPolicy
  • All Implemented Interfaces:
    Serializable ， Comparable<RetentionPolicy>

    public enum RetentionPolicy
extends Enum<RetentionPolicy>
    注释保留政策。 这个枚举类型的常量描述了保留注释的各种策略。 它们与Retention元注释类型一起使用，以指定要保留注释的时间长度。
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CLASS
      注释将由编译器记录在类文件中，但VM不需要在运行时保留。
      RUNTIME
      注释将由编译器记录在类文件中，并由VM在运行时保留，因此可以反射读取。
      SOURCE
      注释将被编译器丢弃。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static RetentionPolicy valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static RetentionPolicy[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SOURCE

        public static final RetentionPolicy SOURCE
        注释将被编译器丢弃。

      • CLASS

        public static final RetentionPolicy CLASS
        注释将由编译器记录在类文件中，但VM不需要在运行时保留。 这是默认行为。

      • RUNTIME

        public static final RetentionPolicy RUNTIME
        注释将由编译器记录在类文件中，并由VM在运行时保留，因此可以反射读取。
        另请参见：
        AnnotatedElement

    • 方法详细信息

      • values

        public static RetentionPolicy[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (RetentionPolicy c : RetentionPolicy.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static RetentionPolicy valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Target (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element
Module java.base
软件包 java.lang.annotation

Annotation Type Target

  • @Documented
@Retention(RUNTIME)
@Target(ANNOTATION_TYPE)
public @interface Target
    指示注释类型适用的上下文。 注释类型可能适用的声明上下文和类型上下文在JLS 9.6.4.1中指定，源代码中的枚举常数为java.lang.annotation.ElementType 。

    如果在注释类型T上不存在一个@Target元注释，则可以将类型为T的注释写为除了类型参数声明之外的任何声明的修饰符。

    如果存在一个@Target元注释，则编译器将强制执行由ElementType枚举常数指定的使用限制，符合JLS 9.7.4。

    例如，这个@Target元注释表明声明的类型本身是元注释类型。 它只能用于注释类型声明：

      @Target(ElementType.ANNOTATION_TYPE)
    public @interface MetaAnnotationType {
        ...
    }

    此@Target元注释表示声明的类型仅用于复杂注释类型声明中的成员类型。 它不能直接用于注释任何东西：

      @Target({})
    public @interface MemberType {
        ...
    }

    一个ElementType常量在@Target注释中不止一次出现编译时错误。 例如，以下@Target元注释是非法的：

      @Target({ElementType.FIELD, ElementType.METHOD, ElementType.FIELD})
    public @interface Bogus {
        ...
    }
    从以下版本开始：
    1.5
    See The Java™ Language Specification:
    9.6.4.1 @Target，9.7.4注释可能出现时，9.7.5同一类型的多重注释

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element 描述
      ElementType[] value
      返回注释类型可应用于的元素种类的数组。

    • Element Detail

      • value

        ElementType[] value
        返回注释类型可应用于的元素种类的数组。
        结果
        可应用注释类型的元素种类的数组
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 字段 |
  • Required |
  • Optional
  • 详细信息：
  • 字段 |
  • Element

Report a bug or suggest an enhancement


Uses of Package java.lang.annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang.annotation

  • Packages that use java.lang.annotation
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.jws
    javax.jws.soap
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.bind.annotation.adapters
    XmlAdapter及其规范定义的子类，允许任意Java类与JAXB一起使用。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。
  • Classes in java.lang.annotation used by java.awt
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by java.awt.color
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by java.awt.dnd
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by java.awt.event
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by java.awt.geom
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by java.awt.image
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by java.awt.print
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by java.beans
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释都将被视为元素公共合同的一部分。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by java.lang
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释将被视为元素的公共合同的一部分。
    Native
    表示定义常量值的字段可以从本地代码引用。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by java.lang.annotation
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果注解类型 A的声明中存在注释 @Documented ，则元素上的任何 @A注释将被视为元素公共合同的一部分。
    ElementType
    这个枚举类型的常量提供了在Java程序中可能出现注释的句法位置的简单分类。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    RetentionPolicy
    注释保留政策。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by java.lang.reflect
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
  • Classes in java.lang.annotation used by java.net
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
  • Classes in java.lang.annotation used by javafx.beans
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注解类型 A的声明上，则元素上的任何 @A注释将被视为元素公共合同的一部分。
    Inherited
    表示注释类型自动继承。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javafx.fxml
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.annotation
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释将被视为元素的公共合同的一部分。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.annotation.processing
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释将被视为元素公共合同的一部分。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.jws
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.jws.soap
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.lang.model
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
  • Classes in java.lang.annotation used by javax.lang.model.element
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
  • Classes in java.lang.annotation used by javax.management
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释都将被视为元素公共合同的一部分。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.swing
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.xml.bind.annotation
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Inherited
    表示注释类型自动继承。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.xml.bind.annotation.adapters
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.xml.ws
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释将被视为元素公共合同的一部分。
    Inherited
    表示注释类型自动继承。
    Repeatable
    注释类型 java.lang.annotation.Repeatable用于表示其声明（meta-）注释的注释类型是 可重复的 。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.xml.ws.soap
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释将被视为元素的公共合同的一部分。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by javax.xml.ws.spi
    Class 描述
    Annotation
    所有注释类型扩展的公共接口。
    Documented
    如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释都将被视为元素公共合同的一部分。
    Retention
    指示要注释具有注释类型的注释的保留时间。
    Target
    指示注释类型适用的上下文。
  • Classes in java.lang.annotation used by jdk.net
    Class 描述
    Native
    表示定义常量值的字段可以从本地代码引用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.AnnotationFormatError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.AnnotationFormatError

No usage of java.lang.annotation.AnnotationFormatError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.AnnotationTypeMismatchException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.AnnotationTypeMismatchException

No usage of java.lang.annotation.AnnotationTypeMismatchException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.Documented (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.Documented

  • Packages that use Documented
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.management
    提供Java管理扩展的核心类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。

    • Uses of Documented in java.beans

      Classes in java.beans with annotations of type Documented
      Modifier and Type Class 描述
      interface  BeanProperty
      用于指定自动生成的BeanInfo类的一些属性相关信息的注释。
      interface  ConstructorProperties
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  JavaBean
      用于为自动生成的BeanInfo类指定一些类相关信息的注释。

    • Uses of Documented in java.lang

      Classes in java.lang with annotations of type Documented
      Modifier and Type Class 描述
      interface  已过时的
      注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
      interface  FunctionalInterface
      用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
      interface  SafeVarargs
      程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。

    • Uses of Documented in java.lang.annotation

      Classes in java.lang.annotation with annotations of type Documented
      Modifier and Type Class 描述
      interface  Documented
      如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释都将被视为元素公共合同的一部分。
      interface  Inherited
      表示注释类型自动继承。
      interface  Native
      表示定义常量值的字段可以从本地代码引用。
      interface  Repeatable
      注释类型 java.lang.annotation.Repeatable用于指示其（meta-）注释声明的注释类型是 可重复的 。
      interface  Retention
      指示要注释具有注释类型的注释的保留时间。
      interface  Target
      指示注释类型适用的上下文。

    • Uses of Documented in javafx.beans

      Classes in javafx.beans with annotations of type Documented
      Modifier and Type Class 描述
      interface  DefaultProperty
      指定未指定显式属性时将添加或设置子元素的属性。

    • Uses of Documented in javax.annotation

      Classes in javax.annotation with annotations of type Documented
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  PostConstruct
      PostConstruct注释用于需要执行相关性注入后执行任何初始化的方法。
      interface  PreDestroy
      PreDestroy注释在方法上用作回调通知，表明实例正在被容器移除。
      interface  Resources
      此类用于允许多个资源声明。

    • Uses of Documented in javax.annotation.processing

      Classes in javax.annotation.processing with annotations of type Documented
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  SupportedAnnotationTypes
      用于指示注释处理器支持的注释类型的注释。
      interface  SupportedOptions
      用于指示注释处理器支持哪些选项的注释。
      interface  SupportedSourceVersion
      用于指示注释处理器支持的最新源版本的注释。

    • Uses of Documented in javax.management

      Classes in javax.management with annotations of type Documented
      Modifier and Type Class 描述
      interface  ConstructorParameters
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  DescriptorKey
      描述注释元素如何与Descriptor中的字段相关的元标注 。
      interface  MXBean
      用于将界面明确标记为MXBean接口或不作为MXBean接口的注释。

    • Uses of Documented in javax.xml.ws

      Classes in javax.xml.ws with annotations of type Documented
      Modifier and Type Class 描述
      interface  Action
      所述 Action注释允许一个WS寻址的显式关联 Action与消息寻址属性 input ， output和 fault映射WSDL操作的消息。
      interface  BindingType
      BindingType注释用于指定用于Web服务端点实现类的绑定。
      interface  FaultAction
      所述FaultAction注解用于内部Action注释以允许WS寻址的显式关联Action与消息寻址属性fault从异常类映射到的WSDL操作的消息。
      interface  RequestWrapper
      用于使用要在运行时使用的请求包装器bean来注释服务端点接口中的方法。
      interface  RespectBinding
      此功能说明了JAX-WS运行时中使用的 wsdl:binding 。
      interface  ResponseWrapper
      用于使用要在运行时使用的响应包装器bean来注释服务端点接口中的方法。
      interface  ServiceMode
      用于指示Provider实现是否希望使用整个协议消息或仅使用协议消息有效载荷。
      interface  WebEndpoint
      用于注释生成的服务接口的 getPortName()方法。
      interface  WebFault
      用于注释特定于服务的异常类，以定制到故障元素的本地和命名空间名称以及故障bean的名称。
      interface  WebServiceClient
      用于注释生成的服务接口。
      interface  WebServiceProvider
      用于注释Provider实现类。
      interface  WebServiceRef
      WebServiceRef注释用于定义对Web服务的引用以及（可选）为其注入目标。
      interface  WebServiceRefs
      WebServiceRefs注释允许在类级别声明多个Web服务引用。

    • Uses of Documented in javax.xml.ws.soap

      Classes in javax.xml.ws.soap with annotations of type Documented
      Modifier and Type Class 描述
      interface  Addressing
      此注释表示使用SOAP 1.1 / HTTP或SOAP 1.2 / HTTP绑定的WS-Addressing。
      interface  MTOM
      此功能表示使用具有Web服务的MTOM。

    • Uses of Documented in javax.xml.ws.spi

      Classes in javax.xml.ws.spi with annotations of type Documented
      Modifier and Type Class 描述
      interface  WebServiceFeatureAnnotation
      Annotation used to identify other annotations as a WebServiceFeature.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.ElementType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.ElementType

  • Packages that use ElementType
    软件包 描述
    java.lang.annotation
    为Java编程语言注释工具提供库支持。

    • Uses of ElementType in java.lang.annotation

      Methods in java.lang.annotation that return ElementType
      Modifier and Type 方法 描述
      static ElementType ElementType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ElementType[] ElementType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.IncompleteAnnotationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.IncompleteAnnotationException

No usage of java.lang.annotation.IncompleteAnnotationException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.Inherited (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.Inherited

  • Packages that use Inherited
    软件包 描述
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.ws
    此软件包包含核心JAX-WS API。

    • Uses of Inherited in javafx.beans

      Classes in javafx.beans with annotations of type Inherited
      Modifier and Type Class 描述
      interface  DefaultProperty
      指定未指定显式属性时将添加或设置子元素的属性。

    • Uses of Inherited in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation with annotations of type Inherited
      Modifier and Type Class 描述
      interface  XmlAccessorOrder
      控制类中字段和属性的顺序。
      interface  XmlAccessorType
      控制字段或Javabean属性是否默认序列化。

    • Uses of Inherited in javax.xml.ws

      Classes in javax.xml.ws with annotations of type Inherited
      Modifier and Type Class 描述
      interface  ServiceMode
      Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.Native (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.Native

  • Packages that use Native
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.print
    提供通用打印API的类和接口。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of Native in java.awt

      Fields in java.awt with annotations of type Native
      Modifier and Type Field 描述
      static int SystemColor.ACTIVE_CAPTION
      阵列索引为 SystemColor.activeCaption系统颜色。
      static int SystemColor.ACTIVE_CAPTION_BORDER
      阵列索引为 SystemColor.activeCaptionBorder系统颜色。
      static int SystemColor.ACTIVE_CAPTION_TEXT
      阵列索引为 SystemColor.activeCaptionText系统颜色。
      static int DisplayMode.BIT_DEPTH_MULTI
      在该显示模式下支持多个位深度时，位深度的值。
      static int Transparency.BITMASK
      表示保证为完全不透明，Alpha值为1.0或完全透明，Alpha值为0.0的图像数据。
      static int BasicStroke.CAP_BUTT
      结束未封闭的子路径和划线段，没有添加装饰。
      static int BasicStroke.CAP_ROUND
      用圆形装饰结束未封闭的子路径和划线段，半圆形的半径等于笔宽的一半。
      static int BasicStroke.CAP_SQUARE
      结束未封闭的子路径和划线段，其中方块投影延伸超出段的末端至等于线宽一半的距离。
      static int AlphaComposite.CLEAR
      目的地的颜色和alpha都被清除（Porter-Duff Clear规则）。
      static int SystemColor.CONTROL
      阵列索引为 SystemColor.control系统颜色。
      static int SystemColor.CONTROL_DK_SHADOW
      阵列索引为 SystemColor.controlDkShadow系统颜色。
      static int SystemColor.CONTROL_HIGHLIGHT
      阵列索引为 SystemColor.controlHighlight系统颜色。
      static int SystemColor.CONTROL_LT_HIGHLIGHT
      阵列索引为 SystemColor.controlLtHighlight系统颜色。
      static int SystemColor.CONTROL_SHADOW
      阵列索引为 SystemColor.controlShadow系统颜色。
      static int SystemColor.CONTROL_TEXT
      阵列索引为 SystemColor.controlText系统颜色。
      static int SystemColor.DESKTOP
      阵列索引为 SystemColor.desktop系统颜色。
      static int AlphaComposite.DST
      目的地保持不变（Porter-Duff目的地规则）。
      static int AlphaComposite.DST_ATOP
      位于源头的目的地的一部分在源上合成，并替换目的地（Porter-Duff Destination Atop Source规则）。
      static int AlphaComposite.DST_IN
      位于源代码内的目的地部分将替换目的地（Porter-Duff Destination In Source规则）。
      static int AlphaComposite.DST_OUT
      位于源代码之外的目的地的一部分将替换目的地（Porter-Duff Destination Held Out By Source规则）。
      static int AlphaComposite.DST_OVER
      目的地在源上合成，结果将替换目的地（Porter-Duff Destination Over Source规则）。
      static int Adjustable.HORIZONTAL
      表示 Adjustable具有水平方向。
      static int SystemColor.INACTIVE_CAPTION
      阵列索引为 SystemColor.inactiveCaption系统颜色。
      static int SystemColor.INACTIVE_CAPTION_BORDER
      阵列索引为 SystemColor.inactiveCaptionBorder系统颜色。
      static int SystemColor.INACTIVE_CAPTION_TEXT
      阵列索引为 SystemColor.inactiveCaptionText系统颜色。
      static int SystemColor.INFO
      阵列索引为 SystemColor.info系统颜色。
      static int SystemColor.INFO_TEXT
      阵列索引为 SystemColor.infoText系统颜色。
      static int BasicStroke.JOIN_BEVEL
      通过连接其广泛轮廓的外角与直线段来连接路段。
      static int BasicStroke.JOIN_MITER
      通过延伸它们的外边缘直到它们相遇来连接路段。
      static int BasicStroke.JOIN_ROUND
      通过以半角宽度的半径舍入角落来连接路径段。
      static int SystemColor.MENU
      阵列索引为 SystemColor.menu系统颜色。
      static int SystemColor.MENU_TEXT
      阵列索引为 SystemColor.menuText系统颜色。
      static int Adjustable.NO_ORIENTATION
      表示 Adjustable没有方向。
      static int SystemColor.NUM_COLORS
      数组中的系统颜色数。
      static int Transparency.OPAQUE
      表示保证完全不透明的图像数据，意味着所有像素的alpha值为1.0。
      static int DisplayMode.REFRESH_RATE_UNKNOWN
      如果不知道刷新率的值。
      static int SystemColor.SCROLLBAR
      阵列索引为 SystemColor.scrollbar系统颜色。
      static int AlphaComposite.SRC
      源被复制到目的地（Porter-Duff源规则）。
      static int AlphaComposite.SRC_ATOP
      位于目的地内部的源的部分被合成到目的地（Porter-Duff Source Atop Destination rule）上。
      static int AlphaComposite.SRC_IN
      位于目的地内部的源的部分替换目的地（目的地规则中的波特 - 达夫源）。
      static int AlphaComposite.SRC_OUT
      位于目的地外部的源的部分取代了目的地（Porter-Duff Source Held Out By Destination规则）。
      static int AlphaComposite.SRC_OVER
      源在目的地（Porter-Duff Source Over Destination规则）上合成。
      static int SystemColor.TEXT
      阵列索引为 SystemColor.text系统颜色。
      static int SystemColor.TEXT_HIGHLIGHT
      阵列索引为 SystemColor.textHighlight系统颜色。
      static int SystemColor.TEXT_HIGHLIGHT_TEXT
      阵列索引为 SystemColor.textHighlightText系统颜色。
      static int SystemColor.TEXT_INACTIVE_TEXT
      阵列索引为 SystemColor.textInactiveText系统颜色。
      static int SystemColor.TEXT_TEXT
      阵列索引为 SystemColor.textText系统颜色。
      static int Transparency.TRANSLUCENT
      表示包含或可能包含0.0和1.0之间的任意α值的图像数据。
      static int Adjustable.VERTICAL
      表示 Adjustable具有垂直方向。
      static int SystemColor.WINDOW
      阵列索引为 SystemColor.window系统颜色。
      static int SystemColor.WINDOW_BORDER
      阵列索引为 SystemColor.windowBorder系统颜色。
      static int SystemColor.WINDOW_TEXT
      阵列索引为 SystemColor.windowText系统颜色。
      static int AlphaComposite.XOR
      位于目的地外部的源的部分与位于源外的目标的部分（Porter-Duff Source Xor Destination rule）组合。

    • Uses of Native in java.awt.color

      Fields in java.awt.color with annotations of type Native
      Modifier and Type Field 描述
      static int ColorSpace.CS_CIEXYZ
      上面定义的CIEXYZ转换颜色空间。
      static int ColorSpace.CS_GRAY
      内置线性灰度色彩空间。
      static int ColorSpace.CS_LINEAR_RGB
      内置线性RGB色彩空间。
      static int ColorSpace.CS_PYCC
      照片YCC转换颜色空间。
      static int ColorSpace.CS_sRGB
      sRGB颜色空间定义在 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html 。
      static int ColorSpace.TYPE_2CLR
      通用2分量颜色空间。
      static int ColorSpace.TYPE_3CLR
      通用3组件颜色空间。
      static int ColorSpace.TYPE_4CLR
      通用4组分颜色空间。
      static int ColorSpace.TYPE_5CLR
      通用5组件颜色空间。
      static int ColorSpace.TYPE_6CLR
      通用6组件颜色空间。
      static int ColorSpace.TYPE_7CLR
      通用7组件颜色空间。
      static int ColorSpace.TYPE_8CLR
      通用8分量颜色空间。
      static int ColorSpace.TYPE_9CLR
      通用9组件颜色空间。
      static int ColorSpace.TYPE_ACLR
      通用10组分色彩空间。
      static int ColorSpace.TYPE_BCLR
      通用11组件颜色空间。
      static int ColorSpace.TYPE_CCLR
      通用12组件颜色空间。
      static int ColorSpace.TYPE_CMY
      任何一个家庭的CMY色彩空间。
      static int ColorSpace.TYPE_CMYK
      任何一个CMYK色彩空间的家庭。
      static int ColorSpace.TYPE_DCLR
      通用13组件颜色空间。
      static int ColorSpace.TYPE_ECLR
      通用14组件颜色空间。
      static int ColorSpace.TYPE_FCLR
      通用15组件颜色空间。
      static int ColorSpace.TYPE_GRAY
      任何一个灰色家庭的颜色空间。
      static int ColorSpace.TYPE_HLS
      任何家庭的HLS颜色空间。
      static int ColorSpace.TYPE_HSV
      任何家庭的HSV色彩空间。
      static int ColorSpace.TYPE_Lab
      任何一个Lab颜色空间的家庭。
      static int ColorSpace.TYPE_Luv
      任何Luv色彩空间的家庭。
      static int ColorSpace.TYPE_RGB
      任何RGB色彩空间的家庭。
      static int ColorSpace.TYPE_XYZ
      任何家庭的XYZ色彩空间。
      static int ColorSpace.TYPE_YCbCr
      任何YCbCr色彩空间的家庭。
      static int ColorSpace.TYPE_Yxy
      任何家庭的Yxy颜色空间。

    • Uses of Native in java.awt.dnd

      Fields in java.awt.dnd with annotations of type Native
      Modifier and Type Field 描述
      static int DnDConstants.ACTION_COPY
      代表“复制”动作的 int 。
      static int DnDConstants.ACTION_COPY_OR_MOVE
      代表“复制”或“移动”动作的 int 。
      static int DnDConstants.ACTION_LINK
      一个 int代表一个“链接”动作。
      static int DnDConstants.ACTION_MOVE
      代表“移动”动作的 int 。
      static int DnDConstants.ACTION_NONE
      一个 int代表没有动作。
      static int DnDConstants.ACTION_REFERENCE
      代表“参考”动作的 int （ACTION_LINK的同义词）。

    • Uses of Native in java.awt.event

      Fields in java.awt.event with annotations of type Native
      Modifier and Type Field 描述
      static int ActionEvent.ACTION_PERFORMED
      此事件ID表示发生了有意义的操作。
      static int AdjustmentEvent.BLOCK_DECREMENT
      块减量调整类型。
      static int AdjustmentEvent.BLOCK_INCREMENT
      块增量调整类型。
      static int InputMethodEvent.CARET_POSITION_CHANGED
      指示输入法文本中更改的插入点的事件类型。
      static int ComponentEvent.COMPONENT_HIDDEN
      此事件表示该组件被呈现为不可见。
      static int ComponentEvent.COMPONENT_MOVED
      此事件表示组件的位置已更改。
      static int ComponentEvent.COMPONENT_RESIZED
      此事件表示组件的大小已更改。
      static int ComponentEvent.COMPONENT_SHOWN
      此事件表示组件已显示。
      static int InputMethodEvent.INPUT_METHOD_FIRST
      标记输入法事件ids范围的第一个整数ID。
      static int InputMethodEvent.INPUT_METHOD_LAST
      标记输入法事件ids范围的最后一个整数ID。
      static int InputMethodEvent.INPUT_METHOD_TEXT_CHANGED
      事件类型指示改变的输入法文本。
      static int AdjustmentEvent.TRACK
      绝对跟踪调整类型。
      static int AdjustmentEvent.UNIT_DECREMENT
      单位减量调整类型。
      static int AdjustmentEvent.UNIT_INCREMENT
      单位增量调整类型。
      static int MouseWheelEvent.WHEEL_BLOCK_SCROLL
      表示通过“块”滚动的常量（如滚动页面向下，向下翻页键）
      static int MouseWheelEvent.WHEEL_UNIT_SCROLL
      表示以“单位”滚动的常量（如用箭头键滚动）
      static int WindowEvent.WINDOW_ACTIVATED
      窗口激活的事件类型。
      static int WindowEvent.WINDOW_CLOSED
      窗户关闭事件。
      static int WindowEvent.WINDOW_CLOSING
      “窗口正在关闭”事件。
      static int WindowEvent.WINDOW_DEACTIVATED
      窗口停用事件类型。
      static int WindowEvent.WINDOW_DEICONIFIED
      窗口deiconified事件类型。
      static int WindowEvent.WINDOW_GAINED_FOCUS
      窗口获取焦点事件类型。
      static int WindowEvent.WINDOW_ICONIFIED
      窗口图标化事件。
      static int WindowEvent.WINDOW_LOST_FOCUS
      窗口丢失焦点事件类型。
      static int WindowEvent.WINDOW_OPENED
      窗户打开事件。
      static int WindowEvent.WINDOW_STATE_CHANGED
      窗口状态更改的事件类型。

    • Uses of Native in java.awt.geom

      Fields in java.awt.geom with annotations of type Native
      Modifier and Type Field 描述
      static int PathIterator.SEG_CLOSE
      通过将线段追加到与最近的SEG_MOVETO对应的点来指定应该关闭前一子路径的段类型常量。
      static int PathIterator.SEG_CUBICTO
      指定要从最近指定点绘制的三次参数曲线的3个点集合的段类型常数。
      static int PathIterator.SEG_LINETO
      指定要从最近指定点绘制的行的终点的点的段类型常量。
      static int PathIterator.SEG_MOVETO
      指定新子路径起始位置的点的段类型常量。
      static int PathIterator.SEG_QUADTO
      指定从最近指定点绘制的二次参数曲线的一对点的段类型常数。
      static int PathIterator.WIND_EVEN_ODD
      用于指定用于确定路径内部的偶数奇数规则的绕组规则常数。
      static int PathIterator.WIND_NON_ZERO
      用于指定用于确定路径内部的非零规则的卷绕规则常数。

    • Uses of Native in java.awt.image

      Fields in java.awt.image with annotations of type Native
      Modifier and Type Field 描述
      static int ConvolveOp.EDGE_NO_OP
      源图像边缘的像素被复制到目的地的相应像素，而不进行修改。
      static int ConvolveOp.EDGE_ZERO_FILL
      目标图像边缘的像素设置为零。
      static int AffineTransformOp.TYPE_BICUBIC
      双三次插补类型。
      static int AffineTransformOp.TYPE_BILINEAR
      双线性插值类型。
      static int DataBuffer.TYPE_BYTE
      标记无符号字节数据。
      static int DataBuffer.TYPE_DOUBLE
      标记为双数据。
      static int DataBuffer.TYPE_FLOAT
      标签浮点数据。
      static int DataBuffer.TYPE_INT
      标签为int数据。
      static int AffineTransformOp.TYPE_NEAREST_NEIGHBOR
      最近邻插值类型。
      static int DataBuffer.TYPE_SHORT
      标记签名的短数据。
      static int DataBuffer.TYPE_UNDEFINED
      标记未定义的数据。
      static int DataBuffer.TYPE_USHORT
      无符号短数据标签。

    • Uses of Native in java.awt.print

      Fields in java.awt.print with annotations of type Native
      Modifier and Type Field 描述
      static int PageFormat.LANDSCAPE
      原点在纸张的左下角，x从底部到顶部运行，y从左到右运行。
      static int PageFormat.PORTRAIT
      原点位于纸张的左上角，x向右移动，y向下移动纸张。
      static int PageFormat.REVERSE_LANDSCAPE
      原点在纸张的右上角，x从上到下运行，y从右到左运行。
      static int Pageable.UNKNOWN_NUMBER_OF_PAGES
      如果 Pageable实现不知道其集合中的页数，则该常量将从 getNumberOfPages方法返回。

    • Uses of Native in java.lang

      Fields in java.lang with annotations of type Native
      Modifier and Type Field 描述
      static int Integer.MAX_VALUE
      持有最大值的常数为 int可以为2 31 -1。
      static long Long.MAX_VALUE
      一个持有最大值一个 long可以有2 63 -1。
      static int Integer.MIN_VALUE
      的常量保持的最小值的 int可以具有，-2 31。
      static long Long.MIN_VALUE
      的常量保持的最小值的 long可以具有-2 63。
      static int Integer.SIZE
      用于表示二进制补码二进制形式的 int值的位数。
      static int Long.SIZE
      用于表示二进制补码二进制形式的 long值的位数。

    • Uses of Native in java.net

      Fields in java.net with annotations of type Native
      Modifier and Type Field 描述
      static int SocketOptions.IP_MULTICAST_IF
      设置发送组播数据包的出接口。
      static int SocketOptions.IP_MULTICAST_IF2
      与上述相同。
      static int SocketOptions.IP_MULTICAST_LOOP
      此选项启用或禁用组播数据报的本地环回。
      static int SocketOptions.IP_TOS
      此选项将TCP或UDP套接字的IP头中的服务类型或流量类别字段设置。
      static int SocketOptions.SO_BINDADDR
      获取套接字的本地地址绑定（此选项不能仅“设置”，因为套接字在创建时绑定，因此本地绑定的地址不能被更改）。
      static int SocketOptions.SO_BROADCAST
      为套接字设置SO_BROADCAST。
      static int SocketOptions.SO_KEEPALIVE
      当为TCP套接字设置keepalive选项，并且没有数据在两个方向上通过套接字交换2小时（注意：实际值取决于实现），TCP自动向对等体发送keepalive探测。
      static int SocketOptions.SO_LINGER
      指定一个随叫随到的超时时间。
      static int SocketOptions.SO_OOBINLINE
      当设置OOBINLINE选项时，将通过套接字输入流接收在套接字上接收的任何TCP紧急数据。
      static int SocketOptions.SO_RCVBUF
      设置平台为传入网络I / O使用的底层缓冲区的大小。
      static int SocketOptions.SO_REUSEADDR
      为套接字设置SO_REUSEADDR。
      static int SocketOptions.SO_REUSEPORT
      为套接字设置SO_REUSEPORT。
      static int SocketOptions.SO_SNDBUF
      设置平台用于传出网络I / O的底层缓冲区的大小。
      static int SocketOptions.SO_TIMEOUT
      在阻塞Socket操作上设置一个超时：
      static int SocketOptions.TCP_NODELAY
      Disable Nagle's algorithm for this connection.

    • Uses of Native in jdk.net

      Fields in jdk.net with annotations of type Native
      Modifier and Type | Field | 描述
      static int | SocketFlow.HIGH_PRIORITY
      static int | SocketFlow.NORMAL_PRIORITY
      static int | SocketFlow.UNSET
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.Repeatable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.Repeatable

  • Packages that use Repeatable
    软件包 描述
    javax.xml.ws
    此软件包包含核心JAX-WS API。

    • Uses of Repeatable in javax.xml.ws

      Classes in javax.xml.ws with annotations of type Repeatable
      Modifier and Type Class 描述
      interface  WebServiceRef
      WebServiceRef注释用于定义对Web服务的引用以及（可选）为其注入目标。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.Retention (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.Retention

  • Packages that use Retention
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.jws
    javax.jws.soap
    javax.management
    提供Java管理扩展的核心类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.bind.annotation.adapters
    XmlAdapter及其规范定义的子类，允许任意Java类与JAXB一起使用。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。

    • Uses of Retention in java.beans

      Classes in java.beans with annotations of type Retention
      Modifier and Type Class 描述
      interface  BeanProperty
      用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
      interface  ConstructorProperties
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  JavaBean
      用于为自动生成的BeanInfo类指定一些类相关信息的注释。
      interface  Transient
      表示当Introspector构造与注释代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明一个名为“transient”的属性。

    • Uses of Retention in java.lang

      Classes in java.lang with annotations of type Retention
      Modifier and Type Class 描述
      interface  已过时的
      注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
      interface  FunctionalInterface
      用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
      interface  Override
      表示方法声明旨在覆盖超类型中的方法声明。
      interface  SafeVarargs
      程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
      interface  SuppressWarnings
      表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。

    • Uses of Retention in java.lang.annotation

      Classes in java.lang.annotation with annotations of type Retention
      Modifier and Type Class 描述
      interface  Documented
      如果批注 @Documented存在于注解类型 A的声明上，则元素上的任何 @A注释将被视为元素的公共合同的一部分。
      interface  Inherited
      表示注释类型自动继承。
      interface  Native
      表示定义常量值的字段可以从本地代码引用。
      interface  Repeatable
      注释类型 java.lang.annotation.Repeatable用于指示其（meta-）注释声明的注释类型是 可重复的 。
      interface  Retention
      指示要注释具有注释类型的注释的保留时间。
      interface  Target
      指示注释类型适用的上下文。

    • Uses of Retention in javafx.beans

      Classes in javafx.beans with annotations of type Retention
      Modifier and Type Class 描述
      interface  DefaultProperty
      指定未指定显式属性时将添加或设置子元素的属性。
      interface  NamedArg
      提供参数名称信息的注释。

    • Uses of Retention in javafx.fxml

      Classes in javafx.fxml with annotations of type Retention
      Modifier and Type Class 描述
      interface  FXML
      将字段或方法标记为可用于标记的注释。

    • Uses of Retention in javax.annotation

      Classes in javax.annotation with annotations of type Retention
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  PostConstruct
      PostConstruct注释用于需要执行相关性注入后执行任何初始化的方法。
      interface  PreDestroy
      PreDestroy注释在方法上用作回调通知，表明实例正在被容器移除。
      interface  Resource
      资源注释标记应用程序需要的资源。
      interface  Resources
      此类用于允许多个资源声明。

    • Uses of Retention in javax.annotation.processing

      Classes in javax.annotation.processing with annotations of type Retention
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  SupportedAnnotationTypes
      用于指示注释处理器支持的注释类型的注释。
      interface  SupportedOptions
      用于指示注释处理器支持哪些选项的注释。
      interface  SupportedSourceVersion
      用于指示注释处理器支持的最新源版本的注释。

    • Uses of Retention in javax.jws

      Classes in javax.jws with annotations of type Retention
      Modifier and Type | Class | 描述
      interface  | HandlerChain
      interface  | Oneway
      interface  | WebMethod
      interface  | WebParam
      interface  | WebResult
      interface  | WebService

    • Uses of Retention in javax.jws.soap

      Classes in javax.jws.soap with annotations of type Retention
      Modifier and Type | Class | 描述
      interface  | SOAPBinding
      interface  SOAPMessageHandlers
      已过时。

    • Uses of Retention in javax.management

      Classes in javax.management with annotations of type Retention
      Modifier and Type Class 描述
      interface  ConstructorParameters
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  DescriptorKey
      描述注释元素如何与Descriptor中的字段相关的元标注 。
      interface  MXBean
      用于将界面明确标记为MXBean接口或不作为MXBean接口的注释。

    • Uses of Retention in javax.swing

      Classes in javax.swing with annotations of type Retention
      Modifier and Type Class 描述
      interface  SwingContainer
      一个注释用于为自动生成的 BeanInfo类指定一些与swing相关的信息。

    • Uses of Retention in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation with annotations of type Retention
      Modifier and Type Class 描述
      interface  XmlAccessorOrder
      控制类中字段和属性的顺序。
      interface  XmlAccessorType
      控制字段或Javabean属性是否默认序列化。
      interface  XmlAnyAttribute
      将JavaBean属性映射到通配符属性的映射。
      interface  XmlAnyElement
      将JavaBean属性映射到XML信息集表示和/或JAXB元素。
      interface  XmlAttachmentRef
      标记一个字段/属性，它的XML表单是一个uri引用mime内容。
      interface  XmlAttribute
      将JavaBean属性映射到XML属性。
      interface  XmlElement
      将JavaBean属性映射到从属性名称派生的XML元素。
      interface  XmlElementDecl
      将工厂方法映射到XML元素。
      interface  XmlElementRef
      将JavaBean属性映射到从属性类型派生的XML元素。
      interface  XmlElementRefs
      标记一个属性，指的是具有XmlElement或JAXBElement的类。
      interface  XmlElements
      多个@ XmlElement注释的容器。
      interface  XmlElementWrapper
      围绕XML表示生成一个包装元素。
      interface  XmlEnum
      将一个枚举类型映射到XML表示形式Enum 。
      interface  XmlEnumValue
      将一个枚举常数映射到Enum类型到XML表示。
      interface  XmlID
      将JavaBean属性映射到XML ID。
      interface  XmlIDREF
      将JavaBean属性映射到XML IDREF。
      interface  XmlInlineBinaryData
      禁用对XML绑定到base64编码的二进制数据的数据类型的XOP编码的考虑。
      interface  XmlList
      用于将属性映射到列表简单类型。
      interface  XmlMimeType
      关联控制属性的XML表示形式的MIME类型。
      interface  XmlMixed
      注释JavaBean多值属性以支持混合内容。
      interface  XmlNs
      将命名空间前缀与XML命名空间URI相关联。
      interface  XmlRegistry
      标记一个有XmlElementDecl秒的课程。
      interface  XmlRootElement
      将类或枚举类型映射到XML元素。
      interface  XmlSchema
      将包名称映射到XML命名空间。
      interface  XmlSchemaType
      将Java类型映射到简单的模式内置类型。
      interface  XmlSchemaTypes
      多个@ XmlSchemaType注释的容器。
      interface  XmlSeeAlso
      指示JAXB在绑定此类时也绑定其他类。
      interface  XmlTransient
      防止将JavaBean属性/类型映射到XML表示。
      interface  XmlType
      将类或枚举类型映射到XML模式类型。
      interface  XmlValue
      使用simpleContent或XML Schema简单类型将类映射到XML模式复合类型。

    • Uses of Retention in javax.xml.bind.annotation.adapters

      Classes in javax.xml.bind.annotation.adapters with annotations of type Retention
      Modifier and Type Class 描述
      interface  XmlJavaTypeAdapter
      使用实现XmlAdapter的适配器进行自定义封送。
      interface  XmlJavaTypeAdapters
      多个@ XmlJavaTypeAdapter注释的容器。

    • Uses of Retention in javax.xml.ws

      Classes in javax.xml.ws with annotations of type Retention
      Modifier and Type Class 描述
      interface  Action
      所述 Action注释允许一个WS寻址的显式关联 Action与消息寻址属性 input ， output和 fault映射WSDL操作的消息。
      interface  BindingType
      BindingType注释用于指定用于Web服务端点实现类的绑定。
      interface  FaultAction
      所述FaultAction注解用于内部Action注释以允许WS寻址的显式关联Action与消息寻址属性fault从异常类映射到的WSDL操作的消息。
      interface  RequestWrapper
      用于使用要在运行时使用的请求包装器bean来注释服务端点接口中的方法。
      interface  RespectBinding
      此功能说明了在JAX-WS运行时中使用 wsdl:binding 。
      interface  ResponseWrapper
      用于使用要在运行时使用的响应包装器bean来注释服务端点接口中的方法。
      interface  ServiceMode
      用于指示Provider实现是否希望与整个协议消息一起使用，或仅与协议消息有效载荷一起使用。
      interface  WebEndpoint
      用于注释生成的服务接口的 getPortName()方法。
      interface  WebFault
      用于注释特定于服务的异常类，以定制到故障元素的本地和命名空间名称以及故障bean的名称。
      interface  WebServiceClient
      用于注释生成的服务接口。
      interface  WebServiceProvider
      用于注释Provider实现类。
      interface  WebServiceRef
      WebServiceRef注释用于定义对Web服务的引用以及（可选）为其注入目标。
      interface  WebServiceRefs
      WebServiceRefs注释允许在类级别声明多个Web服务引用。

    • Uses of Retention in javax.xml.ws.soap

      Classes in javax.xml.ws.soap with annotations of type Retention
      Modifier and Type Class 描述
      interface  Addressing
      此注释表示使用SOAP 1.1 / HTTP或SOAP 1.2 / HTTP绑定的WS-Addressing。
      interface  MTOM
      此功能表示使用具有Web服务的MTOM。

    • Uses of Retention in javax.xml.ws.spi

      Classes in javax.xml.ws.spi with annotations of type Retention
      Modifier and Type Class 描述
      interface  WebServiceFeatureAnnotation
      用于标识其他注释的注释为 WebServiceFeature 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.RetentionPolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.RetentionPolicy

  • Packages that use RetentionPolicy
    软件包 描述
    java.lang.annotation
    为Java编程语言注释工具提供库支持。

    • Uses of RetentionPolicy in java.lang.annotation

      Methods in java.lang.annotation that return RetentionPolicy
      Modifier and Type 方法 描述
      static RetentionPolicy RetentionPolicy.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static RetentionPolicy[] RetentionPolicy.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.annotation.Target (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.annotation.Target

  • Packages that use Target
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.jws
    javax.jws.soap
    javax.management
    提供Java管理扩展的核心类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.bind.annotation.adapters
    XmlAdapter及其指定的子类允许任意Java类与JAXB一起使用。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。

    • Uses of Target in java.beans

      Classes in java.beans with annotations of type Target
      Modifier and Type Class 描述
      interface  BeanProperty
      用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
      interface  ConstructorProperties
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  JavaBean
      用于为自动生成的BeanInfo类指定一些类相关信息的注释。
      interface  Transient
      表示当Introspector构造与注释代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明一个名为“transient”的属性。

    • Uses of Target in java.lang

      Classes in java.lang with annotations of type Target
      Modifier and Type Class 描述
      interface  已过时的
      注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
      interface  FunctionalInterface
      用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
      interface  Override
      表示方法声明旨在覆盖超类型中的方法声明。
      interface  SafeVarargs
      程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
      interface  SuppressWarnings
      表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。

    • Uses of Target in java.lang.annotation

      Classes in java.lang.annotation with annotations of type Target
      Modifier and Type Class 描述
      interface  Documented
      如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释将被视为元素的公共合同的一部分。
      interface  Inherited
      表示注释类型自动继承。
      interface  Native
      表示定义常量值的字段可以从本地代码引用。
      interface  Repeatable
      注释类型 java.lang.annotation.Repeatable用于表示其（meta-）注释声明的注释类型是 可重复的 。
      interface  Retention
      指示要注释具有注释类型的注释的保留时间。
      interface  Target
      指示注释类型适用的上下文。

    • Uses of Target in javafx.beans

      Classes in javafx.beans with annotations of type Target
      Modifier and Type Class 描述
      interface  DefaultProperty
      指定未指定显式属性时将添加或设置子元素的属性。
      interface  NamedArg
      提供参数名称信息的注释。

    • Uses of Target in javafx.fxml

      Classes in javafx.fxml with annotations of type Target
      Modifier and Type Class 描述
      interface  FXML
      将字段或方法标记为可用于标记的注释。

    • Uses of Target in javax.annotation

      Classes in javax.annotation with annotations of type Target
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  PostConstruct
      PostConstruct注释用于需要执行相关性注入后执行任何初始化的方法。
      interface  PreDestroy
      PreDestroy注释在方法上用作回调通知，表明实例正在被容器移除。
      interface  Resource
      资源注释标记应用程序需要的资源。
      interface  Resources
      此类用于允许多个资源声明。

    • Uses of Target in javax.annotation.processing

      Classes in javax.annotation.processing with annotations of type Target
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  SupportedAnnotationTypes
      用于指示注释处理器支持的注释类型的注释。
      interface  SupportedOptions
      用于指示注释处理器支持哪些选项的注释。
      interface  SupportedSourceVersion
      用于指示注释处理器支持的最新源版本的注释。

    • Uses of Target in javax.jws

      Classes in javax.jws with annotations of type Target
      Modifier and Type | Class | 描述
      interface  | HandlerChain
      interface  | Oneway
      interface  | WebMethod
      interface  | WebParam
      interface  | WebResult
      interface  | WebService

    • Uses of Target in javax.jws.soap

      Classes in javax.jws.soap with annotations of type Target
      Modifier and Type | Class | 描述
      interface  | SOAPBinding
      interface  SOAPMessageHandlers
      已过时。

    • Uses of Target in javax.management

      Classes in javax.management with annotations of type Target
      Modifier and Type Class 描述
      interface  ConstructorParameters
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  DescriptorKey
      描述注释元素如何与Descriptor中的字段相关的元标注 。
      interface  MXBean
      用于将界面明确标记为MXBean接口或不作为MXBean接口的注释。

    • Uses of Target in javax.swing

      Classes in javax.swing with annotations of type Target
      Modifier and Type Class 描述
      interface  SwingContainer
      用于指定自动生成的 BeanInfo类的一些swing相关信息的注释。

    • Uses of Target in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation with annotations of type Target
      Modifier and Type Class 描述
      interface  XmlAccessorOrder
      控制类中字段和属性的顺序。
      interface  XmlAccessorType
      控制字段或Javabean属性是否默认序列化。
      interface  XmlAnyAttribute
      将JavaBean属性映射到通配符属性的映射。
      interface  XmlAnyElement
      将JavaBean属性映射到XML信息集表示和/或JAXB元素。
      interface  XmlAttachmentRef
      标记一个字段/属性，它的XML表单是一个uri引用mime内容。
      interface  XmlAttribute
      将JavaBean属性映射到XML属性。
      interface  XmlElement
      将JavaBean属性映射到从属性名称派生的XML元素。
      interface  XmlElementDecl
      将工厂方法映射到XML元素。
      interface  XmlElementRef
      将JavaBean属性映射到从属性类型派生的XML元素。
      interface  XmlElementRefs
      使用XmlElement或JAXBElement标记指向类的属性。
      interface  XmlElements
      多个@ XmlElement注释的容器。
      interface  XmlElementWrapper
      围绕XML表示生成一个包装元素。
      interface  XmlEnum
      将一个枚举类型映射到XML表示形式Enum 。
      interface  XmlEnumValue
      将一个枚举常数映射到Enum类型到XML表示。
      interface  XmlID
      将JavaBean属性映射到XML ID。
      interface  XmlIDREF
      将JavaBean属性映射到XML IDREF。
      interface  XmlInlineBinaryData
      禁用对XML绑定到base64编码的二进制数据的数据类型的XOP编码的考虑。
      interface  XmlList
      用于将属性映射到列表简单类型。
      interface  XmlMimeType
      关联控制属性的XML表示形式的MIME类型。
      interface  XmlMixed
      注释JavaBean多值属性以支持混合内容。
      interface  XmlNs
      将命名空间前缀与XML命名空间URI相关联。
      interface  XmlRegistry
      标记一个有XmlElementDecl的类。
      interface  XmlRootElement
      将类或枚举类型映射到XML元素。
      interface  XmlSchema
      将包名称映射到XML命名空间。
      interface  XmlSchemaType
      将Java类型映射到简单的模式内置类型。
      interface  XmlSchemaTypes
      多个@ XmlSchemaType注释的容器。
      interface  XmlSeeAlso
      指示JAXB在绑定此类时也绑定其他类。
      interface  XmlTransient
      防止将JavaBean属性/类型映射到XML表示。
      interface  XmlType
      将类或枚举类型映射到XML模式类型。
      interface  XmlValue
      使用simpleContent或XML Schema简单类型将类映射到XML模式复合类型。

    • Uses of Target in javax.xml.bind.annotation.adapters

      Classes in javax.xml.bind.annotation.adapters with annotations of type Target
      Modifier and Type Class 描述
      interface  XmlJavaTypeAdapter
      使用实现XmlAdapter的适配器进行自定义封送。
      interface  XmlJavaTypeAdapters
      多个@ XmlJavaTypeAdapter注释的容器。

    • Uses of Target in javax.xml.ws

      Classes in javax.xml.ws with annotations of type Target
      Modifier and Type Class 描述
      interface  Action
      所述 Action注释允许一个WS寻址的显式关联 Action与消息寻址属性 input ， output和 fault映射WSDL操作的消息。
      interface  BindingType
      BindingType注释用于指定用于Web服务端点实现类的绑定。
      interface  FaultAction
      所述FaultAction注解用于内部Action注释以允许WS寻址的显式关联Action与消息寻址属性fault从异常类映射到的WSDL操作的消息。
      interface  RequestWrapper
      用于使用要在运行时使用的请求包装器bean来注释服务端点接口中的方法。
      interface  RespectBinding
      该功能说明了JAX-WS运行时中使用的 wsdl:binding 。
      interface  ResponseWrapper
      用于使用要在运行时使用的响应包装器bean来注释服务端点接口中的方法。
      interface  ServiceMode
      用于指示Provider实现是否希望使用整个协议消息或仅使用协议消息有效载荷。
      interface  WebEndpoint
      用于注释生成的服务接口的 getPortName()方法。
      interface  WebFault
      用于注释特定于服务的异常类，以定制到故障元素的本地和命名空间名称以及故障bean的名称。
      interface  WebServiceClient
      用于注释生成的服务接口。
      interface  WebServiceProvider
      用于注释Provider实现类。
      interface  WebServiceRef
      WebServiceRef注释用于定义对Web服务的引用以及（可选）为其注入目标。
      interface  WebServiceRefs
      WebServiceRefs注释允许在类级别声明多个Web服务引用。

    • Uses of Target in javax.xml.ws.soap

      Classes in javax.xml.ws.soap with annotations of type Target
      Modifier and Type Class 描述
      interface  Addressing
      此注释表示使用SOAP 1.1 / HTTP或SOAP 1.2 / HTTP绑定的WS-Addressing。
      interface  MTOM
      此功能表示使用具有Web服务的MTOM。

    • Uses of Target in javax.xml.ws.spi

      Classes in javax.xml.ws.spi with annotations of type Target
      Modifier and Type Class 描述
      interface  WebServiceFeatureAnnotation
      用于标识其他注释的注释为 WebServiceFeature 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.annotation.Annotation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.annotation.Annotation

  • Packages that use Annotation
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.annotation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.jws
    javax.jws.soap
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.bind.annotation.adapters
    XmlAdapter及其指定的子类允许任意Java类与JAXB一起使用。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。

    • Uses of Annotation in java.beans

      Classes in java.beans that implement Annotation
      Modifier and Type Class 描述
      interface  BeanProperty
      用于为自动生成的BeanInfo类指定一些属性相关信息的注释。
      interface  ConstructorProperties
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  JavaBean
      用于为自动生成的BeanInfo类指定一些类相关信息的注释。
      interface  Transient
      表示当Introspector构造与注释代码元素相关联的PropertyDescriptor或EventSetDescriptor类时，应使用给定的value声明称为“transient”的属性。

    • Uses of Annotation in java.lang

      Classes in java.lang that implement Annotation
      Modifier and Type Class 描述
      interface  已过时的
      注释 @Deprecated的程序元素是不鼓励程序员使用的程序元素。
      interface  FunctionalInterface
      用于指示接口类型声明旨在作为Java语言规范定义的 功能接口的信息性注释类型。
      interface  Override
      表示方法声明旨在覆盖超类型中的方法声明。
      interface  SafeVarargs
      程序员断言注释方法或构造函数的正文不会对其varargs参数执行潜在的不安全操作。
      interface  SuppressWarnings
      表示在注释元素（以及注释元素中包含的所有程序元素）中应该抑制命名的编译器警告。
      Methods in java.lang with type parameters of type Annotation
      Modifier and Type 方法 描述
      <A extends Annotation>
      A             		Class.getAnnotation​(Class<A> annotationClass)
      <T extends Annotation>
      T             		Module.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <A extends Annotation>
      A             		Package.getAnnotation​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Class.getAnnotationsByType​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Package.getAnnotationsByType​(Class<A> annotationClass)
      <A extends Annotation>
      A             		Class.getDeclaredAnnotation​(Class<A> annotationClass)
      <A extends Annotation>
      A             		Package.getDeclaredAnnotation​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Class.getDeclaredAnnotationsByType​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Package.getDeclaredAnnotationsByType​(Class<A> annotationClass)
      Methods in java.lang that return Annotation
      Modifier and Type | 方法 | 描述
      Annotation[] | Class.getAnnotations​()
      Annotation[] Module.getAnnotations​()
      返回此元素上 存在的注释。
      Annotation[] | Package.getAnnotations​()
      <A extends Annotation>
      A[]             		Class.getAnnotationsByType​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Package.getAnnotationsByType​(Class<A> annotationClass)
      Annotation[] | Class.getDeclaredAnnotations​()
      Annotation[] Module.getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Annotation[] | Package.getDeclaredAnnotations​()
      <A extends Annotation>
      A[]             		Class.getDeclaredAnnotationsByType​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Package.getDeclaredAnnotationsByType​(Class<A> annotationClass)
      Method parameters in java.lang with type arguments of type Annotation
      Modifier and Type 方法 描述
      boolean Class.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      boolean Package.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。

    • Uses of Annotation in java.lang.annotation

      Classes in java.lang.annotation that implement Annotation
      Modifier and Type Class 描述
      interface  Documented
      如果批注 @Documented存在于注释类型 A的声明上，则元素上的任何 @A注释都将被视为元素的公共合同的一部分。
      interface  Inherited
      表示注释类型自动继承。
      interface  Native
      表示定义常量值的字段可以从本地代码引用。
      interface  Repeatable
      注释类型 java.lang.annotation.Repeatable用于指示其（meta-）注释声明的注释类型是 可重复的 。
      interface  Retention
      指示要注释具有注释类型的注释的保留时间。
      interface  Target
      指示注释类型适用的上下文。
      Methods in java.lang.annotation that return types with arguments of type Annotation
      Modifier and Type 方法 描述
      Class<? extends Annotation> Annotation.annotationType​()
      返回此注释的注释类型。
      Class<? extends Annotation> IncompleteAnnotationException.annotationType​()
      返回缺少元素的注释类型的Class对象。
      Constructor parameters in java.lang.annotation with type arguments of type Annotation
      Constructor 描述
      IncompleteAnnotationException​(Class<? extends Annotation> annotationType, String elementName)
      构造一个IncompleteAnnotationException来指示指定的元素在指定的注释类型中丢失。

    • Uses of Annotation in java.lang.reflect

      Methods in java.lang.reflect with type parameters of type Annotation
      Modifier and Type 方法 描述
      <T extends Annotation>
      T             		AccessibleObject.getAnnotation​(Class<T> annotationClass)
      <T extends Annotation>
      T             		AnnotatedElement.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Constructor.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Executable.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Field.getAnnotation​(Class<T> annotationClass)
      <T extends Annotation>
      T             		Method.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Parameter.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T[]             		AccessibleObject.getAnnotationsByType​(Class<T> annotationClass)
      default <T extends Annotation>
      T[]             		AnnotatedElement.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Executable.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Field.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Parameter.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T             		AccessibleObject.getDeclaredAnnotation​(Class<T> annotationClass)
      default <T extends Annotation>
      T             		AnnotatedElement.getDeclaredAnnotation​(Class<T> annotationClass)
      如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。
      <T extends Annotation>
      T             		Parameter.getDeclaredAnnotation​(Class<T> annotationClass)
      <T extends Annotation>
      T[]             		AccessibleObject.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      default <T extends Annotation>
      T[]             		AnnotatedElement.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      <T extends Annotation>
      T[]             		Parameter.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      Methods in java.lang.reflect that return Annotation
      Modifier and Type | 方法 | 描述
      Annotation[] | AccessibleObject.getAnnotations​()
      Annotation[] AnnotatedElement.getAnnotations​()
      返回此元素上 存在的注释。
      Annotation[] Parameter.getAnnotations​()
      返回此元素上 存在的注释。
      <T extends Annotation>
      T[]             		AccessibleObject.getAnnotationsByType​(Class<T> annotationClass)
      default <T extends Annotation>
      T[]             		AnnotatedElement.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Executable.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Field.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Parameter.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      Annotation[] | AccessibleObject.getDeclaredAnnotations​()
      Annotation[] AnnotatedElement.getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Annotation[] Constructor.getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Annotation[] Executable.getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Annotation[] Field.getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Annotation[] Method.getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Annotation[] Parameter.getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      <T extends Annotation>
      T[]             		AccessibleObject.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      default <T extends Annotation>
      T[]             		AnnotatedElement.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      <T extends Annotation>
      T[]             		Parameter.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      Annotation[][] Constructor.getParameterAnnotations​()
      返回一个 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。
      abstract Annotation[][] Executable.getParameterAnnotations​()
      返回一个 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。
      Annotation[][] Method.getParameterAnnotations​()
      返回一个 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。
      Method parameters in java.lang.reflect with type arguments of type Annotation
      Modifier and Type 方法 描述
      boolean AccessibleObject.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      default boolean AnnotatedElement.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。

    • Uses of Annotation in javafx.beans

      Classes in javafx.beans that implement Annotation
      Modifier and Type Class 描述
      interface  DefaultProperty
      指定未指定显式属性时将添加或设置子元素的属性。
      interface  NamedArg
      提供参数名称信息的注释。

    • Uses of Annotation in javafx.fxml

      Classes in javafx.fxml that implement Annotation
      Modifier and Type Class 描述
      interface  FXML
      将字段或方法标记为可用于标记的注释。

    • Uses of Annotation in javax.annotation

      Classes in javax.annotation that implement Annotation
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  PostConstruct
      PostConstruct注释用于需要执行相关性注入后执行任何初始化的方法。
      interface  PreDestroy
      PreDestroy注释在方法上用作回调通知，表明实例正在被容器移除。
      interface  Resource
      资源注释标记应用程序需要的资源。
      interface  Resources
      此类用于允许多个资源声明。

    • Uses of Annotation in javax.annotation.processing

      Classes in javax.annotation.processing that implement Annotation
      Modifier and Type Class 描述
      interface  Generated
      生成的注释用于标记已生成的源代码。
      interface  SupportedAnnotationTypes
      用于指示注释处理器支持的注释类型的注释。
      interface  SupportedOptions
      用于指示注释处理器支持哪些选项的注释。
      interface  SupportedSourceVersion
      用于指示注释处理器支持的最新源版本的注释。
      Method parameters in javax.annotation.processing with type arguments of type Annotation
      Modifier and Type 方法 描述
      Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith​(Class<? extends Annotation> a)
      返回使用给定注释类型注释的元素。
      default Set<? extends Element> RoundEnvironment.getElementsAnnotatedWithAny​(Set<Class<? extends Annotation>> annotations)
      返回使用一个或多个给定注释类型注释的元素。

    • Uses of Annotation in javax.jws

      Classes in javax.jws that implement Annotation
      Modifier and Type | Class | 描述
      interface  | HandlerChain
      interface  | Oneway
      interface  | WebMethod
      interface  | WebParam
      interface  | WebResult
      interface  | WebService

    • Uses of Annotation in javax.jws.soap

      Classes in javax.jws.soap that implement Annotation
      Modifier and Type | Class | 描述
      interface  InitParam
      已过时。
      interface  | SOAPBinding
      interface  SOAPMessageHandler
      已过时。
      interface  SOAPMessageHandlers
      已过时。

    • Uses of Annotation in javax.lang.model

      Methods in javax.lang.model with type parameters of type Annotation
      Modifier and Type 方法 描述
      <A extends Annotation>
      A             		AnnotatedConstruct.getAnnotation​(Class<A> annotationType)
      返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。
      <A extends Annotation>
      A[]             		AnnotatedConstruct.getAnnotationsByType​(Class<A> annotationType)
      返回与此构造 关联的注释。
      Methods in javax.lang.model that return Annotation
      Modifier and Type 方法 描述
      <A extends Annotation>
      A[]             		AnnotatedConstruct.getAnnotationsByType​(Class<A> annotationType)
      返回与此构造 关联的注释。

    • Uses of Annotation in javax.lang.model.element

      Methods in javax.lang.model.element with type parameters of type Annotation
      Modifier and Type 方法 描述
      <A extends Annotation>
      A             		Element.getAnnotation​(Class<A> annotationType)
      返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。

    • Uses of Annotation in javax.management

      Classes in javax.management that implement Annotation
      Modifier and Type Class 描述
      interface  ConstructorParameters
      一个构造函数上的注释，显示了该构造函数的参数对应于构造的对象的getter方法。
      interface  DescriptorKey
      描述注释元素如何与Descriptor中的字段相关的元标注 。
      interface  MXBean
      用于将界面明确标记为MXBean接口或不作为MXBean接口的注释。

    • Uses of Annotation in javax.swing

      Classes in javax.swing that implement Annotation
      Modifier and Type Class 描述
      interface  SwingContainer
      一个注释用于为自动生成的 BeanInfo类指定一些与swing相关的信息。

    • Uses of Annotation in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation that implement Annotation
      Modifier and Type Class 描述
      interface  XmlAccessorOrder
      控制类中字段和属性的顺序。
      interface  XmlAccessorType
      控制字段或Javabean属性是否默认序列化。
      interface  XmlAnyAttribute
      将JavaBean属性映射到通配符属性的映射。
      interface  XmlAnyElement
      将JavaBean属性映射到XML信息集表示和/或JAXB元素。
      interface  XmlAttachmentRef
      标记一个字段/属性，它的XML表单是一个uri引用mime内容。
      interface  XmlAttribute
      将JavaBean属性映射到XML属性。
      interface  XmlElement
      将JavaBean属性映射到从属性名称派生的XML元素。
      interface  XmlElementDecl
      将工厂方法映射到XML元素。
      interface  XmlElementRef
      将JavaBean属性映射到从属性类型派生的XML元素。
      interface  XmlElementRefs
      使用XmlElement或JAXBElement标记指向类的属性。
      interface  XmlElements
      多个@ XmlElement注释的容器。
      interface  XmlElementWrapper
      围绕XML表示生成一个包装元素。
      interface  XmlEnum
      将枚举类型Enum映射到XML表示。
      interface  XmlEnumValue
      将一个枚举常数映射到Enum类型到XML表示。
      interface  XmlID
      将JavaBean属性映射到XML ID。
      interface  XmlIDREF
      将JavaBean属性映射到XML IDREF。
      interface  XmlInlineBinaryData
      禁用对XML绑定到base64编码的二进制数据的数据类型的XOP编码的考虑。
      interface  XmlList
      用于将属性映射到列表简单类型。
      interface  XmlMimeType
      关联控制属性的XML表示形式的MIME类型。
      interface  XmlMixed
      注释JavaBean多值属性以支持混合内容。
      interface  XmlNs
      将命名空间前缀与XML命名空间URI相关联。
      interface  XmlRegistry
      标记一个有XmlElementDecl的类。
      interface  XmlRootElement
      将类或枚举类型映射到XML元素。
      interface  XmlSchema
      将包名称映射到XML命名空间。
      interface  XmlSchemaType
      将Java类型映射到简单的模式内置类型。
      interface  XmlSchemaTypes
      多个@ XmlSchemaType注释的容器。
      interface  XmlSeeAlso
      指示JAXB在绑定此类时也绑定其他类。
      interface  XmlTransient
      防止将JavaBean属性/类型映射到XML表示。
      interface  XmlType
      将类或枚举类型映射到XML模式类型。
      interface  XmlValue
      使用simpleContent或XML Schema简单类型将类映射到XML模式复合类型。

    • Uses of Annotation in javax.xml.bind.annotation.adapters

      Classes in javax.xml.bind.annotation.adapters that implement Annotation
      Modifier and Type Class 描述
      interface  XmlJavaTypeAdapter
      使用实现XmlAdapter的适配器进行自定义封送。
      interface  XmlJavaTypeAdapters
      多个@ XmlJavaTypeAdapter注释的容器。

    • Uses of Annotation in javax.xml.ws

      Classes in javax.xml.ws that implement Annotation
      Modifier and Type Class 描述
      interface  Action
      所述 Action注释允许一个WS寻址的显式关联 Action与消息寻址属性 input ， output和 fault映射WSDL操作的消息。
      interface  BindingType
      BindingType注释用于指定要用于Web服务端点实现类的绑定。
      interface  FaultAction
      在FaultAction注释中使用FaultAction注释，以允许WS-Addressing Action消息寻址属性与从异常类映射的WSDL操作的fault消息的显式关联。
      interface  RequestWrapper
      用于使用要在运行时使用的请求包装器bean来注释服务端点接口中的方法。
      interface  RespectBinding
      此功能说明了在JAX-WS运行时中使用 wsdl:binding 。
      interface  ResponseWrapper
      用于使用要在运行时使用的响应包装器bean来注释服务端点接口中的方法。
      interface  ServiceMode
      用于指示Provider实现是否希望与整个协议消息一起工作，或者只是使用协议消息有效载荷。
      interface  WebEndpoint
      用于注释生成的服务接口的 getPortName()方法。
      interface  WebFault
      用于注释特定于服务的异常类，以定制到故障元素的本地和命名空间名称以及故障bean的名称。
      interface  WebServiceClient
      用于注释生成的服务接口。
      interface  WebServiceProvider
      用于注释Provider实现类。
      interface  WebServiceRef
      WebServiceRef注释用于定义对Web服务的引用以及（可选）为其注入目标。
      interface  WebServiceRefs
      WebServiceRefs注释允许在类级别声明多个Web服务引用。

    • Uses of Annotation in javax.xml.ws.soap

      Classes in javax.xml.ws.soap that implement Annotation
      Modifier and Type Class 描述
      interface  Addressing
      此注释表示使用SOAP 1.1 / HTTP或SOAP 1.2 / HTTP绑定的WS-Addressing。
      interface  MTOM
      此功能表示使用具有Web服务的MTOM。

    • Uses of Annotation in javax.xml.ws.spi

      Classes in javax.xml.ws.spi that implement Annotation
      Modifier and Type Class 描述
      interface  WebServiceFeatureAnnotation
      用于标识其他注释的注释为 WebServiceFeature 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.AbstractMethodError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.AbstractMethodError

No usage of java.lang.AbstractMethodError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ArithmeticException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ArithmeticException

No usage of java.lang.ArithmeticException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ArrayIndexOutOfBoundsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ArrayIndexOutOfBoundsException

  • Packages that use ArrayIndexOutOfBoundsException
    软件包 描述
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。

    • Uses of ArrayIndexOutOfBoundsException in java.lang.reflect

      Methods in java.lang.reflect that throw ArrayIndexOutOfBoundsException
      Modifier and Type 方法 描述
      static Object Array.get​(Object array, int index)
      返回指定数组对象中的索引组件的值。
      static boolean Array.getBoolean​(Object array, int index)
      返回指定数组对象中索引组件的值，如 boolean 。
      static byte Array.getByte​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 byte 。
      static char Array.getChar​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 char 。
      static double Array.getDouble​(Object array, int index)
      返回指定数组对象中索引组件的值，如 double 。
      static float Array.getFloat​(Object array, int index)
      返回指定数组对象中索引组件的值，如 float 。
      static int Array.getInt​(Object array, int index)
      返回指定数组对象中索引组件的值，如 int 。
      static long Array.getLong​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 long 。
      static short Array.getShort​(Object array, int index)
      返回指定数组对象中索引组件的值，如 short 。
      static void Array.set​(Object array, int index, Object value)
      将指定数组对象的索引组件的值设置为指定的新值。
      static void Array.setBoolean​(Object array, int index, boolean z)
      将指定数组对象的索引组件的值设置为指定的 boolean值。
      static void Array.setByte​(Object array, int index, byte b)
      将指定数组对象的索引组件的值设置为指定的 byte值。
      static void Array.setChar​(Object array, int index, char c)
      将指定数组对象的索引组件的值设置为指定的 char值。
      static void Array.setDouble​(Object array, int index, double d)
      将指定数组对象的索引组件的值设置为指定的 double值。
      static void Array.setFloat​(Object array, int index, float f)
      将指定数组对象的索引组件的值设置为指定的 float值。
      static void Array.setInt​(Object array, int index, int i)
      将指定数组对象的索引组件的值设置为指定的 int值。
      static void Array.setLong​(Object array, int index, long l)
      将指定数组对象的索引组件的值设置为指定的 long值。
      static void Array.setShort​(Object array, int index, short s)
      将指定数组对象的索引组件的值设置为指定的 short值。

    • Uses of ArrayIndexOutOfBoundsException in javax.sound.midi

      Methods in javax.sound.midi that throw ArrayIndexOutOfBoundsException
      Modifier and Type 方法 描述
      MidiEvent Track.get​(int index)
      在指定的索引处获取事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ArrayStoreException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ArrayStoreException

No usage of java.lang.ArrayStoreException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.AssertionError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.AssertionError

No usage of java.lang.AssertionError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Boolean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Boolean

  • Packages that use Boolean
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.awt.font
    提供与字体相关的类和界面。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.time.format
    提供打印和解析日期和时间的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.timer
    提供定时器MBean的定义。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.filechooser
    包含 JFileChooser组件使用的类和接口。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。

    • Uses of Boolean in com.sun.nio.sctp

      Fields in com.sun.nio.sctp with type parameters of type Boolean
      Modifier and Type Field 描述
      static SctpSocketOption<Boolean> SctpStandardSocketOptions.SCTP_DISABLE_FRAGMENTS
      启用或禁用消息碎片。
      static SctpSocketOption<Boolean> SctpStandardSocketOptions.SCTP_EXPLICIT_COMPLETE
      启用或禁用显式消息完成。
      static SctpSocketOption<Boolean> SctpStandardSocketOptions.SCTP_NODELAY
      启用或禁用类似Nagle的算法。

    • Uses of Boolean in java.awt.font

      Fields in java.awt.font declared as Boolean
      Modifier and Type Field 描述
      static Boolean TextAttribute.RUN_DIRECTION_LTR
      从左到右的运行方向。
      static Boolean TextAttribute.RUN_DIRECTION_RTL
      从右到左的运行方向。
      static Boolean TextAttribute.STRIKETHROUGH_ON
      一个删除线。
      static Boolean TextAttribute.SWAP_COLORS_ON
      交换前景和背景。

    • Uses of Boolean in java.lang

      Fields in java.lang declared as Boolean
      Modifier and Type Field 描述
      static Boolean Boolean.FALSE
      Boolean对象对应于原始值 false 。
      static Boolean Boolean.TRUE
      Boolean对象对应于原始值 true 。
      Fields in java.lang with type parameters of type Boolean
      Modifier and Type Field 描述
      static Class<Boolean> Boolean.TYPE
      表示原始类型的类对象布尔值。
      Methods in java.lang that return Boolean
      Modifier and Type 方法 描述
      static Boolean Boolean.valueOf​(boolean b)
      返回表示 boolean值的 Boolean实例。
      static Boolean Boolean.valueOf​(String s)
      返回一个 Boolean ，其值由指定的字符串表示。
      Methods in java.lang with parameters of type Boolean
      Modifier and Type 方法 描述
      int Boolean.compareTo​(Boolean b)
      将此 Boolean实例与另一个实例进行比较。

    • Uses of Boolean in java.net

      Fields in java.net with type parameters of type Boolean
      Modifier and Type Field 描述
      static SocketOption<Boolean> StandardSocketOptions.IP_MULTICAST_LOOP
      互联网协议（IP）组播数据报的环回。
      static SocketOption<Boolean> StandardSocketOptions.SO_BROADCAST
      允许传输广播数据报。
      static SocketOption<Boolean> StandardSocketOptions.SO_KEEPALIVE
      保持连接活着。
      static SocketOption<Boolean> StandardSocketOptions.SO_REUSEADDR
      重用地址。
      static SocketOption<Boolean> StandardSocketOptions.SO_REUSEPORT
      重新使用端口。
      static SocketOption<Boolean> StandardSocketOptions.TCP_NODELAY
      禁用Nagle算法。

    • Uses of Boolean in java.time.format

      Methods in java.time.format that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      static TemporalQuery<Boolean> DateTimeFormatter.parsedLeapSecond​()
      提供访问是否解析了跨越秒的查询。

    • Uses of Boolean in java.util

      Method parameters in java.util with type arguments of type Boolean
      Modifier and Type 方法 描述
      static <E> Set<E> Collections.newSetFromMap​(Map<E,Boolean> map)
      返回由指定地图支持的集合。

    • Uses of Boolean in java.util.concurrent

      Methods in java.util.concurrent that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      static <K> ConcurrentHashMap.KeySetView<K,Boolean> ConcurrentHashMap.newKeySet​()
      创建一个新的Set由ConcurrentHashMap支持从给定的类型到Boolean.TRUE 。
      static <K> ConcurrentHashMap.KeySetView<K,Boolean> ConcurrentHashMap.newKeySet​(int initialCapacity)
      创建一个新的Set ，由给定类型的ConcurrentHashMap支持Boolean.TRUE 。

    • Uses of Boolean in java.util.stream

      Methods in java.util.stream that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Map<Boolean,List<T>>> Collectors.partitioningBy​(Predicate<? super T> predicate)
      返回 Collector由划分根据所述输入元件 Predicate ，并且将它们组织到一个 Map<Boolean, List<T>> 。
      static <T,D,A> Collector<T,?,Map<Boolean,D>> Collectors.partitioningBy​(Predicate<? super T> predicate, Collector<? super T,A,D> downstream)
      返回 Collector由划分根据所述输入元件 Predicate ，减少了在根据另一每个分区中的值 Collector ，并且将它们组织到一个 Map<Boolean, D>其值是下游减少的结果。

    • Uses of Boolean in javafx.beans.binding

      Methods in javafx.beans.binding that return Boolean
      Modifier and Type | 方法 | 描述
      Boolean | BooleanExpression.getValue​()
      Methods in javafx.beans.binding that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      ObjectExpression<Boolean> BooleanExpression.asObject​()
      创建一个ObjectExpression ，其值为BooleanExpression 。
      Method parameters in javafx.beans.binding with type arguments of type Boolean
      Modifier and Type | 方法 | 描述
      void | BooleanBinding.addListener​(ChangeListener<? super Boolean> listener)
      static BooleanExpression BooleanExpression.booleanExpression​(ObservableValue<Boolean> value)
      返回一个BooleanExpression ，其中包含一个ObservableValue 。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, int index)
      创建一个新的BooleanBinding ，其中包含ObservableList在指定位置的元素。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableIntegerValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的ObservableList元素。
      static BooleanBinding Bindings.booleanValueAt​(ObservableList<Boolean> op, ObservableNumberValue index)
      创建一个新的BooleanBinding ，其中包含指定位置的元素ObservableList 。
      static <K> BooleanBinding Bindings.booleanValueAt​(ObservableMap<K,Boolean> op, ObservableValue<? extends K> key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> BooleanBinding Bindings.booleanValueAt​(ObservableMap<K,Boolean> op, K key)
      创建一个新的BooleanBinding ，其中包含ObservableMap中特定键的映射 。
      static BooleanBinding Bindings.createBooleanBinding​(Callable<Boolean> func, Observable... dependencies)
      助手功能创建自定义BooleanBinding 。
      void | BooleanBinding.removeListener​(ChangeListener<? super Boolean> listener)

    • Uses of Boolean in javafx.beans.property

      Methods in javafx.beans.property that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      ObjectProperty<Boolean> BooleanProperty.asObject​()
      创建一个ObjectProperty ，其值为BooleanProperty 。
      ReadOnlyObjectProperty<Boolean> ReadOnlyBooleanProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyBooleanProperty 。
      Methods in javafx.beans.property with parameters of type Boolean
      Modifier and Type 方法 描述
      void BooleanProperty.setValue​(Boolean v)
      设置包装的值。
      Method parameters in javafx.beans.property with type arguments of type Boolean
      Modifier and Type | 方法 | 描述
      void | BooleanPropertyBase.addListener​(ChangeListener<? super Boolean> listener)
      void | ReadOnlyBooleanPropertyBase.addListener​(ChangeListener<? super Boolean> listener)
      void BooleanPropertyBase.bind​(ObservableValue<? extends Boolean> rawObservable)
      为此创建一个单向绑定 Property 。
      void BooleanProperty.bindBidirectional​(Property<Boolean> other)
      在这个 Property之间创建一个双向绑定。
      static BooleanProperty BooleanProperty.booleanProperty​(Property<Boolean> property)
      返回一个BooleanProperty的BooleanProperty 。
      static ReadOnlyBooleanProperty ReadOnlyBooleanProperty.readOnlyBooleanProperty​(ReadOnlyProperty<Boolean> property)
      返回一个ReadOnlyBooleanProperty的ReadOnlyBooleanProperty 。
      void | BooleanPropertyBase.removeListener​(ChangeListener<? super Boolean> listener)
      void | ReadOnlyBooleanPropertyBase.removeListener​(ChangeListener<? super Boolean> listener)
      void BooleanProperty.unbindBidirectional​(Property<Boolean> other)
      删除这个 Property和另一个之间的双向绑定。

    • Uses of Boolean in javafx.beans.property.adapter

      Method parameters in javafx.beans.property.adapter with type arguments of type Boolean
      Modifier and Type 方法 描述
      void JavaBeanBooleanProperty.addListener​(ChangeListener<? super Boolean> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void JavaBeanBooleanProperty.bind​(ObservableValue<? extends Boolean> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanBooleanProperty.removeListener​(ChangeListener<? super Boolean> listener)
      从监听器列表中删除给定的侦听器，每当 ObservableValue的值更改时都会通知 ObservableValue 。

    • Uses of Boolean in javafx.beans.value

      Methods in javafx.beans.value with parameters of type Boolean
      Modifier and Type 方法 描述
      void WritableBooleanValue.setValue​(Boolean value)
      设置包装的值。

    • Uses of Boolean in javafx.css

      Methods in javafx.css that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function)
      创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Boolean>，并继承标志。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty)
      使用先前创建的给定的 cssProperty创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function)
      创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建一个具有初始值的StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Boolean>并继承标志。
      static StyleConverter<String,Boolean> StyleConverter.getBooleanConverter​()
      返回一个 StyleConverter ，其将“真”或“假”到 Boolean 。
      CssMetaData<? extends Styleable,Boolean> SimpleStyleableBooleanProperty.getCssMetaData​()
      反映对应于这个 javafx.beans.property.StyleableProperty
      Methods in javafx.css with parameters of type Boolean
      Modifier and Type 方法 描述
      void StyleableBooleanProperty.applyStyle​(StyleOrigin origin, Boolean v)
      这个方法从CSS代码调用来设置属性的值。
      Method parameters in javafx.css with type arguments of type Boolean
      Modifier and Type 方法 描述
      void StyleableBooleanProperty.bind​(ObservableValue<? extends Boolean> observable)
      为此创建一个单向绑定 Property 。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function)
      创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。
      CssMetaData<S,Boolean> StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Boolean>，并继承标志。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function)
      创建一个StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)
      创建一个具有初始值的StyleableProperty <Boolean>。
      StyleableProperty<Boolean> StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Boolean>并继承标志。
      Constructor parameters in javafx.css with type arguments of type Boolean
      Constructor 描述
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, boolean initialValue)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)
      SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。
      SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)
      的构造函数 SimpleStyleableBooleanProperty 。

    • Uses of Boolean in javafx.css.converter

      Methods in javafx.css.converter that return Boolean
      Modifier and Type | 方法 | 描述
      Boolean | BooleanConverter.convert​(ParsedValue<String,Boolean> value, Font not_used)
      Methods in javafx.css.converter that return types with arguments of type Boolean
      Modifier and Type | 方法 | 描述
      static StyleConverter<String,Boolean> | BooleanConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Boolean
      Modifier and Type | 方法 | 描述
      Boolean | BooleanConverter.convert​(ParsedValue<String,Boolean> value, Font not_used)

    • Uses of Boolean in javafx.scene

      Methods in javafx.scene that return Boolean
      Modifier and Type 方法 描述
      protected Boolean Node.getInitialFocusTraversable​()
      返回此节点的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

    • Uses of Boolean in javafx.scene.control

      Fields in javafx.scene.control with type parameters of type Boolean
      Modifier and Type Field 描述
      static Callback<TableView.ResizeFeatures,Boolean> TableView.CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.CONSTRAINED_RESIZE_POLICY
      确保此表中所有可见叶列的宽度的简单策略总和等于表本身的宽度。
      static Callback<TableView,Boolean> TableView.DEFAULT_SORT_POLICY
      如果没有指定其他策略，则此TableView将使用默认值 sort policy 。
      static Callback<TreeTableView,Boolean> TreeTableView.DEFAULT_SORT_POLICY
      如果没有指定其他策略，则该TreeTableView将使用默认值 sort policy 。
      static Callback<TableView.ResizeFeatures,Boolean> TableView.UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
      static Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.UNCONSTRAINED_RESIZE_POLICY
      非常简单的调整策略，只需通过提供的增量来调整指定列的大小，并将所有其他列（给定列的右侧）向右移动（当增量为正）或向左（当增量为负数时） 。
      Methods in javafx.scene.control that return Boolean
      Modifier and Type 方法 描述
      protected Boolean Accordion.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean ButtonBar.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean Cell.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean Control.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean Label.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean MenuBar.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean ProgressBar.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean ProgressIndicator.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean ScrollBar.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean ScrollPane.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean Separator.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean SplitPane.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      protected Boolean ToolBar.getInitialFocusTraversable​()
      返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。
      static Boolean SplitPane.isResizableWithParent​(Node node)
      如果父容器调整大小为false时，如果节点可调整大小，则返回true。
      Methods in javafx.scene.control that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      ObjectProperty<Callback<TableView.ResizeFeatures,Boolean>> TableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      ObjectProperty<Callback<TreeTableView.ResizeFeatures,Boolean>> TreeTableView.columnResizePolicyProperty​()
      这是当用户完成列大小调整操作时调用的函数。
      Callback<TableView.ResizeFeatures,Boolean> TableView.getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      Callback<TreeTableView.ResizeFeatures,Boolean> TreeTableView.getColumnResizePolicy​()
      获取属性columnResizePolicy的值。
      Callback<TableView<S>,Boolean> TableView.getSortPolicy​()
      获取属性sortPolicy的值。
      Callback<TreeTableView<S>,Boolean> TreeTableView.getSortPolicy​()
      获取属性sortPolicy的值。
      ObjectProperty<Callback<TableView<S>,Boolean>> TableView.sortPolicyProperty​()
      排序策略指定如何执行此TableView中的排序。
      ObjectProperty<Callback<TreeTableView<S>,Boolean>> TreeTableView.sortPolicyProperty​()
      排序策略指定如何执行此TreeTableView中的排序。
      Methods in javafx.scene.control with parameters of type Boolean
      Modifier and Type 方法 描述
      static void SplitPane.setResizableWithParent​(Node node, Boolean value)
      在SplitPane调整大小时，将SplitPane中的节点设置为可调整大小。
      Method parameters in javafx.scene.control with type arguments of type Boolean
      Modifier and Type 方法 描述
      void TableView.setColumnResizePolicy​(Callback<TableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
      void TreeTableView.setColumnResizePolicy​(Callback<TreeTableView.ResizeFeatures,Boolean> callback)
      设置属性columnResizePolicy的值。
      void TableView.setSortPolicy​(Callback<TableView<S>,Boolean> callback)
      设置属性sortPolicy的值。
      void TreeTableView.setSortPolicy​(Callback<TreeTableView<S>,Boolean> callback)
      设置属性sortPolicy的值。

    • Uses of Boolean in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> CheckBoxTableCell.forTableColumn​(TableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> CheckBoxTableCell.forTableColumn​(TableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> CheckBoxTreeTableCell.forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> CheckBoxTreeTableCell.forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      Callback<T,ObservableValue<Boolean>> CheckBoxListCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<TreeItem<T>,ObservableValue<Boolean>> CheckBoxTreeCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTreeTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<T,ObservableValue<Boolean>>> CheckBoxListCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<TreeItem<T>,ObservableValue<Boolean>>> CheckBoxTreeCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTreeTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      Method parameters in javafx.scene.control.cell with type arguments of type Boolean
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建用于ListView控件的单元格工厂。
      static <T> Callback<ListView<T>,ListCell<T>> CheckBoxListCell.forListView​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建用于ListView控件的单元格工厂。
      static <S> Callback<TableColumn<S,Boolean>,TableCell<S,Boolean>> CheckBoxTableCell.forTableColumn​(TableColumn<S,Boolean> column)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S> Callback<TreeTableColumn<S,Boolean>,TreeTableCell<S,Boolean>> CheckBoxTreeTableCell.forTreeTableColumn​(TreeTableColumn<S,Boolean> column)
      创建一个在TreeTableColumn电池厂使用的电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个用于TreeView控件的单元格工厂。
      static <T> Callback<TreeView<T>,TreeCell<T>> CheckBoxTreeCell.forTreeView​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个用于TreeView控件的单元格工厂。
      void CheckBoxListCell.setSelectedStateCallback​(Callback<T,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTreeCell.setSelectedStateCallback​(Callback<TreeItem<T>,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTreeTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      Constructor parameters in javafx.scene.control.cell with type arguments of type Boolean
      Constructor 描述
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxListCell。
      CheckBoxListCell​(Callback<T,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxListCell。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxTableCell，使用自定义的Callback来检索给定单元索引的ObservableValue。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个带有自定义字符串转换器的CheckBoxTableCell。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。
      CheckBoxTreeCell​(Callback<TreeItem<T>,ObservableValue<Boolean>> getSelectedProperty, StringConverter<TreeItem<T>> converter)
      创建一个CheckBoxTreeCell，用于通过单元格工厂的TreeView控件。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      使用自定义的Callback创建一个默认的CheckBoxTreeTableCell，以检索给定单元格索引的ObservableValue。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxTreeTableCell。

    • Uses of Boolean in javafx.scene.layout

      Methods in javafx.scene.layout that return Boolean
      Modifier and Type 方法 描述
      static Boolean GridPane.isFillHeight​(Node child)
      如果设置，返回小孩的垂直填充策略
      static Boolean GridPane.isFillWidth​(Node child)
      如果设置，返回小孩的横向填充策略
      Methods in javafx.scene.layout with parameters of type Boolean
      Modifier and Type 方法 描述
      static void GridPane.setFillHeight​(Node child, Boolean value)
      设置子窗格包含的窗格的垂直填充策略。
      static void GridPane.setFillWidth​(Node child, Boolean value)
      设置子窗格的水平填充策略。

    • Uses of Boolean in javafx.scene.web

      Methods in javafx.scene.web that return types with arguments of type Boolean
      Modifier and Type 方法 描述
      ObjectProperty<Callback<String,Boolean>> WebEngine.confirmHandlerProperty​()
      JavaScript confirm处理程序属性。
      Callback<String,Boolean> WebEngine.getConfirmHandler​()
      获取属性confirmHandler的值。
      EventHandler<WebEvent<Boolean>> WebEngine.getOnVisibilityChanged​()
      获取属性onVisibilityChanged的值。
      ObjectProperty<EventHandler<WebEvent<Boolean>>> WebEngine.onVisibilityChangedProperty​()
      JavaScript窗口可见性处理器属性。
      Method parameters in javafx.scene.web with type arguments of type Boolean
      Modifier and Type 方法 描述
      void WebEngine.setConfirmHandler​(Callback<String,Boolean> handler)
      设置属性confirmHandler的值。
      void WebEngine.setOnVisibilityChanged​(EventHandler<WebEvent<Boolean>> handler)
      设置属性onVisibilityChanged的值。

    • Uses of Boolean in javafx.util.converter

      Methods in javafx.util.converter that return Boolean
      Modifier and Type 方法 描述
      Boolean BooleanStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Boolean
      Modifier and Type 方法 描述
      String BooleanStringConverter.toString​(Boolean value)
      将提供的对象转换为其字符串形式。

    • Uses of Boolean in javax.management

      Methods in javax.management with parameters of type Boolean
      Modifier and Type 方法 描述
      void MBeanRegistration.postRegister​(Boolean registrationDone)
      允许MBean在MBean服务器中注册或注册失败后执行所需的操作。
      void StandardMBean.postRegister​(Boolean registrationDone)
      允许MBean在MBean服务器中注册或注册失败后执行所需的操作。

    • Uses of Boolean in javax.management.loading

      Methods in javax.management.loading with parameters of type Boolean
      Modifier and Type 方法 描述
      void MLet.postRegister​(Boolean registrationDone)
      允许m-let在MBean服务器中注册或注册失败后执行所需的操作。

    • Uses of Boolean in javax.management.modelmbean

      Methods in javax.management.modelmbean with parameters of type Boolean
      Modifier and Type 方法 描述
      void RequiredModelMBean.postRegister​(Boolean registrationDone)
      允许MBean在MBean服务器中注册或注册失败后执行所需的操作。

    • Uses of Boolean in javax.management.monitor

      Methods in javax.management.monitor with parameters of type Boolean
      Modifier and Type 方法 描述
      void Monitor.postRegister​(Boolean registrationDone)
      允许监视器MBean在MBean服务器中注册或注册失败后执行所需的操作。

    • Uses of Boolean in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Boolean
      Modifier and Type Field 描述
      static SimpleType<Boolean> SimpleType.BOOLEAN
      描述Java类名称为 java.lang.Boolean值的 SimpleType实例。

    • Uses of Boolean in javax.management.relation

      Methods in javax.management.relation that return Boolean
      Modifier and Type 方法 描述
      Boolean RelationService.hasRelation​(String relationId)
      检查在关系服务中是否存在与给定关系ID相关联的关系。
      Boolean RelationServiceMBean.hasRelation​(String relationId)
      检查在关系服务中是否存在与给定关系ID相关联的关系。
      Boolean RelationSupport.isInRelationService​()
      返回一个内部标志，指定对象是否仍由关系服务处理。
      Boolean RelationSupportMBean.isInRelationService​()
      返回一个内部标志，指定对象是否仍由关系服务处理。
      Methods in javax.management.relation with parameters of type Boolean
      Modifier and Type | 方法 | 描述
      Integer RelationService.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)
      检查给定的角色是否可以按给定类型的关系进行设置。
      Integer RelationServiceMBean.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)
      检查给定的角色是否可以按给定类型的关系进行设置。
      void | RelationService.postRegister​(Boolean registrationDone)
      void | RelationSupport.postRegister​(Boolean registrationDone)
      void | RelationSupport.setRelationServiceManagementFlag​(Boolean flag)
      void RelationSupportMBean.setRelationServiceManagementFlag​(Boolean flag)
      指定该关系是否由关系服务处理。

    • Uses of Boolean in javax.management.remote

      Methods in javax.management.remote with parameters of type Boolean
      Modifier and Type | 方法 | 描述
      void | JMXConnectorServer.postRegister​(Boolean registrationDone)

    • Uses of Boolean in javax.management.timer

      Methods in javax.management.timer that return Boolean
      Modifier and Type 方法 描述
      Boolean Timer.getFixedRate​(Integer id)
      获取标志的副本，指示是定期通知是以 固定延迟还是 固定速率执行 。
      Boolean TimerMBean.getFixedRate​(Integer id)
      获取标志的副本，指示是定期通知是以 固定延迟还是 固定速率执行 。
      Methods in javax.management.timer with parameters of type Boolean
      Modifier and Type 方法 描述
      void Timer.postRegister​(Boolean registrationDone)
      允许定时器MBean在MBean服务器中注册或注册失败后执行所需的任何操作。

    • Uses of Boolean in javax.swing

      Methods in javax.swing with parameters of type Boolean
      Modifier and Type 方法 描述
      void GroupLayout.setHonorsVisibility​(Component component, Boolean honorsVisibility)
      设置组件的可见性是否考虑到尺寸和定位。
      protected void DefaultDesktopManager.setWasIcon​(JInternalFrame f, Boolean value)
      设置组件已经被图标化，并且 desktopIcon的边界是有效的。

    • Uses of Boolean in javax.swing.filechooser

      Methods in javax.swing.filechooser that return Boolean
      Modifier and Type 方法 描述
      Boolean FileSystemView.isTraversable​(File f)
      如果可以访问文件（目录），则返回true。
      Boolean FileView.isTraversable​(File f)
      该目录是否可遍历。

    • Uses of Boolean in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic with type parameters of type Boolean
      Modifier and Type Field 描述
      protected Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
      用于最小化垂直线的绘图。
      Methods in javax.swing.plaf.basic that return Boolean
      Modifier and Type 方法 描述
      Boolean BasicFileChooserUI.BasicFileView.isHidden​(File f)
      返回是否隐藏文件。

    • Uses of Boolean in javax.tools

      Methods in javax.tools that return Boolean
      Modifier and Type 方法 描述
      Boolean DocumentationTool.DocumentationTask.call​()
      执行此文档任务。
      Boolean JavaCompiler.CompilationTask.call​()
      执行此编译任务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.BootstrapMethodError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.BootstrapMethodError

No usage of java.lang.BootstrapMethodError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Byte (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Byte

  • Packages that use Byte
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。

    • Uses of Byte in java.lang

      Fields in java.lang with type parameters of type Byte
      Modifier and Type Field 描述
      static Class<Byte> Byte.TYPE
      Class实例代表原始类型 byte 。
      Methods in java.lang that return Byte
      Modifier and Type 方法 描述
      static Byte Byte.decode​(String nm)
      将 String解码成 Byte 。
      static Byte Byte.valueOf​(byte b)
      返回表示指定的 byte值的 Byte实例。
      static Byte Byte.valueOf​(String s)
      返回一个 Byte对象，保存由指定的 String给出的值。
      static Byte Byte.valueOf​(String s, int radix)
      返回一个 Byte对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
      Methods in java.lang with parameters of type Byte
      Modifier and Type 方法 描述
      int Byte.compareTo​(Byte anotherByte)
      数值比较两个 Byte对象。

    • Uses of Byte in javafx.util.converter

      Methods in javafx.util.converter that return Byte
      Modifier and Type 方法 描述
      Byte ByteStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Byte
      Modifier and Type 方法 描述
      String ByteStringConverter.toString​(Byte value)
      将提供的对象转换为其字符串形式。

    • Uses of Byte in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Byte
      Modifier and Type Field 描述
      static SimpleType<Byte> SimpleType.BYTE
      描述Java类名称为 java.lang.Byte值的 SimpleType实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Character (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Character

  • Packages that use Character
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of Character in java.awt

      Methods in java.awt with parameters of type Character
      Modifier and Type 方法 描述
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke​(Character keyChar, int modifiers)
      返回一个 AWTKeyStroke的共享实例，该实例表示指定的Character对象的 KEY_TYPED事件和一组修饰符。

    • Uses of Character in java.lang

      Fields in java.lang with type parameters of type Character
      Modifier and Type Field 描述
      static Class<Character> Character.TYPE
      代表 char原始类型的 Class实例。
      Methods in java.lang that return Character
      Modifier and Type 方法 描述
      static Character Character.valueOf​(char c)
      返回表示指定的 char值的 Character实例。
      Methods in java.lang with parameters of type Character
      Modifier and Type 方法 描述
      int Character.compareTo​(Character anotherCharacter)
      数值比较两个 Character对象。

    • Uses of Character in java.util

      Methods in java.util that return types with arguments of type Character
      Modifier and Type 方法 描述
      Set<Character> Locale.getExtensionKeys​()
      返回与此语言环境相关联的扩展键集合，如果没有扩展名则返回空集合。

    • Uses of Character in javafx.util.converter

      Methods in javafx.util.converter that return Character
      Modifier and Type 方法 描述
      Character CharacterStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Character
      Modifier and Type 方法 描述
      String CharacterStringConverter.toString​(Character value)
      将提供的对象转换为其字符串形式。

    • Uses of Character in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Character
      Modifier and Type Field 描述
      static SimpleType<Character> SimpleType.CHARACTER
      描述Java类名称为 java.lang.Character值的 SimpleType实例。

    • Uses of Character in javax.swing

      Methods in javax.swing with parameters of type Character
      Modifier and Type 方法 描述
      static KeyStroke KeyStroke.getKeyStroke​(Character keyChar, int modifiers)
      返回一个 KeyStroke的共享实例，该实例表示指定的Character对象和一组修饰符的一个 KEY_TYPED事件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Character.Subset (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Character.Subset

  • Packages that use Character.Subset
    软件包 描述
    java.awt.im
    提供输入法框架的类和接口。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of Character.Subset in java.awt.im

      Subclasses of Character.Subset in java.awt.im
      Modifier and Type Class 描述
      class  InputSubset
      定义输入法使用的其他Unicode子集。
      Methods in java.awt.im with parameters of type Character.Subset
      Modifier and Type 方法 描述
      void InputContext.setCharacterSubsets​(Character.Subset[] subsets)
      设置输入上下文输入方法的Unicode字符集的子集。

    • Uses of Character.Subset in java.awt.im.spi

      Methods in java.awt.im.spi with parameters of type Character.Subset
      Modifier and Type 方法 描述
      void InputMethod.setCharacterSubsets​(Character.Subset[] subsets)
      设置该输入法允许输入的Unicode字符集的子集。

    • Uses of Character.Subset in java.lang

      Subclasses of Character.Subset in java.lang
      Modifier and Type Class 描述
      static class  Character.UnicodeBlock
      A family of character subsets representing the character blocks in the Unicode specification.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Character.UnicodeBlock (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Character.UnicodeBlock

  • Packages that use Character.UnicodeBlock
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of Character.UnicodeBlock in java.lang

      Fields in java.lang declared as Character.UnicodeBlock
      Modifier and Type Field 描述
      static Character.UnicodeBlock Character.UnicodeBlock.AEGEAN_NUMBERS
      “爱琴海数字”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.AHOM
      “Ahom”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ALCHEMICAL_SYMBOLS
      常数为“Alchemical Symbols”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.ALPHABETIC_PRESENTATION_FORMS
      “字母表示形式”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ANATOLIAN_HIEROGLYPHS
      “安纳托利亚象形文字”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ANCIENT_GREEK_MUSICAL_NOTATION
      常规为“古希腊音乐符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.ANCIENT_GREEK_NUMBERS
      常数为“古希腊数字”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.ANCIENT_SYMBOLS
      “古代符号”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ARABIC
      “阿拉伯语”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ARABIC_EXTENDED_A
      “阿拉伯语扩展A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS
      常数为“阿拉伯数学字母符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_A
      “阿拉伯文表达式A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_B
      “阿拉伯语表达式B”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ARABIC_SUPPLEMENT
      “阿拉伯语补充”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ARMENIAN
      “亚美尼亚”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ARROWS
      常量为“箭头”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.AVESTAN
      “Avestan”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.BALINESE
      “巴厘岛”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.BAMUM
      “Bamum”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.BAMUM_SUPPLEMENT
      “Bamum Supplement”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.BASIC_LATIN
      Unicode基本字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.BASSA_VAH
      常数为“Bassa Vah”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.BATAK
      “Batak”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.BENGALI
      “孟加拉语”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.BLOCK_ELEMENTS
      常量为“块元素”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.BOPOMOFO
      “Bopomofo”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.BOPOMOFO_EXTENDED
      “Bopomofo Extended”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.BOX_DRAWING
      常量为“框图”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.BRAHMI
      “Brahmi”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.BRAILLE_PATTERNS
      “盲文图案”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.BUGINESE
      “Buginese”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.BUHID
      “Buhid”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.BYZANTINE_MUSICAL_SYMBOLS
      常数为“拜占庭式音乐符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CARIAN
      “Carian”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CAUCASIAN_ALBANIAN
      “阿尔巴尼亚白人”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CHAKMA
      “Chakma”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CHAM
      “Cham”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CHEROKEE
      常数为“切诺基”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CHEROKEE_SUPPLEMENT
      常数为“切诺基补充”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_COMPATIBILITY
      常量为“CJK兼容性”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_COMPATIBILITY_FORMS
      “CJK兼容性表单”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS
      “CJK兼容性表意符号”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT
      “CJK兼容性表意文字补充”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_RADICALS_SUPPLEMENT
      常数为“CJK Radicals Supplement”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_STROKES
      常量为“CJK笔画”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_SYMBOLS_AND_PUNCTUATION
      常量为“CJK符号和标点符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS
      “CJK统一表意符号”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A
      “CJK统一表意扩展A”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B
      “CJK统一表意扩展B”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C
      “CJK统一表意扩展C”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D
      “CJK统一表意扩展D”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_E
      “CJK统一表意扩展E”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.COMBINING_DIACRITICAL_MARKS
      “组合变音符号”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.COMBINING_DIACRITICAL_MARKS_EXTENDED
      Unicode字符块的“组合变音符号扩展”的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.COMBINING_DIACRITICAL_MARKS_SUPPLEMENT
      Unicode字符块的“组合变音符号补充”的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.COMBINING_HALF_MARKS
      Unicode字符块的“组合半标记”的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.COMBINING_MARKS_FOR_SYMBOLS
      Unicode字符块的“组合符号变音符号”的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.COMMON_INDIC_NUMBER_FORMS
      “常用印数字”表示Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CONTROL_PICTURES
      “控制图片”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.COPTIC
      “科普特”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.COPTIC_EPACT_NUMBERS
      常规为“科普特数字”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.COUNTING_ROD_NUMERALS
      常数为“计数杆号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.CUNEIFORM
      “Cuneiform”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CUNEIFORM_NUMBERS_AND_PUNCTUATION
      “Cuneiform数字和标点符号”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CURRENCY_SYMBOLS
      Unicode字符块的“货币符号”的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CYPRIOT_SYLLABARY
      “塞浦路字母”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CYRILLIC
      “西里尔”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.CYRILLIC_EXTENDED_A
      “西里尔扩展A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CYRILLIC_EXTENDED_B
      “西里尔扩展B”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.CYRILLIC_SUPPLEMENTARY
      “西里尔语补充”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.DESERET
      “Deseret”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.DEVANAGARI
      “Devanagari”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.DEVANAGARI_EXTENDED
      “梵文扩展”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.DINGBATS
      “Dingbats”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.DOMINO_TILES
      “Domino Tiles”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.DUPLOYAN
      “Duployan”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.EARLY_DYNASTIC_CUNEIFORM
      常数为“早期楔形文字”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.EGYPTIAN_HIEROGLYPHS
      “埃及象形文字”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ELBASAN
      常数为“Elbasan”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.EMOTICONS
      常量为“表情符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.ENCLOSED_ALPHANUMERIC_SUPPLEMENT
      “封闭的字母数字补充”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ENCLOSED_ALPHANUMERICS
      “封闭字母数字”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ENCLOSED_CJK_LETTERS_AND_MONTHS
      “封闭的CJK字母和月”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ENCLOSED_IDEOGRAPHIC_SUPPLEMENT
      “封闭式表意补充”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ETHIOPIC
      “埃塞俄比亚”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ETHIOPIC_EXTENDED
      “埃塞俄比亚扩展”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ETHIOPIC_EXTENDED_A
      “埃塞俄比亚扩展A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ETHIOPIC_SUPPLEMENT
      “埃塞俄比亚补编”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.GENERAL_PUNCTUATION
      常规为“一般标点符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.GEOMETRIC_SHAPES
      “几何形状”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.GEOMETRIC_SHAPES_EXTENDED
      “几何形状扩展”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.GEORGIAN
      “格式”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.GEORGIAN_SUPPLEMENT
      “格鲁吉亚补编”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.GLAGOLITIC
      “Glagolitic”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.GOTHIC
      “哥特式”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.GRANTHA
      “Grantha”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.GREEK
      “希腊和科普特”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.GREEK_EXTENDED
      “希腊语扩展”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.GUJARATI
      “古吉拉特文”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.GURMUKHI
      常数为“古尔穆基”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.HALFWIDTH_AND_FULLWIDTH_FORMS
      Unicode字符块的“半宽和全宽”的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.HANGUL_COMPATIBILITY_JAMO
      “Hanul兼容性Jamo”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.HANGUL_JAMO
      “Hanul Jamo”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.HANGUL_JAMO_EXTENDED_A
      “Hanul Jamo Extended-A”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.HANGUL_JAMO_EXTENDED_B
      “Hanul Jamo Extended-B”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.HANGUL_SYLLABLES
      “汉字音节”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.HANUNOO
      “Hanunoo”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.HATRAN
      “Hatran”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.HEBREW
      “希伯来语”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES
      “高私人使用代理”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.HIGH_SURROGATES
      常数为“高代理”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.HIRAGANA
      “Hiragana”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.IDEOGRAPHIC_DESCRIPTION_CHARACTERS
      Unicode字符块的“表意描述字符”的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.IMPERIAL_ARAMAIC
      “皇家阿拉姆语”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.INSCRIPTIONAL_PAHLAVI
      常数为“Inscriptional Pahlavi”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.INSCRIPTIONAL_PARTHIAN
      “Inscriptional Parthian”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.IPA_EXTENSIONS
      “IPA扩展”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.JAVANESE
      “爪哇”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.KAITHI
      “Kaithi”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KANA_SUPPLEMENT
      “假名补充”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KANBUN
      “Kanbun”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.KANGXI_RADICALS
      常数为“康熙激进”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.KANNADA
      “Kannada”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.KATAKANA
      “片假名”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KATAKANA_PHONETIC_EXTENSIONS
      “片假名语音扩展”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KAYAH_LI
      常数为“Kayah Li”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.KHAROSHTHI
      “Kharoshthi”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KHMER
      “高棉”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KHMER_SYMBOLS
      “高棉符号”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KHOJKI
      “Khojki”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.KHUDAWADI
      “Khudawadi”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LAO
      常数为“老挝”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.LATIN_1_SUPPLEMENT
      “Latin-1 Supplement”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.LATIN_EXTENDED_A
      “Latin Extended-A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LATIN_EXTENDED_ADDITIONAL
      “拉丁扩展附加”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LATIN_EXTENDED_B
      “拉丁扩展B”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LATIN_EXTENDED_C
      “拉丁扩展C”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LATIN_EXTENDED_D
      “拉丁扩展D”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.LATIN_EXTENDED_E
      “拉丁扩展E”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LEPCHA
      “Lepcha”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.LETTERLIKE_SYMBOLS
      Unicode字符块的“字母符号”的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LIMBU
      “Limbu”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LINEAR_A
      “线性A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LINEAR_B_IDEOGRAMS
      “线性B表意符号”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.LINEAR_B_SYLLABARY
      “线性B音节”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.LISU
      “Lisu”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.LOW_SURROGATES
      “低代理”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.LYCIAN
      “Lycian”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.LYDIAN
      常数为“Lydian”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.MAHAJANI
      “Mahajani”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MAHJONG_TILES
      “麻将瓷砖”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MALAYALAM
      “马拉雅拉姆”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MANDAIC
      常数为“Mandaic”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.MANICHAEAN
      “Manichaean”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MATHEMATICAL_ALPHANUMERIC_SYMBOLS
      “数学字母数字符号”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MATHEMATICAL_OPERATORS
      常数为“数学运算符”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.MEETEI_MAYEK
      “Meetei Mayek”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MEETEI_MAYEK_EXTENSIONS
      “Meetei Mayek Extensions”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MENDE_KIKAKUI
      常数为“Mende Kikakui”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.MEROITIC_CURSIVE
      “Meroitic Cursive”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MEROITIC_HIEROGLYPHS
      “Meroitic象形文字”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MIAO
      常量为“Miao”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A
      “Miscellaneous Mathematical Symbols-A”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B
      “Miscellaneous Mathematical Symbols-B”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MISCELLANEOUS_SYMBOLS
      “杂项符号”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MISCELLANEOUS_SYMBOLS_AND_ARROWS
      “杂项符号和箭头”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS
      “Miscellaneous Symbols and Pictographs”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MISCELLANEOUS_TECHNICAL
      “杂项技术”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MODI
      “Modi”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MODIFIER_TONE_LETTERS
      “Modifier Tone Letters”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MONGOLIAN
      “蒙古”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MRO
      “Mro”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MULTANI
      “Multani”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.MUSICAL_SYMBOLS
      常数为“音符”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.MYANMAR
      常数为“缅甸”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.MYANMAR_EXTENDED_A
      “Myanmar Extended-A”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.MYANMAR_EXTENDED_B
      “缅甸扩展B”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.NABATAEAN
      “Nabataean”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.NEW_TAI_LUE
      “新泰乐”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.NKO
      “NKo”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.NUMBER_FORMS
      “数字形式”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.OGHAM
      “Ogham”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.OL_CHIKI
      “Ol Chiki”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.OLD_HUNGARIAN
      “古匈牙利”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.OLD_ITALIC
      “旧斜体”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.OLD_NORTH_ARABIAN
      常数为“旧北阿拉伯”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.OLD_PERMIC
      “Old Permic”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.OLD_PERSIAN
      “老波斯”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.OLD_SOUTH_ARABIAN
      “旧南阿拉伯”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.OLD_TURKIC
      常数为“古突厥语”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.OPTICAL_CHARACTER_RECOGNITION
      Unicode字符块的“光学字符识别”常数。
      static Character.UnicodeBlock Character.UnicodeBlock.ORIYA
      “Oriya”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.ORNAMENTAL_DINGBATS
      “Ornamental Dingbats”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.OSMANYA
      常量为“Osmanya”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.PAHAWH_HMONG
      “Pahawh Hmong”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.PALMYRENE
      常数为“棕榈”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.PAU_CIN_HAU
      “Pau Cin Hau”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.PHAGS_PA
      “Phags-pa”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.PHAISTOS_DISC
      “Phaistos Disc”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.PHOENICIAN
      “腓尼基”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.PHONETIC_EXTENSIONS
      常量为“语音扩展”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.PHONETIC_EXTENSIONS_SUPPLEMENT
      “语音扩展补充”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.PLAYING_CARDS
      常规为“纸牌”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.PRIVATE_USE_AREA
      “私用区域”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.PSALTER_PAHLAVI
      “Psalter Pahlavi”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.REJANG
      “Rejang”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.RUMI_NUMERAL_SYMBOLS
      常数为“Rumi数字符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.RUNIC
      “Runic”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SAMARITAN
      “Samaritan”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SAURASHTRA
      “Saurashtra”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SHARADA
      “Sharada”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SHAVIAN
      “Shavian”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SHORTHAND_FORMAT_CONTROLS
      “速写格式控件”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SIDDHAM
      常数为“Siddham”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.SINHALA
      “Sinhala”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SINHALA_ARCHAIC_NUMBERS
      常数为“僧伽罗古代数字”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.SMALL_FORM_VARIANTS
      常量为“小型变体”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.SORA_SOMPENG
      常数为“Sora Sompeng”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.SPACING_MODIFIER_LETTERS
      “间隔修饰符字母”的常量Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.SPECIALS
      “特殊”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SUNDANESE
      “Sundanese”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SUNDANESE_SUPPLEMENT
      “Sundanese Supplement”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPERSCRIPTS_AND_SUBSCRIPTS
      常数为“上标和下标”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTAL_ARROWS_A
      “补充箭头A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTAL_ARROWS_B
      “补充箭头B”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTAL_ARROWS_C
      “补充箭头-C”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTAL_MATHEMATICAL_OPERATORS
      常数为“补充数学运算符”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTAL_PUNCTUATION
      “补充标点符号”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTAL_SYMBOLS_AND_PICTOGRAPHS
      “补充符号和象形图”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTARY_PRIVATE_USE_AREA_A
      “补充私用区域A”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SUPPLEMENTARY_PRIVATE_USE_AREA_B
      “补充私用区域B”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SURROGATES_AREA
      已过时。
      取而代之的SURROGATES_AREA ，使用HIGH_SURROGATES ， HIGH_PRIVATE_USE_SURROGATES ，并LOW_SURROGATES 。 这些常量符合Unicode标准的块定义。 of(char)和of(int)方法返回标准常数。
      static Character.UnicodeBlock Character.UnicodeBlock.SUTTON_SIGNWRITING
      “Sutton SignWriting”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SYLOTI_NAGRI
      “Syloti Nagri”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.SYRIAC
      “Syriac”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.TAGALOG
      “Tagalog”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.TAGBANWA
      “Tagbanwa”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.TAGS
      常量为“标签”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.TAI_LE
      常数为“大乐”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.TAI_THAM
      “泰泰”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.TAI_VIET
      常数为“Tai Viet”的Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.TAI_XUAN_JING_SYMBOLS
      常数为“大选京符号”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.TAKRI
      “Takri”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.TAMIL
      “泰米尔语”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.TELUGU
      常数为“泰卢固语”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.THAANA
      “Thaana”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.THAI
      “泰语”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.TIBETAN
      “西藏”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.TIFINAGH
      “Tifinagh”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.TIRHUTA
      “Tirhuta”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.TRANSPORT_AND_MAP_SYMBOLS
      Unicode字符块的“传输和映射符号”的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.UGARITIC
      “Ugaritic”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS
      统一的“统一加拿大原住民音节”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED
      统一的“统一加拿大原住民音节扩展”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.VAI
      “Vai”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.VARIATION_SELECTORS
      “变异选择器”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.VARIATION_SELECTORS_SUPPLEMENT
      “变体选择器补充”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.VEDIC_EXTENSIONS
      “Vedic Extensions”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.VERTICAL_FORMS
      “垂直格式”Unicode字符块的常量。
      static Character.UnicodeBlock Character.UnicodeBlock.WARANG_CITI
      常数为“Warang Citi”Unicode字符块。
      static Character.UnicodeBlock Character.UnicodeBlock.YI_RADICALS
      “Yi Radicals”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.YI_SYLLABLES
      “Yi Syllables”Unicode字符块的常数。
      static Character.UnicodeBlock Character.UnicodeBlock.YIJING_HEXAGRAM_SYMBOLS
      “Yijing Hexagram符号”Unicode字符块的常数。
      Methods in java.lang that return Character.UnicodeBlock
      Modifier and Type 方法 描述
      static Character.UnicodeBlock Character.UnicodeBlock.forName​(String blockName)
      返回具有给定名称的UnicodeBlock。
      static Character.UnicodeBlock Character.UnicodeBlock.of​(char c)
      返回表示包含给定字符的Unicode块的对象，如果字符不是定义块的成员，则返回 null 。
      static Character.UnicodeBlock Character.UnicodeBlock.of​(int codePoint)
      返回表示包含给定字符（Unicode代码点）的Unicode块的对象，如果字符不是定义块的成员，则 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Character.UnicodeScript (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Character.UnicodeScript

  • Packages that use Character.UnicodeScript
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of Character.UnicodeScript in java.lang

      Methods in java.lang that return Character.UnicodeScript
      Modifier and Type 方法 描述
      static Character.UnicodeScript Character.UnicodeScript.forName​(String scriptName)
      使用给定的Unicode脚本名称或脚本名称别名返回UnicodeScript常量。
      static Character.UnicodeScript Character.UnicodeScript.of​(int codePoint)
      返回表示给定字符（Unicode代码点）分配给的Unicode脚本的枚举常量。
      static Character.UnicodeScript Character.UnicodeScript.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Character.UnicodeScript[] Character.UnicodeScript.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Class (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Class

  • Packages that use Class
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.spi
    java.nio.file包的服务提供商类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    javafx.application
    提供应用程序生命周期类。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.util
    包含各种实用程序和助手类。
    javax.activation
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.naming.spi
    提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.rmi
    包含RMI-IIOP的用户API。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，该类实现为程序员可以将其用作全功能对象请求代理（ORB）。
    org.omg.CORBA_2_3.portable
    提供值类型的输入和输出方法，并包含 org/omg/CORBA/portable包的其他更新。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.omg.DynamicAny
    提供类和接口，可以在运行时遍历与 any相关联的数据值，并提取数据值的原始组成部分。
    org.omg.PortableServer
    提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。

    • Uses of Class in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util that return Class
      Modifier and Type 方法 描述
      protected static Class<?> Translator.getTranslatorClass​(Class<?> c)
      找到这个班的翻译。
      Methods in com.sun.java.accessibility.util with parameters of type Class
      Modifier and Type 方法 描述
      void AccessibilityListenerList.add​(Class<? extends EventListener> t, EventListener l)
      将侦听器添加为指定类型的侦听器。
      int AccessibilityListenerList.getListenerCount​(Class<? extends EventListener> t)
      返回此侦听器列表提供的类型的侦听器总数。
      protected static Class<?> Translator.getTranslatorClass​(Class<?> c)
      找到这个班的翻译。
      void AccessibilityListenerList.remove​(Class<? extends EventListener> t, EventListener l)
      将侦听器作为指定类型的侦听器删除。

    • Uses of Class in com.sun.source.tree

      Methods in com.sun.source.tree that return Class
      Modifier and Type 方法 描述
      Class<? extends 树> Tree.Kind.asInterface​()
      返回使用这种类型的关联接口类型。

    • Uses of Class in java.awt

      Methods in java.awt with parameters of type Class
      Modifier and Type 方法 描述
      <T extends DragGestureRecognizer>
      T             		Toolkit.createDragGestureRecognizer​(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
      创建一个具体的，依赖平台的抽象DragGestureRecognizer类的子类，并将其与指定的DragSource，Component和DragGestureListener相关联。
      static <T extends EventListener>
      T[]             		AWTEventMulticaster.getListeners​(EventListener l, Class<T> listenerType)
      返回由指定的 java.util.EventListener链接的 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Button.getListeners​(Class<T> listenerType)
      返回此 Button当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Checkbox.getListeners​(Class<T> listenerType)
      返回此 Checkbox当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		CheckboxMenuItem.getListeners​(Class<T> listenerType)
      返回此 CheckboxMenuItem当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Choice.getListeners​(Class<T> listenerType)
      返回此 Choice当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Component.getListeners​(Class<T> listenerType)
      返回此 Component当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Container.getListeners​(Class<T> listenerType)
      返回此 Container当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		List.getListeners​(Class<T> listenerType)
      返回此 List当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		MenuItem.getListeners​(Class<T> listenerType)
      返回此 MenuItem当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		Scrollbar.getListeners​(Class<T> listenerType)
      返回此 Scrollbar当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		TextComponent.getListeners​(Class<T> listenerType)
      返回此 TextComponent当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		TextField.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，此 TextField 。
      <T extends EventListener>
      T[]             		Window.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，此 Window 。
      protected static void AWTKeyStroke.registerSubclass​(Class<?> subclass)
      已过时。

    • Uses of Class in java.awt.datatransfer

      Methods in java.awt.datatransfer that return Class
      Modifier and Type 方法 描述
      Class<?> DataFlavor.getDefaultRepresentationClass​()
      返回默认表示类。
      Class<?> DataFlavor.getRepresentationClass​()
      返回 Class其对象支持此 DataFlavor时，这将返回 DataFlavor请求。
      protected static Class<?> DataFlavor.tryToLoadClass​(String className, ClassLoader fallback)
      尝试加载一个类：引导加载程序，系统加载程序，上下文加载程序（如果存在），最后指定加载程序。
      Constructors in java.awt.datatransfer with parameters of type Class
      Constructor 描述
      DataFlavor​(Class<?> representationClass, String humanPresentableName)
      构造一个表示Java类的 DataFlavor 。

    • Uses of Class in java.awt.dnd

      Methods in java.awt.dnd with parameters of type Class
      Modifier and Type 方法 描述
      <T extends DragGestureRecognizer>
      T             		DragSource.createDragGestureRecognizer​(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
      创建一个新的 DragGestureRecognizer实现的指定抽象子类 DragGestureRecognizer ，并设置指定 Component和 DragGestureListener新创建的对象上。
      <T extends EventListener>
      T[]             		DragSource.getListeners​(Class<T> listenerType)
      获取当前注册的所有对象为 FooListener s在此 DragSource 。

    • Uses of Class in java.awt.image.renderable

      Methods in java.awt.image.renderable that return Class
      Modifier and Type 方法 描述
      Class<?>[] ParameterBlock.getParamClasses​()
      返回描述参数类型的Class对象数组。

    • Uses of Class in java.beans

      Methods in java.beans that return Class
      Modifier and Type 方法 描述
      Class<?> BeanDescriptor.getBeanClass​()
      获取bean的Class对象。
      Class<?> BeanDescriptor.getCustomizerClass​()
      获取bean的定制器的Class对象。
      Class<?> IndexedPropertyDescriptor.getIndexedPropertyType​()
      返回索引属性的Java类型信息。
      Class<?> EventSetDescriptor.getListenerType​()
      获取目标接口的 Class对象。
      Class<?> PropertyDescriptor.getPropertyEditorClass​()
      获取已为此属性注册的任何显式PropertyEditor类。
      Class<?> PropertyDescriptor.getPropertyType​()
      返回属性的Java类型信息。
      Methods in java.beans with parameters of type Class
      Modifier and Type 方法 描述
      static <T> T EventHandler.create​(Class<T> listenerInterface, Object target, String action)
      创建一个 listenerInterface的实现，其中监听器界面中的 所有方法将处理程序的 action应用于 target 。
      static <T> T EventHandler.create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
      / **创建的实施 listenerInterface ，其中 所有的方法传递事件表达，的值 eventPropertyName ，到最后方法中的发言， action ，其被施加到 target 。
      static <T> T EventHandler.create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
      创建的实施 listenerInterface其中命名方法 listenerMethodName传递事件表达，的值 eventPropertyName ，在语句中的最终方法， action ，其被施加到 target 。
      static PropertyEditor PropertyEditorManager.findEditor​(Class<?> targetType)
      找到给定目标类型的值编辑器。
      static void Introspector.flushFromCaches​(Class<?> clz)
      刷新内部缓存信息给一个给定的类。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass)
      内省Java Bean并了解其所有属性，暴露的方法和事件。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, int flags)
      对Java bean进行内省，并了解其所有属性，公开方法和事件，并遵守一些控制标志。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, Class<?> stopClass)
      内省Java bean并了解其属性，暴露的方法，低于给定的“停止”点。
      static BeanInfo Introspector.getBeanInfo​(Class<?> beanClass, Class<?> stopClass, int flags)
      对Java Bean进行内省，并了解其所有属性，暴露的方法和事件，低于给定的 stopClass点，受到一些控制 flags 。
      static Object Beans.getInstanceOf​(Object bean, Class<?> targetType)
      从给定的bean获取表示该源对象的指定类型视图的对象。
      PersistenceDelegate Encoder.getPersistenceDelegate​(Class<?> type)
      返回给定类型的持久代理。
      protected void DefaultPersistenceDelegate.initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
      这个 initialize方法的默认实现假定这种类型的对象中保留的所有状态都是通过匹配的“setter”和“getter”方法按Introspector返回的顺序公开的。
      protected void PersistenceDelegate.initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
      对 newInstance生成一系列具有副作用的语句，使新实例变为 等效于 oldInstance 。
      static boolean Beans.isInstanceOf​(Object bean, Class<?> targetType)
      检查一个bean是否可以被看作给定的目标类型。
      static void PropertyEditorManager.registerEditor​(Class<?> targetType, Class<?> editorClass)
      注册编辑器类来编辑给定目标类的值。
      void Encoder.setPersistenceDelegate​(Class<?> type, PersistenceDelegate delegate)
      将指定的持久性委托与给定类型关联。
      void PropertyDescriptor.setPropertyEditorClass​(Class<?> propertyEditorClass)
      通常使用PropertyEditorManager可以找到PropertyEditors。
      Constructors in java.beans with parameters of type Class
      Constructor 描述
      BeanDescriptor​(Class<?> beanClass)
      为没有自定义程序的bean创建BeanDescriptor。
      BeanDescriptor​(Class<?> beanClass, Class<?> customizerClass)
      为具有自定义程序的bean创建BeanDescriptor。
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
      创建一个 EventSetDescriptor假设您遵循最简单的标准设计模式，其中一个命名事件“fred”（1）作为对接口FredListener的单一方法的调用传递（2）具有类型为FredEvent的单个参数和（ 3）FredListener可以通过对源组件的addFredListener方法的调用进行注册，并通过removeFredListener方法的调用进行删除。
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
      使用字符串名称从头创建一个 EventSetDescriptor 。
      EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
      该构造函数使用字符串名称从头开始创建一个EventSetDescriptor。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, 方法 addListenerMethod, 方法 removeListenerMethod)
      创建一个 EventSetDescriptor使用从无到有 java.lang.reflect.MethodDescriptor个 java.lang.Class对象。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod)
      使用 java.lang.reflect.Method和 java.lang.Class对象从头开始创建一个 EventSetDescriptor 。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod, 方法 getListenerMethod)
      此构造函数从头开始使用java.lang.reflect.Method和java.lang.Class对象创建一个EventSetDescriptor。
      IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass)
      该构造函数通过使用getFoo和setFoo访问器方法为索引访问和数组访问来构造遵循标准Java约定的属性的IndexedPropertyDescriptor。
      IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的方法名称，包括索引和非索引。
      PropertyDescriptor​(String propertyName, Class<?> beanClass)
      通过使用getFoo和setFoo访问器方法，为遵循标准Java约定的属性构造PropertyDescriptor。
      PropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
      该构造函数使用简单属性的名称，以及读取和写入属性的方法名称。

    • Uses of Class in java.beans.beancontext

      Fields in java.beans.beancontext declared as Class
      Modifier and Type Field 描述
      protected Class<?> BeanContextServiceAvailableEvent.serviceClass
      A Class对新提供的服务的引用
      protected Class<?> BeanContextServiceRevokedEvent.serviceClass
      A Class对正在撤销的服务的引用。
      Methods in java.beans.beancontext that return Class
      Modifier and Type 方法 描述
      Class<?> BeanContextServiceAvailableEvent.getServiceClass​()
      获取作为此通知主题的服务类。
      Class<?> BeanContextServiceRevokedEvent.getServiceClass​()
      获取作为此通知主题的服务类
      Methods in java.beans.beancontext with parameters of type Class
      Modifier and Type | 方法 | 描述
      boolean BeanContextServices.addService​(Class<?> serviceClass, BeanContextServiceProvider serviceProvider)
      向这个BeanContext添加一个服务。
      boolean BeanContextServicesSupport.addService​(Class<?> serviceClass, BeanContextServiceProvider bcsp)
      添加服务
      protected boolean BeanContextServicesSupport.addService​(Class<?> serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
      添加服务
      protected static boolean BeanContextSupport.classEquals​(Class<?> first, Class<?> second)
      测试两个类对象或其名称是否相等。
      protected BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider​(Class<?> sc, BeanContextServiceProvider bcsp)
      子类可以覆盖此方法来创建BCSSServiceProvider的新子类，而不必重写addService（）以便实例化。
      protected void BeanContextServicesSupport.fireServiceAdded​(Class<?> serviceClass)
      通知新服务 BeanContextServiceEvent 。
      protected void BeanContextServicesSupport.fireServiceRevoked​(Class<?> serviceClass, boolean revokeNow)
      触发 BeanContextServiceRevokedEvent表示特定服务不再可用。
      Iterator<?> BeanContextServiceProvider.getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      此方法由 BeanContextServices调用，获取指定服务的当前服务选择器。
      Iterator<?> BeanContextServices.getCurrentServiceSelectors​(Class<?> serviceClass)
      通过调用底层BeanContextServiceProvider上的getCurrentServiceSelectors（），获取指定服务的服务相关服务参数（服务选择器）列表。
      Iterator<?> | BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors​(BeanContextServices bcs, Class<?> serviceClass)
      Iterator<?> | BeanContextServicesSupport.getCurrentServiceSelectors​(Class<?> serviceClass)
      Object BeanContextServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)
      该方法由 BeanContextServices调用，请求此 BeanContextServiceProvider的服务实例。
      Object BeanContextServices.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。
      Object | BeanContextServicesSupport.BCSSProxyServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)
      Object BeanContextServicesSupport.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
      获得可能委托的服务
      boolean BeanContextServices.hasService​(Class<?> serviceClass)
      报告当前是否可以从此上下文获得给定的服务。
      boolean BeanContextServicesSupport.hasService​(Class<?> serviceClass)
      有一个可以委派的服务
      boolean BeanContextServiceRevokedEvent.isServiceClass​(Class<?> service)
      检查此事件以确定被撤销的服务是否属于特定类。
      void BeanContextServices.revokeService​(Class<?> serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
      希望从此上下文中删除当前注册的服务的BeanContextServiceProviders可以通过调用此方法来实现。
      void BeanContextServicesSupport.revokeService​(Class<?> serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
      删除服务
      Constructors in java.beans.beancontext with parameters of type Class
      Constructor 描述
      BeanContextServiceAvailableEvent​(BeanContextServices bcs, Class<?> sc)
      构造一个 BeanContextAvailableServiceEvent 。
      BeanContextServiceRevokedEvent​(BeanContextServices bcs, Class<?> sc, boolean invalidate)
      构建一个 BeanContextServiceEvent 。

    • Uses of Class in java.io

      Methods in java.io that return Class
      Modifier and Type 方法 描述
      Class<?> ObjectStreamClass.forClass​()
      返回此版本映射到的本地VM中的类。
      Class<?> ObjectStreamField.getType​()
      获取字段的类型。
      protected Class<?> ObjectInputStream.resolveClass​(ObjectStreamClass desc)
      加载本地类等效的指定流类描述。
      protected Class<?> ObjectInputStream.resolveProxyClass​(String[] interfaces)
      返回一个代理类，它实现代理类描述符中命名的接口; 子类可以实现此方法从流中读取自定义数据以及动态代理类的描述符，从而允许它们为接口和代理类使用备用加载机制。
      Class<?> ObjectInputFilter.FilterInfo.serialClass​()
      被反序列化的对象的类。
      Methods in java.io with parameters of type Class
      Modifier and Type 方法 描述
      protected void ObjectOutputStream.annotateClass​(Class<?> cl)
      子类可以实现此方法，以允许类数据存储在流中。
      protected void ObjectOutputStream.annotateProxyClass​(Class<?> cl)
      子类可以实现这种方法来存储流中的自定义数据以及动态代理类的描述符。
      static ObjectStreamClass ObjectStreamClass.lookup​(Class<?> cl)
      找到可以序列化的类的描述符。
      static ObjectStreamClass ObjectStreamClass.lookupAny​(Class<?> cl)
      返回任何类的描述符，无论它是否实现Serializable 。
      Constructors in java.io with parameters of type Class
      Constructor 描述
      ObjectStreamField​(String name, Class<?> type)
      创建一个具有指定类型的Serializable字段。
      ObjectStreamField​(String name, Class<?> type, boolean unshared)
      创建一个ObjectStreamField，表示具有给定名称和类型的可序列化字段。

    • Uses of Class in java.lang

      Fields in java.lang declared as Class
      Modifier and Type Field 描述
      static Class<Boolean> Boolean.TYPE
      表示原始类型的类对象布尔值。
      static Class<Byte> Byte.TYPE
      所述 Class实例表示基本类型 byte 。
      static Class<Character> Character.TYPE
      所述 Class实例表示基本类型 char 。
      static Class<Double> Double.TYPE
      代表 double原始类型的 Class实例。
      static Class<Float> Float.TYPE
      Class实例，表示原始类型 float 。
      static Class<Integer> Integer.TYPE
      Class表示原始类型 int实例。
      static Class<Long> Long.TYPE
      Class实例表示原始类型 long 。
      static Class<Short> Short.TYPE
      所述 Class实例表示基本类型 short 。
      static Class<Void> Void.TYPE
      表示对应于关键字 void的伪类型的 Class对象。
      Methods in java.lang that return Class
      Modifier and Type 方法 描述
      <U> Class<? extends U> Class.asSubclass​(Class<U> clazz)
      Class这个 Class对象来表示由指定的类对象表示的类的子类。
      protected Class<?> SecurityManager.currentLoadedClass​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      protected Class<?> ClassLoader.defineClass​(byte[] b, int off, int len)
      已过时。
      由defineClass(String, byte[], int, int)替代
      protected Class<?> ClassLoader.defineClass​(String name, byte[] b, int off, int len)
      将一个字节数组转换为 Class类的实例。
      protected Class<?> ClassLoader.defineClass​(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
      将一个字节数组转换为类 Class一个实例，给定的是 ProtectionDomain 。
      protected Class<?> ClassLoader.defineClass​(String name, ByteBuffer b, ProtectionDomain protectionDomain)
      一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。
      Class<? extends Enum> EnumConstantNotPresentException.enumType​()
      返回缺少的枚举常量的类型。
      protected Class<?> ClassLoader.findClass​(String name)
      查找具有指定的 类别binary name 。
      protected Class<?> ClassLoader.findClass​(String moduleName, String name)
      在给这个类加载器定义的模块中找到给定的 binary name的类。
      protected Class<?> ClassLoader.findLoadedClass​(String name)
      如果这个装载程序已被Java虚拟机记录为具有该 binary name的类的启动加载程序，则返回具有给定的 binary name的类。
      protected Class<?> ClassLoader.findSystemClass​(String name)
      查找具有指定的 类别binary name ，如果需要加载它。
      static Class<?> Class.forName​(Module module, String name)
      返回 Class给定 binary name给定的模块中。
      static Class<?> Class.forName​(String className)
      返回与给定字符串名称的类或接口相关联的 Class对象。
      static Class<?> Class.forName​(String name, boolean initialize, ClassLoader loader)
      使用给定的类加载器返回与给定字符串名称的类或接口关联的 Class对象。
      Class<?> StackWalker.getCallerClass​()
      获取调用者调用 getCallerClass的方法的调用者的 Class对象。
      Class<?> Object.getClass​()
      返回此 Object的运行时类。
      protected Class<?>[] SecurityManager.getClassContext​()
      将当前执行堆栈作为一个类的数组返回。
      Class<?>[] Class.getClasses​()
      返回一个包含 Class对象的数组， Class对象表示由该 Class对象表示的类的成员的所有公共类和接口。
      Class<?> Class.getComponentType​()
      返回表示数组的组件类型的 Class 。
      Class<?>[] Class.getDeclaredClasses​()
      返回一个 Class对象的数组，反映所有被这个 Class对象表示的类的成员声明的类和接口。
      Class<?> Class.getDeclaringClass​()
      如果由此 Class对象表示的类或接口是另一个类的成员，则返回表示其声明的类的 Class对象。
      Class<E> Enum.getDeclaringClass​()
      返回与此枚举常量的枚举类型相对应的Class对象。
      Class<?> StackWalker.StackFrame.getDeclaringClass​()
      获取由此堆栈帧表示的方法的声明 Class 。
      Class<?> Class.getEnclosingClass​()
      返回底层类的即时封闭类。
      Class<?>[] Class.getInterfaces​()
      返回由该对象表示的类或接口直接实现的接口。
      Class<? super T> Class.getSuperclass​()
      返回表示由该 Class表示的实体的直接超类（类，接口，原始类型或空白）的 Class 。
      Class<?> ClassLoader.loadClass​(String name)
      加载指定的 类别binary name 。
      protected Class<?> ClassLoader.loadClass​(String name, boolean resolve)
      加载指定的 类别binary name 。
      Methods in java.lang that return types with arguments of type Class
      Modifier and Type 方法 描述
      TypeVariable<Class<T>>[] Class.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。
      Methods in java.lang with parameters of type Class
      Modifier and Type 方法 描述
      Module Module.addUses​(Class<?> service)
      如果调用者模块是此模块，则更新此模块以添加对给定服务类型的服务依赖。
      <U> Class<? extends U> Class.asSubclass​(Class<U> clazz)
      Class这个 Class对象来表示由指定的类对象表示的类的子类。
      boolean Module.canUse​(Class<?> service)
      指示此模块是否具有对给定服务类型的服务依赖性。
      void SecurityManager.checkMemberAccess​(Class<?> clazz, int which)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法依赖于调用者的堆栈深度为4，容易出错，并且不能由运行时执行。 该方法的用户应直接调用SecurityManager.checkPermission(java.security.Permission) 。 此方法在将来的Java SE版本中可能会被删除。
      static boolean Compiler.compileClass​(Class<?> clazz)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      编译指定的类。
      protected abstract T ClassValue.computeValue​(Class<?> type)
      计算给定类的派生值为这个 ClassValue 。
      T ClassValue.get​(Class<?> type)
      返回给定类的值。
      <A extends Annotation>
      A             		Class.getAnnotation​(Class<A> annotationClass)
      <T extends Annotation>
      T             		Module.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <A extends Annotation>
      A             		Package.getAnnotation​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Class.getAnnotationsByType​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Package.getAnnotationsByType​(Class<A> annotationClass)
      Constructor<T> Class.getConstructor​(Class<?>... parameterTypes)
      返回 Constructor对象，它反映此表示的类的指定公共构造 Class对象。
      <A extends Annotation>
      A             		Class.getDeclaredAnnotation​(Class<A> annotationClass)
      <A extends Annotation>
      A             		Package.getDeclaredAnnotation​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Class.getDeclaredAnnotationsByType​(Class<A> annotationClass)
      <A extends Annotation>
      A[]             		Package.getDeclaredAnnotationsByType​(Class<A> annotationClass)
      Constructor<T> Class.getDeclaredConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由该 Class对象表示的类或接口的指定构造函数。
      方法 Class.getDeclaredMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，它反映此表示的类或接口的指定声明的方法 Class对象。
      方法 Class.getMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，它反映此表示的类或接口的指定公共成员方法 Class对象。
      boolean Class.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      boolean Package.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      boolean Class.isAssignableFrom​(Class<?> cls)
      确定由此 Class对象表示的类或接口是否与由指定的 Class参数表示的类或接口相同，或者是超类或超级接口。
      void ClassValue.remove​(Class<?> type)
      删除给定类的关联值。
      protected void ClassLoader.resolveClass​(Class<?> c)
      链接指定的类。
      protected void ClassLoader.setSigners​(Class<?> c, Object[] signers)
      设置一个类的签名者。
      static <T extends Enum<T>>
      T             		Enum.valueOf​(Class<T> enumType, String name)
      返回具有指定名称的指定枚举类型的枚举常量。
      Constructors in java.lang with parameters of type Class
      Constructor 描述
      EnumConstantNotPresentException​(Class<? extends Enum> enumType, String constantName)
      为指定的常量构造一个 EnumConstantNotPresentException 。

    • Uses of Class in java.lang.annotation

      Methods in java.lang.annotation that return Class
      Modifier and Type 方法 描述
      Class<? extends Annotation> Annotation.annotationType​()
      返回此注释的注释类型。
      Class<? extends Annotation> IncompleteAnnotationException.annotationType​()
      返回缺少元素的注释类型的Class对象。
      Constructors in java.lang.annotation with parameters of type Class
      Constructor 描述
      IncompleteAnnotationException​(Class<? extends Annotation> annotationType, String elementName)
      构造一个IncompleteAnnotationException来指示指定的元素在指定的注释类型中丢失。

    • Uses of Class in java.lang.instrument

      Methods in java.lang.instrument that return Class
      Modifier and Type 方法 描述
      Class[] Instrumentation.getAllLoadedClasses​()
      返回当前由JVM加载的所有类的数组。
      Class<?> ClassDefinition.getDefinitionClass​()
      返回类。
      Class[] Instrumentation.getInitiatedClasses​(ClassLoader loader)
      返回一个 loader是起始加载器的所有类的数组。
      Methods in java.lang.instrument with parameters of type Class
      Modifier and Type 方法 描述
      boolean Instrumentation.isModifiableClass​(Class<?> theClass)
      测试课程是否可修改 retransformation或 redefinition 。
      void Instrumentation.retransformClasses​(Class<?>... classes)
      重新转换提供的一组类。
      default byte[] ClassFileTransformer.transform​(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
      default byte[] ClassFileTransformer.transform​(Module module, ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
      Constructors in java.lang.instrument with parameters of type Class
      Constructor 描述
      ClassDefinition​(Class<?> theClass, byte[] theClassFile)
      使用提供的类和类文件字节创建一个新的 ClassDefinition绑定。

    • Uses of Class in java.lang.invoke

      Methods in java.lang.invoke that return Class
      Modifier and Type 方法 描述
      Class<?> MethodHandles.Lookup.accessClass​(Class<?> targetClass)
      确定是否可以从此 Lookup对象定义的查找上下文中访问类。
      Class<?> MethodHandles.Lookup.defineClass​(byte[] bytes)
      将类定义到相同的类加载器，并在同一个运行时包中，以及protection domain作为此查找的lookup class 。
      Class<?> MethodHandles.Lookup.findClass​(String targetName)
      从这个 Lookup对象定义的查找上下文中按名称查找一个类。
      Class<?> MethodHandleInfo.getDeclaringClass​()
      返回定义了破解方法句柄的基础成员的类。
      Class<?> MethodHandles.Lookup.lookupClass​()
      告诉哪个类执行查找。
      Class<?>[] MethodType.parameterArray​()
      将参数类型显示为数组（方便方法）。
      Class<?> MethodType.parameterType​(int num)
      在此方法类型中返回指定索引处的参数类型。
      Class<?> MethodType.returnType​()
      返回此方法类型的返回类型。
      Class<?> VarHandle.varType​()
      返回此VarHandle引用的变量的变量类型。
      static Class<?> MethodHandleProxies.wrapperInstanceType​(Object x)
      恢复创建此包装器实例的唯一的单一方法接口类型。
      Methods in java.lang.invoke that return types with arguments of type Class
      Modifier and Type 方法 描述
      List<Class<?>> VarHandle.coordinateTypes​()
      返回此VarHandle的坐标类型。
      List<Class<?>> MethodType.parameterList​()
      将参数类型显示为列表（方便方法）。
      Methods in java.lang.invoke with parameters of type Class
      Modifier and Type 方法 描述
      Class<?> MethodHandles.Lookup.accessClass​(Class<?> targetClass)
      确定是否可以从此 Lookup对象定义的查找上下文中访问类。
      MethodType MethodType.appendParameterTypes​(Class<?>... ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      static MethodHandle MethodHandles.arrayConstructor​(Class<?> arrayClass)
      生成构造所需类型的数组的方法句柄。
      static MethodHandle MethodHandles.arrayElementGetter​(Class<?> arrayClass)
      产生方法句柄，提供对数组元素的读取访问。
      static MethodHandle MethodHandles.arrayElementSetter​(Class<?> arrayClass)
      生成方法句柄，为数组的元素提供写访问权限。
      static VarHandle MethodHandles.arrayElementVarHandle​(Class<?> arrayClass)
      产生一个VarHandle，可访问arrayClass类型的数组的 arrayClass 。
      static MethodHandle MethodHandles.arrayLength​(Class<?> arrayClass)
      产生返回数组长度的方法句柄。
      MethodHandle MethodHandle.asCollector​(int collectArgPos, Class<?> arrayType, int arrayLength)
      创建一个 数组收集方法句柄，它接收从给定位置开始的给定数量的位置参数，并将它们收集到数组参数中。
      MethodHandle MethodHandle.asCollector​(Class<?> arrayType, int arrayLength)
      使 数组收集方法句柄接受给定数量的尾随位置参数并将其收集到数组参数中。
      static <T> T MethodHandleProxies.asInterfaceInstance​(Class<T> intfc, MethodHandle target)
      生成给定的单一方法接口的实例，将其调用重定向到给定的方法句柄。
      MethodHandle MethodHandle.asSpreader​(int spreadArgPos, Class<?> arrayType, int arrayLength)
      创建一个 数组扩展方法句柄，它可以在给定的位置接受一个数组参数，并将其元素作为位置参数扩展代替数组。
      MethodHandle MethodHandle.asSpreader​(Class<?> arrayType, int arrayLength)
      创建一个 数组扩展方法句柄，它接受一个尾随数组参数，并将其元素作为位置参数传播。
      MethodHandle MethodHandle.asVarargsCollector​(Class<?> arrayType)
      创建一个 可变的arity适配器，它可以接受任意数量的尾随位置参数并将其收集到数组参数中。
      static VarHandle MethodHandles.byteArrayViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生一个VarHandle，可以访问 byte[]数组的元素，就像它是不同的基元数组类型一样，如 int[]或 long[] 。
      static VarHandle MethodHandles.byteBufferViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生VarHandle给予访问的元素 ByteBuffer视为好像它是一个不同的基本组件类型到的元件的阵列 byte ，如 int[]或 long[] 。
      static MethodHandle MethodHandles.catchException​(MethodHandle target, Class<? extends Throwable> exType, MethodHandle handler)
      通过在异常处理程序中运行它来创建适应目标方法句柄的方法句柄。
      MethodType MethodType.changeParameterType​(int num, Class<?> nptype)
      查找或创建具有单个不同参数类型的方法类型。
      MethodType MethodType.changeReturnType​(Class<?> nrtype)
      查找或创建具有不同返回类型的方法类型。
      static MethodHandle MethodHandles.constant​(Class<?> type, Object value)
      生成请求的返回类型的方法句柄，每次调用时返回给定的常量值。
      static MethodHandle MethodHandles.dropArguments​(MethodHandle target, int pos, Class<?>... valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      MethodHandle MethodHandles.Lookup.findConstructor​(Class<?> refc, MethodType type)
      使用指定类型的构造函数生成创建对象并初始化它的方法句柄。
      MethodHandle MethodHandles.Lookup.findGetter​(Class<?> refc, String name, Class<?> type)
      产生方法句柄，给非静态字段的读访问权限。
      MethodHandle MethodHandles.Lookup.findSetter​(Class<?> refc, String name, Class<?> type)
      产生一个给非静态字段写入访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findSpecial​(Class<?> refc, String name, MethodType type, Class<?> specialCaller)
      为虚拟方法生成早期绑定的方法句柄。
      MethodHandle MethodHandles.Lookup.findStatic​(Class<?> refc, String name, MethodType type)
      为静态方法生成方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticGetter​(Class<?> refc, String name, Class<?> type)
      产生一个给静态字段读取访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticSetter​(Class<?> refc, String name, Class<?> type)
      生成方法句柄，给静态字段写权限。
      VarHandle MethodHandles.Lookup.findStaticVarHandle​(Class<?> decl, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的静态字段 decl 。
      VarHandle MethodHandles.Lookup.findVarHandle​(Class<?> recv, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的非静态字段 recv 。
      MethodHandle MethodHandles.Lookup.findVirtual​(Class<?> refc, String name, MethodType type)
      为虚拟方法生成方法句柄。
      static MethodHandle MethodHandles.identity​(Class<?> type)
      生成方法句柄，在调用时返回其唯一参数。
      MethodHandles.Lookup MethodHandles.Lookup.in​(Class<?> requestedLookupClass)
      在指定的新查找类上创建一个查找。
      MethodType MethodType.insertParameterTypes​(int num, Class<?>... ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, Class<?> ptype0)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, Class<?>[] ptypes)
      查找或创建给定方法类型的实例。
      static MethodType MethodType.methodType​(Class<?> rtype, Class<?> ptype0, Class<?>... ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, MethodType ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, List<Class<?>> ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodHandles.Lookup MethodHandles.privateLookupIn​(Class<?> targetClass, MethodHandles.Lookup lookup)
      返回一个lookup object，具有完整功能，可以在目标类上模拟所有支持的字节码行为，包括private access 。
      <T extends Member>
      T             		MethodHandleInfo.reflectAs​(Class<T> expected, MethodHandles.Lookup lookup)
      将基础成员反映为方法，构造函数或字段对象。
      static <T extends Member>
      T             		MethodHandles.reflectAs​(Class<T> expected, MethodHandle target)
      执行一个未经检查的“裂缝”的 direct method handle 。
      static MethodHandle MethodHandles.throwException​(Class<?> returnType, Class<? extends Throwable> exType)
      产生一个方法句柄，它将抛出给定的异常 exType 。
      static String MethodHandleInfo.toString​(int kind, Class<?> defc, String name, MethodType type)
      给出 MethodHandleInfo的字符串表示，给出其符号引用的四个部分。
      MethodHandle MethodHandles.Lookup.unreflectSpecial​(方法 m, Class<?> specialCaller)
      为反映的方法生成方法句柄。
      static MethodHandle MethodHandles.zero​(Class<?> type)
      生成请求的返回类型的常量方法句柄，每次调用时返回该类型的默认值。
      Method parameters in java.lang.invoke with type arguments of type Class
      Modifier and Type 方法 描述
      MethodType MethodType.appendParameterTypes​(List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      static MethodHandle MethodHandles.dropArguments​(MethodHandle target, int pos, List<Class<?>> valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle MethodHandles.dropArgumentsToMatch​(MethodHandle target, int skip, List<Class<?>> newTypes, int pos)
      适应目标方法句柄以匹配给定的参数类型列表。
      MethodType MethodType.insertParameterTypes​(int num, List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, List<Class<?>> ptypes)
      查找或创建具有给定组件的方法类型。
      Constructors in java.lang.invoke with parameters of type Class
      Constructor 描述
      SerializedLambda​(Class<?> capturingClass, String functionalInterfaceClass, String functionalInterfaceMethodName, String functionalInterfaceMethodSignature, int implMethodKind, String implClass, String implMethodName, String implMethodSignature, String instantiatedMethodType, Object[] capturedArgs)
      从lambda工厂现场的低级信息创建一个 SerializedLambda 。

    • Uses of Class in java.lang.management

      Methods in java.lang.management that return types with arguments of type Class
      Modifier and Type 方法 描述
      static Set<Class<? extends PlatformManagedObject>> ManagementFactory.getPlatformManagementInterfaces​()
      返回Class对象的集合，子界面为PlatformManagedObject ，表示用于监视和管理Java平台的所有管理接口。
      Methods in java.lang.management with parameters of type Class
      Modifier and Type 方法 描述
      static <T extends PlatformManagedObject>
      T             		ManagementFactory.getPlatformMXBean​(Class<T> mxbeanInterface)
      返回实现给定的 mxbeanInterface的平台MXBean，该 mxbeanInterface被指定为在Java虚拟机中具有一个实例。
      static <T extends PlatformManagedObject>
      T             		ManagementFactory.getPlatformMXBean​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回 mxbeanInterface的平台MXBean代理，该代理被指定为在Java虚拟机中具有一个实例，代理将通过给定的 MBeanServerConnection转发方法调用。
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans​(Class<T> mxbeanInterface)
      返回在Java虚拟机中实现给定的 mxbeanInterface的平台 mxbeanInterface的列表。
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回平台MXBean代理的列表，用于通过给定的 MBeanServerConnection转发 mxbeanInterface的方法调用。
      static <T> T ManagementFactory.newPlatformMXBeanProxy​(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
      返回给定的平台MXBean接口的代理 MXBean name转发其方法调用通过给定 MBeanServerConnection 。

    • Uses of Class in java.lang.reflect

      Methods in java.lang.reflect that return Class
      Modifier and Type 方法 描述
      Class<T> Constructor.getDeclaringClass​()
      返回表示声明由该对象表示的构造函数的类的 Class对象。
      abstract Class<?> Executable.getDeclaringClass​()
      返回表示由该对象表示的可执行文件的类或接口的 Class对象。
      Class<?> Field.getDeclaringClass​()
      返回 Class表示声明此表示的字段的类或接口对象 Field对象。
      Class<?> Member.getDeclaringClass​()
      返回表示声明该成员表示的成员或构造函数的类或接口的Class对象。
      Class<?> Method.getDeclaringClass​()
      返回表示由该对象表示的方法的类或接口的 Class对象。
      Class<?>[] Constructor.getExceptionTypes​()
      返回一个 Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。
      abstract Class<?>[] Executable.getExceptionTypes​()
      返回一个 Class对象的数组， Class表示由该对象表示的底层可执行文件抛出的异常类型。
      Class<?>[] Method.getExceptionTypes​()
      返回一个 Class对象的数组，表示由该对象表示的底层可执行文件抛出的异常类型。
      Class<?>[] Constructor.getParameterTypes​()
      返回一个 Class对象的数组， Class以声明顺序表示由该对象表示的可执行文件的形式参数类型。
      abstract Class<?>[] Executable.getParameterTypes​()
      返回一个 Class对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。
      Class<?>[] Method.getParameterTypes​()
      返回一个 Class对象的数组， Class以声明顺序表示由该对象表示的可执行文件的形式参数类型。
      static Class<?> Proxy.getProxyClass​(ClassLoader loader, Class<?>... interfaces)
      已过时。
      在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在不可访问的代理类上调用时抛出IllegalAccessException 。 请改用Proxy.newProxyInstance(ClassLoader, Class[], InvocationHandler)创建代理实例。
      Class<?> Method.getReturnType​()
      返回一个 Class对象，表示由该 方法对象表示的方法的正式返回类型。
      Class<?> Field.getType​()
      返回一个 Class对象，该对象标识由此 Field对象表示的字段的声明类型。
      Class<?> Parameter.getType​()
      返回一个 Class对象，用于标识由此 Parameter对象表示的参数的声明类型。
      Methods in java.lang.reflect with parameters of type Class
      Modifier and Type 方法 描述
      <T extends Annotation>
      T             		AccessibleObject.getAnnotation​(Class<T> annotationClass)
      <T extends Annotation>
      T             		AnnotatedElement.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Constructor.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Executable.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Field.getAnnotation​(Class<T> annotationClass)
      <T extends Annotation>
      T             		Method.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T             		Parameter.getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T[]             		AccessibleObject.getAnnotationsByType​(Class<T> annotationClass)
      default <T extends Annotation>
      T[]             		AnnotatedElement.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Executable.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Field.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T[]             		Parameter.getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T             		AccessibleObject.getDeclaredAnnotation​(Class<T> annotationClass)
      default <T extends Annotation>
      T             		AnnotatedElement.getDeclaredAnnotation​(Class<T> annotationClass)
      如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。
      <T extends Annotation>
      T             		Parameter.getDeclaredAnnotation​(Class<T> annotationClass)
      <T extends Annotation>
      T[]             		AccessibleObject.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      default <T extends Annotation>
      T[]             		AnnotatedElement.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      <T extends Annotation>
      T[]             		Parameter.getDeclaredAnnotationsByType​(Class<T> annotationClass)
      static Class<?> Proxy.getProxyClass​(ClassLoader loader, Class<?>... interfaces)
      已过时。
      在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在无法访问的代理类上调用时抛出IllegalAccessException 。 使用Proxy.newProxyInstance(ClassLoader, Class[], InvocationHandler)代替创建一个代理实例。
      boolean AccessibleObject.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      default boolean AnnotatedElement.isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      static boolean Proxy.isProxyClass​(Class<?> cl)
      如果给定的类是代理类，则返回true。
      static Object Array.newInstance​(Class<?> componentType, int length)
      创建具有指定组件类型和长度的新数组。
      static Object Array.newInstance​(Class<?> componentType, int... dimensions)
      创建具有指定组件类型和尺寸的新数组。
      static Object Proxy.newProxyInstance​(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
      返回指定接口的代理实例，该代理实例将方法调用分派给指定的调用处理程序。

    • Uses of Class in java.net

      Methods in java.net that return Class
      Modifier and Type 方法 描述
      protected Class<?> URLClassLoader.findClass​(String name)
      从URL搜索路径查找并加载具有指定名称的类。
      Class<T> SocketOption.type​()
      返回套接字选项值的类型。
      Methods in java.net with parameters of type Class
      Modifier and Type 方法 描述
      Object ContentHandler.getContent​(URLConnection urlc, Class[] classes)
      给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。
      Object URL.getContent​(Class<?>[] classes)
      获取此URL的内容。
      Object URLConnection.getContent​(Class<?>[] classes)
      检索此URL连接的内容。

    • Uses of Class in java.nio.file

      Methods in java.nio.file that return Class
      Modifier and Type 方法 描述
      Class<T> WatchEvent.Kind.type​()
      返回 context值的类型。
      Methods in java.nio.file with parameters of type Class
      Modifier and Type 方法 描述
      static <V extends FileAttributeView>
      V             		Files.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      <V extends FileAttributeView>
      V             		SecureDirectoryStream.getFileAttributeView​(Class<V> type)
      返回一个新的文件属性视图来访问此目录的文件属性。
      <V extends FileAttributeView>
      V             		SecureDirectoryStream.getFileAttributeView​(T path, Class<V> type, LinkOption... options)
      返回一个新的文件属性视图来访问此目录中文件的文件属性。
      abstract <V extends FileStoreAttributeView>
      V             		FileStore.getFileStoreAttributeView​(Class<V> type)
      返回给定类型的 FileStoreAttributeView 。
      static <A extends BasicFileAttributes>
      A             		Files.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。
      abstract boolean FileStore.supportsFileAttributeView​(Class<? extends FileAttributeView> type)
      告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。

    • Uses of Class in java.nio.file.spi

      Methods in java.nio.file.spi with parameters of type Class
      Modifier and Type 方法 描述
      abstract <V extends FileAttributeView>
      V             		FileSystemProvider.getFileAttributeView​(Path path, Class<V> type, LinkOption... options)
      返回给定类型的文件属性视图。
      abstract <A extends BasicFileAttributes>
      A             		FileSystemProvider.readAttributes​(Path path, Class<A> type, LinkOption... options)
      读取文件的属性作为批量操作。

    • Uses of Class in java.rmi.server

      Methods in java.rmi.server that return Class
      Modifier and Type 方法 描述
      Class<?> LoaderHandler.loadClass​(String name)
      已过时。
      没有替换
      Class<?> LoaderHandler.loadClass​(URL codebase, String name)
      已过时。
      没有替换
      static Class<?> RMIClassLoader.loadClass​(String name)
      已过时。
      代之以loadClass(String,String)法
      static Class<?> RMIClassLoader.loadClass​(String codebase, String name)
      从代码库URL路径加载一个类。
      static Class<?> RMIClassLoader.loadClass​(String codebase, String name, ClassLoader defaultLoader)
      从代码库URL路径加载类，可选地使用提供的加载程序。
      static Class<?> RMIClassLoader.loadClass​(URL codebase, String name)
      从代码库URL加载一个类。
      abstract Class<?> RMIClassLoaderSpi.loadClass​(String codebase, String name, ClassLoader defaultLoader)
       为贯彻
RMIClassLoader.loadClass(URL,String) ，
RMIClassLoader.loadClass(String,String) ，并
RMIClassLoader.loadClass(String,String,ClassLoader) 。
      static Class<?> RMIClassLoader.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      加载一个动态代理类（见Proxy ），它从代码库URL路径中实现一组与给定名称的接口。
      abstract Class<?> RMIClassLoaderSpi.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。
      Methods in java.rmi.server with parameters of type Class
      Modifier and Type 方法 描述
      static String RMIClassLoader.getClassAnnotation​(Class<?> cl)
      返回在编组给定类的对象时，RMI将用于注释类描述符的注释字符串（表示类定义的位置）。
      abstract String RMIClassLoaderSpi.getClassAnnotation​(Class<?> cl)
      提供 RMIClassLoader.getClassAnnotation(Class)的实现。

    • Uses of Class in java.security

      Methods in java.security that return Class
      Modifier and Type 方法 描述
      protected Class<?> SecureClassLoader.defineClass​(String name, byte[] b, int off, int len, CodeSource cs)
      将字节数组转换为类Class的实例，并具有可选的CodeSource。
      protected Class<?> SecureClassLoader.defineClass​(String name, ByteBuffer b, CodeSource cs)
      一个转换ByteBuffer成类的实例Class ，使用可选的CodeSource。
      Methods in java.security with parameters of type Class
      Modifier and Type 方法 描述
      boolean KeyStoreSpi.engineEntryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)
      确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
      protected abstract <T extends KeySpec>
      T             		KeyFactorySpi.engineGetKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      protected abstract <T extends AlgorithmParameterSpec>
      T             		AlgorithmParametersSpi.engineGetParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。
      boolean KeyStore.entryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)
      确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。
      <T extends KeySpec>
      T             		KeyFactory.getKeySpec​(Key key, Class<T> keySpec)
      返回给定键对象的规范（关键材料）。
      <T extends AlgorithmParameterSpec>
      T             		AlgorithmParameters.getParameterSpec​(Class<T> paramSpec)
      返回此参数对象的（透明）规范。

    • Uses of Class in java.sql

      Methods in java.sql that return types with arguments of type Class
      Modifier and Type 方法 描述
      Map<String,Class<?>> Connection.getTypeMap​()
      检索与该 Map对象关联的 Connection对象。
      Methods in java.sql with parameters of type Class
      Modifier and Type 方法 描述
      <T> T CallableStatement.getObject​(int parameterIndex, Class<T> type)
      返回表示OUT参数 parameterIndex的值的对象，如果支持转换，则将从参数的SQL类型转换为请求的Java数据类型。
      <T> T CallableStatement.getObject​(String parameterName, Class<T> type)
      返回表示OUT参数 parameterName的值的对象，并将转换为参数的SQL类型到所请求的Java数据类型，如果支持转换。
      <T> T ResultSet.getObject​(int columnIndex, Class<T> type)
      检索此 ResultSet对象的当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。
      <T> T ResultSet.getObject​(String columnLabel, Class<T> type)
      检索此 ResultSet对象的当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。
      <T extends Source>
      T             		SQLXML.getSource​(Class<T> sourceClass)
      返回一个用于读取此SQLXML实例指定的XML值的源。
      boolean Wrapper.isWrapperFor​(Class<?> iface)
      如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。
      default <T> T SQLInput.readObject​(Class<T> type)
      读取流中的下一个属性，并将其作为Java编程语言中的 Object返回。
      <T extends Result>
      T             		SQLXML.setResult​(Class<T> resultClass)
      返回一个用于设置此SQLXML实例指定的XML值的结果。
      <T> T Wrapper.unwrap​(Class<T> iface)
      返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。
      Method parameters in java.sql with type arguments of type Class
      Modifier and Type 方法 描述
      Object Array.getArray​(long index, int count, Map<String,Class<?>> map)
      检索由 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含高达 count SQL数组的连续元素。
      Object Array.getArray​(Map<String,Class<?>> map)
      检索此 Array对象指定的SQL ARRAY值的内容。
      Object[] Struct.getAttributes​(Map<String,Class<?>> map)
      产生此 Struct对象表示的SQL结构化类型的属性的有序值。
      Object CallableStatement.getObject​(int parameterIndex, Map<String,Class<?>> map)
      返回表示OUT参数 parameterIndex的值的对象，并使用参数值的自定义映射 map 。
      Object CallableStatement.getObject​(String parameterName, Map<String,Class<?>> map)
      返回表示OUT参数 parameterName的值的对象，并使用 map作为参数值的自定义映射。
      Object Ref.getObject​(Map<String,Class<?>> map)
      检索引用的对象，并使用给定的类型映射将其映射到Java类型。
      Object ResultSet.getObject​(int columnIndex, Map<String,Class<?>> map)
      以Java编程语言中的 Object此 ResultSet对象当前行中指定列的值。
      Object ResultSet.getObject​(String columnLabel, Map<String,Class<?>> map)
      以Java编程语言中的 Object此 ResultSet对象的当前行中指定列的值。
      ResultSet Array.getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索一个结果集，该结果集包含从索引 index开始的子阵列的元素，并包含最多 count连续元素。
      ResultSet Array.getResultSet​(Map<String,Class<?>> map)
      检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。
      void Connection.setTypeMap​(Map<String,Class<?>> map)
      安装给定 TypeMap对象的类型映射此 Connection对象。

    • Uses of Class in java.util

      Methods in java.util that return Class
      Modifier and Type 方法 描述
      Class<?> IllegalFormatConversionException.getArgumentClass​()
      返回不匹配参数的类。
      Class<? extends S> ServiceLoader.Provider.type​()
      返回提供者类型。
      Methods in java.util with parameters of type Class
      Modifier and Type 方法 描述
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.allOf​(Class<E> elementType)
      创建一个包含指定元素类型中所有元素的枚举集。
      static <E> Collection<E> Collections.checkedCollection​(Collection<E> c, Class<E> type)
      返回指定集合的动态类型安全视图。
      static <E> List<E> Collections.checkedList​(List<E> list, Class<E> type)
      返回指定列表的动态类型安全视图。
      static <K,V> Map<K,V> Collections.checkedMap​(Map<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定地图的动态类型安全视图。
      static <K,V> NavigableMap<K,V> Collections.checkedNavigableMap​(NavigableMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定可导航地图的动态类型安全视图。
      static <E> NavigableSet<E> Collections.checkedNavigableSet​(NavigableSet<E> s, Class<E> type)
      返回指定的可导航集的动态类型安全视图。
      static <E> Queue<E> Collections.checkedQueue​(Queue<E> queue, Class<E> type)
      返回指定队列的动态类型安全视图。
      static <E> Set<E> Collections.checkedSet​(Set<E> s, Class<E> type)
      返回指定集合的动态类型安全视图。
      static <K,V> SortedMap<K,V> Collections.checkedSortedMap​(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
      返回指定排序映射的动态类型安全视图。
      static <E> SortedSet<E> Collections.checkedSortedSet​(SortedSet<E> s, Class<E> type)
      返回指定排序集的动态类型安全视图。
      static <T,U> T[] Arrays.copyOf​(U[] original, int newLength, Class<? extends T[]> newType)
      复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。
      static <T,U> T[] Arrays.copyOfRange​(U[] original, int from, int to, Class<? extends T[]> newType)
      将指定数组的指定范围复制到新数组中。
      static <S> ServiceLoader<S> ServiceLoader.load​(Class<S> service)
      使用当前线程的 context class loader为给定的服务类型创建一个新的服务加载器。
      static <S> ServiceLoader<S> ServiceLoader.load​(Class<S> service, ClassLoader loader)
      为给定的服务创建一个新的服务加载器。
      static <S> ServiceLoader<S> ServiceLoader.load​(ModuleLayer layer, Class<S> service)
      为给定的服务类型创建新的服务加载器，以便从给定模块层及其祖先的模块加载服务提供者。
      static <S> ServiceLoader<S> ServiceLoader.loadInstalled​(Class<S> service)
      使用 platform class loader为给定的服务类型创建一个新的服务加载程序。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.noneOf​(Class<E> elementType)
      使用指定的元素类型创建一个空的枚举集。
      Constructors in java.util with parameters of type Class
      Constructor 描述
      EnumMap​(Class<K> keyType)
      使用指定的键类型创建一个空的枚举映射。
      IllegalFormatConversionException​(char c, Class<?> arg)
      使用不匹配的转换和相应的参数类构造此类的实例。

    • Uses of Class in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with parameters of type Class
      Modifier and Type 方法 描述
      static <U> AtomicIntegerFieldUpdater<U> AtomicIntegerFieldUpdater.newUpdater​(Class<U> tclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
      static <U> AtomicLongFieldUpdater<U> AtomicLongFieldUpdater.newUpdater​(Class<U> tclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。
      static <U,W> AtomicReferenceFieldUpdater<U,W> AtomicReferenceFieldUpdater.newUpdater​(Class<U> tclass, Class<W> vclass, String fieldName)
      创建并返回具有给定字段的对象的更新程序。

    • Uses of Class in java.util.prefs

      Methods in java.util.prefs with parameters of type Class
      Modifier and Type 方法 描述
      static Preferences Preferences.systemNodeForPackage​(Class<?> c)
      从与指定类的包关联（按照约定）的系统首选项树返回首选项节点。
      static Preferences Preferences.userNodeForPackage​(Class<?> c)
      从调用用户的偏好树中返回偏好节点，该树通过指定的类的包（与约定）相关联。

    • Uses of Class in javafx.application

      Methods in javafx.application with parameters of type Class
      Modifier and Type 方法 描述
      static void Application.launch​(Class<? extends Application> appClass, String... args)
      启动独立应用程序。

    • Uses of Class in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter with parameters of type Class
      Modifier and Type 方法 描述
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter和setter的Java Bean类。
      ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。
      ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.beanClass​(Class<?> beanClass)
      设置要在其中搜索getter的Java Bean类。

    • Uses of Class in javafx.collections

      Methods in javafx.collections with parameters of type Class
      Modifier and Type 方法 描述
      static <E> ObservableList<E> FXCollections.checkedObservableList​(ObservableList<E> list, Class<E> type)
      在提供的可观察列表之上创建并返回一个类型安全的包装器。
      static <K,V> ObservableMap<K,V> FXCollections.checkedObservableMap​(ObservableMap<K,V> map, Class<K> keyType, Class<V> valueType)
      在提供的可观察地图的顶部创建并返回类型安全的包装器。
      static <E> ObservableSet<E> FXCollections.checkedObservableSet​(ObservableSet<E> set, Class<E> type)
      在提供的可观察集之上创建并返回一个类型安全的包装器。

    • Uses of Class in javafx.css

      Methods in javafx.css with parameters of type Class
      Modifier and Type 方法 描述
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，枚举>，并继承标志。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Class<E> enumClass)
      创建一个StyleableProperty <E使用以前创建的给定的 cssProperty扩展枚举<E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass)
      创建一个StyleableProperty <E extends Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue)
      创建一个StyleableProperty <E使用初始值扩展Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue, boolean inherits)
      创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。
      static <E extends Enum<E>>
      StyleConverter<String,? extends Enum<?>>             		StyleConverter.getEnumConverter​(Class<E> enumClass)
      返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。

    • Uses of Class in javafx.css.converter

      Constructors in javafx.css.converter with parameters of type Class
      Constructor 描述
      EnumConverter​(Class<E> enumClass)

    • Uses of Class in javafx.fxml

      Methods in javafx.fxml that return Class
      Modifier and Type 方法 描述
      static Class<?> FXMLLoader.loadType​(String className)
      已过时。
      此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
      static Class<?> FXMLLoader.loadType​(String packageName, String className)
      已过时。
      此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
      Methods in javafx.fxml that return types with arguments of type Class
      Modifier and Type 方法 描述
      Callback<Class<?>,Object> FXMLLoader.getControllerFactory​()
      返回此装载器使用的控制器工厂。
      Methods in javafx.fxml with parameters of type Class
      Modifier and Type 方法 描述
      void LoadListener.beginInstanceDeclarationElement​(Class<?> type)
      当加载程序开始读取实例声明元素时调用。
      void LoadListener.beginPropertyElement​(String name, Class<?> sourceType)
      当加载程序开始读取属性元素时调用。
      Builder<?> JavaFXBuilderFactory.getBuilder​(Class<?> type)
      返回指定类型的构建器，如果不使用构建器，则返回null。
      void LoadListener.readPropertyAttribute​(String name, Class<?> sourceType, String value)
      加载程序读取属性属性时调用。
      Method parameters in javafx.fxml with type arguments of type Class
      Modifier and Type 方法 描述
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      从FXML文档加载对象层次结构。
      static <T> T FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      从FXML文档加载对象层次结构。
      void FXMLLoader.setControllerFactory​(Callback<Class<?>,Object> controllerFactory)
      设置此装载机使用的控制器工厂。
      Constructor parameters in javafx.fxml with type arguments of type Class
      Constructor 描述
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)
      创建一个新的FXMLLoader实例。
      FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)
      创建一个新的FXMLLoader实例。

    • Uses of Class in javafx.scene

      Methods in javafx.scene that return Class
      Modifier and Type | 方法 | 描述
      Class<?> | AccessibleAttribute.getReturnType​()

    • Uses of Class in javafx.util

      Methods in javafx.util with parameters of type Class
      Modifier and Type 方法 描述
      Builder<?> BuilderFactory.getBuilder​(Class<?> type)
      返回适用于构造给定类型实例的构建器。

    • Uses of Class in javax.activation

      Methods in javax.activation that return Class
      Modifier and Type 方法 描述
      Class ActivationDataFlavor.getRepresentationClass​()
      返回代表类。
      Constructors in javax.activation with parameters of type Class
      Constructor 描述
      ActivationDataFlavor​(Class representationClass, String humanPresentableName)
      构造一个表示MimeType的DataFlavor。
      ActivationDataFlavor​(Class representationClass, String mimeType, String humanPresentableName)
      构造一个表示任意Java对象的DataFlavor。

    • Uses of Class in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type Class
      Modifier and Type 方法 描述
      Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith​(Class<? extends Annotation> a)
      返回使用给定注释类型注释的元素。
      Method parameters in javax.annotation.processing with type arguments of type Class
      Modifier and Type 方法 描述
      default Set<? extends Element> RoundEnvironment.getElementsAnnotatedWithAny​(Set<Class<? extends Annotation>> annotations)
      返回使用一个或多个给定注释类型注释的元素。

    • Uses of Class in javax.crypto

      Methods in javax.crypto with parameters of type Class
      Modifier and Type 方法 描述
      protected abstract KeySpec SecretKeyFactorySpi.engineGetKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。
      KeySpec SecretKeyFactory.getKeySpec​(SecretKey key, Class<?> keySpec)
      以请求的格式返回给定键对象的规范（关键材料）。

    • Uses of Class in javax.imageio.metadata

      Methods in javax.imageio.metadata that return Class
      Modifier and Type | 方法 | 描述
      Class<?> IIOMetadataFormat.getObjectClass​(String elementName)
      返回存储在元素中的 Object参考的 Class类型。
      Class<?> | IIOMetadataFormatImpl.getObjectClass​(String elementName)
      Methods in javax.imageio.metadata with parameters of type Class
      Modifier and Type 方法 描述
      protected void IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)
      允许 Object定类类型的引用存储在实现命名元素的节点中。
      protected <T> void IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, boolean required, T defaultValue)
      允许 Object定类类型的引用存储在实现命名元素的节点中。
      protected <T> void IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
      允许 Object要被存储在实现指定元素的节点给定类型的参考。
      protected <T extends Object & Comparable<? super T>>
      void             		IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
      允许给定类类型的 Object引用存储在实现命名元素的节点中。

    • Uses of Class in javax.imageio.spi

      Fields in javax.imageio.spi declared as Class
      Modifier and Type Field 描述
      protected Class<?> ImageInputStreamSpi.inputClass
      一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。
      protected Class<?>[] ImageReaderSpi.inputTypes
      一个 Class对象的数组从 getInputTypes返回，最初为 null 。
      protected Class<?> ImageOutputStreamSpi.outputClass
      一个 Class对象，指示 createInputStreamInstance方法使用的合法对象类型。
      protected Class<?>[] ImageWriterSpi.outputTypes
      一组 Class对象从 getOutputTypes返回，最初为 null 。
      static Class<?>[] ImageReaderSpi.STANDARD_INPUT_TYPE
      已过时。
      而不是使用这个字段，直接创建等效的数组{ ImageInputStream.class } 。
      static Class<?>[] ImageWriterSpi.STANDARD_OUTPUT_TYPE
      已过时。
      而不是使用这个字段，直接创建等效的数组{ ImageOutputStream.class } 。
      Methods in javax.imageio.spi that return Class
      Modifier and Type 方法 描述
      Class<?> ImageInputStreamSpi.getInputClass​()
      返回一个 Class表示必须由输入源，以便被实现为“包装”在的类或接口类型的对象 ImageInputStream经由 createInputStreamInstance方法。
      Class<?>[] ImageReaderSpi.getInputTypes​()
      返回一个 Class对象的数组，指示可以使用什么类型的对象作为读者 setInput方法的参数。
      Class<?> ImageOutputStreamSpi.getOutputClass​()
      返回一个 Class表示必须由输出目的地，以便被实现为“包装”在的类或接口类型的对象 ImageOutputStream经由 createOutputStreamInstance方法。
      Class<?>[] ImageWriterSpi.getOutputTypes​()
      返回一个 Class对象的数组，指示可以使用什么类型的对象作为撰写者的 setOutput方法的参数。
      Methods in javax.imageio.spi that return types with arguments of type Class
      Modifier and Type 方法 描述
      Iterator<Class<?>> ServiceRegistry.getCategories​()
      返回 Iterator的 Class对象，指示当前的类别集。
      Methods in javax.imageio.spi with parameters of type Class
      Modifier and Type 方法 描述
      void ServiceRegistry.deregisterAll​(Class<?> category)
      取消注册目前在给定类别下注册的所有服务提供商对象。
      <T> boolean ServiceRegistry.deregisterServiceProvider​(T provider, Class<T> category)
      从给定的类别中删除服务提供者对象。
      <T> T ServiceRegistry.getServiceProviderByClass​(Class<T> providerClass)
      返回给定类类型的当前注册的服务提供者对象。
      <T> Iterator<T> ServiceRegistry.getServiceProviders​(Class<T> category, boolean useOrdering)
      返回包含给定类别中的所有注册服务提供商的 Iterator 。
      <T> Iterator<T> ServiceRegistry.getServiceProviders​(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
      返回 Iterator一个给定类别中满足由所提供的定义的条件的含服务提供程序对象 ServiceRegistry.Filter对象的 filter方法。
      static <T> Iterator<T> ServiceRegistry.lookupProviders​(Class<T> providerClass)
      使用上下文类加载器定位并递增实例化给定服务的可用提供程序。
      static <T> Iterator<T> ServiceRegistry.lookupProviders​(Class<T> providerClass, ClassLoader loader)
      使用给定的类加载器搜索特定服务类的实现。
      void IIOServiceProvider.onDeregistration​(ServiceRegistry registry, Class<?> category)
      每当Spi课程从 ServiceRegistry注销时，这个 ServiceRegistry 。
      void RegisterableService.onDeregistration​(ServiceRegistry registry, Class<?> category)
      当实现该接口的对象从给定的删除称为 category给定的 registry 。
      void IIOServiceProvider.onRegistration​(ServiceRegistry registry, Class<?> category)
      在Spi类被实例化并注册在 ServiceRegistry之后，将被调用一次的 ServiceRegistry 。
      void RegisterableService.onRegistration​(ServiceRegistry registry, Class<?> category)
      当将实现此接口的对象添加到给定的 category的给定 registry 。
      <T> boolean ServiceRegistry.registerServiceProvider​(T provider, Class<T> category)
      将服务提供者对象添加到注册表。
      <T> boolean ServiceRegistry.setOrdering​(Class<T> category, T firstProvider, T secondProvider)
      在给定类别中的两个服务提供者对象之间设置成对排序。
      <T> boolean ServiceRegistry.unsetOrdering​(Class<T> category, T firstProvider, T secondProvider)
      在给定类别中的两个服务提供者对象之间设置成对排序。
      Constructors in javax.imageio.spi with parameters of type Class
      Constructor 描述
      ImageInputStreamSpi​(String vendorName, String version, Class<?> inputClass)
      构造一个给定值的一个 ImageInputStreamSpi 。
      ImageOutputStreamSpi​(String vendorName, String version, Class<?> outputClass)
      构造一个给定值的一个 ImageOutputStreamSpi 。
      ImageReaderSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class<?>[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
      构造一个给定值的一个 ImageReaderSpi 。
      ImageWriterSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class<?>[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
      构造一个给定值的一个 ImageWriterSpi 。
      Constructor parameters in javax.imageio.spi with type arguments of type Class
      Constructor 描述
      ServiceRegistry​(Iterator<Class<?>> categories)
      构造一个 ServiceRegistry实例，其中包含一组从 categories参数中获取的类别。

    • Uses of Class in javax.lang.model

      Methods in javax.lang.model with parameters of type Class
      Modifier and Type 方法 描述
      <A extends Annotation>
      A             		AnnotatedConstruct.getAnnotation​(Class<A> annotationType)
      返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。
      <A extends Annotation>
      A[]             		AnnotatedConstruct.getAnnotationsByType​(Class<A> annotationType)
      返回与此构造 关联的注释。

    • Uses of Class in javax.lang.model.element

      Methods in javax.lang.model.element with parameters of type Class
      Modifier and Type 方法 描述
      <A extends Annotation>
      A             		Element.getAnnotation​(Class<A> annotationType)
      返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。

    • Uses of Class in javax.management

      Methods in javax.management that return Class
      Modifier and Type 方法 描述
      Class<?> StandardMBean.getImplementationClass​()
      获取此标准MBean（或MXBean）的实现类。
      Class<?> StandardMBean.getMBeanInterface​()
      获取此标准MBean（或MXBean）的管理界面。
      static Class<?> DefaultLoaderRepository.loadClass​(String className)
      已过时。
      浏览类加载器列表，并尝试加载所请求的类。
      static Class<?> DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)
      已过时。
      通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。
      Methods in javax.management with parameters of type Class
      Modifier and Type 方法 描述
      static boolean JMX.isMXBeanInterface​(Class<?> interfaceClass)
      测试接口是否是MXBean接口。
      static <T> T JMX.newMBeanProxy​(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
      在本地或远程MBean服务器中为标准MBean创建代理。
      static <T> T JMX.newMBeanProxy​(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationEmitter)
      为本地或远程MBean服务器中的标准MBean进行代理，该服务器也可能支持NotificationEmitter的方法。
      static <T> T JMX.newMXBeanProxy​(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
      在本地或远程MBean服务器中为MXBean创建代理。
      static <T> T JMX.newMXBeanProxy​(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationEmitter)
      在本地或远程MBean服务器中为MXBean创建代理，该服务器也可能支持NotificationEmitter的方法。
      static <T> T MBeanServerInvocationHandler.newProxyInstance​(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
      通过将其方法通过给定的MBean服务器转发到指定的MBean来返回实现给定接口的代理。
      Constructors in javax.management with parameters of type Class
      Constructor 描述
      StandardEmitterMBean​(Class<?> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
      制作一个MBean，其管理界面由 mbeanInterface指定，通知由给定的 NotificationEmitter处理。
      StandardEmitterMBean​(Class<?> mbeanInterface, NotificationEmitter emitter)
      制作一个MBean，其管理界面由 mbeanInterface指定，通知由给定的 NotificationEmitter处理。
      StandardEmitterMBean​(T implementation, Class<T> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
      制作一个MBean，其管理界面由 mbeanInterface指定，给定的实现和通知由给定的 NotificationEmitter处理。
      StandardEmitterMBean​(T implementation, Class<T> mbeanInterface, NotificationEmitter emitter)
      制作一个MBean，其管理界面由 mbeanInterface指定，给定的实现和通知由给定的 NotificationEmitter处理。
      StandardMBean​(Class<?> mbeanInterface)
      做一个DynamicMBean的出 这一点 ，使用指定的 mbeanInterface类。
      StandardMBean​(Class<?> mbeanInterface, boolean isMXBean)
      做一个DynamicMBean的出 这一点 ，使用指定的 mbeanInterface类，并选择所产生的MBean是一个MXBean。
      StandardMBean​(T implementation, Class<T> mbeanInterface)
      使用指定的 mbeanInterface类，从对象 实现中创建一个DynamicMBean。
      StandardMBean​(T implementation, Class<T> mbeanInterface, boolean isMXBean)
      使用指定的 mbeanInterface类，并选择生成的MBean是否为MXBean，从对象 实现中创建一个DynamicMBean。

    • Uses of Class in javax.management.loading

      Methods in javax.management.loading that return Class
      Modifier and Type 方法 描述
      protected Class<?> MLet.findClass​(String name)
      这是正在重新定义的类加载器的主要方法。
      Class<?> ClassLoaderRepository.loadClass​(String className)
      通过类加载器列表加载给定的类名。
      static Class<?> DefaultLoaderRepository.loadClass​(String className)
      已过时。
      浏览类加载器列表，并尝试加载所请求的类。
      Class<?> MLet.loadClass​(String name, ClassLoaderRepository clr)
      加载一个类，使用给定的ClassLoaderRepository，如果该类没有在这个MLet的URL中找到。
      Class<?> ClassLoaderRepository.loadClassBefore​(ClassLoader stop, String className)
      通过加载器列表加载给定的类名，停止在给定的类名称。
      Class<?> ClassLoaderRepository.loadClassWithout​(ClassLoader exclude, String className)
      通过类加载器列表加载给定的类名，不包括给定的类名。
      static Class<?> DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)
      已过时。
      通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。

    • Uses of Class in javax.management.openmbean

      Methods in javax.management.openmbean with parameters of type Class
      Modifier and Type 方法 描述
      static <T> ArrayType<T> ArrayType.getPrimitiveArrayType​(Class<T> arrayClass)
      以类型安全的方式创建一个 ArrayType实例。

    • Uses of Class in javax.naming.spi

      Methods in javax.naming.spi with parameters of type Class
      Modifier and Type 方法 描述
      ResolveResult Resolver.resolveToClass​(String name, Class<? extends Context> contextType)
      部分解决名称。
      ResolveResult Resolver.resolveToClass​(Name name, Class<? extends Context> contextType)
      部分解决名称。

    • Uses of Class in javax.print

      Methods in javax.print that return Class
      Modifier and Type 方法 描述
      Class<?>[] PrintService.getSupportedAttributeCategories​()
      确定在为此打印服务设置作业时客户端可以指定的打印属性类别。
      Class<?>[] AttributeException.getUnsupportedAttributes​()
      返回Print Service实例根本不支持该属性的打印属性类的数组，如果没有这样的属性，则返回null。
      Methods in javax.print with parameters of type Class
      Modifier and Type 方法 描述
      <T extends PrintServiceAttribute>
      T             		PrintService.getAttribute​(Class<T> category)
      获取单个指定服务属性的值。
      Object PrintService.getDefaultAttributeValue​(Class<? extends Attribute> category)
      确定此打印服务在给定类别中的默认打印属性值。
      Object PrintService.getSupportedAttributeValues​(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
      确定为此打印服务设置作业时客户端可以在给定类别中指定的打印属性值。
      boolean PrintService.isAttributeCategorySupported​(Class<? extends Attribute> category)
      确定在为此打印服务设置作业时，客户端是否可以指定给定的打印属性类别。

    • Uses of Class in javax.print.attribute

      Methods in javax.print.attribute that return Class
      Modifier and Type 方法 描述
      Class<? extends Attribute> Attribute.getCategory​()
      当打印属性值添加到属性集中时，获取打印属性类，该属性类将用作此打印属性值的“类别”。
      static Class<?> AttributeSetUtilities.verifyAttributeCategory​(Object object, Class<?> interfaceName)
      验证给定对象是否是实现给定接口的Class ，该接口假定为接口Attribute或其子接口。
      Methods in javax.print.attribute with parameters of type Class
      Modifier and Type 方法 描述
      boolean AttributeSet.containsKey​(Class<?> category)
      如果此属性集包含指定类别的属性，则返回 true 。
      boolean HashAttributeSet.containsKey​(Class<?> category)
      如果此属性集包含指定类别的属性，则返回 true 。
      Attribute AttributeSet.get​(Class<?> category)
      返回此属性集在给定属性类别中包含的属性值。
      Attribute HashAttributeSet.get​(Class<?> category)
      返回此属性集在给定属性类别中包含的属性值。
      boolean AttributeSet.remove​(Class<?> category)
      从此属性集中删除此类别的任何属性（如果存在）。
      boolean HashAttributeSet.remove​(Class<?> category)
      从此属性集中删除此类别的任何属性（如果存在）。
      static Class<?> AttributeSetUtilities.verifyAttributeCategory​(Object object, Class<?> interfaceName)
      验证给定的对象是实现给定接口的Class ，该接口假定为接口Attribute或其子接口。
      static Attribute AttributeSetUtilities.verifyAttributeValue​(Object object, Class<?> interfaceName)
      验证给定对象是给定接口的一个实例，它被假定为接口Attribute或其子接口。
      static void AttributeSetUtilities.verifyCategoryForValue​(Class<?> category, Attribute attribute)
      验证给定的属性类别对象是否等于给定属性值对象的类别。
      Constructors in javax.print.attribute with parameters of type Class
      Constructor 描述
      HashAttributeSet​(Class<?> interfaceName)
      构造一个新的空属性集，其中属性集的成员被限制到给定的接口。
      HashAttributeSet​(Attribute[] attributes, Class<?> interfaceName)
      构造一个新的属性集，其中属性集的成员被限制到给定的接口。
      HashAttributeSet​(Attribute attribute, Class<?> interfaceName)
      构造一个新的属性集，最初用给定的属性填充，属性集的成员被限制到给定的接口。
      HashAttributeSet​(AttributeSet attributes, Class<?> interfaceName)
      构造一个新的属性集，最初使用给定集合中的值进行填充，其中属性集的成员被限制到给定的接口。

    • Uses of Class in javax.print.attribute.standard

      Methods in javax.print.attribute.standard that return Class
      Modifier and Type 方法 描述
      Class<? extends Attribute> Chromaticity.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> ColorSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Compression.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Copies.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> CopiesSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> DateTimeAtCompleted.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> DateTimeAtCreation.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> DateTimeAtProcessing.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Destination.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> DialogTypeSelection.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> DocumentName.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Fidelity.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Finishings.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobHoldUntil.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobImpressions.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobImpressionsCompleted.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobImpressionsSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobKOctets.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobKOctetsProcessed.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobKOctetsSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobMediaSheets.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobMediaSheetsCompleted.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobMediaSheetsSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobMessageFromOperator.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobName.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobOriginatingUserName.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobPriority.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobPrioritySupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobSheets.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobState.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobStateReason.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> JobStateReasons.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Media.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> MediaPrintableArea.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> MediaSize.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> MultipleDocumentHandling.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> NumberOfDocuments.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> NumberOfInterveningJobs.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> NumberUp.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> NumberUpSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> OrientationRequested.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> OutputDeviceAssigned.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PageRanges.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PagesPerMinute.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PagesPerMinuteColor.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PDLOverrideSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PresentationDirection.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterInfo.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterIsAcceptingJobs.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterLocation.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterMakeAndModel.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterMessageFromOperator.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterMoreInfo.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterMoreInfoManufacturer.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterName.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterResolution.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterState.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterStateReason.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterStateReasons.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrinterURI.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> PrintQuality.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> QueuedJobCount.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> ReferenceUriSchemesSupported.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> RequestingUserName.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Severity.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> SheetCollate.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。
      Class<? extends Attribute> Sides.getCategory​()
      获取要用作此打印属性值的“类别”的打印属性类。

    • Uses of Class in javax.rmi

      Methods in javax.rmi with parameters of type Class
      Modifier and Type 方法 描述
      static Object PortableRemoteObject.narrow​(Object narrowFrom, Class narrowTo)
      检查以确保远程或抽象接口类型的对象可以转换为所需类型。

    • Uses of Class in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return Class
      Modifier and Type 方法 描述
      static Class Util.loadClass​(String className, String remoteCodebase, ClassLoader loader)
      返回指定类的类实例。
      Class UtilDelegate.loadClass​(String className, String remoteCodebase, ClassLoader loader)
      代表团要求 Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 。
      Methods in javax.rmi.CORBA with parameters of type Class
      Modifier and Type 方法 描述
      static String Util.getCodebase​(Class clz)
      返回给定类的代码库（如果有）。
      String UtilDelegate.getCodebase​(Class clz)
      代表团要求 Util.getCodebase(java.lang.Class) 。
      String ValueHandler.getRMIRepositoryID​(Class clz)
      返回给定Java类的CORBA RepositoryId。
      boolean ValueHandler.isCustomMarshaled​(Class clz)
      指示给定的类是执行自定义还是默认编组。
      Object PortableRemoteObjectDelegate.narrow​(Object narrowFrom, Class narrowTo)
      代表团要求 PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 。
      Serializable ValueHandler.readValue​(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
      使用Java语义从流读取值。

    • Uses of Class in javax.script

      Methods in javax.script with parameters of type Class
      Modifier and Type 方法 描述
      <T> T Invocable.getInterface​(Class<T> clasz)
      使用在解释器中编译的函数返回接口的实现。
      <T> T Invocable.getInterface​(Object thiz, Class<T> clasz)
      使用解释器中编译的脚本对象的成员函数返回接口的实现。

    • Uses of Class in javax.security.auth

      Methods in javax.security.auth with parameters of type Class
      Modifier and Type 方法 描述
      <T extends Principal>
      Set<T>             		Subject.getPrincipals​(Class<T> c)
      返回 Set与此关联的Principal Subject是实例或指定的子类 Class 。
      <T> Set<T> Subject.getPrivateCredentials​(Class<T> c)
      返回一个 Set与此相关的私有证书 Subject是实例或指定的子类 Class 。
      <T> Set<T> Subject.getPublicCredentials​(Class<T> c)
      返回一个 Set与此相关的公开证书 Subject是实例或指定的子类 Class 。

    • Uses of Class in javax.sound.midi

      Methods in javax.sound.midi that return Class
      Modifier and Type 方法 描述
      Class<?> SoundbankResource.getDataClass​()
      获取此样本用于表示其数据的类。
      Constructors in javax.sound.midi with parameters of type Class
      Constructor 描述
      Instrument​(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
      从指定的 Patch构建一个新的MIDI乐器。
      SoundbankResource​(Soundbank soundBank, String name, Class<?> dataClass)
      从给定的声音库和波表指数构建一个新的 SoundbankResource 。

    • Uses of Class in javax.sound.sampled

      Methods in javax.sound.sampled that return Class
      Modifier and Type 方法 描述
      Class<?> Line.Info.getLineClass​()
      获取此Line.Info对象描述的行的类。
      Constructors in javax.sound.sampled with parameters of type Class
      Constructor 描述
      Info​(Class<?> lineClass, AudioFormat format)
      根据指定的信息构建数据行的信息对象，其中包含单个音频格式。
      Info​(Class<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
      根据指定的信息构建数据行的信息对象，其中包括一组支持的音频格式和缓冲区大小的范围。
      Info​(Class<?> lineClass, AudioFormat format, int bufferSize)
      从指定的信息构建数据行的信息对象，其中包含单个音频格式和所需的缓冲区大小。
      Info​(Class<?> lineClass)
      构造一个描述指定类的行的信息对象。
      Info​(Class<?> lineClass, String name, boolean isSource)
      根据给出的信息构造端口的信息对象。

    • Uses of Class in javax.sql

      Methods in javax.sql that return types with arguments of type Class
      Modifier and Type 方法 描述
      Map<String,Class<?>> RowSet.getTypeMap​()
      检索与此 Map对象关联的 RowSet对象，该对象指定SQL用户定义类型的自定义映射（如果有）。
      Method parameters in javax.sql with type arguments of type Class
      Modifier and Type 方法 描述
      void RowSet.setTypeMap​(Map<String,Class<?>> map)
      安装给定 java.util.Map对象的默认类型映射此 RowSet对象。

    • Uses of Class in javax.sql.rowset

      Methods in javax.sql.rowset that return types with arguments of type Class
      Modifier and Type 方法 描述
      Map<String,Class<?>> BaseRowSet.getTypeMap​()
      检索与该关联的类型映射 Connection对象此 RowSet对象。
      Methods in javax.sql.rowset with parameters of type Class
      Modifier and Type 方法 描述
      boolean RowSetMetaDataImpl.isWrapperFor​(Class<?> interfaces)
      如果这实现了接口参数，或者直接或间接地为一个对象的包装器返回true。
      <T> T RowSetMetaDataImpl.unwrap​(Class<T> iface)
      返回一个实现给定接口以允许访问非标准方法的对象，或代理不公开的标准方法。
      Method parameters in javax.sql.rowset with type arguments of type Class
      Modifier and Type 方法 描述
      void BaseRowSet.setTypeMap​(Map<String,Class<?>> map)
      安装给定 java.util.Map对象作为与相关联的类型映射 Connection对象此 RowSet对象。

    • Uses of Class in javax.sql.rowset.serial

      Method parameters in javax.sql.rowset.serial with type arguments of type Class
      Modifier and Type 方法 描述
      Object SerialArray.getArray​(long index, int count, Map<String,Class<?>> map)
      返回一个新数组，该数组是该 SerialArray对象的一个片段的副本，从给定索引处的元素开始，并包含给定数量的连续元素。
      Object SerialArray.getArray​(Map<String,Class<?>> map)
      返回一个新数组，该数组是 SerialArray对象的副本，当元素为SQL UDT时，使用给定的类型映射来定位每个元素的映射。
      Object[] SerialStruct.getAttributes​(Map<String,Class<?>> map)
      检索，该SQL结构类型的属性 SerialStruct表示作为阵列 Object值，使用给定类型的地图为如果合适的定制映射。
      Object SerialRef.getObject​(Map<String,Class<?>> map)
      返回 Object表示对此的SQL结构类型 SerialRef对象引用。
      ResultSet SerialArray.getResultSet​(long index, int count, Map<String,Class<?>> map)
      检索设置保持其开始于检索所述子阵列的元素的结果 ResultSet对象，其中包含在该元件的子阵列 SerialArray对象，开始于索引 指数和包含 count个连续元素。
      ResultSet SerialArray.getResultSet​(Map<String,Class<?>> map)
      检索 ResultSet对象，它包含所有的SQL的元件的 ARRAY由该表示值 SerialArray对象。
      Constructor parameters in javax.sql.rowset.serial with type arguments of type Class
      Constructor 描述
      SerialArray​(Array array, Map<String,Class<?>> map)
      从给定的 Array对象构造一个新的 SerialArray对象，当元素是SQL UDT时，使用给定的类型映射来定制每个元素的映射。
      SerialStruct​(SQLData in, Map<String,Class<?>> map)
      从给定的 SQLData对象构造一个 SerialStruct对象，使用给定的类型映射将其自定义映射到Java编程语言中的类。
      SerialStruct​(Struct in, Map<String,Class<?>> map)
      从给定的 Struct对象构造一个 SerialStruct对象，使用给定的 java.util.Map对象来自定义映射SQL结构类型或其任何属性是SQL结构化类型。
      SQLInputImpl​(Object[] attributes, Map<String,Class<?>> map)
      创建一个 SQLInputImpl对象，该对象使用给定的属性数组和给定的类型映射进行初始化。

    • Uses of Class in javax.swing

      Methods in javax.swing that return Class
      Modifier and Type 方法 描述
      Class<?> JTable.getColumnClass​(int column)
      返回列位置 column在视图中显示的列的类型。
      Class<? extends ComponentUI> UIDefaults.getUIClass​(String uiClassID)
      返回呈现此组件的L＆F类。
      Class<? extends ComponentUI> UIDefaults.getUIClass​(String uiClassID, ClassLoader uiClassLoader)
      get(uidClassID)的值必须是实现相应的 ComponentUI类的类的 String名称。
      Methods in javax.swing with parameters of type Class
      Modifier and Type 方法 描述
      static Container SwingUtilities.getAncestorOfClass​(Class<?> c, Component comp)
      在组件层次结构中搜索 comp以上的方便方法，并返回它找到的第 c类的第一个对象。
      TableCellEditor JTable.getDefaultEditor​(Class<?> columnClass)
      返回在 TableColumn未设置编辑器时使用的编辑器。
      TableCellRenderer JTable.getDefaultRenderer​(Class<?> columnClass)
      返回在 TableColumn未设置渲染器时要使用的单元格渲染器。
      <T extends EventListener>
      T[]             		AbstractListModel.getListeners​(Class<T> listenerType)
      返回此模型当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		AbstractSpinnerModel.getListeners​(Class<T> listenerType)
      返回添加到此模型的给定类型的所有侦听器的数组。
      <T extends EventListener>
      T[]             		DefaultBoundedRangeModel.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultButtonModel.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener s的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultListSelectionModel.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultSingleSelectionModel.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		JComponent.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组，此 JComponent 。
      <T extends EventListener>
      T[]             		Timer.getListeners​(Class<T> listenerType)
      返回此 Timer当前注册为 FooListener的所有对象的数组。
      static Object LookAndFeel.makeIcon​(Class<?> baseClass, String gifFile)
      创建并返回加载图像的 UIDefault.LazyValue 。
      void JTable.setDefaultEditor​(Class<?> columnClass, TableCellEditor editor)
      如果在 TableColumn没有设置编辑器，则设置要使用的默认单元格编辑器。
      void JTable.setDefaultRenderer​(Class<?> columnClass, TableCellRenderer renderer)
      如果在 TableColumn未设置渲染器，则设置要使用的默认单元格渲染器。

    • Uses of Class in javax.swing.event

      Methods in javax.swing.event with parameters of type Class
      Modifier and Type 方法 描述
      <T extends EventListener>
      void             		EventListenerList.add​(Class<T> t, T l)
      将侦听器添加为指定类型的侦听器。
      int EventListenerList.getListenerCount​(Class<?> t)
      返回此侦听器列表提供的类型的侦听器总数。
      <T extends EventListener>
      T[]             		EventListenerList.getListeners​(Class<T> t)
      返回给定类型的所有侦听器的数组。
      <T extends EventListener>
      void             		EventListenerList.remove​(Class<T> t, T l)
      将侦听器作为指定类型的侦听器删除。

    • Uses of Class in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type Class
      Modifier and Type 方法 描述
      void SynthLookAndFeel.load​(InputStream input, Class<?> resourceBase)
      载入 SynthStyle将使用的一组 SynthLookAndFeel 。

    • Uses of Class in javax.swing.table

      Methods in javax.swing.table that return Class
      Modifier and Type 方法 描述
      Class<?> AbstractTableModel.getColumnClass​(int columnIndex)
      无论 Object.class如何返回 columnIndex 。
      Class<?> TableModel.getColumnClass​(int columnIndex)
      返回列中所有单元格值的最具体的超类。
      Methods in javax.swing.table with parameters of type Class
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractTableModel.getListeners​(Class<T> listenerType)
      返回此 AbstractTableModel当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultTableColumnModel.getListeners​(Class<T> listenerType)
      返回此模型上当前注册为 FooListener的所有对象的数组。

    • Uses of Class in javax.swing.text

      Methods in javax.swing.text that return Class
      Modifier and Type 方法 描述
      Class<?> DefaultFormatter.getValueClass​()
      返回用于创建新对象的类。
      Methods in javax.swing.text with parameters of type Class
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		AbstractDocument.getListeners​(Class<T> listenerType)
      返回此文档当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultCaret.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener s的所有对象的数组。
      <T extends EventListener>
      T[]             		StyleContext.NamedStyle.getListeners​(Class<T> listenerType)
      返回添加到此模型的给定类型的所有侦听器的数组。
      void DefaultFormatter.setValueClass​(Class<?> valueClass)
      设置用于创建新对象的类。

    • Uses of Class in javax.swing.tree

      Methods in javax.swing.tree with parameters of type Class
      Modifier and Type 方法 描述
      <T extends EventListener>
      T[]             		DefaultTreeModel.getListeners​(Class<T> listenerType)
      返回此模型上当前注册为 FooListener的所有对象的数组。
      <T extends EventListener>
      T[]             		DefaultTreeSelectionModel.getListeners​(Class<T> listenerType)
      返回当前注册为 FooListener的所有对象的数组。

    • Uses of Class in javax.tools

      Methods in javax.tools with parameters of type Class
      Modifier and Type | 方法 | 描述
      <S> ServiceLoader<S> | ForwardingJavaFileManager.getServiceLoader​(JavaFileManager.Location location, Class<S> service)
      default <S> ServiceLoader<S> JavaFileManager.getServiceLoader​(JavaFileManager.Location location, Class<S> service)
      从给定位置获取特定服务类的服务加载程序。
      DocumentationTool.DocumentationTask DocumentationTool.getTask​(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      使用给定的组件和参数为文档任务创建未来。

    • Uses of Class in javax.xml.bind

      Fields in javax.xml.bind declared as Class
      Modifier and Type Field 描述
      protected Class<T> JAXBElement.declaredType
      Java数据类型绑定xml元素声明的类型。
      protected Class JAXBElement.scope
      表示此xml元素实例的xml元素声明的范围。
      Methods in javax.xml.bind that return Class
      Modifier and Type 方法 描述
      Class<T> JAXBElement.getDeclaredType​()
      返回xml元素声明的type属性的Java绑定。
      Class JAXBElement.getScope​()
      返回xml元素声明的范围。
      Methods in javax.xml.bind with parameters of type Class
      Modifier and Type 方法 描述
      <T> Binder<T> JAXBContext.createBinder​(Class<T> domType)
      创建可用于关联/就地解组/编组的 Binder对象。
      JAXBContext JAXBContextFactory.createContext​(Class<?>[] classesToBeBound, Map<String,?> properties)
      创建一个新的 JAXBContext类的实例。
      <A extends XmlAdapter>
      A             		Marshaller.getAdapter​(Class<A> type)
      获取与指定类型相关联的适配器。
      <A extends XmlAdapter>
      A             		Unmarshaller.getAdapter​(Class<A> type)
      获取与指定类型相关联的适配器。
      static JAXBContext JAXBContext.newInstance​(Class<?>... classesToBeBound)
      创建一个新的 JAXBContext类的实例。
      static JAXBContext JAXBContext.newInstance​(Class<?>[] classesToBeBound, Map<String,?> properties)
      创建一个 JAXBContext类的新实例。
      <A extends XmlAdapter>
      void             		Marshaller.setAdapter​(Class<A> type, A adapter)
      将配置的XmlAdapter实例与此编组相关联。
      <A extends XmlAdapter>
      void             		Unmarshaller.setAdapter​(Class<A> type, A adapter)
      将配置的XmlAdapter实例与此解组器相关联。
      abstract <T> JAXBElement<T> Binder.unmarshal​(XmlNode xmlNode, Class<T> declaredType)
      通过向JAXB对象树提供 declaredType解组XML根元素。
      static <T> T JAXB.unmarshal​(File xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      static <T> T JAXB.unmarshal​(InputStream xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      static <T> T JAXB.unmarshal​(Reader xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      static <T> T JAXB.unmarshal​(String xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      static <T> T JAXB.unmarshal​(URI xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      static <T> T JAXB.unmarshal​(URL xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      static <T> T JAXB.unmarshal​(Source xml, Class<T> type)
      从给定的XML输入中读取Java对象树。
      <T> JAXBElement<T> Unmarshaller.unmarshal​(XMLEventReader reader, Class<T> declaredType)
      将根元素解组到JAXB映射 declaredType并返回生成的内容树。
      <T> JAXBElement<T> Unmarshaller.unmarshal​(XMLStreamReader reader, Class<T> declaredType)
      将根元素解组到JAXB映射 declaredType并返回生成的内容树。
      <T> JAXBElement<T> Unmarshaller.unmarshal​(Source source, Class<T> declaredType)
      从 declaredType从指定的XML源解组XML数据，并返回生成的内容树。
      <T> JAXBElement<T> Unmarshaller.unmarshal​(Node node, Class<T> declaredType)
      通过JAXB映射 declaredType解组XML数据并返回结果内容树。
      Constructors in javax.xml.bind with parameters of type Class
      Constructor 描述
      JAXBElement​(QName name, Class<T> declaredType, Class scope, T value)
      构造一个xml元素实例。
      JAXBElement​(QName name, Class<T> declaredType, T value)
      构造一个xml元素实例。

    • Uses of Class in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type Class
      Modifier and Type | 方法 | 描述
      <A extends XmlAdapter>
      A             		AbstractMarshallerImpl.getAdapter​(Class<A> type)
      <A extends XmlAdapter>
      A             		AbstractUnmarshallerImpl.getAdapter​(Class<A> type)
      <A extends XmlAdapter>
      void             		AbstractMarshallerImpl.setAdapter​(Class<A> type, A adapter)
      <A extends XmlAdapter>
      void             		AbstractUnmarshallerImpl.setAdapter​(Class<A> type, A adapter)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal​(XMLEventReader reader, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal​(XMLStreamReader reader, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal​(Source source, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal​(Node node, Class<T> expectedType)

    • Uses of Class in javax.xml.ws

      Methods in javax.xml.ws with parameters of type Class
      Modifier and Type 方法 描述
      <T> Dispatch<T> Service.createDispatch​(QName portName, Class<T> type, Service.Mode mode)
      创建一个 Dispatch实例，供客户选择的对象使用。
      <T> Dispatch<T> Service.createDispatch​(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      创建一个 Dispatch实例，用于客户选择的对象。
      <T> Dispatch<T> Service.createDispatch​(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      创建一个 Dispatch实例，供客户选择的对象使用。
      <T extends EndpointReference>
      T             		BindingProvider.getEndpointReference​(Class<T> clazz)
      返回 EndpointReference与此相关 BindingProvider实例。
      abstract <T extends EndpointReference>
      T             		Endpoint.getEndpointReference​(Class<T> clazz, Element... referenceParameters)
      返回 EndpointReference与此相关 Endpoint实例。
      <T extends EndpointReference>
      T             		WebServiceContext.getEndpointReference​(Class<T> clazz, Element... referenceParameters)
      返回与此端点相关联的 EndpointReference 。
      <T> T EndpointReference.getPort​(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回代理。
      <T> T Service.getPort​(Class<T> serviceEndpointInterface)
      getPort方法返回代理。
      <T> T Service.getPort​(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回代理。
      <T> T Service.getPort​(QName portName, Class<T> serviceEndpointInterface)
      getPort方法返回代理。
      <T> T Service.getPort​(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回代理。
      <T> T Service.getPort​(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回一个代理。

    • Uses of Class in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Class
      Modifier and Type 方法 描述
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch​(QName portName, Class<T> type, Service.Mode mode)
      创建一个 Dispatch实例，供用户选择的对象使用。
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch​(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      创建一个 Dispatch实例，供用户选择的对象使用。
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch​(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      创建一个 Dispatch实例，供用户选择的对象使用。
      Endpoint Provider.createEndpoint​(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      使用提供的绑定，实现类，调用者和Web服务功能创建端点对象。
      abstract ServiceDelegate Provider.createServiceDelegate​(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      创建服务委托对象。
      ServiceDelegate Provider.createServiceDelegate​(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      创建服务委托对象。
      abstract <T> T Provider.getPort​(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回代理。
      abstract <T> T ServiceDelegate.getPort​(Class<T> serviceEndpointInterface)
      getPort方法返回代理。
      abstract <T> T ServiceDelegate.getPort​(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回代理。
      abstract <T> T ServiceDelegate.getPort​(QName portName, Class<T> serviceEndpointInterface)
      getPort方法返回代理。
      abstract <T> T ServiceDelegate.getPort​(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回代理。
      abstract <T> T ServiceDelegate.getPort​(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      getPort方法返回代理。

    • Uses of Class in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type Class
      Modifier and Type 方法 描述
      default <T> T XPath.evaluateExpression​(String expression, Object item, Class<T> type)
      在指定的上下文中评估XPath表达式，并返回结果，并使用 class type指定的类型
      default <T> T XPath.evaluateExpression​(String expression, InputSource source, Class<T> type)
      在指定的 source的上下文中评估XPath表达式，并按照指定返回结果。
      default <T> T XPathExpression.evaluateExpression​(Object item, Class<T> type)
      评估在指定上下文中编译的XPath表达式，并返回结果，并使用 class type指定的类型。
      default <T> T XPathExpression.evaluateExpression​(InputSource source, Class<T> type)
      评估在指定上下文中编译的XPath表达式，并返回结果，其类型通过 class type指定
      static QName XPathEvaluationResult.XPathResultType.getQNameType​(Class<?> clsType)
      返回与指定类类型相对应的XPathConstants中指定的QName类型。

    • Uses of Class in jdk.dynalink.beans

      Methods in jdk.dynalink.beans that return Class
      Modifier and Type 方法 描述
      Class<?> StaticClass.getRepresentedClass​()
      返回表示的Java类。
      Methods in jdk.dynalink.beans with parameters of type Class
      Modifier and Type 方法 描述
      static StaticClass StaticClass.forClass​(Class<?> clazz)
      检索指定类的StaticClass实例。
      static Object BeansLinker.getConstructorMethod​(Class<?> clazz, String signature)
      返回给定类的构造函数的动态方法和给定的签名。
      static Set<String> BeansLinker.getInstanceMethodNames​(Class<?> clazz)
      返回一组类的所有实例方法的名称。
      TypeBasedGuardingDynamicLinker BeansLinker.getLinkerForClass​(Class<?> clazz)
      返回特定单个类的bean连接器。
      static Set<String> BeansLinker.getReadableInstancePropertyNames​(Class<?> clazz)
      返回一组类的所有可读实例属性的名称。
      static Set<String> BeansLinker.getReadableStaticPropertyNames​(Class<?> clazz)
      返回一组类的所有可读静态属性的名称。
      static Set<String> BeansLinker.getStaticMethodNames​(Class<?> clazz)
      返回类的所有静态方法的一组名称。
      static Set<String> BeansLinker.getWritableInstancePropertyNames​(Class<?> clazz)
      返回一组类的所有可写实例属性的名称。
      static Set<String> BeansLinker.getWritableStaticPropertyNames​(Class<?> clazz)
      返回一组类的所有可写静态属性的名称。

    • Uses of Class in jdk.dynalink.linker

      Methods in jdk.dynalink.linker that return Class
      Modifier and Type 方法 描述
      Class<? extends Throwable> GuardedInvocation.getException​()
      返回异常类型，如果调用抛出应该使该被守卫的调用的链接失效。
      Methods in jdk.dynalink.linker with parameters of type Class
      Modifier and Type 方法 描述
      boolean LinkerServices.canConvert​(Class<?> from, Class<?> to)
      如果请求的类型（自动JVM转换或任何可用的GuardingTypeConverterFactory提供的转换）之间可能存在转换，则返回true;如果在请求的类型之间绝对不存在转换，则返回false。
      boolean TypeBasedGuardingDynamicLinker.canLinkType​(Class<?> type)
      如果链接器可以链接第一个参数（接收者）是指定类型的调用，则返回true。
      ConversionComparator.Comparison ConversionComparator.compareConversion​(Class<?> sourceType, Class<?> targetType1, Class<?> targetType2)
      从源类型确定两种目标类型中的哪一种是首选转换目标。
      ConversionComparator.Comparison LinkerServices.compareConversion​(Class<?> sourceType, Class<?> targetType1, Class<?> targetType2)
      确定从源类型到两种目标类型的两种类型转换中的哪一种是首选。
      GuardedInvocation GuardingTypeConverterFactory.convertToType​(Class<?> sourceType, Class<?> targetType, Supplier<MethodHandles.Lookup> lookupSupplier)
      返回受保护的类型转换，它接收指定的源类型的值，并返回转换为指定的目标类型的值。
      GuardedInvocation GuardedInvocation.dropArguments​(int pos, Class<?>... valueTypes)
      在调用和保护（如果存在并且至少具有 pos参数）中使用 MethodHandles.dropArguments(MethodHandle, int, Class...)进行调用 。
      MethodHandle LinkerServices.getTypeConverter​(Class<?> sourceType, Class<?> targetType)
      给定一个源和目标类型，返回一个在它们之间进行转换的方法句柄。
      Method parameters in jdk.dynalink.linker with type arguments of type Class
      Modifier and Type 方法 描述
      GuardedInvocation GuardedInvocation.dropArguments​(int pos, List<Class<?>> valueTypes)
      在调用和保护（如果存在并且至少具有 pos参数）中使用 MethodHandles.dropArguments(MethodHandle, int, List)的参数进行 调用 。
      Constructors in jdk.dynalink.linker with parameters of type Class
      Constructor 描述
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint[] switchPoints, Class<? extends Throwable> exception)
      创建一个新的有保护的调用，具有保护方法句柄，可以使用任何数量的切换点来使其无效，以及如果在调用时抛出的异常也会使其失效。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint switchPoint, Class<? extends Throwable> exception)
      创建一个新的守卫调用，具有保护方法句柄，可用于使其无效的切换点，以及如果在调用时抛出也会使其失效的异常。

    • Uses of Class in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support that return Class
      Modifier and Type 方法 描述
      static Class<?> TypeUtilities.getPrimitiveType​(Class<?> wrapperType)
      当传递一个表示原始类型的包装器的类时，返回表示相应基本类型的类。
      static Class<?> TypeUtilities.getPrimitiveTypeByName​(String name)
      给定一个原始类型的名称返回表示它的类。
      static Class<?> TypeUtilities.getWrapperType​(Class<?> primitiveType)
      当传递表示原始类型的类时，返回表示相应包装器类型的类。
      Methods in jdk.dynalink.linker.support with parameters of type Class
      Modifier and Type 方法 描述
      boolean CompositeTypeBasedGuardingDynamicLinker.canLinkType​(Class<?> type)
      如果至少有一个复合链接器从类型为 TypeBasedGuardingDynamicLinker.canLinkType(Class)返回true， 则返回true。
      MethodHandle Lookup.findGetter​(Class<?> refc, String name, Class<?> type)
      执行MethodHandles.Lookup.findGetter(Class, String, Class) ，将任何遇到的IllegalAccessException转换为IllegalAccessError和NoSuchFieldException到NoSuchFieldError 。
      static MethodHandle Lookup.findOwnSpecial​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)
      给定一个查找，找到使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。
      MethodHandle Lookup.findOwnSpecial​(String name, Class<?> rtype, Class<?>... ptypes)
      查找使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。
      static MethodHandle Lookup.findOwnStatic​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)
      给定一个查找，找到使用 Lookup.findStatic(Class, String, MethodType)该查找的类的方法。
      MethodHandle Lookup.findOwnStatic​(String name, Class<?> rtype, Class<?>... ptypes)
      查找使用 Lookup.findStatic(Class, String, MethodType)该查找的类的方法。
      MethodHandle Lookup.findSpecial​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行 MethodHandles.Lookup.findSpecial(Class, String, MethodType, Class) 。
      MethodHandle Lookup.findStatic​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行 MethodHandles.Lookup.findStatic(Class, String, MethodType) 。
      MethodHandle Lookup.findVirtual​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行 MethodHandles.Lookup.findVirtual(Class, String, MethodType) 。
      static MethodHandle Guards.getClassGuard​(Class<?> clazz)
      创建一个保护方法，测试其唯一的参数是一个确切的特定类。
      static MethodHandle Guards.getInstanceOfGuard​(Class<?> clazz)
      创建一个保护方法，测试其唯一的参数作为特定类的实例。
      static Class<?> TypeUtilities.getPrimitiveType​(Class<?> wrapperType)
      当传递一个表示原始类型的包装器的类时，返回表示相应基本类型的类。
      static Class<?> TypeUtilities.getWrapperType​(Class<?> primitiveType)
      当传递表示原始类型的类时，返回表示相应包装器类型的类。
      static boolean TypeUtilities.isConvertibleWithoutLoss​(Class<?> sourceType, Class<?> targetType)
      确定类型是否可以转换为另一个而不会失去任何精度。
      static MethodHandle Guards.isInstance​(Class<?> clazz, int pos, MethodType type)
      使用指定类型的参数创建方法句柄，但使用布尔值返回值。
      static MethodHandle Guards.isInstance​(Class<?> clazz, MethodType type)
      使用指定类型的参数创建方法句柄，但使用布尔值返回值。
      static boolean TypeUtilities.isMethodInvocationConvertible​(Class<?> sourceType, Class<?> targetType)
      根据JLS 5.3“方法调用转换”，确定是否可以使用方法调用转换将一种类型转换为其他类型。
      static MethodHandle Guards.isOfClass​(Class<?> clazz, MethodType type)
      使用指定类型的参数创建一个保护方法句柄，但使用布尔返回值。
      static boolean TypeUtilities.isSubtype​(Class<?> subType, Class<?> superType)
      根据JLS 4.10“子类型”确定一种类型是否是另一种类型的子类型。
      static boolean TypeUtilities.isWrapperType​(Class<?> type)
      如果传递的类型是原始类型的包装器，则返回true。

    • Uses of Class in jdk.jshell.execution

      Methods in jdk.jshell.execution that return Class
      Modifier and Type 方法 描述
      protected Class<?> DirectExecutionControl.findClass​(String name)
      查找具有指定二进制名称的类。
      Class<?> LoaderDelegate.findClass​(String name)
      查找具有指定二进制名称的类。

    • Uses of Class in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting with parameters of type Class
      Modifier and Type | 方法 | 描述
      static Object AbstractJSObject.getDefaultValue​(JSObject jsobj, Class<?> hint)
      已过时。
      改用JSObject.getDefaultValue(Class) 。
      default Object JSObject.getDefaultValue​(Class<?> hint)
      根据ECMAScript 5.1第8.6.2节，实现该对象的 [[DefaultValue]]方法。
      Object | ScriptObjectMirror.getDefaultValue​(Class<?> hint)
      <T> T | NashornScriptEngine.getInterface​(Class<T> clazz)
      <T> T | NashornScriptEngine.getInterface​(Object thiz, Class<T> clazz)
      <T> T ScriptObjectMirror.to​(Class<T> type)
      将此脚本对象转换为给定类型的实用程序。

    • Uses of Class in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree that return Class
      Modifier and Type 方法 描述
      Class<? extends 树> Tree.Kind.asInterface​()
      返回使用这种类型的关联接口类型。

    • Uses of Class in jdk.net

      Methods in jdk.net with parameters of type Class
      Modifier and Type 方法 描述
      static Set<SocketOption<?>> Sockets.supportedOptions​(Class<?> socketType)
      返回给定套接字类型支持的一组SocketOption 。

    • Uses of Class in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type Class
      Modifier and Type 方法 描述
      ServantObject LocalObject._servant_preinvoke​(String operation, Class expectedType)
      使用消息“这是一个局部约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。

    • Uses of Class in org.omg.CORBA_2_3.portable

      Methods in org.omg.CORBA_2_3.portable with parameters of type Class
      Modifier and Type 方法 描述
      Object InputStream.read_abstract_interface​(Class clz)
      解组对应于传递类型的类对象或存根类。
      Serializable InputStream.read_value​(Class clz)
      从输入流解组值类型。
      void OutputStream.write_value​(Serializable value, Class clz)
      为输出流调度值类型。

    • Uses of Class in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type Class
      Modifier and Type 方法 描述
      ServantObject ObjectImpl._servant_preinvoke​(String operation, Class expectedType)
      返回对本地servant的Java引用，该引用应用于发送请求方法。
      Object InputStream.read_Object​(Class clz)
      解组合对象并返回CORBA对象，该对象是作为参数传递的类的实例。
      ServantObject Delegate.servant_preinvoke​(Object self, String operation, Class expectedType)
      返回应用于此请求的servant的Java引用。 servant_preinvoke（）由本地存根调用。

    • Uses of Class in org.omg.DynamicAny

      Fields in org.omg.DynamicAny declared as Class
      Modifier and Type | Field | 描述
      static Class | _DynAnyFactoryStub._opsClass
      static Class | _DynAnyStub._opsClass
      static Class | _DynArrayStub._opsClass
      static Class | _DynEnumStub._opsClass
      static Class | _DynFixedStub._opsClass
      static Class | _DynSequenceStub._opsClass
      static Class | _DynStructStub._opsClass
      static Class | _DynUnionStub._opsClass
      static Class | _DynValueStub._opsClass

    • Uses of Class in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as Class
      Modifier and Type | Field | 描述
      static Class | _ServantActivatorStub._opsClass
      static Class | _ServantLocatorStub._opsClass
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ClassCastException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ClassCastException

  • Packages that use ClassCastException
    软件包 描述
    javax.rmi
    包含RMI-IIOP的用户API。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    org.w3c.dom.bootstrap
    提供一个工厂获取 DOMImplementation实例。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of ClassCastException in javax.rmi

      Methods in javax.rmi that throw ClassCastException
      Modifier and Type 方法 描述
      static Object PortableRemoteObject.narrow​(Object narrowFrom, Class narrowTo)
      检查以确保远程或抽象接口类型的对象可以转换为所需类型。

    • Uses of ClassCastException in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that throw ClassCastException
      Modifier and Type 方法 描述
      Object PortableRemoteObjectDelegate.narrow​(Object narrowFrom, Class narrowTo)
      代表团要求 PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 。

    • Uses of ClassCastException in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that throw ClassCastException
      Modifier and Type 方法 描述
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance​()
      获取一个新的实例 DOMImplementationRegistry 。

    • Uses of ClassCastException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw ClassCastException
      Modifier and Type 方法 描述
      static Parser ParserFactory.makeParser​()
      已过时。
      使用`org.xml.sax.parser'系统属性创建一个新的SAX解析器。
      static Parser ParserFactory.makeParser​(String className)
      已过时。
      使用提供的类名创建一个新的SAX解析器对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ClassCircularityError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ClassCircularityError

No usage of java.lang.ClassCircularityError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ClassFormatError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ClassFormatError

  • Packages that use ClassFormatError
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of ClassFormatError in java.lang

      Subclasses of ClassFormatError in java.lang
      Modifier and Type Class 描述
      class  UnsupportedClassVersionError
      当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
      Methods in java.lang that throw ClassFormatError
      Modifier and Type 方法 描述
      protected Class<?> ClassLoader.defineClass​(byte[] b, int off, int len)
      已过时。
      替换为defineClass(String, byte[], int, int)
      protected Class<?> ClassLoader.defineClass​(String name, byte[] b, int off, int len)
      将字节数组转换为类别为 Class的实例。
      protected Class<?> ClassLoader.defineClass​(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
      将字节数组转换为类别为 Class的实例，并给出了 ProtectionDomain 。
      protected Class<?> ClassLoader.defineClass​(String name, ByteBuffer b, ProtectionDomain protectionDomain)
      一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。

    • Uses of ClassFormatError in java.lang.reflect

      Subclasses of ClassFormatError in java.lang.reflect
      Modifier and Type Class 描述
      class  GenericSignatureFormatError
      当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ClassLoader

  • Packages that use ClassLoader
    软件包 描述
    com.sun.tools.javadoc
    此软件包及其内容已被弃用，可能会在将来的版本中删除。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.activation
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of ClassLoader in com.sun.tools.javadoc

      Methods in com.sun.tools.javadoc with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static int Main.execute​(ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int Main.execute​(String programName, PrintWriter errWriter, PrintWriter warnWriter, PrintWriter noticeWriter, String defaultDocletClassName, ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int Main.execute​(String programName, ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。
      static int Main.execute​(String programName, String defaultDocletClassName, ClassLoader docletParentClassLoader, String... args)
      已过时。
      程式化界面。

    • Uses of ClassLoader in java.awt.datatransfer

      Methods in java.awt.datatransfer with parameters of type ClassLoader
      Modifier and Type 方法 描述
      protected static Class<?> DataFlavor.tryToLoadClass​(String className, ClassLoader fallback)
      尝试加载一个类：引导加载程序，系统加载程序，上下文加载程序（如果存在），最后指定加载程序。
      Constructors in java.awt.datatransfer with parameters of type ClassLoader
      Constructor 描述
      DataFlavor​(String mimeType, String humanPresentableName, ClassLoader classLoader)
      构造一个 DataFlavor ，代表一个 MimeType 。

    • Uses of ClassLoader in java.beans

      Methods in java.beans with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static DefaultHandler XMLDecoder.createHandler​(Object owner, ExceptionListener el, ClassLoader cl)
      为SAX解析器创建一个新的处理程序，可用于解析由 XMLEncoder类创建的嵌入式XML存档。
      static Object Beans.instantiate​(ClassLoader cls, String beanName)
      实例化JavaBean。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)
      实例化JavaBean。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
      已过时。
      建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      Constructors in java.beans with parameters of type ClassLoader
      Constructor 描述
      XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
      创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。

    • Uses of ClassLoader in java.lang

      Methods in java.lang that return ClassLoader
      Modifier and Type 方法 描述
      protected ClassLoader SecurityManager.currentClassLoader​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      ClassLoader ModuleLayer.findLoader​(String name)
      返回具有给定名称的模块的 ClassLoader 。
      ClassLoader Class.getClassLoader​()
      返回类的类加载器。
      ClassLoader Module.getClassLoader​()
      返回此模块的 ClassLoader 。
      ClassLoader Thread.getContextClassLoader​()
      返回此线程的上下文 ClassLoader 。
      ClassLoader ClassLoader.getParent​()
      返回父类加载器进行委派。
      static ClassLoader ClassLoader.getPlatformClassLoader​()
      返回用于委派的平台类加载器。
      static ClassLoader ClassLoader.getSystemClassLoader​()
      返回用于委派的系统类加载器。
      Methods in java.lang with parameters of type ClassLoader
      Modifier and Type 方法 描述
      ModuleLayer ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      ModuleLayer ModuleLayer.defineModulesWithOneLoader​(Configuration cf, ClassLoader parentLoader)
      通过在Java虚拟机给定的 Configuration定义模块，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithOneLoader​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static Class<?> Class.forName​(String name, boolean initialize, ClassLoader loader)
      使用给定的类加载器返回与给定字符串名称的类或接口相关联的 Class对象。
      void Thread.setContextClassLoader​(ClassLoader cl)
      设置此线程的上下文ClassLoader。
      Method parameters in java.lang with type arguments of type ClassLoader
      Modifier and Type 方法 描述
      ModuleLayer ModuleLayer.defineModules​(Configuration cf, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller ModuleLayer.defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      Constructors in java.lang with parameters of type ClassLoader
      Constructor 描述
      ClassLoader​(ClassLoader parent)
      使用指定的父类加载器创建一个新的类加载器进行委派。
      ClassLoader​(String name, ClassLoader parent)
      创建指定名称的新类加载器，并使用指定的父类加载器进行委派。

    • Uses of ClassLoader in java.lang.instrument

      Methods in java.lang.instrument with parameters of type ClassLoader
      Modifier and Type 方法 描述
      Class[] Instrumentation.getInitiatedClasses​(ClassLoader loader)
      返回一个 loader是起始加载程序的所有类的数组。
      default byte[] ClassFileTransformer.transform​(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
      default byte[] ClassFileTransformer.transform​(Module module, ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。

    • Uses of ClassLoader in java.lang.invoke

      Methods in java.lang.invoke with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static MethodType MethodType.fromMethodDescriptorString​(String descriptor, ClassLoader loader)
      查找或创建方法类型的实例，给定其字节码描述符的拼写。

    • Uses of ClassLoader in java.lang.reflect

      Methods in java.lang.reflect with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static Class<?> Proxy.getProxyClass​(ClassLoader loader, Class<?>... interfaces)
      已过时。
      在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在不可访问的代理类上调用时抛出IllegalAccessException 。 使用Proxy.newProxyInstance(ClassLoader, Class[], InvocationHandler)来代替创建一个代理实例。
      static Object Proxy.newProxyInstance​(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
      返回指定接口的代理实例，该代理实例将方法调用分派给指定的调用处理程序。

    • Uses of ClassLoader in java.net

      Subclasses of ClassLoader in java.net
      Modifier and Type Class 描述
      class  URLClassLoader
      此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。
      Methods in java.net with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static URLClassLoader URLClassLoader.newInstance​(URL[] urls, ClassLoader parent)
      为指定的URL和父类加载器创建URLClassLoader的新实例。
      Constructors in java.net with parameters of type ClassLoader
      Constructor 描述
      URLClassLoader​(String name, URL[] urls, ClassLoader parent)
      为指定的URL构造一个新的名称为 URLClassLoader 。
      URLClassLoader​(String name, URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的命名为 URLClassLoader 。
      URLClassLoader​(URL[] urls, ClassLoader parent)
      为给定的URL构造一个新的URLClassLoader。
      URLClassLoader​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的URLClassLoader。

    • Uses of ClassLoader in java.nio.file

      Methods in java.nio.file with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static FileSystem FileSystems.newFileSystem​(URI uri, Map<String,?> env, ClassLoader loader)
      构造一个由URI标识的新文件系统
      static FileSystem FileSystems.newFileSystem​(Path path, ClassLoader loader)
      构造新的 FileSystem以访问文件的内容作为文件系统。

    • Uses of ClassLoader in java.rmi.server

      Methods in java.rmi.server that return ClassLoader
      Modifier and Type 方法 描述
      static ClassLoader RMIClassLoader.getClassLoader​(String codebase)
      返回从给定的代码库URL路径加载类的类加载器。
      abstract ClassLoader RMIClassLoaderSpi.getClassLoader​(String codebase)
      提供 RMIClassLoader.getClassLoader(String)的实现。
      Methods in java.rmi.server with parameters of type ClassLoader
      Modifier and Type 方法 描述
      Object LoaderHandler.getSecurityContext​(ClassLoader loader)
      已过时。
      没有替换
      static Object RMIClassLoader.getSecurityContext​(ClassLoader loader)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用此方法来获取类加载器的安全上下文。
      static Class<?> RMIClassLoader.loadClass​(String codebase, String name, ClassLoader defaultLoader)
      从代码库URL路径加载类，可选地使用提供的加载程序。
      abstract Class<?> RMIClassLoaderSpi.loadClass​(String codebase, String name, ClassLoader defaultLoader)
       为贯彻
RMIClassLoader.loadClass(URL,String) ，
RMIClassLoader.loadClass(String,String) ，并
RMIClassLoader.loadClass(String,String,ClassLoader) 。
      static Class<?> RMIClassLoader.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      加载一个动态代理类（参见Proxy ），它从代码库URL路径中实现了一组具有给定名称的接口。
      abstract Class<?> RMIClassLoaderSpi.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。

    • Uses of ClassLoader in java.security

      Subclasses of ClassLoader in java.security
      Modifier and Type Class 描述
      class  SecureClassLoader
      此类扩展了ClassLoader，其额外支持用于定义具有相关代码源和权限的类，默认情况下系统策略将检索该类。
      Methods in java.security that return ClassLoader
      Modifier and Type 方法 描述
      ClassLoader ProtectionDomain.getClassLoader​()
      返回此域的ClassLoader。
      Constructors in java.security with parameters of type ClassLoader
      Constructor 描述
      ProtectionDomain​(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
      创建一个由给定的CodeSource，Permissions，ClassLoader和Principals数组限定的新的ProtectionDomain。
      SecureClassLoader​(ClassLoader parent)
      使用指定的父类加载器创建新的SecureClassLoader进行委派。
      SecureClassLoader​(String name, ClassLoader parent)
      创建一个新的指定名称的 SecureClassLoader ，并使用指定的父类加载器进行委派。

    • Uses of ClassLoader in java.util

      Methods in java.util with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static void ResourceBundle.clearCache​(ClassLoader loader)
      从缓存中删除由给定的类加载器加载的所有资源束。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale locale, ClassLoader loader)
      使用指定的基本名称，区域设置和类加载器获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
      使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。
      static <S> ServiceLoader<S> ServiceLoader.load​(Class<S> service, ClassLoader loader)
      为给定的服务创建一个新的服务加载器。
      boolean ResourceBundle.Control.needsReload​(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
      确定是否需要根据 loadTime给出的加载时间或其他一些标准来重新加载高速缓存中的过期 bundle 。
      ResourceBundle ResourceBundle.Control.newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
      为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。

    • Uses of ClassLoader in javafx.fxml

      Methods in javafx.fxml that return ClassLoader
      Modifier and Type 方法 描述
      ClassLoader FXMLLoader.getClassLoader​()
      返回此加载器使用的类加载器。
      static ClassLoader FXMLLoader.getDefaultClassLoader​()
      返回默认的类加载器。
      Methods in javafx.fxml with parameters of type ClassLoader
      Modifier and Type 方法 描述
      void FXMLLoader.setClassLoader​(ClassLoader classLoader)
      设置此装载器使用的类加载器，并清除任何现有的导入。
      static void FXMLLoader.setDefaultClassLoader​(ClassLoader defaultClassLoader)
      设置默认的类加载器。
      Constructors in javafx.fxml with parameters of type ClassLoader
      Constructor 描述
      JavaFXBuilderFactory​(ClassLoader classLoader)
      构造器接收类加载器。

    • Uses of ClassLoader in javax.activation

      Methods in javax.activation with parameters of type ClassLoader
      Modifier and Type 方法 描述
      Object CommandInfo.getCommandObject​(DataHandler dh, ClassLoader loader)
      返回实例化的JavaBean组件。

    • Uses of ClassLoader in javax.imageio.spi

      Methods in javax.imageio.spi with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static <T> Iterator<T> ServiceRegistry.lookupProviders​(Class<T> providerClass, ClassLoader loader)
      使用给定的类加载器搜索特定服务类的实现。

    • Uses of ClassLoader in javax.management

      Methods in javax.management that return ClassLoader
      Modifier and Type 方法 描述
      ClassLoader MBeanServer.getClassLoader​(ObjectName loaderName)
      返回命名为ClassLoader 。
      ClassLoader MBeanServer.getClassLoaderFor​(ObjectName mbeanName)
      返回用于加载名为MBean的类的ClassLoader 。
      Methods in javax.management with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static Class<?> DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)
      已过时。
      通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。

    • Uses of ClassLoader in javax.management.loading

      Subclasses of ClassLoader in javax.management.loading
      Modifier and Type Class 描述
      class  MLet
      允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
      class  PrivateMLet
      未添加到ClassLoaderRepository的MLet。
      Methods in javax.management.loading with parameters of type ClassLoader
      Modifier and Type 方法 描述
      Class<?> ClassLoaderRepository.loadClassBefore​(ClassLoader stop, String className)
      通过加载器列表加载给定的类名，停止在给定的类名称。
      Class<?> ClassLoaderRepository.loadClassWithout​(ClassLoader exclude, String className)
      通过类加载器列表加载给定的类名，不包括给定的类名。
      static Class<?> DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)
      已过时。
      通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。
      Constructors in javax.management.loading with parameters of type ClassLoader
      Constructor 描述
      MLet​(URL[] urls, ClassLoader parent)
      为给定的URL构造一个新的MLet。
      MLet​(URL[] urls, ClassLoader parent, boolean delegateToCLR)
      为给定的URL构造一个新的MLet。
      MLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
      MLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的MLet。
      PrivateMLet​(URL[] urls, ClassLoader parent, boolean delegateToCLR)
      为给定的URL构造一个新的PrivateMLet。
      PrivateMLet​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的PrivateMLet。

    • Uses of ClassLoader in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return ClassLoader
      Modifier and Type 方法 描述
      ClassLoader RMIServerImpl.getDefaultClassLoader​()
      获取此连接器服务器使用的默认值 ClassLoader 。
      Methods in javax.management.remote.rmi with parameters of type ClassLoader
      Modifier and Type 方法 描述
      void RMIServerImpl.setDefaultClassLoader​(ClassLoader cl)
      设置此连接器服务器的默认 ClassLoader 。
      Constructors in javax.management.remote.rmi with parameters of type ClassLoader
      Constructor 描述
      RMIConnectionImpl​(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
      构造新的RMIConnection 。

    • Uses of ClassLoader in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static Class Util.loadClass​(String className, String remoteCodebase, ClassLoader loader)
      返回指定类的类实例。
      Class UtilDelegate.loadClass​(String className, String remoteCodebase, ClassLoader loader)
      代表团要求 Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 。

    • Uses of ClassLoader in javax.script

      Constructors in javax.script with parameters of type ClassLoader
      Constructor 描述
      ScriptEngineManager​(ClassLoader loader)
      该构造函数使用服务提供者机制加载ScriptEngineFactory的给定ClassLoader可见的实现。

      如果装载机是null ，则加载与该平台捆绑的脚本引擎工厂。

    • Uses of ClassLoader in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static RowSetFactory RowSetProvider.newFactory​(String factoryClassName, ClassLoader cl)
      从指定的工厂类名称创建一个新的实例 RowSetFactory 。

    • Uses of ClassLoader in javax.swing

      Methods in javax.swing with parameters of type ClassLoader
      Modifier and Type 方法 描述
      Class<? extends ComponentUI> UIDefaults.getUIClass​(String uiClassID, ClassLoader uiClassLoader)
      get(uidClassID)的值必须是实现相应的 ComponentUI类的类的 String名称。
      static void JEditorPane.registerEditorKitForContentType​(String type, String classname, ClassLoader loader)
      建立 type的默认绑定为 classname 。

    • Uses of ClassLoader in javax.tools

      Methods in javax.tools that return ClassLoader
      Modifier and Type | 方法 | 描述
      ClassLoader | ForwardingJavaFileManager.getClassLoader​(JavaFileManager.Location location)
      ClassLoader JavaFileManager.getClassLoader​(JavaFileManager.Location location)
      返回一个类加载器，用于从给定的面向包的位置加载插件。
      static ClassLoader ToolProvider.getSystemToolClassLoader​()
      已过时。
      此方法在将来的Java SE版本中可能会被删除。 使用system tool provider或service loader机制来定位系统工具以及用户安装的工具。

    • Uses of ClassLoader in javax.xml.bind

      Methods in javax.xml.bind with parameters of type ClassLoader
      Modifier and Type 方法 描述
      JAXBContext JAXBContextFactory.createContext​(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      创建一个新的 JAXBContext类的实例。
      static JAXBContext JAXBContext.newInstance​(String contextPath, ClassLoader classLoader)
      创建一个新的 JAXBContext类的实例。
      static JAXBContext JAXBContext.newInstance​(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      创建一个新的 JAXBContext类的实例。

    • Uses of ClassLoader in javax.xml.datatype

      Methods in javax.xml.datatype with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static DatatypeFactory DatatypeFactory.newInstance​(String factoryClassName, ClassLoader classLoader)
      从类名获取一个新的实例 DatatypeFactory 。

    • Uses of ClassLoader in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static DocumentBuilderFactory DocumentBuilderFactory.newInstance​(String factoryClassName, ClassLoader classLoader)
      从类名获取一个新的 DocumentBuilderFactory实例。
      static SAXParserFactory SAXParserFactory.newInstance​(String factoryClassName, ClassLoader classLoader)
      从类名中获取一个新的 SAXParserFactory实例。

    • Uses of ClassLoader in javax.xml.stream

      Methods in javax.xml.stream with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static XMLEventFactory XMLEventFactory.newFactory​(String factoryId, ClassLoader classLoader)
      创建一个新的工厂实例。
      static XMLInputFactory XMLInputFactory.newFactory​(String factoryId, ClassLoader classLoader)
      创建一个新的工厂实例。
      static XMLOutputFactory XMLOutputFactory.newFactory​(String factoryId, ClassLoader classLoader)
      创建一个新的工厂实例。
      static XMLEventFactory XMLEventFactory.newInstance​(String factoryId, ClassLoader classLoader)
      已过时。
      该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替换XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
      static XMLInputFactory XMLInputFactory.newInstance​(String factoryId, ClassLoader classLoader)
      已过时。
      该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替换XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
      static XMLInputFactory XMLOutputFactory.newInstance​(String factoryId, ClassLoader classLoader)
      已过时。
      此方法已被弃用，因为它返回一个XMLInputFactory的实例，该实例是错误的类。 改用新的方法XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) 。

    • Uses of ClassLoader in javax.xml.transform

      Methods in javax.xml.transform with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static TransformerFactory TransformerFactory.newInstance​(String factoryClassName, ClassLoader classLoader)
      从工厂类名称获取一个新的 TransformerFactory实例。

    • Uses of ClassLoader in javax.xml.validation

      Methods in javax.xml.validation with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static SchemaFactory SchemaFactory.newInstance​(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
      从类名获取一个新的实例 SchemaFactory 。

    • Uses of ClassLoader in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type ClassLoader
      Modifier and Type 方法 描述
      static XPathFactory XPathFactory.newInstance​(String uri, String factoryClassName, ClassLoader classLoader)
      从工厂类名称获取一个新的 XPathFactory实例。

    • Uses of ClassLoader in jdk.dynalink

      Methods in jdk.dynalink with parameters of type ClassLoader
      Modifier and Type 方法 描述
      void DynamicLinkerFactory.setClassLoader​(ClassLoader classLoader)
      设置用于自动发现可用的保护动态链接器的类加载器。

    • Uses of ClassLoader in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting with parameters of type ClassLoader
      Modifier and Type 方法 描述
      ScriptEngine NashornScriptEngineFactory.getScriptEngine​(ClassLoader appLoader)
      创建一个使用给定的类加载器初始化的新脚本引擎。
      ScriptEngine NashornScriptEngineFactory.getScriptEngine​(String[] args, ClassLoader appLoader)
      创建一个新的Script引擎，并使用给定的参数和给定的类加载器进行初始化。
      ScriptEngine NashornScriptEngineFactory.getScriptEngine​(String[] args, ClassLoader appLoader, ClassFilter classFilter)
      创建一个使用给定参数，类加载器和类过滤器初始化的新脚本引擎。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ClassNotFoundException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ClassNotFoundException

  • Packages that use ClassNotFoundException
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.net
    提供实现网络应用程序的类。
    java.rmi
    提供RMI包。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javax.activation
    javax.crypto
    提供加密操作的类和接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.relation
    提供关系服务的定义。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    org.w3c.dom.bootstrap
    提供一个工厂来获取 DOMImplementation实例。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of ClassNotFoundException in java.awt.datatransfer

      Methods in java.awt.datatransfer that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static DataFlavor SystemFlavorMap.decodeDataFlavor​(String nat)
      解码 String本机用作 DataFlavor 。
      void DataFlavor.readExternal​(ObjectInput is)
      从序列化状态恢复此 DataFlavor 。
      protected static Class<?> DataFlavor.tryToLoadClass​(String className, ClassLoader fallback)
      尝试加载一个类：引导加载程序，系统加载程序，上下文加载程序（如果存在），最后指定加载程序。
      Constructors in java.awt.datatransfer that throw ClassNotFoundException
      Constructor 描述
      DataFlavor​(String mimeType)
      从 mimeType字符串构造一个 DataFlavor 。
      DataFlavor​(String mimeType, String humanPresentableName, ClassLoader classLoader)
      构造一个 DataFlavor代表一个 MimeType 。

    • Uses of ClassNotFoundException in java.beans

      Methods in java.beans that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static Object Beans.instantiate​(ClassLoader cls, String beanName)
      实例化JavaBean。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)
      实例化JavaBean。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
      已过时。
      建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of ClassNotFoundException in java.beans.beancontext

      Methods in java.beans.beancontext that throw ClassNotFoundException
      Modifier and Type 方法 描述
      protected void BeanContextServicesSupport.bcsPreDeserializationHook​(ObjectInputStream ois)
      从BeanContextSupport readObject中调用它反序列化子对象...
      protected void BeanContextSupport.bcsPreDeserializationHook​(ObjectInputStream ois)
      通过readObject在defaultReadObject（）之后调用，但在任何孩子反序列化之前。
      protected void BeanContextSupport.deserialize​(ObjectInputStream ois, Collection coll)
      由readObject用于反序列化集合。
      Object BeanContext.instantiateChild​(String beanName)
      实例化命名为此 BeanContext的小孩的javaBean。
      Object BeanContextSupport.instantiateChild​(String beanName)
      instantiateChild方法是BeanContext中的一个方便的钩子，用于简化将Bean实例化的任务嵌套到一个 BeanContext 。
      void BeanContextSupport.readChildren​(ObjectInputStream ois)
      当这个类的实例被用作实现BeanContext协议（及其子协议）的委托时，在反序列化期间存在一个'鸡和蛋'问题

    • Uses of ClassNotFoundException in java.io

      Methods in java.io that throw ClassNotFoundException
      Modifier and Type 方法 描述
      void ObjectInputStream.defaultReadObject​()
      从此流读取当前类的非静态和非瞬态字段。
      protected ObjectStreamClass ObjectInputStream.readClassDescriptor​()
      从序列化流读取类描述符。
      void Externalizable.readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。
      ObjectInputStream.GetField ObjectInputStream.readFields​()
      从流中读取持久性字段，并通过名称使其可用。
      Object ObjectInput.readObject​()
      读取并返回一个对象。
      Object ObjectInputStream.readObject​()
      从ObjectInputStream读取一个对象。
      protected Object ObjectInputStream.readObjectOverride​()
      此方法由ObjectOutputStream的受信任子类调用，该子类使用受保护的无参构造函数构造ObjectOutputStream。
      Object ObjectInputStream.readUnshared​()
      从ObjectInputStream读取一个“非共享”对象。
      protected Class<?> ObjectInputStream.resolveClass​(ObjectStreamClass desc)
      加载本地类等效的指定流类描述。
      protected Class<?> ObjectInputStream.resolveProxyClass​(String[] interfaces)
      返回一个代理类，它实现代理类描述符中命名的接口; 子类可以实现此方法从流中读取自定义数据以及动态代理类的描述符，从而允许它们为接口和代理类使用备用加载机制。

    • Uses of ClassNotFoundException in java.lang

      Methods in java.lang that throw ClassNotFoundException
      Modifier and Type 方法 描述
      protected Class<?> ClassLoader.findClass​(String name)
      找到具有指定的 类别binary name 。
      protected Class<?> ClassLoader.findSystemClass​(String name)
      找到一个具有指定的类的 binary name ，如果需要加载它。
      static Class<?> Class.forName​(String className)
      返回与给定字符串名称的类或接口相关联的 Class对象。
      static Class<?> Class.forName​(String name, boolean initialize, ClassLoader loader)
      使用给定的类加载器返回与给定字符串名称的类或接口相关联的 Class对象。
      Class<?> ClassLoader.loadClass​(String name)
      用指定的 binary name加载课程。
      protected Class<?> ClassLoader.loadClass​(String name, boolean resolve)
      加载指定的 类别binary name 。

    • Uses of ClassNotFoundException in java.lang.instrument

      Methods in java.lang.instrument that throw ClassNotFoundException
      Modifier and Type 方法 描述
      void Instrumentation.redefineClasses​(ClassDefinition... definitions)
      使用提供的类文件重新定义提供的一组类。

    • Uses of ClassNotFoundException in java.lang.invoke

      Methods in java.lang.invoke that throw ClassNotFoundException
      Modifier and Type 方法 描述
      Class<?> MethodHandles.Lookup.findClass​(String targetName)
      从这个 Lookup对象定义的查找上下文中按名称查找一个类。

    • Uses of ClassNotFoundException in java.net

      Methods in java.net that throw ClassNotFoundException
      Modifier and Type 方法 描述
      protected Class<?> URLClassLoader.findClass​(String name)
      从URL搜索路径查找并加载具有指定名称的类。

    • Uses of ClassNotFoundException in java.rmi

      Methods in java.rmi that throw ClassNotFoundException
      Modifier and Type 方法 描述
      T MarshalledObject.get​()
      返回包含的编组对象的新副本。

    • Uses of ClassNotFoundException in java.rmi.server

      Methods in java.rmi.server that throw ClassNotFoundException
      Modifier and Type 方法 描述
      Class<?> LoaderHandler.loadClass​(String name)
      已过时。
      没有替换
      Class<?> LoaderHandler.loadClass​(URL codebase, String name)
      已过时。
      没有替换
      static Class<?> RMIClassLoader.loadClass​(String name)
      已过时。
      替换为loadClass(String,String)方法
      static Class<?> RMIClassLoader.loadClass​(String codebase, String name)
      从代码库URL路径加载一个类。
      static Class<?> RMIClassLoader.loadClass​(String codebase, String name, ClassLoader defaultLoader)
      从代码库URL路径加载类，可选地使用提供的加载程序。
      static Class<?> RMIClassLoader.loadClass​(URL codebase, String name)
      从代码库URL加载一个类。
      abstract Class<?> RMIClassLoaderSpi.loadClass​(String codebase, String name, ClassLoader defaultLoader)
       为贯彻
RMIClassLoader.loadClass(URL,String) ，
RMIClassLoader.loadClass(String,String) ，并
RMIClassLoader.loadClass(String,String,ClassLoader) 。
      static Class<?> RMIClassLoader.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      加载一个动态代理类（参见Proxy ），它从代码库URL路径中实现一组具有给定名称的接口。
      abstract Class<?> RMIClassLoaderSpi.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)
      提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。

    • Uses of ClassNotFoundException in java.security

      Methods in java.security that throw ClassNotFoundException
      Modifier and Type 方法 描述
      Object SignedObject.getObject​()
      检索封装对象。

    • Uses of ClassNotFoundException in javafx.fxml

      Methods in javafx.fxml that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static Class<?> FXMLLoader.loadType​(String className)
      已过时。
      此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
      static Class<?> FXMLLoader.loadType​(String packageName, String className)
      已过时。
      此方法现在委托给FXMLLoader.getDefaultClassLoader() 。

    • Uses of ClassNotFoundException in javax.activation

      Methods in javax.activation that throw ClassNotFoundException
      Modifier and Type 方法 描述
      Object CommandInfo.getCommandObject​(DataHandler dh, ClassLoader loader)
      返回实例化的JavaBean组件。
      void MimeType.readExternal​(ObjectInput in)
      该对象实现了readExternal方法来恢复其内容，方法是为对象，字符串和数组调用基本类型的DataInput方法和readObject。

    • Uses of ClassNotFoundException in javax.crypto

      Methods in javax.crypto that throw ClassNotFoundException
      Modifier and Type 方法 描述
      Object SealedObject.getObject​(Key key)
      检索原始（封装）对象。
      Object SealedObject.getObject​(Key key, String provider)
      检索原始（封装）对象。
      Object SealedObject.getObject​(Cipher c)
      检索原始（封装）对象。

    • Uses of ClassNotFoundException in javax.management

      Methods in javax.management that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static Class<?> DefaultLoaderRepository.loadClass​(String className)
      已过时。
      浏览类加载器列表，并尝试加载所请求的类。
      static Class<?> DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)
      已过时。
      通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。

    • Uses of ClassNotFoundException in javax.management.loading

      Methods in javax.management.loading that throw ClassNotFoundException
      Modifier and Type 方法 描述
      protected Class<?> MLet.findClass​(String name)
      这是正在重新定义的类加载器的主要方法。
      Class<?> ClassLoaderRepository.loadClass​(String className)
      通过类加载器列表加载给定的类名。
      static Class<?> DefaultLoaderRepository.loadClass​(String className)
      已过时。
      浏览类加载器列表，并尝试加载所请求的类。
      Class<?> MLet.loadClass​(String name, ClassLoaderRepository clr)
      加载一个类，使用给定的ClassLoaderRepository如果该类没有在这个MLet的URL中找到。
      Class<?> ClassLoaderRepository.loadClassBefore​(ClassLoader stop, String className)
      通过加载器列表加载给定的类名，停止在给定的类名称。
      Class<?> ClassLoaderRepository.loadClassWithout​(ClassLoader exclude, String className)
      通过类加载器列表加载给定的类名，不包括给定的类名。
      static Class<?> DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)
      已过时。
      通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。
      void MLet.readExternal​(ObjectInput in)
      从给定的ObjectInput恢复此MLet的内容。

    • Uses of ClassNotFoundException in javax.management.relation

      Constructors in javax.management.relation that throw ClassNotFoundException
      Constructor 描述
      RoleInfo​(String roleName, String mbeanClassName)
      构造函数。
      RoleInfo​(String roleName, String mbeanClassName, boolean read, boolean write)
      构造函数。
      RoleInfo​(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
      构造函数。

    • Uses of ClassNotFoundException in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static Class Util.loadClass​(String className, String remoteCodebase, ClassLoader loader)
      返回指定类的类实例。
      Class UtilDelegate.loadClass​(String className, String remoteCodebase, ClassLoader loader)
      代表团要求 Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 。
      void StubDelegate.readObject​(Stub self, ObjectInputStream s)
      代表团要求 Stub.readObject(java.io.ObjectInputStream) 。

    • Uses of ClassNotFoundException in javax.swing

      Methods in javax.swing that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static void UIManager.setLookAndFeel​(String className)
      使用当前线程的上下文类加载器加载由给定类名指定的 LookAndFeel ，并将其传递给 setLookAndFeel(LookAndFeel) 。

    • Uses of ClassNotFoundException in javax.swing.text

      Methods in javax.swing.text that throw ClassNotFoundException
      Modifier and Type 方法 描述
      void StyleContext.readAttributes​(ObjectInputStream in, MutableAttributeSet a)
      属性中阅读的上下文特定处理
      static void StyleContext.readAttributeSet​(ObjectInputStream in, MutableAttributeSet a)
      从给定的对象输入流读取一组属性，这些属性先前已经用 writeAttributeSet 。

    • Uses of ClassNotFoundException in jdk.jshell.execution

      Methods in jdk.jshell.execution that throw ClassNotFoundException
      Modifier and Type 方法 描述
      protected Class<?> DirectExecutionControl.findClass​(String name)
      查找具有指定二进制名称的类。
      Class<?> LoaderDelegate.findClass​(String name)
      查找具有指定二进制名称的类。

    • Uses of ClassNotFoundException in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance​()
      获取一个新的实例 DOMImplementationRegistry 。

    • Uses of ClassNotFoundException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw ClassNotFoundException
      Modifier and Type 方法 描述
      static Parser ParserFactory.makeParser​()
      已过时。
      使用`org.xml.sax.parser'系统属性创建一个新的SAX解析器。
      static Parser ParserFactory.makeParser​(String className)
      已过时。
      Create a new SAX parser object using the class name provided.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ClassValue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ClassValue

No usage of java.lang.ClassValue
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.CloneNotSupportedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.CloneNotSupportedException

  • Packages that use CloneNotSupportedException
    软件包 描述
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。

    • Uses of CloneNotSupportedException in java.awt.datatransfer

      Methods in java.awt.datatransfer that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      Object DataFlavor.clone​()
      返回此 DataFlavor的克隆。

    • Uses of CloneNotSupportedException in java.lang

      Methods in java.lang that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      protected Object Enum.clone​()
      抛出CloneNotSupportedException。
      protected Object Object.clone​()
      创建并返回此对象的副本。
      protected Object Thread.clone​()
      将CloneNotSupportedException作为线程抛出无法有意义地克隆。

    • Uses of CloneNotSupportedException in java.rmi.server

      Subclasses of CloneNotSupportedException in java.rmi.server
      Modifier and Type Class 描述
      class  ServerCloneException
      甲 ServerCloneException如果一个的克隆过程中发生远程抛出异常 UnicastRemoteObject 。
      Methods in java.rmi.server that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      Object UnicastRemoteObject.clone​()
      返回与原始对象不同的远程对象的克隆。

    • Uses of CloneNotSupportedException in java.security

      Methods in java.security that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      Object MessageDigest.clone​()
      如果实现是可克隆的，则返回克隆。
      Object MessageDigestSpi.clone​()
      如果实现是可克隆的，则返回克隆。
      Object Signature.clone​()
      如果实现是可克隆的，则返回克隆。
      Object SignatureSpi.clone​()
      如果实现是可克隆的，则返回克隆。

    • Uses of CloneNotSupportedException in java.util

      Methods in java.util that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      protected Object AbstractMap.clone​()
      返回此 AbstractMap实例的浅拷贝：键和值本身不被克隆。

    • Uses of CloneNotSupportedException in javax.crypto

      Methods in javax.crypto that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      Object Mac.clone​()
      如果提供程序实现是可克隆的，则返回克隆。
      Object MacSpi.clone​()
      如果实现是可克隆的，则返回克隆。

    • Uses of CloneNotSupportedException in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      TIFFDirectory TIFFDirectory.clone​()
      克隆目录及其中包含的所有字段。
      TIFFField TIFFField.clone​()
      克隆该字段及其中包含的所有信息。

    • Uses of CloneNotSupportedException in javax.swing

      Methods in javax.swing that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      protected Object AbstractAction.clone​()
      克隆抽象动作。
      Object DefaultListSelectionModel.clone​()
      返回具有相同选择的此选择模型的克隆。
      protected Object JFormattedTextField.AbstractFormatter.clone​()
      克隆 AbstractFormatter 。

    • Uses of CloneNotSupportedException in javax.swing.text

      Methods in javax.swing.text that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      Object DefaultFormatter.clone​()
      创建DefaultFormatter的副本。
      Object InternationalFormatter.clone​()
      创建DefaultFormatter的副本。

    • Uses of CloneNotSupportedException in javax.swing.tree

      Methods in javax.swing.tree that throw CloneNotSupportedException
      Modifier and Type 方法 描述
      Object DefaultTreeSelectionModel.clone​()
      Returns a clone of this object with the same selection.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Compiler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Compiler

No usage of java.lang.Compiler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Deprecated (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Deprecated

  • Packages that use 已过时的
    软件包 描述
    com.sun.jarsigner
    该包包含用于定义 jarsigner工具使用的签名机制的接口和类。
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    com.sun.javadoc
    注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.security.auth
    提供Principal的实现。
    com.sun.security.auth.module
    提供LoginModule的实现。
    com.sun.tools.doclets
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.doclets.standard
    注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。
    com.sun.tools.javadoc
    此软件包及其内容已被弃用，可能会在将来的版本中删除。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.net
    提供实现网络应用程序的类。
    java.rmi
    提供RMI包。
    java.rmi.dgc
    提供RMI分布式垃圾收集（DGC）的类和接口。
    java.rmi.registry
    为RMI注册表提供一个类和两个接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.application
    提供应用程序生命周期类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.util
    包含各种实用程序和助手类。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jws.soap
    javax.lang.model.util
    协助处理 program elements及 types的工具 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.net.ssl
    为安全套接字包提供类。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.cert
    提供公钥证书类。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB ，它被实现为程序员可以将其用作全功能的对象请求代理（ORB）。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.xml.sax
    提供核心SAX API。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of 已过时的 in com.sun.jarsigner

      Classes in com.sun.jarsigner with annotations of type 已过时的
      Modifier and Type Class 描述
      class  ContentSigner
      已过时。
      此类已被弃用。
      interface  ContentSignerParameters
      已过时。
      此类已被弃用。

    • Uses of 已过时的 in com.sun.java.accessibility.util

      Fields in com.sun.java.accessibility.util with annotations of type 已过时的
      Modifier and Type Field 描述
      protected static ActionListener AWTEventMonitor.actionListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static AdjustmentListener AWTEventMonitor.adjustmentListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static ComponentListener AWTEventMonitor.componentListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static Component AWTEventMonitor.componentWithFocus
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用; 使用getComponentWithFocus方法获取焦点的组件。
      protected static ContainerListener AWTEventMonitor.containerListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static FocusListener AWTEventMonitor.focusListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static ItemListener AWTEventMonitor.itemListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static KeyListener AWTEventMonitor.keyListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static MouseListener AWTEventMonitor.mouseListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static MouseMotionListener AWTEventMonitor.mouseMotionListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static TextListener AWTEventMonitor.textListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。
      protected static WindowListener AWTEventMonitor.windowListener
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此字段未使用。

    • Uses of 已过时的 in com.sun.javadoc

      Classes in com.sun.javadoc with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  AnnotatedType
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationDesc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      static interface  AnnotationDesc.ElementValuePair
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationTypeDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationTypeElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationValue
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ClassDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ConstructorDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  Doc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  DocErrorReporter
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      class  Doclet
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ExecutableMemberDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  FieldDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      class  LanguageVersion
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MemberDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MethodDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  PackageDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  Parameter
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ParameterizedType
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ParamTag
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ProgramElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  RootDoc
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  SeeTag
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  SerialFieldTag
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  SourcePosition
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  Tag
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ThrowsTag
      已过时。
      该包中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  Type
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  TypeVariable
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  WildcardType
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Methods in com.sun.javadoc with annotations of type 已过时的
      Modifier and Type 方法 描述
      ClassDoc[] ClassDoc.importedClasses​()
      已过时。
      导入声明是不应该在这里公开的实现细节。 另外，并不是所有导入的类都是通过单一类型导入的声明导入的。
      PackageDoc[] ClassDoc.importedPackages​()
      已过时。
      导入声明是不应该在这里公开的实现细节。 此外，此方法的返回类型不允许返回所有类型导入按需的声明。

    • Uses of 已过时的 in com.sun.jdi

      Classes in com.sun.jdi with annotations of type 已过时的
      Modifier and Type Class 描述
      class  InvalidCodeIndexException
      已过时。
      不再抛出此异常
      class  InvalidLineNumberException
      已过时。
      不再抛出此异常

    • Uses of 已过时的 in com.sun.security.auth

      Classes in com.sun.security.auth with annotations of type 已过时的
      Modifier and Type Class 描述
      class  PolicyFile
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由sun.security.provider.PolicyFile取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  SolarisNumericGroupPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixNumericGroupPrincipal取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  SolarisNumericUserPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixNumericUserPrincipal取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  SolarisPrincipal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK 1.4，由UnixPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。
      class  X500Principal
      不推荐用于删除：此API元素将在以后的版本中被删除。
      Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。

    • Uses of 已过时的 in com.sun.security.auth.module

      Classes in com.sun.security.auth.module with annotations of type 已过时的
      Modifier and Type Class 描述
      class  SolarisLoginModule
      不推荐用于删除：此API元素将在以后的版本中被删除。
      截至JDK1.4，由com.sun.security.auth.module.UnixLoginModule替代。 这个LoginModule已经完全被废弃了，这里允许平滑过渡到新的UnixLoginModule。 此类可能在将来的Java SE版本中被删除。
      class  SolarisSystem
      不推荐用于删除：此API元素将在以后的版本中被删除。
      替换为UnixSystem 。 此类可能在将来的Java SE版本中被删除。

    • Uses of 已过时的 in com.sun.tools.doclets

      Classes in com.sun.tools.doclets with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  Taglet
      已过时。
      该接口已被替换， Taglet取代。

    • Uses of 已过时的 in com.sun.tools.doclets.standard

      Classes in com.sun.tools.doclets.standard with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Standard
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该文件已被其替换， StandardDoclet取代。

    • Uses of 已过时的 in com.sun.tools.javadoc

      Classes in com.sun.tools.javadoc with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Main
      已过时。
      此类现在已被弃用，可能会在将来的版本中删除。 有关替换功能，请参阅javax.tools.ToolProvider::getSystemDocumentationTool和javax.tools.DocumentationTool 。

    • Uses of 已过时的 in java.applet

      Classes in java.applet with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Applet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      interface  AppletContext
      已过时。
      Applet API已被弃用。 详见java.applet package documentation 。
      interface  AppletStub
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      interface  AudioClip
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of 已过时的 in java.awt

      Classes in java.awt with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Event
      已过时。
      建议使用AWTEvent及其子类
      Fields in java.awt with annotations of type 已过时的
      Modifier and Type Field 描述
      static int Frame.CROSSHAIR_CURSOR
      已过时。
      由Cursor.CROSSHAIR_CURSOR取代。
      static int Frame.DEFAULT_CURSOR
      已过时。
      代之以Cursor.DEFAULT_CURSOR 。
      static int Frame.E_RESIZE_CURSOR
      已过时。
      代之以Cursor.E_RESIZE_CURSOR 。
      static int Frame.HAND_CURSOR
      已过时。
      取代Cursor.HAND_CURSOR 。
      static int Frame.MOVE_CURSOR
      已过时。
      取代Cursor.MOVE_CURSOR 。
      static int Frame.N_RESIZE_CURSOR
      已过时。
      由Cursor.N_RESIZE_CURSOR取代。
      static int Frame.NE_RESIZE_CURSOR
      已过时。
      代之以Cursor.NE_RESIZE_CURSOR 。
      static int Frame.NW_RESIZE_CURSOR
      已过时。
      代之以Cursor.NW_RESIZE_CURSOR 。
      protected static Cursor[] Cursor.predefined
      已过时。
      从JDK 1.7版开始，应该使用Cursor.getPredefinedCursor(int)方法。
      static int Frame.S_RESIZE_CURSOR
      已过时。
      替换为Cursor.S_RESIZE_CURSOR 。
      static int Frame.SE_RESIZE_CURSOR
      已过时。
      取代Cursor.SE_RESIZE_CURSOR 。
      static int Frame.SW_RESIZE_CURSOR
      已过时。
      代之以Cursor.SW_RESIZE_CURSOR 。
      static int Frame.TEXT_CURSOR
      已过时。
      代之以Cursor.TEXT_CURSOR 。
      static int Frame.W_RESIZE_CURSOR
      已过时。
      代之以Cursor.W_RESIZE_CURSOR 。
      static int Frame.WAIT_CURSOR
      已过时。
      替换为Cursor.WAIT_CURSOR 。
      Methods in java.awt with annotations of type 已过时的
      Modifier and Type 方法 描述
      boolean Component.action​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，应该在组件上注册此组件作为ActionListener，该组件将触发动作事件。
      void List.addItem​(String item)
      已过时。
      替换为add(String) 。
      void List.addItem​(String item, int index)
      已过时。
      换成add(String, int) 。
      void BorderLayout.addLayoutComponent​(String name, Component comp)
      已过时。
      替换为addLayoutComponent(Component, Object) 。
      void CardLayout.addLayoutComponent​(String name, Component comp)
      已过时。
      替换为addLayoutComponent(Component, Object) 。
      boolean List.allowsMultipleSelections​()
      已过时。
      从JDK 1.1版开始，由isMultipleMode()替代。
      void TextArea.appendText​(String str)
      已过时。
      从JDK 1.1版开始，由append(String)替代。
      void Window.applyResourceBundle​(String rbName)
      已过时。
      截至J2SE 1.4，由Component.applyComponentOrientation替代。
      void Window.applyResourceBundle​(ResourceBundle rb)
      已过时。
      截至J2SE 1.4，由Component.applyComponentOrientation替代。
      Rectangle Component.bounds​()
      已过时。
      从JDK 1.1版开始，由getBounds()取代。
      void List.clear​()
      已过时。
      从JDK 1.1版开始，由removeAll()替代。
      int Container.countComponents​()
      已过时。
      从JDK 1.1版开始，由getComponentCount（）替换。
      int Choice.countItems​()
      已过时。
      从JDK 1.1版开始，由getItemCount()替代。
      int List.countItems​()
      已过时。
      从JDK 1.1版开始，由getItemCount()替代。
      int Menu.countItems​()
      已过时。
      从JDK 1.1版开始，由getItemCount()替代。
      int MenuBar.countMenus​()
      已过时。
      从JDK 1.1版开始，由getMenuCount()替代。
      void List.delItem​(int position)
      已过时。
      替换为remove(String)和remove(int) 。
      void List.delItems​(int start, int end)
      已过时。
      从JDK 1.1版开始，未来不会公开使用。 这种方法只能作为一个包私有方法保留。
      void Component.deliverEvent​(Event e)
      已过时。
      自JDK 1.1版起，由dispatchEvent(AWTEvent e)替代。
      void Container.deliverEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent(AWTEvent e)替代
      void Component.disable​()
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      void MenuItem.disable​()
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      void Component.enable​()
      已过时。
      截至JDK 1.1版，由setEnabled(boolean)替换。
      void Component.enable​(boolean b)
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      void MenuItem.enable​()
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)代替。
      void MenuItem.enable​(boolean b)
      已过时。
      从JDK 1.1版开始，由setEnabled(boolean)替代。
      void Graphics.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      void PrintJob.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      Rectangle Polygon.getBoundingBox​()
      已过时。
      从JDK 1.1版开始，由getBounds()替代。
      Rectangle Graphics.getClipRect​()
      已过时。
      从JDK 1.1版开始，由getClipBounds()替代。
      Checkbox CheckboxGroup.getCurrent​()
      已过时。
      从JDK 1.1版开始，由getSelectedCheckbox()替代。
      int Frame.getCursorType​()
      已过时。
      截至JDK 1.1版，由Component.getCursor()取代。
      abstract String[] Toolkit.getFontList​()
      已过时。
      见GraphicsEnvironment.getAvailableFontFamilyNames()
      abstract FontMetrics Toolkit.getFontMetrics​(Font font)
      已过时。
      从JDK 1.2版开始，由Font方法getLineMetrics 。
      int Scrollbar.getLineIncrement​()
      已过时。
      从JDK 1.1版开始，由getUnitIncrement()替代。
      int FontMetrics.getMaxDecent​()
      已过时。
      截至JDK 1.1.1版，由getMaxDescent()替代。
      static ComponentOrientation ComponentOrientation.getOrientation​(ResourceBundle bdl)
      已过时。
      从J2SE 1.4起，使用ComponentOrientation.getOrientation(java.util.Locale) 。
      int Scrollbar.getPageIncrement​()
      已过时。
      从JDK 1.1版开始，由getBlockIncrement()替代。
      int Scrollbar.getVisible​()
      已过时。
      从JDK 1.1版开始，由getVisibleAmount()替代。
      boolean Component.gotFocus​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
      boolean Component.handleEvent​(Event evt)
      已过时。
      从JDK版本1.1替换为processEvent（AWTEvent）。
      void Component.hide​()
      已过时。
      从JDK 1.1版开始，由setVisible(boolean)替代。
      void Dialog.hide​()
      已过时。
      截至JDK 1.5版，由setVisible(boolean)取代。
      void Window.hide​()
      已过时。
      从JDK版本1.5开始，由Window.setVisible(boolean)替代。
      void TextArea.insertText​(String str, int pos)
      已过时。
      从JDK 1.1版开始，由insert(String, int)取代。
      Insets Container.insets​()
      已过时。
      自JDK 1.1版起，由getInsets()取代。
      boolean Component.inside​(int x, int y)
      已过时。
      从JDK 1.1版开始，由contains（int，int）替换。
      boolean Polygon.inside​(int x, int y)
      已过时。
      从JDK 1.1版起，由contains(int, int)取代。
      boolean Rectangle.inside​(int X, int Y)
      已过时。
      从JDK 1.1版开始，由contains(int, int)取代。
      boolean Component.isFocusTraversable​()
      已过时。
      截至1.4，由isFocusable()取代。
      boolean List.isSelected​(int index)
      已过时。
      自JDK 1.1版起，由isIndexSelected(int)取代。
      boolean Component.keyDown​(Event evt, int key)
      已过时。
      从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
      boolean Component.keyUp​(Event evt, int key)
      已过时。
      从JDK 1.1版开始，由processKeyEvent（KeyEvent）替换。
      void Component.layout​()
      已过时。
      从JDK 1.1版开始，由doLayout()替代。
      void Container.layout​()
      已过时。
      从JDK 1.1版开始，由doLayout()替代。
      void ScrollPane.layout​()
      已过时。
      从JDK 1.1版开始，由doLayout()替代。
      Component Component.locate​(int x, int y)
      已过时。
      从JDK 1.1版开始，由getComponentAt（int，int）替换。
      Component Container.locate​(int x, int y)
      已过时。
      从JDK 1.1版开始，由getComponentAt(int, int)代替。
      Point Component.location​()
      已过时。
      从JDK 1.1版开始，由getLocation()替代。
      boolean Component.lostFocus​(Event evt, Object what)
      已过时。
      从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。
      Dimension Component.minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      Dimension Container.minimumSize​()
      已过时。
      截至JDK 1.1版，由getMinimumSize()取代。
      Dimension List.minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      Dimension List.minimumSize​(int rows)
      已过时。
      从JDK 1.1版开始，由getMinimumSize(int)替代。
      Dimension TextArea.minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()替代。
      Dimension TextArea.minimumSize​(int rows, int columns)
      已过时。
      从JDK 1.1版开始，由getMinimumSize(int, int)替代。
      Dimension TextField.minimumSize​()
      已过时。
      从JDK 1.1版开始，由getMinimumSize()代替。
      Dimension TextField.minimumSize​(int columns)
      已过时。
      从JDK 1.1版开始，由getMinimumSize(int)替代。
      boolean Component.mouseDown​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean Component.mouseDrag​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
      boolean Component.mouseEnter​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean Component.mouseExit​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      boolean Component.mouseMove​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseMotionEvent（MouseEvent）替换。
      boolean Component.mouseUp​(Event evt, int x, int y)
      已过时。
      从JDK 1.1版开始，由processMouseEvent（MouseEvent）替换。
      void Component.move​(int x, int y)
      已过时。
      截至JDK 1.1版，由setLocation(int, int)取代。
      void Rectangle.move​(int x, int y)
      已过时。
      从JDK 1.1版开始，由setLocation(int, int)替代。
      void Component.nextFocus​()
      已过时。
      从JDK 1.1版开始，由transferFocus（）替换。
      boolean Component.postEvent​(Event e)
      已过时。
      从JDK 1.1版开始，由dispatchEvent（AWTEvent）替换。
      boolean MenuComponent.postEvent​(Event evt)
      已过时。
      从JDK 1.1版开始，由dispatchEvent替代。
      boolean MenuContainer.postEvent​(Event evt)
      已过时。
      由JDK版本1.1替换为dispatchEvent（AWTEvent）。
      boolean Window.postEvent​(Event e)
      已过时。
      由JDK 1.1版本替换为dispatchEvent(AWTEvent) 。
      Dimension Component.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension Container.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension List.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension List.preferredSize​(int rows)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int)替代。
      Dimension TextArea.preferredSize​()
      已过时。
      截至JDK 1.1版，由getPreferredSize()取代。
      Dimension TextArea.preferredSize​(int rows, int columns)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int, int)代替。
      Dimension TextField.preferredSize​()
      已过时。
      从JDK 1.1版开始，由getPreferredSize()替代。
      Dimension TextField.preferredSize​(int columns)
      已过时。
      从JDK 1.1版开始，由getPreferredSize(int)代替。
      protected static void AWTKeyStroke.registerSubclass​(Class<?> subclass)
      已过时。
      void TextArea.replaceText​(String str, int start, int end)
      已过时。
      从JDK 1.1版开始，由replaceRange(String, int, int)取代。
      void Component.reshape​(int x, int y, int width, int height)
      已过时。
      从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
      void Rectangle.reshape​(int x, int y, int width, int height)
      已过时。
      从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
      void Window.reshape​(int x, int y, int width, int height)
      已过时。
      从JDK 1.1版开始，由setBounds(int, int, int, int)替代。
      void Component.resize​(int width, int height)
      已过时。
      从JDK 1.1版开始，由setSize(int, int)替代。
      void Component.resize​(Dimension d)
      已过时。
      从JDK 1.1版开始，由setSize(Dimension)替代。
      void Rectangle.resize​(int width, int height)
      已过时。
      从JDK 1.1版开始，由setSize(int, int)替代。
      void CheckboxGroup.setCurrent​(Checkbox box)
      已过时。
      从JDK 1.1版开始，由setSelectedCheckbox(Checkbox)取代。
      void Frame.setCursor​(int cursorType)
      已过时。
      从JDK 1.1版开始，由Component.setCursor(Cursor)替代。
      void TextField.setEchoCharacter​(char c)
      已过时。
      从JDK 1.1版开始，由setEchoChar(char)替代。
      void Scrollbar.setLineIncrement​(int v)
      已过时。
      从JDK 1.1版开始，由setUnitIncrement(int)替代。
      void List.setMultipleSelections​(boolean b)
      已过时。
      从JDK 1.1版开始，由setMultipleMode(boolean)替代。
      void Scrollbar.setPageIncrement​(int v)
      已过时。
      从JDK 1.1版开始，由setBlockIncrement()取代。
      void Component.show​()
      已过时。
      从JDK 1.1版开始，由setVisible(boolean)替代。
      void Component.show​(boolean b)
      已过时。
      从JDK 1.1版开始，由setVisible(boolean)替代。
      void Dialog.show​()
      已过时。
      从JDK版本1.5开始，由setVisible(boolean)替代。
      void Window.show​()
      已过时。
      从JDK版本1.5开始，由Window.setVisible(boolean)替代。
      Dimension Component.size​()
      已过时。
      从JDK 1.1版开始，由getSize()替代。
      Constructors in java.awt with annotations of type 已过时的
      Constructor 描述
      AWTEvent​(Event event)
      已过时。
      建议使用AWTEvent(Object, int)

    • Uses of 已过时的 in java.awt.color

      Methods in java.awt.color with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void ICC_Profile.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of 已过时的 in java.awt.datatransfer

      Fields in java.awt.datatransfer with annotations of type 已过时的
      Modifier and Type Field 描述
      static DataFlavor DataFlavor.plainTextFlavor
      已过时。
      截至1.3。 使用DataFlavor.getReaderForText(java.awt.datatransfer.Transferable)而不是Transferable.getTransferData(DataFlavor.plainTextFlavor) 。
      Methods in java.awt.datatransfer with annotations of type 已过时的
      Modifier and Type 方法 描述
      boolean DataFlavor.equals​(String s)
      已过时。
      与hashCode()合同不一致，请改用DataFlavor.isMimeTypeEqual(String) 。
      protected String DataFlavor.normalizeMimeType​(String mimeType)
      已过时。
      此方法从1.1开始就不会被此实现所调用
      protected String DataFlavor.normalizeMimeTypeParameter​(String parameterName, String parameterValue)
      已过时。
      此方法从1.1开始就不会被此实现所调用

    • Uses of 已过时的 in java.awt.event

      Fields in java.awt.event with annotations of type 已过时的
      Modifier and Type Field 描述
      static int InputEvent.ALT_GRAPH_MASK
      已过时。
      建议使用ALT_GRAPH_DOWN_MASK和InputEvent.getModifiersEx()
      static int InputEvent.ALT_MASK
      已过时。
      建议使用ALT_DOWN_MASK和InputEvent.getModifiersEx()
      static int InputEvent.BUTTON1_MASK
      已过时。
      建议使用BUTTON1_DOWN_MASK和InputEvent.getModifiersEx()
      static int InputEvent.BUTTON2_MASK
      已过时。
      建议使用BUTTON2_DOWN_MASK和InputEvent.getModifiersEx() 。 请注意，BUTTON2_MASK的值与ALT_MASK相同。
      static int InputEvent.BUTTON3_MASK
      已过时。
      建议使用BUTTON3_DOWN_MASK和InputEvent.getModifiersEx() 。 请注意，BUTTON3_MASK与META_MASK具有相同的值。
      static int InputEvent.CTRL_MASK
      已过时。
      建议使用CTRL_DOWN_MASK和InputEvent.getModifiersEx()
      static int InputEvent.META_MASK
      已过时。
      建议使用META_DOWN_MASK和InputEvent.getModifiersEx()
      static int InputEvent.SHIFT_MASK
      已过时。
      建议使用SHIFT_DOWN_MASK和InputEvent.getModifiersEx()
      Methods in java.awt.event with annotations of type 已过时的
      Modifier and Type 方法 描述
      static String KeyEvent.getKeyModifiersText​(int modifiers)
      已过时。
      建议使用扩展修饰键和InputEvent.getModifiersExText(int)
      int InputEvent.getModifiers​()
      已过时。
      建议使用扩展修饰键和InputEvent.getModifiersEx()
      void KeyEvent.setModifiers​(int modifiers)
      已过时。
      截至JDK1.1.4
      Constructors in java.awt.event with annotations of type 已过时的
      Constructor 描述
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode)
      已过时。
      截至JDK1.1; 改用KeyEvent(Component, int, long, int, int, char)

    • Uses of 已过时的 in java.awt.image

      Methods in java.awt.image with annotations of type 已过时的
      Modifier and Type 方法 描述
      void ColorModel.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      void IndexColorModel.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of 已过时的 in java.awt.image.renderable

      Methods in java.awt.image.renderable with annotations of type 已过时的
      Modifier and Type 方法 描述
      void RenderContext.concetenateTransform​(AffineTransform modTransform)
      已过时。
      代之以concatenateTransform(AffineTransform) 。
      void RenderContext.preConcetenateTransform​(AffineTransform modTransform)
      已过时。
      替换为preConcatenateTransform(AffineTransform) 。

    • Uses of 已过时的 in java.beans

      Classes in java.beans with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  AppletInitializer
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      Methods in java.beans with annotations of type 已过时的
      Modifier and Type 方法 描述
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
      已过时。
      建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of 已过时的 in java.io

      Classes in java.io with annotations of type 已过时的
      Modifier and Type Class 描述
      class  LineNumberInputStream
      已过时。
      该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。
      class  StringBufferInputStream
      已过时。
      此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。
      Methods in java.io with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void FileInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void FileOutputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      String DataInputStream.readLine​()
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1开始，读取文本行的首选方式是通过BufferedReader.readLine()方法。 使用DataInputStream类读取行的程序可以转换为使用BufferedReader类替换形式的代码：
           DataInputStream d = new DataInputStream(in);
      有：
           BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
      String ObjectInputStream.readLine​()
      已过时。
      此方法无法将字节正确转换为字符。 有关详细信息和替代方案，请参阅DataInputStream。
      String ByteArrayOutputStream.toString​(int hibyte)
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1的，要做到这一点的优选方法是通过toString(String enc)方法，它需要一个编码名称参数或toString()方法，它使用平台的默认字符编码。
      URL File.toURL​()
      已过时。
      此方法不会自动转义URL中非法的字符。 建议在新的代码转换的抽象路径到URL通过先转换成URI，经由toURI方法，然后经由转换URI为URL URI.toURL方法。
      abstract void ObjectOutputStream.PutField.write​(ObjectOutput out)
      已过时。
      此方法不会以适当的格式写入此PutField对象所包含的值，并可能导致序列化流的损坏。 写PutField数据的正确方法是通过调用ObjectOutputStream.writeFields()方法。
      Constructors in java.io with annotations of type 已过时的
      Constructor 描述
      StreamTokenizer​(InputStream is)
      已过时。
      从JDK版本1.1开始，将输入流标记化的首选方法是将其转换为字符流，例如：
         Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);

    • Uses of 已过时的 in java.lang

      Classes in java.lang with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Compiler
      不推荐用于删除：此API元素将在以后的版本中被删除。
      JIT编译器及其技术变化太大，可以通过标准化界面有效地进行控制。 因此，许多JIT编译器实现忽略此接口，而是由特定于实现的机制（如命令行选项）控制。 此类可能在将来的Java SE版本中被删除。
      Fields in java.lang with annotations of type 已过时的
      Modifier and Type Field 描述
      protected boolean SecurityManager.inCheck
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此字段在将来的Java SE版本中可能会被删除。
      static Character.UnicodeBlock Character.UnicodeBlock.SURROGATES_AREA
      已过时。
      取而代之的SURROGATES_AREA ，使用Character.UnicodeBlock.HIGH_SURROGATES ， Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES ，并Character.UnicodeBlock.LOW_SURROGATES 。 这些常量符合Unicode标准的块定义。 Character.UnicodeBlock.of(char)和Character.UnicodeBlock.of(int)方法返回标准常量。
      Methods in java.lang with annotations of type 已过时的
      Modifier and Type 方法 描述
      boolean ThreadGroup.allowThreadSuspension​(boolean b)
      已过时。
      此呼叫的定义取决于ThreadGroup.suspend() ，已被弃用。 此外，从未指定此调用的行为。
      void SecurityManager.checkAwtEventQueueAccess​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此方法最初用于检查调用线程是否可以访问AWT事件队列。 该方法已被废弃，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessEventQueue") 。 此方法在将来的Java SE版本中可能会被删除。
      void SecurityManager.checkMemberAccess​(Class<?> clazz, int which)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法依赖于调用者的堆栈深度为4，容易出错，并且不能由运行时执行。 该方法的用户应直接调用SecurityManager.checkPermission(java.security.Permission) 。 此方法在将来的Java SE版本中可能会被删除。
      void SecurityManager.checkMulticast​(InetAddress maddr, byte ttl)
      已过时。
      请改用#checkPermission（java.security.Permission）
      void SecurityManager.checkSystemClipboardAccess​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法最初用于检查调用线程是否可以访问系统剪贴板。 该方法已被废弃，代码应使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("accessClipboard") 。 此方法在将来的Java SE版本中可能会被删除。
      boolean SecurityManager.checkTopLevelWindow​(Object window)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法最初用于检查调用线程是否被信任以启动顶级窗口。 该方法已经过时，代码应该使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("showWindowWithoutWarningBanner") 。 此方法在将来的Java SE版本中可能会被删除。
      protected int SecurityManager.classDepth​(String name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
      protected int SecurityManager.classLoaderDepth​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission呼叫。 此方法在将来的Java SE版本中可能会被删除。
      int Thread.countStackFrames​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此呼叫的定义取决于Thread.suspend() ，已被弃用。 此外，此呼叫的结果从未明确。 此方法在将来的Java SE版本中可能会被删除。
      protected ClassLoader SecurityManager.currentClassLoader​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。
      protected Class<?> SecurityManager.currentLoadedClass​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
      protected Class<?> ClassLoader.defineClass​(byte[] b, int off, int len)
      已过时。
      由defineClass(String, byte[], int, int)取代
      void Thread.destroy​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      这种方法最初是为了销毁这个线程而没有任何清理。 它所持有的任何监视器都将保持锁定。 但是，该方法从未实现。 如果要实施，那么它将是Thread.suspend()的方式会是死锁的。 如果目标线程在销毁时保护关键系统资源的锁，则无法再次访问该资源。 如果另一个线程曾尝试锁定此资源，将导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
      protected void Object.finalize​()
      已过时。
      定稿机制本质上是有问题的。 定稿可能导致性能问题，死锁和挂起。 敲定错误可能导致资源泄漏; 如果不再需要，无法取消定稿; 并且对不同对象的finalize方法的调用中没有指定排序。 此外，关于定稿的时间并不保证。 finalize方法可能只有在无限延迟之后才能在可终结对象上调用，如果有的话。 其实例持有非堆资源的类应提供一种方法来实现这些资源的显式释放，如果合适，它们还应实现AutoCloseable 。 当对象变得不可达时， Cleaner和PhantomReference提供了更灵活和更有效的方式来释放资源。
      void String.getBytes​(int srcBegin, int srcEnd, byte[] dst, int dstBegin)
      已过时。
      此方法无法将字符正确转换为字节。 从JDK 1.1开始，首选的方法是通过使用平台默认字符集的String.getBytes()方法。
      boolean SecurityManager.getInCheck​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
      InputStream Runtime.getLocalizedInputStream​(InputStream in)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1开始，将本地编码中的字节流转换为Unicode中的字符流的首选方法是通过InputStreamReader和BufferedReader类。 此方法在将来的Java SE版本中可能会被删除。
      OutputStream Runtime.getLocalizedOutputStream​(OutputStream out)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      从JDK 1.1，将Unicode字符流转换为本地编码字节流的首选方法是通过OutputStreamWriter ， BufferedWriter ，和PrintWriter类。 此方法在将来的Java SE版本中可能会被删除。
      protected 软件包 ClassLoader.getPackage​(String name)
      已过时。
      如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则软件包暴露的属性可能不如预期的那样其余的程序。 例如， 软件包将仅公开由父加载程序定义的package-info.class文件中的注释，即使注释存在于由子加载器定义的package-info.class文件中。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
      static 软件包 Package.getPackage​(String name)
      已过时。
      如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包只会暴露由父加载程序定义的package-info.class文件中的注释，即使子载入程序定义的package-info.class文件中存在注释。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
      protected boolean SecurityManager.inClass​(String name)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
      protected boolean SecurityManager.inClassLoader​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。
      static boolean Character.isJavaLetter​(char ch)
      已过时。
      替换为isJavaIdentifierStart（char）。
      static boolean Character.isJavaLetterOrDigit​(char ch)
      已过时。
      由isJavaIdentifierPart（char）替代。
      static boolean Character.isSpace​(char ch)
      已过时。
      替换为isWhitespace（char）。
      T Class.newInstance​()
      已过时。
      此方法传播由nullary构造函数抛出的任何异常，包括已检查的异常。 使用此方法有效地绕过编译器异常检查，否则将由编译器执行。 Constructor.newInstance方法通过在（已选） InvocationTargetException中包装构造函数抛出的任何异常来避免此问题。

      电话

         clazz.newInstance()
      可以替换
         clazz.getDeclaredConstructor().newInstance()
      后一个调用序列被推断为能够抛出额外的异常类型InvocationTargetException和NoSuchMethodException 。 这两个异常类型都是ReflectiveOperationException的子类。
      void Thread.resume​()
      已过时。
      该方法仅供Thread.suspend()使用，由于它是死锁倾向，因此已被弃用。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
      void ThreadGroup.resume​()
      已过时。
      该方法仅与Thread.suspend和ThreadGroup.suspend一起使用，它们都已被弃用，因为它们本质上是死锁易受影响的。 详见Thread.suspend() 。
      static void Runtime.runFinalizersOnExit​(boolean value)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
      static void System.runFinalizersOnExit​(boolean value)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
      void Thread.stop​()
      已过时。
      这种方法本质上是不安全的。 使用Thread.stop停止线程可以解锁所有已锁定的监视器（作为未经检查的ThreadDeath异常在堆栈中传播的自然结果）。 如果先前受这些监视器保护的任何对象处于不一致的状态，则损坏的对象将变得对其他线程可见，可能导致任意行为。 stop许多用途应该由代码替代，只需修改一些变量来指示目标线程应该停止运行。 目标线程应该定期检查此变量，如果变量表示要停止运行，则以有序方式从其运行方法返回。 如果目标线程等待长时间（例如，在条件变量上），则应使用interrupt方法来中断等待。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
      void Thread.stop​(Throwable obj)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法最初设计为强制线程停止并抛出给定的Throwable作为例外。 它本质上是不安全的（详见Thread.stop() ），此外还可用于生成目标线程未准备处理的异常。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
      void ThreadGroup.stop​()
      已过时。
      这种方法本质上是不安全的。 详见Thread.stop() 。
      void Thread.suspend​()
      已过时。
      这种方法已被弃用，因为它本身就是死锁的。 如果目标线程在挂起时保护关键系统资源的监视器上的锁定，则在目标线程恢复之前，线程不能访问该资源。 如果要恢复目标线程的线程在调用resume之前尝试锁定此监视器， resume导致死锁。 这种僵局通常表现为“冻结”过程。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。
      void ThreadGroup.suspend​()
      已过时。
      这种方法本质上是死锁的。 详见Thread.suspend() 。
      void Runtime.traceInstructions​(boolean on)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法旨在控制指令跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
      void Runtime.traceMethodCalls​(boolean on)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      此方法旨在控制方法调用跟踪。 它已经被JVM特定的跟踪机制所取代。 此方法在将来的Java SE版本中可能会被删除。
      Constructors in java.lang with annotations of type 已过时的
      Constructor 描述
      Boolean​(boolean value)
      已过时。
      很少使用这个构造函数。 静态工厂Boolean.valueOf(boolean)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。 还可以考虑使用最终的字段Boolean.TRUE和Boolean.FALSE 。
      Boolean​(String s)
      已过时。
      很少使用这个构造函数。 使用Boolean.parseBoolean(String)将字符串转换为boolean原语，或使用Boolean.valueOf(String)将字符串转换为Boolean对象。
      Byte​(byte value)
      已过时。
      很少使用这个构造函数。 静态工厂Byte.valueOf(byte)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Byte​(String s)
      已过时。
      很少使用这个构造函数。 使用Byte.parseByte(String)将字符串转换为byte原语，或使用Byte.valueOf(String)将字符串转换为Byte对象。
      Character​(char value)
      已过时。
      很少使用这个构造函数。 静态工厂Character.valueOf(char)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Double​(double value)
      已过时。
      很少使用这个构造函数。 静态工厂Double.valueOf(double)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
      Double​(String s)
      已过时。
      很少使用这个构造函数。 使用Double.parseDouble(String)将字符串转换为double原语，或使用Double.valueOf(String)将字符串转换为Double对象。
      Float​(double value)
      已过时。
      很少使用这个构造函数。 相反，使用静态工厂方法Float.valueOf(float)方法如下： Float.valueOf((float)value) 。
      Float​(float value)
      已过时。
      很少使用这个构造函数。 静态工厂Float.valueOf(float)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Float​(String s)
      已过时。
      很少使用这个构造函数。 使用Float.parseFloat(String)将字符串转换为float原语，或使用Float.valueOf(String)将字符串转换为Float对象。
      Integer​(int value)
      已过时。
      很少使用这个构造函数。 静态工厂Integer.valueOf(int)通常是一个更好的选择，因为它可能产生明显更好的空间和时间性能。
      Integer​(String s)
      已过时。
      很少使用这个构造函数。 使用Integer.parseInt(String)将字符串转换为int原语，或使用Integer.valueOf(String)将字符串转换为Integer对象。
      Long​(long value)
      已过时。
      很少使用这个构造函数。 静态工厂Long.valueOf(long)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
      Long​(String s)
      已过时。
      很少使用这个构造函数。 使用Long.parseLong(String)将字符串转换为long原语，或使用Long.valueOf(String)将字符串转换为Long对象。
      Short​(short value)
      已过时。
      很少使用这个构造函数。 静态工厂Short.valueOf(short)通常是更好的选择，因为它可能产生明显更好的空间和时间性能。
      Short​(String s)
      已过时。
      很少使用这个构造函数。 使用Short.parseShort(String)将字符串转换为short原语，或使用Short.valueOf(String)将字符串转换为Short对象。
      String​(byte[] ascii, int hibyte)
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过String构造函数获取Charset ，字符集名称，或者使用平台的默认字符集。
      String​(byte[] ascii, int hibyte, int offset, int count)
      已过时。
      此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过采用Charset ，字符集名称的String构造函数，或者使用平台的默认字符集。

    • Uses of 已过时的 in java.lang.reflect

      Methods in java.lang.reflect with annotations of type 已过时的
      Modifier and Type 方法 描述
      static Class<?> Proxy.getProxyClass​(ClassLoader loader, Class<?>... interfaces)
      已过时。
      在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在不可访问的代理类上调用时抛出IllegalAccessException 。 使用Proxy.newProxyInstance(ClassLoader, Class[], InvocationHandler)代替创建一个代理实例。
      boolean AccessibleObject.isAccessible​()
      已过时。
      此方法已被弃用，因为它的名称提示它检查反射对象是否可访问，当它实际指示是否抑制对Java语言访问控制的检查。 此方法可能会在调用者可访问的反射对象上返回false 。 要测试此反射对象是否可访问，应使用AccessibleObject.canAccess(Object) 。

    • Uses of 已过时的 in java.math

      Fields in java.math with annotations of type 已过时的
      Modifier and Type Field 描述
      static int BigDecimal.ROUND_CEILING
      已过时。
      改用RoundingMode.CEILING 。
      static int BigDecimal.ROUND_DOWN
      已过时。
      改用RoundingMode.DOWN 。
      static int BigDecimal.ROUND_FLOOR
      已过时。
      改用RoundingMode.FLOOR 。
      static int BigDecimal.ROUND_HALF_DOWN
      已过时。
      请改用RoundingMode.HALF_DOWN 。
      static int BigDecimal.ROUND_HALF_EVEN
      已过时。
      改用RoundingMode.HALF_EVEN 。
      static int BigDecimal.ROUND_HALF_UP
      已过时。
      改用RoundingMode.HALF_UP 。
      static int BigDecimal.ROUND_UNNECESSARY
      已过时。
      改用RoundingMode.UNNECESSARY 。
      static int BigDecimal.ROUND_UP
      已过时。
      改用RoundingMode.UP 。
      Methods in java.math with annotations of type 已过时的
      Modifier and Type 方法 描述
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int roundingMode)
      已过时。
      应该优先使用该方法BigDecimal.divide(BigDecimal, RoundingMode) 。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int scale, int roundingMode)
      已过时。
      应该优先使用方法BigDecimal.divide(BigDecimal, int, RoundingMode) ，这种传统方法。
      BigDecimal BigDecimal.setScale​(int newScale, int roundingMode)
      已过时。
      应该优先使用方法BigDecimal.setScale(int, RoundingMode) ，这种传统方法。

    • Uses of 已过时的 in java.net

      Fields in java.net with annotations of type 已过时的
      Modifier and Type Field 描述
      static int HttpURLConnection.HTTP_SERVER_ERROR
      已过时。
      它是错误的，不应该存在。
      Methods in java.net with annotations of type 已过时的
      Modifier and Type 方法 描述
      static String URLDecoder.decode​(String s)
      已过时。
      结果字符串可能会因平台的默认编码而异。 而是使用decode（String，String）方法来指定编码。
      static String URLEncoder.encode​(String s)
      已过时。
      结果字符串可能会因平台的默认编码而异。 而是使用encode（String，String）方法来指定编码。
      static String URLConnection.getDefaultRequestProperty​(String key)
      已过时。
      在获得适当的URLConnection实例之后，应该使用实例特定的getRequestProperty方法。
      protected abstract byte DatagramSocketImpl.getTTL​()
      已过时。
      使用getTimeToLive代替。
      byte MulticastSocket.getTTL​()
      已过时。
      使用getTimeToLive方法，它返回一个int而不是一个字节 。
      void MulticastSocket.send​(DatagramPacket p, byte ttl)
      已过时。
      使用以下代码或其等价物：...... int ttl = mcastSocket.getTimeToLive（）;
mcastSocket.setTimeToLive（newttl）;
mcastSocket.send（P）;
mcastSocket.setTimeToLive（TTL）;
......
      static void URLConnection.setDefaultRequestProperty​(String key, String value)
      已过时。
      在获得适当的URLConnection实例之后，应该使用实例特定的setRequestProperty方法。 调用此方法将不起作用。
      protected abstract void DatagramSocketImpl.setTTL​(byte ttl)
      已过时。
      使用setTimeToLive代替。
      void MulticastSocket.setTTL​(byte ttl)
      已过时。
      使用setTimeToLive方法，它使用int而不是byte作为ttl的类型。
      protected void URLStreamHandler.setURL​(URL u, String protocol, String host, int port, String file, String ref)
      已过时。
      使用setURL（URL，String，String，int，String，String，String，String）;
      Constructors in java.net with annotations of type 已过时的
      Constructor 描述
      Socket​(String host, int port, boolean stream)
      已过时。
      使用DatagramSocket代替UDP传输。
      Socket​(InetAddress host, int port, boolean stream)
      已过时。
      使用DatagramSocket代替UDP传输。

    • Uses of 已过时的 in java.rmi

      Classes in java.rmi with annotations of type 已过时的
      Modifier and Type Class 描述
      class  RMISecurityException
      已过时。
      改用SecurityException 。 应用代码不应该直接引用这个类，而且RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。
      class  RMISecurityManager
      已过时。
      改用SecurityManager 。
      class  ServerRuntimeException
      已过时。
      没有替换
      Constructors in java.rmi with annotations of type 已过时的
      Constructor 描述
      RMISecurityException​(String name)
      已过时。
      没有替换
      RMISecurityException​(String name, String arg)
      已过时。
      没有替换
      ServerRuntimeException​(String s, 异常 ex)
      已过时。
      没有替换

    • Uses of 已过时的 in java.rmi.dgc

      Methods in java.rmi.dgc with annotations of type 已过时的
      Modifier and Type 方法 描述
      static boolean VMID.isUnique​()
      已过时。

    • Uses of 已过时的 in java.rmi.registry

      Classes in java.rmi.registry with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  RegistryHandler
      已过时。
      没有替换
      Methods in java.rmi.registry with annotations of type 已过时的
      Modifier and Type 方法 描述
      Registry RegistryHandler.registryImpl​(int port)
      已过时。
      没有替换。 从Java 2平台v1.2起，RMI不再使用RegistryHandler来获取注册表的实现。
      Registry RegistryHandler.registryStub​(String host, int port)
      已过时。
      没有替换。 从Java 2平台v1.2起，RMI不再使用RegistryHandler获取注册表的存根。

    • Uses of 已过时的 in java.rmi.server

      Classes in java.rmi.server with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  LoaderHandler
      已过时。
      没有替换
      class  LogStream
      已过时。
      没有替换
      class  Operation
      已过时。
      没有替换
      interface  RemoteCall
      已过时。
      没有替换。
      class  RemoteStub
      已过时。
      静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。
      interface  ServerRef
      已过时。
      没有替换 此接口未使用，已过时。
      interface  Skeleton
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SkeletonMismatchException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SkeletonNotFoundException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SocketSecurityException
      已过时。
      这个班已经过时了 改用ExportException 。
      Methods in java.rmi.server with annotations of type 已过时的
      Modifier and Type 方法 描述
      void Skeleton.dispatch​(Remote obj, RemoteCall theCall, int opnum, long hash)
      已过时。
      没有替换
      void RemoteCall.done​()
      已过时。
      没有替换
      void RemoteRef.done​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
      void RemoteCall.executeCall​()
      已过时。
      没有替换
      static RemoteStub UnicastRemoteObject.exportObject​(Remote obj)
      已过时。
      此方法已被弃用，因为它仅支持静态存根。 请改用exportObject(Remote, port)或exportObject(Remote, port, csf, ssf) 。
      static PrintStream LogStream.getDefaultStream​()
      已过时。
      没有替换
      ObjectInput RemoteCall.getInputStream​()
      已过时。
      没有替换
      String Operation.getOperation​()
      已过时。
      没有替换
      Operation[] Skeleton.getOperations​()
      已过时。
      没有替换
      OutputStream LogStream.getOutputStream​()
      已过时。
      没有替换
      ObjectOutput RemoteCall.getOutputStream​()
      已过时。
      没有替换
      ObjectOutput RemoteCall.getResultStream​(boolean success)
      已过时。
      没有替换
      Object LoaderHandler.getSecurityContext​(ClassLoader loader)
      已过时。
      没有替换
      static Object RMIClassLoader.getSecurityContext​(ClassLoader loader)
      已过时。
      没有替换。 从Java 2平台v1.2开始，RMI不再使用此方法来获取类加载器的安全上下文。
      void RemoteRef.invoke​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
      Class<?> LoaderHandler.loadClass​(String name)
      已过时。
      没有替换
      Class<?> LoaderHandler.loadClass​(URL codebase, String name)
      已过时。
      没有替换
      static Class<?> RMIClassLoader.loadClass​(String name)
      已过时。
      替换为loadClass(String,String)方法
      static LogStream LogStream.log​(String name)
      已过时。
      没有替换
      RemoteCall RemoteRef.newCall​(RemoteObject obj, Operation[] op, int opnum, long hash)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法调用的顺序上短截线的远程引用（的newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回的值。
      static int LogStream.parseLevel​(String s)
      已过时。
      没有替换
      void RemoteCall.releaseInputStream​()
      已过时。
      没有替换
      void RemoteCall.releaseOutputStream​()
      已过时。
      没有替换
      static void LogStream.setDefaultStream​(PrintStream newDefault)
      已过时。
      没有替换
      void LogStream.setOutputStream​(OutputStream out)
      已过时。
      没有替换
      protected static void RemoteStub.setRef​(RemoteStub stub, RemoteRef ref)
      已过时。
      没有替换 setRef方法用于设置远程存根的远程引用。 这是不必要的，因为可以使用RemoteStub(RemoteRef)构造函数通过远程引用创建和初始化RemoteStub s。
      String LogStream.toString​()
      已过时。
      没有替换
      String Operation.toString​()
      已过时。
      没有替换
      void LogStream.write​(byte[] b, int off, int len)
      已过时。
      没有替换
      void LogStream.write​(int b)
      已过时。
      没有替换
      Constructors in java.rmi.server with annotations of type 已过时的
      Constructor 描述
      Operation​(String op)
      已过时。
      没有替换
      SkeletonMismatchException​(String s)
      已过时。
      没有替换

    • Uses of 已过时的 in java.security

      Classes in java.security with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  Certificate
      已过时。
      Java平台中创建了一个新的证书处理包。 此证书界面已完全弃用，并在此允许平滑过渡到新软件包。
      class  Identity
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  IdentityScope
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      class  Signer
      已过时。
      此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。
      Methods in java.security with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected abstract Object SignatureSpi.engineGetParameter​(String param)
      已过时。
      protected abstract void SignatureSpi.engineSetParameter​(String param, Object value)
      已过时。
      由engineSetParameter替代 。
      static String Security.getAlgorithmProperty​(String algName, String propName)
      已过时。
      此方法用于返回“SUN”加密服务提供程序的主文件中的专有属性的值，以确定如何解析特定于算法的参数。 AlgorithmParameters使用新的基于提供者和算法的AlgorithmParameters和KeyFactory引擎类（在J2SE版本1.2平台中引入）。
      Object Signature.getParameter​(String param)
      已过时。
      double Provider.getVersion​()
      已过时。
      请改用Provider.getVersionStr() 。
      void Signature.setParameter​(String param, Object value)
      已过时。
      使用setParameter 。
      Constructors in java.security with annotations of type 已过时的
      Constructor 描述
      AuthProvider​(String name, double version, String info)
      已过时。
      改用AuthProvider(String, String, String) 。
      Provider​(String name, double version, String info)
      已过时。
      改用Provider(String, String, String) 。

    • Uses of 已过时的 in java.security.acl

      Classes in java.security.acl with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  Acl
      已过时。
      自1.2以来，该软件包已被java.security.Policy和相关类替代。
      interface  AclEntry
      已过时。
      自1.2以来，这个软件包已经被java.security.Policy和相关的类替代了。
      class  AclNotFoundException
      已过时。
      自1.2以来，该软件包已被java.security.Policy及相关课程所取代。
      interface  Group
      已过时。
      自1.2以来，这个软件包已经被java.security.Policy和相关的类替代了。
      class  LastOwnerException
      已过时。
      自1.2以来，该软件包已被java.security.Policy和相关类替代。
      class  NotOwnerException
      已过时。
      自1.2以来，该软件包已被java.security.Policy及相关课程所取代。
      interface  Owner
      已过时。
      自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。
      interface  Permission
      已过时。
      自1.2以来，这个软件包已经被java.security.Policy和相关的类替代了。

    • Uses of 已过时的 in java.sql

      Methods in java.sql with annotations of type 已过时的
      Modifier and Type 方法 描述
      BigDecimal CallableStatement.getBigDecimal​(int parameterIndex, int scale)
      已过时。
      使用getBigDecimal(int parameterIndex)或getBigDecimal(String parameterName)
      BigDecimal ResultSet.getBigDecimal​(int columnIndex, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      BigDecimal ResultSet.getBigDecimal​(String columnLabel, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      int Time.getDate​()
      已过时。
      int Time.getDay​()
      已过时。
      int Date.getHours​()
      已过时。
      static PrintStream DriverManager.getLogStream​()
      已过时。
      使用getLogWriter
      int Date.getMinutes​()
      已过时。
      int Time.getMonth​()
      已过时。
      int Date.getSeconds​()
      已过时。
      InputStream ResultSet.getUnicodeStream​(int columnIndex)
      已过时。
      使用getCharacterStream代替getUnicodeStream
      InputStream ResultSet.getUnicodeStream​(String columnLabel)
      已过时。
      改用getCharacterStream
      int Time.getYear​()
      已过时。
      void Time.setDate​(int i)
      已过时。
      void Date.setHours​(int i)
      已过时。
      static void DriverManager.setLogStream​(PrintStream out)
      已过时。
      使用setLogWriter
      void Date.setMinutes​(int i)
      已过时。
      void Time.setMonth​(int i)
      已过时。
      void Date.setSeconds​(int i)
      已过时。
      void PreparedStatement.setUnicodeStream​(int parameterIndex, InputStream x, int length)
      已过时。
      使用setCharacterStream
      void Time.setYear​(int i)
      已过时。
      Constructors in java.sql with annotations of type 已过时的
      Constructor 描述
      Date​(int year, int month, int day)
      已过时。
      而是使用构造函数Date(long date)
      Time​(int hour, int minute, int second)
      已过时。
      使用构造函数，该构造函数需要一个毫秒值来代替此构造函数
      Timestamp​(int year, int month, int date, int hour, int minute, int second, int nano)
      已过时。
      而是使用构造函数Timestamp(long millis)

    • Uses of 已过时的 in java.util

      Classes in java.util with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Observable
      已过时。
      此类和Observer接口已被弃用。 由Observer和Observable支持的事件模式是非常有限的， Observable发送的通知的Observable是未指定的，状态更改不与通知一一对应。 对于更丰富的事件模型，请考虑使用java.beans软件包。 对于线程之间的可靠且有序的消息传递，请考虑使用java.util.concurrent包中的并发数据结构之一。 对于反应流样式编程，请参见Flow API。
      interface  Observer
      已过时。
      此接口已被弃用。 有关详细信息，请参阅Observable课程。
      Methods in java.util with annotations of type 已过时的
      Modifier and Type 方法 描述
      int Date.getDate​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_MONTH)替代。
      int Date.getDay​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.DAY_OF_WEEK)替代。
      int Date.getHours​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.HOUR_OF_DAY)替代。
      int Date.getMinutes​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.MINUTE)替代。
      int Date.getMonth​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.MONTH)取代。
      int Date.getSeconds​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.SECOND)替代。
      int Date.getTimezoneOffset​()
      已过时。
      自JDK 1.1版起，由-(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000)取代。
      int Date.getYear​()
      已过时。
      从JDK 1.1版开始，由Calendar.get(Calendar.YEAR) - 1900替代。
      static long Date.parse​(String s)
      已过时。
      从JDK 1.1版开始，由DateFormat.parse(String s)替代。
      void Properties.save​(OutputStream out, String comments)
      已过时。
      如果在保存属性列表时发生I / O错误，此方法不会抛出IOException。 保存属性列表的首选方法是通过store(OutputStream out, String comments)方法或storeToXML(OutputStream os, String comment)方法。
      void Date.setDate​(int date)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.DAY_OF_MONTH, int date)替代。
      void Date.setHours​(int hours)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.HOUR_OF_DAY, int hours)替代。
      void Date.setMinutes​(int minutes)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.MINUTE, int minutes)替代。
      void Date.setMonth​(int month)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.MONTH, int month)替代。
      void Date.setSeconds​(int seconds)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.SECOND, int seconds)替代。
      void Date.setYear​(int year)
      已过时。
      从JDK 1.1版开始，由Calendar.set(Calendar.YEAR, year + 1900)替代。
      String Date.toGMTString​()
      已过时。
      从JDK 1.1版开始，用DateFormat.format(Date date)替换，使用GMT TimeZone 。
      String Date.toLocaleString​()
      已过时。
      从JDK 1.1版开始，由DateFormat.format(Date date)替代。
      static long Date.UTC​(int year, int month, int date, int hrs, int min, int sec)
      已过时。
      从JDK 1.1版开始，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec)替换，使用UTC TimeZone ，其次是Calendar.getTime().getTime() 。
      Constructors in java.util with annotations of type 已过时的
      Constructor 描述
      Date​(int year, int month, int date)
      已过时。
      自JDK 1.1版起，由Calendar.set(year + 1900, month, date)或GregorianCalendar(year + 1900, month, date)取代。
      Date​(int year, int month, int date, int hrs, int min)
      已过时。
      从JDK 1.1版开始，由Calendar.set(year + 1900, month, date, hrs, min)或GregorianCalendar(year + 1900, month, date, hrs, min)替换。
      Date​(int year, int month, int date, int hrs, int min, int sec)
      已过时。
      截至JDK 1.1版，由Calendar.set(year + 1900, month, date, hrs, min, sec)或GregorianCalendar(year + 1900, month, date, hrs, min, sec) 。
      Date​(String s)
      已过时。
      从JDK 1.1版开始，由DateFormat.parse(String s)替代。

    • Uses of 已过时的 in java.util.concurrent

      Methods in java.util.concurrent with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void ThreadPoolExecutor.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of 已过时的 in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with annotations of type 已过时的
      Modifier and Type 方法 描述
      boolean AtomicBoolean.weakCompareAndSet​(boolean expectedValue, boolean newValue)
      已过时。
      该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicBoolean.compareAndExchange(boolean, boolean)和AtomicBoolean.compareAndSet(boolean, boolean) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicBoolean.weakCompareAndSetPlain(boolean, boolean) 。
      boolean AtomicInteger.weakCompareAndSet​(int expectedValue, int newValue)
      已过时。
      该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicInteger.compareAndExchange(int, int)和AtomicInteger.compareAndSet(int, int) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicInteger.weakCompareAndSetPlain(int, int) 。
      boolean AtomicIntegerArray.weakCompareAndSet​(int i, int expectedValue, int newValue)
      已过时。
      该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicIntegerArray.compareAndExchange(int, int, int)和AtomicIntegerArray.compareAndSet(int, int, int) ）。 为了避免在简单或易失性记忆效应上的混乱，建议使用方法AtomicIntegerArray.weakCompareAndSetPlain(int, int, int) 。
      boolean AtomicLong.weakCompareAndSet​(long expectedValue, long newValue)
      已过时。
      该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法如AtomicLong.compareAndExchange(long, long)和AtomicLong.compareAndSet(long, long) ）。 为了避免在平常或易失性记忆效应上的混淆，建议使用方法AtomicLong.weakCompareAndSetPlain(long, long) 。
      boolean AtomicLongArray.weakCompareAndSet​(int i, long expectedValue, long newValue)
      已过时。
      该方法具有明显的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicLongArray.compareAndExchange(int, long, long)和AtomicLongArray.compareAndSet(int, long, long) ）。 为了避免在简单或易失性记忆效应上的混乱，建议使用方法AtomicLongArray.weakCompareAndSetPlain(int, long, long) 。
      boolean AtomicReference.weakCompareAndSet​(V expectedValue, V newValue)
      已过时。
      该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicReference.compareAndExchange(V, V)和AtomicReference.compareAndSet(V, V) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicReference.weakCompareAndSetPlain(V, V) 。
      boolean AtomicReferenceArray.weakCompareAndSet​(int i, E expectedValue, E newValue)
      已过时。
      该方法具有简单的记忆效应，但方法名称表示易失性记忆效应（参见方法，如AtomicReferenceArray.compareAndExchange(int, E, E)和AtomicReferenceArray.compareAndSet(int, E, E) ）。 为了避免在平常或易失性记忆效应上的混乱，建议使用方法AtomicReferenceArray.weakCompareAndSetPlain(int, E, E) 。

    • Uses of 已过时的 in java.util.jar

      Fields in java.util.jar with annotations of type 已过时的
      Modifier and Type Field 描述
      static Attributes.Name Attributes.Name.EXTENSION_INSTALLATION
      已过时。
      扩展机制不再受支持。
      static Attributes.Name Attributes.Name.IMPLEMENTATION_URL
      已过时。
      扩展机制不再受支持。
      static Attributes.Name Attributes.Name.IMPLEMENTATION_VENDOR_ID
      已过时。
      扩展机制不再受支持。

    • Uses of 已过时的 in java.util.logging

      Classes in java.util.logging with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  LoggingMXBean
      已过时。
      LoggingMXBean不再是platform MXBean ，而是被替换成PlatformLoggingMXBean 。 它不会在平台上注册MBeanServer 。 改用ManagementFactory.getPlatformMXBean(PlatformLoggingMXBean.class) 。
      Fields in java.util.logging with annotations of type 已过时的
      Modifier and Type Field 描述
      static Logger Logger.global
      已过时。
      此字段的初始化容易出现死锁。 该字段必须由Logger类初始化初始化，这可能会导致与LogManager类初始化的死锁。 在这种情况下，两个类初始化等待彼此完成。 获取全局记录器对象的首选方法是通过调用Logger.getGlobal() 。 为了兼容Logger.getGlobal()不可用的旧JDK版本，请使用电话Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)或Logger.getLogger("global") 。
      Methods in java.util.logging with annotations of type 已过时的
      Modifier and Type 方法 描述
      static LoggingMXBean LogManager.getLoggingMXBean​()
      已过时。
      java.util.logging.LoggingMXBean已被弃用，替换为java.lang.management.PlatformLoggingMXBean 。 改用ManagementFactory.getPlatformMXBean （PlatformLoggingMXBean.class）。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。
      void LogRecord.setMillis​(long millis)
      已过时。
      LogRecord使用Instant值来保持纳秒分辨率的时间戳。 因此， setInstant()应优先于setMillis() 。

    • Uses of 已过时的 in java.util.zip

      Methods in java.util.zip with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void Deflater.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void Inflater.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void ZipFile.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of 已过时的 in javafx.application

      Methods in javafx.application with annotations of type 已过时的
      Modifier and Type 方法 描述
      JSObject HostServices.getWebContext​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      自JDK 9 以来，此方法已被弃用，因为已不推荐使用该API Applet API。

    • Uses of 已过时的 in javafx.css

      Methods in javafx.css with annotations of type 已过时的
      Modifier and Type 方法 描述
      void CssMetaData.set​(S styleable, V value, StyleOrigin origin)
      已过时。
      此方法不再从CSS代码调用。 使用StyleableProperty.applyStyle(javafx.css.StyleOrigin, java.lang.Object)

    • Uses of 已过时的 in javafx.event

      Constructors in javafx.event with annotations of type 已过时的
      Constructor 描述
      EventType​()
      已过时。
      不要使用这个构造函数，因为只有一个这样的EventType可以存在

    • Uses of 已过时的 in javafx.fxml

      Methods in javafx.fxml with annotations of type 已过时的
      Modifier and Type 方法 描述
      static Class<?> FXMLLoader.loadType​(String className)
      已过时。
      此方法现在委托给FXMLLoader.getDefaultClassLoader() 。
      static Class<?> FXMLLoader.loadType​(String packageName, String className)
      已过时。
      此方法现在委托给FXMLLoader.getDefaultClassLoader() 。

    • Uses of 已过时的 in javafx.scene.control

      Methods in javafx.scene.control with annotations of type 已过时的
      Modifier and Type 方法 描述
      static int TreeTableView.getNodeLevel​(TreeItem<?> node)
      已过时。
      此方法无法正确计算从给定TreeItem到TreeTableView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeTableView.getTreeItemLevel(TreeItem)
      static int TreeView.getNodeLevel​(TreeItem<?> node)
      已过时。
      此方法无法正确计算从给定TreeItem到TreeView根的距离。 从JavaFX 8.0_20开始，正确的方法是通过TreeView.getTreeItemLevel(TreeItem)
      protected double SkinBase.snapPosition​(double value)
      已过时。
      替换为snapPositionX()和snapPositionY()
      protected double SkinBase.snapSize​(double value)
      已过时。
      替换为snapSizeX()和snapSizeY()
      protected double SkinBase.snapSpace​(double value)
      已过时。
      代之以snapSpaceX()和snapSpaceY()

    • Uses of 已过时的 in javafx.scene.input

      Constructors in javafx.scene.input with annotations of type 已过时的
      Constructor 描述
      GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。
      GestureEvent​(EventType<? extends GestureEvent> eventType)
      已过时。
      不要使用这个构造函数。 构造空事件。

    • Uses of 已过时的 in javafx.scene.layout

      Methods in javafx.scene.layout with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected double Region.snapPosition​(double value)
      已过时。
      替换为snapPositionX()和snapPositionY()
      protected double Region.snapSize​(double value)
      已过时。
      由snapSizeX()和snapSizeY()取代
      protected double Region.snapSpace​(double value)
      已过时。
      代之以snapSpaceX()和snapSpaceY()

    • Uses of 已过时的 in javafx.scene.media

      Methods in javafx.scene.media with annotations of type 已过时的
      Modifier and Type 方法 描述
      String AudioTrack.getLanguage​()
      已过时。
      改用Track.getLocale() 。

    • Uses of 已过时的 in javafx.util

      Methods in javafx.util with annotations of type 已过时的
      Modifier and Type 方法 描述
      Duration Duration.divide​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用Duration.divide(double) 。
      Duration Duration.multiply​(Duration other)
      已过时。
      这种方法通过不考虑单位产生令人惊讶的结果。 改用Duration.multiply(double) 。

    • Uses of 已过时的 in javax.accessibility

      Classes in javax.accessibility with annotations of type 已过时的
      Modifier and Type Class 描述
      class  AccessibleResourceBundle
      已过时。
      从Java平台1.3版开始，此类已被弃用

    • Uses of 已过时的 in javax.imageio.spi

      Fields in javax.imageio.spi with annotations of type 已过时的
      Modifier and Type Field 描述
      static Class<?>[] ImageReaderSpi.STANDARD_INPUT_TYPE
      已过时。
      而不是使用这个字段，直接创建等效的数组{ ImageInputStream.class } 。
      static Class<?>[] ImageWriterSpi.STANDARD_OUTPUT_TYPE
      已过时。
      而不是使用这个字段，直接创建等效的数组{ ImageOutputStream.class } 。
      Methods in javax.imageio.spi with annotations of type 已过时的
      Modifier and Type 方法 描述
      void ServiceRegistry.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of 已过时的 in javax.imageio.stream

      Methods in javax.imageio.stream with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void FileCacheImageInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void FileImageInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void FileImageOutputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中的描述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void ImageInputStreamImpl.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void MemoryCacheImageInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of 已过时的 in javax.jws.soap

      Classes in javax.jws.soap with annotations of type 已过时的
      Modifier and Type Class 描述
      interface  InitParam
      已过时。
      interface  SOAPMessageHandler
      已过时。
      interface  SOAPMessageHandlers
      已过时。

    • Uses of 已过时的 in javax.lang.model.util

      Constructors in javax.lang.model.util with annotations of type 已过时的
      Constructor 描述
      AbstractAnnotationValueVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      AbstractElementVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      AbstractTypeVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      ElementKindVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      ElementKindVisitor6​(R defaultValue)
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      ElementScanner6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      ElementScanner6​(R defaultValue)
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      SimpleAnnotationValueVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      SimpleAnnotationValueVisitor6​(R defaultValue)
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      SimpleElementVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      SimpleElementVisitor6​(R defaultValue)
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      SimpleTypeVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      SimpleTypeVisitor6​(R defaultValue)
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      TypeKindVisitor6​()
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。
      TypeKindVisitor6​(R defaultValue)
      已过时。
      第6版已经过时了 更新到访问者较新的版本级别。

    • Uses of 已过时的 in javax.management

      Classes in javax.management with annotations of type 已过时的
      Modifier and Type Class 描述
      class  DefaultLoaderRepository
      已过时。
      改用MBeanServer.getClassLoaderRepository() 。
      Methods in javax.management with annotations of type 已过时的
      Modifier and Type 方法 描述
      default ObjectInputStream MBeanServer.deserialize​(String className, byte[] data)
      已过时。
      使用MBeanServer.getClassLoaderRepository()获取类加载程序库，并将其用于反序列化。
      default ObjectInputStream MBeanServer.deserialize​(String className, ObjectName loaderName, byte[] data)
      已过时。
      使用getClassLoader获取反序列化的类加载器。
      default ObjectInputStream MBeanServer.deserialize​(ObjectName name, byte[] data)
      已过时。
      使用getClassLoaderFor获取适当的反序列化类加载器。
      void AttributeValueExp.setMBeanServer​(MBeanServer s)
      已过时。
      此方法无效。 用于获取属性值的MBean Server为QueryEval.getMBeanServer() 。
      void StringValueExp.setMBeanServer​(MBeanServer s)
      已过时。
      void ValueExp.setMBeanServer​(MBeanServer s)
      已过时。
      不需要此方法，因为ValueExp可以访问在其中它被通过使用评估的MBean服务器QueryEval.getMBeanServer() 。
      Constructors in javax.management with annotations of type 已过时的
      Constructor 描述
      AttributeValueExp​()
      已过时。
      使用此构造函数创建的实例不能在查询中使用。

    • Uses of 已过时的 in javax.management.loading

      Classes in javax.management.loading with annotations of type 已过时的
      Modifier and Type Class 描述
      class  DefaultLoaderRepository
      已过时。
      改用MBeanServer.getClassLoaderRepository() 。

    • Uses of 已过时的 in javax.management.monitor

      Fields in javax.management.monitor with annotations of type 已过时的
      Modifier and Type Field 描述
      protected int Monitor.alreadyNotified
      已过时。
      相当于Monitor.alreadyNotifieds [0]。
      protected String Monitor.dbgTag
      已过时。
      没有替换
      Methods in javax.management.monitor with annotations of type 已过时的
      Modifier and Type 方法 描述
      Number CounterMonitor.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由CounterMonitor.getDerivedGauge(ObjectName)替代
      Number CounterMonitorMBean.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.getDerivedGauge(ObjectName)替代
      Number GaugeMonitor.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由GaugeMonitor.getDerivedGauge(ObjectName)替代
      Number GaugeMonitorMBean.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由GaugeMonitorMBean.getDerivedGauge(ObjectName)取代
      String StringMonitor.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由StringMonitor.getDerivedGauge(ObjectName)替代
      String StringMonitorMBean.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由StringMonitorMBean.getDerivedGauge(ObjectName)取代
      long CounterMonitor.getDerivedGaugeTimeStamp​()
      已过时。
      截至JMX 1.2，由CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)替代
      long CounterMonitorMBean.getDerivedGaugeTimeStamp​()
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)取代
      long GaugeMonitor.getDerivedGaugeTimeStamp​()
      已过时。
      截至JMX 1.2，由GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)替换
      long GaugeMonitorMBean.getDerivedGaugeTimeStamp​()
      已过时。
      截至JMX 1.2，由GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)取代
      long StringMonitor.getDerivedGaugeTimeStamp​()
      已过时。
      截至JMX 1.2，由StringMonitor.getDerivedGaugeTimeStamp(ObjectName)取代
      long StringMonitorMBean.getDerivedGaugeTimeStamp​()
      已过时。
      截至JMX 1.2，由StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)取代
      ObjectName Monitor.getObservedObject​()
      已过时。
      截至JMX 1.2，由Monitor.getObservedObjects()取代
      ObjectName MonitorMBean.getObservedObject​()
      已过时。
      截至JMX 1.2，由MonitorMBean.getObservedObjects()替代
      Number CounterMonitor.getThreshold​()
      已过时。
      截至JMX 1.2，由CounterMonitor.getThreshold(ObjectName)替代
      Number CounterMonitorMBean.getThreshold​()
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.getThreshold(ObjectName)取代
      void Monitor.setObservedObject​(ObjectName object)
      已过时。
      截至JMX 1.2，由Monitor.addObservedObject(javax.management.ObjectName)取代
      void MonitorMBean.setObservedObject​(ObjectName object)
      已过时。
      截至JMX 1.2，由MonitorMBean.addObservedObject(javax.management.ObjectName)取代
      void CounterMonitor.setThreshold​(Number value)
      已过时。
      截至JMX 1.2，由CounterMonitor.setInitThreshold(java.lang.Number)替代
      void CounterMonitorMBean.setThreshold​(Number value)
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.setInitThreshold(java.lang.Number)取代

    • Uses of 已过时的 in javax.management.openmbean

      Fields in javax.management.openmbean with annotations of type 已过时的
      Modifier and Type Field 描述
      static String[] OpenType.ALLOWED_CLASSNAMES
      已过时。
      改用ALLOWED_CLASSNAMES_LIST 。

    • Uses of 已过时的 in javax.management.remote.rmi

      Classes in javax.management.remote.rmi with annotations of type 已过时的
      Modifier and Type Class 描述
      class  RMIIIOPServerImpl
      已过时。
      此运输已不再受支持。

    • Uses of 已过时的 in javax.naming

      Fields in javax.naming with annotations of type 已过时的
      Modifier and Type Field 描述
      static String Context.APPLET
      已过时。
      在构建初始上下文时，将忽略具有此名称的环境属性。 此常量最初用作属性名称，以在创建初始上下文时指定Applet以检索参数。 目前需要传递给初始上下文的任何applet属性都应该复制到环境哈希表中：
         Hashtable env = new Hashtable(); env.put(Context.INITIAL_CONTEXT_FACTORY, ((Applet) this).getParameter(Context.INITIAL_CONTEXT_FACTORY)); env.put(Context.PROVIDER_URL, ((Applet) this).getParameter(Context.PROVIDER_URL)); // ... other properties ... Context ctx = new InitialContext(env);

    • Uses of 已过时的 in javax.net.ssl

      Methods in javax.net.ssl with annotations of type 已过时的
      Modifier and Type 方法 描述
      X509Certificate[] HandshakeCompletedEvent.getPeerCertificateChain​()
      已过时。
      应该使用返回java.security.cert.Certificate数组的HandshakeCompletedEvent.getPeerCertificates()方法。
      X509Certificate[] SSLSession.getPeerCertificateChain​()
      已过时。
      应该使用返回java.security.cert.Certificate数组的SSLSession.getPeerCertificates()方法。

    • Uses of 已过时的 in javax.security.auth

      Classes in javax.security.auth with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Policy
      已过时。
      从JDK版本1.4开始 - 由java.security.Policy替代。 java.security.Policy有一个方法：
        public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
      和ProtectionDomain有一个构造函数：
        public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
      这两个API为呼叫者提供查询基于Principal权限条目的策略的方法。

    • Uses of 已过时的 in javax.security.cert

      Classes in javax.security.cert with annotations of type 已过时的
      Modifier and Type Class 描述
      class  Certificate
      已过时。
      使用java.security.cert的类。
      class  CertificateEncodingException
      已过时。
      使用java.security.cert的类。
      class  CertificateException
      已过时。
      使用java.security.cert的类。
      class  CertificateExpiredException
      已过时。
      使用java.security.cert的类。
      class  CertificateNotYetValidException
      已过时。
      使用java.security.cert的类。
      class  CertificateParsingException
      已过时。
      使用java.security.cert的类。
      class  X509Certificate
      已过时。
      使用java.security.cert的类。

    • Uses of 已过时的 in javax.sql.rowset

      Fields in javax.sql.rowset with annotations of type 已过时的
      Modifier and Type Field 描述
      static boolean CachedRowSet.COMMIT_ON_ACCEPT_CHANGES
      已过时。
      因为这个字段是final（它是接口的一部分），所以它的值不能被改变。
      Methods in javax.sql.rowset with annotations of type 已过时的
      Modifier and Type 方法 描述
      void BaseRowSet.setUnicodeStream​(int parameterIndex, InputStream x, int length)
      已过时。
      getCharacterStream应该用于它的位置

    • Uses of 已过时的 in javax.swing

      Classes in javax.swing with annotations of type 已过时的
      Modifier and Type Class 描述
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      protected class  JComponent.AccessibleJComponent.AccessibleFocusHandler
      已过时。
      此类不再使用或需要。 java.awt.Component.AccessibleAWTComponent提供相同的功能，它在Component处理。
      Fields in javax.swing with annotations of type 已过时的
      Modifier and Type Field 描述
      protected FocusListener JComponent.AccessibleJComponent.accessibleFocusHandler
      已过时。
      protected boolean JViewport.backingStore
      已过时。
      从Java 2平台v1.3开始
      protected static Component ImageIcon.component
      已过时。
      自1.8
      protected static MediaTracker ImageIcon.tracker
      已过时。
      自1.8
      Methods in javax.swing with annotations of type 已过时的
      Modifier and Type 方法 描述
      void RepaintManager.addDirtyRegion​(Applet applet, int x, int y, int w, int h)
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      static JScrollPane JTable.createScrollPaneForTable​(JTable aTable)
      已过时。
      截至Swing 1.0.2版，替换为new JScrollPane(aTable) 。
      void JComponent.disable​()
      已过时。
      截至JDK 1.1版，由java.awt.Component.setEnabled(boolean)替代。
      static void FocusManager.disableSwingFocusManager​()
      已过时。
      截至1.4，由KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)取代
      void JComponent.enable​()
      已过时。
      从JDK 1.1版开始，由java.awt.Component.setEnabled(boolean)代替。
      static Component SwingUtilities.findFocusOwner​(Component c)
      已过时。
      截至1.4，由KeyboardFocusManager.getFocusOwner()取代。
      Component JMenuBar.getComponentAtIndex​(int i)
      已过时。
      替换为getComponent(int i)
      Component JPopupMenu.getComponentAtIndex​(int i)
      已过时。
      换成Container.getComponent(int)
      static KeyStroke KeyStroke.getKeyStroke​(char keyChar, boolean onKeyRelease)
      已过时。
      使用getKeyStroke（char）
      String AbstractButton.getLabel​()
      已过时。
      - 替换为getText
      JMenuBar JInternalFrame.getMenuBar​()
      已过时。
      截至Swing 1.0.3版本，由getJMenuBar()替换。
      JMenuBar JRootPane.getMenuBar​()
      已过时。
      从Swing版本1.0.3替换为getJMenuBar() 。
      Component JComponent.getNextFocusableComponent​()
      已过时。
      截至1.4，由FocusTraversalPolicy取代。
      Object[] JList.getSelectedValues​()
      已过时。
      截至JDK 1.7，由JList.getSelectedValuesList()替代
      String JPasswordField.getText​()
      已过时。
      从Java 2平台v1.2开始，由getPassword代替。
      String JPasswordField.getText​(int offs, int len)
      已过时。
      从Java 2平台v1.2开始，由getPassword 。
      Rectangle ScrollPaneLayout.getViewportBorderBounds​(JScrollPane scrollpane)
      已过时。
      截至JDK版本的Swing1.1由JScrollPane.getViewportBorderBounds()替换。
      void JComponent.hide​()
      已过时。
      boolean JViewport.isBackingStoreEnabled​()
      已过时。
      从Java 2平台v1.3开始，由getScrollMode()代替。
      static boolean FocusManager.isFocusManagerEnabled​()
      已过时。
      截至1.4，由KeyboardFocusManager.getDefaultFocusTraversalPolicy()取代
      boolean JComponent.isManagingFocus​()
      已过时。
      截至1.4，由Component.setFocusTraversalKeys(int, Set)和Container.setFocusCycleRoot(boolean)取代。
      boolean JComponent.requestDefaultFocus​()
      已过时。
      截至1.4，由FocusTraversalPolicy.getDefaultComponent(Container).requestFocus()取代
      void JComponent.reshape​(int x, int y, int w, int h)
      已过时。
      截至JDK 5，由Component.setBounds(int, int, int, int)取代。

      移动并调整此组件的大小。

      void JViewport.setBackingStoreEnabled​(boolean enabled)
      已过时。
      截至Java 2平台v1.3，由setScrollMode()取代。
      void AbstractButton.setLabel​(String label)
      已过时。
      - 替换为setText(text)
      void JInternalFrame.setMenuBar​(JMenuBar m)
      已过时。
      从Swing版本1.0.3替换为setJMenuBar(JMenuBar m) 。
      void JRootPane.setMenuBar​(JMenuBar menu)
      已过时。
      从Swing版本1.0.3替换为setJMenuBar(JMenuBar menu) 。
      void JComponent.setNextFocusableComponent​(Component aComponent)
      已过时。
      截至1.4，由FocusTraversalPolicy取代
      boolean InputVerifier.shouldYieldFocus​(JComponent input)
      已过时。
      改用InputVerifier.shouldYieldFocus(JComponent, JComponent) 。
      void JTable.sizeColumnsToFit​(boolean lastColumnOnly)
      已过时。
      截至Swing 1.0.3版本，由doLayout()替换。

    • Uses of 已过时的 in javax.swing.plaf

      Methods in javax.swing.plaf with annotations of type 已过时的
      Modifier and Type 方法 描述
      String TextUI.getToolTipText​(JTextComponent t, Point pt)
      已过时。
      替换为TextUI.getToolTipText2D(JTextComponent, Point2D)
      abstract Rectangle TextUI.modelToView​(JTextComponent t, int pos)
      已过时。
      取代TextUI.modelToView2D(JTextComponent, int, Position.Bias)
      abstract Rectangle TextUI.modelToView​(JTextComponent t, int pos, Position.Bias bias)
      已过时。
      替换为TextUI.modelToView2D(JTextComponent, int, Position.Bias)
      abstract int TextUI.viewToModel​(JTextComponent t, Point pt)
      已过时。
      代之以TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
      abstract int TextUI.viewToModel​(JTextComponent t, Point pt, Position.Bias[] biasReturn)
      已过时。
      替换为TextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])

    • Uses of 已过时的 in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic with annotations of type 已过时的
      Modifier and Type Field 描述
      protected KeyStroke BasicDesktopPaneUI.closeKey
      已过时。
      截至1.3。
      protected KeyStroke BasicSplitPaneUI.dividerResizeToggleKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicSplitPaneUI.downKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicTabbedPaneUI.downKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicToolBarUI.downKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicSplitPaneUI.endKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicSplitPaneUI.homeKey
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardDownRightListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardEndListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardHomeListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardResizeToggleListener
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.keyboardUpLeftListener
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicSplitPaneUI.leftKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicTabbedPaneUI.leftKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicToolBarUI.leftKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicDesktopPaneUI.maximizeKey
      已过时。
      截至1.3。
      protected KeyStroke BasicDesktopPaneUI.minimizeKey
      已过时。
      截至1.3。
      protected KeyStroke BasicDesktopPaneUI.navigateKey
      已过时。
      截至1.3。
      protected KeyStroke BasicDesktopPaneUI.navigateKey2
      已过时。
      截至1.3。
      protected KeyStroke BasicInternalFrameUI.openMenuKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicSplitPaneUI.rightKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicTabbedPaneUI.rightKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicToolBarUI.rightKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicSplitPaneUI.upKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicTabbedPaneUI.upKey
      已过时。
      从Java 2平台v1.3开始。
      protected KeyStroke BasicToolBarUI.upKey
      已过时。
      从Java 2平台v1.3开始。
      Methods in javax.swing.plaf.basic with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected ActionListener BasicSplitPaneUI.createKeyboardDownRightListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardEndListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardHomeListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardResizeToggleListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected ActionListener BasicSplitPaneUI.createKeyboardUpLeftListener​()
      已过时。
      从Java 2平台v1.3开始。
      protected int BasicSplitPaneUI.getDividerBorderSize​()
      已过时。
      从Java 2平台v1.3开始，将边框设置在分隔线上。
      Rectangle BasicTextUI.modelToView​(JTextComponent tc, int pos)
      已过时。
      代之以BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
      Rectangle BasicTextUI.modelToView​(JTextComponent tc, int pos, Position.Bias bias)
      已过时。
      替换为BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)
      int BasicTextUI.viewToModel​(JTextComponent tc, Point pt)
      已过时。
      替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])
      int BasicTextUI.viewToModel​(JTextComponent tc, Point pt, Position.Bias[] biasReturn)
      已过时。
      替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])

    • Uses of 已过时的 in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal with annotations of type 已过时的
      Modifier and Type Class 描述
      class  MetalComboBoxUI.MetalComboPopup
      已过时。
      从Java 2平台v1.4开始。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      protected class  MetalFileChooserUI.SingleClickListener
      已过时。
      截至JDK版本9.过时的课程。
      Methods in javax.swing.plaf.metal with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void MetalComboBoxUI.editablePropertyChanged​(PropertyChangeEvent e)
      已过时。
      从Java 2平台v1.4开始。
      protected void MetalComboBoxUI.removeListeners​()
      已过时。
      从Java 2平台v1.4开始。
      void MetalScrollPaneUI.uninstallListeners​(JScrollPane scrollPane)
      已过时。
      - 替换为MetalScrollPaneUI.uninstallListeners(JComponent)

    • Uses of 已过时的 in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with annotations of type 已过时的
      Modifier and Type 方法 描述
      Rectangle MultiTextUI.modelToView​(JTextComponent a, int b)
      已过时。
      替换为MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)
      Rectangle MultiTextUI.modelToView​(JTextComponent a, int b, Position.Bias c)
      已过时。
      替换为MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)
      int MultiTextUI.viewToModel​(JTextComponent a, Point b)
      已过时。
      int MultiTextUI.viewToModel​(JTextComponent a, Point b, Position.Bias[] c)
      已过时。

    • Uses of 已过时的 in javax.swing.table

      Fields in javax.swing.table with annotations of type 已过时的
      Modifier and Type Field 描述
      protected int TableColumn.resizedPostingDisableCount
      已过时。
      从Java 2平台v1.3开始
      Methods in javax.swing.table with annotations of type 已过时的
      Modifier and Type 方法 描述
      void TableColumn.disableResizedPosting​()
      已过时。
      从Java 2平台v1.3开始
      void TableColumn.enableResizedPosting​()
      已过时。
      从Java 2平台v1.3开始

    • Uses of 已过时的 in javax.swing.text

      Classes in javax.swing.text with annotations of type 已过时的
      Modifier and Type Class 描述
      class  DefaultTextUI
      已过时。
      class  TableView.TableCell
      已过时。
      一个表单元格现在可以是任何View实现。
      Methods in javax.swing.text with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected TableView.TableCell TableView.createTableCell​(Element elem)
      已过时。
      表格单元现在可以是任意的View实现，应该由ViewFactory而不是表生成。
      protected int PasswordView.drawEchoCharacter​(Graphics g, int x, int y, char c)
      已过时。
      替换为PasswordView.drawEchoCharacter(Graphics2D, float, float, char)
      protected void PlainView.drawLine​(int lineIndex, Graphics g, int x, int y)
      已过时。
      替换为PlainView.drawLine(int, Graphics2D, float, float)
      protected void WrappedPlainView.drawLine​(int p0, int p1, Graphics g, int x, int y)
      已过时。
      取代WrappedPlainView.drawLine(int, int, Graphics2D, float, float)
      protected int PasswordView.drawSelectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为PasswordView.drawSelectedText(Graphics2D, float, float, int, int)
      protected int PlainView.drawSelectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      代之以PlainView.drawSelectedText(Graphics2D, float, float, int, int)
      protected int WrappedPlainView.drawSelectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为WrappedPlainView.drawSelectedText(Graphics2D, float, float, int, int)
      static int Utilities.drawTabbedText​(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.drawTabbedText(Segment, float, float, Graphics2D, TabExpander, int)
      protected int PasswordView.drawUnselectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为PasswordView.drawUnselectedText(Graphics2D, float, float, int, int)
      protected int PlainView.drawUnselectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      替换为PlainView.drawUnselectedText(Graphics2D, float, float, int, int)
      protected int WrappedPlainView.drawUnselectedText​(Graphics g, int x, int y, int p0, int p1)
      已过时。
      代之以WrappedPlainView.drawUnselectedText(Graphics2D, float, float, int, int)
      static int Utilities.getBreakLocation​(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.getBreakLocation(Segment, FontMetrics, float, float, TabExpander, int)
      protected FontMetrics LabelView.getFontMetrics​()
      已过时。
      在JDK中运行时，FontMetrics不用于字形渲染。
      static int Utilities.getPositionAbove​(JTextComponent c, int offs, int x)
      已过时。
      替换为Utilities.getPositionAbove(JTextComponent, int, float)
      static int Utilities.getPositionBelow​(JTextComponent c, int offs, int x)
      已过时。
      代之以Utilities.getPositionBelow(JTextComponent, int, float)
      static int Utilities.getTabbedTextOffset​(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)
      static int Utilities.getTabbedTextOffset​(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
      已过时。
      取代Utilities.getTabbedTextOffset(Segment, FontMetrics, float, float, TabExpander, int, boolean)
      static int Utilities.getTabbedTextWidth​(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset)
      已过时。
      替换为Utilities.getTabbedTextWidth(Segment, FontMetrics, float, TabExpander, int)
      Rectangle JTextComponent.modelToView​(int pos)
      已过时。
      由JTextComponent.modelToView2D(int)取代
      Shape View.modelToView​(int pos, Shape a)
      已过时。
      int JTextComponent.viewToModel​(Point pt)
      已过时。
      替换为JTextComponent.viewToModel2D(Point2D)
      int View.viewToModel​(float x, float y, Shape a)
      已过时。

    • Uses of 已过时的 in javax.swing.text.html

      Fields in javax.swing.text.html with annotations of type 已过时的
      Modifier and Type Field 描述
      static String FormView.RESET
      已过时。
      从1.3开始，值来自UIManager UIManager属性FormView.resetButtonText
      static String FormView.SUBMIT
      已过时。
      从1.3起，现在的值来自UIManager属性FormView.submitButtonText
      Methods in javax.swing.text.html with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry​(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      已过时。
      从Java 2平台v1.3开始，使用insertAtBoundary

    • Uses of 已过时的 in javax.swing.tree

      Methods in javax.swing.tree with annotations of type 已过时的
      Modifier and Type 方法 描述
      protected void DefaultTreeSelectionModel.notifyPathChange​(Vector<?> changedPaths, TreePath oldLeadSelection)
      已过时。
      从JDK版本1.7开始

    • Uses of 已过时的 in javax.tools

      Methods in javax.tools with annotations of type 已过时的
      Modifier and Type 方法 描述
      static ClassLoader ToolProvider.getSystemToolClassLoader​()
      已过时。
      此方法在将来的Java SE版本中可能会被删除。 使用system tool provider或service loader机制来定位系统工具以及用户安装的工具。

    • Uses of 已过时的 in javax.xml.bind

      Methods in javax.xml.bind with annotations of type 已过时的
      Modifier and Type 方法 描述
      abstract Validator JAXBContext.createValidator​()
      已过时。
      自JAXB2.0起

    • Uses of 已过时的 in javax.xml.stream

      Methods in javax.xml.stream with annotations of type 已过时的
      Modifier and Type 方法 描述
      static XMLInputFactory XMLInputFactory.newFactory​()
      已过时。
      static XMLEventFactory XMLEventFactory.newInstance​(String factoryId, ClassLoader classLoader)
      已过时。
      该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替换XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
      static XMLInputFactory XMLInputFactory.newInstance​(String factoryId, ClassLoader classLoader)
      已过时。
      该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替换XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。
      static XMLInputFactory XMLOutputFactory.newInstance​(String factoryId, ClassLoader classLoader)
      已过时。
      此方法已被弃用，因为它返回一个XMLInputFactory的实例，该实例是错误的类。 改用新的方法XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) 。

    • Uses of 已过时的 in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting with annotations of type 已过时的
      Modifier and Type 方法 描述
      static Object AbstractJSObject.getDefaultValue​(JSObject jsobj, Class<?> hint)
      已过时。
      改用JSObject.getDefaultValue(Class) 。
      double AbstractJSObject.toNumber​()
      已过时。
      使用JSObject.getDefaultValue(Class)与Number提示相反。
      default double JSObject.toNumber​()
      已过时。
      使用JSObject.getDefaultValue(Class)与Number提示。
      double ScriptObjectMirror.toNumber​()
      已过时。

    • Uses of 已过时的 in netscape.javascript

      Methods in netscape.javascript with annotations of type 已过时的
      Modifier and Type 方法 描述
      static JSObject JSObject.getWindow​(Applet applet)
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of 已过时的 in org.omg.CORBA

      Classes in org.omg.CORBA with annotations of type 已过时的
      Modifier and Type Class 描述
      class  DynamicImplementation
      已过时。
      org.omg.CORBA.DynamicImplementation
      interface  DynAny
      已过时。
      改用新的DynAny
      interface  DynArray
      已过时。
      使用新的DynArray代替
      interface  DynEnum
      已过时。
      改用新的DynEnum
      interface  DynFixed
      已过时。
      改用新的DynFixed
      interface  DynSequence
      已过时。
      改用新的DynSequence
      interface  DynStruct
      已过时。
      改用新的DynStruct
      interface  DynUnion
      已过时。
      改用新的DynUnion
      interface  DynValue
      已过时。
      改用新的DynValue
      class  Principal
      已过时。
      被CORBA弃用2.2。
      class  PrincipalHolder
      已过时。
      被CORBA弃用2.2。
      Methods in org.omg.CORBA with annotations of type 已过时的
      Modifier and Type 方法 描述
      DynAny ORB.create_basic_dyn_any​(TypeCode type)
      已过时。
      使用新的DynAnyFactory API
      DynAny ORB.create_dyn_any​(Any value)
      已过时。
      使用新的DynAnyFactory API
      DynArray ORB.create_dyn_array​(TypeCode type)
      已过时。
      使用新的DynAnyFactory API
      DynEnum ORB.create_dyn_enum​(TypeCode type)
      已过时。
      使用新的DynAnyFactory API
      DynSequence ORB.create_dyn_sequence​(TypeCode type)
      已过时。
      使用新的DynAnyFactory API
      DynStruct ORB.create_dyn_struct​(TypeCode type)
      已过时。
      使用新的DynAnyFactory API
      DynUnion ORB.create_dyn_union​(TypeCode type)
      已过时。
      使用新的DynAnyFactory API
      abstract TypeCode ORB.create_recursive_sequence_tc​(int bound, int offset)
      已过时。
      使用create_recursive_tc和create_sequence_tc的组合
      void ServerRequest.except​(Any any)
      已过时。
      使用set_exception（）
      Principal Any.extract_Principal​()
      已过时。
      被CORBA弃用2.2。
      Current ORB.get_current​()
      已过时。
      使用resolve_initial_references 。
      void Any.insert_Principal​(Principal p)
      已过时。
      被CORBA弃用2.2。
      void DynamicImplementation.invoke​(ServerRequest request)
      已过时。
      便携式对象适配器已弃用
      byte[] Principal.name​()
      已过时。
      被CORBA弃用2.2。
      void Principal.name​(byte[] value)
      已过时。
      被CORBA弃用2.2。
      String ServerRequest.op_name​()
      已过时。
      使用操作（）
      void ServerRequest.params​(NVList params)
      已过时。
      使用方法arguments
      void ServerRequest.result​(Any any)
      已过时。
      使用方法set_result
      Constructors in org.omg.CORBA with annotations of type 已过时的
      Constructor 描述
      TCKind​(int _value)
      已过时。
      不要使用这个构造函数，因为这个方法应该根据OMG规范是私有的。 改用TCKind.from_int(int) 。

    • Uses of 已过时的 in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with annotations of type 已过时的
      Modifier and Type 方法 描述
      Principal InputStream.read_Principal​()
      已过时。
      被CORBA弃用2.2。
      void OutputStream.write_Principal​(Principal value)
      已过时。
      被CORBA弃用2.2。

    • Uses of 已过时的 in org.xml.sax

      Classes in org.xml.sax with annotations of type 已过时的
      Modifier and Type 接口 描述
      interface  AttributeList
      已过时。
      该接口已被SAX2 Attributes接口所取代，其中包括Namespace支持。
      interface  DocumentHandler
      已过时。
      该接口已被SAX2 ContentHandler接口所取代，其中包括命名空间支持。
      interface  Parser
      已过时。
      该接口已被SAX2 XMLReader接口所取代，其中包括命名空间支持。

    • Uses of 已过时的 in org.xml.sax.helpers

      Classes in org.xml.sax.helpers with annotations of type 已过时的
      Modifier and Type Class 描述
      class  ParserFactory
      已过时。
      该类与已弃用的Parser接口配合使用。
      class  XMLReaderFactory
      已过时。
      建议使用SAXParserFactory 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Double (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Double

  • Packages that use Double
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。

    • Uses of Double in java.lang

      Fields in java.lang with type parameters of type Double
      Modifier and Type Field 描述
      static Class<Double> Double.TYPE
      所述 Class实例表示基本类型 double 。
      Methods in java.lang that return Double
      Modifier and Type 方法 描述
      static Double Double.valueOf​(double d)
      返回表示指定的 double值的 Double实例。
      static Double Double.valueOf​(String s)
      返回一个 Double对象，该对象保存由参数字符串 s表示的 double值。
      Methods in java.lang with parameters of type Double
      Modifier and Type 方法 描述
      int Double.compareTo​(Double anotherDouble)
      数值比较两个 Double对象。

    • Uses of Double in java.util

      Methods in java.util that return Double
      Modifier and Type 方法 描述
      default Double PrimitiveIterator.OfDouble.next​()
      返回迭代中的下一个元素。
      Method parameters in java.util with type arguments of type Double
      Modifier and Type 方法 描述
      default void PrimitiveIterator.OfDouble.forEachRemaining​(Consumer<? super Double> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void Spliterator.OfDouble.forEachRemaining​(Consumer<? super Double> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default boolean Spliterator.OfDouble.tryAdvance​(Consumer<? super Double> action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。

    • Uses of Double in java.util.stream

      Methods in java.util.stream that return types with arguments of type Double
      Modifier and Type 方法 描述
      static <T> Collector<T,?,Double> Collectors.averagingDouble​(ToDoubleFunction<? super T> mapper)
      返回产生应用于输入元素的双值函数的算术平均值的 Collector 。
      static <T> Collector<T,?,Double> Collectors.averagingInt​(ToIntFunction<? super T> mapper)
      返回一个产生应用于输入元素的整数值函数的算术平均值的 Collector 。
      static <T> Collector<T,?,Double> Collectors.averagingLong​(ToLongFunction<? super T> mapper)
      返回产生应用于输入元素的长值函数的算术平均值的 Collector 。
      Stream<Double> DoubleStream.boxed​()
      返回一个由这个流的元素组成的 Stream ，装箱到 Double 。
      static <T> Collector<T,?,Double> Collectors.summingDouble​(ToDoubleFunction<? super T> mapper)
      返回一个产生应用于输入元素的双值函数之和的 Collector 。

    • Uses of Double in javafx.beans.binding

      Methods in javafx.beans.binding that return Double
      Modifier and Type | 方法 | 描述
      Double | DoubleExpression.getValue​()
      Methods in javafx.beans.binding that return types with arguments of type Double
      Modifier and Type 方法 描述
      ObjectExpression<Double> DoubleExpression.asObject​()
      创建一个ObjectExpression ，其值为DoubleExpression 。
      Method parameters in javafx.beans.binding with type arguments of type Double
      Modifier and Type 方法 描述
      static DoubleBinding Bindings.createDoubleBinding​(Callable<Double> func, Observable... dependencies)
      助手功能创建一个自定义的DoubleBinding 。

    • Uses of Double in javafx.beans.property

      Methods in javafx.beans.property that return types with arguments of type Double
      Modifier and Type 方法 描述
      ObjectProperty<Double> DoubleProperty.asObject​()
      创建一个ObjectProperty双向绑定到这个DoubleProperty 。
      ReadOnlyObjectProperty<Double> ReadOnlyDoubleProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyDoubleProperty 。
      Method parameters in javafx.beans.property with type arguments of type Double
      Modifier and Type 方法 描述
      static DoubleProperty DoubleProperty.doubleProperty​(Property<Double> property)
      返回一个DoubleProperty ，它包装一个Property并双向绑定到它。

    • Uses of Double in javafx.css

      Constructors in javafx.css with parameters of type Double
      Constructor 描述
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

    • Uses of Double in javafx.scene.control

      Methods in javafx.scene.control that return Double
      Modifier and Type 方法 描述
      Double ResizeFeaturesBase.getDelta​()
      返回在resize操作中添加或删除的水平空间量。
      Methods in javafx.scene.control that return types with arguments of type Double
      Modifier and Type 方法 描述
      StringConverter<Double> Slider.getLabelFormatter​()
      获取属性labelFormatter的值。
      ObjectProperty<StringConverter<Double>> Slider.labelFormatterProperty​()
      用于格式化主要刻度的标签的功能。
      Method parameters in javafx.scene.control with type arguments of type Double
      Modifier and Type 方法 描述
      void Slider.setLabelFormatter​(StringConverter<Double> value)
      设置属性labelFormatter的值。
      Constructors in javafx.scene.control with parameters of type Double
      Constructor 描述
      ResizeFeatures​(TableView<S> table, TableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TableView，TableColumn和delta值被设置并存储在此不可变实例中。
      ResizeFeatures​(TreeTableView<S> treeTable, TreeTableColumn<S,?> column, Double delta)
      创建此类的实例，提供的TreeTableView，TreeTableColumn和delta值被设置并存储在此不可变实例中。
      ResizeFeaturesBase​(TableColumnBase<S,?> column, Double delta)
      创建此类的实例，其中提供的TableColumnBase和delta值被设置并存储在此不可变实例中。

    • Uses of Double in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type Double
      Modifier and Type 方法 描述
      static <S> Callback<TableColumn<S,Double>,TableCell<S,Double>> ProgressBarTableCell.forTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0的容易显示数字值。
      static <S> Callback<TableColumn<S,Double>,TableCell<S,Double>> ProgressBarTableCell.forTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0的容易显示数字值。
      static <S> Callback<TreeTableColumn<S,Double>,TreeTableCell<S,Double>> ProgressBarTreeTableCell.forTreeTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0轻松地显示数字值。
      static <S> Callback<TreeTableColumn<S,Double>,TreeTableCell<S,Double>> ProgressBarTreeTableCell.forTreeTableColumn​()
      提供一个ProgressBar ，允许从0.0到1.0的容易显示数字值。
      Methods in javafx.scene.control.cell with parameters of type Double
      Modifier and Type 方法 描述
      void ProgressBarTableCell.updateItem​(Double item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
      void ProgressBarTreeTableCell.updateItem​(Double item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

    • Uses of Double in javafx.scene.layout

      Methods in javafx.scene.layout that return Double
      Modifier and Type 方法 描述
      static Double AnchorPane.getBottomAnchor​(Node child)
      如果设置，返回小孩的底部锚约束。
      static Double AnchorPane.getLeftAnchor​(Node child)
      如果设置，返回小孩的左锚约束。
      static Double AnchorPane.getRightAnchor​(Node child)
      如果设置，返回小孩的右侧锚点约束。
      static Double AnchorPane.getTopAnchor​(Node child)
      如果设置，返回小孩的顶部锚约束。
      Methods in javafx.scene.layout that return types with arguments of type Double
      Modifier and Type 方法 描述
      List<Double> BorderStrokeStyle.getDashArray​()
      定义表示短划线段长度的数组。
      Methods in javafx.scene.layout with parameters of type Double
      Modifier and Type 方法 描述
      static void AnchorPane.setBottomAnchor​(Node child, Double value)
      设置锚定窗格包含的小孩的底部锚点。
      static void AnchorPane.setLeftAnchor​(Node child, Double value)
      设置锚定窗格所包含的小孩的左侧锚点。
      static void AnchorPane.setRightAnchor​(Node child, Double value)
      为锚定窗格包含的小孩设置正确的锚点。
      static void AnchorPane.setTopAnchor​(Node child, Double value)
      设置锚定窗格包含的小孩的顶部锚点。
      Constructor parameters in javafx.scene.layout with type arguments of type Double
      Constructor 描述
      BorderStrokeStyle​(StrokeType type, StrokeLineJoin lineJoin, StrokeLineCap lineCap, double miterLimit, double dashOffset, List<Double> dashArray)
      创建一个新的BorderStrokeStyle。

    • Uses of Double in javafx.scene.shape

      Methods in javafx.scene.shape that return types with arguments of type Double
      Modifier and Type 方法 描述
      ObservableList<Double> Polygon.getPoints​()
      获取 Polygon顶点的坐标。
      ObservableList<Double> Polyline.getPoints​()
      获取 PolyLine段的坐标。
      ObservableList<Double> Shape.getStrokeDashArray​()
      定义表示短划线段长度的数组。

    • Uses of Double in javafx.util.converter

      Methods in javafx.util.converter that return Double
      Modifier and Type 方法 描述
      Double DoubleStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Double
      Modifier and Type 方法 描述
      String DoubleStringConverter.toString​(Double value)
      将提供的对象转换为其字符串形式。

    • Uses of Double in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Double
      Modifier and Type Field 描述
      static SimpleType<Double> SimpleType.DOUBLE
      The SimpleType instance describing values whose Java class name is java.lang.Double.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Enum (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Enum

  • Packages that use Enum
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。

    • Uses of Enum in java.lang

      Classes in java.lang with type parameters of type Enum
      Modifier and Type Class 描述
      class  Enum<E extends Enum<E>>
      这是所有Java语言枚举类型的公共基类。
      Methods in java.lang with type parameters of type Enum
      Modifier and Type 方法 描述
      static <T extends Enum<T>>
      T             		Enum.valueOf​(Class<T> enumType, String name)
      返回具有指定名称的指定枚举类型的枚举常量。
      Methods in java.lang that return types with arguments of type Enum
      Modifier and Type 方法 描述
      Class<? extends Enum> EnumConstantNotPresentException.enumType​()
      返回缺少的枚举常量的类型。
      Constructor parameters in java.lang with type arguments of type Enum
      Constructor 描述
      EnumConstantNotPresentException​(Class<? extends Enum> enumType, String constantName)
      为指定的常量构造一个 EnumConstantNotPresentException 。

    • Uses of Enum in java.util

      Classes in java.util with type parameters of type Enum
      Modifier and Type Class 描述
      class  EnumMap<K extends Enum<K>,V>
      专门用于枚举类型键的Map实现。
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      Methods in java.util with type parameters of type Enum
      Modifier and Type 方法 描述
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.allOf​(Class<E> elementType)
      创建一个包含指定元素类型中所有元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.complementOf​(EnumSet<E> s)
      创建与指定枚举集具有相同元素类型的枚举集，最初包含此类型的所有元素，该元素 不包含在指定的集合中。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.copyOf​(Collection<E> c)
      创建从指定集合初始化的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.copyOf​(EnumSet<E> s)
      创建与指定的枚举集相同的元素类型的枚举集，最初包含相同的元素（如果有）。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.noneOf​(Class<E> elementType)
      使用指定的元素类型创建一个空的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E first, E... rest)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2, E e3)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2, E e3, E e4)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E e1, E e2, E e3, E e4, E e5)
      创建一个最初包含指定元素的枚举集。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.range​(E from, E to)
      创建最初包含由两个指定端点定义的范围内的所有元素的枚举集。
      Methods in java.util with parameters of type Enum
      Modifier and Type 方法 描述
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E first, E... rest)
      创建一个最初包含指定元素的枚举集。

    • Uses of Enum in javafx.css

      Methods in javafx.css with type parameters of type Enum
      Modifier and Type 方法 描述
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，枚举>，并继承标志。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Class<E> enumClass)
      创建一个StyleableProperty <E扩展枚举<E >>，使用先前创建的给定的 cssProperty 。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass)
      创建一个StyleableProperty <E extends Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue)
      创建一个StyleableProperty <E使用初始值扩展Enum <E >>。
      <E extends Enum<E>>
      StyleableProperty<E>             		StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue, boolean inherits)
      创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。
      static <E extends Enum<E>>
      StyleConverter<String,? extends Enum<?>>             		StyleConverter.getEnumConverter​(Class<E> enumClass)
      返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。
      Methods in javafx.css that return types with arguments of type Enum
      Modifier and Type 方法 描述
      static <E extends Enum<E>>
      StyleConverter<String,? extends Enum<?>>             		StyleConverter.getEnumConverter​(Class<E> enumClass)
      返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。
      Method parameters in javafx.css with type arguments of type Enum
      Modifier and Type 方法 描述
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)
      创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)
      创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。
      <E extends Enum<E>>
      CssMetaData<S,E>             		StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，枚举>，并继承标志。

    • Uses of Enum in javafx.css.converter

      Classes in javafx.css.converter with type parameters of type Enum
      Modifier and Type | Class | 描述
      class  | EnumConverter<E extends Enum<E>>
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.EnumConstantNotPresentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.EnumConstantNotPresentException

No usage of java.lang.EnumConstantNotPresentException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Error (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Error

  • Packages that use Error
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.rmi
    提供RMI包。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.validation
    提供用于验证XML文档的API。

    • Uses of Error in java.awt

      Subclasses of Error in java.awt
      Modifier and Type Class 描述
      class  AWTError
      当出现严重的抽象窗口工具包错误时抛出。

    • Uses of Error in java.io

      Subclasses of Error in java.io
      Modifier and Type Class 描述
      class  IOError
      当出现严重I / O错误时抛出。

    • Uses of Error in java.lang

      Subclasses of Error in java.lang
      Modifier and Type Class 描述
      class  AbstractMethodError
      当应用程序尝试调用抽象方法时抛出。
      class  AssertionError
      抛出以表明断言失败。
      class  BootstrapMethodError
      抛出以表示invokedynamic指令未能找到其引导方法，或引导方法未能提供call site的target正确的method type 。
      class  ClassCircularityError
      当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。
      class  ClassFormatError
      当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
      class  ExceptionInInitializerError
      表示在静态初始化程序中发生意外异常。
      class  IllegalAccessError
      如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。
      class  IncompatibleClassChangeError
      当一些类定义发生不兼容的类更改时抛出。
      class  InstantiationError
      当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。
      class  InternalError
      在Java虚拟机中引发了一些意外的内部错误。
      class  LinkageError
      LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
      class  NoClassDefFoundError
      如果Java虚拟机或 ClassLoader实例尝试加载一个类的定义（作为普通方法调用的一部分或作为使用 new表达式创建新实例的 new ），则将 new此 new并且不会找到该类的定义。
      class  NoSuchFieldError
      如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。
      class  NoSuchMethodError
      如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。
      class  OutOfMemoryError
      当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。
      class  StackOverflowError
      当堆栈溢出发生时抛出一个应用程序递归太深。
      class  ThreadDeath
      当调用（不推荐使用）的 Thread.stop()方法时， ThreadDeath的实例被抛出在受害者线程中。
      class  UnknownError
      当Java虚拟机中出现未知但严重的异常时抛出。
      class  UnsatisfiedLinkError
      如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。
      class  UnsupportedClassVersionError
      当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
      class  VerifyError
      当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。
      class  VirtualMachineError
      抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。

    • Uses of Error in java.lang.annotation

      Subclasses of Error in java.lang.annotation
      Modifier and Type Class 描述
      class  AnnotationFormatError
      当注释解析器尝试从类文件读取注释并确定注释格式错误时抛出。

    • Uses of Error in java.lang.reflect

      Subclasses of Error in java.lang.reflect
      Modifier and Type Class 描述
      class  GenericSignatureFormatError
      当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。

    • Uses of Error in java.nio.charset

      Subclasses of Error in java.nio.charset
      Modifier and Type Class 描述
      class  CoderMalfunctionError
      错误抛出当decodeLoop方法的CharsetDecoder ，或encodeLoop一个的方法CharsetEncoder ，抛出意外的异常。

    • Uses of Error in java.rmi

      Constructors in java.rmi with parameters of type Error
      Constructor 描述
      ServerError​(String s, Error err)
      构造具有指定的详细消息和嵌套错误的 ServerError 。

    • Uses of Error in java.util

      Subclasses of Error in java.util
      Modifier and Type Class 描述
      class  ServiceConfigurationError
      在查找，加载或实例化服务提供商时发生错误时发生错误。

    • Uses of Error in java.util.zip

      Subclasses of Error in java.util.zip
      Modifier and Type Class 描述
      class  ZipError
      表示发生了不可恢复的错误。

    • Uses of Error in javax.management

      Methods in javax.management that return Error
      Modifier and Type 方法 描述
      Error RuntimeErrorException.getTargetError​()
      返回实际抛出的Error 。
      Constructors in javax.management with parameters of type Error
      Constructor 描述
      RuntimeErrorException​(Error e)
      默认构造函数。
      RuntimeErrorException​(Error e, String message)
      允许指定特定错误消息的构造方法。

    • Uses of Error in javax.management.remote

      Constructors in javax.management.remote with parameters of type Error
      Constructor 描述
      JMXServerErrorException​(String s, Error err)
      构造具有指定的详细消息和嵌套错误的 JMXServerErrorException 。

    • Uses of Error in javax.xml.parsers

      Subclasses of Error in javax.xml.parsers
      Modifier and Type Class 描述
      class  FactoryConfigurationError
      当与Parser工厂存在配置问题时抛出。

    • Uses of Error in javax.xml.stream

      Subclasses of Error in javax.xml.stream
      Modifier and Type Class 描述
      class  FactoryConfigurationError
      报告工厂配置错误的错误类。

    • Uses of Error in javax.xml.transform

      Subclasses of Error in javax.xml.transform
      Modifier and Type Class 描述
      class  TransformerFactoryConfigurationError
      当Transformer工厂存在配置问题时抛出。

    • Uses of Error in javax.xml.validation

      Subclasses of Error in javax.xml.validation
      Modifier and Type Class 描述
      class  SchemaFactoryConfigurationError
      当存在具有Schema工厂的配置问题时抛出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Exception (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Exception

  • Packages that use 异常
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.connect.spi
    该包包含用于开发新的TransportService实现的接口和类。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    com.sun.tools.javac
    该包提供了 javac工具的传统入口点。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.im.spi
    提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.application
    提供应用程序生命周期类。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换变换。
    javax.activation
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.timer
    提供定时器MBean的定义。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming包以提供访问目录服务的功能。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.naming.spi
    提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.cert
    提供公钥证书类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    javax.transaction.xa
    提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.annotation.adapters
    XmlAdapter及其指定的子类允许任意Java类与JAXB一起使用。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.http
    该包定义了特定于HTTP绑定的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.jshell.tool
    提供一种启动Javaâ壳工具实例的机制。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.security.jarsigner
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，其实现为程序员可以将其用作全功能对象请求代理（ORB）。
    org.omg.CORBA.DynAnyPackage
    提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。
    org.omg.CORBA.ORBPackage
    提供异常 InvalidName ，这是由方法抛出 ORB.resolve_initial_references和异常 InconsistentTypeCode ，这是由动态的ORB类中的任何创建方法抛出。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.omg.CORBA.TypeCodePackage
    提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。
    org.omg.CosNaming.NamingContextExtPackage
    此软件包包含以下类别，用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress
    org.omg.CosNaming.NamingContextPackage
    此包包含 org.omg.CosNaming包的异常类。
    org.omg.DynamicAny.DynAnyFactoryPackage
    该包包含OMG “公共对象请求代理：体系结构和规范 ” formal/99-10-07第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。
    org.omg.DynamicAny.DynAnyPackage
    该包包含OMG “公共对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。
    org.omg.IOP.CodecFactoryPackage
    该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。
    org.omg.IOP.CodecPackage
    该包是从IOP :: Codec IDL接口定义生成的。
    org.omg.PortableInterceptor
    提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。
    org.omg.PortableInterceptor.ORBInitInfoPackage
    该包包含OMG便携式拦截器规范 ptc/2000-08-06 ，第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。
    org.omg.PortableServer
    提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
    org.omg.PortableServer.CurrentPackage
    提供方法实现，访问方法被调用的对象的标识。
    org.omg.PortableServer.POAManagerPackage
    封装与之相关的POA的处理状态。
    org.omg.PortableServer.POAPackage
    允许程序员构建可在不同ORB产品之间移植的对象实现。
    org.w3c.dom
    提供文档对象模型（DOM）的接口。
    org.w3c.dom.events
    提供DOM Level 2事件的接口。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.w3c.dom.ranges
    提供DOM Level 2范围的界面。
    org.w3c.dom.xpath
    提供DOM Level 3 XPath规范的接口。
    org.xml.sax
    提供核心SAX API。

    • Uses of 异常 in com.sun.jdi

      Subclasses of 异常 in com.sun.jdi
      Modifier and Type Class 描述
      class  AbsentInformationException
      抛出以表示行号或变量信息不可用。
      class  ClassNotLoadedException
      抛出，表示请求的类尚未通过适当的类加载器加载。
      class  ClassNotPreparedException
      抛出以指示由于指定的类尚未准备而请求的操作无法完成。
      class  IncompatibleThreadStateException
      抛出以指示所请求的操作在指定线程处于当前状态时无法完成。
      class  InconsistentDebugInfoException
      被抛出以表明目标VM提供的调试信息有不一致之处。
      class  InternalException
      抛出，表示出现意外的内部错误。
      class  InvalidCodeIndexException
      已过时。
      不再抛出此异常
      class  InvalidLineNumberException
      已过时。
      不再抛出此异常
      class  InvalidModuleException
      抛出以表明所请求的模块在卸载模块后无效或无效。
      class  InvalidStackFrameException
      抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。
      class  InvalidTypeException
      抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。
      class  InvocationException
      抛出以指示目标VM中的调用方法中发生异常。
      class  NativeMethodException
      抛出表示操作无法完成，因为它对本机方法无效。
      class  ObjectCollectedException
      抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。
      class  VMCannotBeModifiedException
      抛出以表示操作无效，因为它会修改VM，VM是只读的。
      class  VMDisconnectedException
      抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。
      class  VMMismatchException
      抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。
      class  VMOutOfMemoryException
      抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。

    • Uses of 异常 in com.sun.jdi.connect

      Subclasses of 异常 in com.sun.jdi.connect
      Modifier and Type Class 描述
      class  IllegalConnectorArgumentsException
      抛出表示无效的参数或不一致传递给Connector 。
      class  TransportTimeoutException
      当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。
      class  VMStartException
      目标VM已成功启动，但在建立连接之前会发生错误。

    • Uses of 异常 in com.sun.jdi.connect.spi

      Subclasses of 异常 in com.sun.jdi.connect.spi
      Modifier and Type Class 描述
      class  ClosedConnectionException
      由于在进行I / O操作时异步关闭Connection可能会抛出此异常。

    • Uses of 异常 in com.sun.jdi.request

      Subclasses of 异常 in com.sun.jdi.request
      Modifier and Type Class 描述
      class  DuplicateRequestException
      抛出以表示重复的事件请求。
      class  InvalidRequestStateException
      抛出以表示所请求的事件由于启用而无法修改。

    • Uses of 异常 in com.sun.nio.sctp

      Subclasses of 异常 in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  IllegalReceiveException
      尝试从通知处理程序调用SctpChannel或SctpMultiChannel的receive方法时抛出未检查的异常。
      class  IllegalUnbindException
      尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。
      class  InvalidStreamException
      尝试将消息发送到无效流时抛出未检查的异常。

    • Uses of 异常 in com.sun.tools.attach

      Subclasses of 异常 in com.sun.tools.attach
      Modifier and Type Class 描述
      class  AgentInitializationException
      当代理程序无法在目标Java虚拟机中初始化时抛出异常。
      class  AgentLoadException
      代理无法加载到目标Java虚拟机时抛出的异常。
      class  AttachNotSupportedException
      当尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。
      class  AttachOperationFailedException
      异常类型表示目标虚拟机中附着操作失败。

    • Uses of 异常 in com.sun.tools.javac

      Methods in com.sun.tools.javac that throw 异常
      Modifier and Type 方法 描述
      static void Main.main​(String[] args)
      发射器的主入口点。

    • Uses of 异常 in java.awt

      Subclasses of 异常 in java.awt
      Modifier and Type Class 描述
      class  AWTException
      表示发生抽象窗口工具包异常。
      class  FontFormatException
      在 Font类中通过 Font方法抛出，指示指定的字体不好。
      class  HeadlessException
      在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
      class  IllegalComponentStateException
      表示AWT组件对于请求的操作不在适当的状态。

    • Uses of 异常 in java.awt.color

      Subclasses of 异常 in java.awt.color
      Modifier and Type Class 描述
      class  CMMException
      如果本机CMM返回错误，则抛出此异常。
      class  ProfileDataException
      在访问或处理ICC_Profile对象时发生错误时抛出此异常。

    • Uses of 异常 in java.awt.datatransfer

      Subclasses of 异常 in java.awt.datatransfer
      Modifier and Type Class 描述
      class  MimeTypeParseException
      封装MimeType解析相关异常的类。
      class  UnsupportedFlavorException
      表示在此风格中不支持请求的数据。

    • Uses of 异常 in java.awt.dnd

      Subclasses of 异常 in java.awt.dnd
      Modifier and Type Class 描述
      class  InvalidDnDOperationException
      java.awt.dnd包中的各种方法抛出此异常。

    • Uses of 异常 in java.awt.event

      Methods in java.awt.event that return 异常
      Modifier and Type 方法 描述
      异常 InvocationEvent.getException​()
      返回在执行Runnable的 run()方法时捕获的任何异常。

    • Uses of 异常 in java.awt.geom

      Subclasses of 异常 in java.awt.geom
      Modifier and Type Class 描述
      class  IllegalPathStateException
      如果在相对于正在执行的特定操作处于非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段追加到GeneralPath 。
      class  NoninvertibleTransformException
      NoninvertibleTransformException类表示如果执行操作需要AffineTransform对象的反向但AffineTransform处于不可逆状态时抛出异常。

    • Uses of 异常 in java.awt.im.spi

      Methods in java.awt.im.spi that throw 异常
      Modifier and Type 方法 描述
      InputMethod InputMethodDescriptor.createInputMethod​()
      创建相应输入法的新实例。

    • Uses of 异常 in java.awt.image

      Subclasses of 异常 in java.awt.image
      Modifier and Type Class 描述
      class  ImagingOpException
      所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。
      class  RasterFormatException
      如果RasterFormatException中有无效的布局信息，则会抛出RasterFormatException 。

    • Uses of 异常 in java.awt.print

      Subclasses of 异常 in java.awt.print
      Modifier and Type Class 描述
      class  PrinterAbortException
      所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。
      class  PrinterException
      PrinterException类及其子类用于指示在打印系统中出现异常情况。
      class  PrinterIOException
      该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。

    • Uses of 异常 in java.beans

      Subclasses of 异常 in java.beans
      Modifier and Type Class 描述
      class  IntrospectionException
      内省时发生异常时抛出。
      class  PropertyVetoException
      当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。
      Methods in java.beans with parameters of type 异常
      Modifier and Type 方法 描述
      void ExceptionListener.exceptionThrown​(异常 e)
      当可捕获的异常被捕获时，调用此方法。
      Methods in java.beans that throw 异常
      Modifier and Type 方法 描述
      void Expression.execute​()
      execute方法查找名称与 methodName属性相同的方法，并调用目标方法。
      void Statement.execute​()
      execute方法查找名称与 methodName属性相同的方法，并调用目标方法。
      Object Expression.getValue​()
      如果此实例的value属性尚未设置，则此方法使用这些参数动态地找到具有指定的methodName的方法并调用该实例。

    • Uses of 异常 in java.io

      Subclasses of 异常 in java.io
      Modifier and Type Class 描述
      class  CharConversionException
      字符转换异常的基类。
      class  EOFException
      表示在输入过程中意外地到达文件结束或流结束。
      class  FileNotFoundException
      指示尝试打开由指定路径名表示的文件失败。
      class  InterruptedIOException
      表示I / O操作已中断。
      class  InvalidClassException
      当序列化运行时检测到类中的以下问题之一时抛出。
      class  InvalidObjectException
      表示一个或多个反序列化对象失败的验证测试。
      class  IOException
      表示发生某种类型的I / O异常。
      class  NotActiveException
      序列化或反序列化不活跃时抛出。
      class  NotSerializableException
      抛出一个实例需要一个Serializable接口。
      class  ObjectStreamException
      对象流类别特有的所有异常的超类。
      class  OptionalDataException
      表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。
      class  StreamCorruptedException
      当从对象流读取的控制信息违反内部一致性检查时抛出。
      class  SyncFailedException
      发出同步操作失败的信号。
      class  UncheckedIOException
      包含一个IOException与未选中的异常。
      class  UnsupportedEncodingException
      字符编码不支持。
      class  UTFDataFormatException
      表示 modified UTF-8格式的格式不正确的字符串已被读入数据输入流或任何实现数据输入接口的类。
      class  WriteAbortedException
      指示在写入操作期间抛出ObjectStreamExceptions之一。
      Fields in java.io declared as 异常
      Modifier and Type Field 描述
      异常 WriteAbortedException.detail
      写入ObjectStream时被捕获的异常。
      Constructors in java.io with parameters of type 异常
      Constructor 描述
      WriteAbortedException​(String s, 异常 ex)
      构造一个WriteAbortedException，其中包含一个描述异常的字符串，异常导致中止。

    • Uses of 异常 in java.lang

      Subclasses of 异常 in java.lang
      Modifier and Type Class 描述
      class  ArithmeticException
      抛出异常算术条件时抛出。
      class  ArrayIndexOutOfBoundsException
      抛出以表示使用非法索引访问数组。
      class  ArrayStoreException
      抛出以表示尝试将错误类型的对象存储到对象数组中。
      class  ClassCastException
      抛出表示代码尝试将对象转换为不属于实例的子类。
      class  ClassNotFoundException
      的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
      class  CloneNotSupportedException
      抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
      class  EnumConstantNotPresentException
      当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。
      class  IllegalAccessException
      当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
      class  IllegalArgumentException
      抛出表示一种方法已经通过了非法或不正确的参数。
      class  IllegalCallerException
      被抛出来表示一个方法已被不适当的调用者调用。
      class  IllegalMonitorStateException
      抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。
      class  IllegalStateException
      表示在非法或不适当的时间调用了一种方法。
      class  IllegalThreadStateException
      抛出以指示线程不处于所请求操作的适当状态。
      class  IndexOutOfBoundsException
      抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
      class  InstantiationException
      当应用程序尝试使用类 Class的 newInstance方法尝试创建类的实例时抛出，但指定的类对象不能被实例化。
      class  InterruptedException
      线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
      class  LayerInstantiationException
      创建module layer时抛出失败。
      class  NegativeArraySizeException
      抛出一个应用程序尝试创建一个负数大小的数组。
      class  NoSuchFieldException
      表示该类没有指定名称的字段。
      class  NoSuchMethodException
      当无法找到特定方法时抛出。
      class  NullPointerException
      当应用程序在需要对象的情况下尝试使用 null时抛出。
      class  NumberFormatException
      抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
      class  ReflectiveOperationException
      核心反射中的反射操作抛出的异常的常见超类。
      class  RuntimeException
      RuntimeException是在Java虚拟机的正常操作期间可以抛出的那些异常的超类。
      class  SecurityException
      由安全管理员抛出，表示安全违规。
      class  StringIndexOutOfBoundsException
      抛出 String方法来指示索引为负或大于字符串的大小。
      class  TypeNotPresentException
      当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。
      class  UnsupportedOperationException
      抛出以表示不支持请求的操作。
      Methods in java.lang that throw 异常
      Modifier and Type 方法 描述
      void AutoCloseable.close​()
      关闭此资源，放弃任何基础资源。

    • Uses of 异常 in java.lang.annotation

      Subclasses of 异常 in java.lang.annotation
      Modifier and Type Class 描述
      class  AnnotationTypeMismatchException
      抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。
      class  IncompleteAnnotationException
      抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。

    • Uses of 异常 in java.lang.instrument

      Subclasses of 异常 in java.lang.instrument
      Modifier and Type Class 描述
      class  IllegalClassFormatException
      当其输入参数无效时，通过执行 ClassFileTransformer.transform抛出。
      class  UnmodifiableClassException
      当其中一个指定的类不能被修改时，通过实现 Instrumentation.redefineClasses抛出。
      class  UnmodifiableModuleException
      抛出以表示模块无法修改。

    • Uses of 异常 in java.lang.invoke

      Subclasses of 异常 in java.lang.invoke
      Modifier and Type Class 描述
      class  LambdaConversionException
      LambdaConversionException
      class  StringConcatException
      当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。
      class  WrongMethodTypeException
      抛出以表示代码尝试通过错误的方法类型调用方法句柄。

    • Uses of 异常 in java.lang.module

      Subclasses of 异常 in java.lang.module
      Modifier and Type Class 描述
      class  FindException
      抛出一个ModuleFinder发生错误时发现一个模块。
      class  InvalidModuleDescriptorException
      读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。
      class  ResolutionException
      在解析一组模块或解析一组具有服务绑定的模块时抛出失败。

    • Uses of 异常 in java.lang.reflect

      Subclasses of 异常 in java.lang.reflect
      Modifier and Type Class 描述
      class  InaccessibleObjectException
      Java语言访问检查无法被抑制时抛出。
      class  InvocationTargetException
      InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
      class  MalformedParameterizedTypeException
      当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。
      class  MalformedParametersException
      当 the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。
      class  UndeclaredThrowableException
      通过方法调用代理实例时抛出的调用处理程序的 invoke方法抛出检查异常（一 Throwable不是分配给 RuntimeException或者 Error ）是不能分配给任何中声明的异常类型 throws方法的条款，在代理实例上调用并分派到调用处理程序。

    • Uses of 异常 in java.net

      Subclasses of 异常 in java.net
      Modifier and Type Class 描述
      class  BindException
      指示尝试将套接字绑定到本地地址和端口时发生错误。
      class  ConnectException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  HttpRetryException
      抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。
      class  MalformedURLException
      抛出以表示发生格式不正确的网址。
      class  NoRouteToHostException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  PortUnreachableException
      指示在连接的数据报上收到了ICMP端口不可达消息。
      class  ProtocolException
      抛出以表示底层协议有错误，如TCP错误。
      class  SocketException
      抛出以表示创建或访问Socket时出错。
      class  SocketTimeoutException
      指示在套接字上发生超时时读取或接受。
      class  UnknownHostException
      抛出以表示无法确定主机的IP地址。
      class  UnknownServiceException
      抛出以表示发生未知服务异常。
      class  URISyntaxException
      检查的异常抛出以指示不能将字符串解析为URI引用。

    • Uses of 异常 in java.nio

      Subclasses of 异常 in java.nio
      Modifier and Type Class 描述
      class  BufferOverflowException
      相对 放置操作达到目标缓冲区限制时抛出的未检查异常。
      class  BufferUnderflowException
      当相对 get操作达到源缓冲区的限制时抛出未检查的异常。
      class  InvalidMarkException
      当未定义其标记时尝试复位缓冲区时抛出未检查的异常。
      class  ReadOnlyBufferException
      当在只读缓冲区上调用诸如 put或 compact类的内容突变方法时抛出未检查的异常。

    • Uses of 异常 in java.nio.channels

      Subclasses of 异常 in java.nio.channels
      Modifier and Type Class 描述
      class  AcceptPendingException
      尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
      class  AlreadyBoundException
      尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
      class  AlreadyConnectedException
      尝试连接已连接的SocketChannel时 ，会引发未检查的异常。
      class  AsynchronousCloseException
      当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
      class  CancelledKeyException
      当试图使用不再有效的选择键时抛出未检查的异常。
      class  ClosedByInterruptException
      另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。
      class  ClosedChannelException
      当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。
      class  ClosedSelectorException
      尝试在闭合选择器上调用I / O操作时抛出未检查的异常。
      class  ConnectionPendingException
      尝试连接未阻塞连接操作的SocketChannel时，会引发未检查的异常。
      class  FileLockInterruptionException
      另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。
      class  IllegalBlockingModeException
      当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。
      class  IllegalChannelGroupException
      尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。
      class  IllegalSelectorException
      当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。
      class  InterruptedByTimeoutException
      在异步操作完成之前经过一段时间后线程接收到的异常检查。
      class  NoConnectionPendingException
      当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
      class  NonReadableChannelException
      尝试从最初打开阅读的频道中读取时未抛出的异常。
      class  NonWritableChannelException
      尝试写入最初未打开的通道进行写入时抛出未检查的异常。
      class  NotYetBoundException
      尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
      class  NotYetConnectedException
      当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
      class  OverlappingFileLockException
      当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
      class  ReadPendingException
      尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
      class  ShutdownChannelGroupException
      当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。
      class  UnresolvedAddressException
      尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
      class  UnsupportedAddressTypeException
      尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。
      class  WritePendingException
      尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。

    • Uses of 异常 in java.nio.charset

      Subclasses of 异常 in java.nio.charset
      Modifier and Type Class 描述
      class  CharacterCodingException
      发生字符编码或解码错误时抛出的检查异常。
      class  IllegalCharsetNameException
      当使用不是 legal charset name的字符串时抛出未检查的异常。
      class  MalformedInputException
      当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
      class  UnmappableCharacterException
      输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。
      class  UnsupportedCharsetException
      对于请求的字符集，当没有可用的支持时抛出未检查的异常。
      Constructors in java.nio.charset with parameters of type 异常
      Constructor 描述
      CoderMalfunctionError​(异常 cause)
      初始化此类的实例。

    • Uses of 异常 in java.nio.file

      Subclasses of 异常 in java.nio.file
      Modifier and Type Class 描述
      class  AccessDeniedException
      文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。
      class  AtomicMoveNotSupportedException
      当文件不能作为原子文件系统操作移动时，检查的异常抛出。
      class  ClosedDirectoryStreamException
      尝试在关闭的目录流上调用操作时抛出未检查的异常。
      class  ClosedFileSystemException
      尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。
      class  ClosedWatchServiceException
      尝试在关闭的手表服务上调用操作时抛出未检查的异常。
      class  DirectoryIteratorException
      如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。
      class  DirectoryNotEmptyException
      由于目录不为空，文件系统操作失败时抛出的检查异常。
      class  FileAlreadyExistsException
      尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
      class  FileSystemAlreadyExistsException
      新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新
      class  FileSystemException
      在一个或两个文件上的文件系统操作失败时抛出。
      class  FileSystemLoopException
      当遇到文件系统循环或循环时抛出的检查异常。
      class  FileSystemNotFoundException
      无法找到文件系统时抛出的运行时异常。
      class  InvalidPathException
      当路径字符串无法转换为Path时导致未检查的异常，因为路径字符串包含无效字符，或路径字符串对于其他文件系统特定的原因无效。
      class  NoSuchFileException
      当尝试访问不存在的文件时抛出检查的异常。
      class  NotDirectoryException
      当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
      class  NotLinkException
      由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
      class  ProviderMismatchException
      当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。
      class  ProviderNotFoundException
      无法找到所需类型的提供者时抛出的运行时异常。
      class  ReadOnlyFileSystemException
      尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。

    • Uses of 异常 in java.nio.file.attribute

      Subclasses of 异常 in java.nio.file.attribute
      Modifier and Type Class 描述
      class  UserPrincipalNotFoundException
      当查询UserPrincipal因为主体不存在而失败时检查异常。

    • Uses of 异常 in java.rmi

      Subclasses of 异常 in java.rmi
      Modifier and Type Class 描述
      class  AccessException
      一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
      class  AlreadyBoundException
      如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出一个 AlreadyBoundException 。
      class  ConnectException
      如果连接拒绝远程主机进行远程方法调用，则会抛出 ConnectException 。
      class  ConnectIOException
      如果在连接到远程主机进行远程方法调用时发生 ConnectIOException则抛出 IOException 。
      class  MarshalException
      如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。
      class  NoSuchObjectException
      如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
      class  NotBoundException
      如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则会抛出 NotBoundException 。
      class  RemoteException
      A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
      class  RMISecurityException
      已过时。
      改用SecurityException 。 应用程式代码永远不应该直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。
      class  ServerError
      甲 ServerError被抛出作为远程方法调用的结果，当一个 Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。
      class  ServerException
      甲 ServerException当被抛出作为远程方法调用的结果 RemoteException在处理服务器上的调用，要么同时解编参数或执行远程方法本身被抛出。
      class  ServerRuntimeException
      已过时。
      没有替换
      class  StubNotFoundException
      如果远程对象在导出时无法找到有效的存根类，则抛出 StubNotFoundException 。
      class  UnexpectedException
      如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口的方法的 throws子句中声明的检查的异常类型中。
      class  UnknownHostException
      如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
      class  UnmarshalException
      如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出一个 UnmarshalException ：如果在解组调用头时 java.io.IOException调用头，如果一个 java.io.IOException发生解组参数（on服务器端）或返回值（在客户端）。
      Constructors in java.rmi with parameters of type 异常
      Constructor 描述
      AccessException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 AccessException 。
      ConnectException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ConnectException 。
      ConnectIOException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ConnectIOException 。
      MarshalException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 MarshalException 。
      ServerException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ServerException 。
      ServerRuntimeException​(String s, 异常 ex)
      已过时。
      没有替换
      StubNotFoundException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 StubNotFoundException 。
      UnexpectedException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 UnexpectedException 。
      UnknownHostException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 UnknownHostException 。
      UnmarshalException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 UnmarshalException 。

    • Uses of 异常 in java.rmi.activation

      Subclasses of 异常 in java.rmi.activation
      Modifier and Type Class 描述
      class  ActivateFailedException
      在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。
      class  ActivationException
      激活界面使用的常规异常。
      class  UnknownGroupException
      一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。
      class  UnknownObjectException
      当方法的 ActivationID参数被确定为无效时，将通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。
      Constructors in java.rmi.activation with parameters of type 异常
      Constructor 描述
      ActivateFailedException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ActivateFailedException 。

    • Uses of 异常 in java.rmi.server

      Subclasses of 异常 in java.rmi.server
      Modifier and Type Class 描述
      class  ExportException
      如果尝试导出远程对象失败，则 ExportException是抛出的 RemoteException 。
      class  ServerCloneException
      甲 ServerCloneException如果一个的克隆过程中发生远程抛出异常 UnicastRemoteObject 。
      class  ServerNotActiveException
      如果在服务远程方法调用之外调用getClientHost方法，则 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。
      class  SkeletonMismatchException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SkeletonNotFoundException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SocketSecurityException
      已过时。
      这个班已经过时了 改用ExportException 。
      Fields in java.rmi.server declared as 异常
      Modifier and Type Field 描述
      异常 ServerCloneException.detail
      造成异常的原因。
      Methods in java.rmi.server with parameters of type 异常
      Modifier and Type 方法 描述
      boolean RMIFailureHandler.failure​(异常 ex)
      当RMI运行时无法通过 RMISocketFactory创建 ServerSocket时，将调用 failure回调。
      Methods in java.rmi.server that throw 异常
      Modifier and Type 方法 描述
      void Skeleton.dispatch​(Remote obj, RemoteCall theCall, int opnum, long hash)
      已过时。
      没有替换
      void RemoteCall.executeCall​()
      已过时。
      没有替换
      Object RemoteRef.invoke​(Remote obj, 方法 method, Object[] params, long opnum)
      调用方法。
      void RemoteRef.invoke​(RemoteCall call)
      已过时。
      1.2样式存根不再使用这种方法。 代替使用方法的序列调用远程引用（ newCall ， invoke ，和done ），存根使用单个方法， invoke(Remote, Method, Object[], int) ，在远程参考来进行参数编组，执行远程方法和解组的返回值。
      Constructors in java.rmi.server with parameters of type 异常
      Constructor 描述
      ExportException​(String s, 异常 ex)
      构造具有指定的详细消息和嵌套异常的 ExportException 。
      ServerCloneException​(String s, 异常 cause)
      构造具有指定的详细消息和原因的 ServerCloneException 。
      SkeletonNotFoundException​(String s, 异常 ex)
      已过时。
      构造具有指定的详细消息和嵌套异常的 SkeletonNotFoundException 。
      SocketSecurityException​(String s, 异常 ex)
      已过时。
      构造具有指定的详细消息和嵌套异常的 SocketSecurityException 。

    • Uses of 异常 in java.security

      Subclasses of 异常 in java.security
      Modifier and Type Class 描述
      class  AccessControlException
      AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
      class  DigestException
      这是通用的消息摘要异常。
      class  GeneralSecurityException
      GeneralSecurityException类是一种通用安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。
      class  InvalidAlgorithmParameterException
      这是无效或不合适的算法参数的例外。
      class  InvalidKeyException
      这是无效键（无效编码，长度错误，未初始化等）的例外。
      class  InvalidParameterException
      当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
      class  KeyException
      这是基本的关键例外。
      class  KeyManagementException
      这是处理密钥管理的所有操作的一般密钥管理例外。
      class  KeyStoreException
      这是通用的KeyStore异常。
      class  NoSuchAlgorithmException
      当请求特定的加密算法但在环境中不可用时抛出此异常。
      class  NoSuchProviderException
      当特定安全提供程序被请求但在环境中不可用时抛出此异常。
      class  PrivilegedActionException
      这个异常是由 doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)引发的，表示正在执行的操作会抛出一个被检查的异常。
      class  ProviderException
      提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。
      class  SignatureException
      这是一般的签名异常。
      class  UnrecoverableEntryException
      如果密钥库中的条目无法恢复，则抛出此异常。
      class  UnrecoverableKeyException
      如果密钥存储库中的密钥无法恢复，则抛出此异常。
      Methods in java.security that return 异常
      Modifier and Type 方法 描述
      异常 PrivilegedActionException.getException​()
      返回导致此 PrivilegedActionException的特权计算抛出的异常。
      Methods in java.security that throw 异常
      Modifier and Type 方法 描述
      T PrivilegedExceptionAction.run​()
      执行计算。
      Constructors in java.security with parameters of type 异常
      Constructor 描述
      PrivilegedActionException​(异常 exception)
      构造一个新的PrivilegedActionException“包装”特定的异常。

    • Uses of 异常 in java.security.acl

      Subclasses of 异常 in java.security.acl
      Modifier and Type Class 描述
      class  AclNotFoundException
      已过时。
      自1.2版本以来，该软件已被替换为java.security.Policy和相关类。
      class  LastOwnerException
      已过时。
      该软件包自java.security.Policy以来被替换为java.security.Policy和相关类。
      class  NotOwnerException
      已过时。
      自1.2版本以来，该软件已被替换为java.security.Policy和相关类。

    • Uses of 异常 in java.security.cert

      Subclasses of 异常 in java.security.cert
      Modifier and Type Class 描述
      class  CertificateEncodingException
      证书编码异常。
      class  CertificateException
      此异常表示各种证书问题之一。
      class  CertificateExpiredException
      证书过期例外
      class  CertificateNotYetValidException
      证书还没有有效的例外。
      class  CertificateParsingException
      证书解析异常。
      class  CertificateRevokedException
      表示X.509证书的异常被撤销。
      class  CertPathBuilderException
      一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。
      class  CertPathValidatorException
      表示验证认证路径时遇到的各种问题之一的异常。
      class  CertStoreException
      一个例外，指出从 CertStore检索证书和CRL的各种问题 CertStore 。
      class  CRLException
      CRL（证书撤销列表）异常。

    • Uses of 异常 in java.security.spec

      Subclasses of 异常 in java.security.spec
      Modifier and Type Class 描述
      class  InvalidKeySpecException
      这是无效密钥规范的例外。
      class  InvalidParameterSpecException
      这是无效参数规范的例外。

    • Uses of 异常 in java.sql

      Subclasses of 异常 in java.sql
      Modifier and Type Class 描述
      class  BatchUpdateException
      在批量更新操作期间发生错误时抛出的SQLException的子类。
      class  DataTruncation
      由于其超出 MaxFieldSize原因导致数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取时）。
      class  SQLClientInfoException
      当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。
      class  SQLDataException
      当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLException
      提供有关数据库访问错误或其他错误的信息的异常。
      class  SQLFeatureNotSupportedException
      当SQLState类值为' 0A '（值为'零'A）时，抛出SQLException的子类。
      class  SQLIntegrityConstraintViolationException
      当SQLState类值为“ 23 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLInvalidAuthorizationSpecException
      当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLNonTransientConnectionException
      的亚类SQLException抛出的SQLState类值“08”，或供应商指定的条件下进行。
      class  SQLNonTransientException
      当一个重试相同操作的实例将失败的情况下，抛出SQLException的子类，除非修正了SQLException的原因。
      class  SQLRecoverableException
      如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，以前发生故障的操作可能会成功的子类抛出SQLException 。
      class  SQLSyntaxErrorException
      当SQLState类值为' 42 '时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTimeoutException
      的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。
      class  SQLTransactionRollbackException
      当SQLState类值为“ 40 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTransientConnectionException
      用于SQLState类值为“ 08 ”的SQLException的子类，或者在供应商指定的条件下。
      class  SQLTransientException
      SQLException的子类在以前失败的操作可能能够在没有应用程序级功能的任何干预的情况下重试操作时能够成功的情况下抛出。
      class  SQLWarning
      提供有关数据库访问警告的信息的异常。

    • Uses of 异常 in java.text

      Subclasses of 异常 in java.text
      Modifier and Type Class 描述
      class  ParseException
      表示解析时意外出现错误。

    • Uses of 异常 in java.time

      Subclasses of 异常 in java.time
      Modifier and Type Class 描述
      class  DateTimeException
      用于在计算日期时间时指示问题的异常。

    • Uses of 异常 in java.time.format

      Subclasses of 异常 in java.time.format
      Modifier and Type Class 描述
      class  DateTimeParseException
      解析期间发生错误时抛出异常。

    • Uses of 异常 in java.time.temporal

      Subclasses of 异常 in java.time.temporal
      Modifier and Type Class 描述
      class  UnsupportedTemporalTypeException
      UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。

    • Uses of 异常 in java.time.zone

      Subclasses of 异常 in java.time.zone
      Modifier and Type Class 描述
      class  ZoneRulesException
      抛出指示时区配置的问题。

    • Uses of 异常 in java.util

      Subclasses of 异常 in java.util
      Modifier and Type Class 描述
      class  ConcurrentModificationException
      当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。
      class  DuplicateFormatFlagsException
      在格式说明符中提供重复标志时抛出未经检查的异常。
      class  EmptyStackException
      由 Stack类中的方法抛出，表示堆栈为空。
      class  FormatFlagsConversionMismatchException
      转换和标志不兼容时抛出未经检查的异常。
      class  FormatterClosedException
      格式化程序已关闭时抛出未检查的异常。
      class  IllegalFormatCodePointException
      当由Character.isValidCodePoint(int)定义的具有无效Unicode代码的字符的字符传递给Formatter时，会抛出未经检查的异常。
      class  IllegalFormatConversionException
      当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。
      class  IllegalFormatException
      当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。
      class  IllegalFormatFlagsException
      提供非法组合标志时抛出未检查的异常。
      class  IllegalFormatPrecisionException
      当精度为 -1以外的负值时，抛出未检查的异常，转换不支持精度，否则不支持该值。
      class  IllegalFormatWidthException
      当格式宽度为 -1以外的否定值时，抛出未经检查的异常，否则不受支持。
      class  IllformedLocaleException
      通过Locale和Locale.Builder中的方法抛出，表明参数不是一个格式正确的BCP 47标签。
      class  InputMismatchException
      由 Scanner抛出，表示检索到的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。
      class  InvalidPropertiesFormatException
      抛出以表示操作无法完成，因为输入不符合属性集合的相应XML文档类型，符合Properties规范。
      class  MissingFormatArgumentException
      当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
      class  MissingFormatWidthException
      需要格式宽度时抛出未检查的异常。
      class  MissingResourceException
      表示资源丢失。
      class  NoSuchElementException
      被各种访问器方法抛出，表示被请求的元素不存在。
      class  TooManyListenersException
      TooManyListenersException异常用作Java事件模型的一部分，用于注释和实现组播事件源的单播特殊情况。
      class  UnknownFormatConversionException
      给出未知转换时抛出未检查的异常。
      class  UnknownFormatFlagsException
      给定未知标志时抛出未检查的异常。

    • Uses of 异常 in java.util.concurrent

      Subclasses of 异常 in java.util.concurrent
      Modifier and Type Class 描述
      class  BrokenBarrierException
      当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。
      class  CancellationException
      异常表示由于任务被取消，无法检索生产任务的结果，如FutureTask 。
      class  CompletionException
      在完成结果或任务的过程中遇到错误或其他异常时抛出异常。
      class  ExecutionException
      尝试检索通过抛出异常中止的任务的结果时抛出的异常。
      class  RejectedExecutionException
      当一个任务不能接受执行时，由一个Executor抛出的异常。
      class  TimeoutException
      阻塞操作超时时抛出异常。
      Methods in java.util.concurrent that throw 异常
      Modifier and Type 方法 描述
      V Callable.call​()
      计算一个结果，如果不能这样做，就会抛出一个异常。

    • Uses of 异常 in java.util.jar

      Subclasses of 异常 in java.util.jar
      Modifier and Type Class 描述
      class  JarException
      表示在读取或写入JAR文件时发生了某种错误。

    • Uses of 异常 in java.util.logging

      Methods in java.util.logging with parameters of type 异常
      Modifier and Type 方法 描述
      void ErrorManager.error​(String msg, 异常 ex, int code)
      发生处理程序失败时调用错误方法。
      protected void Handler.reportError​(String msg, 异常 ex, int code)
      受保护的方便方法来向此处理程序的ErrorManager报告错误。

    • Uses of 异常 in java.util.prefs

      Subclasses of 异常 in java.util.prefs
      Modifier and Type Class 描述
      class  BackingStoreException
      抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。
      class  InvalidPreferencesFormatException
      被抛出以表示操作无法完成，因为输入符合Preferences规范的首选项集合的相应XML文档类型。

    • Uses of 异常 in java.util.regex

      Subclasses of 异常 in java.util.regex
      Modifier and Type Class 描述
      class  PatternSyntaxException
      抛出未经检查的异常，以指示正则表达式模式中的语法错误。

    • Uses of 异常 in java.util.zip

      Subclasses of 异常 in java.util.zip
      Modifier and Type Class 描述
      class  DataFormatException
      发出数据格式错误的信号。
      class  ZipException
      表示发生了某种类型的Zip异常。

    • Uses of 异常 in javafx.application

      Methods in javafx.application that throw 异常
      Modifier and Type 方法 描述
      void Application.init​()
      应用程序初始化方法。
      abstract void Application.start​(Stage primaryStage)
      所有JavaFX应用程序的主要入口点。
      void Application.stop​()
      当应用程序停止时，调用此方法，并为应用程序退出和销毁资源提供了便利的场所。

    • Uses of 异常 in javafx.concurrent

      Methods in javafx.concurrent that throw 异常
      Modifier and Type 方法 描述
      protected abstract V Task.call​()
      在执行任务时调用，调用方法必须被子类覆盖并实现。

    • Uses of 异常 in javafx.fxml

      Subclasses of 异常 in javafx.fxml
      Modifier and Type Class 描述
      class  LoadException
      在加载操作期间遇到错误时抛出。

    • Uses of 异常 in javafx.scene.image

      Methods in javafx.scene.image that return 异常
      Modifier and Type 方法 描述
      异常 Image.getException​()
      获取属性异常的值。
      Methods in javafx.scene.image that return types with arguments of type 异常
      Modifier and Type 方法 描述
      ReadOnlyObjectProperty<异常> Image.exceptionProperty​()
      导致图像加载失败的异常。

    • Uses of 异常 in javafx.scene.media

      Subclasses of 异常 in javafx.scene.media
      Modifier and Type Class 描述
      class  MediaException
      甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。

    • Uses of 异常 in javafx.scene.transform

      Subclasses of 异常 in javafx.scene.transform
      Modifier and Type Class 描述
      class  NonInvertibleTransformException
      NonInvertibleTransformException类表示如果执行的操作需要处于非可逆状态的 Transform对象的倒数时抛出异常。

    • Uses of 异常 in javax.activation

      Subclasses of 异常 in javax.activation
      Modifier and Type Class 描述
      class  MimeTypeParseException
      封装MimeType解析相关异常的类。
      class  UnsupportedDataTypeException
      表示请求的操作不支持请求的数据类型。

    • Uses of 异常 in javax.activity

      Subclasses of 异常 in javax.activity
      Modifier and Type Class 描述
      class  ActivityCompletedException
      可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。
      class  ActivityRequiredException
      如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。
      class  InvalidActivityException
      可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。

    • Uses of 异常 in javax.annotation.processing

      Subclasses of 异常 in javax.annotation.processing
      Modifier and Type Class 描述
      class  FilerException
      表示一个Filer检测到尝试打开一个文件，将违反Filer提供的保证。

    • Uses of 异常 in javax.crypto

      Subclasses of 异常 in javax.crypto
      Modifier and Type Class 描述
      class  AEADBadTagException
      当以AEAD模式运行的Cipher （例如GCM / CCM）无法验证提供的认证标签时，会抛出此异常。
      class  BadPaddingException
      当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
      class  ExemptionMechanismException
      这是通用的ExemptionMechanism异常。
      class  IllegalBlockSizeException
      当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。
      class  NoSuchPaddingException
      当请求特定的填充机制但在环境中不可用时抛出此异常。
      class  ShortBufferException
      当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。

    • Uses of 异常 in javax.imageio

      Subclasses of 异常 in javax.imageio
      Modifier and Type Class 描述
      class  IIOException
      用于发信号读取和写入操作失败的异常类。

    • Uses of 异常 in javax.imageio.metadata

      Subclasses of 异常 in javax.imageio.metadata
      Modifier and Type Class 描述
      class  IIOInvalidTreeException
      一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。

    • Uses of 异常 in javax.jnlp

      Subclasses of 异常 in javax.jnlp
      Modifier and Type Class 描述
      class  UnavailableServiceException
      当 UnavailableServiceException不存在或不可用的服务时， UnavailableServiceException被抛出 ServiceManager 。

    • Uses of 异常 in javax.lang.model

      Subclasses of 异常 in javax.lang.model
      Modifier and Type Class 描述
      class  UnknownEntityException
      例外的超类，表示遇到一个未知类型的实体。

    • Uses of 异常 in javax.lang.model.element

      Subclasses of 异常 in javax.lang.model.element
      Modifier and Type Class 描述
      class  UnknownAnnotationValueException
      表示遇到未知类型的注释值。
      class  UnknownDirectiveException
      表示遇到未知类型的模块指令。
      class  UnknownElementException
      表示遇到未知类型的元素。

    • Uses of 异常 in javax.lang.model.type

      Subclasses of 异常 in javax.lang.model.type
      Modifier and Type Class 描述
      class  MirroredTypeException
      当应用程序尝试访问对应于TypeMirror的Class对象时抛出 。
      class  MirroredTypesException
      当应用程序尝试访问Class个对象的对象时抛出，每个对象对应于一个TypeMirror 。
      class  UnknownTypeException
      表示遇到未知类型的类型。

    • Uses of 异常 in javax.management

      Subclasses of 异常 in javax.management
      Modifier and Type Class 描述
      class  AttributeNotFoundException
      指定的属性不存在或无法检索。
      class  BadAttributeValueExpException
      当无效的MBean属性传递给查询构造方法时抛出。
      class  BadBinaryOpValueExpException
      当无效表达式传递给构造查询的方法时抛出。
      class  BadStringOperationException
      当无效的字符串操作传递给构造查询的方法时抛出。
      class  InstanceAlreadyExistsException
      MBean已经在存储库中注册。
      class  InstanceNotFoundException
      存储库中不存在指定的MBean。
      class  IntrospectionException
      在MBean的内省期间发生了一个例外。
      class  InvalidApplicationException
      当尝试应用以下任一操作时抛出：将MBean的子查询表达式或对错误类的MBean的限定属性表达式。
      class  InvalidAttributeValueException
      指定的值对属性无效。
      class  JMException
      JMX实现抛出异常。
      class  JMRuntimeException
      JMX实现发出的运行时异常。
      class  ListenerNotFoundException
      存储库中不存在指定的MBean侦听器。
      class  MalformedObjectNameException
      字符串的格式不对应于有效的ObjectName。
      class  MBeanException
      表示代理中MBean方法抛出的“用户定义”异常。
      class  MBeanRegistrationException
      包括由preRegister（），preDeregister（）方法抛出的异常 MBeanRegistration接口。
      class  NotCompliantMBeanException
      尝试在不符合JMX的MBean的MBean服务器中注册对象时发生的异常。
      class  OperationsException
      表示对MBean执行操作时MBean服务器中抛出的异常。
      class  ReflectionException
      表示在使用java.lang.reflect类调用MBean方法时，MBean服务器中抛出的异常。
      class  RuntimeErrorException
      当 java.lang.Error发生 java.lang.Error时，应该被捕获并重新抛出为 RuntimeErrorException 。
      class  RuntimeMBeanException
      表示代理中MBean方法抛出的运行时异常。
      class  RuntimeOperationsException
      表示在对MBean执行操作时在代理中抛出的运行时异常。
      class  ServiceNotFoundException
      表示不支持请求的服务时引发的异常。
      Methods in javax.management that return 异常
      Modifier and Type 方法 描述
      异常 MBeanException.getTargetException​()
      返回实际异常抛出。
      异常 ReflectionException.getTargetException​()
      返回实际抛出的异常 。
      Methods in javax.management that throw 异常
      Modifier and Type 方法 描述
      void MBeanRegistration.preDeregister​()
      允许MBean在MBean服务器取消注册之前执行所需的任何操作。
      void StandardMBean.preDeregister​()
      允许MBean在MBean服务器取消注册之前执行所需的任何操作。
      ObjectName MBeanRegistration.preRegister​(MBeanServer server, ObjectName name)
      允许MBean在MBean服务器注册之前执行所需的任何操作。
      ObjectName StandardMBean.preRegister​(MBeanServer server, ObjectName name)
      允许MBean在MBean服务器注册之前执行所需的任何操作。
      Constructors in javax.management with parameters of type 异常
      Constructor 描述
      MBeanException​(异常 e)
      创建一个 MBeanException包裹实际的 java.lang.Exception 。
      MBeanException​(异常 e, String message)
      创建一个 MBeanException ，其中包含实际的 java.lang.Exception与详细消息。
      MBeanRegistrationException​(异常 e)
      创建一个 MBeanRegistrationException ，包裹实际的 java.lang.Exception 。
      MBeanRegistrationException​(异常 e, String message)
      创建一个 MBeanRegistrationException ，其中包含实际的 java.lang.Exception详细消息。
      ReflectionException​(异常 e)
      创建一个 ReflectionException它包裹了实际的 java.lang.Exception 。
      ReflectionException​(异常 e, String message)
      创建一个 ReflectionException ，将实际的 java.lang.Exception包含一条详细消息。

    • Uses of 异常 in javax.management.loading

      Methods in javax.management.loading that throw 异常
      Modifier and Type 方法 描述
      protected URL MLet.check​(String version, URL codebase, String jarfile, MLetContent mlet)
      当扩展此服务以支持缓存和版本控制时，此方法将被覆盖。
      void MLet.preDeregister​()
      允许m-let在MBean服务器取消注册之前执行所需的任何操作。
      ObjectName MLet.preRegister​(MBeanServer server, ObjectName name)
      允许m-let在MBean服务器注册之前执行所需的任何操作。

    • Uses of 异常 in javax.management.modelmbean

      Subclasses of 异常 in javax.management.modelmbean
      Modifier and Type Class 描述
      class  InvalidTargetObjectTypeException
      指定无效目标对象类型时抛出异常。
      class  XMLParseException
      当将XML格式化的字符串解析为ModelMBean对象或从ModelMBean对象创建XML格式的字符串时，将抛出此异常。
      Methods in javax.management.modelmbean that throw 异常
      Modifier and Type 方法 描述
      void RequiredModelMBean.preDeregister​()
      允许MBean在MBean服务器取消注册之前执行所需的任何操作。
      ObjectName RequiredModelMBean.preRegister​(MBeanServer server, ObjectName name)
      允许MBean在MBean服务器注册之前执行所需的任何操作。
      Constructors in javax.management.modelmbean with parameters of type 异常
      Constructor 描述
      InvalidTargetObjectTypeException​(异常 e, String s)
      构造器接受异常和字符串。
      XMLParseException​(异常 e, String s)
      构造函数采用字符串和异常。

    • Uses of 异常 in javax.management.monitor

      Subclasses of 异常 in javax.management.monitor
      Modifier and Type Class 描述
      class  MonitorSettingException
      监视器设置在监视器运行时无效时由监视器抛出异常。
      Methods in javax.management.monitor that throw 异常
      Modifier and Type 方法 描述
      void Monitor.preDeregister​()
      允许监视器MBean在MBean服务器取消注册之前执行所需的任何操作。
      ObjectName Monitor.preRegister​(MBeanServer server, ObjectName name)
      允许监视器MBean在MBean服务器中注册之前执行所需的任何操作。

    • Uses of 异常 in javax.management.openmbean

      Subclasses of 异常 in javax.management.openmbean
      Modifier and Type Class 描述
      class  InvalidKeyException
      抛出此运行时异常以指示预期为 复合数据的项名称或 表格数据的行索引的方法参数无效。
      class  InvalidOpenTypeException
      抛出此运行时异常以指示 打开的类型的 打开数据值不是预期的。
      class  KeyAlreadyExistsException
      抛出此运行时异常以指示要添加到 表格数据实例的行的索引已被用于引用此 表格数据实例中的另一行。
      class  OpenDataException
      当 打开类型 ， 打开数据或 打开的MBean元数据信息实例无法构造时，抛出此检查的异常，因为一个或多个有效性约束不被满足。

    • Uses of 异常 in javax.management.relation

      Subclasses of 异常 in javax.management.relation
      Modifier and Type Class 描述
      class  InvalidRelationIdException
      当已经使用关系id提供给关系时，引发异常。
      class  InvalidRelationServiceException
      当提供无效的关系服务时，引发异常。
      class  InvalidRelationTypeException
      关系类型无效
      class  InvalidRoleInfoException
      当在角色信息中，其最小度大于其最大度时，会引发此异常。
      class  InvalidRoleValueException
      角色值无效。
      class  RelationException
      这个类是在关系管理期间可以提出的任何异常的超类。
      class  RelationNotFoundException
      当关系服务中的给定关系ID没有关系时，会引发此异常。
      class  RelationServiceNotRegisteredException
      当对关系服务进行访问并且没有注册时，会引发此异常。
      class  RelationTypeNotFoundException
      当在关系服务中没有给定名称的关系类型时，引发异常。
      class  RoleInfoNotFoundException
      当给定的关系类型中没有给定名称的角色信息时，会引发此异常。
      class  RoleNotFoundException
      当关系中的角色不存在或不可读或不可设置时，引发此异常。
      Methods in javax.management.relation that throw 异常
      Modifier and Type | 方法 | 描述
      void | RelationService.preDeregister​()
      void | RelationSupport.preDeregister​()
      ObjectName | RelationService.preRegister​(MBeanServer server, ObjectName name)
      ObjectName | RelationSupport.preRegister​(MBeanServer server, ObjectName name)

    • Uses of 异常 in javax.management.remote

      Subclasses of 异常 in javax.management.remote
      Modifier and Type Class 描述
      class  JMXProviderException
      当提供者存在所需的协议但由于某种原因不能使用时，由JMXConnectorFactory和JMXConnectorServerFactory抛出异常。
      class  JMXServerErrorException
      在处理远程MBean服务器中的调用时抛出Error时，由于远程MBeanServer方法调用的结果抛出异常。
      Methods in javax.management.remote that throw 异常
      Modifier and Type 方法 描述
      void JMXConnectorServer.preDeregister​()
      当该连接器服务器从该MBean服务器取消注册时，由MBean服务器调用。

    • Uses of 异常 in javax.management.timer

      Methods in javax.management.timer that throw 异常
      Modifier and Type 方法 描述
      void Timer.preDeregister​()
      允许计时器MBean在MBean服务器取消注册之前执行所需的任何操作。
      ObjectName Timer.preRegister​(MBeanServer server, ObjectName name)
      允许计时器MBean在MBean服务器中注册之前执行所需的任何操作。

    • Uses of 异常 in javax.naming

      Subclasses of 异常 in javax.naming
      Modifier and Type Class 描述
      class  AuthenticationException
      访问命名或目录服务时发生身份验证错误时抛出此异常。
      class  AuthenticationNotSupportedException
      当不支持所请求的身份验证的特定风格时，会抛出此异常。
      class  CannotProceedException
      抛出此异常以指示操作达到操作无法继续进行的名称中的一个点。
      class  CommunicationException
      当客户端无法与目录或命名服务通信时，抛出此异常。
      class  ConfigurationException
      出现配置问题时抛出此异常。
      class  ContextNotEmptyException
      尝试销毁不为空的上下文时抛出此异常。
      class  InsufficientResourcesException
      当资源不可用来完成请求的操作时，抛出此异常。
      class  InterruptedNamingException
      正在调用的命名操作已被中断时抛出此异常。
      class  InvalidNameException
      此异常表示指定的名称不符合命名系统的命名语法。
      class  LimitExceededException
      当方法由于用户或系统指定的限制而异常终止时，会抛出此异常。
      class  LinkException
      此异常用于描述解决链接时遇到的问题。
      class  LinkLoopException
      当尝试解析链接时检测到一个循环，或者达到链接计数的实现特定限制时，会抛出此异常。
      class  MalformedLinkException
      当解决或构建链接时遇到格式错误的链接时抛出此异常。
      class  NameAlreadyBoundException
      通过方法抛出此异常，表示无法添加绑定，因为该名称已被绑定到另一个对象。
      class  NameNotFoundException
      当名称的组件由于未绑定而无法解析时抛出此异常。
      class  NamingException
      这是Context和DirContext接口中的操作抛出的所有异常的超类。
      class  NamingSecurityException
      这是Context和DirContext接口中的操作抛出的与安全相关异常的超类。
      class  NoInitialContextException
      当不能创建初始上下文实现时，抛出此异常。
      class  NoPermissionException
      尝试执行客户端没有权限的操作时抛出此异常。
      class  NotContextException
      当命名操作进行到需要上下文以继续操作的点时抛出此异常，但解析的对象不是上下文。
      class  OperationNotSupportedException
      当上下文实现不支持正在调用的操作时，抛出此异常。
      class  PartialResultException
      抛出此异常以指示到目前为止返回或返回的结果是部分的，并且该操作无法完成。
      class  ReferralException
      此抽象类用于表示引用异常，该引用异常是响应于LDAP v3服务器返回的 引用而生成的。
      class  ServiceUnavailableException
      尝试与目录或命名服务通信并且该服务不可用时，会抛出此异常。
      class  SizeLimitExceededException
      当方法产生超过大小相关限制的结果时，抛出此异常。
      class  TimeLimitExceededException
      当方法不在指定的时间限制内终止时，抛出此异常。

    • Uses of 异常 in javax.naming.directory

      Subclasses of 异常 in javax.naming.directory
      Modifier and Type Class 描述
      class  AttributeInUseException
      当操作尝试添加已经存在的属性时，抛出此异常。
      class  AttributeModificationException
      当尝试添加，删除或修改与属性（模式）定义或属性状态相冲突的属性，其标识符或其值时，将抛出此异常。
      class  InvalidAttributeIdentifierException
      当尝试添加以创建具有无效属性标识符的属性时，会抛出此异常。
      class  InvalidAttributesException
      尝试添加或修改不完整或不正确指定的属性集时，会抛出此异常。
      class  InvalidAttributeValueException
      当尝试向属性添加与属性的模式定义冲突的值时，将抛出此类。
      class  InvalidSearchControlsException
      当搜索操作的SearchControls的规范无效时，抛出此异常。
      class  InvalidSearchFilterException
      当搜索过滤器的规范无效时抛出此异常。
      class  NoSuchAttributeException
      尝试访问不存在的属性时抛出此异常。
      class  SchemaViolationException
      当某种方法违反模式时，抛出此异常。

    • Uses of 异常 in javax.naming.ldap

      Subclasses of 异常 in javax.naming.ldap
      Modifier and Type Class 描述
      class  LdapReferralException
      此抽象类用于表示LDAP引用异常。

    • Uses of 异常 in javax.naming.spi

      Methods in javax.naming.spi that throw 异常
      Modifier and Type 方法 描述
      static Object DirectoryManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      为指定的对象，属性和环境创建一个对象的实例。
      Object DirObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      使用位置或参考信息和指定的属性创建对象。
      static Object NamingManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
      为指定的对象和环境创建一个对象的实例。
      Object ObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      使用指定的位置或引用信息创建对象。

    • Uses of 异常 in javax.net.ssl

      Subclasses of 异常 in javax.net.ssl
      Modifier and Type Class 描述
      class  SSLException
      表示由SSL子系统检测到的某种错误。
      class  SSLHandshakeException
      表示客户端和服务器无法协商所需的安全级别。
      class  SSLKeyException
      报告错误的SSL密钥。
      class  SSLPeerUnverifiedException
      表示对等体的身份尚未验证。
      class  SSLProtocolException
      报告SSL协议操作中的错误。

    • Uses of 异常 in javax.print

      Subclasses of 异常 in javax.print
      Modifier and Type Class 描述
      class  PrintException
      PrintException类封装了在使用Print Service实例时发生的与打印相关的错误条件。
      Constructors in javax.print with parameters of type 异常
      Constructor 描述
      PrintException​(异常 e)
      构造打印异常链接提供的异常。
      PrintException​(String s, 异常 e)
      使用给定的详细消息和链接异常构造打印异常。

    • Uses of 异常 in javax.print.attribute

      Subclasses of 异常 in javax.print.attribute
      Modifier and Type Class 描述
      class  UnmodifiableSetException
      抛出以表示所请求的操作无法执行，因为该集合是不可修改的。

    • Uses of 异常 in javax.script

      Subclasses of 异常 in javax.script
      Modifier and Type Class 描述
      class  ScriptException
      通用的 异常类脚本API。
      Constructors in javax.script with parameters of type 异常
      Constructor 描述
      ScriptException​(异常 e)
      创建一个 ScriptException包装一个底层解释器抛出的一个 异常 。

    • Uses of 异常 in javax.security.auth

      Subclasses of 异常 in javax.security.auth
      Modifier and Type Class 描述
      class  DestroyFailedException
      表示 destroy操作失败。
      class  RefreshFailedException
      表示 refresh操作失败。

    • Uses of 异常 in javax.security.auth.callback

      Subclasses of 异常 in javax.security.auth.callback
      Modifier and Type Class 描述
      class  UnsupportedCallbackException
      信号一个 CallbackHandler不识别一个特定的 Callback 。

    • Uses of 异常 in javax.security.auth.login

      Subclasses of 异常 in javax.security.auth.login
      Modifier and Type Class 描述
      class  AccountException
      通用帐户异常。
      class  AccountExpiredException
      表示用户帐户已过期。
      class  AccountLockedException
      指示帐户被锁定。
      class  AccountNotFoundException
      表示找不到帐户。
      class  CredentialException
      通用凭证异常。
      class  CredentialExpiredException
      信号一个 Credential已过期。
      class  CredentialNotFoundException
      表示没有找到凭据。
      class  FailedLoginException
      表示用户身份验证失败。
      class  LoginException
      这是基本的登录异常。

    • Uses of 异常 in javax.security.cert

      Subclasses of 异常 in javax.security.cert
      Modifier and Type Class 描述
      class  CertificateEncodingException
      已过时。
      使用java.security.cert的类。
      class  CertificateException
      已过时。
      使用java.security.cert的类。
      class  CertificateExpiredException
      已过时。
      使用java.security.cert的类。
      class  CertificateNotYetValidException
      已过时。
      使用java.security.cert的类。
      class  CertificateParsingException
      已过时。
      使用java.security.cert的类。

    • Uses of 异常 in javax.security.sasl

      Subclasses of 异常 in javax.security.sasl
      Modifier and Type Class 描述
      class  AuthenticationException
      由SASL机制实现引发此异常，以指示SASL交换机由于与认证有关的原因（例如无效的身份，密码或密钥）而失败。
      class  SaslException
      此类表示使用SASL时发生的错误。

    • Uses of 异常 in javax.smartcardio

      Subclasses of 异常 in javax.smartcardio
      Modifier and Type Class 描述
      class  CardException
      在与智能卡堆栈或卡本身通信期间发生的错误异常。
      class  CardNotPresentException
      当应用程序尝试与没有存在卡的终端建立连接时抛出异常。

    • Uses of 异常 in javax.sound.midi

      Subclasses of 异常 in javax.sound.midi
      Modifier and Type Class 描述
      class  InvalidMidiDataException
      一个 InvalidMidiDataException表示遇到不适当的MIDI数据。
      class  MidiUnavailableException
      当请求的MIDI组件由于不可用而无法打开或创建时，将抛出 MidiUnavailableException 。

    • Uses of 异常 in javax.sound.sampled

      Subclasses of 异常 in javax.sound.sampled
      Modifier and Type Class 描述
      class  LineUnavailableException
      A LineUnavailableException是一个例外，指示由于不可用而无法打开行。
      class  UnsupportedAudioFileException
      一个 UnsupportedAudioFileException是一个异常，指示操作失败，因为文件不包含已识别的文件类型和格式的有效数据。

    • Uses of 异常 in javax.sql.rowset

      Subclasses of 异常 in javax.sql.rowset
      Modifier and Type Class 描述
      class  RowSetWarning
      扩展名为 SQLException ，其中提供了有关 RowSet对象上设置的数据库警告的信息。

    • Uses of 异常 in javax.sql.rowset.serial

      Subclasses of 异常 in javax.sql.rowset.serial
      Modifier and Type Class 描述
      class  SerialException
      指示和错误的序列化或 BLOB, CLOB, STRUCT or ARRAY序列化的SQL类型，如 BLOB, CLOB, STRUCT or ARRAY除了SQL类型，如 DATALINK and JAVAOBJECT

    • Uses of 异常 in javax.sql.rowset.spi

      Subclasses of 异常 in javax.sql.rowset.spi
      Modifier and Type Class 描述
      class  SyncFactoryException
      表示 SyncFactory机制出错。
      class  SyncProviderException
      表示 SyncProvider机制出错。

    • Uses of 异常 in javax.swing

      Subclasses of 异常 in javax.swing
      Modifier and Type Class 描述
      class  UnsupportedLookAndFeelException
      表示所请求的外观和感觉管理类的异常不在用户系统上。
      Methods in javax.swing that throw 异常
      Modifier and Type 方法 描述
      protected abstract T SwingWorker.doInBackground​()
      计算一个结果，如果不能这样做，就会抛出一个异常。

    • Uses of 异常 in javax.swing.text

      Subclasses of 异常 in javax.swing.text
      Modifier and Type Class 描述
      class  BadLocationException
      此异常是报告文档模型中的不良位置（即尝试引用不存在的位置）。
      class  ChangedCharSetException
      ChangedCharSetException作为名称指示是在更改字符集时抛出的异常。

    • Uses of 异常 in javax.swing.tree

      Subclasses of 异常 in javax.swing.tree
      Modifier and Type Class 描述
      class  ExpandVetoException
      用于阻止扩展/崩溃的异常发生。

    • Uses of 异常 in javax.swing.undo

      Subclasses of 异常 in javax.swing.undo
      Modifier and Type Class 描述
      class  CannotRedoException
      抛出一个UndoableEdit被告知 redo()并且不能。
      class  CannotUndoException
      抛出一个UndoableEdit被告知 undo()并且不能。

    • Uses of 异常 in javax.transaction

      Subclasses of 异常 in javax.transaction
      Modifier and Type Class 描述
      class  InvalidTransactionException
      此异常表示请求携带无效的事务上下文。
      class  TransactionRequiredException
      此异常指示请求携带空事务上下文，但目标对象需要激活事务。
      class  TransactionRolledbackException
      此异常表示与请求的处理关联的事务已回滚，或标记为回滚。

    • Uses of 异常 in javax.transaction.xa

      Subclasses of 异常 in javax.transaction.xa
      Modifier and Type Class 描述
      class  XAException
      资源管理器（RM）抛出XAException，以通知事务管理器涉及的事务遇到的错误。

    • Uses of 异常 in javax.xml.bind

      Subclasses of 异常 in javax.xml.bind
      Modifier and Type Class 描述
      class  DataBindingException
      表示JAXB操作失败的异常。
      class  JAXBException
      这是所有JAXB异常的根异常类。
      class  MarshalException
      此异常表示在执行提供程序无法恢复的组织操作时发生错误。
      class  PropertyException
      此异常表示获取或设置属性时遇到错误。
      class  TypeConstraintException
      此异常表示检测到违反动态检查的类型约束。
      class  UnmarshalException
      此异常表示执行卸载操作时发生错误，阻止JAXB提供程序完成操作。
      class  ValidationException
      此异常表示执行验证操作时发生错误。

    • Uses of 异常 in javax.xml.bind.annotation.adapters

      Methods in javax.xml.bind.annotation.adapters that throw 异常
      Modifier and Type 方法 描述
      abstract ValueType XmlAdapter.marshal​(BoundType v)
      将绑定类型转换为值类型。
      abstract BoundType XmlAdapter.unmarshal​(ValueType v)
      将值类型转换为绑定类型。

    • Uses of 异常 in javax.xml.catalog

      Subclasses of 异常 in javax.xml.catalog
      Modifier and Type Class 描述
      class  CatalogException
      异常类处理在处理或使用目录时可能发生的错误。

    • Uses of 异常 in javax.xml.crypto

      Subclasses of 异常 in javax.xml.crypto
      Modifier and Type Class 描述
      class  KeySelectorException
      表示由KeySelector抛出的异常情况。
      class  MarshalException
      表示在XML编组或解组过程中发生的异常情况。
      class  NoSuchMechanismException
      当请求特定的XML机制但在环境中不可用时抛出此异常。
      class  URIReferenceException
      表示在取消引用URIReference时抛出异常情况。

    • Uses of 异常 in javax.xml.crypto.dsig

      Subclasses of 异常 in javax.xml.crypto.dsig
      Modifier and Type Class 描述
      class  TransformException
      表示执行变换算法时发生的异常情况。
      class  XMLSignatureException
      表示在XML签名生成或验证过程中发生的特殊情况。

    • Uses of 异常 in javax.xml.datatype

      Subclasses of 异常 in javax.xml.datatype
      Modifier and Type Class 描述
      class  DatatypeConfigurationException
      表示严重的配置错误。

    • Uses of 异常 in javax.xml.parsers

      Subclasses of 异常 in javax.xml.parsers
      Modifier and Type Class 描述
      class  ParserConfigurationException
      表示严重的配置错误。
      Methods in javax.xml.parsers that return 异常
      Modifier and Type 方法 描述
      异常 FactoryConfigurationError.getException​()
      返回导致引发此异常的实际异常（如果有的话）。
      Constructors in javax.xml.parsers with parameters of type 异常
      Constructor 描述
      FactoryConfigurationError​(异常 e)
      创建一个新的 FactoryConfigurationError与给定的 异常基本原因的错误。
      FactoryConfigurationError​(异常 e, String msg)
      创建一个新的 FactoryConfigurationError与给定的 异常基本原因和详细信息。

    • Uses of 异常 in javax.xml.soap

      Subclasses of 异常 in javax.xml.soap
      Modifier and Type Class 描述
      class  SOAPException
      发生SOAP异常发生的异常。

    • Uses of 异常 in javax.xml.stream

      Subclasses of 异常 in javax.xml.stream
      Modifier and Type Class 描述
      class  XMLStreamException
      基于异常的意外处理错误。
      Methods in javax.xml.stream that return 异常
      Modifier and Type 方法 描述
      异常 FactoryConfigurationError.getException​()
      返回嵌套异常（如果有）
      Constructors in javax.xml.stream with parameters of type 异常
      Constructor 描述
      FactoryConfigurationError​(异常 e)
      使用嵌套的内部异常构造异常
      FactoryConfigurationError​(异常 e, String msg)
      使用嵌套的内部异常和消息构造异常
      FactoryConfigurationError​(String msg, 异常 e)
      使用嵌套的内部异常和消息构造异常

    • Uses of 异常 in javax.xml.transform

      Subclasses of 异常 in javax.xml.transform
      Modifier and Type Class 描述
      class  TransformerConfigurationException
      表示严重的配置错误。
      class  TransformerException
      此类指定在转换过程中发生的异常情况。
      Methods in javax.xml.transform that return 异常
      Modifier and Type 方法 描述
      异常 TransformerFactoryConfigurationError.getException​()
      返回导致引发此异常的实际异常（如果有的话）。
      Constructors in javax.xml.transform with parameters of type 异常
      Constructor 描述
      TransformerFactoryConfigurationError​(异常 e)
      创建一个新的 TransformerFactoryConfigurationError与给定的 异常基本原因的错误。
      TransformerFactoryConfigurationError​(异常 e, String msg)
      创建一个新的 TransformerFactoryConfigurationError与给定的 异常基本原因和详细信息。

    • Uses of 异常 in javax.xml.ws

      Subclasses of 异常 in javax.xml.ws
      Modifier and Type Class 描述
      class  ProtocolException
      ProtocolException类是与特定协议绑定相关的异常的基类。
      class  WebServiceException
      WebServiceException类是所有JAX-WS API运行时异常的基本异常类。

    • Uses of 异常 in javax.xml.ws.http

      Subclasses of 异常 in javax.xml.ws.http
      Modifier and Type Class 描述
      class  HTTPException
      HTTPException异常表示XML / HTTP故障。

    • Uses of 异常 in javax.xml.ws.soap

      Subclasses of 异常 in javax.xml.ws.soap
      Modifier and Type Class 描述
      class  SOAPFaultException
      SOAPFaultException异常表示SOAP 1.1或1.2故障。

    • Uses of 异常 in javax.xml.xpath

      Subclasses of 异常 in javax.xml.xpath
      Modifier and Type Class 描述
      class  XPathException
      XPathException表示一个通用的XPath异常。
      class  XPathExpressionException
      XPathExpressionException表示XPath表达式中的错误。
      class  XPathFactoryConfigurationException
      XPathFactoryConfigurationException表示 XPathFactory环境中的配置错误。
      class  XPathFunctionException
      XPathFunctionException表示XPath函数的错误。

    • Uses of 异常 in jdk.dynalink

      Subclasses of 异常 in jdk.dynalink
      Modifier and Type Class 描述
      class  NoSuchDynamicMethodException
      如果呼叫站点无法通过任何可用的GuardingDynamicLinker链接，则在调用时抛出。

    • Uses of 异常 in jdk.dynalink.beans

      Methods in jdk.dynalink.beans that throw 异常
      Modifier and Type | 方法 | 描述
      MethodHandle MissingMemberHandlerFactory.createMissingMemberHandler​(LinkRequest linkRequest, LinkerServices linkerServices)
      返回适用于为特定链接请求实现丢失成员行为的方法句柄。
      GuardedInvocation | BeansLinker.getGuardedInvocation​(LinkRequest request, LinkerServices linkerServices)

    • Uses of 异常 in jdk.dynalink.linker

      Methods in jdk.dynalink.linker that throw 异常
      Modifier and Type 方法 描述
      GuardedInvocation GuardingTypeConverterFactory.convertToType​(Class<?> sourceType, Class<?> targetType, Supplier<MethodHandles.Lookup> lookupSupplier)
      返回受保护的类型转换，它接收指定的源类型的值，并返回转换为指定的目标类型的值。
      GuardedInvocation GuardingDynamicLinker.getGuardedInvocation​(LinkRequest linkRequest, LinkerServices linkerServices)
      在调用站点上创建一个适合于具有指定参数的特定调用的保护调用。
      GuardedInvocation LinkerServices.getGuardedInvocation​(LinkRequest linkRequest)
      创建一个守卫的调用委托回270602425753987公开这个链接器服务对象。

    • Uses of 异常 in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support that throw 异常
      Modifier and Type | 方法 | 描述
      GuardedInvocation CompositeGuardingDynamicLinker.getGuardedInvocation​(LinkRequest linkRequest, LinkerServices linkerServices)
      将呼叫委托给其组件链接器。
      GuardedInvocation | CompositeTypeBasedGuardingDynamicLinker.getGuardedInvocation​(LinkRequest linkRequest, LinkerServices linkerServices)

    • Uses of 异常 in jdk.incubator.http

      Subclasses of 异常 in jdk.incubator.http
      Modifier and Type Class 描述
      class  HttpTimeoutException
      在指定时间段内没有收到回应时抛出。
      class  WebSocketHandshakeException
      用于表示开启握手的异常失败。

    • Uses of 异常 in jdk.jshell

      Subclasses of 异常 in jdk.jshell
      Modifier and Type Class 描述
      class  EvalException
      封装在远程执行客户机中抛出的异常。
      class  JShellException
      JShell的超类生成异常
      class  UnresolvedReferenceException
      报告了尝试执行一个 RECOVERABLE_DEFINED片段的异常。

    • Uses of 异常 in jdk.jshell.execution

      Methods in jdk.jshell.execution that throw 异常
      Modifier and Type | 方法 | 描述
      protected String DirectExecutionControl.invoke​(方法 doitMethod)
      调用指定的“doit-method”，一个没有参数的静态方法。
      protected String | LocalExecutionControl.invoke​(方法 doitMethod)
      protected String | RemoteExecutionControl.invoke​(方法 doitMethod)
      static void RemoteExecutionControl.main​(String[] args)
      启动代理，通过命令行参数指定的套接字连接到JShell核心。

    • Uses of 异常 in jdk.jshell.spi

      Subclasses of 异常 in jdk.jshell.spi
      Modifier and Type Class 描述
      static class  ExecutionControl.ClassInstallException
      类安装（加载或重新定义）遇到问题。
      static class  ExecutionControl.EngineTerminationException
      未执行引擎终止已发生。
      static class  ExecutionControl.ExecutionControlException
      所有 ExecutionControl例外的抽象基础。
      static class  ExecutionControl.InternalException
      发生内部问题。
      static class  ExecutionControl.NotImplementedException
      该命令未实现。
      static class  ExecutionControl.ResolutionException
      一个异常，表示遇到了未解决的引用的一个 DeclarationSnippet 。
      static class  ExecutionControl.RunException
      特定于运行用户代码的异常的抽象基础。
      static class  ExecutionControl.StoppedException
       表示
ExecutionControl.invoke(java.lang.String, java.lang.String) （或理论上为
ExecutionControl.varValue(java.lang.String, java.lang.String) ）已被
ExecutionControl.stop()中断的
异常 。
      static class  ExecutionControl.UserException
      发生“正常”用户异常。
      class  SPIResolutionException
      此异常的构造和抛出嵌入在JShell核心实现中生成的代码中，以便在执行 RECOVERABLE_DEFINED用户方法时抛出此异常。

    • Uses of 异常 in jdk.jshell.tool

      Methods in jdk.jshell.tool that throw 异常
      Modifier and Type 方法 描述
      void JavaShellToolBuilder.run​(String... arguments)
      运行该接口中其他方法配置的Java Shell工具实例。

    • Uses of 异常 in jdk.nashorn.api.scripting

      Subclasses of 异常 in jdk.nashorn.api.scripting
      Modifier and Type Class 描述
      class  NashornException
      这是所有Nashorn异常的基础例外。

    • Uses of 异常 in jdk.nashorn.api.tree

      Subclasses of 异常 in jdk.nashorn.api.tree
      Modifier and Type Class 描述
      class  UnknownTreeException
      表示遇到了一种未知类型的树。

    • Uses of 异常 in jdk.security.jarsigner

      Subclasses of 异常 in jdk.security.jarsigner
      Modifier and Type Class 描述
      class  JarSignerException
      当 JarSigner.sign(java.util.zip.ZipFile, java.io.OutputStream)失败时抛出此异常。

    • Uses of 异常 in netscape.javascript

      Subclasses of 异常 in netscape.javascript
      Modifier and Type Class 描述
      class  JSException
      在JavaScript引擎中引发异常时抛出。

    • Uses of 异常 in org.ietf.jgss

      Subclasses of 异常 in org.ietf.jgss
      Modifier and Type Class 描述
      class  GSSException
      发生GSS-API错误时会抛出此异常，包括任何机制特定的错误。

    • Uses of 异常 in org.omg.CORBA

      Subclasses of 异常 in org.omg.CORBA
      Modifier and Type Class 描述
      class  ACTIVITY_COMPLETED
      可以在任何访问Activity上下文的方法上引发 ACTIVITY_COMPLETED系统异常。
      class  ACTIVITY_REQUIRED
      可能会对需要Activity上下文的任何方法引发 ACTIVITY_REQUIRED系统异常。
      class  BAD_CONTEXT
      当客户端调用操作时抛出异常，但传递的上下文不包含操作所需的上下文值。
      class  BAD_INV_ORDER
      这个异常表示调用者以错误的顺序调用了操作。
      class  BAD_OPERATION
      当对象引用表示现有对象但该对象不支持被调用的操作时抛出异常。
      class  BAD_PARAM
      传递给调用的参数超出范围或以其他方式被视为非法时引发的异常。
      class  BAD_QOS
      当对象不能支持具有与其关联的服务质量语义的调用参数所需的服务质量时，引发 BAD_QOS异常。
      class  BAD_TYPECODE
      当ORB遇到格式错误的代码（例如，具有无效 TCKind值的类型代码）时抛出异常。
      class  Bounds
      当参数不在方法尝试访问的对象的合法范围内时抛出用户异常。
      class  CODESET_INCOMPATIBLE
      无论客户端和服务器本机代码集之间无法进行有意义的通信，都会引发此异常。
      class  COMM_FAILURE
      在客户端发送请求后，服务器的回复已经返回到客户端之前，在进行中的通信丢失时发生异常。
      class  DATA_CONVERSION
      如果ORB无法将封送的数据的表示形式转换为其本机表示形式，反之亦然，则会引发此异常。
      class  FREE_MEM
      ORB在尝试释放动态内存时失败，例如由于堆损坏或内存段被锁定而导致异常。
      class  IMP_LIMIT
      此异常表示在ORB运行时间中超出了实施限制。
      class  INITIALIZE
      当ORB在其初始化期间遇到故障（例如无法获取网络资源或检测到配置错误）时抛出异常。
      class  INTERNAL
      此异常指示ORB中的内部故障，例如，如果ORB检测到其内部数据结构的损坏。
      class  INTF_REPOS
      当ORB无法到达接口存储库或检测到与接口存储库相关的某些其他故障时引发异常。
      class  INV_FLAG
      当一个无效标志传递给一个操作时（例如创建一个DII请求）时抛出异常。
      class  INV_IDENT
      此异常表示IDL标识符在语法上无效。
      class  INV_OBJREF
      此异常表示对象引用在内部格式错误。
      class  INV_POLICY
      由于 Policy覆盖适用于特定调用的不兼容性，因此无法进行调用时抛出标准异常。
      class  INVALID_ACTIVITY
      如果事务或活动在与其挂起的环境不同的上下文中恢复，则可能会在“活动”或“事务服务”恢复方法上引发 INVALID_ACTIVITY系统异常。
      class  INVALID_TRANSACTION
      当请求携带无效的事务上下文时抛出异常。
      class  MARSHAL
      来自网络的请求或回复在结构上是无效的。
      class  NO_IMPLEMENT
      此异常表示即使已调用的操作存在（它具有IDL定义），也不存在该操作的实现。
      class  NO_MEMORY
      ORB运行时内存不足时抛出异常。
      class  NO_PERMISSION
      调用失败时引发异常，因为调用者的权限不足。
      class  NO_RESOURCES
      当ORB遇到一些一般资源限制时抛出异常。
      class  NO_RESPONSE
      如果客户端尝试检索延迟同步调用的结果，但该请求的响应尚不可用，则会引发此异常。
      class  OBJ_ADAPTER
      此异常通常表示管理不匹配，例如，服务器可能尝试以已经在使用的名称或对存储库未知的实现存储库注册自身。
      class  OBJECT_NOT_EXIST
      每当执行对被删除对象的调用时，就会引发异常。
      class  PERSIST_STORE
      此异常表示持续存储故障，例如，无法建立数据库连接或数据库损坏。
      class  PolicyError
      发生策略错误时抛出的用户异常。
      class  REBIND
      REBIND上升时电流有效RebindPolicy，具有NO_REBIND或NO_RECONNECT的值和上一个绑定的对象引用在消息LocateReply具有状态OBJECT_FORWARD或状态为LOCATION_FORWARD一个应答消息的调用。
      class  SystemException
      所有CORBA标准异常的根类。
      class  TIMEOUT
      TIMEOUT在没有交付和已经超过指定的生存时间段时被提出。
      class  TRANSACTION_MODE
      如果检测到IOR中的InvocationPolicy与所选择的调用路径（即，直接或路由调用）之间的不匹配，则客户机ORB抛出CORBA TRANSACTION_MODE异常。
      class  TRANSACTION_REQUIRED
      异常表示请求携带一个空事务上下文，但需要一个活动事务。
      class  TRANSACTION_ROLLEDBACK
      与请求相关联的事务已经回滚或标记回滚时抛出异常。
      class  TRANSACTION_UNAVAILABLE
      由于ORB与事务服务的连接已异常终止，所以ORB无法处理事务服务上下文时抛出CORBA TRANSACTION_UNAVAILABLE异常。
      class  TRANSIENT
      当ORB尝试到达对象并失败时抛出异常。
      class  UNKNOWN
      如果操作实现抛出非CORBA异常（例如特定于实现的编程语言的异常），或者操作引发不在操作的引用表达式中出现的用户异常，则会引发此异常。
      class  UnknownUserException
      包含服务器返回的用户异常的类。
      class  UserException
      CORBA IDL定义用户异常的根类。
      class  WrongTransaction
      CORBA WrongTransaction用户定义的异常。
      Methods in org.omg.CORBA that return 异常
      Modifier and Type 方法 描述
      abstract 异常 Environment.exception​()
      检索此 Environment对象中的异常。
      Methods in org.omg.CORBA with parameters of type 异常
      Modifier and Type 方法 描述
      abstract void Environment.exception​(异常 except)
      将给定的异常插入到这个 Environment对象中。

    • Uses of 异常 in org.omg.CORBA.DynAnyPackage

      Subclasses of 异常 in org.omg.CORBA.DynAnyPackage
      Modifier and Type | Class | 描述
      class  Invalid
      当传递错误的 DynAny或 Any作为参数时，动态的任何操作都会抛出无效。
      class  InvalidSeq
      InvalidSeq异常被所有操作抛出，在动态任务中，当序列无效时，它将一个序列（Java数组）作为参数。
      class  | InvalidValue
      class  TypeMismatch
      当实际内容的类型与尝试访问的内容不匹配时，TypeMismatch将被动态的任何访问器方法抛出。

    • Uses of 异常 in org.omg.CORBA.ORBPackage

      Subclasses of 异常 in org.omg.CORBA.ORBPackage
      Modifier and Type Class 描述
      class  InconsistentTypeCode
      尝试创建一个类型代码与 DynAny的特定子类不匹配的动态任务时，会抛出 DynAny 。
      class  InvalidName
      InvalidName异常在 ORB.resolve_initial_references传递一个没有初始引用的名称时被提出。

    • Uses of 异常 in org.omg.CORBA.portable

      Subclasses of 异常 in org.omg.CORBA.portable
      Modifier and Type Class 描述
      class  ApplicationException
      此类用于报告ORB和存根之间的应用程序级异常。
      class  IndirectionException
      间接异常是一个Java特定的系统异常。
      class  RemarshalException
      该类用于将向前的异常和对象前向GIOP消息定位回ORB。
      class  UnknownException
      org.omg.CORBA.portable.UnknownException用于报告关系和ORB之间以及ORB和存根之间的未知异常。

    • Uses of 异常 in org.omg.CORBA.TypeCodePackage

      Subclasses of 异常 in org.omg.CORBA.TypeCodePackage
      Modifier and Type Class 描述
      class  BadKind
      当对 TypeCode对象调用不正确的操作时，抛出 BadKind异常。
      class  Bounds
      提供 TypeCode操作 member_name() ， member_type() ，并 member_label 。

    • Uses of 异常 in org.omg.CosNaming.NamingContextExtPackage

      Subclasses of 异常 in org.omg.CosNaming.NamingContextExtPackage
      Modifier and Type Class 描述
      class  InvalidAddress
      org / omg / CosNaming / NamingContextExtPackage / InvalidAddress.java。

    • Uses of 异常 in org.omg.CosNaming.NamingContextPackage

      Subclasses of 异常 in org.omg.CosNaming.NamingContextPackage
      Modifier and Type Class 描述
      class  AlreadyBound
      org / omg / CosNaming / NamingContextPackage / AlreadyBound.java。
      class  CannotProceed
      org / omg / CosNaming / NamingContextPackage / CannotProceed.java。
      class  InvalidName
      org / omg / CosNaming / NamingContextPackage / InvalidName.java。
      class  NotEmpty
      org / omg / CosNaming / NamingContextPackage / NotEmpty.java。
      class  NotFound
      org / omg / CosNaming / NamingContextPackage / NotFound.java。

    • Uses of 异常 in org.omg.DynamicAny.DynAnyFactoryPackage

      Subclasses of 异常 in org.omg.DynamicAny.DynAnyFactoryPackage
      Modifier and Type Class 描述
      class  InconsistentTypeCode
      org / omg / DynamicAny / DynAnyFactoryPackage / InconsistentTypeCode.java。

    • Uses of 异常 in org.omg.DynamicAny.DynAnyPackage

      Subclasses of 异常 in org.omg.DynamicAny.DynAnyPackage
      Modifier and Type Class 描述
      class  InvalidValue
      org / omg / DynamicAny / DynAnyPackage / InvalidValue.java。
      class  TypeMismatch
      org / omg / DynamicAny / DynAnyPackage / TypeMismatch.java。

    • Uses of 异常 in org.omg.IOP.CodecFactoryPackage

      Subclasses of 异常 in org.omg.IOP.CodecFactoryPackage
      Modifier and Type Class 描述
      class  UnknownEncoding
      org / omg / IOP / CodecFactoryPackage / UnknownEncoding.java。

    • Uses of 异常 in org.omg.IOP.CodecPackage

      Subclasses of 异常 in org.omg.IOP.CodecPackage
      Modifier and Type Class 描述
      class  FormatMismatch
      org / omg / IOP / CodecPackage / FormatMismatch.java。
      class  InvalidTypeForEncoding
      org / omg / IOP / CodecPackage / InvalidTypeForEncoding.java。
      class  TypeMismatch
      org / omg / IOP / CodecPackage / TypeMismatch.java。

    • Uses of 异常 in org.omg.PortableInterceptor

      Subclasses of 异常 in org.omg.PortableInterceptor
      Modifier and Type Class 描述
      class  ForwardRequest
      org / omg / PortableInterceptor / ForwardRequest.java。
      class  InvalidSlot
      org / omg / PortableInterceptor / InvalidSlot.java。

    • Uses of 异常 in org.omg.PortableInterceptor.ORBInitInfoPackage

      Subclasses of 异常 in org.omg.PortableInterceptor.ORBInitInfoPackage
      Modifier and Type Class 描述
      class  DuplicateName
      org / omg / PortableInterceptor / ORBInitInfoPackage / DuplicateName.java。
      class  InvalidName
      org / omg / PortableInterceptor / ORBInitInfoPackage / InvalidName.java。

    • Uses of 异常 in org.omg.PortableServer

      Subclasses of 异常 in org.omg.PortableServer
      Modifier and Type Class 描述
      class  ForwardRequest
      org / omg / PortableServer / ForwardRequest.java。

    • Uses of 异常 in org.omg.PortableServer.CurrentPackage

      Subclasses of 异常 in org.omg.PortableServer.CurrentPackage
      Modifier and Type Class 描述
      class  NoContext
      org / omg / PortableServer / CurrentPackage / NoContext.java。

    • Uses of 异常 in org.omg.PortableServer.POAManagerPackage

      Subclasses of 异常 in org.omg.PortableServer.POAManagerPackage
      Modifier and Type Class 描述
      class  AdapterInactive
      org / omg / PortableServer / POAManagerPackage / AdapterInactive.java。

    • Uses of 异常 in org.omg.PortableServer.POAPackage

      Subclasses of 异常 in org.omg.PortableServer.POAPackage
      Modifier and Type Class 描述
      class  AdapterAlreadyExists
      org / omg / PortableServer / POAPackage / AdapterAlreadyExists.java。
      class  AdapterNonExistent
      org / omg / PortableServer / POAPackage / AdapterNonExistent.java。
      class  InvalidPolicy
      org / omg / PortableServer / POAPackage / InvalidPolicy.java。
      class  NoServant
      org / omg / PortableServer / POAPackage / NoServant.java。
      class  ObjectAlreadyActive
      org / omg / PortableServer / POAPackage / ObjectAlreadyActive.java。
      class  ObjectNotActive
      org / omg / PortableServer / POAPackage / ObjectNotActive.java。
      class  ServantAlreadyActive
      org / omg / PortableServer / POAPackage / ServantAlreadyActive.java。
      class  ServantNotActive
      org / omg / PortableServer / POAPackage / ServantNotActive.java。
      class  WrongAdapter
      org / omg / PortableServer / POAPackage / WrongAdapter.java。
      class  WrongPolicy
      org / omg / PortableServer / POAPackage / WrongPolicy.java。

    • Uses of 异常 in org.w3c.dom

      Subclasses of 异常 in org.w3c.dom
      Modifier and Type Class 描述
      class  DOMException
      DOM操作只会在“异常”情况下引发异常，即当操作无法执行时（出于逻辑原因，因为数据丢失，或者由于实现变得不稳定））。

    • Uses of 异常 in org.w3c.dom.events

      Subclasses of 异常 in org.w3c.dom.events
      Modifier and Type Class 描述
      class  EventException
      事件操作可能会 EventException其方法描述中指定的 EventException 。

    • Uses of 异常 in org.w3c.dom.ls

      Subclasses of 异常 in org.w3c.dom.ls
      Modifier and Type Class 描述
      class  LSException
      如果处理停止，解析器或写入操作可能会抛出 LSException 。

    • Uses of 异常 in org.w3c.dom.ranges

      Subclasses of 异常 in org.w3c.dom.ranges
      Modifier and Type Class 描述
      class  RangeException
      范围操作可能会 RangeException其方法描述中指定的 RangeException 。

    • Uses of 异常 in org.w3c.dom.xpath

      Subclasses of 异常 in org.w3c.dom.xpath
      Modifier and Type Class 描述
      class  XPathException
      为这些XPath接口特定的异常创建了一个新的异常。

    • Uses of 异常 in org.xml.sax

      Subclasses of 异常 in org.xml.sax
      Modifier and Type Class 描述
      class  SAXException
      封装一般的SAX错误或警告。
      class  SAXNotRecognizedException
      无法识别的标识符的异常类。
      class  SAXNotSupportedException
      不受支持的操作的异常类。
      class  SAXParseException
      封装XML解析错误或警告。
      Methods in org.xml.sax that return 异常
      Modifier and Type 方法 描述
      异常 SAXException.getException​()
      返回嵌入式异常（如果有）。
      Constructors in org.xml.sax with parameters of type 异常
      Constructor 描述
      SAXException​(异常 e)
      创建一个包含现有异常的新SAXException。
      SAXException​(String message, 异常 e)
      从现有异常创建新的SAXException。
      SAXParseException​(String message, String publicId, String systemId, int lineNumber, int columnNumber, 异常 e)
      创建一个新的SAXParseException与嵌入式异常。
      SAXParseException​(String message, Locator locator, 异常 e)
      在SAXParseException中包装一个现有的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ExceptionInInitializerError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ExceptionInInitializerError

No usage of java.lang.ExceptionInInitializerError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Float (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Float

  • Packages that use Float
    软件包 描述
    java.awt.font
    提供与字体相关的类和界面。
    java.lang
    提供对Java编程语言设计至关重要的类。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。

    • Uses of Float in java.awt.font

      Fields in java.awt.font declared as Float
      Modifier and Type Field 描述
      static Float TextAttribute.JUSTIFICATION_FULL
      将线对齐为满请求宽度。
      static Float TextAttribute.JUSTIFICATION_NONE
      不要让线路有道理。
      static Float TextAttribute.POSTURE_OBLIQUE
      标准斜体姿势。
      static Float TextAttribute.POSTURE_REGULAR
      标准姿势，直立。
      static Float TextAttribute.TRACKING_LOOSE
      执行松动跟踪。
      static Float TextAttribute.TRACKING_TIGHT
      执行紧跟踪。
      static Float TextAttribute.WEIGHT_BOLD
      标准大胆的体重。
      static Float TextAttribute.WEIGHT_DEMIBOLD
      重量比中等重量比 WEIGHT_BOLD 。
      static Float TextAttribute.WEIGHT_DEMILIGHT
      中间重量在 WEIGHT_LIGHT和 WEIGHT_STANDARD之间。
      static Float TextAttribute.WEIGHT_EXTRA_LIGHT
      最轻的预定义重量。
      static Float TextAttribute.WEIGHT_EXTRABOLD
      重量过重
      static Float TextAttribute.WEIGHT_HEAVY
      比 WEIGHT_BOLD中等重。
      static Float TextAttribute.WEIGHT_LIGHT
      标准重量轻。
      static Float TextAttribute.WEIGHT_MEDIUM
      中间重量在 WEIGHT_REGULAR和 WEIGHT_BOLD之间。
      static Float TextAttribute.WEIGHT_REGULAR
      标准重量。
      static Float TextAttribute.WEIGHT_SEMIBOLD
      中等重量比 WEIGHT_REGULAR 。
      static Float TextAttribute.WEIGHT_ULTRABOLD
      最重的预定义重量。
      static Float TextAttribute.WIDTH_CONDENSED
      最浓缩的预定宽度。
      static Float TextAttribute.WIDTH_EXTENDED
      最大的预定宽度。
      static Float TextAttribute.WIDTH_REGULAR
      标准宽度。
      static Float TextAttribute.WIDTH_SEMI_CONDENSED
      中等浓度的宽度。
      static Float TextAttribute.WIDTH_SEMI_EXTENDED
      中等宽度的宽度。

    • Uses of Float in java.lang

      Fields in java.lang with type parameters of type Float
      Modifier and Type Field 描述
      static Class<Float> Float.TYPE
      Class实例代表原始类型 float 。
      Methods in java.lang that return Float
      Modifier and Type 方法 描述
      static Float Float.valueOf​(float f)
      返回一个表示 float值的 Float实例。
      static Float Float.valueOf​(String s)
      返回一个 Float对象，该对象保存由参数字符串 s表示的 float值。
      Methods in java.lang with parameters of type Float
      Modifier and Type 方法 描述
      int Float.compareTo​(Float anotherFloat)
      数值比较两个 Float对象。

    • Uses of Float in javafx.beans.binding

      Methods in javafx.beans.binding that return Float
      Modifier and Type | 方法 | 描述
      Float | FloatExpression.getValue​()
      Methods in javafx.beans.binding that return types with arguments of type Float
      Modifier and Type 方法 描述
      ObjectExpression<Float> FloatExpression.asObject​()
      创建一个ObjectExpression ，其值为FloatExpression 。
      Method parameters in javafx.beans.binding with type arguments of type Float
      Modifier and Type 方法 描述
      static FloatBinding Bindings.createFloatBinding​(Callable<Float> func, Observable... dependencies)
      助手功能创建自定义FloatBinding 。

    • Uses of Float in javafx.beans.property

      Methods in javafx.beans.property that return types with arguments of type Float
      Modifier and Type 方法 描述
      ObjectProperty<Float> FloatProperty.asObject​()
      创建一个ObjectProperty双向绑定到这个FloatProperty 。
      ReadOnlyObjectProperty<Float> ReadOnlyFloatProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyFloatProperty 。
      Method parameters in javafx.beans.property with type arguments of type Float
      Modifier and Type 方法 描述
      static FloatProperty FloatProperty.floatProperty​(Property<Float> property)
      返回一个FloatProperty ，它包装一个Property ，并双向绑定到它。

    • Uses of Float in javafx.css

      Constructors in javafx.css with parameters of type Float
      Constructor 描述
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。

    • Uses of Float in javafx.util.converter

      Methods in javafx.util.converter that return Float
      Modifier and Type 方法 描述
      Float FloatStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Float
      Modifier and Type 方法 描述
      String FloatStringConverter.toString​(Float value)
      将提供的对象转换为其字符串形式。

    • Uses of Float in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Float
      Modifier and Type Field 描述
      static SimpleType<Float> SimpleType.FLOAT
      The SimpleType instance describing values whose Java class name is java.lang.Float.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.FunctionalInterface (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.FunctionalInterface

  • Packages that use FunctionalInterface
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.function
    功能界面提供了lambda表达式和方法引用的目标类型。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans
    包 javafx.beans包含定义最通用形式的可观察性的接口。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.util
    包含各种实用程序和助手类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

    • Uses of FunctionalInterface in java.awt

      Classes in java.awt with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  KeyEventDispatcher
      KeyEventDispatcher与所有KeyEvents的目标和调度中的当前KeyboardFocusManager配合使用。
      interface  KeyEventPostProcessor
      KeyEventPostProcessor与所有未消耗的KeyEvents的最终分辨率中的当前KeyboardFocusManager配合使用。

    • Uses of FunctionalInterface in java.io

      Classes in java.io with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  FileFilter
      抽象路径名的过滤器。
      interface  FilenameFilter
      用于实现此接口的类的实例用于过滤文件名。
      interface  ObjectInputFilter
      反序列化过程中过滤类，数组长度和图形指标。

    • Uses of FunctionalInterface in java.lang

      Classes in java.lang with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  Runnable
      Runnable接口应由实例由线程执行的任何类实现。
      static interface  Thread.UncaughtExceptionHandler
      当 Thread由于未捕获的异常而突然终止时，处理程序的接口被调用。

    • Uses of FunctionalInterface in java.nio.file

      Classes in java.nio.file with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      static interface  DirectoryStream.Filter<T>
      由对象执行的接口，用于确定是否应接受或过滤目录条目。
      interface  PathMatcher
      由对路径执行匹配操作的对象实现的接口。

    • Uses of FunctionalInterface in java.time.temporal

      Classes in java.time.temporal with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  TemporalAdjuster
      调整时间对象的策略。
      interface  TemporalQuery<R>
      查询时间对象的策略。

    • Uses of FunctionalInterface in java.util

      Classes in java.util with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  Comparator<T>
      比较功能，对一些对象的集合施加了一个 整体排序 。

    • Uses of FunctionalInterface in java.util.concurrent

      Classes in java.util.concurrent with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  Callable<V>
      返回结果并可能引发异常的任务。
      static interface  Flow.Publisher<T>
      订阅者接收的项目（和相关控制消息）的生产者。

    • Uses of FunctionalInterface in java.util.function

      Classes in java.util.function with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  BiConsumer<T,U>
      表示接受两个输入参数并且不返回结果的操作。
      interface  BiFunction<T,U,R>
      表示接受两个参数并产生结果的函数。
      interface  BinaryOperator<T>
      表示对同一类型的两个操作数的操作，产生与操作数相同类型的结果。
      interface  BiPredicate<T,U>
      表示两个参数的谓词（布尔值函数）。
      interface  BooleanSupplier
      代表 boolean结果。
      interface  Consumer<T>
      表示接受单个输入参数并且不返回结果的操作。
      interface  DoubleBinaryOperator
      表示对两个 double操作数的操作，并产生一个 double结果。
      interface  DoubleConsumer
      表示接受单个 double参数的操作，不返回任何结果。
      interface  DoubleFunction<R>
      表示接受双值参数并产生结果的函数。
      interface  DoublePredicate
      表示一个 double值参数的谓词（布尔值函数）。
      interface  DoubleSupplier
      代表 double结果。
      interface  DoubleToIntFunction
      表示接受双值参数并产生int值结果的函数。
      interface  DoubleToLongFunction
      表示接受双值参数并产生长期值结果的函数。
      interface  DoubleUnaryOperator
      表示对单个 double值的操作数的操作，产生一个 double结果。
      interface  Function<T,R>
      表示接受一个参数并产生结果的函数。
      interface  IntBinaryOperator
      表示对两个 int值操作数的操作，并产生一个 int结果。
      interface  IntConsumer
      表示接受单个 int参数的操作，并且不返回任何结果。
      interface  IntFunction<R>
      表示一个接受int值参数并产生结果的函数。
      interface  IntPredicate
      表示一个 int值参数的谓词（布尔值函数）。
      interface  IntSupplier
      代表 int结果。
      interface  IntToDoubleFunction
      表示接受一个int值参数并产生一个双值结果的函数。
      interface  IntToLongFunction
      表示接受一个int值参数并产生一个长效结果的函数。
      interface  IntUnaryOperator
      表示对单个 int值操作数的操作，产生一个 int结果。
      interface  LongBinaryOperator
      表示对两个 long操作数的操作，并产生一个 long结果。
      interface  LongConsumer
      表示接受一个 long参数并且不返回任何结果的操作。
      interface  LongFunction<R>
      表示接受长期参数并产生结果的函数。
      interface  LongPredicate
      表示一个 long值参数的谓词（布尔值函数）。
      interface  LongSupplier
      代表 long结果的供应商。
      interface  LongToDoubleFunction
      表示接受长期参数并产生双值结果的函数。
      interface  LongToIntFunction
      表示接受长值参数并产生int值结果的函数。
      interface  LongUnaryOperator
      表示对单个 long值操作数的操作，产生一个 long结果。
      interface  ObjDoubleConsumer<T>
      表示接受对象值和 double值参数的操作，不返回任何结果。
      interface  ObjIntConsumer<T>
      表示接受对象值和 int值参数的操作，不返回任何结果。
      interface  ObjLongConsumer<T>
      表示接受对象值和 long值参数的操作，不返回任何结果。
      interface  Predicate<T>
      表示一个参数的谓词（布尔值函数）。
      interface  Supplier<T>
      代表结果供应商。
      interface  ToDoubleBiFunction<T,U>
      表示接受两个参数并产生双值结果的函数。
      interface  ToDoubleFunction<T>
      表示产生双值结果的函数。
      interface  ToIntBiFunction<T,U>
      表示一个接受两个参数并产生一个int值结果的函数。
      interface  ToIntFunction<T>
      表示产生一个int值结果的函数。
      interface  ToLongBiFunction<T,U>
      表示接受两个参数并产生长效结果的函数。
      interface  ToLongFunction<T>
      表示产生长期效果的函数。
      interface  UnaryOperator<T>
      表示对单个操作数产生与其操作数相同类型的结果的操作。

    • Uses of FunctionalInterface in java.util.logging

      Classes in java.util.logging with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  Filter
      可以使用过滤器对超出记录级别提供的控制范围内的记录进行细粒度控制。

    • Uses of FunctionalInterface in java.util.prefs

      Classes in java.util.prefs with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  PreferenceChangeListener
      用于接收偏好更改事件的侦听器。

    • Uses of FunctionalInterface in javafx.animation

      Classes in javafx.animation with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  Interpolatable<T>
      可以插值的值。

    • Uses of FunctionalInterface in javafx.beans

      Classes in javafx.beans with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  InvalidationListener
      一个InvalidationListener每当被通知Observable变为无效。

    • Uses of FunctionalInterface in javafx.beans.value

      Classes in javafx.beans.value with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  ChangeListener<T>
      甲ChangeListener通知每当的值ObservableValue种变化。

    • Uses of FunctionalInterface in javafx.collections

      Classes in javafx.collections with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  ListChangeListener<E>
      接收ObservableList更改通知的接口。
      interface  MapChangeListener<K,V>
      接收到ObservableMap更改通知的接口。
      interface  SetChangeListener<E>
      接收ObservableSet更改通知的接口。

    • Uses of FunctionalInterface in javafx.event

      Classes in javafx.event with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  EventHandler<T extends Event>
      处理程序用于特定类/类型的事件。

    • Uses of FunctionalInterface in javafx.util

      Classes in javafx.util with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  Builder<T>
      代表构建器的界面。
      interface  BuilderFactory
      界面代表建筑工厂。
      interface  Callback<P,R>
      回调接口旨在允许一个常见的，可重用的接口，用于定义需要在某些情况下回调的API。

    • Uses of FunctionalInterface in jdk.dynalink.beans

      Classes in jdk.dynalink.beans with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  MissingMemberHandlerFactory
      创建方法句柄的工厂，用于链接缺少的成员行为BeansLinker 。

    • Uses of FunctionalInterface in jdk.dynalink.linker

      Classes in jdk.dynalink.linker with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  GuardedInvocationTransformer
      用于将一个受保护的调用转换为另一个的对象的接口。
      interface  MethodHandleTransformer
      描述变换方法句柄的操作的通用界面。
      interface  MethodTypeConversionStrategy
      表示用于将方法句柄转换为新类型的策略的对象的接口。

    • Uses of FunctionalInterface in jdk.incubator.http

      Classes in jdk.incubator.http with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      static interface  HttpResponse.BodyHandler<T>
      响应机构的处理程序。

    • Uses of FunctionalInterface in jdk.nashorn.api.tree

      Classes in jdk.nashorn.api.tree with annotations of type FunctionalInterface
      Modifier and Type 接口 描述
      interface  DiagnosticListener
      用于从Nashorn解析器接收诊断的接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IllegalAccessError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IllegalAccessError

No usage of java.lang.IllegalAccessError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IllegalAccessException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IllegalAccessException

  • Packages that use IllegalAccessException
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    org.w3c.dom.bootstrap
    提供一个工厂来获取 DOMImplementation实例。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of IllegalAccessException in java.lang

      Methods in java.lang that throw IllegalAccessException
      Modifier and Type 方法 描述
      T Class.newInstance​()
      已过时。
      此方法传播由nullary构造函数抛出的任何异常，包括已检查的异常。 使用此方法有效地绕过编译器异常检查，否则将由编译器执行。 Constructor.newInstance方法通过在（检查）的InvocationTargetException中包装构造函数抛出的任何异常来避免此问题。

      电话

         clazz.newInstance()
      可以替换
         clazz.getDeclaredConstructor().newInstance()
      后一个调用序列被推断为能够抛出额外的异常类型InvocationTargetException和NoSuchMethodException 。 这两个异常类型都是ReflectiveOperationException的子类。

    • Uses of IllegalAccessException in java.lang.invoke

      Methods in java.lang.invoke that throw IllegalAccessException
      Modifier and Type 方法 描述
      Class<?> MethodHandles.Lookup.accessClass​(Class<?> targetClass)
      确定是否可以从此 Lookup对象定义的查找上下文中访问类。
      MethodHandle MethodHandles.Lookup.bind​(Object receiver, String name, MethodType type)
      为非静态方法生成早期绑定的方法句柄。
      Class<?> MethodHandles.Lookup.defineClass​(byte[] bytes)
      将类定义到相同的类加载器，并在同一个运行时包中，以及protection domain作为此查找的lookup class 。
      Class<?> MethodHandles.Lookup.findClass​(String targetName)
      从这个 Lookup对象定义的查找上下文中按名称查找类。
      MethodHandle MethodHandles.Lookup.findConstructor​(Class<?> refc, MethodType type)
      使用指定类型的构造函数生成创建对象并初始化它的方法句柄。
      MethodHandle MethodHandles.Lookup.findGetter​(Class<?> refc, String name, Class<?> type)
      产生方法句柄，给非静态字段的读访问权限。
      MethodHandle MethodHandles.Lookup.findSetter​(Class<?> refc, String name, Class<?> type)
      产生一个给非静态字段写入访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findSpecial​(Class<?> refc, String name, MethodType type, Class<?> specialCaller)
      为虚拟方法生成早期绑定的方法句柄。
      MethodHandle MethodHandles.Lookup.findStatic​(Class<?> refc, String name, MethodType type)
      为静态方法生成方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticGetter​(Class<?> refc, String name, Class<?> type)
      产生一个给静态字段读取访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticSetter​(Class<?> refc, String name, Class<?> type)
      生成方法句柄，给静态字段写权限。
      VarHandle MethodHandles.Lookup.findStaticVarHandle​(Class<?> decl, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的静态字段 decl 。
      VarHandle MethodHandles.Lookup.findVarHandle​(Class<?> recv, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的非静态字段 recv 。
      MethodHandle MethodHandles.Lookup.findVirtual​(Class<?> refc, String name, MethodType type)
      为虚拟方法生成方法句柄。
      static MethodHandles.Lookup MethodHandles.privateLookupIn​(Class<?> targetClass, MethodHandles.Lookup lookup)
      返回一个lookup object，具有完整功能，可以在目标类上模拟所有支持的字节码行为，包括private access 。
      MethodHandle MethodHandles.Lookup.unreflect​(方法 m)
      做一个 direct method handle到 m ，如果查找类有权限。
      MethodHandle MethodHandles.Lookup.unreflectConstructor​(Constructor<?> c)
      为反射的构造函数生成方法句柄。
      MethodHandle MethodHandles.Lookup.unreflectGetter​(Field f)
      产生方法句柄，给予反映字段的读访问权限。
      MethodHandle MethodHandles.Lookup.unreflectSetter​(Field f)
      产生一个方法句柄，给一个反射的字段写权限。
      MethodHandle MethodHandles.Lookup.unreflectSpecial​(方法 m, Class<?> specialCaller)
      为反映的方法生成方法句柄。
      VarHandle MethodHandles.Lookup.unreflectVarHandle​(Field f)
      产生一个VarHandle，可访问 f类中声明的类型为 T的反射字段 R 。

    • Uses of IllegalAccessException in java.lang.reflect

      Methods in java.lang.reflect that throw IllegalAccessException
      Modifier and Type 方法 描述
      Object Field.get​(Object obj)
      返回指定对象上由此 Field表示的字段的值。
      boolean Field.getBoolean​(Object obj)
      获取静态或实例的值 boolean字段。
      byte Field.getByte​(Object obj)
      获取静态或实例的值 byte字段。
      char Field.getChar​(Object obj)
      获取类型为 char的静态或实例字段的值，或通过扩展转换获得可转换为类型 char的另一个原始类型的值。
      double Field.getDouble​(Object obj)
      获取类型为 double的静态或实例字段的值，或通过扩大转换获得可转换为类型 double的另一个原始类型的值。
      float Field.getFloat​(Object obj)
      获取类型为 float的静态或实例字段的值，或通过扩大转换获得可转换为类型 float的另一个原始类型的值。
      int Field.getInt​(Object obj)
      获取类型为 int的静态或实例字段的值，或通过扩展转换获得可转换为类型 int的另一个基本类型的值。
      long Field.getLong​(Object obj)
      获取类型为 long的静态或实例字段的值，或通过扩展转换获得可转换为类型 long的另一个原始类型的值。
      short Field.getShort​(Object obj)
      获取类型为 short的静态或实例字段的 short或通过加宽转换可转换为类型 short的另一个基本类型的值。
      Object Method.invoke​(Object obj, Object... args)
      使用指定的参数调用此 方法对象所代表的基础方法。
      T Constructor.newInstance​(Object... initargs)
      使用此 Constructor对象表示的构造函数，使用指定的初始化参数创建和初始化构造函数声明类的新实例。
      void Field.set​(Object obj, Object value)
      将指定对象参数上的此 Field对象表示的字段设置为指定的新值。
      void Field.setBoolean​(Object obj, boolean z)
      将字段的值设置为指定对象上的 boolean 。
      void Field.setByte​(Object obj, byte b)
      将字段的值设置为指定对象上的 byte 。
      void Field.setChar​(Object obj, char c)
      将字段的值设置为指定对象上的 char 。
      void Field.setDouble​(Object obj, double d)
      将字段的值设置为指定对象上的 double 。
      void Field.setFloat​(Object obj, float f)
      将字段的值设置为指定对象上的 float 。
      void Field.setInt​(Object obj, int i)
      将字段的值设置为指定对象上的 int 。
      void Field.setLong​(Object obj, long l)
      将字段的值设置为指定对象上的 long 。
      void Field.setShort​(Object obj, short s)
      将字段的值设置为指定对象上的 short 。

    • Uses of IllegalAccessException in java.util

      Methods in java.util that throw IllegalAccessException
      Modifier and Type 方法 描述
      ResourceBundle ResourceBundle.Control.newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
      为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。

    • Uses of IllegalAccessException in javax.swing

      Methods in javax.swing that throw IllegalAccessException
      Modifier and Type 方法 描述
      static void UIManager.setLookAndFeel​(String className)
      使用当前线程的上下文类加载器加载由给定类名指定的 LookAndFeel ，并将其传递给 setLookAndFeel(LookAndFeel) 。

    • Uses of IllegalAccessException in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that throw IllegalAccessException
      Modifier and Type 方法 描述
      abstract void Invoker.inject​(WebServiceContext webServiceContext)
      JAX-WS运行时调用此方法来请求容器在端点实例上注入WebServiceContext。
      abstract Object Invoker.invoke​(方法 m, Object... args)
      JAX-WS运行时调用此方法来对端点实例执行实际的Web服务调用。

    • Uses of IllegalAccessException in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that throw IllegalAccessException
      Modifier and Type 方法 描述
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance​()
      获取 DOMImplementationRegistry的新实例。

    • Uses of IllegalAccessException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw IllegalAccessException
      Modifier and Type 方法 描述
      static Parser ParserFactory.makeParser​()
      已过时。
      使用`org.xml.sax.parser'系统属性创建一个新的SAX解析器。
      static Parser ParserFactory.makeParser​(String className)
      已过时。
      使用提供的类名创建一个新的SAX解析器对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IllegalArgumentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IllegalArgumentException

  • Packages that use IllegalArgumentException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.net.httpserver
    提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.security
    提供安全框架的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.timer
    提供定时器MBean的定义。
    javax.net.ssl
    为安全套接字包提供类。
    javax.rmi.ssl
    通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.stream.util
    为Streaming API for XML（StAX）提供实用程序类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.transform.sax
    提供SAX特定的转换类。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

    • Uses of IllegalArgumentException in com.sun.jdi

      Constructors in com.sun.jdi that throw IllegalArgumentException
      Constructor 描述
      JDIPermission​(String name, String actions)
      构造一个新的JDIPermission对象。

    • Uses of IllegalArgumentException in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that throw IllegalArgumentException
      Modifier and Type 方法 描述
      abstract void HttpServer.removeContext​(String path)
      从服务器中删除由给定路径标识的上下文。

    • Uses of IllegalArgumentException in com.sun.nio.sctp

      Subclasses of IllegalArgumentException in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  InvalidStreamException
      尝试将消息发送到无效流时抛出未检查的异常。

    • Uses of IllegalArgumentException in java.awt.print

      Methods in java.awt.print that throw IllegalArgumentException
      Modifier and Type 方法 描述
      void PageFormat.setOrientation​(int orientation)
      设置页面方向。

    • Uses of IllegalArgumentException in java.beans

      Methods in java.beans that throw IllegalArgumentException
      Modifier and Type 方法 描述
      void PropertyEditor.setAsText​(String text)
      通过解析给定的字符串来设置属性值。
      void PropertyEditorSupport.setAsText​(String text)
      通过解析给定的字符串来设置属性值。

    • Uses of IllegalArgumentException in java.beans.beancontext

      Methods in java.beans.beancontext that throw IllegalArgumentException
      Modifier and Type 方法 描述
      URL BeanContext.getResource​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResource() ，这种方法允许一个 BeanContext实现介入孩子 Component和底层的 ClassLoader之间的行为。
      InputStream BeanContext.getResourceAsStream​(String name, BeanContextChild bcc)
      对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。

    • Uses of IllegalArgumentException in java.lang

      Subclasses of IllegalArgumentException in java.lang
      Modifier and Type Class 描述
      class  IllegalThreadStateException
      抛出以指示线程不处于所请求操作的适当状态。
      class  NumberFormatException
      抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。

    • Uses of IllegalArgumentException in java.lang.invoke

      Methods in java.lang.invoke that throw IllegalArgumentException
      Modifier and Type 方法 描述
      static MethodHandle MethodHandles.arrayConstructor​(Class<?> arrayClass)
      生成构造所需类型的数组的方法句柄。
      static MethodHandle MethodHandles.arrayElementGetter​(Class<?> arrayClass)
      产生方法句柄，提供对数组元素的读取访问。
      static MethodHandle MethodHandles.arrayElementSetter​(Class<?> arrayClass)
      生成方法句柄，为数组的元素提供写访问权限。
      static VarHandle MethodHandles.arrayElementVarHandle​(Class<?> arrayClass)
      产生一个VarHandle，可以访问arrayClass类型的数组的 arrayClass 。
      static MethodHandle MethodHandles.arrayLength​(Class<?> arrayClass)
      产生返回数组长度的方法句柄。
      static VarHandle MethodHandles.byteArrayViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生一个VarHandle，可以访问 byte[]数组的元素，就像它是不同的基元数组类型一样，如 int[]或 long[] 。
      static VarHandle MethodHandles.byteBufferViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生VarHandle给予访问的元素 ByteBuffer视为好像它是一个不同的基本组件类型到的元件的阵列 byte ，如 int[]或 long[] 。
      static MethodType MethodType.fromMethodDescriptorString​(String descriptor, ClassLoader loader)
      查找或创建方法类型的实例，给定其字节码描述符的拼写。

    • Uses of IllegalArgumentException in java.lang.management

      Constructors in java.lang.management that throw IllegalArgumentException
      Constructor 描述
      ManagementPermission​(String name, String actions)
      构造一个新的ManagementPermission对象。

    • Uses of IllegalArgumentException in java.lang.ref

      Methods in java.lang.ref that throw IllegalArgumentException
      Modifier and Type 方法 描述
      Reference<? extends T> ReferenceQueue.remove​(long timeout)
      删除此队列中的下一个参考对象，阻塞，直到任何一个可用或给定的超时期限到期。

    • Uses of IllegalArgumentException in java.lang.reflect

      Methods in java.lang.reflect that throw IllegalArgumentException
      Modifier and Type 方法 描述
      static Object Array.get​(Object array, int index)
      返回指定数组对象中的索引组件的值。
      Object Field.get​(Object obj)
      返回指定对象上由此 Field表示的字段的值。
      static boolean Array.getBoolean​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 boolean 。
      boolean Field.getBoolean​(Object obj)
      获取静态或实例的值 boolean字段。
      static byte Array.getByte​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 byte 。
      byte Field.getByte​(Object obj)
      获取静态或实例的值 byte字段。
      static char Array.getChar​(Object array, int index)
      返回指定数组对象中索引组件的值，如 char 。
      char Field.getChar​(Object obj)
      获取类型为 char的静态或实例字段的值，或通过加宽转换获得可转换为类型 char的另一个基本类型的值。
      static double Array.getDouble​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 double 。
      double Field.getDouble​(Object obj)
      获取类型为 double的静态或实例字段的值，或通过扩展转换获得可转换为类型 double的另一个原始类型的值。
      static float Array.getFloat​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 float 。
      float Field.getFloat​(Object obj)
      获取类型为 float的静态或实例字段的值，或通过扩展转换获得可转换为类型 float的另一个原始类型的值。
      static int Array.getInt​(Object array, int index)
      返回指定数组对象中索引组件的值，如 int 。
      int Field.getInt​(Object obj)
      获取类型为 int的静态或实例字段的值，或通过加宽转换获得可转换为类型 int的另一个原始类型的值。
      static InvocationHandler Proxy.getInvocationHandler​(Object proxy)
      返回指定代理实例的调用处理程序。
      static int Array.getLength​(Object array)
      返回指定数组对象的长度，如 int 。
      static long Array.getLong​(Object array, int index)
      返回指定数组对象中索引组件的值，如 long 。
      long Field.getLong​(Object obj)
      获取类型为 long的静态或实例字段的值，或通过扩大转换获得可转换为类型 long的另一个原始类型的值。
      static Class<?> Proxy.getProxyClass​(ClassLoader loader, Class<?>... interfaces)
      已过时。
      在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在无法访问的代理类上调用时抛出IllegalAccessException 。 使用Proxy.newProxyInstance(ClassLoader, Class[], InvocationHandler)代替创建一个代理实例。
      static short Array.getShort​(Object array, int index)
      返回指定数组对象中索引组件的值，如 short 。
      short Field.getShort​(Object obj)
      通过扩展转换获取类型为 short的静态或实例字段的 short或可转换为类型 short的另一个基本类型的值。
      Object Method.invoke​(Object obj, Object... args)
      在具有指定参数的指定对象上调用此 方法对象表示的底层方法。
      static Object Array.newInstance​(Class<?> componentType, int... dimensions)
      创建具有指定组件类型和尺寸的新数组。
      T Constructor.newInstance​(Object... initargs)
      使用由此 Constructor对象表示的构造函数，使用指定的初始化参数来创建和初始化构造函数的声明类的新实例。
      static void Array.set​(Object array, int index, Object value)
      将指定数组对象的索引组件的值设置为指定的新值。
      void Field.set​(Object obj, Object value)
      将指定对象参数上的此 Field对象表示的字段设置为指定的新值。
      static void Array.setBoolean​(Object array, int index, boolean z)
      将指定数组对象的索引组件的值设置为指定的 boolean值。
      void Field.setBoolean​(Object obj, boolean z)
      将字段的值设置为指定对象上的 boolean 。
      static void Array.setByte​(Object array, int index, byte b)
      将指定数组对象的索引组件的值设置为指定的 byte值。
      void Field.setByte​(Object obj, byte b)
      将字段的值设置为指定对象上的 byte 。
      static void Array.setChar​(Object array, int index, char c)
      将指定数组对象的索引组件的值设置为指定的 char值。
      void Field.setChar​(Object obj, char c)
      将字段的值设置为指定对象上的 char 。
      static void Array.setDouble​(Object array, int index, double d)
      将指定数组对象的索引组件的值设置为指定的 double值。
      void Field.setDouble​(Object obj, double d)
      将字段的值设置为指定对象上的 double 。
      static void Array.setFloat​(Object array, int index, float f)
      将指定数组对象的索引组件的值设置为指定的 float值。
      void Field.setFloat​(Object obj, float f)
      将字段的值设置为指定对象上的 float 。
      static void Array.setInt​(Object array, int index, int i)
      将指定数组对象的索引组件的值设置为指定的 int值。
      void Field.setInt​(Object obj, int i)
      将字段的值设置为指定对象上的 int 。
      static void Array.setLong​(Object array, int index, long l)
      将指定数组对象的索引组件的值设置为指定的 long值。
      void Field.setLong​(Object obj, long l)
      将字段的值设置为指定对象上的 long 。
      static void Array.setShort​(Object array, int index, short s)
      将指定数组对象的索引组件的值设置为指定的 short值。
      void Field.setShort​(Object obj, short s)
      将字段的值设置为指定对象上的 short 。

    • Uses of IllegalArgumentException in java.nio.channels

      Subclasses of IllegalArgumentException in java.nio.channels
      Modifier and Type Class 描述
      class  IllegalChannelGroupException
      尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。
      class  IllegalSelectorException
      当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。
      class  UnresolvedAddressException
      尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
      class  UnsupportedAddressTypeException
      尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。

    • Uses of IllegalArgumentException in java.nio.charset

      Subclasses of IllegalArgumentException in java.nio.charset
      Modifier and Type Class 描述
      class  IllegalCharsetNameException
      当使用不是 legal charset name的字符串时抛出未检查的异常。
      class  UnsupportedCharsetException
      对于请求的字符集，当没有可用的支持时抛出未检查的异常。

    • Uses of IllegalArgumentException in java.nio.file

      Subclasses of IllegalArgumentException in java.nio.file
      Modifier and Type Class 描述
      class  InvalidPathException
      当路径字符串不能转换为Path时，由于路径字符串包含无效字符或路径字符串对于其他文件系统特定的原因无效，因此抛出未检查的异常。
      class  ProviderMismatchException
      当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。

    • Uses of IllegalArgumentException in java.security

      Subclasses of IllegalArgumentException in java.security
      Modifier and Type Class 描述
      class  InvalidParameterException
      当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。

    • Uses of IllegalArgumentException in java.util

      Subclasses of IllegalArgumentException in java.util
      Modifier and Type Class 描述
      class  DuplicateFormatFlagsException
      在格式说明符中提供重复标志时抛出未经检查的异常。
      class  FormatFlagsConversionMismatchException
      转换和标志不兼容时抛出未经检查的异常。
      class  IllegalFormatCodePointException
      当由Character.isValidCodePoint(int)定义的具有无效Unicode代码点的字符传递给Formatter时，将抛出未经检查的异常。
      class  IllegalFormatConversionException
      当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。
      class  IllegalFormatException
      当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。
      class  IllegalFormatFlagsException
      提供非法组合标志时抛出未检查的异常。
      class  IllegalFormatPrecisionException
      当精度为 -1以外的负值时，抛出未检查的异常，转换不支持精度，否则不支持该值。
      class  IllegalFormatWidthException
      当格式宽度为 -1以外的否定值时，抛出未经检查的异常，否则不受支持。
      class  MissingFormatArgumentException
      当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
      class  MissingFormatWidthException
      需要格式宽度时抛出未检查的异常。
      class  UnknownFormatConversionException
      给出未知转换时抛出未检查的异常。
      class  UnknownFormatFlagsException
      给定未知标志时抛出未检查的异常。

    • Uses of IllegalArgumentException in java.util.logging

      Methods in java.util.logging that throw IllegalArgumentException
      Modifier and Type 方法 描述
      static Level Level.parse​(String name)
      将级别名称字符串解析为级别。
      Constructors in java.util.logging that throw IllegalArgumentException
      Constructor 描述
      LoggingPermission​(String name, String actions)
      创建一个新的LoggingPermission对象。

    • Uses of IllegalArgumentException in java.util.regex

      Subclasses of IllegalArgumentException in java.util.regex
      Modifier and Type Class 描述
      class  PatternSyntaxException
      抛出未经检查的异常，以指示正则表达式模式中的语法错误。

    • Uses of IllegalArgumentException in javax.management

      Methods in javax.management that throw IllegalArgumentException
      Modifier and Type | 方法 | 描述
      void | MBeanServerDelegate.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)
      void NotificationBroadcaster.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)
      添加一个监听器到这个MBean。
      void AttributeChangeNotificationFilter.enableAttribute​(String name)
      启用所有属性更改通知，其属性名称等于要发送给侦听器的指定名称。
      void NotificationFilterSupport.enableType​(String prefix)
      启用所有类型的通知以指定的前缀开始发送到侦听器。
      Constructors in javax.management that throw IllegalArgumentException
      Constructor 描述
      MBeanInfo​(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
      构造一个 MBeanInfo 。
      MBeanInfo​(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
      构造一个 MBeanInfo 。

    • Uses of IllegalArgumentException in javax.management.modelmbean

      Methods in javax.management.modelmbean that throw IllegalArgumentException
      Modifier and Type | 方法 | 描述
      void ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener​(NotificationListener listener, String attributeName, Object handback)
      注册一个实现NotificationListener接口的对象作为监听器。
      void | RequiredModelMBean.addAttributeChangeNotificationListener​(NotificationListener inlistener, String inAttributeName, Object inhandback)
      void RequiredModelMBean.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)
      注册一个实现NotificationListener接口的对象作为监听器。

    • Uses of IllegalArgumentException in javax.management.monitor

      Methods in javax.management.monitor that throw IllegalArgumentException
      Modifier and Type 方法 描述
      void Monitor.addObservedObject​(ObjectName object)
      如果该对象不存在，则将指定的对象添加到观察到的MBean集合中。
      void MonitorMBean.addObservedObject​(ObjectName object)
      将指定的对象添加到观察到的MBean集合中。
      void Monitor.setGranularityPeriod​(long period)
      设置粒度周期（以毫秒为单位）。
      void MonitorMBean.setGranularityPeriod​(long period)
      设置粒度周期（以毫秒为单位）。
      void CounterMonitor.setInitThreshold​(Number value)
      设置所有观察对象共同的初始阈值。
      void CounterMonitorMBean.setInitThreshold​(Number value)
      设置所有观察到的MBean公用的初始阈值。
      void CounterMonitor.setModulus​(Number value)
      设置所有观察到的MBean共有的模数值。
      void CounterMonitorMBean.setModulus​(Number value)
      设置模数值。
      void Monitor.setObservedAttribute​(String attribute)
      设置要观察的属性。
      void Monitor.setObservedObject​(ObjectName object)
      已过时。
      截至JMX 1.2，由Monitor.addObservedObject(javax.management.ObjectName)替代
      void CounterMonitor.setOffset​(Number value)
      设置所有观察到的MBean公用的偏移值。
      void CounterMonitorMBean.setOffset​(Number value)
      设置偏移值。
      void StringMonitor.setStringToCompare​(String value)
      将字符串设置为与所有观察到的MBean共有的观察属性进行比较。
      void StringMonitorMBean.setStringToCompare​(String value)
      设置与所观察属性进行比较的字符串。
      void CounterMonitor.setThreshold​(Number value)
      已过时。
      截至JMX 1.2，由CounterMonitor.setInitThreshold(java.lang.Number)替换
      void CounterMonitorMBean.setThreshold​(Number value)
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.setInitThreshold(java.lang.Number)取代
      void GaugeMonitor.setThresholds​(Number highValue, Number lowValue)
      设置所有观察到的MBean共有的高和低阈值。
      void GaugeMonitorMBean.setThresholds​(Number highValue, Number lowValue)
      设置高和低阈值。

    • Uses of IllegalArgumentException in javax.management.openmbean

      Subclasses of IllegalArgumentException in javax.management.openmbean
      Modifier and Type Class 描述
      class  InvalidKeyException
      抛出此运行时异常以指示预期为 复合数据的项名称或 表格数据的行索引的方法参数无效。
      class  InvalidOpenTypeException
      抛出此运行时异常以指示 打开的类型的 打开数据值不是预期的。
      class  KeyAlreadyExistsException
      抛出此运行时异常以指示要添加到 表格数据实例的行的索引已被用于引用此 表格数据实例中的另一行。

    • Uses of IllegalArgumentException in javax.management.relation

      Methods in javax.management.relation that throw IllegalArgumentException
      Modifier and Type | 方法 | 描述
      void RoleList.add​(int index, Role role)
      在指定的位置插入指定为元素的角色。
      void RoleList.add​(Role role)
      将指定的角色添加为列表的最后一个元素。
      void RoleUnresolvedList.add​(int index, RoleUnresolved role)
      在指定的位置插入指定为元素的未解决角色。
      void RoleUnresolvedList.add​(RoleUnresolved role)
      将指定的RoleUnresolved作为列表的最后一个元素添加。
      boolean RoleList.addAll​(int index, RoleList roleList)
      从指定的位置开始，按照指定的RoleList的迭代器返回的顺序，将指定的RoleList中的所有元素插入到此列表中。
      boolean RoleUnresolvedList.addAll​(int index, RoleUnresolvedList roleList)
      将指定的RoleUnresolvedList中的所有元素从指定的位置开始，按照指定的RoleUnresolvedList的迭代器返回的顺序。
      void RelationService.addRelation​(ObjectName relationObjectName)
      将由用户创建的一个MBean（并由他注册在MBean服务器中）添加为关系服务中的关系。
      void RelationServiceMBean.addRelation​(ObjectName relationObjectName)
      将由用户创建的一个MBean（并由他注册在MBean服务器中）添加为关系服务中的关系。
      void RelationService.addRelationType​(RelationType relationTypeObj)
      将给定对象添加为关系类型。
      void RelationServiceMBean.addRelationType​(RelationType relationTypeObj)
      将给定对象添加为关系类型。
      protected void RelationTypeSupport.addRoleInfo​(RoleInfo roleInfo)
      添加角色信息。
      Integer RelationService.checkRoleReading​(String roleName, String relationTypeName)
      检查给定角色是否可以以给定类型的关系读取。
      Integer RelationServiceMBean.checkRoleReading​(String roleName, String relationTypeName)
      检查给定角色是否可以以给定类型的关系读取。
      Integer RelationService.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)
      检查给定的角色是否可以按给定类型的关系进行设置。
      Integer RelationServiceMBean.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)
      检查给定的角色是否可以按给定类型的关系进行设置。
      void RelationService.createRelation​(String relationId, String relationTypeName, RoleList roleList)
      创建给定关系类型的简单关系（由RelationSupport对象表示），并将其添加到关系服务中。
      void RelationServiceMBean.createRelation​(String relationId, String relationTypeName, RoleList roleList)
      创建给定关系类型的简单关系（由RelationSupport对象表示），并将其添加到关系服务中。
      void RelationService.createRelationType​(String relationTypeName, RoleInfo[] roleInfoArray)
      使用给定的角色信息（由RoleInfo对象提供）创建关系类型（RelationTypeSupport对象），并将其添加到关系服务中。
      void RelationServiceMBean.createRelationType​(String relationTypeName, RoleInfo[] roleInfoArray)
      使用给定的角色信息（由RoleInfo对象提供）创建关系类型（RelationTypeSupport对象），并将其添加到关系服务中。
      void MBeanServerNotificationFilter.disableObjectName​(ObjectName objectName)
      禁用有关给定ObjectName的MBeanServerNotifications。
      void MBeanServerNotificationFilter.enableObjectName​(ObjectName objectName)
      启用有关给定ObjectName的MBeanServerNotifications。
      Map<ObjectName,List<String>> RelationService.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索与某个关系中的给定关联的MBean。
      Map<ObjectName,List<String>> RelationServiceMBean.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索与某个关系中的给定关联的MBean。
      Map<String,List<String>> RelationService.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索给定MBean引用的关系。
      Map<String,List<String>> RelationServiceMBean.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)
      检索给定MBean引用的关系。
      List<String> RelationService.findRelationsOfType​(String relationTypeName)
      返回给定类型的关系的关系id。
      List<String> RelationServiceMBean.findRelationsOfType​(String relationTypeName)
      返回给定类型的关系的关系id。
      RoleResult RelationService.getAllRoles​(String relationId)
      返回关系中存在的所有角色。
      RoleResult RelationServiceMBean.getAllRoles​(String relationId)
      返回关系中存在的所有角色。
      Map<ObjectName,List<String>> RelationService.getReferencedMBeans​(String relationId)
      检索在关系的各种角色中引用的MBean。
      Map<ObjectName,List<String>> RelationServiceMBean.getReferencedMBeans​(String relationId)
      检索在关系的各种角色中引用的MBean。
      String RelationService.getRelationTypeName​(String relationId)
      返回给定关系的关联关系类型的名称。
      String RelationServiceMBean.getRelationTypeName​(String relationId)
      返回给定关系的关联关系类型的名称。
      List<ObjectName> Relation.getRole​(String roleName)
      检索给定角色名称的角色值。
      List<ObjectName> RelationService.getRole​(String relationId, String roleName)
      在给定关系中为给定的角色名称检索角色值。
      List<ObjectName> RelationServiceMBean.getRole​(String relationId, String roleName)
      在给定关系中为给定的角色名称检索角色值。
      List<ObjectName> RelationSupport.getRole​(String roleName)
      检索给定角色名称的角色值。
      Integer Relation.getRoleCardinality​(String roleName)
      返回当前在给定角色中引用的MBean数。
      Integer RelationService.getRoleCardinality​(String relationId, String roleName)
      检索当前在给定角色中引用的MBeans数。
      Integer RelationServiceMBean.getRoleCardinality​(String relationId, String roleName)
      检索当前在给定角色中引用的MBeans数。
      Integer RelationSupport.getRoleCardinality​(String roleName)
      返回当前在给定角色中引用的MBean数。
      RoleInfo RelationService.getRoleInfo​(String relationTypeName, String roleInfoName)
      检索给定关系类型的给定角色名称的角色信息。
      RoleInfo RelationServiceMBean.getRoleInfo​(String relationTypeName, String roleInfoName)
      检索给定关系类型的给定角色的角色信息。
      RoleInfo RelationType.getRoleInfo​(String roleInfoName)
      返回给定角色信息名称的角色信息（RoleInfo对象）（如果未找到，则返回null）。
      RoleInfo RelationTypeSupport.getRoleInfo​(String roleInfoName)
      返回给定角色信息名称的角色信息（RoleInfo对象）（如果未找到，则返回null）。
      List<RoleInfo> RelationService.getRoleInfos​(String relationTypeName)
      检索给定关系类型的角色信息（RoleInfo对象）的列表。
      List<RoleInfo> RelationServiceMBean.getRoleInfos​(String relationTypeName)
      检索给定关系类型的角色信息（RoleInfo对象）的列表。
      RoleResult Relation.getRoles​(String[] roleNameArray)
      检索具有给定名称的角色值。
      RoleResult RelationService.getRoles​(String relationId, String[] roleNameArray)
      以给定的关系取得给定名称的角色值。
      RoleResult RelationServiceMBean.getRoles​(String relationId, String[] roleNameArray)
      以给定的关系取得给定名称的角色值。
      RoleResult RelationSupport.getRoles​(String[] roleNameArray)
      检索具有给定名称的角色值。
      void Relation.handleMBeanUnregistration​(ObjectName objectName, String roleName)
      当角色引用的MBean未注册时，关系服务使用的回调。
      void RelationSupport.handleMBeanUnregistration​(ObjectName objectName, String roleName)
      当角色引用的MBean未注册时，关系服务使用的回调。
      Boolean RelationService.hasRelation​(String relationId)
      检查在关系服务中是否存在与给定关系ID相关联的关系。
      Boolean RelationServiceMBean.hasRelation​(String relationId)
      检查在关系服务中是否存在与给定关系ID相关联的关系。
      boolean MBeanServerNotificationFilter.isNotificationEnabled​(Notification notif)
      在将指定的通知发送给侦听器之前调用。
      String RelationService.isRelation​(ObjectName objectName)
      如果MBean作为关系服务中的关系添加，则返回与给定ObjectName关联的关系id。
      String RelationServiceMBean.isRelation​(ObjectName objectName)
      如果MBean作为关系服务中的关系添加，则返回与给定ObjectName关联的关系id。
      ObjectName RelationService.isRelationMBean​(String relationId)
      如果关系由MBean（由用户创建并在关系服务中添加为关系）表示，则返回MBean的ObjectName。
      ObjectName RelationServiceMBean.isRelationMBean​(String relationId)
      如果关系由MBean（由用户创建并在关系服务中添加为关系）表示，则返回MBean的ObjectName。
      void RelationService.removeRelation​(String relationId)
      从关系服务中删除给定的关系。
      void RelationServiceMBean.removeRelation​(String relationId)
      从关系服务中删除给定的关系。
      void RelationService.removeRelationType​(String relationTypeName)
      从关系服务中删除给定的关系类型。
      void RelationServiceMBean.removeRelationType​(String relationTypeName)
      从关系服务中删除给定的关系类型。
      static String Role.roleValueToString​(List<ObjectName> roleValue)
      返回给定角色值的字符串。
      void RelationService.sendRelationCreationNotification​(String relationId)
      发送关系创建的通知（RelationNotification）。
      void RelationServiceMBean.sendRelationCreationNotification​(String relationId)
      发送关系创建的通知（RelationNotification）。
      void RelationService.sendRelationRemovalNotification​(String relationId, List<ObjectName> unregMBeanList)
      发送通知（RelationNotification）用于删除关系。
      void RelationServiceMBean.sendRelationRemovalNotification​(String relationId, List<ObjectName> unregMBeanList)
      发送通知（RelationNotification）用于删除关系。
      void RelationService.sendRoleUpdateNotification​(String relationId, Role newRole, List<ObjectName> oldValue)
      发送给定关系中角色更新的通知（RelationNotification）。
      void RelationServiceMBean.sendRoleUpdateNotification​(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      发送给定关系中角色更新的通知（RelationNotification）。
      void RoleList.set​(int index, Role role)
      将元素设置为指定的角色。
      void RoleUnresolvedList.set​(int index, RoleUnresolved role)
      将元素指定为指定的未解决角色。
      void RoleUnresolved.setProblemType​(int pbType)
      设置问题类型。
      void | RelationSupport.setRelationServiceManagementFlag​(Boolean flag)
      void RelationSupportMBean.setRelationServiceManagementFlag​(Boolean flag)
      指定该关系是否由关系服务处理。
      void Relation.setRole​(Role role)
      设置给定的角色。
      void RelationService.setRole​(String relationId, Role role)
      在给定的关系中设定给定的角色。
      void RelationServiceMBean.setRole​(String relationId, Role role)
      在给定的关系中设定给定的角色。
      void RelationSupport.setRole​(Role role)
      设置给定的角色。
      void Role.setRoleName​(String roleName)
      设置角色名称。
      void RoleUnresolved.setRoleName​(String name)
      设置角色名称。
      RoleResult Relation.setRoles​(RoleList roleList)
      设置给定的角色。
      RoleResult RelationService.setRoles​(String relationId, RoleList roleList)
      在给定的关系中设定给定的角色。
      RoleResult RelationServiceMBean.setRoles​(String relationId, RoleList roleList)
      在给定的关系中设定给定的角色。
      RoleResult RelationSupport.setRoles​(RoleList list)
      设置给定的角色。
      void Role.setRoleValue​(List<ObjectName> roleValue)
      设置角色值。
      void RelationService.updateRoleMap​(String relationId, Role newRole, List<ObjectName> oldValue)
      处理关系服务角色图更新给定关系中给定角色的更新。
      void RelationServiceMBean.updateRoleMap​(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      处理关系服务角色图更新给定关系中给定角色的更新。
      Constructors in javax.management.relation that throw IllegalArgumentException
      Constructor 描述
      RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
      为关系中的角色更新创建通知。
      RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
      创建关系创建（RelationSupport对象在关系服务内部创建的，或作为关系添加的MBean）或关系删除关系服务的通知。
      RelationSupport​(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
      创建一个 RelationSupport对象。
      RelationSupport​(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
      创建一个 RelationSupport对象。
      RelationTypeSupport​(String relationTypeName, RoleInfo[] roleInfoArray)
      所有角色定义都被动态创建并作为参数传递的构造方法。
      Role​(String roleName, List<ObjectName> roleValue)
      创建一个新的角色对象。
      RoleInfo​(String roleName, String mbeanClassName)
      构造函数。
      RoleInfo​(String roleName, String mbeanClassName, boolean read, boolean write)
      构造函数。
      RoleInfo​(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
      构造函数。
      RoleInfo​(RoleInfo roleInfo)
      复制构造函数。
      RoleList​(List<Role> list)
      构造一个 RoleList含有的元素 List指定，在其中它们被返回的顺序 List的迭代器。
      RoleUnresolved​(String name, List<ObjectName> value, int pbType)
      构造函数。
      RoleUnresolvedList​(List<RoleUnresolved> list)
      构造一个包含 RoleUnresolvedList元素的 List ，按 List的迭代器返回它们的顺序。

    • Uses of IllegalArgumentException in javax.management.timer

      Methods in javax.management.timer that throw IllegalArgumentException
      Modifier and Type 方法 描述
      Integer Timer.addNotification​(String type, String message, Object userData, Date date)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

    • Uses of IllegalArgumentException in javax.net.ssl

      Methods in javax.net.ssl that throw IllegalArgumentException
      Modifier and Type 方法 描述
      void SSLSessionContext.setSessionCacheSize​(int size)
      设置用于存储 SSLSession对象的高速缓存的大小，分组在此 SSLSessionContext 。
      void SSLSessionContext.setSessionTimeout​(int seconds)
      设置超时限制 SSLSession级这个组合的对象 SSLSessionContext 。

    • Uses of IllegalArgumentException in javax.rmi.ssl

      Constructors in javax.rmi.ssl that throw IllegalArgumentException
      Constructor 描述
      SslRMIServerSocketFactory​(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
      使用指定的SSL套接字配置创建一个新的 SslRMIServerSocketFactory 。
      SslRMIServerSocketFactory​(SSLContext context, String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
      创建一个新的 SslRMIServerSocketFactory与指定的 SSLContext和SSL套接字配置。

    • Uses of IllegalArgumentException in javax.swing

      Methods in javax.swing that throw IllegalArgumentException
      Modifier and Type 方法 描述
      Popup PopupFactory.getPopup​(Component owner, Component contents, int x, int y)
      创建 Popup为组件 owner包含Component contents 。
      protected Popup PopupFactory.getPopup​(Component owner, Component contents, int x, int y, boolean isHeavyWeightPopup)
      创建 Popup为组件 owner包含Component contents 。
      void AbstractButton.setDisplayedMnemonicIndex​(int index)
      提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。
      void JLabel.setDisplayedMnemonicIndex​(int index)
      提供关于文字中哪个字符应该被装饰以表示助记符的外观和感觉的提示。

    • Uses of IllegalArgumentException in javax.xml.parsers

      Methods in javax.xml.parsers that throw IllegalArgumentException
      Modifier and Type 方法 描述
      abstract Object DocumentBuilderFactory.getAttribute​(String name)
      允许用户检索底层实现的特定属性。
      abstract void DocumentBuilderFactory.setAttribute​(String name, Object value)
      允许用户在底层实现上设置特定属性。

    • Uses of IllegalArgumentException in javax.xml.stream

      Methods in javax.xml.stream that throw IllegalArgumentException
      Modifier and Type 方法 描述
      Object XMLEventReader.getProperty​(String name)
      从底层实现获取特征/属性的值
      abstract Object XMLInputFactory.getProperty​(String name)
      从底层实现获取特征/属性的值
      abstract Object XMLOutputFactory.getProperty​(String name)
      获取底层实现的功能/属性
      Object XMLStreamReader.getProperty​(String name)
      从底层实现获取特征/属性的值
      Object XMLStreamWriter.getProperty​(String name)
      从底层实现获取特征/属性的值
      abstract void XMLInputFactory.setProperty​(String name, Object value)
      允许用户在底层实现上设置特定的功能/属性。
      abstract void XMLOutputFactory.setProperty​(String name, Object value)
      允许用户在底层实现上设置特定的功能/属性。

    • Uses of IllegalArgumentException in javax.xml.stream.util

      Methods in javax.xml.stream.util that throw IllegalArgumentException
      Modifier and Type | 方法 | 描述
      Object | EventReaderDelegate.getProperty​(String name)

    • Uses of IllegalArgumentException in javax.xml.transform

      Methods in javax.xml.transform that throw IllegalArgumentException
      Modifier and Type 方法 描述
      abstract String Transformer.getOutputProperty​(String name)
      获取对变压器有效的输出属性。
      abstract void Transformer.setErrorListener​(ErrorListener listener)
      设置变量生效的错误事件侦听器。
      abstract void Transformer.setOutputProperty​(String name, String value)
      设置一个对转换有效的输出属性。

    • Uses of IllegalArgumentException in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that throw IllegalArgumentException
      Modifier and Type 方法 描述
      void TransformerHandler.setResult​(Result result)
      将与此 Result相关联的 TransformerHandler设置为用于转换。

    • Uses of IllegalArgumentException in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that throw IllegalArgumentException
      Modifier and Type 方法 描述
      abstract void Invoker.inject​(WebServiceContext webServiceContext)
      JAX-WS运行时调用此方法来请求容器在端点实例上注入WebServiceContext。
      abstract Object Invoker.invoke​(方法 m, Object... args)
      JAX-WS运行时调用此方法来对端点实例执行实际的Web服务调用。

    • Uses of IllegalArgumentException in jdk.nashorn.api.tree

      Methods in jdk.nashorn.api.tree that throw IllegalArgumentException
      Modifier and Type 方法 描述
      static Parser Parser.create​(String... options)
      Factory方法创建一个新的Parser实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IllegalCallerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IllegalCallerException

No usage of java.lang.IllegalCallerException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IllegalMonitorStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IllegalMonitorStateException

No usage of java.lang.IllegalMonitorStateException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IllegalStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IllegalStateException

  • Packages that use IllegalStateException
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javax.crypto
    提供加密操作的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

    • Uses of IllegalStateException in com.sun.nio.sctp

      Subclasses of IllegalStateException in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  IllegalReceiveException
      当试图调用未经检查的异常receive的方法SctpChannel或SctpMultiChannel从通知处理程序。
      class  IllegalUnbindException
      尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。

    • Uses of IllegalStateException in java.awt

      Subclasses of IllegalStateException in java.awt
      Modifier and Type Class 描述
      class  IllegalComponentStateException
      表示AWT组件对于请求的操作不在适当的状态。
      Methods in java.awt that throw IllegalStateException
      Modifier and Type 方法 描述
      void SplashScreen.close​()
      隐藏启动屏幕，关闭窗口，并释放所有关联的资源。
      Graphics2D SplashScreen.createGraphics​()
      为启动屏幕叠加图像创建图形上下文（作为Graphics2D对象），允许您绘制闪屏。
      Rectangle SplashScreen.getBounds​()
      以Rectangle返回启动屏幕窗口的边界 。
      URL SplashScreen.getImageURL​()
      返回当前的闪屏图像。
      Dimension SplashScreen.getSize​()
      以Dimension返回闪屏的大小。
      void SplashScreen.setImageURL​(URL imageURL)
      更改启动屏幕图像。
      void SplashScreen.update​()
      使用覆盖图像的当前内容更新启动窗口。

    • Uses of IllegalStateException in java.awt.dnd

      Subclasses of IllegalStateException in java.awt.dnd
      Modifier and Type Class 描述
      class  InvalidDnDOperationException
      java.awt.dnd包中的各种方法抛出此异常。

    • Uses of IllegalStateException in java.nio

      Subclasses of IllegalStateException in java.nio
      Modifier and Type Class 描述
      class  InvalidMarkException
      当未定义其标记时尝试复位缓冲区时抛出未检查的异常。

    • Uses of IllegalStateException in java.nio.channels

      Subclasses of IllegalStateException in java.nio.channels
      Modifier and Type Class 描述
      class  AcceptPendingException
      尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
      class  AlreadyBoundException
      尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
      class  AlreadyConnectedException
      尝试连接已连接的SocketChannel时 ，会引发未检查的异常。
      class  CancelledKeyException
      当试图使用不再有效的选择键时抛出未检查的异常。
      class  ClosedSelectorException
      尝试在闭合选择器上调用I / O操作时抛出未检查的异常。
      class  ConnectionPendingException
      尝试连接未阻塞连接操作的SocketChannel时抛出未检查的异常。
      class  IllegalBlockingModeException
      当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。
      class  NoConnectionPendingException
      当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
      class  NonReadableChannelException
      尝试从最初打开阅读的频道中读取时未抛出的异常。
      class  NonWritableChannelException
      尝试写入最初未打开的通道进行写入时抛出未检查的异常。
      class  NotYetBoundException
      尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
      class  NotYetConnectedException
      当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
      class  OverlappingFileLockException
      当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
      class  ReadPendingException
      尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
      class  ShutdownChannelGroupException
      当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。
      class  WritePendingException
      尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。

    • Uses of IllegalStateException in java.nio.file

      Subclasses of IllegalStateException in java.nio.file
      Modifier and Type Class 描述
      class  ClosedDirectoryStreamException
      尝试在关闭的目录流上调用操作时抛出未检查的异常。
      class  ClosedFileSystemException
      尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。
      class  ClosedWatchServiceException
      尝试在关闭的手表服务上调用操作时抛出未检查的异常。

    • Uses of IllegalStateException in java.util

      Subclasses of IllegalStateException in java.util
      Modifier and Type Class 描述
      class  FormatterClosedException
      格式化程序已关闭时抛出未检查的异常。

    • Uses of IllegalStateException in java.util.concurrent

      Subclasses of IllegalStateException in java.util.concurrent
      Modifier and Type Class 描述
      class  CancellationException
      异常表示由于任务被取消，无法检索值生成任务的结果，如FutureTask 。

    • Uses of IllegalStateException in javax.crypto

      Methods in javax.crypto that throw IllegalStateException
      Modifier and Type 方法 描述
      byte[] Mac.doFinal​()
      完成MAC操作。
      byte[] Mac.doFinal​(byte[] input)
      处理给定的字节数组，并完成MAC操作。
      void Mac.doFinal​(byte[] output, int outOffset)
      完成MAC操作。
      Key KeyAgreement.doPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected abstract Key KeyAgreementSpi.engineDoPhase​(Key key, boolean lastPhase)
      执行该关键协议的下一阶段，其中包含从本协议涉及的其中一方收到的给定密钥。
      protected abstract byte[] KeyAgreementSpi.engineGenerateSecret​()
      生成共享密钥并将其返回到新的缓冲区。
      protected abstract int KeyAgreementSpi.engineGenerateSecret​(byte[] sharedSecret, int offset)
      生成共享密钥，并将其放入缓冲区 sharedSecret ，从 offset开始。
      protected abstract SecretKey KeyAgreementSpi.engineGenerateSecret​(String algorithm)
      创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。
      byte[] KeyAgreement.generateSecret​()
      生成共享密钥并将其返回到新的缓冲区。
      int KeyAgreement.generateSecret​(byte[] sharedSecret, int offset)
      生成共享密钥，并将其放入缓冲区 sharedSecret ，从 offset开始。
      SecretKey KeyAgreement.generateSecret​(String algorithm)
      创建共享密钥，并将其作为指定算法的 SecretKey对象返回。
      byte[] ExemptionMechanism.genExemptionBlob​()
      生成豁免机制密钥blob。
      int ExemptionMechanism.genExemptionBlob​(byte[] output)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中。
      int ExemptionMechanism.genExemptionBlob​(byte[] output, int outputOffset)
      生成豁免机制密钥blob，并将结果存储在 output缓冲区中，从 outputOffset开始。
      int ExemptionMechanism.getOutputSize​(int inputLen)
      给定输入长度为 inputLen （以字节为单位），返回输出缓冲区需要保存下一个 genExemptionBlob操作结果的字节长度。
      void Mac.update​(byte input)
      处理给定的字节。
      void Mac.update​(byte[] input)
      处理给定的字节数组。
      void Mac.update​(byte[] input, int offset, int len)
      处理第一 len字节 input ，起始于 offset以下。

    • Uses of IllegalStateException in javax.swing

      Methods in javax.swing that throw IllegalStateException
      Modifier and Type 方法 描述
      void TransferHandler.exportToClipboard​(JComponent comp, Clipboard clip, int action)
      导致从给定组件转移到给定的剪贴板。

    • Uses of IllegalStateException in javax.xml.bind

      Methods in javax.xml.bind that throw IllegalStateException
      Modifier and Type 方法 描述
      Object UnmarshallerHandler.getResult​()
      获得未组织的结果。

    • Uses of IllegalStateException in jdk.jshell

      Methods in jdk.jshell that throw IllegalStateException
      Modifier and Type 方法 描述
      JShell JShell.Builder.build​()
      构建一个JShell状态引擎。
      static JShell JShell.create​()
      创建一个新的JShell状态引擎。
      List<SnippetEvent> JShell.drop​(Snippet snippet)
      从状态中移除声明。
      List<SnippetEvent> JShell.eval​(String input)
      评估输入字符串，包括定义和/或执行（如果适用）。
      JShell.Subscription JShell.onShutdown​(Consumer<JShell> listener)
      当JShell实例终止时，注册要调用的回调。
      JShell.Subscription JShell.onSnippetEvent​(Consumer<SnippetEvent> listener)
      当代码段的状态更改时，注册要调用的回调。
      String JShell.varValue​(VarSnippet snippet)
      获取变量的当前值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IllegalThreadStateException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IllegalThreadStateException

No usage of java.lang.IllegalThreadStateException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IncompatibleClassChangeError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IncompatibleClassChangeError

  • Packages that use IncompatibleClassChangeError
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of IncompatibleClassChangeError in java.lang

      Subclasses of IncompatibleClassChangeError in java.lang
      Modifier and Type Class 描述
      class  AbstractMethodError
      当应用程序尝试调用抽象方法时抛出。
      class  IllegalAccessError
      如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。
      class  InstantiationError
      当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。
      class  NoSuchFieldError
      如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。
      class  NoSuchMethodError
      如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.IndexOutOfBoundsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.IndexOutOfBoundsException

  • Packages that use IndexOutOfBoundsException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.print
    提供通用打印API的类和接口。
    java.lang
    提供对Java编程语言设计至关重要的类。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javax.management.relation
    提供关系服务的定义。

    • Uses of IndexOutOfBoundsException in java.awt

      Methods in java.awt that throw IndexOutOfBoundsException
      Modifier and Type 方法 描述
      Cursor Toolkit.createCustomCursor​(Image cursor, Point hotSpot, String name)
      创建一个新的自定义光标对象。

    • Uses of IndexOutOfBoundsException in java.awt.print

      Methods in java.awt.print that throw IndexOutOfBoundsException
      Modifier and Type 方法 描述
      PageFormat Book.getPageFormat​(int pageIndex)
      返回pageIndex指定页面的pageIndex 。
      PageFormat Pageable.getPageFormat​(int pageIndex)
      返回 PageFormat指定页面的 pageIndex 。
      Printable Book.getPrintable​(int pageIndex)
      返回Printable实例，负责渲染由pageIndex指定的pageIndex 。
      Printable Pageable.getPrintable​(int pageIndex)
      返回 Printable实例，负责渲染由 pageIndex指定的 pageIndex 。
      void Book.setPage​(int pageIndex, Printable painter, PageFormat page)
      为指定的页码设置 PageFormat和 Painter 。

    • Uses of IndexOutOfBoundsException in java.lang

      Subclasses of IndexOutOfBoundsException in java.lang
      Modifier and Type Class 描述
      class  ArrayIndexOutOfBoundsException
      抛出以表示使用非法索引访问数组。
      class  StringIndexOutOfBoundsException
      抛出 String方法来指示索引为负或大于字符串的大小。

    • Uses of IndexOutOfBoundsException in javafx.scene.web

      Methods in javafx.scene.web that throw IndexOutOfBoundsException
      Modifier and Type 方法 描述
      void WebHistory.go​(int offset)
      将Web引擎导航到由相对于当前条目指定位置的 Entry对象定义的URL。

    • Uses of IndexOutOfBoundsException in javax.management.relation

      Methods in javax.management.relation that throw IndexOutOfBoundsException
      Modifier and Type 方法 描述
      void RoleList.add​(int index, Role role)
      在指定的位置插入指定为元素的角色。
      void RoleUnresolvedList.add​(int index, RoleUnresolved role)
      在指定的位置插入指定为元素的未解决角色。
      boolean RoleList.addAll​(int index, RoleList roleList)
      从指定的位置开始，按照指定的RoleList的迭代器返回的顺序，将指定的RoleList中的所有元素插入到此列表中。
      boolean RoleList.addAll​(RoleList roleList)
      将所指定的RoleList中的所有元素按指定的RoleList的迭代器返回的顺序附加到列表的末尾。
      boolean RoleUnresolvedList.addAll​(int index, RoleUnresolvedList roleList)
      将指定的RoleUnresolvedList中的所有元素从指定的位置开始，按照指定的RoleUnresolvedList的迭代器返回的顺序。
      boolean RoleUnresolvedList.addAll​(RoleUnresolvedList roleList)
      按照指定的RoleUnresolvedList的迭代器返回的顺序，将指定的RoleUnresolvedList中的所有元素附加到列表的末尾。
      void RoleList.set​(int index, Role role)
      将元素设置为指定的角色。
      void RoleUnresolvedList.set​(int index, RoleUnresolved role)
      将元素指定为指定的未解决角色。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.InheritableThreadLocal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.InheritableThreadLocal

No usage of java.lang.InheritableThreadLocal
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.InstantiationError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.InstantiationError

No usage of java.lang.InstantiationError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.InstantiationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.InstantiationException

  • Packages that use InstantiationException
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    org.w3c.dom.bootstrap
    提供一个工厂获得 DOMImplementation实例。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of InstantiationException in java.lang

      Methods in java.lang that throw InstantiationException
      Modifier and Type 方法 描述
      T Class.newInstance​()
      已过时。
      此方法传播由nullary构造函数抛出的任何异常，包括已检查的异常。 使用此方法有效地绕过编译器异常检查，否则将由编译器执行。 Constructor.newInstance方法通过在（已选） InvocationTargetException中包含构造函数抛出的任何异常来避免此问题。

      电话

         clazz.newInstance()
      可以替换
         clazz.getDeclaredConstructor().newInstance()
      后一个调用序列被推断为能够抛出额外的异常类型InvocationTargetException和NoSuchMethodException 。 这两个异常类型都是ReflectiveOperationException的子类。

    • Uses of InstantiationException in java.lang.reflect

      Methods in java.lang.reflect that throw InstantiationException
      Modifier and Type 方法 描述
      T Constructor.newInstance​(Object... initargs)
      使用由此 Constructor对象表示的构造函数，使用指定的初始化参数来创建和初始化构造函数的声明类的新实例。

    • Uses of InstantiationException in java.util

      Methods in java.util that throw InstantiationException
      Modifier and Type 方法 描述
      ResourceBundle ResourceBundle.Control.newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
      为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。

    • Uses of InstantiationException in javax.swing

      Methods in javax.swing that throw InstantiationException
      Modifier and Type 方法 描述
      static void UIManager.setLookAndFeel​(String className)
      使用当前线程的上下文类加载器加载由给定类名指定的 LookAndFeel ，并将其传递给 setLookAndFeel(LookAndFeel) 。

    • Uses of InstantiationException in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that throw InstantiationException
      Modifier and Type 方法 描述
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance​()
      获取一个新的实例 DOMImplementationRegistry 。

    • Uses of InstantiationException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw InstantiationException
      Modifier and Type 方法 描述
      static Parser ParserFactory.makeParser​()
      已过时。
      使用`org.xml.sax.parser'系统属性创建一个新的SAX解析器。
      static Parser ParserFactory.makeParser​(String className)
      已过时。
      使用提供的类名创建一个新的SAX解析器对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Integer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Integer

  • Packages that use Integer
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.awt.font
    提供与字体相关的类和界面。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.spi
    java.util包中类的服务提供者类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，加上一些实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.management.timer
    提供定时器MBean的定义。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

    • Uses of Integer in com.sun.nio.sctp

      Fields in com.sun.nio.sctp with type parameters of type Integer
      Modifier and Type Field 描述
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SCTP_FRAGMENT_INTERLEAVE
      分段交错控制消息接收器的消息呈现方式。
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SO_LINGER
      如果数据存在，则关闭。
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SO_RCVBUF
      套接字的大小接收缓冲区。
      static SctpSocketOption<Integer> SctpStandardSocketOptions.SO_SNDBUF
      套接字发送缓冲区的大小。

    • Uses of Integer in java.awt.font

      Fields in java.awt.font declared as Integer
      Modifier and Type Field 描述
      static Integer TextAttribute.KERNING_ON
      请求标准字距。
      static Integer TextAttribute.LIGATURES_ON
      请求标准可选连字。
      static Integer TextAttribute.SUPERSCRIPT_SUB
      标准下标。
      static Integer TextAttribute.SUPERSCRIPT_SUPER
      标准上标。
      static Integer TextAttribute.UNDERLINE_LOW_DASHED
      单像素虚线低下划线。
      static Integer TextAttribute.UNDERLINE_LOW_DOTTED
      单像素点下划线。
      static Integer TextAttribute.UNDERLINE_LOW_GRAY
      双像素灰色低下划线。
      static Integer TextAttribute.UNDERLINE_LOW_ONE_PIXEL
      单像素固体低下划线。
      static Integer TextAttribute.UNDERLINE_LOW_TWO_PIXEL
      双像素固体低下划线。
      static Integer TextAttribute.UNDERLINE_ON
      标准下划线。

    • Uses of Integer in java.lang

      Fields in java.lang with type parameters of type Integer
      Modifier and Type Field 描述
      static Class<Integer> Integer.TYPE
      Class实例代表原始类型 int 。
      Methods in java.lang that return Integer
      Modifier and Type 方法 描述
      static Integer Integer.decode​(String nm)
      将 String解码成 Integer 。
      static Integer Integer.getInteger​(String nm)
      确定具有指定名称的系统属性的整数值。
      static Integer Integer.getInteger​(String nm, int val)
      确定具有指定名称的系统属性的整数值。
      static Integer Integer.getInteger​(String nm, Integer val)
      返回具有指定名称的系统属性的整数值。
      static Integer Integer.valueOf​(int i)
      返回一个表示 int值的 Integer实例。
      static Integer Integer.valueOf​(String s)
      返回一个 Integer对象，保存指定的值为 String 。
      static Integer Integer.valueOf​(String s, int radix)
      返回一个 Integer对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
      Methods in java.lang that return types with arguments of type Integer
      Modifier and Type 方法 描述
      Optional<Integer> Runtime.Version.build​()
      返回 build number 。
      List<Integer> Runtime.Version.version​()
      返回version number中包含的整数数字不可修改的List 。
      Methods in java.lang with parameters of type Integer
      Modifier and Type 方法 描述
      int Integer.compareTo​(Integer anotherInteger)
      数字比较两个 Integer对象。
      static Integer Integer.getInteger​(String nm, Integer val)
      返回具有指定名称的系统属性的整数值。

    • Uses of Integer in java.net

      Fields in java.net with type parameters of type Integer
      Modifier and Type Field 描述
      static SocketOption<Integer> StandardSocketOptions.IP_MULTICAST_TTL
      互联网协议（IP）组播数据报 的生存时间 。
      static SocketOption<Integer> StandardSocketOptions.IP_TOS
      互联网协议（IP）头中的服务类型（ToS）八位字节。
      static SocketOption<Integer> StandardSocketOptions.SO_LINGER
      如果数据存在，则关闭。
      static SocketOption<Integer> StandardSocketOptions.SO_RCVBUF
      套接字的大小接收缓冲区。
      static SocketOption<Integer> StandardSocketOptions.SO_SNDBUF
      套接字发送缓冲区的大小。

    • Uses of Integer in java.nio.channels

      Methods in java.nio.channels that return types with arguments of type Integer
      Modifier and Type | 方法 | 描述
      Future<Integer> AsynchronousByteChannel.read​(ByteBuffer dst)
      从该通道读取到给定缓冲区的字节序列。
      abstract Future<Integer> AsynchronousFileChannel.read​(ByteBuffer dst, long position)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract Future<Integer> | AsynchronousSocketChannel.read​(ByteBuffer dst)
      Future<Integer> AsynchronousByteChannel.write​(ByteBuffer src)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract Future<Integer> AsynchronousFileChannel.write​(ByteBuffer src, long position)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      abstract Future<Integer> | AsynchronousSocketChannel.write​(ByteBuffer src)
      Method parameters in java.nio.channels with type arguments of type Integer
      Modifier and Type | 方法 | 描述
      <A> void AsynchronousByteChannel.read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      abstract <A> void AsynchronousFileChannel.read​(ByteBuffer dst, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的文件位置开始，从该通道读取一个字节序列到给定的缓冲区。
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer dst, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从该通道读取到给定缓冲区的字节序列。
      <A> void | AsynchronousSocketChannel.read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)
      <A> void AsynchronousByteChannel.write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。
      abstract <A> void AsynchronousFileChannel.write​(ByteBuffer src, long position, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向给定的文件位置开始，向该通道写入一个字节序列。
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer src, long timeout, TimeUnit unit, A attachment, CompletionHandler<Integer,? super A> handler)
      从给定的缓冲区向该通道写入一个字节序列。
      <A> void | AsynchronousSocketChannel.write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)

    • Uses of Integer in java.sql

      Methods in java.sql that return Integer
      Modifier and Type 方法 描述
      Integer JDBCType.getVendorTypeNumber​()
      返回数据类型的供应商特定类型编号。
      Integer SQLType.getVendorTypeNumber​()
      返回数据类型的供应商特定类型编号。

    • Uses of Integer in java.util

      Methods in java.util that return Integer
      Modifier and Type 方法 描述
      default Integer PrimitiveIterator.OfInt.next​()
      返回迭代中的下一个元素。
      Methods in java.util that return types with arguments of type Integer
      Modifier and Type 方法 描述
      Map<String,Integer> Calendar.getDisplayNames​(int field, int style, Locale locale)
      返回一个 Map其中包含给定的 style和 locale中的日历 field所有名称及其对应的字段值。
      Method parameters in java.util with type arguments of type Integer
      Modifier and Type 方法 描述
      default void PrimitiveIterator.OfInt.forEachRemaining​(Consumer<? super Integer> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void Spliterator.OfInt.forEachRemaining​(Consumer<? super Integer> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default boolean Spliterator.OfInt.tryAdvance​(Consumer<? super Integer> action)
      如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。

    • Uses of Integer in java.util.spi

      Methods in java.util.spi that return types with arguments of type Integer
      Modifier and Type 方法 描述
      abstract Map<String,Integer> CalendarNameProvider.getDisplayNames​(String calendarType, int field, int style, Locale locale)
      返回 Map包含的所有字符串表示（显示名称） Calendar field给定 style和 locale及其相应的字段值。

    • Uses of Integer in java.util.stream

      Methods in java.util.stream that return types with arguments of type Integer
      Modifier and Type 方法 描述
      Stream<Integer> IntStream.boxed​()
      返回一个由这个流的元素组成的 Stream ，每个包装成一个 Integer 。
      static <T> Collector<T,?,Integer> Collectors.summingInt​(ToIntFunction<? super T> mapper)
      返回一个产生应用于输入元素的整数值函数之和的 Collector 。

    • Uses of Integer in javafx.beans.binding

      Methods in javafx.beans.binding that return Integer
      Modifier and Type | 方法 | 描述
      Integer | IntegerExpression.getValue​()
      Methods in javafx.beans.binding that return types with arguments of type Integer
      Modifier and Type 方法 描述
      ObjectExpression<Integer> IntegerExpression.asObject​()
      创建一个ObjectExpression ，其值为IntegerExpression 。
      Method parameters in javafx.beans.binding with type arguments of type Integer
      Modifier and Type 方法 描述
      static IntegerBinding Bindings.createIntegerBinding​(Callable<Integer> func, Observable... dependencies)
      助手功能创建自定义IntegerBinding 。

    • Uses of Integer in javafx.beans.property

      Methods in javafx.beans.property that return types with arguments of type Integer
      Modifier and Type 方法 描述
      ObjectProperty<Integer> IntegerProperty.asObject​()
      创建一个ObjectProperty是双向绑定到这个IntegerProperty 。
      ReadOnlyObjectProperty<Integer> ReadOnlyIntegerProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyIntegerProperty 。
      Method parameters in javafx.beans.property with type arguments of type Integer
      Modifier and Type 方法 描述
      static IntegerProperty IntegerProperty.integerProperty​(Property<Integer> property)
      返回一个IntegerProperty ，其中包含一个Property并双向绑定到它。

    • Uses of Integer in javafx.css

      Constructors in javafx.css with parameters of type Integer
      Constructor 描述
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。

    • Uses of Integer in javafx.scene.control

      Methods in javafx.scene.control that return types with arguments of type Integer
      Modifier and Type 方法 描述
      EventHandler<ScrollToEvent<Integer>> ListView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TableView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TreeTableView.getOnScrollTo​()
      获取属性onScrollTo的值。
      EventHandler<ScrollToEvent<Integer>> TreeView.getOnScrollTo​()
      获取属性onScrollTo的值。
      Callback<Integer,Node> Pagination.getPageFactory​()
      返回页面工厂回调函数。
      abstract ObservableList<Integer> MultipleSelectionModel.getSelectedIndices​()
      返回所有选定索引的 只读 ObservableList。
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> ListView.onScrollToProperty​()
      当有请求使用 ListView.scrollTo(int)或 ListView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TableView.onScrollToProperty​()
      当有请求使用 TableView.scrollTo(int)或 TableView.scrollTo(Object)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeTableView.onScrollToProperty​()
      当有请求使用 TreeTableView.scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<EventHandler<ScrollToEvent<Integer>>> TreeView.onScrollToProperty​()
      当有请求使用 TreeView.scrollTo(int)将索引滚动到视图时 调用
      ObjectProperty<Callback<Integer,Node>> Pagination.pageFactoryProperty​()
      当应用程序或用户选择页面时调用的pageFactory回调函数。
      static EventType<ScrollToEvent<Integer>> ScrollToEvent.scrollToTopIndex​()
      如果用户请求将给定索引滚动到视图中，则会发生此事件。
      Method parameters in javafx.scene.control with type arguments of type Integer
      Modifier and Type 方法 描述
      void ListView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TableView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TreeTableView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void TreeView.setOnScrollTo​(EventHandler<ScrollToEvent<Integer>> value)
      设置属性onScrollTo的值。
      void Pagination.setPageFactory​(Callback<Integer,Node> value)
      设置页面工厂回调函数。

    • Uses of Integer in javafx.scene.control.cell

      Methods in javafx.scene.control.cell that return types with arguments of type Integer
      Modifier and Type 方法 描述
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      Callback<Integer,ObservableValue<Boolean>> CheckBoxTreeTableCell.getSelectedStateCallback​()
      返回由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      ObjectProperty<Callback<Integer,ObservableValue<Boolean>>> CheckBoxTreeTableCell.selectedStateCallbackProperty​()
      属性表示由屏幕上显示的复选框绑定的Callback 。
      Method parameters in javafx.scene.control.cell with type arguments of type Integer
      Modifier and Type 方法 描述
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> CheckBoxTableCell.forTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, boolean showLabel)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> CheckBoxTreeTableCell.forTreeTableColumn​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个电池厂 ，用于TreeTableColumn电池厂 。
      void CheckBoxTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      void CheckBoxTreeTableCell.setSelectedStateCallback​(Callback<Integer,ObservableValue<Boolean>> value)
      设置由屏幕上显示的复选框绑定的Callback 。
      Constructor parameters in javafx.scene.control.cell with type arguments of type Integer
      Constructor 描述
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxTableCell与自定义Callback检索给定单元格索引的ObservableValue。
      CheckBoxTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      创建一个带有自定义字符串转换器的CheckBoxTableCell。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty)
      创建一个默认的CheckBoxTreeTableCell，使用自定义的Callback来检索给定单元格索引的ObservableValue。
      CheckBoxTreeTableCell​(Callback<Integer,ObservableValue<Boolean>> getSelectedProperty, StringConverter<T> converter)
      用自定义字符串转换器创建一个CheckBoxTreeTableCell。

    • Uses of Integer in javafx.scene.layout

      Methods in javafx.scene.layout that return Integer
      Modifier and Type 方法 描述
      static Integer GridPane.getColumnIndex​(Node child)
      如果设置，则返回小孩的列索引约束。
      static Integer GridPane.getColumnSpan​(Node child)
      如果设置，则返回小孩的列跨度约束。
      static Integer GridPane.getRowIndex​(Node child)
      如果设置，返回小孩的行索引约束。
      static Integer GridPane.getRowSpan​(Node child)
      如果设置，返回小孩的行跨限制。
      Methods in javafx.scene.layout with parameters of type Integer
      Modifier and Type 方法 描述
      static void GridPane.setColumnIndex​(Node child, Integer value)
      设置子窗格的列索引，当窗格包含时，它将从网格窗的该列开始定位。
      static void GridPane.setColumnSpan​(Node child, Integer value)
      设置子窗格包含的网格窗格的列跨度，以便它横跨该列数列。
      static void GridPane.setRowIndex​(Node child, Integer value)
      设置子窗格的行索引，当窗格包含时，它将从网格的该行开始定位。
      static void GridPane.setRowSpan​(Node child, Integer value)
      设置子窗格包含的格子行的行跨度，以便它垂直跨越该行数。

    • Uses of Integer in javafx.util.converter

      Methods in javafx.util.converter that return Integer
      Modifier and Type 方法 描述
      Integer IntegerStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Integer
      Modifier and Type 方法 描述
      String IntegerStringConverter.toString​(Integer value)
      将提供的对象转换为其字符串形式。

    • Uses of Integer in javax.imageio.plugins.tiff

      Methods in javax.imageio.plugins.tiff that return types with arguments of type Integer
      Modifier and Type 方法 描述
      SortedSet<Integer> TIFFTagSet.getTagNumbers​()
      检索一个不可修改的数字增加的标签号集合。

    • Uses of Integer in javax.management

      Methods in javax.management that return Integer
      Modifier and Type 方法 描述
      Integer MBeanServer.getMBeanCount​()
      返回在MBean服务器中注册的MBeans数。
      Integer MBeanServerConnection.getMBeanCount​()
      返回在MBean服务器中注册的MBeans数。

    • Uses of Integer in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Integer
      Modifier and Type Field 描述
      static SimpleType<Integer> SimpleType.INTEGER
      描述Java类名称为 java.lang.Integer值的 SimpleType实例。

    • Uses of Integer in javax.management.relation

      Methods in javax.management.relation that return Integer
      Modifier and Type 方法 描述
      Integer RelationService.checkRoleReading​(String roleName, String relationTypeName)
      检查给定角色是否可以以给定类型的关系读取。
      Integer RelationServiceMBean.checkRoleReading​(String roleName, String relationTypeName)
      检查给定角色是否可以以给定类型的关系读取。
      Integer RelationService.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)
      检查给定的角色是否可以按给定类型的关系进行设置。
      Integer RelationServiceMBean.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)
      检查给定的角色是否可以按给定类型的关系进行设置。
      Integer Relation.getRoleCardinality​(String roleName)
      返回当前在给定角色中引用的MBean数。
      Integer RelationService.getRoleCardinality​(String relationId, String roleName)
      检索当前在给定角色中引用的MBeans数。
      Integer RelationServiceMBean.getRoleCardinality​(String relationId, String roleName)
      检索当前在给定角色中引用的MBeans数。
      Integer RelationSupport.getRoleCardinality​(String roleName)
      返回当前在给定角色中引用的MBean数。

    • Uses of Integer in javax.management.remote

      Methods in javax.management.remote that return Integer
      Modifier and Type 方法 描述
      Integer TargetedNotification.getListenerID​()
      通知所针对的侦听器的ID。
      Constructors in javax.management.remote with parameters of type Integer
      Constructor 描述
      TargetedNotification​(Notification notification, Integer listenerID)
      构造一个 TargetedNotification对象。

    • Uses of Integer in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return Integer
      Modifier and Type | 方法 | 描述
      Integer[] RMIConnection.addNotificationListeners​(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      处理方法 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 。
      Integer[] | RMIConnectionImpl_Stub.addNotificationListeners​(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
      Integer[] | RMIConnectionImpl.addNotificationListeners​(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      Integer RMIConnection.getMBeanCount​(Subject delegationSubject)
      处理方法 MBeanServerConnection.getMBeanCount() 。
      Integer | RMIConnectionImpl_Stub.getMBeanCount​(Subject $param_Subject_1)
      Integer | RMIConnectionImpl.getMBeanCount​(Subject delegationSubject)
      Methods in javax.management.remote.rmi with parameters of type Integer
      Modifier and Type | 方法 | 描述
      void RMIConnection.removeNotificationListeners​(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      处理 removeNotificationListener(ObjectName, NotificationListener)和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)方法。
      void | RMIConnectionImpl_Stub.removeNotificationListeners​(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.removeNotificationListeners​(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)

    • Uses of Integer in javax.management.timer

      Methods in javax.management.timer that return Integer
      Modifier and Type 方法 描述
      Integer Timer.addNotification​(String type, String message, Object userData, Date date)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。
      Integer TimerNotification.getNotificationID​()
      获取此定时器通知的标识符。
      Methods in javax.management.timer that return types with arguments of type Integer
      Modifier and Type 方法 描述
      Vector<Integer> Timer.getAllNotificationIDs​()
      获取注册到通知列表中的所有定时器通知标识符。
      Vector<Integer> TimerMBean.getAllNotificationIDs​()
      获取注册到通知列表中的所有定时器通知标识符。
      Vector<Integer> Timer.getNotificationIDs​(String type)
      获取与指定类型相对应的定时器通知的所有标识符。
      Vector<Integer> TimerMBean.getNotificationIDs​(String type)
      获取与指定类型相对应的定时器通知的所有标识符。
      Methods in javax.management.timer with parameters of type Integer
      Modifier and Type 方法 描述
      Date Timer.getDate​(Integer id)
      获取与定时器通知相关联的日期的副本。
      Date TimerMBean.getDate​(Integer id)
      获取与定时器通知相关联的日期的副本。
      Boolean Timer.getFixedRate​(Integer id)
      获取标志的副本，指示是定期通知是以 固定延迟还是 固定速率执行 。
      Boolean TimerMBean.getFixedRate​(Integer id)
      获取标志的副本，指示是定期通知是以 固定延迟还是 固定速率执行 。
      Long Timer.getNbOccurences​(Integer id)
      获取与定时器通知相关联的剩余发生次数的副本。
      Long TimerMBean.getNbOccurences​(Integer id)
      获取与定时器通知相关联的剩余发生次数的副本。
      String Timer.getNotificationMessage​(Integer id)
      获取与指定标识符相对应的定时器通知详细消息。
      String TimerMBean.getNotificationMessage​(Integer id)
      获取与指定标识符相对应的定时器通知详细消息。
      String Timer.getNotificationType​(Integer id)
      获取与指定标识符对应的定时器通知类型。
      String TimerMBean.getNotificationType​(Integer id)
      获取与指定标识符对应的定时器通知类型。
      Object Timer.getNotificationUserData​(Integer id)
      获取与指定标识符相对应的定时器通知用户数据对象。
      Object TimerMBean.getNotificationUserData​(Integer id)
      获取与指定标识符相对应的定时器通知用户数据对象。
      Long Timer.getPeriod​(Integer id)
      获取与定时器通知相关联的周期（以毫秒为单位）的副本。
      Long TimerMBean.getPeriod​(Integer id)
      获取与定时器通知相关联的周期（以毫秒为单位）的副本。
      void Timer.removeNotification​(Integer id)
      从通知列表中删除与指定标识符相对应的定时器通知。
      void TimerMBean.removeNotification​(Integer id)
      从通知列表中删除与指定标识符相对应的定时器通知。
      Constructors in javax.management.timer with parameters of type Integer
      Constructor 描述
      TimerNotification​(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
      创建定时器通知对象。

    • Uses of Integer in javax.script

      Methods in javax.script that return types with arguments of type Integer
      Modifier and Type 方法 描述
      List<Integer> ScriptContext.getScopes​()
      在ScriptContext中为范围的所有有效值返回不可变的 List 。
      List<Integer> SimpleScriptContext.getScopes​()
      返回不可变的 List ScriptContext中范围的所有有效值。

    • Uses of Integer in javax.swing

      Fields in javax.swing declared as Integer
      Modifier and Type Field 描述
      static Integer JLayeredPane.DEFAULT_LAYER
      定义默认图层的便利对象。
      static Integer JLayeredPane.DRAG_LAYER
      定义拖动图层的便利对象。
      static Integer JLayeredPane.FRAME_CONTENT_LAYER
      定义框架内容层的便利对象。
      static Integer JLayeredPane.MODAL_LAYER
      定义模态层的便利对象。
      static Integer JLayeredPane.PALETTE_LAYER
      定义调色板层的方便对象。
      static Integer JLayeredPane.POPUP_LAYER
      定义Popup图层的便利对象。
      Methods in javax.swing that return Integer
      Modifier and Type 方法 描述
      protected Integer JLayeredPane.getObjectForLayer​(int layer)
      返回与指定图层相关联的整数对象。
      Methods in javax.swing that return types with arguments of type Integer
      Modifier and Type 方法 描述
      Hashtable<Integer,JComponent> JSlider.createStandardLabels​(int increment)
      创建一个 Hashtable的数字文本标签，从最小滑块开始，并使用指定的增量。
      Hashtable<Integer,JComponent> JSlider.createStandardLabels​(int increment, int start)
      创建一个 Hashtable的数字文本标签，从指定的起始点开始，并使用指定的增量。
      protected Hashtable<Component,Integer> JLayeredPane.getComponentToLayer​()
      返回将组件映射到图层的散列表。
      Methods in javax.swing with parameters of type Integer
      Modifier and Type 方法 描述
      void JInternalFrame.setLayer​(Integer layer)
      设置此组件的图层属性的便利方法。

    • Uses of Integer in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return Integer
      Modifier and Type 方法 描述
      protected Integer BasicSliderUI.getHighestValue​()
      返回标签表中有一个条目的最大值。
      protected Integer BasicSliderUI.getLowestValue​()
      返回标签表中具有条目的最小值。

    • Uses of Integer in jdk.jshell

      Method parameters in jdk.jshell with type arguments of type Integer
      Modifier and Type 方法 描述
      JShell.Builder JShell.Builder.idGenerator​(BiFunction<Snippet,Integer,String> generator)
      设置代码段识别名称的生成器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.InternalError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.InternalError

  • Packages that use InternalError
    软件包 描述
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of InternalError in java.util.zip

      Subclasses of InternalError in java.util.zip
      Modifier and Type Class 描述
      class  ZipError
      表示发生了不可恢复的错误。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.InterruptedException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.InterruptedException

  • Packages that use InterruptedException
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.image
    提供创建和修改图像的类。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of InterruptedException in com.sun.jdi.event

      Methods in com.sun.jdi.event that throw InterruptedException
      Modifier and Type 方法 描述
      EventSet EventQueue.remove​()
      等待下一个可用的事件永远。
      EventSet EventQueue.remove​(long timeout)
      等待下一个可用事件的指定时间。

    • Uses of InterruptedException in java.awt

      Methods in java.awt that throw InterruptedException
      Modifier and Type 方法 描述
      AWTEvent EventQueue.getNextEvent​()
      从 EventQueue删除事件并返回。
      static void EventQueue.invokeAndWait​(Runnable runnable)
      导致 runnable在 dispatch thread的 dispatch thread中调用其 run方法。
      void MediaTracker.waitForAll​()
      开始加载此媒体跟踪器跟踪的所有图像。
      boolean MediaTracker.waitForAll​(long ms)
      开始加载此媒体跟踪器跟踪的所有图像。
      void MediaTracker.waitForID​(int id)
      开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。
      boolean MediaTracker.waitForID​(int id, long ms)
      开始使用指定的标识符加载由此媒体跟踪器跟踪的所有图像。

    • Uses of InterruptedException in java.awt.image

      Methods in java.awt.image that throw InterruptedException
      Modifier and Type 方法 描述
      boolean PixelGrabber.grabPixels​()
      请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送。
      boolean PixelGrabber.grabPixels​(long ms)
      请求Image或ImageProducer开始传送像素，并等待感兴趣的矩形中的所有像素被传送，或者直到指定的超时过去。

    • Uses of InterruptedException in java.lang

      Methods in java.lang that throw InterruptedException
      Modifier and Type 方法 描述
      void Thread.join​()
      等待这个线程死亡。
      void Thread.join​(long millis)
      等待这个线程死亡 millis毫秒。
      void Thread.join​(long millis, int nanos)
      等待最多 millis毫秒加上这个线程死亡的 nanos纳秒。
      static void Thread.sleep​(long millis)
      使当前正在执行的线程停留（暂停执行）指定的毫秒数，这取决于系统定时器和调度程序的精度和准确性。
      static void Thread.sleep​(long millis, int nanos)
      导致正在执行的线程以指定的毫秒数加上指定的纳秒数来暂停（临时停止执行），这取决于系统定时器和调度器的精度和准确性。
      void Object.wait​()
      导致当前线程等待，直到另一个线程调用此对象的 Object.notify()方法或 Object.notifyAll()方法。
      void Object.wait​(long timeout)
      导致当前线程等待，直到另一个线程调用此对象的 Object.notify()方法或 Object.notifyAll()方法，或指定的时间已过。
      void Object.wait​(long timeout, int nanos)
      导致当前线程等待，直到另一个线程调用此对象的 Object.notify()方法或 Object.notifyAll()方法，或其他一些线程中断当前线程或一定量的实时时间。
      abstract int Process.waitFor​()
      使当前线程等待，如有必要，直到此 Process对象表示的进程已终止。
      boolean Process.waitFor​(long timeout, TimeUnit unit)
      导致当前线程等待，如有必要，直到由此 Process对象表示的进程已终止，或指定的等待时间过去。

    • Uses of InterruptedException in java.lang.ref

      Methods in java.lang.ref that throw InterruptedException
      Modifier and Type 方法 描述
      Reference<? extends T> ReferenceQueue.remove​()
      删除此队列中的下一个参考对象，阻塞直到可用。
      Reference<? extends T> ReferenceQueue.remove​(long timeout)
      删除此队列中的下一个参考对象，阻塞，直到任何一个可用或给定的超时期限到期。

    • Uses of InterruptedException in java.nio.channels

      Methods in java.nio.channels that throw InterruptedException
      Modifier and Type 方法 描述
      abstract boolean AsynchronousChannelGroup.awaitTermination​(long timeout, TimeUnit unit)
      等待该组终止。

    • Uses of InterruptedException in java.nio.file

      Methods in java.nio.file that throw InterruptedException
      Modifier and Type 方法 描述
      WatchKey WatchService.poll​(long timeout, TimeUnit unit)
      检索并删除下一个watch键，如果还没有，则等待必要时直到指定的等待时间。
      WatchKey WatchService.take​()
      检索并删除下一个Watch键，等待是否还没有。

    • Uses of InterruptedException in java.util.concurrent

      Methods in java.util.concurrent that throw InterruptedException
      Modifier and Type | 方法 | 描述
      void Semaphore.acquire​()
      从此信号量获取许可证，阻止直到可用，或线程为 interrupted 。
      void Semaphore.acquire​(int permits)
      从该信号量获取给定数量的许可证，阻止直到所有可用，或线程为 interrupted 。
      void CountDownLatch.await​()
      使当前线程等待直到锁存器向下计数为零，除非线程为 interrupted 。
      boolean CountDownLatch.await​(long timeout, TimeUnit unit)
      使当前线程等待直到锁存器计数到零为止，除非线程为 interrupted ，否则等待指定的等待时间。
      int CyclicBarrier.await​()
      等待，直到所有的 parties已经在这个障碍上调用了 await 。
      int CyclicBarrier.await​(long timeout, TimeUnit unit)
      等待直到所有 parties已经在此屏障上调用了 await ，或者指定的等待时间 await 。
      int Phaser.awaitAdvanceInterruptibly​(int phase)
      等待相移器的相位从给定的相位值推进，抛出 InterruptedException如果在等待时中断，或者如果当前相位不等于给定的相位值，则立即返回，否则该移相器被终止。
      int Phaser.awaitAdvanceInterruptibly​(int phase, long timeout, TimeUnit unit)
      等待该移相器的阶段从给定的相位值或给定的超时 InterruptedException到等待时抛出 InterruptedException ，或者如果当前相位不等于给定的相位值，则立即返回，否则该相位器被终止。
      boolean ExecutorService.awaitTermination​(long timeout, TimeUnit unit)
      阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
      boolean ForkJoinPool.awaitTermination​(long timeout, TimeUnit unit)
      阻止所有任务在关闭请求完成后执行，或发生超时或当前线程中断，以先到者为准。
      boolean | ThreadPoolExecutor.awaitTermination​(long timeout, TimeUnit unit)
      boolean ForkJoinPool.ManagedBlocker.block​()
      可能阻止当前线程，例如等待锁或条件。
      V Exchanger.exchange​(V x)
      等待另一个线程到达此交换点（除非当前线程为 interrupted ），然后将给定对象传输给它，接收其对象作为回报。
      V Exchanger.exchange​(V x, long timeout, TimeUnit unit)
      等待另一个线程到达此交换点（除非当前线程为 interrupted或指定的等待时间过去），然后将给定的对象传输给它，接收其对象作为回报。
      T CompletableFuture.get​()
      等待这个未来完成的必要，然后返回结果。
      T CompletableFuture.get​(long timeout, TimeUnit unit)
      如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。
      V ForkJoinTask.get​()
      等待计算完成，然后检索其结果。
      V ForkJoinTask.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V Future.get​()
      等待计算完成，然后检索其结果。
      V Future.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      V | FutureTask.get​()
      V | FutureTask.get​(long timeout, TimeUnit unit)
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      <T> List<Future<T>> | AbstractExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回持有他们的状态和结果的所有完成的期货列表。
      <T> List<Future<T>> ExecutorService.invokeAll​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回在所有完成或超时到期时持有其状态和结果的期货列表，以先发生者为准。
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      <T> T | AbstractExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks)
      执行给定的任务，返回成功完成的结果（即，不抛出异常），如果有的话。
      <T> T ExecutorService.invokeAny​(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
      执行给定的任务，返回一个已经成功完成的结果（即，不抛出异常），如果在给定的时间超过之前有的话。
      static void ForkJoinPool.managedBlock​(ForkJoinPool.ManagedBlocker blocker)
      运行给定的可能的阻止任务。
      boolean ArrayBlockingQueue.offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素，等待指定的等待时间，以使空间在队列已满时变为可用。
      boolean BlockingDeque.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入由此deque表示的队列中（换句话说，在该deque的尾部），等待指定的等待时间（如果需要空间可用）。
      boolean BlockingQueue.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此队列中，等待指定的等待时间（如有必要）才能使空间变得可用。
      boolean | LinkedBlockingDeque.offer​(E e, long timeout, TimeUnit unit)
      boolean LinkedBlockingQueue.offer​(E e, long timeout, TimeUnit unit)
      在该队列的尾部插入指定的元素，必要时等待指定的等待时间才能使空间变得可用。
      boolean SynchronousQueue.offer​(E e, long timeout, TimeUnit unit)
      将指定的元素插入到此队列中，如果需要，等待另一个线程接收到的指定等待时间。
      boolean BlockingDeque.offerFirst​(E e, long timeout, TimeUnit unit)
      在此deque的前面插入指定的元素，等待指定的等待时间（如果需要空间可用）。
      boolean | LinkedBlockingDeque.offerFirst​(E e, long timeout, TimeUnit unit)
      boolean BlockingDeque.offerLast​(E e, long timeout, TimeUnit unit)
      在此deque的末尾插入指定的元素，如果需要空间可用，等待指定的等待时间。
      boolean | LinkedBlockingDeque.offerLast​(E e, long timeout, TimeUnit unit)
      E | ArrayBlockingQueue.poll​(long timeout, TimeUnit unit)
      E BlockingDeque.poll​(long timeout, TimeUnit unit)
      检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，等待到指定的等待时间（如有必要）使元素变为可用。
      E BlockingQueue.poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，等待指定的等待时间（如有必要）使元素变为可用。
      Future<V> CompletionService.poll​(long timeout, TimeUnit unit)
      检索并删除表示下一个完成的任务的未来，如果还没有，则等待必要时直到指定的等待时间。
      E DelayQueue.poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头部，如果需要，等待具有到期延迟的元素可用于此队列，或指定的等待时间到期。
      Future<V> | ExecutorCompletionService.poll​(long timeout, TimeUnit unit)
      E | LinkedBlockingDeque.poll​(long timeout, TimeUnit unit)
      E | LinkedBlockingQueue.poll​(long timeout, TimeUnit unit)
      E | LinkedTransferQueue.poll​(long timeout, TimeUnit unit)
      E | PriorityBlockingQueue.poll​(long timeout, TimeUnit unit)
      E SynchronousQueue.poll​(long timeout, TimeUnit unit)
      检索并删除此队列的头，如果需要等待指定的等待时间，另一个线程插入它。
      E BlockingDeque.pollFirst​(long timeout, TimeUnit unit)
      检索并删除此deque的第一个元素，等待到指定的等待时间（如有必要）使元素变为可用。
      E | LinkedBlockingDeque.pollFirst​(long timeout, TimeUnit unit)
      E BlockingDeque.pollLast​(long timeout, TimeUnit unit)
      检索并删除此deque的最后一个元素，等待到指定的等待时间，如果需要，元素可用。
      E | LinkedBlockingDeque.pollLast​(long timeout, TimeUnit unit)
      void ArrayBlockingQueue.put​(E e)
      在该队列的尾部插入指定的元素，如果队列已满，则等待空间变为可用。
      void BlockingDeque.put​(E e)
      将指定的元素插入由此deque表示的队列（换句话说，在该deque的尾部），等待空格变为可用时。
      void BlockingQueue.put​(E e)
      将指定的元素插入到此队列中，等待空格可用。
      void | LinkedBlockingDeque.put​(E e)
      void LinkedBlockingQueue.put​(E e)
      在该队列的尾部插入指定的元素，如果需要，等待空格变为可用。
      void SynchronousQueue.put​(E e)
      将指定的元素添加到此队列，等待另一个线程接收它。
      void BlockingDeque.putFirst​(E e)
      在此deque的前面插入指定的元素，如有必要，等待空格变为可用。
      void | LinkedBlockingDeque.putFirst​(E e)
      void BlockingDeque.putLast​(E e)
      在此deque的末尾插入指定的元素，如有必要，等待空格变为可用。
      void | LinkedBlockingDeque.putLast​(E e)
      void TimeUnit.sleep​(long timeout)
      使用此时间单位执行 Thread.sleep 。
      E | ArrayBlockingQueue.take​()
      E BlockingDeque.take​()
      检索并删除由此deque（换句话说，该deque的第一个元素）表示的队列的头部，如果需要，等待，直到元素可用。
      E BlockingQueue.take​()
      检索并删除此队列的头，如有必要，等待元素可用。
      Future<V> CompletionService.take​()
      检索并删除代表下一个完成任务的未来，等待是否还没有任务。
      E DelayQueue.take​()
      检索并删除此队列的头部，如果需要，等待有一个延迟到期的元素在此队列上可用。
      Future<V> | ExecutorCompletionService.take​()
      E | LinkedBlockingDeque.take​()
      E | LinkedBlockingQueue.take​()
      E | LinkedTransferQueue.take​()
      E | PriorityBlockingQueue.take​()
      E SynchronousQueue.take​()
      检索并删除此队列的头，等待另一个线程插入它。
      E BlockingDeque.takeFirst​()
      检索并删除此deque的第一个元素，如有必要等待，直到元素可用。
      E | LinkedBlockingDeque.takeFirst​()
      E BlockingDeque.takeLast​()
      检索并删除此deque的最后一个元素，如有必要等待，直到元素可用。
      E | LinkedBlockingDeque.takeLast​()
      void TimeUnit.timedJoin​(Thread thread, long timeout)
      使用此时间单位执行定时 Thread.join 。
      void TimeUnit.timedWait​(Object obj, long timeout)
      使用此时间单位执行定时 Object.wait 。
      void LinkedTransferQueue.transfer​(E e)
      将元素转移给消费者，如有必要，等待。
      void TransferQueue.transfer​(E e)
      将元素转移给消费者，如有必要，等待。
      boolean Semaphore.tryAcquire​(int permits, long timeout, TimeUnit unit)
      如果在给定的等待时间内全部可用，并且当前线程尚未 到达interrupted ，则从该信号量获取给定数量的许可证。
      boolean Semaphore.tryAcquire​(long timeout, TimeUnit unit)
      如果在给定的等待时间内可用，并且当前线程尚未 到达interrupted ，则从该信号量获取许可。
      boolean LinkedTransferQueue.tryTransfer​(E e, long timeout, TimeUnit unit)
      如果可以在超时过程之前将元素传送给消费者。
      boolean TransferQueue.tryTransfer​(E e, long timeout, TimeUnit unit)
      如果可以在超时过程之前将元素传送给消费者。

    • Uses of InterruptedException in java.util.concurrent.locks

      Methods in java.util.concurrent.locks that throw InterruptedException
      Modifier and Type 方法 描述
      void AbstractQueuedLongSynchronizer.acquireInterruptibly​(long arg)
      以独占方式获得，如果中断，中止。
      void AbstractQueuedSynchronizer.acquireInterruptibly​(int arg)
      以独占方式获得，如果中断，中止。
      void AbstractQueuedLongSynchronizer.acquireSharedInterruptibly​(long arg)
      以共享方式获取，如果中断，中止。
      void AbstractQueuedSynchronizer.acquireSharedInterruptibly​(int arg)
      以共享方式获取，如果中断，中止。
      void AbstractQueuedLongSynchronizer.ConditionObject.await​()
      实现可中断条件等待。
      boolean AbstractQueuedLongSynchronizer.ConditionObject.await​(long time, TimeUnit unit)
      实现定时状态等待。
      void AbstractQueuedSynchronizer.ConditionObject.await​()
      实现可中断条件等待。
      boolean AbstractQueuedSynchronizer.ConditionObject.await​(long time, TimeUnit unit)
      实现定时状态等待。
      void Condition.await​()
      导致当前线程等到发信号或 interrupted 。
      boolean Condition.await​(long time, TimeUnit unit)
      使当前线程等待直到发出信号或中断，或指定的等待时间过去。
      long AbstractQueuedLongSynchronizer.ConditionObject.awaitNanos​(long nanosTimeout)
      实现定时状态等待。
      long AbstractQueuedSynchronizer.ConditionObject.awaitNanos​(long nanosTimeout)
      实现定时状态等待。
      long Condition.awaitNanos​(long nanosTimeout)
      使当前线程等待直到发出信号或中断，或指定的等待时间过去。
      boolean AbstractQueuedLongSynchronizer.ConditionObject.awaitUntil​(Date deadline)
      实现绝对定时条件等待。
      boolean AbstractQueuedSynchronizer.ConditionObject.awaitUntil​(Date deadline)
      实现绝对定时条件等待。
      boolean Condition.awaitUntil​(Date deadline)
      使当前线程等待直到发出信号或中断，或者指定的最后期限过去。
      void Lock.lockInterruptibly​()
      获取锁定，除非当前线程是 interrupted 。
      void ReentrantLock.lockInterruptibly​()
      获取锁定，除非当前线程是 interrupted 。
      void ReentrantReadWriteLock.ReadLock.lockInterruptibly​()
      获取读锁定，除非当前线程为 interrupted 。
      void ReentrantReadWriteLock.WriteLock.lockInterruptibly​()
      获取写锁定，除非当前线程是 interrupted 。
      long StampedLock.readLockInterruptibly​()
      非排他性地获取锁定，如有必要，阻塞，直到可用或当前线程中断。
      boolean AbstractQueuedLongSynchronizer.tryAcquireNanos​(long arg, long nanosTimeout)
      尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。
      boolean AbstractQueuedSynchronizer.tryAcquireNanos​(int arg, long nanosTimeout)
      尝试以独占模式获取，如果中断则中止，如果给定的超时时间失败。
      boolean AbstractQueuedLongSynchronizer.tryAcquireSharedNanos​(long arg, long nanosTimeout)
      尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。
      boolean AbstractQueuedSynchronizer.tryAcquireSharedNanos​(int arg, long nanosTimeout)
      尝试以共享模式获取，如果中断则中止，如果给定的时间超过，则失败。
      boolean Lock.tryLock​(long time, TimeUnit unit)
      如果在给定的等待时间内自由，并且当前线程尚未被 interrupted获取该锁。
      boolean ReentrantLock.tryLock​(long timeout, TimeUnit unit)
      如果在给定的等待时间内没有被另一个线程 占用 ，并且当前线程尚未被 interrupted ，则获取该锁。
      boolean ReentrantReadWriteLock.ReadLock.tryLock​(long timeout, TimeUnit unit)
      如果写锁定在给定等待时间内未被另一个线程 占用并且当前线程尚未被 interrupted获取读取锁定。
      boolean ReentrantReadWriteLock.WriteLock.tryLock​(long timeout, TimeUnit unit)
      如果在给定的等待时间内没有被另一个线程 占用 ，并且当前线程尚未被 interrupted获取写入锁定。
      long StampedLock.tryReadLock​(long time, TimeUnit unit)
      如果在给定时间内可用，并且当前线程未被中断，则非排他性地获取锁。
      long StampedLock.tryWriteLock​(long time, TimeUnit unit)
      如果在给定时间内可用，并且当前线程未被中断，则专门获取该锁。
      long StampedLock.writeLockInterruptibly​()
      专门获取锁定，如有必要，阻塞，直到可用或当前线程中断。

    • Uses of InterruptedException in javax.swing

      Methods in javax.swing that throw InterruptedException
      Modifier and Type 方法 描述
      T SwingWorker.get​()
      等待计算完成，然后检索其结果。
      T SwingWorker.get​(long timeout, TimeUnit unit)
      如果需要等待最多在给定的时间计算完成，然后检索其结果（如果可用）。
      static void SwingUtilities.invokeAndWait​(Runnable doRun)
      导致在AWT事件调度线程上同步执行 doRun.run() 。

    • Uses of InterruptedException in jdk.incubator.http

      Methods in jdk.incubator.http that throw InterruptedException
      Modifier and Type 方法 描述
      abstract <T> HttpResponse<T> HttpClient.send​(HttpRequest req, HttpResponse.BodyHandler<T> responseBodyHandler)
      Sends the given request using this client, blocking if necessary to get the response.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.LayerInstantiationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.LayerInstantiationException

No usage of java.lang.LayerInstantiationException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.LinkageError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.LinkageError

  • Packages that use LinkageError
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of LinkageError in java.lang

      Subclasses of LinkageError in java.lang
      Modifier and Type Class 描述
      class  AbstractMethodError
      当应用程序尝试调用抽象方法时抛出。
      class  BootstrapMethodError
      抛出以表示invokedynamic指令未能找到其引导方法，或引导方法未能提供call site的target为正确的method type 。
      class  ClassCircularityError
      当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。
      class  ClassFormatError
      当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
      class  ExceptionInInitializerError
      表示在静态初始化程序中发生意外异常。
      class  IllegalAccessError
      如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。
      class  IncompatibleClassChangeError
      当一些类定义发生不兼容的类更改时抛出。
      class  InstantiationError
      当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。
      class  NoClassDefFoundError
      如果Java虚拟机或 ClassLoader实例尝试加载类的定义（作为普通方法调用的一部分或作为使用 new表达式创建新实例的 new ），则 new此 new并且不会找到该类的定义。
      class  NoSuchFieldError
      如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。
      class  NoSuchMethodError
      如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。
      class  UnsatisfiedLinkError
      如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。
      class  UnsupportedClassVersionError
      当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
      class  VerifyError
      当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。

    • Uses of LinkageError in java.lang.reflect

      Subclasses of LinkageError in java.lang.reflect
      Modifier and Type Class 描述
      class  GenericSignatureFormatError
      当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Long (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Long

  • Packages that use Long
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.beans.binding
    提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及许多实现。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.timer
    提供定时器MBean的定义。

    • Uses of Long in java.lang

      Fields in java.lang with type parameters of type Long
      Modifier and Type Field 描述
      static Class<Long> Long.TYPE
      Class表示原始类型 long实例。
      Methods in java.lang that return Long
      Modifier and Type 方法 描述
      static Long Long.decode​(String nm)
      将 String解码为 Long 。
      static Long Long.getLong​(String nm)
      确定具有指定名称的系统属性的值为 long 。
      static Long Long.getLong​(String nm, long val)
      确定具有指定名称的系统属性的值为 long 。
      static Long Long.getLong​(String nm, Long val)
      返回具有指定名称的系统属性的 long值。
      static Long Long.valueOf​(long l)
      返回一个表示 long值的 Long实例。
      static Long Long.valueOf​(String s)
      返回一个 Long对象，保存指定的值为 String 。
      static Long Long.valueOf​(String s, int radix)
      返回一个 Long对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
      Methods in java.lang with parameters of type Long
      Modifier and Type 方法 描述
      int Long.compareTo​(Long anotherLong)
      以数字方式比较两个 Long对象。
      static Long Long.getLong​(String nm, Long val)
      返回具有指定名称的系统属性的 long值。

    • Uses of Long in java.nio.channels

      Method parameters in java.nio.channels with type arguments of type Long
      Modifier and Type 方法 描述
      abstract <A> void AsynchronousSocketChannel.read​(ByteBuffer[] dsts, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从该通道读取字节序列到给定缓冲区的子序列中。
      abstract <A> void AsynchronousSocketChannel.write​(ByteBuffer[] srcs, int offset, int length, long timeout, TimeUnit unit, A attachment, CompletionHandler<Long,? super A> handler)
      从给定缓冲区的子序列将一个字节序列写入该通道。

    • Uses of Long in java.time.chrono

      Method parameters in java.time.chrono with type arguments of type Long
      Modifier and Type | 方法 | 描述
      ChronoLocalDate AbstractChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的 ChronoField值到一个日期。
      ChronoLocalDate Chronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析 ChronoField值到一个日期。
      HijrahDate | HijrahChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      LocalDate IsoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      解析解析中的日期为 ChronoField 。
      JapaneseDate | JapaneseChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      MinguoDate | MinguoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)
      ThaiBuddhistDate | ThaiBuddhistChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

    • Uses of Long in java.time.format

      Method parameters in java.time.format with type arguments of type Long
      Modifier and Type 方法 描述
      DateTimeFormatterBuilder DateTimeFormatterBuilder.appendText​(TemporalField field, Map<Long,String> textLookup)
      使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。

    • Uses of Long in java.time.temporal

      Method parameters in java.time.temporal with type arguments of type Long
      Modifier and Type 方法 描述
      default TemporalAccessor TemporalField.resolve​(Map<TemporalField,Long> fieldValues, TemporalAccessor partialTemporal, ResolverStyle resolverStyle)
      解决此字段以提供更简单的替代或日期。

    • Uses of Long in java.util

      Methods in java.util that return Long
      Modifier and Type 方法 描述
      default Long PrimitiveIterator.OfLong.next​()
      返回迭代中的下一个元素。
      Method parameters in java.util with type arguments of type Long
      Modifier and Type 方法 描述
      default void PrimitiveIterator.OfLong.forEachRemaining​(Consumer<? super Long> action)
      对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。
      default void Spliterator.OfLong.forEachRemaining​(Consumer<? super Long> action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      default boolean Spliterator.OfLong.tryAdvance​(Consumer<? super Long> action)
      如果剩余的元素存在，执行给定的操作，返回true ; 否则返回false 。

    • Uses of Long in java.util.stream

      Methods in java.util.stream that return types with arguments of type Long
      Modifier and Type 方法 描述
      Stream<Long> LongStream.boxed​()
      返回一个由这个流的元素组成的 Stream ，每个都包含一个 Long 。
      static <T> Collector<T,?,Long> Collectors.counting​()
      返回 Collector类型的接受元件 T计数输入元件的数量。
      static <T> Collector<T,?,Long> Collectors.summingLong​(ToLongFunction<? super T> mapper)
      返回一个产生应用于输入元素的长值函数的和的 Collector 。

    • Uses of Long in javafx.beans.binding

      Methods in javafx.beans.binding that return Long
      Modifier and Type | 方法 | 描述
      Long | LongExpression.getValue​()
      Methods in javafx.beans.binding that return types with arguments of type Long
      Modifier and Type 方法 描述
      ObjectExpression<Long> LongExpression.asObject​()
      创建一个ObjectExpression ，其值为LongExpression 。
      Method parameters in javafx.beans.binding with type arguments of type Long
      Modifier and Type 方法 描述
      static LongBinding Bindings.createLongBinding​(Callable<Long> func, Observable... dependencies)
      助手功能创建自定义LongBinding 。

    • Uses of Long in javafx.beans.property

      Methods in javafx.beans.property that return types with arguments of type Long
      Modifier and Type 方法 描述
      ObjectProperty<Long> LongProperty.asObject​()
      创建一个ObjectProperty双向绑定到这个LongProperty 。
      ReadOnlyObjectProperty<Long> ReadOnlyLongProperty.asObject​()
      创建一个ReadOnlyObjectProperty ，其值为ReadOnlyLongProperty 。
      Method parameters in javafx.beans.property with type arguments of type Long
      Modifier and Type 方法 描述
      static LongProperty LongProperty.longProperty​(Property<Long> property)
      返回一个LongProperty ，其中包含一个Property并且双向绑定到它。

    • Uses of Long in javafx.css

      Constructors in javafx.css with parameters of type Long
      Constructor 描述
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。

    • Uses of Long in javafx.util.converter

      Methods in javafx.util.converter that return Long
      Modifier and Type 方法 描述
      Long LongStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Long
      Modifier and Type 方法 描述
      String LongStringConverter.toString​(Long value)
      将提供的对象转换为其字符串形式。

    • Uses of Long in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Long
      Modifier and Type Field 描述
      static SimpleType<Long> SimpleType.LONG
      描述Java类名称为 java.lang.Long值的 SimpleType实例。

    • Uses of Long in javax.management.timer

      Methods in javax.management.timer that return Long
      Modifier and Type 方法 描述
      Long Timer.getNbOccurences​(Integer id)
      获取与定时器通知相关联的剩余发生次数的副本。
      Long TimerMBean.getNbOccurences​(Integer id)
      获取与定时器通知相关联的剩余发生次数的副本。
      Long Timer.getPeriod​(Integer id)
      获取与定时器通知相关联的周期（以毫秒为单位）的副本。
      Long TimerMBean.getPeriod​(Integer id)
      获取与定时器通知相关联的周期（以毫秒为单位）的副本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Math (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Math

No usage of java.lang.Math
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Module (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Module

  • Packages that use Module
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Module in java.lang

      Methods in java.lang that return Module
      Modifier and Type 方法 描述
      Module Module.addExports​(String pn, Module other)
      如果调用者的模块是此模块，则更新此模块以将给定的包导出到给定的模块。
      Module Module.addOpens​(String pn, Module other)
      如果该模块已经至少 打开了一个包到调用者模块，然后更新该模块以将包打开到给定的模块。
      Module Module.addReads​(Module other)
      如果调用者的模块是该模块，则更新该模块以读取给定的模块。
      Module Module.addUses​(Class<?> service)
      如果调用者模块是此模块，则更新此模块以添加对给定服务类型的服务依赖。
      Module Class.getModule​()
      返回此类或接口所属的模块。
      Module ClassLoader.getUnnamedModule​()
      返回此类加载器的未命名的 Module 。
      Methods in java.lang that return types with arguments of type Module
      Modifier and Type 方法 描述
      Optional<Module> ModuleLayer.findModule​(String name)
      在此层中返回具有给定名称的模块，或者如果不在此层中，则 返回parent层。
      Set<Module> ModuleLayer.modules​()
      返回此图层中的模块集。
      Methods in java.lang with parameters of type Module
      Modifier and Type 方法 描述
      Module Module.addExports​(String pn, Module other)
      如果调用者的模块是此模块，则更新此模块以将给定的包导出到给定的模块。
      ModuleLayer.Controller ModuleLayer.Controller.addExports​(Module source, String pn, Module target)
      更新模块 source在图层中导出包到模块 target 。
      Module Module.addOpens​(String pn, Module other)
      如果该模块已经至少 打开了一个包到调用者模块，然后更新该模块以将包打开到给定的模块。
      ModuleLayer.Controller ModuleLayer.Controller.addOpens​(Module source, String pn, Module target)
      更新模块 source在图层中打开一个包到模块 target 。
      Module Module.addReads​(Module other)
      如果调用者的模块是该模块，则更新该模块以读取给定的模块。
      ModuleLayer.Controller ModuleLayer.Controller.addReads​(Module source, Module target)
      更新模块 source在图层读取模块 target 。
      boolean Module.canRead​(Module other)
      指示此模块是否读取给定的模块。
      static Class<?> Class.forName​(Module module, String name)
      返回 Class给定 binary name给定的模块中。
      System.Logger System.LoggerFinder.getLocalizedLogger​(String name, ResourceBundle bundle, Module module)
      返回一个本地化的实例Logger对于给定module 。
      abstract System.Logger System.LoggerFinder.getLogger​(String name, Module module)
      为给定的module返回一个Logger的实例。
      boolean Module.isExported​(String pn, Module other)
      如果此模块将给定的包导出到至少给定的模块，则返回 true 。
      boolean Module.isOpen​(String pn, Module other)
      返回 true如果该模块已经 打开一个包至少给定的模块。

    • Uses of Module in java.lang.instrument

      Methods in java.lang.instrument with parameters of type Module
      Modifier and Type 方法 描述
      boolean Instrumentation.isModifiableModule​(Module module)
      测试模块是否可以使用 redefineModule进行修改。
      void Instrumentation.redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)
      重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。
      default byte[] ClassFileTransformer.transform​(Module module, ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
      Method parameters in java.lang.instrument with type arguments of type Module
      Modifier and Type 方法 描述
      void Instrumentation.redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)
      重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。
      void Instrumentation.redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)
      重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。

    • Uses of Module in java.util

      Methods in java.util with parameters of type Module
      Modifier and Type 方法 描述
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Module module)
      使用指定的基本名称和默认语言环境代替指定的模块获取资源包。
      static ResourceBundle ResourceBundle.getBundle​(String baseName, Locale targetLocale, Module module)
      使用指定的基本名称和区域设置代替指定的模块获取资源包。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ModuleLayer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ModuleLayer

  • Packages that use ModuleLayer
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of ModuleLayer in java.lang

      Methods in java.lang that return ModuleLayer
      Modifier and Type 方法 描述
      static ModuleLayer ModuleLayer.boot​()
      返回引导层。
      ModuleLayer ModuleLayer.defineModules​(Configuration cf, Function<String,ClassLoader> clf)
      通过在Java虚拟机的给定 Configuration定义模块，创建一个新的模块层，将该层作为其父层。
      ModuleLayer ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      ModuleLayer ModuleLayer.defineModulesWithOneLoader​(Configuration cf, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer ModuleLayer.empty​()
      返回 空层。
      ModuleLayer Module.getLayer​()
      如果此模块不在模块层中，则返回包含此模块的模块层或 null 。
      ModuleLayer ModuleLayer.Controller.layer​()
      返回此对象控制的图层。
      Methods in java.lang that return types with arguments of type ModuleLayer
      Modifier and Type 方法 描述
      List<ModuleLayer> ModuleLayer.parents​()
      返回这个图层的父母的列表，除非这是 empty layer ，它没有父母，所以返回一个空列表。
      Method parameters in java.lang with type arguments of type ModuleLayer
      Modifier and Type 方法 描述
      static ModuleLayer.Controller ModuleLayer.defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithOneLoader​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过在Java虚拟机的给定的 Configuration定义模块来创建新的模块层。

    • Uses of ModuleLayer in java.util

      Methods in java.util with parameters of type ModuleLayer
      Modifier and Type 方法 描述
      static <S> ServiceLoader<S> ServiceLoader.load​(ModuleLayer layer, Class<S> service)
      为给定的服务类型创建新的服务加载器，以便从给定模块层及其祖先的模块加载服务提供者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ModuleLayer.Controller (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ModuleLayer.Controller

  • Packages that use ModuleLayer.Controller
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ModuleLayer.Controller in java.lang

      Methods in java.lang that return ModuleLayer.Controller
      Modifier and Type 方法 描述
      ModuleLayer.Controller ModuleLayer.Controller.addExports​(Module source, String pn, Module target)
      更新模块 source在图层 target包导出到模块 target 。
      ModuleLayer.Controller ModuleLayer.Controller.addOpens​(Module source, String pn, Module target)
      更新模块 source在图层中打开一个包到模块 target 。
      ModuleLayer.Controller ModuleLayer.Controller.addReads​(Module source, Module target)
      更新模块 source在图层中读取模块 target 。
      static ModuleLayer.Controller ModuleLayer.defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过在Java虚拟机的给定的 Configuration定义模块来创建新的模块层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithOneLoader​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      Creates a new module layer by defining the modules in the given Configuration to the Java virtual machine.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NegativeArraySizeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NegativeArraySizeException

  • Packages that use NegativeArraySizeException
    软件包 描述
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of NegativeArraySizeException in java.lang.reflect

      Methods in java.lang.reflect that throw NegativeArraySizeException
      Modifier and Type 方法 描述
      static Object Array.newInstance​(Class<?> componentType, int length)
      创建具有指定组件类型和长度的新数组。
      static Object Array.newInstance​(Class<?> componentType, int... dimensions)
      创建具有指定组件类型和尺寸的新数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NoClassDefFoundError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NoClassDefFoundError

No usage of java.lang.NoClassDefFoundError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NoSuchFieldError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NoSuchFieldError

No usage of java.lang.NoSuchFieldError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NoSuchFieldException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NoSuchFieldException

  • Packages that use NoSuchFieldException
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

    • Uses of NoSuchFieldException in java.lang

      Methods in java.lang that throw NoSuchFieldException
      Modifier and Type 方法 描述
      Field Class.getDeclaredField​(String name)
      返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定声明字段。
      Field Class.getField​(String name)
      返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定公共成员字段。

    • Uses of NoSuchFieldException in java.lang.invoke

      Methods in java.lang.invoke that throw NoSuchFieldException
      Modifier and Type 方法 描述
      MethodHandle MethodHandles.Lookup.findGetter​(Class<?> refc, String name, Class<?> type)
      产生方法句柄，给非静态字段的读访问权限。
      MethodHandle MethodHandles.Lookup.findSetter​(Class<?> refc, String name, Class<?> type)
      产生一个给非静态字段写入访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticGetter​(Class<?> refc, String name, Class<?> type)
      产生一个给静态字段读取访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticSetter​(Class<?> refc, String name, Class<?> type)
      生成方法句柄，给静态字段写权限。
      VarHandle MethodHandles.Lookup.findStaticVarHandle​(Class<?> decl, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的静态字段 decl 。
      VarHandle MethodHandles.Lookup.findVarHandle​(Class<?> recv, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的非静态字段 recv 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NoSuchMethodError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NoSuchMethodError

No usage of java.lang.NoSuchMethodError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NoSuchMethodException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NoSuchMethodException

  • Packages that use NoSuchMethodException
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javax.management.relation
    提供关系服务的定义。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of NoSuchMethodException in java.lang

      Methods in java.lang that throw NoSuchMethodException
      Modifier and Type 方法 描述
      Constructor<T> Class.getConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由该 Class对象表示的类的指定公共构造函数。
      Constructor<T> Class.getDeclaredConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，它反映此表示的类或接口的指定构造 Class对象。
      方法 Class.getDeclaredMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，它反映此表示的类或接口的指定声明的方法 Class对象。
      方法 Class.getMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，它反映此表示的类或接口的指定公共成员方法 Class对象。

    • Uses of NoSuchMethodException in java.lang.invoke

      Methods in java.lang.invoke that throw NoSuchMethodException
      Modifier and Type 方法 描述
      MethodHandle MethodHandles.Lookup.bind​(Object receiver, String name, MethodType type)
      为非静态方法生成早期绑定的方法句柄。
      MethodHandle MethodHandles.Lookup.findConstructor​(Class<?> refc, MethodType type)
      使用指定类型的构造函数生成创建对象并初始化它的方法句柄。
      MethodHandle MethodHandles.Lookup.findSpecial​(Class<?> refc, String name, MethodType type, Class<?> specialCaller)
      为虚拟方法生成早期绑定的方法句柄。
      MethodHandle MethodHandles.Lookup.findStatic​(Class<?> refc, String name, MethodType type)
      为静态方法生成方法句柄。
      MethodHandle MethodHandles.Lookup.findVirtual​(Class<?> refc, String name, MethodType type)
      为虚拟方法生成方法句柄。

    • Uses of NoSuchMethodException in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter that throw NoSuchMethodException
      Modifier and Type 方法 描述
      JavaBeanBooleanProperty JavaBeanBooleanPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanBooleanProperty 。
      JavaBeanDoubleProperty JavaBeanDoublePropertyBuilder.build​()
      使用当前设置生成新的JavaBeanDoubleProperty 。
      JavaBeanFloatProperty JavaBeanFloatPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanFloatProperty 。
      JavaBeanIntegerProperty JavaBeanIntegerPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanIntegerProperty 。
      JavaBeanLongProperty JavaBeanLongPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanLongProperty 。
      JavaBeanObjectProperty<T> JavaBeanObjectPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanObjectProperty 。
      JavaBeanStringProperty JavaBeanStringPropertyBuilder.build​()
      使用当前设置生成新的JavaBeanStringProperty 。
      ReadOnlyJavaBeanBooleanProperty ReadOnlyJavaBeanBooleanPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanBooleanProperty 。
      ReadOnlyJavaBeanDoubleProperty ReadOnlyJavaBeanDoublePropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanDoubleProperty 。
      ReadOnlyJavaBeanFloatProperty ReadOnlyJavaBeanFloatPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanFloatProperty 。
      ReadOnlyJavaBeanIntegerProperty ReadOnlyJavaBeanIntegerPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanIntegerProperty 。
      ReadOnlyJavaBeanLongProperty ReadOnlyJavaBeanLongPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanLongProperty 。
      ReadOnlyJavaBeanObjectProperty<T> ReadOnlyJavaBeanObjectPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanObjectProperty 。
      ReadOnlyJavaBeanStringProperty ReadOnlyJavaBeanStringPropertyBuilder.build​()
      使用当前设置生成新的ReadOnlyJavaBeanStringProperty 。

    • Uses of NoSuchMethodException in javax.management.relation

      Methods in javax.management.relation that throw NoSuchMethodException
      Modifier and Type 方法 描述
      void RelationService.addRelation​(ObjectName relationObjectName)
      将由用户创建的一个MBean（并由他注册在MBean服务器中）添加为关系服务中的关系。
      void RelationServiceMBean.addRelation​(ObjectName relationObjectName)
      将由用户创建的一个MBean（并由他注册在MBean服务器中）添加为关系服务中的关系。

    • Uses of NoSuchMethodException in javax.script

      Methods in javax.script that throw NoSuchMethodException
      Modifier and Type 方法 描述
      Object Invocable.invokeFunction​(String name, Object... args)
      用于调用脚本中定义的顶级过程和函数。
      Object Invocable.invokeMethod​(Object thiz, String name, Object... args)
      在前一个脚本执行期间编译的脚本对象上调用方法，该方法保留在 ScriptEngine的状态。

    • Uses of NoSuchMethodException in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that throw NoSuchMethodException
      Modifier and Type | 方法 | 描述
      Object | NashornScriptEngine.invokeFunction​(String name, Object... args)
      Object | NashornScriptEngine.invokeMethod​(Object thiz, String name, Object... args)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NullPointerException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NullPointerException

  • Packages that use NullPointerException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.print
    提供通用打印API的类和接口。
    javax.management
    提供Java管理扩展的核心类。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of NullPointerException in java.awt

      Methods in java.awt that throw NullPointerException
      Modifier and Type 方法 描述
      void SplashScreen.setImageURL​(URL imageURL)
      更改启动屏幕图像。

    • Uses of NullPointerException in java.awt.print

      Methods in java.awt.print that throw NullPointerException
      Modifier and Type 方法 描述
      abstract void PrinterJob.setPageable​(Pageable document)
      查询 document的页数和 PageFormat和 Printable为 Pageable实例中的每个页面， document 。

    • Uses of NullPointerException in javax.management

      Methods in javax.management that throw NullPointerException
      Modifier and Type 方法 描述
      static ObjectName ObjectName.getInstance​(String name)
      返回可以使用任何可以使用 new ObjectName(name)获得的对象的ObjectName实例。

    • Uses of NullPointerException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw NullPointerException
      Modifier and Type 方法 描述
      static Parser ParserFactory.makeParser​()
      已过时。
      使用`org.xml.sax.parser'系统属性创建一个新的SAX解析器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Number (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Number

  • Packages that use Number
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.css.converter
    提供各种转换CSS解析值的StyleConverter类。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.accessibility
    定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.monitor
    提供监视器类的定义。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.datatype
    定义XML / Java类型映射。

    • Uses of Number in java.awt

      Methods in java.awt that return Number
      Modifier and Type 方法 描述
      Number Button.AccessibleAWTButton.getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number Checkbox.AccessibleAWTCheckbox.getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number MenuItem.AccessibleAWTMenuItem.getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number Scrollbar.AccessibleAWTScrollBar.getCurrentAccessibleValue​()
      获取此对象的可访问值。
      Number Button.AccessibleAWTButton.getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number Checkbox.AccessibleAWTCheckbox.getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number MenuItem.AccessibleAWTMenuItem.getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number Scrollbar.AccessibleAWTScrollBar.getMaximumAccessibleValue​()
      获取此对象的最大可访问值。
      Number Button.AccessibleAWTButton.getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      Number Checkbox.AccessibleAWTCheckbox.getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      Number CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      Number MenuItem.AccessibleAWTMenuItem.getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      Number Scrollbar.AccessibleAWTScrollBar.getMinimumAccessibleValue​()
      获取此对象的最小可访问值。
      Methods in java.awt with parameters of type Number
      Modifier and Type 方法 描述
      boolean Button.AccessibleAWTButton.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean Checkbox.AccessibleAWTCheckbox.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean MenuItem.AccessibleAWTMenuItem.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean Scrollbar.AccessibleAWTScrollBar.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。

    • Uses of Number in java.lang

      Subclasses of Number in java.lang
      Modifier and Type Class 描述
      class  Byte
      Byte类在一个对象中包装一个原始类型为 byte的值。
      class  Double
      Double类包装一个对象中的原始类型 double的值。
      class  Float
      Float类包装一个对象中原始类型为 float的值。
      class  Integer
      Integer类包装一个对象中的基元类型 int的值。
      class  Long
      Long类将一个对象中的原始类型为 long的值。
      class  Short
      Short类在一个对象中包含一个原始类型 short的值。

    • Uses of Number in java.math

      Subclasses of Number in java.math
      Modifier and Type Class 描述
      class  BigDecimal
      不变的，任意精度的带符号的十进制数字。
      class  BigInteger
      不可变的任意精度整数。

    • Uses of Number in java.text

      Methods in java.text that return Number
      Modifier and Type 方法 描述
      Number ChoiceFormat.parse​(String text, ParsePosition status)
      从输入文本中解析一个数字。
      Number DecimalFormat.parse​(String text, ParsePosition pos)
      从字符串中解析文本，产生一个 Number 。
      Number NumberFormat.parse​(String source)
      从给定字符串的开头解析文本以产生一个数字。
      abstract Number NumberFormat.parse​(String source, ParsePosition parsePosition)
      如果可能，返回长（例如，在[Long.MIN_VALUE，Long.MAX_VALUE]范围内，无小数），否则为Double。

    • Uses of Number in java.util.concurrent.atomic

      Subclasses of Number in java.util.concurrent.atomic
      Modifier and Type Class 描述
      class  AtomicInteger
      一个 int可能原子更新的值。
      class  AtomicLong
      A long可能原子更新的值。
      class  DoubleAccumulator
      一个或多个变量，它们一起保持运行 double使用所提供的功能更新值。
      class  DoubleAdder
      一个或多个变量一起保持初始为零 double总和。
      class  LongAccumulator
      一个或多个变量，它们一起保持运行 long使用所提供的功能更新值。
      class  LongAdder
      一个或多个变量一起维持起始零点 long和。

    • Uses of Number in javafx.beans.binding

      Methods in javafx.beans.binding with type parameters of type Number
      Modifier and Type 方法 描述
      static <T extends Number>
      DoubleExpression             		DoubleExpression.doubleExpression​(ObservableValue<T> value)
      返回一个DoubleExpression的DoubleExpression 。
      static <T extends Number>
      FloatExpression             		FloatExpression.floatExpression​(ObservableValue<T> value)
      返回一个FloatExpression的FloatExpression 。
      static <T extends Number>
      IntegerExpression             		IntegerExpression.integerExpression​(ObservableValue<T> value)
      返回一个IntegerExpression ，其中包含一个ObservableValue 。
      static <T extends Number>
      LongExpression             		LongExpression.longExpression​(ObservableValue<T> value)
      返回一个LongExpression ，其中包含一个ObservableValue 。
      static <S extends Number>
      NumberExpressionBase             		NumberExpressionBase.numberExpression​(ObservableNumberValue value)
      返回一个NumberExpressionBase ，其中包含一个ObservableNumberValue 。
      Method parameters in javafx.beans.binding with type arguments of type Number
      Modifier and Type | 方法 | 描述
      void | DoubleBinding.addListener​(ChangeListener<? super Number> listener)
      void | FloatBinding.addListener​(ChangeListener<? super Number> listener)
      void | IntegerBinding.addListener​(ChangeListener<? super Number> listener)
      void | LongBinding.addListener​(ChangeListener<? super Number> listener)
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的DoubleBinding ，其中包含在指定位置的ObservableList的元素。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的DoubleBinding ，其中包含ObservableList在指定位置的元素。
      static DoubleBinding Bindings.doubleValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的DoubleBinding ，其中包含指定位置的ObservableList的元素。
      static <K> DoubleBinding Bindings.doubleValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> DoubleBinding Bindings.doubleValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的DoubleBinding ，其中包含ObservableMap中特定键的映射 。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的FloatBinding ，其中包含指定位置的元素ObservableList 。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的FloatBinding ，其中包含在指定位置的ObservableList的元素。
      static FloatBinding Bindings.floatValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的FloatBinding ，其中包含指定位置的元素ObservableList 。
      static <K> FloatBinding Bindings.floatValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> FloatBinding Bindings.floatValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的FloatBinding ，其中包含ObservableMap中特定键的映射 。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的IntegerBinding ，其中包含ObservableList在指定位置的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static IntegerBinding Bindings.integerValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的IntegerBinding ，其中包含指定位置的ObservableList的元素。
      static <K> IntegerBinding Bindings.integerValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> IntegerBinding Bindings.integerValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的IntegerBinding ，其中包含ObservableMap中特定键的映射 。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, int index)
      创建一个新的LongBinding ，其中包含在指定位置的ObservableList的元素。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableIntegerValue index)
      创建一个新的LongBinding ，其中包含指定位置的元素ObservableList 。
      static LongBinding Bindings.longValueAt​(ObservableList<? extends Number> op, ObservableNumberValue index)
      创建一个新的LongBinding ，其中包含指定位置的ObservableList的元素。
      static <K> LongBinding Bindings.longValueAt​(ObservableMap<K,? extends Number> op, ObservableValue<? extends K> key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      static <K> LongBinding Bindings.longValueAt​(ObservableMap<K,? extends Number> op, K key)
      创建一个新的LongBinding ，其中包含ObservableMap中特定键的映射 。
      void | DoubleBinding.removeListener​(ChangeListener<? super Number> listener)
      void | FloatBinding.removeListener​(ChangeListener<? super Number> listener)
      void | IntegerBinding.removeListener​(ChangeListener<? super Number> listener)
      void | LongBinding.removeListener​(ChangeListener<? super Number> listener)

    • Uses of Number in javafx.beans.property

      Methods in javafx.beans.property with type parameters of type Number
      Modifier and Type 方法 描述
      static <T extends Number>
      ReadOnlyDoubleProperty             		ReadOnlyDoubleProperty.readOnlyDoubleProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyDoubleProperty的ReadOnlyDoubleProperty 。
      static <T extends Number>
      ReadOnlyFloatProperty             		ReadOnlyFloatProperty.readOnlyFloatProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyFloatProperty的ReadOnlyFloatProperty 。
      static <T extends Number>
      ReadOnlyIntegerProperty             		ReadOnlyIntegerProperty.readOnlyIntegerProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyIntegerProperty的ReadOnlyIntegerProperty 。
      static <T extends Number>
      ReadOnlyLongProperty             		ReadOnlyLongProperty.readOnlyLongProperty​(ReadOnlyProperty<T> property)
      返回一个ReadOnlyLongProperty的ReadOnlyLongProperty 。
      Methods in javafx.beans.property with parameters of type Number
      Modifier and Type 方法 描述
      void DoubleProperty.setValue​(Number v)
      设置包装的值。
      void FloatProperty.setValue​(Number v)
      设置包装的值。
      void IntegerProperty.setValue​(Number v)
      设置包装的值。
      void LongProperty.setValue​(Number v)
      设置包装的值。
      Method parameters in javafx.beans.property with type arguments of type Number
      Modifier and Type | 方法 | 描述
      void | DoublePropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | FloatPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | IntegerPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | LongPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyDoublePropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyFloatPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyIntegerPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyLongPropertyBase.addListener​(ChangeListener<? super Number> listener)
      void DoublePropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      void FloatPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      void IntegerPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      void LongPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)
      为此创建一个单向绑定 Property 。
      void DoubleProperty.bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      void FloatProperty.bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      void IntegerProperty.bindBidirectional​(Property<Number> other)
      在这个 Property和另一个之间创建双向绑定。
      void LongProperty.bindBidirectional​(Property<Number> other)
      在这个 Property之间创建一个双向绑定。
      void | DoublePropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | FloatPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | IntegerPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | LongPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyDoublePropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyFloatPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyIntegerPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void | ReadOnlyLongPropertyBase.removeListener​(ChangeListener<? super Number> listener)
      void DoubleProperty.unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。
      void FloatProperty.unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。
      void IntegerProperty.unbindBidirectional​(Property<Number> other)
      删除此 Property和另一个之间的双向绑定。
      void LongProperty.unbindBidirectional​(Property<Number> other)
      删除此 Property与另一个之间的双向绑定。

    • Uses of Number in javafx.beans.property.adapter

      Method parameters in javafx.beans.property.adapter with type arguments of type Number
      Modifier and Type 方法 描述
      void JavaBeanDoubleProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void JavaBeanFloatProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void JavaBeanIntegerProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。
      void JavaBeanLongProperty.addListener​(ChangeListener<? super Number> listener)
      添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。
      void JavaBeanDoubleProperty.bind​(ObservableValue<? extends Number> observable)
      为这个 Property创建一个单向绑定。
      void JavaBeanFloatProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanIntegerProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanLongProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void JavaBeanDoubleProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanFloatProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanIntegerProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的侦听器，当 ObservableValue的值发生变化时通知 ObservableValue 。
      void JavaBeanLongProperty.removeListener​(ChangeListener<? super Number> listener)
      从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

    • Uses of Number in javafx.beans.value

      Methods in javafx.beans.value with parameters of type Number
      Modifier and Type 方法 描述
      void WritableDoubleValue.setValue​(Number value)
      设置包装的值。
      void WritableFloatValue.setValue​(Number value)
      设置包装的值。
      void WritableIntegerValue.setValue​(Number value)
      设置包装的值。
      void WritableLongValue.setValue​(Number value)
      设置包装的值。

    • Uses of Number in javafx.css

      Methods in javafx.css that return types with arguments of type Number
      Modifier and Type 方法 描述
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function)
      创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Number>，并继承标志。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty)
      使用以前创建的给定的 cssProperty创建一个StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function)
      创建一个StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建一个具有初始值的StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Number>并继承标志。
      CssMetaData<? extends Styleable,Number> SimpleStyleableDoubleProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableFloatProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableIntegerProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      CssMetaData<? extends Styleable,Number> SimpleStyleableLongProperty.getCssMetaData​()
      反映了对应于这个 javafx.beans.property.StyleableProperty
      static StyleConverter<?,Number> StyleConverter.getSizeConverter​()
      将CSS长度和数值解析为Size对象，该对象在应用该值之前转换为Number。
      Methods in javafx.css with parameters of type Number
      Modifier and Type 方法 描述
      void StyleableDoubleProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableFloatProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableIntegerProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      void StyleableLongProperty.applyStyle​(StyleOrigin origin, Number v)
      这个方法从CSS代码调用来设置属性的值。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Number>，并继承标志。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建一个具有初始值的StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Number>并继承标志。
      Method parameters in javafx.css with type arguments of type Number
      Modifier and Type 方法 描述
      void StyleableDoubleProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void StyleableFloatProperty.bind​(ObservableValue<? extends Number> observable)
      为此 Property创建一个单向绑定。
      void StyleableIntegerProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      void StyleableLongProperty.bind​(ObservableValue<? extends Number> observable)
      为此创建一个单向绑定 Property 。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function)
      创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。
      CssMetaData<S,Number> StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建具有初始值的CssMetaData <S，Number>，并继承标志。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function)
      创建一个StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)
      创建一个具有初始值的StyleableProperty <Number>。
      StyleableProperty<Number> StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)
      创建一个具有初始值的StyleableProperty <Number>并继承标志。
      Constructor parameters in javafx.css with type arguments of type Number
      Constructor 描述
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)
      SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)
      SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)
      SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。
      SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)
      SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。

    • Uses of Number in javafx.css.converter

      Methods in javafx.css.converter that return Number
      Modifier and Type | 方法 | 描述
      Number | FontConverter.FontSizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      Number | SizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      Number[] | SizeConverter.SequenceConverter.convert​(ParsedValue<ParsedValue[],Number[]> value, Font font)
      Methods in javafx.css.converter that return types with arguments of type Number
      Modifier and Type | 方法 | 描述
      static StyleConverter<ParsedValue<?,Size>,Number> | SizeConverter.getInstance​()
      Method parameters in javafx.css.converter with type arguments of type Number
      Modifier and Type | 方法 | 描述
      Number | FontConverter.FontSizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)
      Number | SizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)

    • Uses of Number in javafx.scene.chart

      Classes in javafx.scene.chart with type parameters of type Number
      Modifier and Type Class 描述
      class  ValueAxis<T extends Number>
      数据定义为数字的轴。
      Methods in javafx.scene.chart that return Number
      Modifier and Type 方法 描述
      Number NumberAxis.DefaultFormatter.fromString​(String string)
      将提供的字符串转换为由此转换器定义的数字。
      Methods in javafx.scene.chart that return types with arguments of type Number
      Modifier and Type 方法 描述
      protected List<Number> NumberAxis.calculateMinorTickMarks​()
      计算每个小刻度线的数据值列表
      protected List<Number> NumberAxis.calculateTickValues​(double length, Object range)
      计算范围内每个刻度线的所有数据值的列表
      Methods in javafx.scene.chart with parameters of type Number
      Modifier and Type 方法 描述
      protected String NumberAxis.getTickMarkLabel​(Number value)
      获取具有给定值的刻度线的字符串标签名称。
      protected Dimension2D NumberAxis.measureTickMarkSize​(Number value, Object range)
      测量给定刻度标记值的标签尺寸。
      String NumberAxis.DefaultFormatter.toString​(Number object)
      将提供的对象转换为其字符串形式。

    • Uses of Number in javafx.util.converter

      Methods in javafx.util.converter that return Number
      Modifier and Type 方法 描述
      Number NumberStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Number
      Modifier and Type 方法 描述
      String NumberStringConverter.toString​(Number value)
      将提供的对象转换为其字符串形式。

    • Uses of Number in javax.accessibility

      Methods in javax.accessibility that return Number
      Modifier and Type 方法 描述
      Number AccessibleValue.getCurrentAccessibleValue​()
      将该对象的值作为 Number 。
      Number AccessibleValue.getMaximumAccessibleValue​()
      以 Number获取此对象的 Number 。
      Number AccessibleValue.getMinimumAccessibleValue​()
      以 Number获取此对象的 Number 。
      Methods in javax.accessibility with parameters of type Number
      Modifier and Type 方法 描述
      boolean AccessibleValue.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为 Number 。

    • Uses of Number in javax.management

      Methods in javax.management with parameters of type Number
      Modifier and Type 方法 描述
      static ValueExp Query.value​(Number val)
      返回一个数值表达式，可以在任何期望使用ValueExp的Query调用中使用。

    • Uses of Number in javax.management.monitor

      Methods in javax.management.monitor that return Number
      Modifier and Type 方法 描述
      Number CounterMonitor.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由CounterMonitor.getDerivedGauge(ObjectName)取代
      Number CounterMonitor.getDerivedGauge​(ObjectName object)
      如果该对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。
      Number CounterMonitorMBean.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.getDerivedGauge(ObjectName)取代
      Number CounterMonitorMBean.getDerivedGauge​(ObjectName object)
      获取指定MBean的派生量规。
      Number GaugeMonitor.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由GaugeMonitor.getDerivedGauge(ObjectName)替代
      Number GaugeMonitor.getDerivedGauge​(ObjectName object)
      如果此对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。
      Number GaugeMonitorMBean.getDerivedGauge​()
      已过时。
      截至JMX 1.2，由GaugeMonitorMBean.getDerivedGauge(ObjectName)替代
      Number GaugeMonitorMBean.getDerivedGauge​(ObjectName object)
      获取指定MBean的派生量规。
      Number GaugeMonitor.getHighThreshold​()
      获得所有观察到的MBean共有的高阈值。
      Number GaugeMonitorMBean.getHighThreshold​()
      获得高阈值。
      Number CounterMonitor.getInitThreshold​()
      获得所有观察对象共同的初始阈值。
      Number CounterMonitorMBean.getInitThreshold​()
      获得所有观察对象共同的初始阈值。
      Number GaugeMonitor.getLowThreshold​()
      获得所有观察到的MBean共有的低阈值。
      Number GaugeMonitorMBean.getLowThreshold​()
      获得低阈值。
      Number CounterMonitor.getModulus​()
      获得所有观察到的MBean共有的模数值。
      Number CounterMonitorMBean.getModulus​()
      获得模数值。
      Number CounterMonitor.getOffset​()
      获取所有观察到的MBean公用的偏移值。
      Number CounterMonitorMBean.getOffset​()
      获取偏移值。
      Number CounterMonitor.getThreshold​()
      已过时。
      截至JMX 1.2，由CounterMonitor.getThreshold(ObjectName)替代
      Number CounterMonitor.getThreshold​(ObjectName object)
      获取指定对象的当前阈值，如果该对象包含在观察到的MBean集合中，否则为 null 。
      Number CounterMonitorMBean.getThreshold​()
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.getThreshold(ObjectName)取代
      Number CounterMonitorMBean.getThreshold​(ObjectName object)
      获取指定MBean的阈值。
      Methods in javax.management.monitor with parameters of type Number
      Modifier and Type 方法 描述
      void CounterMonitor.setInitThreshold​(Number value)
      设置所有观察对象共同的初始阈值。
      void CounterMonitorMBean.setInitThreshold​(Number value)
      设置所有观察到的MBean公用的初始阈值。
      void CounterMonitor.setModulus​(Number value)
      设置所有观察到的MBean共有的模数值。
      void CounterMonitorMBean.setModulus​(Number value)
      设置模数值。
      void CounterMonitor.setOffset​(Number value)
      设置所有观察到的MBean公用的偏移值。
      void CounterMonitorMBean.setOffset​(Number value)
      设置偏移值。
      void CounterMonitor.setThreshold​(Number value)
      已过时。
      截至JMX 1.2，由CounterMonitor.setInitThreshold(java.lang.Number)替代
      void CounterMonitorMBean.setThreshold​(Number value)
      已过时。
      截至JMX 1.2，由CounterMonitorMBean.setInitThreshold(java.lang.Number)取代
      void GaugeMonitor.setThresholds​(Number highValue, Number lowValue)
      设置所有观察到的MBean共有的高和低阈值。
      void GaugeMonitorMBean.setThresholds​(Number highValue, Number lowValue)
      设置高和低阈值。

    • Uses of Number in javax.swing

      Methods in javax.swing that return Number
      Modifier and Type 方法 描述
      Number AbstractButton.AccessibleAbstractButton.getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number JInternalFrame.AccessibleJInternalFrame.getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getCurrentAccessibleValue​()
      获取该对象的值作为 Number 。
      Number JProgressBar.AccessibleJProgressBar.getCurrentAccessibleValue​()
      获取此对象的可访问值。
      Number JScrollBar.AccessibleJScrollBar.getCurrentAccessibleValue​()
      获取此对象的可访问值。
      Number JSlider.AccessibleJSlider.getCurrentAccessibleValue​()
      获取此对象的可访问值。
      Number JSpinner.AccessibleJSpinner.getCurrentAccessibleValue​()
      将该对象的值作为数字获取。
      Number JSplitPane.AccessibleJSplitPane.getCurrentAccessibleValue​()
      获取此对象的可访问值。
      Number AbstractButton.AccessibleAbstractButton.getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number JInternalFrame.AccessibleJInternalFrame.getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMaximumAccessibleValue​()
      获取此对象的最大值为 Number 。
      Number JProgressBar.AccessibleJProgressBar.getMaximumAccessibleValue​()
      获取此对象的最大可访问值。
      Number JScrollBar.AccessibleJScrollBar.getMaximumAccessibleValue​()
      获取此对象的最大可访问值。
      Number JSlider.AccessibleJSlider.getMaximumAccessibleValue​()
      获取此对象的最大可访问值。
      Number JSpinner.AccessibleJSpinner.getMaximumAccessibleValue​()
      获取该对象的最大值作为数字。
      Number JSplitPane.AccessibleJSplitPane.getMaximumAccessibleValue​()
      获取此对象的最大可访问值。
      Number AbstractButton.AccessibleAbstractButton.getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      Number JInternalFrame.AccessibleJInternalFrame.getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      Number JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMinimumAccessibleValue​()
      获取此对象的最小值为 Number 。
      Number JProgressBar.AccessibleJProgressBar.getMinimumAccessibleValue​()
      获取此对象的最小可访问值。
      Number JScrollBar.AccessibleJScrollBar.getMinimumAccessibleValue​()
      获取此对象的最小可访问值。
      Number JSlider.AccessibleJSlider.getMinimumAccessibleValue​()
      获取此对象的最小可访问值。
      Number JSpinner.AccessibleJSpinner.getMinimumAccessibleValue​()
      将此对象的最小值作为数字获取。
      Number JSplitPane.AccessibleJSplitPane.getMinimumAccessibleValue​()
      获取此对象的最小可访问值。
      Number SpinnerNumberModel.getNumber​()
      返回序列的当前元素的值。
      Number SpinnerNumberModel.getStepSize​()
      返回由 getNextValue和 getPreviousValue计算的值变化的大小。
      Methods in javax.swing with parameters of type Number
      Modifier and Type 方法 描述
      static <M,I> RowFilter<M,I> RowFilter.numberFilter​(RowFilter.ComparisonType type, Number number, int... indices)
      返回一个 RowFilter ，其中包含符合指定条件的至少一个 Number值的条目。
      boolean AbstractButton.AccessibleAbstractButton.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean JInternalFrame.AccessibleJInternalFrame.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为 Number 。
      boolean JProgressBar.AccessibleJProgressBar.setCurrentAccessibleValue​(Number n)
      将该对象的值设置为 Number 。
      boolean JScrollBar.AccessibleJScrollBar.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean JSlider.AccessibleJSlider.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean JSpinner.AccessibleJSpinner.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      boolean JSplitPane.AccessibleJSplitPane.setCurrentAccessibleValue​(Number n)
      将此对象的值设置为数字。
      void SpinnerNumberModel.setStepSize​(Number stepSize)
      更改由 getNextValue和 getPreviousValue方法计算的值变化的大小。
      Constructors in javax.swing with parameters of type Number
      Constructor 描述
      SpinnerNumberModel​(Number value, Comparable<?> minimum, Comparable<?> maximum, Number stepSize)
      构造一个 SpinnerModel ，表示从 minimum到 maximum一个封闭序列。

    • Uses of Number in javax.xml.datatype

      Methods in javax.xml.datatype that return Number
      Modifier and Type 方法 描述
      abstract Number Duration.getField​(DatatypeConstants.Field field)
      获取字段的值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.NumberFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.NumberFormatException

  • Packages that use NumberFormatException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of NumberFormatException in java.awt

      Methods in java.awt that throw NumberFormatException
      Modifier and Type 方法 描述
      static Color Color.decode​(String nm)
      将 String转换为整数，并返回指定的不透明度 Color 。

    • Uses of NumberFormatException in java.lang

      Methods in java.lang that throw NumberFormatException
      Modifier and Type 方法 描述
      static Byte Byte.decode​(String nm)
      将 String解码成 Byte 。
      static Integer Integer.decode​(String nm)
      将 String解码为 Integer 。
      static Long Long.decode​(String nm)
      将 String解码成 Long 。
      static Short Short.decode​(String nm)
      将 String解码成 Short 。
      boolean Package.isCompatibleWith​(String desired)
      将该软件包的规格版本与所需版本进行比较。
      static byte Byte.parseByte​(String s)
      将字符串参数解析为有符号的二进制 byte 。
      static byte Byte.parseByte​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的带符号的 byte 。
      static double Double.parseDouble​(String s)
      返回一个新 double初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Double 。
      static float Float.parseFloat​(String s)
      返回一个新 float初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Float 。
      static int Integer.parseInt​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数作为有符号int指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
      static int Integer.parseInt​(String s)
      将字符串参数解析为带符号的十进制整数。
      static int Integer.parseInt​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的有符号整数。
      static long Long.parseLong​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数作为有符号long指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
      static long Long.parseLong​(String s)
      解析字符串参数作为带符号的二进制 long 。
      static long Long.parseLong​(String s, int radix)
      将字符串参数解析为由第二个参数指定的基数中的带符号的 long 。
      static short Short.parseShort​(String s)
      将字符串参数解析为有符号的二进制 short 。
      static short Short.parseShort​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的带符号的 short 。
      static int Integer.parseUnsignedInt​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数为一个无符号int在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
      static int Integer.parseUnsignedInt​(String s)
      将字符串参数解析为无符号十进制整数。
      static int Integer.parseUnsignedInt​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的无符号整数。
      static long Long.parseUnsignedLong​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数为一个无符号long在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
      static long Long.parseUnsignedLong​(String s)
      将字符串参数解析为无符号十进制 long 。
      static long Long.parseUnsignedLong​(String s, int radix)
      将字符串参数解析为第二个参数指定的基数中的无符号 long 。
      static Byte Byte.valueOf​(String s)
      返回一个 Byte对象，保存由指定的 String给出的值。
      static Byte Byte.valueOf​(String s, int radix)
      返回一个 Byte对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
      static Double Double.valueOf​(String s)
      返回一个 Double对象，该对象保存由参数字符串 s表示的 double值。
      static Float Float.valueOf​(String s)
      返回一个 Float对象，该对象保存由参数字符串 s表示的 float值。
      static Integer Integer.valueOf​(String s)
      返回一个 Integer对象，保存指定的值为 String 。
      static Integer Integer.valueOf​(String s, int radix)
      返回一个 Integer对象，该对象保存从指定的 String提取的值，并用第二个参数给出的基数进行解析。
      static Long Long.valueOf​(String s)
      返回一个 Long对象，该对象持有指定的值 String 。
      static Long Long.valueOf​(String s, int radix)
      返回一个 Long对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
      static Short Short.valueOf​(String s)
      返回一个 Short对象，保存由指定的 String给出的值。
      static Short Short.valueOf​(String s, int radix)
      返回一个 Short对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。
      Constructors in java.lang that throw NumberFormatException
      Constructor 描述
      Byte​(String s)
      已过时。
      很少使用这个构造函数。 使用Byte.parseByte(String)将字符串转换为byte原语，或使用Byte.valueOf(String)将字符串转换为Byte对象。
      Double​(String s)
      已过时。
      很少使用这个构造函数。 使用Double.parseDouble(String)将字符串转换为double原语，或使用Double.valueOf(String)将字符串转换为Double对象。
      Float​(String s)
      已过时。
      很少使用这个构造函数。 使用Float.parseFloat(String)将字符串转换为float原语，或使用Float.valueOf(String)将字符串转换为Float对象。
      Integer​(String s)
      已过时。
      很少使用这个构造函数。 使用Integer.parseInt(String)将字符串转换为int原语，或使用Integer.valueOf(String)将字符串转换为Integer对象。
      Long​(String s)
      已过时。
      很少使用这个构造函数。 使用Long.parseLong(String)将字符串转换为long原语，或使用Long.valueOf(String)将字符串转换为Long对象。
      Short​(String s)
      已过时。
      很少使用这个构造函数。 使用Short.parseShort(String)将字符串转换为short原语，或使用Short.valueOf(String)将字符串转换为Short对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Object (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev

Next

框架

无框架

所有类

SEARCH:

Uses of Class
java.lang.Object

Packages that use Object

软件包

描述

com.sun.jarsigner

该包包含用于定义 jarsigner工具使用的签名机制的接口和类。

com.sun.java.accessibility.util

提供组成Java辅助功能实用程序的接口和类的集合。

com.sun.javadoc

注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

com.sun.jdi

这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

com.sun.jdi.connect

该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

com.sun.jdi.connect.spi

该包包含用于开发新的TransportService实现的接口和类。

com.sun.jdi.request

该包用于请求在指定条件下发送JDI事件。

com.sun.management

该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

com.sun.net.httpserver

提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

com.sun.net.httpserver.spi

提供可插拔的服务提供程序接口，允许将HTTP服务器实现替换为其他实现。

com.sun.nio.sctp

用于流控制传输协议的Java API。

com.sun.security.auth

提供Principal的实现。

com.sun.security.auth.callback

提供CallbackHandler的实现。

com.sun.security.auth.login

提供Configuration的实现。

com.sun.security.auth.module

提供LoginModule的实现。

com.sun.security.jgss

com.sun.source.tree

提供用于将源代码表示为抽象语法树（AST）的接口。

com.sun.source.util

为抽象语法树（AST）的操作提供实用程序。

com.sun.tools.attach

提供API附加到Java的虚拟机。

com.sun.tools.attach.spi

只有定义新附加提供商的开发者才需要直接使用这个包。

com.sun.tools.doclets.standard

注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

com.sun.tools.javac

该包提供了 javac工具的传统入口点。

com.sun.tools.javadoc

此软件包及其内容已被弃用，可能会在将来的版本中删除。

com.sun.tools.jconsole

此程序包包含JConsole API。

java.applet

提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。

java.awt

包含用于创建用户界面和绘制图形和图像的所有类。

java.awt.color

提供颜色空间的类。

java.awt.datatransfer

提供用于在应用程序之间和之间传输数据的接口和类。

java.awt.desktop

提供与各种桌面功能交互的接口和类。

java.awt.dnd

拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

java.awt.event

提供用于处理AWT组件触发的不同类型事件的接口和类。

java.awt.font

提供与字体相关的类和界面。

java.awt.geom

提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

java.awt.im

提供输入法框架的类和接口。

java.awt.im.spi

提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。

java.awt.image

提供创建和修改图像的类。

java.awt.image.renderable

提供用于生成与渲染无关的图像的类和接口。

java.awt.print

提供通用打印API的类和接口。

java.beans

包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

java.beans.beancontext

提供与bean上下文相关的类和接口。

java.io

通过数据流，序列化和文件系统提供系统输入和输出。

java.lang

提供对Java编程语言设计至关重要的类。

java.lang.annotation

为Java编程语言注释工具提供库支持。

java.lang.instrument

提供允许Java编程语言代理仪器在JVM上运行程序的服务。

java.lang.invoke

java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

java.lang.management

提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

java.lang.module

通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

java.lang.ref

提供参考对象类，它支持与垃圾收集器的有限度的交互。

java.lang.reflect

提供用于获取关于类和对象的反射信息的类和接口。

java.math

提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。

java.net

提供实现网络应用程序的类。

java.net.spi

java.net包的服务提供商类。

java.nio

定义缓冲区，它们是数据容器，并提供其他NIO包的概述。

java.nio.channels

定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

java.nio.channels.spi

服务提供商类为 java.nio.channels包。

java.nio.charset

定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

java.nio.charset.spi

服务提供商类为 java.nio.charset包。

java.nio.file

定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

java.nio.file.attribute

提供访问文件和文件系统属性的接口和类。

java.nio.file.spi

服务提供商类为 java.nio.file包。

java.rmi

提供RMI包。

java.rmi.activation

提供对RMI对象激活的支持。

java.rmi.dgc

提供RMI分布式垃圾收集（DGC）的类和接口。

java.rmi.registry

为RMI注册表提供一个类和两个接口。

java.rmi.server

提供用于支持RMI服务器端的类和接口。

java.security

提供安全框架的类和接口。

java.security.acl

此包中的类和接口已被弃用。

java.security.cert

提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

java.security.spec

提供关键规范和算法参数规范的类和接口。

java.sql

提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

java.text

提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

java.text.spi

java.text包中类的服务提供者类。

java.time

日期，时间，瞬间和持续时间的主要API。

java.time.chrono

除默认ISO之外的日历系统的通用API。

java.time.format

提供打印和解析日期和时间的类。

java.time.temporal

使用字段和单位访问日期和时间，以及日期时间调整器。

java.time.zone

支持时区及其规则。

java.util

包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

java.util.concurrent

实用程序类通常用于并发编程。

java.util.concurrent.atomic

一个小型工具包，支持单个变量上的无锁线程安全编程。

java.util.concurrent.locks

接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

java.util.function

功能界面提供了lambda表达式和方法引用的目标类型。

java.util.jar

提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

java.util.logging

提供Java¢2平台核心日志记录工具的类和接口。

java.util.prefs

该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

java.util.regex

匹配字符序列与正则表达式指定的模式的类。

java.util.spi

java.util包中类的服务提供者类。

java.util.stream

支持元素流功能性操作的类，例如集合上的map-reduce转换。

java.util.zip

提供读写标准ZIP和GZIP文件格式的类。

javafx.animation

提供一组类，便于使用基于过渡的动画。

javafx.application

提供应用程序生命周期类。

javafx.beans

包 javafx.beans包含定义最通用形式的可观察性的接口。

javafx.beans.binding

提供创建和操作的类，用于计算取决于一个或多个来源的值的Binding 。

javafx.beans.property

程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

javafx.beans.property.adapter

提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

javafx.beans.value

包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。

javafx.collections

包含基本的JavaFX集合和集合实用程序

javafx.collections.transformation

提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。

javafx.concurrent

提供javafx.task的一组类。

javafx.css

提供API，通过CSS使属性变得风格，并支持伪类状态。

javafx.css.converter

提供各种转换CSS解析值的StyleConverter类。

javafx.embed.swing

提供一组在Swing应用程序中使用JavaFX的类。

javafx.event

为FX事件，交付和处理提供基本框架。

javafx.fxml

包含用于从标记加载对象层次结构的类。

javafx.geometry

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

javafx.print

提供JavaFX Printing API的公共类。

javafx.scene

为JavaFX Scene Graph API提供核心的基类集。

javafx.scene.canvas

为canvas提供一组类，即渲染API的立即模式样式。

javafx.scene.chart

JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

javafx.scene.control

JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

javafx.scene.control.cell

所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。

javafx.scene.control.skin

javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

javafx.scene.effect

提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

javafx.scene.image

提供加载和显示图像的一组类。

javafx.scene.input

提供一组用于鼠标和键盘输入事件处理的类。

javafx.scene.layout

提供类来支持用户界面布局。

javafx.scene.media

提供用于将音频和视频集成到Java FX应用程序中的一组类。

javafx.scene.paint

提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

javafx.scene.shape

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

javafx.scene.text

为字体和可渲染的文本节点提供一组类。

javafx.scene.transform

提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

javafx.scene.web

该软件包提供了加载和显示Web内容的方法。

javafx.stage

提供JavaFX内容的顶级容器类。

javafx.util

包含各种实用程序和助手类。

javafx.util.converter

此包用于JavaFX的标准字符串转换器。

javax.accessibility

定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。

javax.activation

javax.activity

包含ORB机械在解组时抛出的活动服务相关异常。

javax.annotation.processing

用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

javax.crypto

提供加密操作的类和接口。

javax.crypto.spec

提供关键规范和算法参数规范的类和接口。

javax.imageio

Java Image I / O API的主要包。

javax.imageio.metadata

处理读写元数据的Java Image I / O API的一个包。

javax.imageio.plugins.bmp

包含内置BMP插件使用的公共类的软件包。

javax.imageio.plugins.jpeg

支持内置JPEG插件的类。

javax.imageio.plugins.tiff

内置TIFF插件使用的公共类。

javax.imageio.spi

包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

javax.imageio.stream

Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

javax.jnlp

JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

javax.lang.model

用于建模Java编程语言的软件包的类和层次结构。

javax.lang.model.element

用于建模Java编程语言元素的接口。

javax.lang.model.type

用于建模Java编程语言类型的接口。

javax.lang.model.util

协助处理 program elements及 types的公用事业 。

javax.management

提供Java管理扩展的核心类。

javax.management.loading

提供实现高级动态加载的类。

javax.management.modelmbean

提供ModelMBean类的定义。

javax.management.monitor

提供监视器类的定义。

javax.management.openmbean

提供打开的数据类型和Open MBean描述符类。

javax.management.relation

提供关系服务的定义。

javax.management.remote

用于远程访问JMX MBean服务器的接口。

javax.management.remote.rmi

RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

javax.management.timer

提供定时器MBean的定义。

javax.naming

提供用于访问命名服务的类和接口。

javax.naming.directory

扩展 javax.naming软件包以提供访问目录服务的功能。

javax.naming.event

访问命名和目录服务时，提供对事件通知的支持。

javax.naming.ldap

提供对LDAPv3扩展操作和控件的支持。

javax.naming.spi

提供通过 javax.naming及相关软件包动态插入支持访问命名和目录服务的 javax.naming 。

javax.net

提供网络应用程序的类。

javax.net.ssl

为安全套接字包提供类。

javax.print

提供Java®打印服务API的主要类和接口。

javax.print.attribute

提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。

javax.print.attribute.standard

包javax.print.attribute.standard包含特定打印属性的类。

javax.print.event

程序包javax.print.event包含事件类和侦听器接口。

javax.rmi

包含RMI-IIOP的用户API。

javax.rmi.CORBA

包含RMI-IIOP的可移植API。

javax.rmi.ssl

通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。

javax.script

脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。

javax.security.auth

此软件包提供了认证和授权的框架。

javax.security.auth.callback

该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。

javax.security.auth.kerberos

此包包含与Kerberos网络身份验证协议相关的实用程序类。

javax.security.auth.login

该包提供了一个可插拔的认证框架。

javax.security.auth.x500

该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。

javax.security.cert

提供公钥证书类。

javax.security.sasl

包含用于支持SASL的类和接口。

javax.smartcardio

Java™智能卡I / O API

javax.sound.midi

提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。

javax.sound.midi.spi

为服务提供商提供了提供新的MIDI设备，MIDI文件读取器和写入器或声卡读取器的接口。

javax.sound.sampled

提供用于捕获，处理和播放采样音频数据的接口和类。

javax.sound.sampled.spi

为服务提供商提供抽象类，以提供新的音频设备，声音文件读取器和写入器或音频格式转换器。

javax.sql

通过Java编程语言为服务器端数据源访问和处理提供API。

javax.sql.rowset

JDBC RowSet实现的标准接口和基类。

javax.sql.rowset.serial

提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

javax.sql.rowset.spi

第三方供应商在实施同步提供程序时必须使用的标准类和接口。

javax.swing

提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

javax.swing.border

提供用于绘制Swing组件周围特殊边框的类和接口。

javax.swing.colorchooser

包含 JColorChooser组件使用的类和接口。

javax.swing.event

提供Swing组件触发的事件。

javax.swing.filechooser

包含 JFileChooser组件使用的类和接口。

javax.swing.plaf

提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。

javax.swing.plaf.basic

提供根据“基本”外观构建的用户界面对象。

javax.swing.plaf.metal

提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。

javax.swing.plaf.multi

提供组合两种或多种外观和感觉的用户界面对象。

javax.swing.plaf.nimbus

提供根据跨平台Nimbus外观构建的用户界面对象。

javax.swing.plaf.synth

合成是一种可以让所有绘画委托的外观和感觉。

javax.swing.table

提供处理 javax.swing.JTable类和接口。

javax.swing.text

提供处理可编辑和不可编辑文本组件的类和接口。

javax.swing.text.html

提供类 HTMLEditorKit和支持类用于创建HTML文本编辑器。

javax.swing.text.html.parser

提供默认的HTML解析器以及支持类。

javax.swing.text.rtf

提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。

javax.swing.tree

提供处理 javax.swing.JTree类和接口。

javax.swing.undo

允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。

javax.tools

为可以从程序调用的工具提供接口，例如编译器。

javax.transaction

包含ORB机械在解组期间抛出的三个异常。

javax.transaction.xa

提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。

javax.xml

定义XML处理的常量。

javax.xml.bind

为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。

javax.xml.bind.annotation

定义用于将Java程序元素定制到XML模式映射的注释。

javax.xml.bind.annotation.adapters

XmlAdapter及其指定的子类允许任意Java类与JAXB一起使用。

javax.xml.bind.attachment

该包由基于MIME的包处理器实现，可以在基于MIME的包格式中解释和创建优化的二进制数据。

javax.xml.bind.helpers

仅限JAXB提供者使用：为部分 javax.xml.bind接口提供部分默认实现。

javax.xml.bind.util

有用的客户端工具类。

javax.xml.catalog

提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。

javax.xml.crypto

XML加密的通用类。

javax.xml.crypto.dom

DOM专用类为 javax.xml.crypto包。

javax.xml.crypto.dsig

用于生成和验证XML数字签名的类。

javax.xml.crypto.dsig.dom

DOM专用类为 javax.xml.crypto.dsig包。

javax.xml.crypto.dsig.keyinfo

用于解析和处理元素和结构的类别KeyInfo 。

javax.xml.crypto.dsig.spec

XML数字签名的参数类。

javax.xml.datatype

定义XML / Java类型映射。

javax.xml.namespace

定义XML命名空间处理。

javax.xml.parsers

提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。

javax.xml.soap

提供用于创建和构建SOAP消息的API。

javax.xml.stream

定义Streaming API for XML（StAX）的接口和类。

javax.xml.stream.events

定义Streaming API for XML（StAX）的事件接口。

javax.xml.stream.util

为Streaming API for XML（StAX）提供实用程序类。

javax.xml.transform

定义用于处理转换指令的通用API，以及执行从源到结果的转换。

javax.xml.transform.dom

提供DOM特定的转换类。

javax.xml.transform.sax

提供SAX特定的转换类。

javax.xml.transform.stax

提供StAX特定的转换类。

javax.xml.transform.stream

提供流和URI特定的转换类。

javax.xml.validation

提供用于验证XML文档的API。

javax.xml.ws

此软件包包含核心JAX-WS API。

javax.xml.ws.handler.soap

此包定义SOAP消息处理程序的API。

javax.xml.ws.http

该包定义了特定于HTTP绑定的API。

javax.xml.ws.soap

该包定义了SOAP绑定专用的API。

javax.xml.ws.spi

此套件为JAX-WS定义了SPI。

javax.xml.ws.spi.http

提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。

javax.xml.ws.wsaddressing

此包定义与WS-Addressing相关的API。

javax.xml.xpath

提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。

jdk.dynalink

包含用于链接 invokedynamic通话网站的接口和类。

jdk.dynalink.beans

包含普通Java对象的链接器。

jdk.dynalink.linker

包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。

jdk.dynalink.linker.support

包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。

jdk.dynalink.support

包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。

jdk.incubator.http

高级HTTP和WebSocket API

jdk.javadoc.doclet

Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

jdk.jshell

提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

jdk.jshell.execution

提供构建JShell执行引擎的实现支持。

jdk.jshell.spi

定义可插拔JShell执行引擎的服务提供程序接口。

jdk.nashorn.api.scripting

这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

jdk.nashorn.api.tree

Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

jdk.net

针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。

jdk.security.jarsigner

netscape.javascript

使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。

org.ietf.jgss

该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。

org.omg.CORBA

提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能对象请求代理（ORB）。

org.omg.CORBA_2_3

CORBA_2_3包定义了Java [tm]标准版6中现有CORBA接口的添加。这些更改发生在由OMG定义的CORBA API的最新修订版本中。 将新方法添加到从CORBA包中相应接口派生的接口。 这提供向后兼容性，并避免破坏JCK测试。

org.omg.CORBA_2_3.portable

提供输入和输出值类型的方法，并包含 org/omg/CORBA/portable包的其他更新。

org.omg.CORBA.DynAnyPackage

提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。

org.omg.CORBA.ORBPackage

提供异常 InvalidName ，由方法 ORB.resolve_initial_references和异常 InconsistentTypeCode抛出，由ORB类中的动态任何创建方法抛出。

org.omg.CORBA.portable

提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。

org.omg.CORBA.TypeCodePackage

提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。

org.omg.CosNaming

为Java IDL提供命名服务。

org.omg.CosNaming.NamingContextExtPackage

此包包含以下类别，其用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress

org.omg.CosNaming.NamingContextPackage

此程序包包含 org.omg.CosNaming程序包的异常类。

org.omg.Dynamic

此软件包包含OMG便携式拦截器规范 ptc/2000-08-06第21.9节中指定的 Dynamic模块。

org.omg.DynamicAny

提供类和接口，可以在运行时遍历与 any相关联的数据值，并提取数据值的原始组成部分。

org.omg.DynamicAny.DynAnyFactoryPackage

该包包含OMG “公共对象请求代理：体系结构和规范 ” formal/99-10-07第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。

org.omg.DynamicAny.DynAnyPackage

该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。

org.omg.IOP

该包包含OMG文档 “通用对象请求代理：体系结构和规范 ” formal/99-10-07第13.6节中指定的 IOP模块。

org.omg.IOP.CodecFactoryPackage

该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。

org.omg.IOP.CodecPackage

该包是从IOP :: Codec IDL接口定义生成的。

org.omg.Messaging

该包包含OMG CORBA消息传递规范 formal/99-10-07中指定的 Messaging模块。

org.omg.PortableInterceptor

提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。

org.omg.PortableInterceptor.ORBInitInfoPackage

该软件包包含OMG便携式拦截器规范 ptc/2000-08-06第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。

org.omg.PortableServer

提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。

org.omg.PortableServer.CurrentPackage

提供方法实现，访问方法被调用的对象的标识。

org.omg.PortableServer.POAManagerPackage

封装与之相关的POA的处理状态。

org.omg.PortableServer.POAPackage

允许程序员构建可在不同ORB产品之间移植的对象实现。

org.omg.PortableServer.ServantLocatorPackage

提供用于定位仆人的类和接口。

org.omg.stub.java.rmi

包含 java.rmi软件包中出现的远程类型的RMI-IIOP存根。

org.w3c.dom

提供文档对象模型（DOM）的接口。

org.w3c.dom.bootstrap

提供一个工厂获得 DOMImplementation实例。

org.w3c.dom.events

提供DOM Level 2事件的接口。

org.w3c.dom.ls

提供DOM Level 3加载和保存的界面。

org.w3c.dom.ranges

提供DOM Level 2范围的界面。

org.w3c.dom.xpath

提供DOM Level 3 XPath规范的接口。

org.xml.sax

提供核心SAX API。

org.xml.sax.ext

提供与符合SAX驱动程序不一定支持的SAX2设施的接口。

org.xml.sax.helpers

提供帮助类，包括支持引导基于SAX的应用程序。

Uses of Object in com.sun.jarsigner

Subclasses of Object in com.sun.jarsigner

Modifier and Type

Class

描述

class

ContentSigner

已过时。
此类已被弃用。

Uses of Object in com.sun.java.accessibility.util

Subclasses of Object in com.sun.java.accessibility.util

Modifier and Type

Class

描述

class

AccessibilityEventMonitor

AccessibilityEventMonitor在实现Java虚拟机中的接口 Accessible每个UI对象上实现PropertyChange监听器。

class

AccessibilityListenerList

AccessibilityListenerList是Swing EventListerList课程的副本。

class

AWTEventMonitor

AWTEventMonitor实现了一套监听器，它们有条件地安装在Java虚拟机中的每个AWT组件实例上。

class

EventID

EventID包含映射到AWT和Swing中的事件支持的整型常量。

class

EventQueueMonitor

EventQueueMonitor类为辅助技术提供了关键的核心功能（以及需要辅助技术需要的一些相同功能的其他系统级技术）。

class

SwingEventMonitor

SwingEventMonitor通过添加一个有条件地安装在Java虚拟机中的每个Swing组件实例上的监听SwingEventMonitor扩展AWTEventMonitor 。

class

Translator

Translator类为不实现接口Accessible对象提供了一个到接口Accessible的翻译。

Fields in com.sun.java.accessibility.util declared as Object

Modifier and Type

Field

描述

protected Object[]

AccessibilityListenerList.listenerList

侦听器类型列表，侦听器对

protected Object

Translator.source

源对象需要翻译。

Methods in com.sun.java.accessibility.util that return Object

Modifier and Type

方法

描述

Object[]

AccessibilityListenerList.getListenerList​()

将事件侦听器列表作为侦听器类型，侦听器对的数组传回。

Object

Translator.getSource​()

获取 Object的来源 Translator 。

Methods in com.sun.java.accessibility.util with parameters of type Object

Modifier and Type

方法

描述

boolean

Translator.equals​(Object o)

如果此对象与传入的对象相同，则返回true。

static Accessible

Translator.getAccessible​(Object o)

获取实现接口 Accessible的对象。

void

Translator.setSource​(Object o)

设置源对象的 Translator 。

Constructors in com.sun.java.accessibility.util with parameters of type Object

Constructor

描述

Translator​(Object o)

创建一个新的 Translator与源对象o。

Uses of Object in com.sun.javadoc

Subclasses of Object in com.sun.javadoc

Modifier and Type

Class

描述

class

Doclet

已过时。
该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

Methods in com.sun.javadoc that return Object

Modifier and Type

方法

描述

Object

FieldDoc.constantValue​()

已过时。

获取常量字段的值。

Object

AnnotationValue.value​()

已过时。

返回值。

Methods in com.sun.javadoc with parameters of type Object

Modifier and Type

方法

描述

int

Doc.compareTo​(Object obj)

已过时。

将此doc对象与指定的对象进行比较以进行排序。

int

SerialFieldTag.compareTo​(Object obj)

已过时。

将此对象与指定的对象进行比较。

Uses of Object in com.sun.jdi

Subclasses of Object in com.sun.jdi

Modifier and Type

Class

描述

class

AbsentInformationException

抛出以表示行号或变量信息不可用。

class

Bootstrap

提供对JDI接口的默认实现的初始类。

class

ClassNotLoadedException

抛出，表示请求的类尚未通过适当的类加载器加载。

class

ClassNotPreparedException

抛出以指示由于指定的类尚未准备而请求的操作无法完成。

class

IncompatibleThreadStateException

抛出以指示所请求的操作在指定线程处于当前状态时无法完成。

class

InconsistentDebugInfoException

被抛出以表明目标VM提供的调试信息有不一致之处。

class

InternalException

抛出，表示出现意外的内部错误。

class

InvalidCodeIndexException

已过时。
不再抛出此异常

class

InvalidLineNumberException

已过时。
不再抛出此异常

class

InvalidModuleException

抛出以表明所请求的模块在卸载模块后无效或无效。

class

InvalidStackFrameException

抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。

class

InvalidTypeException

抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。

class

InvocationException

抛出以指示目标VM中的调用方法中发生异常。

class

JDIPermission

JDIPermission类代表访问权限 VirtualMachineManager 。

class

NativeMethodException

抛出表示操作无法完成，因为它对本机方法无效。

class

ObjectCollectedException

抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。

class

VMCannotBeModifiedException

抛出以表示操作无效，因为它会修改VM，VM是只读的。

class

VMDisconnectedException

抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。

class

VMMismatchException

抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。

class

VMOutOfMemoryException

抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。

Methods in com.sun.jdi with parameters of type Object

Modifier and Type

方法

描述

boolean

BooleanValue.equals​(Object obj)

将指定的Object与此BooleanValue进行比较以获得相等性。

boolean

ByteValue.equals​(Object obj)

将指定的对象与此ByteValue进行比较以获得相等性。

boolean

CharValue.equals​(Object obj)

将指定的对象与此CharValue进行比较以获得相等性。

boolean

DoubleValue.equals​(Object obj)

将指定的Object与此DoubleValue进行比较以获得相等性。

boolean

Field.equals​(Object obj)

将指定的Object与此字段进行比较以获得相等性。

boolean

FloatValue.equals​(Object obj)

将指定的对象与此FloatValue进行比较以获得相等性。

boolean

IntegerValue.equals​(Object obj)

将指定的Object与此IntegerValue进行比较以获得相等性。

boolean

LocalVariable.equals​(Object obj)

将指定的Object与此LocalVariable进行比较以获得相等性。

boolean

Location.equals​(Object obj)

将指定的对象与此位置进行比较以获得相等性。

boolean

LongValue.equals​(Object obj)

将指定的Object与此LongValue进行比较以获得相等性。

boolean

Method.equals​(Object obj)

将指定的Object与此方法进行比较以实现相等。

boolean

ObjectReference.equals​(Object obj)

将指定的Object与此ObjectReference进行比较以获得相等性。

boolean

ReferenceType.equals​(Object obj)

将指定的Object与此ReferenceType进行比较以获得相等性。

boolean

ShortValue.equals​(Object obj)

将指定的Object与此ShortValue进行比较以获得相等性。

boolean

VoidValue.equals​(Object obj)

将指定的Object与此VoidValue进行比较以获得相等性。

Uses of Object in com.sun.jdi.connect

Subclasses of Object in com.sun.jdi.connect

Modifier and Type

Class

描述

class

IllegalConnectorArgumentsException

抛出表示无效参数或不一致传递给Connector 。

class

TransportTimeoutException

当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。

class

VMStartException

目标VM已成功启动，但在建立连接之前会发生错误。

Uses of Object in com.sun.jdi.connect.spi

Subclasses of Object in com.sun.jdi.connect.spi

Modifier and Type

Class

描述

class

ClosedConnectionException

由于在进行I / O操作时异步关闭Connection ，可能会抛出此异常。

class

Connection

调试器和调试器之间的连接。

class

TransportService

用于调试器和目标VM之间连接的传输服务。

static class

TransportService.Capabilities

运输服务能力。

static class

TransportService.ListenKey

听密钥 。

Uses of Object in com.sun.jdi.request

Subclasses of Object in com.sun.jdi.request

Modifier and Type

Class

描述

class

DuplicateRequestException

抛出以表示重复的事件请求。

class

InvalidRequestStateException

抛出以表示所请求的事件由于启用而无法修改。

Methods in com.sun.jdi.request that return Object

Modifier and Type

方法

描述

Object

EventRequest.getProperty​(Object key)

使用指定的键返回属性的值。

Methods in com.sun.jdi.request with parameters of type Object

Modifier and Type

方法

描述

Object

EventRequest.getProperty​(Object key)

使用指定的键返回属性的值。

void

EventRequest.putProperty​(Object key, Object value)

向此请求添加任意键/值“属性”。

Uses of Object in com.sun.management

Subclasses of Object in com.sun.management

Modifier and Type

Class

描述

class

GarbageCollectionNotificationInfo

有关垃圾收集的信息

class

GcInfo

垃圾收集信息。

class

VMOption

有关VM选项的信息，包括其值，值来自哪里被称为其origin 。

Methods in com.sun.management that return Object

Modifier and Type

方法

描述

Object

GcInfo.get​(String key)

Object[]

GcInfo.getAll​(String[] keys)

Methods in com.sun.management with parameters of type Object

Modifier and Type

方法

描述

boolean

GcInfo.containsValue​(Object value)

boolean

GcInfo.equals​(Object obj)

Uses of Object in com.sun.net.httpserver

Subclasses of Object in com.sun.net.httpserver

Modifier and Type

Class

描述

class

Authenticator

认证者表示HTTP认证机制的实现。

static class

Authenticator.Failure

表示认证失败。

static class

Authenticator.Result

来自authenticate（）方法的返回类型的基类

static class

Authenticator.Retry

表示验证必须重试。

static class

Authenticator.Success

表示认证成功，通过调用getPrincipal（）可以获取已认证的用户主体。

class

BasicAuthenticator

BasicAuthenticator提供HTTP Basic认证的实现。

class

Filter

用于预处理和后处理传入请求的过滤器。

static class

Filter.Chain

与HttpServer关联的一连串过滤器。

class

Headers

HTTP请求和响应头通过此类，它实现接口表示Map < String ， List < String >>。

class

HttpContext

HttpContext表示应用程序的根URI路径与HttpHandler之间的映射，该对象被调用以处理在相关联的HttpServer或HttpsServer上发往该路径的请求。

class

HttpExchange

此类封装了收到的HTTP请求和在一个交换中生成的响应。

class

HttpPrincipal

表示通过HTTP Basic或Digest身份验证身份验证的用户。

class

HttpsConfigurator

此类用于配置HttpsServer上每个传入https连接的https参数。

class

HttpServer

这个类实现了一个简单的HTTP服务器。

class

HttpsExchange

此类封装了收到的HTTPS请求和在一个交换中生成的响应，并定义了特定于HTTPS协议的HttpExchange扩展。

class

HttpsParameters

表示与客户端协商的每个https连接的参数集。

class

HttpsServer

此类是HttpServer的扩展，它为HTTPS提供支持。

Methods in com.sun.net.httpserver that return Object

Modifier and Type

方法

描述

abstract Object

HttpExchange.getAttribute​(String name)

过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。

Methods in com.sun.net.httpserver that return types with arguments of type Object

Modifier and Type

方法

描述

abstract Map<String,Object>

HttpContext.getAttributes​()

返回一个可变的Map，可以将配置和其他数据传递给Filter模块和上下文的交换处理程序。

Methods in com.sun.net.httpserver with parameters of type Object

Modifier and Type

方法

描述

boolean

Headers.containsKey​(Object key)

boolean

Headers.containsValue​(Object value)

boolean

Headers.equals​(Object o)

boolean

HttpPrincipal.equals​(Object another)

比较两个HttpPrincipal。

List<String>

Headers.get​(Object key)

List<String>

Headers.remove​(Object key)

abstract void

HttpExchange.setAttribute​(String name, Object value)

过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。

Uses of Object in com.sun.net.httpserver.spi

Subclasses of Object in com.sun.net.httpserver.spi

Modifier and Type

Class

描述

class

HttpServerProvider

HttpServer的服务提供者类。

Uses of Object in com.sun.nio.sctp

Subclasses of Object in com.sun.nio.sctp

Modifier and Type

Class

描述

class

AbstractNotificationHandler<T>

消耗通知并继续的骨架处理程序。

class

Association

表示SCTP关联的类。

class

AssociationChangeNotification

关联已打开或关闭时发出的通知。

class

IllegalReceiveException

当试图调用未经检查的异常receive的方法SctpChannel或SctpMultiChannel从通知处理程序。

class

IllegalUnbindException

尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。

class

InvalidStreamException

尝试将消息发送到无效流时抛出未检查的异常。

class

MessageInfo

MessageInfo课程提供了有关消息的其他辅助信息。

class

PeerAddressChangeNotification

多宿主对等体上的目标地址发生更改时发出的通知。

class

SctpChannel

用于面向消息的连接SCTP套接字的可选通道。

class

SctpMultiChannel

用于面向消息的SCTP套接字的可选通道。

class

SctpServerChannel

用于面向消息的侦听SCTP插座的可选通道。

class

SctpStandardSocketOptions

SCTP通道支持此类定义的套接字选项（以及特定通道类中列出的套接字选项），并且可以支持额外的实现特定套接字选项。

static class

SctpStandardSocketOptions.InitMaxStreams

此类用于设置关联初始化期间本地端点使用的入站/出站流的最大数量。

class

SendFailedNotification

收到发送失败通知时发出的通知。

class

ShutdownNotification

当对等体关闭关联时发出的通知。

Methods in com.sun.nio.sctp with parameters of type Object

Modifier and Type

方法

描述

boolean

SctpStandardSocketOptions.InitMaxStreams.equals​(Object obj)

如果指定的对象是具有相同数量的进出流绑定流的另一个 InitMaxStreams实例，则返回true。

Uses of Object in com.sun.security.auth

Subclasses of Object in com.sun.security.auth

Modifier and Type

Class

描述

class

LdapPrincipal

由 RFC 2253指定的专有名称确定的 主体 。

class

NTDomainPrincipal

此类实现 Principal接口，并表示用户认证的Windows NT域的名称。

class

NTNumericCredential

该类抽象出一个NT安全性令牌，并提供了一种进行相同进程安全模拟的机制。

class

NTSid

该类实现了 Principal接口，并表示有关Windows NT用户，组或领域的信息。

class

NTSidDomainPrincipal

该类扩展了 NTSid ，代表Windows NT用户的域SID。

class

NTSidGroupPrincipal

此类扩展为 NTSid并表示Windows NT用户所属的组之一。

class

NTSidPrimaryGroupPrincipal

此类扩展为 NTSid ，表示Windows NT用户的主组SID。

class

NTSidUserPrincipal

此类扩展为 NTSid ，表示Windows NT用户的SID。

class

NTUserPrincipal

该类实现了 Principal接口，代表了Windows NT用户。

class

PolicyFile

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由sun.security.provider.PolicyFile取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

class

SolarisNumericGroupPrincipal

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由UnixNumericGroupPrincipal取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

class

SolarisNumericUserPrincipal

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由UnixNumericUserPrincipal取代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

class

SolarisPrincipal

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK 1.4，由UnixPrincipal替代。 这个类完全被弃用了。 此类可能在将来的Java SE版本中被删除。

class

UnixNumericGroupPrincipal

该类实现了 Principal接口，代表用户的Unix组标识号（GID）。

class

UnixNumericUserPrincipal

该类实现了 Principal接口，代表用户的Unix标识号（UID）。

class

UnixPrincipal

该类实现了 Principal接口，代表了Unix用户。

class

UserPrincipal

由用户名或帐户名称标识的用户主体。

class

X500Principal

不推荐用于删除：此API元素将在以后的版本中被删除。
Java平台中提供了一个新的X500Principal类。 这个X500Principal类完全被弃用，这里允许平滑过渡到新类。 此类可能在将来的Java SE版本中被删除。

Methods in com.sun.security.auth with parameters of type Object

Modifier and Type

方法

描述

boolean

LdapPrincipal.equals​(Object object)

将此主体与指定对象进行比较。

boolean

NTDomainPrincipal.equals​(Object o)

将指定的对象与此 NTDomainPrincipal进行比较以获得相等性。

boolean

NTNumericCredential.equals​(Object o)

将指定的对象与此 NTNumericCredential进行比较以获得相等性。

boolean

NTSid.equals​(Object o)

将指定的对象与此 NTSid进行比较以获得相等性。

boolean

NTSidDomainPrincipal.equals​(Object o)

将指定的对象与此 NTSidDomainPrincipal进行比较以获得相等性。

boolean

NTSidGroupPrincipal.equals​(Object o)

将指定的对象与此 NTSidGroupPrincipal进行比较以获得相等性。

boolean

NTSidPrimaryGroupPrincipal.equals​(Object o)

将指定的对象与此 NTSidPrimaryGroupPrincipal进行比较以获得相等性。

boolean

NTSidUserPrincipal.equals​(Object o)

将指定的对象与此 NTSidUserPrincipal进行比较以获得相等性。

boolean

NTUserPrincipal.equals​(Object o)

将指定的对象与此 NTUserPrincipal进行比较以获得相等性。

boolean

SolarisNumericGroupPrincipal.equals​(Object o)

不推荐用于删除：此API元素将在以后的版本中被删除。

将指定的对象与此 SolarisNumericGroupPrincipal进行比较以获得相等性。

boolean

SolarisNumericUserPrincipal.equals​(Object o)

不推荐用于删除：此API元素将在以后的版本中被删除。

将指定的对象与此 SolarisNumericUserPrincipal进行比较以获得相等性。

boolean

SolarisPrincipal.equals​(Object o)

不推荐用于删除：此API元素将在以后的版本中被删除。

将指定的对象与此 SolarisPrincipal进行比较以获得相等性。

boolean

UnixNumericGroupPrincipal.equals​(Object o)

将指定的对象与此 UnixNumericGroupPrincipal进行比较以获得相等性。

boolean

UnixNumericUserPrincipal.equals​(Object o)

将指定的对象与此 UnixNumericUserPrincipal进行比较以获得相等性。

boolean

UnixPrincipal.equals​(Object o)

将指定的对象与此 UnixPrincipal进行比较以获得相等性。

boolean

UserPrincipal.equals​(Object object)

将此主体与指定对象进行比较。

boolean

X500Principal.equals​(Object o)

不推荐用于删除：此API元素将在以后的版本中被删除。

将指定的对象与此 X500Principal进行比较以获得相等性。

Uses of Object in com.sun.security.auth.callback

Subclasses of Object in com.sun.security.auth.callback

Modifier and Type

Class

描述

class

TextCallbackHandler

从命令行提示并读取认证问题的答案。

Uses of Object in com.sun.security.auth.login

Subclasses of Object in com.sun.security.auth.login

Modifier and Type

Class

描述

class

ConfigFile

此类表示 javax.security.auth.login.Configuration的默认实现。

Uses of Object in com.sun.security.auth.module

Subclasses of Object in com.sun.security.auth.module

Modifier and Type

Class

描述

class

JndiLoginModule

模块提示输入用户名和密码，然后根据存储在JNDI下配置的目录服务中的密码验证密码。

class

KeyStoreLoginModule

提供一个JAAS登录模块，提示密钥存储别名，并使用别名的主体和凭据填充主题。

class

Krb5LoginModule

此 LoginModule使用Kerberos协议对用户进行身份验证。

class

LdapLoginModule

此LoginModule执行基于LDAP的身份验证。

class

NTLoginModule

这个 LoginModule将用户的NT安全信息呈现为 Principal的一些数字， Principal其与 Subject相关联。

class

NTSystem

此类实现检索并为当前用户提供可用的NT安全信息。

class

SolarisLoginModule

不推荐用于删除：此API元素将在以后的版本中被删除。
截至JDK1.4，由com.sun.security.auth.module.UnixLoginModule取代。 这个LoginModule已经完全被废弃了，这里允许平滑过渡到新的UnixLoginModule。 此类可能在将来的Java SE版本中被删除。

class

SolarisSystem

不推荐用于删除：此API元素将在以后的版本中被删除。
代之以UnixSystem 。 此类可能在将来的Java SE版本中被删除。

class

UnixLoginModule

这 LoginModule导入用户的Unix Principal信息（ UnixPrincipal ， UnixNumericUserPrincipal ，并 UnixNumericGroupPrincipal ），并与当前的关联 Subject 。

class

UnixSystem

此类实现检索并提供当前用户的Unix UID / GID /组信息。

Uses of Object in com.sun.security.jgss

Subclasses of Object in com.sun.security.jgss

Modifier and Type

Class

描述

class

AuthorizationDataEntry

Kerberos 5 AuthorizationData条目。

class

GSSUtil

GSS-API实用程序与Sun Microsystem的Java GSS-API实现结合使用。

class

InquireSecContextPermission

此类用于保护可以使用 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)方法访问的已建立GSS安全上下文的各种属性。

Methods in com.sun.security.jgss that return Object

Modifier and Type

方法

描述

Object

ExtendedGSSContext.inquireSecContext​(InquireType type)

返回与 type相关联的机制特定属性。

Uses of Object in com.sun.source.tree

Methods in com.sun.source.tree that return Object

Modifier and Type

方法

描述

Object

LiteralTree.getValue​()

返回文字表达式的值。

Uses of Object in com.sun.source.util

Subclasses of Object in com.sun.source.util

Modifier and Type

Class

描述

class

DocTreePath

树节点的路径，通常用于表示直到顶层DocCommentTree节点的树节点的祖先节点序列。

class

DocTreePathScanner<R,P>

访问所有子树节点的DocTreeVisitor，并为维护父节点的路径提供支持。

class

DocTrees

提供对文档注释的语法树的访问。

class

DocTreeScanner<R,P>

访问所有子树节点的TreeVisitor。

class

JavacTask

提供对JDK Java编译器javac特有的功能的访问。

class

SimpleDocTreeVisitor<R,P>

树节点的简单访问者。

class

SimpleTreeVisitor<R,P>

树节点的简单访问者。

class

TaskEvent

提供有关JDK Java Compiler（javac）完成的工作的详细信息。

class

TreePath

树节点的路径，通常用于表示树节点的祖先节点的序列，直到顶层的CompilationUnitTree节点。

class

TreePathScanner<R,P>

一个访问所有子树节点的TreeVisitor，并为维护父节点的路径提供支持。

class

Trees

Bridges JSR 199，JSR 269和Tree API。

class

TreeScanner<R,P>

访问所有子树节点的TreeVisitor。

Fields in com.sun.source.util declared as Object

Modifier and Type

Field

描述

protected R

SimpleDocTreeVisitor.DEFAULT_VALUE

默认值，由 default action返回。

protected R

SimpleTreeVisitor.DEFAULT_VALUE

默认值，由 default action返回。

Uses of Object in com.sun.tools.attach

Subclasses of Object in com.sun.tools.attach

Modifier and Type

Class

描述

class

AgentInitializationException

当代理程序无法在目标Java虚拟机中初始化时抛出异常。

class

AgentLoadException

代理无法加载到目标Java虚拟机时抛出的异常。

class

AttachNotSupportedException

当尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。

class

AttachOperationFailedException

异常类型表示目标虚拟机中附着操作失败。

class

AttachPermission

当一个SecurityManager集合，这是当代码调用VirtalMachine.attach附加到目标虚拟机时将被检查的权限。

class

VirtualMachine

Java虚拟机。

class

VirtualMachineDescriptor

描述一个Java虚拟机。

Methods in com.sun.tools.attach with parameters of type Object

Modifier and Type

方法

描述

boolean

VirtualMachine.equals​(Object ob)

测试此VirtualMachine与另一个对象的相等性。

boolean

VirtualMachineDescriptor.equals​(Object ob)

测试此VirtualMachineDescriptor与其他对象的相等性。

Uses of Object in com.sun.tools.attach.spi

Subclasses of Object in com.sun.tools.attach.spi

Modifier and Type

Class

描述

class

AttachProvider

附加提供程序类以附加到Java虚拟机。

Uses of Object in com.sun.tools.doclets.standard

Subclasses of Object in com.sun.tools.doclets.standard

Modifier and Type

Class

描述

class

Standard

不推荐用于删除：此API元素将在以后的版本中被删除。
该文件已被替换， StandardDoclet取代。

Uses of Object in com.sun.tools.javac

Subclasses of Object in com.sun.tools.javac

Modifier and Type

Class

描述

class

Main

Java编程语言编译器javac的遗留编程接口。

Uses of Object in com.sun.tools.javadoc

Subclasses of Object in com.sun.tools.javadoc

Modifier and Type

Class

描述

class

Main

已过时。
此类现在已被弃用，可能会在将来的版本中删除。 有关替换功能，请参见javax.tools.ToolProvider::getSystemDocumentationTool和javax.tools.DocumentationTool 。

Uses of Object in com.sun.tools.jconsole

Subclasses of Object in com.sun.tools.jconsole

Modifier and Type

Class

描述

class

JConsolePlugin

一个JConsole插件类。

Uses of Object in java.applet

Subclasses of Object in java.applet

Modifier and Type

Class

描述

class

Applet

已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

protected class

Applet.AccessibleApplet

已过时。

这个类实现 Applet类的可访问性支持。

Uses of Object in java.awt

Subclasses of Object in java.awt

Modifier and Type

Class

描述

class

AlphaComposite

AlphaComposite类实现了基本的alpha合成规则，用于组合源和目标颜色，以实现图形和图像的混合和透明效果。

class

AWTError

当出现严重的抽象窗口工具包错误时抛出。

class

AWTEvent

所有AWT事件的根事件类。

class

AWTEventMulticaster

AWTEventMulticaster为 java.awt.event包中定义的AWT事件实现高效和线程安全的多播事件调度。

class

AWTException

表示发生抽象窗口工具包异常。

class

AWTKeyStroke

AWTKeyStroke表示键盘或等效输入设备上的关键操作。

class

AWTPermission

此类用于AWT权限。

class

BasicStroke

BasicStroke类为图形基元的轮廓定义了一组基本的渲染属性，这些属性用一个Graphics2D对象渲染，该对象的Stroke属性设置为BasicStroke 。

class

BorderLayout

边界布局设置了一个容器，安排和调整其组件，以适应五个区域：北，南，东，西和中心。

class

BufferCapabilities

缓冲区的功能和属性。

static class

BufferCapabilities.FlipContents

页面翻转后可能的反向缓冲区内容的类型安全枚举

class

Button

这个类创建一个标记的按钮。

protected class

Button.AccessibleAWTButton

这个类实现 Button类的可访问性支持。

class

Canvas

Canvas组件表示应用程序可以绘制的屏幕的空白矩形区域，或者应用程序可以从中捕获来自用户的输入事件。

protected class

Canvas.AccessibleAWTCanvas

这个类实现 Canvas类的可访问性支持。

class

CardLayout

一个 CardLayout对象是一个容器的布局管理器。

class

Checkbox

复选框是可以处于“开”（ true ）或“关”（ false ）状态的图形组件。

protected class

Checkbox.AccessibleAWTCheckbox

这个类实现 Checkbox类的可访问性支持。

class

CheckboxGroup

CheckboxGroup类用于组合一组 Checkbox按钮。

class

CheckboxMenuItem

此类表示可以包含在菜单中的复选框。

protected class

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

用于提供对辅助功能的默认支持的CheckboxMenuItem的内部类。

class

Choice

Choice课程提供了一个弹出菜单的选择。

protected class

Choice.AccessibleAWTChoice

这个类实现 Choice类的可访问性支持。

class

Color

Color类用于将颜色封装在默认的sRGB颜色空间中，或由ColorSpace标识的任意颜色空间中的颜色。

class

Component

组件是具有可以在屏幕上显示并且可以与用户交互的图形表示的对象。

protected class

Component.AccessibleAWTComponent

组件的内部类用于为辅助功能提供默认支持。

protected class

Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

Fire PropertyChange监听器，如果已注册，显示/隐藏..

protected class

Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

Fire PropertyChange监听器，如果有注册，焦点事件发生时

protected class

Component.BltBufferStrategy

内部类别将屏幕外表面喷涂到组件上。

protected class

Component.FlipBufferStrategy

内部类用于在组件上翻转缓冲区。

class

ComponentOrientation

ComponentOrientation类封装了用于对组件或文本的元素进行排序的语言敏感方向。

class

Container

通用抽象窗口工具包（AWT）容器对象是可以包含其他AWT组件的组件。

protected class

Container.AccessibleAWTContainer

Container的内部类用于为辅助功能提供默认支持。

protected class

Container.AccessibleAWTContainer.AccessibleContainerHandler

消防 PropertyChange听众，如果有人注册，当孩子被添加或删除。

class

ContainerOrderFocusTraversalPolicy

FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。

class

Cursor

封装鼠标光标位图表示的类。

class

DefaultFocusTraversalPolicy

FocusTraversalPolicy根据容器中子组件的顺序确定遍历顺序。

class

DefaultKeyboardFocusManager

用于AWT应用程序的默认KeyboardFocusManager。

class

Desktop

Desktop类允许与各种桌面功能进行交互。

class

Dialog

Dialog是一个具有标题和边框的顶级窗口，通常用于从用户处采取某种形式的输入。

protected class

Dialog.AccessibleAWTDialog

这个类实现 Dialog类的可访问性支持。

class

Dimension

Dimension类封装单个对象中组件的宽度和高度（以整数精度）。

class

DisplayMode

所述 DisplayMode类封装的位深度，高度，宽度，和刷新速率 GraphicsDevice 。

class

Event

已过时。
建议使用AWTEvent及其子类

class

EventQueue

EventQueue是一个与平台无关的类，可以从基础对等类和可信应用程序类排队事件。

class

FileDialog

FileDialog类显示一个对话窗口，用户可以从中选择一个文件。

class

FlowLayout

流程布局将组件布置在定向流中，与段落中的文本行类似。

class

FocusTraversalPolicy

FocusTraversalPolicy定义了遍历特定焦点循环根的组件的顺序。

class

Font

Font类表示字体，用于以可见的方式呈现文本。

class

FontFormatException

在 Font类中通过 Font方法抛出，以指示指定的字体不好。

class

FontMetrics

FontMetrics类定义了一个字体度量对象，它将特定字体的渲染信息封装在特定的屏幕上。

class

Frame

A Frame是具有标题和边框的顶级窗口。

protected class

Frame.AccessibleAWTFrame

这个类实现 Frame类的可访问性支持。

class

GradientPaint

GradientPaint课程提供了一种以线性颜色渐变模式填充Shape的方法。

class

Graphics

Graphics类是所有图形上下文的抽象基类，允许应用程序绘制在各种设备上实现的组件，以及到屏幕外图像上。

class

Graphics2D

这个Graphics2D类扩展了Graphics类，以提供对几何，坐标变换，颜色管理和文本布局的更复杂的控制。

class

GraphicsConfigTemplate

GraphicsConfigTemplate类用于获取有效的GraphicsConfiguration 。

class

GraphicsConfiguration

GraphicsConfiguration类描述了诸如打印机或显示器之类的图形目的地的特征。

class

GraphicsDevice

GraphicsDevice类描述了在特定图形环境中可能可用的图形设备。

class

GraphicsEnvironment

GraphicsEnvironment类描述了可用于特定平台上的Java（tm）应用程序的GraphicsDevice对象和Font对象的集合。

class

GridBagConstraints

GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。

class

GridBagLayout

GridBagLayout类是一种灵活的布局管理器，可以垂直，水平或沿其基准对齐组件，而不需要组件的大小相同。

class

GridBagLayoutInfo

GridBagLayoutInfo是 GridBagLayout布局管理器的实用程序类。

class

GridLayout

GridLayout类是一个布局管理器，它将一个容器的组件放在一个矩形网格中。

class

HeadlessException

在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。

class

IllegalComponentStateException

表示AWT组件对于请求的操作不在适当的状态。

class

Image

抽象类 Image是表示图形图像的所有类的超类。

class

ImageCapabilities

图像的能力和属性。

class

Insets

一个 Insets对象是容器边框的表示。

class

JobAttributes

一组控制打印作业的属性。

static class

JobAttributes.DefaultSelectionType

可能的默认选择状态的类型安全枚举。

static class

JobAttributes.DestinationType

可能的工作目的地的类型安全枚举。

static class

JobAttributes.DialogType

可以显示给用户的可能对话框的类型安全枚举。

static class

JobAttributes.MultipleDocumentHandlingType

可能的多重复制处理状态的类型安全枚举。

static class

JobAttributes.SidesType

可能的多页面强制的类型安全枚举。

class

KeyboardFocusManager

KeyboardFocusManager负责管理主动和关注的Windows以及当前焦点所有者。

class

Label

Label对象是用于将文本放置在容器中的组件。

protected class

Label.AccessibleAWTLabel

这个类实现 Label类的辅助功能支持。

class

LinearGradientPaint

LinearGradientPaint课程提供了一种以线性颜色渐变模式填充Shape的方法。

class

List

List组件向用户显示文本项目的滚动列表。

protected class

List.AccessibleAWTList

这个类实现 List类的可访问性支持。

protected class

List.AccessibleAWTList.AccessibleAWTListChild

此类实现对List子项的可访问性支持。

class

MediaTracker

MediaTracker类是用于跟踪多个媒体对象的状态的实用类。

class

Menu

Menu对象是从菜单栏部署的下拉菜单组件。

protected class

Menu.AccessibleAWTMenu

菜单的内部类用于提供对辅助功能的默认支持。

class

MenuBar

MenuBar类封装了平台与框架绑定的菜单栏的概念。

protected class

MenuBar.AccessibleAWTMenuBar

MenuBar的内部类用于为辅助功能提供默认支持。

class

MenuComponent

抽象类 MenuComponent是所有菜单相关组件的超类。

protected class

MenuComponent.AccessibleAWTMenuComponent

内部类别 MenuComponent用于为辅助功能提供默认支持。

class

MenuItem

菜单中的所有项目必须属于类别 MenuItem或其子类之一。

protected class

MenuItem.AccessibleAWTMenuItem

MenuItem的内部类用于为辅助功能提供默认支持。

class

MenuShortcut

MenuShortcut类代表一个MenuItem的键盘加速器。

class

MouseInfo

MouseInfo提供了获取鼠标信息的方法，如鼠标指针位置和鼠标按键数量。

class

MultipleGradientPaint

这是Paints的超类，它使用多色渐变填充其栅格。

class

PageAttributes

一组控制打印页面输出的属性。

static class

PageAttributes.ColorType

可能的颜色状态的类型安全枚举。

static class

PageAttributes.MediaType

可能的纸张尺寸的类型安全枚举。

static class

PageAttributes.OrientationRequestedType

可能的方向的类型安全的枚举。

static class

PageAttributes.OriginType

可能来源的类型安全枚举。

static class

PageAttributes.PrintQualityType

可能的打印质量的类型安全枚举。

class

Panel

Panel是最简单的容器类。

protected class

Panel.AccessibleAWTPanel

这个类实现 Panel类的可访问性支持。

class

Point

一个点代表 (x,y)坐标空间中的一个位置，以整数精度指定。

class

PointerInfo

描述指针位置的类。

class

Polygon

Polygon类封装了坐标空间内封闭的二维区域的描述。

class

PopupMenu

一个实现菜单的类，可以在组件中的指定位置动态弹出菜单。

protected class

PopupMenu.AccessibleAWTPopupMenu

PopupMenu的内部类用于提供对辅助功能的默认支持。

class

PrintJob

一个启动和执行打印作业的抽象类。

class

RadialGradientPaint

RadialGradientPaint课程提供了一种填充圆形径向颜色渐变图案的形状的方式。

class

Rectangle

A Rectangle指定坐标空间中由坐标空间中的 Rectangle对象的左上点 (x,y)的区域，其宽度及其高度。

class

RenderingHints

RenderingHints类定义和管理密钥和关联值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。

static class

RenderingHints.Key

定义与RenderingHints类一起使用的所有键的基本类型，以控制渲染和成像管道中的各种算法选择。

class

Robot

此类用于生成本机系统输入事件，用于测试自动化，自动运行演示和需要鼠标和键盘控制的其他应用程序。

class

Scrollbar

Scrollbar类体现了一个滚动条，一个熟悉的用户界面对象。

protected class

Scrollbar.AccessibleAWTScrollBar

该类实现 Scrollbar类的可访问性支持。

class

ScrollPane

一个容器类，用于实现单个子组件的自动水平和/或垂直滚动。

protected class

ScrollPane.AccessibleAWTScrollPane

这个类实现 ScrollPane类的可访问性支持。

class

ScrollPaneAdjustable

该类表示 ScrollPane的水平或垂直滚动条的 ScrollPane 。

class

SplashScreen

在Java虚拟机（JVM）启动之前，启动屏幕可以在应用程序启动时显示。

class

SystemColor

封装代表系统上本地GUI对象颜色的符号颜色的类。

class

SystemTray

SystemTray类代表桌面的系统托盘。

class

Taskbar

Taskbar类允许Java应用程序与系统任务区（任务栏，Dock等）进行交互。

class

TextArea

一个 TextArea对象是一个显示文本的多行区域。

protected class

TextArea.AccessibleAWTTextArea

这个类实现 TextArea类的可访问性支持。

class

TextComponent

TextComponent类是允许编辑某些文本的任何组件的超类。

protected class

TextComponent.AccessibleAWTTextComponent

这个类实现 TextComponent类的可访问性支持。

class

TextField

TextField对象是允许编辑单行文本的文本组件。

protected class

TextField.AccessibleAWTTextField

该类为 TextField类实现可访问性支持。

class

TexturePaint

TexturePaint类提供了一种填充Shape的方法 ，该纹理指定为BufferedImage 。

class

Toolkit

这个类是抽象窗口工具包的所有实际实现的抽象超类。

class

TrayIcon

TrayIcon对象表示可以添加到system tray的托盘图标。

class

Window

一个 Window对象是没有边框的顶级窗口，没有菜单。

protected class

Window.AccessibleAWTWindow

这个类实现 Window类的可访问性支持。

Fields in java.awt declared as Object

Modifier and Type

Field

描述

Object

Event.arg

已过时。

事件的任意论证。

Object

Event.target

已过时。

目标组件。

static Object

Image.UndefinedProperty

每当获取未为特定图像定义的属性时，应返回 UndefinedProperty对象。

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_DEFAULT

Alpha插值提示值 - alpha混合算法由实现选择，以实现性能与质量的良好折衷。

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_QUALITY

选择Alpha插值提示值 - alpha混合算法，偏好精度和视觉质量。

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_SPEED

选择Alpha插值提示值 - alpha混合算法，优先于计算速度。

static Object

RenderingHints.VALUE_ANTIALIAS_DEFAULT

抗锯齿提示值 - 使用实现选择的默认抗锯齿模式进行渲染。

static Object

RenderingHints.VALUE_ANTIALIAS_OFF

抗锯齿提示值 - 渲染完成时没有抗锯齿。

static Object

RenderingHints.VALUE_ANTIALIAS_ON

抗混叠提示值 - 使用抗锯齿来实现渲染。

static Object

RenderingHints.VALUE_COLOR_RENDER_DEFAULT

显色渲染提示值 - 执行颜色转换计算，以表示性能和精度之间的最佳可用权衡。

static Object

RenderingHints.VALUE_COLOR_RENDER_QUALITY

显色提示值 - 以最高的精度和视觉质量执行颜色转换计算。

static Object

RenderingHints.VALUE_COLOR_RENDER_SPEED

显色提示值 - 执行最快的颜色转换为输出设备的格式。

static Object

RenderingHints.VALUE_DITHER_DEFAULT

抖动提示值 - 使用实现选择的抖动的默认值。

static Object

RenderingHints.VALUE_DITHER_DISABLE

抖动提示值 - 渲染几何时不要抖动。

static Object

RenderingHints.VALUE_DITHER_ENABLE

抖动提示值 - 如果需要，渲染几何时，抖动。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_DEFAULT

字体分数度量提示值 - 字符字形按照实现选择的精度进行定位。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_OFF

字体分数度量提示值 - 字符字形以先进宽度定位，四舍五入到像素边界。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_ON

字体分数度量提示值 - 字符字形以子像素精度定位。

static Object

RenderingHints.VALUE_INTERPOLATION_BICUBIC

插值提示值 - 使用 X和 Y的立方函数对图像中9个附近整数坐标样本的颜色样本进行插值，以生成颜色样本。

static Object

RenderingHints.VALUE_INTERPOLATION_BILINEAR

插值提示值 - 图像中最近邻近4个整数坐标样本的颜色样本被线性内插以产生颜色样本。

static Object

RenderingHints.VALUE_INTERPOLATION_NEAREST_NEIGHBOR

插值提示值 - 使用图像中最近的相邻整数坐标样本的颜色样本。

static Object

RenderingHints.VALUE_RENDER_DEFAULT

渲染提示值 - 渲染算法由实现选择，以实现性能与质量的良好折衷。

static Object

RenderingHints.VALUE_RENDER_QUALITY

渲染提示值 - 选择渲染算法以优化输出质量。

static Object

RenderingHints.VALUE_RENDER_SPEED

渲染提示值 - 选择渲染算法以优先输出速度。

static Object

RenderingHints.VALUE_RESOLUTION_VARIANT_BASE

图像分辨率变体提示值 - 始终使用图像的标准分辨率。

static Object

RenderingHints.VALUE_RESOLUTION_VARIANT_DEFAULT

图像分辨率变体提示值 - 基于可能依赖于平台策略的默认启发式来选择图像分辨率变体

static Object

RenderingHints.VALUE_RESOLUTION_VARIANT_DPI_FIT

图像分辨率变体提示值 - 仅基于屏幕的DPI选择图像分辨率变体。

static Object

RenderingHints.VALUE_RESOLUTION_VARIANT_SIZE_FIT

图像分辨率变体提示值 - 基于屏幕的DPI和Graphics2D上下文中的变换来选择图像分辨率变体。

static Object

RenderingHints.VALUE_STROKE_DEFAULT

笔画归一化控制提示值 - 几何可能被修改或者保留为纯粹，取决于给定实现中的权衡。

static Object

RenderingHints.VALUE_STROKE_NORMALIZE

笔画归一化控制提示值 - 几何应归一化，以提高线条的均匀性或间距以及整体美感。

static Object

RenderingHints.VALUE_STROKE_PURE

笔画归一化控制提示值 - 几何应保持未修改，并以亚像素精度呈现。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_DEFAULT

文本抗锯齿提示值 - 文本渲染是根据 RenderingHints.KEY_ANTIALIASING提示或实现选择的默认来完成的。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_GASP

文本抗锯齿提示值 - 请求文本呈现以使用字体资源中的信息，为每个点大小指定是否应用 RenderingHints.VALUE_TEXT_ANTIALIAS_ON或 RenderingHints.VALUE_TEXT_ANTIALIAS_OFF 。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_HBGR

文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照B，G，R的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HBGR）的三倍， 。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_HRGB

文本抗锯齿提示值 - 要求显示的文本被优化为具有子像素的LCD显示，按照R，G，B的显示从左到右的顺序显示，使得水平子像素分辨率是全像素水平分辨率（HRGB）的三倍， 。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_VBGR

文本抗锯齿提示值 - 要求显示的文本被优化为具有从B，G，R的显示器顶部到底部的子像素组织的LCD显示，使得垂直子像素分辨率是全像素垂直分辨率（VBGR）的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_VRGB

文本抗锯齿提示值 - 要求文本显示优化为具有子像素组织的液晶显示器，从R，G，B的显示顶部到底部，使得垂直子像素分辨率是全像素垂直分辨率（VRGB）的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_OFF

文本抗锯齿提示值 - 文本呈现没有任何形式的抗锯齿。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_ON

文本抗锯齿提示值 - 文本渲染是通过某种形式的抗锯齿来完成的。

Fields in java.awt with type parameters of type Object

Modifier and Type

Field

描述

protected Map<String,Object>

Toolkit.desktopProperties

桌面属性。

Methods in java.awt that return Object

Modifier and Type

方法

描述

Object

BufferCapabilities.clone​()

Object

GridBagConstraints.clone​()

创建此网格包约束的副本。

Object

ImageCapabilities.clone​()

Object

Insets.clone​()

创建此对象的副本。

Object

JobAttributes.clone​()

创建并返回此 JobAttributes的副本。

Object

PageAttributes.clone​()

创建并返回此PageAttributes的副本。

Object

RenderingHints.clone​()

创建此的克隆 RenderingHints具有相同的内容，因为这对象 RenderingHints对象。

Object

RenderingHints.get​(Object key)

返回指定键映射到的值。

Object

BorderLayout.getConstraints​(Component comp)

获取指定组件的约束

Object

Toolkit.getDesktopProperty​(String propertyName)

获取指定的桌面属性的值。

Object[]

MediaTracker.getErrorsAny​()

返回遇到错误的所有介质的列表。

Object[]

MediaTracker.getErrorsID​(int id)

返回具有遇到错误的指定ID的介质列表。

abstract Object

Image.getProperty​(String name, ImageObserver observer)

通过名称获取此图像的属性。

abstract Object

Graphics2D.getRenderingHint​(RenderingHints.Key hintKey)

返回渲染算法的单个首选项的值。

Object[]

Checkbox.getSelectedObjects​()

返回一个包含复选框标签的数组（长度1），如果未选中该复选框，则返回null。

Object[]

CheckboxMenuItem.getSelectedObjects​()

返回包含复选框菜单项标签的数组（长度1），如果未选中复选框，则返回null。

Object[]

Choice.getSelectedObjects​()

返回一个包含当前所选项目的数组（长度1）。

Object[]

ItemSelectable.getSelectedObjects​()

如果没有选择项目，则返回所选项目或 null 。

Object[]

List.getSelectedObjects​()

在对象数组中获取此滚动列表中选定的项目。

Object

Component.getTreeLock​()

获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。

protected Object

MenuComponent.getTreeLock​()

获取AWT组件树和布局操作的此组件的锁定对象（拥有线程同步监视器的对象）。

protected Object

Toolkit.lazilyLoadDesktopProperty​(String name)

懒惰评估桌面属性值的机会。

Object

RenderingHints.put​(Object key, Object value)

将指定的 key映射到此 RenderingHints对象中指定的 value 。

protected Object

AWTKeyStroke.readResolve​()

返回的缓存实例 AWTKeyStroke （或子类 AWTKeyStroke ），这是此实例相等。

Object

RenderingHints.remove​(Object key)

从这个 RenderingHints对象中删除键及其对应的值。

Methods in java.awt that return types with arguments of type Object

Modifier and Type

方法

描述

Set<Map.Entry<Object,Object>>

RenderingHints.entrySet​()

返回此 RenderingHints包含的映射的 Set视图。

Set<Map.Entry<Object,Object>>

RenderingHints.entrySet​()

返回此 RenderingHints包含的映射的 Set视图。

Set<Object>

RenderingHints.keySet​()

返回 Set视图包含在这个按键的 RenderingHints 。

Collection<Object>

RenderingHints.values​()

返回 Collection视图包含在这个值的 RenderingHints 。

Methods in java.awt with parameters of type Object

Modifier and Type

方法

描述

boolean

Component.action​(Event evt, Object what)

已过时。
从JDK 1.1版开始，应该在组件上注册此组件作为ActionListener，该组件将触发动作事件。

void

Container.add​(Component comp, Object constraints)

将指定的组件添加到此容器的末尾。

void

Container.add​(Component comp, Object constraints, int index)

将指定的组件添加到指定索引处的指定约束的容器中。

protected void

Container.addImpl​(Component comp, Object constraints, int index)

在指定的索引处将指定的组件添加到此容器。

protected void

ScrollPane.addImpl​(Component comp, Object constraints, int index)

将指定的组件添加到此滚动窗格容器。

void

BorderLayout.addLayoutComponent​(Component comp, Object constraints)

使用指定的约束对象将指定的组件添加到布局。

void

CardLayout.addLayoutComponent​(Component comp, Object constraints)

将指定的组件添加到此卡布局的内部名称表中。

void

GridBagLayout.addLayoutComponent​(Component comp, Object constraints)

使用指定的 constraints对象将指定的组件添加到布局。

void

LayoutManager2.addLayoutComponent​(Component comp, Object constraints)

使用指定的约束对象将指定的组件添加到布局。

boolean

RenderingHints.containsKey​(Object key)

如果此 RenderingHints包含指定键的映射，则返回 true 。

boolean

RenderingHints.containsValue​(Object value)

如果此RenderingHints将一个或多个键映射到指定的值，则返回true。

boolean

AlphaComposite.equals​(Object obj)

确定指定的对象是否等于此 AlphaComposite 。

boolean

AWTKeyStroke.equals​(Object anObject)

如果此对象与指定的对象相同，则返回true。

boolean

BasicStroke.equals​(Object obj)

测试指定的对象是否等于 BasicStroke ，首先测试是否为 BasicStroke ，然后将其宽度，连接，上限， BasicStroke限制，破折号和破折号相位属性与该 BasicStroke 。

boolean

Color.equals​(Object obj)

确定另一个对象是否等于此 Color 。

boolean

Dimension.equals​(Object obj)

检查两维对象是否具有相等的值。

boolean

DisplayMode.equals​(Object dm)

指示一些其他对象是否等于此。

boolean

Font.equals​(Object obj)

将此 Font对象与指定的 Object 。

boolean

Insets.equals​(Object obj)

检查两个插入对象是否相等。

boolean

JobAttributes.equals​(Object obj)

确定两个JobAttributes是否相等。

boolean

MenuShortcut.equals​(Object obj)

返回此MenuShortcut是否与另一个相同：等式被定义为意味着两个MenuShortcuts使用相同的键，两者都使用或不使用SHIFT键。

boolean

PageAttributes.equals​(Object obj)

确定两个PageAttributes是否相等。

boolean

Point.equals​(Object obj)

确定两点是否相等。

boolean

Rectangle.equals​(Object obj)

检查两个矩形是否相等。

boolean

RenderingHints.equals​(Object o)

将此 Object与 RenderingHints进行比较，以获得相等性。

boolean

RenderingHints.Key.equals​(Object o)

所有Key对象的equals方法将返回与等式运算符“==”相同的结果。

protected void

Component.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告对象属性的绑定属性更改。

protected void

KeyboardFocusManager.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

触发PropertyChangeEvent以响应绑定属性的更改。

protected void

KeyboardFocusManager.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)

触发PropertyChangeEvent以响应否决权属性的更改。

Object

RenderingHints.get​(Object key)

返回指定键映射到的值。

Component

BorderLayout.getLayoutComponent​(Container target, Object constraints)

基于目标 Container的组件方向返回与给定约束位置相对应的组件。

Component

BorderLayout.getLayoutComponent​(Object constraints)

获取使用给定约束添加的组件

boolean

Component.gotFocus​(Event evt, Object what)

已过时。
从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。

abstract boolean

RenderingHints.Key.isCompatibleValue​(Object val)

如果指定的对象是此Key的有效值，则返回true。

boolean

Component.lostFocus​(Event evt, Object what)

已过时。
从JDK 1.1版开始，由processFocusEvent（FocusEvent）替代。

Object

RenderingHints.put​(Object key, Object value)

将指定的 key映射到此 RenderingHints对象中指定的 value 。

Object

RenderingHints.remove​(Object key)

从这个 RenderingHints对象中删除键及其对应的值。

protected void

Toolkit.setDesktopProperty​(String name, Object newValue)

将指定的桌面属性设置为指定的值，并触发属性更改事件以通知任何侦听器该值已更改。

abstract void

Graphics2D.setRenderingHint​(RenderingHints.Key hintKey, Object hintValue)

为渲染算法设置单个首选项的值。

void

AWTEvent.setSource​(Object newSource)

将事件重新定位到新的来源。

Constructors in java.awt with parameters of type Object

Constructor

描述

AWTEvent​(Object source, int id)

构造具有指定源对象和类型的AWTEvent对象。

Event​(Object target, int id, Object arg)

已过时。

注意： Event类已过时，仅适用于向后兼容性。

Event​(Object target, long when, int id, int x, int y, int key, int modifiers)

已过时。

注意： Event类已过时，仅适用于向后兼容性。

Event​(Object target, long when, int id, int x, int y, int key, int modifiers, Object arg)

已过时。

注意： Event类已过时，仅适用于向后兼容性。

RenderingHints​(RenderingHints.Key key, Object value)

使用指定的键/值对构造新对象。

Uses of Object in java.awt.color

Subclasses of Object in java.awt.color

Modifier and Type

Class

描述

class

CMMException

如果本机CMM返回错误，则抛出此异常。

class

ColorSpace

该抽象类用于作为颜色空间标签，用于标识Color对象的特定颜色空间，或通过ColorModel对象来映射Image，BufferedImage或GraphicsDevice。

class

ICC_ColorSpace

ICC_ColorSpace类是抽象ColorSpace类的一个实现。

class

ICC_Profile

基于国际色彩联盟规范ICC.1：2001-12，颜色配置文件格式（见 http://www.color.org ）的设备独立和设备相关色彩空间的颜色配置文件数据的表示。

class

ICC_ProfileGray

ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为TYPE_GRAY，配置文件包含grayTRCTag和mediaWhitePointTag标签。

class

ICC_ProfileRGB

ICC_ProfileRGB类是ICC_Profile类的子类，表示符合以下条件的配置文件：配置文件的颜色空间类型为RGB。 该配置文件包含redColorantTag ， greenColorantTag ， blueColorantTag ， redTRCTag ， greenTRCTag ， blueTRCTag ，并mediaWhitePointTag标签。 当满足这些条件时， ICC_Profile getInstance方法将返回一个ICC_ProfileRGB对象。

class

ProfileDataException

在访问或处理ICC_Profile对象时发生错误时抛出此异常。

Methods in java.awt.color that return Object

Modifier and Type

方法

描述

protected Object

ICC_Profile.readResolve​()

将被反序列化的实例解析为使用CMM注册的实例。

Uses of Object in java.awt.datatransfer

Subclasses of Object in java.awt.datatransfer

Modifier and Type

Class

描述

class

Clipboard

实现使用剪切/复制/粘贴操作传输数据的机制的类。

class

DataFlavor

A DataFlavor提供有关数据的元信息。

class

FlavorEvent

FlavorEvent用于通知有关方面可用的DataFlavor在Clipboard （事件源）中已更改。

class

MimeTypeParseException

封装MimeType解析相关异常的类。

class

StringSelection

A Transferable ，其实现传送 String所需的能力。

class

SystemFlavorMap

SystemFlavorMap是与“平台”特定的数据格式相对应的“本地”（Stratives）和与平台无关的MIME类型对应的“风格”（DataFlavors）之间的可配置映射。

class

UnsupportedFlavorException

表示在此风格中不支持请求的数据。

Methods in java.awt.datatransfer that return Object

Modifier and Type

方法

描述

Object

DataFlavor.clone​()

返回此 DataFlavor的克隆。

Object

Clipboard.getData​(DataFlavor flavor)

在指定的 DataFlavor返回表示此剪贴板当前内容的对象。

Object

StringSelection.getTransferData​(DataFlavor flavor)

返回 Transferable所请求的数据 DataFlavor如果可能的话。

Object

Transferable.getTransferData​(DataFlavor flavor)

返回表示要传输的数据的对象。

Methods in java.awt.datatransfer with parameters of type Object

Modifier and Type

方法

描述

boolean

DataFlavor.equals​(Object o)

指示一些其他对象是否等于此。

Transferable

Clipboard.getContents​(Object requestor)

返回表示剪贴板当前内容的可转移对象。

Uses of Object in java.awt.desktop

Subclasses of Object in java.awt.desktop

Modifier and Type

Class

描述

class

AboutEvent

当应用程序被要求打开窗口时发送事件。

class

AppEvent

AppEvent被发送到安装在Desktop上的监听器和处理程序。

class

AppForegroundEvent

当应用程序成为前台应用程序时，发送的事件，以及何时不再是前台应用程序。

class

AppHiddenEvent

应用程序隐藏或显示时发送的事件。

class

AppReopenedEvent

当应用程序被要求重新打开时发送事件。

class

FilesEvent

辅助事件包含文件列表。

class

OpenFilesEvent

当应用程序被要求打开文件列表时发送事件。

class

OpenURIEvent

当应用程序被要求打开一个 URI时发送的事件。

class

PreferencesEvent

当请求应用程序打开其首选项窗口时发送事件。

class

PrintFilesEvent

当应用程序被要求打印文件列表时发送事件。

class

QuitEvent

当应用程序被要求退出时发送事件。

class

ScreenSleepEvent

当系统显示器进入并退出省电睡眠时发送事件。

class

SystemSleepEvent

系统进入和退出省电休眠时发送的事件。

class

UserSessionEvent

用户会话更改时发送的事件。

Uses of Object in java.awt.dnd

Subclasses of Object in java.awt.dnd

Modifier and Type

Class

描述

class

DnDConstants

此类包含表示由拖放操作执行的操作类型的常量值。

class

DragGestureEvent

当特定的 DragGestureRecognizer检测到正在跟踪的 Component上发生平台相关的拖动启动手势时， DragGestureEvent将传递给 DragGestureListener的dragGestureRecognized（）方法。

class

DragGestureRecognizer

DragGestureRecognizer是一个用于规范平台相关侦听器的抽象基类，可以与特定的 Component相关联，以便识别平台相关的拖动启动手势。

class

DragSource

DragSource是负责启动拖放操作的实体，可用于多种情况：该JVM的生命周期为每个JVM使用1个默认实例。

class

DragSourceAdapter

用于接收拖动源事件的抽象适配器类。

class

DragSourceContext

DragSourceContext类负责管理拖放协议的发起方。

class

DragSourceDragEvent

DragSourceDragEvent从 DragSourceContextPeer通过 DragSourceContext发送到 DragSourceListener注册 DragSourceContext及其相关联的 DragSource 。

class

DragSourceDropEvent

DragSourceDropEvent通过 DragSourceContextPeer通过 DragSourceContext发送到 dragDropEnd和 DragSourceListener的 DragSourceContext及其相关联的 DragSource 。

class

DragSourceEvent

这个类是 DragSourceDragEvent和 DragSourceDropEvent的基类。

class

DropTarget

该 DropTarget与相关 Component时 Component希望接受拖放操作期间下降。

protected static class

DropTarget.DropTargetAutoScroller

这个受保护的嵌套类实现自动滚动

class

DropTargetAdapter

用于接收丢弃目标事件的抽象适配器类。

class

DropTargetContext

甲 DropTargetContext每当用拖放操作相关联的逻辑光标用的可见几何一致创建 Component与相关联 DropTarget 。

protected class

DropTargetContext.TransferableProxy

TransferableProxy是一个助手内部类，它实现 Transferable接口，并且作为另一个 Transferable对象的代理，代表特定的拖放操作的数据传输。

class

DropTargetDragEvent

所述 DropTargetDragEvent被输送到 DropTargetListener经由其dragEnter事件（）和的dragover（）方法。

class

DropTargetDropEvent

DropTargetDropEvent通过 DropTargetListener drop（）方法传递。

class

DropTargetEvent

DropTargetEvent是 DropTargetDragEvent和 DropTargetDropEvent的基础类。

class

InvalidDnDOperationException

java.awt.dnd包中的各种方法抛出此异常。

class

MouseDragGestureRecognizer

DragGestureRecognizer这个抽象子类定义了基于鼠标的手势的 DragGestureRecognizer 。

Methods in java.awt.dnd that return Object

Modifier and Type

方法

描述

Object

DropTargetContext.TransferableProxy.getTransferData​(DataFlavor df)

返回一个对象，该对象表示由所请求的数据风格的可封装转移提供的数据。

Object[]

DragGestureEvent.toArray​()

返回包含拖动手势的事件的 Object数组。

Object[]

DragGestureEvent.toArray​(Object[] array)

返回包含拖动手势的事件数组。

Methods in java.awt.dnd with parameters of type Object

Modifier and Type

方法

描述

Object[]

DragGestureEvent.toArray​(Object[] array)

返回包含拖动手势的事件数组。

Uses of Object in java.awt.event

Subclasses of Object in java.awt.event

Modifier and Type

Class

描述

class

ActionEvent

指示组件定义的动作发生的语义事件。

class

AdjustmentEvent

可调整对象发出的调整事件，如Scrollbar和ScrollPane 。

class

AWTEventListenerProxy

一个扩展 EventListenerProxy专门用于为特定事件掩码添加一个 AWTEventListener的类。

class

ComponentAdapter

用于接收组件事件的抽象适配器类。

class

ComponentEvent

指示组件移动，更改大小或更改可见性的低级事件（也称为其他组件级事件的根类）。

class

ContainerAdapter

用于接收容器事件的抽象适配器类。

class

ContainerEvent

低级别事件，表示容器的内容因添加或删除组件而发生更改。

class

FocusAdapter

用于接收键盘焦点事件的抽象适配器类。

class

FocusEvent

指示组件已经获得或丢失了输入焦点的低级事件。

class

HierarchyBoundsAdapter

用于接收祖先移动和调整大小的事件的抽象适配器类。

class

HierarchyEvent

指示对 Component所属的 Component层次结构进行更改的事件。

class

InputEvent

所有组件级输入事件的根事件类。

class

InputMethodEvent

输入法事件包含使用输入法组合的文本信息。

class

InvocationEvent

在由AWT事件调度程序线程调度时，在 Runnable执行 run()方法的事件。

class

ItemEvent

表示选择或取消选择项目的语义事件。

class

KeyAdapter

用于接收键盘事件的抽象适配器类。

class

KeyEvent

指示组件中发生击键的事件。

class

MouseAdapter

用于接收鼠标事件的抽象适配器类。

class

MouseEvent

指示组件中发生鼠标操作的事件。

class

MouseMotionAdapter

用于接收鼠标运动事件的抽象适配器类。

class

MouseWheelEvent

指示鼠标轮在组件中旋转的事件。

class

PaintEvent

组件级paint事件。

class

TextEvent

表示对象的文本改变的语义事件。

class

WindowAdapter

用于接收窗口事件的抽象适配器类。

class

WindowEvent

指示窗口已更改其状态的低级别事件。

Fields in java.awt.event declared as Object

Modifier and Type

Field

描述

protected Object

InvocationEvent.notifier

在Runnable.run（）方法返回或抛出异常之后或事件处理完毕后，将立即调用其notifyAll（）方法的（可能为空）的对象。

Methods in java.awt.event that return Object

Modifier and Type

方法

描述

Object

ItemEvent.getItem​()

返回受事件影响的项目。

Constructors in java.awt.event with parameters of type Object

Constructor

描述

ActionEvent​(Object source, int id, String command)

构造一个 ActionEvent对象。

ActionEvent​(Object source, int id, String command, int modifiers)

使用修饰键构造一个 ActionEvent对象。

ActionEvent​(Object source, int id, String command, long when, int modifiers)

构造具有指定的修饰符键和时间戳的 ActionEvent对象。

InvocationEvent​(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables)

构造一个 InvocationEvent具有指定源和ID将执行可运行的 run时调度方法。

InvocationEvent​(Object source, Runnable runnable)

构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

InvocationEvent​(Object source, Runnable runnable, Object notifier, boolean catchThrowables)

构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

InvocationEvent​(Object source, Runnable runnable, Runnable listener, boolean catchThrowables)

构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

ItemEvent​(ItemSelectable source, int id, Object item, int stateChange)

构造一个 ItemEvent对象。

TextEvent​(Object source, int id)

构造一个 TextEvent对象。

Uses of Object in java.awt.font

Subclasses of Object in java.awt.font

Modifier and Type

Class

描述

class

FontRenderContext

FontRenderContext类是用于正确测量文本所需信息的容器。

class

GlyphJustificationInfo

GlyphJustificationInfo类表示有关字形对齐属性的信息。

class

GlyphMetrics

GlyphMetrics类代表单个字形的信息。

class

GlyphVector

GlyphVector对象是包含几何信息的字形的集合，用于在与最终显示 GlyphVector的设备相对应的变换的坐标空间中放置每个字形。

class

GraphicAttribute

该类与CHAR_REPLACEMENT属性一起使用。

class

ImageGraphicAttribute

该ImageGraphicAttribute类的实现GraphicAttribute其中提请在图像TextLayout 。

class

LayoutPath

LayoutPath提供了相对于基准的位置和用户空间中的点之间的映射。

class

LineBreakMeasurer

LineBreakMeasurer类允许将样式文本分解成符合特定视觉进步的线（或段）。

class

LineMetrics

LineMetrics类允许访问沿线排列字符和布局一组线所需的度量。

class

NumericShaper

NumericShaper类用于将Latin-1（欧洲）数字转换为其他Unicode十进制数字。

class

ShapeGraphicAttribute

该ShapeGraphicAttribute类的实现GraphicAttribute绘制形状在TextLayout 。

class

TextAttribute

TextAttribute类定义用于文本呈现的属性键和属性值。

class

TextHitInfo

TextHitInfo类表示文本模型中的字符位置，并且表示字符的 偏差或“边”。

class

TextLayout

TextLayout是风格字符数据的不可变图形表示。

static class

TextLayout.CaretPolicy

定义确定强插插位置的策略。

class

TextMeasurer

TextMeasurer类提供换行所需的原始操作：测量高达给定的提前，确定字符范围的提前，并为一系列字符生成 TextLayout 。

class

TransformAttribute

TransformAttribute类为转换提供了一个不可变的包装器，以便作为属性使用是安全的。

Methods in java.awt.font that return Object

Modifier and Type

方法

描述

protected Object

TextLayout.clone​()

创建这个 TextLayout的副本。

protected Object

TextMeasurer.clone​()

Object

FontRenderContext.getAntiAliasingHint​()

返回此 FontRenderContext使用的文本反锯齿渲染模式提示。

Object

FontRenderContext.getFractionalMetricsHint​()

返回此 FontRenderContext使用的文本小数度量渲染模式提示。

protected Object

TextAttribute.readResolve​()

解析反序列化为预定义常量的实例。

Methods in java.awt.font with parameters of type Object

Modifier and Type

方法

描述

boolean

FontRenderContext.equals​(Object obj)

如果obj是FontRenderContext的一个实例，并且具有与此相同的转换，抗锯齿和小数度量值，则返回true。

boolean

ImageGraphicAttribute.equals​(Object rhs)

比较这个ImageGraphicAttribute到指定的Object 。

boolean

NumericShaper.equals​(Object o)

如果指定的对象是 NumericShaper的实例，并且与这个对象的形状相同，则返回 true ，而不考虑范围表示，位掩码或枚举。

boolean

ShapeGraphicAttribute.equals​(Object rhs)

将此 ShapeGraphicAttribute比较为 Object 。

boolean

TextHitInfo.equals​(Object obj)

返回 true如果指定 Object是 TextHitInfo ，等于这个 TextHitInfo 。

boolean

TransformAttribute.equals​(Object rhs)

如果rhs是一个 TransformAttribute其变换等于这个 TransformAttribute的变换，则返回 true 。

Constructors in java.awt.font with parameters of type Object

Constructor

描述

FontRenderContext​(AffineTransform tx, Object aaHint, Object fmHint)

从可选的AffineTransform和两个Object值构造一个FontRenderContext对象，确定新构造的对象是否具有抗锯齿或小数度量。

Uses of Object in java.awt.geom

Subclasses of Object in java.awt.geom

Modifier and Type

Class

描述

class

AffineTransform

AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，保留线的“直线度”和“平行度”。

class

Arc2D

Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或 PIE ）。

static class

Arc2D.Double

该类定义了 double精度中指定的弧。

static class

Arc2D.Float

此类定义了 float精度中指定的弧。

class

Area

一个 Area对象存储和操纵二维空间的封闭区域的与分辨率无关的描述。

class

CubicCurve2D

CubicCurve2D类定义了 (x,y)坐标空间中的三次参数曲线段。

static class

CubicCurve2D.Double

用 double坐标指定的三次参数曲线段。

static class

CubicCurve2D.Float

用 float坐标指定的三次参数曲线段。

class

Dimension2D

Dimension2D类是封装宽度和高度尺寸。

class

Ellipse2D

Ellipse2D类描述了由框架矩形定义的椭圆。

static class

Ellipse2D.Double

Double类定义了 double精度中指定的椭圆。

static class

Ellipse2D.Float

Float类定义了 float精度中指定的椭圆。

class

FlatteningPathIterator

FlatteningPathIterator类返回另一个PathIterator对象的展平视图。

class

GeneralPath

GeneralPath类代表由直线构成的几何路径，以及二次和立方（Bézier）曲线。

class

IllegalPathStateException

如果在关于正在执行的特定操作的非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段追加到GeneralPath 。

class

Line2D

此 Line2D表示 (x,y)坐标空间中的线段。

static class

Line2D.Double

用双坐标指定的线段。

static class

Line2D.Float

用浮点坐标指定的线段。

class

NoninvertibleTransformException

NoninvertibleTransformException类表示如果执行需要AffineTransform对象的反向但AffineTransform处于非可逆状态的操作时抛出的异常。

class

Path2D

Path2D类提供了一个简单而又灵活的形状，表示任意的几何路径。

static class

Path2D.Double

Double类定义了一个几何路径，坐标存储在双精度浮点中。

static class

Path2D.Float

Float类定义了坐标存储在单精度浮点中的几何路径。

class

Point2D

Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。

static class

Point2D.Double

Double类定义了 double精度指定的点。

static class

Point2D.Float

Float类定义了浮点精度指定的点。

class

QuadCurve2D

QuadCurve2D类定义了 (x,y)坐标空间中的二次参数曲线段。

static class

QuadCurve2D.Double

用 double指定的二次参数曲线段。

static class

QuadCurve2D.Float

用 float坐标指定的二次参数曲线段。

class

Rectangle2D

Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。

static class

Rectangle2D.Double

Double类定义了一个以双坐标指定的矩形。

static class

Rectangle2D.Float

Float类定义了一个以浮点坐标指定的矩形。

class

RectangularShape

RectangularShape是几何由矩形框架定义的Shape个对象的基类。

class

RoundRectangle2D

RoundRectangle2D类定义了一个矩形，其圆角由位置 (x,y)定义，尺寸为 (w x h) ，以及 (w x h)的宽度和高度。

static class

RoundRectangle2D.Double

Double类定义了一个带有圆角的矩形，全部在 double坐标中指定。

static class

RoundRectangle2D.Float

Float类定义了一个带有圆角的矩形，全部在 float坐标中指定。

Methods in java.awt.geom that return Object

Modifier and Type

方法

描述

Object

AffineTransform.clone​()

返回此 AffineTransform对象的副本。

Object

Area.clone​()

返回此 Area对象的精确副本。

Object

CubicCurve2D.clone​()

创建与此对象相同类的新对象。

Object

Dimension2D.clone​()

创建与此对象相同类的新对象。

Object

Line2D.clone​()

创建与此对象相同类的新对象。

abstract Object

Path2D.clone​()

创建与此对象相同类的新对象。

Object

Path2D.Double.clone​()

创建与此对象相同类的新对象。

Object

Path2D.Float.clone​()

创建与此对象相同类的新对象。

Object

Point2D.clone​()

创建与该对象相同的类和新内容相同的新对象。

Object

QuadCurve2D.clone​()

创建与该对象相同的类和新内容相同的新对象。

Object

RectangularShape.clone​()

创建与该对象相同的类和新内容相同的新对象。

Methods in java.awt.geom with parameters of type Object

Modifier and Type

方法

描述

boolean

AffineTransform.equals​(Object obj)

如果该 AffineTransform表示与指定参数相同的仿射坐标变换，则返回 true 。

boolean

Arc2D.equals​(Object obj)

确定指定的 Object是否等于此 Arc2D 。

boolean

Ellipse2D.equals​(Object obj)

确定指定的 Object是否等于此 Ellipse2D 。

boolean

Point2D.equals​(Object obj)

确定两点是否相等。

boolean

Rectangle2D.equals​(Object obj)

确定指定的 Object是否等于此 Rectangle2D 。

boolean

RoundRectangle2D.equals​(Object obj)

确定指定的 Object是否等于此 RoundRectangle2D 。

Uses of Object in java.awt.im

Subclasses of Object in java.awt.im

Modifier and Type

Class

描述

class

InputContext

提供控制文本输入设备（如输入法和键盘布局）的方法。

class

InputMethodHighlight

InputMethodHighlight用于描述正在组成的文本的突出显示属性。

class

InputSubset

定义输入法使用的其他Unicode子集。

Methods in java.awt.im that return Object

Modifier and Type

方法

描述

Object

InputContext.getInputMethodControlObject​()

从当前输入法返回一个控件对象，或者返回null。

Uses of Object in java.awt.im.spi

Methods in java.awt.im.spi that return Object

Modifier and Type

方法

描述

Object

InputMethod.getControlObject​()

从此输入法返回一个控件对象，或者返回null。

Uses of Object in java.awt.image

Subclasses of Object in java.awt.image

Modifier and Type

Class

描述

class

AbstractMultiResolutionImage

该类为要实现 MultiResolutionImage接口的类提供了几个 Image方法的默认实现。

class

AffineTransformOp

该类使用仿射变换来执行从源图像中的2D坐标或目标图像中的 Raster到2D坐标的线性映射或 Raster 。

class

AreaAveragingScaleFilter

一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。

class

BandCombineOp

该类使用指定的矩阵在 Raster执行带的任意线性组合。

class

BandedSampleModel

该类表示以频带交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。

class

BaseMultiResolutionImage

这个类是一个基于数组的 AbstractMultiResolutionImage类的实现。

class

BufferedImage

BufferedImage子类描述了具有图像数据可访问缓冲区的Image 。

class

BufferedImageFilter

所述BufferedImageFilter类的子类的ImageFilter是提供一种使用单一源/单一目标图像操作符（的简单方法BufferedImageOp ）以过滤BufferedImage在图像生产者/消费者/观察员范例。

class

BufferStrategy

BufferStrategy类代表了在特定的 Canvas或 Window上组织复杂内存的机制。

class

ByteLookupTable

这个类定义了一个查找表对象。

class

ColorConvertOp

该类对源图像中的数据执行逐像素颜色转换。

class

ColorModel

ColorModel抽象类封装了将像素值转换为颜色分量（例如，红色，绿色和蓝色）和Alpha组件的方法。

class

ComponentColorModel

一个 ColorModel类，用于将颜色和alpha信息表示为单独样本的像素值，并将每个样本存储在单独的数据元素中。

class

ComponentSampleModel

该类表示存储的图像数据，使得像素的每个样本占据DataBuffer的一个数据元素。

class

ConvolveOp

该类实现从源到目的地的卷积。

class

CropImageFilter

用于裁剪图像的ImageFilter类。

class

DataBuffer

此类存在用于包装一个或多个数据数组。

class

DataBufferByte

该类扩展了 DataBuffer并将数据内部存储为字节。

class

DataBufferDouble

该类扩展 DataBuffer并在 double内部存储数据。

class

DataBufferFloat

该类扩展 DataBuffer并在 float内部存储数据。

class

DataBufferInt

该类扩展了 DataBuffer并将数据内部存储为整数。

class

DataBufferShort

此类扩展 DataBuffer并将数据内部存储为短裤。

class

DataBufferUShort

该类扩展了 DataBuffer并将数据内部存储为短裤。

class

DirectColorModel

DirectColorModel类是一个 ColorModel类，适用于将RGB颜色和alpha信息表示为单独样本的像素值，并将单个像素的所有样本包装为单个int，short或byte数量。

class

FilteredImageSource

这个类是ImageProducer接口的一个实现，它接收一个现有的图像和一个过滤器对象，并使用它们来生成原始图像的新过滤版本的图像数据。

class

ImageFilter

此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。

class

ImagingOpException

所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。

class

IndexColorModel

IndexColorModel类是一个 ColorModel类，适用于由单个样本组成的像素值，该样本是默认sRGB色彩空间中固定色彩映射的索引。

class

Kernel

Kernel类定义了一个矩阵，描述指定像素及其周围像素如何影响对滤波操作的输出图像中像素的位置计算的值。

class

LookupOp

该类实现从源到目标的查找操作。

class

LookupTable

这个抽象类定义了一个查找表对象。

class

MemoryImageSource

该类是ImageProducer接口的一个实现，它使用一个数组为图像生成像素值。

class

MultiPixelPackedSampleModel

MultiPixelPackedSampleModel类表示单带图像，可以将多个单样本像素包装到一个数据元素中。

class

PackedColorModel

PackedColorModel类是一个抽象的ColorModel类，它与像素值一起使用，它们将颜色和alpha信息表示为单独的样本，并将单个像素的所有样本包装为单个int，short或byte数量。

class

PixelGrabber

PixelGrabber类实现了一个ImageConsumer，它可以附加到Image或ImageProducer对象，以检索该图像中的像素的子集。

class

PixelInterleavedSampleModel

该类表示以像素交错方式存储的图像数据，并且像素的每个样本占据DataBuffer的一个数据元素。

class

Raster

表示矩形像素阵列的类。

class

RasterFormatException

如果RasterFormatException中有无效的布局信息，则会抛出RasterFormatException 。

class

ReplicateScaleFilter

一个ImageFilter类，用于使用最简单的算法缩放图像。

class

RescaleOp

该类通过将每个像素的采样值乘以比例因子然后添加偏移来执行源图像中的数据的逐像素重新缩放。

class

RGBImageFilter

该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。

class

SampleModel

这个抽象类定义了一个用于提取图像中像素样本的接口。

class

ShortLookupTable

这个类定义了一个查找表对象。

class

SinglePixelPackedSampleModel

该类表示打包的像素数据，使得构成单个像素的N个采样被存储在单个数据阵列元素中，并且每个数据数据阵列元素仅保存一个像素的采样。

class

VolatileImage

VolatileImage是由于超出应用程序控制的情况（例如由操作系统或其他应用程序引起的情况），可能随时丢失其内容的映像。

class

WritableRaster

该类扩展了Raster，以提供像素写入功能。

Fields in java.awt.image declared as Object

Modifier and Type

Field

描述

protected Object

ReplicateScaleFilter.outpixbuf

A byte数组初始化大小为ReplicateScaleFilter.destWidth ，用于将一行像素数据传送到ImageConsumer 。

Methods in java.awt.image that return Object

Modifier and Type

方法

描述

Object

ImageFilter.clone​()

克隆这个对象。

Object

Kernel.clone​()

克隆这个对象。

Object

BandedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

Object

ColorModel.getDataElements​(float[] normComponents, int normOffset, Object obj)

给出这个 ColorModel中的像素的数据元素数组表示，给出了一组归一化的颜色/ alpha分量。

Object

ColorModel.getDataElements​(int[] components, int offset, Object obj)

给出这个 ColorModel的一个像素的数据元素数组表示，给出了一个非标准化颜色/ alpha分量的数组。

Object

ColorModel.getDataElements​(int rgb, Object pixel)

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

Object

ComponentColorModel.getDataElements​(float[] normComponents, int normOffset, Object obj)

给出这个 ColorModel的一个像素的数据元素数组表示，给出了一组归一化的颜色/ alpha分量。

Object

ComponentColorModel.getDataElements​(int[] components, int offset, Object obj)

返回此 ColorModel的一个像素的数据元素数组表示，给出一个非规范化颜色/ alpha分量的数组。

Object

ComponentColorModel.getDataElements​(int rgb, Object pixel)

返回此 ColorModel中的像素的数据元素数组表示，给定了默认RGB颜色模型中的整数像素表示。

Object

ComponentSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回类型为 TransferType的原始数组中的单个像素的数据。

Object

DirectColorModel.getDataElements​(int[] components, int offset, Object obj)

给出一个非标准化颜色/ alpha分量的数组，返回此 ColorModel中的像素的数据元素数组表示。

Object

DirectColorModel.getDataElements​(int rgb, Object pixel)

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

Object

IndexColorModel.getDataElements​(int[] components, int offset, Object pixel)

在给定一个非标准化颜色/ alpha组件数组的情况下，返回此 ColorModel中的像素的数据元素数组表示。

Object

IndexColorModel.getDataElements​(int rgb, Object pixel)

返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

Object

MultiPixelPackedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

Object

Raster.getDataElements​(int x, int y, int w, int h, Object outData)

返回TransferType类型的原始数组中指定的像素矩形的像素数据。

Object

Raster.getDataElements​(int x, int y, Object outData)

返回TransferType类型的原始数组中单个像素的数据。

Object

SampleModel.getDataElements​(int x, int y, int w, int h, Object obj, DataBuffer data)

返回TransferType类型的原始数组中指定的像素矩形的像素数据。

abstract Object

SampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

Object

SinglePixelPackedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

Object

PixelGrabber.getPixels​()

获取像素缓冲区。

Object

AbstractMultiResolutionImage.getProperty​(String name, ImageObserver observer)

该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getProperty(name, observer) 。

Object

BufferedImage.getProperty​(String name)

按名称返回图像的属性。

Object

BufferedImage.getProperty​(String name, ImageObserver observer)

按名称返回图像的属性。

Object

RenderedImage.getProperty​(String name)

从该图像的属性集获取属性。

Methods in java.awt.image with parameters of type Object

Modifier and Type

方法

描述

boolean

ColorModel.equals​(Object obj)

该方法简单地委托到 Object的默认实现，该默认实现与 ==测试相同，因为此类不能在多个独立子类分支之间强制执行适当的等式测试的问题。

boolean

ComponentColorModel.equals​(Object obj)

测试指定 Object是一个实例 ComponentColorModel和等于这个 ComponentColorModel 。

boolean

ComponentSampleModel.equals​(Object o)

boolean

IndexColorModel.equals​(Object obj)

如果指定的测试 Object是一个实例 IndexColorModel ，以及它是否该 IndexColorModel

boolean

MultiPixelPackedSampleModel.equals​(Object o)

boolean

PackedColorModel.equals​(Object obj)

测试指定 Object是一个实例 PackedColorModel和等于这个 PackedColorModel 。

boolean

SinglePixelPackedSampleModel.equals​(Object o)

int

ColorModel.getAlpha​(Object inData)

返回指定像素的alpha分量，从0到255。

int

ComponentColorModel.getAlpha​(Object inData)

返回指定像素的alpha分量，从0到255。

int

DirectColorModel.getAlpha​(Object inData)

返回指定像素的alpha分量，从0到255。

int

ColorModel.getBlue​(Object inData)

返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。

int

ComponentColorModel.getBlue​(Object inData)

返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。

int

DirectColorModel.getBlue​(Object inData)

返回指定像素的蓝色分量，在默认RGB ColorSpace （sRGB）中从0到255。

int[]

ColorModel.getComponents​(Object pixel, int[] components, int offset)

返回给这个 ColorModel一个像素的非规范化颜色/ alpha分量的数组。

int[]

ComponentColorModel.getComponents​(Object pixel, int[] components, int offset)

在这个 ColorModel给出一个像素的返回一个非规范化的颜色/ alpha分量的数组。

int[]

DirectColorModel.getComponents​(Object pixel, int[] components, int offset)

返回给这个 ColorModel一个像素的非规范化颜色/ alpha分量的数组。

int[]

IndexColorModel.getComponents​(Object pixel, int[] components, int offset)

返回此 ColorModel指定像素的非标准化颜色/ alpha分量 ColorModel 。

Object

BandedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

Object

ColorModel.getDataElements​(float[] normComponents, int normOffset, Object obj)

给出这个 ColorModel的一个像素的数据元素数组表示，给出了一组归一化的颜色/ alpha分量。

Object

ColorModel.getDataElements​(int[] components, int offset, Object obj)

给定一个非标准化颜色/ alpha分量的数组，返回此 ColorModel中的像素的数据元素数组表示。

Object

ColorModel.getDataElements​(int rgb, Object pixel)

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

Object

ComponentColorModel.getDataElements​(float[] normComponents, int normOffset, Object obj)

给定一个归一化颜色/ alpha分量的数组，返回此 ColorModel中的像素的数据元素数组表示。

Object

ComponentColorModel.getDataElements​(int[] components, int offset, Object obj)

给出一个非标准化颜色/ alpha分量的数组，返回此 ColorModel中的像素的数据元素数组表示。

Object

ComponentColorModel.getDataElements​(int rgb, Object pixel)

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

Object

ComponentSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回 TransferType的基本数组中单个像素的数据。

Object

DirectColorModel.getDataElements​(int[] components, int offset, Object obj)

返回这个 ColorModel的一个像素的数据元素数组表示，给出一个非标准化颜色/ alpha分量的数组。

Object

DirectColorModel.getDataElements​(int rgb, Object pixel)

返回此 ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

Object

IndexColorModel.getDataElements​(int[] components, int offset, Object pixel)

给出一个非标准化颜色/ alpha分量的数组，返回此 ColorModel中的像素的数据元素数组表示。

Object

IndexColorModel.getDataElements​(int rgb, Object pixel)

返回此ColorModel中的像素的数据元素数组表示，给出了默认RGB颜色模型中的整数像素表示。

Object

MultiPixelPackedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

Object

Raster.getDataElements​(int x, int y, int w, int h, Object outData)

返回TransferType类型的原始数组中指定的像素矩形的像素数据。

Object

Raster.getDataElements​(int x, int y, Object outData)

返回TransferType类型的原始数组中单个像素的数据。

Object

SampleModel.getDataElements​(int x, int y, int w, int h, Object obj, DataBuffer data)

返回TransferType类型的原始数组中指定的像素矩形的像素数据。

abstract Object

SampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

Object

SinglePixelPackedSampleModel.getDataElements​(int x, int y, Object obj, DataBuffer data)

返回TransferType类型的原始数组中单个像素的数据。

int

ColorModel.getGreen​(Object inData)

返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。

int

ComponentColorModel.getGreen​(Object inData)

返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。

int

DirectColorModel.getGreen​(Object inData)

返回指定像素的绿色分量，在默认RGB ColorSpace （sRGB）中从0到255。

float[]

ColorModel.getNormalizedComponents​(Object pixel, float[] normComponents, int normOffset)

在这个 ColorModel给出一个像素，返回标准化形式的所有颜色/ alpha分量的 ColorModel 。

float[]

ComponentColorModel.getNormalizedComponents​(Object pixel, float[] normComponents, int normOffset)

给出这个 ColorModel一个像素，返回标准化形式的所有颜色/ alpha分量的 ColorModel 。

int

ColorModel.getRed​(Object inData)

返回指定像素的红色分量，在默认RGB ColorSpace （sRGB）中从0到255。

int

ComponentColorModel.getRed​(Object inData)

返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。

int

DirectColorModel.getRed​(Object inData)

返回指定像素的红色分量，在默认RGB ColorSpace sRGB中从0到255。

int

ColorModel.getRGB​(Object inData)

以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。

int

ComponentColorModel.getRGB​(Object inData)

以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。

int

DirectColorModel.getRGB​(Object inData)

以默认RGB颜色模型格式返回指定像素的颜色/ alpha分量。

void

BandedSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)

从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。

void

ComponentSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)

设置在指定的一个单个像素的数据 DataBuffer从类型的基本数组 TransferType 。

void

MultiPixelPackedSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)

从TransferType类型的原始数组中设置指定的 DataBuffer单个像素的数据。

void

SampleModel.setDataElements​(int x, int y, int w, int h, Object obj, DataBuffer data)

从TransferType类型的原始数组中设置指定DataBuffer中像素矩形的数据。

abstract void

SampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)

从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。

void

SinglePixelPackedSampleModel.setDataElements​(int x, int y, Object obj, DataBuffer data)

从TransferType类型的原始数组中设置指定DataBuffer中单个像素的数据。

void

WritableRaster.setDataElements​(int x, int y, int w, int h, Object inData)

从TransferType类型的原始数组中设置一个像素矩形的数据。

void

WritableRaster.setDataElements​(int x, int y, Object inData)

从TransferType类型的原始数组中设置单个像素的数据。

Uses of Object in java.awt.image.renderable

Subclasses of Object in java.awt.image.renderable

Modifier and Type

Class

描述

class

ParameterBlock

A ParameterBlock封装了所有关于RenderableImageOp或处理图像的其他类所需的源和参数（对象）的信息。

class

RenderableImageOp

此类通过其关联的ContextualRenderedImageFactory实例的帮助来处理操作的可渲染方面。

class

RenderableImageProducer

一个实现ImageProducer以允许异步生成RenderableImage的适配器类。

class

RenderContext

RenderContext封装了从RenderableImage生成特定渲染所需的信息。

Fields in java.awt.image.renderable with type parameters of type Object

Modifier and Type

Field

描述

protected Vector<Object>

ParameterBlock.parameters

非源参数向量，存储为任意对象。

protected Vector<Object>

ParameterBlock.sources

源的矢量，存储为任意对象。

Methods in java.awt.image.renderable that return Object

Modifier and Type

方法

描述

Object

ParameterBlock.clone​()

创建一个 ParameterBlock的副本。

Object

RenderContext.clone​()

制作RenderContext的副本。

Object

ParameterBlock.getObjectParameter​(int index)

获取参数作为对象。

Object

ContextualRenderedImageFactory.getProperty​(ParameterBlock paramBlock, String name)

获取由name参数指定的属性的适当实例。

Object

RenderableImage.getProperty​(String name)

从该图像的属性集获取属性。

Object

RenderableImageOp.getProperty​(String name)

从该图像的属性集获取属性。

Object

ParameterBlock.getSource​(int index)

将源作为一般对象返回。

Object

ParameterBlock.shallowClone​()

创建一个 ParameterBlock的浅拷贝。

Methods in java.awt.image.renderable that return types with arguments of type Object

Modifier and Type

方法

描述

Vector<Object>

ParameterBlock.getParameters​()

返回整个参数向量。

Vector<Object>

ParameterBlock.getSources​()

返回整个Vector的Vector。

Methods in java.awt.image.renderable with parameters of type Object

Modifier and Type

方法

描述

ParameterBlock

ParameterBlock.add​(Object obj)

将对象添加到参数列表中。

ParameterBlock

ParameterBlock.addSource​(Object source)

将图像添加到源列表的末尾。

ParameterBlock

ParameterBlock.set​(Object obj, int index)

替换参数列表中的对象。

ParameterBlock

ParameterBlock.setSource​(Object source, int index)

用源代替源列表中的条目。

Method parameters in java.awt.image.renderable with type arguments of type Object

Modifier and Type

方法

描述

void

ParameterBlock.setParameters​(Vector<Object> parameters)

将参数的整个Vector设置为给定的Vector。

void

ParameterBlock.setSources​(Vector<Object> sources)

将整个Vector矢量设置为给定的Vector。

Constructor parameters in java.awt.image.renderable with type arguments of type Object

Constructor

描述

ParameterBlock​(Vector<Object> sources)

构造一个给定矢量的源的 ParameterBlock 。

ParameterBlock​(Vector<Object> sources, Vector<Object> parameters)

构造一个 ParameterBlock与给定矢量的源和参数矢量。

Uses of Object in java.awt.print

Subclasses of Object in java.awt.print

Modifier and Type

Class

描述

class

Book

Book类提供了一个文档的表示，其中页面可能具有不同的页面格式和页面绘图。

class

PageFormat

PageFormat类描述了要打印的页面的大小和方向。

class

Paper

Paper课程描述了一张纸的物理特性。

class

PrinterAbortException

所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。

class

PrinterException

PrinterException类及其子类用于指示在打印系统中出现异常情况。

class

PrinterIOException

该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。

class

PrinterJob

PrinterJob类是控制打印的主要类。

Methods in java.awt.print that return Object

Modifier and Type

方法

描述

Object

PageFormat.clone​()

使此副本 PageFormat具有相同的内容，因为这 PageFormat 。

Object

Paper.clone​()

创建一个 Paper的副本，内容与这个 Paper相同。

Uses of Object in java.beans

Subclasses of Object in java.beans

Modifier and Type

Class

描述

class

BeanDescriptor

BeanDescriptor提供有关“bean”的全局信息，包括其Java类，其displayName等。

class

Beans

这个类提供了一些通用的bean控制方法。

class

DefaultPersistenceDelegate

DefaultPersistenceDelegate是抽象 PersistenceDelegate类的具体实现，是默认情况下用于没有信息可用的类的委托。

class

Encoder

一个 Encoder是一个类，可用于创建根据其公共API编码JavaBean集合的状态的文件或流。

class

EventHandler

EventHandler类提供了动态生成事件侦听器的支持，该侦听器的方法执行一个涉及到传入事件对象和目标对象的简单语句。

class

EventSetDescriptor

EventSetDescriptor描述给定的Java Bean触发的一组事件。

class

Expression

一个 Expression对象表示一个原始表达式，其中单个方法应用于目标和一组参数以返回结果 - 如 "a.getFoo()" 。

class

FeatureDescriptor

FeatureDescriptor类是PropertyDescriptor，EventSetDescriptor和MethodDescriptor等的常见基类。

class

IndexedPropertyChangeEvent

只要符合JavaBeans¢规范（“bean”）的组件更改绑定的索引属性，就会传递“IndexedPropertyChange”事件。

class

IndexedPropertyDescriptor

IndexedPropertyDescriptor描述了一个像数组一样的属性，并且具有索引的读取和/或索引的写入方法来访问数组的特定元素。

class

IntrospectionException

内省时发生异常时抛出。

class

Introspector

Introspector类提供了一种标准的工具来了解目标Java Bean支持的属性，事件和方法。

class

MethodDescriptor

MethodDescriptor描述了Java Bean支持的特定方法，用于从其他组件进行外部访问。

class

ParameterDescriptor

ParameterDescriptor类允许bean实现者提供关于每个参数的附加信息，超出java.lang.reflect.Method类提供的低级类型信息。

class

PersistenceDelegate

PersistenceDelegate类负责根据类的公共API中的方法来表达给定类的实例的状态。

class

PropertyChangeEvent

只要bean更改“bound”或“constrained”属性，就会传递一个“PropertyChange”事件。

class

PropertyChangeListenerProxy

一个类扩展了 EventListenerProxy专门用于添加一个“绑定”属性的 PropertyChangeListener 。

class

PropertyChangeSupport

这是一个可以由支持绑定属性的bean使用的实用程序类。

class

PropertyDescriptor

PropertyDescriptor描述了Java Bean通过一对访问器方法导出的一个属性。

class

PropertyEditorManager

PropertyEditorManager可用于查找任何给定类型名称的属性编辑器。

class

PropertyEditorSupport

这是一个帮助构建属性编辑器的支持类。

class

PropertyVetoException

当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。

class

SimpleBeanInfo

这是一个支持类，使人们更容易提供BeanInfo类。

class

Statement

一个 Statement对象表示一个原始语句，其中单个方法应用于目标和一组参数 - 如 "a.setFoo(b)" 。

class

VetoableChangeListenerProxy

它扩展了一类 EventListenerProxy专门用于添加 VetoableChangeListener具有“受限”属性。

class

VetoableChangeSupport

这是一个可以由支持约束属性的bean使用的实用程序类。

class

XMLDecoder

XMLDecoder类用于读取使用 XMLEncoder创建的XML文档，并且像 ObjectInputStream那样使用。

class

XMLEncoder

所述 XMLEncoder类是互补替代 ObjectOutputStream ，并且可以用于产生以相同的方式，该一个 JavaBean的文本表示 ObjectOutputStream可以用来创建的二进制表示 Serializable对象。

Methods in java.beans that return Object

Modifier and Type

方法

描述

Object

Encoder.get​(Object oldInstance)

在此流创建的环境中返回 oldInstance的临时值。

Object[]

Statement.getArguments​()

返回要调用的方法的参数。

static Object

Beans.getInstanceOf​(Object bean, Class<?> targetType)

从给定的bean获取表示该源对象的指定类型视图的对象。

Object

PropertyChangeEvent.getNewValue​()

获取属性的新值，表示为Object。

Object

PropertyChangeEvent.getOldValue​()

获取属性的旧值，表示为对象。

Object

XMLDecoder.getOwner​()

获取此解码器的所有者。

Object

XMLEncoder.getOwner​()

获取该编码器的所有者。

Object

PropertyChangeEvent.getPropagationId​()

“propagationId”字段保留供将来使用。

Object

PropertyEditorSupport.getSource​()

返回用作事件源的bean。

Object

EventHandler.getTarget​()

返回此事件处理程序将发送消息的对象。

Object

Statement.getTarget​()

返回此语句的目标对象。

Object

Expression.getValue​()

如果此实例的value属性尚未设置，则此方法使用这些参数动态地找到具有指定的methodName的方法并调用该实例。

Object

FeatureDescriptor.getValue​(String attributeName)

使用此功能检索命名属性。

Object

PropertyEditor.getValue​()

获取属性值。

Object

PropertyEditorSupport.getValue​()

获取属性的值。

static Object

Beans.instantiate​(ClassLoader cls, String beanName)

实例化JavaBean。

static Object

Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)

实例化JavaBean。

static Object

Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)

已过时。
建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

Object

EventHandler.invoke​(Object proxy, 方法 method, Object[] arguments)

从事件中提取适当的属性值，并将其传递到与此 EventHandler相关联的操作。

Object

XMLDecoder.readObject​()

从底层输入流读取下一个对象。

Object

Encoder.remove​(Object oldInstance)

删除此实例的条目，返回旧条目。

Methods in java.beans with parameters of type Object

Modifier and Type

方法

描述

static <T> T

EventHandler.create​(Class<T> listenerInterface, Object target, String action)

创建一个 listenerInterface的实现，其中监听器界面中的 所有方法将处理程序的 action应用于 target 。

static <T> T

EventHandler.create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName)

/ **创建一个 listenerInterface的实现，其中 所有方法将事件表达式 eventPropertyName的值传递给语句中的最终方法， action ，该方法应用于 target 。

static <T> T

EventHandler.create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)

创建的实施 listenerInterface其中命名方法 listenerMethodName传递事件表达，的值 eventPropertyName ，在语句中的最终方法， action ，其被施加到 target 。

static DefaultHandler

XMLDecoder.createHandler​(Object owner, ExceptionListener el, ClassLoader cl)

为SAX解析器创建一个新的处理程序，可用于解析由 XMLEncoder类创建的嵌入式XML归档。

PropertyEditor

PropertyDescriptor.createPropertyEditor​(Object bean)

使用当前的属性编辑器类构造一个属性编辑器的实例。

boolean

IndexedPropertyDescriptor.equals​(Object obj)

将此 PropertyDescriptor与指定对象进行比较。

boolean

PropertyDescriptor.equals​(Object obj)

将此 PropertyDescriptor与指定对象进行比较。

void

PropertyChangeSupport.fireIndexedPropertyChange​(String propertyName, int index, Object oldValue, Object newValue)

向已注册的监听器报告绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

PropertyChangeSupport.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

向已注册的监听器报告绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

VetoableChangeSupport.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)

向已注册的监听器报告受限属性更新，以跟踪所有属性的更新或具有指定名称的属性。

Object

Encoder.get​(Object oldInstance)

在此流创建的环境中返回 oldInstance的临时值。

static Object

Beans.getInstanceOf​(Object bean, Class<?> targetType)

从给定的bean获取表示该源对象的指定类型视图的对象。

protected void

DefaultPersistenceDelegate.initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)

这个 initialize方法的默认实现假设这个类型的对象中保存的所有状态都是通过匹配的“setter”和“getter”方法按照Introspector返回的顺序公开的。

protected void

PersistenceDelegate.initialize​(Class<?> type, Object oldInstance, Object newInstance, Encoder out)

对 newInstance产生一系列副作用的陈述，使新的实例变成 相当于 oldInstance 。

protected Expression

DefaultPersistenceDelegate.instantiate​(Object oldInstance, Encoder out)

instantiate方法的此默认实现将返回一个表达式，其中包含预定义方法名“new”，表示对具有 DefaultPersistenceDelegate构造函数中指定的参数的构造函数的调用。

protected abstract Expression

PersistenceDelegate.instantiate​(Object oldInstance, Encoder out)

返回一个值为 oldInstance的表达式。

Object

EventHandler.invoke​(Object proxy, 方法 method, Object[] arguments)

从事件中提取适当的属性值，并将其传递到与此 EventHandler相关联的操作。

static boolean

Beans.isInstanceOf​(Object bean, Class<?> targetType)

检查一个bean是否可以被看作给定的目标类型。

protected boolean

DefaultPersistenceDelegate.mutatesTo​(Object oldInstance, Object newInstance)

如果指定构造函数中的参数数量不为零，并且类别为 oldInstance显式声明“equals”方法，则此方法返回值为 oldInstance.equals(newInstance) 。

protected boolean

PersistenceDelegate.mutatesTo​(Object oldInstance, Object newInstance)

如果通过将一系列语句应用于 newInstance可以创建 oldInstance的 等效副本，则返回true。

Object

Encoder.remove​(Object oldInstance)

删除此实例的条目，返回旧条目。

void

Customizer.setObject​(Object bean)

设置要定制的对象。

void

XMLDecoder.setOwner​(Object owner)

将该解码器的所有者设置为 owner 。

void

XMLEncoder.setOwner​(Object owner)

将此编码器的所有者设置为 owner 。

void

PropertyChangeEvent.setPropagationId​(Object propagationId)

设置事件的propagationId对象。

void

PropertyEditorSupport.setSource​(Object source)

设置源bean。

void

Expression.setValue​(Object value)

将此表达式的值设置为 value 。

void

FeatureDescriptor.setValue​(String attributeName, Object value)

将命名属性与此功能相关联。

void

PropertyEditor.setValue​(Object value)

设置（或更改）要编辑的对象。

void

PropertyEditorSupport.setValue​(Object value)

设置（或更改）要编辑的对象。

protected void

Encoder.writeObject​(Object o)

将指定的对象写入输出流。

void

PersistenceDelegate.writeObject​(Object oldInstance, Encoder out)

writeObject是持久性的单个入口点，由传统的授权模式中的 Encoder使用。

void

XMLEncoder.writeObject​(Object o)

将指定对象的XML表示形式写入输出。

Constructors in java.beans with parameters of type Object

Constructor

描述

EventHandler​(Object target, String action, String eventPropertyName, String listenerMethodName)

创建一个新的EventHandler对象; 你通常使用一个create方法，而不是直接调用这个构造函数。

Expression​(Object value, Object target, String methodName, Object[] arguments)

使用指定的目标对象的指定值创建一个新的Expression对象，以调用由名称和参数数组指定的方法。

Expression​(Object target, String methodName, Object[] arguments)

为指定的目标对象创建一个新的Expression对象，以调用由名称和参数数组指定的方法。

IndexedPropertyChangeEvent​(Object source, String propertyName, Object oldValue, Object newValue, int index)

构造一个新的 IndexedPropertyChangeEvent对象。

PropertyChangeEvent​(Object source, String propertyName, Object oldValue, Object newValue)

构造新的 PropertyChangeEvent 。

PropertyChangeSupport​(Object sourceBean)

构造一个 PropertyChangeSupport对象。

PropertyEditorSupport​(Object source)

构造一个 PropertyEditorSupport对象。

Statement​(Object target, String methodName, Object[] arguments)

为指定的目标对象创建一个新的Statement对象，以调用由名称和参数数组指定的方法。

VetoableChangeSupport​(Object sourceBean)

构造一个 VetoableChangeSupport对象。

XMLDecoder​(InputStream in, Object owner)

创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。

XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener)

创建一个新的输入流，用于阅读由 XMLEncoder类创建的 XMLEncoder 。

XMLDecoder​(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)

创建一个新的输入流，用于阅读 XMLEncoder类创建的 XMLEncoder 。

Uses of Object in java.beans.beancontext

Subclasses of Object in java.beans.beancontext

Modifier and Type

Class

描述

class

BeanContextChildSupport

这是一个通用支持类，用于为实现BeanContextChild协议提供支持。

class

BeanContextEvent

BeanContextEvent是用于从发射的所有事件的抽象根事件类，和有关的语义，一个 BeanContext 。

class

BeanContextMembershipEvent

A BeanContextMembershipEvent封装了添加到特定 BeanContext的成员资格或从其中删除的子项列表。

class

BeanContextServiceAvailableEvent

BeanContextServicesListener使用此事件类型来识别正在注册的服务。

class

BeanContextServiceRevokedEvent

该事件类型由 BeanContextServiceRevokedListener用于识别正在撤销的服务。

class

BeanContextServicesSupport

这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。

protected class

BeanContextServicesSupport.BCSSChild

protected class

BeanContextServicesSupport.BCSSProxyServiceProvider

protected static class

BeanContextServicesSupport.BCSSServiceProvider

子类可以将此嵌套类子类化为每个BeanContextServicesProvider添加行为。

class

BeanContextSupport

这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。

protected class

BeanContextSupport.BCSChild

protected static class

BeanContextSupport.BCSIterator

受保护的final子类封装了一个迭代器，但实现了一个noop remove（）方法。

Fields in java.beans.beancontext declared as Object

Modifier and Type

Field

描述

static Object

BeanContext.globalHierarchyLock

这个全局锁由 BeanContext和 BeanContextServices实现者使用，以序列化 BeanContext层次结构和任何服务请求等中的更改。

Fields in java.beans.beancontext with type parameters of type Object

Modifier and Type

Field

描述

protected HashMap<Object,BeanContextSupport.BCSChild>

BeanContextSupport.children

对 protected HashMap children字段的所有访问应在该对象上同步。

protected HashMap<Object,BeanContextServicesSupport.BCSSServiceProvider>

BeanContextServicesSupport.services

应该对该对象同步对 protected transient HashMap services字段的所有访问

Methods in java.beans.beancontext that return Object

Modifier and Type

方法

描述

protected Object[]

BeanContextSupport.copyChildren​()

获取这个BeanContext的孩子的副本。

Object

BeanContextServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)

通过调用 BeanContextServices ，这种方法从这个请求服务的实例 BeanContextServiceProvider 。

Object

BeanContextServices.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)

A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。

Object

BeanContextServicesSupport.BCSSProxyServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)

Object

BeanContextServicesSupport.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)

获得可能委托的服务

Object

BeanContext.instantiateChild​(String beanName)

实例化命名为此 BeanContext的小孩的javaBean。

Object

BeanContextSupport.instantiateChild​(String beanName)

instantiateChild方法是BeanContext中的一个方便的钩子，用于简化将Bean实例化的任务嵌套到一个 BeanContext 。

Object

BeanContextSupport.BCSIterator.next​()

Object[]

BeanContextMembershipEvent.toArray​()

获取受此事件影响的子项数组。

Object[]

BeanContextSupport.toArray​()

获取当前嵌套在此BeanContext中的所有JavaBean或 BeanContext实例。

Object[]

BeanContextSupport.toArray​(Object[] arry)

获取一个包含此 BeanContext所有子项的数组，该数组与 BeanContext中包含的类型相匹配。

Methods in java.beans.beancontext that return types with arguments of type Object

Modifier and Type

方法

描述

Iterator<Object>

BeanContextServicesSupport.getCurrentServiceClasses​()

Iterator<Object>

BeanContextSupport.iterator​()

获取当前嵌套在此 BeanContext中的所有JavaBean或 BeanContext实例。

Methods in java.beans.beancontext with parameters of type Object

Modifier and Type

方法

描述

boolean

BeanContextSupport.add​(Object targetChild)

在这个 BeanContext内添加/嵌套一个孩子。

protected void

BeanContextSupport.childDeserializedHook​(Object child, BeanContextSupport.BCSChild bcsc)

由readObject与新反序列化的小孩和BCSChild调用。

protected void

BeanContextSupport.childJustAddedHook​(Object child, BeanContextSupport.BCSChild bcsc)

子类可以覆盖此方法，以便在添加子项之后和事件通知发生之前简单地扩展add（）语义。

protected void

BeanContextServicesSupport.childJustRemovedHook​(Object child, BeanContextSupport.BCSChild bcsc)

在孩子被成功删除之后从超类儿童删除操作中调用。 调用与子同步。

protected void

BeanContextSupport.childJustRemovedHook​(Object child, BeanContextSupport.BCSChild bcsc)

子类可以覆盖此方法，以便在子进程已被删除之后和事件通知发生之前简单地扩展remove（）语义。

boolean

BeanContextMembershipEvent.contains​(Object child)

孩子指定是否受到事件的影响？

boolean

BeanContextSupport.contains​(Object o)

确定指定的对象当前是否为此 BeanContext的子 BeanContext 。

boolean

BeanContextSupport.containsKey​(Object o)

确定指定的对象当前是否为此 BeanContext的子 BeanContext 。

protected BeanContextSupport.BCSChild

BeanContextServicesSupport.createBCSChild​(Object targetChild, Object peer)

子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。

protected BeanContextSupport.BCSChild

BeanContextSupport.createBCSChild​(Object targetChild, Object peer)

子类可以覆盖这个方法来插入他们自己的Child子类，而不必重写add（）或者添加子集的其他Collection方法。

void

BeanContextChildSupport.firePropertyChange​(String name, Object oldValue, Object newValue)

向任何已注册的监听器报告绑定属性更新。

void

BeanContextChildSupport.fireVetoableChange​(String name, Object oldValue, Object newValue)

向任何已注册的听众报告否决权属性更新。

protected static BeanContextChild

BeanContextSupport.getChildBeanContextChild​(Object child)

获取指定子节点的BeanContextChild（如果有）

protected static BeanContextMembershipListener

BeanContextSupport.getChildBeanContextMembershipListener​(Object child)

获取指定子节点的BeanContextMembershipListener（如果有）

protected static BeanContextServicesListener

BeanContextServicesSupport.getChildBeanContextServicesListener​(Object child)

获取指定的小孩的 BeanContextServicesListener （如果有的话）。

protected static PropertyChangeListener

BeanContextSupport.getChildPropertyChangeListener​(Object child)

获取指定子对象的PropertyChangeListener（如果有）

protected static Serializable

BeanContextSupport.getChildSerializable​(Object child)

获取与指定的Child相关联的Serializable（如果有）

protected static VetoableChangeListener

BeanContextSupport.getChildVetoableChangeListener​(Object child)

获取指定子节点的VetoableChangeListener（如果有）

protected static Visibility

BeanContextSupport.getChildVisibility​(Object child)

获取与指定子项关联的组件（如果有）。

Object

BeanContextServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)

通过调用 BeanContextServices ，这种方法从这个请求服务的实例 BeanContextServiceProvider 。

Object

BeanContextServices.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)

A BeanContextChild或与 BeanContextChild相关联的任何任意对象可以通过调用该方法从其嵌套 BeanContextServices获得对当前注册服务的引用。

Object

BeanContextServicesSupport.BCSSProxyServiceProvider.getService​(BeanContextServices bcs, Object requestor, Class<?> serviceClass, Object serviceSelector)

Object

BeanContextServicesSupport.getService​(BeanContextChild child, Object requestor, Class<?> serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)

获得可能委托的服务

void

BeanContextServiceProvider.releaseService​(BeanContextServices bcs, Object requestor, Object service)

此方法由 BeanContextServices调用，释放嵌套的 BeanContextChild （或任何与 BeanContextChild相关联的任意对象）对指定服务的引用。

void

BeanContextServices.releaseService​(BeanContextChild child, Object requestor, Object service)

通过在底层的 BeanContextServiceProvider上调用releaseService（），释放一个 BeanContextChild （或任何与BeanContextChild关联的任意对象）对指定服务的 BeanContextServiceProvider 。

void

BeanContextServicesSupport.BCSSProxyServiceProvider.releaseService​(BeanContextServices bcs, Object requestor, Object service)

void

BeanContextServicesSupport.releaseService​(BeanContextChild child, Object requestor, Object service)

发布服务

boolean

BeanContextSupport.remove​(Object targetChild)

从此BeanContext中删除一个小孩。

protected boolean

BeanContextSupport.remove​(Object targetChild, boolean callChildSetBC)

内部删除使用时，由意外 setBeanContext或 remove()调用引起的移除。

Object[]

BeanContextSupport.toArray​(Object[] arry)

获取一个数组，其中包含与该 BeanContext中包含的类型相匹配的所有这个 BeanContext子项。

protected boolean

BeanContextSupport.validatePendingAdd​(Object targetChild)

此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在添加到BeanContext之前立即检查子对象。

protected boolean

BeanContextSupport.validatePendingRemove​(Object targetChild)

此类的子类可以覆盖或包络此方法，以便为BeanContext添加验证行为，以便在BeanContext从BeanContext中删除之前立即检查子对象。

Constructors in java.beans.beancontext with parameters of type Object

Constructor

描述

BeanContextMembershipEvent​(BeanContext bc, Object[] changes)

引发BeanContextMembershipEvent

Uses of Object in java.io

Subclasses of Object in java.io

Modifier and Type

Class

描述

class

BufferedInputStream

A BufferedInputStream为另一个输入流添加了功能，即缓冲输入并支持 mark和 reset方法的功能。

class

BufferedOutputStream

该类实现缓冲输出流。

class

BufferedReader

从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。

class

BufferedWriter

将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。

class

ByteArrayInputStream

A ByteArrayInputStream包含一个内部缓冲区，其中包含可以从流中读取的字节。

class

ByteArrayOutputStream

该类实现了将数据写入字节数组的输出流。

class

CharArrayReader

该类实现了一个字符缓冲区，可以用作字符输入流。

class

CharArrayWriter

该类实现了可以用作Writer的字符缓冲区。

class

CharConversionException

字符转换异常的基类。

class

Console

访问与当前Java虚拟机关联的基于字符的控制台设备（如果有的话）的方法。

class

DataInputStream

数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。

class

DataOutputStream

数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。

class

EOFException

表示在输入过程中意外地到达文件结束或流结束。

class

File

文件和目录路径名的抽象表示。

class

FileDescriptor

文件描述符类的实例用作表示打开文件，开放套接字或其他字节源或信宿的底层机器特定结构的不透明句柄。

class

FileInputStream

A FileInputStream从文件系统中的文件获取输入字节。

class

FileNotFoundException

指示尝试打开由指定路径名表示的文件失败。

class

FileOutputStream

文件输出流是用于将数据写入 File或 FileDescriptor的输出流。

class

FilePermission

此类表示访问文件或目录。

class

FileReader

阅读字符文件的便利课。

class

FileWriter

方便课写字符文件。

class

FilterInputStream

A FilterInputStream包含一些其他输入流，它用作其基本的数据源，可能会沿着路径转换数据或提供附加功能。

class

FilterOutputStream

这个类是过滤输出流的所有类的超类。

class

FilterReader

用于读取过滤后的字符流的抽象类。

class

FilterWriter

用于编写过滤后的字符流的抽象类。

class

InputStream

这个抽象类是表示输入字节流的所有类的超类。

class

InputStreamReader

InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。

class

InterruptedIOException

表示I / O操作已中断。

class

InvalidClassException

当序列化运行时检测到类中的以下问题之一时抛出。

class

InvalidObjectException

表示一个或多个反序列化对象失败的验证测试。

class

IOError

当出现严重I / O错误时抛出。

class

IOException

表示发生某种类型的I / O异常。

class

LineNumberInputStream

已过时。
该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。

class

LineNumberReader

缓冲字符输入流，跟踪行号。

class

NotActiveException

序列化或反序列化不活跃时抛出。

class

NotSerializableException

抛出一个实例需要一个Serializable接口。

static class

ObjectInputFilter.Config

一个实用程序类，用于设置和获取过程范围的过滤器或从模式字符串创建过滤器。

class

ObjectInputStream

ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。

static class

ObjectInputStream.GetField

提供对从输入流读取的持久性字段的访问。

class

ObjectOutputStream

ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。

static class

ObjectOutputStream.PutField

提供对要写入ObjectOutput的持久字段的编程访问。

class

ObjectStreamClass

序列化的类的描述符。

class

ObjectStreamException

对象流类别特有的所有异常的超类。

class

ObjectStreamField

Serializable类的Serializable字段的描述。

class

OptionalDataException

表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。

class

OutputStream

这个抽象类是表示字节输出流的所有类的超类。

class

OutputStreamWriter

OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入其的字符编码为字节。

class

PipedInputStream

管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。

class

PipedOutputStream

管道输出流可以连接到管道输入流以创建通信管道。

class

PipedReader

流水字符输入流。

class

PipedWriter

流水字符输出流。

class

PrintStream

A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。

class

PrintWriter

将对象的格式表示打印到文本输出流。

class

PushbackInputStream

A PushbackInputStream通过将推回的字节存储在内部缓冲区中，为另一个输入流添加功能，即“推回”或“未读”字节的功能。

class

PushbackReader

一个字符流读取器，允许将字符推回到流中。

class

RandomAccessFile

该类的实例支持读取和写入随机访问文件。

class

Reader

用于读取字符流的抽象类。

class

SequenceInputStream

A SequenceInputStream表示其他输入流的逻辑级联。

class

SerializablePermission

这个类用于Serializable权限。

class

StreamCorruptedException

当从对象流读取的控制信息违反内部一致性检查时抛出。

class

StreamTokenizer

StreamTokenizer类接收输入流并将其解析为“令牌”，允许一次读取一个令牌。

class

StringBufferInputStream

已过时。
此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。

class

StringReader

一个字符流，其源是一个字符串。

class

StringWriter

在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。

class

SyncFailedException

发出同步操作失败的信号。

class

UncheckedIOException

包装一个IOException与未经检查的异常。

class

UnsupportedEncodingException

字符编码不支持。

class

UTFDataFormatException

表示 modified UTF-8格式的格式不正确的字符串已被读入数据输入流或实现数据输入接口的任何类。

class

WriteAbortedException

指示在写入操作期间抛出ObjectStreamExceptions之一。

class

Writer

用于写入字符流的抽象类。

Fields in java.io declared as Object

Modifier and Type

Field

描述

protected Object

Reader.lock

用于同步此流上的操作的对象。

protected Object

Writer.lock

用于同步此流上的操作的对象。

Methods in java.io that return Object

Modifier and Type

方法

描述

abstract Object

ObjectInputStream.GetField.get​(String name, Object val)

从持久化字段获取命名的对象字段的值。

Object

ObjectInput.readObject​()

读取并返回一个对象。

Object

ObjectInputStream.readObject​()

从ObjectInputStream读取一个对象。

protected Object

ObjectInputStream.readObjectOverride​()

此方法由ObjectOutputStream的受信任子类调用，该子类使用受保护的无参构造函数构造ObjectOutputStream。

Object

ObjectInputStream.readUnshared​()

从ObjectInputStream读取一个“非共享”对象。

protected Object

ObjectOutputStream.replaceObject​(Object obj)

该方法将允许ObjectOutputStream的可信子类在序列化期间将一个对象替换为另一个对象。

protected Object

ObjectInputStream.resolveObject​(Object obj)

此方法将允许ObjectInputStream的受信任子类在反序列化期间将一个对象替换为另一个对象。

Methods in java.io with parameters of type Object

Modifier and Type

方法

描述

int

ObjectStreamField.compareTo​(Object obj)

将此字段与另一个 ObjectStreamField进行比较。

boolean

File.equals​(Object obj)

测试此抽象路径名与给定对象的相等性。

boolean

FilePermission.equals​(Object obj)

检查两个FilePermission对象是否相等。

Console

Console.format​(String fmt, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流。

PrintStream

PrintStream.format​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流。

PrintStream

PrintStream.format​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流。

PrintWriter

PrintWriter.format​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此写入程序。

PrintWriter

PrintWriter.format​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此写入程序。

abstract Object

ObjectInputStream.GetField.get​(String name, Object val)

从持久化字段获取命名的对象字段的值。

void

PrintStream.print​(Object obj)

打印一个对象。

void

PrintWriter.print​(Object obj)

打印一个对象。

Console

Console.printf​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流的便利方法。

PrintStream

PrintStream.printf​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。

PrintStream

PrintStream.printf​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。

PrintWriter

PrintWriter.printf​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。

PrintWriter

PrintWriter.printf​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。

void

PrintStream.println​(Object x)

打印一个对象，然后终止该行。

void

PrintWriter.println​(Object x)

打印一个对象，然后终止该行。

abstract void

ObjectOutputStream.PutField.put​(String name, Object val)

将命名的对象字段的值放入持久字段。

String

Console.readLine​(String fmt, Object... args)

提供一个格式化的提示，然后从控制台读取一行文本。

char[]

Console.readPassword​(String fmt, Object... args)

提供一个格式化的提示，然后从禁用回显的控制台读取密码或密码。

protected Object

ObjectOutputStream.replaceObject​(Object obj)

该方法将允许ObjectOutputStream的可信子类在序列化期间将一个对象替换为另一个对象。

protected Object

ObjectInputStream.resolveObject​(Object obj)

此方法将允许ObjectInputStream的受信任子类在反序列化期间将一个对象替换为另一个对象。

void

ObjectOutput.writeObject​(Object obj)

将对象写入底层存储或流。

void

ObjectOutputStream.writeObject​(Object obj)

将指定的对象写入ObjectOutputStream。

protected void

ObjectOutputStream.writeObjectOverride​(Object obj)

子类使用的方法来覆盖默认的writeObject方法。

void

ObjectOutputStream.writeUnshared​(Object obj)

将“非共享”对象写入ObjectOutputStream。

Constructors in java.io with parameters of type Object

Constructor

描述

Reader​(Object lock)

创建一个新的字符流阅读器，其关键部分将在给定对象上同步。

Writer​(Object lock)

创建一个新的字符流写入器，其关键部分将在给定对象上进行同步。

Uses of Object in java.lang

Subclasses of Object in java.lang

Modifier and Type

Class

描述

class

AbstractMethodError

当应用程序尝试调用抽象方法时抛出。

class

ArithmeticException

抛出异常算术条件时抛出。

class

ArrayIndexOutOfBoundsException

抛出以表示使用非法索引访问数组。

class

ArrayStoreException

抛出以表示尝试将错误类型的对象存储到对象数组中。

class

AssertionError

抛出以表明断言失败。

class

Boolean

布尔类将对象中的基元类型 boolean的值进行包装。

class

BootstrapMethodError

抛出以表明invokedynamic指令未能找到其引导方法，或引导方法无法提供call site的target的正确的method type 。

class

Byte

Byte类包装一个对象中的原始类型 byte的值。

class

Character

Character类包装一个对象中的基元类型 char的值。

static class

Character.Subset

该类的实例表示Unicode字符集的特定子集。

static class

Character.UnicodeBlock

一系列字符子集，表示Unicode规范中的字符块。

class

Class<T>

类 Class实例表示正在运行的Java应用程序中的类和接口。

class

ClassCastException

抛出表示代码尝试将对象转换为不属于实例的子类。

class

ClassCircularityError

当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。

class

ClassFormatError

当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。

class

ClassLoader

类加载器是负责加载类的对象。

class

ClassNotFoundException

的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。

class

ClassValue<T>

将计算的值与（潜在地）每种类型相关联。

class

CloneNotSupportedException

抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。

class

Compiler

不推荐用于删除：此API元素将在以后的版本中被删除。
JIT编译器及其技术变化太大，可以通过标准化界面有效地进行控制。 因此，许多JIT编译器实现忽略此接口，而是由特定于实现的机制（如命令行选项）控制。 此类可能在将来的Java SE版本中被删除。

class

Double

Double类包装一个对象中的原始类型 double的值。

class

Enum<E extends Enum<E>>

这是所有Java语言枚举类型的公共基类。

class

EnumConstantNotPresentException

当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。

class

Error

一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。

class

异常

异常及其子类是 Throwable的形式，表示合理的应用程序可能想要捕获的条件。

class

ExceptionInInitializerError

表示在静态初始化程序中发生意外异常。

class

Float

Float类包装一个对象中的原始类型 float的值。

class

IllegalAccessError

如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。

class

IllegalAccessException

当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。

class

IllegalArgumentException

抛出表示一种方法已经通过了非法或不正确的参数。

class

IllegalCallerException

被抛出来表示一个方法已被不适当的调用者调用。

class

IllegalMonitorStateException

抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。

class

IllegalStateException

表示在非法或不适当的时间调用了一种方法。

class

IllegalThreadStateException

抛出以指示线程不处于所请求操作的适当状态。

class

IncompatibleClassChangeError

当一些类定义发生不兼容的类更改时抛出。

class

IndexOutOfBoundsException

抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。

class

InheritableThreadLocal<T>

该类扩展了 ThreadLocal以提供从父线程到子线程的值的继承：当子线程被创建时，子接收到父值具有值的所有可继承的线程局部变量的初始值。

class

InstantiationError

当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。

class

InstantiationException

当应用程序试图创建使用一个类的实例抛出 newInstance方法在类 Class ，而指定的类对象不能被实例化。

class

Integer

Integer类包装一个对象中的原始类型 int的值。

class

InternalError

在Java虚拟机中引发了一些意外的内部错误。

class

InterruptedException

线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。

class

LayerInstantiationException

创建module layer时抛出失败。

class

LinkageError

LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。

class

Long

Long类包装一个对象中的原始类型 long的值。

class

Math

类 Math包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。

class

Module

代表一个运行时模块，无论是 named还是未命名的。

class

ModuleLayer

Java虚拟机中的一层模块。

static class

ModuleLayer.Controller

控制模块层。

class

NegativeArraySizeException

抛出一个应用程序尝试创建一个负数大小的数组。

class

NoClassDefFoundError

如果Java虚拟机或 ClassLoader实例尝试加载类的定义（作为普通方法调用的一部分或作为使用 new表达式创建新实例的 new ），则可能会 new此 new并且不会找到该类的定义。

class

NoSuchFieldError

如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。

class

NoSuchFieldException

表示该类没有指定名称的字段。

class

NoSuchMethodError

如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。

class

NoSuchMethodException

当无法找到特定方法时抛出。

class

NullPointerException

当应用程序在需要对象的情况下尝试使用 null时抛出。

class

Number

抽象类 Number是表示数字值可转换为基本数据类型平台类的超类 byte ， double ， float ， int ， long ，和 short 。

class

NumberFormatException

抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。

class

OutOfMemoryError

当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。

class

软件包

表示与类加载器关联的运行时包的元数据。

class

Process

Process提供了由ProcessBuilder.start和Runtime.exec启动的本机进程的控制。

class

ProcessBuilder

此类用于创建操作系统进程。

static class

ProcessBuilder.Redirect

表示子进程输入的源或子进程输出的目的地。

class

ReflectiveOperationException

核心反射中的反射操作抛出的异常的常见超类。

class

Runtime

每个Java应用程序都有一个 Runtime类的 Runtime ，允许应用程序与运行应用程序的环境进行接口。

static class

Runtime.Version

用于实现Java SE平台的版本字符串的表示。

class

RuntimeException

RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。

class

RuntimePermission

此类用于运行时权限。

class

SecurityException

由安全管理员抛出，表示安全违规。

class

SecurityManager

安全管理器是允许应用程序实施安全策略的类。

class

Short

Short类包装一个对象中的原始类型 short的值。

class

StackOverflowError

当堆栈溢出发生时抛出一个应用程序递归太深。

class

StackTraceElement

堆栈跟踪中的元素，由 Throwable.getStackTrace()返回。

class

StackWalker

堆栈步行者。

class

StrictMath

类 StrictMath包含执行基本数字运算的方法，如基本指数，对数，平方根和三角函数。

class

String

String类代表字符串。

class

StringBuffer

线程安全，可变的字符序列。

class

StringBuilder

一个可变的字符序列。

class

StringIndexOutOfBoundsException

抛出 String方法来指示索引为负或大于字符串的大小。

class

System

System类包含几个有用的类字段和方法。

static class

System.LoggerFinder

LoggerFinder服务负责创建，管理和配置记录器到其使用的基础框架。

class

Thread

线程是程序中执行的线程。

class

ThreadDeath

当调用（不建议使用的） Thread.stop()方法时，将在受害者线程中抛出 ThreadDeath的实例。

class

ThreadGroup

线程组代表一组线程。

class

ThreadLocal<T>

这个类提供线程局部变量。

class

Throwable

Throwable类是Java语言中所有错误和异常的超类。

class

TypeNotPresentException

当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。

class

UnknownError

当Java虚拟机中出现未知但严重的异常时抛出。

class

UnsatisfiedLinkError

如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。

class

UnsupportedClassVersionError

当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。

class

UnsupportedOperationException

抛出以表示不支持请求的操作。

class

VerifyError

当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。

class

VirtualMachineError

抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。

class

Void

Void类是一个不可抗拒的占位符类，用于保存对表示Java关键字void的 Class对象的引用。

Methods in java.lang that return Object

Modifier and Type

方法

描述

protected Object

Enum.clone​()

抛出CloneNotSupportedException。

protected Object

Object.clone​()

创建并返回此对象的副本。

protected Object

Thread.clone​()

将CloneNotSupportedException作为线程抛出无法有意义地克隆。

static Object

Compiler.command​(Object any)

不推荐用于删除：此API元素将在以后的版本中被删除。

检查参数类型及其字段并执行一些文档化操作。

protected Object

ClassLoader.getClassLoadingLock​(String className)

返回类加载操作的锁定对象。

T[]

Class.getEnumConstants​()

返回此枚举类的元素，如果此Class对象不表示枚举类型，则返回null。

Object

SecurityManager.getSecurityContext​()

创建封装当前执行环境的对象。

Object[]

Class.getSigners​()

获得这个类的签名者。

Methods in java.lang with parameters of type Object

Modifier and Type

方法

描述

StringBuffer

StringBuffer.append​(Object obj)

StringBuilder

StringBuilder.append​(Object obj)

static void

System.arraycopy​(Object src, int srcPos, Object dest, int destPos, int length)

将指定源数组中的数组从指定位置复制到目标数组的指定位置。

T

Class.cast​(Object obj)

将对象转换为由该 Class对象表示的类或接口。

void

SecurityManager.checkConnect​(String host, int port, Object context)

如果指定的安全上下文不允许打开到指定的主机和端口号的套接字连接，则抛出一个 SecurityException 。

void

SecurityManager.checkPermission​(Permission perm, Object context)

如果指定的安全上下文被拒绝访问由给定权限指定的资源，则抛出一个 SecurityException 。

void

SecurityManager.checkRead​(String file, Object context)

如果指定的安全上下文不允许读取由字符串参数指定的文件，则抛出一个 SecurityException 。

boolean

SecurityManager.checkTopLevelWindow​(Object window)

不推荐用于删除：此API元素将在以后的版本中被删除。
该方法最初用于检查调用线程是否被信任以启动顶级窗口。 该方法已被废弃，代码应使用SecurityManager.checkPermission(java.security.Permission)来检查AWTPermission("showWindowWithoutWarningBanner") 。 此方法在将来的Java SE版本中可能会被删除。

static Object

Compiler.command​(Object any)

不推荐用于删除：此API元素将在以后的版本中被删除。

检查参数类型及其字段并执行一些文档化操作。

boolean

Boolean.equals​(Object obj)

返回 true当且仅当该参数不是 null并且是一个 Boolean对象，该对象表示与此对象相同的 boolean值。

boolean

Byte.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

Character.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

Character.Subset.equals​(Object obj)

比较两个 Subset对象的相等性。

boolean

Double.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

Enum.equals​(Object other)

如果指定的对象等于此枚举常量，则返回true。

boolean

Float.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

Integer.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

Long.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

Object.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

ProcessBuilder.Redirect.equals​(Object obj)

将指定的对象与此 Redirect进行比较以获得相等性。

boolean

ProcessHandle.equals​(Object other)

返回true如果other对象是非空的，是相同的实现，并表示相同的系统进程; 否则返回false 。

boolean

Runtime.Version.equals​(Object obj)

确定此 Version是否等于另一个对象。

boolean

Short.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

StackTraceElement.equals​(Object obj)

如果指定的对象是另一个表示与该实例相同的执行点的 StackTraceElement实例，则返回true。

boolean

String.equals​(Object anObject)

将此字符串与指定对象进行比较。

boolean

Runtime.Version.equalsIgnoreOptional​(Object obj)

确定此 Version是否等于另一个忽略可选构建信息。

static String

String.format​(String format, Object... args)

使用指定的格式字符串和参数返回格式化的字符串。

static String

String.format​(Locale l, String format, Object... args)

使用指定的区域设置，格式字符串和参数返回格式化的字符串。

static boolean

Thread.holdsLock​(Object obj)

当且仅当当前线程持有指定对象上的监视器锁时，才返回 true 。

static int

System.identityHashCode​(Object x)

返回与默认方法hashCode（）返回的给定对象相同的哈希码，无论给定对象的类是否覆盖了hashCode（）。

StringBuffer

StringBuffer.insert​(int offset, Object obj)

StringBuilder

StringBuilder.insert​(int offset, Object obj)

boolean

Class.isInstance​(Object obj)

确定指定的 Object是否与此 Class表示的对象分配兼容。

default void

System.Logger.log​(System.Logger.Level level, Object obj)

记录从给定对象生成的消息。

default void

System.Logger.log​(System.Logger.Level level, String format, Object... params)

使用可选参数列表记录消息。

void

System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String format, Object... params)

使用资源束和可选的参数列表记录消息。

protected void

ClassLoader.setSigners​(Class<?> c, Object[] signers)

设置一个类的签名者。

static String

String.valueOf​(Object obj)

返回 Object参数的字符串表示形式。

Constructors in java.lang with parameters of type Object

Constructor

描述

AssertionError​(Object detailMessage)

构造具有从指定的对象派生其详细消息，如在 The Java™ Language Specification部15.18.1.1的定义转换为字符串一个AssertionError。

Uses of Object in java.lang.annotation

Subclasses of Object in java.lang.annotation

Modifier and Type

Class

描述

class

AnnotationFormatError

当注释解析器尝试从类文件读取注释并确定注释格式错误时抛出。

class

AnnotationTypeMismatchException

抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。

class

IncompleteAnnotationException

抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。

Methods in java.lang.annotation with parameters of type Object

Modifier and Type

方法

描述

boolean

Annotation.equals​(Object obj)

如果指定的对象表示在逻辑上等同于该注释的注释，则返回true。

Uses of Object in java.lang.instrument

Subclasses of Object in java.lang.instrument

Modifier and Type

Class

描述

class

ClassDefinition

该类作为 Instrumentation.redefineClasses方法的参数块。

class

IllegalClassFormatException

当其输入参数无效时，执行 ClassFileTransformer.transform时抛出。

class

UnmodifiableClassException

当其中一个指定的类不能修改时，通过执行 Instrumentation.redefineClasses抛出。

class

UnmodifiableModuleException

抛出以表示模块无法修改。

Methods in java.lang.instrument with parameters of type Object

Modifier and Type

方法

描述

long

Instrumentation.getObjectSize​(Object objectToSize)

返回指定对象所消耗的存储量的实现特定近似值。

Uses of Object in java.lang.invoke

Subclasses of Object in java.lang.invoke

Modifier and Type

Class

描述

class

CallSite

A CallSite是变量MethodHandle的持有人，称为其target 。

class

ConstantCallSite

A ConstantCallSite是一个CallSite，其目标是永久性的，永远不能更改。

class

LambdaConversionException

LambdaConversionException

class

LambdaMetafactory

方法是通过委派给所提供的MethodHandle来实现一个或多个接口的简单“功能对象”的创建，可能在类型适配和参数的部分评估之后。

class

MethodHandle

方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。

class

MethodHandleProxies

此类仅由静态方法组成，可帮助将方法句柄修改为其他JVM类型（如接口）。

class

MethodHandles

该类仅由静态方法组成，或者返回方法句柄。

static class

MethodHandles.Lookup

查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。

class

MethodType

方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。

class

MutableCallSite

A MutableCallSite是一个CallSite，其目标变量的行为像一个普通字段。

class

SerializedLambda

lambda表达式的序列化形式。

class

StringConcatException

当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。

class

StringConcatFactory

有助于创建String连接方法的方法，可用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。

class

SwitchPoint

A SwitchPoint是可以将状态转换发布到其他线程的对象。

class

VarHandle

VarHandle是对变量或参数定义的变量系列的动态强类型引用，包括静态字段，非静态字段，数组元素或非堆组数据结构的组件。

class

VolatileCallSite

A VolatileCallSite是一个CallSite，其目标像一个volatile变量。

class

WrongMethodTypeException

抛出以表示代码尝试通过错误的方法类型调用方法句柄。

Methods in java.lang.invoke that return Object

Modifier and Type

方法

描述

Object

VarHandle.compareAndExchange​(Object... args)

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getVolatile(java.lang.Object...) 。

Object

VarHandle.compareAndExchangeAcquire​(Object... args)

将变量的值原子设置为 newValue ，其内存语义为 VarHandle.set(java.lang.Object...)，如果变量的当前值（称为 见证值 ==为 expectedValue ，因为内存语义为 VarHandle.getAcquire(java.lang.Object...) 。

Object

VarHandle.compareAndExchangeRelease​(Object... args)

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.setRelease(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.get(java.lang.Object...) 。

Object

VarHandle.get​(Object... args)

返回一个变量的值，读取的内存语义就好像变量被声明为非 volatile 。

Object

VarHandle.getAcquire​(Object... args)

返回变量的值，并确保后续加载和存储在此访问之前未重新排序。

Object

VarHandle.getAndAdd​(Object... args)

以原子添加 value用的内存语义变量的当前值 VarHandle.setVolatile(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.getVolatile(java.lang.Object...) 。

Object

VarHandle.getAndAddAcquire​(Object... args)

以原子添加 value用的内存语义变量的当前值 VarHandle.set(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.getAcquire(java.lang.Object...) 。

Object

VarHandle.getAndAddRelease​(Object... args)

以原子添加 value用的内存语义变量的当前值 VarHandle.setRelease(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.get(java.lang.Object...) 。

Object

VarHandle.getAndBitwiseAnd​(Object... args)

原子地将变量的值设置为变量当前值与 mask的内存语义的 mask之间按位AND的结果，并返回变量的先前值，如使用内存语义 VarHandle.getVolatile(java.lang.Object...)访问的。

Object

VarHandle.getAndBitwiseAndAcquire​(Object... args)

原子地将变量的值设置为变量当前值与 mask的存储器语义的 mask之间的按位AND的结果，并返回变量的先前值，内存语义为 VarHandle.getAcquire(java.lang.Object...) 。

Object

VarHandle.getAndBitwiseAndRelease​(Object... args)

将变量的值原子设置为变量的当前值与 mask的内存语义的 mask之间的按位AND的结果，并返回变量的先前值，如使用内存语义 VarHandle.get(java.lang.Object...)所访问的。

Object

VarHandle.getAndBitwiseOr​(Object... args)

原子地将变量的值设置为变量的当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的上一个值，并使用内存语义 VarHandle.getVolatile(java.lang.Object...)访问。

Object

VarHandle.getAndBitwiseOrAcquire​(Object... args)

将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的上一个值，内存语义为 VarHandle.getAcquire(java.lang.Object...) 。

Object

VarHandle.getAndBitwiseOrRelease​(Object... args)

将变量的值原子设置为变量的当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的先前值，并使用内存语义 VarHandle.get(java.lang.Object...)访问。

Object

VarHandle.getAndBitwiseXor​(Object... args)

将变量的值原子设置为变量的当前值与 mask的内存语义的 mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为 VarHandle.getVolatile(java.lang.Object...) 。

Object

VarHandle.getAndBitwiseXorAcquire​(Object... args)

原子地将变量的值设置为变量当前值与 mask的存储器语义的 mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为 VarHandle.getAcquire(java.lang.Object...) 。

Object

VarHandle.getAndBitwiseXorRelease​(Object... args)

将变量的值原子设置为变量当前值与 mask的内存语义的 mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为 VarHandle.get(java.lang.Object...) 。

Object

VarHandle.getAndSet​(Object... args)

原子地将变量的值设置为 newValue ，其内存语义为 VarHandle.setVolatile(java.lang.Object...)，并返回变量的先前值，如使用 VarHandle.getVolatile(java.lang.Object...)的内存语义访问的。

Object

VarHandle.getAndSetAcquire​(Object... args)

原子地将变量的值设置为 newValue ，其内存语义为 VarHandle.set(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.getAcquire(java.lang.Object...)访问的。

Object

VarHandle.getAndSetRelease​(Object... args)

将变量的值原子设置为 newValue ，其内存语义为 VarHandle.setRelease(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.get(java.lang.Object...)访问的。

Object

SerializedLambda.getCapturedArg​(int i)

获取lambda捕获站点的动态参数。

Object

VarHandle.getOpaque​(Object... args)

返回以程序顺序访问的变量的值，但不能保证相对于其他线程的内存排序效果。

Object

VarHandle.getVolatile​(Object... args)

返回一个变量的值，具有读取的内存语义，就像变量被声明为 volatile 。

Object

MethodHandle.invoke​(Object... args)

调用方法句柄，允许任何调用者类型描述符，以及可选地对参数和返回值执行转换。

Object

MethodHandle.invokeExact​(Object... args)

调用方法句柄，允许任何调用者类型描述符，但需要确切的类型匹配。

Object

MethodHandle.invokeWithArguments​(Object... arguments)

执行可变元数调用，传递的参数在给定列表的方法处理，就好像通过不精确 invoke从呼叫位点，其仅提到类型 Object ，且其元数是参数列表的长度。

Object

MethodHandle.invokeWithArguments​(List<?> arguments)

执行可变元数调用，传递参数给定的阵列中的方法处理，就好像通过不精确 invoke从呼叫位点，其仅提到类型 Object ，且其元数是参数阵列的长度。

Methods in java.lang.invoke with parameters of type Object

Modifier and Type

方法

描述

static CallSite

LambdaMetafactory.altMetafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)

在适当的类型适配和参数的部分评估后，便于创建简单的“功能对象”，通过委派给所提供的MethodHandle来实现一个或多个接口。

MethodHandle

MethodHandles.Lookup.bind​(Object receiver, String name, MethodType type)

为非静态方法生成早期绑定的方法句柄。

MethodHandle

MethodHandle.bindTo​(Object x)

将值 x绑定到方法句柄的第一个参数，而不调用它。

Object

VarHandle.compareAndExchange​(Object... args)

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getVolatile(java.lang.Object...) 。

Object

VarHandle.compareAndExchangeAcquire​(Object... args)

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getAcquire(java.lang.Object...) 。

Object

VarHandle.compareAndExchangeRelease​(Object... args)

以原子方式设置的变量的值 newValue用的存储器语义 VarHandle.setRelease(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.get(java.lang.Object...) 。

boolean

VarHandle.compareAndSet​(Object... args)

将变量的值原子设置为 newValue ，其内存语义为 VarHandle.setVolatile(java.lang.Object...)，如果变量的当前值，被称为 见证值 == ， expectedValue ，由于内存语义为 VarHandle.getVolatile(java.lang.Object...) 。

static MethodHandle

MethodHandles.constant​(Class<?> type, Object value)

生成请求的返回类型的方法句柄，每次调用时返回给定的常量值。

boolean

MethodType.equals​(Object x)

将指定的对象与此类型进行比较以获得相等性。

Object

VarHandle.get​(Object... args)

返回一个变量的值，具有读取的内存语义，就好像变量被声明为非 volatile 。

Object

VarHandle.getAcquire​(Object... args)

返回变量的值，并确保后续加载和存储在此访问之前未重新排序。

Object

VarHandle.getAndAdd​(Object... args)

以原子添加 value用的内存语义变量的当前值 VarHandle.setVolatile(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.getVolatile(java.lang.Object...) 。

Object

VarHandle.getAndAddAcquire​(Object... args)

以原子添加 value用的内存语义变量的当前值 VarHandle.set(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 VarHandle.getAcquire(java.lang.Object...) 。

Object

VarHandle.getAndAddRelease​(Object... args)

原子 value添加到存储器语义为 VarHandle.setRelease(java.lang.Object...)的变量的当前值，并返回变量的先前值，如使用内存语义 VarHandle.get(java.lang.Object...)访问的。

Object

VarHandle.getAndBitwiseAnd​(Object... args)

将变量的值原子设置为变量的当前值与 mask之间的按位AND的结果，其内存语义为 VarHandle.setVolatile(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.getVolatile(java.lang.Object...)访问的。

Object

VarHandle.getAndBitwiseAndAcquire​(Object... args)

原子地将变量的值设置为变量当前值与 mask之间的按位AND的结果，内存语义为 VarHandle.set(java.lang.Object...)，并返回变量的上一个值，并使用内存语义为 VarHandle.getAcquire(java.lang.Object...)进行访问。

Object

VarHandle.getAndBitwiseAndRelease​(Object... args)

将变量的值原子设置为变量当前值与 mask之间的按位AND的结果，其内存语义为 VarHandle.setRelease(java.lang.Object...)，并返回变量的上一个值，内存语义为 VarHandle.get(java.lang.Object...) 。

Object

VarHandle.getAndBitwiseOr​(Object... args)

将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的上一个值，如使用内存语义 VarHandle.getVolatile(java.lang.Object...)访问的。

Object

VarHandle.getAndBitwiseOrAcquire​(Object... args)

原子地将变量的值设置为变量当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的上一个值，如使用内存语义 VarHandle.getAcquire(java.lang.Object...)访问的。

Object

VarHandle.getAndBitwiseOrRelease​(Object... args)

原子地将变量的值设置为变量当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的先前值，如使用存储器语义 VarHandle.get(java.lang.Object...)访问的。

Object

VarHandle.getAndBitwiseXor​(Object... args)

将变量的值原子设置为变量当前值和 mask之间按位XOR的结果，内存语义为 VarHandle.setVolatile(java.lang.Object...)，并返回变量的上一个值，内存语义为 VarHandle.getVolatile(java.lang.Object...) 。

Object

VarHandle.getAndBitwiseXorAcquire​(Object... args)

将变量的值原子设置为变量的当前值与 mask的存储器语义的 mask之间的按位XOR的结果，并返回变量的上一个值，如使用内存语义 VarHandle.getAcquire(java.lang.Object...)访问的。

Object

VarHandle.getAndBitwiseXorRelease​(Object... args)

将变量的值原子设置为变量当前值和 mask与内存语义为 VarHandle.setRelease(java.lang.Object...)的 mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为 VarHandle.get(java.lang.Object...) 。

Object

VarHandle.getAndSet​(Object... args)

将变量的值原子设置为 newValue ，其内存语义为 VarHandle.setVolatile(java.lang.Object...)，并返回变量的上一个值，如使用 VarHandle.getVolatile(java.lang.Object...)的内存语义访问的。

Object

VarHandle.getAndSetAcquire​(Object... args)

原子地将变量的值设置为 newValue ，其内存语义为 VarHandle.set(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.getAcquire(java.lang.Object...)访问的。

Object

VarHandle.getAndSetRelease​(Object... args)

原子地将变量的值设置为 newValue ，其内存语义为 VarHandle.setRelease(java.lang.Object...)，并返回变量的先前值，如使用内存语义 VarHandle.get(java.lang.Object...)访问的。

Object

VarHandle.getOpaque​(Object... args)

返回以程序顺序访问的变量的值，但不能保证相对于其他线程的内存排序效果。

Object

VarHandle.getVolatile​(Object... args)

返回变量的值，读取的内存语义就像变量声明为 volatile 。

static MethodHandle

MethodHandles.insertArguments​(MethodHandle target, int pos, Object... values)

在方法句柄的调用之前提供一个具有一个或多个 绑定参数的目标方法句柄。

Object

MethodHandle.invoke​(Object... args)

调用方法句柄，允许任何调用者类型描述符，以及可选地对参数和返回值执行转换。

Object

MethodHandle.invokeExact​(Object... args)

调用方法句柄，允许任何调用者类型描述符，但需要确切的类型匹配。

Object

MethodHandle.invokeWithArguments​(Object... arguments)

执行可变元数调用，传递的参数在给定列表的方法处理，就好像通过不精确 invoke从呼叫位点，其仅提到类型 Object ，且其元数是参数列表的长度。

static boolean

MethodHandleProxies.isWrapperInstance​(Object x)

确定给定对象是否通过调用 asInterfaceInstance生成 。

static CallSite

StringConcatFactory.makeConcatWithConstants​(MethodHandles.Lookup lookup, String name, MethodType concatType, String recipe, Object... constants)

促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。

void

VarHandle.set​(Object... args)

将变量的值设置为 newValue ，具有设置的内存语义，就像变量被声明为非 volatile final 。

void

VarHandle.setOpaque​(Object... args)

以程序顺序将变量的值设置为 newValue ，但不能保证相对于其他线程的内存排序效果。

void

VarHandle.setRelease​(Object... args)

将变量的值设置为 newValue ，并确保先前的加载和存储在此访问后不重新排序。

void

VarHandle.setVolatile​(Object... args)

将变量的值设置为 newValue ，其内存语义设置为声明为变量 volatile 。

boolean

VarHandle.weakCompareAndSet​(Object... args)

可能原子将变量到值 newValue用的存储器语义 VarHandle.setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getVolatile(java.lang.Object...) 。

boolean

VarHandle.weakCompareAndSetAcquire​(Object... args)

可能原子将变量到值 newValue用的语义 VarHandle.set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.getAcquire(java.lang.Object...) 。

boolean

VarHandle.weakCompareAndSetPlain​(Object... args)

可能原子将变量到值 newValue用的语义 VarHandle.set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.get(java.lang.Object...) 。

boolean

VarHandle.weakCompareAndSetRelease​(Object... args)

可能原子将变量到值 newValue用的语义 VarHandle.setRelease(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 VarHandle.get(java.lang.Object...) 。

static MethodHandle

MethodHandleProxies.wrapperInstanceTarget​(Object x)

产生或恢复目标方法句柄，其行为上等同于此包装器实例的唯一方法。

static Class<?>

MethodHandleProxies.wrapperInstanceType​(Object x)

恢复创建此包装器实例的唯一的单一方法接口类型。

Constructors in java.lang.invoke with parameters of type Object

Constructor

描述

SerializedLambda​(Class<?> capturingClass, String functionalInterfaceClass, String functionalInterfaceMethodName, String functionalInterfaceMethodSignature, int implMethodKind, String implClass, String implMethodName, String implMethodSignature, String instantiatedMethodType, Object[] capturedArgs)

从lambda工厂现场的低级信息创建一个 SerializedLambda 。

Uses of Object in java.lang.management

Subclasses of Object in java.lang.management

Modifier and Type

Class

描述

class

LockInfo

有关 锁的信息。

class

ManagementFactory

ManagementFactory类是用于获取Java平台的托管Bean的工厂类。

class

ManagementPermission

当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。

class

MemoryNotificationInfo

有关内存通知的信息。

class

MemoryUsage

MemoryUsage对象表示内存使用的快照。

class

MonitorInfo

有关对象监视器锁的信息。

class

ThreadInfo

线程信息。

Uses of Object in java.lang.module

Subclasses of Object in java.lang.module

Modifier and Type

Class

描述

class

Configuration

的构造的结果是 resolution或分辨率 service binding 。

class

FindException

抛出一个ModuleFinder发生错误时发现一个模块。

class

InvalidModuleDescriptorException

读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。

class

ModuleDescriptor

模块描述符。

static class

ModuleDescriptor.Builder

建造ModuleDescriptor物件的建造者。

static class

ModuleDescriptor.Exports

由模块导出的包可能有资格或不合格。

static class

ModuleDescriptor.Opens

由模块打开的包可能有资格或不合格。

static class

ModuleDescriptor.Provides

模块提供一个或多个实现的服务。

static class

ModuleDescriptor.Requires

对模块的依赖

static class

ModuleDescriptor.Version

模块的版本字符串。

class

ModuleReference

参考模块的内容。

class

ResolutionException

在解析一组模块或解析一组具有服务绑定的模块时抛出失败。

class

ResolvedModule

解析模块图中的 模块 。

Methods in java.lang.module with parameters of type Object

Modifier and Type

方法

描述

boolean

ModuleDescriptor.equals​(Object ob)

测试此模块描述符与给定对象的相等性。

boolean

ModuleDescriptor.Exports.equals​(Object ob)

测试此模块导出与给定对象的相等性。

boolean

ModuleDescriptor.Opens.equals​(Object ob)

测试此模块打开以与给定对象相等。

boolean

ModuleDescriptor.Provides.equals​(Object ob)

测试这提供了与给定对象的相等性。

boolean

ModuleDescriptor.Requires.equals​(Object ob)

测试此模块与给定对象的相等性的依赖关系。

boolean

ModuleDescriptor.Version.equals​(Object ob)

测试此模块版本与给定对象的相等性。

boolean

ResolvedModule.equals​(Object ob)

测试此已解析模块与给定对象的相等性。

Uses of Object in java.lang.ref

Subclasses of Object in java.lang.ref

Modifier and Type

Class

描述

class

Cleaner

Cleaner管理一组对象引用和相应的清理操作。

class

PhantomReference<T>

在收集者确定其指示物可能被回收之后排入队列的Phantom参考对象。

class

Reference<T>

参考对象的抽象基类。

class

ReferenceQueue<T>

在检测到适当的可达性更改后，引用队列被垃圾收集器附加到哪个已注册的参考对象。

class

SoftReference<T>

软参考对象，由垃圾收集器根据内存需求自行清除。

class

WeakReference<T>

弱参考对象，不会阻止其指定对象的最终确定，最终确定，然后被回收。

Methods in java.lang.ref with parameters of type Object

Modifier and Type

方法

描述

static void

Reference.reachabilityFence​(Object ref)

确保给定引用引用的对象仍然是strongly reachable ，无论程序的任何先前的动作可能会导致对象变得不可访问; 因此，至少在调用此方法之后，引用的对象不能通过垃圾回收来回收。

Cleaner.Cleanable

Cleaner.register​(Object obj, Runnable action)

注册一个对象和一个清理动作，以便在对象变为幻像时可以运行。

Uses of Object in java.lang.reflect

Subclasses of Object in java.lang.reflect

Modifier and Type

Class

描述

class

AccessibleObject

所述 AccessibleObject类是基础类 Field ， 方法 ，和 Constructor对象（被称为 反射的对象 ）。

class

Array

Array类提供静态方法来动态创建和访问Java数组。

class

Constructor<T>

Constructor提供了一个类的单个构造函数的信息和访问。

class

Executable

方法和Constructor的共同功能的共享超类。

class

Field

A Field提供有关类或接口的单个字段的信息和动态访问。

class

GenericSignatureFormatError

当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。

class

InaccessibleObjectException

Java语言访问检查无法被抑制时抛出。

class

InvocationTargetException

InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。

class

MalformedParameterizedTypeException

当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。

class

MalformedParametersException

当 the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。

class

方法

A 方法在类或接口上提供有关单一方法的信息和访问权限。

class

Modifier

Modifier类提供 static方法和常量来解码类和成员访问修饰符。

class

Parameter

有关方法参数的信息。

class

Proxy

Proxy提供了静态方法来创建类似于接口实例的对象，但允许自定义的方法调用。

class

ReflectPermission

反思操作的权限类。

class

UndeclaredThrowableException

通过方法调用代理实例时抛出的调用处理程序的 invoke方法抛出检查异常（一 Throwable不是分配给 RuntimeException或者 Error ）是不能分配给任何中声明的异常类型 throws方法的条款，在代理实例上调用并分派到调用处理程序。

Methods in java.lang.reflect that return Object

Modifier and Type

方法

描述

static Object

Array.get​(Object array, int index)

返回指定数组对象中的索引组件的值。

Object

Field.get​(Object obj)

返回指定对象上由此 Field表示的字段的值。

Object

Method.getDefaultValue​()

返回由该 方法实例表示的注释成员的默认值。

Object

InvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

处理代理实例上的方法调用并返回结果。

Object

Method.invoke​(Object obj, Object... args)

在具有指定参数的指定对象上调用此 方法对象表示的底层方法。

static Object

Array.newInstance​(Class<?> componentType, int length)

创建具有指定组件类型和长度的新数组。

static Object

Array.newInstance​(Class<?> componentType, int... dimensions)

创建具有指定组件类型和尺寸的新数组。

static Object

Proxy.newProxyInstance​(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)

返回指定接口的代理实例，该代理实例将方法调用分派给指定的调用处理程序。

Methods in java.lang.reflect with parameters of type Object

Modifier and Type

方法

描述

boolean

AccessibleObject.canAccess​(Object obj)

测试调用者是否可以访问此反射对象。

boolean

Constructor.equals​(Object obj)

将此 Constructor与指定对象进行比较。

boolean

Field.equals​(Object obj)

将此 Field与指定对象进行比较。

boolean

Method.equals​(Object obj)

将此 方法与指定对象进行比较。

boolean

Parameter.equals​(Object obj)

基于可执行文件和索引进行比较。

static Object

Array.get​(Object array, int index)

返回指定数组对象中的索引组件的值。

Object

Field.get​(Object obj)

返回指定对象上由此 Field表示的字段的值。

static boolean

Array.getBoolean​(Object array, int index)

返回指定数组对象中的索引组件的值，如 boolean 。

boolean

Field.getBoolean​(Object obj)

获取静态或实例的值 boolean字段。

static byte

Array.getByte​(Object array, int index)

返回指定数组对象中索引组件的值，如 byte 。

byte

Field.getByte​(Object obj)

获取静态或实例的值 byte字段。

static char

Array.getChar​(Object array, int index)

返回指定数组对象中的索引组件的值，如 char 。

char

Field.getChar​(Object obj)

获取类型为 char的静态或实例字段的值，或通过扩大转换获得可转换为类型 char的另一个原始类型的值。

static double

Array.getDouble​(Object array, int index)

返回指定数组对象中索引组件的值，如 double 。

double

Field.getDouble​(Object obj)

获取类型为 double的静态或实例字段的 double或通过加宽转换可转换为类型 double的另一个原始类型的值。

static float

Array.getFloat​(Object array, int index)

返回指定数组对象中索引组件的值，如 float 。

float

Field.getFloat​(Object obj)

获取类型为 float的静态或实例字段的值，或通过扩大转换获得可转换为类型 float的另一个原始类型的值。

static int

Array.getInt​(Object array, int index)

返回指定数组对象中的索引组件的值，如 int 。

int

Field.getInt​(Object obj)

获取类型为 int的静态或实例字段的值，或通过扩大转换获得可转换为类型 int的另一个原始类型的值。

static InvocationHandler

Proxy.getInvocationHandler​(Object proxy)

返回指定代理实例的调用处理程序。

static int

Array.getLength​(Object array)

返回指定数组对象的长度，如 int 。

static long

Array.getLong​(Object array, int index)

返回指定数组对象中的索引组件的值，如 long 。

long

Field.getLong​(Object obj)

获取类型为 long的静态或实例字段的值，或通过扩大转换获得可转换为类型 long的另一个原始类型的值。

static short

Array.getShort​(Object array, int index)

返回指定数组对象中的索引组件的值，如 short 。

short

Field.getShort​(Object obj)

获取类型为 short的静态或实例字段的值，或通过扩大转换获得可转换为类型 short的另一个原始类型的值。

Object

InvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

处理代理实例上的方法调用并返回结果。

Object

Method.invoke​(Object obj, Object... args)

调用由此 方法对象表示的基础方法，在指定的对象上使用指定的参数。

T

Constructor.newInstance​(Object... initargs)

使用此 Constructor对象表示的构造函数，使用指定的初始化参数来创建和初始化构造函数的声明类的新实例。

static void

Array.set​(Object array, int index, Object value)

将指定数组对象的索引组件的值设置为指定的新值。

void

Field.set​(Object obj, Object value)

将指定对象参数上的此 Field对象表示的字段设置为指定的新值。

static void

Array.setBoolean​(Object array, int index, boolean z)

将指定数组对象的索引组件的值设置为指定的 boolean值。

void

Field.setBoolean​(Object obj, boolean z)

将字段的值设置为指定对象上的 boolean 。

static void

Array.setByte​(Object array, int index, byte b)

将指定数组对象的索引组件的值设置为指定的 byte值。

void

Field.setByte​(Object obj, byte b)

将字段的值设置为指定对象上的 byte 。

static void

Array.setChar​(Object array, int index, char c)

将指定数组对象的索引组件的值设置为指定的 char值。

void

Field.setChar​(Object obj, char c)

将字段的值设置为指定对象上的 char 。

static void

Array.setDouble​(Object array, int index, double d)

将指定数组对象的索引组件的值设置为指定的 double值。

void

Field.setDouble​(Object obj, double d)

将字段的值设置为指定对象上的 double 。

static void

Array.setFloat​(Object array, int index, float f)

将指定数组对象的索引组件的值设置为指定的 float值。

void

Field.setFloat​(Object obj, float f)

将字段的值设置为指定对象上的 float 。

static void

Array.setInt​(Object array, int index, int i)

将指定数组对象的索引组件的值设置为指定的 int值。

void

Field.setInt​(Object obj, int i)

将字段的值设置为指定对象上的 int 。

static void

Array.setLong​(Object array, int index, long l)

将指定数组对象的索引组件的值设置为指定的 long值。

void

Field.setLong​(Object obj, long l)

将字段的值设置为指定对象上的 long 。

static void

Array.setShort​(Object array, int index, short s)

将指定数组对象的索引组件的值设置为指定的 short值。

void

Field.setShort​(Object obj, short s)

将字段的值设置为指定对象上的 short 。

Uses of Object in java.math

Subclasses of Object in java.math

Modifier and Type

Class

描述

class

BigDecimal

不变的，任意精度的带符号的十进制数字。

class

BigInteger

不可变的任意精度整数。

class

MathContext

封装描述数值运算符某些规则的上下文设置的不可变对象，例如由BigDecimal类实现的那些规则。

Methods in java.math with parameters of type Object

Modifier and Type

方法

描述

boolean

BigDecimal.equals​(Object x)

将此 BigDecimal与指定的 Object进行比较，以获得相等性。

boolean

BigInteger.equals​(Object x)

将此BigInteger与指定的对象进行比较以实现相等。

boolean

MathContext.equals​(Object x)

将此 MathContext与指定的 Object进行比较以获得相等性。

Uses of Object in java.net

Subclasses of Object in java.net

Modifier and Type

Class

描述

class

Authenticator

Authenticator类代表一个知道如何获取网络连接认证的对象。

class

BindException

指示尝试将套接字绑定到本地地址和端口时发生错误。

class

CacheRequest

表示在ResponseCache中存储资源的通道。

class

CacheResponse

代表从ResponseCache中检索资源的通道。

class

ConnectException

指示尝试将套接字连接到远程地址和端口时发生错误。

class

ContentHandler

抽象类 ContentHandler是从 URLConnection读取 Object的所有类的超类。

class

CookieHandler

CookieHandler对象提供一个回调机制，将HTTP状态管理策略实现连接到HTTP协议处理程序中。

class

CookieManager

CookieManager提供了一个CookieHandler的具体实现， 它将 cookie的存储与接受和拒绝Cookie的策略分开。

class

DatagramPacket

该类表示数据报包。

class

DatagramSocket

此类表示用于发送和接收数据报数据包的套接字。

class

DatagramSocketImpl

抽象数据报和组播套接字实现基类。

class

HttpCookie

HttpCookie对象表示HTTP cookie，它承载服务器和用户代理之间的状态信息。

class

HttpRetryException

抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。

class

HttpURLConnection

支持HTTP特定功能的URLConnection。

class

IDN

提供在正常Unicode表示和ASCII兼容编码（ACE）表示之间转换国际化域名（IDN）的方法。

class

Inet4Address

该类表示Internet协议版本4（IPv4）地址。

class

Inet6Address

该类表示Internet协议版本6（IPv6）地址。

class

InetAddress

此类表示Internet协议（IP）地址。

class

InetSocketAddress

该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。

class

InterfaceAddress

此类表示网络接口地址。

class

JarURLConnection

与Java ARchive（JAR）文件或JAR文件中的条目的URL连接。

class

MalformedURLException

抛出以表示发生格式不正确的网址。

class

MulticastSocket

组播数据报套接字类对发送和接收IP组播数据包很有用。

class

NetPermission

此类用于各种网络权限。

class

NetworkInterface

此类表示由名称组成的网络接口和分配给此接口的IP地址列表。

class

NoRouteToHostException

指示尝试将套接字连接到远程地址和端口时发生错误。

class

PasswordAuthentication

PasswordAuthentication类是Authenticator使用的数据持有者。

class

PortUnreachableException

指示在连接的数据报上收到了ICMP端口不可达消息。

class

ProtocolException

抛出以表示底层协议有错误，如TCP错误。

class

Proxy

此类表示代理设置，通常是类型（http，socks）和套接字地址。

class

ProxySelector

选择在连接到URL引用的网络资源时使用的代理服务器（如果有）。

class

ResponseCache

表示URLConnection缓存的实现。

class

SecureCacheResponse

表示最初通过安全手段（例如TLS）检索的缓存响应。

class

ServerSocket

这个类实现了服务器套接字。

class

Socket

该类实现客户端套接字（也称为“套接字”）。

class

SocketAddress

这个类代表一个没有协议附件的Socket地址。

class

SocketException

抛出以表示创建或访问Socket时出错。

class

SocketImpl

抽象类 SocketImpl是实际实现套接字的所有类的常用超类。

class

SocketPermission

此类表示通过套接字访问网络。

class

SocketTimeoutException

指示在套接字上发生超时时读取或接受。

class

StandardSocketOptions

定义 标准套接字选项。

class

UnknownHostException

抛出以表示无法确定主机的IP地址。

class

UnknownServiceException

抛出以表示发生未知服务异常。

class

URI

表示统一资源标识符（URI）参考。

class

URISyntaxException

检查的异常抛出以指示不能将字符串解析为URI引用。

class

URL

URL类表示统一资源定位符，指向万维网上“资源”的指针。

class

URLClassLoader

此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。

class

URLConnection

抽象类 URLConnection是表示应用程序和URL之间的通信链接的所有类的超类。

class

URLDecoder

HTML表单解码的实用类。

class

URLEncoder

HTML表单编码的实用类。

class

URLPermission

表示访问由给定网址定义的资源或资源集的权限，以及给定的一组用户可设置的请求方法和请求标头。

class

URLStreamHandler

抽象类 URLStreamHandler是所有流协议处理程序的常用超类。

Methods in java.net that return Object

Modifier and Type

方法

描述

Object

HttpCookie.clone​()

创建并返回此对象的副本。

abstract Object

ContentHandler.getContent​(URLConnection urlc)

给定位于对象表示开头的URL连接流，该方法读取该流并从中创建一个对象。

Object

ContentHandler.getContent​(URLConnection urlc, Class[] classes)

给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。

Object

URL.getContent​()

获取此URL的内容。

Object

URL.getContent​(Class<?>[] classes)

获取此URL的内容。

Object

URLConnection.getContent​()

检索此URL连接的内容。

Object

URLConnection.getContent​(Class<?>[] classes)

检索此URL连接的内容。

Object

SocketOptions.getOption​(int optID)

获取选项的值。

Methods in java.net with parameters of type Object

Modifier and Type

方法

描述

boolean

HttpCookie.equals​(Object obj)

测试两个HTTP Cookie的相等性。

boolean

Inet4Address.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

Inet6Address.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

InetAddress.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

InetSocketAddress.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

InterfaceAddress.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

NetworkInterface.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

Proxy.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

SocketPermission.equals​(Object obj)

检查两个SocketPermission对象是否相等。

boolean

URI.equals​(Object ob)

测试此URI以与另一个对象相等。

boolean

URL.equals​(Object obj)

将此URL与其他对象进行比较。

boolean

URLPermission.equals​(Object p)

如果this.getActions（）。equals（p.getActions（））和p的url等于这个url，则返回true。

void

SocketOptions.setOption​(int optID, Object value)

启用/禁用 optID指定的选项。

Uses of Object in java.net.spi

Subclasses of Object in java.net.spi

Modifier and Type

Class

描述

class

URLStreamHandlerProvider

URL流处理程序服务提供程序类。

Uses of Object in java.nio

Subclasses of Object in java.nio

Modifier and Type

Class

描述

class

Buffer

用于特定原始类型的数据的容器。

class

BufferOverflowException

相对 放置操作达到目标缓冲区限制时抛出的未检查异常。

class

BufferUnderflowException

当相对 get操作达到源缓冲区的限制时抛出未检查的异常。

class

ByteBuffer

一个字节缓冲区。

class

ByteOrder

字节顺序的类型安全枚举。

class

CharBuffer

一个char缓冲区。

class

DoubleBuffer

双缓冲。

class

FloatBuffer

一个浮动缓冲区。

class

IntBuffer

一个int缓冲区

class

InvalidMarkException

当未定义其标记时尝试复位缓冲区时抛出未检查的异常。

class

LongBuffer

一个长缓冲区。

class

MappedByteBuffer

直接字节缓冲器，其内容是文件的存储器映射区域。

class

ReadOnlyBufferException

在只读缓冲区中调用内容突变方法（如 put或 compact ）时调用未检查的异常。

class

ShortBuffer

一个短暂的缓冲。

Methods in java.nio that return Object

Modifier and Type

方法

描述

abstract Object

Buffer.array​()

返回支持此缓冲区的数组 （可选操作） 。

Methods in java.nio with parameters of type Object

Modifier and Type

方法

描述

boolean

ByteBuffer.equals​(Object ob)

告诉这个缓冲区是否等于另一个对象。

boolean

CharBuffer.equals​(Object ob)

告诉这个缓冲区是否等于另一个对象。

boolean

DoubleBuffer.equals​(Object ob)

告诉这个缓冲区是否等于另一个对象。

boolean

FloatBuffer.equals​(Object ob)

告诉这个缓冲区是否等于另一个对象。

boolean

IntBuffer.equals​(Object ob)

告诉这个缓冲区是否等于另一个对象。

boolean

LongBuffer.equals​(Object ob)

告诉这个缓冲区是否等于另一个对象。

boolean

ShortBuffer.equals​(Object ob)

告诉这个缓冲区是否等于另一个对象。

Uses of Object in java.nio.channels

Subclasses of Object in java.nio.channels

Modifier and Type

Class

描述

class

AcceptPendingException

尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。

class

AlreadyBoundException

尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。

class

AlreadyConnectedException

当尝试连接已连接的SocketChannel时 ，会抛出未检查的异常。

class

AsynchronousChannelGroup

用于资源共享的一组异步通道。

class

AsynchronousCloseException

当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。

class

AsynchronousFileChannel

用于读取，写入和操作文件的异步通道。

class

AsynchronousServerSocketChannel

用于面向流的侦听套接字的异步通道。

class

AsynchronousSocketChannel

用于面向流的连接插座的异步通道。

class

CancelledKeyException

当试图使用不再有效的选择键时抛出未检查的异常。

class

Channels

通道和流的实用方法。

class

ClosedByInterruptException

另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。

class

ClosedChannelException

当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。

class

ClosedSelectorException

尝试在闭合选择器上调用I / O操作时抛出未检查的异常。

class

ConnectionPendingException

尝试连接未阻塞连接操作的SocketChannel时，会引发未检查的异常。

class

DatagramChannel

面向数据报的套接字的可选通道。

class

FileChannel

用于读取，写入，映射和操作文件的通道。

static class

FileChannel.MapMode

文件映射模式的类型安全枚举。

class

FileLock

表示文件区域上的锁的令牌。

class

FileLockInterruptionException

另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。

class

IllegalBlockingModeException

当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。

class

IllegalChannelGroupException

尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。

class

IllegalSelectorException

当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。

class

InterruptedByTimeoutException

在异步操作完成之前经过一段时间后线程接收到的异常检查。

class

MembershipKey

代表互联网协议（IP）组播组成员身份的令牌。

class

NoConnectionPendingException

当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。

class

NonReadableChannelException

尝试从最初打开阅读的频道中读取时未抛出的异常。

class

NonWritableChannelException

尝试写入最初未打开的通道进行写入时抛出未检查的异常。

class

NotYetBoundException

尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。

class

NotYetConnectedException

当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。

class

OverlappingFileLockException

当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。

class

Pipe

实现单向管道的一对通道。

static class

Pipe.SinkChannel

一个代表Pipe可写端的通道 。

static class

Pipe.SourceChannel

一个代表Pipe可读端的通道 。

class

ReadPendingException

尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。

class

SelectableChannel

可以通过Selector复用的通道 。

class

SelectionKey

代表SelectableChannel与Selector注册的令牌。

class

Selector

SelectableChannel对象的多路复用器。

class

ServerSocketChannel

用于面向流的侦听套接字的可选通道。

class

ShutdownChannelGroupException

当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。

class

SocketChannel

用于面向流的连接插座的可选通道。

class

UnresolvedAddressException

尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。

class

UnsupportedAddressTypeException

尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。

class

WritePendingException

尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。

Methods in java.nio.channels that return Object

Modifier and Type

方法

描述

Object

SelectionKey.attach​(Object ob)

将给定对象附加到此键。

Object

SelectionKey.attachment​()

检索当前附件。

abstract Object

SelectableChannel.blockingLock​()

检索 configureBlocking和 register方法同步的对象。

Methods in java.nio.channels with parameters of type Object

Modifier and Type

方法

描述

Object

SelectionKey.attach​(Object ob)

将给定对象附加到此键。

abstract SelectionKey

SelectableChannel.register​(Selector sel, int ops, Object att)

使用给定的选择器注册此频道，返回一个选择键。

Uses of Object in java.nio.channels.spi

Subclasses of Object in java.nio.channels.spi

Modifier and Type

Class

描述

class

AbstractInterruptibleChannel

可中断通道的基本实现类。

class

AbstractSelectableChannel

可选通道的基本实现类。

class

AbstractSelectionKey

选择键的基本实现类。

class

AbstractSelector

选择器的基本实现类。

class

AsynchronousChannelProvider

用于异步通道的服务提供程序类。

class

SelectorProvider

选择器和可选择通道的服务提供者类。

Methods in java.nio.channels.spi that return Object

Modifier and Type

方法

描述

Object

AbstractSelectableChannel.blockingLock​()

Methods in java.nio.channels.spi with parameters of type Object

Modifier and Type

方法

描述

SelectionKey

AbstractSelectableChannel.register​(Selector sel, int ops, Object att)

使用给定的选择器注册此频道，返回一个选择键。

protected abstract SelectionKey

AbstractSelector.register​(AbstractSelectableChannel ch, int ops, Object att)

使用此选择器注册给定通道。

Uses of Object in java.nio.charset

Subclasses of Object in java.nio.charset

Modifier and Type

Class

描述

class

CharacterCodingException

发生字符编码或解码错误时抛出的检查异常。

class

Charset

16位Unicode code units和字节序列的序列之间的命名映射。

class

CharsetDecoder

可以将特定字符集中的字节序列转换为十六位Unicode字符序列的引擎。

class

CharsetEncoder

一种引擎，可以将一系列十六位Unicode字符转换为特定字符集中的字节序列。

class

CoderMalfunctionError

错误抛出当decodeLoop方法的CharsetDecoder ，或encodeLoop一个的方法CharsetEncoder ，抛出意外的异常。

class

CoderResult

编码器的结果状态的描述。

class

CodingErrorAction

用于编码错误操作的类型安全枚举。

class

IllegalCharsetNameException

当使用不是 legal charset name的字符串时抛出未检查的异常。

class

MalformedInputException

当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。

class

StandardCharsets

常规定义的标准Charsets 。

class

UnmappableCharacterException

输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。

class

UnsupportedCharsetException

对于请求的字符集，当没有可用的支持时抛出未检查的异常。

Methods in java.nio.charset with parameters of type Object

Modifier and Type

方法

描述

boolean

Charset.equals​(Object ob)

告诉这个对象是否等于另一个。

Uses of Object in java.nio.charset.spi

Subclasses of Object in java.nio.charset.spi

Modifier and Type

Class

描述

class

CharsetProvider

字符集服务提供者类。

Uses of Object in java.nio.file

Subclasses of Object in java.nio.file

Modifier and Type

Class

描述

class

AccessDeniedException

文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。

class

AtomicMoveNotSupportedException

当文件不能作为原子文件系统操作移动时，检查的异常抛出。

class

ClosedDirectoryStreamException

尝试在关闭的目录流上调用操作时抛出未检查的异常。

class

ClosedFileSystemException

尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。

class

ClosedWatchServiceException

尝试在关闭的手表服务上调用操作时抛出未检查的异常。

class

DirectoryIteratorException

如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。

class

DirectoryNotEmptyException

由于目录不为空，文件系统操作失败时抛出的检查异常。

class

FileAlreadyExistsException

尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。

class

Files

该类只包含对文件，目录或其他类型文件进行操作的静态方法。

class

FileStore

文件存储

class

FileSystem

提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。

class

FileSystemAlreadyExistsException

新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新

class

FileSystemException

在一个或两个文件上的文件系统操作失败时抛出。

class

FileSystemLoopException

当遇到文件系统循环或循环时抛出的检查异常。

class

FileSystemNotFoundException

无法找到文件系统时抛出的运行时异常。

class

FileSystems

文件系统的工厂方法。

class

InvalidPathException

当路径字符串不能转换为Path因为路径字符串包含无效字符或路径字符串对于其他文件系统特定的原因无效时，会抛出未检查的异常。

class

LinkPermission

Permission类链接创建操作。

class

NoSuchFileException

当尝试访问不存在的文件时抛出检查的异常。

class

NotDirectoryException

当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。

class

NotLinkException

由于文件不是符号链接，文件系统操作失败时抛出的检查异常。

class

Paths

该类完全由返回一个静态方法Path通过转换路径字符串或URI 。

class

ProviderMismatchException

当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。

class

ProviderNotFoundException

无法找到所需类型的提供者时抛出的运行时异常。

class

ReadOnlyFileSystemException

当尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。

class

SimpleFileVisitor<T>

具有默认行为的简单文件访问者访问所有文件并重新抛出I / O错误。

class

StandardWatchEventKinds

定义 标准事件种类。

Fields in java.nio.file with type parameters of type Object

Modifier and Type

Field

描述

static WatchEvent.Kind<Object>

StandardWatchEventKinds.OVERFLOW

一个特殊事件，表明事件可能已丢失或丢弃。

Methods in java.nio.file that return Object

Modifier and Type

方法

描述

static Object

Files.getAttribute​(Path path, String attribute, LinkOption... options)

读取文件属性的值。

abstract Object

FileStore.getAttribute​(String attribute)

读取文件存储属性的值。

Methods in java.nio.file that return types with arguments of type Object

Modifier and Type

方法

描述

static Map<String,Object>

Files.readAttributes​(Path path, String attributes, LinkOption... options)

读取一组文件属性作为批量操作。

Methods in java.nio.file with parameters of type Object

Modifier and Type

方法

描述

boolean

Path.equals​(Object other)

测试此路径与给定对象的相等性。

static Path

Files.setAttribute​(Path path, String attribute, Object value, LinkOption... options)

设置文件属性的值。

Uses of Object in java.nio.file.attribute

Subclasses of Object in java.nio.file.attribute

Modifier and Type

Class

描述

class

AclEntry

访问控制列表（ACL）中的条目。

static class

AclEntry.Builder

一个AclEntry对象的生成器。

class

FileTime

表示文件时间戳属性的值。

class

PosixFilePermissions

该类只包含对PosixFilePermission对象进行操作的静态方法。

class

UserPrincipalLookupService

按名称查找用户和组主体的对象。

class

UserPrincipalNotFoundException

当查询UserPrincipal失败，因为主体不存在时抛出的检查异常。

Methods in java.nio.file.attribute that return Object

Modifier and Type

方法

描述

Object

BasicFileAttributes.fileKey​()

返回唯一标识给定文件的对象，如果文件密钥不可用，则返回 null 。

Methods in java.nio.file.attribute with parameters of type Object

Modifier and Type

方法

描述

boolean

AclEntry.equals​(Object ob)

将指定的对象与此ACL条目进行比较以获得相等性。

boolean

FileTime.equals​(Object obj)

测试此 FileTime与给定对象的相等性。

Uses of Object in java.nio.file.spi

Subclasses of Object in java.nio.file.spi

Modifier and Type

Class

描述

class

FileSystemProvider

文件系统的服务提供者类。

class

FileTypeDetector

用于探测文件以猜测其文件类型的文件类型检测器。

Methods in java.nio.file.spi that return types with arguments of type Object

Modifier and Type

方法

描述

abstract Map<String,Object>

FileSystemProvider.readAttributes​(Path path, String attributes, LinkOption... options)

读取一组文件属性作为批量操作。

Methods in java.nio.file.spi with parameters of type Object

Modifier and Type

方法

描述

abstract void

FileSystemProvider.setAttribute​(Path path, String attribute, Object value, LinkOption... options)

设置文件属性的值。

Uses of Object in java.rmi

Subclasses of Object in java.rmi

Modifier and Type

Class

描述

class

AccessException

一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。

class

AlreadyBoundException

如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出一个 AlreadyBoundException 。

class

ConnectException

如果连接拒绝远程主机进行远程方法调用，则抛出 ConnectException 。

class

ConnectIOException

如果在远程方法调用连接到远程主机时出现 ConnectIOException则抛出 IOException 。

class

MarshalException

如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。

class

MarshalledObject<T>

A MarshalledObject包含具有给其构造函数的对象的序列化表示的字节流。

class

Naming

Naming类提供了存储和获取对远程对象注册表中远程对象的引用的方法。

class

NoSuchObjectException

如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。

class

NotBoundException

如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出 NotBoundException 。

class

RemoteException

A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。

class

RMISecurityException

已过时。
改用SecurityException 。 应用程式代码不应该直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。

class

RMISecurityManager

已过时。
改用SecurityManager 。

class

ServerError

甲 ServerError被抛出作为远程方法调用的结果，当一个 Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。

class

ServerException

甲 ServerException当被抛出作为远程方法调用的结果 RemoteException在处理服务器上的调用，要么同时解编参数或执行远程方法本身被抛出。

class

ServerRuntimeException

已过时。
没有替换

class

StubNotFoundException

如果远程对象导出时无法找到有效的存根类，则抛出 StubNotFoundException 。

class

UnexpectedException

如果远程方法调用的客户机接收到调用的结果，那么抛出一个 UnexpectedException ，该检查异常不在远程接口的方法的 throws子句中声明的检查的异常类型中。

class

UnknownHostException

如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。

class

UnmarshalException

如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出一个 UnmarshalException ：如果发生异常时 java.io.IOException调用头，如果返回值的协议如果 java.io.IOException发生解组参数（on服务器端）或返回值（在客户端）。

Methods in java.rmi with parameters of type Object

Modifier and Type

方法

描述

boolean

MarshalledObject.equals​(Object obj)

将此 MarshalledObject与另一个对象进行比较。

Uses of Object in java.rmi.activation

Subclasses of Object in java.rmi.activation

Modifier and Type

Class

描述

class

Activatable

Activatable类提供对需要持续访问的远程对象的支持，并且可以由系统激活。

class

ActivateFailedException

在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。

class

ActivationDesc

激活描述符包含激活对象所需的信息：对象的组标识符，对象的全限定类名，对象的代码位置（类的位置），代码库URL路径，对象的重新启动“模式”，以及，一个可以包含对象特定初始化数据的“编组”对象。

class

ActivationException

激活界面使用的常规异常。

class

ActivationGroup

一个 ActivationGroup负责在其组中创建“可激活”对象的新实例，通知其 ActivationMonitor ：其对象变为活动或不活动，或组作为整体变为不活动。

class

ActivationGroup_Stub

ActivationGroup_Stub是导出为 java.rmi.server.UnicastRemoteObject的 java.rmi.activation.ActivationGroup的子类的存根类。

class

ActivationGroupDesc

激活组描述符包含创建/重新创建激活对象的激活组所需的信息。

static class

ActivationGroupDesc.CommandEnvironment

ActivationGroup实现的启动选项。

class

ActivationGroupID

注册激活组的标识符有几个目的：在激活系统中唯一标识组，并包含对组的激活系统的引用，以便组可以在必要时联系其激活系统。

class

ActivationID

激活使用特殊标识符来表示可以随时间激活的远程对象。

class

UnknownGroupException

一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。

class

UnknownObjectException

当方法的 ActivationID参数被确定为无效时，通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。

Methods in java.rmi.activation with parameters of type Object

Modifier and Type

方法

描述

boolean

ActivationDesc.equals​(Object obj)

比较两个激活描述符的内容相等性。

boolean

ActivationGroupDesc.CommandEnvironment.equals​(Object obj)

比较两个命令环境的内容相等性。

boolean

ActivationGroupDesc.equals​(Object obj)

比较两个激活组描述符的内容相等性。

boolean

ActivationGroupID.equals​(Object obj)

比较两个组标识符的内容相等性。

boolean

ActivationID.equals​(Object obj)

比较两个激活ID用于内容相等。

Uses of Object in java.rmi.dgc

Subclasses of Object in java.rmi.dgc

Modifier and Type

Class

描述

class

Lease

租赁包含唯一的VM标识符和租期。

class

VMID

VMID是所有Java虚拟机中唯一的标识符。

Methods in java.rmi.dgc with parameters of type Object

Modifier and Type

方法

描述

boolean

VMID.equals​(Object obj)

将此VMID与另一个进行比较，如果它们是相同的标识符，则返回true。

Uses of Object in java.rmi.registry

Subclasses of Object in java.rmi.registry

Modifier and Type

Class

描述

class

LocateRegistry

LocateRegistry用于获取对特定主机（包括本地主机）上的引导远程对象注册表的引用，或者创建接受特定端口上的调用的远程对象注册表。

Uses of Object in java.rmi.server

Subclasses of Object in java.rmi.server

Modifier and Type

Class

描述

class

ExportException

如果尝试导出远程对象失败，则 ExportException是抛出的 RemoteException 。

class

LogStream

已过时。
没有替换

class

ObjID

ObjID用于标识导出到RMI运行时的远程对象。

class

Operation

已过时。
没有替换

class

RemoteObject

RemoteObject类实现了远程对象的 java.lang.Object行为。

class

RemoteObjectInvocationHandler

用于Java Remote Method Invocation（Java RMI）的 InvocationHandler接口的实现。

class

RemoteServer

RemoteServer类是服务器实现的常见超类，并提供了支持各种远程引用语义的框架。

class

RemoteStub

已过时。
静态生成的存根被不推荐使用，因为存根是动态生成的。 有关动态存根生成的信息，请参阅UnicastRemoteObject 。

class

RMIClassLoader

RMIClassLoader包括静态方法来支持使用RMI的动态类加载。

class

RMIClassLoaderSpi

RMIClassLoaderSpi是服务提供者接口 RMIClassLoader 。

class

RMISocketFactory

RMI运行时使用 RMISocketFactory实例来获取RMI调用的客户端和服务器套接字。

class

ServerCloneException

甲 ServerCloneException如果一个的克隆过程中发生远程抛出异常 UnicastRemoteObject 。

class

ServerNotActiveException

如果在服务远程方法调用之外调用getClientHost方法，则 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。

class

SkeletonMismatchException

已过时。
没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

class

SkeletonNotFoundException

已过时。
没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。

class

SocketSecurityException

已过时。
这个班已经过时了 改用ExportException 。

class

UID

A UID表示相对于其在其上生成的主机或两个 16 “知名”标识符之一的时间而言是唯一的标识符。

class

UnicastRemoteObject

用于使用JRMP导出远程对象并获取与远程对象通信的存根。

Methods in java.rmi.server that return Object

Modifier and Type

方法

描述

Object

UnicastRemoteObject.clone​()

返回与原始对象不同的远程对象的克隆。

Object

LoaderHandler.getSecurityContext​(ClassLoader loader)

已过时。
没有替换

static Object

RMIClassLoader.getSecurityContext​(ClassLoader loader)

已过时。
没有替换。 从Java 2平台v1.2开始，RMI不再使用此方法来获取类加载器的安全上下文。

Object

RemoteObjectInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

处理封装代理实例 proxy上的方法调用，并返回结果。

Object

RemoteRef.invoke​(Remote obj, 方法 method, Object[] params, long opnum)

调用方法。

Methods in java.rmi.server with parameters of type Object

Modifier and Type

方法

描述

boolean

ObjID.equals​(Object obj)

将指定的对象与此 ObjID进行比较以获得相等性。

boolean

RemoteObject.equals​(Object obj)

比较两个远程对象的相等性。

boolean

UID.equals​(Object obj)

将指定的对象与此 UID进行比较以获得相等性。

RemoteStub

ServerRef.exportObject​(Remote obj, Object data)

已过时。

为所提供的Remote对象创建客户端存根对象。

Object

RemoteObjectInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

处理封装代理实例 proxy上的方法调用，并返回结果。

Object

RemoteRef.invoke​(Remote obj, 方法 method, Object[] params, long opnum)

调用方法。

Uses of Object in java.security

Subclasses of Object in java.security

Modifier and Type

Class

描述

class

AccessControlContext

AccessControlContext用于根据其封装的上下文来进行系统资源访问决策。

class

AccessControlException

AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。

class

AccessController

AccessController类用于访问控制操作和决策。

class

AlgorithmParameterGenerator

AlgorithmParameterGenerator类用于生成一组要用于某种算法的参数。

class

AlgorithmParameterGeneratorSpi

该类定义了 AlgorithmParameterGenerator类的 （ SPI ），用于生成一组要与特定算法一起使用的参数。

class

AlgorithmParameters

此类用作加密参数的不透明表示。

class

AlgorithmParametersSpi

该类定义了 AlgorithmParameters类的 （ SPI ），用于管理算法参数。

class

AllPermission

AllPermission是一个隐含所有其他权限的权限。

class

AuthProvider

此类为提供程序定义登录和注销方法。

class

BasicPermission

BasicPermission类扩展了Permission类，并且可以用作基类，用于遵循与BasicPermission相同的命名约定的权限。

class

CodeSigner

该类封装了有关代码签名者的信息。

class

CodeSource

该类扩展了代码库的概念，不仅封装了位置（URL），还封装了用于验证源自该位置的签名代码的证书链。

class

DigestException

这是通用的消息摘要异常。

class

DigestInputStream

透明流，使用通过流的位更新关联的消息摘要。

class

DigestOutputStream

透明流，使用通过流的位更新关联的消息摘要。

class

DomainLoadStoreParameter

指定密钥库中密钥库的配置数据。

class

DrbgParameters

该类指定DRBG（确定性随机位发生器）使用的参数。

static class

DrbgParameters.Instantiation

用于实例化的DRBG参数。

static class

DrbgParameters.NextBytes

用于随机位生成的DRBG参数。

static class

DrbgParameters.Reseed

重新植入的DRBG参数。

class

GeneralSecurityException

GeneralSecurityException类是一种通用的安全性异常类，它为从其延伸的所有与安全性相关的异常类提供类型安全性。

class

GuardedObject

GuardedObject是一个用于保护对另一个对象的访问的对象。

class

Identity

已过时。
此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

class

IdentityScope

已过时。
此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

class

InvalidAlgorithmParameterException

这是无效或不合适的算法参数的例外。

class

InvalidKeyException

这是无效键（无效编码，长度错误，未初始化等）的例外。

class

InvalidParameterException

当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。

class

KeyException

这是基本的关键例外。

class

KeyFactory

主要工厂用于将 密钥 （ Key型的不透明加密密钥）转换为 密钥规范 （基础密钥材料的透明表示），反之亦然。

class

KeyFactorySpi

该类定义了 KeyFactory类的 （ SPI ）。

class

KeyManagementException

这是处理密钥管理的所有操作的一般密钥管理例外。

class

KeyPair

这个类是密钥对（一个公钥和一个私钥）的简单持有者。

class

KeyPairGenerator

KeyPairGenerator类用于生成公钥和私钥对。

class

KeyPairGeneratorSpi

该类定义 KeyPairGenerator类的 （ SPI ），用于生成公钥和私钥对。

class

KeyRep

序列化关键对象的标准化表示。

class

KeyStore

该类代表加密密钥和证书的存储设备。

static class

KeyStore.Builder

要实例化的KeyStore对象的描述。

static class

KeyStore.CallbackHandlerProtection

一个封装CallbackHandler的ProtectionParameter。

static class

KeyStore.PasswordProtection

基于密码的实现 ProtectionParameter 。

static class

KeyStore.PrivateKeyEntry

一个 KeyStore条目，其中包含一个 PrivateKey和相应的证书链。

static class

KeyStore.SecretKeyEntry

A KeyStore条目，其中包含一个 SecretKey 。

static class

KeyStore.TrustedCertificateEntry

A KeyStore条目，其中包含受信任的 Certificate 。

class

KeyStoreException

这是通用的KeyStore异常。

class

KeyStoreSpi

该类定义了 KeyStore类的 （ SPI ）。

class

MessageDigest

该MessageDigest类为应用程序提供消息摘要算法的功能，如SHA-1或SHA-256。

class

MessageDigestSpi

该类定义了 MessageDigest类的 （ SPI ），它提供消息摘要算法（如MD5或SHA）的功能。

class

NoSuchAlgorithmException

当请求特定的加密算法但在环境中不可用时抛出此异常。

class

NoSuchProviderException

当特定安全提供程序被请求但在环境中不可用时抛出此异常。

class

Permission

用于表示访问系统资源的抽象类。

class

PermissionCollection

代表Permission对象集合的抽象类。

class

Permissions

此类表示许多权限的异构集合。

class

PKCS12Attribute

与PKCS12密钥库条目关联的属性。

class

Policy

Policy对象负责确定在Java运行时环境中执行的代码是否具有执行安全敏感操作的权限。

class

PolicySpi

该类定义了 Policy类的 （ SPI ）。

class

PrivilegedActionException

这个异常是由 doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)引发的，表示正在执行的操作会抛出一个被检查的异常。

class

ProtectionDomain

ProtectionDomain类封装了一个域的特性，该域包含一组类，当代表一组给定的主体执行时，该类的实例被授予一组权限。

class

Provider

该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。

static class

Provider.Service

安全服务的描述。

class

ProviderException

提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。

class

SecureClassLoader

此类扩展了ClassLoader，其额外支持用于定义具有相关代码源和权限的类，默认情况下系统策略将检索该类。

class

SecureRandom

这个类提供了一个密码强的随机数生成器（RNG）。

class

SecureRandomSpi

该类定义了SecureRandom类的 （ SPI ）。

class

Security

此类集中所有安全属性和常见的安全方法。

class

SecurityPermission

此类用于安全权限。

class

Signature

Signature类用于向应用程序提供数字签名算法的功能。

class

SignatureException

这是一般的签名异常。

class

SignatureSpi

该类定义了 Signature类的 （ SPI ），用于提供数字签名算法的功能。

class

SignedObject

SignedObject是一个类，用于创建可靠的运行时对象，其完整性不会受到威胁，而不会被检测到。

class

Signer

已过时。
此类不再使用。 它的功能已经被替换为java.security.KeyStore ，该java.security.cert包， java.security.Principal 。

class

Timestamp

此类封装了有关已签名时间戳的信息。

class

UnrecoverableEntryException

如果密钥库中的条目无法恢复，则抛出此异常。

class

UnrecoverableKeyException

如果密钥存储库中的密钥无法恢复，则抛出此异常。

class

UnresolvedPermission

UnresolvedPermission类用于保存初始化策略时“未解决”的权限。

class

URIParameter

包含指向PolicySpi或ConfigurationSpi实现的数据的URI的参数。

Methods in java.security that return Object

Modifier and Type

方法

描述

Object

MessageDigest.clone​()

如果实现是可克隆的，则返回克隆。

Object

MessageDigestSpi.clone​()

如果实现是可克隆的，则返回克隆。

Object

Signature.clone​()

如果实现是可克隆的，则返回克隆。

Object

SignatureSpi.clone​()

如果实现是可克隆的，则返回克隆。

Object

Provider.compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

Object

Provider.computeIfAbsent​(Object key, Function<? super Object,? extends Object> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

Object

Provider.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

protected abstract Object

SignatureSpi.engineGetParameter​(String param)

已过时。

Object

Provider.get​(Object key)

Object

GuardedObject.getObject​()

检索被保护的对象，或者如果对守卫对象的访问被守卫拒绝，则抛出异常。

Object

SignedObject.getObject​()

检索封装对象。

Object

Provider.getOrDefault​(Object key, Object defaultValue)

Object

Signature.getParameter​(String param)

已过时。

Object

Provider.merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。

Object

Provider.Service.newInstance​(Object constructorParameter)

返回此服务描述的实现的新实例。

Object

Provider.put​(Object key, Object value)

将 key属性设置为具有指定的 value 。

Object

Provider.putIfAbsent​(Object key, Object value)

如果指定的键尚未与值（或映射到 null ）相关联，并将其与给定值相关联并返回 null ，否则返回当前值。

protected Object

KeyRep.readResolve​()

解决Key对象。

Object

Provider.remove​(Object key)

删除 key属性（及其对应的 value ）。

Object

Provider.replace​(Object key, Object value)

只有当目标映射到某个值时，才能替换指定键的条目。

Methods in java.security that return types with arguments of type Object

Modifier and Type

方法

描述

Enumeration<Object>

Provider.elements​()

Set<Map.Entry<Object,Object>>

Provider.entrySet​()

返回此提供程序中包含的属性条目的不可修改的Set视图。

Set<Map.Entry<Object,Object>>

Provider.entrySet​()

返回此提供程序中包含的属性条目的不可修改的Set视图。

Enumeration<Object>

Provider.keys​()

Set<Object>

Provider.keySet​()

返回此提供程序中包含的属性键的不可修改的Set视图。

Collection<Object>

Provider.values​()

返回此提供程序中包含的属性值的不可修改的集合视图。

Methods in java.security with parameters of type Object

Modifier and Type

方法

描述

void

Guard.checkGuard​(Object object)

确定是否允许访问被保护对象 object 。

void

Permission.checkGuard​(Object object)

实施保护接口以获得许可。

Object

Provider.compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

尝试计算指定键的映射及其当前映射值（如果没有当前映射，则 null ）。

Object

Provider.computeIfAbsent​(Object key, Function<? super Object,? extends Object> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

Object

Provider.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

protected abstract void

SignatureSpi.engineSetParameter​(String param, Object value)

已过时。
由engineSetParameter取代 。

boolean

AccessControlContext.equals​(Object obj)

检查两个AccessControlContext对象的相等性。

boolean

AllPermission.equals​(Object obj)

检查两个AllPermission对象是否相等。

boolean

BasicPermission.equals​(Object obj)

检查两个BasicPermission对象是否相等。

boolean

CodeSigner.equals​(Object obj)

测试指定对象与此代码签名者之间的相等性。

boolean

CodeSource.equals​(Object obj)

测试指定对象和此对象之间的相等性。

boolean

Identity.equals​(Object identity)

已过时。

测试指定对象与此身份之间的相等性。

abstract boolean

Permission.equals​(Object obj)

检查两个Permission对象的相等性。

boolean

PKCS12Attribute.equals​(Object obj)

比较这个 PKCS12Attribute和一个指定的对象的相等性。

boolean

Principal.equals​(Object another)

将此主体与指定对象进行比较。

boolean

Timestamp.equals​(Object obj)

测试指定对象与此时间戳之间的相等性。

boolean

UnresolvedPermission.equals​(Object obj)

检查两个UnresolvedPermission对象是否相等。

Object

Provider.get​(Object key)

Object

Provider.getOrDefault​(Object key, Object defaultValue)

Object

Provider.merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。

Object

Provider.Service.newInstance​(Object constructorParameter)

返回此服务描述的实现的新实例。

Object

Provider.put​(Object key, Object value)

将 key属性设置为具有指定的 value 。

Object

Provider.putIfAbsent​(Object key, Object value)

如果指定的键尚未与值相关联（或映射到 null ）， null其与给定值相关联并返回 null ，否则返回当前值。

Object

Provider.remove​(Object key)

删除 key属性（及其对应的 value ）。

boolean

Provider.remove​(Object key, Object value)

仅当指定的密钥当前映射到指定的值时删除该条目。

Object

Provider.replace​(Object key, Object value)

只有当目标映射到某个值时，才能替换指定键的条目。

boolean

Provider.replace​(Object key, Object oldValue, Object newValue)

仅当当前映射到指定的值时，才能替换指定键的条目。

void

Signature.setParameter​(String param, Object value)

已过时。
使用setParameter 。

boolean

Provider.Service.supportsParameter​(Object parameter)

测试此服务是否可以使用指定的参数。

Method parameters in java.security with type arguments of type Object

Modifier and Type

方法

描述

Object

Provider.compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

Object

Provider.compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

Object

Provider.compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

Object

Provider.computeIfAbsent​(Object key, Function<? super Object,? extends Object> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

Object

Provider.computeIfAbsent​(Object key, Function<? super Object,? extends Object> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

Object

Provider.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

Object

Provider.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

Object

Provider.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

void

Provider.forEach​(BiConsumer<? super Object,? super Object> action)

void

Provider.forEach​(BiConsumer<? super Object,? super Object> action)

Object

Provider.merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。

Object

Provider.merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。

Object

Provider.merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。

void

Provider.replaceAll​(BiFunction<? super Object,? super Object,? extends Object> function)

用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。

void

Provider.replaceAll​(BiFunction<? super Object,? super Object,? extends Object> function)

用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。

void

Provider.replaceAll​(BiFunction<? super Object,? super Object,? extends Object> function)

用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。

Constructors in java.security with parameters of type Object

Constructor

描述

GuardedObject​(Object object, Guard guard)

使用指定的对象和守卫构造一个GuardedObject。

Uses of Object in java.security.acl

Subclasses of Object in java.security.acl

Modifier and Type

Class

描述

class

AclNotFoundException

已过时。
自1.2以来，该软件包已被java.security.Policy及相关课程所取代。

class

LastOwnerException

已过时。
自1.2以来，该软件包已被java.security.Policy及相关课程所取代。

class

NotOwnerException

已过时。
自1.2以来，该软件包已被java.security.Policy及相关课程所取代。

Methods in java.security.acl that return Object

Modifier and Type

方法

描述

Object

AclEntry.clone​()

已过时。

克隆此ACL条目。

Methods in java.security.acl with parameters of type Object

Modifier and Type

方法

描述

boolean

Permission.equals​(Object another)

已过时。

如果传递的对象匹配此接口中表示的权限，则返回true。

Uses of Object in java.security.cert

Subclasses of Object in java.security.cert

Modifier and Type

Class

描述

class

Certificate

用于管理各种身份证件的抽象类。

protected static class

Certificate.CertificateRep

用于序列化的替代证书类。

class

CertificateEncodingException

证书编码异常。

class

CertificateException

此异常表示各种证书问题之一。

class

CertificateExpiredException

证书过期例外

class

CertificateFactory

该类定义了证书工厂的功能，用于从其编码生成证书，认证路径（ CertPath ）和证书吊销列表（CRL）对象。

class

CertificateFactorySpi

该类定义了 CertificateFactory类的 （ SPI ）。

class

CertificateNotYetValidException

证书还没有有效的例外。

class

CertificateParsingException

证书解析异常。

class

CertificateRevokedException

表示X.509证书的异常被撤销。

class

CertPath

证书的不可变序列（认证路径）。

protected static class

CertPath.CertPathRep

替代 CertPath类用于序列化。

class

CertPathBuilder

建立认证路径（也称为证书链）的课程。

class

CertPathBuilderException

一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。

class

CertPathBuilderSpi

CertPathBuilder类的 （ SPI ）。

class

CertPathValidator

用于验证认证路径（也称为证书链）的类。

class

CertPathValidatorException

表示验证认证路径时遇到的各种问题之一的异常。

class

CertPathValidatorSpi

（ SPI ）为CertPathValidator类。

class

CertStore

从存储库检索 Certificate s和 CRL s的类。

class

CertStoreException

一个例外，指出从 CertStore检索证书和CRL的各种问题 CertStore 。

class

CertStoreSpi

CertStore类的 （ SPI ）。

class

CollectionCertStoreParameters

参数用作集合 CertStore算法的输入。

class

CRL

该类是具有不同格式但重要常见用途的证书吊销列表（CRL）的抽象。

class

CRLException

CRL（证书撤销列表）异常。

class

LDAPCertStoreParameters

参数用作LDAP CertStore算法的输入。

class

PKIXBuilderParameters

参数用作PKIX CertPathBuilder算法的输入。

class

PKIXCertPathBuilderResult

此类表示PKIX认证路径构建器算法的成功结果。

class

PKIXCertPathChecker

对 X509Certificate执行一个或多个检查的抽象类。

class

PKIXCertPathValidatorResult

该类代表PKIX认证路径验证算法的成功结果。

class

PKIXParameters

参数用作PKIX CertPathValidator算法的输入。

class

PKIXRevocationChecker

A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。

class

PolicyQualifierInfo

由ASN.1 PolicyQualifierInfo结构表示的不可变策略限定符。

class

TrustAnchor

信任锚或最受信任的证书颁发机构（CA）。

class

URICertStoreParameters

用作 CertStore算法的参数的参数，其使用URI中包含的信息来检索证书和CRL。

class

X509Certificate

X.509证书的抽象类。

class

X509CertSelector

A CertSelector选择符合所有指定条件的 X509Certificates 。

class

X509CRL

X.509证书撤销列表（CRL）的抽象类。

class

X509CRLEntry

CRL（证书撤销列表）中撤销证书的抽象类。

class

X509CRLSelector

A CRLSelector选择符合所有指定条件的 X509CRLs 。

Methods in java.security.cert that return Object

Modifier and Type

方法

描述

Object

CertPathBuilderResult.clone​()

复制一份这个 CertPathBuilderResult 。

Object

CertPathParameters.clone​()

复制这份 CertPathParameters 。

Object

CertPathValidatorResult.clone​()

做一个这个 CertPathValidatorResult的副本。

Object

CertSelector.clone​()

做一个这个 CertSelector的副本。

Object

CertStoreParameters.clone​()

复制这份 CertStoreParameters 。

Object

CollectionCertStoreParameters.clone​()

返回此对象的副本。

Object

CRLSelector.clone​()

复制这份 CRLSelector 。

Object

LDAPCertStoreParameters.clone​()

返回此对象的副本。

Object

PKIXCertPathChecker.clone​()

返回此对象的克隆。

Object

PKIXCertPathValidatorResult.clone​()

返回此对象的副本。

Object

PKIXParameters.clone​()

制作这个 PKIXParameters对象的副本。

Object

X509CertSelector.clone​()

返回此对象的副本。

Object

X509CRLSelector.clone​()

返回此对象的副本。

protected Object

Certificate.CertificateRep.readResolve​()

解决证书对象。

protected Object

CertPath.CertPathRep.readResolve​()

返回从类型和数据构造的 CertPath 。

protected Object

Certificate.writeReplace​()

更换要序列化的证书。

protected Object

CertPath.writeReplace​()

替换 CertPath成与被序列 CertPathRep对象。

Methods in java.security.cert that return types with arguments of type Object

Modifier and Type

方法

描述

Collection<Object>

X509CRLSelector.getIssuerNames​()

返回issuerNames条件的副本。

Methods in java.security.cert with parameters of type Object

Modifier and Type

方法

描述

boolean

Certificate.equals​(Object other)

将此证书与指定的对象进行比较。

boolean

CertPath.equals​(Object other)

将此认证路径与指定的对象进行比较。

boolean

URICertStoreParameters.equals​(Object p)

将指定的对象与此参数对象进行比较以获得相等性。

boolean

X509CRL.equals​(Object other)

将此CRL与给定对象进行比较。

boolean

X509CRLEntry.equals​(Object other)

将此CRL条目与给定对象进行比较。

Uses of Object in java.security.spec

Subclasses of Object in java.security.spec

Modifier and Type

Class

描述

class

DSAGenParameterSpec

此不可变类指定用于生成 FIPS 186-3 Digital Signature Standard (DSS)中指定的DSA参数的参数 集 。

class

DSAParameterSpec

该类指定与DSA算法一起使用的参数集。

class

DSAPrivateKeySpec

此类指定具有相关参数的DSA私钥。

class

DSAPublicKeySpec

该类指定具有相关参数的DSA公钥。

class

ECFieldF2m

这个不可变类定义了椭圆曲线（EC）特征2有限域。

class

ECFieldFp

这个不可变类定义了椭圆曲线（EC）素数有限域。

class

ECGenParameterSpec

这个不可变类指定用于生成椭圆曲线（EC）域参数的参数集。

class

ECParameterSpec

这个不可变类指定了使用椭圆曲线加密（ECC）的一组域参数。

class

ECPoint

这个不可变的类表示仿射坐标中的椭圆曲线（EC）上的点。

class

ECPrivateKeySpec

这个不可变类指定一个带有关联参数的椭圆曲线私钥。

class

ECPublicKeySpec

这个不可变类指定了一个带有关联参数的椭圆曲线公钥。

class

EllipticCurve

这个不变的类保存代表椭圆曲线所需的必要值。

class

EncodedKeySpec

该类表示编码格式的公钥或私钥。

class

InvalidKeySpecException

这是无效密钥规范的例外。

class

InvalidParameterSpecException

这是无效参数规范的例外。

class

MGF1ParameterSpec

该类指定在 PKCS #1 v2.1标准中定义的OAEP填充和RSA-PSS签名方案中与掩码生成函数MGF1一起使用的参数集合。

class

PKCS8EncodedKeySpec

该类代表私有密钥的ASN.1编码，根据ASN.1类型 PrivateKeyInfo编码。

class

PSSParameterSpec

该类指定了 PKCS#1 v2.1标准中定义的RSA-PSS签名方案的参数规范。

class

RSAKeyGenParameterSpec

此类指定用于生成RSA密钥对的参数集。

class

RSAMultiPrimePrivateCrtKeySpec

该类指定PKCS＃1 v2.1中定义的RSA多权限私钥，使用中文余数定理（CRT）信息值进行效率。

class

RSAOtherPrimeInfo

该类表示RSA的OtherPrimeInfo结构中的三元组（素数，指数和系数），如PKCS＃1 v2.1中定义的。

class

RSAPrivateCrtKeySpec

该类指定PKCS＃1标准中定义的RSA私钥，使用中文余数定理（CRT）信息值进行效率。

class

RSAPrivateKeySpec

此类指定一个RSA私钥。

class

RSAPublicKeySpec

此类指定一个RSA公钥。

class

X509EncodedKeySpec

该类表示公钥的ASN.1编码，根据ASN.1类型 SubjectPublicKeyInfo编码。

Methods in java.security.spec with parameters of type Object

Modifier and Type

方法

描述

boolean

ECFieldF2m.equals​(Object obj)

将此有限域作为与指定对象相等的比较。

boolean

ECFieldFp.equals​(Object obj)

将此主要有限域与等同与指定对象进行比较。

boolean

ECPoint.equals​(Object obj)

将此椭圆曲线点与指定对象进行比较。

boolean

EllipticCurve.equals​(Object obj)

将此椭圆曲线与指定对象进行比较。

Uses of Object in java.sql

Subclasses of Object in java.sql

Modifier and Type

Class

描述

class

BatchUpdateException

在批量更新操作期间发生错误时，抛出SQLException的子类。

class

DataTruncation

由于其超出 MaxFieldSize原因，数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取）。

class

Date

大约一毫秒值的薄包装，允许JDBC将其标识为SQL DATE值。

class

DriverManager

用于管理一组JDBC驱动程序的基本服务。

class

DriverPropertyInfo

用于进行连接的驱动程序属性。

class

SQLClientInfoException

当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。

class

SQLDataException

当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。

class

SQLException

提供有关数据库访问错误或其他错误的信息的异常。

class

SQLFeatureNotSupportedException

当SQLState类的值为' 0A '（值为'零'A）时，抛出SQLException的子类。

class

SQLIntegrityConstraintViolationException

当SQLState类值为' 23 '时，或在供应商指定的条件下抛出SQLException的子类。

class

SQLInvalidAuthorizationSpecException

当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。

class

SQLNonTransientConnectionException

的亚类SQLException抛出的SQLState类值“08”，或供应商指定的条件下进行。

class

SQLNonTransientException

SQLException的子类在相同操作的重试失败的情况下抛出，除非修正了SQLException的原因。

class

SQLPermission

的量，许可 SecurityManager将检查当运行用的应用程序代码 SecurityManager启用，调用 DriverManager.deregisterDriver方法， DriverManager.setLogWriter方法， DriverManager.setLogStream （不建议使用）方法， SyncFactory.setJNDIContext方法， SyncFactory.setLogger方法， Connection.setNetworkTimeout方法或 Connection.abort方法。

class

SQLRecoverableException

如果应用程序执行一些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，先前发生故障的操作可能会成功的情况下抛出SQLException的子类。

class

SQLSyntaxErrorException

当SQLState类值为' 42 '时，或在供应商指定的条件下，抛出SQLException的子类。

class

SQLTimeoutException

的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。

class

SQLTransactionRollbackException

当SQLState类值为“ 40 ”时，或者在供应商指定的条件下，抛出SQLException的子类。

class

SQLTransientConnectionException

对于SQLState类值为“ 08 ”的SQLException的子类，或者在供应商指定的条件下。

class

SQLTransientException

SQLException的子类被抛出在以前失败的操作可能能够成功的情况下，当操作被重试而没有任何干预的应用程序级功能。

class

SQLWarning

提供有关数据库访问警告的信息的异常。

class

Time

围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。

class

Timestamp

java.util.Date一个薄包装，允许JDBC API将其识别为SQL TIMESTAMP值。

class

Types

定义用于标识通用SQL类型的常量的类，称为JDBC类型。

Methods in java.sql that return Object

Modifier and Type

方法

描述

Object

Array.getArray​()

以Java编程语言的形式 Array由该 Array对象指定的SQL ARRAY值的内容。

Object

Array.getArray​(long index, int count)

检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。

Object

Array.getArray​(long index, int count, Map<String,Class<?>> map)

检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。

Object

Array.getArray​(Map<String,Class<?>> map)

检索此 Array对象指定的SQL ARRAY值的内容。

Object[]

Struct.getAttributes​()

生成此 Struct对象表示的SQL结构化类型的属性的有序值。

Object[]

Struct.getAttributes​(Map<String,Class<?>> map)

生成此 Struct对象表示的SQL结构化类型的属性的有序值。

Object

CallableStatement.getObject​(int parameterIndex)

以Java编程语言中的 Object指定参数的值。

Object

CallableStatement.getObject​(int parameterIndex, Map<String,Class<?>> map)

返回表示OUT参数 parameterIndex的值的对象，并使用参数值的自定义映射 map 。

Object

CallableStatement.getObject​(String parameterName)

以Java编程语言中的 Object参数的值。

Object

CallableStatement.getObject​(String parameterName, Map<String,Class<?>> map)

返回表示OUT参数 parameterName的值的对象，并使用 map作为参数值的自定义映射。

Object

Ref.getObject​()

检索此 Ref对象引用的SQL结构类型实例。

Object

Ref.getObject​(Map<String,Class<?>> map)

检索引用的对象，并使用给定的类型映射将其映射到Java类型。

Object

ResultSet.getObject​(int columnIndex)

将此 ResultSet对象的当前行中指定列的值作为Java编程语言中的 Object 。

Object

ResultSet.getObject​(int columnIndex, Map<String,Class<?>> map)

以Java编程语言中的 Object此 ResultSet对象当前行中指定列的值。

Object

ResultSet.getObject​(String columnLabel)

将此 ResultSet对象的当前行中指定列的值作为Java编程语言中的 Object 。

Object

ResultSet.getObject​(String columnLabel, Map<String,Class<?>> map)

以Java编程语言中的 Object此 ResultSet对象当前行中指定列的值。

Object

SQLInput.readObject​()

读取流头的数据，并将其作为Java编程语言中的 Object返回。

Methods in java.sql with parameters of type Object

Modifier and Type

方法

描述

Array

Connection.createArrayOf​(String typeName, Object[] elements)

用于创建Array对象的Factory方法。

Struct

Connection.createStruct​(String typeName, Object[] attributes)

用于创建Struct对象的工厂方法。

boolean

RowId.equals​(Object obj)

将此 RowId与指定对象进行比较。

boolean

Timestamp.equals​(Object ts)

测试这个 Timestamp对象是否等于给定的对象。

void

CallableStatement.setObject​(String parameterName, Object x)

使用给定对象设置指定参数的值。

void

CallableStatement.setObject​(String parameterName, Object x, int targetSqlType)

使用给定对象设置指定参数的值。

void

CallableStatement.setObject​(String parameterName, Object x, int targetSqlType, int scale)

使用给定对象设置指定参数的值。

default void

CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType)

使用给定对象设置指定参数的值。

default void

CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType, int scaleOrLength)

使用给定对象设置指定参数的值。

void

PreparedStatement.setObject​(int parameterIndex, Object x)

使用给定对象设置指定参数的值。

void

PreparedStatement.setObject​(int parameterIndex, Object x, int targetSqlType)

使用给定对象设置指定参数的值。

void

PreparedStatement.setObject​(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)

使用给定对象设置指定参数的值。

default void

PreparedStatement.setObject​(int parameterIndex, Object x, SQLType targetSqlType)

使用给定对象设置指定参数的值。

default void

PreparedStatement.setObject​(int parameterIndex, Object x, SQLType targetSqlType, int scaleOrLength)

使用给定对象设置指定参数的值。

void

Ref.setObject​(Object value)

将此 Ref对象引用到给定实例的结构化类型值设置为 Object 。

ShardingKeyBuilder

ShardingKeyBuilder.subkey​(Object subkey, SQLType subkeyType)

将调用此方法将子项添加到正在构建的Sharding Key对象中。

void

ResultSet.updateObject​(int columnIndex, Object x)

使用 Object值更新指定的列。

void

ResultSet.updateObject​(int columnIndex, Object x, int scaleOrLength)

使用 Object值更新指定的列。

default void

ResultSet.updateObject​(int columnIndex, Object x, SQLType targetSqlType)

使用 Object值更新指定的列。

default void

ResultSet.updateObject​(int columnIndex, Object x, SQLType targetSqlType, int scaleOrLength)

使用 Object值更新指定的列。

void

ResultSet.updateObject​(String columnLabel, Object x)

使用 Object值更新指定的列。

void

ResultSet.updateObject​(String columnLabel, Object x, int scaleOrLength)

使用 Object值更新指定的列。

default void

ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType)

使用 Object值更新指定的列。

default void

ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType, int scaleOrLength)

使用 Object值更新指定的列。

default void

SQLOutput.writeObject​(Object x, SQLType targetSqlType)

将包含在给定对象中的数据写入流。

Uses of Object in java.text

Subclasses of Object in java.text

Modifier and Type

Class

描述

class

Annotation

如果属性具有注释特征，则Annotation对象用作文本属性值的包装器。

static class

AttributedCharacterIterator.Attribute

定义用于标识文本属性的属性键。

class

AttributedString

AttributedString保存文本和相关属性信息。

class

Bidi

该类实现了Unicode双向算法。

class

BreakIterator

BreakIterator类实现了在文本中查找边界位置的方法。

class

ChoiceFormat

A ChoiceFormat允许您将格式附加到一系列数字。

class

CollationElementIterator

CollationElementIterator类用作遍历国际字符串的每个字符的迭代器。

class

CollationKey

A CollationKey表示一个 String根据特定的 Collator对象的规则。

class

Collator

Collator类执行区域设置敏感 String比较。

class

DateFormat

DateFormat是一种用于日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。

static class

DateFormat.Field

定义了用于作为属性键常数 AttributedCharacterIterator从返回 DateFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。

class

DateFormatSymbols

DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，一周中的几天的名称和时区数据。

class

DecimalFormat

DecimalFormat是格式为十进制数的 NumberFormat的具体子类。

class

DecimalFormatSymbols

此类表示 DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。

class

FieldPosition

FieldPosition是由 Format及其子类使用的简单类，用于标识格式化输出中的字段。

class

Format

Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。

static class

Format.Field

定义了用于作为属性键常数 AttributedCharacterIterator从返回 Format.formatToCharacterIterator和字段标识符在 FieldPosition 。

class

MessageFormat

MessageFormat提供了一种以语言中立的方式产生连接消息的方法。

static class

MessageFormat.Field

定义在 AttributedCharacterIterator返回的 AttributedCharacterIterator中用作属性键的 MessageFormat.formatToCharacterIterator 。

class

Normalizer

该类提供了将Unicode文本转换为等效的组合或分解形式的方法 normalize ，从而可以轻松地对文本进行排序和搜索。

class

NumberFormat

NumberFormat是所有数字格式的抽象基类。

static class

NumberFormat.Field

定义了用于作为属性键常数 AttributedCharacterIterator从返回 NumberFormat.formatToCharacterIterator和字段标识符在 FieldPosition 。

class

ParseException

表示解析时意外出现错误。

class

ParsePosition

ParsePosition是一个简单的类，由 Format及其子类使用，用于跟踪解析过程中的当前位置。

class

RuleBasedCollator

所述 RuleBasedCollator类是的具体子类 Collator ，提供了一个简单的，数据驱动的表collator。

class

SimpleDateFormat

SimpleDateFormat是一个具体的类，用于以区域设置敏感的方式格式化和解析日期。

class

StringCharacterIterator

StringCharacterIterator实现 CharacterIterator协议为 String 。

Methods in java.text that return Object

Modifier and Type

方法

描述

Object

BreakIterator.clone​()

创建一个这个迭代器的副本

Object

CharacterIterator.clone​()

创建一个这个迭代器的副本

Object

ChoiceFormat.clone​()

覆盖可克隆

Object

Collator.clone​()

覆盖可克隆

Object

DateFormat.clone​()

覆盖可克隆

Object

DateFormatSymbols.clone​()

覆盖可克隆

Object

DecimalFormat.clone​()

标准覆盖 语义不变。

Object

DecimalFormatSymbols.clone​()

标准覆盖。

Object

Format.clone​()

创建并返回此对象的副本。

Object

MessageFormat.clone​()

创建并返回此对象的副本。

Object

NumberFormat.clone​()

覆盖可克隆。

Object

RuleBasedCollator.clone​()

标准覆盖 语义不变。

Object

SimpleDateFormat.clone​()

创建一个这个 SimpleDateFormat的副本。

Object

StringCharacterIterator.clone​()

创建此迭代器的副本。

Object

AttributedCharacterIterator.getAttribute​(AttributedCharacterIterator.Attribute attribute)

返回当前字符的名称为 attribute的值。

Object[]

ChoiceFormat.getFormats​()

获取在构造函数中传递的格式。

Object

Annotation.getValue​()

返回属性的值，可以为null。

Object[]

MessageFormat.parse​(String source)

从给定字符串的开头解析文本以产生一个对象数组。

Object[]

MessageFormat.parse​(String source, ParsePosition pos)

解析字符串。

Object

DateFormat.parseObject​(String source, ParsePosition pos)

从字符串中解析文本，产生一个 Date 。

Object

Format.parseObject​(String source)

从给定字符串的开头解析文本以产生一个对象。

abstract Object

Format.parseObject​(String source, ParsePosition pos)

从字符串中解析文本以生成对象。

Object

MessageFormat.parseObject​(String source, ParsePosition pos)

从字符串中解析文本以生成对象数组。

Object

NumberFormat.parseObject​(String source, ParsePosition pos)

从字符串中解析文本，产生一个 Number 。

protected Object

AttributedCharacterIterator.Attribute.readResolve​()

解析反序列化为预定义常量的实例。

protected Object

DateFormat.Field.readResolve​()

解析反序列化为预定义常量的实例。

protected Object

MessageFormat.Field.readResolve​()

解析反序列化为预定义常量的实例。

protected Object

NumberFormat.Field.readResolve​()

解析反序列化为预定义常量的实例。

Methods in java.text that return types with arguments of type Object

Modifier and Type

方法

描述

Map<AttributedCharacterIterator.Attribute,Object>

AttributedCharacterIterator.getAttributes​()

返回当前字符中定义的属性的地图。

Methods in java.text with parameters of type Object

Modifier and Type

方法

描述

void

AttributedString.addAttribute​(AttributedCharacterIterator.Attribute attribute, Object value)

在整个字符串中添加一个属性。

void

AttributedString.addAttribute​(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex)

将一个属性添加到字符串的子范围。

int

Collator.compare​(Object o1, Object o2)

比较其两个参数的顺序。

boolean

AttributedCharacterIterator.Attribute.equals​(Object obj)

比较两个对象的平等。

boolean

ChoiceFormat.equals​(Object obj)

两者之间的平等比较

boolean

Collator.equals​(Object that)

比较两个Collator的平等。

boolean

DateFormat.equals​(Object obj)

覆盖等于

boolean

DateFormatSymbols.equals​(Object obj)

覆盖等于

boolean

DecimalFormat.equals​(Object obj)

覆盖等于

boolean

DecimalFormatSymbols.equals​(Object obj)

覆盖等于。

boolean

FieldPosition.equals​(Object obj)

覆盖等于

boolean

MessageFormat.equals​(Object obj)

两个消息格式对象之间的平等比较

boolean

NumberFormat.equals​(Object obj)

覆盖等于。

boolean

ParsePosition.equals​(Object obj)

覆盖等于

boolean

RuleBasedCollator.equals​(Object obj)

比较两个对照对象的相等性。

boolean

SimpleDateFormat.equals​(Object obj)

将给定对象与此 SimpleDateFormat进行比较以获得相等性。

boolean

StringCharacterIterator.equals​(Object obj)

比较两个StringCharacterIterator对象的相等性。

StringBuffer

DateFormat.format​(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition)

覆盖格式。

StringBuffer

DecimalFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)

格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。

String

Format.format​(Object obj)

格式化一个对象来生成一个字符串。

abstract StringBuffer

Format.format​(Object obj, StringBuffer toAppendTo, FieldPosition pos)

格式化对象并将生成的文本附加到给定的字符串缓冲区。

StringBuffer

MessageFormat.format​(Object[] arguments, StringBuffer result, FieldPosition pos)

格式化一个对象数组，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。

StringBuffer

MessageFormat.format​(Object arguments, StringBuffer result, FieldPosition pos)

格式化一组对象，并将 MessageFormat的格式附加到格式化对象的格式元素中，并提供给所提供的 StringBuffer 。

static String

MessageFormat.format​(String pattern, Object... arguments)

使用给定的模式创建一个MessageFormat，并使用它来格式化给定的参数。

StringBuffer

NumberFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)

格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。

AttributedCharacterIterator

DecimalFormat.formatToCharacterIterator​(Object obj)

格式化一个对象，生成一个 AttributedCharacterIterator 。

AttributedCharacterIterator

Format.formatToCharacterIterator​(Object obj)

格式化一个对象，生成一个 AttributedCharacterIterator 。

AttributedCharacterIterator

MessageFormat.formatToCharacterIterator​(Object arguments)

格式化一组对象并将其插入到 MessageFormat的模式中，产生一个 AttributedCharacterIterator 。

AttributedCharacterIterator

SimpleDateFormat.formatToCharacterIterator​(Object obj)

格式化一个对象，生成一个 AttributedCharacterIterator 。

static void

Bidi.reorderVisually​(byte[] levels, int levelStart, Object[] objects, int objectStart, int count)

将数组中的对象根据其级别重新排序为可视化顺序。

Constructors in java.text with parameters of type Object

Constructor

描述

Annotation​(Object value)

构造具有给定值的注释记录，可以为null。

Uses of Object in java.text.spi

Subclasses of Object in java.text.spi

Modifier and Type

Class

描述

class

BreakIteratorProvider

提供BreakIterator类的具体实现的服务提供者的抽象类。

class

CollatorProvider

提供Collator类的具体实现的服务提供者的抽象类。

class

DateFormatProvider

提供DateFormat类的具体实现的服务提供者的抽象类。

class

DateFormatSymbolsProvider

提供DateFormatSymbols类的实例的服务提供者的抽象类。

class

DecimalFormatSymbolsProvider

提供DecimalFormatSymbols类的实例的服务提供者的抽象类。

class

NumberFormatProvider

提供NumberFormat类的具体实现的服务提供者的抽象类。

Uses of Object in java.time

Subclasses of Object in java.time

Modifier and Type

Class

描述

class

Clock

使用时区提供对当前即时，日期和时间的访问的时钟。

class

DateTimeException

用于在计算日期时间时指示问题的异常。

class

Duration

基于时间的时间量，如'34.5秒'。

class

Instant

在时间线上的瞬间点。

class

LocalDate

在ISO- 2007-12-03 ，如 2007-12-03 。

class

LocalDateTime

在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。

class

LocalTime

在ISO- 10:15:30 ，如 10:15:30 。

class

MonthDay

ISO- --12-03 ，如 --12-03 。

class

OffsetDateTime

在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。

class

OffsetTime

在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。

class

Period

ISO-8601日历系统中的日期时间，例如“2年3个月4天”。

class

Year

ISO- 2007 ，如 2007 。

class

YearMonth

在ISO- 2007-12 ，如 2007-12 。

class

ZonedDateTime

ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。

class

ZoneId

一个时区ID，如 Europe/Paris 。

class

ZoneOffset

与格林威治/ UTC的时区偏移，如 +02:00 。

Methods in java.time with parameters of type Object

Modifier and Type

方法

描述

boolean

Clock.equals​(Object obj)

检查这个时钟是否等于另一个时钟。

boolean

Duration.equals​(Object otherDuration)

检查此持续时间是否等于指定的 Duration 。

boolean

Instant.equals​(Object otherInstant)

检查这个瞬间是否等于指定的时刻。

boolean

LocalDate.equals​(Object obj)

检查这个日期是否等于另一个日期。

boolean

LocalDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

LocalTime.equals​(Object obj)

检查这次是否等于另一次。

boolean

MonthDay.equals​(Object obj)

检查这个月日是否等于另一个月 - 日。

boolean

OffsetDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

OffsetTime.equals​(Object obj)

检查这次是否等于另一次。

boolean

Period.equals​(Object obj)

检查此期间是否等于另一期间。

boolean

Year.equals​(Object obj)

检查今年是否等于另一年。

boolean

YearMonth.equals​(Object obj)

检查这个年月是否等于另一个一个月。

boolean

ZonedDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

ZoneId.equals​(Object obj)

检查此时区ID是否等于其他时区ID。

boolean

ZoneOffset.equals​(Object obj)

检查这个偏移量是否等于另一个偏移量。

Uses of Object in java.time.chrono

Subclasses of Object in java.time.chrono

Modifier and Type

Class

描述

class

AbstractChronology

用于组织和识别日期的日历系统的抽象实现。

class

HijrahChronology

Hijrah日历是支持伊斯兰教日历的农历。

class

HijrahDate

日期在Hijrah日历系统。

class

IsoChronology

ISO日历系统。

class

JapaneseChronology

日本帝国历法系统。

class

JapaneseDate

在日本帝国日历系统的日期。

class

JapaneseEra

日本帝国日历系统的一个时代。

class

MinguoChronology

国际日历系统。

class

MinguoDate

在日语系统中的日期。

class

ThaiBuddhistChronology

泰国佛教日历系统。

class

ThaiBuddhistDate

在泰国佛教日历系统的日期。

Methods in java.time.chrono with parameters of type Object

Modifier and Type

方法

描述

boolean

AbstractChronology.equals​(Object obj)

检查这个年表是否等于另一个年表。

boolean

ChronoLocalDate.equals​(Object obj)

检查这个日期是否等于另一个日期，包括年表。

boolean

ChronoLocalDateTime.equals​(Object obj)

检查这个日期时间是否等于另一个日期时间，包括年表。

boolean

Chronology.equals​(Object obj)

检查这个年表是否等于另一个年表。

boolean

ChronoPeriod.equals​(Object obj)

检查这个时期是否等于另一个时期，包括年表。

boolean

ChronoZonedDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

HijrahDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

boolean

JapaneseDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

boolean

MinguoDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

boolean

ThaiBuddhistDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

Uses of Object in java.time.format

Subclasses of Object in java.time.format

Modifier and Type

Class

描述

class

DateTimeFormatter

格式化器用于打印和解析日期时间对象。

class

DateTimeFormatterBuilder

Builder创建日期格式化程序。

class

DateTimeParseException

解析期间发生错误时抛出异常。

class

DecimalStyle

在日期和时间格式中使用的本地化十进制格式。

Methods in java.time.format with parameters of type Object

Modifier and Type

方法

描述

boolean

DecimalStyle.equals​(Object obj)

检查这个DecimalStyle是否等于另一个DecimalStyle。

Uses of Object in java.time.temporal

Subclasses of Object in java.time.temporal

Modifier and Type

Class

描述

class

IsoFields

特定于ISO-8601日历系统的领域和单位，包括季度和周年。

class

JulianFields

一组提供访问朱利安日的日期字段。

class

TemporalAdjusters

常用和有用的TemporalAdjusters。

class

TemporalQueries

通用实现 TemporalQuery 。

class

UnsupportedTemporalTypeException

UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。

class

ValueRange

日期时间字段的有效值的范围。

class

WeekFields

星期几，星期周和周末字段的本地化定义。

Methods in java.time.temporal with parameters of type Object

Modifier and Type

方法

描述

boolean

ValueRange.equals​(Object obj)

检查此范围是否等于另一个范围。

boolean

WeekFields.equals​(Object object)

检查这个 WeekFields是否等于指定的对象。

Uses of Object in java.time.zone

Subclasses of Object in java.time.zone

Modifier and Type

Class

描述

class

ZoneOffsetTransition

由本地时间线不连续性引起的两个偏移之间的转换。

class

ZoneOffsetTransitionRule

表达如何创建转换的规则。

class

ZoneRules

定义区域偏移对于单个时区的变化的规则。

class

ZoneRulesException

抛出指示时区配置的问题。

class

ZoneRulesProvider

提供给系统的时区规则。

Methods in java.time.zone with parameters of type Object

Modifier and Type

方法

描述

boolean

ZoneOffsetTransition.equals​(Object other)

检查这个对象是否等于另一个。

boolean

ZoneOffsetTransitionRule.equals​(Object otherRule)

检查这个对象是否等于另一个。

boolean

ZoneRules.equals​(Object otherRules)

检查这套规则是否等于另一个。

Uses of Object in java.util

Subclasses of Object in java.util

Modifier and Type

Class

描述

class

AbstractCollection<E>

该类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。

class

AbstractList<E>

该类提供List接口的骨架实现，以最小化实现由“随机存取”数据存储（例如数组）支持的此接口所需的工作量。

class

AbstractMap<K,V>

该类提供 Map接口的骨架实现，以最大限度地减少实现此接口所需的工作量。

static class

AbstractMap.SimpleEntry<K,V>

保存密钥和值的条目。

static class

AbstractMap.SimpleImmutableEntry<K,V>

保持一个不变的钥匙和价值的条目。

class

AbstractQueue<E>

这个类提供了一些Queue操作的骨架实现。

class

AbstractSequentialList<E>

该类提供了 List接口的骨架实现，以最小化实现由“顺序访问”数据存储（如链接列表）支持的此接口所需的工作量。

class

AbstractSet<E>

该类提供了 Set接口的骨架实现，以尽量减少实现此接口所需的工作量。

class

ArrayDeque<E>

Deque接口的可调整大小的数组实现。

class

ArrayList<E>

List接口的可调整大小的数组实现。

class

Arrays

该类包含用于操作数组的各种方法（如排序和搜索）。

class

Base64

该类仅由用于获得Base64编码方案的编码器和解码器的静态方法组成。

static class

Base64.Decoder

该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于解码字节数据的解码器。

static class

Base64.Encoder

该类使用RFC 4648和RFC 2045中规定的Base64编码方案来实现用于编码字节数据的编码器。

class

BitSet

该类实现了根据需要增长的位向量。

class

Calendar

所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。

static class

Calendar.Builder

Calendar.Builder用于从各种日期时间参数创建 Calendar 。

class

Collections

此类仅由静态方法组合或返回集合。

class

ConcurrentModificationException

当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。

class

Currency

代表货币。

class

Date

Date类代表了一个特定的时刻，毫秒级的精度。

class

Dictionary<K,V>

Dictionary类是任何类的抽象父类，例如 Hashtable ，它将键映射到值。

class

DoubleSummaryStatistics

统计数据的收集状态，如count，min，max，sum和average。

class

DuplicateFormatFlagsException

在格式说明符中提供重复标志时抛出未经检查的异常。

class

EmptyStackException

由 Stack类中的方法抛出，表示堆栈为空。

class

EnumMap<K extends Enum<K>,V>

专门用于枚举类型键的Map实现。

class

EnumSet<E extends Enum<E>>

专门用于枚举类型的Set实现。

class

EventListenerProxy<T extends EventListener>

EventListener类的抽象包装类， EventListener一组附加参数与侦听器相关联。

class

EventObject

所有事件状态对象应从其派生的根类。

class

FormatFlagsConversionMismatchException

转换和标志不兼容时抛出未经检查的异常。

class

FormattableFlags

FomattableFlags被传递给Formattable.formatTo()方法和修改的输出格式为Formattables 。

class

Formatter

printf风格格式字符串的解释器。

class

FormatterClosedException

格式化程序已关闭时抛出未检查的异常。

class

GregorianCalendar

GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。

class

HashMap<K,V>

基于哈希表的实现的 Map接口。

class

HashSet<E>

该类实现了 Set接口，由哈希表（实际为 HashMap实例）支持。

class

Hashtable<K,V>

该类实现了一个哈希表，它将键映射到值。

class

IdentityHashMap<K,V>

该类使用哈希表实现 Map接口，在比较键（和值）时使用引用相等代替对象相等。

class

IllegalFormatCodePointException

当由Character.isValidCodePoint(int)定义的具有无效Unicode代码点的字符传递给Formatter时，将抛出未经检查的异常。

class

IllegalFormatConversionException

当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。

class

IllegalFormatException

当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。

class

IllegalFormatFlagsException

提供非法组合标志时抛出未检查的异常。

class

IllegalFormatPrecisionException

当精度为 -1以外的负值时，抛出未检查的异常，转换不支持精度，否则不支持该值。

class

IllegalFormatWidthException

当格式宽度为 -1以外的负值时，将抛出未检查的异常，否则不受支持。

class

IllformedLocaleException

由Locale和Locale.Builder中的方法抛出，以表明参数不是一个格式正确的BCP 47标签。

class

InputMismatchException

由 Scanner抛出，表示检索到的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。

class

IntSummaryStatistics

统计数据的收集状态，如count，min，max，sum和average。

class

InvalidPropertiesFormatException

抛出以表示操作无法完成，因为输入符合Properties规范的属性集合的相应XML文档类型。

class

LinkedHashMap<K,V>

哈希表和链表实现的 Map接口，具有可预测的迭代顺序。

class

LinkedHashSet<E>

哈希表和链表实现的 Set接口，具有可预测的迭代顺序。

class

LinkedList<E>

双链表实现了 List和 Deque接口。

class

ListResourceBundle

ListResourceBundle是一个抽象类 ResourceBundle管理资源，以方便和易于使用的列表区域设置。

class

Locale

一个 Locale对象代表一个具体的地理，政治或文化地区。

static class

Locale.Builder

Builder用于从由setter配置的值构建 Locale实例。

static class

Locale.LanguageRange

该类表示 RFC 4647 Matching of Language Tags中定义的 语言范围 。

class

LongSummaryStatistics

统计数据的收集状态，如count，min，max，sum和average。

class

MissingFormatArgumentException

当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。

class

MissingFormatWidthException

需要格式宽度时抛出未检查的异常。

class

MissingResourceException

表示资源丢失。

class

NoSuchElementException

被各种访问器方法抛出，表示被请求的元素不存在。

class

Objects

此类由 static用于在对象上操作的实用方法或在操作之前检查某些条件。

class

Observable

已过时。
此类和Observer接口已被弃用。 由Observer和Observable支持的事件模式是非常有限的， Observable传递的通知的Observable是未指定的，状态更改不与通知一一对应。 对于更丰富的事件模型，请考虑使用java.beans软件包。 对于线程之间的可靠和有序的消息传递，请考虑使用java.util.concurrent包中的并发数据结构之一。 对于反应流样式编程，请参阅Flow API。

class

Optional<T>

可能包含或不包含非 null值的容器对象。

class

OptionalDouble

可能包含或不包含 double值的容器对象。

class

OptionalInt

一个可能含有也可能不包含 int值的容器对象。

class

OptionalLong

可能包含或不包含 long值的容器对象。

class

PriorityQueue<E>

基于优先级堆的无限优先级queue 。

class

Properties

Properties类表示一组持久的属性。

class

PropertyPermission

此类用于属性权限。

class

PropertyResourceBundle

PropertyResourceBundle是的具体子类 ResourceBundle管理资源使用一组属性文件中的静态字符串的语言环境。

class

Random

该类的实例用于生成伪随机数的流。

class

ResourceBundle

资源束包含区域特定的对象。

static class

ResourceBundle.Control

ResourceBundle.Control定义了在捆绑包加载过程中由 ResourceBundle.getBundle工厂方法调用的一组回调方法。

class

Scanner

一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。

class

ServiceConfigurationError

在查找，加载或实例化服务提供商时发生错误时发生错误。

class

ServiceLoader<S>

一种加载服务实现的工具。

class

SimpleTimeZone

SimpleTimeZone是一个具体子类 TimeZone ，表示一个使用格里高利历的时区。

class

Spliterators

静态类和用于上操作或创建的实例的方法Spliterator及其原始特Spliterator.OfInt ， Spliterator.OfLong ，和Spliterator.OfDouble 。

static class

Spliterators.AbstractDoubleSpliterator

一个抽象的 Spliterator.OfDouble实现 trySplit以允许有限的并行性。

static class

Spliterators.AbstractIntSpliterator

一个抽象的 Spliterator.OfInt实现 trySplit以允许有限的并行性。

static class

Spliterators.AbstractLongSpliterator

摘要 Spliterator.OfLong实现了 trySplit以允许有限的并行性。

static class

Spliterators.AbstractSpliterator<T>

一个抽象的 Spliterator实现 trySplit以允许有限的并行性。

class

SplittableRandom

适用于（在其他上下文中）使用可能产生子任务的孤立并行计算的均匀伪随机值的生成器。

class

Stack<E>

Stack类代表一个先进先出（LIFO）的对象堆栈。

class

StringJoiner

StringJoiner用于构造由分隔符分隔的字符序列，并且可选地从提供的前缀开始并以提供的后缀结尾。

class

StringTokenizer

字符串tokenizer类允许应用程序将字符串拆分成令牌。

class

Timer

线程调度任务以供将来在后台线程中执行的功能。

class

TimerTask

可以通过Timer进行一次性或重复执行的任务 。

class

TimeZone

TimeZone表示时区偏移，并且还显示出夏令时。

class

TooManyListenersException

TooManyListenersException异常用作Java事件模型的一部分，用于注释和实现组播事件源的单播特殊情况。

class

TreeMap<K,V>

一个基于红黑树的NavigableMap实现。

class

TreeSet<E>

一个NavigableSet实现基于一个TreeMap 。

class

UnknownFormatConversionException

给出未知转换时抛出未检查的异常。

class

UnknownFormatFlagsException

给定未知标志时抛出未检查的异常。

class

UUID

一个表示不可变的通用唯一标识符（UUID）的类。

class

Vector<E>

Vector类实现了可扩展的对象数组。

class

WeakHashMap<K,V>

基于哈希表的实现的 Map接口，具有 弱键 。

Fields in java.util declared as Object

Modifier and Type

Field

描述

protected Object[]

Vector.elementData

存储向量的组件的阵列缓冲区。

protected Object

EventObject.source

事件最初发生的对象。

Methods in java.util with type parameters of type Object

Modifier and Type

方法

描述

static <T extends Object & Comparable<? super T>>
T

Collections.max​(Collection<? extends T> coll)

根据其元素的 自然顺序返回给定集合的最大元素。

static <T extends Object & Comparable<? super T>>
T

Collections.min​(Collection<? extends T> coll)

根据其元素的 自然顺序返回给定集合的最小元素。

Methods in java.util that return Object

Modifier and Type

方法

描述

protected Object

AbstractMap.clone​()

返回此 AbstractMap实例的浅拷贝：键和值本身不被克隆。

Object

ArrayList.clone​()

返回此 ArrayList实例的浅拷贝。

Object

BitSet.clone​()

克隆 BitSet产生一个新的 BitSet ，等于它。

Object

Calendar.clone​()

创建并返回此对象的副本。

Object

Date.clone​()

返回此对象的副本。

Object

GregorianCalendar.clone​()

Object

HashMap.clone​()

返回此 HashMap实例的浅拷贝：键和值本身不被克隆。

Object

HashSet.clone​()

返回此 HashSet实例的浅拷贝：元素本身不被克隆。

Object

Hashtable.clone​()

创建这个散列表的浅拷贝。

Object

IdentityHashMap.clone​()

返回此标识哈希映射的浅拷贝：键和值本身不被克隆。

Object

LinkedList.clone​()

返回此 LinkedList的浅拷贝。

Object

Locale.clone​()

覆盖可克隆。

Object

Properties.clone​()

Object

SimpleTimeZone.clone​()

返回此 SimpleTimeZone实例的克隆。

Object

TimeZone.clone​()

创建一个这个 TimeZone的副本。

Object

TreeMap.clone​()

返回此 TreeMap实例的浅拷贝。

Object

TreeSet.clone​()

返回此 TreeSet实例的浅拷贝。

Object

Vector.clone​()

返回此向量的克隆。

Object

Properties.compute​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

Object

Properties.computeIfAbsent​(Object key, Function<? super Object,?> mappingFunction)

Object

Properties.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

static <T> T[]

Arrays.copyOf​(T[] original, int newLength)

复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。

static <T,U> T[]

Arrays.copyOf​(U[] original, int newLength, Class<? extends T[]> newType)

复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。

static <T> T[]

Arrays.copyOfRange​(T[] original, int from, int to)

将指定数组的指定范围复制到新数组中。

static <T,U> T[]

Arrays.copyOfRange​(U[] original, int from, int to, Class<? extends T[]> newType)

将指定数组的指定范围复制到新数组中。

Object

Properties.get​(Object key)

protected abstract Object[][]

ListResourceBundle.getContents​()

返回一个数组，其中每个项目是 Object数组中的一对对象。

Object

ResourceBundle.getObject​(String key)

从此资源包或其父项之一获取给定密钥的对象。

Object

Properties.getOrDefault​(Object key, Object defaultValue)

Object

EventObject.getSource​()

事件最初发生的对象。

Object

ListResourceBundle.handleGetObject​(String key)

Object

PropertyResourceBundle.handleGetObject​(String key)

protected abstract Object

ResourceBundle.handleGetObject​(String key)

从此资源包获取给定键的对象。

Object

Properties.merge​(Object key, Object value, BiFunction<? super Object,? super Object,?> remappingFunction)

Object

StringTokenizer.nextElement​()

返回与 nextToken方法相同的值，但其声明的返回值为 Object而不是 String 。

Object

Properties.put​(Object key, Object value)

Object

Properties.putIfAbsent​(Object key, Object value)

Object

Properties.remove​(Object key)

Object

Properties.replace​(Object key, Object value)

Object

Properties.setProperty​(String key, String value)

致电 Hashtable方法 put 。

Object[]

AbstractCollection.toArray​()

返回一个包含此集合中所有元素的数组。

<T> T[]

AbstractCollection.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

ArrayDeque.toArray​()

以适当的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）。

<T> T[]

ArrayDeque.toArray​(T[] a)

以正确的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

ArrayList.toArray​()

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

<T> T[]

ArrayList.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

Collection.toArray​()

返回一个包含此集合中所有元素的数组。

<T> T[]

Collection.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

LinkedList.toArray​()

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

<T> T[]

LinkedList.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

List.toArray​()

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

<T> T[]

List.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

PriorityQueue.toArray​()

返回一个包含此队列中所有元素的数组。

<T> T[]

PriorityQueue.toArray​(T[] a)

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

Set.toArray​()

返回一个包含此集合中所有元素的数组。

<T> T[]

Set.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

Vector.toArray​()

以正确的顺序返回一个包含此Vector中所有元素的数组。

<T> T[]

Vector.toArray​(T[] a)

以正确的顺序返回一个包含此Vector中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Methods in java.util that return types with arguments of type Object

Modifier and Type

方法

描述

Enumeration<Object>

Properties.elements​()

Set<Map.Entry<Object,Object>>

Properties.entrySet​()

Set<Map.Entry<Object,Object>>

Properties.entrySet​()

Enumeration<Object>

Properties.keys​()

Set<Object>

Properties.keySet​()

Collection<Object>

Properties.values​()

Methods in java.util with parameters of type Object

Modifier and Type

方法

描述

static <T> boolean

Collections.addAll​(Collection<? super T> c, T... elements)

将所有指定的元素添加到指定的集合。

boolean

Calendar.after​(Object when)

返回此 Calendar是否表示在指定的 Object表示的时间之后的时间。

static <T> List<T>

Arrays.asList​(T... a)

返回由指定数组支持的固定大小的列表。

boolean

Calendar.before​(Object when)

返回此 Calendar是否表示在指定的 Object表示的时间之前的时间。

static int

Arrays.binarySearch​(Object[] a, int fromIndex, int toIndex, Object key)

使用二进制搜索算法搜索指定对象的指定数组的范围。

static int

Arrays.binarySearch​(Object[] a, Object key)

使用二叉搜索算法搜索指定对象的指定数组。

static <T> int

Arrays.binarySearch​(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)

使用二进制搜索算法搜索指定对象的指定数组的范围。

static <T> int

Arrays.binarySearch​(T[] a, T key, Comparator<? super T> c)

使用二叉搜索算法搜索指定对象的指定数组。

static <T> int

Arrays.compare​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)

比较两个 Object阵列在指定范围内的字典。

static <T> int

Arrays.compare​(T[] a, T[] b, Comparator<? super T> cmp)

比较两个 Object阵列，使用指定的比较器进行字典比对。

Object

Properties.compute​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

Object

Properties.computeIfAbsent​(Object key, Function<? super Object,?> mappingFunction)

Object

Properties.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

boolean

AbstractCollection.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

ArrayDeque.contains​(Object o)

如果此deque包含指定的元素，则返回 true 。

boolean

ArrayList.contains​(Object o)

如果此列表包含指定的元素，则返回 true 。

boolean

Collection.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

Deque.contains​(Object o)

如果此deque包含指定的元素，则返回 true 。

boolean

HashSet.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

Hashtable.contains​(Object value)

测试一些键映射到这个哈希表中的指定值。

boolean

LinkedList.contains​(Object o)

如果此列表包含指定的元素，则返回 true 。

boolean

List.contains​(Object o)

如果此列表包含指定的元素，则返回 true 。

boolean

PriorityQueue.contains​(Object o)

如果此队列包含指定的元素，则返回 true 。

boolean

Properties.contains​(Object value)

boolean

Set.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

TreeSet.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

Vector.contains​(Object o)

如果此向量包含指定的元素，则返回 true 。

boolean

AbstractMap.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

EnumMap.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

HashMap.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

Hashtable.containsKey​(Object key)

测试指定的对象是否在此哈希表中的键。

boolean

IdentityHashMap.containsKey​(Object key)

测试此标识哈希映射中指定的对象引用是否为密钥。

boolean

Map.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

Properties.containsKey​(Object key)

boolean

TreeMap.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

WeakHashMap.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

AbstractMap.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

boolean

EnumMap.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

boolean

HashMap.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

boolean

Hashtable.containsValue​(Object value)

如果此哈希表将一个或多个键映射到此值，则返回true。

boolean

IdentityHashMap.containsValue​(Object value)

测试指定的对象引用是否是此标识哈希映射中的值。

boolean

LinkedHashMap.containsValue​(Object value)

如果此地图将一个或多个键映射到指定值，则返回 true 。

boolean

Map.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

boolean

Properties.containsValue​(Object value)

boolean

TreeMap.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

boolean

WeakHashMap.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

void

Vector.copyInto​(Object[] anArray)

将此向量的组件复制到指定的数组中。

static <T> T[]

Arrays.copyOf​(T[] original, int newLength)

复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。

static <T,U> T[]

Arrays.copyOf​(U[] original, int newLength, Class<? extends T[]> newType)

复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。

static <T> T[]

Arrays.copyOfRange​(T[] original, int from, int to)

将指定数组的指定范围复制到新数组中。

static <T,U> T[]

Arrays.copyOfRange​(U[] original, int from, int to, Class<? extends T[]> newType)

将指定数组的指定范围复制到新数组中。

static boolean

Arrays.deepEquals​(Object[] a1, Object[] a2)

如果两个指定的数组彼此 深度相等 ，则返回 true 。

static boolean

Objects.deepEquals​(Object a, Object b)

返回 true如果参数是深层相等，彼此 false否则。

static int

Arrays.deepHashCode​(Object[] a)

根据指定数组的“深度内容”返回哈希码。

static String

Arrays.deepToString​(Object[] a)

返回指定数组的“深度内容”的字符串表示形式。

boolean

AbstractList.equals​(Object o)

将指定的对象与此列表进行比较以获得相等性。

boolean

AbstractMap.equals​(Object o)

将指定的对象与此映射进行比较以获得相等性。

boolean

AbstractMap.SimpleEntry.equals​(Object o)

将指定的对象与此条目进行比较以获得相等性。

boolean

AbstractMap.SimpleImmutableEntry.equals​(Object o)

将指定的对象与此条目进行比较以获得相等性。

boolean

AbstractSet.equals​(Object o)

将指定的对象与此集合进行比较以实现相等。

static boolean

Arrays.equals​(Object[] a, int aFromIndex, int aToIndex, Object[] b, int bFromIndex, int bToIndex)

如果两个指定的对象数组在指定范围内彼此 相等 ，则返回true。

static boolean

Arrays.equals​(Object[] a, Object[] a2)

如果两个指定的对象数组彼此 相等 ，则返回 true 。

static <T> boolean

Arrays.equals​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)

如果两个指定的对象数组在指定范围内彼此 相等 ，则返回true。

static <T> boolean

Arrays.equals​(T[] a, T[] a2, Comparator<? super T> cmp)

如果两个指定的对象数组彼此 相等 ，则返回 true 。

boolean

BitSet.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

Calendar.equals​(Object obj)

将此 Calendar与指定的 Object 。

boolean

Collection.equals​(Object o)

将指定的对象与此集合进行比较以获得相等性。

boolean

Comparator.equals​(Object obj)

指示某个其他对象是否等于此比较器。

boolean

Date.equals​(Object obj)

比较两个日期来平等。

boolean

EnumMap.equals​(Object o)

将指定的对象与此映射进行比较以获得相等性。

boolean

GregorianCalendar.equals​(Object obj)

将此 GregorianCalendar与指定的 Object 。

boolean

Hashtable.equals​(Object o)

根据Map界面中的定义，将指定的对象与此Map进行比较以相等。

boolean

IdentityHashMap.equals​(Object o)

将指定的对象与此映射进行比较以获得相等性。

boolean

List.equals​(Object o)

将指定的对象与此列表进行比较以获得相等性。

boolean

Locale.equals​(Object obj)

如果此区域设置等于另一个对象，则返回true。

boolean

Locale.LanguageRange.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

Map.Entry.equals​(Object o)

将指定的对象与此条目进行比较以获得相等性。

boolean

Map.equals​(Object o)

将指定的对象与此映射进行比较以获得相等性。

static boolean

Objects.equals​(Object a, Object b)

返回 true如果参数相等，彼此 false否则。

boolean

Optional.equals​(Object obj)

指示其他对象是否等于此 Optional 。

boolean

OptionalDouble.equals​(Object obj)

指示某个其他对象是否等于此 OptionalDouble 。

boolean

OptionalInt.equals​(Object obj)

指示其他对象是否等于此 OptionalInt 。

boolean

OptionalLong.equals​(Object obj)

指示某个其他对象是否等于此 OptionalLong 。

boolean

Properties.equals​(Object o)

boolean

PropertyPermission.equals​(Object obj)

检查两个PropertyPermission对象是否相等。

boolean

Set.equals​(Object o)

将指定的对象与此集合进行比较以实现相等。

boolean

SimpleTimeZone.equals​(Object obj)

比较两个 SimpleTimeZone对象的平等。

boolean

UUID.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

Vector.equals​(Object o)

将指定的对象与此向量进行比较以获得相等性。

static void

Arrays.fill​(Object[] a, int fromIndex, int toIndex, Object val)

将指定的对象引用分配给指定的对象数组的指定范围的每个元素。

static void

Arrays.fill​(Object[] a, Object val)

将指定的对象引用分配给指定的对象数组的每个元素。

Formatter

Formatter.format​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此对象的目标。

Formatter

Formatter.format​(Locale l, String format, Object... args)

使用指定的区域设置，格式字符串和参数将格式化的字符串写入此对象的目标。

static int

Collections.frequency​(Collection<?> c, Object o)

返回指定集合中与指定对象相等的元素数。

V

AbstractMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

abstract V

Dictionary.get​(Object key)

返回该字典中键映射到的值。

V

EnumMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

V

HashMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

V

Hashtable.get​(Object key)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

V

IdentityHashMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

V

LinkedHashMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

V

Map.get​(Object key)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

Object

Properties.get​(Object key)

V

TreeMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

V

WeakHashMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

V

HashMap.getOrDefault​(Object key, V defaultValue)

V

Hashtable.getOrDefault​(Object key, V defaultValue)

V

LinkedHashMap.getOrDefault​(Object key, V defaultValue)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。

default V

Map.getOrDefault​(Object key, V defaultValue)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。

Object

Properties.getOrDefault​(Object key, Object defaultValue)

static int

Objects.hash​(Object... values)

为输入值序列生成哈希码。

static int

Arrays.hashCode​(Object[] a)

根据指定数组的内容返回哈希码。

static int

Objects.hashCode​(Object o)

返回非的哈希码 null参数，0为 null参数。

int

AbstractList.indexOf​(Object o)

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

int

ArrayList.indexOf​(Object o)

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

int

LinkedList.indexOf​(Object o)

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

int

List.indexOf​(Object o)

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

int

Vector.indexOf​(Object o)

返回此向量中指定元素的第一次出现的索引，如果此向量不包含元素，则返回-1。

int

Vector.indexOf​(Object o, int index)

返回此向量中指定元素的第一次出现的索引，从 index向前搜索，如果未找到该元素，则返回-1。

static boolean

Objects.isNull​(Object obj)

返回 true如果提供的参考是 null ，否则返回 false 。

int

AbstractList.lastIndexOf​(Object o)

返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。

int

ArrayList.lastIndexOf​(Object o)

返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。

int

LinkedList.lastIndexOf​(Object o)

返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。

int

List.lastIndexOf​(Object o)

返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。

int

Vector.lastIndexOf​(Object o)

返回此向量中指定元素的最后一次出现的索引，如果此向量不包含元素，则返回-1。

int

Vector.lastIndexOf​(Object o, int index)

返回此向量中指定元素的最后一次出现的索引，从 index向后搜索，如果未找到该元素，则返回-1。

Object

Properties.merge​(Object key, Object value, BiFunction<? super Object,? super Object,?> remappingFunction)

static int

Arrays.mismatch​(Object[] a, int aFromIndex, int aToIndex, Object[] b, int bFromIndex, int bToIndex)

查找并返回指定范围内的两个 Object数组之间的第一个不匹配的相对索引，否则返回-1，如果没有发现不匹配。

static int

Arrays.mismatch​(Object[] a, Object[] b)

查找并返回两个 Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。

static <T> int

Arrays.mismatch​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex, Comparator<? super T> cmp)

查找并返回指定范围内两个 Object数组之间的第一个不匹配的相对索引，否则返回-1，如果未发现不匹配。

static <T> int

Arrays.mismatch​(T[] a, T[] b, Comparator<? super T> cmp)

查找并返回两个 Object数组之间的第一个不匹配的索引，否则返回-1，如果没有发现不匹配。

static boolean

Objects.nonNull​(Object obj)

返回 true如果提供的参考是非 null否则返回 false 。

void

Observable.notifyObservers​(Object arg)

已过时。

如果这个对象已经改变，如 hasChanged方法所示，然后通知所有的观察者，然后调用 clearChanged方法来指示该对象已经不再改变了。

static <E> List<E>

List.of​(E... elements)

返回包含任意数量元素的不可变列表。

static <E> Set<E>

Set.of​(E... elements)

返回一个包含任意数量元素的不可变集合。

static <T> void

Arrays.parallelPrefix​(T[] array, int fromIndex, int toIndex, BinaryOperator<T> op)

对于数组的给定子范围执行 Arrays.parallelPrefix(Object[], BinaryOperator) 。

static <T> void

Arrays.parallelPrefix​(T[] array, BinaryOperator<T> op)

使用提供的功能，并行地计算给定阵列的每个元素。

static <T> void

Arrays.parallelSetAll​(T[] array, IntFunction<? extends T> generator)

使用提供的生成函数来并行设置指定数组的所有元素来计算每个元素。

static <T> void

Arrays.parallelSort​(T[] a, int fromIndex, int toIndex, Comparator<? super T> cmp)

根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。

static <T> void

Arrays.parallelSort​(T[] a, Comparator<? super T> cmp)

根据指定的比较器引发的顺序对指定的对象数组进行排序。

Object

Properties.put​(Object key, Object value)

Object

Properties.putIfAbsent​(Object key, Object value)

boolean

AbstractCollection.remove​(Object o)

从该集合中删除指定元素的单个实例（如果存在）（可选操作）。

V

AbstractMap.remove​(Object key)

如果存在（从可选的操作），从该地图中删除一个键的映射。

boolean

ArrayDeque.remove​(Object o)

从此deque中删除指定元素的单个实例。

boolean

ArrayList.remove​(Object o)

从列表中删除指定元素的第一个出现（如果存在）。

boolean

Collection.remove​(Object o)

从该集合中删除指定元素的单个实例（如果存在）（可选操作）。

boolean

Deque.remove​(Object o)

从此deque中删除指定元素的第一个出现。

abstract V

Dictionary.remove​(Object key)

从该字典中删除 key （及其对应的 value ）。

V

EnumMap.remove​(Object key)

从该地图中删除此密钥的映射（如果存在）。

V

HashMap.remove​(Object key)

从该地图中删除指定键的映射（如果存在）。

boolean

HashMap.remove​(Object key, Object value)

boolean

HashSet.remove​(Object o)

如果存在，则从该集合中删除指定的元素。

V

Hashtable.remove​(Object key)

从此散列表中删除键（及其对应的值）。

boolean

Hashtable.remove​(Object key, Object value)

V

IdentityHashMap.remove​(Object key)

从该地图中删除此密钥的映射（如果存在）。

boolean

LinkedList.remove​(Object o)

从列表中删除指定元素的第一个出现（如果存在）。

boolean

List.remove​(Object o)

从列表中删除指定元素的第一个出现（如果存在）（可选操作）。

V

Map.remove​(Object key)

如果存在（从可选的操作），从该地图中删除一个键的映射。

default boolean

Map.remove​(Object key, Object value)

仅当指定的密钥当前映射到指定的值时删除该条目。

boolean

PriorityQueue.remove​(Object o)

从该队列中删除指定元素的单个实例（如果存在）。

Object

Properties.remove​(Object key)

boolean

Properties.remove​(Object key, Object value)

boolean

Set.remove​(Object o)

如果存在，则从该集合中删除指定的元素（可选操作）。

V

TreeMap.remove​(Object key)

从此TreeMap中删除此键的映射（如果存在）。

boolean

TreeSet.remove​(Object o)

如果存在，则从该集合中删除指定的元素。

boolean

Vector.remove​(Object o)

删除此向量中指定元素的第一个出现如果Vector不包含元素，则它不会更改。

V

WeakHashMap.remove​(Object key)

如果存在，则从该弱散列映射中删除密钥的映射。

boolean

Vector.removeElement​(Object obj)

从此向量中删除参数的第一个（最低索引）出现次数。

boolean

ArrayDeque.removeFirstOccurrence​(Object o)

删除此deque中指定元素的第一个出现（从头到尾遍历deque时）。

boolean

Deque.removeFirstOccurrence​(Object o)

从此deque中删除指定元素的第一个出现。

boolean

LinkedList.removeFirstOccurrence​(Object o)

删除此列表中指定元素的第一个出现（从头到尾遍历列表时）。

boolean

ArrayDeque.removeLastOccurrence​(Object o)

删除此deque中指定元素的最后一次（从头到尾遍历deque时）。

boolean

Deque.removeLastOccurrence​(Object o)

从此deque中删除指定元素的最后一次出现。

boolean

LinkedList.removeLastOccurrence​(Object o)

删除此列表中指定元素的最后一次出现（从头到尾遍历列表时）。

Object

Properties.replace​(Object key, Object value)

boolean

Properties.replace​(Object key, Object oldValue, Object newValue)

int

Stack.search​(Object o)

返回一个对象在此堆栈上的基于1的位置。

static <T> void

Arrays.setAll​(T[] array, IntFunction<? extends T> generator)

使用提供的生成函数来计算每个元素，设置指定数组的所有元素。

static void

Arrays.sort​(Object[] a)

根据其元素的natural ordering按照升序排列指定的对象数组。

static void

Arrays.sort​(Object[] a, int fromIndex, int toIndex)

根据其元素的natural ordering按照升序排列指定数组对象的指定范围。

static <T> void

Arrays.sort​(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)

根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。

static <T> void

Arrays.sort​(T[] a, Comparator<? super T> c)

根据指定的比较器引发的顺序对指定的对象数组进行排序。

static <T> Spliterator<T>

Arrays.spliterator​(T[] array)

返回覆盖所有指定数组的Spliterator 。

static <T> Spliterator<T>

Arrays.spliterator​(T[] array, int startInclusive, int endExclusive)

返回覆盖指定数组的指定范围的Spliterator 。

static <T> Spliterator<T>

Spliterators.spliterator​(Object[] array, int additionalCharacteristics)

创建一个 Spliterator ，使用定制的一组拼接器特征来覆盖给定阵列的元素。

static <T> Spliterator<T>

Spliterators.spliterator​(Object[] array, int fromIndex, int toIndex, int additionalCharacteristics)

创建一个 Spliterator ，使用定制的一组拼接器特征来覆盖给定阵列的一系列元素。

static <T> Stream<T>

Arrays.stream​(T[] array)

返回指定数组作为源的顺序Stream 。

static <T> Stream<T>

Arrays.stream​(T[] array, int startInclusive, int endExclusive)

返回指定数组的指定范围作为源的顺序Stream 。

<T> T[]

AbstractCollection.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

ArrayDeque.toArray​(T[] a)

以正确的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

ArrayList.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

Collection.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedList.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

List.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityQueue.toArray​(T[] a)

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

Set.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

Vector.toArray​(T[] a)

以正确的顺序返回一个包含此Vector中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

static String

Arrays.toString​(Object[] a)

返回指定数组的内容的字符串表示形式。

static String

Objects.toString​(Object o)

返回一个非 null参数调用 toString的结果， toString对于 null参数，则 "null" null 。

static String

Objects.toString​(Object o, String nullDefault)

如果第一个参数不为 null ，则返回第一个参数的调用 toString的结果，否则返回第二个参数。

void

Observer.update​(Observable o, Object arg)

已过时。

每当观察到的对象发生变化时，都会调用此方法。

Method parameters in java.util with type arguments of type Object

Modifier and Type

方法

描述

Object

Properties.compute​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

Object

Properties.compute​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

Object

Properties.computeIfAbsent​(Object key, Function<? super Object,?> mappingFunction)

Object

Properties.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

Object

Properties.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

void

Properties.forEach​(BiConsumer<? super Object,? super Object> action)

void

Properties.forEach​(BiConsumer<? super Object,? super Object> action)

Object

Properties.merge​(Object key, Object value, BiFunction<? super Object,? super Object,?> remappingFunction)

Object

Properties.merge​(Object key, Object value, BiFunction<? super Object,? super Object,?> remappingFunction)

void

Properties.replaceAll​(BiFunction<? super Object,? super Object,?> function)

void

Properties.replaceAll​(BiFunction<? super Object,? super Object,?> function)

Constructors in java.util with parameters of type Object

Constructor

描述

EventObject​(Object source)

构建一个典型的事件。

Uses of Object in java.util.concurrent

Subclasses of Object in java.util.concurrent

Modifier and Type

Class

描述

class

AbstractExecutorService

提供ExecutorService执行方法的默认实现。

class

ArrayBlockingQueue<E>

有限的blocking queue由数组支持。

class

BrokenBarrierException

当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。

class

CancellationException

异常表示由于任务被取消，无法检索生产任务的结果（如FutureTask） 。

class

CompletableFuture<T>

A Future可以明确完成（设置其值和状态），并可用作CompletionStage ，支持在完成后触发的依赖功能和操作。

class

CompletionException

在完成结果或任务的过程中遇到错误或其他异常时抛出异常。

class

ConcurrentHashMap<K,V>

支持检索的完全并发性和更新的高预期并发性的哈希表。

static class

ConcurrentHashMap.KeySetView<K,V>

ConcurrentHashMap视图为Set的密钥，其中可以通过映射到公共值来选择添加。

class

ConcurrentLinkedDeque<E>

基于链接节点的无界并发deque 。

class

ConcurrentLinkedQueue<E>

基于链接节点的无界线程安全queue 。

class

ConcurrentSkipListMap<K,V>

可扩展的并发ConcurrentNavigableMap实现。

class

ConcurrentSkipListSet<E>

可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。

class

CopyOnWriteArrayList<E>

的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。

class

CopyOnWriteArraySet<E>

A Set在其所有操作中使用内部CopyOnWriteArrayList 。

class

CountDownLatch

允许一个或多个线程等待直到在其他线程中执行的一组操作完成的同步辅助。

class

CountedCompleter<T>

A ForkJoinTask ，其触发时执行完成操作，并且没有剩余的待处理操作。

class

CyclicBarrier

允许一组线程全部等待彼此达到共同屏障点的同步辅助。

class

DelayQueue<E extends Delayed>

一个无限制的blocking queue的Delayed元素，其中元素只能在其延迟到期时才被使用。

class

Exchanger<V>

线程可以在成对内配对和交换元素的同步点。

class

ExecutionException

尝试检索通过抛出异常中止的任务的结果时抛出的异常。

class

ExecutorCompletionService<V>

A CompletionService使用提供的Executor执行任务。

class

Executors

工厂和工具方法Executor ， ExecutorService ， ScheduledExecutorService ， ThreadFactory和Callable此包中定义的类。

class

Flow

用于建立流量控制组件的相互关联的接口和静态方法，其中Publishers产生一个或多个Subscribers消耗的项目，每个由Subscription管理。

class

ForkJoinPool

一个ExecutorService运行ForkJoinTask s。

class

ForkJoinTask<V>

在ForkJoinPool内运行的任务的抽象基类。

class

ForkJoinWorkerThread

一个由ForkJoinPool管理的线程，执行ForkJoinTask 。

class

FutureTask<V>

可取消的异步计算。

class

LinkedBlockingDeque<E>

基于链接节点的可选限定的blocking deque 。

class

LinkedBlockingQueue<E>

基于链接节点的可选限定的blocking queue 。

class

LinkedTransferQueue<E>

基于链接节点的无界TransferQueue 。

class

Phaser

一个可重复使用的同步屏障，功能类似于CyclicBarrier和CountDownLatch，但支持更灵活的使用。

class

PriorityBlockingQueue<E>

无限blocking queue使用与类别PriorityQueue相同的排序规则，并提供阻止检索操作。

class

RecursiveAction

递归结果ForkJoinTask 。

class

RecursiveTask<V>

递归结果ForkJoinTask 。

class

RejectedExecutionException

当一个任务不能接受执行时，由一个Executor抛出的异常。

class

ScheduledThreadPoolExecutor

A ThreadPoolExecutor可以额外地调度命令在给定的延迟之后运行，或者周期性地执行。

class

Semaphore

一个计数信号量。

class

SubmissionPublisher<T>

A Flow.Publisher异常地将提交的（非空）项目发送给当前订户，直到关闭。

class

SynchronousQueue<E>

A blocking queue其中每个插入操作必须等待另一个线程进行相应的删除操作，反之亦然。

class

ThreadLocalRandom

与当前线程隔离的随机数生成器。

class

ThreadPoolExecutor

一个ExecutorService ，使用可能的几个合并的线程执行每个提交的任务，通常使用Executors工厂方法配置。

static class

ThreadPoolExecutor.AbortPolicy

被拒绝的任务的处理程序，抛出一个 RejectedExecutionException 。

static class

ThreadPoolExecutor.CallerRunsPolicy

被拒绝的任务的处理程序直接在 execute方法的调用线程中运行被拒绝的任务，除非执行程序已被关闭，在这种情况下，任务被丢弃。

static class

ThreadPoolExecutor.DiscardOldestPolicy

被拒绝的任务的处理程序丢弃最旧的未处理请求，然后重试 execute ，除非执行程序关闭，否则将丢弃该任务。

static class

ThreadPoolExecutor.DiscardPolicy

被拒绝的任务的处理程序静默地丢弃被拒绝的任务。

class

TimeoutException

阻塞操作超时时抛出异常。

Methods in java.util.concurrent that return Object

Modifier and Type

方法

描述

Object

CopyOnWriteArrayList.clone​()

返回此列表的浅层副本。

Object[]

ArrayBlockingQueue.toArray​()

以适当的顺序返回一个包含此队列中所有元素的数组。

<T> T[]

ArrayBlockingQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

ConcurrentLinkedDeque.toArray​()

以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。

<T> T[]

ConcurrentLinkedDeque.toArray​(T[] a)

以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

ConcurrentLinkedQueue.toArray​()

以适当的顺序返回一个包含此队列中所有元素的数组。

<T> T[]

ConcurrentLinkedQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

CopyOnWriteArrayList.toArray​()

以正确的顺序（从第一个到最后一个元素）返回一个包含此列表中所有元素的数组。

<T> T[]

CopyOnWriteArrayList.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

CopyOnWriteArraySet.toArray​()

返回一个包含此集合中所有元素的数组。

<T> T[]

CopyOnWriteArraySet.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

DelayQueue.toArray​()

返回一个包含此队列中所有元素的数组。

<T> T[]

DelayQueue.toArray​(T[] a)

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

LinkedBlockingDeque.toArray​()

以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。

<T> T[]

LinkedBlockingDeque.toArray​(T[] a)

以适当的顺序返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

LinkedBlockingQueue.toArray​()

以适当的顺序返回一个包含此队列中所有元素的数组。

<T> T[]

LinkedBlockingQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

LinkedTransferQueue.toArray​()

以适当的顺序返回一个包含此队列中所有元素的数组。

<T> T[]

LinkedTransferQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

PriorityBlockingQueue.toArray​()

返回一个包含此队列中所有元素的数组。

<T> T[]

PriorityBlockingQueue.toArray​(T[] a)

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

Object[]

SynchronousQueue.toArray​()

返回零长度数组。

<T> T[]

SynchronousQueue.toArray​(T[] a)

将指定数组的第零个元素设置为 null （如果数组具有非零长度）并返回。

Methods in java.util.concurrent that return types with arguments of type Object

Modifier and Type

方法

描述

static CompletableFuture<Object>

CompletableFuture.anyOf​(CompletableFuture<?>... cfs)

返回一个新的CompletableFuture，当任何一个给定的CompletableFutures完成时，完成相同的结果。

static Callable<Object>

Executors.callable​(Runnable task)

返回一个Callable对象，当被调用时，它运行给定的任务并返回null 。

static Callable<Object>

Executors.callable​(PrivilegedAction<?> action)

返回一个Callable对象，当被调用时，它运行给定的特权动作并返回其结果。

static Callable<Object>

Executors.callable​(PrivilegedExceptionAction<?> action)

返回一个Callable对象，当被调用时，它运行给定的特权异常操作并返回其结果。

Methods in java.util.concurrent with parameters of type Object

Modifier and Type

方法

描述

boolean

ArrayBlockingQueue.contains​(Object o)

如果此队列包含指定的元素，则返回 true 。

boolean

BlockingDeque.contains​(Object o)

如果此deque包含指定的元素，则返回 true 。

boolean

BlockingQueue.contains​(Object o)

如果此队列包含指定的元素，则返回 true 。

boolean

ConcurrentHashMap.contains​(Object value)

测试一些键映射到此表中的指定值。

boolean

ConcurrentHashMap.KeySetView.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

ConcurrentLinkedDeque.contains​(Object o)

如果此deque包含指定的元素，则返回 true 。

boolean

ConcurrentLinkedQueue.contains​(Object o)

如果此队列包含指定的元素，则返回 true 。

boolean

ConcurrentSkipListSet.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

CopyOnWriteArrayList.contains​(Object o)

如果此列表包含指定的元素，则返回 true 。

boolean

CopyOnWriteArraySet.contains​(Object o)

如果此集合包含指定的元素，则返回 true 。

boolean

LinkedBlockingDeque.contains​(Object o)

如果此deque包含指定的元素，则返回 true 。

boolean

LinkedBlockingQueue.contains​(Object o)

如果此队列包含指定的元素，则返回 true 。

boolean

LinkedTransferQueue.contains​(Object o)

如果此队列包含指定的元素，则返回 true 。

boolean

PriorityBlockingQueue.contains​(Object o)

如果此队列包含指定的元素，则返回 true 。

boolean

SynchronousQueue.contains​(Object o)

始终返回 false 。

boolean

ConcurrentHashMap.containsKey​(Object key)

测试此表中的指定对象是否为键。

boolean

ConcurrentSkipListMap.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

ConcurrentHashMap.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

boolean

ConcurrentSkipListMap.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

boolean

ConcurrentHashMap.equals​(Object o)

将指定的对象与此映射进行比较以获得相等性。

boolean

ConcurrentHashMap.KeySetView.equals​(Object o)

boolean

ConcurrentSkipListMap.equals​(Object o)

将指定的对象与此映射进行比较以获得相等性。

boolean

ConcurrentSkipListSet.equals​(Object o)

将指定的对象与此集合进行比较以实现相等。

boolean

CopyOnWriteArrayList.equals​(Object o)

将指定的对象与此列表进行比较以获得相等性。

boolean

CopyOnWriteArraySet.equals​(Object o)

将指定的对象与此集合进行比较以实现相等。

V

ConcurrentHashMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。

V

ConcurrentSkipListMap.get​(Object key)

返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。

V

ConcurrentHashMap.getOrDefault​(Object key, V defaultValue)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回给定的默认值。

default V

ConcurrentMap.getOrDefault​(Object key, V defaultValue)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。

V

ConcurrentSkipListMap.getOrDefault​(Object key, V defaultValue)

返回指定键映射到的值或给定的defaultValue，如果该映射不包含该键的映射。

int

CopyOnWriteArrayList.indexOf​(Object o)

返回此列表中指定元素的第一次出现的索引，如果此列表不包含元素，则返回-1。

int

CopyOnWriteArrayList.lastIndexOf​(Object o)

返回此列表中指定元素的最后一次出现的索引，如果此列表不包含元素，则返回-1。

boolean

ArrayBlockingQueue.remove​(Object o)

从该队列中删除指定元素的单个实例（如果存在）。

boolean

BlockingDeque.remove​(Object o)

从此deque中删除指定元素的第一个出现。

boolean

BlockingQueue.remove​(Object o)

从该队列中删除指定元素的单个实例（如果存在）。

boolean

ConcurrentHashMap.KeySetView.remove​(Object o)

从该地图视图中删除键，方法是从支持地图中删除该键（及其对应的值）。

V

ConcurrentHashMap.remove​(Object key)

从该地图中删除键（及其对应的值）。

boolean

ConcurrentHashMap.remove​(Object key, Object value)

仅当当前映射到给定值时才删除密钥的条目。

boolean

ConcurrentLinkedDeque.remove​(Object o)

从此deque中删除指定元素的第一个出现。

boolean

ConcurrentLinkedQueue.remove​(Object o)

从该队列中删除指定元素的单个实例（如果存在）。

boolean

ConcurrentMap.remove​(Object key, Object value)

仅当当前映射到给定值时才删除密钥的条目。

V

ConcurrentSkipListMap.remove​(Object key)

从该地图中删除指定键的映射（如果存在）。

boolean

ConcurrentSkipListMap.remove​(Object key, Object value)

仅当当前映射到给定值时才删除密钥的条目。

boolean

ConcurrentSkipListSet.remove​(Object o)

如果存在，则从该集合中删除指定的元素。

boolean

CopyOnWriteArrayList.remove​(Object o)

从列表中删除指定元素的第一个出现（如果存在）。

boolean

CopyOnWriteArraySet.remove​(Object o)

如果存在，则从该集合中删除指定的元素。

boolean

DelayQueue.remove​(Object o)

从该队列中移除指定元素的单个实例（如果存在），无论其是否已过期。

boolean

LinkedBlockingDeque.remove​(Object o)

从此deque中删除指定元素的第一个出现。

boolean

LinkedBlockingQueue.remove​(Object o)

从该队列中删除指定元素的单个实例（如果存在）。

boolean

LinkedTransferQueue.remove​(Object o)

从该队列中删除指定元素的单个实例（如果存在）。

boolean

PriorityBlockingQueue.remove​(Object o)

从该队列中删除指定元素的单个实例（如果存在）。

boolean

SynchronousQueue.remove​(Object o)

始终返回 false 。

boolean

BlockingDeque.removeFirstOccurrence​(Object o)

从此deque中删除指定元素的第一个出现。

boolean

ConcurrentLinkedDeque.removeFirstOccurrence​(Object o)

从此deque中删除指定元素的第一个出现。

boolean

LinkedBlockingDeque.removeFirstOccurrence​(Object o)

boolean

BlockingDeque.removeLastOccurrence​(Object o)

从此deque中删除指定元素的最后一次出现。

boolean

ConcurrentLinkedDeque.removeLastOccurrence​(Object o)

从此deque中删除指定元素的最后一次出现。

boolean

LinkedBlockingDeque.removeLastOccurrence​(Object o)

void

TimeUnit.timedWait​(Object obj, long timeout)

使用此时间单位执行定时 Object.wait 。

<T> T[]

ArrayBlockingQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

ConcurrentLinkedDeque.toArray​(T[] a)

以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

ConcurrentLinkedQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArrayList.toArray​(T[] a)

以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArraySet.toArray​(T[] a)

返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

DelayQueue.toArray​(T[] a)

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedBlockingDeque.toArray​(T[] a)

以适当的顺序返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedBlockingQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedTransferQueue.toArray​(T[] a)

以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityBlockingQueue.toArray​(T[] a)

返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

<T> T[]

SynchronousQueue.toArray​(T[] a)

将指定数组的第零个元素设置为 null （如果数组具有非零长度）并返回。

Constructors in java.util.concurrent with parameters of type Object

Constructor

描述

CopyOnWriteArrayList​(E[] toCopyIn)

创建一个包含给定数组的副本的列表。

Uses of Object in java.util.concurrent.atomic

Subclasses of Object in java.util.concurrent.atomic

Modifier and Type

Class

描述

class

AtomicBoolean

可能原子更新的值为 boolean 。

class

AtomicInteger

可能原子更新的值为 int 。

class

AtomicIntegerArray

一个 int数组，其中元素可以原子更新。

class

AtomicIntegerFieldUpdater<T>

基于反射的实用程序，可以对指定类的指定的 volatile int字段进行原子更新。

class

AtomicLong

A long可能原子更新的值。

class

AtomicLongArray

A long可以原子更新元素的数组。

class

AtomicLongFieldUpdater<T>

基于反射的实用程序，可以对指定类的指定的 volatile long字段进行原子更新。

class

AtomicMarkableReference<V>

一个 AtomicMarkableReference维护对象引用以及可以原子更新的标记位。

class

AtomicReference<V>

可以原子更新的对象引用。

class

AtomicReferenceArray<E>

可以以原子方式更新元素的对象引用数组。

class

AtomicReferenceFieldUpdater<T,V>

基于反射的实用程序，可以对指定类的指定的 volatile参考字段进行原子更新。

class

AtomicStampedReference<V>

一个 AtomicStampedReference维护对象引用以及可以原子更新的整数“印记”。

class

DoubleAccumulator

一个或多个变量，它们一起保持运行 double使用所提供的功能更新值。

class

DoubleAdder

一个或多个变量一起保持初始为零 double总和。

class

LongAccumulator

一个或多个变量，它们一起保持运行 long使用所提供的功能更新值。

class

LongAdder

一个或多个变量一起保持初始为零 long总和。

Constructors in java.util.concurrent.atomic with parameters of type Object

Constructor

描述

AtomicReferenceArray​(E[] array)

创建一个与原始数组相同的长度和所有元素的AtomicReferenceArray。

Uses of Object in java.util.concurrent.locks

Subclasses of Object in java.util.concurrent.locks

Modifier and Type

Class

描述

class

AbstractOwnableSynchronizer

可以由线程专有的同步器。

class

AbstractQueuedLongSynchronizer

的一个版本AbstractQueuedSynchronizer ，其中同步状态保持为long 。

class

AbstractQueuedLongSynchronizer.ConditionObject

AbstractQueuedLongSynchronizer作为Lock实施基础的条件实施。

class

AbstractQueuedSynchronizer

提供一个框架，用于实现依赖先进先出（FIFO）等待队列的阻塞锁和相关同步器（信号量，事件等）。

class

AbstractQueuedSynchronizer.ConditionObject

条件实施AbstractQueuedSynchronizer作为Lock实施的基础。

class

LockSupport

用于创建锁和其他同步类的基本线程阻塞原语。

class

ReentrantLock

具有与使用synchronized方法和语句访问的隐式监视锁相同的基本行为和语义的可重入互斥Lock ，但具有扩展功能。

class

ReentrantReadWriteLock

ReadWriteLock支持类似语义ReentrantLock的实现 。

static class

ReentrantReadWriteLock.ReadLock

该锁由方法 ReentrantReadWriteLock.readLock()返回。

static class

ReentrantReadWriteLock.WriteLock

该锁由方法 ReentrantReadWriteLock.writeLock()返回。

class

StampedLock

一种基于能力的锁，具有三种模式用于控制读/写访问。

Methods in java.util.concurrent.locks that return Object

Modifier and Type

方法

描述

static Object

LockSupport.getBlocker​(Thread t)

返回提供给最近调用尚未解除阻塞的park方法的阻止程序对象，如果不阻止则返回null。

Methods in java.util.concurrent.locks with parameters of type Object

Modifier and Type

方法

描述

static void

LockSupport.park​(Object blocker)

禁止当前线程进行线程调度，除非许可证可用。

static void

LockSupport.parkNanos​(Object blocker, long nanos)

禁用当前线程进行线程调度，直到指定的等待时间，除非许可证可用。

static void

LockSupport.parkUntil​(Object blocker, long deadline)

禁用当前线程进行线程调度，直到指定的截止日期，除非许可证可用。

Uses of Object in java.util.function

Methods in java.util.function with parameters of type Object

Modifier and Type

方法

描述

static <T> Predicate<T>

Predicate.isEqual​(Object targetRef)

返回一个谓词，根据 Objects.equals(Object, Object)测试两个参数是否相等。

Uses of Object in java.util.jar

Subclasses of Object in java.util.jar

Modifier and Type

Class

描述

class

Attributes

属性类将Manifest属性名称映射到关联的字符串值。

static class

Attributes.Name

Attributes.Name类表示存储在此Map中的属性名称。

class

JarEntry

此类用于表示JAR文件条目。

class

JarException

表示在读取或写入JAR文件时发生了某种错误。

class

JarFile

JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。

class

JarInputStream

JarInputStream类用于从任何输入流读取JAR文件的内容。

class

JarOutputStream

JarOutputStream类用于将JAR文件的内容写入任何输出流。

class

Manifest

Manifest类用于维护清单条目名称及其相关属性。

class

Pack200

从Pack200格式的压缩流转换JAR文件。

Fields in java.util.jar with type parameters of type Object

Modifier and Type

Field

描述

protected Map<Object,Object>

Attributes.map

属性名称 - 值映射。

protected Map<Object,Object>

Attributes.map

属性名称 - 值映射。

Methods in java.util.jar that return Object

Modifier and Type

方法

描述

Object

Attributes.clone​()

返回属性的副本，实现如下：

Object

Manifest.clone​()

返回此清单的浅层副本。

Object

Attributes.get​(Object name)

返回指定属性名的值，如果未找到属性名，则返回null。

Object

Attributes.put​(Object name, Object value)

将指定的值与此Map中的指定属性名称（键）相关联。

Object

Attributes.remove​(Object name)

从此Map中删除具有指定名称（键）的属性。

Methods in java.util.jar that return types with arguments of type Object

Modifier and Type

方法

描述

Set<Map.Entry<Object,Object>>

Attributes.entrySet​()

返回此Map中包含的属性名称 - 值映射的集合视图。

Set<Map.Entry<Object,Object>>

Attributes.entrySet​()

返回此Map中包含的属性名称 - 值映射的集合视图。

Set<Object>

Attributes.keySet​()

返回此Map中包含的属性名称（键）的Set视图。

Collection<Object>

Attributes.values​()

返回此Map中包含的属性值的集合视图。

Methods in java.util.jar with parameters of type Object

Modifier and Type

方法

描述

boolean

Attributes.containsKey​(Object name)

如果此Map包含指定的属性名称（key），则返回true。

boolean

Attributes.containsValue​(Object value)

如果此Map将一个或多个属性名称（键）映射到指定的值，则返回true。

boolean

Attributes.equals​(Object o)

将指定的Attributes对象与此Map进行比较以获得相等性。

boolean

Attributes.Name.equals​(Object o)

将此属性名称与其他名称进行比较以获得相等性

boolean

Manifest.equals​(Object o)

如果指定的对象也是清单并具有相同的主要属性和条目，则返回true。

Object

Attributes.get​(Object name)

返回指定属性名的值，如果未找到属性名，则返回null。

Object

Attributes.put​(Object name, Object value)

将指定的值与此Map中的指定属性名称（键）相关联。

Object

Attributes.remove​(Object name)

从此Map中删除具有指定名称（键）的属性。

Uses of Object in java.util.logging

Subclasses of Object in java.util.logging

Modifier and Type

Class

描述

class

ConsoleHandler

这个 Handler将日志记录发布到 System.err 。

class

ErrorManager

可以将ErrorManager对象附加到处理程序，以处理在记录期间在处理程序中发生的任何错误。

class

FileHandler

简单文件记录 Handler 。

class

Formatter

格式化程序提供对LogRecords进行格式化的支持。

class

Handler

一个 Handler对象从需要日志消息 Logger和出口他们。

class

Level

Level类定义了一组可用于控制日志输出的标准日志记录级别。

class

Logger

Logger对象用于记录特定系统或应用程序组件的消息。

class

LoggingPermission

当SecurityManager运行的代码调用其中一个日志控件方法（如Logger.setLevel）时，SecurityManager将检查该权限。

class

LogManager

有一个全局LogManager对象用于维护关于日志记录器和日志服务的一组共享状态。

class

LogRecord

LogRecord对象用于在日志框架和各个日志处理程序之间传递日志请求。

class

MemoryHandler

Handler缓冲在内存中的循环缓冲区中的请求。

class

SimpleFormatter

以人类可读格式打印 LogRecord的简要摘要。

class

SocketHandler

简单网络日志记录 Handler 。

class

StreamHandler

基于流的日志记录 Handler 。

class

XMLFormatter

将LogRecord格式化为标准XML格式。

Methods in java.util.logging that return Object

Modifier and Type

方法

描述

Object[]

LogRecord.getParameters​()

获取日志消息的参数。

Methods in java.util.logging with parameters of type Object

Modifier and Type

方法

描述

void

Logger.entering​(String sourceClass, String sourceMethod, Object param1)

使用一个参数记录方法条目。

void

Logger.entering​(String sourceClass, String sourceMethod, Object[] params)

使用参数数组记录方法条目。

boolean

Level.equals​(Object ox)

比较两个对象的值相等。

void

Logger.exiting​(String sourceClass, String sourceMethod, Object result)

使用结果对象记录方法返回。

void

Logger.log​(Level level, String msg, Object param1)

使用一个对象参数记录消息。

void

Logger.log​(Level level, String msg, Object[] params)

用一个对象参数数组记录消息。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Object param1)

使用单个对象参数记录消息，指定源类和方法到日志消息。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)

使用对象参数数组记录消息，指定源类和方法。

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)

已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)

已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Object... params)

使用可选的消息参数列表记录消息，指定源类，方法和资源包。

void

Logger.logrb​(Level level, ResourceBundle bundle, String msg, Object... params)

使用可选的消息参数列表记录消息，指定源类，方法和资源包。

void

LogRecord.setParameters​(Object[] parameters)

将参数设置为日志消息。

Uses of Object in java.util.prefs

Subclasses of Object in java.util.prefs

Modifier and Type

Class

描述

class

AbstractPreferences

这个类提供了一个Preferences类的骨架实现，大大缓解了实现它的任务。

class

BackingStoreException

抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。

class

InvalidPreferencesFormatException

被抛出以表示操作无法完成，因为输入符合Preferences规范的偏好集合的相应XML文档类型。

class

NodeChangeEvent

Preferences节点发出的一个事件，指示已添加或删除该节点的子节点。

class

PreferenceChangeEvent

由 Preferences节点发出的一个事件，表示已添加，删除或已更改其值的首选项。

class

Preferences

优先级数据的分层收集中的节点。

Fields in java.util.prefs declared as Object

Modifier and Type

Field

描述

protected Object

AbstractPreferences.lock

监视器用于锁定此节点的对象。

Uses of Object in java.util.regex

Subclasses of Object in java.util.regex

Modifier and Type

Class

描述

class

Matcher

通过解释Pattern对character sequence执行匹配操作的引擎。

class

Pattern

正则表达式的编译表示。

class

PatternSyntaxException

抛出未经检查的异常，以指示正则表达式模式中的语法错误。

Uses of Object in java.util.spi

Subclasses of Object in java.util.spi

Modifier and Type

Class

描述

class

AbstractResourceBundleProvider

AbstractResourceBundleProvider是一个抽象类，为ResourceBundleProvider的提供程序实现类提供了基本支持。

class

CalendarDataProvider

服务提供商的抽象类，提供依赖于区域设置的Calendar参数。

class

CalendarNameProvider

提供 Calendar字段值的本地化字符串表示（显示名称）的服务提供者的抽象类。

class

CurrencyNameProvider

为Currency类提供本地化货币符号和显示名称的服务提供商的抽象类。

class

LocaleNameProvider

为Locale类提供本地化名称的服务提供商的抽象类。

class

LocaleServiceProvider

这是所有区域设置敏感的服务提供商接口（SPI）的超类。

class

TimeZoneNameProvider

为TimeZone类提供本地化时区名称的服务提供商的抽象类。

Uses of Object in java.util.stream

Subclasses of Object in java.util.stream

Modifier and Type

Class

描述

class

Collectors

实现各种有用的还原操作的Collector ，例如将元素累积到集合中，根据各种标准汇总元素等。

class

StreamSupport

用于创建和操纵流的低级实用程序方法。

Methods in java.util.stream that return Object

Modifier and Type

方法

描述

Object[]

Stream.toArray​()

返回一个包含此流的元素的数组。

<A> A[]

Stream.toArray​(IntFunction<A[]> generator)

使用提供的 generator函数返回一个包含此流的元素的数组，以分配返回的数组，以及分区执行或调整大小可能需要的任何其他数组。

Methods in java.util.stream with parameters of type Object

Modifier and Type

方法

描述

static <T> Stream<T>

Stream.of​(T... values)

返回其元素是指定值的顺序排序流。

Uses of Object in java.util.zip

Subclasses of Object in java.util.zip

Modifier and Type

Class

描述

class

Adler32

可用于计算数据流的Adler-32校验和的类。

class

CheckedInputStream

也保持正在读取的数据的校验和的输入流。

class

CheckedOutputStream

一个输出流，它还维护正在写入的数据的校验和。

class

CRC32

可用于计算数据流的CRC-32的类。

class

CRC32C

可用于计算数据流的CRC-32C的类。

class

DataFormatException

发出数据格式错误的信号。

class

Deflater

该类支持通用压缩使用流行的ZLIB压缩库。

class

DeflaterInputStream

实现用于压缩“放气”压缩格式的数据的输入流过滤器。

class

DeflaterOutputStream

该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。

class

GZIPInputStream

该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。

class

GZIPOutputStream

该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。

class

Inflater

此类提供对使用流行的ZLIB压缩库的通用解压缩的支持。

class

InflaterInputStream

该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。

class

InflaterOutputStream

实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。

class

ZipEntry

此类用于表示ZIP文件条目。

class

ZipError

表示发生了不可恢复的错误。

class

ZipException

表示发生了某种类型的Zip异常。

class

ZipFile

此类用于从zip文件读取条目。

class

ZipInputStream

该类实现了以ZIP文件格式读取文件的输入流过滤器。

class

ZipOutputStream

该类实现了以ZIP文件格式写入文件的输出流过滤器。

Methods in java.util.zip that return Object

Modifier and Type

方法

描述

Object

ZipEntry.clone​()

返回此条目的副本。

Uses of Object in javafx.animation

Subclasses of Object in javafx.animation

Modifier and Type

Class

描述

class

Animation

Animation提供了JavaFX运行时使用的所有动画的核心功能。

class

AnimationTimer

类 AnimationTimer允许创建一个定时器，它在每个帧处于活动状态时被调用。

class

FadeTransition

这个 Transition创建了一个跨越其 duration的褪色效果动画。

class

FillTransition

这个 Transition创建一个动画，可以改变 duration上的形状填充。

class

Interpolator

抽象类定义了几个 interpolate方法，用于计算内插值。

class

KeyFrame

在指定的时间点定义一组沿Timeline内插的变量的目标值 。

class

KeyValue

定义要在动画中的特定间隔内插的键值。

class

ParallelTransition

这Transition剧目Animations并行。

class

PathTransition

这个 Transition创建了一个跨越其 PathTransition.duration的路径动画。

class

PauseTransition

这个 Transition在其 PauseTransition.duration的末尾执行一个 Animation.onFinished 。

class

RotateTransition

此 Transition创建一个旋转动画，涵盖其 duration 。

class

ScaleTransition

这个 Transition创建了一个尺度动画，涵盖其 ScaleTransition.duration 。

class

SequentialTransition

这Transition剧目Animations顺序排列。

class

StrokeTransition

这个 Transition创建一个动画，可以改变 duration中的形状的笔触颜色。

class

Timeline

A Timeline可以用于定义任何WritableValue的自由格式动画，例如，全部为JavaFX Properties 。

class

Transition

一个抽象类，其中包含所有基于Transition的动画所需的基本功能，如PathTransition和RotateTransition 。

class

TranslateTransition

这个 Transition创建一个移动/翻译动画，跨越其 TranslateTransition.duration 。

Methods in javafx.animation that return Object

Modifier and Type

方法

描述

Object

KeyValue.getEndValue​()

返回此 KeyValue的结束值

Object

Interpolator.interpolate​(Object startValue, Object endValue, double fraction)

这个方法有两个 Objects与沿 fraction之间 0.0和 1.0并返回插补值。

Methods in javafx.animation with parameters of type Object

Modifier and Type

方法

描述

boolean

KeyFrame.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

KeyValue.equals​(Object obj)

指示一些其他对象是否等于此。

Object

Interpolator.interpolate​(Object startValue, Object endValue, double fraction)

这个方法有两个 Objects与沿 fraction之间 0.0和 1.0并返回插补值。

Uses of Object in javafx.application

Subclasses of Object in javafx.application

Modifier and Type

Class

描述

class

Application

JavaFX应用程序扩展的应用程序类。

static class

Application.Parameters

封装一组应用程序的参数。

class

HostServices

此类为应用程序提供HostServices。

class

Platform

应用平台支持类。

class

Preloader

扩展定义JavaFX应用程序的可选预加载器的类。

static class

Preloader.ErrorNotification

报告错误的预加载程序通知。

static class

Preloader.ProgressNotification

报告进度的预加载程序通知。

static class

Preloader.StateChangeNotification

发出申明状态更改的通知。

Methods in javafx.application that return Object

Modifier and Type

方法

描述

static Object

Platform.enterNestedEventLoop​(Object key)

输入嵌套事件循环并阻塞，直到相应的exitNestedEventLoop调用被创建为止。

Methods in javafx.application with parameters of type Object

Modifier and Type

方法

描述

static Object

Platform.enterNestedEventLoop​(Object key)

输入嵌套事件循环并阻塞，直到相应的exitNestedEventLoop调用被创建为止。

static void

Platform.exitNestedEventLoop​(Object key, Object rval)

退出一个嵌套事件循环并解除对应的enterNestedEventLoop的调用者的阻塞。

Uses of Object in javafx.beans

Subclasses of Object in javafx.beans

Modifier and Type

Class

描述

class

WeakInvalidationListener

A WeakInvalidationListener可以使用，如果一个Observable应该只保留一个弱的引用侦听器。

Uses of Object in javafx.beans.binding

Subclasses of Object in javafx.beans.binding

Modifier and Type

Class

描述

class

Bindings

绑定是一个帮助类，具有很多实用功能来创建简单的绑定。

class

BooleanBinding

基类提供实现boolean的boolean所需的大部分功能。

class

BooleanExpression

BooleanExpression是一个ObservableBooleanValue，另外还有一个方便的方法来生成流畅的绑定。

class

DoubleBinding

提供实现double的double所需的大部分功能的基类。

class

DoubleExpression

DoubleExpression是一个ObservableDoubleValue，另外还有一个方便的方法来生成流畅的绑定。

class

FloatBinding

基类提供了实现float值的Binding所需的大部分功能。

class

FloatExpression

FloatExpression是一个ObservableFloatValue加上额外的便利方法，以流利的风格生成绑定。

class

IntegerBinding

提供实现int值Binding所需的大部分功能的基类。

class

IntegerExpression

IntegerExpression是一个ObservableIntegerValue，另外还有一个方便的方法来生成流畅的绑定。

class

ListBinding<E>

提供实现ObservableList的Binding所需的大部分功能的基类。

class

ListExpression<E>

ListExpression是一个ObservableListValue，另外还有一种方便的方法来生成流畅的绑定。

class

LongBinding

基类提供了实现long的long所需的大部分功能。

class

LongExpression

LongExpression是一个ObservableLongValue加上额外的便利方法，以流利的风格生成绑定。

class

MapBinding<K,V>

提供实现ObservableMap的Binding所需的大部分功能的基类。

class

MapExpression<K,V>

MapExpression是一个ObservableMapValue加上额外的便利方法，以流利的风格生成绑定。

class

NumberExpressionBase

NumberExpressionBase包含了以流畅样式生成绑定的方便方法，这是所有NumberExpression子类所共有的。

class

ObjectBinding<T>

提供实现Object的Object所需的大部分功能的基类。

class

ObjectExpression<T>

ObjectExpression是一个ObservableObjectValue加上额外的便利方法，以流利的风格生成绑定。

class

SetBinding<E>

提供实现ObservableSet的Binding所需的大部分功能的基类。

class

SetExpression<E>

SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。

class

StringBinding

提供实现String的String所需的大部分功能的基类。

class

StringExpression

StringExpression是一个ObservableStringValue加上额外的便利方法，以流利的风格生成绑定。

class

When

计算三元表达式的绑定的起始点。

class

When.BooleanConditionBuilder

组装三元表达时需要一个中间类。

class

When.NumberConditionBuilder

if-then-else表达式返回一个数字。

class

When.ObjectConditionBuilder<T>

组装三元表达时需要一个中间类。

class

When.StringConditionBuilder

组装三元表达时需要一个中间类。

Methods in javafx.beans.binding that return Object

Modifier and Type

方法

描述

Object[]

ListExpression.toArray​()

<T> T[]

ListExpression.toArray​(T[] array)

Object[]

SetExpression.toArray​()

<T> T[]

SetExpression.toArray​(T[] array)

Methods in javafx.beans.binding with parameters of type Object

Modifier and Type

方法

描述

boolean

ListExpression.addAll​(E... elements)

static StringExpression

Bindings.concat​(Object... args)

返回一个StringExpression ，它保持多个Objects的并置值。

StringExpression

StringExpression.concat​(Object other)

返回一个 StringExpression ，保留 StringExpression与另一个 Object连接的值。

boolean

ListExpression.contains​(Object obj)

boolean

SetExpression.contains​(Object obj)

boolean

MapExpression.containsKey​(Object obj)

boolean

MapExpression.containsValue​(Object obj)

static BooleanBinding

Bindings.equal​(Object op1, ObservableObjectValue<?> op2)

创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值等于一个恒定值，它将保持true 。

static BooleanBinding

Bindings.equal​(ObservableObjectValue<?> op1, Object op2)

创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue等于恒定值。

static StringExpression

Bindings.format​(String format, Object... args)

创建StringExpression保持多个值Objects根据格式格式化String 。

static StringExpression

Bindings.format​(Locale locale, String format, Object... args)

创建一个StringExpression ，其中保存多个Objects的值，根据格式String和指定的Locale格式

V

MapExpression.get​(Object key)

int

ListExpression.indexOf​(Object obj)

BooleanBinding

ObjectExpression.isEqualTo​(Object other)

创建一个新的 BooleanExpression ，如果这个 ObjectExpression等于一个恒定值，它将持有 true 。

BooleanBinding

ObjectExpression.isNotEqualTo​(Object other)

创建一个新的 BooleanExpression ，如果这个 ObjectExpression不等于一个恒定值，则保留 true 。

int

ListExpression.lastIndexOf​(Object obj)

static BooleanBinding

Bindings.notEqual​(Object op1, ObservableObjectValue<?> op2)

创建一个新的BooleanBinding ，如果一个ObservableObjectValue的值不等于一个恒定值，则保留true 。

static BooleanBinding

Bindings.notEqual​(ObservableObjectValue<?> op1, Object op2)

创建一个新的BooleanBinding保持true如果一个的值ObservableObjectValue不等于恒定值。

boolean

ListExpression.remove​(Object obj)

V

MapExpression.remove​(Object obj)

boolean

SetExpression.remove​(Object obj)

boolean

ListExpression.removeAll​(E... elements)

boolean

ListExpression.retainAll​(E... elements)

static <T> ObjectBinding<T>

Bindings.select​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static BooleanBinding

Bindings.selectBoolean​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static DoubleBinding

Bindings.selectDouble​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static FloatBinding

Bindings.selectFloat​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static IntegerBinding

Bindings.selectInteger​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static LongBinding

Bindings.selectLong​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static StringBinding

Bindings.selectString​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

boolean

ListExpression.setAll​(E... elements)

<T> T[]

ListExpression.toArray​(T[] array)

<T> T[]

SetExpression.toArray​(T[] array)

static void

Bindings.unbindBidirectional​(Object property1, Object property2)

删除先前使用 Bindings.bindBidirectional(Property, Property)或 Bindings.bindBidirectional(javafx.beans.property.Property, javafx.beans.property.Property, java.text.Format)定义的双向绑定。

static void

Bindings.unbindContent​(Object obj1, Object obj2)

删除内容绑定。

static void

Bindings.unbindContentBidirectional​(Object obj1, Object obj2)

删除双向内容绑定。

Uses of Object in javafx.beans.property

Subclasses of Object in javafx.beans.property

Modifier and Type

Class

描述

class

BooleanProperty

这个类提供了一个包含 boolean值的Property的全面实现。

class

BooleanPropertyBase

BooleanPropertyBase类是包含 boolean值的属性的基类。

class

DoubleProperty

这个类定义一个Property包装一个double值。

class

DoublePropertyBase

类 DoublePropertyBase是包含 double值的属性的基类。

class

FloatProperty

这个类定义了一个Property包裹一个float值。

class

FloatPropertyBase

类 FloatPropertyBase是包含 float值的属性的基类。

class

IntegerProperty

这个类定义了一个包含 int值的int 。

class

IntegerPropertyBase

类 IntegerPropertyBase是包含 int值的属性的基类。

class

ListProperty<E>

这个类提供了一个Property的全面实现，包装了一个ObservableList 。

class

ListPropertyBase<E>

ListPropertyBase类是包装ObservableList的属性的基类。

class

LongProperty

这个类定义了一个Property包裹一个long值。

class

LongPropertyBase

类 LongPropertyBase是包含 long值的属性的基类。

class

MapProperty<K,V>

这个类提供了一个Property的全面实现，包装了一个ObservableMap 。

class

MapPropertyBase<K,V>

MapPropertyBase类是包装ObservableMap的属性的基类。

class

ObjectProperty<T>

这个类提供了一个Property的全面实现，包装了一个任意的Object 。

class

ObjectPropertyBase<T>

ObjectPropertyBase类是包含任意 Object的属性的基类。

class

ReadOnlyBooleanProperty

超类为所有只读属性包装一个 boolean 。

class

ReadOnlyBooleanPropertyBase

所有只读属性的基类包装一个 boolean 。

class

ReadOnlyBooleanWrapper

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyDoubleProperty

超类为所有只读属性包装一个 double 。

class

ReadOnlyDoublePropertyBase

所有只读属性的基类包装一个 double 。

class

ReadOnlyDoubleWrapper

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyFloatProperty

超类为所有只读属性包装一个 float 。

class

ReadOnlyFloatPropertyBase

所有只读属性的基类包装一个 float 。

class

ReadOnlyFloatWrapper

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyIntegerProperty

所有readonly属性的超类包装一个 int 。

class

ReadOnlyIntegerPropertyBase

所有只读属性的基类包装一个 int 。

class

ReadOnlyIntegerWrapper

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyListProperty<E>

超类为所有只读属性包装一个ObservableList 。

class

ReadOnlyListPropertyBase<E>

所有只读属性的基类包装一个ObservableList 。

class

ReadOnlyListWrapper<E>

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyLongProperty

超类为所有只读属性包装一个 long 。

class

ReadOnlyLongPropertyBase

所有只读属性的基类包装一个 long 。

class

ReadOnlyLongWrapper

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyMapProperty<K,V>

超类为所有只读属性包装一个ObservableMap 。

class

ReadOnlyMapPropertyBase<K,V>

所有只读属性的基类包装一个ObservableMap 。

class

ReadOnlyMapWrapper<K,V>

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyObjectProperty<T>

超类为所有只读属性包装任意 Object 。

class

ReadOnlyObjectPropertyBase<T>

所有只读属性的基类包装任意 Object 。

class

ReadOnlyObjectWrapper<T>

该类提供了一个方便的类来定义只读属性。

class

ReadOnlySetProperty<E>

超类为所有只读属性包装一个ObservableSet 。

class

ReadOnlySetPropertyBase<E>

所有只读属性的基类包装一个ObservableSet 。

class

ReadOnlySetWrapper<E>

该类提供了一个方便的类来定义只读属性。

class

ReadOnlyStringProperty

超类为所有只读属性包装一个 String 。

class

ReadOnlyStringPropertyBase

所有只读属性的基类包装一个 String 。

class

ReadOnlyStringWrapper

该类提供了一个方便的类来定义只读属性。

class

SetProperty<E>

这个类提供了一个包含ObservableSet的Property的完整实现。

class

SetPropertyBase<E>

SetPropertyBase类是包装ObservableSet的属性的基类。

class

SimpleBooleanProperty

这个类提供了一个包含 boolean值的Property的完整实现。

class

SimpleDoubleProperty

该类提供了一个包含 double值的Property的完整实现。

class

SimpleFloatProperty

这个类提供了一个Property的全面实现，包装了一个float值。

class

SimpleIntegerProperty

这个类提供了一个包含 int值的Property的全面实现。

class

SimpleListProperty<E>

这个类提供了一个Property的全面实现，包含一个ObservableList 。

class

SimpleLongProperty

这个类提供了一个包含 long值的Property的全面实现。

class

SimpleMapProperty<K,V>

这个类提供了一个Property的全面实现，包装了一个ObservableMap 。

class

SimpleObjectProperty<T>

这个类提供了一个包含任意Object的Property的完整实现。

class

SimpleSetProperty<E>

这个类提供了一个Property的全面实现，包装了一个ObservableSet 。

class

SimpleStringProperty

这个类提供了一个包含 String值的Property的全面实现。

class

StringProperty

这个类提供了一个Property的全面实现，包含一个String值。

class

StringPropertyBase

StringPropertyBase类是包含一个 String值的属性的基类。

Methods in javafx.beans.property that return Object

Modifier and Type

方法

描述

Object

ReadOnlyProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleListProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleLongProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleMapProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleSetProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStringProperty.getBean​()

返回包含此属性的 Object 。

Methods in javafx.beans.property with parameters of type Object

Modifier and Type

方法

描述

boolean

ReadOnlyListProperty.equals​(Object obj)

boolean

ReadOnlyMapProperty.equals​(Object obj)

boolean

ReadOnlySetProperty.equals​(Object obj)

void

StringProperty.unbindBidirectional​(Object other)

删除此 Property和另一个之间的双向绑定。

void

ReadOnlyListProperty.unbindContent​(Object object)

删除ObservableList之间的内容绑定，即包装在这个ReadOnlyListProperty ，另外Object 。

void

ReadOnlyMapProperty.unbindContent​(Object object)

删除ObservableMap之间的内容绑定，即包含在这个ReadOnlyMapProperty ，另一个是Object 。

void

ReadOnlySetProperty.unbindContent​(Object object)

删除ObservableSet之间的内容绑定，即包含在这个ReadOnlySetProperty ，另一个是Object 。

void

ReadOnlyListProperty.unbindContentBidirectional​(Object object)

删除ObservableList之间的双向内容绑定，即包含在这个ReadOnlyListProperty ，另一个是Object 。

void

ReadOnlyMapProperty.unbindContentBidirectional​(Object object)

删除ObservableMap之间的双向内容绑定，即ReadOnlyMapProperty和另一个Object 。

void

ReadOnlySetProperty.unbindContentBidirectional​(Object object)

删除ObservableSet之间的双向内容绑定，即包含在这个ReadOnlySetProperty ，另外Object 。

Constructors in javafx.beans.property with parameters of type Object

Constructor

描述

ReadOnlyBooleanWrapper​(Object bean, String name)

构造函数为 ReadOnlyBooleanWrapper

ReadOnlyBooleanWrapper​(Object bean, String name, boolean initialValue)

构造函数为 ReadOnlyBooleanWrapper

ReadOnlyDoubleWrapper​(Object bean, String name)

构造函数为 ReadOnlyDoubleWrapper

ReadOnlyDoubleWrapper​(Object bean, String name, double initialValue)

构造函数为 ReadOnlyDoubleWrapper

ReadOnlyFloatWrapper​(Object bean, String name)

构造函数为 ReadOnlyFloatWrapper

ReadOnlyFloatWrapper​(Object bean, String name, float initialValue)

构造函数为 ReadOnlyFloatWrapper

ReadOnlyIntegerWrapper​(Object bean, String name)

构造函数为 ReadOnlyIntegerWrapper

ReadOnlyIntegerWrapper​(Object bean, String name, int initialValue)

构造函数为 ReadOnlyIntegerWrapper

ReadOnlyListWrapper​(Object bean, String name)

构造函数为 ReadOnlyListWrapper

ReadOnlyListWrapper​(Object bean, String name, ObservableList<E> initialValue)

构造函数为 ReadOnlyListWrapper

ReadOnlyLongWrapper​(Object bean, String name)

构造函数为 ReadOnlyLongWrapper

ReadOnlyLongWrapper​(Object bean, String name, long initialValue)

构造函数为 ReadOnlyLongWrapper

ReadOnlyMapWrapper​(Object bean, String name)

构造函数为 ReadOnlyMapWrapper

ReadOnlyMapWrapper​(Object bean, String name, ObservableMap<K,V> initialValue)

构造函数为 ReadOnlyMapWrapper

ReadOnlyObjectWrapper​(Object bean, String name)

构造函数为 ReadOnlyObjectWrapper

ReadOnlyObjectWrapper​(Object bean, String name, T initialValue)

构造函数为 ReadOnlyObjectWrapper

ReadOnlySetWrapper​(Object bean, String name)

构造函数为 ReadOnlySetWrapper

ReadOnlySetWrapper​(Object bean, String name, ObservableSet<E> initialValue)

构造函数为 ReadOnlySetWrapper

ReadOnlyStringWrapper​(Object bean, String name)

构造函数为 ReadOnlyStringWrapper

ReadOnlyStringWrapper​(Object bean, String name, String initialValue)

构造函数为 ReadOnlyStringWrapper

SimpleBooleanProperty​(Object bean, String name)

构造函数为 BooleanProperty

SimpleBooleanProperty​(Object bean, String name, boolean initialValue)

构造函数为 BooleanProperty

SimpleDoubleProperty​(Object bean, String name)

构造函数为 DoubleProperty

SimpleDoubleProperty​(Object bean, String name, double initialValue)

构造函数为 DoubleProperty

SimpleFloatProperty​(Object bean, String name)

构造函数为 FloatProperty

SimpleFloatProperty​(Object bean, String name, float initialValue)

构造函数为 FloatProperty

SimpleIntegerProperty​(Object bean, String name)

构造函数为 IntegerProperty

SimpleIntegerProperty​(Object bean, String name, int initialValue)

构造函数为 IntegerProperty

SimpleListProperty​(Object bean, String name)

构造函数为 SimpleListProperty

SimpleListProperty​(Object bean, String name, ObservableList<E> initialValue)

构造函数为 SimpleListProperty

SimpleLongProperty​(Object bean, String name)

构造函数为 LongProperty

SimpleLongProperty​(Object bean, String name, long initialValue)

的构造函数为 LongProperty

SimpleMapProperty​(Object bean, String name)

构造函数为 SimpleMapProperty

SimpleMapProperty​(Object bean, String name, ObservableMap<K,V> initialValue)

构造函数为 SimpleMapProperty

SimpleObjectProperty​(Object bean, String name)

构造函数为 ObjectProperty

SimpleObjectProperty​(Object bean, String name, T initialValue)

构造函数为 ObjectProperty

SimpleSetProperty​(Object bean, String name)

构造函数为 SimpleSetProperty

SimpleSetProperty​(Object bean, String name, ObservableSet<E> initialValue)

构造函数为 SimpleSetProperty

SimpleStringProperty​(Object bean, String name)

构造函数为 StringProperty

SimpleStringProperty​(Object bean, String name, String initialValue)

构造函数为 StringProperty

Uses of Object in javafx.beans.property.adapter

Subclasses of Object in javafx.beans.property.adapter

Modifier and Type

Class

描述

class

JavaBeanBooleanProperty

A JavaBeanBooleanProperty在 boolean或 Boolean之间的常规Java Bean属性和JavaFX BooleanProperty之间提供了一个适配器。

class

JavaBeanBooleanPropertyBuilder

A JavaBeanBooleanPropertyBuilder可以用来创建JavaBeanBooleanProperties 。

class

JavaBeanDoubleProperty

A JavaBeanDoubleProperty在 double或 Double之间的常规Java Bean属性和JavaFX DoubleProperty之间提供了一个适配器。

class

JavaBeanDoublePropertyBuilder

A JavaBeanDoublePropertyBuilder可以用来创建JavaBeanDoubleProperties 。

class

JavaBeanFloatProperty

A JavaBeanFloatProperty在类型为 float或 Float的常规Java Bean属性和JavaFX FloatProperty之间提供了一个适配器。

class

JavaBeanFloatPropertyBuilder

A JavaBeanFloatPropertyBuilder可以用来创建JavaBeanFloatProperties 。

class

JavaBeanIntegerProperty

A JavaBeanIntegerProperty在 int或 Integer之间的常规Java Bean属性和JavaFX IntegerProperty之间提供了一个适配器。

class

JavaBeanIntegerPropertyBuilder

A JavaBeanIntegerPropertyBuilder可以用来创建JavaBeanIntegerProperties 。

class

JavaBeanLongProperty

A JavaBeanLongProperty在 long或 Long之间的常规Java Bean属性和JavaFX LongProperty之间提供了一个适配器。

class

JavaBeanLongPropertyBuilder

A JavaBeanLongPropertyBuilder可以用来创建JavaBeanLongProperties 。

class

JavaBeanObjectProperty<T>

A JavaBeanObjectProperty在类型为 T的常规Java Bean属性和JavaFX ObjectProperty<T>之间提供了一个适配器。

class

JavaBeanObjectPropertyBuilder<T>

A JavaBeanObjectPropertyBuilder可以用来创建JavaBeanObjectProperties 。

class

JavaBeanStringProperty

一个 JavaBeanStringProperty提供类型的普通的Java Bean属性之间的适配器 String和一个JavaFX StringProperty 。

class

JavaBeanStringPropertyBuilder

A JavaBeanStringPropertyBuilder可以用来创建JavaBeanStringProperties 。

class

ReadOnlyJavaBeanBooleanProperty

A ReadOnlyJavaBeanBooleanProperty在常规的只读Java Bean属性类型为 boolean或 Boolean和JavaFX ReadOnlyBooleanProperty之间提供了一个适配器。

class

ReadOnlyJavaBeanBooleanPropertyBuilder

A ReadOnlyJavaBeanBooleanPropertyBuilder可以用来创建ReadOnlyJavaBeanBooleanProperties 。

class

ReadOnlyJavaBeanDoubleProperty

A ReadOnlyJavaBeanDoubleProperty在 double或 Double的常规只读Java Bean属性和JavaFX ReadOnlyDoubleProperty之间提供了一个适配器。

class

ReadOnlyJavaBeanDoublePropertyBuilder

A ReadOnlyJavaBeanDoublePropertyBuilder可以用来创建ReadOnlyJavaBeanDoubleProperties 。

class

ReadOnlyJavaBeanFloatProperty

A ReadOnlyJavaBeanFloatProperty在类型为 float或 Float的常规只读Java Bean属性和JavaFX ReadOnlyFloatProperty之间提供了一个适配器。

class

ReadOnlyJavaBeanFloatPropertyBuilder

A ReadOnlyJavaBeanFloatPropertyBuilder可以用来创建ReadOnlyJavaBeanFloatProperties 。

class

ReadOnlyJavaBeanIntegerProperty

A ReadOnlyJavaBeanIntegerProperty在类型为 int或 Integer的常规只读Java Bean属性和JavaFX ReadOnlyIntegerProperty之间提供了适配器。

class

ReadOnlyJavaBeanIntegerPropertyBuilder

A ReadOnlyJavaBeanIntegerPropertyBuilder可以用来创建ReadOnlyJavaBeanIntegerProperties 。

class

ReadOnlyJavaBeanLongProperty

A ReadOnlyJavaBeanLongProperty在 long或 Long之间的常规只读Java Bean属性和JavaFX ReadOnlyLongProperty提供了一个适配器。

class

ReadOnlyJavaBeanLongPropertyBuilder

A ReadOnlyJavaBeanLongPropertyBuilder可以用来创建ReadOnlyJavaBeanLongProperties 。

class

ReadOnlyJavaBeanObjectProperty<T>

A ReadOnlyJavaBeanObjectProperty在常规只读Java Bean属性 T和JavaFX ReadOnlyObjectProperty之间提供了一个适配器。

class

ReadOnlyJavaBeanObjectPropertyBuilder<T>

A ReadOnlyJavaBeanObjectPropertyBuilder可以用来创建ReadOnlyJavaBeanObjectProperties 。

class

ReadOnlyJavaBeanStringProperty

A ReadOnlyJavaBeanStringProperty在常规的只读Java Bean属性类型为 String和JavaFX ReadOnlyStringProperty之间提供了一个适配器。

class

ReadOnlyJavaBeanStringPropertyBuilder

A ReadOnlyJavaBeanStringPropertyBuilder可以用来创建ReadOnlyJavaBeanStringProperties 。

Methods in javafx.beans.property.adapter that return Object

Modifier and Type

方法

描述

Object

JavaBeanBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanLongProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanStringProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanLongProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanStringProperty.getBean​()

返回包含此属性的 Object 。

Methods in javafx.beans.property.adapter with parameters of type Object

Modifier and Type

方法

描述

JavaBeanBooleanPropertyBuilder

JavaBeanBooleanPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

JavaBeanDoublePropertyBuilder

JavaBeanDoublePropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

JavaBeanFloatPropertyBuilder

JavaBeanFloatPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

JavaBeanIntegerPropertyBuilder

JavaBeanIntegerPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

JavaBeanLongPropertyBuilder

JavaBeanLongPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

JavaBeanObjectPropertyBuilder

JavaBeanObjectPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

JavaBeanStringPropertyBuilder

JavaBeanStringPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

ReadOnlyJavaBeanBooleanPropertyBuilder

ReadOnlyJavaBeanBooleanPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

ReadOnlyJavaBeanDoublePropertyBuilder

ReadOnlyJavaBeanDoublePropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

ReadOnlyJavaBeanFloatPropertyBuilder

ReadOnlyJavaBeanFloatPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

ReadOnlyJavaBeanIntegerPropertyBuilder

ReadOnlyJavaBeanIntegerPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

ReadOnlyJavaBeanLongPropertyBuilder

ReadOnlyJavaBeanLongPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

ReadOnlyJavaBeanObjectPropertyBuilder<T>

ReadOnlyJavaBeanObjectPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

ReadOnlyJavaBeanStringPropertyBuilder

ReadOnlyJavaBeanStringPropertyBuilder.bean​(Object bean)

设置适配器应该连接的Java Bean实例

Uses of Object in javafx.beans.value

Subclasses of Object in javafx.beans.value

Modifier and Type

Class

描述

class

ObservableValueBase<T>

创建ObservableValue实现的便利类。

class

WeakChangeListener<T>

A WeakChangeListener可以使用，如果一个ObservableValue应该只保留一个弱参考的监听器。

Uses of Object in javafx.collections

Subclasses of Object in javafx.collections

Modifier and Type

Class

描述

class

FXCollections

由静态方法组成的实用程序类，它们是java.util.Collections方法的1：1。

static class

ListChangeListener.Change<E>

表示对Observablelist进行的更改的报告。

static class

MapChangeListener.Change<K,V>

对ObservableMap做一个基本的改动。

class

ModifiableObservableListBase<E>

抽象类作为可修改的ObservableList实现的基类。

class

ObservableArrayBase<T extends ObservableArray<T>>

抽象类，用作ObservableArray实现的基类。

class

ObservableListBase<E>

抽象类，用作ObservableList实现的基类。

static class

SetChangeListener.Change<E>

对ObservableSet进行基本更改。

class

WeakListChangeListener<E>

A WeakListChangeListener可以使用，如果一个ObservableList应该只保留一个弱的参考侦听器。

class

WeakMapChangeListener<K,V>

A WeakMapChangeListener可以使用，如果一个ObservableMap应该只保留对该监听器的弱引用。

class

WeakSetChangeListener<E>

A WeakSetChangeListener可以使用，如果一个ObservableSet应该只保留一个弱参考的监听器。

Methods in javafx.collections with parameters of type Object

Modifier and Type

方法

描述

boolean

ObservableList.addAll​(E... elements)

用于var-arg添加元素的方便方法。

boolean

ObservableListBase.addAll​(E... elements)

static <E> ObservableList<E>

FXCollections.observableArrayList​(E... items)

创建一个新的可观察数组列表， items添加了 items 。

static <E> ObservableSet<E>

FXCollections.observableSet​(E... elements)

构造一个由包含所有指定元素的HashSet支持的ObservableSet。

boolean

ModifiableObservableListBase.remove​(Object o)

boolean

ObservableList.removeAll​(E... elements)

一个方便的方法，用于var-arg使用的 removeAll方法。

boolean

ObservableListBase.removeAll​(E... elements)

boolean

ObservableList.retainAll​(E... elements)

对于 retainAll方法的var-arg使用的 方便方法。

boolean

ObservableListBase.retainAll​(E... elements)

boolean

ObservableList.setAll​(E... elements)

清除ObservableList并添加所有传递给var-args的元素。

boolean

ObservableListBase.setAll​(E... elements)

Uses of Object in javafx.collections.transformation

Subclasses of Object in javafx.collections.transformation

Modifier and Type

Class

描述

class

FilteredList<E>

包装一个ObservableList并使用提供的谓词过滤其内容。

class

SortedList<E>

包装一个ObservableList并对其内容进行排序。

class

TransformationList<E,F>

所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

Uses of Object in javafx.concurrent

Subclasses of Object in javafx.concurrent

Modifier and Type

Class

描述

class

ScheduledService<V>

ScheduledService是一个Service ，它将在成功执行后自动重新启动，并且在某些情况下，即使发生故障也将重新启动。

class

Service<V>

服务是一个非可视化组件，封装了在一个或多个后台线程上执行某些工作所需的信息。

class

Task<V>

一个完全可观察到的一个FutureTask的实现。

class

WorkerStateEvent

当一个工人状态发生变化时发生的事件。

Uses of Object in javafx.css

Subclasses of Object in javafx.css

Modifier and Type

Class

描述

class

CompoundSelector

根据CSS标准行事的复合选择器。

class

CssMetaData<S extends Styleable,V>

CssMetaData实例提供有关CSS样式的信息，并提供允许CSS设置属性值的钩子。

class

CssParser

static class

CssParser.ParseError

封装关于解析CSS或将样式应用于节点时遇到的错误的来源和性质的信息。

static class

CssParser.ParseError.InlineStyleParsingError

封装从节点样式属性解析引起的错误

static class

CssParser.ParseError.PropertySetError

封装将风格应用于节点所产生的错误。

static class

CssParser.ParseError.StringParsingError

当样式不是内联样式时，也不会从样式表中选择样式，从而解析解析时出现的错误。

static class

CssParser.ParseError.StylesheetParsingError

封装解析样式表文件时产生的错误

class

Declaration

class

FontCssMetaData<S extends Styleable>

CssMetaData部分实现Font属性，其中包含字体子属性：weight，style，family和size。

class

FontFace

FontFace是一个来自CSS文件的@ font-face定义

class

Match

由Rule用于确定选择器是否适用于给定的对象。

class

ParsedValue<V,T>

解析的CSS值的表示。

class

PseudoClass

伪类代表一个唯一的伪类状态。

class

Rule

class

Selector

由CSSRule用于确定选择器是否适用于给定的对象。

class

SimpleSelector

一个根据CSS标准行事的简单选择器。

class

SimpleStyleableBooleanProperty

这个课程扩展了 SimpleBooleanProperty并提供了一个 StyleableProperty的完整实现。

class

SimpleStyleableDoubleProperty

该课程扩展了 SimpleDoubleProperty并提供了一个 StyleableProperty的完整实现。

class

SimpleStyleableFloatProperty

这个类扩展了 SimpleFloatProperty并提供了一个 StyleableProperty的完整实现。

class

SimpleStyleableIntegerProperty

该课程扩展了 SimpleIntegerProperty并提供了一个 StyleableProperty的完整实现。

class

SimpleStyleableLongProperty

这个课程扩展了 SimpleLongProperty并提供了一个 StyleableProperty的完整实现。

class

SimpleStyleableObjectProperty<T>

这个类扩展了 SimpleObjectProperty并提供了一个 StyleableProperty的完整实现。

class

SimpleStyleableStringProperty

该课程扩展了 SimpleStringProperty并提供了一个 StyleableProperty的完整实现。

class

Size

表示特定单位中指定的大小，例如14px或0.2em。

class

Style

风格只是一个规则的选择器和声明。

class

StyleableBooleanProperty

这个类扩展了 BooleanPropertyBase并提供了一个 StyleableProperty的部分实现。

class

StyleableDoubleProperty

这个类扩展了 DoublePropertyBase并提供了一个 StyleableProperty的部分实现。

class

StyleableFloatProperty

这个类扩展了 FloatPropertyBase并提供了一个 StyleableProperty的部分实现。

class

StyleableIntegerProperty

这个类扩展了 IntegerPropertyBase并提供了一个 StyleableProperty的部分实现。

class

StyleableLongProperty

这个类扩展了 LongPropertyBase并提供了一个 StyleableProperty的部分实现。

class

StyleableObjectProperty<T>

这个类扩展了 ObjectPropertyBase并提供了一个 StyleableProperty的部分实现。

class

StyleablePropertyFactory<S extends Styleable>

使用相应的CssMetaData创建StyleableProperty实例的方法。

class

StyleableStringProperty

这个类扩展了 StringPropertyBase并提供了一个 StyleableProperty的部分实现。

class

StyleClass

class

StyleConverter<F,T>

StyleConverter转换 ParsedValue<F,T>从类型 F键入 T 。

static class

StyleConverter.StringStore

StringStore类

class

Stylesheet

可以将属性应用于对象树的样式表。

Fields in javafx.css declared as Object

Modifier and Type

Field

描述

protected V

ParsedValue.value

由解析器创建的CSS属性值。

Methods in javafx.css that return Object

Modifier and Type

方法

描述

Object

SimpleStyleableBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableLongProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableStringProperty.getBean​()

返回包含此属性的 Object 。

Methods in javafx.css with parameters of type Object

Modifier and Type

方法

描述

protected void

StyleConverter.cacheValue​(ParsedValue key, Object value)

缓存指定键的值。

boolean

CompoundSelector.equals​(Object obj)

boolean

CssMetaData.equals​(Object obj)

如果两个CssMetaData对象的 property值相等，则被认为是相等的。

boolean

Declaration.equals​(Object obj)

无论宣言所属的规则如何，一个宣言是相等的。

boolean

SimpleSelector.equals​(Object obj)

boolean

Size.equals​(Object obj)

boolean

Style.equals​(Object obj)

boolean

Stylesheet.equals​(Object obj)

Method parameters in javafx.css with type arguments of type Object

Modifier and Type

方法

描述

T

StyleConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)

从成分值转换为目标属性类型。

Constructors in javafx.css with parameters of type Object

Constructor

描述

SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)

的构造函数 SimpleStyleableBooleanProperty 。

SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)

SimpleStyleableBooleanProperty的构造 SimpleStyleableBooleanProperty 。

SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)

SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。

SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)

SimpleStyleableFloatProperty的构造 SimpleStyleableFloatProperty 。

SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。

SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)

SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。

SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。

SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)

SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。

SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)

SimpleStyleableObjectProperty的构造 SimpleStyleableObjectProperty 。

SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)

的构造器的 SimpleStyleableObjectProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)

的构造函数为 SimpleStyleableStringProperty 。

Uses of Object in javafx.css.converter

Subclasses of Object in javafx.css.converter

Modifier and Type

Class

描述

class

BooleanConverter

class

ColorConverter

class

CursorConverter

class

DeriveColorConverter

从颜色和亮度值导出颜色

class

DeriveSizeConverter

一种组合两个Size值的类型。

class

DurationConverter

将大小转换为持续时间

class

EffectConverter

static class

EffectConverter.DropShadowConverter

static class

EffectConverter.InnerShadowConverter

class

EnumConverter<E extends Enum<E>>

class

FontConverter

static class

FontConverter.FontSizeConverter

static class

FontConverter.FontStyleConverter

static class

FontConverter.FontWeightConverter

class

InsetsConverter

将1到4个大小组件的解析值数组转换为Insets。

static class

InsetsConverter.SequenceConverter

将一组解析的值转换为Insets对象数组，每个值都是1到4个大小的数组。

class

LadderConverter

class

PaintConverter

static class

PaintConverter.ImagePatternConverter

static class

PaintConverter.LinearGradientConverter

static class

PaintConverter.RadialGradientConverter

static class

PaintConverter.RepeatingImagePatternConverter

static class

PaintConverter.SequenceConverter

将解析值数组转换为Paint对象数组。

class

ShapeConverter

将SVG形状字符串转换为Shape对象。

class

SizeConverter

将大小转换为数字

static class

SizeConverter.SequenceConverter

class

StopConverter

从一个大小和一个颜色转换一个停止

class

StringConverter

字符串类型转换嵌入式unicode字符

static class

StringConverter.SequenceConverter

class

URLConverter

将表示URL的解析值转换为相对于样式表位置解析的URL字符串。

static class

URLConverter.SequenceConverter

Methods in javafx.css.converter with parameters of type Object

Modifier and Type

方法

描述

boolean

EnumConverter.equals​(Object other)

Method parameters in javafx.css.converter with type arguments of type Object

Modifier and Type

方法

描述

Font

FontConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)

Uses of Object in javafx.embed.swing

Subclasses of Object in javafx.embed.swing

Modifier and Type

Class

描述

class

JFXPanel

JFXPanel是将JavaFX内容嵌入到Swing应用程序中的组件。

class

SwingFXUtils

该类提供了用于在Swing / AWT和JavaFX格式之间转换数据类型的实用方法。

class

SwingNode

此类用于将Swing内容嵌入到JavaFX应用程序中。

Uses of Object in javafx.event

Subclasses of Object in javafx.event

Modifier and Type

Class

描述

class

ActionEvent

一个Event代表一些类型的动作。

class

Event

FX事件的基础类。

class

EventType<T extends Event>

此类表示与 Event相关联的特定事件类型。

class

WeakEventHandler<T extends Event>

用于事件处理程序注册代替其关联的事件处理程序。

Methods in javafx.event that return Object

Modifier and Type

方法

描述

Object

Event.clone​()

创建并返回此 Event的副本。

Methods in javafx.event with parameters of type Object

Modifier and Type

方法

描述

ActionEvent

ActionEvent.copyFor​(Object newSource, EventTarget newTarget)

Event

Event.copyFor​(Object newSource, EventTarget newTarget)

使用指定的事件源和目标创建并返回此事件的副本。

Constructors in javafx.event with parameters of type Object

Constructor

描述

ActionEvent​(Object source, EventTarget target)

构造一个新的 ActionEvent与指定的事件源和目标。

Event​(Object source, EventTarget target, EventType<? extends Event> eventType)

构造一个新的 Event与指定的事件源，目标和类型。

Uses of Object in javafx.fxml

Subclasses of Object in javafx.fxml

Modifier and Type

Class

描述

class

FXMLLoader

从XML文档加载对象层次结构。

class

JavaFXBuilderFactory

JavaFX构建工厂。

class

LoadException

在加载操作期间遇到错误时抛出。

Methods in javafx.fxml that return types with arguments of type Object

Modifier and Type

方法

描述

Callback<Class<?>,Object>

FXMLLoader.getControllerFactory​()

返回此装载器使用的控制器工厂。

ObservableMap<String,Object>

FXMLLoader.getNamespace​()

返回此装载器使用的命名空间。

Methods in javafx.fxml with parameters of type Object

Modifier and Type

方法

描述

void

LoadListener.endElement​(Object value)

加载程序完成读取元素后调用。

boolean

FXMLLoader.equals​(Object obj)

void

FXMLLoader.setController​(Object controller)

设置与根对象关联的控制器。

void

FXMLLoader.setRoot​(Object root)

设置对象层次结构的根。

Method parameters in javafx.fxml with type arguments of type Object

Modifier and Type

方法

描述

static <T> T

FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)

从FXML文档加载对象层次结构。

static <T> T

FXMLLoader.load​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)

从FXML文档加载对象层次结构。

void

FXMLLoader.setControllerFactory​(Callback<Class<?>,Object> controllerFactory)

设置此装载机使用的控制器工厂。

Constructor parameters in javafx.fxml with type arguments of type Object

Constructor

描述

FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory)

创建一个新的FXMLLoader实例。

FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset)

创建一个新的FXMLLoader实例。

FXMLLoader​(URL location, ResourceBundle resources, BuilderFactory builderFactory, Callback<Class<?>,Object> controllerFactory, Charset charset, LinkedList<FXMLLoader> loaders)

创建一个新的FXMLLoader实例。

Uses of Object in javafx.geometry

Subclasses of Object in javafx.geometry

Modifier and Type

Class

描述

class

BoundingBox

一个矩形边框，用于描述节点或其他场景图对象的界限。

class

Bounds

用于描述节点或其他场景图形对象边界的对象的基类。

class

Dimension2D

包含宽度和高度的2D维度对象。

class

Insets

一组矩形区域的4边的内部偏移量

class

Point2D

通常代表x，y坐标的二维几何点。

class

Point3D

通常表示x，y，z坐标的3D几何点。

class

Rectangle2D

用于描述对象边界的2D矩形。

Methods in javafx.geometry with parameters of type Object

Modifier and Type

方法

描述

boolean

BoundingBox.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Dimension2D.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Insets.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Point2D.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Point3D.equals​(Object obj)

返回该点的哈希码值。

boolean

Rectangle2D.equals​(Object obj)

指示一些其他对象是否等于此。

Uses of Object in javafx.print

Subclasses of Object in javafx.print

Modifier and Type

Class

描述

class

JobSettings

JobSettings类封装了打印作业的大部分配置。

class

PageLayout

PageLayout封装了布局内容所需的信息。

class

PageRange

A PageRange用于选择或约束要打印的作业打印流页面。

class

Paper

封装打印机使用的纸介质尺寸的类。

class

PaperSource

PaperSource是用于纸张的进纸盘。

class

Printer

打印机实例表示打印作业的目的地。

class

PrinterAttributes

该类封装了与其作业打印功能和其他属性相关的打印机的属性。

class

PrinterJob

PrinterJob是JavaFX场景打印的起点。

class

PrintResolution

类别表示打印机在进给和交叉进给方向上的支持的设备分辨率，单位英寸（DPI）。

Methods in javafx.print with parameters of type Object

Modifier and Type

方法

描述

boolean

PageLayout.equals​(Object o)

boolean

Paper.equals​(Object o)

boolean

PrintResolution.equals​(Object o)

Uses of Object in javafx.scene

Subclasses of Object in javafx.scene

Modifier and Type

Class

描述

class

AmbientLight

定义环境光源对象。

class

Camera

用于渲染场景的相机的基类。

class

Cursor

封装鼠标光标位图表示的类。

class

Group

一个 Group节点包含一个可观察的子节点列表，每当呈现该节点时，它们按顺序渲染。

class

ImageCursor

鼠标光标的自定义图像表示。

class

LightBase

LightBase类提供了表示光源形式的对象的常用属性的定义。

class

Node

场景图节点的基类。

class

ParallelCamera

指定用于渲染场景而不进行透视校正的并行相机。

class

Parent

在场景图中有子节点的所有节点的基类。

class

PerspectiveCamera

指定用于渲染场景的透视相机。

class

PointLight

定义点光源对象。

class

Scene

JavaFX Scene类是场景图中所有内容的容器。

class

SceneAntialiasing

JavaFX SceneAntialiasing类指定所需的抗锯齿级别。

class

SnapshotParameters

用于指定节点快照的渲染属性的参数。

class

SnapshotResult

此类保存快照操作的结果。

class

SubScene

SubScene类是场景图中内容的容器。

Methods in javafx.scene that return Object

Modifier and Type

方法

描述

Object

SnapshotResult.getSource​()

获取调用快照的源节点或场景。

Object

Node.getUserData​()

返回先前设置的Object属性，如果没有使用 Node.setUserData(java.lang.Object)方法设置此属性，则返回null。

Object

Scene.getUserData​()

返回先前设置的Object属性，如果没有使用 Scene.setUserData(java.lang.Object)方法设置此属性，则返回null。

Object

Node.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Parent.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Methods in javafx.scene that return types with arguments of type Object

Modifier and Type

方法

描述

ObservableMap<Object,Object>

Node.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Node.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Scene.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Scene.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

Methods in javafx.scene with parameters of type Object

Modifier and Type

方法

描述

void

Node.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

Object

Node.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Parent.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

void

Node.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

void

Scene.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

Uses of Object in javafx.scene.canvas

Subclasses of Object in javafx.scene.canvas

Modifier and Type

Class

描述

class

Canvas

Canvas是可以使用由GraphicsContext提供的一组图形命令绘制的图像。

class

GraphicsContext

该类用于使用缓冲区向Canvas发出绘制调用。

Uses of Object in javafx.scene.chart

Subclasses of Object in javafx.scene.chart

Modifier and Type

Class

描述

class

AreaChart<X,Y>

AreaChart - 绘制连接数据点的线和Y轴上0行之间的区域。

class

Axis<T>

JavaFX中所有轴的基类，表示在图表区域上绘制的轴。

static class

Axis.TickMark<T>

TickMark代表标签文本，它与Axis的每个刻度相关联的属性。

class

BarChart<X,Y>

绘制一个指示类别数据值的条形图。

class

BubbleChart<X,Y>

为一系列数据点绘制气泡的图表类型。

class

CategoryAxis

一个轴实现，它将对字符串类别起作用，其中每个值作为轴上的唯一类别（刻度线）。

class

Chart

所有图表的基础类。

class

LineChart<X,Y>

线图绘制了连接数据点的行。

class

NumberAxis

一个轴类，用于在每个tickUnit中绘制主要刻度线的数字范围。

static class

NumberAxis.DefaultFormatter

NumberAxis的默认数字格式化程序，与自动量程保持同步，并适当地格式化值。

class

PieChart

显示PieChart。

static class

PieChart.Data

PieChart数据项，表示PieChart中的一个切片

class

ScatterChart<X,Y>

绘制一系列数据点符号的图表类型。

class

StackedAreaChart<X,Y>

StackedAreaChart是的变化AreaChart显示每个值的贡献的趋势。

class

StackedBarChart<X,Y>

StackedBarChart是的变化BarChart绘出指示用于一个类别的数据值条。

class

ValueAxis<T extends Number>

数据定义为数字的轴。

class

XYChart<X,Y>

所有2轴图的图表基类。

static class

XYChart.Data<X,Y>

具有2轴图数据的单个数据项

static class

XYChart.Series<X,Y>

一系列命名的数据项

Methods in javafx.scene.chart that return Object

Modifier and Type

方法

描述

protected abstract Object

Axis.autoRange​(double length)

这将根据提供给invalidateRange（）方法的数据计算上限和下限。

protected Object

CategoryAxis.autoRange​(double length)

这将根据提供给invalidateRange（）方法的数据计算类别。

protected Object

NumberAxis.autoRange​(double minValue, double maxValue, double length, double labelSize)

被要求设置上限和下限以及需要自动调整的任何其他内容。

protected Object

ValueAxis.autoRange​(double length)

这将根据提供给invalidateRange（）方法的数据计算上限和下限。

protected Object

ValueAxis.autoRange​(double minValue, double maxValue, double length, double labelSize)

被要求设置上限和下限以及需要自动调整的任何其他内容。

protected Object

XYChart.getCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item)

当前显示的数据额外值。

Object

XYChart.Data.getExtraValue​()

获取属性extraValue的值。

protected abstract Object

Axis.getRange​()

被称为获取当前的轴范围。

protected Object

CategoryAxis.getRange​()

被称为获取当前的轴范围。

protected Object

NumberAxis.getRange​()

被称为获取当前的轴范围。

Methods in javafx.scene.chart that return types with arguments of type Object

Modifier and Type

方法

描述

protected ObjectProperty<Object>

XYChart.currentDisplayedExtraValueProperty​(XYChart.Data<X,Y> item)

当前显示的额外值属性。

ObjectProperty<Object>

XYChart.Data.extraValueProperty​()

以图表所需的任何方式绘制的通用数据值。

Methods in javafx.scene.chart with parameters of type Object

Modifier and Type

方法

描述

protected abstract List<T>

Axis.calculateTickValues​(double length, Object range)

计算范围内每个刻度线的所有数据值的列表

protected List<String>

CategoryAxis.calculateTickValues​(double length, Object range)

计算范围内每个刻度线的所有数据值的列表

protected List<Number>

NumberAxis.calculateTickValues​(double length, Object range)

计算范围内每个刻度线的所有数据值的列表

protected Dimension2D

Axis.measureTickMarkSize​(T value, Object range)

测量给定刻度标记值的标签尺寸。

protected Dimension2D

CategoryAxis.measureTickMarkSize​(String value, Object range)

测量给定刻度标记值的标签尺寸。

protected Dimension2D

NumberAxis.measureTickMarkSize​(Number value, Object range)

测量给定刻度标记值的标签尺寸。

protected void

XYChart.setCurrentDisplayedExtraValue​(XYChart.Data<X,Y> item, Object value)

设置当前显示的数据额外值。

void

XYChart.Data.setExtraValue​(Object value)

设置属性extraValue的值。

protected abstract void

Axis.setRange​(Object range, boolean animate)

调用将当前轴范围设置为给定范围。

protected void

CategoryAxis.setRange​(Object range, boolean animate)

调用将当前轴范围设置为给定范围。

protected void

NumberAxis.setRange​(Object range, boolean animate)

调用将当前轴范围设置为给定范围。

Constructors in javafx.scene.chart with parameters of type Object

Constructor

描述

Data​(X xValue, Y yValue, Object extraValue)

创建XYChart.Data对象的实例，并初始化X，Y数据值和extraValue。

Uses of Object in javafx.scene.control

Subclasses of Object in javafx.scene.control

Modifier and Type

Class

描述

class

Accordion

手风琴是一组TitlePanes 。

class

Alert

Alert类对Dialog类进行子类化，并为许多预构建的对话框类型提供支持，可以轻松向用户显示提示响应。

class

Button

一个简单的按钮控件。

class

ButtonBar

ButtonBar本质上是一个HBox ，具有操作系统特定按钮放置的附加功能。

class

ButtonBase

按钮式UI控件的基类，包括超链接，按钮，ToggleButtons，复选框和RadioButtons。

class

ButtonType

ButtonType类用作JavaFX Dialog API（更具体地说是DialogPane API）的一部分，用于指定在对话框中向用户显示哪些按钮。

class

Cell<T>

细胞API被用于如虚拟化控制ListView ， TreeView ，和TableView 。

class

CheckBox

三态选择控件通常在选中时以带有复选标记或刻度标记的方式打包。

class

CheckBoxTreeItem<T>

TreeItem子类增加了在选定的，未选择的和不确定的状态中的支持。

static class

CheckBoxTreeItem.TreeModificationEvent<T>

一个TreeModificationEvent类，与类似于TreeItem.TreeModificationEvent类的工作类似，因为该事件将引发 CheckBoxTreeItem层次结构，直到父节点为空。

class

CheckMenuItem

A MenuItem可以在选定状态和未选择状态之间切换。

class

ChoiceBox<T>

ChoiceBox用于向用户呈现一组相对较小的预定义选项，从中可以选择。

class

ChoiceDialog<T>

一个对话框，向用户显示选择列表，最多可以从中选择一个项目。

class

ColorPicker

ColorPicker控件允许用户从标准的颜色调色板中选择一种颜色，只需点击一下简单的选择或定义自己的自定义颜色。

class

ComboBox<T>

对于最常见的ComboBox形式的ComboBoxBase抽象类的实现，其中向用户提供弹出列表，以提供他们可以选择的选项。

class

ComboBoxBase<T>

ComboBox类控件的抽象基类。

class

ContextMenu

一个包含菜单项的ObservableList的弹出控件。

class

Control

所有用户界面控件的基类。

class

CustomMenuItem

A MenuItem ，允许任意节点嵌入其中，通过为content属性分配一个Node 。

class

DateCell

DateCell由DatePicker用于在日历月中呈现单个网格单元格。

class

DatePicker

DatePicker控件允许用户输入日期作为文本或从日历弹出窗口中选择日期。

class

Dialog<R>

JavaFX中的Dialog包装了一个DialogPane，并提供必要的API来将其呈现给最终用户。

class

DialogEvent

与对话框显示/隐藏操作相关的事件。

class

DialogPane

DialogPane应该被认为是在一个Dialog实例中显示的根节点 。

class

FocusModel<T>

FocusModel实现的抽象基类。

class

Hyperlink

一个HTML标签，可以是一个图形和/或文本，用于响应滚动和点击。

class

IndexedCell<T>

一个Cell的实现，其中包含一个索引属性，该属性映射到可视化的底层的数据模型中。

class

IndexRange

表示整数值的连续范围的类。

class

Label

标签是不可编辑的文本控件。

class

Labeled

标签Control是其用户界面的一部分，与其相关联的文本内容。

class

ListCell<T>

Cell类型中使用的ListView实例。

class

ListView<T>

ListView显示用户可以从中选择或与用户可以进行交互的项目的水平或垂直列表。

static class

ListView.EditEvent<T>

一个Event用于表示编辑相关事件的ListView中特别使用的子类。

class

Menu

可触发的项目的弹出菜单，仅根据请求向用户显示。

class

MenuBar

MenuBar控件传统上放置在用户界面的最上方，嵌入其中是Menus 。

class

MenuButton

MenuButton是一个按钮，当点击或按下时，它将显示一个ContextMenu 。

class

MenuItem

MenuItem旨在与Menu结合使用，为用户提供选项。

class

MultipleSelectionModel<T>

一个抽象类，扩展SelectionModel以添加API以支持多选。

class

Pagination

分页控件用于单个内容的页面之间的导航，该页面已分为较小的部分。

class

PasswordField

掩码输入字符的文本字段。

class

PopupControl

PopupWindow的扩展，允许CSS样式。

protected class

PopupControl.CSSBridge

弹出窗口和场景图之间的链接。

class

ProgressBar

ProgressIndator的专业化表示为横杠。

class

ProgressIndicator

用于指示进度的循环控制，无限（也称为不确定）或有限。

class

RadioButton

RadioButtons创建一系列只能选择一个项目的项目。

class

RadioMenuItem

RadioMenuItem是一个MenuItem可以切换（它使用Toggle mixin）。

class

ResizeFeaturesBase<S>

列使用的不可变包装类可调整由控件（如TableView和TreeTableView）提供的策略大小。

class

ScrollBar

具有增量和减量按钮的水平或垂直条，以及用户可以与之交互的“拇指”。

class

ScrollPane

提供其内容的滚动，剪切视口的控件。

class

ScrollToEvent<T>

事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。

class

SelectionModel<T>

SelectionModel是UI控件用来提供一致的API来维护选择的抽象类。

class

Separator

水平或垂直分隔线。

class

SeparatorMenuItem

A MenuItem ，如名称所示，允许将水平分隔符嵌入其中，通过为CustomMenuItem分配content属性Separator提供这是为了方便起见，可以通过分隔符分隔menuitems的组。

class

SingleSelectionModel<T>

一个SelectionModel，它强制要求在任何给定的时间只选择一个索引。

class

SkinBase<C extends Control>

基本实现类，用于通过定义节点的场景图来定义用户界面控件的可视化表示，以表示skin 。

class

Slider

滑块控件用于显示连续或离散的有效数字选项范围，并允许用户与控件进行交互。

class

SortEvent<C>

事件涉及TableView和TreeTableView排序。

class

Spinner<T>

单行文本字段，允许用户从有序序列中选择一个数字或一个对象值。

class

SpinnerValueFactory<T>

SpinnerValueFactory是JavaFX Spinner control背后的模型 - 没有值工厂安装的Spinner不可用。

static class

SpinnerValueFactory.DoubleSpinnerValueFactory

A SpinnerValueFactory旨在迭代双重值的实现。

static class

SpinnerValueFactory.IntegerSpinnerValueFactory

一个设计用于遍历整数值的SpinnerValueFactory实现。

static class

SpinnerValueFactory.ListSpinnerValueFactory<T>

一个SpinnerValueFactory实现，旨在迭代一个值列表。

class

SplitMenuButton

SplitMenuButton，像MenuButton与从菜单中选择一个MenuItem的概念密切相关。

class

SplitPane

具有两个或更多个侧面的控制器，每个侧面由分隔件隔开，可以由用户拖动以给其中一个侧面提供更多的空间，导致另一侧收缩相等的量。

static class

SplitPane.Divider

在SplitPane中代表一个分隔符。

class

Tab

标签放置在TabPane中 ，其中每个选项卡表示单个“页面”。

class

TableCell<S,T>

在TableView中表示单行/列交集。

class

TableColumn<S,T>

A TableView由多个TableColumn实例组成。

static class

TableColumn.CellDataFeatures<S,T>

在TableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。

static class

TableColumn.CellEditEvent<S,T>

用户在表单元格上执行编辑时触发的事件。

class

TableColumnBase<S,T>

表类控件（例如TableView和TreeTableView ）由零个或多个具体TableColumnBase子类（ TableColumn和TreeTableColumn ）的实例组成。

class

TableFocusModel<T,TC extends TableColumnBase<T,?>>

FocusModel实现的抽象基类，用于表类控件中（最着名的是TableView和TreeTableView） 。

class

TablePosition<S,T>

此类用于表示TableView中的单个行/列/单元格。

class

TablePositionBase<TC extends TableColumnBase>

此类用于表示表中的单个行/列/单元格。

class

TableRow<T>

TableRow是一个IndexedCell ，但很少需要由开发人员使用创建TableView实例。

class

TableSelectionModel<T>

MultipleSelectionModel实现的抽象基类，用于表类控件中（最着名的是TableView和TreeTableView） 。

class

TableView<S>

TableView控件旨在可视化无限数量的数据行，分为列。

static class

TableView.ResizeFeatures<S>

用于TableView column resize功能的不可变包装类。

static class

TableView.TableViewFocusModel<S>

A FocusModel具有支持TableView控件要求的附加功能。

static class

TableView.TableViewSelectionModel<S>

SelectionModel抽象类的简单扩展，允许对TableView控件的特殊支持。

class

TabPane

一个允许在一组Tabs之间切换的控件 。

class

TextArea

文本输入组件，允许用户输入多行纯文本。

class

TextField

文本输入组件，允许用户输入一行未格式化的文本。

class

TextFormatter<V>

格式化器通过使用两种截然不同的机制来描述 TextInputControl文本的格式：可以拦截和修改用户输入的过滤器（ TextFormatter.getFilter() ）。

static class

TextFormatter.Change

包含表示TextInputControl的内容或选择更改的状态。

class

TextInputControl

文本输入控件的抽象基类。

class

TextInputDialog

显示给用户的文本输入控件的对话框。

class

TitledPane

TitledPane是一个可以打开和关闭的标题的面板。

class

ToggleButton

A ToggleButton是一种具有选择能力的专业控制。

class

ToggleGroup

它包含所有的引用的类 Toggles其 selected变量应该被管理，使得仅仅单个 Toggle的内 ToggleGroup可以在任一周时间来选择。

class

ToolBar

ToolBar是一个可以水平或垂直显示项目的控件。

class

Tooltip

工具提示是常见的UI元素，通常用于在节点由鼠标悬停时在场景图中显示有关节点的附加信息。

class

TreeCell<T>

Cell类型与TreeView控件一起使用。

class

TreeItem<T>

单个节点的模型为诸如TreeView之类的控件提供值的层次结构。

static class

TreeItem.TreeModificationEvent<T>

一个Event ，其中包含所有形式的TreeItem修改的相关信息。

class

TreeTableCell<S,T>

在TreeTableView中表示单行/列交集。

class

TreeTableColumn<S,T>

A TreeTableView由多个TreeTableColumn实例组成。

static class

TreeTableColumn.CellDataFeatures<S,T>

在TreeTableColumn中使用的支持类作为包装类，为特定的Cell提供所有必要的信息。

static class

TreeTableColumn.CellEditEvent<S,T>

用户在表单元格上执行编辑时触发的事件。

class

TreeTablePosition<S,T>

此类用于在TreeTableView中表示单个行/列/单元格。

class

TreeTableRow<T>

TreeTableRow是一个IndexedCell ，但很少需要由开发人员使用创建TreeTableView实例。

class

TreeTableView<S>

TreeTableView控件旨在可视化无限数量的数据行，分为列。

static class

TreeTableView.EditEvent<S>

一个Event用于表示编辑相关事件的TreeTableView中使用的子类。

static class

TreeTableView.ResizeFeatures<S>

用于TableView column resize功能的不可变包装类。

static class

TreeTableView.TreeTableViewFocusModel<S>

A FocusModel具有支持TableView控件要求的附加功能。

static class

TreeTableView.TreeTableViewSelectionModel<S>

一个简单的扩展的SelectionModel抽象类，以允许对TreeTableView控件的特殊支持。

class

TreeView<T>

TreeView控件提供了一个到根的视图（类型为TreeItem ）。

static class

TreeView.EditEvent<T>

一个Event子类，专门用于TreeView中用于表示编辑相关事件。

Methods in javafx.scene.control that return Object

Modifier and Type

方法

描述

Object

MenuItem.getUserData​()

返回先前设置的Object属性，如果没有使用 MenuItem.setUserData(java.lang.Object)方法设置此属性，则返回null。

Object

Tab.getUserData​()

返回先前设置的Object属性，如果没有使用 Tab.setUserData(java.lang.Object)方法设置此属性，则返回null。

Object

TableColumnBase.getUserData​()

返回先前设置的Object属性，如果没有使用 TableColumnBase.setUserData(java.lang.Object)方法设置此属性，则返回null。

Object

Toggle.getUserData​()

返回先前设置的Object属性，如果没有使用 Node.setUserData(java.lang.Object)方法设置此属性，则返回null。

Object

ToggleGroup.getUserData​()

返回先前设置的Object属性，如果没有使用 ToggleGroup.setUserData(java.lang.Object)方法设置此属性，则返回null。

Object

CheckBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ChoiceBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ComboBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ComboBoxBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Control.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

DatePicker.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Hyperlink.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ListCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ListView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

PasswordField.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ProgressBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ProgressIndicator.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

RadioButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ScrollBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ScrollPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

SkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Slider.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Spinner.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

SplitMenuButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TextInputControl.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TitledPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ToggleButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Methods in javafx.scene.control that return types with arguments of type Object

Modifier and Type

方法

描述

ObservableMap<Object,Object>

MenuItem.getProperties​()

返回此菜单项上可观察到的属性映射，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

MenuItem.getProperties​()

返回此菜单项上可观察到的属性映射，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Tab.getProperties​()

返回此选项卡上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Tab.getProperties​()

返回此选项卡上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

TableColumnBase.getProperties​()

返回此表列上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

TableColumnBase.getProperties​()

返回此表列上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Toggle.getProperties​()

返回此切换上属性的可观察地图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Toggle.getProperties​()

返回此切换上属性的可观察地图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

ToggleGroup.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

ToggleGroup.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

Methods in javafx.scene.control with parameters of type Object

Modifier and Type

方法

描述

DialogEvent

DialogEvent.copyFor​(Object newSource, EventTarget newTarget)

DialogEvent

DialogEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<DialogEvent> type)

用给定的字段替换给定事件的副本。

boolean

IndexRange.equals​(Object object)

指示一些其他对象是否等于此。

boolean

TablePositionBase.equals​(Object obj)

指示一些其他对象是否等于此。

void

ButtonBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ChoiceBox.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ComboBoxBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

Control.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ListCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

MenuButton.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ScrollBar.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

protected void

SkinBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

Slider.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

Spinner.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

SplitMenuButton.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TableCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TextInputControl.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TitledPane.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TreeCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TreeTableCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TreeTableRow.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

Object

CheckBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ChoiceBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ComboBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ComboBoxBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Control.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

DatePicker.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Hyperlink.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ListCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ListView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

PasswordField.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ProgressBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ProgressIndicator.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

RadioButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ScrollBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ScrollPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

SkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Slider.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Spinner.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

SplitMenuButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TextInputControl.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TitledPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ToggleButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

void

MenuItem.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

void

Tab.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

void

TableColumnBase.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

void

Toggle.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

void

ToggleGroup.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

Constructors in javafx.scene.control with parameters of type Object

Constructor

描述

ChoiceDialog​(T defaultChoice, T... choices)

创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选项，并且所有以下参数都被视为用户所有可用选项的varargs数组。

ScrollToEvent​(Object source, EventTarget target, EventType<ScrollToEvent<T>> type, T scrollTarget)

构造一个新的 Event与指定的事件源，目标和类型。

Uses of Object in javafx.scene.control.cell

Subclasses of Object in javafx.scene.control.cell

Modifier and Type

Class

描述

class

CheckBoxListCell<T>

一个包含ListCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签来指示复选框代表什么。

class

CheckBoxTableCell<S,T>

一个包含TableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。

class

CheckBoxTreeCell<T>

一个包含一个TreeCell实现的类，它在单元格中绘制一个CheckBox节点，并支持常见的交互（ 稍后更详细地讨论）。

class

CheckBoxTreeTableCell<S,T>

一个包含TreeTableCell实现的类，可以在单元格中绘制一个CheckBox节点，可选地带有一个标签，以指示复选框代表什么。

class

ChoiceBoxListCell<T>

一个包含一个ListCell实现的类，它在单元格内绘制一个ChoiceBox节点。

class

ChoiceBoxTableCell<S,T>

一个包含一个TableCell实现的类，它在单元格内绘制一个ChoiceBox节点。

class

ChoiceBoxTreeCell<T>

一个包含ListCell实现的类，它在单元格内绘制一个ChoiceBox节点。

class

ChoiceBoxTreeTableCell<S,T>

一个包含TreeTableCell实现的类，在单元格内绘制一个ChoiceBox节点。

class

ComboBoxListCell<T>

一个包含ListCell实现的类，它在单元格中绘制一个ComboBox节点。

class

ComboBoxTableCell<S,T>

一个包含一个TableCell实现的类，它在单元格内绘制一个2705256968080节点。

class

ComboBoxTreeCell<T>

一个包含TreeCell实现的类，它在单元格内绘制一个ComboBox节点。

class

ComboBoxTreeTableCell<S,T>

一个包含TreeTableCell实现的类，在该单元格内绘制一个ComboBox节点。

class

MapValueFactory<T>

Callback界面的方便实现，专为TableColumn cell value factory使用而设计。

class

ProgressBarTableCell<S>

一个包含TableCell实现的类，在单元格内绘制一个ProgressBar节点。

class

ProgressBarTreeTableCell<S>

一个包含TreeTableCell实现的类，在该单元格内绘制一个ProgressBar节点。

class

PropertyValueFactory<S,T>

Callback界面的方便实现，专为TableColumn cell value factory中使用而设计。

class

TextFieldListCell<T>

一个包含一个ListCell实现的类，它在单元格中绘制一个2705256967598节点。

class

TextFieldTableCell<S,T>

一个包含TableCell实现的类，它在单元格内绘制一个TextField节点。

class

TextFieldTreeCell<T>

一个包含TreeCell实现的类，在单元格内绘制一个TextField节点。

class

TextFieldTreeTableCell<S,T>

一个包含一个TableCell实现的类，它在单元格内绘制一个TextField节点。

class

TreeItemPropertyValueFactory<S,T>

Callback界面的方便实现，专为TreeTableColumn cell value factory使用而设计。

Methods in javafx.scene.control.cell with parameters of type Object

Modifier and Type

方法

描述

static <T> Callback<ListView<T>,ListCell<T>>

ChoiceBoxListCell.forListView​(StringConverter<T> converter, T... items)

创建一个ChoiceBox单元格工厂，用于ListView控件。

static <T> Callback<ListView<T>,ListCell<T>>

ChoiceBoxListCell.forListView​(T... items)

创建一个ChoiceBox单元格工厂，用于ListView控件。

static <T> Callback<ListView<T>,ListCell<T>>

ComboBoxListCell.forListView​(StringConverter<T> converter, T... items)

创建ComboBox单元格工厂，用于ListView控件。

static <T> Callback<ListView<T>,ListCell<T>>

ComboBoxListCell.forListView​(T... items)

创建一个ComboBox单元格工厂用于ListView控件。

static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>>

ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)

创建一个ChoiceBox单元格工厂用于TableColumn控件。

static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>>

ChoiceBoxTableCell.forTableColumn​(T... items)

创建一个ChoiceBox单元格工厂，用于TableColumn控件。

static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>>

ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)

创建ComboBox单元格工厂用于TableColumn控件。

static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>>

ComboBoxTableCell.forTableColumn​(T... items)

创建ComboBox单元格工厂用于TableColumn控件。

static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>

ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)

创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。

static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>

ChoiceBoxTreeTableCell.forTreeTableColumn​(T... items)

创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。

static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>

ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)

创建ComboBox单元格工厂用于TreeTableColumn控件。

static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>>

ComboBoxTreeTableCell.forTreeTableColumn​(T... items)

创建ComboBox单元格工厂用于TreeTableColumn控件。

static <T> Callback<TreeView<T>,TreeCell<T>>

ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)

创建一个ChoiceBox单元格工厂用于TreeView控件。

static <T> Callback<TreeView<T>,TreeCell<T>>

ChoiceBoxTreeCell.forTreeView​(T... items)

创建一个ChoiceBox单元格工厂，用于TreeView控件。

static <T> Callback<TreeView<T>,TreeCell<T>>

ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)

创建ComboBox单元格工厂用于TreeView控件。

static <T> Callback<TreeView<T>,TreeCell<T>>

ComboBoxTreeCell.forTreeView​(T... items)

创建ComboBox单元格工厂用于TreeView控件。

Constructors in javafx.scene.control.cell with parameters of type Object

Constructor

描述

ChoiceBoxListCell​(StringConverter<T> converter, T... items)

创建一个27052570898942实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxListCell​(T... items)

创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充它。

ChoiceBoxTableCell​(StringConverter<T> converter, T... items)

创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时显示ChoiceBox ，而StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTableCell​(T... items)

创建默认的ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxTreeCell​(StringConverter<T> converter, T... items)

创建一个ChoiceBoxTreeCell实例，给定的项目用于填充ChoiceBox ，并显示StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTreeCell​(T... items)

创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。

ChoiceBoxTreeTableCell​(StringConverter<T> converter, T... items)

创建一个ChoiceBoxTreeTableCell实例，给定的项目用于填充ChoiceBox ，并且StringConverter用于将项目转换为用户可读的形式。

ChoiceBoxTreeTableCell​(T... items)

创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于填充ChoiceBox 。

ComboBoxListCell​(StringConverter<T> converter, T... items)

创建一个ComboBoxListCell实例，给定的项目用于在显示ComboBox时显示，而StringConverter用于将项目转换为用户可读的形式。

ComboBoxListCell​(T... items)

创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充它。

ComboBoxTableCell​(StringConverter<T> converter, T... items)

创建一个ComboBoxTableCell实例，给定的项目用于填充ComboBox ，并显示StringConverter用于将项目转换为用户可读的形式。

ComboBoxTableCell​(T... items)

创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

ComboBoxTreeCell​(StringConverter<T> converter, T... items)

创建一个ComboBoxTreeCell实例，给定的项目用于填充ComboBox ，并显示StringConverter用于将项目转换为用户可读的形式。

ComboBoxTreeCell​(T... items)

创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充它。

ComboBoxTreeTableCell​(StringConverter<T> converter, T... items)

创建一个ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时显示ComboBox ，而StringConverter用于将该项目转换为用户可读的形式。

ComboBoxTreeTableCell​(T... items)

创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

MapValueFactory​(Object key)

创建默认的MapValueFactory，它将使用提供的键来查找安装此MapValueFactory的TableColumn中的单元格值（通过cell value factory属性）。

Uses of Object in javafx.scene.control.skin

Subclasses of Object in javafx.scene.control.skin

Modifier and Type

Class

描述

class

AccordionSkin

默认皮肤实现为Accordion控件。

class

ButtonBarSkin

默认皮肤实现为ButtonBar控件。

class

ButtonSkin

默认皮肤实现为Button控件。

class

CellSkinBase<C extends Cell>

默认皮肤的实施为Cell控制和子类，如ListCell ， TreeCell ，等等。

class

CheckBoxSkin

默认皮肤实现为三态CheckBox控件。

class

ChoiceBoxSkin<T>

默认皮肤实现为ChoiceBox控件。

class

ColorPickerSkin

默认皮肤实现为ColorPicker控件。

class

ComboBoxBaseSkin<T>

一个抽象类，旨在用作基于ComboBoxBase的 ComboBox类控件的基础外观 。

class

ComboBoxListViewSkin<T>

默认皮肤实现为ComboBox控件。

class

ComboBoxPopupControl<T>

一个抽象类，扩展了ComboBoxBaseSkin的功能，以包含与显示ComboBox类控件作为弹出窗口相关的API。

class

ContextMenuSkin

ContextMenu的默认皮肤实现。

class

DateCellSkin

默认皮肤实现为DateCell控件。

class

DatePickerSkin

默认皮肤实现为DatePicker控件。

class

HyperlinkSkin

默认皮肤实现为Hyperlink控件。

class

LabeledSkinBase<C extends Labeled>

控件的默认皮肤实现扩展为Labeled 。

class

LabelSkin

默认皮肤实现为Label控件。

class

ListCellSkin<T>

默认皮肤实现为ListCell控件。

class

ListViewSkin<T>

默认皮肤实现为ListView控件。

class

MenuBarSkin

默认皮肤实现为MenuBar控件。

class

MenuButtonSkin

默认皮肤实现为MenuButton控件。

class

MenuButtonSkinBase<C extends MenuButton>

MenuButtonSkin和SplitMenuButtonSkin的基类。

class

NestedTableColumnHeader

此类用于构造TableView的头。

class

PaginationSkin

默认皮肤实现为Pagination控件。

class

ProgressBarSkin

默认皮肤实现为ProgressBar控件。

class

ProgressIndicatorSkin

默认皮肤实现为ProgressIndicator控件。

class

RadioButtonSkin

默认皮肤实现为RadioButton控件。

class

ScrollBarSkin

默认皮肤实现为ScrollBar控件。

class

ScrollPaneSkin

默认皮肤实现为ScrollPane控件。

class

SeparatorSkin

默认皮肤实现为Separator控件。

class

SliderSkin

默认皮肤实现为Slider控件。

class

SpinnerSkin<T>

默认皮肤实现为Spinner控件。

class

SplitMenuButtonSkin

默认皮肤实现为SplitMenuButton控件。

class

SplitPaneSkin

默认皮肤实现为SplitPane控件。

class

TableCellSkin<S,T>

默认皮肤实现为TableCell控件。

class

TableCellSkinBase<S,T,C extends IndexedCell<T>>

表格单元格控件的基础皮肤，例如： TableCell和TreeTableCell 。

class

TableColumnHeader

负责绘制单列标题的区域。

class

TableHeaderRow

负责绘制整列列标题的区域。

class

TableRowSkin<T>

默认皮肤实现为TableRow控件。

class

TableRowSkinBase<T,C extends IndexedCell,R extends IndexedCell>

TableRowSkinBase是控件使用的基础皮肤类，如TableRow和TreeTableRow （具体类别分别为TableRowSkin和TreeTableRowSkin ）。

class

TableViewSkin<T>

默认皮肤实现为TableView控件。

class

TableViewSkinBase<M,S,C extends Control,I extends IndexedCell<M>,TC extends TableColumnBase<S,?>>

TableViewSkinBase是控件使用的基础皮肤类，如TableView和TreeTableView （具体类别分别为TableViewSkin和TreeTableViewSkin ）。

class

TabPaneSkin

默认皮肤实现为TabPane控件。

class

TextAreaSkin

默认皮肤实现为TextArea控件。

class

TextFieldSkin

默认皮肤实现为TextField控件。

class

TextInputControlSkin<T extends TextInputControl>

文本输入皮肤的抽象基类。

class

TitledPaneSkin

默认皮肤实现为TitledPane控件。

class

ToggleButtonSkin

默认皮肤实现为ToggleButton控件。

class

ToolBarSkin

默认皮肤实现为ToolBar控件。

class

TooltipSkin

基于CSS的皮肤为Tooltip。

class

TreeCellSkin<T>

默认皮肤实现为TreeCell控件。

class

TreeTableCellSkin<S,T>

默认皮肤实现为TreeTableCell控件。

class

TreeTableRowSkin<T>

默认皮肤实现为TreeTableRow控件。

class

TreeTableViewSkin<T>

默认皮肤实现为TreeTableView控件。

class

TreeViewSkin<T>

默认皮肤实现为TreeView控件。

class

VirtualContainerBase<C extends Control,I extends IndexedCell>

父类控制其内容虚拟化和可滚动的外观。

class

VirtualFlow<T extends IndexedCell>

使用基于单元的机制实现虚拟化容器。

Methods in javafx.scene.control.skin that return Object

Modifier and Type

方法

描述

Object

ComboBoxListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

LabeledSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

MenuBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

MenuButtonSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

PaginationSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ScrollPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableColumnHeader.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TableViewSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TabPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

protected Object

TextAreaSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TextFieldSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ToolBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

protected Object

TreeTableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TreeTableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TreeViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Methods in javafx.scene.control.skin with parameters of type Object

Modifier and Type

方法

描述

protected void

ListViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

protected void

TableViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

protected void

TextInputControlSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

protected void

ToolBarSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

protected void

TreeTableViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

protected void

TreeViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

Object

ComboBoxListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

LabeledSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

MenuBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

MenuButtonSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

PaginationSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ScrollPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableColumnHeader.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TableViewSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TabPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

protected Object

TextAreaSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TextFieldSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ToolBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

protected Object

TreeTableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TreeTableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TreeViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Uses of Object in javafx.scene.effect

Subclasses of Object in javafx.scene.effect

Modifier and Type

Class

描述

class

Blend

使用预定义的BlendMode之一将两个输入组合在一起的效果。

class

Bloom

基于可配置的阈值，使得输入图像的较亮部分看起来发亮的高级效果。

class

BoxBlur

使用简单的盒式过滤器内核的模糊效果，在两个维度上都有单独配置的大小，以及控制所产生的模糊质量的迭代参数。

class

ColorAdjust

允许每个像素调整色调，饱和度，亮度和对比度的效果。

class

ColorInput

使用给定的 Paint填充（“淹没”）的矩形区域的效果。

class

DisplacementMap

将每个像素移动由指定的FloatMap的前两个频带指定的距离的效果 。

class

DropShadow

使用指定的颜色，半径和偏移量将给定内容的阴影呈现在内容后面的高级效果。

class

Effect

所有效果实现的抽象基类。

class

FloatMap

包含浮点数据的缓冲区，用作DisplacementMap等效果的参数。

class

GaussianBlur

使用高斯卷积核的模糊效果，具有可配置的半径。

class

Glow

基于可配置的阈值，使输入图像看起来发亮的高级效果。

class

ImageInput

一种源效果，只是将给定的 Image通过未修改，作为输入到另一个 Effect 。

class

InnerShadow

使用指定的颜色，半径和偏移量在给定内容的边缘内部呈现阴影的高级效果。

class

Light

所有轻型实现的抽象基类。

static class

Light.Distant

代表遥远的光源。

static class

Light.Point

表示3D空间中给定位置的光源。

static class

Light.Spot

在3D空间中的给定位置表示点光源，具有可配置的方向和焦点。

class

Lighting

模拟照亮给定内容的光源的效果，可用于给平坦物体更逼真的三维外观。

class

MotionBlur

使用高斯卷积核的运动模糊效果，具有可配置的半径和角度。

class

PerspectiveTransform

提供输入内容的非仿射变换的效果。

class

Reflection

将输入的反映版本呈现在实际输入内容之下的效果。

class

SepiaTone

一个过滤器，产生棕褐色调效果，类似于古董照片。

class

Shadow

产生具有模糊边缘的输入的单色副本的效果。

Uses of Object in javafx.scene.image

Subclasses of Object in javafx.scene.image

Modifier and Type

Class

描述

class

Image

Image类表示图形图像，用于从指定的URL加载图像。

class

ImageView

ImageView是一个Node用于绘制图像加载Image类。

class

PixelFormat<T extends Buffer>

A PixelFormat对象定义给定格式的像素的数据布局。

class

WritableImage

WritableImage类表示由应用程序提供的像素构建的自定义图形图像，可能来自任何数量来源的 PixelReader对象，包括从文件或URL读取的图像。

class

WritablePixelFormat<T extends Buffer>

表示可以存储全色的像素格式的物体PixelFormat可以用作从任意图像写入像素数据的目的地格式。

Uses of Object in javafx.scene.input

Subclasses of Object in javafx.scene.input

Modifier and Type

Class

描述

class

Clipboard

表示操作系统剪贴板，数据可能在例如剪切，复制和粘贴操作期间放置。

class

ClipboardContent

数据容器为Clipboard数据。

class

ContextMenuEvent

当用户请求上下文菜单时，会发生此事件。

class

DataFormat

数据格式标识符用作识别存储在剪贴板/拖板上的数据的手段。

class

Dragboard

一个拖放具体的Clipboard 。

class

DragEvent

拖动事件在拖放手势时替换鼠标事件。

class

GestureEvent

表示手势输入的事件。

class

InputEvent

指示用户输入的事件。

class

InputMethodEvent

一个表示底层输入法在Node中通知其文本更改的事件 。

class

InputMethodTextRun

表示单个运行，其中字符在输入法文本中具有相同的高亮集。

class

KeyCharacterCombination

该类表示主键由其字符指定的组合键。

class

KeyCodeCombination

该类表示主键由其 KeyCode指定的组合键。

class

KeyCombination

表示在键盘快捷键中使用的键组合。

static class

KeyCombination.Modifier

此类表示一对修饰符键及其值。

class

KeyEvent

一个事件表明一个击键发生在一个Node 。

class

Mnemonic

创建助记符时使用此类。

class

MouseDragEvent

鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。

class

MouseEvent

当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher中描述的捕获和冒泡阶段将事件传递给它。

class

PickResult

包含pick事件结果的容器对象

class

RotateEvent

旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。

class

ScrollEvent

滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。

class

SwipeEvent

滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。

class

TouchEvent

触摸事件表示触摸屏操作。

class

TouchPoint

触摸点表示多点触摸动作的单个点，通常一个手指触摸屏幕。

class

ZoomEvent

缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。

Methods in javafx.scene.input that return Object

Modifier and Type

方法

描述

Object

DragEvent.getAcceptingObject​()

接受拖动的对象。

Object

Clipboard.getContent​(DataFormat dataFormat)

返回给定类型的此剪贴板中存储的内容，如果没有此类型的内容，则返回null。

Object

DragEvent.getGestureSource​()

拖放手势的源对象。

Object

MouseDragEvent.getGestureSource​()

返回正在进行的手势的源对象。

Object

DragEvent.getGestureTarget​()

拖放手势的目标对象。

Methods in javafx.scene.input with parameters of type Object

Modifier and Type

方法

描述

ContextMenuEvent

ContextMenuEvent.copyFor​(Object newSource, EventTarget newTarget)

DragEvent

DragEvent.copyFor​(Object newSource, EventTarget newTarget)

DragEvent

DragEvent.copyFor​(Object source, EventTarget target, Object gestureSource, Object gestureTarget, EventType<DragEvent> eventType)

创建给定字段替换的给定拖动事件的副本。

DragEvent

DragEvent.copyFor​(Object source, EventTarget target, EventType<DragEvent> type)

创建给定字段替换的给定拖动事件的副本。

GestureEvent

GestureEvent.copyFor​(Object newSource, EventTarget newTarget)

使用指定的事件源和目标创建并返回此事件的副本。

InputMethodEvent

InputMethodEvent.copyFor​(Object newSource, EventTarget newTarget)

KeyEvent

KeyEvent.copyFor​(Object newSource, EventTarget newTarget)

KeyEvent

KeyEvent.copyFor​(Object source, EventTarget target, EventType<KeyEvent> type)

用给定的字段替换给定事件的副本。

MouseDragEvent

MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget)

MouseDragEvent

MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> type)

MouseEvent

MouseEvent.copyFor​(Object newSource, EventTarget newTarget)

将此事件复制到不同的来源和目标。

MouseEvent

MouseEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> eventType)

用给定的字段替换给定事件的副本。

RotateEvent

RotateEvent.copyFor​(Object newSource, EventTarget newTarget)

RotateEvent

RotateEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<RotateEvent> type)

用给定的字段替换给定事件的副本。

ScrollEvent

ScrollEvent.copyFor​(Object newSource, EventTarget newTarget)

ScrollEvent

ScrollEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ScrollEvent> type)

用给定的字段替换给定事件的副本。

SwipeEvent

SwipeEvent.copyFor​(Object newSource, EventTarget newTarget)

SwipeEvent

SwipeEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<SwipeEvent> type)

用给定的字段替换给定事件的副本。

TouchEvent

TouchEvent.copyFor​(Object newSource, EventTarget newTarget)

使用指定的事件源和目标创建并返回此事件的副本。

TouchEvent

TouchEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<TouchEvent> type)

用给定的字段替换给定事件的副本。

ZoomEvent

ZoomEvent.copyFor​(Object newSource, EventTarget newTarget)

ZoomEvent

ZoomEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<ZoomEvent> type)

用给定的字段替换给定事件的副本。

static MouseDragEvent

MouseEvent.copyForMouseDragEvent​(MouseEvent e, Object source, EventTarget target, EventType<MouseDragEvent> type, Object gestureSource, PickResult pickResult)

创建MouseDragEvent类型的鼠标事件的副本

boolean

DataFormat.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

KeyCharacterCombination.equals​(Object obj)

测试这个 KeyCharacterCombination是否等于指定的对象。

boolean

KeyCodeCombination.equals​(Object obj)

测试这个 KeyCodeCombination是否等于指定的对象。

boolean

KeyCombination.equals​(Object obj)

测试这个 KeyCombination是否等于指定的对象。

Method parameters in javafx.scene.input with type arguments of type Object

Modifier and Type

方法

描述

boolean

Clipboard.setContent​(Map<DataFormat,Object> content)

将内容放在剪贴板上。

Constructors in javafx.scene.input with parameters of type Object

Constructor

描述

ContextMenuEvent​(Object source, EventTarget target, EventType<ContextMenuEvent> eventType, double x, double y, double screenX, double screenY, boolean keyboardTrigger, PickResult pickResult)

构造新的ContextMenu事件。

DragEvent​(Object source, EventTarget target, EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)

构造新的DragEvent事件。

DragEvent​(EventType<DragEvent> eventType, Dragboard dragboard, double x, double y, double screenX, double screenY, TransferMode transferMode, Object gestureSource, Object gestureTarget, PickResult pickResult)

构造具有空源和目标的新的DragEvent事件。

GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType)

已过时。
不要使用这个构造函数。 构造空事件。

GestureEvent​(Object source, EventTarget target, EventType<? extends GestureEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, PickResult pickResult)

构建新的GestureEvent事件。

InputEvent​(Object source, EventTarget target, EventType<? extends InputEvent> eventType)

创建新的InputEvent实例。

InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)

构造新的InputMethodEvent事件。

KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)

从指定的参数构造一个新的 KeyEvent事件。

MouseDragEvent​(Object source, EventTarget target, EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)

构造新的MouseDragEvent事件。

MouseDragEvent​(EventType<MouseDragEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, PickResult pickResult, Object gestureSource)

构造具有null源和目标的新的MouseDragEvent事件。

MouseEvent​(Object source, EventTarget target, EventType<? extends MouseEvent> eventType, double x, double y, double screenX, double screenY, MouseButton button, int clickCount, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean primaryButtonDown, boolean middleButtonDown, boolean secondaryButtonDown, boolean synthesized, boolean popupTrigger, boolean stillSincePress, PickResult pickResult)

构造新的MouseEvent事件。

RotateEvent​(Object source, EventTarget target, EventType<RotateEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double angle, double totalAngle, PickResult pickResult)

构造新的RotateEvent事件。

ScrollEvent​(Object source, EventTarget target, EventType<ScrollEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double deltaX, double deltaY, double totalDeltaX, double totalDeltaY, ScrollEvent.HorizontalTextScrollUnits textDeltaXUnits, double textDeltaX, ScrollEvent.VerticalTextScrollUnits textDeltaYUnits, double textDeltaY, int touchCount, PickResult pickResult)

构造新的ScrollEvent事件。

SwipeEvent​(Object source, EventTarget target, EventType<SwipeEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, int touchCount, PickResult pickResult)

构造新的SwipeEvent事件。

TouchEvent​(Object source, EventTarget target, EventType<TouchEvent> eventType, TouchPoint touchPoint, List<TouchPoint> touchPoints, int eventSetId, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)

构建新的TouchEvent事件。

ZoomEvent​(Object source, EventTarget target, EventType<ZoomEvent> eventType, double x, double y, double screenX, double screenY, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown, boolean direct, boolean inertia, double zoomFactor, double totalZoomFactor, PickResult pickResult)

构造新的ZoomEvent事件。

Uses of Object in javafx.scene.layout

Subclasses of Object in javafx.scene.layout

Modifier and Type

Class

描述

class

AnchorPane

AnchorPane允许子节点的边缘锚定到锚定窗格边缘的偏移。

class

Background

背景Region 。

class

BackgroundFill

填充和相关属性指示如何填充Region的背景。

class

BackgroundImage

定义描述如何将图像呈现为背景的属性Region 。

class

BackgroundPosition

表示的位置BackgroundImage的内Region的绘图区域。

class

BackgroundSize

定义BackgroundImage应该填充的区域的大小相对于其样式的Region。

class

Border

边界一个Region 。

class

BorderImage

定义描述如何将图像呈现为某个区域的边框的属性。

class

BorderPane

BorderPane在上，左，右，底部和中间位置摆放孩子。

class

BorderStroke

定义用于对区域进行样式设置的边框上使用的笔画。

class

BorderStrokeStyle

定义在BorderStroke的一边使用的笔触风格。

class

BorderWidths

定义四个组件（顶部，右侧，底部和左侧）的宽度。

class

ColumnConstraints

为GridPane中的列定义可选布局约束。

class

ConstraintsBase

用于定义节点特定布局约束的基类。

class

CornerRadii

定义BorderStroke的四个角中的每一个的半径。

class

FlowPane

FlowPane将其孩子摆放在流过玻璃边界的流中。

class

GridPane

GridPane将其孩子放在一个灵活的行和列格网中。

class

HBox

HBox将孩子放在一排水平排列中。

class

Pane

布局窗格的基类需要将子列表暴露为公开，以便子类的用户可以自由添加/删除子级。

class

Region

Region是所有基于JavaFX Node的UI控件和所有布局容器的基类。

class

RowConstraints

为GridPane中的行定义可选布局约束。

class

StackPane

StackPane将它的孩子放在一个靠前的堆叠中。

class

TilePane

TilePane将其孩子们放在一个大小均匀的“瓷砖”网格中。

class

VBox

VBox把孩子放在一个垂直的立柱上。

Methods in javafx.scene.layout with parameters of type Object

Modifier and Type

方法

描述

boolean

Background.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundFill.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundImage.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundPosition.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundSize.equals​(Object o)

指示一些其他对象是否等于此。

boolean

Border.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderImage.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderStroke.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderStrokeStyle.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderWidths.equals​(Object o)

指示一些其他对象是否等于此。

boolean

CornerRadii.equals​(Object o)

指示一些其他对象是否等于此。

Uses of Object in javafx.scene.media

Subclasses of Object in javafx.scene.media

Modifier and Type

Class

描述

class

AudioClip

AudioClip表示可以以最小延迟播放的音频段。

class

AudioEqualizer

AudioEqualizer课程为媒体播放器提供音频均衡控制。

class

AudioTrack

描述音轨的Track 。

class

EqualizerBand

所述EqualizerBand类提供了在每个频带控制AudioEqualizer 。

class

Media

Media类代表媒体资源。

class

MediaErrorEvent

一个Event表示在处理媒体时发生错误。

class

MediaException

甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。

class

MediaMarkerEvent

代表媒体标记的ActionEvent 。

class

MediaPlayer

MediaPlayer课程提供播放媒体的控制。

class

MediaView

A Node ，提供Media由MediaPlayer播放的视图 。

class

SubtitleTrack

A Track包含要覆盖视频轨道的副标题或字幕数据。

class

Track

表示媒体资源中包含的曲目的类。

class

VideoTrack

描述视频轨道的Track 。

Methods in javafx.scene.media that return types with arguments of type Object

Modifier and Type

方法

描述

ObservableMap<String,Object>

Media.getMetadata​()

检索此媒体源中包含的元数据。

Map<String,Object>

Track.getMetadata​()

Methods in javafx.scene.media with parameters of type Object

Modifier and Type

方法

描述

MediaErrorEvent

MediaErrorEvent.copyFor​(Object newSource, EventTarget newTarget)

Uses of Object in javafx.scene.paint

Subclasses of Object in javafx.scene.paint

Modifier and Type

Class

描述

class

Color

Color类用于将颜色封装在默认的sRGB颜色空间中。

class

ImagePattern

ImagePattern类填充具有图像模式的形状。

class

LinearGradient

LinearGradient类用线性颜色渐变模式填充形状。

class

Material

用于表示3D表面材质的基类。

class

Paint

用于在渲染场景图时填充形状和背景的颜色或渐变的基类。

class

PhongMaterial

PhongMaterial类提供了代表Phong阴影材料的属性的定义。

class

RadialGradient

RadialGradient类提供了一种填充圆形径向颜色渐变图案的形状的方法。

class

Stop

定义渐变颜色斜坡的一个元素。

Methods in javafx.scene.paint with parameters of type Object

Modifier and Type

方法

描述

boolean

Color.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

LinearGradient.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

RadialGradient.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Stop.equals​(Object obj)

指示一些其他对象是否等于此。

Uses of Object in javafx.scene.shape

Subclasses of Object in javafx.scene.shape

Modifier and Type

Class

描述

class

Arc

所述 Arc类表示2D弧对象，由中心点限定的，起始角度（度），角度范围（以度数表示的弧的长度），和一弧型（ ArcType.OPEN ， ArcType.CHORD ，或 ArcType.ROUND ）。

class

ArcTo

一个路径元素，它使用指定的半径从前一个坐标到指定的x和y坐标形成弧。

class

Box

Box类定义了具有指定大小的3维框。

class

Circle

Circle类创建一个新的圆，其中指定的半径和中心位置以像素为单位。

class

ClosePath

关闭当前路径的路径元素。

class

CubicCurve

CubiCurve类定义了（x，y）坐标空间中的三次Bézier参数曲线段。

class

CubicCurveTo

通过绘制与当前坐标和指定坐标 (x,y)相交的立方Bier曲线，使用指定点 (controlX1,controlY1)和 (controlX2,controlY2)作为Bézier控制点，创建由三个新点定义的曲线路径元素。

class

Cylinder

Cylinder类定义了具有指定大小的3维圆柱体。

class

Ellipse

Ellipse类创建一个新的椭圆，具有指定的大小和位置（以像素为单位）

class

HLineTo

创建从当前点到x的水平线路元素。

class

Line

此行表示 (x,y)坐标空间中的线段。

class

LineTo

通过从当前坐标绘制直线到新坐标来创建线路元素。

class

Mesh

用于表示3D几何表面的基类。

class

MeshView

MeshView类定义了具有指定3D网格数据的曲面。

class

MoveTo

通过移动到指定的坐标来创建对路径的补充。

class

Path

Path类代表一个简单的形状，并提供了几何路径的基本构造和管理所需的设施。

class

PathElement

所述PathElement类表示的一个抽象元素Path能够表示像直线，圆弧，二次曲线，三次曲线等的任何几何对象

class

Polygon

创建由x，y坐标数组定义的多边形。

class

Polyline

创建折线，由分段点数组定义。

class

QuadCurve

Quadcurve类定义了（x，y）坐标空间中的二次Bézier参数曲线段。

class

QuadCurveTo

通过绘制与当前坐标和指定坐标 (x, y)两者相交的二次曲线曲线，使用指定点 (controlX, controlY)作为Bézier控制点，创建由两个新点定义的曲线路径元素。

class

Rectangle

Rectangle类定义了一个具有指定大小和位置的矩形。

class

Shape

Shape类为表示某种形式的几何形状的对象提供了常见属性的定义。

class

Shape3D

Shape3D基类为表示某种形式的3D几何形状的对象提供了常用属性的定义。

class

Sphere

Sphere类定义了具有指定大小的三维球体。

class

SVGPath

SVGPath类表示通过从String解析SVG路径数据构建的简单形状。

class

TriangleMesh

定义一个三角形三角形网格，它包含相关联的 VertexFormat和一组独立的顶点组件阵列，例如点，法线，纹理坐标和定义网格的各个三角形的面阵列。

class

VertexFormat

定义网格中顶点的格式。

class

VLineTo

创建从当前点到y的垂直线路元素。

Uses of Object in javafx.scene.text

Subclasses of Object in javafx.scene.text

Modifier and Type

Class

描述

class

Font

Font类表示字体，用于在屏幕上呈现文本。

class

HitInfo

表示文本节点中的命中信息。

class

Text

Text类定义了一个显示文本的节点。

class

TextFlow

TextFlow是设计用于布置富文本的特殊布局。

Methods in javafx.scene.text that return Object

Modifier and Type

方法

描述

Object

Text.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TextFlow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Methods in javafx.scene.text with parameters of type Object

Modifier and Type

方法

描述

boolean

Font.equals​(Object obj)

指示一些其他对象是否等于此。

Object

Text.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TextFlow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Uses of Object in javafx.scene.transform

Subclasses of Object in javafx.scene.transform

Modifier and Type

Class

描述

class

Affine

Affine类代表一般的仿射变换。

class

NonInvertibleTransformException

NonInvertibleTransformException类表示如果执行的操作需要 Transform对象处于不可逆状态的对象时抛出异常。

class

Rotate

该类表示一个 Affine对象，它绕坐标点旋转坐标。

class

Scale

此类表示一个 Affine对象，可根据指定的因素缩放坐标。

class

Shear

该类代表一个 Affine对象，它通过指定的乘数来剪切坐标。

class

Transform

这个类是不同仿射变换的基类。

class

TransformChangedEvent

当它的任何属性发生变化时，这个事件被触发。

class

Translate

此类表示一个 Affine对象，它根据指定的因素转换坐标。

Constructors in javafx.scene.transform with parameters of type Object

Constructor

描述

TransformChangedEvent​(Object source, EventTarget target)

构造一个新的 TransformChangedEvent与指定的事件源和目标。

Uses of Object in javafx.scene.web

Subclasses of Object in javafx.scene.web

Modifier and Type

Class

描述

class

HTMLEditor

允许用户编辑文本并将样式应用于此文本的控件。

class

HTMLEditorSkin

HTML编辑器皮肤。

class

PopupFeatures

此类描述了由JavaScript window.open函数指定的Web弹出窗口的功能。

class

PromptData

该类封装了传递给JavaScript prompt()函数的数据：一条消息和一个默认值。

class

WebEngine

WebEngine是一个能够一次管理一个网页的非可视对象。

class

WebErrorEvent

一个事件指示WebEngine错误。

class

WebEvent<T>

WebEvent实例被传递到EventHandler ，注册小号WebEngine由JavaScript的网页上运行。

class

WebHistory

WebHistory类表示与WebEngine实例相关联的会话历史。

class

WebHistory.Entry

Entry类表示会话历史中的单个条目。

class

WebView

WebView是一个Node ，它管理一个WebEngine并显示其内容。

Methods in javafx.scene.web that return Object

Modifier and Type

方法

描述

Object

WebEngine.executeScript​(String script)

在当前页面的上下文中执行脚本。

Constructors in javafx.scene.web with parameters of type Object

Constructor

描述

WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)

创建一个新的 WebErrorEvent 。

WebEvent​(Object source, EventType<WebEvent> type, T data)

创建一个新的事件对象。

Uses of Object in javafx.stage

Subclasses of Object in javafx.stage

Modifier and Type

Class

描述

class

DirectoryChooser

提供对标准目录选择器对话框的支持。

class

FileChooser

提供对标准平台文件对话框的支持。

static class

FileChooser.ExtensionFilter

定义一个扩展过滤器，用于过滤可以在FileDialog中根据文件扩展名选择哪些文件。

class

Popup

弹出窗口是用于场景图形的特殊的类似窗口的容器。

class

PopupWindow

PopupWindow是各种不同类型的基于弹出窗口的窗口的父级，包括Popup和Tooltip以及ContextMenu 。

class

Screen

描述诸如监视器之类的图形目的地的特征。

class

Stage

JavaFX Stage类是顶级的JavaFX容器。

class

Window

托管场景的顶层窗口，用户与之交互的顶级窗口。

class

WindowEvent

与窗口显示/隐藏操作相关的事件。

Methods in javafx.stage that return Object

Modifier and Type

方法

描述

Object

Window.getUserData​()

返回先前设置的Object属性，如果没有使用 Window.setUserData(java.lang.Object)方法设置此属性，则返回null。

Methods in javafx.stage that return types with arguments of type Object

Modifier and Type

方法

描述

ObservableMap<Object,Object>

Window.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

ObservableMap<Object,Object>

Window.getProperties​()

返回此节点上属性的可观察图，主要由应用程序开发人员使用。

Methods in javafx.stage with parameters of type Object

Modifier and Type

方法

描述

WindowEvent

WindowEvent.copyFor​(Object newSource, EventTarget newTarget)

WindowEvent

WindowEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<WindowEvent> type)

用给定的字段替换给定事件的副本。

boolean

Screen.equals​(Object obj)

指示一些其他对象是否等于此。

void

Window.setUserData​(Object value)

用于设置可以在以后检索的单个Object属性的便利方法。

Uses of Object in javafx.util

Subclasses of Object in javafx.util

Modifier and Type

Class

描述

class

Duration

定义持续时间的类。

class

FXPermission

此类用于JavaFX权限。

class

Pair<K,V>

一个方便的类来表示名称 - 值对。

class

StringConverter<T>

Converter定义了字符串和对象之间的转换行为。

Methods in javafx.util with parameters of type Object

Modifier and Type

方法

描述

boolean

Duration.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Pair.equals​(Object o)

测试这个 Pair与其他 Object平等。

Uses of Object in javafx.util.converter

Subclasses of Object in javafx.util.converter

Modifier and Type

Class

描述

class

BigDecimalStringConverter

StringConverter实现BigDecimal值。

class

BigIntegerStringConverter

StringConverter实现BigInteger值。

class

BooleanStringConverter

StringConverter实现Boolean （和布尔基元）值。

class

ByteStringConverter

StringConverter实现Byte （和字节基元）值。

class

CharacterStringConverter

StringConverter实现Character （和char基元）值。

class

CurrencyStringConverter

StringConverter实施Number个值代表的货币。

class

DateStringConverter

StringConverter实现Date值。

class

DateTimeStringConverter

StringConverter代表日期和时间的Date值的实现。

class

DefaultStringConverter

StringConverter实现String值。

class

DoubleStringConverter

StringConverter实现Double （和双原语）值。

class

FloatStringConverter

StringConverter实现Float （和浮点数）值。

class

FormatStringConverter<T>

StringConverter实现可以使用Format实例。

class

IntegerStringConverter

StringConverter实现Integer （和int原语）值。

class

LocalDateStringConverter

StringConverter实现LocalDate值。

class

LocalDateTimeStringConverter

StringConverter实现LocalDateTime值。

class

LocalTimeStringConverter

StringConverter实现LocalTime的值。

class

LongStringConverter

StringConverter实现Long （和长基元）值。

class

NumberStringConverter

StringConverter实现Number值。

class

PercentageStringConverter

StringConverter实现为代表百分比的Number值。

class

ShortStringConverter

StringConverter实现Short值。

class

TimeStringConverter

StringConverter代表时间的Date值的实现。

Uses of Object in javax.accessibility

Subclasses of Object in javax.accessibility

Modifier and Type

Class

描述

class

AccessibilityProvider

用于辅助技术的服务提供商接口（SPI）。

class

AccessibleAttributeSequence

该类将共享相同连续属性集的文本的跨度以及该组属性一起收集。

class

AccessibleBundle

用于维护强类型枚举的基类。

class

AccessibleContext

AccessibleContext表示所有可访问对象返回的最小信息。

class

AccessibleHyperlink

在超文本文件中封装链接或一组链接（例如客户端图像映射）

class

AccessibleRelation

类 AccessibleRelation描述了实现 AccessibleRelation的对象与一个或多个其他对象之间的关系。

class

AccessibleRelationSet

AccessibleRelationSet类决定一个组件的关系集。

class

AccessibleResourceBundle

已过时。
从Java平台1.3版开始，此类已被弃用

class

AccessibleRole

AccessibleRole类确定组件的作用。

class

AccessibleState

AccessibleState类描述了一个组件的特定状态。

class

AccessibleStateSet

AccessibleStateSet类确定组件的状态集。

class

AccessibleTextSequence

这个类收集了文本跨度的关键细节。

Methods in javax.accessibility that return Object

Modifier and Type

方法

描述

abstract Object

AccessibleHyperlink.getAccessibleActionAnchor​(int i)

返回一个表示链接锚点的对象，适用于该链接。

abstract Object

AccessibleHyperlink.getAccessibleActionObject​(int i)

返回表示链接操作的对象，适用于该链接。

Object

AccessibleKeyBinding.getAccessibleKeyBinding​(int i)

返回此对象的键绑定。

Object[][]

AccessibleResourceBundle.getContents​()

已过时。

返回编程键和本地化显示字符串之间的映射。

Object[]

AccessibleRelation.getTarget​()

返回此关系的目标对象。

Methods in javax.accessibility with parameters of type Object

Modifier and Type

方法

描述

void

AccessibleContext.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告绑定属性更改。

void

AccessibleRelation.setTarget​(Object target)

设置此关系的目标对象。

void

AccessibleRelation.setTarget​(Object[] target)

设置此关系的目标对象。

Constructors in javax.accessibility with parameters of type Object

Constructor

描述

AccessibleRelation​(String key, Object target)

使用给定的区域设置独立键创建一个新的 AccessibleRelation 。

AccessibleRelation​(String key, Object[] target)

使用给定的区域设置独立键创建一个新的 AccessibleRelation 。

Uses of Object in javax.activation

Subclasses of Object in javax.activation

Modifier and Type

Class

描述

class

ActivationDataFlavor

ActivationDataFlavor类是 java.awt.datatransfer.DataFlavor的特殊子类。

class

CommandInfo

CommandMap实现使用CommandInfo类来描述命令请求的结果。

class

CommandMap

CommandMap类为系统中可用的命令对象的注册表提供了一个接口。

class

DataHandler

DataHandler类为许多不同来源和格式的数据提供了一致的界面。

class

FileDataSource

FileDataSource类实现了一个封装文件的简单DataSource对象。

class

FileTypeMap

FileTypeMap是一个抽象类，为文件提供数据输入界面。

class

MailcapCommandMap

MailcapCommandMap扩展了CommandMap抽象类。

class

MimeType

多功能Internet邮件扩展（MIME）类型，如RFC 2045和2046中所定义。

class

MimeTypeParameterList

RFC 2045和2046中定义的MimeType的参数列表。

class

MimeTypeParseException

封装MimeType解析相关异常的类。

class

MimetypesFileTypeMap

该类扩展了FileTypeMap，并通过其文件扩展名提供了文件的数据输入。

class

UnsupportedDataTypeException

表示请求的操作不支持请求的数据类型。

class

URLDataSource

URLDataSource类提供了一个在DataSource接口中包装一个 URL对象的对象。

Methods in javax.activation that return Object

Modifier and Type

方法

描述

Object

DataHandler.getBean​(CommandInfo cmdinfo)

一个方便的方法，它接受CommandInfo对象并实例化相应的命令，通常是一个JavaBean组件。

Object

CommandInfo.getCommandObject​(DataHandler dh, ClassLoader loader)

返回实例化的JavaBean组件。

Object

DataContentHandler.getContent​(DataSource ds)

以最优选的形式返回表示数据的对象。

Object

DataHandler.getContent​()

以其首选对象形式返回数据。

Object

DataContentHandler.getTransferData​(DataFlavor df, DataSource ds)

返回表示要传输的数据的对象。

Object

DataHandler.getTransferData​(DataFlavor flavor)

返回表示要传输的数据的对象。

Methods in javax.activation with parameters of type Object

Modifier and Type

方法

描述

void

DataContentHandler.writeTo​(Object obj, String mimeType, OutputStream os)

将对象转换为指定MIME类型的字节流，并将其写入输出流。

Constructors in javax.activation with parameters of type Object

Constructor

描述

DataHandler​(Object obj, String mimeType)

创建一个表示此MIME类型对象的 DataHandler实例。

Uses of Object in javax.activity

Subclasses of Object in javax.activity

Modifier and Type

Class

描述

class

ActivityCompletedException

可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。

class

ActivityRequiredException

如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。

class

InvalidActivityException

可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。

Uses of Object in javax.annotation.processing

Subclasses of Object in javax.annotation.processing

Modifier and Type

Class

描述

class

AbstractProcessor

一个抽象的注释处理器，被设计为大多数具体注解处理器的一个方便的超类。

class

Completions

组装Completion对象的实用类。

class

FilerException

表示Filer检测到尝试打开文件将违反Filer提供的保证。

Uses of Object in javax.crypto

Subclasses of Object in javax.crypto

Modifier and Type

Class

描述

class

AEADBadTagException

当以AEAD模式（如GCM / CCM）运行的Cipher无法验证提供的认证标记时，会抛出此异常。

class

BadPaddingException

当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。

class

Cipher

该类提供加密和解密的加密密码的功能。

class

CipherInputStream

CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。

class

CipherOutputStream

CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。

class

CipherSpi

该类定义了 Cipher类的 （ SPI ）。

class

EncryptedPrivateKeyInfo

该类实现了PKCS＃8中定义的 EncryptedPrivateKeyInfo类型。

class

ExemptionMechanism

这个类提供了豁免机制的功能，其中的例子是 密钥恢复 ， 密钥弱化和 密钥托管 。

class

ExemptionMechanismException

这是通用的ExemptionMechanism异常。

class

ExemptionMechanismSpi

该类定义了 ExemptionMechanism类的 （ SPI ）。

class

IllegalBlockSizeException

当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。

class

KeyAgreement

该类提供了密钥协议（或密钥交换）协议的功能。

class

KeyAgreementSpi

该类定义了 KeyAgreement类的 （ SPI ）。

class

KeyGenerator

该类提供了一个秘密（对称）密钥生成器的功能。

class

KeyGeneratorSpi

该类定义了 KeyGenerator类的 （ SPI ）。

class

Mac

该类提供了“消息验证码”（MAC）算法的功能。

class

MacSpi

该类定义了 Mac类的 （ SPI ）。

class

NoSuchPaddingException

当请求特定的填充机制但在环境中不可用时抛出此异常。

class

NullCipher

NullCipher类是提供“身份密码”的类，不会转换纯文本。

class

SealedObject

该类使程序员能够使用加密算法创建对象并保护其机密性。

class

SecretKeyFactory

这个类代表一个秘密密钥的工厂。

class

SecretKeyFactorySpi

该类为 SecretKeyFactory类定义了 （ SPI ）。

class

ShortBufferException

当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。

Methods in javax.crypto that return Object

Modifier and Type

方法

描述

Object

Mac.clone​()

如果提供程序实现是可克隆的，则返回克隆。

Object

MacSpi.clone​()

如果实现是可克隆的，则返回克隆。

Object

SealedObject.getObject​(Key key)

检索原始（封装）对象。

Object

SealedObject.getObject​(Key key, String provider)

检索原始（封装）对象。

Object

SealedObject.getObject​(Cipher c)

检索原始（封装）对象。

Uses of Object in javax.crypto.spec

Subclasses of Object in javax.crypto.spec

Modifier and Type

Class

描述

class

DESedeKeySpec

该类指定DES-EDE（“triple-DES”）键。

class

DESKeySpec

该类指定一个DES密钥。

class

DHGenParameterSpec

此类指定用于生成Diffie-Hellman密钥协议中使用的Diffie-Hellman（系统）参数的参数集。

class

DHParameterSpec

该类指定与PKCS＃3： Diffie-Hellman密钥协商标准中指定的Diffie-Hellman算法一起使用的参数集合。

class

DHPrivateKeySpec

该类指定具有相关参数的Diffie-Hellman私钥。

class

DHPublicKeySpec

该类指定具有相关参数的Diffie-Hellman公钥。

class

GCMParameterSpec

指定使用伽罗瓦/计数器模式（GCM）模式的Cipher所需的一组参数。

class

IvParameterSpec

该类指定 初始化向量 （IV）。

class

OAEPParameterSpec

该类指定了与OAEP填充一起使用的参数集，如 PKCS #1标准中所定义。

class

PBEKeySpec

用户选择的密码，可用于基于密码的加密（ PBE ）。

class

PBEParameterSpec

该类指定了使用密码加密（PBE）的参数集，如 PKCS #5标准中所定义。

class

PSource

该类指定了在OAEP填充中编码输入P的源，如 PKCS #1标准中定义的。

static class

PSource.PSpecified

该类用于在OAEP填充中明确指定编码输入P的值。

class

RC2ParameterSpec

该类指定与 RC2算法一起使用的参数。

class

RC5ParameterSpec

该类指定与 RC5算法一起使用的参数。

class

SecretKeySpec

该类以独立于提供商的方式指定密钥。

Methods in javax.crypto.spec with parameters of type Object

Modifier and Type

方法

描述

boolean

RC2ParameterSpec.equals​(Object obj)

测试指定对象和此对象之间的相等性。

boolean

RC5ParameterSpec.equals​(Object obj)

测试指定对象和此对象之间的相等性。

boolean

SecretKeySpec.equals​(Object obj)

测试指定对象和此对象之间的相等性。

Uses of Object in javax.imageio

Subclasses of Object in javax.imageio

Modifier and Type

Class

描述

class

IIOException

用于发信号读取和写入操作失败的异常类。

class

IIOImage

用于聚合图像的简单容器类，一组缩略图（预览）图像，以及表示与该图像相关联的元数据的对象。

class

IIOParam

描述流如何解码或编码的所有类的超类。

class

ImageIO

一个包含静态方便的方法，用于定位 ImageReader s和 ImageWriter s，并执行简单的编码和解码。

class

ImageReader

用于解析和解码图像的抽象超类。

class

ImageReadParam

描述流如何解码的类。

class

ImageTypeSpecifier

允许以方便的方式指定图像的格式（特别是其 SampleModel和 ColorModel ）的类。

class

ImageWriteParam

描述流如何编码的类。

class

ImageWriter

用于编码和写入图像的抽象超类。

Fields in javax.imageio declared as Object

Modifier and Type

Field

描述

protected Object

ImageReader.input

所述 ImageInputStream或其它 Object通过 setInput和由检索 getInput 。

protected Object

ImageWriter.output

所述 ImageOutputStream或其它 Object通过设置 setOutput ，并通过检索 getOutput 。

Methods in javax.imageio that return Object

Modifier and Type

方法

描述

Object

ImageReader.getInput​()

返回 ImageInputStream或其他 Object以前设置为输入源。

Object

ImageWriter.getOutput​()

返回 ImageOutputStream或其他 Object由最近调用的 setOutput方法设置。

Methods in javax.imageio with parameters of type Object

Modifier and Type

方法

描述

static ImageInputStream

ImageIO.createImageInputStream​(Object input)

返回一个 ImageInputStream ，它将从给定的 Object获取其输入。

static ImageOutputStream

ImageIO.createImageOutputStream​(Object output)

返回一个 ImageOutputStream ，它将其输出发送给给定的 Object 。

boolean

ImageTypeSpecifier.equals​(Object o)

如果给定的 Object是 ImageTypeSpecifier并且具有与该对象相同的 SampleModel和 ColorModel ，则返回 true 。

static Iterator<ImageReader>

ImageIO.getImageReaders​(Object input)

返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够解码所提供的 Object ，通常为 ImageInputStream 。

void

ImageReader.setInput​(Object input)

设置要用于给定的 ImageInputStream或其他 Object的输入源。

void

ImageReader.setInput​(Object input, boolean seekForwardOnly)

设置要用于给定的 ImageInputStream或其他 Object的输入源。

void

ImageReader.setInput​(Object input, boolean seekForwardOnly, boolean ignoreMetadata)

设置要用于给定的 ImageInputStream或其他 Object的输入源。

void

ImageWriter.setOutput​(Object output)

将目的地设置为给定的 ImageOutputStream或其他 Object 。

Uses of Object in javax.imageio.metadata

Subclasses of Object in javax.imageio.metadata

Modifier and Type

Class

描述

class

IIOInvalidTreeException

一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。

class

IIOMetadata

由与图像和流相关联的元数据（非图像数据）的对象扩展的抽象类。

class

IIOMetadataFormatImpl

一个具体的类提供了可重用的 IIOMetadataFormat接口的实现。

class

IIOMetadataNode

表示元数据树中的节点的类，其实现 org.w3c.dom.Element接口，并且还允许通过 getUserObject和 setUserObject方法存储非文本对象。

Methods in javax.imageio.metadata with type parameters of type Object

Modifier and Type

方法

描述

protected <T extends Object & Comparable<? super T>>
void

IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)

允许 Object要被存储在实现指定元素的节点给定类型的参考。

Methods in javax.imageio.metadata that return Object

Modifier and Type

方法

描述

Object

IIOMetadataNode.getFeature​(String feature, String version)

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

Object

IIOMetadataFormat.getObjectDefaultValue​(String elementName)

返回一个 Object s，其中包含命名元素中的 Object引用的默认值。

Object

IIOMetadataFormatImpl.getObjectDefaultValue​(String elementName)

Object[]

IIOMetadataFormat.getObjectEnumerations​(String elementName)

返回一个包含 Object的数组， Object包含命名元素中的 Object引用的合法枚举值。

Object[]

IIOMetadataFormatImpl.getObjectEnumerations​(String elementName)

Object

IIOMetadataNode.getUserData​(String key)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

Object

IIOMetadataNode.getUserObject​()

返回与此节点相关联的 Object值。

Object

IIOMetadataNode.setUserData​(String key, Object data, UserDataHandler handler)

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

Methods in javax.imageio.metadata with parameters of type Object

Modifier and Type

方法

描述

Object

IIOMetadataNode.setUserData​(String key, Object data, UserDataHandler handler)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

void

IIOMetadataNode.setUserObject​(Object userObject)

设置与该节点关联的值。

Uses of Object in javax.imageio.plugins.bmp

Subclasses of Object in javax.imageio.plugins.bmp

Modifier and Type

Class

描述

class

BMPImageWriteParam

用于编码BMP格式的图像的 ImageWriteParam的子类。

Uses of Object in javax.imageio.plugins.jpeg

Subclasses of Object in javax.imageio.plugins.jpeg

Modifier and Type

Class

描述

class

JPEGHuffmanTable

一个封装单个JPEG霍夫曼表的类。

class

JPEGImageReadParam

此类增加了在使用内置JPEG阅读器插件时设置JPEG量化和霍夫曼表的功能。

class

JPEGImageWriteParam

该类增加了在使用内置JPEG writer插件时设置JPEG量化和霍夫曼表的能力，并请求为图像计算优化的霍夫曼表。

class

JPEGQTable

一个封装单个JPEG量化表的类。

Uses of Object in javax.imageio.plugins.tiff

Subclasses of Object in javax.imageio.plugins.tiff

Modifier and Type

Class

描述

class

BaselineTIFFTagSet

表示在基准TIFF规范中找到的一组标签的类以及一些常见的附加标签。

class

ExifGPSTagSet

代表在Exif GPS Info IFD中找到的标签的类。

class

ExifInteroperabilityTagSet

代表在Exif互操作性IFD中找到的标签的类。

class

ExifParentTIFFTagSet

包含用于引用Exif和GPS IFD的TIFF标签的类。

class

ExifTIFFTagSet

代表在Exif IFD中找到的标签的类。

class

FaxTIFFTagSet

表示在 TIFF-F （RFC 2036）文件中找到的额外标签的类。

class

GeoTIFFTagSet

代表GeoTIFF IFD中找到的标签的类。

class

TIFFDirectory

简化与TIFF本地图像元数据交互的便利类。

class

TIFFField

表示TIFF 6.0图像文件目录中的字段的类。

class

TIFFImageReadParam

ImageReadParam的子类允许控制TIFF读取过程。

class

TIFFTag

定义TIFF标签概念的类。

class

TIFFTagSet

代表一组TIFF标签的类。

Methods in javax.imageio.plugins.tiff that return Object

Modifier and Type

方法

描述

static Object

TIFFField.createArrayForType​(int dataType, int count)

创建一个适合指定数据类型的数组。

Object

TIFFField.getData​()

返回与该字段关联的数据对象的引用。

Constructors in javax.imageio.plugins.tiff with parameters of type Object

Constructor

描述

TIFFField​(TIFFTag tag, int type, int count, Object data)

构造具有任意数据的 TIFFField 。

Uses of Object in javax.imageio.spi

Subclasses of Object in javax.imageio.spi

Modifier and Type

Class

描述

class

IIORegistry

服务提供商实例的注册表。

class

IIOServiceProvider

所有Image I / O服务提供商接口（SPI）通用功能的超级界面。

class

ImageInputStreamSpi

ImageInputStream的服务提供商接口（SPI）。

class

ImageOutputStreamSpi

ImageOutputStream的服务提供商接口（SPI）。

class

ImageReaderSpi

服务提供商接口（SPI），用于 ImageReader s。

class

ImageReaderWriterSpi

包含实例变量的超类和 ImageReaderSpi和 ImageWriterSpi通用的方法。

class

ImageTranscoderSpi

ImageTranscoder的服务提供商接口（SPI）

class

ImageWriterSpi

ImageWriter的服务提供商接口（SPI）。

class

ServiceRegistry

服务提供商实例的注册表。

Methods in javax.imageio.spi with parameters of type Object

Modifier and Type

方法

描述

abstract boolean

ImageReaderSpi.canDecodeInput​(Object source)

如果提供的源对象看起来是这个读者支持的格式，则返回 true 。

boolean

ServiceRegistry.contains​(Object provider)

返回 true如果 provider当前注册。

ImageInputStream

ImageInputStreamSpi.createInputStreamInstance​(Object input)

返回与此服务提供商关联的 ImageInputStream实现的实例。

abstract ImageInputStream

ImageInputStreamSpi.createInputStreamInstance​(Object input, boolean useCache, File cacheDir)

返回与该服务提供商相关联的 ImageInputStream实现的实例。

ImageOutputStream

ImageOutputStreamSpi.createOutputStreamInstance​(Object output)

返回与此服务提供商相关联的 ImageOutputStream实现的实例。

abstract ImageOutputStream

ImageOutputStreamSpi.createOutputStreamInstance​(Object output, boolean useCache, File cacheDir)

返回与此服务提供商关联的 ImageOutputStream实现的实例。

abstract ImageReader

ImageReaderSpi.createReaderInstance​(Object extension)

返回与此服务提供商关联的 ImageReader实现的实例。

abstract ImageWriter

ImageWriterSpi.createWriterInstance​(Object extension)

返回与该服务提供商相关联的 ImageWriter实现的实例。

void

ServiceRegistry.deregisterServiceProvider​(Object provider)

从包含它的所有类别中删除服务提供商对象。

boolean

ServiceRegistry.Filter.filter​(Object provider)

返回 true如果给定 provider对象通过这个定义的标准匹配 Filter 。

void

ServiceRegistry.registerServiceProvider​(Object provider)

将服务提供者对象添加到注册表。

Uses of Object in javax.imageio.stream

Subclasses of Object in javax.imageio.stream

Modifier and Type

Class

描述

class

FileCacheImageInputStream

一个 ImageInputStream的实现，从常规的 InputStream获得它的输入。

class

FileCacheImageOutputStream

一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。

class

FileImageInputStream

一个 ImageInputStream的实现，从 File或 RandomAccessFile获取它的输入。

class

FileImageOutputStream

实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。

class

IIOByteBuffer

表示对字节数组的可变引用以及该数组中的偏移量和长度的类。

class

ImageInputStreamImpl

一个实现 ImageInputStream接口的抽象类。

class

ImageOutputStreamImpl

一个实现 ImageOutputStream接口的抽象类。

class

MemoryCacheImageInputStream

一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。

class

MemoryCacheImageOutputStream

实现 ImageOutputStream将其输出写入常规的 OutputStream 。

Uses of Object in javax.jnlp

Subclasses of Object in javax.jnlp

Modifier and Type

Class

描述

static class

DownloadService2.ResourceSpec

指定资源查询的模式作为参数，并在 DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec)和 DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec)中保留结果。

class

ServiceManager

ServiceManager提供了查找JNLP服务的静态方法。

class

UnavailableServiceException

当 UnavailableServiceException不存在或不可用的服务时， ServiceManager由 UnavailableServiceException抛出。

Methods in javax.jnlp that return Object

Modifier and Type

方法

描述

static Object

ServiceManager.lookup​(String name)

向JNLP客户端询问具有给定名称的服务。

Object

ServiceManagerStub.lookup​(String name)

参见 ServiceManager.lookup(java.lang.String)的说明

Uses of Object in javax.lang.model

Subclasses of Object in javax.lang.model

Modifier and Type

Class

描述

class

UnknownEntityException

例外的超类，表示遇到一个未知类型的实体。

Uses of Object in javax.lang.model.element

Subclasses of Object in javax.lang.model.element

Modifier and Type

Class

描述

class

UnknownAnnotationValueException

表示遇到未知类型的注释值。

class

UnknownDirectiveException

表示遇到未知类型的模块指令。

class

UnknownElementException

表示遇到未知类型的元素。

Methods in javax.lang.model.element that return Object

Modifier and Type

方法

描述

Object

UnknownAnnotationValueException.getArgument​()

返回附加参数。

Object

UnknownDirectiveException.getArgument​()

返回附加参数。

Object

UnknownElementException.getArgument​()

返回附加参数。

Object

VariableElement.getConstantValue​()

如果这是一个初始化为编译 final数的 final字段，则返回此变量的值。

Object

AnnotationValue.getValue​()

返回值。

Methods in javax.lang.model.element with parameters of type Object

Modifier and Type

方法

描述

boolean

Element.equals​(Object obj)

返回 true如果参数表示相同的元件作为 this ，或 false否则。

boolean

Name.equals​(Object obj)

返回 true如果参数表示相同的名字 this和 false否则。

Constructors in javax.lang.model.element with parameters of type Object

Constructor

描述

UnknownAnnotationValueException​(AnnotationValue av, Object p)

创建一个新的 UnknownAnnotationValueException 。

UnknownDirectiveException​(ModuleElement.Directive d, Object p)

创建一个新的 UnknownElementException 。

UnknownElementException​(Element e, Object p)

创建一个新的 UnknownElementException 。

Uses of Object in javax.lang.model.type

Subclasses of Object in javax.lang.model.type

Modifier and Type

Class

描述

class

MirroredTypeException

当应用程序尝试访问对应于TypeMirror的Class对象时抛出 。

class

MirroredTypesException

当应用程序尝试访问Class对象的每个对象TypeMirror对象时抛出 。

class

UnknownTypeException

表示遇到未知类型的类型。

Methods in javax.lang.model.type that return Object

Modifier and Type

方法

描述

Object

UnknownTypeException.getArgument​()

返回附加参数。

Methods in javax.lang.model.type with parameters of type Object

Modifier and Type

方法

描述

boolean

TypeMirror.equals​(Object obj)

遵守 Object.equals的一般合同。

Constructors in javax.lang.model.type with parameters of type Object

Constructor

描述

UnknownTypeException​(TypeMirror t, Object p)

创建新的UnknownTypeException可以使用p参数传递附加参数，其中包含遇到未知类型的上下文的信息; 例如， TypeVisitor的访问方法可能会传入其附加参数。

Uses of Object in javax.lang.model.util

Subclasses of Object in javax.lang.model.util

Modifier and Type

Class

描述

class

AbstractAnnotationValueVisitor6<R,P>

注释值的骨架访问者，默认行为适用于 RELEASE_6源版本。

class

AbstractAnnotationValueVisitor7<R,P>

具有默认行为的注释值的骨架访问者适用于 RELEASE_7源版本。

class

AbstractAnnotationValueVisitor8<R,P>

注释值的骨骼访问者，具有适合 RELEASE_8源版本的默认行为。

class

AbstractAnnotationValueVisitor9<R,P>

注释值的骨架访问者，具有适用于 RELEASE_9源版本的默认行为。

class

AbstractElementVisitor6<R,P>

程序元素的骨架访问者，默认行为适用于 RELEASE_6源版本。

class

AbstractElementVisitor7<R,P>

程序元素的骨架访问者，默认行为适用于 RELEASE_7源版本。

class

AbstractElementVisitor8<R,P>

具有适用于 RELEASE_8源版本的默认行为的程序元素的骨架访问者。

class

AbstractElementVisitor9<R,P>

具有适用于 RELEASE_9源版本的默认行为的程序元素的骨架访问者。

class

AbstractTypeVisitor6<R,P>

类型的骨骼访问者，具有适合 RELEASE_6源版本的默认行为。

class

AbstractTypeVisitor7<R,P>

类型的骨骼访问者，默认行为适用于 RELEASE_7源版本。

class

AbstractTypeVisitor8<R,P>

类型的骨骼访问者，具有适合 RELEASE_8源版本的默认行为。

class

AbstractTypeVisitor9<R,P>

具有适用于 RELEASE_9源版本的默认行为类型的骨架访问者。

class

ElementFilter

用于从元素集合中仅选择感兴趣元素的过滤器。

class

ElementKindVisitor6<R,P>

程序元素的访问者基于他们的kind默认行为适合RELEASE_6源版本。

class

ElementKindVisitor7<R,P>

程序元素的访问者基于他们的kind ，默认行为适用于RELEASE_7源版本。

class

ElementKindVisitor8<R,P>

基于他们的kind的程序元素的访问者 ，默认行为适用于RELEASE_8源版本。

class

ElementKindVisitor9<R,P>

基于他们的kind程序元素的访问者 ，默认行为适用于RELEASE_9源版本。

class

ElementScanner6<R,P>

具有默认行为的程序元素的扫描访问者适用于 RELEASE_6源版本。

class

ElementScanner7<R,P>

具有适用于 RELEASE_7源版本的默认行为的程序元素的扫描访问者。

class

ElementScanner8<R,P>

具有适用于 RELEASE_8源版本的默认行为的程序元素的扫描访问者。

class

ElementScanner9<R,P>

具有适用于 RELEASE_9源版本的默认行为的程序元素的扫描访问者。

class

SimpleAnnotationValueVisitor6<R,P>

注释值的简单访问者，默认行为适用于 RELEASE_6源版本。

class

SimpleAnnotationValueVisitor7<R,P>

注释值的简单访问者，默认行为适用于 RELEASE_7源版本。

class

SimpleAnnotationValueVisitor8<R,P>

注释值的简单访问者，默认行为适用于 RELEASE_8源版本。

class

SimpleAnnotationValueVisitor9<R,P>

注释值的简单访问者，默认行为适用于 RELEASE_9源版本。

class

SimpleElementVisitor6<R,P>

一个简单的程序元素访问者，默认行为适合 RELEASE_6源版本。

class

SimpleElementVisitor7<R,P>

程序元素的简单访问者，默认行为适用于 RELEASE_7源版本。

class

SimpleElementVisitor8<R,P>

程序元素的简单访问者，默认行为适用于 RELEASE_8源版本。

class

SimpleElementVisitor9<R,P>

一个简单的访问程序元素的默认行为适合 RELEASE_9源版本。

class

SimpleTypeVisitor6<R,P>

类型的简单访问者，默认行为适用于 RELEASE_6源版本。

class

SimpleTypeVisitor7<R,P>

类型的简单访问者，默认行为适合 RELEASE_7源版本。

class

SimpleTypeVisitor8<R,P>

类型的简单访问者，默认行为适合 RELEASE_8源版本。

class

SimpleTypeVisitor9<R,P>

类型的简单访问者，默认行为适用于 RELEASE_9源版本。

class

TypeKindVisitor6<R,P>

基于他们的kind类型的访问者的默认行为适合RELEASE_6源版本。

class

TypeKindVisitor7<R,P>

基于他们的kind类型的访问者 ，默认行为适用于RELEASE_7源版本。

class

TypeKindVisitor8<R,P>

基于他们的kind类型的访问者的默认行为适合RELEASE_8源版本。

class

TypeKindVisitor9<R,P>

基于他们的kind类型的访问者的默认行为适合RELEASE_9源版本。

Fields in javax.lang.model.util declared as Object

Modifier and Type

Field

描述

protected R

ElementScanner6.DEFAULT_VALUE

指定的默认值。

protected R

SimpleAnnotationValueVisitor6.DEFAULT_VALUE

要返回的默认值; defaultAction返回此值，除非该方法被覆盖。

protected R

SimpleElementVisitor6.DEFAULT_VALUE

要返回的默认值; defaultAction返回此值，除非该方法被覆盖。

protected R

SimpleTypeVisitor6.DEFAULT_VALUE

要返回的默认值; defaultAction返回此值，除非该方法被覆盖。

Methods in javax.lang.model.util with parameters of type Object

Modifier and Type

方法

描述

protected R

SimpleAnnotationValueVisitor6.defaultAction​(Object o, P p)

访问方法的默认操作。

String

Elements.getConstantExpression​(Object value)

返回表示原始值或字符串的 常量表达式的文本。

Uses of Object in javax.management

Subclasses of Object in javax.management

Modifier and Type

Class

描述

class

Attribute

通过将其名称与其值相关联来表示MBean属性。

class

AttributeChangeNotification

提供MBean发送的属性更改通知的定义。

class

AttributeChangeNotificationFilter

这个类实现了NotificationFilter接口的attribute change notification 。

class

AttributeList

表示MBean属性值的列表。

class

AttributeNotFoundException

指定的属性不存在或无法检索。

class

AttributeValueExp

表示用作关系约束的参数的属性。

class

BadAttributeValueExpException

当无效的MBean属性传递给查询构造方法时抛出。

class

BadBinaryOpValueExpException

当无效表达式传递给构造查询的方法时抛出。

class

BadStringOperationException

当无效的字符串操作传递给构造查询的方法时抛出。

class

DefaultLoaderRepository

已过时。
改用MBeanServer.getClassLoaderRepository() 。

class

ImmutableDescriptor

一个不可变的描述符。

class

InstanceAlreadyExistsException

MBean已经在存储库中注册。

class

InstanceNotFoundException

存储库中不存在指定的MBean。

class

IntrospectionException

在MBean的内省期间发生了一个例外。

class

InvalidApplicationException

当尝试应用以下任一操作时抛出：将MBean的子查询表达式或对错误类的MBean的限定属性表达式。

class

InvalidAttributeValueException

指定的值对属性无效。

class

JMException

JMX实现抛出异常。

class

JMRuntimeException

JMX实现发出的运行时异常。

class

JMX

来自JMX API的静态方法。

class

ListenerNotFoundException

存储库中不存在指定的MBean侦听器。

class

MalformedObjectNameException

字符串的格式不对应于有效的ObjectName。

class

MBeanAttributeInfo

描述为管理而公开的MBean属性。

class

MBeanConstructorInfo

描述由MBean公开的构造函数。

class

MBeanException

表示代理中MBean方法抛出的“用户定义”异常。

class

MBeanFeatureInfo

提供MBean描述符对象的一般信息。

class

MBeanInfo

描述MBean暴露的管理界面; 即可用于管理操作的一组属性和操作。

class

MBeanNotificationInfo

MBeanNotificationInfo类用于描述针对给定Java类通知的MBean发出的不同通知实例的特征。

class

MBeanOperationInfo

描述MBean公开的管理操作。

class

MBeanParameterInfo

描述MBean暴露的操作的参数。

class

MBeanPermission

控制访问MBeanServer操作的权限。

class

MBeanRegistrationException

包含由preRegister（）引发的异常，preDeregister（）方法的 MBeanRegistration接口。

class

MBeanServerBuilder

此类表示构建器，它创建默认的MBeanServer实现。

class

MBeanServerDelegate

从管理的角度来看MBean服务器。

class

MBeanServerFactory

提供MBean服务器引用。

class

MBeanServerInvocationHandler

InvocationHandler将MBean管理界面中的方法通过MBean服务器转发到MBean。

class

MBeanServerNotification

表示MBean服务器通过MBeanServerDelegate MBean发出的通知。

class

MBeanServerPermission

A执行与MBeanServers有关的操作的权限。

class

MBeanTrustPermission

此权限在签名者或代码库中表示“信任”。

class

NotCompliantMBeanException

尝试在不符合JMX的MBean的MBean服务器中注册对象时发生的异常。

class

Notification

Notification类表示由MBean发出的通知。

class

NotificationBroadcasterSupport

提供NotificationEmitter接口的实现。

class

NotificationFilterSupport

提供NotificationFilter接口的实现。

class

ObjectInstance

用于表示MBean的对象名称及其类名。

class

ObjectName

表示MBean的对象名称，或可匹配多个MBean名称的模式。

class

OperationsException

表示对MBean执行操作时MBean服务器中抛出的异常。

class

Query

构造查询对象约束。

class

QueryEval

允许在特定MBean服务器的上下文中执行查询。

class

ReflectionException

表示在使用java.lang.reflect类调用MBean方法时，MBean服务器中抛出的异常。

class

RuntimeErrorException

当 java.lang.Error发生 java.lang.Error时，应该被捕获并重新抛出为 RuntimeErrorException 。

class

RuntimeMBeanException

表示代理中MBean方法抛出的运行时异常。

class

RuntimeOperationsException

表示在对MBean执行操作时在代理中抛出的运行时异常。

class

ServiceNotFoundException

表示不支持请求的服务时引发的异常。

class

StandardEmitterMBean

一个MBean，其管理接口由Java接口上的反射决定，并发出通知。

class

StandardMBean

一个MBean，其管理界面由Java接口上的反射决定。

class

StringValueExp

表示作为关系约束的参数的字符串。

Fields in javax.management declared as Object

Modifier and Type

Field

描述

protected Object

Notification.source

该字段隐藏了父类中的 EventObject.source字段，使其成为非瞬态，因此是序列化形式的一部分。

Methods in javax.management that return Object

Modifier and Type

方法

描述

Object

Descriptor.clone​()

返回一个等于该描述符的描述符。

Object

MBeanAttributeInfo.clone​()

返回此实例的浅克隆。

Object

MBeanConstructorInfo.clone​()

返回此实例的浅克隆。

Object

MBeanInfo.clone​()

返回此实例的浅克隆。

Object

MBeanNotificationInfo.clone​()

返回此实例的浅克隆。

Object

MBeanOperationInfo.clone​()

返回此实例的浅克隆。

Object

MBeanParameterInfo.clone​()

返回此实例的浅克隆。

protected Object

AttributeValueExp.getAttribute​(ObjectName name)

返回指定的MBean中给定属性的值。

Object

DynamicMBean.getAttribute​(String attribute)

获取动态MBean的特定属性的值。

Object

MBeanServer.getAttribute​(ObjectName name, String attribute)

Object

MBeanServerConnection.getAttribute​(ObjectName name, String attribute)

获取命名MBean的特定属性的值。

Object

StandardMBean.getAttribute​(String attribute)

Object

Descriptor.getFieldValue​(String fieldName)

返回特定字段名称的值，如果该名称没有值，则返回null。

Object

ImmutableDescriptor.getFieldValue​(String fieldName)

Object[]

Descriptor.getFieldValues​(String... fieldNames)

将描述符中的所有字段值作为对象数组返回。

Object[]

ImmutableDescriptor.getFieldValues​(String... fieldNames)

Object

StandardMBean.getImplementation​()

获取此标准MBean（或MXBean）的实现。

Object

AttributeChangeNotification.getNewValue​()

获取已更改的属性的新值。

Object

AttributeChangeNotification.getOldValue​()

获取已更改的属性的旧值。

Object

Notification.getUserData​()

获取用户数据。

Object

Attribute.getValue​()

返回作为此属性值的Object。

Object

MBeanServer.instantiate​(String className)

使用在MBean服务器的Class Loader Repository中注册的所有类加载器的列表来实例化对象。

Object

MBeanServer.instantiate​(String className, Object[] params, String[] signature)

使用在MBean服务器Class Loader Repository中注册的所有类加载器的列表来实例化一个对象。

Object

MBeanServer.instantiate​(String className, ObjectName loaderName)

使用由其 ObjectName指定的类Loader来实例化一个对象。

Object

MBeanServer.instantiate​(String className, ObjectName loaderName, Object[] params, String[] signature)

实例化一个对象。

Object

DynamicMBean.invoke​(String actionName, Object[] params, String[] signature)

允许在动态MBean上调用操作。

Object

MBeanServer.invoke​(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke​(ObjectName name, String operationName, Object[] params, String[] signature)

调用MBean上的操作。

Object

MBeanServerInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

Object

StandardMBean.invoke​(String actionName, Object[] params, String[] signature)

Object

AttributeList.set​(int index, Object element)

用指定的元素替换此列表中指定位置的元素。

Methods in javax.management with parameters of type Object

Modifier and Type

方法

描述

void

AttributeList.add​(int index, Object element)

在此列表中的指定位置插入指定的元素。

boolean

AttributeList.add​(Object element)

将指定的元素追加到此列表的末尾。

void

MBeanServer.addNotificationListener​(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

将一个监听器添加到注册的MBean。

void

MBeanServer.addNotificationListener​(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

将一个监听器添加到注册的MBean。

void

MBeanServerConnection.addNotificationListener​(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

将一个监听器添加到注册的MBean。

void

MBeanServerConnection.addNotificationListener​(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

将一个监听器添加到注册的MBean。

void

MBeanServerDelegate.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationBroadcaster.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

添加一个监听器到这个MBean。

void

NotificationBroadcasterSupport.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

添加一个监听器。

void

StandardEmitterMBean.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

ObjectInstance

MBeanServer.createMBean​(String className, ObjectName name, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServer.createMBean​(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServerConnection.createMBean​(String className, ObjectName name, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServerConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

boolean

Attribute.equals​(Object object)

将当前属性对象与另一个属性对象进行比较。

boolean

Descriptor.equals​(Object obj)

将此描述符与给定对象进行比较。

boolean

ImmutableDescriptor.equals​(Object o)

将此描述符与给定对象进行比较。

boolean

MBeanAttributeInfo.equals​(Object o)

将此MBeanAttributeInfo与另一个进行比较。

boolean

MBeanConstructorInfo.equals​(Object o)

将此MBeanConstructorInfo与另一个进行比较。

boolean

MBeanFeatureInfo.equals​(Object o)

将此MBeanFeatureInfo与另一个进行比较。

boolean

MBeanInfo.equals​(Object o)

将此MBeanInfo与另一个进行比较。

boolean

MBeanNotificationInfo.equals​(Object o)

将此MBeanNotificationInfo与另一个进行比较。

boolean

MBeanOperationInfo.equals​(Object o)

将此MBeanOperationInfo与另一个进行比较。

boolean

MBeanParameterInfo.equals​(Object o)

将此MBeanParameterInfo与另一个进行比较。

boolean

MBeanPermission.equals​(Object obj)

检查两个MBeanPermission对象是否相等。

boolean

MBeanServerPermission.equals​(Object obj)

检查两个MBeanServerPermission对象是否相等。

boolean

ObjectInstance.equals​(Object object)

将当前对象实例与另一个对象实例进行比较。

boolean

ObjectName.equals​(Object object)

将当前对象名称与另一个对象名称进行比较。

protected MBeanConstructorInfo[]

StandardMBean.getConstructors​(MBeanConstructorInfo[] ctors, Object impl)

自定义钩子：获取将在此MBean返回的MBeanInfo中使用的MBeanConstructorInfo []。

protected void

NotificationBroadcasterSupport.handleNotification​(NotificationListener listener, Notification notif, Object handback)

为每个侦听器调用此方法 sendNotification才能将该通知发送给该侦听器。

void

NotificationListener.handleNotification​(Notification notification, Object handback)

JMX通知发生时调用。

Object

MBeanServer.instantiate​(String className, Object[] params, String[] signature)

使用在MBean服务器Class Loader Repository中注册的所有类加载器的列表来实例化对象。

Object

MBeanServer.instantiate​(String className, ObjectName loaderName, Object[] params, String[] signature)

实例化一个对象。

Object

DynamicMBean.invoke​(String actionName, Object[] params, String[] signature)

允许在动态MBean上调用操作。

Object

MBeanServer.invoke​(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke​(ObjectName name, String operationName, Object[] params, String[] signature)

调用MBean上的操作。

Object

MBeanServerInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

Object

StandardMBean.invoke​(String actionName, Object[] params, String[] signature)

ObjectInstance

MBeanServer.registerMBean​(Object object, ObjectName name)

使用MBean服务器将一个预先存在的对象注册为MBean。

void

MBeanServer.removeNotificationListener​(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServer.removeNotificationListener​(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.removeNotificationListener​(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

从注册的MBean中删除一个监听器。

void

MBeanServerConnection.removeNotificationListener​(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

从注册的MBean中删除一个监听器。

void

MBeanServerDelegate.removeNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationBroadcasterSupport.removeNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationEmitter.removeNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

从这个MBean中删除一个监听器。

void

StandardEmitterMBean.removeNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

Object

AttributeList.set​(int index, Object element)

用指定的元素替换此列表中指定位置的元素。

void

Descriptor.setField​(String fieldName, Object fieldValue)

设置特定字段名称的值。

void

ImmutableDescriptor.setField​(String fieldName, Object fieldValue)

此操作不受支持，因为此类是不可变的。

void

Descriptor.setFields​(String[] fieldNames, Object[] fieldValues)

将字段名称数组中的所有字段设置为字段值数组中具有相同索引的新值。

void

ImmutableDescriptor.setFields​(String[] fieldNames, Object[] fieldValues)

此操作不受支持，因为此类是不可变的。

void

StandardMBean.setImplementation​(Object implementation)

替换包含在该对象中的实现对象。

void

Notification.setSource​(Object source)

设置源。

void

Notification.setUserData​(Object userData)

设置用户数据。

Constructors in javax.management with parameters of type Object

Constructor

描述

Attribute​(String name, Object value)

构造一个将给定属性名称与给定值相关联的属性对象。

AttributeChangeNotification​(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)

构造属性更改通知对象。

BadAttributeValueExpException​(Object val)

使用指定的Object构造一个BadAttributeValueExpException来创建toString（）值。

ImmutableDescriptor​(String[] fieldNames, Object[] fieldValues)

构造一个包含给定字段和值的描述符。

InvalidApplicationException​(Object val)

构造一个 InvalidApplicationException与指定的 Object 。

MBeanServerNotification​(String type, Object source, long sequenceNumber, ObjectName objectName)

创建一个MBeanServerNotification对象，指定导致通知的MBean的对象名称和指定的通知类型。

Notification​(String type, Object source, long sequenceNumber)

创建Notification对象。

Notification​(String type, Object source, long sequenceNumber, long timeStamp)

创建Notification对象。

Notification​(String type, Object source, long sequenceNumber, long timeStamp, String message)

创建Notification对象。

Notification​(String type, Object source, long sequenceNumber, String message)

创建Notification对象。

Uses of Object in javax.management.loading

Subclasses of Object in javax.management.loading

Modifier and Type

Class

描述

class

DefaultLoaderRepository

已过时。
改用MBeanServer.getClassLoaderRepository() 。

class

MLet

允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。

class

MLetContent

该类代表 MLET标签的内容。

class

PrivateMLet

没有添加到ClassLoaderRepository的MLet。

Methods in javax.management.loading that return types with arguments of type Object

Modifier and Type

方法

描述

Set<Object>

MLet.getMBeansFromURL​(String url)

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

Set<Object>

MLet.getMBeansFromURL​(URL url)

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

Set<Object>

MLetMBean.getMBeansFromURL​(String url)

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

Set<Object>

MLetMBean.getMBeansFromURL​(URL url)

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

Uses of Object in javax.management.modelmbean

Subclasses of Object in javax.management.modelmbean

Modifier and Type

Class

描述

class

DescriptorSupport

此类表示一个ModelMBean元素的元数据集。

class

InvalidTargetObjectTypeException

指定无效目标对象类型时抛出异常。

class

ModelMBeanAttributeInfo

ModelMBeanAttributeInfo对象描述了ModelMBean的属性。

class

ModelMBeanConstructorInfo

ModelMBeanConstructorInfo对象描述了ModelMBean的构造函数。

class

ModelMBeanInfoSupport

此类表示ModelMBeans的元数据。

class

ModelMBeanNotificationInfo

ModelMBeanNotificationInfo对象描述了由ModelMBean发出的通知。

class

ModelMBeanOperationInfo

ModelMBeanOperationInfo对象描述了ModelMBean的管理操作。

class

RequiredModelMBean

这个类是一个ModelMBean的实现。

class

XMLParseException

当将XML格式化的字符串解析为ModelMBean对象或从ModelMBean对象创建XML格式的字符串时，将抛出此异常。

Methods in javax.management.modelmbean that return Object

Modifier and Type

方法

描述

Object

DescriptorSupport.clone​()

返回与描述符重复的新描述符。

Object

ModelMBeanAttributeInfo.clone​()

创建并返回一个新的ModelMBeanAttributeInfo，它与此ModelMBeanAttributeInfo重复。

Object

ModelMBeanConstructorInfo.clone​()

创建并返回一个新的ModelMBeanConstructorInfo，它与此ModelBeanConstructorInfo重复。

Object

ModelMBeanInfo.clone​()

创建并返回此对象的副本。

Object

ModelMBeanInfoSupport.clone​()

返回此实例的浅克隆。

Object

ModelMBeanNotificationInfo.clone​()

创建并返回一个新的ModelMBeanNotificationInfo，它与此ModelMBeanNotificationInfo重复。

Object

ModelMBeanOperationInfo.clone​()

创建并返回一个与此ModelMBeanOperationInfo重复的新ModelMBeanOperationInfo。

Object

RequiredModelMBean.getAttribute​(String attrName)

返回为此ModelMBean定义的特定属性的值。

Object

DescriptorSupport.getFieldValue​(String fieldName)

Object[]

DescriptorSupport.getFieldValues​(String... fieldNames)

Object

RequiredModelMBean.invoke​(String opName, Object[] opArgs, String[] sig)

通过或者通过RequiredModelMBean调用方法，并返回方法执行的结果。

Methods in javax.management.modelmbean with parameters of type Object

Modifier and Type

方法

描述

void

ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener​(NotificationListener listener, String attributeName, Object handback)

注册一个实现NotificationListener接口的对象作为监听器。

void

RequiredModelMBean.addAttributeChangeNotificationListener​(NotificationListener inlistener, String inAttributeName, Object inhandback)

void

RequiredModelMBean.addNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

注册一个实现NotificationListener接口的对象作为监听器。

boolean

DescriptorSupport.equals​(Object o)

将此描述符与给定对象进行比较。

Object

RequiredModelMBean.invoke​(String opName, Object[] opArgs, String[] sig)

通过或者通过RequiredModelMBean调用方法，并返回方法执行的结果。

void

RequiredModelMBean.removeNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

void

DescriptorSupport.setField​(String fieldName, Object fieldValue)

void

DescriptorSupport.setFields​(String[] fieldNames, Object[] fieldValues)

void

ModelMBean.setManagedResource​(Object mr, String mr_type)

设置要在此ModelMBean管理界面（MBeanInfo和Descriptors）中执行所有方法的对象的实例句柄。

void

RequiredModelMBean.setManagedResource​(Object mr, String mr_type)

设置要在此ModelMBean管理界面（MBeanInfo和Descriptors）中执行所有方法的对象的实例句柄。

Constructors in javax.management.modelmbean with parameters of type Object

Constructor

描述

DescriptorSupport​(String[] fieldNames, Object[] fieldValues)

构造器获取字段名称和字段值。

Uses of Object in javax.management.monitor

Subclasses of Object in javax.management.monitor

Modifier and Type

Class

描述

class

CounterMonitor

定义监视器MBean，用于观察计数器属性的值。

class

GaugeMonitor

定义一个监视器MBean，用于观察仪表属性的值。

class

Monitor

定义所有监视器MBean的通用部分。

class

MonitorNotification

提供监视器MBean发送的通知的定义。

class

MonitorSettingException

监视器设置在监视器运行时无效时由监视器抛出异常。

class

StringMonitor

定义一个监视器MBean，用于观察字符串属性的值。

Methods in javax.management.monitor that return Object

Modifier and Type

方法

描述

Object

MonitorNotification.getDerivedGauge​()

获取此监视器通知的派生量规。

Object

MonitorNotification.getTrigger​()

获取触发此监视器通知的阈值/字符串（取决于监视器类型）。

Uses of Object in javax.management.openmbean

Subclasses of Object in javax.management.openmbean

Modifier and Type

Class

描述

class

ArrayType<T>

所述 ArrayType类是 开放类型类，其实例描述了作为 开放数据值的n维阵列所有 打开的 数据值。

class

CompositeDataInvocationHandler

一个InvocationHandler ，它将getter方法转发到一个CompositeData 。

class

CompositeDataSupport

CompositeDataSupport类是实现 CompositeData接口的 开放数据类。

class

CompositeType

CompositeType类是开放类，其实例描述了CompositeData值的类型。

class

InvalidKeyException

抛出此运行时异常以指示预期为 复合数据的项名称或 表格数据的行索引的方法参数无效。

class

InvalidOpenTypeException

抛出此运行时异常以指示 打开的类型的 打开数据值不是预期的。

class

KeyAlreadyExistsException

抛出此运行时异常以指示要添加到 表格数据实例的行的索引已被用于引用此 表格数据实例中的另一行。

class

OpenDataException

当 打开类型 ， 打开数据或 打开的MBean元数据信息实例无法构造时，抛出此检查的异常，因为一个或多个有效性约束不被满足。

class

OpenMBeanAttributeInfoSupport

描述一个打开的MBean的属性。

class

OpenMBeanConstructorInfoSupport

描述一个开放MBean的构造函数。

class

OpenMBeanInfoSupport

OpenMBeanInfoSupport类描述了一个开放的MBean的管理信息：它是一个MBeanInfo的子类，它实现了OpenMBeanInfo接口。

class

OpenMBeanOperationInfoSupport

描述一个Open MBean的操作。

class

OpenMBeanParameterInfoSupport

描述在开放MBean的一个或多个操作或构造函数中使用的参数。

class

OpenType<T>

OpenType类是描述开放数据值的实际 开放类型的所有类的父抽象类。

class

SimpleType<T>

SimpleType类是开放类型，其实例描述了既不是数组，也不是CompositeData值的所有打开的数据值，也不包括TabularData值。

class

TabularDataSupport

TabularDataSupport类是 开放数据类，它实现了 TabularData和 Map接口，内部基于哈希映射数据结构。

class

TabularType

TabularType类是开放类，其实例描述了TabularData值的类型。

Methods in javax.management.openmbean that return Object

Modifier and Type

方法

描述

Object[]

TabularData.calculateIndex​(CompositeData value)

计算此 TabularData实例中使用的索引，以引用指定的复合数据 值参数（如果已添加到此实例）。

Object[]

TabularDataSupport.calculateIndex​(CompositeData value)

计算此 TabularData实例中将使用的索引，以引用指定的复合数据 值参数（如果已添加到此实例）。

Object

TabularDataSupport.clone​()

返回此 TabularDataSupport实例的克隆：通过调用 super.clone()获取克隆，然后克隆底层地图。

Object

CompositeData.get​(String key)

返回名称为 key的项目的值。

Object

CompositeDataSupport.get​(String key)

返回名称为 key的项目的值。

Object

TabularDataSupport.get​(Object key)

这个方法只需调用 get((Object[]) key) 。

Object[]

CompositeData.getAll​(String[] keys)

返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。

Object[]

CompositeDataSupport.getAll​(String[] keys)

返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。

Object

OpenMBeanAttributeInfoSupport.getDefaultValue​()

返回此 OpenMBeanAttributeInfoSupport实例描述的属性的默认值（如果指定），否则 null 。

Object

OpenMBeanParameterInfo.getDefaultValue​()

返回此参数的默认值（如果有），否则 null 。

Object

OpenMBeanParameterInfoSupport.getDefaultValue​()

返回此 OpenMBeanParameterInfoSupport实例描述的参数的默认值（如果指定），否则 null 。

Object

CompositeDataInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

Object

TabularDataSupport.put​(Object key, Object value)

该方法简单地调用 put((CompositeData) value) ，因此忽略其 关键参数，可以是 null 。

Object

SimpleType.readResolve​()

使用该值的唯一实例替换从ObjectInputStream读取的对象。

Object

TabularDataSupport.remove​(Object key)

这个方法只需调用 remove((Object[]) key) 。

Methods in javax.management.openmbean that return types with arguments of type Object

Modifier and Type

方法

描述

Set<Map.Entry<Object,Object>>

TabularDataSupport.entrySet​()

返回此 TabularDataSupport实例中包含的行映射索引的集合视图。

Set<Map.Entry<Object,Object>>

TabularDataSupport.entrySet​()

返回此 TabularDataSupport实例中包含的行映射索引的集合视图。

Set<Object>

TabularDataSupport.keySet​()

返回用于对行进行索引的此 TabularDataSupport实例的底层映射中包含的键的集视图。

Collection<Object>

TabularDataSupport.values​()

返回此 TabularDataSupport实例中包含的行的集合视图。

Methods in javax.management.openmbean with parameters of type Object

Modifier and Type

方法

描述

boolean

TabularData.containsKey​(Object[] key)

当且仅当该 TabularData实例包含索引为指定 键的 CompositeData值（即一行）时，返回 true 。

boolean

TabularDataSupport.containsKey​(Object key)

如果此 TabularData实例包含索引为指定 键的 CompositeData值（即一行），则返回 true 。

boolean

TabularDataSupport.containsKey​(Object[] key)

返回 true当且仅当此 TabularData实例包含索引为指定 键的 CompositeData值（即一行）时。

boolean

CompositeData.containsValue​(Object value)

返回 true当且仅当此 CompositeData实例包含其值是一个项目 value 。

boolean

CompositeDataSupport.containsValue​(Object value)

返回 true当且仅当此 CompositeData实例包含其值是一个项目 value 。

boolean

TabularDataSupport.containsValue​(Object value)

当且仅当此 TabularData实例包含指定值时，返回 true 。

boolean

ArrayType.equals​(Object obj)

将指定的 obj参数与此 ArrayType实例相比较。

boolean

CompositeData.equals​(Object obj)

将指定的 obj参数与此 CompositeData实例进行比较以获得相等性。

boolean

CompositeDataSupport.equals​(Object obj)

将指定的 obj参数与此 CompositeDataSupport实例进行比较以获得相等性。

boolean

CompositeType.equals​(Object obj)

将指定的 obj参数与此 CompositeType实例相比较。

boolean

OpenMBeanAttributeInfo.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanAttributeInfo实例进行比较以获得相等性。

boolean

OpenMBeanAttributeInfoSupport.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanAttributeInfoSupport实例相比较。

boolean

OpenMBeanConstructorInfo.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanConstructorInfo实例进行比较以获得相等性。

boolean

OpenMBeanConstructorInfoSupport.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanConstructorInfoSupport实例进行比较以获得相等性。

boolean

OpenMBeanInfo.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanInfo实例相比较。

boolean

OpenMBeanInfoSupport.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanInfoSupport实例进行比较以获得相等性。

boolean

OpenMBeanOperationInfo.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanOperationInfo实例进行比较以获得相等性。

boolean

OpenMBeanOperationInfoSupport.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanOperationInfoSupport实例相比较。

boolean

OpenMBeanParameterInfo.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanParameterInfo实例进行比较，以实现相等。

boolean

OpenMBeanParameterInfoSupport.equals​(Object obj)

将指定的 obj参数与此 OpenMBeanParameterInfoSupport实例进行比较以获得相等性。

abstract boolean

OpenType.equals​(Object obj)

将指定的 obj参数与此打开类型的实例进行比较以获得相等性。

boolean

SimpleType.equals​(Object obj)

将指定的 obj参数与此 SimpleType实例进行比较，以实现相等。

boolean

TabularData.equals​(Object obj)

将指定的 obj参数与此 TabularData实例进行比较以获得相等性。

boolean

TabularDataSupport.equals​(Object obj)

将指定的 obj参数与此 TabularDataSupport实例进行比较，以实现相等。

boolean

TabularType.equals​(Object obj)

将指定的 obj参数与此 TabularType实例进行比较以获得相等性。

CompositeData

TabularData.get​(Object[] key)

返回 CompositeData值，其指数是 关键 ，或 null如果没有值映射到 按键 ，在此 TabularData实例。

Object

TabularDataSupport.get​(Object key)

这个方法只需调用 get((Object[]) key) 。

CompositeData

TabularDataSupport.get​(Object[] key)

在这个 TabularData实例中，如果没有值映射到 键 ，则返回其索引为 key的 CompositeData值，或 null 。

Object

CompositeDataInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

boolean

ArrayType.isValue​(Object obj)

测试 obj是否为此 ArrayType实例的值。

boolean

CompositeType.isValue​(Object obj)

测试 obj是否可以由此 CompositeType实例描述的值。

boolean

OpenMBeanAttributeInfoSupport.isValue​(Object obj)

测试 obj是 OpenMBeanAttributeInfoSupport实例描述的属性的 OpenMBeanAttributeInfoSupport 。

boolean

OpenMBeanParameterInfo.isValue​(Object obj)

测试 obj是否为 OpenMBeanParameterInfo实例描述的参数的 OpenMBeanParameterInfo 。

boolean

OpenMBeanParameterInfoSupport.isValue​(Object obj)

测试 obj是 OpenMBeanParameterInfo实例描述的参数的 OpenMBeanParameterInfo 。

abstract boolean

OpenType.isValue​(Object obj)

测试 obj是否是此打开类型的值。

boolean

SimpleType.isValue​(Object obj)

测试 obj是否为此 SimpleType实例的值。

boolean

TabularType.isValue​(Object obj)

测试 obj是否可以由此 TabularType实例描述的值。

Object

TabularDataSupport.put​(Object key, Object value)

该方法简单地调用 put((CompositeData) value) ，因此忽略其 关键参数，可以是 null 。

CompositeData

TabularData.remove​(Object[] key)

从该 TabularData实例中删除其索引为 关键字的 CompositeData值，并返回删除的值，如果没有索引为 键的值，则返回 null 。

Object

TabularDataSupport.remove​(Object key)

这个方法只需调用 remove((Object[]) key) 。

CompositeData

TabularDataSupport.remove​(Object[] key)

删除 CompositeData值，其指数是从这个 关键 TabularData实例，并返回被移除的值，或返回 null如果没有价值，其指数是 关键 。

Constructors in javax.management.openmbean with parameters of type Object

Constructor

描述

CompositeDataSupport​(CompositeType compositeType, String[] itemNames, Object[] itemValues)

构造一个 CompositeDataSupport实例与指定 compositeType ，其项值由指定 itemValues[] ，以相同的顺序为 itemNames[] 。

OpenMBeanAttributeInfoSupport​(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)

构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放的MBean具有指定的属性 name ， openType ， description ， defaultValue和 legalValues ，以及指定的读/写访问属性。

OpenMBeanParameterInfoSupport​(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)

构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ， defaultValue和 legalValues 。

Uses of Object in javax.management.relation

Subclasses of Object in javax.management.relation

Modifier and Type

Class

描述

class

InvalidRelationIdException

当已经使用关系id提供给关系时，引发异常。

class

InvalidRelationServiceException

当提供无效的关系服务时，引发异常。

class

InvalidRelationTypeException

关系类型无效

class

InvalidRoleInfoException

当在角色信息中，其最小度大于其最大度时，会引发此异常。

class

InvalidRoleValueException

角色值无效。

class

MBeanServerNotificationFilter

过滤器MBeanServerNotification 。

class

RelationException

这个类是在关系管理期间可以提出的任何异常的超类。

class

RelationNotFoundException

当关系服务中的给定关系ID没有关系时，会引发此异常。

class

RelationNotification

关系服务变更通知。

class

RelationService

关系服务负责创建和删除关系类型和关系，处理一致性和提供查询机制。

class

RelationServiceNotRegisteredException

当对关系服务进行访问并且没有注册时，会引发此异常。

class

RelationSupport

RelationSupport对象由Relation Service内部使用，用于表示任意关系类型的简单关系（仅角色，无属性或方法）以及无限数量的角色。

class

RelationTypeNotFoundException

当在关系服务中没有给定名称的关系类型时，引发异常。

class

RelationTypeSupport

RelationTypeSupport对象实现RelationType接口。

class

Role

表示角色：包括角色名称和引用的MBean（通过其ObjectNames）。

class

RoleInfo

RoleInfo对象总结了关系类型中的角色。

class

RoleInfoNotFoundException

当给定的关系类型中没有给定名称的角色信息时，会引发此异常。

class

RoleList

RoleList表示角色列表（Role对象）。

class

RoleNotFoundException

当关系中的角色不存在或不可读或不可设置时，引发此异常。

class

RoleResult

表示多次访问关系的几个角色（用于阅读或写入）的结果。

class

RoleStatus

此类描述访问角色时可能遇到的各种问题。

class

RoleUnresolved

代表一个未解决的角色：由于问题而无法从关系中检索到的角色。

class

RoleUnresolvedList

RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。

Methods in javax.management.relation that return Object

Modifier and Type

方法

描述

Object

Role.clone​()

克隆角色对象。

Object

RoleUnresolved.clone​()

克隆这个对象。

Object

RoleList.set​(int index, Object element)

Object

RoleUnresolvedList.set​(int index, Object element)

Methods in javax.management.relation with parameters of type Object

Modifier and Type

方法

描述

void

RoleList.add​(int index, Object element)

boolean

RoleList.add​(Object o)

void

RoleUnresolvedList.add​(int index, Object element)

boolean

RoleUnresolvedList.add​(Object o)

void

RelationService.handleNotification​(Notification notif, Object handback)

JMX通知发生时调用。

Object

RoleList.set​(int index, Object element)

Object

RoleUnresolvedList.set​(int index, Object element)

Constructors in javax.management.relation with parameters of type Object

Constructor

描述

RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)

为关系中的角色更新创建通知。

RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)

创建关系创建（RelationSupport对象在关系服务内部创建的，或作为关系添加的MBean）或关系删除关系服务的通知。

Uses of Object in javax.management.remote

Subclasses of Object in javax.management.remote

Modifier and Type

Class

描述

class

JMXConnectionNotification

客户端连接打开或关闭或通知丢失时发出的通知。

class

JMXConnectorFactory

工厂创建JMX API连接器客户端。

class

JMXConnectorServer

每个连接器服务器的超类。

class

JMXConnectorServerFactory

工厂创建JMX API连接器服务器。

class

JMXPrincipal

JMX Remote API的远程客户端的身份。

class

JMXProviderException

JMXConnectorFactory和JMXConnectorServerFactory引起的异常 ，当提供者存在所需的协议，但由于某些原因不能使用。

class

JMXServerErrorException

在处理远程MBean服务器中的调用时抛出Error时抛出的异常作为远程MBeanServer方法调用的结果。

class

JMXServiceURL

JMX API连接器服务器的地址。

class

NotificationResult

对缓冲通知的查询结果。

class

SubjectDelegationPermission

认证身份所需的权限代表授权身份执行操作。

class

TargetedNotification

A（通知，听众ID）对。

Methods in javax.management.remote with parameters of type Object

Modifier and Type

方法

描述

void

JMXConnector.addConnectionNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

添加一个监听器以通知连接状态的变化。

Subject

JMXAuthenticator.authenticate​(Object credentials)

使用给定的客户端凭据验证 MBeanServerConnection客户端。

protected void

JMXConnectorServer.connectionClosed​(String connectionId, String message, Object userData)

当客户端连接正常关闭时，由子类调用。

protected void

JMXConnectorServer.connectionFailed​(String connectionId, String message, Object userData)

当客户端连接失败时由子类调用。

protected void

JMXConnectorServer.connectionOpened​(String connectionId, String message, Object userData)

当新的客户端连接打开时由子类调用。

boolean

JMXPrincipal.equals​(Object o)

将指定的对象与此 JMXPrincipal进行比较以获得相等性。

boolean

JMXServiceURL.equals​(Object obj)

指示一些其他对象是否等于此。

void

JMXConnector.removeConnectionNotificationListener​(NotificationListener l, NotificationFilter f, Object handback)

从列表中删除一个监听器以通知状态更改。

Constructors in javax.management.remote with parameters of type Object

Constructor

描述

JMXConnectionNotification​(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)

构造一个新的连接通知。

Uses of Object in javax.management.remote.rmi

Subclasses of Object in javax.management.remote.rmi

Modifier and Type

Class

描述

class

RMIConnectionImpl

实现RMIConnection界面。

class

RMIConnectionImpl_Stub

class

RMIConnector

与远程RMI连接器的连接。

class

RMIConnectorServer

从远程客户端创建基于RMI的连接的JMX API连接器服务器。

class

RMIIIOPServerImpl

已过时。
此运输已不再受支持。

class

RMIJRMPServerImpl

一个RMIServer对象，通过JRMP导出，并将客户端连接创建为通过JRMP导出的RMI对象。

class

RMIServerImpl

表示连接器服务器的RMI对象。

class

RMIServerImpl_Stub

Methods in javax.management.remote.rmi that return Object

Modifier and Type

方法

描述

Object

RMIConnection.getAttribute​(ObjectName name, String attribute, Subject delegationSubject)

处理方法 MBeanServerConnection.getAttribute(ObjectName, String) 。

Object

RMIConnectionImpl_Stub.getAttribute​(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

Object

RMIConnectionImpl.getAttribute​(ObjectName name, String attribute, Subject delegationSubject)

Object

RMIConnection.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

处理方法 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 。

Object

RMIConnectionImpl_Stub.invoke​(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

Object

RMIConnectionImpl.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

Methods in javax.management.remote.rmi with parameters of type Object

Modifier and Type

方法

描述

void

RMIConnector.addConnectionNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

protected void

RMIConnectorServer.connectionClosed​(String connectionId, String message, Object userData)

protected void

RMIConnectorServer.connectionFailed​(String connectionId, String message, Object userData)

protected void

RMIConnectorServer.connectionOpened​(String connectionId, String message, Object userData)

RMIConnection

RMIServer.newClient​(Object credentials)

通过此RMI连接器进行新的连接。

RMIConnection

RMIServerImpl_Stub.newClient​(Object $param_Object_1)

RMIConnection

RMIServerImpl.newClient​(Object credentials)

创建一个新的客户端连接。

void

RMIConnector.removeConnectionNotificationListener​(NotificationListener listener, NotificationFilter filter, Object handback)

Uses of Object in javax.management.timer

Subclasses of Object in javax.management.timer

Modifier and Type

Class

描述

class

Timer

提供定时器MBean的实现。

class

TimerNotification

此类提供了定时器MBeans发送的通知的定义。

Methods in javax.management.timer that return Object

Modifier and Type

方法

描述

Object

Timer.getNotificationUserData​(Integer id)

获取与指定标识符相对应的定时器通知用户数据对象。

Object

TimerMBean.getNotificationUserData​(Integer id)

获取与指定标识符相对应的定时器通知用户数据对象。

Methods in javax.management.timer with parameters of type Object

Modifier and Type

方法

描述

Integer

Timer.addNotification​(String type, String message, Object userData, Date date)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。

Integer

Timer.addNotification​(String type, String message, Object userData, Date date, long period)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。

Integer

Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Integer

Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Constructors in javax.management.timer with parameters of type Object

Constructor

描述

TimerNotification​(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)

创建定时器通知对象。

Uses of Object in javax.naming

Subclasses of Object in javax.naming

Modifier and Type

Class

描述

class

AuthenticationException

访问命名或目录服务时发生身份验证错误时抛出此异常。

class

AuthenticationNotSupportedException

当不支持所请求的身份验证的特定风格时，会抛出此异常。

class

BinaryRefAddr

该类表示通信端点的地址的二进制形式。

class

Binding

此类表示在上下文中找到的名称对对象绑定。

class

CannotProceedException

抛出此异常以指示操作达到操作无法继续进行的名称中的一个点。

class

CommunicationException

当客户端无法与目录或命名服务通信时，抛出此异常。

class

CompositeName

此类表示组合名称 - 跨多个命名空间的组件名称序列。

class

CompoundName

该类表示复合名称 - 来自分层名称空间的名称。

class

ConfigurationException

出现配置问题时抛出此异常。

class

ContextNotEmptyException

尝试销毁不为空的上下文时抛出此异常。

class

InitialContext

这个类是执行命名操作的起始上下文。

class

InsufficientResourcesException

当资源不可用来完成请求的操作时，抛出此异常。

class

InterruptedNamingException

正在调用的命名操作已被中断时抛出此异常。

class

InvalidNameException

此异常表示指定的名称不符合命名系统的命名语法。

class

LimitExceededException

当方法由于用户或系统指定的限制而异常终止时，会抛出此异常。

class

LinkException

此异常用于描述解决链接时遇到的问题。

class

LinkLoopException

当尝试解析链接时检测到一个循环，或者达到链接计数的实现特定限制时，会抛出此异常。

class

LinkRef

此类表示一个引用，其内容是名称，称为链接名称，该名称绑定到上下文中的原子名称。

class

MalformedLinkException

当解决或构建链接时遇到格式错误的链接时抛出此异常。

class

NameAlreadyBoundException

通过方法抛出此异常，表示无法添加绑定，因为该名称已被绑定到另一个对象。

class

NameClassPair

此类表示在上下文中找到的绑定的对象名称和类名称对。

class

NameNotFoundException

当名称的组件由于未绑定而无法解析时抛出此异常。

class

NamingException

这是Context和DirContext接口中的操作抛出的所有异常的超类。

class

NamingSecurityException

这是Context和DirContext接口中的操作抛出的与安全相关异常的超类。

class

NoInitialContextException

当不能创建初始上下文实现时，抛出此异常。

class

NoPermissionException

尝试执行客户端没有权限的操作时抛出此异常。

class

NotContextException

当命名操作进行到需要上下文以继续操作的点时抛出此异常，但解析的对象不是上下文。

class

OperationNotSupportedException

当上下文实现不支持正在调用的操作时，抛出此异常。

class

PartialResultException

抛出此异常以指示到目前为止返回或返回的结果是部分的，并且该操作无法完成。

class

RefAddr

该类表示通信端点的地址。

class

Reference

此类表示对在命名/目录系统外部找到的对象的引用。

class

ReferralException

此抽象类用于表示引用异常，该引用异常是响应于LDAP v3服务器返回的 引用而生成的。

class

ServiceUnavailableException

尝试与目录或命名服务通信并且该服务不可用时，会抛出此异常。

class

SizeLimitExceededException

当方法产生超过大小相关限制的结果时，抛出此异常。

class

StringRefAddr

此类表示通信端点的地址的字符串形式。

class

TimeLimitExceededException

当方法不在指定的时间限制内终止时，抛出此异常。

Fields in javax.naming declared as Object

Modifier and Type

Field

描述

protected Object

LinkException.linkResolvedObj

包含链接部分的分辨率成功的对象。

protected Object

NamingException.resolvedObj

包含名称部分的解析成功的对象。

Fields in javax.naming with type parameters of type Object

Modifier and Type

Field

描述

protected Hashtable<Object,Object>

InitialContext.myProps

与此InitialContext关联的环境。

protected Hashtable<Object,Object>

InitialContext.myProps

与此InitialContext关联的环境。

Methods in javax.naming that return Object

Modifier and Type

方法

描述

Object

Context.addToEnvironment​(String propName, Object propVal)

在此上下文的环境中添加一个新的环境属性。

Object

InitialContext.addToEnvironment​(String propName, Object propVal)

Object

CompositeName.clone​()

生成此复合名称的副本。

Object

CompoundName.clone​()

创建此复合名称的副本。

Object

Name.clone​()

生成一个这个名字的新副本。

Object

Reference.clone​()

使用其类别名称列表的地址，类工厂名称和类工厂位置创建此引用的副本。

Object

BinaryRefAddr.getContent​()

作为对象检索此地址的内容。

abstract Object

RefAddr.getContent​()

检索此地址的内容。

Object

StringRefAddr.getContent​()

检索此地址的内容。

Object

LinkException.getLinkResolvedObj​()

检索分辨率成功的对象。

Object

Binding.getObject​()

检索绑定到此绑定名称的对象。

abstract Object

ReferralException.getReferralInfo​()

检索与此推介相关的信息（如URL）。

Object

NamingException.getResolvedObj​()

检索分辨率成功的对象。

Object

Context.lookup​(String name)

检索命名对象。

Object

Context.lookup​(Name name)

检索命名对象。

Object

InitialContext.lookup​(String name)

Object

InitialContext.lookup​(Name name)

Object

Context.lookupLink​(String name)

检索命名对象，除了名称的终端原子组件以外的链接。

Object

Context.lookupLink​(Name name)

检索命名对象，除了名称的终端原子组件以外的链接。

Object

InitialContext.lookupLink​(String name)

Object

InitialContext.lookupLink​(Name name)

Object

CompositeName.remove​(int posn)

从此复合名称中删除组件。

Object

CompoundName.remove​(int posn)

从此化合物名称中删除组件。

Object

Name.remove​(int posn)

从此名称中删除组件。

Object

Reference.remove​(int posn)

从地址列表中删除索引posn上的地址。

Object

Context.removeFromEnvironment​(String propName)

从环境环境中删除环境属性。

Object

InitialContext.removeFromEnvironment​(String propName)

Methods in javax.naming with parameters of type Object

Modifier and Type

方法

描述

Object

Context.addToEnvironment​(String propName, Object propVal)

在此上下文的环境中添加一个新的环境属性。

Object

InitialContext.addToEnvironment​(String propName, Object propVal)

void

Context.bind​(String name, Object obj)

将名称绑定到对象。

void

Context.bind​(Name name, Object obj)

将名称绑定到对象。

void

InitialContext.bind​(String name, Object obj)

void

InitialContext.bind​(Name name, Object obj)

int

CompositeName.compareTo​(Object obj)

将此CompositeName与指定的对象进行比较。

int

CompoundName.compareTo​(Object obj)

将此CompoundName与指定的对象进行比较以进行订购。

int

Name.compareTo​(Object obj)

将此名称与其他名称进行比较以进行订购。

boolean

BinaryRefAddr.equals​(Object obj)

确定obj是否等于此地址。

boolean

CompositeName.equals​(Object obj)

确定两个复合名称是否相等。

boolean

CompoundName.equals​(Object obj)

确定obj是否在语法上等于此化合物名称。

boolean

RefAddr.equals​(Object obj)

确定obj是否等于此RefAddr。

boolean

Reference.equals​(Object obj)

确定obj是否是具有与该引用相同的地址（以相同的顺序）的引用。

void

Context.rebind​(String name, Object obj)

将名称绑定到对象，覆盖任何现有绑定。

void

Context.rebind​(Name name, Object obj)

将名称绑定到对象，覆盖任何现有绑定。

void

InitialContext.rebind​(String name, Object obj)

void

InitialContext.rebind​(Name name, Object obj)

void

LinkException.setLinkResolvedObj​(Object obj)

设置此异常的链接解析对象字段。

void

Binding.setObject​(Object obj)

设置与此绑定关联的对象。

void

NamingException.setResolvedObj​(Object obj)

设置此异常的已解析对象字段。

Constructors in javax.naming with parameters of type Object

Constructor

描述

Binding​(String name, Object obj)

构造一个绑定的实例给它的名称和对象。

Binding​(String name, Object obj, boolean isRelative)

构造绑定的实例给它的名称，对象以及名称是否相对。

Binding​(String name, String className, Object obj)

构造一个绑定的实例给它的名称，类名和对象。

Binding​(String name, String className, Object obj, boolean isRelative)

构造绑定的实例给它的名称，类名，对象以及名称是否相对。

Uses of Object in javax.naming.directory

Subclasses of Object in javax.naming.directory

Modifier and Type

Class

描述

class

AttributeInUseException

当操作尝试添加已经存在的属性时，抛出此异常。

class

AttributeModificationException

当尝试添加，删除或修改与属性（模式）定义或属性状态相冲突的属性，其标识符或其值时，将抛出此异常。

class

BasicAttribute

该类提供了 Attribute接口的基本实现。

class

BasicAttributes

该类提供了Attributes界面的基本实现。

class

InitialDirContext

此类是执行目录操作的起始上下文。

class

InvalidAttributeIdentifierException

当尝试添加以创建具有无效属性标识符的属性时，会抛出此异常。

class

InvalidAttributesException

尝试添加或修改不完整或不正确指定的属性集时，会抛出此异常。

class

InvalidAttributeValueException

当尝试向属性添加与属性的模式定义冲突的值时，将抛出此类。

class

InvalidSearchControlsException

当搜索操作的SearchControls的规范无效时，抛出此异常。

class

InvalidSearchFilterException

当搜索过滤器的规范无效时抛出此异常。

class

ModificationItem

此类表示修改项。

class

NoSuchAttributeException

尝试访问不存在的属性时抛出此异常。

class

SchemaViolationException

当某种方法违反模式时，抛出此异常。

class

SearchControls

该类封装了确定搜索范围和搜索结果返回的因素。

class

SearchResult

该类表示由DirContext.search（）方法返回的NamingEnumeration中的一个项目。

Fields in javax.naming.directory with type parameters of type Object

Modifier and Type

Field

描述

protected Vector<Object>

BasicAttribute.values

保留属性的值。

Methods in javax.naming.directory that return Object

Modifier and Type

方法

描述

Object

Attribute.clone​()

制作属性的副本。

Object

Attributes.clone​()

创建属性集的副本。

Object

BasicAttribute.clone​()

Object

BasicAttributes.clone​()

Object

Attribute.get​()

检索此属性值之一。

Object

Attribute.get​(int ix)

从有序的属性值列表中检索属性值。

Object

BasicAttribute.get​()

检索此属性值之一。

Object

BasicAttribute.get​(int ix)

Object

Attribute.remove​(int ix)

从有序的属性值列表中删除属性值。

Object

BasicAttribute.remove​(int ix)

Object

Attribute.set​(int ix, Object attrVal)

在属性值的有序列表中设置属性值。

Object

BasicAttribute.set​(int ix, Object attrVal)

Methods in javax.naming.directory with parameters of type Object

Modifier and Type

方法

描述

void

Attribute.add​(int ix, Object attrVal)

向属性值的有序列表添加属性值。

boolean

Attribute.add​(Object attrVal)

向属性添加一个新值。

void

BasicAttribute.add​(int ix, Object attrVal)

boolean

BasicAttribute.add​(Object attrVal)

向此属性添加一个新值。

void

DirContext.bind​(String name, Object obj, Attributes attrs)

将名称绑定到对象，以及关联的属性。

void

DirContext.bind​(Name name, Object obj, Attributes attrs)

将名称绑定到对象，以及关联的属性。

void

InitialDirContext.bind​(String name, Object obj, Attributes attrs)

void

InitialDirContext.bind​(Name name, Object obj, Attributes attrs)

boolean

Attribute.contains​(Object attrVal)

确定值是否在属性中。

boolean

BasicAttribute.contains​(Object attrVal)

确定值是否在此属性中。

boolean

BasicAttribute.equals​(Object obj)

确定obj是否等于此属性。

boolean

BasicAttributes.equals​(Object obj)

确定这 BasicAttributes是否等于另一个 Attributes两个 Attributes都是相等的，如果它们都是 Attributes实例， Attributes相同的方式处理属性ID的情况，并包含相同的属性。

Attribute

Attributes.put​(String attrID, Object val)

向属性集添加一个新属性。

Attribute

BasicAttributes.put​(String attrID, Object val)

void

DirContext.rebind​(String name, Object obj, Attributes attrs)

将名称绑定到对象以及关联的属性，覆盖任何现有绑定。

void

DirContext.rebind​(Name name, Object obj, Attributes attrs)

将名称绑定到对象以及关联的属性，覆盖任何现有绑定。

void

InitialDirContext.rebind​(String name, Object obj, Attributes attrs)

void

InitialDirContext.rebind​(Name name, Object obj, Attributes attrs)

boolean

Attribute.remove​(Object attrval)

从属性中删除指定的值。

boolean

BasicAttribute.remove​(Object attrval)

从此属性中删除指定的值。

NamingEnumeration<SearchResult>

DirContext.search​(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

NamingEnumeration<SearchResult>

DirContext.search​(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

NamingEnumeration<SearchResult>

InitialDirContext.search​(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

InitialDirContext.search​(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

Object

Attribute.set​(int ix, Object attrVal)

在属性值的有序列表中设置属性值。

Object

BasicAttribute.set​(int ix, Object attrVal)

Constructors in javax.naming.directory with parameters of type Object

Constructor

描述

BasicAttribute​(String id, Object value)

使用单个值构造无序属性的新实例。

BasicAttribute​(String id, Object value, boolean ordered)

构造具有单个值的可能有序属性的新实例。

BasicAttributes​(String attrID, Object val)

使用一个属性构造一个新的属性实例。

BasicAttributes​(String attrID, Object val, boolean ignoreCase)

使用一个属性构造一个新的属性实例。

SearchResult​(String name, Object obj, Attributes attrs)

使用结果的名称，其绑定对象及其属性构造搜索结果。

SearchResult​(String name, Object obj, Attributes attrs, boolean isRelative)

使用结果的名称，其绑定对象及其属性构建搜索结果，以及该名称是否相对。

SearchResult​(String name, String className, Object obj, Attributes attrs)

使用结果的名称，其类名称，其绑定对象及其属性构造搜索结果。

SearchResult​(String name, String className, Object obj, Attributes attrs, boolean isRelative)

使用结果的名称，其类名称，其绑定对象，其属性以及名称是否相对构造搜索结果。

Uses of Object in javax.naming.event

Subclasses of Object in javax.naming.event

Modifier and Type

Class

描述

class

NamingEvent

此类表示由命名/目录服务触发的事件。

class

NamingExceptionEvent

这个类代表一个事件，当用于收集信息的过程/过程通知 NamingEvent的听众抛出一个 NamingException 。

Fields in javax.naming.event declared as Object

Modifier and Type

Field

描述

protected Object

NamingEvent.changeInfo

包含有关生成此事件的更改的信息。

Methods in javax.naming.event that return Object

Modifier and Type

方法

描述

Object

NamingEvent.getChangeInfo​()

检索此事件的更改信息。

Methods in javax.naming.event with parameters of type Object

Modifier and Type

方法

描述

void

EventDirContext.addNamingListener​(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)

添加一个侦听器，用于接收由搜索过滤器 filter标识的对象和由字符串目标名称命名的对象的过滤器参数时触发的命名事件。

void

EventDirContext.addNamingListener​(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)

添加一个侦听器，用于接收由搜索过滤器标识的对象 filter并且由目标命名的对象的过滤器参数被修改时触发的命名事件。

Constructors in javax.naming.event with parameters of type Object

Constructor

描述

NamingEvent​(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)

构造一个 NamingEvent的实例。

Uses of Object in javax.naming.ldap

Subclasses of Object in javax.naming.ldap

Modifier and Type

Class

描述

class

BasicControl

该类提供了 Control接口的基本实现。

class

ControlFactory

这个抽象类代表一个用于创建LDAPv3控件的工厂。

class

InitialLdapContext

此类是执行LDAPv3风格的扩展操作和控件的起始上下文。

class

LdapName

此类表示由 RFC 2253指定的专有名称。

class

LdapReferralException

此抽象类用于表示LDAP引用异常。

class

ManageReferralControl

请求将引用和其他特殊LDAP对象作为普通LDAP对象进行操作。

class

PagedResultsControl

请求LDAP服务器以指定大小的批量返回搜索操作的结果。

class

PagedResultsResponseControl

表示一批搜索结果的结束。

class

Rdn

该类表示相对可分辨名称或RDN，它是 RFC 2253指定的专有名称的组成部分。

class

SortControl

请求在返回之前由LDAP服务器对搜索操作的结果进行排序。

class

SortKey

排序键及其相关的排序参数。

class

SortResponseControl

指示所请求的搜索结果是否成功。

class

StartTlsRequest

该类实现了针对StartTLS的LDAPv3扩展请求，如 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security中定义的 。StartTLS的对象标识符为1.3.6.1.4.1.1466.20037，并且未定义扩展请求值。

class

StartTlsResponse

此类实现了针对StartTLS的LDAPv3扩展响应，如 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security所定义 。StartTLS的对象标识符为1.3.6.1.4.1.1466.20037，未定义扩展响应值。

class

UnsolicitedNotificationEvent

此类表示响应LDAP服务器发送的未经请求的通知触发的事件。

Methods in javax.naming.ldap that return Object

Modifier and Type

方法

描述

Object

LdapName.clone​()

生成一个这个名字的新副本。

Object

Rdn.getValue​()

检索此Rdn值之一。

Object

LdapName.remove​(int posn)

从此LDAP名称中删除组件。

static Object

Rdn.unescapeValue​(String val)

给定根据 RFC 2253中规定的规则格式化的属性值字符串，返回未格式化的值。

Methods in javax.naming.ldap with parameters of type Object

Modifier and Type

方法

描述

int

LdapName.compareTo​(Object obj)

将此LdapName与指定的对象进行比较。

int

Rdn.compareTo​(Object obj)

将此Rdn与指定的对象进行比较以进行订购。

boolean

LdapName.equals​(Object obj)

确定两个LDAP名称是否相等。

boolean

Rdn.equals​(Object obj)

将指定的对象与此Rdn进行比较以获得相等性。

static String

Rdn.escapeValue​(Object val)

给定一个属性的值，根据 RFC 2253中规定的规则返回一个转义的字符串。

Constructors in javax.naming.ldap with parameters of type Object

Constructor

描述

Rdn​(String type, Object value)

从给定的属性类型和值构造一个Rdn。

UnsolicitedNotificationEvent​(Object src, UnsolicitedNotification notice)

构造一个新的实例 UnsolicitedNotificationEvent 。

Uses of Object in javax.naming.spi

Subclasses of Object in javax.naming.spi

Modifier and Type

Class

描述

class

DirectoryManager

此类包含支持 DirContext实现的方法。

static class

DirStateFactory.Result

用于返回DirStateFactory.getStateToBind（）的结果的对象/属性对。

class

NamingManager

该类包含用于创建命名或目录服务中位置信息引用的上下文对象和对象的方法。

class

ResolveResult

该类代表解析名称的结果。

Fields in javax.naming.spi declared as Object

Modifier and Type

Field

描述

protected Object

ResolveResult.resolvedObj

包含已成功解析的对象的字段。

Methods in javax.naming.spi that return Object

Modifier and Type

方法

描述

Object

DirStateFactory.Result.getObject​()

检索要绑定的对象。

static Object

DirectoryManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)

为指定的对象，属性和环境创建一个对象的实例。

Object

DirObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)

使用位置或参考信息和指定的属性创建对象。

static Object

NamingManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)

为指定的对象和环境创建一个对象的实例。

Object

ObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)

使用指定的位置或引用信息创建对象。

Object

ResolveResult.getResolvedObj​()

检索分辨率成功的对象。

static Object

NamingManager.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)

检索绑定对象的状态。

Object

StateFactory.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)

检索绑定对象的状态。

Methods in javax.naming.spi with parameters of type Object

Modifier and Type

方法

描述

ObjectFactory

ObjectFactoryBuilder.createObjectFactory​(Object obj, Hashtable<?,?> environment)

使用提供的环境创建一个新的对象工厂。

static Object

DirectoryManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)

为指定的对象，属性和环境创建一个对象的实例。

Object

DirObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)

使用位置或参考信息和指定的属性创建对象。

static Object

NamingManager.getObjectInstance​(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)

为指定的对象和环境创建一个对象的实例。

Object

ObjectFactory.getObjectInstance​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)

使用指定的位置或引用信息创建对象。

static DirStateFactory.Result

DirectoryManager.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)

当给定原始对象及其属性时，检索绑定对象的状态。

DirStateFactory.Result

DirStateFactory.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)

在给定要转换的对象和属性的情况下，检索绑定对象的状态。

static Object

NamingManager.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)

检索绑定对象的状态。

Object

StateFactory.getStateToBind​(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)

检索绑定对象的状态。

void

ResolveResult.setResolvedObj​(Object obj)

将此结果的已解析对象字段设置为obj。

Constructors in javax.naming.spi with parameters of type Object

Constructor

描述

ResolveResult​(Object robj, String rcomp)

构造由解析的对象和剩余的未解析组件组成的ResolveResult的新实例。

ResolveResult​(Object robj, Name rname)

构造由解析的对象和剩余名称组成的ResolveResult的新实例。

Result​(Object obj, Attributes outAttrs)

构造一个Result的实例。

Uses of Object in javax.net

Subclasses of Object in javax.net

Modifier and Type

Class

描述

class

ServerSocketFactory

此类创建服务器套接字。

class

SocketFactory

这个类创建套接字。

Uses of Object in javax.net.ssl

Subclasses of Object in javax.net.ssl

Modifier and Type

Class

描述

class

CertPathTrustManagerParameters

CertPathParameters的包装器。

class

ExtendedSSLSession

扩展 SSLSession接口以支持其他会话属性。

class

HandshakeCompletedEvent

此事件表示在给定SSL连接上完成SSL握手。

class

HttpsURLConnection

HttpsURLConnection扩展了 HttpURLConnection ，支持https特定功能。

class

KeyManagerFactory

该类作为关键管理人员基于关键材料来源的工厂。

class

KeyManagerFactorySpi

该类定义了 KeyManagerFactory类的 （ SPI ）。

class

KeyStoreBuilderParameters

封装KeyStore.Builders列表的X509KeyManagers的参数对象。

class

SNIHostName

此类的实例表示服务器名称指示（SNI）扩展中的类型为 host_name的服务器名称。

class

SNIMatcher

此类的实例表示在SNIServerName实例上执行匹配操作的匹配器。

class

SNIServerName

此类的实例表示服务器名称指示（SNI）扩展中的服务器名称。

class

SSLContext

这个类的实例代表一个安全的套接字协议实现，它作为安全套接字工厂的工厂或 SSLEngine 。

class

SSLContextSpi

该类定义了 SSLContext类的 （ SPI ）。

class

SSLEngine

一类使得能够使用的协议，如安全套接字层（SSL）或安全通信 IETF RFC 2246 "Transport Layer Security" (TLS)个协议，但是输送独立的。

class

SSLEngineResult

由 SSLEngine I / O调用产生的结果状态的封装。

class

SSLException

表示由SSL子系统检测到的某种错误。

class

SSLHandshakeException

表示客户端和服务器无法协商所需的安全级别。

class

SSLKeyException

报告错误的SSL密钥。

class

SSLParameters

封装SSL / TLS / DTLS连接的参数。

class

SSLPeerUnverifiedException

表示对等体的身份尚未验证。

class

SSLPermission

此类用于各种网络权限。

class

SSLProtocolException

报告SSL协议操作中的错误。

class

SSLServerSocket

此类扩展了 ServerSocket并使用安全套接字层（SSL）或传输层安全（TLS）协议等协议提供安全的服务器套接字。

class

SSLServerSocketFactory

SSLServerSocketFactory s创建 SSLServerSocket s。

class

SSLSessionBindingEvent

此事件传播到SSLSessionBindingListener。

class

SSLSocket

此类扩展了 Socket s，并使用诸如“安全套接字层”（SSL）或IETF“传输层安全”（TLS）协议之类的协议提供安全套接字。

class

SSLSocketFactory

SSLSocketFactory s创建 SSLSocket s。

class

StandardConstants

标准常数定义

class

TrustManagerFactory

该类作为基于信任资料来源的信托经理的工厂。

class

TrustManagerFactorySpi

该类定义了 TrustManagerFactory类的 （ SPI ）。

class

X509ExtendedKeyManager

抽象类，用于扩展X509KeyManager接口。

class

X509ExtendedTrustManager

扩展到 X509TrustManager接口，支持SSL / TLS / DTLS连接敏感信任管理。

Methods in javax.net.ssl that return Object

Modifier and Type

方法

描述

Object

SSLSession.getValue​(String name)

返回绑定到会话应用层数据中给定名称的对象。

Methods in javax.net.ssl with parameters of type Object

Modifier and Type

方法

描述

boolean

SNIHostName.equals​(Object other)

将此服务器名称与指定对象进行比较。

boolean

SNIServerName.equals​(Object other)

指示某个其他对象是否等于此服务器名称。

void

SSLSession.putValue​(String name, Object value)

使用给定的 name将指定的 value对象绑定到会话的应用程序层数据中。

Uses of Object in javax.print

Subclasses of Object in javax.print

Modifier and Type

Class

描述

class

DocFlavor

类别DocFlavor封装了一个对象，该对象指定打印数据提供给DocPrintJob的格式 。

static class

DocFlavor.BYTE_ARRAY

DocFlavor.BYTE_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字节数组（ byte[] ）作为打印数据表示类的doc风格。

static class

DocFlavor.CHAR_ARRAY

DocFlavor.CHAR_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字符数组（ char[] ）作为打印数据表示类的doc风格。

static class

DocFlavor.INPUT_STREAM

DocFlavor.INPUT_STREAM类提供预定义的静态常量DocFlavor对象，例如使用字节流（ java.io.InputStream ）作为打印数据表示类的doc风格。

static class

DocFlavor.READER

DocFlavor.READER类提供了预定义的静态常量DocFlavor对象，例如使用字符流（ java.io.Reader ）作为打印数据表示类的doc风格。

static class

DocFlavor.SERVICE_FORMATTED

DocFlavor.SERVICE_FORMATTED类提供了预定义的静态常量DocFlavor对象，例如用于服务格式化打印数据的doc风格。

static class

DocFlavor.STRING

DocFlavor.STRING类提供了预定义的静态常量DocFlavor对象，例如使用字符串（ java.lang.String ）作为打印数据表示类的doc风格。

static class

DocFlavor.URL

DocFlavor.URL类提供了预定义的静态常量DocFlavor对象。

class

PrintException

PrintException类封装了在使用Print Service实例时发生的与打印相关的错误条件。

class

PrintServiceLookup

该类的实现为特定类型的打印服务（通常相当于打印机）提供查找服务。

class

ServiceUI

该类是UI便利方法的集合，其提供用于浏览通过Java Print Service API查找的打印服务的图形用户对话框。

class

ServiceUIFactory

服务可以可选地提供UI，其允许不同角色的不同风格的交互。

class

SimpleDoc

该类是可以在许多常见打印请求中使用的接口 Doc的实现。

class

StreamPrintService

该类扩展了PrintService ，代表一种以不同格式将数据打印到客户端提供的输出流的打印服务。

class

StreamPrintServiceFactory

A StreamPrintServiceFactory是StreamPrintService实例的工厂，可以以描述为MIME类型的特定文档格式打印到输出流。

Methods in javax.print that return Object

Modifier and Type

方法

描述

Object

PrintService.getDefaultAttributeValue​(Class<? extends Attribute> category)

确定此打印服务在给定类别中的默认打印属性值。

Object

Doc.getPrintData​()

以与支持的文档风格相对应的格式获取包含此文档对象的打印数据的打印数据表示对象。

Object

SimpleDoc.getPrintData​()

Object

PrintService.getSupportedAttributeValues​(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)

确定为此打印服务设置作业时客户端可以在给定类别中指定的打印属性值。

abstract Object

ServiceUIFactory.getUI​(int role, String ui)

获取UI对象，该对象可能被应用程序转换为请求的UI类型，并在其用户界面中使用。

Methods in javax.print with parameters of type Object

Modifier and Type

方法

描述

boolean

DocFlavor.equals​(Object obj)

确定此文档flavor对象是否等于给定对象。

boolean

PrintService.equals​(Object obj)

确定两个服务是否指向相同的底层服务。

Constructors in javax.print with parameters of type Object

Constructor

描述

SimpleDoc​(Object printData, DocFlavor flavor, DocAttributeSet attributes)

构造一个具有指定打印数据的 SimpleDoc ，doc风格和doc属性集。

Uses of Object in javax.print.attribute

Subclasses of Object in javax.print.attribute

Modifier and Type

Class

描述

class

AttributeSetUtilities

Class AttributeSetUtilities提供用于操作AttributeSets的静态方法。

class

DateTimeSyntax

类DateTimeSyntax是一个抽象基类，提供值为日期和时间的所有属性的常见实现。

class

EnumSyntax

类EnumSyntax是提供所有“类型安全枚举”对象的通用实现的抽象基类。

class

HashAttributeSet

HashAttributeSet类提供了具有哈希映射特征的 AttributeSet实现。

class

HashDocAttributeSet

HashDocAttributeSet类提供一个属性集，它从HashAttributeSet类继承其实现，并强制实现接口DocAttributeSet的语义限制。

class

HashPrintJobAttributeSet

HashPrintJobAttributeSet类提供了一个从HashAttributeSet类继承其实现的属性集，并强制接口PrintJobAttributeSet的语义限制。

class

HashPrintRequestAttributeSet

HashPrintRequestAttributeSet类从HashAttributeSet类继承其实现，并强制接口PrintRequestAttributeSet的语义限制。

class

HashPrintServiceAttributeSet

HashPrintServiceAttributeSet类提供了一个属性集，它从HashAttributeSet类继承其实现，并强制接口PrintServiceAttributeSet的语义限制。

class

IntegerSyntax

Class IntegerSyntax是一个抽象基类，提供了具有整数值的所有属性的通用实现。

class

ResolutionSyntax

Class ResolutionSyntax是一个抽象基类，提供表示打印机分辨率的所有属性的常见实现。

class

SetOfIntegerSyntax

类SetOfIntegerSyntax是一个抽象基类，提供了所有属性的常见实现，其值是一组非负整数。

class

Size2DSyntax

Class Size2DSyntax是一个抽象基类，提供表示二维大小的所有属性的常见实现。

class

TextSyntax

Class TextSyntax是一个抽象基类，提供了值为字符串的所有属性的常见实现。

class

UnmodifiableSetException

抛出以表示所请求的操作无法执行，因为该集合是不可修改的。

class

URISyntax

类URISyntax是一个抽象基类，提供其值为统一资源标识符（URI）的所有属性的常见实现。

Methods in javax.print.attribute that return Object

Modifier and Type

方法

描述

Object

EnumSyntax.clone​()

返回此枚举值的克隆，其中保留枚举值的语义是与此枚举值相同的对象。

protected Object

EnumSyntax.readResolve​()

在对象输入期间，将此反序列化枚举实例转换为枚举属性类中定义的适当枚举值。

Methods in javax.print.attribute with parameters of type Object

Modifier and Type

方法

描述

boolean

AttributeSet.equals​(Object object)

将指定的对象与此属性集进行比较，以便相等。

boolean

DateTimeSyntax.equals​(Object object)

返回此日期时间属性是否等同于传入的对象。

boolean

HashAttributeSet.equals​(Object object)

将指定的对象与此属性集进行比较，以便相等。

boolean

IntegerSyntax.equals​(Object object)

返回此整数属性是否等同于传入的对象。

boolean

ResolutionSyntax.equals​(Object object)

返回此分辨率属性是否等同于传入的对象。

boolean

SetOfIntegerSyntax.equals​(Object object)

返回此整数属性是否等同于传入的对象。

boolean

Size2DSyntax.equals​(Object object)

返回此二维大小属性是否等同于传入的对象。

boolean

TextSyntax.equals​(Object object)

返回此文本属性是否等同于传入的对象。

boolean

URISyntax.equals​(Object object)

返回此URI属性是否等同于传入的对象。

static Class<?>

AttributeSetUtilities.verifyAttributeCategory​(Object object, Class<?> interfaceName)

验证给定对象是实现给定接口的Class ，该接口假定为接口Attribute或其子接口。

static Attribute

AttributeSetUtilities.verifyAttributeValue​(Object object, Class<?> interfaceName)

验证给定对象是给定接口的一个实例，该接口被假定为接口Attribute或其子接口。

Uses of Object in javax.print.attribute.standard

Subclasses of Object in javax.print.attribute.standard

Modifier and Type

Class

描述

class

Chromaticity

Class Chromaticity是一个打印属性类，一个枚举，用于指定单色或彩色打印。

class

ColorSupported

ColorSupported类是一个打印属性类，一个枚举，用于标识设备是否能够进行任何类型的彩色打印，包括突出显示颜色以及全过程颜色。

class

Compression

类压缩是打印属性类，枚举，用于指定打印数据的压缩方式。

class

Copies

Class Copies是一个整数值的打印属性类，它指定要打印的份数。

class

CopiesSupported

Class CopiesSupported是一个打印属性类，一组整数，它为Copies属性提供支持的值。

class

DateTimeAtCompleted

类DateTimeAtCompleted是打印属性类，日期时间属性，指示打印作业完成（或被取消或中止）的日期和时间。

class

DateTimeAtCreation

类DateTimeAtCreation是一个打印属性类，一个日期时间属性，表示创建打印作业的日期和时间。

class

DateTimeAtProcessing

类DateTimeAtProcessing是打印属性类，日期时间属性，表示打印作业首次开始处理的日期和时间。

class

Destination

类目标是打印属性类（URI），用于指示假脱机打印机格式化数据的备用目标。

class

DialogTypeSelection

DialogTypeSelection类是一个打印属性类，一个枚举，指示用于指定打印选项的用户对话框类型。

class

DocumentName

DocumentName类是一个打印属性类，一个指定文档名称的文本属性。

class

Fidelity

类Fidelity是打印属性类，枚举，指示是否需要对客户端提供的打印请求属性的总保真度。

class

Finishings

类完成是打印属性类，枚举，用于标识打印机是否对作业中每个打印文档的每个副本执行某种类型的装订操作。

class

JobHoldUntil

JobHoldUntil类是一个打印属性类，一个日期时间属性，用于指定作业必须成为打印候选者的确切日期和时间。

class

JobImpressions

JobImpress类是一个整数值打印属性类，它指定要提交的文档的展示次数的总大小。

class

JobImpressionsCompleted

JobImpressionsCompleted类是一个整数值的打印属性类，用于指定目前为该作业完成的展示次数。

class

JobImpressionsSupported

JobImpressions类支持是一个打印属性类，一组整数，它为JobImpressions属性提供支持的值。

class

JobKOctets

JobKOctets类是一个整数值打印属性类，用于指定以K个八位字节为单位的文档的总大小，即以作业中请求处理的1024个八位字节为单位。

class

JobKOctetsProcessed

JobKOctetsProcessed类是一个整数值打印属性类，它指定了目前以K个八位字节处理的打印数据八位字节的总数，即1024个八位字节的单位。

class

JobKOctetsSupported

JobKOctetsSupported类是一个打印属性类，一组整数，它为JobKOctets属性提供支持的值。

class

JobMediaSheets

JobMediaSheets类是一个整数值打印属性类，它指定要为此作业生成的介质页的总数。

class

JobMediaSheetsCompleted

JobMediaSheetsCompleted类是一个整数值的打印属性类，它指定了到目前为止整个作业已经完成标记和堆叠的介质页数，无论这些工作表是在一边还是两者上进行处理。

class

JobMediaSheetsSupported

类JobMediaSheetsSupported是打印属性类，一组整数，为JobMediaSheets属性提供支持的值。

class

JobMessageFromOperator

JobMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示对作业执行修改或其他管理操作的原因。

class

JobName

JobName类是一个打印属性类，一个指定打印作业名称的文本属性。

class

JobOriginatingUserName

JobOriginatingUserName类是一个打印属性类，一个文本属性，其中包含提交打印作业的最终用户的名称。

class

JobPriority

JobPriority类是一个整数值打印属性类，用于指定打印作业的优先级。

class

JobPrioritySupported

JobPrioritySupported类是一个整数值打印属性类，用于指定Print Service实例是否支持JobPriority属性和支持的不同作业优先级数。

class

JobSheets

JobSheets类是打印属性类（枚举），用于确定必须使用作业打印哪些作业开始和结束工作表（如果有）。

class

JobState

JobState是一个打印属性类，一个枚举，用于标识打印作业的当前状态。

class

JobStateReason

JobStateReason类是一个打印属性类，一个枚举，提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。

class

JobStateReasons

JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。

class

Media

Class Media是一个打印属性类，用于指定要打印的介质。

class

MediaName

MediaName类是Media的子类，它是打印属性类（枚举），用于将打印作业的媒体指定为名称。

class

MediaPrintableArea

MediaPrintableArea类是用于区分可打印区域和不可打印区域的打印属性。

class

MediaSize

MediaSize类是一种二维尺寸值的打印属性类，它以纵向方向指示介质的尺寸，X尺寸沿着底边缘运行，Y尺寸沿着左边缘运行。

static class

MediaSize.Engineering

Class MediaSize.Engineering包括工程媒体的MediaSize值。

static class

MediaSize.ISO

MediaSize.ISO类包含ISO媒体的MediaSize值。

static class

MediaSize.JIS

Class MediaSize.JIS包括JIS（日本）媒体的MediaSize值

static class

MediaSize.NA

MediaSize.NA类包括北美媒体的MediaSize值。

static class

MediaSize.Other

Class MediaSize.Other包括杂项媒体的MediaSize值。

class

MediaSizeName

MediaSizeName类是Media的子类。

class

MediaTray

MediaTray类是Media的一个子类。

class

MultipleDocumentHandling

MultipleDocumentHandling类是一个打印属性类，一个枚举，用于控制整理操作，以及将一个或多个打印流页面放置到展示位置和介质页面上。

class

NumberOfDocuments

类NumberOfDocuments是一个整数值打印属性，表示打印机已接受此作业的单个文档的数量，无论文档的打印数据是否到达打印机。

class

NumberOfInterveningJobs

Class NumberOfInterveningJobs是一个整数值打印属性，它以预期完成时间（即当前调度顺序）的相对时间顺序指示该作业前面的作业数。

class

NumberUp

类NumberUp是一个整数值打印属性类，它指定要在所选介质的实例的单侧施加的打印流页数。

class

NumberUpSupported

NumberUpSupported类是一个打印属性类，一组整数，它为NumberUp属性提供支持的值。

class

OrientationRequested

类OrientationRequested是打印属性类，枚举，指示打印的打印流页面的所需方向; 它不描述客户端提供的打印流页面的方向。

class

OutputDeviceAssigned

类OutputDeviceAssigned是一个打印属性类，一个文本属性，用于标识服务分配了此作业的输出设备。

class

PageRanges

Class PageRanges是一个打印属性类，一组整数，用于标识打印机对象用于打印每个文档的每个副本的打印流页面的范围。

class

PagesPerMinute

Class PagesPerMinute是一个整数值打印属性，它表示可能由此打印机生成的最接近的整数的每分钟的标称页数（例如单面，黑白）。

class

PagesPerMinuteColor

Class PagesPerMinuteColor是一个整数值打印属性，表示当打印颜色（例如，单色，颜色）时可能由此打印机生成的最近整数的每分钟的标称页数。

class

PDLOverrideSupported

类PDLOverrideSupported是打印属性类，枚举，表示打印机尝试覆盖嵌入在文档打印数据中的处理指令的能力，处理指令指定为打印数据之外的属性。

class

PresentationDirection

类PresentationDirection是与NumberUp属性结合使用的打印属性类（枚举），用于指示多个打印流页面在所选介质的实例的单侧上施加的布局。

class

PrinterInfo

PrinterInfo类是一个打印属性类，一个文本属性，它提供有关打印机的描述信息。

class

PrinterIsAcceptingJobs

PrinterIsAcceptingJobs类是打印属性类，枚举，指示打印机当前是否能够接受作业。

class

PrinterLocation

PrinterLocation类是打印属性类，一个文本属性，用于标识设备的位置。

class

PrinterMakeAndModel

PrinterMakeAndModel类是打印属性类，文本属性，即打印机的制造商和型号。

class

PrinterMessageFromOperator

PrinterMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示打印机的信息或状态，例如为什么不可用或何时预计可用。

class

PrinterMoreInfo

PrinterMoreInfo类是打印属性类（URI），用于获取有关此特定打印机的更多信息。

class

PrinterMoreInfoManufacturer

PrinterMoreInfoManufacturer类是打印属性类（URI），用于获取有关此类设备的更多信息。

class

PrinterName

PrinterName类是一个打印属性类，一个指定打印机名称的文本属性。

class

PrinterResolution

PrinterResolution类是一个打印属性类，它指定打印机支持的准确分辨率或用于打印作业。

class

PrinterState

PrinterState类是打印属性类，枚举，用于标识打印机的当前状态。

class

PrinterStateReason

PrinterStateReason类是打印属性类（枚举），它提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。

class

PrinterStateReasons

PrinterStateReasons类是打印属性类，一组枚举值，它提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。

class

PrinterURI

PrinterURI类是一个打印属性类，一个URI，它指定打印机的全局唯一名称。

class

PrintQuality

PrintQuality类是打印属性类（枚举），用于指定打印机用于作业的打印质量。

class

QueuedJobCount

Class QueuedJobCount是一个整数值打印属性，指示打印机中的作业数量，其中JobState为PENDING，PENDING_HELD，PROCESSING或PROCESSING_STOPPED。

class

ReferenceUriSchemesSupported

Class ReferenceUriSchemesSupported是打印属性类，表示打印机可用于检索存储在URI位置的打印数据的“URI方案”（例如“http：”或“ftp：”）的枚举。

class

RequestingUserName

Class RequestingUserName是一个打印属性类，一个文本属性，指定提交打印作业的最终用户的名称。

class

Severity

Class Severity是一个打印属性类，一个枚举，表示PrinterStateReason属性的严重性。

class

SheetCollate

Sheet SheetCollate是一个打印属性类，枚举，用于指定当Copies属性指定文档的多个副本时，作业中每个打印文档的每个副本的介质页是否依次排列。

class

Sides

Class Sides是一个打印属性类，一个枚举，它指定打印流页面如何被施加到所选介质实例的侧面，即一个印象。

Methods in javax.print.attribute.standard with parameters of type Object

Modifier and Type

方法

描述

boolean

Copies.equals​(Object object)

返回此副本属性是否等同于传入的对象。

boolean

CopiesSupported.equals​(Object object)

返回此副本支持的属性是否等同于传入的对象。

boolean

DateTimeAtCompleted.equals​(Object object)

返回完成属性中的此日期时间是否等同于传入的对象。

boolean

DateTimeAtCreation.equals​(Object object)

返回创建时的此date-time属性是否等同于传入的对象。

boolean

DateTimeAtProcessing.equals​(Object object)

返回处理属性中的此日期时间是否等同于传入的对象。

boolean

Destination.equals​(Object object)

返回此目标属性是否等同于传入的对象。

boolean

DocumentName.equals​(Object object)

返回此文档名称属性是否等同于传入的对象。

boolean

JobHoldUntil.equals​(Object object)

返回此作业是否保持，直到attribute等同于传入的对象。

boolean

JobImpressions.equals​(Object object)

返回此作业展示属性是否等同于传入的对象。

boolean

JobImpressionsCompleted.equals​(Object object)

返回此作业展示完成属性是否等同于传入的对象。

boolean

JobImpressionsSupported.equals​(Object object)

返回此作业展示支持的属性是否等同于传入的对象。

boolean

JobKOctets.equals​(Object object)

返回此作业K octets属性是否等同于传入的对象。

boolean

JobKOctetsProcessed.equals​(Object object)

返回此作业K个八位字节处理的属性是否等同于传入的对象。

boolean

JobKOctetsSupported.equals​(Object object)

返回此作业K字节支持的属性是否等同于传入的对象。

boolean

JobMediaSheets.equals​(Object object)

返回此作业介质页属性是否等同于传入的对象。

boolean

JobMediaSheetsCompleted.equals​(Object object)

返回此作业介质单的完成属性是否等同于传入的对象。

boolean

JobMediaSheetsSupported.equals​(Object object)

返回此作业介质页支持的属性是否等同于传入的对象。

boolean

JobMessageFromOperator.equals​(Object object)

返回来自operator属性的此作业消息是否等同于传入的对象。

boolean

JobName.equals​(Object object)

返回此作业名称属性是否等同于传入的对象。

boolean

JobOriginatingUserName.equals​(Object object)

返回此作业发起用户名属性是否等同于传入的对象。

boolean

JobPriority.equals​(Object object)

返回此作业优先级属性是否等同于传入的对象。

boolean

JobPrioritySupported.equals​(Object object)

返回此作业优先级支持的属性是否等同于传入的对象。

boolean

Media.equals​(Object object)

返回此media属性是否等同于传入的对象。

boolean

MediaPrintableArea.equals​(Object object)

返回此介质边距属性是否等同于传入的对象。

boolean

MediaSize.equals​(Object object)

返回此media size属性是否等同于传入的对象。

boolean

NumberOfDocuments.equals​(Object object)

返回此数量的文档属性是否等同于传入的对象。

boolean

NumberOfInterveningJobs.equals​(Object object)

返回此数量的介入作业属性是否等同于传入的对象。

boolean

NumberUp.equals​(Object object)

返回此数字up属性是否等同于传入的对象。

boolean

NumberUpSupported.equals​(Object object)

返回此数字支持的属性是否等同于传入的对象。

boolean

OutputDeviceAssigned.equals​(Object object)

返回此输出设备分配的属性是否等同于传入的对象。

boolean

PageRanges.equals​(Object object)

返回此页面范围属性是否等同于传入的对象。

boolean

PagesPerMinute.equals​(Object object)

返回此页面每分钟属性是否等同于传入的对象。

boolean

PagesPerMinuteColor.equals​(Object object)

返回此页面每分钟的颜色属性是否等同于传入的对象。

boolean

PrinterInfo.equals​(Object object)

返回此打印机信息属性是否等同于传入的对象。

boolean

PrinterLocation.equals​(Object object)

返回此打印机位置属性是否等同于传入的对象。

boolean

PrinterMakeAndModel.equals​(Object object)

返回此打印机的make和model属性是否等同于传入的对象。

boolean

PrinterMessageFromOperator.equals​(Object object)

返回来自operator属性的此打印机消息是否等同于传入的对象。

boolean

PrinterMoreInfo.equals​(Object object)

返回此打印机的更多信息属性是否等同于传入的对象。

boolean

PrinterMoreInfoManufacturer.equals​(Object object)

返回此打印机更多信息制造商属性是否等同于传入的对象。

boolean

PrinterName.equals​(Object object)

返回此打印机名称属性是否等同于传入的对象。

boolean

PrinterResolution.equals​(Object object)

返回此打印机分辨率属性是否等同于传入的对象。

boolean

PrinterURI.equals​(Object object)

返回此打印机名称属性是否等同于传入的对象。

boolean

QueuedJobCount.equals​(Object object)

返回此排队的作业计数属性是否等同于传入的对象。

boolean

RequestingUserName.equals​(Object object)

返回此请求用户名属性是否等同于传入的对象。

Uses of Object in javax.print.event

Subclasses of Object in javax.print.event

Modifier and Type

Class

描述

class

PrintEvent

PrintEvent类是所有Print Service API事件的超类。

class

PrintJobAdapter

用于接收打印作业事件的抽象适配器类。

class

PrintJobAttributeEvent

PrintJobAttributeEvent类封装PrintService报告的事件，让客户端知道PrintJob的一个或多个打印属性已更改。

class

PrintJobEvent

PrintJobEvent类封装了打印作业报告的常见事件，让听众知道处理DocPrintJob的进度 。

class

PrintServiceAttributeEvent

PrintServiceAttributeEvent类封装Print Service实例报告的事件，让客户端了解打印服务状态的变化。

Constructors in javax.print.event with parameters of type Object

Constructor

描述

PrintEvent​(Object source)

构造一个PrintEvent对象。

Uses of Object in javax.rmi

Subclasses of Object in javax.rmi

Modifier and Type

Class

描述

class

PortableRemoteObject

服务器实现对象可以从javax.rmi.PortableRemoteObject继承，也可以实现远程接口，然后使用exportObject方法将自身注册为服务对象。

Methods in javax.rmi that return Object

Modifier and Type

方法

描述

static Object

PortableRemoteObject.narrow​(Object narrowFrom, Class narrowTo)

检查以确保远程或抽象接口类型的对象可以转换为所需类型。

Methods in javax.rmi with parameters of type Object

Modifier and Type

方法

描述

static Object

PortableRemoteObject.narrow​(Object narrowFrom, Class narrowTo)

检查以确保远程或抽象接口类型的对象可以转换为所需类型。

Uses of Object in javax.rmi.CORBA

Subclasses of Object in javax.rmi.CORBA

Modifier and Type

Class

描述

class

ClassDesc

此类用于通过IIOP来组织java.lang.Class对象。

class

Stub

所有RMI-IIOP存根都必须从其继承的基类。

class

Util

提供可由桩和关系使用的实用方法来执行常见操作。

Methods in javax.rmi.CORBA that return Object

Modifier and Type

方法

描述

static Object

Util.copyObject​(Object obj, ORB orb)

复制或连接对象。

Object

UtilDelegate.copyObject​(Object obj, ORB orb)

代表团要求 Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 。

static Object[]

Util.copyObjects​(Object[] obj, ORB orb)

复制或连接对象数组。

Object[]

UtilDelegate.copyObjects​(Object[] obj, ORB orb)

代表团要求 Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 。

Object

PortableRemoteObjectDelegate.narrow​(Object narrowFrom, Class narrowTo)

代表团要求 PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 。

static Object

Util.readAny​(InputStream in)

将java.lang.Object读取为任何CORBA。

Object

UtilDelegate.readAny​(InputStream in)

代表团要求 Util.readAny(org.omg.CORBA.portable.InputStream) 。

Methods in javax.rmi.CORBA with parameters of type Object

Modifier and Type

方法

描述

static Object

Util.copyObject​(Object obj, ORB orb)

复制或连接对象。

Object

UtilDelegate.copyObject​(Object obj, ORB orb)

代表团要求 Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 。

static Object[]

Util.copyObjects​(Object[] obj, ORB orb)

复制或连接对象数组。

Object[]

UtilDelegate.copyObjects​(Object[] obj, ORB orb)

代表团要求 Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 。

boolean

Stub.equals​(Object obj)

比较两个存根的平等。

boolean

StubDelegate.equals​(Stub self, Object obj)

代表团要求 Stub.equals(java.lang.Object) 。

Object

PortableRemoteObjectDelegate.narrow​(Object narrowFrom, Class narrowTo)

代表团要求 PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 。

static void

Util.writeAbstractObject​(OutputStream out, Object obj)

将java.lang.Object写入值或CORBA对象。

void

UtilDelegate.writeAbstractObject​(OutputStream out, Object obj)

代表团要求 Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 。

static void

Util.writeAny​(OutputStream out, Object obj)

将任何java.lang.Object写为任何CORBA。

void

UtilDelegate.writeAny​(OutputStream out, Object obj)

代表团要求 Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 。

static void

Util.writeRemoteObject​(OutputStream out, Object obj)

将java.lang.Object写入CORBA对象。

void

UtilDelegate.writeRemoteObject​(OutputStream out, Object obj)

代表团要求 Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 。

Uses of Object in javax.rmi.ssl

Subclasses of Object in javax.rmi.ssl

Modifier and Type

Class

描述

class

SslRMIClientSocketFactory

一个 SslRMIClientSocketFactory实例由RMI运行时使用，以便通过SSL获取RMI调用的客户端套接字。

class

SslRMIServerSocketFactory

一个 SslRMIServerSocketFactory实例由RMI运行时使用，以便通过SSL获取用于RMI调用的服务器套接字。

Methods in javax.rmi.ssl with parameters of type Object

Modifier and Type

方法

描述

boolean

SslRMIClientSocketFactory.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

SslRMIServerSocketFactory.equals​(Object obj)

指示一些其他对象是否等于此。

Uses of Object in javax.script

Subclasses of Object in javax.script

Modifier and Type

Class

描述

class

AbstractScriptEngine

为 eval方法的几个变体提供标准实现。

class

CompiledScript

由存储编译结果的类扩展。

class

ScriptEngineManager

ScriptEngineManager为 ScriptEngine类实现了一个发现和实例化机制，并且还维护了一组存储由管理器创建的所有引擎共享的状态的键/值对。

class

ScriptException

脚本API的通用 异常类。

class

SimpleBindings

一个简单的实现绑定由 HashMap或其他一些指定的 Map 。

class

SimpleScriptContext

简单实现ScriptContext。

Methods in javax.script that return Object

Modifier and Type

方法

描述

Object

AbstractScriptEngine.eval​(Reader reader)

eval(Reader)调用摘要 eval(Reader, ScriptContext)传递 context字段的值。

Object

AbstractScriptEngine.eval​(Reader reader, Bindings bindings)

eval(Reader, Bindings)调用抽象的 eval(Reader, ScriptContext)方法，传递一个 ScriptContext ，其中 ScriptContext的读者，作者和绑定，其他 ENGINE_SCOPE与被保护的 context字段的成员相同。

Object

AbstractScriptEngine.eval​(String script)

与 eval(Reader)相同，但使用摘要 eval(String, ScriptContext) 。

Object

AbstractScriptEngine.eval​(String script, Bindings bindings)

与 eval(Reader, Bindings)相同，但使用摘要 eval(String, ScriptContext) 。

Object

CompiledScript.eval​()

执行存储在 CompiledScript对象中的程序。

Object

CompiledScript.eval​(Bindings bindings)

在脚本执行期间，使用 Bindings属性作为相关联的 ScriptEngine的 ENGINE_SCOPE执行存储在 CompiledScript对象中的程序。

abstract Object

CompiledScript.eval​(ScriptContext context)

执行存储在此 CompiledScript对象中的程序。

Object

ScriptEngine.eval​(Reader reader)

相同 eval(String)除了将脚本的源被提供为 Reader

Object

ScriptEngine.eval​(Reader reader, Bindings n)

同 eval(String, Bindings)除了脚本的源是以提供 Reader 。

Object

ScriptEngine.eval​(Reader reader, ScriptContext context)

与 eval(String, ScriptContext)相同，其中脚本的来源从 Reader读取。

Object

ScriptEngine.eval​(String script)

执行指定的脚本。

Object

ScriptEngine.eval​(String script, Bindings n)

在脚本执行期间，使用 Bindings参数作为 ENGINE_SCOPE Bindings的 ScriptEngine执行脚本。

Object

ScriptEngine.eval​(String script, ScriptContext context)

导致立即执行脚本，其脚本是作为第一个参数传递的String。

Object

AbstractScriptEngine.get​(String key)

获取受保护的 context字段的 ENGINE_SCOPE中指定键的值。

Object

Bindings.get​(Object key)

返回此映射映射指定键的值。

Object

ScriptEngine.get​(String key)

检索在此引擎状态下设置的值。

Object

ScriptEngineManager.get​(String key)

获取全局范围中指定键的值

Object

SimpleBindings.get​(Object key)

返回此映射映射指定键的值。

Object

ScriptContext.getAttribute​(String name)

在搜索顺序中最早出现的范围内检索具有给定名称的属性值。

Object

ScriptContext.getAttribute​(String name, int scope)

获取给定范围内的属性值。

Object

SimpleScriptContext.getAttribute​(String name)

在搜索顺序中最早出现的范围内检索具有给定名称的属性值。

Object

SimpleScriptContext.getAttribute​(String name, int scope)

获取给定范围内的属性值。

Object

ScriptEngineFactory.getParameter​(String key)

返回属性的值，该属性的含义可能是实现特定的。

Object

Invocable.invokeFunction​(String name, Object... args)

用于调用脚本中定义的顶级过程和函数。

Object

Invocable.invokeMethod​(Object thiz, String name, Object... args)

调用在前一个脚本执行期间编译的脚本对象上的方法，该方法保留在 ScriptEngine的状态。

Object

Bindings.put​(String name, Object value)

设置一个命名值。

Object

SimpleBindings.put​(String name, Object value)

在底层的 map字段中设置指定的键/值。

Object

Bindings.remove​(Object key)

如果存在该地图，则从该地图中删除该密钥的映射（可选操作）。

Object

SimpleBindings.remove​(Object key)

如果存在该地图，则从该地图中删除该密钥的映射（可选操作）。

Object

ScriptContext.removeAttribute​(String name, int scope)

删除给定范围内的属性。

Object

SimpleScriptContext.removeAttribute​(String name, int scope)

删除给定范围内的属性。

Methods in javax.script that return types with arguments of type Object

Modifier and Type

方法

描述

Set<Map.Entry<String,Object>>

SimpleBindings.entrySet​()

返回此地图中包含的映射的Set视图。

Collection<Object>

SimpleBindings.values​()

返回此地图中包含的值的Collection视图。

Methods in javax.script with parameters of type Object

Modifier and Type

方法

描述

boolean

Bindings.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

SimpleBindings.containsKey​(Object key)

如果此映射包含指定键的映射，则返回 true 。

boolean

SimpleBindings.containsValue​(Object value)

如果此映射将一个或多个键映射到指定的值，则返回 true 。

Object

Bindings.get​(Object key)

返回此映射映射指定键的值。

Object

SimpleBindings.get​(Object key)

返回此映射映射指定键的值。

<T> T

Invocable.getInterface​(Object thiz, Class<T> clasz)

使用解释器中编译的脚本对象的成员函数返回接口的实现。

Object

Invocable.invokeFunction​(String name, Object... args)

用于调用脚本中定义的顶级过程和函数。

Object

Invocable.invokeMethod​(Object thiz, String name, Object... args)

调用在前一个脚本执行期间编译的脚本对象上的方法，该方法保留在 ScriptEngine的状态。

void

AbstractScriptEngine.put​(String key, Object value)

在受保护的 context字段的 ENGINE_SCOPE Bindings指定的键设置指定值。

Object

Bindings.put​(String name, Object value)

设置一个命名值。

void

ScriptEngine.put​(String key, Object value)

在ScriptEngine的状态下设置一个键/值对，可以创建一个Java语言绑定，以便在执行脚本时使用，或者以其他方式使用，具体取决于该键是否被保留。

void

ScriptEngineManager.put​(String key, Object value)

在全局范围中设置指定的键/值对。

Object

SimpleBindings.put​(String name, Object value)

在底层的 map字段中设置指定的键/值。

Object

Bindings.remove​(Object key)

如果存在该地图，则从该地图中删除该密钥的映射（可选操作）。

Object

SimpleBindings.remove​(Object key)

如果存在该地图，则从该地图中删除该密钥的映射（可选操作）。

void

ScriptContext.setAttribute​(String name, Object value, int scope)

设置给定范围内的属性值。

void

SimpleScriptContext.setAttribute​(String name, Object value, int scope)

设置给定范围内的属性值。

Method parameters in javax.script with type arguments of type Object

Modifier and Type

方法

描述

void

Bindings.putAll​(Map<? extends String,? extends Object> toMerge)

将给定的 Map中的所有映射添加到此 Bindings 。

void

SimpleBindings.putAll​(Map<? extends String,? extends Object> toMerge)

putAll是使用 Map.putAll实现的。

Constructor parameters in javax.script with type arguments of type Object

Constructor

描述

SimpleBindings​(Map<String,Object> m)

构造函数使用现有的 Map来存储值。

Uses of Object in javax.security.auth

Subclasses of Object in javax.security.auth

Modifier and Type

Class

描述

class

AuthPermission

此类用于验证权限。

class

DestroyFailedException

表示 destroy操作失败。

class

Policy

已过时。
从JDK版本1.4开始 - 由java.security.Policy替代。 java.security.Policy有一个方法：
  public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
和ProtectionDomain有一个构造函数：
  public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
这两个API为呼叫者提供查询基于Principal权限条目的策略的方法。

class

PrivateCredentialPermission

此类用于保护对属于特定 Subject私有凭据的访问。

class

RefreshFailedException

表示 refresh操作失败。

class

Subject

A Subject表示单个实体（诸如人）的相关信息的分组。

class

SubjectDomainCombiner

A SubjectDomainCombiner更新来自与此 SubjectDomainCombiner相关联的 Subject主体的 SubjectDomainCombiner 。

Methods in javax.security.auth that return types with arguments of type Object

Modifier and Type

方法

描述

Set<Object>

Subject.getPrivateCredentials​()

返回这个 Set所持有的私人证书的 Subject 。

Set<Object>

Subject.getPublicCredentials​()

返回 Set本公开证书 Subject 。

Methods in javax.security.auth with parameters of type Object

Modifier and Type

方法

描述

boolean

PrivateCredentialPermission.equals​(Object obj)

检查两个 PrivateCredentialPermission对象的相等性。

boolean

Subject.equals​(Object o)

将指定的对象与此 Subject进行比较以获得相等性。

Uses of Object in javax.security.auth.callback

Subclasses of Object in javax.security.auth.callback

Modifier and Type

Class

描述

class

ChoiceCallback

基础安全服务实例，并通过一个 ChoiceCallback至 handle一个方法 CallbackHandler ，以显示选项列表并获取选中的选项（S）。

class

ConfirmationCallback

基础安全服务实例化并通过一个 ConfirmationCallback的 handle方法 CallbackHandler要求YES / NO，OK / CANCEL，YES / NO / CANCEL或其他类似的确认。

class

LanguageCallback

基础安全服务实例化并通过 LanguageCallback handle方法的 CallbackHandler来检索用于本地化文本的 Locale 。

class

NameCallback

基础安全服务实例，并通过一个 NameCallback至 handle一个方法 CallbackHandler ，以获取名称信息。

class

PasswordCallback

基础安全服务实例，并通过一个 PasswordCallback至 handle一个方法 CallbackHandler ，以获取密码信息。

class

TextInputCallback

基础安全服务实例，并通过一个 TextInputCallback至 handle一个方法 CallbackHandler检索普通的文本信息。

class

TextOutputCallback

基础安全服务实例，并通过一个 TextOutputCallback至 handle一个方法 CallbackHandler ，以显示信息消息，警告消息和错误消息。

class

UnsupportedCallbackException

信号一个 CallbackHandler不识别一个特定的 Callback 。

Uses of Object in javax.security.auth.kerberos

Subclasses of Object in javax.security.auth.kerberos

Modifier and Type

Class

描述

class

DelegationPermission

此类用于限制Kerberos授权模型的使用，即：可转发和可预售的机票。

class

EncryptionKey

此类封装了Kerberos中使用的EncryptionKey。

class

KerberosCredMessage

此类封装了Kerberos 5 KRB_CRED消息，可用于将Kerberos凭据从一个主体发送到另一个主体。

class

KerberosKey

该类封装了Kerberos主体的长期密钥。

class

KerberosPrincipal

这个类封装了一个Kerberos主体。

class

KerberosTicket

从客户端的角度来看，该类封装了Kerberos票证和相关信息。

class

KeyTab

这个类封装了一个keytab文件。

class

ServicePermission

此类用于保护Kerberos服务和访问这些服务所必需的凭据。

Methods in javax.security.auth.kerberos with parameters of type Object

Modifier and Type

方法

描述

boolean

DelegationPermission.equals​(Object obj)

检查两个DelegatorPermission对象是否相等。

boolean

EncryptionKey.equals​(Object other)

将指定的对象与此键进行比较以获得相等性。

boolean

KerberosCredMessage.equals​(Object other)

将指定的对象与此 KerberosCredMessage进行比较以获得相等性。

boolean

KerberosKey.equals​(Object other)

将指定的对象与此 KerberosKey进行比较以获得相等性。

boolean

KerberosPrincipal.equals​(Object other)

将指定的对象与此主体进行比较以获得相等性。

boolean

KerberosTicket.equals​(Object other)

将指定的对象与此 KerberosTicket进行比较以获得相等性。

boolean

KeyTab.equals​(Object other)

将指定的对象与此 KeyTab进行比较以获得相等性。

boolean

ServicePermission.equals​(Object obj)

检查两个ServicePermission对象是否相等。

Uses of Object in javax.security.auth.login

Subclasses of Object in javax.security.auth.login

Modifier and Type

Class

描述

class

AccountException

通用帐户异常。

class

AccountExpiredException

表示用户帐户已过期。

class

AccountLockedException

指示帐户被锁定。

class

AccountNotFoundException

表示找不到帐户。

class

AppConfigurationEntry

此类表示为 Configuration类中的 getAppConfigurationEntry(String appName)方法中指定的应用程序配置的单个 LoginModule条目。

static class

AppConfigurationEntry.LoginModuleControlFlag

该类代表 LoginModule是否需要，必要，有效或可选。

class

Configuration

一个配置对象负责指定哪一个LoginModule应该用于一个特定的应用程序，以及以什么顺序调用LoginModule。

class

ConfigurationSpi

该类定义了 Configuration类的 （ SPI ）。

class

CredentialException

通用凭证异常。

class

CredentialExpiredException

表示 Credential已过期。

class

CredentialNotFoundException

表示没有找到凭据。

class

FailedLoginException

表示用户身份验证失败。

class

LoginContext

LoginContext类描述了用于认证主题的基本方法，并提供了独立于底层认证技术开发应用程序的方法。

class

LoginException

这是基本的登录异常。

Uses of Object in javax.security.auth.x500

Subclasses of Object in javax.security.auth.x500

Modifier and Type

Class

描述

class

X500Principal

这个类代表一个X.500 Principal 。

class

X500PrivateCredential

这个类代表一个 X500PrivateCredential 。

Methods in javax.security.auth.x500 with parameters of type Object

Modifier and Type

方法

描述

boolean

X500Principal.equals​(Object o)

将此 Object与 X500Principal进行比较以获得相等性。

Uses of Object in javax.security.cert

Subclasses of Object in javax.security.cert

Modifier and Type

Class

描述

class

Certificate

已过时。
使用java.security.cert的类。

class

CertificateEncodingException

已过时。
使用java.security.cert的类。

class

CertificateException

已过时。
使用java.security.cert的类。

class

CertificateExpiredException

已过时。
使用java.security.cert的类。

class

CertificateNotYetValidException

已过时。
使用java.security.cert的类。

class

CertificateParsingException

已过时。
使用java.security.cert的类。

class

X509Certificate

已过时。
使用java.security.cert的类。

Methods in javax.security.cert with parameters of type Object

Modifier and Type

方法

描述

boolean

Certificate.equals​(Object other)

已过时。

将此证书与指定的对象进行比较。

Uses of Object in javax.security.sasl

Subclasses of Object in javax.security.sasl

Modifier and Type

Class

描述

class

AuthenticationException

由SASL机制实现引发此异常，以指示SASL交换机由于与认证有关的原因（例如无效的身份，密码或密钥）而失败。

class

AuthorizeCallback

SaslServer使用该回调来确定一个实体（通过认证的身份验证身份标识）是否可以代表另一个实体（由授权标识符标识）。

class

RealmCallback

该回调由 SaslClient和 SaslServer用于检索领域信息。

class

RealmChoiceCallback

这个回调由 SaslClient和 SaslServer使用，以获得一个领域列表的选择范围。

class

Sasl

用于创建SASL客户端和服务器的静态类。

class

SaslException

此类表示使用SASL时发生的错误。

Methods in javax.security.sasl that return Object

Modifier and Type

方法

描述

Object

SaslClient.getNegotiatedProperty​(String propName)

检索谈判的财产。

Object

SaslServer.getNegotiatedProperty​(String propName)

检索谈判的财产。

Uses of Object in javax.smartcardio

Subclasses of Object in javax.smartcardio

Modifier and Type

Class

描述

class

ATR

智能卡的应答复位字节。

class

Card

与其建立连接的智能卡。

class

CardChannel

与智能卡的逻辑通道连接。

class

CardException

在与智能卡堆栈或卡本身通信期间发生的错误异常。

class

CardNotPresentException

当应用程序尝试与没有存在卡的终端建立连接时抛出异常。

class

CardPermission

智能卡操作的许可。

class

CardTerminal

智能卡终端，有时称为智能卡读卡器。

class

CardTerminals

TerminalFactory支持的一组终端。

class

CommandAPDU

遵循ISO / IEC 7816-4中定义的结构的命令APDU。

class

ResponseAPDU

符合ISO / IEC 7816-4规定的响应APDU。

class

TerminalFactory

CardTerminal对象工厂。

class

TerminalFactorySpi

TerminalFactorySpi类定义服务提供者接口。

Methods in javax.smartcardio with parameters of type Object

Modifier and Type

方法

描述

boolean

ATR.equals​(Object obj)

将指定的对象与此ATR进行比较以获得相等性。

boolean

CardPermission.equals​(Object obj)

将指定的对象与此CardPermission进行比较以获得相等性。

boolean

CommandAPDU.equals​(Object obj)

将指定的对象与此命令APDU相比较。

boolean

ResponseAPDU.equals​(Object obj)

将指定的对象与此响应APDU进行比较以获得相等性。

static TerminalFactory

TerminalFactory.getInstance​(String type, Object params)

返回使用指定参数初始化的指定类型的TerminalFactory。

static TerminalFactory

TerminalFactory.getInstance​(String type, Object params, String provider)

返回使用指定参数初始化的指定类型的TerminalFactory。

static TerminalFactory

TerminalFactory.getInstance​(String type, Object params, Provider provider)

返回使用指定参数初始化的指定类型的TerminalFactory。

Uses of Object in javax.sound.midi

Subclasses of Object in javax.sound.midi

Modifier and Type

Class

描述

class

Instrument

仪器是具有某些参数设置的声音合成算法，通常设计为模拟特定的真实乐器或实现特定类型的声音效果。

class

InvalidMidiDataException

一个 InvalidMidiDataException表示遇到不适当的MIDI数据。

class

MetaMessage

A MetaMessage是对合成器无意义的MidiMessage ，但可以存储在MIDI文件中并由顺控程序解释。

static class

MidiDevice.Info

A MidiDevice.Info对象包含有关MidiDevice的各种数据，包括其名称，创建它的公司和描述性文本。

class

MidiEvent

MIDI事件包含一个MIDI消息和相应的时间戳，以刻度表示，并且可以表示存储在MIDI文件或Sequence对象中的MIDI事件信息。

class

MidiFileFormat

一个 MidiFileFormat对象封装了一个MIDI文件的类型，以及它的长度和时间信息。

class

MidiMessage

MidiMessage是MIDI消息的基类。

class

MidiSystem

MidiSystem课程提供对所安装的MIDI系统资源的访问，包括合成器，音序器和MIDI输入和输出端口等设备。

class

MidiUnavailableException

当请求的MIDI组件由于不可用而无法打开或创建时，将抛出 MidiUnavailableException 。

class

Patch

Patch对象表示MIDI合成器上存储（加载）单个乐器的位置。

class

Sequence

A Sequence是包含可由Sequencer对象重放的音乐信息（通常是整个歌曲或作曲）的数据结构。

static class

Sequencer.SyncMode

一个 SyncMode对象表示MIDI音序器的时间概念可以与主设备或从设备同步的方式之一。

class

ShortMessage

A ShortMessage包含一个MIDI消息，其状态字节后面最多有两个数据字节。

class

SoundbankResource

A SoundbankResource表示存储在Soundbank中的任何音频资源。

class

SysexMessage

SysexMessage对象表示MIDI系统专用消息。

class

Track

MIDI轨道是独立的MIDI事件流（时间戳的MIDI数据），可以与标准MIDI文件中的其他轨道一起存储。

class

VoiceStatus

A VoiceStatus对象包含有关由Synthesizer生成的其中一个语音的当前状态的信息。

Methods in javax.sound.midi that return Object

Modifier and Type

方法

描述

Object

MetaMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

abstract Object

MidiMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

Object

ShortMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

Object

SysexMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

abstract Object

SoundbankResource.getData​()

获取存储在此 SoundbankResource的采样音频。

Object

MidiFileFormat.getProperty​(String key)

获取由密钥指定的属性值。

Methods in javax.sound.midi that return types with arguments of type Object

Modifier and Type

方法

描述

Map<String,Object>

MidiFileFormat.properties​()

获取不可修改的属性地图。

Methods in javax.sound.midi with parameters of type Object

Modifier and Type

方法

描述

boolean

MidiDevice.Info.equals​(Object obj)

报告两个对象是否相等。

boolean

Sequencer.SyncMode.equals​(Object obj)

确定两个对象是否相等。

Constructor parameters in javax.sound.midi with type arguments of type Object

Constructor

描述

MidiFileFormat​(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)

构造一个 MidiFileFormat与一组属性。

Uses of Object in javax.sound.midi.spi

Subclasses of Object in javax.sound.midi.spi

Modifier and Type

Class

描述

class

MidiDeviceProvider

A MidiDeviceProvider是特定类型的MIDI设备的工厂或提供商。

class

MidiFileReader

A MidiFileReader提供MIDI文件阅读服务。

class

MidiFileWriter

A MidiFileWriter提供MIDI文件写入服务。

class

SoundbankReader

A SoundbankReader提供 SoundbankReader文件阅读服务。

Uses of Object in javax.sound.sampled

Subclasses of Object in javax.sound.sampled

Modifier and Type

Class

描述

class

AudioFileFormat

AudioFileFormat类的实例描述了音频文件，包括文件类型，文件的长度（以字节为单位），文件中包含的音频数据的采样帧长度以及音频数据的格式。

static class

AudioFileFormat.Type

Type类的一个实例代表了音频文件的标准类型之一。

class

AudioFormat

AudioFormat是指定声音流中数据的特定排列的类。

static class

AudioFormat.Encoding

Encoding类命名用于音频流的特定类型的数据表示。

class

AudioInputStream

音频输入流是具有指定音频格式和长度的输入流。

class

AudioPermission

AudioPermission类代表对音频系统资源的访问权限。

class

AudioSystem

AudioSystem类作为采样音频系统资源的入口点。

class

BooleanControl

A BooleanControl提供了在影响线路音频的两种可能设置之间进行切换的功能。

static class

BooleanControl.Type

BooleanControl.Type类的实例标识一种布尔控件。

class

CompoundControl

A CompoundControl （例如图形均衡器）提供对两个或多个相关属性的控制，每个属性本身表示为 Control 。

static class

CompoundControl.Type

CompoundControl.Type内部类的实例标识了一种复合控件。

class

Control

Lines经常有一组控制，如增益和平移，影响通过线路的音频信号。

static class

Control.Type

Type类的实例表示控件的类型。

static class

DataLine.Info

除了从其超类继承的类信息， DataLine.Info还提供了特定于数据行的附加信息。

class

EnumControl

一个 EnumControl提供对一组离散的可能值的控制，每个值由对象表示。

static class

EnumControl.Type

EnumControl.Type内部类的实例标识了一种枚举控件。

class

FloatControl

一个 FloatControl对象提供对一系列浮点值的控制。

static class

FloatControl.Type

FloatControl.Type内部类的实例标识一种浮动控件。

static class

Line.Info

A Line.Info对象包含有关行的信息。

class

LineEvent

LineEvent类封装了线路打开，关闭，启动或停止时线路发送监听器的信息。

static class

LineEvent.Type

LineEvent.Type内部类标识一行发生的事件。

class

LineUnavailableException

A LineUnavailableException是一个例外，指示由于不可用而无法打开该行。

static class

Mixer.Info

Mixer.Info类表示有关音频混音器的信息，包括产品的名称，版本和供应商，以及文本描述。

static class

Port.Info

Port.Info类扩展了 Line.Info ，其中包括端口的附加信息，包括端口的名称以及它是混合器的源还是目标。

class

ReverbType

ReverbType课程提供了访问要应用于音频信号的各种混响设置的方法。

class

UnsupportedAudioFileException

一个 UnsupportedAudioFileException是一个例外，指示操作失败，因为文件不包含已识别的文件类型和格式的有效数据。

Methods in javax.sound.sampled that return Object

Modifier and Type

方法

描述

Object

AudioFileFormat.getProperty​(String key)

获取由密钥指定的属性值。

Object

AudioFormat.getProperty​(String key)

获取由密钥指定的属性值。

Object

EnumControl.getValue​()

获取此控件的当前值。

Object[]

EnumControl.getValues​()

返回此控件的可能值集。

Methods in javax.sound.sampled that return types with arguments of type Object

Modifier and Type

方法

描述

Map<String,Object>

AudioFileFormat.properties​()

获取不可修改的属性地图。

Map<String,Object>

AudioFormat.properties​()

获取不可修改的属性地图。

Methods in javax.sound.sampled with parameters of type Object

Modifier and Type

方法

描述

boolean

AudioFileFormat.Type.equals​(Object obj)

完成equals方法。

boolean

AudioFormat.Encoding.equals​(Object obj)

完成equals方法。

boolean

Control.Type.equals​(Object obj)

完成equals方法。

boolean

LineEvent.Type.equals​(Object obj)

指示指定的对象是否等于此事件类型，如果对象相同，则返回 true 。

boolean

Mixer.Info.equals​(Object obj)

指示两个信息对象是否相等，如果相同，返回 true 。

boolean

Port.Info.equals​(Object obj)

完成equals方法。

boolean

ReverbType.equals​(Object obj)

指示指定的对象是否等于此混响类型，如果对象相同，则返回 true 。

void

EnumControl.setValue​(Object value)

设置控件的当前值。

Constructors in javax.sound.sampled with parameters of type Object

Constructor

描述

EnumControl​(EnumControl.Type type, Object[] values, Object value)

使用给定的参数构造一个新的枚举控制对象。

Constructor parameters in javax.sound.sampled with type arguments of type Object

Constructor

描述

AudioFileFormat​(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)

使用一组定义的属性构建音频文件格式对象。

AudioFormat​(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)

构造具有给定参数的 AudioFormat 。

Uses of Object in javax.sound.sampled.spi

Subclasses of Object in javax.sound.sampled.spi

Modifier and Type

Class

描述

class

AudioFileReader

音频文件阅读服务提供商。

class

AudioFileWriter

音频文件写入服务提供商。

class

FormatConversionProvider

格式转换提供者将一种或多种输入格式的格式转换服务提供给一种或多种输出格式。

class

MixerProvider

特定搅拌机型号的供应商或工厂。

Uses of Object in javax.sql

Subclasses of Object in javax.sql

Modifier and Type

Class

描述

class

ConnectionEvent

一个 Event对象，提供有关连接相关事件源的信息。

class

RowSetEvent

当事件发生到 Event对象时生成的一个 RowSet对象。

class

StatementEvent

A StatementEvent发送到所有 StatementEventListener ，其中注册了一个 PooledConnection 。

Methods in javax.sql that return Object

Modifier and Type

方法

描述

Object[]

RowSetInternal.getParams​()

检索已为此 RowSet对象的命令设置的参数。

Methods in javax.sql with parameters of type Object

Modifier and Type

方法

描述

void

RowSet.setObject​(int parameterIndex, Object x)

使用Java Object在此 RowSet对象的命令中设置指定的参数。

void

RowSet.setObject​(int parameterIndex, Object x, int targetSqlType)

使用Java Object在此 RowSet对象的命令中设置指定的参数。

void

RowSet.setObject​(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)

使用给定的Java Object在此 RowSet对象的命令中设置指定的参数。

void

RowSet.setObject​(String parameterName, Object x)

使用给定对象设置指定参数的值。

void

RowSet.setObject​(String parameterName, Object x, int targetSqlType)

使用给定对象设置指定参数的值。

void

RowSet.setObject​(String parameterName, Object x, int targetSqlType, int scale)

使用给定对象设置指定参数的值。

Uses of Object in javax.sql.rowset

Subclasses of Object in javax.sql.rowset

Modifier and Type

Class

描述

class

BaseRowSet

提供 RowSet对象及其基本功能的抽象类。

class

RowSetMetaDataImpl

提供有关设置和获取有关 RowSet对象列的元数据信息的方法的实现。

class

RowSetProvider

工厂API，使应用程序能够获得 RowSetFactory实现，可将用于产生不同类型的 RowSet实现。

class

RowSetWarning

SQLException的扩展名，它提供有关 RowSet对象上设置的数据库警告的信息。

Methods in javax.sql.rowset that return Object

Modifier and Type

方法

描述

Object[]

BaseRowSet.getParams​()

检索包含为此 RowSet对象的命令设置的参数值（对象和基元）的 SQLException如果尚未设置所有参数，则抛出一个 SQLException对象。

Methods in javax.sql.rowset with parameters of type Object

Modifier and Type

方法

描述

boolean

Predicate.evaluate​(Object value, int column)

该方法由 FilteredRowSet对象调用，以检查值是否位于使用 setFilter()方法设置的过滤条件（或存在多个约束的条件） setFilter() 。

boolean

Predicate.evaluate​(Object value, String columnName)

该方法由 FilteredRowSet对象调用，以检查该值是否在使用setFilter方法设置的过滤条件之间。

void

BaseRowSet.setObject​(int parameterIndex, Object x)

将指定的参数设置为Java编程语言中的 Object 。

void

BaseRowSet.setObject​(int parameterIndex, Object x, int targetSqlType)

使用给定的 Object值设置指定参数的值。

void

BaseRowSet.setObject​(int parameterIndex, Object x, int targetSqlType, int scale)

将指定的参数设置为Java编程语言中的 Object 。

void

BaseRowSet.setObject​(String parameterName, Object x)

使用给定对象设置指定参数的值。

void

BaseRowSet.setObject​(String parameterName, Object x, int targetSqlType)

使用给定对象设置指定参数的值。

void

BaseRowSet.setObject​(String parameterName, Object x, int targetSqlType, int scale)

使用给定对象设置指定参数的值。

Uses of Object in javax.sql.rowset.serial

Subclasses of Object in javax.sql.rowset.serial

Modifier and Type

Class

描述

class

SerialArray

一个 Array对象的序列化版本，它是Java编程语言中的一个SQL ARRAY值的映射。

class

SerialBlob

在Java编程语言中的序列化映射SQL BLOB值。

class

SerialClob

一个序列化的映射在Java编程语言中的一个SQL CLOB值。

class

SerialDatalink

一个序列化映射的Java编程语言中的一个SQL DATALINK值。

class

SerialException

指示和错误的序列化或 BLOB, CLOB, STRUCT or ARRAY序列化的SQL类型，如 BLOB, CLOB, STRUCT or ARRAY除了SQL类型，如 DATALINK and JAVAOBJECT

class

SerialJavaObject

SQL编程语言中的可序列化映射SQL JAVA_OBJECT值。

class

SerialRef

一个 Ref对象的序列化映射，它是Java编程语言中的一个SQL REF值的映射。

class

SerialStruct

SQL编程语言中的SQL结构化类型的序列化映射。

class

SQLInputImpl

用于自定义映射用户定义类型（UDT）的输入流。

class

SQLOutputImpl

用于将自定义映射的用户定义类型（UDT）的属性写入数据库的输出流。

Methods in javax.sql.rowset.serial that return Object

Modifier and Type

方法

描述

Object

SerialArray.clone​()

返回此 SerialArray的克隆。

Object

SerialBlob.clone​()

返回此 SerialBlob的克隆。

Object

SerialClob.clone​()

返回此 SerialClob的克隆。

Object

SerialDatalink.clone​()

返回此 SerialDatalink的克隆。

Object

SerialJavaObject.clone​()

返回此 SerialJavaObject的克隆。

Object

SerialRef.clone​()

返回此 SerialRef的克隆。

Object

SerialStruct.clone​()

返回此 SerialStruct的克隆。

Object

SerialArray.getArray​()

返回一个新数组，该数组是该 SerialArray对象的副本。

Object

SerialArray.getArray​(long index, int count)

返回一个新数组，它是 SerialArray对象的一个slice的副本，从给定索引处的元素开始，并包含给定数量的连续元素。

Object

SerialArray.getArray​(long index, int count, Map<String,Class<?>> map)

返回一个新数组，它是 SerialArray对象的一个slice的副本，从给定索引处的元素开始，并包含给定数量的连续元素。

Object

SerialArray.getArray​(Map<String,Class<?>> map)

返回一个新数组，该数组是 SerialArray对象的副本，当元素为SQL UDT时，使用给定类型映射来定位每个元素的映射。

Object[]

SerialStruct.getAttributes​()

检索包含 SerialStruct对象所代表的SQL结构化类型的属性的 Object值的数组。

Object[]

SerialStruct.getAttributes​(Map<String,Class<?>> map)

检索此 SerialStruct表示为 Object值的数组的SQL结构类型的属性，如果合适，则使用给定类型映射进行自定义映射。

Object

SerialJavaObject.getObject​()

返回一个 Object是 SerialJavaObject对象的副本。

Object

SerialRef.getObject​()

返回 Object表示对此的SQL结构类型 SerialRef对象引用。

Object

SerialRef.getObject​(Map<String,Class<?>> map)

返回 Object表示对此的SQL结构类型 SerialRef对象引用。

Object

SQLInputImpl.readObject​()

以Java编程语言中的 Object该 SQLInputImpl对象的头部的值。

Methods in javax.sql.rowset.serial with parameters of type Object

Modifier and Type

方法

描述

boolean

SerialArray.equals​(Object obj)

将此SerialArray与指定的对象进行比较。

boolean

SerialBlob.equals​(Object obj)

将此SerialBlob与指定对象进行比较。

boolean

SerialClob.equals​(Object obj)

将此SerialClob与指定对象进行比较。

boolean

SerialDatalink.equals​(Object obj)

将此 SerialDatalink与指定对象进行比较。

boolean

SerialJavaObject.equals​(Object o)

将此SerialJavaObject与指定的对象进行比较。

boolean

SerialRef.equals​(Object obj)

将此SerialRef与指定的对象进行比较。

boolean

SerialStruct.equals​(Object obj)

将此SerialStruct与指定对象进行比较。

void

SerialRef.setObject​(Object obj)

将此 SerialRef对象引用到给定的 Object对象的SQL结构化类型设置。

Constructors in javax.sql.rowset.serial with parameters of type Object

Constructor

描述

SerialJavaObject​(Object obj)

SerialJavaObject助手类的构造方法。

SQLInputImpl​(Object[] attributes, Map<String,Class<?>> map)

创建一个 SQLInputImpl对象，该对象使用给定的属性数组和给定的类型映射进行初始化。

Uses of Object in javax.sql.rowset.spi

Subclasses of Object in javax.sql.rowset.spi

Modifier and Type

Class

描述

class

SyncFactory

服务提供者接口（SPI）机制，可生成 SyncProvider实例，由断开的 RowSet对象使用。

class

SyncFactoryException

表示 SyncFactory机制出错。

class

SyncProvider

同步机制，为断开连接的 RowSet对象提供读写器功能。

class

SyncProviderException

表示 SyncProvider机制出现错误。

Methods in javax.sql.rowset.spi that return Object

Modifier and Type

方法

描述

Object

SyncResolver.getConflictValue​(int index)

检索此 SyncResolver对象当前行中指定列中的值，该对象是导致冲突的数据源中的值。

Object

SyncResolver.getConflictValue​(String columnName)

检索此 SyncResolver对象的当前行中指定列中的值，该值是导致冲突的数据源中的值。

Methods in javax.sql.rowset.spi with parameters of type Object

Modifier and Type

方法

描述

void

SyncResolver.setResolvedValue​(int index, Object obj)

将 obj设置为正在同步的 RowSet对象的当前行中的列 索引中的值。

void

SyncResolver.setResolvedValue​(String columnName, Object obj)

将 obj设置为正在同步的 RowSet对象的当前行中的列 columnName中的值。

Uses of Object in javax.swing

Subclasses of Object in javax.swing

Modifier and Type

Class

描述

class

AbstractAction

该类提供了JFC Action接口的默认实现。

class

AbstractButton

定义按钮和菜单项的常见行为。

protected class

AbstractButton.AccessibleAbstractButton

这个类实现 AbstractButton类的可访问性支持。

protected class

AbstractButton.ButtonChangeListener

扩展 ChangeListener可串行化。

class

AbstractCellEditor

CellEditors的基类，为 CellEditor接口除 getCellEditorValue()之外的方法提供默认实现。

class

AbstractListModel<E>

数据模型的抽象定义提供了一个 List及其内容。

class

AbstractSpinnerModel

此类提供了SpinnerModel接口的ChangeListener部分，该接口应适用于大多数具体的SpinnerModel实现。

class

ActionMap

ActionMap提供从 Object s（称为 密钥或 Action名称 ）到 Action 。

class

BorderFactory

出厂标准为 Border对象。

class

Box

一个使用BoxLayout对象作为其布局管理器的轻量级容器。

protected class

Box.AccessibleBox

这个类实现 Box类的可访问性支持。

static class

Box.Filler

参与布局但没有视图的轻量级组件的实现。

protected class

Box.Filler.AccessibleBoxFiller

这个类实现 Box.Filler类的可访问性支持。

class

BoxLayout

一个布局管理器，可以将多个组件垂直或水平放置。

class

ButtonGroup

此类用于为一组按钮创建多重排除范围。

class

CellRendererPane

此类插入到单元格渲染器和使用它们的组件之间。

protected class

CellRendererPane.AccessibleCellRendererPane

这个类实现 CellRendererPane类的可访问性支持。

class

ComponentInputMap

甲 ComponentInputMap是 InputMap与特定关联 JComponent 。

class

DebugGraphics

图形子类支持图形调试。

class

DefaultBoundedRangeModel

BoundedRangeModel的一般实现。

class

DefaultButtonModel

默认实现的一个 Button组件的数据模型。

class

DefaultCellEditor

表和树单元格的默认编辑器。

protected class

DefaultCellEditor.EditorDelegate

受保护的 EditorDelegate课。

class

DefaultComboBoxModel<E>

组合框的默认模型。

class

DefaultDesktopManager

这是一个 DesktopManager的实现。

class

DefaultFocusManager

这个类已被1.4焦点API过时了。

class

DefaultListCellRenderer

渲染列表中的项目。

static class

DefaultListCellRenderer.UIResource

实现UIResource的DefaultListCellRenderer的子类。

class

DefaultListModel<E>

该类松散地实现了 java.util.Vector API，因为它实现了1.1.x版本的 java.util.Vector ，没有收集类支持，并且在发生更改时通知 ListDataListener 。

class

DefaultListSelectionModel

列表选择的默认数据模型。

class

DefaultRowSorter<M,I>

一个 RowSorter的实现，提供围绕网格数据模型的排序和过滤。

protected static class

DefaultRowSorter.ModelWrapper<M,I>

DefaultRowSorter.ModelWrapper负责提供按 DefaultRowSorter进行排序的数据。

class

DefaultSingleSelectionModel

SingleSelectionModel的一般实现。

class

FocusManager

这个类已被1.4焦点API过时了。

class

GrayFilter

通过将图像转换成灰度图像来“禁用”图像并增亮图像中的像素的图像滤镜。

class

GroupLayout

GroupLayout是一个 LayoutManager ，它分层组合组件，以便将它们放置在一个 Container 。

class

GroupLayout.Group

Group为GroupLayout支持的两种操作提供了基础：一个接一个地（ SequentialGroup ）或对齐（ ParallelGroup ）组成的组件。

class

GroupLayout.ParallelGroup

A Group ，它对齐和调整它的孩子的大小。

class

GroupLayout.SequentialGroup

A Group一个接一个地依次定位和调整其元素的大小。

class

ImageIcon

从图像绘制图标的图标界面的实现。

protected class

ImageIcon.AccessibleImageIcon

该类为 ImageIcon类实现可访问性支持。

class

InputMap

InputMap提供输入事件（目前仅使用 KeyStroke s）与 Object 。

class

InputVerifier

此类为Swing组件提供了验证机制。

class

InternalFrameFocusTraversalPolicy

FocusTraversalPolicy可以选择提供一种用于确定JInternalFrame初始组件的算法。

class

JApplet

已过时。
Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

protected class

JApplet.AccessibleJApplet

已过时。

这个类实现 JApplet类的可访问性支持。

class

JButton

实现“推”按钮。

protected class

JButton.AccessibleJButton

这个类实现 JButton类的可访问性支持。

class

JCheckBox

复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。

protected class

JCheckBox.AccessibleJCheckBox

这个类实现 JCheckBox类的可访问性支持。

class

JCheckBoxMenuItem

可以选择或取消选择的菜单项。

protected class

JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

这个类实现 JCheckBoxMenuItem类的可访问性支持。

class

JColorChooser

JColorChooser提供了一个设计为允许用户操纵和选择颜色的控件窗格。

protected class

JColorChooser.AccessibleJColorChooser

这个类实现 JColorChooser类的可访问性支持。

class

JComboBox<E>

组合按钮或可编辑字段和下拉列表的组件。

protected class

JComboBox.AccessibleJComboBox

这个类实现 JComboBox类的可访问性支持。

class

JComponent

除顶级容器之外的所有Swing组件的基类。

class

JComponent.AccessibleJComponent

JComponent的内部类用于为辅助功能提供默认支持。

protected class

JComponent.AccessibleJComponent.AccessibleContainerHandler

Fire PropertyChange监听器，如果一个注册，当孩子添加/删除。

protected class

JComponent.AccessibleJComponent.AccessibleFocusHandler

已过时。
此类不再使用或需要。 java.awt.Component.AccessibleAWTComponent提供相同的功能，它在Component处理。

class

JDesktopPane

用于创建多文档界面或虚拟桌面的容器。

protected class

JDesktopPane.AccessibleJDesktopPane

该类为 JDesktopPane类实现可访问性支持。

class

JDialog

创建对话窗口的主要类。

protected class

JDialog.AccessibleJDialog

这个类实现 JDialog类的可访问性支持。

class

JEditorPane

用于编辑各种内容的文本组件。

protected class

JEditorPane.AccessibleJEditorPane

这个类实现 JEditorPane类的可访问性支持。

protected class

JEditorPane.AccessibleJEditorPaneHTML

此类提供对 AccessibleHypertext支持，并且在 EditorKit安装的 JEditorPane是 JEditorPane的实例的情况下 HTMLEditorKit 。

protected class

JEditorPane.JEditorPaneAccessibleHypertextSupport

AccessibleJEditorPaneHTML.getAccessibleText返回的 AccessibleJEditorPaneHTML.getAccessibleText 。

class

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

一个HTML链接。

class

JFileChooser

JFileChooser为用户提供了一种简单的机制来选择文件。

protected class

JFileChooser.AccessibleJFileChooser

这个类实现 JFileChooser类的可访问性支持。

class

JFormattedTextField

JFormattedTextField扩展了 JTextField增加了格式化任意值的支持，以及一旦用户编辑文本，就检索一个特定的对象。

static class

JFormattedTextField.AbstractFormatter

AbstractFormatter实例由 JFormattedTextField用于处理从对象到字符串以及从字符串返回到对象的转换。

static class

JFormattedTextField.AbstractFormatterFactory

AbstractFormatterFactory实例由 JFormattedTextField用于获取 JFormattedTextField实例， AbstractFormatter这些实例又用于格式化值。

class

JFrame

扩展版本的 java.awt.Frame ，增加了对JFC / Swing组件架构的支持。

protected class

JFrame.AccessibleJFrame

这个类实现 JFrame类的可访问性支持。

class

JInternalFrame

一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。

protected class

JInternalFrame.AccessibleJInternalFrame

这个类实现 JInternalFrame类的可访问性支持。

static class

JInternalFrame.JDesktopIcon

该组件代表 JInternalFrame的图标化版本。

protected class

JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

这个类实现 JInternalFrame.JDesktopIcon类的可访问性支持。

class

JLabel

用于短文本字符串或图像的显示区域，或两者。

protected class

JLabel.AccessibleJLabel

该类用于获取此对象的可访问角色。

class

JLayer<V extends Component>

JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并且可以接收在其边框内生成的所有 AWTEvent的通知。

class

JLayeredPane

JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。

protected class

JLayeredPane.AccessibleJLayeredPane

这个类实现 JLayeredPane类的可访问性支持。

class

JList<E>

显示对象列表并允许用户选择一个或多个项目的组件。

protected class

JList.AccessibleJList

该类实现 JList类的可访问性支持。

protected class

JList.AccessibleJList.AccessibleJListChild

该类实现适用于列表子级的辅助功能支持。

static class

JList.DropLocation

的一个子类 TransferHandler.DropLocation表示用于一个放置位置 JList 。

class

JMenu

一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。

protected class

JMenu.AccessibleJMenu

这个类实现 JMenu类的可访问性支持。

protected class

JMenu.WinListener

监听一个弹出窗口关闭的监听器类。

class

JMenuBar

一个菜单栏的实现。

protected class

JMenuBar.AccessibleJMenuBar

这个类实现 JMenuBar类的可访问性支持。

class

JMenuItem

菜单中项目的实现。

protected class

JMenuItem.AccessibleJMenuItem

这个类实现 JMenuItem类的可访问性支持。

class

JOptionPane

JOptionPane可以方便地弹出一个标准对话框，提示用户获取值或通知他们某些内容。

protected class

JOptionPane.AccessibleJOptionPane

这个类实现 JOptionPane类的可访问性支持。

class

JPanel

JPanel是一个通用的轻量级容器。

protected class

JPanel.AccessibleJPanel

这个类实现 JPanel类的可访问性支持。

class

JPasswordField

JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示某些内容是键入的，但不显示原始字符。

protected class

JPasswordField.AccessibleJPasswordField

这个类实现 JPasswordField类的可访问性支持。

class

JPopupMenu

弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。

protected class

JPopupMenu.AccessibleJPopupMenu

这个类实现 JPopupMenu类的可访问性支持。

static class

JPopupMenu.Separator

弹出菜单特定的分隔符。

class

JProgressBar

可视化显示某些任务进度的组件。

protected class

JProgressBar.AccessibleJProgressBar

该类为 JProgressBar类实现可访问性支持。

class

JRadioButton

单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。

protected class

JRadioButton.AccessibleJRadioButton

这个类实现 JRadioButton类的可访问性支持。

class

JRadioButtonMenuItem

单选按钮菜单项的实现。

protected class

JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

这个类实现 JRadioButtonMenuItem类的可访问性支持。

class

JRootPane

通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。

protected class

JRootPane.AccessibleJRootPane

该类为 JRootPane类实现可访问性支持。

protected class

JRootPane.RootLayout

一个自定义布局管理器，负责分层面，玻璃面和菜单栏的布局。

class

JScrollBar

一个滚动条的实现。

protected class

JScrollBar.AccessibleJScrollBar

这个类实现 JScrollBar类的可访问性支持。

class

JScrollPane

提供轻量级组件的可滚动视图。

protected class

JScrollPane.AccessibleJScrollPane

这个类实现 JScrollPane类的可访问性支持。

protected class

JScrollPane.ScrollBar

默认情况下， JScrollPane创建作为此类的实例的滚动条。

class

JSeparator

JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。

protected class

JSeparator.AccessibleJSeparator

该类实现 JSeparator类的可访问性支持。

class

JSlider

允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。

protected class

JSlider.AccessibleJSlider

这个类实现 JSlider类的可访问性支持。

class

JSpinner

单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。

protected class

JSpinner.AccessibleJSpinner

AccessibleJSpinner实现 JSpinner类的辅助功能支持。

static class

JSpinner.DateEditor

一个 JSpinner的编辑器，其型号是 SpinnerDateModel 。

static class

JSpinner.DefaultEditor

更专业的编辑器的简单基类，通过 JFormattedTextField显示模型当前值的 JFormattedTextField 。

static class

JSpinner.ListEditor

一个 JSpinner的编辑器，其型号是 SpinnerListModel 。

static class

JSpinner.NumberEditor

一个 JSpinner的编辑器，其型号是 SpinnerNumberModel 。

class

JSplitPane

JSplitPane用于分割二（仅两个） Component s。

protected class

JSplitPane.AccessibleJSplitPane

这个类实现 JSplitPane类的可访问性支持。

class

JTabbedPane

通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。

protected class

JTabbedPane.AccessibleJTabbedPane

这个类实现 JTabbedPane类的可访问性支持。

protected class

JTabbedPane.ModelListener

我们通过 ModelChanged （而不是模型本身）将 ModelChanged事件传递给听众，作为事件源。

class

JTable

JTable用于显示和编辑单元格的常规二维表。

protected class

JTable.AccessibleJTable

这个类实现 JTable类的可访问性支持。

protected class

JTable.AccessibleJTable.AccessibleJTableCell

该类提供了适用于表单元格的Java Accessibility API的实现。

protected class

JTable.AccessibleJTable.AccessibleJTableModelChange

描述可访问表模型的变化。

static class

JTable.DropLocation

的一个子类 TransferHandler.DropLocation表示用于一个放置位置 JTable 。

class

JTextArea

A JTextArea是显示纯文本的多行区域。

protected class

JTextArea.AccessibleJTextArea

这个类实现 JTextArea类的可访问性支持。

class

JTextField

JTextField是一个轻量级组件，允许编辑单行文本。

protected class

JTextField.AccessibleJTextField

这个类实现 JTextField类的可访问性支持。

class

JTextPane

可以用图形化的属性标记的文本组件。

class

JToggleButton

一个两状态按钮的实现。

protected class

JToggleButton.AccessibleJToggleButton

这个类实现 JToggleButton类的可访问性支持。

static class

JToggleButton.ToggleButtonModel

ToggleButton模型

class

JToolBar

JToolBar提供了一个组件，可用于显示常用的 Action或控件。

protected class

JToolBar.AccessibleJToolBar

该类为 JToolBar类实现可访问性支持。

static class

JToolBar.Separator

工具栏特定的分隔符。

class

JToolTip

用于显示组件的“提示”。

protected class

JToolTip.AccessibleJToolTip

这个类实现 JToolTip类的可访问性支持。

class

JTree

作为轮廓显示一组分层数据的控件。

protected class

JTree.AccessibleJTree

这个类实现 JTree类的可访问性支持。

protected class

JTree.AccessibleJTree.AccessibleJTreeNode

该类为 JTree孩子实现可访问性支持。

static class

JTree.DropLocation

的一个子类 TransferHandler.DropLocation表示用于一个放置位置 JTree 。

static class

JTree.DynamicUtilTreeNode

DynamicUtilTreeNode可以包装向量/哈希表/数组/字符串，并根据需要创建适当的子树节点。

protected static class

JTree.EmptySelectionModel

EmptySelectionModel是一个 TreeSelectionModel ，不允许任何东西被选中。

protected class

JTree.TreeModelHandler

监听模型，并在节点被删除或更改时相应更新 expandedState 。

protected class

JTree.TreeSelectionRedirector

手柄创建一个新的 TreeSelectionEvent与 JTree作为来源，并将其传递给所有的听众。

class

JViewport

您可以通过它查看基础信息的“视口”或“舷窗”。

protected class

JViewport.AccessibleJViewport

这个类实现 JViewport类的可访问性支持。

protected class

JViewport.ViewListener

视图的监听器。

class

JWindow

A JWindow是可以在用户桌面上的任何位置显示的容器。

protected class

JWindow.AccessibleJWindow

这个类实现 JWindow类的可访问性支持。

class

KeyStroke

KeyStroke表示键盘或等效输入设备上的关键操作。

class

LayoutFocusTraversalPolicy

一个SortingFocusTraversalPolicy，它根据大小，位置和方向对组件进行排序。

class

LayoutStyle

LayoutStyle提供了有关如何定位组件的信息。

class

LookAndFeel

LookAndFeel ，顾名思义，封装外观和感觉。

class

MenuSelectionManager

MenuSelectionManager拥有菜单层次结构中的选择。

class

OverlayLayout

布局管理器将组件排列在彼此的顶部。

class

Popup

弹出窗口用于向用户显示 Component ，通常位于特定包容层次结构中的所有其他 Component 。

class

PopupFactory

PopupFactory ，顾名思义，用于获取 Popup的实例。

class

ProgressMonitor

一类监视某些操作的进度。

protected class

ProgressMonitor.AccessibleProgressMonitor

AccessibleProgressMonitor实现 ProgressMonitor类的辅助功能支持。

class

ProgressMonitorInputStream

监视从一些InputStream读取进度。

class

RepaintManager

此类管理重绘请求，允许重绘的数量最小化，例如通过将多个请求压缩为组件树成员的单个重绘。

class

RowFilter<M,I>

RowFilter用于过滤模型中的条目，以便它们不会在视图中显示。

static class

RowFilter.Entry<M,I>

一个 Entry对象传递给 RowFilter实例，允许过滤器获取条目数据的值，从而确定是否应该显示条目。

class

RowSorter<M>

RowSorter为排序和筛选提供依据。

static class

RowSorter.SortKey

SortKey描述特定列的排序顺序。

class

ScrollPaneLayout

JScrollPane使用的布局管理器。

static class

ScrollPaneLayout.UIResource

UI资源版本为 ScrollPaneLayout 。

class

SizeRequirements

为了方便布局管理器，计算有关组件的大小和位置的信息。

class

SizeSequence

一个 SizeSequence对象有效地维护一个有序的大小和对应位置的列表。

class

SortingFocusTraversalPolicy

FocusTraversalPolicy通过基于给定的比较器对焦点遍历周期的组件进行排序来确定遍历顺序。

class

SpinnerDateModel

甲 SpinnerModel为序列 Date秒。

class

SpinnerListModel

SpinnerModel的简单实现，其值由数组或 List定义。

class

SpinnerNumberModel

A SpinnerModel用于数字序列。

class

Spring

Spring类的实例具有表征其行为的三个属性： 最小值 ， 首选值和 最大值 。

class

SpringLayout

A SpringLayout根据一组约束规定了其关联容器的子项。

static class

SpringLayout.Constraints

一个 Constraints对象包含控制由一个 SpringLayout控制的容器中组件的大小和位置变化方式的 SpringLayout 。

class

SwingUtilities

Swing的一个实用方法的集合。

class

SwingWorker<T,V>

在后台线程中执行冗长的GUI交互任务的抽象类。

class

Timer

以指定的间隔触发一个或多个 ActionEvent 。

class

ToolTipManager

管理系统中的所有 ToolTips 。

protected class

ToolTipManager.insideTimerAction

内部定时器动作。

protected class

ToolTipManager.outsideTimerAction

外部定时器动作。

protected class

ToolTipManager.stillInsideTimerAction

仍然在定时器动作。

class

TransferHandler

该类用于处理从Swing组件 Transferable 。

static class

TransferHandler.DropLocation

表示应插入丢弃数据的位置。

static class

TransferHandler.TransferSupport

该类封装了剪贴板的所有相关细节或拖放传输，还允许自定义拖放体验的方面。

class

UIDefaults

Swing组件的默认表。

static class

UIDefaults.LazyInputMap

LazyInputMap将在其 createValue方法中创建一个 InputMap 。

static class

UIDefaults.ProxyLazyValue

该类提供了一个 LazyValue的实现，可以用于延迟加载要创建的实例的Class。

class

UIManager

UIManager管理目前的外观和感觉，一组可用的外观和感觉， PropertyChangeListeners ，当外观和感觉变化，外观和感觉默认值以及获取各种默认值的便利方法时通知。

static class

UIManager.LookAndFeelInfo

提供有关安装的 LookAndFeel的一些信息，以配置菜单或初始应用程序设置。

class

UnsupportedLookAndFeelException

表示所请求的外观和感觉管理类的异常不在用户系统上。

class

ViewportLayout

默认布局管理器为 JViewport 。

Fields in javax.swing declared as Object

Modifier and Type

Field

描述

protected Object

JTree.DynamicUtilTreeNode.childValue

创造孩子的价值。

protected Object

JOptionPane.initialSelectionValue

初始值在 selectionValues进行选择。

protected Object

JOptionPane.initialValue

应在 options最初选择的 options 。

protected Object

JOptionPane.inputValue

用户输入的价值

protected Object

JOptionPane.message

消息显示。

protected Object[]

JOptionPane.options

向用户显示的选项。

protected Object

JComboBox.selectedItemReminder

此保护字段是实现特定的。

protected Object[]

JOptionPane.selectionValues

用户可以选择的数组数组。

static Object

JOptionPane.UNINITIALIZED_VALUE

表示用户尚未选择值。

protected Object

DefaultCellEditor.EditorDelegate.value

这个单元格的值。

protected Object

JOptionPane.value

当前所选值，将是有效选项，或 UNINITIALIZED_VALUE或 null 。

Fields in javax.swing with type parameters of type Object

Modifier and Type

Field

描述

protected Hashtable<Object,Object>

JTable.defaultEditorsByColumnClass

显示和编辑单元格内容的对象表，由 TableModel接口中的 getColumnClass中声明的类索引。

protected Hashtable<Object,Object>

JTable.defaultEditorsByColumnClass

显示和编辑单元格内容的对象表，由 TableModel接口中的 getColumnClass中声明的类索引。

protected Hashtable<Object,Object>

JTable.defaultRenderersByColumnClass

一个显示单元格内容的对象表，按 TableModel接口的 getColumnClass中声明的类索引。

protected Hashtable<Object,Object>

JTable.defaultRenderersByColumnClass

一个显示单元格内容的对象表，按 TableModel接口的 getColumnClass中声明的类进行索引。

Methods in javax.swing that return Object

Modifier and Type

方法

描述

Object[]

ActionMap.allKeys​()

返回此 ActionMap及其父代码中定义的键的数组。

protected Object

AbstractAction.clone​()

克隆抽象动作。

Object

DefaultListSelectionModel.clone​()

返回具有相同选择的此选择模型的克隆。

protected Object

JFormattedTextField.AbstractFormatter.clone​()

克隆 AbstractFormatter 。

Object

UIDefaults.ActiveValue.createValue​(UIDefaults table)

创建从 UIDefaults表中检索的值。

Object

UIDefaults.LazyInputMap.createValue​(UIDefaults table)

创建一个 InputMap与传入的绑定。

Object

UIDefaults.LazyValue.createValue​(UIDefaults table)

创建从 UIDefaults表检索的实际值。

Object

UIDefaults.ProxyLazyValue.createValue​(UIDefaults table)

创建从 UIDefaults表中检索的值。

Object

InputMap.get​(KeyStroke keyStroke)

返回 keyStroke的绑定，如果绑定未在本地定义，则发送消息为父母 InputMap 。

Object

UIDefaults.get​(Object key)

返回值的值。

Object

UIDefaults.get​(Object key, Locale l)

返回与给定语言环境相关联的键的值。

static Object

UIManager.get​(Object key)

从默认值返回一个对象。

static Object

UIManager.get​(Object key, Locale l)

从适用于给定语言环境的默认值返回一个对象。

Object

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionAnchor​(int i)

根据该链接返回一个表示链接锚点的对象。

Object

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionObject​(int i)

返回一个表示链接的URL对象。

Object

CellEditor.getCellEditorValue​()

返回编辑器中包含的值。

Object

DefaultCellEditor.EditorDelegate.getCellEditorValue​()

返回此单元格的值。

Object

DefaultCellEditor.getCellEditorValue​()

将消息从 CellEditor转发到 delegate 。

Object

JComponent.getClientProperty​(Object key)

使用指定的键返回属性的值。

static Object

LookAndFeel.getDesktopPropertyValue​(String systemPropertyName, Object fallbackValue)

通过调用 Toolkit.getDefaultToolkit().getDesktopProperty()返回指定的系统桌面属性的 Toolkit.getDefaultToolkit().getDesktopProperty() 。

Object

JOptionPane.getInitialSelectionValue​()

返回最初显示为用户的输入值。

Object

JOptionPane.getInitialValue​()

返回初始值。

Object

JOptionPane.getInputValue​()

返回用户输入的值，如果 wantsInput为真。

Object

ComboBoxEditor.getItem​()

返回已编辑的项目

Object[]

AbstractAction.getKeys​()

返回一个 Object s的数组，它们是为这个 AbstractAction设置了值的键，如果没有键设置值，则 null 。

Object

JTree.getLastSelectedPathComponent​()

返回所选路径的最后一个路径组件。

Object

JOptionPane.getMessage​()

返回窗格显示的消息对象。

Object

JSpinner.getNextValue​()

返回由 getValue()返回的对象之后的序列中的对象。

Object

SpinnerDateModel.getNextValue​()

返回下 Date序列中，或 null如果下一个日期是后 end 。

Object

SpinnerListModel.getNextValue​()

返回底层序列的下一个合法值，如果值已经是最后一个元素，则返回 null 。

Object

SpinnerModel.getNextValue​()

按 getValue()返回的对象后面的顺序返回对象。

Object

SpinnerNumberModel.getNextValue​()

返回序列中的下一个数字。

Object[]

JOptionPane.getOptions​()

返回用户可以做出的选择。

Object

JSpinner.getPreviousValue​()

返回 getValue()返回的对象之前的序列中的对象。

Object

SpinnerDateModel.getPreviousValue​()

返回以前 Date序列中，或 null如果上一个日期是前 start 。

Object

SpinnerListModel.getPreviousValue​()

返回底层序列的前一个元素，如果值已经是第一个元素，则返回 null 。

Object

SpinnerModel.getPreviousValue​()

按 getValue()返回的对象之前的顺序返回对象。

Object

SpinnerNumberModel.getPreviousValue​()

返回序列中的前一个数字。

Object

ComboBoxModel.getSelectedItem​()

返回所选项目

Object

DefaultComboBoxModel.getSelectedItem​()

Object

JComboBox.getSelectedItem​()

返回当前所选项目。

Object[]

AbstractButton.getSelectedObjects​()

如果没有选择该按钮，则返回一个包含标签的数组（长度1）或 null 。

Object[]

DefaultButtonModel.getSelectedObjects​()

被 null返回 null 。

Object[]

JCheckBoxMenuItem.getSelectedObjects​()

返回一个包含复选框菜单项标签的数组（长度1），如果未选中该复选框，则返回null。

Object[]

JComboBox.getSelectedObjects​()

返回一个包含所选项目的数组。

Object[]

JList.getSelectedValues​()

已过时。
截至JDK 1.7，由JList.getSelectedValuesList()取代

Object[]

JOptionPane.getSelectionValues​()

返回输入选择值。

Object

AbstractAction.getValue​(String key)

获取与指定键相关联的 Object 。

Object

Action.getValue​(String key)

使用关联的键获取该对象的属性之一。

Object

JFormattedTextField.getValue​()

返回最后一个有效值。

Object

JOptionPane.getValue​()

返回用户选择的值。

Object

JSpinner.getValue​()

返回模型的当前值，通常这个值由 editor显示。

abstract Object

RowFilter.Entry.getValue​(int index)

返回指定索引处的值。

Object

SpinnerDateModel.getValue​()

返回此序列中的当前元素 Date s。

Object

SpinnerListModel.getValue​()

返回序列的当前元素。

Object

SpinnerModel.getValue​()

序列的 当前元素 。

Object

SpinnerNumberModel.getValue​()

返回序列的当前元素的值。

abstract Object

DefaultRowSorter.ModelWrapper.getValueAt​(int row, int column)

返回指定索引处的值。

Object

JTable.getValueAt​(int row, int column)

返回值为 row和 column的单元格值。

Object[]

ActionMap.keys​()

返回 Action了在这个约束的名字 ActionMap 。

static Object

LookAndFeel.makeIcon​(Class<?> baseClass, String gifFile)

创建并返回加载图像的 UIDefault.LazyValue 。

Object

UIDefaults.put​(Object key, Object value)

将所有区域设置的值为 key设置为 value 。

static Object

UIManager.put​(Object key, Object value)

在开发人员默认值中存储一个对象。

static Object

JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)

在阻止对话框中提示用户输入，可以指定初始选择，可能的选择和所有其他选项。

static Object

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)

在阻止内部对话框中提示输入用户，可以指定初始选择，可能的选择和所有其他选项。

abstract Object

JFormattedTextField.AbstractFormatter.stringToValue​(String text)

解析 text返回一个任意的对象。

Object[]

DefaultListModel.toArray​()

以正确的顺序返回包含此列表中所有元素的数组。

Methods in javax.swing with parameters of type Object

Modifier and Type

方法

描述

default boolean

Action.accept​(Object sender)

确定是否应该使用指定的发件人对象执行操作。

void

JTabbedPane.add​(Component component, Object constraints)

在选项卡窗格中添加 component 。

void

JTabbedPane.add​(Component component, Object constraints, int index)

在指定的选项卡索引中添加一个 component 。

protected void

AbstractButton.addImpl​(Component comp, Object constraints, int index)

将指定的组件添加到指定索引的此容器中，有关此方法的完整说明，请参阅 Container.addImpl(Component, Object, int) 。

protected void

CellRendererPane.addImpl​(Component x, Object constraints, int index)

如果指定的组件已经是一个小孩，那么我们不用担心任何事情 - 堆栈顺序对于单元格渲染器组件并不重要（CellRendererPane不会绘制）。

protected void

JApplet.addImpl​(Component comp, Object constraints, int index)

已过时。

添加指定的小孩 Component 。

protected void

JDesktopPane.addImpl​(Component comp, Object constraints, int index)

在指定的索引处将指定的组件添加到此容器。

protected void

JDialog.addImpl​(Component comp, Object constraints, int index)

添加指定的小孩 Component 。

protected void

JFrame.addImpl​(Component comp, Object constraints, int index)

添加指定的小孩 Component 。

protected void

JInternalFrame.addImpl​(Component comp, Object constraints, int index)

添加指定的小孩 Component 。

protected void

JLayer.addImpl​(Component comp, Object constraints, int index)

JLayer不支持此方法，并始终抛出 UnsupportedOperationException

protected void

JLayeredPane.addImpl​(Component comp, Object constraints, int index)

protected void

JRootPane.addImpl​(Component comp, Object constraints, int index)

覆盖以执行玻璃部件的位置作为零子。

protected void

JSplitPane.addImpl​(Component comp, Object constraints, int index)

将指定的组件添加到此拆分窗格。

protected void

JToolBar.addImpl​(Component comp, Object constraints, int index)

如果添加了一个 JButton ，它最初被设置为禁用。

protected void

JViewport.addImpl​(Component child, Object constraints, int index)

设置 JViewport的一个轻量级的小孩，可以是 null 。

protected void

JWindow.addImpl​(Component comp, Object constraints, int index)

添加指定的小孩 Component 。

void

BoxLayout.addLayoutComponent​(Component comp, Object constraints)

本课不使用

void

GroupLayout.addLayoutComponent​(Component component, Object constraints)

通知已将 Component添加到父容器。

void

JRootPane.RootLayout.addLayoutComponent​(Component comp, Object constraints)

void

OverlayLayout.addLayoutComponent​(Component comp, Object constraints)

使用指定的约束对象将指定的组件添加到布局。

void

SpringLayout.addLayoutComponent​(Component component, Object constraints)

如果 constraints是 constraints的实例， SpringLayout.Constraints约束与指定的组件关联。

void

JComboBox.configureEditor​(ComboBoxEditor anEditor, Object anItem)

用指定的项目初始化编辑器。

boolean

DefaultListModel.contains​(Object elem)

测试指定的对象是否是此列表中的组件。

String

JTree.convertValueToText​(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)

由渲染器调用，将指定的值转换为文本。

void

DefaultListModel.copyInto​(Object[] anArray)

将此列表的组件复制到指定的数组中。

static void

JTree.DynamicUtilTreeNode.createChildren​(DefaultMutableTreeNode parent, Object children)

添加到父母所有的孩子在 children 。

protected static TreeModel

JTree.createTreeModel​(Object value)

返回包装指定对象的 TreeModel 。

boolean

RowSorter.SortKey.equals​(Object o)

如果此对象等于指定的对象，则返回true。

protected void

AbstractListModel.fireContentsChanged​(Object source, int index0, int index1)

AbstractListModel子类必须在列表的一个或多个元素更改 后调用此方法。

protected void

AbstractListModel.fireIntervalAdded​(Object source, int index0, int index1)

AbstractListModel子类必须 在将一个或多个元素添加到模型 后调用此方法。

protected void

AbstractListModel.fireIntervalRemoved​(Object source, int index0, int index1)

AbstractListModel子类必须 在从模型中删除一个或多个元素 之后调用此方法。

protected void

AbstractAction.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告绑定属性更改。

protected void

DefaultListCellRenderer.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

由于性能原因而被覆盖。

protected void

JViewport.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

通知侦听器属性更改。

void

SwingWorker.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

向任何已注册的监听器报告绑定属性更新。

protected void

UIDefaults.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告绑定属性更改。

protected void

JComponent.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)

支持报告受限的属性更改。

Action

ActionMap.get​(Object key)

返回 key的绑定，如果绑定未在本地定义，则发送消息，父母 ActionMap 。

Object

UIDefaults.get​(Object key)

返回值的值。

Object

UIDefaults.get​(Object key, Locale l)

返回与给定语言环境相关联的键的值。

static Object

UIManager.get​(Object key)

从默认值返回一个对象。

static Object

UIManager.get​(Object key, Locale l)

从适用于给定语言环境的默认值返回一个对象。

boolean

UIDefaults.getBoolean​(Object key)

如果值为 key是布尔值，则返回布尔值，否则返回false。

boolean

UIDefaults.getBoolean​(Object key, Locale l)

如果值 key对于给定 Locale是布尔值，则返回该boolean值，否则返回false。

static boolean

UIManager.getBoolean​(Object key)

从与键值相关联的默认值返回一个布尔值。

static boolean

UIManager.getBoolean​(Object key, Locale l)

从与键值和给定的 Locale相关联的默认值返回一个布尔值。

Border

UIDefaults.getBorder​(Object key)

如果 key的值是 Border返回，否则返回 null 。

Border

UIDefaults.getBorder​(Object key, Locale l)

如果值 key对于给定 Locale是 Border返回它，否则返回 null 。

static Border

UIManager.getBorder​(Object key)

从默认值返回一个边框。

static Border

UIManager.getBorder​(Object key, Locale l)

从适用于给定语言环境的默认值返回一个边框。

Object

JComponent.getClientProperty​(Object key)

使用指定的键返回属性的值。

Color

UIDefaults.getColor​(Object key)

如果 key的值是 Color返回，否则返回 null 。

Color

UIDefaults.getColor​(Object key, Locale l)

如果 key为 Locale值为 Color返回，否则返回 null 。

static Color

UIManager.getColor​(Object key)

从默认值返回颜色。

static Color

UIManager.getColor​(Object key, Locale l)

从适用于给定语言环境的默认值返回颜色。

TableColumn

JTable.getColumn​(Object identifier)

返回 TableColumn对象，该对象的标识符等于 identifier ，当与 equals进行比较时。

static Object

LookAndFeel.getDesktopPropertyValue​(String systemPropertyName, Object fallbackValue)

通过调用 Toolkit.getDefaultToolkit().getDesktopProperty()返回指定的系统桌面属性的 Toolkit.getDefaultToolkit().getDesktopProperty() 。

Dimension

UIDefaults.getDimension​(Object key)

如果 key的值是 Dimension返回，否则返回 null 。

Dimension

UIDefaults.getDimension​(Object key, Locale l)

如果值 key对于给定 Locale是 Dimension返回它，否则返回 null 。

static Dimension

UIManager.getDimension​(Object key)

从默认值返回维度。

static Dimension

UIManager.getDimension​(Object key, Locale l)

从适用于给定语言环境的默认值返回维度。

Font

UIDefaults.getFont​(Object key)

如果 key的值是 Font返回，否则返回 null 。

Font

UIDefaults.getFont​(Object key, Locale l)

如果 key的给定 Locale Font ，则返回 null ，否则返回 null 。

static Font

UIManager.getFont​(Object key)

从默认值返回一个字体。

static Font

UIManager.getFont​(Object key, Locale l)

从适用于给定语言环境的默认值返回一个字体。

Icon

UIDefaults.getIcon​(Object key)

如果 key的值是 Icon返回，否则返回 null 。

Icon

UIDefaults.getIcon​(Object key, Locale l)

如果 key的值为 key ， Locale Icon返回，否则返回 null 。

static Icon

UIManager.getIcon​(Object key)

从默认值返回 Icon 。

static Icon

UIManager.getIcon​(Object key, Locale l)

从适用于给定语言环境的默认值返回 Icon 。

int

DefaultComboBoxModel.getIndexOf​(Object anObject)

返回列表中指定对象的索引位置。

Insets

UIDefaults.getInsets​(Object key)

如果值 key是 Insets返回它，否则返回 null 。

Insets

UIDefaults.getInsets​(Object key, Locale l)

如果 key对于 key为 Locale的 Insets返回，否则返回 null 。

static Insets

UIManager.getInsets​(Object key)

从默认值返回一个 Insets对象。

static Insets

UIManager.getInsets​(Object key, Locale l)

从适用于给定语言环境的默认值返回 Insets对象。

int

UIDefaults.getInt​(Object key)

如果 key值为 Integer返回其整数值，否则返回0。

int

UIDefaults.getInt​(Object key, Locale l)

如果值 key对于给定 Locale是 Integer返回其整数值，否则返回0。

static int

UIManager.getInt​(Object key)

从默认值返回一个整数。

static int

UIManager.getInt​(Object key, Locale l)

从适用于给定语言环境的默认值返回一个整数。

Component

DefaultListCellRenderer.getListCellRendererComponent​(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)

String

UIDefaults.getString​(Object key)

如果 key的值是 String返回，否则返回 null 。

String

UIDefaults.getString​(Object key, Locale l)

如果 key为 Locale为 String回报，否则返回 null 。

static String

UIManager.getString​(Object key)

从默认值返回一个字符串。

static String

UIManager.getString​(Object key, Locale l)

从适用于给定语言环境的默认值返回一个字符串。

Component

DefaultCellEditor.getTableCellEditorComponent​(JTable table, Object value, boolean isSelected, int row, int column)

实现 TableCellEditor界面。

Component

DefaultCellEditor.getTreeCellEditorComponent​(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)

实现 TreeCellEditor界面。

int

DefaultListModel.indexOf​(Object elem)

搜索首次发生 elem 。

int

DefaultListModel.indexOf​(Object elem, int index)

搜索首次发生 elem ，开始搜索 index 。

static void

LookAndFeel.installProperty​(JComponent c, String propertyName, Object propertyValue)

如果开发人员尚未设置该属性，则在方法上安装具有指定名称和值的属性。

int

DefaultListModel.lastIndexOf​(Object elem)

返回上一次发生的索引 elem 。

int

DefaultListModel.lastIndexOf​(Object elem, int index)

向后搜索 elem ，从指定的索引开始，并返回一个索引。

static void

LookAndFeel.loadKeyBindings​(InputMap retMap, Object[] keys)

使用指定的绑定填充 InputMap 。

static ComponentInputMap

LookAndFeel.makeComponentInputMap​(JComponent c, Object[] keys)

创建 ComponentInputMapUIResource从 keys 。

static InputMap

LookAndFeel.makeInputMap​(Object[] keys)

创建 InputMapUIResource从 keys 。

static JTextComponent.KeyBinding[]

LookAndFeel.makeKeyBindings​(Object[] keyBindingList)

构建 KeyBindings数组的便利方法。

static boolean

SwingUtilities.notifyAction​(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)

调用 actionPerformed上 action如果 action是非 null并接受发送对象。

protected void

SwingWorker.publish​(V... chunks)

发送数据块到 SwingWorker.process(java.util.List<V>)方法。

void

ActionMap.put​(Object key, Action action)

添加一个绑定 key到 action 。

void

ComponentInputMap.put​(KeyStroke keyStroke, Object actionMapKey)

为 keyStroke添加一个绑定到 actionMapKey 。

void

InputMap.put​(KeyStroke keyStroke, Object actionMapKey)

为 keyStroke添加一个绑定到 actionMapKey 。

Object

UIDefaults.put​(Object key, Object value)

将所有区域设置的值为 key设置为 value 。

static Object

UIManager.put​(Object key, Object value)

在开发人员默认值中存储一个对象。

void

JComponent.putClientProperty​(Object key, Object value)

向此组件添加任意键/值“客户端属性”。

void

UIDefaults.putDefaults​(Object[] keyValueList)

将所有键/值对放在数据库中，并无条件地生成一个 PropertyChangeEvent 。

void

AbstractAction.putValue​(String key, Object newValue)

设置与指定键相关联的 Value 。

void

Action.putValue​(String key, Object value)

使用关联的键设置此对象的属性之一。

void

JEditorPane.read​(InputStream in, Object desc)

此方法从流初始化。

void

ActionMap.remove​(Object key)

从 ActionMap删除 key的绑定。

void

DefaultComboBoxModel.removeElement​(Object anObject)

boolean

DefaultListModel.removeElement​(Object obj)

从此列表中删除参数的第一个（最低索引）出现次数。

void

MutableComboBoxModel.removeElement​(Object obj)

从模型中删除一个项目。

void

JComboBox.removeItem​(Object anObject)

从项目列表中删除一个项目。

void

JOptionPane.setInitialSelectionValue​(Object newValue)

将最初显示为选定的输入值设置为用户。

void

JOptionPane.setInitialValue​(Object newInitialValue)

设置要启用的初始值 - 初始显示窗格时具有焦点的 Component 。

void

JOptionPane.setInputValue​(Object newValue)

设置用户选择或输入的输入值。

void

ComboBoxEditor.setItem​(Object anObject)

设置应编辑的项目。

void

JList.setListData​(E[] listData)

从一系列项目构建只读 ListModel ，并使用此模型调用 setModel 。

void

JOptionPane.setMessage​(Object newMessage)

设置选项窗格的消息对象。

void

JOptionPane.setOptions​(Object[] newOptions)

设置该窗格显示的选项。

void

ComboBoxModel.setSelectedItem​(Object anItem)

设置所选项目。

void

DefaultComboBoxModel.setSelectedItem​(Object anObject)

设置所选项目的值。

void

JComboBox.setSelectedItem​(Object anObject)

将组合框显示区域中的选定项目设置为参数中的对象。

void

JList.setSelectedValue​(Object anObject, boolean shouldScroll)

从列表中选择指定的对象。

void

JOptionPane.setSelectionValues​(Object[] newValues)

设置为用户提供可供选择的项目列表的窗格的输入选择值。

void

DefaultCellEditor.EditorDelegate.setValue​(Object value)

设置此单元格的值。

void

JFormattedTextField.setValue​(Object value)

设置将通过被格式化的值 AbstractFormatter从当前获得的 AbstractFormatterFactory 。

void

JOptionPane.setValue​(Object newValue)

设置用户选择的值。

void

JSpinner.setValue​(Object value)

改变模型的当前值，通常这个值由 editor显示。

void

Renderer.setValue​(Object aValue, boolean isSelected)

指定要显示的值以及该值是否应被描述为“当前选择”。

void

SpinnerDateModel.setValue​(Object value)

设置此序列的当前 Date 。

void

SpinnerListModel.setValue​(Object elt)

更改序列的当前元素并通知 ChangeListeners 。

void

SpinnerModel.setValue​(Object value)

更改模型的当前值，通常这个值由 editor部分 JSpinner 。

void

SpinnerNumberModel.setValue​(Object value)

设置此序列的当前值。

void

JTable.setValueAt​(Object aValue, int row, int column)

设置表模型中单元格的值为 row和 column 。

static int

JOptionPane.showConfirmDialog​(Component parentComponent, Object message)

启动对话框，选择是 ， 否和取消 ; 标题为“ 选择选项” 。

static int

JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType)

提出一个对话框，其中选择次数由 optionType参数决定。

static int

JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType)

调出其中的选项的数目由所确定的一个对话框 optionType参数，其中，所述 messageType参数确定要显示的图标。

static int

JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)

启动具有指定图标的对话框，其中选择的数量由 optionType参数确定。

static String

JOptionPane.showInputDialog​(Component parentComponent, Object message)

显示一个问题消息对话框，要求从父母的用户输入 parentComponent 。

static String

JOptionPane.showInputDialog​(Component parentComponent, Object message, Object initialSelectionValue)

显示一个问题消息对话框，请求从用户输入并父母为 parentComponent 。

static String

JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType)

显示一个对话框，请求从用户父母的输入 parentComponent ，对话框具有标题 title和消息类型 messageType 。

static Object

JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)

在阻止对话框中提示用户输入，可以指定初始选择，可能的选择和所有其他选项。

static String

JOptionPane.showInputDialog​(Object message)

显示一个请求用户输入的问题消息对话框。

static String

JOptionPane.showInputDialog​(Object message, Object initialSelectionValue)

显示询问消息对话框，请求用户输入，输入值初始化为 initialSelectionValue 。

static int

JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message)

启动一个内部对话面板，选择是 ， 否和取消 ; 标题为“ 选择选项” 。

static int

JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType)

启动内部对话面板，其中选择次数由 optionType参数确定。

static int

JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType)

调出其中的选项数由所确定的内部对话框面板 optionType参数，其中，所述 messageType参数确定要显示的图标。

static int

JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)

启动具有指定图标的内部对话面板，其中选择次数由 optionType参数确定。

static String

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message)

显示一个内部问题消息对话框，要求从父母的用户输入 parentComponent 。

static String

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType)

显示一个内部对话框，请求从 parentComponent父母的用户输入，对话框标题为 title ，消息类型为 messageType 。

static Object

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)

在阻止内部对话框中提示输入用户，可以指定初始选择，可能的选择和所有其他选项。

static void

JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message)

启动内部确认对话框面板。

static void

JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message, String title, int messageType)

启动内部对话面板，使用 messageType参数确定的默认图标显示消息。

static void

JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon)

启动一个显示消息的内部对话框面板，指定所有参数。

static int

JOptionPane.showInternalOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)

启动具有指定图标的内部对话面板，其中初始选择由 initialValue参数确定，选择次数由 optionType参数确定。

static void

JOptionPane.showMessageDialog​(Component parentComponent, Object message)

提供一个名为“消息”的信息消息对话框。

static void

JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType)

使用由 messageType参数确定的默认图标显示消息的对话框。

static void

JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon)

显示一个显示消息的对话框，指定所有参数。

static int

JOptionPane.showOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)

启动一个带有指定图标的对话框，其中初始选择由 initialValue参数确定，选择次数由 optionType参数决定。

abstract String

JFormattedTextField.AbstractFormatter.valueToString​(Object value)

返回要显示 value的字符串值。

Constructors in javax.swing with parameters of type Object

Constructor

描述

DefaultComboBoxModel​(E[] items)

构造一个使用对象数组初始化的DefaultComboBoxModel对象。

DynamicUtilTreeNode​(Object value, Object children)

创建具有指定对象的节点作为其值和指定的子节点。

JComboBox​(E[] items)

创建一个 JComboBox ，其中包含指定数组中的元素。

JFormattedTextField​(Object value)

创建一个具有指定值的JFormattedTextField。

JFormattedTextField​(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)

创建一个 JFormattedTextField与指定的 AbstractFormatterFactory和初始值。

JList​(E[] listData)

构造一个 JList ，显示指定数组中的元素。

JOptionPane​(Object message)

创建一个 JOptionPane的实例，使用简单消息消息类型和UI提供的默认选项来显示消息。

JOptionPane​(Object message, int messageType)

创建 JOptionPane的实例以显示具有指定消息类型和默认选项的消息，

JOptionPane​(Object message, int messageType, int optionType)

创建 JOptionPane的实例以显示具有指定消息类型和选项的消息。

JOptionPane​(Object message, int messageType, int optionType, Icon icon)

创建 JOptionPane的实例以显示具有指定消息类型，选项和图标的消息。

JOptionPane​(Object message, int messageType, int optionType, Icon icon, Object[] options)

创建 JOptionPane的实例以显示具有指定消息类型，图标和选项的消息。

JOptionPane​(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)

创建 JOptionPane的实例以显示具有指定的消息类型，图标和选项的消息，并指定最初选择的选项。

JTable​(Object[][] rowData, Object[] columnNames)

构造一个 JTable以显示二维数组中的值， rowData ，列名称为 columnNames 。

JTree​(Object[] value)

返回 JTree与指定数组的每个元素作为未显示的新根节点的子节点。

LazyInputMap​(Object[] bindings)

构造一个 LazyInputMap 。

ProgressMonitor​(Component parentComponent, Object message, String note, int min, int max)

构造一个显示进度的图形对象，通常通过填充矩形栏来完成过程。

ProgressMonitorInputStream​(Component parentComponent, Object message, InputStream in)

构造一个对象来监视输入流的进度。

ProxyLazyValue​(String c, Object[] o)

创建一个 LazyValue ，它将在询问时构建一个实例。

ProxyLazyValue​(String c, String m, Object[] o)

创建一个 LazyValue ，这将在被询问时构建一个实例。

SpinnerListModel​(Object[] values)

构造一个 SpinnerModel其值序列由指定的数组定义。

UIDefaults​(Object[] keyValueList)

创建使用指定的键/值对初始化的默认值表。

Uses of Object in javax.swing.border

Subclasses of Object in javax.swing.border

Modifier and Type

Class

描述

class

AbstractBorder

实现无大小空白边框的类。

class

BevelBorder

一个实现一个简单的两行斜角边框的类。

class

CompoundBorder

一个复合的Border类，用于通过在Border对象的外部嵌套内嵌一个Border对象来将两个Border对象组合成一个单一的边框。

class

EmptyBorder

一个提供一个空的透明边框的类，占用空间但不绘图。

class

EtchedBorder

一个实现一个简单蚀刻边界的课程，可以被蚀刻或蚀刻出来。

class

LineBorder

实现任意厚度和单一颜色的线边框的类。

class

MatteBorder

一个提供纯色或平铺图标的无光泽边框的课程。

class

SoftBevelBorder

实现具有软化拐角的凸起或降低的斜面的课程。

class

StrokeBorder

实现任意笔画边框的课程。

class

TitledBorder

一个实现一个任意边框的类，在一个指定的位置添加一个String标题和对齐。

Uses of Object in javax.swing.colorchooser

Subclasses of Object in javax.swing.colorchooser

Modifier and Type

Class

描述

class

AbstractColorChooserPanel

这是颜色选择器的抽象超类。

class

ColorChooserComponentFactory

一个设计用于生产预配置的“附件”对象以插入到颜色选择器中的类。

class

DefaultColorSelectionModel

通用实现 ColorSelectionModel 。

Uses of Object in javax.swing.event

Subclasses of Object in javax.swing.event

Modifier and Type

Class

描述

class

AncestorEvent

向组件层级中的祖先发送的子组件的事件。

class

CaretEvent

CaretEvent用于通知有关方面事件源文本插入符已更改。

class

ChangeEvent

ChangeEvent用于通知有关方面事件来源状态已更改。

static class

DocumentEvent.EventType

文档事件类型的枚举

class

EventListenerList

一个持有EventListener列表的类。

class

HyperlinkEvent

HyperlinkEvent用于通知有关方面，超文本链接发生了一些事情。

static class

HyperlinkEvent.EventType

定义ENTERED，EXITED和ACTIVATED事件类型以及由toString（）返回的字符串表示形式。

class

InternalFrameAdapter

用于接收内部帧事件的抽象适配器类。

class

InternalFrameEvent

一个 AWTEvent添加了对 JInternalFrame对象的支持作为事件源。

class

ListDataEvent

定义将更改封装到列表的事件。

class

ListSelectionEvent

表征选择变化的事件。

class

MenuDragMouseEvent

MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。

class

MenuEvent

MenuEvent用于通知有关方面，事件源的菜单已经过滤，选择或取消。

class

MenuKeyEvent

MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。

class

MouseInputAdapter

一个空的实现的 MouseInputListener接口，提供了方便简化创建监听器的任务，只通过扩展和实现感兴趣的方法。

class

PopupMenuEvent

PopupMenuEvent仅包含发送事件的JPopupMenu事件的源

class

RowSorterEvent

RowSorterEvent提供改变到的通知 RowSorter 。

class

SwingPropertyChangeSupport

java.beans.PropertyChangeSupport这个子类功能几乎相同。

class

TableColumnModelEvent

TableColumnModelEvent用于通知侦听器表列模型已更改，例如添加，删除或移动列。

class

TableModelEvent

TableModelEvent用于通知侦听器表模型已更改。

class

TreeExpansionEvent

用于标识树中单个路径的事件。

class

TreeModelEvent

将描述更改的信息封装到树模型，并用于通知树型模型侦听器的更改。

class

TreeSelectionEvent

表示当前选择的变化的事件。

class

UndoableEditEvent

发生可以撤消的操作的事件。

Fields in javax.swing.event declared as Object

Modifier and Type

Field

描述

protected Object[]

TreeModelEvent.children

被删除的孩子

protected Object[]

EventListenerList.listenerList

ListenerType - Listener对的列表

Methods in javax.swing.event that return Object

Modifier and Type

方法

描述

Object

TreeSelectionEvent.cloneWithSource​(Object newSource)

返回接收者的副本，但源代码是newSource。

Object[]

TreeModelEvent.getChildren​()

返回由标识节点的子对象 getPath在由指定的位置 getChildIndices 。

Object[]

EventListenerList.getListenerList​()

将事件侦听器列表作为ListenerType侦听器对的数组传回。

Object[]

TreeModelEvent.getPath​()

从事件包装的TreePath实例获取对象数组的便利方法。

Methods in javax.swing.event with parameters of type Object

Modifier and Type

方法

描述

Object

TreeSelectionEvent.cloneWithSource​(Object newSource)

返回接收者的副本，但源代码是newSource。

Constructors in javax.swing.event with parameters of type Object

Constructor

描述

CaretEvent​(Object source)

创建一个新的CaretEvent对象。

ChangeEvent​(Object source)

构造一个ChangeEvent对象。

HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u)

创建一个表示超文本链接事件的新对象。

HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc)

创建一个表示超文本链接事件的新对象。

HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)

创建一个表示超文本链接事件的新对象。

HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement, InputEvent inputEvent)

创建一个表示超文本链接事件的新对象。

ListDataEvent​(Object source, int type, int index0, int index1)

构造一个ListDataEvent对象。

ListSelectionEvent​(Object source, int firstIndex, int lastIndex, boolean isAdjusting)

表示 firstIndex和 lastIndex之间选择状态的变化。

MenuEvent​(Object source)

构造一个MenuEvent对象。

PopupMenuEvent​(Object source)

构造一个PopupMenuEvent对象。

SwingPropertyChangeSupport​(Object sourceBean)

构造一个SwingPropertyChangeSupport对象。

SwingPropertyChangeSupport​(Object sourceBean, boolean notifyOnEDT)

构造一个SwingPropertyChangeSupport对象。

TreeExpansionEvent​(Object source, TreePath path)

构造一个TreeExpansionEvent对象。

TreeModelEvent​(Object source, Object[] path)

用于在节点结构以某种方式更改时创建事件，将修改后的子树的根目录的路径标识为对象数组。

TreeModelEvent​(Object source, Object[] path, int[] childIndices, Object[] children)

用于在更改，插入或删除节点时创建事件，将修改后的项目的父项路径标识为对象数组。

TreeModelEvent​(Object source, TreePath path)

用于在节点结构以某种方式更改时创建事件，将修改后的子树的根路径标识为TreePath对象。

TreeModelEvent​(Object source, TreePath path, int[] childIndices, Object[] children)

用于在更改，插入或删除节点时创建事件，将修改后的项目的父项路径标识为TreePath对象。

TreeSelectionEvent​(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)

代表一个 TreeSelectionModel的选择的 TreeSelectionModel 。

TreeSelectionEvent​(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)

代表一个 TreeSelectionModel的选择的 TreeSelectionModel 。

UndoableEditEvent​(Object source, UndoableEdit edit)

构造一个UndoableEditEvent对象。

Uses of Object in javax.swing.filechooser

Subclasses of Object in javax.swing.filechooser

Modifier and Type

Class

描述

class

FileFilter

FileFilter是 JFileChooser用于过滤向用户显示的文件集的抽象类。

class

FileNameExtensionFilter

过滤使用指定的一组扩展的 FileFilter的实现。

class

FileSystemView

FileSystemView是JFileChooser到文件系统的网关。

class

FileView

FileView定义了可被实现为提供有用于UI信息的文件选择一个抽象类 File 。

Uses of Object in javax.swing.plaf

Subclasses of Object in javax.swing.plaf

Modifier and Type

Class

描述

class

ActionMapUIResource

实现UIResource的javax.swing.ActionMap的子类。

class

BorderUIResource

实现UIResource的边界包装类。

static class

BorderUIResource.BevelBorderUIResource

斜角边界UI资源。

static class

BorderUIResource.CompoundBorderUIResource

复合边界UI资源。

static class

BorderUIResource.EmptyBorderUIResource

一个空的边界UI资源。

static class

BorderUIResource.EtchedBorderUIResource

蚀刻的边界UI资源。

static class

BorderUIResource.LineBorderUIResource

线边界UI资源。

static class

BorderUIResource.MatteBorderUIResource

无边界的UI资源。

static class

BorderUIResource.TitledBorderUIResource

标题边界UI资源。

class

ButtonUI

JButton可插拔的外观和界面。

class

ColorChooserUI

JColorChooser可插拔的外观和界面。

class

ColorUIResource

实现UIResource的Color子类。

class

ComboBoxUI

JComboBox可插拔的外观和界面。

class

ComponentInputMapUIResource

实现UIResource的javax.swing.ComponentInputMap的子类。

class

ComponentUI

所有UI委托对象的基类在Swing可插拔外观和体系结构中。

class

DesktopIconUI

JDesktopIcon可插拔的外观和界面。

class

DesktopPaneUI

JDesktopPane可插拔外观界面。

class

DimensionUIResource

Dimension的子类实现 UIResource 。

class

FileChooserUI

可插拔外观界面 JFileChooser 。

class

FontUIResource

实现UIResource的java.awt.Font的子类。

class

IconUIResource

一个实现UIResource的图标包装类。

class

InputMapUIResource

实现UIResource的javax.swing.InputMap的子类。

class

InsetsUIResource

Insets实现UIResource的子类。

class

InternalFrameUI

JInternalFrame可插拔的外观和界面。

class

LabelUI

JLabel可插拔的外观和界面。

class

LayerUI<V extends Component>

所有JLayer的UI代表的基础类。

class

ListUI

JList可插拔的外观和感觉代表。

class

MenuBarUI

JMenuBar可插拔的外观和界面。

class

MenuItemUI

JMenuItem可插拔的外观和界面。

class

OptionPaneUI

JOptionPane可插拔的外观和界面。

class

PanelUI

面板可插拔的外观和界面。

class

PopupMenuUI

JPopupMenu可插拔的外观和界面。

class

ProgressBarUI

JProgressBar可插拔的外观和界面。

class

RootPaneUI

JRootPane可插拔的外观和界面。

class

ScrollBarUI

JScrollBar可插拔的外观和界面。

class

ScrollPaneUI

JScrollPane可插拔的外观和界面。

class

SeparatorUI

JSeparator可插拔的外观和界面。

class

SliderUI

JSlider可插拔的外观和界面。

class

SpinnerUI

JSpinner可插拔的外观和界面

class

SplitPaneUI

JSplitPane可插拔的外观和界面。

class

TabbedPaneUI

JTabbedPane可插拔的外观和界面。

class

TableHeaderUI

JTableHeader的可插拔外观界面。

class

TableUI

JTable可插拔的外观和界面。

class

TextUI

文本编辑器用户界面

class

ToolBarUI

JToolBar可插拔的外观和界面。

class

ToolTipUI

JToolTip可插拔的外观和界面。

class

TreeUI

JTree可插拔的外观和界面。

class

ViewportUI

JViewport可插拔的外观和界面。

Methods in javax.swing.plaf with parameters of type Object

Modifier and Type

方法

描述

protected void

LayerUI.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告对象属性的绑定属性更改。

Uses of Object in javax.swing.plaf.basic

Subclasses of Object in javax.swing.plaf.basic

Modifier and Type

Class

描述

class

BasicArrowButton

JButton对象在其中一个主要方向上绘制了一个缩放的箭头。

class

BasicBorders

工厂对象可以出售适用于基本L＆F的边界

static class

BasicBorders.ButtonBorder

画一个按钮周围的边框。

static class

BasicBorders.FieldBorder

绘制一个字段周围的边框。

static class

BasicBorders.MarginBorder

围绕支持边距的组件绘制边框。

static class

BasicBorders.MenuBarBorder

绘制菜单栏周围的边框。

static class

BasicBorders.RadioButtonBorder

绘制单选按钮周围的边框。

static class

BasicBorders.RolloverButtonBorder

特殊的细边框，用于翻转工具栏按钮。

static class

BasicBorders.SplitPaneBorder

画出裂缝周围的边界。

static class

BasicBorders.ToggleButtonBorder

绘制切换按钮周围的边框。

class

BasicButtonListener

按钮监听器

class

BasicButtonUI

BasicButton实现

class

BasicCheckBoxMenuItemUI

BasicCheckboxMenuItem实现

class

BasicCheckBoxUI

BasicCheckboxUI的CheckboxUI实现

class

BasicColorChooserUI

为JColorChooser提供基本的外观和感觉。

class

BasicColorChooserUI.PropertyHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicComboBoxEditor

可编辑组合框的默认编辑器。

static class

BasicComboBoxEditor.UIResource

BasicComboBoxEditor的子类实现UIResource。

class

BasicComboBoxRenderer

ComboBox渲染器

static class

BasicComboBoxRenderer.UIResource

BasicComboBoxRenderer的子类实现UIResource。

class

BasicComboBoxUI

JComboBox的基本UI实现。

class

BasicComboBoxUI.ComboBoxLayoutManager

该布局管理器处理组合框的“标准”布局。

class

BasicComboBoxUI.FocusHandler

当焦点丢失时，此侦听器隐藏弹出窗口。

class

BasicComboBoxUI.ItemHandler

此监听器监视组合框中对选择的更改。

class

BasicComboBoxUI.KeyHandler

该侦听器检查键事件是否不是导航键。

class

BasicComboBoxUI.ListDataHandler

这位听众观看 ComboBoxModel变化。

class

BasicComboBoxUI.PropertyChangeHandler

该监听器监视组合框中已更改的绑定属性。

class

BasicComboPopup

这是 ComboPopup接口的基本实现。

class

BasicComboPopup.InvocationKeyHandler

从Java 2平台v 1.4开始，此类现在已经过时，仅用于向后兼容API。

protected class

BasicComboPopup.InvocationMouseHandler

在组合框（ 而不是其弹出菜单）上注册的侦听器来处理影响弹出菜单状态的鼠标事件。

protected class

BasicComboPopup.InvocationMouseMotionHandler

如果拖动列表，该监听器将监视拖动并更新列表中的当前选择。

protected class

BasicComboPopup.ItemHandler

此监听器监视组合框中对选择的更改。

class

BasicComboPopup.ListDataHandler

从1.4开始，这个类现在已经过时了，不做任何事情，只能包含用于向后兼容的API。

protected class

BasicComboPopup.ListMouseHandler

当列表中释放鼠标时，此侦听器会隐藏弹出窗口。

protected class

BasicComboPopup.ListMouseMotionHandler

当您将鼠标移动到列表上时，此侦听器将更改所选项。

protected class

BasicComboPopup.ListSelectionHandler

从Java 2平台v 1.4开始，这个类现在已经过时了，不做任何事情，只包含在后端的API兼容性中。

protected class

BasicComboPopup.PropertyChangeHandler

该监听器监视组合框中已更改的绑定属性。

class

BasicDesktopIconUI

桌面上最小化窗口的基本L＆F。

class

BasicDesktopIconUI.MouseInputHandler

监听鼠标移动并对其进行操作。

class

BasicDesktopPaneUI

台式机的基本L＆F。

protected class

BasicDesktopPaneUI.CloseAction

处理关闭内部框架。

protected class

BasicDesktopPaneUI.MaximizeAction

处理最大化内部框架。

protected class

BasicDesktopPaneUI.MinimizeAction

处理最小化内部框架。

protected class

BasicDesktopPaneUI.NavigateAction

处理导航到下一个内部框架。

protected class

BasicDesktopPaneUI.OpenAction

处理恢复最小化或最大化的内部框架。

class

BasicDirectoryModel

文件列表的基本实现。

class

BasicEditorPaneUI

为JEditorPane提供外观和感觉。

class

BasicFileChooserUI

FileChooser的基本L＆F实现。

protected class

BasicFileChooserUI.AcceptAllFileFilter

接受所有文件过滤器。

protected class

BasicFileChooserUI.ApproveSelectionAction

响应打开或保存请求

protected class

BasicFileChooserUI.BasicFileView

一个基本的文件视图。

protected class

BasicFileChooserUI.CancelSelectionAction

回复取消请求。

protected class

BasicFileChooserUI.ChangeToParentDirectoryAction

更改为父目录操作。

protected class

BasicFileChooserUI.DoubleClickListener

双击监听器。

protected class

BasicFileChooserUI.GoHomeAction

在“家”键事件或等效事件上行事。

protected class

BasicFileChooserUI.NewFolderAction

创建一个新文件夹。

protected class

BasicFileChooserUI.SelectionListener

选择听众。

protected class

BasicFileChooserUI.UpdateAction

重新扫描当前目录中的文件

class

BasicFormattedTextFieldUI

提供 JFormattedTextField的外观和实现。

class

BasicGraphicsUtils

方便的util类。

class

BasicHTML

支持为swing组件提供html视图。

class

BasicIconFactory

工厂对象可以将图标适用于基本的L＆F

class

BasicInternalFrameTitlePane

管理基本标题栏的类

class

BasicInternalFrameTitlePane.CloseAction

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.IconifyAction

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.MaximizeAction

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.MoveAction

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.PropertyChangeHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.RestoreAction

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.SizeAction

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.SystemMenuBar

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameTitlePane.TitlePaneLayout

这个类应该被视为一个“受保护”的内部类。

class

BasicInternalFrameUI

JInternalFrame的基本L＆F实现。

protected class

BasicInternalFrameUI.BasicInternalFrameListener

基本内部框架监听器。

protected class

BasicInternalFrameUI.BorderListener

倾听边界调整。

protected class

BasicInternalFrameUI.ComponentHandler

组件处理程序

protected class

BasicInternalFrameUI.GlassPaneDispatcher

玻璃窗格调度器。

class

BasicInternalFrameUI.InternalFrameLayout

内部框架布局。

class

BasicInternalFrameUI.InternalFramePropertyChangeListener

内部框架属性更改侦听器。

class

BasicLabelUI

LabelUI的Windows L＆F实现。

class

BasicListUI

可扩展的实现 ListUI 。

class

BasicListUI.FocusHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicListUI.ListDataHandler

该 ListDataListener被添加到 JLists型号在 installUI time ，并且每当JList.model属性更改。

class

BasicListUI.ListSelectionHandler

在installUI时添加到JLists选择模型的ListSelectionListener，以及JList.selectionModel属性更改时。

class

BasicListUI.MouseInputHandler

鼠标输入和JList的焦点处理。

class

BasicListUI.PropertyChangeHandler

在InstallUI时添加到JList的PropertyChangeListener。

class

BasicLookAndFeel

用于创建Swing的外观的基础类。

class

BasicMenuBarUI

MenuBarUI的默认L＆F实现。

class

BasicMenuItemUI

BasicMenuItem实现

protected class

BasicMenuItemUI.MouseInputHandler

鼠标输入处理程序

class

BasicMenuUI

MenuUI的默认L＆F实现。

class

BasicMenuUI.ChangeHandler

从Java 2平台1.4开始，这个以前没有记录的类现在已经过时了。

protected class

BasicMenuUI.MouseInputHandler

由菜单项实例化和使用，以处理鼠标事件当前的菜单选择。

class

BasicOptionPaneUI

为 JOptionPane提供基本的外观和感觉。

class

BasicOptionPaneUI.ButtonActionListener

这个类应该被视为一个“受保护”的内部类。

static class

BasicOptionPaneUI.ButtonAreaLayout

ButtonAreaLayout行为类似于 FlowLayout 。

class

BasicOptionPaneUI.PropertyChangeHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicPanelUI

BasicPanel实现

class

BasicPasswordFieldUI

提供Windows外观和密码字段。

class

BasicPopupMenuSeparatorUI

PopupMenuSeparatorUI的基本L＆F实现。

class

BasicPopupMenuUI

一个Windows L＆F实现的PopupMenuUI。

class

BasicProgressBarUI

ProgressBarUI的基本L＆F实现。

class

BasicProgressBarUI.ChangeHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicRadioButtonMenuItemUI

BasicRadioButtonMenuItem实现

class

BasicRadioButtonUI

BasicRadioButtonUI的RadioButtonUI实现

class

BasicRootPaneUI

RootPaneUI的基本实现，所有JRootPane实例之间共享一个。

class

BasicScrollBarUI

实现ScrollBarUI的基本外观和感觉

protected class

BasicScrollBarUI.ArrowButtonListener

光标键侦听器。

protected class

BasicScrollBarUI.ModelListener

监听模式更改的监听器。

class

BasicScrollBarUI.PropertyChangeHandler

属性更改处理程序

protected class

BasicScrollBarUI.ScrollListener

ScrollPane发起的滚动事件侦听器。

protected class

BasicScrollBarUI.TrackListener

跟踪鼠标拖动。

class

BasicScrollPaneUI

ScrollPaneUI的默认L＆F实现。

class

BasicScrollPaneUI.HSBChangeListener

水平滚动条监听器。

protected class

BasicScrollPaneUI.MouseWheelHandler

MouseWheelHandler是一个实现MouseWheelListener接口的内部类。

class

BasicScrollPaneUI.PropertyChangeHandler

属性更改处理程序

class

BasicScrollPaneUI.ViewportChangeHandler

监听器用于视口事件。

class

BasicScrollPaneUI.VSBChangeListener

垂直卷轴侦听器。

class

BasicSeparatorUI

SeparatorUI的基本L＆F实现。

class

BasicSliderUI

SliderUI的基本L＆F实现。

class

BasicSliderUI.ActionScroller

从Java 2平台v1.3开始，这个未记录的类就不再使用了。

class

BasicSliderUI.ChangeHandler

数据模型侦听器

class

BasicSliderUI.ComponentHandler

调整事件大小的侦听器。

class

BasicSliderUI.FocusHandler

聚焦改变听众

class

BasicSliderUI.PropertyChangeHandler

属性更改处理程序。

class

BasicSliderUI.ScrollListener

滚动事件侦听器。

class

BasicSliderUI.TrackListener

跟踪鼠标移动。

class

BasicSpinnerUI

默认的Spinner UI委托。

class

BasicSplitPaneDivider

BasicSplitPaneUI使用的分隔符。

protected class

BasicSplitPaneDivider.DividerLayout

用于布局一个 BasicSplitPaneDivider 。

protected class

BasicSplitPaneDivider.DragController

在针对HORIZONTAL_SPLIT的拆分窗格的拖动会话期间处理事件。

protected class

BasicSplitPaneDivider.MouseHandler

MouseHandler负责将鼠标事件（释放，拖动...）转换为适当的DragController方法。

protected class

BasicSplitPaneDivider.VerticalDragController

在VERTICAL_SPLIT面向拆分窗格的拖动会话期间处理事件。

class

BasicSplitPaneUI

SplitPaneUI的基本L＆F实现。

class

BasicSplitPaneUI.BasicHorizontalLayoutManager

具有方向为HORIZONTAL_SPLIT的JSplitPanes的LayoutManager。

class

BasicSplitPaneUI.BasicVerticalLayoutManager

LayoutManager用于JSplitPanes，方向为VERTICAL_SPLIT。

class

BasicSplitPaneUI.FocusHandler

JSplitPane UI使用的FocusListener的实现。

class

BasicSplitPaneUI.KeyboardDownRightHandler

JSplitPane UI用于处理特定按键的ActionListener的实现。

class

BasicSplitPaneUI.KeyboardEndHandler

JSplitPane UI用于处理特定按键的ActionListener的实现。

class

BasicSplitPaneUI.KeyboardHomeHandler

JSplitPane UI用于处理特定按键的ActionListener的实现。

class

BasicSplitPaneUI.KeyboardResizeToggleHandler

JSplitPane UI用于处理特定按键的ActionListener的实现。

class

BasicSplitPaneUI.KeyboardUpLeftHandler

JSplitPane UI用于处理特定按键的ActionListener的实现。

class

BasicSplitPaneUI.PropertyHandler

实现JSplitPane UI使用的PropertyChangeListener。

class

BasicTabbedPaneUI

TabbedPaneUI的基本L＆F实现。

class

BasicTabbedPaneUI.FocusHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTabbedPaneUI.MouseHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTabbedPaneUI.PropertyChangeHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTabbedPaneUI.TabbedPaneLayout

这个类应该被视为一个“受保护”的内部类。

class

BasicTabbedPaneUI.TabSelectionHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTableHeaderUI

BasicTableHeaderUI实现

class

BasicTableHeaderUI.MouseInputHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTableUI

BasicTableUI实现

class

BasicTableUI.FocusHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTableUI.KeyHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTableUI.MouseInputHandler

这个类应该被视为一个“受保护”的内部类。

class

BasicTextAreaUI

提供纯文本编辑器的外观和感觉。

class

BasicTextFieldUI

JTextField的外观和感觉的基础。

class

BasicTextPaneUI

为风格的文本编辑器提供外观和感觉。

class

BasicTextUI

文本元素的外观和感觉的基础。

static class

BasicTextUI.BasicCaret

界面默认实现 Caret 。

static class

BasicTextUI.BasicHighlighter

界面默认实现 Highlighter 。

class

BasicToggleButtonUI

BasicToggleButton实现

class

BasicToolBarSeparatorUI

ToolBarSeparatorUI的基本L＆F实现。

class

BasicToolBarUI

ToolBarUI的基本L＆F实现。

class

BasicToolBarUI.DockingListener

这个类应该被视为一个“受保护”的内部类。

protected class

BasicToolBarUI.DragWindow

在拖动 JToolBar期间出现的窗口。

protected class

BasicToolBarUI.FrameListener

该类监听窗口事件。

protected class

BasicToolBarUI.PropertyListener

该类监听属性更改的事件。

protected class

BasicToolBarUI.ToolBarContListener

该类侦听组件事件。

protected class

BasicToolBarUI.ToolBarFocusListener

班级聆听焦点事件。

class

BasicToolTipUI

标准刀尖L＆F。

class

BasicTreeUI

分层数据结构的基本L＆F。

class

BasicTreeUI.CellEditorHandler

监听器负责获取单元格编辑事件并相应地更新树。

class

BasicTreeUI.ComponentHandler

更新滚动时的首选大小（如有必要）。

class

BasicTreeUI.FocusHandler

当重点丢失/获得时，重新排列主导选择行。

class

BasicTreeUI.KeyHandler

这用于获取多个关键事件以适当地生成事件。

class

BasicTreeUI.MouseHandler

TreeMouseListener负责根据鼠标事件更新选择。

class

BasicTreeUI.MouseInputHandler

MouseInputHandler处理所有鼠标事件，包括鼠标移动事件，直到鼠标释放到它构造的目的地。

class

BasicTreeUI.NodeDimensionsHandler

负责获取节点大小的类，方法转发到BasicTreeUI方法。

class

BasicTreeUI.PropertyChangeHandler

PropertyChangeListener为树。

class

BasicTreeUI.SelectionModelPropertyChangeHandler

在TreeSelectionModel上的侦听器，如果模型的任何属性更改，则重置行选择。

class

BasicTreeUI.TreeCancelEditingAction

ActionListener在执行操作时调用cancelEditing。

class

BasicTreeUI.TreeExpansionHandler

响应节点扩展/折叠更新TreeState。

class

BasicTreeUI.TreeHomeAction

TreeHomeAction用于处理结束/ home操作。

class

BasicTreeUI.TreeIncrementAction

TreeIncrementAction用于处理上/下动作。

class

BasicTreeUI.TreeModelHandler

将所有TreeModel事件转发给TreeState。

class

BasicTreeUI.TreePageAction

TreePageAction处理页面向上和向下翻页事件。

class

BasicTreeUI.TreeSelectionHandler

监听选择模型中的更改，并相应地更新显示。

class

BasicTreeUI.TreeToggleAction

对于第一个选定的行展开将被切换。

class

BasicTreeUI.TreeTraverseAction

TreeTraverseAction是用于左/右键的动作。

class

BasicViewportUI

BasicViewport实现

class

DefaultMenuLayout

弹出菜单和菜单栏的默认布局管理器。

Fields in javax.swing.plaf.basic with type parameters of type Object

Modifier and Type

Field

描述

protected JComboBox<Object>

BasicComboBoxUI.comboBox

实例 JComboBox 。

protected JComboBox<Object>

BasicComboPopup.comboBox

实例 JComboBox 。

protected JList<Object>

BasicComboPopup.list

此保护字段是实现特定的。

protected JList<Object>

BasicListUI.list

实例 JList 。

protected JList<Object>

BasicComboBoxUI.listBox

此列表用于在组合框中绘制当前项。

Methods in javax.swing.plaf.basic that return Object

Modifier and Type

方法

描述

protected Object[]

BasicOptionPaneUI.getButtons​()

返回从 JOptionPane显示的按钮，接收器提供外观和感觉。

Object

BasicDirectoryModel.getElementAt​(int index)

Object

BasicComboBoxEditor.getItem​()

protected Object

BasicOptionPaneUI.getMessage​()

返回从 JOptionPane显示的消息，接收器提供外观和感觉。

Methods in javax.swing.plaf.basic that return types with arguments of type Object

Modifier and Type

方法

描述

protected JList<Object>

BasicComboPopup.createList​()

创建弹出窗口中使用的JList，以显示组合框模型中的项目。

protected ListCellRenderer<Object>

BasicComboBoxUI.createRenderer​()

创建将在不可编辑的组合框中使用的默认渲染器。

JList<Object>

BasicComboPopup.getList​()

实现ComboPopup.getList（）。

JList<Object>

ComboPopup.getList​()

返回用于在组合框中绘制项目的列表。

Methods in javax.swing.plaf.basic with parameters of type Object

Modifier and Type

方法

描述

protected void

BasicOptionPaneUI.addButtonComponents​(Container container, Object[] buttons, int initialIndex)

创建适当的对象以表示 buttons每个对象，并将其添加到 container 。

void

BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent​(Component comp, Object constraints)

使用指定的约束对象将指定的组件添加到布局。

protected void

BasicOptionPaneUI.addMessageComponents​(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)

创建适当的对象来表示 msg并将其放入 container 。

boolean

BasicDirectoryModel.contains​(Object o)

返回 true如果一个元素 o是在文件缓存，否则，返回 false 。

protected Action

BasicLookAndFeel.createAudioAction​(Object key)

创建并返回一个 Action用于播放声音。

protected void

BasicDirectoryModel.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告布尔属性的绑定属性更改。

Component

BasicComboBoxRenderer.getListCellRendererComponent​(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)

Rectangle

BasicTreeUI.NodeDimensionsHandler.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle size)

负责获取特定节点的大小。

int

BasicDirectoryModel.indexOf​(Object o)

返回文件缓存中元素 o的索引。

void

BasicComboBoxEditor.setItem​(Object anObject)

设置应编辑的项目。

Method parameters in javax.swing.plaf.basic with type arguments of type Object

Modifier and Type

方法

描述

protected void

BasicListUI.paintCell​(Graphics g, int row, Rectangle rowBounds, ListCellRenderer<Object> cellRenderer, ListModel<Object> dataModel, ListSelectionModel selModel, int leadIndex)

绘制一个列表单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane进行绘制。

protected void

BasicListUI.paintCell​(Graphics g, int row, Rectangle rowBounds, ListCellRenderer<Object> cellRenderer, ListModel<Object> dataModel, ListSelectionModel selModel, int leadIndex)

绘制一个列表单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane进行绘制。

Constructor parameters in javax.swing.plaf.basic with type arguments of type Object

Constructor

描述

BasicComboPopup​(JComboBox<Object> combo)

构造一个新的实例 BasicComboPopup 。

Uses of Object in javax.swing.plaf.metal

Subclasses of Object in javax.swing.plaf.metal

Modifier and Type

Class

描述

class

DefaultMetalTheme

具体实现了 MetalTheme提供了Java Look and Feel的原始外观，代号为“Steel”。

class

MetalBorders

工厂对象可以出售边界适合金属L＆F.

static class

MetalBorders.ButtonBorder

该类代表一个 JButton的边界。

static class

MetalBorders.Flush3DBorder

该类代表3D边框。

static class

MetalBorders.InternalFrameBorder

该类代表一个 JInternalFrame的边界。

static class

MetalBorders.MenuBarBorder

该类代表一个 JMenuBar的边界。

static class

MetalBorders.MenuItemBorder

该类代表一个 JMenuItem的边界。

static class

MetalBorders.OptionDialogBorder

该类表示选项对话框的边框。

static class

MetalBorders.PaletteBorder

边框的调色板。

static class

MetalBorders.PopupMenuBorder

该类代表一个 JPopupMenu的边界。

static class

MetalBorders.RolloverButtonBorder

该类代表翻转的边界 Button 。

static class

MetalBorders.ScrollPaneBorder

该类代表一个 JScrollPane的边界。

static class

MetalBorders.TableHeaderBorder

表头的边框

static class

MetalBorders.TextFieldBorder

该类代表一个 JTestField的边界。

static class

MetalBorders.ToggleButtonBorder

static class

MetalBorders.ToolBarBorder

该类代表一个 JToolBar的边界。

class

MetalButtonUI

MetalButtonUI实现

class

MetalCheckBoxIcon

OrganicCheckBoxUI的CheckboxIcon实现

class

MetalCheckBoxUI

MetalCheckboxUI的CheckboxUI实现

class

MetalComboBoxButton

JButton子类来帮助MetalComboBoxUI

class

MetalComboBoxEditor

Metal可编辑组合框的默认编辑器

static class

MetalComboBoxEditor.UIResource

BasicComboBoxEditor的子类实现UIResource。

class

MetalComboBoxIcon

此实用程序类绘制指示MetalComboBox的水平条

class

MetalComboBoxUI

JComboBox的金属UI

class

MetalComboBoxUI.MetalComboBoxLayoutManager

这个类应该被视为一个“受保护”的内部类。

class

MetalComboBoxUI.MetalComboPopup

已过时。
从Java 2平台v1.4开始。

class

MetalComboBoxUI.MetalPropertyChangeListener

这个类应该被视为一个“受保护”的内部类。

class

MetalDesktopIconUI

金属桌面图标。

class

MetalFileChooserUI

金属L＆F实现的FileChooser。

protected class

MetalFileChooserUI.DirectoryComboBoxAction

当DirectoryComboBox更改所选项目时使用。

protected class

MetalFileChooserUI.DirectoryComboBoxModel

类型面部选择组合框的数据模型。

protected class

MetalFileChooserUI.FileRenderer

已过时。
截至JDK版本9.过时的课程。

protected class

MetalFileChooserUI.FilterComboBoxModel

类型面部选择组合框的数据模型。

class

MetalFileChooserUI.FilterComboBoxRenderer

渲染不同类型的尺寸和样式。

protected class

MetalFileChooserUI.SingleClickListener

已过时。
截至JDK版本9.过时的课程。

class

MetalIconFactory

工厂对象为Java“¢”外观（Metal）提供 Icon s。

static class

MetalIconFactory.FileIcon16

警告：此类的序列化对象与将来的Swing版本不兼容。

static class

MetalIconFactory.FolderIcon16

警告：此类的序列化对象与将来的Swing版本不兼容。

static class

MetalIconFactory.PaletteCloseIcon

定义调色板关闭的图标

static class

MetalIconFactory.TreeControlIcon

警告：此类的序列化对象与将来的Swing版本不兼容。

static class

MetalIconFactory.TreeFolderIcon

警告：此类的序列化对象与将来的Swing版本不兼容。

static class

MetalIconFactory.TreeLeafIcon

该类代表树叶图标。

class

MetalInternalFrameTitlePane

管理JLF标题栏的类

class

MetalInternalFrameUI

金属实现JInternalFrame。

class

MetalLabelUI

LabelUI的Windows L＆F实现。

class

MetalLookAndFeel

Java外观和感觉，也称为金属。

class

MetalMenuBarUI

金属执行 MenuBarUI 。

class

MetalPopupMenuSeparatorUI

PopupMenuSeparatorUI的金属L＆F实现。

class

MetalProgressBarUI

ProgressBarUI的Metal实现。

class

MetalRadioButtonUI

MetalBadtonButtonUI的RadioButtonUI实现

class

MetalRootPaneUI

提供金属外观实现 RootPaneUI 。

class

MetalScrollBarUI

实现ScrollBarUI的金属外观和感觉

class

MetalScrollButton

金属滚动条箭头的JButton对象。

class

MetalScrollPaneUI

ScrollPaneUI的金属L＆F实现。

class

MetalSeparatorUI

SeparatorUI的金属L＆F实现。

class

MetalSliderUI

SliderUI的Java L＆F实现。

protected class

MetalSliderUI.MetalPropertyListener

PropertyListener为 JSlider.isFilled 。

class

MetalSplitPaneUI

金属分割窗格。

class

MetalTabbedPaneUI

BasicTabbedPaneUI的Metal子类。

class

MetalTabbedPaneUI.TabbedPaneLayout

这个类应该被视为一个“受保护”的内部类。

class

MetalTextFieldUI

JTextField的外观和感觉的基础。

class

MetalTheme

MetalTheme提供Java Look and Feel使用的调色板和字体。

class

MetalToggleButtonUI

MetalToggleButton实现

class

MetalToolBarUI

金属外观实现ToolBarUI。

protected class

MetalToolBarUI.MetalContainerListener

不再使用

protected class

MetalToolBarUI.MetalDockingListener

DockingListener适用于 MetalToolBarUI 。

protected class

MetalToolBarUI.MetalRolloverListener

不再使用

class

MetalToolTipUI

BasicToolTipUI的金属L＆F扩展。

class

MetalTreeUI

金属外观实现 TreeUI 。

class

OceanTheme

默认主题为 MetalLookAndFeel 。

Fields in javax.swing.plaf.metal with type parameters of type Object

Modifier and Type

Field

描述

protected JComboBox<Object>

MetalComboBoxButton.comboBox

实例 JComboBox 。

protected JList<Object>

MetalComboBoxButton.listBox

实例 JList 。

Methods in javax.swing.plaf.metal that return Object

Modifier and Type

方法

描述

Object

MetalFileChooserUI.DirectoryComboBoxModel.getElementAt​(int index)

Object

MetalFileChooserUI.FilterComboBoxModel.getElementAt​(int index)

Object

MetalFileChooserUI.DirectoryComboBoxModel.getSelectedItem​()

Object

MetalFileChooserUI.FilterComboBoxModel.getSelectedItem​()

Methods in javax.swing.plaf.metal that return types with arguments of type Object

Modifier and Type

方法

描述

JComboBox<Object>

MetalComboBoxButton.getComboBox​()

返回 JComboBox 。

Methods in javax.swing.plaf.metal with parameters of type Object

Modifier and Type

方法

描述

protected void

MetalTreeUI.decodeLineStyle​(Object lineStyleFlag)

传递给客户端属性的字符串和内部表示（当前和int）之间的转换

Component

MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent​(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)

void

MetalFileChooserUI.DirectoryComboBoxModel.setSelectedItem​(Object selectedDirectory)

void

MetalFileChooserUI.FilterComboBoxModel.setSelectedItem​(Object filter)

Method parameters in javax.swing.plaf.metal with type arguments of type Object

Modifier and Type

方法

描述

void

MetalComboBoxButton.setComboBox​(JComboBox<Object> cb)

设置 JComboBox 。

Constructor parameters in javax.swing.plaf.metal with type arguments of type Object

Constructor

描述

MetalComboBoxButton​(JComboBox<Object> cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList<Object> list)

构造一个新的实例 MetalComboBoxButton 。

MetalComboBoxButton​(JComboBox<Object> cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList<Object> list)

构造一个新的实例 MetalComboBoxButton 。

MetalComboBoxButton​(JComboBox<Object> cb, Icon i, CellRendererPane pane, JList<Object> list)

构造一个新的实例 MetalComboBoxButton 。

MetalComboBoxButton​(JComboBox<Object> cb, Icon i, CellRendererPane pane, JList<Object> list)

构造一个新的实例 MetalComboBoxButton 。

MetalComboPopup​(JComboBox<Object> cBox)

已过时。

构造一个新的实例 MetalComboPopup 。

Uses of Object in javax.swing.plaf.multi

Subclasses of Object in javax.swing.plaf.multi

Modifier and Type

Class

描述

class

MultiButtonUI

用于组合 ButtonUI的复用UI。

class

MultiColorChooserUI

用于组合 ColorChooserUI的复用UI。

class

MultiComboBoxUI

用于组合 ComboBoxUI的复用UI。

class

MultiDesktopIconUI

用于组合 DesktopIconUI的复用UI。

class

MultiDesktopPaneUI

用于组合 DesktopPaneUI的复用UI。

class

MultiFileChooserUI

用于组合 FileChooserUI的复用UI。

class

MultiInternalFrameUI

用于组合 InternalFrameUI的复用UI。

class

MultiLabelUI

用于组合 LabelUI的复用UI。

class

MultiListUI

用于组合 ListUI的复用UI。

class

MultiLookAndFeel

复用外观和感觉，允许多个UI同时与组件相关联。

class

MultiMenuBarUI

用于组合 MenuBarUI的复用UI。

class

MultiMenuItemUI

用于组合 MenuItemUI的复用UI。

class

MultiOptionPaneUI

用于组合 OptionPaneUI的复用UI。

class

MultiPanelUI

用于组合 PanelUI的复用UI。

class

MultiPopupMenuUI

用于组合 PopupMenuUI的复用UI。

class

MultiProgressBarUI

用于组合 ProgressBarUI的复用UI。

class

MultiRootPaneUI

用于组合 RootPaneUI的复用UI。

class

MultiScrollBarUI

用于组合 ScrollBarUI的复用UI。

class

MultiScrollPaneUI

用于组合 ScrollPaneUI的复用UI。

class

MultiSeparatorUI

用于组合 SeparatorUI的复用UI。

class

MultiSliderUI

用于组合 SliderUI的复用UI。

class

MultiSpinnerUI

用于组合 SpinnerUI的复用UI。

class

MultiSplitPaneUI

用于组合 SplitPaneUI的复用UI。

class

MultiTabbedPaneUI

用于组合 TabbedPaneUI的复用UI。

class

MultiTableHeaderUI

用于组合 TableHeaderUI的复用UI。

class

MultiTableUI

用于组合 TableUI的复用UI。

class

MultiTextUI

用于组合 TextUI的复用UI。

class

MultiToolBarUI

用于组合 ToolBarUI的复用UI。

class

MultiToolTipUI

用于组合 ToolTipUI的复用UI。

class

MultiTreeUI

用于组合 TreeUI的复用UI。

class

MultiViewportUI

用于组合 ViewportUI的复用UI。

Uses of Object in javax.swing.plaf.nimbus

Subclasses of Object in javax.swing.plaf.nimbus

Modifier and Type

Class

描述

class

AbstractRegionPainter

方便的基类，用于定义Painter实例，用于渲染Nimbus中的区域或组件。

protected static class

AbstractRegionPainter.PaintContext

一个类封装状态在绘画时有用。

class

NimbusLookAndFeel

NimbusLookAndFeel类。

class

NimbusStyle

Nimbus使用的SynthStyle实现。

class

State<T extends JComponent>

代表Nimbus内置或定制的状态。

Methods in javax.swing.plaf.nimbus that return Object

Modifier and Type

方法

描述

Object

NimbusStyle.get​(SynthContext ctx, Object key)

Getter为区域特定样式属性。

protected Object[]

AbstractRegionPainter.getExtendedCacheKeys​(JComponent c)

获取绘图器实现想要包含在图像缓存查找中的任何额外的属性。

Methods in javax.swing.plaf.nimbus that return types with arguments of type Object

Modifier and Type

方法

描述

Painter<Object>

NimbusStyle.getBackgroundPainter​(SynthContext ctx)

获取适当的背景Painter，如果有的话，给定SynthContext中指定的状态。

Painter<Object>

NimbusStyle.getBorderPainter​(SynthContext ctx)

获取适当的边界Painter，如果有的话，给定SynthContext中指定的状态。

Painter<Object>

NimbusStyle.getForegroundPainter​(SynthContext ctx)

获取适当的前景Painter，如果有的话，给定SynthContext中指定的状态。

Methods in javax.swing.plaf.nimbus with parameters of type Object

Modifier and Type

方法

描述

protected abstract void

AbstractRegionPainter.doPaint​(Graphics2D g, JComponent c, int width, int height, Object[] extendedCacheKeys)

实际执行绘画操作。

Object

NimbusStyle.get​(SynthContext ctx, Object key)

Getter为区域特定样式属性。

Uses of Object in javax.swing.plaf.synth

Subclasses of Object in javax.swing.plaf.synth

Modifier and Type

Class

描述

class

ColorType

一种可以从风格中获取的颜色的类型安全枚举。

class

Region

一个不同的渲染区域的Swing组件。

class

SynthButtonUI

为JButton提供Synth L＆F UI代表。

class

SynthCheckBoxMenuItemUI

为JCheckBoxMenuItem提供Synth L＆F UI代表。

class

SynthCheckBoxUI

为JCheckBox提供Synth L＆F UI代表。

class

SynthColorChooserUI

为JColorChooser提供Synth L＆F UI代表。

class

SynthComboBoxUI

为JComboBox提供Synth L＆F UI代表。

class

SynthContext

包含关于 Region上下文信息的不可变临时对象。

class

SynthDesktopIconUI

为桌面上最小化的内部框架提供Synth L＆F UI代理。

class

SynthDesktopPaneUI

为JDesktopPane提供Synth L＆F UI代表。

class

SynthEditorPaneUI

为JEditorPane提供Synth L＆F UI代表。

class

SynthFormattedTextFieldUI

为JFormattedTextField提供Synth L＆F UI代表。

class

SynthGraphicsUtils

原始图形调用的包装器。

class

SynthInternalFrameUI

为JInternalFrame提供Synth L＆F UI代表。

class

SynthLabelUI

为JLabel提供Synth L＆F UI代表。

class

SynthListUI

为JList提供Synth L＆F UI代表。

class

SynthLookAndFeel

SynthLookAndFeel提供了创建自定义外观的基础。

class

SynthMenuBarUI

为JMenuBar提供Synth L＆F UI代表。

class

SynthMenuItemUI

为JMenuItem提供Synth L＆F UI代表。

class

SynthMenuUI

为JMenu提供Synth L＆F UI代表。

class

SynthOptionPaneUI

为JOptionPane提供Synth L＆F UI代表。

class

SynthPainter

SynthPainter用于绘制 JComponent s的部分。

class

SynthPanelUI

为JPanel提供Synth L＆F UI代表。

class

SynthPasswordFieldUI

为JPasswordField提供Synth L＆F UI代表。

class

SynthPopupMenuUI

为JPopupMenu提供Synth L＆F UI代表。

class

SynthProgressBarUI

为JProgressBar提供Synth L＆F UI代表。

class

SynthRadioButtonMenuItemUI

为JRadioButtonMenuItem提供Synth L＆F UI代表。

class

SynthRadioButtonUI

提供Synth L＆F UI代表JRadioButton 。

class

SynthRootPaneUI

为JRootPane提供Synth L＆F UI代表。

class

SynthScrollBarUI

为JScrollBar提供Synth L＆F UI代表。

class

SynthScrollPaneUI

为JScrollPane提供Synth L＆F UI代表。

class

SynthSeparatorUI

为JSeparator提供Synth L＆F UI代表。

class

SynthSliderUI

为JSlider提供Synth L＆F UI代表。

class

SynthSpinnerUI

为JSpinner提供Synth L＆F UI代表。

class

SynthSplitPaneUI

为JSplitPane提供Synth L＆F UI代表。

class

SynthStyle

SynthStyle是一套风格属性。

class

SynthStyleFactory

工厂用于获得 SynthStyle s。

class

SynthTabbedPaneUI

为JTabbedPane提供Synth L＆F UI代表。

class

SynthTableHeaderUI

为JTableHeader提供Synth L＆F UI代表。

class

SynthTableUI

为JTable提供Synth L＆F UI代表。

class

SynthTextAreaUI

为Synth的外观和感觉提供纯文本编辑器的外观和感觉。

class

SynthTextFieldUI

为JTextField提供Synth L＆F UI代表。

class

SynthTextPaneUI

为Synth外观和风格的样式文本编辑器提供外观和感觉。

class

SynthToggleButtonUI

为JToggleButton提供Synth L＆F UI代表。

class

SynthToolBarUI

为JToolBar提供Synth L＆F UI代表。

class

SynthToolTipUI

为JToolTip提供Synth L＆F UI代表。

class

SynthTreeUI

为JTree提供Synth L＆F UI代表。

class

SynthViewportUI

为JViewport提供Synth L＆F UI代表。

Methods in javax.swing.plaf.synth that return Object

Modifier and Type

方法

描述

Object

SynthStyle.get​(SynthContext context, Object key)

Getter为区域特定样式属性。

Methods in javax.swing.plaf.synth that return types with arguments of type Object

Modifier and Type

方法

描述

protected ListCellRenderer<Object>

SynthComboBoxUI.createRenderer​()

创建将在不可编辑的组合框中使用的默认渲染器。

Methods in javax.swing.plaf.synth with parameters of type Object

Modifier and Type

方法

描述

void

SynthGraphicsUtils.drawLine​(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2)

在两个终点之间画一条线。

void

SynthGraphicsUtils.drawLine​(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey)

在两个终点之间画一条线。

Object

SynthStyle.get​(SynthContext context, Object key)

Getter为区域特定样式属性。

boolean

SynthStyle.getBoolean​(SynthContext context, Object key, boolean defaultValue)

方便的方法来获取一个特定的style属性，其值是一个布尔值。

Icon

SynthStyle.getIcon​(SynthContext context, Object key)

方便的方法来获取一个特定的样式属性，其值是一个Icon。

int

SynthStyle.getInt​(SynthContext context, Object key, int defaultValue)

方便的方法来获取一个具体的样式属性，其值为 Number 。

String

SynthStyle.getString​(SynthContext context, Object key, String defaultValue)

方便的方法来获取一个特定的style属性，其值是一个String。

Uses of Object in javax.swing.table

Subclasses of Object in javax.swing.table

Modifier and Type

Class

描述

class

AbstractTableModel

这个抽象类为 TableModel界面中的大多数方法提供了默认实现。

class

DefaultTableCellRenderer

在 JTable渲染（显示）单个单元格的标准类。

static class

DefaultTableCellRenderer.UIResource

DefaultTableCellRenderer的子类实现 UIResource 。

class

DefaultTableColumnModel

JTable的标准列处理程序。

class

DefaultTableModel

这是一个 TableModel的实现，它使用 Vector的 Vectors来存储单元格值对象。

class

JTableHeader

这是管理 JTable的标题的 JTable 。

protected class

JTableHeader.AccessibleJTableHeader

该类实现 JTableHeader类的可访问性支持。

protected class

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

该类提供了适用于JTableHeader条目的Java Accessibility API的实现。

class

TableColumn

甲 TableColumn表示在所述列的所有属性 JTable ，诸如宽度，可调整大小，最小和最大宽度。

class

TableRowSorter<M extends TableModel>

的实施 RowSorter ，其提供排序，并使用过滤 TableModel 。

class

TableStringConverter

TableStringConverter用于将模型中的对象转换为字符串。

Fields in javax.swing.table declared as Object

Modifier and Type

Field

描述

protected Object

TableColumn.headerValue

列的标题值。

protected Object

TableColumn.identifier

这个对象不是由JTable的绘图机械内部使用; 可以在TableColumn设置标识符，作为标记和查找表列的可选方法。

Methods in javax.swing.table that return Object

Modifier and Type

方法

描述

Object

TableColumn.getHeaderValue​()

返回用作标题渲染器的值的 Object 。

Object

TableColumn.getIdentifier​()

返回此列的 identifier对象。

Object

DefaultTableModel.getValueAt​(int row, int column)

返回 row和 column的单元格的属性值。

Object

TableModel.getValueAt​(int rowIndex, int columnIndex)

返回单元格的值为 columnIndex和 rowIndex 。

Methods in javax.swing.table that return types with arguments of type Object

Modifier and Type

方法

描述

protected static Vector<Object>

DefaultTableModel.convertToVector​(Object[] anArray)

返回一个包含与数组相同的对象的向量。

protected static Vector<Vector<Object>>

DefaultTableModel.convertToVector​(Object[][] anArray)

返回包含与数组相同对象的向量向量。

Methods in javax.swing.table with parameters of type Object

Modifier and Type

方法

描述

void

DefaultTableModel.addColumn​(Object columnName)

向模型添加一列。

void

DefaultTableModel.addColumn​(Object columnName, Object[] columnData)

向模型添加一列。

void

DefaultTableModel.addColumn​(Object columnName, Vector<?> columnData)

向模型添加一列。

void

DefaultTableModel.addRow​(Object[] rowData)

在模型的末尾添加一行。

protected static Vector<Object>

DefaultTableModel.convertToVector​(Object[] anArray)

返回一个包含与数组相同的对象的向量。

protected static Vector<Vector<Object>>

DefaultTableModel.convertToVector​(Object[][] anArray)

返回包含与数组相同对象的向量向量。

protected void

DefaultTableCellRenderer.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

由于性能原因而被覆盖。

int

DefaultTableColumnModel.getColumnIndex​(Object identifier)

当使用 equals进行比较时，返回其标识符等于 identifier的 tableColumns阵列中第一列的索引。

int

TableColumnModel.getColumnIndex​(Object columnIdentifier)

当使用 equals进行比较时，返回标识符等于 identifier的表中第一列的索引。

Component

TableCellEditor.getTableCellEditorComponent​(JTable table, Object value, boolean isSelected, int row, int column)

为编辑器设置初始值 value 。

Component

DefaultTableCellRenderer.getTableCellRendererComponent​(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)

返回默认的表格单元格渲染器。

Component

TableCellRenderer.getTableCellRendererComponent​(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)

返回用于绘制单元格的组件。

void

DefaultTableModel.insertRow​(int row, Object[] rowData)

在模型中插入一行 row 。

void

DefaultTableModel.setColumnIdentifiers​(Object[] newIdentifiers)

替换模型中的列标识符。

void

DefaultTableModel.setDataVector​(Object[][] dataVector, Object[] columnIdentifiers)

使用数组 dataVector的值替换 dataVector实例变量中的值。

void

TableColumn.setHeaderValue​(Object headerValue)

设置 Object其字符串表示将用作值 headerRenderer 。

void

TableColumn.setIdentifier​(Object identifier)

将 TableColumn的标识符设置为 anIdentifier 。

protected void

DefaultTableCellRenderer.setValue​(Object value)

将要呈现的单元格的 String对象设置为 value 。

void

AbstractTableModel.setValueAt​(Object aValue, int rowIndex, int columnIndex)

这个空的实现被提供，所以如果用户的数据模型是不可编辑的，用户就不需要实现这个方法。

void

DefaultTableModel.setValueAt​(Object aValue, int row, int column)

设置单元格的对象值为 column和 row 。

void

TableModel.setValueAt​(Object aValue, int rowIndex, int columnIndex)

将单元格中的值设置为 columnIndex并将 rowIndex为 aValue 。

Constructors in javax.swing.table with parameters of type Object

Constructor

描述

DefaultTableModel​(Object[][] data, Object[] columnNames)

构造一个 DefaultTableModel并通过将 data和 columnNames通过 setDataVector方法初始化表。

DefaultTableModel​(Object[] columnNames, int rowCount)

构造一个 DefaultTableModel与尽可能多的列有在元件 columnNames和 rowCount的 null对象值。

Uses of Object in javax.swing.text

Subclasses of Object in javax.swing.text

Modifier and Type

Class

描述

class

AbstractDocument

实现文档界面，作为实施各种文件的基础。

class

AbstractDocument.AbstractElement

实现元素的抽象部分。

class

AbstractDocument.BranchElement

实现一个包含其他元素的复合元素。

class

AbstractDocument.DefaultDocumentEvent

正在修改文档时存储文档更改。

static class

AbstractDocument.ElementEdit

可以添加到文档事件中的ElementChange的实现。

class

AbstractDocument.LeafElement

实现直接表示某种内容的元素。

class

AbstractWriter

AbstractWriter是一个抽象类，它实际上完成了包含属性的元素树的写入工作。

class

AsyncBoxView

一个异步执行布局的框。

class

AsyncBoxView.ChildLocator

在本地化区域内进行变更时，可以管理子视图在局部区域中的有效位置。

class

AsyncBoxView.ChildState

表示子视图的布局状态的记录。

class

BadLocationException

此异常是报告文档模型中的不良位置（即尝试引用不存在的位置）。

class

BoxView

通过沿着一条轴平铺儿童，将孩子们排列成盒子形状的观点。

class

ChangedCharSetException

ChangedCharSetException作为名称指示是在更改字符集时抛出的异常。

class

ComponentView

实现视图界面的组件装饰器。

class

CompositeView

CompositeView是一个抽象的 View实现，它管理一个或多个子视图。

class

DateFormatter

DateFormatter是一个 InternationalFormatter ，它通过 java.text.DateFormat的实例进行 java.text.DateFormat 。

class

DefaultCaret

默认的Caret实现。

class

DefaultEditorKit

这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。

static class

DefaultEditorKit.BeepAction

发出哔声

static class

DefaultEditorKit.CopyAction

复制所选区域并将其内容放入系统剪贴板。

static class

DefaultEditorKit.CutAction

剪切所选区域并将其内容放入系统剪贴板。

static class

DefaultEditorKit.DefaultKeyTypedAction

如果接收到 键入类型的事件并且没有键映射条目，则默认执行的操作。

static class

DefaultEditorKit.InsertBreakAction

在文档中放置一个行/段落。

static class

DefaultEditorKit.InsertContentAction

将内容放入相关的文档。

static class

DefaultEditorKit.InsertTabAction

将标签字符放在文档中。

static class

DefaultEditorKit.PasteAction

将系统剪贴板的内容粘贴到所选区域中，或者如果没有选择任何内容，则将其插入插入符号之前。

class

DefaultFormatter

DefaultFormatter格式化任意对象。

class

DefaultFormatterFactory

执行 JFormattedTextField.AbstractFormatterFactory 。

class

DefaultHighlighter

实现荧光笔界面。

static class

DefaultHighlighter.DefaultHighlightPainter

简单的高亮画家，用纯色填充突出显示的区域。

class

DefaultStyledDocument

可以以与RTF格式相似的方式标记字符和段落样式的文档。

static class

DefaultStyledDocument.AttributeUndoableEdit

一个UndoableEdit用于记住对元素的AttributeSet更改。

class

DefaultStyledDocument.ElementBuffer

用于管理元素层次结构更改的类。

static class

DefaultStyledDocument.ElementSpec

建筑元素规范。

protected class

DefaultStyledDocument.SectionElement

文档的默认根元素...映射包含的段落/行。

class

DefaultTextUI

已过时。

class

DocumentFilter

DocumentFilter ，顾名思义，是 Document突变方法的过滤器。

static class

DocumentFilter.FilterBypass

用作一种方式来规避回调文档以更改它。

class

EditorKit

将文本组件所需的一组事物建立为某种 类型的文本内容的合理功能的编辑器。

class

ElementIterator

ElementIterator，顾名思义，遍历Element树。

class

FieldView

将多行纯文本视图扩展为适合单行编辑器视图。

class

FlowView

一个试图将孩子流入某些部分受限空间的视图。

static class

FlowView.FlowStrategy

保持流动的物理形式的策略。

class

GapContent

AbstractDocument.Content接口的实现使用与emacs使用的类似的间隙缓冲区来实现。

class

GlyphView

GlyphView是一种风格的文本块，表示在文本模型中映射到元素上的视图。

static class

GlyphView.GlyphPainter

一个执行字形渲染的类。

class

IconView

图标装饰器实现视图界面。

class

InternationalFormatter

InternationalFormatter延伸 DefaultFormatter ，使用的实例 java.text.Format来处理转换为字符串，并从字符串的转换。

class

JTextComponent

JTextComponent是摆动文本组件的基础类。

class

JTextComponent.AccessibleJTextComponent

这个类实现 JTextComponent类的可访问性支持。

static class

JTextComponent.DropLocation

代表 JTextComponent的下载位置。

static class

JTextComponent.KeyBinding

用于创建密钥绑定的绑定记录。

class

LabelView

A LabelView是一种风格的文本块，表示在文本模型中映射到元素上的视图。

class

LayeredHighlighter

static class

LayeredHighlighter.LayerPainter

分层突出显示渲染器。

class

LayoutQueue

文本布局任务的队列。

class

MaskFormatter

MaskFormatter用于格式化和编辑字符串。

class

NavigationFilter

NavigationFilter可用于限制光标位置的位置。

static class

NavigationFilter.FilterBypass

用来作为一种避开回调插入符来定位光标的方式。

class

NumberFormatter

NumberFormatter子类 InternationalFormatter为数字添加特殊行为。

class

ParagraphView

查看支持多种字体，颜色，组件，图标等的简单换行段落。

class

PasswordView

实现适合在JPasswordField UI实现中使用的视图。

class

PlainDocument

一个不保留字符属性的简单文档。

class

PlainView

实现一个简单的多行文本视图的视图界面，它具有一种字体和颜色的文本。

static class

Position.Bias

一种类型安全的枚举，用于指示模型中位置的偏差。

class

Segment

表示文本片段的字符数组的段。

class

SimpleAttributeSet

使用哈希表直接实现MutableAttributeSet。

class

StringContent

AbstractDocument.Content接口的实现是一种强大的强制实现，对于较小的文档和/或调试很有用。

class

StyleConstants

用于应用于AttributeSet或MutableAttributeSet的 众所周知或常用属性键和方法的集合，以类型安全的方式获取/设置属性。

static class

StyleConstants.CharacterConstants

这是有助于字符风格 的众所周知的属性的类型安全枚举。

static class

StyleConstants.ColorConstants

这是有助于颜色 的众所周知的属性的类型安全枚举。

static class

StyleConstants.FontConstants

这是有助于字体 的众所周知的属性的类型安全枚举。

static class

StyleConstants.ParagraphConstants

这是对段落样式有贡献 的众所周知的属性的类型安全枚举。

class

StyleContext

一组风格及其相关资源。

class

StyleContext.NamedStyle

属性集合，通常用于表示字符和段落样式。

class

StyleContext.SmallAttributeSet

该类在数组中保存少量属性。

class

StyledEditorKit

这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。

static class

StyledEditorKit.AlignmentAction

设置段落对齐的动作。

static class

StyledEditorKit.BoldAction

用于切换粗体属性的操作。

static class

StyledEditorKit.FontFamilyAction

在关联的JEditorPane中设置字体系列的操作。

static class

StyledEditorKit.FontSizeAction

在关联的JEditorPane中设置字体大小的操作。

static class

StyledEditorKit.ForegroundAction

设置前景色的动作。

static class

StyledEditorKit.ItalicAction

切换斜体属性的动作。

static class

StyledEditorKit.StyledTextAction

一个假定它被安装在一个带有StyledEditorKit（或子类）的JEditorPane上被触发的动作。

static class

StyledEditorKit.UnderlineAction

切换下划线属性的动作。

class

TableView

实现一个表的视图界面，它由元素结构组成，该视图的元素的子元素负责表示行，行元素的子元素是单元格。

class

TableView.TableCell

已过时。
一个表单元格现在可以是任何View实现。

class

TableView.TableRow

以行为中心的表格中的行的视图。

class

TabSet

TabSet由许多TabStops组成。

class

TabStop

这个类封装了一个制表符停止（基本上就是标签停止被RTF认为）。

class

TextAction

对于跨多个不同文本组件共享的键绑定的Action实现。

class

Utilities

一系列处理各种文字相关活动的方法。

class

View

文本包中非常重要的一部分是 View类。

class

WrappedPlainView

查看纯文本（只有一种字体和颜色的文本），进行换行。

class

ZoneView

ZoneView是一个View实现，它创建区域，为了显示或模型/视图转换，子视图未被创建或存储，直到它们被需要为止。

Fields in javax.swing.text declared as Object

Modifier and Type

Field

描述

static Object

StyleConstants.Alignment

段落的对齐。

static Object

StyleConstants.Background

背景颜色属性的名称。

static Object

StyleConstants.BidiLevel

由Unicode bidi算法分配的字符的双向级别。

static Object

StyleConstants.Bold

粗体属性的名称。

static Object

StyleConstants.ComponentAttribute

组件属性的名称。

static Object

StyleConstants.ComposedTextAttribute

输入法的名称组合文本属性。

static Object

StyleConstants.Family

字体系列的名称

static Object

StyleConstants.FirstLineIndent

缩进段落第一行的空格量。

static Object

StyleConstants.FontFamily

字体系列的名称

static Object

StyleConstants.FontSize

字体大小的名称。

static Object

StyleConstants.Foreground

前景颜色属性的名称。

static Object

StyleConstants.IconAttribute

图标属性的名称。

static Object

StyleConstants.Italic

斜体属性的名称。

static Object

StyleConstants.LeftIndent

缩进段落左侧的数量。

static Object

StyleConstants.LineSpacing

段落之间的空格数量。

static Object

StyleConstants.ModelAttribute

用于识别具有模型视图分离的嵌入对象的模型的属性。

static Object

AttributeSet.NameAttribute

用于命名属性集合的属性名称。

static Object

StyleConstants.NameAttribute

用于命名属性集合的属性名称。

static Object

StyleConstants.Orientation

段落的方向。

static Object

AttributeSet.ResolveAttribute

用于标识解析父属性属性的属性名称（如果已定义）。

static Object

StyleConstants.ResolveAttribute

用于标识解析父属性属性的属性名称（如果已定义）。

static Object

StyleConstants.RightIndent

缩小段落右侧的数量。

static Object

StyleConstants.Size

字体大小的名称。

static Object

StyleConstants.SpaceAbove

段落上方的空间量。

static Object

StyleConstants.SpaceBelow

段落以下的空间量。

static Object

StyleConstants.StrikeThrough

删除线属性的名称。

static Object

StyleConstants.Subscript

下标属性的名称。

static Object

StyleConstants.Superscript

上标属性的名称。

static Object

StyleConstants.TabSet

该类型为TabSet的类型为TabStops。

static Object

StyleConstants.Underline

下划线属性的名称。

Methods in javax.swing.text that return Object

Modifier and Type

方法

描述

Object

DefaultHighlighter.addHighlight​(int p0, int p1, Highlighter.HighlightPainter p)

在视图中添加高亮。

Object

Highlighter.addHighlight​(int p0, int p1, Highlighter.HighlightPainter p)

在视图中添加高亮。

protected Object

GapContent.allocateArray​(int len)

分配一个数组以存储适当类型的项目（由子类确定）。

Object

DefaultFormatter.clone​()

创建DefaultFormatter的副本。

Object

EditorKit.clone​()

创建一个编辑工具包的副本。

Object

ElementIterator.clone​()

克隆ElementIterator。

protected Object

GlyphView.clone​()

创建一个浅的副本。

Object

InternationalFormatter.clone​()

创建DefaultFormatter的副本。

Object

Segment.clone​()

创建一个浅的副本。

Object

SimpleAttributeSet.clone​()

克隆一组属性。

Object

StyleContext.SmallAttributeSet.clone​()

克隆一组属性。

Object

StyledEditorKit.clone​()

创建一个编辑工具包的副本。

Object

AbstractDocument.AbstractElement.getAttribute​(Object attrName)

获取属性的值。

Object

AttributeSet.getAttribute​(Object key)

获取给定属性的值。

Object

SimpleAttributeSet.getAttribute​(Object name)

获取属性的值。

Object

StyleContext.NamedStyle.getAttribute​(Object attrName)

获取属性的值。

Object

StyleContext.SmallAttributeSet.getAttribute​(Object key)

获取属性的值。

Object

AbstractDocument.getProperty​(Object key)

查找属性值的方便方法。

Object

Document.getProperty​(Object key)

获取与文档关联的属性。

static Object

StyleContext.getStaticAttribute​(Object key)

返回先前使用 registerStaticAttributeKey注册的对象。

static Object

StyleContext.getStaticAttributeKey​(Object key)

返回 key注册的字符串。

Object

DefaultFormatter.stringToValue​(String string)

通过使用String参数的构造函数将String中的传递转换为 getValueClass的实例。

Object

InternationalFormatter.stringToValue​(String text)

返回 Object的表示 String text 。

Object

MaskFormatter.stringToValue​(String value)

解析文本，返回字符串 value的相应对象表示 value 。

Methods in javax.swing.text that return types with arguments of type Object

Modifier and Type

方法

描述

Dictionary<Object,Object>

AbstractDocument.getDocumentProperties​()

支持管理一组属性。

Dictionary<Object,Object>

AbstractDocument.getDocumentProperties​()

支持管理一组属性。

Methods in javax.swing.text with parameters of type Object

Modifier and Type

方法

描述

void

AbstractDocument.AbstractElement.addAttribute​(Object name, Object value)

向元素添加一个属性。

AttributeSet

AbstractDocument.AttributeContext.addAttribute​(AttributeSet old, Object name, Object value)

向给定集添加属性，并返回新的代表集。

void

MutableAttributeSet.addAttribute​(Object name, Object value)

创建与此类似的新属性集，除了它包含具有给定名称和值的属性。

void

SimpleAttributeSet.addAttribute​(Object name, Object value)

向列表中添加一个属性。

AttributeSet

StyleContext.addAttribute​(AttributeSet old, Object name, Object value)

向给定集添加属性，并返回新的代表集。

void

StyleContext.NamedStyle.addAttribute​(Object name, Object value)

添加一个属性。

void

DefaultHighlighter.changeHighlight​(Object tag, int p0, int p1)

改变亮点

void

Highlighter.changeHighlight​(Object tag, int p0, int p1)

更改给定的突出显示以覆盖文档的不同部分。

boolean

AbstractDocument.AbstractElement.containsAttribute​(Object name, Object value)

检查是否定义了一个给定的属性名称/值。

boolean

AttributeSet.containsAttribute​(Object name, Object value)

如果此集合定义了具有相同名称和相同值的属性，则返回 true 。

boolean

SimpleAttributeSet.containsAttribute​(Object name, Object value)

检查属性列表是否包含指定的属性名称/值对。

boolean

StyleContext.NamedStyle.containsAttribute​(Object name, Object value)

检查是否定义了一个给定的属性名称/值。

boolean

StyleContext.SmallAttributeSet.containsAttribute​(Object name, Object value)

检查是否定义了一个给定的属性名称/值。

boolean

DefaultCaret.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

SimpleAttributeSet.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

StyleContext.SmallAttributeSet.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

TabSet.equals​(Object o)

指示这个 TabSet是否等于另一个。

boolean

TabStop.equals​(Object other)

如果选项卡相等则返回true。

Object

AbstractDocument.AbstractElement.getAttribute​(Object attrName)

获取属性的值。

Object

AttributeSet.getAttribute​(Object key)

获取给定属性的值。

Object

SimpleAttributeSet.getAttribute​(Object name)

获取属性的值。

Object

StyleContext.NamedStyle.getAttribute​(Object attrName)

获取属性的值。

Object

StyleContext.SmallAttributeSet.getAttribute​(Object key)

获取属性的值。

Object

AbstractDocument.getProperty​(Object key)

查找属性值的方便方法。

Object

Document.getProperty​(Object key)

获取与文档关联的属性。

static Object

StyleContext.getStaticAttribute​(Object key)

返回先前使用 registerStaticAttributeKey注册的对象。

static Object

StyleContext.getStaticAttributeKey​(Object key)

返回 key注册的字符串。

boolean

AbstractDocument.AbstractElement.isDefined​(Object attrName)

检查给定属性是否被定义。

boolean

AttributeSet.isDefined​(Object attrName)

检查命名属性是否具有在集合中指定的值，而不通过另一个属性集进行解析。

boolean

SimpleAttributeSet.isDefined​(Object attrName)

告诉是否定义了一个给定的属性。

boolean

StyleContext.NamedStyle.isDefined​(Object attrName)

检查给定属性是否被定义。

boolean

StyleContext.SmallAttributeSet.isDefined​(Object key)

检查给定属性是否被定义。

void

AbstractDocument.putProperty​(Object key, Object value)

用于存储属性值的便利方法。

void

Document.putProperty​(Object key, Object value)

将属性与文档相关联。

void

JTextComponent.read​(Reader in, Object desc)

从流初始化。

static void

StyleContext.registerStaticAttributeKey​(Object key)

将对象注册为作为属性集中的键的静态对象。

void

AbstractDocument.AbstractElement.removeAttribute​(Object name)

从集合中删除属性。

AttributeSet

AbstractDocument.AttributeContext.removeAttribute​(AttributeSet old, Object name)

从集合中删除属性。

void

MutableAttributeSet.removeAttribute​(Object name)

删除给定的属性 name 。

void

SimpleAttributeSet.removeAttribute​(Object name)

从列表中删除一个属性。

void

StyleContext.NamedStyle.removeAttribute​(Object name)

从集合中删除属性。

AttributeSet

StyleContext.removeAttribute​(AttributeSet old, Object name)

从集合中删除属性。

void

DefaultHighlighter.removeHighlight​(Object tag)

从视图中移除高亮。

void

Highlighter.removeHighlight​(Object tag)

从视图中移除高亮。

String

DefaultFormatter.valueToString​(Object value)

通过 toString方法将Object中传递的对象转换为字符串。

String

InternationalFormatter.valueToString​(Object value)

返回Object value的String表示 value 。

String

MaskFormatter.valueToString​(Object value)

返回基于掩码的对象 value的字符串表示形式。

Method parameters in javax.swing.text with type arguments of type Object

Modifier and Type

方法

描述

void

AbstractDocument.setDocumentProperties​(Dictionary<Object,Object> x)

替换此文档的文档属性字典。

void

AbstractDocument.setDocumentProperties​(Dictionary<Object,Object> x)

替换此文档的文档属性字典。

Constructors in javax.swing.text with parameters of type Object

Constructor

描述

SmallAttributeSet​(Object[] attributes)

构造一个SmallAttributeSet。

Uses of Object in javax.swing.text.html

Subclasses of Object in javax.swing.text.html

Modifier and Type

Class

描述

class

BlockView

使用CSS规范显示块（作为框）的视图实现。

class

CSS

将一组 CSS attributes定义为类型安全枚举。

static class

CSS.Attribute

定义用作可能包含CSS属性的AttributeSet的键。

class

FormSubmitEvent

FormSubmitEvent用于通知有关方面提交表单。

class

FormView

组件装饰器，用于实现表单元素<input>，<textarea>和<select>的视图界面。

protected class

FormView.MouseEventListener

当类型等于图像的输入点击时，MouseEventListener类可以处理表单提交。

class

HTML

常数用于 HTMLDocument 。

static class

HTML.Attribute

表示HTML属性的Typesafe枚举。

static class

HTML.Tag

HTML标签的类型安全枚举。

static class

HTML.UnknownTag

类代表未知的HTML标签。

class

HTMLDocument

建立HTML的文档。

class

HTMLDocument.BlockElement

表示HTML的结构 块的元素。

class

HTMLDocument.HTMLReader

HTML读取器，用于加载HTML元素结构的HTML文档。

class

HTMLDocument.HTMLReader.BlockAction

默认情况下分配的操作来处理读取器的Block任务。

class

HTMLDocument.HTMLReader.CharacterAction

默认分配的操作来处理读者的Character任务。

class

HTMLDocument.HTMLReader.FormAction

通过构建用于表示表单控件的所有元素来支持表单的操作。

class

HTMLDocument.HTMLReader.HiddenAction

默认分配的操作来处理读者的隐藏任务。

class

HTMLDocument.HTMLReader.IsindexAction

默认情况下分配的操作来处理读取器的Isindex任务。

class

HTMLDocument.HTMLReader.ParagraphAction

默认分配的操作来处理读者的Paragraph任务。

class

HTMLDocument.HTMLReader.PreAction

默认情况下分配的操作来处理读卡器的Pre块任务。

class

HTMLDocument.HTMLReader.SpecialAction

默认情况下分配的操作来处理读者的特殊任务。

class

HTMLDocument.HTMLReader.TagAction

响应解析标签而执行的操作。

static class

HTMLDocument.Iterator

迭代器迭代特定类型的标签。

class

HTMLDocument.RunElement

表示一组文本的元素，该文本块分配有一组HTML字符级属性。

class

HTMLEditorKit

Swing JEditorPane文本组件通过称为EditorKit的插件机制来支持不同类型的内容。

static class

HTMLEditorKit.HTMLFactory

为HTML创建视图的工厂。

static class

HTMLEditorKit.HTMLTextAction

一个抽象的Action提供了一些方便的方法，可能有助于将HTML插入到现有文档中。

static class

HTMLEditorKit.InsertHTMLTextAction

InsertHTMLTextAction可用于将HTML的任意字符串插入到现有的HTML文档中。

static class

HTMLEditorKit.LinkController

在适当的时候，类可以观看相关组件并在其上触发超链接事件。

static class

HTMLEditorKit.Parser

接口由解析器支持。

static class

HTMLEditorKit.ParserCallback

解析的结果驱动这些回调方法。

class

HTMLFrameHyperlinkEvent

HTMLFrameHyperlinkEvent用于通知相关方链接已在一帧中激活。

class

HTMLWriter

这是HTMLDocuments的作者。

class

ImageView

视图，旨在支持HTML <IMG>标签。

class

InlineView

基于CSS属性显示 内联元素样式。

class

ListView

显示html列表的视图实现

class

MinimalHTMLWriter

MinimalHTMLWriter是由HTMLEditorKit用于为不是由EditorKit生成的文档编写HTML的后备书写器。

class

ObjectView

实现<object>元素的视图接口的组件装饰器。

class

Option

用于表示<option>元素的ListModel的值。

class

ParagraphView

显示一个段落，并使用css属性进行配置。

class

StyleSheet

支持定义正在渲染的HTML视图的视觉特征。

static class

StyleSheet.BoxPainter

课程执行CSS格式的一些职责。

static class

StyleSheet.ListPainter

课程执行CSS列表格式的一些职责。

Fields in javax.swing.text.html declared as Object

Modifier and Type

Field

描述

static Object

HTMLEditorKit.ParserCallback.IMPLIED

这是作为属性集中的一个属性传递的，以表示元素是隐含的，例如，字符串'<> foo <\ t>'包含隐含的html元素和隐含的body元素。

Methods in javax.swing.text.html that return Object

Modifier and Type

方法

描述

Object

HTMLEditorKit.clone​()

创建一个编辑工具包的副本。

Methods in javax.swing.text.html with parameters of type Object

Modifier and Type

方法

描述

AttributeSet

StyleSheet.addAttribute​(AttributeSet old, Object key, Object value)

向给定集添加属性，并返回新的代表集。

boolean

HTML.UnknownTag.equals​(Object obj)

将此对象与指定的对象进行比较。

Element

HTMLDocument.getElement​(Element e, Object attribute, Object value)

返回的子元素 e包含属性， attribute与价值 value或者 null如果一个也没有找到。

AttributeSet

StyleSheet.removeAttribute​(AttributeSet old, Object key)

从集合中删除属性。

Constructors in javax.swing.text.html with parameters of type Object

Constructor

描述

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)

创建一个表示html框架超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)

创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)

创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)

创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)

创建一个表示超文本链接事件的新对象。

Uses of Object in javax.swing.text.html.parser

Subclasses of Object in javax.swing.text.html.parser

Modifier and Type

Class

描述

class

AttributeList

该类使用ATTLIST构造在DTD中描述了SGML元素的属性。

class

ContentModel

内容模型的表示。

class

DocumentParser

HTML文档的解析器（实际上，您可以指定一个DTD，但您应该只使用html dtd的这个类）。

class

DTD

SGML DTD的表示。

class

Element

使用ELEMENT构造在DTD中描述的元素。

class

Entity

使用ENTITY构造在DTD中描述实体。

class

Parser

一个简单的DTD驱动的HTML解析器。

class

ParserDelegator

每次调用它的解析方法时，负责启动一个新的DocumentParser。

class

TagElement

通用的HTML TagElement类。

Fields in javax.swing.text.html.parser declared as Object

Modifier and Type

Field

描述

Object

ContentModel.content

内容。

Object

Element.data

用于存储用户数据的字段。

Fields in javax.swing.text.html.parser with type parameters of type Object

Modifier and Type

Field

描述

Hashtable<Object,Entity>

DTD.entityHash

哈希表包含一个 Object和相应的 Entity

Methods in javax.swing.text.html.parser with parameters of type Object

Modifier and Type

方法

描述

protected ContentModel

DTD.defContentModel​(int type, Object obj, ContentModel next)

创建并返回新的内容模型。

boolean

ContentModel.first​(Object token)

如果令牌可能是输入流中的第一个令牌，则返回true。

Constructors in javax.swing.text.html.parser with parameters of type Object

Constructor

描述

ContentModel​(int type, Object content, ContentModel next)

创建特定类型的内容模型。

Uses of Object in javax.swing.text.rtf

Subclasses of Object in javax.swing.text.rtf

Modifier and Type

Class

描述

class

RTFEditorKit

这是RTF编辑功能的默认实现。

Uses of Object in javax.swing.tree

Subclasses of Object in javax.swing.tree

Modifier and Type

Class

描述

class

AbstractLayoutCache

警告：此类的序列化对象与将来的Swing版本不兼容。

static class

AbstractLayoutCache.NodeDimensions

由 AbstractLayoutCache用于确定特定节点的大小和x原点。

class

DefaultMutableTreeNode

A DefaultMutableTreeNode是树状数据结构中的通用节点。

class

DefaultTreeCellEditor

A TreeCellEditor 。

class

DefaultTreeCellEditor.DefaultTextField

当不提供编辑器时使用 TextField 。

class

DefaultTreeCellEditor.EditorContainer

集装箱负责放置 editingComponent 。

class

DefaultTreeCellRenderer

在树中显示一个条目。

class

DefaultTreeModel

一个使用TreeNodes的简单树数据模型。

class

DefaultTreeSelectionModel

TreeSelectionModel的默认实现。

class

ExpandVetoException

用于阻止扩展/崩溃的异常发生。

class

FixedHeightLayoutCache

注意：在将来的版本中这将变得更加开放。

class

TreePath

TreePath表示唯一标识树中某个节点的路径的对象数组。

class

VariableHeightLayoutCache

注意：在将来的版本中这将变得更加开放。

Fields in javax.swing.tree declared as Object

Modifier and Type

Field

描述

protected Object

DefaultMutableTreeNode.userObject

可选的用户对象

Methods in javax.swing.tree that return Object

Modifier and Type

方法

描述

Object

DefaultMutableTreeNode.clone​()

覆盖使克隆公开。

Object

DefaultTreeSelectionModel.clone​()

返回具有相同选择的此对象的克隆。

Object

DefaultTreeCellEditor.getCellEditorValue​()

返回当前正在编辑的值。

Object

DefaultTreeModel.getChild​(Object parent, int index)

返回父节点的子数组中的 父索引 的索引孩子。

Object

TreeModel.getChild​(Object parent, int index)

返回父级子数组中索引 index为 parent的 index的子代。

Object

TreePath.getLastPathComponent​()

返回此路径的最后一个元素。

Object[]

TreePath.getPath​()

返回此 TreePath元素的有序数组。

Object

TreePath.getPathComponent​(int index)

返回指定索引处的path元素。

Object

DefaultTreeModel.getRoot​()

返回树的根。

Object

TreeModel.getRoot​()

返回树的根。

Object

DefaultMutableTreeNode.getUserObject​()

返回此节点的用户对象。

Object[]

DefaultMutableTreeNode.getUserObjectPath​()

从根中返回用户对象路径，以获取到此节点。

Methods in javax.swing.tree with parameters of type Object

Modifier and Type

方法

描述

protected void

DefaultTreeCellEditor.determineOffset​(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)

确定偏移量。

boolean

TreePath.equals​(Object o)

将此 TreePath与指定对象进行比较。

protected void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

由于性能原因而被覆盖。

protected void

DefaultTreeModel.fireTreeNodesChanged​(Object source, Object[] path, int[] childIndices, Object[] children)

通知所有在此事件类型上通知有兴趣的听众。

protected void

DefaultTreeModel.fireTreeNodesInserted​(Object source, Object[] path, int[] childIndices, Object[] children)

通知所有在此事件类型上通知有兴趣的听众。

protected void

DefaultTreeModel.fireTreeNodesRemoved​(Object source, Object[] path, int[] childIndices, Object[] children)

通知所有在此事件类型上通知有兴趣的听众。

protected void

DefaultTreeModel.fireTreeStructureChanged​(Object source, Object[] path, int[] childIndices, Object[] children)

通知所有在此事件类型上通知有兴趣的听众。

Object

DefaultTreeModel.getChild​(Object parent, int index)

返回父节点的子数组中的 父索引 的索引孩子。

Object

TreeModel.getChild​(Object parent, int index)

返回父级子数组中索引 index为 parent的 index的子代。

int

DefaultTreeModel.getChildCount​(Object parent)

返回 父节点的子节点数。

int

TreeModel.getChildCount​(Object parent)

返回子女数 parent 。

int

DefaultTreeModel.getIndexOfChild​(Object parent, Object child)

返回父项中的子项的索引。

int

TreeModel.getIndexOfChild​(Object parent, Object child)

返回父项中的子项的索引。

protected Rectangle

AbstractLayoutCache.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle placeIn)

通过参考，返回 placeIn ，代表 value所需的大小。

abstract Rectangle

AbstractLayoutCache.NodeDimensions.getNodeDimensions​(Object value, int row, int depth, boolean expanded, Rectangle bounds)

通过边界的引用返回大小和x的起始位置。

Component

DefaultTreeCellEditor.getTreeCellEditorComponent​(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)

配置编辑器。

Component

TreeCellEditor.getTreeCellEditorComponent​(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)

设置编辑器的初始 值 。

Component

DefaultTreeCellRenderer.getTreeCellRendererComponent​(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus)

根据传入的组件配置渲染器。

Component

TreeCellRenderer.getTreeCellRendererComponent​(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)

将当前树状单元格的值设置为 value 。

boolean

DefaultTreeModel.isLeaf​(Object node)

返回指定节点是否为叶节点。

boolean

TreeModel.isLeaf​(Object node)

如果 node是叶，则返回 true 。

void

DefaultTreeModel.nodesWereRemoved​(TreeNode node, int[] childIndices, Object[] removedChildren)

从节点中删除一些TreeNodes后，调用此方法。

TreePath

TreePath.pathByAddingChild​(Object child)

返回一个包含此路径的所有元素的新路径加上 child 。

void

DefaultMutableTreeNode.setUserObject​(Object userObject)

将此节点的用户对象设置为 userObject 。

void

MutableTreeNode.setUserObject​(Object object)

将接收者的用户对象重置为 object 。

void

DefaultTreeModel.valueForPathChanged​(TreePath path, Object newValue)

这设置由路径标识的TreeNode的用户对象，并发布一个节点更改。

void

TreeModel.valueForPathChanged​(TreePath path, Object newValue)

当用户将由 path识别的项目的值更改为 path发生 newValue 。

Constructors in javax.swing.tree with parameters of type Object

Constructor

描述

DefaultMutableTreeNode​(Object userObject)

创建一个没有父进程，没有子节点，但允许子节点的树节点，并用指定的用户对象初始化它。

DefaultMutableTreeNode​(Object userObject, boolean allowsChildren)

创建一个没有父进程的树节点，没有子节点，用指定的用户对象进行初始化，只有在指定的时候才允许子节点。

TreePath​(Object lastPathComponent)

创建一个包含单个元素的 TreePath 。

TreePath​(Object[] path)

从数组中创建一个 TreePath 。

TreePath​(Object[] path, int length)

从数组中创建一个 TreePath 。

TreePath​(TreePath parent, Object lastPathComponent)

使用指定的父元素和元素创建一个 TreePath 。

Uses of Object in javax.swing.undo

Subclasses of Object in javax.swing.undo

Modifier and Type

Class

描述

class

AbstractUndoableEdit

UndoableEdit的抽象实现，实现对该接口中所有布尔方法的简单响应。

class

CannotRedoException

抛出一个UndoableEdit被告知到 redo()而不能。

class

CannotUndoException

抛出一个UndoableEdit被告知到 undo()并且不能。

class

CompoundEdit

AbstractUndoableEdit的一个具体子类，用于将小的UndoableEdits组合成大型的。

class

StateEdit

StateEdit是更改状态的对象的一般编辑。

class

UndoableEditSupport

用于管理 UndoableEdit监听器的支持类。

class

UndoManager

UndoManager管理列表 UndoableEdits ，提供了一种方法来撤消或恢复适当的编辑。

Fields in javax.swing.undo declared as Object

Modifier and Type

Field

描述

protected Object

UndoableEditSupport.realSource

真正的来源。

Fields in javax.swing.undo with type parameters of type Object

Modifier and Type

Field

描述

protected Hashtable<Object,Object>

StateEdit.postState

编辑后的状态信息

protected Hashtable<Object,Object>

StateEdit.postState

编辑后的状态信息

protected Hashtable<Object,Object>

StateEdit.preState

编辑前的状态信息

protected Hashtable<Object,Object>

StateEdit.preState

编辑前的状态信息

Method parameters in javax.swing.undo with type arguments of type Object

Modifier and Type

方法

描述

void

StateEditable.storeState​(Hashtable<Object,Object> state)

收到该消息后，接收方应将任何相关状态置于 状态 。

void

StateEditable.storeState​(Hashtable<Object,Object> state)

收到该消息后，接收方应将任何相关状态置于 状态 。

Constructors in javax.swing.undo with parameters of type Object

Constructor

描述

UndoableEditSupport​(Object r)

构造一个 UndoableEditSupport对象。

Uses of Object in javax.tools

Subclasses of Object in javax.tools

Modifier and Type

Class

描述

class

DiagnosticCollector<S>

提供在列表中收集诊断的简单方法。

class

ForwardingFileObject<F extends FileObject>

转发给定文件对象。

class

ForwardingJavaFileManager<M extends JavaFileManager>

转发给给定的文件管理器。

class

ForwardingJavaFileObject<F extends JavaFileObject>

转发给定文件对象。

class

SimpleJavaFileObject

为JavaFileObject中的大多数方法提供简单的实现。

class

ToolProvider

提供定位工具提供者的方法，例如编译器的提供者。

Uses of Object in javax.transaction

Subclasses of Object in javax.transaction

Modifier and Type

Class

描述

class

InvalidTransactionException

此异常表示请求携带无效的事务上下文。

class

TransactionRequiredException

此异常指示请求携带空事务上下文，但目标对象需要激活事务。

class

TransactionRolledbackException

此异常表示与请求的处理关联的事务已回滚，或标记为回滚。

Uses of Object in javax.transaction.xa

Subclasses of Object in javax.transaction.xa

Modifier and Type

Class

描述

class

XAException

资源管理器（RM）抛出XAException，以通知事务管理器涉及的事务遇到的错误。

Uses of Object in javax.xml

Subclasses of Object in javax.xml

Modifier and Type

Class

描述

class

XMLConstants

包含基本XML值作为常量的实用程序类。

Uses of Object in javax.xml.bind

Subclasses of Object in javax.xml.bind

Modifier and Type

Class

描述

class

Binder<XmlNode>

启用表示相同XML文档的XML信息集节点和JAXB对象之间的同步。

class

DataBindingException

表示JAXB操作失败的异常。

class

DatatypeConverter

可以使用javaType绑定声明来自定义XML模式数据类型与Java数据类型的绑定。

class

JAXB

定义方便方法的类用于常见，简单的使用JAXB。

class

JAXBContext

JAXBContext类为客户端提供了JAXB API的入口点。

class

JAXBElement<T>

一个Xml元素的JAXB表示。

static class

JAXBElement.GlobalScope

指定xml元素的全局范围。

class

JAXBException

这是所有JAXB异常的根异常类。

class

JAXBIntrospector

提供对JAXB对象的JAXB xml绑定数据的访问。

class

JAXBPermission

此类用于JAXB权限。

class

MarshalException

此异常表示在执行提供程序无法恢复的组织操作时发生错误。

static class

Marshaller.Listener

使用Marshaller注册此类的实现的实例，以外部监听元帅事件。

class

PropertyException

此异常表示获取或设置属性时遇到错误。

class

SchemaOutputResolver

控制JAXB实现放置生成架构文件的位置。

class

TypeConstraintException

此异常表示检测到违反动态检查的类型约束。

class

UnmarshalException

此异常表示执行卸载操作时发生错误，阻止JAXB提供程序完成操作。

static class

Unmarshaller.Listener

使用Unmarshaller注册此类实现的实例，以外部侦听未散布的事件。

class

ValidationException

此异常表示执行验证操作时发生错误。

Fields in javax.xml.bind declared as Object

Modifier and Type

Field

描述

protected T

JAXBElement.value

xml元素值。

Methods in javax.xml.bind that return Object

Modifier and Type

方法

描述

abstract Object

Binder.getJAXBNode​(XmlNode xmlNode)

获取与给定XML元素关联的JAXB对象。

Object

ValidationEventLocator.getObject​()

返回Java内容树中对象的引用（如果可用）

abstract Object

Binder.getProperty​(String name)

获取底层实现中的特定属性 Binder 。

Object

Marshaller.getProperty​(String name)

获取底层实现中的特定属性 Marshaller 。

Object

Unmarshaller.getProperty​(String name)

获取底层实现中的特定属性 Unmarshaller 。

Object

Validator.getProperty​(String name)

已过时。
自JAXB2.0起

Object

UnmarshallerHandler.getResult​()

获得未组织的结果。

static Object

JAXBIntrospector.getValue​(Object jaxbElement)

获取JAXB元素的元素值。

abstract Object

Binder.unmarshal​(XmlNode xmlNode)

将XML信息集视图解组到JAXB对象树。

Object

Unmarshaller.unmarshal​(File f)

从指定的文件解组XML数据并返回生成的内容树。

Object

Unmarshaller.unmarshal​(InputStream is)

从指定的InputStream中解组XML数据，并返回生成的内容树。

Object

Unmarshaller.unmarshal​(Reader reader)

从指定的Reader中解组XML数据并返回生成的内容树。

Object

Unmarshaller.unmarshal​(URL url)

从指定的URL解组XML数据并返回生成的内容树。

Object

Unmarshaller.unmarshal​(XMLEventReader reader)

从指定的解析器解组XML数据并返回生成的内容树。

Object

Unmarshaller.unmarshal​(XMLStreamReader reader)

从指定的解析器解组XML数据并返回生成的内容树。

Object

Unmarshaller.unmarshal​(Source source)

从指定的XML Source中解组XML数据并返回生成的内容树。

Object

Unmarshaller.unmarshal​(Node node)

从指定的DOM树中解组全局XML数据，并返回生成的内容树。

Object

Unmarshaller.unmarshal​(InputSource source)

从指定的SAX InputSource解组XML数据并返回结果内容树。

abstract Object

Binder.updateJAXB​(XmlNode xmlNode)

获取一个XML节点并更新其关联的JAXB对象及其后代。

Methods in javax.xml.bind with parameters of type Object

Modifier and Type

方法

描述

void

Marshaller.Listener.afterMarshal​(Object source)

在将 source编组为XML后调用回调方法。

void

Unmarshaller.Listener.afterUnmarshal​(Object target, Object parent)

解组XML数据后调用回调方法到 target 。

void

Marshaller.Listener.beforeMarshal​(Object source)

在从 source编组到XML之前调用的回调方法。

void

Unmarshaller.Listener.beforeUnmarshal​(Object target, Object parent)

在解 target之前调用回调方法到 target 。

abstract QName

JAXBIntrospector.getElementName​(Object jaxbElement)

获取xml元素qname为 jaxbElement 。

Node

Marshaller.getNode​(Object contentTree)

获取内容树的DOM树视图（可选）。

static Object

JAXBIntrospector.getValue​(Object jaxbElement)

获取JAXB元素的元素值。

abstract XmlNode

Binder.getXMLNode​(Object jaxbObject)

获取与给定JAXB对象关联的XML元素。

abstract boolean

JAXBIntrospector.isElement​(Object object)

如果 object表示JAXB元素，则返回true。

abstract void

Binder.marshal​(Object jaxbObject, XmlNode xmlNode)

将JAXB对象树编组到新的XML文档。

static void

JAXB.marshal​(Object jaxbObject, File xml)

将Java对象树写入XML并将其存储到指定的位置。

static void

JAXB.marshal​(Object jaxbObject, OutputStream xml)

将Java对象树写入XML并将其存储到指定的位置。

static void

JAXB.marshal​(Object jaxbObject, Writer xml)

将Java对象树写入XML并将其存储到指定的位置。

static void

JAXB.marshal​(Object jaxbObject, String xml)

将Java对象树写入XML并将其存储到指定的位置。

static void

JAXB.marshal​(Object jaxbObject, URI xml)

将Java对象树写入XML并将其存储到指定的位置。

static void

JAXB.marshal​(Object jaxbObject, URL xml)

将Java对象树写入XML并将其存储到指定的位置。

static void

JAXB.marshal​(Object jaxbObject, Result xml)

将Java对象树写入XML并将其存储到指定的位置。

void

Marshaller.marshal​(Object jaxbElement, File output)

将根据 jaxbElement的内容树 jaxbElement成一个文件。

void

Marshaller.marshal​(Object jaxbElement, OutputStream os)

将根据 jaxbElement的内容树 jaxbElement到输出流中。

void

Marshaller.marshal​(Object jaxbElement, Writer writer)

将根据 jaxbElement的内容树 jaxbElement成一个作家。

void

Marshaller.marshal​(Object jaxbElement, XMLEventWriter writer)

将根源于jaxbElement的内容树jaxbElement成一个XMLEventWriter 。

void

Marshaller.marshal​(Object jaxbElement, XMLStreamWriter writer)

将根据jaxbElement的内容树jaxbElement成一个XMLStreamWriter 。

void

Marshaller.marshal​(Object jaxbElement, Result result)

将根据 jaxbElement的内容树 jaxbElement到指定的 javax.xml.transform.Result 。

void

Marshaller.marshal​(Object jaxbElement, Node node)

将根据 jaxbElement的内容树 jaxbElement到DOM树中。

void

Marshaller.marshal​(Object jaxbElement, ContentHandler handler)

将根据 jaxbElement的内容树 jaxbElement成SAX2事件。

abstract void

Binder.setProperty​(String name, Object value)

在底层实现中设置特定属性 Binder 。

void

Marshaller.setProperty​(String name, Object value)

在底层实现中设置特定属性 Marshaller 。

void

Unmarshaller.setProperty​(String name, Object value)

在底层实现中设置特定属性 Unmarshaller 。

void

Validator.setProperty​(String name, Object value)

已过时。
自JAXB2.0起

abstract XmlNode

Binder.updateXML​(Object jaxbObject)

获取JAXB对象并更新其关联的XML节点及其后代。

abstract XmlNode

Binder.updateXML​(Object jaxbObject, XmlNode xmlNode)

在其关联的XML解析树中更新JAXB对象树中的更改。

boolean

Validator.validate​(Object subrootObj)

已过时。
自JAXB2.0起

boolean

Validator.validateRoot​(Object rootObj)

已过时。
自JAXB2.0起

Constructors in javax.xml.bind with parameters of type Object

Constructor

描述

PropertyException​(String name, Object value)

构造一个PropertyException，其消息字段是基于属性的名称和value.toString（）来设置的。

Uses of Object in javax.xml.bind.annotation

Subclasses of Object in javax.xml.bind.annotation

Modifier and Type

Class

描述

class

W3CDomHandler

DomHandler W3C DOM实现（ org.w3c.dom包）

static class

XmlElement.DEFAULT

用于 XmlElement.type() ，表示从属性的签名中推断出该类型。

static class

XmlElementDecl.GLOBAL

用于 XmlElementDecl.scope()以表示声明在全球范围内。

static class

XmlElementRef.DEFAULT

用于 XmlElementRef.type() ，表示从属性的签名中推断出该类型。

static class

XmlSchemaType.DEFAULT

在 XmlSchemaType.type()中用于表示从属性的签名中推断出该类型。

static class

XmlType.DEFAULT

在XmlType.factoryClass()中使用，表示没有使用工厂方法，或者是在这个XmlType本身的类中。

Uses of Object in javax.xml.bind.annotation.adapters

Subclasses of Object in javax.xml.bind.annotation.adapters

Modifier and Type

Class

描述

class

CollapsedStringAdapter

内置XmlAdapter处理xs:token及其派生类型。

class

HexBinaryAdapter

XmlAdapter，适用于xs:hexBinary 。

class

NormalizedStringAdapter

XmlAdapter处理xs:normalizedString 。

class

XmlAdapter<ValueType,BoundType>

适应Java类型进行自定义封送。

static class

XmlJavaTypeAdapter.DEFAULT

用于 XmlJavaTypeAdapter.type() ，表示从字段，属性，参数或类的签名中推断出该类型。

Uses of Object in javax.xml.bind.attachment

Subclasses of Object in javax.xml.bind.attachment

Modifier and Type

Class

描述

class

AttachmentMarshaller

启用JAXB编组以优化二进制数据的存储。

class

AttachmentUnmarshaller

使JAXB解组合包含优化的二进制数据格式的根文档。

Uses of Object in javax.xml.bind.helpers

Subclasses of Object in javax.xml.bind.helpers

Modifier and Type

Class

描述

class

AbstractMarshallerImpl

部分默认 Marshaller实现。

class

AbstractUnmarshallerImpl

部分默认 Unmarshaller实现。

class

DefaultValidationEventHandler

JAXB 1.0只有默认的验证事件处理程序。

class

NotIdentifiableEventImpl

NotIdentifiableEvent接口的默认实现。

class

ParseConversionEventImpl

ParseConversionEvent接口的默认实现。

class

PrintConversionEventImpl

PrintConversionEvent接口的默认实现。

class

ValidationEventImpl

ValidationEvent接口的默认实现。

class

ValidationEventLocatorImpl

ValidationEventLocator接口的默认实现。

Methods in javax.xml.bind.helpers that return Object

Modifier and Type

方法

描述

Object

ValidationEventLocatorImpl.getObject​()

Object

AbstractMarshallerImpl.getProperty​(String name)

getProperty方法的默认实现处理Marshaller中四个定义的属性。

Object

AbstractUnmarshallerImpl.getProperty​(String name)

getProperty方法的默认实现总是抛出PropertyException，因为没有必需的属性。

Object

AbstractUnmarshallerImpl.unmarshal​(File f)

Object

AbstractUnmarshallerImpl.unmarshal​(InputStream is)

Object

AbstractUnmarshallerImpl.unmarshal​(Reader reader)

Object

AbstractUnmarshallerImpl.unmarshal​(URL url)

Object

AbstractUnmarshallerImpl.unmarshal​(XMLEventReader reader)

Object

AbstractUnmarshallerImpl.unmarshal​(XMLStreamReader reader)

Object

AbstractUnmarshallerImpl.unmarshal​(Source source)

Object

AbstractUnmarshallerImpl.unmarshal​(InputSource source)

protected abstract Object

AbstractUnmarshallerImpl.unmarshal​(XMLReader reader, InputSource source)

使用指定的XMLReader和InputSource解组合对象。

Methods in javax.xml.bind.helpers with parameters of type Object

Modifier and Type

方法

描述

Node

AbstractMarshallerImpl.getNode​(Object obj)

默认情况下，getNode方法不受支持，并抛出一个UnsupportedOperationException 。

void

AbstractMarshallerImpl.marshal​(Object jaxbElement, File output)

void

AbstractMarshallerImpl.marshal​(Object obj, OutputStream os)

void

AbstractMarshallerImpl.marshal​(Object obj, Writer w)

void

AbstractMarshallerImpl.marshal​(Object obj, XMLEventWriter writer)

void

AbstractMarshallerImpl.marshal​(Object obj, XMLStreamWriter writer)

void

AbstractMarshallerImpl.marshal​(Object obj, Node node)

void

AbstractMarshallerImpl.marshal​(Object obj, ContentHandler handler)

void

ValidationEventLocatorImpl.setObject​(Object _object)

设置此事件定位器上的对象字段。

void

AbstractMarshallerImpl.setProperty​(String name, Object value)

setProperty方法的默认实现处理Marshaller中四个定义的属性。

void

AbstractUnmarshallerImpl.setProperty​(String name, Object value)

setProperty方法的默认实现总是抛出PropertyException，因为没有必需的属性。

Constructors in javax.xml.bind.helpers with parameters of type Object

Constructor

描述

ValidationEventLocatorImpl​(Object _object)

构造指向JAXB内容对象的对象。

Uses of Object in javax.xml.bind.util

Subclasses of Object in javax.xml.bind.util

Modifier and Type

Class

描述

class

JAXBResult

JAXP Result实现解组JAXB对象。

class

JAXBSource

编写 JAXB生成的对象的JAXP Source实现。

class

ValidationEventCollector

ValidationEventHandler收集所有事件的实现。

Methods in javax.xml.bind.util that return Object

Modifier and Type

方法

描述

Object

JAXBResult.getResult​()

获取由转换创建的未编组对象。

Constructors in javax.xml.bind.util with parameters of type Object

Constructor

描述

JAXBSource​(JAXBContext context, Object contentObject)

为给定的内容对象创建一个新的Source 。

JAXBSource​(Marshaller marshaller, Object contentObject)

为给定的内容对象创建一个新的Source 。

Uses of Object in javax.xml.catalog

Subclasses of Object in javax.xml.catalog

Modifier and Type

Class

描述

class

CatalogException

异常类处理在处理或使用目录时可能发生的错误。

class

CatalogFeatures

CatalogFeatures拥有功能和属性的集合。

static class

CatalogFeatures.Builder

用于构建CatalogFeatures对象的Builder类。

class

CatalogManager

目录管理器管理XML目录和目录解析器的创建。

Uses of Object in javax.xml.crypto

Subclasses of Object in javax.xml.crypto

Modifier and Type

Class

描述

class

KeySelector

使用KeyInfo对象中包含的数据查找并返回键的选择器。

static class

KeySelector.Purpose

要选择的键的目的。

class

KeySelectorException

表示KeySelector抛出的异常情况。

class

MarshalException

表示在XML编组或解组过程中发生的异常情况。

class

NoSuchMechanismException

当请求特定的XML机制但在环境中不可用时抛出此异常。

class

OctetStreamData

包含八位字节流的 Data类型的表示。

class

URIReferenceException

表示在取消引用URIReference时抛出异常情况。

Methods in javax.xml.crypto that return Object

Modifier and Type

方法

描述

Object

XMLCryptoContext.get​(Object key)

返回此上下文映射指定键的值。

Object

XMLCryptoContext.getProperty​(String name)

返回指定属性的值。

Object

XMLCryptoContext.put​(Object key, Object value)

将指定的值与此上下文中的指定关键字相关联。

Object

XMLCryptoContext.setProperty​(String name, Object value)

设置指定的属性。

Methods in javax.xml.crypto with parameters of type Object

Modifier and Type

方法

描述

Object

XMLCryptoContext.get​(Object key)

返回此上下文映射指定键的值。

Object

XMLCryptoContext.put​(Object key, Object value)

将指定的值与此上下文中的指定关键字相关联。

Object

XMLCryptoContext.setProperty​(String name, Object value)

设置指定的属性。

Uses of Object in javax.xml.crypto.dom

Subclasses of Object in javax.xml.crypto.dom

Modifier and Type

Class

描述

class

DOMCryptoContext

这个类提供了一个DOM特定的XMLCryptoContext接口的实现。

class

DOMStructure

一个DOM特定的XMLStructure 。

Methods in javax.xml.crypto.dom that return Object

Modifier and Type

方法

描述

Object

DOMCryptoContext.get​(Object key)

此实现使用内部HashMap来获取指定键映射到的对象。

Object

DOMCryptoContext.getProperty​(String name)

此实现使用内部HashMap获取指定名称映射到的对象。

Object

DOMCryptoContext.put​(Object key, Object value)

此实现使用内部HashMap将密钥映射到指定的对象。

Object

DOMCryptoContext.setProperty​(String name, Object value)

此实现使用内部HashMap将名称映射到指定的对象。

Methods in javax.xml.crypto.dom with parameters of type Object

Modifier and Type

方法

描述

Object

DOMCryptoContext.get​(Object key)

此实现使用内部HashMap获取指定键映射到的对象。

Object

DOMCryptoContext.put​(Object key, Object value)

此实现使用内部HashMap将键映射到指定的对象。

Object

DOMCryptoContext.setProperty​(String name, Object value)

此实现使用内部HashMap将名称映射到指定的对象。

Uses of Object in javax.xml.crypto.dsig

Subclasses of Object in javax.xml.crypto.dsig

Modifier and Type

Class

描述

class

TransformException

表示执行变换算法时发生的异常情况。

class

TransformService

用于变换和规范化算法的服务提供程序接口。

class

XMLSignatureException

表示在XML签名生成或验证过程中发生的特殊情况。

class

XMLSignatureFactory

从零开始创建XMLSignature个对象的工厂，或从对应的XML表示中解组XMLSignature对象。

Uses of Object in javax.xml.crypto.dsig.dom

Subclasses of Object in javax.xml.crypto.dsig.dom

Modifier and Type

Class

描述

class

DOMSignContext

一个DOM特定的XMLSignContext 。

class

DOMValidateContext

DOM专有的XMLValidateContext 。

Uses of Object in javax.xml.crypto.dsig.keyinfo

Subclasses of Object in javax.xml.crypto.dsig.keyinfo

Modifier and Type

Class

描述

class

KeyInfoFactory

从零开始创建KeyInfo个对象的工厂，或从对应的XML表示中解组KeyInfo对象。

Uses of Object in javax.xml.crypto.dsig.spec

Subclasses of Object in javax.xml.crypto.dsig.spec

Modifier and Type

Class

描述

class

ExcC14NParameterSpec

W3C推荐参数： Exclusive XML Canonicalization (C14N) algorithm 。

class

HMACParameterSpec

参数为 XML Signature HMAC Algorithm 。

class

XPathFilter2ParameterSpec

参考W3C推荐 XPath Filter 2.0 Transform Algorithm 。

class

XPathFilterParameterSpec

参数为 XPath Filtering Transform Algorithm 。

class

XPathType

所述的XML架构定义 XPath如在定义元件 W3C Recommendation for XML-Signature XPath Filter 2.0 ：

static class

XPathType.Filter

表示过滤器设置操作。

class

XSLTTransformParameterSpec

参数为 XSLT Transform Algorithm 。

Uses of Object in javax.xml.datatype

Subclasses of Object in javax.xml.datatype

Modifier and Type

Class

描述

class

DatatypeConfigurationException

表示严重的配置错误。

class

DatatypeConstants

包含基本数据类型值作为常量的实用程序类。

static class

DatatypeConstants.Field

类型安全的枚举类，表示Duration类的六个字段。

class

DatatypeFactory

创建新的 javax.xml.datatype Object s的工厂， javax.xml.datatype XML映射到/从Java Object s。

class

Duration

W3C XML Schema 1.0规范中定义的时间跨度的不可变表示。

class

XMLGregorianCalendar

W3C XML Schema 1.0日期/时间数据类型的表示。

Methods in javax.xml.datatype that return Object

Modifier and Type

方法

描述

abstract Object

XMLGregorianCalendar.clone​()

创建并返回此对象的副本。

Methods in javax.xml.datatype with parameters of type Object

Modifier and Type

方法

描述

boolean

Duration.equals​(Object duration)

检查此持续时间对象是否与另一个 Duration对象具有相同的持续时间。

boolean

XMLGregorianCalendar.equals​(Object obj)

将此日历与指定的对象进行比较。

Uses of Object in javax.xml.namespace

Subclasses of Object in javax.xml.namespace

Modifier and Type

Class

描述

class

QName

QName表示如在XML规范中定义一个 限定名 ： XML Schema Part2: Datatypes specification ， Namespaces in XML ， Namespaces in XML Errata 。

Methods in javax.xml.namespace with parameters of type Object

Modifier and Type

方法

描述

boolean

QName.equals​(Object objectToTest)

测试这个 QName与其他 Object平等。

Uses of Object in javax.xml.parsers

Subclasses of Object in javax.xml.parsers

Modifier and Type

Class

描述

class

DocumentBuilder

定义从XML文档获取DOM文档实例的API。

class

DocumentBuilderFactory

定义工厂API，使应用程序能够从XML文档获取生成DOM对象树的解析器。

class

FactoryConfigurationError

当与Parser工厂存在配置问题时抛出。

class

ParserConfigurationException

表示严重的配置错误。

class

SAXParser

定义包装一个XMLReader实现类的API。

class

SAXParserFactory

定义工厂API，使应用程序能够配置和获取基于SAX的解析器来解析XML文档。

Methods in javax.xml.parsers that return Object

Modifier and Type

方法

描述

abstract Object

DocumentBuilderFactory.getAttribute​(String name)

允许用户检索底层实现的特定属性。

abstract Object

SAXParser.getProperty​(String name)

返回底层实现中请求的特定属性XMLReader 。

Methods in javax.xml.parsers with parameters of type Object

Modifier and Type

方法

描述

abstract void

DocumentBuilderFactory.setAttribute​(String name, Object value)

允许用户在底层实现上设置特定属性。

abstract void

SAXParser.setProperty​(String name, Object value)

设置基础实现中的特定属性XMLReader 。

Uses of Object in javax.xml.soap

Subclasses of Object in javax.xml.soap

Modifier and Type

Class

描述

class

AttachmentPart

一个附件到一个 SOAPMessage对象。

class

MessageFactory

创建 SOAPMessage对象的工厂。

class

MimeHeader

一个存储MIME头名称及其值的对象。

class

MimeHeaders

一个容纳 MimeHeader对象的容器，代表消息的MIME部分中出现的MIME头。

class

SAAJMetaFactory

在SAAJ API中定义的工厂的实现类的接入点。

class

SAAJResult

作为SAAJ树形式的JAXP转换或JAXB编组的结果的持有者。

class

SOAPConnection

客户端可以将消息直接发送到远程方（例如由URL表示）的点对点连接。

class

SOAPConnectionFactory

创建 SOAPConnection对象的工厂。

class

SOAPElementFactory

已过时。
- 使用javax.xml.soap.SOAPFactory创建SOAPElements。

class

SOAPException

发生SOAP异常发生的异常。

class

SOAPFactory

SOAPFactory是用于创建SOAP XML树中存在的各种对象的工厂。

class

SOAPMessage

所有SOAP消息的根类。

class

SOAPPart

用于 SOAPMessage对象的SOAP特定部分的 SOAPMessage 。

Methods in javax.xml.soap that return Object

Modifier and Type

方法

描述

abstract Object

AttachmentPart.getContent​()

获取此 AttachmentPart对象的内容作为Java对象。

Object

SOAPMessage.getProperty​(String property)

检索指定属性的值。

Methods in javax.xml.soap with parameters of type Object

Modifier and Type

方法

描述

abstract SOAPMessage

SOAPConnection.call​(SOAPMessage request, Object to)

将给定的消息发送到指定的端点并阻塞，直到它返回响应。

AttachmentPart

SOAPMessage.createAttachmentPart​(Object content, String contentType)

创建一个 AttachmentPart对象，并使用指定的内容类型的指定数据进行填充。

SOAPMessage

SOAPConnection.get​(Object to)

从特定端点获取消息，并阻塞，直到收到，

abstract void

AttachmentPart.setContent​(Object object, String contentType)

将此附件部分的内容设置为给定的 Object的内容，并将 Content-Type标头的值设置为给定类型。

void

SOAPMessage.setProperty​(String property, Object value)

将指定的值与指定的属性相关联。

Uses of Object in javax.xml.stream

Subclasses of Object in javax.xml.stream

Modifier and Type

Class

描述

class

FactoryConfigurationError

报告工厂配置错误的错误类。

class

XMLEventFactory

该界面定义了一个用于创建XMLEvents实例的实用程序类

class

XMLInputFactory

定义了一个工厂的抽象实现来获取流。

class

XMLOutputFactory

定义用于获取XMLEventWriters和XMLStreamWrit的工厂的抽象实现。

class

XMLStreamException

基于异常的意外处理错误。

Methods in javax.xml.stream that return Object

Modifier and Type

方法

描述

Object

XMLEventReader.getProperty​(String name)

从底层实现获取特征/属性的值

abstract Object

XMLInputFactory.getProperty​(String name)

从底层实现获取特征/属性的值

abstract Object

XMLOutputFactory.getProperty​(String name)

获取底层实现的功能/属性

Object

XMLStreamReader.getProperty​(String name)

从底层实现获取特征/属性的值

Object

XMLStreamWriter.getProperty​(String name)

从底层实现获取特征/属性的值

Object

XMLResolver.resolveEntity​(String publicID, String systemID, String baseURI, String namespace)

检索资源。

Methods in javax.xml.stream with parameters of type Object

Modifier and Type

方法

描述

void

XMLReporter.report​(String message, String errorType, Object relatedInformation, Location location)

以应用程序特定格式报告所需的消息。

abstract void

XMLInputFactory.setProperty​(String name, Object value)

允许用户在底层实现上设置特定的功能/属性。

abstract void

XMLOutputFactory.setProperty​(String name, Object value)

允许用户在底层实现上设置特定的功能/属性。

Uses of Object in javax.xml.stream.events

Methods in javax.xml.stream.events that return Object

Modifier and Type

方法

描述

Object

DTD.getProcessedDTD​()

返回DTD的实现定义表示。

Uses of Object in javax.xml.stream.util

Subclasses of Object in javax.xml.stream.util

Modifier and Type

Class

描述

class

EventReaderDelegate

这是导出XMLEventReader过滤器的基类。

class

StreamReaderDelegate

这是派生XMLStreamReader过滤器的基础类此类设计为位于XMLStreamReader和应用程序的XMLStreamReader之间。

Methods in javax.xml.stream.util that return Object

Modifier and Type

方法

描述

Object

EventReaderDelegate.getProperty​(String name)

Object

StreamReaderDelegate.getProperty​(String name)

Object

EventReaderDelegate.next​()

Uses of Object in javax.xml.transform

Subclasses of Object in javax.xml.transform

Modifier and Type

Class

描述

class

OutputKeys

提供可用于设置Transformer的输出属性或从Transformer或Templates对象检索输出属性的字符串常量。

class

Transformer

这个抽象类的一个实例可以将一个源代码树转换成一个结果树。

class

TransformerConfigurationException

表示严重的配置错误。

class

TransformerException

此类指定在转换过程中发生的异常情况。

class

TransformerFactory

TransformerFactory实例可用于创建Transformer和Templates对象。

class

TransformerFactoryConfigurationError

当Transformer工厂存在配置问题时抛出。

Methods in javax.xml.transform that return Object

Modifier and Type

方法

描述

abstract Object

TransformerFactory.getAttribute​(String name)

允许用户检索底层实现的特定属性。

abstract Object

Transformer.getParameter​(String name)

获取使用setParameter显式设置的参数。

Methods in javax.xml.transform with parameters of type Object

Modifier and Type

方法

描述

abstract void

TransformerFactory.setAttribute​(String name, Object value)

允许用户在底层实现上设置特定属性。

abstract void

Transformer.setParameter​(String name, Object value)

添加转换参数。

Uses of Object in javax.xml.transform.dom

Subclasses of Object in javax.xml.transform.dom

Modifier and Type

Class

描述

class

DOMResult

作为文档对象模型（DOM）树形式的转换结果树的持有者。

class

DOMSource

作为文档对象模型（DOM）树形式的变换源树的持有者。

Uses of Object in javax.xml.transform.sax

Subclasses of Object in javax.xml.transform.sax

Modifier and Type

Class

描述

class

SAXResult

作为转型结果的持有人。

class

SAXSource

作为SAX风格来源的持有人。

class

SAXTransformerFactory

此类扩展TransformerFactory以提供SAX特定的工厂方法。

Uses of Object in javax.xml.transform.stax

Subclasses of Object in javax.xml.transform.stax

Modifier and Type

Class

描述

class

StAXResult

作为一个持有的XML Result以StAX作家的形式，即

class

StAXSource

作为StAX读者形式的XML Source的持有人，即

Uses of Object in javax.xml.transform.stream

Subclasses of Object in javax.xml.transform.stream

Modifier and Type

Class

描述

class

StreamResult

作为转换结果的持有人，可以是XML，纯文本，HTML或其他形式的标记。

class

StreamSource

作为转换的持有人以XML标记流的形式来源。

Uses of Object in javax.xml.validation

Subclasses of Object in javax.xml.validation

Modifier and Type

Class

描述

class

Schema

不可变的内存中的语法表示。

class

SchemaFactory

创建Schema对象的工厂。

class

SchemaFactoryConfigurationError

当存在具有Schema工厂的配置问题时抛出。

class

SchemaFactoryLoader

工厂创建SchemaFactory 。

class

TypeInfoProvider

该类提供对由ValidatorHandler确定的类型信息的访问 。

class

Validator

根据Schema检查XML文档的处理器。

class

ValidatorHandler

流式验证器，适用于SAX流。

Methods in javax.xml.validation that return Object

Modifier and Type

方法

描述

Object

SchemaFactory.getProperty​(String name)

查找属性的值。

Object

Validator.getProperty​(String name)

查找属性的值。

Object

ValidatorHandler.getProperty​(String name)

查找属性的值。

Methods in javax.xml.validation with parameters of type Object

Modifier and Type

方法

描述

void

SchemaFactory.setProperty​(String name, Object object)

设置属性的值。

void

Validator.setProperty​(String name, Object object)

设置属性的值。

void

ValidatorHandler.setProperty​(String name, Object object)

设置属性的值。

Uses of Object in javax.xml.ws

Subclasses of Object in javax.xml.ws

Modifier and Type

Class

描述

class

Endpoint

Web服务端点。

class

EndpointContext

EndpointContext允许应用程序中的多个端点共享任何信息。

class

EndpointReference

此类表示WS-Addressing EndpointReference，它是对Web服务端点的远程引用。

class

Holder<T>

持有值类型 T 。

class

ProtocolException

ProtocolException类是与特定协议绑定相关的异常的基类。

class

RespectBindingFeature

此功能说明了JAX-WS运行时中使用的 wsdl:binding 。

class

Service

Service对象提供Web服务的客户端视图。

class

WebServiceException

WebServiceException类是所有JAX-WS API运行时异常的基本异常类。

class

WebServiceFeature

WebServiceFeature用于表示可以为Web服务启用或禁用的功能。

class

WebServicePermission

此类定义Web服务权限。

Fields in javax.xml.ws declared as Object

Modifier and Type

Field

描述

T

Holder.value

包含在持有人的价值。

Methods in javax.xml.ws that return Object

Modifier and Type

方法

描述

abstract Object

Endpoint.getImplementor​()

返回此端点的实现对象。

Object

LogicalMessage.getPayload​(JAXBContext context)

获取消息有效载荷作为JAXB对象。

Methods in javax.xml.ws that return types with arguments of type Object

Modifier and Type

方法

描述

Dispatch<Object>

Service.createDispatch​(QName portName, JAXBContext context, Service.Mode mode)

创建一个用于JAXB生成的对象的 Dispatch实例。

Dispatch<Object>

Service.createDispatch​(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)

创建一个用于JAXB生成的对象的 Dispatch实例。

Dispatch<Object>

Service.createDispatch​(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)

创建一个用于JAXB生成的对象的 Dispatch实例。

Map<String,Object>

Response.getContext​()

获取包含的响应上下文。

abstract Map<String,Object>

Endpoint.getProperties​()

返回此 Endpoint实例的属性包。

Map<String,Object>

BindingProvider.getRequestContext​()

获取用于初始化请求消息的消息上下文的上下文。

Map<String,Object>

BindingProvider.getResponseContext​()

获取处理响应消息产生的上下文。

Methods in javax.xml.ws with parameters of type Object

Modifier and Type

方法

描述

static Endpoint

Endpoint.create​(Object implementor)

创建具有指定的实现对象的端点。

static Endpoint

Endpoint.create​(Object implementor, WebServiceFeature... features)

创建具有指定的实现者对象和Web服务功能的端点。

static Endpoint

Endpoint.create​(String bindingId, Object implementor)

创建具有指定绑定类型和实现方对象的端点。

static Endpoint

Endpoint.create​(String bindingId, Object implementor, WebServiceFeature... features)

创建具有指定绑定类型，实现方对象和Web服务功能的端点。

abstract void

Endpoint.publish​(Object serverContext)

在提供的服务器上下文中发布此端点。

static Endpoint

Endpoint.publish​(String address, Object implementor)

在给定的地址创建并发布指定的实现者对象的端点。

static Endpoint

Endpoint.publish​(String address, Object implementor, WebServiceFeature... features)

在给定的地址创建并发布指定的实现者对象的端点。

void

LogicalMessage.setPayload​(Object payload, JAXBContext context)

设置消息有效载荷

Method parameters in javax.xml.ws with type arguments of type Object

Modifier and Type

方法

描述

abstract void

Endpoint.setProperties​(Map<String,Object> properties)

设置此 Endpoint实例的属性包。

Uses of Object in javax.xml.ws.handler.soap

Methods in javax.xml.ws.handler.soap that return Object

Modifier and Type

方法

描述

Object[]

SOAPMessageContext.getHeaders​(QName header, JAXBContext context, boolean allRoles)

从消息上下文中的消息获取具有特定限定名称的头文件。

Uses of Object in javax.xml.ws.http

Subclasses of Object in javax.xml.ws.http

Modifier and Type

Class

描述

class

HTTPException

HTTPException异常表示XML / HTTP故障。

Uses of Object in javax.xml.ws.soap

Subclasses of Object in javax.xml.ws.soap

Modifier and Type

Class

描述

class

AddressingFeature

AddressingFeature表示使用SOAP 1.1 / HTTP或SOAP 1.2 / HTTP绑定的WS-Addressing。

class

MTOMFeature

此功能表示使用具有Web服务的MTOM。

class

SOAPFaultException

SOAPFaultException异常表示SOAP 1.1或1.2故障。

Uses of Object in javax.xml.ws.spi

Subclasses of Object in javax.xml.ws.spi

Modifier and Type

Class

描述

class

Invoker

Invoker隐藏了调用应用程序端点实现的细节。

class

Provider

服务提供商 ServiceDelegate和 Endpoint对象。

class

ServiceDelegate

服务代表由 Service对象内部使用，以允许JAX-WS实现的可插拔性。

Methods in javax.xml.ws.spi that return Object

Modifier and Type

方法

描述

abstract Object

Invoker.invoke​(方法 m, Object... args)

JAX-WS运行时调用此方法来对端点实例执行实际的Web服务调用。

Methods in javax.xml.ws.spi that return types with arguments of type Object

Modifier and Type

方法

描述

abstract Dispatch<Object>

ServiceDelegate.createDispatch​(QName portName, JAXBContext context, Service.Mode mode)

创建一个用于JAXB生成的对象的 Dispatch实例。

abstract Dispatch<Object>

ServiceDelegate.createDispatch​(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)

创建一个用于JAXB生成的对象的 Dispatch实例。

abstract Dispatch<Object>

ServiceDelegate.createDispatch​(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)

创建一个用于JAXB生成的对象的 Dispatch实例。

Methods in javax.xml.ws.spi with parameters of type Object

Modifier and Type

方法

描述

abstract Endpoint

Provider.createAndPublishEndpoint​(String address, Object implementor)

创建并发布具有指定地址和实现对象的端点对象。

Endpoint

Provider.createAndPublishEndpoint​(String address, Object implementor, WebServiceFeature... features)

创建并发布具有指定地址，实现对象和Web服务功能的端点对象。

abstract Endpoint

Provider.createEndpoint​(String bindingId, Object implementor)

使用提供的绑定和实现对象创建端点对象。

Endpoint

Provider.createEndpoint​(String bindingId, Object implementor, WebServiceFeature... features)

使用提供的绑定，实现对象和Web服务功能创建端点对象。

abstract Object

Invoker.invoke​(方法 m, Object... args)

JAX-WS运行时调用此方法来对端点实例执行实际的Web服务调用。

Uses of Object in javax.xml.ws.spi.http

Subclasses of Object in javax.xml.ws.spi.http

Modifier and Type

Class

描述

class

HttpContext

HttpContext表示Web服务的根URI路径与HttpHandler之间的映射，该对象被调用以处理发往关联容器上的该路径的请求。

class

HttpExchange

此类封装了收到的HTTP请求和在一个交换中生成的响应。

class

HttpHandler

被调用以处理HTTP请求的处理程序。

Methods in javax.xml.ws.spi.http that return Object

Modifier and Type

方法

描述

abstract Object

HttpContext.getAttribute​(String name)

返回容器配置的属性值和jax-ws运行时可以使用的其他数据。

abstract Object

HttpExchange.getAttribute​(String name)

返回与此 HttpExchange相关联的属性。

Uses of Object in javax.xml.ws.wsaddressing

Subclasses of Object in javax.xml.ws.wsaddressing

Modifier and Type

Class

描述

class

W3CEndpointReference

此类表示W3C寻址端点引用，它是支持W3C WS-Addressing 1.0 - 核心推荐的Web服务端点的远程引用。

class

W3CEndpointReferenceBuilder

此类用于构建 W3CEndpointReference实例。

Uses of Object in javax.xml.xpath

Subclasses of Object in javax.xml.xpath

Modifier and Type

Class

描述

class

XPathConstants

XPath常量。

class

XPathException

XPathException表示一个通用的XPath异常。

class

XPathExpressionException

XPathExpressionException表示XPath表达式中的错误。

class

XPathFactory

一个XPathFactory实例可以用来创建XPath对象。

class

XPathFactoryConfigurationException

XPathFactoryConfigurationException表示 XPathFactory环境中的配置错误。

class

XPathFunctionException

XPathFunctionException表示XPath函数的错误。

Methods in javax.xml.xpath that return Object

Modifier and Type

方法

描述

Object

XPath.evaluate​(String expression, Object item, QName returnType)

在指定的上下文中评估 XPath表达式，并将结果作为指定的类型返回。

Object

XPath.evaluate​(String expression, InputSource source, QName returnType)

在指定的 InputSource的上下文中评估XPath表达式，并返回结果作为指定的类型。

Object

XPathExpression.evaluate​(Object item, QName returnType)

在指定的上下文中评估编译的XPath表达式，并将结果作为指定的类型返回。

Object

XPathExpression.evaluate​(InputSource source, QName returnType)

在指定的 InputSource的上下文中评估编译的XPath表达式，并返回结果作为指定的类型。

Object

XPathFunction.evaluate​(List args)

用指定的参数来评估函数。

Object

XPathVariableResolver.resolveVariable​(QName variableName)

在可用变量集中找到一个变量。

Methods in javax.xml.xpath with parameters of type Object

Modifier and Type

方法

描述

String

XPath.evaluate​(String expression, Object item)

评估指定上下文中的XPath表达式，并将结果作为 String返回。

Object

XPath.evaluate​(String expression, Object item, QName returnType)

在指定的上下文中评估一个 XPath表达式，并将结果作为指定的类型返回。

String

XPathExpression.evaluate​(Object item)

在指定的上下文中评估编译的XPath表达式，并将结果作为 String返回。

Object

XPathExpression.evaluate​(Object item, QName returnType)

在指定的上下文中评估编译的XPath表达式，并将结果作为指定的类型返回。

default XPathEvaluationResult<?>

XPath.evaluateExpression​(String expression, Object item)

评估指定上下文中的XPath表达式。

default <T> T

XPath.evaluateExpression​(String expression, Object item, Class<T> type)

在指定的上下文中评估一个XPath表达式，并通过 class type指定的类型返回结果

default XPathEvaluationResult<?>

XPathExpression.evaluateExpression​(Object item)

在指定的上下文中评估编译的XPath表达式。

default <T> T

XPathExpression.evaluateExpression​(Object item, Class<T> type)

在指定的上下文中评估编译的XPath表达式，并返回具有通过 class type指定的类型的结果。

Uses of Object in jdk.dynalink

Subclasses of Object in jdk.dynalink

Modifier and Type

Class

描述

class

CallSiteDescriptor

呼叫站点描述符包含链接呼叫站点所需的所有信息。

class

DynamicLinker

RelinkableCallSite对象的链接器。

class

DynamicLinkerFactory

创建DynamicLinker对象的工厂类。

class

NamedOperation

将名称与另一个操作相关联的操作。

class

NamespaceOperation

描述对至少一个对象Namespace进行操作的操作。

class

NoSuchDynamicMethodException

如果呼叫站点无法通过任何可用的GuardingDynamicLinker链接，则在调用时抛出。

class

SecureLookupSupplier

提供安全检查访问 MethodHandles.Lookup对象。

Methods in jdk.dynalink that return Object

Modifier and Type

方法

描述

Object

NamedOperation.getName​()

返回此命名操作的名称。

static Object

NamedOperation.getName​(Operation op)

如果传递的操作是命名操作，则返回其 NamedOperation.getName() ，否则返回null。

Methods in jdk.dynalink with parameters of type Object

Modifier and Type

方法

描述

boolean

CallSiteDescriptor.equals​(Object obj)

如果此调用站点描述符等于传递的对象，则返回true。

boolean

NamedOperation.equals​(Object obj)

将此命名操作与另一个对象进行比较。

boolean

NamespaceOperation.equals​(Object obj)

如果另一个对象也是命名空间操作，并且它们的基本操作和命名空间相等，则返回true。

default NamedOperation

Operation.named​(Object name)

以此操作为基础返回NamedOperation 。

Constructors in jdk.dynalink with parameters of type Object

Constructor

描述

NamedOperation​(Operation baseOperation, Object name)

创建一个新的命名操作。

Uses of Object in jdk.dynalink.beans

Subclasses of Object in jdk.dynalink.beans

Modifier and Type

Class

描述

class

BeansLinker

用于普通Java对象的链接器。

class

StaticClass

允许访问类的静态成员（其静态方法，属性和字段）的对象，以及使用 StandardOperation.NEW操作构建实例的 对象 。

Methods in jdk.dynalink.beans that return Object

Modifier and Type

方法

描述

static Object

BeansLinker.getConstructorMethod​(Class<?> clazz, String signature)

返回给定类的构造函数的动态方法和给定的签名。

Methods in jdk.dynalink.beans with parameters of type Object

Modifier and Type

方法

描述

static boolean

BeansLinker.isDynamicConstructor​(Object obj)

如果对象是Java构造函数（通过 BeansLinker.getConstructorMethod(Class, String)获得），则返回true。

static boolean

BeansLinker.isDynamicMethod​(Object obj)

如果对象是Java动态方法（例如，通过Java对象上的GET:METHOD操作或StaticClass或通过BeansLinker.getConstructorMethod(Class, String)获取的对象），则返回true。

Uses of Object in jdk.dynalink.linker

Subclasses of Object in jdk.dynalink.linker

Modifier and Type

Class

描述

class

GuardedInvocation

表示有条件的有效方法句柄。

class

GuardingDynamicLinkerExporter

作为保护动态链接器的供应商的类，可以由其他语言运行时自动加载。

Methods in jdk.dynalink.linker that return Object

Modifier and Type

方法

描述

Object[]

LinkRequest.getArguments​()

返回要链接的调用的参数。

Object

LinkRequest.getReceiver​()

返回被链接的调用的第一个参数; 这通常是接收器对象。

Methods in jdk.dynalink.linker with parameters of type Object

Modifier and Type

方法

描述

LinkRequest

LinkRequest.replaceArguments​(CallSiteDescriptor callSiteDescriptor, Object... arguments)

返回与此调用站点描述符相同的请求，并使用指定的参数替换参数。

Uses of Object in jdk.dynalink.linker.support

Subclasses of Object in jdk.dynalink.linker.support

Modifier and Type

Class

描述

class

CompositeGuardingDynamicLinker

A GuardingDynamicLinker ，其顺序地委托给其CompositeGuardingDynamicLinker.getGuardedInvocation(LinkRequest, LinkerServices)中的其他保护动态链接器的列表 。

class

CompositeTypeBasedGuardingDynamicLinker

一种基于复合类型的保护动态链接器。

class

DefaultInternalObjectFilter

一个 DynamicLinkerFactory.setInternalObjectsFilter(MethodHandleTransformer)的默认实现，委托一对过滤方法句柄。

class

Guards

用于创建 MethodHandles.guardWithTest(MethodHandle, MethodHandle, MethodHandle)的典型守护 者和调整其方法类型的实用方法。

class

Lookup

封装MethodHandles.Lookup ，掩盖检查的异常。

class

SimpleLinkRequest

默认简单实现LinkRequest 。

class

TypeUtilities

用于处理Java类型的各种静态实用程序方法。

Methods in jdk.dynalink.linker.support that return Object

Modifier and Type

方法

描述

Object[]

SimpleLinkRequest.getArguments​()

Object

SimpleLinkRequest.getReceiver​()

Methods in jdk.dynalink.linker.support with parameters of type Object

Modifier and Type

方法

描述

static MethodHandle

Guards.getIdentityGuard​(Object obj)

创建一个保护方法，测试其唯一的参数与其他对象的位置相同

LinkRequest

SimpleLinkRequest.replaceArguments​(CallSiteDescriptor newCallSiteDescriptor, Object... newArguments)

Constructors in jdk.dynalink.linker.support with parameters of type Object

Constructor

描述

SimpleLinkRequest​(CallSiteDescriptor callSiteDescriptor, boolean callSiteUnstable, Object... arguments)

创建一个新的链接请求。

Uses of Object in jdk.dynalink.support

Subclasses of Object in jdk.dynalink.support

Modifier and Type

Class

描述

class

AbstractRelinkableCallSite

一个基本实现的RelinkableCallSite作为MutableCallSite 。

class

ChainedCallSite

实现多态内联缓存策略的可重新链接的调用站点。

class

SimpleRelinkableCallSite

一个可重新链接的调用站点，实现单态内联缓存策略，只能在任何给定时间链接到单个GuardedInvocation 。

Uses of Object in jdk.incubator.http

Subclasses of Object in jdk.incubator.http

Modifier and Type

Class

描述

class

HttpClient

用于多个HttpRequest的通用配置信息的容器。

static class

HttpClient.Builder

不可变的建筑师HttpClient s。

class

HttpRequest

表示可以发送到服务器的一个HTTP请求。

static class

HttpRequest.Builder

一个建筑师HttpRequest s。

class

HttpResponse<T>

代表对HttpRequest的回复 。

class

HttpTimeoutException

在指定时间段内没有收到回应时抛出。

class

MultiMapResult<V>

A Map包含HTTP / 2请求和多响应的结果。

class

WebSocketHandshakeException

用于表示开启握手的异常失败。

Methods in jdk.incubator.http with parameters of type Object

Modifier and Type

方法

描述

boolean

MultiMapResult.containsKey​(Object key)

boolean

MultiMapResult.containsValue​(Object value)

CompletableFuture<HttpResponse<V>>

MultiMapResult.get​(Object key)

CompletableFuture<HttpResponse<V>>

MultiMapResult.remove​(Object key)

Uses of Object in jdk.javadoc.doclet

Subclasses of Object in jdk.javadoc.doclet

Modifier and Type

Class

描述

class

StandardDoclet

该doclet为指定的模块，包和类型生成HTML格式的文档。

Uses of Object in jdk.jshell

Subclasses of Object in jdk.jshell

Modifier and Type

Class

描述

class

DeclarationSnippet

分组所有声明片段：变量声明（ VarSnippet ），方法声明（ MethodSnippet ）和类型声明（ TypeDeclSnippet ）。

class

Diag

代码段的诊断信息。

class

ErroneousSnippet

一段代码无效的Java编程语言代码。

class

EvalException

封装在远程执行客户机中抛出的异常。

class

ExpressionSnippet

赋值或变量值表达式的代码段。

class

ImportSnippet

导入声明的代码段。

class

JShell

JShell评估状态引擎。

static class

JShell.Builder

生成器为 JShell实例。

class

JShell.Subscription

订阅是引用订阅的标记，因此可以是 unsubscribed 。

class

JShellException

JShell的超类生成异常

class

MethodSnippet

方法定义的代码段。

class

PersistentSnippet

对持续存在并影响未来代码的片段进行分组。

class

Snippet

代码片段代表传递给 JShell.eval的Java源代码片段。

class

SnippetEvent

对代码段的更改的描述。

class

SourceCodeAnalysis

提供源代码输入的分析实用程序。

static class

SourceCodeAnalysis.QualifiedNames

可能的合格名称列表。

class

StatementSnippet

一段语句的片段

class

TypeDeclSnippet

类型定义的代码段（类，接口，枚举或注释接口定义）。

class

UnresolvedReferenceException

在尝试执行 RECOVERABLE_DEFINED片段时报告异常。

class

VarSnippet

变量定义的代码段。

Uses of Object in jdk.jshell.execution

Subclasses of Object in jdk.jshell.execution

Modifier and Type

Class

描述

class

DirectExecutionControl

在当前进程中运行的ExecutionControl实现。

class

FailOverExecutionControlProvider

一直尝试其他提供商，直到一个工作。

class

JdiDefaultExecutionControl

默认情况下，JShell-core使用的是ExecutionControl的实现。

class

JdiExecutionControl

摘要JDI实现ExecutionControl 。

class

JdiExecutionControlProvider

远程JDI控制执行引擎的提供者。

class

JdiInitiator

设置一个JDI连接，提供所产生的JDI VirtualMachine和远程代理正在运行的Process 。

class

LocalExecutionControl

执行ExecutionControl ，它在与JShell核心相同的JVM中执行。

class

LocalExecutionControlProvider

执行引擎的提供者以与JShell相同的方式运行。

class

RemoteExecutionControl

远程代理在执行过程中运行（与主JShell进程分开）。

class

StreamingExecutionControl

ExecutionControl执行引擎SPI的实现，将请求发送到执行发生的远程代理。

class

Util

用于设置实现的其他实用方法ExecutionControl 。

Methods in jdk.jshell.execution that return Object

Modifier and Type

方法

描述

Object

DirectExecutionControl.extensionCommand​(String command, Object arg)

Object

StreamingExecutionControl.extensionCommand​(String command, Object arg)

Methods in jdk.jshell.execution with parameters of type Object

Modifier and Type

方法

描述

Object

DirectExecutionControl.extensionCommand​(String command, Object arg)

Object

StreamingExecutionControl.extensionCommand​(String command, Object arg)

protected static String

DirectExecutionControl.valueString​(Object value)

将 Object值从 ExecutionControl.invoke(String, String)或 ExecutionControl.varValue(String, String)转换为 String 。

Uses of Object in jdk.jshell.spi

Subclasses of Object in jdk.jshell.spi

Modifier and Type

Class

描述

static class

ExecutionControl.ClassBytecodes

使用类字节码捆绑类名。

static class

ExecutionControl.ClassInstallException

类安装（加载或重新定义）遇到问题。

static class

ExecutionControl.EngineTerminationException

未执行引擎终止已发生。

static class

ExecutionControl.ExecutionControlException

所有 ExecutionControl例外的抽象基础。

static class

ExecutionControl.InternalException

发生内部问题。

static class

ExecutionControl.NotImplementedException

该命令未实现。

static class

ExecutionControl.ResolutionException

一个异常，表示遇到了一个未解决的引用的 DeclarationSnippet 。

static class

ExecutionControl.RunException

特定于运行用户代码的异常的抽象基础。

static class

ExecutionControl.StoppedException

表示 ExecutionControl.invoke(java.lang.String, java.lang.String) （或理论上为 ExecutionControl.varValue(java.lang.String, java.lang.String) ）已被 ExecutionControl.stop()中断的 例外 。

static class

ExecutionControl.UserException

发生“正常”用户异常。

class

SPIResolutionException

此异常的构造和抛出嵌入在JShell核心实现中生成的代码中，以便在执行 RECOVERABLE_DEFINED用户方法时抛出此异常。

Methods in jdk.jshell.spi that return Object

Modifier and Type

方法

描述

Object

ExecutionControl.extensionCommand​(String command, Object arg)

运行非标准命令（或较新版本的标准命令）。

Methods in jdk.jshell.spi with parameters of type Object

Modifier and Type

方法

描述

Object

ExecutionControl.extensionCommand​(String command, Object arg)

运行非标准命令（或较新版本的标准命令）。

Uses of Object in jdk.nashorn.api.scripting

Subclasses of Object in jdk.nashorn.api.scripting

Modifier and Type

Class

描述

class

AbstractJSObject

这是nashorn ScriptObjectMirror类的基类。

class

NashornException

这是所有Nashorn异常的基础例外。

class

NashornScriptEngine

适用于Nashorn的JSR-223兼容脚本引擎。

class

NashornScriptEngineFactory

适用于Nashorn的JSR-223兼容脚本引擎工厂。

class

ScriptObjectMirror

包含给定Nashorn Script对象的镜像对象。

class

ScriptUtils

要从脚本代码调用的实用程序。

class

URLReader

从URL读取的读者。

Methods in jdk.nashorn.api.scripting that return Object

Modifier and Type

方法

描述

Object

AbstractJSObject.call​(Object thiz, Object... args)

Object

JSObject.call​(Object thiz, Object... args)

将此对象称为JavaScript函数。

Object

ScriptObjectMirror.call​(Object thiz, Object... args)

Object

ScriptObjectMirror.callMember​(String functionName, Object... args)

调用成员函数

static Object

ScriptUtils.convert​(Object obj, Object type)

将给定对象转换为给定类型。

Object

AbstractJSObject.eval​(String s)

Object

JSObject.eval​(String s)

评估JavaScript表达式。

Object

NashornScriptEngine.eval​(Reader reader, ScriptContext ctxt)

Object

NashornScriptEngine.eval​(String script, ScriptContext ctxt)

Object

ScriptObjectMirror.eval​(String s)

Object

ScriptObjectMirror.get​(Object key)

static Object

AbstractJSObject.getDefaultValue​(JSObject jsobj, Class<?> hint)

已过时。
改用JSObject.getDefaultValue(Class) 。

default Object

JSObject.getDefaultValue​(Class<?> hint)

根据ECMAScript 5.1第8.6.2节实现该对象的 [[DefaultValue]]方法。

Object

ScriptObjectMirror.getDefaultValue​(Class<?> hint)

Object

NashornException.getEcmaError​()

返回底层的ECMA错误对象（如果可用）。

Object

AbstractJSObject.getMember​(String name)

Object

JSObject.getMember​(String name)

检索此JavaScript对象的命名成员。

Object

ScriptObjectMirror.getMember​(String name)

Object

ScriptObjectMirror.getOwnPropertyDescriptor​(String key)

ECMA 8.12.1 [[GetOwnProperty]]（P）

Object

NashornScriptEngineFactory.getParameter​(String key)

Object

ScriptObjectMirror.getProto​()

返回此对象的__proto__。

Object

AbstractJSObject.getSlot​(int index)

Object

JSObject.getSlot​(int index)

检索此JavaScript对象的索引成员。

Object

ScriptObjectMirror.getSlot​(int index)

protected Object

NashornException.getThrown​()

获取抛出的对象。

Object

NashornScriptEngine.invokeFunction​(String name, Object... args)

Object

NashornScriptEngine.invokeMethod​(Object thiz, String name, Object... args)

static Object

ScriptUtils.makeSynchronizedFunction​(Object func, Object sync)

创建一个调用包装函数 func上同步 sync或者，如果是不确定的， self 。

Object

AbstractJSObject.newObject​(Object... args)

Object

JSObject.newObject​(Object... args)

调用这个“构造函数”JavaScript函数来创建一个新对象。

Object

ScriptObjectMirror.newObject​(Object... args)

Object

ScriptObjectMirror.put​(String key, Object value)

Object

ScriptObjectMirror.remove​(Object key)

static Object

ScriptObjectMirror.unwrap​(Object obj, Object homeGlobal)

如果需要，可以解开脚本对象镜像。

static Object

ScriptUtils.unwrap​(Object obj)

如果需要，可以解开脚本对象镜像。

static Object[]

ScriptObjectMirror.unwrapArray​(Object[] args, Object homeGlobal)

如果需要，展开一组脚本对象镜像。

static Object[]

ScriptUtils.unwrapArray​(Object[] args)

如果需要，展开一组脚本对象镜像。

static Object

ScriptObjectMirror.wrap​(Object obj, Object homeGlobal)

如果需要，在给定对象上做一个脚本对象镜像。

static Object[]

ScriptObjectMirror.wrapArray​(Object[] args, Object homeGlobal)

如果需要，将对象数组包装到脚本对象镜像中。

static Object[]

ScriptUtils.wrapArray​(Object[] args)

如果需要，将对象数组包装到脚本对象镜像中。

static Object

ScriptObjectMirror.wrapAsJSONCompatible​(Object obj, Object homeGlobal)

如果需要，在给定对象上做一个脚本对象镜像。

Methods in jdk.nashorn.api.scripting that return types with arguments of type Object

Modifier and Type

方法

描述

Set<Map.Entry<String,Object>>

ScriptObjectMirror.entrySet​()

Collection<Object>

AbstractJSObject.values​()

Collection<Object>

JSObject.values​()

返回此对象的所有属性值的集合。

Collection<Object>

ScriptObjectMirror.values​()

Methods in jdk.nashorn.api.scripting with parameters of type Object

Modifier and Type

方法

描述

Object

AbstractJSObject.call​(Object thiz, Object... args)

Object

JSObject.call​(Object thiz, Object... args)

将此对象称为JavaScript函数。

Object

ScriptObjectMirror.call​(Object thiz, Object... args)

Object

ScriptObjectMirror.callMember​(String functionName, Object... args)

调用成员函数

boolean

ScriptObjectMirror.containsKey​(Object key)

boolean

ScriptObjectMirror.containsValue​(Object value)

static Object

ScriptUtils.convert​(Object obj, Object type)

将给定对象转换为给定类型。

boolean

ScriptObjectMirror.delete​(Object key)

从此对象中删除属性。

boolean

ScriptObjectMirror.equals​(Object other)

static String

ScriptUtils.format​(String format, Object[] args)

将JavaScript类型转换为String.format方法（jrunscript函数sprintf）的java类型的方法。

Object

ScriptObjectMirror.get​(Object key)

<T> T

NashornScriptEngine.getInterface​(Object thiz, Class<T> clazz)

static boolean

ScriptObjectMirror.identical​(Object obj1, Object obj2)

给定的对象是否反映到相同的底层对象？

Object

NashornScriptEngine.invokeFunction​(String name, Object... args)

Object

NashornScriptEngine.invokeMethod​(Object thiz, String name, Object... args)

boolean

AbstractJSObject.isInstance​(Object instance)

boolean

JSObject.isInstance​(Object instance)

检查给定对象是否为“this”对象的实例。

boolean

ScriptObjectMirror.isInstance​(Object instance)

boolean

AbstractJSObject.isInstanceOf​(Object clazz)

boolean

JSObject.isInstanceOf​(Object clazz)

检查此对象是否是给定的“clazz”对象的实例。

static boolean

ScriptObjectMirror.isUndefined​(Object obj)

检查给定对象的实用程序是否为ECMAScript未定义的值

static Object

ScriptUtils.makeSynchronizedFunction​(Object func, Object sync)

创建一个调用包装函数 func上同步 sync或者，如果是不确定的， self 。

Object

AbstractJSObject.newObject​(Object... args)

Object

JSObject.newObject​(Object... args)

调用这个“构造函数”JavaScript函数来创建一个新对象。

Object

ScriptObjectMirror.newObject​(Object... args)

Object

ScriptObjectMirror.put​(String key, Object value)

Object

ScriptObjectMirror.remove​(Object key)

void

NashornException.setEcmaError​(Object ecmaError)

返回底层的ECMA错误对象（如果可用）。

void

AbstractJSObject.setMember​(String name, Object value)

void

JSObject.setMember​(String name, Object value)

在此JavaScript对象中设置一个命名成员

void

ScriptObjectMirror.setMember​(String name, Object value)

void

ScriptObjectMirror.setProto​(Object proto)

设置此对象的__proto__。

void

AbstractJSObject.setSlot​(int index, Object value)

void

JSObject.setSlot​(int index, Object value)

在此JavaScript对象中设置索引成员

void

ScriptObjectMirror.setSlot​(int index, Object value)

static Object

ScriptObjectMirror.unwrap​(Object obj, Object homeGlobal)

如果需要，可以解开脚本对象镜像。

static Object

ScriptUtils.unwrap​(Object obj)

如果需要，可以解开脚本对象镜像。

static Object[]

ScriptObjectMirror.unwrapArray​(Object[] args, Object homeGlobal)

如果需要，展开一组脚本对象镜像。

static Object[]

ScriptUtils.unwrapArray​(Object[] args)

如果需要，展开一组脚本对象镜像。

static Object

ScriptObjectMirror.wrap​(Object obj, Object homeGlobal)

如果需要，在给定对象上做一个脚本对象镜像。

static ScriptObjectMirror

ScriptUtils.wrap​(Object obj)

如果需要，在给定对象上做一个脚本对象镜像。

static Object[]

ScriptObjectMirror.wrapArray​(Object[] args, Object homeGlobal)

如果需要，将对象数组包装到脚本对象镜像中。

static Object[]

ScriptUtils.wrapArray​(Object[] args)

如果需要，将对象数组包装到脚本对象镜像中。

static Object

ScriptObjectMirror.wrapAsJSONCompatible​(Object obj, Object homeGlobal)

如果需要，在给定对象上做一个脚本对象镜像。

Method parameters in jdk.nashorn.api.scripting with type arguments of type Object

Modifier and Type

方法

描述

void

ScriptObjectMirror.putAll​(Map<? extends String,? extends Object> map)

Uses of Object in jdk.nashorn.api.tree

Subclasses of Object in jdk.nashorn.api.tree

Modifier and Type

Class

描述

class

SimpleTreeVisitorES5_1<R,P>

用于ECMAScript版本5.1的TreeVisitor的简单实现。

class

SimpleTreeVisitorES6<R,P>

对于ECMAScript版本6的TreeVisitor的简单实现。

class

UnknownTreeException

表示遇到了一种未知类型的树。

Methods in jdk.nashorn.api.tree that return Object

Modifier and Type

方法

描述

Object

UnknownTreeException.getArgument​()

返回附加参数。

Object

LiteralTree.getValue​()

返回此文字的值。

Constructors in jdk.nashorn.api.tree with parameters of type Object

Constructor

描述

UnknownTreeException​(树 t, Object p)

创建一个新的 UnknownTreeException 。

Uses of Object in jdk.net

Subclasses of Object in jdk.net

Modifier and Type

Class

描述

class

ExtendedSocketOptions

定义扩展套接字选项，超出StandardSocketOptions中定义的。

class

NetworkPermission

表示访问jdk.net包中定义的扩展网络功能的权限。

class

SocketFlow

表示平台特定套接字选项 ExtendedSocketOptions.SO_FLOW_SLA的服务级别属性。

class

Sockets

定义静态方法来设置和获取由SocketOption界面定义的套接字选项。

Uses of Object in jdk.security.jarsigner

Subclasses of Object in jdk.security.jarsigner

Modifier and Type

Class

描述

class

JarSigner

一个不可变的实用程序类来签名一个jar文件。

static class

JarSigner.Builder

一个可变的构建器类，可以从各种与签名相关的参数创建一个不可变的 JarSigner 。

class

JarSignerException

当 JarSigner.sign(java.util.zip.ZipFile, java.io.OutputStream)失败时抛出此异常。

Uses of Object in netscape.javascript

Subclasses of Object in netscape.javascript

Modifier and Type

Class

描述

class

JSException

在JavaScript引擎中引发异常时抛出。

class

JSObject

允许Java代码来操纵JavaScript对象。

Methods in netscape.javascript that return Object

Modifier and Type

方法

描述

abstract Object

JSObject.call​(String methodName, Object... args)

调用JavaScript方法。

abstract Object

JSObject.eval​(String s)

评估JavaScript表达式。

abstract Object

JSObject.getMember​(String name)

检索JavaScript对象的命名成员。

abstract Object

JSObject.getSlot​(int index)

检索JavaScript对象的索引成员。

Methods in netscape.javascript with parameters of type Object

Modifier and Type

方法

描述

abstract Object

JSObject.call​(String methodName, Object... args)

调用JavaScript方法。

abstract void

JSObject.setMember​(String name, Object value)

设置一个JavaScript对象的命名成员。

abstract void

JSObject.setSlot​(int index, Object value)

设置JavaScript对象的索引成员。

Uses of Object in org.ietf.jgss

Subclasses of Object in org.ietf.jgss

Modifier and Type

Class

描述

class

ChannelBinding

该类封装了主叫方提供的通道绑定信息的概念。

class

GSSException

发生GSS-API错误时会抛出此异常，包括任何机制特定的错误。

class

GSSManager

该类作为其他重要GSS-API类的工厂，并提供有关支持的机制的信息。

class

MessageProp

这是在每消息GSSContext方法中使用的实用程序类，用于传递每消息属性。

class

Oid

该类表示通用对象标识符（Oid）及其相关联的操作。

Methods in org.ietf.jgss with parameters of type Object

Modifier and Type

方法

描述

boolean

ChannelBinding.equals​(Object obj)

比较两个ChannelBinding实例。

boolean

GSSCredential.equals​(Object another)

测试此GSSCredential是否与提供的对象断言相同的实体。

boolean

GSSName.equals​(Object another)

与此相比 GSSName对象的另一个对象可能是 GSSName 。

boolean

Oid.equals​(Object other)

测试两个Oid对象是否表示相同的对象标识符值。

Uses of Object in org.omg.CORBA

Subclasses of Object in org.omg.CORBA

Modifier and Type

Class

描述

class

_IDLTypeStub

存根为 IDLType 。

class

_PolicyStub

存根为 Policy 。

class

ACTIVITY_COMPLETED

可以在任何访问Activity上下文的方法上引发 ACTIVITY_COMPLETED系统异常。

class

ACTIVITY_REQUIRED

对于需要活动上下文的任何方法，可能会引发 ACTIVITY_REQUIRED系统异常。

class

Any

作为可以在IDL或任何IDL原语类型中描述的任何数据的容器。

class

AnyHolder

持有人 Any 。

class

AnySeqHelper

助手 AnySeq 。

class

AnySeqHolder

持有人 AnySeq 。

class

BAD_CONTEXT

当客户端调用操作时抛出异常，但传递的上下文不包含操作所需的上下文值。

class

BAD_INV_ORDER

这个异常表示调用者以错误的顺序调用了操作。

class

BAD_OPERATION

当对象引用表示现有对象但该对象不支持被调用的操作时抛出异常。

class

BAD_PARAM

传递给调用的参数超出范围或以其他方式被视为非法时引发的异常。

class

BAD_QOS

当对象不能支持具有与其相关联的服务质量语义的调用参数所需的服务质量时，引发 BAD_QOS异常。

class

BAD_TYPECODE

当ORB遇到格式错误的代码（例如， TCKind值无效的类型代码）时抛出异常。

class

BooleanHolder

持有人 Boolean 。

class

BooleanSeqHelper

助手 BooleanSeq 。

class

BooleanSeqHolder

持有人 BooleanSeq 。

class

Bounds

当参数不在方法尝试访问的对象的合法范围内时抛出用户异常。

class

BoundsHelper

这个Helper类用于方便编组 Bounds 。

class

ByteHolder

持有人 Byte 。

class

CharHolder

持有人 Char 。

class

CharSeqHelper

助手 CharSeq 。

class

CharSeqHolder

持有人 CharSeq 。

class

CODESET_INCOMPATIBLE

无论客户端和服务器本机代码集之间无法进行有意义的通信，都会引发此异常。

class

COMM_FAILURE

在客户端发送请求后，服务器的回复已经返回到客户端之前，在进行中的通信丢失时发生异常。

class

CompletionStatus

指出当抛出 SystemException时方法是否已完成运行的对象。

class

CompletionStatusHelper

助手 CompletionStatus 。

class

Context

在 Request操作中使用的对象，用于指定在发送请求调用之前必须解析上下文字符串的上下文对象。

class

ContextList

包含表示属性名称的 String对象的可修改列表的对象。

class

CurrentHelper

助手 Current 。

class

CurrentHolder

持有人 Current 。

class

DATA_CONVERSION

如果ORB无法将封送的数据的表示形式转换为其本机表示形式，反之亦然，则会引发此异常。

class

DefinitionKind

提供用于标识Interface Repository对象类型的常量的类。

class

DefinitionKindHelper

助手 DefinitionKind 。

class

DoubleHolder

持有人 Double 。

class

DoubleSeqHelper

助手 DoubleSeq 。

class

DoubleSeqHolder

持有人 DoubleSeq 。

class

DynamicImplementation

已过时。
org.omg.CORBA.DynamicImplementation

class

Environment

用于 Request操作以使异常可用于客户端的异常的容器（持有者）。

class

ExceptionList

在 Request操作中使用的一个对象来描述方法可以抛出的异常。

class

FieldNameHelper

助手 FieldName 。

class

FixedHolder

持有人 Fixed 。

class

FloatHolder

持有人 Float 。

class

FloatSeqHelper

助手 FloatSeq 。

class

FloatSeqHolder

持有人 FloatSeq 。

class

FREE_MEM

ORB在尝试释放动态内存时失败，例如由于堆损坏或内存段被锁定而导致异常。

class

IdentifierHelper

助手 Identifier 。

class

IDLTypeHelper

助手 IDLType 。

class

IMP_LIMIT

此异常表示在ORB运行时间中超出了实施限制。

class

INITIALIZE

当ORB在其初始化期间遇到故障（例如无法获取网络资源或检测到配置错误）时抛出异常。

class

INTERNAL

此异常指示ORB中的内部故障，例如，如果ORB检测到其内部数据结构的损坏。

class

INTF_REPOS

当ORB无法到达接口存储库或检测到与接口存储库相关的某些其他故障时引发异常。

class

IntHolder

持有人 Int 。

class

INV_FLAG

当一个无效标志传递给一个操作时（例如创建一个DII请求）时抛出异常。

class

INV_IDENT

此异常表示IDL标识符在语法上无效。

class

INV_OBJREF

此异常表示对象引用在内部格式错误。

class

INV_POLICY

当由于 Policy覆盖不适用于特定调用而不能进行调用时，抛出标准异常。

class

INVALID_ACTIVITY

如果事务或活动在与其挂起的环境不同的上下文中恢复，则可能会在“活动”或“事务服务”恢复方法上引发 INVALID_ACTIVITY系统异常。

class

INVALID_TRANSACTION

当请求携带无效的事务上下文时抛出异常。

class

LocalObject

用作在Java语言映射中实现本地IDL接口的基类。

class

LongHolder

持有人 Long 。

class

LongLongSeqHelper

助手 LongLongSeq 。

class

LongLongSeqHolder

持有人 LongLongSeq 。

class

LongSeqHelper

助手 LongSeqHelper 。

class

LongSeqHolder

持有人 LongSeq 。

class

MARSHAL

来自网络的请求或回复在结构上是无效的。

class

NamedValue

DII和DSI中使用的对象来描述参数和返回值。

class

NameValuePair

将名称与作为IDL结构体的属性的值相关联，并在 DynStruct API中使用。

class

NameValuePairHelper

助手 NameValuePair 。

class

NO_IMPLEMENT

此异常表示即使已调用的操作存在（它具有IDL定义），也不存在该操作的实现。

class

NO_MEMORY

ORB运行时内存不足时抛出异常。

class

NO_PERMISSION

调用失败时引发异常，因为调用者的权限不足。

class

NO_RESOURCES

当ORB遇到一些一般资源限制时抛出异常。

class

NO_RESPONSE

如果客户端尝试检索延迟同步调用的结果，但该请求的响应尚不可用，则会引发此异常。

class

NVList

一个包含 NamedValue对象的可修改列表。

class

OBJ_ADAPTER

此异常通常表示管理不匹配，例如，服务器可能尝试以已经在使用的名称或对存储库未知的实现存储库注册自身。

class

OBJECT_NOT_EXIST

每当执行对被删除对象的调用时，就会引发异常。

class

ObjectHelper

class

ObjectHolder

持有人 Object 。

class

OctetSeqHelper

助手 OctetSeq 。

class

OctetSeqHolder

持有人 OctetSeq 。

class

ORB

一个为CORBA对象请求代理功能提供API的类。

class

ParameterMode

枚举参数的参数模式。

class

ParameterModeHelper

枚举参数的参数模式。

class

ParameterModeHolder

枚举参数的参数模式。

class

PERSIST_STORE

此异常表示持续存储故障，例如，无法建立数据库连接或数据库损坏。

class

PolicyError

发生策略错误时抛出的用户异常。

class

PolicyErrorCodeHelper

封装“策略”可能无效的原因。

class

PolicyErrorHelper

抛出指示参数值传递给 ORB.create_policy操作的问题。

class

PolicyErrorHolder

抛出指示参数值传递给 ORB.create_policy操作的问题。

class

PolicyHelper

助手 Policy 。

class

PolicyHolder

持有人 Policy 。

class

PolicyListHelper

助手 PolicyList 。

class

PolicyListHolder

持有人 PolicyList 。

class

PolicyTypeHelper

助手 PolicyType 。

class

Principal

已过时。
被CORBA弃用2.2。

class

PrincipalHolder

已过时。
被CORBA弃用2.2。

class

REBIND

REBIND上升时电流有效RebindPolicy，具有NO_REBIND或NO_RECONNECT的值和上一个绑定的对象引用在消息LocateReply具有状态OBJECT_FORWARD或状态为LOCATION_FORWARD一个应答消息的调用。

class

RepositoryIdHelper

助手 RepositoryId 。

class

Request

包含调用方法所需信息的对象。

class

ServerRequest

捕获动态骨架接口（DSI）请求的显式状态的对象。

class

ServiceDetail

表示ORB服务的对象：其 service_detail_type字段包含ORB服务的类型，其 service_detail字段包含ORB服务的描述。

class

ServiceDetailHelper

class

ServiceInformation

CORBA模块中的IDL结构，用于存储有关ORB实现中可用的CORBA服务的信息，并从 ORB.get_service_information获取。

class

ServiceInformationHelper

class

ServiceInformationHolder

持有人 ServiceInformation 。

class

SetOverrideType

CORBA 枚举标记 SET_OVERRIDE和 ADD_OVERRIDE ，指出策略是否应替换 Object的现有策略或添加到它们。

class

SetOverrideTypeHelper

助手 SetOverrideType 。

class

ShortHolder

持有人 Short 。

class

ShortSeqHelper

助手 ShortSeqHelper 。

class

ShortSeqHolder

持有人 ShortSeq 。

class

StringHolder

持有人 String 。

class

StringSeqHelper

一串字符串

class

StringSeqHolder

一串字符串

class

StringValueHelper

助手 StringValue 。

class

StructMember

描述了一种IDL的成员 struct在接口库，包括名称 struct构件，所述的类型 struct构件，和表示的IDL类型的typedef struct构件描述的 struct成员对象。

class

StructMemberHelper

助手 StructMember 。

class

SystemException

所有CORBA标准异常的根类。

class

TCKind

IDL枚举的Java映射 TCKind ，它指定了一个 TypeCode对象的种类。

class

TIMEOUT

TIMEOUT在没有交付和已经超过指定的生存时间段时被提出。

class

TRANSACTION_MODE

如果客户端ORB检测到IOR中的InvocationPolicy与所选择的调用路径（即，直接或路由调用）之间的不匹配，则会抛出CORBA TRANSACTION_MODE异常。

class

TRANSACTION_REQUIRED

异常表示请求携带一个空事务上下文，但需要一个活动事务。

class

TRANSACTION_ROLLEDBACK

与请求相关联的事务已经回滚或标记回滚时抛出异常。

class

TRANSACTION_UNAVAILABLE

由于ORB与事务服务的连接异常终止，所以ORB无法处理事务服务上下文时抛出CORBA TRANSACTION_UNAVAILABLE异常。

class

TRANSIENT

当ORB尝试到达对象并失败时抛出异常。

class

TypeCode

有关特定CORBA数据类型的信息的容器。

class

TypeCodeHolder

持有人 TypeCode 。

class

ULongLongSeqHelper

助手 ULongLongSeq 。

class

ULongLongSeqHolder

持有人 ULongLongSeq 。

class

ULongSeqHelper

助手 ULongSeq 。

class

ULongSeqHolder

持有人 ULongSeq 。

class

UnionMember

IDL联盟成员的Interface Repository中的描述。

class

UnionMemberHelper

助手 UnionMember 。

class

UNKNOWN

如果操作实现抛出非CORBA异常（例如特定于实现的编程语言的异常），或者操作引发不在操作的引用表达式中出现的用户异常，则会引发此异常。

class

UnknownUserException

包含服务器返回的用户异常的类。

class

UnknownUserExceptionHelper

助手 UnknownUserException 。

class

UnknownUserExceptionHolder

持有人 UnknownUserException 。

class

UserException

CORBA IDL定义用户异常的根类。

class

UShortSeqHelper

助手 UShortSeq 。

class

UShortSeqHolder

持有人 UShortSeq 。

class

ValueBaseHelper

class

ValueBaseHolder

持有人 ValueBase 。

class

ValueMember

在 value对象的成员的Interface Repository中的描述。

class

ValueMemberHelper

助手 ValueMember 。

class

VersionSpecHelper

助手 VersionSpec 。

class

VisibilityHelper

助手 Visibility 。

class

WCharSeqHelper

助手 WCharSeq 。

class

WCharSeqHolder

持有人 WCharSeq 。

class

WrongTransaction

CORBA WrongTransaction用户定义的异常。

class

WrongTransactionHelper

助手 WrongTransaction 。

class

WrongTransactionHolder

持有人 WrongTransaction 。

class

WStringSeqHelper

一系列WStrings

class

WStringSeqHolder

一系列WStrings

class

WStringValueHelper

org / omg / CORBA / WStringValueHelper.java由IDL到Java编译器（便携式）生成，从orb.idl版本“3.0”1999年5月31日22:27:30 GMT + 00：00类定义被修改，以符合以下OMG规范：ORB芯由CORBA 2.3.1所定义（ formal/99-10-07 ）IDL / Java语言映射中定义 ptc/00-01-08

Methods in org.omg.CORBA that return Object

Modifier and Type

方法

描述

Object

DataInputStream.read_Abstract​()

从输入流读取IDL抽象界面。

Methods in org.omg.CORBA with parameters of type Object

Modifier and Type

方法

描述

void

DataOutputStream.write_Abstract​(Object value)

将IDL抽象接口类型写入输出流。

Uses of Object in org.omg.CORBA_2_3

Subclasses of Object in org.omg.CORBA_2_3

Modifier and Type

Class

描述

class

ORB

一个扩展 org.omg.CORBA.ORB的类，使ORB可移植到OMG CORBA 2.3版规范之下。

Methods in org.omg.CORBA_2_3 with parameters of type Object

Modifier and Type

方法

描述

void

ORB.set_delegate​(Object wrapper)

Uses of Object in org.omg.CORBA_2_3.portable

Subclasses of Object in org.omg.CORBA_2_3.portable

Modifier and Type

Class

描述

class

Delegate

代理类提供ORB供应商具体实现CORBA对象。

class

InputStream

InputStream提供从流中读取所有映射的IDL类型。

class

ObjectImpl

ObjectImpl类是所有存根的基类。

class

OutputStream

OutputStream提供了将所有映射的IDL类型写入流的接口。

Methods in org.omg.CORBA_2_3.portable that return Object

Modifier and Type

方法

描述

Object

InputStream.read_abstract_interface​()

解组数值对象或合适的存根对象。

Object

InputStream.read_abstract_interface​(Class clz)

解组对应于传递类型的类对象或存根类。

Methods in org.omg.CORBA_2_3.portable with parameters of type Object

Modifier and Type

方法

描述

void

OutputStream.write_abstract_interface​(Object obj)

汇总值对象或存根对象。

Uses of Object in org.omg.CORBA.DynAnyPackage

Subclasses of Object in org.omg.CORBA.DynAnyPackage

Modifier and Type

Class

描述

class

Invalid

当传递错误的 DynAny或 Any作为参数时，动态的任何操作都会抛出无效。

class

InvalidSeq

InvalidSeq异常被所有操作抛出，在动态任务中，当序列无效时，它将一个序列（Java数组）作为参数。

class

InvalidValue

class

TypeMismatch

当实际内容的类型与尝试访问的内容不匹配时，TypeMismatch将被动态的任何访问器方法抛出。

Uses of Object in org.omg.CORBA.ORBPackage

Subclasses of Object in org.omg.CORBA.ORBPackage

Modifier and Type

Class

描述

class

InconsistentTypeCode

当尝试创建一个类型代码与 DynAny的特定子类不匹配的动态任务时，会抛出 DynAny 。

class

InvalidName

InvalidName异常在 ORB.resolve_initial_references传递了一个没有初始引用的名称时 ORB.resolve_initial_references 。

class

InvalidNameHelper

这个Helper类用于方便编组 ORBPackage/InvalidName 。

Uses of Object in org.omg.CORBA.portable

Subclasses of Object in org.omg.CORBA.portable

Modifier and Type

Class

描述

class

ApplicationException

此类用于报告ORB和存根之间的应用程序级异常。

class

Delegate

指定用于ORB特定于org.omg.CORBA.Object方法的ORB特定于实现的便携式API。

class

IndirectionException

间接异常是一个Java特定的系统异常。

class

InputStream

InputStream是用于从CDR元数据流读取IDL类型的Java API。

class

ObjectImpl

所有存根类的公共基类; 提供org.omg.CORBA.Object方法的默认实现。

class

OutputStream

OuputStream是用于将IDL类型写入CDR元数据流的Java API。

class

RemarshalException

该类用于将向前的异常和对象前向GIOP消息定位回ORB。

class

ServantObject

该类是本地存根API的一部分，其目的是为并置的客户端和服务器（即驻留在同一Java VM中的客户端和服务器）提供高性能调用。

class

UnknownException

org.omg.CORBA.portable.UnknownException用于报告关系和ORB之间以及ORB和存根之间的未知异常。

Fields in org.omg.CORBA.portable declared as Object

Modifier and Type

Field

描述

Object

ServantObject.servant

真正的仆人。

Methods in org.omg.CORBA.portable with parameters of type Object

Modifier and Type

方法

描述

boolean

Delegate.equals​(Object self, Object obj)

提供实现来覆盖委托CORBA对象的equals（java.lang.Object obj）方法。

boolean

ObjectImpl.equals​(Object obj)

将此 ObjectImpl对象与给定的对象进行比较以获得相等性。

Uses of Object in org.omg.CORBA.TypeCodePackage

Subclasses of Object in org.omg.CORBA.TypeCodePackage

Modifier and Type

Class

描述

class

BadKind

当对 TypeCode对象调用不正确的操作时，抛出异常 BadKind 。

class

BadKindHelper

这个Helper类用于方便编组 TypeCodePackage/BadKind 。

class

Bounds

提供 TypeCode操作 member_name() ， member_type() ，并 member_label 。

class

BoundsHelper

这个Helper类用于方便编组 TypeCodePackage/Bounds 。

Uses of Object in org.omg.CosNaming

Subclasses of Object in org.omg.CosNaming

Modifier and Type

Class

描述

class

_BindingIteratorImplBase

class

_BindingIteratorStub

BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。

class

_NamingContextExtStub

NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。

class

_NamingContextImplBase

class

_NamingContextStub

命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。

class

Binding

org / omg / CosNaming / Binding.java。

class

BindingHelper

org / omg / CosNaming / BindingHelper.java。

class

BindingHolder

org / omg / CosNaming / BindingHolder.java。

class

BindingIteratorHelper

BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。

class

BindingIteratorHolder

BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。

class

BindingIteratorPOA

BindingIterator接口允许客户端使用next_one或next_n操作来迭代绑定。

class

BindingListHelper

绑定清单。

class

BindingListHolder

绑定清单。

class

BindingType

指定给定的绑定是针对对象（不是命名上下文）还是用于命名上下文。

class

BindingTypeHelper

指定给定的绑定是针对对象（不是命名上下文）还是用于命名上下文。

class

BindingTypeHolder

指定给定的绑定是针对对象（不是命名上下文）还是用于命名上下文。

class

IstringHelper

org / omg / CosNaming / IstringHelper.java。

class

NameComponent

org / omg / CosNaming / NameComponent.java。

class

NameComponentHelper

org / omg / CosNaming / NameComponentHelper.java。

class

NameComponentHolder

org / omg / CosNaming / NameComponentHolder.java。

class

NameHelper

名称是名称组件的序列。

class

NameHolder

名称是名称组件的序列。

class

NamingContextExtHelper

NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。

class

NamingContextExtHolder

NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。

class

NamingContextExtPOA

NamingContextExt是延长 NamingContext其含有一组名称的绑定，其中每个名字是唯一的并且是可互操作的命名服务的一部分。

class

NamingContextHelper

命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。

class

NamingContextHolder

命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。

class

NamingContextPOA

命名上下文是一个包含一组名称绑定的对象，其中每个名称都是唯一的。

Uses of Object in org.omg.CosNaming.NamingContextExtPackage

Subclasses of Object in org.omg.CosNaming.NamingContextExtPackage

Modifier and Type

Class

描述

class

AddressHelper

地址是以字符串表示的主机和端口信息。

class

InvalidAddress

org / omg / CosNaming / NamingContextExtPackage / InvalidAddress.java。

class

InvalidAddressHelper

org / omg / CosNaming / NamingContextExtPackage / InvalidAddressHelper.java。

class

InvalidAddressHolder

org / omg / CosNaming / NamingContextExtPackage / InvalidAddressHolder.java。

class

StringNameHelper

StringName是字符串名称，名称组件的数组表示为字符串。

class

URLStringHelper

URLString是以String形式表示的URL地址（corbaloc：或corbaname :)。

Uses of Object in org.omg.CosNaming.NamingContextPackage

Subclasses of Object in org.omg.CosNaming.NamingContextPackage

Modifier and Type

Class

描述

class

AlreadyBound

org / omg / CosNaming / NamingContextPackage / AlreadyBound.java。

class

AlreadyBoundHelper

org / omg / CosNaming / NamingContextPackage / AlreadyBoundHelper.java。

class

AlreadyBoundHolder

org / omg / CosNaming / NamingContextPackage / AlreadyBoundHolder.java。

class

CannotProceed

org / omg / CosNaming / NamingContextPackage / CannotProceed.java。

class

CannotProceedHelper

org / omg / CosNaming / NamingContextPackage / CannotProceedHelper.java。

class

CannotProceedHolder

org / omg / CosNaming / NamingContextPackage / CannotProceedHolder.java。

class

InvalidName

org / omg / CosNaming / NamingContextPackage / InvalidName.java。

class

InvalidNameHelper

org / omg / CosNaming / NamingContextPackage / InvalidNameHelper.java。

class

InvalidNameHolder

org / omg / CosNaming / NamingContextPackage / InvalidNameHolder.java。

class

NotEmpty

org / omg / CosNaming / NamingContextPackage / NotEmpty.java。

class

NotEmptyHelper

org / omg / CosNaming / NamingContextPackage / NotEmptyHelper.java。

class

NotEmptyHolder

org / omg / CosNaming / NamingContextPackage / NotEmptyHolder.java。

class

NotFound

org / omg / CosNaming / NamingContextPackage / NotFound.java。

class

NotFoundHelper

org / omg / CosNaming / NamingContextPackage / NotFoundHelper.java。

class

NotFoundHolder

org / omg / CosNaming / NamingContextPackage / NotFoundHolder.java。

class

NotFoundReason

表示无法解决的原因。

class

NotFoundReasonHelper

表示无法解决的原因。

class

NotFoundReasonHolder

表示无法解决的原因。

Uses of Object in org.omg.Dynamic

Subclasses of Object in org.omg.Dynamic

Modifier and Type

Class

描述

class

Parameter

org / omg / Dynamic / Parameter.java。

Uses of Object in org.omg.DynamicAny

Subclasses of Object in org.omg.DynamicAny

Modifier and Type

Class

描述

class

_DynAnyFactoryStub

可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。

class

_DynAnyStub

任何值都可以动态解释（遍历）并通过DynAny对象构造。

class

_DynArrayStub

DynArray对象支持IDL数组的操作。

class

_DynEnumStub

DynEnum对象支持对IDL枚举值的操作。

class

_DynFixedStub

DynFixed对象支持IDL固定值的操作。

class

_DynSequenceStub

DynSequence对象支持IDL序列的操作。

class

_DynStructStub

DynStruct对象支持IDL结构和异常值的操作。

class

_DynUnionStub

DynUnion对象支持IDL联盟的操纵。

class

_DynValueStub

DynValue对象支持IDL非盒装值类型的操作。

class

AnySeqHelper

org / omg / DynamicAny / AnySeqHelper.java。

class

DynAnyFactoryHelper

可以通过调用DynAnyFactory对象上的操作来创建DynAny对象。

class

DynAnyHelper

任何值都可以动态解释（遍历）并通过DynAny对象构造。

class

DynAnySeqHelper

org / omg / DynamicAny / DynAnySeqHelper.java。

class

DynArrayHelper

DynArray对象支持IDL数组的操作。

class

DynEnumHelper

DynEnum对象支持对IDL枚举值的操作。

class

DynFixedHelper

DynFixed对象支持IDL固定值的操作。

class

DynSequenceHelper

DynSequence对象支持IDL序列的操作。

class

DynStructHelper

DynStruct对象支持IDL结构和异常值的操作。

class

DynUnionHelper

DynUnion对象支持IDL联盟的操纵。

class

DynValueHelper

DynValue对象支持IDL非盒装值类型的操作。

class

FieldNameHelper

org / omg / DynamicAny / FieldNameHelper.java。

class

NameDynAnyPair

org / omg / DynamicAny / NameDynAnyPair.java。

class

NameDynAnyPairHelper

org / omg / DynamicAny / NameDynAnyPairHelper.java。

class

NameDynAnyPairSeqHelper

org / omg / DynamicAny / NameDynAnyPairSeqHelper.java。

class

NameValuePair

org / omg / DynamicAny / NameValuePair.java。

class

NameValuePairHelper

org / omg / DynamicAny / NameValuePairHelper.java。

class

NameValuePairSeqHelper

org / omg / DynamicAny / NameValuePairSeqHelper.java。

Uses of Object in org.omg.DynamicAny.DynAnyFactoryPackage

Subclasses of Object in org.omg.DynamicAny.DynAnyFactoryPackage

Modifier and Type

Class

描述

class

InconsistentTypeCode

org / omg / DynamicAny / DynAnyFactoryPackage / InconsistentTypeCode.java。

class

InconsistentTypeCodeHelper

org / omg / DynamicAny / DynAnyFactoryPackage / InconsistentTypeCodeHelper.java。

Uses of Object in org.omg.DynamicAny.DynAnyPackage

Subclasses of Object in org.omg.DynamicAny.DynAnyPackage

Modifier and Type

Class

描述

class

InvalidValue

org / omg / DynamicAny / DynAnyPackage / InvalidValue.java。

class

InvalidValueHelper

org / omg / DynamicAny / DynAnyPackage / InvalidValueHelper.java。

class

TypeMismatch

org / omg / DynamicAny / DynAnyPackage / TypeMismatch.java。

class

TypeMismatchHelper

org / omg / DynamicAny / DynAnyPackage / TypeMismatchHelper.java。

Uses of Object in org.omg.IOP

Subclasses of Object in org.omg.IOP

Modifier and Type

Class

描述

class

CodecFactoryHelper

Codecs是从 CodecFactory获得的。

class

ComponentIdHelper

表示多组件配置文件的标准方式。

class

Encoding

org / omg / IOP / Encoding.java。

class

IOR

org / omg / IOP / IOR.java。

class

IORHelper

org / omg / IOP / IORHelper.java。

class

IORHolder

org / omg / IOP / IORHolder.java。

class

MultipleComponentProfileHelper

一组标记的组件，形成一个多组件配置文件。

class

MultipleComponentProfileHolder

一组标记的组件，形成一个多组件配置文件。

class

ProfileIdHelper

个人资料ID

class

ServiceContext

org / omg / IOP / ServiceContext.java。

class

ServiceContextHelper

org / omg / IOP / ServiceContextHelper.java。

class

ServiceContextHolder

org / omg / IOP / ServiceContextHolder.java。

class

ServiceContextListHelper

一组服务上下文，形成一个服务上下文列表。

class

ServiceContextListHolder

一组服务上下文，形成一个服务上下文列表。

class

ServiceIdHelper

一个服务ID，表示为int

class

TaggedComponent

org / omg / IOP / TaggedComponent.java。

class

TaggedComponentHelper

org / omg / IOP / TaggedComponentHelper.java。

class

TaggedComponentHolder

org / omg / IOP / TaggedComponentHolder.java。

class

TaggedProfile

org / omg / IOP / TaggedProfile.java。

class

TaggedProfileHelper

org / omg / IOP / TaggedProfileHelper.java。

class

TaggedProfileHolder

org / omg / IOP / TaggedProfileHolder.java。

Uses of Object in org.omg.IOP.CodecFactoryPackage

Subclasses of Object in org.omg.IOP.CodecFactoryPackage

Modifier and Type

Class

描述

class

UnknownEncoding

org / omg / IOP / CodecFactoryPackage / UnknownEncoding.java。

class

UnknownEncodingHelper

org / omg / IOP / CodecFactoryPackage / UnknownEncodingHelper.java。

Uses of Object in org.omg.IOP.CodecPackage

Subclasses of Object in org.omg.IOP.CodecPackage

Modifier and Type

Class

描述

class

FormatMismatch

org / omg / IOP / CodecPackage / FormatMismatch.java。

class

FormatMismatchHelper

org / omg / IOP / CodecPackage / FormatMismatchHelper.java。

class

InvalidTypeForEncoding

org / omg / IOP / CodecPackage / InvalidTypeForEncoding.java。

class

InvalidTypeForEncodingHelper

org / omg / IOP / CodecPackage / InvalidTypeForEncodingHelper.java。

class

TypeMismatch

org / omg / IOP / CodecPackage / TypeMismatch.java。

class

TypeMismatchHelper

org / omg / IOP / CodecPackage / TypeMismatchHelper.java。

Uses of Object in org.omg.Messaging

Subclasses of Object in org.omg.Messaging

Modifier and Type

Class

描述

class

SyncScopeHelper

同步范围

Uses of Object in org.omg.PortableInterceptor

Subclasses of Object in org.omg.PortableInterceptor

Modifier and Type

Class

描述

class

AdapterManagerIdHelper

适配器管理标识符

class

AdapterNameHelper

对象适配器的名称。

class

AdapterStateHelper

对象适配器状态的类型。

class

CurrentHelper

便携式拦截器当前（也称为 PICurrent ）仅仅是一个时隙表，每个服务的时隙表都用于在其上下文和请求或应答的服务上下文之间传送其上下文数据。

class

ForwardRequest

org / omg / PortableInterceptor / ForwardRequest.java。

class

ForwardRequestHelper

org / omg / PortableInterceptor / ForwardRequestHelper.java。

class

InvalidSlot

org / omg / PortableInterceptor / InvalidSlot.java。

class

InvalidSlotHelper

org / omg / PortableInterceptor / InvalidSlotHelper.java。

class

IORInterceptor_3_0Helper

org / omg / PortableInterceptor / IORInterceptor_3_0Helper.java。

class

IORInterceptor_3_0Holder

org / omg / PortableInterceptor / IORInterceptor_3_0Holder.java。

class

ObjectIdHelper

对象ID的类型。

class

ObjectReferenceFactoryHelper

对象引用工厂。

class

ObjectReferenceFactoryHolder

对象引用工厂。

class

ObjectReferenceTemplateHelper

对象引用模板。

class

ObjectReferenceTemplateHolder

对象引用模板。

class

ObjectReferenceTemplateSeqHelper

对象引用模板的序列用于报告适配器管理器上不发生的状态更改。

class

ObjectReferenceTemplateSeqHolder

对象引用模板的序列用于报告适配器管理器上不发生的状态更改。

class

ORBIdHelper

org / omg / PortableInterceptor / ORBIdHelper.java。

class

ServerIdHelper

org / omg / PortableInterceptor / ServerIdHelper.java。

Uses of Object in org.omg.PortableInterceptor.ORBInitInfoPackage

Subclasses of Object in org.omg.PortableInterceptor.ORBInitInfoPackage

Modifier and Type

Class

描述

class

DuplicateName

org / omg / PortableInterceptor / ORBInitInfoPackage / DuplicateName.java。

class

DuplicateNameHelper

org / omg / PortableInterceptor / ORBInitInfoPackage / DuplicateNameHelper.java。

class

InvalidName

org / omg / PortableInterceptor / ORBInitInfoPackage / InvalidName.java。

class

InvalidNameHelper

org / omg / PortableInterceptor / ORBInitInfoPackage / InvalidNameHelper.java。

class

ObjectIdHelper

对象标识，表示为字符串

Uses of Object in org.omg.PortableServer

Subclasses of Object in org.omg.PortableServer

Modifier and Type

Class

描述

class

_ServantActivatorStub

当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。

class

_ServantLocatorStub

当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。

class

CurrentHelper

从CORBA :: Current派生的PortableServer :: Current接口提供了访问方法被调用的对象的身份的方法实现。

class

DynamicImplementation

允许动态处理对象调用。

class

ForwardRequest

org / omg / PortableServer / ForwardRequest.java。

class

ForwardRequestHelper

org / omg / PortableServer / ForwardRequestHelper.java。

class

IdAssignmentPolicyValue

IdAssignmentPolicyValue可以具有以下值。

class

IdUniquenessPolicyValue

IdUniquenessPolicyValue可以具有以下值。

class

ImplicitActivationPolicyValue

ImplicitActivationPolicyValue具有以下语义。

class

LifespanPolicyValue

LifespanPolicyValue可以具有以下值。

class

POAHelper

POA对象管理对象集合的实现。

class

RequestProcessingPolicyValue

RequestProcessingPolicyValue可以具有以下值。

class

Servant

定义本机 Servant类型。

class

ServantActivatorHelper

当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。

class

ServantActivatorPOA

当POA具有RETAIN策略时，它使用ServantActivator的仆人管理器。

class

ServantLocatorHelper

当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。

class

ServantLocatorPOA

当POA具有NON_RETAIN策略时，它使用ServantLocator的servant管理器。

class

ServantRetentionPolicyValue

ServantRetentionPolicyValue可以具有以下值。

class

ThreadPolicyValue

ThreadPolicyValue可以具有以下值。

Methods in org.omg.PortableServer with parameters of type Object

Modifier and Type

方法

描述

void

_ServantLocatorStub.postinvoke​(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)

在服务器完成请求时调用此操作。

void

ServantLocatorOperations.postinvoke​(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)

在服务器完成请求时调用此操作。

Uses of Object in org.omg.PortableServer.CurrentPackage

Subclasses of Object in org.omg.PortableServer.CurrentPackage

Modifier and Type

Class

描述

class

NoContext

org / omg / PortableServer / CurrentPackage / NoContext.java。

class

NoContextHelper

org / omg / PortableServer / CurrentPackage / NoContextHelper.java。

Uses of Object in org.omg.PortableServer.POAManagerPackage

Subclasses of Object in org.omg.PortableServer.POAManagerPackage

Modifier and Type

Class

描述

class

AdapterInactive

org / omg / PortableServer / POAManagerPackage / AdapterInactive.java。

class

AdapterInactiveHelper

org / omg / PortableServer / POAManagerPackage / AdapterInactiveHelper.java。

class

State

指定POAManager的状态

Uses of Object in org.omg.PortableServer.POAPackage

Subclasses of Object in org.omg.PortableServer.POAPackage

Modifier and Type

Class

描述

class

AdapterAlreadyExists

org / omg / PortableServer / POAPackage / AdapterAlreadyExists.java。

class

AdapterAlreadyExistsHelper

org / omg / PortableServer / POAPackage / AdapterAlreadyExistsHelper.java。

class

AdapterNonExistent

org / omg / PortableServer / POAPackage / AdapterNonExistent.java。

class

AdapterNonExistentHelper

org / omg / PortableServer / POAPackage / AdapterNonExistentHelper.java。

class

InvalidPolicy

org / omg / PortableServer / POAPackage / InvalidPolicy.java。

class

InvalidPolicyHelper

org / omg / PortableServer / POAPackage / InvalidPolicyHelper.java。

class

NoServant

org / omg / PortableServer / POAPackage / NoServant.java。

class

NoServantHelper

org / omg / PortableServer / POAPackage / NoServantHelper.java。

class

ObjectAlreadyActive

org / omg / PortableServer / POAPackage / ObjectAlreadyActive.java。

class

ObjectAlreadyActiveHelper

org / omg / PortableServer / POAPackage / ObjectAlreadyActiveHelper.java。

class

ObjectNotActive

org / omg / PortableServer / POAPackage / ObjectNotActive.java。

class

ObjectNotActiveHelper

org / omg / PortableServer / POAPackage / ObjectNotActiveHelper.java。

class

ServantAlreadyActive

org / omg / PortableServer / POAPackage / ServantAlreadyActive.java。

class

ServantAlreadyActiveHelper

org / omg / PortableServer / POAPackage / ServantAlreadyActiveHelper.java。

class

ServantNotActive

org / omg / PortableServer / POAPackage / ServantNotActive.java。

class

ServantNotActiveHelper

org / omg / PortableServer / POAPackage / ServantNotActiveHelper.java。

class

WrongAdapter

org / omg / PortableServer / POAPackage / WrongAdapter.java。

class

WrongAdapterHelper

org / omg / PortableServer / POAPackage / WrongAdapterHelper.java。

class

WrongPolicy

org / omg / PortableServer / POAPackage / WrongPolicy.java。

class

WrongPolicyHelper

org / omg / PortableServer / POAPackage / WrongPolicyHelper.java。

Uses of Object in org.omg.PortableServer.ServantLocatorPackage

Subclasses of Object in org.omg.PortableServer.ServantLocatorPackage

Modifier and Type

Class

描述

class

CookieHolder

PortableServer :: ServantLocator :: Cookie的本机类型映射到java.lang.Object。

Fields in org.omg.PortableServer.ServantLocatorPackage declared as Object

Modifier and Type

Field

描述

Object

CookieHolder.value

Constructors in org.omg.PortableServer.ServantLocatorPackage with parameters of type Object

Constructor

描述

CookieHolder​(Object initial)

Uses of Object in org.omg.stub.java.rmi

Subclasses of Object in org.omg.stub.java.rmi

Modifier and Type

Class

描述

class

_Remote_Stub

该类提供了远程类型的存根。

Uses of Object in org.w3c.dom

Subclasses of Object in org.w3c.dom

Modifier and Type

Class

描述

class

DOMException

DOM操作只会在“异常”情况下引发异常，即当操作无法执行时（出于逻辑原因，因为数据丢失，或者由于实现变得不稳定））。

Methods in org.w3c.dom that return Object

Modifier and Type

方法

描述

Object

DOMImplementation.getFeature​(String feature, String version)

此方法返回一个专门的对象，它实现了特定功能和版本的专门API，如 DOM Features所述 。

Object

Node.getFeature​(String feature, String version)

该方法返回一个专门的对象，该对象实现指定的特征和版本的专门API，如

Object

DOMConfiguration.getParameter​(String name)

如果已知，返回参数的值。

Object

DOMError.getRelatedData​()

相关数据相关的 DOMError.type如有。

Object

DOMError.getRelatedException​()

相关的平台依赖异常如果有的话。

Object

Node.getUserData​(String key)

检索与该节点上的键相关联的对象。

Object

Node.setUserData​(String key, Object data, UserDataHandler handler)

将对象与此节点上的键相关联。

Methods in org.w3c.dom with parameters of type Object

Modifier and Type

方法

描述

boolean

DOMConfiguration.canSetParameter​(String name, Object value)

检查是否将参数设置为特定值。

void

UserDataHandler.handle​(short operation, String key, Object data, Node src, Node dst)

每当注册此处理程序的节点被导入或克隆时，都会调用此方法。

void

DOMConfiguration.setParameter​(String name, Object value)

设置参数的值。

Object

Node.setUserData​(String key, Object data, UserDataHandler handler)

将对象与此节点上的键相关联。

Uses of Object in org.w3c.dom.bootstrap

Subclasses of Object in org.w3c.dom.bootstrap

Modifier and Type

Class

描述

class

DOMImplementationRegistry

一个允许应用程序获取 DOMImplementation实例的 DOMImplementation 。

Uses of Object in org.w3c.dom.events

Subclasses of Object in org.w3c.dom.events

Modifier and Type

Class

描述

class

EventException

事件操作可能会 EventException其方法描述中指定的 EventException 。

Uses of Object in org.w3c.dom.ls

Subclasses of Object in org.w3c.dom.ls

Modifier and Type

Class

描述

class

LSException

如果处理停止，解析器或写入操作可能会抛出 LSException 。

Uses of Object in org.w3c.dom.ranges

Subclasses of Object in org.w3c.dom.ranges

Modifier and Type

Class

描述

class

RangeException

范围操作可能会抛出其方法说明中指定的 RangeException 。

Uses of Object in org.w3c.dom.xpath

Subclasses of Object in org.w3c.dom.xpath

Modifier and Type

Class

描述

class

XPathException

为这些XPath接口特定的异常创建了一个新的异常。

Methods in org.w3c.dom.xpath that return Object

Modifier and Type

方法

描述

Object

XPathEvaluator.evaluate​(String expression, Node contextNode, XPathNSResolver resolver, short type, Object result)

评估XPath表达式字符串，如果可能，返回指定类型的结果。

Object

XPathExpression.evaluate​(Node contextNode, short type, Object result)

评估此XPath表达式并返回结果。

Methods in org.w3c.dom.xpath with parameters of type Object

Modifier and Type

方法

描述

Object

XPathEvaluator.evaluate​(String expression, Node contextNode, XPathNSResolver resolver, short type, Object result)

评估XPath表达式字符串，如果可能，返回指定类型的结果。

Object

XPathExpression.evaluate​(Node contextNode, short type, Object result)

评估此XPath表达式并返回结果。

Uses of Object in org.xml.sax

Subclasses of Object in org.xml.sax

Modifier and Type

Class

描述

class

HandlerBase

已过时。
此类与已弃用的DocumentHandler接口配合使用。 它已被SAX2 DefaultHandler类替代。

class

InputSource

XML实体的单一输入源。

class

SAXException

封装一般的SAX错误或警告。

class

SAXNotRecognizedException

无法识别的标识符的异常类。

class

SAXNotSupportedException

不受支持的操作的异常类。

class

SAXParseException

封装XML解析错误或警告。

Methods in org.xml.sax that return Object

Modifier and Type

方法

描述

Object

XMLReader.getProperty​(String name)

查找属性的值。

Methods in org.xml.sax with parameters of type Object

Modifier and Type

方法

描述

void

XMLReader.setProperty​(String name, Object value)

设置属性的值。

Uses of Object in org.xml.sax.ext

Subclasses of Object in org.xml.sax.ext

Modifier and Type

Class

描述

class

Attributes2Impl

SAX2扩展助手附加属性信息，实现Attributes2界面。

class

DefaultHandler2

此类扩展SAX2基本处理程序类，以支持SAX2 LexicalHandler ， DeclHandler ，并EntityResolver2扩展。

class

Locator2Impl

SAX2扩展助手用于保存附加实体信息，实现Locator2接口。

Uses of Object in org.xml.sax.helpers

Subclasses of Object in org.xml.sax.helpers

Modifier and Type

Class

描述

class

AttributeListImpl

已过时。
这个类实现了一个不推荐的接口， AttributeList ; 该接口已被替换为Attributes ，它是在AttributesImpl帮助类中实现的。

class

AttributesImpl

属性界面的默认实现。

class

DefaultHandler

SAX2事件处理程序的默认基类。

class

LocatorImpl

提供Locator的可选便利实现。

class

NamespaceSupport

封装使用SAX的应用程序或由SAX驱动程序内部使用的命名空间逻辑。

class

ParserAdapter

将SAX1解析器调整为SAX2 XMLReader。

class

ParserFactory

已过时。
该类与已弃用的Parser接口配合使用。

class

XMLFilterImpl

用于导出XML过滤器的基类。

class

XMLReaderAdapter

将SAX2 XMLReader修改为SAX1解析器。

class

XMLReaderFactory

已过时。
建议使用SAXParserFactory 。

Methods in org.xml.sax.helpers that return Object

Modifier and Type

方法

描述

Object

ParserAdapter.getProperty​(String name)

获取解析器属性。

Object

XMLFilterImpl.getProperty​(String name)

查找属性的值。

Methods in org.xml.sax.helpers with parameters of type Object

Modifier and Type

方法

描述

void

ParserAdapter.setProperty​(String name, Object value)

设置解析器属性。

void

XMLFilterImpl.setProperty​(String name, Object value)

设置属性的值。

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev

Next

框架

无框架

所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.OutOfMemoryError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.OutOfMemoryError

No usage of java.lang.OutOfMemoryError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Override (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev

Next

框架

无框架

所有类

SEARCH:

Uses of Class
java.lang.Override

Packages that use Override

软件包

描述

com.sun.nio.sctp

用于流控制传输协议的Java API。

com.sun.security.auth

提供Principal的实现。

com.sun.security.auth.login

提供Configuration的实现。

com.sun.source.util

为抽象语法树（AST）的操作提供实用程序。

java.applet

提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。

java.awt

包含用于创建用户界面和绘制图形和图像的所有类。

java.awt.datatransfer

提供用于在应用程序之间和之间传输数据的接口和类。

java.awt.image

提供创建和修改图像的类。

java.beans

包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

java.io

通过数据流，序列化和文件系统提供系统输入和输出。

java.lang

提供对Java编程语言设计至关重要的类。

java.lang.invoke

java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

java.lang.module

通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

java.lang.reflect

提供用于获取关于类和对象的反射信息的类和接口。

java.math

提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。

java.net

提供实现网络应用程序的类。

java.nio

定义缓冲区，它们是数据容器，并提供其他NIO包的概述。

java.nio.channels

定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

java.nio.file

定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

java.nio.file.attribute

提供访问文件和文件系统属性的接口和类。

java.security

提供安全框架的类和接口。

java.security.cert

提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

java.sql

提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

java.text

提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

java.time

日期，时间，瞬间和持续时间的主要API。

java.time.chrono

除默认ISO之外的日历系统的通用API。

java.time.format

提供打印和解析日期和时间的类。

java.time.temporal

使用字段和单位访问日期和时间，以及日期时间调整器。

java.time.zone

支持时区及其规则。

java.util

包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

java.util.concurrent

实用程序类通常用于并发编程。

java.util.logging

提供Java¢2平台核心日志记录工具的类和接口。

java.util.spi

java.util包中类的服务提供者类。

java.util.stream

支持元素流功能性操作的类，例如集合上的map-reduce转换。

java.util.zip

提供读写标准ZIP和GZIP文件格式的类。

javafx.animation

提供一组类，便于使用基于过渡的动画。

javafx.application

提供应用程序生命周期类。

javafx.beans

包 javafx.beans包含定义最通用形式的可观察性的接口。

javafx.beans.binding

提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

javafx.beans.property

程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

javafx.beans.property.adapter

提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

javafx.beans.value

包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。

javafx.collections

包含基本的JavaFX集合和集合实用程序

javafx.collections.transformation

提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。

javafx.concurrent

提供javafx.task的一组类。

javafx.css

提供API，通过CSS使属性变得风格，并支持伪类状态。

javafx.css.converter

提供各种转换CSS解析值的StyleConverter类。

javafx.embed.swing

提供一组在Swing应用程序中使用JavaFX的类。

javafx.event

为FX事件，交付和处理提供基本框架。

javafx.fxml

包含用于从标记加载对象层次结构的类。

javafx.geometry

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

javafx.print

提供JavaFX Printing API的公共类。

javafx.scene

为JavaFX Scene Graph API提供核心的基类集。

javafx.scene.chart

JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

javafx.scene.control

JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

javafx.scene.control.cell

所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。

javafx.scene.control.skin

javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

javafx.scene.image

提供加载和显示图像的一组类。

javafx.scene.input

提供一组用于鼠标和键盘输入事件处理的类。

javafx.scene.layout

提供类来支持用户界面布局。

javafx.scene.media

提供用于将音频和视频集成到Java FX应用程序中的一组类。

javafx.scene.paint

提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

javafx.scene.shape

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

javafx.scene.text

为字体和可渲染的文本节点提供一组类。

javafx.scene.transform

提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。

javafx.scene.web

该软件包提供了加载和显示Web内容的方法。

javafx.stage

提供JavaFX内容的顶级容器类。

javafx.util

包含各种实用程序和助手类。

javafx.util.converter

此包用于JavaFX的标准字符串转换器。

javax.imageio.plugins.tiff

内置TIFF插件使用的公共类。

javax.lang.model.element

用于建模Java编程语言元素的接口。

javax.lang.model.util

协助处理 program elements及 types的公用事业 。

javax.management

提供Java管理扩展的核心类。

javax.management.modelmbean

提供ModelMBean类的定义。

javax.management.monitor

提供监视器类的定义。

javax.management.openmbean

提供打开的数据类型和Open MBean描述符类。

javax.management.relation

提供关系服务的定义。

javax.management.remote

用于远程访问JMX MBean服务器的接口。

javax.management.remote.rmi

RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

javax.net.ssl

为安全套接字包提供类。

javax.security.auth

此软件包提供了认证和授权的框架。

javax.security.auth.kerberos

此包包含与Kerberos网络身份验证协议相关的实用程序类。

javax.sound.midi

提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。

javax.sound.sampled

提供用于捕获，处理和播放采样音频数据的接口和类。

javax.sql

通过Java编程语言为服务器端数据源访问和处理提供API。

javax.swing

提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

javax.swing.border

提供用于绘制Swing组件周围特殊边框的类和接口。

javax.swing.event

提供Swing组件触发的事件。

javax.swing.plaf.basic

提供根据“基本”外观构建的用户界面对象。

javax.swing.plaf.metal

提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。

javax.swing.plaf.multi

提供组合两种或多种外观和感觉的用户界面对象。

javax.swing.plaf.nimbus

提供根据跨平台Nimbus外观构建的用户界面对象。

javax.swing.plaf.synth

合成是一种可以让所有绘画委托的外观和感觉。

javax.swing.table

提供处理 javax.swing.JTable类和接口。

javax.swing.text

提供处理可编辑和不可编辑文本组件的类和接口。

javax.tools

为可以从程序调用的工具提供接口，例如编译器。

javax.xml.bind

为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。

javax.xml.catalog

提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。

javax.xml.datatype

定义XML / Java类型映射。

javax.xml.parsers

提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。

javax.xml.soap

提供用于创建和构建SOAP消息的API。

javax.xml.stream

定义Streaming API for XML（StAX）的接口和类。

javax.xml.transform

定义用于处理转换指令的通用API，以及执行从源到结果的转换。

javax.xml.transform.dom

提供DOM特定的转换类。

javax.xml.transform.sax

提供SAX特定的转换类。

javax.xml.transform.stax

提供StAX特定的转换类。

javax.xml.transform.stream

提供流和URI特定的转换类。

javax.xml.ws

此软件包包含核心JAX-WS API。

javax.xml.ws.wsaddressing

此包定义与WS-Addressing相关的API。

javax.xml.xpath

提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。

jdk.dynalink

包含用于链接 invokedynamic呼叫站点的接口和类。

jdk.dynalink.beans

包含普通Java对象的链接器。

jdk.dynalink.linker.support

包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。

jdk.dynalink.support

包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。

jdk.incubator.http

高级HTTP和WebSocket API

jdk.javadoc.doclet

Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

jdk.jshell

提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

jdk.jshell.execution

提供构建JShell执行引擎的实现支持。

jdk.jshell.spi

定义可插拔JShell执行引擎的服务提供程序接口。

jdk.nashorn.api.scripting

这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

jdk.nashorn.api.tree

Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

jdk.net

针对 java.net和 java.nio.channels套接字类的平台特定套接字选项。

Uses of Override in com.sun.nio.sctp

Methods in com.sun.nio.sctp with annotations of type Override

Modifier and Type

方法

描述

abstract Association

SendFailedNotification.association​()

返回此通知适用的关联。

boolean

SctpStandardSocketOptions.InitMaxStreams.equals​(Object obj)

如果指定的对象是具有相同数量的进出流绑定流的另一个 InitMaxStreams实例，则返回true。

HandlerResult

AbstractNotificationHandler.handleNotification​(Notification notification, T attachment)

当从SCTP堆栈接收到实现特定通知时调用。

int

SctpStandardSocketOptions.InitMaxStreams.hashCode​()

返回此init数据流的哈希码值。

String

SctpStandardSocketOptions.InitMaxStreams.toString​()

返回此init最大流的字符串表示形式，包括最大输入和输出绑定流。

int

SctpChannel.validOps​()

返回确定此频道支持的操作的操作集。

int

SctpMultiChannel.validOps​()

返回确定此频道支持的操作的操作集。

int

SctpServerChannel.validOps​()

返回确定此频道支持的操作的操作集。

Uses of Override in com.sun.security.auth

Methods in com.sun.security.auth with annotations of type Override

Modifier and Type

方法

描述

PermissionCollection

PolicyFile.getPermissions​(Subject subject, CodeSource codesource)

不推荐用于删除：此API元素将在以后的版本中被删除。

检查此 Policy并返回授予给指定的 Subject和 CodeSource的权限。

void

PolicyFile.refresh​()

不推荐用于删除：此API元素将在以后的版本中被删除。

通过重新读取所有策略文件来刷新策略对象。

Uses of Override in com.sun.security.auth.login

Methods in com.sun.security.auth.login with annotations of type Override

Modifier and Type

方法

描述

AppConfigurationEntry[]

ConfigFile.getAppConfigurationEntry​(String applicationName)

使用应用程序名称作为索引从 Configuration检索条目。

void

ConfigFile.refresh​()

通过重新读取所有登录配置，刷新并重新加载 Configuration 。

Uses of Override in com.sun.source.util

Methods in com.sun.source.util with annotations of type Override

Modifier and Type

方法

描述

Iterator<DocTree>

DocTreePath.iterator​()

Iterator<树>

TreePath.iterator​()

从叶到叶重迭。

R

DocTreePathScanner.scan​(DocTree tree, P p)

扫描单个节点。

R

TreePathScanner.scan​(树 tree, P p)

扫描单个节点。

String

TaskEvent.toString​()

R

SimpleTreeVisitor.visitAnnotatedType​(AnnotatedTypeTree node, P p)

访问AnnotatedTypeTree节点。

R

TreeScanner.visitAnnotatedType​(AnnotatedTypeTree node, P p)

访问AnnotatedTypeTree节点。

R

SimpleTreeVisitor.visitAnnotation​(AnnotationTree node, P p)

访问AnnotatedTree节点。

R

TreeScanner.visitAnnotation​(AnnotationTree node, P p)

访问AnnotatedTree节点。

R

SimpleTreeVisitor.visitArrayAccess​(ArrayAccessTree node, P p)

访问ArrayAccessTree节点。

R

TreeScanner.visitArrayAccess​(ArrayAccessTree node, P p)

访问ArrayAccessTree节点。

R

SimpleTreeVisitor.visitArrayType​(ArrayTypeTree node, P p)

访问ArrayTypeTree节点。

R

TreeScanner.visitArrayType​(ArrayTypeTree node, P p)

访问ArrayTypeTree节点。

R

SimpleTreeVisitor.visitAssert​(AssertTree node, P p)

访问AssertTree节点。

R

TreeScanner.visitAssert​(AssertTree node, P p)

访问AssertTree节点。

R

SimpleTreeVisitor.visitAssignment​(AssignmentTree node, P p)

访问AssignmentTree节点。

R

TreeScanner.visitAssignment​(AssignmentTree node, P p)

访问AssignmentTree节点。

R

DocTreeScanner.visitAttribute​(AttributeTree node, P p)

访问AttributeTree节点。

R

SimpleDocTreeVisitor.visitAttribute​(AttributeTree node, P p)

访问AttributeTree节点。

R

DocTreeScanner.visitAuthor​(AuthorTree node, P p)

访问AuthorTree节点。

R

SimpleDocTreeVisitor.visitAuthor​(AuthorTree node, P p)

访问AuthorTree节点。

R

SimpleTreeVisitor.visitBinary​(BinaryTree node, P p)

访问二进制流节点。

R

TreeScanner.visitBinary​(BinaryTree node, P p)

访问二进制流节点。

R

SimpleTreeVisitor.visitBlock​(BlockTree node, P p)

访问BlockTree节点。

R

TreeScanner.visitBlock​(BlockTree node, P p)

访问BlockTree节点。

R

SimpleTreeVisitor.visitBreak​(BreakTree node, P p)

访问BreakTree节点。

R

TreeScanner.visitBreak​(BreakTree node, P p)

访问BreakTree节点。

R

SimpleTreeVisitor.visitCase​(CaseTree node, P p)

访问CaseTree节点。

R

TreeScanner.visitCase​(CaseTree node, P p)

访问CaseTree节点。

R

SimpleTreeVisitor.visitCatch​(CatchTree node, P p)

访问CatchTree节点。

R

TreeScanner.visitCatch​(CatchTree node, P p)

访问CatchTree节点。

R

SimpleTreeVisitor.visitClass​(ClassTree node, P p)

访问ClassTree节点。

R

TreeScanner.visitClass​(ClassTree node, P p)

访问ClassTree节点。

R

DocTreeScanner.visitComment​(CommentTree node, P p)

访问CommentTree节点。

R

SimpleDocTreeVisitor.visitComment​(CommentTree node, P p)

访问CommentTree节点。

R

SimpleTreeVisitor.visitCompilationUnit​(CompilationUnitTree node, P p)

访问CompilationUnitTree节点。

R

TreeScanner.visitCompilationUnit​(CompilationUnitTree node, P p)

访问CompilationUnitTree节点。

R

SimpleTreeVisitor.visitCompoundAssignment​(CompoundAssignmentTree node, P p)

访问一个CompoundAssignmentTree节点。

R

TreeScanner.visitCompoundAssignment​(CompoundAssignmentTree node, P p)

访问一个CompoundAssignmentTree节点。

R

SimpleTreeVisitor.visitConditionalExpression​(ConditionalExpressionTree node, P p)

访问一个ConditionalExpressionTree节点。

R

TreeScanner.visitConditionalExpression​(ConditionalExpressionTree node, P p)

访问一个ConditionalExpressionTree节点。

R

SimpleTreeVisitor.visitContinue​(ContinueTree node, P p)

访问ContinueTree节点。

R

TreeScanner.visitContinue​(ContinueTree node, P p)

访问ContinueTree节点。

R

DocTreeScanner.visitDeprecated​(DeprecatedTree node, P p)

访问DeprecatedTree节点。

R

SimpleDocTreeVisitor.visitDeprecated​(DeprecatedTree node, P p)

访问DeprecatedTree节点。

R

DocTreeScanner.visitDocComment​(DocCommentTree node, P p)

访问DocCommentTree节点。

R

SimpleDocTreeVisitor.visitDocComment​(DocCommentTree node, P p)

访问DocCommentTree节点。

R

DocTreeScanner.visitDocRoot​(DocRootTree node, P p)

访问DocRootTree节点。

R

SimpleDocTreeVisitor.visitDocRoot​(DocRootTree node, P p)

访问DocRootTree节点。

R

SimpleTreeVisitor.visitDoWhileLoop​(DoWhileLoopTree node, P p)

访问DoWhileTree节点。

R

TreeScanner.visitDoWhileLoop​(DoWhileLoopTree node, P p)

访问DoWhileTree节点。

R

SimpleTreeVisitor.visitEmptyStatement​(EmptyStatementTree node, P p)

访问一个EmptyStatementTree节点。

R

TreeScanner.visitEmptyStatement​(EmptyStatementTree node, P p)

访问一个EmptyStatementTree节点。

R

DocTreeScanner.visitEndElement​(EndElementTree node, P p)

访问EndElementTree节点。

R

SimpleDocTreeVisitor.visitEndElement​(EndElementTree node, P p)

访问EndElementTree节点。

R

SimpleTreeVisitor.visitEnhancedForLoop​(EnhancedForLoopTree node, P p)

访问EnhancedForLoopTree节点。

R

TreeScanner.visitEnhancedForLoop​(EnhancedForLoopTree node, P p)

访问EnhancedForLoopTree节点。

R

DocTreeScanner.visitEntity​(EntityTree node, P p)

访问EntityTree节点。

R

SimpleDocTreeVisitor.visitEntity​(EntityTree node, P p)

访问EntityTree节点。

R

DocTreeScanner.visitErroneous​(ErroneousTree node, P p)

访问ErroneousTree节点。

R

SimpleDocTreeVisitor.visitErroneous​(ErroneousTree node, P p)

访问ErroneousTree节点。

R

TreeScanner.visitErroneous​(ErroneousTree node, P p)

访问ErroneousTree节点。

R

SimpleTreeVisitor.visitExports​(ExportsTree node, P p)

R

TreeScanner.visitExports​(ExportsTree node, P p)

R

SimpleTreeVisitor.visitExpressionStatement​(ExpressionStatementTree node, P p)

访问ExpressionStatementTree节点。

R

TreeScanner.visitExpressionStatement​(ExpressionStatementTree node, P p)

访问ExpressionStatementTree节点。

R

SimpleTreeVisitor.visitForLoop​(ForLoopTree node, P p)

访问ForLoopTree节点。

R

TreeScanner.visitForLoop​(ForLoopTree node, P p)

访问ForLoopTree节点。

R

DocTreeScanner.visitHidden​(HiddenTree node, P p)

访问HiddenTree节点。

R

SimpleDocTreeVisitor.visitHidden​(HiddenTree node, P p)

访问HiddenTree节点。

R

DocTreeScanner.visitIdentifier​(IdentifierTree node, P p)

访问IdentifierTree节点。

R

SimpleDocTreeVisitor.visitIdentifier​(IdentifierTree node, P p)

访问IdentifierTree节点。

R

SimpleTreeVisitor.visitIdentifier​(IdentifierTree node, P p)

访问IdentifierTree节点。

R

TreeScanner.visitIdentifier​(IdentifierTree node, P p)

访问IdentifierTree节点。

R

SimpleTreeVisitor.visitIf​(IfTree node, P p)

访问IfTree节点。

R

TreeScanner.visitIf​(IfTree node, P p)

访问IfTree节点。

R

SimpleTreeVisitor.visitImport​(ImportTree node, P p)

访问ImportTree节点。

R

TreeScanner.visitImport​(ImportTree node, P p)

访问ImportTree节点。

R

DocTreeScanner.visitIndex​(IndexTree node, P p)

访问IndexTree节点。

R

SimpleDocTreeVisitor.visitIndex​(IndexTree node, P p)

访问IndexTree节点。

R

DocTreeScanner.visitInheritDoc​(InheritDocTree node, P p)

访问InheritDocTree节点。

R

SimpleDocTreeVisitor.visitInheritDoc​(InheritDocTree node, P p)

访问InheritDocTree节点。

R

SimpleTreeVisitor.visitInstanceOf​(InstanceOfTree node, P p)

访问InstanceOfTree节点。

R

TreeScanner.visitInstanceOf​(InstanceOfTree node, P p)

访问InstanceOfTree节点。

R

SimpleTreeVisitor.visitIntersectionType​(IntersectionTypeTree node, P p)

访问一个IntersectionTypeTree节点。

R

TreeScanner.visitIntersectionType​(IntersectionTypeTree node, P p)

访问一个IntersectionTypeTree节点。

R

SimpleTreeVisitor.visitLabeledStatement​(LabeledStatementTree node, P p)

访问LabeledStatementTree节点。

R

TreeScanner.visitLabeledStatement​(LabeledStatementTree node, P p)

访问LabeledStatementTree节点。

R

SimpleTreeVisitor.visitLambdaExpression​(LambdaExpressionTree node, P p)

访问LambdaExpressionTree节点。

R

TreeScanner.visitLambdaExpression​(LambdaExpressionTree node, P p)

访问LambdaExpressionTree节点。

R

DocTreeScanner.visitLink​(LinkTree node, P p)

访问LinkTree节点。

R

SimpleDocTreeVisitor.visitLink​(LinkTree node, P p)

访问LinkTree节点。

R

DocTreeScanner.visitLiteral​(LiteralTree node, P p)

访问LiteralTree节点。

R

SimpleDocTreeVisitor.visitLiteral​(LiteralTree node, P p)

访问LiteralTree节点。

R

SimpleTreeVisitor.visitLiteral​(LiteralTree node, P p)

访问LiteralTree节点。

R

TreeScanner.visitLiteral​(LiteralTree node, P p)

访问LiteralTree节点。

R

SimpleTreeVisitor.visitMemberReference​(MemberReferenceTree node, P p)

访问MemberReferenceTree节点。

R

TreeScanner.visitMemberReference​(MemberReferenceTree node, P p)

访问MemberReferenceTree节点。

R

SimpleTreeVisitor.visitMemberSelect​(MemberSelectTree node, P p)

访问MemberSelectTree节点。

R

TreeScanner.visitMemberSelect​(MemberSelectTree node, P p)

访问MemberSelectTree节点。

R

SimpleTreeVisitor.visitMethod​(MethodTree node, P p)

访问MethodTree节点。

R

TreeScanner.visitMethod​(MethodTree node, P p)

访问MethodTree节点。

R

SimpleTreeVisitor.visitMethodInvocation​(MethodInvocationTree node, P p)

访问MethodInvocationTree节点。

R

TreeScanner.visitMethodInvocation​(MethodInvocationTree node, P p)

访问MethodInvocationTree节点。

R

SimpleTreeVisitor.visitModifiers​(ModifiersTree node, P p)

访问修饰符Tree节点。

R

TreeScanner.visitModifiers​(ModifiersTree node, P p)

访问修饰符Tree节点。

R

TreeScanner.visitModule​(ModuleTree node, P p)

R

SimpleTreeVisitor.visitNewArray​(NewArrayTree node, P p)

访问NewArrayTree节点。

R

TreeScanner.visitNewArray​(NewArrayTree node, P p)

访问NewArrayTree节点。

R

SimpleTreeVisitor.visitNewClass​(NewClassTree node, P p)

访问NewClassTree节点。

R

TreeScanner.visitNewClass​(NewClassTree node, P p)

访问NewClassTree节点。

R

SimpleTreeVisitor.visitOpens​(OpensTree node, P p)

R

TreeScanner.visitOpens​(OpensTree node, P p)

R

DocTreeScanner.visitOther​(DocTree node, P p)

访问未知类型的DocTree节点。

R

SimpleDocTreeVisitor.visitOther​(DocTree node, P p)

访问未知类型的DocTree节点。

R

SimpleTreeVisitor.visitOther​(树 node, P p)

访问未知类型的树节点。

R

TreeScanner.visitOther​(树 node, P p)

访问未知类型的树节点。

R

SimpleTreeVisitor.visitPackage​(PackageTree node, P p)

访问PackageTree节点。

R

TreeScanner.visitPackage​(PackageTree node, P p)

访问PackageTree节点。

R

DocTreeScanner.visitParam​(ParamTree node, P p)

访问ParamTree节点。

R

SimpleDocTreeVisitor.visitParam​(ParamTree node, P p)

访问ParamTree节点。

R

SimpleTreeVisitor.visitParameterizedType​(ParameterizedTypeTree node, P p)

访问ParameterizedTypeTree节点。

R

TreeScanner.visitParameterizedType​(ParameterizedTypeTree node, P p)

访问ParameterizedTypeTree节点。

R

SimpleTreeVisitor.visitParenthesized​(ParenthesizedTree node, P p)

访问ParenthesizedTree节点。

R

TreeScanner.visitParenthesized​(ParenthesizedTree node, P p)

访问ParenthesizedTree节点。

R

SimpleTreeVisitor.visitPrimitiveType​(PrimitiveTypeTree node, P p)

访问PrimitiveTypeTree节点。

R

TreeScanner.visitPrimitiveType​(PrimitiveTypeTree node, P p)

访问PrimitiveTypeTree节点。

R

DocTreeScanner.visitProvides​(ProvidesTree node, P p)

访问ProvideTree节点。

R

SimpleDocTreeVisitor.visitProvides​(ProvidesTree node, P p)

访问ProvideTree节点。

R

SimpleTreeVisitor.visitProvides​(ProvidesTree node, P p)

R

TreeScanner.visitProvides​(ProvidesTree node, P p)

R

DocTreeScanner.visitReference​(ReferenceTree node, P p)

访问一个ReferenceTree节点。

R

SimpleDocTreeVisitor.visitReference​(ReferenceTree node, P p)

访问一个ReferenceTree节点。

R

SimpleTreeVisitor.visitRequires​(RequiresTree node, P p)

R

TreeScanner.visitRequires​(RequiresTree node, P p)

R

DocTreeScanner.visitReturn​(ReturnTree node, P p)

访问ReturnTree节点。

R

SimpleDocTreeVisitor.visitReturn​(ReturnTree node, P p)

访问ReturnTree节点。

R

SimpleTreeVisitor.visitReturn​(ReturnTree node, P p)

访问ReturnTree节点。

R

TreeScanner.visitReturn​(ReturnTree node, P p)

访问ReturnTree节点。

R

DocTreeScanner.visitSee​(SeeTree node, P p)

访问SeeTree节点。

R

SimpleDocTreeVisitor.visitSee​(SeeTree node, P p)

访问SeeTree节点。

R

DocTreeScanner.visitSerial​(SerialTree node, P p)

访问SerialTree节点。

R

SimpleDocTreeVisitor.visitSerial​(SerialTree node, P p)

访问SerialTree节点。

R

DocTreeScanner.visitSerialData​(SerialDataTree node, P p)

访问一个SerialDataTree节点。

R

SimpleDocTreeVisitor.visitSerialData​(SerialDataTree node, P p)

访问一个SerialDataTree节点。

R

DocTreeScanner.visitSerialField​(SerialFieldTree node, P p)

访问SerialFieldTree节点。

R

SimpleDocTreeVisitor.visitSerialField​(SerialFieldTree node, P p)

访问SerialFieldTree节点。

R

DocTreeScanner.visitSince​(SinceTree node, P p)

访问SinceTree节点。

R

SimpleDocTreeVisitor.visitSince​(SinceTree node, P p)

访问SinceTree节点。

R

DocTreeScanner.visitStartElement​(StartElementTree node, P p)

访问StartElementTree节点。

R

SimpleDocTreeVisitor.visitStartElement​(StartElementTree node, P p)

访问StartElementTree节点。

R

SimpleTreeVisitor.visitSwitch​(SwitchTree node, P p)

访问SwitchTree节点。

R

TreeScanner.visitSwitch​(SwitchTree node, P p)

访问SwitchTree节点。

R

SimpleTreeVisitor.visitSynchronized​(SynchronizedTree node, P p)

访问SynchronizedTree节点。

R

TreeScanner.visitSynchronized​(SynchronizedTree node, P p)

访问SynchronizedTree节点。

R

DocTreeScanner.visitText​(TextTree node, P p)

访问TextTree节点。

R

SimpleDocTreeVisitor.visitText​(TextTree node, P p)

访问TextTree节点。

R

SimpleTreeVisitor.visitThrow​(ThrowTree node, P p)

访问ThrowTree节点

R

TreeScanner.visitThrow​(ThrowTree node, P p)

访问ThrowTree节点

R

DocTreeScanner.visitThrows​(ThrowsTree node, P p)

访问ThrowsTree节点。

R

SimpleDocTreeVisitor.visitThrows​(ThrowsTree node, P p)

访问ThrowsTree节点。

R

SimpleTreeVisitor.visitTry​(TryTree node, P p)

访问TryTree节点。

R

TreeScanner.visitTry​(TryTree node, P p)

访问TryTree节点。

R

SimpleTreeVisitor.visitTypeCast​(TypeCastTree node, P p)

访问TypeCastTree节点。

R

TreeScanner.visitTypeCast​(TypeCastTree node, P p)

访问TypeCastTree节点。

R

SimpleTreeVisitor.visitTypeParameter​(TypeParameterTree node, P p)

访问TypeParameterTree节点。

R

TreeScanner.visitTypeParameter​(TypeParameterTree node, P p)

访问TypeParameterTree节点。

R

SimpleTreeVisitor.visitUnary​(UnaryTree node, P p)

访问UnaryTree节点。

R

TreeScanner.visitUnary​(UnaryTree node, P p)

访问UnaryTree节点。

R

SimpleTreeVisitor.visitUnionType​(UnionTypeTree node, P p)

访问UnionTypeTree节点。

R

TreeScanner.visitUnionType​(UnionTypeTree node, P p)

访问UnionTypeTree节点。

R

DocTreeScanner.visitUnknownBlockTag​(UnknownBlockTagTree node, P p)

访问UnknownBlockTagTree节点。

R

SimpleDocTreeVisitor.visitUnknownBlockTag​(UnknownBlockTagTree node, P p)

访问UnknownBlockTagTree节点。

R

DocTreeScanner.visitUnknownInlineTag​(UnknownInlineTagTree node, P p)

访问UnknownInlineTagTree节点。

R

SimpleDocTreeVisitor.visitUnknownInlineTag​(UnknownInlineTagTree node, P p)

访问UnknownInlineTagTree节点。

R

DocTreeScanner.visitUses​(UsesTree node, P p)

访问UsesTree节点。

R

SimpleDocTreeVisitor.visitUses​(UsesTree node, P p)

访问UsesTree节点。

R

SimpleTreeVisitor.visitUses​(UsesTree node, P p)

R

TreeScanner.visitUses​(UsesTree node, P p)

R

DocTreeScanner.visitValue​(ValueTree node, P p)

访问ValueTree节点。

R

SimpleDocTreeVisitor.visitValue​(ValueTree node, P p)

访问ValueTree节点。

R

SimpleTreeVisitor.visitVariable​(VariableTree node, P p)

访问VariableTree节点。

R

TreeScanner.visitVariable​(VariableTree node, P p)

访问VariableTree节点。

R

DocTreeScanner.visitVersion​(VersionTree node, P p)

访问VersionTreeTree节点。

R

SimpleDocTreeVisitor.visitVersion​(VersionTree node, P p)

访问VersionTreeTree节点。

R

SimpleTreeVisitor.visitWhileLoop​(WhileLoopTree node, P p)

访问WhileLoopTree节点。

R

TreeScanner.visitWhileLoop​(WhileLoopTree node, P p)

访问WhileLoopTree节点。

R

SimpleTreeVisitor.visitWildcard​(WildcardTree node, P p)

访问WildcardTypeTree节点。

R

TreeScanner.visitWildcard​(WildcardTree node, P p)

访问WildcardTypeTree节点。

Uses of Override in java.applet

Methods in java.applet with annotations of type Override

Modifier and Type

方法

描述

boolean

Applet.isValidateRoot​()

已过时。

指示此容器是否为验证根。

Uses of Override in java.awt

Methods in java.awt with annotations of type Override

Modifier and Type

方法

描述

boolean

DisplayMode.equals​(Object dm)

指示一些其他对象是否等于此。

Color

Window.getBackground​()

获取此窗口的背景颜色。

int

DisplayMode.hashCode​()

返回对象的哈希码值。

void

Container.invalidate​()

使容器无效。

boolean

Window.isOpaque​()

指示窗口当前是否不透明。

boolean

Window.isValidateRoot​()

指示此容器是否为验证根。

void

Window.paint​(Graphics g)

涂上容器

void

Dialog.setBackground​(Color bgColor)

设置此窗口的背景颜色。

void

Frame.setBackground​(Color bgColor)

设置此窗口的背景颜色。

void

Window.setBackground​(Color bgColor)

设置此窗口的背景颜色。

void

Window.setLocation​(int x, int y)

将此组件移动到新位置。

void

Window.setLocation​(Point p)

将此组件移动到新位置。

void

Dialog.setOpacity​(float opacity)

设置窗口的不透明度。

void

Frame.setOpacity​(float opacity)

设置窗口的不透明度。

void

Dialog.setShape​(Shape shape)

设置窗口的形状。

void

Frame.setShape​(Shape shape)

设置窗口的形状。

void

FileDialog.setTitle​(String title)

设置对话框的标题。

String

DisplayMode.toString​()

返回对象的字符串表示形式。

String

Robot.toString​()

返回此Robot的字符串表示形式。

Uses of Override in java.awt.datatransfer

Methods in java.awt.datatransfer with annotations of type Override

Modifier and Type

方法

描述

List<DataFlavor>

SystemFlavorMap.getFlavorsForNative​(String nat)

返回 List的 DataFlavor s，指定的 String本机可以由数据传输子系统翻译。

Map<String,DataFlavor>

SystemFlavorMap.getFlavorsForNatives​(String[] natives)

返回 Map的 String原住民最喜欢的 DataFlavor 。

List<String>

SystemFlavorMap.getNativesForFlavor​(DataFlavor flav)

返回 List的 String本地人，指定的 DataFlavor可以由数据传输子系统翻译。

Map<DataFlavor,String>

SystemFlavorMap.getNativesForFlavors​(DataFlavor[] flavors)

返回 Map的 DataFlavor ，最 String本机。

Uses of Override in java.awt.image

Methods in java.awt.image with annotations of type Override

Modifier and Type

方法

描述

boolean

ColorModel.equals​(Object obj)

该方法简单地委托给 Object的默认实现，这与 ==测试相同，因为该类不能在多个独立子类分支之间强制执行适当的等式测试的问题。

boolean

ComponentColorModel.equals​(Object obj)

测试指定 Object是一个实例 ComponentColorModel和等于这个 ComponentColorModel 。

boolean

IndexColorModel.equals​(Object obj)

如果指定的测试 Object是一个实例 IndexColorModel ，以及它是否该 IndexColorModel

boolean

PackedColorModel.equals​(Object obj)

测试指定 Object是一个实例 PackedColorModel和等于这个 PackedColorModel 。

protected Image

BaseMultiResolutionImage.getBaseImage​()

Graphics

AbstractMultiResolutionImage.getGraphics​()

根据基础 Image#getGraphics()方法的合同，此实现将始终抛出 UnsupportedOperationException因为只有离屏图像可以返回一个 Graphics对象。

int

AbstractMultiResolutionImage.getHeight​(ImageObserver observer)

该方法简单地委托给基本图像上相同的方法，它等同于： getBaseImage().getHeight(observer) 。

Object

AbstractMultiResolutionImage.getProperty​(String name, ImageObserver observer)

该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getProperty(name, observer) 。

Image

BaseMultiResolutionImage.getResolutionVariant​(double destImageWidth, double destImageHeight)

List<Image>

BaseMultiResolutionImage.getResolutionVariants​()

ImageProducer

AbstractMultiResolutionImage.getSource​()

该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getSource() 。

int

AbstractMultiResolutionImage.getWidth​(ImageObserver observer)

该方法简单地委托给基本图像上相同的方法，它等效于： getBaseImage().getWidth(observer) 。

int

ColorModel.hashCode​()

该方法只是委托给 Object的默认实现，返回该类的系统ID。

int

ComponentColorModel.hashCode​()

返回此ComponentColorModel的哈希码。

int

IndexColorModel.hashCode​()

返回IndexColorModel的哈希码。

int

PackedColorModel.hashCode​()

返回此PackedColorModel的哈希码。

Uses of Override in java.beans

Methods in java.beans with annotations of type Override

Modifier and Type

方法

描述

void

Expression.execute​()

execute方法查找名称与 methodName属性相同的方法，并调用目标方法。

BeanInfo[]

SimpleBeanInfo.getAdditionalBeanInfo​()

声明没有其他相关的BeanInfo对象。

BeanDescriptor

SimpleBeanInfo.getBeanDescriptor​()

拒绝关于bean的类和定制器的知识。

int

SimpleBeanInfo.getDefaultEventIndex​()

拒绝默认事件的知识。

int

SimpleBeanInfo.getDefaultPropertyIndex​()

拒绝默认属性的知识。

EventSetDescriptor[]

SimpleBeanInfo.getEventSetDescriptors​()

否认事件集的知识。

Image

SimpleBeanInfo.getIcon​(int iconKind)

声明没有可用的图标。

MethodDescriptor[]

SimpleBeanInfo.getMethodDescriptors​()

否认知识的方法。

PropertyDescriptor[]

SimpleBeanInfo.getPropertyDescriptors​()

拒绝属性知识。

Uses of Override in java.io

Methods in java.io with annotations of type Override

Modifier and Type

方法

描述

Writer

OutputStreamWriter.append​(CharSequence csq)

Writer

OutputStreamWriter.append​(CharSequence csq, int start, int end)

void

FilterOutputStream.close​()

关闭此输出流并释放与流相关联的任何系统资源。

boolean

FilePermission.equals​(Object obj)

检查两个FilePermission对象是否相等。

void

BufferedOutputStream.flush​()

刷新缓冲输出流。

void

FilterOutputStream.flush​()

刷新此输出流，并强制将任何缓冲的输出字节写入流。

String

FilePermission.getActions​()

返回动作的“规范字符串表示”。

IOException

UncheckedIOException.getCause​()

返回此异常的原因。

int

FilePermission.hashCode​()

返回此对象的哈希码值。

boolean

FilePermission.implies​(Permission p)

检查此FilePermission对象是否“暗示”指定的权限。

PermissionCollection

FilePermission.newPermissionCollection​()

返回一个新的PermissionCollection对象，用于存储FilePermission对象。

void

BufferedOutputStream.write​(byte[] b, int off, int len)

从指定的字节数组写入 len个字节，从偏移量 off开始到这个缓冲的输出流。

void

BufferedOutputStream.write​(int b)

将指定的字节写入缓冲的输出流。

void

FilterOutputStream.write​(byte[] b)

将 b.length字节写入此输出流。

void

FilterOutputStream.write​(byte[] b, int off, int len)

写入 len从指定的字节 byte数组以抵消 off此输出流。

void

FilterOutputStream.write​(int b)

将指定的 byte写入此输出流。

Uses of Override in java.lang

Methods in java.lang with annotations of type Override

Modifier and Type

方法

描述

StringBuffer

StringBuffer.append​(boolean b)

StringBuffer

StringBuffer.append​(char c)

StringBuffer

StringBuffer.append​(char[] str)

StringBuffer

StringBuffer.append​(char[] str, int offset, int len)

StringBuffer

StringBuffer.append​(double d)

StringBuffer

StringBuffer.append​(float f)

StringBuffer

StringBuffer.append​(int i)

StringBuffer

StringBuffer.append​(long lng)

StringBuffer

StringBuffer.append​(CharSequence s)

追加指定的 CharSequence到这个序列。

StringBuffer

StringBuffer.append​(CharSequence s, int start, int end)

StringBuffer

StringBuffer.append​(Object obj)

StringBuffer

StringBuffer.append​(String str)

StringBuilder

StringBuilder.append​(boolean b)

StringBuilder

StringBuilder.append​(char c)

StringBuilder

StringBuilder.append​(char[] str)

StringBuilder

StringBuilder.append​(char[] str, int offset, int len)

StringBuilder

StringBuilder.append​(double d)

StringBuilder

StringBuilder.append​(float f)

StringBuilder

StringBuilder.append​(int i)

StringBuilder

StringBuilder.append​(long lng)

StringBuilder

StringBuilder.append​(CharSequence s)

StringBuilder

StringBuilder.append​(CharSequence s, int start, int end)

StringBuilder

StringBuilder.append​(Object obj)

StringBuilder

StringBuilder.append​(String str)

StringBuffer

StringBuffer.appendCodePoint​(int codePoint)

StringBuilder

StringBuilder.appendCodePoint​(int codePoint)

int

StringBuffer.capacity​()

char

StringBuffer.charAt​(int index)

IntStream

String.chars​()

返回一个 int的流，从这个序列中扩展 char值。

protected Object

Thread.clone​()

将CloneNotSupportedException作为线程抛出无法有意义地克隆。

int

StringBuffer.codePointAt​(int index)

int

StringBuffer.codePointBefore​(int index)

int

StringBuffer.codePointCount​(int beginIndex, int endIndex)

IntStream

String.codePoints​()

从此序列返回码流值。

int

ProcessHandle.compareTo​(ProcessHandle other)

将此ProcessHandle与指定的ProcessHandle进行比较。

int

Runtime.Version.compareTo​(Runtime.Version obj)

将此版本与另一版本进行比较。

StringBuffer

StringBuffer.delete​(int start, int end)

StringBuilder

StringBuilder.delete​(int start, int end)

StringBuffer

StringBuffer.deleteCharAt​(int index)

StringBuilder

StringBuilder.deleteCharAt​(int index)

void

StringBuffer.ensureCapacity​(int minimumCapacity)

boolean

ProcessHandle.equals​(Object other)

如果other对象为非空，则返回true ，具有相同的实现，并表示相同的系统进程; 否则返回false 。

boolean

Runtime.Version.equals​(Object obj)

确定此 Version是否等于另一个对象。

<T extends Annotation>
T

Module.getAnnotation​(Class<T> annotationClass)

返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。

Annotation[]

Module.getAnnotations​()

返回此元素上 存在的注释。

<A extends Annotation>
A[]

Class.getAnnotationsByType​(Class<A> annotationClass)

<A extends Annotation>
A[]

Package.getAnnotationsByType​(Class<A> annotationClass)

void

StringBuffer.getChars​(int srcBegin, int srcEnd, char[] dst, int dstBegin)

<A extends Annotation>
A

Class.getDeclaredAnnotation​(Class<A> annotationClass)

<A extends Annotation>
A

Package.getDeclaredAnnotation​(Class<A> annotationClass)

Annotation[]

Module.getDeclaredAnnotations​()

返回 直接存在于此元素上的注释。

<A extends Annotation>
A[]

Class.getDeclaredAnnotationsByType​(Class<A> annotationClass)

<A extends Annotation>
A[]

Package.getDeclaredAnnotationsByType​(Class<A> annotationClass)

int

Boolean.hashCode​()

返回此 Boolean对象的哈希码。

int

Byte.hashCode​()

返回这个Byte的哈希码; 等于调用intValue()的结果。

int

Character.hashCode​()

返回这个Character的哈希码; 等于调用charValue()的结果。

int

Double.hashCode​()

返回此 Double对象的哈希码。

int

Float.hashCode​()

返回此 Float对象的哈希码。

int

Integer.hashCode​()

返回此 Integer的哈希码。

int

Long.hashCode​()

返回此 Long的哈希码。

int

Package.hashCode​()

返回从包名称计算的哈希码。

int

ProcessHandle.hashCode​()

返回此ProcessHandle的哈希码值。

int

Runtime.Version.hashCode​()

返回此版本的哈希码。

int

Short.hashCode​()

返回这个Short的哈希码; 等于调用intValue()的结果。

int

StringBuffer.indexOf​(String str)

int

StringBuffer.indexOf​(String str, int fromIndex)

int

StringBuilder.indexOf​(String str)

int

StringBuilder.indexOf​(String str, int fromIndex)

StringBuffer

StringBuffer.insert​(int offset, boolean b)

StringBuffer

StringBuffer.insert​(int offset, char c)

StringBuffer

StringBuffer.insert​(int offset, char[] str)

StringBuffer

StringBuffer.insert​(int index, char[] str, int offset, int len)

StringBuffer

StringBuffer.insert​(int offset, double d)

StringBuffer

StringBuffer.insert​(int offset, float f)

StringBuffer

StringBuffer.insert​(int offset, int i)

StringBuffer

StringBuffer.insert​(int offset, long l)

StringBuffer

StringBuffer.insert​(int dstOffset, CharSequence s)

StringBuffer

StringBuffer.insert​(int dstOffset, CharSequence s, int start, int end)

StringBuffer

StringBuffer.insert​(int offset, Object obj)

StringBuffer

StringBuffer.insert​(int offset, String str)

StringBuilder

StringBuilder.insert​(int offset, boolean b)

StringBuilder

StringBuilder.insert​(int offset, char c)

StringBuilder

StringBuilder.insert​(int offset, char[] str)

StringBuilder

StringBuilder.insert​(int index, char[] str, int offset, int len)

StringBuilder

StringBuilder.insert​(int offset, double d)

StringBuilder

StringBuilder.insert​(int offset, float f)

StringBuilder

StringBuilder.insert​(int offset, int i)

StringBuilder

StringBuilder.insert​(int offset, long l)

StringBuilder

StringBuilder.insert​(int dstOffset, CharSequence s)

StringBuilder

StringBuilder.insert​(int dstOffset, CharSequence s, int start, int end)

StringBuilder

StringBuilder.insert​(int offset, Object obj)

StringBuilder

StringBuilder.insert​(int offset, String str)

boolean

Class.isAnnotationPresent​(Class<? extends Annotation> annotationClass)

如果此元素上 存在指定类型的注释，则返回true，否则返回false。

boolean

Package.isAnnotationPresent​(Class<? extends Annotation> annotationClass)

如果此元素上 存在指定类型的注释，则返回true，否则返回false。

int

StringBuffer.lastIndexOf​(String str)

int

StringBuffer.lastIndexOf​(String str, int fromIndex)

int

StringBuilder.lastIndexOf​(String str)

int

StringBuilder.lastIndexOf​(String str, int fromIndex)

int

StringBuffer.length​()

int

StringBuffer.offsetByCodePoints​(int index, int codePointOffset)

StringBuffer

StringBuffer.replace​(int start, int end, String str)

StringBuilder

StringBuilder.replace​(int start, int end, String str)

StringBuffer

StringBuffer.reverse​()

StringBuilder

StringBuilder.reverse​()

void

Thread.run​()

如果使用单独的Runnable运行对象构建此线程，则调用该Runnable对象的run方法; 否则，此方法不执行任何操作并返回。

void

StringBuffer.setCharAt​(int index, char ch)

void

StringBuffer.setLength​(int newLength)

CharSequence

StringBuffer.subSequence​(int start, int end)

String

StringBuffer.substring​(int start)

String

StringBuffer.substring​(int start, int end)

String

Module.toString​()

返回此模块的字符串表示形式。

String

ModuleLayer.toString​()

返回描述此模块层的字符串。

String

Package.toString​()

返回此包的字符串表示形式。

String

Runtime.Version.toString​()

返回此版本的字符串表示形式。

String

StringBuffer.toString​()

String

StringBuilder.toString​()

void

StringBuffer.trimToSize​()

Uses of Override in java.lang.invoke

Methods in java.lang.invoke with annotations of type Override

Modifier and Type

方法

描述

MethodHandle

ConstantCallSite.dynamicInvoker​()

返回此呼叫站点的永久目标。

MethodHandle

MutableCallSite.dynamicInvoker​()

生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。

MethodHandle

VolatileCallSite.dynamicInvoker​()

生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。

boolean

MethodType.equals​(Object x)

将指定的对象与此类型进行比较以获得相等性。

MethodHandle

ConstantCallSite.getTarget​()

返回调用点，其行为类似于目标方法 final的领域 ConstantCallSite 。

MethodHandle

MutableCallSite.getTarget​()

返回调用站点的目标方法，其行为类似于 MutableCallSite的正常字段。

MethodHandle

VolatileCallSite.getTarget​()

返回调用点，其行为类似于目标方法 volatile的领域 VolatileCallSite 。

int

MethodType.hashCode​()

返回此方法类型的哈希码值。

void

ConstantCallSite.setTarget​(MethodHandle ignore)

总是抛出一个UnsupportedOperationException 。

void

MutableCallSite.setTarget​(MethodHandle newTarget)

将此呼叫站点的目标方法更新为常规变量。

void

VolatileCallSite.setTarget​(MethodHandle newTarget)

将此调用站点的目标方法更新为volatile变量。

String

MethodHandle.toString​()

返回方法句柄的字符串表示形式，从字符串 "MethodHandle"开始，以方法句柄类型的字符串表示形式结束。

String

MethodHandles.Lookup.toString​()

显示要从中进行查找的类的名称。

String

MethodType.toString​()

返回方法类型的字符串表示形式，格式为 "(PT0,PT1...)RT" 。

String

SerializedLambda.toString​()

Uses of Override in java.lang.module

Methods in java.lang.module with annotations of type Override

Modifier and Type

方法

描述

void

ModuleReader.close​()

关闭模块阅读器。

int

ModuleDescriptor.compareTo​(ModuleDescriptor that)

将此模块描述符与其他描述符进行比较

int

ModuleDescriptor.Exports.compareTo​(ModuleDescriptor.Exports that)

将此模块导出与另一个进行比较。

int

ModuleDescriptor.Opens.compareTo​(ModuleDescriptor.Opens that)

比较这个模块打开另一个。

int

ModuleDescriptor.Requires.compareTo​(ModuleDescriptor.Requires that)

将此模块的依赖性与另一个模型相比较

int

ModuleDescriptor.Version.compareTo​(ModuleDescriptor.Version that)

将此模块版本与其他模块版本进行比较。

boolean

ModuleDescriptor.equals​(Object ob)

测试此模块描述符与给定对象的相等性。

boolean

ModuleDescriptor.Exports.equals​(Object ob)

测试此模块导出与给定对象的相等性。

boolean

ModuleDescriptor.Opens.equals​(Object ob)

测试此模块打开以与给定对象相等。

boolean

ModuleDescriptor.Provides.equals​(Object ob)

测试这提供了与给定对象的相等性。

boolean

ModuleDescriptor.Requires.equals​(Object ob)

测试此模块与给定对象的相等性的依赖关系。

boolean

ModuleDescriptor.Version.equals​(Object ob)

测试此模块版本与给定对象的相等性。

boolean

ResolvedModule.equals​(Object ob)

测试此已解析模块与给定对象的相等性。

int

ModuleDescriptor.Exports.hashCode​()

计算此模块导出的哈希码。

int

ModuleDescriptor.hashCode​()

计算此模块描述符的哈希码。

int

ModuleDescriptor.Opens.hashCode​()

计算此模块的哈希码打开。

int

ModuleDescriptor.Provides.hashCode​()

计算这个提供的哈希码。

int

ModuleDescriptor.Requires.hashCode​()

计算此模块依赖的哈希码。

int

ModuleDescriptor.Version.hashCode​()

计算此模块版本的哈希码。

int

ResolvedModule.hashCode​()

计算此解析模块的哈希码。

String

Configuration.toString​()

返回描述此配置的字符串。

String

ModuleDescriptor.Exports.toString​()

返回描述导出包的字符串。

String

ModuleDescriptor.Opens.toString​()

返回描述打开包的字符串。

String

ModuleDescriptor.Provides.toString​()

返回描述此提供的字符串。

String

ModuleDescriptor.Requires.toString​()

返回描述此模块依赖关系的字符串。

String

ModuleDescriptor.toString​()

返回描述模块的字符串。

String

ModuleDescriptor.Version.toString​()

返回解析此版本的字符串。

String

ResolvedModule.toString​()

返回描述此已解析模块的字符串。

Uses of Override in java.lang.reflect

Methods in java.lang.reflect with annotations of type Override

Modifier and Type

方法

描述

AnnotatedType

AnnotatedArrayType.getAnnotatedOwnerType​()

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

AnnotatedType

AnnotatedParameterizedType.getAnnotatedOwnerType​()

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

AnnotatedType

AnnotatedTypeVariable.getAnnotatedOwnerType​()

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

AnnotatedType

AnnotatedWildcardType.getAnnotatedOwnerType​()

如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

AnnotatedType

Constructor.getAnnotatedReceiverType​()

返回一个 AnnotatedType对象，表示使用类型来指定由 Executable对象表示的方法/构造函数的接收器类型。

AnnotatedType

Constructor.getAnnotatedReturnType​()

返回一个 AnnotatedType对象，该对象表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。

AnnotatedType

Method.getAnnotatedReturnType​()

返回一个 AnnotatedType对象，该对象表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。

<T extends Annotation>
T[]

AccessibleObject.getAnnotationsByType​(Class<T> annotationClass)

<T extends Annotation>
T[]

Executable.getAnnotationsByType​(Class<T> annotationClass)

返回与此元素 相关联的注释。

<T extends Annotation>
T[]

Field.getAnnotationsByType​(Class<T> annotationClass)

返回与此元素 相关联的注释。

<T extends Annotation>
T[]

Parameter.getAnnotationsByType​(Class<T> annotationClass)

返回与此元素 相关联的注释。

<T extends Annotation>
T

AccessibleObject.getDeclaredAnnotation​(Class<T> annotationClass)

<T extends Annotation>
T[]

AccessibleObject.getDeclaredAnnotationsByType​(Class<T> annotationClass)

<T extends Annotation>
T[]

Parameter.getDeclaredAnnotationsByType​(Class<T> annotationClass)

Class<T>

Constructor.getDeclaringClass​()

返回表示由该对象表示的构造函数的类的 Class对象。

Class<?>

Field.getDeclaringClass​()

返回 Class表示声明此表示的字段的类或接口对象 Field对象。

Class<?>

Method.getDeclaringClass​()

返回表示由该对象表示的方法的类或接口的 Class对象。

Class<?>[]

Constructor.getExceptionTypes​()

返回一个 Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。

Class<?>[]

Method.getExceptionTypes​()

返回一个 Class对象的数组，表示由该对象表示的底层可执行文件抛出的异常类型。

Type[]

Constructor.getGenericExceptionTypes​()

返回一个 Type对象的数组，表示该可执行对象抛出的异常。

Type[]

Method.getGenericExceptionTypes​()

返回一个 Type对象的数组，它们表示声明为可执行对象抛出的异常。

Type[]

Constructor.getGenericParameterTypes​()

返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。

Type[]

Method.getGenericParameterTypes​()

返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。

int

Constructor.getModifiers​()

返回由该对象表示的可执行文件的Java语言modifiers 。

int

Method.getModifiers​()

返回由该对象表示的可执行文件的Java语言modifiers 。

String

Constructor.getName​()

以字符串形式返回此构造函数的名称。

String

Method.getName​()

返回由 方法对象表示的方法的名称，作为 String 。

Annotation[][]

Constructor.getParameterAnnotations​()

返回 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。

Annotation[][]

Method.getParameterAnnotations​()

返回 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序的注释。

Class<?>[]

Constructor.getParameterTypes​()

返回一个 Class对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。

Class<?>[]

Method.getParameterTypes​()

返回一个 Class对象的数组， Class以声明顺序表示由该对象表示的可执行文件的形式参数类型。

TypeVariable<Constructor<T>>[]

Constructor.getTypeParameters​()

返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

TypeVariable<方法>[]

Method.getTypeParameters​()

返回一个 TypeVariable对象的数组，表示由该 GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。

boolean

AccessibleObject.isAnnotationPresent​(Class<? extends Annotation> annotationClass)

如果此元素上 存在指定类型的注释，则返回true，否则返回false。

boolean

Constructor.isSynthetic​()

如果这个可执行文件是一个合成的结构，返回true ; 否则返回false 。

boolean

Method.isSynthetic​()

如果这个可执行文件是一个合成结构，则返回true ; 否则返回false 。

boolean

Constructor.isVarArgs​()

如果该可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。

boolean

Method.isVarArgs​()

如果此可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。

void

Constructor.setAccessible​(boolean flag)

将此反射对象的 accessible标志设置为指示的布尔值。

void

Field.setAccessible​(boolean flag)

void

Method.setAccessible​(boolean flag)

String

Constructor.toGenericString​()

返回一个描述这个 Constructor的字符串，包括类型参数。

String

Method.toGenericString​()

返回描述此 方法的字符串，包括类型参数。

Uses of Override in java.math

Methods in java.math with annotations of type Override

Modifier and Type

方法

描述

int

BigDecimal.compareTo​(BigDecimal val)

将此 BigDecimal与指定的 BigDecimal 。

double

BigDecimal.doubleValue​()

将此 BigDecimal转换为 double 。

boolean

BigDecimal.equals​(Object x)

将此 BigDecimal与指定的 Object进行比较以获得相等性。

float

BigDecimal.floatValue​()

将此 BigDecimal转换为 float 。

int

BigDecimal.hashCode​()

返回此 BigDecimal的哈希码。

int

BigDecimal.intValue​()

将此 BigDecimal转换为 int 。

long

BigDecimal.longValue​()

将此 BigDecimal转换为 long 。

String

BigDecimal.toString​()

返回此 BigDecimal的字符串表示 BigDecimal ，如果需要指数则使用科学计数法。

Uses of Override in java.net

Methods in java.net with annotations of type Override

Modifier and Type

方法

描述

Object

HttpCookie.clone​()

创建并返回此对象的副本。

boolean

HttpCookie.equals​(Object obj)

测试两个HTTP Cookie的相等性。

boolean

Inet6Address.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

InetSocketAddress.equals​(Object obj)

将此对象与指定对象进行比较。

boolean

SocketPermission.equals​(Object obj)

检查两个SocketPermission对象是否相等。

String

SocketPermission.getActions​()

返回动作的规范字符串表示形式。

byte[]

Inet6Address.getAddress​()

返回此 InetAddress对象的原始IP地址。

String

Inet6Address.getHostAddress​()

返回文本显示中的IP地址字符串。

int

HttpCookie.hashCode​()

返回此HTTP cookie的哈希码。

int

Inet6Address.hashCode​()

返回此IP地址的哈希码。

int

InetSocketAddress.hashCode​()

返回此套接字地址的哈希码。

int

SocketPermission.hashCode​()

返回此对象的哈希码值。

boolean

SocketPermission.implies​(Permission p)

检查此套接字许可对象是否“暗示”指定的权限。

boolean

Inet6Address.isAnyLocalAddress​()

检查InetAddress是否为通配符地址的实用程序。

boolean

Inet6Address.isLinkLocalAddress​()

检查InetAddress是否是链接本地地址的实用程序。

boolean

Inet6Address.isLoopbackAddress​()

检查InetAddress是否是环回地址的实用程序。

boolean

Inet6Address.isMCGlobal​()

检查多播地址是否具有全局范围的实用程序。

boolean

Inet6Address.isMCLinkLocal​()

检查组播地址是否具有链路范围的实用程序。

boolean

Inet6Address.isMCNodeLocal​()

检查多播地址是否具有节点范围的实用程序。

boolean

Inet6Address.isMCOrgLocal​()

检查组播地址是否具有组织范围的实用程序。

boolean

Inet6Address.isMCSiteLocal​()

检查多播地址是否具有站点范围的实用程序。

boolean

Inet6Address.isMulticastAddress​()

检查InetAddress是否是IP组播地址的实用程序。 11111111在地址开头将该地址标识为多播地址。

boolean

Inet6Address.isSiteLocalAddress​()

检查InetAddress是否是站点本地地址的实用程序。

PermissionCollection

SocketPermission.newPermissionCollection​()

返回一个新的PermissionCollection对象，用于存储SocketPermission对象。

Set<SocketOption<?>>

MulticastSocket.supportedOptions​()

String

HttpCookie.toString​()

构造此Cookie的Cookie标题字符串表示形式，其格式为相应Cookie规范定义的格式，但不包含前导“Cookie：”标记。

String

InetSocketAddress.toString​()

构造此InetSocketAddress的字符串表示形式。

Uses of Override in java.nio

Methods in java.nio with annotations of type Override

Modifier and Type

方法

描述

IntStream

CharBuffer.chars​()

ByteBuffer

ByteBuffer.clear​()

清除此缓冲区。

CharBuffer

CharBuffer.clear​()

清除此缓冲区。

DoubleBuffer

DoubleBuffer.clear​()

清除此缓冲区。

FloatBuffer

FloatBuffer.clear​()

清除此缓冲区。

IntBuffer

IntBuffer.clear​()

清除此缓冲区。

LongBuffer

LongBuffer.clear​()

清除此缓冲区。

MappedByteBuffer

MappedByteBuffer.clear​()

清除此缓冲区。

ShortBuffer

ShortBuffer.clear​()

清除此缓冲区。

abstract ByteBuffer

ByteBuffer.duplicate​()

创建一个新的字节缓冲区，共享此缓冲区的内容。

abstract CharBuffer

CharBuffer.duplicate​()

创建一个新的char缓冲区，共享此缓冲区的内容。

abstract DoubleBuffer

DoubleBuffer.duplicate​()

创建一个新的双缓冲区，共享此缓冲区的内容。

abstract FloatBuffer

FloatBuffer.duplicate​()

创建一个新的浮动缓冲区，共享此缓冲区的内容。

abstract IntBuffer

IntBuffer.duplicate​()

创建一个共享此缓冲区内容的新int缓冲区。

abstract LongBuffer

LongBuffer.duplicate​()

创建一个新的长缓冲区，共享此缓冲区的内容。

abstract ShortBuffer

ShortBuffer.duplicate​()

创建一个新的缓冲区，共享此缓冲区的内容。

ByteBuffer

ByteBuffer.flip​()

翻转这个缓冲区。

CharBuffer

CharBuffer.flip​()

翻转这个缓冲区。

DoubleBuffer

DoubleBuffer.flip​()

翻转这个缓冲区。

FloatBuffer

FloatBuffer.flip​()

翻转这个缓冲区。

IntBuffer

IntBuffer.flip​()

翻转这个缓冲区。

LongBuffer

LongBuffer.flip​()

翻转这个缓冲区。

MappedByteBuffer

MappedByteBuffer.flip​()

翻转这个缓冲区。

ShortBuffer

ShortBuffer.flip​()

翻转这个缓冲区。

ByteBuffer

ByteBuffer.limit​(int newLimit)

设置此缓冲区的限制。

CharBuffer

CharBuffer.limit​(int newLimit)

设置此缓冲区的限制。

DoubleBuffer

DoubleBuffer.limit​(int newLimit)

设置此缓冲区的限制。

FloatBuffer

FloatBuffer.limit​(int newLimit)

设置此缓冲区的限制。

IntBuffer

IntBuffer.limit​(int newLimit)

设置此缓冲区的限制。

LongBuffer

LongBuffer.limit​(int newLimit)

设置此缓冲区的限制。

MappedByteBuffer

MappedByteBuffer.limit​(int newLimit)

设置此缓冲区的限制。

ShortBuffer

ShortBuffer.limit​(int newLimit)

设置此缓冲区的限制。

ByteBuffer

ByteBuffer.mark​()

将此缓冲区的标记设置在其位置。

CharBuffer

CharBuffer.mark​()

将此缓冲区的标记设置在其位置。

DoubleBuffer

DoubleBuffer.mark​()

将此缓冲区的标记设置在其位置。

FloatBuffer

FloatBuffer.mark​()

将此缓冲区的标记设置在其位置。

IntBuffer

IntBuffer.mark​()

将此缓冲区的标记设置在其位置。

LongBuffer

LongBuffer.mark​()

将此缓冲区的标记设置在其位置。

MappedByteBuffer

MappedByteBuffer.mark​()

将此缓冲区的标记设置在其位置。

ShortBuffer

ShortBuffer.mark​()

将此缓冲区的标记设置在其位置。

ByteBuffer

ByteBuffer.position​(int newPosition)

设置这个缓冲区的位置。

CharBuffer

CharBuffer.position​(int newPosition)

设置这个缓冲区的位置。

DoubleBuffer

DoubleBuffer.position​(int newPosition)

设置这个缓冲区的位置。

FloatBuffer

FloatBuffer.position​(int newPosition)

设置这个缓冲区的位置。

IntBuffer

IntBuffer.position​(int newPosition)

设置这个缓冲区的位置。

LongBuffer

LongBuffer.position​(int newPosition)

设置这个缓冲区的位置。

MappedByteBuffer

MappedByteBuffer.position​(int newPosition)

设置这个缓冲区的位置。

ShortBuffer

ShortBuffer.position​(int newPosition)

设置这个缓冲区的位置。

ByteBuffer

ByteBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

CharBuffer

CharBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

DoubleBuffer

DoubleBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

FloatBuffer

FloatBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

IntBuffer

IntBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

LongBuffer

LongBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

MappedByteBuffer

MappedByteBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

ShortBuffer

ShortBuffer.reset​()

将此缓冲区的位置重置为先前标记的位置。

ByteBuffer

ByteBuffer.rewind​()

倒带这个缓冲区。

CharBuffer

CharBuffer.rewind​()

倒带这个缓冲区。

DoubleBuffer

DoubleBuffer.rewind​()

倒带这个缓冲区。

FloatBuffer

FloatBuffer.rewind​()

倒带这个缓冲区。

IntBuffer

IntBuffer.rewind​()

倒带这个缓冲区。

LongBuffer

LongBuffer.rewind​()

倒带这个缓冲区。

MappedByteBuffer

MappedByteBuffer.rewind​()

倒带这个缓冲区。

ShortBuffer

ShortBuffer.rewind​()

倒带这个缓冲区。

abstract ByteBuffer

ByteBuffer.slice​()

创建一个新的字节缓冲区，其内容是此缓冲区内容的共享子序列。

abstract CharBuffer

CharBuffer.slice​()

创建一个新的char缓冲区，其内容是此缓冲区内容的共享子序列。

abstract DoubleBuffer

DoubleBuffer.slice​()

创建一个新的双缓冲区，其内容是此缓冲区内容的共享子序列。

abstract FloatBuffer

FloatBuffer.slice​()

创建一个新的浮动缓冲区，其内容是此缓冲区内容的共享子序列。

abstract IntBuffer

IntBuffer.slice​()

创建一个新的int缓冲区，其内容是此缓冲区内容的共享子序列。

abstract LongBuffer

LongBuffer.slice​()

创建一个新的长缓冲区，其内容是此缓冲区内容的共享子序列。

abstract ShortBuffer

ShortBuffer.slice​()

创建一个新的短缓冲区，其内容是此缓冲区内容的共享子序列。

Uses of Override in java.nio.channels

Methods in java.nio.channels with annotations of type Override

Modifier and Type

方法

描述

abstract AsynchronousSocketChannel

AsynchronousSocketChannel.bind​(SocketAddress local)

abstract SocketChannel

SocketChannel.bind​(SocketAddress local)

void

AsynchronousChannel.close​()

关闭此频道。

void

MulticastChannel.close​()

关闭此频道。

abstract SocketAddress

AsynchronousServerSocketChannel.getLocalAddress​()

返回此通道的套接字所绑定的套接字地址。

abstract SocketAddress

DatagramChannel.getLocalAddress​()

返回此通道的套接字所绑定的套接字地址。

abstract SocketAddress

ServerSocketChannel.getLocalAddress​()

返回此通道的套接字所绑定的套接字地址。

abstract SocketAddress

SocketChannel.getLocalAddress​()

返回此通道的套接字所绑定的套接字地址。

abstract Future<Integer>

AsynchronousSocketChannel.read​(ByteBuffer dst)

<A> void

AsynchronousSocketChannel.read​(ByteBuffer dst, A attachment, CompletionHandler<Integer,? super A> handler)

int

SeekableByteChannel.read​(ByteBuffer dst)

从该通道读取到给定缓冲区的字节序列。

abstract <T> AsynchronousSocketChannel

AsynchronousSocketChannel.setOption​(SocketOption<T> name, T value)

abstract <T> SocketChannel

SocketChannel.setOption​(SocketOption<T> name, T value)

abstract Future<Integer>

AsynchronousSocketChannel.write​(ByteBuffer src)

<A> void

AsynchronousSocketChannel.write​(ByteBuffer src, A attachment, CompletionHandler<Integer,? super A> handler)

int

SeekableByteChannel.write​(ByteBuffer src)

从给定的缓冲区向该通道写入一个字节序列。

Uses of Override in java.nio.file

Methods in java.nio.file with annotations of type Override

Modifier and Type

方法

描述

abstract void

FileSystem.close​()

关闭此文件系统。

void

WatchService.close​()

关闭这个手表服务。

int

Path.compareTo​(Path other)

比较两个抽象的路径词典。

IOException

DirectoryIteratorException.getCause​()

返回此异常的原因。

String

FileSystemException.getMessage​()

返回详细消息字符串。

Iterator<T>

DirectoryStream.iterator​()

返回与此 DirectoryStream关联的迭代器。

default Iterator<Path>

Path.iterator​()

返回此路径的名称元素的迭代器。

FileVisitResult

SimpleFileVisitor.postVisitDirectory​(T dir, IOException exc)

在目录中的条目之后调用目录，并且已经访问了所有的后代。

FileVisitResult

SimpleFileVisitor.preVisitDirectory​(T dir, BasicFileAttributes attrs)

在目录中的条目被访问之前调用一个目录。

default WatchKey

Path.register​(WatchService watcher, WatchEvent.Kind<?>... events)

使用手表服务注册此路径所在的文件。

WatchKey

Path.register​(WatchService watcher, WatchEvent.Kind<?>[] events, WatchEvent.Modifier... modifiers)

使用手表服务注册此路径所在的文件。

FileVisitResult

SimpleFileVisitor.visitFile​(T file, BasicFileAttributes attrs)

为目录中的文件调用。

FileVisitResult

SimpleFileVisitor.visitFileFailed​(T file, IOException exc)

为无法访问的文件调用。

Uses of Override in java.nio.file.attribute

Methods in java.nio.file.attribute with annotations of type Override

Modifier and Type

方法

描述

int

FileTime.compareTo​(FileTime other)

比较两个 FileTime对象的价值。

boolean

AclEntry.equals​(Object ob)

将指定的对象与此ACL条目进行比较以获得相等性。

boolean

FileTime.equals​(Object obj)

测试此 FileTime与给定对象的相等性。

int

AclEntry.hashCode​()

返回此ACL条目的哈希码值。

int

FileTime.hashCode​()

计算此文件时间的哈希码。

String

AclFileAttributeView.name​()

返回属性视图的名称。

String

BasicFileAttributeView.name​()

返回属性视图的名称。

String

DosFileAttributeView.name​()

返回属性视图的名称。

String

FileOwnerAttributeView.name​()

返回属性视图的名称。

String

PosixFileAttributeView.name​()

返回属性视图的名称。

String

UserDefinedFileAttributeView.name​()

返回此属性视图的名称。

DosFileAttributes

DosFileAttributeView.readAttributes​()

PosixFileAttributes

PosixFileAttributeView.readAttributes​()

String

AclEntry.toString​()

返回此ACL条目的字符串表示形式。

String

FileTime.toString​()

返回此 FileTime的字符串表示 FileTime 。

Uses of Override in java.security

Methods in java.security with annotations of type Override

Modifier and Type

方法

描述

void

Permissions.add​(Permission permission)

将权限对象添加到权限所属的类的PermissionCollection。

void

Provider.clear​()

清除此提供程序，使其不再包含用于查找由提供程序实施的设施的属性。

Object

Provider.compute​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

Object

Provider.computeIfAbsent​(Object key, Function<? super Object,? extends Object> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

Object

Provider.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

Enumeration<Permission>

Permissions.elements​()

返回此Permissions对象中所有PermissionCollections中所有Permission对象的枚举。

Enumeration<Object>

Provider.elements​()

Set<Map.Entry<Object,Object>>

Provider.entrySet​()

返回此提供程序中包含的属性条目的不可修改的Set视图。

boolean

BasicPermission.equals​(Object obj)

检查两个BasicPermission对象是否相等。

boolean

CodeSource.equals​(Object obj)

测试指定对象和此对象之间的相等性。

boolean

PKCS12Attribute.equals​(Object obj)

比较这个 PKCS12Attribute和一个指定的对象的相等性。

void

Provider.forEach​(BiConsumer<? super Object,? super Object> action)

Object

Provider.get​(Object key)

String

BasicPermission.getActions​()

返回动作的规范字符串表示形式，它当前是空字符串“”，因为BasicPermission没有任何操作。

Set<KeyStore.Entry.Attribute>

KeyStore.PrivateKeyEntry.getAttributes​()

检索与条目关联的属性。

Set<KeyStore.Entry.Attribute>

KeyStore.SecretKeyEntry.getAttributes​()

检索与条目关联的属性。

Set<KeyStore.Entry.Attribute>

KeyStore.TrustedCertificateEntry.getAttributes​()

检索与条目关联的属性。

String

PKCS12Attribute.getName​()

返回表示为点分隔整数列表的属性的ASN.1对象标识符。

Object

Provider.getOrDefault​(Object key, Object defaultValue)

KeyStore.ProtectionParameter

DomainLoadStoreParameter.getProtectionParameter​()

获取此域的密钥库保护参数。

String

PKCS12Attribute.getValue​()

返回属性的ASN.1 DER编码值作为字符串。

int

BasicPermission.hashCode​()

返回此对象的哈希码值。

int

CodeSource.hashCode​()

返回此对象的哈希码值。

int

PKCS12Attribute.hashCode​()

返回此 PKCS12Attribute的哈希 PKCS12Attribute 。

boolean

BasicPermission.implies​(Permission p)

检查指定的权限是否被该对象“隐含”。

boolean

Permissions.implies​(Permission permission)

检查此对象的PermissionCollection是否具有指定权限类的权限，这意味着在 权限对象中表达的 权限 。

Enumeration<Object>

Provider.keys​()

Set<Object>

Provider.keySet​()

返回此提供程序中包含的属性键的不可修改的Set视图。

void

Provider.load​(InputStream inStream)

从输入流读取属性列表（键和元素对）。

Object

Provider.merge​(Object key, Object value, BiFunction<? super Object,? super Object,? extends Object> remappingFunction)

如果指定的键尚未与值相关联或与null关联，则将其与给定值相关联。

PermissionCollection

BasicPermission.newPermissionCollection​()

返回一个新的PermissionCollection对象，用于存储BasicPermission对象。

protected int

SecureRandom.next​(int numBits)

生成一个包含用户指定数量的伪随机位的整数（右对齐，带前导零）。

void

SecureRandom.nextBytes​(byte[] bytes)

生成用户指定的随机字节数。

Object

Provider.put​(Object key, Object value)

将 key属性设置为具有指定的 value 。

void

Provider.putAll​(Map<?,?> t)

将指定地图中的所有映射复制到此提供程序。

Object

Provider.putIfAbsent​(Object key, Object value)

如果指定的键尚未与某个值相关联（或映射到 null ）将其与给定值相关联并返回 null ，否则返回当前值。

Object

Provider.remove​(Object key)

删除 key属性（及其对应的 value ）。

boolean

Provider.remove​(Object key, Object value)

仅当指定的密钥当前映射到指定的值时删除该条目。

Object

Provider.replace​(Object key, Object value)

只有当目标映射到某个值时，才能替换指定键的条目。

boolean

Provider.replace​(Object key, Object oldValue, Object newValue)

仅当当前映射到指定的值时，才能替换指定键的条目。

void

Provider.replaceAll​(BiFunction<? super Object,? super Object,? extends Object> function)

用条目集迭代器返回的顺序，直到所有的条目都被处理或函数抛出一个异常，替换每个条目的值，结果是对该条目调用给定的函数。

void

SecureRandom.setSeed​(long seed)

重新使用这个随机对象，使用给定的 long seed包含的八个字节。

String

CodeSource.toString​()

返回描述此CodeSource的字符串，告知其URL和证书。

String

DrbgParameters.Capability.toString​()

String

DrbgParameters.Instantiation.toString​()

返回此 Instantiation的人类可读字符串表示 Instantiation 。

String

PKCS12Attribute.toString​()

返回此 PKCS12Attribute的字符串表示 PKCS12Attribute 。

String

ProtectionDomain.toString​()

将ProtectionDomain转换为字符串。

String

SecureRandom.toString​()

返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

String

SecureRandomSpi.toString​()

返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

Collection<Object>

Provider.values​()

返回此提供程序中包含的属性值的不可修改的集合视图。

Uses of Override in java.security.cert

Methods in java.security.cert with annotations of type Override

Modifier and Type

方法

描述

void

PKIXCertPathChecker.check​(Certificate cert)

使用其内部状态对指定的证书执行检查。

Object

PKIXCertPathChecker.clone​()

返回此对象的克隆。

PKIXRevocationChecker

PKIXRevocationChecker.clone​()

URICertStoreParameters

URICertStoreParameters.clone​()

返回此对象的副本。

boolean

URICertStoreParameters.equals​(Object p)

将指定的对象与此参数对象进行比较以获得相等性。

String

CertificateRevokedException.getMessage​()

int

URICertStoreParameters.hashCode​()

返回此参数对象的哈希码值。

abstract void

PKIXCertPathChecker.init​(boolean forward)

初始化这个 PKIXCertPathChecker的内部状态。

abstract boolean

PKIXCertPathChecker.isForwardCheckingSupported​()

指示是否支持转发检查。

String

URICertStoreParameters.toString​()

返回描述包含用于构造此对象的URI的参数的格式化字符串。

Uses of Override in java.sql

Methods in java.sql with annotations of type Override

Modifier and Type

方法

描述

int

Timestamp.hashCode​()

返回此对象的哈希码值。

Instant

Date.toInstant​()

此方法总是引发UnsupportedOperationException，因为SQL Date值没有时间组件，因此不应该使用此方法。

Instant

Time.toInstant​()

此方法总是引发UnsupportedOperationException，因为SQL Time值不具有日期组件，因此不应该使用此方法。

Instant

Timestamp.toInstant​()

将此 Timestamp对象转换为 Instant 。

Uses of Override in java.text

Methods in java.text with annotations of type Override

Modifier and Type

方法

描述

Object

BreakIterator.clone​()

创建一个这个迭代器的副本

Object

Collator.clone​()

覆盖可克隆

Object

DecimalFormat.clone​()

标准覆盖 语义不变。

Object

DecimalFormatSymbols.clone​()

标准覆盖。

Object

NumberFormat.clone​()

覆盖可克隆。

Object

SimpleDateFormat.clone​()

创建一个这个 SimpleDateFormat的副本。

int

Collator.compare​(Object o1, Object o2)

比较其两个参数的顺序。

boolean

Collator.equals​(Object that)

比较两个Collator的平等。

boolean

DecimalFormat.equals​(Object obj)

覆盖等于

boolean

DecimalFormatSymbols.equals​(Object obj)

覆盖等于。

boolean

NumberFormat.equals​(Object obj)

覆盖等于。

boolean

SimpleDateFormat.equals​(Object obj)

将给定对象与此 SimpleDateFormat进行比较以获得相等性。

StringBuffer

DecimalFormat.format​(double number, StringBuffer result, FieldPosition fieldPosition)

格式化为一个字符串。

StringBuffer

DecimalFormat.format​(long number, StringBuffer result, FieldPosition fieldPosition)

格式化一个长的字符串。

StringBuffer

DecimalFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)

格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。

StringBuffer

NumberFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)

格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。

StringBuffer

SimpleDateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition pos)

将给定的 Date成日期/时间字符串，并将结果追加到给定的 StringBuffer 。

AttributedCharacterIterator

DecimalFormat.formatToCharacterIterator​(Object obj)

格式化一个对象，生成一个 AttributedCharacterIterator 。

AttributedCharacterIterator

SimpleDateFormat.formatToCharacterIterator​(Object obj)

格式化产生一个 AttributedCharacterIterator的对象。

Currency

DecimalFormat.getCurrency​()

在格式化货币值时获取此十进制格式使用的货币。

int

DecimalFormat.getMaximumFractionDigits​()

获取数字小数部分中允许的最大位数。

int

DecimalFormat.getMaximumIntegerDigits​()

获取数字的整数部分允许的最大位数。

int

DecimalFormat.getMinimumFractionDigits​()

获取数字小数部分中允许的最小位数。

int

DecimalFormat.getMinimumIntegerDigits​()

获取数字整数部分允许的最小位数。

RoundingMode

DecimalFormat.getRoundingMode​()

获取此DecimalFormat中使用的RoundingMode 。

abstract int

Collator.hashCode​()

生成此Collator的哈希码。

int

DateFormatSymbols.hashCode​()

覆盖hashCode。

int

DecimalFormat.hashCode​()

覆盖hashCode

int

DecimalFormatSymbols.hashCode​()

覆盖hashCode。

int

NumberFormat.hashCode​()

覆盖hashCode。

int

SimpleDateFormat.hashCode​()

返回此 SimpleDateFormat对象的哈希码值。

Number

DecimalFormat.parse​(String text, ParsePosition pos)

从字符串中解析文本，产生一个 Number 。

Date

SimpleDateFormat.parse​(String text, ParsePosition pos)

从字符串中解析文本，产生一个 Date 。

Object

NumberFormat.parseObject​(String source, ParsePosition pos)

从字符串中解析文本，产生一个 Number 。

protected Object

DateFormat.Field.readResolve​()

解析反序列化为预定义常量的实例。

protected Object

NumberFormat.Field.readResolve​()

解析反序列化为预定义常量的实例。

void

DecimalFormat.setCurrency​(Currency currency)

设置格式化货币值时此数字格式使用的货币。

void

DecimalFormat.setGroupingUsed​(boolean newValue)

设置是否以此格式使用分组。

void

DecimalFormat.setMaximumFractionDigits​(int newValue)

设置数字小数部分允许的最大位数。

void

DecimalFormat.setMaximumIntegerDigits​(int newValue)

设置数字的整数部分允许的最大位数。

void

DecimalFormat.setMinimumFractionDigits​(int newValue)

设置数字小数部分允许的最小位数。

void

DecimalFormat.setMinimumIntegerDigits​(int newValue)

设置数字的整数部分允许的最小位数。

void

DecimalFormat.setRoundingMode​(RoundingMode roundingMode)

设置此DecimalFormat中使用的RoundingMode 。

Uses of Override in java.time

Methods in java.time with annotations of type Override

Modifier and Type

方法

描述

Temporal

Duration.addTo​(Temporal temporal)

将此持续时间添加到指定的时间对象。

Temporal

Period.addTo​(Temporal temporal)

将此时段添加到指定的时间对象。

Temporal

DayOfWeek.adjustInto​(Temporal temporal)

将指定的时间对象调整为具有这一天的日期。

Temporal

Instant.adjustInto​(Temporal temporal)

调整指定的时间对象具有这个瞬间。

Temporal

LocalDate.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象的日期相同。

Temporal

LocalDateTime.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象具有相同的日期和时间。

Temporal

LocalTime.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象具有相同的时间。

Temporal

Month.adjustInto​(Temporal temporal)

将指定的时间对象调整为具有这个月的年份。

Temporal

MonthDay.adjustInto​(Temporal temporal)

将指定的时间对象调整为具有这个月日。

Temporal

OffsetDateTime.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象具有相同的偏移量，日期和时间。

Temporal

OffsetTime.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象具有相同的偏移量和时间。

Temporal

Year.adjustInto​(Temporal temporal)

调整指定的时间对象到今年。

Temporal

YearMonth.adjustInto​(Temporal temporal)

将指定的时间对象调整为今年。

Temporal

ZoneOffset.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象的偏移量相同。

LocalDateTime

LocalDate.atTime​(LocalTime time)

结合此日期与时间创建一个 LocalDateTime 。

ZonedDateTime

LocalDateTime.atZone​(ZoneId zone)

将此日期时间与时区相结合，创建一个 ZonedDateTime 。

int

Duration.compareTo​(Duration otherDuration)

将此持续时间与指定的 Duration 。

int

Instant.compareTo​(Instant otherInstant)

将此瞬间与指定的时刻进行比较。

int

LocalDate.compareTo​(ChronoLocalDate other)

将此日期与另一个日期进行比较。

int

LocalDateTime.compareTo​(ChronoLocalDateTime<?> other)

将此日期时间与其他日期时间进行比较。

int

LocalTime.compareTo​(LocalTime other)

比较这个时间到另一个时间。

int

MonthDay.compareTo​(MonthDay other)

比较这个月份到另一个月的日子。

int

OffsetDateTime.compareTo​(OffsetDateTime other)

将此日期时间与其他日期时间进行比较。

int

OffsetTime.compareTo​(OffsetTime other)

再比较这个 OffsetTime 。

int

Year.compareTo​(Year other)

今年再比较一年。

int

YearMonth.compareTo​(YearMonth other)

比较今年至另一个月。

int

ZoneOffset.compareTo​(ZoneOffset other)

将此偏移量与其他偏移量按降序进行比较。

boolean

Clock.equals​(Object obj)

检查这个时钟是否等于另一个时钟。

boolean

Duration.equals​(Object otherDuration)

检查此持续时间是否等于指定的 Duration 。

boolean

Instant.equals​(Object otherInstant)

检查这个瞬间是否等于指定的时刻。

boolean

LocalDate.equals​(Object obj)

检查这个日期是否等于另一个日期。

boolean

LocalDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

LocalTime.equals​(Object obj)

检查这次是否等于另一次。

boolean

MonthDay.equals​(Object obj)

检查这个月日是否等于另一个月 - 日。

boolean

OffsetDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

OffsetTime.equals​(Object obj)

检查这次是否等于另一次。

boolean

Period.equals​(Object obj)

检查此期间是否等于另一期间。

boolean

Year.equals​(Object obj)

检查今年是否等于另一年。

boolean

YearMonth.equals​(Object obj)

检查这个年月是否等于另一个一个月。

boolean

ZonedDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

ZoneId.equals​(Object obj)

检查此时区ID是否等于其他时区ID。

boolean

ZoneOffset.equals​(Object obj)

检查这个偏移量是否等于另一个偏移量。

String

LocalDate.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期。

String

LocalDateTime.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期时间。

String

ZonedDateTime.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期时间。

int

DayOfWeek.get​(TemporalField field)

从这个星期几获取指定字段的值作为 int 。

long

Duration.get​(TemporalUnit unit)

获取所请求单元的值。

int

Instant.get​(TemporalField field)

从该时刻获取指定字段的值作为 int 。

int

LocalDate.get​(TemporalField field)

从该日期获取指定字段的值作为 int 。

int

LocalDateTime.get​(TemporalField field)

从此日期时间获取指定字段的值作为 int 。

int

LocalTime.get​(TemporalField field)

从此时间获取指定字段的值为 int 。

int

Month.get​(TemporalField field)

从这个月份获取指定字段的值作为 int 。

int

MonthDay.get​(TemporalField field)

从这个月份获取指定字段的值作为 int 。

int

OffsetDateTime.get​(TemporalField field)

从此日期时间获取指定字段的值作为 int 。

int

OffsetTime.get​(TemporalField field)

从这个时间获取指定字段的值作为 int 。

long

Period.get​(TemporalUnit unit)

获取所请求单元的值。

int

Year.get​(TemporalField field)

从今年获取指定字段的值作为 int 。

int

YearMonth.get​(TemporalField field)

从本年度获取指定字段的值为 int 。

int

ZonedDateTime.get​(TemporalField field)

从此日期时间获取指定字段的值作为 int 。

int

ZoneOffset.get​(TemporalField field)

从该偏移量获取指定字段的值作为 int 。

IsoChronology

LocalDate.getChronology​()

获取这个日期的时间顺序，即ISO日历系统。

IsoChronology

Period.getChronology​()

获得这个时期的年表，即ISO日历系统。

IsoEra

LocalDate.getEra​()

获得这个时代适用的时代。

String

ZoneOffset.getId​()

获取标准化区域偏移ID。

long

DayOfWeek.getLong​(TemporalField field)

从这个星期几获取指定字段的值作为 long 。

long

Instant.getLong​(TemporalField field)

从该时刻获取指定字段的值作为 long 。

long

LocalDate.getLong​(TemporalField field)

从此日期获取指定字段的值作为 long 。

long

LocalDateTime.getLong​(TemporalField field)

从此日期时间获取指定字段的值作为 long 。

long

LocalTime.getLong​(TemporalField field)

从这个时间获取指定字段的值作为 long 。

long

Month.getLong​(TemporalField field)

从这个月份获取指定字段的值作为 long 。

long

MonthDay.getLong​(TemporalField field)

从这个月日获取指定字段的值作为 long 。

long

OffsetDateTime.getLong​(TemporalField field)

从此日期时间获取指定字段的值作为 long 。

long

OffsetTime.getLong​(TemporalField field)

从此时间获取指定字段的值为 long 。

long

Year.getLong​(TemporalField field)

从今年获取指定字段的值作为 long 。

long

YearMonth.getLong​(TemporalField field)

从本年度获取指定字段的值作为 long 。

long

ZonedDateTime.getLong​(TemporalField field)

从此日期时间获取指定字段的值作为 long 。

long

ZoneOffset.getLong​(TemporalField field)

从该偏移量获取指定字段的值作为 long 。

ZoneOffset

ZonedDateTime.getOffset​()

获取区域偏移量，例如“+01：00”。

ZoneRules

ZoneOffset.getRules​()

获取相关的时区规则。

List<TemporalUnit>

Duration.getUnits​()

获取此持续时间支持的单位集。

List<TemporalUnit>

Period.getUnits​()

获取此期间支持的单位集。

ZoneId

ZonedDateTime.getZone​()

获得时区，如“欧洲/巴黎”。

int

Clock.hashCode​()

这个时钟的哈希码。

int

Duration.hashCode​()

这个持续时间的哈希码。

int

Instant.hashCode​()

返回此时刻的哈希码。

int

LocalDate.hashCode​()

这个日期的哈希码。

int

LocalDateTime.hashCode​()

这个日期时间的哈希码。

int

LocalTime.hashCode​()

这个时候的哈希码。

int

MonthDay.hashCode​()

这个月的哈希码。

int

OffsetDateTime.hashCode​()

这个日期时间的哈希码。

int

OffsetTime.hashCode​()

这个时候的哈希码。

int

Period.hashCode​()

此期间的哈希码。

int

Year.hashCode​()

今年的哈希码。

int

YearMonth.hashCode​()

今年的哈希码。

int

ZonedDateTime.hashCode​()

这个日期时间的哈希码。

int

ZoneId.hashCode​()

此时区ID的哈希码。

int

ZoneOffset.hashCode​()

这个偏移的哈希码。

boolean

LocalDate.isAfter​(ChronoLocalDate other)

检查此日期是否在指定日期之后。

boolean

LocalDateTime.isAfter​(ChronoLocalDateTime<?> other)

检查这个日期时间是否在指定的日期之后。

boolean

LocalDate.isBefore​(ChronoLocalDate other)

检查此日期是否在指定日期之前。

boolean

LocalDateTime.isBefore​(ChronoLocalDateTime<?> other)

检查此日期时间是否在指定的日期时间之前。

boolean

LocalDate.isEqual​(ChronoLocalDate other)

检查此日期是否等于指定的日期。

boolean

LocalDateTime.isEqual​(ChronoLocalDateTime<?> other)

检查此日期时间是否等于指定的日期时间。

boolean

LocalDate.isLeapYear​()

根据ISO培训日历系统规则，检查年份是否是闰年。

boolean

DayOfWeek.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

Instant.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

Instant.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

LocalDate.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

LocalDate.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

LocalDateTime.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

LocalDateTime.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

LocalTime.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

LocalTime.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

Month.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

MonthDay.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

OffsetDateTime.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

OffsetDateTime.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

OffsetTime.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

OffsetTime.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

Year.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

Year.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

YearMonth.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

YearMonth.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

ZonedDateTime.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

ZonedDateTime.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

ZoneOffset.isSupported​(TemporalField field)

检查指定的字段是否受支持。

int

LocalDate.lengthOfMonth​()

返回由此日期表示的月份的长度。

int

LocalDate.lengthOfYear​()

返回由此日期表示的年份的长度。

Instant

Instant.minus​(long amountToSubtract, TemporalUnit unit)

返回此时刻的副本，减去指定的金额。

Instant

Instant.minus​(TemporalAmount amountToSubtract)

返回此时刻的副本，减去指定的金额。

LocalDate

LocalDate.minus​(long amountToSubtract, TemporalUnit unit)

返回此日期的副本，减去指定的金额。

LocalDate

LocalDate.minus​(TemporalAmount amountToSubtract)

返回此日期的副本，减去指定的金额。

LocalDateTime

LocalDateTime.minus​(long amountToSubtract, TemporalUnit unit)

返回此日期时间的副本，并减去指定的金额。

LocalDateTime

LocalDateTime.minus​(TemporalAmount amountToSubtract)

返回此日期时间的副本，并减去指定的金额。

LocalTime

LocalTime.minus​(long amountToSubtract, TemporalUnit unit)

返回此次的副本，减去指定的金额。

LocalTime

LocalTime.minus​(TemporalAmount amountToSubtract)

返回此次的副本，减去指定的金额。

OffsetDateTime

OffsetDateTime.minus​(long amountToSubtract, TemporalUnit unit)

返回此日期时间的副本，并减去指定的金额。

OffsetDateTime

OffsetDateTime.minus​(TemporalAmount amountToSubtract)

返回此日期时间的副本，并减去指定的金额。

OffsetTime

OffsetTime.minus​(long amountToSubtract, TemporalUnit unit)

返回此次的副本，减去指定的金额。

OffsetTime

OffsetTime.minus​(TemporalAmount amountToSubtract)

返回此次的副本，减去指定的金额。

Year

Year.minus​(long amountToSubtract, TemporalUnit unit)

返回今年的副本，减去指定的金额。

Year

Year.minus​(TemporalAmount amountToSubtract)

返回今年的副本，减去指定的金额。

YearMonth

YearMonth.minus​(long amountToSubtract, TemporalUnit unit)

返回减去指定数量的今年的副本。

YearMonth

YearMonth.minus​(TemporalAmount amountToSubtract)

返回减去指定数量的今年的副本。

ZonedDateTime

ZonedDateTime.minus​(long amountToSubtract, TemporalUnit unit)

返回此日期时间的副本，并减去指定的金额。

ZonedDateTime

ZonedDateTime.minus​(TemporalAmount amountToSubtract)

返回此日期时间的副本，并减去指定的金额。

Instant

Instant.plus​(long amountToAdd, TemporalUnit unit)

返回添加指定数量的此瞬间的副本。

Instant

Instant.plus​(TemporalAmount amountToAdd)

返回添加指定数量的此瞬间的副本。

LocalDate

LocalDate.plus​(long amountToAdd, TemporalUnit unit)

返回此日期的副本，并添加指定的金额。

LocalDate

LocalDate.plus​(TemporalAmount amountToAdd)

返回此日期的副本，并添加指定的金额。

LocalDateTime

LocalDateTime.plus​(long amountToAdd, TemporalUnit unit)

返回此日期时间的副本，并添加指定的数量。

LocalDateTime

LocalDateTime.plus​(TemporalAmount amountToAdd)

返回此日期时间的副本，并添加指定的数量。

LocalTime

LocalTime.plus​(long amountToAdd, TemporalUnit unit)

返回此时添加了指定数量的副本。

LocalTime

LocalTime.plus​(TemporalAmount amountToAdd)

返回此时添加了指定数量的副本。

OffsetDateTime

OffsetDateTime.plus​(long amountToAdd, TemporalUnit unit)

返回此日期时间的副本，并添加指定的数量。

OffsetDateTime

OffsetDateTime.plus​(TemporalAmount amountToAdd)

返回此日期时间的副本，并添加指定的数量。

OffsetTime

OffsetTime.plus​(long amountToAdd, TemporalUnit unit)

返回此时添加了指定数量的副本。

OffsetTime

OffsetTime.plus​(TemporalAmount amountToAdd)

返回此时添加了指定数量的副本。

Year

Year.plus​(long amountToAdd, TemporalUnit unit)

返回今年的副本，并附加指定的金额。

Year

Year.plus​(TemporalAmount amountToAdd)

返回今年的副本，并附加指定的金额。

YearMonth

YearMonth.plus​(long amountToAdd, TemporalUnit unit)

返回此年份的副本，并添加指定的金额。

YearMonth

YearMonth.plus​(TemporalAmount amountToAdd)

返回此年份的副本，并添加指定的金额。

ZonedDateTime

ZonedDateTime.plus​(long amountToAdd, TemporalUnit unit)

返回此日期时间的副本，并添加指定的数量。

ZonedDateTime

ZonedDateTime.plus​(TemporalAmount amountToAdd)

返回此日期时间的副本，并添加指定的数量。

<R> R

DayOfWeek.query​(TemporalQuery<R> query)

使用指定的查询查询此星期几。

<R> R

Instant.query​(TemporalQuery<R> query)

使用指定的查询查询此即时。

<R> R

LocalDate.query​(TemporalQuery<R> query)

使用指定的查询查询此日期。

<R> R

LocalDateTime.query​(TemporalQuery<R> query)

使用指定的查询查询此日期时间。

<R> R

LocalTime.query​(TemporalQuery<R> query)

此时使用指定的查询进行查询。

<R> R

Month.query​(TemporalQuery<R> query)

使用指定的查询查询此月份的一年。

<R> R

MonthDay.query​(TemporalQuery<R> query)

使用指定的查询查询此月日。

<R> R

OffsetDateTime.query​(TemporalQuery<R> query)

使用指定的查询查询此日期时间。

<R> R

OffsetTime.query​(TemporalQuery<R> query)

此时使用指定的查询进行查询。

<R> R

Year.query​(TemporalQuery<R> query)

今年查询使用指定的查询。

<R> R

YearMonth.query​(TemporalQuery<R> query)

使用指定的查询查询今年。

<R> R

ZonedDateTime.query​(TemporalQuery<R> query)

使用指定的查询查询此日期时间。

<R> R

ZoneOffset.query​(TemporalQuery<R> query)

使用指定的查询查询此偏移量。

ValueRange

DayOfWeek.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

Instant.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

LocalDate.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

LocalDateTime.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

LocalTime.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

Month.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

MonthDay.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

OffsetDateTime.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

OffsetTime.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

Year.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

YearMonth.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

ZonedDateTime.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

ZoneOffset.range​(TemporalField field)

获取指定字段的有效值的范围。

Temporal

Duration.subtractFrom​(Temporal temporal)

从指定的时间对象中减去此持续时间。

Temporal

Period.subtractFrom​(Temporal temporal)

从指定的时间对象中减去这个时间段。

long

LocalDate.toEpochDay​()

LocalDate

LocalDateTime.toLocalDate​()

获取此日期时间的 LocalDate部分。

LocalDate

ZonedDateTime.toLocalDate​()

获取此日期时间的 LocalDate部分。

LocalDateTime

ZonedDateTime.toLocalDateTime​()

获取此日期时间的 LocalDateTime部分。

LocalTime

LocalDateTime.toLocalTime​()

获得 LocalTime这个日期时间的一部分。

LocalTime

ZonedDateTime.toLocalTime​()

获得这个日期时间的 LocalTime部分。

String

Duration.toString​()

使用ISO-8601秒表示形式的字符串表示形式，如 PT8H6M12.345S 。

String

Instant.toString​()

此瞬间使用ISO-8601表示形式的字符串表示形式。

String

LocalDate.toString​()

输出此日期为 String ，如 2007-12-03 。

String

LocalDateTime.toString​()

将此日期时间输出为 String ，例如 2007-12-03T10:15:30 。

String

LocalTime.toString​()

此时输出为 String ，如 10:15 。

String

MonthDay.toString​()

本月产量为 String ，如 --12-03 。

String

OffsetDateTime.toString​()

将此日期时间输出为 String ，例如 2007-12-03T10:15:30+01:00 。

String

OffsetTime.toString​()

此时输出为 String ，如 10:15:30+01:00 。

String

Period.toString​()

输出这个时期为 String ，如 P6Y3M1D 。

String

Year.toString​()

今年产量为 String 。

String

YearMonth.toString​()

今年产量为 String ，如 2007-12 。

String

ZonedDateTime.toString​()

将此日期时间输出为 String ，如 2007-12-03T10:15:30+01:00[Europe/Paris] 。

String

ZoneId.toString​()

使用ID将该区域输出为 String 。

String

ZoneOffset.toString​()

使用归一化ID将此偏移量输出为 String 。

long

Instant.until​(Temporal endExclusive, TemporalUnit unit)

根据指定单位计算直到另一瞬间的时间量。

Period

LocalDate.until​(ChronoLocalDate endDateExclusive)

将此日期和其他日期之间的期间计算为 Period 。

long

LocalDate.until​(Temporal endExclusive, TemporalUnit unit)

根据指定的单位计算直到另一个日期的时间量。

long

LocalDateTime.until​(Temporal endExclusive, TemporalUnit unit)

根据指定的单位计算到另一个日期时间的时间量。

long

LocalTime.until​(Temporal endExclusive, TemporalUnit unit)

根据指定的单位计算直到另一次的时间量。

long

OffsetDateTime.until​(Temporal endExclusive, TemporalUnit unit)

根据指定的单位计算到另一个日期时间的时间量。

long

OffsetTime.until​(Temporal endExclusive, TemporalUnit unit)

根据指定的单位计算直到另一次的时间量。

long

Year.until​(Temporal endExclusive, TemporalUnit unit)

根据指定单位计算直到另一年的时间。

long

YearMonth.until​(Temporal endExclusive, TemporalUnit unit)

根据指定单位计算直到另一个一个月的时间量。

long

ZonedDateTime.until​(Temporal endExclusive, TemporalUnit unit)

根据指定的单位计算到另一个日期时间的时间量。

Instant

Instant.with​(TemporalAdjuster adjuster)

返回此瞬间的调整副本。

Instant

Instant.with​(TemporalField field, long newValue)

将指定的字段设置为新值返回此瞬间的副本。

LocalDate

LocalDate.with​(TemporalAdjuster adjuster)

返回此日期的调整副本。

LocalDate

LocalDate.with​(TemporalField field, long newValue)

返回此日期的副本，并将指定的字段设置为新值。

LocalDateTime

LocalDateTime.with​(TemporalAdjuster adjuster)

返回此日期时间的调整副本。

LocalDateTime

LocalDateTime.with​(TemporalField field, long newValue)

返回此日期时间的副本，并将指定的字段设置为新值。

LocalTime

LocalTime.with​(TemporalAdjuster adjuster)

返回此次调整后的副本。

LocalTime

LocalTime.with​(TemporalField field, long newValue)

返回此时间的副本，并将指定的字段设置为新值。

OffsetDateTime

OffsetDateTime.with​(TemporalAdjuster adjuster)

返回此日期时间的调整副本。

OffsetDateTime

OffsetDateTime.with​(TemporalField field, long newValue)

返回此日期时间的副本，并将指定的字段设置为新值。

OffsetTime

OffsetTime.with​(TemporalAdjuster adjuster)

返回此次调整后的副本。

OffsetTime

OffsetTime.with​(TemporalField field, long newValue)

返回此时间的副本，并将指定的字段设置为新值。

Year

Year.with​(TemporalAdjuster adjuster)

返回今年的调整副本。

Year

Year.with​(TemporalField field, long newValue)

返回今年的副本，并将指定的字段设置为新值。

YearMonth

YearMonth.with​(TemporalAdjuster adjuster)

返回今年的调整副本。

YearMonth

YearMonth.with​(TemporalField field, long newValue)

返回此年月份的副本，并将指定的字段设置为新值。

ZonedDateTime

ZonedDateTime.with​(TemporalAdjuster adjuster)

返回此日期时间的调整副本。

ZonedDateTime

ZonedDateTime.with​(TemporalField field, long newValue)

返回此日期时间的副本，并将指定的字段设置为新值。

ZonedDateTime

ZonedDateTime.withEarlierOffsetAtOverlap​()

返回此日期的副本，将区域偏移更改为本地时间线重叠处的两个有效偏移量的较早者。

ZonedDateTime

ZonedDateTime.withLaterOffsetAtOverlap​()

返回此日期的副本，将区域偏移更改为本地时间线重叠的两个有效偏移量的后面。

ZonedDateTime

ZonedDateTime.withZoneSameInstant​(ZoneId zone)

使用不同的时区返回此日期时间的副本，保留即时。

ZonedDateTime

ZonedDateTime.withZoneSameLocal​(ZoneId zone)

使用不同的时区返回此日期时间的副本，如果可能，保留本地日期时间。

Uses of Override in java.time.chrono

Methods in java.time.chrono with annotations of type Override

Modifier and Type

方法

描述

Temporal

ChronoPeriod.addTo​(Temporal temporal)

将此时段添加到指定的时间对象。

default Temporal

ChronoLocalDate.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象的日期相同。

default Temporal

ChronoLocalDateTime.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象具有相同的日期和时间。

default Temporal

Era.adjustInto​(Temporal temporal)

调整指定的时间对象与此对象具有相同的时代。

ChronoLocalDateTime<HijrahDate>

HijrahDate.atTime​(LocalTime localTime)

ChronoLocalDateTime<JapaneseDate>

JapaneseDate.atTime​(LocalTime localTime)

ChronoLocalDateTime<MinguoDate>

MinguoDate.atTime​(LocalTime localTime)

ChronoLocalDateTime<ThaiBuddhistDate>

ThaiBuddhistDate.atTime​(LocalTime localTime)

int

AbstractChronology.compareTo​(Chronology other)

将这个年表与另一个年表进行比较。

default int

ChronoLocalDate.compareTo​(ChronoLocalDate other)

将此日期与其他日期进行比较，包括年表。

default int

ChronoLocalDateTime.compareTo​(ChronoLocalDateTime<?> other)

将此日期时间与其他日期时间进行比较，包括年表。

int

Chronology.compareTo​(Chronology other)

将这个年表与另一个年表进行比较。

default int

ChronoZonedDateTime.compareTo​(ChronoZonedDateTime<?> other)

将此日期时间与其他日期时间进行比较，包括年表。

HijrahDate

HijrahChronology.date​(int prolepticYear, int month, int dayOfMonth)

在Hijrah日历系统中，从幼稚年份，月份和月份月份获取当地日期。

HijrahDate

HijrahChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)

从Hijrah日历系统的时代，年龄，月份和月份月份获取当地的日期。

HijrahDate

HijrahChronology.date​(TemporalAccessor temporal)

LocalDate

IsoChronology.date​(int prolepticYear, int month, int dayOfMonth)

从月度，月份和月份月份获取ISO本地日期。

LocalDate

IsoChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)

从时代，年龄，月份和月份的时代获得ISO本地日期。

LocalDate

IsoChronology.date​(TemporalAccessor temporal)

从另一个日期时间对象获取ISO本地日期。

JapaneseDate

JapaneseChronology.date​(int prolepticYear, int month, int dayOfMonth)

从日光年，月 - 日和日月份获取日本日历系统的当地日期。

JapaneseDate

JapaneseChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)

从日期，时代，月份和月份的时代，获取日本日历系统中的当地日期。

JapaneseDate

JapaneseChronology.date​(TemporalAccessor temporal)

MinguoDate

MinguoChronology.date​(int prolepticYear, int month, int dayOfMonth)

从月光年，月和月的月份中获取Minguo日历系统中的当地日期。

MinguoDate

MinguoChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)

从时代，年龄，月份和月份的时代，获得Minguo日历系统中的当地日期。

MinguoDate

MinguoChronology.date​(TemporalAccessor temporal)

ThaiBuddhistDate

ThaiBuddhistChronology.date​(int prolepticYear, int month, int dayOfMonth)

在泰国佛教日历系统中，从幼稚年份，月份和月份月份获取当地日期。

ThaiBuddhistDate

ThaiBuddhistChronology.date​(Era era, int yearOfEra, int month, int dayOfMonth)

从时代，年龄，月份和月份的时代，获得泰国佛教日历系统的当地日期。

ThaiBuddhistDate

ThaiBuddhistChronology.date​(TemporalAccessor temporal)

HijrahDate

HijrahChronology.dateEpochDay​(long epochDay)

从Hijrah日历系统中获取当地的日期。

LocalDate

IsoChronology.dateEpochDay​(long epochDay)

从时代获取ISO本地日期。

JapaneseDate

JapaneseChronology.dateEpochDay​(long epochDay)

在日历日历系统中从当天获取本地日期。

MinguoDate

MinguoChronology.dateEpochDay​(long epochDay)

从时代到日本的Minguo日历系统获取本地日期。

ThaiBuddhistDate

ThaiBuddhistChronology.dateEpochDay​(long epochDay)

从泰国佛教日历系统中获取当地的日期。

HijrahDate

HijrahChronology.dateNow​()

HijrahDate

HijrahChronology.dateNow​(Clock clock)

HijrahDate

HijrahChronology.dateNow​(ZoneId zone)

LocalDate

IsoChronology.dateNow​()

从默认时区的系统时钟获取当前的ISO本地日期。

LocalDate

IsoChronology.dateNow​(Clock clock)

从指定的时钟获取当前的ISO本地日期。

LocalDate

IsoChronology.dateNow​(ZoneId zone)

从指定时区的系统时钟获取当前的ISO本地日期。

JapaneseDate

JapaneseChronology.dateNow​()

JapaneseDate

JapaneseChronology.dateNow​(Clock clock)

JapaneseDate

JapaneseChronology.dateNow​(ZoneId zone)

MinguoDate

MinguoChronology.dateNow​()

MinguoDate

MinguoChronology.dateNow​(Clock clock)

MinguoDate

MinguoChronology.dateNow​(ZoneId zone)

ThaiBuddhistDate

ThaiBuddhistChronology.dateNow​()

ThaiBuddhistDate

ThaiBuddhistChronology.dateNow​(Clock clock)

ThaiBuddhistDate

ThaiBuddhistChronology.dateNow​(ZoneId zone)

HijrahDate

HijrahChronology.dateYearDay​(int prolepticYear, int dayOfYear)

从日光年和日间字段获取Hijrah日历系统中的当地日期。

HijrahDate

HijrahChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)

从Hijrah日历系统的时代，年龄和日期领域获得当地的日期。

LocalDate

IsoChronology.dateYearDay​(int prolepticYear, int dayOfYear)

从幼稚年份和日期字段获取ISO本地日期。

LocalDate

IsoChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)

从时代，年龄和日期的领域获得ISO本地日期。

JapaneseDate

JapaneseChronology.dateYearDay​(int prolepticYear, int dayOfYear)

从日光年和日期字段获取日语日历系统中的当地日期。

JapaneseDate

JapaneseChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)

从时代，年龄和日期领域获取日本日历系统中的当地日期。

MinguoDate

MinguoChronology.dateYearDay​(int prolepticYear, int dayOfYear)

从日光年和日期字段获取Minguo日历系统中的当地日期。

MinguoDate

MinguoChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)

从时代，年龄和日期领域获得Minguo日历系统中的当地日期。

ThaiBuddhistDate

ThaiBuddhistChronology.dateYearDay​(int prolepticYear, int dayOfYear)

在泰国佛教日历系统中，从幼稚年份和日期领域获得当地日期。

ThaiBuddhistDate

ThaiBuddhistChronology.dateYearDay​(Era era, int yearOfEra, int dayOfYear)

在泰国佛教日历系统中，从时代，年龄和日期领域获得当地日期。

long

IsoChronology.epochSecond​(int prolepticYear, int month, int dayOfMonth, int hour, int minute, int second, ZoneOffset zoneOffset)

从1970-01-01T00：00：00Z的时期获取秒数。

boolean

AbstractChronology.equals​(Object obj)

检查这个年表是否等于另一个年表。

boolean

ChronoLocalDate.equals​(Object obj)

检查这个日期是否等于另一个日期，包括年表。

boolean

ChronoLocalDateTime.equals​(Object obj)

检查这个日期时间是否等于另一个日期时间，包括年表。

boolean

Chronology.equals​(Object obj)

检查这个年表是否等于另一个年表。

boolean

ChronoPeriod.equals​(Object obj)

检查这个时期是否等于另一个时期，包括年表。

boolean

ChronoZonedDateTime.equals​(Object obj)

检查此日期时间是否等于另一个日期时间。

boolean

HijrahDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

boolean

JapaneseDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

boolean

MinguoDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

boolean

ThaiBuddhistDate.equals​(Object obj)

将此日期与其他日期进行比较，包括年表。

HijrahEra

HijrahChronology.eraOf​(int eraValue)

从数值创建HijrahEra对象。

IsoEra

IsoChronology.eraOf​(int eraValue)

JapaneseEra

JapaneseChronology.eraOf​(int eraValue)

从给定的数值返回日历系统时代对象。

MinguoEra

MinguoChronology.eraOf​(int eraValue)

ThaiBuddhistEra

ThaiBuddhistChronology.eraOf​(int eraValue)

List<Era>

HijrahChronology.eras​()

List<Era>

IsoChronology.eras​()

List<Era>

JapaneseChronology.eras​()

List<Era>

MinguoChronology.eras​()

List<Era>

ThaiBuddhistChronology.eras​()

long

ChronoPeriod.get​(TemporalUnit unit)

获取所请求单元的值。

default int

ChronoZonedDateTime.get​(TemporalField field)

default int

Era.get​(TemporalField field)

从该时代获取指定字段的值作为 int 。

String

HijrahChronology.getCalendarType​()

获取伊斯兰历法的日历类型。

String

IsoChronology.getCalendarType​()

获取底层日历系统的日历类型 - 'iso8601'。

String

JapaneseChronology.getCalendarType​()

获取基础日历系统的日历类型 - “日语”。

String

MinguoChronology.getCalendarType​()

获取底层日历系统的日历类型 - “roc”。

String

ThaiBuddhistChronology.getCalendarType​()

获取基础日历系统的日历类型 - “佛教”。

HijrahChronology

HijrahDate.getChronology​()

获得这个日期的年表，即Hijrah日历系统。

JapaneseChronology

JapaneseDate.getChronology​()

获得这个日期的年表，这是日本的日历系统。

MinguoChronology

MinguoDate.getChronology​()

获得这个日期的时间顺序，即Minguo日历系统。

ThaiBuddhistChronology

ThaiBuddhistDate.getChronology​()

获得这个日期的年表，这是泰国佛教日历系统。

String

JapaneseEra.getDisplayName​(TextStyle style, Locale locale)

获得这个时代的文字表现。

HijrahEra

HijrahDate.getEra​()

获得这个时代适用的时代。

JapaneseEra

JapaneseDate.getEra​()

获得这个时代适用的时代。

MinguoEra

MinguoDate.getEra​()

获得这个时代适用的时代。

ThaiBuddhistEra

ThaiBuddhistDate.getEra​()

获得这个时代适用的时代。

String

HijrahChronology.getId​()

获取年表的ID。

String

IsoChronology.getId​()

获取年表的ID - “ISO”。

String

JapaneseChronology.getId​()

获取年表的ID - “日语”。

String

MinguoChronology.getId​()

获取年代的ID - “Minguo”。

String

ThaiBuddhistChronology.getId​()

获取年代的ID - “泰国人”。

default long

ChronoZonedDateTime.getLong​(TemporalField field)

default long

Era.getLong​(TemporalField field)

从该时代获取指定字段的值作为 long 。

long

HijrahDate.getLong​(TemporalField field)

long

JapaneseDate.getLong​(TemporalField field)

long

MinguoDate.getLong​(TemporalField field)

long

ThaiBuddhistDate.getLong​(TemporalField field)

List<TemporalUnit>

ChronoPeriod.getUnits​()

获取此期间支持的单位集。

int

HijrahEra.getValue​()

获得数字时代 int价值。

int

IsoEra.getValue​()

获得数字时代 int价值。

int

JapaneseEra.getValue​()

获得数字时代 int价值。

int

MinguoEra.getValue​()

获得数字时代 int价值。

int

ThaiBuddhistEra.getValue​()

获得数字时代 int价值。

int

AbstractChronology.hashCode​()

这个年表的哈希码。

int

ChronoLocalDate.hashCode​()

这个日期的哈希码。

int

ChronoLocalDateTime.hashCode​()

这个日期时间的哈希码。

int

Chronology.hashCode​()

这个年表的哈希码。

int

ChronoPeriod.hashCode​()

此期间的哈希码。

int

ChronoZonedDateTime.hashCode​()

这个日期时间的哈希码。

int

HijrahDate.hashCode​()

这个日期的哈希码。

int

JapaneseDate.hashCode​()

这个日期的哈希码。

int

MinguoDate.hashCode​()

这个日期的哈希码。

int

ThaiBuddhistDate.hashCode​()

这个日期的哈希码。

boolean

HijrahChronology.isLeapYear​(long prolepticYear)

boolean

HijrahDate.isLeapYear​()

根据Hijrah日历系统规则检查年份是否是闰年。

boolean

IsoChronology.isLeapYear​(long prolepticYear)

根据ISO培训日历系统规则，检查年份是否是闰年。

boolean

JapaneseChronology.isLeapYear​(long prolepticYear)

检查指定年份是否是闰年。

boolean

MinguoChronology.isLeapYear​(long prolepticYear)

检查指定年份是否是闰年。

boolean

ThaiBuddhistChronology.isLeapYear​(long prolepticYear)

检查指定年份是否是闰年。

default boolean

ChronoLocalDate.isSupported​(TemporalField field)

检查指定的字段是否受支持。

default boolean

ChronoLocalDate.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

ChronoLocalDateTime.isSupported​(TemporalField field)

检查指定的字段是否受支持。

default boolean

ChronoLocalDateTime.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

boolean

ChronoZonedDateTime.isSupported​(TemporalField field)

检查指定的字段是否受支持。

default boolean

ChronoZonedDateTime.isSupported​(TemporalUnit unit)

检查指定的单位是否受支持。

default boolean

Era.isSupported​(TemporalField field)

检查指定的字段是否受支持。

boolean

JapaneseDate.isSupported​(TemporalField field)

检查指定的字段是否受支持。

int

HijrahDate.lengthOfMonth​()

返回由此日期表示的月份的长度。

int

JapaneseDate.lengthOfMonth​()

返回由此日期表示的月份的长度。

int

MinguoDate.lengthOfMonth​()

返回由此日期表示的月份的长度。

int

ThaiBuddhistDate.lengthOfMonth​()

返回由此日期表示的月份的长度。

int

HijrahDate.lengthOfYear​()

返回由此日期表示的年份的长度。

int

JapaneseDate.lengthOfYear​()

ChronoLocalDateTime<HijrahDate>

HijrahChronology.localDateTime​(TemporalAccessor temporal)

LocalDateTime

IsoChronology.localDateTime​(TemporalAccessor temporal)

从另一个日期时间对象获取ISO本地日期时间。

ChronoLocalDateTime<JapaneseDate>

JapaneseChronology.localDateTime​(TemporalAccessor temporal)

ChronoLocalDateTime<MinguoDate>

MinguoChronology.localDateTime​(TemporalAccessor temporal)

ChronoLocalDateTime<ThaiBuddhistDate>

ThaiBuddhistChronology.localDateTime​(TemporalAccessor temporal)

default ChronoLocalDate

ChronoLocalDate.minus​(long amountToSubtract, TemporalUnit unit)

返回与该对象相同类型的对象，并减去指定的时间段。

default ChronoLocalDate

ChronoLocalDate.minus​(TemporalAmount amount)

返回与该对象相同类型的对象，并减去一个数量。

default ChronoLocalDateTime<D>

ChronoLocalDateTime.minus​(long amountToSubtract, TemporalUnit unit)

返回与该对象相同类型的对象，并减去指定的时间段。

default ChronoLocalDateTime<D>

ChronoLocalDateTime.minus​(TemporalAmount amount)

返回与该对象相同类型的对象，并减去一个数量。

default ChronoZonedDateTime<D>

ChronoZonedDateTime.minus​(long amountToSubtract, TemporalUnit unit)

返回与该对象相同类型的对象，并减去指定的时间段。

default ChronoZonedDateTime<D>

ChronoZonedDateTime.minus​(TemporalAmount amount)

返回与该对象相同类型的对象，并减去一个数量。

HijrahDate

HijrahDate.minus​(long amountToSubtract, TemporalUnit unit)

HijrahDate

HijrahDate.minus​(TemporalAmount amount)

返回与该对象相同类型的对象，并减去一个数量。

JapaneseDate

JapaneseDate.minus​(long amountToAdd, TemporalUnit unit)

JapaneseDate

JapaneseDate.minus​(TemporalAmount amount)

返回与该对象相同类型的对象，并减去一个数量。

MinguoDate

MinguoDate.minus​(long amountToAdd, TemporalUnit unit)

MinguoDate

MinguoDate.minus​(TemporalAmount amount)

返回与该对象相同类型的对象，并减去一个数量。

ThaiBuddhistDate

ThaiBuddhistDate.minus​(long amountToAdd, TemporalUnit unit)

ThaiBuddhistDate

ThaiBuddhistDate.minus​(TemporalAmount amount)

返回与该对象相同类型的对象，并减去一个数量。

Period

IsoChronology.period​(int years, int months, int days)

根据几年，几个月和几天的时间表获得一段时间。

default ChronoLocalDate

ChronoLocalDate.plus​(long amountToAdd, TemporalUnit unit)

返回与此对象相同类型的对象，并添加指定的句点。

default ChronoLocalDate

ChronoLocalDate.plus​(TemporalAmount amount)

返回与此对象相同类型的对象，并添加一个金额。

ChronoLocalDateTime<D>

ChronoLocalDateTime.plus​(long amountToAdd, TemporalUnit unit)

返回与此对象相同类型的对象，并添加指定的句点。

default ChronoLocalDateTime<D>

ChronoLocalDateTime.plus​(TemporalAmount amount)

返回与此对象相同类型的对象，并添加一个金额。

ChronoZonedDateTime<D>

ChronoZonedDateTime.plus​(long amountToAdd, TemporalUnit unit)

返回与此对象相同类型的对象，并添加指定的句点。

default ChronoZonedDateTime<D>

ChronoZonedDateTime.plus​(TemporalAmount amount)

返回与此对象相同类型的对象，并添加一个金额。

HijrahDate

HijrahDate.plus​(long amountToAdd, TemporalUnit unit)

HijrahDate

HijrahDate.plus​(TemporalAmount amount)

返回与此对象相同类型的对象，并添加一个金额。

JapaneseDate

JapaneseDate.plus​(long amountToAdd, TemporalUnit unit)

JapaneseDate

JapaneseDate.plus​(TemporalAmount amount)

返回与此对象相同类型的对象，并添加一个金额。

MinguoDate

MinguoDate.plus​(long amountToAdd, TemporalUnit unit)

MinguoDate

MinguoDate.plus​(TemporalAmount amount)

返回与此对象相同类型的对象，并添加一个金额。

ThaiBuddhistDate

ThaiBuddhistDate.plus​(long amountToAdd, TemporalUnit unit)

ThaiBuddhistDate

ThaiBuddhistDate.plus​(TemporalAmount amount)

返回与此对象相同类型的对象，并添加一个金额。

int

HijrahChronology.prolepticYear​(Era era, int yearOfEra)

int

IsoChronology.prolepticYear​(Era era, int yearOfEra)

int

JapaneseChronology.prolepticYear​(Era era, int yearOfEra)

int

MinguoChronology.prolepticYear​(Era era, int yearOfEra)

int

ThaiBuddhistChronology.prolepticYear​(Era era, int yearOfEra)

default <R> R

ChronoLocalDate.query​(TemporalQuery<R> query)

使用指定的查询查询此日期。

default <R> R

ChronoLocalDateTime.query​(TemporalQuery<R> query)

使用指定的查询查询此日期时间。

default <R> R

ChronoZonedDateTime.query​(TemporalQuery<R> query)

使用指定的查询查询此日期时间。

default <R> R

Era.query​(TemporalQuery<R> query)

使用指定的查询查询此时代。

default ValueRange

ChronoZonedDateTime.range​(TemporalField field)

default ValueRange

Era.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

HijrahChronology.range​(ChronoField field)

ValueRange

HijrahDate.range​(TemporalField field)

ValueRange

HijrahEra.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

IsoChronology.range​(ChronoField field)

ValueRange

JapaneseChronology.range​(ChronoField field)

ValueRange

JapaneseDate.range​(TemporalField field)

ValueRange

JapaneseEra.range​(TemporalField field)

获取指定字段的有效值的范围。

ValueRange

MinguoChronology.range​(ChronoField field)

ValueRange

MinguoDate.range​(TemporalField field)

ValueRange

ThaiBuddhistChronology.range​(ChronoField field)

ValueRange

ThaiBuddhistDate.range​(TemporalField field)

ChronoLocalDate

AbstractChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

解析解析 ChronoField值到一个日期。

HijrahDate

HijrahChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

LocalDate

IsoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

解析解析中的 ChronoField的日期。

JapaneseDate

JapaneseChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

MinguoDate

MinguoChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

ThaiBuddhistDate

ThaiBuddhistChronology.resolveDate​(Map<TemporalField,Long> fieldValues, ResolverStyle resolverStyle)

Temporal

ChronoPeriod.subtractFrom​(Temporal temporal)

从指定的时间对象中减去这个时间段。

long

HijrahDate.toEpochDay​()

long

JapaneseDate.toEpochDay​()

long

MinguoDate.toEpochDay​()

long

ThaiBuddhistDate.toEpochDay​()

String

AbstractChronology.toString​()

输出这个年表为 String ，使用年表ID。

String

ChronoLocalDate.toString​()

将此日期输出为 String 。

String

ChronoLocalDateTime.toString​()

将此日期时间输出为 String 。

String

Chronology.toString​()

输出这个年表为 String 。

String

ChronoPeriod.toString​()

将此期间输出为 String 。

String

ChronoZonedDateTime.toString​()

将此日期时间输出为 String 。

String

JapaneseEra.toString​()

long

ChronoLocalDate.until​(Temporal endExclusive, TemporalUnit unit)

根据指定的单位计算直到另一个日期的时间量。

ChronoPeriod

HijrahDate.until​(ChronoLocalDate endDate)

ChronoPeriod

JapaneseDate.until​(ChronoLocalDate endDate)

ChronoPeriod

MinguoDate.until​(ChronoLocalDate endDate)

ChronoPeriod

ThaiBuddhistDate.until​(ChronoLocalDate endDate)

default ChronoLocalDate

ChronoLocalDate.with​(TemporalAdjuster adjuster)

通过进行调整，返回与该对象相同类型的调整对象。

default ChronoLocalDate

ChronoLocalDate.with​(TemporalField field, long newValue)

返回与该对象具有相同类型的对象，并更改指定的字段。

default ChronoLocalDateTime<D>

ChronoLocalDateTime.with​(TemporalAdjuster adjuster)

通过进行调整，返回与该对象相同类型的调整对象。

ChronoLocalDateTime<D>

ChronoLocalDateTime.with​(TemporalField field, long newValue)

返回与该对象具有相同类型的对象，并更改指定的字段。

default ChronoZonedDateTime<D>

ChronoZonedDateTime.with​(TemporalAdjuster adjuster)

通过进行调整，返回与该对象相同类型的调整对象。

ChronoZonedDateTime<D>

ChronoZonedDateTime.with​(TemporalField field, long newValue)

返回与该对象具有相同类型的对象，并更改指定的字段。

HijrahDate

HijrahDate.with​(TemporalAdjuster adjuster)

通过进行调整，返回与该对象相同类型的调整对象。

HijrahDate

HijrahDate.with​(TemporalField field, long newValue)

JapaneseDate

JapaneseDate.with​(TemporalAdjuster adjuster)

通过进行调整，返回与该对象相同类型的调整对象。

JapaneseDate

JapaneseDate.with​(TemporalField field, long newValue)

MinguoDate

MinguoDate.with​(TemporalAdjuster adjuster)

通过进行调整，返回与该对象相同类型的调整对象。

MinguoDate

MinguoDate.with​(TemporalField field, long newValue)

ThaiBuddhistDate

ThaiBuddhistDate.with​(TemporalAdjuster adjuster)

通过进行调整，返回与该对象相同类型的调整对象。

ThaiBuddhistDate

ThaiBuddhistDate.with​(TemporalField field, long newValue)

ChronoZonedDateTime<HijrahDate>

HijrahChronology.zonedDateTime​(Instant instant, ZoneId zone)

ChronoZonedDateTime<HijrahDate>

HijrahChronology.zonedDateTime​(TemporalAccessor temporal)

ZonedDateTime

IsoChronology.zonedDateTime​(Instant instant, ZoneId zone)

从一个 Instant获得这个年代的ISO分区日期。

ZonedDateTime

IsoChronology.zonedDateTime​(TemporalAccessor temporal)

从另一个日期时间对象获取ISO分区的日期时间。

ChronoZonedDateTime<JapaneseDate>

JapaneseChronology.zonedDateTime​(Instant instant, ZoneId zone)

ChronoZonedDateTime<JapaneseDate>

JapaneseChronology.zonedDateTime​(TemporalAccessor temporal)

ChronoZonedDateTime<MinguoDate>

MinguoChronology.zonedDateTime​(Instant instant, ZoneId zone)

ChronoZonedDateTime<MinguoDate>

MinguoChronology.zonedDateTime​(TemporalAccessor temporal)

ChronoZonedDateTime<ThaiBuddhistDate>

ThaiBuddhistChronology.zonedDateTime​(Instant instant, ZoneId zone)

ChronoZonedDateTime<ThaiBuddhistDate>

ThaiBuddhistChronology.zonedDateTime​(TemporalAccessor temporal)

Uses of Override in java.time.format

Methods in java.time.format with annotations of type Override

Modifier and Type

方法

描述

boolean

DecimalStyle.equals​(Object obj)

检查这个DecimalStyle是否等于另一个DecimalStyle。

int

DecimalStyle.hashCode​()

这个DecimalStyle的哈希码。

String

DateTimeFormatter.toString​()

返回底层格式化程序的描述。

String

DecimalStyle.toString​()

返回描述此DecimalStyle的字符串。

Uses of Override in java.time.temporal

Methods in java.time.temporal with annotations of type Override

Modifier and Type

方法

描述

<R extends Temporal>
R

ChronoUnit.addTo​(R temporal, long amount)

<R extends Temporal>
R

ChronoField.adjustInto​(R temporal, long newValue)

long

ChronoUnit.between​(Temporal temporal1Inclusive, Temporal temporal2Exclusive)

boolean

ValueRange.equals​(Object obj)

检查此范围是否等于另一个范围。

boolean

WeekFields.equals​(Object object)

检查这个 WeekFields是否等于指定的对象。

TemporalUnit

ChronoField.getBaseUnit​()

String

ChronoField.getDisplayName​(Locale locale)

Duration

ChronoUnit.getDuration​()

在ISO日历系统中获取本机的预计持续时间。

long

ChronoField.getFrom​(TemporalAccessor temporal)

TemporalUnit

ChronoField.getRangeUnit​()

int

ValueRange.hashCode​()

此范围的哈希码。

int

WeekFields.hashCode​()

这个 WeekFields哈希码。

boolean

ChronoField.isDateBased​()

检查此字段是否表示日期的组件。

boolean

ChronoUnit.isDateBased​()

检查本机是否是日期单位。

boolean

ChronoUnit.isDurationEstimated​()

检查单位的持续时间是否是估计。

boolean

ChronoField.isSupportedBy​(TemporalAccessor temporal)

boolean

ChronoUnit.isSupportedBy​(Temporal temporal)

boolean

ChronoField.isTimeBased​()

检查此字段是否表示时间的一个组成部分。

boolean

ChronoUnit.isTimeBased​()

检查本机是否是时间单位。

ValueRange

ChronoField.range​()

获取字段的有效值的范围。

ValueRange

ChronoField.rangeRefinedBy​(TemporalAccessor temporal)

String

ChronoField.toString​()

String

ChronoUnit.toString​()

String

TemporalField.toString​()

获取字段的描述性名称。

String

TemporalUnit.toString​()

获取单位的描述性名称。

String

ValueRange.toString​()

将此范围输出为 String 。

String

WeekFields.toString​()

这个 WeekFields实例的字符串表示形式。

Uses of Override in java.time.zone

Methods in java.time.zone with annotations of type Override

Modifier and Type

方法

描述

int

ZoneOffsetTransition.compareTo​(ZoneOffsetTransition transition)

根据转换时刻将此转换与另一个进行比较。

boolean

ZoneOffsetTransition.equals​(Object other)

检查这个对象是否等于另一个。

boolean

ZoneOffsetTransitionRule.equals​(Object otherRule)

检查这个对象是否等于另一个。

boolean

ZoneRules.equals​(Object otherRules)

检查这套规则是否等于另一个。

int

ZoneOffsetTransition.hashCode​()

返回一个合适的哈希码。

int

ZoneOffsetTransitionRule.hashCode​()

返回一个合适的哈希码。

int

ZoneRules.hashCode​()

返回给定 #equals的合适的哈希码。

String

ZoneOffsetTransition.toString​()

返回描述此对象的字符串。

String

ZoneOffsetTransitionRule.toString​()

返回描述此对象的字符串。

String

ZoneRules.toString​()

返回描述此对象的字符串。

Uses of Override in java.util

Methods in java.util with annotations of type Override

Modifier and Type

方法

描述

void

DoubleSummaryStatistics.accept​(double value)

在摘要信息中记录另一个值。

void

IntSummaryStatistics.accept​(int value)

在摘要信息中记录一个新值

void

LongSummaryStatistics.accept​(int value)

记录一个新的 int值的摘要信息。

void

LongSummaryStatistics.accept​(long value)

在摘要信息中记录一个新的 long值。

void

GregorianCalendar.add​(int field, int amount)

根据日历的规则，将指定的（已签名的）时间添加到给定的日历字段。

int

Spliterators.AbstractDoubleSpliterator.characteristics​()

返回此Spliterator及其元素的一组特征。

int

Spliterators.AbstractIntSpliterator.characteristics​()

返回此Spliterator及其元素的一组特征。

int

Spliterators.AbstractLongSpliterator.characteristics​()

返回此Spliterator及其元素的一组特征。

int

Spliterators.AbstractSpliterator.characteristics​()

返回此Spliterator及其元素的一组特征。

void

Properties.clear​()

Object

Calendar.clone​()

创建并返回此对象的副本。

Object

GregorianCalendar.clone​()

Object

HashMap.clone​()

返回此 HashMap实例的浅拷贝：键和值本身不被克隆。

Object

Locale.clone​()

覆盖可克隆。

Object

Properties.clone​()

int

Calendar.compareTo​(Calendar anotherCalendar)

比较由两个 Calendar对象表示的时间值（ Epoch的毫秒偏移量）。

V

HashMap.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

V

Hashtable.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

Object

Properties.compute​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

protected void

GregorianCalendar.computeFields​()

将时间值（从 Epoch的毫秒偏移）转换为日历字段值。

V

HashMap.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

V

Hashtable.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

Object

Properties.computeIfAbsent​(Object key, Function<? super Object,?> mappingFunction)

V

HashMap.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

V

Hashtable.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

Object

Properties.computeIfPresent​(Object key, BiFunction<? super Object,? super Object,?> remappingFunction)

protected void

GregorianCalendar.computeTime​()

将日历字段值转换为时间值（与 Epoch的毫秒偏移量）。

boolean

Properties.contains​(Object value)

boolean

Properties.containsKey​(Object key)

boolean

Properties.containsValue​(Object value)

Enumeration<Object>

Properties.elements​()

Set<Map.Entry<Object,Object>>

Properties.entrySet​()

boolean

Calendar.equals​(Object obj)

将此 Calendar与指定的 Object 。

boolean

GregorianCalendar.equals​(Object obj)

将此 GregorianCalendar与指定的 Object 。

boolean

Locale.equals​(Object obj)

如果此区域设置等于另一个对象，则返回true。

boolean

Locale.LanguageRange.equals​(Object obj)

将此对象与指定的对象进行比较。

boolean

Optional.equals​(Object obj)

指示一些其他对象是否等于此 Optional 。

boolean

OptionalDouble.equals​(Object obj)

指示某个其他对象是否等于此 OptionalDouble 。

boolean

OptionalInt.equals​(Object obj)

指示某个其他对象是否等于此 OptionalInt 。

boolean

OptionalLong.equals​(Object obj)

指示一些其他对象是否等于此 OptionalLong 。

boolean

Properties.equals​(Object o)

boolean

PropertyPermission.equals​(Object obj)

检查两个PropertyPermission对象是否相等。

long

Spliterators.AbstractDoubleSpliterator.estimateSize​()

返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果为无穷大，未知数或计算成本太高，则返回 Long.MAX_VALUE 。

long

Spliterators.AbstractIntSpliterator.estimateSize​()

返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。

long

Spliterators.AbstractLongSpliterator.estimateSize​()

返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计，如果为无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。

long

Spliterators.AbstractSpliterator.estimateSize​()

返回 Spliterator.forEachRemaining(java.util.function.Consumer<? super T>)遍历将遇到的元素数量的估计值，如果无穷大，未知或计算太贵，则返回 Long.MAX_VALUE 。

void

ArrayList.forEach​(Consumer<? super E> action)

void

HashMap.forEach​(BiConsumer<? super K,? super V> action)

void

Hashtable.forEach​(BiConsumer<? super K,? super V> action)

void

IdentityHashMap.forEach​(BiConsumer<? super K,? super V> action)

void

Properties.forEach​(BiConsumer<? super Object,? super Object> action)

void

TreeMap.forEach​(BiConsumer<? super K,? super V> action)

void

Vector.forEach​(Consumer<? super E> action)

void

WeakHashMap.forEach​(BiConsumer<? super K,? super V> action)

default void

PrimitiveIterator.OfDouble.forEachRemaining​(Consumer<? super Double> action)

对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。

default void

PrimitiveIterator.OfInt.forEachRemaining​(Consumer<? super Integer> action)

对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。

default void

PrimitiveIterator.OfLong.forEachRemaining​(Consumer<? super Long> action)

对每个剩余元素执行给定的操作，直到所有元素都被处理或动作引发异常。

default void

Spliterator.OfDouble.forEachRemaining​(Consumer<? super Double> action)

在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。

default void

Spliterator.OfDouble.forEachRemaining​(DoubleConsumer action)

default void

Spliterator.OfInt.forEachRemaining​(Consumer<? super Integer> action)

在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。

default void

Spliterator.OfInt.forEachRemaining​(IntConsumer action)

default void

Spliterator.OfLong.forEachRemaining​(Consumer<? super Long> action)

在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。

default void

Spliterator.OfLong.forEachRemaining​(LongConsumer action)

Object

Properties.get​(Object key)

S

ServiceLoader.Provider.get​()

返回提供者的一个实例。

String

PropertyPermission.getActions​()

返回动作的“规范字符串表示”。

int

GregorianCalendar.getActualMaximum​(int field)

返回此日历字段可能有，考虑到给定的时间值和的当前值中的最大值 getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和 getTimeZone方法。

int

GregorianCalendar.getActualMinimum​(int field)

返回此日历字段可能有，考虑到给定的时间值和的当前值的最小值 getFirstDayOfWeek ， getMinimalDaysInFirstWeek ， getGregorianChange和 getTimeZone方法。

String

GregorianCalendar.getCalendarType​()

作为日历类型返回 "gregory" 。

int

GregorianCalendar.getGreatestMinimum​(int field)

返回此 GregorianCalendar实例的给定日历字段的最高最小值。

int

GregorianCalendar.getLeastMaximum​(int field)

返回此 GregorianCalendar实例的给定日历字段的最低最大值。

int

GregorianCalendar.getMaximum​(int field)

返回此 GregorianCalendar实例的给定日历字段的 GregorianCalendar 。

int

GregorianCalendar.getMinimum​(int field)

返回此 GregorianCalendar实例的给定日历字段的 GregorianCalendar 。

V

HashMap.getOrDefault​(Object key, V defaultValue)

V

Hashtable.getOrDefault​(Object key, V defaultValue)

Object

Properties.getOrDefault​(Object key, Object defaultValue)

TimeZone

GregorianCalendar.getTimeZone​()

int

GregorianCalendar.getWeeksInWeekYear​()

返回周在数量 week year由这代表 GregorianCalendar 。

int

GregorianCalendar.getWeekYear​()

返回 270525241424985表示的 GregorianCalendar 。

int

Calendar.hashCode​()

返回此日历的哈希码。

int

GregorianCalendar.hashCode​()

生成此 GregorianCalendar对象的哈希码。

int

Locale.hashCode​()

覆盖hashCode。

int

Locale.LanguageRange.hashCode​()

返回对象的哈希码值。

int

Optional.hashCode​()

返回值的哈希码（如果存在），否则如果没有值，则 0 （零）。

int

OptionalDouble.hashCode​()

返回值的哈希码（如果存在），否则，如果没有值，则 0 （零）。

int

OptionalInt.hashCode​()

返回值的哈希码（如果存在），否则如果没有值，则 0 （零）。

int

OptionalLong.hashCode​()

返回值的哈希码（如果存在），否则如果没有值，则 0 （零）。

int

Properties.hashCode​()

int

PropertyPermission.hashCode​()

返回此对象的哈希码值。

boolean

PropertyPermission.implies​(Permission p)

检查此PropertyPermission对象是否“暗示”指定的权限。

boolean

Properties.isEmpty​()

boolean

GregorianCalendar.isWeekDateSupported​()

返回 true表示此 GregorianCalendar支持周日期。

Enumeration<Object>

Properties.keys​()

Set<Object>

Properties.keySet​()

V

HashMap.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)

如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。

V

Hashtable.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)

如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。

Object

Properties.merge​(Object key, Object value, BiFunction<? super Object,? super Object,?> remappingFunction)

PermissionCollection

PropertyPermission.newPermissionCollection​()

返回一个用于存储PropertyPermission对象的新的PermissionCollection对象。

default Double

PrimitiveIterator.OfDouble.next​()

返回迭代中的下一个元素。

default Integer

PrimitiveIterator.OfInt.next​()

返回迭代中的下一个元素。

default Long

PrimitiveIterator.OfLong.next​()

返回迭代中的下一个元素。

boolean

SimpleTimeZone.observesDaylightTime​()

如果这个 SimpleTimeZone观察到夏令时，则返回 true 。

Object

Properties.put​(Object key, Object value)

void

Properties.putAll​(Map<?,?> t)

V

HashMap.putIfAbsent​(K key, V value)

V

Hashtable.putIfAbsent​(K key, V value)

Object

Properties.putIfAbsent​(Object key, Object value)

protected void

Properties.rehash​()

boolean

HashMap.remove​(Object key, Object value)

boolean

Hashtable.remove​(Object key, Object value)

Object

Properties.remove​(Object key)

boolean

Properties.remove​(Object key, Object value)

boolean

ArrayList.removeIf​(Predicate<? super E> filter)

boolean

Vector.removeIf​(Predicate<? super E> filter)

V

HashMap.replace​(K key, V value)

boolean

HashMap.replace​(K key, V oldValue, V newValue)

V

Hashtable.replace​(K key, V value)

boolean

Hashtable.replace​(K key, V oldValue, V newValue)

Object

Properties.replace​(Object key, Object value)

boolean

Properties.replace​(Object key, Object oldValue, Object newValue)

V

TreeMap.replace​(K key, V value)

boolean

TreeMap.replace​(K key, V oldValue, V newValue)

void

ArrayList.replaceAll​(UnaryOperator<E> operator)

void

HashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)

void

Hashtable.replaceAll​(BiFunction<? super K,? super V,? extends V> function)

void

IdentityHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)

void

Properties.replaceAll​(BiFunction<? super Object,? super Object,?> function)

void

TreeMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)

void

Vector.replaceAll​(UnaryOperator<E> operator)

void

WeakHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)

void

GregorianCalendar.roll​(int field, boolean up)

在给定时间字段上添加或减少单个时间单位，而不改变较大的字段。

void

GregorianCalendar.roll​(int field, int amount)

向指定的日历字段添加签名金额，而不更改较大的字段。

void

GregorianCalendar.setTimeZone​(TimeZone zone)

void

GregorianCalendar.setWeekDate​(int weekYear, int weekOfYear, int dayOfWeek)

设置此 GregorianCalendar由日期符给出的日期- weekYear ， weekOfYear ，并 dayOfWeek 。

int

Properties.size​()

void

ArrayList.sort​(Comparator<? super E> c)

void

Vector.sort​(Comparator<? super E> c)

Spliterator<E>

ArrayList.spliterator​()

在此列表中的元素上创建late-binding和故障快速 Spliterator 。

default Spliterator<E>

Collection.spliterator​()

在此集合中的元素上创建一个Spliterator 。

Spliterator<E>

LinkedHashSet.spliterator​()

在此集合中的元素上创建 late-binding和 故障快速的 Spliterator 。

Spliterator<E>

LinkedList.spliterator​()

在此列表中的元素上创建late-binding和故障快速 Spliterator 。

default Spliterator<E>

List.spliterator​()

在此列表中的元素上创建一个Spliterator 。

default Spliterator<E>

Set.spliterator​()

在此集合中的元素上创建一个 Spliterator 。

default Spliterator<E>

SortedSet.spliterator​()

在此排序集中的元素上创建一个 Spliterator 。

Spliterator<E>

Vector.spliterator​()

在此列表中的元素上创建一个late-binding和故障快速的 Spliterator 。

String

Calendar.toString​()

返回此日历的字符串表示形式。

String

Currency.toString​()

返回此货币的ISO 4217货币代码。

String

DoubleSummaryStatistics.toString​()

返回适用于调试的此对象的非空字符串表示形式。

String

IntSummaryStatistics.toString​()

返回适用于调试的此对象的非空字符串表示形式。

String

Locale.LanguageRange.toString​()

返回此 LanguageRange对象的内容丰富的字符串表示，如果范围被加权且重量小于最大重量， LanguageRange包含语言范围和重量。

String

Locale.toString​()

返回此 Locale对象的字符串表示形式，由语言，国家/地区，变体，脚本和扩展名组成，如下所示：language +“_”+ country +“_”+（variant +“_＃”|“＃”）+脚本+“_”+扩展语言总是小写，国家总是大写，脚本总是标题大小写，而扩展名总是小写。

String

LongSummaryStatistics.toString​()

返回适用于调试的此对象的非空字符串表示形式。

String

Optional.toString​()

返回适用于调试的 Optional的非空字符串表示形式。

String

OptionalDouble.toString​()

返回适用于调试的 OptionalDouble的非空字符串表示形式。

String

OptionalInt.toString​()

返回适用于调试的 OptionalInt的非空字符串表示形式。

String

OptionalLong.toString​()

返回适用于调试的 OptionalLong的非空字符串表示形式。

String

Properties.toString​()

String

StringJoiner.toString​()

返回当前值，由的 prefix ，值加入迄今由分离 delimiter和 suffix ，除非没有元素已经在这种情况下，被添加 prefix + suffix或 emptyValue返回字符。

default boolean

Spliterator.OfDouble.tryAdvance​(Consumer<? super Double> action)

如果剩下的元素存在，执行给定的动作，返回true ; 否则返回false 。

boolean

Spliterator.OfDouble.tryAdvance​(DoubleConsumer action)

default boolean

Spliterator.OfInt.tryAdvance​(Consumer<? super Integer> action)

如果剩下的元素存在，执行给定的操作，返回true ; 否则返回false 。

boolean

Spliterator.OfInt.tryAdvance​(IntConsumer action)

default boolean

Spliterator.OfLong.tryAdvance​(Consumer<? super Long> action)

如果剩余的元素存在，执行给定的操作，返回true ; 否则返回false 。

boolean

Spliterator.OfLong.tryAdvance​(LongConsumer action)

Spliterator.OfDouble

Spliterator.OfDouble.trySplit​()

Spliterator.OfInt

Spliterator.OfInt.trySplit​()

Spliterator.OfLong

Spliterator.OfLong.trySplit​()

T_SPLITR

Spliterator.OfPrimitive.trySplit​()

Spliterator.OfDouble

Spliterators.AbstractDoubleSpliterator.trySplit​()

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

Spliterator.OfInt

Spliterators.AbstractIntSpliterator.trySplit​()

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

Spliterator.OfLong

Spliterators.AbstractLongSpliterator.trySplit​()

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

Spliterator<T>

Spliterators.AbstractSpliterator.trySplit​()

如果此分割器可以被分区，返回一个包含元素的Spliter，当从该方法返回时，它不会被该Spliter所覆盖。

Collection<Object>

Properties.values​()

Uses of Override in java.util.concurrent

Methods in java.util.concurrent with annotations of type Override

Modifier and Type

方法

描述

default V

ConcurrentMap.compute​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)

尝试计算指定密钥及其当前映射值的映射（如果没有当前映射，则 null ）。

default V

ConcurrentMap.computeIfAbsent​(K key, Function<? super K,? extends V> mappingFunction)

如果指定的键尚未与值相关联（或映射到 null ），则尝试使用给定的映射函数计算其值，并将其输入到此映射中，除非是 null 。

default V

ConcurrentMap.computeIfPresent​(K key, BiFunction<? super K,? super V,? extends V> remappingFunction)

如果指定的密钥的值存在且非空，则尝试计算给定密钥及其当前映射值的新映射。

default void

ConcurrentMap.forEach​(BiConsumer<? super K,? super V> action)

对此映射中的每个条目执行给定的操作，直到所有条目都被处理或操作引发异常。

default V

ConcurrentMap.getOrDefault​(Object key, V defaultValue)

返回指定键映射到的值，如果此映射不包含该键的映射，则返回 defaultValue 。

default V

ConcurrentMap.merge​(K key, V value, BiFunction<? super V,? super V,? extends V> remappingFunction)

如果指定的键尚未与值相关联或与null相关联，则将其与给定的非空值相关联。

default void

ConcurrentMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)

将每个条目的值替换为对该条目调用给定函数的结果，直到所有条目都被处理或该函数抛出异常。

Spliterator<E>

ConcurrentLinkedQueue.spliterator​()

返回此队列中的元素Spliterator 。

Uses of Override in java.util.logging

Methods in java.util.logging with annotations of type Override

Modifier and Type

方法

描述

void

ConsoleHandler.close​()

覆盖 StreamHandler.close做一个flush但不关闭输出流。

void

FileHandler.close​()

关闭所有文件。

void

MemoryHandler.close​()

关闭 Handler并释放所有相关资源。

void

SocketHandler.close​()

关闭此输出流。

void

StreamHandler.close​()

关闭当前的输出流。

boolean

Level.equals​(Object ox)

比较两个对象的值相等。

void

MemoryHandler.flush​()

对目标 Handler 。

void

StreamHandler.flush​()

刷新任何缓冲的消息。

String

SimpleFormatter.format​(LogRecord record)

格式化给定的LogRecord。

String

XMLFormatter.format​(LogRecord record)

将给定的消息格式化为XML。

String

XMLFormatter.getHead​(Handler h)

返回一组XML格式记录的标题字符串。

String

XMLFormatter.getTail​(Handler h)

返回一组XML格式记录的尾字符串。

int

Level.hashCode​()

生成哈希码。

boolean

MemoryHandler.isLoggable​(LogRecord record)

检查这个 Handler是否会将给定的 LogRecord实际记录到其内部缓冲区中。

boolean

StreamHandler.isLoggable​(LogRecord record)

检查这个 Handler是否会实际记录给定的 LogRecord 。

void

ConsoleHandler.publish​(LogRecord record)

发表 LogRecord 。

void

FileHandler.publish​(LogRecord record)

格式化并发布一个 LogRecord 。

void

MemoryHandler.publish​(LogRecord record)

将 LogRecord存储在内部缓冲区中。

void

SocketHandler.publish​(LogRecord record)

格式化并发布 LogRecord 。

void

StreamHandler.publish​(LogRecord record)

格式化并发布 LogRecord 。

void

StreamHandler.setEncoding​(String encoding)

设置（或更改）此 Handler使用的字符编码。

String

Level.toString​()

返回此级别的字符串表示形式。

Uses of Override in java.util.spi

Methods in java.util.spi with annotations of type Override

Modifier and Type

方法

描述

ResourceBundle

AbstractResourceBundleProvider.getBundle​(String baseName, Locale locale)

返回 ResourceBundle为给定 baseName和 locale 。

Uses of Override in java.util.stream

Methods in java.util.stream with annotations of type Override

Modifier and Type

方法

描述

void

DoubleStream.Builder.accept​(double t)

向要构建的流添加元素。

void

IntStream.Builder.accept​(int t)

向要构建的流添加元素。

void

LongStream.Builder.accept​(long t)

向要构建的流添加元素。

void

Stream.Builder.accept​(T t)

向要构建的流添加元素。

void

BaseStream.close​()

关闭此流，导致此流管道的所有关闭处理程序被调用。

PrimitiveIterator.OfDouble

DoubleStream.iterator​()

PrimitiveIterator.OfInt

IntStream.iterator​()

PrimitiveIterator.OfLong

LongStream.iterator​()

DoubleStream

DoubleStream.parallel​()

IntStream

IntStream.parallel​()

LongStream

LongStream.parallel​()

DoubleStream

DoubleStream.sequential​()

IntStream

IntStream.sequential​()

LongStream

LongStream.sequential​()

Spliterator.OfDouble

DoubleStream.spliterator​()

Spliterator.OfInt

IntStream.spliterator​()

Spliterator.OfLong

LongStream.spliterator​()

Uses of Override in java.util.zip

Methods in java.util.zip with annotations of type Override

Modifier and Type

方法

描述

long

Adler32.getValue​()

返回校验和值。

long

CRC32.getValue​()

返回CRC-32值。

long

CRC32C.getValue​()

返回CRC-32C值。

void

Adler32.reset​()

将校验和重置为初始值。

void

CRC32.reset​()

将CRC-32复位为初始值。

void

CRC32C.reset​()

将CRC-32C复位为初始值。

void

Adler32.update​(byte[] b, int off, int len)

用指定的字节数组更新校验和。

void

Adler32.update​(int b)

用指定的字节更新校验和（参数b的低8位）。

void

Adler32.update​(ByteBuffer buffer)

使用指定缓冲区的字节更新校验和。

void

CRC32.update​(byte[] b, int off, int len)

用指定的字节数组更新CRC-32校验和。

void

CRC32.update​(int b)

用指定的字节（参数b的低8位）更新CRC-32校验和。

void

CRC32.update​(ByteBuffer buffer)

用指定缓冲区的字节更新CRC-32校验和。

void

CRC32C.update​(byte[] b, int off, int len)

用指定的字节数组更新CRC-32C校验和。

void

CRC32C.update​(int b)

用指定的字节（参数b的低8位）更新CRC-32C校验和。

void

CRC32C.update​(ByteBuffer buffer)

用指定缓冲区的字节更新CRC-32C校验和。

Uses of Override in javafx.animation

Methods in javafx.animation with annotations of type Override

Modifier and Type

方法

描述

boolean

KeyFrame.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

KeyValue.equals​(Object obj)

指示一些其他对象是否等于此。

protected Node

ParallelTransition.getParentTargetNode​()

返回此Transition的动画的目标Transition 。

protected Node

SequentialTransition.getParentTargetNode​()

返回此Transition的动画的目标Transition 。

int

KeyFrame.hashCode​()

返回此 KeyFrame对象的哈希码。

int

KeyValue.hashCode​()

返回此 KeyValue对象的哈希码。

protected void

FadeTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

protected void

FillTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

protected void

ParallelTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

void

PathTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

void

PauseTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

protected void

RotateTransition.interpolate​(double frac)

该方法 interpolate()必须通过的实现来提供 Transition 。

void

ScaleTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

protected void

SequentialTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

protected void

StrokeTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

void

TranslateTransition.interpolate​(double frac)

方法 interpolate()必须由 Transition的实现来提供。

void

Timeline.stop​()

停止动画并将播放头重置到其初始位置。

String

KeyFrame.toString​()

返回此 KeyFrame对象的字符串表示形式。

String

KeyValue.toString​()

返回此 KeyValue对象的字符串表示形式。

Uses of Override in javafx.application

Methods in javafx.application with annotations of type Override

Modifier and Type

方法

描述

String

Preloader.ErrorNotification.toString​()

返回此 ErrorNotification对象的字符串表示形式。

Uses of Override in javafx.beans

Methods in javafx.beans with annotations of type Override

Modifier and Type

方法

描述

void

WeakInvalidationListener.invalidated​(Observable observable)

该方法需要通过 InvalidationListener的实现来提供。

boolean

WeakInvalidationListener.wasGarbageCollected​()

如果链接的侦听器被垃圾回收，则返回 true 。

Uses of Override in javafx.beans.binding

Methods in javafx.beans.binding with annotations of type Override

Modifier and Type

方法

描述

DoubleBinding

DoubleExpression.add​(double other)

DoubleBinding

DoubleExpression.add​(float other)

DoubleBinding

DoubleExpression.add​(int other)

DoubleBinding

DoubleExpression.add​(long other)

DoubleBinding

DoubleExpression.add​(ObservableNumberValue other)

DoubleBinding

FloatExpression.add​(double other)

FloatBinding

FloatExpression.add​(float other)

FloatBinding

FloatExpression.add​(int other)

FloatBinding

FloatExpression.add​(long other)

DoubleBinding

IntegerExpression.add​(double other)

FloatBinding

IntegerExpression.add​(float other)

IntegerBinding

IntegerExpression.add​(int other)

LongBinding

IntegerExpression.add​(long other)

void

ListExpression.add​(int i, E element)

boolean

ListExpression.add​(E element)

DoubleBinding

LongExpression.add​(double other)

FloatBinding

LongExpression.add​(float other)

LongBinding

LongExpression.add​(int other)

LongBinding

LongExpression.add​(long other)

NumberBinding

NumberExpressionBase.add​(ObservableNumberValue other)

boolean

SetExpression.add​(E element)

boolean

ListExpression.addAll​(int i, Collection<? extends E> elements)

boolean

ListExpression.addAll​(E... elements)

boolean

ListExpression.addAll​(Collection<? extends E> elements)

boolean

SetExpression.addAll​(Collection<? extends E> elements)

void

BooleanBinding.addListener​(InvalidationListener listener)

void

BooleanBinding.addListener​(ChangeListener<? super Boolean> listener)

void

DoubleBinding.addListener​(InvalidationListener listener)

void

DoubleBinding.addListener​(ChangeListener<? super Number> listener)

void

FloatBinding.addListener​(InvalidationListener listener)

void

FloatBinding.addListener​(ChangeListener<? super Number> listener)

void

IntegerBinding.addListener​(InvalidationListener listener)

void

IntegerBinding.addListener​(ChangeListener<? super Number> listener)

void

ListBinding.addListener​(InvalidationListener listener)

void

ListBinding.addListener​(ChangeListener<? super ObservableList<E>> listener)

void

ListBinding.addListener​(ListChangeListener<? super E> listener)

void

LongBinding.addListener​(InvalidationListener listener)

void

LongBinding.addListener​(ChangeListener<? super Number> listener)

void

MapBinding.addListener​(InvalidationListener listener)

void

MapBinding.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)

void

MapBinding.addListener​(MapChangeListener<? super K,? super V> listener)

void

ObjectBinding.addListener​(InvalidationListener listener)

void

ObjectBinding.addListener​(ChangeListener<? super T> listener)

void

SetBinding.addListener​(InvalidationListener listener)

void

SetBinding.addListener​(ChangeListener<? super ObservableSet<E>> listener)

void

SetBinding.addListener​(SetChangeListener<? super E> listener)

void

StringBinding.addListener​(InvalidationListener listener)

void

StringBinding.addListener​(ChangeListener<? super String> listener)

StringBinding

NumberExpressionBase.asString​()

StringBinding

NumberExpressionBase.asString​(String format)

StringBinding

NumberExpressionBase.asString​(Locale locale, String format)

void

ListExpression.clear​()

void

MapExpression.clear​()

void

SetExpression.clear​()

boolean

ListExpression.contains​(Object obj)

boolean

SetExpression.contains​(Object obj)

boolean

ListExpression.containsAll​(Collection<?> objects)

boolean

SetExpression.containsAll​(Collection<?> objects)

boolean

MapExpression.containsKey​(Object obj)

boolean

MapExpression.containsValue​(Object obj)

void

BooleanBinding.dispose​()

默认实现为 dispose()为空。

void

DoubleBinding.dispose​()

默认实现为 dispose() ，为空。

void

FloatBinding.dispose​()

默认实现为 dispose()为空。

void

IntegerBinding.dispose​()

默认实现为 dispose() ，为空。

void

ListBinding.dispose​()

默认实现为 dispose() ，为空。

void

LongBinding.dispose​()

默认实现为 dispose()为空。

void

MapBinding.dispose​()

默认实现为 dispose()为空。

void

ObjectBinding.dispose​()

默认实现为 dispose() ，为空。

void

SetBinding.dispose​()

默认实现为 dispose()为空。

void

StringBinding.dispose​()

默认实现为 dispose()为空。

DoubleBinding

DoubleExpression.divide​(double other)

DoubleBinding

DoubleExpression.divide​(float other)

DoubleBinding

DoubleExpression.divide​(int other)

DoubleBinding

DoubleExpression.divide​(long other)

DoubleBinding

DoubleExpression.divide​(ObservableNumberValue other)

DoubleBinding

FloatExpression.divide​(double other)

FloatBinding

FloatExpression.divide​(float other)

FloatBinding

FloatExpression.divide​(int other)

FloatBinding

FloatExpression.divide​(long other)

DoubleBinding

IntegerExpression.divide​(double other)

FloatBinding

IntegerExpression.divide​(float other)

IntegerBinding

IntegerExpression.divide​(int other)

LongBinding

IntegerExpression.divide​(long other)

DoubleBinding

LongExpression.divide​(double other)

FloatBinding

LongExpression.divide​(float other)

LongBinding

LongExpression.divide​(int other)

LongBinding

LongExpression.divide​(long other)

NumberBinding

NumberExpressionBase.divide​(ObservableNumberValue other)

double

DoubleExpression.doubleValue​()

double

FloatExpression.doubleValue​()

double

IntegerExpression.doubleValue​()

double

LongExpression.doubleValue​()

ReadOnlyBooleanProperty

ListBinding.emptyProperty​()

ReadOnlyBooleanProperty

MapBinding.emptyProperty​()

ReadOnlyBooleanProperty

SetBinding.emptyProperty​()

Set<Map.Entry<K,V>>

MapExpression.entrySet​()

float

DoubleExpression.floatValue​()

float

FloatExpression.floatValue​()

float

IntegerExpression.floatValue​()

float

LongExpression.floatValue​()

boolean

BooleanBinding.get​()

返回 BooleanBinding.computeValue()的结果。

double

DoubleBinding.get​()

返回 DoubleBinding.computeValue()的结果。

float

FloatBinding.get​()

返回 FloatBinding.computeValue()的结果。

int

IntegerBinding.get​()

返回 IntegerBinding.computeValue()的结果。

ObservableList<E>

ListBinding.get​()

返回 ListBinding.computeValue()的结果。

E

ListExpression.get​(int i)

long

LongBinding.get​()

返回 LongBinding.computeValue()的结果。

ObservableMap<K,V>

MapBinding.get​()

返回 MapBinding.computeValue()的结果。

V

MapExpression.get​(Object key)

T

ObjectBinding.get​()

返回 ObjectBinding.computeValue()的结果。

ObservableSet<E>

SetBinding.get​()

返回 SetBinding.computeValue()的结果。

String

StringBinding.get​()

返回 StringBinding.computeValue()的结果。

ObservableList<?>

BooleanBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

ObservableList<?>

DoubleBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

ObservableList<?>

FloatBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

ObservableList<?>

IntegerBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

ObservableList<?>

ListBinding.getDependencies​()

默认执行getDependencies() ，返回一个空的ObservableList 。

ObservableList<?>

LongBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

ObservableList<?>

MapBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

ObservableList<?>

ObjectBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

ObservableList<?>

SetBinding.getDependencies​()

默认实现getDependencies() ，返回一个空的ObservableList 。

ObservableList<?>

StringBinding.getDependencies​()

getDependencies()的默认实现返回一个空的ObservableList 。

Boolean

BooleanExpression.getValue​()

Double

DoubleExpression.getValue​()

Float

FloatExpression.getValue​()

Integer

IntegerExpression.getValue​()

ObservableList<E>

ListExpression.getValue​()

Long

LongExpression.getValue​()

ObservableMap<K,V>

MapExpression.getValue​()

T

ObjectExpression.getValue​()

ObservableSet<E>

SetExpression.getValue​()

String

StringExpression.getValue​()

BooleanBinding

NumberExpressionBase.greaterThan​(double other)

BooleanBinding

NumberExpressionBase.greaterThan​(float other)

BooleanBinding

NumberExpressionBase.greaterThan​(int other)

BooleanBinding

NumberExpressionBase.greaterThan​(long other)

BooleanBinding

NumberExpressionBase.greaterThan​(ObservableNumberValue other)

BooleanBinding

NumberExpressionBase.greaterThanOrEqualTo​(double other)

BooleanBinding

NumberExpressionBase.greaterThanOrEqualTo​(float other)

BooleanBinding

NumberExpressionBase.greaterThanOrEqualTo​(int other)

BooleanBinding

NumberExpressionBase.greaterThanOrEqualTo​(long other)

BooleanBinding

NumberExpressionBase.greaterThanOrEqualTo​(ObservableNumberValue other)

int

ListExpression.indexOf​(Object obj)

int

DoubleExpression.intValue​()

int

FloatExpression.intValue​()

int

IntegerExpression.intValue​()

int

LongExpression.intValue​()

void

BooleanBinding.invalidate​()

void

DoubleBinding.invalidate​()

void

FloatBinding.invalidate​()

void

IntegerBinding.invalidate​()

void

ListBinding.invalidate​()

void

LongBinding.invalidate​()

void

MapBinding.invalidate​()

void

ObjectBinding.invalidate​()

void

SetBinding.invalidate​()

void

StringBinding.invalidate​()

boolean

ListExpression.isEmpty​()

获取属性的值为空。

boolean

MapExpression.isEmpty​()

获取属性的值为空。

boolean

SetExpression.isEmpty​()

获取属性的值为空。

BooleanBinding

NumberExpressionBase.isEqualTo​(double other, double epsilon)

BooleanBinding

NumberExpressionBase.isEqualTo​(float other, double epsilon)

BooleanBinding

NumberExpressionBase.isEqualTo​(int other)

BooleanBinding

NumberExpressionBase.isEqualTo​(int other, double epsilon)

BooleanBinding

NumberExpressionBase.isEqualTo​(long other)

BooleanBinding

NumberExpressionBase.isEqualTo​(long other, double epsilon)

BooleanBinding

NumberExpressionBase.isEqualTo​(ObservableNumberValue other)

BooleanBinding

NumberExpressionBase.isEqualTo​(ObservableNumberValue other, double epsilon)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(double other, double epsilon)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(float other, double epsilon)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(int other)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(int other, double epsilon)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(long other)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(long other, double epsilon)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(ObservableNumberValue other)

BooleanBinding

NumberExpressionBase.isNotEqualTo​(ObservableNumberValue other, double epsilon)

boolean

BooleanBinding.isValid​()

boolean

DoubleBinding.isValid​()

boolean

FloatBinding.isValid​()

boolean

IntegerBinding.isValid​()

boolean

ListBinding.isValid​()

boolean

LongBinding.isValid​()

boolean

MapBinding.isValid​()

boolean

ObjectBinding.isValid​()

boolean

SetBinding.isValid​()

boolean

StringBinding.isValid​()

Iterator<E>

ListExpression.iterator​()

Iterator<E>

SetExpression.iterator​()

Set<K>

MapExpression.keySet​()

int

ListExpression.lastIndexOf​(Object obj)

BooleanBinding

NumberExpressionBase.lessThan​(double other)

BooleanBinding

NumberExpressionBase.lessThan​(float other)

BooleanBinding

NumberExpressionBase.lessThan​(int other)

BooleanBinding

NumberExpressionBase.lessThan​(long other)

BooleanBinding

NumberExpressionBase.lessThan​(ObservableNumberValue other)

BooleanBinding

NumberExpressionBase.lessThanOrEqualTo​(double other)

BooleanBinding

NumberExpressionBase.lessThanOrEqualTo​(float other)

BooleanBinding

NumberExpressionBase.lessThanOrEqualTo​(int other)

BooleanBinding

NumberExpressionBase.lessThanOrEqualTo​(long other)

BooleanBinding

NumberExpressionBase.lessThanOrEqualTo​(ObservableNumberValue other)

ListIterator<E>

ListExpression.listIterator​()

ListIterator<E>

ListExpression.listIterator​(int i)

long

DoubleExpression.longValue​()

long

FloatExpression.longValue​()

long

IntegerExpression.longValue​()

long

LongExpression.longValue​()

DoubleBinding

DoubleExpression.multiply​(double other)

DoubleBinding

DoubleExpression.multiply​(float other)

DoubleBinding

DoubleExpression.multiply​(int other)

DoubleBinding

DoubleExpression.multiply​(long other)

DoubleBinding

DoubleExpression.multiply​(ObservableNumberValue other)

DoubleBinding

FloatExpression.multiply​(double other)

FloatBinding

FloatExpression.multiply​(float other)

FloatBinding

FloatExpression.multiply​(int other)

FloatBinding

FloatExpression.multiply​(long other)

DoubleBinding

IntegerExpression.multiply​(double other)

FloatBinding

IntegerExpression.multiply​(float other)

IntegerBinding

IntegerExpression.multiply​(int other)

LongBinding

IntegerExpression.multiply​(long other)

DoubleBinding

LongExpression.multiply​(double other)

FloatBinding

LongExpression.multiply​(float other)

LongBinding

LongExpression.multiply​(int other)

LongBinding

LongExpression.multiply​(long other)

NumberBinding

NumberExpressionBase.multiply​(ObservableNumberValue other)

DoubleBinding

DoubleExpression.negate​()

FloatBinding

FloatExpression.negate​()

IntegerBinding

IntegerExpression.negate​()

LongBinding

LongExpression.negate​()

V

MapExpression.put​(K key, V value)

void

MapExpression.putAll​(Map<? extends K,? extends V> elements)

E

ListExpression.remove​(int i)

void

ListExpression.remove​(int from, int to)

boolean

ListExpression.remove​(Object obj)

V

MapExpression.remove​(Object obj)

boolean

SetExpression.remove​(Object obj)

boolean

ListExpression.removeAll​(E... elements)

boolean

ListExpression.removeAll​(Collection<?> objects)

boolean

SetExpression.removeAll​(Collection<?> objects)

void

BooleanBinding.removeListener​(InvalidationListener listener)

void

BooleanBinding.removeListener​(ChangeListener<? super Boolean> listener)

void

DoubleBinding.removeListener​(InvalidationListener listener)

void

DoubleBinding.removeListener​(ChangeListener<? super Number> listener)

void

FloatBinding.removeListener​(InvalidationListener listener)

void

FloatBinding.removeListener​(ChangeListener<? super Number> listener)

void

IntegerBinding.removeListener​(InvalidationListener listener)

void

IntegerBinding.removeListener​(ChangeListener<? super Number> listener)

void

ListBinding.removeListener​(InvalidationListener listener)

void

ListBinding.removeListener​(ChangeListener<? super ObservableList<E>> listener)

void

ListBinding.removeListener​(ListChangeListener<? super E> listener)

void

LongBinding.removeListener​(InvalidationListener listener)

void

LongBinding.removeListener​(ChangeListener<? super Number> listener)

void

MapBinding.removeListener​(InvalidationListener listener)

void

MapBinding.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)

void

MapBinding.removeListener​(MapChangeListener<? super K,? super V> listener)

void

ObjectBinding.removeListener​(InvalidationListener listener)

void

ObjectBinding.removeListener​(ChangeListener<? super T> listener)

void

SetBinding.removeListener​(InvalidationListener listener)

void

SetBinding.removeListener​(ChangeListener<? super ObservableSet<E>> listener)

void

SetBinding.removeListener​(SetChangeListener<? super E> listener)

void

StringBinding.removeListener​(InvalidationListener listener)

void

StringBinding.removeListener​(ChangeListener<? super String> listener)

boolean

ListExpression.retainAll​(E... elements)

boolean

ListExpression.retainAll​(Collection<?> objects)

boolean

SetExpression.retainAll​(Collection<?> objects)

E

ListExpression.set​(int i, E element)

boolean

ListExpression.setAll​(E... elements)

boolean

ListExpression.setAll​(Collection<? extends E> elements)

int

ListExpression.size​()

int

MapExpression.size​()

int

SetExpression.size​()

ReadOnlyIntegerProperty

ListBinding.sizeProperty​()

ReadOnlyIntegerProperty

MapBinding.sizeProperty​()

ReadOnlyIntegerProperty

SetBinding.sizeProperty​()

List<E>

ListExpression.subList​(int from, int to)

DoubleBinding

DoubleExpression.subtract​(double other)

DoubleBinding

DoubleExpression.subtract​(float other)

DoubleBinding

DoubleExpression.subtract​(int other)

DoubleBinding

DoubleExpression.subtract​(long other)

DoubleBinding

DoubleExpression.subtract​(ObservableNumberValue other)

DoubleBinding

FloatExpression.subtract​(double other)

FloatBinding

FloatExpression.subtract​(float other)

FloatBinding

FloatExpression.subtract​(int other)

FloatBinding

FloatExpression.subtract​(long other)

DoubleBinding

IntegerExpression.subtract​(double other)

FloatBinding

IntegerExpression.subtract​(float other)

IntegerBinding

IntegerExpression.subtract​(int other)

LongBinding

IntegerExpression.subtract​(long other)

DoubleBinding

LongExpression.subtract​(double other)

FloatBinding

LongExpression.subtract​(float other)

LongBinding

LongExpression.subtract​(int other)

LongBinding

LongExpression.subtract​(long other)

NumberBinding

NumberExpressionBase.subtract​(ObservableNumberValue other)

Object[]

ListExpression.toArray​()

<T> T[]

ListExpression.toArray​(T[] array)

Object[]

SetExpression.toArray​()

<T> T[]

SetExpression.toArray​(T[] array)

String

BooleanBinding.toString​()

返回此 BooleanBinding对象的字符串表示形式。

String

DoubleBinding.toString​()

返回此 DoubleBinding对象的字符串表示形式。

String

FloatBinding.toString​()

返回此 FloatBinding对象的字符串表示形式。

String

IntegerBinding.toString​()

返回此 IntegerBinding对象的字符串表示形式。

String

ListBinding.toString​()

返回此 ListBinding对象的字符串表示形式。

String

LongBinding.toString​()

返回此 LongBinding对象的字符串表示形式。

String

MapBinding.toString​()

返回此 MapBinding对象的字符串表示形式。

String

ObjectBinding.toString​()

返回此 ObjectBinding对象的字符串表示形式。

String

SetBinding.toString​()

返回此 SetBinding对象的字符串表示形式。

String

StringBinding.toString​()

返回此 StringBinding对象的字符串表示形式。

Collection<V>

MapExpression.values​()

Uses of Override in javafx.beans.property

Methods in javafx.beans.property with annotations of type Override

Modifier and Type

方法

描述

void

BooleanPropertyBase.addListener​(InvalidationListener listener)

void

BooleanPropertyBase.addListener​(ChangeListener<? super Boolean> listener)

void

DoublePropertyBase.addListener​(InvalidationListener listener)

void

DoublePropertyBase.addListener​(ChangeListener<? super Number> listener)

void

FloatPropertyBase.addListener​(InvalidationListener listener)

void

FloatPropertyBase.addListener​(ChangeListener<? super Number> listener)

void

IntegerPropertyBase.addListener​(InvalidationListener listener)

void

IntegerPropertyBase.addListener​(ChangeListener<? super Number> listener)

void

ListPropertyBase.addListener​(InvalidationListener listener)

void

ListPropertyBase.addListener​(ChangeListener<? super ObservableList<E>> listener)

void

ListPropertyBase.addListener​(ListChangeListener<? super E> listener)

void

LongPropertyBase.addListener​(InvalidationListener listener)

void

LongPropertyBase.addListener​(ChangeListener<? super Number> listener)

void

MapPropertyBase.addListener​(InvalidationListener listener)

void

MapPropertyBase.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)

void

MapPropertyBase.addListener​(MapChangeListener<? super K,? super V> listener)

void

ObjectPropertyBase.addListener​(InvalidationListener listener)

void

ObjectPropertyBase.addListener​(ChangeListener<? super T> listener)

void

ReadOnlyBooleanPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyBooleanPropertyBase.addListener​(ChangeListener<? super Boolean> listener)

void

ReadOnlyDoublePropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyDoublePropertyBase.addListener​(ChangeListener<? super Number> listener)

void

ReadOnlyFloatPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyFloatPropertyBase.addListener​(ChangeListener<? super Number> listener)

void

ReadOnlyIntegerPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyIntegerPropertyBase.addListener​(ChangeListener<? super Number> listener)

void

ReadOnlyListPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyListPropertyBase.addListener​(ChangeListener<? super ObservableList<E>> listener)

void

ReadOnlyListPropertyBase.addListener​(ListChangeListener<? super E> listener)

void

ReadOnlyLongPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyLongPropertyBase.addListener​(ChangeListener<? super Number> listener)

void

ReadOnlyMapPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyMapPropertyBase.addListener​(ChangeListener<? super ObservableMap<K,V>> listener)

void

ReadOnlyMapPropertyBase.addListener​(MapChangeListener<? super K,? super V> listener)

void

ReadOnlyObjectPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyObjectPropertyBase.addListener​(ChangeListener<? super T> listener)

void

ReadOnlySetPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlySetPropertyBase.addListener​(ChangeListener<? super ObservableSet<E>> listener)

void

ReadOnlySetPropertyBase.addListener​(SetChangeListener<? super E> listener)

void

ReadOnlyStringPropertyBase.addListener​(InvalidationListener listener)

void

ReadOnlyStringPropertyBase.addListener​(ChangeListener<? super String> listener)

void

SetPropertyBase.addListener​(InvalidationListener listener)

void

SetPropertyBase.addListener​(ChangeListener<? super ObservableSet<E>> listener)

void

SetPropertyBase.addListener​(SetChangeListener<? super E> listener)

void

StringPropertyBase.addListener​(InvalidationListener listener)

void

StringPropertyBase.addListener​(ChangeListener<? super String> listener)

ObjectProperty<Boolean>

BooleanProperty.asObject​()

创建一个ObjectProperty ，其值为BooleanProperty 。

ObjectProperty<Double>

DoubleProperty.asObject​()

创建一个ObjectProperty双向绑定到这个DoubleProperty 。

ObjectProperty<Float>

FloatProperty.asObject​()

创建一个27052524453260双向绑定到这个FloatProperty 。

ObjectProperty<Integer>

IntegerProperty.asObject​()

创建一个ObjectProperty双向绑定到这个IntegerProperty 。

ObjectProperty<Long>

LongProperty.asObject​()

创建一个ObjectProperty双向绑定到这个LongProperty 。

ReadOnlyObjectProperty<Boolean>

ReadOnlyBooleanProperty.asObject​()

创建一个ReadOnlyObjectProperty ，其值为ReadOnlyBooleanProperty 。

ReadOnlyObjectProperty<Double>

ReadOnlyDoubleProperty.asObject​()

创建一个ReadOnlyObjectProperty ，其值为ReadOnlyDoubleProperty 。

ReadOnlyObjectProperty<Float>

ReadOnlyFloatProperty.asObject​()

创建一个ReadOnlyObjectProperty ，其值为ReadOnlyFloatProperty 。

ReadOnlyObjectProperty<Integer>

ReadOnlyIntegerProperty.asObject​()

创建一个持有ReadOnlyIntegerProperty的价值的ReadOnlyIntegerProperty 。

ReadOnlyObjectProperty<Long>

ReadOnlyLongProperty.asObject​()

创建一个ReadOnlyObjectProperty ，其值为ReadOnlyLongProperty 。

void

BooleanPropertyBase.bind​(ObservableValue<? extends Boolean> rawObservable)

为此创建一个单向绑定 Property 。

void

DoublePropertyBase.bind​(ObservableValue<? extends Number> rawObservable)

为此 Property创建一个单向绑定。

void

FloatPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)

为此创建一个单向绑定 Property 。

void

IntegerPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)

为此创建一个单向绑定 Property 。

void

ListPropertyBase.bind​(ObservableValue<? extends ObservableList<E>> newObservable)

void

LongPropertyBase.bind​(ObservableValue<? extends Number> rawObservable)

为此创建一个单向绑定 Property 。

void

MapPropertyBase.bind​(ObservableValue<? extends ObservableMap<K,V>> newObservable)

void

ObjectPropertyBase.bind​(ObservableValue<? extends T> newObservable)

为此 Property创建一个单向绑定。

void

SetPropertyBase.bind​(ObservableValue<? extends ObservableSet<E>> newObservable)

void

StringPropertyBase.bind​(ObservableValue<? extends String> newObservable)

为此创建一个单向绑定 Property 。

void

BooleanProperty.bindBidirectional​(Property<Boolean> other)

在这个 Property和另一个之间创建双向绑定。

void

DoubleProperty.bindBidirectional​(Property<Number> other)

在这个 Property和另一个之间创建双向绑定。

void

FloatProperty.bindBidirectional​(Property<Number> other)

在这个 Property和另一个之间创建双向绑定。

void

IntegerProperty.bindBidirectional​(Property<Number> other)

在这个 Property和另一个之间创建双向绑定。

void

ListProperty.bindBidirectional​(Property<ObservableList<E>> other)

在这个 Property和另一个之间创建双向绑定。

void

LongProperty.bindBidirectional​(Property<Number> other)

在这个 Property和另一个之间创建双向绑定。

void

MapProperty.bindBidirectional​(Property<ObservableMap<K,V>> other)

在这个 Property和另一个之间创建双向绑定。

void

ObjectProperty.bindBidirectional​(Property<T> other)

在这个 Property之间创建一个双向绑定。

void

SetProperty.bindBidirectional​(Property<ObservableSet<E>> other)

在这个 Property和另一个之间创建双向绑定。

void

StringProperty.bindBidirectional​(Property<String> other)

在这个 Property和另一个之间创建双向绑定。

ReadOnlyBooleanProperty

ListPropertyBase.emptyProperty​()

ReadOnlyBooleanProperty

MapPropertyBase.emptyProperty​()

ReadOnlyBooleanProperty

SetPropertyBase.emptyProperty​()

boolean

ReadOnlyListProperty.equals​(Object obj)

boolean

ReadOnlyMapProperty.equals​(Object obj)

boolean

ReadOnlySetProperty.equals​(Object obj)

protected void

ReadOnlyBooleanWrapper.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

protected void

ReadOnlyDoubleWrapper.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

protected void

ReadOnlyFloatWrapper.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

protected void

ReadOnlyIntegerWrapper.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

protected void

ReadOnlyListWrapper.fireValueChangedEvent​()

发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。

protected void

ReadOnlyListWrapper.fireValueChangedEvent​(ListChangeListener.Change<? extends E> change)

发送通知到所有连接InvalidationListeners ， ChangeListeners ，并ListChangeListener 。

protected void

ReadOnlyLongWrapper.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

protected void

ReadOnlyMapWrapper.fireValueChangedEvent​()

发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。

protected void

ReadOnlyMapWrapper.fireValueChangedEvent​(MapChangeListener.Change<? extends K,? extends V> change)

发送通知到所有连接InvalidationListeners ， ChangeListeners ，并MapChangeListener 。

protected void

ReadOnlyObjectWrapper.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

protected void

ReadOnlySetWrapper.fireValueChangedEvent​()

发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。

protected void

ReadOnlySetWrapper.fireValueChangedEvent​(SetChangeListener.Change<? extends E> change)

发送通知到所有连接InvalidationListeners ， ChangeListeners ，并SetChangeListener 。

protected void

ReadOnlyStringWrapper.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

boolean

BooleanPropertyBase.get​()

获取包装的值。

double

DoublePropertyBase.get​()

获取包装的值。

float

FloatPropertyBase.get​()

获取包装的值。

int

IntegerPropertyBase.get​()

获取包装的值。

ObservableList<E>

ListPropertyBase.get​()

long

LongPropertyBase.get​()

获取包装的值。

ObservableMap<K,V>

MapPropertyBase.get​()

T

ObjectPropertyBase.get​()

获取包装的值。

ObservableSet<E>

SetPropertyBase.get​()

String

StringPropertyBase.get​()

获取包装的值。

Object

SimpleBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleListProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleLongProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleMapProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleSetProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStringProperty.getBean​()

返回包含此属性的 Object 。

String

SimpleBooleanProperty.getName​()

返回此属性的名称。

String

SimpleDoubleProperty.getName​()

返回此属性的名称。

String

SimpleFloatProperty.getName​()

返回此属性的名称。

String

SimpleIntegerProperty.getName​()

返回此属性的名称。

String

SimpleListProperty.getName​()

返回此属性的名称。

String

SimpleLongProperty.getName​()

返回此属性的名称。

String

SimpleMapProperty.getName​()

返回此属性的名称。

String

SimpleObjectProperty.getName​()

返回此属性的名称。

String

SimpleSetProperty.getName​()

返回此属性的名称。

String

SimpleStringProperty.getName​()

返回此属性的名称。

int

ReadOnlyListProperty.hashCode​()

int

ReadOnlyMapProperty.hashCode​()

返回此 ReadOnlyMapProperty对象的哈希码。

int

ReadOnlySetProperty.hashCode​()

返回此 ReadOnlySetProperty对象的哈希码。

boolean

BooleanPropertyBase.isBound​()

可以用来检查，如果一个 Property被绑定。

boolean

DoublePropertyBase.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

FloatPropertyBase.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

IntegerPropertyBase.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

ListPropertyBase.isBound​()

boolean

LongPropertyBase.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

MapPropertyBase.isBound​()

boolean

ObjectPropertyBase.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

SetPropertyBase.isBound​()

boolean

StringPropertyBase.isBound​()

可以用来检查，如果一个 Property是绑定的。

void

BooleanPropertyBase.removeListener​(InvalidationListener listener)

void

BooleanPropertyBase.removeListener​(ChangeListener<? super Boolean> listener)

void

DoublePropertyBase.removeListener​(InvalidationListener listener)

void

DoublePropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

FloatPropertyBase.removeListener​(InvalidationListener listener)

void

FloatPropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

IntegerPropertyBase.removeListener​(InvalidationListener listener)

void

IntegerPropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

ListPropertyBase.removeListener​(InvalidationListener listener)

void

ListPropertyBase.removeListener​(ChangeListener<? super ObservableList<E>> listener)

void

ListPropertyBase.removeListener​(ListChangeListener<? super E> listener)

void

LongPropertyBase.removeListener​(InvalidationListener listener)

void

LongPropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

MapPropertyBase.removeListener​(InvalidationListener listener)

void

MapPropertyBase.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)

void

MapPropertyBase.removeListener​(MapChangeListener<? super K,? super V> listener)

void

ObjectPropertyBase.removeListener​(InvalidationListener listener)

void

ObjectPropertyBase.removeListener​(ChangeListener<? super T> listener)

void

ReadOnlyBooleanPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyBooleanPropertyBase.removeListener​(ChangeListener<? super Boolean> listener)

void

ReadOnlyDoublePropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyDoublePropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

ReadOnlyFloatPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyFloatPropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

ReadOnlyIntegerPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyIntegerPropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

ReadOnlyListPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyListPropertyBase.removeListener​(ChangeListener<? super ObservableList<E>> listener)

void

ReadOnlyListPropertyBase.removeListener​(ListChangeListener<? super E> listener)

void

ReadOnlyLongPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyLongPropertyBase.removeListener​(ChangeListener<? super Number> listener)

void

ReadOnlyMapPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyMapPropertyBase.removeListener​(ChangeListener<? super ObservableMap<K,V>> listener)

void

ReadOnlyMapPropertyBase.removeListener​(MapChangeListener<? super K,? super V> listener)

void

ReadOnlyObjectPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyObjectPropertyBase.removeListener​(ChangeListener<? super T> listener)

void

ReadOnlySetPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlySetPropertyBase.removeListener​(ChangeListener<? super ObservableSet<E>> listener)

void

ReadOnlySetPropertyBase.removeListener​(SetChangeListener<? super E> listener)

void

ReadOnlyStringPropertyBase.removeListener​(InvalidationListener listener)

void

ReadOnlyStringPropertyBase.removeListener​(ChangeListener<? super String> listener)

void

SetPropertyBase.removeListener​(InvalidationListener listener)

void

SetPropertyBase.removeListener​(ChangeListener<? super ObservableSet<E>> listener)

void

SetPropertyBase.removeListener​(SetChangeListener<? super E> listener)

void

StringPropertyBase.removeListener​(InvalidationListener listener)

void

StringPropertyBase.removeListener​(ChangeListener<? super String> listener)

void

BooleanPropertyBase.set​(boolean newValue)

设置包装的值。

void

DoublePropertyBase.set​(double newValue)

设置包装的值。

void

FloatPropertyBase.set​(float newValue)

设置包装的值。

void

IntegerPropertyBase.set​(int newValue)

设置包装的值。

void

ListPropertyBase.set​(ObservableList<E> newValue)

void

LongPropertyBase.set​(long newValue)

设置包装的值。

void

MapPropertyBase.set​(ObservableMap<K,V> newValue)

void

ObjectPropertyBase.set​(T newValue)

设置包装的值。

void

SetPropertyBase.set​(ObservableSet<E> newValue)

void

StringPropertyBase.set​(String newValue)

设置包装的值。

void

BooleanProperty.setValue​(Boolean v)

设置包装的值。

void

DoubleProperty.setValue​(Number v)

设置包装的值。

void

FloatProperty.setValue​(Number v)

设置包装的值。

void

IntegerProperty.setValue​(Number v)

设置包装的值。

void

ListProperty.setValue​(ObservableList<E> v)

设置包装的值。

void

LongProperty.setValue​(Number v)

设置包装的值。

void

MapProperty.setValue​(ObservableMap<K,V> v)

设置包装的值。

void

ObjectProperty.setValue​(T v)

设置包装的值。

void

SetProperty.setValue​(ObservableSet<E> v)

设置包装的值。

void

StringProperty.setValue​(String v)

设置包装的值。

ReadOnlyIntegerProperty

ListPropertyBase.sizeProperty​()

ReadOnlyIntegerProperty

MapPropertyBase.sizeProperty​()

ReadOnlyIntegerProperty

SetPropertyBase.sizeProperty​()

String

BooleanProperty.toString​()

返回此 BooleanProperty对象的字符串表示形式。

String

BooleanPropertyBase.toString​()

返回此 BooleanPropertyBase对象的字符串表示形式。

String

DoubleProperty.toString​()

返回此 DoubleProperty对象的字符串表示形式。

String

DoublePropertyBase.toString​()

返回此 DoublePropertyBase对象的字符串表示形式。

String

FloatProperty.toString​()

返回此 FloatProperty对象的字符串表示形式。

String

FloatPropertyBase.toString​()

返回此 FloatPropertyBase对象的字符串表示形式。

String

IntegerProperty.toString​()

返回此 IntegerProperty对象的字符串表示形式。

String

IntegerPropertyBase.toString​()

返回此 IntegerPropertyBase对象的字符串表示形式。

String

ListProperty.toString​()

返回此 ListProperty对象的字符串表示形式。

String

ListPropertyBase.toString​()

返回此 ListPropertyBase对象的字符串表示形式。

String

LongProperty.toString​()

返回此 LongProperty对象的字符串表示形式。

String

LongPropertyBase.toString​()

返回此 LongPropertyBase对象的字符串表示形式。

String

MapProperty.toString​()

返回此 MapProperty对象的字符串表示形式。

String

MapPropertyBase.toString​()

返回此 MapPropertyBase对象的字符串表示形式。

String

ObjectProperty.toString​()

返回此 ObjectProperty对象的字符串表示形式。

String

ObjectPropertyBase.toString​()

返回此 ObjectPropertyBase对象的字符串表示形式。

String

ReadOnlyBooleanProperty.toString​()

返回此 ReadOnlyBooleanProperty对象的字符串表示形式。

String

ReadOnlyDoubleProperty.toString​()

返回此 ReadOnlyDoubleProperty对象的字符串表示形式。

String

ReadOnlyFloatProperty.toString​()

返回此 ReadOnlyFloatProperty对象的字符串表示形式。

String

ReadOnlyIntegerProperty.toString​()

返回此 ReadOnlyIntegerProperty对象的字符串表示形式。

String

ReadOnlyListProperty.toString​()

返回此 ReadOnlyListProperty对象的字符串表示形式。

String

ReadOnlyLongProperty.toString​()

返回此 ReadOnlyLongProperty对象的字符串表示形式。

String

ReadOnlyMapProperty.toString​()

返回此 ReadOnlyMapProperty对象的字符串表示形式。

String

ReadOnlyObjectProperty.toString​()

返回此 ReadOnlyObjectProperty对象的字符串表示形式。

String

ReadOnlySetProperty.toString​()

返回此 ReadOnlySetProperty对象的字符串表示形式。

String

ReadOnlyStringProperty.toString​()

返回此 ReadOnlyStringProperty对象的字符串表示形式。

String

SetProperty.toString​()

返回此 SetProperty对象的字符串表示形式。

String

SetPropertyBase.toString​()

返回此 SetPropertyBase对象的字符串表示形式。

String

StringProperty.toString​()

返回此 StringProperty对象的字符串表示形式。

String

StringPropertyBase.toString​()

返回此 StringPropertyBase对象的字符串表示形式。

void

BooleanPropertyBase.unbind​()

删除这个 Property的单向绑定。

void

DoublePropertyBase.unbind​()

删除这个 Property的单向绑定。

void

FloatPropertyBase.unbind​()

删除这个 Property的单向绑定。

void

IntegerPropertyBase.unbind​()

删除此 Property的单向绑定。

void

ListPropertyBase.unbind​()

void

LongPropertyBase.unbind​()

删除这个 Property的单向绑定。

void

MapPropertyBase.unbind​()

void

ObjectPropertyBase.unbind​()

删除这个 Property的单向绑定。

void

SetPropertyBase.unbind​()

void

StringPropertyBase.unbind​()

删除这个 Property的单向绑定。

void

BooleanProperty.unbindBidirectional​(Property<Boolean> other)

删除此 Property和另一个之间的双向绑定。

void

DoubleProperty.unbindBidirectional​(Property<Number> other)

删除这个 Property和另一个之间的双向绑定。

void

FloatProperty.unbindBidirectional​(Property<Number> other)

删除此 Property和另一个之间的双向绑定。

void

IntegerProperty.unbindBidirectional​(Property<Number> other)

删除此 Property和另一个之间的双向绑定。

void

ListProperty.unbindBidirectional​(Property<ObservableList<E>> other)

删除此 Property和另一个之间的双向绑定。

void

LongProperty.unbindBidirectional​(Property<Number> other)

删除这个 Property和另一个之间的双向绑定。

void

MapProperty.unbindBidirectional​(Property<ObservableMap<K,V>> other)

删除此 Property和另一个之间的双向绑定。

void

ObjectProperty.unbindBidirectional​(Property<T> other)

删除此 Property和另一个之间的双向绑定。

void

SetProperty.unbindBidirectional​(Property<ObservableSet<E>> other)

删除此 Property和另一个之间的双向绑定。

void

StringProperty.unbindBidirectional​(Property<String> other)

删除此 Property和另一个之间的双向绑定。

Uses of Override in javafx.beans.property.adapter

Methods in javafx.beans.property.adapter with annotations of type Override

Modifier and Type

方法

描述

void

JavaBeanBooleanProperty.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable无效时，它将被通知。

void

JavaBeanBooleanProperty.addListener​(ChangeListener<? super Boolean> listener)

添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。

void

JavaBeanDoubleProperty.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable无效时，它将被通知。

void

JavaBeanDoubleProperty.addListener​(ChangeListener<? super Number> listener)

添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。

void

JavaBeanFloatProperty.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable无效时，它将被通知。

void

JavaBeanFloatProperty.addListener​(ChangeListener<? super Number> listener)

添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。

void

JavaBeanIntegerProperty.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable变为无效时，它将被通知。

void

JavaBeanIntegerProperty.addListener​(ChangeListener<? super Number> listener)

添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。

void

JavaBeanLongProperty.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable无效时，它将被通知。

void

JavaBeanLongProperty.addListener​(ChangeListener<? super Number> listener)

添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。

void

JavaBeanObjectProperty.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable无效时，它将被通知。

void

JavaBeanObjectProperty.addListener​(ChangeListener<? super T> listener)

添加一个ChangeListener ，当ObservableValue的值更改时，它将被通知。

void

JavaBeanStringProperty.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable无效时，它将被通知。

void

JavaBeanStringProperty.addListener​(ChangeListener<? super String> listener)

添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。

void

JavaBeanBooleanProperty.bind​(ObservableValue<? extends Boolean> observable)

为此创建一个单向绑定 Property 。

void

JavaBeanDoubleProperty.bind​(ObservableValue<? extends Number> observable)

为此创建一个单向绑定 Property 。

void

JavaBeanFloatProperty.bind​(ObservableValue<? extends Number> observable)

为此 Property创建一个单向绑定。

void

JavaBeanIntegerProperty.bind​(ObservableValue<? extends Number> observable)

为此创建一个单向绑定 Property 。

void

JavaBeanLongProperty.bind​(ObservableValue<? extends Number> observable)

为此创建一个单向绑定 Property 。

void

JavaBeanObjectProperty.bind​(ObservableValue<? extends T> observable)

为此创建一个单向绑定 Property 。

void

JavaBeanStringProperty.bind​(ObservableValue<? extends String> observable)

为此 Property创建一个单向绑定。

void

JavaBeanBooleanProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

JavaBeanDoubleProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

JavaBeanFloatProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

JavaBeanIntegerProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

JavaBeanLongProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

JavaBeanObjectProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

JavaBeanStringProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

ReadOnlyJavaBeanBooleanProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

ReadOnlyJavaBeanDoubleProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

ReadOnlyJavaBeanFloatProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

ReadOnlyJavaBeanIntegerProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

ReadOnlyJavaBeanLongProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

ReadOnlyJavaBeanObjectProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

ReadOnlyJavaBeanStringProperty.dispose​()

信号到JavaFX属性，它将不再被使用，任何引用都可以被删除。

void

JavaBeanBooleanProperty.fireValueChangedEvent​()

如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

void

JavaBeanDoubleProperty.fireValueChangedEvent​()

如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

void

JavaBeanFloatProperty.fireValueChangedEvent​()

如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

void

JavaBeanIntegerProperty.fireValueChangedEvent​()

如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

void

JavaBeanLongProperty.fireValueChangedEvent​()

如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

void

JavaBeanObjectProperty.fireValueChangedEvent​()

如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

void

JavaBeanStringProperty.fireValueChangedEvent​()

如果Java Bean属性未绑定（即它不支持PropertyChangeListeners），则可以调用此方法来通知适配器更改Java Bean值。

void

ReadOnlyJavaBeanBooleanProperty.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

void

ReadOnlyJavaBeanDoubleProperty.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

void

ReadOnlyJavaBeanFloatProperty.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

void

ReadOnlyJavaBeanIntegerProperty.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

void

ReadOnlyJavaBeanLongProperty.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

void

ReadOnlyJavaBeanObjectProperty.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

void

ReadOnlyJavaBeanStringProperty.fireValueChangedEvent​()

发送所有附件的通知InvalidationListeners和ChangeListeners 。

boolean

JavaBeanBooleanProperty.get​()

获取包装的值。

double

JavaBeanDoubleProperty.get​()

获取包装的值。

float

JavaBeanFloatProperty.get​()

获取包装的值。

int

JavaBeanIntegerProperty.get​()

获取包装的值。

long

JavaBeanLongProperty.get​()

获取包装的值。

T

JavaBeanObjectProperty.get​()

获取包装的值。

String

JavaBeanStringProperty.get​()

获取包装的值。

boolean

ReadOnlyJavaBeanBooleanProperty.get​()

返回此 ObservableBooleanValue的当前值。

double

ReadOnlyJavaBeanDoubleProperty.get​()

返回此 ObservableDoubleValue的当前值。

float

ReadOnlyJavaBeanFloatProperty.get​()

返回此 ObservableFloatValue的当前值。

int

ReadOnlyJavaBeanIntegerProperty.get​()

返回此 ObservableIntegerValue的当前值。

long

ReadOnlyJavaBeanLongProperty.get​()

返回此 ObservableLongValue的当前值。

T

ReadOnlyJavaBeanObjectProperty.get​()

返回此 ObservableObjectValue<T>的当前值。

String

ReadOnlyJavaBeanStringProperty.get​()

返回此 ObservableObjectValue<T>的当前值。

Object

JavaBeanBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanLongProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

JavaBeanStringProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanLongProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

ReadOnlyJavaBeanStringProperty.getBean​()

返回包含此属性的 Object 。

String

JavaBeanBooleanProperty.getName​()

返回此属性的名称。

String

JavaBeanDoubleProperty.getName​()

返回此属性的名称。

String

JavaBeanFloatProperty.getName​()

返回此属性的名称。

String

JavaBeanIntegerProperty.getName​()

返回此属性的名称。

String

JavaBeanLongProperty.getName​()

返回此属性的名称。

String

JavaBeanObjectProperty.getName​()

返回此属性的名称。

String

JavaBeanStringProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanBooleanProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanDoubleProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanFloatProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanIntegerProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanLongProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanObjectProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanStringProperty.getName​()

返回此属性的名称。

boolean

JavaBeanBooleanProperty.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

JavaBeanDoubleProperty.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

JavaBeanFloatProperty.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

JavaBeanIntegerProperty.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

JavaBeanLongProperty.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

JavaBeanObjectProperty.isBound​()

可以用来检查，如果一个 Property是绑定的。

boolean

JavaBeanStringProperty.isBound​()

可以用来检查，如果一个 Property是绑定的。

void

JavaBeanBooleanProperty.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

void

JavaBeanBooleanProperty.removeListener​(ChangeListener<? super Boolean> listener)

从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知该 ObservableValue 。

void

JavaBeanDoubleProperty.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

void

JavaBeanDoubleProperty.removeListener​(ChangeListener<? super Number> listener)

从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

void

JavaBeanFloatProperty.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的侦听器，每当 Observable的值变为无效时通知 Observable 。

void

JavaBeanFloatProperty.removeListener​(ChangeListener<? super Number> listener)

从监听器列表中删除给定的侦听器，每当 ObservableValue的值发生更改时通知 ObservableValue 。

void

JavaBeanIntegerProperty.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

void

JavaBeanIntegerProperty.removeListener​(ChangeListener<? super Number> listener)

从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

void

JavaBeanLongProperty.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

void

JavaBeanLongProperty.removeListener​(ChangeListener<? super Number> listener)

从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

void

JavaBeanObjectProperty.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

void

JavaBeanObjectProperty.removeListener​(ChangeListener<? super T> listener)

从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。

void

JavaBeanStringProperty.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的监听器，当 Observable的值变为无效时通知 Observable 。

void

JavaBeanStringProperty.removeListener​(ChangeListener<? super String> listener)

从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。

void

JavaBeanBooleanProperty.set​(boolean value)

设置包装的值。

void

JavaBeanDoubleProperty.set​(double value)

设置包装的值。

void

JavaBeanFloatProperty.set​(float value)

设置包装的值。

void

JavaBeanIntegerProperty.set​(int value)

设置包装的值。

void

JavaBeanLongProperty.set​(long value)

设置包装的值。

void

JavaBeanObjectProperty.set​(T value)

设置包装的值。

void

JavaBeanStringProperty.set​(String value)

设置包装的值。

String

JavaBeanBooleanProperty.toString​()

返回此 JavaBeanBooleanProperty对象的字符串表示形式。

String

JavaBeanDoubleProperty.toString​()

返回此 JavaBeanDoubleProperty对象的字符串表示形式。

String

JavaBeanFloatProperty.toString​()

返回此 JavaBeanFloatProperty对象的字符串表示形式。

String

JavaBeanIntegerProperty.toString​()

返回此 JavaBeanIntegerProperty对象的字符串表示形式。

String

JavaBeanLongProperty.toString​()

返回此 JavaBeanLongProperty对象的字符串表示形式。

String

JavaBeanObjectProperty.toString​()

返回此 JavaBeanObjectProperty对象的字符串表示形式。

void

JavaBeanBooleanProperty.unbind​()

删除这个 Property的单向绑定。

void

JavaBeanDoubleProperty.unbind​()

删除这个 Property的单向绑定。

void

JavaBeanFloatProperty.unbind​()

删除这个 Property的单向绑定。

void

JavaBeanIntegerProperty.unbind​()

删除这个 Property的单向绑定。

void

JavaBeanLongProperty.unbind​()

删除此 Property的单向绑定。

void

JavaBeanObjectProperty.unbind​()

删除此 Property的单向绑定。

void

JavaBeanStringProperty.unbind​()

删除这个 Property的单向绑定。

Uses of Override in javafx.beans.value

Methods in javafx.beans.value with annotations of type Override

Modifier and Type

方法

描述

void

ObservableValueBase.addListener​(InvalidationListener listener)

添加一个InvalidationListener ，当Observable变得无效时，它将被通知。

void

ObservableValueBase.addListener​(ChangeListener<? super T> listener)

添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。

void

WeakChangeListener.changed​(ObservableValue<? extends T> observable, T oldValue, T newValue)

该方法需要通过 ChangeListener的实现来提供。

void

ObservableValueBase.removeListener​(InvalidationListener listener)

从监听器列表中删除给定的侦听器，当 Observable的值变为无效时，它们将被通知。

void

ObservableValueBase.removeListener​(ChangeListener<? super T> listener)

从监听器列表中删除给定的监听器，当 ObservableValue的值发生变化时通知 ObservableValue 。

void

WritableBooleanValue.setValue​(Boolean value)

设置包装的值。

void

WritableDoubleValue.setValue​(Number value)

设置包装的值。

void

WritableFloatValue.setValue​(Number value)

设置包装的值。

void

WritableIntegerValue.setValue​(Number value)

设置包装的值。

void

WritableLongValue.setValue​(Number value)

设置包装的值。

boolean

WeakChangeListener.wasGarbageCollected​()

如果链接的侦听器被垃圾回收，则返回 true 。

Uses of Override in javafx.collections

Methods in javafx.collections with annotations of type Override

Modifier and Type

方法

描述

void

ModifiableObservableListBase.add​(int index, E element)

boolean

ModifiableObservableListBase.addAll​(int index, Collection<? extends E> c)

boolean

ModifiableObservableListBase.addAll​(Collection<? extends E> c)

boolean

ObservableListBase.addAll​(E... elements)

void

ObservableArrayBase.addListener​(InvalidationListener listener)

void

ObservableArrayBase.addListener​(ArrayChangeListener<T> listener)

void

ObservableListBase.addListener​(InvalidationListener listener)

void

ObservableListBase.addListener​(ListChangeListener<? super E> listener)

abstract E

ModifiableObservableListBase.get​(int index)

void

WeakListChangeListener.onChanged​(ListChangeListener.Change<? extends E> change)

在对ObservableList进行了更改后调用。

void

WeakMapChangeListener.onChanged​(MapChangeListener.Change<? extends K,? extends V> change)

在对ObservableMap进行了更改后调用。

void

WeakSetChangeListener.onChanged​(SetChangeListener.Change<? extends E> change)

在对ObservableSet进行了更改后调用。

E

ModifiableObservableListBase.remove​(int index)

boolean

ModifiableObservableListBase.remove​(Object o)

void

ObservableListBase.remove​(int from, int to)

boolean

ModifiableObservableListBase.removeAll​(Collection<?> c)

boolean

ObservableListBase.removeAll​(E... elements)

void

ObservableArrayBase.removeListener​(InvalidationListener listener)

void

ObservableArrayBase.removeListener​(ArrayChangeListener<T> listener)

void

ObservableListBase.removeListener​(InvalidationListener listener)

void

ObservableListBase.removeListener​(ListChangeListener<? super E> listener)

protected void

ModifiableObservableListBase.removeRange​(int fromIndex, int toIndex)

boolean

ModifiableObservableListBase.retainAll​(Collection<?> c)

boolean

ObservableListBase.retainAll​(E... elements)

E

ModifiableObservableListBase.set​(int index, E element)

boolean

ModifiableObservableListBase.setAll​(Collection<? extends E> col)

boolean

ObservableListBase.setAll​(E... elements)

boolean

ObservableListBase.setAll​(Collection<? extends E> col)

abstract int

ModifiableObservableListBase.size​()

List<E>

ModifiableObservableListBase.subList​(int fromIndex, int toIndex)

boolean

WeakListChangeListener.wasGarbageCollected​()

如果链接的侦听器被垃圾回收，则返回 true 。

boolean

WeakMapChangeListener.wasGarbageCollected​()

如果链接的侦听器被垃圾回收，则返回 true 。

boolean

WeakSetChangeListener.wasGarbageCollected​()

如果链接的侦听器被垃圾回收，则返回 true 。

Uses of Override in javafx.collections.transformation

Methods in javafx.collections.transformation with annotations of type Override

Modifier and Type

方法

描述

E

FilteredList.get​(int index)

返回此列表中指定位置的元素。

E

SortedList.get​(int index)

返回此列表中指定位置的元素。

int

FilteredList.getSourceIndex​(int index)

int

SortedList.getSourceIndex​(int index)

int

FilteredList.getViewIndex​(int index)

int

SortedList.getViewIndex​(int index)

int

FilteredList.size​()

返回此列表中的元素数。

int

SortedList.size​()

返回此列表中的元素数。

protected void

FilteredList.sourceChanged​(ListChangeListener.Change<? extends E> c)

protected void

SortedList.sourceChanged​(ListChangeListener.Change<? extends E> c)

Uses of Override in javafx.concurrent

Methods in javafx.concurrent with annotations of type Override

Modifier and Type

方法

描述

EventDispatchChain

Service.buildEventDispatchChain​(EventDispatchChain tail)

EventDispatchChain

Task.buildEventDispatchChain​(EventDispatchChain tail)

boolean

ScheduledService.cancel​()

取消任何当前正在运行的任务并停止此计划的服务，这样就不会发生额外的迭代。

boolean

Service.cancel​()

取消任何当前正在运行的任务（如果有）。

boolean

Task.cancel​()

boolean

Task.cancel​(boolean mayInterruptIfRunning)

ReadOnlyObjectProperty<Throwable>

Service.exceptionProperty​()

ReadOnlyObjectProperty<Throwable>

Task.exceptionProperty​()

protected void

ScheduledService.executeTask​(Task<V> task)

protected void

ScheduledService.failed​()

对于子类的受保护的便利方法，只要服务状态已经转换到FAILED状态。

Throwable

Service.getException​()

获取属性异常的值。

Throwable

Task.getException​()

获取属性异常的值。

String

Service.getMessage​()

获取属性消息的值。

String

Task.getMessage​()

获取属性消息的值。

double

Service.getProgress​()

获取属性进度的值。

double

Task.getProgress​()

获取属性进度的值。

Worker

WorkerStateEvent.getSource​()

事件最初发生的工人。

Worker.State

Service.getState​()

获取属性状态的值。

Worker.State

Task.getState​()

获取属性状态的值。

String

Service.getTitle​()

获取属性标题的值。

String

Task.getTitle​()

获取属性标题的值。

double

Service.getTotalWork​()

获取属性totalWork的值。

double

Task.getTotalWork​()

获取属性totalWork的值。

V

Service.getValue​()

获取属性值的值。

V

Task.getValue​()

获取属性值的值。

double

Service.getWorkDone​()

获取属性workDone的值。

double

Task.getWorkDone​()

获取属性workDone的值。

boolean

Service.isRunning​()

获取运行的属性的值。

boolean

Task.isRunning​()

获取运行的属性的值。

ReadOnlyStringProperty

Service.messageProperty​()

ReadOnlyStringProperty

Task.messageProperty​()

ReadOnlyDoubleProperty

Service.progressProperty​()

ReadOnlyDoubleProperty

Task.progressProperty​()

void

ScheduledService.reset​()

重置服务。

ReadOnlyBooleanProperty

Service.runningProperty​()

ReadOnlyBooleanProperty

Task.runningProperty​()

ReadOnlyObjectProperty<Worker.State>

Service.stateProperty​()

ReadOnlyObjectProperty<Worker.State>

Task.stateProperty​()

protected void

ScheduledService.succeeded​()

对于子类的受保护的便利方法，当服务状态已转换到SUCCEEDED状态时调用。

ReadOnlyStringProperty

Service.titleProperty​()

ReadOnlyStringProperty

Task.titleProperty​()

ReadOnlyDoubleProperty

Service.totalWorkProperty​()

ReadOnlyDoubleProperty

Task.totalWorkProperty​()

ReadOnlyObjectProperty<V>

Service.valueProperty​()

ReadOnlyObjectProperty<V>

Task.valueProperty​()

ReadOnlyDoubleProperty

Service.workDoneProperty​()

ReadOnlyDoubleProperty

Task.workDoneProperty​()

Uses of Override in javafx.css

Methods in javafx.css with annotations of type Override

Modifier and Type

方法

描述

boolean

CompoundSelector.applies​(Styleable styleable)

boolean

CompoundSelector.applies​(Styleable styleable, Set<PseudoClass>[] triggerStates, int depth)

boolean

SimpleSelector.applies​(Styleable styleable)

boolean

SimpleSelector.applies​(Styleable styleable, Set<PseudoClass>[] pseudoClasses, int depth)

void

StyleableBooleanProperty.applyStyle​(StyleOrigin origin, Boolean v)

这个方法从CSS代码调用来设置属性的值。

void

StyleableDoubleProperty.applyStyle​(StyleOrigin origin, Number v)

这个方法从CSS代码调用来设置属性的值。

void

StyleableFloatProperty.applyStyle​(StyleOrigin origin, Number v)

这个方法从CSS代码调用来设置属性的值。

void

StyleableIntegerProperty.applyStyle​(StyleOrigin origin, Number v)

这个方法从CSS代码调用来设置属性的值。

void

StyleableLongProperty.applyStyle​(StyleOrigin origin, Number v)

这个方法从CSS代码调用来设置属性的值。

void

StyleableObjectProperty.applyStyle​(StyleOrigin origin, T v)

这个方法从CSS代码调用来设置属性的值。

void

StyleableStringProperty.applyStyle​(StyleOrigin origin, String v)

这个方法从CSS代码调用来设置属性的值。

void

StyleableBooleanProperty.bind​(ObservableValue<? extends Boolean> observable)

为此创建一个单向绑定 Property 。

void

StyleableDoubleProperty.bind​(ObservableValue<? extends Number> observable)

为此创建一个单向绑定 Property 。

void

StyleableFloatProperty.bind​(ObservableValue<? extends Number> observable)

为此创建一个单向绑定 Property 。

void

StyleableIntegerProperty.bind​(ObservableValue<? extends Number> observable)

为此创建一个单向绑定 Property 。

void

StyleableLongProperty.bind​(ObservableValue<? extends Number> observable)

为此创建一个单向绑定 Property 。

void

StyleableObjectProperty.bind​(ObservableValue<? extends T> observable)

为此 Property创建一个单向绑定。

void

StyleableStringProperty.bind​(ObservableValue<? extends String> observable)

为此创建一个单向绑定 Property 。

int

Match.compareTo​(Match o)

Match

CompoundSelector.createMatch​()

Match

SimpleSelector.createMatch​()

boolean

CompoundSelector.equals​(Object obj)

boolean

CssMetaData.equals​(Object obj)

如果两个CssMetaData对象的 值为property，则它们被认为是相等的。

boolean

Declaration.equals​(Object obj)

无论宣言所属的规则如何，一个宣言是相等的。

boolean

SimpleSelector.equals​(Object obj)

boolean

Size.equals​(Object obj)

boolean

Style.equals​(Object obj)

boolean

Stylesheet.equals​(Object obj)

Object

SimpleStyleableBooleanProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableDoubleProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableFloatProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableIntegerProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableLongProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableObjectProperty.getBean​()

返回包含此属性的 Object 。

Object

SimpleStyleableStringProperty.getBean​()

返回包含此属性的 Object 。

CssMetaData<? extends Styleable,Boolean>

SimpleStyleableBooleanProperty.getCssMetaData​()

反映了对应于这个 javafx.beans.property.StyleableProperty

CssMetaData<? extends Styleable,Number>

SimpleStyleableDoubleProperty.getCssMetaData​()

反映了对应于这个 javafx.beans.property.StyleableProperty

CssMetaData<? extends Styleable,Number>

SimpleStyleableFloatProperty.getCssMetaData​()

反映与此 javafx.beans.property.StyleableProperty相对应的 javafx.beans.property.StyleableProperty

CssMetaData<? extends Styleable,Number>

SimpleStyleableIntegerProperty.getCssMetaData​()

反映了对应于这个 javafx.beans.property.StyleableProperty

CssMetaData<? extends Styleable,Number>

SimpleStyleableLongProperty.getCssMetaData​()

反映了对应于这个 javafx.beans.property.StyleableProperty

CssMetaData<? extends Styleable,T>

SimpleStyleableObjectProperty.getCssMetaData​()

反映与此 javafx.beans.property.StyleableProperty对应的 javafx.beans.property.StyleableProperty

CssMetaData<? extends Styleable,String>

SimpleStyleableStringProperty.getCssMetaData​()

反映对应于这个 javafx.beans.property.StyleableProperty

String

SimpleStyleableBooleanProperty.getName​()

返回此属性的名称。

String

SimpleStyleableDoubleProperty.getName​()

返回此属性的名称。

String

SimpleStyleableFloatProperty.getName​()

返回此属性的名称。

String

SimpleStyleableIntegerProperty.getName​()

返回此属性的名称。

String

SimpleStyleableLongProperty.getName​()

返回此属性的名称。

String

SimpleStyleableObjectProperty.getName​()

返回此属性的名称。

String

SimpleStyleableStringProperty.getName​()

返回此属性的名称。

StyleOrigin

StyleableBooleanProperty.getStyleOrigin​()

告诉物业的价值的起源。

StyleOrigin

StyleableDoubleProperty.getStyleOrigin​()

告诉物业的价值的起源。

StyleOrigin

StyleableFloatProperty.getStyleOrigin​()

告诉物业的价值的起源。

StyleOrigin

StyleableIntegerProperty.getStyleOrigin​()

告诉物业的价值的起源。

StyleOrigin

StyleableLongProperty.getStyleOrigin​()

告诉物业的价值的起源。

StyleOrigin

StyleableObjectProperty.getStyleOrigin​()

告诉物业的价值的起源。

StyleOrigin

StyleableStringProperty.getStyleOrigin​()

告诉物业的价值的起源。

int

CompoundSelector.hashCode​()

int

CssMetaData.hashCode​()

int

Declaration.hashCode​()

int

SimpleSelector.hashCode​()

int

Size.hashCode​()

int

Style.hashCode​()

int

Stylesheet.hashCode​()

void

StyleableBooleanProperty.set​(boolean v)

设置包装的值。

void

StyleableDoubleProperty.set​(double v)

设置包装的值。

void

StyleableFloatProperty.set​(float v)

设置包装的值。

void

StyleableIntegerProperty.set​(int v)

设置包装的值。

void

StyleableLongProperty.set​(long v)

设置包装的值。

void

StyleableObjectProperty.set​(T v)

设置包装的值。

void

StyleableStringProperty.set​(String v)

设置包装的值。

boolean

CompoundSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)

boolean

SimpleSelector.stateMatches​(Styleable styleable, Set<PseudoClass> states)

String

CompoundSelector.toString​()

String

CssMetaData.toString​()

String

CssParser.ParseError.InlineStyleParsingError.toString​()

String

CssParser.ParseError.PropertySetError.toString​()

String

CssParser.ParseError.StringParsingError.toString​()

String

CssParser.ParseError.StylesheetParsingError.toString​()

String

CssParser.ParseError.toString​()

String

Declaration.toString​()

String

Rule.toString​()

将此对象转换为字符串。

String

SimpleSelector.toString​()

将此对象转换为字符串。

String

Size.toString​()

String

Style.toString​()

String

StyleClass.toString​()

String

Stylesheet.toString​()

返回此对象的字符串表示形式。

protected void

CompoundSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)

protected void

SimpleSelector.writeBinary​(DataOutputStream os, StyleConverter.StringStore stringStore)

Uses of Override in javafx.css.converter

Methods in javafx.css.converter with annotations of type Override

Modifier and Type

方法

描述

Boolean

BooleanConverter.convert​(ParsedValue<String,Boolean> value, Font not_used)

Color

ColorConverter.convert​(ParsedValue<String,Color> value, Font font)

Cursor

CursorConverter.convert​(ParsedValue<String,Cursor> value, Font not_used)

Color

DeriveColorConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)

Size

DeriveSizeConverter.convert​(ParsedValue<ParsedValue<Size,Size>[],Size> value, Font font)

Duration

DurationConverter.convert​(ParsedValue<ParsedValue<?,Size>,Duration> value, Font font)

Effect

EffectConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)

Effect

EffectConverter.DropShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)

Effect

EffectConverter.InnerShadowConverter.convert​(ParsedValue<ParsedValue[],Effect> value, Font font)

E

EnumConverter.convert​(ParsedValue<String,E> value, Font not_used)

Font

FontConverter.convert​(Map<CssMetaData<? extends Styleable,?>,Object> convertedValues)

Font

FontConverter.convert​(ParsedValue<ParsedValue[],Font> value, Font font)

Number

FontConverter.FontSizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)

FontPosture

FontConverter.FontStyleConverter.convert​(ParsedValue<String,FontPosture> value, Font font)

FontWeight

FontConverter.FontWeightConverter.convert​(ParsedValue<String,FontWeight> value, Font font)

Insets

InsetsConverter.convert​(ParsedValue<ParsedValue[],Insets> value, Font font)

Insets[]

InsetsConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],Insets>[],Insets[]> value, Font font)

Color

LadderConverter.convert​(ParsedValue<ParsedValue[],Color> value, Font font)

Paint

PaintConverter.convert​(ParsedValue<ParsedValue<?,Paint>,Paint> value, Font font)

Paint

PaintConverter.ImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)

Paint

PaintConverter.LinearGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)

Paint

PaintConverter.RadialGradientConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)

Paint

PaintConverter.RepeatingImagePatternConverter.convert​(ParsedValue<ParsedValue[],Paint> value, Font font)

Paint[]

PaintConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<?,Paint>[],Paint[]> value, Font font)

Shape

ShapeConverter.convert​(ParsedValue<String,Shape> value, Font font)

Number

SizeConverter.convert​(ParsedValue<ParsedValue<?,Size>,Number> value, Font font)

Number[]

SizeConverter.SequenceConverter.convert​(ParsedValue<ParsedValue[],Number[]> value, Font font)

Stop

StopConverter.convert​(ParsedValue<ParsedValue[],Stop> value, Font font)

String

StringConverter.convert​(ParsedValue<String,String> value, Font font)

String[]

StringConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<String,String>[],String[]> value, Font font)

String

URLConverter.convert​(ParsedValue<ParsedValue[],String> value, Font font)

String[]

URLConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],String>[],String[]> value, Font font)

boolean

EnumConverter.equals​(Object other)

int

EnumConverter.hashCode​()

String

BooleanConverter.toString​()

String

ColorConverter.toString​()

String

CursorConverter.toString​()

String

DeriveColorConverter.toString​()

String

DeriveSizeConverter.toString​()

String

DurationConverter.toString​()

String

EffectConverter.DropShadowConverter.toString​()

String

EffectConverter.InnerShadowConverter.toString​()

String

EffectConverter.toString​()

String

EnumConverter.toString​()

String

FontConverter.FontSizeConverter.toString​()

String

FontConverter.FontStyleConverter.toString​()

String

FontConverter.FontWeightConverter.toString​()

String

FontConverter.toString​()

String

InsetsConverter.SequenceConverter.toString​()

String

InsetsConverter.toString​()

String

LadderConverter.toString​()

String

PaintConverter.ImagePatternConverter.toString​()

String

PaintConverter.LinearGradientConverter.toString​()

String

PaintConverter.RadialGradientConverter.toString​()

String

PaintConverter.RepeatingImagePatternConverter.toString​()

String

PaintConverter.SequenceConverter.toString​()

String

PaintConverter.toString​()

String

SizeConverter.SequenceConverter.toString​()

String

SizeConverter.toString​()

String

StopConverter.toString​()

String

StringConverter.SequenceConverter.toString​()

String

StringConverter.toString​()

String

URLConverter.SequenceConverter.toString​()

String

URLConverter.toString​()

void

EnumConverter.writeBinary​(DataOutputStream os, StyleConverter.StringStore sstore)

Uses of Override in javafx.embed.swing

Methods in javafx.embed.swing with annotations of type Override

Modifier and Type

方法

描述

void

JFXPanel.addNotify​()

通知此组件它现在有一个父组件。

InputMethodRequests

JFXPanel.getInputMethodRequests​()

Dimension

JFXPanel.getPreferredSize​()

返回此 JFXPanel的首选大小，先前使用 JComponent.setPreferredSize(Dimension)设置，或根据连接到此 JFXPanel的JavaFX场景的内容。

boolean

JFXPanel.isOpaque​()

JFXPanel的不透明度由此组件中显示的JavaFX内容控制，因此此方法将覆盖 JComponent.isOpaque()以始终返回 false值。

boolean

SwingNode.isResizable​()

double

SwingNode.maxHeight​(double width)

返回 SwingNode的最大高度用于布局计算。

double

SwingNode.maxWidth​(double height)

返回 SwingNode用于布局计算的最大宽度。

double

SwingNode.minHeight​(double width)

返回 SwingNode用于布局计算的最小高度。

double

SwingNode.minWidth​(double height)

返回 SwingNode用于布局计算的最小宽度。

protected void

JFXPanel.paintComponent​(Graphics g)

覆盖 JComponent.paintComponent(Graphics)方法来绘制附加到此 JFXpanel的JavaFX场景的内容。

double

SwingNode.prefHeight​(double width)

返回用于布局计算的 SwingNode的首选高度。

double

SwingNode.prefWidth​(double height)

返回 SwingNode用于布局计算的首选宽度。

protected void

JFXPanel.processComponentEvent​(ComponentEvent e)

覆盖 Component.processComponentEvent(ComponentEvent)方法将 ComponentEvent.COMPONENT_RESIZED事件发送到附加到此 JFXPanel的JavaFX场景。

protected void

JFXPanel.processFocusEvent​(FocusEvent e)

覆盖 Component.processFocusEvent(FocusEvent)方法来将焦点事件分配给连接到此 JFXPanel的JavaFX场景。

protected void

JFXPanel.processHierarchyBoundsEvent​(HierarchyEvent e)

覆盖 Component.processHierarchyBoundsEvent(HierarchyEvent)方法处理 HierarchyEvent.ANCESTOR_MOVED事件，并更新JavaFX场景位置以匹配屏幕上的 JFXPanel位置。

protected void

JFXPanel.processHierarchyEvent​(HierarchyEvent e)

protected void

JFXPanel.processInputMethodEvent​(InputMethodEvent e)

protected void

JFXPanel.processKeyEvent​(KeyEvent e)

覆盖 Component.processKeyEvent(KeyEvent)方法将键事件发送到连接到此 JFXPanel的JavaFX场景。

protected void

JFXPanel.processMouseEvent​(MouseEvent e)

覆盖 Component.processMouseEvent(MouseEvent)方法将鼠标事件发送到连接到此 JFXPanel的JavaFX场景。

protected void

JFXPanel.processMouseMotionEvent​(MouseEvent e)

覆盖 Component.processMouseMotionEvent(MouseEvent)方法将鼠标移动事件发送到连接到此 JFXPanel的JavaFX场景。

protected void

JFXPanel.processMouseWheelEvent​(MouseWheelEvent e)

覆盖 Component.processMouseWheelEvent(MouseWheelEvent)方法将鼠标滚轮事件发送到连接到此 JFXPanel的JavaFX场景。

void

JFXPanel.removeNotify​()

通知此组件它不再具有父组件。

void

SwingNode.resize​(double width, double height)

由 SwingNode的父母在布局期间调用 SwingNode的宽度和高度。

void

JFXPanel.setOpaque​(boolean opaque)

JFXPanel的不透明度由在此组件中显示的JavaFX内容控制，因此此方法将覆盖 JComponent.setOpaque(boolean)以仅接受 false值。

Uses of Override in javafx.event

Methods in javafx.event with annotations of type Override

Modifier and Type

方法

描述

Object

Event.clone​()

创建并返回此 Event的副本。

ActionEvent

ActionEvent.copyFor​(Object newSource, EventTarget newTarget)

EventType<? extends ActionEvent>

ActionEvent.getEventType​()

void

WeakEventHandler.handle​(T event)

向相关事件处理程序发送事件通知。

String

EventType.toString​()

返回此 EventType对象的字符串表示形式。

Uses of Override in javafx.fxml

Methods in javafx.fxml with annotations of type Override

Modifier and Type

方法

描述

boolean

FXMLLoader.equals​(Object obj)

Builder<?>

JavaFXBuilderFactory.getBuilder​(Class<?> type)

返回指定类型的构建器，如果不使用构建器，则返回null。

Uses of Override in javafx.geometry

Methods in javafx.geometry with annotations of type Override

Modifier and Type

方法

描述

boolean

BoundingBox.contains​(double x, double y)

测试指定的 (x, y)坐标是否在 Bounds的边界内。

boolean

BoundingBox.contains​(double x, double y, double z)

测试指定的 (x, y, z)坐标是否在 Bounds的边界内。

boolean

BoundingBox.contains​(double x, double y, double w, double h)

测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。

boolean

BoundingBox.contains​(double x, double y, double z, double w, double h, double d)

测试这个 Bounds的内部 Bounds完全包含指定的矩形区域。

boolean

BoundingBox.contains​(Bounds b)

测试这个 Bounds的内部 Bounds完全包含指定的边界， b 。

boolean

BoundingBox.contains​(Point2D p)

测试指定点是否在 Bounds的边界内。

boolean

BoundingBox.contains​(Point3D p)

测试指定点是否在 Bounds的边界内。

boolean

BoundingBox.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Dimension2D.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Insets.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Point2D.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Point3D.equals​(Object obj)

返回该点的哈希码值。

boolean

Rectangle2D.equals​(Object obj)

指示一些其他对象是否等于此。

int

BoundingBox.hashCode​()

返回对象的哈希码值。

int

Dimension2D.hashCode​()

返回Dimension2D对象的哈希码值。

int

Insets.hashCode​()

返回插值的哈希码值。

int

Point2D.hashCode​()

返回该点的哈希码值。

int

Point3D.hashCode​()

返回此 Point3D对象的哈希码。

int

Rectangle2D.hashCode​()

返回此 Rectangle2D对象的哈希码。

boolean

BoundingBox.intersects​(double x, double y, double w, double h)

测试这个 Bounds的内部是否与指定矩形区域的内部相交。

boolean

BoundingBox.intersects​(double x, double y, double z, double w, double h, double d)

测试这个 Bounds的内部是否与指定矩形区域的内部相交。

boolean

BoundingBox.intersects​(Bounds b)

测试这个 Bounds的内部是否与指定的边界 b的内部相交。

boolean

BoundingBox.isEmpty​()

指示此边界的任何尺寸（宽度，高度或深度）是否小于零。

String

BoundingBox.toString​()

返回此 BoundingBox的字符串表示 BoundingBox 。

String

Dimension2D.toString​()

返回此 Dimension2D的字符串表示 Dimension2D 。

String

Insets.toString​()

返回插值的字符串表示形式。

String

Point2D.toString​()

返回此 Point2D的字符串表示 Point2D 。

String

Point3D.toString​()

返回此 Point3D的字符串表示 Point3D 。

String

Rectangle2D.toString​()

返回此 Rectangle2D的字符串表示 Rectangle2D 。

Uses of Override in javafx.print

Methods in javafx.print with annotations of type Override

Modifier and Type

方法

描述

boolean

PageLayout.equals​(Object o)

boolean

Paper.equals​(Object o)

boolean

PrintResolution.equals​(Object o)

int

PageLayout.hashCode​()

int

Paper.hashCode​()

int

PrintResolution.hashCode​()

String

JobSettings.toString​()

String

PageLayout.toString​()

String

Paper.toString​()

String

PaperSource.toString​()

String

Printer.toString​()

String

PrinterJob.toString​()

String

PrintResolution.toString​()

Uses of Override in javafx.scene

Methods in javafx.scene with annotations of type Override

Modifier and Type

方法

描述

EventDispatchChain

Node.buildEventDispatchChain​(EventDispatchChain tail)

为此节点构造事件调度链。

EventDispatchChain

Scene.buildEventDispatchChain​(EventDispatchChain tail)

为此场景构建事件调度链。

double

Parent.getBaselineOffset​()

基于第一个受管理的子节点计算基线偏移量。

ObservableList<Node>

Group.getChildren​()

获取此 Group的孩子列表。

List<CssMetaData<? extends Styleable,?>>

Node.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

Styleable

Node.getStyleableParent​()

返回此Styleable的父项，如果没有父项则返回null。

ObservableList<String>

Node.getStyleClass​()

String

Node.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

protected void

Group.layoutChildren​()

组实现layoutChildren，以便每个小孩都调整为首选大小，如果小孩可调整大小。

Node

Parent.lookup​(String selector)

double

Group.minHeight​(double width)

double

Parent.minHeight​(double width)

double

Group.minWidth​(double height)

double

Parent.minWidth​(double height)

double

Group.prefHeight​(double width)

组定义优选高度只是其布局界限的高度，反过来只是其所有子项的位置和高度的总和。

double

Parent.prefHeight​(double width)

double

Group.prefWidth​(double height)

组将首选宽度定义为其布局边界的宽度，而宽度又是其所有子项的位置和宽度之和。

double

Parent.prefWidth​(double height)

Object

Parent.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

String

Cursor.toString​()

返回游标的字符串表示形式。

String

Node.toString​()

返回对象的字符串表示形式。

String

SceneAntialiasing.toString​()

protected void

Parent.updateBounds​()

Uses of Override in javafx.scene.chart

Methods in javafx.scene.chart with annotations of type Override

Modifier and Type

方法

描述

protected Object

CategoryAxis.autoRange​(double length)

这将根据提供给invalidateRange（）方法的数据计算类别。

protected Object

NumberAxis.autoRange​(double minValue, double maxValue, double length, double labelSize)

被要求设置上限和下限以及需要自动调整的任何其他内容。

protected Object

ValueAxis.autoRange​(double length)

这将根据提供给invalidateRange（）方法的数据计算上限和下限。

protected List<String>

CategoryAxis.calculateTickValues​(double length, Object range)

计算范围内每个刻度线的所有数据值的列表

protected List<Number>

NumberAxis.calculateTickValues​(double length, Object range)

计算范围内每个刻度线的所有数据值的列表

protected double

Chart.computeMinHeight​(double width)

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

protected double

Chart.computeMinWidth​(double height)

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

protected double

Axis.computePrefHeight​(double width)

计算给定宽度的该轴的首选高度。

protected double

Chart.computePrefHeight​(double width)

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

protected double

Axis.computePrefWidth​(double height)

计算给定高度的该轴的首选宽度。

protected double

Chart.computePrefWidth​(double height)

图表的大小在外，用户告诉图表，它有多少空间和图表在里面。

protected void

AreaChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)

protected void

BarChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)

protected void

BubbleChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)

protected void

LineChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)

protected void

ScatterChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)

将数据项添加到系列时调用。

protected void

StackedAreaChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)

protected void

StackedBarChart.dataItemAdded​(XYChart.Series<X,Y> series, int itemIndex, XYChart.Data<X,Y> item)

protected void

AreaChart.dataItemChanged​(XYChart.Data<X,Y> item)

数据项已更改时调用，即其xValue，yValue或extraValue已更改。

protected void

BarChart.dataItemChanged​(XYChart.Data<X,Y> item)

数据项已更改时调用，即其xValue，yValue或extraValue已更改。

protected void

BubbleChart.dataItemChanged​(XYChart.Data<X,Y> item)

数据项已更改时调用，即其xValue，yValue或extraValue已更改。

protected void

LineChart.dataItemChanged​(XYChart.Data<X,Y> item)

数据项已更改时调用，即其xValue，yValue或extraValue已更改。

protected void

ScatterChart.dataItemChanged​(XYChart.Data<X,Y> item)

数据项已更改时调用，即其xValue，yValue或extraValue已更改。

protected void

StackedAreaChart.dataItemChanged​(XYChart.Data<X,Y> item)

数据项已更改时调用，即其xValue，yValue或extraValue已更改。

protected void

StackedBarChart.dataItemChanged​(XYChart.Data<X,Y> item)

数据项已更改时调用，即其xValue，yValue或extraValue已更改。

protected void

AreaChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)

protected void

BarChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)

protected void

BubbleChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)

protected void

LineChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)

protected void

ScatterChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)

当数据项已从数据模型中删除但在图表上仍然可见时调用。

protected void

StackedAreaChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)

protected void

StackedBarChart.dataItemRemoved​(XYChart.Data<X,Y> item, XYChart.Series<X,Y> series)

Number

NumberAxis.DefaultFormatter.fromString​(String string)

将提供的字符串转换为由此转换器定义的数字。

List<CssMetaData<? extends Styleable,?>>

AreaChart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

Axis.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

BarChart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

CategoryAxis.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

Chart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

LineChart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

NumberAxis.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

PieChart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

StackedAreaChart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

StackedBarChart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

ValueAxis.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

XYChart.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

double

CategoryAxis.getDisplayPosition​(String value)

获取给定值的沿该轴的显示位置。

double

ValueAxis.getDisplayPosition​(T value)

获取给定值的沿该轴的显示位置。

protected Object

CategoryAxis.getRange​()

被称为获取当前的轴范围。

protected Object

NumberAxis.getRange​()

被称为获取当前的轴范围。

protected String

CategoryAxis.getTickMarkLabel​(String value)

获取具有给定值的刻度线的字符串标签名称

protected String

NumberAxis.getTickMarkLabel​(Number value)

获取具有给定值的刻度线的字符串标签名称。

String

CategoryAxis.getValueForDisplay​(double displayPosition)

获取此轴上给定显示位置的数据值。

T

ValueAxis.getValueForDisplay​(double displayPosition)

获取此轴上给定显示位置的数据值。

double

CategoryAxis.getZeroPosition​()

获取沿该轴的零线的显示位置。

double

ValueAxis.getZeroPosition​()

获取零轴沿该轴的显示位置。

void

CategoryAxis.invalidateRange​(List<String> data)

数据更改时调用，范围可能不再有效。

void

ValueAxis.invalidateRange​(List<T> data)

当数据发生变化并且范围可能不再有效时调用。

boolean

CategoryAxis.isValueOnAxis​(String value)

检查给定值是否在该轴上是可绘制的

boolean

ValueAxis.isValueOnAxis​(T value)

检查给定值是否在该轴上是可绘制的

protected void

PieChart.layoutChartChildren​(double top, double left, double contentWidth, double contentHeight)

调用更新和布局从getChartChildren（）

protected void

XYChart.layoutChartChildren​(double top, double left, double width, double height)

调用更新和布局从getChartChildren（）

protected void

Axis.layoutChildren​()

在布局传递期间调用以布局此轴及其所有内容。

protected void

Chart.layoutChildren​()

在布局传递期间调用以布局此图表及其所有内容。

protected void

ValueAxis.layoutChildren​()

在布局传递期间调用以布局此轴及其所有内容。

protected void

AreaChart.layoutPlotChildren​()

被要求更新和布局情节儿童。

protected void

BarChart.layoutPlotChildren​()

被要求更新和布局情节儿童。

protected void

BubbleChart.layoutPlotChildren​()

被要求更新和布局情节儿童。

protected void

LineChart.layoutPlotChildren​()

被要求更新和布局情节儿童。

protected void

ScatterChart.layoutPlotChildren​()

被要求更新和布局情节儿童。

protected void

StackedAreaChart.layoutPlotChildren​()

被要求更新和布局情节儿童。

protected void

StackedBarChart.layoutPlotChildren​()

被要求更新和布局情节儿童。

protected Dimension2D

CategoryAxis.measureTickMarkSize​(String value, Object range)

测量给定刻度标记值的标签尺寸。

protected Dimension2D

NumberAxis.measureTickMarkSize​(Number value, Object range)

测量给定刻度标记值的标签尺寸。

void

Axis.requestLayout​()

我们通过不做任何事情来抑制requestLayout（）调用，因为我们不希望更改我们的孩子来导致布局。

protected void

AreaChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)

protected void

BarChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)

protected void

BubbleChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)

protected void

LineChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)

protected void

ScatterChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)

一系列已经添加到图表数据模型中。

protected void

StackedAreaChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)

protected void

StackedBarChart.seriesAdded​(XYChart.Series<X,Y> series, int seriesIndex)

一系列已经添加到图表数据模型中。

protected void

AreaChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)

protected void

BarChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)

protected void

LineChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)

protected void

StackedAreaChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)

protected void

StackedBarChart.seriesChanged​(ListChangeListener.Change<? extends XYChart.Series> c)

protected void

AreaChart.seriesRemoved​(XYChart.Series<X,Y> series)

protected void

BarChart.seriesRemoved​(XYChart.Series<X,Y> series)

protected void

BubbleChart.seriesRemoved​(XYChart.Series<X,Y> series)

protected void

LineChart.seriesRemoved​(XYChart.Series<X,Y> series)

protected void

ScatterChart.seriesRemoved​(XYChart.Series<X,Y> series)

数据模型中已经删除了一个系列，但它仍然可以在图表上显示。

protected void

StackedAreaChart.seriesRemoved​(XYChart.Series<X,Y> series)

protected void

StackedBarChart.seriesRemoved​(XYChart.Series<X,Y> series)

protected void

CategoryAxis.setRange​(Object range, boolean animate)

调用将当前轴范围设置为给定范围。

protected void

NumberAxis.setRange​(Object range, boolean animate)

调用将当前轴范围设置为给定范围。

protected void

ValueAxis.tickMarksUpdated​()

如果已经更新了标记，则在布局期间调用，允许子类在反应中执行所需的任何操作。

double

CategoryAxis.toNumericValue​(String value)

所有轴值必须由某些数值表示。

double

ValueAxis.toNumericValue​(T value)

所有轴值必须由某些数值表示。

String

CategoryAxis.toRealValue​(double value)

所有轴值必须由某些数值表示。

T

ValueAxis.toRealValue​(double value)

所有轴值必须由某些数值表示。

String

Axis.TickMark.toString​()

返回此 TickMark对象的字符串表示形式。

String

NumberAxis.DefaultFormatter.toString​(Number object)

将提供的对象转换为其字符串形式。

String

PieChart.Data.toString​()

返回此 Data对象的字符串表示形式。

String

XYChart.Data.toString​()

返回此 Data对象的字符串表示形式。

String

XYChart.Series.toString​()

返回此 Series对象的字符串表示形式。

protected void

AreaChart.updateAxisRange​()

当范围已经无效并且我们需要更新时，这被称为。

protected void

BubbleChart.updateAxisRange​()

当范围已经无效并且我们需要更新时，这被称为。

protected void

LineChart.updateAxisRange​()

当范围已经无效并且我们需要更新时，这被称为。

protected void

StackedAreaChart.updateAxisRange​()

当范围已经无效并且我们需要更新时，这被称为。

protected void

StackedBarChart.updateAxisRange​()

当范围已经无效并且我们需要更新时，这被称为。

Uses of Override in javafx.scene.control

Methods in javafx.scene.control with annotations of type Override

Modifier and Type

方法

描述

<E extends Event>
void

Menu.addEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)

在此MenuItem中注册一个事件处理程序。

EventDispatchChain

Dialog.buildEventDispatchChain​(EventDispatchChain tail)

为此目标构建事件调度链。

EventDispatchChain

Menu.buildEventDispatchChain​(EventDispatchChain tail)

为此目标构建事件调度链。

EventDispatchChain

MenuItem.buildEventDispatchChain​(EventDispatchChain tail)

为此目标构建事件调度链。

EventDispatchChain

Tab.buildEventDispatchChain​(EventDispatchChain tail)

为此目标构建事件调度链。

EventDispatchChain

TableColumnBase.buildEventDispatchChain​(EventDispatchChain tail)

为此目标构建事件调度链。

EventDispatchChain

TreeItem.buildEventDispatchChain​(EventDispatchChain tail)

为此目标构建事件调度链。

void

ListCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TreeCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TreeTableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TreeTableRow.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

SingleSelectionModel.clearAndSelect​(int index)

在SingleSelectionModel中，此方法在功能上等同于调用 select(index) ，因为一次只允许一个选择。

void

TableView.TableViewSelectionModel.clearAndSelect​(int row, TableColumnBase<S,?> column)

清除所有选择，然后选择给定行/列交点处的单元格。

void

SingleSelectionModel.clearSelection​()

清除所有选定索引的选择模型。

void

SingleSelectionModel.clearSelection​(int index)

清除给定索引的选择，如果它当前被选中。

void

TableView.TableViewSelectionModel.clearSelection​(int row, TableColumnBase<S,?> column)

从指定的行/列位置（视图索引）中移除选择。

TextFormatter.Change

TextFormatter.Change.clone​()

void

ListCell.commitEdit​(T newValue)

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

void

TableCell.commitEdit​(T newValue)

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

void

TreeCell.commitEdit​(T newValue)

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

void

TreeTableCell.commitEdit​(T newValue)

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

void

TreeTableRow.commitEdit​(T newValue)

在适当的时候调用此功能（根据您的单元格编辑用户界面的用户交互需求）来执行以下两件事：将相应的事件反馈回支持UI控件（例如

protected double

Control.computeMaxHeight​(double width)

根据提供的宽度计算控制的最大允许高度。

protected double

Control.computeMaxWidth​(double height)

根据提供的高度计算控件的最大允许宽度。

protected double

Control.computeMinHeight​(double width)

根据提供的宽度计算控制的最小允许高度。

protected double

DialogPane.computeMinHeight​(double width)

计算该区域的最小高度。

protected double

Control.computeMinWidth​(double height)

根据提供的高度计算控件的最小允许宽度。

protected double

DialogPane.computeMinWidth​(double height)

计算该区域的最小宽度。

protected double

Control.computePrefHeight​(double width)

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

protected double

DialogPane.computePrefHeight​(double width)

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

protected double

Control.computePrefWidth​(double height)

计算给定高度的该区域的首选宽度。

protected double

DialogPane.computePrefWidth​(double height)

计算给定高度的该区域的首选宽度。

void

PasswordField.copy​()

PasswordField什么也不做。

DialogEvent

DialogEvent.copyFor​(Object newSource, EventTarget newTarget)

protected Skin<?>

Accordion.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Button.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ButtonBar.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

CheckBox.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ChoiceBox.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ColorPicker.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ComboBox.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ContextMenu.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

DateCell.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

DatePicker.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Hyperlink.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Label.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ListCell.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ListView.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

MenuBar.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

MenuButton.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Pagination.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ProgressBar.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ProgressIndicator.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

RadioButton.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ScrollBar.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ScrollPane.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Separator.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Slider.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Spinner.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

SplitMenuButton.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

SplitPane.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TableCell.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TableRow.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TableView.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TabPane.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TextArea.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TextField.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TitledPane.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ToggleButton.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

ToolBar.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

Tooltip.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TreeCell.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TreeTableCell.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TreeTableRow.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TreeTableView.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

protected Skin<?>

TreeView.createDefaultSkin​()

为此控件创建一个新的默认皮肤实例。

void

PasswordField.cut​()

PasswordField什么也不做。

void

SpinnerValueFactory.DoubleSpinnerValueFactory.decrement​(int steps)

尝试按照给定的步数减少 value 。

void

SpinnerValueFactory.IntegerSpinnerValueFactory.decrement​(int steps)

尝试按照给定的步数减少 value 。

void

SpinnerValueFactory.ListSpinnerValueFactory.decrement​(int steps)

尝试按照给定的步数减少 value 。

void

SkinBase.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

boolean

IndexRange.equals​(Object object)

指示一些其他对象是否等于此。

boolean

TablePositionBase.equals​(Object obj)

指示一些其他对象是否等于此。

void

ButtonBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ChoiceBox.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ComboBoxBase.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

Control.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ListCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

MenuButton.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

ScrollBar.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

Slider.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

Spinner.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

SplitMenuButton.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TableCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TextInputControl.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TitledPane.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TreeCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TreeTableCell.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

TreeTableRow.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

void

Button.fire​()

当用户手势指示此事件发生 ButtonBase时调用。

void

CheckBox.fire​()

切换 CheckBox的状态。

void

Hyperlink.fire​()

实现调用ActionEvent如果定义了一个。

void

MenuButton.fire​()

这没有影响。

void

RadioButton.fire​()

当且仅当RadioButton尚未选择或不是ToggleGroup的一部分时，才能切换单选按钮的状态。

void

SplitMenuButton.fire​()

按下按钮时调用动作。

void

ToggleButton.fire​()

当用户手势指示应发生 ButtonBase的事件时调用。

void

TableView.TableViewFocusModel.focus​(int index)

导致给定索引处的项目接收焦点。

void

TableView.TableViewFocusModel.focus​(int row, TableColumn<S,?> column)

导致给定索引处的项目接收焦点。

void

TableView.TableViewSelectionModel.focus​(int row)

void

TreeTableView.TreeTableViewFocusModel.focus​(int index)

导致给定索引处的项目接收焦点。

void

TreeTableView.TreeTableViewFocusModel.focus​(int row, TreeTableColumn<S,?> column)

导致给定索引处的项目接收焦点。

void

TreeTableView.TreeTableViewSelectionModel.focus​(int row)

void

TableView.TableViewFocusModel.focusAboveCell​()

尝试将焦点移动到当前聚焦单元格上方的单元格。

void

TreeTableView.TreeTableViewFocusModel.focusAboveCell​()

尝试将焦点移动到当前聚焦单元格上方的单元格。

void

TableView.TableViewFocusModel.focusBelowCell​()

尝试将焦点移动到当前聚焦单元格下方的单元格。

void

TreeTableView.TreeTableViewFocusModel.focusBelowCell​()

尝试将焦点移动到当前聚焦单元格下方的单元格。

void

TableView.TableViewFocusModel.focusLeftCell​()

尝试将焦点移动到当前聚焦单元格左侧的单元格。

void

TreeTableView.TreeTableViewFocusModel.focusLeftCell​()

尝试将焦点移动到当前聚焦单元格左侧的单元格。

void

TableView.TableViewFocusModel.focusNext​()

尝试将焦点放在当前焦点集中的行之后。

void

TreeTableView.TreeTableViewFocusModel.focusNext​()

尝试将焦点放在当前焦点集中的行之后。

void

TableView.TableViewFocusModel.focusPrevious​()

尝试将重点放在目前重点集中的行之前。

void

TreeTableView.TreeTableViewFocusModel.focusPrevious​()

尝试将重点放在目前重点集中的行之前。

void

TableView.TableViewFocusModel.focusRightCell​()

尝试将焦点移动到当前聚焦单元格右侧的单元格。

void

TreeTableView.TreeTableViewFocusModel.focusRightCell​()

尝试将焦点移动到当前聚焦单元格右侧的单元格。

double

Control.getBaselineOffset​()

基于第一个受管理的子节点计算基线偏移量。

ObservableValue<T>

TableColumn.getCellObservableValue​(int index)

尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。

ObservableValue<T>

TableColumn.getCellObservableValue​(S item)

尝试返回给定项目（其类型为S）的ObservableValue <T>。

ObservableValue<T>

TreeTableColumn.getCellObservableValue​(int index)

尝试返回给定索引（类型为S）中的项目的ObservableValue <T>。

ObservableValue<T>

TreeTableColumn.getCellObservableValue​(TreeItem<S> item)

尝试返回给定项目（其类型为S）的ObservableValue <T>。

int

TablePosition.getColumn​()

Table Table在TableView中表示的列索引。

TableColumn<S,?>

TableView.ResizeFeatures.getColumn​()

返回发生resize的列，如果由于TableView resize操作而创建了此ResizeFeatures实例，则返回null。

int

TreeTablePosition.getColumn​()

TreeTablePosition在TreeTableView中表示的列索引。

TreeTableColumn<S,?>

TreeTableView.ResizeFeatures.getColumn​()

返回发生resize的列，如果由于TreeTableView resize操作而创建了此ResizeFeatures实例，则返回null。

ObservableList<TableColumn<S,?>>

TableColumn.getColumns​()

这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。

ObservableList<TreeTableColumn<S,?>>

TreeTableColumn.getColumns​()

这样可以支持嵌套列，这对于将相关数据组合在一起是有用的。

Orientation

Accordion.getContentBias​()

返回节点调整大小偏置的方向以进行布局。

Orientation

Labeled.getContentBias​()

如果wrapText为true，则contentBias将为HORIZONTAL，否则为null。

Orientation

TitledPane.getContentBias​()

List<CssMetaData<? extends Styleable,?>>

DatePicker.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

Labeled.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

ListView.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

MenuBar.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

Pagination.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

ScrollBar.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

ScrollPane.getControlCssMetaData​()

protected List<CssMetaData<? extends Styleable,?>>

Separator.getControlCssMetaData​()

protected List<CssMetaData<? extends Styleable,?>>

Slider.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

SplitPane.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TableView.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TabPane.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TextArea.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TextField.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TextInputControl.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TitledPane.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

ToolBar.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TreeTableView.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

TreeView.getControlCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

Control.getCssMetaData​()

此方法返回一个List，其中包含所有CssMetaData，用于此控件（从Control.getControlCssMetaData()返回其Skin ，假设skin property为SkinBase 。

List<CssMetaData<? extends Styleable,?>>

DialogPane.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

MenuItem.getCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

PopupControl.CSSBridge.getCssMetaData​()

List<CssMetaData<? extends Styleable,?>>

PopupControl.getCssMetaData​()

这个样式的CssMetaData。

List<CssMetaData<? extends Styleable,?>>

Tab.getCssMetaData​()

这个样式的CssMetaData。

List<CssMetaData<? extends Styleable,?>>

TableColumn.getCssMetaData​()

这个样式的CssMetaData。

List<CssMetaData<? extends Styleable,?>>

Tooltip.getCssMetaData​()

这个样式的CssMetaData。

List<CssMetaData<? extends Styleable,?>>

TreeTableColumn.getCssMetaData​()

这个样式的CssMetaData。

EventType<DialogEvent>

DialogEvent.getEventType​()

int

TableView.TableViewSelectionModel.getFocusedIndex​()

int

TreeTableView.TreeTableViewSelectionModel.getFocusedIndex​()

String

MenuItem.getId​()

获取属性ID的值。

String

PopupControl.getId​()

这个id的这个 PopupControl 。

String

Tab.getId​()

此选项卡的ID。

String

TableColumnBase.getId​()

获取属性ID的值。

protected Pos

RadioButton.getInitialAlignment​()

返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。

protected Pos

ToggleButton.getInitialAlignment​()

返回此控件的初始对齐状态，供JavaFX CSS引擎正确设置其初始值。

protected Cursor

Hyperlink.getInitialCursor​()

返回此控件的初始游标状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

Accordion.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

ButtonBar.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

Cell.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

Control.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

Label.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

MenuBar.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

ProgressBar.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

ProgressIndicator.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

ScrollBar.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

ScrollPane.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

Separator.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

SplitPane.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected Boolean

ToolBar.getInitialFocusTraversable​()

返回此控件的初始焦点遍历状态，供JavaFX CSS引擎正确设置其初始值。

protected int

TableView.TableViewFocusModel.getItemCount​()

返回数据模型中支配控件的项目数。

protected int

TableView.TableViewSelectionModel.getItemCount​()

返回数据模型中支配控件的项目数。

protected int

TreeTableView.TreeTableViewFocusModel.getItemCount​()

返回数据模型中支配控件的项目数。

protected int

TreeTableView.TreeTableViewSelectionModel.getItemCount​()

返回数据模型中支配控件的项目数。

protected S

TableView.TableViewFocusModel.getModelItem​(int index)

返回给定索引处的项目。

protected S

TableView.TableViewSelectionModel.getModelItem​(int index)

返回给定索引处的项目。

protected TreeItem<S>

TreeTableView.TreeTableViewFocusModel.getModelItem​(int index)

返回给定索引处的项目。

TreeItem<S>

TreeTableView.TreeTableViewSelectionModel.getModelItem​(int index)

返回给定索引处的项目。

Node

SkinBase.getNode​()

获取代表此皮肤的节点。

ObservableSet<PseudoClass>

MenuItem.getPseudoClassStates​()

返回此Styleable的伪类状态。

ObservableSet<PseudoClass>

PopupControl.getPseudoClassStates​()

返回此Styleable的伪类状态。

Skin<?>

Control.getSkin​()

获取属性皮肤的值。

Skin<?>

PopupControl.getSkin​()

获取属性皮肤的值。

C

SkinBase.getSkinnable​()

获取此皮肤分配到的Skinnable。

ListView<T>

ListView.EditEvent.getSource​()

返回发生编辑的ListView。

C

SortEvent.getSource​()

TreeItem<T>

TreeItem.TreeModificationEvent.getSource​()

返回发生此事件的TreeItem。

TreeTableView<S>

TreeTableView.EditEvent.getSource​()

返回发生编辑的TreeTableView。

TreeView<T>

TreeView.EditEvent.getSource​()

返回发生编辑的TreeView。

String

MenuItem.getStyle​()

获取属性样式的值。

String

PopupControl.getStyle​()

与此特定的 PopupControl相关联的CSS样式的字符串表示 PopupControl 。

String

Tab.getStyle​()

与此选项卡关联的CSS样式字符串。

String

TableColumnBase.getStyle​()

获取属性样式的值。

Node

MenuItem.getStyleableNode​()

返回表示此Styleable对象的Node。

Node

PopupControl.getStyleableNode​()

返回表示此Styleable对象的Node。

Node

TableColumn.getStyleableNode​()

返回表示此Styleable对象的Node。

Node

TreeTableColumn.getStyleableNode​()

返回表示此Styleable对象的Node。

Styleable

MenuItem.getStyleableParent​()

返回此Styleable的父项，如果没有父项则返回null。

Styleable

PopupControl.CSSBridge.getStyleableParent​()

该方法应被视为最终方法，不应被CSSBridge的任何子类覆盖。

Styleable

PopupControl.getStyleableParent​()

返回此Styleable的父项，如果没有父项则返回null。

Styleable

Tab.getStyleableParent​()

返回此Styleable的父项，如果没有父项则返回null。

Styleable

TableColumn.getStyleableParent​()

返回此Styleable的父项，如果没有父项则返回null。

Styleable

Tooltip.getStyleableParent​()

Styleable

TreeTableColumn.getStyleableParent​()

返回此Styleable的父项，如果没有父项则返回null。

ObservableList<String>

MenuItem.getStyleClass​()

*公开API * *

ObservableList<String>

PopupControl.getStyleClass​()

返回构成此PopupControl的styleClass的String标识符列表。

ObservableList<String>

Tab.getStyleClass​()

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

ObservableList<String>

TableColumnBase.getStyleClass​()

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

TableColumn<S,T>

TablePosition.getTableColumn​()

Table Table在TableView中表示的TableColumn。

TreeTableColumn<S,T>

TreeTablePosition.getTableColumn​()

ToggleGroup

RadioMenuItem.getToggleGroup​()

获取属性toggleGroup的值。

String

MenuItem.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

PopupControl.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

Tab.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

TableColumn.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

TreeTableColumn.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

int

IndexRange.hashCode​()

返回此 Range对象的哈希码。

int

TablePositionBase.hashCode​()

返回此 TablePosition对象的哈希码。

void

ContextMenu.hide​()

隐藏这个 ContextMenu和任何可见的子菜单，假设当这个函数被调用时显示 ContextMenu 。

void

SpinnerValueFactory.DoubleSpinnerValueFactory.increment​(int steps)

试图通过给定的步数来弥补 value 。

void

SpinnerValueFactory.IntegerSpinnerValueFactory.increment​(int steps)

试图通过给定的步数来弥补 value 。

void

SpinnerValueFactory.ListSpinnerValueFactory.increment​(int steps)

试图通过给定的步数来弥补 value 。

boolean

SingleSelectionModel.isEmpty​()

该方法可用于测试是否有任何选定的索引/项目。

boolean

TableView.TableViewFocusModel.isFocused​(int row, TableColumn<S,?> column)

测试给定位置的行/单元格当前是否具有TableView内的焦点。

boolean

TreeTableView.TreeTableViewFocusModel.isFocused​(int row, TreeTableColumn<S,?> column)

测试给定位置的行/单元格当前是否具有TableView内的焦点。

boolean

Control.isResizable​()

返回 true因为所有的控件都可调整大小。

boolean

RadioMenuItem.isSelected​()

获取所选属性的值。

boolean

SingleSelectionModel.isSelected​(int index)

如果给定的索引是此SingleSelectionModel中当前选定的索引，则此方法将返回true。

boolean

TableView.TableViewSelectionModel.isSelected​(int row, TableColumnBase<S,?> column)

测试在此表实例中当前是否选择给定行和列索引的便利函数。

protected void

Cell.layoutChildren​()

在布局传递过程中调用这个 Parent的孩子。

protected void

Control.layoutChildren​()

在布局传递过程中调用这个 Parent的孩子。

protected void

DialogPane.layoutChildren​()

在布局传递期间调用这个 Parent的孩子。

protected void

TableCell.layoutChildren​()

protected void

TreeTableCell.layoutChildren​()

protected void

TreeTableView.layoutChildren​()

在布局传递过程中调用这个 Parent的孩子进行布局。

protected void

TreeView.layoutChildren​()

在布局传递过程中调用这个 Parent的孩子。

Node

TabPane.lookup​(String selector)

找到这个 Node ，或第一个子节点，基于给定的CSS选择器。

Object

CheckBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ChoiceBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ComboBox.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ComboBoxBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Control.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

DatePicker.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Hyperlink.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ListCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ListView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

PasswordField.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ProgressBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ProgressIndicator.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

RadioButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ScrollBar.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ScrollPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Slider.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

Spinner.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

SplitMenuButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TextInputControl.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TitledPane.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

ToggleButton.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableCell.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableRow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeTableView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TreeView.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

<E extends Event>
void

Menu.removeEventHandler​(EventType<E> eventType, EventHandler<E> eventHandler)

从此MenuItem中注销先前注册的事件处理程序。

void

Accordion.requestLayout​()

请求在渲染下一个场景之前执行布局传递。

void

PopupControl.CSSBridge.requestLayout​()

请求在渲染下一个场景之前执行布局传递。

void

SingleSelectionModel.select​(int index)

选择给定的索引。

void

SingleSelectionModel.select​(T obj)

选择基础数据模型中给定对象的第一个实例的索引。

void

TableView.TableViewSelectionModel.select​(int row, TableColumnBase<S,?> column)

选择给定的行/列交叉点的单元格。

BooleanProperty

RadioMenuItem.selectedProperty​()

abstract void

MultipleSelectionModel.selectFirst​()

该方法将尝试选择控件中的第一个索引。

void

SingleSelectionModel.selectFirst​()

选择第一个索引。

abstract void

MultipleSelectionModel.selectLast​()

此方法将尝试选择控件中的最后一个索引。

void

SingleSelectionModel.selectLast​()

选择最后一个索引。

void

SingleSelectionModel.selectNext​()

选择下一个索引。

void

SingleSelectionModel.selectPrevious​()

选择上一个索引。

void

TableView.TableViewSelectionModel.selectRange​(int minRow, TableColumnBase<S,?> minColumn, int maxRow, TableColumnBase<S,?> maxColumn)

选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。

void

TreeTableView.TreeTableViewSelectionModel.selectRange​(int minRow, TableColumnBase<TreeItem<S>,?> minColumn, int maxRow, TableColumnBase<TreeItem<S>,?> maxColumn)

选择范围内的单元格（minRow，minColumn）至（maxRow，maxColumn）（包括）。

void

RadioMenuItem.setSelected​(boolean value)

设置所选属性的值。

void

Control.setSkin​(Skin<?> value)

设置属性皮肤的值。

void

PopupControl.setSkin​(Skin<?> value)

设置属性皮肤的值。

void

RadioMenuItem.setToggleGroup​(ToggleGroup value)

设置属性toggleGroup的值。

void

ContextMenu.show​(Node anchor, double screenX, double screenY)

在指定的屏幕坐标处显示 ContextMenu 。

ObjectProperty<Skin<?>>

Control.skinProperty​()

皮肤负责渲染这个 Control 。

ObjectProperty<Skin<?>>

PopupControl.skinProperty​()

皮肤负责渲染这个 PopupControl 。

void

ListCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TreeCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TreeTableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TreeTableRow.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

ObjectProperty<ToggleGroup>

RadioMenuItem.toggleGroupProperty​()

代表这个RadioMenuItem所属的ToggleGroup 。

String

ButtonType.toString​()

返回对象的字符串表示形式。

String

DialogEvent.toString​()

返回此 DialogEvent对象的字符串表示形式。

String

IndexRange.toString​()

返回此 Range对象的字符串表示形式。

String

Labeled.toString​()

String

ListView.EditEvent.toString​()

返回此 EditEvent对象的字符串表示形式。

String

MenuItem.toString​()

String

TablePosition.toString​()

返回此 TablePosition对象的字符串表示形式。

String

TextFormatter.Change.toString​()

String

TreeItem.toString​()

返回此 TreeItem对象的字符串表示形式。

void

DateCell.updateItem​(LocalDate item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

TableCell.updateSelected​(boolean selected)

更新此单元格是否处于选定状态。

void

TreeTableCell.updateSelected​(boolean selected)

更新此单元格是否处于选定状态。

Uses of Override in javafx.scene.control.cell

Methods in javafx.scene.control.cell with annotations of type Override

Modifier and Type

方法

描述

ObservableValue<T>

MapValueFactory.call​(TableColumn.CellDataFeatures<Map,T> cdf)

ObservableValue<T>

PropertyValueFactory.call​(TableColumn.CellDataFeatures<S,T> param)

call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。

ObservableValue<T>

TreeItemPropertyValueFactory.call​(TreeTableColumn.CellDataFeatures<S,T> param)

call方法在需要时被调用，并且被赋予类型为P的单个参数，并且要求返回类型为R的对象。

void

ChoiceBoxListCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ChoiceBoxTableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ChoiceBoxTreeCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ChoiceBoxTreeTableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ComboBoxListCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ComboBoxTableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ComboBoxTreeCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ComboBoxTreeTableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TextFieldListCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TextFieldTableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TextFieldTreeCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

TextFieldTreeTableCell.cancelEdit​()

调用此功能从编辑状态转换为非编辑状态，而不保存任何用户输入。

void

ChoiceBoxListCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

ChoiceBoxTableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

ChoiceBoxTreeCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

ChoiceBoxTreeTableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

ComboBoxListCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

ComboBoxTableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

ComboBoxTreeCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

ComboBoxTreeTableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TextFieldListCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TextFieldTableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TextFieldTreeCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

TextFieldTreeTableCell.startEdit​()

调用此功能从非编辑状态转换到编辑状态，如果单元格是可编辑的。

void

CheckBoxListCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

CheckBoxTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

CheckBoxTreeCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

CheckBoxTreeTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ChoiceBoxListCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ChoiceBoxTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ChoiceBoxTreeCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ChoiceBoxTreeTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ComboBoxListCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ComboBoxTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ComboBoxTreeCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ComboBoxTreeTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ProgressBarTableCell.updateItem​(Double item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

ProgressBarTreeTableCell.updateItem​(Double item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

TextFieldListCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

TextFieldTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

TextFieldTreeCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

void

TextFieldTreeTableCell.updateItem​(T item, boolean empty)

updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

Uses of Override in javafx.scene.control.skin

Methods in javafx.scene.control.skin with annotations of type Override

Modifier and Type

方法

描述

protected void

TextAreaSkin.addHighlight​(List<? extends Node> nodes, int start)

从输入法添加组合文本的高亮。

protected void

TextFieldSkin.addHighlight​(List<? extends Node> nodes, int start)

从输入法添加组合文本的高亮。

protected double

ComboBoxBaseSkin.computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)

基于第一个受管理的子节点计算基线偏移量。

double

LabeledSkinBase.computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)

基于第一个受管理的子节点计算基线偏移量。

double

ProgressBarSkin.computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)

基于第一个受管理的子节点计算基线偏移量。

protected double

SpinnerSkin.computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)

基于第一个受管理的子节点计算基线偏移量。

double

TabPaneSkin.computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)

基于第一个受管理的子节点计算基线偏移量。

double

TextAreaSkin.computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)

基于第一个受管理的子节点计算基线偏移量。

double

TextFieldSkin.computeBaselineOffset​(double topInset, double rightInset, double bottomInset, double leftInset)

基于第一个受管理的子节点计算基线偏移量。

protected double

ChoiceBoxSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

ComboBoxBaseSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

ComboBoxListViewSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

LabeledSkinBase.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

ListCellSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

MenuBarSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

MenuButtonSkinBase.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

ProgressBarSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

ScrollBarSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

SeparatorSkin.computeMaxHeight​(double w, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

SliderSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

SpinnerSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

TableRowSkinBase.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

TextFieldSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

ToolBarSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

TreeCellSkin.computeMaxHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最大允许高度。

protected double

ChoiceBoxSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

ComboBoxBaseSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

ComboBoxListViewSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

LabeledSkinBase.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

MenuButtonSkinBase.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

ProgressBarSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

ScrollBarSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

SeparatorSkin.computeMaxWidth​(double h, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

SliderSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

SpinnerSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

TitledPaneSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

ToolBarSkin.computeMaxWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最大允许宽度。

protected double

AccordionSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

CheckBoxSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

ChoiceBoxSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

ComboBoxListViewSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

LabeledSkinBase.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

ListCellSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

MenuBarSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

MenuButtonSkinBase.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

PaginationSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

RadioButtonSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

ScrollBarSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

ScrollPaneSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

SeparatorSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

SliderSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

SpinnerSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

SplitPaneSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

TableColumnHeader.computeMinHeight​(double width)

计算该区域的最小高度。

protected double

TableHeaderRow.computeMinHeight​(double width)

计算该区域的最小高度。

protected double

TableRowSkinBase.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

TextFieldSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

TitledPaneSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

ToolBarSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

TreeCellSkin.computeMinHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的宽度计算皮肤的最小允许高度。

protected double

CheckBoxSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算并返回此Labeled的最小宽度。

protected double

ChoiceBoxSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

ComboBoxListViewSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

DatePickerSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

LabeledSkinBase.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算并返回此Labeled的最小宽度。

protected double

MenuBarSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

MenuButtonSkinBase.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

PaginationSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

RadioButtonSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算并返回此Labeled的最小宽度。

protected double

ScrollBarSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

ScrollPaneSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

SeparatorSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

SliderSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

SpinnerSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

protected double

SplitPaneSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

TitledPaneSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算并返回此Labeled的最小宽度。

protected double

ToolBarSkin.computeMinWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

根据提供的高度计算皮肤的最小允许宽度。

protected double

AccordionSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

CheckBoxSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ChoiceBoxSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ComboBoxBaseSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ComboBoxListViewSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

DateCellSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

LabeledSkinBase.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ListCellSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ListViewSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

MenuBarSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

MenuButtonSkinBase.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

NestedTableColumnHeader.computePrefHeight​(double width)

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

protected double

PaginationSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ProgressBarSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

RadioButtonSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ScrollBarSkin.computePrefHeight​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ScrollPaneSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

SeparatorSkin.computePrefHeight​(double w, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

SliderSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

SpinnerSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

SplitPaneSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

TableColumnHeader.computePrefHeight​(double width)

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

protected double

TableHeaderRow.computePrefHeight​(double width)

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

protected double

TableRowSkinBase.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

TableViewSkinBase.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

TabPaneSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

TextFieldSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

TitledPaneSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

ToolBarSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

TreeCellSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

TreeViewSkin.computePrefHeight​(double width, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选高度。

protected double

VirtualFlow.computePrefHeight​(double width)

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

protected double

CheckBoxSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ChoiceBoxSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算此 SkinBase的首选宽度。

protected double

ColorPickerSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ComboBoxBaseSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ComboBoxListViewSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

DateCellSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

LabeledSkinBase.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ListCellSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ListViewSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

MenuBarSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

MenuButtonSkinBase.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

NestedTableColumnHeader.computePrefWidth​(double height)

计算给定高度的该区域的首选宽度。

protected double

PaginationSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ProgressBarSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

RadioButtonSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ScrollBarSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ScrollPaneSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

SeparatorSkin.computePrefWidth​(double h, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

SliderSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

SpinnerSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

SplitPaneSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

TableCellSkinBase.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

TableColumnHeader.computePrefWidth​(double height)

计算给定高度的该区域的首选宽度。

protected double

TableHeaderRow.computePrefWidth​(double height)

计算给定高度的该区域的首选宽度。

protected double

TableRowSkinBase.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

TableViewSkinBase.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

TabPaneSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算 SkinBase的首选宽度。

protected double

TextFieldSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

TitledPaneSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

ToolBarSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

TreeCellSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

TreeViewSkin.computePrefWidth​(double height, double topInset, double rightInset, double bottomInset, double leftInset)

计算这个 SkinBase的首选宽度。

protected double

VirtualFlow.computePrefWidth​(double height)

计算给定高度的该区域的首选宽度。

protected TableCell<T,?>

TableRowSkin.createCell​(TableColumnBase tcb)

创建适用于表示给定表列实例的新单元实例。

protected TreeTableCell<T,?>

TreeTableRowSkin.createCell​(TableColumnBase tcb)

创建适用于表示给定表列实例的新单元实例。

void

AccordionSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ButtonSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

CheckBoxSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ChoiceBoxSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ColorPickerSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ComboBoxListViewSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ContextMenuSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

DateCellSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

DatePickerSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

HyperlinkSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ListCellSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ListViewSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

MenuBarSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

MenuButtonSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

MenuButtonSkinBase.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

PaginationSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ProgressIndicatorSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

RadioButtonSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ScrollBarSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ScrollPaneSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

SliderSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

SpinnerSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

SplitMenuButtonSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TableCellSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TableCellSkinBase.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TableRowSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TableViewSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TableViewSkinBase.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TabPaneSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TextAreaSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TextFieldSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TitledPaneSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ToggleButtonSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

ToolBarSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TooltipSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TreeCellSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TreeTableCellSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TreeTableRowSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TreeTableViewSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

void

TreeViewSkin.dispose​()

当Skinnable更换皮肤时，由Skinnable调用。

protected void

ListViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

protected void

TableViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

protected void

TextInputControlSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

protected void

ToolBarSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

protected void

TreeTableViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

protected void

TreeViewSkin.executeAccessibleAction​(AccessibleAction action, Object... parameters)

该方法由辅助技术调用，请求执行由参数指示的动作。

Rectangle2D

TextAreaSkin.getCharacterBounds​(int index)

返回给定索引处字符的边界。

Rectangle2D

TextFieldSkin.getCharacterBounds​(int index)

返回给定索引处字符的边界。

protected StringConverter<Color>

ColorPickerSkin.getConverter​()

子类负责获取转换器。

protected StringConverter<T>

ComboBoxListViewSkin.getConverter​()

子类负责获取转换器。

protected StringConverter<LocalDate>

DatePickerSkin.getConverter​()

子类负责获取转换器。

List<CssMetaData<? extends Styleable,?>>

CellSkinBase.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

ColorPickerSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

MenuBarSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

PaginationSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

ProgressBarSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

ProgressIndicatorSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

TableColumnHeader.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

TabPaneSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

TextInputControlSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

ToolBarSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

TreeCellSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

TreeTableRowSkin.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

Node

ColorPickerSkin.getDisplayNode​()

该方法应该返回一个将位于ComboBox'按钮'区域内的节点。

Node

ComboBoxListViewSkin.getDisplayNode​()

该方法应该返回一个将位于ComboBox'按钮'区域内的节点。

Node

DatePickerSkin.getDisplayNode​()

该方法应该返回一个将位于ComboBox'按钮'区域内的节点。

protected TextField

ColorPickerSkin.getEditor​()

ColorPicker不使用主文本字段，因此此方法已被覆盖以返回null。

protected TextField

ComboBoxListViewSkin.getEditor​()

子类负责获取编辑器。

protected TextField

DatePickerSkin.getEditor​()

子类负责获取编辑器。

protected int

TextAreaSkin.getInsertionPoint​(double x, double y)

返回给定位置的插入点。

protected int

ListViewSkin.getItemCount​()

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

protected int

TableViewSkin.getItemCount​()

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

protected int

TreeTableViewSkin.getItemCount​()

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

protected int

TreeViewSkin.getItemCount​()

返回此容器中的项目总数，包括当前未隐藏的项目的总数。

Point2D

TextAreaSkin.getMenuPosition​()

根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。

Point2D

TextFieldSkin.getMenuPosition​()

根据插入符句柄或选择句柄的位置返回用于上下文菜单的位置。

Node

ContextMenuSkin.getNode​()

获取代表此皮肤的节点。

Node

TooltipSkin.getNode​()

获取代表此皮肤的节点。

protected Node

ColorPickerSkin.getPopupContent​()

此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。

Node

ComboBoxListViewSkin.getPopupContent​()

此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。

Node

DatePickerSkin.getPopupContent​()

此方法应返回当用户单击ComboBox'按钮'区域时将显示的节点。

protected PathElement[]

TextAreaSkin.getRangeShape​(int start, int end)

protected PathElement[]

TextFieldSkin.getRangeShape​(int start, int end)

ContextMenu

ContextMenuSkin.getSkinnable​()

获取此皮肤分配到的Skinnable。

Tooltip

TooltipSkin.getSkinnable​()

获取此皮肤分配到的Skinnable。

protected TableColumn<T,?>

TableRowSkin.getTableColumn​(TableCell<T,?> cell)

返回给定单元格实例的TableColumnBase实例。

protected TreeTableColumn<T,?>

TreeTableRowSkin.getTableColumn​(TreeTableCell cell)

返回给定单元格实例的TableColumnBase实例。

protected PathElement[]

TextAreaSkin.getUnderlineShape​(int start, int end)

protected PathElement[]

TextFieldSkin.getUnderlineShape​(int start, int end)

protected ObservableList<TableColumn<T,?>>

TableRowSkin.getVisibleLeafColumns​()

返回一个不可修改的列表，其中包含当前可见的叶子列。

protected ObservableList<TreeTableColumn<T,?>>

TreeTableRowSkin.getVisibleLeafColumns​()

返回一个不可修改的列表，其中包含当前可见的叶子列。

protected ObjectProperty<Node>

TreeTableRowSkin.graphicProperty​()

返回在公开节点内部绘制的图形。

void

ComboBoxPopupControl.hide​()

当隐藏ComboBox弹出窗口时，将调用此方法。

protected void

TextAreaSkin.invalidateMetrics​()

对TextInputControl的缓存最小和最小大小无效。

protected void

AccordionSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

CheckBoxSkin.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

ChoiceBoxSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

ColorPickerSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

ComboBoxBaseSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

ComboBoxListViewSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

DateCellSkin.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

LabeledSkinBase.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

ListViewSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

MenuBarSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

MenuButtonSkinBase.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

NestedTableColumnHeader.layoutChildren​()

在布局传递过程中调用这个 Parent的孩子。

protected void

PaginationSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

ProgressBarSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

ProgressIndicatorSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

RadioButtonSkin.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

ScrollBarSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

ScrollPaneSkin.layoutChildren​(double x, double y, double w, double h)

protected void

SeparatorSkin.layoutChildren​(double x, double y, double w, double h)

我们只需要处理单一的“线”儿童地区。

protected void

SliderSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

SpinnerSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

SplitPaneSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

TableCellSkinBase.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

TableColumnHeader.layoutChildren​()

在布局传递过程中调用这个 Parent的孩子。

protected void

TableHeaderRow.layoutChildren​()

在布局传递期间调用这个 Parent的孩子进行布局。

protected void

TableRowSkinBase.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

TableViewSkinBase.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

TabPaneSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

TextAreaSkin.layoutChildren​(double contentX, double contentY, double contentWidth, double contentHeight)

在场景图的布局过程中调用。

protected void

TextFieldSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

TitledPaneSkin.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

ToolBarSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

TreeCellSkin.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

TreeTableRowSkin.layoutChildren​(double x, double y, double w, double h)

布局算法的工作原理如下： - 获取标签的w / h，图形w / h，文本w / h - 基于graphicVPos，graphicHPos，graphicTextGap和图形w / h和文本w / h - （请注意，文本内容已经在必要时被预截取） - 基于内容w / h计算内容x / y并标记为w / h，标记的hpos和vpos定位图形和文本

protected void

TreeViewSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

VirtualContainerBase.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

protected void

VirtualFlow.layoutChildren​()

在布局传递过程中调用这个 Parent的孩子。

protected String

TextFieldSkin.maskText​(String txt)

子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。

void

TextAreaSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)

按照给定的方向，以指定文本单位之一移动插入符号。

void

TextFieldSkin.moveCaret​(TextInputControlSkin.TextUnit unit, TextInputControlSkin.Direction dir, boolean select)

按照给定的方向，以指定文本单位之一移动插入符号。

Object

ComboBoxListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

LabeledSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ListViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

MenuBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

MenuButtonSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

PaginationSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ScrollPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableColumnHeader.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TableViewSkinBase.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TabPaneSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

protected Object

TextAreaSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TextFieldSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

ToolBarSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

protected Object

TreeTableRowSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TreeTableViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected Object

TreeViewSkin.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

protected void

TextAreaSkin.removeHighlight​(List<? extends Node> nodes)

从Input Method中删除组合文本的高亮。

protected void

TextFieldSkin.removeHighlight​(List<? extends Node> nodes)

从Input Method中删除组合文本的高亮。

void

VirtualFlow.requestLayout​()

被覆盖来实现更有效地支持布局。

protected void

TextAreaSkin.scrollCharacterToVisible​(int index)

确保给定索引处的字符是可见的。

protected void

VirtualFlow.setHeight​(double value)

设置属性高度的值。

protected void

VirtualFlow.setWidth​(double value)

设置属性宽度的值。

void

ColorPickerSkin.show​()

当显示ComboBox弹出窗口时，将调用此方法。

void

ComboBoxPopupControl.show​()

当显示ComboBox弹出窗口时，将调用此方法。

void

DatePickerSkin.show​()

当显示ComboBox弹出窗口时，将调用此方法。

protected double

MenuBarSkin.snappedBottomInset​()

获取底部插图的实用方法，其中包括填充和边框插入。

protected double

MenuBarSkin.snappedLeftInset​()

获取包含填充和边框插入的左边插图的实用方法。

protected double

MenuBarSkin.snappedRightInset​()

获取正确的插图的实用方法，包括填充和边框插入。

protected double

MenuBarSkin.snappedTopInset​()

获取包含填充和边框插入的顶层插图的实用方法。

ReadOnlyObjectProperty<TableColumn<S,T>>

TableCellSkin.tableColumnProperty​()

负责此单元格的TableColumnBase实例。

ReadOnlyObjectProperty<TreeTableColumn<S,T>>

TreeTableCellSkin.tableColumnProperty​()

负责此单元格的TableColumnBase实例。

protected void

TableRowSkin.updateCell​(TableCell<T,?> cell, TableRow<T> row)

允许给定单元格被告知它是给定行的成员的方法。

protected void

TreeTableRowSkin.updateCell​(TreeTableCell<T,?> cell, TreeTableRow<T> row)

允许给定单元格被告知它是给定行的成员的方法。

protected void

CheckBoxSkin.updateChildren​()

更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

protected void

DateCellSkin.updateChildren​()

更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

protected void

RadioButtonSkin.updateChildren​()

更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

protected void

TitledPaneSkin.updateChildren​()

更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

protected void

TreeCellSkin.updateChildren​()

更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

protected void

TreeTableRowSkin.updateChildren​()

更新由LabeledSkinBase管理的子项，LabeledSkinBase可以是Labeled图形和/或Text节点。

protected void

TextAreaSkin.updateHighlightFill​()

当highlightFill属性更改时调用。

protected void

ListViewSkin.updateItemCount​()

当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

protected void

TableViewSkinBase.updateItemCount​()

当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

protected void

TreeTableViewSkin.updateItemCount​()

当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

protected void

TreeViewSkin.updateItemCount​()

当可能的项目计数已经改变（即滚动已经发生，控件已调整大小等）时，调用此方法。

Uses of Override in javafx.scene.image

Methods in javafx.scene.image with annotations of type Override

Modifier and Type

方法

描述

List<CssMetaData<? extends Styleable,?>>

ImageView.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

boolean

WritablePixelFormat.isWritable​()

Uses of Override in javafx.scene.input

Methods in javafx.scene.input with annotations of type Override

Modifier and Type

方法

描述

ContextMenuEvent

ContextMenuEvent.copyFor​(Object newSource, EventTarget newTarget)

DragEvent

DragEvent.copyFor​(Object newSource, EventTarget newTarget)

GestureEvent

GestureEvent.copyFor​(Object newSource, EventTarget newTarget)

使用指定的事件源和目标创建并返回此事件的副本。

InputMethodEvent

InputMethodEvent.copyFor​(Object newSource, EventTarget newTarget)

KeyEvent

KeyEvent.copyFor​(Object newSource, EventTarget newTarget)

MouseDragEvent

MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget)

MouseDragEvent

MouseDragEvent.copyFor​(Object newSource, EventTarget newTarget, EventType<? extends MouseEvent> type)

MouseEvent

MouseEvent.copyFor​(Object newSource, EventTarget newTarget)

将此事件复制到不同的来源和目标。

RotateEvent

RotateEvent.copyFor​(Object newSource, EventTarget newTarget)

ScrollEvent

ScrollEvent.copyFor​(Object newSource, EventTarget newTarget)

SwipeEvent

SwipeEvent.copyFor​(Object newSource, EventTarget newTarget)

TouchEvent

TouchEvent.copyFor​(Object newSource, EventTarget newTarget)

使用指定的事件源和目标创建并返回此事件的副本。

ZoomEvent

ZoomEvent.copyFor​(Object newSource, EventTarget newTarget)

boolean

DataFormat.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

KeyCharacterCombination.equals​(Object obj)

测试这个 KeyCharacterCombination是否等于指定的对象。

boolean

KeyCodeCombination.equals​(Object obj)

测试这个 KeyCodeCombination是否等于指定的对象。

boolean

KeyCombination.equals​(Object obj)

测试这个 KeyCombination是否等于指定的对象。

String

KeyCharacterCombination.getDisplayText​()

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

String

KeyCodeCombination.getDisplayText​()

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

EventType<ContextMenuEvent>

ContextMenuEvent.getEventType​()

EventType<DragEvent>

DragEvent.getEventType​()

EventType<? extends GestureEvent>

GestureEvent.getEventType​()

EventType<? extends InputEvent>

InputEvent.getEventType​()

EventType<InputMethodEvent>

InputMethodEvent.getEventType​()

EventType<KeyEvent>

KeyEvent.getEventType​()

EventType<MouseDragEvent>

MouseDragEvent.getEventType​()

EventType<? extends MouseEvent>

MouseEvent.getEventType​()

EventType<RotateEvent>

RotateEvent.getEventType​()

EventType<ScrollEvent>

ScrollEvent.getEventType​()

EventType<SwipeEvent>

SwipeEvent.getEventType​()

EventType<TouchEvent>

TouchEvent.getEventType​()

EventType<ZoomEvent>

ZoomEvent.getEventType​()

String

KeyCharacterCombination.getName​()

返回此 KeyCharacterCombination的字符串表示 KeyCharacterCombination 。

String

KeyCodeCombination.getName​()

返回此 KeyCodeCombination的字符串表示 KeyCodeCombination 。

int

DataFormat.hashCode​()

返回此 DataFormat对象的哈希码。

int

KeyCharacterCombination.hashCode​()

返回此 KeyCharacterCombination的哈希码值。

int

KeyCodeCombination.hashCode​()

返回此 KeyCodeCombination的哈希码值。

int

KeyCombination.hashCode​()

返回此 KeyCombination的哈希码值。

boolean

KeyCharacterCombination.match​(KeyEvent event)

测试此组合是否与给定的 KeyEvent组合键匹配。

boolean

KeyCodeCombination.match​(KeyEvent event)

测试此键组合是否与给定的 KeyEvent组合键匹配。

String

ContextMenuEvent.toString​()

返回此 ContextMenuEvent对象的字符串表示形式。

String

DataFormat.toString​()

返回此 DataFormat对象的字符串表示形式。

String

GestureEvent.toString​()

返回此 GestureEvent对象的字符串表示形式。

String

InputMethodEvent.toString​()

返回此 InputMethodEvent对象的字符串表示形式。

String

InputMethodTextRun.toString​()

返回此 InputMethodTextRun对象的字符串表示形式。

String

KeyCombination.Modifier.toString​()

返回修饰符的字符串表示形式。

String

KeyCombination.toString​()

返回此对象的字符串表示形式。

String

KeyEvent.toString​()

返回此 KeyEvent对象的字符串表示形式。

String

MouseDragEvent.toString​()

返回此 MouseDragEvent对象的字符串表示形式。

String

MouseEvent.toString​()

返回此 MouseEvent对象的字符串表示形式。

String

PickResult.toString​()

String

RotateEvent.toString​()

返回此 RotateEvent对象的字符串表示形式。

String

ScrollEvent.toString​()

返回此 ScrollEvent对象的字符串表示形式。

String

SwipeEvent.toString​()

返回此 SwipeEvent对象的字符串表示形式。

String

TouchEvent.toString​()

返回此 TouchEvent对象的字符串表示形式。

String

TouchPoint.toString​()

返回此 TouchPoint对象的字符串表示形式。

String

ZoomEvent.toString​()

返回此 ZoomEvent对象的字符串表示形式。

Uses of Override in javafx.scene.layout

Methods in javafx.scene.layout with annotations of type Override

Modifier and Type

方法

描述

protected double

AnchorPane.computeMinHeight​(double width)

protected double

BorderPane.computeMinHeight​(double width)

protected double

FlowPane.computeMinHeight​(double width)

protected double

GridPane.computeMinHeight​(double width)

protected double

HBox.computeMinHeight​(double width)

protected double

Region.computeMinHeight​(double width)

计算该区域的最小高度。

protected double

StackPane.computeMinHeight​(double width)

protected double

TilePane.computeMinHeight​(double width)

protected double

VBox.computeMinHeight​(double width)

protected double

AnchorPane.computeMinWidth​(double height)

protected double

BorderPane.computeMinWidth​(double height)

protected double

FlowPane.computeMinWidth​(double height)

protected double

GridPane.computeMinWidth​(double height)

protected double

HBox.computeMinWidth​(double height)

protected double

Region.computeMinWidth​(double height)

计算该区域的最小宽度。

protected double

StackPane.computeMinWidth​(double height)

protected double

TilePane.computeMinWidth​(double height)

protected double

VBox.computeMinWidth​(double height)

protected double

AnchorPane.computePrefHeight​(double width)

protected double

BorderPane.computePrefHeight​(double width)

protected double

FlowPane.computePrefHeight​(double forWidth)

protected double

GridPane.computePrefHeight​(double width)

protected double

HBox.computePrefHeight​(double width)

protected double

Region.computePrefHeight​(double width)

计算给定宽度的该区域的首选高度; 区域子类应该覆盖此方法，以根据其内容和布局策略返回适当的值。

protected double

StackPane.computePrefHeight​(double width)

protected double

TilePane.computePrefHeight​(double forWidth)

protected double

VBox.computePrefHeight​(double width)

protected double

AnchorPane.computePrefWidth​(double height)

protected double

BorderPane.computePrefWidth​(double height)

protected double

FlowPane.computePrefWidth​(double forHeight)

protected double

GridPane.computePrefWidth​(double height)

protected double

HBox.computePrefWidth​(double height)

protected double

Region.computePrefWidth​(double height)

计算给定高度的该区域的首选宽度。

protected double

StackPane.computePrefWidth​(double height)

protected double

TilePane.computePrefWidth​(double forHeight)

protected double

VBox.computePrefWidth​(double height)

boolean

Background.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundFill.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundImage.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundPosition.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BackgroundSize.equals​(Object o)

指示一些其他对象是否等于此。

boolean

Border.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderImage.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderStroke.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderStrokeStyle.equals​(Object o)

指示一些其他对象是否等于此。

boolean

BorderWidths.equals​(Object o)

指示一些其他对象是否等于此。

boolean

CornerRadii.equals​(Object o)

指示一些其他对象是否等于此。

double

HBox.getBaselineOffset​()

ObservableList<Node>

Pane.getChildren​()

Orientation

BorderPane.getContentBias​()

Orientation

FlowPane.getContentBias​()

Orientation

GridPane.getContentBias​()

Orientation

HBox.getContentBias​()

Orientation

StackPane.getContentBias​()

Orientation

TilePane.getContentBias​()

Orientation

VBox.getContentBias​()

List<CssMetaData<? extends Styleable,?>>

FlowPane.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

GridPane.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

HBox.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

Region.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

StackPane.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

TilePane.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

VBox.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

int

Background.hashCode​()

返回对象的哈希码值。

int

BackgroundFill.hashCode​()

返回对象的哈希码值。

int

BackgroundImage.hashCode​()

返回对象的哈希码值。

int

BackgroundPosition.hashCode​()

返回对象的哈希码值。

int

BackgroundSize.hashCode​()

返回对象的哈希码值。

int

Border.hashCode​()

返回对象的哈希码值。

int

BorderImage.hashCode​()

返回对象的哈希码值。

int

BorderStroke.hashCode​()

返回对象的哈希码值。

int

BorderStrokeStyle.hashCode​()

返回对象的哈希码值。

int

BorderWidths.hashCode​()

返回对象的哈希码值。

int

CornerRadii.hashCode​()

返回对象的哈希码值。

boolean

Region.isResizable​()

返回 true因为所有地区都可调整大小。

protected void

AnchorPane.layoutChildren​()

protected void

BorderPane.layoutChildren​()

protected void

FlowPane.layoutChildren​()

protected void

GridPane.layoutChildren​()

protected void

HBox.layoutChildren​()

protected void

StackPane.layoutChildren​()

protected void

TilePane.layoutChildren​()

protected void

VBox.layoutChildren​()

double

Region.maxHeight​(double width)

在布局期间调用以确定此节点的最大高度。

double

Region.maxWidth​(double height)

在布局期间调用以确定此节点的最大宽度。

double

Region.minHeight​(double width)

在布局期间调用以确定此节点的最小高度。

double

Region.minWidth​(double height)

在布局期间调用以确定此节点的最小宽度。

double

Region.prefHeight​(double width)

在布局期间调用以确定此节点的首选高度。

double

Region.prefWidth​(double height)

在布局期间调用以确定此节点的首选宽度。

void

FlowPane.requestLayout​()

void

GridPane.requestLayout​()

void

HBox.requestLayout​()

void

StackPane.requestLayout​()

void

TilePane.requestLayout​()

void

VBox.requestLayout​()

void

Region.resize​(double width, double height)

在布局期间由区域的父项调用以设置区域的宽度和高度。

String

BorderStrokeStyle.toString​()

返回对象的字符串表示形式。

String

ColumnConstraints.toString​()

返回此 ColumnConstraints对象的字符串表示形式。

String

CornerRadii.toString​()

String

GridPane.toString​()

返回此 GridPane对象的字符串表示形式。

String

RowConstraints.toString​()

返回此 RowConstraints对象的字符串表示形式。

Uses of Override in javafx.scene.media

Methods in javafx.scene.media with annotations of type Override

Modifier and Type

方法

描述

MediaErrorEvent

MediaErrorEvent.copyFor​(Object newSource, EventTarget newTarget)

EventType<MediaErrorEvent>

MediaErrorEvent.getEventType​()

String

MediaErrorEvent.toString​()

检索事件的 String表示。

String

MediaException.toString​()

返回此 MediaException对象的字符串表示形式。

String

Track.toString​()

Uses of Override in javafx.scene.paint

Methods in javafx.scene.paint with annotations of type Override

Modifier and Type

方法

描述

boolean

Color.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

LinearGradient.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

RadialGradient.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Stop.equals​(Object obj)

指示一些其他对象是否等于此。

int

Color.hashCode​()

返回此 Color对象的哈希码。

int

LinearGradient.hashCode​()

返回此 LinearGradient对象的哈希码。

int

RadialGradient.hashCode​()

返回此 RadialGradient对象的哈希码。

int

Stop.hashCode​()

返回此 Stop对象的哈希码。

Color

Color.interpolate​(Color endValue, double t)

该函数计算 0.0和 1.0之间的分数 t的内插值。

boolean

Color.isOpaque​()

获取此Paint是否完全不透明。

boolean

ImagePattern.isOpaque​()

boolean

LinearGradient.isOpaque​()

获取此Paint是否完全不透明。

boolean

RadialGradient.isOpaque​()

获取此Paint是否完全不透明。

String

Color.toString​()

返回此 Color的字符串表示 Color 。

String

LinearGradient.toString​()

返回此 LinearGradient对象的字符串表示形式。

String

PhongMaterial.toString​()

String

RadialGradient.toString​()

返回此 RadialGradient对象的字符串表示形式。

String

Stop.toString​()

返回此 Stop对象的字符串表示形式。

Uses of Override in javafx.scene.shape

Methods in javafx.scene.shape with annotations of type Override

Modifier and Type

方法

描述

List<CssMetaData<? extends Styleable,?>>

Rectangle.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

Shape.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

String

Arc.toString​()

返回此 Arc对象的字符串表示形式。

String

ArcTo.toString​()

返回此 ArcTo对象的字符串表示形式。

String

Circle.toString​()

返回此 Circle对象的字符串表示形式。

String

ClosePath.toString​()

返回此 ArcTo对象的字符串表示形式。

String

CubicCurve.toString​()

返回此 CubicCurve对象的字符串表示形式。

String

CubicCurveTo.toString​()

返回此 CubicCurveTo对象的字符串表示形式。

String

Ellipse.toString​()

返回此 Ellipse对象的字符串表示形式。

String

HLineTo.toString​()

返回此 HLineTo对象的字符串表示形式。

String

Line.toString​()

返回此 Line对象的字符串表示形式。

String

LineTo.toString​()

返回此 LineTo对象的字符串表示形式。

String

MoveTo.toString​()

返回此 MoveTo对象的字符串表示形式。

String

Path.toString​()

返回此 Path对象的字符串表示形式。

String

Polygon.toString​()

返回此 Polygon对象的字符串表示形式。

String

Polyline.toString​()

返回此 Polyline对象的字符串表示形式。

String

QuadCurve.toString​()

返回此 QuadCurve对象的字符串表示形式。

String

QuadCurveTo.toString​()

返回此 CubicCurveTo对象的字符串表示形式。

String

Rectangle.toString​()

返回此 Rectangle对象的字符串表示形式。

String

SVGPath.toString​()

返回此 SVGPath对象的字符串表示形式。

String

VertexFormat.toString​()

String

VLineTo.toString​()

返回此 VLineTo对象的字符串表示形式。

Uses of Override in javafx.scene.text

Methods in javafx.scene.text with annotations of type Override

Modifier and Type

方法

描述

protected double

TextFlow.computeMinHeight​(double width)

protected double

TextFlow.computePrefHeight​(double width)

protected double

TextFlow.computePrefWidth​(double height)

boolean

Font.equals​(Object obj)

指示一些其他对象是否等于此。

double

Text.getBaselineOffset​()

获取属性baselineOffset的值。

double

TextFlow.getBaselineOffset​()

Orientation

TextFlow.getContentBias​()

List<CssMetaData<? extends Styleable,?>>

Text.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问Node的CssMetaData而不需要反射。

List<CssMetaData<? extends Styleable,?>>

TextFlow.getCssMetaData​()

int

Font.hashCode​()

返回此 Font对象的哈希码。

protected void

TextFlow.layoutChildren​()

Object

Text.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

Object

TextFlow.queryAccessibleAttribute​(AccessibleAttribute attribute, Object... parameters)

该方法由辅助技术调用以请求属性的值。

void

TextFlow.requestLayout​()

protected void

TextFlow.setWidth​(double value)

String

Font.toString​()

将此 Font对象转换为 String表示形式。

String

HitInfo.toString​()

String

Text.toString​()

返回此 Text对象的字符串表示形式。

boolean

Text.usesMirroring​()

boolean

TextFlow.usesMirroring​()

Uses of Override in javafx.scene.transform

Methods in javafx.scene.transform with annotations of type Override

Modifier and Type

方法

描述

EventDispatchChain

Transform.buildEventDispatchChain​(EventDispatchChain tail)

Affine

Affine.clone​()

Rotate

Rotate.clone​()

Scale

Scale.clone​()

Shear

Shear.clone​()

Transform

Transform.clone​()

返回此转换的深层副本。

Translate

Translate.clone​()

Transform

Affine.createConcatenation​(Transform transform)

Transform

Rotate.createConcatenation​(Transform transform)

Transform

Scale.createConcatenation​(Transform transform)

Transform

Shear.createConcatenation​(Transform transform)

Transform

Translate.createConcatenation​(Transform transform)

Affine

Affine.createInverse​()

Transform

Rotate.createInverse​()

Scale

Scale.createInverse​()

Transform

Shear.createInverse​()

Translate

Translate.createInverse​()

Point2D

Affine.deltaTransform​(double x, double y)

Point3D

Affine.deltaTransform​(double x, double y, double z)

Point2D

Rotate.deltaTransform​(double x, double y)

Point3D

Rotate.deltaTransform​(double x, double y, double z)

Point2D

Scale.deltaTransform​(double x, double y)

Point3D

Scale.deltaTransform​(double x, double y, double z)

Point2D

Shear.deltaTransform​(double x, double y)

Point3D

Shear.deltaTransform​(double x, double y, double z)

Point2D

Translate.deltaTransform​(double x, double y)

Point3D

Translate.deltaTransform​(double x, double y, double z)

Point2D

Translate.deltaTransform​(Point2D point)

Point3D

Translate.deltaTransform​(Point3D point)

double

Affine.determinant​()

double

Affine.getMxx​()

获取属性mxx的值。

double

Rotate.getMxx​()

double

Scale.getMxx​()

double

Affine.getMxy​()

获取属性mxy的值。

double

Rotate.getMxy​()

double

Shear.getMxy​()

double

Affine.getMxz​()

获取属性mxz的值。

double

Rotate.getMxz​()

double

Affine.getMyx​()

获取属性myx的值。

double

Rotate.getMyx​()

double

Shear.getMyx​()

double

Affine.getMyy​()

获取属性myy的价值。

double

Rotate.getMyy​()

double

Scale.getMyy​()

double

Affine.getMyz​()

获取属性myz的值。

double

Rotate.getMyz​()

double

Affine.getMzx​()

获取属性mzx的值。

double

Rotate.getMzx​()

double

Affine.getMzy​()

获取属性mzy的值。

double

Rotate.getMzy​()

double

Affine.getMzz​()

获取属性mzz的值。

double

Rotate.getMzz​()

double

Scale.getMzz​()

double

Affine.getTx​()

获取属性tx的值。

double

Rotate.getTx​()

double

Scale.getTx​()

double

Shear.getTx​()

double

Translate.getTx​()

double

Affine.getTy​()

获取属性值的值。

double

Rotate.getTy​()

double

Scale.getTy​()

double

Shear.getTy​()

double

Translate.getTy​()

double

Affine.getTz​()

获取属性tz的值。

double

Rotate.getTz​()

double

Scale.getTz​()

double

Translate.getTz​()

Point2D

Affine.inverseDeltaTransform​(double x, double y)

Point3D

Affine.inverseDeltaTransform​(double x, double y, double z)

Point2D

Rotate.inverseDeltaTransform​(double x, double y)

Point3D

Rotate.inverseDeltaTransform​(double x, double y, double z)

Point2D

Scale.inverseDeltaTransform​(double x, double y)

Point3D

Scale.inverseDeltaTransform​(double x, double y, double z)

Point2D

Shear.inverseDeltaTransform​(double x, double y)

Point3D

Shear.inverseDeltaTransform​(double x, double y, double z)

Point2D

Translate.inverseDeltaTransform​(double x, double y)

Point3D

Translate.inverseDeltaTransform​(double x, double y, double z)

Point2D

Translate.inverseDeltaTransform​(Point2D point)

Point3D

Translate.inverseDeltaTransform​(Point3D point)

Point2D

Affine.inverseTransform​(double x, double y)

Point3D

Affine.inverseTransform​(double x, double y, double z)

Point2D

Rotate.inverseTransform​(double x, double y)

Point3D

Rotate.inverseTransform​(double x, double y, double z)

Point2D

Scale.inverseTransform​(double x, double y)

Point3D

Scale.inverseTransform​(double x, double y, double z)

Point2D

Shear.inverseTransform​(double x, double y)

Point3D

Shear.inverseTransform​(double x, double y, double z)

Point2D

Translate.inverseTransform​(double x, double y)

Point3D

Translate.inverseTransform​(double x, double y, double z)

String

Affine.toString​()

返回此 Affine对象的字符串表示形式。

String

Rotate.toString​()

返回此 Rotate对象的字符串表示形式。

String

Scale.toString​()

返回此 Scale对象的字符串表示形式。

String

Shear.toString​()

返回此 Shear对象的字符串表示形式。

String

Translate.toString​()

返回此 Translate对象的字符串表示形式。

Point2D

Affine.transform​(double x, double y)

Point3D

Affine.transform​(double x, double y, double z)

Point2D

Rotate.transform​(double x, double y)

Point3D

Rotate.transform​(double x, double y, double z)

Point2D

Scale.transform​(double x, double y)

Point3D

Scale.transform​(double x, double y, double z)

Point2D

Shear.transform​(double x, double y)

Point3D

Shear.transform​(double x, double y, double z)

Point2D

Translate.transform​(double x, double y)

Point3D

Translate.transform​(double x, double y, double z)

protected void

Rotate.transformChanged​()

Uses of Override in javafx.scene.web

Methods in javafx.scene.web with annotations of type Override

Modifier and Type

方法

描述

protected Skin<?>

HTMLEditor.createDefaultSkin​()

protected ObservableList<Node>

WebView.getChildren​()

List<CssMetaData<? extends Styleable,?>>

WebView.getCssMetaData​()

该方法应该委托给 Node.getClassCssMetaData()，以便可以访问节点的CssMetaData而不需要反射。

boolean

WebView.isResizable​()

protected void

HTMLEditorSkin.layoutChildren​(double x, double y, double w, double h)

在场景图的布局过程中调用。

double

WebView.maxHeight​(double width)

在布局期间调用以确定此节点的最大高度。

double

WebView.maxWidth​(double height)

在布局期间调用以确定此节点的最大宽度。

double

WebView.minHeight​(double width)

在布局期间调用以确定此节点的最小高度。

double

WebView.minWidth​(double height)

在布局期间调用以确定此节点的最小宽度。

double

WebView.prefHeight​(double width)

在布局期间调用以确定此节点的首选高度。

double

WebView.prefWidth​(double height)

在布局期间调用以确定此节点的首选宽度。

void

WebView.resize​(double width, double height)

String

WebErrorEvent.toString​()

返回此EventObject的String表示形式。

String

WebEvent.toString​()

返回此 WebEvent对象的字符串表示形式。

String

WebHistory.Entry.toString​()

Uses of Override in javafx.stage

Methods in javafx.stage with annotations of type Override

Modifier and Type

方法

描述

EventDispatchChain

Window.buildEventDispatchChain​(EventDispatchChain tail)

为此窗口构建事件调度链。

WindowEvent

WindowEvent.copyFor​(Object newSource, EventTarget newTarget)

boolean

Screen.equals​(Object obj)

指示一些其他对象是否等于此。

ObservableList<Node>

Popup.getContent​()

Node的ObservableList将在此 Popup上呈现。

EventType<WindowEvent>

WindowEvent.getEventType​()

int

Screen.hashCode​()

返回此 Screen对象的哈希码。

void

PopupWindow.hide​()

隐藏此弹出窗口及其所有子项

protected void

PopupWindow.setScene​(Scene scene)

注意子类：PopupWindow使用的场景是非常具体由PopupWindow管理的。

void

Stage.setScene​(Scene value)

指定此舞台上要使用的场景。

void

Stage.show​()

尝试通过将可见性设置为true来显示此窗口

String

Screen.toString​()

返回此 Screen对象的字符串表示形式。

String

WindowEvent.toString​()

返回此 WindowEvent对象的字符串表示形式。

Uses of Override in javafx.util

Methods in javafx.util with annotations of type Override

Modifier and Type

方法

描述

int

Duration.compareTo​(Duration d)

比较由此对象和指定对象表示的持续时间。

boolean

Duration.equals​(Object obj)

指示一些其他对象是否等于此。

boolean

Pair.equals​(Object o)

测试这个 Pair与另一个 Object 。

int

Duration.hashCode​()

返回此 Duration对象的哈希码。

int

Pair.hashCode​()

为此产生一个哈希码 Pair 。

String

Duration.toString​()

返回此 Duration对象的字符串表示形式。

String

Pair.toString​()

String这个 Pair代表。

Uses of Override in javafx.util.converter

Methods in javafx.util.converter with annotations of type Override

Modifier and Type

方法

描述

BigDecimal

BigDecimalStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

BigInteger

BigIntegerStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Boolean

BooleanStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Byte

ByteStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Character

CharacterStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Date

DateTimeStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

String

DefaultStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Double

DoubleStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Float

FloatStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

T

FormatStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Integer

IntegerStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

LocalDate

LocalDateStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

LocalDateTime

LocalDateTimeStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

LocalTime

LocalTimeStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Long

LongStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Number

NumberStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Short

ShortStringConverter.fromString​(String text)

将提供的字符串转换为由特定转换器定义的对象。

protected DateFormat

DateStringConverter.getDateFormat​()

返回一个DateFormat实例，用于格式化和解析StringConverter 。

protected DateFormat

TimeStringConverter.getDateFormat​()

返回一个DateFormat实例，用于格式化和解析StringConverter 。

protected NumberFormat

CurrencyStringConverter.getNumberFormat​()

返回一个NumberFormat实例，用于在此StringConverter中进行格式化和解析。

NumberFormat

PercentageStringConverter.getNumberFormat​()

返回一个NumberFormat实例，用于格式化和解析StringConverter 。

String

BigDecimalStringConverter.toString​(BigDecimal value)

将提供的对象转换为其字符串形式。

String

BigIntegerStringConverter.toString​(BigInteger value)

将提供的对象转换为其字符串形式。

String

BooleanStringConverter.toString​(Boolean value)

将提供的对象转换为其字符串形式。

String

ByteStringConverter.toString​(Byte value)

将提供的对象转换为其字符串形式。

String

CharacterStringConverter.toString​(Character value)

将提供的对象转换为其字符串形式。

String

DateTimeStringConverter.toString​(Date value)

将提供的对象转换为其字符串形式。

String

DefaultStringConverter.toString​(String value)

将提供的对象转换为其字符串形式。

String

DoubleStringConverter.toString​(Double value)

将提供的对象转换为其字符串形式。

String

FloatStringConverter.toString​(Float value)

将提供的对象转换为其字符串形式。

String

FormatStringConverter.toString​(T value)

将提供的对象转换为其字符串形式。

String

IntegerStringConverter.toString​(Integer value)

将提供的对象转换为其字符串形式。

String

LocalDateStringConverter.toString​(LocalDate value)

将提供的对象转换为其字符串形式。

String

LocalDateTimeStringConverter.toString​(LocalDateTime value)

将提供的对象转换为其字符串形式。

String

LocalTimeStringConverter.toString​(LocalTime value)

将提供的对象转换为其字符串形式。

String

LongStringConverter.toString​(Long value)

将提供的对象转换为其字符串形式。

String

NumberStringConverter.toString​(Number value)

将提供的对象转换为其字符串形式。

String

ShortStringConverter.toString​(Short value)

将提供的对象转换为其字符串形式。

Uses of Override in javax.imageio.plugins.tiff

Methods in javax.imageio.plugins.tiff with annotations of type Override

Modifier and Type

方法

描述

TIFFDirectory

TIFFDirectory.clone​()

克隆目录及其中包含的所有字段。

TIFFField

TIFFField.clone​()

克隆该字段及其中包含的所有信息。

Uses of Override in javax.lang.model.element

Methods in javax.lang.model.element with annotations of type Override

Modifier and Type

方法

描述

boolean

Element.equals​(Object obj)

返回 true如果参数表示相同的元件作为 this ，或 false否则。

<A extends Annotation>
A

Element.getAnnotation​(Class<A> annotationType)

返回指定类型的这种构造的注解，如果这样的注释 存在 ，否则 null 。

List<? extends AnnotationMirror>

Element.getAnnotationMirrors​()

返回 直接存在于此构造上的注释。

List<? extends Element>

ModuleElement.getEnclosedElements​()

返回此模块中的包。

List<? extends Element>

PackageElement.getEnclosedElements​()

返回此包中的 top-level类和接口。

List<? extends Element>

TypeElement.getEnclosedElements​()

返回在此类或接口中直接声明的字段，方法，构造函数和成员类型。

Element

ModuleElement.getEnclosingElement​()

返回 null因为模块未被其他元素包围。

Element

PackageElement.getEnclosingElement​()

如果存在这样的模块，则返回包围模块; 否则返回null 。

Element

TypeElement.getEnclosingElement​()

返回顶级类型的包，并返回 nested类型的立即包含的元素。

Element

TypeParameterElement.getEnclosingElement​()

返回此类型参数的 generic element 。

Element

VariableElement.getEnclosingElement​()

返回此变量的包围元素。

Name

ModuleElement.getQualifiedName​()

返回此模块的完全限定名称。

Name

ExecutableElement.getSimpleName​()

返回构造函数，方法或初始值设置的简单名称。

Name

ModuleElement.getSimpleName​()

返回此模块的简单名称。

Name

PackageElement.getSimpleName​()

返回此包的简单名称。

Name

TypeElement.getSimpleName​()

返回此类型元素的简单名称。

Name

VariableElement.getSimpleName​()

返回此变量元素的简单名称。

int

Element.hashCode​()

遵守 Object.hashCode的一般合同。

Uses of Override in javax.lang.model.util

Methods in javax.lang.model.util with annotations of type Override

Modifier and Type

方法

描述

R

ElementKindVisitor6.visitExecutable​(ExecutableElement e, P p)

访问的可执行元件，指派给该访问方法用于特定kind可执行的CONSTRUCTOR ， INSTANCE_INIT ， METHOD ，或STATIC_INIT 。

R

AbstractTypeVisitor6.visitIntersection​(IntersectionType t, P p)

访问交叉路口类型。

abstract R

AbstractTypeVisitor8.visitIntersection​(IntersectionType t, P p)

以一个子类定义的方式访问一个 IntersectionType 。

R

SimpleTypeVisitor8.visitIntersection​(IntersectionType t, P p)

此实现访问的 IntersectionType致电 defaultAction 。

R

TypeKindVisitor8.visitIntersection​(IntersectionType t, P p)

此实现访问的 IntersectionType致电 defaultAction 。

R

AbstractElementVisitor6.visitModule​(ModuleElement e, P p)

访问模块元素。

abstract R

AbstractElementVisitor9.visitModule​(ModuleElement t, P p)

以一个子类定义的方式访问一个 ModuleElement 。

R

ElementKindVisitor9.visitModule​(ModuleElement e, P p)

访问一个 ModuleElement致电 defaultAction 。

R

ElementScanner9.visitModule​(ModuleElement e, P p)

通过扫描附带的元素访问 ModuleElement 。

R

SimpleElementVisitor9.visitModule​(ModuleElement e, P p)

访问一个 ModuleElement致电 defaultAction 。

R

TypeKindVisitor6.visitNoType​(NoType t, P p)

访问一个NoType实例，指派给访问方法的具体kind伪类型： VOID ， PACKAGE ，或NONE 。

R

ElementKindVisitor6.visitPackage​(PackageElement e, P p)

访问包元素。

R

TypeKindVisitor6.visitPrimitive​(PrimitiveType t, P p)

访问基本类型，指派给该访问方法用于特定kind基本类型： BOOLEAN ， BYTE等

R

ElementKindVisitor6.visitType​(TypeElement e, P p)

访问类型元素，指派给该访问方法用于特定kind类型， ANNOTATION_TYPE ， CLASS ， ENUM ，或INTERFACE 。

R

ElementKindVisitor6.visitTypeParameter​(TypeParameterElement e, P p)

访问类型参数元素。

abstract R

AbstractTypeVisitor7.visitUnion​(UnionType t, P p)

以一个子类定义的方式访问一个 UnionType 。

R

SimpleTypeVisitor7.visitUnion​(UnionType t, P p)

此实现访问一个 UnionType致电 defaultAction 。

R

TypeKindVisitor7.visitUnion​(UnionType t, P p)

此实现访问一个 UnionType致电 defaultAction 。

R

AbstractAnnotationValueVisitor6.visitUnknown​(AnnotationValue av, P p)

访问未知类型的注释值。

R

AbstractElementVisitor6.visitUnknown​(Element e, P p)

访问一种未知的元素。

R

AbstractTypeVisitor6.visitUnknown​(TypeMirror t, P p)

访问未知类型的类型。

R

ElementKindVisitor6.visitVariable​(VariableElement e, P p)

访问一个变量元素，指派给访问方法用于特定kind变量，的ENUM_CONSTANT ， EXCEPTION_PARAMETER ， 字段 ， LOCAL_VARIABLE ， PARAMETER ，或RESOURCE_VARIABLE 。

R

ElementScanner7.visitVariable​(VariableElement e, P p)

此实现扫描包含的元素。

R

SimpleElementVisitor7.visitVariable​(VariableElement e, P p)

此实现调用 defaultAction 。

R

ElementKindVisitor7.visitVariableAsResourceVariable​(VariableElement e, P p)

通过调用 defaultAction访问一个 RESOURCE_VARIABLE变量元素。

Uses of Override in javax.management

Methods in javax.management with annotations of type Override

Modifier and Type

方法

描述

void

AttributeList.add​(int index, Object element)

在此列表中的指定位置插入指定的元素。

boolean

AttributeList.add​(Object element)

将指定的元素追加到此列表的末尾。

boolean

AttributeList.addAll​(int index, Collection<?> c)

将指定集合中的所有元素插入到此列表中，从指定的位置开始。

boolean

AttributeList.addAll​(Collection<?> c)

按指定集合的Iterator返回的顺序将指定集合中的所有元素追加到此列表的末尾。

ValueExp

AttributeValueExp.apply​(ObjectName name)

在一个MBean上应用 AttributeValueExp 。

ValueExp

StringValueExp.apply​(ObjectName name)

在MBean上应用ValueExp。

Descriptor

ImmutableDescriptor.clone​()

返回一个等于该描述符的描述符。

Object

MBeanInfo.clone​()

返回此实例的浅克隆。

Object

MBeanOperationInfo.clone​()

返回此实例的浅克隆。

boolean

ImmutableDescriptor.equals​(Object o)

将此描述符与给定对象进行比较。

boolean

MBeanInfo.equals​(Object o)

将此MBeanInfo与另一个进行比较。

boolean

MBeanOperationInfo.equals​(Object o)

将此MBeanOperationInfo与另一个进行比较。

boolean

ObjectName.equals​(Object object)

将当前对象名称与另一个对象名称进行比较。

int

ImmutableDescriptor.hashCode​()

返回此描述符的哈希码值。

int

MBeanInfo.hashCode​()

int

MBeanOperationInfo.hashCode​()

int

ObjectName.hashCode​()

返回此对象名称的哈希码。

Object

AttributeList.set​(int index, Object element)

用指定的元素替换此列表中指定位置的元素。

void

AttributeValueExp.setMBeanServer​(MBeanServer s)

已过时。
此方法无效。 用于获取属性值的MBean Server为QueryEval.getMBeanServer() 。

String

AttributeValueExp.toString​()

返回表示其值的字符串。

String

ImmutableDescriptor.toString​()

String

MBeanInfo.toString​()

String

MBeanOperationInfo.toString​()

String

MBeanServerNotification.toString​()

String

Notification.toString​()

返回此通知的String表示形式。

String

ObjectName.toString​()

返回对象名称的字符串表示形式。

Uses of Override in javax.management.modelmbean

Methods in javax.management.modelmbean with annotations of type Override

Modifier and Type

方法

描述

Object

DescriptorSupport.clone​()

返回与描述符重复的新描述符。

Object

ModelMBeanAttributeInfo.clone​()

创建并返回一个新的ModelMBeanAttributeInfo，它与此ModelMBeanAttributeInfo重复。

Object

ModelMBeanConstructorInfo.clone​()

创建并返回一个新的ModelMBeanConstructorInfo，它与此ModelBeanConstructorInfo重复。

boolean

DescriptorSupport.equals​(Object o)

将此描述符与给定对象进行比较。

Descriptor

ModelMBeanConstructorInfo.getDescriptor​()

返回相关描述符的副本。

Descriptor

ModelMBeanInfoSupport.getDescriptor​()

int

DescriptorSupport.hashCode​()

返回此描述符的哈希码值。

String

DescriptorSupport.toString​()

返回表示描述符的人类可读字符串。

String

ModelMBeanAttributeInfo.toString​()

返回一个可读的ModelMBeanAttributeInfo实例版本。

String

ModelMBeanConstructorInfo.toString​()

返回一个包含ModelMBeanConstructorInfo的全部内容的字符串，以人类可读的形式显示。

Uses of Override in javax.management.monitor

Methods in javax.management.monitor with annotations of type Override

Modifier and Type

方法

描述

Number

CounterMonitor.getDerivedGauge​(ObjectName object)

如果该对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。

Number

GaugeMonitor.getDerivedGauge​(ObjectName object)

如果此对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。

String

StringMonitor.getDerivedGauge​(ObjectName object)

如果该对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。

long

CounterMonitor.getDerivedGaugeTimeStamp​(ObjectName object)

如果此对象包含在观察到的MBean集合中，则获取指定对象的派生标尺时间戳，否则为 0 。

long

GaugeMonitor.getDerivedGaugeTimeStamp​(ObjectName object)

如果该对象包含在观察到的MBean集合中，则获取指定对象的派生量规时间戳，否则为 0 。

long

StringMonitor.getDerivedGaugeTimeStamp​(ObjectName object)

如果该对象包含在观察到的MBean集合中，则获取指定对象的派生量规时间戳，否则为 0 。

MBeanNotificationInfo[]

CounterMonitor.getNotificationInfo​()

返回一个 NotificationInfo对象，其中包含通知的Java类的名称以及计数器监视器发送的通知类型。

MBeanNotificationInfo[]

GaugeMonitor.getNotificationInfo​()

返回一个 NotificationInfo对象，其中包含通知的Java类的名称以及量规监视器发送的通知类型。

MBeanNotificationInfo[]

StringMonitor.getNotificationInfo​()

返回一个 NotificationInfo对象，其中包含通知的Java类的名称以及字符串监视器发送的通知类型。

Uses of Override in javax.management.openmbean

Methods in javax.management.openmbean with annotations of type Override

Modifier and Type

方法

描述

boolean

CompositeDataSupport.equals​(Object obj)

将指定的 obj参数与此 CompositeDataSupport实例进行比较以获得相等性。

int

CompositeDataSupport.hashCode​()

返回此 CompositeDataSupport实例的哈希码值。

String

CompositeDataSupport.toString​()

返回此 CompositeDataSupport实例的字符串表示形式。

Uses of Override in javax.management.relation

Methods in javax.management.relation with annotations of type Override

Modifier and Type

方法

描述

void

RoleList.add​(int index, Object element)

boolean

RoleList.add​(Object o)

void

RoleUnresolvedList.add​(int index, Object element)

boolean

RoleUnresolvedList.add​(Object o)

boolean

RoleList.addAll​(int index, Collection<?> c)

boolean

RoleList.addAll​(Collection<?> c)

boolean

RoleUnresolvedList.addAll​(int index, Collection<?> c)

boolean

RoleUnresolvedList.addAll​(Collection<?> c)

Object

RoleList.set​(int index, Object element)

Object

RoleUnresolvedList.set​(int index, Object element)

Uses of Override in javax.management.remote

Methods in javax.management.remote with annotations of type Override

Modifier and Type

方法

描述

MBeanNotificationInfo[]

JMXConnectorServer.getNotificationInfo​()

返回一个数组，指示此MBean发送的通知。

Uses of Override in javax.management.remote.rmi

Methods in javax.management.remote.rmi with annotations of type Override

Modifier and Type

方法

描述

protected void

RMIIIOPServerImpl.closeClient​(RMIConnection client)

已过时。

protected void

RMIIIOPServerImpl.closeServer​()

已过时。

protected void

RMIConnectorServer.connectionClosed​(String connectionId, String message, Object userData)

protected void

RMIConnectorServer.connectionFailed​(String connectionId, String message, Object userData)

protected void

RMIConnectorServer.connectionOpened​(String connectionId, String message, Object userData)

protected void

RMIIIOPServerImpl.export​()

已过时。

protected String

RMIIIOPServerImpl.getProtocol​()

已过时。

protected RMIConnection

RMIIIOPServerImpl.makeClient​(String connectionId, Subject subject)

已过时。

void

RMIConnectorServer.setMBeanServerForwarder​(MBeanServerForwarder mbsf)

String

RMIConnectionImpl.toString​()

返回此对象的字符串表示形式。

String

RMIConnector.toString​()

返回此对象的字符串表示形式。

Remote

RMIIIOPServerImpl.toStub​()

已过时。

Uses of Override in javax.net.ssl

Methods in javax.net.ssl with annotations of type Override

Modifier and Type

方法

描述

boolean

SNIHostName.equals​(Object other)

将此服务器名称与指定对象进行比较。

boolean

SNIServerName.equals​(Object other)

指示某个其他对象是否等于此服务器名称。

int

SNIHostName.hashCode​()

返回此 SNIHostName的哈希码值。

int

SNIServerName.hashCode​()

返回此服务器名称的哈希码值。

String

SNIHostName.toString​()

返回对象的字符串表示形式，包括此 SNIHostName对象中的DNS主机名。

String

SNIServerName.toString​()

返回此服务器名称的字符串表示形式，包括此 SNIServerName对象中的服务器名称类型和编码的服务器名称值。

String

SSLEngineResult.toString​()

返回此对象的String表示形式。

Uses of Override in javax.security.auth

Methods in javax.security.auth with annotations of type Override

Modifier and Type

方法

描述

boolean

Subject.equals​(Object o)

将指定的对象与此 Subject进行比较以获得相等性。

int

Subject.hashCode​()

返回此 Subject的哈希 Subject 。

String

Subject.toString​()

返回这个 Subject的String表示。

Uses of Override in javax.security.auth.kerberos

Methods in javax.security.auth.kerberos with annotations of type Override

Modifier and Type

方法

描述

void

EncryptionKey.destroy​()

清除此键的关键材料来销毁此键。

void

KerberosCredMessage.destroy​()

清除该消息来销毁此对象。

boolean

DelegationPermission.equals​(Object obj)

检查两个DelegatorPermission对象是否相等。

boolean

EncryptionKey.equals​(Object other)

将指定的对象与此键进行比较以获得相等性。

boolean

KerberosCredMessage.equals​(Object other)

将指定的对象与此 KerberosCredMessage进行比较以获得相等性。

boolean

ServicePermission.equals​(Object obj)

检查两个ServicePermission对象是否相等。

String

ServicePermission.getActions​()

返回动作的规范字符串表示形式。

String

EncryptionKey.getAlgorithm​()

返回此键的标准算法名称。

byte[]

EncryptionKey.getEncoded​()

返回此键的关键材料。

String

EncryptionKey.getFormat​()

返回此键的编码格式的名称。

int

DelegationPermission.hashCode​()

返回此对象的哈希码值。

int

EncryptionKey.hashCode​()

返回这个 EncryptionKey的哈希码。

int

KerberosCredMessage.hashCode​()

返回这个 KerberosCredMessage的哈希码。

int

ServicePermission.hashCode​()

返回此对象的哈希码值。

boolean

DelegationPermission.implies​(Permission p)

检查此Kerberos委托许可对象是否“暗示”指定的权限。

boolean

ServicePermission.implies​(Permission p)

检查此Kerberos服务权限对象是否“暗示”指定的权限。

boolean

EncryptionKey.isDestroyed​()

boolean

KerberosCredMessage.isDestroyed​()

PermissionCollection

DelegationPermission.newPermissionCollection​()

返回一个PermissionCollection对象，用于存储DelegationPermission对象。

PermissionCollection

ServicePermission.newPermissionCollection​()

返回一个用于存储ServicePermission对象的PermissionCollection对象。

String

EncryptionKey.toString​()

返回此 EncryptionKey的内容丰富的文字表示。

String

KerberosCredMessage.toString​()

返回此 KerberosCredMessage的内容丰富的文字表示。

Uses of Override in javax.sound.midi

Methods in javax.sound.midi with annotations of type Override

Modifier and Type

方法

描述

Object

MetaMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

abstract Object

MidiMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

Object

ShortMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

Object

SysexMessage.clone​()

创建与该对象相同的类和新内容相同的新对象。

void

MidiDevice.close​()

关闭设备，指示设备现在应该释放它正在使用的任何系统资源。

void

Receiver.close​()

表示应用程序已完成使用接收器，并且其所需的有限资源可能会被释放或提供。

void

Transmitter.close​()

表示应用程序已完成使用发射机，并且其所需的有限资源可能会被释放或提供。

boolean

MidiDevice.Info.equals​(Object obj)

报告两个对象是否相等。

boolean

Sequencer.SyncMode.equals​(Object obj)

确定两个对象是否相等。

long

Sequencer.getMicrosecondPosition​()

获取序列中的当前位置，以微秒表示。

int

MidiDevice.Info.hashCode​()

完成哈希码方法。

int

Sequencer.SyncMode.hashCode​()

完成哈希码方法。

void

SysexMessage.setMessage​(byte[] data, int length)

设置系统专用消息的数据。

String

MidiDevice.Info.toString​()

提供设备信息的字符串表示。

String

Sequencer.SyncMode.toString​()

提供此同步模式的名称作为模式的字符串表示形式。

Uses of Override in javax.sound.sampled

Methods in javax.sound.sampled with annotations of type Override

Modifier and Type

方法

描述

int

AudioInputStream.available​()

返回从该音频输入流中可以读取（或跳过）的最大字节数，而不会阻塞。

void

AudioInputStream.close​()

关闭此音频输入流并释放与流相关联的任何系统资源。

void

Line.close​()

关闭该行，表示可以释放该行所使用的任何系统资源。

boolean

AudioFileFormat.Type.equals​(Object obj)

完成equals方法。

boolean

AudioFormat.Encoding.equals​(Object obj)

完成equals方法。

boolean

Control.Type.equals​(Object obj)

完成equals方法。

boolean

LineEvent.Type.equals​(Object obj)

指示指定的对象是否等于此事件类型，如果对象相同，则返回 true 。

boolean

Mixer.Info.equals​(Object obj)

指示两个信息对象是否相等，如果它们相同，则返回 true 。

boolean

Port.Info.equals​(Object obj)

完成equals方法。

boolean

ReverbType.equals​(Object obj)

指示指定的对象是否等于此混响类型，如果对象相同，则返回 true 。

int

AudioFileFormat.Type.hashCode​()

完成hashCode方法。

int

AudioFormat.Encoding.hashCode​()

完成hashCode方法。

int

Control.Type.hashCode​()

完成hashCode方法。

int

LineEvent.Type.hashCode​()

完成哈希码方法。

int

Mixer.Info.hashCode​()

完成哈希码方法。

int

Port.Info.hashCode​()

完成hashCode方法。

int

ReverbType.hashCode​()

完成哈希码方法。

void

AudioInputStream.mark​(int readlimit)

标记此音频输入流中的当前位置。

boolean

AudioInputStream.markSupported​()

测试此音频输入流是否支持 mark和 reset方法。

boolean

DataLine.Info.matches​(Line.Info info)

确定指定的信息对象是否与此匹配。

boolean

Port.Info.matches​(Line.Info info)

指示此信息对象是否与此匹配。

int

AudioInputStream.read​()

从音频输入流读取数据的下一个字节。

int

AudioInputStream.read​(byte[] b)

从音频输入流读取一些字节数，并将它们存储到缓冲器阵列 b 。

int

AudioInputStream.read​(byte[] b, int off, int len)

从音频流读取指定的最大数据字节数，将它们放入给定的字节数组。

void

AudioInputStream.reset​()

将此音频输入流重新定位到上次调用其 mark方法时的位置。

long

AudioInputStream.skip​(long n)

跳过并丢弃该音频输入流中指定数量的字节。

String

AudioFileFormat.toString​()

提供文件格式的字符串表示形式。

String

AudioFileFormat.Type.toString​()

提供文件类型的名称作为文件类型的 String表示。

String

AudioFormat.Encoding.toString​()

提供编码的 String表示。

String

AudioFormat.toString​()

返回描述格式的字符串，如：“PCM SIGNED 22050 Hz 16 bit mono big-endian”。

String

BooleanControl.toString​()

提供控件的字符串表示形式。

String

CompoundControl.toString​()

提供控件的字符串表示形式。

String

Control.toString​()

获取描述控件类型及其当前状态的字符串。

String

Control.Type.toString​()

提供控件类型的 String表示。

String

DataLine.Info.toString​()

获取数据行信息的文本描述。

String

EnumControl.toString​()

提供控件的字符串表示形式。

String

FloatControl.toString​()

提供控件的字符串表示形式。

String

Line.Info.toString​()

获取行信息的文本描述。

String

LineEvent.toString​()

获取事件的字符串表示形式。

String

LineEvent.Type.toString​()

返回类型名称作为字符串表示形式。

String

Mixer.Info.toString​()

提供混音器信息的字符串表示。

String

Port.Info.toString​()

提供端口的 String表示。

String

ReverbType.toString​()

提供混响类型的 String表示，包括其名称及其参数设置。

Uses of Override in javax.sql

Methods in javax.sql with annotations of type Override

Modifier and Type

方法

描述

int

ConnectionPoolDataSource.getLoginTimeout​()

获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。

int

DataSource.getLoginTimeout​()

获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。

int

XADataSource.getLoginTimeout​()

获取此数据源在尝试连接到数据库时可以等待的最长时间（秒）。

PrintWriter

ConnectionPoolDataSource.getLogWriter​()

检索 DataSource对象的日志记录器。

PrintWriter

DataSource.getLogWriter​()

检索 DataSource对象的日志记录器。

PrintWriter

XADataSource.getLogWriter​()

检索 DataSource对象的日志记录器。

void

ConnectionPoolDataSource.setLoginTimeout​(int seconds)

设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。

void

DataSource.setLoginTimeout​(int seconds)

设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。

void

XADataSource.setLoginTimeout​(int seconds)

设置该数据源在尝试连接到数据库时将等待的最长时间（秒）。

void

ConnectionPoolDataSource.setLogWriter​(PrintWriter out)

将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。

void

DataSource.setLogWriter​(PrintWriter out)

将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。

void

XADataSource.setLogWriter​(PrintWriter out)

将此 DataSource对象的日志写入器设置为给定的 java.io.PrintWriter对象。

Uses of Override in javax.swing

Methods in javax.swing with annotations of type Override

Modifier and Type

方法

描述

boolean

JList.AccessibleJList.AccessibleJListChild.doAccessibleAction​(int i)

对对象执行指定的操作。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, byte oldValue, byte newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, char oldValue, char newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, double oldValue, double newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, float oldValue, float newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, int oldValue, int newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, long oldValue, long newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, short oldValue, short newValue)

由于性能原因而被覆盖。

protected void

DefaultListCellRenderer.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

由于性能原因而被覆盖。

AccessibleAction

JList.AccessibleJList.AccessibleJListChild.getAccessibleAction​()

获取与该对象关联的 AccessibleAction ，该对象支持一个或多个操作。

int

JList.AccessibleJList.AccessibleJListChild.getAccessibleActionCount​()

返回此对象中可用操作的数量如果有多个可访问的操作数，则第一个被视为对象的“默认”操作。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

void

JComponent.hide​()

已过时。

void

DefaultListCellRenderer.invalidate​()

由于性能原因而被覆盖。

boolean

DefaultListCellRenderer.isOpaque​()

由于性能原因而被覆盖。

boolean

JComponent.isValidateRoot​()

如果此方法返回true， revalidate此组件的后代的调用将导致从该根开始的整个树被验证。

boolean

JRootPane.isValidateRoot​()

如果这个 JRootPane的后代 JRootPane给 revalidate ，从这里下来验证。

boolean

JScrollPane.isValidateRoot​()

被 revalidate返回true，以便对这个 JScrollPane任何后代的任何调用 JScrollPane将导致从该 JScrollPane开始的整个树被验证。

boolean

JSplitPane.isValidateRoot​()

返回true，因此调用 revalidate这个的任何后代 JSplitPane将导致请求被排队将验证 JSplitPane及其所有后代。

boolean

JTextField.isValidateRoot​()

来自textfield本身的 revalidate调用将通过验证文本字段来处理，除非textfield包含在一个 JViewport ，在这种情况下返回false。

protected boolean

JComboBox.processKeyBinding​(KeyStroke ks, KeyEvent e, int condition, boolean pressed)

调用以处理键绑定为 ks作为的结果 KeyEvent e 。

void

JDesktopPane.remove​(Component comp)

从此容器中删除指定的组件。

void

DefaultListCellRenderer.repaint​()

由于性能原因而被覆盖。

void

DefaultListCellRenderer.repaint​(long tm, int x, int y, int width, int height)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.repaint​(Rectangle r)

由于性能原因而被覆盖。

void

JEditorPane.replaceSelection​(String content)

用给定字符串表示的新内容替换当前所选内容。

void

JTextPane.replaceSelection​(String content)

用给定字符串表示的新内容替换当前所选内容。

void

JToggleButton.requestFocus​(FocusEvent.Cause cause)

如果此切换按钮是ButtonGroup的成员，该另一个切换按钮被选中并且可以是焦点所有者，并且焦点原因参数表示任何方向的窗口激活或焦点遍历操作，则方法执行的结果与在组中选择的切换按钮上调用Component.requestFocus(FocusEvent.Cause) 。

void

DefaultListCellRenderer.revalidate​()

由于性能原因而被覆盖。

void

JSpinner.NumberEditor.setComponentOrientation​(ComponentOrientation o)

设置用于对该组件中的元素或文本进行排序的语言敏感方向。

void

DefaultListCellRenderer.validate​()

由于性能原因而被覆盖。

Uses of Override in javax.swing.border

Methods in javax.swing.border with annotations of type Override

Modifier and Type

方法

描述

Insets

StrokeBorder.getBorderInsets​(Component c, Insets insets)

使用此边框的当前插图重新初始化 insets参数。

boolean

CompoundBorder.isBorderOpaque​()

返回复合边框是否不透明。

void

StrokeBorder.paintBorder​(Component c, Graphics g, int x, int y, int width, int height)

用指定的位置和大小绘制指定组件的边框。

Uses of Override in javax.swing.event

Methods in javax.swing.event with annotations of type Override

Modifier and Type

方法

描述

RowSorter<?>

RowSorterEvent.getSource​()

将事件的来源作为 RowSorter 。

Uses of Override in javax.swing.plaf.basic

Methods in javax.swing.plaf.basic with annotations of type Override

Modifier and Type

方法

描述

Accessible

BasicComboBoxUI.getAccessibleChild​(JComponent c, int i)

int

BasicComboBoxUI.getAccessibleChildrenCount​(JComponent c)

int

BasicComboBoxUI.getBaseline​(JComponent c, int width, int height)

返回基线。

Component.BaselineResizeBehavior

BasicComboBoxUI.getBaselineResizeBehavior​(JComponent c)

返回一个枚举，指示组件的基线如何随着大小的变化而改变。

Component

BasicComboBoxRenderer.getListCellRendererComponent​(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)

Dimension

BasicComboBoxUI.getMaximumSize​(JComponent c)

Dimension

BasicDesktopPaneUI.getMaximumSize​(JComponent c)

Dimension

BasicComboBoxUI.getMinimumSize​(JComponent c)

最小尺寸是显示区域的大小加上插页加上按钮。

Dimension

BasicDesktopPaneUI.getMinimumSize​(JComponent c)

Dimension

BasicComboBoxUI.getPreferredSize​(JComponent c)

Dimension

BasicDesktopPaneUI.getPreferredSize​(JComponent c)

Dimension

BasicRadioButtonUI.getPreferredSize​(JComponent c)

单选按钮的首选大小

protected String

BasicRadioButtonUI.getPropertyPrefix​()

protected void

BasicRadioButtonUI.installDefaults​(AbstractButton b)

protected void

BasicRadioButtonUI.installListeners​(AbstractButton button)

void

BasicComboBoxUI.installUI​(JComponent c)

void

BasicComboBoxUI.KeyHandler.keyPressed​(KeyEvent e)

Rectangle

BasicTextUI.modelToView​(JTextComponent tc, int pos)

已过时。
代之以BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)

Rectangle

BasicTextUI.modelToView​(JTextComponent tc, int pos, Position.Bias bias)

已过时。
替换为BasicTextUI.modelToView2D(JTextComponent, int, Position.Bias)

Rectangle2D

BasicTextUI.modelToView2D​(JTextComponent tc, int pos, Position.Bias bias)

void

BasicComboBoxUI.paint​(Graphics g, JComponent c)

void

BasicRadioButtonUI.paint​(Graphics g, JComponent c)

画单选按钮

protected void

BasicRadioButtonUI.uninstallDefaults​(AbstractButton b)

protected void

BasicRadioButtonUI.uninstallListeners​(AbstractButton button)

void

BasicComboBoxUI.uninstallUI​(JComponent c)

int

BasicTextUI.viewToModel​(JTextComponent tc, Point pt)

已过时。
替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])

int

BasicTextUI.viewToModel​(JTextComponent tc, Point pt, Position.Bias[] biasReturn)

已过时。
替换为BasicTextUI.viewToModel2D(JTextComponent, Point2D, Position.Bias[])

int

BasicTextUI.viewToModel2D​(JTextComponent tc, Point2D pt, Position.Bias[] biasReturn)

Uses of Override in javax.swing.plaf.metal

Methods in javax.swing.plaf.metal with annotations of type Override

Modifier and Type

方法

描述

Dimension

MetalFileChooserUI.getMaximumSize​(JComponent c)

返回 JFileChooser的最大大小。

Dimension

MetalFileChooserUI.getMinimumSize​(JComponent c)

返回 JFileChooser的最小大小。

Dimension

MetalFileChooserUI.getPreferredSize​(JComponent c)

返回指定的首选大小 JFileChooser 。

Uses of Override in javax.swing.plaf.multi

Methods in javax.swing.plaf.multi with annotations of type Override

Modifier and Type

方法

描述

Rectangle

MultiTextUI.modelToView​(JTextComponent a, int b, Position.Bias c)

已过时。
代之以MultiTextUI.modelToView2D(JTextComponent, int, Position.Bias)

Rectangle2D

MultiTextUI.modelToView2D​(JTextComponent a, int b, Position.Bias c)

int

MultiTextUI.viewToModel​(JTextComponent a, Point b)

已过时。

int

MultiTextUI.viewToModel​(JTextComponent a, Point b, Position.Bias[] c)

已过时。

int

MultiTextUI.viewToModel2D​(JTextComponent a, Point2D b, Position.Bias[] c)

Uses of Override in javax.swing.plaf.nimbus

Methods in javax.swing.plaf.nimbus with annotations of type Override

Modifier and Type

方法

描述

Object

NimbusStyle.get​(SynthContext ctx, Object key)

Getter为区域特定样式属性。

protected Color

NimbusStyle.getColorForState​(SynthContext ctx, ColorType type)

返回指定状态的颜色。

UIDefaults

NimbusLookAndFeel.getDefaults​()

返回此SynthLookAndFeel的默认值。

String

NimbusLookAndFeel.getDescription​()

返回此外观的文字说明。

Icon

NimbusLookAndFeel.getDisabledIcon​(JComponent component, Icon icon)

protected Font

NimbusStyle.getFontForState​(SynthContext ctx)

返回指定状态的字体。

String

NimbusLookAndFeel.getID​()

返回一个识别这种外观和感觉的字符串。

Insets

NimbusStyle.getInsets​(SynthContext ctx, Insets in)

返回用于计算大小信息的Insets。

String

NimbusLookAndFeel.getName​()

返回一个标识这种外观和感觉的短字符串。

SynthPainter

NimbusStyle.getPainter​(SynthContext ctx)

返回将用于绘画的 SynthPainter 。

void

NimbusLookAndFeel.initialize​()

当这个外观和感觉被安装时，由UIManager打来的。

void

NimbusStyle.installDefaults​(SynthContext ctx)

从 JComponent从 context安装此样式所需的状态。

boolean

NimbusStyle.isOpaque​(SynthContext ctx)

如果区域不透明，则返回true。

void

AbstractRegionPainter.paint​(Graphics2D g, JComponent c, int w, int h)

给予给定的Graphics2D对象。

boolean

NimbusLookAndFeel.shouldUpdateStyleOnAncestorChanged​()

返回当 SynthStyleFactory的祖先发生变化时，UI是否应从 SynthStyles更新 JComponent 。

protected boolean

NimbusLookAndFeel.shouldUpdateStyleOnEvent​(PropertyChangeEvent ev)

返回在特定事件发生时，UI是否应更新其样式。

String

State.toString​()

void

NimbusLookAndFeel.uninitialize​()

当这个外观和感觉被卸载时，由UIManager打电话。

Uses of Override in javax.swing.plaf.synth

Methods in javax.swing.plaf.synth with annotations of type Override

Modifier and Type

方法

描述

protected void

SynthSliderUI.calculateGeometry​()

计算几何。

protected int

SynthTabbedPaneUI.calculateMaxTabHeight​(int tabPlacement)

计算最大标签高度。

protected int

SynthTabbedPaneUI.calculateMaxTabWidth​(int tabPlacement)

计算最大标签宽度。

protected int

SynthTabbedPaneUI.calculateTabWidth​(int tabPlacement, int tabIndex, FontMetrics metrics)

计算标签宽度。

protected void

SynthSliderUI.calculateThumbLocation​()

计算拇指位置。

protected void

SynthScrollBarUI.configureScrollBarColors​()

配置滚动条颜色。

View

SynthPasswordFieldUI.create​(Element elem)

为元素创建一个视图（PasswordView）。

protected JButton

SynthComboBoxUI.createArrowButton​()

创建一个按钮，该按钮将用作控件来显示或隐藏组合框的弹出窗口部分。

protected ComponentListener

SynthInternalFrameUI.createComponentListener​()

创建组件侦听器。

protected JButton

SynthScrollBarUI.createDecreaseButton​(int orientation)

创建减少按钮。

protected TreeCellEditor

SynthTreeUI.createDefaultCellEditor​()

创建默认单元格编辑器。

protected TreeCellRenderer

SynthTreeUI.createDefaultCellRenderer​()

返回用于执行每个节点冲压的默认单元格渲染器。

protected AbstractColorChooserPanel[]

SynthColorChooserUI.createDefaultChoosers​()

返回一组默认颜色选择器。

BasicSplitPaneDivider

SynthSplitPaneUI.createDefaultDivider​()

创建默认分隔符。

protected Component

SynthSplitPaneUI.createDefaultNonContinuousLayoutDivider​()

返回默认的非连续布局分隔符，这是一个 Canvas的实例，用灰色填充背景。

protected ComboBoxEditor

SynthComboBoxUI.createEditor​()

创建将在可编辑组合框中使用的默认编辑器。

protected JComponent

SynthSpinnerUI.createEditor​()

该方法由installUI调用，以获取 JSpinner的编辑器组件。

protected JButton

SynthScrollBarUI.createIncreaseButton​(int orientation)

创建一个增加按钮。

protected LayoutManager

SynthSpinnerUI.createLayout​()

创建一个 LayoutManager管理的 editor ， nextButton ，并 previousButton的JSpinner的儿童。

protected LayoutManager

SynthTabbedPaneUI.createLayoutManager​()

调用 installUI创建一个布局管理器对象来管理 JTabbedPane 。

protected Container

SynthOptionPaneUI.createMessageArea​()

从 SynthOptionPaneUI.installComponents()调用，创建一个包含消息正文的 Container 。

protected MouseListener

SynthTabbedPaneUI.createMouseListener​()

创建一个鼠标监听器。

protected Component

SynthSpinnerUI.createNextButton​()

创建一个增量按钮，即用 spinner.getNextValue返回的对象替换微调 spinner.getNextValue值的 spinner.getNextValue 。

protected JComponent

SynthInternalFrameUI.createNorthPane​(JInternalFrame w)

创建北面的窗格。

protected ComboPopup

SynthComboBoxUI.createPopup​()

创建组合框的弹出窗口部分。

protected Component

SynthSpinnerUI.createPreviousButton​()

创建一个减量按钮，即用 spinner.getPreviousValue返回的对象替换微调值的 spinner.getPreviousValue 。

protected ListCellRenderer<Object>

SynthComboBoxUI.createRenderer​()

创建将在不可编辑的组合框中使用的默认渲染器。

protected JButton

SynthTabbedPaneUI.createScrollButton​(int direction)

创建并返回一个JButton，它将向用户提供一种在特定方向滚动选项卡的方法。

protected Container

SynthOptionPaneUI.createSeparator​()

返回一个分隔符。

protected BasicSliderUI.TrackListener

SynthSliderUI.createTrackListener​(JSlider s)

创建一个轨道监听器。

protected void

SynthTreeUI.drawCentered​(Component c, Graphics graphics, Icon icon, int x, int y)

绘制以（x，y）为中心的 icon 。

void

SynthSplitPaneUI.finishedPaintingChildren​(JSplitPane jc, Graphics g)

当指定的拆分窗格绘制其子项时调用。

int

SynthButtonUI.getBaseline​(JComponent c, int width, int height)

返回基线。

int

SynthLabelUI.getBaseline​(JComponent c, int width, int height)

返回基线。

int

SynthProgressBarUI.getBaseline​(JComponent c, int width, int height)

返回基线。

int

SynthSliderUI.getBaseline​(JComponent c, int width, int height)

返回基线。

protected int

SynthTabbedPaneUI.getBaseline​(int tab)

返回指定选项卡的基线。

protected Rectangle

SynthProgressBarUI.getBox​(Rectangle r)

存储将在 r为当前动画索引绘制的弹跳框的位置和大小，并返回 r 。

SynthContext

SynthButtonUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthColorChooserUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthComboBoxUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthDesktopIconUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthDesktopPaneUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthEditorPaneUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthInternalFrameUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthLabelUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthListUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthMenuBarUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthMenuItemUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthMenuUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthOptionPaneUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthPanelUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthPopupMenuUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthProgressBarUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthRootPaneUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthScrollBarUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthScrollPaneUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthSeparatorUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthSliderUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthSpinnerUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthSplitPaneUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthTabbedPaneUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthTableHeaderUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthTableUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthTextAreaUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthTextFieldUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthToolBarUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthToolTipUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthTreeUI.getContext​(JComponent c)

返回指定组件的上下文。

SynthContext

SynthViewportUI.getContext​(JComponent c)

返回指定组件的上下文。

UIDefaults

SynthLookAndFeel.getDefaults​()

返回此SynthLookAndFeel的默认值。

protected Dimension

SynthComboBoxUI.getDefaultSize​()

使用当前渲染器和字体返回组合框的空显示区域的默认大小。

String

SynthLookAndFeel.getDescription​()

返回SynthLookAndFeel的文本描述。

Icon

SynthTreeUI.getExpandedIcon​()

返回展开的图标。

protected FontMetrics

SynthTabbedPaneUI.getFontMetrics​()

返回字体指标。

default int

SynthIcon.getIconHeight​()

default int

SynthIcon.getIconWidth​()

String

SynthLookAndFeel.getID​()

返回一个识别这种外观和感觉的字符串。

Dimension

SynthButtonUI.getMaximumSize​(JComponent c)

返回指定组件的最大尺寸，适合外观和感觉。

Dimension

SynthLabelUI.getMaximumSize​(JComponent c)

返回指定组件的最大尺寸，适合外观和感觉。

Dimension

SynthSeparatorUI.getMaximumSize​(JComponent c)

返回指定组件的最大尺寸，适合外观和感觉。

Dimension

SynthButtonUI.getMinimumSize​(JComponent c)

返回指定组件的最小尺寸，适合外观和感觉。

Dimension

SynthLabelUI.getMinimumSize​(JComponent c)

返回指定组件的最小尺寸，适合外观和感觉。

Dimension

SynthSeparatorUI.getMinimumSize​(JComponent c)

返回指定组件的最小尺寸，适合外观和感觉。

Dimension

SynthSliderUI.getMinimumSize​(JComponent c)

返回最小大小。

protected Dimension

SynthScrollBarUI.getMinimumThumbSize​()

返回拇指的最小可接受尺寸。

String

SynthLookAndFeel.getName​()

返回一个标识这种外观和感觉的短字符串。

protected Dimension

SynthMenuItemUI.getPreferredMenuItemSize​(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)

返回菜单项的首选大小。

protected Dimension

SynthMenuUI.getPreferredMenuItemSize​(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)

返回菜单项的首选大小。

Dimension

SynthButtonUI.getPreferredSize​(JComponent c)

返回指定组件的偏好大小，适合外观和感觉。

Dimension

SynthLabelUI.getPreferredSize​(JComponent c)

返回指定组件的偏好大小，适合外观和感觉。

Dimension

SynthProgressBarUI.getPreferredSize​(JComponent c)

返回指定组件的偏好大小，适合外观和感觉。

Dimension

SynthScrollBarUI.getPreferredSize​(JComponent c)

垂直滚动条的首选宽度是（非 null ）增量/减量按钮的最大宽度以及拇指的最小宽度的最大值。

Dimension

SynthSeparatorUI.getPreferredSize​(JComponent c)

返回指定组件的偏好大小，适合外观和感觉。

Dimension

SynthSliderUI.getPreferredSize​(JComponent c)

返回首选大小。

Dimension

SynthToolTipUI.getPreferredSize​(JComponent c)

返回指定组件的偏好大小，适合外观和感觉。

protected String

SynthCheckBoxMenuItemUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthCheckBoxUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthFormattedTextFieldUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

SynthPasswordFieldUI.getPropertyPrefix​()

获取用作密钥的名称，通过UIManager查找属性。

protected String

SynthRadioButtonMenuItemUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthRadioButtonUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthTextPaneUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

SynthToggleButtonUI.getPropertyPrefix​()

返回属性前缀。

protected int

SynthTreeUI.getRowX​(int row, int depth)

返回沿x轴的位置，以呈现特定的行。

protected boolean

SynthOptionPaneUI.getSizeButtonsToSameWidth​()

返回 true ，基本的L＆F想要所有的按钮具有相同的宽度。

protected Icon

SynthRadioButtonUI.getSizingIcon​(AbstractButton b)

返回用于计算首选/最小/最大大小的图标。

boolean

SynthScrollBarUI.getSupportsAbsolutePositioning​()

指示用户是否可以用鼠标手势（通常是鼠标中键）绝对定位拇指。

protected Insets

SynthTabbedPaneUI.getTabInsets​(int tabPlacement, int tabIndex)

返回标签插入。

protected int

SynthTabbedPaneUI.getTabLabelShiftX​(int tabPlacement, int tabIndex, boolean isSelected)

返回标签移位x。

protected int

SynthTabbedPaneUI.getTabLabelShiftY​(int tabPlacement, int tabIndex, boolean isSelected)

返回标签标签shift y。

protected Dimension

SynthSliderUI.getThumbSize​()

返回拇指大小。

void

SynthLookAndFeel.initialize​()

当这个外观和感觉被安装时，由UIManager打来的。

protected void

SynthDesktopIconUI.installComponents​()

注册组件。

protected void

SynthOptionPaneUI.installComponents​()

注册组件。

protected void

SynthToolBarUI.installComponents​()

注册组件。

protected void

SynthButtonUI.installDefaults​(AbstractButton b)

安装默认属性。

protected void

SynthColorChooserUI.installDefaults​()

安装默认属性。

protected void

SynthComboBoxUI.installDefaults​()

protected void

SynthDesktopIconUI.installDefaults​()

安装默认属性。

protected void

SynthDesktopPaneUI.installDefaults​()

安装默认属性。

protected void

SynthEditorPaneUI.installDefaults​()

初始化组件属性，如字体，前景，背景，插入符号颜色，选择颜色，选定的文本颜色，禁用的文本颜色和边框颜色。

void

SynthInternalFrameUI.installDefaults​()

安装默认值。

protected void

SynthLabelUI.installDefaults​(JLabel c)

安装默认属性。

protected void

SynthListUI.installDefaults​()

初始化字体，前景和背景等列表属性，并添加CellRendererPane。

protected void

SynthMenuBarUI.installDefaults​()

安装默认属性。

protected void

SynthMenuItemUI.installDefaults​()

安装默认属性。

protected void

SynthMenuUI.installDefaults​()

安装默认属性。

protected void

SynthOptionPaneUI.installDefaults​()

安装默认属性。

protected void

SynthPanelUI.installDefaults​(JPanel p)

安装面板属性的方法。

void

SynthPopupMenuUI.installDefaults​()

安装默认属性。

protected void

SynthProgressBarUI.installDefaults​()

安装默认属性。

protected void

SynthRootPaneUI.installDefaults​(JRootPane c)

安装默认属性。

protected void

SynthScrollBarUI.installDefaults​()

安装默认值。

protected void

SynthScrollPaneUI.installDefaults​(JScrollPane scrollpane)

安装默认属性。

protected void

SynthSliderUI.installDefaults​(JSlider slider)

安装默认值。

protected void

SynthSpinnerUI.installDefaults​()

初始化 JSpinner border ， foreground和 background基于从默认值表中对应的“微调。*”的属性，属性。

protected void

SynthSplitPaneUI.installDefaults​()

安装UI默认值。

protected void

SynthTabbedPaneUI.installDefaults​()

安装默认值。

protected void

SynthTableHeaderUI.installDefaults​()

初始化JTableHeader属性，如字体，前景和背景。

protected void

SynthTableUI.installDefaults​()

初始化JTable属性，如字体，前景和背景。

protected void

SynthTextAreaUI.installDefaults​()

初始化组件属性，如字体，前景，背景，插入符号颜色，选择颜色，选定的文本颜色，禁用的文本颜色和边框颜色。

protected void

SynthTextFieldUI.installDefaults​()

初始化组件属性，如字体，前景，背景，插入符号颜色，选择颜色，选定的文本颜色，禁用的文本颜色和边框颜色。

protected void

SynthToolBarUI.installDefaults​()

安装默认属性。

protected void

SynthToolTipUI.installDefaults​(JComponent c)

安装默认属性。

protected void

SynthTreeUI.installDefaults​()

安装默认属性。

protected void

SynthDesktopPaneUI.installDesktopManager​()

安装桌面管理器。

protected void

SynthPasswordFieldUI.installKeyboardActions​()

注册键盘操作。

protected void

SynthButtonUI.installListeners​(AbstractButton b)

注册听众。

protected void

SynthColorChooserUI.installListeners​()

注册听众。

protected void

SynthComboBoxUI.installListeners​()

为组合框及其模型创建并安装侦听器。

protected void

SynthDesktopIconUI.installListeners​()

注册听众。

protected void

SynthDesktopPaneUI.installListeners​()

安装 PropertyChangeListener返回的 createPropertyChangeListener在 JDesktopPane 。

protected void

SynthInternalFrameUI.installListeners​()

安装侦听器

protected void

SynthListUI.installListeners​()

创建并安装JList，其模型及其selectionModel的侦听器。

protected void

SynthMenuBarUI.installListeners​()

注册听众。

protected void

SynthMenuItemUI.installListeners​()

注册听众。

protected void

SynthMenuUI.installListeners​()

注册听众。

protected void

SynthOptionPaneUI.installListeners​()

注册听众。

protected void

SynthPopupMenuUI.installListeners​()

注册听众。

protected void

SynthProgressBarUI.installListeners​()

注册听众。

protected void

SynthScrollBarUI.installListeners​()

安装侦听器

protected void

SynthScrollPaneUI.installListeners​(JScrollPane c)

注册听众。

protected void

SynthSliderUI.installListeners​(JSlider slider)

安装侦听器

protected void

SynthSpinnerUI.installListeners​()

使用共享对象初始化 PropertyChangeListener ，该对象将感兴趣的PropertyChangeEvents委托给受保护的方法。

protected void

SynthSplitPaneUI.installListeners​()

安装UI的事件监听器。

protected void

SynthTabbedPaneUI.installListeners​()

安装侦听器

protected void

SynthTableHeaderUI.installListeners​()

将侦听器附加到JTableHeader。

protected void

SynthTableUI.installListeners​()

将侦听器附加到JTable。

protected void

SynthToolBarUI.installListeners​()

注册听众。

protected void

SynthToolTipUI.installListeners​(JComponent c)

注册听众。

protected void

SynthTreeUI.installListeners​()

注册听众。

void

SynthComboBoxUI.installUI​(JComponent c)

适当地配置指定的组件的外观和感觉。

void

SynthPanelUI.installUI​(JComponent c)

适当地配置指定的组件的外观和感觉。

void

SynthSeparatorUI.installUI​(JComponent c)

适当地配置指定的组件的外观和感觉。

void

SynthTextPaneUI.installUI​(JComponent c)

安装组件的UI。

void

SynthViewportUI.installUI​(JComponent c)

适当地配置指定的组件的外观和感觉。

boolean

SynthLookAndFeel.isNativeLookAndFeel​()

返回false，SynthLookAndFeel不是原生的外观。

boolean

SynthLookAndFeel.isSupportedLookAndFeel​()

返回true，始终支持SynthLookAndFeel。

void

SynthButtonUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthColorChooserUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthComboBoxUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthDesktopIconUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthDesktopPaneUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthInternalFrameUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthLabelUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthMenuBarUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthMenuItemUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthMenuUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthOptionPaneUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthPanelUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthPopupMenuUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthProgressBarUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthRootPaneUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthScrollBarUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthScrollPaneUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthSeparatorUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthSliderUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthSpinnerUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthSplitPaneUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthTabbedPaneUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthTableHeaderUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthTableUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthToolBarUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthToolTipUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthTreeUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

void

SynthViewportUI.paint​(Graphics g, JComponent c)

根据外观和外观绘制指定的组件。

protected void

SynthEditorPaneUI.paintBackground​(Graphics g)

绘制视图的背景。

protected void

SynthTextAreaUI.paintBackground​(Graphics g)

绘制视图的背景。

protected void

SynthTextFieldUI.paintBackground​(Graphics g)

绘制视图的背景。

void

SynthButtonUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthCheckBoxMenuItemUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthCheckBoxUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthColorChooserUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthComboBoxUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthDesktopIconUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthDesktopPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthEditorPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthFormattedTextFieldUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthInternalFrameUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthLabelUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthListUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthMenuBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthMenuItemUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthMenuUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthOptionPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthPanelUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthPasswordFieldUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthPopupMenuUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthProgressBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthRadioButtonMenuItemUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthRadioButtonUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthRootPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthScrollBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthScrollPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthSeparatorUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthSliderUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthSpinnerUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthSplitPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthTabbedPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthTableHeaderUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthTableUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthTextAreaUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthTextFieldUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthTextPaneUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthToggleButtonUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthToolBarUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthToolTipUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthTreeUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthViewportUI.paintBorder​(SynthContext context, Graphics g, int x, int y, int w, int h)

画边框

void

SynthComboBoxUI.paintCurrentValue​(Graphics g, Rectangle bounds, boolean hasFocus)

绘制当前选定的项目。

protected void

SynthToolBarUI.paintDragWindow​(Graphics g)

绘制用于拖动的窗口的内容。

protected void

SynthTreeUI.paintDropLine​(Graphics g)

画下线。

protected void

SynthTreeUI.paintExpandControl​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)

绘制一行的展开（切换）部分。

protected void

SynthTreeUI.paintHorizontalLine​(Graphics g, JComponent c, int y, int left, int right)

画一条水平线。

protected void

SynthTreeUI.paintHorizontalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)

涂抹腿部的水平部分。

default void

SynthIcon.paintIcon​(Component c, Graphics g, int x, int y)

protected void

SynthTreeUI.paintVerticalLine​(Graphics g, JComponent c, int x, int top, int bottom)

画一条垂直线。

protected void

SynthTreeUI.paintVerticalPartOfLeg​(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

涂上腿部的垂直部分。

void

SynthButtonUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthColorChooserUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthComboBoxUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthDesktopPaneUI.propertyChange​(PropertyChangeEvent evt)

当绑定属性更改时，此方法将被调用。

protected void

SynthEditorPaneUI.propertyChange​(PropertyChangeEvent evt)

当在关联的JTextComponent上更改bound属性时，将调用此方法。

void

SynthInternalFrameUI.propertyChange​(PropertyChangeEvent evt)

当绑定属性更改时，此方法将被调用。

void

SynthLabelUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthListUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthMenuBarUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthMenuItemUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthMenuUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthOptionPaneUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthPanelUI.propertyChange​(PropertyChangeEvent pce)

当绑定属性更改时，此方法将被调用。

void

SynthPopupMenuUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthProgressBarUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthRootPaneUI.propertyChange​(PropertyChangeEvent e)

在根窗格上更改属性时调用。

void

SynthSliderUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthSpinnerUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthSplitPaneUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthTabbedPaneUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthTableHeaderUI.propertyChange​(PropertyChangeEvent evt)

当绑定属性更改时，此方法将被调用。

void

SynthTableUI.propertyChange​(PropertyChangeEvent event)

当绑定属性更改时，此方法将被调用。

protected void

SynthTextAreaUI.propertyChange​(PropertyChangeEvent evt)

当在关联的JTextComponent上更改bound属性时，将调用此方法。

protected void

SynthTextFieldUI.propertyChange​(PropertyChangeEvent evt)

当在关联的JTextComponent上更改bound属性时，将调用此方法。

protected void

SynthTextPaneUI.propertyChange​(PropertyChangeEvent evt)

当在关联的JTextComponent上更改bound属性时，将调用此方法。

void

SynthToolBarUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthToolTipUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

void

SynthTreeUI.propertyChange​(PropertyChangeEvent event)

当绑定属性更改时，此方法将被调用。

void

SynthViewportUI.propertyChange​(PropertyChangeEvent e)

当绑定属性更改时，此方法将被调用。

protected void

SynthSliderUI.recalculateIfInsetsChanged​()

如果插图已更改，请重新计算。

protected void

SynthSpinnerUI.replaceEditor​(JComponent oldEditor, JComponent newEditor)

由 PropertyChangeListener调用时，编辑器的属性变化 JSpinner 。

protected void

SynthTableHeaderUI.rolloverColumnUpdated​(int oldColumn, int newColumn)

每当更新表头中的翻转列时，将调用此方法。

protected void

SynthProgressBarUI.setAnimationIndex​(int newValue)

将当前动画帧的索引设置为指定的值，并请求重绘进度条。

protected void

SynthToolBarUI.setBorderToNonRollover​(Component c)

这个实现什么都不做，因为 JToolBar类的 rollover属性没有用在Synth Look and Feel中。

protected void

SynthToolBarUI.setBorderToNormal​(Component c)

这个实现什么都不做，因为 JToolBar类的 rollover属性在Synth Look和Feel中没有使用。

protected void

SynthToolBarUI.setBorderToRollover​(Component c)

这个实现什么都不做，因为 JToolBar类的 rollover属性没有在Synth Look和Feel中使用。

protected void

SynthTabbedPaneUI.setRolloverTab​(int index)

将鼠标目前的标签设置为 index 。

void

SynthSliderUI.setThumbLocation​(int x, int y)

设置拇指位置。

protected void

SynthScrollBarUI.setThumbRollover​(boolean active)

设置鼠标是否当前在拇指上。

String

Region.toString​()

返回Region的名称。

void

SynthLookAndFeel.uninitialize​()

当这个外观和感觉被卸载时，由UIManager打电话。

protected void

SynthInternalFrameUI.uninstallComponents​()

卸载组件。

protected void

SynthToolBarUI.uninstallComponents​()

取消注册组件。

protected void

SynthButtonUI.uninstallDefaults​(AbstractButton b)

卸载默认属性。

protected void

SynthColorChooserUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthComboBoxUI.uninstallDefaults​()

从组合框中卸载默认颜色，默认字体，默认渲染器和默认编辑器。

protected void

SynthDesktopIconUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthDesktopPaneUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthEditorPaneUI.uninstallDefaults​()

将未明确覆盖的组件属性设置为 null 。

protected void

SynthInternalFrameUI.uninstallDefaults​()

卸载默认值。

protected void

SynthLabelUI.uninstallDefaults​(JLabel c)

卸载默认属性。

protected void

SynthListUI.uninstallDefaults​()

将未明确覆盖的列表属性设置为 null 。

protected void

SynthMenuBarUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthMenuItemUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthMenuUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthOptionPaneUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthPanelUI.uninstallDefaults​(JPanel p)

卸载面板属性的方法。

protected void

SynthPopupMenuUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthProgressBarUI.uninstallDefaults​()

Unintalls默认属性。

protected void

SynthRootPaneUI.uninstallDefaults​(JRootPane root)

卸载默认属性。

protected void

SynthScrollBarUI.uninstallDefaults​()

卸载默认值。

protected void

SynthScrollPaneUI.uninstallDefaults​(JScrollPane c)

卸载默认属性。

protected void

SynthSpinnerUI.uninstallDefaults​()

将 JSpinner's布局管理器设置为null。

protected void

SynthSplitPaneUI.uninstallDefaults​()

卸载UI默认值。

protected void

SynthTabbedPaneUI.uninstallDefaults​()

卸载默认值。

protected void

SynthTableHeaderUI.uninstallDefaults​()

卸载默认属性

protected void

SynthTableUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthTextAreaUI.uninstallDefaults​()

将未明确覆盖的组件属性设置为 null 。

protected void

SynthTextFieldUI.uninstallDefaults​()

将未明确覆盖的组件属性设置为 null 。

protected void

SynthToolBarUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthToolTipUI.uninstallDefaults​(JComponent c)

卸载默认属性。

protected void

SynthTreeUI.uninstallDefaults​()

卸载默认属性。

protected void

SynthDesktopPaneUI.uninstallDesktopManager​()

卸载桌面管理器。

protected void

SynthButtonUI.uninstallListeners​(AbstractButton b)

取消注册听众。

protected void

SynthColorChooserUI.uninstallListeners​()

取消注册听众。

protected void

SynthComboBoxUI.uninstallListeners​()

从组合框及其模型中删除已安装的监听器。

protected void

SynthDesktopIconUI.uninstallListeners​()

取消注册听众。

protected void

SynthDesktopPaneUI.uninstallListeners​()

卸载 PropertyChangeListener从返回 createPropertyChangeListener从 JDesktopPane 。

protected void

SynthInternalFrameUI.uninstallListeners​()

卸载侦听器。

protected void

SynthListUI.uninstallListeners​()

从JList，其模型及其selectionModel中移除侦听器。

protected void

SynthMenuBarUI.uninstallListeners​()

取消注册听众。

protected void

SynthMenuItemUI.uninstallListeners​()

取消注册听众。

protected void

SynthMenuUI.uninstallListeners​()

取消注册听众。

protected void

SynthOptionPaneUI.uninstallListeners​()

取消注册听众。

protected void

SynthPopupMenuUI.uninstallListeners​()

取消注册听众。

protected void

SynthProgressBarUI.uninstallListeners​()

删除此对象安装的所有侦听器。

protected void

SynthScrollBarUI.uninstallListeners​()

卸载侦听器。

protected void

SynthScrollPaneUI.uninstallListeners​(JComponent c)

取消注册听众。

protected void

SynthSliderUI.uninstallListeners​(JSlider slider)

卸载侦听器。

protected void

SynthSpinnerUI.uninstallListeners​()

删除由 PropertyChangeListener添加的PropertyChangeListener。

protected void

SynthSplitPaneUI.uninstallListeners​()

从UI中卸载事件侦听器。

protected void

SynthTabbedPaneUI.uninstallListeners​()

卸载侦听器。

protected void

SynthTableHeaderUI.uninstallListeners​()

取消注册听众。

protected void

SynthTableUI.uninstallListeners​()

取消注册听众。

protected void

SynthToolBarUI.uninstallListeners​()

取消注册听众。

protected void

SynthToolTipUI.uninstallListeners​(JComponent c)

取消注册听众。

protected void

SynthTreeUI.uninstallListeners​()

取消注册听众。

void

SynthComboBoxUI.uninstallUI​(JComponent c)

在 installUI反转在指定组件上完成的配置。

void

SynthMenuItemUI.uninstallUI​(JComponent c)

在 installUI反转在指定组件上完成的配置。

void

SynthMenuUI.uninstallUI​(JComponent c)

在 installUI反转在指定组件上完成的配置。

void

SynthPanelUI.uninstallUI​(JComponent c)

在 installUI反转在指定组件上完成的配置。

void

SynthSeparatorUI.uninstallUI​(JComponent c)

在 installUI反转在指定组件上完成的配置。

void

SynthViewportUI.uninstallUI​(JComponent c)

在 installUI反转在指定组件上完成的配置。

void

SynthButtonUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthColorChooserUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthComboBoxUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthDesktopIconUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthDesktopPaneUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthEditorPaneUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthInternalFrameUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthLabelUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthListUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthMenuBarUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthMenuItemUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthMenuUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthOptionPaneUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthPanelUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthPopupMenuUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthProgressBarUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthRootPaneUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthScrollBarUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthScrollPaneUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthSeparatorUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthSliderUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthSpinnerUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthSplitPaneUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthTabbedPaneUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthTableHeaderUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthTableUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthTextAreaUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthTextFieldUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthToolBarUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthToolTipUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthTreeUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

void

SynthViewportUI.update​(Graphics g, JComponent c)

通知此UI代理重新绘制指定的组件。

int

SynthSliderUI.valueForXPosition​(int xPos)

返回x位置的值。

int

SynthSliderUI.valueForYPosition​(int yPos)

返回y位置的值。

protected int

SynthSliderUI.xPositionForValue​(int value)

返回值的x位置。

protected int

SynthSliderUI.yPositionForValue​(int value, int trackY, int trackHeight)

返回指定值的y位置。

Uses of Override in javax.swing.table

Methods in javax.swing.table with annotations of type Override

Modifier and Type

方法

描述

Dimension

JTableHeader.getPreferredSize​()

返回表头的首选大小。

Uses of Override in javax.swing.text

Methods in javax.swing.text with annotations of type Override

Modifier and Type

方法

描述

protected SizeRequirements

TableView.TableRow.calculateMajorAxisRequirements​(int axis, SizeRequirements r)

protected SizeRequirements

ParagraphView.calculateMinorAxisRequirements​(int axis, SizeRequirements r)

计算沿着短轴的段落的需要。

Enumeration<TreeNode>

AbstractDocument.LeafElement.children​()

以 Enumeration返回接收者的 Enumeration 。

protected float

PasswordView.drawSelectedText​(Graphics2D g, float x, float y, int p0, int p1)

protected int

PasswordView.drawSelectedText​(Graphics g, int x, int y, int p0, int p1)

已过时。
代之以PasswordView.drawSelectedText(Graphics2D, float, float, int, int)

protected float

PasswordView.drawUnselectedText​(Graphics2D g, float x, float y, int p0, int p1)

protected int

PasswordView.drawUnselectedText​(Graphics g, int x, int y, int p0, int p1)

已过时。
代之以PasswordView.drawUnselectedText(Graphics2D, float, float, int, int)

float

TableView.TableRow.getMaximumSpan​(int axis)

float

GlyphView.getMinimumSpan​(int axis)

确定此视图沿轴的最小跨度。

float

TableView.TableRow.getMinimumSpan​(int axis)

float

TableView.TableRow.getPreferredSpan​(int axis)

Uses of Override in javax.tools

Methods in javax.tools with annotations of type Override

Modifier and Type

方法

描述

Boolean

JavaCompiler.CompilationTask.call​()

执行此编译任务。

void

JavaFileManager.close​()

释放此文件管理器直接或间接打开的任何资源。

void

JavaFileManager.flush​()

刷新此文件管理器直接或间接打开输出的任何资源。

String

StandardLocation.getName​()

boolean

StandardLocation.isModuleOrientedLocation​()

指出这个位置是否是面向模块的位置，因此与面向包的位置相比，预期它将包含一个 模块/包/类层次结构中的 类 ，该位置预期包含一个 包/类层次结构中的 类 。

boolean

StandardLocation.isOutputLocation​()

boolean

StandardJavaFileManager.isSameFile​(FileObject a, FileObject b)

比较两个文件对象，如果它们表示相同的规范文件，zip文件条目或任何基于文件系统的容器中的条目，则返回true。

String

SimpleJavaFileObject.toString​()

Uses of Override in javax.xml.bind

Methods in javax.xml.bind with annotations of type Override

Modifier and Type

方法

描述

Throwable

JAXBException.getCause​()

Uses of Override in javax.xml.catalog

Methods in javax.xml.catalog with annotations of type Override

Modifier and Type

方法

描述

Source

CatalogResolver.resolve​(String href, String base)

实施URIRsolver。

InputSource

CatalogResolver.resolveEntity​(String publicId, String systemId)

实现EntityResolver 。

InputStream

CatalogResolver.resolveEntity​(String publicId, String systemId, String baseUri, String namespace)

实现XMLResolver 。

LSInput

CatalogResolver.resolveResource​(String type, String namespaceUri, String publicId, String systemId, String baseUri)

实现LSResourceResolver 。

Uses of Override in javax.xml.datatype

Methods in javax.xml.datatype with annotations of type Override

Modifier and Type

方法

描述

abstract Object

XMLGregorianCalendar.clone​()

创建并返回此对象的副本。

boolean

XMLGregorianCalendar.equals​(Object obj)

将此日历与指定的对象进行比较。

int

XMLGregorianCalendar.hashCode​()

返回与equals方法的定义一致的哈希码。

String

XMLGregorianCalendar.toString​()

返回此 XMLGregorianCalendar Object的 String表示。

Uses of Override in javax.xml.parsers

Methods in javax.xml.parsers with annotations of type Override

Modifier and Type

方法

描述

Throwable

FactoryConfigurationError.getCause​()

使用JDK1.4的异常链接机制

Uses of Override in javax.xml.soap

Methods in javax.xml.soap with annotations of type Override

Modifier and Type

方法

描述

Throwable

SOAPException.getCause​()

返回 Throwable对象嵌入在这个 SOAPException如果有的话。

String

SOAPException.getMessage​()

返回此 SOAPException对象的详细消息。

Throwable

SOAPException.initCause​(Throwable cause)

使用给定的 Throwable对象初始化此 SOAPException对象的 cause字段。

Uses of Override in javax.xml.stream

Methods in javax.xml.stream with annotations of type Override

Modifier and Type

方法

描述

Throwable

FactoryConfigurationError.getCause​()

使用JDK1.4的异常链接机制

boolean

XMLEventReader.hasNext​()

检查是否有更多的事件。

Uses of Override in javax.xml.transform

Methods in javax.xml.transform with annotations of type Override

Modifier and Type

方法

描述

Throwable

TransformerFactoryConfigurationError.getCause​()

使用JDK1.4的异常链接机制

Uses of Override in javax.xml.transform.dom

Methods in javax.xml.transform.dom with annotations of type Override

Modifier and Type

方法

描述

String

DOMSource.getSystemId​()

获取基址（URL或系统ID），从中解析URL。

boolean

DOMSource.isEmpty​()

指示 DOMSource对象是否为空。

void

DOMSource.setSystemId​(String systemID)

设置基址（URL或系统ID）从哪里解决URL。

Uses of Override in javax.xml.transform.sax

Methods in javax.xml.transform.sax with annotations of type Override

Modifier and Type

方法

描述

String

SAXSource.getSystemId​()

获取URI将被解析的基本ID（URI或系统ID）。

boolean

SAXSource.isEmpty​()

指示 SAXSource对象是否为空。

void

SAXSource.setSystemId​(String systemId)

设置此源的系统标识符。

Uses of Override in javax.xml.transform.stax

Methods in javax.xml.transform.stax with annotations of type Override

Modifier and Type

方法

描述

String

StAXSource.getSystemId​()

获取此 StAXSource使用的系统标识符。

boolean

StAXSource.isEmpty​()

指示 StAXSource对象是否为空。

void

StAXSource.setSystemId​(String systemId)

在 StAXSource的上下文中，显式设置系统标识符是不合适的。

Uses of Override in javax.xml.transform.stream

Methods in javax.xml.transform.stream with annotations of type Override

Modifier and Type

方法

描述

String

StreamSource.getSystemId​()

获取使用setSystemId设置的系统标识符。

boolean

StreamSource.isEmpty​()

指示 StreamSource对象是否为空。

void

StreamSource.setSystemId​(String systemId)

设置此源的系统标识符。

Uses of Override in javax.xml.ws

Methods in javax.xml.ws with annotations of type Override

Modifier and Type

方法

描述

String

EndpointReference.toString​()

显示EPR信息，方便调试。

Uses of Override in javax.xml.ws.wsaddressing

Methods in javax.xml.ws.wsaddressing with annotations of type Override

Modifier and Type

方法

描述

void

W3CEndpointReference.writeTo​(Result result)

将此 EndpointReference写入指定的信息集格式

Uses of Override in javax.xml.xpath

Methods in javax.xml.xpath with annotations of type Override

Modifier and Type

方法

描述

Iterator<Node>

XPathNodes.iterator​()

返回Nodes的迭代器。

Uses of Override in jdk.dynalink

Methods in jdk.dynalink with annotations of type Override

Modifier and Type

方法

描述

boolean

CallSiteDescriptor.equals​(Object obj)

如果此调用站点描述符等于传递的对象，则返回true。

boolean

NamedOperation.equals​(Object obj)

将此命名操作与另一个对象进行比较。

boolean

NamespaceOperation.equals​(Object obj)

如果另一个对象也是命名空间操作，并且它们的基本操作和命名空间相等，则返回true。

int

CallSiteDescriptor.hashCode​()

返回从其操作，方法类型和查找对象的查找类和查找模式计算的此调用站点描述符的基于值的哈希码。

int

NamedOperation.hashCode​()

返回此命名操作的哈希码。

int

NamespaceOperation.hashCode​()

返回此命名空间操作的哈希码。

String

CallSiteDescriptor.toString​()

返回此调用站点描述符的字符串表示形式，格式为 name(parameterTypes)returnType@lookup 。

String

NamedOperation.toString​()

返回此命名操作的字符串表示形式。

String

NamespaceOperation.toString​()

返回此命名空间操作的字符串表示形式。

Uses of Override in jdk.dynalink.beans

Methods in jdk.dynalink.beans with annotations of type Override

Modifier and Type

方法

描述

GuardedInvocation

BeansLinker.getGuardedInvocation​(LinkRequest request, LinkerServices linkerServices)

String

StaticClass.toString​()

Uses of Override in jdk.dynalink.linker.support

Methods in jdk.dynalink.linker.support with annotations of type Override

Modifier and Type

方法

描述

boolean

CompositeTypeBasedGuardingDynamicLinker.canLinkType​(Class<?> type)

如果至少有一个复合链接器从类型的 TypeBasedGuardingDynamicLinker.canLinkType(Class)返回true， 则返回true。

Object[]

SimpleLinkRequest.getArguments​()

CallSiteDescriptor

SimpleLinkRequest.getCallSiteDescriptor​()

GuardedInvocation

CompositeGuardingDynamicLinker.getGuardedInvocation​(LinkRequest linkRequest, LinkerServices linkerServices)

将呼叫委托给其组件链接器。

GuardedInvocation

CompositeTypeBasedGuardingDynamicLinker.getGuardedInvocation​(LinkRequest linkRequest, LinkerServices linkerServices)

Object

SimpleLinkRequest.getReceiver​()

boolean

SimpleLinkRequest.isCallSiteUnstable​()

LinkRequest

SimpleLinkRequest.replaceArguments​(CallSiteDescriptor newCallSiteDescriptor, Object... newArguments)

MethodHandle

DefaultInternalObjectFilter.transform​(MethodHandle target)

Uses of Override in jdk.dynalink.support

Methods in jdk.dynalink.support with annotations of type Override

Modifier and Type

方法

描述

CallSiteDescriptor

AbstractRelinkableCallSite.getDescriptor​()

void

AbstractRelinkableCallSite.initialize​(MethodHandle relinkAndInvoke)

void

ChainedCallSite.relink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)

void

SimpleRelinkableCallSite.relink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)

void

ChainedCallSite.resetAndRelink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)

void

SimpleRelinkableCallSite.resetAndRelink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)

Uses of Override in jdk.incubator.http

Methods in jdk.incubator.http with annotations of type Override

Modifier and Type

方法

描述

void

MultiMapResult.clear​()

boolean

MultiMapResult.containsKey​(Object key)

boolean

MultiMapResult.containsValue​(Object value)

Set<Map.Entry<HttpRequest,CompletableFuture<HttpResponse<V>>>>

MultiMapResult.entrySet​()

CompletableFuture<HttpResponse<V>>

MultiMapResult.get​(Object key)

WebSocketHandshakeException

WebSocketHandshakeException.initCause​(Throwable cause)

boolean

MultiMapResult.isEmpty​()

Set<HttpRequest>

MultiMapResult.keySet​()

CompletableFuture<HttpResponse<V>>

MultiMapResult.put​(HttpRequest key, CompletableFuture<HttpResponse<V>> value)

void

MultiMapResult.putAll​(Map<? extends HttpRequest,? extends CompletableFuture<HttpResponse<V>>> m)

CompletableFuture<HttpResponse<V>>

MultiMapResult.remove​(Object key)

int

MultiMapResult.size​()

Collection<CompletableFuture<HttpResponse<V>>>

MultiMapResult.values​()

Uses of Override in jdk.javadoc.doclet

Methods in jdk.javadoc.doclet with annotations of type Override

Modifier and Type

方法

描述

String

StandardDoclet.getName​()

Set<Doclet.Option>

StandardDoclet.getSupportedOptions​()

SourceVersion

StandardDoclet.getSupportedSourceVersion​()

void

StandardDoclet.init​(Locale locale, Reporter reporter)

boolean

StandardDoclet.run​(DocletEnvironment docEnv)

Uses of Override in jdk.jshell

Methods in jdk.jshell with annotations of type Override

Modifier and Type

方法

描述

void

JShell.close​()

关闭这个状态引擎。

String

ExpressionSnippet.name​()

变量名称是表达式的值。

String

ImportSnippet.name​()

导入的识别名称。

String

PersistentSnippet.name​()

代码片段的名称

String

MethodSnippet.toString​()

String

Snippet.toString​()

String

SnippetEvent.toString​()

返回事件的字符串表示形式

Uses of Override in jdk.jshell.execution

Methods in jdk.jshell.execution with annotations of type Override

Modifier and Type

方法

描述

void

DirectExecutionControl.addToClasspath​(String cp)

void

StreamingExecutionControl.addToClasspath​(String path)

protected void

LocalExecutionControl.clientCodeEnter​()

protected void

RemoteExecutionControl.clientCodeEnter​()

protected void

LocalExecutionControl.clientCodeLeave​()

protected void

RemoteExecutionControl.clientCodeLeave​()

void

DirectExecutionControl.close​()

void

JdiDefaultExecutionControl.close​()

void

StreamingExecutionControl.close​()

关闭执行引擎。

Map<String,String>

FailOverExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

Map<String,String>

JdiExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

Map<String,String>

LocalExecutionControlProvider.defaultParameters​()

创建并返回 LocalExecutionControlProvider的默认参数图。

Object

DirectExecutionControl.extensionCommand​(String command, Object arg)

Object

StreamingExecutionControl.extensionCommand​(String command, Object arg)

ExecutionControl

FailOverExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回本地执行的 ExecutionControl实例。

ExecutionControl

JdiExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

ExecutionControl

LocalExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回本地执行的 ExecutionControl实例。

String

DirectExecutionControl.invoke​(String className, String methodName)

String

JdiDefaultExecutionControl.invoke​(String classname, String methodname)

protected String

LocalExecutionControl.invoke​(方法 doitMethod)

protected String

RemoteExecutionControl.invoke​(方法 doitMethod)

String

StreamingExecutionControl.invoke​(String classname, String methodname)

void

DirectExecutionControl.load​(ExecutionControl.ClassBytecodes[] cbcs)

void

StreamingExecutionControl.load​(ExecutionControl.ClassBytecodes[] cbcs)

String

FailOverExecutionControlProvider.name​()

这个独特的名字 ExecutionControlProvider 。

String

JdiExecutionControlProvider.name​()

这个独特的名字 ExecutionControlProvider 。

String

LocalExecutionControlProvider.name​()

这个独特的名字 ExecutionControlProvider 。

void

DirectExecutionControl.redefine​(ExecutionControl.ClassBytecodes[] cbcs)

void

JdiExecutionControl.redefine​(ExecutionControl.ClassBytecodes[] cbcs)

重新定义指定的类。

void

RemoteExecutionControl.redefine​(ExecutionControl.ClassBytecodes[] cbcs)

远程重新定义处理只用于注册重新定义的类

void

StreamingExecutionControl.redefine​(ExecutionControl.ClassBytecodes[] cbcs)

void

DirectExecutionControl.stop​()

中断一个正在运行的调用。

void

JdiDefaultExecutionControl.stop​()

通过操作远程变量并通过JDI发送停止来中断正在运行的远程调用。

void

LocalExecutionControl.stop​()

void

RemoteExecutionControl.stop​()

void

StreamingExecutionControl.stop​()

protected String

RemoteExecutionControl.throwConvertedInvocationException​(Throwable cause)

protected String

RemoteExecutionControl.throwConvertedOtherException​(Throwable ex)

String

DirectExecutionControl.varValue​(String className, String varName)

String

RemoteExecutionControl.varValue​(String className, String varName)

String

StreamingExecutionControl.varValue​(String classname, String varname)

protected VirtualMachine

JdiDefaultExecutionControl.vm​()

Uses of Override in jdk.jshell.spi

Methods in jdk.jshell.spi with annotations of type Override

Modifier and Type

方法

描述

void

ExecutionControl.close​()

关闭这个执行引擎。

Uses of Override in jdk.nashorn.api.scripting

Methods in jdk.nashorn.api.scripting with annotations of type Override

Modifier and Type

方法

描述

Object

AbstractJSObject.call​(Object thiz, Object... args)

Object

ScriptObjectMirror.call​(Object thiz, Object... args)

void

ScriptObjectMirror.clear​()

void

URLReader.close​()

CompiledScript

NashornScriptEngine.compile​(Reader reader)

CompiledScript

NashornScriptEngine.compile​(String str)

boolean

ScriptObjectMirror.containsKey​(Object key)

boolean

ScriptObjectMirror.containsValue​(Object value)

Bindings

NashornScriptEngine.createBindings​()

Set<Map.Entry<String,Object>>

ScriptObjectMirror.entrySet​()

boolean

ScriptObjectMirror.equals​(Object other)

Object

AbstractJSObject.eval​(String s)

Object

NashornScriptEngine.eval​(Reader reader, ScriptContext ctxt)

Object

NashornScriptEngine.eval​(String script, ScriptContext ctxt)

Object

ScriptObjectMirror.eval​(String s)

Object

ScriptObjectMirror.get​(Object key)

String

AbstractJSObject.getClassName​()

String

ScriptObjectMirror.getClassName​()

Object

ScriptObjectMirror.getDefaultValue​(Class<?> hint)

String

NashornScriptEngineFactory.getEngineName​()

String

NashornScriptEngineFactory.getEngineVersion​()

List<String>

NashornScriptEngineFactory.getExtensions​()

ScriptEngineFactory

NashornScriptEngine.getFactory​()

<T> T

NashornScriptEngine.getInterface​(Class<T> clazz)

<T> T

NashornScriptEngine.getInterface​(Object thiz, Class<T> clazz)

String

NashornScriptEngineFactory.getLanguageName​()

String

NashornScriptEngineFactory.getLanguageVersion​()

Object

AbstractJSObject.getMember​(String name)

Object

ScriptObjectMirror.getMember​(String name)

String

NashornScriptEngineFactory.getMethodCallSyntax​(String obj, String method, String... args)

List<String>

NashornScriptEngineFactory.getMimeTypes​()

List<String>

NashornScriptEngineFactory.getNames​()

String

NashornScriptEngineFactory.getOutputStatement​(String toDisplay)

Object

NashornScriptEngineFactory.getParameter​(String key)

String

NashornScriptEngineFactory.getProgram​(String... statements)

ScriptEngine

NashornScriptEngineFactory.getScriptEngine​()

Object

AbstractJSObject.getSlot​(int index)

Object

ScriptObjectMirror.getSlot​(int index)

int

ScriptObjectMirror.hashCode​()

boolean

AbstractJSObject.hasMember​(String name)

boolean

ScriptObjectMirror.hasMember​(String name)

boolean

AbstractJSObject.hasSlot​(int slot)

boolean

ScriptObjectMirror.hasSlot​(int slot)

Object

NashornScriptEngine.invokeFunction​(String name, Object... args)

Object

NashornScriptEngine.invokeMethod​(Object thiz, String name, Object... args)

boolean

AbstractJSObject.isArray​()

boolean

ScriptObjectMirror.isArray​()

boolean

ScriptObjectMirror.isEmpty​()

boolean

AbstractJSObject.isFunction​()

boolean

ScriptObjectMirror.isFunction​()

boolean

AbstractJSObject.isInstance​(Object instance)

boolean

ScriptObjectMirror.isInstance​(Object instance)

boolean

AbstractJSObject.isInstanceOf​(Object clazz)

boolean

AbstractJSObject.isStrictFunction​()

boolean

ScriptObjectMirror.isStrictFunction​()

Set<String>

AbstractJSObject.keySet​()

Set<String>

ScriptObjectMirror.keySet​()

Object

AbstractJSObject.newObject​(Object... args)

Object

ScriptObjectMirror.newObject​(Object... args)

Object

ScriptObjectMirror.put​(String key, Object value)

void

ScriptObjectMirror.putAll​(Map<? extends String,? extends Object> map)

int

URLReader.read​(char[] cbuf, int off, int len)

Object

ScriptObjectMirror.remove​(Object key)

void

AbstractJSObject.removeMember​(String name)

void

ScriptObjectMirror.removeMember​(String name)

void

AbstractJSObject.setMember​(String name, Object value)

void

ScriptObjectMirror.setMember​(String name, Object value)

void

AbstractJSObject.setSlot​(int index, Object value)

void

ScriptObjectMirror.setSlot​(int index, Object value)

int

ScriptObjectMirror.size​()

double

AbstractJSObject.toNumber​()

已过时。
使用JSObject.getDefaultValue(Class)与Number提示代替。

double

ScriptObjectMirror.toNumber​()

已过时。

String

ScriptObjectMirror.toString​()

Collection<Object>

AbstractJSObject.values​()

Collection<Object>

ScriptObjectMirror.values​()

Uses of Override in jdk.nashorn.api.tree

Methods in jdk.nashorn.api.tree with annotations of type Override

Modifier and Type

方法

描述

ExpressionTree

DoWhileLoopTree.getCondition​()

返回此do-while语句的条件表达式。

ExpressionTree

ForLoopTree.getCondition​()

返回此'for'语句的条件表达式。

ExpressionTree

WhileLoopTree.getCondition​()

这个'while'语句的条件表达式。

String

BreakTree.getLabel​()

与此break语句关联的标签。

String

ContinueTree.getLabel​()

与此continue语句关联的标签。

StatementTree

DoWhileLoopTree.getStatement​()

该声明包含在此do-while语句中。

StatementTree

ForInLoopTree.getStatement​()

该声明中包含的声明。

StatementTree

ForLoopTree.getStatement​()

返回此'for'语句中包含的语句。

StatementTree

ForOfLoopTree.getStatement​()

声明中包含的声明。

StatementTree

WhileLoopTree.getStatement​()

该声明中包含的声明。

R

SimpleTreeVisitorES5_1.visitArrayAccess​(ArrayAccessTree node, P r)

R

SimpleTreeVisitorES5_1.visitArrayLiteral​(ArrayLiteralTree node, P r)

R

SimpleTreeVisitorES5_1.visitAssignment​(AssignmentTree node, P r)

R

SimpleTreeVisitorES5_1.visitBinary​(BinaryTree node, P r)

R

SimpleTreeVisitorES5_1.visitBlock​(BlockTree node, P r)

R

SimpleTreeVisitorES5_1.visitBreak​(BreakTree node, P r)

R

SimpleTreeVisitorES5_1.visitCase​(CaseTree node, P r)

R

SimpleTreeVisitorES5_1.visitCatch​(CatchTree node, P r)

R

SimpleTreeVisitorES5_1.visitClassDeclaration​(ClassDeclarationTree node, P p)

通过致电 visitUnknown访问 ClassDeclarationTree树。

R

SimpleTreeVisitorES6.visitClassDeclaration​(ClassDeclarationTree node, P p)

访问类语句树。

R

SimpleTreeVisitorES5_1.visitClassExpression​(ClassExpressionTree node, P p)

通过致电 visitUnknown访问一个 ClassExpressionTree树。

R

SimpleTreeVisitorES6.visitClassExpression​(ClassExpressionTree node, P p)

访问类表达式树。

R

SimpleTreeVisitorES5_1.visitCompilationUnit​(CompilationUnitTree node, P r)

R

SimpleTreeVisitorES6.visitCompilationUnit​(CompilationUnitTree node, P r)

R

SimpleTreeVisitorES5_1.visitCompoundAssignment​(CompoundAssignmentTree node, P r)

R

SimpleTreeVisitorES5_1.visitConditionalExpression​(ConditionalExpressionTree node, P r)

R

SimpleTreeVisitorES5_1.visitContinue​(ContinueTree node, P r)

R

SimpleTreeVisitorES5_1.visitDebugger​(DebuggerTree node, P r)

R

SimpleTreeVisitorES5_1.visitDoWhileLoop​(DoWhileLoopTree node, P r)

R

SimpleTreeVisitorES5_1.visitEmptyStatement​(EmptyStatementTree node, P r)

R

SimpleTreeVisitorES5_1.visitErroneous​(ErroneousTree node, P r)

R

SimpleTreeVisitorES5_1.visitExportEntry​(ExportEntryTree node, P p)

通过致电 visitUnknown访问 ExportEntryTree树。

R

SimpleTreeVisitorES6.visitExportEntry​(ExportEntryTree node, P p)

访问模块ExportEntry树。

R

SimpleTreeVisitorES5_1.visitExpressionStatement​(ExpressionStatementTree node, P r)

R

SimpleTreeVisitorES5_1.visitForInLoop​(ForInLoopTree node, P r)

R

SimpleTreeVisitorES5_1.visitForLoop​(ForLoopTree node, P r)

R

SimpleTreeVisitorES5_1.visitForOfLoop​(ForOfLoopTree node, P p)

通过致电 visitUnknown访问一个 ForOfLoopTree树。

R

SimpleTreeVisitorES6.visitForOfLoop​(ForOfLoopTree node, P p)

访问声明树。

R

SimpleTreeVisitorES5_1.visitFunctionCall​(FunctionCallTree node, P r)

R

SimpleTreeVisitorES5_1.visitFunctionDeclaration​(FunctionDeclarationTree node, P r)

R

SimpleTreeVisitorES5_1.visitFunctionExpression​(FunctionExpressionTree node, P r)

R

SimpleTreeVisitorES5_1.visitIdentifier​(IdentifierTree node, P r)

R

SimpleTreeVisitorES5_1.visitIf​(IfTree node, P r)

R

SimpleTreeVisitorES5_1.visitImportEntry​(ImportEntryTree node, P p)

通过致电 visitUnknown访问 ImportEntryTree树。

R

SimpleTreeVisitorES6.visitImportEntry​(ImportEntryTree node, P p)

访问模块ImportEntry树。

R

SimpleTreeVisitorES5_1.visitInstanceOf​(InstanceOfTree node, P r)

R

SimpleTreeVisitorES5_1.visitLabeledStatement​(LabeledStatementTree node, P r)

R

SimpleTreeVisitorES5_1.visitLiteral​(LiteralTree node, P r)

R

SimpleTreeVisitorES5_1.visitMemberSelect​(MemberSelectTree node, P r)

R

SimpleTreeVisitorES5_1.visitModule​(ModuleTree node, P p)

通过致电 visitUnknown访问 ModuleTree树。

R

SimpleTreeVisitorES6.visitModule​(ModuleTree node, P p)

访问模块树。

R

SimpleTreeVisitorES5_1.visitNew​(NewTree node, P r)

R

SimpleTreeVisitorES5_1.visitObjectLiteral​(ObjectLiteralTree node, P r)

R

SimpleTreeVisitorES5_1.visitParenthesized​(ParenthesizedTree node, P r)

R

SimpleTreeVisitorES5_1.visitProperty​(PropertyTree node, P r)

R

SimpleTreeVisitorES5_1.visitRegExpLiteral​(RegExpLiteralTree node, P r)

R

SimpleTreeVisitorES5_1.visitReturn​(ReturnTree node, P r)

R

SimpleTreeVisitorES5_1.visitSpread​(SpreadTree node, P p)

通过致电 visitUnknown访问一个 SpreadTree树。

R

SimpleTreeVisitorES6.visitSpread​(SpreadTree node, P p)

访问“传播”表达式树。

R

SimpleTreeVisitorES5_1.visitSwitch​(SwitchTree node, P r)

R

SimpleTreeVisitorES5_1.visitTemplateLiteral​(TemplateLiteralTree node, P p)

访问 TemplateLiteralTree树通过调用 visitUnknown 。

R

SimpleTreeVisitorES6.visitTemplateLiteral​(TemplateLiteralTree node, P p)

访问模板文字树。

R

SimpleTreeVisitorES5_1.visitThrow​(ThrowTree node, P r)

R

SimpleTreeVisitorES5_1.visitTry​(TryTree node, P r)

R

SimpleTreeVisitorES5_1.visitUnary​(UnaryTree node, P r)

R

SimpleTreeVisitorES5_1.visitUnknown​(树 node, P p)

访问未知表达式/语句树。

R

SimpleTreeVisitorES5_1.visitVariable​(VariableTree node, P r)

R

SimpleTreeVisitorES6.visitVariable​(VariableTree node, P r)

R

SimpleTreeVisitorES5_1.visitWhileLoop​(WhileLoopTree node, P r)

R

SimpleTreeVisitorES5_1.visitWith​(WithTree node, P r)

R

SimpleTreeVisitorES5_1.visitYield​(YieldTree node, P p)

通过致电 visitUnknown访问一个 YieldTree树。

R

SimpleTreeVisitorES6.visitYield​(YieldTree node, P p)

访问“yield”表达式树。

Uses of Override in jdk.net

Methods in jdk.net with annotations of type Override

Modifier and Type

方法

描述

String

SocketFlow.toString​()

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev

Next

框架

无框架

所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Package (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Package

  • Packages that use 软件包
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.net
    提供实现网络应用程序的类。

    • Uses of 软件包 in java.lang

      Methods in java.lang that return 软件包
      Modifier and Type 方法 描述
      protected 软件包 ClassLoader.definePackage​(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
      通过定义一个包 name在这个 ClassLoader 。
      软件包 ClassLoader.getDefinedPackage​(String name)
      返回 软件包给定的 name已经被这个类加载器定义。
      软件包[] ClassLoader.getDefinedPackages​()
      返回此类加载器定义的所有 软件包 s。
      软件包 Class.getPackage​()
      获取此类的包。
      protected 软件包 ClassLoader.getPackage​(String name)
      已过时。
      如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使子载入程序定义的package-info.class文件中存在注释。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
      static 软件包 Package.getPackage​(String name)
      已过时。
      如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则软件包暴露的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使子载入程序定义的package-info.class文件中存在注释。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
      protected 软件包[] ClassLoader.getPackages​()
      返回由此类加载器及其祖先定义的所有 软件包 。
      static 软件包[] Package.getPackages​()
      返回由调用者的类加载器及其祖先定义的所有 软件包 。

    • Uses of 软件包 in java.net

      Methods in java.net that return 软件包
      Modifier and Type 方法 描述
      protected 软件包 URLClassLoader.definePackage​(String name, Manifest man, URL url)
      Defines a new package by name in this URLClassLoader.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Process (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Process

  • Packages that use Process
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    java.lang
    提供对Java编程语言设计至关重要的类。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of Process in com.sun.jdi

      Methods in com.sun.jdi that return Process
      Modifier and Type 方法 描述
      Process VirtualMachine.process​()
      如果由LaunchingConnector启动，则返回此虚拟机的Process对象
      Methods in com.sun.jdi with parameters of type Process
      Modifier and Type 方法 描述
      VirtualMachine VirtualMachineManager.createVirtualMachine​(Connection connection, Process process)
      为目标虚拟机创建虚拟机镜像。

    • Uses of Process in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that return Process
      Modifier and Type | 方法 | 描述
      Process | VMStartException.process​()
      Constructors in com.sun.jdi.connect with parameters of type Process
      Constructor 描述
      VMStartException​(Process process)
      VMStartException​(String message, Process process)

    • Uses of Process in java.lang

      Methods in java.lang that return Process
      Modifier and Type 方法 描述
      Process Process.destroyForcibly​()
      强制杀死进程。
      Process Runtime.exec​(String command)
      在单独的进程中执行指定的字符串命令。
      Process Runtime.exec​(String[] cmdarray)
      在单独的进程中执行指定的命令和参数。
      Process Runtime.exec​(String[] cmdarray, String[] envp)
      在指定环境的单独进程中执行指定的命令和参数。
      Process Runtime.exec​(String[] cmdarray, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的命令和参数。
      Process Runtime.exec​(String command, String[] envp)
      在具有指定环境的单独进程中执行指定的字符串命令。
      Process Runtime.exec​(String command, String[] envp, File dir)
      在指定的环境和工作目录的单独进程中执行指定的字符串命令。
      Process ProcessBuilder.start​()
      使用此流程构建器的属性启动新进程。
      Methods in java.lang that return types with arguments of type Process
      Modifier and Type 方法 描述
      CompletableFuture<Process> Process.onExit​()
      返回一个 CompletableFuture<Process>终止进程。
      static List<Process> ProcessBuilder.startPipeline​(List<ProcessBuilder> builders)
      为每个ProcessBuilder启动流程，创建一个由其标准输出流和标准输入流链接的流程。

    • Uses of Process in jdk.jshell.execution

      Methods in jdk.jshell.execution that return Process
      Modifier and Type 方法 描述
      Process JdiInitiator.process​()
      返回启动的进程。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ProcessBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ProcessBuilder

  • Packages that use ProcessBuilder
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ProcessBuilder in java.lang

      Methods in java.lang that return ProcessBuilder
      Modifier and Type 方法 描述
      ProcessBuilder ProcessBuilder.command​(String... command)
      设置此流程构建器的操作系统程序和参数。
      ProcessBuilder ProcessBuilder.command​(List<String> command)
      设置此流程构建器的操作系统程序和参数。
      ProcessBuilder ProcessBuilder.directory​(File directory)
      设置此进程构建器的工作目录。
      ProcessBuilder ProcessBuilder.inheritIO​()
      将子进程标准I / O的源和目标设置为与当前Java进程相同。
      ProcessBuilder ProcessBuilder.redirectError​(File file)
      将此流程构建器的标准错误目标设置为文件。
      ProcessBuilder ProcessBuilder.redirectError​(ProcessBuilder.Redirect destination)
      设置此流程构建器的标准错误目标。
      ProcessBuilder ProcessBuilder.redirectErrorStream​(boolean redirectErrorStream)
      设置此流程构建器的 redirectErrorStream属性。
      ProcessBuilder ProcessBuilder.redirectInput​(File file)
      将此流程构建器的标准输入源设置为文件。
      ProcessBuilder ProcessBuilder.redirectInput​(ProcessBuilder.Redirect source)
      设置此流程构建器的标准输入源。
      ProcessBuilder ProcessBuilder.redirectOutput​(File file)
      将此流程构建器的标准输出目标设置为文件。
      ProcessBuilder ProcessBuilder.redirectOutput​(ProcessBuilder.Redirect destination)
      设置此流程构建器的标准输出目标。
      Method parameters in java.lang with type arguments of type ProcessBuilder
      Modifier and Type 方法 描述
      static List<Process> ProcessBuilder.startPipeline​(List<ProcessBuilder> builders)
      Starts a Process for each ProcessBuilder, creating a pipeline of processes linked by their standard output and standard input streams.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ProcessBuilder.Redirect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ProcessBuilder.Redirect

  • Packages that use ProcessBuilder.Redirect
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ProcessBuilder.Redirect in java.lang

      Fields in java.lang declared as ProcessBuilder.Redirect
      Modifier and Type Field 描述
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.DISCARD
      表示子进程输出将被丢弃。
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.INHERIT
      表示子进程I / O源或目标将与当前进程的相同。
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.PIPE
      表示子流程I / O将通过管道连接到当前的Java进程。
      Methods in java.lang that return ProcessBuilder.Redirect
      Modifier and Type 方法 描述
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.appendTo​(File file)
      返回重定向以附加到指定的文件。
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.from​(File file)
      返回从指定文件读取的重定向。
      ProcessBuilder.Redirect ProcessBuilder.redirectError​()
      返回此流程构建器的标准错误目标。
      ProcessBuilder.Redirect ProcessBuilder.redirectInput​()
      返回此流程构建器的标准输入源。
      ProcessBuilder.Redirect ProcessBuilder.redirectOutput​()
      返回此流程构建器的标准输出目标。
      static ProcessBuilder.Redirect ProcessBuilder.Redirect.to​(File file)
      返回写入指定文件的重定向。
      Methods in java.lang with parameters of type ProcessBuilder.Redirect
      Modifier and Type 方法 描述
      ProcessBuilder ProcessBuilder.redirectError​(ProcessBuilder.Redirect destination)
      设置此流程构建器的标准错误目标。
      ProcessBuilder ProcessBuilder.redirectInput​(ProcessBuilder.Redirect source)
      设置此流程构建器的标准输入源。
      ProcessBuilder ProcessBuilder.redirectOutput​(ProcessBuilder.Redirect destination)
      Sets this process builder's standard output destination.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ProcessBuilder.Redirect.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ProcessBuilder.Redirect.Type

  • Packages that use ProcessBuilder.Redirect.Type
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ProcessBuilder.Redirect.Type in java.lang

      Methods in java.lang that return ProcessBuilder.Redirect.Type
      Modifier and Type 方法 描述
      abstract ProcessBuilder.Redirect.Type ProcessBuilder.Redirect.type​()
      返回此 Redirect的类型。
      static ProcessBuilder.Redirect.Type ProcessBuilder.Redirect.Type.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ProcessBuilder.Redirect.Type[] ProcessBuilder.Redirect.Type.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ReflectiveOperationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ReflectiveOperationException

  • Packages that use ReflectiveOperationException
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of ReflectiveOperationException in java.lang

      Subclasses of ReflectiveOperationException in java.lang
      Modifier and Type Class 描述
      class  ClassNotFoundException
      的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
      class  IllegalAccessException
      当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
      class  InstantiationException
      当应用程序试图创建使用一个类的实例抛出 newInstance方法在类 Class ，而指定的类对象不能被实例化。
      class  NoSuchFieldException
      表示该类没有指定名称的字段。
      class  NoSuchMethodException
      当无法找到特定方法时抛出。

    • Uses of ReflectiveOperationException in java.lang.reflect

      Subclasses of ReflectiveOperationException in java.lang.reflect
      Modifier and Type Class 描述
      class  InvocationTargetException
      InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Runtime (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Runtime

  • Packages that use Runtime
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of Runtime in java.lang

      Methods in java.lang that return Runtime
      Modifier and Type 方法 描述
      static Runtime Runtime.getRuntime​()
      返回与当前Java应用程序关联的运行时对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Runtime.Version (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Runtime.Version

  • Packages that use Runtime.Version
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

    • Uses of Runtime.Version in java.lang

      Methods in java.lang that return Runtime.Version
      Modifier and Type 方法 描述
      static Runtime.Version Runtime.Version.parse​(String s)
      将给定的字符串解析为有效的 version string，其中包含一个 version number，其后是预发布和构建信息。
      static Runtime.Version Runtime.version​()
      以Runtime.Version返回Java运行时环境的版本 。
      Methods in java.lang with parameters of type Runtime.Version
      Modifier and Type 方法 描述
      int Runtime.Version.compareTo​(Runtime.Version obj)
      将此版本与另一版本进行比较。
      int Runtime.Version.compareToIgnoreOptional​(Runtime.Version obj)
      将此版本与其他版本进行比较，忽略可选构建信息。

    • Uses of Runtime.Version in java.util.jar

      Methods in java.util.jar that return Runtime.Version
      Modifier and Type 方法 描述
      static Runtime.Version JarFile.baseVersion​()
      返回表示多版本jar文件的未版本化配置的版本。
      Runtime.Version JarFile.getVersion​()
      返回搜索版本化条目时使用的最大版本。
      static Runtime.Version JarFile.runtimeVersion​()
      返回表示多版本jar文件的有效运行时版本配置的版本。
      Constructors in java.util.jar with parameters of type Runtime.Version
      Constructor 描述
      JarFile​(File file, boolean verify, int mode, Runtime.Version version)
      创建新的 JarFile以在指定的模式下从指定的 File对象中读取。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.RuntimeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.RuntimeException

  • Packages that use RuntimeException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.rmi
    提供RMI包。
    java.security
    提供安全框架的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.http
    该包定义了特定于HTTP绑定的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方法。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.security.jarsigner
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能对象请求代理（ORB）。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.w3c.dom
    提供文档对象模型（DOM）的接口。
    org.w3c.dom.events
    提供DOM Level 2事件的接口。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.w3c.dom.ranges
    提供DOM Level 2范围的界面。
    org.w3c.dom.xpath
    提供DOM Level 3 XPath规范的接口。

    • Uses of RuntimeException in com.sun.jdi

      Subclasses of RuntimeException in com.sun.jdi
      Modifier and Type Class 描述
      class  ClassNotPreparedException
      抛出以指示由于指定的类尚未准备而请求的操作无法完成。
      class  InconsistentDebugInfoException
      被抛出以表明目标VM提供的调试信息有不一致之处。
      class  InternalException
      抛出，表示出现意外的内部错误。
      class  InvalidCodeIndexException
      已过时。
      不再抛出此异常
      class  InvalidLineNumberException
      已过时。
      不再抛出此异常
      class  InvalidModuleException
      抛出以表明所请求的模块在卸载模块后无效或无效。
      class  InvalidStackFrameException
      抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。
      class  NativeMethodException
      抛出表示操作无法完成，因为它对本机方法无效。
      class  ObjectCollectedException
      抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。
      class  VMCannotBeModifiedException
      抛出以表示操作无效，因为它会修改VM，VM是只读的。
      class  VMDisconnectedException
      抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。
      class  VMMismatchException
      抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。
      class  VMOutOfMemoryException
      抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。

    • Uses of RuntimeException in com.sun.jdi.request

      Subclasses of RuntimeException in com.sun.jdi.request
      Modifier and Type Class 描述
      class  DuplicateRequestException
      抛出以表示重复的事件请求。
      class  InvalidRequestStateException
      抛出以表示所请求的事件由于启用而无法修改。

    • Uses of RuntimeException in com.sun.nio.sctp

      Subclasses of RuntimeException in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  IllegalReceiveException
      尝试从通知处理程序调用SctpChannel或SctpMultiChannel的270525735774902的receive方法时抛出未经检查的异常。
      class  IllegalUnbindException
      尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。
      class  InvalidStreamException
      尝试将消息发送到无效流时抛出未检查的异常。

    • Uses of RuntimeException in java.awt

      Subclasses of RuntimeException in java.awt
      Modifier and Type Class 描述
      class  HeadlessException
      在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
      class  IllegalComponentStateException
      表示AWT组件对于请求的操作不在适当的状态。

    • Uses of RuntimeException in java.awt.color

      Subclasses of RuntimeException in java.awt.color
      Modifier and Type Class 描述
      class  CMMException
      如果本机CMM返回错误，则抛出此异常。
      class  ProfileDataException
      在访问或处理ICC_Profile对象时发生错误时抛出此异常。

    • Uses of RuntimeException in java.awt.dnd

      Subclasses of RuntimeException in java.awt.dnd
      Modifier and Type Class 描述
      class  InvalidDnDOperationException
      java.awt.dnd包中的各种方法抛出此异常。

    • Uses of RuntimeException in java.awt.geom

      Subclasses of RuntimeException in java.awt.geom
      Modifier and Type Class 描述
      class  IllegalPathStateException
      如果在相对于正在执行的特定操作处于非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段附加到GeneralPath 。

    • Uses of RuntimeException in java.awt.image

      Subclasses of RuntimeException in java.awt.image
      Modifier and Type Class 描述
      class  ImagingOpException
      所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。
      class  RasterFormatException
      如果RasterFormatException中有无效的布局信息，则会抛出RasterFormatException 。

    • Uses of RuntimeException in java.io

      Subclasses of RuntimeException in java.io
      Modifier and Type Class 描述
      class  UncheckedIOException
      包装一个IOException与未检查的例外。

    • Uses of RuntimeException in java.lang

      Subclasses of RuntimeException in java.lang
      Modifier and Type Class 描述
      class  ArithmeticException
      抛出异常算术条件时抛出。
      class  ArrayIndexOutOfBoundsException
      抛出以表示使用非法索引访问数组。
      class  ArrayStoreException
      抛出以表示尝试将错误类型的对象存储到对象数组中。
      class  ClassCastException
      抛出表示代码尝试将对象转换为不属于实例的子类。
      class  EnumConstantNotPresentException
      当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。
      class  IllegalArgumentException
      抛出表示一种方法已经通过了非法或不正确的参数。
      class  IllegalCallerException
      被抛出来表示一个方法已被不适当的调用者调用。
      class  IllegalMonitorStateException
      抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。
      class  IllegalStateException
      表示在非法或不适当的时间调用了一种方法。
      class  IllegalThreadStateException
      抛出以指示线程不处于所请求操作的适当状态。
      class  IndexOutOfBoundsException
      抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
      class  LayerInstantiationException
      创建module layer时抛出失败。
      class  NegativeArraySizeException
      抛出一个应用程序尝试创建一个负数大小的数组。
      class  NullPointerException
      当应用程序在需要对象的情况下尝试使用 null时抛出。
      class  NumberFormatException
      抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
      class  SecurityException
      由安全管理员抛出，表示安全违规。
      class  StringIndexOutOfBoundsException
      抛出 String方法来指示索引为负或大于字符串的大小。
      class  TypeNotPresentException
      当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。
      class  UnsupportedOperationException
      抛出以表示不支持请求的操作。

    • Uses of RuntimeException in java.lang.annotation

      Subclasses of RuntimeException in java.lang.annotation
      Modifier and Type Class 描述
      class  AnnotationTypeMismatchException
      抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。
      class  IncompleteAnnotationException
      抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。

    • Uses of RuntimeException in java.lang.instrument

      Subclasses of RuntimeException in java.lang.instrument
      Modifier and Type Class 描述
      class  UnmodifiableModuleException
      抛出以表示模块无法修改。

    • Uses of RuntimeException in java.lang.invoke

      Subclasses of RuntimeException in java.lang.invoke
      Modifier and Type Class 描述
      class  WrongMethodTypeException
      抛出以表示代码尝试通过错误的方法类型调用方法句柄。

    • Uses of RuntimeException in java.lang.module

      Subclasses of RuntimeException in java.lang.module
      Modifier and Type Class 描述
      class  FindException
      抛出一个ModuleFinder发生错误时发现一个模块。
      class  InvalidModuleDescriptorException
      读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。
      class  ResolutionException
      在解析一组模块或解析一组具有服务绑定的模块时抛出失败。

    • Uses of RuntimeException in java.lang.reflect

      Subclasses of RuntimeException in java.lang.reflect
      Modifier and Type Class 描述
      class  InaccessibleObjectException
      Java语言访问检查无法被抑制时抛出。
      class  MalformedParameterizedTypeException
      当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。
      class  MalformedParametersException
      当 the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。
      class  UndeclaredThrowableException
      通过方法调用代理实例时抛出的调用处理程序的 invoke方法抛出检查异常（一 Throwable不是分配给 RuntimeException或者 Error ）是不能分配给任何中声明的异常类型 throws方法的条款，在代理实例上调用并分派到调用处理程序。

    • Uses of RuntimeException in java.nio

      Subclasses of RuntimeException in java.nio
      Modifier and Type Class 描述
      class  BufferOverflowException
      相对 放置操作达到目标缓冲区限制时抛出的未检查异常。
      class  BufferUnderflowException
      当相对 get操作达到源缓冲区的限制时抛出未检查的异常。
      class  InvalidMarkException
      当未定义其标记时尝试复位缓冲区时抛出未检查的异常。
      class  ReadOnlyBufferException
      在只读缓冲区中调用内容突变方法（如 put或 compact ）时调用未检查的异常。

    • Uses of RuntimeException in java.nio.channels

      Subclasses of RuntimeException in java.nio.channels
      Modifier and Type Class 描述
      class  AcceptPendingException
      尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
      class  AlreadyBoundException
      尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
      class  AlreadyConnectedException
      尝试连接已连接的SocketChannel时 ，会引发未检查的异常。
      class  CancelledKeyException
      当试图使用不再有效的选择键时抛出未检查的异常。
      class  ClosedSelectorException
      尝试在闭合选择器上调用I / O操作时抛出未检查的异常。
      class  ConnectionPendingException
      尝试连接未阻塞连接操作的SocketChannel时，会抛出未检查的异常。
      class  IllegalBlockingModeException
      当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。
      class  IllegalChannelGroupException
      尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。
      class  IllegalSelectorException
      当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。
      class  NoConnectionPendingException
      当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
      class  NonReadableChannelException
      尝试从最初打开阅读的频道中读取时未抛出的异常。
      class  NonWritableChannelException
      尝试写入最初未打开的通道进行写入时抛出未检查的异常。
      class  NotYetBoundException
      尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
      class  NotYetConnectedException
      当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
      class  OverlappingFileLockException
      当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
      class  ReadPendingException
      尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
      class  ShutdownChannelGroupException
      当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。
      class  UnresolvedAddressException
      尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
      class  UnsupportedAddressTypeException
      尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。
      class  WritePendingException
      尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。

    • Uses of RuntimeException in java.nio.charset

      Subclasses of RuntimeException in java.nio.charset
      Modifier and Type Class 描述
      class  IllegalCharsetNameException
      当使用不是 legal charset name的字符串时抛出未检查的异常。
      class  UnsupportedCharsetException
      对于请求的字符集，当没有可用的支持时抛出未检查的异常。

    • Uses of RuntimeException in java.nio.file

      Subclasses of RuntimeException in java.nio.file
      Modifier and Type Class 描述
      class  ClosedDirectoryStreamException
      尝试在关闭的目录流上调用操作时抛出未检查的异常。
      class  ClosedFileSystemException
      尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。
      class  ClosedWatchServiceException
      尝试在关闭的手表服务上调用操作时抛出未检查的异常。
      class  DirectoryIteratorException
      如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。
      class  FileSystemAlreadyExistsException
      新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新
      class  FileSystemNotFoundException
      无法找到文件系统时抛出的运行时异常。
      class  InvalidPathException
      当路径字符串无法转换为Path时，由于路径字符串包含无效字符或路径字符串对其他文件系统特定的原因无效，因此抛出未检查的异常。
      class  ProviderMismatchException
      当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。
      class  ProviderNotFoundException
      无法找到所需类型的提供者时抛出的运行时异常。
      class  ReadOnlyFileSystemException
      尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。

    • Uses of RuntimeException in java.rmi

      Subclasses of RuntimeException in java.rmi
      Modifier and Type Class 描述
      class  RMISecurityException
      已过时。
      改用SecurityException 。 应用程式代码永远不要直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。

    • Uses of RuntimeException in java.security

      Subclasses of RuntimeException in java.security
      Modifier and Type Class 描述
      class  AccessControlException
      AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
      class  InvalidParameterException
      当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
      class  ProviderException
      提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。

    • Uses of RuntimeException in java.time

      Subclasses of RuntimeException in java.time
      Modifier and Type Class 描述
      class  DateTimeException
      用于在计算日期时间时指示问题的异常。

    • Uses of RuntimeException in java.time.format

      Subclasses of RuntimeException in java.time.format
      Modifier and Type Class 描述
      class  DateTimeParseException
      解析期间发生错误时抛出异常。

    • Uses of RuntimeException in java.time.temporal

      Subclasses of RuntimeException in java.time.temporal
      Modifier and Type Class 描述
      class  UnsupportedTemporalTypeException
      UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。

    • Uses of RuntimeException in java.time.zone

      Subclasses of RuntimeException in java.time.zone
      Modifier and Type Class 描述
      class  ZoneRulesException
      抛出指示时区配置的问题。

    • Uses of RuntimeException in java.util

      Subclasses of RuntimeException in java.util
      Modifier and Type Class 描述
      class  ConcurrentModificationException
      当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。
      class  DuplicateFormatFlagsException
      在格式说明符中提供重复标志时抛出未经检查的异常。
      class  EmptyStackException
      由 Stack类中的方法抛出，表示堆栈为空。
      class  FormatFlagsConversionMismatchException
      转换和标志不兼容时抛出未经检查的异常。
      class  FormatterClosedException
      格式化程序已关闭时抛出未检查的异常。
      class  IllegalFormatCodePointException
      当Character.isValidCodePoint(int)定义的Unicode代码无效的字符被传递到Formatter时，会抛出未经检查的异常。
      class  IllegalFormatConversionException
      当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。
      class  IllegalFormatException
      当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。
      class  IllegalFormatFlagsException
      提供非法组合标志时抛出未检查的异常。
      class  IllegalFormatPrecisionException
      当精度为 -1以外的负值时，抛出未检查的异常，转换不支持精度，否则不支持此值。
      class  IllegalFormatWidthException
      当格式宽度为 -1以外的否定值时，将抛出未检查的异常，否则不受支持。
      class  IllformedLocaleException
      通过Locale和Locale.Builder中的方法抛出，表示参数不是一个格式正确的BCP 47标签。
      class  InputMismatchException
      由 Scanner抛出，以指示所检索的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。
      class  MissingFormatArgumentException
      当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
      class  MissingFormatWidthException
      需要格式宽度时抛出未检查的异常。
      class  MissingResourceException
      表示资源丢失。
      class  NoSuchElementException
      被各种访问器方法抛出，表示被请求的元素不存在。
      class  UnknownFormatConversionException
      给出未知转换时抛出未检查的异常。
      class  UnknownFormatFlagsException
      给定未知标志时抛出未检查的异常。

    • Uses of RuntimeException in java.util.concurrent

      Subclasses of RuntimeException in java.util.concurrent
      Modifier and Type Class 描述
      class  CancellationException
      异常表示由于任务被取消，无法检索值生成任务的结果，如FutureTask 。
      class  CompletionException
      在完成结果或任务的过程中遇到错误或其他异常时抛出异常。
      class  RejectedExecutionException
      当任务不能被接受执行时，由一个Executor抛出的异常。

    • Uses of RuntimeException in java.util.regex

      Subclasses of RuntimeException in java.util.regex
      Modifier and Type Class 描述
      class  PatternSyntaxException
      抛出未经检查的异常，以指示正则表达式模式中的语法错误。

    • Uses of RuntimeException in javafx.scene.media

      Subclasses of RuntimeException in javafx.scene.media
      Modifier and Type Class 描述
      class  MediaException
      甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。

    • Uses of RuntimeException in javax.lang.model

      Subclasses of RuntimeException in javax.lang.model
      Modifier and Type Class 描述
      class  UnknownEntityException
      例外的超类，表示遇到一个未知类型的实体。

    • Uses of RuntimeException in javax.lang.model.element

      Subclasses of RuntimeException in javax.lang.model.element
      Modifier and Type Class 描述
      class  UnknownAnnotationValueException
      表示遇到未知类型的注释值。
      class  UnknownDirectiveException
      表示遇到未知类型的模块指令。
      class  UnknownElementException
      表示遇到未知类型的元素。

    • Uses of RuntimeException in javax.lang.model.type

      Subclasses of RuntimeException in javax.lang.model.type
      Modifier and Type Class 描述
      class  MirroredTypeException
      当应用程序尝试访问对应于TypeMirror的Class对象时抛出 。
      class  MirroredTypesException
      当应用程序尝试访问Class对象的每个对象TypeMirror对象时抛出 。
      class  UnknownTypeException
      表示遇到未知类型的类型。

    • Uses of RuntimeException in javax.management

      Subclasses of RuntimeException in javax.management
      Modifier and Type Class 描述
      class  JMRuntimeException
      JMX实现发出的运行时异常。
      class  RuntimeErrorException
      当 java.lang.Error发生 java.lang.Error时，应该被捕获并重新抛出为 RuntimeErrorException 。
      class  RuntimeMBeanException
      表示代理中MBean方法抛出的运行时异常。
      class  RuntimeOperationsException
      表示在对MBean执行操作时在代理中抛出的运行时异常。
      Methods in javax.management that return RuntimeException
      Modifier and Type 方法 描述
      RuntimeException RuntimeMBeanException.getTargetException​()
      返回实际抛出的RuntimeException 。
      RuntimeException RuntimeOperationsException.getTargetException​()
      返回实际抛出的RuntimeException 。
      Constructors in javax.management with parameters of type RuntimeException
      Constructor 描述
      RuntimeMBeanException​(RuntimeException e)
      创建一个 RuntimeMBeanException ，包裹实际的 java.lang.RuntimeException 。
      RuntimeMBeanException​(RuntimeException e, String message)
      创建一个 RuntimeMBeanException ，其中包含实际的 java.lang.RuntimeException详细消息。
      RuntimeOperationsException​(RuntimeException e)
      创建一个 RuntimeOperationsException ，包装实际的 java.lang.RuntimeException 。
      RuntimeOperationsException​(RuntimeException e, String message)
      创建一个 RuntimeOperationsException ，其中包含了实际的 java.lang.RuntimeException详细消息。

    • Uses of RuntimeException in javax.management.monitor

      Subclasses of RuntimeException in javax.management.monitor
      Modifier and Type Class 描述
      class  MonitorSettingException
      监视器设置在监视器运行时无效时由监视器抛出异常。

    • Uses of RuntimeException in javax.management.openmbean

      Subclasses of RuntimeException in javax.management.openmbean
      Modifier and Type Class 描述
      class  InvalidKeyException
      抛出此运行时异常以指示预期为 复合数据的项名称或 表格数据的行索引的方法参数无效。
      class  InvalidOpenTypeException
      抛出此运行时异常以指示 打开的类型的 打开数据值不是预期的。
      class  KeyAlreadyExistsException
      抛出此运行时异常以指示要添加到 表格数据实例的行的索引已被用于引用此 表格数据实例中的另一行。

    • Uses of RuntimeException in javax.print.attribute

      Subclasses of RuntimeException in javax.print.attribute
      Modifier and Type Class 描述
      class  UnmodifiableSetException
      抛出以表示所请求的操作无法执行，因为该集合是不可修改的。

    • Uses of RuntimeException in javax.swing.undo

      Subclasses of RuntimeException in javax.swing.undo
      Modifier and Type Class 描述
      class  CannotRedoException
      抛出一个UndoableEdit被告知 redo()而不能。
      class  CannotUndoException
      抛出一个UndoableEdit被告知 undo()并且不能。

    • Uses of RuntimeException in javax.xml.bind

      Subclasses of RuntimeException in javax.xml.bind
      Modifier and Type Class 描述
      class  DataBindingException
      表示JAXB操作失败的异常。
      class  TypeConstraintException
      此异常表示检测到违反动态检查的类型约束。

    • Uses of RuntimeException in javax.xml.catalog

      Subclasses of RuntimeException in javax.xml.catalog
      Modifier and Type Class 描述
      class  CatalogException
      异常类处理在处理或使用目录时可能发生的错误。

    • Uses of RuntimeException in javax.xml.crypto

      Subclasses of RuntimeException in javax.xml.crypto
      Modifier and Type Class 描述
      class  NoSuchMechanismException
      当请求特定的XML机制但在环境中不可用时抛出此异常。

    • Uses of RuntimeException in javax.xml.ws

      Subclasses of RuntimeException in javax.xml.ws
      Modifier and Type Class 描述
      class  ProtocolException
      ProtocolException类是与特定协议绑定相关的异常的基类。
      class  WebServiceException
      WebServiceException类是所有JAX-WS API运行时异常的基础异常类。

    • Uses of RuntimeException in javax.xml.ws.http

      Subclasses of RuntimeException in javax.xml.ws.http
      Modifier and Type Class 描述
      class  HTTPException
      HTTPException异常表示XML / HTTP故障。

    • Uses of RuntimeException in javax.xml.ws.soap

      Subclasses of RuntimeException in javax.xml.ws.soap
      Modifier and Type Class 描述
      class  SOAPFaultException
      SOAPFaultException异常表示SOAP 1.1或1.2故障。

    • Uses of RuntimeException in jdk.dynalink

      Subclasses of RuntimeException in jdk.dynalink
      Modifier and Type Class 描述
      class  NoSuchDynamicMethodException
      如果呼叫站点无法通过任何可用的GuardingDynamicLinker链接，则在调用时抛出。

    • Uses of RuntimeException in jdk.jshell.spi

      Subclasses of RuntimeException in jdk.jshell.spi
      Modifier and Type Class 描述
      class  SPIResolutionException
      此异常的构造和抛出嵌入在JShell核心实现中生成的代码中，以便在执行 RECOVERABLE_DEFINED用户方法时抛出此异常。

    • Uses of RuntimeException in jdk.nashorn.api.scripting

      Subclasses of RuntimeException in jdk.nashorn.api.scripting
      Modifier and Type Class 描述
      class  NashornException
      这是所有Nashorn异常的基础例外。

    • Uses of RuntimeException in jdk.nashorn.api.tree

      Subclasses of RuntimeException in jdk.nashorn.api.tree
      Modifier and Type Class 描述
      class  UnknownTreeException
      表示遇到了一种未知类型的树。

    • Uses of RuntimeException in jdk.security.jarsigner

      Subclasses of RuntimeException in jdk.security.jarsigner
      Modifier and Type Class 描述
      class  JarSignerException
      当 JarSigner.sign(java.util.zip.ZipFile, java.io.OutputStream)失败时抛出此异常。

    • Uses of RuntimeException in netscape.javascript

      Subclasses of RuntimeException in netscape.javascript
      Modifier and Type Class 描述
      class  JSException
      在JavaScript引擎中引发异常时抛出。

    • Uses of RuntimeException in org.omg.CORBA

      Subclasses of RuntimeException in org.omg.CORBA
      Modifier and Type Class 描述
      class  ACTIVITY_COMPLETED
      可以在访问Activity上下文的任何方法上引发 ACTIVITY_COMPLETED系统异常。
      class  ACTIVITY_REQUIRED
      对于需要活动上下文的任何方法，可能会引发 ACTIVITY_REQUIRED系统异常。
      class  BAD_CONTEXT
      当客户端调用操作时抛出异常，但传递的上下文不包含操作所需的上下文值。
      class  BAD_INV_ORDER
      这个异常表示调用者以错误的顺序调用了操作。
      class  BAD_OPERATION
      当对象引用表示现有对象但该对象不支持被调用的操作时抛出异常。
      class  BAD_PARAM
      传递给调用的参数超出范围或以其他方式被视为非法时引发的异常。
      class  BAD_QOS
      当对象不能支持具有与其相关联的服务质量语义的调用参数所需的服务质量时，引发 BAD_QOS异常。
      class  BAD_TYPECODE
      当ORB遇到格式错误的代码（例如， TCKind值无效的类型代码）时抛出异常。
      class  CODESET_INCOMPATIBLE
      无论客户端和服务器本机代码集之间无法进行有意义的通信，都会引发此异常。
      class  COMM_FAILURE
      在客户端发送请求后，服务器的回复已经返回到客户端之前，在进行中的通信丢失时发生异常。
      class  DATA_CONVERSION
      如果ORB无法将封送的数据的表示形式转换为其本机表示形式，反之亦然，则会引发此异常。
      class  FREE_MEM
      ORB在尝试释放动态内存时失败，例如由于堆损坏或内存段被锁定而导致异常。
      class  IMP_LIMIT
      此异常表示在ORB运行时间中超出了实施限制。
      class  INITIALIZE
      当ORB在其初始化期间遇到故障（例如无法获取网络资源或检测到配置错误）时抛出异常。
      class  INTERNAL
      此异常指示ORB中的内部故障，例如，如果ORB检测到其内部数据结构的损坏。
      class  INTF_REPOS
      当ORB无法到达接口存储库或检测到与接口存储库相关的某些其他故障时引发异常。
      class  INV_FLAG
      当一个无效标志传递给一个操作时（例如创建一个DII请求）时抛出异常。
      class  INV_IDENT
      此异常表示IDL标识符在语法上无效。
      class  INV_OBJREF
      此异常表示对象引用在内部格式错误。
      class  INV_POLICY
      由于 Policy覆盖不适用于特定调用时不能进行调用，因此抛出标准异常。
      class  INVALID_ACTIVITY
      如果事务或活动在与其挂起的环境不同的上下文中恢复，则可能会在“活动”或“事务服务”恢复方法上引发 INVALID_ACTIVITY系统异常。
      class  INVALID_TRANSACTION
      当请求携带无效的事务上下文时抛出异常。
      class  MARSHAL
      来自网络的请求或回复在结构上是无效的。
      class  NO_IMPLEMENT
      此异常表示即使已调用的操作存在（它具有IDL定义），也不存在该操作的实现。
      class  NO_MEMORY
      ORB运行时内存不足时抛出异常。
      class  NO_PERMISSION
      调用失败时引发异常，因为调用者的权限不足。
      class  NO_RESOURCES
      当ORB遇到一些一般资源限制时抛出异常。
      class  NO_RESPONSE
      如果客户端尝试检索延迟同步调用的结果，但该请求的响应尚不可用，则会引发此异常。
      class  OBJ_ADAPTER
      此异常通常表示管理不匹配，例如，服务器可能尝试以已经在使用的名称或对存储库未知的实现存储库注册自身。
      class  OBJECT_NOT_EXIST
      每当执行对被删除对象的调用时，就会引发异常。
      class  PERSIST_STORE
      此异常表示持续存储故障，例如，无法建立数据库连接或数据库损坏。
      class  REBIND
      REBIND上升时电流有效RebindPolicy，具有NO_REBIND或NO_RECONNECT的值和上一个绑定的对象引用在消息LocateReply具有状态OBJECT_FORWARD或状态为LOCATION_FORWARD一个应答消息的调用。
      class  SystemException
      所有CORBA标准异常的根类。
      class  TIMEOUT
      TIMEOUT在没有交付和已经超过指定的生存时间时被提出。
      class  TRANSACTION_MODE
      如果检测到IOR中的InvocationPolicy与所选择的调用路径（即，直接或路由调用）之间的不匹配，则客户机ORB抛出CORBA TRANSACTION_MODE异常。
      class  TRANSACTION_REQUIRED
      异常表示请求携带一个空事务上下文，但需要一个活动事务。
      class  TRANSACTION_ROLLEDBACK
      与请求相关联的事务已经回滚或标记回滚时抛出异常。
      class  TRANSACTION_UNAVAILABLE
      由于ORB与事务服务的连接异常终止，因此ORB无法处理事务服务上下文时抛出CORBA TRANSACTION_UNAVAILABLE异常。
      class  TRANSIENT
      当ORB尝试到达对象并失败时抛出异常。
      class  UNKNOWN
      如果操作实现抛出非CORBA异常（例如特定于实现的编程语言的异常），或者操作引发不在操作的引用表达式中出现的用户异常，则会引发此异常。

    • Uses of RuntimeException in org.omg.CORBA.portable

      Subclasses of RuntimeException in org.omg.CORBA.portable
      Modifier and Type Class 描述
      class  IndirectionException
      间接异常是一个Java特定的系统异常。
      class  UnknownException
      org.omg.CORBA.portable.UnknownException用于报告关系和ORB之间以及ORB和存根之间的未知异常。

    • Uses of RuntimeException in org.w3c.dom

      Subclasses of RuntimeException in org.w3c.dom
      Modifier and Type Class 描述
      class  DOMException
      DOM操作只会在“异常”情况下引发异常，即当操作无法执行时（出于逻辑原因，因为数据丢失，或者由于实现变得不稳定））。

    • Uses of RuntimeException in org.w3c.dom.events

      Subclasses of RuntimeException in org.w3c.dom.events
      Modifier and Type Class 描述
      class  EventException
      事件操作可能会抛出方法描述中指定的 EventException 。

    • Uses of RuntimeException in org.w3c.dom.ls

      Subclasses of RuntimeException in org.w3c.dom.ls
      Modifier and Type Class 描述
      class  LSException
      如果处理停止，解析器或写入操作可能会抛出 LSException 。

    • Uses of RuntimeException in org.w3c.dom.ranges

      Subclasses of RuntimeException in org.w3c.dom.ranges
      Modifier and Type Class 描述
      class  RangeException
      范围操作可能会抛出其方法说明中指定的 RangeException 。

    • Uses of RuntimeException in org.w3c.dom.xpath

      Subclasses of RuntimeException in org.w3c.dom.xpath
      Modifier and Type Class 描述
      class  XPathException
      为这些XPath接口特定的异常创建了一个新的异常。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.RuntimePermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.RuntimePermission

No usage of java.lang.RuntimePermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.SafeVarargs (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.SafeVarargs

  • Packages that use SafeVarargs
    软件包 描述
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of SafeVarargs in java.util

      Methods in java.util with annotations of type SafeVarargs
      Modifier and Type 方法 描述
      static <T> boolean Collections.addAll​(Collection<? super T> c, T... elements)
      将所有指定的元素添加到指定的集合。
      static <T> List<T> Arrays.asList​(T... a)
      返回由指定数组支持的固定大小的列表。
      static <E extends Enum<E>>
      EnumSet<E>             		EnumSet.of​(E first, E... rest)
      创建一个最初包含指定元素的枚举集。
      static <E> List<E> List.of​(E... elements)
      返回包含任意数量元素的不可变列表。
      static <E> Set<E> Set.of​(E... elements)
      返回一个包含任意数量元素的不可变集合。
      static <K,V> Map<K,V> Map.ofEntries​(Map.Entry<? extends K,? extends V>... entries)
      返回包含从给定条目提取的键和值的不可变地图。

    • Uses of SafeVarargs in java.util.stream

      Methods in java.util.stream with annotations of type SafeVarargs
      Modifier and Type 方法 描述
      static <T> Stream<T> Stream.of​(T... values)
      返回其元素是指定值的顺序排序流。

    • Uses of SafeVarargs in javafx.scene.control.cell

      Methods in javafx.scene.control.cell with annotations of type SafeVarargs
      Modifier and Type 方法 描述
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ChoiceBoxListCell.forListView​(T... items)
      创建一个ChoiceBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <T> Callback<ListView<T>,ListCell<T>> ComboBoxListCell.forListView​(T... items)
      创建ComboBox单元格工厂，用于ListView控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ChoiceBoxTableCell.forTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂，用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TableColumn<S,T>,TableCell<S,T>> ComboBoxTableCell.forTableColumn​(T... items)
      创建一个ComboBox单元格工厂用于TableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ChoiceBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建一个ChoiceBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <S,T> Callback<TreeTableColumn<S,T>,TreeTableCell<S,T>> ComboBoxTreeTableCell.forTreeTableColumn​(T... items)
      创建ComboBox单元格工厂，用于TreeTableColumn控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建一个ChoiceBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ChoiceBoxTreeCell.forTreeView​(T... items)
      创建一个ChoiceBox单元格工厂用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(StringConverter<T> converter, T... items)
      创建ComboBox单元格工厂，用于TreeView控件。
      static <T> Callback<TreeView<T>,TreeCell<T>> ComboBoxTreeCell.forTreeView​(T... items)
      创建ComboBox单元格工厂，用于TreeView控件。
      Constructors in javafx.scene.control.cell with annotations of type SafeVarargs
      Constructor 描述
      ChoiceBoxListCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxListCell​(T... items)
      创建默认的ChoiceBoxListCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTableCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTableCell实例，给定的项目用于在显示ChoiceBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTableCell​(T... items)
      创建一个默认的ChoiceBoxTableCell实例，给定的项目用于填充ChoiceBox 。
      ChoiceBoxTreeCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTreeCell实例，给定的项目用于填充ChoiceBox ，并且StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeCell​(T... items)
      创建默认的ChoiceBoxTreeCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ChoiceBoxTreeTableCell​(StringConverter<T> converter, T... items)
      创建一个ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ChoiceBoxTreeTableCell​(T... items)
      创建默认的ChoiceBoxTreeTableCell实例，给定的项目用于在显示ChoiceBox时填充ChoiceBox 。
      ComboBoxListCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxListCell实例，给定的项目用于在显示ComboBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxListCell​(T... items)
      创建默认的ComboBoxListCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTableCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTableCell实例，给定的项目用于在显示ComboBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTableCell​(T... items)
      创建默认的ComboBoxTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTreeCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时显示，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeCell​(T... items)
      创建默认的ComboBoxTreeCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。
      ComboBoxTreeTableCell​(StringConverter<T> converter, T... items)
      创建一个ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox ，而StringConverter用于将项目转换为用户可读的形式。
      ComboBoxTreeTableCell​(T... items)
      创建默认的ComboBoxTreeTableCell实例，给定的项目用于在显示ComboBox时填充ComboBox 。

    • Uses of SafeVarargs in javax.swing

      Methods in javax.swing with annotations of type SafeVarargs
      Modifier and Type 方法 描述
      protected void SwingWorker.publish​(V... chunks)
      发送数据块到 SwingWorker.process(java.util.List<V>)方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.SecurityException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.SecurityException

  • Packages that use SecurityException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.rmi
    提供RMI包。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

    • Uses of SecurityException in java.awt

      Methods in java.awt that throw SecurityException
      Modifier and Type 方法 描述
      void KeyboardFocusManager.clearGlobalFocusOwner​()
      在Java和本机级别清除全局焦点所有者。
      protected Window KeyboardFocusManager.getGlobalActiveWindow​()
      返回活动窗口，即使调用线程与活动窗口处于不同的上下文中。
      protected Container KeyboardFocusManager.getGlobalCurrentFocusCycleRoot​()
      返回当前焦点循环根，即使调用线程与当前焦点循环根不同。
      protected Window KeyboardFocusManager.getGlobalFocusedWindow​()
      返回聚焦窗口，即使调用线程与聚焦窗口处于不同的上下文中。
      protected Component KeyboardFocusManager.getGlobalFocusOwner​()
      即使调用线程与焦点所有者的上下文不同，返回焦点所有者。
      protected Component KeyboardFocusManager.getGlobalPermanentFocusOwner​()
      返回永久焦点所有者，即使调用线程与永久焦点所有者处于不同的上下文中。
      void Window.setAlwaysOnTop​(boolean alwaysOnTop)
      设置此窗口是否应始终高于其他窗口。
      static void KeyboardFocusManager.setCurrentKeyboardFocusManager​(KeyboardFocusManager newManager)
      为调用线程的上下文设置当前的KeyboardFocusManager实例。
      protected void KeyboardFocusManager.setGlobalActiveWindow​(Window activeWindow)
      设置活动窗口。
      void KeyboardFocusManager.setGlobalCurrentFocusCycleRoot​(Container newFocusCycleRoot)
      设置当前焦点循环根。
      protected void KeyboardFocusManager.setGlobalFocusedWindow​(Window focusedWindow)
      设置聚焦窗口。
      protected void KeyboardFocusManager.setGlobalFocusOwner​(Component focusOwner)
      设置焦点所有者。
      protected void KeyboardFocusManager.setGlobalPermanentFocusOwner​(Component permanentFocusOwner)
      设置永久焦点所有者。

    • Uses of SecurityException in java.beans

      Methods in java.beans that throw SecurityException
      Modifier and Type 方法 描述
      static void Beans.setDesignTime​(boolean isDesignTime)
      用于指示我们是否在应用程序构建器环境中运行。
      static void Beans.setGuiAvailable​(boolean isGuiAvailable)
      用于指示我们是否在可以进行GUI交互的环境中运行。

    • Uses of SecurityException in java.io

      Methods in java.io that throw SecurityException
      Modifier and Type 方法 描述
      protected boolean ObjectOutputStream.enableReplaceObject​(boolean enable)
      启用流来替代写入流的对象。
      protected boolean ObjectInputStream.enableResolveObject​(boolean enable)
      启用流来替换从流读取的对象。
      Constructors in java.io that throw SecurityException
      Constructor 描述
      ObjectInputStream​()
      为完全重新实现ObjectInputStream的子类提供一种方法，不必分配刚刚被ObjectInputStream实现使用的私有数据。
      ObjectOutputStream​()
      为完全重新实现ObjectOutputStream的子类提供一种方法，不必分配刚刚被ObjectOutputStream实现使用的私有数据。

    • Uses of SecurityException in java.lang

      Methods in java.lang that throw SecurityException
      Modifier and Type 方法 描述
      Constructor<T> Class.getConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由该 Class对象表示的类的指定公共构造函数。
      Constructor<?>[] Class.getConstructors​()
      返回一个包含 Constructor对象的数组， Constructor对象反映了由该 Class对象表示的类的所有公共构造函数。
      Class<?>[] Class.getDeclaredClasses​()
      返回一个 Class对象的数组，反映了所有被声明为由 Class对象表示的类的成员的类和接口。
      Constructor<T> Class.getDeclaredConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由该 Class对象表示的类或接口的指定构造函数。
      Constructor<?>[] Class.getDeclaredConstructors​()
      返回一个 Constructor对象的数组，反映由该 Class对象表示的类声明的所有构造函数。
      Field Class.getDeclaredField​(String name)
      返回一个 Field对象，它反映此表示的类或接口的指定已声明字段 Class对象。
      Field[] Class.getDeclaredFields​()
      返回一个 Field对象的数组，反映了由该 Class对象表示的类或接口声明的所有字段。
      方法 Class.getDeclaredMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，该对象反映由此 Class对象表示的类或接口的指定声明方法。
      方法[] Class.getDeclaredMethods​()
      返回一个包含 方法对象的数组， 方法对象反映由 Class对象表示的类或接口的所有声明方法，包括public，protected，default（package）访问和私有方法，但不包括继承方法。
      Class<?> Class.getDeclaringClass​()
      如果由此 Class对象表示的类或接口是另一个类的成员，则返回表示其声明的类的 Class对象。
      Class<?> Class.getEnclosingClass​()
      返回底层类的即时封闭类。
      Constructor<?> Class.getEnclosingConstructor​()
      如果此Class对象表示构造函数中的本地或匿名类，则返回表示基础类的立即封闭构造函数的Constructor对象。
      方法 Class.getEnclosingMethod​()
      如果此Class对象表示方法中的本地或匿名类，则返回表示基础类的即时封闭方法的方法对象。
      Field Class.getField​(String name)
      返回一个 Field对象，它反映此表示的类或接口的指定公共成员字段 Class对象。
      Field[] Class.getFields​()
      返回一个包含 Field对象的数组， Field对象反映由该 Class对象表示的类或接口的所有可访问的公共字段。
      方法 Class.getMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，该对象反映由该 Class对象表示的类或接口的指定公共成员方法。
      方法[] Class.getMethods​()
      返回一个包含 方法对象的数组， 方法对象反映由该 Class对象表示的类或接口的所有公共方法，包括由类或接口声明的对象以及从超类和超级接口继承的类。

    • Uses of SecurityException in java.rmi

      Subclasses of SecurityException in java.rmi
      Modifier and Type Class 描述
      class  RMISecurityException
      已过时。
      改用SecurityException 。 应用代码永远不应该直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。

    • Uses of SecurityException in java.rmi.server

      Methods in java.rmi.server that throw SecurityException
      Modifier and Type 方法 描述
      static ClassLoader RMIClassLoader.getClassLoader​(String codebase)
      返回从给定的代码库URL路径加载类的类加载器。

    • Uses of SecurityException in java.security

      Subclasses of SecurityException in java.security
      Modifier and Type Class 描述
      class  AccessControlException
      AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
      Methods in java.security that throw SecurityException
      Modifier and Type 方法 描述
      void Guard.checkGuard​(Object object)
      确定是否允许访问被保护对象 object 。
      void Permission.checkGuard​(Object object)
      实施保护接口以获得许可。
      Object GuardedObject.getObject​()
      检索被保护的对象，或者如果对守卫对象的访问被守卫拒绝，则抛出异常。

    • Uses of SecurityException in java.util.logging

      Methods in java.util.logging that throw SecurityException
      Modifier and Type 方法 描述
      void Logger.addHandler​(Handler handler)
      添加日志处理程序以接收日志消息。
      void LogManager.checkAccess​()
      检查当前上下文是否受信任以修改日志记录配置。
      void FileHandler.close​()
      关闭所有文件。
      abstract void Handler.close​()
      关闭 Handler并释放所有相关资源。
      void MemoryHandler.close​()
      关闭 Handler并释放所有相关资源。
      void SocketHandler.close​()
      关闭此输出流。
      void StreamHandler.close​()
      关闭当前的输出流。
      void LogManager.readConfiguration​()
      读取并初始化日志记录配置。
      void LogManager.readConfiguration​(InputStream ins)
      从给定的输入流读取和初始化日志记录配置。
      void Logger.removeHandler​(Handler handler)
      删除日志处理程序。
      void LogManager.reset​()
      重置日志配置。
      void Handler.setEncoding​(String encoding)
      设置 Handler使用的字符编码。
      void StreamHandler.setEncoding​(String encoding)
      设置（或更改） Handler使用的字符编码。
      void Handler.setFilter​(Filter newFilter)
      设置 Filter以控制此 Handler输出。
      void Logger.setFilter​(Filter newFilter)
      设置一个过滤器来控制此记录器的输出。
      void Handler.setFormatter​(Formatter newFormatter)
      设置一个 Formatter 。
      void Handler.setLevel​(Level newLevel)
      设置日志级别，指定 Handler将记录哪些消息级别。
      void Logger.setLevel​(Level newLevel)
      设置日志级别，指定该记录器将记录哪些消息级别。
      protected void StreamHandler.setOutputStream​(OutputStream out)
      更改输出流。
      void MemoryHandler.setPushLevel​(Level newLevel)
      设置 pushLevel 。
      Constructors in java.util.logging that throw SecurityException
      Constructor 描述
      FileHandler​()
      构造默认值 FileHandler 。
      FileHandler​(String pattern)
      初始化 FileHandler以写入给定的文件名。
      FileHandler​(String pattern, boolean append)
      初始化一个 FileHandler写入给定的文件名，可选附加。
      FileHandler​(String pattern, int limit, int count)
      初始化 FileHandler以写入一组文件。
      FileHandler​(String pattern, int limit, int count, boolean append)
      初始化一个 FileHandler写入一组可选附加的文件。

    • Uses of SecurityException in javax.swing

      Methods in javax.swing that throw SecurityException
      Modifier and Type 方法 描述
      static void FocusManager.setCurrentManager​(FocusManager aFocusManager)
      为调用线程的上下文设置当前的 KeyboardFocusManager实例。
      static void UIManager.setInstalledLookAndFeels​(UIManager.LookAndFeelInfo[] infos)
      Sets the set of available look and feels.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.SecurityManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.SecurityManager

  • Packages that use SecurityManager
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.rmi
    提供RMI包。

    • Uses of SecurityManager in java.lang

      Methods in java.lang that return SecurityManager
      Modifier and Type 方法 描述
      static SecurityManager System.getSecurityManager​()
      获取系统安全界面。
      Methods in java.lang with parameters of type SecurityManager
      Modifier and Type 方法 描述
      static void System.setSecurityManager​(SecurityManager s)
      设置系统安全性。

    • Uses of SecurityManager in java.rmi

      Subclasses of SecurityManager in java.rmi
      Modifier and Type Class 描述
      class  RMISecurityManager
      已过时。
      改用SecurityManager 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Short (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Short

  • Packages that use Short
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。

    • Uses of Short in java.lang

      Fields in java.lang with type parameters of type Short
      Modifier and Type Field 描述
      static Class<Short> Short.TYPE
      代表原始类型 short的 Class实例。
      Methods in java.lang that return Short
      Modifier and Type 方法 描述
      static Short Short.decode​(String nm)
      将 String解码成 Short 。
      static Short Short.valueOf​(short s)
      返回表示指定的 short值的 Short实例。
      static Short Short.valueOf​(String s)
      返回一个 Short对象，该对象保存由指定的 String给出的值。
      static Short Short.valueOf​(String s, int radix)
      返回一个 Short对象，该对象保存从指定的 String提取的值，当用第二个参数给出的基数进行解析时。
      Methods in java.lang with parameters of type Short
      Modifier and Type 方法 描述
      int Short.compareTo​(Short anotherShort)
      以数字形式比较两个 Short对象。

    • Uses of Short in javafx.util.converter

      Methods in javafx.util.converter that return Short
      Modifier and Type 方法 描述
      Short ShortStringConverter.fromString​(String text)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type Short
      Modifier and Type 方法 描述
      String ShortStringConverter.toString​(Short value)
      将提供的对象转换为其字符串形式。

    • Uses of Short in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Short
      Modifier and Type Field 描述
      static SimpleType<Short> SimpleType.SHORT
      描述Java类名称为 java.lang.Short值的 SimpleType实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StackOverflowError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StackOverflowError

No usage of java.lang.StackOverflowError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StackTraceElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StackTraceElement

  • Packages that use StackTraceElement
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of StackTraceElement in java.lang

      Methods in java.lang that return StackTraceElement
      Modifier and Type 方法 描述
      StackTraceElement[] Thread.getStackTrace​()
      返回表示此线程的堆栈转储的堆栈跟踪元素数组。
      StackTraceElement[] Throwable.getStackTrace​()
      提供对 Throwable.printStackTrace()打印的堆栈跟踪信息的编程访问。
      StackTraceElement StackWalker.StackFrame.toStackTraceElement​()
      获取此堆栈帧的 StackTraceElement 。
      Methods in java.lang with parameters of type StackTraceElement
      Modifier and Type 方法 描述
      void Throwable.setStackTrace​(StackTraceElement[] stackTrace)
      设置将被返回的堆栈微量元素 Throwable.getStackTrace()和由印刷 Throwable.printStackTrace()和相关方法。

    • Uses of StackTraceElement in java.lang.management

      Methods in java.lang.management that return StackTraceElement
      Modifier and Type 方法 描述
      StackTraceElement MonitorInfo.getLockedStackFrame​()
      返回锁定对象监视器的堆栈帧。
      StackTraceElement[] ThreadInfo.getStackTrace​()
      返回与此 ThreadInfo相关联的线程的堆栈跟踪。
      Constructors in java.lang.management with parameters of type StackTraceElement
      Constructor 描述
      MonitorInfo​(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)
      构造一个 MonitorInfo对象。

    • Uses of StackTraceElement in jdk.dynalink

      Methods in jdk.dynalink that return StackTraceElement
      Modifier and Type 方法 描述
      static StackTraceElement DynamicLinker.getLinkedCallSiteLocation​()
      返回描述当前线程当前正在链接的 invokedynamic调用站点的堆栈跟踪元素。

    • Uses of StackTraceElement in jdk.jshell.spi

      Constructors in jdk.jshell.spi with parameters of type StackTraceElement
      Constructor 描述
      ResolutionException​(int id, StackTraceElement[] stackElements)
      构造一个异常，指示已遇到具有未解析引用的 DeclarationSnippet 。
      UserException​(String message, String causeExceptionClass, StackTraceElement[] stackElements)

    • Uses of StackTraceElement in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that return StackTraceElement
      Modifier and Type 方法 描述
      static StackTraceElement[] NashornException.getScriptFrames​(Throwable exception)
      从给定的异常对象返回数组JavaScript堆栈帧。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StackWalker (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StackWalker

  • Packages that use StackWalker
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of StackWalker in java.lang

      Methods in java.lang that return StackWalker
      Modifier and Type 方法 描述
      static StackWalker StackWalker.getInstance​()
      返回一个 StackWalker实例。
      static StackWalker StackWalker.getInstance​(StackWalker.Option option)
      返回一个具有给定选项的 StackWalker实例，指定可以访问的堆栈帧信息。
      static StackWalker StackWalker.getInstance​(Set<StackWalker.Option> options)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。
      static StackWalker StackWalker.getInstance​(Set<StackWalker.Option> options, int estimateDepth)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StackWalker.Option (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StackWalker.Option

  • Packages that use StackWalker.Option
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of StackWalker.Option in java.lang

      Methods in java.lang that return StackWalker.Option
      Modifier and Type 方法 描述
      static StackWalker.Option StackWalker.Option.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StackWalker.Option[] StackWalker.Option.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.lang with parameters of type StackWalker.Option
      Modifier and Type 方法 描述
      static StackWalker StackWalker.getInstance​(StackWalker.Option option)
      返回一个具有给定选项的 StackWalker实例，指定可以访问的堆栈帧信息。
      Method parameters in java.lang with type arguments of type StackWalker.Option
      Modifier and Type 方法 描述
      static StackWalker StackWalker.getInstance​(Set<StackWalker.Option> options)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。
      static StackWalker StackWalker.getInstance​(Set<StackWalker.Option> options, int estimateDepth)
      返回一个 StackWalker实例，给定的 options指定可以访问的堆栈帧信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StrictMath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StrictMath

No usage of java.lang.StrictMath
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.String (Java SE 9 & JDK 9 )

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev

Next

框架

无框架

所有类

SEARCH:

Uses of Class
java.lang.String

Packages that use String

软件包

描述

com.sun.jarsigner

该包包含用于定义 jarsigner工具使用的签名机制的接口和类。

com.sun.java.accessibility.util

提供组成Java辅助功能实用程序的接口和类的集合。

com.sun.javadoc

注意：此包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。

com.sun.jdi

这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。

com.sun.jdi.connect

该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。

com.sun.jdi.connect.spi

该包包含用于开发新的TransportService实现的接口和类。

com.sun.jdi.event

该包定义了JDI事件和事件处理。

com.sun.jdi.request

该包用于请求在指定条件下发送JDI事件。

com.sun.management

该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。

com.sun.net.httpserver

提供一个简单的高级Http服务器API，可用于构建嵌入式HTTP服务器。

com.sun.nio.sctp

用于流控制传输协议的Java API。

com.sun.security.auth

提供Principal的实现。

com.sun.security.auth.login

提供Configuration的实现。

com.sun.security.auth.module

提供LoginModule的实现。

com.sun.security.jgss

com.sun.source.doctree

提供用于将文档注释表示为抽象语法树（AST）的接口。

com.sun.source.tree

提供用于将源代码表示为抽象语法树（AST）的接口。

com.sun.source.util

为抽象语法树（AST）的操作提供实用程序。

com.sun.tools.attach

提供API附加到Java的虚拟机。

com.sun.tools.attach.spi

只有定义新附加提供商的开发者才需要直接使用这个包。

com.sun.tools.doclets

注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

com.sun.tools.doclets.standard

注意：此包中的声明已被新包 jdk.javadoc.doclet中的声明所取代。

com.sun.tools.javac

该包提供了 javac工具的传统入口点。

com.sun.tools.javadoc

此软件包及其内容已被弃用，可能会在将来的版本中删除。

com.sun.tools.jconsole

此程序包包含JConsole API。

java.applet

提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。

java.awt

包含用于创建用户界面和绘制图形和图像的所有类。

java.awt.color

提供颜色空间的类。

java.awt.datatransfer

提供用于在应用程序之间和之间传输数据的接口和类。

java.awt.desktop

提供与各种桌面功能交互的接口和类。

java.awt.dnd

拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。

java.awt.event

提供用于处理AWT组件触发的不同类型事件的接口和类。

java.awt.font

提供与字体相关的类和界面。

java.awt.geom

提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。

java.awt.im.spi

提供可以开发可以与任何Java运行时环境一起使用的输入法的接口。

java.awt.image

提供创建和修改图像的类。

java.awt.image.renderable

提供用于生成与渲染无关的图像的类和接口。

java.awt.print

提供通用打印API的类和接口。

java.beans

包含与开发 bean相关的类 - 基于JavaBeans架构的组件。

java.beans.beancontext

提供与bean上下文相关的类和接口。

java.io

通过数据流，序列化和文件系统提供系统输入和输出。

java.lang

提供对Java编程语言设计至关重要的类。

java.lang.annotation

为Java编程语言注释工具提供库支持。

java.lang.instrument

提供允许Java编程语言代理仪器在JVM上运行程序的服务。

java.lang.invoke

java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

java.lang.management

提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

java.lang.module

通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

java.lang.reflect

提供用于获取关于类和对象的反射信息的类和接口。

java.math

提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。

java.net

提供实现网络应用程序的类。

java.nio

定义缓冲区，它们是数据容器，并提供其他NIO包的概述。

java.nio.channels

定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。

java.nio.charset

定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。

java.nio.charset.spi

服务提供商类为 java.nio.charset包。

java.nio.file

定义Java虚拟机访问文件，文件属性和文件系统的接口和类。

java.nio.file.attribute

提供访问文件和文件系统属性的接口和类。

java.nio.file.spi

服务提供商类为 java.nio.file包。

java.rmi

提供RMI包。

java.rmi.activation

提供对RMI对象激活的支持。

java.rmi.dgc

提供RMI分布式垃圾收集（DGC）的类和接口。

java.rmi.registry

为RMI注册表提供一个类和两个接口。

java.rmi.server

提供用于支持RMI服务器端的类和接口。

java.security

提供安全框架的类和接口。

java.security.acl

此包中的类和接口已被弃用。

java.security.cert

提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。

java.security.spec

提供关键规范和算法参数规范的类和接口。

java.sql

提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。

java.text

提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

java.time

日期，时间，瞬间和持续时间的主要API。

java.time.chrono

除默认ISO之外的日历系统的通用API。

java.time.format

提供打印和解析日期和时间的类。

java.time.temporal

使用字段和单位访问日期和时间，以及日期时间调整器。

java.time.zone

支持时区及其规则。

java.util

包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

java.util.concurrent

实用程序类通常用于并发编程。

java.util.concurrent.atomic

一个小型工具包，支持单个变量上的无锁线程安全编程。

java.util.concurrent.locks

接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。

java.util.jar

提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。

java.util.logging

提供Java¢2平台核心日志记录工具的类和接口。

java.util.prefs

该软件包允许应用程序存储和检索用户和系统首选项和配置数据。

java.util.regex

匹配字符序列与正则表达式指定的模式的类。

java.util.spi

java.util包中类的服务提供者类。

java.util.stream

支持元素流功能性操作的类，例如集合上的map-reduce转换。

java.util.zip

提供读写标准ZIP和GZIP文件格式的类。

javafx.animation

提供一组类，便于使用基于过渡的动画。

javafx.application

提供应用程序生命周期类。

javafx.beans.binding

提供在Binding上创建和操作的类，用于计算取决于一个或多个来源的值。

javafx.beans.property

程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。

javafx.beans.property.adapter

提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。

javafx.concurrent

提供javafx.task的一组类。

javafx.css

提供API，通过CSS使属性变得风格，并支持伪类状态。

javafx.css.converter

提供各种转换CSS解析值的StyleConverter类。

javafx.event

为FX事件，交付和处理提供基本框架。

javafx.fxml

包含用于从标记加载对象层次结构的类。

javafx.geometry

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

javafx.print

提供JavaFX Printing API的公共类。

javafx.scene

为JavaFX Scene Graph API提供核心的基类集。

javafx.scene.canvas

为canvas提供一组类，即渲染API的立即模式样式。

javafx.scene.chart

JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。

javafx.scene.control

JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。

javafx.scene.control.cell

所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。

javafx.scene.control.skin

javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置

javafx.scene.effect

提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。

javafx.scene.image

提供加载和显示图像的一组类。

javafx.scene.input

提供一组用于鼠标和键盘输入事件处理的类。

javafx.scene.layout

提供类来支持用户界面布局。

javafx.scene.media

提供用于将音频和视频集成到Java FX应用程序中的一组类。

javafx.scene.paint

提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。

javafx.scene.shape

提供一组2D类，用于定义和执行与二维几何相关的对象的操作。

javafx.scene.text

为字体和可渲染的文本节点提供一组类。

javafx.scene.transform

提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。

javafx.scene.web

该软件包提供了加载和显示Web内容的方法。

javafx.stage

提供JavaFX内容的顶级容器类。

javafx.util

包含各种实用程序和助手类。

javafx.util.converter

此包用于JavaFX的标准字符串转换器。

javax.accessibility

定义用户界面组件与提供对这些组件的访问的辅助技术之间的合同。

javax.activation

javax.activity

包含ORB机械在解组时抛出的活动服务相关异常。

javax.annotation

javax.annotation.processing

用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。

javax.crypto

提供加密操作的类和接口。

javax.crypto.spec

提供关键规范和算法参数规范的类和接口。

javax.imageio

Java Image I / O API的主要包。

javax.imageio.event

一组Java Image I / O API，用于在图像读取和写入期间同步通知事件。

javax.imageio.metadata

处理读写元数据的Java Image I / O API的一个包。

javax.imageio.plugins.jpeg

支持内置JPEG插件的类。

javax.imageio.plugins.tiff

内置TIFF插件使用的公共类。

javax.imageio.spi

包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。

javax.imageio.stream

Java Image I / O API的一个封装，处理来自文件和流的低级I / O。

javax.jnlp

JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。

javax.jws

javax.jws.soap

javax.lang.model

用于建模Java编程语言的软件包的类和层次结构。

javax.lang.model.element

用于建模Java编程语言元素的接口。

javax.lang.model.type

用于建模Java编程语言类型的接口。

javax.lang.model.util

协助处理 program elements及 types的公用事业 。

javax.management

提供Java管理扩展的核心类。

javax.management.loading

提供实现高级动态加载的类。

javax.management.modelmbean

提供ModelMBean类的定义。

javax.management.monitor

提供监视器类的定义。

javax.management.openmbean

提供打开的数据类型和Open MBean描述符类。

javax.management.relation

提供关系服务的定义。

javax.management.remote

用于远程访问JMX MBean服务器的接口。

javax.management.remote.rmi

RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。

javax.management.timer

提供定时器MBean的定义。

javax.naming

提供用于访问命名服务的类和接口。

javax.naming.directory

扩展 javax.naming包以提供访问目录服务的功能。

javax.naming.event

访问命名和目录服务时，提供对事件通知的支持。

javax.naming.ldap

提供对LDAPv3扩展操作和控件的支持。

javax.naming.spi

提供通过 javax.naming和相关软件包动态插入支持访问命名和目录服务的 javax.naming 。

javax.net

提供网络应用程序的类。

javax.net.ssl

为安全套接字包提供类。

javax.print

提供Java®打印服务API的主要类和接口。

javax.print.attribute

提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。

javax.print.attribute.standard

包javax.print.attribute.standard包含特定打印属性的类。

javax.print.event

程序包javax.print.event包含事件类和侦听器接口。

javax.rmi.CORBA

包含RMI-IIOP的可移植API。

javax.rmi.ssl

通过安全套接字层（SSL）或传输层安全（TLS）协议提供RMIClientSocketFactory和RMIServerSocketFactory的实现。

javax.script

脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。

javax.security.auth

此软件包提供了认证和授权的框架。

javax.security.auth.callback

该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。

javax.security.auth.kerberos

此包包含与Kerberos网络身份验证协议相关的实用程序类。

javax.security.auth.login

该包提供了一个可插拔的认证框架。

javax.security.auth.spi

该包提供了用于实现可插拔认证模块的接口。

javax.security.auth.x500

该包包含用于在 主题中存储X500 Principal和X500 Private Credentials的类。

javax.security.cert

提供公钥证书类。

javax.security.sasl

包含用于支持SASL的类和接口。

javax.smartcardio

Java™智能卡I / O API

javax.sound.midi

提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。

javax.sound.sampled

提供用于捕获，处理和播放采样音频数据的接口和类。

javax.sql

通过Java编程语言为服务器端数据源访问和处理提供API。

javax.sql.rowset

JDBC RowSet实现的标准接口和基类。

javax.sql.rowset.serial

提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。

javax.sql.rowset.spi

第三方供应商在实施同步提供程序时必须使用的标准类和接口。

javax.swing

提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。

javax.swing.border

提供用于绘制Swing组件周围特殊边框的类和接口。

javax.swing.colorchooser

包含 JColorChooser组件使用的类和接口。

javax.swing.event

提供Swing组件触发的事件。

javax.swing.filechooser

包含 JFileChooser组件使用的类和接口。

javax.swing.plaf

提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。

javax.swing.plaf.basic

提供根据“基本”外观构建的用户界面对象。

javax.swing.plaf.metal

提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。

javax.swing.plaf.multi

提供组合两种或多种外观和感觉的用户界面对象。

javax.swing.plaf.nimbus

提供根据跨平台Nimbus外观构建的用户界面对象。

javax.swing.plaf.synth

合成是一种可以让所有绘画委托的外观和感觉。

javax.swing.table

提供处理 javax.swing.JTable类和接口。

javax.swing.text

提供处理可编辑和不可编辑文本组件的类和接口。

javax.swing.text.html

提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。

javax.swing.text.html.parser

提供默认的HTML解析器以及支持类。

javax.swing.text.rtf

提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。

javax.swing.tree

提供处理 javax.swing.JTree类和接口。

javax.swing.undo

允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。

javax.tools

为可以从程序调用的工具提供接口，例如编译器。

javax.transaction

包含ORB机械在解组期间抛出的三个异常。

javax.transaction.xa

提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。

javax.xml

定义XML处理的常量。

javax.xml.bind

为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。

javax.xml.bind.annotation

定义用于将Java程序元素定制到XML模式映射的注释。

javax.xml.bind.annotation.adapters

XmlAdapter及其指定的子类允许任意Java类与JAXB一起使用。

javax.xml.bind.attachment

该包由基于MIME的包处理器实现，可以在基于MIME的包格式中解释和创建优化的二进制数据。

javax.xml.bind.helpers

仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。

javax.xml.catalog

提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。

javax.xml.crypto

XML加密的通用类。

javax.xml.crypto.dom

DOM专用类为 javax.xml.crypto包。

javax.xml.crypto.dsig

用于生成和验证XML数字签名的类。

javax.xml.crypto.dsig.keyinfo

用于解析和处理元素和结构的类别KeyInfo 。

javax.xml.crypto.dsig.spec

XML数字签名的参数类。

javax.xml.datatype

定义XML / Java类型映射。

javax.xml.namespace

定义XML命名空间处理。

javax.xml.parsers

提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。

javax.xml.soap

提供用于创建和构建SOAP消息的API。

javax.xml.stream

定义Streaming API for XML（StAX）的接口和类。

javax.xml.stream.events

定义Streaming API for XML（StAX）的事件接口。

javax.xml.stream.util

为Streaming API for XML（StAX）提供实用程序类。

javax.xml.transform

定义用于处理转换指令的通用API，以及执行从源到结果的转换。

javax.xml.transform.dom

提供DOM特定的转换类。

javax.xml.transform.sax

提供SAX特定的转换类。

javax.xml.transform.stax

提供StAX特定的转换类。

javax.xml.transform.stream

提供流和URI特定的转换类。

javax.xml.validation

提供用于验证XML文档的API。

javax.xml.ws

此软件包包含核心JAX-WS API。

javax.xml.ws.handler

新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：

javax.xml.ws.handler.soap

此包定义SOAP消息处理程序的API。

javax.xml.ws.http

该包定义了特定于HTTP绑定的API。

javax.xml.ws.soap

该包定义了SOAP绑定专用的API。

javax.xml.ws.spi

此套件为JAX-WS定义了SPI。

javax.xml.ws.spi.http

提供用于在容器（例如servlet容器）中便携式部署JAX-WS Web服务的HTTP SPI。

javax.xml.ws.wsaddressing

此包定义与WS-Addressing相关的API。

javax.xml.xpath

提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。

jdk.dynalink

包含用于链接 invokedynamic呼叫站点的接口和类。

jdk.dynalink.beans

包含普通Java对象的链接器。

jdk.dynalink.linker

包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。

jdk.dynalink.linker.support

包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。

jdk.incubator.http

高级HTTP和WebSocket API

jdk.javadoc.doclet

Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。

jdk.jshell

提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。

jdk.jshell.execution

提供构建JShell执行引擎的实现支持。

jdk.jshell.spi

定义可插拔JShell执行引擎的服务提供程序接口。

jdk.jshell.tool

提供一种启动Javaâ壳工具实例的机制。

jdk.nashorn.api.scripting

这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

jdk.nashorn.api.tree

Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。

jdk.net

适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。

jdk.packager.services

定义Java Packager工具使用的服务。

jdk.security.jarsigner

netscape.javascript

使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。

org.ietf.jgss

该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。

org.omg.CORBA

提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能的对象请求代理（ORB）。

org.omg.CORBA_2_3

CORBA_2_3包定义了Java [tm]标准版6中现有CORBA接口的添加。这些更改发生在由OMG定义的CORBA API的最新修订版本中。 将新方法添加到从CORBA包中相应接口派生的接口。 这提供向后兼容性，并避免破坏JCK测试。

org.omg.CORBA_2_3.portable

提供输入和输出值类型的方法，并包含其他更新的 org/omg/CORBA/portable包。

org.omg.CORBA.DynAnyPackage

提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。

org.omg.CORBA.ORBPackage

提供异常 InvalidName ，由方法 ORB.resolve_initial_references和异常 InconsistentTypeCode抛出，由ORB类中的动态任何创建方法抛出。

org.omg.CORBA.portable

提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。

org.omg.CORBA.TypeCodePackage

提供用户定义的异常 BadKind和 Bounds ，它们通过 TypeCode类中的方法抛出。

org.omg.CosNaming

为Java IDL提供命名服务。

org.omg.CosNaming.NamingContextExtPackage

此包装包含以下类别，其用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress

org.omg.CosNaming.NamingContextPackage

此程序包包含 org.omg.CosNaming程序包的异常类。

org.omg.DynamicAny

提供类和接口，可以在运行时遍历与 any相关联的数据值，并提取数据值的原始组成部分。

org.omg.DynamicAny.DynAnyFactoryPackage

该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。

org.omg.DynamicAny.DynAnyPackage

该包包含OMG “公共对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。

org.omg.IOP

该包包含OMG文档 “通用对象请求代理：体系结构和规范 ” formal/99-10-07第13.6节中指定的 IOP模块。

org.omg.IOP.CodecFactoryPackage

该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。

org.omg.IOP.CodecPackage

该包是从IOP :: Codec IDL接口定义生成的。

org.omg.Messaging

该包包含OMG CORBA消息传递规范 formal/99-10-07中指定的 Messaging模块。

org.omg.PortableInterceptor

提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。

org.omg.PortableInterceptor.ORBInitInfoPackage

该包包含OMG便携式拦截器规范 ptc/2000-08-06第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。

org.omg.PortableServer

提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。

org.omg.PortableServer.CurrentPackage

提供方法实现，访问方法被调用的对象的标识。

org.omg.PortableServer.POAManagerPackage

封装与之相关的POA的处理状态。

org.omg.PortableServer.POAPackage

允许程序员构建可在不同ORB产品之间移植的对象实现。

org.omg.PortableServer.portable

提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。

org.omg.stub.java.rmi

包含 java.rmi软件包中出现的远程类型的RMI-IIOP存根。

org.w3c.dom

提供文档对象模型（DOM）的接口。

org.w3c.dom.bootstrap

提供一个工厂来获取 DOMImplementation实例。

org.w3c.dom.css

提供DOM Level 2 Style Specification的界面。

org.w3c.dom.events

提供DOM Level 2事件的接口。

org.w3c.dom.html

提供DOM Level 2 HTML规范的接口。

org.w3c.dom.ls

提供DOM Level 3加载和保存的界面。

org.w3c.dom.ranges

提供DOM Level 2范围的界面。

org.w3c.dom.stylesheets

提供DOM Level 2 Style Specification的界面。

org.w3c.dom.xpath

提供DOM Level 3 XPath规范的接口。

org.xml.sax

提供核心SAX API。

org.xml.sax.ext

提供与符合SAX驱动程序不一定支持的SAX2设施的接口。

org.xml.sax.helpers

提供帮助类，包括支持引导基于SAX的应用程序。

Uses of String in com.sun.jarsigner

Methods in com.sun.jarsigner that return String

Modifier and Type

方法

描述

String[]

ContentSignerParameters.getCommandLine​()

已过时。

检索传递给jarsigner工具的命令行参数。

String

ContentSignerParameters.getSignatureAlgorithm​()

已过时。

检索签名算法的名称。

default String

ContentSignerParameters.getTSADigestAlg​()

已过时。

检索用于生成要发送到TSA服务器的消息印记的消息摘要算法。

default String

ContentSignerParameters.getTSAPolicyID​()

已过时。

检索时间戳权限（TSA）的TSAPolicyID。

Uses of String in com.sun.java.accessibility.util

Methods in com.sun.java.accessibility.util that return String

Modifier and Type

方法

描述

String

Translator.getAccessibleDescription​()

获取此对象的可访问描述。

String

Translator.getAccessibleName​()

获取此对象的可访问名称。

String

AccessibilityListenerList.toString​()

返回一个字符串表示的 AccessibilityListenerList 。

Methods in com.sun.java.accessibility.util with parameters of type String

Modifier and Type

方法

描述

void

Translator.setAccessibleDescription​(String s)

设置此对象的可访问性描述。

void

Translator.setAccessibleName​(String s)

设置此对象的名称。

Uses of String in com.sun.javadoc

Methods in com.sun.javadoc that return String

Modifier and Type

方法

描述

String

Doc.commentText​()

已过时。

返回此文档项目的注释文本。

String

FieldDoc.constantValueExpression​()

已过时。

获取常量字段的值。

String

SerialFieldTag.description​()

已过时。

返回字段注释。

String

Type.dimension​()

已过时。

返回类型的维度信息，作为字符串。

String

ThrowsTag.exceptionComment​()

已过时。

返回与此 ThrowsTag相关联的异常注释。

String

ThrowsTag.exceptionName​()

已过时。

返回与此 ThrowsTag相关联的异常的名称。

String

SerialFieldTag.fieldName​()

已过时。

返回可序列化的字段名称。

String

SerialFieldTag.fieldType​()

已过时。

返回字段类型字符串。

String

ExecutableMemberDoc.flatSignature​()

已过时。

得到平面签名。

String

Doc.getRawCommentText​()

已过时。

返回评论的完整未处理文本。

String

Tag.kind​()

已过时。

返回这个标签的种类。

String

SeeTag.label​()

已过时。

获取标签的 @see标签。

String

ProgramElementDoc.modifiers​()

已过时。

获取修饰符字符串。

String

Doc.name​()

已过时。

返回此Doc文件的非限定名称。

String

Parameter.name​()

已过时。

获取此参数的本地名称。

String

Tag.name​()

已过时。

返回此标签的名称。

String[][]

RootDoc.options​()

已过时。

命令行选项。

String

ParamTag.parameterComment​()

已过时。

返回与此 ParamTag相关联的参数注释。

String

ParamTag.parameterName​()

已过时。

返回与此 ParamTag相关联的参数或类型参数的名称。

String

ProgramElementDoc.qualifiedName​()

已过时。

获取此程序元素的完全限定名称。

String

Type.qualifiedTypeName​()

已过时。

返回不包括任何维度信息的类型的限定名称。

String

SeeTag.referencedClassName​()

已过时。

获取 @see参考的类或接口名称。

String

SeeTag.referencedMemberName​()

已过时。

获取 @see参考的字段，构造函数或方法子字符串。

String

ExecutableMemberDoc.signature​()

已过时。

签名。

String

Type.simpleTypeName​()

已过时。

返回此类型的简单名称，不包括任何维度信息。

String

Tag.text​()

已过时。

返回此标签的文本，即超出标签名称的部分。

String

AnnotationValue.toString​()

已过时。

返回值的字符串表示形式。

String

Parameter.toString​()

已过时。

返回参数的字符串表示形式。

String

SourcePosition.toString​()

已过时。

将源位置转换为“Filename：line”形式。

String

Tag.toString​()

已过时。

将此对象转换为字符串。

String

Type.toString​()

已过时。

返回类型的字符串表示形式。

String

Parameter.typeName​()

已过时。

获取此参数的类型名称。

String

Type.typeName​()

已过时。

返回类型的不合格的名称，不包括任何维度信息。

Methods in com.sun.javadoc with parameters of type String

Modifier and Type

方法

描述

ClassDoc

RootDoc.classNamed​(String qualifiedName)

已过时。

为指定的类或接口名返回ClassDoc。

ClassDoc

ClassDoc.findClass​(String className)

已过时。

在该类doc的上下文中找到指定的类或接口。

ClassDoc

PackageDoc.findClass​(String className)

已过时。

在此包中查找类或接口。

static int

Doclet.optionLength​(String option)

已过时。

检查doclet添加的选项。

PackageDoc

RootDoc.packageNamed​(String name)

已过时。

为指定的包名返回一个PackageDoc。

void

DocErrorReporter.printError​(SourcePosition pos, String msg)

已过时。

打印错误消息并增加错误计数。

void

DocErrorReporter.printError​(String msg)

已过时。

打印错误消息和增量错误计数。

void

DocErrorReporter.printNotice​(SourcePosition pos, String msg)

已过时。

打印信息。

void

DocErrorReporter.printNotice​(String msg)

已过时。

打印信息。

void

DocErrorReporter.printWarning​(SourcePosition pos, String msg)

已过时。

打印警告信息并增加警告计数。

void

DocErrorReporter.printWarning​(String msg)

已过时。

打印警告信息并增加警告计数。

void

Doc.setRawCommentText​(String rawDocumentation)

已过时。

设置注释的完整未处理文本。

Tag[]

Doc.tags​(String tagname)

已过时。

返回本文档中指定的 kind的标签。

static boolean

Doclet.validOptions​(String[][] options, DocErrorReporter reporter)

已过时。

检查选项是否具有正确的参数。

static LanguageVersion

LanguageVersion.valueOf​(String name)

已过时。

以指定的名称返回此类型的枚举常量。

Uses of String in com.sun.jdi

Methods in com.sun.jdi that return String

Modifier and Type

方法

描述

String

PathSearchingVirtualMachine.baseDirectory​()

获取用于路径搜索的基本目录。

String

ClassNotLoadedException.className​()

String

ArrayType.componentSignature​()

获取该数组类的组件的JNI签名。

String

ArrayType.componentTypeName​()

返回此数组的组件类型的文本表示形式。

String

ReferenceType.defaultStratum​()

返回此引用类型的默认层次。

String

VirtualMachine.description​()

返回目标虚拟机上的文本信息和镜像它的调试器支持。

String

LocalVariable.genericSignature​()

获取此变量的通用签名（如果有）。

String

ReferenceType.genericSignature​()

获取此类型的通用签名（如果有）。

String

TypeComponent.genericSignature​()

获取此类型组件的通用签名（如果有）。

String

VirtualMachine.getDefaultStratum​()

返回此虚拟机的默认层。

String

LocalVariable.name​()

获取局部变量的名称。

String

ModuleReference.name​()

返回模块名称。

String

ReferenceType.name​()

获取此类型的完全限定名称。

String

ThreadGroupReference.name​()

返回此线程组的名称。

String

ThreadReference.name​()

返回此线程的名称。

String

Type.name​()

String

TypeComponent.name​()

获取此类型组件的名称。

String

VirtualMachine.name​()

返回由属性 java.vm.name报告的目标VM的名称。

String

Method.returnTypeName​()

返回返回类型的文本表示形式，如该方法的声明所指定。

String

LocalVariable.signature​()

获取局部变量的JNI签名。

String

Type.signature​()

返回此类型的JNI样式签名。

String

TypeComponent.signature​()

获取此类型组件的JNI样式签名。

String

ReferenceType.sourceDebugExtension​()

获取此类型的源调试扩展。

String

Location.sourceName​()

获取与此位置相对应的源的标识名称。

String

Location.sourceName​(String stratum)

获取与此位置相对应的源的标识名称。

String

ReferenceType.sourceName​()

获取与此类型的声明相对应的源的识别名称。

String

Location.sourcePath​()

获取与此位置相对应的源的路径。

String

Location.sourcePath​(String stratum)

获取与此位置相对应的源的路径。

String

Mirror.toString​()

返回描述此镜像的String

String

Field.typeName​()

返回此字段类型的文本表示。

String

LocalVariable.typeName​()

返回此变量类型的文本表示形式。

String

StringReference.value​()

以字符串形式返回StringReference。

String

VirtualMachine.version​()

返回由属性 java.version报告的目标虚拟机中的Java运行时环境的版本。

Methods in com.sun.jdi that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

Method.argumentTypeNames​()

返回一个包含此方法的每个形式参数类型的文本表示的列表。

List<String>

ReferenceType.availableStrata​()

返回此参考类型的可用层。

List<String>

PathSearchingVirtualMachine.bootClassPath​()

获取此虚拟机的引导类路径。

List<String>

PathSearchingVirtualMachine.classPath​()

获取此虚拟机的类路径。

List<String>

ReferenceType.sourceNames​(String stratum)

获取与此类型的声明对应的所有源的识别名称。

List<String>

ReferenceType.sourcePaths​(String stratum)

获取与此类型的声明对应的源的路径。

Methods in com.sun.jdi with parameters of type String

Modifier and Type

方法

描述

List<Location>

Method.allLineLocations​(String stratum, String sourceName)

在此方法中，为每个可执行源行返回一个包含Location对象的列表。

List<Location>

ReferenceType.allLineLocations​(String stratum, String sourceName)

在此引用类型中，为每个可执行源行返回一个包含Location对象的列表。

List<ReferenceType>

VirtualMachine.classesByName​(String className)

返回与给定名称相匹配的加载引用类型。

方法

ClassType.concreteMethodByName​(String name, String signature)

返回从该类可见的具有给定名称和签名的单个非抽象方法 。

Field

ReferenceType.fieldByName​(String fieldName)

找到具有给定的非歧义名称的可见Field 。

int

Location.lineNumber​(String stratum)

此位置的行号。

List<Location>

Method.locationsOfLine​(String stratum, String sourceName, int lineNumber)

返回包含映射到给定行号和源名称的所有Location对象的列表。

List<Location>

ReferenceType.locationsOfLine​(String stratum, String sourceName, int lineNumber)

返回包含映射到给定行号的所有Location对象的列表。

List<方法>

ReferenceType.methodsByName​(String name)

返回一个列表，其中包含具有给定名称的每个可见的方法 。

List<方法>

ReferenceType.methodsByName​(String name, String signature)

返回一个列表，其中包含具有给定名称和签名的每个可见的方法 。

StringReference

VirtualMachine.mirrorOf​(String value)

在此虚拟机中创建一个字符串。

void

VirtualMachine.setDefaultStratum​(String stratum)

设置此VM的默认层次（有关层次的讨论，请参阅Location ）。

String

Location.sourceName​(String stratum)

获取与此位置相对应的源的标识名称。

List<String>

ReferenceType.sourceNames​(String stratum)

获取与此类型的声明对应的所有源的识别名称。

String

Location.sourcePath​(String stratum)

获取与此位置相对应的源的路径。

List<String>

ReferenceType.sourcePaths​(String stratum)

获取与此类型的声明对应的源的路径。

List<LocalVariable>

Method.variablesByName​(String name)

在此方法中返回包含给定名称的每个LocalVariable的列表。

LocalVariable

StackFrame.visibleVariableByName​(String name)

找到匹配给定名称的LocalVariable ，并在当前帧位置可见。

Constructors in com.sun.jdi with parameters of type String

Constructor

描述

AbsentInformationException​(String s)

ClassNotLoadedException​(String className)

ClassNotLoadedException​(String className, String message)

ClassNotPreparedException​(String s)

IncompatibleThreadStateException​(String s)

InconsistentDebugInfoException​(String s)

InternalException​(String s)

InternalException​(String s, int errorCode)

InvalidCodeIndexException​(String s)

已过时。

InvalidLineNumberException​(String s)

已过时。

InvalidModuleException​(String msg)

构造一个 InvalidModuleException与给定的详细消息。

InvalidStackFrameException​(String s)

InvalidTypeException​(String s)

JDIPermission​(String name)

JDIPermission类代表对 VirtualMachineManager访问权限

JDIPermission​(String name, String actions)

构造一个新的JDIPermission对象。

NativeMethodException​(String message)

ObjectCollectedException​(String s)

VMCannotBeModifiedException​(String s)

VMDisconnectedException​(String message)

VMMismatchException​(String s)

VMOutOfMemoryException​(String s)

Uses of String in com.sun.jdi.connect

Methods in com.sun.jdi.connect that return String

Modifier and Type

方法

描述

String

Connector.Argument.description​()

返回该参数及其目的的可读描述。

String

Connector.description​()

返回此连接器的可读描述及其目的。

String

Connector.Argument.label​()

为此参数返回一个简短的可读标签。

String

Connector.Argument.name​()

返回参数的简短唯一标识符。

String

Connector.name​()

返回连接器的短标识符。

String

Transport.name​()

返回传输的简短标识符。

String

ListeningConnector.startListening​(Map<String,? extends Connector.Argument> arguments)

侦听由目标虚拟机发起的一个或多个连接。

String

Connector.BooleanArgument.stringValueOf​(boolean value)

返回 value参数的字符串表示形式。

String

Connector.IntegerArgument.stringValueOf​(int value)

返回 value参数的字符串表示形式。

String

Connector.Argument.value​()

返回参数的当前值。

Methods in com.sun.jdi.connect that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

IllegalConnectorArgumentsException.argumentNames​()

返回一个包含无效或不一致参数的名称的 List 。

List<String>

Connector.SelectedArgument.choices​()

返回参数的可能值

Map<String,Connector.Argument>

Connector.defaultArguments​()

返回此连接器接受的参数及其默认值。

Methods in com.sun.jdi.connect with parameters of type String

Modifier and Type

方法

描述

boolean

Connector.Argument.isValid​(String value)

对参数进行基本的理性检查。

boolean

Connector.BooleanArgument.isValid​(String value)

对参数进行基本的理性检查。

boolean

Connector.IntegerArgument.isValid​(String value)

对参数进行基本的理性检查。

boolean

Connector.SelectedArgument.isValid​(String value)

对参数进行基本的理性检查。

boolean

Connector.StringArgument.isValid​(String value)

对参数进行基本的理性检查。

void

Connector.Argument.setValue​(String value)

设置参数的值。

Method parameters in com.sun.jdi.connect with type arguments of type String

Modifier and Type

方法

描述

VirtualMachine

ListeningConnector.accept​(Map<String,? extends Connector.Argument> arguments)

等待目标VM附加到此连接器。

VirtualMachine

AttachingConnector.attach​(Map<String,? extends Connector.Argument> arguments)

附加到正在运行的应用程序并返回其虚拟机的镜像。

VirtualMachine

LaunchingConnector.launch​(Map<String,? extends Connector.Argument> arguments)

启动应用程序并连接到其VM。

String

ListeningConnector.startListening​(Map<String,? extends Connector.Argument> arguments)

侦听由目标虚拟机发起的一个或多个连接。

void

ListeningConnector.stopListening​(Map<String,? extends Connector.Argument> arguments)

取消侦听连接。

Constructors in com.sun.jdi.connect with parameters of type String

Constructor

描述

IllegalConnectorArgumentsException​(String s, String name)

构造一个具有指定的详细消息的 IllegalConnectorArgumentsException和无效或不一致的参数的名称。

IllegalConnectorArgumentsException​(String s, List<String> names)

构建 IllegalConnectorArgumentsException带指定详细消息和 List的参数，其是无效的或不一致的名字。

TransportTimeoutException​(String message)

构造具有指定详细消息的 TransportTimeoutException 。

VMStartException​(String message, Process process)

Constructor parameters in com.sun.jdi.connect with type arguments of type String

Constructor

描述

IllegalConnectorArgumentsException​(String s, List<String> names)

构建 IllegalConnectorArgumentsException带指定详细消息和 List的参数，其是无效的或不一致的名字。

Uses of String in com.sun.jdi.connect.spi

Methods in com.sun.jdi.connect.spi that return String

Modifier and Type

方法

描述

abstract String

TransportService.ListenKey.address​()

返回listen键的字符串表示形式。

abstract String

TransportService.description​()

返回传输服务的描述。

abstract String

TransportService.name​()

返回一个名称以识别传输服务。

Methods in com.sun.jdi.connect.spi with parameters of type String

Modifier and Type

方法

描述

abstract Connection

TransportService.attach​(String address, long attachTimeout, long handshakeTimeout)

附加到指定的地址。

abstract TransportService.ListenKey

TransportService.startListening​(String address)

侦听入站连接的指定地址。

Constructors in com.sun.jdi.connect.spi with parameters of type String

Constructor

描述

ClosedConnectionException​(String message)

构造具有指定详细消息的 ClosedConnectionException 。

Uses of String in com.sun.jdi.event

Methods in com.sun.jdi.event that return String

Modifier and Type

方法

描述

String

ClassUnloadEvent.className​()

返回已卸载的类的名称。

String

ClassUnloadEvent.classSignature​()

返回已卸载的类的JNI样式签名。

Uses of String in com.sun.jdi.request

Methods in com.sun.jdi.request with parameters of type String

Modifier and Type

方法

描述

void

ClassPrepareRequest.addClassExclusionFilter​(String classPattern)

将此请求生成的事件限制为编写名称与此受限正则表达式 不匹配的引用类型。

void

ClassUnloadRequest.addClassExclusionFilter​(String classPattern)

将此请求生成的事件限制为卸载其名称与受限正则表达式 不匹配的引用类型。

void

ExceptionRequest.addClassExclusionFilter​(String classPattern)

限制通过该请求到那些位置是在类名 不匹配的受限的正则表达式生成的事件。

void

MethodEntryRequest.addClassExclusionFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象

void

MethodExitRequest.addClassExclusionFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法。

void

MonitorContendedEnteredRequest.addClassExclusionFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象

void

MonitorContendedEnterRequest.addClassExclusionFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的方法的对象

void

MonitorWaitedRequest.addClassExclusionFilter​(String classPattern)

将由此请求生成的事件限制于监视对象的类名与此受限正则表达式 不匹配的事件，例如

void

MonitorWaitRequest.addClassExclusionFilter​(String classPattern)

将由此请求生成的事件限制于监视对象的类名与此受限正则表达式 不匹配的事件，例如

void

StepRequest.addClassExclusionFilter​(String classPattern)

限制通过该请求到那些位置是在类名 不匹配的受限的正则表达式生成的事件。

void

WatchpointRequest.addClassExclusionFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式 不匹配的类中的位置。

void

ClassPrepareRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制为编写名称与此受限正则表达式匹配的引用类型。

void

ClassUnloadRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制为卸载其名称与受限正则表达式匹配的引用类型。

void

ExceptionRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。

void

MethodEntryRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。

void

MethodExitRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制在其名称与受限正则表达式匹配的类中的方法。

void

MonitorContendedEnteredRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。

void

MonitorContendedEnterRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制在其名称与此受限正则表达式匹配的类中的方法。

void

MonitorWaitedRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。

void

MonitorWaitRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制为监视对象的类名与此受限正则表达式匹配的事件。

void

StepRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。

void

WatchpointRequest.addClassFilter​(String classPattern)

将此请求生成的事件限制在名称与受限正则表达式匹配的类中的位置。

void

ClassPrepareRequest.addSourceNameFilter​(String sourceNamePattern)

将此请求生成的事件限制为准备引用类型，受限正则表达式“sourceNamePattern”与正在准备的引用类型的“sourceNames”匹配。

Constructors in com.sun.jdi.request with parameters of type String

Constructor

描述

DuplicateRequestException​(String s)

InvalidRequestStateException​(String s)

Uses of String in com.sun.management

Fields in com.sun.management declared as String

Modifier and Type

Field

描述

static String

GarbageCollectionNotificationInfo.GARBAGE_COLLECTION_NOTIFICATION

通知类型表示Java虚拟机已完成垃圾回收循环。

Methods in com.sun.management that return String

Modifier and Type

方法

描述

String

GarbageCollectionNotificationInfo.getGcAction​()

返回垃圾收集器执行的操作

String

GarbageCollectionNotificationInfo.getGcCause​()

返回垃圾收集的原因

String

GarbageCollectionNotificationInfo.getGcName​()

返回用于执行集合的垃圾收集器的名称

String

VMOption.getName​()

返回此VM选项的名称。

String

VMOption.getValue​()

在创建此 VMOption时返回此VM选项的值。

String

GcInfo.toString​()

String

VMOption.toString​()

Methods in com.sun.management that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,MemoryUsage>

GcInfo.getMemoryUsageAfterGc​()

返回此GC结尾处的所有内存池的内存使用情况。

Map<String,MemoryUsage>

GcInfo.getMemoryUsageBeforeGc​()

返回此GC开头的所有内存池的内存使用情况。

Methods in com.sun.management with parameters of type String

Modifier and Type

方法

描述

boolean

GcInfo.containsKey​(String key)

void

HotSpotDiagnosticMXBean.dumpHeap​(String outputFile, boolean live)

以与hprof堆转储相同的格式将堆转储到 outputFile文件。

Object

GcInfo.get​(String key)

Object[]

GcInfo.getAll​(String[] keys)

VMOption

HotSpotDiagnosticMXBean.getVMOption​(String name)

返回给定名称的VM选项的 VMOption对象。

void

HotSpotDiagnosticMXBean.setVMOption​(String name, String value)

将给定名称的VM选项设置为指定的值。

static VMOption.Origin

VMOption.Origin.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in com.sun.management with parameters of type String

Constructor

描述

GarbageCollectionNotificationInfo​(String gcName, String gcAction, String gcCause, GcInfo gcInfo)

构造一个 GarbageCollectionNotificationInfo对象。

VMOption​(String name, String value, boolean writeable, VMOption.Origin origin)

构造一个 VMOption 。

Uses of String in com.sun.net.httpserver

Fields in com.sun.net.httpserver declared as String

Modifier and Type

Field

描述

protected String

BasicAuthenticator.realm

Methods in com.sun.net.httpserver that return String

Modifier and Type

方法

描述

abstract String

Filter.description​()

返回此过滤器的简短说明

String[]

HttpsParameters.getCipherSuites​()

返回密码数组的副本，如果没有设置则返回null。

String

Headers.getFirst​(String key)

从给定键的String列表中返回第一个值（如果至少存在一个）。

String

HttpPrincipal.getName​()

以 realm：username格式返回此主体的内容

abstract String

HttpContext.getPath​()

返回此上下文创建的路径

abstract String

HttpExchange.getProtocol​()

从请求中以 协议/ majorVersion.minorVersion的形式返回协议串。

String[]

HttpsParameters.getProtocols​()

返回协议数组的副本，如果没有设置，则返回null。

String

BasicAuthenticator.getRealm​()

返回此BasicAuthenticator创建的领域

String

HttpPrincipal.getRealm​()

返回此对象创建的领域。

abstract String

HttpExchange.getRequestMethod​()

获取请求方法

String

HttpPrincipal.getUsername​()

返回此对象创建的用户名。

String

HttpPrincipal.toString​()

返回与getName（）相同的字符串

Methods in com.sun.net.httpserver that return types with arguments of type String

Modifier and Type

方法

描述

Set<Map.Entry<String,List<String>>>

Headers.entrySet​()

Set<Map.Entry<String,List<String>>>

Headers.entrySet​()

List<String>

Headers.get​(Object key)

abstract Map<String,Object>

HttpContext.getAttributes​()

返回一个可变的Map，可以将配置和其他数据传递给Filter模块和上下文的交换处理程序。

Set<String>

Headers.keySet​()

List<String>

Headers.put​(String key, List<String> value)

List<String>

Headers.remove​(Object key)

Collection<List<String>>

Headers.values​()

Methods in com.sun.net.httpserver with parameters of type String

Modifier and Type

方法

描述

void

Headers.add​(String key, String value)

将给定的值添加到给定键的标题列表中。

abstract boolean

BasicAuthenticator.checkCredentials​(String username, String password)

要求每个传入请求在此Authenticator的领域的上下文中验证给定的名称和密码。

abstract HttpContext

HttpServer.createContext​(String path)

创建一个HttpContext，而不会最初指定一个处理程序。

abstract HttpContext

HttpServer.createContext​(String path, HttpHandler handler)

创建一个HttpContext。

abstract Object

HttpExchange.getAttribute​(String name)

过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。

String

Headers.getFirst​(String key)

从给定键的String列表中返回第一个值（如果至少存在一个）。

List<String>

Headers.put​(String key, List<String> value)

abstract void

HttpServer.removeContext​(String path)

从服务器中删除由给定路径标识的上下文。

void

Headers.set​(String key, String value)

将给定值设置为给定键的唯一标题值。

abstract void

HttpExchange.setAttribute​(String name, Object value)

过滤器模块可以将具有HttpExchange实例的任意对象存储为带外通信机制。

void

HttpsParameters.setCipherSuites​(String[] cipherSuites)

设置密码组数组。

void

HttpsParameters.setProtocols​(String[] protocols)

设置协议数组。

Method parameters in com.sun.net.httpserver with type arguments of type String

Modifier and Type

方法

描述

List<String>

Headers.put​(String key, List<String> value)

void

Headers.putAll​(Map<? extends String,? extends List<String>> t)

void

Headers.putAll​(Map<? extends String,? extends List<String>> t)

Constructors in com.sun.net.httpserver with parameters of type String

Constructor

描述

BasicAuthenticator​(String realm)

为给定的HTTP领域创建BasicAuthenticator

HttpPrincipal​(String username, String realm)

从给定的用户名和领域创建一个HttpPrincipal

Uses of String in com.sun.nio.sctp

Methods in com.sun.nio.sctp that return String

Modifier and Type

方法

描述

String

SctpStandardSocketOptions.InitMaxStreams.toString​()

返回此init最大流的字符串表示形式，包括最大输入和输出绑定流。

Methods in com.sun.nio.sctp with parameters of type String

Modifier and Type

方法

描述

static AssociationChangeNotification.AssocChangeEvent

AssociationChangeNotification.AssocChangeEvent.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static HandlerResult

HandlerResult.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PeerAddressChangeNotification.AddressChangeEvent

PeerAddressChangeNotification.AddressChangeEvent.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in com.sun.nio.sctp with parameters of type String

Constructor

描述

IllegalReceiveException​(String msg)

使用指定的消息构造此类的实例。

IllegalUnbindException​(String msg)

使用指定的详细消息构造此类的实例。

InvalidStreamException​(String msg)

使用指定的详细消息构造此类的实例。

Uses of String in com.sun.security.auth

Methods in com.sun.security.auth that return String

Modifier and Type

方法

描述

String

LdapPrincipal.getName​()

返回最初用于创建此主体的名称。

String

NTDomainPrincipal.getName​()

返回这个 NTDomainPrincipal的Windows NT域名。

String

NTSid.getName​()

返回一个字符串版本的这个 NTSid 。

String

NTUserPrincipal.getName​()

返回这个 NTPrincipal的Windows NT用户名。

String

SolarisNumericGroupPrincipal.getName​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回此 SolarisNumericGroupPrincipal的用户组标识号（GID）。

String

SolarisNumericUserPrincipal.getName​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回此 SolarisNumericUserPrincipal的用户标识号（UID）。

String

SolarisPrincipal.getName​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回这个 SolarisPrincipal的Unix用户名。

String

UnixNumericGroupPrincipal.getName​()

返回此 UnixNumericGroupPrincipal的用户组标识号（GID）。

String

UnixNumericUserPrincipal.getName​()

返回此 UnixNumericUserPrincipal的用户标识号（UID）。

String

UnixPrincipal.getName​()

返回这个 UnixPrincipal的Unix用户名。

String

UserPrincipal.getName​()

返回此主体的名称。

String

X500Principal.getName​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回此 X500Principal的Unix用户名。

String

LdapPrincipal.toString​()

以 RFC 2253定义的格式创建此主体名称的字符串表示形式。

String

NTDomainPrincipal.toString​()

返回此 NTDomainPrincipal的字符串表示 NTDomainPrincipal 。

String

NTNumericCredential.toString​()

返回这个 NTNumericCredential的字符串表示。

String

NTSid.toString​()

返回这个 NTSid的字符串表示。

String

NTSidDomainPrincipal.toString​()

返回此 NTSidDomainPrincipal的字符串表示 NTSidDomainPrincipal 。

String

NTSidGroupPrincipal.toString​()

返回这个 NTSidGroupPrincipal的字符串表示。

String

NTSidPrimaryGroupPrincipal.toString​()

返回此 NTSidPrimaryGroupPrincipal的字符串表示 NTSidPrimaryGroupPrincipal 。

String

NTSidUserPrincipal.toString​()

返回此 NTSidUserPrincipal的字符串表示 NTSidUserPrincipal 。

String

NTUserPrincipal.toString​()

返回此 NTPrincipal的字符串表示 NTPrincipal 。

String

SolarisNumericGroupPrincipal.toString​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回此 SolarisNumericGroupPrincipal的字符串表示 SolarisNumericGroupPrincipal 。

String

SolarisNumericUserPrincipal.toString​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回此 SolarisNumericUserPrincipal的字符串表示 SolarisNumericUserPrincipal 。

String

SolarisPrincipal.toString​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回此 SolarisPrincipal的字符串表示 SolarisPrincipal 。

String

UnixNumericGroupPrincipal.toString​()

返回此 UnixNumericGroupPrincipal的字符串表示 UnixNumericGroupPrincipal 。

String

UnixNumericUserPrincipal.toString​()

返回此 UnixNumericUserPrincipal的字符串表示 UnixNumericUserPrincipal 。

String

UnixPrincipal.toString​()

返回此 UnixPrincipal的字符串表示 UnixPrincipal 。

String

UserPrincipal.toString​()

返回此主体的字符串表示形式。

String

X500Principal.toString​()

不推荐用于删除：此API元素将在以后的版本中被删除。

返回这个 X500Principal的字符串表示。

Constructors in com.sun.security.auth with parameters of type String

Constructor

描述

LdapPrincipal​(String name)

创建一个LDAP主体。

NTDomainPrincipal​(String name)

创建一个具有Windows NT域名的 NTDomainPrincipal 。

NTSid​(String stringSid)

使用Windows NT SID创建一个 NTSid 。

NTSidDomainPrincipal​(String name)

使用Windows NT SID创建一个 NTSidDomainPrincipal 。

NTSidGroupPrincipal​(String name)

创建一个具有Windows NT组名称的 NTSidGroupPrincipal 。

NTSidPrimaryGroupPrincipal​(String name)

使用Windows NT组SID创建一个 NTSidPrimaryGroupPrincipal 。

NTSidUserPrincipal​(String name)

使用Windows NT SID创建一个 NTSidUserPrincipal 。

NTUserPrincipal​(String name)

创建一个具有Windows NT用户名的 NTUserPrincipal 。

SolarisNumericGroupPrincipal​(String name, boolean primaryGroup)

不推荐用于删除：此API元素将在以后的版本中被删除。

使用 String表示用户的组标识号（GID）创建 SolarisNumericGroupPrincipal 。

SolarisNumericUserPrincipal​(String name)

不推荐用于删除：此API元素将在以后的版本中被删除。

创建 SolarisNumericUserPrincipal使用 String用户的标识号（UID）的表示。

SolarisPrincipal​(String name)

不推荐用于删除：此API元素将在以后的版本中被删除。

使用Solaris用户名创建SolarisPrincipal。

UnixNumericGroupPrincipal​(String name, boolean primaryGroup)

使用 String表示用户的组标识号（GID）创建 UnixNumericGroupPrincipal 。

UnixNumericUserPrincipal​(String name)

使用用户标识号（UID）的 String表示创建 UnixNumericUserPrincipal 。

UnixPrincipal​(String name)

用Unix用户名创建一个UnixPrincipal。

UserPrincipal​(String name)

创建校长

X500Principal​(String name)

不推荐用于删除：此API元素将在以后的版本中被删除。

使用X.500名称创建X500Principal，例如“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”（RFC 1779样式）。

Uses of String in com.sun.security.auth.login

Methods in com.sun.security.auth.login with parameters of type String

Modifier and Type

方法

描述

AppConfigurationEntry[]

ConfigFile.getAppConfigurationEntry​(String applicationName)

使用应用程序名称作为索引从 Configuration检索条目。

Uses of String in com.sun.security.auth.module

Fields in com.sun.security.auth.module declared as String

Modifier and Type

Field

描述

String

JndiLoginModule.GROUP_PROVIDER

String

JndiLoginModule.USER_PROVIDER

JNDI提供商

protected String

SolarisSystem.username

不推荐用于删除：此API元素将在以后的版本中被删除。

protected String

UnixSystem.username

Methods in com.sun.security.auth.module that return String

Modifier and Type

方法

描述

String

NTSystem.getDomain​()

获取当前NT用户的域。

String

NTSystem.getDomainSID​()

获取当前NT用户域的可打印SID。

String[]

NTSystem.getGroupIDs​()

获取当前NT用户的可打印组SID。

String

NTSystem.getName​()

获取当前NT用户的用户名。

String

NTSystem.getPrimaryGroupID​()

获取当前NT用户的可打印主组SID。

String

SolarisSystem.getUsername​()

不推荐用于删除：此API元素将在以后的版本中被删除。

获取当前Solaris用户的用户名。

String

UnixSystem.getUsername​()

获取当前Unix用户的用户名。

String

NTSystem.getUserSID​()

获取当前NT用户的可打印SID。

Method parameters in com.sun.security.auth.module with type arguments of type String

Modifier and Type

方法

描述

void

JndiLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

初始化这个 LoginModule 。

void

KeyStoreLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

初始化这个 LoginModule 。

void

Krb5LoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

初始化这个 LoginModule 。

void

LdapLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

初始化 LoginModule 。

void

NTLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

初始化 LoginModule 。

void

SolarisLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

不推荐用于删除：此API元素将在以后的版本中被删除。

初始化这个 LoginModule 。

void

UnixLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

初始化 LoginModule 。

Uses of String in com.sun.security.jgss

Methods in com.sun.security.jgss that return String

Modifier and Type

方法

描述

String

AuthorizationDataEntry.toString​()

Methods in com.sun.security.jgss with parameters of type String

Modifier and Type

方法

描述

static InquireType

InquireType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in com.sun.security.jgss with parameters of type String

Constructor

描述

InquireSecContextPermission​(String name)

构造具有指定名称的新的 InquireSecContextPermission对象。

Uses of String in com.sun.source.doctree

Fields in com.sun.source.doctree declared as String

Modifier and Type

Field

描述

String

DocTree.Kind.tagName

与此类节点相关联的标记名称（如果有）。

Methods in com.sun.source.doctree that return String

Modifier and Type

方法

描述

String

CommentTree.getBody​()

返回注释的文本。

String

TextTree.getBody​()

返回文本。

String

ReferenceTree.getSignature​()

返回被引用的Java语言元素的签名，如 @see和类似的节点所示。

String

BlockTagTree.getTagName​()

返回标签的名称。

String

InlineTagTree.getTagName​()

返回标签的名称。

Methods in com.sun.source.doctree with parameters of type String

Modifier and Type

方法

描述

static AttributeTree.ValueKind

AttributeTree.ValueKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static DocTree.Kind

DocTree.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in com.sun.source.tree

Methods in com.sun.source.tree with parameters of type String

Modifier and Type

方法

描述

static LambdaExpressionTree.BodyKind

LambdaExpressionTree.BodyKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static MemberReferenceTree.ReferenceMode

MemberReferenceTree.ReferenceMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ModuleTree.ModuleKind

ModuleTree.ModuleKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Tree.Kind

Tree.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in com.sun.source.util

Methods in com.sun.source.util that return String

Modifier and Type

方法

描述

abstract String

Trees.getDocComment​(TreePath path)

返回给定TreePath标识的Tree节点的doc注释（如果有）。

String

Plugin.getName​()

返回此插件的用户友好名称。

String

TaskEvent.toString​()

Methods in com.sun.source.util with parameters of type String

Modifier and Type

方法

描述

abstract DocCommentTree

DocTrees.getDocCommentTree​(Element e, String relativePath)

返回相对于给定元素指定路径的给定文件的doc注释树。

void

Plugin.init​(JavacTask task, String... args)

初始化给定编译任务的插件。

CommentTree

DocTreeFactory.newCommentTree​(String text)

创建一个新的 CommentTree ，以表示HTML注释。

ErroneousTree

DocTreeFactory.newErroneousTree​(String text, Diagnostic<JavaFileObject> diag)

创建一个新的 ErroneousTree对象，以表示一些不可 ErroneousTree输入。

ReferenceTree

DocTreeFactory.newReferenceTree​(String signature)

创建一个新的 ReferenceTree对象，以表示对API元素的引用。

TextTree

DocTreeFactory.newTextTree​(String text)

创建一个新的 TextTree对象，来表示一些纯文本。

static TaskEvent.Kind

TaskEvent.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in com.sun.tools.attach

Methods in com.sun.tools.attach that return String

Modifier and Type

方法

描述

String

VirtualMachineDescriptor.displayName​()

返回此描述符的 显示名称组件。

String

VirtualMachine.id​()

返回此Java虚拟机的标识符。

String

VirtualMachineDescriptor.id​()

返回此描述符的标识符组件。

abstract String

VirtualMachine.startLocalManagementAgent​()

启动目标虚拟机中的本地JMX管理代理。

String

VirtualMachine.toString​()

返回 VirtualMachine的字符串表示 VirtualMachine 。

String

VirtualMachineDescriptor.toString​()

返回 VirtualMachineDescriptor的字符串表示 VirtualMachineDescriptor 。

Methods in com.sun.tools.attach with parameters of type String

Modifier and Type

方法

描述

static VirtualMachine

VirtualMachine.attach​(String id)

附加到Java虚拟机。

void

VirtualMachine.loadAgent​(String agent)

加载代理

abstract void

VirtualMachine.loadAgent​(String agent, String options)

加载代理

void

VirtualMachine.loadAgentLibrary​(String agentLibrary)

加载代理库。

abstract void

VirtualMachine.loadAgentLibrary​(String agentLibrary, String options)

加载代理库。

void

VirtualMachine.loadAgentPath​(String agentPath)

以完整路径名加载本地代理库。

abstract void

VirtualMachine.loadAgentPath​(String agentPath, String options)

以完整路径名加载本地代理库。

Constructors in com.sun.tools.attach with parameters of type String

Constructor

描述

AgentInitializationException​(String s)

构造具有指定详细消息的 AgentInitializationException 。

AgentInitializationException​(String s, int returnValue)

构造一个具有指定详细消息的 AgentInitializationException和执行代理 Agent_OnAttach函数的返回值。

AgentLoadException​(String s)

构造具有指定详细消息的 AgentLoadException 。

AttachNotSupportedException​(String s)

构造具有指定详细消息的 AttachNotSupportedException 。

AttachOperationFailedException​(String message)

构造具有指定详细消息的 AttachOperationFailedException 。

AttachPermission​(String name)

构造一个新的AttachPermission对象。

AttachPermission​(String name, String actions)

构造一个新的AttachPermission对象。

VirtualMachine​(AttachProvider provider, String id)

初始化此类的新实例。

VirtualMachineDescriptor​(AttachProvider provider, String id)

从给定的组件创建一个虚拟机描述符。

VirtualMachineDescriptor​(AttachProvider provider, String id, String displayName)

从给定的组件创建一个虚拟机描述符。

Uses of String in com.sun.tools.attach.spi

Methods in com.sun.tools.attach.spi that return String

Modifier and Type

方法

描述

abstract String

AttachProvider.name​()

返回此提供商的名称。

abstract String

AttachProvider.type​()

返回此提供商的类型。

Methods in com.sun.tools.attach.spi with parameters of type String

Modifier and Type

方法

描述

abstract VirtualMachine

AttachProvider.attachVirtualMachine​(String id)

附加到Java虚拟机。

Uses of String in com.sun.tools.doclets

Methods in com.sun.tools.doclets that return String

Modifier and Type

方法

描述

String

Taglet.getName​()

已过时。

返回此自定义标签的名称。

String

Taglet.toString​(Tag tag)

已过时。

给定此自定义标签的 Tag表示，返回其字符串表示，将其输出到生成的页面。

String

Taglet.toString​(Tag[] tags)

已过时。

给定一个 Tag s的数组代表这个自定义标签，返回它的字符串表示，它被输出到生成的页面。

Uses of String in com.sun.tools.doclets.standard

Methods in com.sun.tools.doclets.standard with parameters of type String

Modifier and Type

方法

描述

static int

Standard.optionLength​(String option)

不推荐用于删除：此API元素将在以后的版本中被删除。

static boolean

Standard.validOptions​(String[][] options, DocErrorReporter reporter)

不推荐用于删除：此API元素将在以后的版本中被删除。

Uses of String in com.sun.tools.javac

Methods in com.sun.tools.javac with parameters of type String

Modifier and Type

方法

描述

static int

Main.compile​(String[] args)

Java编程语言编程器的编程接口javac。

static int

Main.compile​(String[] args, PrintWriter out)

Java编程语言编程器的编程接口javac。

static void

Main.main​(String[] args)

发射器的主入口点。

Uses of String in com.sun.tools.javadoc

Methods in com.sun.tools.javadoc with parameters of type String

Modifier and Type

方法

描述

static int

Main.execute​(ClassLoader docletParentClassLoader, String... args)

已过时。

程式化界面。

static int

Main.execute​(String... args)

已过时。

程式化界面。

static int

Main.execute​(String programName, PrintWriter errWriter, PrintWriter warnWriter, PrintWriter noticeWriter, String defaultDocletClassName, ClassLoader docletParentClassLoader, String... args)

已过时。

程式化界面。

static int

Main.execute​(String programName, PrintWriter errWriter, PrintWriter warnWriter, PrintWriter noticeWriter, String defaultDocletClassName, String... args)

已过时。

程式化界面。

static int

Main.execute​(String programName, ClassLoader docletParentClassLoader, String... args)

已过时。

程式化界面。

static int

Main.execute​(String programName, String... args)

已过时。

程式化界面。

static int

Main.execute​(String programName, String defaultDocletClassName, ClassLoader docletParentClassLoader, String... args)

已过时。

程式化界面。

static int

Main.execute​(String programName, String defaultDocletClassName, String... args)

已过时。

程式化界面。

static void

Main.main​(String... args)

已过时。

命令行界面。

Uses of String in com.sun.tools.jconsole

Fields in com.sun.tools.jconsole declared as String

Modifier and Type

Field

描述

static String

JConsoleContext.CONNECTION_STATE_PROPERTY

ConnectionState绑定属性名称。

Methods in com.sun.tools.jconsole that return types with arguments of type String

Modifier and Type

方法

描述

abstract Map<String,JPanel>

JConsolePlugin.getTabs​()

返回要在JConsole窗口中添加的选项卡。

Methods in com.sun.tools.jconsole with parameters of type String

Modifier and Type

方法

描述

static JConsoleContext.ConnectionState

JConsoleContext.ConnectionState.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in java.applet

Methods in java.applet that return String

Modifier and Type

方法

描述

String

Applet.getAppletInfo​()

已过时。

返回有关此小程序的信息。

String

Applet.getParameter​(String name)

已过时。

返回HTML标签中命名参数的值。

String

AppletStub.getParameter​(String name)

已过时。

返回HTML标签中命名参数的值。

String[][]

Applet.getParameterInfo​()

已过时。

返回有关此applet可以理解的参数的信息。

Methods in java.applet that return types with arguments of type String

Modifier and Type

方法

描述

Iterator<String>

AppletContext.getStreamKeys​()

已过时。

在此applet上下文中查找流的所有键。

Methods in java.applet with parameters of type String

Modifier and Type

方法

描述

Applet

AppletContext.getApplet​(String name)

已过时。

找到并返回由该applet上下文表示的文档中的applet，该文件具有给定的名称。

AudioClip

Applet.getAudioClip​(URL url, String name)

已过时。

返回由 URL和 name参数指定的 AudioClip对象。

Image

Applet.getImage​(URL url, String name)

已过时。

返回一个 Image对象，然后可以在屏幕上绘制。

String

Applet.getParameter​(String name)

已过时。

返回HTML标签中命名参数的值。

String

AppletStub.getParameter​(String name)

已过时。

返回HTML标签中命名参数的值。

InputStream

AppletContext.getStream​(String key)

已过时。

返回指定键在此applet上下文中相关联的流。

void

Applet.play​(URL url, String name)

已过时。

播放给定URL的音频剪辑和与之相关的说明符。

void

AppletContext.setStream​(String key, InputStream stream)

已过时。

将指定的流与此applet上下文中的指定关键字相关联。

void

AppletContext.showDocument​(URL url, String target)

已过时。

请求浏览器或小程序查看器显示由 url参数指示的 url 。

void

Applet.showStatus​(String msg)

已过时。

请求参数字符串显示在“状态窗口”中。

void

AppletContext.showStatus​(String status)

已过时。

请求参数字符串显示在“状态窗口”中。

Uses of String in java.awt

Fields in java.awt declared as String

Modifier and Type

Field

描述

static String

BorderLayout.AFTER_LAST_LINE

PAGE_END的同义词。

static String

BorderLayout.AFTER_LINE_ENDS

LINE_END的同义词。

static String

BorderLayout.BEFORE_FIRST_LINE

PAGE_START的同义词。

static String

BorderLayout.BEFORE_LINE_BEGINS

LINE_START的同义词。

static String

BorderLayout.CENTER

中心布局约束（容器中间）。

static String

Font.DIALOG

逻辑字体“对话框”的规范系列名称的字符串常量。

static String

Font.DIALOG_INPUT

逻辑字体“DialogInput”的规范系列名称的字符串常量。

static String

BorderLayout.EAST

东面布局限制（容器右侧）。

static String

BorderLayout.LINE_END

组件在布局的行方向的末尾。

static String

BorderLayout.LINE_START

组件在布局的行方向的开始处。

static String

Font.MONOSPACED

逻辑字体“Monospaced”的规范系列名称的字符串常量。

protected String

Cursor.name

光标的用户可见名称。

protected String

Font.name

这个 Font的逻辑名称，传递给构造函数。

static String

BorderLayout.NORTH

北面布局约束（容器顶部）。

static String

BorderLayout.PAGE_END

该组件来自布局内容的最后一行。

static String

BorderLayout.PAGE_START

该组件位于布局内容的第一行之前。

static String

Font.SANS_SERIF

逻辑字体“SansSerif”的规范系列名称的字符串常量。

static String

Font.SERIF

逻辑字体“Serif”的规范系列名称的字符串常量。

static String

BorderLayout.SOUTH

南布局约束（容器底部）。

static String

BorderLayout.WEST

西布局限制（容器左侧）。

Fields in java.awt with type parameters of type String

Modifier and Type

Field

描述

protected Map<String,Object>

Toolkit.desktopProperties

桌面属性。

Methods in java.awt that return String

Modifier and Type

方法

描述

String

Button.AccessibleAWTButton.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

Checkbox.AccessibleAWTCheckbox.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

Choice.AccessibleAWTChoice.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

MenuItem.AccessibleAWTMenuItem.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

Component.AccessibleAWTComponent.getAccessibleDescription​()

获取此对象的可访问描述。

String

MenuComponent.AccessibleAWTMenuComponent.getAccessibleDescription​()

获取此对象的可访问描述。

String

Button.AccessibleAWTButton.getAccessibleName​()

获取此对象的可访问名称。

String

Component.AccessibleAWTComponent.getAccessibleName​()

获取此对象的可访问名称。

String

Label.AccessibleAWTLabel.getAccessibleName​()

获取此对象的可访问名称。

String

MenuComponent.AccessibleAWTMenuComponent.getAccessibleName​()

获取此对象的可访问名称。

String

MenuItem.AccessibleAWTMenuItem.getAccessibleName​()

获取此对象的可访问名称。

String

Button.getActionCommand​()

返回此按钮触发的操作事件的命令名称。

String

MenuItem.getActionCommand​()

获取此菜单项触发的操作事件的命令名称。

String

TrayIcon.getActionCommand​()

返回此托盘图标触发的操作事件的命令名称。

String

TextComponent.AccessibleAWTTextComponent.getAfterIndex​(int part, int index)

返回给定索引后的String。

String

TextComponent.AccessibleAWTTextComponent.getAtIndex​(int part, int index)

返回给定索引处的String。

abstract String[]

GraphicsEnvironment.getAvailableFontFamilyNames​()

返回一个数组，该数组包含本地化为默认语言环境的 GraphicsEnvironment中所有字体族的名称，由 Locale.getDefault()返回。

abstract String[]

GraphicsEnvironment.getAvailableFontFamilyNames​(Locale l)

返回一个包含本地化为指定区域设置的 GraphicsEnvironment中所有字体族的名称的数组。

String

TextComponent.AccessibleAWTTextComponent.getBeforeIndex​(int part, int index)

返回给定索引之前的String。

String

FileDialog.getDirectory​()

获取此文件对话框的目录。

String

Font.getFamily​()

返回此 Font 。

String

Font.getFamily​(Locale l)

返回此 Font本地化名称，用于指定的区域设置。

String

FileDialog.getFile​()

获取此文件对话框的选定文件。

String

JobAttributes.getFileName​()

指定使用这些属性的作业的输出文件的文件名。

abstract String[]

Toolkit.getFontList​()

已过时。
见GraphicsEnvironment.getAvailableFontFamilyNames()

String

Font.getFontName​()

返回此 Font的字体名称。

String

Font.getFontName​(Locale l)

返回 Font的字体面部名称，该名称已针对指定的区域设置进行了本地化。

abstract String

GraphicsDevice.getIDstring​()

返回与此 GraphicsDevice相关联的标识字符串。

String

Choice.getItem​(int index)

获取此 Choice菜单中指定索引处的字符串。

String

List.getItem​(int index)

获取与指定索引关联的项目。

String[]

List.getItems​()

获取列表中的项目。

String

Button.getLabel​()

获取此按钮的标签。

String

Checkbox.getLabel​()

获取此复选框的标签。

String

MenuItem.getLabel​()

获取此菜单项的标签。

String

HeadlessException.getMessage​()

返回此 HeadlessException的详细消息字符串。

String

Component.getName​()

获取组件的名称。

String

Cursor.getName​()

返回此游标的名称。

String

Font.getName​()

返回此 Font的逻辑名称。

String

MenuComponent.getName​()

获取菜单组件的名称。

String

JobAttributes.getPrinter​()

使用这些属性返回作业的目标打印机。

static String

Toolkit.getProperty​(String key, String defaultValue)

获取具有指定键和默认值的属性。

String

Font.getPSName​()

返回此 Font的后记名称。

String

Choice.getSelectedItem​()

获取当前选择的表示形式作为字符串。

String

List.getSelectedItem​()

获取此滚动列表中选定的项目。

String[]

List.getSelectedItems​()

获取此滚动列表中选定的项目。

String

TextComponent.AccessibleAWTTextComponent.getSelectedText​()

返回所选文本的部分。

String

TextComponent.getSelectedText​()

从由此文本组件呈现的文本中返回所选文本。

String

Label.getText​()

获取此标签的文本。

String

TextComponent.getText​()

返回此文本组件显示的文本。

String

Dialog.getTitle​()

获取对话框的标题。

String

Frame.getTitle​()

获取框架的标题。

String

TrayIcon.getToolTip​()

返回与此 TrayIcon关联的工具提示字符串。

String

Window.getWarningString​()

获取此窗口显示的警告字符串。

String

AWTEvent.paramString​()

返回一个表示 Event状态的字符串。

protected String

Button.paramString​()

返回一个表示 Button状态的字符串。

protected String

Checkbox.paramString​()

返回表示 Checkbox的状态的字符串。

String

CheckboxMenuItem.paramString​()

返回一个表示 CheckBoxMenuItem状态的字符串。

protected String

Choice.paramString​()

返回表示此 Choice菜单状态的字符串。

protected String

Component.paramString​()

返回表示此组件状态的字符串。

protected String

Container.paramString​()

返回一个表示 Container状态的字符串。

protected String

Dialog.paramString​()

返回表示此对话框状态的字符串。

protected String

Event.paramString​()

已过时。

注意： Event类已过时，仅适用于向后兼容性。

protected String

FileDialog.paramString​()

返回表示此 FileDialog窗口状态的字符串。

protected String

Frame.paramString​()

返回表示 Frame的状态的字符串。

protected String

Label.paramString​()

返回表示 Label状态的字符串。

protected String

List.paramString​()

返回表示此滚动列表状态的参数字符串。

String

Menu.paramString​()

返回一个表示 Menu状态的字符串。

protected String

MenuComponent.paramString​()

返回表示此 MenuComponent的状态的字符串。

String

MenuItem.paramString​()

返回一个表示 MenuItem状态的字符串。

protected String

MenuShortcut.paramString​()

返回表示此MenuShortcut状态的参数字符串。

protected String

Scrollbar.paramString​()

返回一个表示 Scrollbar状态的字符串。

String

ScrollPane.paramString​()

返回一个表示 ScrollPane状态的字符串。

String

ScrollPaneAdjustable.paramString​()

返回一个表示此滚动条状态的字符串。

protected String

TextArea.paramString​()

返回表示 TextArea状态的字符串。

protected String

TextComponent.paramString​()

返回表示 TextComponent的状态的字符串。

protected String

TextField.paramString​()

返回一个表示 TextField状态的字符串。

String

AWTEvent.toString​()

返回此对象的String表示形式。

String

AWTKeyStroke.toString​()

返回显示和标识此对象属性的字符串。

String

BorderLayout.toString​()

返回此边框布局状态的字符串表示形式。

String

CardLayout.toString​()

返回此卡布局状态的字符串表示形式。

String

CheckboxGroup.toString​()

返回此复选框组的字符串表示形式，包括其当前选择的值。

String

Color.toString​()

返回此 Color的字符串表示 Color 。

String

Component.toString​()

返回此组件及其值的字符串表示形式。

String

Cursor.toString​()

返回此游标的字符串表示形式。

String

Dimension.toString​()

返回 Dimension对象的 height和 width字段的值的字符串表示。

String

DisplayMode.toString​()

返回对象的字符串表示形式。

String

Event.toString​()

已过时。

注意： Event类已过时，仅适用于向后兼容性。

String

FlowLayout.toString​()

返回此 FlowLayout对象及其值的字符串表示形式。

String

Font.toString​()

将此 Font对象转换为 String表示。

String

FontMetrics.toString​()

返回此 FontMetrics对象的值作为 String 。

String

Graphics.toString​()

返回 String表示此对象 Graphics对象的值。

String

GridBagLayout.toString​()

返回此网格包布局值的字符串表示形式。

String

GridLayout.toString​()

返回此网格布局值的字符串表示形式。

String

Insets.toString​()

返回此 Insets对象的字符串表示形式。

String

JobAttributes.toString​()

返回此JobAttributes的字符串表示形式。

String

MenuComponent.toString​()

以字符串形式返回此菜单组件的表示。

String

MenuShortcut.toString​()

返回MenuShortcut的国际化描述。

String

PageAttributes.toString​()

返回此PageAttributes的字符串表示形式。

String

Point.toString​()

在 (x,y)坐标空间中返回此点及其位置的字符串表示形式。

String

Rectangle.toString​()

返回一个 String代表这个 Rectangle及其值。

String

RenderingHints.toString​()

返回hashmap的相当长的字符串表示形式，其中包含键值与该 RenderingHints对象的值的映射。

String

Robot.toString​()

返回此Robot的字符串表示形式。

String

ScrollPaneAdjustable.toString​()

返回此滚动条及其值的字符串表示形式。

String

SystemColor.toString​()

返回此 Color的值的字符串表示形式。

Methods in java.awt with parameters of type String

Modifier and Type

方法

描述

void

Choice.add​(String item)

在 Choice菜单中添加一个项目。

Component

Container.add​(String name, Component comp)

将指定的组件添加到此容器。

void

List.add​(String item)

将指定的项目添加到滚动列表的末尾。

void

List.add​(String item, int index)

在指定的位置将指定的项目添加到滚动列表。

void

Menu.add​(String label)

将具有指定标签的项目添加到此菜单。

void

Choice.addItem​(String item)

作为Java 2平台v1.1的过时。

void

List.addItem​(String item)

已过时。
替换为add(String) 。

void

List.addItem​(String item, int index)

已过时。
替换为add(String, int) 。

void

BorderLayout.addLayoutComponent​(String name, Component comp)

已过时。
替换为addLayoutComponent(Component, Object) 。

void

CardLayout.addLayoutComponent​(String name, Component comp)

已过时。
替换为addLayoutComponent(Component, Object) 。

void

FlowLayout.addLayoutComponent​(String name, Component comp)

将指定的组件添加到布局。

void

GridBagLayout.addLayoutComponent​(String name, Component comp)

没有效果，因为此布局管理器不使用每个组件字符串。

void

GridLayout.addLayoutComponent​(String name, Component comp)

将具有指定名称的指定组件添加到布局。

void

LayoutManager.addLayoutComponent​(String name, Component comp)

如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与 name指定的字符串相关联。

void

Component.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)

将PropertyChangeListener添加到特定属性的侦听器列表中。

void

Container.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)

将PropertyChangeListener添加到特定属性的侦听器列表中。

void

KeyboardFocusManager.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)

将PropertyChangeListener添加到特定属性的侦听器列表中。

void

SystemTray.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)

将 PropertyChangeListener添加到特定属性的侦听器列表中。

void

Toolkit.addPropertyChangeListener​(String name, PropertyChangeListener pcl)

为指定的桌面属性添加指定的属性更改侦听器。

void

Window.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)

将PropertyChangeListener添加到特定属性的侦听器列表中。

void

KeyboardFocusManager.addVetoableChangeListener​(String propertyName, VetoableChangeListener listener)

将VetoableChangeListener添加到特定属性的侦听器列表中。

void

TextArea.append​(String str)

将给定的文本附加到文本区域的当前文本。

void

TextArea.appendText​(String str)

已过时。
从JDK 1.1版开始，由append(String)替代。

void

Window.applyResourceBundle​(String rbName)

已过时。
截至J2SE 1.4，由Component.applyComponentOrientation替代。

int

Font.canDisplayUpTo​(String str)

表示此 Font是否可以显示指定的 String 。

Cursor

Toolkit.createCustomCursor​(Image cursor, Point hotSpot, String name)

创建一个新的自定义光标对象。

GlyphVector

Font.createGlyphVector​(FontRenderContext frc, String str)

根据Font中的Unicode cmap，将字符映射到字形，创建一个Font 。

abstract Image

Toolkit.createImage​(String filename)

返回从指定文件获取像素数据的图像。

static Color

Color.decode​(String nm)

将 String转换为整数，并返回指定的不透明度 Color 。

static Font

Font.decode​(String str)

返回 Font ，该 str参数描述。

void

TrayIcon.displayMessage​(String caption, String text, TrayIcon.MessageType messageType)

在托盘图标附近显示弹出消息。

abstract void

Graphics.drawString​(String str, int x, int y)

使用该图形上下文的当前字体和颜色绘制由指定字符串给出的文本。

abstract void

Graphics2D.drawString​(String str, float x, float y)

使用 Graphics2D上下文中的当前文本属性状态呈现由指定的 String指定的文本。

abstract void

Graphics2D.drawString​(String str, int x, int y)

使用 Graphics2D上下文中的当前文本属性状态呈现指定的 String的文本。

protected void

Component.firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)

支持报告布尔属性的绑定属性更改。

void

Component.firePropertyChange​(String propertyName, byte oldValue, byte newValue)

报告绑定属性更改。

void

Component.firePropertyChange​(String propertyName, char oldValue, char newValue)

报告绑定属性更改。

void

Component.firePropertyChange​(String propertyName, double oldValue, double newValue)

报告绑定属性更改。

void

Component.firePropertyChange​(String propertyName, float oldValue, float newValue)

报告绑定属性更改。

protected void

Component.firePropertyChange​(String propertyName, int oldValue, int newValue)

支持报告整数属性的绑定属性更改。

void

Component.firePropertyChange​(String propertyName, long oldValue, long newValue)

报告绑定属性更改。

void

Component.firePropertyChange​(String propertyName, short oldValue, short newValue)

报告绑定属性更改。

protected void

Component.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告对象属性的绑定属性更改。

protected void

KeyboardFocusManager.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

触发PropertyChangeEvent以响应绑定属性的更改。

protected void

KeyboardFocusManager.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)

触发PropertyChangeEvent以响应否决权属性的更改。

static AWTKeyStroke

AWTKeyStroke.getAWTKeyStroke​(String s)

解析一个字符串并返回一个 AWTKeyStroke 。

static Color

Color.getColor​(String nm)

在系统属性中查找颜色。

static Color

Color.getColor​(String nm, int v)

在系统属性中查找颜色。

static Color

Color.getColor​(String nm, Color v)

在系统属性中查找颜色。

Object

Toolkit.getDesktopProperty​(String propertyName)

获取指定的桌面属性的值。

static Font

Font.getFont​(String nm)

从系统属性列表中返回一个 Font对象。

static Font

Font.getFont​(String nm, Font font)

从系统属性列表获取指定的 Font 。

abstract Image

Toolkit.getImage​(String filename)

返回从指定文件获取像素数据的图像，其格式可以是GIF，JPEG或PNG。

LineMetrics

Font.getLineMetrics​(String str, int beginIndex, int limit, FontRenderContext frc)

返回使用指定参数创建的对象 LineMetrics 。

LineMetrics

Font.getLineMetrics​(String str, FontRenderContext frc)

返回使用指定的String和FontRenderContext创建的LineMetrics对象。

LineMetrics

FontMetrics.getLineMetrics​(String str, int beginIndex, int limit, Graphics context)

在指定的Graphics上下文中返回指定的String的LineMetrics对象。

LineMetrics

FontMetrics.getLineMetrics​(String str, Graphics context)

返回指定的Graphics上下文中指定的String的LineMetrics对象。

PrintJob

Toolkit.getPrintJob​(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)

获取 PrintJob对象，这是在工具包的平台上启动打印操作的结果。

abstract PrintJob

Toolkit.getPrintJob​(Frame frame, String jobtitle, Properties props)

获取一个 PrintJob对象，这是在工具包的平台上启动打印操作的结果。

abstract Object

Image.getProperty​(String name, ImageObserver observer)

通过名称获取此图像的属性。

static String

Toolkit.getProperty​(String key, String defaultValue)

获取具有指定键和默认值的属性。

PropertyChangeListener[]

Component.getPropertyChangeListeners​(String propertyName)

返回与named属性相关联的所有侦听器的数组。

PropertyChangeListener[]

KeyboardFocusManager.getPropertyChangeListeners​(String propertyName)

返回与named属性相关联的所有 PropertyChangeListener的数组。

PropertyChangeListener[]

SystemTray.getPropertyChangeListeners​(String propertyName)

返回与named属性相关联的所有侦听器的数组。

PropertyChangeListener[]

Toolkit.getPropertyChangeListeners​(String propertyName)

返回与指定的桌面属性名称相关联的所有属性更改侦听器的数组。

Rectangle2D

Font.getStringBounds​(String str, int beginIndex, int limit, FontRenderContext frc)

返回指定的 String中指定的 FontRenderContext的逻辑边界。

Rectangle2D

Font.getStringBounds​(String str, FontRenderContext frc)

返回指定的 String中指定的 FontRenderContext的逻辑边界。

Rectangle2D

FontMetrics.getStringBounds​(String str, int beginIndex, int limit, Graphics context)

返回指定的 Graphics上下文中指定的 String的边界。

Rectangle2D

FontMetrics.getStringBounds​(String str, Graphics context)

返回指定的 Graphics上下文中指定的 String的边界。

static Cursor

Cursor.getSystemCustomCursor​(String name)

返回与指定名称匹配的特定于系统的自定义游标对象。

VetoableChangeListener[]

KeyboardFocusManager.getVetoableChangeListeners​(String propertyName)

返回与命名属性相关联的所有 VetoableChangeListener的数组。

void

Choice.insert​(String item, int index)

在指定位置将项目插入此选项。

void

Menu.insert​(String label, int index)

在指定位置的菜单中插入带有指定标签的菜单项。

void

TextArea.insert​(String str, int pos)

在此文本区域的指定位置插入指定的文本。

void

TextArea.insertText​(String str, int pos)

已过时。
从JDK 1.1版起，由insert(String, int)取代。

protected Object

Toolkit.lazilyLoadDesktopProperty​(String name)

懒惰评估桌面属性值的机会。

void

Choice.remove​(String item)

从 Choice菜单中删除 item的首次出现。

void

List.remove​(String item)

从列表中删除项目的第一次出现。

void

Component.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)

从侦听器列表中删除特定属性的 PropertyChangeListener 。

void

KeyboardFocusManager.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)

从侦听器列表中为特定属性移除PropertyChangeListener。

void

SystemTray.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)

从侦听器列表中删除特定属性的 PropertyChangeListener 。

void

Toolkit.removePropertyChangeListener​(String name, PropertyChangeListener pcl)

为指定的桌面属性移除指定的属性更改侦听器。

void

KeyboardFocusManager.removeVetoableChangeListener​(String propertyName, VetoableChangeListener listener)

从侦听器列表中为特定属性删除VetoableChangeListener。

void

List.replaceItem​(String newValue, int index)

使用新的字符串替换滚动列表中指定索引处的项目。

void

TextArea.replaceRange​(String str, int start, int end)

将指定的开始和结束位置之间的文本替换为指定的替换文本。

void

TextArea.replaceText​(String str, int start, int end)

已过时。
从JDK 1.1版开始，由replaceRange(String, int, int)替代。

protected static void

AWTEventMulticaster.save​(ObjectOutputStream s, String k, EventListener l)

将可序列化的监听器链保存到序列化流。

protected void

AWTEventMulticaster.saveInternal​(ObjectOutputStream s, String k)

序列化支持。

void

Choice.select​(String str)

将此 Choice菜单中的选定项目设置为名称等于指定字符串的项目。

void

Button.setActionCommand​(String command)

设置此按钮触发的操作事件的命令名称。

void

MenuItem.setActionCommand​(String command)

设置此菜单项触发的操作事件的命令名称。

void

TrayIcon.setActionCommand​(String command)

设置此托盘图标触发的操作事件的命令名称。

protected void

Toolkit.setDesktopProperty​(String name, Object newValue)

将指定的桌面属性设置为指定的值，并触发属性更改事件以通知任何侦听器该值已更改。

void

FileDialog.setDirectory​(String dir)

将此文件对话框窗口的目录设置为指定的目录。

void

FileDialog.setFile​(String file)

将此文件对话框窗口的选定文件设置为指定的文件。

void

JobAttributes.setFileName​(String fileName)

指定使用这些属性的作业的输出文件的文件名。

void

Taskbar.setIconBadge​(String badge)

在该应用程序的图标上贴上一个小系统提供的徽章。

void

Button.setLabel​(String label)

将按钮的标签设置为指定的字符串。

void

Checkbox.setLabel​(String label)

将此复选框的标签设置为字符串参数。

void

MenuItem.setLabel​(String label)

将此菜单项的标签设置为指定的标签。

void

Component.setName​(String name)

将组件的名称设置为指定的字符串。

void

MenuComponent.setName​(String name)

将组件的名称设置为指定的字符串。

void

JobAttributes.setPrinter​(String printer)

使用这些属性指定作业的目标打印机。

void

Label.setText​(String text)

将此标签的文本设置为指定的文本。

void

TextComponent.setText​(String t)

将此文本组件呈现的文本设置为指定的文本。

void

TextField.setText​(String t)

将此文本组件呈现的文本设置为指定的文本。

void

Dialog.setTitle​(String title)

设置对话框的标题。

void

FileDialog.setTitle​(String title)

设置对话框的标题。

void

Frame.setTitle​(String title)

将此框架的标题设置为指定的字符串。

void

TrayIcon.setToolTip​(String tooltip)

设置此 TrayIcon的工具提示字符串。

void

CardLayout.show​(Container parent, String name)

使用指定的 name ，使用 addLayoutComponent翻转到添加到此布局的组件。

int

FontMetrics.stringWidth​(String str)

返回显示指定的总的超前宽度 String在此 Font 。

static Component.BaselineResizeBehavior

Component.BaselineResizeBehavior.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Desktop.Action

Desktop.Action.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Dialog.ModalExclusionType

Dialog.ModalExclusionType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Dialog.ModalityType

Dialog.ModalityType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static GraphicsDevice.WindowTranslucency

GraphicsDevice.WindowTranslucency.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static MultipleGradientPaint.ColorSpaceType

MultipleGradientPaint.ColorSpaceType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static MultipleGradientPaint.CycleMethod

MultipleGradientPaint.CycleMethod.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Taskbar.Feature

Taskbar.Feature.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Taskbar.State

Taskbar.State.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TrayIcon.MessageType

TrayIcon.MessageType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Window.Type

Window.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.awt with parameters of type String

Constructor

描述

AWTError​(String msg)

使用指定的详细消息构造一个 AWTError的实例。

AWTException​(String msg)

构造具有指定详细消息的 AWTException实例。

AWTPermission​(String name)

创建一个具有指定名称的新的 AWTPermission 。

AWTPermission​(String name, String actions)

使用指定的名称创建一个新的 AWTPermission对象。

Button​(String label)

构造具有指定标签的按钮。

Checkbox​(String label)

创建一个带有指定标签的复选框。

Checkbox​(String label, boolean state)

创建一个带有指定标签的复选框，并设置指定的状态。

Checkbox​(String label, boolean state, CheckboxGroup group)

构造具有指定标签的复选框，设置为指定的状态，并在指定的复选框组中。

Checkbox​(String label, CheckboxGroup group, boolean state)

在指定的复选框组中创建带有指定标签的复选框，并设置为指定的状态。

CheckboxMenuItem​(String label)

创建带有指定标签的复选框菜单项。

CheckboxMenuItem​(String label, boolean state)

创建带有指定标签和状态的复选框菜单项。

Cursor​(String name)

使用指定的名称创建一个新的自定义游标对象。

Dialog​(Dialog owner, String title)

构造一个最初看不见的，无模式的 Dialog与指定的所有者 Dialog和标题。

Dialog​(Dialog owner, String title, boolean modal)

构造最初不可见的 Dialog与指定的所有者 Dialog ，标题和模态。

Dialog​(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)

构造最初不可见的 Dialog与指定的所有者 Dialog ，标题，模态和 GraphicsConfiguration 。

Dialog​(Frame owner, String title)

构造一个初始隐形的，无指定的 Dialog与指定的所有者 Frame和标题。

Dialog​(Frame owner, String title, boolean modal)

构造最初无形 Dialog与指定的所有者 Frame ，标题和模态。

Dialog​(Frame owner, String title, boolean modal, GraphicsConfiguration gc)

构造最初不可见的 Dialog与指定的所有者 Frame ，标题，模式和 GraphicsConfiguration 。

Dialog​(Window owner, String title)

构造一个最初看不见的，无指定的 Dialog与指定的所有者 Window和标题。

Dialog​(Window owner, String title, Dialog.ModalityType modalityType)

构造最初不可见的 Dialog与指定的所有者 Window ，标题和模态。

Dialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)

构造最初不可见的 Dialog与指定的所有者 Window ，标题，模式和 GraphicsConfiguration 。

FileDialog​(Dialog parent, String title)

创建一个文件对话框窗口，其中包含用于加载文件的指定标题。

FileDialog​(Dialog parent, String title, int mode)

创建一个带有指定标题的文件对话窗口，用于加载或保存文件。

FileDialog​(Frame parent, String title)

创建一个文件对话框窗口，其中包含用于加载文件的指定标题。

FileDialog​(Frame parent, String title, int mode)

创建一个带有指定标题的文件对话窗口，用于加载或保存文件。

Font​(String name, int style, int size)

从指定的名称，样式和点大小创建一个新的 Font 。

FontFormatException​(String reason)

报告FontFormatException为指定的原因。

Frame​(String title)

构造一个新的，最初不可见的 Frame对象，具有指定的标题。

Frame​(String title, GraphicsConfiguration gc)

构造一个新的，最初不可见的 Frame对象与指定的标题和一个 GraphicsConfiguration 。

HeadlessException​(String msg)

使用指定的详细错误消息创建一个新实例。

IllegalComponentStateException​(String s)

构造具有指定详细消息的IllegalComponentStateException。

JobAttributes​(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)

为每个属性构造具有指定值的 JobAttributes实例。

Label​(String text)

用指定的文本字符串构造一个新的标签，左对齐。

Label​(String text, int alignment)

构造一个新的标签，以指定的对齐方式显示指定的文本字符串。

Menu​(String label)

构造一个带有指定标签的新菜单。

Menu​(String label, boolean tearOff)

构造具有指定标签的新菜单，指示菜单是否可以被拆除。

MenuItem​(String label)

使用指定的标签构建一个新的MenuItem，而不需要键盘快捷方式。

MenuItem​(String label, MenuShortcut s)

创建一个带有相关键盘快捷方式的菜单项。

PopupMenu​(String label)

创建一个具有指定名称的新弹出菜单。

TextArea​(String text)

构造具有指定文本的新文本区域。

TextArea​(String text, int rows, int columns)

构造具有指定文本的新文本区域，并具有指定的行数和列数。

TextArea​(String text, int rows, int columns, int scrollbars)

构造具有指定文本的新文本区域，并按照指定的行，列和滚动条可见性构造。

TextField​(String text)

构造一个使用指定文本初始化的新文本字段。

TextField​(String text, int columns)

构造一个新的文本字段，并使用指定的文本进行初始化，以便显示，并且足够宽以容纳指定的列数。

TrayIcon​(Image image, String tooltip)

创建具有指定图像和工具提示文本的 TrayIcon 。

TrayIcon​(Image image, String tooltip, PopupMenu popup)

创建一个 TrayIcon与指定的图像，工具提示和弹出菜单。

Uses of String in java.awt.color

Methods in java.awt.color that return String

Modifier and Type

方法

描述

String

ColorSpace.getName​(int idx)

返回给定组件索引的组件的名称。

Methods in java.awt.color with parameters of type String

Modifier and Type

方法

描述

static ICC_Profile

ICC_Profile.getInstance​(String fileName)

构造与文件中数据对应的ICC_Profile。

void

ICC_Profile.write​(String fileName)

将此ICC_Profile写入文件。

Constructors in java.awt.color with parameters of type String

Constructor

描述

CMMException​(String s)

构造具有指定详细消息的CMMException。

ProfileDataException​(String s)

构造具有指定详细消息的ProfileDataException。

Uses of String in java.awt.datatransfer

Fields in java.awt.datatransfer declared as String

Modifier and Type

Field

描述

static String

DataFlavor.javaJVMLocalObjectMimeType

要将引用传递给不具有关联的MIME内容类型的任意Java对象引用，通过在同一JVM中的 Transferable接口，将 DataFlavor具有此类型/子类型的 representationClass ，其中 representationClass等于类/接口的类型正在通过 Transferable 。

static String

DataFlavor.javaRemoteObjectMimeType

为了通过拖放 ACTION_LINK操作将实时链接传递给远程对象， ACTION_LINK使用Mime Content应用程序类型/ x-java-remote-object，其中 DataFlavor的表示类表示 Remote接口的类型被转移。

static String

DataFlavor.javaSerializedObjectMimeType

MIME内容 - 应用程序类型/ x-java-serialized-object表示已被持久化的Java对象的图形。

Methods in java.awt.datatransfer that return String

Modifier and Type

方法

描述

static String

SystemFlavorMap.decodeJavaMIMEType​(String nat)

解码一个 String本机用作Java MIME类型。

static String

SystemFlavorMap.encodeDataFlavor​(DataFlavor flav)

编码 DataFlavor用作 String本机。

static String

SystemFlavorMap.encodeJavaMIMEType​(String mimeType)

对MIME类型进行编码，以 String本机的 String 。

String

DataFlavor.getDefaultRepresentationClassAsString​()

返回默认表示类的名称。

String

DataFlavor.getHumanPresentableName​()

返回此 DataFlavor表示的数据格式的人类可呈现的名称。

String

DataFlavor.getMimeType​()

返回此 DataFlavor的MIME类型字符串。

String

Clipboard.getName​()

返回此剪贴板对象的名称。

String

DataFlavor.getParameter​(String paramName)

如果 paramName等于“humanPresentableName”，则返回此 DataFlavor的人性化名称。

String

DataFlavor.getPrimaryType​()

返回此 DataFlavor的主MIME类型。

String

DataFlavor.getSubType​()

返回此 DataFlavor的子MIME类型。

protected String

DataFlavor.normalizeMimeType​(String mimeType)

已过时。
此方法从1.1开始就不会被此实现所调用

protected String

DataFlavor.normalizeMimeTypeParameter​(String parameterName, String parameterValue)

已过时。
此方法从1.1开始就不会被此实现所调用

String

DataFlavor.toString​()

这个 DataFlavor字符串表示及其参数。

Methods in java.awt.datatransfer that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,DataFlavor>

FlavorMap.getFlavorsForNatives​(String[] natives)

返回一个 Map的 String本地人对应的 DataFlavor 。

Map<String,DataFlavor>

SystemFlavorMap.getFlavorsForNatives​(String[] natives)

返回 Map的 String原住民最喜欢的 DataFlavor 。

List<String>

FlavorTable.getNativesForFlavor​(DataFlavor flav)

返回 List的 String当地人到指定 DataFlavor对应。

List<String>

SystemFlavorMap.getNativesForFlavor​(DataFlavor flav)

返回 List的 String本地人，数据传输子系统可以转换指定的 DataFlavor 。

Map<DataFlavor,String>

FlavorMap.getNativesForFlavors​(DataFlavor[] flavors)

将 Map的 DataFlavor为相应的 String本机。

Map<DataFlavor,String>

SystemFlavorMap.getNativesForFlavors​(DataFlavor[] flavors)

返回 Map的 DataFlavor他们最喜欢的 String本机。

Methods in java.awt.datatransfer with parameters of type String

Modifier and Type

方法

描述

void

SystemFlavorMap.addFlavorForUnencodedNative​(String nat, DataFlavor flav)

将一个从一个 String本机的映射添加到一个 DataFlavor 。

void

SystemFlavorMap.addUnencodedNativeForFlavor​(DataFlavor flav, String nat)

将指定的 DataFlavor （和所有 DataFlavor s等于指定的 DataFlavor ）的映射添加到指定的 String本机。

static DataFlavor

SystemFlavorMap.decodeDataFlavor​(String nat)

解码 String本机用作 DataFlavor 。

static String

SystemFlavorMap.decodeJavaMIMEType​(String nat)

解码一个 String本机用作Java MIME类型。

static String

SystemFlavorMap.encodeJavaMIMEType​(String mimeType)

将MIME类型编码为 String本机。

boolean

DataFlavor.equals​(String s)

已过时。
与hashCode()合同不一致，请改用DataFlavor.isMimeTypeEqual(String) 。

List<DataFlavor>

FlavorTable.getFlavorsForNative​(String nat)

返回 List的 DataFlavor s到其指定的 String对应。

List<DataFlavor>

SystemFlavorMap.getFlavorsForNative​(String nat)

返回 List的 DataFlavor ，其中指定的 String本机可以由数据传输子系统翻译。

Map<String,DataFlavor>

FlavorMap.getFlavorsForNatives​(String[] natives)

返回一个 Map的 String本地人到其对应的 DataFlavor 。

Map<String,DataFlavor>

SystemFlavorMap.getFlavorsForNatives​(String[] natives)

返回 Map指定的 String native到其最优选 DataFlavor 。

String

DataFlavor.getParameter​(String paramName)

如果 paramName等于“humanPresentableName”，则返回此 DataFlavor的人性化名称。

static boolean

SystemFlavorMap.isJavaMIMEType​(String str)

返回指定的 String是否是编码的Java MIME类型。

boolean

DataFlavor.isMimeTypeEqual​(String mimeType)

返回传入的MIME类型的字符串表示是否等同于此 DataFlavor的MIME类型。

protected String

DataFlavor.normalizeMimeType​(String mimeType)

已过时。
此方法从1.1开始就不会被此实现所调用

protected String

DataFlavor.normalizeMimeTypeParameter​(String parameterName, String parameterValue)

已过时。
此方法从1.1开始就不会被此实现所调用

void

SystemFlavorMap.setFlavorsForNative​(String nat, DataFlavor[] flavors)

丢弃指定的 String本机的当前映射，并创建新的映射到指定的 DataFlavor s。

void

DataFlavor.setHumanPresentableName​(String humanPresentableName)

设置 DataFlavor表示的数据格式的人性化名称。

void

SystemFlavorMap.setNativesForFlavor​(DataFlavor flav, String[] natives)

丢弃指定的 DataFlavor的当前映射，所有 DataFlavor s等于指定的 DataFlavor ，并为指定的 String本地人创建新的映射。

protected static Class<?>

DataFlavor.tryToLoadClass​(String className, ClassLoader fallback)

尝试加载一个类：引导加载程序，系统加载程序，上下文加载程序（如果存在），最后指定加载程序。

Constructors in java.awt.datatransfer with parameters of type String

Constructor

描述

Clipboard​(String name)

创建剪贴板对象。

DataFlavor​(Class<?> representationClass, String humanPresentableName)

构造一个代表Java类的 DataFlavor 。

DataFlavor​(String mimeType)

从一个 mimeType字符串构造一个 DataFlavor 。

DataFlavor​(String mimeType, String humanPresentableName)

构造一个 DataFlavor代表一个 MimeType 。

DataFlavor​(String mimeType, String humanPresentableName, ClassLoader classLoader)

构造一个 DataFlavor代表一个 MimeType 。

MimeTypeParseException​(String s)

构造具有指定详细消息的MimeTypeParseException。

StringSelection​(String data)

创建 Transferable能够传送所述指定的 String 。

Uses of String in java.awt.desktop

Methods in java.awt.desktop that return String

Modifier and Type

方法

描述

String

OpenFilesEvent.getSearchTerm​()

获取搜索字词。

Methods in java.awt.desktop with parameters of type String

Modifier and Type

方法

描述

static QuitStrategy

QuitStrategy.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static UserSessionEvent.Reason

UserSessionEvent.Reason.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.awt.desktop with parameters of type String

Constructor

描述

OpenFilesEvent​(List<File> files, String searchTerm)

构造一个 OpenFilesEvent

Uses of String in java.awt.dnd

Constructors in java.awt.dnd with parameters of type String

Constructor

描述

InvalidDnDOperationException​(String msg)

使用自己的描述性消息创建异常

Uses of String in java.awt.event

Methods in java.awt.event that return String

Modifier and Type

方法

描述

String

ActionEvent.getActionCommand​()

返回与此操作相关联的命令字符串。

static String

KeyEvent.getKeyModifiersText​(int modifiers)

已过时。
建议使用扩展修饰键和InputEvent.getModifiersExText(int)

static String

KeyEvent.getKeyText​(int keyCode)

返回一个描述keyCode的String，如“HOME”，“F1”或“A”。

static String

InputEvent.getModifiersExText​(int modifiers)

返回一个描述扩展修饰符键和鼠标按钮的字符串，例如“Shift”，“Button1”或“Ctrl + Shift”。

static String

MouseEvent.getMouseModifiersText​(int modifiers)

返回一个 String实例，描述在事件期间关闭的修改键和鼠标按钮，例如“Shift”或“Ctrl + Shift”。

String

ActionEvent.paramString​()

返回标识此操作事件的参数字符串。

String

AdjustmentEvent.paramString​()

String

ComponentEvent.paramString​()

返回标识此事件的参数字符串。

String

ContainerEvent.paramString​()

返回标识此事件的参数字符串。

String

FocusEvent.paramString​()

返回标识此事件的参数字符串。

String

HierarchyEvent.paramString​()

返回标识此事件的参数字符串。

String

InputMethodEvent.paramString​()

返回标识此事件的参数字符串。

String

InvocationEvent.paramString​()

返回标识此事件的参数字符串。

String

ItemEvent.paramString​()

返回标识此项事件的参数字符串。

String

KeyEvent.paramString​()

返回标识此事件的参数字符串。

String

MouseEvent.paramString​()

返回标识此事件的参数字符串。

String

MouseWheelEvent.paramString​()

返回标识此事件的参数字符串。

String

PaintEvent.paramString​()

String

TextEvent.paramString​()

返回标识此文本事件的参数字符串。

String

WindowEvent.paramString​()

返回标识此事件的参数字符串。

Methods in java.awt.event with parameters of type String

Modifier and Type

方法

描述

static FocusEvent.Cause

FocusEvent.Cause.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.awt.event with parameters of type String

Constructor

描述

ActionEvent​(Object source, int id, String command)

构造一个 ActionEvent对象。

ActionEvent​(Object source, int id, String command, int modifiers)

使用修饰键构造一个 ActionEvent对象。

ActionEvent​(Object source, int id, String command, long when, int modifiers)

使用指定的修饰符键和时间戳构造一个 ActionEvent对象。

Uses of String in java.awt.font

Methods in java.awt.font that return String

Modifier and Type

方法

描述

String[]

MultipleMaster.getDesignAxisNames​()

返回每个设计轴的名称。

String

NumericShaper.toString​()

返回描述此整形器的 String 。

String

TextHitInfo.toString​()

返回一个 String表示仅用于调试的命中。

String

TextLayout.toString​()

返回此 TextLayout调试信息。

Methods in java.awt.font with parameters of type String

Modifier and Type

方法

描述

byte[]

OpenType.getFontTable​(String strSfntTag)

将表作为指定标记的字节数组返回。

byte[]

OpenType.getFontTable​(String strSfntTag, int offset, int count)

将表的子集作为指定标记的字节数组返回。

int

OpenType.getFontTableSize​(String strSfntTag)

返回指定标记的表的大小。

static NumericShaper.Range

NumericShaper.Range.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.awt.font with parameters of type String

Constructor

描述

TextAttribute​(String name)

构造具有指定名称的 TextAttribute 。

TextLayout​(String string, Font font, FontRenderContext frc)

构造一个TextLayout从String和Font 。

TextLayout​(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)

从一个 String和一个属性集构造一个 TextLayout 。

Uses of String in java.awt.geom

Methods in java.awt.geom that return String

Modifier and Type

方法

描述

String

AffineTransform.toString​()

返回一个表示String的值的String 。

String

Point2D.Double.toString​()

返回一个表示 String的值的 Point2D 。

String

Point2D.Float.toString​()

返回一个表示 String的值的 Point2D 。

String

Rectangle2D.Double.toString​()

返回 String这个 Rectangle2D表示。

String

Rectangle2D.Float.toString​()

返回此 Rectangle2D的 String表示。

Constructors in java.awt.geom with parameters of type String

Constructor

描述

IllegalPathStateException​(String s)

构造具有指定详细消息的 IllegalPathStateException 。

NoninvertibleTransformException​(String s)

使用指定的详细消息构造一个 NoninvertibleTransformException的实例。

Uses of String in java.awt.im.spi

Methods in java.awt.im.spi that return String

Modifier and Type

方法

描述

String

InputMethodDescriptor.getInputMethodDisplayName​(Locale inputLocale, Locale displayLanguage)

以显示名称的语言返回给定输入区域设置的相应输入法的用户可见名称。

Methods in java.awt.im.spi with parameters of type String

Modifier and Type

方法

描述

JFrame

InputMethodContext.createInputMethodJFrame​(String title, boolean attachToInputContext)

创建一个顶级的Swing JFrame以供输入法使用。

Window

InputMethodContext.createInputMethodWindow​(String title, boolean attachToInputContext)

创建一个顶级窗口，供输入法使用。

Uses of String in java.awt.image

Methods in java.awt.image that return String

Modifier and Type

方法

描述

String[]

BufferedImage.getPropertyNames​()

返回一个由 getProperty(String)或 null识别的名称数组，如果没有属性名称被识别。

String[]

RenderedImage.getPropertyNames​()

返回由 getProperty(String)或 null识别的名称数组，如果未识别到属性名称。

String

BufferedImage.toString​()

返回此 BufferedImage对象及其值的 String表示。

String

ColorModel.toString​()

返回此 ColorModel对象的内容的 String表示。

String

DirectColorModel.toString​()

返回一个 String ，代表这个 DirectColorModel 。

String

IndexColorModel.toString​()

返回此 ColorModel对象的内容的 String表示。

Methods in java.awt.image with parameters of type String

Modifier and Type

方法

描述

Object

AbstractMultiResolutionImage.getProperty​(String name, ImageObserver observer)

该方法简单地委托给基本图像上相同的方法，它等同于： getBaseImage().getProperty(name, observer) 。

Object

BufferedImage.getProperty​(String name)

按名称返回图像的属性。

Object

BufferedImage.getProperty​(String name, ImageObserver observer)

按名称返回图像的属性。

Object

RenderedImage.getProperty​(String name)

从该图像的属性集获取属性。

Constructors in java.awt.image with parameters of type String

Constructor

描述

ImagingOpException​(String s)

使用指定的消息构造一个 ImagingOpException对象。

RasterFormatException​(String s)

构造一个新的 RasterFormatException与指定的消息。

Uses of String in java.awt.image.renderable

Fields in java.awt.image.renderable declared as String

Modifier and Type

Field

描述

static String

RenderableImage.HINTS_OBSERVED

可以用于标识通过createRendering或createScaledRendering方法获得的RenderedImage上的属性的字符串常量。

Methods in java.awt.image.renderable that return String

Modifier and Type

方法

描述

String[]

ContextualRenderedImageFactory.getPropertyNames​()

返回由getProperty识别的名称列表。

String[]

RenderableImage.getPropertyNames​()

返回由getProperty识别的名称列表。

String[]

RenderableImageOp.getPropertyNames​()

返回由getProperty识别的名称列表。

Methods in java.awt.image.renderable with parameters of type String

Modifier and Type

方法

描述

Object

ContextualRenderedImageFactory.getProperty​(ParameterBlock paramBlock, String name)

获取由name参数指定的属性的适当实例。

Object

RenderableImage.getProperty​(String name)

从该图像的属性集获取属性。

Object

RenderableImageOp.getProperty​(String name)

从该图像的属性集获取属性。

Uses of String in java.awt.print

Methods in java.awt.print that return String

Modifier and Type

方法

描述

abstract String

PrinterJob.getJobName​()

获取要打印的文档的名称。

abstract String

PrinterJob.getUserName​()

获取打印用户的名称。

Methods in java.awt.print with parameters of type String

Modifier and Type

方法

描述

static StreamPrintServiceFactory[]

PrinterJob.lookupStreamPrintServices​(String mimeType)

一种方便的方法，可以定位可以对2D图形进行图像处理的流打印服务的工厂。

abstract void

PrinterJob.setJobName​(String jobName)

设置要打印的文档的名称。

Constructors in java.awt.print with parameters of type String

Constructor

描述

PrinterAbortException​(String msg)

构造一个新的 PrinterAbortException与指定的详细消息。

PrinterException​(String msg)

构造具有指定详细消息的新的 PrinterException对象。

Uses of String in java.beans

Fields in java.beans declared as String

Modifier and Type

Field

描述

static String

DesignMode.PROPERTYNAME

从BeanContext或PropertyChangeEvents的其他来源触发的propertyName的标准值。

Methods in java.beans that return String

Modifier and Type

方法

描述

static String

Introspector.decapitalize​(String name)

实用方法来取一个字符串并将其转换为正常的Java变量名称大小写。

String

EventHandler.getAction​()

返回此事件处理程序将设置的目标的可写属性的名称，或此事件处理程序将在目标上调用的方法的名称。

String

PropertyEditor.getAsText​()

获取属性值作为文本。

String

PropertyEditorSupport.getAsText​()

获取属性值作为适合演示文稿的字符串进行编辑。

static String[]

Introspector.getBeanInfoSearchPath​()

获取将用于查找BeanInfo类的包名称列表。

String

FeatureDescriptor.getDisplayName​()

获取此功能的本地化显示名称。

static String[]

PropertyEditorManager.getEditorSearchPath​()

获取将搜索属性编辑器的包名称。

String

EventHandler.getEventPropertyName​()

返回在应用于目标的操作中应该使用的事件的属性。

String

PropertyEditor.getJavaInitializationString​()

返回可用于设置属性以匹配编辑器当前状态的Java代码片段。

String

PropertyEditorSupport.getJavaInitializationString​()

此方法用于生成Java代码以设置属性值。

String

EventHandler.getListenerMethodName​()

返回将触发操作的方法的名称。

String

Statement.getMethodName​()

返回要调用的方法的名称。

String

FeatureDescriptor.getName​()

获取此功能的编程名称。

String

PropertyChangeEvent.getPropertyName​()

获取已更改的属性的编程名称。

String

PropertyChangeListenerProxy.getPropertyName​()

返回与侦听器关联的命名属性的名称。

String

VetoableChangeListenerProxy.getPropertyName​()

返回与侦听器关联的命名属性的名称。

String

FeatureDescriptor.getShortDescription​()

获取此功能的简短描述。

String[]

PropertyEditor.getTags​()

如果属性值必须是一组已知标记值，则该方法应返回一个标记数组。

String[]

PropertyEditorSupport.getTags​()

如果属性值必须是一组已知标记值之一，则该方法应返回一个标记值的数组。

String

Expression.toString​()

使用Java风格的语法打印此表达式的值。

String

FeatureDescriptor.toString​()

返回对象的字符串表示形式。

String

PropertyChangeEvent.toString​()

返回对象的字符串表示形式。

String

Statement.toString​()

使用Java风格的语法打印此语句的值。

Methods in java.beans that return types with arguments of type String

Modifier and Type

方法

描述

Enumeration<String>

FeatureDescriptor.attributeNames​()

获取此功能的与区域设置无关的名称的枚举。

Methods in java.beans with parameters of type String

Modifier and Type

方法

描述

void

PropertyChangeSupport.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)

为特定属性添加PropertyChangeListener。

void

VetoableChangeSupport.addVetoableChangeListener​(String propertyName, VetoableChangeListener listener)

为特定属性添加VetoableChangeListener。

static <T> T

EventHandler.create​(Class<T> listenerInterface, Object target, String action)

创建一个 listenerInterface的实现，其中监听器界面中的 所有方法将处理程序的 action应用于 target 。

static <T> T

EventHandler.create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName)

/ **创建 listenerInterface的实现，其中 所有方法将事件表达式 eventPropertyName的值传递给语句中的最终方法， action ，该方法应用于 target 。

static <T> T

EventHandler.create​(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)

创建的实施 listenerInterface其中命名方法 listenerMethodName传递事件表达，的值 eventPropertyName ，在语句中的最终方法， action ，其被施加到 target 。

static String

Introspector.decapitalize​(String name)

实用方法来取一个字符串并将其转换为正常的Java变量名称大小写。

void

PropertyChangeSupport.fireIndexedPropertyChange​(String propertyName, int index, boolean oldValue, boolean newValue)

向已注册的侦听器报告布尔绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

PropertyChangeSupport.fireIndexedPropertyChange​(String propertyName, int index, int oldValue, int newValue)

向已注册的监听器报告整数绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

PropertyChangeSupport.fireIndexedPropertyChange​(String propertyName, int index, Object oldValue, Object newValue)

向已注册的监听器报告绑定的索引属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

PropertyChangeSupport.firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)

向已注册的侦听器报告布尔绑定属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

PropertyChangeSupport.firePropertyChange​(String propertyName, int oldValue, int newValue)

向已注册的监听器报告整数绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

PropertyChangeSupport.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

向已注册的监听器报告绑定的属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

VetoableChangeSupport.fireVetoableChange​(String propertyName, boolean oldValue, boolean newValue)

向已注册的监听器报告布尔约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

VetoableChangeSupport.fireVetoableChange​(String propertyName, int oldValue, int newValue)

向已注册的监听器报告整数约束属性更新，以跟踪所有属性的更新或具有指定名称的属性。

void

VetoableChangeSupport.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)

向已注册的监听器报告受限属性更新，以跟踪所有属性的更新或具有指定名称的属性。

PropertyChangeListener[]

PropertyChangeSupport.getPropertyChangeListeners​(String propertyName)

返回与named属性相关联的所有侦听器的数组。

Object

FeatureDescriptor.getValue​(String attributeName)

使用此功能检索命名属性。

VetoableChangeListener[]

VetoableChangeSupport.getVetoableChangeListeners​(String propertyName)

返回与named属性相关联的所有侦听器的数组。

boolean

PropertyChangeSupport.hasListeners​(String propertyName)

检查是否有特定属性的监听器，包括在所有属性上注册的监听器。

boolean

VetoableChangeSupport.hasListeners​(String propertyName)

检查是否有特定属性的监听器，包括在所有属性上注册的监听器。

static Object

Beans.instantiate​(ClassLoader cls, String beanName)

实例化JavaBean。

static Object

Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)

实例化JavaBean。

static Object

Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)

已过时。
建议使用Beans.instantiate(ClassLoader, String, BeanContext) ，因为Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

Image

SimpleBeanInfo.loadImage​(String resourceName)

这是一种帮助加载图标图像的实用方法。

void

PropertyChangeSupport.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)

删除特定属性的PropertyChangeListener。

void

VetoableChangeSupport.removeVetoableChangeListener​(String propertyName, VetoableChangeListener listener)

删除特定属性的VetoableChangeListener。

void

PropertyEditor.setAsText​(String text)

通过解析给定的字符串来设置属性值。

void

PropertyEditorSupport.setAsText​(String text)

通过解析给定的字符串来设置属性值。

static void

Introspector.setBeanInfoSearchPath​(String[] path)

更改将用于查找BeanInfo类的包名称列表。

void

FeatureDescriptor.setDisplayName​(String displayName)

设置此功能的本地化显示名称。

static void

PropertyEditorManager.setEditorSearchPath​(String[] path)

更改将用于查找属性编辑器的包名称列表。

void

FeatureDescriptor.setName​(String name)

设置此功能的编程名称。

void

FeatureDescriptor.setShortDescription​(String text)

您可以将简短描述性字符串与功能相关联。

void

FeatureDescriptor.setValue​(String attributeName, Object value)

将命名属性与此功能相关联。

Constructors in java.beans with parameters of type String

Constructor

描述

DefaultPersistenceDelegate​(String[] constructorPropertyNames)

为具有构造函数的类创建默认持久性委托，该构造函数的参数是由 constructorPropertyNames指定的属性名称的值。

EventHandler​(Object target, String action, String eventPropertyName, String listenerMethodName)

创建一个新的EventHandler对象; 你通常使用一个create方法，而不是直接调用这个构造函数。

EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)

创建一个 EventSetDescriptor假设您遵循最简单的标准设计模式，其中一个命名事件“fred”（1）作为调用接口FredListener的一个方法传递，（2）具有类型为FredEvent的单个参数， 3）FredListener可以通过对源组件的addFredListener方法的调用进行注册，并通过removeFredListener方法的调用进行删除。

EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)

使用字符串名称从头创建 EventSetDescriptor 。

EventSetDescriptor​(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)

该构造函数使用字符串名称从头开始创建一个EventSetDescriptor。

EventSetDescriptor​(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, 方法 addListenerMethod, 方法 removeListenerMethod)

使用 java.lang.reflect.MethodDescriptor和 java.lang.Class对象从头创建一个 EventSetDescriptor 。

EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod)

使用 java.lang.reflect.Method和 java.lang.Class对象从头开始创建一个 EventSetDescriptor 。

EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod, 方法 getListenerMethod)

此构造函数从头开始使用java.lang.reflect.Method和java.lang.Class对象创建一个EventSetDescriptor。

Expression​(Object value, Object target, String methodName, Object[] arguments)

使用指定的目标对象的指定值创建一个新的Expression对象，以调用由名称和参数数组指定的方法。

Expression​(Object target, String methodName, Object[] arguments)

为指定的目标对象创建一个新的Expression对象，以调用由名称和参数数组指定的方法。

IndexedPropertyChangeEvent​(Object source, String propertyName, Object oldValue, Object newValue, int index)

构造一个新的 IndexedPropertyChangeEvent对象。

IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass)

该构造函数通过使用getFoo和setFoo访问器方法为索引访问和数组访问来构造遵循标准Java约定的属性的IndexedPropertyDescriptor。

IndexedPropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)

此构造函数使用简单属性的名称，以及用于读取和写入属性的方法名称，包括索引和非索引。

IndexedPropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod, 方法 indexedReadMethod, 方法 indexedWriteMethod)

此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。

IntrospectionException​(String mess)

构造一个 IntrospectionException的详细消息。

PropertyChangeEvent​(Object source, String propertyName, Object oldValue, Object newValue)

构造新的 PropertyChangeEvent 。

PropertyChangeListenerProxy​(String propertyName, PropertyChangeListener listener)

构造函数， PropertyChangeListener绑定到特定属性。

PropertyDescriptor​(String propertyName, Class<?> beanClass)

通过使用getFoo和setFoo访问器方法，为遵循标准Java约定的属性构造PropertyDescriptor。

PropertyDescriptor​(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)

该构造函数使用简单属性的名称，以及读取和写入属性的方法名称。

PropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod)

此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。

PropertyVetoException​(String mess, PropertyChangeEvent evt)

构造一个 PropertyVetoException的详细消息。

Statement​(Object target, String methodName, Object[] arguments)

为指定的目标对象创建一个新的Statement对象，以调用由名称和参数数组指定的方法。

VetoableChangeListenerProxy​(String propertyName, VetoableChangeListener listener)

构造函数， VetoableChangeListener绑定到特定属性。

XMLEncoder​(OutputStream out, String charset, boolean declaration, int indentation)

创建一个新的XML编码器 的JavaBeans写出到流 out使用给定 charset从给定的起始 indentation 。

Uses of String in java.beans.beancontext

Methods in java.beans.beancontext with parameters of type String

Modifier and Type

方法

描述

void

BeanContextChild.addPropertyChangeListener​(String name, PropertyChangeListener pcl)

添加一个 PropertyChangeListener到这个 BeanContextChild ，以便每当指定的属性更改时接收一个 PropertyChangeEvent 。

void

BeanContextChildSupport.addPropertyChangeListener​(String name, PropertyChangeListener pcl)

为特定属性添加PropertyChangeListener。

void

BeanContextChild.addVetoableChangeListener​(String name, VetoableChangeListener vcl)

在此 BeanContextChild添加一个 VetoableChangeListener ，以便在指定的属性更改时接收事件。

void

BeanContextChildSupport.addVetoableChangeListener​(String name, VetoableChangeListener vcl)

为特定属性添加VetoableChangeListener。

void

BeanContextChildSupport.firePropertyChange​(String name, Object oldValue, Object newValue)

向任何已注册的监听器报告绑定属性更新。

void

BeanContextChildSupport.fireVetoableChange​(String name, Object oldValue, Object newValue)

向任何已注册的听众报告否决权属性更新。

URL

BeanContext.getResource​(String name, BeanContextChild bcc)

对于 java.lang.ClassLoader.getResource() ，这种方法允许 BeanContext实施介入孩子 Component和底层 ClassLoader之间的行为。

URL

BeanContextSupport.getResource​(String name, BeanContextChild bcc)

InputStream

BeanContext.getResourceAsStream​(String name, BeanContextChild bcc)

对于 java.lang.ClassLoader.getResourceAsStream() ，这种方法允许 BeanContext实现介入孩子 Component和底层 ClassLoader之间的行为。

InputStream

BeanContextSupport.getResourceAsStream​(String name, BeanContextChild bcc)

Object

BeanContext.instantiateChild​(String beanName)

实例化命名为此 BeanContext的小孩的javaBean。

Object

BeanContextSupport.instantiateChild​(String beanName)

instantiateChild方法是BeanContext中的一个方便的钩子，用于简化将Bean实例化的任务嵌套到一个 BeanContext 。

void

BeanContextChild.removePropertyChangeListener​(String name, PropertyChangeListener pcl)

从该 BeanContextChild删除 PropertyChangeListener ，以便在指定的属性更改时不再接收 PropertyChangeEvents 。

void

BeanContextChildSupport.removePropertyChangeListener​(String name, PropertyChangeListener pcl)

删除特定属性的PropertyChangeListener。

void

BeanContextChild.removeVetoableChangeListener​(String name, VetoableChangeListener vcl)

从此 BeanContextChild删除 VetoableChangeListener ，以便在指定的属性更改时不再收到事件。

void

BeanContextChildSupport.removeVetoableChangeListener​(String name, VetoableChangeListener vcl)

删除一个 VetoableChangeListener 。

Uses of String in java.io

Fields in java.io declared as String

Modifier and Type

Field

描述

protected String

StringBufferInputStream.buffer

已过时。

读取字节的字符串。

String

InvalidClassException.classname

无效类的名称

static String

File.pathSeparator

与系统相关的路径分隔符字符，为方便起见，表示为字符串。

static String

File.separator

与系统相关的默认名称 - 分隔符字符，以方便的方式表示为字符串。

String

StreamTokenizer.sval

如果当前令牌是一个单词标记，则该字段包含一个字符串，给出单词令牌的字符。

Methods in java.io that return String

Modifier and Type

方法

描述

String

File.getAbsolutePath​()

返回此抽象路径名的绝对路径名字符串。

String

FilePermission.getActions​()

返回动作的“规范字符串表示”。

String

File.getCanonicalPath​()

返回此抽象路径名的规范路径名字符串。

String

InputStreamReader.getEncoding​()

返回此流使用的字符编码的名称。

String

OutputStreamWriter.getEncoding​()

返回此流使用的字符编码的名称。

String

InvalidClassException.getMessage​()

生成消息并包括类名（如果存在）。

String

WriteAbortedException.getMessage​()

生成消息并将嵌套异常中的消息包含在内。

String

File.getName​()

返回由此抽象路径名表示的文件或目录的名称。

String

ObjectStreamClass.getName​()

返回此描述符描述的类的名称。

String

ObjectStreamField.getName​()

获取此字段的名称。

String

File.getParent​()

返回此抽象路径名的父目录的路径名字符串，如果此路径名未命名为父目录，则返回 null 。

String

File.getPath​()

将此抽象路径名转换为路径名字符串。

String

ObjectStreamField.getTypeString​()

返回JVM类型签名。

String[]

File.list​()

返回一个字符串数组，命名由此抽象路径名表示的目录中的文件和目录。

String[]

File.list​(FilenameFilter filter)

返回一个字符串数组，命名由此抽象路径名表示的目录中满足指定过滤器的文件和目录。

String

BufferedReader.readLine​()

读一行文字。

String

Console.readLine​()

从控制台读取一行文本。

String

Console.readLine​(String fmt, Object... args)

提供一个格式化的提示，然后从控制台读取一行文本。

String

DataInput.readLine​()

从输入流读取下一行文本。

String

DataInputStream.readLine​()

已过时。
此方法无法将字节正确转换为字符。 从JDK 1.1开始，读取文本行的首选方式是通过BufferedReader.readLine()方法。 使用DataInputStream类读取行的程序可以转换为使用BufferedReader类替换以下形式的代码：
     DataInputStream d = new DataInputStream(in);
有：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
String

LineNumberReader.readLine​()

读一行文字。

String

ObjectInputStream.readLine​()

已过时。
此方法无法将字节正确转换为字符。 有关详细信息和替代方案，请参阅DataInputStream。

String

RandomAccessFile.readLine​()

从此文件中读取下一行文本。

String

DataInput.readUTF​()

读取已使用 modified UTF-8格式编码的字符串。

String

DataInputStream.readUTF​()

见 readUTF法 DataInput的一般合同。

static String

DataInputStream.readUTF​(DataInput in)

从流in读取以modified UTF-8格式编码的Unicode字符串的表示; 这个字符串然后作为String返回。

String

ObjectInputStream.readUTF​()

读取字符串 modified UTF-8格式。

String

RandomAccessFile.readUTF​()

从该文件读取字符串。

String

ByteArrayOutputStream.toString​()

使用平台的默认字符集将缓冲区内容转换为字符串解码字节。

String

ByteArrayOutputStream.toString​(int hibyte)

已过时。
此方法无法将字节正确转换为字符。 从JDK 1.1开始，首选的方法是通过toString(String enc)方法，该方法采用encoding-name参数，或toString()方法，该方法使用平台的默认字符编码。

String

ByteArrayOutputStream.toString​(String charsetName)

通过使用命名的charset解码字节将缓冲区的内容转换为字符串。

String

CharArrayWriter.toString​()

将输入数据转换为字符串。

String

File.toString​()

返回此抽象路径名的路径名字符串。

String

ObjectStreamClass.toString​()

返回描述此ObjectStreamClass的字符串。

String

ObjectStreamField.toString​()

返回描述此字段的字符串。

String

StreamTokenizer.toString​()

返回当前流令牌的字符串表示形式及其发生的行号。

String

StringWriter.toString​()

以缓冲区的当前值作为字符串返回。

Methods in java.io that return types with arguments of type String

Modifier and Type

方法

描述

Stream<String>

BufferedReader.lines​()

返回一个 Stream ，其元素是从这个 BufferedReader读取的行。

Methods in java.io with parameters of type String

Modifier and Type

方法

描述

boolean

FilenameFilter.accept​(File dir, String name)

测试指定文件是否应包含在文件列表中。

static ObjectInputFilter

ObjectInputFilter.Config.createFilter​(String pattern)

从一个模式字符串返回一个ObjectInputFilter。

static File

File.createTempFile​(String prefix, String suffix)

在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。

static File

File.createTempFile​(String prefix, String suffix, File directory)

在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。

abstract boolean

ObjectInputStream.GetField.defaulted​(String name)

如果命名字段是默认值，并且此流中没有值，则返回true。

Console

Console.format​(String fmt, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流。

PrintStream

PrintStream.format​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流。

PrintStream

PrintStream.format​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流。

PrintWriter

PrintWriter.format​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此写入程序。

PrintWriter

PrintWriter.format​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此写入程序。

abstract boolean

ObjectInputStream.GetField.get​(String name, boolean val)

从持久化字段获取命名布尔字段的值。

abstract byte

ObjectInputStream.GetField.get​(String name, byte val)

从持久化字段获取命名字节字段的值。

abstract char

ObjectInputStream.GetField.get​(String name, char val)

从持久化字段获取命名的char字段的值。

abstract double

ObjectInputStream.GetField.get​(String name, double val)

从持续字段获取命名的双字段的值。

abstract float

ObjectInputStream.GetField.get​(String name, float val)

从持久化字段获取命名的float字段的值。

abstract int

ObjectInputStream.GetField.get​(String name, int val)

从持久化字段获取命名的int字段的值。

abstract long

ObjectInputStream.GetField.get​(String name, long val)

从持久化字段获取命名的长字段的值。

abstract short

ObjectInputStream.GetField.get​(String name, short val)

从持续字段获取命名的短字段的值。

abstract Object

ObjectInputStream.GetField.get​(String name, Object val)

从持久化字段获取命名的对象字段的值。

ObjectStreamField

ObjectStreamClass.getField​(String name)

通过名称获取此类的字段。

void

PrintStream.print​(String s)

打印字符串。

void

PrintWriter.print​(String s)

打印字符串。

Console

Console.printf​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此控制台的输出流的便利方法。

PrintStream

PrintStream.printf​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。

PrintStream

PrintStream.printf​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此输出流的便利方法。

PrintWriter

PrintWriter.printf​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。

PrintWriter

PrintWriter.printf​(Locale l, String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入该writer的方便方法。

void

PrintStream.println​(String x)

打印一个字符串，然后终止行。

void

PrintWriter.println​(String x)

打印一个字符串，然后终止行。

abstract void

ObjectOutputStream.PutField.put​(String name, boolean val)

将命名布尔字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, byte val)

将命名字节字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, char val)

将命名的char字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, double val)

将命名的双字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, float val)

将命名的浮动字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, int val)

将命名的int字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, long val)

将命名的长字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, short val)

将命名的短字段的值放入持久字段。

abstract void

ObjectOutputStream.PutField.put​(String name, Object val)

将命名的对象字段的值放入持久字段。

String

Console.readLine​(String fmt, Object... args)

提供一个格式化的提示，然后从控制台读取一行文本。

char[]

Console.readPassword​(String fmt, Object... args)

提供一个格式化的提示，然后从禁用回显的控制台读取密码或密码。

protected Class<?>

ObjectInputStream.resolveProxyClass​(String[] interfaces)

返回一个代理类，它实现代理类描述符中命名的接口; 子类可以实现此方法从流中读取自定义数据以及动态代理类的描述符，从而允许它们为接口和代理类使用备用加载机制。

String

ByteArrayOutputStream.toString​(String charsetName)

通过使用命名的charset解码字节将缓冲区的内容转换为字符串。

static ObjectInputFilter.Status

ObjectInputFilter.Status.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

void

BufferedWriter.write​(String s, int off, int len)

写一个字符串的一部分。

void

CharArrayWriter.write​(String str, int off, int len)

将一部分字符串写入缓冲区。

void

FilterWriter.write​(String str, int off, int len)

写一个字符串的一部分。

void

OutputStreamWriter.write​(String str, int off, int len)

写一个字符串的一部分。

void

PrintWriter.write​(String s)

写一个字符串

void

PrintWriter.write​(String s, int off, int len)

写一个字符串的一部分。

void

StringWriter.write​(String str)

写一个字符串

void

StringWriter.write​(String str, int off, int len)

写一个字符串的一部分

void

Writer.write​(String str)

写一个字符串

void

Writer.write​(String str, int off, int len)

写一个字符串的一部分。

void

DataOutput.writeBytes​(String s)

将一个字符串写入输出流。

void

DataOutputStream.writeBytes​(String s)

将字符串作为字节序列写入基础输出流。

void

ObjectOutputStream.writeBytes​(String str)

写一个字符串作为字节序列。

void

RandomAccessFile.writeBytes​(String s)

将字符串作为字节序列写入文件。

void

DataOutput.writeChars​(String s)

将字符串 s中的每个字符写入输出流，按顺序排列每个字符两个字节。

void

DataOutputStream.writeChars​(String s)

将字符串写入底层输出流作为一系列字符。

void

ObjectOutputStream.writeChars​(String str)

写一个字符串作为一系列的字符。

void

RandomAccessFile.writeChars​(String s)

将一个字符串作为字符序列写入文件。

void

DataOutput.writeUTF​(String s)

将两个字节写入的长度信息到输出流，接着是 modified UTF-8的每个字符的字符串中表示 s 。

void

DataOutputStream.writeUTF​(String str)

使用机器无关的方式使用 modified UTF-8编码将字符串写入底层输出流。

void

ObjectOutputStream.writeUTF​(String str)

该字符串的原始数据写入格式为 modified UTF-8 。

void

RandomAccessFile.writeUTF​(String str)

使用机器独立的方式使用 modified UTF-8编码将字符串写入文件。

Constructors in java.io with parameters of type String

Constructor

描述

CharConversionException​(String s)

这提供了详细的信息。

EOFException​(String s)

构造具有指定的详细消息的 EOFException 。

File​(File parent, String child)

从父抽象路径名和子路径名字符串创建新的 File实例。

File​(String pathname)

通过将给定的路径名字符串转换为抽象路径名来创建新的 File实例。

File​(String parent, String child)

从父路径名字符串和子路径名字符串创建新的 File实例。

FileInputStream​(String name)

通过打开与实际文件的连接来创建 FileInputStream ，该文件由文件系统中的路径名称为 name命名。

FileNotFoundException​(String s)

构造具有指定详细消息的 FileNotFoundException 。

FileOutputStream​(String name)

创建文件输出流以指定的名称写入文件。

FileOutputStream​(String name, boolean append)

创建文件输出流以指定的名称写入文件。

FilePermission​(String path, String actions)

使用指定的操作创建一个新的FilePermission对象。

FileReader​(String fileName)

创建一个新的 FileReader ，给定要读取的文件的名称。

FileWriter​(String fileName)

构造一个给定文件名的FileWriter对象。

FileWriter​(String fileName, boolean append)

构造一个FileWriter对象，给出一个带有布尔值的文件名，表示是否附加写入的数据。

InputStreamReader​(InputStream in, String charsetName)

创建一个使用命名字符集的InputStreamReader。

InterruptedIOException​(String s)

构造具有指定详细消息的 InterruptedIOException 。

InvalidClassException​(String reason)

针对指定的原因报告InvalidClassException。

InvalidClassException​(String cname, String reason)

构造一个InvalidClassException对象。

InvalidObjectException​(String reason)

构造一个 InvalidObjectException 。

IOException​(String message)

构造具有指定详细消息的 IOException 。

IOException​(String message, Throwable cause)

构造具有指定的详细信息和原因的 IOException 。

NotActiveException​(String reason)

构造函数创建一个新的NotActiveException与给定的原因。

NotSerializableException​(String classname)

构造带有消息字符串的NotSerializableException对象。

ObjectStreamException​(String message)

使用指定的参数创建一个ObjectStreamException。

ObjectStreamField​(String name, Class<?> type)

创建一个具有指定类型的Serializable字段。

ObjectStreamField​(String name, Class<?> type, boolean unshared)

创建一个ObjectStreamField，表示具有给定名称和类型的可序列化字段。

OutputStreamWriter​(OutputStream out, String charsetName)

创建一个使用命名字符集的OutputStreamWriter。

PrintStream​(File file, String csn)

使用指定的文件和字符集创建新的打印流，而不需要自动换行。

PrintStream​(OutputStream out, boolean autoFlush, String encoding)

创建一个新的打印流。

PrintStream​(String fileName)

使用指定的文件名创建新的打印流，无需自动换行。

PrintStream​(String fileName, String csn)

创建一个新的打印流，不需要自动换行，具有指定的文件名和字符集。

PrintWriter​(File file, String csn)

使用指定的文件和字符集创建一个新的PrintWriter，而不需要自动进行线条刷新。

PrintWriter​(String fileName)

使用指定的文件名创建一个新的PrintWriter，而不需要自动执行行刷新。

PrintWriter​(String fileName, String csn)

使用指定的文件名和字符集创建一个新的PrintWriter，而不需要自动线路刷新。

RandomAccessFile​(File file, String mode)

创建一个随机访问文件流从File参数指定的文件中读取并可选地写入。

RandomAccessFile​(String name, String mode)

创建随机访问文件流，以从中指定名称的文件读取，并可选择写入文件。

SerializablePermission​(String name)

创建一个具有指定名称的新SerializablePermission。

SerializablePermission​(String name, String actions)

创建一个具有指定名称的新SerializablePermission对象。

StreamCorruptedException​(String reason)

创建一个StreamCorruptedException并列出抛出的原因。

StringBufferInputStream​(String s)

已过时。

创建一个字符串输入流，以从指定的字符串读取数据。

StringReader​(String s)

创建一个新的字符串阅读器。

SyncFailedException​(String desc)

构造具有详细消息的SyncFailedException。

UncheckedIOException​(String message, IOException cause)

构造这个类的一个实例。

UnsupportedEncodingException​(String s)

构造具有详细消息的UnsupportedEncodingException。

UTFDataFormatException​(String s)

构造具有指定详细消息的 UTFDataFormatException 。

WriteAbortedException​(String s, 异常 ex)

构造一个WriteAbortedException，其中包含一个描述异常的字符串，异常导致中止。

Uses of String in java.lang

Fields in java.lang with type parameters of type String

Modifier and Type

Field

描述

static Comparator<String>

String.CASE_INSENSITIVE_ORDER

一个比较器，可以按 compareToIgnoreCase命令 String对象。

Methods in java.lang that return String

Modifier and Type

方法

描述

static String

System.clearProperty​(String key)

删除指定键指定的系统属性。

String

String.concat​(String str)

将指定的字符串连接到该字符串的末尾。

String

EnumConstantNotPresentException.constantName​()

返回缺少的枚举常量的名称。

static String

String.copyValueOf​(char[] data)

相当于 valueOf(char[]) 。

static String

String.copyValueOf​(char[] data, int offset, int count)

相当于 valueOf(char[], int, int) 。

protected String

ClassLoader.findLibrary​(String libname)

返回本机库的绝对路径名。

static String

String.format​(String format, Object... args)

使用指定的格式字符串和参数返回格式化的字符串。

static String

String.format​(Locale l, String format, Object... args)

使用指定的区域设置，格式字符串和参数返回格式化的字符串。

String

Class.getCanonicalName​()

返回由Java语言规范定义的基础类的规范名称。

String

StackTraceElement.getClassLoaderName​()

返回包含由此堆栈跟踪元素表示的执行点的类的类加载器的名称。

String

StackTraceElement.getClassName​()

返回包含由该堆栈跟踪元素表示的执行点的类的完全限定名称。

String

StackWalker.StackFrame.getClassName​()

获取由此堆栈框架表示的方法的声明类的 binary name 。

static String

System.getenv​(String name)

获取指定环境变量的值。

String

StackTraceElement.getFileName​()

返回包含由该堆栈跟踪元素表示的执行点的源文件的名称。

String

StackWalker.StackFrame.getFileName​()

返回包含由该堆栈帧表示的执行点的源文件的名称。

String

Package.getImplementationTitle​()

返回此包的标题。

String

Package.getImplementationVendor​()

返回实现此软件包的供应商，如果不知道则返回 null 。

String

Package.getImplementationVersion​()

返回这个实现的版本。

String

Throwable.getLocalizedMessage​()

创建此可抛出的本地化描述。

String

Throwable.getMessage​()

返回此throwable的详细消息字符串。

String

StackTraceElement.getMethodName​()

返回包含由该堆栈跟踪元素表示的执行点的方法的名称。

String

StackWalker.StackFrame.getMethodName​()

获取由该堆栈帧表示的方法的名称。

String

StackTraceElement.getModuleName​()

返回包含由该堆栈跟踪元素表示的执行点的模块的模块名称。

String

StackTraceElement.getModuleVersion​()

返回包含由该堆栈跟踪元素表示的执行点的模块的模块版本。

static String

Character.getName​(int codePoint)

返回指定字符的Unicode名称 codePoint ，如果代码点为 unassigned ，则返回null。

String

Class.getName​()

返回由该 Class对象表示的实体（类，接口，数组类，基元类型或空值）的 Class ，作为 String 。

String

ClassLoader.getName​()

如果此类加载器未命名，则返回此类加载器的名称或 null 。

String

Module.getName​()

如果此模块是未命名模块，则返回模块名称或 null 。

String

Package.getName​()

返回此包的名称。

String

System.Logger.getName​()

返回此记录器的名称。

String

System.Logger.Level.getName​()

返回此级别的名称。

String

Thread.getName​()

返回此线程的名称。

String

ThreadGroup.getName​()

返回此线程组的名称。

String

Class.getPackageName​()

返回完全限定的包名称。

static String

System.getProperty​(String key)

获取指定键指示的系统属性。

static String

System.getProperty​(String key, String def)

获取指定键指示的系统属性。

String

Class.getSimpleName​()

返回源代码中给出的基础类的简单名称。

String

Package.getSpecificationTitle​()

返回此程序包实现的规范的标题。

String

Package.getSpecificationVendor​()

返回拥有和维护实现此程序包的类的规范的组织，供应商或公司的名称。

String

Package.getSpecificationVersion​()

返回此程序包实现的规范的版本号。

String

Class.getTypeName​()

为此类型的名称返回一个内容丰富的字符串。

String

String.intern​()

返回字符串对象的规范表示。

static String

String.join​(CharSequence delimiter, CharSequence... elements)

返回由 CharSequence elements的副本组成的一个新的字符串，并附带一个指定的 delimiter的副本。

static String

String.join​(CharSequence delimiter, Iterable<? extends CharSequence> elements)

返回一个新 String的副本组成 CharSequence elements与指定的副本一起加入 delimiter 。

static String

System.lineSeparator​()

返回与系统相关的行分隔符字符串。

static String

System.mapLibraryName​(String libname)

将库名称映射到表示本地库的平台特定字符串。

String

Enum.name​()

返回此枚举常量的名称，与其枚举声明中声明的完全相同。

String

String.replace​(char oldChar, char newChar)

返回从替换所有出现的导致一个字符串 oldChar ，在这个字符串 newChar 。

String

String.replace​(CharSequence target, CharSequence replacement)

将与字面目标序列匹配的字符串的每个子字符串替换为指定的文字替换序列。

String

String.replaceAll​(String regex, String replacement)

用给定的替换替换与给定的 regular expression匹配的此字符串的每个子字符串。

String

String.replaceFirst​(String regex, String replacement)

用给定的替换替换与给定的 regular expression匹配的此字符串的第一个子字符串。

static String

System.setProperty​(String key, String value)

设置由指定键指示的系统属性。

String[]

String.split​(String regex)

将此字符串拆分为给定的匹配 regular expression 。

String[]

String.split​(String regex, int limit)

将此字符串拆分为给定的 regular expression的匹配 项 。

String

String.substring​(int beginIndex)

返回一个字符串，该字符串是此字符串的子字符串。

String

String.substring​(int beginIndex, int endIndex)

返回一个字符串，该字符串是此字符串的子字符串。

String

StringBuffer.substring​(int start)

String

StringBuffer.substring​(int start, int end)

static String

Integer.toBinaryString​(int i)

在基数2中返回整数参数的字符串表示形式为无符号整数。

static String

Long.toBinaryString​(long i)

返回 long参数的字符串表示形式为基数2中的无符号整数。

String

Class.toGenericString​()

返回描述此 Class的字符串，包括有关修饰符和类型参数的信息。

static String

Double.toHexString​(double d)

返回 double参数的十六进制字符串表示形式。

static String

Float.toHexString​(float f)

返回 float参数的十六进制字符串表示形式。

static String

Integer.toHexString​(int i)

返回整数参数的字符串表示形式，作为16位中的无符号整数。

static String

Long.toHexString​(long i)

将 long参数的字符串表示形式返回为16位中的无符号整数。

String

String.toLowerCase​()

使用默认语言环境的规则将此 String所有字符转换为小写。

String

String.toLowerCase​(Locale locale)

将此 String所有字符转换为小写，使用给定的 Locale的规则。

static String

Integer.toOctalString​(int i)

在基数8中返回整数参数的字符串表示形式为无符号整数。

static String

Long.toOctalString​(long i)

返回 long参数的字符串表示形式，作为基数8中的无符号整数。

String

Boolean.toString​()

返回表示此布尔值的一个 String对象。

static String

Boolean.toString​(boolean b)

返回表示指定布尔值的 String对象。

String

Byte.toString​()

返回表示该 Byte的值的 String对象。

static String

Byte.toString​(byte b)

返回一个新的 String对象，表示 byte 。

String

Character.Subset.toString​()

返回此子集的名称。

String

Character.toString​()

返回一个表示 Character的值的 String对象。

static String

Character.toString​(char c)

返回 String表示指定对象 char 。

String

CharSequence.toString​()

以与此顺序相同的顺序返回包含此序列中的字符的字符串。

String

Class.toString​()

将对象转换为字符串。

String

Double.toString​()

返回此 Double对象的字符串表示形式。

static String

Double.toString​(double d)

返回 double参数的字符串表示形式。

String

Enum.toString​()

返回声明中包含的此枚举常量的名称。

String

Float.toString​()

返回此 Float对象的字符串表示形式。

static String

Float.toString​(float f)

返回 float参数的字符串表示形式。

String

Integer.toString​()

返回一个表示 Integer的值的 String对象。

static String

Integer.toString​(int i)

返回表示指定整数的 String对象。

static String

Integer.toString​(int i, int radix)

返回由第二个参数指定的基数中的第一个参数的字符串表示形式。

String

Long.toString​()

返回一个表示 Long的值的 String对象。

static String

Long.toString​(long i)

返回 String表示指定对象 long 。

static String

Long.toString​(long i, int radix)

返回由第二个参数指定的基数中的第一个参数的字符串表示形式。

String

Module.toString​()

返回此模块的字符串表示形式。

String

ModuleLayer.toString​()

返回描述此模块层的字符串。

String

Object.toString​()

返回对象的字符串表示形式。

String

Package.toString​()

返回此包的字符串表示形式。

String

Runtime.Version.toString​()

返回此版本的字符串表示形式。

String

Short.toString​()

返回一个表示 Short的值的 String对象。

static String

Short.toString​(short s)

返回一个新 String表示指定对象 short 。

String

StackTraceElement.toString​()

返回此堆栈跟踪元素的字符串表示形式。

String

String.toString​()

这个对象（已经是一个字符串！）

String

StringBuffer.toString​()

String

StringBuilder.toString​()

String

Thread.toString​()

返回此线程的字符串表示，包括线程的名称，优先级和线程组。

String

ThreadGroup.toString​()

返回此Thread组的字符串表示形式。

String

Throwable.toString​()

返回此可抛出的简短描述。

static String

Integer.toUnsignedString​(int i)

将参数的字符串表示形式返回为无符号十进制值。

static String

Integer.toUnsignedString​(int i, int radix)

以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。

static String

Long.toUnsignedString​(long i)

将参数的字符串表示形式返回为无符号十进制值。

static String

Long.toUnsignedString​(long i, int radix)

以第二个参数指定的基数中的无符号整数值返回第一个参数的字符串表示形式。

String

String.toUpperCase​()

将此 String所有字符转换为大写，使用默认语言环境的规则。

String

String.toUpperCase​(Locale locale)

将此 String所有字符转换为大写字母，使用给定的 Locale的规则。

String

String.trim​()

返回一个字符串，其值为此字符串，并删除任何前导和尾随空格。

String

TypeNotPresentException.typeName​()

返回不可用类型的完全限定名称。

static String

String.valueOf​(boolean b)

返回 boolean参数的字符串表示形式。

static String

String.valueOf​(char c)

返回 char参数的字符串表示形式。

static String

String.valueOf​(char[] data)

返回 char数组参数的字符串表示形式。

static String

String.valueOf​(char[] data, int offset, int count)

返回 char数组参数的特定子阵列的字符串表示形式。

static String

String.valueOf​(double d)

返回 double参数的字符串表示形式。

static String

String.valueOf​(float f)

返回 float参数的字符串表示形式。

static String

String.valueOf​(int i)

返回 int参数的字符串表示形式。

static String

String.valueOf​(long l)

返回 long参数的字符串表示形式。

static String

String.valueOf​(Object obj)

返回 Object参数的字符串表示形式。

Methods in java.lang that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

ProcessBuilder.command​()

返回此流程构建器的操作系统程序和参数。

Optional<String>

ProcessHandle.Info.command​()

返回进程的可执行路径名。

Optional<String>

ProcessHandle.Info.commandLine​()

返回进程的命令行。

Map<String,String>

ProcessBuilder.environment​()

返回此流程构建器环境的字符串映射视图。

Map<String,String>

ProcessBuilder.environment​()

返回此流程构建器环境的字符串映射视图。

static Map<String,String>

System.getenv​()

返回当前系统环境的不可修改的字符串映射视图。

static Map<String,String>

System.getenv​()

返回当前系统环境的不可修改的字符串映射视图。

Set<String>

Module.getPackages​()

返回此模块中软件包的软件包名称集。

Optional<String>

Runtime.Version.optional​()

返回 optional附加识别构建信息。

Optional<String>

Runtime.Version.pre​()

返回可选的 pre-release信息。

Optional<String>

ProcessHandle.Info.user​()

返回进程的用户。

Methods in java.lang with parameters of type String

Modifier and Type

方法

描述

Module

Module.addExports​(String pn, Module other)

如果调用者的模块是此模块，则更新此模块以将给定的包导出到给定的模块。

ModuleLayer.Controller

ModuleLayer.Controller.addExports​(Module source, String pn, Module target)

更新模块 source在图层中导出包到模块 target 。

Module

Module.addOpens​(String pn, Module other)

如果该模块已经至少 打开了一个包到调用者模块，然后更新该模块以将包打开到给定的模块。

ModuleLayer.Controller

ModuleLayer.Controller.addOpens​(Module source, String pn, Module target)

更新模块 source在图层中打开一个包到模块 target 。

StringBuffer

StringBuffer.append​(String str)

StringBuilder

StringBuilder.append​(String str)

void

SecurityManager.checkAccept​(String host, int port)

如果调用线程不允许从指定的主机和端口号接受套接字连接，则抛出一个 SecurityException 。

void

SecurityManager.checkConnect​(String host, int port)

如果调用线程不允许打开到指定主机和端口号的套接字连接，则抛出一个 SecurityException 。

void

SecurityManager.checkConnect​(String host, int port, Object context)

如果指定的安全上下文不允许打开到指定的主机和端口号的套接字连接，则抛出一个 SecurityException 。

void

SecurityManager.checkDelete​(String file)

如果调用线程不允许删除指定的文件，则抛出一个 SecurityException 。

void

SecurityManager.checkExec​(String cmd)

如果调用线程不允许创建子进程，则抛出一个 SecurityException 。

void

SecurityManager.checkLink​(String lib)

如果调用线程不允许动态链接由字符串参数文件指定的库代码，则抛出一个 SecurityException 。

void

SecurityManager.checkPackageAccess​(String pkg)

如果调用线程不允许访问指定的包，则抛出一个 SecurityException 。

void

SecurityManager.checkPackageDefinition​(String pkg)

如果调用线程不允许在指定的包中定义类，则抛出一个 SecurityException 。

void

SecurityManager.checkPropertyAccess​(String key)

如果调用线程不允许访问具有指定的 key名称的系统属性，则抛出一个 SecurityException 。

void

SecurityManager.checkRead​(String file)

如果调用线程不允许读取由字符串参数指定的文件，则抛出一个 SecurityException 。

void

SecurityManager.checkRead​(String file, Object context)

如果指定的安全上下文不允许读取由字符串参数指定的文件，则抛出一个 SecurityException 。

void

SecurityManager.checkSecurityAccess​(String target)

确定是否应授予或拒绝具有指定权限目标名称的权限。

void

SecurityManager.checkWrite​(String file)

如果调用线程不允许写入由字符串参数指定的文件，则抛出一个 SecurityException 。

protected int

SecurityManager.classDepth​(String name)

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission调用。 此方法在将来的Java SE版本中可能会被删除。

static String

System.clearProperty​(String key)

删除指定键指定的系统属性。

static int

Character.codePointOf​(String name)

返回由给定的Unicode字符名称指定的Unicode字符的代码点值。

ProcessBuilder

ProcessBuilder.command​(String... command)

设置此流程构建器的操作系统程序和参数。

int

String.compareTo​(String anotherString)

按字典顺序比较两个字符串。

int

String.compareToIgnoreCase​(String str)

按字典顺序比较两个字符串，忽略病例差异。

static boolean

Compiler.compileClasses​(String string)

不推荐用于删除：此API元素将在以后的版本中被删除。

编译名称与指定字符串匹配的所有类。

String

String.concat​(String str)

将指定的字符串连接到该字符串的末尾。

static Byte

Byte.decode​(String nm)

将 String解码成 Byte 。

static Integer

Integer.decode​(String nm)

将 String解码成 Integer 。

static Long

Long.decode​(String nm)

将 String解码成 Long 。

static Short

Short.decode​(String nm)

将 String解码为 Short 。

protected Class<?>

ClassLoader.defineClass​(String name, byte[] b, int off, int len)

将一个字节数组转换为 Class类的实例。

protected Class<?>

ClassLoader.defineClass​(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)

将一个字节数组转换为 Class类的实例，并给出了一个 ProtectionDomain 。

protected Class<?>

ClassLoader.defineClass​(String name, ByteBuffer b, ProtectionDomain protectionDomain)

一个转换ByteBuffer成类的实例Class ，与给定ProtectionDomain 。

protected 软件包

ClassLoader.definePackage​(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)

在这个 ClassLoader定义了一个 name的包。

boolean

String.endsWith​(String suffix)

测试此字符串是否以指定的后缀结尾。

boolean

String.equalsIgnoreCase​(String anotherString)

将此 String与另一个 String比较，忽略案例注意事项。

Process

Runtime.exec​(String command)

在单独的进程中执行指定的字符串命令。

Process

Runtime.exec​(String[] cmdarray)

在单独的进程中执行指定的命令和参数。

Process

Runtime.exec​(String[] cmdarray, String[] envp)

在指定环境的单独进程中执行指定的命令和参数。

Process

Runtime.exec​(String[] cmdarray, String[] envp, File dir)

在指定的环境和工作目录的单独进程中执行指定的命令和参数。

Process

Runtime.exec​(String command, String[] envp)

在具有指定环境的单独进程中执行指定的字符串命令。

Process

Runtime.exec​(String command, String[] envp, File dir)

在指定的环境和工作目录的单独进程中执行指定的字符串命令。

protected Class<?>

ClassLoader.findClass​(String name)

找到具有指定的 类别binary name 。

protected Class<?>

ClassLoader.findClass​(String moduleName, String name)

在定义到此类加载器的模块中找到给定的 binary name的类。

protected String

ClassLoader.findLibrary​(String libname)

返回本机库的绝对路径名。

protected Class<?>

ClassLoader.findLoadedClass​(String name)

如果这个加载程序已被Java虚拟机记录为具有该类别的启动加载程序，则返回具有给定的 binary name的类 binary name 。

ClassLoader

ModuleLayer.findLoader​(String name)

返回具有给定名称的模块的 ClassLoader 。

Optional<Module>

ModuleLayer.findModule​(String name)

在此层中返回具有给定名称的模块，或者如果不在此层中，则 返回parent层。

protected URL

ClassLoader.findResource​(String name)

找到具有给定名称的资源。

protected URL

ClassLoader.findResource​(String moduleName, String name)

返回一个URL定义到此类加载器的模块中的资源。

protected Enumeration<URL>

ClassLoader.findResources​(String name)

返回表示具有给定名称的所有资源的URL对象的枚举。

protected Class<?>

ClassLoader.findSystemClass​(String name)

查找具有指定的 类别binary name ，如果需要加载它。

static String

String.format​(String format, Object... args)

使用指定的格式字符串和参数返回格式化的字符串。

static String

String.format​(Locale l, String format, Object... args)

使用指定的区域设置，格式字符串和参数返回格式化的字符串。

static Character.UnicodeBlock

Character.UnicodeBlock.forName​(String blockName)

返回具有给定名称的UnicodeBlock。

static Character.UnicodeScript

Character.UnicodeScript.forName​(String scriptName)

使用给定的Unicode脚本名称或脚本名称别名返回UnicodeScript常量。

static Class<?>

Class.forName​(Module module, String name)

返回 Class给定 binary name给定的模块中。

static Class<?>

Class.forName​(String className)

返回与给定字符串名称的类或接口相关联的 Class对象。

static Class<?>

Class.forName​(String name, boolean initialize, ClassLoader loader)

使用给定的类加载器返回与给定字符串名称的类或接口相关联的对象 Class 。

static boolean

Boolean.getBoolean​(String name)

返回 true当且仅当由参数命名的系统属性存在且等于忽略大小写时，字符串为 "true" 。

byte[]

String.getBytes​(String charsetName)

使用命名的字符集将这个 String编码成一个字节序列，将结果存储到一个新的字节数组中。

protected Object

ClassLoader.getClassLoadingLock​(String className)

返回类加载操作的锁定对象。

Field

Class.getDeclaredField​(String name)

返回一个 Field对象，它反映此表示的类或接口的指定已声明字段 Class对象。

方法

Class.getDeclaredMethod​(String name, Class<?>... parameterTypes)

返回一个 方法对象，该对象反映由该 Class对象表示的类或接口的指定声明方法。

软件包

ClassLoader.getDefinedPackage​(String name)

返回 软件包给定的 name已经被这个类加载器定义。

static String

System.getenv​(String name)

获取指定环境变量的值。

Field

Class.getField​(String name)

返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定公共成员字段。

static Integer

Integer.getInteger​(String nm)

确定具有指定名称的系统属性的整数值。

static Integer

Integer.getInteger​(String nm, int val)

确定具有指定名称的系统属性的整数值。

static Integer

Integer.getInteger​(String nm, Integer val)

返回具有指定名称的系统属性的整数值。

System.Logger

System.LoggerFinder.getLocalizedLogger​(String name, ResourceBundle bundle, Module module)

返回一个本地化的实例Logger对于给定module 。

static System.Logger

System.getLogger​(String name)

返回一个Logger的调用者使用的实例。

static System.Logger

System.getLogger​(String name, ResourceBundle bundle)

返回一个可本地化的Logger实例，用于调用者的使用。

abstract System.Logger

System.LoggerFinder.getLogger​(String name, Module module)

为给定的module返回一个Logger的实例。

static Long

Long.getLong​(String nm)

确定具有指定名称的系统属性的值为 long 。

static Long

Long.getLong​(String nm, long val)

确定具有指定名称的系统属性的值为 long 。

static Long

Long.getLong​(String nm, Long val)

返回具有指定名称的系统属性的值为 long 。

方法

Class.getMethod​(String name, Class<?>... parameterTypes)

返回一个 方法对象，它反映此表示的类或接口的指定公共成员方法 Class对象。

protected 软件包

ClassLoader.getPackage​(String name)

已过时。
如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则软件包暴露的属性可能不如预期的那样其余的程序。 例如，即使在由子载入程序定义的package-info.class文件中存在注释， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。

static 软件包

Package.getPackage​(String name)

已过时。
如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅公开由父加载程序定义的package-info.class文件的注释，即使注释存在于由子加载器定义的package-info.class文件中。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。

static String

System.getProperty​(String key)

获取指定键指示的系统属性。

static String

System.getProperty​(String key, String def)

获取指定键指示的系统属性。

URL

Class.getResource​(String name)

查找具有给定名称的资源。

URL

ClassLoader.getResource​(String name)

找到具有给定名称的资源。

InputStream

Class.getResourceAsStream​(String name)

查找具有给定名称的资源。

InputStream

ClassLoader.getResourceAsStream​(String name)

返回用于读取指定资源的输入流。

InputStream

Module.getResourceAsStream​(String name)

返回用于读取此模块中资源的输入流。

Enumeration<URL>

ClassLoader.getResources​(String name)

查找具有给定名称的所有资源。

static URL

ClassLoader.getSystemResource​(String name)

从用于加载类的搜索路径中查找指定名称的资源。

static InputStream

ClassLoader.getSystemResourceAsStream​(String name)

打开阅读，从用于加载类的搜索路径中指定名称的资源。

static Enumeration<URL>

ClassLoader.getSystemResources​(String name)

从用于加载类的搜索路径中查找指定名称的所有资源。

protected boolean

SecurityManager.inClass​(String name)

不推荐用于删除：此API元素将在以后的版本中被删除。
不推荐使用这种类型的安全检查。 建议使用checkPermission通话。 此方法在将来的Java SE版本中可能会被删除。

int

String.indexOf​(String str)

返回指定子字符串第一次出现的字符串内的索引。

int

String.indexOf​(String str, int fromIndex)

返回指定子串的第一次出现的字符串中的索引，从指定的索引开始。

int

StringBuffer.indexOf​(String str)

int

StringBuffer.indexOf​(String str, int fromIndex)

int

StringBuilder.indexOf​(String str)

int

StringBuilder.indexOf​(String str, int fromIndex)

StringBuffer

StringBuffer.insert​(int offset, String str)

StringBuilder

StringBuilder.insert​(int offset, String str)

boolean

Package.isCompatibleWith​(String desired)

将该软件包的规格版本与所需版本进行比较。

boolean

Module.isExported​(String pn)

如果此模块无条件导出给定的包，则返回 true 。

boolean

Module.isExported​(String pn, Module other)

如果此模块将给定的包导出到至少给定的模块，则返回 true 。

boolean

Module.isOpen​(String pn)

如果此模块无条件 打开包，则返回 true 。

boolean

Module.isOpen​(String pn, Module other)

返回 true如果这个模块已经 打开一个包至少给定的模块。

int

String.lastIndexOf​(String str)

返回指定子字符串最后一次出现的字符串中的索引。

int

String.lastIndexOf​(String str, int fromIndex)

返回指定子字符串的最后一次出现的字符串中的索引，从指定索引开始向后搜索。

int

StringBuffer.lastIndexOf​(String str)

int

StringBuffer.lastIndexOf​(String str, int fromIndex)

int

StringBuilder.lastIndexOf​(String str)

int

StringBuilder.lastIndexOf​(String str, int fromIndex)

void

Runtime.load​(String filename)

加载由filename参数指定的本机库。

static void

System.load​(String filename)

加载由filename参数指定的本机库。

Class<?>

ClassLoader.loadClass​(String name)

加载指定的 类别binary name 。

protected Class<?>

ClassLoader.loadClass​(String name, boolean resolve)

加载指定的 类别binary name 。

void

Runtime.loadLibrary​(String libname)

加载由 libname参数指定的本机库。

static void

System.loadLibrary​(String libname)

加载由 libname参数指定的本机库。

default void

System.Logger.log​(System.Logger.Level level, String msg)

记录消息。

default void

System.Logger.log​(System.Logger.Level level, String format, Object... params)

使用可选参数列表记录消息。

default void

System.Logger.log​(System.Logger.Level level, String msg, Throwable thrown)

记录与给定的可抛弃关联的消息。

void

System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String format, Object... params)

使用资源束和可选的参数列表记录消息。

void

System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String msg, Throwable thrown)

记录与给定的可抛物线相关联的本地化消息。

static String

System.mapLibraryName​(String libname)

将库名称映射到表示本地库的平台特定字符串。

boolean

String.matches​(String regex)

告诉这个字符串是否匹配给定的 regular expression 。

static Runtime.Version

Runtime.Version.parse​(String s)

将给定的字符串解析为有效的 version string，其中包含一个 version number，然后是预发布和构建信息。

static boolean

Boolean.parseBoolean​(String s)

将字符串参数解析为布尔值。

static byte

Byte.parseByte​(String s)

解析字符串参数作为带符号的二进制 byte 。

static byte

Byte.parseByte​(String s, int radix)

在第二个参数指定的基数中将字符串参数解析为带符号的 byte 。

static double

Double.parseDouble​(String s)

返回一个新 double初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Double 。

static float

Float.parseFloat​(String s)

返回一个新 float初始化为指定的代表的值 String ，如通过执行 valueOf类的方法 Float 。

static int

Integer.parseInt​(String s)

将字符串参数解析为带符号的十进制整数。

static int

Integer.parseInt​(String s, int radix)

将字符串参数解析为第二个参数指定的基数中的有符号整数。

static long

Long.parseLong​(String s)

解析字符串参数为带符号的二进制 long 。

static long

Long.parseLong​(String s, int radix)

将字符串参数解析为由第二个参数指定的基数中的带符号的 long 。

static short

Short.parseShort​(String s)

将字符串参数解析为有符号的二进制 short 。

static short

Short.parseShort​(String s, int radix)

在第二个参数指定的基数中将字符串参数解析为带符号的 short 。

static int

Integer.parseUnsignedInt​(String s)

将字符串参数解析为无符号十进制整数。

static int

Integer.parseUnsignedInt​(String s, int radix)

将字符串参数解析为第二个参数指定的基数中的无符号整数。

static long

Long.parseUnsignedLong​(String s)

将字符串参数解析为无符号小数 long 。

static long

Long.parseUnsignedLong​(String s, int radix)

将字符串参数解析为第二个参数指定的基数中的无符号 long 。

boolean

String.regionMatches​(boolean ignoreCase, int toffset, String other, int ooffset, int len)

测试两个字符串区域是否相等。

boolean

String.regionMatches​(int toffset, String other, int ooffset, int len)

测试两个字符串区域是否相等。

StringBuffer

StringBuffer.replace​(int start, int end, String str)

StringBuilder

StringBuilder.replace​(int start, int end, String str)

String

String.replaceAll​(String regex, String replacement)

用给定的替换替换与给定的 regular expression匹配的此字符串的每个子字符串。

String

String.replaceFirst​(String regex, String replacement)

用给定的替换替换与给定的 regular expression匹配的此字符串的第一个子字符串。

Stream<URL>

ClassLoader.resources​(String name)

返回一个流，其元素是具有给定名称的所有资源的URL。

void

ClassLoader.setClassAssertionStatus​(String className, boolean enabled)

为此类加载器中指定的顶级类和其中包含的任何嵌套类设置所需的断言状态。

void

Thread.setName​(String name)

将此线程的名称更改为等于参数 name 。

void

ClassLoader.setPackageAssertionStatus​(String packageName, boolean enabled)

设置命名包的包默认断言状态。

static String

System.setProperty​(String key, String value)

设置由指定键指示的系统属性。

String[]

String.split​(String regex)

将此字符串拆分为给定的 regular expression的匹配 项 。

String[]

String.split​(String regex, int limit)

将此字符串拆分为给定的 regular expression的匹配 项 。

boolean

String.startsWith​(String prefix)

测试此字符串是否以指定的前缀开头。

boolean

String.startsWith​(String prefix, int toffset)

测试在指定索引处开始的此字符串的子字符串是否以指定的前缀开头。

static Boolean

Boolean.valueOf​(String s)

返回一个 Boolean ，其值由指定的字符串表示。

static Byte

Byte.valueOf​(String s)

返回一个 Byte对象，该对象保存由指定的 String给出的值。

static Byte

Byte.valueOf​(String s, int radix)

返回一个 Byte对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。

static Character.UnicodeScript

Character.UnicodeScript.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Double

Double.valueOf​(String s)

返回一个 Double对象，该对象保存由参数字符串 s表示的 double值。

static <T extends Enum<T>>
T

Enum.valueOf​(Class<T> enumType, String name)

返回具有指定名称的指定枚举类型的枚举常量。

static Float

Float.valueOf​(String s)

返回一个 Float对象，保存由参数字符串 s表示的 float值。

static Integer

Integer.valueOf​(String s)

返回一个保存指定值的 Integer对象 String 。

static Integer

Integer.valueOf​(String s, int radix)

返回一个 Integer对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。

static Long

Long.valueOf​(String s)

返回一个保持指定值的 Long对象 String 。

static Long

Long.valueOf​(String s, int radix)

返回一个 Long对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。

static ProcessBuilder.Redirect.Type

ProcessBuilder.Redirect.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Short

Short.valueOf​(String s)

返回一个 Short对象，保存由指定的 String给出的值。

static Short

Short.valueOf​(String s, int radix)

返回一个 Short对象，该对象保存从指定的 String提取的值，并使用第二个参数给出的基数进行解析。

static StackWalker.Option

StackWalker.Option.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static System.Logger.Level

System.Logger.Level.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Thread.State

Thread.State.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in java.lang with type arguments of type String

Modifier and Type

方法

描述

ProcessBuilder

ProcessBuilder.command​(List<String> command)

设置此流程构建器的操作系统程序和参数。

ModuleLayer

ModuleLayer.defineModules​(Configuration cf, Function<String,ClassLoader> clf)

通过在Java虚拟机的给定 Configuration定义模块，创建一个新的模块层，将该层作为其父层。

static ModuleLayer.Controller

ModuleLayer.defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)

通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。

default void

System.Logger.log​(System.Logger.Level level, Supplier<String> msgSupplier)

记录一个懒惰的提供的消息。

default void

System.Logger.log​(System.Logger.Level level, Supplier<String> msgSupplier, Throwable thrown)

记录与给定的可抛物线相关联的延迟提供的消息。

Constructors in java.lang with parameters of type String

Constructor

描述

AbstractMethodError​(String s)

构造具有指定详细消息的 AbstractMethodError 。

ArithmeticException​(String s)

构造具有指定详细消息的 ArithmeticException 。

ArrayIndexOutOfBoundsException​(String s)

构造具有指定详细消息的 ArrayIndexOutOfBoundsException类。

ArrayStoreException​(String s)

构造具有指定详细消息的 ArrayStoreException 。

AssertionError​(String message, Throwable cause)

构造一个新的 AssertionError与指定的详细信息和原因。

Boolean​(String s)

已过时。
很少使用这个构造函数。 使用Boolean.parseBoolean(String)将字符串转换为boolean原语，或使用Boolean.valueOf(String)将字符串转换为Boolean对象。

BootstrapMethodError​(String s)

构造具有指定详细消息的 BootstrapMethodError 。

BootstrapMethodError​(String s, Throwable cause)

构造一个具有指定的详细信息和原因的 BootstrapMethodError 。

Byte​(String s)

已过时。
很少使用这个构造函数。 使用Byte.parseByte(String)将字符串转换为byte原语，或使用Byte.valueOf(String)将字符串转换为Byte对象。

ClassCastException​(String s)

构造具有指定详细消息的 ClassCastException 。

ClassCircularityError​(String s)

构造具有指定详细信息的 ClassCircularityError 。

ClassFormatError​(String s)

构造具有指定详细消息的 ClassFormatError 。

ClassLoader​(String name, ClassLoader parent)

创建指定名称的新类加载器，并使用指定的父类加载器进行委派。

ClassNotFoundException​(String s)

构造具有指定详细消息的 ClassNotFoundException 。

ClassNotFoundException​(String s, Throwable ex)

构造具有指定的详细消息的 ClassNotFoundException和加载类时引发的可选异常。

CloneNotSupportedException​(String s)

构造具有指定详细消息的 CloneNotSupportedException 。

Double​(String s)

已过时。
很少使用这个构造函数。 使用Double.parseDouble(String)将字符串转换为double原语，或使用Double.valueOf(String)将字符串转换为Double对象。

Enum​(String name, int ordinal)

唯一的构造函数。

EnumConstantNotPresentException​(Class<? extends Enum> enumType, String constantName)

为指定的常量构造一个 EnumConstantNotPresentException 。

Error​(String message)

使用指定的详细信息构造新的错误。

Error​(String message, Throwable cause)

构造一个新的错误与指定的详细信息和原因。

Error​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)

构造一个新的错误指定的详细信息，原因，抑制启用或禁用，可写栈跟踪启用或禁用。

异常​(String message)

使用指定的详细消息构造新的异常。

异常​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

异常​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)

构造一个新的异常，指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。

ExceptionInInitializerError​(String s)

构造具有指定的详细消息字符串的ExceptionInInitializerError。

Float​(String s)

已过时。
很少使用这个构造函数。 使用Float.parseFloat(String)将字符串转换为float原语，或使用Float.valueOf(String)将字符串转换为Float对象。

IllegalAccessError​(String s)

构造具有指定详细消息的 IllegalAccessError 。

IllegalAccessException​(String s)

构造一个 IllegalAccessException的详细信息。

IllegalArgumentException​(String s)

构造具有指定详细消息的 IllegalArgumentException 。

IllegalArgumentException​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

IllegalCallerException​(String s)

构造具有指定详细消息的IllegalCallerException。

IllegalCallerException​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

IllegalMonitorStateException​(String s)

构造具有指定详细消息的 IllegalMonitorStateException 。

IllegalStateException​(String s)

构造具有指定详细消息的IllegalStateException。

IllegalStateException​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

IllegalThreadStateException​(String s)

构造具有指定详细消息的 IllegalThreadStateException 。

IncompatibleClassChangeError​(String s)

构造具有指定详细消息的 IncompatibleClassChangeError 。

IndexOutOfBoundsException​(String s)

构造具有指定详细消息的 IndexOutOfBoundsException 。

InstantiationError​(String s)

构造具有指定详细消息的 InstantiationError 。

InstantiationException​(String s)

构造具有指定详细消息的 InstantiationException 。

Integer​(String s)

已过时。
很少使用这个构造函数。 使用Integer.parseInt(String)将字符串转换为int原语，或使用Integer.valueOf(String)将字符串转换为Integer对象。

InternalError​(String message)

构造具有指定详细消息的 InternalError 。

InternalError​(String message, Throwable cause)

构造具有指定的详细消息和原因的 InternalError 。

InterruptedException​(String s)

构造具有指定详细消息的 InterruptedException 。

LayerInstantiationException​(String msg)

构造具有给定详细消息的 LayerInstantiationException 。

LayerInstantiationException​(String msg, Throwable cause)

构造一个 LayerInstantiationException与给定的详细信息和原因。

LinkageError​(String s)

构造具有指定详细消息的 LinkageError 。

LinkageError​(String s, Throwable cause)

构造一个具有指定的详细信息和原因的 LinkageError 。

Long​(String s)

已过时。
很少使用这个构造函数。 使用Long.parseLong(String)将字符串转换为long原语，或使用Long.valueOf(String)将字符串转换为Long对象。

NegativeArraySizeException​(String s)

构造具有指定详细消息的 NegativeArraySizeException 。

NoClassDefFoundError​(String s)

构造具有指定详细消息的 NoClassDefFoundError 。

NoSuchFieldError​(String s)

构造具有指定详细消息的 NoSuchFieldError 。

NoSuchFieldException​(String s)

具有详细消息的构造方法。

NoSuchMethodError​(String s)

构造具有指定详细消息的 NoSuchMethodError 。

NoSuchMethodException​(String s)

构造一个 NoSuchMethodException的详细信息。

NullPointerException​(String s)

构造具有指定详细消息的 NullPointerException 。

NumberFormatException​(String s)

构造具有指定详细消息的 NumberFormatException 。

OutOfMemoryError​(String s)

构造具有指定详细消息的 OutOfMemoryError 。

ProcessBuilder​(String... command)

构造具有指定操作系统程序和参数的进程构建器。

ReflectiveOperationException​(String message)

使用指定的详细消息构造新的异常。

ReflectiveOperationException​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

RuntimeException​(String message)

使用指定的详细消息构造新的运行时异常。

RuntimeException​(String message, Throwable cause)

构造一个新的运行时异常与指定的详细信息和原因。

RuntimeException​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)

构造一个新的运行时异常，其中包含指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。

RuntimePermission​(String name)

创建一个新的具有指定名称的RuntimePermission。

RuntimePermission​(String name, String actions)

创建一个具有指定名称的新RuntimePermission对象。

SecurityException​(String s)

构造具有指定详细消息的 SecurityException 。

SecurityException​(String message, Throwable cause)

创建一个 SecurityException与指定的详细信息和原因。

Short​(String s)

已过时。
很少使用这个构造函数。 使用Short.parseShort(String)将字符串转换为short原语，或使用Short.valueOf(String)将字符串转换为Short对象。

StackOverflowError​(String s)

构造具有指定详细消息的 StackOverflowError 。

StackTraceElement​(String declaringClass, String methodName, String fileName, int lineNumber)

创建表示指定执行点的堆栈跟踪元素。

StackTraceElement​(String classLoaderName, String moduleName, String moduleVersion, String declaringClass, String methodName, String fileName, int lineNumber)

创建表示指定执行点的堆栈跟踪元素。

String​(byte[] bytes, int offset, int length, String charsetName)

通过使用指定的字符集解码指定的字节子阵列，构造新的 String 。

String​(byte[] bytes, String charsetName)

构造一个新的String由指定用指定的字节的数组解码charset 。

String​(String original)

初始化新创建的String对象，使其表示与参数相同的字符序列; 换句话说，新创建的字符串是参数字符串的副本。

StringBuffer​(String str)

构造一个初始化为指定字符串内容的字符串缓冲区。

StringBuilder​(String str)

构造一个初始化为指定字符串内容的字符串构建器。

StringIndexOutOfBoundsException​(String s)

构造具有指定详细消息的 StringIndexOutOfBoundsException 。

Subset​(String name)

构造一个新的 Subset实例。

Thread​(Runnable target, String name)

分配一个新的 Thread对象。

Thread​(String name)

分配一个新的 Thread对象。

Thread​(ThreadGroup group, Runnable target, String name)

分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于 group引用的线程组。

Thread​(ThreadGroup group, Runnable target, String name, long stackSize)

分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于由 group引用的线程组，并具有指定的 堆栈大小 。

Thread​(ThreadGroup group, Runnable target, String name, long stackSize, boolean inheritThreadLocals)

分配一个新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于group引用的线程组，具有指定的stackSize ，如果inheritThreadLocals为true ，则继承inheritable thread-local变量的初始值。

Thread​(ThreadGroup group, String name)

分配一个新的 Thread对象。

ThreadGroup​(String name)

构造一个新的线程组。

ThreadGroup​(ThreadGroup parent, String name)

创建一个新的线程组。

Throwable​(String message)

构造一个具有指定的详细消息的新的throwable。

Throwable​(String message, Throwable cause)

构造一个新的可抛出指定的详细信息和原因。

Throwable​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)

构造一个具有指定的详细消息的新的throwable，因为启用或禁用了 suppression和启用或禁用可写栈跟踪。

TypeNotPresentException​(String typeName, Throwable cause)

构造具有指定原因的命名类型的 TypeNotPresentException 。

UnknownError​(String s)

构造具有指定详细消息的 UnknownError 。

UnsatisfiedLinkError​(String s)

构造具有指定详细消息的 UnsatisfiedLinkError 。

UnsupportedClassVersionError​(String s)

构造具有指定详细消息的 UnsupportedClassVersionError 。

UnsupportedOperationException​(String message)

构造具有指定详细消息的UnsupportedOperationException。

UnsupportedOperationException​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

VerifyError​(String s)

构造具有指定详细消息的 VerifyError 。

VirtualMachineError​(String message)

构造具有指定详细消息的 VirtualMachineError 。

VirtualMachineError​(String message, Throwable cause)

构造一个具有指定的详细消息和原因的 VirtualMachineError 。

Constructor parameters in java.lang with type arguments of type String

Constructor

描述

ProcessBuilder​(List<String> command)

构造具有指定操作系统程序和参数的进程构建器。

Uses of String in java.lang.annotation

Methods in java.lang.annotation that return String

Modifier and Type

方法

描述

String

IncompleteAnnotationException.elementName​()

返回缺少元素的名称。

String

AnnotationTypeMismatchException.foundType​()

返回错误类型元素中找到的数据类型。

String

Annotation.toString​()

返回此注释的字符串表示形式。

Methods in java.lang.annotation with parameters of type String

Modifier and Type

方法

描述

static ElementType

ElementType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static RetentionPolicy

RetentionPolicy.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.lang.annotation with parameters of type String

Constructor

描述

AnnotationFormatError​(String message)

构造一个新的 AnnotationFormatError与指定的详细信息。

AnnotationFormatError​(String message, Throwable cause)

构造一个新的 AnnotationFormatError具有指定的详细信息和原因。

AnnotationTypeMismatchException​(方法 element, String foundType)

为指定的注释类型元素构造AnnotationTypeMismatchException，并找到数据类型。

IncompleteAnnotationException​(Class<? extends Annotation> annotationType, String elementName)

构造一个IncompleteAnnotationException来指示指定的元素在指定的注释类型中丢失。

Uses of String in java.lang.instrument

Methods in java.lang.instrument with parameters of type String

Modifier and Type

方法

描述

void

Instrumentation.setNativeMethodPrefix​(ClassFileTransformer transformer, String prefix)

此方法通过允许使用应用于名称的前缀进行重试来修改本机方法解析的故障处理。

default byte[]

ClassFileTransformer.transform​(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)

转换给定的类文件并返回一个新的替换类文件。

default byte[]

ClassFileTransformer.transform​(Module module, ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)

转换给定的类文件并返回一个新的替换类文件。

Method parameters in java.lang.instrument with type arguments of type String

Modifier and Type

方法

描述

void

Instrumentation.redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)

重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。

Constructors in java.lang.instrument with parameters of type String

Constructor

描述

IllegalClassFormatException​(String s)

构造具有指定详细消息的 IllegalClassFormatException 。

UnmodifiableClassException​(String s)

构造具有指定详细消息的 UnmodifiableClassException 。

UnmodifiableModuleException​(String msg)

构造具有指定详细消息的 UnmodifiableModuleException 。

Uses of String in java.lang.invoke

Methods in java.lang.invoke that return String

Modifier and Type

方法

描述

String

SerializedLambda.getCapturingClass​()

获取捕获此lambda的类的名称。

String

SerializedLambda.getFunctionalInterfaceClass​()

获取此lambda已转换到的调用类型的名称

String

SerializedLambda.getFunctionalInterfaceMethodName​()

获取此lambda已转换的功能界面的主要方法的名称。

String

SerializedLambda.getFunctionalInterfaceMethodSignature​()

获取此lambda已转换的功能界面的主要方法的签名。

String

SerializedLambda.getImplClass​()

获取包含实现方法的类的名称。

String

SerializedLambda.getImplMethodName​()

获取实现方法的名称。

String

SerializedLambda.getImplMethodSignature​()

获取实现方法的签名。

String

SerializedLambda.getInstantiatedMethodType​()

在使用捕获站点的实例化代替类型变量后，获取主要功能接口方法的签名。

String

MethodHandleInfo.getName​()

返回破解方法句柄的底层成员的名称。

String

VarHandle.AccessMode.methodName​()

返回与此 AccessMode值相关联的 VarHandle签名 - 多态方法名称。

static String

MethodHandleInfo.referenceKindToString​(int referenceKind)

返回给定参考类型的描述性名称，如 table above中所定义。

String

MethodType.toMethodDescriptorString​()

生成方法类型的字节码描述符表示。

String

MethodHandle.toString​()

返回方法句柄的字符串表示形式，从字符串 "MethodHandle"开始，以方法句柄类型的字符串表示形式结束。

static String

MethodHandleInfo.toString​(int kind, Class<?> defc, String name, MethodType type)

给出 MethodHandleInfo的字符串表示，给出其符号参考的四个部分。

String

MethodHandles.Lookup.toString​()

显示要从中进行查找的类的名称。

String

MethodType.toString​()

返回方法类型的字符串表示形式，格式为 "(PT0,PT1...)RT" 。

String

SerializedLambda.toString​()

Methods in java.lang.invoke with parameters of type String

Modifier and Type

方法

描述

static CallSite

LambdaMetafactory.altMetafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)

在适当的类型适应和参数的部分评估之后，便于创建简单的“功能对象”，通过委派给所提供的MethodHandle来实现一个或多个接口。

MethodHandle

MethodHandles.Lookup.bind​(Object receiver, String name, MethodType type)

为非静态方法生成早期绑定的方法句柄。

Class<?>

MethodHandles.Lookup.findClass​(String targetName)

从这个 Lookup对象定义的查找上下文中按名称查找一个类。

MethodHandle

MethodHandles.Lookup.findGetter​(Class<?> refc, String name, Class<?> type)

产生方法句柄，给非静态字段的读访问权限。

MethodHandle

MethodHandles.Lookup.findSetter​(Class<?> refc, String name, Class<?> type)

产生一个给非静态字段写入访问权限的方法句柄。

MethodHandle

MethodHandles.Lookup.findSpecial​(Class<?> refc, String name, MethodType type, Class<?> specialCaller)

为虚拟方法生成早期绑定的方法句柄。

MethodHandle

MethodHandles.Lookup.findStatic​(Class<?> refc, String name, MethodType type)

为静态方法生成方法句柄。

MethodHandle

MethodHandles.Lookup.findStaticGetter​(Class<?> refc, String name, Class<?> type)

产生一个给静态字段读取访问权限的方法句柄。

MethodHandle

MethodHandles.Lookup.findStaticSetter​(Class<?> refc, String name, Class<?> type)

生成方法句柄，给静态字段写权限。

VarHandle

MethodHandles.Lookup.findStaticVarHandle​(Class<?> decl, String name, Class<?> type)

产生一个VarHandle，可以访问 name类中声明的类型为 type的静态字段 decl 。

VarHandle

MethodHandles.Lookup.findVarHandle​(Class<?> recv, String name, Class<?> type)

产生一个VarHandle，可以访问 name类中声明的类型为 type的非静态字段 recv 。

MethodHandle

MethodHandles.Lookup.findVirtual​(Class<?> refc, String name, MethodType type)

为虚拟方法生成方法句柄。

static MethodType

MethodType.fromMethodDescriptorString​(String descriptor, ClassLoader loader)

查找或创建方法类型的实例，给定其字节码描述符的拼写。

static CallSite

StringConcatFactory.makeConcat​(MethodHandles.Lookup lookup, String name, MethodType concatType)

促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。

static CallSite

StringConcatFactory.makeConcatWithConstants​(MethodHandles.Lookup lookup, String name, MethodType concatType, String recipe, Object... constants)

促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。

static CallSite

LambdaMetafactory.metafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType)

通过委派给所提供的MethodHandle ，在适当的类型适应和参数的部分评估之后，便于创建简单的“功能对象”，实现一个或多个接口。

static String

MethodHandleInfo.toString​(int kind, Class<?> defc, String name, MethodType type)

返回一个 MethodHandleInfo的字符串表示，给出其符号参考的四个部分。

static VarHandle.AccessMode

VarHandle.AccessMode.valueFromMethodName​(String methodName)

返回与指定的 VarHandle签名多态方法名称相关联的 AccessMode值。

static VarHandle.AccessMode

VarHandle.AccessMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.lang.invoke with parameters of type String

Constructor

描述

LambdaConversionException​(String message)

构造一个 LambdaConversionException的消息。

LambdaConversionException​(String message, Throwable cause)

构造一个 LambdaConversionException的消息和原因。

LambdaConversionException​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)

构造一个 LambdaConversionException的消息，原因和其他设置。

SerializedLambda​(Class<?> capturingClass, String functionalInterfaceClass, String functionalInterfaceMethodName, String functionalInterfaceMethodSignature, int implMethodKind, String implClass, String implMethodName, String implMethodSignature, String instantiatedMethodType, Object[] capturedArgs)

从lambda工厂现场的低级别信息中创建一个 SerializedLambda 。

StringConcatException​(String msg)

使用消息构造异常

StringConcatException​(String msg, Throwable cause)

使用消息和链接的throwable构造异常

WrongMethodTypeException​(String s)

构造具有指定详细消息的 WrongMethodTypeException 。

Uses of String in java.lang.management

Fields in java.lang.management declared as String

Modifier and Type

Field

描述

static String

ManagementFactory.CLASS_LOADING_MXBEAN_NAME

字符串表示的ObjectName为ClassLoadingMXBean 。

static String

ManagementFactory.COMPILATION_MXBEAN_NAME

字符串表示的ObjectName为CompilationMXBean 。

static String

ManagementFactory.GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE

ObjectName的域名和类型密钥属性为GarbageCollectorMXBean 。

static String

MemoryNotificationInfo.MEMORY_COLLECTION_THRESHOLD_EXCEEDED

通知类型表示在Java虚拟机已经花费了回收该内存池中未使用的对象的努力之后，内存池的内存使用量大于或等于其内存池的内存使用量为 collection usage threshold 。

static String

ManagementFactory.MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE

ObjectName的域名和类型密钥属性为MemoryManagerMXBean 。

static String

ManagementFactory.MEMORY_MXBEAN_NAME

字符串表示的ObjectName为MemoryMXBean 。

static String

ManagementFactory.MEMORY_POOL_MXBEAN_DOMAIN_TYPE

ObjectName的域名和类型密钥属性为MemoryPoolMXBean 。

static String

MemoryNotificationInfo.MEMORY_THRESHOLD_EXCEEDED

通知类型表示内存池的内存使用量已达到或超过其 usage threshold值。

static String

ManagementFactory.OPERATING_SYSTEM_MXBEAN_NAME

字符串表示的ObjectName为OperatingSystemMXBean 。

static String

ManagementFactory.RUNTIME_MXBEAN_NAME

字符串表示的ObjectName为RuntimeMXBean 。

static String

ManagementFactory.THREAD_MXBEAN_NAME

字符串表示的ObjectName为ThreadMXBean 。

Methods in java.lang.management that return String

Modifier and Type

方法

描述

String

OperatingSystemMXBean.getArch​()

返回操作系统架构。

String

RuntimeMXBean.getBootClassPath​()

返回bootstrap类加载器用于搜索类文件的引导类路径。

String

LockInfo.getClassName​()

返回锁定对象的类的完全限定名称。

String

RuntimeMXBean.getClassPath​()

返回系统类加载器用于搜索类文件的Java类路径。

String

RuntimeMXBean.getLibraryPath​()

返回Java库路径。

String

ThreadInfo.getLockName​()

返回 string representation ，与此相关的线程的对象的 ThreadInfo被阻塞等待。

String

ThreadInfo.getLockOwnerName​()

返回拥有与此 ThreadInfo相关联的线程被阻止等待的对象的线程的名称。

String

PlatformLoggingMXBean.getLoggerLevel​(String loggerName)

获取与指定记录器关联的日志 level的名称。

String

RuntimeMXBean.getManagementSpecVersion​()

返回由运行的Java虚拟机实现的管理接口的规范版本。

String[]

MemoryPoolMXBean.getMemoryManagerNames​()

返回管理此内存池的内存管理器的名称。

String[]

MemoryManagerMXBean.getMemoryPoolNames​()

返回此内存管理器管理的内存池的名称。

String

BufferPoolMXBean.getName​()

返回表示此缓冲池的名称。

String

CompilationMXBean.getName​()

返回即时（JIT）编译器的名称。

String

MemoryManagerMXBean.getName​()

返回表示此内存管理器的名称。

String

MemoryPoolMXBean.getName​()

返回表示此内存池的名称。

String

OperatingSystemMXBean.getName​()

返回操作系统名称。

String

RuntimeMXBean.getName​()

返回表示正在运行的Java虚拟机的名称。

String

PlatformLoggingMXBean.getParentLoggerName​(String loggerName)

返回指定记录器的 parent的名称。

String

MemoryNotificationInfo.getPoolName​()

返回触发此通知的内存池的名称。

String

RuntimeMXBean.getSpecName​()

返回Java虚拟机规范名称。

String

RuntimeMXBean.getSpecVendor​()

返回Java虚拟机规范供应商。

String

RuntimeMXBean.getSpecVersion​()

返回Java虚拟机规范版本。

String

ThreadInfo.getThreadName​()

返回与此 ThreadInfo相关联的线程的名称。

String

OperatingSystemMXBean.getVersion​()

返回操作系统版本。

String

RuntimeMXBean.getVmName​()

返回Java虚拟机实现名称。

String

RuntimeMXBean.getVmVendor​()

返回Java虚拟机实现供应商。

String

RuntimeMXBean.getVmVersion​()

返回Java虚拟机实现版本。

String

LockInfo.toString​()

返回一个锁的字符串表示形式。

String

MemoryType.toString​()

返回此 MemoryType的字符串表示 MemoryType 。

String

MemoryUsage.toString​()

返回此内存使用情况的描述性表示。

String

ThreadInfo.toString​()

返回此线程信息的字符串表示形式。

Methods in java.lang.management that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

RuntimeMXBean.getInputArguments​()

返回传递给Java虚拟机的输入参数，该虚拟机不包括 main方法的参数。

List<String>

PlatformLoggingMXBean.getLoggerNames​()

返回当前注册的logger名称的列表。

Map<String,String>

RuntimeMXBean.getSystemProperties​()

返回所有系统属性的名称和值的映射。

Map<String,String>

RuntimeMXBean.getSystemProperties​()

返回所有系统属性的名称和值的映射。

Methods in java.lang.management with parameters of type String

Modifier and Type

方法

描述

String

PlatformLoggingMXBean.getLoggerLevel​(String loggerName)

获取与指定记录器关联的日志 level的名称。

String

PlatformLoggingMXBean.getParentLoggerName​(String loggerName)

返回指定记录器的 parent的名称。

static <T> T

ManagementFactory.newPlatformMXBeanProxy​(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)

返回给定的平台MXBean接口的代理 MXBean name转发其方法调用通过给定 MBeanServerConnection 。

void

PlatformLoggingMXBean.setLoggerLevel​(String loggerName, String levelName)

将指定的记录器设置为指定的新的 level 。

static MemoryType

MemoryType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.lang.management with parameters of type String

Constructor

描述

LockInfo​(String className, int identityHashCode)

构造一个 LockInfo对象。

ManagementPermission​(String name)

构造具有指定名称的ManagementPermission。

ManagementPermission​(String name, String actions)

构造一个新的ManagementPermission对象。

MemoryNotificationInfo​(String poolName, MemoryUsage usage, long count)

构造一个 MemoryNotificationInfo对象。

MonitorInfo​(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)

构造一个 MonitorInfo对象。

Uses of String in java.lang.module

Methods in java.lang.module that return String

Modifier and Type

方法

描述

String

ModuleDescriptor.name​()

返回模块名称。

String

ModuleDescriptor.Requires.name​()

返回模块名称。

String

ResolvedModule.name​()

返回模块名称。

String

ModuleDescriptor.Provides.service​()

返回服务类型的完全限定类名。

String

ModuleDescriptor.Exports.source​()

返回包名称。

String

ModuleDescriptor.Opens.source​()

返回包名称。

String

ModuleDescriptor.toNameAndVersion​()

返回一个包含模块名称的字符串，如果存在，则显示其版本。

String

Configuration.toString​()

返回描述此配置的字符串。

String

ModuleDescriptor.Exports.toString​()

返回描述导出包的字符串。

String

ModuleDescriptor.Opens.toString​()

返回描述打开包的字符串。

String

ModuleDescriptor.Provides.toString​()

返回描述此提供的字符串。

String

ModuleDescriptor.Requires.toString​()

返回描述此模块依赖关系的字符串。

String

ModuleDescriptor.toString​()

返回描述模块的字符串。

String

ModuleDescriptor.Version.toString​()

返回解析此版本的字符串。

String

ResolvedModule.toString​()

返回描述此已解析模块的字符串。

Methods in java.lang.module that return types with arguments of type String

Modifier and Type

方法

描述

Stream<String>

ModuleReader.list​()

列出模块的内容，返回作为模块中所有资源名称的元素流。

Optional<String>

ModuleDescriptor.mainClass​()

返回模块主类。

Set<String>

ModuleDescriptor.packages​()

返回模块中的一组包。

List<String>

ModuleDescriptor.Provides.providers​()

返回提供商或提供者工厂的完全限定类名的列表。

Optional<String>

ModuleDescriptor.Requires.rawCompiledVersion​()

如果在编译时记录，则返回具有可能不可粗体版本的模块的字符串。

Optional<String>

ModuleDescriptor.rawVersion​()

返回具有可能不可粗体版本的模块的字符串

Set<String>

ModuleDescriptor.Exports.targets​()

对于合格的导出，返回导出包的模块名称的非空和不可变的集合。

Set<String>

ModuleDescriptor.Opens.targets​()

对于合格的打开，返回打包该包的模块名称的非空和不可变的集合。

Set<String>

ModuleDescriptor.uses​()

返回一组服务依赖关系。

Methods in java.lang.module with parameters of type String

Modifier and Type

方法

描述

ModuleDescriptor.Builder

ModuleDescriptor.Builder.exports​(String pn)

添加导出的包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.exports​(String pn, Set<String> targets)

添加导出的包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn)

使用给定（可能为空）的修饰符集添加导出的包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn, Set<String> targets)

使用给定（可能为空）的修饰符集添加导出的包。

Optional<ModuleReference>

ModuleFinder.find​(String name)

查找给定名称的模块的引用。

Optional<URI>

ModuleReader.find​(String name)

查找资源，将URI返回给模块中的资源。

Optional<ResolvedModule>

Configuration.findModule​(String name)

在此配置中查找已解决的模块，或者在此配置中 找不到parent配置。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.mainClass​(String mc)

设置模块主类。

static ModuleDescriptor.Builder

ModuleDescriptor.newAutomaticModule​(String name)

实例化构建器为自动模块构建模块描述符。

static ModuleDescriptor.Builder

ModuleDescriptor.newModule​(String name)

实例化构建器以构建 正常模块的模块描述符。

static ModuleDescriptor.Builder

ModuleDescriptor.newModule​(String name, Set<ModuleDescriptor.Modifier> ms)

实例化构建器以构建模块描述符。

static ModuleDescriptor.Builder

ModuleDescriptor.newOpenModule​(String name)

实例化构建器为开放模块构建模块描述符。

default Optional<InputStream>

ModuleReader.open​(String name)

打开资源，返回输入流以读取模块中的资源。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.opens​(String pn)

添加一个开放的包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.opens​(String pn, Set<String> targets)

添加一个开放的包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn)

添加一个带有给定（可能为空）的修饰符集的开放包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn, Set<String> targets)

添加一个带有给定（可能为空）的修饰符集的开放包。

static ModuleDescriptor.Version

ModuleDescriptor.Version.parse​(String v)

将给定的字符串解析为版本字符串。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.provides​(String service, List<String> providers)

提供服务的实现。

default Optional<ByteBuffer>

ModuleReader.read​(String name)

读取资源，返回一个具有资源内容的字节缓冲区。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.requires​(String mn)

使用一组空白的修饰符添加对模块的依赖。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn)

使用给定（可能为空）的修饰符集添加对模块的依赖。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn, ModuleDescriptor.Version compiledVersion)

使用给定（可能为空）的修饰符集添加对模块的依赖。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.uses​(String service)

增加服务依赖性。

static ModuleDescriptor.Exports.Modifier

ModuleDescriptor.Exports.Modifier.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ModuleDescriptor.Modifier

ModuleDescriptor.Modifier.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ModuleDescriptor.Opens.Modifier

ModuleDescriptor.Opens.Modifier.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ModuleDescriptor.Requires.Modifier

ModuleDescriptor.Requires.Modifier.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.version​(String vs)

设置模块版本。

Method parameters in java.lang.module with type arguments of type String

Modifier and Type

方法

描述

ModuleDescriptor.Builder

ModuleDescriptor.Builder.exports​(String pn, Set<String> targets)

添加导出的包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.opens​(String pn, Set<String> targets)

添加一个开放的包。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.packages​(Set<String> pns)

将包添加到模块。

ModuleDescriptor.Builder

ModuleDescriptor.Builder.provides​(String service, List<String> providers)

提供服务的实现。

static ModuleDescriptor

ModuleDescriptor.read​(InputStream in, Supplier<Set<String>> packageFinder)

从输入流读取模块声明的二进制形式作为模块描述符。

static ModuleDescriptor

ModuleDescriptor.read​(ByteBuffer bb, Supplier<Set<String>> packageFinder)

从字节缓冲区中读取模块声明的二进制形式作为模块描述符。

Configuration

Configuration.resolve​(ModuleFinder before, ModuleFinder after, Collection<String> roots)

解决一个根模块的集合，以此配置为其父级，以创建新的配置。

static Configuration

Configuration.resolve​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)

解析根模块的集合以创建配置。

Configuration

Configuration.resolveAndBind​(ModuleFinder before, ModuleFinder after, Collection<String> roots)

解决一系列根模块，具有服务绑定，并将此配置作为其父配置来创建新配置。

static Configuration

Configuration.resolveAndBind​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)

解决一系列根模块，具有服务绑定功能，以创建配置。

Constructors in java.lang.module with parameters of type String

Constructor

描述

FindException​(String msg)

构造具有给定详细消息的 FindException 。

FindException​(String msg, Throwable cause)

构造一个 FindException与给定的详细信息和原因。

InvalidModuleDescriptorException​(String msg)

构造具有指定详细消息的 InvalidModuleDescriptorException 。

ResolutionException​(String msg)

构造具有给定详细消息的 ResolutionException 。

ResolutionException​(String msg, Throwable cause)

构造一个 ResolutionException与给定的详细信息和原因。

Uses of String in java.lang.reflect

Methods in java.lang.reflect that return String

Modifier and Type

方法

描述

String

Constructor.getName​()

以字符串形式返回此构造函数的名称。

abstract String

Executable.getName​()

返回由此对象表示的可执行文件的名称。

String

Field.getName​()

返回由该 Field对象表示的字段的名称。

String

Member.getName​()

返回由此成员表示的基础成员或构造函数的简单名称。

String

Method.getName​()

返回由该 方法对象表示的方法的名称，作为 String 。

String

Parameter.getName​()

返回参数的名称。

String

TypeVariable.getName​()

返回此类型变量的名称，因为它在源代码中出现。

default String

Type.getTypeName​()

返回描述此类型的字符串，包括有关任何类型参数的信息。

String

Constructor.toGenericString​()

返回一个描述这个 Constructor的字符串，包括类型参数。

abstract String

Executable.toGenericString​()

返回一个描述这个 Executable的字符串，包括任何类型的参数。

String

Field.toGenericString​()

返回描述这个 Field的字符串，包括它的泛型类型。

String

Method.toGenericString​()

返回一个描述这个 方法的字符串，包括类型参数。

String

Constructor.toString​()

返回一个描述这个 Constructor的字符串。

String

Field.toString​()

返回一个描述这个 Field的字符串。

String

Method.toString​()

返回一个描述这个 方法的字符串。

static String

Modifier.toString​(int mod)

返回描述指定修饰符中的访问修饰符标志的字符串。

String

Parameter.toString​()

返回描述此参数的字符串。

Constructors in java.lang.reflect with parameters of type String

Constructor

描述

GenericSignatureFormatError​(String message)

使用指定的消息构造新的 GenericSignatureFormatError 。

InaccessibleObjectException​(String msg)

构造具有给定详细消息的 InaccessibleObjectException 。

InvocationTargetException​(Throwable target, String s)

构造一个具有目标异常和详细消息的InvocationTargetException。

MalformedParametersException​(String reason)

创建一个 MalformedParametersException 。

ReflectPermission​(String name)

构造具有指定名称的ReflectPermission。

ReflectPermission​(String name, String actions)

构造具有指定名称和操作的ReflectPermission。

UndeclaredThrowableException​(Throwable undeclaredThrowable, String s)

构造一个 UndeclaredThrowableException与指定的 Throwable和一个详细信息。

Uses of String in java.math

Methods in java.math that return String

Modifier and Type

方法

描述

String

BigDecimal.toEngineeringString​()

返回此 BigDecimal的字符串表示 BigDecimal ，如果需要指数则使用工程符号。

String

BigDecimal.toPlainString​()

返回没有指数字段的 BigDecimal的字符串表示形式。

String

BigDecimal.toString​()

返回此 BigDecimal的字符串表示 BigDecimal ，如果需要指数，则使用科学计数法。

String

BigInteger.toString​()

返回此BigInteger的十进制字符串表示形式。

String

BigInteger.toString​(int radix)

返回给定基数中BigInteger的String表示形式。

String

MathContext.toString​()

返回此 MathContext的字符串表示 MathContext 。

Methods in java.math with parameters of type String

Modifier and Type

方法

描述

static RoundingMode

RoundingMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.math with parameters of type String

Constructor

描述

BigDecimal​(String val)

将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal 。

BigDecimal​(String val, MathContext mc)

将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符串，根据上下文设置进行舍入。

BigInteger​(String val)

将BigInteger的十进制字符串表示形式转换为BigInteger。

BigInteger​(String val, int radix)

将指定基数中的BigInteger的String表示形式转换为BigInteger。

MathContext​(String val)

从一个字符串构造一个新的 MathContext 。

Uses of String in java.net

Fields in java.net declared as String

Modifier and Type

Field

描述

protected String

HttpURLConnection.method

HTTP方法（GET，POST，PUT等）。

protected String

HttpURLConnection.responseMessage

HTTP响应消息。

Methods in java.net that return String

Modifier and Type

方法

描述

static String

URLDecoder.decode​(String s)

已过时。
结果字符串可能会因平台的默认编码而异。 而是使用decode（String，String）方法来指定编码。

static String

URLDecoder.decode​(String s, String enc)

使用特定的编码方案解码 application/x-www-form-urlencoded字符串。

static String

URLEncoder.encode​(String s)

已过时。
结果字符串可能会因平台的默认编码而异。 而是使用encode（String，String）方法来指定编码。

static String

URLEncoder.encode​(String s, String enc)

使用特定的编码方案将字符串转换为 application/x-www-form-urlencoded格式。

String

SocketPermission.getActions​()

返回动作的规范字符串表示形式。

String

URLPermission.getActions​()

返回标准化方法列表和请求头列表，格式如下：

String

URI.getAuthority​()

返回此URI的已解码权限组件。

String

URL.getAuthority​()

获得这个 URL的权限部分。

String

InetAddress.getCanonicalHostName​()

获取此IP地址的完全限定域名。

abstract String

SecureCacheResponse.getCipherSuite​()

返回在检索网络资源的原始连接上使用的加密套件。

String

HttpCookie.getComment​()

返回描述此cookie的目的的注释，如果cookie没有注释，则返回 null 。

String

HttpCookie.getCommentURL​()

返回描述此cookie的目的的注释URL，如果cookie没有注释URL，则返回 null 。

String

URLConnection.getContentEncoding​()

返回 content-encoding标题字段的值。

String

URLConnection.getContentType​()

返回 content-type标题字段的值。

String

FileNameMap.getContentTypeFor​(String fileName)

获取指定文件名的MIME类型。

static String

URLConnection.getDefaultRequestProperty​(String key)

已过时。
在获得适当的URLConnection实例之后，应该使用实例特定的getRequestProperty方法。

String

NetworkInterface.getDisplayName​()

获取此网络接口的显示名称。

String

HttpCookie.getDomain​()

返回为此cookie设置的域名。

String

JarURLConnection.getEntryName​()

返回此连接的条目名称。

String

URL.getFile​()

获取此 URL的文件名。

String

URI.getFragment​()

返回此URI的解码片段组件。

String

HttpURLConnection.getHeaderField​(int n)

返回的值 n th头字段。

String

URLConnection.getHeaderField​(int n)

返回的值 n th头字段。

String

URLConnection.getHeaderField​(String name)

返回命名头字段的值。

String

HttpURLConnection.getHeaderFieldKey​(int n)

返回的关键 n th头字段。

String

URLConnection.getHeaderFieldKey​(int n)

返回的关键 n th头字段。

String

URI.getHost​()

返回此URI的主机组件。

String

URL.getHost​()

获取此 URL的主机名（如果适用）。

String

Inet4Address.getHostAddress​()

以文本表示形式返回IP地址字符串。

String

Inet6Address.getHostAddress​()

返回文本显示中的IP地址字符串。

String

InetAddress.getHostAddress​()

返回文本显示中的IP地址字符串。

String

InetAddress.getHostName​()

获取此IP地址的主机名。

String

InetSocketAddress.getHostName​()

获得 hostname 。

String

InetSocketAddress.getHostString​()

如果没有主机名（使用文字创建），则返回主机名或地址的String形式。

String

URISyntaxException.getInput​()

返回输入字符串。

String

HttpRetryException.getLocation​()

如果由重定向导致错误，则返回“位置”头域的值。

String

URISyntaxException.getMessage​()

返回描述解析错误的字符串。

String

HttpCookie.getName​()

返回cookie的名称。

String

NetworkInterface.getName​()

获取此网络接口的名称。

String

HttpCookie.getPath​()

返回浏览器返回此Cookie的服务器上的路径。

String

URI.getPath​()

返回此URI的解码路径组件。

String

URL.getPath​()

获取此 URL的路径部分。

String

HttpCookie.getPortlist​()

返回cookie的端口列表属性

String

URL.getProtocol​()

获取此协议名称 URL 。

String

URI.getQuery​()

返回此URI的解码查询组件。

String

URL.getQuery​()

获取此 URL的查询部分。

String

URI.getRawAuthority​()

返回此URI的原始权限组件。

String

URI.getRawFragment​()

返回此URI的原始片段组件。

String

URI.getRawPath​()

返回此URI的原始路径组件。

String

URI.getRawQuery​()

返回此URI的原始查询组件。

String

URI.getRawSchemeSpecificPart​()

返回此URI的原始方案特定部分。

String

URI.getRawUserInfo​()

返回此URI的原始用户信息组件。

String

HttpRetryException.getReason​()

返回一个字符串，解释为什么不能重试http请求。

String

URISyntaxException.getReason​()

返回一个字符串，解释为什么无法解析输入字符串。

String

URL.getRef​()

获得 URL的锚点（也称为“参考”）。

protected String

Authenticator.getRequestingHost​()

获取 hostname的网站或代理请求验证的，或 null如果不可用。

protected String

Authenticator.getRequestingPrompt​()

获取请求者给出的提示字符串。

protected String

Authenticator.getRequestingProtocol​()

给出请求连接的协议。

protected String

Authenticator.getRequestingScheme​()

获取请求者的方案（例如HTTP防火墙的HTTP方案）。

String

HttpURLConnection.getRequestMethod​()

获取请求方法。

String

URLConnection.getRequestProperty​(String key)

返回此连接的命名的常规请求属性的值。

String

HttpURLConnection.getResponseMessage​()

获取与服务器的响应代码一起返回的HTTP响应消息（如果有）。

String

URI.getScheme​()

返回此URI的方案组件。

String

URI.getSchemeSpecificPart​()

返回此URI的解码方案特定部分。

String

URI.getUserInfo​()

返回此URI的解码的用户信息组件。

String

URL.getUserInfo​()

获取这个 URL的userInfo部分。

String

PasswordAuthentication.getUserName​()

返回用户名。

String

HttpCookie.getValue​()

返回cookie的值。

static String

URLConnection.guessContentTypeFromName​(String fname)

根据URL的指定“文件”组件，尝试确定对象的内容类型。

static String

URLConnection.guessContentTypeFromStream​(InputStream is)

根据输入流开头的字符，尝试确定输入流的类型。

String

ProtocolFamily.name​()

返回协议族的名称。

String

SocketOption.name​()

返回套接字选项的名称。

static String

IDN.toASCII​(String input)

将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。

static String

IDN.toASCII​(String input, int flag)

将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。

String

URI.toASCIIString​()

将此URI的内容作为US-ASCII字符串返回。

String

URL.toExternalForm​()

构造此 URL的字符串表示 URL 。

protected String

URLStreamHandler.toExternalForm​(URL u)

将 URL的特定协议转换为 String 。

String

HttpCookie.toString​()

构造此Cookie的Cookie标题字符串表示形式，其格式为相应Cookie规范定义的格式，但不包含前导“Cookie：”标记。

String

InetAddress.toString​()

将此IP地址转换为 String 。

String

InetSocketAddress.toString​()

构造此InetSocketAddress的字符串表示形式。

String

InterfaceAddress.toString​()

将此接口地址转换为 String 。

String

NetworkInterface.toString​()

String

Proxy.toString​()

构造此代理的字符串表示形式。

String

ServerSocket.toString​()

将该套接字的实现地址和实现端口作为 String 。

String

Socket.toString​()

将此套接字转换为 String 。

String

SocketImpl.toString​()

将此套接字的地址和端口作为 String 。

String

URI.toString​()

以字符串形式返回此URI的内容。

String

URL.toString​()

构造一个 URL的字符串表示 URL 。

String

URLConnection.toString​()

返回此URL连接的 String表示。

static String

IDN.toUnicode​(String input)

将字符串从ASCII兼容编码（ACE）转换为Unicode，由 RFC 3490的ToUnicode操作定义。

static String

IDN.toUnicode​(String input, int flag)

将字符串从ASCII兼容编码（ACE）转换为Unicode，由 RFC 3490的ToUnicode操作定义。

Methods in java.net that return types with arguments of type String

Modifier and Type

方法

描述

abstract Map<String,List<String>>

CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)

从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。

abstract Map<String,List<String>>

CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)

从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。

Map<String,List<String>>

CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

URLConnection.getHeaderFields​()

返回不可修改的标题字段的映射。

Map<String,List<String>>

URLConnection.getHeaderFields​()

返回不可修改的标题字段的映射。

abstract Map<String,List<String>>

CacheResponse.getHeaders​()

将响应标头作为Map返回。

abstract Map<String,List<String>>

CacheResponse.getHeaders​()

将响应标头作为Map返回。

Map<String,List<String>>

URLConnection.getRequestProperties​()

返回此连接的一般请求属性的不可修改映射。

Map<String,List<String>>

URLConnection.getRequestProperties​()

返回此连接的一般请求属性的不可修改映射。

Methods in java.net with parameters of type String

Modifier and Type

方法

描述

void

URLConnection.addRequestProperty​(String key, String value)

添加由键值对指定的一般请求属性。

protected abstract void

SocketImpl.connect​(String host, int port)

将此套接字连接到指定主机上的指定端口。

static URI

URI.create​(String str)

通过解析给定的字符串创建一个URI。

ContentHandler

ContentHandlerFactory.createContentHandler​(String mimetype)

创建一个新的 ContentHandler从 URLStreamHandler读取一个对象。

static InetSocketAddress

InetSocketAddress.createUnresolved​(String host, int port)

从主机名和端口号创建未解析的套接字地址。

URLStreamHandler

URLStreamHandlerFactory.createURLStreamHandler​(String protocol)

使用指定的协议创建一个新的 URLStreamHandler实例。

static String

URLDecoder.decode​(String s)

已过时。
结果字符串可能会因平台的默认编码而异。 而是使用decode（String，String）方法来指定编码。

static String

URLDecoder.decode​(String s, String enc)

使用特定的编码方案解码 application/x-www-form-urlencoded字符串。

protected 软件包

URLClassLoader.definePackage​(String name, Manifest man, URL url)

在这个 URLClassLoader按名称定义一个新的包。

static boolean

HttpCookie.domainMatches​(String domain, String host)

检查主机名是否在域中的实用方法。

static String

URLEncoder.encode​(String s)

已过时。
结果字符串可能会因平台的默认编码而异。 而是使用encode（String，String）方法来指定编码。

static String

URLEncoder.encode​(String s, String enc)

使用特定的编码方案将字符串转换为 application/x-www-form-urlencoded格式。

protected Class<?>

URLClassLoader.findClass​(String name)

从URL搜索路径查找并加载具有指定名称的类。

URL

URLClassLoader.findResource​(String name)

在URL搜索路径上查找具有指定名称的资源。

Enumeration<URL>

URLClassLoader.findResources​(String name)

返回表示URL搜索路径上具有指定名称的所有资源的URL的枚举。

abstract CacheResponse

ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)

根据请求的uri，请求方法和请求标头检索缓存的响应。

static InetAddress[]

InetAddress.getAllByName​(String host)

给定主机的名称，根据系统上配置的名称服务返回其IP地址数组。

static Inet6Address

Inet6Address.getByAddress​(String host, byte[] addr, int scope_id)

按照 InetAddress.getByAddress(String,byte[])的确切方式创建Inet6Address，但将IPv6范围 ID设置为给定的数值。

static Inet6Address

Inet6Address.getByAddress​(String host, byte[] addr, NetworkInterface nif)

在的确切方式创建Inet6Address， InetAddress.getByAddress(String,byte[])不同之处在于将IPv6 scope_id设置为对应于在指定的地址类型的给定接口的值 addr 。

static InetAddress

InetAddress.getByAddress​(String host, byte[] addr)

根据提供的主机名和IP地址创建InetAddress。

static InetAddress

InetAddress.getByName​(String host)

确定主机名称的IP地址。

static NetworkInterface

NetworkInterface.getByName​(String name)

搜索具有指定名称的网络接口。

String

FileNameMap.getContentTypeFor​(String fileName)

获取指定文件名的MIME类型。

static String

URLConnection.getDefaultRequestProperty​(String key)

已过时。
在获得适当的URLConnection实例之后，应该使用实例特定的getRequestProperty方法。

static boolean

URLConnection.getDefaultUseCaches​(String protocol)

返回给定协议的默认值 useCaches标志。

String

URLConnection.getHeaderField​(String name)

返回命名头字段的值。

long

HttpURLConnection.getHeaderFieldDate​(String name, long Default)

long

URLConnection.getHeaderFieldDate​(String name, long Default)

返回以日期解析的命名字段的值。

int

URLConnection.getHeaderFieldInt​(String name, int Default)

返回被解析为命名字段的值。

long

URLConnection.getHeaderFieldLong​(String name, long Default)

返回被解析为命名字段的值。

String

URLConnection.getRequestProperty​(String key)

返回此连接的命名的常规请求属性的值。

InputStream

URLClassLoader.getResourceAsStream​(String name)

返回用于读取指定资源的输入流。

static String

URLConnection.guessContentTypeFromName​(String fname)

根据URL的指定“文件”组件，尝试确定对象的内容类型。

static List<HttpCookie>

HttpCookie.parse​(String header)

从set-cookie或set-cookie2头字符串构造cookie。

protected void

URLStreamHandler.parseURL​(URL u, String spec, int start, int limit)

将 URL的字符串表示解析为 URL对象。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme)

请向系统注册的验证者询问密码。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)

请向系统注册的验证者询问密码。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication​(Authenticator authenticator, String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)

询问给定的 authenticator密码。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication​(InetAddress addr, int port, String protocol, String prompt, String scheme)

请向系统注册的验证者询问密码。

PasswordAuthentication

Authenticator.requestPasswordAuthenticationInstance​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)

向该验证者询问密码。

URI

URI.resolve​(String str)

通过解析给定的字符串构造一个新的URI，然后根据此URI进行解析。

void

HttpCookie.setComment​(String purpose)

指定描述Cookie目的的注释。

void

HttpCookie.setCommentURL​(String purpose)

指定描述Cookie目的的注释URL。

static void

URLConnection.setDefaultRequestProperty​(String key, String value)

已过时。
在获得适当的URLConnection实例之后，应该使用实例特定的setRequestProperty方法。 调用此方法将不起作用。

static void

URLConnection.setDefaultUseCaches​(String protocol, boolean defaultVal)

将命名协议的 useCaches字段的默认值设置为给定值。

void

HttpCookie.setDomain​(String pattern)

指定应显示此Cookie的域。

void

HttpCookie.setPath​(String uri)

指定客户端应该返回cookie的cookie的路径。

void

HttpCookie.setPortlist​(String ports)

指定cookie的端口列表，该端口列表限制Cookie可以在Cookie头中发回的端口。

void

HttpURLConnection.setRequestMethod​(String method)

设置URL请求的方法，其中之一是：GET POST HEAD OPTIONS PUT DELETE TRACE是符合协议限制的合法的。

void

URLConnection.setRequestProperty​(String key, String value)

设置一般请求属性。

protected void

URLStreamHandler.setURL​(URL u, String protocol, String host, int port, String file, String ref)

已过时。
使用setURL（URL，String，String，int，String，String，String，String）;

protected void

URLStreamHandler.setURL​(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)

将 URL参数的字段设置为指示的值。

void

HttpCookie.setValue​(String newValue)

在创建cookie之后为cookie分配一个新值。

static String

IDN.toASCII​(String input)

将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。

static String

IDN.toASCII​(String input, int flag)

将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。

static String

IDN.toUnicode​(String input)

将字符串从ASCII兼容编码（ACE）转换为Unicode，由 RFC 3490的ToUnicode操作定义。

static String

IDN.toUnicode​(String input, int flag)

将字符串从ASCII兼容编码（ACE）转换为Unicode，由 RFC 3490的ToUnicode操作定义。

static Authenticator.RequestorType

Authenticator.RequestorType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Proxy.Type

Proxy.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StandardProtocolFamily

StandardProtocolFamily.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in java.net with type arguments of type String

Modifier and Type

方法

描述

abstract Map<String,List<String>>

CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)

从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。

abstract Map<String,List<String>>

CookieHandler.get​(URI uri, Map<String,List<String>> requestHeaders)

从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。

Map<String,List<String>>

CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

CookieManager.get​(URI uri, Map<String,List<String>> requestHeaders)

abstract CacheResponse

ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)

根据请求的uri，请求方法和请求标头检索缓存的响应。

abstract CacheResponse

ResponseCache.get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)

根据请求的uri，请求方法和请求标头检索缓存的响应。

abstract void

CookieHandler.put​(URI uri, Map<String,List<String>> responseHeaders)

设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。

abstract void

CookieHandler.put​(URI uri, Map<String,List<String>> responseHeaders)

设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。

void

CookieManager.put​(URI uri, Map<String,List<String>> responseHeaders)

void

CookieManager.put​(URI uri, Map<String,List<String>> responseHeaders)

Constructors in java.net with parameters of type String

Constructor

描述

BindException​(String msg)

构造一个新的BindException与指定的详细信息为什么绑定错误发生。

ConnectException​(String msg)

构造一个新的ConnectException与指定的详细信息，为什么连接错误发生。

HttpCookie​(String name, String value)

构造具有指定名称和值的cookie。

HttpRetryException​(String detail, int code)

从指定的响应代码和异常详细消息构造一个新的 HttpRetryException

HttpRetryException​(String detail, int code, String location)

构造新的 HttpRetryException其中包含详细消息responseCode和位置响应头字段的内容。

InetSocketAddress​(String hostname, int port)

从主机名和端口号创建套接字地址。

MalformedURLException​(String msg)

构造具有指定详细消息的 MalformedURLException 。

NetPermission​(String name)

创建一个具有指定名称的新NetPermission。

NetPermission​(String name, String actions)

创建具有指定名称的新NetPermission对象。

NoRouteToHostException​(String msg)

构造一个新的NoRouteToHostException，其中指定的详细信息是为什么无法访问远程主机。

PasswordAuthentication​(String userName, char[] password)

从给定的用户名和密码创建一个新的 PasswordAuthentication对象。

PortUnreachableException​(String msg)

构造一个新的 PortUnreachableException与一个详细的消息。

ProtocolException​(String message)

构造一个新的 ProtocolException具有指定的详细信息。

Socket​(String host, int port)

创建流套接字并将其连接到指定主机上的指定端口号。

Socket​(String host, int port, boolean stream)

已过时。
使用DatagramSocket代替UDP传输。

Socket​(String host, int port, InetAddress localAddr, int localPort)

创建套接字并将其连接到指定远程端口上的指定远程主机。

SocketException​(String msg)

构造一个新的 SocketException与指定的详细信息。

SocketPermission​(String host, String action)

使用指定的操作创建一个新的SocketPermission对象。

SocketTimeoutException​(String msg)

构造一个带有详细消息的新SocketTimeoutException。

UnknownHostException​(String message)

构造一个新的 UnknownHostException与指定的详细信息。

UnknownServiceException​(String msg)

构造一个新的 UnknownServiceException具有指定的详细信息。

URI​(String str)

通过解析给定的字符串构造一个URI。

URI​(String scheme, String ssp, String fragment)

从给定的组件构造一个URI。

URI​(String scheme, String userInfo, String host, int port, String path, String query, String fragment)

从给定的组件构造一个分层URI。

URI​(String scheme, String host, String path, String fragment)

从给定的组件构造一个分层URI。

URI​(String scheme, String authority, String path, String query, String fragment)

从给定的组件构造一个分层URI。

URISyntaxException​(String input, String reason)

从给定的输入字符串构造一个实例和原因。

URISyntaxException​(String input, String reason, int index)

从给定的输入字符串，原因和错误索引构造一个实例。

URL​(String spec)

从 String表示中创建一个 URL对象。

URL​(String protocol, String host, int port, String file)

创建 URL从指定对象 protocol ， host ， port号码，和 file 。

URL​(String protocol, String host, int port, String file, URLStreamHandler handler)

创建 URL从指定对象 protocol ， host ， port号码， file ，和 handler 。

URL​(String protocol, String host, String file)

从指定的 protocol名称， host名称和 file名称创建一个URL。

URL​(URL context, String spec)

通过在指定的上下文中解析给定的规范来创建一个URL。

URL​(URL context, String spec, URLStreamHandler handler)

通过在指定上下文中使用指定的处理程序解析给定规范来创建URL。

URLClassLoader​(String name, URL[] urls, ClassLoader parent)

为指定的URL构造一个新的命名为 URLClassLoader 。

URLClassLoader​(String name, URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)

为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的命名为 URLClassLoader 。

URLPermission​(String url)

使用给定的url字符串和无限制的方法创建一个URLPermission，并通过调用两个参数构造函数来请求头，如下所示：URLPermission（url，“*：*”）

URLPermission​(String url, String actions)

从url字符串创建一个新的URLPermission，并允许给定的请求方法和用户可设置的请求头。

Uses of String in java.nio

Methods in java.nio that return String

Modifier and Type

方法

描述

String

ByteBuffer.toString​()

返回一个汇总此缓冲区状态的字符串。

String

ByteOrder.toString​()

构造描述此对象的字符串。

String

CharBuffer.toString​()

返回一个包含此缓冲区中字符的字符串。

String

DoubleBuffer.toString​()

返回一个汇总此缓冲区状态的字符串。

String

FloatBuffer.toString​()

返回一个汇总此缓冲区状态的字符串。

String

IntBuffer.toString​()

返回一个汇总此缓冲区状态的字符串。

String

LongBuffer.toString​()

返回一个汇总此缓冲区状态的字符串。

String

ShortBuffer.toString​()

返回一个汇总此缓冲区状态的字符串。

Methods in java.nio with parameters of type String

Modifier and Type

方法

描述

CharBuffer

CharBuffer.put​(String src)

相对大容量 put方法 （可选操作） 。

CharBuffer

CharBuffer.put​(String src, int start, int end)

相对大容量 put方法 （可选操作） 。

Uses of String in java.nio.channels

Methods in java.nio.channels that return String

Modifier and Type

方法

描述

String

FileChannel.MapMode.toString​()

返回描述此文件映射模式的字符串。

String

FileLock.toString​()

返回描述此锁的范围，类型和有效性的字符串。

Methods in java.nio.channels with parameters of type String

Modifier and Type

方法

描述

static Reader

Channels.newReader​(ReadableByteChannel ch, String csName)

构造一个读取器，根据命名的字符集解码来自给定通道的字节。

static Writer

Channels.newWriter​(WritableByteChannel ch, String csName)

构造一个根据命名的字符集对字符进行编码的写入程序，并将生成的字节写入给定的通道。

Uses of String in java.nio.charset

Methods in java.nio.charset that return String

Modifier and Type

方法

描述

String

Charset.displayName​()

返回此字符集的默认语言环境的可读名称。

String

Charset.displayName​(Locale locale)

返回此字符集的给定语言环境的人类可读名称。

String

IllegalCharsetNameException.getCharsetName​()

检索非法字符集名称。

String

UnsupportedCharsetException.getCharsetName​()

检索不支持的字符集的名称。

String

MalformedInputException.getMessage​()

返回消息。

String

UnmappableCharacterException.getMessage​()

返回消息。

String

Charset.name​()

返回此字符集的规范名称。

String

CharsetDecoder.replacement​()

返回此解码器的替换值。

String

Charset.toString​()

返回描述此字符集的字符串。

String

CoderResult.toString​()

返回描述此编码器结果的字符串。

String

CodingErrorAction.toString​()

返回描述此操作的字符串。

Methods in java.nio.charset that return types with arguments of type String

Modifier and Type

方法

描述

Set<String>

Charset.aliases​()

返回一个包含此字符集的别名的集合。

static SortedMap<String,Charset>

Charset.availableCharsets​()

构造从规范字符集名称到字符集对象的排序映射。

Methods in java.nio.charset with parameters of type String

Modifier and Type

方法

描述

ByteBuffer

Charset.encode​(String str)

在此字符集中将字符串编码为字节的便捷方法。

static Charset

Charset.forName​(String charsetName)

返回名为charset的charset对象。

protected void

CharsetDecoder.implReplaceWith​(String newReplacement)

报告对该解码器的替换值的更改。

static boolean

Charset.isSupported​(String charsetName)

告诉是否支持命名的字符集。

CharsetDecoder

CharsetDecoder.replaceWith​(String newReplacement)

更改此解码器的替换值。

Constructors in java.nio.charset with parameters of type String

Constructor

描述

Charset​(String canonicalName, String[] aliases)

使用给定的规范名称和别名集初始化新的字符集。

IllegalCharsetNameException​(String charsetName)

构造这个类的一个实例。

UnsupportedCharsetException​(String charsetName)

构造这个类的一个实例。

Uses of String in java.nio.charset.spi

Methods in java.nio.charset.spi with parameters of type String

Modifier and Type

方法

描述

abstract Charset

CharsetProvider.charsetForName​(String charsetName)

检索给定字符集名称的字符集。

Uses of String in java.nio.file

Methods in java.nio.file that return String

Modifier and Type

方法

描述

String

FileSystemException.getFile​()

返回用于创建此异常的文件。

String

InvalidPathException.getInput​()

返回输入字符串。

String

FileSystemException.getMessage​()

返回详细消息字符串。

String

InvalidPathException.getMessage​()

返回描述错误的字符串。

String

FileSystemException.getOtherFile​()

返回用于创建此异常的另一个文件。

String

FileSystemException.getReason​()

返回解释为什么文件系统操作失败的字符串。

String

InvalidPathException.getReason​()

返回一个字符串，解释为什么输入字符串被拒绝。

abstract String

FileSystem.getSeparator​()

返回名称分隔符，表示为字符串。

abstract String

FileStore.name​()

返回此文件存储的名称。

String

WatchEvent.Kind.name​()

返回事件类型的名称。

String

WatchEvent.Modifier.name​()

返回修饰符的名称。

static String

Files.probeContentType​(Path path)

探测文件的内容类型。

String

Path.toString​()

返回此路径的字符串表示形式。

abstract String

FileStore.type​()

返回此文件存储的 类型 。

Methods in java.nio.file that return types with arguments of type String

Modifier and Type

方法

描述

static Stream<String>

Files.lines​(Path path)

从文件中读取所有行作为 Stream 。

static Stream<String>

Files.lines​(Path path, Charset cs)

从文件中读取所有行作为 Stream 。

static List<String>

Files.readAllLines​(Path path)

从文件中读取所有行。

static List<String>

Files.readAllLines​(Path path, Charset cs)

从文件中读取所有行。

static Map<String,Object>

Files.readAttributes​(Path path, String attributes, LinkOption... options)

读取一组文件属性作为批量操作。

abstract Set<String>

FileSystem.supportedFileAttributeViews​()

返回 FileSystem支持的文件属性视图的 FileSystem 。

Methods in java.nio.file with parameters of type String

Modifier and Type

方法

描述

static Path

Files.createTempDirectory​(String prefix, FileAttribute<?>... attrs)

在默认临时文件目录中创建一个新目录，使用给定的前缀生成其名称。

static Path

Files.createTempDirectory​(Path dir, String prefix, FileAttribute<?>... attrs)

在指定的目录中创建一个新目录，使用给定的前缀生成其名称。

static Path

Files.createTempFile​(String prefix, String suffix, FileAttribute<?>... attrs)

在默认临时文件目录中创建一个空文件，使用给定的前缀和后缀生成其名称。

static Path

Files.createTempFile​(Path dir, String prefix, String suffix, FileAttribute<?>... attrs)

在指定的目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。

default boolean

Path.endsWith​(String other)

测试此路径是否以 Path ，通过转换给定的路径字符串，完全由 endsWith(Path)方法指定的方式 构建 。

static Path

Paths.get​(String first, String... more)

将路径字符串或连接到路径字符串的字符串序列转换为 Path 。

static Object

Files.getAttribute​(Path path, String attribute, LinkOption... options)

读取文件属性的值。

abstract Object

FileStore.getAttribute​(String attribute)

读取文件存储属性的值。

abstract Path

FileSystem.getPath​(String first, String... more)

将路径字符串或将连接到路径字符串的字符串序列转换为 Path 。

abstract PathMatcher

FileSystem.getPathMatcher​(String syntaxAndPattern)

返回一个PathMatcher ，通过解释给定的模式对Path个对象的String表示执行匹配操作。

static DirectoryStream<Path>

Files.newDirectoryStream​(Path dir, String glob)

打开一个目录，返回一个DirectoryStream来迭代目录中的条目。

static Map<String,Object>

Files.readAttributes​(Path path, String attributes, LinkOption... options)

读取一组文件属性作为批量操作。

default Path

Path.resolve​(String other)

一个给定的路径字符串转换为 Path并解析它针对此 Path在完全按规定的方式 resolve方法。

default Path

Path.resolveSibling​(String other)

将给定的路径字符串转换为 Path并按照 resolveSibling方法指定的方式将其解析为该路径的 parent路径。

static Path

Files.setAttribute​(Path path, String attribute, Object value, LinkOption... options)

设置文件属性的值。

default boolean

Path.startsWith​(String other)

测试此路径是否以 Path开始，通过转换给定的路径字符串，完全由 startsWith(Path)方法指定的方式 构建 。

abstract boolean

FileStore.supportsFileAttributeView​(String name)

告诉这个文件存储是否支持由给定文件属性视图标识的文件属性。

static AccessMode

AccessMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static FileVisitOption

FileVisitOption.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static FileVisitResult

FileVisitResult.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static LinkOption

LinkOption.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StandardCopyOption

StandardCopyOption.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StandardOpenOption

StandardOpenOption.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in java.nio.file with type arguments of type String

Modifier and Type

方法

描述

static FileSystem

FileSystems.newFileSystem​(URI uri, Map<String,?> env)

构造一个由URI标识的新文件系统

static FileSystem

FileSystems.newFileSystem​(URI uri, Map<String,?> env, ClassLoader loader)

构造一个由URI标识的新文件系统

Constructors in java.nio.file with parameters of type String

Constructor

描述

AccessDeniedException​(String file)

构造这个类的一个实例。

AccessDeniedException​(String file, String other, String reason)

构造这个类的一个实例。

AtomicMoveNotSupportedException​(String source, String target, String reason)

构造这个类的一个实例。

DirectoryNotEmptyException​(String dir)

构造这个类的一个实例。

FileAlreadyExistsException​(String file)

构造这个类的一个实例。

FileAlreadyExistsException​(String file, String other, String reason)

构造这个类的一个实例。

FileSystemAlreadyExistsException​(String msg)

构造这个类的一个实例。

FileSystemException​(String file)

构造这个类的一个实例。

FileSystemException​(String file, String other, String reason)

构造这个类的一个实例。

FileSystemLoopException​(String file)

构造这个类的一个实例。

FileSystemNotFoundException​(String msg)

构造这个类的一个实例。

InvalidPathException​(String input, String reason)

从给定的输入字符串构造一个实例和原因。

InvalidPathException​(String input, String reason, int index)

从给定的输入字符串，原因和错误索引构造一个实例。

LinkPermission​(String name)

构造具有指定名称的 LinkPermission 。

LinkPermission​(String name, String actions)

构造具有指定名称的 LinkPermission 。

NoSuchFileException​(String file)

构造这个类的一个实例。

NoSuchFileException​(String file, String other, String reason)

构造这个类的一个实例。

NotDirectoryException​(String file)

构造这个类的一个实例。

NotLinkException​(String file)

构造这个类的一个实例。

NotLinkException​(String file, String other, String reason)

构造这个类的一个实例。

ProviderMismatchException​(String msg)

构造这个类的一个实例。

ProviderNotFoundException​(String msg)

构造这个类的一个实例。

Uses of String in java.nio.file.attribute

Methods in java.nio.file.attribute that return String

Modifier and Type

方法

描述

String

UserPrincipalNotFoundException.getName​()

如果使用未找到的用户主体名称创建此异常，则返回用户主体名称，否则为 null 。

String

AclFileAttributeView.name​()

返回属性视图的名称。

String

AttributeView.name​()

返回属性视图的名称。

String

BasicFileAttributeView.name​()

返回属性视图的名称。

String

DosFileAttributeView.name​()

返回属性视图的名称。

String

FileAttribute.name​()

返回属性名称。

String

FileOwnerAttributeView.name​()

返回属性视图的名称。

String

PosixFileAttributeView.name​()

返回属性视图的名称。

String

UserDefinedFileAttributeView.name​()

返回此属性视图的名称。

String

AclEntry.toString​()

返回此ACL条目的字符串表示形式。

String

FileTime.toString​()

返回此 FileTime的字符串表示 FileTime 。

static String

PosixFilePermissions.toString​(Set<PosixFilePermission> perms)

返回一组权限的 String表示。

Methods in java.nio.file.attribute that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

UserDefinedFileAttributeView.list​()

返回包含用户定义属性名称的列表。

Methods in java.nio.file.attribute with parameters of type String

Modifier and Type

方法

描述

void

UserDefinedFileAttributeView.delete​(String name)

删除用户定义的属性。

static Set<PosixFilePermission>

PosixFilePermissions.fromString​(String perms)

返回与给定的 String表示相对应的一组权限。

abstract GroupPrincipal

UserPrincipalLookupService.lookupPrincipalByGroupName​(String group)

按组名查找组主体。

abstract UserPrincipal

UserPrincipalLookupService.lookupPrincipalByName​(String name)

按名称查找用户主体。

int

UserDefinedFileAttributeView.read​(String name, ByteBuffer dst)

将用户定义属性的值读入缓冲区。

int

UserDefinedFileAttributeView.size​(String name)

返回用户定义属性值的大小。

static AclEntryFlag

AclEntryFlag.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static AclEntryPermission

AclEntryPermission.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static AclEntryType

AclEntryType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PosixFilePermission

PosixFilePermission.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

int

UserDefinedFileAttributeView.write​(String name, ByteBuffer src)

从缓冲区写入用户定义属性的值。

Constructors in java.nio.file.attribute with parameters of type String

Constructor

描述

UserPrincipalNotFoundException​(String name)

构造这个类的一个实例。

Uses of String in java.nio.file.spi

Methods in java.nio.file.spi that return String

Modifier and Type

方法

描述

abstract String

FileSystemProvider.getScheme​()

返回标识此提供程序的URI方案。

abstract String

FileTypeDetector.probeContentType​(Path path)

探测给定的文件来猜测其内容类型。

Methods in java.nio.file.spi that return types with arguments of type String

Modifier and Type

方法

描述

abstract Map<String,Object>

FileSystemProvider.readAttributes​(Path path, String attributes, LinkOption... options)

读取一组文件属性作为批量操作。

Methods in java.nio.file.spi with parameters of type String

Modifier and Type

方法

描述

abstract Map<String,Object>

FileSystemProvider.readAttributes​(Path path, String attributes, LinkOption... options)

读取一组文件属性作为批量操作。

abstract void

FileSystemProvider.setAttribute​(Path path, String attribute, Object value, LinkOption... options)

设置文件属性的值。

Method parameters in java.nio.file.spi with type arguments of type String

Modifier and Type

方法

描述

abstract FileSystem

FileSystemProvider.newFileSystem​(URI uri, Map<String,?> env)

构造由URI标识的新的 FileSystem对象。

FileSystem

FileSystemProvider.newFileSystem​(Path path, Map<String,?> env)

构造新的 FileSystem以访问文件的内容作为文件系统。

Uses of String in java.rmi

Methods in java.rmi that return String

Modifier and Type

方法

描述

String

RemoteException.getMessage​()

返回详细信息，包括原因的消息（如果有的话）的异常。

static String[]

Naming.list​(String name)

返回在注册表中绑定的名称的数组。

Methods in java.rmi with parameters of type String

Modifier and Type

方法

描述

static void

Naming.bind​(String name, Remote obj)

将指定的 name绑定到远程对象。

static String[]

Naming.list​(String name)

返回在注册表中绑定的名称的数组。

static Remote

Naming.lookup​(String name)

返回与指定的 name相关联的远程对象的引用（stub）。

static void

Naming.rebind​(String name, Remote obj)

将指定的名称重新绑定到一个新的远程对象。

static void

Naming.unbind​(String name)

销毁与远程对象关联的指定名称的绑定。

Constructors in java.rmi with parameters of type String

Constructor

描述

AccessException​(String s)

构造具有指定详细消息的 AccessException 。

AccessException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 AccessException 。

AlreadyBoundException​(String s)

构造具有指定详细消息的 AlreadyBoundException 。

ConnectException​(String s)

构造具有指定详细消息的 ConnectException 。

ConnectException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 ConnectException 。

ConnectIOException​(String s)

构造具有指定详细消息的 ConnectIOException 。

ConnectIOException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 ConnectIOException 。

MarshalException​(String s)

构造具有指定详细消息的 MarshalException 。

MarshalException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 MarshalException 。

NoSuchObjectException​(String s)

构造具有指定详细消息的 NoSuchObjectException 。

NotBoundException​(String s)

构造具有指定详细消息的 NotBoundException 。

RemoteException​(String s)

构造具有指定详细信息的 RemoteException 。

RemoteException​(String s, Throwable cause)

构造一个具有指定的详细信息和原因的 RemoteException 。

RMISecurityException​(String name)

已过时。
没有替换

RMISecurityException​(String name, String arg)

已过时。
没有替换

ServerError​(String s, Error err)

构造具有指定的详细消息和嵌套错误的 ServerError 。

ServerException​(String s)

构造具有指定详细消息的 ServerException 。

ServerException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 ServerException 。

ServerRuntimeException​(String s, 异常 ex)

已过时。
没有替换

StubNotFoundException​(String s)

构造具有指定详细消息的 StubNotFoundException 。

StubNotFoundException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 StubNotFoundException 。

UnexpectedException​(String s)

构造具有指定详细消息的 UnexpectedException 。

UnexpectedException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 UnexpectedException 。

UnknownHostException​(String s)

构造具有指定详细消息的 UnknownHostException 。

UnknownHostException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 UnknownHostException 。

UnmarshalException​(String s)

构造具有指定详细消息的 UnmarshalException 。

UnmarshalException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 UnmarshalException 。

Uses of String in java.rmi.activation

Methods in java.rmi.activation that return String

Modifier and Type

方法

描述

String

ActivationDesc.getClassName​()

返回此描述符指定的对象的类名。

String

ActivationGroupDesc.getClassName​()

返回组的类名（可能为 null ）。

String[]

ActivationGroupDesc.CommandEnvironment.getCommandOptions​()

获取配置的java命令选项。

String

ActivationGroupDesc.CommandEnvironment.getCommandPath​()

获取配置的路径限定的java命令名称。

String

ActivationDesc.getLocation​()

返回由此描述符指定的对象的代码位置。

String

ActivationGroupDesc.getLocation​()

返回组的代码位置。

String

ActivationException.getMessage​()

返回详细信息，包括原因的消息（如果有的话）的异常。

Methods in java.rmi.activation with parameters of type String

Modifier and Type

方法

描述

static ActivationID

Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)

为指定的对象注册激活描述符（具有指定的位置，数据和重新启动模式），并使用指定的端口导出该对象。

static ActivationID

Activatable.exportObject​(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)

注册指定对象的激活描述符（具有指定位置，数据和重新启动模式），并使用指定的端口以及指定的客户端和服务器套接字工厂导出该对象。

Constructors in java.rmi.activation with parameters of type String

Constructor

描述

Activatable​(String location, MarshalledObject<?> data, boolean restart, int port)

通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并使用指定的端口导出对象。

Activatable​(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)

通过为该对象注册激活描述符（具有指定的位置，数据和重新启动模式）来构造可激活的远程对象，并导出具有指定端口的对象以及指定的客户端和服务器套接字工厂。

ActivateFailedException​(String s)

构造具有指定详细消息的 ActivateFailedException 。

ActivateFailedException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 ActivateFailedException 。

ActivationDesc​(String className, String location, MarshalledObject<?> data)

为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。

ActivationDesc​(String className, String location, MarshalledObject<?> data, boolean restart)

为类名为 className的对象构造一个对象描述符，可以从代码 location加载，其初始化信息为 data 。

ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)

为类名为 className的对象构造一个对象描述符，该对象描述符可以从代码 location加载，其初始化信息为 data 。

ActivationDesc​(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)

为类名为 className的对象构造一个对象描述符，该对象描述符可以从代码 location加载，其初始化信息为 data 。

ActivationException​(String s)

构造具有指定详细消息的 ActivationException 。

ActivationException​(String s, Throwable cause)

构造具有指定的详细信息和原因的 ActivationException 。

ActivationGroupDesc​(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)

指定要用于组的备用组实现和执行环境。

CommandEnvironment​(String cmdpath, String[] argv)

创建一个具有所有必要信息的CommandEnvironment。

UnknownGroupException​(String s)

构造具有指定详细消息的 UnknownGroupException 。

UnknownObjectException​(String s)

构造具有指定详细消息的 UnknownObjectException 。

Uses of String in java.rmi.dgc

Methods in java.rmi.dgc that return String

Modifier and Type

方法

描述

String

VMID.toString​()

返回此VMID的字符串表示形式。

Uses of String in java.rmi.registry

Methods in java.rmi.registry that return String

Modifier and Type

方法

描述

String[]

Registry.list​()

返回在此注册表中绑定的名称的数组。

Methods in java.rmi.registry with parameters of type String

Modifier and Type

方法

描述

void

Registry.bind​(String name, Remote obj)

绑定到此注册表中指定的 name的远程引用。

static Registry

LocateRegistry.getRegistry​(String host)

返回对默认注册表端口1099上指定的 host上的远程对象 Registry的引用。

static Registry

LocateRegistry.getRegistry​(String host, int port)

返回对指定的 host和 port的远程对象 Registry的 port 。

static Registry

LocateRegistry.getRegistry​(String host, int port, RMIClientSocketFactory csf)

返回本地创建的对指定的 host和 port的远程对象 Registry远程引用。

Remote

Registry.lookup​(String name)

返回绑定到此注册表中指定的 name的远程引用。

void

Registry.rebind​(String name, Remote obj)

使用提供的远程引用替换此注册表中指定的 name的绑定。

Registry

RegistryHandler.registryStub​(String host, int port)

已过时。
没有替换。 从Java 2平台v1.2开始，RMI不再使用RegistryHandler来获取注册表的存根。

void

Registry.unbind​(String name)

删除此注册表中指定的 name的绑定。

Uses of String in java.rmi.server

Fields in java.rmi.server declared as String

Modifier and Type

Field

描述

static String

LoaderHandler.packagePrefix

已过时。

系统包装 LoaderHandler实现。

static String

RemoteRef.packagePrefix

初始化服务器包前缀：假定服务器参考类的实现（例如，UnicastRef，UnicastServerRef）位于由前缀定义的包中。

Methods in java.rmi.server that return String

Modifier and Type

方法

描述

static String

RMIClassLoader.getClassAnnotation​(Class<?> cl)

返回在编组给定类的对象时，RMI将用于注释类描述符的注释字符串（表示类定义的位置）。

abstract String

RMIClassLoaderSpi.getClassAnnotation​(Class<?> cl)

提供 RMIClassLoader.getClassAnnotation(Class)的实现。

static String

RemoteServer.getClientHost​()

返回在当前线程中正在处理的远程方法调用的客户端主机的字符串表示形式。

String

ServerRef.getClientHost​()

已过时。

返回当前客户端的主机名。

String

ServerCloneException.getMessage​()

返回详细信息，包括原因的消息（如果有的话）的异常。

String

Operation.getOperation​()

已过时。
没有替换

String

RemoteRef.getRefClass​(ObjectOutput out)

将要序列化的引用类型的类名返回到流“out”。

String

RemoteRef.remoteToString​()

返回一个表示此远程对象引用的字符串。

String

LogStream.toString​()

已过时。
没有替换

String

ObjID.toString​()

返回此对象标识符的字符串表示形式。

String

Operation.toString​()

已过时。
没有替换

String

RemoteObject.toString​()

返回一个表示该远程对象的值的字符串。

String

UID.toString​()

返回此 UID的字符串表示 UID 。

Methods in java.rmi.server with parameters of type String

Modifier and Type

方法

描述

Socket

RMIClientSocketFactory.createSocket​(String host, int port)

创建连接到指定主机和端口的客户端套接字。

abstract Socket

RMISocketFactory.createSocket​(String host, int port)

创建连接到指定主机和端口的客户端套接字。

static ClassLoader

RMIClassLoader.getClassLoader​(String codebase)

返回从给定的代码库URL路径加载类的类加载器。

abstract ClassLoader

RMIClassLoaderSpi.getClassLoader​(String codebase)

提供 RMIClassLoader.getClassLoader(String)的实现。

Class<?>

LoaderHandler.loadClass​(String name)

已过时。
没有替换

Class<?>

LoaderHandler.loadClass​(URL codebase, String name)

已过时。
没有替换

static Class<?>

RMIClassLoader.loadClass​(String name)

已过时。
替换为loadClass(String,String)方法

static Class<?>

RMIClassLoader.loadClass​(String codebase, String name)

从代码库URL路径加载一个类。

static Class<?>

RMIClassLoader.loadClass​(String codebase, String name, ClassLoader defaultLoader)

从代码库URL路径加载类，可选地使用提供的加载程序。

static Class<?>

RMIClassLoader.loadClass​(URL codebase, String name)

从代码库URL加载一个类。

abstract Class<?>

RMIClassLoaderSpi.loadClass​(String codebase, String name, ClassLoader defaultLoader)

为贯彻 RMIClassLoader.loadClass(URL,String) ， RMIClassLoader.loadClass(String,String) ，并 RMIClassLoader.loadClass(String,String,ClassLoader) 。

static Class<?>

RMIClassLoader.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)

加载一个动态代理类（见Proxy ），该代码类通过代码库URL路径实现了一组与给定名称的接口。

abstract Class<?>

RMIClassLoaderSpi.loadProxyClass​(String codebase, String[] interfaces, ClassLoader defaultLoader)

提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader)的实现。

static LogStream

LogStream.log​(String name)

已过时。
没有替换

static int

LogStream.parseLevel​(String s)

已过时。
没有替换

Constructors in java.rmi.server with parameters of type String

Constructor

描述

ExportException​(String s)

构造具有指定详细消息的 ExportException 。

ExportException​(String s, 异常 ex)

构造具有指定的详细消息和嵌套异常的 ExportException 。

Operation​(String op)

已过时。
没有替换

ServerCloneException​(String s)

构造具有指定详细消息的 ServerCloneException 。

ServerCloneException​(String s, 异常 cause)

构造一个具有指定的详细信息和原因的 ServerCloneException 。

ServerNotActiveException​(String s)

构造具有指定详细消息的 ServerNotActiveException 。

SkeletonMismatchException​(String s)

已过时。
没有替换

SkeletonNotFoundException​(String s)

已过时。

构造具有指定详细消息的 SkeletonNotFoundException 。

SkeletonNotFoundException​(String s, 异常 ex)

已过时。

构造具有指定的详细消息和嵌套异常的 SkeletonNotFoundException 。

SocketSecurityException​(String s)

已过时。

构造具有指定详细消息的 SocketSecurityException 。

SocketSecurityException​(String s, 异常 ex)

已过时。

构造具有指定的详细消息和嵌套异常的 SocketSecurityException 。

Uses of String in java.security

Methods in java.security that return String

Modifier and Type

方法

描述

abstract String

KeyStoreSpi.engineGetCertificateAlias​(Certificate cert)

返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。

protected abstract String

AlgorithmParametersSpi.engineToString​()

返回描述参数的格式化字符串。

String

AllPermission.getActions​()

返回动作的规范字符串表示形式。

String

BasicPermission.getActions​()

返回动作的规范字符串表示形式，它当前是空字符串“”，因为BasicPermission没有任何操作。

abstract String

Permission.getActions​()

以String形式返回操作。

String

UnresolvedPermission.getActions​()

返回动作的规范字符串表示形式，它当前是空字符串“”，因为UnresolvedPermission没有任何操作。

String

AlgorithmParameterGenerator.getAlgorithm​()

返回此参数生成器关联的算法的标准名称。

String

AlgorithmParameters.getAlgorithm​()

返回与此参数对象关联的算法的名称。

String

Key.getAlgorithm​()

返回此键的标准算法名称。

String

KeyFactory.getAlgorithm​()

获取与此 KeyFactory相关联的算法的名称。

String

KeyPairGenerator.getAlgorithm​()

返回此密钥对生成器的算法的标准名称。

String

MessageDigest.getAlgorithm​()

返回一个标识算法的字符串，与实现细节无关。

String

Provider.Service.getAlgorithm​()

返回此服务的算法的名称。

String

SecureRandom.getAlgorithm​()

返回由此 SecureRandom对象实现的算法的名称。

String

Signature.getAlgorithm​()

返回此签名对象的算法名称。

String

SignedObject.getAlgorithm​()

检索签名算法的名称。

static String

Security.getAlgorithmProperty​(String algName, String propName)

已过时。
此方法用于返回“SUN”加密服务提供程序的主文件中的专有属性的值，以确定如何解析特定于算法的参数。 AlgorithmParameters使用新的基于提供者和算法的AlgorithmParameters和KeyFactory引擎类（在J2SE版本1.2平台中引入）。

String

Provider.Service.getAttribute​(String name)

返回指定属性的值，如果未为此服务设置此属性，则返回null。

String

KeyStore.getCertificateAlias​(Certificate cert)

返回其证书与给定证书匹配的第一个密钥库条目的（别名）名称。

String

Provider.Service.getClassName​()

返回实现此服务的类的名称。

static String

KeyStore.getDefaultType​()

返回由 keystore.type安全属性指定的默认密钥库类型，或者如果没有这样的属性，则返回字符串“jks”（“Java密钥库”的缩写）。

String

Certificate.getFormat​()

已过时。

返回编码格式的名称。

String

Key.getFormat​()

返回此键的主编码格式的名称，如果此键不支持编码，则返回null。

String

Identity.getInfo​()

已过时。

返回先前为此标识指定的一般信息。

String

Provider.getInfo​()

返回提供商及其服务的可读描述。

String

Identity.getName​()

已过时。

返回此身份的名称。

String

KeyStore.Entry.Attribute.getName​()

返回属性的名称。

String

Permission.getName​()

返回此权限的名称。

String

PKCS12Attribute.getName​()

返回表示为点分隔整数列表的属性的ASN.1对象标识符。

String

Principal.getName​()

返回此主体的名称。

String

Provider.getName​()

返回此提供程序的名称。

String

Provider.getProperty​(String key)

static String

Security.getProperty​(String key)

获取安全属性值。

String

KeyStore.PasswordProtection.getProtectionAlgorithm​()

获取保护算法的名称。

String

KeyStore.getType​()

返回此密钥库的类型。

String

Policy.getType​()

返回此策略的类型。

String

Provider.Service.getType​()

获取此服务的类型。

String

UnresolvedPermission.getUnresolvedActions​()

获取尚未解决的基础权限的操作。

String

UnresolvedPermission.getUnresolvedName​()

获取尚未解决的基础权限的目标名称。

String

UnresolvedPermission.getUnresolvedType​()

获取尚未解决的基础权限的类型（类名）。

String

KeyStore.Entry.Attribute.getValue​()

返回属性的值。

String

PKCS12Attribute.getValue​()

返回属性的ASN.1 DER编码值作为字符串。

String

Provider.getVersionStr​()

返回此提供程序的版本字符串。

String

AlgorithmParameters.toString​()

返回描述参数的格式化字符串。

String

Certificate.toString​(boolean detailed)

已过时。

返回一个表示证书内容的字符串。

String

CodeSigner.toString​()

返回描述此代码签名者的字符串。

String

CodeSource.toString​()

返回描述此CodeSource的字符串，告知其URL和证书。

String

DigestInputStream.toString​()

打印此摘要输入流及其相关消息摘要对象的字符串表示形式。

String

DigestOutputStream.toString​()

打印此摘要输出流及其相关消息摘要对象的字符串表示形式。

String

DrbgParameters.Capability.toString​()

String

DrbgParameters.Instantiation.toString​()

返回此 Instantiation的人类可读字符串表示 Instantiation 。

String

Identity.toString​()

已过时。

返回一个描述此身份的短字符串，告诉其名称及其范围（如果有）。

String

Identity.toString​(boolean detailed)

已过时。

返回此标识的字符串表示形式，可选择更多的细节，不包括 toString方法提供的详细信息，无任何参数。

String

IdentityScope.toString​()

已过时。

返回此标识范围的字符串表示形式，包括其名称，其范围名称和此身份范围中的身份数。

String

KeyStore.PrivateKeyEntry.toString​()

返回此PrivateKeyEntry的字符串表示形式。

String

KeyStore.SecretKeyEntry.toString​()

返回此SecretKeyEntry的字符串表示形式。

String

KeyStore.TrustedCertificateEntry.toString​()

返回此TrustedCertificateEntry的字符串表示形式。

String

MessageDigest.toString​()

返回此消息摘要对象的字符串表示形式。

String

Permission.toString​()

返回描述此权限的字符串。

String

PermissionCollection.toString​()

返回描述此PermissionCollection对象的字符串，提供有关其所包含的所有权限的信息。

String

PKCS12Attribute.toString​()

返回此 PKCS12Attribute的字符串表示 PKCS12Attribute 。

String

Principal.toString​()

返回此主体的字符串表示形式。

String

PrivilegedActionException.toString​()

String

ProtectionDomain.toString​()

将ProtectionDomain转换为字符串。

String

Provider.Service.toString​()

返回此服务的字符串表示形式。

String

Provider.toString​()

返回一个带有该提供者的名称和版本字符串的字符串。

String

SecureRandom.toString​()

返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

String

SecureRandomSpi.toString​()

返回此 SecureRandom的人类可读字符串表示 SecureRandom 。

String

Signature.toString​()

返回此签名对象的字符串表示形式，提供包含对象状态和所使用算法名称的信息。

String

Signer.toString​()

已过时。

返回一个关于签名者的信息字符串。

String

Timestamp.toString​()

返回描述此时间戳的字符串。

String

UnresolvedPermission.toString​()

返回描述此UnresolvedPermission的字符串。

Methods in java.security that return types with arguments of type String

Modifier and Type

方法

描述

Enumeration<String>

KeyStore.aliases​()

列出此密钥库的所有别名。

abstract Enumeration<String>

KeyStoreSpi.engineAliases​()

列出此密钥库的所有别名。

static Set<String>

Security.getAlgorithms​(String serviceName)

返回一组字符串，其中包含指定Java加密服务的所有可用算法或类型的名称（例如Signature，MessageDigest，Cipher，Mac，KeyStore）。

Map<String,KeyStore.ProtectionParameter>

DomainLoadStoreParameter.getProtectionParams​()

获取此域中密钥库的密钥库保护参数。

Methods in java.security with parameters of type String

Modifier and Type

方法

描述

Provider

Provider.configure​(String configArg)

将提供的配置参数应用于此提供程序实例并返回配置的提供程序。

boolean

KeyStore.containsAlias​(String alias)

检查此密钥库中是否存在给定的别名。

protected Class<?>

SecureClassLoader.defineClass​(String name, byte[] b, int off, int len, CodeSource cs)

将字节数组转换为类Class的实例，并具有可选的CodeSource。

protected Class<?>

SecureClassLoader.defineClass​(String name, ByteBuffer b, CodeSource cs)

一个转换ByteBuffer成类的实例Class ，使用可选的CodeSource。

void

KeyStore.deleteEntry​(String alias)

从此密钥库中删除由给定别名标识的条目。

abstract boolean

KeyStoreSpi.engineContainsAlias​(String alias)

检查此密钥库中是否存在给定的别名。

abstract void

KeyStoreSpi.engineDeleteEntry​(String alias)

从此密钥库中删除由给定别名标识的条目。

boolean

KeyStoreSpi.engineEntryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)

确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。

abstract Certificate

KeyStoreSpi.engineGetCertificate​(String alias)

返回与给定别名相关联的证书。

abstract Certificate[]

KeyStoreSpi.engineGetCertificateChain​(String alias)

返回与给定别名关联的证书链。

abstract Date

KeyStoreSpi.engineGetCreationDate​(String alias)

返回由给定别名标识的条目的创建日期。

protected abstract byte[]

AlgorithmParametersSpi.engineGetEncoded​(String format)

返回以指定格式编码的参数。

KeyStore.Entry

KeyStoreSpi.engineGetEntry​(String alias, KeyStore.ProtectionParameter protParam)

获取具有指定保护参数的指定别名的 KeyStore.Entry 。

abstract Key

KeyStoreSpi.engineGetKey​(String alias, char[] password)

返回与给定别名相关联的密钥，使用给定的密码恢复它。

protected abstract Object

SignatureSpi.engineGetParameter​(String param)

已过时。

protected abstract void

AlgorithmParametersSpi.engineInit​(byte[] params, String format)

从 params导入参数，并根据指定的解码格式进行解码。

abstract boolean

KeyStoreSpi.engineIsCertificateEntry​(String alias)

如果由给定别名标识的条目是通过调用 setCertificateEntry创建的，或通过调用 setEntry与 TrustedCertificateEntry创建的条目，则返回true。

abstract boolean

KeyStoreSpi.engineIsKeyEntry​(String alias)

如果给定别名标识的条目是通过调用创建返回true setKeyEntry ，或者创建通过调用 setEntry与 PrivateKeyEntry或者 SecretKeyEntry 。

abstract void

KeyStoreSpi.engineSetCertificateEntry​(String alias, Certificate cert)

将给定的证书分配给给定的别名。

void

KeyStoreSpi.engineSetEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)

在指定的别名下保存一个 KeyStore.Entry 。

abstract void

KeyStoreSpi.engineSetKeyEntry​(String alias, byte[] key, Certificate[] chain)

将给定的密钥（已经被保护）分配给给定的别名。

abstract void

KeyStoreSpi.engineSetKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)

将给定的密钥分配给给定的别名，并使用给定的密码进行保护。

protected abstract void

SignatureSpi.engineSetParameter​(String param, Object value)

已过时。
替换为engineSetParameter 。

boolean

KeyStore.entryInstanceOf​(String alias, Class<? extends KeyStore.Entry> entryClass)

确定密钥库 Entry为指定 alias是指定的一个实例或亚类 entryClass 。

static String

Security.getAlgorithmProperty​(String algName, String propName)

已过时。
此方法用于返回“SUN”加密服务提供程序的主文件中的专有属性的值，以确定如何解析特定于算法的参数。 AlgorithmParameters使用新的基于提供者的和算法无关的AlgorithmParameters和KeyFactory引擎类（在J2SE版本1.2平台中引入）。

static Set<String>

Security.getAlgorithms​(String serviceName)

返回一组字符串，其中包含指定Java加密服务的所有可用算法或类型的名称（例如Signature，MessageDigest，Cipher，Mac，KeyStore）。

String

Provider.Service.getAttribute​(String name)

返回指定属性的值，如果未为此服务设置此属性，则返回null。

Certificate

KeyStore.getCertificate​(String alias)

返回与给定别名相关联的证书。

Certificate[]

KeyStore.getCertificateChain​(String alias)

返回与给定别名关联的证书链。

Date

KeyStore.getCreationDate​(String alias)

返回由给定别名标识的条目的创建日期。

byte[]

AlgorithmParameters.getEncoded​(String format)

返回在指定方案中编码的参数。

KeyStore.Entry

KeyStore.getEntry​(String alias, KeyStore.ProtectionParameter protParam)

获取具有指定保护参数的指定别名的密钥库 Entry 。

abstract Identity

IdentityScope.getIdentity​(String name)

已过时。

以指定的名称（如果有）返回此范围中的身份。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance​(String algorithm)

返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance​(String algorithm, String provider)

返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance​(String algorithm, Provider provider)

返回一个AlgorithmParameterGenerator对象，用于生成与指定算法一起使用的一组参数。

static AlgorithmParameters

AlgorithmParameters.getInstance​(String algorithm)

返回指定算法的参数对象。

static AlgorithmParameters

AlgorithmParameters.getInstance​(String algorithm, String provider)

返回指定算法的参数对象。

static AlgorithmParameters

AlgorithmParameters.getInstance​(String algorithm, Provider provider)

返回指定算法的参数对象。

static KeyFactory

KeyFactory.getInstance​(String algorithm)

返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

static KeyFactory

KeyFactory.getInstance​(String algorithm, String provider)

返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

static KeyFactory

KeyFactory.getInstance​(String algorithm, Provider provider)

返回一个KeyFactory对象，它转换指定算法的公钥/私钥。

static KeyPairGenerator

KeyPairGenerator.getInstance​(String algorithm)

返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

static KeyPairGenerator

KeyPairGenerator.getInstance​(String algorithm, String provider)

返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

static KeyPairGenerator

KeyPairGenerator.getInstance​(String algorithm, Provider provider)

返回一个KeyPairGenerator对象，该对象为指定的算法生成公钥/私钥对。

static KeyStore

KeyStore.getInstance​(String type)

返回指定类型的密钥库对象。

static KeyStore

KeyStore.getInstance​(String type, String provider)

返回指定类型的密钥库对象。

static KeyStore

KeyStore.getInstance​(String type, Provider provider)

返回指定类型的密钥库对象。

static MessageDigest

MessageDigest.getInstance​(String algorithm)

返回实现指定摘要算法的MessageDigest对象。

static MessageDigest

MessageDigest.getInstance​(String algorithm, String provider)

返回实现指定摘要算法的MessageDigest对象。

static MessageDigest

MessageDigest.getInstance​(String algorithm, Provider provider)

返回实现指定摘要算法的MessageDigest对象。

static Policy

Policy.getInstance​(String type, Policy.Parameters params)

返回指定类型的Policy对象。

static Policy

Policy.getInstance​(String type, Policy.Parameters params, String provider)

返回指定类型的Policy对象。

static Policy

Policy.getInstance​(String type, Policy.Parameters params, Provider provider)

返回指定类型的Policy对象。

static SecureRandom

SecureRandom.getInstance​(String algorithm)

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。

static SecureRandom

SecureRandom.getInstance​(String algorithm, String provider)

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。

static SecureRandom

SecureRandom.getInstance​(String algorithm, Provider provider)

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象。

static SecureRandom

SecureRandom.getInstance​(String algorithm, SecureRandomParameters params)

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。

static SecureRandom

SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, String provider)

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。

static SecureRandom

SecureRandom.getInstance​(String algorithm, SecureRandomParameters params, Provider provider)

返回实现指定的随机数生成器（RNG）算法的 SecureRandom对象，并支持指定的 SecureRandomParameters请求。

static Signature

Signature.getInstance​(String algorithm)

返回实现指定签名算法的Signature对象。

static Signature

Signature.getInstance​(String algorithm, String provider)

返回实现指定签名算法的Signature对象。

static Signature

Signature.getInstance​(String algorithm, Provider provider)

返回实现指定签名算法的Signature对象。

Key

KeyStore.getKey​(String alias, char[] password)

返回与给定别名相关联的密钥，使用给定的密码恢复它。

Object

Signature.getParameter​(String param)

已过时。

String

Provider.getProperty​(String key)

static String

Security.getProperty​(String key)

获取安全属性值。

abstract KeyStore.ProtectionParameter

KeyStore.Builder.getProtectionParameter​(String alias)

返回应用于获取给定别名的Entry的ProtectionParameters。

static Provider

Security.getProvider​(String name)

返回以指定名称安装的提供程序（如果有）。

static Provider[]

Security.getProviders​(String filter)

返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。

Provider.Service

Provider.getService​(String type, String algorithm)

获取描述此提供程序实现该算法或别名的指定类型的服务。

void

AlgorithmParameters.init​(byte[] params, String format)

从 params导入参数，并根据指定的解码方案进行解码。

boolean

KeyStore.isCertificateEntry​(String alias)

如果由给定别名标识的条目是通过调用 setCertificateEntry创建的，或者通过调用 setEntry与 TrustedCertificateEntry创建的条目，则返回true。

boolean

KeyStore.isKeyEntry​(String alias)

如果给定别名标识的条目是通过调用创建返回true setKeyEntry ，或者创建通过调用 setEntry与 PrivateKeyEntry或者 SecretKeyEntry 。

static KeyStore.Builder

KeyStore.Builder.newInstance​(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)

返回一个新的Builder对象。

static KeyStore.Builder

KeyStore.Builder.newInstance​(String type, Provider provider, KeyStore.ProtectionParameter protection)

返回一个新的Builder对象。

boolean

AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, AlgorithmParameters parameters)

确定是否为算法授予了指定的加密原语的权限。

boolean

AlgorithmConstraints.permits​(Set<CryptoPrimitive> primitives, String algorithm, Key key, AlgorithmParameters parameters)

确定算法和相应的密钥是否被授予对指定的加密原语的许可。

static void

Security.removeProvider​(String name)

删除具有指定名称的提供程序。

void

KeyStore.setCertificateEntry​(String alias, Certificate cert)

将给定的可信证书分配给给定的别名。

void

KeyStore.setEntry​(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)

在指定的别名下保存密钥库 Entry 。

void

Identity.setInfo​(String info)

已过时。

指定此标识的常规信息字符串。

void

KeyStore.setKeyEntry​(String alias, byte[] key, Certificate[] chain)

将给定的密钥（已经被保护）分配给给定的别名。

void

KeyStore.setKeyEntry​(String alias, Key key, char[] password, Certificate[] chain)

将给定的密钥分配给给定的别名，并使用给定的密码进行保护。

void

Signature.setParameter​(String param, Object value)

已过时。
使用setParameter 。

static void

Security.setProperty​(String key, String datum)

设置安全属性值。

static CryptoPrimitive

CryptoPrimitive.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static DrbgParameters.Capability

DrbgParameters.Capability.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static KeyRep.Type

KeyRep.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in java.security with type arguments of type String

Modifier and Type

方法

描述

static Provider[]

Security.getProviders​(Map<String,String> filter)

返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。

static Provider[]

Security.getProviders​(Map<String,String> filter)

返回包含满足指定选择条件的所有已安装提供程序的数组，如果未安装此类提供程序，则返回null。

Constructors in java.security with parameters of type String

Constructor

描述

AccessControlException​(String s)

构造一个 AccessControlException具有指定的详细消息。

AccessControlException​(String s, Permission p)

构造具有指定的详细消息的 AccessControlException以及引起异常的请求权限。

AlgorithmParameterGenerator​(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)

创建一个AlgorithmParameterGenerator对象。

AlgorithmParameters​(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)

创建一个AlgorithmParameters对象。

AllPermission​(String name, String actions)

创建一个新的AllPermission对象。

AuthProvider​(String name, double version, String info)

已过时。
改用AuthProvider(String, String, String) 。

AuthProvider​(String name, String versionStr, String info)

构造具有指定名称，版本字符串和信息的提供程序。

BasicPermission​(String name)

用指定的名称创建一个新的BasicPermission。

BasicPermission​(String name, String actions)

创建一个具有指定名称的新BasicPermission对象。

DigestException​(String msg)

构造具有指定详细消息的DigestException。

DigestException​(String message, Throwable cause)

创建一个 DigestException具有指定的详细信息和原因。

GeneralSecurityException​(String msg)

构造具有指定详细消息的GeneralSecurityException。

GeneralSecurityException​(String message, Throwable cause)

创建一个 GeneralSecurityException与指定的详细信息和原因。

Identity​(String name)

已过时。

构造一个具有指定名称的标识符，而不指定范围。

Identity​(String name, IdentityScope scope)

已过时。

构造具有指定名称和范围的身份。

IdentityScope​(String name)

已过时。

构造具有指定名称的新的身份范围。

IdentityScope​(String name, IdentityScope scope)

已过时。

构造具有指定名称和范围的新的身份范围。

InvalidAlgorithmParameterException​(String msg)

使用指定的详细消息构造InvalidAlgorithmParameterException。

InvalidAlgorithmParameterException​(String message, Throwable cause)

创建一个 InvalidAlgorithmParameterException与指定的详细信息和原因。

InvalidKeyException​(String msg)

构造具有指定详细消息的InvalidKeyException。

InvalidKeyException​(String message, Throwable cause)

创建一个 InvalidKeyException与指定的详细信息和原因。

InvalidParameterException​(String msg)

构造具有指定详细消息的InvalidParameterException。

KeyException​(String msg)

构造具有指定详细消息的KeyException。

KeyException​(String message, Throwable cause)

创建一个 KeyException与指定的详细信息和原因。

KeyFactory​(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)

创建一个KeyFactory对象。

KeyManagementException​(String msg)

构造具有指定详细消息的KeyManagementException。

KeyManagementException​(String message, Throwable cause)

创建一个 KeyManagementException与指定的详细信息和原因。

KeyPairGenerator​(String algorithm)

为指定的算法创建一个KeyPairGenerator对象。

KeyRep​(KeyRep.Type type, String algorithm, String format, byte[] encoded)

构造备用Key类。

KeyStore​(KeyStoreSpi keyStoreSpi, Provider provider, String type)

创建给定类型的KeyStore对象，并封装给定的提供者实现（SPI对象）。

KeyStoreException​(String msg)

构造具有指定详细消息的KeyStoreException。

KeyStoreException​(String message, Throwable cause)

创建一个 KeyStoreException与指定的详细信息和原因。

MessageDigest​(String algorithm)

使用指定的算法名称创建消息摘要。

NoSuchAlgorithmException​(String msg)

构造具有指定详细消息的NoSuchAlgorithmException。

NoSuchAlgorithmException​(String message, Throwable cause)

创建一个 NoSuchAlgorithmException与指定的详细信息和原因。

NoSuchProviderException​(String msg)

构造具有指定详细消息的NoSuchProviderException。

PasswordProtection​(char[] password, String protectionAlgorithm, AlgorithmParameterSpec protectionParameters)

创建密码参数，并指定在加密密钥库条目时使用的保护算法和相关参数。

Permission​(String name)

构造具有指定名称的权限。

PKCS12Attribute​(String name, String value)

从其名称和值构造PKCS12属性。

Provider​(String name, double version, String info)

已过时。
改用Provider(String, String, String) 。

Provider​(String name, String versionStr, String info)

构造具有指定名称，版本字符串和信息的提供程序。

ProviderException​(String s)

构造具有指定详细消息的ProviderException。

ProviderException​(String message, Throwable cause)

创建一个 ProviderException与指定的详细信息和原因。

SecureClassLoader​(String name, ClassLoader parent)

创建一个新的指定名称的 SecureClassLoader并使用指定的父类加载器进行委派。

SecurityPermission​(String name)

创建一个新的具有指定名称的SecurityPermission。

SecurityPermission​(String name, String actions)

创建一个新的具有指定名称的SecurityPermission对象。

Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)

构建新服务

Signature​(String algorithm)

为指定的算法创建一个Signature对象。

SignatureException​(String msg)

构造具有指定详细消息的SignatureException。

SignatureException​(String message, Throwable cause)

创建一个 SignatureException与指定的详细信息和原因。

Signer​(String name)

已过时。

创建具有指定身份名称的签名者。

Signer​(String name, IdentityScope scope)

已过时。

创建具有指定身份名称和范围的签名者。

UnrecoverableEntryException​(String msg)

构造具有指定的详细消息的UnrecoverableEntryException，它提供了有关为什么抛出此异常的更多信息。

UnrecoverableKeyException​(String msg)

构造一个具有指定的详细信息的UnrecoverableKeyException，它提供了有关为什么抛出此异常的更多信息。

UnresolvedPermission​(String type, String name, String actions, Certificate[] certs)

创建一个新的UnresolvedPermission，当权限解决时，包含稍后实际创建指定类的权限所需的权限信息。

Constructor parameters in java.security with type arguments of type String

Constructor

描述

DomainLoadStoreParameter​(URI configuration, Map<String,KeyStore.ProtectionParameter> protectionParams)

使用用于保护密钥库数据的参数构建密钥库域的DomainLoadStoreParameter。

Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)

构建新服务

Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)

构建新服务

Service​(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)

构建新服务

Uses of String in java.security.acl

Methods in java.security.acl that return String

Modifier and Type

方法

描述

String

Acl.getName​()

已过时。

返回此ACL的名称。

String

Acl.toString​()

已过时。

返回ACL内容的字符串表示形式。

String

AclEntry.toString​()

已过时。

返回此ACL条目内容的字符串表示形式。

String

Permission.toString​()

已过时。

打印此权限的字符串表示形式。

Methods in java.security.acl with parameters of type String

Modifier and Type

方法

描述

void

Acl.setName​(Principal caller, String name)

已过时。

设置此ACL的名称。

Uses of String in java.security.cert

Methods in java.security.cert that return String

Modifier and Type

方法

描述

String

CertPathBuilder.getAlgorithm​()

返回此 CertPathBuilder算法的 CertPathBuilder 。

String

CertPathValidator.getAlgorithm​()

返回此 CertPathValidator的算法名称。

String

TrustAnchor.getCAName​()

返回RFC 2253 String格式中最受信任的CA的名称。

static String

CertPathBuilder.getDefaultType​()

返回由 certpathbuilder.type安全属性指定的默认 CertPathBuilder类型，如果不存在此属性，则返回字符串“PKIX”。

static String

CertPathValidator.getDefaultType​()

返回由 certpathvalidator.type安全属性指定的默认 CertPathValidator类型，如果不存在此属性，则返回字符串“PKIX”。

static String

CertStore.getDefaultType​()

返回由 certstore.type安全属性指定的默认 CertStore类型，如果不存在此属性，则返回字符串“LDAP”。

String

Extension.getId​()

获取扩展的对象标识符。

String

X509CertSelector.getIssuerAsString​()

诋毁 ，使用 X509CertSelector.getIssuer()或者 X509CertSelector.getIssuerAsBytes()代替。

String

CertificateRevokedException.getMessage​()

String

PolicyQualifierInfo.getPolicyQualifierId​()

返回 policyQualifierId这个领域 PolicyQualifierInfo 。

String

LDAPCertStoreParameters.getServerName​()

返回LDAP服务器的DNS名称。

abstract String

X509Certificate.getSigAlgName​()

获取证书签名算法的签名算法名称。

abstract String

X509CRL.getSigAlgName​()

获取CRL签名算法的签名算法名称。

abstract String

X509Certificate.getSigAlgOID​()

从证书获取签名算法OID字符串。

abstract String

X509CRL.getSigAlgOID​()

从CRL获取签名算法OID字符串。

String

PKIXParameters.getSigProvider​()

返回签名提供者的名称，如果未设置，则返回 null 。

String

X509CertSelector.getSubjectAsString​()

诋毁 ，使用 X509CertSelector.getSubject()或者 X509CertSelector.getSubjectAsBytes()代替。

String

X509CertSelector.getSubjectPublicKeyAlgID​()

返回subjectPublicKeyAlgID条件。

String

Certificate.getType​()

返回此证书的类型。

String

CertificateFactory.getType​()

返回与该证书工厂相关联的证书类型的名称。

String

CertPath.getType​()

返回此认证路径中的 Certificate的类型。

String

CertStore.getType​()

返回此 CertStore的类型。

String

CRL.getType​()

返回此CRL的类型。

String

PolicyNode.getValidPolicy​()

返回此节点所表示的有效策略。

abstract String

Certificate.toString​()

返回此证书的字符串表示形式。

String

CertPath.toString​()

返回此认证路径的字符串表示形式。

String

CollectionCertStoreParameters.toString​()

返回描述参数的格式化字符串。

abstract String

CRL.toString​()

返回此CRL的字符串表示形式。

String

LDAPCertStoreParameters.toString​()

返回描述参数的格式化字符串。

String

PKIXBuilderParameters.toString​()

返回描述参数的格式化字符串。

String

PKIXCertPathBuilderResult.toString​()

返回此 PKIXCertPathBuilderResult的可打印的表示。

String

PKIXCertPathValidatorResult.toString​()

返回此打印表示 PKIXCertPathValidatorResult 。

String

PKIXParameters.toString​()

返回描述参数的格式化字符串。

String

PolicyQualifierInfo.toString​()

返回此 PolicyQualifierInfo的可打印的表示。

String

TrustAnchor.toString​()

返回描述 TrustAnchor的格式化字符串。

String

URICertStoreParameters.toString​()

返回描述包含用于构造此对象的URI的参数的格式化字符串。

String

X509CertSelector.toString​()

返回 CertSelector的可打印代表。

abstract String

X509CRLEntry.toString​()

返回此CRL条目的字符串表示形式。

String

X509CRLSelector.toString​()

返回 X509CRLSelector的可打印表示。

Methods in java.security.cert that return types with arguments of type String

Modifier and Type

方法

描述

Iterator<String>

CertificateFactorySpi.engineGetCertPathEncodings​()

返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。

Iterator<String>

CertificateFactory.getCertPathEncodings​()

返回此证书工厂支持的 CertPath编码的迭代，首先使用默认编码。

Set<String>

X509Extension.getCriticalExtensionOIDs​()

获取由实现此接口的对象管理的证书/ CRL中标记为“CRITICAL”的扩展名的OID字符串集。

abstract Iterator<String>

CertPath.getEncodings​()

返回此认证路径支持的编码的迭代，并使用默认编码。

Set<String>

PolicyNode.getExpectedPolicies​()

返回在待处理的下一个证书中满足此节点有效策略的一组预期策略。

List<String>

X509Certificate.getExtendedKeyUsage​()

获取表示扩展密钥使用扩展（OID = 2.5.29.37）的 ExtKeyUsageSyntax字段的OBJECT IDENTIFIER的字符串的不可修改列表。

Set<String>

X509CertSelector.getExtendedKeyUsage​()

返回extendedKeyUsage标准。

Map<String,Extension>

CertificateRevokedException.getExtensions​()

返回X.509扩展名的地图，其中包含有关撤销证书的附加信息，例如无效日期扩展。

Set<String>

PKIXParameters.getInitialPolicies​()

返回一个不可变的初始策略标识符（OID字符串）的 Set ，这表明这些策略中的任何一个对证书用户来说都是可以接受的，用于认证路径处理。

Set<String>

X509Extension.getNonCriticalExtensionOIDs​()

获取由实现此接口的对象管理的证书/ CRL中标记为“非关键性”的扩展名的OID字符串集。

Set<String>

X509CertSelector.getPolicy​()

返回策略标准。

abstract Set<String>

PKIXCertPathChecker.getSupportedExtensions​()

返回 PKIXCertPathChecker支持（即识别，能够处理）的X.509证书扩展的不可变 Set ，如果不支持扩展名，则 null 。

Methods in java.security.cert with parameters of type String

Modifier and Type

方法

描述

void

X509CRLSelector.addIssuerName​(String name)

诋毁 ，使用 X509CRLSelector.addIssuer(X500Principal)或者 X509CRLSelector.addIssuerName(byte[])代替。

void

X509CertSelector.addPathToName​(int type, String name)

在pathToNames条件中添加一个名称。

void

X509CertSelector.addSubjectAlternativeName​(int type, String name)

在subjectAlternativeNames条件中添加一个名称。

CertPath

CertificateFactorySpi.engineGenerateCertPath​(InputStream inStream, String encoding)

生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。

CertPath

CertificateFactory.generateCertPath​(InputStream inStream, String encoding)

生成一个 CertPath对象，并使用从 InputStream inStream读取的数据进行初始化。

abstract byte[]

CertPath.getEncoded​(String encoding)

使用指定的编码返回此认证路径的编码形式。

byte[]

X509Extension.getExtensionValue​(String oid)

获取由传入的 oid字符串标识的扩展值（ extnValue ）的DER编码的OCTET字符串。

static CertificateFactory

CertificateFactory.getInstance​(String type)

返回实现指定证书类型的证书工厂对象。

static CertificateFactory

CertificateFactory.getInstance​(String type, String provider)

返回指定证书类型的证书工厂对象。

static CertificateFactory

CertificateFactory.getInstance​(String type, Provider provider)

返回指定证书类型的证书工厂对象。

static CertPathBuilder

CertPathBuilder.getInstance​(String algorithm)

返回实现指定算法的 CertPathBuilder对象。

static CertPathBuilder

CertPathBuilder.getInstance​(String algorithm, String provider)

返回实现指定算法的 CertPathBuilder对象。

static CertPathBuilder

CertPathBuilder.getInstance​(String algorithm, Provider provider)

返回实现指定算法的 CertPathBuilder对象。

static CertPathValidator

CertPathValidator.getInstance​(String algorithm)

返回实现指定算法的 CertPathValidator对象。

static CertPathValidator

CertPathValidator.getInstance​(String algorithm, String provider)

返回实现指定算法的 CertPathValidator对象。

static CertPathValidator

CertPathValidator.getInstance​(String algorithm, Provider provider)

返回实现指定算法的 CertPathValidator对象。

static CertStore

CertStore.getInstance​(String type, CertStoreParameters params)

返回一个实现指定的 CertStore类型的 CertStore对象，并使用指定的参数进行初始化。

static CertStore

CertStore.getInstance​(String type, CertStoreParameters params, String provider)

返回实现指定的 CertStore类型的 CertStore对象。

static CertStore

CertStore.getInstance​(String type, CertStoreParameters params, Provider provider)

返回实现指定的 CertStore类型的 CertStore对象。

void

X509CertSelector.setIssuer​(String issuerDN)

诋毁 ，使用 X509CertSelector.setIssuer(X500Principal)或者 X509CertSelector.setIssuer(byte[])代替。

void

PKIXParameters.setSigProvider​(String sigProvider)

设置签名提供者的名称。

void

X509CertSelector.setSubject​(String subjectDN)

诋毁 ，使用 X509CertSelector.setSubject(X500Principal)或者 X509CertSelector.setSubject(byte[])代替。

void

X509CertSelector.setSubjectPublicKeyAlgID​(String oid)

设置subjectPublicKeyAlgID标准。

static CertPathValidatorException.BasicReason

CertPathValidatorException.BasicReason.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static CRLReason

CRLReason.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PKIXReason

PKIXReason.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PKIXRevocationChecker.Option

PKIXRevocationChecker.Option.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

abstract void

Certificate.verify​(PublicKey key, String sigProvider)

使用与指定公钥对应的私钥验证此证书是否已经签名。

abstract void

X509CRL.verify​(PublicKey key, String sigProvider)

验证此CRL是否使用与给定公钥对应的私钥进行签名。

Method parameters in java.security.cert with type arguments of type String

Modifier and Type

方法

描述

abstract void

PKIXCertPathChecker.check​(Certificate cert, Collection<String> unresolvedCritExts)

使用其内部状态对指定证书执行检查，并从指定的OID字符串集合中删除其处理的任何关键扩展，这些扩展代表未解决的关键扩展。

void

X509CertSelector.setExtendedKeyUsage​(Set<String> keyPurposeSet)

设置extendedKeyUsage标准。

void

PKIXParameters.setInitialPolicies​(Set<String> initialPolicies)

设置初始策略标识符（OID字符串）的 Set ，指示证书用户为了认证路径处理的目的而可以接受这些策略中的任何一个。

void

X509CertSelector.setPolicy​(Set<String> certPolicySet)

设置策略约束。

Constructors in java.security.cert with parameters of type String

Constructor

描述

Certificate​(String type)

创建指定类型的证书。

CertificateEncodingException​(String message)

构造具有指定详细消息的CertificateEncodingException。

CertificateEncodingException​(String message, Throwable cause)

创建一个 CertificateEncodingException与指定的详细信息和原因。

CertificateException​(String msg)

使用给定的详细消息构造证书异常。

CertificateException​(String message, Throwable cause)

创建一个 CertificateException与指定的详细信息和原因。

CertificateExpiredException​(String message)

构造具有指定详细消息的CertificateExpiredException。

CertificateFactory​(CertificateFactorySpi certFacSpi, Provider provider, String type)

创建给定类型的CertificateFactory对象，并将给定的提供者实现（SPI对象）封装在其中。

CertificateNotYetValidException​(String message)

构造具有指定详细消息的CertificateNotYetValidException。

CertificateParsingException​(String message)

构造具有指定详细消息的CertificateParsingException。

CertificateParsingException​(String message, Throwable cause)

创建一个 CertificateParsingException与指定的详细信息和原因。

CertificateRep​(String type, byte[] data)

使用证书类型和证书编码字节构造备用证书类。

CertPath​(String type)

创建指定类型的 CertPath 。

CertPathBuilder​(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)

创建给定算法的 CertPathBuilder对象，并将给定的提供者实现（SPI对象）封装在其中。

CertPathBuilderException​(String msg)

创建一个 CertPathBuilderException与给定的详细信息。

CertPathBuilderException​(String msg, Throwable cause)

创建一个 CertPathBuilderException与指定的详细信息和原因。

CertPathRep​(String type, byte[] data)

创建具有指定类型和认证路径的编码形式的 CertPathRep 。

CertPathValidator​(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)

创建给定算法的 CertPathValidator对象，并将给定的提供者实现（SPI对象）封装在其中。

CertPathValidatorException​(String msg)

使用给定的详细信息创建一个 CertPathValidatorException 。

CertPathValidatorException​(String msg, Throwable cause)

创建一个 CertPathValidatorException与指定的详细信息和原因。

CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index)

创建具有指定的详细消息，原因，认证路径和索引的 CertPathValidatorException 。

CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index, CertPathValidatorException.Reason reason)

创建具有指定的详细消息，原因，认证路径，索引和原因的 CertPathValidatorException 。

CertStore​(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)

创建给定类型的 CertStore对象，并将给定的提供者实现（SPI对象）封装在其中。

CertStoreException​(String msg)

使用给定的详细信息创建一个 CertStoreException 。

CertStoreException​(String msg, Throwable cause)

创建一个 CertStoreException与指定的详细信息和原因。

CRL​(String type)

创建指定类型的CRL。

CRLException​(String message)

构造具有指定详细消息的CRLException。

CRLException​(String message, Throwable cause)

创建一个 CRLException与指定的详细信息和原因。

LDAPCertStoreParameters​(String serverName)

使用指定的服务器名称创建一个 LDAPCertStoreParameters的实例，默认端口为389。

LDAPCertStoreParameters​(String serverName, int port)

创建具有指定参数值的 LDAPCertStoreParameters实例。

TrustAnchor​(String caName, PublicKey pubKey, byte[] nameConstraints)

创建一个 TrustAnchor的实例，其中最受信任的CA被指定为可分辨名称和公钥。

Constructor parameters in java.security.cert with type arguments of type String

Constructor

描述

CertificateRevokedException​(Date revocationDate, CRLReason reason, X500Principal authority, Map<String,Extension> extensions)

构造具有指定撤销日期，原因代码，权限名称和扩展名映射的 CertificateRevokedException 。

Uses of String in java.security.spec

Methods in java.security.spec that return String

Modifier and Type

方法

描述

String

EncodedKeySpec.getAlgorithm​()

返回编码密钥算法的名称。

String

MGF1ParameterSpec.getDigestAlgorithm​()

返回掩码生成函数使用的消息摘要的算法名称。

String

PSSParameterSpec.getDigestAlgorithm​()

返回消息摘要算法名称。

abstract String

EncodedKeySpec.getFormat​()

返回与此密钥规范相关联的编码格式的名称。

String

PKCS8EncodedKeySpec.getFormat​()

返回与此密钥规范相关联的编码格式的名称。

String

X509EncodedKeySpec.getFormat​()

返回与此密钥规范相关联的编码格式的名称。

String

PSSParameterSpec.getMGFAlgorithm​()

返回掩码生成函数算法名称。

String

ECGenParameterSpec.getName​()

返回要生成的EC域参数的标准或预定义名称。

Constructors in java.security.spec with parameters of type String

Constructor

描述

ECGenParameterSpec​(String stdName)

使用标准（或预定义）名称 stdName创建EC参数生成的参数规范，以生成相应的（预计算）椭圆曲线域参数。

EncodedKeySpec​(byte[] encodedKey, String algorithm)

使用给定的编码密钥创建一个新的 EncodedKeySpec 。

InvalidKeySpecException​(String msg)

使用指定的详细消息构造InvalidKeySpecException。

InvalidKeySpecException​(String message, Throwable cause)

创建具有指定的详细消息和原因的 InvalidKeySpecException 。

InvalidParameterSpecException​(String msg)

使用指定的详细消息构造InvalidParameterSpecException。

MGF1ParameterSpec​(String mdName)

为PKCS＃1标准中定义的掩码生成函数MGF1构造一个参数集。

PKCS8EncodedKeySpec​(byte[] encodedKey, String algorithm)

使用给定的编码密钥和算法创建一个新的 PKCS8EncodedKeySpec 。

PSSParameterSpec​(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)

使用指定的消息摘要，掩码生成功能，掩码生成功能参数，盐长度和尾部字段值创建PKCS＃1标准中定义的新的 PSSParameterSpec 。

X509EncodedKeySpec​(byte[] encodedKey, String algorithm)

使用给定的编码密钥创建一个新的 X509EncodedKeySpec 。

Uses of String in java.sql

Fields in java.sql declared as String

Modifier and Type

Field

描述

String[]

DriverPropertyInfo.choices

如果可以从特定值集合中选择字段DriverPropertyInfo.value的值，则可能的值的数组; 否则为空。

String

DriverPropertyInfo.description

属性的简要说明，可能为null。

String

DriverPropertyInfo.name

物业的名称。

String

DriverPropertyInfo.value

value字段基于提供给方法 getPropertyInfo的信息，Java环境和驱动程序提供的默认值的组合来指定属性的当前值。

Methods in java.sql that return String

Modifier and Type

方法

描述

default String

Statement.enquoteIdentifier​(String identifier, boolean alwaysQuote)

返回一个SQL标识符。

default String

Statement.enquoteLiteral​(String val)

返回一个用引号括起来的 String 。

default String

Statement.enquoteNCharLiteral​(String val)

返回一个 String代表一个用单引号括起来的前缀为大写字母N的国家字符集文字。

String

Array.getBaseTypeName​()

检索此 Array对象指定的数组中的元素的SQL类型名称。

String

Ref.getBaseTypeName​()

检索此 Ref对象引用的SQL结构化类型的全限定SQL名称。

String

Connection.getCatalog​()

检索此 Connection对象的当前目录名称。

String

ResultSetMetaData.getCatalogName​(int column)

获取指定列的表的目录名称。

String

DatabaseMetaData.getCatalogSeparator​()

检索此数据库用作目录和表名之间的分隔符的 String 。

String

DatabaseMetaData.getCatalogTerm​()

检索“目录”的数据库供应商的首选项。

String

Connection.getClientInfo​(String name)

返回由name指定的客户端信息属性的值。

String

ResultSetMetaData.getColumnClassName​(int column)

如果调用方法 ResultSet.getObject从列中检索值，则返回其实例生成的Java类的完全限定名称。

String

ResultSetMetaData.getColumnLabel​(int column)

获取指定列的建议标题用于打印输出和显示。

String

ResultSetMetaData.getColumnName​(int column)

获取指定列的名称。

String

ResultSetMetaData.getColumnTypeName​(int column)

检索指定列的数据库特定类型名称。

String

ResultSet.getCursorName​()

检索此 ResultSet对象使用的SQL游标的名称。

String

DatabaseMetaData.getDatabaseProductName​()

检索此数据库产品的名称。

String

DatabaseMetaData.getDatabaseProductVersion​()

检索此数据库产品的版本号。

String

DatabaseMetaData.getDriverName​()

检索此JDBC驱动程序的名称。

String

DatabaseMetaData.getDriverVersion​()

以 String检索此JDBC驱动程序的版本号。

String

DatabaseMetaData.getExtraNameCharacters​()

检索可用于未引号的标识符名称（超出az，AZ，0-9和_）的所有“额外”字符。

String

DatabaseMetaData.getIdentifierQuoteString​()

检索用于引用SQL标识符的字符串。

String

JDBCType.getName​()

返回表示SQL数据类型的 SQLType名称。

String

SQLType.getName​()

返回表示SQL数据类型的 SQLType名称。

String

CallableStatement.getNString​(int parameterIndex)

检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。

String

CallableStatement.getNString​(String parameterName)

检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。

String

ResultSet.getNString​(int columnIndex)

以Java编程语言中的 String此 ResultSet对象的当前行中指定列的值。

String

ResultSet.getNString​(String columnLabel)

以Java编程语言中的 String此 ResultSet对象的当前行中指定列的值。

String

DatabaseMetaData.getNumericFunctions​()

检索此数据库可用的逗号分隔的数学函数列表。

String

ParameterMetaData.getParameterClassName​(int param)

检索要将其实例传递给方法的Java类的完全限定名称 PreparedStatement.setObject 。

String

ParameterMetaData.getParameterTypeName​(int param)

检索指定参数的数据库特定类型名称。

String

DatabaseMetaData.getProcedureTerm​()

检索“程序”的数据库供应商的首选项。

String

Savepoint.getSavepointName​()

检索此 Savepoint对象所代表的保存点的名称。

String

Connection.getSchema​()

检索此 Connection对象的当前模式名称。

String

ResultSetMetaData.getSchemaName​(int column)

获取指定列的表的模式。

String

DatabaseMetaData.getSchemaTerm​()

检索“模式”的数据库供应商的首选项。

String

DatabaseMetaData.getSearchStringEscape​()

检索可用于转义通配符的字符串。

String

DatabaseMetaData.getSQLKeywords​()

检索所有这些数据库的SQL关键字的逗号分隔列表，这些关键字也不是SQL：2003关键字。

String

SQLException.getSQLState​()

检索此 SQLException对象的SQLState。

String

SQLData.getSQLTypeName​()

返回此对象表示的SQL用户定义类型的完全限定名称。

String

Struct.getSQLTypeName​()

检索此 Struct对象所代表的SQL结构类型的SQL类型名称。

String

CallableStatement.getString​(int parameterIndex)

以Java编程语言中的 CHAR VARCHAR指定的JDBC CHAR或 LONGVARCHAR参数的 String 。

String

CallableStatement.getString​(String parameterName)

检索JDBC的价值 CHAR ， VARCHAR ，或 LONGVARCHAR参数为 String的Java编程语言。

String

ResultSet.getString​(int columnIndex)

以Java编程语言中的 String该 ResultSet对象的当前行中指定列的值。

String

ResultSet.getString​(String columnLabel)

以Java编程语言中的 String此 ResultSet对象当前行中指定列的值。

String

SQLXML.getString​()

返回此SQLXML实例指定的XML值的字符串表示形式。

String

DatabaseMetaData.getStringFunctions​()

检索此数据库可用的逗号分隔的字符串函数列表。

String

Clob.getSubString​(long pos, int length)

在 Clob对象指定的 CLOB值中检索指定子字符串的副本。

String

DatabaseMetaData.getSystemFunctions​()

检索此数据库可用的系统函数的逗号分隔列表。

String

ResultSetMetaData.getTableName​(int column)

获取指定列的表名称。

String

DatabaseMetaData.getTimeDateFunctions​()

检索此数据库可用的时间和日期函数的逗号分隔列表。

String

DatabaseMetaData.getURL​()

检索此DBMS的URL。

String

DatabaseMetaData.getUserName​()

检索此数据库已知的用户名。

String

JDBCType.getVendor​()

返回支持此数据类型的供应商的名称。

String

SQLType.getVendor​()

返回支持此数据类型的供应商的名称。

String

Connection.nativeSQL​(String sql)

将给定的SQL语句转换为系统的本机SQL语法。

String

SQLInput.readNString​()

读取流中的下一个属性，并将其作为Java编程语言中的 String返回。

String

SQLInput.readString​()

读取流中的下一个属性，并将其作为Java编程语言中的 String返回。

String

Date.toString​()

格式化日期转义格式yyyy-mm-dd。

String

RowId.toString​()

返回一个表示由此 java.sql.RowId对象指定的SQL ROWID值的字符串。

String

Time.toString​()

以JDBC时间转义格式格式化。

String

Timestamp.toString​()

以JDBC时间戳转义格式格式化时间戳。

Methods in java.sql that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,ClientInfoStatus>

SQLClientInfoException.getFailedProperties​()

返回无法设置的客户端信息属性列表。

Map<String,Class<?>>

Connection.getTypeMap​()

检索 Map与此相关联的对象 Connection对象。

Methods in java.sql with parameters of type String

Modifier and Type

方法

描述

boolean

Driver.acceptsURL​(String url)

检索驱动程序是否认为可以打开与给定URL的连接。

void

Statement.addBatch​(String sql)

将给定的SQL命令添加到此 Statement对象的当前命令列表中。

Connection

Driver.connect​(String url, Properties info)

尝试使数据库连接到给定的URL。

Array

Connection.createArrayOf​(String typeName, Object[] elements)

用于创建Array对象的Factory方法。

Struct

Connection.createStruct​(String typeName, Object[] attributes)

用于创建Struct对象的工厂方法。

default String

Statement.enquoteIdentifier​(String identifier, boolean alwaysQuote)

返回一个SQL标识符。

default String

Statement.enquoteLiteral​(String val)

返回一个包含在单引号中的 String 。

default String

Statement.enquoteNCharLiteral​(String val)

返回一个 String代表一个用单引号括起来并以大写字母N前缀的国家字符集文字。

boolean

Statement.execute​(String sql)

执行给定的SQL语句，这可能会返回多个结果。

boolean

Statement.execute​(String sql, int autoGeneratedKeys)

执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出任何自动生成的密钥应该可用于检索。

boolean

Statement.execute​(String sql, int[] columnIndexes)

执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。

boolean

Statement.execute​(String sql, String[] columnNames)

执行给定的SQL语句，这可能返回多个结果，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。

default long

Statement.executeLargeUpdate​(String sql)

执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。

default long

Statement.executeLargeUpdate​(String sql, int autoGeneratedKeys)

执行给定的SQL语句，并用给定的标志来向驱动程序发出信号，指出这个 Statement对象产生的自动生成的密钥是否应该可用于检索。

default long

Statement.executeLargeUpdate​(String sql, int[] columnIndexes)

执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。

default long

Statement.executeLargeUpdate​(String sql, String[] columnNames)

执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。

ResultSet

Statement.executeQuery​(String sql)

执行给定的SQL语句，返回一个 ResultSet对象。

int

Statement.executeUpdate​(String sql)

执行给定的SQL语句，这可能是 INSERT ， UPDATE ，或 DELETE声明，或者不返回任何内容，如SQL DDL语句的SQL语句。

int

Statement.executeUpdate​(String sql, int autoGeneratedKeys)

执行给定的SQL语句，并用给定的标志来向驱动程序发出信号，指出这个 Statement对象产生的自动生成的密钥是否应该可用于检索。

int

Statement.executeUpdate​(String sql, int[] columnIndexes)

执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。

int

Statement.executeUpdate​(String sql, String[] columnNames)

执行给定的SQL语句，并向驱动程序发出信号，指出给定数组中指示的自动生成的键应该可用于检索。

int

ResultSet.findColumn​(String columnLabel)

将给定的 ResultSet列标签映射到其 ResultSet列索引。

Array

CallableStatement.getArray​(String parameterName)

以Java编程语言作为Array对象检索JDBC ARRAY参数的值。

Array

ResultSet.getArray​(String columnLabel)

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 Array对象。

InputStream

ResultSet.getAsciiStream​(String columnLabel)

将此 ResultSet对象的当前行中指定列的值作为ASCII字符流 ResultSet 。

ResultSet

DatabaseMetaData.getAttributes​(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)

检索给定模式和目录中可用的用户定义类型（UDT）给定类型的给定属性的描述。

ResultSet

DatabaseMetaData.getBestRowIdentifier​(String catalog, String schema, String table, int scope, boolean nullable)

检索表的唯一标识行的最佳列集描述。

BigDecimal

CallableStatement.getBigDecimal​(String parameterName)

检索JDBC NUMERIC参数的值作为 java.math.BigDecimal对象，其值包含小数点右侧的数字。

BigDecimal

ResultSet.getBigDecimal​(String columnLabel)

检索此的当前行中指定列的值 ResultSet对象作为 java.math.BigDecimal具有全精度。

BigDecimal

ResultSet.getBigDecimal​(String columnLabel, int scale)

已过时。
使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)

InputStream

ResultSet.getBinaryStream​(String columnLabel)

将此 ResultSet对象的当前行中指定列的值作为未解释的流 byte 。

Blob

CallableStatement.getBlob​(String parameterName)

以Java编程语言作为Blob对象检索JDBC BLOB参数的值。

Blob

ResultSet.getBlob​(String columnLabel)

以Java编程语言中的 ResultSet对象的形式 Blob此 ResultSet对象的当前行中指定列的值。

boolean

CallableStatement.getBoolean​(String parameterName)

以Java编程语言中的 boolean JDBC BIT或 BOOLEAN参数的值。

boolean

ResultSet.getBoolean​(String columnLabel)

以Java编程语言中的 boolean该 ResultSet对象的当前行中指定列的值。

byte

CallableStatement.getByte​(String parameterName)

以Java编程语言中的 byte JDBC TINYINT参数的值。

byte

ResultSet.getByte​(String columnLabel)

以Java编程语言中的 byte该 ResultSet对象的当前行中指定列的值。

byte[]

CallableStatement.getBytes​(String parameterName)

检索JDBC BINARY或 VARBINARY参数的值，作为Java编程语言中的 byte值的数组。

byte[]

ResultSet.getBytes​(String columnLabel)

检索该 ResultSet对象的当前行中指定列的值为Java编程语言中的 byte数组。

Reader

CallableStatement.getCharacterStream​(String parameterName)

以Java编程语言 java.io.Reader指定参数的值作为 java.io.Reader对象。

Reader

ResultSet.getCharacterStream​(String columnLabel)

检索 ResultSet对象的当前行中指定列的值作为 java.io.Reader对象。

String

Connection.getClientInfo​(String name)

返回由name指定的客户端信息属性的值。

Clob

CallableStatement.getClob​(String parameterName)

以Java编程语言的形式 java.sql.Clob JDBC CLOB参数的值作为 java.sql.Clob对象。

Clob

ResultSet.getClob​(String columnLabel)

以Java编程语言中的 ResultSet对象的形式 Clob此 ResultSet对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getColumnPrivileges​(String catalog, String schema, String table, String columnNamePattern)

检索表的列的访问权限的描述。

ResultSet

DatabaseMetaData.getColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)

检索指定目录中可用的表列的描述。

static Connection

DriverManager.getConnection​(String url)

尝试建立与给定数据库URL的连接。

static Connection

DriverManager.getConnection​(String url, String user, String password)

尝试建立与给定数据库URL的连接。

static Connection

DriverManager.getConnection​(String url, Properties info)

尝试建立与给定数据库URL的连接。

ResultSet

DatabaseMetaData.getCrossReference​(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)

检索引用主键的给定外键表中的外键列的描述，或表示父表的唯一约束的列（可以是相同或不同的表）。

Date

CallableStatement.getDate​(String parameterName)

检索作为 java.sql.Date对象的JDBC DATE参数的值。

Date

CallableStatement.getDate​(String parameterName, Calendar cal)

检索JDBC DATE参数的值作为 java.sql.Date对象，使用给定的 Calendar对象构造日期。

Date

ResultSet.getDate​(String columnLabel)

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.sql.Date对象。

Date

ResultSet.getDate​(String columnLabel, Calendar cal)

这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Date的Java编程语言对象。

double

CallableStatement.getDouble​(String parameterName)

以Java编程语言中的 double JDBC DOUBLE参数的值。

double

ResultSet.getDouble​(String columnLabel)

检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 double 。

static Driver

DriverManager.getDriver​(String url)

尝试查找了解给定URL的驱动程序。

ResultSet

DatabaseMetaData.getExportedKeys​(String catalog, String schema, String table)

检索引用给定表的主键列（由表导出的外键）的外键列的描述。

float

CallableStatement.getFloat​(String parameterName)

以Java编程语言中的 float JDBC FLOAT参数的值。

float

ResultSet.getFloat​(String columnLabel)

检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 float 。

ResultSet

DatabaseMetaData.getFunctionColumns​(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)

检索给定目录的系统或用户功能参数和返回类型的描述。

ResultSet

DatabaseMetaData.getFunctions​(String catalog, String schemaPattern, String functionNamePattern)

检索给定目录中可用的系统和用户功能的描述。

ResultSet

DatabaseMetaData.getImportedKeys​(String catalog, String schema, String table)

检索给定表的外键列（由表导入的主键）引用的主键列的描述。

ResultSet

DatabaseMetaData.getIndexInfo​(String catalog, String schema, String table, boolean unique, boolean approximate)

检索给定表的索引和统计信息的描述。

int

CallableStatement.getInt​(String parameterName)

以Java编程语言中的 int JDBC INTEGER参数的值。

int

ResultSet.getInt​(String columnLabel)

以Java编程语言中的 int此 ResultSet对象当前行中指定列的值。

long

CallableStatement.getLong​(String parameterName)

以Java编程语言中的 long JDBC BIGINT参数的值。

long

ResultSet.getLong​(String columnLabel)

以Java编程语言中的 long此 ResultSet对象的当前行中指定列的值。

Reader

CallableStatement.getNCharacterStream​(String parameterName)

以Java编程语言的形式获取指定参数的值作为 java.io.Reader对象。

Reader

ResultSet.getNCharacterStream​(String columnLabel)

以 ResultSet对象的形式 java.io.Reader此 ResultSet对象的当前行中指定列的值。

NClob

CallableStatement.getNClob​(String parameterName)

以Java编程语言的形式 java.sql.NClob JDBC NCLOB参数的值作为 java.sql.NClob对象。

NClob

ResultSet.getNClob​(String columnLabel)

以Java编程语言中的 NClob对象的形式，检索此 ResultSet对象的当前行中指定列的值。

String

CallableStatement.getNString​(String parameterName)

检索指定的值 NCHAR ， NVARCHAR或者 LONGNVARCHAR参数为 String的Java编程语言。

String

ResultSet.getNString​(String columnLabel)

以Java编程语言中的 String该 ResultSet对象的当前行中指定列的值。

Object

CallableStatement.getObject​(String parameterName)

以Java编程语言中的 Object参数的值。

<T> T

CallableStatement.getObject​(String parameterName, Class<T> type)

返回表示OUT参数 parameterName的值的对象，并将转换为参数的SQL类型到所请求的Java数据类型（如果支持转换）。

Object

CallableStatement.getObject​(String parameterName, Map<String,Class<?>> map)

返回表示OUT参数 parameterName的值的对象，并使用参数值的自定义映射 map 。

Object

ResultSet.getObject​(String columnLabel)

将此 ResultSet对象的当前行中指定列的值作为Java编程语言中的 Object 。

<T> T

ResultSet.getObject​(String columnLabel, Class<T> type)

检索此 ResultSet对象当前行中指定列的值，并将转换为SQL类型的列到所请求的Java数据类型，如果转换支持。

Object

ResultSet.getObject​(String columnLabel, Map<String,Class<?>> map)

以Java编程语言中的 Object该 ResultSet对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getPrimaryKeys​(String catalog, String schema, String table)

检索给定表的主键列的描述。

ResultSet

DatabaseMetaData.getProcedureColumns​(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)

检索给定目录的存储过程参数和结果列的描述。

ResultSet

DatabaseMetaData.getProcedures​(String catalog, String schemaPattern, String procedureNamePattern)

200的X- 200 200 X- 200 200 X- 200 200：

DriverPropertyInfo[]

Driver.getPropertyInfo​(String url, Properties info)

获取有关此驱动程序可能属性的信息。

ResultSet

DatabaseMetaData.getPseudoColumns​(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)

检索指定目录和模式中给定表中可用的伪列或隐藏列的描述。

Ref

CallableStatement.getRef​(String parameterName)

以Java编程语言的形式获取 JDBC REF(<structured-type>)参数的值作为Ref对象。

Ref

ResultSet.getRef​(String columnLabel)

检索此 ResultSet对象当前行中指定列的值为Java编程语言中的 Ref对象。

RowId

CallableStatement.getRowId​(String parameterName)

以 java.sql.RowId对象的形式获取指定的JDBC ROWID参数的值。

RowId

ResultSet.getRowId​(String columnLabel)

以Java编程语言中的 ResultSet对象的形式 java.sql.RowId该 ResultSet对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getSchemas​(String catalog, String schemaPattern)

检索此数据库中可用的模式名称。

short

CallableStatement.getShort​(String parameterName)

以Java编程语言中的 short JDBC SMALLINT参数的值。

short

ResultSet.getShort​(String columnLabel)

以此Java编程语言中的 short该 ResultSet对象的当前行中指定列的值。

SQLXML

CallableStatement.getSQLXML​(String parameterName)

以Java编程语言中的 java.sql.SQLXML对象的形式获取指定的 SQL XML参数的值。

SQLXML

ResultSet.getSQLXML​(String columnLabel)

以Java编程语言中的 java.sql.SQLXML对象的形式，将此 ResultSet的当前行中的指定列的值检索。

String

CallableStatement.getString​(String parameterName)

检索JDBC的价值 CHAR ， VARCHAR ，或 LONGVARCHAR参数为 String的Java编程语言。

String

ResultSet.getString​(String columnLabel)

以Java编程语言中的 String此 ResultSet对象当前行中指定列的值。

ResultSet

DatabaseMetaData.getSuperTables​(String catalog, String schemaPattern, String tableNamePattern)

检索此数据库中特定模式中定义的表层次结构的描述。

ResultSet

DatabaseMetaData.getSuperTypes​(String catalog, String schemaPattern, String typeNamePattern)

检索此数据库中特定模式中定义的用户定义类型（UDT）层次结构的描述。

ResultSet

DatabaseMetaData.getTablePrivileges​(String catalog, String schemaPattern, String tableNamePattern)

检索目录中可用的每个表的访问权限的描述。

ResultSet

DatabaseMetaData.getTables​(String catalog, String schemaPattern, String tableNamePattern, String[] types)

检索给定目录中可用表的描述。

Time

CallableStatement.getTime​(String parameterName)

检索作为 java.sql.Time对象的JDBC TIME参数的值。

Time

CallableStatement.getTime​(String parameterName, Calendar cal)

检索JDBC TIME参数的值作为 java.sql.Time对象，使用给定的 Calendar对象构建时间。

Time

ResultSet.getTime​(String columnLabel)

这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Time的Java编程语言对象。

Time

ResultSet.getTime​(String columnLabel, Calendar cal)

这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Time的Java编程语言对象。

Timestamp

CallableStatement.getTimestamp​(String parameterName)

检索作为 java.sql.Timestamp对象的JDBC TIMESTAMP参数的值。

Timestamp

CallableStatement.getTimestamp​(String parameterName, Calendar cal)

检索JDBC TIMESTAMP参数的值作为 java.sql.Timestamp对象，使用给定的 Calendar对象来构造 Timestamp对象。

Timestamp

ResultSet.getTimestamp​(String columnLabel)

这个检索的当前行中指定列的值 ResultSet对象为 java.sql.Timestamp的Java编程语言对象。

Timestamp

ResultSet.getTimestamp​(String columnLabel, Calendar cal)

以Java编程语言中的 java.sql.Timestamp对象的形式，检索此 ResultSet对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getUDTs​(String catalog, String schemaPattern, String typeNamePattern, int[] types)

检索在特定模式中定义的用户定义类型（UDT）的描述。

InputStream

ResultSet.getUnicodeStream​(String columnLabel)

已过时。
改用getCharacterStream

URL

CallableStatement.getURL​(String parameterName)

检索作为 java.net.URL对象的JDBC DATALINK参数的值。

URL

ResultSet.getURL​(String columnLabel)

检索此 ResultSet对象的当前行中指定列的值为Java编程语言中的 java.net.URL对象。

ResultSet

DatabaseMetaData.getVersionColumns​(String catalog, String schema, String table)

检索表中更新行中任何值时自动更新的表的列的说明。

default boolean

Statement.isSimpleIdentifier​(String identifier)

检索 identifier是否是一个简单的SQL标识符。

String

Connection.nativeSQL​(String sql)

将给定的SQL语句转换为系统的本机SQL语法。

ConnectionBuilder

ConnectionBuilder.password​(String password)

指定创建连接时要使用的密码

long

Clob.position​(String searchstr, long start)

检索由 Clob对象表示的SQL CLOB指定的子字符串 searchstr出现的字符位置。

CallableStatement

Connection.prepareCall​(String sql)

创建一个 CallableStatement对象来调用数据库存储过程。

CallableStatement

Connection.prepareCall​(String sql, int resultSetType, int resultSetConcurrency)

创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。

CallableStatement

Connection.prepareCall​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)

创建一个 CallableStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。

PreparedStatement

Connection.prepareStatement​(String sql)

创建一个 PreparedStatement对象，用于将参数化的SQL语句发送到数据库。

PreparedStatement

Connection.prepareStatement​(String sql, int autoGeneratedKeys)

创建一个默认的 PreparedStatement对象，该对象具有检索自动生成的键的能力。

PreparedStatement

Connection.prepareStatement​(String sql, int[] columnIndexes)

创建一个默认的 PreparedStatement对象，能够返回给定数组指定的自动生成的键。

PreparedStatement

Connection.prepareStatement​(String sql, int resultSetType, int resultSetConcurrency)

创建一个 PreparedStatement对象，该对象将生成具有给定类型和并发性的 ResultSet对象。

PreparedStatement

Connection.prepareStatement​(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)

创建一个 PreparedStatement对象，该对象将生成具有给定类型，并发和 ResultSet对象。

PreparedStatement

Connection.prepareStatement​(String sql, String[] columnNames)

创建一个默认的 PreparedStatement对象，能够返回由给定数组指定的自动生成的键。

static void

DriverManager.println​(String message)

打印到当前JDBC日志流的消息。

void

SQLData.readSQL​(SQLInput stream, String typeName)

使用从数据库读取的数据填充此对象。

void

CallableStatement.registerOutParameter​(int parameterIndex, int sqlType, String typeName)

注册指定的输出参数。

default void

CallableStatement.registerOutParameter​(int parameterIndex, SQLType sqlType, String typeName)

注册指定的输出参数。

void

CallableStatement.registerOutParameter​(String parameterName, int sqlType)

将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。

void

CallableStatement.registerOutParameter​(String parameterName, int sqlType, int scale)

将名为 parameterName的参数注册为JDBC类型 sqlType 。

void

CallableStatement.registerOutParameter​(String parameterName, int sqlType, String typeName)

注册指定的输出参数。

default void

CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType)

将名为 parameterName的OUT参数注册到JDBC类型 sqlType 。

default void

CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType, int scale)

将名为 parameterName的参数注册为JDBC类型 sqlType 。

default void

CallableStatement.registerOutParameter​(String parameterName, SQLType sqlType, String typeName)

注册指定的输出参数。

void

CallableStatement.setAsciiStream​(String parameterName, InputStream x)

将指定的参数设置为给定的输入流。

void

CallableStatement.setAsciiStream​(String parameterName, InputStream x, int length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

CallableStatement.setAsciiStream​(String parameterName, InputStream x, long length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

CallableStatement.setBigDecimal​(String parameterName, BigDecimal x)

将指定的参数设置为给定的 java.math.BigDecimal值。

void

CallableStatement.setBinaryStream​(String parameterName, InputStream x)

将指定的参数设置为给定的输入流。

void

CallableStatement.setBinaryStream​(String parameterName, InputStream x, int length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

CallableStatement.setBinaryStream​(String parameterName, InputStream x, long length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

CallableStatement.setBlob​(String parameterName, InputStream inputStream)

将指定的参数设置为 InputStream对象。

void

CallableStatement.setBlob​(String parameterName, InputStream inputStream, long length)

将指定的参数设置为 InputStream对象。

void

CallableStatement.setBlob​(String parameterName, Blob x)

将指定的参数设置为给定的 java.sql.Blob对象。

void

CallableStatement.setBoolean​(String parameterName, boolean x)

将指定的参数设置为给定的Java boolean值。

void

CallableStatement.setByte​(String parameterName, byte x)

将指定的参数设置为给定的Java byte值。

void

CallableStatement.setBytes​(String parameterName, byte[] x)

将指定的参数设置为给定的Java字节数组。

void

Connection.setCatalog​(String catalog)

设置给定的目录名称，以便选择要在其中工作的 Connection对象的数据库的子空间。

void

CallableStatement.setCharacterStream​(String parameterName, Reader reader)

将指定的参数设置为给定的 Reader对象。

void

CallableStatement.setCharacterStream​(String parameterName, Reader reader, int length)

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

void

CallableStatement.setCharacterStream​(String parameterName, Reader reader, long length)

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

void

Connection.setClientInfo​(String name, String value)

将由name指定的客户端信息属性的值设置为由值指定的值。

void

CallableStatement.setClob​(String parameterName, Reader reader)

将指定的参数设置为 Reader对象。

void

CallableStatement.setClob​(String parameterName, Reader reader, long length)

将指定的参数设置为 Reader对象。

void

CallableStatement.setClob​(String parameterName, Clob x)

将指定的参数设置为给定的 java.sql.Clob对象。

void

Statement.setCursorName​(String name)

将SQL游标名称设置为给定的 String ，这将由后续的 Statement对象 execute方法使用。

void

CallableStatement.setDate​(String parameterName, Date x)

使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。

void

CallableStatement.setDate​(String parameterName, Date x, Calendar cal)

将指定的参数设置为给定的 java.sql.Date值，使用给定的 Calendar对象。

void

CallableStatement.setDouble​(String parameterName, double x)

将指定的参数设置为给定的Java double值。

void

CallableStatement.setFloat​(String parameterName, float x)

将指定的参数设置为给定的Java float值。

void

CallableStatement.setInt​(String parameterName, int x)

将指定的参数设置为给定的Java int值。

void

CallableStatement.setLong​(String parameterName, long x)

将指定的参数设置为给定的Java long值。

void

CallableStatement.setNCharacterStream​(String parameterName, Reader value)

将指定的参数设置为 Reader对象。

void

CallableStatement.setNCharacterStream​(String parameterName, Reader value, long length)

将指定的参数设置为 Reader对象。

void

CallableStatement.setNClob​(String parameterName, Reader reader)

将指定的参数设置为 Reader对象。

void

CallableStatement.setNClob​(String parameterName, Reader reader, long length)

将指定的参数设置为 Reader对象。

void

CallableStatement.setNClob​(String parameterName, NClob value)

将指定的参数设置为 java.sql.NClob对象。

void

CallableStatement.setNString​(String parameterName, String value)

将指定的参数设置为给定的 String对象。

void

PreparedStatement.setNString​(int parameterIndex, String value)

将指定的参数设置为给定的 String对象。

void

CallableStatement.setNull​(String parameterName, int sqlType)

将指定的参数设置为SQL NULL 。

void

CallableStatement.setNull​(String parameterName, int sqlType, String typeName)

将指定的参数设置为SQL NULL 。

void

PreparedStatement.setNull​(int parameterIndex, int sqlType, String typeName)

将指定的参数设置为SQL NULL 。

void

CallableStatement.setObject​(String parameterName, Object x)

使用给定对象设置指定参数的值。

void

CallableStatement.setObject​(String parameterName, Object x, int targetSqlType)

使用给定对象设置指定参数的值。

void

CallableStatement.setObject​(String parameterName, Object x, int targetSqlType, int scale)

使用给定对象设置指定参数的值。

default void

CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType)

使用给定对象设置指定参数的值。

default void

CallableStatement.setObject​(String parameterName, Object x, SQLType targetSqlType, int scaleOrLength)

使用给定对象设置指定参数的值。

void

CallableStatement.setRowId​(String parameterName, RowId x)

将指定的参数设置为给定的 java.sql.RowId对象。

Savepoint

Connection.setSavepoint​(String name)

在当前事务中创建具有给定名称的保存点，并返回代表它的新的 Savepoint对象。

void

Connection.setSchema​(String schema)

设置要访问的给定模式名称。

void

CallableStatement.setShort​(String parameterName, short x)

将指定的参数设置为给定的Java short值。

void

CallableStatement.setSQLXML​(String parameterName, SQLXML xmlObject)

将指定的参数设置为给定的 java.sql.SQLXML对象。

void

CallableStatement.setString​(String parameterName, String x)

将指定的参数设置为给定的Java String值。

int

Clob.setString​(long pos, String str)

写入给定的Java String到 CLOB值，这 Clob对象表示在该位置 pos 。

int

Clob.setString​(long pos, String str, int offset, int len)

写 len字符的 str ，从字符 offset开始，以 Clob表示的 CLOB值。

void

PreparedStatement.setString​(int parameterIndex, String x)

将指定的参数设置为给定的Java String值。

void

SQLXML.setString​(String value)

将此SQLXML实例指定的XML值设置为给定的String表示形式。

void

CallableStatement.setTime​(String parameterName, Time x)

将指定的参数设置为给定的 java.sql.Time值。

void

CallableStatement.setTime​(String parameterName, Time x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。

void

CallableStatement.setTimestamp​(String parameterName, Timestamp x)

将指定的参数设置为给定的 java.sql.Timestamp值。

void

CallableStatement.setTimestamp​(String parameterName, Timestamp x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

void

CallableStatement.setURL​(String parameterName, URL val)

将指定的参数设置为给定的 java.net.URL对象。

void

ResultSet.updateArray​(String columnLabel, Array x)

使用 java.sql.Array值更新指定的列。

void

ResultSet.updateAsciiStream​(String columnLabel, InputStream x)

使用ascii流值更新指定的列。

void

ResultSet.updateAsciiStream​(String columnLabel, InputStream x, int length)

使用ascii流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateAsciiStream​(String columnLabel, InputStream x, long length)

使用ascii流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateBigDecimal​(String columnLabel, BigDecimal x)

使用 java.sql.BigDecimal值更新指定的列。

void

ResultSet.updateBinaryStream​(String columnLabel, InputStream x)

使用二进制流值更新指定的列。

void

ResultSet.updateBinaryStream​(String columnLabel, InputStream x, int length)

使用二进制流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateBinaryStream​(String columnLabel, InputStream x, long length)

使用二进制流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateBlob​(String columnLabel, InputStream inputStream)

使用给定的输入流更新指定的列。

void

ResultSet.updateBlob​(String columnLabel, InputStream inputStream, long length)

使用给定的输入流更新指定列，该输入流将具有指定的字节数。

void

ResultSet.updateBlob​(String columnLabel, Blob x)

使用 java.sql.Blob值更新指定的列。

void

ResultSet.updateBoolean​(String columnLabel, boolean x)

使用 boolean值更新指定的列。

void

ResultSet.updateByte​(String columnLabel, byte x)

使用 byte值更新指定的列。

void

ResultSet.updateBytes​(String columnLabel, byte[] x)

使用字节数组值更新指定的列。

void

ResultSet.updateCharacterStream​(String columnLabel, Reader reader)

使用字符流值更新指定的列。

void

ResultSet.updateCharacterStream​(String columnLabel, Reader reader, int length)

使用字符流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateCharacterStream​(String columnLabel, Reader reader, long length)

使用字符流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateClob​(String columnLabel, Reader reader)

使用给定的 Reader对象更新指定的列。

void

ResultSet.updateClob​(String columnLabel, Reader reader, long length)

使用给定的 Reader对象更新指定的列，这是给定的字符数。

void

ResultSet.updateClob​(String columnLabel, Clob x)

使用 java.sql.Clob值更新指定的列。

void

ResultSet.updateDate​(String columnLabel, Date x)

使用 java.sql.Date值更新指定的列。

void

ResultSet.updateDouble​(String columnLabel, double x)

使用 double值更新指定的列。

void

ResultSet.updateFloat​(String columnLabel, float x)

使用 float值更新指定的列。

void

ResultSet.updateInt​(String columnLabel, int x)

使用 int值更新指定的列。

void

ResultSet.updateLong​(String columnLabel, long x)

使用 long值更新指定的列。

void

ResultSet.updateNCharacterStream​(String columnLabel, Reader reader)

使用字符流值更新指定的列。

void

ResultSet.updateNCharacterStream​(String columnLabel, Reader reader, long length)

使用字符流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateNClob​(String columnLabel, Reader reader)

使用给定的 Reader对象更新指定的列。

void

ResultSet.updateNClob​(String columnLabel, Reader reader, long length)

使用给定的 Reader对象更新指定的列，这是给定的字符数。

void

ResultSet.updateNClob​(String columnLabel, NClob nClob)

使用 java.sql.NClob值更新指定的列。

void

ResultSet.updateNString​(int columnIndex, String nString)

使用 String值更新指定的列。

void

ResultSet.updateNString​(String columnLabel, String nString)

使用 String值更新指定的列。

void

ResultSet.updateNull​(String columnLabel)

使用 null值更新指定的列。

void

ResultSet.updateObject​(String columnLabel, Object x)

使用 Object值更新指定的列。

void

ResultSet.updateObject​(String columnLabel, Object x, int scaleOrLength)

使用 Object值更新指定的列。

default void

ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType)

使用 Object值更新指定的列。

default void

ResultSet.updateObject​(String columnLabel, Object x, SQLType targetSqlType, int scaleOrLength)

使用 Object值更新指定的列。

void

ResultSet.updateRef​(String columnLabel, Ref x)

使用 java.sql.Ref值更新指定的列。

void

ResultSet.updateRowId​(String columnLabel, RowId x)

使用 RowId值更新指定的列。

void

ResultSet.updateShort​(String columnLabel, short x)

使用 short值更新指定的列。

void

ResultSet.updateSQLXML​(String columnLabel, SQLXML xmlObject)

使用 java.sql.SQLXML值更新指定的列。

void

ResultSet.updateString​(int columnIndex, String x)

使用 String值更新指定的列。

void

ResultSet.updateString​(String columnLabel, String x)

使用 String值更新指定的列。

void

ResultSet.updateTime​(String columnLabel, Time x)

使用 java.sql.Time值更新指定的列。

void

ResultSet.updateTimestamp​(String columnLabel, Timestamp x)

使用 java.sql.Timestamp值更新指定的列。

ConnectionBuilder

ConnectionBuilder.user​(String username)

指定创建连接时要使用的用户名

static ClientInfoStatus

ClientInfoStatus.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Date

Date.valueOf​(String s)

将JDBC日期转义格式的字符串转换为 Date值。

static JDBCType

JDBCType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PseudoColumnUsage

PseudoColumnUsage.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static RowIdLifetime

RowIdLifetime.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Time

Time.valueOf​(String s)

将JDBC时间转义格式的字符串转换为 Time值。

static Timestamp

Timestamp.valueOf​(String s)

将JDBC时间戳转换格式的 String对象转换为 Timestamp值。

void

SQLOutput.writeNString​(String x)

将下一个属性写入流中，作为Java编程语言中的 String 。

void

SQLOutput.writeString​(String x)

将下一个属性写入流，作为Java编程语言中的一个 String 。

Method parameters in java.sql with type arguments of type String

Modifier and Type

方法

描述

Object

Array.getArray​(long index, int count, Map<String,Class<?>> map)

检索由该 Array对象指定的SQL ARRAY值，从指定的 index开始，并包含最多 count个SQL数组的连续元素。

Object

Array.getArray​(Map<String,Class<?>> map)

检索此 Array对象指定的SQL ARRAY值的内容。

Object[]

Struct.getAttributes​(Map<String,Class<?>> map)

生成此 Struct对象所代表的SQL结构化类型的属性的有序值。

Object

CallableStatement.getObject​(int parameterIndex, Map<String,Class<?>> map)

返回表示OUT参数 parameterIndex的值的对象，并使用参数值的自定义映射 map 。

Object

CallableStatement.getObject​(String parameterName, Map<String,Class<?>> map)

返回表示OUT参数 parameterName的值的对象，并使用参数值的自定义映射 map 。

Object

Ref.getObject​(Map<String,Class<?>> map)

检索引用的对象，并使用给定的类型映射将其映射到Java类型。

Object

ResultSet.getObject​(int columnIndex, Map<String,Class<?>> map)

以Java编程语言中的 Object此 ResultSet对象的当前行中指定列的值。

Object

ResultSet.getObject​(String columnLabel, Map<String,Class<?>> map)

以Java编程语言中的 Object此 ResultSet对象的当前行中指定列的值。

ResultSet

Array.getResultSet​(long index, int count, Map<String,Class<?>> map)

检索一个结果集，该结果集保存从索引 index开始的子阵列的元素，并包含最多 count连续元素。

ResultSet

Array.getResultSet​(Map<String,Class<?>> map)

检索包含此 Array对象指定的SQL ARRAY值的元素的结果集。

void

Connection.setTypeMap​(Map<String,Class<?>> map)

安装给定 TypeMap对象的类型映射此 Connection对象。

Constructors in java.sql with parameters of type String

Constructor

描述

BatchUpdateException​(String reason, int[] updateCounts)

构造一个 BatchUpdateException对象，初始化为给定的 reason和 updateCounts 。

BatchUpdateException​(String reason, int[] updateCounts, Throwable cause)

构造一个 BatchUpdateException与给定的初始化的对象 reason ， cause和 updateCounts 。

BatchUpdateException​(String reason, String SQLState, int[] updateCounts)

构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState和 updateCounts 。

BatchUpdateException​(String reason, String SQLState, int[] updateCounts, Throwable cause)

构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， cause ，和 updateCounts 。

BatchUpdateException​(String reason, String SQLState, int vendorCode, int[] updateCounts)

构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode和 updateCounts 。

BatchUpdateException​(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)

构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。

BatchUpdateException​(String reason, String SQLState, int vendorCode, long[] updateCounts, Throwable cause)

构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。

DriverPropertyInfo​(String name, String value)

构造具有给定名称和值的 DriverPropertyInfo对象。

SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， vendorCode和 failedProperties 。

SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。

SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState和 failedProperties 。

SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause和 failedProperties 。

SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties)

构造一个 SQLClientInfoException对象，该对象使用给定的 reason和 failedProperties初始化。

SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， cause和 failedProperties 。

SQLDataException​(String reason)

构造一个 SQLDataException对象与给定的 reason 。

SQLDataException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLDataException对象。

SQLDataException​(String reason, String SQLState, int vendorCode)

构造一个 SQLDataException与给定对象 reason ， SQLState和 vendorCode 。

SQLDataException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLDataException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLDataException​(String reason, String SQLState, Throwable cause)

构造一个 SQLDataException与给定对象 reason ， SQLState和 cause 。

SQLDataException​(String reason, Throwable cause)

构造一个 SQLDataException对象与一个给定的 reason和 cause 。

SQLException​(String reason)

构造一个 SQLException对象与给定的 reason 。

SQLException​(String reason, String SQLState)

构造一个 SQLException对象与给定的 reason和 SQLState 。

SQLException​(String reason, String SQLState, int vendorCode)

构造一个 SQLException与给定对象 reason ， SQLState和 vendorCode 。

SQLException​(String reason, String sqlState, int vendorCode, Throwable cause)

构造一个 SQLException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLException​(String reason, String sqlState, Throwable cause)

构造一个 SQLException与给定对象 reason ， SQLState和 cause 。

SQLException​(String reason, Throwable cause)

使用给定的 reason和 cause构造一个 SQLException对象。

SQLFeatureNotSupportedException​(String reason)

构造一个 SQLFeatureNotSupportedException对象与给定的 reason 。

SQLFeatureNotSupportedException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLFeatureNotSupportedException对象。

SQLFeatureNotSupportedException​(String reason, String SQLState, int vendorCode)

构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState和 vendorCode 。

SQLFeatureNotSupportedException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLFeatureNotSupportedException​(String reason, String SQLState, Throwable cause)

构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState和 cause 。

SQLFeatureNotSupportedException​(String reason, Throwable cause)

使用给定的 reason和 cause构造一个 SQLFeatureNotSupportedException对象。

SQLIntegrityConstraintViolationException​(String reason)

构造一个 SQLIntegrityConstraintViolationException与给定的 reason 。

SQLIntegrityConstraintViolationException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLIntegrityConstraintViolationException对象。

SQLIntegrityConstraintViolationException​(String reason, String SQLState, int vendorCode)

构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState和 vendorCode 。

SQLIntegrityConstraintViolationException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLIntegrityConstraintViolationException​(String reason, String SQLState, Throwable cause)

构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState和 cause 。

SQLIntegrityConstraintViolationException​(String reason, Throwable cause)

构造一个 SQLIntegrityConstraintViolationException对象与给定的 reason和 cause 。

SQLInvalidAuthorizationSpecException​(String reason)

构造一个 SQLInvalidAuthorizationSpecException对象与给定的 reason 。

SQLInvalidAuthorizationSpecException​(String reason, String SQLState)

构造一个 SQLInvalidAuthorizationSpecException对象，给定的 reason和 SQLState 。

SQLInvalidAuthorizationSpecException​(String reason, String SQLState, int vendorCode)

构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState和 vendorCode 。

SQLInvalidAuthorizationSpecException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLInvalidAuthorizationSpecException​(String reason, String SQLState, Throwable cause)

构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState和 cause 。

SQLInvalidAuthorizationSpecException​(String reason, Throwable cause)

使用给定的 reason和 cause构造一个 SQLInvalidAuthorizationSpecException对象。

SQLNonTransientConnectionException​(String reason)

构造一个 SQLNonTransientConnectionException对象与给定的 reason 。

SQLNonTransientConnectionException​(String reason, String SQLState)

构造一个 SQLNonTransientConnectionException对象，给定的 reason和 SQLState 。

SQLNonTransientConnectionException​(String reason, String SQLState, int vendorCode)

构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState和 vendorCode 。

SQLNonTransientConnectionException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLNonTransientConnectionException​(String reason, String SQLState, Throwable cause)

构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState和 cause 。

SQLNonTransientConnectionException​(String reason, Throwable cause)

使用给定的 reason和 cause构造一个 SQLTransientException对象。

SQLNonTransientException​(String reason)

构造一个 SQLNonTransientException对象与给定的 reason 。

SQLNonTransientException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLNonTransientException对象。

SQLNonTransientException​(String reason, String SQLState, int vendorCode)

构造一个 SQLNonTransientException与给定对象 reason ， SQLState和 vendorCode 。

SQLNonTransientException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLNonTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLNonTransientException​(String reason, String SQLState, Throwable cause)

构造一个 SQLNonTransientException与给定对象 reason ， SQLState和 cause 。

SQLNonTransientException​(String reason, Throwable cause)

构造一个 SQLTransientException对象，给定的 reason和 cause 。

SQLPermission​(String name)

使用指定的名称创建一个新的 SQLPermission对象。

SQLPermission​(String name, String actions)

使用指定的名称创建一个新的 SQLPermission对象。

SQLRecoverableException​(String reason)

构造一个 SQLRecoverableException对象与给定的 reason 。

SQLRecoverableException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLRecoverableException对象。

SQLRecoverableException​(String reason, String SQLState, int vendorCode)

构造一个 SQLRecoverableException与给定对象 reason ， SQLState和 vendorCode 。

SQLRecoverableException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLRecoverableException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLRecoverableException​(String reason, String SQLState, Throwable cause)

构造一个 SQLRecoverableException与给定对象 reason ， SQLState和 cause 。

SQLRecoverableException​(String reason, Throwable cause)

使用给定的 reason和 cause构造一个 SQLRecoverableException对象。

SQLSyntaxErrorException​(String reason)

构造一个 SQLSyntaxErrorException对象与给定的 reason 。

SQLSyntaxErrorException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLSyntaxErrorException对象。

SQLSyntaxErrorException​(String reason, String SQLState, int vendorCode)

构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState和 vendorCode 。

SQLSyntaxErrorException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLSyntaxErrorException​(String reason, String SQLState, Throwable cause)

构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState和 cause 。

SQLSyntaxErrorException​(String reason, Throwable cause)

构造一个 SQLSyntaxErrorException对象，给定的 reason和 cause 。

SQLTimeoutException​(String reason)

构造一个 SQLTimeoutException对象与给定的 reason 。

SQLTimeoutException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLTimeoutException对象。

SQLTimeoutException​(String reason, String SQLState, int vendorCode)

构造一个 SQLTimeoutException与给定对象 reason ， SQLState和 vendorCode 。

SQLTimeoutException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLTimeoutException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTimeoutException​(String reason, String SQLState, Throwable cause)

构造一个 SQLTimeoutException与给定对象 reason ， SQLState和 cause 。

SQLTimeoutException​(String reason, Throwable cause)

构造一个 SQLTimeoutException对象与给定的 reason和 cause 。

SQLTransactionRollbackException​(String reason)

使用给定的 reason构造一个 SQLTransactionRollbackException对象。

SQLTransactionRollbackException​(String reason, String SQLState)

构造一个 SQLTransactionRollbackException对象，给定的 reason和 SQLState 。

SQLTransactionRollbackException​(String reason, String SQLState, int vendorCode)

构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState和 vendorCode 。

SQLTransactionRollbackException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTransactionRollbackException​(String reason, String SQLState, Throwable cause)

构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState和 cause 。

SQLTransactionRollbackException​(String reason, Throwable cause)

构造一个 SQLTransactionRollbackException对象，给定的 reason和 cause 。

SQLTransientConnectionException​(String reason)

构造一个 SQLTransientConnectionException对象与给定的 reason 。

SQLTransientConnectionException​(String reason, String SQLState)

构造一个 SQLTransientConnectionException对象，给定的 reason和 SQLState 。

SQLTransientConnectionException​(String reason, String SQLState, int vendorCode)

构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState和 vendorCode 。

SQLTransientConnectionException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTransientConnectionException​(String reason, String SQLState, Throwable cause)

构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState和 cause 。

SQLTransientConnectionException​(String reason, Throwable cause)

构造一个 SQLTransientConnectionException对象，给定的 reason和 cause 。

SQLTransientException​(String reason)

使用给定的 reason构造一个 SQLTransientException对象。

SQLTransientException​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLTransientException对象。

SQLTransientException​(String reason, String SQLState, int vendorCode)

构造一个 SQLTransientException与给定对象 reason ， SQLState和 vendorCode 。

SQLTransientException​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLTransientException​(String reason, String SQLState, Throwable cause)

构造一个 SQLTransientException与给定对象 reason ， SQLState和 cause 。

SQLTransientException​(String reason, Throwable cause)

使用给定的 reason和 cause构造一个 SQLTransientException对象。

SQLWarning​(String reason)

构造一个 SQLWarning对象与给定的 reason 。

SQLWarning​(String reason, String SQLState)

使用给定的 reason和 SQLState构造一个 SQLWarning对象。

SQLWarning​(String reason, String SQLState, int vendorCode)

构造一个 SQLWarning与给定对象 reason ， SQLState和 vendorCode 。

SQLWarning​(String reason, String SQLState, int vendorCode, Throwable cause)

构造一个 SQLWarning与给定对象 reason ， SQLState ， vendorCode和 cause 。

SQLWarning​(String reason, String SQLState, Throwable cause)

构造一个 SQLWarning与给定对象 reason ， SQLState和 cause 。

SQLWarning​(String reason, Throwable cause)

构造一个 SQLWarning对象，给定的 reason和 cause 。

Constructor parameters in java.sql with type arguments of type String

Constructor

描述

SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， vendorCode和 failedProperties 。

SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。

SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState和 failedProperties 。

SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause和 failedProperties 。

SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties)

构造一个 SQLClientInfoException对象，该对象使用给定的 reason和 failedProperties初始化。

SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)

构造一个 SQLClientInfoException与给定的初始化的对象 reason ， cause和 failedProperties 。

SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties)

构造一个 SQLClientInfoException对象，使用给定的 failedProperties初始化。

SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties, Throwable cause)

构造一个 SQLClientInfoException对象，初始化为给定的 cause和 failedProperties 。

Uses of String in java.text

Methods in java.text that return String

Modifier and Type

方法

描述

String

DateFormat.format​(Date date)

将日期格式化成日期/时间字符串。

String

Format.format​(Object obj)

格式化一个对象来生成一个字符串。

static String

MessageFormat.format​(String pattern, Object... arguments)

使用给定的模式创建一个MessageFormat，并使用它来格式化给定的参数。

String

NumberFormat.format​(double number)

专业化格式。

String

NumberFormat.format​(long number)

专业化格式。

String[]

DateFormatSymbols.getAmPmStrings​()

获取ampm字符串。

String

DecimalFormatSymbols.getCurrencySymbol​()

返回其区域设置中这些DecimalFormatSymbols的货币的货币符号。

String[]

DateFormatSymbols.getEras​()

获取时代字符串。

String

DecimalFormatSymbols.getExponentSeparator​()

返回用于将尾数与指数分隔开的字符串。

String

DecimalFormatSymbols.getInfinity​()

获取用于表示无穷大的字符串。

String

DecimalFormatSymbols.getInternationalCurrencySymbol​()

返回这些DecimalFormatSymbols的货币的ISO 4217货币代码。

String

DateFormatSymbols.getLocalPatternChars​()

获取本地化的日期时间模式字符。

String[]

DateFormatSymbols.getMonths​()

获取月份字符串。

protected String

AttributedCharacterIterator.Attribute.getName​()

返回属性的名称。

String

DecimalFormatSymbols.getNaN​()

获取用于表示“不是数字”的字符串。

String

DecimalFormat.getNegativePrefix​()

获取负前缀。

String

DecimalFormat.getNegativeSuffix​()

得到负的后缀。

String

DecimalFormat.getPositivePrefix​()

获取正面前缀。

String

DecimalFormat.getPositiveSuffix​()

获得积极的后缀。

String

RuleBasedCollator.getRules​()

获取排序规则对象的基于表的规则。

String[]

DateFormatSymbols.getShortMonths​()

获得短的月份字符串。

String[]

DateFormatSymbols.getShortWeekdays​()

获得短周日字符串。

String

CollationKey.getSourceString​()

返回此CollationKey表示的String。

String[]

DateFormatSymbols.getWeekdays​()

获得平日字符串。

String[][]

DateFormatSymbols.getZoneStrings​()

获取时区字符串。

static String

Normalizer.normalize​(CharSequence src, Normalizer.Form form)

归一化一个char值序列。

String

DecimalFormat.toLocalizedPattern​()

合成表示此Format对象的当前状态的本地化模式字符串。

String

SimpleDateFormat.toLocalizedPattern​()

返回描述此日期格式的本地化模式字符串。

String

ChoiceFormat.toPattern​()

获得模式。

String

DecimalFormat.toPattern​()

合成表示此Format对象的当前状态的模式字符串。

String

MessageFormat.toPattern​()

返回表示消息格式的当前状态的模式。

String

SimpleDateFormat.toPattern​()

返回描述此日期格式的模式字符串。

String

Annotation.toString​()

返回此注释的String表示形式。

String

AttributedCharacterIterator.Attribute.toString​()

返回对象的字符串表示形式。

String

Bidi.toString​()

显示调试中使用的双向内部状态。

String

FieldPosition.toString​()

返回此FieldPosition的字符串表示形式。

String

ParsePosition.toString​()

返回此ParsePosition的字符串表示形式。

Methods in java.text with parameters of type String

Modifier and Type

方法

描述

void

DecimalFormat.applyLocalizedPattern​(String pattern)

将给定的模式应用于此Format对象。

void

SimpleDateFormat.applyLocalizedPattern​(String pattern)

将给定的本地化模式字符串应用于此日期格式。

void

ChoiceFormat.applyPattern​(String newPattern)

设置模式。

void

DecimalFormat.applyPattern​(String pattern)

将给定的模式应用于此Format对象。

void

MessageFormat.applyPattern​(String pattern)

设置此消息格式使用的模式。

void

SimpleDateFormat.applyPattern​(String pattern)

将给定的模式字符串应用于此日期格式。

abstract int

Collator.compare​(String source, String target)

根据此Collator的排序规则将源字符串与目标字符串进行比较。

int

RuleBasedCollator.compare​(String source, String target)

基于归类规则比较存储在两个不同字符串中的字符数据。

boolean

Collator.equals​(String source, String target)

基于此Collator的排序规则比较两个字符串的相等性的便利方法。

static String

MessageFormat.format​(String pattern, Object... arguments)

使用给定的模式创建一个MessageFormat，并使用它来格式化给定的参数。

CollationElementIterator

RuleBasedCollator.getCollationElementIterator​(String source)

返回给定String的CollationElementIterator。

abstract CollationKey

Collator.getCollationKey​(String source)

将String转换成可以与其他CollationKeys进行比较的一系列位。

CollationKey

RuleBasedCollator.getCollationKey​(String source)

将字符串转换成可以与CollationKey.compareTo进行比较的一系列字符。

Number

ChoiceFormat.parse​(String text, ParsePosition status)

从输入文本中解析一个数字。

Date

DateFormat.parse​(String source)

从给定字符串的开始解析文本以生成日期。

abstract Date

DateFormat.parse​(String source, ParsePosition pos)

根据给定的解析位置解析日期/时间字符串。

Number

DecimalFormat.parse​(String text, ParsePosition pos)

从字符串中解析文本，产生一个 Number 。

Object[]

MessageFormat.parse​(String source)

从给定字符串的开头解析文本以产生一个对象数组。

Object[]

MessageFormat.parse​(String source, ParsePosition pos)

解析字符串。

Number

NumberFormat.parse​(String source)

从给定字符串的开头解析文本以产生一个数字。

abstract Number

NumberFormat.parse​(String source, ParsePosition parsePosition)

如果可能，返回长（例如，在[Long.MIN_VALUE，Long.MAX_VALUE]范围内，无小数），否则为Double。

Date

SimpleDateFormat.parse​(String text, ParsePosition pos)

从字符串中解析文本，产生一个 Date 。

Object

DateFormat.parseObject​(String source, ParsePosition pos)

从字符串中解析文本，产生一个 Date 。

Object

Format.parseObject​(String source)

从给定字符串的开头解析文本以产生一个对象。

abstract Object

Format.parseObject​(String source, ParsePosition pos)

从字符串中解析文本以生成对象。

Object

MessageFormat.parseObject​(String source, ParsePosition pos)

从字符串中解析文本以生成对象数组。

Object

NumberFormat.parseObject​(String source, ParsePosition pos)

从字符串中解析文本，产生一个 Number 。

void

DateFormatSymbols.setAmPmStrings​(String[] newAmpms)

设置ampm字符串。

void

ChoiceFormat.setChoices​(double[] limits, String[] formats)

设置要在格式化中使用的选项。

void

DecimalFormatSymbols.setCurrencySymbol​(String currency)

在其区域设置中设置这些DecimalFormatSymbols的货币的货币符号。

void

DateFormatSymbols.setEras​(String[] newEras)

设置时代字符串。

void

DecimalFormatSymbols.setExponentSeparator​(String exp)

设置用于将尾数与指数分开的字符串。

void

DecimalFormatSymbols.setInfinity​(String infinity)

设置用于表示无穷大的字符串。

void

DecimalFormatSymbols.setInternationalCurrencySymbol​(String currencyCode)

设置这些DecimalFormatSymbols的货币的ISO 4217货币代码。

void

DateFormatSymbols.setLocalPatternChars​(String newLocalPatternChars)

设置本地化的日期时间模式字符。

void

DateFormatSymbols.setMonths​(String[] newMonths)

设置月份字符串。

void

DecimalFormatSymbols.setNaN​(String NaN)

设置用于表示“不是数字”的字符串。

void

DecimalFormat.setNegativePrefix​(String newValue)

设置负前缀。

void

DecimalFormat.setNegativeSuffix​(String newValue)

设置负后缀。

void

DecimalFormat.setPositivePrefix​(String newValue)

设置正前缀。

void

DecimalFormat.setPositiveSuffix​(String newValue)

设置正后缀。

void

DateFormatSymbols.setShortMonths​(String[] newShortMonths)

设置短的月份字符串。

void

DateFormatSymbols.setShortWeekdays​(String[] newShortWeekdays)

设置短周日字符串。

void

BreakIterator.setText​(String newText)

设置要扫描的新文本字符串。

void

CollationElementIterator.setText​(String source)

设置要迭代的新字符串。

void

StringCharacterIterator.setText​(String text)

重置这个迭代器以指向一个新的字符串。

void

DateFormatSymbols.setWeekdays​(String[] newWeekdays)

设置工作日字符串

void

DateFormatSymbols.setZoneStrings​(String[][] newZoneStrings)

设置时区字符串。

static Normalizer.Form

Normalizer.Form.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.text with parameters of type String

Constructor

描述

Attribute​(String name)

构造一个具有给定名称的 Attribute 。

AttributedString​(String text)

使用给定的文本构造一个AttributedString实例。

AttributedString​(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)

使用给定的文本和属性构造一个AttributedString实例。

Bidi​(String paragraph, int flags)

从文本和基本方向的给定段落创建Bidi。

ChoiceFormat​(double[] limits, String[] formats)

具有限制和相应格式的构造。

ChoiceFormat​(String newPattern)

基于模式的限制和相应格式的构造。

CollationKey​(String source)

CollationKey构造函数。

DecimalFormat​(String pattern)

使用给定的模式和默认的 FORMAT区域设置的符号创建一个DecimalFormat。

DecimalFormat​(String pattern, DecimalFormatSymbols symbols)

使用给定的模式和符号创建一个DecimalFormat。

Field​(String name, int calendarField)

创建一个 Field 。

Field​(String name)

用指定的名称创建一个字段。

Field​(String name)

用指定的名称创建一个字段。

Field​(String name)

创建具有指定名称的Field实例。

MessageFormat​(String pattern)

为默认的 FORMAT语言环境和指定的模式构造一个MessageFormat。

MessageFormat​(String pattern, Locale locale)

为指定的区域设置和模式构造一个MessageFormat。

ParseException​(String s, int errorOffset)

构造具有指定的详细消息和偏移量的ParseException。

RuleBasedCollator​(String rules)

RuleBasedCollator构造函数。

SimpleDateFormat​(String pattern)

构造一个 SimpleDateFormat使用给定的模式和默认的日期格式符号为默认的 FORMAT区域设置。

SimpleDateFormat​(String pattern, DateFormatSymbols formatSymbols)

使用给定的模式和日期格式符号构造 SimpleDateFormat 。

SimpleDateFormat​(String pattern, Locale locale)

构造一个 SimpleDateFormat使用给定的模式和给定的区域设置的默认日期格式符号。

StringCharacterIterator​(String text)

构造一个初始索引为0的迭代器。

StringCharacterIterator​(String text, int pos)

构造具有指定初始索引的迭代器。

StringCharacterIterator​(String text, int begin, int end, int pos)

在给定字符串的给定范围内构造迭代器，索引设置在指定的位置。

Uses of String in java.time

Fields in java.time with type parameters of type String

Modifier and Type

Field

描述

static Map<String,String>

ZoneId.SHORT_IDS

区域覆盖的映射，以启用短时区名称。

static Map<String,String>

ZoneId.SHORT_IDS

区域覆盖的映射，以启用短时区名称。

Methods in java.time that return String

Modifier and Type

方法

描述

String

LocalDate.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期。

String

LocalDateTime.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期时间。

String

LocalTime.format​(DateTimeFormatter formatter)

此时使用指定的格式化程序格式化。

String

MonthDay.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化本月。

String

OffsetDateTime.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期时间。

String

OffsetTime.format​(DateTimeFormatter formatter)

此时使用指定的格式化程序格式化。

String

Year.format​(DateTimeFormatter formatter)

今年格式使用指定的格式化程序。

String

YearMonth.format​(DateTimeFormatter formatter)

使用指定的格式化程序在今年的格式。

String

ZonedDateTime.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期时间。

String

DayOfWeek.getDisplayName​(TextStyle style, Locale locale)

获取文本表示，如“星期一”或“星期五”。

String

Month.getDisplayName​(TextStyle style, Locale locale)

获取文本表示，如“1月”或“12月”。

String

ZoneId.getDisplayName​(TextStyle style, Locale locale)

获取区域的文字表示，例如“英国时间”或“+02：00”。

abstract String

ZoneId.getId​()

获取唯一的时区ID。

String

ZoneOffset.getId​()

获取标准化区域偏移ID。

String

Duration.toString​()

使用ISO-8601秒表示形式的字符串表示形式，如 PT8H6M12.345S 。

String

Instant.toString​()

此瞬间使用ISO-8601表示形式的字符串表示形式。

String

LocalDate.toString​()

将此日期输出为 String ，如 2007-12-03 。

String

LocalDateTime.toString​()

将此日期时间输出为 String ，如 2007-12-03T10:15:30 。

String

LocalTime.toString​()

此时输出为 String ，如 10:15 。

String

MonthDay.toString​()

本月产量为 String ，如 --12-03 。

String

OffsetDateTime.toString​()

将此日期时间输出为 String ，如 2007-12-03T10:15:30+01:00 。

String

OffsetTime.toString​()

此时输出为 String ，如 10:15:30+01:00 。

String

Period.toString​()

输出这个时期为 String ，如 P6Y3M1D 。

String

Year.toString​()

今年产量为 String 。

String

YearMonth.toString​()

今年产量为 String ，如 2007-12 。

String

ZonedDateTime.toString​()

将此日期时间输出为 String ，如 2007-12-03T10:15:30+01:00[Europe/Paris] 。

String

ZoneId.toString​()

输出此区域为 String ，使用ID。

String

ZoneOffset.toString​()

使用归一化ID将此偏移量输出为 String 。

Methods in java.time that return types with arguments of type String

Modifier and Type

方法

描述

static Set<String>

ZoneId.getAvailableZoneIds​()

获取一组可用的区域ID。

Methods in java.time with parameters of type String

Modifier and Type

方法

描述

static ZoneId

ZoneId.of​(String zoneId)

从ID获取一个 ZoneId的实例，确保该ID有效并且可供使用。

static ZoneId

ZoneId.of​(String zoneId, Map<String,String> aliasMap)

获取使用其ID的 ZoneId实例，使用别名映射来补充标准区域ID。

static ZoneOffset

ZoneOffset.of​(String offsetId)

使用ID获取 ZoneOffset的实例。

static ZoneId

ZoneId.ofOffset​(String prefix, ZoneOffset offset)

获得一个 ZoneId的实例包装一个偏移量。

static DayOfWeek

DayOfWeek.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Month

Month.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in java.time with type arguments of type String

Modifier and Type

方法

描述

static ZoneId

ZoneId.of​(String zoneId, Map<String,String> aliasMap)

获取使用其ID的 ZoneId实例，使用别名映射来补充标准区域ID。

static ZoneId

ZoneId.of​(String zoneId, Map<String,String> aliasMap)

获取 ZoneId的实例，使用其ID使用别名映射来补充标准区域ID。

Constructors in java.time with parameters of type String

Constructor

描述

DateTimeException​(String message)

使用指定的消息构造新的日期时间异常。

DateTimeException​(String message, Throwable cause)

构造一个新的日期时间异常与指定的消息和原因。

Uses of String in java.time.chrono

Methods in java.time.chrono that return String

Modifier and Type

方法

描述

default String

ChronoLocalDate.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期。

default String

ChronoLocalDateTime.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期时间。

default String

ChronoZonedDateTime.format​(DateTimeFormatter formatter)

使用指定的格式化程序格式化此日期时间。

String

Chronology.getCalendarType​()

获取日历系统的日历类型。

String

HijrahChronology.getCalendarType​()

获取伊斯兰历法的日历类型。

String

IsoChronology.getCalendarType​()

获取底层日历系统的日历类型 - 'iso8601'。

String

JapaneseChronology.getCalendarType​()

获取基础日历系统的日历类型 - “日语”。

String

MinguoChronology.getCalendarType​()

获取底层日历系统的日历类型 - “roc”。

String

ThaiBuddhistChronology.getCalendarType​()

获取基础日历系统的日历类型 - “佛教”。

default String

Chronology.getDisplayName​(TextStyle style, Locale locale)

获取这个年表的文本表示。

default String

Era.getDisplayName​(TextStyle style, Locale locale)

获得这个时代的文字表现。

String

JapaneseEra.getDisplayName​(TextStyle style, Locale locale)

获得这个时代的文字表现。

String

Chronology.getId​()

获取年表的ID。

String

HijrahChronology.getId​()

获取年表的ID。

String

IsoChronology.getId​()

获取年表的ID - “ISO”。

String

JapaneseChronology.getId​()

获取年表的ID - “日语”。

String

MinguoChronology.getId​()

获取年代的ID - “Minguo”。

String

ThaiBuddhistChronology.getId​()

获取年代的ID - “泰国人”。

String

AbstractChronology.toString​()

输出这个年表为 String ，使用年表ID。

String

ChronoLocalDate.toString​()

将此日期输出为 String 。

String

ChronoLocalDateTime.toString​()

将此日期时间输出为 String 。

String

Chronology.toString​()

输出这个年表为 String 。

String

ChronoPeriod.toString​()

将此期间输出为 String 。

String

ChronoZonedDateTime.toString​()

将此日期时间输出为 String 。

String

JapaneseEra.toString​()

Methods in java.time.chrono with parameters of type String

Modifier and Type

方法

描述

static Chronology

Chronology.of​(String id)

从时间顺序ID或日历系统类型获取 Chronology的实例。

static HijrahEra

HijrahEra.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static IsoEra

IsoEra.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static JapaneseEra

JapaneseEra.valueOf​(String japaneseEra)

返回名称为 JapaneseEra 。

static MinguoEra

MinguoEra.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ThaiBuddhistEra

ThaiBuddhistEra.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in java.time.format

Methods in java.time.format that return String

Modifier and Type

方法

描述

String

DateTimeFormatter.format​(TemporalAccessor temporal)

使用此格式化程序格式化日期时间对象。

static String

DateTimeFormatterBuilder.getLocalizedDateTimePattern​(FormatStyle dateStyle, FormatStyle timeStyle, Chronology chrono, Locale locale)

获取区域设置和时间顺序的日期和时间样式的格式模式。

String

DateTimeParseException.getParsedString​()

返回要解析的字符串。

String

DateTimeFormatter.toString​()

返回底层格式化程序的描述。

String

DecimalStyle.toString​()

返回描述此DecimalStyle的字符串。

Methods in java.time.format with parameters of type String

Modifier and Type

方法

描述

DateTimeFormatterBuilder

DateTimeFormatterBuilder.appendLiteral​(String literal)

将一个字符串字面值附加到格式化程序。

DateTimeFormatterBuilder

DateTimeFormatterBuilder.appendOffset​(String pattern, String noOffsetText)

将区域偏移（如“+01：00”）附加到格式化程序。

DateTimeFormatterBuilder

DateTimeFormatterBuilder.appendPattern​(String pattern)

将指定模式定义的元素附加到构建器。

static DateTimeFormatter

DateTimeFormatter.ofPattern​(String pattern)

使用指定的模式创建格式化程序。

static DateTimeFormatter

DateTimeFormatter.ofPattern​(String pattern, Locale locale)

使用指定的模式和区域设置创建格式化程序。

static FormatStyle

FormatStyle.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ResolverStyle

ResolverStyle.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SignStyle

SignStyle.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TextStyle

TextStyle.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in java.time.format with type arguments of type String

Modifier and Type

方法

描述

DateTimeFormatterBuilder

DateTimeFormatterBuilder.appendText​(TemporalField field, Map<Long,String> textLookup)

使用指定的地图将日期时间字段的文本附加到格式化程序以提供文本。

Constructors in java.time.format with parameters of type String

Constructor

描述

DateTimeParseException​(String message, CharSequence parsedData, int errorIndex)

使用指定的消息构造新的异常。

DateTimeParseException​(String message, CharSequence parsedData, int errorIndex, Throwable cause)

构造一个新的异常与指定的消息和原因。

Uses of String in java.time.temporal

Methods in java.time.temporal that return String

Modifier and Type

方法

描述

String

ChronoField.getDisplayName​(Locale locale)

default String

TemporalField.getDisplayName​(Locale locale)

获取所请求语言环境中字段的显示名称。

String

ChronoField.toString​()

String

ChronoUnit.toString​()

String

TemporalField.toString​()

获取字段的描述性名称。

String

TemporalUnit.toString​()

获取单位的描述性名称。

String

ValueRange.toString​()

将此范围输出为 String 。

String

WeekFields.toString​()

这个 WeekFields实例的字符串表示形式。

Methods in java.time.temporal with parameters of type String

Modifier and Type

方法

描述

static ChronoField

ChronoField.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ChronoUnit

ChronoUnit.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.time.temporal with parameters of type String

Constructor

描述

UnsupportedTemporalTypeException​(String message)

使用指定的消息构造一个新的UnsupportedTemporalTypeException。

UnsupportedTemporalTypeException​(String message, Throwable cause)

构造一个新的UnsupportedTemporalTypeException与指定的消息和原因。

Uses of String in java.time.zone

Methods in java.time.zone that return String

Modifier and Type

方法

描述

String

ZoneOffsetTransition.toString​()

返回描述此对象的字符串。

String

ZoneOffsetTransitionRule.toString​()

返回描述此对象的字符串。

String

ZoneRules.toString​()

返回描述此对象的字符串。

Methods in java.time.zone that return types with arguments of type String

Modifier and Type

方法

描述

static Set<String>

ZoneRulesProvider.getAvailableZoneIds​()

获取一组可用的区域ID。

static NavigableMap<String,ZoneRules>

ZoneRulesProvider.getVersions​(String zoneId)

获取区域ID的规则历史记录。

protected abstract NavigableMap<String,ZoneRules>

ZoneRulesProvider.provideVersions​(String zoneId)

SPI方法获取区域ID的规则历史。

protected abstract Set<String>

ZoneRulesProvider.provideZoneIds​()

SPI方法获取可用的区域ID。

Methods in java.time.zone with parameters of type String

Modifier and Type

方法

描述

static ZoneRules

ZoneRulesProvider.getRules​(String zoneId, boolean forCaching)

获取区域ID的规则。

static NavigableMap<String,ZoneRules>

ZoneRulesProvider.getVersions​(String zoneId)

获取区域ID的规则历史记录。

protected abstract ZoneRules

ZoneRulesProvider.provideRules​(String zoneId, boolean forCaching)

SPI方法获取区域ID的规则。

protected abstract NavigableMap<String,ZoneRules>

ZoneRulesProvider.provideVersions​(String zoneId)

SPI方法获取区域ID的规则历史。

static ZoneOffsetTransitionRule.TimeDefinition

ZoneOffsetTransitionRule.TimeDefinition.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.time.zone with parameters of type String

Constructor

描述

ZoneRulesException​(String message)

使用指定的消息构造新的日期时间异常。

ZoneRulesException​(String message, Throwable cause)

构造一个新的日期时间异常与指定的消息和原因。

Uses of String in java.util

Fields in java.util with type parameters of type String

Modifier and Type

Field

描述

static List<String>

ResourceBundle.Control.FORMAT_CLASS

类的 List包含 "java.class" 。

static List<String>

ResourceBundle.Control.FORMAT_DEFAULT

默认格式为 List ，其中包含字符串 "java.class"和 "java.properties" ，按此顺序。

static List<String>

ResourceBundle.Control.FORMAT_PROPERTIES

仅属性格式 List包含 "java.properties" 。

Methods in java.util that return String

Modifier and Type

方法

描述

static String

Arrays.deepToString​(Object[] a)

返回指定数组的“深度内容”的字符串表示形式。

String

Base64.Encoder.encodeToString​(byte[] src)

使用Base64编码方案将指定的字节数组编码为字符串。

String

Scanner.findInLine​(String pattern)

尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。

String

Scanner.findInLine​(Pattern pattern)

尝试找到忽略分隔符的指定模式的下一个出现。

String

Scanner.findWithinHorizon​(String pattern, int horizon)

尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。

String

Scanner.findWithinHorizon​(Pattern pattern, int horizon)

尝试找到指定模式的下一个出现。

String

PropertyPermission.getActions​()

返回动作的“规范字符串表示”。

static String[]

TimeZone.getAvailableIDs​()

获取支持的所有可用ID。

static String[]

TimeZone.getAvailableIDs​(int rawOffset)

根据给定的时区偏移（以毫秒为单位）获取可用ID。

String

ResourceBundle.getBaseBundleName​()

如果已知，则返回此包的基本名称，如果未知，则返回 null 。

String

Calendar.getCalendarType​()

返回此 Calendar的日历类型。

String

GregorianCalendar.getCalendarType​()

作为日历类型返回 "gregory" 。

String

MissingResourceException.getClassName​()

获取由构造函数传递的参数。

String

UnknownFormatConversionException.getConversion​()

返回未知的转换。

String

Locale.getCountry​()

返回此区域设置的国家/地区代码，该代码应为空字符串，大写ISO 3166 2字母代码或UN M.49 3位代码。

String

Currency.getCurrencyCode​()

获得此货币的ISO 4217货币代码。

String

Locale.getDisplayCountry​()

返回适合显示给用户的区域设置国家/地区的名称。

String

Locale.getDisplayCountry​(Locale inLocale)

返回适合显示给用户的区域设置国家/地区的名称。

String

Locale.getDisplayLanguage​()

返回适合显示给用户的语言环境语言的名称。

String

Locale.getDisplayLanguage​(Locale inLocale)

返回适合显示给用户的语言环境语言的名称。

String

Calendar.getDisplayName​(int field, int style, Locale locale)

返回给定的 style和 locale中的日历 field的字符串表示。

String

Currency.getDisplayName​()

获取适用于默认 DISPLAY语言环境显示此货币的名称。

String

Currency.getDisplayName​(Locale locale)

获取适用于显示指定区域设置的货币的名称。

String

Locale.getDisplayName​()

返回适合显示给用户的区域设置的名称。

String

Locale.getDisplayName​(Locale inLocale)

返回适合显示给用户的区域设置的名称。

String

TimeZone.getDisplayName​()

返回此 TimeZone的较长标准时间名称，适合在默认语言环境中呈现给用户。

String

TimeZone.getDisplayName​(boolean daylight, int style)

返回此 TimeZone指定的 style中的名称，该名称适用于以默认语言环境向用户呈现。

String

TimeZone.getDisplayName​(boolean daylight, int style, Locale locale)

返回此 TimeZone指定的 style中的一个名称，适用于在指定的 style中向用户 locale 。

String

TimeZone.getDisplayName​(Locale locale)

返回此 TimeZone的长标准时间名称，适用于在指定的 locale向用户 locale 。

String

Locale.getDisplayScript​()

返回适合显示给用户的区域设置脚本的名称。

String

Locale.getDisplayScript​(Locale inLocale)

返回适合显示给用户的区域设置脚本的名称。

String

Locale.getDisplayVariant​()

返回适合显示给用户的区域设置变体代码的名称。

String

Locale.getDisplayVariant​(Locale inLocale)

返回适合显示给用户的区域设置变体代码的名称。

String

Locale.getExtension​(char key)

返回与指定键相关联的扩展名（或私有使用）值，如果没有与密钥关联的扩展名，则返回null。

String

DuplicateFormatFlagsException.getFlags​()

返回包含重复标志的标志集。

String

FormatFlagsConversionMismatchException.getFlags​()

返回不兼容的标志。

String

IllegalFormatFlagsException.getFlags​()

返回包含非法组合的标志集。

String

UnknownFormatFlagsException.getFlags​()

返回包含未知标志的标志集。

String

MissingFormatArgumentException.getFormatSpecifier​()

返回不匹配的格式说明符。

String

MissingFormatWidthException.getFormatSpecifier​()

返回没有宽度的格式说明符。

String

TimeZone.getID​()

获取此时区的ID。

String

Locale.getISO3Country​()

返回此区域设置的国家/地区的三个字母的缩写。

String

Locale.getISO3Language​()

返回此语言环境的三个字母缩写。

static String[]

Locale.getISOCountries​()

返回ISO 3166中定义的所有2个字母的国家/地区代码的列表。

static String[]

Locale.getISOLanguages​()

返回ISO 639中定义的所有2个字母的语言代码的列表。

String

MissingResourceException.getKey​()

获取由构造函数传递的参数。

String

Locale.getLanguage​()

返回此区域设置的语言代码。

String

DuplicateFormatFlagsException.getMessage​()

String

FormatFlagsConversionMismatchException.getMessage​()

String

IllegalFormatCodePointException.getMessage​()

String

IllegalFormatConversionException.getMessage​()

String

IllegalFormatFlagsException.getMessage​()

String

IllegalFormatPrecisionException.getMessage​()

String

IllegalFormatWidthException.getMessage​()

String

MissingFormatArgumentException.getMessage​()

String

MissingFormatWidthException.getMessage​()

String

UnknownFormatConversionException.getMessage​()

String

UnknownFormatFlagsException.getMessage​()

String

Currency.getNumericCodeAsString​()

以 String返回该货币的3位数ISO 4217数字代码。

String

Properties.getProperty​(String key)

使用此属性列表中指定的键搜索属性。

String

Properties.getProperty​(String key, String defaultValue)

使用此属性列表中指定的键搜索属性。

String

Locale.LanguageRange.getRange​()

返回此 LanguageRange的语言范围。

String

Locale.getScript​()

返回此语言环境的脚本，该脚本应为空字符串或ISO 15924 4字母脚本代码。

String

ResourceBundle.getString​(String key)

从此资源束或其父项之一获取给定密钥的字符串。

String[]

ResourceBundle.getStringArray​(String key)

从此资源包或其父项之一获取给定键的字符串数组。

String

Currency.getSymbol​()

获取默认的 DISPLAY区域设置的货币符号。

String

Currency.getSymbol​(Locale locale)

获取指定区域设置的货币符号。

String

Locale.getUnicodeLocaleType​(String key)

返回与该区域设置的指定Unicode区域设置键相关联的Unicode区域设置类型。

String

Locale.getVariant​()

返回此区域设置的变体代码。

static String

Locale.lookupTag​(List<Locale.LanguageRange> priorityList, Collection<String> tags)

使用RFC 4647中定义的查找机制返回最匹配的语言标签。

String

Scanner.next​()

查找并返回此扫描仪的下一个完整令牌。

String

Scanner.next​(String pattern)

如果匹配从指定字符串构造的模式，则返回下一个令牌。

String

Scanner.next​(Pattern pattern)

如果匹配指定的模式，则返回下一个令牌。

String

Scanner.nextLine​()

将此扫描仪推进到当前行并返回跳过的输入。

String

StringTokenizer.nextToken​()

从此字符串标记器返回下一个令牌。

String

StringTokenizer.nextToken​(String delim)

返回此字符串tokenizer字符串中的下一个令牌。

String

ResourceBundle.Control.toBundleName​(String baseName, Locale locale)

将给定的 baseName和 locale转换为包名称。

String

Date.toGMTString​()

已过时。
截至JDK 1.1版，由DateFormat.format(Date date)替代，使用GMT TimeZone 。

String

Locale.toLanguageTag​()

返回一个格式正确的IETF BCP 47语言标签，代表这个区域。

String

Date.toLocaleString​()

已过时。
从JDK 1.1版开始，替换为DateFormat.format(Date date) 。

String

ResourceBundle.Control.toResourceName​(String bundleName, String suffix)

将给定的 bundleName转换为 ClassLoader.getResource方法所需的 格式 ，替换所有出现的 '.'

String

AbstractCollection.toString​()

返回此集合的字符串表示形式。

String

AbstractMap.SimpleEntry.toString​()

返回此映射条目的字符串表示形式。

String

AbstractMap.SimpleImmutableEntry.toString​()

返回此映射条目的字符串表示形式。

String

AbstractMap.toString​()

返回此地图的字符串表示形式。

static String

Arrays.toString​(boolean[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(byte[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(char[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(double[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(float[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(int[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(long[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(short[] a)

返回指定数组的内容的字符串表示形式。

static String

Arrays.toString​(Object[] a)

返回指定数组的内容的字符串表示形式。

String

BitSet.toString​()

返回此位集的字符串表示形式。

String

Calendar.toString​()

返回此日历的字符串表示形式。

String

Currency.toString​()

返回此货币的ISO 4217货币代码。

String

Date.toString​()

将此 Date对象转换为 String的形式：

String

DoubleSummaryStatistics.toString​()

返回适用于调试的此对象的非空字符串表示形式。

String

EventObject.toString​()

返回此EventObject的String表示形式。

String

Formatter.toString​()

返回在输出的目的地上调用 toString()的结果。

String

Hashtable.toString​()

以一组条目的形式返回此 Hashtable对象的字符串表示形式，并以ASCII字符“ ,  ”（逗号和空格）分隔。

String

IntSummaryStatistics.toString​()

返回适用于调试的此对象的非空字符串表示形式。

String

Locale.LanguageRange.toString​()

返回此 LanguageRange对象的信息字符串表示，如果范围被加权且重量小于最大权重，则会包含语言范围和重量。

String

Locale.toString​()

返回此 Locale对象的字符串表示形式，由语言，国家/地区，变体，脚本和扩展名组成，如下所示：language +“_”+ country +“_”+（variant +“_＃”|“＃”）+ script +“_”+扩展语言总是小写，国家总是大写，脚本总是标题大小写，而扩展名总是小写。

String

LongSummaryStatistics.toString​()

返回适用于调试的此对象的非空字符串表示形式。

static String

Objects.toString​(Object o)

返回对于非 null参数调用 toString的结果，以及 "null"参数的 "null"的 null 。

static String

Objects.toString​(Object o, String nullDefault)

如果第一个参数不是 null ，则返回第一个参数中调用 toString的结果，否则返回第二个参数。

String

Optional.toString​()

返回适用于调试的 Optional的非空字符串表示形式。

String

OptionalDouble.toString​()

返回适用于调试的 OptionalDouble的非空字符串表示形式。

String

OptionalInt.toString​()

返回适用于调试的 OptionalInt的非空字符串表示形式。

String

OptionalLong.toString​()

返回适用于调试的 OptionalLong的非空字符串表示形式。

String

Properties.toString​()

String

Scanner.toString​()

返回此 Scanner的字符串表示 Scanner 。

String

ServiceLoader.toString​()

返回描述此服务的字符串。

String

SimpleTimeZone.toString​()

返回此时区的字符串表示形式。

String

StringJoiner.toString​()

返回当前值，由的 prefix ，值加入迄今由分离 delimiter和 suffix ，除非没有元素已经在这种情况下，被添加 prefix + suffix或 emptyValue返回字符。

String

UUID.toString​()

返回一个表示 UUID的 String对象。

String

Vector.toString​()

返回此Vector的字符串表示形式，其中包含每个元素的String表示形式。

Methods in java.util that return types with arguments of type String

Modifier and Type

方法

描述

static List<String>

Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags)

使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。

static List<String>

Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)

使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。

static Set<String>

Calendar.getAvailableCalendarTypes​()

返回一个不可修改的 Set其中包含 Calendar在运行时环境中支持的所有日历类型。

Map<String,Integer>

Calendar.getDisplayNames​(int field, int style, Locale locale)

返回 Map其中包含给定的 style和 locale中的日历 field所有名称及其对应的字段值。

List<String>

ResourceBundle.Control.getFormats​(String baseName)

返回 List的 String其中包含用于为给定的 baseName加载资源束的 baseName 。

static Set<String>

Locale.getISOCountries​(Locale.IsoCountryCode type)

返回 Set的指定类型的ISO3166国家代码。

Enumeration<String>

ListResourceBundle.getKeys​()

返回一个 Enumeration包含在此按键 ResourceBundle及其父包。

Enumeration<String>

PropertyResourceBundle.getKeys​()

返回此 ResourceBundle及其父级包含的密钥中的 Enumeration个密钥。

abstract Enumeration<String>

ResourceBundle.getKeys​()

返回键的枚举。

Set<String>

Locale.getUnicodeLocaleAttributes​()

返回与此区域设置关联的unicode区域设置属性集，如果没有属性，则返回空集合。

Set<String>

Locale.getUnicodeLocaleKeys​()

返回此区域设置定义的Unicode区域设置键的集合，如果此区域设置没有，则返回空集合。

protected Set<String>

ListResourceBundle.handleKeySet​()

返回一个 Set的键 只包含在这个 ResourceBundle 。

protected Set<String>

PropertyResourceBundle.handleKeySet​()

返回一个 Set的键 只包含在这个 ResourceBundle 。

protected Set<String>

ResourceBundle.handleKeySet​()

返回 Set 只有在这个包含的键 ResourceBundle 。

Set<String>

ResourceBundle.keySet​()

返回 Set包含在此的所有键的 ResourceBundle及其父包。

Set<String>

Properties.stringPropertyNames​()

从该属性列表中返回一个不可修改的键集，其中键及其对应的值是字符串，包括默认属性列表中的不同键，如果尚未从主属性列表中找到相同名称的键。

Stream<String>

Scanner.tokens​()

从此扫描仪返回一个分隔符的分隔符号流。

Methods in java.util with parameters of type String

Modifier and Type

方法

描述

Locale.Builder

Locale.Builder.addUnicodeLocaleAttribute​(String attribute)

添加unicode区域设置属性（如果尚未存在），否则不起作用。

boolean

ResourceBundle.containsKey​(String key)

确定给定的 key是否包含在此 ResourceBundle或其父包中。

byte[]

Base64.Decoder.decode​(String src)

使用Base64编码方案将Base64编码的字符串解码为新分配的字节数组。

Stream<MatchResult>

Scanner.findAll​(String patString)

返回与提供的模式字符串相匹配的匹配结果流。

String

Scanner.findInLine​(String pattern)

尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。

String

Scanner.findWithinHorizon​(String pattern, int horizon)

尝试查找从指定字符串构造的模式的下一个出现，忽略分隔符。

static Locale

Locale.forLanguageTag​(String languageTag)

返回指定的IETF BCP 47语言标记字符串的语言环境。

Formatter

Formatter.format​(String format, Object... args)

使用指定的格式字符串和参数将格式化的字符串写入此对象的目标。

Formatter

Formatter.format​(Locale l, String format, Object... args)

使用指定的区域设置，格式字符串和参数将格式化的字符串写入此对象的目标。

static UUID

UUID.fromString​(String name)

创建 UUID如在所描述的字符串标准表示 UUID.toString()方法。

static ResourceBundle

ResourceBundle.getBundle​(String baseName)

使用指定的基本名称，默认语言环境和调用者的类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle​(String baseName, Module module)

使用指定的基本名称和默认语言环境代替指定的模块获取资源包。

static ResourceBundle

ResourceBundle.getBundle​(String baseName, Locale locale)

使用指定的基本名称和区域设置以及调用者的类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle​(String baseName, Locale locale, ClassLoader loader)

使用指定的基本名称，区域设置和类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle​(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)

使用指定的基本名称，目标语言环境，类加载器和控件返回资源包。

static ResourceBundle

ResourceBundle.getBundle​(String baseName, Locale targetLocale, Module module)

使用指定的基本名称和区域设置代替指定的模块获取资源包。

static ResourceBundle

ResourceBundle.getBundle​(String baseName, Locale targetLocale, ResourceBundle.Control control)

使用指定的基本名称，目标语言环境和控件以及调用者的类加载器返回资源包。

static ResourceBundle

ResourceBundle.getBundle​(String baseName, ResourceBundle.Control control)

X- 2004545 CEEC X-

List<Locale>

ResourceBundle.Control.getCandidateLocales​(String baseName, Locale locale)

返回 List的 Locale S作为候选语言环境为 baseName和 locale 。

Locale

ResourceBundle.Control.getFallbackLocale​(String baseName, Locale locale)

返回一个 Locale ，以作为后备区域设置，用于通过 ResourceBundle.getBundle工厂方法进一步查找资源。

List<String>

ResourceBundle.Control.getFormats​(String baseName)

返回一个 List的 String其中包含用于为给定的 baseName加载资源束的 baseName 。

static Currency

Currency.getInstance​(String currencyCode)

返回给定货币代码的 Currency实例。

Object

ResourceBundle.getObject​(String key)

从此资源包或其父项之一获取给定密钥的对象。

String

Properties.getProperty​(String key)

使用此属性列表中指定的键搜索属性。

String

Properties.getProperty​(String key, String defaultValue)

使用此属性列表中指定的键搜索属性。

String

ResourceBundle.getString​(String key)

从此资源束或其父项之一获取给定密钥的字符串。

String[]

ResourceBundle.getStringArray​(String key)

从此资源包或其父项之一获取给定键的字符串数组。

long

ResourceBundle.Control.getTimeToLive​(String baseName, Locale locale)

返回此 ResourceBundle.Control下加载的资源束的生存时间（TTL）值。

static TimeZone

TimeZone.getTimeZone​(String ID)

获取给定ID的 TimeZone 。

String

Locale.getUnicodeLocaleType​(String key)

返回与该区域设置的指定Unicode区域设置键相关联的Unicode区域设置类型。

Object

ListResourceBundle.handleGetObject​(String key)

Object

PropertyResourceBundle.handleGetObject​(String key)

protected abstract Object

ResourceBundle.handleGetObject​(String key)

从此资源包获取给定键的对象。

boolean

Scanner.hasNext​(String pattern)

如果下一个令牌匹配从指定字符串构造的模式，则返回true。

boolean

ResourceBundle.Control.needsReload​(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)

根据 loadTime或其他一些标准确定加载时间是否需要重新加载缓存中的过期 bundle 。

ResourceBundle

ResourceBundle.Control.newBundle​(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)

为给定格式和区域设置的给定捆绑包名称实例化资源包，如有必要，使用给定的类加载器。

String

Scanner.next​(String pattern)

如果匹配从指定字符串构造的模式，则返回下一个令牌。

String

StringTokenizer.nextToken​(String delim)

返回此字符串tokenizer字符串中的下一个令牌。

static long

Date.parse​(String s)

已过时。
从JDK 1.1版开始，替换为DateFormat.parse(String s) 。

static List<Locale.LanguageRange>

Locale.LanguageRange.parse​(String ranges)

解析给定的 ranges以生成语言优先级列表。

static List<Locale.LanguageRange>

Locale.LanguageRange.parse​(String ranges, Map<String,List<String>> map)

解析给定的 ranges以生成语言优先级列表，然后使用给定的 map自定义列表。

Locale.Builder

Locale.Builder.removeUnicodeLocaleAttribute​(String attribute)

删除unicode区域设置属性（如果存在），否则不起作用。

static <T> T

Objects.requireNonNull​(T obj, String message)

检查指定的对象引用不是null并抛出一个自定义的NullPointerException（如果是）。

void

Properties.save​(OutputStream out, String comments)

已过时。
如果在保存属性列表时发生I / O错误，此方法不会抛出IOException。 保存属性列表的首选方法是通过store(OutputStream out, String comments)方法或storeToXML(OutputStream os, String comment)方法。

Calendar.Builder

Calendar.Builder.setCalendarType​(String type)

将日历类型参数设置为给定的 type 。

Locale.Builder

Locale.Builder.setExtension​(char key, String value)

设置给定键的扩展名。

void

TimeZone.setID​(String ID)

设置时区ID。

Locale.Builder

Locale.Builder.setLanguage​(String language)

设置语言。

Locale.Builder

Locale.Builder.setLanguageTag​(String languageTag)

重置生成器以匹配提供的IETF BCP 47语言标记。

Object

Properties.setProperty​(String key, String value)

致电 Hashtable方法 put 。

Locale.Builder

Locale.Builder.setRegion​(String region)

设置区域。

Locale.Builder

Locale.Builder.setScript​(String script)

设置脚本。

Locale.Builder

Locale.Builder.setUnicodeLocaleKeyword​(String key, String type)

设置给定键的Unicode区域设置关键字类型。

Locale.Builder

Locale.Builder.setVariant​(String variant)

设置变体。

Scanner

Scanner.skip​(String pattern)

跳过与指定字符串构成的模式匹配的输入。

void

Properties.store​(OutputStream out, String comments)

将此属性列表（键和元素对）写入此 Properties表格中，以适合于使用 load(InputStream)方法加载到 Properties表格的格式输出流。

void

Properties.store​(Writer writer, String comments)

将此属性列表（键和元素对）写入此 Properties表格中，以适合使用 load(Reader)方法的格式将输出字符流 写入 。

void

Properties.storeToXML​(OutputStream os, String comment)

发出表示此表中包含的所有属性的XML文档。

void

Properties.storeToXML​(OutputStream os, String comment, String encoding)

使用指定的编码发出表示此表中包含的所有属性的XML文档。

String

ResourceBundle.Control.toBundleName​(String baseName, Locale locale)

将给定的 baseName和 locale转换为包名称。

String

ResourceBundle.Control.toResourceName​(String bundleName, String suffix)

将给定的 bundleName转换为 ClassLoader.getResource方法所需的 格式 ，替换所有出现的 '.'

static String

Objects.toString​(Object o, String nullDefault)

如果第一个参数不是 null ，则返回第一个参数上调用 toString的结果，否则返回第二个参数。

Scanner

Scanner.useDelimiter​(String pattern)

将此扫描仪的分隔模式设置为从指定的 String构造的模式。

static Formatter.BigDecimalLayoutForm

Formatter.BigDecimalLayoutForm.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Locale.Category

Locale.Category.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Locale.FilteringMode

Locale.FilteringMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Locale.IsoCountryCode

Locale.IsoCountryCode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in java.util with type arguments of type String

Modifier and Type

方法

描述

static List<String>

Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags)

使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。

static List<String>

Locale.filterTags​(List<Locale.LanguageRange> priorityList, Collection<String> tags, Locale.FilteringMode mode)

使用RFC 4647中定义的基本过滤机制返回匹配语言标签的列表。

static ResourceBundle.Control

ResourceBundle.Control.getControl​(List<String> formats)

返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats 。

static ResourceBundle.Control

ResourceBundle.Control.getNoFallbackControl​(List<String> formats)

返回一个 ResourceBundle.Control ，其中 getFormats方法返回指定的 formats ，而 getFallbackLocale方法返回 null 。

static String

Locale.lookupTag​(List<Locale.LanguageRange> priorityList, Collection<String> tags)

使用RFC 4647中定义的查找机制返回最匹配的语言标签。

static List<Locale.LanguageRange>

Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)

使用给定的 priorityList和 map生成新的自定义语言优先级列表。

static List<Locale.LanguageRange>

Locale.LanguageRange.mapEquivalents​(List<Locale.LanguageRange> priorityList, Map<String,List<String>> map)

使用给定的 priorityList和 map生成新的自定义语言优先级列表。

static List<Locale.LanguageRange>

Locale.LanguageRange.parse​(String ranges, Map<String,List<String>> map)

解析给定的 ranges生成语言优先级列表，然后使用给定的 map自定义列表。

static List<Locale.LanguageRange>

Locale.LanguageRange.parse​(String ranges, Map<String,List<String>> map)

解析给定的 ranges以生成语言优先级列表，然后使用给定的 map自定义列表。

static <T> T

Objects.requireNonNull​(T obj, Supplier<String> messageSupplier)

检查指定的对象引用不是null并抛出一个自定义的NullPointerException（如果是）。

Constructors in java.util with parameters of type String

Constructor

描述

ConcurrentModificationException​(String message)

构造具有指定详细消息的 ConcurrentModificationException 。

ConcurrentModificationException​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

Date​(String s)

已过时。
从JDK 1.1版开始，由DateFormat.parse(String s)替代。

DuplicateFormatFlagsException​(String f)

使用指定的标志构造此类的实例。

FormatFlagsConversionMismatchException​(String f, char c)

使用指定的标志和转换构造此类的实例。

Formatter​(File file, String csn)

使用指定的文件和字符集构造一个新的格式化程序。

Formatter​(File file, String csn, Locale l)

使用指定的文件，字符集和区域设置构造一个新的格式化程序。

Formatter​(OutputStream os, String csn)

使用指定的输出流和字符集构造一个新的格式化程序。

Formatter​(OutputStream os, String csn, Locale l)

使用指定的输出流，字符集和区域设置构造一个新的格式化程序。

Formatter​(String fileName)

构造具有指定文件名的新格式化程序。

Formatter​(String fileName, String csn)

构造具有指定文件名和字符集的新格式化程序。

Formatter​(String fileName, String csn, Locale l)

构造具有指定文件名，字符集和区域设置的新格式化程序。

IllegalFormatFlagsException​(String f)

使用指定的标志构造此类的实例。

IllformedLocaleException​(String message)

构造一个新的 IllformedLocaleException与给定的消息和-1作为错误索引。

IllformedLocaleException​(String message, int errorIndex)

构造一个新的 IllformedLocaleException与给定的消息和错误索引。

InputMismatchException​(String s)

构造 InputMismatchException ，保存对错误消息字符串 s的引用，以供稍后通过 getMessage方法检索。

InvalidPropertiesFormatException​(String message)

使用指定的详细消息构造InvalidPropertiesFormatException。

LanguageRange​(String range)

构造一个 LanguageRange使用给定的 range 。

LanguageRange​(String range, double weight)

构造一个 LanguageRange使用给定 range和 weight 。

Locale​(String language)

从语言代码构建语言环境。

Locale​(String language, String country)

从语言和国家构建语言环境。

Locale​(String language, String country, String variant)

从语言，国家和变体构建语言环境。

MissingFormatArgumentException​(String s)

使用不匹配的格式说明符构造此类的实例。

MissingFormatWidthException​(String s)

使用指定的格式说明符构造此类的实例。

MissingResourceException​(String s, String className, String key)

构造具有指定信息的MissingResourceException。

NoSuchElementException​(String s)

构造一个 NoSuchElementException ，保存对错误消息字符串 s的引用，以供以后通过 getMessage方法检索。

PropertyPermission​(String name, String actions)

创建一个具有指定名称的新PropertyPermission对象。

Scanner​(File source, String charsetName)

构造一个新的 Scanner ，产生从指定文件扫描的值。

Scanner​(InputStream source, String charsetName)

构造一个新的 Scanner ，产生从指定的输入流扫描的值。

Scanner​(String source)

构造一个新的 Scanner ，产生从指定字符串扫描的值。

Scanner​(ReadableByteChannel source, String charsetName)

构造新的 Scanner ，产生从指定通道扫描的值。

Scanner​(Path source, String charsetName)

构造一个新的 Scanner ，产生从指定文件扫描的值。

ServiceConfigurationError​(String msg)

使用指定的消息构造新的实例。

ServiceConfigurationError​(String msg, Throwable cause)

构造具有指定消息和原因的新实例。

SimpleTimeZone​(int rawOffset, String ID)

构造一个SimpleTimeZone，其给定的基准时区偏离GMT和时区ID，而没有夏令时。

SimpleTimeZone​(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime)

构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。

SimpleTimeZone​(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime, int dstSavings)

构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。

SimpleTimeZone​(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int startTimeMode, int endMonth, int endDay, int endDayOfWeek, int endTime, int endTimeMode, int dstSavings)

构造一个SimpleTimeZone，其给定的基准时区偏离GMT，时区ID以及开始和结束夏令时的规则。

StringTokenizer​(String str)

为指定的字符串构造一个字符串tokenizer。

StringTokenizer​(String str, String delim)

为指定的字符串构造一个字符串tokenizer。

StringTokenizer​(String str, String delim, boolean returnDelims)

为指定的字符串构造一个字符串tokenizer。

Timer​(String name)

创建一个新的定时器，其相关线程具有指定的名称。

Timer​(String name, boolean isDaemon)

创建一个新的定时器，其相关线程具有指定的名称，可以指定为 run as a daemon 。

TooManyListenersException​(String s)

构造具有指定详细消息的TooManyListenersException。

UnknownFormatConversionException​(String s)

构造具有未知转换的此类的实例。

UnknownFormatFlagsException​(String f)

使用指定的标志构造此类的实例。

Uses of String in java.util.concurrent

Methods in java.util.concurrent that return String

Modifier and Type

方法

描述

String

ArrayBlockingQueue.toString​()

String

CompletableFuture.toString​()

返回一个标识此CompletableFuture的字符串及其完成状态。

String

ConcurrentHashMap.toString​()

返回此地图的字符串表示形式。

String

ConcurrentLinkedDeque.toString​()

String

ConcurrentLinkedQueue.toString​()

String

CopyOnWriteArrayList.toString​()

返回此列表的字符串表示形式。

String

CountDownLatch.toString​()

返回一个标识此锁存器的字符串及其状态。

String

ForkJoinPool.toString​()

返回一个标识此池的字符串，以及它的状态，包括运行状态，并行级和工作和任务计数的指示。

String

LinkedBlockingDeque.toString​()

String

LinkedBlockingQueue.toString​()

String

LinkedTransferQueue.toString​()

String

Phaser.toString​()

返回一个标识此移相器的字符串及其状态。

String

PriorityBlockingQueue.toString​()

String

Semaphore.toString​()

返回一个标识此信号量的字符串及其状态。

String

SynchronousQueue.toString​()

始终返回 "[]" 。

String

ThreadPoolExecutor.toString​()

返回标识此池的字符串及其状态，包括运行状态和估计的工作人员和任务计数的指示。

Methods in java.util.concurrent with parameters of type String

Modifier and Type

方法

描述

static TimeUnit

TimeUnit.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in java.util.concurrent with parameters of type String

Constructor

描述

BrokenBarrierException​(String message)

构造具有指定详细消息的 BrokenBarrierException 。

CancellationException​(String message)

构造具有指定详细消息的 CancellationException 。

CompletionException​(String message)

构造具有指定详细消息的 CompletionException 。

CompletionException​(String message, Throwable cause)

构造具有指定的详细消息和原因的 CompletionException 。

ExecutionException​(String message)

构造具有指定详细消息的 ExecutionException 。

ExecutionException​(String message, Throwable cause)

构造一个具有指定的详细消息和原因的 ExecutionException 。

RejectedExecutionException​(String message)

构造具有指定详细消息的 RejectedExecutionException 。

RejectedExecutionException​(String message, Throwable cause)

构造一个 RejectedExecutionException与指定的详细信息和原因。

TimeoutException​(String message)

构造具有指定详细消息的 TimeoutException 。

Uses of String in java.util.concurrent.atomic

Methods in java.util.concurrent.atomic that return String

Modifier and Type

方法

描述

String

AtomicBoolean.toString​()

返回当前值的String表示形式。

String

AtomicInteger.toString​()

返回当前值的String表示形式。

String

AtomicIntegerArray.toString​()

返回数组的当前值的String表示形式。

String

AtomicLong.toString​()

返回当前值的String表示形式。

String

AtomicLongArray.toString​()

返回数组的当前值的String表示形式。

String

AtomicReference.toString​()

返回当前值的String表示形式。

String

AtomicReferenceArray.toString​()

返回数组的当前值的String表示形式。

String

DoubleAccumulator.toString​()

返回当前值的String表示形式。

String

DoubleAdder.toString​()

返回 DoubleAdder.sum()的String表示 形式 。

String

LongAccumulator.toString​()

返回当前值的String表示形式。

String

LongAdder.toString​()

返回 LongAdder.sum()的String表示 形式 。

Methods in java.util.concurrent.atomic with parameters of type String

Modifier and Type

方法

描述

static <U> AtomicIntegerFieldUpdater<U>

AtomicIntegerFieldUpdater.newUpdater​(Class<U> tclass, String fieldName)

创建并返回具有给定字段的对象的更新程序。

static <U> AtomicLongFieldUpdater<U>

AtomicLongFieldUpdater.newUpdater​(Class<U> tclass, String fieldName)

创建并返回具有给定字段的对象的更新程序。

static <U,W> AtomicReferenceFieldUpdater<U,W>

AtomicReferenceFieldUpdater.newUpdater​(Class<U> tclass, Class<W> vclass, String fieldName)

创建并返回具有给定字段的对象的更新程序。

Uses of String in java.util.concurrent.locks

Methods in java.util.concurrent.locks that return String

Modifier and Type

方法

描述

String

AbstractQueuedLongSynchronizer.toString​()

返回一个标识此同步器的字符串及其状态。

String

AbstractQueuedSynchronizer.toString​()

返回一个标识此同步器的字符串及其状态。

String

ReentrantLock.toString​()

返回一个标识此锁的字符串以及其锁定状态。

String

ReentrantReadWriteLock.ReadLock.toString​()

返回一个标识此锁的字符串以及其锁定状态。

String

ReentrantReadWriteLock.toString​()

返回一个标识此锁的字符串以及其锁定状态。

String

ReentrantReadWriteLock.WriteLock.toString​()

返回一个标识此锁的字符串以及其锁定状态。

String

StampedLock.toString​()

返回一个标识此锁的字符串以及其锁定状态。

Uses of String in java.util.jar

Fields in java.util.jar declared as String

Modifier and Type

Field

描述

static String

Pack200.Packer.CLASS_ATTRIBUTE_PFX

当与类属性名称连接时，使用JSR 200规范中指定的布局语言来指示该属性的格式。

static String

Pack200.Packer.CODE_ATTRIBUTE_PFX

当与代码属性名称连接时，表示该属性的格式。

static String

Pack200.Packer.DEFLATE_HINT

如果此属性设置为 Pack200.Packer.TRUE或 Pack200.Packer.FALSE ，则 打包程序将在输出归档中相应设置通关提示，并且不会传送归档元素的各个通知提示。

static String

Pack200.Unpacker.DEFLATE_HINT

表明解包器应忽略DEFLATE_HINT的所有传输值，替换它们给定值 Pack200.Unpacker.TRUE或 Pack200.Unpacker.FALSE 。

static String

Pack200.Packer.EFFORT

如果此属性设置为单个十进制数字，打包程序将使用指定的压缩压缩数据量。

static String

Pack200.Packer.ERROR

字符串“error”是某些属性的可能值。

static String

Pack200.Packer.FALSE

字符串“false”是某些属性的可能值。

static String

Pack200.Unpacker.FALSE

字符串“false”是某些属性的可能值。

static String

Pack200.Packer.FIELD_ATTRIBUTE_PFX

当与字段属性名称连接时，表示该属性的格式。

static String

Pack200.Packer.KEEP

字符串“keep”是某些属性的可能值。

static String

Pack200.Unpacker.KEEP

字符串“keep”是某些属性的可能值。

static String

Pack200.Packer.KEEP_FILE_ORDER

如果此属性设置为 Pack200.Packer.TRUE ，则 打包程序将以源原始文件中的原始顺序传输所有元素。

static String

Pack200.Packer.LATEST

字符串“最新”，某些属性的可能值。

static String

JarFile.MANIFEST_NAME

JAR清单文件名。

static String

Pack200.Packer.METHOD_ATTRIBUTE_PFX

当与方法属性名称连接时，表示该属性的格式。

static String

Pack200.Packer.MODIFICATION_TIME

如果此属性设置为特殊字符串 Pack200.Packer.LATEST ， 打包程序将尝试确定最初修改时间，原始存档中的所有可用条目或每个段中所有可用条目的最新修改时间。

static String

Pack200.Packer.PASS

字符串“pass”是某些属性的可能值。

static String

Pack200.Packer.PASS_FILE_PFX

表示一个文件应该被传递通过，没有压缩。

static String

Pack200.Packer.PROGRESS

封隔器的进度为百分比，由封隔器定期更新。

static String

Pack200.Unpacker.PROGRESS

解包器的进度占百分比，由打包机定期更新。

static String

Pack200.Packer.SEGMENT_LIMIT

该属性是给出每个归档段的估计目标大小N（以字节为单位）的数字。

static String

Pack200.Packer.STRIP

字符串“strip”，某些属性的可能值。

static String

Pack200.Packer.TRUE

字符串“true”是某些属性的可能值。

static String

Pack200.Unpacker.TRUE

字符串“true”是某些属性的可能值。

static String

Pack200.Packer.UNKNOWN_ATTRIBUTE

指示遇到包含未知属性的类文件时要执行的操作。

Methods in java.util.jar that return String

Modifier and Type

方法

描述

String

Attributes.getValue​(String name)

返回指定为字符串的指定属性名称的值，如果未找到该属性，则返回null。

String

Attributes.getValue​(Attributes.Name name)

返回指定的Attributes.Name的值，如果未找到该属性，则返回null。

String

Attributes.putValue​(String name, String value)

将指定的值与指定的属性名称相关联，指定为String。

String

Attributes.Name.toString​()

返回属性名称作为字符串。

Methods in java.util.jar that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,Attributes>

Manifest.getEntries​()

返回此清单中包含的条目的地图。

SortedMap<String,String>

Pack200.Packer.properties​()

获取此引擎的属性集。

SortedMap<String,String>

Pack200.Packer.properties​()

获取此引擎的属性集。

SortedMap<String,String>

Pack200.Unpacker.properties​()

获取此引擎的属性集。

SortedMap<String,String>

Pack200.Unpacker.properties​()

获取此引擎的属性集。

Methods in java.util.jar with parameters of type String

Modifier and Type

方法

描述

protected ZipEntry

JarInputStream.createZipEntry​(String name)

为指定的JAR文件条目名称创建一个新的 JarEntry （ ZipEntry ）。

Attributes

Manifest.getAttributes​(String name)

返回指定条目名称的属性。

ZipEntry

JarFile.getEntry​(String name)

如果 ZipEntry ，则返回给定基本条目名称的 null或 null 。

JarEntry

JarFile.getJarEntry​(String name)

如果 JarEntry ，则返回给定基本条目名称的 null或 null 。

String

Attributes.getValue​(String name)

返回指定为字符串的指定属性名称的值，如果未找到该属性，则返回null。

String

Attributes.putValue​(String name, String value)

将指定的值与指定的属性名称相关联，指定为String。

Constructors in java.util.jar with parameters of type String

Constructor

描述

JarEntry​(String name)

为指定的JAR文件条目名称创建一个新的 JarEntry 。

JarException​(String s)

构造具有指定详细消息的JarException。

JarFile​(String name)

创建一个新的 JarFile从指定的文件 name 。

JarFile​(String name, boolean verify)

创建一个新的 JarFile从指定的文件 name 。

Name​(String name)

使用给定的字符串名称构造一个新的属性名称。

Uses of String in java.util.logging

Fields in java.util.logging declared as String

Modifier and Type

Field

描述

static String

Logger.GLOBAL_LOGGER_NAME

GLOBAL_LOGGER_NAME是全球记录器的名称。

static String

LogManager.LOGGING_MXBEAN_NAME

ObjectName用于日志记录工具的管理界面的字符串表示。

Methods in java.util.logging that return String

Modifier and Type

方法

描述

abstract String

Formatter.format​(LogRecord record)

格式化给定的日志记录并返回格式化的字符串。

String

SimpleFormatter.format​(LogRecord record)

格式化给定的LogRecord。

String

XMLFormatter.format​(LogRecord record)

将给定的消息格式化为XML。

String

Formatter.formatMessage​(LogRecord record)

从日志记录本地化和格式化消息字符串。

String

Handler.getEncoding​()

返回这个 Handler的字符编码。

String

Formatter.getHead​(Handler h)

返回一组格式化记录的标题字符串。

String

XMLFormatter.getHead​(Handler h)

返回一组XML格式记录的标题字符串。

String

Level.getLocalizedName​()

返回当前默认语言环境的Level的本地化字符串名称。

String

LoggingMXBean.getLoggerLevel​(String loggerName)

已过时。

获取与指定记录器关联的日志级别的名称。

String

LogRecord.getLoggerName​()

获取源记录器的名称。

String

LogRecord.getMessage​()

在本地化或格式化之前获取“原始”日志消息。

String

Level.getName​()

返回Level的非本地化字符串名称。

String

Logger.getName​()

获取此记录器的名称。

String

LoggingMXBean.getParentLoggerName​(String loggerName)

已过时。

返回指定记录器的父级名称。

String

LogManager.getProperty​(String name)

获取日志记录属性的值。

String

Level.getResourceBundleName​()

返回级别的本地化资源包名称，如果未定义本地化包，则返回null。

String

Logger.getResourceBundleName​()

检索此记录器的本地化资源包名称。

String

LogRecord.getResourceBundleName​()

获取本地化资源包名称

String

LogRecord.getSourceClassName​()

获取（据称）发出日志记录请求的类的名称。

String

LogRecord.getSourceMethodName​()

获取（据称）发出日志记录请求的方法的名称。

String

Formatter.getTail​(Handler h)

返回一组格式化记录的尾部字符串。

String

XMLFormatter.getTail​(Handler h)

返回一组XML格式记录的尾字符串。

String

Level.toString​()

返回此级别的字符串表示形式。

Methods in java.util.logging that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

LoggingMXBean.getLoggerNames​()

已过时。

返回当前注册的记录器名称的列表。

Enumeration<String>

LogManager.getLoggerNames​()

获取已知记录器名称的枚举。

Methods in java.util.logging with parameters of type String

Modifier and Type

方法

描述

void

Logger.config​(String msg)

记录CONFIG消息。

void

Logger.entering​(String sourceClass, String sourceMethod)

记录方法条目。

void

Logger.entering​(String sourceClass, String sourceMethod, Object param1)

使用一个参数记录方法条目。

void

Logger.entering​(String sourceClass, String sourceMethod, Object[] params)

使用参数数组记录方法条目。

void

ErrorManager.error​(String msg, 异常 ex, int code)

发生处理程序失败时调用错误方法。

void

Logger.exiting​(String sourceClass, String sourceMethod)

记录方法返回。

void

Logger.exiting​(String sourceClass, String sourceMethod, Object result)

使用结果对象记录方法返回。

void

Logger.fine​(String msg)

记录一个FINE消息。

void

Logger.finer​(String msg)

记录一个FINER消息。

void

Logger.finest​(String msg)

记录一条FINEST消息。

static Logger

Logger.getAnonymousLogger​(String resourceBundleName)

创建一个匿名记录器。

static Logger

Logger.getLogger​(String name)

查找或创建一个命名子系统的记录器。

static Logger

Logger.getLogger​(String name, String resourceBundleName)

查找或创建一个命名子系统的记录器。

Logger

LogManager.getLogger​(String name)

找到一个命名记录器的方法。

String

LoggingMXBean.getLoggerLevel​(String loggerName)

已过时。

获取与指定记录器关联的日志级别的名称。

String

LoggingMXBean.getParentLoggerName​(String loggerName)

已过时。

返回指定记录器的父级名称。

String

LogManager.getProperty​(String name)

获取日志记录属性的值。

void

Logger.info​(String msg)

记录INFO消息。

void

Logger.log​(Level level, String msg)

记录消息，没有参数。

void

Logger.log​(Level level, String msg, Object param1)

使用一个对象参数记录消息。

void

Logger.log​(Level level, String msg, Object[] params)

用一个对象参数数组记录消息。

void

Logger.log​(Level level, String msg, Throwable thrown)

使用相关联的Throwable信息记录消息。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg)

记录消息，指定源类和方法，没有参数。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Object param1)

使用单个对象参数记录消息，指定源类和方法到日志消息。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)

使用对象参数数组记录消息，指定源类和方法。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown)

使用相关联的Throwable信息记录消息，指定源类和方法。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, Throwable thrown, Supplier<String> msgSupplier)

记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, Supplier<String> msgSupplier)

记录一个延迟构造的消息，指定源类和方法，没有参数。

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg)

已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)

已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...)

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)

已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) 。

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown)

已过时。
改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Object... params)

使用可选的消息参数列表记录消息，指定源类，方法和资源包。

void

Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Throwable thrown)

使用相关联的Throwable信息记录消息，指定源类，方法和资源包。

void

Logger.logrb​(Level level, ResourceBundle bundle, String msg, Object... params)

使用可选的消息参数列表记录消息，指定源类，方法和资源包。

void

Logger.logrb​(Level level, ResourceBundle bundle, String msg, Throwable thrown)

使用相关联的Throwable信息记录消息，指定源类，方法和资源包。

static Level

Level.parse​(String name)

将级别名称字符串解析为级别。

protected void

Handler.reportError​(String msg, 异常 ex, int code)

受保护的方便方法来向此处理程序的ErrorManager报告错误。

void

Handler.setEncoding​(String encoding)

设置此 Handler使用的字符编码。

void

StreamHandler.setEncoding​(String encoding)

设置（或更改）此 Handler使用的字符编码。

void

LoggingMXBean.setLoggerLevel​(String loggerName, String levelName)

已过时。

将指定的记录器设置为指定的新级别。

void

LogRecord.setLoggerName​(String name)

设置源记录器的名称。

void

LogRecord.setMessage​(String message)

在本地化或格式化之前设置“原始”日志消息。

void

LogRecord.setResourceBundleName​(String name)

设置本地化资源包名称。

void

LogRecord.setSourceClassName​(String sourceClassName)

设置（据称）发出日志记录请求的类的名称。

void

LogRecord.setSourceMethodName​(String sourceMethodName)

设置（据称）发出日志记录请求的方法的名称。

void

Logger.severe​(String msg)

记录一个SEVERE消息。

void

Logger.throwing​(String sourceClass, String sourceMethod, Throwable thrown)

日志抛出异常。

void

Logger.warning​(String msg)

记录警告消息。

Method parameters in java.util.logging with type arguments of type String

Modifier and Type

方法

描述

void

Logger.config​(Supplier<String> msgSupplier)

记录一个CONFIG消息，只有在记录级别实际上记录该消息时，才能构建一个CONFIG消息。

void

Logger.fine​(Supplier<String> msgSupplier)

记录一个FINE消息，只有在记录级别实际上记录该消息时才会被构造。

void

Logger.finer​(Supplier<String> msgSupplier)

记录一个FINER消息，只有在记录级别实际上记录该消息时，才会构建一个FINER消息。

void

Logger.finest​(Supplier<String> msgSupplier)

记录一个FINEST消息，只有当记录级别实际上记录消息时，才能构建FINEST消息。

void

Logger.info​(Supplier<String> msgSupplier)

记录INFO消息，只有在记录级别实际记录消息时，才能构建INFO消息。

void

Logger.log​(Level level, Throwable thrown, Supplier<String> msgSupplier)

记录一个懒惰构造的消息，并附带相关的Throwable信息。

void

Logger.log​(Level level, Supplier<String> msgSupplier)

记录一条消息，只有在日志记录级别实际上记录该消息时才会被构造。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, Throwable thrown, Supplier<String> msgSupplier)

记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。

void

Logger.logp​(Level level, String sourceClass, String sourceMethod, Supplier<String> msgSupplier)

记录一个延迟构造的消息，指定源类和方法，没有参数。

void

Logger.severe​(Supplier<String> msgSupplier)

记录一个SEVERE消息，只有当记录级别实际上记录该消息时，才会构建一个SEVERE消息。

void

LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

LogManager.updateConfiguration​(InputStream ins, Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

LogManager.updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

LogManager.updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

LogManager.updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

LogManager.updateConfiguration​(Function<String,BiFunction<String,String,String>> mapper)

更新日志记录配置。

void

Logger.warning​(Supplier<String> msgSupplier)

记录一条警告消息，只有当记录级别实际上记录消息时，才能构建一条警告消息。

Constructors in java.util.logging with parameters of type String

Constructor

描述

FileHandler​(String pattern)

初始化 FileHandler以写入给定的文件名。

FileHandler​(String pattern, boolean append)

初始化一个 FileHandler写入给定的文件名，可选附加。

FileHandler​(String pattern, int limit, int count)

初始化 FileHandler以写入一组文件。

FileHandler​(String pattern, int limit, int count, boolean append)

初始化一个 FileHandler以写入一组可选的附加文件。

FileHandler​(String pattern, long limit, int count, boolean append)

初始化一个 FileHandler写入一组可选附加的文件。

Level​(String name, int value)

创建一个具有给定整数值的命名级别。

Level​(String name, int value, String resourceBundleName)

创建一个具有给定整数值和给定的本地化资源名称的命名级别。

Logger​(String name, String resourceBundleName)

构建命名子系统的记录器的受保护方法。

LoggingPermission​(String name, String actions)

创建一个新的LoggingPermission对象。

LogRecord​(Level level, String msg)

使用给定的级别和消息值构造LogRecord。

SocketHandler​(String host, int port)

使用指定的主机和端口构造 SocketHandler 。

Uses of String in java.util.prefs

Methods in java.util.prefs that return String

Modifier and Type

方法

描述

String

AbstractPreferences.absolutePath​()

实现 absolutePath方法按照在本说明书中 Preferences.absolutePath() 。

abstract String

Preferences.absolutePath​()

返回此首选项节点的绝对路径名。

String[]

AbstractPreferences.childrenNames​()

实现 children方法按照在本说明书中 Preferences.childrenNames() 。

abstract String[]

Preferences.childrenNames​()

返回此首选项节点的子节点相对于此节点的名称。

protected abstract String[]

AbstractPreferences.childrenNamesSpi​()

返回此首选项节点的子节点的名称。

String

AbstractPreferences.get​(String key, String def)

实现 get方法按照在本说明书中 Preferences.get(String,String) 。

abstract String

Preferences.get​(String key, String def)

返回与此首选项节点中指定键相关联的值。

String

PreferenceChangeEvent.getKey​()

返回更改的首选项的键。

String

PreferenceChangeEvent.getNewValue​()

返回首选项的新值。

protected abstract String

AbstractPreferences.getSpi​(String key)

如果此键不存在关联，则返回与此首选项节点处的指定键相关联的值，或 null ，否则此时无法确定关联。

String[]

AbstractPreferences.keys​()

实现 keys方法按照在本说明书中 Preferences.keys() 。

abstract String[]

Preferences.keys​()

返回在此首选项节点中具有关联值的所有键。

protected abstract String[]

AbstractPreferences.keysSpi​()

返回在此首选项节点中具有关联值的所有键。

String

AbstractPreferences.name​()

实现 name方法按照在本说明书中 Preferences.name() 。

abstract String

Preferences.name​()

返回此首选项节点的名称，相对于其父项。

String

AbstractPreferences.toString​()

返回此首选项节点的绝对路径名。

abstract String

Preferences.toString​()

返回此首选项节点的字符串表示形式，如同由以下表达式计算： (this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 。

Methods in java.util.prefs with parameters of type String

Modifier and Type

方法

描述

protected abstract AbstractPreferences

AbstractPreferences.childSpi​(String name)

返回此首选项节点的命名子节点，如果它不存在则创建它。

String

AbstractPreferences.get​(String key, String def)

实现 get方法按照在本说明书中 Preferences.get(String,String) 。

abstract String

Preferences.get​(String key, String def)

返回与此首选项节点中指定键相关联的值。

boolean

AbstractPreferences.getBoolean​(String key, boolean def)

实现 getBoolean方法按照在本说明书中 Preferences.getBoolean(String,boolean) 。

abstract boolean

Preferences.getBoolean​(String key, boolean def)

返回由此首选项节点中与指定键相关联的字符串表示的布尔值。

byte[]

AbstractPreferences.getByteArray​(String key, byte[] def)

实现 getByteArray方法按照在本说明书中 Preferences.getByteArray(String,byte[]) 。

abstract byte[]

Preferences.getByteArray​(String key, byte[] def)

返回由此首选项节点中与指定键相关联的字符串表示的字节数组值。

protected AbstractPreferences

AbstractPreferences.getChild​(String nodeName)

如果没有，返回命名的子项，如果不存在，则返回 null 。

double

AbstractPreferences.getDouble​(String key, double def)

实现 getDouble方法按照在本说明书中 Preferences.getDouble(String,double) 。

abstract double

Preferences.getDouble​(String key, double def)

返回由此首选项节点中与指定键相关联的字符串表示的双精度值。

float

AbstractPreferences.getFloat​(String key, float def)

实现 getFloat方法按照在本说明书中 Preferences.getFloat(String,float) 。

abstract float

Preferences.getFloat​(String key, float def)

返回由此首选项节点中与指定键相关联的字符串表示的浮点值。

int

AbstractPreferences.getInt​(String key, int def)

实现 getInt方法按照在本说明书中 Preferences.getInt(String,int) 。

abstract int

Preferences.getInt​(String key, int def)

返回由此首选项节点中与指定键相关联的字符串表示的int值。

long

AbstractPreferences.getLong​(String key, long def)

实现 getLong方法按照在本说明书中 Preferences.getLong(String,long) 。

abstract long

Preferences.getLong​(String key, long def)

返回由此首选项节点中与指定键相关联的字符串表示的长整型值。

protected abstract String

AbstractPreferences.getSpi​(String key)

返回与此首选项节点上的指定键或相关联的值 null如果没有关联此键，或不能在这个时间来确定所述关联。

Preferences

AbstractPreferences.node​(String path)

实现 node方法按照在本说明书中 Preferences.node(String) 。

abstract Preferences

Preferences.node​(String pathName)

返回与该节点相同树中的命名偏好节点，创建它及其任何祖先（如果它们不存在）。

boolean

AbstractPreferences.nodeExists​(String path)

实现 nodeExists方法按照在本说明书中 Preferences.nodeExists(String) 。

abstract boolean

Preferences.nodeExists​(String pathName)

如果指定的首选节点存在于与该节点相同的树中，则返回true。

void

AbstractPreferences.put​(String key, String value)

实现 put方法按照在本说明书中 Preferences.put(String,String) 。

abstract void

Preferences.put​(String key, String value)

将指定的值与此首选项节点中的指定键相关联。

void

AbstractPreferences.putBoolean​(String key, boolean value)

实现 putBoolean方法按照在本说明书中 Preferences.putBoolean(String,boolean) 。

abstract void

Preferences.putBoolean​(String key, boolean value)

将表示指定布尔值的字符串与此首选项节点中指定的键相关联。

void

AbstractPreferences.putByteArray​(String key, byte[] value)

实现 putByteArray方法按照在本说明书中 Preferences.putByteArray(String,byte[]) 。

abstract void

Preferences.putByteArray​(String key, byte[] value)

将表示指定字节数组的字符串与此首选项节点中指定的键相关联。

void

AbstractPreferences.putDouble​(String key, double value)

实现 putDouble方法按照在本说明书中 Preferences.putDouble(String,double) 。

abstract void

Preferences.putDouble​(String key, double value)

将表示指定双重值的字符串与此首选项节点中指定的键相关联。

void

AbstractPreferences.putFloat​(String key, float value)

实现 putFloat方法按照在本说明书中 Preferences.putFloat(String,float) 。

abstract void

Preferences.putFloat​(String key, float value)

将表示指定浮点值的字符串与此首选项节点中指定的键相关联。

void

AbstractPreferences.putInt​(String key, int value)

实现 putInt方法按照在本说明书中 Preferences.putInt(String,int) 。

abstract void

Preferences.putInt​(String key, int value)

将表示指定int值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putLong​(String key, long value)

实现 putLong方法按照在本说明书中 Preferences.putLong(String,long) 。

abstract void

Preferences.putLong​(String key, long value)

将表示指定长值的字符串与此首选项节点中指定的键相关联。

protected abstract void

AbstractPreferences.putSpi​(String key, String value)

将给定的键值关联放入此首选项节点。

void

AbstractPreferences.remove​(String key)

实现 remove(String)方法按照在本说明书中 Preferences.remove(String) 。

abstract void

Preferences.remove​(String key)

删除与此首选项节点中指定键相关联的值（如果有）。

protected abstract void

AbstractPreferences.removeSpi​(String key)

删除此首选项节点上指定键的关联（如果有）。

Constructors in java.util.prefs with parameters of type String

Constructor

描述

AbstractPreferences​(AbstractPreferences parent, String name)

创建具有指定父项和相对于其父对象的指定名称的首选项节点。

BackingStoreException​(String s)

构造具有指定详细消息的BackingStoreException。

InvalidPreferencesFormatException​(String message)

使用指定的详细消息构造InvalidPreferencesFormatException。

InvalidPreferencesFormatException​(String message, Throwable cause)

构造一个InvalidPreferencesFormatException与指定的详细信息和原因。

PreferenceChangeEvent​(Preferences node, String key, String newValue)

构造一个新的 PreferenceChangeEvent实例。

Uses of String in java.util.regex

Methods in java.util.regex that return String

Modifier and Type

方法

描述

String

PatternSyntaxException.getDescription​()

检索错误的描述。

String

PatternSyntaxException.getMessage​()

返回一个多行字符串，其中包含语法错误及其索引的描述，错误的正则表达式模式以及模式中错误索引的可视指示。

String

PatternSyntaxException.getPattern​()

检索错误的正则表达式模式。

String

Matcher.group​()

返回与上一个匹配匹配的输入子序列。

String

Matcher.group​(int group)

返回在上一次匹配操作期间由给定组捕获的输入子序列。

String

Matcher.group​(String name)

返回在上一次匹配操作期间由给定的 named-capturing group捕获的输入子序列。

String

MatchResult.group​()

返回与上一个匹配匹配的输入子序列。

String

MatchResult.group​(int group)

返回在上一次匹配操作期间由给定组捕获的输入子序列。

String

Pattern.pattern​()

返回编译此模式的正则表达式。

static String

Pattern.quote​(String s)

返回面值模式 String指定的 String 。

static String

Matcher.quoteReplacement​(String s)

返回面值替换 String指定的 String 。

String

Matcher.replaceAll​(String replacement)

将与模式匹配的输入序列的每个子序列替换为给定的替换字符串。

String

Matcher.replaceAll​(Function<MatchResult,String> replacer)

将与模式匹配的输入序列的每个子序列替换为将给定的替换器函数应用于与该子序列相对应的匹配器的匹配结果的结果。

String

Matcher.replaceFirst​(String replacement)

将与模式匹配的输入序列的第一个子序列替换为给定的替换字符串。

String

Matcher.replaceFirst​(Function<MatchResult,String> replacer)

将与模式匹配的输入序列的第一个子序列替换为将给定的替换器函数应用于与该子序列对应的匹配器的匹配结果的结果。

String[]

Pattern.split​(CharSequence input)

将给定的输入序列分成这个模式的匹配。

String[]

Pattern.split​(CharSequence input, int limit)

将给定的输入序列分成这个模式的匹配。

String

Matcher.toString​()

返回此匹配器的字符串表示形式。

String

Pattern.toString​()

返回此模式的字符串表示形式。

Methods in java.util.regex that return types with arguments of type String

Modifier and Type

方法

描述

Predicate<String>

Pattern.asPredicate​()

创建可用于匹配字符串的谓词。

Stream<String>

Pattern.splitAsStream​(CharSequence input)

根据给定的输入序列创建一个流，该流与该模式匹配。

Methods in java.util.regex with parameters of type String

Modifier and Type

方法

描述

Matcher

Matcher.appendReplacement​(StringBuffer sb, String replacement)

实施非终端附加和替换步骤。

Matcher

Matcher.appendReplacement​(StringBuilder sb, String replacement)

实施非终端附加和替换步骤。

static Pattern

Pattern.compile​(String regex)

将给定的正则表达式编译为模式。

static Pattern

Pattern.compile​(String regex, int flags)

将给定的正则表达式编译为带有给定标志的模式。

int

Matcher.end​(String name)

返回在上一次匹配操作期间由给定的 named-capturing group捕获的子序列的最后一个字符之后的偏移量。

String

Matcher.group​(String name)

返回在上一次匹配操作期间由给定的 named-capturing group捕获的输入子序列。

static boolean

Pattern.matches​(String regex, CharSequence input)

编译给定的正则表达式，并尝试匹配给定的输入。

static String

Pattern.quote​(String s)

返回面值模式 String指定的 String 。

static String

Matcher.quoteReplacement​(String s)

返回面值替换 String指定的 String 。

String

Matcher.replaceAll​(String replacement)

将与模式匹配的输入序列的每个子序列替换为给定的替换字符串。

String

Matcher.replaceFirst​(String replacement)

将与模式匹配的输入序列的第一个子序列替换为给定的替换字符串。

int

Matcher.start​(String name)

返回在上一次匹配操作期间由给定的 named-capturing group捕获的子序列的开始索引。

Method parameters in java.util.regex with type arguments of type String

Modifier and Type

方法

描述

String

Matcher.replaceAll​(Function<MatchResult,String> replacer)

将与模式匹配的输入序列的每个子序列替换为将给定的替换器函数应用于与该子序列相对应的匹配器的匹配结果的结果。

String

Matcher.replaceFirst​(Function<MatchResult,String> replacer)

将与模式匹配的输入序列的第一个子序列替换为将给定的替换器函数应用于与该子序列对应的匹配器的匹配结果的结果。

Constructors in java.util.regex with parameters of type String

Constructor

描述

PatternSyntaxException​(String desc, String regex, int index)

构造一个这个类的新实例。

Uses of String in java.util.spi

Methods in java.util.spi that return String

Modifier and Type

方法

描述

abstract String

LocaleNameProvider.getDisplayCountry​(String countryCode, Locale locale)

返回给定的 IETF BCP47区域代码（ISO 3166国家代码或UN M.49区域代码）的本地化名称以及适合向用户显示的给定区域设置。

abstract String

LocaleNameProvider.getDisplayLanguage​(String languageCode, Locale locale)

返回给定的 IETF BCP47语言代码和适合显示给用户的给定语言环境的本地化名称。

abstract String

CalendarNameProvider.getDisplayName​(String calendarType, int field, int value, int style, Locale locale)

返回给定的 style和 locale中的日历 field value的字符串表示（显示名称）。

String

CurrencyNameProvider.getDisplayName​(String currencyCode, Locale locale)

返回适合显示给用户的货币名称。

abstract String

TimeZoneNameProvider.getDisplayName​(String ID, boolean daylight, int style, Locale locale)

返回适合在指定语言环境中向用户呈现的给定时区ID的名称。

String

LocaleNameProvider.getDisplayScript​(String scriptCode, Locale locale)

返回给定的 IETF BCP47脚本代码和适用于向用户显示的给定语言环境的本地化名称。

abstract String

LocaleNameProvider.getDisplayVariant​(String variant, Locale locale)

返回适用于向用户显示的给定变体代码和给定语言环境的本地化名称。

String

TimeZoneNameProvider.getGenericDisplayName​(String ID, int style, Locale locale)

返回指定时区 ID的通用名称，适用于在指定的 locale向用户 locale 。

abstract String

CurrencyNameProvider.getSymbol​(String currencyCode, Locale locale)

获取指定区域设置的给定货币代码的符号。

String

ToolProvider.name​()

返回此工具提供程序的名称。

protected String

AbstractResourceBundleProvider.toBundleName​(String baseName, Locale locale)

返回此提供程序提供的给定 baseName和 locale的软件包名称。

Methods in java.util.spi that return types with arguments of type String

Modifier and Type

方法

描述

abstract Map<String,Integer>

CalendarNameProvider.getDisplayNames​(String calendarType, int field, int style, Locale locale)

返回 Map包含的所有字符串表示（显示名称） Calendar field给定 style和 locale及其相应的字段值。

Methods in java.util.spi with parameters of type String

Modifier and Type

方法

描述

static Optional<ToolProvider>

ToolProvider.findFirst​(String name)

返回具有给定名称的ToolProvider的第一个实例，由使用系统类加载器的ServiceLoader加载。

ResourceBundle

AbstractResourceBundleProvider.getBundle​(String baseName, Locale locale)

返回 ResourceBundle为给定 baseName和 locale 。

ResourceBundle

ResourceBundleProvider.getBundle​(String baseName, Locale locale)

为给定的包名称和区域设置返回 ResourceBundle 。

ResourceBundle.Control

ResourceBundleControlProvider.getControl​(String baseName)

返回一个 ResourceBundle.Control实例，用于处理给定的 baseName资源束加载。

abstract String

LocaleNameProvider.getDisplayCountry​(String countryCode, Locale locale)

返回给定的 IETF BCP47区域代码（ISO 3166国家代码或UN M.49区域代码）的本地化名称以及适合向用户显示的给定语言环境。

abstract String

LocaleNameProvider.getDisplayLanguage​(String languageCode, Locale locale)

返回给定的 IETF BCP47语言代码和适用于向用户显示的给定语言环境的本地化名称。

abstract String

CalendarNameProvider.getDisplayName​(String calendarType, int field, int value, int style, Locale locale)

返回给定的 style和 locale中的日历 field value的字符串表示（显示名称）。

String

CurrencyNameProvider.getDisplayName​(String currencyCode, Locale locale)

返回适合显示给用户的货币名称。

abstract String

TimeZoneNameProvider.getDisplayName​(String ID, boolean daylight, int style, Locale locale)

返回适合在指定语言环境中向用户呈现的给定时区ID的名称。

abstract Map<String,Integer>

CalendarNameProvider.getDisplayNames​(String calendarType, int field, int style, Locale locale)

返回 Map包含的所有字符串表示（显示名称） Calendar field给定 style和 locale及其相应的字段值。

String

LocaleNameProvider.getDisplayScript​(String scriptCode, Locale locale)

返回给定的 IETF BCP47脚本代码和适用于向用户显示的给定语言环境的本地化名称。

abstract String

LocaleNameProvider.getDisplayVariant​(String variant, Locale locale)

返回适用于向用户显示的给定变体代码和给定语言环境的本地化名称。

String

TimeZoneNameProvider.getGenericDisplayName​(String ID, int style, Locale locale)

返回给定时区 ID的通用名称，适用于在指定的 locale向用户 locale 。

abstract String

CurrencyNameProvider.getSymbol​(String currencyCode, Locale locale)

获取指定区域设置的给定货币代码的符号。

default int

ToolProvider.run​(PrintStream out, PrintStream err, String... args)

运行该工具的实例，返回零以成功运行。

int

ToolProvider.run​(PrintWriter out, PrintWriter err, String... args)

运行该工具的实例，返回零以成功运行。

protected String

AbstractResourceBundleProvider.toBundleName​(String baseName, Locale locale)

返回此提供商提供的给定 baseName和 locale的包名称。

Constructors in java.util.spi with parameters of type String

Constructor

描述

AbstractResourceBundleProvider​(String... formats)

构造一个 AbstractResourceBundleProvider与指定的 formats 。

Uses of String in java.util.stream

Methods in java.util.stream that return types with arguments of type String

Modifier and Type

方法

描述

static Collector<CharSequence,?,String>

Collectors.joining​()

返回一个 Collector ，将输入元素连接到一个 String ，以遇到顺序。

static Collector<CharSequence,?,String>

Collectors.joining​(CharSequence delimiter)

返回一个 Collector ，按照遇到的顺序连接由指定的分隔符分隔的输入元素。

static Collector<CharSequence,?,String>

Collectors.joining​(CharSequence delimiter, CharSequence prefix, CharSequence suffix)

返回一个 Collector ，它将按指定的分隔符分隔的输入元素与指定的前缀和后缀进行连接。

Methods in java.util.stream with parameters of type String

Modifier and Type

方法

描述

static Collector.Characteristics

Collector.Characteristics.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in java.util.zip

Methods in java.util.zip that return String

Modifier and Type

方法

描述

String

ZipEntry.getComment​()

返回条目的注释字符串。

String

ZipFile.getComment​()

返回zip文件注释，否则返回null。

String

ZipEntry.getName​()

返回条目的名称。

String

ZipFile.getName​()

返回ZIP文件的路径名。

String

ZipEntry.toString​()

返回ZIP条目的字符串表示形式。

Methods in java.util.zip with parameters of type String

Modifier and Type

方法

描述

protected ZipEntry

ZipInputStream.createZipEntry​(String name)

为指定的条目名称创建一个新的 ZipEntry对象。

ZipEntry

ZipFile.getEntry​(String name)

返回指定名称的zip文件条目，如果找不到则返回null。

void

ZipEntry.setComment​(String comment)

设置条目的可选注释字符串。

void

ZipOutputStream.setComment​(String comment)

设置ZIP文件注释。

Constructors in java.util.zip with parameters of type String

Constructor

描述

DataFormatException​(String s)

构造具有指定详细消息的DataFormatException。

ZipEntry​(String name)

创建具有指定名称的新的zip条目。

ZipError​(String s)

使用给定的详细消息构造ZipError。

ZipException​(String s)

构造具有指定详细消息的 ZipException 。

ZipFile​(String name)

打开一个zip文件进行阅读。

ZipFile​(String name, Charset charset)

打开一个zip文件进行阅读。

Uses of String in javafx.animation

Methods in javafx.animation that return String

Modifier and Type

方法

描述

String

KeyFrame.getName​()

返回这个 name的 KeyFrame 。

String

KeyFrame.toString​()

返回此 KeyFrame对象的字符串表示形式。

String

KeyValue.toString​()

返回此 KeyValue对象的字符串表示形式。

Methods in javafx.animation that return types with arguments of type String

Modifier and Type

方法

描述

ObservableMap<String,Duration>

Animation.getCuePoints​()

提示点可用于标记 Animation重要位置。

Methods in javafx.animation with parameters of type String

Modifier and Type

方法

描述

void

Animation.jumpTo​(String cuePoint)

Animation这个 Animation的预定位置。

void

Animation.playFrom​(String cuePoint)

从预定位置播放 Animation方便方法。

static Animation.Status

Animation.Status.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PathTransition.OrientationType

PathTransition.OrientationType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.animation with parameters of type String

Constructor

描述

KeyFrame​(Duration time, String name, KeyValue... values)

构造函数 KeyFrame

KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, Collection<KeyValue> values)

构造函数 KeyFrame

KeyFrame​(Duration time, String name, EventHandler<ActionEvent> onFinished, KeyValue... values)

构造函数 KeyFrame

Uses of String in javafx.application

Fields in javafx.application declared as String

Modifier and Type

Field

描述

static String

Application.STYLESHEET_CASPIAN

用于“Caspian”主题的用户代理样式表的常量。

static String

Application.STYLESHEET_MODENA

用于“Modena”主题的用户代理样式表的常量。

Methods in javafx.application that return String

Modifier and Type

方法

描述

String

HostServices.getCodeBase​()

获取此应用程序的代码库URI。

String

Preloader.ErrorNotification.getDetails​()

检索错误的描述。

String

HostServices.getDocumentBase​()

获取此应用程序的文档基础URI。

String

Preloader.ErrorNotification.getLocation​()

检索与此错误相关联的URL（如果有）。

static String

Application.getUserAgentStylesheet​()

获取整个应用程序使用的用户代理样式表。

String

HostServices.resolveURI​(String base, String rel)

根据基本URI解析指定的相对URI并返回已解析的URI。

String

Preloader.ErrorNotification.toString​()

返回此 ErrorNotification对象的字符串表示形式。

Methods in javafx.application that return types with arguments of type String

Modifier and Type

方法

描述

abstract Map<String,String>

Application.Parameters.getNamed​()

检索命名参数的只读映射。

abstract Map<String,String>

Application.Parameters.getNamed​()

检索命名参数的只读映射。

abstract List<String>

Application.Parameters.getRaw​()

检索原始参数的只读列表。

abstract List<String>

Application.Parameters.getUnnamed​()

检索未命名参数的只读列表。

Methods in javafx.application with parameters of type String

Modifier and Type

方法

描述

static void

Application.launch​(Class<? extends Application> appClass, String... args)

启动独立应用程序。

static void

Application.launch​(String... args)

启动独立应用程序。

String

HostServices.resolveURI​(String base, String rel)

根据基本URI解析指定的相对URI并返回已解析的URI。

static void

Application.setUserAgentStylesheet​(String url)

设置整个应用程序使用的用户代理样式表。

void

HostServices.showDocument​(String uri)

在新的浏览器窗口或选项卡中打开指定的URI。

static ConditionalFeature

ConditionalFeature.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Preloader.StateChangeNotification.Type

Preloader.StateChangeNotification.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.application with parameters of type String

Constructor

描述

ErrorNotification​(String location, String details, Throwable cause)

构造错误通知。

Uses of String in javafx.beans.binding

Methods in javafx.beans.binding that return String

Modifier and Type

方法

描述

protected abstract String

StringBinding.computeValue​()

计算此绑定的当前值。

String

StringBinding.get​()

返回 StringBinding.computeValue()的结果。

String

StringExpression.getValue​()

String

StringExpression.getValueSafe​()

通常返回此值 StringExpression 。

String

BooleanBinding.toString​()

返回此 BooleanBinding对象的字符串表示形式。

String

DoubleBinding.toString​()

返回此 DoubleBinding对象的字符串表示形式。

String

FloatBinding.toString​()

返回此 FloatBinding对象的字符串表示形式。

String

IntegerBinding.toString​()

返回此 IntegerBinding对象的字符串表示形式。

String

ListBinding.toString​()

返回此 ListBinding对象的字符串表示形式。

String

LongBinding.toString​()

返回此 LongBinding对象的字符串表示形式。

String

MapBinding.toString​()

返回此 MapBinding对象的字符串表示形式。

String

ObjectBinding.toString​()

返回此 ObjectBinding对象的字符串表示形式。

String

SetBinding.toString​()

返回此 SetBinding对象的字符串表示形式。

String

StringBinding.toString​()

返回此 StringBinding对象的字符串表示形式。

Methods in javafx.beans.binding with parameters of type String

Modifier and Type

方法

描述

StringBinding

NumberExpression.asString​(String format)

创建一个StringBinding持有的价值NumberExpression变成了String 。

StringBinding

NumberExpression.asString​(Locale locale, String format)

创建一个StringBinding持有的价值NumberExpression变成了String 。

StringBinding

NumberExpressionBase.asString​(String format)

StringBinding

NumberExpressionBase.asString​(Locale locale, String format)

StringBinding

ObjectExpression.asString​(String format)

创建一个StringBinding持有的价值ObjectExpression变成了String 。

StringBinding

ObjectExpression.asString​(Locale locale, String format)

创建一个StringBinding持有的价值NumberExpression变成了String 。

static BooleanBinding

Bindings.equal​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。

static BooleanBinding

Bindings.equal​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于一个恒定值，则保留true 。

static BooleanBinding

Bindings.equalIgnoreCase​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding ，如果一个ObservableStringValue的值等于恒定值忽略大小 ，则保留true 。

static BooleanBinding

Bindings.equalIgnoreCase​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding保持true如果a的值ObservableStringValue等于恒定值忽略大小写。

static StringExpression

Bindings.format​(String format, Object... args)

创建StringExpression保持多个值Objects根据格式格式化String 。

static StringExpression

Bindings.format​(Locale locale, String format, Object... args)

创建StringExpression保持多个值Objects根据格式格式化String和指定Locale

static BooleanBinding

Bindings.greaterThan​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding持有true如果一个恒定值的值比的值越大ObservableStringValue 。

static BooleanBinding

Bindings.greaterThan​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue比恒定值。

BooleanBinding

StringExpression.greaterThan​(String other)

创建一个新的BooleanBinding ，如果这个StringExpression大于恒定值，则保留true 。

static BooleanBinding

Bindings.greaterThanOrEqual​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding保持true如果恒定值是大于或等于一的值ObservableStringValue 。

static BooleanBinding

Bindings.greaterThanOrEqual​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding保持true如果a的值ObservableStringValue大于或等于恒定值。

BooleanBinding

StringExpression.greaterThanOrEqualTo​(String other)

创建一个新的BooleanBinding ，如果该StringExpression大于或等于常数值，则保留true 。

BooleanBinding

StringExpression.isEqualTo​(String other)

创建一个新的BooleanBinding ，如果这个StringExpression等于一个恒定值，则保留true 。

BooleanBinding

StringExpression.isEqualToIgnoreCase​(String other)

创建一个新的BooleanBinding ，其持有true如果这个StringExpression等于恒定值忽略大小写。

BooleanBinding

StringExpression.isNotEqualTo​(String other)

创建一个新的BooleanBinding ，如果这个StringExpression不等于一个恒定值，则保留true 。

BooleanBinding

StringExpression.isNotEqualToIgnoreCase​(String other)

创建一个新的BooleanBinding ，如果这个StringExpression不等于恒定值忽略大小写，则保留true 。

static BooleanBinding

Bindings.lessThan​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding持有true如果一个恒定值小于一的值ObservableStringValue 。

static BooleanBinding

Bindings.lessThan​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding持有true如果一个值ObservableStringValue小于一个恒定值。

BooleanBinding

StringExpression.lessThan​(String other)

创建一个新的BooleanBinding ，如果这个StringExpression小于一个恒定值，则保留true 。

static BooleanBinding

Bindings.lessThanOrEqual​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding保持true如果恒定值是小于或等于一的值ObservableStringValue 。

static BooleanBinding

Bindings.lessThanOrEqual​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding保持true如果a的值ObservableStringValue小于或等于恒定值。

BooleanBinding

StringExpression.lessThanOrEqualTo​(String other)

创建一个新的BooleanBinding ，如果该StringExpression小于或等于常数值，则保留true 。

static BooleanBinding

Bindings.notEqual​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding ，如果一个ObservableStringValue的值不等于一个恒定值，则保留true 。

static BooleanBinding

Bindings.notEqual​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding持有true如果一个价值ObservableStringValue不等于一个恒定值。

static BooleanBinding

Bindings.notEqualIgnoreCase​(String op1, ObservableStringValue op2)

创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。

static BooleanBinding

Bindings.notEqualIgnoreCase​(ObservableStringValue op1, String op2)

创建一个新的BooleanBinding保持true如果a的值ObservableStringValue不等于恒定值忽略大小写。

StringBinding

When.StringConditionBuilder.otherwise​(String otherwiseValue)

定义三元表达式的常量值，如果条件为 false ，则返回该 false 。

static <T> ObjectBinding<T>

Bindings.select​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static <T> ObjectBinding<T>

Bindings.select​(ObservableValue<?> root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static BooleanBinding

Bindings.selectBoolean​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static BooleanBinding

Bindings.selectBoolean​(ObservableValue<?> root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static DoubleBinding

Bindings.selectDouble​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static DoubleBinding

Bindings.selectDouble​(ObservableValue<?> root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static FloatBinding

Bindings.selectFloat​(Object root, String... steps)

创建一个用于获取成员的绑定，如 a.b.c 。

static FloatBinding

Bindings.selectFloat​(ObservableValue<?> root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static IntegerBinding

Bindings.selectInteger​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static IntegerBinding

Bindings.selectInteger​(ObservableValue<?> root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static LongBinding

Bindings.selectLong​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static LongBinding

Bindings.selectLong​(ObservableValue<?> root, String... steps)

创建一个用于获取成员的绑定，如 a.b.c 。

static StringBinding

Bindings.selectString​(Object root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

static StringBinding

Bindings.selectString​(ObservableValue<?> root, String... steps)

创建用于获取成员的绑定，如 a.b.c 。

When.StringConditionBuilder

When.then​(String thenValue)

定义三元表达式的常量值，如果条件为 true ，则返回。

Method parameters in javafx.beans.binding with type arguments of type String

Modifier and Type

方法

描述

void

StringBinding.addListener​(ChangeListener<? super String> listener)

static void

Bindings.bindBidirectional​(Property<String> stringProperty, Property<?> otherProperty, Format format)

在String - Property和另一个Property使用指定的Format生成双向绑定（或“反向绑定”）进行转换。

static <T> void

Bindings.bindBidirectional​(Property<String> stringProperty, Property<T> otherProperty, StringConverter<T> converter)

在String - Property和另一个Property使用指定的StringConverter生成双向绑定（或“反向绑定”）进行转换。

static StringBinding

Bindings.createStringBinding​(Callable<String> func, Observable... dependencies)

助手功能创建一个自定义的StringBinding 。

void

StringBinding.removeListener​(ChangeListener<? super String> listener)

static StringBinding

Bindings.stringValueAt​(ObservableList<String> op, int index)

创建一个新的StringBinding ，其中包含指定位置的元素ObservableList 。

static StringBinding

Bindings.stringValueAt​(ObservableList<String> op, ObservableIntegerValue index)

创建一个新的StringBinding ，其中包含指定位置的元素ObservableList 。

static StringBinding

Bindings.stringValueAt​(ObservableList<String> op, ObservableNumberValue index)

创建一个新的StringBinding ，其中包含ObservableList在指定位置的元素。

static <K> StringBinding

Bindings.stringValueAt​(ObservableMap<K,String> op, ObservableValue<? extends K> key)

创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。

static <K> StringBinding

Bindings.stringValueAt​(ObservableMap<K,String> op, K key)

创建一个新的StringBinding ，其中包含ObservableMap中特定键的映射 。

Uses of String in javafx.beans.property

Methods in javafx.beans.property that return String

Modifier and Type

方法

描述

String

StringPropertyBase.get​()

获取包装的值。

String

ReadOnlyProperty.getName​()

返回此属性的名称。

String

SimpleBooleanProperty.getName​()

返回此属性的名称。

String

SimpleDoubleProperty.getName​()

返回此属性的名称。

String

SimpleFloatProperty.getName​()

返回此属性的名称。

String

SimpleIntegerProperty.getName​()

返回此属性的名称。

String

SimpleListProperty.getName​()

返回此属性的名称。

String

SimpleLongProperty.getName​()

返回此属性的名称。

String

SimpleMapProperty.getName​()

返回此属性的名称。

String

SimpleObjectProperty.getName​()

返回此属性的名称。

String

SimpleSetProperty.getName​()

返回此属性的名称。

String

SimpleStringProperty.getName​()

返回此属性的名称。

String

BooleanProperty.toString​()

返回此 BooleanProperty对象的字符串表示形式。

String

BooleanPropertyBase.toString​()

返回此 BooleanPropertyBase对象的字符串表示形式。

String

DoubleProperty.toString​()

返回此 DoubleProperty对象的字符串表示形式。

String

DoublePropertyBase.toString​()

返回此 DoublePropertyBase对象的字符串表示形式。

String

FloatProperty.toString​()

返回此 FloatProperty对象的字符串表示形式。

String

FloatPropertyBase.toString​()

返回此 FloatPropertyBase对象的字符串表示形式。

String

IntegerProperty.toString​()

返回此 IntegerProperty对象的字符串表示形式。

String

IntegerPropertyBase.toString​()

返回此 IntegerPropertyBase对象的字符串表示形式。

String

ListProperty.toString​()

返回此 ListProperty对象的字符串表示形式。

String

ListPropertyBase.toString​()

返回此 ListPropertyBase对象的字符串表示形式。

String

LongProperty.toString​()

返回此 LongProperty对象的字符串表示形式。

String

LongPropertyBase.toString​()

返回此 LongPropertyBase对象的字符串表示形式。

String

MapProperty.toString​()

返回此 MapProperty对象的字符串表示形式。

String

MapPropertyBase.toString​()

返回此 MapPropertyBase对象的字符串表示形式。

String

ObjectProperty.toString​()

返回此 ObjectProperty对象的字符串表示形式。

String

ObjectPropertyBase.toString​()

返回此 ObjectPropertyBase对象的字符串表示形式。

String

ReadOnlyBooleanProperty.toString​()

返回此 ReadOnlyBooleanProperty对象的字符串表示形式。

String

ReadOnlyDoubleProperty.toString​()

返回此 ReadOnlyDoubleProperty对象的字符串表示形式。

String

ReadOnlyFloatProperty.toString​()

返回此 ReadOnlyFloatProperty对象的字符串表示形式。

String

ReadOnlyIntegerProperty.toString​()

返回此 ReadOnlyIntegerProperty对象的字符串表示形式。

String

ReadOnlyListProperty.toString​()

返回此 ReadOnlyListProperty对象的字符串表示形式。

String

ReadOnlyLongProperty.toString​()

返回此 ReadOnlyLongProperty对象的字符串表示形式。

String

ReadOnlyMapProperty.toString​()

返回此 ReadOnlyMapProperty对象的字符串表示形式。

String

ReadOnlyObjectProperty.toString​()

返回此 ReadOnlyObjectProperty对象的字符串表示形式。

String

ReadOnlySetProperty.toString​()

返回此 ReadOnlySetProperty对象的字符串表示形式。

String

ReadOnlyStringProperty.toString​()

返回此 ReadOnlyStringProperty对象的字符串表示形式。

String

SetProperty.toString​()

返回此 SetProperty对象的字符串表示形式。

String

SetPropertyBase.toString​()

返回此 SetPropertyBase对象的字符串表示形式。

String

StringProperty.toString​()

返回此 StringProperty对象的字符串表示形式。

String

StringPropertyBase.toString​()

返回此 StringPropertyBase对象的字符串表示形式。

Methods in javafx.beans.property with parameters of type String

Modifier and Type

方法

描述

void

StringPropertyBase.set​(String newValue)

设置包装的值。

void

StringProperty.setValue​(String v)

设置包装的值。

Method parameters in javafx.beans.property with type arguments of type String

Modifier and Type

方法

描述

void

ReadOnlyStringPropertyBase.addListener​(ChangeListener<? super String> listener)

void

StringPropertyBase.addListener​(ChangeListener<? super String> listener)

void

StringPropertyBase.bind​(ObservableValue<? extends String> newObservable)

为此创建一个单向绑定 Property 。

void

StringProperty.bindBidirectional​(Property<String> other)

在这个 Property和另一个之间创建双向绑定。

void

ReadOnlyStringPropertyBase.removeListener​(ChangeListener<? super String> listener)

void

StringPropertyBase.removeListener​(ChangeListener<? super String> listener)

void

StringProperty.unbindBidirectional​(Property<String> other)

删除这个 Property和另一个之间的双向绑定。

Constructors in javafx.beans.property with parameters of type String

Constructor

描述

ReadOnlyBooleanWrapper​(Object bean, String name)

构造函数为 ReadOnlyBooleanWrapper

ReadOnlyBooleanWrapper​(Object bean, String name, boolean initialValue)

构造函数为 ReadOnlyBooleanWrapper

ReadOnlyDoubleWrapper​(Object bean, String name)

构造函数为 ReadOnlyDoubleWrapper

ReadOnlyDoubleWrapper​(Object bean, String name, double initialValue)

构造函数为 ReadOnlyDoubleWrapper

ReadOnlyFloatWrapper​(Object bean, String name)

构造函数为 ReadOnlyFloatWrapper

ReadOnlyFloatWrapper​(Object bean, String name, float initialValue)

构造函数为 ReadOnlyFloatWrapper

ReadOnlyIntegerWrapper​(Object bean, String name)

构造函数为 ReadOnlyIntegerWrapper

ReadOnlyIntegerWrapper​(Object bean, String name, int initialValue)

构造函数为 ReadOnlyIntegerWrapper

ReadOnlyListWrapper​(Object bean, String name)

构造函数为 ReadOnlyListWrapper

ReadOnlyListWrapper​(Object bean, String name, ObservableList<E> initialValue)

构造函数为 ReadOnlyListWrapper

ReadOnlyLongWrapper​(Object bean, String name)

构造函数为 ReadOnlyLongWrapper

ReadOnlyLongWrapper​(Object bean, String name, long initialValue)

构造函数为 ReadOnlyLongWrapper

ReadOnlyMapWrapper​(Object bean, String name)

构造函数为 ReadOnlyMapWrapper

ReadOnlyMapWrapper​(Object bean, String name, ObservableMap<K,V> initialValue)

构造函数为 ReadOnlyMapWrapper

ReadOnlyObjectWrapper​(Object bean, String name)

构造函数为 ReadOnlyObjectWrapper

ReadOnlyObjectWrapper​(Object bean, String name, T initialValue)

构造函数为 ReadOnlyObjectWrapper

ReadOnlySetWrapper​(Object bean, String name)

构造函数为 ReadOnlySetWrapper

ReadOnlySetWrapper​(Object bean, String name, ObservableSet<E> initialValue)

构造函数为 ReadOnlySetWrapper

ReadOnlyStringWrapper​(Object bean, String name)

构造函数为 ReadOnlyStringWrapper

ReadOnlyStringWrapper​(Object bean, String name, String initialValue)

构造函数为 ReadOnlyStringWrapper

ReadOnlyStringWrapper​(String initialValue)

构造函数为 ReadOnlyStringWrapper

SimpleBooleanProperty​(Object bean, String name)

构造函数为 BooleanProperty

SimpleBooleanProperty​(Object bean, String name, boolean initialValue)

构造函数为 BooleanProperty

SimpleDoubleProperty​(Object bean, String name)

构造函数为 DoubleProperty

SimpleDoubleProperty​(Object bean, String name, double initialValue)

构造函数为 DoubleProperty

SimpleFloatProperty​(Object bean, String name)

构造函数 FloatProperty

SimpleFloatProperty​(Object bean, String name, float initialValue)

构造函数为 FloatProperty

SimpleIntegerProperty​(Object bean, String name)

构造函数为 IntegerProperty

SimpleIntegerProperty​(Object bean, String name, int initialValue)

构造函数为 IntegerProperty

SimpleListProperty​(Object bean, String name)

构造函数为 SimpleListProperty

SimpleListProperty​(Object bean, String name, ObservableList<E> initialValue)

构造函数为 SimpleListProperty

SimpleLongProperty​(Object bean, String name)

构造函数为 LongProperty

SimpleLongProperty​(Object bean, String name, long initialValue)

构造函数为 LongProperty

SimpleMapProperty​(Object bean, String name)

构造函数为 SimpleMapProperty

SimpleMapProperty​(Object bean, String name, ObservableMap<K,V> initialValue)

构造函数为 SimpleMapProperty

SimpleObjectProperty​(Object bean, String name)

构造函数为 ObjectProperty

SimpleObjectProperty​(Object bean, String name, T initialValue)

构造函数为 ObjectProperty

SimpleSetProperty​(Object bean, String name)

构造函数为 SimpleSetProperty

SimpleSetProperty​(Object bean, String name, ObservableSet<E> initialValue)

构造函数为 SimpleSetProperty

SimpleStringProperty​(Object bean, String name)

构造函数为 StringProperty

SimpleStringProperty​(Object bean, String name, String initialValue)

构造函数为 StringProperty

SimpleStringProperty​(String initialValue)

构造函数为 StringProperty

StringPropertyBase​(String initialValue)

StringPropertyBase的构造 StringPropertyBase 。

Uses of String in javafx.beans.property.adapter

Methods in javafx.beans.property.adapter that return String

Modifier and Type

方法

描述

String

JavaBeanStringProperty.get​()

获取包装的值。

String

ReadOnlyJavaBeanStringProperty.get​()

返回此 ObservableObjectValue<T>的当前值。

String

JavaBeanBooleanProperty.getName​()

返回此属性的名称。

String

JavaBeanDoubleProperty.getName​()

返回此属性的名称。

String

JavaBeanFloatProperty.getName​()

返回此属性的名称。

String

JavaBeanIntegerProperty.getName​()

返回此属性的名称。

String

JavaBeanLongProperty.getName​()

返回此属性的名称。

String

JavaBeanObjectProperty.getName​()

返回此属性的名称。

String

JavaBeanStringProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanBooleanProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanDoubleProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanFloatProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanIntegerProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanLongProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanObjectProperty.getName​()

返回此属性的名称。

String

ReadOnlyJavaBeanStringProperty.getName​()

返回此属性的名称。

String

JavaBeanBooleanProperty.toString​()

返回此 JavaBeanBooleanProperty对象的字符串表示形式。

String

JavaBeanDoubleProperty.toString​()

返回此 JavaBeanDoubleProperty对象的字符串表示形式。

String

JavaBeanFloatProperty.toString​()

返回此 JavaBeanFloatProperty对象的字符串表示形式。

String

JavaBeanIntegerProperty.toString​()

返回此 JavaBeanIntegerProperty对象的字符串表示形式。

String

JavaBeanLongProperty.toString​()

返回此 JavaBeanLongProperty对象的字符串表示形式。

String

JavaBeanObjectProperty.toString​()

返回此 JavaBeanObjectProperty对象的字符串表示形式。

Methods in javafx.beans.property.adapter with parameters of type String

Modifier and Type

方法

描述

JavaBeanBooleanPropertyBuilder

JavaBeanBooleanPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

JavaBeanDoublePropertyBuilder

JavaBeanDoublePropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

JavaBeanFloatPropertyBuilder

JavaBeanFloatPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

JavaBeanIntegerPropertyBuilder

JavaBeanIntegerPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

JavaBeanLongPropertyBuilder

JavaBeanLongPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

JavaBeanObjectPropertyBuilder

JavaBeanObjectPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

JavaBeanStringPropertyBuilder

JavaBeanStringPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

ReadOnlyJavaBeanBooleanPropertyBuilder

ReadOnlyJavaBeanBooleanPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

ReadOnlyJavaBeanDoublePropertyBuilder

ReadOnlyJavaBeanDoublePropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

ReadOnlyJavaBeanFloatPropertyBuilder

ReadOnlyJavaBeanFloatPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

ReadOnlyJavaBeanIntegerPropertyBuilder

ReadOnlyJavaBeanIntegerPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

ReadOnlyJavaBeanLongPropertyBuilder

ReadOnlyJavaBeanLongPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

ReadOnlyJavaBeanObjectPropertyBuilder<T>

ReadOnlyJavaBeanObjectPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

ReadOnlyJavaBeanStringPropertyBuilder

ReadOnlyJavaBeanStringPropertyBuilder.getter​(String getter)

设置吸气剂的替代名称。

JavaBeanBooleanPropertyBuilder

JavaBeanBooleanPropertyBuilder.name​(String name)

设置属性的名称

JavaBeanDoublePropertyBuilder

JavaBeanDoublePropertyBuilder.name​(String name)

设置属性的名称

JavaBeanFloatPropertyBuilder

JavaBeanFloatPropertyBuilder.name​(String name)

设置属性的名称

JavaBeanIntegerPropertyBuilder

JavaBeanIntegerPropertyBuilder.name​(String name)

设置属性的名称

JavaBeanLongPropertyBuilder

JavaBeanLongPropertyBuilder.name​(String name)

设置属性的名称

JavaBeanObjectPropertyBuilder

JavaBeanObjectPropertyBuilder.name​(String name)

设置属性的名称

JavaBeanStringPropertyBuilder

JavaBeanStringPropertyBuilder.name​(String name)

设置属性的名称

ReadOnlyJavaBeanBooleanPropertyBuilder

ReadOnlyJavaBeanBooleanPropertyBuilder.name​(String name)

设置属性的名称

ReadOnlyJavaBeanDoublePropertyBuilder

ReadOnlyJavaBeanDoublePropertyBuilder.name​(String name)

设置属性的名称

ReadOnlyJavaBeanFloatPropertyBuilder

ReadOnlyJavaBeanFloatPropertyBuilder.name​(String name)

设置属性的名称

ReadOnlyJavaBeanIntegerPropertyBuilder

ReadOnlyJavaBeanIntegerPropertyBuilder.name​(String name)

设置属性的名称

ReadOnlyJavaBeanLongPropertyBuilder

ReadOnlyJavaBeanLongPropertyBuilder.name​(String name)

设置属性的名称

ReadOnlyJavaBeanObjectPropertyBuilder<T>

ReadOnlyJavaBeanObjectPropertyBuilder.name​(String name)

设置属性的名称

ReadOnlyJavaBeanStringPropertyBuilder

ReadOnlyJavaBeanStringPropertyBuilder.name​(String name)

设置属性的名称

void

JavaBeanStringProperty.set​(String value)

设置包装的值。

JavaBeanBooleanPropertyBuilder

JavaBeanBooleanPropertyBuilder.setter​(String setter)

为设定者设置一个替代名称。

JavaBeanDoublePropertyBuilder

JavaBeanDoublePropertyBuilder.setter​(String setter)

为设定者设置一个替代名称。

JavaBeanFloatPropertyBuilder

JavaBeanFloatPropertyBuilder.setter​(String setter)

为设定者设置一个替代名称。

JavaBeanIntegerPropertyBuilder

JavaBeanIntegerPropertyBuilder.setter​(String setter)

为设定者设置一个替代名称。

JavaBeanLongPropertyBuilder

JavaBeanLongPropertyBuilder.setter​(String setter)

为设定者设置一个替代名称。

JavaBeanObjectPropertyBuilder

JavaBeanObjectPropertyBuilder.setter​(String setter)

为设定者设置一个替代名称。

JavaBeanStringPropertyBuilder

JavaBeanStringPropertyBuilder.setter​(String setter)

为设定者设置一个替代名称。

Method parameters in javafx.beans.property.adapter with type arguments of type String

Modifier and Type

方法

描述

void

JavaBeanStringProperty.addListener​(ChangeListener<? super String> listener)

添加一个ChangeListener ，当ObservableValue的值发生变化时，它将被通知。

void

JavaBeanStringProperty.bind​(ObservableValue<? extends String> observable)

为此创建一个单向绑定 Property 。

void

JavaBeanStringProperty.removeListener​(ChangeListener<? super String> listener)

从监听器列表中删除给定的监听器，每当 ObservableValue的值发生变化时通知 ObservableValue 。

Uses of String in javafx.concurrent

Methods in javafx.concurrent that return String

Modifier and Type

方法

描述

String

Service.getMessage​()

获取属性消息的值。

String

Task.getMessage​()

获取属性消息的值。

String

Worker.getMessage​()

获取与此Worker的当前状态相关联的消息。

String

Service.getTitle​()

获取属性标题的值。

String

Task.getTitle​()

获取属性标题的值。

String

Worker.getTitle​()

应该与此Worker关联的可选标题。

Methods in javafx.concurrent with parameters of type String

Modifier and Type

方法

描述

protected void

Task.updateMessage​(String message)

更新 message属性。

protected void

Task.updateTitle​(String title)

更新 title属性。

static Worker.State

Worker.State.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.css

Fields in javafx.css with type parameters of type String

Modifier and Type

Field

描述

List<String>

StyleConverter.StringStore.strings

Methods in javafx.css that return String

Modifier and Type

方法

描述

String

SimpleSelector.getId​()

String

Styleable.getId​()

该 Styleable为 Styleable 。

String

CssParser.ParseError.getMessage​()

String

SimpleSelector.getName​()

String

SimpleStyleableBooleanProperty.getName​()

返回此属性的名称。

String

SimpleStyleableDoubleProperty.getName​()

返回此属性的名称。

String

SimpleStyleableFloatProperty.getName​()

返回此属性的名称。

String

SimpleStyleableIntegerProperty.getName​()

返回此属性的名称。

String

SimpleStyleableLongProperty.getName​()

返回此属性的名称。

String

SimpleStyleableObjectProperty.getName​()

返回此属性的名称。

String

SimpleStyleableStringProperty.getName​()

返回此属性的名称。

String

CssMetaData.getProperty​()

String

Declaration.getProperty​()

abstract String

PseudoClass.getPseudoClassName​()

String

Styleable.getStyle​()

与此特定的 Node相关联的CSS样式的字符串表示 Node 。

String

StyleClass.getStyleClassName​()

String

Styleable.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

Stylesheet.getUrl​()

加载样式表的URL。

static String[]

StyleConverter.StringStore.readBinary​(DataInputStream is)

String

CompoundSelector.toString​()

String

CssMetaData.toString​()

String

CssParser.ParseError.InlineStyleParsingError.toString​()

String

CssParser.ParseError.PropertySetError.toString​()

String

CssParser.ParseError.StringParsingError.toString​()

String

CssParser.ParseError.StylesheetParsingError.toString​()

String

CssParser.ParseError.toString​()

String

Declaration.toString​()

String

Rule.toString​()

将此对象转换为字符串。

String

SimpleSelector.toString​()

将此对象转换为字符串。

String

Size.toString​()

String

Style.toString​()

String

StyleClass.toString​()

String

Stylesheet.toString​()

返回此对象的字符串表示形式。

Methods in javafx.css that return types with arguments of type String

Modifier and Type

方法

描述

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function)

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，String>并继承标志。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)

创建一个StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <String>并继承标志。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <String>并继承标志。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function)

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，String>并继承标志。

static StyleConverter<String,Boolean>

StyleConverter.getBooleanConverter​()

返回一个 StyleConverter ，其将“真”或“假”到 Boolean 。

static StyleConverter<String,Color>

StyleConverter.getColorConverter​()

返回一个 StyleConverter ，其转换Web颜色到的字符串表示 Color 。

CssMetaData<? extends Styleable,String>

SimpleStyleableStringProperty.getCssMetaData​()

反映对应于这个 javafx.beans.property.StyleableProperty

static <E extends Enum<E>>
StyleConverter<String,? extends Enum<?>>

StyleConverter.getEnumConverter​(Class<E> enumClass)

返回一个 StyleConverter一种转换的String表示 Enum至 Enum 。

static StyleConverter<String,String>

StyleConverter.getStringConverter​()

用于引用的字符串的转换器，可以嵌入unicode字符。

static StyleConverter<String,String>

StyleConverter.getStringConverter​()

用于引用的字符串的转换器，可以嵌入unicode字符。

ObservableList<String>

Styleable.getStyleClass​()

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

List<String>

SimpleSelector.getStyleClasses​()

static StyleConverter<ParsedValue[],String>

StyleConverter.getUrlConverter​()

用于URL字符串的转换器。

Methods in javafx.css with parameters of type String

Modifier and Type

方法

描述

int

StyleConverter.StringStore.addString​(String s)

void

StyleableStringProperty.applyStyle​(StyleOrigin origin, String v)

这个方法从CSS代码调用来设置属性的值。

CssMetaData<S,Boolean>

StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function)

创建一个具有初始值的CssMetaData <S，Boolean>，并继承标志，两者都默认为false。

CssMetaData<S,Boolean>

StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)

创建具有初始值的CssMetaData <S，Boolean>，并将标志默认为false。

CssMetaData<S,Boolean>

StyleablePropertyFactory.createBooleanCssMetaData​(String property, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，Boolean>，并继承标志。

CssMetaData<S,Color>

StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function)

创建一个CssMetaData <S，Color>，初始值为Color.BLACK，并继承标志默认为false。

CssMetaData<S,Color>

StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue)

创建具有初始值的CssMetaData <S，Color>，并将标志默认为false。

CssMetaData<S,Color>

StyleablePropertyFactory.createColorCssMetaData​(String property, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，Color>并继承标志。

CssMetaData<S,Duration>

StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function)

创建一个具有Duration.BLACK的初始值的CssMetaData <S，Duration>，并将标志默认为false。

CssMetaData<S,Duration>

StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue)

创建具有初始值的CssMetaData <S，持续时间>，并将标志默认为false。

CssMetaData<S,Duration>

StyleablePropertyFactory.createDurationCssMetaData​(String property, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，Duration>并继承标志。

<E extends Effect>
CssMetaData<S,E>

StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function)

创建CssMetaData <S，Effect>，初始值为null，并将标志默认为false。

<E extends Effect>
CssMetaData<S,E>

StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue)

创建具有初始值的CssMetaData <S，Effect>，并将标志默认为false。

<E extends Effect>
CssMetaData<S,E>

StyleablePropertyFactory.createEffectCssMetaData​(String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)

用初始值创建一个CssMetaData <S，Effect>并继承标志。

<E extends Enum<E>>
CssMetaData<S,E>

StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function)

创建CssMetaData <S，枚举>，初始值为null，并将标志默认为false。

<E extends Enum<E>>
CssMetaData<S,E>

StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue)

创建具有初始值的CssMetaData <S，枚举>，并将标志默认为false。

<E extends Enum<E>>
CssMetaData<S,E>

StyleablePropertyFactory.createEnumCssMetaData​(Class<? extends Enum> enumClass, String property, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，枚举>，并继承标志。

CssMetaData<S,Font>

StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function)

创建CssMetaData <S，Font>，初始值为 Font.getDefault() ，并将标志默认为true。

CssMetaData<S,Font>

StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue)

创建具有初始值的CssMetaData <S，Font>，并将标志默认为true。

CssMetaData<S,Font>

StyleablePropertyFactory.createFontCssMetaData​(String property, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)

创建一个具有初始值的CssMetaData <S，Font>并继承标志。

CssMetaData<S,Insets>

StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function)

创建CssMetaData <S，Insets>，初始值为 Insets.EMPTY ，并将标志默认为false。

CssMetaData<S,Insets>

StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue)

创建具有初始值的CssMetaData <S，Insets>，并将标志默认为false。

CssMetaData<S,Insets>

StyleablePropertyFactory.createInsetsCssMetaData​(String property, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，Insets>并继承标志。

CssMetaData<S,Paint>

StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function)

使用Color.BLACK的初始值创建一个CssMetaData <S，Paint>，并将标志默认为false。

CssMetaData<S,Paint>

StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue)

创建具有初始值的CssMetaData <S，Paint>，并将标志默认为false。

CssMetaData<S,Paint>

StyleablePropertyFactory.createPaintCssMetaData​(String property, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)

用初始值创建一个CssMetaData <S，Paint>并继承标志。

static Selector

Selector.createSelector​(String cssSelector)

CssMetaData<S,Number>

StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function)

创建CssMetaData <S，Number>，初始值为 0d ，并将标志默认为false。

CssMetaData<S,Number>

StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue)

创建具有初始值的CssMetaData <S，Number>，并将标志默认为false。

CssMetaData<S,Number>

StyleablePropertyFactory.createSizeCssMetaData​(String property, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，Number>，并继承标志。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function)

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，String>并继承标志。

StyleableProperty<Boolean>

StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Boolean>。

StyleableProperty<Boolean>

StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function)

创建一个StyleableProperty <Boolean>。

StyleableProperty<Boolean>

StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue)

创建一个具有初始值的StyleableProperty <Boolean>。

StyleableProperty<Boolean>

StyleablePropertyFactory.createStyleableBooleanProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Boolean>> function, boolean initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Boolean>并继承标志。

StyleableProperty<Color>

StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Color>。

StyleableProperty<Color>

StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function)

创建一个StyleableProperty <Color>。

StyleableProperty<Color>

StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue)

创建一个具有初始值的StyleableProperty <Color>。

StyleableProperty<Color>

StyleablePropertyFactory.createStyleableColorProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Color>> function, Color initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Color>并继承标志。

StyleableProperty<Duration>

StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Duration>。

StyleableProperty<Duration>

StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function)

创建一个StyleableProperty <Duration>。

StyleableProperty<Duration>

StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue)

创建一个具有初始值的StyleableProperty <Duration>。

StyleableProperty<Duration>

StyleablePropertyFactory.createStyleableDurationProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Duration>> function, Duration initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Duration>并继承标志。

StyleableProperty<Effect>

StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的CssMetaData为给定的 cssProperty创建一个StyleableProperty <Effect>。

<E extends Enum<E>>
StyleableProperty<E>

StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Class<E> enumClass)

创建一个StyleableProperty <E使用以前创建的给定的 cssProperty扩展枚举<E >>。

<E extends Effect>
StyleableProperty<E>

StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function)

创建一个StyleableProperty <Effect>。

<E extends Effect>
StyleableProperty<E>

StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue)

创建一个具有初始值的StyleableProperty <Effect>。

<E extends Effect>
StyleableProperty<E>

StyleablePropertyFactory.createStyleableEffectProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, E initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Effect>并继承标志。

<E extends Enum<E>>
StyleableProperty<E>

StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass)

创建一个StyleableProperty <E extends Enum <E >>。

<E extends Enum<E>>
StyleableProperty<E>

StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue)

创建一个StyleableProperty <E使用初始值扩展Enum <E >>。

<E extends Enum<E>>
StyleableProperty<E>

StyleablePropertyFactory.createStyleableEnumProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<E>> function, Class<E> enumClass, E initialValue, boolean inherits)

创建一个StyleableProperty <E使用初始值扩展枚举<E >>并继承标志。

StyleableProperty<Font>

StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Font>。

StyleableProperty<Font>

StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function)

创建一个StyleableProperty <Font>。

StyleableProperty<Font>

StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue)

创建一个具有初始值的StyleableProperty <Font>。

StyleableProperty<Font>

StyleablePropertyFactory.createStyleableFontProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Font>> function, Font initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Font>并继承标志。

StyleableProperty<Insets>

StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Insets>。

StyleableProperty<Insets>

StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function)

创建一个StyleableProperty <Inset>。

StyleableProperty<Insets>

StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue)

创建一个具有初始值的StyleableProperty <Inset>。

StyleableProperty<Insets>

StyleablePropertyFactory.createStyleableInsetsProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Insets>> function, Insets initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Inset>并继承标志。

StyleableProperty<Number>

StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Number>。

StyleableProperty<Number>

StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function)

创建一个StyleableProperty <Number>。

StyleableProperty<Number>

StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue)

创建一个具有初始值的StyleableProperty <Number>。

StyleableProperty<Number>

StyleablePropertyFactory.createStyleableNumberProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Number>> function, Number initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Number>并继承标志。

StyleableProperty<Paint>

StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <Paint>。

StyleableProperty<Paint>

StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function)

创建一个StyleableProperty <Paint>。

StyleableProperty<Paint>

StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue)

创建一个具有初始值的StyleableProperty <Paint>。

StyleableProperty<Paint>

StyleablePropertyFactory.createStyleablePaintProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<Paint>> function, Paint initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <Paint>并继承标志。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)

创建一个StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <String>并继承标志。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty)

使用先前创建的给定的 cssProperty创建一个StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <String>并继承标志。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function)

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，String>并继承标志。

static PseudoClass

PseudoClass.getPseudoClass​(String pseudoClass)

给定的pseudoClass只有一个PseudoClass实例。

Stylesheet

CssParser.parse​(String stylesheetText)

从CSS文档字符串创建样式表。

Stylesheet

CssParser.parse​(String docbase, String stylesheetText)

使用docbase作为解析样式表中的引用的基本URL从CSS文档字符串创建样式表。

static StyleConverter<?,?>

StyleConverter.readBinary​(DataInputStream is, String[] strings)

读取二进制数据流。

void

StyleableStringProperty.set​(String v)

设置包装的值。

static SizeUnits

SizeUnits.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StyleOrigin

StyleOrigin.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in javafx.css with type arguments of type String

Modifier and Type

方法

描述

void

StyleableStringProperty.bind​(ObservableValue<? extends String> observable)

为此创建一个单向绑定 Property 。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function)

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createStringCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，String>并继承标志。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)

创建一个StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableStringProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <String>并继承标志。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue)

创建一个具有初始值的StyleableProperty <String>。

StyleableProperty<String>

StyleablePropertyFactory.createStyleableUrlProperty​(S styleable, String propertyName, String cssProperty, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建一个具有初始值的StyleableProperty <String>并继承标志。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function)

创建CssMetaData <S，String>，初始值为null，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue)

创建具有初始值的CssMetaData <S，String>，并将标志默认为false。

CssMetaData<S,String>

StyleablePropertyFactory.createUrlCssMetaData​(String property, Function<S,StyleableProperty<String>> function, String initialValue, boolean inherits)

创建具有初始值的CssMetaData <S，String>并继承标志。

Constructors in javafx.css with parameters of type String

Constructor

描述

CssMetaData​(String property, StyleConverter<?,V> converter)

使用给定的参数构造一个CssMetaData，initialValue为null，inherit设置为false，没有子属性。

CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue)

使用给定的参数构造一个CssMetaData，继承设置为false并且没有子属性。

CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits)

用给定的参数构造一个CssMetaData，没有子属性。

CssMetaData​(String property, StyleConverter<?,V> converter, V initialValue, boolean inherits, List<CssMetaData<? extends Styleable,?>> subProperties)

用给定的参数构造一个CssMetaData，没有子属性。

FontCssMetaData​(String property, Font initial)

从指定的属性和初始字体构造一个FontCSSMetaData对象。

ParseError​(String message)

PropertySetError​(CssMetaData styleableProperty, Styleable styleable, String message)

SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name)

的构造函数 SimpleStyleableBooleanProperty 。

SimpleStyleableBooleanProperty​(CssMetaData<? extends Styleable,Boolean> cssMetaData, Object bean, String name, boolean initialValue)

的构造函数 SimpleStyleableBooleanProperty 。

SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

的构造器的 SimpleStyleableDoubleProperty 。

SimpleStyleableDoubleProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Double initialValue)

SimpleStyleableDoubleProperty的构造 SimpleStyleableDoubleProperty 。

SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

的构造器的 SimpleStyleableFloatProperty 。

SimpleStyleableFloatProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Float initialValue)

的构造函数 SimpleStyleableFloatProperty 。

SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

的构造器的 SimpleStyleableIntegerProperty 。

SimpleStyleableIntegerProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Integer initialValue)

SimpleStyleableIntegerProperty的构造 SimpleStyleableIntegerProperty 。

SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name)

的构造函数 SimpleStyleableLongProperty 。

SimpleStyleableLongProperty​(CssMetaData<? extends Styleable,Number> cssMetaData, Object bean, String name, Long initialValue)

SimpleStyleableLongProperty的构造 SimpleStyleableLongProperty 。

SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name)

的构造函数 SimpleStyleableObjectProperty 。

SimpleStyleableObjectProperty​(CssMetaData<? extends Styleable,T> cssMetaData, Object bean, String name, T initialValue)

的构造函数 SimpleStyleableObjectProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)

的构造器的 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, String initialValue)

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

StyleableStringProperty​(String initialValue)

的构造函数为 StyleableStringProperty 。

StyleClass​(String styleClassName, int index)

Constructor parameters in javafx.css with type arguments of type String

Constructor

描述

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData)

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name)

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, Object bean, String name, String initialValue)

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

SimpleStyleableStringProperty​(CssMetaData<? extends Styleable,String> cssMetaData, String initialValue)

SimpleStyleableStringProperty的构造 SimpleStyleableStringProperty 。

Uses of String in javafx.css.converter

Methods in javafx.css.converter that return String

Modifier and Type

方法

描述

String

StringConverter.convert​(ParsedValue<String,String> value, Font font)

String[]

StringConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<String,String>[],String[]> value, Font font)

String

URLConverter.convert​(ParsedValue<ParsedValue[],String> value, Font font)

String[]

URLConverter.SequenceConverter.convert​(ParsedValue<ParsedValue<ParsedValue[],String>[],String[]> value, Font font)

String

BooleanConverter.toString​()

String

ColorConverter.toString​()

String

CursorConverter.toString​()

String

DeriveColorConverter.toString​()

String

DeriveSizeConverter.toString​()

String

DurationConverter.toString​()

String

EffectConverter.DropShadowConverter.toString​()

String

EffectConverter.InnerShadowConverter.toString​()

String

EffectConverter.toString​()

String

EnumConverter.toString​()

String

FontConverter.FontSizeConverter.toString​()

String

FontConverter.FontStyleConverter.toString​()

String

FontConverter.FontWeightConverter.toString​()

String

FontConverter.toString​()

String

InsetsConverter.SequenceConverter.toString​()

String

InsetsConverter.toString​()

String

LadderConverter.toString​()

String

PaintConverter.ImagePatternConverter.toString​()

String

PaintConverter.LinearGradientConverter.toString​()

String

PaintConverter.RadialGradientConverter.toString​()

String

PaintConverter.RepeatingImagePatternConverter.toString​()

String

PaintConverter.SequenceConverter.toString​()

String

PaintConverter.toString​()

String

SizeConverter.SequenceConverter.toString​()

String

SizeConverter.toString​()

String

StopConverter.toString​()

String

StringConverter.SequenceConverter.toString​()

String

StringConverter.toString​()

String

URLConverter.SequenceConverter.toString​()

String

URLConverter.toString​()

Methods in javafx.css.converter that return types with arguments of type String

Modifier and Type

方法

描述

static StyleConverter<String,Boolean>

BooleanConverter.getInstance​()

static StyleConverter<String,Color>

ColorConverter.getInstance​()

static StyleConverter<String,Cursor>

CursorConverter.getInstance​()

static StyleConverter<String,Shape>

ShapeConverter.getInstance​()

static StyleConverter<String,String>

StringConverter.getInstance​()

static StyleConverter<String,String>

StringConverter.getInstance​()

static StyleConverter<ParsedValue[],String>

URLConverter.getInstance​()

Methods in javafx.css.converter with parameters of type String

Modifier and Type

方法

描述

static StyleConverter<?,?>

EnumConverter.getInstance​(String ename)

static StyleConverter<?,?>

EnumConverter.readBinary​(DataInputStream is, String[] strings)

Method parameters in javafx.css.converter with type arguments of type String

Modifier and Type

方法

描述

Boolean

BooleanConverter.convert​(ParsedValue<String,Boolean> value, Font not_used)

Color

ColorConverter.convert​(ParsedValue<String,Color> value, Font font)

Cursor

CursorConverter.convert​(ParsedValue<String,Cursor> value, Font not_used)

E

EnumConverter.convert​(ParsedValue<String,E> value, Font not_used)

FontPosture

FontConverter.FontStyleConverter.convert​(ParsedValue<String,FontPosture> value, Font font)

FontWeight

FontConverter.FontWeightConverter.convert​(ParsedValue<String,FontWeight> value, Font font)

Shape

ShapeConverter.convert​(ParsedValue<String,Shape> value, Font font)

String

StringConverter.convert​(ParsedValue<String,String> value, Font font)

String

StringConverter.convert​(ParsedValue<String,String> value, Font font)

String

URLConverter.convert​(ParsedValue<ParsedValue[],String> value, Font font)

Uses of String in javafx.event

Methods in javafx.event that return String

Modifier and Type

方法

描述

String

EventType.getName​()

获取此事件类型的名称。

String

EventType.toString​()

返回此 EventType对象的字符串表示形式。

Constructors in javafx.event with parameters of type String

Constructor

描述

EventType​(String name)

构造一个新的 EventType具有指定的名称和 EventType.ROOT作为其超级类型。

EventType​(EventType<? super T> superType, String name)

构造具有指定的超类型和名称的新的 EventType 。

Uses of String in javafx.fxml

Fields in javafx.fxml declared as String

Modifier and Type

Field

描述

static String

FXMLLoader.ARRAY_COMPONENT_DELIMITER

数组的分隔符作为值。

static String

FXMLLoader.BI_DIRECTIONAL_BINDING_PREFIX

前缀用于双向绑定表达式解析。

static String

FXMLLoader.BI_DIRECTIONAL_BINDING_SUFFIX

双向绑定表达式解析的后缀。

static String

FXMLLoader.BINDING_EXPRESSION_PREFIX

用于表达式解析的前缀。

static String

FXMLLoader.BINDING_EXPRESSION_SUFFIX

绑定表达式分辨率的后缀

static String

FXMLLoader.CHANGE_EVENT_HANDLER_SUFFIX

财产更改/无效处理程序的后缀。

static String

FXMLLoader.CONTROLLER_KEYWORD

控制器在命名空间映射中的关键。

static String

FXMLLoader.CONTROLLER_METHOD_PREFIX

控制器方法分辨率前缀。

static String

FXMLLoader.CONTROLLER_SUFFIX

包含fxml文件的控制器的后缀。

static String

FXMLLoader.COPY_SOURCE_ATTRIBUTE

<fx：copy>'source'属性。

static String

FXMLLoader.COPY_TAG

标签名称为<fx：copy>。

static String

FXMLLoader.DEFAULT_CHARSET_NAME

字符集未被明确指定时使用的字符集。

static String

FXMLLoader.DEFINE_TAG

标签名称为<fx：define>。

static String

FXMLLoader.ESCAPE_PREFIX

转义属性值内的特殊字符的转义前缀。

static String

FXMLLoader.EVENT_HANDLER_PREFIX

事件处理程序属性的前缀。

static String

FXMLLoader.EVENT_KEY

事件处理程序脚本中Event对象的名称。

static String

FXMLLoader.EXPRESSION_PREFIX

（变量）表达式分辨率的前缀。

static String

FXMLLoader.FX_CONSTANT_ATTRIBUTE

标签名为'fx：constant'。

static String

FXMLLoader.FX_CONTROLLER_ATTRIBUTE

根的fx：controller属性的名称。

static String

FXMLLoader.FX_FACTORY_ATTRIBUTE

“fx：factory”属性的名称。

static String

FXMLLoader.FX_ID_ATTRIBUTE

fx：id属性的名称。

static String

FXMLLoader.FX_NAMESPACE_PREFIX

'fx'命名空间的前缀。

static String

FXMLLoader.FX_NAMESPACE_VERSION

包含当前的fx namepsace版本。

static String

FXMLLoader.FX_VALUE_ATTRIBUTE

fx：value属性的名称。

static String

FXMLLoader.IMPORT_PROCESSING_INSTRUCTION

导入处理指令的标签名称。

static String

FXMLLoader.INCLUDE_CHARSET_ATTRIBUTE

<fx：include>'charset'属性。

static String

FXMLLoader.INCLUDE_RESOURCES_ATTRIBUTE

<fx：include>'资源'属性。

static String

FXMLLoader.INCLUDE_SOURCE_ATTRIBUTE

<fx：include>'source'属性。

static String

FXMLLoader.INCLUDE_TAG

标签名称为<fx：include>。

static String

FXMLLoader.INITIALIZE_METHOD_NAME

初始化方法的名称。

static String

FXMLLoader.JAVAFX_VERSION

包含当前的javafx版本。

static String

FXMLLoader.LANGUAGE_PROCESSING_INSTRUCTION

语言处理指令的标签名称。

static String

FXMLLoader.LOCATION_KEY

命名空间地图中位置URL的键。

static String

FXMLLoader.NULL_KEYWORD

代表'null'的值。

static String

FXMLLoader.REFERENCE_SOURCE_ATTRIBUTE

<fx：reference>'source'属性。

static String

FXMLLoader.REFERENCE_TAG

标签名称为<fx：reference>。

static String

FXMLLoader.RELATIVE_PATH_PREFIX

前缀相对位置解析。

static String

FXMLLoader.RESOURCE_KEY_PREFIX

前缀用于资源解析。

static String

FXMLLoader.RESOURCES_KEY

ResourceBundle在命名空间映射中的关键。

static String

FXMLLoader.ROOT_TAG

标签名称为<fx：root>。

static String

FXMLLoader.ROOT_TYPE_ATTRIBUTE

<fx：root>'type'属性。

static String

FXMLLoader.SCRIPT_CHARSET_ATTRIBUTE

<fx：script>'charset'属性。

static String

FXMLLoader.SCRIPT_SOURCE_ATTRIBUTE

<fx：script>'source'属性。

static String

FXMLLoader.SCRIPT_TAG

标签名称为<fx：script>。

Methods in javafx.fxml that return types with arguments of type String

Modifier and Type

方法

描述

ObservableMap<String,Object>

FXMLLoader.getNamespace​()

返回此装载器使用的命名空间。

Methods in javafx.fxml with parameters of type String

Modifier and Type

方法

描述

void

LoadListener.beginPropertyElement​(String name, Class<?> sourceType)

当加载程序开始读取属性元素时调用。

void

LoadListener.beginUnknownStaticPropertyElement​(String name)

当加载程序开始读取由未知类型定义的静态属性元素时调用。

void

LoadListener.beginUnknownTypeElement​(String name)

当加载程序已经开始读取未知类型的实例声明元素时调用。

static Class<?>

FXMLLoader.loadType​(String className)

已过时。
此方法现在委托给FXMLLoader.getDefaultClassLoader() 。

static Class<?>

FXMLLoader.loadType​(String packageName, String className)

已过时。
此方法现在委托给FXMLLoader.getDefaultClassLoader() 。

void

LoadListener.readComment​(String comment)

当加载程序读取注释时调用。

void

LoadListener.readEventHandlerAttribute​(String name, String value)

当加载程序读取事件处理程序属性时调用。

void

LoadListener.readImportProcessingInstruction​(String target)

当加载程序读取导入处理指令时调用。

void

LoadListener.readInternalAttribute​(String name, String value)

加载程序读取内部属性时调用。

void

LoadListener.readLanguageProcessingInstruction​(String language)

当加载程序读取语言处理指令时调用。

void

LoadListener.readPropertyAttribute​(String name, Class<?> sourceType, String value)

加载程序读取属性属性时调用。

void

LoadListener.readUnknownStaticPropertyAttribute​(String name, String value)

当加载程序读取未知的静态属性属性时调用。

Constructors in javafx.fxml with parameters of type String

Constructor

描述

LoadException​(String message)

LoadException​(String message, Throwable cause)

Uses of String in javafx.geometry

Methods in javafx.geometry that return String

Modifier and Type

方法

描述

String

BoundingBox.toString​()

返回此 BoundingBox的字符串表示 BoundingBox 。

String

Dimension2D.toString​()

返回此 Dimension2D的字符串表示 Dimension2D 。

String

Insets.toString​()

返回插值的字符串表示形式。

String

Point2D.toString​()

返回此 Point2D的字符串表示 Point2D 。

String

Point3D.toString​()

返回此 Point3D的字符串表示 Point3D 。

String

Rectangle2D.toString​()

返回此 Rectangle2D的字符串表示 Rectangle2D 。

Methods in javafx.geometry with parameters of type String

Modifier and Type

方法

描述

static HorizontalDirection

HorizontalDirection.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static HPos

HPos.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static NodeOrientation

NodeOrientation.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Orientation

Orientation.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Pos

Pos.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Side

Side.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static VerticalDirection

VerticalDirection.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static VPos

VPos.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.print

Methods in javafx.print that return String

Modifier and Type

方法

描述

String

JobSettings.getJobName​()

获取工作的名称。

String

Paper.getName​()

获取论文名称。

String

PaperSource.getName​()

返回此纸张来源的名称。

String

Printer.getName​()

返回基础系统使用的名称，以便向用户和/或应用程序标识打印机。

String

JobSettings.toString​()

String

PageLayout.toString​()

String

Paper.toString​()

String

PaperSource.toString​()

String

Printer.toString​()

String

PrinterJob.toString​()

String

PrintResolution.toString​()

Methods in javafx.print with parameters of type String

Modifier and Type

方法

描述

void

JobSettings.setJobName​(String name)

设置工作的名称。

static Collation

Collation.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PageOrientation

PageOrientation.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PrintColor

PrintColor.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Printer.MarginType

Printer.MarginType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PrinterJob.JobStatus

PrinterJob.JobStatus.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PrintQuality

PrintQuality.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PrintSides

PrintSides.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.scene

Methods in javafx.scene that return String

Modifier and Type

方法

描述

String

Node.getAccessibleHelp​()

获取属性accessibleHelp的值。

String

Node.getAccessibleRoleDescription​()

获取属性accessibilityRoleDescription的值。

String

Node.getAccessibleText​()

获取属性accessibleText的值。

String

Node.getId​()

这个id的这个 Node 。

String

Node.getStyle​()

与此特定 Node相关联的CSS样式的字符串表示 Node 。

String

Node.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

Scene.getUserAgentStylesheet​()

获取此场景将使用的用户代理样式表的URL。

String

SubScene.getUserAgentStylesheet​()

获取此SubScene将使用的用户代理样式表的URL。

String

Cursor.toString​()

返回游标的字符串表示形式。

String

Node.toString​()

返回对象的字符串表示形式。

String

SceneAntialiasing.toString​()

Methods in javafx.scene that return types with arguments of type String

Modifier and Type

方法

描述

ObjectProperty<String>

Node.accessibleHelpProperty​()

该 Node的无障碍帮助文本。

ObjectProperty<String>

Node.accessibleRoleDescriptionProperty​()

这个角色描述 Node 。

ObjectProperty<String>

Node.accessibleTextProperty​()

这个 Node的可访问文本。

ObservableList<String>

Node.getStyleClass​()

ObservableList<String>

Parent.getStylesheets​()

获取链接到此父项内容使用的样式表的字符串URL的可观察列表。

ObservableList<String>

Scene.getStylesheets​()

获取链接到与场景内容一起使用的样式表的字符串URL的可观察列表。

ObjectProperty<String>

Scene.userAgentStylesheetProperty​()

ObjectProperty<String>

SubScene.userAgentStylesheetProperty​()

Methods in javafx.scene with parameters of type String

Modifier and Type

方法

描述

static Cursor

Cursor.cursor​(String identifier)

返回指定标识符的游标。

Node

Node.lookup​(String selector)

根据给定的CSS选择器找到这个 Node或第一个子节点。

Node

Parent.lookup​(String selector)

Node

Scene.lookup​(String selector)

根据指定的CSS选择器查找场景图中的任何节点。

Set<Node>

Node.lookupAll​(String selector)

查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。

void

Node.setAccessibleHelp​(String value)

设置属性accessibleHelp的值。

void

Node.setAccessibleRoleDescription​(String value)

设置属性accessibilityRoleDescription的值。

void

Node.setAccessibleText​(String value)

设置属性accessibleText的值。

void

Node.setId​(String value)

设置属性id的值。

void

Node.setStyle​(String value)

与此特定的 Node相关联的CSS样式的字符串表示 Node 。

void

Scene.setUserAgentStylesheet​(String url)

设置此场景将使用的用户代理样式表的URL，而不是platform-default用户代理样式表。

void

SubScene.setUserAgentStylesheet​(String url)

设置此SubScene将使用的用户代理样式表的URL代替platform-default用户代理样式表。

static AccessibleAction

AccessibleAction.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static AccessibleAttribute

AccessibleAttribute.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static AccessibleRole

AccessibleRole.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static CacheHint

CacheHint.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static DepthTest

DepthTest.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.scene.canvas

Methods in javafx.scene.canvas with parameters of type String

Modifier and Type

方法

描述

void

GraphicsContext.appendSVGPath​(String svgpath)

将SVG路径字符串附加到当前路径。

void

GraphicsContext.fillText​(String text, double x, double y)

使用当前的填充颜色属性填充位置x，y处的给定文本字符串。

void

GraphicsContext.fillText​(String text, double x, double y, double maxWidth)

填写文本并包含字符串的最大宽度。

void

GraphicsContext.strokeText​(String text, double x, double y)

使用当前笔画paint属性绘制位置x，y处的给定文本字符串。

void

GraphicsContext.strokeText​(String text, double x, double y, double maxWidth)

用笔画绘制文本，并包含字符串的最大宽度。

Uses of String in javafx.scene.chart

Methods in javafx.scene.chart that return String

Modifier and Type

方法

描述

String

Axis.getLabel​()

获取属性标签的值。

String

Axis.TickMark.getLabel​()

获取属性标签的值。

String

PieChart.Data.getName​()

获取属性名称的值。

String

XYChart.Series.getName​()

获取属性名称的值。

protected abstract String

Axis.getTickMarkLabel​(T value)

获取具有给定值的刻度线的字符串标签名称

protected String

CategoryAxis.getTickMarkLabel​(String value)

获取具有给定值的刻度线的字符串标签名称

protected String

NumberAxis.getTickMarkLabel​(Number value)

获取具有给定值的刻度线的字符串标签名称。

String

Chart.getTitle​()

获取属性标题的值。

String

CategoryAxis.getValueForDisplay​(double displayPosition)

获取此轴上给定显示位置的数据值。

String

CategoryAxis.toRealValue​(double value)

所有轴值必须由某些数值表示。

String

Axis.TickMark.toString​()

返回此 TickMark对象的字符串表示形式。

String

NumberAxis.DefaultFormatter.toString​(Number object)

将提供的对象转换为其字符串形式。

String

PieChart.Data.toString​()

返回此 Data对象的字符串表示形式。

String

XYChart.Data.toString​()

返回此 Data对象的字符串表示形式。

String

XYChart.Series.toString​()

返回此 Series对象的字符串表示形式。

Methods in javafx.scene.chart that return types with arguments of type String

Modifier and Type

方法

描述

protected List<String>

CategoryAxis.calculateTickValues​(double length, Object range)

计算范围内每个刻度线的所有数据值的列表

ObservableList<String>

CategoryAxis.getCategories​()

返回在此轴上绘制的类别的ObservableList 。

ObjectProperty<String>

Axis.labelProperty​()

轴标签

Methods in javafx.scene.chart with parameters of type String

Modifier and Type

方法

描述

Number

NumberAxis.DefaultFormatter.fromString​(String string)

将提供的字符串转换为由此转换器定义的数字。

double

CategoryAxis.getDisplayPosition​(String value)

获取给定值的沿该轴的显示位置。

protected String

CategoryAxis.getTickMarkLabel​(String value)

获取具有给定值的刻度线的字符串标签名称

boolean

CategoryAxis.isValueOnAxis​(String value)

检查给定值是否在该轴上是可绘制的

protected Dimension2D

Axis.measureTickMarkLabelSize​(String labelText, double rotation)

测量给定刻度标记值的标签尺寸。

protected Dimension2D

CategoryAxis.measureTickMarkSize​(String value, Object range)

测量给定刻度标记值的标签尺寸。

void

Axis.setLabel​(String value)

设置属性标签的值。

void

Axis.TickMark.setLabel​(String value)

设置属性标签的值。

void

PieChart.Data.setName​(String value)

设置属性名称的值。

void

XYChart.Series.setName​(String value)

设置属性名称的值。

void

Chart.setTitle​(String value)

设置属性标题的值。

double

CategoryAxis.toNumericValue​(String value)

所有轴值必须由某些数值表示。

static LineChart.SortingPolicy

LineChart.SortingPolicy.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in javafx.scene.chart with type arguments of type String

Modifier and Type

方法

描述

void

CategoryAxis.invalidateRange​(List<String> data)

数据更改时调用，范围可能不再有效。

void

CategoryAxis.setCategories​(ObservableList<String> value)

在此轴上绘制的类别的有序列表。

Constructors in javafx.scene.chart with parameters of type String

Constructor

描述

Data​(String name, double value)

构造具有给定名称和值的PieChart.Data对象。

DefaultFormatter​(NumberAxis axis, String prefix, String suffix)

为给定的NumberAxis构造一个带有前缀和/或后缀的DefaultFormatter。

NumberAxis​(String axisLabel, double lowerBound, double upperBound, double tickUnit)

用给定的下限，上限和滴答单位创建非自动范围的NumberAxis。

Series​(String name, ObservableList<XYChart.Data<X,Y>> data)

构造一个命名的系列，并使用给定的ObservableList数据填充它。

Constructor parameters in javafx.scene.chart with type arguments of type String

Constructor

描述

CategoryAxis​(ObservableList<String> categories)

创建具有给定类别的类别轴。

Uses of String in javafx.scene.control

Fields in javafx.scene.control declared as String

Modifier and Type

Field

描述

static String

ButtonBar.BUTTON_ORDER_LINUX

Linux上的默认按钮排序（特别是GNOME）。

static String

ButtonBar.BUTTON_ORDER_MAC_OS

Mac OS上的默认按钮排序。

static String

ButtonBar.BUTTON_ORDER_NONE

一个按钮排序字符串，指定没有按钮排序。

static String

ButtonBar.BUTTON_ORDER_WINDOWS

Windows上的默认按钮排序。

static String

Spinner.STYLE_CLASS_ARROWS_ON_LEFT_HORIZONTAL

箭头放置在Spinner的左侧，水平（即左右）指向。

static String

Spinner.STYLE_CLASS_ARROWS_ON_LEFT_VERTICAL

箭头放置在旋钮的左侧，垂直指向（即上下）。

static String

Spinner.STYLE_CLASS_ARROWS_ON_RIGHT_HORIZONTAL

箭头放置在Spinner的右侧，水平（即左右）指向。

static String

Pagination.STYLE_CLASS_BULLET

将类型的数字页面指示符更改为子弹指示器。

static String

ColorPicker.STYLE_CLASS_BUTTON

指定一个Button的样式类就像ColorPicker控件的外观。

static String

TabPane.STYLE_CLASS_FLOATING

TabPane模式将被更改为浮动，允许TabPane与其他控件一起放置。

static String

Spinner.STYLE_CLASS_SPLIT_ARROWS_HORIZONTAL

减量箭头位于微调器的左侧，右侧的增量。

static String

Spinner.STYLE_CLASS_SPLIT_ARROWS_VERTICAL

将箭头放置在旋转器的上方和下方，拉伸以占据整个宽度。

static String

ColorPicker.STYLE_CLASS_SPLIT_BUTTON

指定SplitMenuButton的样式类，如ColorPicker控件的外观。

static String

IndexRange.VALUE_DELIMITER

索引范围值分隔符。

Fields in javafx.scene.control with type parameters of type String

Modifier and Type

Field

描述

static StringConverter<String>

TextFormatter.IDENTITY_STRING_CONVERTER

该字符串转换器将文本转换为相同的String值。

Methods in javafx.scene.control that return String

Modifier and Type

方法

描述

String

TextInputControl.Content.get​(int start, int end)

检索内容的一个子集。

String

ButtonBar.getButtonOrder​()

返回当前的 button order 。

String

Dialog.getContentText​()

返回此DialogPane的当前设置的内容文本。

String

DialogPane.getContentText​()

返回此DialogPane的当前设置的内容文本。

String

TextFormatter.Change.getControlNewText​()

获取完整的新文本，将在此更改后用于控件。

String

TextFormatter.Change.getControlText​()

这是控制在更改之前的全文。

String

TextInputDialog.getDefaultValue​()

返回在构造函数中指定的默认值。

String

Labeled.getEllipsisString​()

获取属性ellipsisString的值。

String

Dialog.getHeaderText​()

返回此DialogPane的当前设置的标题文本。

String

DialogPane.getHeaderText​()

返回此DialogPane的当前设置的标题文本。

String

MenuItem.getId​()

获取属性ID的值。

String

PopupControl.getId​()

这个id的这个 PopupControl 。

String

Tab.getId​()

此选项卡的ID。

String

TableColumnBase.getId​()

获取属性ID的值。

String

ComboBoxBase.getPromptText​()

获取属性promptText的值。

String

Spinner.getPromptText​()

获取属性promptText的值。

String

TextInputControl.getPromptText​()

获取属性promptText的值。

String

TextInputControl.getSelectedText​()

获取属性selectedText的值。

String

MenuItem.getStyle​()

获取属性样式的值。

String

PopupControl.getStyle​()

与此特定 PopupControl相关联的CSS样式的字符串表示 PopupControl 。

String

Tab.getStyle​()

与此选项卡关联的CSS样式字符串。

String

TableColumnBase.getStyle​()

获取属性样式的值。

String

ButtonType.getText​()

返回在构造函数中为此ButtonType指定的文本。

String

Labeled.getText​()

获取属性文本的值。

String

MenuItem.getText​()

获取属性文本的值。

String

Tab.getText​()

选项卡中显示的文本。

String

TableColumnBase.getText​()

获取属性文本的值。

String

TextFormatter.Change.getText​()

获取此更改中使用的文本。

String

TextInputControl.getText​()

获取属性文本的值。

String

TextInputControl.getText​(int start, int end)

返回文本输入内容的一个子集。

String

Tooltip.getText​()

获取属性文本的值。

String

Dialog.getTitle​()

返回对话框的标题。

String

ButtonBar.ButtonData.getTypeCode​()

返回在 button order字符串中用于表示ButtonData注释的单个字符代码。

String

MenuItem.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

PopupControl.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

Tab.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

TableColumn.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

TreeTableColumn.getTypeSelector​()

这种 Styleable的类型用于选择器匹配。

String

ButtonType.toString​()

返回对象的字符串表示形式。

String

DialogEvent.toString​()

返回此 DialogEvent对象的字符串表示形式。

String

IndexRange.toString​()

返回此 Range对象的字符串表示形式。

String

Labeled.toString​()

String

ListView.EditEvent.toString​()

返回此 EditEvent对象的字符串表示形式。

String

MenuItem.toString​()

String

TablePosition.toString​()

返回此 TablePosition对象的字符串表示形式。

String

TextFormatter.Change.toString​()

String

TreeItem.toString​()

返回此 TreeItem对象的字符串表示形式。

Methods in javafx.scene.control that return types with arguments of type String

Modifier and Type

方法

描述

ObservableList<String>

MenuItem.getStyleClass​()

*公开API * *

ObservableList<String>

PopupControl.getStyleClass​()

返回构成此PopupControl的styleClass的String标识符列表。

ObservableList<String>

Tab.getStyleClass​()

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

ObservableList<String>

TableColumnBase.getStyleClass​()

可用于逻辑组合节点的字符串标识符列表，专门用于外部样式引擎。

Methods in javafx.scene.control with parameters of type String

Modifier and Type

方法

描述

void

TextInputControl.appendText​(String text)

向内容追加一串字符。

void

TextInputControl.Content.insert​(int index, String text, boolean notifyListeners)

在内容中插入一串字符。

void

TextInputControl.insertText​(int index, String text)

在内容中插入一串字符。

Node

TabPane.lookup​(String selector)

根据给定的CSS选择器找到这个 Node或第一个子节点。

Set<Node>

TabPane.lookupAll​(String selector)

查找所有 Node s，包括这个和任何孩子，匹配给定的CSS选择器。

void

TextInputControl.replaceSelection​(String replacement)

用给定的替换字符串替换选择。

void

TextInputControl.replaceText​(int start, int end, String text)

用给定的文本替换一系列的字符。

void

TextInputControl.replaceText​(IndexRange range, String text)

用给定的文本替换一系列的字符。

void

ButtonBar.setButtonOrder​(String buttonOrder)

设置 button order

void

Dialog.setContentText​(String contentText)

设置在对话框内容区域显示的字符串。

void

DialogPane.setContentText​(String contentText)

设置在对话框内容区域显示的字符串。

void

Labeled.setEllipsisString​(String value)

设置属性ellipsisString的值。

void

Dialog.setHeaderText​(String headerText)

设置在对话框头部区域显示的字符串。

void

DialogPane.setHeaderText​(String headerText)

设置在对话框头部区域显示的字符串。

void

MenuItem.setId​(String value)

设置属性id的值。

void

PopupControl.setId​(String value)

设置这个 PopupControl的id。

void

Tab.setId​(String value)

设置此选项卡的ID。

void

TableColumnBase.setId​(String value)

设置属性id的值。

void

ComboBoxBase.setPromptText​(String value)

设置属性promptText的值。

void

Spinner.setPromptText​(String value)

设置属性promptText的值。

void

TextInputControl.setPromptText​(String value)

设置属性promptText的值。

void

MenuItem.setStyle​(String value)

设置属性样式的值。

void

PopupControl.setStyle​(String value)

与此特定 PopupControl相关联的CSS样式的字符串表示 PopupControl 。

void

Tab.setStyle​(String value)

与此选项卡相关联的CSS样式的字符串表示形式。

void

TableColumnBase.setStyle​(String value)

设置属性样式的值。

void

Labeled.setText​(String value)

设置属性文本的值。

void

MenuItem.setText​(String value)

设置属性文本的值。

void

Tab.setText​(String value)

将选项卡中显示的文本设置为允许用户区分每个选项卡的功能。

void

TableColumnBase.setText​(String value)

设置属性文本的值。

void

TextFormatter.Change.setText​(String value)

设置在此更改中使用的文本。

void

TextInputControl.setText​(String value)

设置属性文本的值。

void

Tooltip.setText​(String value)

设置属性文本的值。

void

Dialog.setTitle​(String title)

更改对话框的标题。

static Alert.AlertType

Alert.AlertType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ButtonBar.ButtonData

ButtonBar.ButtonData.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ContentDisplay

ContentDisplay.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static IndexRange

IndexRange.valueOf​(String value)

在“2,6”形式的字符串中解析的方便方法，它将创建一个起始值为2的IndexRange实例，最终值为6。

static OverrunStyle

OverrunStyle.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ScrollPane.ScrollBarPolicy

ScrollPane.ScrollBarPolicy.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SelectionMode

SelectionMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TableColumn.SortType

TableColumn.SortType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TabPane.TabClosingPolicy

TabPane.TabClosingPolicy.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TreeSortMode

TreeSortMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TreeTableColumn.SortType

TreeTableColumn.SortType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.scene.control with parameters of type String

Constructor

描述

Alert​(Alert.AlertType alertType, String contentText, ButtonType... buttons)

使用给定的contentText，ButtonTypes和AlertType创建警报（参考Alert.AlertType文档了解哪一个是最合适的）。

Button​(String text)

创建具有指定文本的按钮作为其标签。

Button​(String text, Node graphic)

创建一个带有指定文本和图标的按钮。

ButtonBar​(String buttonOrder)

使用给定的按钮顺序创建ButtonBar（有关详细信息，请参阅 ButtonBar.buttonOrderProperty() ）。

ButtonBase​(String text)

创建一个带有给定文本的ButtonBase。

ButtonBase​(String text, Node graphic)

创建一个带有给定文本和图形的ButtonBase。

ButtonType​(String text)

使用给定文本创建一个ButtonType实例，并将ButtonData设置为 ButtonBar.ButtonData.OTHER 。

ButtonType​(String text, ButtonBar.ButtonData buttonData)

创建一个带有给定文本的ButtonType实例，并按指定的方式设置ButtonData。

CheckBox​(String text)

创建一个带有指定文本的复选框作为其标签。

CheckMenuItem​(String text)

构造一个CheckMenuItem并设置具有指定文本的显示文本。

CheckMenuItem​(String text, Node graphic)

构造一个CheckMenuItem并设置具有指定文本的显示文本，并将图形Node设置为给定节点。

Hyperlink​(String text)

创建指定文本的超链接作为其标签。

Hyperlink​(String text, Node graphic)

创建指定文本和图形作为其标签的超链接。

Label​(String text)

创建带有提供文本的标签。

Label​(String text, Node graphic)

使用提供的文本和图形创建标签。

Labeled​(String text)

创建带有文本的标签

Labeled​(String text, Node graphic)

创建带有文本和图形的标签

Menu​(String text)

构造一个菜单，并将显示文本设置为指定的文本。

Menu​(String text, Node graphic)

构造一个菜单，并使用指定的文本设置显示文本，并将图形Node设置为给定节点。

Menu​(String text, Node graphic, MenuItem... items)

构造一个菜单，并将指定文本的显示文本，给定节点的图形Node设置，并将给定的项目插入到items列表中。

MenuButton​(String text)

创建一个新的空的菜单按钮，给定的文本显示在按钮上。

MenuButton​(String text, Node graphic)

创建一个新的空的菜单按钮，给定的文本和图形显示在按钮上。

MenuButton​(String text, Node graphic, MenuItem... items)

创建一个新的菜单按钮，给定的文本和图形显示在按钮上，并将给定的项目插入到 items列表中。

MenuItem​(String text)

构造一个MenuItem并设置具有指定文本的显示文本

MenuItem​(String text, Node graphic)

构造函数的MenuItem，并且使用指定的文本设置显示文本，并将图形Node设置为给定的节点。

RadioButton​(String text)

创建具有指定文本的单选按钮作为其标签。

RadioMenuItem​(String text)

构造一个RadioMenuItem并设置指定文本的显示文本。

RadioMenuItem​(String text, Node graphic)

构造一个RadioMenuItem并设置具有指定文本的显示文本，并将图形Node设置为给定节点。

Tab​(String text)

创建一个带有文本标题的选项卡。

Tab​(String text, Node content)

创建一个带有文本标题和指定内容节点的选项卡。

TableColumn​(String text)

创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

TableColumnBase​(String text)

创建一个TableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

TextArea​(String text)

创建一个 TextArea与初始文本内容。

TextField​(String text)

创建一个 TextField与初始文本内容。

TextInputDialog​(String defaultValue)

创建一个新的TextInputDialog，其默认值输入到对话框TextField中 。

TitledPane​(String title, Node content)

创建一个标题和内容的新TitledPane。

ToggleButton​(String text)

创建具有指定文本的切换按钮作为其标签。

ToggleButton​(String text, Node graphic)

创建一个切换按钮，其标签具有指定的文本和图标。

Tooltip​(String text)

用指定的文本创建一个工具提示。

TreeTableColumn​(String text)

创建一个TreeTableColumn，文本设置为提供的字符串，默认单元格工厂，比较器和onEditCommit实现。

Uses of String in javafx.scene.control.cell

Methods in javafx.scene.control.cell that return String

Modifier and Type

方法

描述

String

PropertyValueFactory.getProperty​()

返回构造函数中提供的属性名称。

String

TreeItemPropertyValueFactory.getProperty​()

返回构造函数中提供的属性名称。

Methods in javafx.scene.control.cell that return types with arguments of type String

Modifier and Type

方法

描述

static Callback<ListView<String>,ListCell<String>>

TextFieldListCell.forListView​()

提供TextField ，允许在双击单元格时调用单元格内容，或调用ListView.edit(int)时。

static Callback<ListView<String>,ListCell<String>>

TextFieldListCell.forListView​()

提供TextField ，允许在双击单元格时调用单元格内容，或者调用ListView.edit(int)时。

static <S> Callback<TableColumn<S,String>,TableCell<S,String>>

TextFieldTableCell.forTableColumn​()

提供TextField ，允许在双击单元格时调用单元格内容，或调用TableView.edit(int, javafx.scene.control.TableColumn)时。

static <S> Callback<TableColumn<S,String>,TableCell<S,String>>

TextFieldTableCell.forTableColumn​()

提供TextField ，允许在双击单元格时调用单元格内容，或者调用TableView.edit(int, javafx.scene.control.TableColumn)时。

static <S> Callback<TreeTableColumn<S,String>,TreeTableCell<S,String>>

TextFieldTreeTableCell.forTreeTableColumn​()

提供TextField ，允许在双击单元格时调用单元格内容，或调用TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)时。

static <S> Callback<TreeTableColumn<S,String>,TreeTableCell<S,String>>

TextFieldTreeTableCell.forTreeTableColumn​()

提供TextField ，使单元格内容的编辑在小区双击，或者当TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)被调用。

static Callback<TreeView<String>,TreeCell<String>>

TextFieldTreeCell.forTreeView​()

提供TextField ，允许在单元格双击时或当调用TreeView.edit(javafx.scene.control.TreeItem)时编辑单元格内容。

static Callback<TreeView<String>,TreeCell<String>>

TextFieldTreeCell.forTreeView​()

提供一个TextField ，允许双击单元格时或当调用TreeView.edit(javafx.scene.control.TreeItem)时编辑单元格内容。

Constructors in javafx.scene.control.cell with parameters of type String

Constructor

描述

PropertyValueFactory​(String property)

创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。

TreeItemPropertyValueFactory​(String property)

创建一个默认的PropertyValueFactory，使用给定的属性名称反射地从给定的TableView行项中提取值。

Uses of String in javafx.scene.control.skin

Methods in javafx.scene.control.skin that return String

Modifier and Type

方法

描述

protected String

TextFieldSkin.maskText​(String txt)

子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。

protected String

TextInputControlSkin.maskText​(String txt)

子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。

Methods in javafx.scene.control.skin with parameters of type String

Modifier and Type

方法

描述

protected String

TextFieldSkin.maskText​(String txt)

子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。

protected String

TextInputControlSkin.maskText​(String txt)

子类可以覆盖此方法来替换显示的字符而不影响实际的文本内容。

void

TextFieldSkin.replaceText​(int start, int end, String txt)

用给定的文本替换一系列的字符。

static TextInputControlSkin.Direction

TextInputControlSkin.Direction.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TextInputControlSkin.TextUnit

TextInputControlSkin.TextUnit.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.scene.effect

Methods in javafx.scene.effect with parameters of type String

Modifier and Type

方法

描述

static BlendMode

BlendMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static BlurType

BlurType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.scene.image

Methods in javafx.scene.image that return String

Modifier and Type

方法

描述

String

Image.getUrl​()

返回用于获取Image实例中包含的像素数据的URL，如果在构造函数中指定。

Methods in javafx.scene.image with parameters of type String

Modifier and Type

方法

描述

static PixelFormat.Type

PixelFormat.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.scene.image with parameters of type String

Constructor

描述

Image​(String url)

构造一个 Image其中包含从指定的url加载的内容。

Image​(String url, boolean backgroundLoading)

使用指定的参数构建新的 Image 。

Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth)

使用指定的参数构建新的 Image 。

Image​(String url, double requestedWidth, double requestedHeight, boolean preserveRatio, boolean smooth, boolean backgroundLoading)

使用指定的参数构造新的 Image 。

ImageView​(String url)

分配一个新的ImageView对象，并从指定的URL加载图像。

Uses of String in javafx.scene.input

Fields in javafx.scene.input declared as String

Modifier and Type

Field

描述

static String

KeyEvent.CHAR_UNDEFINED

KEY_PRESSED和KEY_RELEASED事件不映射到一个有效的Unicode字符使用它作为keyChar值。

Methods in javafx.scene.input that return String

Modifier and Type

方法

描述

String

KeyCode.getChar​()

返回此键代码的字符元素，这只是 KeyCode.getCode()返回的底层平台代码的 映射 。

String

KeyCharacterCombination.getCharacter​()

获取与该组合关联的关键字符。

String

KeyEvent.getCharacter​()

与键类型事件相关联的Unicode字符或字符序列。

String

InputMethodEvent.getCommitted​()

作为组合的结果，获取输入法提交的文本。

String

KeyCharacterCombination.getDisplayText​()

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

String

KeyCodeCombination.getDisplayText​()

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

String

KeyCombination.getDisplayText​()

返回适用于在用户界面中显示的 KeyCombination的字符串表示（例如，在菜单项旁边）。

String

Clipboard.getHtml​()

从以前注册的剪贴板获取HTML文本字符串。

String

ClipboardContent.getHtml​()

从之前被放置的 ClipboardContent获取HTML字符串。

String

KeyCharacterCombination.getName​()

返回此 KeyCharacterCombination的字符串表示 KeyCharacterCombination 。

String

KeyCode.getName​()

获取此密钥代码的名称。

String

KeyCodeCombination.getName​()

返回此 KeyCodeCombination的字符串表示 KeyCodeCombination 。

String

KeyCombination.getName​()

返回此 KeyCombination的字符串表示 KeyCombination 。

String

Clipboard.getRtf​()

从以前注册的剪贴板获取RTF文本字符串。

String

ClipboardContent.getRtf​()

从以前已经放置的 ClipboardContent获取RTF字符串。

String

InputMethodRequests.getSelectedText​()

从文本编辑节点获取当前选定的文本。

String

Clipboard.getString​()

从以前注册的剪贴板中获取纯文本字符串。

String

ClipboardContent.getString​()

从以前已经放置的 ClipboardContent获取纯文本字符串。

String

InputMethodTextRun.getText​()

获取此运行中的文本。

String

KeyEvent.getText​()

描述按键和键释放事件的键代码的字符串，如“HOME”，“F1”或“A”。

String

Clipboard.getUrl​()

从先前已注册的剪贴板获取URL字符串。

String

ClipboardContent.getUrl​()

从先前已被放置的 ClipboardContent获取URL字符串。

String

ContextMenuEvent.toString​()

返回此 ContextMenuEvent对象的字符串表示形式。

String

DataFormat.toString​()

返回此 DataFormat对象的字符串表示形式。

String

GestureEvent.toString​()

返回此 GestureEvent对象的字符串表示形式。

String

InputMethodEvent.toString​()

返回此 InputMethodEvent对象的字符串表示形式。

String

InputMethodTextRun.toString​()

返回此 InputMethodTextRun对象的字符串表示形式。

String

KeyCombination.Modifier.toString​()

返回修饰符的字符串表示形式。

String

KeyCombination.toString​()

返回此对象的字符串表示形式。

String

KeyEvent.toString​()

返回此 KeyEvent对象的字符串表示形式。

String

MouseDragEvent.toString​()

返回此 MouseDragEvent对象的字符串表示形式。

String

MouseEvent.toString​()

返回此 MouseEvent对象的字符串表示形式。

String

PickResult.toString​()

String

RotateEvent.toString​()

返回此 RotateEvent对象的字符串表示形式。

String

ScrollEvent.toString​()

返回此 ScrollEvent对象的字符串表示形式。

String

SwipeEvent.toString​()

返回此 SwipeEvent对象的字符串表示形式。

String

TouchEvent.toString​()

返回此 TouchEvent对象的字符串表示形式。

String

TouchPoint.toString​()

返回此 TouchPoint对象的字符串表示形式。

String

ZoomEvent.toString​()

返回此 ZoomEvent对象的字符串表示形式。

Methods in javafx.scene.input that return types with arguments of type String

Modifier and Type

方法

描述

Set<String>

DataFormat.getIdentifiers​()

获取此DataFormat的不可修改的标识符集。

Methods in javafx.scene.input with parameters of type String

Modifier and Type

方法

描述

static KeyCode

KeyCode.getKeyCode​(String name)

解析一个键的文本表示。

static KeyCombination

KeyCombination.keyCombination​(String name)

从指定的字符串构造一个新的 KeyCombination 。

static DataFormat

DataFormat.lookupMimeType​(String mimeType)

查找之前使用给定的MIME类型创建的DataFormat作为其IDID之一。

boolean

ClipboardContent.putHtml​(String html)

将一个HTML字符串放入 ClipboardContent 。

boolean

ClipboardContent.putRtf​(String rtf)

将RTF字符串放入 ClipboardContent 。

boolean

ClipboardContent.putString​(String s)

将纯文本字符串插入到 ClipboardContent 。

boolean

ClipboardContent.putUrl​(String url)

将一个URL字符串放入 ClipboardContent 。

static InputMethodHighlight

InputMethodHighlight.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static KeyCode

KeyCode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static KeyCombination.ModifierValue

KeyCombination.ModifierValue.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static KeyCombination

KeyCombination.valueOf​(String value)

从指定的字符串构造一个新的 KeyCombination 。

static MouseButton

MouseButton.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ScrollEvent.HorizontalTextScrollUnits

ScrollEvent.HorizontalTextScrollUnits.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ScrollEvent.VerticalTextScrollUnits

ScrollEvent.VerticalTextScrollUnits.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TouchPoint.State

TouchPoint.State.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TransferMode

TransferMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in javafx.scene.input with type arguments of type String

Modifier and Type

方法

描述

boolean

ClipboardContent.putFilesByPath​(List<String> filePaths)

根据文件路径将文件列表放入 ClipboardContent 。

Constructors in javafx.scene.input with parameters of type String

Constructor

描述

DataFormat​(String... ids)

创建一个新的DataFormat，指定与此数据格式相关联的ids集。

InputMethodEvent​(Object source, EventTarget target, EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)

构造新的InputMethodEvent事件。

InputMethodEvent​(EventType<InputMethodEvent> eventType, List<InputMethodTextRun> composed, String committed, int caretPosition)

构造具有空源和目标的新的InputMethodEvent事件。

InputMethodTextRun​(String text, InputMethodHighlight highlight)

构造输入法的单个文本运行。

KeyCharacterCombination​(String character, KeyCombination.Modifier... modifiers)

为指定的主键字符和指定的修饰符列表构造一个 KeyCharacterCombination 。

KeyCharacterCombination​(String character, KeyCombination.ModifierValue shift, KeyCombination.ModifierValue control, KeyCombination.ModifierValue alt, KeyCombination.ModifierValue meta, KeyCombination.ModifierValue shortcut)

为指定的主键字符构建一个 KeyCharacterCombination ，并显式指定所有修改键。

KeyEvent​(Object source, EventTarget target, EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)

从指定的参数构造一个新的 KeyEvent事件。

KeyEvent​(EventType<KeyEvent> eventType, String character, String text, KeyCode code, boolean shiftDown, boolean controlDown, boolean altDown, boolean metaDown)

从指定的参数构建新的 KeyEvent事件，其中包含一个 null源和目标。

Uses of String in javafx.scene.layout

Methods in javafx.scene.layout that return String

Modifier and Type

方法

描述

String

Region.getUserAgentStylesheet​()

实现可以通过覆盖此方法来为该Region及其子项指定其自己的用户代理样式。

String

BorderStrokeStyle.toString​()

返回对象的字符串表示形式。

String

ColumnConstraints.toString​()

返回此 ColumnConstraints对象的字符串表示形式。

String

CornerRadii.toString​()

String

GridPane.toString​()

返回此 GridPane对象的字符串表示形式。

String

RowConstraints.toString​()

返回此 RowConstraints对象的字符串表示形式。

Methods in javafx.scene.layout with parameters of type String

Modifier and Type

方法

描述

static BackgroundRepeat

BackgroundRepeat.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static BorderRepeat

BorderRepeat.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Priority

Priority.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.scene.media

Methods in javafx.scene.media that return String

Modifier and Type

方法

描述

String

AudioTrack.getLanguage​()

已过时。
改用Track.getLocale() 。

String

Track.getName​()

检索轨道的名称。

String

AudioClip.getSource​()

获取用于创建此源的源URL AudioClip 。

String

Media.getSource​()

检索媒体的源URI。

String

MediaErrorEvent.toString​()

检索事件的 String表示。

String

MediaException.toString​()

返回此 MediaException对象的字符串表示形式。

String

Track.toString​()

Methods in javafx.scene.media that return types with arguments of type String

Modifier and Type

方法

描述

Pair<String,Duration>

MediaMarkerEvent.getMarker​()

检索事件代表的标记。

ObservableMap<String,Duration>

Media.getMarkers​()

检索此 Media实例上定义的标记。

ObservableMap<String,Object>

Media.getMetadata​()

检索此媒体源中包含的元数据。

Map<String,Object>

Track.getMetadata​()

Methods in javafx.scene.media with parameters of type String

Modifier and Type

方法

描述

static MediaException.Type

MediaException.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static MediaPlayer.Status

MediaPlayer.Status.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.scene.media with parameters of type String

Constructor

描述

AudioClip​(String source)

从提供的源URL创建一个 AudioClip 。

Media​(String source)

构造一个 Media实例。

Uses of String in javafx.scene.paint

Methods in javafx.scene.paint that return String

Modifier and Type

方法

描述

String

Color.toString​()

返回此 Color的字符串表示 Color 。

String

LinearGradient.toString​()

返回此 LinearGradient对象的字符串表示形式。

String

PhongMaterial.toString​()

String

RadialGradient.toString​()

返回此 RadialGradient对象的字符串表示形式。

String

Stop.toString​()

返回此 Stop对象的字符串表示形式。

Methods in javafx.scene.paint with parameters of type String

Modifier and Type

方法

描述

static Color

Color.valueOf​(String value)

从字符串表示形式创建颜色值。

static CycleMethod

CycleMethod.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static LinearGradient

LinearGradient.valueOf​(String value)

从字符串表示形成线性渐变值。

static Paint

Paint.valueOf​(String value)

从字符串表示形式创建一个绘制值。

static RadialGradient

RadialGradient.valueOf​(String value)

从字符串表示形成径向渐变值。

static Color

Color.web​(String colorString)

创建使用HTML或CSS属性字符串指定的RGB颜色。

static Color

Color.web​(String colorString, double opacity)

创建使用HTML或CSS属性字符串指定的RGB颜色。

Uses of String in javafx.scene.shape

Methods in javafx.scene.shape that return String

Modifier and Type

方法

描述

String

SVGPath.getContent​()

获取属性内容的值。

String

Arc.toString​()

返回此 Arc对象的字符串表示形式。

String

ArcTo.toString​()

返回此 ArcTo对象的字符串表示形式。

String

Circle.toString​()

返回此 Circle对象的字符串表示形式。

String

ClosePath.toString​()

返回此 ArcTo对象的字符串表示形式。

String

CubicCurve.toString​()

返回此 CubicCurve对象的字符串表示形式。

String

CubicCurveTo.toString​()

返回此 CubicCurveTo对象的字符串表示形式。

String

Ellipse.toString​()

返回此 Ellipse对象的字符串表示形式。

String

HLineTo.toString​()

返回此 HLineTo对象的字符串表示形式。

String

Line.toString​()

返回此 Line对象的字符串表示形式。

String

LineTo.toString​()

返回此 LineTo对象的字符串表示形式。

String

MoveTo.toString​()

返回此 MoveTo对象的字符串表示形式。

String

Path.toString​()

返回此 Path对象的字符串表示形式。

String

Polygon.toString​()

返回此 Polygon对象的字符串表示形式。

String

Polyline.toString​()

返回此 Polyline对象的字符串表示形式。

String

QuadCurve.toString​()

返回此 QuadCurve对象的字符串表示形式。

String

QuadCurveTo.toString​()

返回此 CubicCurveTo对象的字符串表示形式。

String

Rectangle.toString​()

返回此 Rectangle对象的字符串表示形式。

String

SVGPath.toString​()

返回此 SVGPath对象的字符串表示形式。

String

VertexFormat.toString​()

String

VLineTo.toString​()

返回此 VLineTo对象的字符串表示形式。

Methods in javafx.scene.shape with parameters of type String

Modifier and Type

方法

描述

void

SVGPath.setContent​(String value)

设置属性内容的值。

static ArcType

ArcType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static CullFace

CullFace.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static DrawMode

DrawMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static FillRule

FillRule.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StrokeLineCap

StrokeLineCap.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StrokeLineJoin

StrokeLineJoin.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StrokeType

StrokeType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javafx.scene.text

Methods in javafx.scene.text that return String

Modifier and Type

方法

描述

String

Font.getFamily​()

返回此字体的系列。

String

Font.getName​()

完整的字体名称。

String

Font.getStyle​()

描述字体系列中的样式的字体指定字符串。

String

Text.getText​()

获取属性文本的值。

String

Font.toString​()

将此 Font对象转换为 String表示。

String

HitInfo.toString​()

String

Text.toString​()

返回此 Text对象的字符串表示形式。

Methods in javafx.scene.text that return types with arguments of type String

Modifier and Type

方法

描述

static List<String>

Font.getFamilies​()

获取用户系统上安装的所有字体，包括任何应用程序字体或SDK字体。

static List<String>

Font.getFontNames​()

获取用户系统上安装的所有字体的名称，包括任何应用程序字体和SDK字体。

static List<String>

Font.getFontNames​(String family)

获取用户系统上安装的指定字体系列中所有字体的名称，包括任何应用程序字体和SDK字体。

Methods in javafx.scene.text with parameters of type String

Modifier and Type

方法

描述

static FontPosture

FontPosture.findByName​(String name)

以其名称返回 FontPosture 。

static FontWeight

FontWeight.findByName​(String name)

以其名称返回 FontWeight 。

static Font

Font.font​(String family)

根据给定的字体系列名称和默认字体大小搜索适当的字体。

static Font

Font.font​(String family, double size)

根据字体系列名称和大小搜索适当的字体。

static Font

Font.font​(String family, FontPosture posture, double size)

根据字体系列名称和姿势样式，搜索适合的字体。

static Font

Font.font​(String family, FontWeight weight, double size)

根据字体系列名称和体重样式搜索适当的字体。

static Font

Font.font​(String family, FontWeight weight, FontPosture posture, double size)

根据字体系列名称，体重和姿势样式搜索适当的字体。

static List<String>

Font.getFontNames​(String family)

获取用户系统上安装的指定字体系列中所有字体的名称，包括任何应用程序字体和SDK字体。

static Font

Font.loadFont​(String urlStr, double size)

从指定的URL加载字体资源。

static Font[]

Font.loadFonts​(String urlStr, double size)

从指定的URL加载字体资源。

void

Text.setText​(String value)

设置属性文本的值。

static FontPosture

FontPosture.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static FontSmoothingType

FontSmoothingType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static FontWeight

FontWeight.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TextAlignment

TextAlignment.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static TextBoundsType

TextBoundsType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.scene.text with parameters of type String

Constructor

描述

Font​(String name, double size)

使用指定的正面名称和大小构造字体

Text​(double x, double y, String text)

在包含给定字符串的给定坐标上创建一个Text实例。

Text​(String text)

创建一个包含给定字符串的文本的实例。

Uses of String in javafx.scene.transform

Methods in javafx.scene.transform that return String

Modifier and Type

方法

描述

String

Affine.toString​()

返回此 Affine对象的字符串表示形式。

String

Rotate.toString​()

返回此 Rotate对象的字符串表示形式。

String

Scale.toString​()

返回此 Scale对象的字符串表示形式。

String

Shear.toString​()

返回此 Shear对象的字符串表示形式。

String

Translate.toString​()

返回此 Translate对象的字符串表示形式。

Methods in javafx.scene.transform with parameters of type String

Modifier and Type

方法

描述

static MatrixType

MatrixType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.scene.transform with parameters of type String

Constructor

描述

NonInvertibleTransformException​(String message)

使用指定的详细消息创建一个新实例 NonInvertibleTransformException 。

Uses of String in javafx.scene.web

Methods in javafx.scene.web that return String

Modifier and Type

方法

描述

String

HTMLEditorSkin.Command.getCommand​()

String

PromptData.getDefaultValue​()

返回此数据对象携带的默认值。

String

HTMLEditor.getHtmlText​()

返回编辑器的HTML内容。

String

WebEngine.getLocation​()

获取属性位置的值。

String

PromptData.getMessage​()

返回此数据对象携带的消息。

String

WebErrorEvent.getMessage​()

返回与此事件关联的文本消息。

String

WebEngine.getTitle​()

获取属性标题的值。

String

WebHistory.Entry.getTitle​()

获取属性标题的值。

String

WebHistory.Entry.getUrl​()

返回页面的URL。

String

WebEngine.getUserAgent​()

获取属性userAgent的值。

String

WebEngine.getUserStyleSheetLocation​()

获取属性userStyleSheetLocation的值。

String

WebErrorEvent.toString​()

返回此EventObject的String表示形式。

String

WebEvent.toString​()

返回此 WebEvent对象的字符串表示形式。

String

WebHistory.Entry.toString​()

Methods in javafx.scene.web that return types with arguments of type String

Modifier and Type

方法

描述

ObjectProperty<Callback<String,Boolean>>

WebEngine.confirmHandlerProperty​()

JavaScript confirm处理程序属性。

Callback<String,Boolean>

WebEngine.getConfirmHandler​()

获取属性confirmHandler的值。

EventHandler<WebEvent<String>>

WebEngine.getOnAlert​()

获取属性onAlert的值。

EventHandler<WebEvent<String>>

WebEngine.getOnStatusChanged​()

获取属性onStatusChanged的值。

Callback<PromptData,String>

WebEngine.getPromptHandler​()

获取属性promptHandler的值。

ObjectProperty<EventHandler<WebEvent<String>>>

WebEngine.onAlertProperty​()

JavaScript alert处理程序属性。

ObjectProperty<EventHandler<WebEvent<String>>>

WebEngine.onStatusChangedProperty​()

JavaScript状态处理程序属性。

ObjectProperty<Callback<PromptData,String>>

WebEngine.promptHandlerProperty​()

JavaScript prompt处理程序属性。

ReadOnlyObjectProperty<String>

WebHistory.Entry.titleProperty​()

定义页面的标题。

Methods in javafx.scene.web with parameters of type String

Modifier and Type

方法

描述

Object

WebEngine.executeScript​(String script)

在当前页面的上下文中执行脚本。

void

WebEngine.load​(String url)

将网页加载到此引擎中。

void

WebEngine.loadContent​(String content)

直接加载给定的HTML内容。

void

WebEngine.loadContent​(String content, String contentType)

直接载入给定的内容。

void

HTMLEditor.setHtmlText​(String htmlText)

设置编辑器的HTML内容。

void

WebEngine.setUserAgent​(String value)

设置属性userAgent的值。

void

WebEngine.setUserStyleSheetLocation​(String value)

设置属性userStyleSheetLocation的值。

static HTMLEditorSkin.Command

HTMLEditorSkin.Command.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in javafx.scene.web with type arguments of type String

Modifier and Type

方法

描述

void

WebEngine.setConfirmHandler​(Callback<String,Boolean> handler)

设置属性confirmHandler的值。

void

WebEngine.setOnAlert​(EventHandler<WebEvent<String>> handler)

设置属性onAlert的值。

void

WebEngine.setOnStatusChanged​(EventHandler<WebEvent<String>> handler)

设置属性onStatusChanged的值。

void

WebEngine.setPromptHandler​(Callback<PromptData,String> handler)

设置属性promptHandler的值。

Constructors in javafx.scene.web with parameters of type String

Constructor

描述

PromptData​(String message, String defaultValue)

创建一个新的实例。

WebEngine​(String url)

创建一个新的引擎并加载一个网页。

WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)

创建一个新的 WebErrorEvent 。

Uses of String in javafx.stage

Methods in javafx.stage that return String

Modifier and Type

方法

描述

String

FileChooser.ExtensionFilter.getDescription​()

获取此 ExtensionFilter的说明。

String

Stage.getFullScreenExitHint​()

获取属性fullScreenExitHint的值。

String

FileChooser.getInitialFileName​()

获取属性initialFileName的值。

String

DirectoryChooser.getTitle​()

获取属性标题的值。

String

FileChooser.getTitle​()

获取属性标题的值。

String

Stage.getTitle​()

获取属性标题的值。

String

Screen.toString​()

返回此 Screen对象的字符串表示形式。

String

WindowEvent.toString​()

返回此 WindowEvent对象的字符串表示形式。

Methods in javafx.stage that return types with arguments of type String

Modifier and Type

方法

描述

ObjectProperty<String>

Stage.fullScreenExitHintProperty​()

List<String>

FileChooser.ExtensionFilter.getExtensions​()

获取此 ExtensionFilter的文件扩展名。

ObjectProperty<String>

FileChooser.initialFileNameProperty​()

显示对话框的初始文件名。

Methods in javafx.stage with parameters of type String

Modifier and Type

方法

描述

void

Stage.setFullScreenExitHint​(String value)

指定用户进入全屏模式时显示的文字，通常用于指示用户从全屏模式退出的方式。

void

FileChooser.setInitialFileName​(String value)

设置属性initialFileName的值。

void

DirectoryChooser.setTitle​(String value)

设置属性标题的值。

void

FileChooser.setTitle​(String value)

设置属性标题的值。

void

Stage.setTitle​(String value)

设置属性标题的值。

static Modality

Modality.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static PopupWindow.AnchorLocation

PopupWindow.AnchorLocation.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StageStyle

StageStyle.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javafx.stage with parameters of type String

Constructor

描述

ExtensionFilter​(String description, String... extensions)

创建一个具有指定描述和文件扩展名的 ExtensionFilter 。

ExtensionFilter​(String description, List<String> extensions)

创建一个具有指定描述和文件扩展名的 ExtensionFilter 。

Constructor parameters in javafx.stage with type arguments of type String

Constructor

描述

ExtensionFilter​(String description, List<String> extensions)

创建一个具有指定描述和文件扩展名的 ExtensionFilter 。

Uses of String in javafx.util

Methods in javafx.util that return String

Modifier and Type

方法

描述

String

Duration.toString​()

返回此 Duration对象的字符串表示形式。

String

Pair.toString​()

String这个 Pair表示。

abstract String

StringConverter.toString​(T object)

将提供的对象转换为其字符串形式。

Methods in javafx.util with parameters of type String

Modifier and Type

方法

描述

abstract T

StringConverter.fromString​(String string)

将提供的字符串转换为由特定转换器定义的对象。

static Duration

Duration.valueOf​(String time)

在一段指定时间内返回一个Duration实例的Factory方法。

Constructors in javafx.util with parameters of type String

Constructor

描述

FXPermission​(String name)

创建一个新的指定名称的 FXPermission 。

Uses of String in javafx.util.converter

Fields in javafx.util.converter declared as String

Modifier and Type

Field

描述

protected String

DateTimeStringConverter.pattern

Methods in javafx.util.converter that return String

Modifier and Type

方法

描述

String

DefaultStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

String

BigDecimalStringConverter.toString​(BigDecimal value)

将提供的对象转换为其字符串形式。

String

BigIntegerStringConverter.toString​(BigInteger value)

将提供的对象转换为其字符串形式。

String

BooleanStringConverter.toString​(Boolean value)

将提供的对象转换为其字符串形式。

String

ByteStringConverter.toString​(Byte value)

将提供的对象转换为其字符串形式。

String

CharacterStringConverter.toString​(Character value)

将提供的对象转换为其字符串形式。

String

DateTimeStringConverter.toString​(Date value)

将提供的对象转换为其字符串形式。

String

DefaultStringConverter.toString​(String value)

将提供的对象转换为其字符串形式。

String

DoubleStringConverter.toString​(Double value)

将提供的对象转换为其字符串形式。

String

FloatStringConverter.toString​(Float value)

将提供的对象转换为其字符串形式。

String

FormatStringConverter.toString​(T value)

将提供的对象转换为其字符串形式。

String

IntegerStringConverter.toString​(Integer value)

将提供的对象转换为其字符串形式。

String

LocalDateStringConverter.toString​(LocalDate value)

将提供的对象转换为其字符串形式。

String

LocalDateTimeStringConverter.toString​(LocalDateTime value)

将提供的对象转换为其字符串形式。

String

LocalTimeStringConverter.toString​(LocalTime value)

将提供的对象转换为其字符串形式。

String

LongStringConverter.toString​(Long value)

将提供的对象转换为其字符串形式。

String

NumberStringConverter.toString​(Number value)

将提供的对象转换为其字符串形式。

String

ShortStringConverter.toString​(Short value)

将提供的对象转换为其字符串形式。

Methods in javafx.util.converter with parameters of type String

Modifier and Type

方法

描述

BigDecimal

BigDecimalStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

BigInteger

BigIntegerStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Boolean

BooleanStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Byte

ByteStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Character

CharacterStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Date

DateTimeStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

String

DefaultStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Double

DoubleStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Float

FloatStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

T

FormatStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Integer

IntegerStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

LocalDate

LocalDateStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

LocalDateTime

LocalDateTimeStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

LocalTime

LocalTimeStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Long

LongStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Number

NumberStringConverter.fromString​(String value)

将提供的字符串转换为由特定转换器定义的对象。

Short

ShortStringConverter.fromString​(String text)

将提供的字符串转换为由特定转换器定义的对象。

String

DefaultStringConverter.toString​(String value)

将提供的对象转换为其字符串形式。

Constructors in javafx.util.converter with parameters of type String

Constructor

描述

CurrencyStringConverter​(String pattern)

CurrencyStringConverter​(Locale locale, String pattern)

DateStringConverter​(String pattern)

使用指定的模式为Date创建一个StringConverter值。

DateStringConverter​(Locale locale, String pattern)

使用指定的区域设置和模式为Date创建一个StringConverter值。

DateTimeStringConverter​(String pattern)

使用指定的模式为Date创建一个StringConverter值。

DateTimeStringConverter​(Locale locale, String pattern)

创建StringConverter为Date值，使用指定的语言环境和模式。

NumberStringConverter​(String pattern)

NumberStringConverter​(Locale locale, String pattern)

TimeStringConverter​(String pattern)

创建StringConverter为Date值，使用指定的模式。

TimeStringConverter​(Locale locale, String pattern)

创建StringConverter为Date值，使用指定的语言环境和模式。

Uses of String in javax.accessibility

Fields in javax.accessibility declared as String

Modifier and Type

Field

描述

static String

AccessibleContext.ACCESSIBLE_ACTION_PROPERTY

常数用于指示受支持的操作集已更改。

static String

AccessibleContext.ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY

用于确定组件的活动后代何时已更改的常数。

static String

AccessibleContext.ACCESSIBLE_CARET_PROPERTY

常数用于确定 accessibleText插入符号何时发生变化。

static String

AccessibleContext.ACCESSIBLE_CHILD_PROPERTY

常数用于确定何时 Accessible孩子被添加/从对象中删除。

static String

AccessibleContext.ACCESSIBLE_COMPONENT_BOUNDS_CHANGED

PropertyChangeEvent ，其指示组件边界中发生更改。

static String

AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY

常数用于确定何时 AccessibleContext.accessibleDescription属性已更改。

static String

AccessibleContext.ACCESSIBLE_HYPERTEXT_OFFSET

用于指示超文本元素已经接收焦点的常数。

static String

AccessibleContext.ACCESSIBLE_INVALIDATE_CHILDREN

PropertyChangeEvent ，这表明一个组件的孩子，如树或文本发生了重大变化。

static String

AccessibleContext.ACCESSIBLE_NAME_PROPERTY

常数用于确定何时 AccessibleContext.accessibleName属性已更改。

static String

AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY

常数用于确定 accessibleSelection发生变化。

static String

AccessibleContext.ACCESSIBLE_STATE_PROPERTY

常数用于确定何时 accessibleStateSet属性已更改。

static String

AccessibleContext.ACCESSIBLE_TABLE_CAPTION_CHANGED

常数用于表示表格已更改。

static String

AccessibleContext.ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED

常数用于指示列描述已更改。

static String

AccessibleContext.ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED

常量用于指示列标题已更改。

static String

AccessibleContext.ACCESSIBLE_TABLE_MODEL_CHANGED

用于表示表数据已更改的常数。

static String

AccessibleContext.ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED

常数用于指示行描述已更改。

static String

AccessibleContext.ACCESSIBLE_TABLE_ROW_HEADER_CHANGED

用于指示行标题已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_SUMMARY_CHANGED

常数用于表示表格摘要已更改。

static String

AccessibleContext.ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED

PropertyChangeEvent ，表示文本属性已更改。

static String

AccessibleContext.ACCESSIBLE_TEXT_PROPERTY

PropertyChangeEvent ，表示文本已更改。

static String

AccessibleContext.ACCESSIBLE_VALUE_PROPERTY

常数用于确定何时 accessibleValue属性已更改。

static String

AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

用于确定对象的视觉外观何时改变的常数。

protected String

AccessibleContext.accessibleDescription

包含对象描述的本地化字符串。

protected String

AccessibleContext.accessibleName

包含对象名称的本地化字符串。

static String

AccessibleRelation.CHILD_NODE_OF

表示对象是一个或多个对象的子节点。

static String

AccessibleRelation.CHILD_NODE_OF_PROPERTY

表示两个或多个对象之间的 CHILD_NODE_OF关系已更改。

static String

AccessibleAction.CLICK

使组件执行其默认操作的操作。

static String

AccessibleRelation.CONTROLLED_BY

表示对象由一个或多个目标对象控制。

static String

AccessibleRelation.CONTROLLED_BY_PROPERTY

标识正在进行控制的目标对象已更改。

static String

AccessibleRelation.CONTROLLER_FOR

表示对象是一个或多个目标对象的控制器。

static String

AccessibleRelation.CONTROLLER_FOR_PROPERTY

标识目标对象的控制器已更改。

static String

AccessibleAction.DECREMENT

减少值的动作。

static String

AccessibleRelation.EMBEDDED_BY

表示对象嵌入到一个或多个对象中。

static String

AccessibleRelation.EMBEDDED_BY_PROPERTY

表示两个或多个对象之间的 EMBEDDED_BY关系已更改。

static String

AccessibleRelation.EMBEDS

表示对象中嵌入了一个或多个对象。

static String

AccessibleRelation.EMBEDS_PROPERTY

表示两个或多个对象之间的 EMBEDS关系已更改。

static String

AccessibleRelation.FLOWS_FROM

表示一个对象与第二个对象在逻辑上邻接，第二个对象发生在对象之前。

static String

AccessibleRelation.FLOWS_FROM_PROPERTY

表示两个对象之间的 FLOWS_FROM关系已更改。

static String

AccessibleRelation.FLOWS_TO

表示对象与第二个对象在逻辑上邻接，第二个对象发生在对象之后。

static String

AccessibleRelation.FLOWS_TO_PROPERTY

表示 FLOWS_TO两个对象之间的关系发生了变化。

static String

AccessibleAction.INCREMENT

增加值的动作。

protected String

AccessibleBundle.key

州的独立名称。

static String

AccessibleRelation.LABEL_FOR

表示一个对象是一个或多个目标对象的标签。

static String

AccessibleRelation.LABEL_FOR_PROPERTY

标识标签的目标组已更改。

static String

AccessibleRelation.LABELED_BY

表示一个对象被一个或多个目标对象标记。

static String

AccessibleRelation.LABELED_BY_PROPERTY

标识正在进行标签的对象已更改。

static String

AccessibleRelation.MEMBER_OF

表示对象是一个或多个目标对象组的成员。

static String

AccessibleRelation.MEMBER_OF_PROPERTY

标识组成员资格已更改。

static String

AccessibleRelation.PARENT_WINDOW_OF

表示对象是一个或多个对象的父窗口。

static String

AccessibleRelation.PARENT_WINDOW_OF_PROPERTY

表示两个或多个对象之间的 PARENT_WINDOW_OF关系已更改。

static String

AccessibleRelation.SUBWINDOW_OF

表示对象是一个或多个对象的子窗口。

static String

AccessibleRelation.SUBWINDOW_OF_PROPERTY

表示两个或多个对象之间的 SUBWINDOW_OF关系已更改。

String

AccessibleTextSequence.text

文本。

static String

AccessibleAction.TOGGLE_EXPAND

如果展开并导致树状节点折叠的动作，如果已折叠则展开。

static String

AccessibleAction.TOGGLE_POPUP

一个弹出窗口在隐藏并隐藏（如果可见）时变得可见的操作。

Methods in javax.accessibility that return String

Modifier and Type

方法

描述

String

AccessibleAction.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

abstract String

AccessibleHyperlink.getAccessibleActionDescription​(int i)

返回此特定链接操作的字符串描述。

String

AccessibleContext.getAccessibleDescription​()

获取此对象的 accessibleDescription属性。

String

AccessibleIcon.getAccessibleIconDescription​()

获取图标的描述。

String

AccessibleContext.getAccessibleName​()

获取此对象的 accessibleName属性。

String

AccessibleText.getAfterIndex​(int part, int index)

给定索引后返回 String 。

String

AccessibleText.getAtIndex​(int part, int index)

返回给定索引的 String 。

String

AccessibleText.getBeforeIndex​(int part, int index)

返回给定索引前的 String 。

String

AccessibleRelation.getKey​()

返回此关系的关键。

abstract String

AccessibilityProvider.getName​()

返回此服务提供商的名称。

String

AccessibleText.getSelectedText​()

返回所选文本的部分。

String

AccessibleEditableText.getTextRange​(int startIndex, int endIndex)

返回两个索引之间的文本字符串。

String

AccessibleExtendedText.getTextRange​(int startIndex, int endIndex)

返回两个索引之间的文本。

String

AccessibleExtendedComponent.getTitledBorderText​()

返回标题边框文本。

String

AccessibleExtendedComponent.getToolTipText​()

返回工具提示文本。

String

AccessibleBundle.toDisplayString​()

使用默认语言环境获取描述密钥的本地化字符串。

protected String

AccessibleBundle.toDisplayString​(String resourceBundleName, Locale locale)

获取密钥作为本地化字符串。

String

AccessibleBundle.toDisplayString​(Locale locale)

获取密钥作为本地化字符串。

String

AccessibleBundle.toString​()

使用默认语言环境获取描述密钥的本地化字符串。

String

AccessibleRelationSet.toString​()

使用默认语言环境创建表示集合中所有关系的本地化字符串。

String

AccessibleStateSet.toString​()

使用默认语言环境创建表示集合中所有状态的本地化字符串。

Methods in javax.accessibility with parameters of type String

Modifier and Type

方法

描述

boolean

AccessibleRelationSet.contains​(String key)

返回关系集是否包含与指定键匹配的关系。

void

AccessibleContext.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告绑定属性更改。

AccessibleRelation

AccessibleRelationSet.get​(String key)

返回与指定键匹配的关系。

void

AccessibleEditableText.insertTextAtIndex​(int index, String s)

在指定的索引处插入指定的字符串。

void

AccessibleEditableText.replaceText​(int startIndex, int endIndex, String s)

用指定的字符串替换两个索引之间的文本。

void

AccessibleContext.setAccessibleDescription​(String s)

设置此对象的可访问描述。

void

AccessibleIcon.setAccessibleIconDescription​(String description)

设置图标的描述。

void

AccessibleContext.setAccessibleName​(String s)

设置此对象的本地化可访问名称。

void

AccessibleEditableText.setTextContents​(String s)

将文本内容设置为指定的字符串。

protected String

AccessibleBundle.toDisplayString​(String resourceBundleName, Locale locale)

获取密钥作为本地化字符串。

Constructors in javax.accessibility with parameters of type String

Constructor

描述

AccessibleRelation​(String key)

使用给定的区域设置独立键创建一个新的 AccessibleRelation 。

AccessibleRelation​(String key, Object target)

使用给定的区域设置独立键创建一个新的 AccessibleRelation 。

AccessibleRelation​(String key, Object[] target)

使用给定的区域设置独立键创建一个新的 AccessibleRelation 。

AccessibleRole​(String key)

使用给定的区域设置独立键创建一个新的 AccessibleRole 。

AccessibleState​(String key)

使用给定的区域设置独立键创建一个新的 AccessibleState 。

AccessibleTextSequence​(int start, int end, String txt)

构造具有给定参数的 AccessibleTextSequence 。

Uses of String in javax.activation

Methods in javax.activation that return String

Modifier and Type

方法

描述

String

MimeTypeParameterList.get​(String name)

检索与给定名称相关联的值，如果没有当前关联，则返回null。

String

MimeType.getBaseType​()

返回此对象的String表示，而不包含参数列表。

String

CommandInfo.getCommandClass​()

返回命令的类名。

String

CommandInfo.getCommandName​()

返回命令动词。

String

DataHandler.getContentType​()

返回从源对象检索的此对象的MIME类型。

String

DataSource.getContentType​()

此方法以字符串的形式返回数据的MIME类型。

String

FileDataSource.getContentType​()

此方法以字符串的形式返回数据的MIME类型。

abstract String

FileTypeMap.getContentType​(File file)

返回文件对象的类型。

abstract String

FileTypeMap.getContentType​(String filename)

返回传入的文件的类型。

String

MimetypesFileTypeMap.getContentType​(File f)

返回文件对象的MIME类型。

String

MimetypesFileTypeMap.getContentType​(String filename)

根据指定的文件名返回MIME类型。

String

URLDataSource.getContentType​()

返回URL内容类型头字段的值。

String

ActivationDataFlavor.getHumanPresentableName​()

返回人类可呈现的名称。

String

ActivationDataFlavor.getMimeType​()

返回此DataFlavor的MIME类型。

String[]

CommandMap.getMimeTypes​()

获取此命令映射已知的所有MIME类型。

String[]

MailcapCommandMap.getMimeTypes​()

获取此命令映射已知的所有MIME类型。

String

DataHandler.getName​()

返回数据对象的名称。

String

DataSource.getName​()

返回此对象，其中对象的名称是依赖于底层的对象的性质 名称 。

String

FileDataSource.getName​()

返回此对象的 名称 。

String

URLDataSource.getName​()

在用于实例化对象的URL上调用 getFile方法。

String[]

MailcapCommandMap.getNativeCommands​(String mimeType)

获取给定MIME类型的本机命令。

String

MimeType.getParameter​(String name)

检索与给定名称相关联的值，如果没有当前关联，则返回null。

String

MimeType.getPrimaryType​()

检索此对象的主要类型。

String

MimeType.getSubType​()

检索此对象的子类型。

protected String

ActivationDataFlavor.normalizeMimeType​(String mimeType)

已过时。

protected String

ActivationDataFlavor.normalizeMimeTypeParameter​(String parameterName, String parameterValue)

已过时。

String

MimeType.toString​()

返回此对象的String表示。

String

MimeTypeParameterList.toString​()

返回此对象的字符串表示形式。

Methods in javax.activation with parameters of type String

Modifier and Type

方法

描述

void

MailcapCommandMap.addMailcap​(String mail_cap)

将条目添加到注册表。

void

MimetypesFileTypeMap.addMimeTypes​(String mime_types)

将MIME类型值添加到注册表。

abstract DataContentHandler

CommandMap.createDataContentHandler​(String mimeType)

找到与MIME类型相对应的DataContentHandler。

DataContentHandler

CommandMap.createDataContentHandler​(String mimeType, DataSource ds)

找到与MIME类型相对应的DataContentHandler。

DataContentHandler

DataContentHandlerFactory.createDataContentHandler​(String mimeType)

为MIME类型创建一个新的DataContentHandler对象。

DataContentHandler

MailcapCommandMap.createDataContentHandler​(String mimeType)

返回指定MIME类型的DataContentHandler。

String

MimeTypeParameterList.get​(String name)

检索与给定名称相关联的值，如果没有当前关联，则返回null。

abstract CommandInfo[]

CommandMap.getAllCommands​(String mimeType)

获取此类型的所有可用命令。

CommandInfo[]

CommandMap.getAllCommands​(String mimeType, DataSource ds)

获取此类型的所有可用命令。

CommandInfo[]

MailcapCommandMap.getAllCommands​(String mimeType)

获取此MIME类型的MailcapCommandMap的此实例已知的所有mailcap文件中的所有可用命令。

abstract CommandInfo

CommandMap.getCommand​(String mimeType, String cmdName)

获取与MIME类型相对应的默认命令。

CommandInfo

CommandMap.getCommand​(String mimeType, String cmdName, DataSource ds)

获取与MIME类型相对应的默认命令。

CommandInfo

DataHandler.getCommand​(String cmdName)

获取命令 cmdName 。

CommandInfo

MailcapCommandMap.getCommand​(String mimeType, String cmdName)

获取对应于 cmdName的MIME类型的命令。

abstract String

FileTypeMap.getContentType​(String filename)

返回传入的文件的类型。

String

MimetypesFileTypeMap.getContentType​(String filename)

根据指定的文件名返回MIME类型。

String[]

MailcapCommandMap.getNativeCommands​(String mimeType)

获取给定MIME类型的本机命令。

String

MimeType.getParameter​(String name)

检索与给定名称相关联的值，如果没有当前关联，则返回null。

abstract CommandInfo[]

CommandMap.getPreferredCommands​(String mimeType)

从MIME类型获取首选命令列表。

CommandInfo[]

CommandMap.getPreferredCommands​(String mimeType, DataSource ds)

从MIME类型获取首选命令列表。

CommandInfo[]

MailcapCommandMap.getPreferredCommands​(String mimeType)

获取MIME类型的首选命令列表。

boolean

ActivationDataFlavor.isMimeTypeEqual​(String mimeType)

MIME类型的字符串表示形式相当于此DataFlavor的MIME类型。

boolean

MimeType.match​(String rawdata)

确定此对象的主要类型和子类型是否与rawdata中描述的内容类型相同。

protected String

ActivationDataFlavor.normalizeMimeType​(String mimeType)

已过时。

protected String

ActivationDataFlavor.normalizeMimeTypeParameter​(String parameterName, String parameterValue)

已过时。

protected void

MimeTypeParameterList.parse​(String parameterList)

用于从String解析参数列表的例程。

void

MimeTypeParameterList.remove​(String name)

删除与给定名称相关联的任何值。

void

MimeType.removeParameter​(String name)

删除与给定名称相关联的任何值。

void

MimeTypeParameterList.set​(String name, String value)

设置与给定名称相关联的值，替换任何先前的关联。

void

CommandObject.setCommandContext​(String verb, DataHandler dh)

使用要处理的动词来初始化命令，以及描述将要操作的数据的DataHandler。

void

ActivationDataFlavor.setHumanPresentableName​(String humanPresentableName)

设置人性化的名称。

void

MimeType.setParameter​(String name, String value)

设置与给定名称相关联的值，替换任何先前的关联。

void

MimeType.setPrimaryType​(String primary)

将此对象的主要类型设置为给定的String。

void

MimeType.setSubType​(String sub)

将此对象的子类型设置为给定的String。

void

DataContentHandler.writeTo​(Object obj, String mimeType, OutputStream os)

将对象转换为指定MIME类型的字节流，并将其写入输出流。

Constructors in javax.activation with parameters of type String

Constructor

描述

ActivationDataFlavor​(Class representationClass, String humanPresentableName)

构造一个表示MimeType的DataFlavor。

ActivationDataFlavor​(Class representationClass, String mimeType, String humanPresentableName)

构造一个表示任意Java对象的DataFlavor。

ActivationDataFlavor​(String mimeType, String humanPresentableName)

构造一个表示MimeType的DataFlavor。

CommandInfo​(String verb, String className)

CommandInfo的构造方法。

DataHandler​(Object obj, String mimeType)

创建一个表示此MIME类型对象的 DataHandler实例。

FileDataSource​(String name)

从指定的路径名创建一个FileDataSource。

MailcapCommandMap​(String fileName)

构造函数允许调用者指定 mailcap文件的路径。

MimeType​(String rawdata)

从String构建MimeType的构造方法。

MimeType​(String primary, String sub)

构造函数，它使用给定的主类型和子类型构建MimeType，但具有空参数列表。

MimeTypeParameterList​(String parameterList)

使用传入的数据构造一个新的MimeTypeParameterList。

MimeTypeParseException​(String s)

构造具有指定详细消息的MimeTypeParseException。

MimetypesFileTypeMap​(String mimeTypeFileName)

构造MimetypesFileTypeMap，并从命名文件中添加程序化条目。

UnsupportedDataTypeException​(String s)

构造具有指定消息的UnsupportedDataTypeException。

Uses of String in javax.activity

Constructors in javax.activity with parameters of type String

Constructor

描述

ActivityCompletedException​(String message)

构造具有指定详细消息的新实例。

ActivityCompletedException​(String message, Throwable cause)

构造一个新的可抛出指定的详细信息和原因。

ActivityRequiredException​(String message)

构造具有指定详细消息的新实例。

ActivityRequiredException​(String message, Throwable cause)

构造一个新的可抛出指定的详细信息和原因。

InvalidActivityException​(String message)

构造具有指定详细消息的新实例。

InvalidActivityException​(String message, Throwable cause)

构造一个新的可抛出指定的详细信息和原因。

Uses of String in javax.annotation

Methods in javax.annotation with parameters of type String

Modifier and Type

方法

描述

static Resource.AuthenticationType

Resource.AuthenticationType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javax.annotation.processing

Methods in javax.annotation.processing that return String

Modifier and Type

方法

描述

String

Completion.getMessage​()

返回有关完成的信息性消息。

String

Completion.getValue​()

返回建议完成的文本。

Methods in javax.annotation.processing that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,String>

ProcessingEnvironment.getOptions​()

返回传递给注解处理工具的处理器特定选项。

Map<String,String>

ProcessingEnvironment.getOptions​()

返回传递给注解处理工具的处理器特定选项。

Set<String>

AbstractProcessor.getSupportedAnnotationTypes​()

如果使用SupportedAnnotationTypes注释处理器类，则返回与注释具有相同字符串集的不可修改集。

Set<String>

Processor.getSupportedAnnotationTypes​()

返回此处理器支持的注释类型的名称。

Set<String>

AbstractProcessor.getSupportedOptions​()

如果使用SupportedOptions注释处理器类，则返回与注释具有相同字符串集的不可修改集。

Set<String>

Processor.getSupportedOptions​()

返回此处理器识别的选项。

Methods in javax.annotation.processing with parameters of type String

Modifier and Type

方法

描述

Iterable<? extends Completion>

AbstractProcessor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)

返回一个空的可迭代的完成。

Iterable<? extends Completion>

Processor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)

返回到工具基础结构，可以对注释的建议完成进行迭代。

static Completion

Completions.of​(String value)

返回值的完成和空消息

static Completion

Completions.of​(String value, String message)

返回值和消息的完成。

Constructors in javax.annotation.processing with parameters of type String

Constructor

描述

FilerException​(String s)

使用指定的详细消息构造异常。

Uses of String in javax.crypto

Methods in javax.crypto that return String

Modifier and Type

方法

描述

String

EncryptedPrivateKeyInfo.getAlgName​()

返回加密算法。

String

Cipher.getAlgorithm​()

返回此 Cipher对象的算法名称。

String

KeyAgreement.getAlgorithm​()

返回此 KeyAgreement对象的算法名称。

String

KeyGenerator.getAlgorithm​()

返回此 KeyGenerator对象的算法名称。

String

Mac.getAlgorithm​()

返回此 Mac对象的算法名称。

String

SealedObject.getAlgorithm​()

返回用于密封此对象的算法。

String

SecretKeyFactory.getAlgorithm​()

返回此 SecretKeyFactory对象的算法名称。

String

ExemptionMechanism.getName​()

返回此 ExemptionMechanism对象的豁免机制名称。

Methods in javax.crypto with parameters of type String

Modifier and Type

方法

描述

protected abstract SecretKey

KeyAgreementSpi.engineGenerateSecret​(String algorithm)

创建共享密钥，并将其作为请求的算法类型的秘密密钥对象返回。

protected abstract void

CipherSpi.engineSetMode​(String mode)

设置此密码的模式。

protected abstract void

CipherSpi.engineSetPadding​(String padding)

设置这个密码的填充机制。

protected Key

CipherSpi.engineUnwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)

打开以前包装的钥匙。

SecretKey

KeyAgreement.generateSecret​(String algorithm)

创建共享密钥，并将其作为指定算法的 SecretKey对象返回。

static Cipher

Cipher.getInstance​(String transformation)

返回一个 Cipher对象，实现指定的转换。

static Cipher

Cipher.getInstance​(String transformation, String provider)

返回实现指定转换的 Cipher对象。

static Cipher

Cipher.getInstance​(String transformation, Provider provider)

返回实现指定转换的 Cipher对象。

static ExemptionMechanism

ExemptionMechanism.getInstance​(String algorithm)

返回一个 ExemptionMechanism对象，实现指定的豁免机制算法。

static ExemptionMechanism

ExemptionMechanism.getInstance​(String algorithm, String provider)

返回一个 ExemptionMechanism对象，该对象实现指定的豁免机制算法。

static ExemptionMechanism

ExemptionMechanism.getInstance​(String algorithm, Provider provider)

返回一个 ExemptionMechanism对象，实现指定的豁免机制算法。

static KeyAgreement

KeyAgreement.getInstance​(String algorithm)

返回一个 KeyAgreement对象，该对象实现指定的密钥协商算法。

static KeyAgreement

KeyAgreement.getInstance​(String algorithm, String provider)

返回实现指定密钥协商算法的 KeyAgreement对象。

static KeyAgreement

KeyAgreement.getInstance​(String algorithm, Provider provider)

返回实现指定密钥协商算法的 KeyAgreement对象。

static KeyGenerator

KeyGenerator.getInstance​(String algorithm)

返回一个 KeyGenerator对象，该对象为指定的算法生成密钥。

static KeyGenerator

KeyGenerator.getInstance​(String algorithm, String provider)

返回产生指定算法的密钥的 KeyGenerator对象。

static KeyGenerator

KeyGenerator.getInstance​(String algorithm, Provider provider)

返回产生指定算法的密钥的 KeyGenerator对象。

static Mac

Mac.getInstance​(String algorithm)

返回实现指定的MAC算法的 Mac对象。

static Mac

Mac.getInstance​(String algorithm, String provider)

返回实现指定的MAC算法的 Mac对象。

static Mac

Mac.getInstance​(String algorithm, Provider provider)

返回实现指定MAC算法的 Mac对象。

static SecretKeyFactory

SecretKeyFactory.getInstance​(String algorithm)

返回转换指定算法的密钥的 SecretKeyFactory对象。

static SecretKeyFactory

SecretKeyFactory.getInstance​(String algorithm, String provider)

返回转换指定算法的密钥的 SecretKeyFactory对象。

static SecretKeyFactory

SecretKeyFactory.getInstance​(String algorithm, Provider provider)

返回转换指定算法的密钥的 SecretKeyFactory对象。

PKCS8EncodedKeySpec

EncryptedPrivateKeyInfo.getKeySpec​(Key decryptKey, String providerName)

从加密数据中提取附带的PKCS8EncodedKeySpec对象并返回。

static int

Cipher.getMaxAllowedKeyLength​(String transformation)

根据已安装的JCE管辖区策略文件，返回指定转换的最大密钥长度。

static AlgorithmParameterSpec

Cipher.getMaxAllowedParameterSpec​(String transformation)

返回一个AlgorithmParameterSpec对象，该对象包含根据管辖区策略文件的最大密码参数值。

Object

SealedObject.getObject​(Key key, String provider)

检索原始（封装）对象。

Key

Cipher.unwrap​(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)

打开以前包装的钥匙。

Constructors in javax.crypto with parameters of type String

Constructor

描述

AEADBadTagException​(String msg)

构造具有指定详细消息的AEADBadTagException。

BadPaddingException​(String msg)

构造具有指定详细消息的BadPaddingException。

Cipher​(CipherSpi cipherSpi, Provider provider, String transformation)

创建一个Cipher对象。

EncryptedPrivateKeyInfo​(String algName, byte[] encryptedData)

根据加密算法名称和加密数据构建一个 EncryptedPrivateKeyInfo 。

ExemptionMechanism​(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)

创建一个ExemptionMechanism对象。

ExemptionMechanismException​(String msg)

构造具有指定详细消息的ExemptionMechanismException。

IllegalBlockSizeException​(String msg)

构造具有指定详细消息的IllegalBlockSizeException。

KeyAgreement​(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)

创建一个KeyAgreement对象。

KeyGenerator​(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)

创建一个KeyGenerator对象。

Mac​(MacSpi macSpi, Provider provider, String algorithm)

创建MAC对象。

NoSuchPaddingException​(String msg)

构造具有指定详细消息的NoSuchPaddingException。

SecretKeyFactory​(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)

创建一个SecretKeyFactory对象。

ShortBufferException​(String msg)

构造具有指定详细消息的ShortBufferException。

Uses of String in javax.crypto.spec

Methods in javax.crypto.spec that return String

Modifier and Type

方法

描述

String

PSource.getAlgorithm​()

返回PSource算法名称。

String

SecretKeySpec.getAlgorithm​()

返回与该密钥相关联的算法的名称。

String

OAEPParameterSpec.getDigestAlgorithm​()

返回消息摘要算法名称。

String

SecretKeySpec.getFormat​()

返回此密钥的编码格式的名称。

String

OAEPParameterSpec.getMGFAlgorithm​()

返回掩码生成函数算法名称。

Constructors in javax.crypto.spec with parameters of type String

Constructor

描述

OAEPParameterSpec​(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)

构造为使用指定的消息摘要算法在PKCS＃1标准中定义的OAEP冗余参数集 mdName ，掩码生成函数算法 mgfName ，掩码生成函数参数 mgfSpec编码输入P的，和源 pSrc 。

PSource​(String pSrcName)

使用指定的PSource算法构建PKCS＃1标准中定义的OAEP填充的编码输入P的源。

SecretKeySpec​(byte[] key, int offset, int len, String algorithm)

根据给定的字节数组的秘密密钥，使用所述第一 len的字节 key ，起始于 offset以下。

SecretKeySpec​(byte[] key, String algorithm)

从给定的字节数组构造一个秘密密钥。

Uses of String in javax.imageio

Fields in javax.imageio declared as String

Modifier and Type

Field

描述

protected String

ImageWriteParam.compressionType

A String包含当前压缩类型的名称，如果没有设置， null 。

protected String[]

ImageWriteParam.compressionTypes

包含可用压缩类型名称的 String的数组。

Methods in javax.imageio that return String

Modifier and Type

方法

描述

String[]

ImageWriteParam.getCompressionQualityDescriptions​()

返回的数组 String可与被用于沿小号 getCompressionQualityValues作为用户接口，用于设置或显示压缩质量级别的一部分。

String

ImageWriteParam.getCompressionType​()

返回当前设置的压缩类型，如果没有设置，则返回 null 。

String[]

ImageWriteParam.getCompressionTypes​()

返回一个可用的压缩类型列表，如数组或 String ，或者如果可能不使用这些接口选择压缩类型，则返回 null 。

String

ImageReader.getFormatName​()

返回一个 String标识输入源的格式。

String

ImageWriteParam.getLocalizedCompressionTypeName​()

返回当前压缩类型名称的本地化版本，使用 Locale通过返回 getLocale 。

static String[]

ImageIO.getReaderFileSuffixes​()

返回一个 String的数组，列出与当前注册读者集合所理解的格式相关联的所有文件后缀。

static String[]

ImageIO.getReaderFormatNames​()

返回一个 String的数组， String列出了当前注册读者集所理解的所有非正式格式名称。

static String[]

ImageIO.getReaderMIMETypes​()

返回一个 String的数组， String列出了当前注册读者集所理解的所有MIME类型。

static String[]

ImageIO.getWriterFileSuffixes​()

返回一个 String的数组， String列出了与当前注册作者集合所理解的格式相关联的所有文件后缀。

static String[]

ImageIO.getWriterFormatNames​()

返回一个 String的数组， String列出了当前注册作者集所理解的所有非正式格式名称。

static String[]

ImageIO.getWriterMIMETypes​()

返回一个 String的数组， String列出了当前注册作者集所理解的所有MIME类型。

Methods in javax.imageio with parameters of type String

Modifier and Type

方法

描述

IIOMetadata

ImageReader.getImageMetadata​(int imageIndex, String formatName, Set<String> nodeNames)

返回一个 IIOMetadata表示与给定图像，或相关联的元数据对象 null如果读取器不支持读取元数据或没有可用的。

static Iterator<ImageReader>

ImageIO.getImageReadersByFormatName​(String formatName)

返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够解码命名格式。

static Iterator<ImageReader>

ImageIO.getImageReadersByMIMEType​(String MIMEType)

返回一个 Iterator其中包含所有当前注册的 ImageReader ，声称能够解码具有给定MIME类型的文件。

static Iterator<ImageReader>

ImageIO.getImageReadersBySuffix​(String fileSuffix)

返回一个 Iterator其中包含所有当前注册的 ImageReader s，声称能够使用给定的后缀解码文件。

static Iterator<ImageWriter>

ImageIO.getImageWriters​(ImageTypeSpecifier type, String formatName)

返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够以给定格式对给定布局（使用 ImageTypeSpecifier指定）的图像进行编码。

static Iterator<ImageWriter>

ImageIO.getImageWritersByFormatName​(String formatName)

返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够对命名格式进行编码。

static Iterator<ImageWriter>

ImageIO.getImageWritersByMIMEType​(String MIMEType)

返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够对给定MIME类型的文件进行编码。

static Iterator<ImageWriter>

ImageIO.getImageWritersBySuffix​(String fileSuffix)

返回一个 Iterator其中包含所有当前注册的 ImageWriter s，声称能够使用给定的后缀对文件进行编码。

IIOMetadata

ImageReader.getStreamMetadata​(String formatName, Set<String> nodeNames)

返回一个 IIOMetadata对象，表示与整个输入源相关联的元数据（即，与任何特定图像无关）。

protected void

ImageReader.processWarningOccurred​(String warning)

通过拨打他们的 warningOccurred方法向所有注册的 IIOReadWarningListener发送警告信息。

protected void

ImageReader.processWarningOccurred​(String baseName, String keyword)

通过使用从 ResourceBundle获取的字符串调用其 warningOccurred方法，向所有注册的 IIOReadWarningListener广播本地化警告消息。

protected void

ImageWriter.processWarningOccurred​(int imageIndex, String warning)

通过致电 warningOccurred方法向所有注册的 IIOWriteWarningListener发送警告信息。

protected void

ImageWriter.processWarningOccurred​(int imageIndex, String baseName, String keyword)

通过使用从 ResourceBundle获取的字符串调用其 warningOccurred方法向所有注册的 IIOWriteWarningListener广播本地化警告消息。

void

ImageWriteParam.setCompressionType​(String compressionType)

将压缩类型设置为 getCompressionTypes所示的值 getCompressionTypes 。

static boolean

ImageIO.write​(RenderedImage im, String formatName, File output)

使用支持给定格式的任意 ImageWriter写入图像到 File 。

static boolean

ImageIO.write​(RenderedImage im, String formatName, OutputStream output)

使用支持给定格式的任意 ImageWriter写入图像到 OutputStream 。

static boolean

ImageIO.write​(RenderedImage im, String formatName, ImageOutputStream output)

使用支持给定格式的任意 ImageWriter写入图像到 ImageOutputStream 。

Method parameters in javax.imageio with type arguments of type String

Modifier and Type

方法

描述

IIOMetadata

ImageReader.getImageMetadata​(int imageIndex, String formatName, Set<String> nodeNames)

返回一个 IIOMetadata表示与给定图像，或相关联的元数据对象 null如果读取器不支持读取元数据或没有可用的。

IIOMetadata

ImageReader.getStreamMetadata​(String formatName, Set<String> nodeNames)

返回表示与整个输入源相关联的元数据（即与任何特定图像无关）的 IIOMetadata对象。

Constructors in javax.imageio with parameters of type String

Constructor

描述

IIOException​(String message)

构造一个 IIOException与给定的消息 String 。

IIOException​(String message, Throwable cause)

构造一个 IIOException与给定的消息 String和一个 Throwable这是其根本原因。

Uses of String in javax.imageio.event

Methods in javax.imageio.event with parameters of type String

Modifier and Type

方法

描述

void

IIOReadWarningListener.warningOccurred​(ImageReader source, String warning)

报告解码中出现非致命错误。

void

IIOWriteWarningListener.warningOccurred​(ImageWriter source, int imageIndex, String warning)

报告编码中出现非致命错误。

Uses of String in javax.imageio.metadata

Fields in javax.imageio.metadata declared as String

Modifier and Type

Field

描述

protected String[]

IIOMetadata.extraMetadataFormatClassNames

实现 IIOMetadataFormat的类的名称数组，并表示此插件支持的元数据格式（不包括标准和本地格式），初始化为 null并通过构造函数进行设置。

protected String[]

IIOMetadata.extraMetadataFormatNames

这个插件支持的格式，不同于标准和本机格式的数组，初始化为 null并通过构造函数进行设置。

protected String

IIOMetadata.nativeMetadataFormatClassName

实现 IIOMetadataFormat并表示原生元数据格式的类的名称，初始化为 null并通过构造函数设置。

protected String

IIOMetadata.nativeMetadataFormatName

该对象的本机元数据格式的名称，初始化为 null并通过构造函数进行设置。

static String

IIOMetadataFormatImpl.standardMetadataFormatName

A String常量包含标准格式名称， "javax_imageio_1.0" 。

Methods in javax.imageio.metadata that return String

Modifier and Type

方法

描述

String

IIOMetadataNode.getAttribute​(String name)

按名称检索属性值。

String

IIOMetadataFormat.getAttributeDefaultValue​(String elementName, String attrName)

如果没有默认值可用，则返回命名属性的默认值（如果它未显式存在于指定元素中）， String ，或 null 。

String

IIOMetadataFormatImpl.getAttributeDefaultValue​(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDescription​(String elementName, String attrName, Locale locale)

返回 String含有指定属性，或的描述 null 。

String

IIOMetadataFormatImpl.getAttributeDescription​(String elementName, String attrName, Locale locale)

返回 String含有指定属性，或的描述 null 。

String[]

IIOMetadataFormat.getAttributeEnumerations​(String elementName, String attrName)

返回一个包含指定元素中给定属性的合法枚举值的数组 String 。

String[]

IIOMetadataFormatImpl.getAttributeEnumerations​(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMaxValue​(String elementName, String attrName)

返回属性的最大合法值。

String

IIOMetadataFormatImpl.getAttributeMaxValue​(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMinValue​(String elementName, String attrName)

返回属性的最小合法值。

String

IIOMetadataFormatImpl.getAttributeMinValue​(String elementName, String attrName)

String[]

IIOMetadataFormat.getAttributeNames​(String elementName)

返回一个 String的数组，列出可能与命名元素相关联的属性的名称。

String[]

IIOMetadataFormatImpl.getAttributeNames​(String elementName)

String

IIOMetadataNode.getAttributeNS​(String namespaceURI, String localName)

相当于 getAttribute(localName) 。

String

IIOMetadataNode.getBaseURI​()

这个DOM Level 3方法不支持 IIOMetadataNode并且将抛出一个 DOMException 。

String[]

IIOMetadataFormat.getChildNames​(String elementName)

返回一个 String s的数组，表示允许作为命名元素的子元素的元素的名称，按照它们应该出现的顺序。

String[]

IIOMetadataFormatImpl.getChildNames​(String elementName)

String

IIOMetadataFormat.getElementDescription​(String elementName, Locale locale)

返回一个 String其中包含命名元素的描述，或 null 。

String

IIOMetadataFormatImpl.getElementDescription​(String elementName, Locale locale)

返回 String含有指定元素，或的描述 null 。

String[]

IIOMetadata.getExtraMetadataFormatNames​()

返回的数组 String含的附加的元数据格式，比天然和标准格式，此插件中的识别名字小号 getAsTree ， setFromTree ，和 mergeTree方法。

String

IIOMetadataNode.getLocalName​()

相当于 getNodeName 。

String[]

IIOMetadata.getMetadataFormatNames​()

返回数组 String包含的所有元数据格式的名称，包括本地和标准格式，通过此插件的认为科学 getAsTree ， setFromTree ，并 mergeTree方法。

String

IIOMetadataNode.getNamespaceURI​()

返回 null ，因为不支持命名空间。

String

IIOMetadata.getNativeMetadataFormatName​()

返回此插件的“本机”元数据格式的名称，通常允许以该插件处理的格式存储的元数据进行无损编码和传输。

String

IIOMetadataNode.getNodeName​()

返回与此节点相关联的节点名称。

String

IIOMetadataNode.getNodeValue​()

返回与该节点关联的值。

String

IIOMetadataNode.getPrefix​()

返回 null ，因为不支持命名空间。

protected String

IIOMetadataFormatImpl.getResourceBaseName​()

返回当前设置的基本名称，以查找 ResourceBundle s。

String

IIOMetadataFormat.getRootName​()

返回格式的根元素的名称。

String

IIOMetadataFormatImpl.getRootName​()

String

IIOMetadataNode.getTagName​()

相当于 getNodeName 。

String

IIOMetadataNode.getTextContent​()

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

String

IIOMetadataNode.lookupNamespaceURI​(String prefix)

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

String

IIOMetadataNode.lookupPrefix​(String namespaceURI)

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

Methods in javax.imageio.metadata with parameters of type String

Modifier and Type

方法

描述

protected void

IIOMetadataFormatImpl.addAttribute​(String elementName, String attrName, int dataType, boolean required, int listMinLength, int listMaxLength)

将新属性添加到由值列表定义的先前定义的元素中。

protected void

IIOMetadataFormatImpl.addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue)

将新属性添加到可以设置为任意值的先前定义的元素。

protected void

IIOMetadataFormatImpl.addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue, String minValue, String maxValue, boolean minInclusive, boolean maxInclusive)

向先前定义的元素添加一个新属性，该元素将由一系列值定义。

protected void

IIOMetadataFormatImpl.addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)

向先前定义的元素添加一个新属性，该元素将由一组枚举值定义。

protected void

IIOMetadataFormatImpl.addBooleanAttribute​(String elementName, String attrName, boolean hasDefaultValue, boolean defaultValue)

向先前定义的元素添加一个新属性，该元素将由枚举值 TRUE和 FALSE ，数据类型为 DATATYPE_BOOLEAN 。

protected void

IIOMetadataFormatImpl.addChildElement​(String elementName, String parentName)

将一个现有元素添加到给定父节点类型的合法子节点列表中。

protected void

IIOMetadataFormatImpl.addElement​(String elementName, String parentName, int childPolicy)

使用除 CHILD_POLICY_REPEAT之外的子策略为此元数据文档格式添加新元素类型。

protected void

IIOMetadataFormatImpl.addElement​(String elementName, String parentName, int minChildren, int maxChildren)

将新元素类型添加到此元数据文档格式，子策略为 CHILD_POLICY_REPEAT 。

protected void

IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)

允许 Object定类类型的引用存储在实现命名元素的节点中。

protected <T> void

IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, boolean required, T defaultValue)

允许 Object定类类型的引用存储在实现命名元素的节点中。

protected <T> void

IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)

允许 Object定类类型的引用存储在实现命名元素的节点中的 Object引用。

protected <T extends Object & Comparable<? super T>>
void

IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)

允许 Object定类类型的引用存储在实现命名元素的节点中。

boolean

IIOMetadataFormat.canNodeAppear​(String elementName, ImageTypeSpecifier imageType)

如果 true元素（及其下面的子树）允许出现在由 ImageTypeSpecifier定义的给定类型的图像的元数据文档中。

abstract boolean

IIOMetadataFormatImpl.canNodeAppear​(String elementName, ImageTypeSpecifier imageType)

abstract Node

IIOMetadata.getAsTree​(String formatName)

根据给定元数据格式定义的约定，返回一个XML DOM Node对象，该对象表示该对象中包含的元数据树的根。

String

IIOMetadataNode.getAttribute​(String name)

按名称检索属性值。

int

IIOMetadataFormat.getAttributeDataType​(String elementName, String attrName)

返回从 DATATYPE_开始的常量 DATATYPE_ ，指示指定元素中给定属性的值的格式和解释。

int

IIOMetadataFormatImpl.getAttributeDataType​(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDefaultValue​(String elementName, String attrName)

如果没有默认值可用，则返回命名属性的默认值（如果它未显式存在于命名元素中）， String ，或 null 。

String

IIOMetadataFormatImpl.getAttributeDefaultValue​(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDescription​(String elementName, String attrName, Locale locale)

返回 String含有指定属性，或的描述 null 。

String

IIOMetadataFormatImpl.getAttributeDescription​(String elementName, String attrName, Locale locale)

返回一个 String其中包含命名属性的描述，或 null 。

String[]

IIOMetadataFormat.getAttributeEnumerations​(String elementName, String attrName)

返回一个 String的数组， String包含指定元素中给定属性的合法枚举值。

String[]

IIOMetadataFormatImpl.getAttributeEnumerations​(String elementName, String attrName)

int

IIOMetadataFormat.getAttributeListMaxLength​(String elementName, String attrName)

返回可用于定义此属性的列表项的最大数量。

int

IIOMetadataFormatImpl.getAttributeListMaxLength​(String elementName, String attrName)

int

IIOMetadataFormat.getAttributeListMinLength​(String elementName, String attrName)

返回可用于定义此属性的列表项的最小数量。

int

IIOMetadataFormatImpl.getAttributeListMinLength​(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMaxValue​(String elementName, String attrName)

返回属性的最大合法值。

String

IIOMetadataFormatImpl.getAttributeMaxValue​(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMinValue​(String elementName, String attrName)

返回属性的最小合法值。

String

IIOMetadataFormatImpl.getAttributeMinValue​(String elementName, String attrName)

String[]

IIOMetadataFormat.getAttributeNames​(String elementName)

返回一个 String的数组，列出可能与命名元素相关联的属性的名称。

String[]

IIOMetadataFormatImpl.getAttributeNames​(String elementName)

Attr

IIOMetadataNode.getAttributeNode​(String name)

Attr

IIOMetadataNode.getAttributeNodeNS​(String namespaceURI, String localName)

相当于 getAttributeNode(localName) 。

String

IIOMetadataNode.getAttributeNS​(String namespaceURI, String localName)

相当于 getAttribute(localName) 。

int

IIOMetadataFormat.getAttributeValueType​(String elementName, String attrName)

返回从 VALUE_开始的常量 VALUE_ ，指示指定元素中给定属性的值是否是任意的，被限制在指定范围内，被限制为一组枚举值之一，或是空格分隔的列表的任意值。

int

IIOMetadataFormatImpl.getAttributeValueType​(String elementName, String attrName)

String[]

IIOMetadataFormat.getChildNames​(String elementName)

返回一个 String的数组，表示允许作为命名元素的子元素的元素的名称，按照它们应该出现的顺序。

String[]

IIOMetadataFormatImpl.getChildNames​(String elementName)

int

IIOMetadataFormat.getChildPolicy​(String elementName)

返回从 CHILD_POLICY_开始的常量 CHILD_POLICY_ ，指示命名元素的子代的合法模式。

int

IIOMetadataFormatImpl.getChildPolicy​(String elementName)

String

IIOMetadataFormat.getElementDescription​(String elementName, Locale locale)

返回一个 String其中包含命名元素的描述，或 null 。

String

IIOMetadataFormatImpl.getElementDescription​(String elementName, Locale locale)

返回一个 String其中包含命名元素的描述，或 null 。

int

IIOMetadataFormat.getElementMaxChildren​(String elementName)

返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最大子 CHILD_POLICY_REPEAT 。

int

IIOMetadataFormatImpl.getElementMaxChildren​(String elementName)

int

IIOMetadataFormat.getElementMinChildren​(String elementName)

返回具有子策略 CHILD_POLICY_REPEAT的命名元素的最 CHILD_POLICY_REPEAT 。

int

IIOMetadataFormatImpl.getElementMinChildren​(String elementName)

NodeList

IIOMetadataNode.getElementsByTagName​(String name)

NodeList

IIOMetadataNode.getElementsByTagNameNS​(String namespaceURI, String localName)

相当于 getElementsByTagName(localName) 。

Object

IIOMetadataNode.getFeature​(String feature, String version)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

IIOMetadataFormat

IIOMetadata.getMetadataFormat​(String formatName)

返回一个 IIOMetadataFormat对象描述给定的元数据格式，或 null如果没有可用的描述。

int

IIOMetadataFormat.getObjectArrayMaxLength​(String elementName)

返回可用于定义指定元素中的 Object引用的最大数组元素数。

int

IIOMetadataFormatImpl.getObjectArrayMaxLength​(String elementName)

int

IIOMetadataFormat.getObjectArrayMinLength​(String elementName)

返回可用于定义指定元素中的 Object引用的最小数组元素数。

int

IIOMetadataFormatImpl.getObjectArrayMinLength​(String elementName)

Class<?>

IIOMetadataFormat.getObjectClass​(String elementName)

返回存储在元素中的 Object参考的 Class类型。

Class<?>

IIOMetadataFormatImpl.getObjectClass​(String elementName)

Object

IIOMetadataFormat.getObjectDefaultValue​(String elementName)

返回 Object包含为默认值s Object指定元素中引用。

Object

IIOMetadataFormatImpl.getObjectDefaultValue​(String elementName)

Object[]

IIOMetadataFormat.getObjectEnumerations​(String elementName)

返回一个 Object s的数组， Object包含命名元素中的 Object引用的合法枚举值。

Object[]

IIOMetadataFormatImpl.getObjectEnumerations​(String elementName)

Comparable<?>

IIOMetadataFormat.getObjectMaxValue​(String elementName)

返回指定元素中 Object引用的最大合法值。

Comparable<?>

IIOMetadataFormatImpl.getObjectMaxValue​(String elementName)

Comparable<?>

IIOMetadataFormat.getObjectMinValue​(String elementName)

返回指定元素中的 Object引用的最小合法值。

Comparable<?>

IIOMetadataFormatImpl.getObjectMinValue​(String elementName)

int

IIOMetadataFormat.getObjectValueType​(String elementName)

返回从 VALUE_开始的枚举值 VALUE_ ，指示 Object引用允许的值（枚举，范围或数组）的 Object 。

int

IIOMetadataFormatImpl.getObjectValueType​(String elementName)

Object

IIOMetadataNode.getUserData​(String key)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

boolean

IIOMetadataNode.hasAttribute​(String name)

boolean

IIOMetadataNode.hasAttributeNS​(String namespaceURI, String localName)

相当于 hasAttribute(localName) 。

boolean

IIOMetadataFormat.isAttributeRequired​(String elementName, String attrName)

如果命名的属性必须存在于命名元素中，则返回 true 。

boolean

IIOMetadataFormatImpl.isAttributeRequired​(String elementName, String attrName)

boolean

IIOMetadataNode.isDefaultNamespace​(String namespaceURI)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

boolean

IIOMetadataNode.isSupported​(String feature, String version)

返回 false因为不支持DOM功能。

String

IIOMetadataNode.lookupNamespaceURI​(String prefix)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

String

IIOMetadataNode.lookupPrefix​(String namespaceURI)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

abstract void

IIOMetadata.mergeTree​(String formatName, Node root)

从XML DOM Node的树中更改此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。

protected void

IIOMetadataFormatImpl.removeAttribute​(String elementName, String attrName)

从先前定义的元素中删除一个属性。

void

IIOMetadataNode.removeAttribute​(String name)

void

IIOMetadataNode.removeAttributeNS​(String namespaceURI, String localName)

相当于 removeAttribute(localName) 。

protected void

IIOMetadataFormatImpl.removeElement​(String elementName)

从格式中移除元素。

protected void

IIOMetadataFormatImpl.removeObjectValue​(String elementName)

不允许将 Object引用存储在实现命名元素的节点中。

void

IIOMetadataNode.setAttribute​(String name, String value)

void

IIOMetadataNode.setAttributeNS​(String namespaceURI, String qualifiedName, String value)

相当于 setAttribute(qualifiedName, value) 。

void

IIOMetadata.setFromTree​(String formatName, Node root)

从XML DOM Node的树中设置此 IIOMetadata对象的内部状态，其语法由给定的元数据格式定义。

void

IIOMetadataNode.setIdAttribute​(String name, boolean isId)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

void

IIOMetadataNode.setIdAttributeNS​(String namespaceURI, String localName, boolean isId)

对于 IIOMetadataNode不支持此DOM 3级方法，并将抛出一个 DOMException 。

void

IIOMetadataNode.setNodeValue​(String nodeValue)

设置与此节点相关联的 String值。

void

IIOMetadataNode.setPrefix​(String prefix)

不支持命名空间，

protected void

IIOMetadataFormatImpl.setResourceBaseName​(String resourceBaseName)

设置一个新的基本名称，用于定位 ResourceBundle s，其中包含此格式的元素和属性说明。

void

IIOMetadataNode.setTextContent​(String textContent)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

Object

IIOMetadataNode.setUserData​(String key, Object data, UserDataHandler handler)

这个DOM Level 3方法不支持 IIOMetadataNode ，并将抛出一个 DOMException 。

Method parameters in javax.imageio.metadata with type arguments of type String

Modifier and Type

方法

描述

protected void

IIOMetadataFormatImpl.addAttribute​(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)

向先前定义的元素添加一个新属性，该元素将由一组枚举值定义。

Constructors in javax.imageio.metadata with parameters of type String

Constructor

描述

IIOInvalidTreeException​(String message, Throwable cause, Node offendingNode)

构造一个 IIOInvalidTreeException与消息字符串，来导致此异常的异常的参考，并以参考 Node导致解析错误。

IIOInvalidTreeException​(String message, Node offendingNode)

构造一个 IIOInvalidTreeException其中包含一条消息字符串，并引用了导致解析错误的 Node 。

IIOMetadata​(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)

构造具有给定格式名称和格式类名称的 IIOMetadata对象，以及指示是否支持标准格式的布尔。

IIOMetadataFormatImpl​(String rootName, int childPolicy)

构造一个空白的 IIOMetadataFormatImpl实例，具有给定的根元素名称和子策略（ CHILD_POLICY_REPEAT ）。

IIOMetadataFormatImpl​(String rootName, int minChildren, int maxChildren)

构造一个空白的 IIOMetadataFormatImpl实例，给定的根元素名称和子策略为 CHILD_POLICY_REPEAT 。

IIOMetadataNode​(String nodeName)

构造具有给定节点名称的 IIOMetadataNode 。

Uses of String in javax.imageio.plugins.jpeg

Methods in javax.imageio.plugins.jpeg that return String

Modifier and Type

方法

描述

String[]

JPEGImageWriteParam.getCompressionQualityDescriptions​()

String

JPEGHuffmanTable.toString​()

返回代表这个霍夫曼表的 String 。

String

JPEGQTable.toString​()

返回表示该量化表的 String 。

Uses of String in javax.imageio.plugins.tiff

Fields in javax.imageio.plugins.tiff declared as String

Modifier and Type

Field

描述

static String

ExifGPSTagSet.DEST_DISTANCE_REF_KILOMETERS

与“GPSDestDistanceRef”标签一起使用的值。

static String

ExifGPSTagSet.DEST_DISTANCE_REF_KNOTS

与“GPSDestDistanceRef”标签一起使用的值。

static String

ExifGPSTagSet.DEST_DISTANCE_REF_MILES

与“GPSDestDistanceRef”标签一起使用的值。

static String

ExifGPSTagSet.DIRECTION_REF_MAGNETIC

与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。

static String

ExifGPSTagSet.DIRECTION_REF_TRUE

与“GPSTrackRef”，“GPSImgDirectionRef”和“GPSDestBearingRef”标签一起使用的值。

static String

ExifTIFFTagSet.EXIF_VERSION_2_1

要与ExifVersion标签一起使用的值来表示Exif版本2.1。

static String

ExifTIFFTagSet.EXIF_VERSION_2_2

要与ExifVersion标签一起使用以指示Exif版本2.2的值。

static String

ExifGPSTagSet.GPS_VERSION_2_2

与“GPSVersionID”标签一起使用以指示GPS版本2.2的值。

static String

ExifInteroperabilityTagSet.INTEROPERABILITY_INDEX_R98

要与“InteroperabilityIndex”标签一起使用的值。

static String

ExifInteroperabilityTagSet.INTEROPERABILITY_INDEX_THM

要与“InteroperabilityIndex”标签一起使用的值。

static String

ExifGPSTagSet.LATITUDE_REF_NORTH

与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。

static String

ExifGPSTagSet.LATITUDE_REF_SOUTH

与“GPSLatitudeRef”和“GPSDestLatitudeRef”标签一起使用的值。

static String

ExifGPSTagSet.LONGITUDE_REF_EAST

与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。

static String

ExifGPSTagSet.LONGITUDE_REF_WEST

与“GPSLongitudeRef”和“GPSDestLongitudeRef”标签一起使用的值。

static String

ExifGPSTagSet.MEASURE_MODE_2D

要与“GPSMeasureMode”标签一起使用的值。

static String

ExifGPSTagSet.MEASURE_MODE_3D

要与“GPSMeasureMode”标签一起使用的值。

static String

ExifGPSTagSet.SPEED_REF_KILOMETERS_PER_HOUR

与“GPSSpeedRef”标签一起使用的值。

static String

ExifGPSTagSet.SPEED_REF_KNOTS

与“GPSSpeedRef”标签一起使用的值。

static String

ExifGPSTagSet.SPEED_REF_MILES_PER_HOUR

与“GPSSpeedRef”标签一起使用的值。

static String

ExifGPSTagSet.STATUS_MEASUREMENT_IN_PROGRESS

200：200454545“

static String

ExifGPSTagSet.STATUS_MEASUREMENT_INTEROPERABILITY

200：200454545“

static String

TIFFTag.UNKNOWN_TAG_NAME

分配给具有未知标签号的标签的名称。

Methods in javax.imageio.plugins.tiff that return String

Modifier and Type

方法

描述

String

TIFFField.getAsString​(int index)

返回 TIFFTag.TIFF_ASCII值作为 String 。

String

TIFFTag.getName​()

返回标记的名称，因为它将显示在图像元数据中。

static String

TIFFField.getTypeName​(int dataType)

返回提供的数据类型常量的名称。

String

TIFFField.getValueAsString​(int index)

返回包含数据项的人性化版本的 String 。

String

TIFFTag.getValueName​(int value)

返回与该标签的数据可能占用的特定值相关联的助记符名称，如果没有名称，则 null 。

Methods in javax.imageio.plugins.tiff that return types with arguments of type String

Modifier and Type

方法

描述

SortedSet<String>

TIFFTagSet.getTagNames​()

检索不可修改的词典增加的标签名称集合。

Methods in javax.imageio.plugins.tiff with parameters of type String

Modifier and Type

方法

描述

protected void

TIFFTag.addValueName​(int value, String name)

为此标签的数据可能需要的特定值添加一个助记符名称。

TIFFTag

TIFFTagSet.getTag​(String tagName)

返回 TIFFTag具有给定标记名称，或者 null如果指定的标记不属于这个标签集。

static int

TIFFField.getTypeByName​(String typeName)

返回与提供的数据类型名称相对应的数据类型常量。

Constructors in javax.imageio.plugins.tiff with parameters of type String

Constructor

描述

TIFFTag​(String name, int number, int dataTypes)

构造具有给定名称，标签号和法定数据类型集合的 TIFFTag 。

TIFFTag​(String name, int number, int dataTypes, int count)

构造具有给定名称，标签号，法定数据类型集合和值计数的 TIFFTag 。

TIFFTag​(String name, int number, TIFFTagSet tagSet)

构造一个 TIFFTag与给定的名称，标签号和它所参考的 TIFFTagSet 。

Uses of String in javax.imageio.spi

Fields in javax.imageio.spi declared as String

Modifier and Type

Field

描述

protected String[]

ImageReaderWriterSpi.extraImageMetadataFormatClassNames

包含 String的数组， String包含此插件支持的任何其他图像元数据格式的类名，最初为 null 。

protected String[]

ImageReaderWriterSpi.extraImageMetadataFormatNames

String的数组包含该插件支持的任何其他图像元数据格式的名称，最初为 null 。

protected String[]

ImageReaderWriterSpi.extraStreamMetadataFormatClassNames

包含 String s的数组， String包含此插件支持的任何其他流元数据格式的类名，最初为 null 。

protected String[]

ImageReaderWriterSpi.extraStreamMetadataFormatNames

包含 String的数组， String包含此插件支持的任何其他流元数据格式的名称，最初为 null 。

protected String[]

ImageReaderWriterSpi.MIMETypes

要从 getMIMETypes返回的字符串数组，最初为 null 。

protected String[]

ImageReaderWriterSpi.names

要从 getFormatNames返回的字符串数组，最初为 null 。

protected String

ImageReaderWriterSpi.nativeImageMetadataFormatClassName

A String其中包含此插件支持的本地流元数据格式的类名，最初为 null 。

protected String

ImageReaderWriterSpi.nativeImageMetadataFormatName

A String其中包含此插件支持的本机流元数据格式的名称，最初为 null 。

protected String

ImageReaderWriterSpi.nativeStreamMetadataFormatClassName

A String其中包含此插件支持的本机流元数据格式的类名，最初为 null 。

protected String

ImageReaderWriterSpi.nativeStreamMetadataFormatName

A String包含此插件支持的本地流元数据格式的名称，最初为 null 。

protected String

ImageReaderWriterSpi.pluginClassName

A String包含相关插件类的名称，最初为 null 。

protected String[]

ImageWriterSpi.readerSpiNames

要从 getImageReaderSpiNames返回的字符串数组，最初为 null 。

protected String[]

ImageReaderWriterSpi.suffixes

要从 getFileSuffixes返回的字符串数组，最初为 null 。

protected String

IIOServiceProvider.vendorName

A String从 getVendorName返回，最初为 null 。

protected String

IIOServiceProvider.version

A String从 getVersion返回，最初为null。

protected String[]

ImageReaderSpi.writerSpiNames

要从 getImageWriterSpiNames返回的字符串数组，最初为 null 。

Methods in javax.imageio.spi that return String

Modifier and Type

方法

描述

abstract String

IIOServiceProvider.getDescription​(Locale locale)

返回此服务提供商及其相关实现的简短可读的描述。

String[]

ImageReaderWriterSpi.getExtraImageMetadataFormatNames​()

返回一个包含 String s的数组， String包含由此插件生成或使用的图像元数据对象上的 getAsTree和 setFromTree方法识别的其他文档格式（本机和标准格式）。

String[]

ImageReaderWriterSpi.getExtraStreamMetadataFormatNames​()

返回一个包含 String s的数组， String包含由此插件生成或使用的流元数据对象上的 getAsTree和 setFromTree方法识别的其他文档格式（本机和标准格式）。

String[]

ImageReaderWriterSpi.getFileSuffixes​()

返回一个 String的数组， String包含与此服务提供商关联的 ImageReader或 ImageWriter实现通常可用的格式相关联的文件后缀列表。

String[]

ImageReaderWriterSpi.getFormatNames​()

返回 String的数组， String包含与此服务提供商关联的 ImageReader或 ImageWriter实现通常可用的格式的可读名称。

String[]

ImageWriterSpi.getImageReaderSpiNames​()

返回的数组 String包含所有的所有的完全合格的名称小号 ImageReaderSpi类，可以理解由所使用的内部元数据表示 ImageWriter与此服务提供商相关联，或 null ，如果没有这样的 ImageReaders指定。

String[]

ImageReaderSpi.getImageWriterSpiNames​()

返回的数组 String包含所有的完全合格的名称小号 ImageWriterSpi类，可以理解由所使用的内部元数据表示 ImageReader与此服务提供商相关联，或 null如果没有这样的 ImageWriter指定秒。

String[]

ImageReaderWriterSpi.getMIMETypes​()

返回一个 String的数组， String包含与此服务提供商关联的 ImageReader或 ImageWriter实现通常可用的格式相关联的MIME类型列表。

String

ImageReaderWriterSpi.getNativeImageMetadataFormatName​()

返回此插件的“本机”图像元数据格式的名称，通常允许以由该插件处理的格式存储的图像元数据的无损编码和传输。

String

ImageReaderWriterSpi.getNativeStreamMetadataFormatName​()

返回此插件的“本机”流元数据格式的名称，通常允许以该插件处理的格式存储的流元数据进行无损编码和传输。

String

ImageReaderWriterSpi.getPluginClassName​()

返回与此服务提供商关联的 ImageReader或 ImageWriter插件的完全限定类名。

abstract String

ImageTranscoderSpi.getReaderServiceProviderName​()

返回 ImageReaderSpi类的完全限定类名，该类可生成 IIOMetadata此代码转换器输入的 IIOMetadata对象。

String

IIOServiceProvider.getVendorName​()

返回负责创建此服务提供商及其关联实施的供应商的名称。

String

IIOServiceProvider.getVersion​()

返回描述此服务提供商及其关联实现的版本号的字符串。

abstract String

ImageTranscoderSpi.getWriterServiceProviderName​()

返回 ImageWriterSpi类的完全限定类名，该类可生成 IIOMetadata该代码转换器输入的 IIOMetadata对象。

Methods in javax.imageio.spi with parameters of type String

Modifier and Type

方法

描述

IIOMetadataFormat

ImageReaderWriterSpi.getImageMetadataFormat​(String formatName)

返回一个 IIOMetadataFormat对象描述给定的图像的元数据格式，或 null如果没有可用的描述。

IIOMetadataFormat

ImageReaderWriterSpi.getStreamMetadataFormat​(String formatName)

返回一个 IIOMetadataFormat对象描述给定的流元数据格式，或 null如果没有可用的描述。

Constructors in javax.imageio.spi with parameters of type String

Constructor

描述

IIOServiceProvider​(String vendorName, String version)

构造具有给定供应商名称和版本标识符的 IIOServiceProvider 。

ImageInputStreamSpi​(String vendorName, String version, Class<?> inputClass)

构造一个给定值的一个 ImageInputStreamSpi 。

ImageOutputStreamSpi​(String vendorName, String version, Class<?> outputClass)

构造一个给定值的一个 ImageOutputStreamSpi 。

ImageReaderSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class<?>[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)

构造一个给定值的一个 ImageReaderSpi 。

ImageReaderWriterSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)

构造一个给定值的一个 ImageReaderWriterSpi 。

ImageTranscoderSpi​(String vendorName, String version)

构造一个给定值的一个 ImageTranscoderSpi 。

ImageWriterSpi​(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class<?>[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)

构造一个给定值的一个 ImageWriterSpi 。

Uses of String in javax.imageio.stream

Methods in javax.imageio.stream that return String

Modifier and Type

方法

描述

String

ImageInputStream.readLine​()

从输入流读取下一行文本。

String

ImageInputStreamImpl.readLine​()

String

ImageInputStream.readUTF​()

读取已使用 modified UTF-8格式编码的字符串。

String

ImageInputStreamImpl.readUTF​()

Methods in javax.imageio.stream with parameters of type String

Modifier and Type

方法

描述

void

ImageOutputStream.writeBytes​(String s)

将一个字符串写入输出流。

void

ImageOutputStreamImpl.writeBytes​(String s)

void

ImageOutputStream.writeChars​(String s)

将一个字符串写入输出流。

void

ImageOutputStreamImpl.writeChars​(String s)

void

ImageOutputStream.writeUTF​(String s)

以网络字节顺序将两个字节的长度信息写入输出流，后跟字符串 s中每个字符的 modified UTF-8表示。

void

ImageOutputStreamImpl.writeUTF​(String s)

Uses of String in javax.jnlp

Methods in javax.jnlp that return String

Modifier and Type

方法

描述

String

ExtensionInstallerService.getExtensionVersion​()

返回正在安装的扩展程序的版本

String

ExtensionInstallerService.getInstalledJRE​(URL url, String version)

返回给定JRE的可执行文件的路径。

String

ExtensionInstallerService.getInstallPath​()

返回安装程序建议安装扩展程序的目录。

String

FileContents.getName​()

获取文件名为 String 。

String[]

PersistenceService.getNames​(URL url)

返回一个字符串数组，其中包含给定URL的所有条目的名称。

static String[]

ServiceManager.getServiceNames​()

返回由JNLP Client实现的所有服务的名称。

String[]

ServiceManagerStub.getServiceNames​()

参见 ServiceManager.getServiceNames()的说明

String

DownloadService2.ResourceSpec.getUrl​()

返回此资源的URL。

String

DownloadService2.ResourceSpec.getVersion​()

返回此资源的版本。

String

JNLPRandomAccessFile.readLine​()

从此文件中读取下一行文本。

String

JNLPRandomAccessFile.readUTF​()

从该文件读取字符串。

Methods in javax.jnlp with parameters of type String

Modifier and Type

方法

描述

void

DownloadServiceListener.downloadFailed​(URL url, String version)

如果下载失败或意外中止，JNLP客户端的 DownloadService实现应该调用此方法。

String

ExtensionInstallerService.getInstalledJRE​(URL url, String version)

返回给定JRE的可执行文件的路径。

JNLPRandomAccessFile

FileContents.getRandomAccessFile​(String mode)

返回表示文件内容的随机访问接口的 JNLPRandomAccessFile 。

boolean

IntegrationService.hasAssociation​(String mimetype, String[] extensions)

检查此应用程序是否与指定的mimetype和文件扩展名相关联。

boolean

DownloadService.isExtensionPartCached​(URL ref, String version, String part)

如果给定的扩展名的给定部分被缓存，并且该应用程序的JNLP文件中提到了扩展名和部分，则返回 true 。

boolean

DownloadService.isExtensionPartCached​(URL ref, String version, String[] parts)

如果缓存给定扩展的给定部分，并返回 true ，并且在应用程序的JNLP文件中提到扩展和部件。

boolean

DownloadService.isPartCached​(String part)

如果给定字符串引用的部分被缓存，并且该部分在应用程序的JNLP文件中被提到，则返回 true 。

boolean

DownloadService.isPartCached​(String[] parts)

如果给定数组引用的部分被缓存，并且这些部分在应用程序的JNLP文件中被提到，则返回 true 。

boolean

DownloadService.isResourceCached​(URL ref, String version)

如果给定的URL和版本引用的资源被缓存，并且该资源在调用的应用程序JNLP文件中被提及，则在调用应用程序JNLP文件的代码库中，或者调用应用程序已被授予所有权限，则返回true 。 。

void

DownloadService.loadExtensionPart​(URL ref, String version, String[] parts, DownloadServiceListener progress)

如果在应用程序的JNLP文件中提到了部件和扩展名，请下载给定扩展的给定部分。

void

DownloadService.loadExtensionPart​(URL ref, String version, String part, DownloadServiceListener progress)

如果在应用程序的JNLP文件中提到了部分和扩展名，请下载给定扩展的给定部分。

void

DownloadService.loadPart​(String[] parts, DownloadServiceListener progress)

如果在应用程序的JNLP文件中提到了这些部分，请下载给定的部分。

void

DownloadService.loadPart​(String part, DownloadServiceListener progress)

下载给定的部分，如果该部分在应用程序的JNLP文件中被提到。

void

DownloadService.loadResource​(URL ref, String version, DownloadServiceListener progress)

如果在调用的应用程序JNLP文件中提到资源，请下载给定的资源，是在调用应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。

static Object

ServiceManager.lookup​(String name)

向JNLP客户端询问具有给定名称的服务。

Object

ServiceManagerStub.lookup​(String name)

请参阅 ServiceManager.lookup(java.lang.String)的说明

void

SingleInstanceListener.newActivation​(String[] params)

该方法应该由应用程序来实现，以处理单一实例行为 - 应用程序如何使用params调用应用程序的另一个实例时如何处理参数。

FileContents

FileOpenService.openFileDialog​(String pathHint, String[] extensions)

要求用户选择一个文件。

FileContents[]

FileOpenService.openMultiFileDialog​(String pathHint, String[] extensions)

要求用户选择一个或多个文件。

void

DownloadServiceListener.progress​(URL url, String version, long readSoFar, long total, int overallPercent)

JNLP客户端的 DownloadService实现应该在下载过程中多次调用该方法。

boolean

IntegrationService.removeAssociation​(String mimetype, String[] extensions)

删除此应用程序的关联作为指定的mimetype的处理程序。

void

DownloadService.removeExtensionPart​(URL ref, String version, String part)

如果在应用程序的JNLP文件中提到了部分和扩展名，则从缓存中删除给定扩展的给定部分。

void

DownloadService.removeExtensionPart​(URL ref, String version, String[] parts)

如果在应用程序的JNLP文件中提到了部件和扩展名，则从缓存中删除给定扩展的给定部分。

void

DownloadService.removePart​(String part)

如果在应用程序的JNLP文件中提到了该部分，则从缓存中删除给定的部分。

void

DownloadService.removePart​(String[] parts)

如果在应用程序的JNLP文件中提到了这些部分，则从缓存中删除给定的部分。

void

DownloadService.removeResource​(URL ref, String version)

如果在调用应用程序JNLP文件中提到资源，则从缓存中删除给定的资源，在调用的应用程序JNLP文件的代码库内，或者如果调用应用程序已被授予全部权限。

boolean

IntegrationService.requestAssociation​(String mimetype, String[] extensions)

请求将此应用程序注册为指定的MIME类型和文件扩展名的处理程序。

boolean

IntegrationService.requestShortcut​(boolean desktop, boolean menu, String submenu)

请求为此应用程序创建快捷方式。

FileContents

FileSaveService.saveAsFileDialog​(String pathHint, String[] extensions, FileContents contents)

要求用户保存文件。

FileContents

FileSaveService.saveFileDialog​(String pathHint, String[] extensions, InputStream stream, String name)

要求用户保存文件。

void

ExtensionInstallerService.setHeading​(String heading)

更新进度窗口的标题文本。

void

ExtensionInstallerService.setJREInfo​(String platformVersion, String jrePath)

通知JNLP客户端JRE的可执行文件的路径，如果这是JRE的安装程序，以及该JRE实现的平台版本。

void

ExtensionInstallerService.setNativeLibraryInfo​(String path)

通知JNLP客户端应搜索本机库的目录。

void

ExtensionInstallerService.setStatus​(String status)

更新进度窗口的状态文本。

void

DownloadServiceListener.upgradingArchive​(URL url, String version, int patchPercent, int overallPercent)

JNLP客户端的 DownloadService实现在将缓存资源应用增量更新时至少应该调用此方法。

void

DownloadServiceListener.validating​(URL url, String version, long entry, long total, int overallPercent)

JNLP客户端的 DownloadService实现在验证下载过程中至少应该调用此方法。

void

JNLPRandomAccessFile.writeBytes​(String s)

将字符串作为字节序列写入文件。

void

JNLPRandomAccessFile.writeChars​(String s)

将一个字符串作为字符序列写入文件。

void

JNLPRandomAccessFile.writeUTF​(String str)

使用UTF-8编码以机器无关方式将字符串写入文件。

Constructors in javax.jnlp with parameters of type String

Constructor

描述

ResourceSpec​(String url, String version, int type)

创建一个新的ResourceSpec实例。

UnavailableServiceException​(String msg)

构造具有指定详细消息的 UnavailableServiceException 。

Uses of String in javax.jws

Methods in javax.jws with parameters of type String

Modifier and Type

方法

描述

static WebParam.Mode

WebParam.Mode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javax.jws.soap

Methods in javax.jws.soap with parameters of type String

Modifier and Type

方法

描述

static SOAPBinding.ParameterStyle

SOAPBinding.ParameterStyle.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SOAPBinding.Style

SOAPBinding.Style.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SOAPBinding.Use

SOAPBinding.Use.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javax.lang.model

Methods in javax.lang.model with parameters of type String

Modifier and Type

方法

描述

static SourceVersion

SourceVersion.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javax.lang.model with parameters of type String

Constructor

描述

UnknownEntityException​(String message)

创建一个新的 UnknownEntityException具有指定的详细消息。

Uses of String in javax.lang.model.element

Methods in javax.lang.model.element that return String

Modifier and Type

方法

描述

String

AnnotationValue.toString​()

返回此值的字符串表示形式。

String

Modifier.toString​()

以小写形式返回此修饰符的名称。

Methods in javax.lang.model.element with parameters of type String

Modifier and Type

方法

描述

static ElementKind

ElementKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Modifier

Modifier.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static ModuleElement.DirectiveKind

ModuleElement.DirectiveKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static NestingKind

NestingKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

R

AnnotationValueVisitor.visitString​(String s, P p)

访问注释中的字符串值。

Uses of String in javax.lang.model.type

Methods in javax.lang.model.type that return String

Modifier and Type

方法

描述

String

TypeMirror.toString​()

返回此类型的内容丰富的字符串表示形式。

Methods in javax.lang.model.type with parameters of type String

Modifier and Type

方法

描述

static TypeKind

TypeKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javax.lang.model.util

Methods in javax.lang.model.util that return String

Modifier and Type

方法

描述

String

Elements.getConstantExpression​(Object value)

返回表示原始值或字符串的 常量表达式的文本。

String

Elements.getDocComment​(Element e)

返回元素的文档（“Javadoc”）注释的文本。

Methods in javax.lang.model.util with parameters of type String

Modifier and Type

方法

描述

static Elements.Origin

Elements.Origin.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

R

SimpleAnnotationValueVisitor6.visitString​(String s, P p)

访问注释中的字符串值。

Uses of String in javax.management

Fields in javax.management declared as String

Modifier and Type

Field

描述

static String

AttributeChangeNotification.ATTRIBUTE_CHANGE

指示观察到的MBean属性值已更改的通知类型。

static String

JMX.DEFAULT_VALUE_FIELD

的名称 defaultValue字段。

protected String

MBeanFeatureInfo.description

该功能的人性化描述。

static String

JMX.IMMUTABLE_INFO_FIELD

名称为 immutableInfo字段。

static String

JMX.INTERFACE_CLASS_NAME_FIELD

名称为 interfaceClassName字段。

static String

JMX.LEGAL_VALUES_FIELD

名称为 legalValues字段。

static String

JMX.MAX_VALUE_FIELD

名称为 maxValue字段。

static String

JMX.MIN_VALUE_FIELD

名称为 minValue字段。

static String

JMX.MXBEAN_FIELD

名称为 mxbean字段。

protected String

MBeanFeatureInfo.name

功能的名称。

static String

JMX.OPEN_TYPE_FIELD

名称为 openType字段。

static String

JMX.ORIGINAL_TYPE_FIELD

名称为 originalType字段。

static String

MBeanServerNotification.REGISTRATION_NOTIFICATION

通知类型表示MBean已被注册。

static String

MBeanServerNotification.UNREGISTRATION_NOTIFICATION

通知类型表示MBean已被注销。

Methods in javax.management that return String

Modifier and Type

方法

描述

String

MBeanPermission.getActions​()

返回动作的“规范字符串表示”。

String

AttributeChangeNotification.getAttributeName​()

获取已更改的属性的名称。

String

AttributeValueExp.getAttributeName​()

返回属性名称的字符串表示形式。

String

AttributeChangeNotification.getAttributeType​()

获取已更改的属性的类型。

String

ObjectName.getCanonicalKeyPropertyListString​()

返回键属性列表的字符串表示形式，其中键属性按词法顺序排序。

String

ObjectName.getCanonicalName​()

返回名称的规范形式; 也就是字符串表示，其中属性按词法顺序排序。

String

MBeanInfo.getClassName​()

返回此 MBeanInfo描述的MBean的Java类的名称。

String

ObjectInstance.getClassName​()

返回类部分。

protected String

StandardMBean.getClassName​(MBeanInfo info)

自定义钩子：获取将在此MBean返回的MBeanInfo中使用的className。

String

MBeanServer.getDefaultDomain​()

String

MBeanServerConnection.getDefaultDomain​()

返回用于命名MBean的默认域。

String

MBeanFeatureInfo.getDescription​()

返回该功能的可读描述。

String

MBeanInfo.getDescription​()

返回MBean的可读描述。

protected String

StandardMBean.getDescription​(MBeanAttributeInfo info)

自定义钩子：获取将在此MBean返回的MBeanAttributeInfo中使用的描述。

protected String

StandardMBean.getDescription​(MBeanConstructorInfo info)

自定义钩子：获取将在此MBean返回的MBeanConstructorInfo中使用的描述。

protected String

StandardMBean.getDescription​(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence)

自定义钩子：获取将用于MBean返回的MBeanConstructorInfo的 序列 MBeanParameterInfo的描述。

protected String

StandardMBean.getDescription​(MBeanFeatureInfo info)

自定义钩子：获取将在此MBean返回的MBeanFeatureInfo中使用的描述。

protected String

StandardMBean.getDescription​(MBeanInfo info)

自定义钩子：获取将在此MBean返回的MBeanInfo中使用的描述。

protected String

StandardMBean.getDescription​(MBeanOperationInfo info)

自定义钩子：获取将在此MBean返回的MBeanOperationInfo中使用的描述。

protected String

StandardMBean.getDescription​(MBeanOperationInfo op, MBeanParameterInfo param, int sequence)

自定义钩子：获取将用于MBean返回的MBeanOperationInfo的 序列 MBeanParameterInfo的描述。

String

ObjectName.getDomain​()

返回域部分。

String[]

MBeanServer.getDomains​()

String[]

MBeanServerConnection.getDomains​()

返回任何MBean当前注册的域列表。

String[]

Descriptor.getFieldNames​()

返回描述符中的所有字段名。

String[]

ImmutableDescriptor.getFieldNames​()

String[]

Descriptor.getFields​()

以字符串数组的形式返回此描述符中包含的所有字段。

String[]

ImmutableDescriptor.getFields​()

String

MBeanServerDelegate.getImplementationName​()

返回JMX实现名称（此产品的名称）。

String

MBeanServerDelegateMBean.getImplementationName​()

返回JMX实现名称（此产品的名称）。

String

MBeanServerDelegate.getImplementationVendor​()

返回JMX实现供应商（该产品的供应商）。

String

MBeanServerDelegateMBean.getImplementationVendor​()

返回JMX实现供应商（该产品的供应商）。

String

MBeanServerDelegate.getImplementationVersion​()

返回JMX实现版本（此产品的版本）。

String

MBeanServerDelegateMBean.getImplementationVersion​()

返回JMX实现版本（此产品的版本）。

String

ObjectName.getKeyProperty​(String property)

获取与键属性中的键相关联的值。

String

ObjectName.getKeyPropertyListString​()

返回在创建时指定的关键属性列表的字符串表示形式。

String

MBeanServerDelegate.getMBeanServerId​()

返回MBean服务器代理身份。

String

MBeanServerDelegateMBean.getMBeanServerId​()

返回MBean服务器代理身份。

String

Notification.getMessage​()

获取通知消息。

String

Attribute.getName​()

返回一个包含属性名称的String。

String

MBeanFeatureInfo.getName​()

返回功能的名称。

String[]

MBeanNotificationInfo.getNotifTypes​()

返回包含MBean可能发出的通知类型的字符串数组（以点表示）。

protected String

StandardMBean.getParameterName​(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence)

自定义钩子：获取将用于MBean返回的MBeanConstructorInfo的 序列 MBeanParameterInfo的名称。

protected String

StandardMBean.getParameterName​(MBeanOperationInfo op, MBeanParameterInfo param, int sequence)

自定义钩子：获取将用于MBean返回的MBeanOperationInfo的 序列 MBeanParameterInfo的名称。

String

MBeanOperationInfo.getReturnType​()

返回方法的返回值的类型。

String

MBeanServerDelegate.getSpecificationName​()

返回此产品实现的JMX规范的全称。

String

MBeanServerDelegateMBean.getSpecificationName​()

返回此产品实现的JMX规范的全称。

String

MBeanServerDelegate.getSpecificationVendor​()

返回由本产品实现的JMX规范的供应商。

String

MBeanServerDelegateMBean.getSpecificationVendor​()

返回由本产品实现的JMX规范的供应商。

String

MBeanServerDelegate.getSpecificationVersion​()

返回此产品实现的JMX规范版本。

String

MBeanServerDelegateMBean.getSpecificationVersion​()

返回此产品实现的JMX规范版本。

String

MBeanAttributeInfo.getType​()

返回属性的类名。

String

MBeanParameterInfo.getType​()

返回数据的类型或类名。

String

Notification.getType​()

获取通知类型。

String

StringValueExp.getValue​()

返回由 StringValueExp实例表示的字符串。

static String

ObjectName.quote​(String s)

返回给定String的引用形式，适合包含在ObjectName中。

String

Attribute.toString​()

返回表示此Attribute值的String对象。

String

AttributeValueExp.toString​()

返回表示其值的字符串。

String

BadAttributeValueExpException.toString​()

返回表示对象的字符串。

String

BadBinaryOpValueExpException.toString​()

返回表示对象的字符串。

String

BadStringOperationException.toString​()

返回表示对象的字符串。

String

ImmutableDescriptor.toString​()

String

MBeanAttributeInfo.toString​()

String

MBeanConstructorInfo.toString​()

String

MBeanInfo.toString​()

String

MBeanNotificationInfo.toString​()

String

MBeanOperationInfo.toString​()

String

MBeanParameterInfo.toString​()

String

MBeanServerNotification.toString​()

String

Notification.toString​()

返回此通知的String表示形式。

String

ObjectInstance.toString​()

返回表示此ObjectInstance对象的字符串。

String

ObjectName.toString​()

返回对象名称的字符串表示形式。

String

StringValueExp.toString​()

返回表示对象的字符串。

static String

ObjectName.unquote​(String q)

返回给定String的无引号形式。

Methods in javax.management that return types with arguments of type String

Modifier and Type

方法

描述

Vector<String>

AttributeChangeNotificationFilter.getEnabledAttributes​()

获取此过滤器的所有已启用的属性名称。

Vector<String>

NotificationFilterSupport.getEnabledTypes​()

获取此过滤器的所有启用的通知类型。

Hashtable<String,String>

ObjectName.getKeyPropertyList​()

将关键属性作为Hashtable返回。

Hashtable<String,String>

ObjectName.getKeyPropertyList​()

将关键属性作为Hashtable返回。

Methods in javax.management with parameters of type String

Modifier and Type

方法

描述

static AttributeValueExp

Query.attr​(String name)

返回一个新的属性表达式。

static AttributeValueExp

Query.attr​(String className, String name)

返回一个新的限定属性表达式。

ObjectInstance

MBeanServer.createMBean​(String className, ObjectName name)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServer.createMBean​(String className, ObjectName name, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServer.createMBean​(String className, ObjectName name, ObjectName loaderName)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServer.createMBean​(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServerConnection.createMBean​(String className, ObjectName name)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServerConnection.createMBean​(String className, ObjectName name, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServerConnection.createMBean​(String className, ObjectName name, ObjectName loaderName)

在MBean服务器中实例化并注册一个MBean。

ObjectInstance

MBeanServerConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

在MBean服务器中实例化并注册一个MBean。

static MBeanServer

MBeanServerFactory.createMBeanServer​(String domain)

使用指定的默认域名返回实现MBeanServer接口的新对象。

default ObjectInputStream

MBeanServer.deserialize​(String className, byte[] data)

已过时。
使用MBeanServer.getClassLoaderRepository()获取类加载程序库，并将其用于反序列化。

default ObjectInputStream

MBeanServer.deserialize​(String className, ObjectName loaderName, byte[] data)

已过时。
使用getClassLoader获取反序列化的类加载器。

void

AttributeChangeNotificationFilter.disableAttribute​(String name)

禁用其属性名称等于要发送给侦听器的指定属性名称的所有属性更改通知。

void

NotificationFilterSupport.disableType​(String prefix)

从前缀列表中删除给定的前缀。

void

AttributeChangeNotificationFilter.enableAttribute​(String name)

启用所有属性更改通知，其属性名称等于要发送给侦听器的指定名称。

void

NotificationFilterSupport.enableType​(String prefix)

启用所有类型的通知以指定的前缀开始发送到侦听器。

static ArrayList<MBeanServer>

MBeanServerFactory.findMBeanServer​(String agentId)

返回已注册MBeanServer对象的列表。

Object

DynamicMBean.getAttribute​(String attribute)

获取动态MBean的特定属性的值。

Object

MBeanServer.getAttribute​(ObjectName name, String attribute)

Object

MBeanServerConnection.getAttribute​(ObjectName name, String attribute)

获取命名MBean的特定属性的值。

Object

StandardMBean.getAttribute​(String attribute)

AttributeList

DynamicMBean.getAttributes​(String[] attributes)

获取动态MBean的几个属性的值。

AttributeList

MBeanServer.getAttributes​(ObjectName name, String[] attributes)

AttributeList

MBeanServerConnection.getAttributes​(ObjectName name, String[] attributes)

检索命名MBean的几个属性的值。

AttributeList

StandardMBean.getAttributes​(String[] attributes)

Object

Descriptor.getFieldValue​(String fieldName)

返回特定字段名称的值，如果该名称没有值，则返回null。

Object

ImmutableDescriptor.getFieldValue​(String fieldName)

Object[]

Descriptor.getFieldValues​(String... fieldNames)

将描述符中的所有字段值作为对象数组返回。

Object[]

ImmutableDescriptor.getFieldValues​(String... fieldNames)

static ObjectName

ObjectName.getInstance​(String name)

返回一个ObjectName的实例，可以在任何地方使用可以使用 new ObjectName(name)获得的对象。

static ObjectName

ObjectName.getInstance​(String domain, String key, String value)

返回一个ObjectName的实例，可以在使用 new ObjectName(domain, key, value)获得的对象的任何地方使用。

static ObjectName

ObjectName.getInstance​(String domain, Hashtable<String,String> table)

返回一个ObjectName实例，可以在任何地方使用可以使用 new ObjectName(domain, table)获得的对象。

String

ObjectName.getKeyProperty​(String property)

获取与键属性中的键相关联的值。

Object

MBeanServer.instantiate​(String className)

使用在MBean服务器的Class Loader Repository中注册的所有类加载器的列表来实例化对象。

Object

MBeanServer.instantiate​(String className, Object[] params, String[] signature)

使用在MBean服务器Class Loader Repository中注册的所有类加载器的列表来实例化对象。

Object

MBeanServer.instantiate​(String className, ObjectName loaderName)

使用由其 ObjectName指定的类Loader来实例化一个对象。

Object

MBeanServer.instantiate​(String className, ObjectName loaderName, Object[] params, String[] signature)

实例化一个对象。

Object

DynamicMBean.invoke​(String actionName, Object[] params, String[] signature)

允许在动态MBean上调用操作。

Object

MBeanServer.invoke​(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke​(ObjectName name, String operationName, Object[] params, String[] signature)

调用MBean上的操作。

Object

StandardMBean.invoke​(String actionName, Object[] params, String[] signature)

boolean

MBeanServer.isInstanceOf​(ObjectName name, String className)

boolean

MBeanServerConnection.isInstanceOf​(ObjectName name, String className)

如果指定的MBean是指定类的实例，则返回true，否则返回false。

boolean

ObjectName.isPropertyValuePattern​(String property)

检查与键属性中的键相关联的值是否为模式。

static Class<?>

DefaultLoaderRepository.loadClass​(String className)

已过时。

浏览类加载器列表，并尝试加载所请求的类。

static Class<?>

DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)

已过时。

通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。

MBeanServer

MBeanServerBuilder.newMBeanServer​(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)

此方法创建一个新的MBeanServer实现对象。

static MBeanServer

MBeanServerFactory.newMBeanServer​(String domain)

使用指定的默认域名返回实现MBeanServer接口的新对象，而不保留对此新对象的内部引用。

static String

ObjectName.quote​(String s)

返回给定String的引用形式，适合包含在ObjectName中。

void

Descriptor.removeField​(String fieldName)

从描述符中删除一个字段。

void

ImmutableDescriptor.removeField​(String fieldName)

从描述符中删除一个字段。

void

Descriptor.setField​(String fieldName, Object fieldValue)

设置特定字段名称的值。

void

ImmutableDescriptor.setField​(String fieldName, Object fieldValue)

此操作不受支持，因为此类是不可变的。

void

Descriptor.setFields​(String[] fieldNames, Object[] fieldValues)

将字段名称数组中的所有字段设置为字段值数组中具有相同索引的新值。

void

ImmutableDescriptor.setFields​(String[] fieldNames, Object[] fieldValues)

此操作不受支持，因为此类是不可变的。

static String

ObjectName.unquote​(String q)

返回给定String的无引号形式。

static StringValueExp

Query.value​(String val)

返回新的字符串表达式。

Method parameters in javax.management with type arguments of type String

Modifier and Type

方法

描述

static ObjectName

ObjectName.getInstance​(String domain, Hashtable<String,String> table)

返回可以使用任何可以使用 new ObjectName(domain, table)获取的对象的ObjectName实例。

static ObjectName

ObjectName.getInstance​(String domain, Hashtable<String,String> table)

返回一个ObjectName的实例，可以在任何可以使用 new ObjectName(domain, table)获得的对象的地方使用。

Constructors in javax.management with parameters of type String

Constructor

描述

Attribute​(String name, Object value)

构造一个将给定属性名称与给定值相关联的属性对象。

AttributeChangeNotification​(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)

构造属性更改通知对象。

AttributeNotFoundException​(String message)

允许指定特定错误消息的构造方法。

AttributeValueExp​(String attr)

创建一个新的 AttributeValueExp表示指定的对象属性，名为attr。

BadStringOperationException​(String message)

构造具有指定详细消息的 BadStringOperationException 。

ImmutableDescriptor​(String... fields)

构造一个包含给定字段的描述符。

ImmutableDescriptor​(String[] fieldNames, Object[] fieldValues)

构造一个包含给定字段和值的描述符。

InstanceAlreadyExistsException​(String message)

允许指定特定错误消息的构造方法。

InstanceNotFoundException​(String message)

允许指定特定错误消息的构造方法。

IntrospectionException​(String message)

允许指定特定错误消息的构造方法。

InvalidAttributeValueException​(String message)

允许指定特定错误消息的构造方法。

JMException​(String msg)

允许指定特定错误消息的构造方法。

JMRuntimeException​(String message)

允许指定特定错误消息的构造方法。

ListenerNotFoundException​(String message)

允许指定特定错误消息的构造方法。

MalformedObjectNameException​(String message)

允许指定特定错误消息的构造方法。

MBeanAttributeInfo​(String name, String description, 方法 getter, 方法 setter)

该构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。

MBeanAttributeInfo​(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)

构造一个 MBeanAttributeInfo对象。

MBeanAttributeInfo​(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)

构造一个 MBeanAttributeInfo对象。

MBeanConstructorInfo​(String description, Constructor<?> constructor)

构造一个 MBeanConstructorInfo对象。

MBeanConstructorInfo​(String name, String description, MBeanParameterInfo[] signature)

构造一个 MBeanConstructorInfo对象。

MBeanConstructorInfo​(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)

构造一个 MBeanConstructorInfo对象。

MBeanException​(异常 e, String message)

创建一个 MBeanException ，其中包含实际的 java.lang.Exception和详细消息。

MBeanFeatureInfo​(String name, String description)

构造一个 MBeanFeatureInfo对象。

MBeanFeatureInfo​(String name, String description, Descriptor descriptor)

构造一个 MBeanFeatureInfo对象。

MBeanInfo​(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)

构造一个 MBeanInfo 。

MBeanInfo​(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)

构造一个 MBeanInfo 。

MBeanNotificationInfo​(String[] notifTypes, String name, String description)

构造一个 MBeanNotificationInfo对象。

MBeanNotificationInfo​(String[] notifTypes, String name, String description, Descriptor descriptor)

构造一个 MBeanNotificationInfo对象。

MBeanOperationInfo​(String description, 方法 method)

构造一个 MBeanOperationInfo对象。

MBeanOperationInfo​(String name, String description, MBeanParameterInfo[] signature, String type, int impact)

构造一个 MBeanOperationInfo对象。

MBeanOperationInfo​(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)

构造一个 MBeanOperationInfo对象。

MBeanParameterInfo​(String name, String type, String description)

构造一个 MBeanParameterInfo对象。

MBeanParameterInfo​(String name, String type, String description, Descriptor descriptor)

构造一个 MBeanParameterInfo对象。

MBeanPermission​(String name, String actions)

使用指定的目标名称和操作创建一个新的MBeanPermission对象。

MBeanPermission​(String className, String member, ObjectName objectName, String actions)

使用指定的目标名称（类名，成员，对象名称）和操作创建新的MBeanPermission对象。

MBeanRegistrationException​(异常 e, String message)

创建一个 MBeanRegistrationException ，其中包含实际的 java.lang.Exception详细消息。

MBeanServerNotification​(String type, Object source, long sequenceNumber, ObjectName objectName)

创建一个MBeanServerNotification对象，指定导致通知的MBean的对象名称和指定的通知类型。

MBeanServerPermission​(String name)

使用给定的名称创建一个新的MBeanServerPermission。

MBeanServerPermission​(String name, String actions)

使用给定的名称创建一个新的MBeanServerPermission。

MBeanTrustPermission​(String name)

使用给定的名称创建一个新的MBeanTrustPermission。

MBeanTrustPermission​(String name, String actions)

使用给定的名称创建一个新的MBeanTrustPermission。

NotCompliantMBeanException​(String message)

允许指定特定错误消息的构造方法。

Notification​(String type, Object source, long sequenceNumber)

创建Notification对象。

Notification​(String type, Object source, long sequenceNumber, long timeStamp)

创建Notification对象。

Notification​(String type, Object source, long sequenceNumber, long timeStamp, String message)

创建Notification对象。

Notification​(String type, Object source, long sequenceNumber, String message)

创建Notification对象。

ObjectInstance​(String objectName, String className)

允许创建对象实例，并提供对象名称和完整类名称（包括包名称）的字符串表示形式。

ObjectInstance​(ObjectName objectName, String className)

允许在给定对象名称和完整的类名称（包括包名称）的情况下创建对象实例。

ObjectName​(String name)

从给定的字符串构造一个对象名称。

ObjectName​(String domain, String key, String value)

用一个key属性构造对象名。

ObjectName​(String domain, Hashtable<String,String> table)

从Hashtable构造具有多个关键属性的对象名称。

OperationsException​(String message)

允许指定特定错误消息的构造方法。

ReflectionException​(异常 e, String message)

创建一个 ReflectionException ，其中包含实际的 java.lang.Exception与详细信息。

RuntimeErrorException​(Error e, String message)

允许指定特定错误消息的构造方法。

RuntimeMBeanException​(RuntimeException e, String message)

创建一个 RuntimeMBeanException ，其中包含实际的 java.lang.RuntimeException详细消息。

RuntimeOperationsException​(RuntimeException e, String message)

创建一个 RuntimeOperationsException它包裹了实际的 java.lang.RuntimeException与详细的消息。

ServiceNotFoundException​(String message)

允许指定特定错误消息的构造方法。

StringValueExp​(String val)

创建一个新的 StringValueExp表示给定的字符串。

Constructor parameters in javax.management with type arguments of type String

Constructor

描述

ImmutableDescriptor​(Map<String,?> fields)

构造描述符，其中字段的名称和值是给定Map的键和值。

ObjectName​(String domain, Hashtable<String,String> table)

从Hashtable构造具有多个关键属性的对象名称。

ObjectName​(String domain, Hashtable<String,String> table)

从Hashtable构造具有多个关键属性的对象名称。

Uses of String in javax.management.loading

Methods in javax.management.loading that return String

Modifier and Type

方法

描述

protected String

MLet.findLibrary​(String libname)

返回本机库的绝对路径名。

String

MLetContent.getCode​()

获取 MLET标签的 CODE属性的值。

String

MLetContent.getJarFiles​()

获取由 MLET标签的 ARCHIVE属性指定的 .jar文件的列表。

String

MLet.getLibraryDirectory​()

获取库加载器用于存储本机库的当前目录，然后再将其加载到内存中。

String

MLetMBean.getLibraryDirectory​()

获取库加载器用于存储本机库的当前目录，然后再将其加载到内存中。

String

MLetContent.getName​()

获取 MLET标签的 NAME属性的值。

String

MLetContent.getSerializedObject​()

获取 MLET标签的 OBJECT属性的值。

String

MLetContent.getVersion​()

获取 MLET标签的 VERSION属性的值。

Methods in javax.management.loading that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,String>

MLetContent.getAttributes​()

获取 MLET标签的属性。

Map<String,String>

MLetContent.getAttributes​()

获取 MLET标签的属性。

List<String>

MLetContent.getParameterTypes​()

获取的值的列表 TYPE在中每个嵌套<PARAM>标记属性 MLET标签。

List<String>

MLetContent.getParameterValues​()

获取的值的列表 VALUE在中每个嵌套<PARAM>标记属性 MLET标签。

Methods in javax.management.loading with parameters of type String

Modifier and Type

方法

描述

void

MLet.addURL​(String url)

将指定的URL附加到URL列表中以搜索类和资源。

void

MLetMBean.addURL​(String url)

将指定的URL附加到URL列表中以搜索类和资源。

protected URL

MLet.check​(String version, URL codebase, String jarfile, MLetContent mlet)

当扩展此服务以支持缓存和版本控制时，此方法将被覆盖。

protected Class<?>

MLet.findClass​(String name)

这是正在重新定义的类加载器的主要方法。

protected String

MLet.findLibrary​(String libname)

返回本机库的绝对路径名。

Set<Object>

MLet.getMBeansFromURL​(String url)

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

Set<Object>

MLetMBean.getMBeansFromURL​(String url)

加载一个包含定义要添加到MBean服务器的MBean的MLET标签的文本文件。

URL

MLetMBean.getResource​(String name)

找到具有给定名称的资源。

InputStream

MLetMBean.getResourceAsStream​(String name)

返回用于读取指定资源的输入流。

Enumeration<URL>

MLetMBean.getResources​(String name)

查找具有给定名称的所有资源。

Class<?>

ClassLoaderRepository.loadClass​(String className)

通过类加载器列表加载给定的类名。

static Class<?>

DefaultLoaderRepository.loadClass​(String className)

已过时。

浏览类加载器列表，并尝试加载所请求的类。

Class<?>

MLet.loadClass​(String name, ClassLoaderRepository clr)

加载一个类，使用给定的ClassLoaderRepository如果在这个MLet的URL中找不到该类。

Class<?>

ClassLoaderRepository.loadClassBefore​(ClassLoader stop, String className)

通过加载器列表加载给定的类名，停止在给定的类名称。

Class<?>

ClassLoaderRepository.loadClassWithout​(ClassLoader exclude, String className)

通过类加载器列表加载给定的类名，不包括给定的类名。

static Class<?>

DefaultLoaderRepository.loadClassWithout​(ClassLoader loader, String className)

已过时。

通过类加载器列表，但排除给定的类加载器，然后尝试加载所请求的类。

void

MLet.setLibraryDirectory​(String libdir)

设置用于存储本机库的库加载器使用的目录，然后将其加载到内存中。

void

MLetMBean.setLibraryDirectory​(String libdir)

设置用于存储本机库的库加载器使用的目录，然后将其加载到内存中。

Constructor parameters in javax.management.loading with type arguments of type String

Constructor

描述

MLetContent​(URL url, Map<String,String> attributes, List<String> types, List<String> values)

创建一个 MLet实例，使用从MLet文本文件中的 MLET标记读取的属性进行初始化。

MLetContent​(URL url, Map<String,String> attributes, List<String> types, List<String> values)

创建一个 MLet实例，使用从MLet文本文件中的 MLET标记读取的属性进行初始化。

MLetContent​(URL url, Map<String,String> attributes, List<String> types, List<String> values)

创建一个 MLet实例，使用从MLet文本文件中的 MLET标记读取的属性初始化。

Uses of String in javax.management.modelmbean

Methods in javax.management.modelmbean that return String

Modifier and Type

方法

描述

String

ModelMBeanInfo.getClassName​()

返回此 MBeanInfo描述的MBean的Java类的名称。

String

ModelMBeanInfo.getDescription​()

返回MBean的可读描述。

String[]

DescriptorSupport.getFieldNames​()

String[]

DescriptorSupport.getFields​()

String

DescriptorSupport.toString​()

返回表示描述符的人类可读字符串。

String

ModelMBeanAttributeInfo.toString​()

返回一个可读的ModelMBeanAttributeInfo实例版本。

String

ModelMBeanConstructorInfo.toString​()

返回一个包含ModelMBeanConstructorInfo的全部内容的字符串，以人类可读的形式显示。

String

ModelMBeanNotificationInfo.toString​()

返回一个包含ModelMBeanNotificationInfo的可读字符串。

String

ModelMBeanOperationInfo.toString​()

返回一个包含以可读的形式显示的ModelMBeanOperationInfo的全部内容的字符串。

String

DescriptorSupport.toXMLString​()

返回表示描述符的XML字符串。

Methods in javax.management.modelmbean with parameters of type String

Modifier and Type

方法

描述

void

ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener​(NotificationListener listener, String attributeName, Object handback)

注册一个实现NotificationListener接口的对象作为监听器。

void

RequiredModelMBean.addAttributeChangeNotificationListener​(NotificationListener inlistener, String inAttributeName, Object inhandback)

ModelMBeanAttributeInfo

ModelMBeanInfo.getAttribute​(String inName)

返回名称请求的ModelMBeanAttributeInfo。

ModelMBeanAttributeInfo

ModelMBeanInfoSupport.getAttribute​(String inName)

Object

RequiredModelMBean.getAttribute​(String attrName)

返回为此ModelMBean定义的特定属性的值。

AttributeList

RequiredModelMBean.getAttributes​(String[] attrNames)

返回ModelMBean中的几个属性的值。

ModelMBeanConstructorInfo

ModelMBeanInfoSupport.getConstructor​(String inName)

返回名称请求的ModelMBeanConstructorInfo。

Descriptor

ModelMBeanInfo.getDescriptor​(String inDescriptorName, String inDescriptorType)

返回由name和descriptorType请求的描述符。

Descriptor

ModelMBeanInfoSupport.getDescriptor​(String inDescriptorName)

返回名称请求的描述符。

Descriptor

ModelMBeanInfoSupport.getDescriptor​(String inDescriptorName, String inDescriptorType)

Descriptor[]

ModelMBeanInfo.getDescriptors​(String inDescriptorType)

返回一个Descriptor数组，它由TypeDelegorType类型的ModelMBeanInfo的所有描述符组成。

Descriptor[]

ModelMBeanInfoSupport.getDescriptors​(String inDescriptorType)

Object

DescriptorSupport.getFieldValue​(String fieldName)

Object[]

DescriptorSupport.getFieldValues​(String... fieldNames)

ModelMBeanNotificationInfo

ModelMBeanInfo.getNotification​(String inName)

返回名称请求的ModelMBeanNotificationInfo。

ModelMBeanNotificationInfo

ModelMBeanInfoSupport.getNotification​(String inName)

ModelMBeanOperationInfo

ModelMBeanInfo.getOperation​(String inName)

返回名称请求的ModelMBeanOperationInfo。

ModelMBeanOperationInfo

ModelMBeanInfoSupport.getOperation​(String inName)

Object

RequiredModelMBean.invoke​(String opName, Object[] opArgs, String[] sig)

通过或者通过RequiredModelMBean调用方法，并返回方法执行的结果。

void

ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener​(NotificationListener listener, String attributeName)

从RequiredModelMBean中删除attributeChangeNotifications的侦听器。

void

RequiredModelMBean.removeAttributeChangeNotificationListener​(NotificationListener inlistener, String inAttributeName)

void

DescriptorSupport.removeField​(String fieldName)

void

ModelMBeanNotificationBroadcaster.sendNotification​(String ntfyText)

发送一个通知，其中包含传递给ModelMBean上注册的通知侦听器的文本字符串。

void

RequiredModelMBean.sendNotification​(String ntfyText)

void

ModelMBeanInfo.setDescriptor​(Descriptor inDescriptor, String inDescriptorType)

在ModelMBean的类型为inDescriptorType的info数组中设置描述符。

void

ModelMBeanInfoSupport.setDescriptor​(Descriptor inDescriptor, String inDescriptorType)

void

DescriptorSupport.setField​(String fieldName, Object fieldValue)

void

DescriptorSupport.setFields​(String[] fieldNames, Object[] fieldValues)

void

ModelMBean.setManagedResource​(Object mr, String mr_type)

设置要在此ModelMBean管理界面（MBeanInfo和Descriptors）中执行所有方法的对象的实例句柄。

void

RequiredModelMBean.setManagedResource​(Object mr, String mr_type)

设置要在此ModelMBean管理界面（MBeanInfo和Descriptors）中执行所有方法的对象的实例句柄。

Constructors in javax.management.modelmbean with parameters of type String

Constructor

描述

DescriptorSupport​(String inStr)

描述符构造函数采用XML字符串。

DescriptorSupport​(String... fields)

构造器采用 fieldName = fieldValue格式的字段。

DescriptorSupport​(String[] fieldNames, Object[] fieldValues)

构造器获取字段名称和字段值。

InvalidTargetObjectTypeException​(异常 e, String s)

构造器接受异常和字符串。

InvalidTargetObjectTypeException​(String s)

一个字符串的构造方法

ModelMBeanAttributeInfo​(String name, String description, 方法 getter, 方法 setter)

使用默认描述符构造一个ModelMBeanAttributeInfo对象。

ModelMBeanAttributeInfo​(String name, String description, 方法 getter, 方法 setter, Descriptor descriptor)

构造一个ModelMBeanAttributeInfo对象。

ModelMBeanAttributeInfo​(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)

使用默认描述符构造一个ModelMBeanAttributeInfo对象。

ModelMBeanAttributeInfo​(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)

构造一个ModelMBeanAttributeInfo对象。

ModelMBeanConstructorInfo​(String description, Constructor<?> constructorMethod)

使用默认描述符构造一个ModelMBeanConstructorInfo对象。

ModelMBeanConstructorInfo​(String description, Constructor<?> constructorMethod, Descriptor descriptor)

构造一个ModelMBeanConstructorInfo对象。

ModelMBeanConstructorInfo​(String name, String description, MBeanParameterInfo[] signature)

使用默认描述符构造一个ModelMBeanConstructorInfo对象。

ModelMBeanConstructorInfo​(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)

构造一个ModelMBeanConstructorInfo对象。

ModelMBeanInfoSupport​(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)

使用提供的信息创建一个ModelMBeanInfoSupport，但描述符是默认值。

ModelMBeanInfoSupport​(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)

使用参数中提供的信息和描述符创建一个ModelMBeanInfoSupport。

ModelMBeanNotificationInfo​(String[] notifTypes, String name, String description)

使用默认描述符构造一个ModelMBeanNotificationInfo对象。

ModelMBeanNotificationInfo​(String[] notifTypes, String name, String description, Descriptor descriptor)

构造一个ModelMBeanNotificationInfo对象。

ModelMBeanOperationInfo​(String description, 方法 operationMethod)

使用默认描述符构造一个ModelMBeanOperationInfo对象。

ModelMBeanOperationInfo​(String description, 方法 operationMethod, Descriptor descriptor)

构造一个ModelMBeanOperationInfo对象。

ModelMBeanOperationInfo​(String name, String description, MBeanParameterInfo[] signature, String type, int impact)

使用默认描述符构造一个ModelMBeanOperationInfo对象。

ModelMBeanOperationInfo​(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)

构造一个ModelMBeanOperationInfo对象。

XMLParseException​(异常 e, String s)

构造函数采用字符串和异常。

XMLParseException​(String s)

构造函数采用字符串。

Uses of String in javax.management.monitor

Fields in javax.management.monitor declared as String

Modifier and Type

Field

描述

protected String

Monitor.dbgTag

已过时。
没有替换

static String

MonitorNotification.OBSERVED_ATTRIBUTE_ERROR

通知类型表示观察到的属性不包含在观察对象中。

static String

MonitorNotification.OBSERVED_ATTRIBUTE_TYPE_ERROR

通知类型表示观察属性的类型不正确。

static String

MonitorNotification.OBSERVED_OBJECT_ERROR

通知类型表示观察到的对象未在MBean服务器中注册。

static String

MonitorNotification.RUNTIME_ERROR

指示在尝试获取观察属性的值时发生非预定义错误类型的通知类型。

static String

MonitorNotification.STRING_TO_COMPARE_VALUE_DIFFERED

通知类型表示观察到的属性与“字符串比较”值不同。

static String

MonitorNotification.STRING_TO_COMPARE_VALUE_MATCHED

通知类型表示观察到的属性与“string to compare”值匹配。

static String

MonitorNotification.THRESHOLD_ERROR

通知类型表示阈值类型，偏移量或模数不正确。

static String

MonitorNotification.THRESHOLD_HIGH_VALUE_EXCEEDED

通知类型表示观察属性已超过阈值高值。

static String

MonitorNotification.THRESHOLD_LOW_VALUE_EXCEEDED

通知类型表示观察属性已超过阈值低值。

static String

MonitorNotification.THRESHOLD_VALUE_EXCEEDED

表示观察属性达到阈值的通知类型。

Methods in javax.management.monitor that return String

Modifier and Type

方法

描述

String

StringMonitor.getDerivedGauge​()

已过时。
截至JMX 1.2，由StringMonitor.getDerivedGauge(ObjectName)替代

String

StringMonitor.getDerivedGauge​(ObjectName object)

如果该对象包含在观察到的MBean集合中，则获取指定对象的派生规格，否则为 null 。

String

StringMonitorMBean.getDerivedGauge​()

已过时。
截至JMX 1.2，由StringMonitorMBean.getDerivedGauge(ObjectName)取代

String

StringMonitorMBean.getDerivedGauge​(ObjectName object)

获取指定MBean的派生量规。

String

Monitor.getObservedAttribute​()

获取正在观察的属性。

String

MonitorMBean.getObservedAttribute​()

获取正在观察的属性。

String

MonitorNotification.getObservedAttribute​()

获取此监视器通知的观察属性。

String

StringMonitor.getStringToCompare​()

获取与所有观察到的MBean共有的观察属性进行比较的字符串。

String

StringMonitorMBean.getStringToCompare​()

获取与所观察属性进行比较的字符串。

Methods in javax.management.monitor with parameters of type String

Modifier and Type

方法

描述

void

Monitor.setObservedAttribute​(String attribute)

设置要观察的属性。

void

MonitorMBean.setObservedAttribute​(String attribute)

设置要观察的属性。

void

StringMonitor.setStringToCompare​(String value)

将字符串设置为与所有观察到的MBean共有的观察属性进行比较。

void

StringMonitorMBean.setStringToCompare​(String value)

设置与所观察属性进行比较的字符串。

Constructors in javax.management.monitor with parameters of type String

Constructor

描述

MonitorSettingException​(String message)

允许指定错误消息的构造方法。

Uses of String in javax.management.openmbean

Fields in javax.management.openmbean declared as String

Modifier and Type

Field

描述

static String[]

OpenType.ALLOWED_CLASSNAMES

已过时。
改用ALLOWED_CLASSNAMES_LIST 。

Fields in javax.management.openmbean with type parameters of type String

Modifier and Type

Field

描述

static List<String>

OpenType.ALLOWED_CLASSNAMES_LIST

列出允许开放数据值的Java类的完全限定名称。

static SimpleType<String>

SimpleType.STRING

描述Java类名称为 java.lang.String值的 SimpleType实例。

Methods in javax.management.openmbean that return String

Modifier and Type

方法

描述

String

OpenMBeanInfo.getClassName​()

返回 OpenMBeanInfo描述的开放MBean实例的完全限定Java类名。

String

OpenType.getClassName​()

返回此开放类型描述的开放数据值的完全限定Java类名称。

String

CompositeType.getDescription​(String itemName)

返回其名称为 itemName，或该项目的描述 null如果 CompositeType实例不定义其名称为 itemName的任何项目。

String

OpenMBeanConstructorInfo.getDescription​()

返回此 OpenMBeanConstructorInfo实例描述的构造函数的可读描述。

String

OpenMBeanInfo.getDescription​()

返回对 OpenMBeanInfo描述的开放MBean实例类型的可读描述。

String

OpenMBeanOperationInfo.getDescription​()

返回此 OpenMBeanOperationInfo实例描述的操作的可读描述。

String

OpenMBeanParameterInfo.getDescription​()

返回此 OpenMBeanParameterInfo实例描述的参数的可读描述。

String

OpenType.getDescription​()

返回此 OpenType实例的文本描述。

String

OpenMBeanConstructorInfo.getName​()

返回此 OpenMBeanConstructorInfo实例描述的构造函数的名称。

String

OpenMBeanOperationInfo.getName​()

返回此 OpenMBeanOperationInfo实例描述的操作的名称。

String

OpenMBeanParameterInfo.getName​()

返回此 OpenMBeanParameterInfo实例描述的参数的名称。

String

OpenMBeanOperationInfo.getReturnType​()

返回由该 OpenMBeanOperationInfo实例描述的操作返回的值的完全限定Java类名。

String

OpenType.getTypeName​()

返回此 OpenType实例的名称。

String

ArrayType.toString​()

返回此 ArrayType实例的字符串表示形式。

String

CompositeData.toString​()

返回此 CompositeData实例的字符串表示形式。

String

CompositeDataSupport.toString​()

返回此 CompositeDataSupport实例的字符串表示形式。

String

CompositeType.toString​()

返回此 CompositeType实例的字符串表示形式。

String

OpenMBeanAttributeInfo.toString​()

返回此 OpenMBeanAttributeInfo实例的字符串表示形式。

String

OpenMBeanAttributeInfoSupport.toString​()

返回此 OpenMBeanAttributeInfoSupport实例的字符串表示形式。

String

OpenMBeanConstructorInfo.toString​()

返回此 OpenMBeanConstructorInfo实例的字符串表示形式。

String

OpenMBeanConstructorInfoSupport.toString​()

返回此 OpenMBeanConstructorInfoSupport实例的字符串表示形式。

String

OpenMBeanInfo.toString​()

返回此 OpenMBeanInfo实例的字符串表示形式。

String

OpenMBeanInfoSupport.toString​()

返回此 OpenMBeanInfoSupport实例的字符串表示形式。

String

OpenMBeanOperationInfo.toString​()

返回此 OpenMBeanOperationInfo实例的字符串表示形式。

String

OpenMBeanOperationInfoSupport.toString​()

返回此 OpenMBeanOperationInfoSupport实例的字符串表示形式。

String

OpenMBeanParameterInfo.toString​()

返回此 OpenMBeanParameterInfo实例的字符串表示形式。

String

OpenMBeanParameterInfoSupport.toString​()

返回此 OpenMBeanParameterInfoSupport实例的字符串表示形式。

abstract String

OpenType.toString​()

返回此打开类型实例的字符串表示形式。

String

SimpleType.toString​()

返回此 SimpleType实例的字符串表示形式。

String

TabularData.toString​()

返回此 TabularData实例的字符串表示形式。

String

TabularDataSupport.toString​()

返回此 TabularDataSupport实例的字符串表示形式。

String

TabularType.toString​()

返回此 TabularType实例的字符串表示形式。

Methods in javax.management.openmbean that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

TabularType.getIndexNames​()

以与给该实例的构造函数相同的顺序返回一个不可修改的列的名称，其值用于唯一地索引该 TabularType实例描述的表格数据值的每个行元素。

Set<String>

CompositeType.keySet​()

返回此 CompositeType实例定义的所有项目名称的不可修改的集合视图。

Methods in javax.management.openmbean with parameters of type String

Modifier and Type

方法

描述

boolean

CompositeData.containsKey​(String key)

返回 true当且仅当此 CompositeData实例包含名称是项目 key 。

boolean

CompositeDataSupport.containsKey​(String key)

返回 true当且仅当此 CompositeData实例包含名称是项目 key 。

boolean

CompositeType.containsKey​(String itemName)

如果此 CompositeType实例定义名称为 itemName的项目，则返回 true 。

Object

CompositeData.get​(String key)

返回名称为 key的项目的值。

Object

CompositeDataSupport.get​(String key)

返回名称为 key的项目的值。

Object[]

CompositeData.getAll​(String[] keys)

返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。

Object[]

CompositeDataSupport.getAll​(String[] keys)

返回其名称由被指定的项目的值的数组 keys ，以相同的顺序为 keys 。

String

CompositeType.getDescription​(String itemName)

返回其名称为 itemName，或该项目的描述 null如果 CompositeType实例不定义其名称为 itemName的任何项目。

OpenType<?>

CompositeType.getType​(String itemName)

返回 开放类型 ，其名称为 itemName，或该项目的 null如果 CompositeType实例不定义其名称为 itemName的任何项目。

Constructors in javax.management.openmbean with parameters of type String

Constructor

描述

CompositeDataSupport​(CompositeType compositeType, String[] itemNames, Object[] itemValues)

构造一个 CompositeDataSupport实例与指定 compositeType ，其项值由指定 itemValues[] ，以相同的顺序为 itemNames[] 。

CompositeType​(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)

构造一个 CompositeType实例，检查给定参数的有效性。

InvalidKeyException​(String msg)

带有详细消息的InvalidKeyException。

InvalidOpenTypeException​(String msg)

带有详细消息的InvalidOpenTypeException。

KeyAlreadyExistsException​(String msg)

具有详细消息的KeyAlreadyExistsException。

OpenDataException​(String msg)

具有详细消息的OpenDataException。

OpenMBeanAttributeInfoSupport​(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)

构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放MBean的与指定的属性 name ， openType和 description ，以及指定的读/写访问属性。

OpenMBeanAttributeInfoSupport​(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)

构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放的MBean具有指定的属性 name ， openType ， description ，读/写访问属性，和 Descriptor 。

OpenMBeanAttributeInfoSupport​(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)

构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放MBean的属性具有指定 name ， openType ， description和 defaultValue ，以及指定的读/写访问属性。

OpenMBeanAttributeInfoSupport​(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)

构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放MBean的属性，与指定 name ， openType ， description ， defaultValue ， minValue和 maxValue 。

OpenMBeanAttributeInfoSupport​(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)

构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放的MBean具有指定的属性 name ， openType ， description ， defaultValue和 legalValues ，以及指定的读/写访问属性。

OpenMBeanConstructorInfoSupport​(String name, String description, OpenMBeanParameterInfo[] signature)

构造一个 OpenMBeanConstructorInfoSupport实例，该实例描述open MBean类的构造函数与指定 name ， description和 signature 。

OpenMBeanConstructorInfoSupport​(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)

构造一个 OpenMBeanConstructorInfoSupport实例，该实例描述open MBean类与指定的构造 name ， description ， signature ，并 descriptor 。

OpenMBeanInfoSupport​(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)

构造一个 OpenMBeanInfoSupport实例，其描述了open MBean类具有指定的 className ， description ， openAttributes ， openConstructors ， openOperations和 notifications 。

OpenMBeanInfoSupport​(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)

构造一个 OpenMBeanInfoSupport实例，其描述了open MBean类具有指定的 className ， description ， openAttributes ， openConstructors ， openOperations ， notifications ，和 descriptor 。

OpenMBeanOperationInfoSupport​(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)

构造一个 OpenMBeanOperationInfoSupport实例，该实例描述了一类open MBeans的的操作中，与指定的 name ， description ， signature ， returnOpenType和 impact 。

OpenMBeanOperationInfoSupport​(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)

构造一个 OpenMBeanOperationInfoSupport实例，该实例描述了一类open MBeans的的操作中，与指定的 name ， description ， signature ， returnOpenType ， impact ，和 descriptor 。

OpenMBeanParameterInfoSupport​(String name, String description, OpenType<?> openType)

构造一个 OpenMBeanParameterInfoSupport实例，它描述了一个或多个开放MBean类的一个或多个操作或构造函数中使用的参数，其中指定的 name openType和 description 。

OpenMBeanParameterInfoSupport​(String name, String description, OpenType<?> openType, Descriptor descriptor)

构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ，和 descriptor 。

OpenMBeanParameterInfoSupport​(String name, String description, OpenType<T> openType, T defaultValue)

构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description和 defaultValue 。

OpenMBeanParameterInfoSupport​(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)

构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ， defaultValue ， minValue和 maxValue 。

OpenMBeanParameterInfoSupport​(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)

构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ， defaultValue和 legalValues 。

OpenType​(String className, String typeName, String description)

构造一个 OpenType实例（实际上是一个子类实例为 OpenType是抽象的），检查给定参数的有效性。

TabularType​(String typeName, String description, CompositeType rowType, String[] indexNames)

构造一个 TabularType实例，检查给定参数的有效性。

Constructor parameters in javax.management.openmbean with type arguments of type String

Constructor

描述

CompositeDataSupport​(CompositeType compositeType, Map<String,?> items)

构造具有指定的 compositeType的 CompositeDataSupport实例，其中项目名称和对应的值由映射 items中的映射 items 。

Uses of String in javax.management.relation

Fields in javax.management.relation declared as String

Modifier and Type

Field

描述

static String

RelationNotification.RELATION_BASIC_CREATION

键入用于创建内部关系。

static String

RelationNotification.RELATION_BASIC_REMOVAL

从关系服务中删除内部关系的类型。

static String

RelationNotification.RELATION_BASIC_UPDATE

输入内部关系的更新。

static String

RelationNotification.RELATION_MBEAN_CREATION

键入添加到关系服务中的MBean关系。

static String

RelationNotification.RELATION_MBEAN_REMOVAL

键入从关系MBean的关系服务中删除。

static String

RelationNotification.RELATION_MBEAN_UPDATE

键入更新关系MBean。

Methods in javax.management.relation that return String

Modifier and Type

方法

描述

String

RoleInfo.getDescription​()

返回角色的说明文字。

String

RoleInfo.getName​()

返回角色的名称。

String

RoleInfo.getRefMBeanClassName​()

返回预期在相应角色中引用的MBean类型的名称。

String

Relation.getRelationId​()

返回关系标识符（用于唯一标识关系服务中的关系）。

String

RelationNotification.getRelationId​()

返回创建/删除/更新的关系的关系标识符。

String

RelationSupport.getRelationId​()

返回关系标识符（用于唯一标识关系服务中的关系）。

String

Relation.getRelationTypeName​()

返回关联关系类型的名称。

String

RelationNotification.getRelationTypeName​()

返回创建/删除/更新的关系的关系类型名称。

String

RelationService.getRelationTypeName​(String relationId)

返回给定关系的关联关系类型的名称。

String

RelationServiceMBean.getRelationTypeName​(String relationId)

返回给定关系的关联关系类型的名称。

String

RelationSupport.getRelationTypeName​()

返回关联关系类型的名称。

String

RelationType.getRelationTypeName​()

返回关系类型名称。

String

RelationTypeSupport.getRelationTypeName​()

返回关系类型名称。

String

RelationNotification.getRoleName​()

返回更新关系的更新角色的名称（仅用于角色更新）。

String

Role.getRoleName​()

检索角色名称。

String

RoleUnresolved.getRoleName​()

检索角色名称。

String

RelationService.isRelation​(ObjectName objectName)

如果MBean作为关系服务中的关系添加，则返回与给定ObjectName关联的关系id。

String

RelationServiceMBean.isRelation​(ObjectName objectName)

如果MBean作为关系服务中的关系添加，则返回与给定ObjectName关联的关系id。

static String

Role.roleValueToString​(List<ObjectName> roleValue)

返回给定角色值的字符串。

String

Role.toString​()

返回描述角色的字符串。

String

RoleInfo.toString​()

返回描述角色信息的字符串。

String

RoleUnresolved.toString​()

返回描述此对象的字符串。

Methods in javax.management.relation that return types with arguments of type String

Modifier and Type

方法

描述

Map<ObjectName,List<String>>

RelationService.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)

检索与某个关系中的给定关联的MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)

检索与某个关系中的给定关联的MBean。

Map<String,List<String>>

RelationService.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)

检索给定MBean引用的关系。

Map<String,List<String>>

RelationService.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)

检索给定MBean引用的关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)

检索给定MBean引用的关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)

检索给定MBean引用的关系。

List<String>

RelationService.findRelationsOfType​(String relationTypeName)

返回给定类型的关系的关系id。

List<String>

RelationServiceMBean.findRelationsOfType​(String relationTypeName)

返回给定类型的关系的关系id。

List<String>

RelationService.getAllRelationIds​()

返回由关系服务处理的所有关系的所有关系ID。

List<String>

RelationServiceMBean.getAllRelationIds​()

返回由关系服务处理的所有关系的所有关系ID。

List<String>

RelationService.getAllRelationTypeNames​()

检索所有已知关系类型的名称。

List<String>

RelationServiceMBean.getAllRelationTypeNames​()

检索所有已知关系类型的名称。

Map<ObjectName,List<String>>

Relation.getReferencedMBeans​()

检索在关系的各种角色中引用的MBean。

Map<ObjectName,List<String>>

RelationService.getReferencedMBeans​(String relationId)

检索在关系的各种角色中引用的MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.getReferencedMBeans​(String relationId)

检索在关系的各种角色中引用的MBean。

Map<ObjectName,List<String>>

RelationSupport.getReferencedMBeans​()

检索在关系的各种角色中引用的MBean。

Methods in javax.management.relation with parameters of type String

Modifier and Type

方法

描述

Integer

RelationService.checkRoleReading​(String roleName, String relationTypeName)

检查给定角色是否可以以给定类型的关系读取。

Integer

RelationServiceMBean.checkRoleReading​(String roleName, String relationTypeName)

检查给定角色是否可以以给定类型的关系读取。

Integer

RelationService.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)

检查给定的角色是否可以按给定类型的关系进行设置。

Integer

RelationServiceMBean.checkRoleWriting​(Role role, String relationTypeName, Boolean initFlag)

检查给定的角色是否可以按给定类型的关系进行设置。

void

RelationService.createRelation​(String relationId, String relationTypeName, RoleList roleList)

创建给定关系类型的简单关系（由RelationSupport对象表示），并将其添加到关系服务中。

void

RelationServiceMBean.createRelation​(String relationId, String relationTypeName, RoleList roleList)

创建给定关系类型的简单关系（由RelationSupport对象表示），并将其添加到关系服务中。

void

RelationService.createRelationType​(String relationTypeName, RoleInfo[] roleInfoArray)

使用给定的角色信息（由RoleInfo对象提供）创建关系类型（RelationTypeSupport对象），并将其添加到关系服务中。

void

RelationServiceMBean.createRelationType​(String relationTypeName, RoleInfo[] roleInfoArray)

使用给定的角色信息（由RoleInfo对象提供）创建关系类型（RelationTypeSupport对象），并将其添加到关系服务中。

Map<ObjectName,List<String>>

RelationService.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)

检索与某个关系中的给定关联的MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.findAssociatedMBeans​(ObjectName mbeanName, String relationTypeName, String roleName)

检索与某个关系中的给定关联的MBean。

Map<String,List<String>>

RelationService.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)

检索给定MBean引用的关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations​(ObjectName mbeanName, String relationTypeName, String roleName)

检索给定MBean引用的关系。

List<String>

RelationService.findRelationsOfType​(String relationTypeName)

返回给定类型的关系的关系id。

List<String>

RelationServiceMBean.findRelationsOfType​(String relationTypeName)

返回给定类型的关系的关系id。

RoleResult

RelationService.getAllRoles​(String relationId)

返回关系中存在的所有角色。

RoleResult

RelationServiceMBean.getAllRoles​(String relationId)

返回关系中存在的所有角色。

Map<ObjectName,List<String>>

RelationService.getReferencedMBeans​(String relationId)

检索在关系的各种角色中引用的MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.getReferencedMBeans​(String relationId)

检索在关系的各种角色中引用的MBean。

String

RelationService.getRelationTypeName​(String relationId)

返回给定关系的关联关系类型的名称。

String

RelationServiceMBean.getRelationTypeName​(String relationId)

返回给定关系的关联关系类型的名称。

List<ObjectName>

Relation.getRole​(String roleName)

检索给定角色名称的角色值。

List<ObjectName>

RelationService.getRole​(String relationId, String roleName)

在给定关系中为给定的角色名称检索角色值。

List<ObjectName>

RelationServiceMBean.getRole​(String relationId, String roleName)

在给定关系中为给定的角色名称检索角色值。

List<ObjectName>

RelationSupport.getRole​(String roleName)

检索给定角色名称的角色值。

Integer

Relation.getRoleCardinality​(String roleName)

返回当前在给定角色中引用的MBean数。

Integer

RelationService.getRoleCardinality​(String relationId, String roleName)

检索当前在给定角色中引用的MBeans数。

Integer

RelationServiceMBean.getRoleCardinality​(String relationId, String roleName)

检索当前在给定角色中引用的MBeans数。

Integer

RelationSupport.getRoleCardinality​(String roleName)

返回当前在给定角色中引用的MBean数。

RoleInfo

RelationService.getRoleInfo​(String relationTypeName, String roleInfoName)

检索给定关系类型的给定角色名称的角色信息。

RoleInfo

RelationServiceMBean.getRoleInfo​(String relationTypeName, String roleInfoName)

检索给定关系类型的给定角色的角色信息。

RoleInfo

RelationType.getRoleInfo​(String roleInfoName)

返回给定角色信息名称的角色信息（RoleInfo对象）（如果未找到，则返回null）。

RoleInfo

RelationTypeSupport.getRoleInfo​(String roleInfoName)

返回给定角色信息名称的角色信息（RoleInfo对象）（如果未找到，则返回null）。

List<RoleInfo>

RelationService.getRoleInfos​(String relationTypeName)

检索给定关系类型的角色信息（RoleInfo对象）的列表。

List<RoleInfo>

RelationServiceMBean.getRoleInfos​(String relationTypeName)

检索给定关系类型的角色信息（RoleInfo对象）的列表。

RoleResult

Relation.getRoles​(String[] roleNameArray)

检索具有给定名称的角色值。

RoleResult

RelationService.getRoles​(String relationId, String[] roleNameArray)

以给定的关系取得给定名称的角色值。

RoleResult

RelationServiceMBean.getRoles​(String relationId, String[] roleNameArray)

以给定的关系取得给定名称的角色值。

RoleResult

RelationSupport.getRoles​(String[] roleNameArray)

检索具有给定名称的角色值。

void

Relation.handleMBeanUnregistration​(ObjectName objectName, String roleName)

当角色引用的MBean未注册时，关系服务使用的回调。

void

RelationSupport.handleMBeanUnregistration​(ObjectName objectName, String roleName)

当角色引用的MBean未注册时，关系服务使用的回调。

Boolean

RelationService.hasRelation​(String relationId)

检查在关系服务中是否存在与给定关系ID相关联的关系。

Boolean

RelationServiceMBean.hasRelation​(String relationId)

检查在关系服务中是否存在与给定关系ID相关联的关系。

ObjectName

RelationService.isRelationMBean​(String relationId)

如果关系由MBean（由用户创建并在关系服务中添加为关系）表示，则返回MBean的ObjectName。

ObjectName

RelationServiceMBean.isRelationMBean​(String relationId)

如果关系由MBean（由用户创建并在关系服务中添加为关系）表示，则返回MBean的ObjectName。

void

RelationService.removeRelation​(String relationId)

从关系服务中删除给定的关系。

void

RelationServiceMBean.removeRelation​(String relationId)

从关系服务中删除给定的关系。

void

RelationService.removeRelationType​(String relationTypeName)

从关系服务中删除给定的关系类型。

void

RelationServiceMBean.removeRelationType​(String relationTypeName)

从关系服务中删除给定的关系类型。

void

RelationService.sendRelationCreationNotification​(String relationId)

发送关系创建的通知（RelationNotification）。

void

RelationServiceMBean.sendRelationCreationNotification​(String relationId)

发送关系创建的通知（RelationNotification）。

void

RelationService.sendRelationRemovalNotification​(String relationId, List<ObjectName> unregMBeanList)

发送通知（RelationNotification）用于删除关系。

void

RelationServiceMBean.sendRelationRemovalNotification​(String relationId, List<ObjectName> unregMBeanList)

发送通知（RelationNotification）用于删除关系。

void

RelationService.sendRoleUpdateNotification​(String relationId, Role newRole, List<ObjectName> oldValue)

发送给定关系中角色更新的通知（RelationNotification）。

void

RelationServiceMBean.sendRoleUpdateNotification​(String relationId, Role newRole, List<ObjectName> oldRoleValue)

发送给定关系中角色更新的通知（RelationNotification）。

void

RelationService.setRole​(String relationId, Role role)

在给定的关系中设定给定的角色。

void

RelationServiceMBean.setRole​(String relationId, Role role)

在给定的关系中设定给定的角色。

void

Role.setRoleName​(String roleName)

设置角色名称。

void

RoleUnresolved.setRoleName​(String name)

设置角色名称。

RoleResult

RelationService.setRoles​(String relationId, RoleList roleList)

在给定的关系中设定给定的角色。

RoleResult

RelationServiceMBean.setRoles​(String relationId, RoleList roleList)

在给定的关系中设定给定的角色。

void

RelationService.updateRoleMap​(String relationId, Role newRole, List<ObjectName> oldValue)

处理关系服务角色图更新给定关系中给定角色的更新。

void

RelationServiceMBean.updateRoleMap​(String relationId, Role newRole, List<ObjectName> oldRoleValue)

处理关系服务角色图更新给定关系中给定角色的更新。

Constructors in javax.management.relation with parameters of type String

Constructor

描述

InvalidRelationIdException​(String message)

具有给定消息的构造方法放在异常中。

InvalidRelationServiceException​(String message)

具有给定消息的构造方法放在异常中。

InvalidRelationTypeException​(String message)

具有给定消息的构造方法放在异常中。

InvalidRoleInfoException​(String message)

具有给定消息的构造方法放在异常中。

InvalidRoleValueException​(String message)

具有给定消息的构造方法放在异常中。

RelationException​(String message)

具有给定消息的构造方法放在异常中。

RelationNotFoundException​(String message)

具有给定消息的构造方法放在异常中。

RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)

为关系中的角色更新创建通知。

RelationNotification​(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)

创建关系创建（RelationSupport对象在关系服务内部创建的，或作为关系添加的MBean）或关系删除关系服务的通知。

RelationServiceNotRegisteredException​(String message)

具有给定消息的构造方法放在异常中。

RelationSupport​(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)

创建一个 RelationSupport对象。

RelationSupport​(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)

创建一个 RelationSupport对象。

RelationTypeNotFoundException​(String message)

具有给定消息的构造方法放在异常中。

RelationTypeSupport​(String relationTypeName)

构造器用于子类。

RelationTypeSupport​(String relationTypeName, RoleInfo[] roleInfoArray)

所有角色定义都被动态创建并作为参数传递的构造方法。

Role​(String roleName, List<ObjectName> roleValue)

创建一个新的角色对象。

RoleInfo​(String roleName, String mbeanClassName)

构造函数。

RoleInfo​(String roleName, String mbeanClassName, boolean read, boolean write)

构造函数。

RoleInfo​(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)

构造函数。

RoleInfoNotFoundException​(String message)

具有给定消息的构造方法放在异常中。

RoleNotFoundException​(String message)

具有给定消息的构造方法放在异常中。

RoleUnresolved​(String name, List<ObjectName> value, int pbType)

构造函数。

Uses of String in javax.management.remote

Fields in javax.management.remote declared as String

Modifier and Type

Field

描述

static String

JMXConnectorServer.AUTHENTICATOR

指定连接器服务器的认证器的属性的名称。

static String

JMXConnectionNotification.CLOSED

连接关闭通知的通知类型字符串。

static String

JMXConnector.CREDENTIALS

指定在连接期间发送到连接器服务器的凭据的属性的名称。

static String

JMXConnectorFactory.DEFAULT_CLASS_LOADER

指定默认类加载器的属性的名称。

static String

JMXConnectorServerFactory.DEFAULT_CLASS_LOADER

指定默认类加载器的属性的名称。

static String

JMXConnectorServerFactory.DEFAULT_CLASS_LOADER_NAME

指定默认类加载器MBean名称的属性的名称。

static String

JMXConnectionNotification.FAILED

连接失败通知的通知类型字符串。

static String

JMXConnectionNotification.NOTIFS_LOST

可能丢失通知的连接的通知类型字符串。

static String

JMXConnectionNotification.OPENED

连接打开通知的通知类型字符串。

static String

JMXConnectorFactory.PROTOCOL_PROVIDER_CLASS_LOADER

指定加载协议提供程序的类加载器的属性的名称。

static String

JMXConnectorServerFactory.PROTOCOL_PROVIDER_CLASS_LOADER

指定加载协议提供程序的类加载器的属性的名称。

static String

JMXConnectorFactory.PROTOCOL_PROVIDER_PACKAGES

指定在查找协议的处理程序时查询的提供程序包的属性的名称。

static String

JMXConnectorServerFactory.PROTOCOL_PROVIDER_PACKAGES

指定在查找协议的处理程序时查询的提供程序包的属性的名称。

Methods in javax.management.remote that return String

Modifier and Type

方法

描述

String

JMXConnectionNotification.getConnectionId​()

此通知所属的连接ID。

String

JMXConnector.getConnectionId​()

从连接器服务器获取此连接的ID。

String[]

JMXConnectorServer.getConnectionIds​()

String[]

JMXConnectorServerMBean.getConnectionIds​()

此连接器服务器当前打开的连接的ID列表。

String

JMXServiceURL.getHost​()

服务网址的主机部分。

String

JMXPrincipal.getName​()

返回此主体的名称。

String

JMXServiceURL.getProtocol​()

服务网址的协议部分。

String

JMXServiceURL.getURLPath​()

服务网址的URL路径部分。

String

JMXPrincipal.toString​()

返回此 JMXPrincipal的字符串表示 JMXPrincipal 。

String

JMXServiceURL.toString​()

此服务网址的字符串表示形式。

String

NotificationResult.toString​()

返回对象的字符串表示形式。

String

TargetedNotification.toString​()

返回此定向通知的文本表示。

Methods in javax.management.remote that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,?>

JMXConnectorServerMBean.getAttributes​()

此连接器服务器的属性。

Methods in javax.management.remote with parameters of type String

Modifier and Type

方法

描述

protected void

JMXConnectorServer.connectionClosed​(String connectionId, String message, Object userData)

当客户端连接正常关闭时，由子类调用。

protected void

JMXConnectorServer.connectionFailed​(String connectionId, String message, Object userData)

当客户端连接失败时由子类调用。

protected void

JMXConnectorServer.connectionOpened​(String connectionId, String message, Object userData)

当新的客户端连接打开时由子类调用。

Method parameters in javax.management.remote with type arguments of type String

Modifier and Type

方法

描述

void

JMXConnector.connect​(Map<String,?> env)

建立与连接器服务器的连接。

static JMXConnector

JMXConnectorFactory.connect​(JMXServiceURL serviceURL, Map<String,?> environment)

创建与给定地址的连接器服务器的连接。

static JMXConnector

JMXConnectorFactory.newJMXConnector​(JMXServiceURL serviceURL, Map<String,?> environment)

在给定的地址创建连接器服务器的连接器客户端。

JMXConnector

JMXConnectorProvider.newJMXConnector​(JMXServiceURL serviceURL, Map<String,?> environment)

创建一个新的连接器客户端，可以在给定的地址连接到连接器服务器。

static JMXConnectorServer

JMXConnectorServerFactory.newJMXConnectorServer​(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)

在给定的地址创建一个连接器服务器。

JMXConnectorServer

JMXConnectorServerProvider.newJMXConnectorServer​(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)

在给定的地址创建一个新的连接器服务器。

JMXConnector

JMXConnectorServer.toJMXConnector​(Map<String,?> env)

返回此连接器服务器的客户端存根。

JMXConnector

JMXConnectorServerMBean.toJMXConnector​(Map<String,?> env)

返回此连接器服务器的客户端存根。

Constructors in javax.management.remote with parameters of type String

Constructor

描述

JMXConnectionNotification​(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)

构造一个新的连接通知。

JMXPrincipal​(String name)

为给定的身份创建一个JMXPrincipal。

JMXProviderException​(String message)

构造具有指定详细消息的 JMXProviderException 。

JMXProviderException​(String message, Throwable cause)

构造具有指定的详细消息和嵌套异常的 JMXProviderException 。

JMXServerErrorException​(String s, Error err)

构造具有指定的详细消息和嵌套错误的 JMXServerErrorException 。

JMXServiceURL​(String serviceURL)

通过解析服务URL字符串构造一个 JMXServiceURL 。

JMXServiceURL​(String protocol, String host, int port)

使用给定的协议，主机和端口构造一个 JMXServiceURL 。

JMXServiceURL​(String protocol, String host, int port, String urlPath)

构造一个 JMXServiceURL与给定的部分。

SubjectDelegationPermission​(String name)

创建一个新的具有指定名称的SubjectDelegationPermission。

SubjectDelegationPermission​(String name, String actions)

创建一个具有指定名称的新的SubjectDelegationPermission对象。

Uses of String in javax.management.remote.rmi

Fields in javax.management.remote.rmi declared as String

Modifier and Type

Field

描述

static String

RMIConnectorServer.CREDENTIAL_TYPES

指定可接受作为 RMIServer.newClient()远程方法调用的参数的类名列表的属性的名称。

static String

RMIConnectorServer.JNDI_REBIND_ATTRIBUTE

指定表示RMI连接器服务器的RMIServer存根是否应覆盖同一地址上的现有存根的属性名称。

static String

RMIConnectorServer.RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE

为与此连接器一起创建的RMI对象指定RMIClientSocketFactory的属性名称。

static String

RMIConnectorServer.RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE

为与此连接器一起创建的RMI对象指定了RMIServerSocketFactory的属性的名称。

Methods in javax.management.remote.rmi that return String

Modifier and Type

方法

描述

String

RMIConnection.getConnectionId​()

返回连接ID。

String

RMIConnectionImpl_Stub.getConnectionId​()

String

RMIConnectionImpl.getConnectionId​()

String

RMIConnector.getConnectionId​()

String

RMIConnection.getDefaultDomain​(Subject delegationSubject)

处理方法 MBeanServerConnection.getDefaultDomain() 。

String

RMIConnectionImpl_Stub.getDefaultDomain​(Subject $param_Subject_1)

String

RMIConnectionImpl.getDefaultDomain​(Subject delegationSubject)

String[]

RMIConnection.getDomains​(Subject delegationSubject)

处理方法 MBeanServerConnection.getDomains() 。

String[]

RMIConnectionImpl_Stub.getDomains​(Subject $param_Subject_1)

String[]

RMIConnectionImpl.getDomains​(Subject delegationSubject)

protected String

RMIIIOPServerImpl.getProtocol​()

已过时。

protected String

RMIJRMPServerImpl.getProtocol​()

protected abstract String

RMIServerImpl.getProtocol​()

返回此对象的协议字符串。

String

RMIServer.getVersion​()

该连接器服务器了解的RMI连接器协议版本。

String

RMIServerImpl_Stub.getVersion​()

String

RMIServerImpl.getVersion​()

String

RMIConnectionImpl.toString​()

返回此对象的字符串表示形式。

String

RMIConnector.toString​()

返回此对象的字符串表示形式。

Methods in javax.management.remote.rmi that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,?>

RMIConnectorServer.getAttributes​()

Methods in javax.management.remote.rmi with parameters of type String

Modifier and Type

方法

描述

protected void

RMIConnectorServer.connectionClosed​(String connectionId, String message, Object userData)

protected void

RMIConnectorServer.connectionFailed​(String connectionId, String message, Object userData)

protected void

RMIConnectorServer.connectionOpened​(String connectionId, String message, Object userData)

ObjectInstance

RMIConnection.createMBean​(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)

处理方法 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 。

ObjectInstance

RMIConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)

处理方法 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 。

ObjectInstance

RMIConnection.createMBean​(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)

处理方法 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 。

ObjectInstance

RMIConnection.createMBean​(String className, ObjectName name, Subject delegationSubject)

处理方法 MBeanServerConnection.createMBean(String, ObjectName) 。

ObjectInstance

RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

ObjectInstance

RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)

ObjectInstance

RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)

ObjectInstance

RMIConnectionImpl_Stub.createMBean​(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)

ObjectInstance

RMIConnectionImpl.createMBean​(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl.createMBean​(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl.createMBean​(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl.createMBean​(String className, ObjectName name, Subject delegationSubject)

Object

RMIConnection.getAttribute​(ObjectName name, String attribute, Subject delegationSubject)

处理方法 MBeanServerConnection.getAttribute(ObjectName, String) 。

Object

RMIConnectionImpl_Stub.getAttribute​(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

Object

RMIConnectionImpl.getAttribute​(ObjectName name, String attribute, Subject delegationSubject)

AttributeList

RMIConnection.getAttributes​(ObjectName name, String[] attributes, Subject delegationSubject)

处理方法 MBeanServerConnection.getAttributes(ObjectName, String[]) 。

AttributeList

RMIConnectionImpl_Stub.getAttributes​(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)

AttributeList

RMIConnectionImpl.getAttributes​(ObjectName name, String[] attributes, Subject delegationSubject)

Object

RMIConnection.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

处理方法 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 。

Object

RMIConnectionImpl_Stub.invoke​(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

Object

RMIConnectionImpl.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

boolean

RMIConnection.isInstanceOf​(ObjectName name, String className, Subject delegationSubject)

处理方法 MBeanServerConnection.isInstanceOf(ObjectName, String) 。

boolean

RMIConnectionImpl_Stub.isInstanceOf​(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

boolean

RMIConnectionImpl.isInstanceOf​(ObjectName name, String className, Subject delegationSubject)

protected RMIConnection

RMIIIOPServerImpl.makeClient​(String connectionId, Subject subject)

已过时。

protected RMIConnection

RMIJRMPServerImpl.makeClient​(String connectionId, Subject subject)

创建一个新的客户端连接作为通过JRMP导出的RMI对象。

protected abstract RMIConnection

RMIServerImpl.makeClient​(String connectionId, Subject subject)

创建一个新的客户端连接。

Method parameters in javax.management.remote.rmi with type arguments of type String

Modifier and Type

方法

描述

void

RMIConnector.connect​(Map<String,?> environment)

JMXConnector

RMIConnectorServer.toJMXConnector​(Map<String,?> env)

返回此连接器服务器的客户端存根。

Constructors in javax.management.remote.rmi with parameters of type String

Constructor

描述

RMIConnectionImpl​(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)

构造新的RMIConnection 。

Constructor parameters in javax.management.remote.rmi with type arguments of type String

Constructor

描述

RMIConnectionImpl​(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)

构造新的RMIConnection 。

RMIConnector​(JMXServiceURL url, Map<String,?> environment)

构造一个将连接RMI连接器服务器与给定地址的 RMIConnector 。

RMIConnector​(RMIServer rmiServer, Map<String,?> environment)

使用给定的RMI存根构造一个 RMIConnector 。

RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment)

做一个 RMIConnectorServer 。

RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)

为给定的MBean服务器创建一个 RMIConnectorServer 。

RMIConnectorServer​(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)

为给定的MBean服务器做一个 RMIConnectorServer 。

RMIIIOPServerImpl​(Map<String,?> env)

已过时。

抛出UnsupportedOperationException

RMIJRMPServerImpl​(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)

创建一个新的RMIServer对象，该对象将使用给定的套接字工厂在给定端口上导出。

RMIServerImpl​(Map<String,?> env)

构造新的 RMIServerImpl 。

Uses of String in javax.management.timer

Methods in javax.management.timer that return String

Modifier and Type

方法

描述

String

Timer.getNotificationMessage​(Integer id)

获取与指定标识符相对应的定时器通知详细消息。

String

TimerMBean.getNotificationMessage​(Integer id)

获取与指定标识符相对应的定时器通知详细消息。

String

Timer.getNotificationType​(Integer id)

获取与指定标识符对应的定时器通知类型。

String

TimerMBean.getNotificationType​(Integer id)

获取与指定标识符对应的定时器通知类型。

Methods in javax.management.timer with parameters of type String

Modifier and Type

方法

描述

Integer

Timer.addNotification​(String type, String message, Object userData, Date date)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。

Integer

Timer.addNotification​(String type, String message, Object userData, Date date, long period)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。

Integer

Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Integer

Timer.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件给定日期以及null时段和数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到带有给定日期和时段，以及null出现数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Integer

TimerMBean.addNotification​(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)

创建具有指定的新计时器通知 type ， message和 userData并将其插入到与事件的定日期，时段和数量的通知列表中。

Vector<Integer>

Timer.getNotificationIDs​(String type)

获取与指定类型相对应的定时器通知的所有标识符。

Vector<Integer>

TimerMBean.getNotificationIDs​(String type)

获取与指定类型相对应的定时器通知的所有标识符。

void

Timer.removeNotifications​(String type)

从通知列表中删除与指定类型对应的所有定时器通知。

void

TimerMBean.removeNotifications​(String type)

从通知列表中删除与指定类型对应的所有定时器通知。

Constructors in javax.management.timer with parameters of type String

Constructor

描述

TimerNotification​(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)

创建定时器通知对象。

Uses of String in javax.naming

Fields in javax.naming declared as String

Modifier and Type

Field

描述

protected String

RefAddr.addrType

包含此地址的类型。

static String

Context.APPLET

已过时。
在构建初始上下文时，将忽略具有此名称的环境属性。 此常量最初用作属性名称，以在创建初始上下文时指定Applet以从中检索参数。 目前需要传递给初始上下文的任何applet属性都应该复制到环境哈希表中：
   Hashtable env = new Hashtable(); env.put(Context.INITIAL_CONTEXT_FACTORY, ((Applet) this).getParameter(Context.INITIAL_CONTEXT_FACTORY)); env.put(Context.PROVIDER_URL, ((Applet) this).getParameter(Context.PROVIDER_URL)); // ... other properties ... Context ctx = new InitialContext(env);
static String

Context.AUTHORITATIVE

用于指定所请求的服务的权威性的环境属性的名称的常量。

static String

Context.BATCHSIZE

包含用于指定通过服务协议返回数据时使用的批量大小的环境属性名称的常量。

protected String

Reference.classFactory

包含用于创建此引用引用的对象的实例的工厂类的名称。

protected String

Reference.classFactoryLocation

包含工厂类的位置。

protected String

Reference.className

包含此引用引用的对象的类的完全限定名称。

static String

Context.DNS_URL

持有用于指定用于JNDI URL上下文的DNS主机和域名的环境属性的名称的常量（例如“dns：//somehost/wiz.com”）。

static String

Context.INITIAL_CONTEXT_FACTORY

用于指定要使用的初始上下文工厂的环境属性的名称的常量。

static String

Context.LANGUAGE

包含用于指定与服务一起使用的首选语言的环境属性名称的常量。

protected String

LinkException.linkExplanation

包含为什么解决链接失败的例外。

static String

Context.OBJECT_FACTORIES

用于指定要使用的对象工厂列表的环境属性的名称的常量。

static String

Context.PROVIDER_URL

包含用于指定服务提供商要使用的配置信息的环境属性的名称的常量。

static String

Context.REFERRAL

持有用于指定如何处理服务提供商遇到的引用的环境属性的名称的常量。

static String

Context.SECURITY_AUTHENTICATION

持有用于指定要使用的安全级别的环境属性的名称的常量。

static String

Context.SECURITY_CREDENTIALS

包含用于指定用于验证呼叫者到服务的主体的凭据的环境属性的名称的常量。

static String

Context.SECURITY_PRINCIPAL

持有用于指定主体的身份的环境属性的常量，用于验证对该服务的呼叫者。

static String

Context.SECURITY_PROTOCOL

用于指定要使用的安全协议的环境属性的名称的常量。

static String

Context.STATE_FACTORIES

用于指定要使用的状态工厂列表的环境属性的名称的常量。

static String

Context.URL_PKG_PREFIXES

持有环境属性名称的常量，用于指定在URL上下文工厂中加载时使用的包前缀列表。

Methods in javax.naming that return String

Modifier and Type

方法

描述

String

Context.composeName​(String name, String prefix)

使用相对于该上下文的名称组合此上下文的名称。

String

InitialContext.composeName​(String name, String prefix)

使用相对于该上下文的名称组合此上下文的名称。

String

CompositeName.get​(int posn)

检索此复合名称的组件。

String

CompoundName.get​(int posn)

检索此化合物名称的组件。

String

Name.get​(int posn)

检索此名称的组件。

String

Binding.getClassName​()

检索绑定到此绑定名称的对象的类名。

String

NameClassPair.getClassName​()

检索绑定到此绑定名称的对象的类名。

String

Reference.getClassName​()

检索引用引用的对象的类名。

String

NamingException.getExplanation​()

检索与此异常相关的说明。

String

Reference.getFactoryClassLocation​()

检索此引用引用的对象的工厂位置。

String

Reference.getFactoryClassName​()

检索此引用引用的对象的工厂类的名称。

String

LinkException.getLinkExplanation​()

检索与解决链接时遇到的问题相关的说明。

String

LinkRef.getLinkName​()

检索此链接的名称。

String

NameClassPair.getName​()

检索此绑定的名称。

String

Context.getNameInNamespace​()

在其自己的命名空间中检索此上下文的全名。

String

InitialContext.getNameInNamespace​()

String

NameClassPair.getNameInNamespace​()

检索此绑定的全名。

String

RefAddr.getType​()

检索此地址的地址类型。

String

BinaryRefAddr.toString​()

生成此地址的字符串表示形式。

String

Binding.toString​()

生成此绑定的字符串表示形式。

String

CompositeName.toString​()

生成此复合名称的字符串表示形式。

String

CompoundName.toString​()

使用复合名称的语法规则生成此化合物名称的字符串表示形式。

String

LinkException.toString​()

生成此异常的字符串表示形式。

String

LinkException.toString​(boolean detail)

生成此异常的字符串表示形式。

String

NameClassPair.toString​()

生成此名称/类对的字符串表示形式。

String

NamingException.toString​()

生成此异常的字符串表示形式。

String

NamingException.toString​(boolean detail)

更详细地生成字符串表示。

String

RefAddr.toString​()

生成此地址的字符串表示形式。

String

Reference.toString​()

生成此引用的字符串表示形式。

Methods in javax.naming that return types with arguments of type String

Modifier and Type

方法

描述

Enumeration<String>

CompositeName.getAll​()

检索此复合名称的组件作为字符串的枚举。

Enumeration<String>

CompoundName.getAll​()

检索此复合名称的组件作为字符串的枚举。

Enumeration<String>

Name.getAll​()

检索此名称的组件作为字符串的枚举。

Methods in javax.naming with parameters of type String

Modifier and Type

方法

描述

Name

CompositeName.add​(int posn, String comp)

在此复合名称中的指定位置添加单个组件。

Name

CompositeName.add​(String comp)

将单个组件添加到此组合名称的末尾。

Name

CompoundName.add​(int posn, String comp)

在此化合物名称中的指定位置添加单个组件。

Name

CompoundName.add​(String comp)

将单个组件添加到此化合物名称的末尾。

Name

Name.add​(int posn, String comp)

在此名称中的指定位置添加单个组件。

Name

Name.add​(String comp)

将单个组件添加到此名称的末尾。

Object

Context.addToEnvironment​(String propName, Object propVal)

在此上下文的环境中添加一个新的环境属性。

Object

InitialContext.addToEnvironment​(String propName, Object propVal)

void

NamingException.appendRemainingComponent​(String name)

将名称添加为剩余名称中的最后一个组件。

void

Context.bind​(String name, Object obj)

将名称绑定到对象。

void

InitialContext.bind​(String name, Object obj)

String

Context.composeName​(String name, String prefix)

使用相对于该上下文的名称组合此上下文的名称。

String

InitialContext.composeName​(String name, String prefix)

使用相对于该上下文的名称组合此上下文的名称。

Context

Context.createSubcontext​(String name)

创建并绑定新的上下文。

Context

InitialContext.createSubcontext​(String name)

void

Context.destroySubcontext​(String name)

销毁命名上下文并将其从命名空间中删除。

void

InitialContext.destroySubcontext​(String name)

static <T> T

InitialContext.doLookup​(String name)

一种用于检索命名对象的静态方法。

RefAddr

Reference.get​(String addrType)

检索地址类型为“addrType”的第一个地址。

NameParser

Context.getNameParser​(String name)

检索与命名上下文关联的解析器。

NameParser

InitialContext.getNameParser​(String name)

protected Context

InitialContext.getURLOrDefaultInitCtx​(String name)

检索用于解析字符串名称 name的上下文。

NamingEnumeration<NameClassPair>

Context.list​(String name)

枚举在命名上下文中绑定的名称以及绑定到它们的对象的类名。

NamingEnumeration<NameClassPair>

InitialContext.list​(String name)

NamingEnumeration<Binding>

Context.listBindings​(String name)

枚举在命名上下文中绑定的名称以及绑定到它们的对象。

NamingEnumeration<Binding>

InitialContext.listBindings​(String name)

Object

Context.lookup​(String name)

检索命名对象。

Object

InitialContext.lookup​(String name)

Object

Context.lookupLink​(String name)

检索命名对象，除了名称的终端原子组件以外的链接。

Object

InitialContext.lookupLink​(String name)

Name

NameParser.parse​(String name)

在其组件中解析名称。

void

Context.rebind​(String name, Object obj)

将名称绑定到对象，覆盖任何现有绑定。

void

InitialContext.rebind​(String name, Object obj)

Object

Context.removeFromEnvironment​(String propName)

从环境环境中删除环境属性。

Object

InitialContext.removeFromEnvironment​(String propName)

void

Context.rename​(String oldName, String newName)

将绑定到旧名称的对象绑定一个新名称，并取消绑定旧名称。

void

InitialContext.rename​(String oldName, String newName)

void

NameClassPair.setClassName​(String name)

设置此绑定的类名。

void

LinkException.setLinkExplanation​(String msg)

设置解决链接时遇到的问题的解释。

void

NameClassPair.setName​(String name)

设置此绑定的名称。

void

NameClassPair.setNameInNamespace​(String fullName)

设置此绑定的全名。

void

Context.unbind​(String name)

取消绑定命名对象。

void

InitialContext.unbind​(String name)

Constructors in javax.naming with parameters of type String

Constructor

描述

AuthenticationException​(String explanation)

使用提供的说明构造一个新的AuthenticationException实例。

AuthenticationNotSupportedException​(String explanation)

使用说明构造一个新的AuthenticationNotSupportedException实例。

BinaryRefAddr​(String addrType, byte[] src)

使用其地址类型和内容的字节数组构造一个新的BinaryRefAddr实例。

BinaryRefAddr​(String addrType, byte[] src, int offset, int count)

使用其地址类型构建一个新的BinaryRefAddr实例，并为内容构造一个字节数组的区域。

Binding​(String name, Object obj)

构造一个绑定的实例给它的名称和对象。

Binding​(String name, Object obj, boolean isRelative)

构造绑定的实例给它的名称，对象以及名称是否相对。

Binding​(String name, String className, Object obj)

构造一个绑定的实例给它的名称，类名和对象。

Binding​(String name, String className, Object obj, boolean isRelative)

构造绑定的实例给它的名称，类名，对象以及名称是否相对。

CannotProceedException​(String explanation)

使用说明构造一个新的CannotProceedException实例。

CommunicationException​(String explanation)

使用提供的参数构造一个新的CommunicationException实例。

CompositeName​(String n)

通过使用复合名称语法（从左到右，斜杠分隔）解析字符串n来构造新的复合名称实例。

CompoundName​(String n, Properties syntax)

通过使用提供的语法属性指定的语法解析字符串n来构造新的化合物名称实例。

ConfigurationException​(String explanation)

使用解释构造一个新的ConfigurationException实例。

ContextNotEmptyException​(String explanation)

使用解释构造一个新的ContextNotEmptyException实例。

InsufficientResourcesException​(String explanation)

使用说明构造一个新的InsufficientResourcesException实例。

InterruptedNamingException​(String explanation)

使用问题的解释构造InterruptedNamingException的实例。

InvalidNameException​(String explanation)

使用问题的解释构造InvalidNameException的实例。

LimitExceededException​(String explanation)

使用说明构造一个新的LimitExceededException实例。

LinkException​(String explanation)

构造一个新的LinkException实例，并给出解释。

LinkLoopException​(String explanation)

构造一个新的LinkLoopException实例和解释。

LinkRef​(String linkName)

构造一个字符串名称的LinkRef。

MalformedLinkException​(String explanation)

构造一个新的MalformedLinkException实例，并给出解释。

NameAlreadyBoundException​(String explanation)

使用提供的说明构造一个新的NameAlreadyBoundException实例。

NameClassPair​(String name, String className)

构造一个NameClassPair的实例，其名称和类名称。

NameClassPair​(String name, String className, boolean isRelative)

构造一个NameClassPair的实例，其名称，类名称以及它是否与列表上下文相关。

NameNotFoundException​(String explanation)

使用提供的说明构造一个新的NameNotFoundException实例。

NamingException​(String explanation)

构造一个新的NamingException和解释。

NamingSecurityException​(String explanation)

使用提供的说明构造一个新的NamingSecurityException实例。

NoInitialContextException​(String explanation)

构造一个NoInitialContextException的实例，并带有解释。

NoPermissionException​(String explanation)

使用解释构造一个新的NoPermissionException实例。

NotContextException​(String explanation)

使用解释构造一个新的NotContextException实例。

OperationNotSupportedException​(String explanation)

使用说明构造一个新的OperationNotSupportedException实例。

PartialResultException​(String explanation)

使用指定的说明消息构造异常的新实例。

RefAddr​(String addrType)

使用其地址类型构造一个新的RefAddr实例。

Reference​(String className)

为类名为“className”的对象构造一个新的引用。

Reference​(String className, String factory, String factoryLocation)

为类名为“className”的对象以及对象工厂的类名和位置构造一个新引用。

Reference​(String className, RefAddr addr)

为类名为“className”的对象和地址构造一个新引用。

Reference​(String className, RefAddr addr, String factory, String factoryLocation)

为类名为“className”的对象，对象工厂的类名和位置以及对象的地址构造一个新引用。

ReferralException​(String explanation)

使用提供的说明构造一个新的ReferralException实例。

ServiceUnavailableException​(String explanation)

使用解释构造一个新的ServiceUnavailableException实例。

SizeLimitExceededException​(String explanation)

使用说明构造一个新的SizeLimitExceededException实例。

StringRefAddr​(String addrType, String addr)

使用其地址类型和内容构造一个新的StringRefAddr实例。

TimeLimitExceededException​(String explanation)

使用提供的参数构造一个新的TimeLimitExceededException实例。

Constructor parameters in javax.naming with type arguments of type String

Constructor

描述

CompositeName​(Enumeration<String> comps)

使用“comps”指定的组件构造新的组合名称实例。

CompoundName​(Enumeration<String> comps, Properties syntax)

使用comps和syntax中指定的组件构造一个新的复合名称实例。

Uses of String in javax.naming.directory

Fields in javax.naming.directory declared as String

Modifier and Type

Field

描述

protected String

BasicAttribute.attrID

保留属性的ID。

Methods in javax.naming.directory that return String

Modifier and Type

方法

描述

String

Attribute.getID​()

检索此属性的ID。

String

BasicAttribute.getID​()

String[]

SearchControls.getReturningAttributes​()

检索将作为搜索的一部分返回的属性。

String

AttributeModificationException.toString​()

此异常的字符串表示形式包含有关错误发生位置的信息和第一个未执行的修改。

String

BasicAttribute.toString​()

生成此属性的字符串表示形式。

String

BasicAttributes.toString​()

生成此属性集的字符串表示形式。

String

ModificationItem.toString​()

生成此修改项的字符串表示形式，由修改操作及其相关属性组成。

String

SearchResult.toString​()

生成此SearchResult的字符串表示形式。

Methods in javax.naming.directory that return types with arguments of type String

Modifier and Type

方法

描述

NamingEnumeration<String>

Attributes.getIDs​()

检索属性集中属性ID的枚举。

NamingEnumeration<String>

BasicAttributes.getIDs​()

Methods in javax.naming.directory with parameters of type String

Modifier and Type

方法

描述

void

DirContext.bind​(String name, Object obj, Attributes attrs)

将名称绑定到对象，以及关联的属性。

void

InitialDirContext.bind​(String name, Object obj, Attributes attrs)

DirContext

DirContext.createSubcontext​(String name, Attributes attrs)

创建和绑定新的上下文以及关联的属性。

DirContext

InitialDirContext.createSubcontext​(String name, Attributes attrs)

Attribute

Attributes.get​(String attrID)

使用属性集中的给定属性id检索属性。

Attribute

BasicAttributes.get​(String attrID)

Attributes

DirContext.getAttributes​(String name)

检索与命名对象关联的所有属性。

Attributes

DirContext.getAttributes​(String name, String[] attrIds)

检索与命名对象关联的所选属性。

Attributes

DirContext.getAttributes​(Name name, String[] attrIds)

检索与命名对象关联的所选属性。

Attributes

InitialDirContext.getAttributes​(String name)

Attributes

InitialDirContext.getAttributes​(String name, String[] attrIds)

Attributes

InitialDirContext.getAttributes​(Name name, String[] attrIds)

DirContext

DirContext.getSchema​(String name)

检索与命名对象关联的模式。

DirContext

InitialDirContext.getSchema​(String name)

DirContext

DirContext.getSchemaClassDefinition​(String name)

检索包含命名对象的类定义的模式对象的上下文。

DirContext

InitialDirContext.getSchemaClassDefinition​(String name)

void

DirContext.modifyAttributes​(String name, int mod_op, Attributes attrs)

修改与命名对象关联的属性。

void

DirContext.modifyAttributes​(String name, ModificationItem[] mods)

使用有序的修改列表修改与命名对象关联的属性。

void

InitialDirContext.modifyAttributes​(String name, int mod_op, Attributes attrs)

void

InitialDirContext.modifyAttributes​(String name, ModificationItem[] mods)

Attribute

Attributes.put​(String attrID, Object val)

向属性集添加一个新属性。

Attribute

BasicAttributes.put​(String attrID, Object val)

void

DirContext.rebind​(String name, Object obj, Attributes attrs)

将名称绑定到对象以及关联的属性，覆盖任何现有绑定。

void

InitialDirContext.rebind​(String name, Object obj, Attributes attrs)

Attribute

Attributes.remove​(String attrID)

从属性集中删除属性id“attrID”的属性。

Attribute

BasicAttributes.remove​(String attrID)

NamingEnumeration<SearchResult>

DirContext.search​(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

NamingEnumeration<SearchResult>

DirContext.search​(String name, String filter, SearchControls cons)

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

NamingEnumeration<SearchResult>

DirContext.search​(String name, Attributes matchingAttributes)

在单个上下文中搜索包含指定属性集的对象。

NamingEnumeration<SearchResult>

DirContext.search​(String name, Attributes matchingAttributes, String[] attributesToReturn)

在单个上下文中搜索包含指定属性集的对象，并检索所选属性。

NamingEnumeration<SearchResult>

DirContext.search​(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

NamingEnumeration<SearchResult>

DirContext.search​(Name name, String filter, SearchControls cons)

在命名的上下文或对象中搜索满足给定搜索过滤器的条目。

NamingEnumeration<SearchResult>

DirContext.search​(Name name, Attributes matchingAttributes, String[] attributesToReturn)

在单个上下文中搜索包含指定属性集的对象，并检索所选属性。

NamingEnumeration<SearchResult>

InitialDirContext.search​(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

InitialDirContext.search​(String name, String filter, SearchControls cons)

NamingEnumeration<SearchResult>

InitialDirContext.search​(String name, Attributes matchingAttributes)

NamingEnumeration<SearchResult>

InitialDirContext.search​(String name, Attributes matchingAttributes, String[] attributesToReturn)

NamingEnumeration<SearchResult>

InitialDirContext.search​(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

InitialDirContext.search​(Name name, String filter, SearchControls cons)

NamingEnumeration<SearchResult>

InitialDirContext.search​(Name name, Attributes matchingAttributes, String[] attributesToReturn)

void

SearchControls.setReturningAttributes​(String[] attrs)

指定将作为搜索的一部分返回的属性。

Constructors in javax.naming.directory with parameters of type String

Constructor

描述

AttributeInUseException​(String explanation)

构造一个新的AttributeInUseException实例，并带有解释。

AttributeModificationException​(String explanation)

使用说明构造一个新的AttributeModificationException实例。

BasicAttribute​(String id)

构造无值的无序属性的新实例。

BasicAttribute​(String id, boolean ordered)

构造一个没有值的可能有序属性的新实例。

BasicAttribute​(String id, Object value)

使用单个值构造无序属性的新实例。

BasicAttribute​(String id, Object value, boolean ordered)

构造具有单个值的可能有序属性的新实例。

BasicAttributes​(String attrID, Object val)

使用一个属性构造一个新的属性实例。

BasicAttributes​(String attrID, Object val, boolean ignoreCase)

使用一个属性构造一个新的属性实例。

InvalidAttributeIdentifierException​(String explanation)

使用提供的说明构造一个InvalidAttributeIdentifierException的新实例。

InvalidAttributesException​(String explanation)

使用说明构造一个InvalidAttributesException的新实例。

InvalidAttributeValueException​(String explanation)

使用说明构造一个InvalidAttributeValueException的新实例。

InvalidSearchControlsException​(String msg)

构造一个新的InvalidSearchControlsException实例，并带有解释。

InvalidSearchFilterException​(String msg)

构造一个InvalidSearchFilterException的新实例，并带有解释。

NoSuchAttributeException​(String explanation)

使用解释构造一个新的NoSuchAttributeException实例。

SchemaViolationException​(String explanation)

使用提供的说明构造一个新的SchemaViolationException实例。

SearchControls​(int scope, long countlim, int timelim, String[] attrs, boolean retobj, boolean deref)

使用参数构造搜索约束。

SearchResult​(String name, Object obj, Attributes attrs)

使用结果的名称，其绑定对象及其属性构造搜索结果。

SearchResult​(String name, Object obj, Attributes attrs, boolean isRelative)

使用结果的名称，其绑定对象及其属性构建搜索结果，以及该名称是否相对。

SearchResult​(String name, String className, Object obj, Attributes attrs)

使用结果的名称，其类名称，其绑定对象及其属性构造搜索结果。

SearchResult​(String name, String className, Object obj, Attributes attrs, boolean isRelative)

使用结果的名称，其类名称，其绑定对象，其属性以及名称是否相对构造搜索结果。

Uses of String in javax.naming.event

Methods in javax.naming.event with parameters of type String

Modifier and Type

方法

描述

void

EventContext.addNamingListener​(String target, int scope, NamingListener l)

添加一个侦听器，用于接收由字符串目标名称和范围指定的对象更改时触发的命名事件。

void

EventDirContext.addNamingListener​(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)

添加一个侦听器，用于接收由搜索过滤器 filter标识的对象和由字符串目标名称命名的对象的过滤器参数时触发的命名事件。

void

EventDirContext.addNamingListener​(String target, String filter, SearchControls ctls, NamingListener l)

添加一个侦听器，用于接收由字符串目标名称命名的对象由搜索过滤器 filter标识的对象时触发的命名事件。

void

EventDirContext.addNamingListener​(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)

添加一个侦听器，用于接收由搜索过滤器标识的对象 filter并且由目标命名的对象的过滤器参数被修改时触发的命名事件。

void

EventDirContext.addNamingListener​(Name target, String filter, SearchControls ctls, NamingListener l)

添加一个侦听器，用于接收由目标命名的对象由搜索过滤器 filter标识的对象时触发的命名事件。

Uses of String in javax.naming.ldap

Fields in javax.naming.ldap declared as String

Modifier and Type

Field

描述

static String

LdapContext.CONTROL_FACTORIES

用于指定要使用的控制工厂列表的环境属性的名称的常量。

protected String

BasicControl.id

控件的对象标识符字符串。

static String

ManageReferralControl.OID

管理控制台的分配对象标识符为2.16.840.1.113730.3.4.2。

static String

PagedResultsControl.OID

分页结果控件的分配对象标识符为1.2.840.113556.1.4.319。

static String

PagedResultsResponseControl.OID

分页结果响应控件的分配对象标识符为1.2.840.113556.1.4.319。

static String

SortControl.OID

服务器端排序控件的分配对象标识符为1.2.840.113556.1.4.473。

static String

SortResponseControl.OID

服务器端排序响应控件的分配对象标识符为1.2.840.113556.1.4.474。

static String

StartTlsRequest.OID

StartTLS扩展请求的分配对象标识符为1.3.6.1.4.1.1466.20037。

static String

StartTlsResponse.OID

StartTLS扩展响应的分配对象标识符为1.3.6.1.4.1.1466.20037。

Methods in javax.naming.ldap that return String

Modifier and Type

方法

描述

static String

Rdn.escapeValue​(Object val)

给定一个属性的值，根据 RFC 2253中规定的规则返回一个转义的字符串。

String

LdapName.get​(int posn)

以此字符串形式检索此LDAP名称的组件。

String

SortKey.getAttributeID​()

检索排序键的属性ID。

String

SortResponseControl.getAttributeID​()

检索导致排序失败的属性的ID。

String

BasicControl.getID​()

检索控件的对象标识符字符串。

String

Control.getID​()

检索分配给LDAP控件的对象标识符。

String

ExtendedRequest.getID​()

检索请求的对象标识符。

String

ExtendedResponse.getID​()

检索响应的对象标识符。

String

StartTlsRequest.getID​()

检索StartTLS请求的对象标识符字符串。

String

StartTlsResponse.getID​()

检索StartTLS响应的对象标识符字符串。

String

SortKey.getMatchingRuleID​()

检索用于对属性值进行排序的匹配规则ID。

String[]

UnsolicitedNotification.getReferrals​()

检索由服务器发送的推荐。

String

Rdn.getType​()

检索此Rdn类型之一。

String

LdapName.toString​()

以 RFC 2253定义的格式返回此LDAP名称的字符串表示形式，并在类描述中描述。

String

Rdn.toString​()

返回此Rdn如在由定义的格式表示的字符串RFC 2253和在类描述用于描述LdapName 。

Methods in javax.naming.ldap that return types with arguments of type String

Modifier and Type

方法

描述

Enumeration<String>

LdapName.getAll​()

检索此名称的组件作为字符串的枚举。

Methods in javax.naming.ldap with parameters of type String

Modifier and Type

方法

描述

Name

LdapName.add​(int posn, String comp)

在此LDAP名称中的指定位置添加单个组件。

Name

LdapName.add​(String comp)

将单个组件添加到此LDAP名称的末尾。

ExtendedResponse

ExtendedRequest.createExtendedResponse​(String id, byte[] berValue, int offset, int length)

创建与此请求对应的响应对象。

ExtendedResponse

StartTlsRequest.createExtendedResponse​(String id, byte[] berValue, int offset, int length)

创建对应于LDAP StartTLS扩展请求的扩展响应对象。

abstract void

StartTlsResponse.setEnabledCipherSuites​(String[] suites)

覆盖在TLS连接上启用的密码套件的默认列表。

static Object

Rdn.unescapeValue​(String val)

给定根据 RFC 2253中规定的规则格式化的属性值字符串，返回未格式化的值。

Constructors in javax.naming.ldap with parameters of type String

Constructor

描述

BasicControl​(String id)

构建非关键控件。

BasicControl​(String id, boolean criticality, byte[] value)

使用提供的参数构造一个控件。

LdapName​(String name)

从给定的可分辨名称构造一个LDAP名称。

LdapReferralException​(String explanation)

使用提供的说明构造一个新的LdapReferralException实例。

PagedResultsResponseControl​(String id, boolean criticality, byte[] value)

构建分页结果响应控件。

Rdn​(String rdnString)

从给定的字符串构造一个Rdn。

Rdn​(String type, Object value)

从给定的属性类型和值构造一个Rdn。

SortControl​(String[] sortBy, boolean criticality)

构造一个控件以按升序对属性列表进行排序。

SortControl​(String sortBy, boolean criticality)

构造一个控件以按升序对单个属性进行排序。

SortKey​(String attrID)

创建属性的默认排序键。

SortKey​(String attrID, boolean ascendingOrder, String matchingRuleID)

为属性创建排序键。

SortResponseControl​(String id, boolean criticality, byte[] value)

构造一个控件来指示排序请求的结果。

Uses of String in javax.naming.spi

Fields in javax.naming.spi declared as String

Modifier and Type

Field

描述

static String

NamingManager.CPE

持有 getContinuationContext()存储其 CannotProceedException参数值的环境属性名称的常量。

Methods in javax.naming.spi with parameters of type String

Modifier and Type

方法

描述

void

ResolveResult.appendRemainingComponent​(String name)

将单个组件添加到剩余名称的末尾。

static Context

NamingManager.getURLContext​(String scheme, Hashtable<?,?> environment)

为给定的URL方案ID创建上下文。

ResolveResult

Resolver.resolveToClass​(String name, Class<? extends Context> contextType)

部分解决名称。

Constructors in javax.naming.spi with parameters of type String

Constructor

描述

ResolveResult​(Object robj, String rcomp)

构造由解析的对象和剩余的未解析组件组成的ResolveResult的新实例。

Uses of String in javax.net

Methods in javax.net with parameters of type String

Modifier and Type

方法

描述

abstract Socket

SocketFactory.createSocket​(String host, int port)

创建套接字并将其连接到指定的远程端口上的指定远程主机。

abstract Socket

SocketFactory.createSocket​(String host, int port, InetAddress localHost, int localPort)

创建套接字并将其连接到指定远程端口上的指定远程主机。

Uses of String in javax.net.ssl

Methods in javax.net.ssl that return String

Modifier and Type

方法

描述

String

X509KeyManager.chooseClientAlias​(String[] keyType, Principal[] issuers, Socket socket)

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，来认证安全套接字的客户端。

String

X509ExtendedKeyManager.chooseEngineClientAlias​(String[] keyType, Principal[] issuers, SSLEngine engine)

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表，鉴定客户端 SSLEngine连接。

String

X509ExtendedKeyManager.chooseEngineServerAlias​(String keyType, Principal[] issuers, SSLEngine engine)

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表，鉴定 SSLEngine连接的服务器端。

String

X509KeyManager.chooseServerAlias​(String keyType, Principal[] issuers, Socket socket)

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，对安全套接字的服务器端进行身份验证。

String

KeyManagerFactory.getAlgorithm​()

返回此 KeyManagerFactory对象的算法名称。

String

TrustManagerFactory.getAlgorithm​()

返回此 TrustManagerFactory对象的算法名称。

String

SSLEngine.getApplicationProtocol​()

返回为此连接协商的最新应用程序协议值。

String

SSLSocket.getApplicationProtocol​()

返回为此连接协商的最新应用程序协议值。

String[]

SSLParameters.getApplicationProtocols​()

返回可通过SSL / TLS / DTLS协议协商的应用层协议名称的优先级数组。

String

SNIHostName.getAsciiName​()

返回此 SNIHostName对象的 StandardCharsets.US_ASCII兼容主机名。

String

HandshakeCompletedEvent.getCipherSuite​()

返回由握手产生的会话使用的密码套件。

abstract String

HttpsURLConnection.getCipherSuite​()

返回此连接上正在使用的密码套件。

String

SSLSession.getCipherSuite​()

返回用于会话中所有连接的SSL加密套件的名称。

String[]

SSLParameters.getCipherSuites​()

返回密码数组的副本，如果没有设置则返回null。

String[]

X509KeyManager.getClientAliases​(String keyType, Principal[] issuers)

获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的客户端。

static String

KeyManagerFactory.getDefaultAlgorithm​()

获取默认的KeyManagerFactory算法名称。

static String

TrustManagerFactory.getDefaultAlgorithm​()

获取默认的TrustManagerFactory算法名称。

abstract String[]

SSLServerSocketFactory.getDefaultCipherSuites​()

返回默认启用的密码套件列表。

abstract String[]

SSLSocketFactory.getDefaultCipherSuites​()

返回默认启用的密码套件列表。

abstract String[]

SSLEngine.getEnabledCipherSuites​()

返回当前启用此引擎使用的SSL密码套件的名称。

abstract String[]

SSLServerSocket.getEnabledCipherSuites​()

返回当前允许新接受连接使用的密码套件列表。

abstract String[]

SSLSocket.getEnabledCipherSuites​()

返回当前启用此SSL连接的SSL密码套件的名称。

abstract String[]

SSLEngine.getEnabledProtocols​()

返回当前允许与此 SSLEngine一起使用的协议版本的名称。

abstract String[]

SSLServerSocket.getEnabledProtocols​()

返回当前启用以便新接受的连接使用的协议的名称。

abstract String[]

SSLSocket.getEnabledProtocols​()

返回当前允许在此连接上使用的协议版本的名称。

String

SSLParameters.getEndpointIdentificationAlgorithm​()

获取端点识别算法。

String

SSLEngine.getHandshakeApplicationProtocol​()

返回当前正在进行的SSL / TLS握手协商的应用协议值。

String

SSLSocket.getHandshakeApplicationProtocol​()

返回当前正在进行的SSL / TLS握手协商的应用协议值。

abstract String[]

ExtendedSSLSession.getLocalSupportedSignatureAlgorithms​()

获取本地方面愿意使用的支持的签名算法数组。

String

SSLSessionBindingEvent.getName​()

返回对象被绑定到的名称，或者对象被绑定的名称。

String

SSLEngine.getPeerHost​()

返回对等体的主机名。

String

SSLSession.getPeerHost​()

返回此会话中对等体的主机名。

abstract String[]

ExtendedSSLSession.getPeerSupportedSignatureAlgorithms​()

获得对等体能够使用的支持的签名算法数组。

String

SSLContext.getProtocol​()

返回此 SSLContext对象的协议名称。

String

SSLSession.getProtocol​()

返回用于会话中所有连接的协议的标准名称。

String[]

SSLParameters.getProtocols​()

返回协议数组的副本，如果没有设置，则返回null。

String[]

X509KeyManager.getServerAliases​(String keyType, Principal[] issuers)

获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的服务器端。

abstract String[]

SSLEngine.getSupportedCipherSuites​()

返回可以在此引擎上使用的密码套件的名称。

abstract String[]

SSLServerSocket.getSupportedCipherSuites​()

返回可以在SSL连接上使用的密码套件的名称。

abstract String[]

SSLServerSocketFactory.getSupportedCipherSuites​()

返回可以在此工厂创建的SSL连接上启用的密码套件的名称。

abstract String[]

SSLSocket.getSupportedCipherSuites​()

返回可以在此连接上使用的密码套件的名称。

abstract String[]

SSLSocketFactory.getSupportedCipherSuites​()

返回可以在SSL连接上使用的密码套件的名称。

abstract String[]

SSLEngine.getSupportedProtocols​()

返回可用于此 SSLEngine的协议的名称。

abstract String[]

SSLServerSocket.getSupportedProtocols​()

返回可以启用的协议的名称。

abstract String[]

SSLSocket.getSupportedProtocols​()

返回可以在SSL连接上使用的协议的名称。

String[]

SSLSession.getValueNames​()

返回绑定到会话中的所有应用层数据对象的名称数组。

String

SNIHostName.toString​()

返回对象的字符串表示形式，包括此 SNIHostName对象中的DNS主机名。

String

SNIServerName.toString​()

返回此服务器名称的字符串表示形式，包括此 SNIServerName对象中的服务器名称类型和编码服务器名称值。

String

SSLEngineResult.toString​()

返回此对象的String表示形式。

Methods in javax.net.ssl that return types with arguments of type String

Modifier and Type

方法

描述

BiFunction<SSLEngine,List<String>,String>

SSLEngine.getHandshakeApplicationProtocolSelector​()

检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。

BiFunction<SSLEngine,List<String>,String>

SSLEngine.getHandshakeApplicationProtocolSelector​()

检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。

BiFunction<SSLSocket,List<String>,String>

SSLSocket.getHandshakeApplicationProtocolSelector​()

检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。

BiFunction<SSLSocket,List<String>,String>

SSLSocket.getHandshakeApplicationProtocolSelector​()

检索在SSL / TLS / DTLS握手期间选择应用协议值的回调函数。

Methods in javax.net.ssl with parameters of type String

Modifier and Type

方法

描述

abstract void

X509ExtendedTrustManager.checkClientTrusted​(X509Certificate[] chain, String authType, Socket socket)

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

abstract void

X509ExtendedTrustManager.checkClientTrusted​(X509Certificate[] chain, String authType, SSLEngine engine)

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

void

X509TrustManager.checkClientTrusted​(X509Certificate[] chain, String authType)

给定由对等体提供的部分或完整的证书链，构建证书路径到受信任的根，并返回，如果它可以被验证，并且基于认证类型对客户端SSL认证信任。

abstract void

X509ExtendedTrustManager.checkServerTrusted​(X509Certificate[] chain, String authType, Socket socket)

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

abstract void

X509ExtendedTrustManager.checkServerTrusted​(X509Certificate[] chain, String authType, SSLEngine engine)

给定对等体提供的部分或完整证书链，根据认证类型和ssl参数构建和验证证书路径。

void

X509TrustManager.checkServerTrusted​(X509Certificate[] chain, String authType)

给定对等体提供的部分或完整的证书链，构建一个证书路径到一个受信任的根，并返回，如果它可以被验证，并且信任基于认证类型的服务器SSL认证。

String

X509KeyManager.chooseClientAlias​(String[] keyType, Principal[] issuers, Socket socket)

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，来认证安全套接字的客户端。

String

X509ExtendedKeyManager.chooseEngineClientAlias​(String[] keyType, Principal[] issuers, SSLEngine engine)

选择一个别名，以鉴定公钥类型和对等体识别的证书颁发机构列表（如果有的话），鉴别客户端 SSLEngine连接。

String

X509ExtendedKeyManager.chooseEngineServerAlias​(String keyType, Principal[] issuers, SSLEngine engine)

选择一个别名，以鉴定公钥类型和对等体识别的证书颁发机构列表（如果有的话），鉴定 SSLEngine连接的服务器端。

String

X509KeyManager.chooseServerAlias​(String keyType, Principal[] issuers, Socket socket)

选择一个别名，以鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构的列表，对安全套接字的服务器端进行身份验证。

static SNIMatcher

SNIHostName.createSNIMatcher​(String regex)

为SNIHostName创建一个SNIMatcher对象。

abstract Socket

SSLSocketFactory.createSocket​(Socket s, String host, int port, boolean autoClose)

返回在给定端口上分层连接到指定主机的现有套接字上的套接字。

SSLEngine

SSLContext.createSSLEngine​(String peerHost, int peerPort)

使用咨询对等体信息使用此上下文创建一个新的 SSLEngine 。

protected abstract SSLEngine

SSLContextSpi.engineCreateSSLEngine​(String host, int port)

使用此上下文创建一个 SSLEngine 。

X509Certificate[]

X509KeyManager.getCertificateChain​(String alias)

返回与给定别名关联的证书链。

String[]

X509KeyManager.getClientAliases​(String keyType, Principal[] issuers)

获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的客户端。

static KeyManagerFactory

KeyManagerFactory.getInstance​(String algorithm)

返回一个 KeyManagerFactory对象，作为密钥管理器的工厂。

static KeyManagerFactory

KeyManagerFactory.getInstance​(String algorithm, String provider)

返回一个 KeyManagerFactory对象，作为关键经理的工厂。

static KeyManagerFactory

KeyManagerFactory.getInstance​(String algorithm, Provider provider)

返回一个 KeyManagerFactory对象，作为主要管理员的工厂。

static SSLContext

SSLContext.getInstance​(String protocol)

返回实现指定安全套接字协议的 SSLContext对象。

static SSLContext

SSLContext.getInstance​(String protocol, String provider)

返回实现指定安全套接字协议的 SSLContext对象。

static SSLContext

SSLContext.getInstance​(String protocol, Provider provider)

返回实现指定安全套接字协议的 SSLContext对象。

static TrustManagerFactory

TrustManagerFactory.getInstance​(String algorithm)

返回作为信任管理器的工厂的 TrustManagerFactory对象。

static TrustManagerFactory

TrustManagerFactory.getInstance​(String algorithm, String provider)

返回作为信任管理器的工厂的 TrustManagerFactory对象。

static TrustManagerFactory

TrustManagerFactory.getInstance​(String algorithm, Provider provider)

返回一个充当信任管理器的工厂的 TrustManagerFactory对象。

PrivateKey

X509KeyManager.getPrivateKey​(String alias)

返回与给定别名相关联的键。

String[]

X509KeyManager.getServerAliases​(String keyType, Principal[] issuers)

获取匹配的别名，用于鉴定公钥类型和对等体（如果有的话）识别的证书颁发机构列表的身份验证安全套接字的服务器端。

Object

SSLSession.getValue​(String name)

返回绑定到会话应用层数据中给定名称的对象。

void

SSLSession.putValue​(String name, Object value)

使用给定的 name将指定的 value对象绑定到会话的应用程序层数据中。

void

SSLSession.removeValue​(String name)

删除在会话的应用层数据中绑定到给定名称的对象。

void

SSLParameters.setApplicationProtocols​(String[] protocols)

设置可以通过SSL / TLS / DTLS协议协商的应用层协议名称的优先级数组。

void

SSLParameters.setCipherSuites​(String[] cipherSuites)

设置密码组数组。

abstract void

SSLEngine.setEnabledCipherSuites​(String[] suites)

设置启用此引擎使用的密码套件。

abstract void

SSLServerSocket.setEnabledCipherSuites​(String[] suites)

设置允许接受连接使用的密码套件。

abstract void

SSLSocket.setEnabledCipherSuites​(String[] suites)

设置启用此连接的密码套件。

abstract void

SSLEngine.setEnabledProtocols​(String[] protocols)

设置允许在此引擎上使用的协议版本。

abstract void

SSLServerSocket.setEnabledProtocols​(String[] protocols)

控制哪些特定协议被接受的连接启用。

abstract void

SSLSocket.setEnabledProtocols​(String[] protocols)

设置允许在此连接上使用的协议版本。

void

SSLParameters.setEndpointIdentificationAlgorithm​(String algorithm)

设置端点识别算法。

void

SSLParameters.setProtocols​(String[] protocols)

设置协议数组。

static SSLEngineResult.HandshakeStatus

SSLEngineResult.HandshakeStatus.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SSLEngineResult.Status

SSLEngineResult.Status.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

boolean

HostnameVerifier.verify​(String hostname, SSLSession session)

验证主机名是否与服务器认证方案可接受的匹配。

Method parameters in javax.net.ssl with type arguments of type String

Modifier and Type

方法

描述

void

SSLEngine.setHandshakeApplicationProtocolSelector​(BiFunction<SSLEngine,List<String>,String> selector)

注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。

void

SSLEngine.setHandshakeApplicationProtocolSelector​(BiFunction<SSLEngine,List<String>,String> selector)

注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。

void

SSLSocket.setHandshakeApplicationProtocolSelector​(BiFunction<SSLSocket,List<String>,String> selector)

注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。

void

SSLSocket.setHandshakeApplicationProtocolSelector​(BiFunction<SSLSocket,List<String>,String> selector)

注册回调函数，为SSL / TLS / DTLS握手选择应用程序协议值。

Constructors in javax.net.ssl with parameters of type String

Constructor

描述

KeyManagerFactory​(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)

创建一个KeyManagerFactory对象。

SNIHostName​(String hostname)

使用指定的主机名创建一个 SNIHostName 。

SSLContext​(SSLContextSpi contextSpi, Provider provider, String protocol)

创建一个SSLContext对象。

SSLEngine​(String peerHost, int peerPort)

构造函数为 SSLEngine 。

SSLException​(String reason)

构造一个异常报告SSL子系统发现的错误。

SSLException​(String message, Throwable cause)

创建一个 SSLException与指定的详细信息和原因。

SSLHandshakeException​(String reason)

在握手期间构造一个异常报告SSL子系统发现的错误。

SSLKeyException​(String reason)

构造一个异常报告SSL子系统发现的密钥管理错误。

SSLParameters​(String[] cipherSuites)

从指定的密码子数组构造SSLParameters。

SSLParameters​(String[] cipherSuites, String[] protocols)

从指定的密码和协议数组构造SSLParameters。

SSLPeerUnverifiedException​(String reason)

构造一个异常，报告SSL对等体的身份未被验证。

SSLPermission​(String name)

创建一个具有指定名称的新SSLPermission。

SSLPermission​(String name, String actions)

创建一个具有指定名称的新SSLPermission对象。

SSLProtocolException​(String reason)

构造一个异常报告由SSL子系统检测到的SSL协议错误。

SSLSessionBindingEvent​(SSLSession session, String name)

构造一个新的SSLSessionBindingEvent。

SSLSocket​(String host, int port)

仅由子类使用。

SSLSocket​(String host, int port, InetAddress clientAddress, int clientPort)

仅由子类使用。

TrustManagerFactory​(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)

创建一个TrustManagerFactory对象。

Uses of String in javax.print

Fields in javax.print declared as String

Modifier and Type

Field

描述

static String

ServiceUIFactory.DIALOG_UI

表示实现为AWT对话框的UI。

static String

DocFlavor.hostEncoding

代表主机操作系统编码的字符串。

static String

ServiceUIFactory.JCOMPONENT_UI

表示实现为Swing组件的UI。

static String

ServiceUIFactory.JDIALOG_UI

表示实现为Swing对话框的UI。

static String

ServiceUIFactory.PANEL_UI

表示作为AWT面板实现的UI。

Methods in javax.print that return String

Modifier and Type

方法

描述

String

DocFlavor.getMediaSubtype​()

返回此文档flavor对象的媒体子类型（从MIME类型）。

String

DocFlavor.getMediaType​()

返回此文档flavor对象的媒体类型（从MIME类型）。

String

DocFlavor.getMimeType​()

根据规范表单返回此doc风格对象的MIME类型字符串。

String

PrintService.getName​()

返回此打印服务的字符串名称，可由应用程序用于请求特定打印服务。

abstract String

StreamPrintService.getOutputFormat​()

返回此打印服务发出的文档格式。

abstract String

StreamPrintServiceFactory.getOutputFormat​()

查询工厂获得的打印机发出的文档格式。

String

DocFlavor.getParameter​(String paramName)

返回表示MIME参数的 String 。

String

DocFlavor.getRepresentationClassName​()

返回此文档flavor对象的表示类的名称。

abstract String[]

ServiceUIFactory.getUIClassNamesForRole​(int role)

给定从这个工厂获得的UI角色，获取从这个工厂实现这个角色的UI类型。

String

DocFlavor.toString​()

将此 DocFlavor转换为字符串。

Methods in javax.print with parameters of type String

Modifier and Type

方法

描述

String

DocFlavor.getParameter​(String paramName)

返回表示MIME参数的 String 。

abstract Object

ServiceUIFactory.getUI​(int role, String ui)

获取UI对象，该对象可能被应用程序转换为请求的UI类型，并在其用户界面中使用。

static StreamPrintServiceFactory[]

StreamPrintServiceFactory.lookupStreamPrintServiceFactories​(DocFlavor flavor, String outputMimeType)

找到可用于打印作业的打印服务的工厂，以 outputMimeType指定的格式输出数据流。

Constructors in javax.print with parameters of type String

Constructor

描述

BYTE_ARRAY​(String mimeType)

使用给定的MIME类型和打印数据表示类名称为 "[B" （字节数组）构造新的doc风格。

CHAR_ARRAY​(String mimeType)

使用给定的MIME类型和打印数据表示类名称为 "[C" （字符数组）构造新的doc风格。

DocFlavor​(String mimeType, String className)

从给定的MIME类型和表示类名称构造一个新的doc flavor对象。

INPUT_STREAM​(String mimeType)

构造具有给定MIME类型和打印数据表示类名称 "java.io.InputStream" （字节流）的新文档风格。

PrintException​(String s)

使用给定的详细信息构造打印例外。

PrintException​(String s, 异常 e)

使用给定的详细消息和链接异常构造打印异常。

READER​(String mimeType)

构造具有给定MIME类型和打印数据表示类名称\ * "java.io.Reader" （字符流）的新文档风格。

SERVICE_FORMATTED​(String className)

构造一种MIME类型为 "application/x-java-jvm-local-objectref"的新文档风格，指示服务格式的打印数据和给定的打印数据表示类名。

STRING​(String mimeType)

构造具有给定MIME类型和打印数据表示类名称 "java.lang.String"的新文档风格。

URL​(String mimeType)

使用给定的MIME类型和打印数据表示类名称为 "java.net.URL"构造新的doc风格。

Uses of String in javax.print.attribute

Methods in javax.print.attribute that return String

Modifier and Type

方法

描述

String

Attribute.getName​()

获取此属性值是一个实例的类别的名称。

protected String[]

EnumSyntax.getStringTable​()

返回枚举值枚举类的字符串表。

String

TextSyntax.getValue​()

返回此文本属性的文本字符串。

String

DateTimeSyntax.toString​()

返回与此date-time属性对应的字符串值。

String

EnumSyntax.toString​()

返回与此枚举值对应的字符串值。

String

IntegerSyntax.toString​()

返回与该整数属性对应的字符串值。

String

ResolutionSyntax.toString​()

返回此分辨率属性的字符串版本。

String

ResolutionSyntax.toString​(int units, String unitsName)

以给定的单位返回此分辨率属性的字符串版本。

String

SetOfIntegerSyntax.toString​()

返回与该set-of-integer属性对应的字符串值。

String

Size2DSyntax.toString​()

返回此二维大小属性的字符串版本。

String

Size2DSyntax.toString​(int units, String unitsName)

以给定单位返回此二维尺寸属性的字符串版本。

String

TextSyntax.toString​()

返回一个标识此文本属性的字符串。

String

URISyntax.toString​()

返回一个标识此URI属性的字符串。

Methods in javax.print.attribute with parameters of type String

Modifier and Type

方法

描述

String

ResolutionSyntax.toString​(int units, String unitsName)

以给定的单位返回此分辨率属性的字符串版本。

String

Size2DSyntax.toString​(int units, String unitsName)

以给定单位返回此二维尺寸属性的字符串版本。

Constructors in javax.print.attribute with parameters of type String

Constructor

描述

SetOfIntegerSyntax​(String members)

使用字符串形式的给定成员构造一个新的整数整型属性。

TextSyntax​(String value, Locale locale)

构造具有指定字符串和语言环境的TextAttribute。

UnmodifiableSetException​(String message)

构造具有指定详细消息的UnmodifiableSetException。

Uses of String in javax.print.attribute.standard

Methods in javax.print.attribute.standard that return String

Modifier and Type

方法

描述

String

Chromaticity.getName​()

获取此属性值是一个实例的类别的名称。

String

ColorSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

Compression.getName​()

获取此属性值是一个实例的类别的名称。

String

Copies.getName​()

获取此属性值是一个实例的类别的名称。

String

CopiesSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

DateTimeAtCompleted.getName​()

获取此属性值是一个实例的类别的名称。

String

DateTimeAtCreation.getName​()

获取此属性值是一个实例的类别的名称。

String

DateTimeAtProcessing.getName​()

获取此属性值是一个实例的类别的名称。

String

Destination.getName​()

获取此属性值是一个实例的类别的名称。

String

DialogTypeSelection.getName​()

获取此属性值是一个实例的类别的名称。

String

DocumentName.getName​()

获取此属性值是一个实例的类别的名称。

String

Fidelity.getName​()

获取此属性值是一个实例的类别的名称。

String

Finishings.getName​()

获取此属性值是一个实例的类别的名称。

String

JobHoldUntil.getName​()

获取此属性值是一个实例的类别的名称。

String

JobImpressions.getName​()

获取此属性值是一个实例的类别的名称。

String

JobImpressionsCompleted.getName​()

获取此属性值是一个实例的类别的名称。

String

JobImpressionsSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

JobKOctets.getName​()

获取此属性值是一个实例的类别的名称。

String

JobKOctetsProcessed.getName​()

获取此属性值是一个实例的类别的名称。

String

JobKOctetsSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

JobMediaSheets.getName​()

获取此属性值是一个实例的类别的名称。

String

JobMediaSheetsCompleted.getName​()

获取此属性值是一个实例的类别的名称。

String

JobMediaSheetsSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

JobMessageFromOperator.getName​()

获取此属性值是一个实例的类别的名称。

String

JobName.getName​()

获取此属性值是一个实例的类别的名称。

String

JobOriginatingUserName.getName​()

获取此属性值是一个实例的类别的名称。

String

JobPriority.getName​()

获取此属性值是一个实例的类别的名称。

String

JobPrioritySupported.getName​()

获取此属性值是一个实例的类别的名称。

String

JobSheets.getName​()

获取此属性值是一个实例的类别的名称。

String

JobState.getName​()

获取此属性值是一个实例的类别的名称。

String

JobStateReason.getName​()

获取此属性值是一个实例的类别的名称。

String

JobStateReasons.getName​()

获取此属性值是一个实例的类别的名称。

String

Media.getName​()

获取此属性值是一个实例的类别的名称。

String

MediaPrintableArea.getName​()

获取此属性值是一个实例的类别的名称。

String

MediaSize.getName​()

获取此属性值是一个实例的类别的名称。

String

MultipleDocumentHandling.getName​()

获取此属性值是一个实例的类别的名称。

String

NumberOfDocuments.getName​()

获取此属性值是一个实例的类别的名称。

String

NumberOfInterveningJobs.getName​()

获取此属性值是一个实例的类别的名称。

String

NumberUp.getName​()

获取此属性值是一个实例的类别的名称。

String

NumberUpSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

OrientationRequested.getName​()

获取此属性值是一个实例的类别的名称。

String

OutputDeviceAssigned.getName​()

获取此属性值是一个实例的类别的名称。

String

PageRanges.getName​()

获取此属性值是一个实例的类别的名称。

String

PagesPerMinute.getName​()

获取此属性值是一个实例的类别的名称。

String

PagesPerMinuteColor.getName​()

获取此属性值是一个实例的类别的名称。

String

PDLOverrideSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

PresentationDirection.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterInfo.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterIsAcceptingJobs.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterLocation.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterMakeAndModel.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterMessageFromOperator.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterMoreInfo.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterMoreInfoManufacturer.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterName.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterResolution.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterState.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterStateReason.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterStateReasons.getName​()

获取此属性值是一个实例的类别的名称。

String

PrinterURI.getName​()

获取此属性值是一个实例的类别的名称。

String

PrintQuality.getName​()

获取此属性值是一个实例的类别的名称。

String

QueuedJobCount.getName​()

获取此属性值是一个实例的类别的名称。

String

ReferenceUriSchemesSupported.getName​()

获取此属性值是一个实例的类别的名称。

String

RequestingUserName.getName​()

获取此属性值是一个实例的类别的名称。

String

Severity.getName​()

获取此属性值是一个实例的类别的名称。

String

SheetCollate.getName​()

获取此属性值是一个实例的类别的名称。

String

Sides.getName​()

获取此属性值是一个实例的类别的名称。

protected String[]

Chromaticity.getStringTable​()

返回类Chromaticity的字符串表。

protected String[]

ColorSupported.getStringTable​()

返回ColorSupported类的字符串表。

protected String[]

Compression.getStringTable​()

返回类Compression的字符串表。

protected String[]

DialogTypeSelection.getStringTable​()

返回DialogTypeSelection类的字符串表。

protected String[]

Fidelity.getStringTable​()

返回Fidelity类的字符串表。

protected String[]

Finishings.getStringTable​()

返回类Finishings的字符串表。

protected String[]

JobSheets.getStringTable​()

返回JobSheets类的字符串表。

protected String[]

JobState.getStringTable​()

返回JobState类的字符串表。

protected String[]

JobStateReason.getStringTable​()

返回JobStateReason类的字符串表。

protected String[]

MediaName.getStringTable​()

返回类MediaTray的字符串表。

protected String[]

MediaSizeName.getStringTable​()

返回类MediaSizeName的字符串表。

protected String[]

MediaTray.getStringTable​()

返回类MediaTray的字符串表。

protected String[]

MultipleDocumentHandling.getStringTable​()

返回类MultipleDocumentHandling的字符串表。

protected String[]

OrientationRequested.getStringTable​()

返回类OrientationRequested的字符串表。

protected String[]

PDLOverrideSupported.getStringTable​()

返回类PDLOverrideSupported的字符串表。

protected String[]

PresentationDirection.getStringTable​()

返回类PresentationDirection的字符串表。

protected String[]

PrinterIsAcceptingJobs.getStringTable​()

返回PrinterIsAcceptingJobs类的字符串表。

protected String[]

PrinterState.getStringTable​()

返回PrinterState类的字符串表。

protected String[]

PrinterStateReason.getStringTable​()

返回PrinterStateReason类的字符串表。

protected String[]

PrintQuality.getStringTable​()

返回PrintQuality类的字符串表。

protected String[]

ReferenceUriSchemesSupported.getStringTable​()

返回ReferenceUriSchemesSupported类的字符串表。

protected String[]

Severity.getStringTable​()

返回类Severity的字符串表。

protected String[]

SheetCollate.getStringTable​()

返回SheetCollate类的字符串表。

protected String[]

Sides.getStringTable​()

返回类Sides的字符串表。

String

MediaPrintableArea.toString​()

返回以mm为单位的矩形大小属性的字符串版本。

String

MediaPrintableArea.toString​(int units, String unitsName)

返回给定单位的此矩形大小属性的字符串版本。

Methods in javax.print.attribute.standard with parameters of type String

Modifier and Type

方法

描述

String

MediaPrintableArea.toString​(int units, String unitsName)

返回给定单位的此矩形大小属性的字符串版本。

Constructors in javax.print.attribute.standard with parameters of type String

Constructor

描述

DocumentName​(String documentName, Locale locale)

使用给定的文档名称和语言环境构造新的文档名称属性。

JobMessageFromOperator​(String message, Locale locale)

使用给定的消息和语言环境构造来自operator属性的新作业消息。

JobName​(String jobName, Locale locale)

构造具有给定作业名称和区域设置的新作业名称属性。

JobOriginatingUserName​(String userName, Locale locale)

构造具有给定用户名和区域设置的新作业发起用户名属性。

OutputDeviceAssigned​(String deviceName, Locale locale)

使用给定的设备名称和语言环境构造新的输出设备分配的属性。

PageRanges​(String members)

使用字符串形式的给定成员构造新的页面范围属性。

PrinterInfo​(String info, Locale locale)

使用给定的信息字符串和语言环境构造新的打印机信息属性。

PrinterLocation​(String location, Locale locale)

构造具有给定位置和区域设置的新的打印机位置属性。

PrinterMakeAndModel​(String makeAndModel, Locale locale)

使用给定的make和model字符串和locale构造一个新的打印机make和model属性。

PrinterMessageFromOperator​(String message, Locale locale)

使用给定的消息和区域设置构造来自operator属性的新打印机消息。

PrinterName​(String printerName, Locale locale)

构造具有给定名称和区域设置的新的打印机名称属性。

RequestingUserName​(String userName, Locale locale)

使用给定的用户名和区域设置构造一个新的请求用户名属性。

Uses of String in javax.print.event

Methods in javax.print.event that return String

Modifier and Type

方法

描述

String

PrintEvent.toString​()

Uses of String in javax.rmi.CORBA

Methods in javax.rmi.CORBA that return String

Modifier and Type

方法

描述

static String

Util.getCodebase​(Class clz)

返回给定类的代码库（如果有）。

String

UtilDelegate.getCodebase​(Class clz)

代表团要求 Util.getCodebase(java.lang.Class) 。

String

ValueHandler.getRMIRepositoryID​(Class clz)

返回给定Java类的CORBA RepositoryId。

String

Stub.toString​()

返回此存根的字符串表示形式。

String

StubDelegate.toString​(Stub self)

代表团要求 Stub.toString() 。

Methods in javax.rmi.CORBA with parameters of type String

Modifier and Type

方法

描述

static Class

Util.loadClass​(String className, String remoteCodebase, ClassLoader loader)

返回指定类的类实例。

Class

UtilDelegate.loadClass​(String className, String remoteCodebase, ClassLoader loader)

代表团要求 Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 。

Serializable

ValueHandler.readValue​(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)

使用Java语义从流读取值。

Uses of String in javax.rmi.ssl

Methods in javax.rmi.ssl that return String

Modifier and Type

方法

描述

String[]

SslRMIServerSocketFactory.getEnabledCipherSuites​()

返回由此工厂创建的服务器套接字接受的SSL连接启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则 null 。

String[]

SslRMIServerSocketFactory.getEnabledProtocols​()

返回由此工厂创建的服务器套接字接受的SSL连接启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则 null 。

Methods in javax.rmi.ssl with parameters of type String

Modifier and Type

方法

描述

Socket

SslRMIClientSocketFactory.createSocket​(String host, int port)

创建一个SSL套接字。

Constructors in javax.rmi.ssl with parameters of type String

Constructor

描述

SslRMIServerSocketFactory​(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)

使用指定的SSL套接字配置创建一个新的 SslRMIServerSocketFactory 。

SslRMIServerSocketFactory​(SSLContext context, String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)

创建一个新的 SslRMIServerSocketFactory与指定的 SSLContext和SSL套接字配置。

Uses of String in javax.script

Fields in javax.script declared as String

Modifier and Type

Field

描述

static String

ScriptEngine.ARGV

用于将位置参数数组传递给脚本的命名值的保留键。

static String

ScriptEngine.ENGINE

命名值的保留键为 ScriptEngine实现的名称。

static String

ScriptEngine.ENGINE_VERSION

用于标识 ScriptEngine实现版本的命名值的保留键。

static String

ScriptEngine.FILENAME

作为正在执行的文件的名称的命名值的保留键。

static String

ScriptEngine.LANGUAGE

作为实现支持的脚本语言的全名的命名值的保留键。

static String

ScriptEngine.LANGUAGE_VERSION

用于标识实现支持的脚本语言版本的命名值的保留键。

static String

ScriptEngine.NAME

用于标识脚本语言的短名称的命名值的保留键。

Methods in javax.script that return String

Modifier and Type

方法

描述

String

ScriptEngineFactory.getEngineName​()

返回 ScriptEngine的全名。

String

ScriptEngineFactory.getEngineVersion​()

返回 ScriptEngine的版本。

String

ScriptException.getFileName​()

获取导致错误的脚本的源。

String

ScriptEngineFactory.getLanguageName​()

返回此 ScriptEngine支持的脚本语言的名称。

String

ScriptEngineFactory.getLanguageVersion​()

返回此 ScriptEngine支持的脚本语言版本。

String

ScriptException.getMessage​()

返回包含传递给构造函数的String以及行和列号以及文件名（如果有的话）已知的消息。

String

ScriptEngineFactory.getMethodCallSyntax​(String obj, String m, String... args)

返回一个String，可以使用支持的脚本语言的语法来调用Java对象的方法。

String

ScriptEngineFactory.getOutputStatement​(String toDisplay)

返回一个可用作语句的字符串，使用支持的脚本语言的语法显示指定的String。

String

ScriptEngineFactory.getProgram​(String... statements)

返回带有给定语句的有效脚本语言可执行程序。

Methods in javax.script that return types with arguments of type String

Modifier and Type

方法

描述

Set<Map.Entry<String,Object>>

SimpleBindings.entrySet​()

返回此地图中包含的映射的Set视图。

List<String>

ScriptEngineFactory.getExtensions​()

返回一个不可变的文件扩展名列表，它们通常标识以 ScriptEngine支持的语言编写的脚本。

List<String>

ScriptEngineFactory.getMimeTypes​()

返回一个不可变的mimetype列表，与引擎可执行的脚本相关联。

List<String>

ScriptEngineFactory.getNames​()

返回一个不可变的 ScriptEngine短名单，可用于识别 ScriptEngine由 ScriptEngineManager 。

Set<String>

SimpleBindings.keySet​()

返回此地图中包含的键的Set视图。

Methods in javax.script with parameters of type String

Modifier and Type

方法

描述

CompiledScript

Compilable.compile​(String script)

编译脚本（源代码为 String ）供以后执行。

Object

AbstractScriptEngine.eval​(String script)

与 eval(Reader)相同，但使用摘要 eval(String, ScriptContext) 。

Object

AbstractScriptEngine.eval​(String script, Bindings bindings)

与 eval(Reader, Bindings)相同，但使用摘要 eval(String, ScriptContext) 。

Object

ScriptEngine.eval​(String script)

执行指定的脚本。

Object

ScriptEngine.eval​(String script, Bindings n)

执行使用该脚本 Bindings参数为 ENGINE_SCOPE Bindings的的 ScriptEngine的脚本执行期间。

Object

ScriptEngine.eval​(String script, ScriptContext context)

导致立即执行脚本，其脚本是作为第一个参数传递的String。

Object

AbstractScriptEngine.get​(String key)

获取受保护的 context字段的 ENGINE_SCOPE中的指定键的值。

Object

ScriptEngine.get​(String key)

检索在此引擎状态下设置的值。

Object

ScriptEngineManager.get​(String key)

获取全局范围中指定键的值

Object

ScriptContext.getAttribute​(String name)

在搜索顺序中最早出现的范围内检索具有给定名称的属性值。

Object

ScriptContext.getAttribute​(String name, int scope)

获取给定范围内的属性值。

Object

SimpleScriptContext.getAttribute​(String name)

在搜索顺序中最早出现的范围内检索具有给定名称的属性值。

Object

SimpleScriptContext.getAttribute​(String name, int scope)

获取给定范围内的属性值。

int

ScriptContext.getAttributesScope​(String name)

获取定义属性的最低范围。

int

SimpleScriptContext.getAttributesScope​(String name)

获取定义属性的最低范围。

ScriptEngine

ScriptEngineManager.getEngineByExtension​(String extension)

查找并为给定的扩展程序创建一个 ScriptEngine 。

ScriptEngine

ScriptEngineManager.getEngineByMimeType​(String mimeType)

查找并为给定的MIME类型创建一个 ScriptEngine 。

ScriptEngine

ScriptEngineManager.getEngineByName​(String shortName)

查找并为给定的名称创建一个 ScriptEngine 。

String

ScriptEngineFactory.getMethodCallSyntax​(String obj, String m, String... args)

返回一个String，可以使用支持的脚本语言的语法来调用Java对象的方法。

String

ScriptEngineFactory.getOutputStatement​(String toDisplay)

返回一个可用作语句的字符串，使用支持的脚本语言的语法显示指定的String。

Object

ScriptEngineFactory.getParameter​(String key)

返回属性的值，该属性的含义可能是实现特定的。

String

ScriptEngineFactory.getProgram​(String... statements)

返回带有给定语句的有效脚本语言可执行程序。

Object

Invocable.invokeFunction​(String name, Object... args)

用于调用脚本中定义的顶级过程和函数。

Object

Invocable.invokeMethod​(Object thiz, String name, Object... args)

调用在前一个脚本执行期间编译的脚本对象上的方法，该方法保留在 ScriptEngine的状态。

void

AbstractScriptEngine.put​(String key, Object value)

设置与在指定键指定的值 ENGINE_SCOPE Bindings受保护的 context领域。

Object

Bindings.put​(String name, Object value)

设置一个命名值。

void

ScriptEngine.put​(String key, Object value)

在ScriptEngine的状态下设置一个键/值对，可以创建一个Java语言绑定，以便在执行脚本时使用，或者以其他方式使用，具体取决于该键是否被保留。

void

ScriptEngineManager.put​(String key, Object value)

在全局范围中设置指定的键/值对。

Object

SimpleBindings.put​(String name, Object value)

在底层的 map字段中设置指定的键/值。

void

ScriptEngineManager.registerEngineExtension​(String extension, ScriptEngineFactory factory)

注册一个 ScriptEngineFactory来处理扩展。

void

ScriptEngineManager.registerEngineMimeType​(String type, ScriptEngineFactory factory)

注册一个 ScriptEngineFactory来处理一个MIME类型。

void

ScriptEngineManager.registerEngineName​(String name, ScriptEngineFactory factory)

注册一个 ScriptEngineFactory来处理一个语言名称。

Object

ScriptContext.removeAttribute​(String name, int scope)

删除给定范围内的属性。

Object

SimpleScriptContext.removeAttribute​(String name, int scope)

删除给定范围内的属性。

void

ScriptContext.setAttribute​(String name, Object value, int scope)

设置给定范围内的属性值。

void

SimpleScriptContext.setAttribute​(String name, Object value, int scope)

设置给定范围内的属性值。

Method parameters in javax.script with type arguments of type String

Modifier and Type

方法

描述

void

Bindings.putAll​(Map<? extends String,? extends Object> toMerge)

将给定的 Map中的所有映射添加到此 Bindings 。

void

SimpleBindings.putAll​(Map<? extends String,? extends Object> toMerge)

putAll是使用 Map.putAll实现的。

Constructors in javax.script with parameters of type String

Constructor

描述

ScriptException​(String s)

创建一个 ScriptException与一个字符串在其消息中使用。

ScriptException​(String message, String fileName, int lineNumber)

创建一个 ScriptException其中包含消息，文件名和 ScriptException以用于错误消息。

ScriptException​(String message, String fileName, int lineNumber, int columnNumber)

ScriptException构造指定信息，文件名，行号和列号。

Constructor parameters in javax.script with type arguments of type String

Constructor

描述

SimpleBindings​(Map<String,Object> m)

构造函数使用现有的 Map来存储值。

Uses of String in javax.security.auth

Methods in javax.security.auth that return String

Modifier and Type

方法

描述

String

PrivateCredentialPermission.getActions​()

返回动作的“规范字符串表示”。

String

PrivateCredentialPermission.getCredentialClass​()

返回与此 PrivateCredentialPermission关联的凭据的类名。

String[][]

PrivateCredentialPermission.getPrincipals​()

返回与此 PrivateCredentialPermission相关联的 Principal类和名称。

String

Subject.toString​()

返回此 Subject的字符串表示 Subject 。

Constructors in javax.security.auth with parameters of type String

Constructor

描述

AuthPermission​(String name)

创建一个具有指定名称的新AuthPermission。

AuthPermission​(String name, String actions)

创建一个具有指定名称的新AuthPermission对象。

DestroyFailedException​(String msg)

构造具有指定详细消息的DestroyFailedException。

PrivateCredentialPermission​(String name, String actions)

创建一个新的 PrivateCredentialPermission与指定的 name 。

RefreshFailedException​(String msg)

构造具有指定详细消息的RefreshFailedException。

Uses of String in javax.security.auth.callback

Methods in javax.security.auth.callback that return String

Modifier and Type

方法

描述

String[]

ChoiceCallback.getChoices​()

获取选择列表。

String

NameCallback.getDefaultName​()

获取默认名称。

String

TextInputCallback.getDefaultText​()

获取默认文本。

String

TextOutputCallback.getMessage​()

获取要显示的消息。

String

NameCallback.getName​()

获取检索到的名称。

String[]

ConfirmationCallback.getOptions​()

获取确认选项。

String

ChoiceCallback.getPrompt​()

获取提示。

String

ConfirmationCallback.getPrompt​()

获取提示。

String

NameCallback.getPrompt​()

获取提示。

String

PasswordCallback.getPrompt​()

获取提示。

String

TextInputCallback.getPrompt​()

获取提示。

String

TextInputCallback.getText​()

获取检索到的文本。

Methods in javax.security.auth.callback with parameters of type String

Modifier and Type

方法

描述

void

NameCallback.setName​(String name)

设置检索到的名称。

void

TextInputCallback.setText​(String text)

设置检索到的文本。

Constructors in javax.security.auth.callback with parameters of type String

Constructor

描述

ChoiceCallback​(String prompt, String[] choices, int defaultChoice, boolean multipleSelectionsAllowed)

构造一个 ChoiceCallback其中包含提示，选择列表，默认选项和布尔值，指定是否允许从选项列表中选择多个选项。

ConfirmationCallback​(int messageType, String[] options, int defaultOption)

构造一个 ConfirmationCallback与消息类型，选项列表和默认选项。

ConfirmationCallback​(String prompt, int messageType, int optionType, int defaultOption)

使用提示，消息类型，选项类型和默认选项构造 ConfirmationCallback 。

ConfirmationCallback​(String prompt, int messageType, String[] options, int defaultOption)

使用提示，消息类型，选项列表和默认选项构建 ConfirmationCallback 。

NameCallback​(String prompt)

用提示构建一个 NameCallback 。

NameCallback​(String prompt, String defaultName)

构造一个带有提示和默认名称的 NameCallback 。

PasswordCallback​(String prompt, boolean echoOn)

构造一个带有提示符和布尔值的 PasswordCallback ，指定是否应该在输入密码时显示该密码。

TextInputCallback​(String prompt)

构造一个 TextInputCallback提示。

TextInputCallback​(String prompt, String defaultText)

构造一个具有提示和默认输入值的 TextInputCallback 。

TextOutputCallback​(int messageType, String message)

构造一个TextOutputCallback，并显示消息类型和消息。

UnsupportedCallbackException​(Callback callback, String msg)

构造具有指定详细消息的UnsupportedCallbackException。

Uses of String in javax.security.auth.kerberos

Methods in javax.security.auth.kerberos that return String

Modifier and Type

方法

描述

String

ServicePermission.getActions​()

返回动作的规范字符串表示形式。

String

EncryptionKey.getAlgorithm​()

返回此键的标准算法名称。

String

KerberosKey.getAlgorithm​()

返回此键的标准算法名称。

String

EncryptionKey.getFormat​()

返回此键的编码格式的名称。

String

KerberosKey.getFormat​()

返回此密钥的编码格式的名称。

String

KerberosPrincipal.getName​()

返回的字符串对应于 RFC 1964第2.1节中指定的Kerberos主体名称的单字符串表示 形式 。

String

KerberosPrincipal.getRealm​()

返回此Kerberos主体的领域组件。

String

EncryptionKey.toString​()

返回此 EncryptionKey的内容丰富的文字表示。

String

KerberosCredMessage.toString​()

返回此 KerberosCredMessage的内容丰富的文字表示。

String

KerberosKey.toString​()

返回此 KerberosKey的内容丰富的文字表示。

String

KerberosPrincipal.toString​()

返回此 KerberosPrincipal的内容丰富的文字表示。

String

KerberosTicket.toString​()

返回此 KerberosTicket的内容丰富的文字表示。

String

KeyTab.toString​()

返回此 KeyTab的内容丰富的文字表示。

Constructors in javax.security.auth.kerberos with parameters of type String

Constructor

描述

DelegationPermission​(String principals)

创建一个新的 DelegationPermission与指定的下属和目标主体。

DelegationPermission​(String principals, String actions)

创建一个新的 DelegationPermission与指定的下属和目标主体。

KerberosKey​(KerberosPrincipal principal, char[] password, String algorithm)

使用指定的算法名称从主体的密码构建一个 KerberosKey 。

KerberosPrincipal​(String name)

从提供的字符串输入构造一个 KerberosPrincipal 。

KerberosPrincipal​(String name, int nameType)

从提供的字符串和名称类型输入构造一个 KerberosPrincipal 。

ServicePermission​(String servicePrincipal, String action)

创建一个新的 ServicePermission与指定的 servicePrincipal和 action 。

Uses of String in javax.security.auth.login

Methods in javax.security.auth.login that return String

Modifier and Type

方法

描述

String

AppConfigurationEntry.getLoginModuleName​()

获取配置的类别名称 LoginModule 。

String

Configuration.getType​()

返回此配置的类型。

String

AppConfigurationEntry.LoginModuleControlFlag.toString​()

返回此controlFlag的String表示形式。

Methods in javax.security.auth.login that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,?>

AppConfigurationEntry.getOptions​()

获取为此配置的选项 LoginModule 。

Methods in javax.security.auth.login with parameters of type String

Modifier and Type

方法

描述

protected abstract AppConfigurationEntry[]

ConfigurationSpi.engineGetAppConfigurationEntry​(String name)

检索指定的 name的AppConfigurationEntries。

abstract AppConfigurationEntry[]

Configuration.getAppConfigurationEntry​(String name)

从此配置中检索指定的 name的AppConfigurationEntries。

static Configuration

Configuration.getInstance​(String type, Configuration.Parameters params)

返回指定类型的Configuration对象。

static Configuration

Configuration.getInstance​(String type, Configuration.Parameters params, String provider)

返回指定类型的Configuration对象。

static Configuration

Configuration.getInstance​(String type, Configuration.Parameters params, Provider provider)

返回指定类型的Configuration对象。

Constructors in javax.security.auth.login with parameters of type String

Constructor

描述

AccountException​(String msg)

构造具有指定详细消息的AccountException。

AccountExpiredException​(String msg)

构造具有指定详细消息的AccountExpiredException。

AccountLockedException​(String msg)

构造具有指定详细消息的AccountLockedException。

AccountNotFoundException​(String msg)

构造具有指定详细消息的AccountNotFoundException。

AppConfigurationEntry​(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)

此类的默认构造函数。

CredentialException​(String msg)

构造具有指定详细消息的CredentialException。

CredentialExpiredException​(String msg)

构造具有指定详细消息的CredentialExpiredException。

CredentialNotFoundException​(String msg)

构造具有指定详细消息的CredentialNotFoundException。

FailedLoginException​(String msg)

构造具有指定详细消息的FailedLoginException。

LoginContext​(String name)

使用名称实例化一个新的 LoginContext对象。

LoginContext​(String name, CallbackHandler callbackHandler)

实例化一个新的 LoginContext的名称和一个对象 CallbackHandler对象。

LoginContext​(String name, Subject subject)

实例化一个新的 LoginContext的名称和一个对象 Subject对象。

LoginContext​(String name, Subject subject, CallbackHandler callbackHandler)

实例化一个新的 LoginContext对象，其名称为 Subject以进行身份验证，以及一个 CallbackHandler对象。

LoginContext​(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)

实例化一个新 LoginContext对象有一个名字，一个 Subject要进行身份验证，一个 CallbackHandler对象，登录 Configuration 。

LoginException​(String msg)

构造一个具有指定的详细消息的LoginException。

Constructor parameters in javax.security.auth.login with type arguments of type String

Constructor

描述

AppConfigurationEntry​(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)

此类的默认构造函数。

Uses of String in javax.security.auth.spi

Method parameters in javax.security.auth.spi with type arguments of type String

Modifier and Type

方法

描述

void

LoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)

初始化此LoginModule。

Uses of String in javax.security.auth.x500

Fields in javax.security.auth.x500 declared as String

Modifier and Type

Field

描述

static String

X500Principal.CANONICAL

可分辨名称的规范字符串格式。

static String

X500Principal.RFC1779

RFC 1779可分辨名称的字符串格式。

static String

X500Principal.RFC2253

RFC 2253可分辨名称的字符串格式。

Methods in javax.security.auth.x500 that return String

Modifier and Type

方法

描述

String

X500PrivateCredential.getAlias​()

返回KeyStore别名。

String

X500Principal.getName​()

使用RFC 2253中定义的格式返回X.500可分辨名称的字符串表示形式。

String

X500Principal.getName​(String format)

使用指定的格式返回X.500可分辨名称的字符串表示形式。

String

X500Principal.getName​(String format, Map<String,String> oidMap)

使用指定的格式返回X.500可分辨名称的字符串表示形式。

String

X500Principal.toString​()

返回这个 X500Principal的用户友好的字符串表示。

Methods in javax.security.auth.x500 with parameters of type String

Modifier and Type

方法

描述

String

X500Principal.getName​(String format)

使用指定的格式返回X.500可分辨名称的字符串表示形式。

String

X500Principal.getName​(String format, Map<String,String> oidMap)

使用指定的格式返回X.500可分辨名称的字符串表示形式。

Method parameters in javax.security.auth.x500 with type arguments of type String

Modifier and Type

方法

描述

String

X500Principal.getName​(String format, Map<String,String> oidMap)

使用指定的格式返回X.500可分辨名称的字符串表示形式。

String

X500Principal.getName​(String format, Map<String,String> oidMap)

使用指定的格式返回X.500可分辨名称的字符串表示形式。

Constructors in javax.security.auth.x500 with parameters of type String

Constructor

描述

X500Principal​(String name)

从X.500专有名称的字符串表示形式（例如：“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”）创建 X500Principal 。

X500Principal​(String name, Map<String,String> keywordMap)

从X.500专有名称的字符串表示形式（例如：“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”）创建一个 X500Principal 。

X500PrivateCredential​(X509Certificate cert, PrivateKey key, String alias)

创建X500PrivateCredential，它将X.509证书，私钥和KeyStore别名相关联。

Constructor parameters in javax.security.auth.x500 with type arguments of type String

Constructor

描述

X500Principal​(String name, Map<String,String> keywordMap)

从X.500专有名称的字符串表示形式（例如：“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”）创建 X500Principal 。

X500Principal​(String name, Map<String,String> keywordMap)

从X.500专有名称的字符串表示形式（例如：“CN = Duke，OU = JavaSoft，O = Sun Microsystems，C = US”）创建 X500Principal 。

Uses of String in javax.security.cert

Methods in javax.security.cert that return String

Modifier and Type

方法

描述

abstract String

X509Certificate.getSigAlgName​()

已过时。

获取证书签名算法的签名算法名称。

abstract String

X509Certificate.getSigAlgOID​()

已过时。

从证书获取签名算法OID字符串。

abstract String

Certificate.toString​()

已过时。

返回此证书的字符串表示形式。

Methods in javax.security.cert with parameters of type String

Modifier and Type

方法

描述

abstract void

Certificate.verify​(PublicKey key, String sigProvider)

已过时。

使用与指定公钥对应的私钥验证此证书是否已经签名。

Constructors in javax.security.cert with parameters of type String

Constructor

描述

CertificateEncodingException​(String message)

已过时。

构造具有指定详细消息的CertificateEncodingException。

CertificateException​(String msg)

已过时。

使用给定的详细消息构造证书异常。

CertificateExpiredException​(String message)

已过时。

构造具有指定详细消息的CertificateExpiredException。

CertificateNotYetValidException​(String message)

已过时。

构造具有指定详细消息的CertificateNotYetValidException。

CertificateParsingException​(String message)

已过时。

构造具有指定详细消息的CertificateParsingException。

Uses of String in javax.security.sasl

Fields in javax.security.sasl declared as String

Modifier and Type

Field

描述

static String

Sasl.BOUND_SERVER_NAME

指定未绑定服务器的绑定服务器名称的属性的名称。

static String

Sasl.CREDENTIALS

指定要使用的凭据的属性的名称。

static String

Sasl.MAX_BUFFER

指定 SaslClient的接收缓冲区的最大大小（以字节为单位）的 SaslClient SaslServer 。

static String

Sasl.POLICY_FORWARD_SECRECY

指定是否需要在会话之间实现向前保密的机制的属性的名称。

static String

Sasl.POLICY_NOACTIVE

指定是否允许容易受到活动（非字典）攻击的机制的属性的名称。

static String

Sasl.POLICY_NOANONYMOUS

指定是否允许接受匿名登录的机制的属性的名称。

static String

Sasl.POLICY_NODICTIONARY

指定是否允许容易受被动字典攻击的机制的属性的名称。

static String

Sasl.POLICY_NOPLAINTEXT

指定是否允许容易受到简单的被动攻击的机制（例如“PLAIN”）的属性的名称。

static String

Sasl.POLICY_PASS_CREDENTIALS

指定是否需要传递客户端凭据的机制的属性的名称。

static String

Sasl.QOP

指定要使用的保护质量的属性的名称。

static String

Sasl.RAW_SEND_SIZE

它指定的字节初始发送缓冲区的最大大小的属性的名称 SaslClient / SaslServer 。

static String

Sasl.REUSE

指定是否重新使用以前验证的会话信息的属性的名称。

static String

Sasl.SERVER_AUTH

指定服务器是否必须向客户端进行身份验证的属性的名称。

static String

Sasl.STRENGTH

指定要使用的密码强度的属性的名称。

Methods in javax.security.sasl that return String

Modifier and Type

方法

描述

String

AuthorizeCallback.getAuthenticationID​()

返回要检查的身份验证ID。

String

AuthorizeCallback.getAuthorizationID​()

返回要检查的授权ID。

String

SaslServer.getAuthorizationID​()

报告此会话客户端的授权ID。

String

AuthorizeCallback.getAuthorizedID​()

返回授权用户的ID。

String

SaslClient.getMechanismName​()

返回此SASL客户端的IANA注册机制名称。

String

SaslServer.getMechanismName​()

返回该SASL服务器的IANA注册的机制名称。

String[]

SaslClientFactory.getMechanismNames​(Map<String,?> props)

返回与指定的机制选择策略匹配的机制名称数组。

String[]

SaslServerFactory.getMechanismNames​(Map<String,?> props)

返回与指定的机制选择策略匹配的机制名称数组。

String

SaslException.toString​()

返回此异常的字符串表示形式。

Methods in javax.security.sasl with parameters of type String

Modifier and Type

方法

描述

static SaslClient

Sasl.createSaslClient​(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

使用提供的参数创建一个 SaslClient 。

SaslClient

SaslClientFactory.createSaslClient​(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

使用提供的参数创建SaslClient。

static SaslServer

Sasl.createSaslServer​(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

为指定的机制创建一个 SaslServer 。

SaslServer

SaslServerFactory.createSaslServer​(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

使用提供的参数创建一个 SaslServer 。

Object

SaslClient.getNegotiatedProperty​(String propName)

检索谈判的财产。

Object

SaslServer.getNegotiatedProperty​(String propName)

检索谈判的财产。

void

AuthorizeCallback.setAuthorizedID​(String id)

设置授权实体的ID。

Method parameters in javax.security.sasl with type arguments of type String

Modifier and Type

方法

描述

static SaslClient

Sasl.createSaslClient​(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

使用提供的参数创建 SaslClient 。

SaslClient

SaslClientFactory.createSaslClient​(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

使用提供的参数创建SaslClient。

static SaslServer

Sasl.createSaslServer​(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

为指定的机制创建一个 SaslServer 。

SaslServer

SaslServerFactory.createSaslServer​(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)

使用提供的参数创建一个 SaslServer 。

String[]

SaslClientFactory.getMechanismNames​(Map<String,?> props)

返回与指定的机制选择策略匹配的机制名称数组。

String[]

SaslServerFactory.getMechanismNames​(Map<String,?> props)

返回与指定的机制选择策略匹配的机制名称数组。

Constructors in javax.security.sasl with parameters of type String

Constructor

描述

AuthenticationException​(String detail)

构造一个新的实例 AuthenticationException与详细的消息。

AuthenticationException​(String detail, Throwable ex)

构造一个新的实例 AuthenticationException其中包含详细的消息和根异常。

AuthorizeCallback​(String authnID, String authzID)

构造一个 AuthorizeCallback的实例。

RealmCallback​(String prompt)

构造一个 RealmCallback提示。

RealmCallback​(String prompt, String defaultRealmInfo)

构造一个带有提示和默认领域信息的 RealmCallback 。

RealmChoiceCallback​(String prompt, String[] choices, int defaultChoice, boolean multiple)

构造一个 RealmChoiceCallback ，带有提示，选择列表和默认选项。

SaslException​(String detail)

构造一个新的实例 SaslException与详细的消息。

SaslException​(String detail, Throwable ex)

构造一个新的实例 SaslException其中包含详细的消息和根异常。

Uses of String in javax.smartcardio

Methods in javax.smartcardio that return String

Modifier and Type

方法

描述

String

CardPermission.getActions​()

返回动作的规范字符串表示形式。

static String

TerminalFactory.getDefaultType​()

获取默认的TerminalFactory类型。

abstract String

CardTerminal.getName​()

返回此终端的唯一名称。

abstract String

Card.getProtocol​()

返回此卡使用的协议。

String

TerminalFactory.getType​()

返回此TerminalFactory的类型。

String

ATR.toString​()

返回此ATR的字符串表示形式。

String

CommandAPDU.toString​()

返回此命令APDU的字符串表示形式。

String

ResponseAPDU.toString​()

返回此响应APDU的字符串表示形式。

String

TerminalFactory.toString​()

返回此TerminalFactory的字符串表示形式。

Methods in javax.smartcardio with parameters of type String

Modifier and Type

方法

描述

abstract Card

CardTerminal.connect​(String protocol)

建立与卡的连接。

static TerminalFactory

TerminalFactory.getInstance​(String type, Object params)

返回使用指定参数初始化的指定类型的TerminalFactory。

static TerminalFactory

TerminalFactory.getInstance​(String type, Object params, String provider)

返回使用指定参数初始化的指定类型的TerminalFactory。

static TerminalFactory

TerminalFactory.getInstance​(String type, Object params, Provider provider)

返回使用指定参数初始化的指定类型的TerminalFactory。

CardTerminal

CardTerminals.getTerminal​(String name)

返回具有指定名称的终端，如果不存在此类终端则返回null。

static CardTerminals.State

CardTerminals.State.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javax.smartcardio with parameters of type String

Constructor

描述

CardException​(String message)

构造一个带有指定详细信息的新CardException。

CardException​(String message, Throwable cause)

构造一个具有指定的详细信息和原因的新CardException。

CardNotPresentException​(String message)

构造一个新的具有指定详细消息的CardNotPresentException。

CardNotPresentException​(String message, Throwable cause)

构造一个新的具有指定的详细信息和原因的CardNotPresentException。

CardPermission​(String terminalName, String actions)

构造一个具有指定操作的新CardPermission。

Uses of String in javax.sound.midi

Methods in javax.sound.midi that return String

Modifier and Type

方法

描述

String

MidiDevice.Info.getDescription​()

获取设备的描述。

String

Soundbank.getDescription​()

获取声音库的文字描述，适合显示。

String

MidiDevice.Info.getName​()

获取设备的名称。

String

Soundbank.getName​()

获取声音库的名称。

String

SoundbankResource.getName​()

获取资源的名称。

String

MidiDevice.Info.getVendor​()

获取提供设备的公司的名称。

String

Soundbank.getVendor​()

获得一个 string命名提供声音库的公司。

String

MidiDevice.Info.getVersion​()

获取设备的版本。

String

Soundbank.getVersion​()

获取声音库的版本字符串。

String

MidiDevice.Info.toString​()

提供设备信息的字符串表示。

String

Sequencer.SyncMode.toString​()

提供此同步模式的名称作为模式的字符串表示形式。

Methods in javax.sound.midi that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,Object>

MidiFileFormat.properties​()

获取不可修改的属性地图。

Methods in javax.sound.midi with parameters of type String

Modifier and Type

方法

描述

Object

MidiFileFormat.getProperty​(String key)

获取由密钥指定的属性值。

Constructors in javax.sound.midi with parameters of type String

Constructor

描述

Info​(String name, String vendor, String description, String version)

构造一个设备信息对象。

Instrument​(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)

从指定的 Patch构建一个新的MIDI乐器。

InvalidMidiDataException​(String message)

构造具有指定详细消息的 InvalidMidiDataException 。

MidiUnavailableException​(String message)

构造具有指定详细消息的 MidiUnavailableException 。

SoundbankResource​(Soundbank soundBank, String name, Class<?> dataClass)

从给定的声音库和波表指数构建一个新的 SoundbankResource 。

SyncMode​(String name)

构造同步模式。

Constructor parameters in javax.sound.midi with type arguments of type String

Constructor

描述

MidiFileFormat​(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)

构造一个 MidiFileFormat与一组属性。

Uses of String in javax.sound.sampled

Methods in javax.sound.sampled that return String

Modifier and Type

方法

描述

String

Mixer.Info.getDescription​()

获取混音器的描述。

String

AudioFileFormat.Type.getExtension​()

获取此文件类型的公用文件扩展名。

String

FloatControl.getMaxLabel​()

获取最大值的标签，例如“Right”或“Full”。

String

FloatControl.getMidLabel​()

获取中点值的标签，例如“中心”或“默认”。

String

FloatControl.getMinLabel​()

获取最小值的标签，例如“左”或“关”。

String

Mixer.Info.getName​()

获取混音器的名称。

String

Port.Info.getName​()

获取端口的名称。

String

ReverbType.getName​()

获取此混响类型的名称。

String

BooleanControl.getStateLabel​(boolean state)

获取指定状态的标签。

String

FloatControl.getUnits​()

获取表示控件值的单位的标签，例如“dB”或“每秒帧数”。

String

Mixer.Info.getVendor​()

获得混音器的供应商。

String

Mixer.Info.getVersion​()

获取混音器的版本。

String

AudioFileFormat.toString​()

提供文件格式的字符串表示形式。

String

AudioFileFormat.Type.toString​()

提供文件类型的名称作为文件类型的 String表示。

String

AudioFormat.Encoding.toString​()

提供编码的 String表示。

String

AudioFormat.toString​()

返回描述格式的字符串，如：“PCM SIGNED 22050 Hz 16 bit mono big-endian”。

String

BooleanControl.toString​()

提供控件的字符串表示形式。

String

CompoundControl.toString​()

提供控件的字符串表示形式。

String

Control.toString​()

获取描述控件类型及其当前状态的字符串。

String

Control.Type.toString​()

提供控制类型的 String表示。

String

DataLine.Info.toString​()

获取数据行信息的文本描述。

String

EnumControl.toString​()

提供控件的字符串表示形式。

String

FloatControl.toString​()

提供控件的字符串表示形式。

String

Line.Info.toString​()

获取行信息的文本描述。

String

LineEvent.toString​()

获取事件的字符串表示形式。

String

LineEvent.Type.toString​()

返回类型名称作为字符串表示形式。

String

Mixer.Info.toString​()

提供混音器信息的字符串表示。

String

Port.Info.toString​()

提供端口的 String表示。

String

ReverbType.toString​()

提供混响类型的 String表示，包括其名称及其参数设置。

Methods in javax.sound.sampled that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,Object>

AudioFileFormat.properties​()

获取不可修改的属性地图。

Map<String,Object>

AudioFormat.properties​()

获取不可修改的属性地图。

Methods in javax.sound.sampled with parameters of type String

Modifier and Type

方法

描述

Object

AudioFileFormat.getProperty​(String key)

获取由密钥指定的属性值。

Object

AudioFormat.getProperty​(String key)

获取由密钥指定的属性值。

Constructors in javax.sound.sampled with parameters of type String

Constructor

描述

AudioPermission​(String name)

创建具有指定符号名称的新的 AudioPermission对象，例如“播放”或“记录”。

AudioPermission​(String name, String actions)

创建具有指定符号名称的新的 AudioPermission对象，例如“播放”或“记录”。

BooleanControl​(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel)

使用给定的参数构造一个新的布尔控件对象。

Encoding​(String name)

构造新的编码。

FloatControl​(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units)

使用给定的参数构造一个新的float控件对象。

FloatControl​(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel)

使用给定的参数构造一个新的float控件对象。

Info​(String name, String vendor, String description, String version)

构建混音器的信息对象，传递给定的文本信息。

Info​(Class<?> lineClass, String name, boolean isSource)

根据给出的信息构造端口的信息对象。

LineUnavailableException​(String message)

构造一个具有指定详细消息的 LineUnavailableException 。

ReverbType​(String name, int earlyReflectionDelay, float earlyReflectionIntensity, int lateReflectionDelay, float lateReflectionIntensity, int decayTime)

构造具有指定混响参数值的新混响类型。

Type​(String name, String extension)

构造文件类型。

Type​(String name)

构造一个新的布尔控件类型。

Type​(String name)

构建新的复合控制类型。

Type​(String name)

构造具有指定名称的新控件类型。

Type​(String name)

构造一个新的枚举控件类型。

Type​(String name)

构造一个新的浮动控件类型。

Type​(String name)

构造一个新的事件类型。

UnsupportedAudioFileException​(String message)

构造一个具有指定详细消息的 UnsupportedAudioFileException 。

Constructor parameters in javax.sound.sampled with type arguments of type String

Constructor

描述

AudioFileFormat​(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)

使用一组定义的属性构建音频文件格式对象。

AudioFormat​(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)

构造具有给定参数的 AudioFormat 。

Uses of String in javax.sql

Methods in javax.sql that return String

Modifier and Type

方法

描述

String

RowSet.getCommand​()

检索此 RowSet对象的命令属性。

String

RowSet.getDataSourceName​()

检索标识该 RowSet对象的数据源的逻辑名称。

String

RowSet.getPassword​()

检索用于创建数据库连接的密码。

String

RowSet.getUrl​()

检索url属性这个 RowSet对象将用于创建连接，如果它使用 DriverManager代替的 DataSource对象建立连接。

String

RowSet.getUsername​()

检索用于为此 RowSet对象创建数据库连接的用户名。

Methods in javax.sql that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,Class<?>>

RowSet.getTypeMap​()

检索与此 Map对象关联的 RowSet对象，该对象指定SQL用户定义类型的自定义映射（如果有）。

Methods in javax.sql with parameters of type String

Modifier and Type

方法

描述

Connection

DataSource.getConnection​(String username, String password)

尝试建立与此 DataSource对象所代表的数据源的连接。

PooledConnection

ConnectionPoolDataSource.getPooledConnection​(String user, String password)

尝试建立可用作池连接的物理数据库连接。

XAConnection

XADataSource.getXAConnection​(String user, String password)

尝试使用给定的用户名和密码建立物理数据库连接。

PooledConnectionBuilder

PooledConnectionBuilder.password​(String password)

指定创建连接时要使用的密码

XAConnectionBuilder

XAConnectionBuilder.password​(String password)

指定创建连接时要使用的密码

void

RowSet.setAsciiStream​(String parameterName, InputStream x)

将指定的参数设置为给定的输入流。

void

RowSet.setAsciiStream​(String parameterName, InputStream x, int length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

RowSet.setBigDecimal​(String parameterName, BigDecimal x)

将指定的参数设置为给定的 java.math.BigDecimal值。

void

RowSet.setBinaryStream​(String parameterName, InputStream x)

将指定的参数设置为给定的输入流。

void

RowSet.setBinaryStream​(String parameterName, InputStream x, int length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

RowSet.setBlob​(String parameterName, InputStream inputStream)

将指定的参数设置为 InputStream对象。

void

RowSet.setBlob​(String parameterName, InputStream inputStream, long length)

将指定的参数设置为 InputStream对象。

void

RowSet.setBlob​(String parameterName, Blob x)

将指定的参数设置为给定的 java.sql.Blob对象。

void

RowSet.setBoolean​(String parameterName, boolean x)

将指定的参数设置为给定的Java boolean值。

void

RowSet.setByte​(String parameterName, byte x)

将指定的参数设置为给定的Java byte值。

void

RowSet.setBytes​(String parameterName, byte[] x)

将指定的参数设置为给定的Java字节数组。

void

RowSetMetaData.setCatalogName​(int columnIndex, String catalogName)

将指定列的表的目录名称（如果有）设置为给定的 String 。

void

RowSet.setCharacterStream​(String parameterName, Reader reader)

将指定的参数设置为给定的 Reader对象。

void

RowSet.setCharacterStream​(String parameterName, Reader reader, int length)

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

void

RowSet.setClob​(String parameterName, Reader reader)

将指定的参数设置为 Reader对象。

void

RowSet.setClob​(String parameterName, Reader reader, long length)

将指定的参数设置为 Reader对象。

void

RowSet.setClob​(String parameterName, Clob x)

将指定的参数设置为给定的 java.sql.Clob对象。

void

RowSetMetaData.setColumnLabel​(int columnIndex, String label)

设置建议列标题用于打印输出和显示（如果有）给给定的 String 。

void

RowSetMetaData.setColumnName​(int columnIndex, String columnName)

将指定列的名称设置为给定的 String 。

void

RowSetMetaData.setColumnTypeName​(int columnIndex, String typeName)

将指定列的类型名称（如果有的话）设置为给定的 String 。

void

RowSet.setCommand​(String cmd)

将此 RowSet对象的命令属性设置为给定的SQL查询。

void

RowSet.setDataSourceName​(String name)

将此 RowSet对象的数据源名称属性设置为给定的 String 。

void

RowSet.setDate​(String parameterName, Date x)

使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。

void

RowSet.setDate​(String parameterName, Date x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

void

RowSet.setDouble​(String parameterName, double x)

将指定的参数设置为给定的Java double值。

void

RowSet.setFloat​(String parameterName, float x)

将指定的参数设置为给定的Java float值。

void

RowSet.setInt​(String parameterName, int x)

将指定的参数设置为给定的Java int值。

void

RowSet.setLong​(String parameterName, long x)

将指定的参数设置为给定的Java long值。

void

RowSet.setNCharacterStream​(String parameterName, Reader value)

将指定的参数设置为 Reader对象。

void

RowSet.setNCharacterStream​(String parameterName, Reader value, long length)

将指定的参数设置为 Reader对象。

void

RowSet.setNClob​(String parameterName, Reader reader)

将指定的参数设置为 Reader对象。

void

RowSet.setNClob​(String parameterName, Reader reader, long length)

将指定的参数设置为 Reader对象。

void

RowSet.setNClob​(String parameterName, NClob value)

将指定的参数设置为 java.sql.NClob对象。

void

RowSet.setNString​(int parameterIndex, String value)

将指定的参数设置为给定的 String对象。

void

RowSet.setNString​(String parameterName, String value)

将指定的参数设置为给定的 String对象。

void

RowSet.setNull​(int paramIndex, int sqlType, String typeName)

将此 RowSet对象的SQL命令中的指定参数设置为SQL NULL 。

void

RowSet.setNull​(String parameterName, int sqlType)

将指定的参数设置为SQL NULL 。

void

RowSet.setNull​(String parameterName, int sqlType, String typeName)

将指定的参数设置为SQL NULL 。

void

RowSet.setObject​(String parameterName, Object x)

使用给定对象设置指定参数的值。

void

RowSet.setObject​(String parameterName, Object x, int targetSqlType)

使用给定对象设置指定参数的值。

void

RowSet.setObject​(String parameterName, Object x, int targetSqlType, int scale)

使用给定对象设置指定参数的值。

void

RowSet.setPassword​(String password)

将此 RowSet对象的数据库密码设置为给定的 String 。

void

RowSet.setRowId​(String parameterName, RowId x)

将指定的参数设置为给定的 java.sql.RowId对象。

void

RowSetMetaData.setSchemaName​(int columnIndex, String schemaName)

将指定列的表的模式（如果有）的名称设置为给定的 String 。

void

RowSet.setShort​(String parameterName, short x)

将指定的参数设置为给定的Java short值。

void

RowSet.setSQLXML​(String parameterName, SQLXML xmlObject)

将指定的参数设置为给定的 java.sql.SQLXML对象。

void

RowSet.setString​(int parameterIndex, String x)

将此 RowSet对象的命令中的指定参数设置为给定的Java String值。

void

RowSet.setString​(String parameterName, String x)

将指定的参数设置为给定的Java String值。

void

RowSetMetaData.setTableName​(int columnIndex, String tableName)

将指定列的表名称（如果有）设置为给定的 String 。

void

RowSet.setTime​(String parameterName, Time x)

将指定的参数设置为给定的 java.sql.Time值。

void

RowSet.setTime​(String parameterName, Time x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。

void

RowSet.setTimestamp​(String parameterName, Timestamp x)

将指定的参数设置为给定的 java.sql.Timestamp值。

void

RowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

void

RowSet.setUrl​(String url)

设置 RowSet对象在使用 DriverManager创建连接时将使用的URL。

void

RowSet.setUsername​(String name)

将此 RowSet对象的用户名属性设置为给定的 String 。

PooledConnectionBuilder

PooledConnectionBuilder.user​(String username)

指定创建连接时要使用的用户名

XAConnectionBuilder

XAConnectionBuilder.user​(String username)

指定创建连接时要使用的用户名

Method parameters in javax.sql with type arguments of type String

Modifier and Type

方法

描述

void

RowSet.setTypeMap​(Map<String,Class<?>> map)

安装给定 java.util.Map对象的默认类型映射此 RowSet对象。

Uses of String in javax.sql.rowset

Fields in javax.sql.rowset declared as String

Modifier and Type

Field

描述

static String

WebRowSet.PUBLIC_XML_SCHEMA

定义XML标签的XML模式定义的公共标识符及其对于 WebRowSet实现的 WebRowSet 。

static String

WebRowSet.SCHEMA_SYSTEM_ID

定义XML标签的XML Schema定义文件的URL及其对于 WebRowSet实现的 WebRowSet 。

Methods in javax.sql.rowset that return String

Modifier and Type

方法

描述

String

RowSetMetaDataImpl.getCatalogName​(int columnIndex)

检索从中导出指定列中的值的表的目录名称。

String

RowSetMetaDataImpl.getColumnClassName​(int columnIndex)

以指定列中的值映射到的Java编程语言中的类的全限定名称。

String

RowSetMetaDataImpl.getColumnLabel​(int columnIndex)

检索指定列的建议列标题，以用于打印输出和显示。

String

RowSetMetaDataImpl.getColumnName​(int columnIndex)

检索指定列的名称。

String

RowSetMetaDataImpl.getColumnTypeName​(int columnIndex)

检索存储在指定列中的值的DBMS特定类型名称。

String

BaseRowSet.getCommand​()

检索作为此 RowSet对象的命令的SQL查询。

String

BaseRowSet.getDataSourceName​()

返回当提供给使用Java命名和目录接口（JNDI）API的命名服务时，将检索 javax.sql.DataSource对象的逻辑名称。

String[]

Joinable.getMatchColumnNames​()

使用方法 setMatchColumn(String [] columnNames)检索为此 RowSet对象设置的匹配列的名称。

String

BaseRowSet.getPassword​()

返回用于为此 RowSet对象创建数据库连接的密码。

String[]

JoinRowSet.getRowSetNames​()

返回一个 String数组，其中包含添加到此 JoinRowSet对象的 RowSet对象的名称。

String

RowSetMetaDataImpl.getSchemaName​(int columnIndex)

检索从中导出指定列中的值的表的模式名称。

String

CachedRowSet.getTableName​()

返回用于创建此 CachedRowSet对象的对象（表）的标识符。

String

RowSetMetaDataImpl.getTableName​(int columnIndex)

检索从中导出指定列中的值的表的名称。

String

BaseRowSet.getUrl​()

检索JDBC URL，这 RowSet对象的 javax.sql.Reader对象用来建立与使用JDBC技术的驱动程序一个关系数据库的连接。

String

BaseRowSet.getUsername​()

返回用于创建数据库连接的用户名。

String

JoinRowSet.getWhereClause​()

返回在JoinRowSet对象中使用的WHERE子句的类似SQL的描述。

Methods in javax.sql.rowset that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,Class<?>>

BaseRowSet.getTypeMap​()

检索与该关联的类型映射 Connection对象此 RowSet对象。

Methods in javax.sql.rowset with parameters of type String

Modifier and Type

方法

描述

void

JoinRowSet.addRowSet​(RowSet[] rowset, String[] columnName)

将一个或多个 RowSet包含的给定阵列中的对象 RowSet对象此 JoinRowSet对象，并为每一个的匹配列 RowSet对象列名的给定阵列中的匹配列。

void

JoinRowSet.addRowSet​(RowSet rowset, String columnName)

将 rowset添加到此 JoinRowSet对象，并将指定的列设置为匹配列。

boolean

CachedRowSet.columnUpdated​(String columnName)

指示此 CachedRowSet对象的当前行中的指定列是否已更新。

boolean

Predicate.evaluate​(Object value, String columnName)

该方法由 FilteredRowSet对象调用，以检查该值是否在使用setFilter方法设置的过滤条件之间。

static RowSetFactory

RowSetProvider.newFactory​(String factoryClassName, ClassLoader cl)

从指定的工厂类名称创建一个新的实例 RowSetFactory 。

void

BaseRowSet.setAsciiStream​(String parameterName, InputStream x)

将指定的参数设置为给定的输入流。

void

BaseRowSet.setAsciiStream​(String parameterName, InputStream x, int length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

BaseRowSet.setBigDecimal​(String parameterName, BigDecimal x)

将指定的参数设置为给定的 java.math.BigDecimal值。

void

BaseRowSet.setBinaryStream​(String parameterName, InputStream x)

将指定的参数设置为给定的输入流。

void

BaseRowSet.setBinaryStream​(String parameterName, InputStream x, int length)

将指定的参数设置为给定的输入流，它将具有指定的字节数。

void

BaseRowSet.setBlob​(String parameterName, InputStream inputStream)

将指定的参数设置为 InputStream对象。

void

BaseRowSet.setBlob​(String parameterName, InputStream inputStream, long length)

将指定的参数设置为 InputStream对象。

void

BaseRowSet.setBlob​(String parameterName, Blob x)

将指定的参数设置为给定的 java.sql.Blob对象。

void

BaseRowSet.setBoolean​(String parameterName, boolean x)

将指定的参数设置为给定的Java boolean值。

void

BaseRowSet.setByte​(String parameterName, byte x)

将指定的参数设置为给定的Java byte值。

void

BaseRowSet.setBytes​(String parameterName, byte[] x)

将指定的参数设置为给定的Java字节数组。

void

RowSetMetaDataImpl.setCatalogName​(int columnIndex, String catalogName)

将派生指定列的表的目录名称设置为 catalogName 。

void

BaseRowSet.setCharacterStream​(String parameterName, Reader reader)

将指定的参数设置为给定的 Reader对象。

void

BaseRowSet.setCharacterStream​(String parameterName, Reader reader, int length)

将指定的参数设置为给定的 Reader对象，这是给定的长度的字符数。

void

BaseRowSet.setClob​(String parameterName, Reader reader)

将指定的参数设置为 Reader对象。

void

BaseRowSet.setClob​(String parameterName, Reader reader, long length)

将指定的参数设置为 Reader对象。

void

BaseRowSet.setClob​(String parameterName, Clob x)

将指定的参数设置为给定的 java.sql.Clob对象。

void

RowSetMetaDataImpl.setColumnLabel​(int columnIndex, String label)

设置建议的列标签，用于打印输出和显示（如果有） 标签 。

void

RowSetMetaDataImpl.setColumnName​(int columnIndex, String columnName)

将指定列的列名称设置为给定的名称。

void

RowSetMetaDataImpl.setColumnTypeName​(int columnIndex, String typeName)

将存储在指定列中的值的数据源使用的类型名称设置为给定的类型名称。

void

BaseRowSet.setCommand​(String cmd)

将此 RowSet对象的 command属性设置为给定的 String对象，并清除为先前命令设置的参数（如果有）。

void

BaseRowSet.setDataSourceName​(String name)

设置 DataSource名称属性此 RowSet对象给定的逻辑名，并将此 RowSet对象的Url属性设置为 null 。

void

BaseRowSet.setDate​(String parameterName, Date x)

使用运行应用程序的虚拟机的默认时区将指定的参数设置为给定的 java.sql.Date值。

void

BaseRowSet.setDate​(String parameterName, Date x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Date值。

void

BaseRowSet.setDouble​(String parameterName, double x)

将指定的参数设置为给定的Java double值。

void

BaseRowSet.setFloat​(String parameterName, float x)

将指定的参数设置为给定的Java float值。

void

BaseRowSet.setInt​(String parameterName, int x)

将指定的参数设置为给定的Java int值。

void

BaseRowSet.setLong​(String parameterName, long x)

将指定的参数设置为给定的Java long值。

void

Joinable.setMatchColumn​(String columnName)

将指定列设置为此 RowSet对象的匹配列。

void

Joinable.setMatchColumn​(String[] columnNames)

将指定的列设置为此 RowSet对象的匹配列。

void

BaseRowSet.setNCharacterStream​(String parameterName, Reader value)

将指定的参数设置为 Reader对象。

void

BaseRowSet.setNCharacterStream​(String parameterName, Reader value, long length)

将指定的参数设置为 Reader对象。

void

BaseRowSet.setNClob​(String parameterName, Reader reader)

将指定的参数设置为 Reader对象。

void

BaseRowSet.setNClob​(String parameterName, Reader reader, long length)

将指定的参数设置为 Reader对象。

void

BaseRowSet.setNClob​(String parameterName, NClob value)

将指定的参数设置为 java.sql.NClob对象。

void

BaseRowSet.setNString​(int parameterIndex, String value)

将指定的参数设置为给定的 String对象。

void

BaseRowSet.setNString​(String parameterName, String value)

将指定的参数设置为给定的 String对象。

void

BaseRowSet.setNull​(int parameterIndex, int sqlType, String typeName)

将指定的参数设置为SQL NULL 。

void

BaseRowSet.setNull​(String parameterName, int sqlType)

将指定的参数设置为SQL NULL 。

void

BaseRowSet.setNull​(String parameterName, int sqlType, String typeName)

将指定的参数设置为SQL NULL 。

void

BaseRowSet.setObject​(String parameterName, Object x)

使用给定对象设置指定参数的值。

void

BaseRowSet.setObject​(String parameterName, Object x, int targetSqlType)

使用给定对象设置指定参数的值。

void

BaseRowSet.setObject​(String parameterName, Object x, int targetSqlType, int scale)

使用给定对象设置指定参数的值。

void

BaseRowSet.setPassword​(String pass)

设置用于为此 RowSet对象创建与给定的 String对象的数据库连接的密码。

void

BaseRowSet.setRowId​(String parameterName, RowId x)

将指定的参数设置为给定的 java.sql.RowId对象。

void

RowSetMetaDataImpl.setSchemaName​(int columnIndex, String schemaName)

将指定列的表的模式名称（如果有）设置为 schemaName 。

void

BaseRowSet.setShort​(String parameterName, short x)

将指定的参数设置为给定的Java short值。

void

BaseRowSet.setSQLXML​(String parameterName, SQLXML xmlObject)

将指定的参数设置为给定的 java.sql.SQLXML对象。

void

BaseRowSet.setString​(int parameterIndex, String x)

将指定的参数设置为给定的 String值。

void

BaseRowSet.setString​(String parameterName, String x)

将指定的参数设置为给定的Java String值。

void

CachedRowSet.setSyncProvider​(String provider)

设置 SyncProvider此对象 CachedRowSet对象到指定的一个。

void

CachedRowSet.setTableName​(String tabName)

设置派生这个 CachedRowSet对象的表的标识符给给定的表名。

void

RowSetMetaDataImpl.setTableName​(int columnIndex, String tableName)

将派生指定列的表的名称设置为给定的表名。

void

BaseRowSet.setTime​(String parameterName, Time x)

将指定的参数设置为给定的 java.sql.Time值。

void

BaseRowSet.setTime​(String parameterName, Time x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Time值。

void

BaseRowSet.setTimestamp​(String parameterName, Timestamp x)

将指定的参数设置为给定的 java.sql.Timestamp值。

void

BaseRowSet.setTimestamp​(String parameterName, Timestamp x, Calendar cal)

使用给定的 Calendar对象将指定的参数设置为给定的 java.sql.Timestamp值。

void

BaseRowSet.setUrl​(String url)

将此 RowSet对象的Url属性设置为给定的 String对象，并将dataSource名称属性设置为 null 。

void

BaseRowSet.setUsername​(String name)

将此 RowSet对象的用户名属性设置为给定的用户名。

Collection<?>

CachedRowSet.toCollection​(String column)

将此 CachedRowSet对象中的指定列转换为 Collection对象。

void

Joinable.unsetMatchColumn​(String columnName)

将指定的列 RowSet为该 RowSet对象的匹配列。

void

Joinable.unsetMatchColumn​(String[] columnName)

将指定的列 RowSet为该 RowSet对象的匹配列。

Method parameters in javax.sql.rowset with type arguments of type String

Modifier and Type

方法

描述

void

BaseRowSet.setTypeMap​(Map<String,Class<?>> map)

安装给定 java.util.Map对象作为与相关联的类型映射 Connection对象此 RowSet对象。

Constructors in javax.sql.rowset with parameters of type String

Constructor

描述

RowSetWarning​(String reason)

构造一个具有给定值的RowSetWarning对象的原因; SQLState默认为null，vendorCode默认为0。

RowSetWarning​(String reason, String SQLState)

构造一个 RowSetWarning对象，该对象由于原因和SQLState由给定值初始化。

RowSetWarning​(String reason, String SQLState, int vendorCode)

构造一个完全指定的 RowSetWarning对象，该对象使用给定值初始化，原因为SQLState和vendorCode。

Uses of String in javax.sql.rowset.serial

Methods in javax.sql.rowset.serial that return String

Modifier and Type

方法

描述

String

SerialArray.getBaseTypeName​()

检索此 SerialArray对象中元素的DBMS特定类型名称。

String

SerialRef.getBaseTypeName​()

返回描述 Ref的基本类型名称的 Ref 。

String

SerialStruct.getSQLTypeName​()

检索此 SerialStruct对象的SQL类型名称。

String

SerialClob.getSubString​(long pos, int length)

返回此 SerialClob对象中包含的子字符串的副本，从给定位置开始，并继续指定的数字或字符。

String

SQLInputImpl.readNString​()

读取流中的下一个属性，并将其作为Java编程语言中的 String返回。

String

SQLInputImpl.readString​()

获取此的下一个属性 SQLInputImpl对象为 String的Java编程语言。

Methods in javax.sql.rowset.serial with parameters of type String

Modifier and Type

方法

描述

long

SerialClob.position​(String searchStr, long start)

返回此 SerialClob对象中的位置，给定的 String对象开始，开始在指定位置的搜索。

int

SerialClob.setString​(long pos, String str)

将给定的Java String写入 SerialClob对象表示的 CLOB值，位置 pos 。

int

SerialClob.setString​(long pos, String str, int offset, int length)

写 len字符为 str ，从字符 offset开始，以 Clob表示的 CLOB值。

void

SQLOutputImpl.writeNString​(String x)

将下一个属性作为Java编程语言中的一个 String写入流。

void

SQLOutputImpl.writeString​(String x)

将Java编程语言中的 String写入此 SQLOutputImpl对象。

Method parameters in javax.sql.rowset.serial with type arguments of type String

Modifier and Type

方法

描述

Object

SerialArray.getArray​(long index, int count, Map<String,Class<?>> map)

返回一个新的数组，它是 SerialArray对象的一个slice的副本，从给定索引的元素开始，并包含给定数量的连续元素。

Object

SerialArray.getArray​(Map<String,Class<?>> map)

返回一个新数组，该数组是 SerialArray对象的副本，当元素为SQL UDT时，使用给定的类型映射来定制每个元素的映射。

Object[]

SerialStruct.getAttributes​(Map<String,Class<?>> map)

检索此 SerialStruct表示为 Object值的数组的SQL结构类型的属性，如果合适，则使用给定类型映射进行自定义映射。

Object

SerialRef.getObject​(Map<String,Class<?>> map)

返回 Object表示对此的SQL结构类型 SerialRef对象引用。

ResultSet

SerialArray.getResultSet​(long index, int count, Map<String,Class<?>> map)

检索设置保持其开始于检索所述子阵列的元素的结果 ResultSet对象，其中包含在该元件的子阵列 SerialArray对象，开始于索引 指数和包含 count个连续元素。

ResultSet

SerialArray.getResultSet​(Map<String,Class<?>> map)

检索 ResultSet对象，其中包含由该 SerialArray对象表示的SQL ARRAY值的所有元素。

Constructors in javax.sql.rowset.serial with parameters of type String

Constructor

描述

SerialException​(String msg)

使用指定的消息创建一个新的 SerialException 。

Constructor parameters in javax.sql.rowset.serial with type arguments of type String

Constructor

描述

SerialArray​(Array array, Map<String,Class<?>> map)

从给定的 Array对象构造一个新的 SerialArray对象，当元素为SQL UDT时，使用给定的类型映射来定制每个元素的映射。

SerialStruct​(SQLData in, Map<String,Class<?>> map)

从给定的 SQLData对象构造一个 SerialStruct对象，使用给定的类型映射将其定制到Java编程语言中的类。

SerialStruct​(Struct in, Map<String,Class<?>> map)

从给定的 Struct对象构造一个 SerialStruct对象，使用给定的 java.util.Map对象自定义映射SQL结构类型或其任何属性，这些属性是SQL结构化类型。

SQLInputImpl​(Object[] attributes, Map<String,Class<?>> map)

创建一个 SQLInputImpl对象，该对象使用给定的属性数组和给定的类型映射进行初始化。

SQLOutputImpl​(Vector<?> attributes, Map<String,?> map)

创建一个新的 SQLOutputImpl对象，使用给定的属性向量进行初始化，并输入map。

Uses of String in javax.sql.rowset.spi

Fields in javax.sql.rowset.spi declared as String

Modifier and Type

Field

描述

static String

SyncFactory.ROWSET_SYNC_PROVIDER

同步提供程序实现名称的标准属性ID。

static String

SyncFactory.ROWSET_SYNC_PROVIDER_VERSION

同步提供程序实现版本标记的标准属性ID。

static String

SyncFactory.ROWSET_SYNC_VENDOR

同步提供程序实现供应商名称的标准属性ID。

Methods in javax.sql.rowset.spi that return String

Modifier and Type

方法

描述

abstract String

SyncProvider.getProviderID​()

返回此 SyncProvider对象的唯一标识符。

abstract String

SyncProvider.getVendor​()

返回此 SyncProvider实例的供应商名称

abstract String

SyncProvider.getVersion​()

返回此 SyncProvider实例的发行版本。

Methods in javax.sql.rowset.spi with parameters of type String

Modifier and Type

方法

描述

Object

SyncResolver.getConflictValue​(String columnName)

检索此 SyncResolver对象的当前行中指定列中的值，该值是导致冲突的数据源中的值。

static SyncProvider

SyncFactory.getInstance​(String providerID)

返回由 providerID标识的 SyncProvider实例。

static void

SyncFactory.registerProvider​(String providerID)

将给定的同步提供程序添加到工厂注册表。

void

SyncResolver.setResolvedValue​(String columnName, Object obj)

将 obj设置为正在同步的 RowSet对象的当前行中的列 columnName中的值。

static void

SyncFactory.unregisterProvider​(String providerID)

从工厂SPI寄存器中删除指定的当前注册的同步提供程序。

Constructors in javax.sql.rowset.spi with parameters of type String

Constructor

描述

SyncFactoryException​(String msg)

构造具有指定详细消息的 SyncFactoryException 。

SyncProviderException​(String msg)

构造具有指定详细消息的 SyncProviderException对象。

Uses of String in javax.swing

Fields in javax.swing declared as String

Modifier and Type

Field

描述

static String

Action.ACCELERATOR_KEY

用于存储 KeyStroke作为加速器的动作的键。

static String

JFileChooser.ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY

标识是否使用AcceptAllFileFilter。

static String

JFileChooser.ACCESSORY_CHANGED_PROPERTY

说使用不同的附件组件（例如，预览文件）。

static String

Action.ACTION_COMMAND_KEY

用于确定该命令的键 String为 ActionEvent将当被创建 Action将被通知作为驻留在的结果 Keymap与相关联 JComponent 。

protected String

DefaultButtonModel.actionCommand

按钮触发的动作命令字符串。

protected String

JComboBox.actionCommand

此保护字段是实现特定的。

static String

JTree.ANCHOR_SELECTION_PATH_PROPERTY

锚点选择路径的绑定属性名称。

static String

JFileChooser.APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY

识别助记符的更改（yes，ok）按钮。

static String

JFileChooser.APPROVE_BUTTON_TEXT_CHANGED_PROPERTY

标识批准文本的更改（是，确定）按钮。

static String

JFileChooser.APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY

标识批准（是，确定）按钮的工具提示文本中的更改。

static String

JFileChooser.APPROVE_SELECTION

批准当前选择的指令（与按yes或ok相同）。

static String

SpringLayout.BASELINE

指定组件的基线。

static String

AbstractButton.BORDER_PAINTED_CHANGED_PROPERTY

标识绘制边框或不绘制边框的更改。

static String

JCheckBox.BORDER_PAINTED_FLAT_CHANGED_PROPERTY

标识对平面属性的更改。

static String

JSplitPane.BOTTOM

用来添加 Component其他下方 Component 。

static String

JFileChooser.CANCEL_SELECTION

取消当前选择的指令。

static String

JTree.CELL_EDITOR_PROPERTY

绑定属性名称为 cellEditor 。

static String

JTree.CELL_RENDERER_PROPERTY

绑定属性名称为 cellRenderer 。

static String

JFileChooser.CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY

标识用户可以选择的预定义文件过滤器列表中的更改。

static String

JColorChooser.CHOOSER_PANELS_PROPERTY

chooserPanel数组属性名称。

static String

ScrollPaneConstants.COLUMN_HEADER

标识左上角和右上角之间的视口顶部的区域。

static String

AbstractButton.CONTENT_AREA_FILLED_CHANGED_PROPERTY

标识使按钮绘制内容区域的更改。

static String

JInternalFrame.CONTENT_PANE_PROPERTY

绑定属性名称。

static String

JSplitPane.CONTINUOUS_LAYOUT_PROPERTY

continuousLayout的绑定属性名称。

static String

JFileChooser.CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY

指示显示控制按钮。

static String

Action.DEFAULT

目前不使用

static String

JFileChooser.DIALOG_TITLE_CHANGED_PROPERTY

标识对话标题中的更改。

static String

JFileChooser.DIALOG_TYPE_CHANGED_PROPERTY

标识显示文件类型的变化（仅文件，仅目录，或文件和目录）。

static String

JFileChooser.DIRECTORY_CHANGED_PROPERTY

标识用户的目录更改。

static String

AbstractButton.DISABLED_ICON_CHANGED_PROPERTY

标识当按钮被禁用时使用的图标的更改。

static String

AbstractButton.DISABLED_SELECTED_ICON_CHANGED_PROPERTY

标识当按钮被禁用并选择时使用的图标的更改。

static String

Action.DISPLAYED_MNEMONIC_INDEX_KEY

用于存储的密钥 Integer对应于在文本（由所识别的索引 NAME属性），对于一个助记符的装饰应在被渲染。

static String

JSplitPane.DIVIDER

用于添加将代表分隔符的 Component 。

static String

JSplitPane.DIVIDER_LOCATION_PROPERTY

dividerLocation的绑定属性。

static String

JSplitPane.DIVIDER_SIZE_PROPERTY

边界的绑定属性名称。

static String

SpringLayout.EAST

指定组件的边界矩形的右边缘。

static String

JTree.EDITABLE_PROPERTY

绑定属性名称为 editable 。

static String

JTree.EXPANDS_SELECTED_PATHS_PROPERTY

用于展开所选路径属性的绑定属性名称

static String

JFileChooser.FILE_FILTER_CHANGED_PROPERTY

用户更改了要显示的文件种类。

static String

JFileChooser.FILE_HIDING_CHANGED_PROPERTY

标识显示隐藏文件属性的更改。

static String

JFileChooser.FILE_SELECTION_MODE_CHANGED_PROPERTY

识别选择类型的变化（单个，多个等）。

static String

JFileChooser.FILE_SYSTEM_VIEW_CHANGED_PROPERTY

说使用不同的对象来查找系统上可用的驱动器。

static String

JFileChooser.FILE_VIEW_CHANGED_PROPERTY

说使用不同的对象来检索文件信息。

static String

FocusManager.FOCUS_MANAGER_CLASS_PROPERTY

该字段已过时，因为其规范与1.4焦点API不兼容，因此不鼓励使用该字段。

static String

AbstractButton.FOCUS_PAINTED_CHANGED_PROPERTY

标识在聚焦时突出显示边框的更改。

static String

JInternalFrame.FRAME_ICON_PROPERTY

绑定属性名称。

static String

JInternalFrame.GLASS_PANE_PROPERTY

绑定属性名称。

static String

SpringLayout.HEIGHT

指定组件的边界矩形的高度。

static String

JEditorPane.HONOR_DISPLAY_PROPERTIES

客户端属性的键用于指示如果在样式文本中未指定字体或前景颜色，则会使用来自组件的默认字体和前景颜色。

static String

AbstractButton.HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY

标识按钮的水平对齐方式的变化。

static String

SpringLayout.HORIZONTAL_CENTER

指定组件边界矩形的水平中心。

static String

ScrollPaneConstants.HORIZONTAL_SCROLLBAR

标识一个水平滚动条。

static String

ScrollPaneConstants.HORIZONTAL_SCROLLBAR_POLICY

标识水平滚动条策略属性。

static String

AbstractButton.HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY

标识按钮的水平文本位置的变化。

static String

AbstractButton.ICON_CHANGED_PROPERTY

标识代表该按钮的图标的更改。

static String

JOptionPane.ICON_PROPERTY

绑定属性名称为 icon 。

static String

JOptionPane.INITIAL_SELECTION_VALUE_PROPERTY

绑定属性名称为 initialSelectionValue 。

static String

JOptionPane.INITIAL_VALUE_PROPERTY

绑定属性名称为 initialValue 。

static String

JOptionPane.INPUT_VALUE_PROPERTY

绑定属性名称为 inputValue 。

static String

JTree.INVOKES_STOP_CELL_EDITING_PROPERTY

绑定属性名称为 messagesStopCellEditing 。

static String

JInternalFrame.IS_CLOSED_PROPERTY

内部框架关闭的约束属性名称。

static String

JInternalFrame.IS_ICON_PROPERTY

指示内部框架被图标化的约束属性名称。

static String

JInternalFrame.IS_MAXIMUM_PROPERTY

指示内部框架最大化的约束属性名称。

static String

JInternalFrame.IS_SELECTED_PROPERTY

受限属性名称表示此框已选择状态。

static String

Action.LARGE_ICON_KEY

用于存储 Icon的密钥。

static String

JTree.LARGE_MODEL_PROPERTY

绑定属性名称为 largeModel 。

static String

JSplitPane.LAST_DIVIDER_LOCATION_PROPERTY

最后位置的绑定属性。

static String

JLayeredPane.LAYER_PROPERTY

绑定财产

static String

JInternalFrame.LAYERED_PANE_PROPERTY

绑定属性名称。

static String

JTree.LEAD_SELECTION_PATH_PROPERTY

绑定属性名称为 leadSelectionPath 。

static String

JSplitPane.LEFT

用于将添加 Component其他左侧 Component 。

static String

Action.LONG_DESCRIPTION

用于存储更长的 String描述的关键字可用于上下文相关帮助。

static String

ScrollPaneConstants.LOWER_LEADING_CORNER

标识视口的下前缘角。

static String

ScrollPaneConstants.LOWER_LEFT_CORNER

标识视口的左下角。

static String

ScrollPaneConstants.LOWER_RIGHT_CORNER

标识视口右下角。

static String

ScrollPaneConstants.LOWER_TRAILING_CORNER

标识视口的较低后缘角。

static String

AbstractButton.MARGIN_CHANGED_PROPERTY

标识按钮边距的变化。

static String

JInternalFrame.MENU_BAR_PROPERTY

绑定属性名称。

static String

JOptionPane.MESSAGE_PROPERTY

绑定属性名称为 message 。

static String

JOptionPane.MESSAGE_TYPE_PROPERTY

绑定属性名称为 type 。

static String

AbstractButton.MNEMONIC_CHANGED_PROPERTY

标识按钮的助记符的更改。

static String

Action.MNEMONIC_KEY

用于存储的密钥 Integer对应于所述的一个 KeyEvent键码。

static String

AbstractButton.MODEL_CHANGED_PROPERTY

标识按钮模型的变化。

static String

JFileChooser.MULTI_SELECTION_ENABLED_CHANGED_PROPERTY

启用多文件选择。

static String

Action.NAME

用于存储用于操作的 String名称的键，用于菜单或按钮。

static String

SpringLayout.NORTH

指定组件的边界矩形的顶边。

static String

JTextField.notifyAction

要发送通知的操作的名称，该字段的内容已被接受。

static String

JSplitPane.ONE_TOUCH_EXPANDABLE_PROPERTY

1TouchExpandable的绑定属性。

static String

JOptionPane.OPTION_TYPE_PROPERTY

绑定属性名称为 optionType 。

static String

JOptionPane.OPTIONS_PROPERTY

绑定属性名称为 option 。

static String

JSplitPane.ORIENTATION_PROPERTY

方向（水平或垂直）的绑定属性名称。

static String

AbstractButton.PRESSED_ICON_CHANGED_PROPERTY

标识按下按钮时使用的图标的更改。

static String

JColorChooser.PREVIEW_PANEL_PROPERTY

预览面板属性名称。

protected String

JProgressBar.progressString

可以在进度条上显示的可选字符串。

static String

JSplitPane.RESIZE_WEIGHT_PROPERTY

重量限制属性。

static String

JSplitPane.RIGHT

用于将添加 Component其他权 Component 。

static String

AbstractButton.ROLLOVER_ENABLED_CHANGED_PROPERTY

标识从翻转启用的禁用或恢复启用的更改。

static String

AbstractButton.ROLLOVER_ICON_CHANGED_PROPERTY

标识当光标在按钮上方使用的图标的更改。

static String

AbstractButton.ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY

标识当光标在按钮上方并且已被选择时使用的图标的更改。

static String

JInternalFrame.ROOT_PANE_PROPERTY

绑定属性名称。

static String

JTree.ROOT_VISIBLE_PROPERTY

绑定属性名称为 rootVisible 。

static String

ScrollPaneConstants.ROW_HEADER

识别左上角和左下角之间的视口左侧的区域。

static String

JTree.ROW_HEIGHT_PROPERTY

绑定属性名称为 rowHeight 。

static String

JTree.SCROLLS_ON_EXPAND_PROPERTY

绑定属性名称为 scrollsOnExpand 。

static String

JFileChooser.SELECTED_FILE_CHANGED_PROPERTY

标识用户单文件选择的变化。

static String

JFileChooser.SELECTED_FILES_CHANGED_PROPERTY

标识用户多文件选择的变化。

static String

AbstractButton.SELECTED_ICON_CHANGED_PROPERTY

标识在选择按钮时使用的图标的更改。

static String

Action.SELECTED_KEY

用于存储对应于所选状态的 Boolean的密钥。

static String

JColorChooser.SELECTION_MODEL_PROPERTY

选择模型属性名称。

static String

JTree.SELECTION_MODEL_PROPERTY

选择模型的绑定属性名称。

static String

JOptionPane.SELECTION_VALUES_PROPERTY

绑定属性名称为 selectionValues 。

static String

Action.SHORT_DESCRIPTION

用于存储一个短的关键 String描述的动作中，用于工具提示文本。

static String

JTree.SHOWS_ROOT_HANDLES_PROPERTY

绑定属性名称为 showsRootHandles 。

static String

Action.SMALL_ICON

密钥用于存储一个小的 Icon ，如 ImageIcon 。

static String

SpringLayout.SOUTH

指定组件边界矩形的下边缘。

static String

AbstractButton.TEXT_CHANGED_PROPERTY

标识按钮文本中的更改。

protected String

JInternalFrame.title

标题显示在此内部框架的标题栏中。

static String

JInternalFrame.TITLE_PROPERTY

绑定属性名称。

static String

JTree.TOGGLE_CLICK_COUNT_PROPERTY

绑定属性名称为 toggleClickCount 。

static String

JComponent.TOOL_TIP_TEXT_KEY

当光标在组件上方时显示的注释，也称为“值提示”，“天桥帮助”或“飞越标签”。

static String

JSplitPane.TOP

用于添加 Component以上其他 Component 。

static String

JTree.TREE_MODEL_PROPERTY

绑定属性名称为 treeModel 。

static String

ScrollPaneConstants.UPPER_LEADING_CORNER

标识视口的上前缘角。

static String

ScrollPaneConstants.UPPER_LEFT_CORNER

标识视口的左上角。

static String

ScrollPaneConstants.UPPER_RIGHT_CORNER

标识视口右上角。

static String

ScrollPaneConstants.UPPER_TRAILING_CORNER

标识视口的上后缘角。

static String

JOptionPane.VALUE_PROPERTY

绑定属性名称为 value 。

static String

AbstractButton.VERTICAL_ALIGNMENT_CHANGED_PROPERTY

标识按钮垂直对齐方式的变化。

static String

SpringLayout.VERTICAL_CENTER

指定组件的边界矩形的垂直中心。

static String

ScrollPaneConstants.VERTICAL_SCROLLBAR

标识垂直滚动条。

static String

ScrollPaneConstants.VERTICAL_SCROLLBAR_POLICY

标识垂直滚动条策略属性。

static String

AbstractButton.VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

标识按钮垂直文本位置的变化。

static String

ScrollPaneConstants.VIEWPORT

标识“视口”或显示区域，滚动内容可以在其中显示。

static String

JTree.VISIBLE_ROW_COUNT_PROPERTY

绑定属性名称为 visibleRowCount 。

static String

JEditorPane.W3C_LENGTH_UNITS

用于指示是否将 w3c compliant长度单位用于html呈现的客户端属性的键。

static String

JOptionPane.WANTS_INPUT_PROPERTY

绑定属性名称为 wantsInput 。

static String

SpringLayout.WEST

指定组件的边界矩形的左边缘。

static String

SpringLayout.WIDTH

指定组件边界矩形的宽度。

Methods in javax.swing that return String

Modifier and Type

方法

描述

String

JTree.convertValueToText​(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)

由渲染器调用，将指定的值转换为文本。

String

AbstractButton.AccessibleAbstractButton.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

JComboBox.AccessibleJComboBox.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionDescription​(int i)

返回此特定链接操作的字符串描述。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

JSpinner.AccessibleJSpinner.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleActionDescription​(int i)

返回树节点指定动作的描述。

String

JComponent.AccessibleJComponent.getAccessibleDescription​()

获取此对象的可访问描述。

String

JEditorPane.AccessibleJEditorPane.getAccessibleDescription​()

获取此对象的accessibleDescription属性。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleDescription​()

String

JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleDescription​()

获取此对象的可访问描述。

String

JToolTip.AccessibleJToolTip.getAccessibleDescription​()

获取此对象的可访问描述。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleDescription​()

获取此对象的可访问描述。

String

ProgressMonitor.AccessibleProgressMonitor.getAccessibleDescription​()

获取此对象的accessibleDescription属性。

String

ImageIcon.AccessibleImageIcon.getAccessibleIconDescription​()

获取图标的描述。

String

AbstractButton.AccessibleAbstractButton.getAccessibleName​()

返回此对象的可访问名称。

String

JComponent.AccessibleJComponent.getAccessibleName​()

获取此对象的可访问名称。

String

JDialog.AccessibleJDialog.getAccessibleName​()

获取此对象的可访问名称。

String

JFrame.AccessibleJFrame.getAccessibleName​()

获取此对象的可访问名称。

String

JInternalFrame.AccessibleJInternalFrame.getAccessibleName​()

获取此对象的可访问名称。

String

JLabel.AccessibleJLabel.getAccessibleName​()

获取此对象的可访问名称。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleName​()

String

JTabbedPane.AccessibleJTabbedPane.getAccessibleName​()

返回此对象的可访问名称，如果没有可访问名称，则返回 null 。

String

JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleName​()

获取此对象的可访问名称。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleName​()

获取此对象的可访问名称。

String

ProgressMonitor.AccessibleProgressMonitor.getAccessibleName​()

获取此对象的accessibleName属性。

String

AbstractButton.getActionCommand​()

返回此按钮的动作命令。

String

ButtonModel.getActionCommand​()

返回按钮的动作命令字符串。

String

DefaultButtonModel.getActionCommand​()

返回按钮的动作命令字符串。

String

JComboBox.getActionCommand​()

返回发送到动作侦听器的事件中包含的动作命令。

String

Timer.getActionCommand​()

返回由此定时器触发的 ActionEvent的action命令将传递的字符串。

String

AbstractButton.AccessibleAbstractButton.getAfterIndex​(int part, int index)

返回给定索引后的String。

String

JLabel.AccessibleJLabel.getAfterIndex​(int part, int index)

返回给定索引后的String。

String

JPasswordField.AccessibleJPasswordField.getAfterIndex​(int part, int index)

返回 String给定后 index 。

String

JSpinner.AccessibleJSpinner.getAfterIndex​(int part, int index)

返回给定索引后的String。

String

ProgressMonitor.AccessibleProgressMonitor.getAfterIndex​(int part, int index)

返回给定索引后的String。

String

JFileChooser.getApproveButtonText​()

返回在使用的文本 ApproveButton在 FileChooserUI 。

String

JFileChooser.getApproveButtonToolTipText​()

返回 ApproveButton使用的工具提示文本。

String

AbstractButton.AccessibleAbstractButton.getAtIndex​(int part, int index)

返回给定索引处的String。

String

JLabel.AccessibleJLabel.getAtIndex​(int part, int index)

返回给定索引处的String。

String

JPasswordField.AccessibleJPasswordField.getAtIndex​(int part, int index)

返回 String在给定 index 。

String

JSpinner.AccessibleJSpinner.getAtIndex​(int part, int index)

返回给定索引处的String。

String

ProgressMonitor.AccessibleProgressMonitor.getAtIndex​(int part, int index)

返回给定索引处的String。

String

AbstractButton.AccessibleAbstractButton.getBeforeIndex​(int part, int index)

返回给定索引之前的String。

String

JLabel.AccessibleJLabel.getBeforeIndex​(int part, int index)

返回给定索引之前的String。

String

JPasswordField.AccessibleJPasswordField.getBeforeIndex​(int part, int index)

返回 String之前给定的 index 。

String

JSpinner.AccessibleJSpinner.getBeforeIndex​(int part, int index)

返回给定索引之前的String。

String

ProgressMonitor.AccessibleProgressMonitor.getBeforeIndex​(int part, int index)

返回给定索引之前的String。

protected String

JComponent.AccessibleJComponent.getBorderTitle​(Border b)

递归搜索具有非空标题的TitledBorder的边界层次结构（如果存在）。

String

UIManager.LookAndFeelInfo.getClassName​()

返回实现这种外观的类的名称。

String

JTable.getColumnName​(int column)

返回列位置 column在视图中出现的列的名称。

String

JEditorPane.getContentType​()

获取此编辑器当前设置处理的内容类型。

static String

UIManager.getCrossPlatformLookAndFeelClassName​()

返回实现默认跨平台外观的 LookAndFeel类的名称--Java Look and Feel（JLF）。

String

ImageIcon.getDescription​()

获取图像的描述。

String

JFileChooser.getDescription​(File f)

返回文件描述。

abstract String

LookAndFeel.getDescription​()

返回这个外观的一行描述实现，例如

String

JFileChooser.getDialogTitle​()

获取 JFileChooser的标题栏中的字符串。

static String

JEditorPane.getEditorKitClassNameForContentType​(String type)

返回当前注册的 EditorKit类的名称，类型为 type 。

abstract String

LookAndFeel.getID​()

返回一个识别这种外观和感觉的字符串。

String

AbstractButton.getLabel​()

已过时。
- 替换为getText

String

JPopupMenu.getLabel​()

返回弹出菜单的标签

String

JEditorPane.JEditorPaneAccessibleHypertextSupport.getLinkText​(int linkIndex)

返回与该超链接相关联的文档中的连续文本。

String

JFileChooser.getName​(File f)

返回文件名。

abstract String

LookAndFeel.getName​()

返回一个标识这种外观和感觉的短字符串，例如

String

UIManager.LookAndFeelInfo.getName​()

以适合于菜单或其他演示的形式返回外观的名称

String

ProgressMonitor.getNote​()

指定与进度消息一起显示的附加注释。

String

AbstractButton.AccessibleAbstractButton.getSelectedText​()

返回所选文本的部分。

String

JLabel.AccessibleJLabel.getSelectedText​()

返回所选文本的部分。

String

JSpinner.AccessibleJSpinner.getSelectedText​()

返回所选文本的部分。

String

ProgressMonitor.AccessibleProgressMonitor.getSelectedText​()

返回所选文本的部分。

String

JProgressBar.getString​()

返回当前进度的 String表示。

String

UIDefaults.getString​(Object key)

如果 key的值是 String返回，否则返回 null 。

String

UIDefaults.getString​(Object key, Locale l)

如果 key的给定 Locale String ，则返回 null ，否则返回 null 。

static String

UIManager.getString​(Object key)

从默认值返回一个字符串。

static String

UIManager.getString​(Object key, Locale l)

从适用于给定语言环境的默认值返回一个字符串。

String

RowFilter.Entry.getStringValue​(int index)

返回指定索引处的字符串值。

String

DefaultRowSorter.ModelWrapper.getStringValueAt​(int row, int column)

在指定索引处返回值为 String 。

static String

UIManager.getSystemLookAndFeelClassName​()

返回实现本机系统外观的 LookAndFeel类的名称，如果有一个，否则默认跨平台的名称为 LookAndFeel类。

String

AbstractButton.getText​()

返回按钮的文字。

String

JEditorPane.getText​()

根据此编辑器的内容类型返回此 TextComponent中包含的文本。

String

JLabel.getText​()

返回标签显示的文本字符串。

String

JPasswordField.getText​()

已过时。
从Java 2平台v1.2开始，由getPassword取代。

String

JPasswordField.getText​(int offs, int len)

已过时。
从Java 2平台v1.2开始，由getPassword替代。

String

JPasswordField.AccessibleJPasswordField.getTextRange​(int startIndex, int endIndex)

返回两个之间的文字 indices 。

String

JSpinner.AccessibleJSpinner.getTextRange​(int startIndex, int endIndex)

返回两个索引之间的文本字符串。

String

JToolTip.getTipText​()

返回显示工具提示时显示的文本。

String

JInternalFrame.getTitle​()

返回 JInternalFrame的标题。

String

JTabbedPane.getTitleAt​(int index)

返回标签标题 index 。

String

AbstractButton.AccessibleAbstractButton.getTitledBorderText​()

返回标题边框文本

String

JComponent.AccessibleJComponent.getTitledBorderText​()

返回标题边框文本

String

JLabel.AccessibleJLabel.getTitledBorderText​()

返回标题边框文本

String

AbstractButton.AccessibleAbstractButton.getToolTipText​()

返回工具提示文本

String

JComponent.AccessibleJComponent.getToolTipText​()

返回工具提示文本

String

JComponent.getToolTipText​()

返回已设置为 setToolTipText的工具提示字符串。

String

JComponent.getToolTipText​(MouseEvent event)

返回要用作 事件的工具提示的字符串。

String

JLabel.AccessibleJLabel.getToolTipText​()

返回工具提示文本

String

JList.getToolTipText​(MouseEvent event)

返回用于给定事件的工具提示文本。

String

JTabbedPane.getToolTipText​(MouseEvent event)

返回由鼠标事件位置确定的组件的工具提示文本。

String

JTable.getToolTipText​(MouseEvent event)

覆盖 JComponent的 getToolTipText方法，以便允许渲染器的提示被使用，如果它有文本集。

String

JTree.getToolTipText​(MouseEvent event)

覆盖 JComponent的 getToolTipText方法，以便允许使用渲染器的提示，如果它具有文本集。

String

JTabbedPane.getToolTipTextAt​(int index)

在 index返回标签工具提示文本。

String

JFileChooser.getTypeDescription​(File f)

返回文件类型。

String

JButton.getUIClassID​()

返回一个字符串，它指定呈现此组件的L＆F类的名称。

String

JCheckBox.getUIClassID​()

返回一个字符串，它指定呈现此组件的L＆F类的名称。

String

JCheckBoxMenuItem.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JColorChooser.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JComboBox.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JComponent.getUIClassID​()

返回 UIDefaults键，用于查找定义该组件外观的 swing.plaf.ComponentUI类的名称。

String

JDesktopPane.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JEditorPane.getUIClassID​()

获取UI的类ID。

String

JFileChooser.getUIClassID​()

返回一个字符串，它指定呈现此组件的L＆F类的名称。

String

JFormattedTextField.getUIClassID​()

获取UI的类ID。

String

JInternalFrame.getUIClassID​()

返回呈现此组件的look-and-feel类的名称。

String

JInternalFrame.JDesktopIcon.getUIClassID​()

返回呈现此组件的look-and-feel类的名称。

String

JLabel.getUIClassID​()

返回一个字符串，指定呈现此组件的l＆f类的名称。

String

JList.getUIClassID​()

返回 "ListUI" ，该 UIDefaults用于查找该名关键 javax.swing.plaf.ListUI类定义的外观和感觉这个组件。

String

JMenu.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JMenuBar.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JMenuItem.getUIClassID​()

返回用于构造用于呈现此组件的L＆F类的名称的后缀。

String

JOptionPane.getUIClassID​()

返回实现该组件的L＆F的UI类的名称。

String

JPanel.getUIClassID​()

返回一个字符串，它指定呈现此组件的L＆F类的名称。

String

JPasswordField.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JPopupMenu.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JPopupMenu.Separator.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JProgressBar.getUIClassID​()

返回呈现此组件的look-and-feel类的名称。

String

JRadioButton.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JRadioButtonMenuItem.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JRootPane.getUIClassID​()

返回一个字符串，它指定呈现此组件的L＆F类的名称。

String

JScrollBar.getUIClassID​()

返回此组件的LookAndFeel类的名称。

String

JScrollPane.getUIClassID​()

返回用于构造用于呈现此组件的L＆F类的名称的后缀。

String

JSeparator.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JSlider.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JSpinner.getUIClassID​()

返回用于构造用于渲染此组件的外观（L＆F）类的名称的后缀。

String

JSplitPane.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JTabbedPane.getUIClassID​()

返回实现该组件的L＆F的UI类的名称。

String

JTable.getUIClassID​()

返回用于构造用于呈现此组件的L＆F类的名称的后缀。

String

JTextArea.getUIClassID​()

返回UI的类ID。

String

JTextField.getUIClassID​()

获取UI的类ID。

String

JTextPane.getUIClassID​()

返回UI的类ID。

String

JToggleButton.getUIClassID​()

返回一个字符串，指定呈现此组件的l＆f类的名称。

String

JToolBar.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JToolBar.Separator.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JToolTip.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JTree.getUIClassID​()

返回呈现此组件的L＆F类的名称。

String

JViewport.getUIClassID​()

返回一个字符串，它指定呈现此组件的L＆F类的名称。

String

JInternalFrame.getWarningString​()

获取与此内部框架一起显示的警告字符串。

static String

SwingUtilities.layoutCompoundLabel​(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)

计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。

static String

SwingUtilities.layoutCompoundLabel​(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)

计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。

protected String

AbstractButton.paramString​()

返回此 AbstractButton的字符串表示 AbstractButton 。

protected String

JApplet.paramString​()

已过时。

返回此JApplet的字符串表示形式。

protected String

JButton.paramString​()

返回此 JButton的字符串表示 JButton 。

protected String

JCheckBox.paramString​()

返回此JCheckBox的字符串表示形式。

protected String

JCheckBoxMenuItem.paramString​()

返回此JCheckBoxMenuItem的字符串表示形式。

protected String

JColorChooser.paramString​()

返回此 JColorChooser的字符串表示 JColorChooser 。

protected String

JComboBox.paramString​()

返回此 JComboBox的字符串表示 JComboBox 。

protected String

JComponent.paramString​()

返回此 JComponent的字符串表示 JComponent 。

protected String

JDesktopPane.paramString​()

返回此 JDesktopPane的字符串表示 JDesktopPane 。

protected String

JDialog.paramString​()

返回此 JDialog的字符串表示 JDialog 。

protected String

JEditorPane.paramString​()

返回此 JEditorPane的字符串表示 JEditorPane 。

protected String

JFileChooser.paramString​()

返回此 JFileChooser的字符串表示 JFileChooser 。

protected String

JFrame.paramString​()

返回此 JFrame的字符串表示 JFrame 。

protected String

JInternalFrame.paramString​()

返回此 JInternalFrame的字符串表示 JInternalFrame 。

protected String

JLabel.paramString​()

返回此JLabel的字符串表示形式。

protected String

JLayeredPane.paramString​()

返回此JLayeredPane的字符串表示形式。

protected String

JList.paramString​()

返回此 JList的 String表示。

protected String

JMenu.paramString​()

返回此 JMenu的字符串表示 JMenu 。

protected String

JMenuBar.paramString​()

返回此 JMenuBar的字符串表示 JMenuBar 。

protected String

JMenuItem.paramString​()

返回此 JMenuItem的字符串表示 JMenuItem 。

protected String

JOptionPane.paramString​()

返回此 JOptionPane的字符串表示 JOptionPane 。

protected String

JPanel.paramString​()

返回此JPanel的字符串表示形式。

protected String

JPasswordField.paramString​()

返回此 JPasswordField的字符串表示 JPasswordField 。

protected String

JPopupMenu.paramString​()

返回此 JPopupMenu的字符串表示 JPopupMenu 。

protected String

JProgressBar.paramString​()

返回此 JProgressBar的字符串表示 JProgressBar 。

protected String

JRadioButton.paramString​()

返回此JRadioButton的字符串表示形式。

protected String

JRadioButtonMenuItem.paramString​()

返回此 JRadioButtonMenuItem的字符串表示 JRadioButtonMenuItem 。

protected String

JRootPane.paramString​()

返回此 JRootPane的字符串表示 JRootPane 。

protected String

JScrollBar.paramString​()

返回此JScrollBar的字符串表示形式。

protected String

JScrollPane.paramString​()

返回此 JScrollPane的字符串表示 JScrollPane 。

protected String

JSeparator.paramString​()

返回此 JSeparator的字符串表示 JSeparator 。

protected String

JSlider.paramString​()

返回此JSlider的字符串表示形式。

protected String

JSplitPane.paramString​()

返回此 JSplitPane的字符串表示 JSplitPane 。

protected String

JTabbedPane.paramString​()

返回此 JTabbedPane的字符串表示 JTabbedPane 。

protected String

JTable.paramString​()

返回此表的字符串表示形式。

protected String

JTextArea.paramString​()

返回此JTextArea的字符串表示形式。

protected String

JTextField.paramString​()

返回此 JTextField的字符串表示 JTextField 。

protected String

JTextPane.paramString​()

返回此 JTextPane的字符串表示 JTextPane 。

protected String

JToggleButton.paramString​()

返回此JToggleButton的字符串表示形式。

protected String

JToolBar.paramString​()

返回此 JToolBar的字符串表示 JToolBar 。

protected String

JToolTip.paramString​()

返回此 JToolTip的字符串表示 JToolTip 。

protected String

JTree.paramString​()

返回此 JTree的字符串表示 JTree 。

protected String

JViewport.paramString​()

返回此 JViewport的字符串表示 JViewport 。

protected String

JWindow.paramString​()

返回此 JWindow的字符串表示 JWindow 。

static String

JOptionPane.showInputDialog​(Component parentComponent, Object message)

显示一个问题消息对话框，要求从父母的用户输入 parentComponent 。

static String

JOptionPane.showInputDialog​(Component parentComponent, Object message, Object initialSelectionValue)

显示一个问题消息对话框，请求从用户输入并加入 parentComponent 。

static String

JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType)

显示一个对话框，要求从具有标题 title和消息类型 messageType的对话框父母为 parentComponent的用户的输入。

static String

JOptionPane.showInputDialog​(Object message)

显示一个请求用户输入的问题消息对话框。

static String

JOptionPane.showInputDialog​(Object message, Object initialSelectionValue)

显示询问消息对话框，请求用户输入，输入值初始化为 initialSelectionValue 。

static String

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message)

显示一个内部问题消息对话框，请求从父母 parentComponent的用户的输入。

static String

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType)

显示一个内部对话框，请求用户对 parentComponent的用户的输入，对话框具有标题 title和消息类型 messageType 。

String

DefaultBoundedRangeModel.toString​()

返回显示所有 BoundedRangeModel属性的字符串。

String

DefaultListModel.toString​()

返回显示和标识此对象属性的字符串。

String

DefaultListSelectionModel.toString​()

返回显示和标识此对象属性的字符串。

String

GroupLayout.toString​()

返回此 GroupLayout的字符串表示 GroupLayout 。

String

ImageIcon.toString​()

返回此图像的字符串表示形式。

String

JList.DropLocation.toString​()

返回此放置位置的字符串表示形式。

String

JTable.DropLocation.toString​()

返回此放置位置的字符串表示形式。

String

JTree.DropLocation.toString​()

返回此放置位置的字符串表示形式。

String

LookAndFeel.toString​()

返回显示和标识此对象属性的字符串。

String

RepaintManager.toString​()

返回显示和标识此对象属性的字符串。

String

SizeRequirements.toString​()

返回描述最小，首选和最大大小要求的字符串以及对齐方式。

String

TransferHandler.DropLocation.toString​()

返回此放置位置的字符串表示形式。

String

UIManager.LookAndFeelInfo.toString​()

返回显示和标识此对象属性的字符串。

abstract String

JFormattedTextField.AbstractFormatter.valueToString​(Object value)

返回要显示 value的字符串值。

Methods in javax.swing with parameters of type String

Modifier and Type

方法

描述

protected void

AbstractButton.actionPropertyChanged​(Action action, String propertyName)

响应关联操作中的属性更改更新按钮的状态。

protected void

JComboBox.actionPropertyChanged​(Action action, String propertyName)

响应关联操作中的属性更改更新组合框的状态。

protected void

JMenuItem.actionPropertyChanged​(Action action, String propertyName)

响应关联操作中的属性更改更新按钮的状态。

protected void

JTextField.actionPropertyChanged​(Action action, String propertyName)

响应相关操作中的属性更改更新文本框的状态。

JMenuItem

JMenu.add​(String s)

创建一个带有指定文本的新菜单项，并将其附加到此菜单的末尾。

JMenuItem

JPopupMenu.add​(String s)

创建一个带有指定文本的新菜单项，并将其附加到此菜单的末尾。

Component

JTabbedPane.add​(String title, Component component)

添加一个 component与指定的选项卡标题。

void

BoxLayout.addLayoutComponent​(String name, Component comp)

本课不使用

void

GroupLayout.addLayoutComponent​(String name, Component component)

通知已将 Component添加到父容器。

void

JRootPane.RootLayout.addLayoutComponent​(String name, Component comp)

void

JSpinner.DefaultEditor.addLayoutComponent​(String name, Component child)

这个 LayoutManager方法什么都不做。

void

OverlayLayout.addLayoutComponent​(String name, Component comp)

将指定的组件添加到布局。

void

ScrollPaneLayout.addLayoutComponent​(String s, Component c)

将指定的组件添加到布局。

void

SpringLayout.addLayoutComponent​(String name, Component c)

没有效果，因为此布局管理器不使用每个组件字符串。

void

ViewportLayout.addLayoutComponent​(String name, Component c)

将指定的组件添加到布局。

void

UIDefaults.addResourceBundle​(String bundleName)

将资源包添加到搜索本地化值的资源束列表中。

Style

JTextPane.addStyle​(String nm, Style parent)

在逻辑样式层次结构中添加新样式。

void

JTabbedPane.addTab​(String title, Component component)

添加一个由 component表示的 title ，没有图标。

void

JTabbedPane.addTab​(String title, Icon icon, Component component)

添加由 title和/或 component表示的 icon ，其中任一个可以是 null 。

void

JTabbedPane.addTab​(String title, Icon icon, Component component, String tip)

增加了一个 component和 tip由a表示 title和/或 icon ，其中任一个可以是 null 。

void

JTextArea.append​(String str)

将给定的文本附加到文档的末尾。

protected int

AbstractButton.checkHorizontalKey​(int key, String exception)

验证 key参数是否为 horizontalAlignment和 horizontalTextPosition属性的合法值。

protected int

JLabel.checkHorizontalKey​(int key, String message)

验证该键是horizontalAlignment属性的合法值。

protected int

AbstractButton.checkVerticalKey​(int key, String exception)

验证 key参数是垂直属性的合法值。

protected int

JLabel.checkVerticalKey​(int key, String message)

验证该键是verticalAlignment或verticalTextPosition属性的合法值。

static int

SwingUtilities.computeStringWidth​(FontMetrics fm, String str)

使用指定的“metrics”（大小）的字体计算字符串的宽度。

static JDialog

JColorChooser.createDialog​(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)

创建并返回包含指定的 ColorChooser窗格的新对话框以及“确定”，“取消”和“重置”按钮。

JDialog

JOptionPane.createDialog​(Component parentComponent, String title)

创建并返回一个新的 JDialog包装 this居中于 parentComponent在 parentComponent的帧。

JDialog

JOptionPane.createDialog​(String title)

创建并返回具有指定标题的新的无父母 JDialog 。

static EditorKit

JEditorPane.createEditorKitForContentType​(String type)

从编辑器工具箱的默认注册表创建给定类型的处理程序。

JInternalFrame

JOptionPane.createInternalFrame​(Component parentComponent, String title)

创建并返回一个 JInternalFrame的实例。

static LookAndFeel

UIManager.createLookAndFeel​(String name)

创建由给定的 L&F name名称指定的受支持的内置Java LookAndFeel 。

static TitledBorder

BorderFactory.createTitledBorder​(String title)

创建一个带有指定标题的新标题边框，默认边框类型（由当前外观确定），默认文本位置（由当前外观确定），默认对齐（前导）和默认字体，文字颜色（由目前的外观所决定）。

static TitledBorder

BorderFactory.createTitledBorder​(Border border, String title)

将标题添加到现有边框，默认定位（由当前外观确定），默认对齐（前导）和默认字体和文字颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder​(Border border, String title, int titleJustification, int titlePosition)

将标题添加到现有边框中，并使用指定的定位，并使用默认的字体和文字颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont)

使用指定的定位和字体，使用默认文本颜色（由当前外观确定）将标题添加到现有边框。

static TitledBorder

BorderFactory.createTitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)

使用指定的定位，字体和颜色将标题添加到现有边框。

void

DebugGraphics.drawString​(String aString, int x, int y)

覆盖 Graphics.drawString 。

protected void

JFileChooser.fireActionPerformed​(String command)

通知所有在此事件类型上通知有兴趣的听众。

protected void

AbstractAction.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告绑定属性更改。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, byte oldValue, byte newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, char oldValue, char newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, double oldValue, double newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, float oldValue, float newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, int oldValue, int newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, long oldValue, long newValue)

由于性能原因而被覆盖。

void

DefaultListCellRenderer.firePropertyChange​(String propertyName, short oldValue, short newValue)

由于性能原因而被覆盖。

protected void

DefaultListCellRenderer.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

由于性能原因而被覆盖。

void

JComponent.firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)

支持报告布尔属性的绑定属性更改。

void

JComponent.firePropertyChange​(String propertyName, char oldValue, char newValue)

void

JComponent.firePropertyChange​(String propertyName, int oldValue, int newValue)

支持报告整数属性的绑定属性更改。

protected void

JViewport.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

通知侦听器属性更改。

void

SwingWorker.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

向任何已注册的监听器报告绑定属性更新。

protected void

UIDefaults.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告绑定属性更改。

protected void

JComponent.fireVetoableChange​(String propertyName, Object oldValue, Object newValue)

支持报告受限的属性更改。

static Container

SwingUtilities.getAncestorNamed​(String name, Component comp)

在组件层次结构中搜索 comp以上的方便方法，并返回其找到的第一个对象 name 。

Spring

SpringLayout.Constraints.getConstraint​(String edgeName)

返回指定边的值，该值可以是派生值，甚至是 null 。

Spring

SpringLayout.getConstraint​(String edgeName, Component c)

返回控制组件的指定边缘与其父级的顶部或左侧边缘之间的距离的弹簧。

Component

JScrollPane.getCorner​(String key)

返回指定角落的组件。

Component

ScrollPaneLayout.getCorner​(String key)

返回指定角落的 Component 。

static Object

LookAndFeel.getDesktopPropertyValue​(String systemPropertyName, Object fallbackValue)

通过调用 Toolkit.getDefaultToolkit().getDesktopProperty()返回指定的系统桌面属性的 Toolkit.getDefaultToolkit().getDesktopProperty() 。

static String

JEditorPane.getEditorKitClassNameForContentType​(String type)

返回当前注册的 EditorKit类名称，类型为 type 。

EditorKit

JEditorPane.getEditorKitForContentType​(String type)

获取编辑器套件以用于给定类型的内容。

static KeyStroke

KeyStroke.getKeyStroke​(String s)

解析一个字符串并返回一个 KeyStroke 。

int

JList.getNextMatch​(String prefix, int startIndex, Position.Bias bias)

返回下一个列表元素，其中 toString值以给定的前缀开头。

TreePath

JTree.getNextMatch​(String prefix, int startingRow, Position.Bias bias)

将TreePath返回到以前缀开头的下一个树元素。

Style

JTextPane.getStyle​(String nm)

获取以前添加的一个名为非 null样式。

Class<? extends ComponentUI>

UIDefaults.getUIClass​(String uiClassID)

返回呈现此组件的L＆F类。

Class<? extends ComponentUI>

UIDefaults.getUIClass​(String uiClassID, ClassLoader uiClassLoader)

值 get(uidClassID)必须 String实现相应的类的名称 ComponentUI类。

protected void

UIDefaults.getUIError​(String msg)

如果由于任何原因 getUI()失败，则在返回 null之前调用此方法。

Object

AbstractAction.getValue​(String key)

获取与指定键相关联的 Object 。

Object

Action.getValue​(String key)

使用关联的键获取该对象的属性之一。

int

JTabbedPane.indexOfTab​(String title)

返回带有给定的 title的第一个选项卡索引，如果没有选项卡具有此标题，则返回-1。

protected void

AbstractButton.init​(String text, Icon icon)

初始化 AbstractButton 。

protected void

JMenuItem.init​(String text, Icon icon)

用指定的文本和图标初始化菜单项。

void

JMenu.insert​(String s, int pos)

在给定的位置插入一个带有指定文本的新菜单项。

void

JTextArea.insert​(String str, int pos)

在指定的位置插入指定的文本。

void

JTabbedPane.insertTab​(String title, Icon icon, Component component, String tip, int index)

在给定的索引上插入给定组件的新选项卡，由给定的标题和/或图标表示，其中任一个可以是 null 。

void

JSpinner.AccessibleJSpinner.insertTextAtIndex​(int index, String s)

在指定的索引/

static void

LookAndFeel.installBorder​(JComponent c, String defaultBorderName)

使用默认值设置组件边框属性的便利方法。

static void

LookAndFeel.installColors​(JComponent c, String defaultBgName, String defaultFgName)

使用默认值设置组件的前景和背景颜色属性的便利方法。

static void

LookAndFeel.installColorsAndFont​(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)

使用默认值设置组件的前景，背景和字体属性的便利方法。

static void

UIManager.installLookAndFeel​(String name, String className)

添加指定的外观和感觉的一套可用的外观和感觉。

static void

LookAndFeel.installProperty​(JComponent c, String propertyName, Object propertyValue)

如果开发人员尚未设置该属性，则在方法上安装具有指定名称和值的属性。

static String

SwingUtilities.layoutCompoundLabel​(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)

计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。

static String

SwingUtilities.layoutCompoundLabel​(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)

计算并返回图标原点的位置，文本基线的原点位置以及复合标签字符串的可能剪切版本。

static Object

LookAndFeel.makeIcon​(Class<?> baseClass, String gifFile)

创建并返回加载图像的 UIDefault.LazyValue 。

void

SpringLayout.putConstraint​(String e1, Component c1, int pad, String e2, Component c2)

链接边缘 e1组分 c1到边缘 e2组分 c2 ，边与边之间的距离固定。

void

SpringLayout.putConstraint​(String e1, Component c1, Spring s, String e2, Component c2)

链接边缘 e1组分 c1到边缘 e2组分 c2 。

void

AbstractAction.putValue​(String key, Object newValue)

设置与指定键相关联的 Value 。

void

Action.putValue​(String key, Object value)

使用关联的键设置此对象的属性之一。

static <M,I> RowFilter<M,I>

RowFilter.regexFilter​(String regex, int... indices)

返回一个 RowFilter ，它使用正则表达式来确定要包括哪些条目。

static void

JEditorPane.registerEditorKitForContentType​(String type, String classname)

建立 type的默认绑定为 classname 。

static void

JEditorPane.registerEditorKitForContentType​(String type, String classname, ClassLoader loader)

建立 type至 classname的默认绑定。

void

JComponent.registerKeyboardAction​(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)

此方法现已过时，请使用 getActionMap()和 getInputMap()的组合进行类似的操作。

void

UIDefaults.removeResourceBundle​(String bundleName)

从查找本地化默认值的资源束列表中删除资源包。

void

JTextPane.removeStyle​(String nm)

删除以前添加到文档的命名非 null样式。

void

JTextArea.replaceRange​(String str, int start, int end)

用指定的新文本替换指定的开始到结束位置的文本。

void

JEditorPane.replaceSelection​(String content)

用给定字符串表示的新内容替换当前所选内容。

void

JTextPane.replaceSelection​(String content)

用给定字符串表示的新内容替换当前所选内容。

void

JSpinner.AccessibleJSpinner.replaceText​(int startIndex, int endIndex, String s)

用指定的字符串替换两个索引之间的文本。

void

JEditorPane.scrollToReference​(String reference)

将视图滚动到给定的参考位置（即，所显示的URL的 URL.getRef方法返回的值）。

void

JList.AccessibleJList.AccessibleJListChild.setAccessibleDescription​(String s)

void

JTable.AccessibleJTable.AccessibleJTableCell.setAccessibleDescription​(String s)

设置此对象的可访问描述。

void

JTree.AccessibleJTree.AccessibleJTreeNode.setAccessibleDescription​(String s)

设置此对象的可访问性描述。

void

ImageIcon.AccessibleImageIcon.setAccessibleIconDescription​(String description)

设置图标的描述。

void

JList.AccessibleJList.AccessibleJListChild.setAccessibleName​(String s)

void

JTable.AccessibleJTable.AccessibleJTableCell.setAccessibleName​(String s)

设置此对象的本地化可访问名称。

void

JTree.AccessibleJTree.AccessibleJTreeNode.setAccessibleName​(String s)

设置此对象的本地化可访问名称。

void

AbstractButton.setActionCommand​(String actionCommand)

设置此按钮的动作命令。

void

ButtonModel.setActionCommand​(String s)

设置当触发按钮时作为 ActionEvent一部分发送的动作命令字符串。

void

DefaultButtonModel.setActionCommand​(String actionCommand)

设置当触发按钮时作为 ActionEvent一部分发送的动作命令字符串。

void

JComboBox.setActionCommand​(String aCommand)

设置应该包含在发送到action监听器的事件中的action命令。

void

JTextField.setActionCommand​(String command)

设置用于操作事件的命令字符串。

void

Timer.setActionCommand​(String command)

将此定时器触发的 ActionEvent的动作命令设置为要传递的字符串。

void

JFileChooser.setApproveButtonText​(String approveButtonText)

设置 ApproveButton中使用的文本 FileChooserUI 。

void

JFileChooser.setApproveButtonToolTipText​(String toolTipText)

设置 ApproveButton使用的工具提示文本。

void

SpringLayout.Constraints.setConstraint​(String edgeName, Spring s)

设置弹簧控制指定的边缘。

void

JEditorPane.setContentType​(String type)

设置此编辑器处理的内容类型。

void

JScrollPane.setCorner​(String key, Component corner)

添加一个孩子，出现在一个滚动窗格的角落，如果有空间。

void

ImageIcon.setDescription​(String description)

设置图像的描述。

void

JFileChooser.setDialogTitle​(String dialogTitle)

设置 JFileChooser窗口的标题栏中的字符串。

void

JEditorPane.setEditorKitForContentType​(String type, EditorKit k)

直接设置用于给定类型的编辑器工具包。

void

AbstractButton.setLabel​(String label)

已过时。
- 替换为setText(text)

void

JPopupMenu.setLabel​(String label)

设置弹出菜单的标签。

static void

UIManager.setLookAndFeel​(String className)

使用当前线程的上下文类加载器加载由给定类名指定的 LookAndFeel ，并将其传递给 setLookAndFeel(LookAndFeel) 。

void

ProgressMonitor.setNote​(String note)

指定与进度消息一起显示的附加注释。

void

JEditorPane.setPage​(String url)

设置显示的当前URL。

void

JProgressBar.setString​(String s)

设置进度字符串的值。

void

AbstractButton.setText​(String text)

设置按钮的文本。

void

JEditorPane.setText​(String t)

将此 TextComponent的文本设置为指定的内容，预期其格式为此编辑器的内容类型。

void

JLabel.setText​(String text)

定义该组件将显示的单行文本。

void

JSpinner.AccessibleJSpinner.setTextContents​(String s)

将文本内容设置为指定的字符串。

void

JToolTip.setTipText​(String tipText)

设置显示工具提示时显示的文本。

void

JInternalFrame.setTitle​(String title)

设置 JInternalFrame标题。

void

JTabbedPane.setTitleAt​(int index, String title)

将标题设置为 index至 title ，其可以为 null 。

void

JComponent.setToolTipText​(String text)

注册文本以显示在工具提示。

void

JTabbedPane.setToolTipTextAt​(int index, String toolTipText)

内置的工具提示文本 index至 toolTipText它可以是 null 。

static int

JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType)

提出一个对话框，其中选择的数量由 optionType参数确定。

static int

JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType)

调出其中的选项的数目由所确定的一个对话框 optionType参数，其中，所述 messageType参数确定要显示的图标。

static int

JOptionPane.showConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)

启动具有指定图标的对话框，其中选择数由 optionType参数决定。

static Color

JColorChooser.showDialog​(Component component, String title, Color initialColor)

显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。

static Color

JColorChooser.showDialog​(Component component, String title, Color initialColor, boolean colorTransparencySelectionEnabled)

显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。

int

JFileChooser.showDialog​(Component parent, String approveButtonText)

使用自定义批准按钮弹出自定义文件选择器对话框。

static String

JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType)

显示一个对话框，要求从具有 parentComponent的用户的输入，对话框具有标题 title和消息类型 messageType 。

static Object

JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)

在阻止对话框中提示用户输入，可以指定初始选择，可能的选择和所有其他选项。

static int

JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType)

启动内部对话面板，其中选择次数由 optionType参数决定。

static int

JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType)

调出其中的选项数由所确定的内部对话框面板 optionType参数，其中，所述 messageType参数确定要显示的图标。

static int

JOptionPane.showInternalConfirmDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)

使用指定的图标启动内部对话面板，其中选择次数由 optionType参数决定。

static String

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType)

显示一个内部对话框，请求从 parentComponent的用户输入的对话框，标题为 title ，消息类型为 messageType 。

static Object

JOptionPane.showInternalInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)

在阻止内部对话框中提示输入用户，可以指定初始选择，可能的选择和所有其他选项。

static void

JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message, String title, int messageType)

启动内部对话面板，使用 messageType参数确定的默认图标显示消息。

static void

JOptionPane.showInternalMessageDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon)

启动一个显示消息的内部对话框面板，指定所有参数。

static int

JOptionPane.showInternalOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)

启动具有指定图标的内部对话面板，其中初始选择由 initialValue参数确定，选择次数由 optionType参数确定。

static void

JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType)

使用由 messageType参数确定的默认图标显示消息的对话框。

static void

JOptionPane.showMessageDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon)

显示一个显示消息的对话框，指定所有参数。

static int

JOptionPane.showOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)

启动具有指定图标的对话框，其中初始选择由 initialValue参数确定，选择次数由 optionType参数确定。

abstract Object

JFormattedTextField.AbstractFormatter.stringToValue​(String text)

解析 text返回任意的对象。

static DropMode

DropMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static GroupLayout.Alignment

GroupLayout.Alignment.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static JTable.PrintMode

JTable.PrintMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static LayoutStyle.ComponentPlacement

LayoutStyle.ComponentPlacement.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static RowFilter.ComparisonType

RowFilter.ComparisonType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SortOrder

SortOrder.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SwingWorker.StateValue

SwingWorker.StateValue.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javax.swing with parameters of type String

Constructor

描述

AbstractAction​(String name)

创建一个具有指定名称的 Action 。

AbstractAction​(String name, Icon icon)

创建一个具有指定名称和小图标的 Action 。

DateEditor​(JSpinner spinner, String dateFormatPattern)

构造一个 JSpinner编辑器，支持显示和编辑一个 SpinnerDateModel的值，带有一个 JFormattedTextField 。

ImageIcon​(byte[] imageData, String description)

从包含支持的图像格式（如GIF，JPEG或（1.3）PNG）的图像文件中读取的字节数组创建一个ImageIcon。

ImageIcon​(Image image, String description)

从图像创建一个ImageIcon。

ImageIcon​(String filename)

从指定的文件创建一个ImageIcon。

ImageIcon​(String filename, String description)

从指定的文件创建一个ImageIcon。

ImageIcon​(URL location, String description)

从指定的URL创建一个ImageIcon。

JButton​(String text)

创建一个带文本的按钮。

JButton​(String text, Icon icon)

创建一个带有初始文本和图标的按钮。

JCheckBox​(String text)

创建一个最初未选择的复选框与文本。

JCheckBox​(String text, boolean selected)

创建一个带有文本的复选框，并指定是否最初选择它。

JCheckBox​(String text, Icon icon)

使用指定的文本和图标创建最初未选择的复选框。

JCheckBox​(String text, Icon icon, boolean selected)

创建一个带有文本和图标的复选框，并指定是否最初选择它。

JCheckBoxMenuItem​(String text)

用文本创建一个初始未选择的复选框菜单项。

JCheckBoxMenuItem​(String text, boolean b)

创建具有指定文本和选择状态的复选框菜单项。

JCheckBoxMenuItem​(String text, Icon icon)

使用指定的文本和图标创建最初未选择的复选框菜单项。

JCheckBoxMenuItem​(String text, Icon icon, boolean b)

创建带有指定文本，图标和选择状态的复选框菜单项。

JDialog​(Dialog owner, String title)

使用指定的标题和指定的所有者对话框创建无模式对话框。

JDialog​(Dialog owner, String title, boolean modal)

创建一个具有指定标题，模态和指定所有者的 Dialog 。

JDialog​(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)

创建一个具有指定标题的对话框，所有者 Dialog ，模式和 GraphicsConfiguration 。

JDialog​(Frame owner, String title)

使用指定的标题和指定的所有者框架创建无模式对话框。

JDialog​(Frame owner, String title, boolean modal)

创建一个带有指定标题的对话框，拥有者 Frame和模态。

JDialog​(Frame owner, String title, boolean modal, GraphicsConfiguration gc)

创建一个具有指定标题的对话框，所有者 Frame ，模式和 GraphicsConfiguration 。

JDialog​(Window owner, String title)

使用指定的标题和所有者创建无模式对话框 Window 。

JDialog​(Window owner, String title, Dialog.ModalityType modalityType)

创建一个具有指定标题的对话框，拥有者 Window和模态。

JDialog​(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)

创建一个具有指定标题的对话框，所有者 Window ，模态和 GraphicsConfiguration 。

JEditorPane​(String url)

根据包含URL规范的字符串创建一个 JEditorPane 。

JEditorPane​(String type, String text)

创建已初始化为给定文本的 JEditorPane 。

JFileChooser​(String currentDirectoryPath)

使用给定的路径构建一个 JFileChooser 。

JFileChooser​(String currentDirectoryPath, FileSystemView fsv)

构造一个 JFileChooser使用给定的当前目录路径和 FileSystemView 。

JFrame​(String title)

创建一个新的，最初不可见的 Frame与指定的标题。

JFrame​(String title, GraphicsConfiguration gc)

创建 JFrame具有指定标题和指定 GraphicsConfiguration屏幕设备的。

JInternalFrame​(String title)

创建一个不可调整大小，不可关闭，不可最大化，非图形化的 JInternalFrame与指定的标题。

JInternalFrame​(String title, boolean resizable)

创建一个不可关闭，不可最大化，非图形化的 JInternalFrame具有指定的标题和可 JInternalFrame性。

JInternalFrame​(String title, boolean resizable, boolean closable)

创建一个不可最大化，非图形化的 JInternalFrame具有指定的标题，可重定位性和可关闭性。

JInternalFrame​(String title, boolean resizable, boolean closable, boolean maximizable)

创建具有指定标题，可重定位性，可关闭性和最大化性能的非图形化 JInternalFrame 。

JInternalFrame​(String title, boolean resizable, boolean closable, boolean maximizable, boolean iconifiable)

创建 JInternalFrame具有指定标题，可调整，可关闭，可最大化和图标化。

JLabel​(String text)

使用指定的文本创建一个 JLabel实例。

JLabel​(String text, int horizontalAlignment)

创建一个具有指定文本和水平对齐的 JLabel实例。

JLabel​(String text, Icon icon, int horizontalAlignment)

创建具有指定文本，图像和水平对齐的 JLabel实例。

JMenu​(String s)

构造一个新的 JMenu ，其中提供的字符串作为其文本。

JMenu​(String s, boolean b)

构造新的 JMenu ，其中提供的字符串作为其文本并指定为撕下菜单。

JMenuItem​(String text)

创建一个 JMenuItem与指定的文本。

JMenuItem​(String text, int mnemonic)

创建一个 JMenuItem与指定的文本和键盘助记符。

JMenuItem​(String text, Icon icon)

创建一个 JMenuItem与指定的文本和图标。

JPasswordField​(String text)

构造一个新的 JPasswordField ，用指定的文本初始化。

JPasswordField​(String text, int columns)

构造一个新的 JPasswordField ，使用指定的文本和列进行初始化。

JPasswordField​(Document doc, String txt, int columns)

构造一个新的 JPasswordField ，它使用给定的文本存储模型和给定的列数。

JPopupMenu​(String label)

构造具有指定标题的 JPopupMenu 。

JRadioButton​(String text)

使用指定的文本创建一个未选择的单选按钮。

JRadioButton​(String text, boolean selected)

创建具有指定文本和选择状态的单选按钮。

JRadioButton​(String text, Icon icon)

创建具有指定文本和图像的单选按钮，最初未被选择。

JRadioButton​(String text, Icon icon, boolean selected)

创建具有指定文本，图像和选择状态的单选按钮。

JRadioButtonMenuItem​(String text)

创建一个 JRadioButtonMenuItem与文本。

JRadioButtonMenuItem​(String text, boolean selected)

创建具有指定文本和选择状态的单选按钮菜单项。

JRadioButtonMenuItem​(String text, Icon icon)

创建一个带有指定文本的单选按钮菜单项和 Icon 。

JRadioButtonMenuItem​(String text, Icon icon, boolean selected)

创建具有指定文本，图像和选择状态的单选按钮菜单项。

JTextArea​(String text)

构造一个新的TextArea，并显示指定的文本。

JTextArea​(String text, int rows, int columns)

构造具有指定文本和行数和列数的新TextArea。

JTextArea​(Document doc, String text, int rows, int columns)

构造具有指定行数和列数的新JTextArea以及给定模型。

JTextField​(String text)

构造一个新的 TextField ，用指定的文本初始化。

JTextField​(String text, int columns)

构造一个新的 TextField ，用指定的文本和列初始化。

JTextField​(Document doc, String text, int columns)

构造一个新的 JTextField ，它使用给定的文本存储模型和给定的列数。

JToggleButton​(String text)

使用指定的文本创建一个未选择的切换按钮。

JToggleButton​(String text, boolean selected)

创建具有指定文本和选择状态的切换按钮。

JToggleButton​(String text, Icon icon)

创建具有指定文本和图像的切换按钮，最初未被选择。

JToggleButton​(String text, Icon icon, boolean selected)

创建具有指定文本，图像和选择状态的切换按钮。

JToolBar​(String name)

用指定的 name创建一个新的工具栏。

JToolBar​(String name, int orientation)

创建一个新的工具栏与指定的 name和 orientation 。

LookAndFeelInfo​(String name, String className)

构造一个 UIManager的 LookAndFeelInfo对象。

NumberEditor​(JSpinner spinner, String decimalFormatPattern)

构造一个 JSpinner编辑器，支持显示和编辑的价值 SpinnerNumberModel用 JFormattedTextField 。

ProgressMonitor​(Component parentComponent, Object message, String note, int min, int max)

构造一个显示进度的图形对象，通常通过填充矩形栏来完成过程。

ProxyLazyValue​(String c)

创建一个 LazyValue ，这将在询问时构建一个实例。

ProxyLazyValue​(String c, Object[] o)

创建一个 LazyValue ，这将在询问时构建一个实例。

ProxyLazyValue​(String c, String m)

创建一个 LazyValue ，这将在询问时构建一个实例。

ProxyLazyValue​(String c, String m, Object[] o)

创建一个 LazyValue ，这将在被询问时构造一个实例。

TransferHandler​(String property)

构造一个可以通过剪贴板或拖放操作将Java Bean属性从一个组件传输到另一个组件的传输处理程序。

UnsupportedLookAndFeelException​(String s)

构造一个UnsupportedLookAndFeelException对象。

Uses of String in javax.swing.border

Fields in javax.swing.border declared as String

Modifier and Type

Field

描述

protected String

TitledBorder.title

边界应该显示的标题。

Methods in javax.swing.border that return String

Modifier and Type

方法

描述

String

TitledBorder.getTitle​()

返回标题边框的标题。

Methods in javax.swing.border with parameters of type String

Modifier and Type

方法

描述

void

TitledBorder.setTitle​(String title)

设置标题边框的标题。

Constructors in javax.swing.border with parameters of type String

Constructor

描述

TitledBorder​(String title)

创建一个TitledBorder实例。

TitledBorder​(Border border, String title)

创建带有指定边框和标题的TitledBorder实例。

TitledBorder​(Border border, String title, int titleJustification, int titlePosition)

创建一个带有指定边框，标题，标题对齐和标题位置的TitledBorder实例。

TitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont)

创建带有指定边框，标题，标题对齐，标题位置和标题字体的TitledBorder实例。

TitledBorder​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)

创建带有指定边框，标题，标题对齐，标题位置，标题字体和标题颜色的TitledBorder实例。

Uses of String in javax.swing.colorchooser

Fields in javax.swing.colorchooser declared as String

Modifier and Type

Field

描述

static String

AbstractColorChooserPanel.TRANSPARENCY_ENABLED_PROPERTY

标识可以选择颜色的透明度（alpha值）

Methods in javax.swing.colorchooser that return String

Modifier and Type

方法

描述

abstract String

AbstractColorChooserPanel.getDisplayName​()

返回一个包含面板显示名称的字符串。

Uses of String in javax.swing.event

Methods in javax.swing.event that return String

Modifier and Type

方法

描述

String

HyperlinkEvent.getDescription​()

以链接形式获取链接的描述。

String

InternalFrameEvent.paramString​()

返回标识此事件的参数字符串。

String

DocumentEvent.EventType.toString​()

将类型转换为字符串。

String

EventListenerList.toString​()

返回EventListenerList的字符串表示形式。

String

HyperlinkEvent.EventType.toString​()

将类型转换为字符串。

String

ListDataEvent.toString​()

返回此ListDataEvent的字符串表示形式。

String

ListSelectionEvent.toString​()

返回一个 String ，显示和标识此对象的属性。

String

TreeModelEvent.toString​()

返回显示和标识此对象属性的字符串。

Methods in javax.swing.event with parameters of type String

Modifier and Type

方法

描述

static RowSorterEvent.Type

RowSorterEvent.Type.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javax.swing.event with parameters of type String

Constructor

描述

HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc)

创建一个表示超文本链接事件的新对象。

HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)

创建一个表示超文本链接事件的新对象。

HyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement, InputEvent inputEvent)

创建一个表示超文本链接事件的新对象。

Uses of String in javax.swing.filechooser

Methods in javax.swing.filechooser that return String

Modifier and Type

方法

描述

abstract String

FileFilter.getDescription​()

这个过滤器的描述。

String

FileNameExtensionFilter.getDescription​()

这个过滤器的描述。

String

FileView.getDescription​(File f)

该文件的人类可读描述。

String[]

FileNameExtensionFilter.getExtensions​()

返回所测试的文件扩展名文件集。

String

FileView.getName​(File f)

文件的名称。

String

FileSystemView.getSystemDisplayName​(File f)

在系统文件浏览器中显示的文件，目录或文件夹的名称。

String

FileSystemView.getSystemTypeDescription​(File f)

键入在系统文件浏览器中显示的文件，目录或文件夹的描述。

String

FileView.getTypeDescription​(File f)

对文件类型的可读描述。

String

FileNameExtensionFilter.toString​()

返回 FileNameExtensionFilter的字符串表示 FileNameExtensionFilter 。

Methods in javax.swing.filechooser with parameters of type String

Modifier and Type

方法

描述

File

FileSystemView.createFileObject​(File dir, String filename)

返回从给定文件名在dir中构造的File对象。

File

FileSystemView.createFileObject​(String path)

返回从给定的路径字符串构造的File对象。

File

FileSystemView.getChild​(File parent, String fileName)

Constructors in javax.swing.filechooser with parameters of type String

Constructor

描述

FileNameExtensionFilter​(String description, String... extensions)

创建一个具有指定的说明和文件扩展名的 FileNameExtensionFilter 。

Uses of String in javax.swing.plaf

Methods in javax.swing.plaf that return String

Modifier and Type

方法

描述

abstract String

FileChooserUI.getApproveButtonText​(JFileChooser fc)

退回批准按钮文本。

abstract String

FileChooserUI.getDialogTitle​(JFileChooser fc)

返回对话框标题。

String

TextUI.getToolTipText​(JTextComponent t, Point pt)

已过时。
替换为TextUI.getToolTipText2D(JTextComponent, Point2D)

String

TextUI.getToolTipText2D​(JTextComponent t, Point2D pt)

返回要用作传入位置的工具提示的字符串。

Methods in javax.swing.plaf with parameters of type String

Modifier and Type

方法

描述

void

LayerUI.addPropertyChangeListener​(String propertyName, PropertyChangeListener listener)

将PropertyChangeListener添加到特定属性的侦听器列表中。

protected void

LayerUI.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告对象属性的绑定属性更改。

PropertyChangeListener[]

LayerUI.getPropertyChangeListeners​(String propertyName)

返回与named属性相关联的所有侦听器的数组。

void

LayerUI.removePropertyChangeListener​(String propertyName, PropertyChangeListener listener)

从侦听器列表中删除特定属性的 PropertyChangeListener 。

Constructors in javax.swing.plaf with parameters of type String

Constructor

描述

FontUIResource​(String name, int style, int size)

构造一个 FontUIResource 。

TitledBorderUIResource​(String title)

构造一个 TitledBorderUIResource 。

TitledBorderUIResource​(Border border, String title)

构造一个 TitledBorderUIResource 。

TitledBorderUIResource​(Border border, String title, int titleJustification, int titlePosition)

构造一个 TitledBorderUIResource 。

TitledBorderUIResource​(Border border, String title, int titleJustification, int titlePosition, Font titleFont)

构造一个 TitledBorderUIResource 。

TitledBorderUIResource​(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)

构造一个 TitledBorderUIResource 。

Uses of String in javax.swing.plaf.basic

Fields in javax.swing.plaf.basic declared as String

Modifier and Type

Field

描述

protected String

BasicMenuItemUI.acceleratorDelimiter

加速器分隔字符串，如 '+'在 'Ctrl+C' 。

protected String

BasicFileChooserUI.cancelButtonText

取消按钮文字

protected String

BasicFileChooserUI.cancelButtonToolTipText

取消按钮工具提示文本

protected static String

BasicInternalFrameTitlePane.CLOSE_CMD

关闭按钮文本属性。

protected String

BasicToolBarUI.constraintBeforeFloating

浮动前的布局。

protected String

BasicFileChooserUI.directoryOpenButtonText

当选择目录并且当前选择模式为FILES_ONLY时，批准按钮上显示的标签文本。

protected String

BasicFileChooserUI.directoryOpenButtonToolTipText

当选择目录并且当前选择模式为FILES_ONLY时，在批准按钮上显示的工具提示文本。

static String

BasicHTML.documentBaseKey

密钥存储为客户端属性，以指示相对引用被解析的基础。

protected String

BasicFileChooserUI.helpButtonText

帮助按钮文字

protected String

BasicFileChooserUI.helpButtonToolTipText

帮助按钮工具提示文本

protected static String

BasicInternalFrameTitlePane.ICONIFY_CMD

最小化按钮文本属性。

protected static String

BasicInternalFrameTitlePane.MAXIMIZE_CMD

最大化按钮文本属性。

protected static String

BasicInternalFrameTitlePane.MOVE_CMD

移动按钮文本属性。

protected static String

BasicSplitPaneUI.NON_CONTINUOUS_DIVIDER

用于非连续布局的分隔符将添加到具有此对象的拆分窗格中。

protected String

BasicFileChooserUI.openButtonText

打开按钮文本

protected String

BasicFileChooserUI.openButtonToolTipText

打开按钮工具提示文本

static String

BasicHTML.propertyKey

作为JComponent的客户端属性存储时，用于html渲染器的键。

protected static String

BasicInternalFrameTitlePane.RESTORE_CMD

还原按钮文本属性。

protected String

BasicFileChooserUI.saveButtonText

保存按钮文字

protected String

BasicFileChooserUI.saveButtonToolTipText

保存按钮工具提示文本

protected static String

BasicInternalFrameTitlePane.SIZE_CMD

大小按钮文本属性。

protected String

BasicFileChooserUI.updateButtonText

更新按钮文本

protected String

BasicFileChooserUI.updateButtonToolTipText

更新按钮工具提示文本

Methods in javax.swing.plaf.basic that return String

Modifier and Type

方法

描述

String

BasicFileChooserUI.getApproveButtonText​(JFileChooser fc)

退回批准按钮文本。

String

BasicFileChooserUI.getApproveButtonToolTipText​(JFileChooser fc)

返回批准按钮工具提示。

static String

BasicGraphicsUtils.getClippedString​(JComponent c, FontMetrics fm, String string, int availTextWidth)

将传入的字符串剪切到提供的空格。

String

BasicFileChooserUI.AcceptAllFileFilter.getDescription​()

这个过滤器的描述。

String

BasicFileChooserUI.BasicFileView.getDescription​(File f)

该文件的人类可读描述。

String

BasicFileChooserUI.getDialogTitle​(JFileChooser fc)

返回此对话框的标题

String

BasicFileChooserUI.getDirectoryName​()

返回目录名称。

String

BasicFileChooserUI.getFileName​()

返回文件名。

protected String

BasicTextUI.getKeymapName​()

获取此UI将默认安装/使用的键盘映射的名称。

String

BasicFileChooserUI.BasicFileView.getName​(File f)

文件的名称。

protected String

BasicButtonUI.getPropertyPrefix​()

返回属性前缀。

protected String

BasicCheckBoxMenuItemUI.getPropertyPrefix​()

String

BasicCheckBoxUI.getPropertyPrefix​()

protected String

BasicEditorPaneUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

BasicFormattedTextFieldUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

BasicMenuItemUI.getPropertyPrefix​()

返回属性前缀。

protected String

BasicMenuUI.getPropertyPrefix​()

protected String

BasicPasswordFieldUI.getPropertyPrefix​()

获取用作密钥的名称，通过UIManager查找属性。

protected String

BasicRadioButtonMenuItemUI.getPropertyPrefix​()

protected String

BasicRadioButtonUI.getPropertyPrefix​()

protected String

BasicTextAreaUI.getPropertyPrefix​()

获取用作密钥的名称，通过UIManager查找属性。

protected String

BasicTextFieldUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

BasicTextPaneUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected abstract String

BasicTextUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

BasicToggleButtonUI.getPropertyPrefix​()

protected String

BasicInternalFrameTitlePane.getTitle​(String text, FontMetrics fm, int availTextWidth)

返回标题。

String

BasicTextUI.getToolTipText​(JTextComponent t, Point pt)

返回要用作传入位置的工具提示的字符串。

String

BasicFileChooserUI.BasicFileView.getTypeDescription​(File f)

对文件类型的可读描述。

protected String

BasicLabelUI.layoutCL​(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)

转发给SwingUtilities.layoutCompoundLabel（）的调用。

Methods in javax.swing.plaf.basic with parameters of type String

Modifier and Type

方法

描述

void

BasicComboBoxUI.ComboBoxLayoutManager.addLayoutComponent​(String name, Component comp)

void

BasicInternalFrameTitlePane.TitlePaneLayout.addLayoutComponent​(String name, Component c)

void

BasicInternalFrameUI.InternalFrameLayout.addLayoutComponent​(String name, Component c)

如果布局管理器使用每个组件字符串，则将组件 comp添加到布局，将其与 name指定的字符串相关联。

void

BasicOptionPaneUI.ButtonAreaLayout.addLayoutComponent​(String string, Component comp)

void

BasicScrollBarUI.addLayoutComponent​(String name, Component child)

void

BasicSplitPaneDivider.DividerLayout.addLayoutComponent​(String string, Component c)

void

BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent​(String place, Component component)

将组件添加到位置。

void

BasicTabbedPaneUI.TabbedPaneLayout.addLayoutComponent​(String name, Component comp)

protected void

BasicOptionPaneUI.burstStringInto​(Container c, String d, int maxll)

递归创建新的 JLabel实例来表示 d 。

static View

BasicHTML.createHTMLView​(JComponent c, String html)

为给定的组件和html的字符串创建一个html渲染器。

static void

BasicGraphicsUtils.drawString​(Graphics g, String text, int underlinedChar, int x, int y)

绘制一个字符串的图形 g在位置（x，y）就像 g.drawString会。

static void

BasicGraphicsUtils.drawString​(JComponent c, Graphics2D g, String string, float x, float y)

使用提供的组件的文本属性和反锯齿提示在指定位置绘制给定的字符串。

static void

BasicGraphicsUtils.drawStringUnderlineCharAt​(Graphics g, String text, int underlinedIndex, int x, int y)

画一个字符串与图形 g在位置（ x ， y ）就像 g.drawString会。

static void

BasicGraphicsUtils.drawStringUnderlineCharAt​(JComponent c, Graphics2D g, String string, int underlinedIndex, float x, float y)

在指定的位置绘制给定的字符串，强调指定的字符。

protected void

BasicDirectoryModel.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

支持报告布尔属性的绑定属性更改。

static String

BasicGraphicsUtils.getClippedString​(JComponent c, FontMetrics fm, String string, int availTextWidth)

将传入的字符串剪切到提供的空格。

protected Point

BasicProgressBarUI.getStringPlacement​(Graphics g, String progressString, int x, int y, int width, int height)

指定进度字符串将被绘制的地方。

static float

BasicGraphicsUtils.getStringWidth​(JComponent c, FontMetrics fm, String string)

使用提供的组件的文本属性和反锯齿提示返回传入的字符串的宽度。

protected String

BasicInternalFrameTitlePane.getTitle​(String text, FontMetrics fm, int availTextWidth)

返回标题。

static boolean

BasicHTML.isHTMLString​(String s)

检查给定的字符串，看看它是否应该在支持html呈现的非文本组件中触发html渲染逻辑。

protected String

BasicLabelUI.layoutCL​(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)

转发给SwingUtilities.layoutCompoundLabel（）的调用。

protected void

BasicTabbedPaneUI.layoutLabel​(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)

Laysout一个标签。

protected void

BasicLookAndFeel.loadSystemColors​(UIDefaults table, String[] systemColors, boolean useNative)

填充 table与 name-color对在 systemColors 。

protected void

BasicLabelUI.paintDisabledText​(JLabel l, Graphics g, String s, int textX, int textY)

在textX上绘制clippedText，textY与background.lighter（），然后向下移动并向右移动一个像素与background.darker（）。

protected void

BasicLabelUI.paintEnabledText​(JLabel l, Graphics g, String s, int textX, int textY)

在textX上绘制clippedText，textY带有标签前景色。

protected void

BasicButtonUI.paintText​(Graphics g, AbstractButton b, Rectangle textRect, String text)

呈现当前按钮文本的方法。

protected void

BasicButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)

呈现当前按钮文本的方法。

protected void

BasicMenuItemUI.paintText​(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)

呈现当前菜单项的文本。

protected void

BasicTabbedPaneUI.paintText​(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)

油漆文字。

void

BasicFileChooserUI.setDirectoryName​(String dirname)

设置目录名称。

void

BasicFileChooserUI.setFileName​(String filename)

设置文件名。

static void

BasicHTML.updateRenderer​(JComponent c, String text)

将给定文本的HTML渲染存储到给定JComponent的客户端属性中。

Constructors in javax.swing.plaf.basic with parameters of type String

Constructor

描述

TreeCancelEditingAction​(String name)

构造一个新的实例 TreeCancelEditingAction 。

TreeHomeAction​(int direction, String name)

构造一个新的实例 TreeHomeAction 。

TreeIncrementAction​(int direction, String name)

构造一个新的实例 TreeIncrementAction 。

TreePageAction​(int direction, String name)

构造一个新的实例 TreePageAction 。

TreeToggleAction​(String name)

构造一个新的实例 TreeToggleAction 。

TreeTraverseAction​(int direction, String name)

构造一个新的实例 TreeTraverseAction 。

Uses of String in javax.swing.plaf.metal

Fields in javax.swing.plaf.metal declared as String

Modifier and Type

Field

描述

static String

MetalScrollBarUI.FREE_STANDING_PROP

物业 JScrollBar.isFreeStanding 。

protected static String

MetalInternalFrameUI.IS_PALETTE

物业 JInternalFrame.isPalette 。

protected String

MetalSliderUI.SLIDER_FILL

物业 JSlider.isFilled 。

Methods in javax.swing.plaf.metal that return String

Modifier and Type

方法

描述

String

MetalToolTipUI.getAcceleratorString​()

返回加速器字符串。

String

MetalLookAndFeel.getDescription​()

返回这种外观的简短描述。

String

MetalFileChooserUI.getDirectoryName​()

返回目录名称。

String

MetalFileChooserUI.getFileName​()

String

MetalLookAndFeel.getID​()

返回此外观的标识符。

String

DefaultMetalTheme.getName​()

返回此主题的名称。

String

MetalLookAndFeel.getName​()

返回这种外观的名称。

abstract String

MetalTheme.getName​()

返回此主题的名称。

String

OceanTheme.getName​()

返回这个主题的名称，“海洋”。

String

MetalCheckBoxUI.getPropertyPrefix​()

Methods in javax.swing.plaf.metal with parameters of type String

Modifier and Type

方法

描述

protected void

MetalLabelUI.paintDisabledText​(JLabel l, Graphics g, String s, int textX, int textY)

只需将文字画成灰色（Label.disabledForeground），而不是标签前景色。

protected void

MetalButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)

protected void

MetalToggleButtonUI.paintText​(Graphics g, JComponent c, Rectangle textRect, String text)

void

MetalFileChooserUI.setDirectoryName​(String dirname)

设置目录名称。

void

MetalFileChooserUI.setFileName​(String filename)

Uses of String in javax.swing.plaf.multi

Methods in javax.swing.plaf.multi that return String

Modifier and Type

方法

描述

String

MultiFileChooserUI.getApproveButtonText​(JFileChooser a)

在此对象处理的每个UI上调用 getApproveButtonText方法。

String

MultiLookAndFeel.getDescription​()

返回这种外观的一行描述。

String

MultiFileChooserUI.getDialogTitle​(JFileChooser a)

在此对象处理的每个UI上调用 getDialogTitle方法。

String

MultiLookAndFeel.getID​()

返回一个适用于应用程序/服务的字符串，用于标识这种外观。

String

MultiLookAndFeel.getName​()

返回适合在菜单中使用的字符串，用于标识这种外观。

String

MultiTextUI.getToolTipText​(JTextComponent a, Point b)

在此对象处理的每个UI上调用 getToolTipText方法。

Uses of String in javax.swing.plaf.nimbus

Fields in javax.swing.plaf.nimbus declared as String

Modifier and Type

Field

描述

static String

NimbusStyle.LARGE_KEY

大钥匙

static String

NimbusStyle.MINI_KEY

迷你钥匙

static String

NimbusStyle.SMALL_KEY

小钥匙

Methods in javax.swing.plaf.nimbus that return String

Modifier and Type

方法

描述

String

NimbusLookAndFeel.getDescription​()

返回此外观的文字说明。

String

NimbusLookAndFeel.getID​()

返回一个识别这种外观和感觉的字符串。

String

NimbusLookAndFeel.getName​()

返回一个标识这种外观和感觉的短字符串。

String

State.toString​()

Methods in javax.swing.plaf.nimbus with parameters of type String

Modifier and Type

方法

描述

protected Color

AbstractRegionPainter.decodeColor​(String key, float hOffset, float sOffset, float bOffset, int aOffset)

解码并返回从UI默认值中的基色导出的颜色。

protected Color

AbstractRegionPainter.getComponentColor​(JComponent c, String property, Color defaultColor, float saturationOffset, float brightnessOffset, int alphaOffset)

从给定的JComponent获取颜色属性。

Color

NimbusLookAndFeel.getDerivedColor​(String uiDefaultParentName, float hOffset, float sOffset, float bOffset, int aOffset, boolean uiResource)

获取派生颜色，派生颜色是共享实例，并且当其父UIDefault颜色更改时，颜色值将更改。

void

NimbusLookAndFeel.register​(Region region, String prefix)

使用NimbusLookAndFeel注册第三方组件。

static AbstractRegionPainter.PaintContext.CacheMode

AbstractRegionPainter.PaintContext.CacheMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javax.swing.plaf.nimbus with parameters of type String

Constructor

描述

State​(String name)

创建一个新的自定义状态。

Uses of String in javax.swing.plaf.synth

Methods in javax.swing.plaf.synth that return String

Modifier and Type

方法

描述

String

SynthLookAndFeel.getDescription​()

返回SynthLookAndFeel的文本描述。

String

SynthLookAndFeel.getID​()

返回一个识别这种外观和感觉的字符串。

String

Region.getName​()

返回区域的名称。

String

SynthLookAndFeel.getName​()

返回一个标识这种外观和感觉的短字符串。

protected String

SynthCheckBoxMenuItemUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthCheckBoxUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthFormattedTextFieldUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

SynthPasswordFieldUI.getPropertyPrefix​()

获取用作密钥的名称，通过UIManager查找属性。

protected String

SynthRadioButtonMenuItemUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthRadioButtonUI.getPropertyPrefix​()

返回属性前缀。

protected String

SynthTextPaneUI.getPropertyPrefix​()

获取通过UIManager查找属性的键。

protected String

SynthToggleButtonUI.getPropertyPrefix​()

返回属性前缀。

String

SynthStyle.getString​(SynthContext context, Object key, String defaultValue)

方便的方法来获取一个特定的style属性，其值是一个String。

String

SynthGraphicsUtils.layoutText​(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)

通过引用将文本和图标返回，放置图标和文本的位置。

String

ColorType.toString​()

返回此 ColorType的文字描述。

String

Region.toString​()

返回Region的名称。

Methods in javax.swing.plaf.synth with parameters of type String

Modifier and Type

方法

描述

int

SynthGraphicsUtils.computeStringWidth​(SynthContext ss, Font font, FontMetrics metrics, String text)

返回传入的字符串的大小。

Dimension

SynthGraphicsUtils.getMaximumSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)

返回正确呈现图标和文本所需的最大大小。

Dimension

SynthGraphicsUtils.getMinimumSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)

返回正确呈现图标和文本所需的最小尺寸。

Dimension

SynthGraphicsUtils.getPreferredSize​(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)

返回正确呈现图标和文字所需的首选大小。

String

SynthStyle.getString​(SynthContext context, Object key, String defaultValue)

方便的方法来获取一个特定的style属性，其值是一个String。

String

SynthGraphicsUtils.layoutText​(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)

通过引用将文本和图标返回，放置图标和文本的位置。

void

SynthGraphicsUtils.paintText​(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex)

在指定位置绘制文本。

void

SynthGraphicsUtils.paintText​(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex)

在指定位置绘制文本。

void

SynthGraphicsUtils.paintText​(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset)

画一个图标和文字。

protected void

SynthProgressBarUI.paintText​(SynthContext context, Graphics g, String title)

绘制组件的文本。

Constructors in javax.swing.plaf.synth with parameters of type String

Constructor

描述

ColorType​(String description)

创建一个带有指定说明的新ColorType。

Region​(String name, String ui, boolean subregion)

创建具有指定名称的区域。

Uses of String in javax.swing.table

Fields in javax.swing.table declared as String

Modifier and Type

Field

描述

static String

TableColumn.CELL_RENDERER_PROPERTY

作为Java 2平台v1.3的过时。

static String

TableColumn.COLUMN_WIDTH_PROPERTY

作为Java 2平台v1.3的过时。

static String

TableColumn.HEADER_RENDERER_PROPERTY

作为Java 2平台v1.3的过时。

static String

TableColumn.HEADER_VALUE_PROPERTY

作为Java 2平台v1.3的过时。

Methods in javax.swing.table that return String

Modifier and Type

方法

描述

String

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleDescription​()

String

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleName​()

String

AbstractTableModel.getColumnName​(int column)

使用电子表格约定返回列的默认名称：A，B，C，...

String

DefaultTableModel.getColumnName​(int column)

返回列名。

String

TableModel.getColumnName​(int columnIndex)

返回列的名称为 columnIndex 。

String

JTableHeader.getToolTipText​(MouseEvent event)

允许渲染器的提示被使用，如果有文本集。

String

JTableHeader.getUIClassID​()

返回用于构造用于渲染此组件的外观（L＆F）类的名称的后缀。

protected String

JTableHeader.paramString​()

返回此 JTableHeader的字符串表示 JTableHeader 。

abstract String

TableStringConverter.toString​(TableModel model, int row, int column)

返回指定位置的值的字符串表示形式。

Methods in javax.swing.table with parameters of type String

Modifier and Type

方法

描述

int

AbstractTableModel.findColumn​(String columnName)

返回一个给定其名称的列。

void

DefaultTableCellRenderer.firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)

由于性能原因而被覆盖。

protected void

DefaultTableCellRenderer.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

由于性能原因而被覆盖。

void

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setAccessibleDescription​(String s)

void

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setAccessibleName​(String s)

Uses of String in javax.swing.text

Fields in javax.swing.text declared as String

Modifier and Type

Field

描述

String

JTextComponent.KeyBinding.actionName

键的动作名称。

static String

DefaultEditorKit.backwardAction

将插入符号逻辑地向后移动一个位置的Action的名称。

protected static String

AbstractDocument.BAD_LOCATION

错误信息表示错误的位置。

static String

DefaultEditorKit.beepAction

创建哔声的动作名称。

static String

DefaultEditorKit.beginAction

将插入符号移动到文档开头的 Action名称。

static String

DefaultEditorKit.beginLineAction

Action名称，用于将插入符号移动到行的开头。

static String

DefaultEditorKit.beginParagraphAction

将插入符号移动到段落开头的 Action名称。

static String

DefaultEditorKit.beginWordAction

Action名称，用于将插入符号移动到单词的开头。

static String

AbstractDocument.BidiElementName

用于保持单向运行的元素的名称

static String

StyleConstants.ComponentElementName

用于表示组件的元素的名称。

static String

AbstractDocument.ContentElementName

用于表示内容的元素的名称

static String

DefaultEditorKit.copyAction

复制所选区域的操作名称，并将内容放入系统剪贴板。

static String

DefaultEditorKit.cutAction

要剪切所选区域并将内容放入系统剪贴板的操作名称。

static String

JTextComponent.DEFAULT_KEYMAP

所有 JTextComponent实例将共享的默认键盘映射，除非它们具有不同的键映射集。

static String

StyleContext.DEFAULT_STYLE

名称附加到段落的默认逻辑风格。

static String

DefaultEditorKit.defaultKeyTypedAction

默认情况下，如果接收到 键类型事件并且没有键映射条目，则执行的操作的名称。

static String

DefaultEditorKit.deleteNextCharAction

删除当前插入符位置后的内容的字符的操作名称。

static String

DefaultEditorKit.deleteNextWordAction

删除选择开始之后的单词的动作名称。

static String

DefaultEditorKit.deletePrevCharAction

删除当前插入符号位置前的内容字符的操作名称。

static String

DefaultEditorKit.deletePrevWordAction

要删除选择开始之前的单词的操作的名称。

static String

DefaultEditorKit.downAction

将插入符号向下移动一个位置的操作名称。

static String

AbstractDocument.ElementNameAttribute

用于指定元素名称的属性的名称。

static String

DefaultEditorKit.endAction

Action名称，用于将插入符号移动到文档的末尾。

static String

DefaultEditorKit.endLineAction

Action名称，用于将插入符号移动到行尾。

static String

DefaultEditorKit.EndOfLineStringProperty

当遇到CRLF时读取文档时，添加具有此名称的属性，该值将为“\ r \ n”。

static String

DefaultEditorKit.endParagraphAction

Action名称，用于将插入符号移动到段落的末尾。

static String

DefaultEditorKit.endWordAction

将插入符移动到单词末尾的操作名称。

static String

JTextComponent.FOCUS_ACCELERATOR_KEY

焦点加速器的绑定属性名称。

static String

DefaultEditorKit.forwardAction

将插入符号逻辑移动一个位置的操作名称。

static String

StyleConstants.IconElementName

用于表示图标的元素名称。

static String

DefaultEditorKit.insertBreakAction

将行/段落段落放入文档的操作名称。

static String

DefaultEditorKit.insertContentAction

将内容放入关联文档的操作名称。

static String

DefaultEditorKit.insertTabAction

将标签字符放入文档的操作名称。

static String

PlainDocument.lineLimitAttribute

如果有最大长度，则指定一行的最大长度的属性名称。

static String

DefaultEditorKit.nextWordAction

Action名称，用于将插入符号移动到下一个字的开头。

static String

DefaultEditorKit.pageDownAction

垂直向下翻页的动作名称。

static String

DefaultEditorKit.pageUpAction

要垂直翻页的动作名称。

static String

AbstractDocument.ParagraphElementName

用于表示段落的元素的名称

static String

DefaultEditorKit.pasteAction

将系统剪贴板的内容粘贴到所选区域或插入符之前的动作名称，如果未选择任何内容。

static String

DefaultEditorKit.previousWordAction

Action名称，用于将插入符号移动到上一个单词的开头。

static String

DefaultEditorKit.readOnlyAction

将编辑器设置为只读模式的操作名称。

static String

AbstractDocument.SectionElementName

用于保存部分的元素名称（行/段落）。

static String

DefaultEditorKit.selectAllAction

用于选择整个文档的操作的名称

static String

DefaultEditorKit.selectionBackwardAction

通过将插入符逻辑地向后移动一个位置来扩展选择的动作的名称。

static String

DefaultEditorKit.selectionBeginAction

Action名称，用于将插入符号移动到文档的开头。

static String

DefaultEditorKit.selectionBeginLineAction

Action名称，用于将插入符号移动到行的开头，扩展选择。

static String

DefaultEditorKit.selectionBeginParagraphAction

Action名称，用于将插入符号移动到段落的开头，扩展选择。

static String

DefaultEditorKit.selectionBeginWordAction

Action名称，用于将插入符号移动到单词的开头，扩展选择。

static String

DefaultEditorKit.selectionDownAction

将插入符号向下移动一个位置的操作的名称，扩展选择。

static String

DefaultEditorKit.selectionEndAction

将插入符移动到文档末尾的Action的名称。

static String

DefaultEditorKit.selectionEndLineAction

Action名称，用于将插入符号移动到行尾，扩展选择。

static String

DefaultEditorKit.selectionEndParagraphAction

Action名称，用于将插入符号移动到段落的末尾，扩展选择。

static String

DefaultEditorKit.selectionEndWordAction

将插入符号移动到单词结尾的Action的名称，扩展选择。

static String

DefaultEditorKit.selectionForwardAction

通过将插入符逻辑地向前移动一个位置来扩展选择的动作的名称。

static String

DefaultEditorKit.selectionNextWordAction

Action名称，用于将选择移动到下一个字的开头，扩展选择。

static String

DefaultEditorKit.selectionPreviousWordAction

Action名称，用于将选择移动到上一个单词的开头，扩展选择。

static String

DefaultEditorKit.selectionUpAction

将插入符号向上移动一个位置的操作的名称，扩展选择。

static String

DefaultEditorKit.selectLineAction

用于在插入符号周围选择一行的动作名称。

static String

DefaultEditorKit.selectParagraphAction

用于在插入符号周围选择一个段落的Action的名称。

static String

DefaultEditorKit.selectWordAction

在插入符号周围选择一个单词的动作名称。

static String

Document.StreamDescriptionProperty

用于初始化文档的流的描述的属性名称。

static String

PlainDocument.tabSizeAttribute

指定内容中包含的标签的标签大小的属性名称。

static String

Document.TitleProperty

文件标题的属性名称，如果有的话。

static String

DefaultEditorKit.upAction

将插入符号向上移动一个位置的操作名称。

static String

DefaultEditorKit.writableAction

将编辑器设置为可写模式的操作名称。

Methods in javax.swing.text that return String

Modifier and Type

方法

描述

String

JTextComponent.AccessibleJTextComponent.getAccessibleActionDescription​(int i)

返回对象的指定操作的描述。

String

JTextComponent.AccessibleJTextComponent.getAfterIndex​(int part, int index)

返回给定索引后的String。

String

JTextComponent.AccessibleJTextComponent.getAtIndex​(int part, int index)

返回给定索引处的String。

String

JTextComponent.AccessibleJTextComponent.getBeforeIndex​(int part, int index)

返回给定索引之前的String。

String

ChangedCharSetException.getCharSetSpec​()

返回字符集规范。

String

DefaultEditorKit.getContentType​()

获取此套件代表支持的数据的MIME类型。

abstract String

EditorKit.getContentType​()

获取此套件代表支持的数据的MIME类型。

static String

StyleConstants.getFontFamily​(AttributeSet a)

从属性列表中获取字体系列设置。

String

MaskFormatter.getInvalidCharacters​()

返回对输入无效的字符。

String

AbstractWriter.getLineSeparator​()

返回用于表示换行符的字符串。

String

MaskFormatter.getMask​()

返回格式化掩码。

String

AbstractDocument.AbstractElement.getName​()

获取元素的名称。

String

AbstractDocument.BranchElement.getName​()

获取元素名称。

String

AbstractDocument.LeafElement.getName​()

获取元素名称。

String

DefaultStyledDocument.SectionElement.getName​()

获取元素的名称。

String

Element.getName​()

获取元素的名称。

String

Keymap.getName​()

获取一组键绑定的名称。

String

Style.getName​()

获取样式的名称。

String

StyleContext.NamedStyle.getName​()

获取样式的名称。

String

MaskFormatter.getPlaceholder​()

如果值未完全填写掩码，则返回要使用的字符串。

String

AbstractDocument.DefaultDocumentEvent.getPresentationName​()

提供适用于（例如更改日志）的此编辑的本地化，可读取的描述。

String

AbstractDocument.DefaultDocumentEvent.getRedoPresentationName​()

提供本编辑的可重复形式的本地化，可读的描述，例如用作重做菜单项。

String

JTextComponent.AccessibleJTextComponent.getSelectedText​()

返回所选文本的部分。

String

JTextComponent.getSelectedText​()

返回此 TextComponent包含的选定文本。

String

AbstractDocument.Content.getString​(int where, int len)

获取序列中包含的一串字符。

String

GapContent.getString​(int where, int len)

检索一部分内容。

String

StringContent.getString​(int where, int len)

检索一部分内容。

String

AbstractDocument.getText​(int offset, int length)

从文档中获取文本序列。

protected String

AbstractWriter.getText​(Element elem)

返回与元素关联的文本。

String

Document.getText​(int offset, int length)

获取文档给定部分中包含的文本。

String

JTextComponent.getText​()

返回此 TextComponent包含的文本。

String

JTextComponent.getText​(int offs, int len)

获取由组件表示的文本的一部分。

String

JTextComponent.AccessibleJTextComponent.getTextRange​(int startIndex, int endIndex)

返回两个索引之间的文本字符串。

String

JTextComponent.getToolTipText​(MouseEvent event)

返回要用作 event的工具提示的 event 。

String

View.getToolTipText​(float x, float y, Shape allocation)

返回指定位置的工具提示文本。

String

AbstractDocument.DefaultDocumentEvent.getUndoPresentationName​()

提供本编辑的可撤销形式的本地化，可读的描述，例如用作撤消菜单项。

String

MaskFormatter.getValidCharacters​()

返回可以输入的有效字符。

protected String

JTextComponent.paramString​()

返回此 JTextComponent的字符串表示 JTextComponent 。

String

AbstractDocument.BranchElement.toString​()

将元素转换为字符串。

String

AbstractDocument.DefaultDocumentEvent.toString​()

返回更改事件的字符串描述。

String

AbstractDocument.LeafElement.toString​()

将元素转换为字符串。

String

DefaultCaret.toString​()

String

DefaultStyledDocument.ElementSpec.toString​()

将元素转换为字符串。

String

JTextComponent.DropLocation.toString​()

返回此放置位置的字符串表示形式。

String

Position.Bias.toString​()

字符串表示

String

Segment.toString​()

将段转换为字符串。

String

SimpleAttributeSet.toString​()

将属性集转换为字符串。

String

StyleConstants.toString​()

返回字符串表示形式。

String

StyleContext.NamedStyle.toString​()

将样式转换为字符串。

String

StyleContext.SmallAttributeSet.toString​()

返回一个显示键/值对的字符串。

String

StyleContext.toString​()

将StyleContext转换为字符串。

String

TabSet.toString​()

返回一组选项卡的字符串表示形式。

String

TabStop.toString​()

String

DefaultFormatter.valueToString​(Object value)

通过 toString方法将Object中传递的对象转换为字符串。

String

InternationalFormatter.valueToString​(Object value)

返回Object value的String表示 value 。

String

MaskFormatter.valueToString​(Object value)

根据掩码返回对象 value的字符串表示形式。

Methods in javax.swing.text with parameters of type String

Modifier and Type

方法

描述

static Keymap

JTextComponent.addKeymap​(String nm, Keymap parent)

在键盘层次结构中添加一个新的键盘映射。

Style

DefaultStyledDocument.addStyle​(String nm, Style parent)

在逻辑样式层次结构中添加新样式。

Style

StyleContext.addStyle​(String nm, Style parent)

在样式层次结构中添加新样式。

Style

StyledDocument.addStyle​(String nm, Style parent)

在逻辑样式层次结构中添加新样式。

Font

StyleContext.getFont​(String family, int style, int size)

获取一个新的字体。

static Keymap

JTextComponent.getKeymap​(String nm)

获取先前添加到文档的命名键盘映射。

Style

DefaultStyledDocument.getStyle​(String nm)

获取先前添加的命名样式。

Style

StyleContext.getStyle​(String nm)

获取先前添加到文档的命名样式

Style

StyledDocument.getStyle​(String nm)

获取先前添加的命名样式。

UndoableEdit

AbstractDocument.Content.insertString​(int where, String str)

在序列中插入一串字符。

void

AbstractDocument.insertString​(int offs, String str, AttributeSet a)

在文档中插入一些内容。

void

Document.insertString​(int offset, String str, AttributeSet a)

插入一串内容。

abstract void

DocumentFilter.FilterBypass.insertString​(int offset, String string, AttributeSet attr)

插入指定的文本，绕过DocumentFilter。

void

DocumentFilter.insertString​(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)

在将文本插入指定的文档之前调用。

UndoableEdit

GapContent.insertString​(int where, String str)

在内容中插入一个字符串。

void

PlainDocument.insertString​(int offs, String str, AttributeSet a)

在文档中插入一些内容。

UndoableEdit

StringContent.insertString​(int where, String str)

在内容中插入一个字符串。

void

JTextComponent.AccessibleJTextComponent.insertTextAtIndex​(int index, String s)

在指定的索引处插入指定的字符串

static Keymap

JTextComponent.removeKeymap​(String nm)

删除以前添加到文档的命名键盘映射。

void

DefaultStyledDocument.removeStyle​(String nm)

删除之前添加到文档的命名样式。

void

StyleContext.removeStyle​(String nm)

删除之前添加到文档的命名样式。

void

StyledDocument.removeStyle​(String nm)

删除之前添加到文档的命名样式。

void

AbstractDocument.replace​(int offset, int length, String text, AttributeSet attrs)

将文本区域从 offset删除为 offset + length ，并将其替换为 text 。

abstract void

DocumentFilter.FilterBypass.replace​(int offset, int length, String string, AttributeSet attrs)

将文本区域从 offset删除为 offset + length ，并将其替换为 text 。

void

DocumentFilter.replace​(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)

在替换指定文档中的文本区域之前调用。

void

JTextComponent.replaceSelection​(String content)

用给定字符串表示的新内容替换当前所选内容。

void

JTextComponent.AccessibleJTextComponent.replaceText​(int startIndex, int endIndex, String s)

用指定的字符串替换两个索引之间的文本。

static void

StyleConstants.setFontFamily​(MutableAttributeSet a, String fam)

设置字体属性。

void

MaskFormatter.setInvalidCharacters​(String invalidCharacters)

允许进一步限制可以输入的字符。

void

AbstractWriter.setLineSeparator​(String value)

设置用于表示换行符的字符串。

void

MaskFormatter.setMask​(String mask)

设置掩码规定合法字符。

void

StyleContext.NamedStyle.setName​(String name)

更改样式的名称。

void

MaskFormatter.setPlaceholder​(String placeholder)

如果值未完全填写掩码，则设置要使用的字符串。

void

JTextComponent.setText​(String t)

将此 TextComponent的文本设置为指定的文本。

void

JTextComponent.AccessibleJTextComponent.setTextContents​(String s)

将文本内容设置为指定的字符串。

void

MaskFormatter.setValidCharacters​(String validCharacters)

允许进一步限制可以输入的字符。

Object

DefaultFormatter.stringToValue​(String string)

通过使用String参数的构造函数将String中的传递转换为 getValueClass的实例。

Object

InternationalFormatter.stringToValue​(String text)

返回 Object的表示 String text 。

Object

MaskFormatter.stringToValue​(String value)

解析文本，返回字符串 value的相应对象表示 value 。

protected void

AbstractWriter.write​(String content)

写出一个字符串。

Constructors in javax.swing.text with parameters of type String

Constructor

描述

AlignmentAction​(String nm, int a)

创建一个新的AlignmentAction。

BadLocationException​(String s, int offs)

创建一个新的BadLocationException对象。

ChangedCharSetException​(String charSetSpec, boolean charSetKey)

构造一个 ChangedCharSetException 。

FontFamilyAction​(String nm, String family)

创建一个新的FontFamilyAction。

FontSizeAction​(String nm, int size)

创建一个新的FontSizeAction。

ForegroundAction​(String nm, Color fg)

创建一个新的ForegroundAction。

KeyBinding​(KeyStroke key, String actionName)

创建一个新的键绑定。

MaskFormatter​(String mask)

使用指定的掩码创建一个 MaskFormatter 。

NamedStyle​(String name, Style parent)

创建一个新的命名样式。

StyledTextAction​(String nm)

从字符串操作名称创建一个新的StyledTextAction。

TextAction​(String name)

创建一个新的JTextAction对象。

Uses of String in javax.swing.text.html

Fields in javax.swing.text.html declared as String

Modifier and Type

Field

描述

static String

HTMLDocument.AdditionalComments

文档属性键值。

static String

HTMLEditorKit.BOLD_ACTION

粗体动作标识符

static String

HTMLEditorKit.COLOR_ACTION

颜色选择动作标识符颜色作为参数传递

static String

HTMLEditorKit.DEFAULT_CSS

默认级联样式表文件，用于设置标签视图。

static String

HTMLEditorKit.FONT_CHANGE_BIGGER

字体大小增加到下一个值动作标识符

static String

HTMLEditorKit.FONT_CHANGE_SMALLER

字体大小减小到下一个值动作标识符

protected String

HTMLEditorKit.InsertHTMLTextAction.html

HTML插入。

static String

HTMLEditorKit.IMG_ALIGN_BOTTOM

将图像对齐在底部。

static String

HTMLEditorKit.IMG_ALIGN_MIDDLE

在中间对齐图像。

static String

HTMLEditorKit.IMG_ALIGN_TOP

将图像对齐在顶部。

static String

HTMLEditorKit.IMG_BORDER

在边框对齐图像。

static String

HTMLEditorKit.ITALIC_ACTION

斜体动作标识符

static String

HTMLEditorKit.LOGICAL_STYLE_ACTION

逻辑样式选择动作标识符逻辑样式作为参数传入

static String

HTML.NULL_ATTRIBUTE_VALUE

NULL_ATTRIBUTE_VALUE用于未指定属性值的情况。

static String

HTMLEditorKit.PARA_INDENT_LEFT

段落为缩进动作标识符

static String

HTMLEditorKit.PARA_INDENT_RIGHT

段落正确的缩进动作标识符

static String

FormView.RESET

已过时。
从1.3开始，值来自UIManager UIManager属性FormView.resetButtonText

static String

FormView.SUBMIT

已过时。
从1.3起，现在的值来自UIManager属性FormView.submitButtonText

Methods in javax.swing.text.html that return String

Modifier and Type

方法

描述

String

ImageView.getAltText​()

如果图像无法加载，返回要显示的文本。

String

HTMLEditorKit.getContentType​()

获取此套件代表支持的数据的MIME类型。

String

FormSubmitEvent.getData​()

获取表单提交数据。

String

CSS.Attribute.getDefaultValue​()

获取属性的默认值。

String

Option.getLabel​()

获取与该选项相关联的标签。

String

HTMLDocument.BlockElement.getName​()

获取元素的名称。

String

HTMLDocument.RunElement.getName​()

获取元素的名称。

String

HTMLFrameHyperlinkEvent.getTarget​()

返回链接的目标。

String

ImageView.getToolTipText​(float x, float y, Shape allocation)

对于图像，工具提示文本来自使用 ALT属性指定的文本。

String

Option.getValue​()

方便返回与 value相关联的字符串属性。

String

CSS.Attribute.toString​()

属性的字符串表示形式。

String

HTML.Attribute.toString​()

返回此属性的字符串表示形式。

String

HTML.Tag.toString​()

返回标签的字符串表示形式。

String

Option.toString​()

字符串表示是标签。

Methods in javax.swing.text.html with parameters of type String

Modifier and Type

方法

描述

void

StyleSheet.addCSSAttribute​(MutableAttributeSet attr, CSS.Attribute key, String value)

将CSS属性添加到给定的集合。

boolean

StyleSheet.addCSSAttributeFromHTML​(MutableAttributeSet attr, CSS.Attribute key, String value)

将CSS属性添加到给定的集合。

void

StyleSheet.addRule​(String rule)

在工作表中添加一组规则。

static CSS.Attribute

CSS.getAttribute​(String name)

将字符串转换为 CSS.Attribute对象。

static HTML.Attribute

HTML.getAttributeKey​(String attName)

获取一个众所周知的属性名称的属性常量（即集合{FACE，COMMENT，SIZE，COLOR，CLEAR，BACKGROUND，BGCOLOR，TEXT，LINK，VLINK，ALINK，WIDTH，HEIGHT，ALIGN，NAME ，HREF，REL，REV，TITLE，TARGET，SHAPE，COORDS，ISMAP，NOHREF，ALT，ID，SRC，HSPACE，VSPACE，USEMAP，LOWSRC，CODEBASE，CODE，ARCHIVE，VALUE，VALUETYPE，TYPE，CLASS，STYLE，LANG ，DIR，DECLARE，CLASSID，DATA，CODETYPE，STANDBY，BORDER，SHAPES，NOSHADE，COMPACT，START，ACTION，METHOD，ENCTYPE，CHECKED，MAXLENGTH，MULTIPLE，SELECTED，ROWS，COLS，DUMMY，CELLSPACING，CELLPADDING，VALIGN，HALIGN ，NOWRAP，ROWSPAN，COLSPAN，PROMPT，HTTPEQUIV，CONTENT，LANGUAGE，VERSION，N，FRAMEBORDER，MARGINWIDTH，MARGINHEIGHT，SCROLLING，NORESIZE，MEDIA，ENDTAG}）。

AttributeSet

StyleSheet.getDeclaration​(String decl)

将CSS声明转换为表示CSS声明的AttributeSet。

Element

HTMLDocument.getElement​(String id)

返回给定id为 Attribute的元素。

float

StyleSheet.getPointSize​(String size)

给定一个字符串，如“+2”，“-2”或“2”，返回一个点大小值。

Style

StyleSheet.getRule​(String selector)

获取与字符串形式给出的选择器最匹配的规则。

static HTML.Tag

HTML.getTag​(String tagName)

获取一个公知标签名称的标签常量（即集合{A，ADDRESS，APPLET，AREA，B，BASE，BASEFONT，BIG，BLOCKQUOTE，BODY，BR，CAPTION，CENTER，CITE，CODE中的一个标签，DD，DFN，DIR，DIV，DL，DT，EM，FONT，FORM，FRAME，FRAMESET，H1，H2，H3，H4，H5，H6，HEAD，HR，HTML，I，IMG，INPUT，ISINDEX，KBD ，LI，LINK，MAP，MENU，META，NOBR，NOFRAMES，OBJECT，OL，OPTION，P，PARAM，PRE，SAMP，SCRIPT，SELECT，SMALL，SPAN，STRIKE，S，STRONG，STYLE，SUB，SUP，TABLE ，TD，TEXTAREA，TH，TITLE，TR，TT，U，UL，VAR}。

void

HTMLDocument.HTMLReader.handleEndOfLineString​(String eol)

在流已经被解析后，但在 flush之前 flush 。

void

HTMLEditorKit.ParserCallback.handleEndOfLineString​(String eol)

在流已经被解析之后调用，但在 flush之前。

void

HTMLEditorKit.ParserCallback.handleError​(String errorMsg, int pos)

从解析器回调。

protected void

FormView.imageSubmit​(String imageData)

调用此方法以响应点击图像 - “image”类型的<INPUT>表单元素提交表单。

void

HTMLDocument.insertAfterEnd​(Element elem, String htmlText)

在给定元素结束后插入指定为字符串的HTML。

void

HTMLDocument.insertAfterStart​(Element elem, String htmlText)

在元素的开始处插入指定为字符串的HTML。

protected void

HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary​(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)

在插入边界时调用这一点。

protected void

HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry​(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)

已过时。
从Java 2平台v1.3开始，使用insertAtBoundary

void

HTMLDocument.insertBeforeEnd​(Element elem, String htmlText)

在元素的末尾插入指定为字符串的HTML。

void

HTMLDocument.insertBeforeStart​(Element elem, String htmlText)

在给定元素开始之前插入指定为字符串的HTML。

void

HTMLEditorKit.insertHTML​(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)

将HTML插入到现有文档中。

protected void

HTMLEditorKit.InsertHTMLTextAction.insertHTML​(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)

HTMLEditorKit.insertHTML的封面。

void

StyleSheet.removeStyle​(String nm)

删除之前添加到文档的命名样式。

void

StyleSheet.setBaseFontSize​(String size)

从String中传递的基本字体大小设置。

void

HTMLDocument.setInnerHTML​(Element elem, String htmlText)

用指定为HTML字符串的内容替换给定元素的子元素。

void

Option.setLabel​(String label)

设置要用于该选项的标签。

void

HTMLDocument.setOuterHTML​(Element elem, String htmlText)

用指定为HTML字符串的内容替换父项中的给定元素。

protected void

MinimalHTMLWriter.startFontTag​(String style)

这不再使用，而是会写出<span>。

Color

StyleSheet.stringToColor​(String string)

将颜色串（例如“RED”或“#NNNNNN”）转换为颜色。

protected void

FormView.submitData​(String data)

此方法负责提交表单数据。

static FormSubmitEvent.MethodType

FormSubmitEvent.MethodType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

protected void

MinimalHTMLWriter.writeEndTag​(String endTag)

写出一个适合缩进的结束标签。

protected void

MinimalHTMLWriter.writeStartTag​(String tag)

写出一个适当缩进的开始标签。

Constructors in javax.swing.text.html with parameters of type String

Constructor

描述

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)

创建一个表示html框架超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)

创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)

创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)

创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent​(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)

创建一个表示超文本链接事件的新对象。

HTMLTextAction​(String name)

从字符串操作名称创建一个新的HTMLTextAction。

InsertHTMLTextAction​(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)

创建一个新的InsertHTMLTextAction。

InsertHTMLTextAction​(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

创建一个新的InsertHTMLTextAction。

Tag​(String id)

创建一个新的 Tag与指定的 id ，并与 causesBreak和 isBlock设置为 false 。

Tag​(String id, boolean causesBreak, boolean isBlock)

创建一个新的Tag与指定的id ; causesBreak和isBlock由用户定义。

UnknownTag​(String id)

创建一个新的 UnknownTag与指定的 id 。

Uses of String in javax.swing.text.html.parser

Fields in javax.swing.text.html.parser declared as String

Modifier and Type

Field

描述

String

AttributeList.name

属性名称

String

DTD.name

DTD的名称

String

Element.name

元素的名称

String

Entity.name

实体的名称。

String

AttributeList.value

默认属性值

Fields in javax.swing.text.html.parser with type parameters of type String

Modifier and Type

Field

描述

Hashtable<String,Element>

DTD.elementHash

散列表包含元素的名称和相应的元素。

Methods in javax.swing.text.html.parser that return String

Modifier and Type

方法

描述

String

AttributeList.getName​()

String

DTD.getName​()

获取DTD的名称。

String

Element.getName​()

获取元素的名称。

String

Entity.getName​()

获取实体的名称。

String

Entity.getString​()

以 String返回数据。

String

AttributeList.getValue​()

String

Parser.parseDTDMarkup​()

解析文档类型声明标记声明。

String

AttributeList.toString​()

String

ContentModel.toString​()

转换成字符串。

String

DTD.toString​()

返回此DTD的字符串表示形式。

String

Element.toString​()

转换成字符串。

static String

AttributeList.type2name​(int tp)

将类型转换为属性名称

Methods in javax.swing.text.html.parser with parameters of type String

Modifier and Type

方法

描述

protected static DTD

ParserDelegator.createDTD​(DTD dtd, String name)

使用指定的 name从归档格式重新创建DTD。

protected AttributeList

DTD.defAttributeList​(String name, int type, int modifier, String value, String values, AttributeList atts)

创建并返回一个 AttributeList响应一个新属性。

protected Element

DTD.defElement​(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)

创建并返回一个 Element 。

Entity

DTD.defEntity​(String name, int type, int ch)

创建并返回一个字符 Entity 。

protected Entity

DTD.defEntity​(String name, int type, String str)

创建并返回一个 Entity 。

void

DTD.defineAttributes​(String name, AttributeList atts)

定义 Element属性。

Element

DTD.defineElement​(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)

返回匹配指定参数的 Element 。

Entity

DTD.defineEntity​(String name, int type, char[] data)

定义一个实体。

protected void

Parser.error​(String err)

使用第1，第2和第3个错误消息参数“？”调用错误处理程序。

protected void

Parser.error​(String err, String arg1)

使用第2和第3个错误消息参数“？”调用错误处理程序。

protected void

Parser.error​(String err, String arg1, String arg2)

使用第三个错误消息参数“？”调用错误处理程序。

protected void

Parser.error​(String err, String arg1, String arg2, String arg3)

调用错误处理程序。

AttributeList

Element.getAttribute​(String name)

通过名称获取属性。

AttributeList

Element.getAttributeByValue​(String value)

通过值获取属性。

static DTD

DTD.getDTD​(String name)

返回具有指定的 name的DTD。

Element

DTD.getElement​(String name)

通过名称获取元素。

Entity

DTD.getEntity​(String name)

通过名称获取实体。

protected void

DocumentParser.handleError​(int ln, String errorMsg)

protected void

Parser.handleError​(int ln, String msg)

发生了错误。

static int

AttributeList.name2type​(String nm)

将属性名称转换为类型

static int

Element.name2type​(String nm)

转换 nm进行输入。

static int

Entity.name2type​(String nm)

将 nm字符串转换为相应的实体类型。

static void

DTD.putDTDHash​(String name, DTD dtd)

将名称和适当的DTD放在散列表中。

Constructors in javax.swing.text.html.parser with parameters of type String

Constructor

描述

AttributeList​(String name)

创建属性列表元素。

AttributeList​(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)

创建属性列表元素。

DTD​(String name)

创建具有指定名称的新DTD。

Entity​(String name, int type, char[] data)

创建一个实体。

Uses of String in javax.swing.text.rtf

Methods in javax.swing.text.rtf that return String

Modifier and Type

方法

描述

String

RTFEditorKit.getContentType​()

获取此套件代表支持的数据的MIME类型。

Uses of String in javax.swing.tree

Fields in javax.swing.tree declared as String

Modifier and Type

Field

描述

static String

DefaultTreeSelectionModel.SELECTION_MODE_PROPERTY

selectionMode的属性名称。

Methods in javax.swing.tree that return String

Modifier and Type

方法

描述

String

DefaultMutableTreeNode.toString​()

返回向该节点的用户对象发送 toString()的结果，如果节点没有用户对象，则返回空字符串。

String

DefaultTreeSelectionModel.toString​()

返回显示和标识此对象属性的字符串。

String

TreePath.toString​()

返回显示和标识此对象属性的字符串。

Methods in javax.swing.tree with parameters of type String

Modifier and Type

方法

描述

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, boolean oldValue, boolean newValue)

由于性能原因而被覆盖。

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, byte oldValue, byte newValue)

由于性能原因而被覆盖。

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, char oldValue, char newValue)

由于性能原因而被覆盖。

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, double oldValue, double newValue)

由于性能原因而被覆盖。

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, float oldValue, float newValue)

由于性能原因而被覆盖。

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, int oldValue, int newValue)

由于性能原因而被覆盖。

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, long oldValue, long newValue)

由于性能原因而被覆盖。

void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, short oldValue, short newValue)

由于性能原因而被覆盖。

protected void

DefaultTreeCellRenderer.firePropertyChange​(String propertyName, Object oldValue, Object newValue)

由于性能原因而被覆盖。

Constructors in javax.swing.tree with parameters of type String

Constructor

描述

ExpandVetoException​(TreeExpansionEvent event, String message)

构造具有指定消息的ExpandVetoException对象。

Uses of String in javax.swing.undo

Fields in javax.swing.undo declared as String

Modifier and Type

Field

描述

protected static String

StateEdit.RCSID

过时的RCS版本身份。

static String

StateEditable.RCSID

此类的资源ID。

protected static String

AbstractUndoableEdit.RedoName

字符串返回getRedoPresentationName ; 从Java 2平台v1.3.1开始，此字段不再使用。

protected static String

AbstractUndoableEdit.UndoName

字符串返回getUndoPresentationName ; 从Java 2平台v1.3.1开始，此字段不再使用。

protected String

StateEdit.undoRedoName

撤消/重做演示文稿名称

Methods in javax.swing.undo that return String

Modifier and Type

方法

描述

String

AbstractUndoableEdit.getPresentationName​()

此默认实现返回“”。

String

CompoundEdit.getPresentationName​()

从最后 UndoableEdit返回 getPresentationName加到 edits 。

String

StateEdit.getPresentationName​()

获取此编辑的演示文稿名称

String

UndoableEdit.getPresentationName​()

例如，返回适用于更改日志的本编辑的本地化，可读取的描述。

String

AbstractUndoableEdit.getRedoPresentationName​()

使用关键字 AbstractUndoableEdit.redoText从默认值表中检索值，并返回该值后跟空格，后跟 getPresentationName 。

String

CompoundEdit.getRedoPresentationName​()

从最后 UndoableEdit返回 getRedoPresentationName加到 edits 。

String

UndoableEdit.getRedoPresentationName​()

返回适用于例如Redo菜单项的本编辑的可重写形式的本地化，可读的描述。

String

UndoManager.getRedoPresentationName​()

返回此修改的可重写形式的描述。

String

UndoManager.getUndoOrRedoPresentationName​()

方便方法返回 getUndoPresentationName或 getRedoPresentationName 。

String

AbstractUndoableEdit.getUndoPresentationName​()

使用关键字 AbstractUndoableEdit.undoText从默认表中检索值，并返回该值后跟一个空格，后跟 getPresentationName 。

String

CompoundEdit.getUndoPresentationName​()

返回 getUndoPresentationName从最后的 UndoableEdit添加到 edits 。

String

UndoableEdit.getUndoPresentationName​()

返回适用于例如撤消菜单项的此编辑的可撤销形式的本地化，可读的描述。

String

UndoManager.getUndoPresentationName​()

返回此修改的可撤销形式的描述。

String

AbstractUndoableEdit.toString​()

返回显示和标识此对象属性的字符串。

String

CompoundEdit.toString​()

返回显示和标识此对象属性的字符串。

String

UndoableEditSupport.toString​()

返回显示和标识此对象属性的字符串。

String

UndoManager.toString​()

返回显示和标识此对象属性的字符串。

Methods in javax.swing.undo with parameters of type String

Modifier and Type

方法

描述

protected void

StateEdit.init​(StateEditable anObject, String name)

初始化状态编辑。

Constructors in javax.swing.undo with parameters of type String

Constructor

描述

StateEdit​(StateEditable anObject, String name)

创建并返回一个新的StateEdit与演示名称。

Uses of String in javax.tools

Fields in javax.tools declared as String

Modifier and Type

Field

描述

String

JavaFileObject.Kind.extension

通常用于这种文件对象的扩展。

Methods in javax.tools that return String

Modifier and Type

方法

描述

String

Diagnostic.getCode​()

返回指示诊断类型的诊断代码。

String

Diagnostic.getMessage​(Locale locale)

返回给定区域设置的本地化消息。

String

DocumentationTool.Location.getName​()

String

FileObject.getName​()

返回此文件对象的用户友好名称。

String

ForwardingFileObject.getName​()

String

JavaFileManager.Location.getName​()

返回此位置的名称。

String

SimpleJavaFileObject.getName​()

String

StandardLocation.getName​()

String

ForwardingJavaFileManager.inferBinaryName​(JavaFileManager.Location location, JavaFileObject file)

String

JavaFileManager.inferBinaryName​(JavaFileManager.Location location, JavaFileObject file)

基于面向包的位置来触发文件对象的二进制名称。

String

ForwardingJavaFileManager.inferModuleName​(JavaFileManager.Location location)

default String

JavaFileManager.inferModuleName​(JavaFileManager.Location location)

从其位置输入模块的名称，如 getLocationForModule或 listModuleLocations 。

default String

Tool.name​()

返回此工具的名称，如果未提供名称，则返回空字符串。

String

SimpleJavaFileObject.toString​()

Methods in javax.tools with parameters of type String

Modifier and Type

方法

描述

FileObject

ForwardingJavaFileManager.getFileForInput​(JavaFileManager.Location location, String packageName, String relativeName)

FileObject

JavaFileManager.getFileForInput​(JavaFileManager.Location location, String packageName, String relativeName)

返回file object用于表示指定的输入relative name中指定的包在给定的取向包位置。

FileObject

ForwardingJavaFileManager.getFileForOutput​(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)

FileObject

JavaFileManager.getFileForOutput​(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)

返回file object用于表示指定的输出relative name中指定的包在给定的位置。

JavaFileObject

ForwardingJavaFileManager.getJavaFileForInput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)

JavaFileObject

JavaFileManager.getJavaFileForInput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)

返回一个file object，用于在给定的面向对象的位置中表示指定类型的指定类的输入。

JavaFileObject

ForwardingJavaFileManager.getJavaFileForOutput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)

JavaFileObject

JavaFileManager.getJavaFileForOutput​(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)

返回一个file object，用于在给定的面向包的位置中表示指定类型的指定类的输出。

Iterable<? extends JavaFileObject>

StandardJavaFileManager.getJavaFileObjects​(String... names)

返回表示给定文件名的文件对象。

JavaFileManager.Location

ForwardingJavaFileManager.getLocationForModule​(JavaFileManager.Location location, String moduleName)

default JavaFileManager.Location

JavaFileManager.getLocationForModule​(JavaFileManager.Location location, String moduleName)

在位置中获取命名模块的位置，该位置可以是面向模块的位置或输出位置。

Path

StandardJavaFileManager.PathFactory.getPath​(String first, String... more)

将路径字符串或将路径字符串连接时的字符串序列转换为路径。

boolean

ForwardingJavaFileManager.handleOption​(String current, Iterator<String> remaining)

boolean

JavaFileManager.handleOption​(String current, Iterator<String> remaining)

处理一个选项

boolean

ForwardingJavaFileObject.isNameCompatible​(String simpleName, JavaFileObject.Kind kind)

boolean

JavaFileObject.isNameCompatible​(String simpleName, JavaFileObject.Kind kind)

检查此文件对象是否与指定的简单名称和种类兼容。

boolean

SimpleJavaFileObject.isNameCompatible​(String simpleName, JavaFileObject.Kind kind)

此实现将其URI的路径与给定的简单名称进行比较。

int

ForwardingJavaFileManager.isSupportedOption​(String option)

int

OptionChecker.isSupportedOption​(String option)

确定给定选项是否受支持，如果是，该选项的参数数量。

Iterable<JavaFileObject>

ForwardingJavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)

Iterable<JavaFileObject>

JavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)

列出与给定的面向对象位置匹配的所有文件对象。

static JavaFileManager.Location

StandardLocation.locationFor​(String name)

返回具有给定名称的位置对象。

int

Tool.run​(InputStream in, OutputStream out, OutputStream err, String... arguments)

使用给定的I / O通道和参数运行该工具。

default void

StandardJavaFileManager.setLocationForModule​(JavaFileManager.Location location, String moduleName, Collection<? extends Path> paths)

将给定的搜索路径与给定的模块和位置相关联，该模块和位置必须是面向模块或输出位置。

static Diagnostic.Kind

Diagnostic.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static DocumentationTool.Location

DocumentationTool.Location.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static JavaFileObject.Kind

JavaFileObject.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StandardLocation

StandardLocation.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in javax.tools with type arguments of type String

Modifier and Type

方法

描述

void

DocumentationTool.DocumentationTask.addModules​(Iterable<String> moduleNames)

在模块解析期间添加要考虑的根模块。

void

JavaCompiler.CompilationTask.addModules​(Iterable<String> moduleNames)

在模块解析期间添加要考虑的根模块。

Iterable<? extends JavaFileObject>

StandardJavaFileManager.getJavaFileObjectsFromStrings​(Iterable<String> names)

返回表示给定文件名的文件对象。

DocumentationTool.DocumentationTask

DocumentationTool.getTask​(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)

使用给定的组件和参数为文档任务创建未来。

JavaCompiler.CompilationTask

JavaCompiler.getTask​(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)

使用给定的组件和参数创建编译任务的未来。

boolean

ForwardingJavaFileManager.handleOption​(String current, Iterator<String> remaining)

boolean

JavaFileManager.handleOption​(String current, Iterator<String> remaining)

处理一个选项

Uses of String in javax.transaction

Constructors in javax.transaction with parameters of type String

Constructor

描述

InvalidTransactionException​(String msg)

构造一个 InvalidTransactionException 。

TransactionRequiredException​(String msg)

构造一个 TransactionRequiredException 。

TransactionRolledbackException​(String msg)

构造一个 TransactionRolledbackException 。

Uses of String in javax.transaction.xa

Constructors in javax.transaction.xa with parameters of type String

Constructor

描述

XAException​(String s)

用给定的字符串创建XAException。

Uses of String in javax.xml

Fields in javax.xml declared as String

Modifier and Type

Field

描述

static String

XMLConstants.ACCESS_EXTERNAL_DTD

属性：accessExternalDTD

static String

XMLConstants.ACCESS_EXTERNAL_SCHEMA

属性：accessExternalSchema

static String

XMLConstants.ACCESS_EXTERNAL_STYLESHEET

属性：accessExternalStylesheet

static String

XMLConstants.DEFAULT_NS_PREFIX

用于表示默认XML命名空间的前缀。

static String

XMLConstants.FEATURE_SECURE_PROCESSING

安全处理功能。

static String

XMLConstants.NULL_NS_URI

用于表示没有命名空间的命名空间URI。

static String

XMLConstants.RELAXNG_NS_URI

RELAX NG命名空间URI。

static String

XMLConstants.USE_CATALOG

功能：useCatalog

static String

XMLConstants.W3C_XML_SCHEMA_INSTANCE_NS_URI

W3C XML Schema实例命名空间URI。

static String

XMLConstants.W3C_XML_SCHEMA_NS_URI

W3C XML Schema命名空间URI。

static String

XMLConstants.W3C_XPATH_DATATYPE_NS_URI

W3C XPath数据类型命名空间URI。

static String

XMLConstants.XML_DTD_NS_URI

XML文档类型声明命名空间URI为任意值。

static String

XMLConstants.XML_NS_PREFIX

官方的XML命名空间前缀。

static String

XMLConstants.XML_NS_URI

官方XML命名空间名称URI。

static String

XMLConstants.XMLNS_ATTRIBUTE

用于指定XML命名空间声明的官方XML属性。

static String

XMLConstants.XMLNS_ATTRIBUTE_NS_URI

用于指定XML命名空间声明的官方XML属性， XMLConstants.XMLNS_ATTRIBUTE ，命名空间名称URI。

Uses of String in javax.xml.bind

Fields in javax.xml.bind declared as String

Modifier and Type

Field

描述

static String

JAXBContext.JAXB_CONTEXT_FACTORY

包含能够创建新的 JAXBContext对象的类的名称的属性的名称。

static String

Marshaller.JAXB_ENCODING

用于在编组的XML数据中指定输出编码的属性的名称。

static String

Marshaller.JAXB_FORMATTED_OUTPUT

用于指定编组的XML数据是否使用换行符和缩进格式化的属性的名称。

static String

Marshaller.JAXB_FRAGMENT

用于指定编组器是否生成文档级事件（即调用startDocument或endDocument）的属性的名称。

static String

Marshaller.JAXB_NO_NAMESPACE_SCHEMA_LOCATION

用于指定要排列在编组XML输出中的xsi：noNamespaceSchemaLocation属性值的属性名称。

static String

Marshaller.JAXB_SCHEMA_LOCATION

用于指定要排列在编组XML输出中的xsi：schemaLocation属性值的属性名称。

Methods in javax.xml.bind that return String

Modifier and Type

方法

描述

String

JAXBException.getErrorCode​()

获取供应商特定的错误代码

String

TypeConstraintException.getErrorCode​()

获取供应商特定的错误代码

String

ValidationEvent.getMessage​()

检索此警告/错误的短信。

static String

DatatypeConverter.parseAnySimpleType​(String lexicalXSDAnySimpleType)

返回一个包含简单类型的词法表示的字符串。

String

DatatypeConverterInterface.parseAnySimpleType​(String lexicalXSDAnySimpleType)

返回一个包含简单类型的词法表示的字符串。

static String

DatatypeConverter.parseString​(String lexicalXSDString)

将词法XSD字符串参数转换为字符串值。

String

DatatypeConverterInterface.parseString​(String lexicalXSDString)

将字符串参数转换为字符串。

static String

DatatypeConverter.printAnySimpleType​(String val)

将字符串值转换为字符串。

String

DatatypeConverterInterface.printAnySimpleType​(String val)

将字符串值转换为字符串。

static String

DatatypeConverter.printBase64Binary​(byte[] val)

将字节数组转换为字符串。

String

DatatypeConverterInterface.printBase64Binary​(byte[] val)

将字节数组转换为字符串。

static String

DatatypeConverter.printBoolean​(boolean val)

将布尔值转换为字符串。

String

DatatypeConverterInterface.printBoolean​(boolean val)

将布尔值转换为字符串。

static String

DatatypeConverter.printByte​(byte val)

将字节值转换为字符串。

String

DatatypeConverterInterface.printByte​(byte val)

将字节值转换为字符串。

static String

DatatypeConverter.printDate​(Calendar val)

将日历值转换为字符串。

String

DatatypeConverterInterface.printDate​(Calendar val)

将日历值转换为字符串。

static String

DatatypeConverter.printDateTime​(Calendar val)

将日历值转换为字符串。

String

DatatypeConverterInterface.printDateTime​(Calendar val)

将日历值转换为字符串。

static String

DatatypeConverter.printDecimal​(BigDecimal val)

将BigDecimal值转换为字符串。

String

DatatypeConverterInterface.printDecimal​(BigDecimal val)

将BigDecimal值转换为字符串。

static String

DatatypeConverter.printDouble​(double val)

将double值转换为字符串。

String

DatatypeConverterInterface.printDouble​(double val)

将double值转换为字符串。

static String

DatatypeConverter.printFloat​(float val)

将float值转换为字符串。

String

DatatypeConverterInterface.printFloat​(float val)

将float值转换为字符串。

static String

DatatypeConverter.printHexBinary​(byte[] val)

将字节数组转换为字符串。

String

DatatypeConverterInterface.printHexBinary​(byte[] val)

将字节数组转换为字符串。

static String

DatatypeConverter.printInt​(int val)

将int值转换为字符串。

String

DatatypeConverterInterface.printInt​(int val)

将int值转换为字符串。

static String

DatatypeConverter.printInteger​(BigInteger val)

将BigInteger值转换为字符串。

String

DatatypeConverterInterface.printInteger​(BigInteger val)

将BigInteger值转换为字符串。

static String

DatatypeConverter.printLong​(long val)

将长整型值转换为字符串。

String

DatatypeConverterInterface.printLong​(long val)

将一个长的值转换成一个字符串。

static String

DatatypeConverter.printQName​(QName val, NamespaceContext nsc)

将QName实例转换为字符串。

String

DatatypeConverterInterface.printQName​(QName val, NamespaceContext nsc)

将QName实例转换为字符串。

static String

DatatypeConverter.printShort​(short val)

将一个简短的值转换成一个字符串。

String

DatatypeConverterInterface.printShort​(short val)

将一个简短的值转换成一个字符串。

static String

DatatypeConverter.printString​(String val)

将字符串参数转换为字符串。

String

DatatypeConverterInterface.printString​(String val)

将字符串参数转换为字符串。

static String

DatatypeConverter.printTime​(Calendar val)

将日历值转换为字符串。

String

DatatypeConverterInterface.printTime​(Calendar val)

将日历值转换为字符串。

static String

DatatypeConverter.printUnsignedInt​(long val)

将一个长的值转换成一个字符串。

String

DatatypeConverterInterface.printUnsignedInt​(long val)

将一个长的值转换成一个字符串。

static String

DatatypeConverter.printUnsignedShort​(int val)

将int值转换为字符串。

String

DatatypeConverterInterface.printUnsignedShort​(int val)

将int值转换为字符串。

String

JAXBException.toString​()

返回此JAXBException的简短描述。

String

TypeConstraintException.toString​()

返回此TypeConstraintException的简短描述。

Methods in javax.xml.bind with parameters of type String

Modifier and Type

方法

描述

JAXBContext

JAXBContextFactory.createContext​(String contextPath, ClassLoader classLoader, Map<String,?> properties)

创建一个 JAXBContext类的新实例。

abstract Result

SchemaOutputResolver.createOutput​(String namespaceUri, String suggestedFileName)

决定在哪个模式文件（给定的命名空间URI）将被写入，并将其作为一个Result对象返回。

abstract Object

Binder.getProperty​(String name)

获取底层实现中的特定属性 Binder 。

Object

Marshaller.getProperty​(String name)

获取底层实现中的特定属性 Marshaller 。

Object

Unmarshaller.getProperty​(String name)

获取底层实现中的特定属性 Unmarshaller 。

Object

Validator.getProperty​(String name)

已过时。
自JAXB2.0起

static void

JAXB.marshal​(Object jaxbObject, String xml)

将Java对象树写入XML并将其存储到指定的位置。

static JAXBContext

JAXBContext.newInstance​(String contextPath)

创建一个新的 JAXBContext类的实例。

static JAXBContext

JAXBContext.newInstance​(String contextPath, ClassLoader classLoader)

创建一个新的 JAXBContext类的实例。

static JAXBContext

JAXBContext.newInstance​(String contextPath, ClassLoader classLoader, Map<String,?> properties)

创建一个新的 JAXBContext类的实例。

static String

DatatypeConverter.parseAnySimpleType​(String lexicalXSDAnySimpleType)

返回一个包含简单类型的词法表示的字符串。

String

DatatypeConverterInterface.parseAnySimpleType​(String lexicalXSDAnySimpleType)

返回一个包含简单类型的词法表示的字符串。

static byte[]

DatatypeConverter.parseBase64Binary​(String lexicalXSDBase64Binary)

将字符串参数转换为字节数组。

byte[]

DatatypeConverterInterface.parseBase64Binary​(String lexicalXSDBase64Binary)

将字符串参数转换为字节数组。

static boolean

DatatypeConverter.parseBoolean​(String lexicalXSDBoolean)

将字符串参数转换为布尔值。

boolean

DatatypeConverterInterface.parseBoolean​(String lexicalXSDBoolean)

将字符串参数转换为布尔值。

static byte

DatatypeConverter.parseByte​(String lexicalXSDByte)

将字符串参数转换为字节值。

byte

DatatypeConverterInterface.parseByte​(String lexicalXSDByte)

将字符串参数转换为字节值。

static Calendar

DatatypeConverter.parseDate​(String lexicalXSDDate)

将字符串参数转换为日历值。

Calendar

DatatypeConverterInterface.parseDate​(String lexicalXSDDate)

将字符串参数转换为日历值。

static Calendar

DatatypeConverter.parseDateTime​(String lexicalXSDDateTime)

将字符串参数转换为日历值。

Calendar

DatatypeConverterInterface.parseDateTime​(String lexicalXSDDateTime)

将字符串参数转换为日历值。

static BigDecimal

DatatypeConverter.parseDecimal​(String lexicalXSDDecimal)

将字符串参数转换为BigDecimal值。

BigDecimal

DatatypeConverterInterface.parseDecimal​(String lexicalXSDDecimal)

将字符串参数转换为BigDecimal值。

static double

DatatypeConverter.parseDouble​(String lexicalXSDDouble)

将字符串参数转换为双精度值。

double

DatatypeConverterInterface.parseDouble​(String lexicalXSDDouble)

将字符串参数转换为双精度值。

static float

DatatypeConverter.parseFloat​(String lexicalXSDFloat)

将字符串参数转换为浮点值。

float

DatatypeConverterInterface.parseFloat​(String lexicalXSDFloat)

将字符串参数转换为浮点值。

static byte[]

DatatypeConverter.parseHexBinary​(String lexicalXSDHexBinary)

将字符串参数转换为字节数组。

byte[]

DatatypeConverterInterface.parseHexBinary​(String lexicalXSDHexBinary)

将字符串参数转换为字节数组。

static int

DatatypeConverter.parseInt​(String lexicalXSDInt)

将字符串参数转换为int值。

int

DatatypeConverterInterface.parseInt​(String lexicalXSDInt)

将字符串参数转换为int值。

static BigInteger

DatatypeConverter.parseInteger​(String lexicalXSDInteger)

将字符串参数转换为BigInteger值。

BigInteger

DatatypeConverterInterface.parseInteger​(String lexicalXSDInteger)

将字符串参数转换为BigInteger值。

static long

DatatypeConverter.parseLong​(String lexicalXSDLong)

将字符串参数转换为长整型值。

long

DatatypeConverterInterface.parseLong​(String lexicalXSDLong)

将字符串参数转换为长整型值。

static QName

DatatypeConverter.parseQName​(String lexicalXSDQName, NamespaceContext nsc)

将字符串参数转换为字节值。

QName

DatatypeConverterInterface.parseQName​(String lexicalXSDQName, NamespaceContext nsc)

将字符串参数转换为QName值。

static short

DatatypeConverter.parseShort​(String lexicalXSDShort)

将字符串参数转换为短值。

short

DatatypeConverterInterface.parseShort​(String lexicalXSDShort)

将字符串参数转换为短值。

static String

DatatypeConverter.parseString​(String lexicalXSDString)

将词法XSD字符串参数转换为字符串值。

String

DatatypeConverterInterface.parseString​(String lexicalXSDString)

将字符串参数转换为字符串。

static Calendar

DatatypeConverter.parseTime​(String lexicalXSDTime)

将字符串参数转换为日历值。

Calendar

DatatypeConverterInterface.parseTime​(String lexicalXSDTime)

将字符串参数转换为日历值。

static long

DatatypeConverter.parseUnsignedInt​(String lexicalXSDUnsignedInt)

将字符串参数转换为长整型值。

long

DatatypeConverterInterface.parseUnsignedInt​(String lexicalXSDUnsignedInt)

将字符串参数转换为长整型值。

static int

DatatypeConverter.parseUnsignedShort​(String lexicalXSDUnsignedShort)

将字符串参数转换为int值。

int

DatatypeConverterInterface.parseUnsignedShort​(String lexicalXSDUnsignedShort)

将字符串参数转换为int值。

static String

DatatypeConverter.printAnySimpleType​(String val)

将字符串值转换为字符串。

String

DatatypeConverterInterface.printAnySimpleType​(String val)

将字符串值转换为字符串。

static String

DatatypeConverter.printString​(String val)

将字符串参数转换为字符串。

String

DatatypeConverterInterface.printString​(String val)

将字符串参数转换为字符串。

abstract void

Binder.setProperty​(String name, Object value)

在底层实现中设置特定的属性 Binder 。

void

Marshaller.setProperty​(String name, Object value)

在底层实现中设置特定属性 Marshaller 。

void

Unmarshaller.setProperty​(String name, Object value)

在底层实现中设置特定属性 Unmarshaller 。

void

Validator.setProperty​(String name, Object value)

已过时。
自JAXB2.0起

static <T> T

JAXB.unmarshal​(String xml, Class<T> type)

从给定的XML输入中读取Java对象树。

Method parameters in javax.xml.bind with type arguments of type String

Modifier and Type

方法

描述

JAXBContext

JAXBContextFactory.createContext​(Class<?>[] classesToBeBound, Map<String,?> properties)

创建一个 JAXBContext类的新实例。

JAXBContext

JAXBContextFactory.createContext​(String contextPath, ClassLoader classLoader, Map<String,?> properties)

创建一个新的 JAXBContext类的实例。

static JAXBContext

JAXBContext.newInstance​(Class<?>[] classesToBeBound, Map<String,?> properties)

创建一个 JAXBContext类的新实例。

static JAXBContext

JAXBContext.newInstance​(String contextPath, ClassLoader classLoader, Map<String,?> properties)

创建一个新的 JAXBContext类的实例。

Constructors in javax.xml.bind with parameters of type String

Constructor

描述

DataBindingException​(String message, Throwable cause)

JAXBException​(String message)

构造具有指定详细消息的JAXBException。

JAXBException​(String message, String errorCode)

构造具有指定的详细消息和供应商特定的错误代码的JAXBException。

JAXBException​(String message, String errorCode, Throwable exception)

构造具有指定的详细消息，供应商特定的错误代码和linkedException的JAXBException。

JAXBException​(String message, Throwable exception)

构造具有指定的详细消息和linkedException的JAXBException。

JAXBPermission​(String name)

创建具有指定名称的新JAXBPermission。

MarshalException​(String message)

使用指定的详细消息构造MarshalException。

MarshalException​(String message, String errorCode)

构造具有指定的详细消息和供应商特定的错误代码的MarshalException。

MarshalException​(String message, String errorCode, Throwable exception)

构造具有指定的详细消息，供应商特定的错误代码和linkedException的MarshalException。

MarshalException​(String message, Throwable exception)

使用指定的详细消息和linkedException构造MarshalException。

PropertyException​(String message)

使用指定的详细消息构造PropertyException。

PropertyException​(String name, Object value)

构造一个PropertyException，其消息字段是基于属性的名称和value.toString（）来设置的。

PropertyException​(String message, String errorCode)

构造具有指定的详细消息和供应商特定的错误代码的PropertyException。

PropertyException​(String message, String errorCode, Throwable exception)

使用指定的详细消息，供应商特定的错误代码和linkedException构造PropertyException。

PropertyException​(String message, Throwable exception)

使用指定的详细消息和linkedException构造PropertyException。

TypeConstraintException​(String message)

使用指定的详细消息构造TypeConstraintException。

TypeConstraintException​(String message, String errorCode)

构造具有指定的详细消息和供应商特定的错误代码的TypeConstraintException。

TypeConstraintException​(String message, String errorCode, Throwable exception)

构造具有指定的详细消息，供应商特定的错误代码和linkedException的TypeConstraintException。

TypeConstraintException​(String message, Throwable exception)

使用指定的详细消息和linkedException构造TypeConstraintException。

UnmarshalException​(String message)

使用指定的详细消息构造UnmarshalException。

UnmarshalException​(String message, String errorCode)

使用指定的详细消息和供应商特定的错误代码构造UnmarshalException。

UnmarshalException​(String message, String errorCode, Throwable exception)

构造具有指定的详细消息，供应商特定的错误代码和linkedException的UnmarshalException。

UnmarshalException​(String message, Throwable exception)

使用指定的详细消息和linkedException构造UnmarshalException。

ValidationException​(String message)

构造具有指定详细消息的ValidationException。

ValidationException​(String message, String errorCode)

使用指定的详细消息和供应商特定的错误代码构造ValidationException。

ValidationException​(String message, String errorCode, Throwable exception)

使用指定的详细消息，供应商特定的错误代码和linkedException构造ValidationException。

ValidationException​(String message, Throwable exception)

使用指定的详细消息和linkedException构造ValidationException。

Uses of String in javax.xml.bind.annotation

Methods in javax.xml.bind.annotation with parameters of type String

Modifier and Type

方法

描述

static XmlAccessOrder

XmlAccessOrder.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static XmlAccessType

XmlAccessType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static XmlNsForm

XmlNsForm.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javax.xml.bind.annotation.adapters

Methods in javax.xml.bind.annotation.adapters that return String

Modifier and Type

方法

描述

String

CollapsedStringAdapter.marshal​(String s)

无操作。

String

HexBinaryAdapter.marshal​(byte[] bytes)

String

NormalizedStringAdapter.marshal​(String s)

无操作。

String

CollapsedStringAdapter.unmarshal​(String text)

删除作为参数给出的字符串的前导和尾随空格，然后通过单个空格字符“'截断任何标签，CR，LF和SP序列。

String

NormalizedStringAdapter.unmarshal​(String text)

按照 the whitespace facet 'replace'中的规定，将任何标签，CR和LF替换为空格字符“'

Methods in javax.xml.bind.annotation.adapters with parameters of type String

Modifier and Type

方法

描述

String

CollapsedStringAdapter.marshal​(String s)

无操作。

String

NormalizedStringAdapter.marshal​(String s)

无操作。

String

CollapsedStringAdapter.unmarshal​(String text)

删除作为参数给出的字符串的前导和尾随空格，然后通过单个空格字符“'截断任何标签，CR，LF和SP序列。

byte[]

HexBinaryAdapter.unmarshal​(String s)

String

NormalizedStringAdapter.unmarshal​(String text)

按照 the whitespace facet 'replace'中的规定，用空格字符替换任何标签，CR和LF

Uses of String in javax.xml.bind.attachment

Methods in javax.xml.bind.attachment that return String

Modifier and Type

方法

描述

abstract String

AttachmentMarshaller.addMtomAttachment​(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)

考虑二进制 data作为附件的优化二进制存储。

abstract String

AttachmentMarshaller.addMtomAttachment​(DataHandler data, String elementNamespace, String elementLocalName)

考虑MIME内容 data用于优化二进制存储作为附件。

abstract String

AttachmentMarshaller.addSwaRefAttachment​(DataHandler data)

添加MIME data作为附件并返回附件的content-id，cid。

Methods in javax.xml.bind.attachment with parameters of type String

Modifier and Type

方法

描述

abstract String

AttachmentMarshaller.addMtomAttachment​(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)

考虑二进制 data作为附件的优化二进制存储。

abstract String

AttachmentMarshaller.addMtomAttachment​(DataHandler data, String elementNamespace, String elementLocalName)

考虑MIME内容 data用于优化的二进制存储作为附件。

abstract byte[]

AttachmentUnmarshaller.getAttachmentAsByteArray​(String cid)

检索由content-id标识的附件， cid ，作为 byte[] 。

abstract DataHandler

AttachmentUnmarshaller.getAttachmentAsDataHandler​(String cid)

根据content-id查询MIME内容， cid ，并返回为DataHandler 。

Uses of String in javax.xml.bind.helpers

Methods in javax.xml.bind.helpers that return String

Modifier and Type

方法

描述

protected String

AbstractMarshallerImpl.getEncoding​()

获取当前输出编码的便利方法。

protected String

AbstractMarshallerImpl.getJavaEncoding​(String encoding)

从IANA名称获取相应的Java编码名称。

String

ValidationEventImpl.getMessage​()

protected String

AbstractMarshallerImpl.getNoNSSchemaLocation​()

获取当前noNamespaceSchemaLocation的便利方法。

protected String

AbstractMarshallerImpl.getSchemaLocation​()

获取当前schemaLocation的便利方法。

String

ValidationEventImpl.toString​()

以有助于调试的格式返回此对象的字符串表示形式。

String

ValidationEventLocatorImpl.toString​()

以有助于调试的格式返回此对象的字符串表示形式。

Methods in javax.xml.bind.helpers with parameters of type String

Modifier and Type

方法

描述

protected String

AbstractMarshallerImpl.getJavaEncoding​(String encoding)

从IANA名称获取相应的Java编码名称。

Object

AbstractMarshallerImpl.getProperty​(String name)

getProperty方法的默认实现处理Marshaller中四个定义的属性。

Object

AbstractUnmarshallerImpl.getProperty​(String name)

getProperty方法的默认实现总是抛出PropertyException，因为没有必需的属性。

protected void

AbstractMarshallerImpl.setEncoding​(String encoding)

设置输出编码的方便方法。

void

ValidationEventImpl.setMessage​(String _message)

设置此事件的消息字段。

protected void

AbstractMarshallerImpl.setNoNSSchemaLocation​(String location)

设置noNamespaceSchemaLocation的便利方法。

void

AbstractMarshallerImpl.setProperty​(String name, Object value)

setProperty方法的默认实现处理Marshaller中四个定义的属性。

void

AbstractUnmarshallerImpl.setProperty​(String name, Object value)

setProperty方法的默认实现总是抛出PropertyException，因为没有必需的属性。

protected void

AbstractMarshallerImpl.setSchemaLocation​(String location)

设置schemaLocation的便利方法。

Constructors in javax.xml.bind.helpers with parameters of type String

Constructor

描述

NotIdentifiableEventImpl​(int _severity, String _message, ValidationEventLocator _locator)

创建一个新的NotIdentifiableEventImpl。

NotIdentifiableEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)

创建一个新的NotIdentifiableEventImpl。

ParseConversionEventImpl​(int _severity, String _message, ValidationEventLocator _locator)

创建一个新的ParseConversionEventImpl。

ParseConversionEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)

创建一个新的ParseConversionEventImpl。

PrintConversionEventImpl​(int _severity, String _message, ValidationEventLocator _locator)

创建一个新的PrintConversionEventImpl。

PrintConversionEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)

创建一个新的PrintConversionEventImpl。

ValidationEventImpl​(int _severity, String _message, ValidationEventLocator _locator)

创建一个新的ValidationEventImpl。

ValidationEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)

创建一个新的ValidationEventImpl。

Uses of String in javax.xml.catalog

Methods in javax.xml.catalog that return String

Modifier and Type

方法

描述

String

CatalogFeatures.Feature.defaultValue​()

返回属性的默认值。

String

CatalogFeatures.get​(CatalogFeatures.Feature cf)

返回指定要素的值。

String

CatalogFeatures.Feature.getPropertyName​()

返回相应系统属性的名称。

String

Catalog.matchPublic​(String publicId)

尝试通过publicId在目录中找到匹配的条目。

String

Catalog.matchSystem​(String systemId)

尝试通过systemId在目录中找到匹配的条目。

String

Catalog.matchURI​(String uri)

尝试通过uri元素在目录中找到匹配的条目。

Methods in javax.xml.catalog with parameters of type String

Modifier and Type

方法

描述

String

Catalog.matchPublic​(String publicId)

尝试通过publicId在目录中找到匹配的条目。

String

Catalog.matchSystem​(String systemId)

尝试通过systemId在目录中找到匹配的条目。

String

Catalog.matchURI​(String uri)

尝试通过uri元素在目录中找到匹配的条目。

Source

CatalogResolver.resolve​(String href, String base)

实施URIRsolver。

InputSource

CatalogResolver.resolveEntity​(String publicId, String systemId)

实现EntityResolver 。

InputStream

CatalogResolver.resolveEntity​(String publicId, String systemId, String baseUri, String namespace)

实现XMLResolver 。

LSInput

CatalogResolver.resolveResource​(String type, String namespaceUri, String publicId, String systemId, String baseUri)

实施LSResourceResolver 。

static CatalogFeatures.Feature

CatalogFeatures.Feature.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

CatalogFeatures.Builder

CatalogFeatures.Builder.with​(CatalogFeatures.Feature feature, String value)

将值设置为指定的要素。

Constructors in javax.xml.catalog with parameters of type String

Constructor

描述

CatalogException​(String message)

使用指定的详细消息构造新的CatalogException。

CatalogException​(String message, Throwable cause)

构造一个具有指定的详细信息和原因的新的CatalogException。

Uses of String in javax.xml.crypto

Methods in javax.xml.crypto that return String

Modifier and Type

方法

描述

String

AlgorithmMethod.getAlgorithm​()

返回此 AlgorithmMethod的算法URI。

String

XMLCryptoContext.getBaseURI​()

返回基本URI。

String

XMLCryptoContext.getDefaultNamespacePrefix​()

返回默认名称空间前缀。

String

OctetStreamData.getMimeType​()

返回与此 OctetStreamData表示的数据对象关联的MIME类型。

String

XMLCryptoContext.getNamespacePrefix​(String namespaceURI, String defaultPrefix)

返回指定的命名空间URI与之关联的命名空间前缀。

String

URIReference.getType​()

返回此URI引用的数据类型。

String

OctetStreamData.getURI​()

返回标识由此 OctetStreamData表示的数据对象的URI字符串。

String

URIReference.getURI​()

返回引用的数据对象的URI。

String

XMLCryptoContext.putNamespacePrefix​(String namespaceURI, String prefix)

将指定的命名空间URI映射到指定的前缀。

String

KeySelector.Purpose.toString​()

返回此目的的字符串表示（“sign”，“verify”，“encrypt”或“decrypt”）。

Methods in javax.xml.crypto with parameters of type String

Modifier and Type

方法

描述

String

XMLCryptoContext.getNamespacePrefix​(String namespaceURI, String defaultPrefix)

返回指定的命名空间URI与之关联的命名空间前缀。

Object

XMLCryptoContext.getProperty​(String name)

返回指定属性的值。

boolean

XMLStructure.isFeatureSupported​(String feature)

指示是否支持指定的功能。

String

XMLCryptoContext.putNamespacePrefix​(String namespaceURI, String prefix)

将指定的命名空间URI映射到指定的前缀。

void

XMLCryptoContext.setBaseURI​(String baseURI)

设置基本URI。

void

XMLCryptoContext.setDefaultNamespacePrefix​(String defaultPrefix)

设置默认名称空间前缀。

Object

XMLCryptoContext.setProperty​(String name, Object value)

设置指定的属性。

Constructors in javax.xml.crypto with parameters of type String

Constructor

描述

KeySelectorException​(String message)

构造一个新的 KeySelectorException与指定的详细信息。

KeySelectorException​(String message, Throwable cause)

构造一个新的 KeySelectorException具有指定的详细信息和原因。

MarshalException​(String message)

构造一个新的 MarshalException具有指定的详细消息。

MarshalException​(String message, Throwable cause)

构造一个新的 MarshalException与指定的详细信息和原因。

NoSuchMechanismException​(String message)

构造一个新的 NoSuchMechanismException具有指定的详细消息。

NoSuchMechanismException​(String message, Throwable cause)

构造一个新的 NoSuchMechanismException与指定的详细信息和原因。

OctetStreamData​(InputStream octetStream, String uri, String mimeType)

创建一个新的 OctetStreamData 。

URIReferenceException​(String message)

构造具有指定详细消息的新的 URIReferenceException 。

URIReferenceException​(String message, Throwable cause)

构造一个新的 URIReferenceException具有指定的详细信息和原因。

URIReferenceException​(String message, Throwable cause, URIReference uriReference)

构造一个新的 URIReferenceException与指定的详细信息，原因和 URIReference 。

Uses of String in javax.xml.crypto.dom

Methods in javax.xml.crypto.dom that return String

Modifier and Type

方法

描述

String

DOMCryptoContext.getBaseURI​()

String

DOMCryptoContext.getDefaultNamespacePrefix​()

String

DOMCryptoContext.getNamespacePrefix​(String namespaceURI, String defaultPrefix)

此实现使用内部HashMap获取指定的URI映射到的前缀。

String

DOMCryptoContext.putNamespacePrefix​(String namespaceURI, String prefix)

此实现使用内部HashMap将URI映射到指定的前缀。

Methods in javax.xml.crypto.dom that return types with arguments of type String

Modifier and Type

方法

描述

Iterator<Map.Entry<String,Element>>

DOMCryptoContext.iterator​()

在这个 DOMCryptoContext的Id / Element映射集中返回一个只读迭代器。

Methods in javax.xml.crypto.dom with parameters of type String

Modifier and Type

方法

描述

Element

DOMCryptoContext.getElementById​(String idValue)

返回具有指定ID属性值的 Element 。

String

DOMCryptoContext.getNamespacePrefix​(String namespaceURI, String defaultPrefix)

此实现使用内部HashMap获取指定的URI映射到的前缀。

Object

DOMCryptoContext.getProperty​(String name)

此实现使用内部HashMap来获取指定名称映射到的对象。

boolean

DOMStructure.isFeatureSupported​(String feature)

String

DOMCryptoContext.putNamespacePrefix​(String namespaceURI, String prefix)

此实现使用内部HashMap将URI映射到指定的前缀。

void

DOMCryptoContext.setBaseURI​(String baseURI)

void

DOMCryptoContext.setDefaultNamespacePrefix​(String defaultPrefix)

void

DOMCryptoContext.setIdAttributeNS​(Element element, String namespaceURI, String localName)

将名称空间URI和本地名称指定的元素的属性注册为类型ID。

Object

DOMCryptoContext.setProperty​(String name, Object value)

此实现使用内部HashMap将名称映射到指定的对象。

Uses of String in javax.xml.crypto.dsig

Fields in javax.xml.crypto.dsig declared as String

Modifier and Type

Field

描述

static String

Transform.BASE64

Base64转换算法URI。

static String

SignatureMethod.DSA_SHA1

DSAwithSHA1 （DSS）签名方法算法URI。

static String

Transform.ENVELOPED

Enveloped Signature转换算法的URI。

static String

CanonicalizationMethod.EXCLUSIVE

Exclusive Canonical XML (without comments)规范化方法算法URI。

static String

CanonicalizationMethod.EXCLUSIVE_WITH_COMMENTS

Exclusive Canonical XML with comments规范化方法算法URI。

static String

SignatureMethod.HMAC_SHA1

HMAC-SHA1 MAC签名方法算法URI

static String

CanonicalizationMethod.INCLUSIVE

Canonical XML (without comments)规范化方法算法URI。

static String

CanonicalizationMethod.INCLUSIVE_WITH_COMMENTS

Canonical XML with comments规范化方法算法URI。

static String

DigestMethod.RIPEMD160

RIPEMD-160摘要方法算法URI。

static String

SignatureMethod.RSA_SHA1

RSAwithSHA1 （PKCS＃1）签名方法算法URI。

static String

DigestMethod.SHA1

SHA1摘要方法算法URI。

static String

DigestMethod.SHA256

SHA256摘要方法算法URI。

static String

DigestMethod.SHA512

SHA512摘要方法算法URI。

static String

Manifest.TYPE

URI标识Manifest元件（这可以被指定为值type所述的参数Reference类来识别引用的类型）。

static String

SignatureProperties.TYPE

标识SignatureProperties元素的URI（可以指定为Reference类的type参数的值来标识指示物的类型）。

static String

XMLObject.TYPE

标识Object元素的URI（可以指定为Reference类的type参数的值，以确定指示物的类型）。

static String

XMLSignature.XMLNS

用于XML签名语法和处理的W3C建议书的XML命名空间URI。

static String

Transform.XPATH

XPath变换算法的URI。

static String

Transform.XPATH2

XPath Filter 2转换算法的URI。

static String

Transform.XSLT

XSLT转换算法URI。

Methods in javax.xml.crypto.dsig that return String

Modifier and Type

方法

描述

String

TransformService.getAlgorithm​()

返回此 TransformService支持的算法的URI。

String

XMLObject.getEncoding​()

返回此 XMLObject的编码URI。

String

Manifest.getId​()

返回此 Manifest的ID。

String

Reference.getId​()

返回此 Reference的可选 Id属性，该属性允许从其他地方引用此引用。

String

SignatureProperties.getId​()

返回此 SignatureProperties的ID。

String

SignatureProperty.getId​()

返回此 SignatureProperty的ID。

String

SignedInfo.getId​()

返回此 SignedInfo的可选 Id属性。

String

XMLObject.getId​()

返回此 XMLObject的ID。

String

XMLSignature.getId​()

返回此 XMLSignature的可选ID。

String

XMLSignature.SignatureValue.getId​()

返回此 SignatureValue的可选 Id属性，该属性允许从其他地方引用该元素。

String

TransformService.getMechanismType​()

返回此 TransformService支持的机制类型。

String

XMLSignatureFactory.getMechanismType​()

返回此 XMLSignatureFactory （例如：“DOM”）支持的XML处理机制和表示的类型。

String

XMLObject.getMimeType​()

返回这个 XMLObject的MIME类型。

String

SignatureProperty.getTarget​()

返回此 SignatureProperty的目标URI。

Methods in javax.xml.crypto.dsig with parameters of type String

Modifier and Type

方法

描述

static TransformService

TransformService.getInstance​(String algorithm, String mechanismType)

返回一个 TransformService支持指定算法URI（例如： Transform.XPATH2 ）和机制类型（比如：DOM）。

static TransformService

TransformService.getInstance​(String algorithm, String mechanismType, String provider)

返回一个 TransformService支持指定算法URI（例如： Transform.XPATH2 ）和机制类型：由指定的提供者提供（例如，DOM）。

static TransformService

TransformService.getInstance​(String algorithm, String mechanismType, Provider provider)

返回一个 TransformService ，它支持指定的 TransformService程序提供的指定算法URI（例如： Transform.XPATH2 ）和机制类型（例如：DOM）。

static XMLSignatureFactory

XMLSignatureFactory.getInstance​(String mechanismType)

返回支持指定的XML处理机制和表示类型（例如：“DOM”）的 XMLSignatureFactory 。

static XMLSignatureFactory

XMLSignatureFactory.getInstance​(String mechanismType, String provider)

返回一个 XMLSignatureFactory ，它支持由指定提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

static XMLSignatureFactory

XMLSignatureFactory.getInstance​(String mechanismType, Provider provider)

返回一个 XMLSignatureFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

abstract boolean

XMLSignatureFactory.isFeatureSupported​(String feature)

指示是否支持指定的功能。

abstract CanonicalizationMethod

XMLSignatureFactory.newCanonicalizationMethod​(String algorithm, C14NMethodParameterSpec params)

为指定的算法URI和参数创建一个 CanonicalizationMethod 。

abstract CanonicalizationMethod

XMLSignatureFactory.newCanonicalizationMethod​(String algorithm, XMLStructure params)

为指定的算法URI和参数创建一个 CanonicalizationMethod 。

abstract DigestMethod

XMLSignatureFactory.newDigestMethod​(String algorithm, DigestMethodParameterSpec params)

为指定的算法URI和参数创建一个 DigestMethod 。

abstract Manifest

XMLSignatureFactory.newManifest​(List<? extends Reference> references, String id)

创建一个Manifest其中包含Reference s和可选id的指定列表。

abstract Reference

XMLSignatureFactory.newReference​(String uri, DigestMethod dm)

使用指定的URI和摘要方法创建一个 Reference 。

abstract Reference

XMLSignatureFactory.newReference​(String uri, DigestMethod dm, List<? extends Transform> transforms, String type, String id)

创建具有指定参数的 Reference 。

abstract Reference

XMLSignatureFactory.newReference​(String uri, DigestMethod dm, List<? extends Transform> transforms, String type, String id, byte[] digestValue)

创建具有指定参数的 Reference和预先计算的摘要值。

abstract Reference

XMLSignatureFactory.newReference​(String uri, DigestMethod dm, List<? extends Transform> appliedTransforms, Data result, List<? extends Transform> transforms, String type, String id)

创建具有指定参数的 Reference 。

abstract SignatureMethod

XMLSignatureFactory.newSignatureMethod​(String algorithm, SignatureMethodParameterSpec params)

为指定的算法URI和参数创建一个 SignatureMethod 。

abstract SignatureProperties

XMLSignatureFactory.newSignatureProperties​(List<? extends SignatureProperty> properties, String id)

创建一个SignatureProperties其中包含SignatureProperty s和可选id的指定列表。

abstract SignatureProperty

XMLSignatureFactory.newSignatureProperty​(List<? extends XMLStructure> content, String target, String id)

创建一个SignatureProperty其中包含XMLStructure s的目标URI和可选的id。

abstract SignedInfo

XMLSignatureFactory.newSignedInfo​(CanonicalizationMethod cm, SignatureMethod sm, List<? extends Reference> references, String id)

创建具有指定参数的 SignedInfo 。

abstract Transform

XMLSignatureFactory.newTransform​(String algorithm, TransformParameterSpec params)

为指定的算法URI和参数创建一个 Transform 。

abstract Transform

XMLSignatureFactory.newTransform​(String algorithm, XMLStructure params)

为指定的算法URI和参数创建一个 Transform 。

abstract XMLObject

XMLSignatureFactory.newXMLObject​(List<? extends XMLStructure> content, String id, String mimeType, String encoding)

从指定的参数创建一个 XMLObject 。

abstract XMLSignature

XMLSignatureFactory.newXMLSignature​(SignedInfo si, KeyInfo ki, List<? extends XMLObject> objects, String id, String signatureValueId)

创建一个 XMLSignature并用指定的参数进行初始化。

Constructors in javax.xml.crypto.dsig with parameters of type String

Constructor

描述

TransformException​(String message)

构造一个新的 TransformException与指定的详细信息。

TransformException​(String message, Throwable cause)

构造一个新的 TransformException具有指定的详细信息和原因。

XMLSignatureException​(String message)

构造一个新的 XMLSignatureException与指定的详细信息。

XMLSignatureException​(String message, Throwable cause)

构造一个新的 XMLSignatureException与指定的详细信息和原因。

Uses of String in javax.xml.crypto.dsig.keyinfo

Fields in javax.xml.crypto.dsig.keyinfo declared as String

Modifier and Type

Field

描述

static String

KeyValue.DSA_TYPE

标识DSA KeyValue KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。

static String

X509Data.RAW_X509_CERTIFICATE_TYPE

标识二进制文件的URI（ASN.1 DER）X.509证书KeyInfo类型：http://www.w3.org/2000/09/xmldsig#rawX509证书。

static String

KeyValue.RSA_TYPE

标识RSA KeyValue KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。

static String

PGPData.TYPE

标识PGPData KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#PGPData。

static String

X509Data.TYPE

标识X509Data KeyInfo类型的URI：http://www.w3.org/2000/09/xmldsig#X509Data。

Methods in javax.xml.crypto.dsig.keyinfo that return String

Modifier and Type

方法

描述

String

KeyInfo.getId​()

返回此 KeyInfo的可选Id属性，这对于从其他XML结构引用此 KeyInfo可能很有用。

String

X509IssuerSerial.getIssuerName​()

以 RFC 2253字符串格式返回此 X509IssuerSerial的X.500可分辨名称。

String

KeyInfoFactory.getMechanismType​()

返回此 KeyInfoFactory支持的XML处理机制和表示 KeyInfoFactory （例如：“DOM”）

String

KeyName.getName​()

返回此 KeyName的名称。

String

RetrievalMethod.getURI​()

返回引用的 KeyInfo信息的URI。

Methods in javax.xml.crypto.dsig.keyinfo with parameters of type String

Modifier and Type

方法

描述

static KeyInfoFactory

KeyInfoFactory.getInstance​(String mechanismType)

返回支持指定的XML处理机制和表示类型（例如：“DOM”）的 KeyInfoFactory 。

static KeyInfoFactory

KeyInfoFactory.getInstance​(String mechanismType, String provider)

返回一个 KeyInfoFactory ，它支持由指定的提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

static KeyInfoFactory

KeyInfoFactory.getInstance​(String mechanismType, Provider provider)

返回一个 KeyInfoFactory ，它支持由指定提供者提供的请求的XML处理机制和表示类型（例如：“DOM”）。

abstract boolean

KeyInfoFactory.isFeatureSupported​(String feature)

指示是否支持指定的功能。

abstract KeyInfo

KeyInfoFactory.newKeyInfo​(List<? extends XMLStructure> content, String id)

创建一个 KeyInfo其中包含指定的关键信息类型和可选标识列表。

abstract KeyName

KeyInfoFactory.newKeyName​(String name)

从指定的名称创建一个 KeyName 。

abstract RetrievalMethod

KeyInfoFactory.newRetrievalMethod​(String uri)

从指定的URI创建一个 RetrievalMethod 。

abstract RetrievalMethod

KeyInfoFactory.newRetrievalMethod​(String uri, String type, List<? extends Transform> transforms)

从指定的参数创建一个 RetrievalMethod 。

abstract X509IssuerSerial

KeyInfoFactory.newX509IssuerSerial​(String issuerName, BigInteger serialNumber)

从指定的X.500发行人可分辨名称和序列号创建 X509IssuerSerial 。

Uses of String in javax.xml.crypto.dsig.spec

Fields in javax.xml.crypto.dsig.spec declared as String

Modifier and Type

Field

描述

static String

ExcC14NParameterSpec.DEFAULT

表示默认命名空间（“#default”）。

Methods in javax.xml.crypto.dsig.spec that return String

Modifier and Type

方法

描述

String

XPathType.getExpression​()

返回要评估的XPath表达式。

String

XPathFilterParameterSpec.getXPath​()

返回要评估的XPath表达式。

String

XPathType.Filter.toString​()

返回操作的字符串形式。

Methods in javax.xml.crypto.dsig.spec that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,String>

XPathFilterParameterSpec.getNamespaceMap​()

返回名称空间前缀的映射。

Map<String,String>

XPathFilterParameterSpec.getNamespaceMap​()

返回名称空间前缀的映射。

Map<String,String>

XPathType.getNamespaceMap​()

返回名称空间前缀的映射。

Map<String,String>

XPathType.getNamespaceMap​()

返回名称空间前缀的映射。

List<String>

ExcC14NParameterSpec.getPrefixList​()

返回包含的名称空间前缀列表。

Constructors in javax.xml.crypto.dsig.spec with parameters of type String

Constructor

描述

XPathFilterParameterSpec​(String xPath)

使用指定的XPath表达式创建一个 XPathFilterParameterSpec 。

XPathFilterParameterSpec​(String xPath, Map<String,String> namespaceMap)

使用指定的XPath表达式和命名空间映射创建一个 XPathFilterParameterSpec 。

XPathType​(String expression, XPathType.Filter filter)

使用指定的XPath表达式和过滤器创建一个 XPathType实例。

XPathType​(String expression, XPathType.Filter filter, Map<String,String> namespaceMap)

使用指定的XPath表达式，过滤器和命名空间映射创建一个 XPathType实例。

Constructor parameters in javax.xml.crypto.dsig.spec with type arguments of type String

Constructor

描述

ExcC14NParameterSpec​(List<String> prefixList)

创建具有指定的前缀列表的 ExcC14NParameterSpec 。

XPathFilterParameterSpec​(String xPath, Map<String,String> namespaceMap)

使用指定的XPath表达式和命名空间映射创建一个 XPathFilterParameterSpec 。

XPathFilterParameterSpec​(String xPath, Map<String,String> namespaceMap)

使用指定的XPath表达式和命名空间映射创建一个 XPathFilterParameterSpec 。

XPathType​(String expression, XPathType.Filter filter, Map<String,String> namespaceMap)

使用指定的XPath表达式，过滤器和命名空间映射创建一个 XPathType实例。

XPathType​(String expression, XPathType.Filter filter, Map<String,String> namespaceMap)

使用指定的XPath表达式，过滤器和命名空间映射创建一个 XPathType实例。

Uses of String in javax.xml.datatype

Fields in javax.xml.datatype declared as String

Modifier and Type

Field

描述

static String

DatatypeFactory.DATATYPEFACTORY_IMPLEMENTATION_CLASS

JSR 206中定义的默认实现类名称 ：用于XML处理的Java（TM）API（JAXP）1.3 。

static String

DatatypeFactory.DATATYPEFACTORY_PROPERTY

JSR 206中定义的默认属性名称：用于XML处理的Java（TM）API（JAXP）1.3。

Methods in javax.xml.datatype that return String

Modifier and Type

方法

描述

String

DatatypeConstants.Field.toString​()

返回英文字段名称。

String

Duration.toString​()

返回此 Duration Object的 String表示。

String

XMLGregorianCalendar.toString​()

返回此 XMLGregorianCalendar Object的 String表示。

abstract String

XMLGregorianCalendar.toXMLFormat​()

返回 this实例的词汇表示。

Methods in javax.xml.datatype with parameters of type String

Modifier and Type

方法

描述

abstract Duration

DatatypeFactory.newDuration​(String lexicalRepresentation)

获取 Duration的新实例，指定 Duration作为其XML Schema 1.0第3.2.6.1节中定义的字符串表示形式“PnYnMnDTnHnMnS”。

Duration

DatatypeFactory.newDurationDayTime​(String lexicalRepresentation)

创建 Duration型 xdt:dayTimeDuration通过分析其 String表示 ，“PnDTnHnMnS” XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 。

Duration

DatatypeFactory.newDurationYearMonth​(String lexicalRepresentation)

创建 Duration型 xdt:yearMonthDuration通过分析其 String表示 ，“PnYnM” XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 。

static DatatypeFactory

DatatypeFactory.newInstance​(String factoryClassName, ClassLoader classLoader)

从类名中获取一个新的 DatatypeFactory实例。

abstract XMLGregorianCalendar

DatatypeFactory.newXMLGregorianCalendar​(String lexicalRepresentation)

通过解析String作为词法表示来创建一个新的XMLGregorianCalendar。

Constructors in javax.xml.datatype with parameters of type String

Constructor

描述

DatatypeConfigurationException​(String message)

使用指定的详细消息创建一个新的 DatatypeConfigurationException 。

DatatypeConfigurationException​(String message, Throwable cause)

创建一个新的 DatatypeConfigurationException具有指定的详细信息和原因。

Uses of String in javax.xml.namespace

Methods in javax.xml.namespace that return String

Modifier and Type

方法

描述

String

QName.getLocalPart​()

获取这个 QName的本地部分。

String

NamespaceContext.getNamespaceURI​(String prefix)

获取命名空间URI绑定到当前作用域中的前缀。

String

QName.getNamespaceURI​()

获取此 QName的命名空间URI。

String

NamespaceContext.getPrefix​(String namespaceURI)

获取前缀绑定到当前作用域中的命名空间URI。

String

QName.getPrefix​()

获取此 QName的前缀。

String

QName.toString​()

String这个 QName代表。

Methods in javax.xml.namespace with parameters of type String

Modifier and Type

方法

描述

String

NamespaceContext.getNamespaceURI​(String prefix)

获取命名空间URI绑定到当前作用域中的前缀。

String

NamespaceContext.getPrefix​(String namespaceURI)

获取前缀绑定到当前作用域中的命名空间URI。

Iterator

NamespaceContext.getPrefixes​(String namespaceURI)

获取绑定到当前作用域中的命名空间URI的所有前缀。

static QName

QName.valueOf​(String qNameAsString)

QName派生自解析格式化的 String 。

Constructors in javax.xml.namespace with parameters of type String

Constructor

描述

QName​(String localPart)

QName指定本地零件的构造函数。

QName​(String namespaceURI, String localPart)

QName构造函数指定命名空间URI和本地部分。

QName​(String namespaceURI, String localPart, String prefix)

QName构造函数，指定命名空间URI，本地部分和前缀。

Uses of String in javax.xml.parsers

Methods in javax.xml.parsers that return String

Modifier and Type

方法

描述

String

FactoryConfigurationError.getMessage​()

返回此错误的消息（如果有）。

Methods in javax.xml.parsers with parameters of type String

Modifier and Type

方法

描述

abstract Object

DocumentBuilderFactory.getAttribute​(String name)

允许用户检索底层实现的特定属性。

abstract boolean

DocumentBuilderFactory.getFeature​(String name)

获取命名功能的状态。

abstract boolean

SAXParserFactory.getFeature​(String name)

返回org.xml.sax.XMLReader的底层实现中请求的特定属性。

abstract Object

SAXParser.getProperty​(String name)

返回底层实现中请求的特定属性XMLReader 。

static DocumentBuilderFactory

DocumentBuilderFactory.newInstance​(String factoryClassName, ClassLoader classLoader)

从类名获取一个新的实例 DocumentBuilderFactory 。

static SAXParserFactory

SAXParserFactory.newInstance​(String factoryClassName, ClassLoader classLoader)

从类名获取一个新的实例 SAXParserFactory 。

Document

DocumentBuilder.parse​(InputStream is, String systemId)

将给定的InputStream的内容解析为XML文档，并返回一个新的DOM Document对象。

Document

DocumentBuilder.parse​(String uri)

将给定URI的内容解析为XML文档，并返回一个新的DOM Document对象。

void

SAXParser.parse​(InputStream is, HandlerBase hb, String systemId)

使用指定的HandlerBase将给定的InputStream实例的内容解析为XML。

void

SAXParser.parse​(InputStream is, DefaultHandler dh, String systemId)

使用指定的DefaultHandler将给定的InputStream实例的内容解析为XML。

void

SAXParser.parse​(String uri, HandlerBase hb)

使用指定的HandlerBase解析给出使用统一资源标识符（URI）作为XML的内容 。

void

SAXParser.parse​(String uri, DefaultHandler dh)

使用指定的DefaultHandler解析给出使用统一资源标识符（URI）作为XML的内容 。

abstract void

DocumentBuilderFactory.setAttribute​(String name, Object value)

允许用户在底层实现上设置特定属性。

abstract void

DocumentBuilderFactory.setFeature​(String name, boolean value)

为这个工厂创建的 DocumentBuilderFactory和 DocumentBuilder设置了一个功能。

abstract void

SAXParserFactory.setFeature​(String name, boolean value)

设置org.xml.sax.XMLReader的底层实现中的特殊功能。

abstract void

SAXParser.setProperty​(String name, Object value)

设置底层实现中的特定属性XMLReader 。

Constructors in javax.xml.parsers with parameters of type String

Constructor

描述

FactoryConfigurationError​(异常 e, String msg)

创建一个新的 FactoryConfigurationError与给定的 异常基本原因和详细信息。

FactoryConfigurationError​(String msg)

创建一个新的 FactoryConfigurationError ，其中 String指定为错误消息。

ParserConfigurationException​(String msg)

创建一个新的 ParserConfigurationException ，其中 String指定为错误消息。

Uses of String in javax.xml.soap

Fields in javax.xml.soap declared as String

Modifier and Type

Field

描述

static String

SOAPMessage.CHARACTER_SET_ENCODING

指定SOAP消息的字符类型编码。

static String

SOAPConstants.DEFAULT_SOAP_PROTOCOL

默认协议：SOAP 1.1，用于向后兼容。

static String

SOAPConstants.DYNAMIC_SOAP_PROTOCOL

用于创建 MessageFactory实例，创建 SOAPMessages其具体类型基于传递给 createMessage方法的 Content-Type MIME标头。

static String

SOAPConstants.SOAP_1_1_CONTENT_TYPE

SOAP 1.1中的 Content-Type MIME头的媒体类型。

static String

SOAPConstants.SOAP_1_1_PROTOCOL

用于创建 MessageFactory实例，创建其行为支持SOAP 1.1规范的 SOAPMessages 。

static String

SOAPConstants.SOAP_1_2_CONTENT_TYPE

SOAP 1.2中的 Content-Type MIME头的媒体类型。

static String

SOAPConstants.SOAP_1_2_PROTOCOL

用于创建 MessageFactory创造实例 SOAPMessages其行为支持SOAP 1.2规范

static String

SOAPConstants.SOAP_ENV_PREFIX

http://www.w3.org/2003/05/soap-envelope的默认命名空间前缀

static String

SOAPConstants.URI_NS_SOAP_1_1_ENVELOPE

SOAP 1.1信封的命名空间标识符。

static String

SOAPConstants.URI_NS_SOAP_1_2_ENCODING

SOAP 1.2编码的命名空间标识符。

static String

SOAPConstants.URI_NS_SOAP_1_2_ENVELOPE

SOAP 1.2信封的命名空间标识符。

static String

SOAPConstants.URI_NS_SOAP_ENCODING

SOAP 1.1编码的命名空间标识符。

static String

SOAPConstants.URI_NS_SOAP_ENVELOPE

SOAP 1.1包络的命名空间标识符，此命名空间中的所有SOAPElements由SOAP 1.1规范定义。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_NEXT

标识下一个处理SOAP请求的应用程序的URI作为SOAP 1.2标题条目的预期角色（参见SOAP 1.2规范的第1部分的第2.2节）。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_NONE

SOAP 1.2中指定角色无的URI。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER

标识SOAP 1.2消息的最终接收者的URI。

static String

SOAPConstants.URI_SOAP_ACTOR_NEXT

URI标识下一个处理SOAP请求的应用程序作为SOAP 1.1标头条目的预期actor（参见SOAP 1.1规范的第4.2.2节）。

static String

SOAPMessage.WRITE_XML_DECLARATION

指定SOAP消息发送时是否包含XML声明。

Methods in javax.xml.soap that return String

Modifier and Type

方法

描述

String

SOAPHeaderElement.getActor​()

返回此 SOAPHeaderElement的 actor属性的uri。

String

SOAPElement.getAttributeValue​(QName qname)

返回具有指定qname的属性值。

String

SOAPElement.getAttributeValue​(Name name)

返回具有指定名称的属性值。

abstract String

SOAPMessage.getContentDescription​()

检索此 SOAPMessage对象内容的描述。

String

AttachmentPart.getContentId​()

获取名称为“Content-ID”的MIME标头的值。

String

SOAPPart.getContentId​()

检索名称为“Content-Id”的MIME标头的值。

String

AttachmentPart.getContentLocation​()

获取名称为“Content-Location”的MIME标头的值。

String

SOAPPart.getContentLocation​()

检索名称为“Content-Location”的MIME标头的值。

String

AttachmentPart.getContentType​()

获取名称为“Content-Type”的MIME标头的值。

String

SOAPElement.getEncodingStyle​()

返回此 SOAPElement对象的编码样式。

String

SOAPFault.getFaultActor​()

获取此 SOAPFault对象的故障演员。

String

SOAPFault.getFaultCode​()

获取此 SOAPFault对象的故障代码。

String

SOAPFault.getFaultNode​()

返回此 SOAPFault对象的可选Node元素值。

String

SOAPFault.getFaultReasonText​(Locale locale)

返回与给定的 Locale相关联的原因文本。

String

SOAPFault.getFaultRole​()

返回此 SOAPFault对象的可选Role元素值。

String

SOAPFault.getFaultString​()

获取此 SOAPFault对象的故障字符串。

String[]

MimeHeaders.getHeader​(String name)

将指定标题的所有值作为 String对象的数组 String 。

String

Name.getLocalName​()

获取此 Name对象所代表的XML名称的本地名称部分。

String

SOAPException.getMessage​()

返回此 SOAPException对象的详细消息。

abstract String[]

AttachmentPart.getMimeHeader​(String name)

获取由给定的 String标识的标题的所有值。

abstract String[]

SOAPPart.getMimeHeader​(String name)

获取的所有值 MimeHeader在这个对象 SOAPPart对象由给定的标识 String 。

String

MimeHeader.getName​()

返回此 MimeHeader对象的名称。

String

SOAPElement.getNamespaceURI​(String prefix)

返回具有给定前缀的命名空间的URI。

String

Name.getPrefix​()

返回此 Name对象初始化时指定的前缀。

String

Name.getQualifiedName​()

获取此 Name对象所代表的XML名称的命名空间限定名称。

String

SOAPHeaderElement.getRole​()

返回此 SOAPHeaderElement的“ 角色”属性的 SOAPHeaderElement 。

String

Name.getURI​()

返回此 Name对象所代表的XML名称的命名空间的URI。

String

MimeHeader.getValue​()

返回此 MimeHeader对象的值。

String

Node.getValue​()

如果此节点为 Text节点，则返回此节点的值，否则返回此节点的直接子节点的值。

Methods in javax.xml.soap that return types with arguments of type String

Modifier and Type

方法

描述

Iterator<String>

SOAPFault.getFaultReasonTexts​()

在 String对象中返回 Iterator ，该对象包含此 SOAPFault所有原因文本项。

Iterator<String>

SOAPElement.getNamespacePrefixes​()

返回一个 Iterator在命名空间前缀 String此元素声明秒。

Iterator<String>

SOAPElement.getVisibleNamespacePrefixes​()

在该元素可见的命名空间前缀 String返回 Iterator 。

Methods in javax.xml.soap with parameters of type String

Modifier and Type

方法

描述

SOAPElement

SOAPElement.addAttribute​(QName qname, String value)

将具有指定名称和值的属性添加到此 SOAPElement对象。

SOAPElement

SOAPElement.addAttribute​(Name name, String value)

将具有指定名称和值的属性添加到此 SOAPElement对象。

SOAPElement

SOAPElement.addChildElement​(String localName)

创建一个新的 SOAPElement对象，使用指定的本地名称初始化，并将新元素添加到此 SOAPElement对象。

SOAPElement

SOAPElement.addChildElement​(String localName, String prefix)

创建一个新的 SOAPElement对象，使用指定的本地名称和前缀进行初始化，并将新元素添加到此 SOAPElement对象。

SOAPElement

SOAPElement.addChildElement​(String localName, String prefix, String uri)

创建使用指定的本地名称，前缀和URI初始化的新的 SOAPElement对象，并将新元素添加到此 SOAPElement对象。

SOAPFault

SOAPBody.addFault​(QName faultCode, String faultString)

创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。

SOAPFault

SOAPBody.addFault​(QName faultCode, String faultString, Locale locale)

创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。

SOAPFault

SOAPBody.addFault​(Name faultCode, String faultString)

创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。

SOAPFault

SOAPBody.addFault​(Name faultCode, String faultString, Locale locale)

创建一个新的 SOAPFault对象，并将其添加到此 SOAPBody对象。

void

SOAPFault.addFaultReasonText​(String text, Locale locale)

追加或替换包含指定短信的原因文本项目和从 locale派生的 xml：lang 。

void

MimeHeaders.addHeader​(String name, String value)

将一个具有指定名称和值的 MimeHeader对象添加到此 MimeHeaders对象的标题列表中。

abstract void

AttachmentPart.addMimeHeader​(String name, String value)

向此 AttachmentPart对象添加具有指定名称和值的MIME标头。

abstract void

SOAPPart.addMimeHeader​(String name, String value)

创建 MimeHeader具有指定名称和值对象，并将其添加到这个 SOAPPart对象。

SOAPElement

SOAPElement.addNamespaceDeclaration​(String prefix, String uri)

向此 SOAPElement对象添加具有指定前缀和URI的命名空间声明。

SOAPElement

SOAPElement.addTextNode​(String text)

创建一个新的 Text对象，使用给定的 String初始化并将其添加到此 SOAPElement对象。

SOAPHeaderElement

SOAPHeader.addUpgradeHeaderElement​(String supportedSoapUri)

创建一个新的升级 SOAPHeaderElement对象，并使用指定的支持的SOAP URI进行初始化，并将其添加到此 SOAPHeader对象。

SOAPHeaderElement

SOAPHeader.addUpgradeHeaderElement​(String[] supportedSoapUris)

创建一个新的升级 SOAPHeaderElement对象，并使用指定的受支持的SOAP URI数组进行初始化，并将其添加到此 SOAPHeader对象。

SOAPElement

SOAPElementFactory.create​(String localName)

已过时。
改用javax.xml.soap.SOAPFactory.createElement（String localName）

SOAPElement

SOAPElementFactory.create​(String localName, String prefix, String uri)

已过时。
改用javax.xml.soap.SOAPFactory.createElement（String localName，String prefix，String uri）

AttachmentPart

SOAPMessage.createAttachmentPart​(Object content, String contentType)

创建一个 AttachmentPart对象，并使用指定的内容类型的指定数据进行填充。

abstract SOAPElement

SOAPFactory.createElement​(String localName)

创建一个使用给定本地名称初始化的 SOAPElement对象。

abstract SOAPElement

SOAPFactory.createElement​(String localName, String prefix, String uri)

使用给定的本地名称，前缀和uri创建一个新的 SOAPElement对象。

abstract SOAPFault

SOAPFactory.createFault​(String reasonText, QName faultCode)

创建一个新的 SOAPFault对象，初始化为给定的 reasonText和 faultCode

Name

SOAPEnvelope.createName​(String localName)

创建使用给定的本地名称初始化的新的 Name对象。

Name

SOAPEnvelope.createName​(String localName, String prefix, String uri)

创建使用给定的本地名称，命名空间前缀和命名空间URI初始化的新的 Name对象。

abstract Name

SOAPFactory.createName​(String localName)

创建使用给定的本地名称初始化的新的 Name对象。

abstract Name

SOAPFactory.createName​(String localName, String prefix, String uri)

创建使用给定的本地名称，命名空间前缀和命名空间URI初始化的新的 Name对象。

QName

SOAPElement.createQName​(String localName, String prefix)

在这个 SOAPElement的上下文中创建一个 QName其命名空间URI是与参数 prefix相关联的URI。

Iterator<SOAPHeaderElement>

SOAPHeader.examineHeaderElements​(String actor)

返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象具有指定 演员 。

Iterator<SOAPHeaderElement>

SOAPHeader.examineMustUnderstandHeaderElements​(String actor)

返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象具有指定 演员 ，有一个mustUnderstand属性，其值等于 true 。

Iterator<SOAPHeaderElement>

SOAPHeader.extractHeaderElements​(String actor)

返回一个 Iterator在所有 SOAPHeaderElement这个对象 SOAPHeader对象中具有指定 的actor并从此中分离出来 SOAPHeader对象。

String[]

MimeHeaders.getHeader​(String name)

将指定标题的所有值作为 String对象的数组 String 。

Iterator<MimeHeader>

MimeHeaders.getMatchingHeaders​(String[] names)

返回名称与给定名称数组中的名称相匹配的所有 MimeHeader对象。

abstract Iterator<MimeHeader>

AttachmentPart.getMatchingMimeHeaders​(String[] names)

检索与给定数组中的名称相匹配的所有 MimeHeader对象。

abstract Iterator<MimeHeader>

SOAPPart.getMatchingMimeHeaders​(String[] names)

检索与给定数组中的名称相匹配的所有 MimeHeader对象。

abstract String[]

AttachmentPart.getMimeHeader​(String name)

获取由给定的 String标识的标题的所有值。

abstract String[]

SOAPPart.getMimeHeader​(String name)

获取 MimeHeader对象中 SOAPPart对象的所有值，该对象由给定的 String 。

String

SOAPElement.getNamespaceURI​(String prefix)

返回具有给定前缀的命名空间的URI。

Iterator<MimeHeader>

MimeHeaders.getNonMatchingHeaders​(String[] names)

返回名称与给定名称数组中的名称不匹配的所有 MimeHeader对象。

abstract Iterator<MimeHeader>

AttachmentPart.getNonMatchingMimeHeaders​(String[] names)

检索名称与给定数组中的名称不匹配的所有 MimeHeader对象。

abstract Iterator<MimeHeader>

SOAPPart.getNonMatchingMimeHeaders​(String[] names)

检索所有 MimeHeader对象，其名称与给定数组中的名称不匹配。

Object

SOAPMessage.getProperty​(String property)

检索指定属性的值。

static MessageFactory

MessageFactory.newInstance​(String protocol)

创建一个新的 MessageFactory对象，该对象是指定实现的实例。

static SOAPFactory

SOAPFactory.newInstance​(String protocol)

创建一个新的 SOAPFactory对象，该对象是指定实现的实例，此方法使用SAAJMetaFactory来定位实现类并创建SOAPFactory实例。

protected abstract MessageFactory

SAAJMetaFactory.newMessageFactory​(String protocol)

为给定的 String协议创建一个 MessageFactory对象。

protected abstract SOAPFactory

SAAJMetaFactory.newSOAPFactory​(String protocol)

为给定的 String协议创建一个 SOAPFactory对象。

void

MimeHeaders.removeHeader​(String name)

删除名称与给定名称匹配的所有 MimeHeader对象。

abstract void

AttachmentPart.removeMimeHeader​(String header)

删除与给定名称相匹配的所有MIME标头。

abstract void

SOAPPart.removeMimeHeader​(String header)

删除与给定名称相匹配的所有MIME标头。

boolean

SOAPElement.removeNamespaceDeclaration​(String prefix)

删除与给定前缀相对应的命名空间声明。

void

SOAPHeaderElement.setActor​(String actorURI)

将与此 SOAPHeaderElement对象相关联的actor设置为指定的actor。

abstract void

AttachmentPart.setBase64Content​(InputStream content, String contentType)

将此附件部分从所述的Base64源的内容 InputStream和设置的值 Content-Type头中包含的值 contentType ，此方法将首先解码的base64输入并写入到附接所得的原始字节。

abstract void

AttachmentPart.setContent​(Object object, String contentType)

将此附件部分的内容设置为给定的 Object的内容，并将 Content-Type标头的值设置为给定类型。

abstract void

SOAPMessage.setContentDescription​(String description)

使用给定的说明设置此 SOAPMessage对象的内容的描述。

void

AttachmentPart.setContentId​(String contentId)

使用给定值设置名称为“Content-ID”的MIME标头。

void

SOAPPart.setContentId​(String contentId)

将名为“Content-Id”的MIME头的值设置为给定的 String 。

void

AttachmentPart.setContentLocation​(String contentLocation)

使用给定值设置名称为“Content-Location”的MIME头。

void

SOAPPart.setContentLocation​(String contentLocation)

将MIME标题“Content-Location”的值设置为给定的 String 。

void

AttachmentPart.setContentType​(String contentType)

使用给定值设置名称为“Content-Type”的MIME头。

void

SOAPElement.setEncodingStyle​(String encodingStyle)

将此 SOAPElement对象的编码样式设置为一个指定。

void

SOAPFault.setFaultActor​(String faultActor)

使用给定的故障演员设置此 SOAPFault对象。

void

SOAPFault.setFaultCode​(String faultCode)

使用给定故障代码设置此 SOAPFault对象。

void

SOAPFault.setFaultNode​(String uri)

创建或替换此 SOAPFault对象的任何现有Node元素值。

void

SOAPFault.setFaultRole​(String uri)

创建或替换此 SOAPFault对象的任何现有Role元素值。

void

SOAPFault.setFaultString​(String faultString)

将此 SOAPFault对象的故障字符串设置为给定的字符串。

void

SOAPFault.setFaultString​(String faultString, Locale locale)

将此 SOAPFault对象的故障字符串设置为给定的字符串，并将其定位到给定的区域设置。

void

MimeHeaders.setHeader​(String name, String value)

将名称与给定名称匹配的第一个标题条目的当前值替换为给定值，如果没有现有的标题名称匹配，则添加一个新标题。

abstract void

AttachmentPart.setMimeHeader​(String name, String value)

将与给定名称匹配的第一个标题条目更改为给定值，如果没有现有标题匹配，则添加一个新标题。

abstract void

SOAPPart.setMimeHeader​(String name, String value)

更改与给定标题名称匹配的第一个标题条目，以使其值为给定值，如果没有现有标题匹配，则添加具有给定名称和值的新标题。

void

SOAPMessage.setProperty​(String property, Object value)

将指定的值与指定的属性相关联。

abstract void

AttachmentPart.setRawContent​(InputStream content, String contentType)

将此附件部分以使得由包含的内容 InputStream content并设定的值 Content-Type头中所包含的值 contentType 。

abstract void

AttachmentPart.setRawContentBytes​(byte[] content, int offset, int len, String contentType)

将此附件部分以使得由包含的内容 byte[]阵列 content并设置的值 Content-Type头中所包含的值 contentType 。

void

SOAPHeaderElement.setRole​(String uri)

将与此 SOAPHeaderElement对象相关联的 Role设置为指定的 Role 。

void

Node.setValue​(String value)

如果这是一个Text节点，那么这个方法将设置它的值，否则它设置该节点的immediate（Text）子节点的值。

Method parameters in javax.xml.soap with type arguments of type String

Modifier and Type

方法

描述

SOAPHeaderElement

SOAPHeader.addUpgradeHeaderElement​(Iterator<String> supportedSOAPURIs)

创建一个新的升级 SOAPHeaderElement对象，并使用指定的支持的SOAP URI的String Iterator进行初始化，并将其添加到此 SOAPHeader对象。

Constructors in javax.xml.soap with parameters of type String

Constructor

描述

MimeHeader​(String name, String value)

构造一个用给定的名称和值初始化的 MimeHeader对象。

SAAJResult​(String protocol)

创建一个 SAAJResult ，将以支持指定协议的SAAJ树的形式显示结果。

SOAPException​(String reason)

构造一个 SOAPException对象与给定的 String作为抛出异常的原因。

SOAPException​(String reason, Throwable cause)

构造一个 SOAPException对象，给定的 String作为引发异常的原因，给定的 Throwable对象作为嵌入式异常。

Uses of String in javax.xml.stream

Fields in javax.xml.stream declared as String

Modifier and Type

Field

描述

static String

XMLInputFactory.ALLOCATOR

该属性用于设置/获取分配器的实现

static String

XMLInputFactory.IS_COALESCING

需要解析器来合并相邻字符数据部分的属性

static String

XMLInputFactory.IS_NAMESPACE_AWARE

该属性用于打开/关闭命名空间支持，这是为了支持XML 1.0文档，只有真正的设置必须被支持

static String

XMLOutputFactory.IS_REPAIRING_NAMESPACES

用于在输出端设置前缀默认值的属性

static String

XMLInputFactory.IS_REPLACING_ENTITY_REFERENCES

需要解析器用其替换文本替换内部实体引用并将其报告为字符

static String

XMLInputFactory.IS_SUPPORTING_EXTERNAL_ENTITIES

需要解析器解析外部解析实体的属性

static String

XMLInputFactory.IS_VALIDATING

用于打开/关闭实现特定验证的属性

static String

XMLInputFactory.REPORTER

该属性用于设置/获取XMLReporter接口的实现

static String

XMLInputFactory.RESOLVER

该属性用于设置/获取XMLResolver的实现

static String

XMLInputFactory.SUPPORT_DTD

需要解析器支持DTD的属性

Methods in javax.xml.stream that return String

Modifier and Type

方法

描述

String

XMLStreamReader.getAttributeLocalName​(int index)

返回提供的索引处的属性的localName

String

XMLStreamReader.getAttributeNamespace​(int index)

返回在提供的索引处的属性的命名空间

String

XMLStreamReader.getAttributePrefix​(int index)

在提供的索引处返回此属性的前缀

String

XMLStreamReader.getAttributeType​(int index)

返回提供的索引处的属性的XML类型

String

XMLStreamReader.getAttributeValue​(int index)

返回索引处的属性值

String

XMLStreamReader.getAttributeValue​(String namespaceURI, String localName)

返回具有命名空间和localName的属性的归一化属性值如果namespaceURI为空，则不会检查命名空间是否相等

String

XMLStreamReader.getCharacterEncodingScheme​()

返回在xml声明中声明的字符编码如果没有声明，则返回null

String

XMLEventReader.getElementText​()

读取纯文本元素的内容。

String

XMLStreamReader.getElementText​()

读取纯文本元素的内容，如果这不是纯文本元素，则抛出异常。

String

XMLStreamReader.getEncoding​()

如果已知返回输入编码，如果未知则返回null。

String

XMLStreamReader.getLocalName​()

返回当前事件的（本地）名称。

String

FactoryConfigurationError.getMessage​()

报告与此错误相关联的消息

String

XMLStreamReader.getNamespacePrefix​(int index)

返回在索引处声明的命名空间的前缀。

String

XMLStreamReader.getNamespaceURI​()

如果当前事件是START_ELEMENT或END_ELEMENT，则此方法返回前缀或缺省命名空间的URI。

String

XMLStreamReader.getNamespaceURI​(int index)

返回在索引处声明的命名空间的uri。

String

XMLStreamReader.getNamespaceURI​(String prefix)

返回给定前缀的uri。

String

XMLStreamReader.getPIData​()

获取处理指令的数据部分

String

XMLStreamReader.getPITarget​()

获取处理指令的目标

String

XMLEventWriter.getPrefix​(String uri)

获取uri绑定的前缀

String

XMLStreamReader.getPrefix​()

返回当前事件的前缀，如果事件没有前缀，则返回null

String

XMLStreamWriter.getPrefix​(String uri)

获取uri绑定的前缀

String

Location.getPublicId​()

返回XML的公共ID

String

Location.getSystemId​()

返回XML的系统ID

String

XMLStreamReader.getText​()

以字符串形式返回解析事件的当前值，返回CHARACTERS事件的字符串值，返回COMMENT的值，ENTITY_REFERENCE的替换值，CDATA部分的字符串值，SPACE的字符串值事件或DTD的内部子集的String值。

String

XMLStreamReader.getVersion​()

获取在xml声明中声明的xml版本如果没有声明，则返回null

Methods in javax.xml.stream with parameters of type String

Modifier and Type

方法

描述

abstract Attribute

XMLEventFactory.createAttribute​(String localName, String value)

创建一个新的属性

abstract Attribute

XMLEventFactory.createAttribute​(String prefix, String namespaceURI, String localName, String value)

创建一个新的属性

abstract Attribute

XMLEventFactory.createAttribute​(QName name, String value)

创建一个新的属性

abstract Characters

XMLEventFactory.createCData​(String content)

创建一个Charata事件，CData标志设置为true

abstract Characters

XMLEventFactory.createCharacters​(String content)

创建一个Characters事件，此方法不检查内容是否为空白。

abstract Comment

XMLEventFactory.createComment​(String text)

创建评论

abstract DTD

XMLEventFactory.createDTD​(String dtd)

创建文档类型定义事件此字符串包含与XML 1.0规范中的doctypedecl匹配的整个文档类型声明

abstract EndElement

XMLEventFactory.createEndElement​(String prefix, String namespaceUri, String localName)

创建一个新的EndElement

abstract EndElement

XMLEventFactory.createEndElement​(String prefix, String namespaceUri, String localName, Iterator<? extends Namespace> namespaces)

创建一个新的EndElement

abstract EntityReference

XMLEventFactory.createEntityReference​(String name, EntityDeclaration declaration)

创建EntityReference事件的新实例

abstract Characters

XMLEventFactory.createIgnorableSpace​(String content)

创建一个可忽略的空间

abstract Namespace

XMLEventFactory.createNamespace​(String namespaceURI)

创建一个新的默认命名空间

abstract Namespace

XMLEventFactory.createNamespace​(String prefix, String namespaceUri)

创建一个新的命名空间

abstract ProcessingInstruction

XMLEventFactory.createProcessingInstruction​(String target, String data)

创建处理指令

abstract Characters

XMLEventFactory.createSpace​(String content)

创建一个字符事件，将isSpace标志设置为true

abstract StartDocument

XMLEventFactory.createStartDocument​(String encoding)

创建一个StartDocument事件的新实例

abstract StartDocument

XMLEventFactory.createStartDocument​(String encoding, String version)

创建一个StartDocument事件的新实例

abstract StartDocument

XMLEventFactory.createStartDocument​(String encoding, String version, boolean standalone)

创建一个StartDocument事件的新实例

abstract StartElement

XMLEventFactory.createStartElement​(String prefix, String namespaceUri, String localName)

创建一个新的StartElement。

abstract StartElement

XMLEventFactory.createStartElement​(String prefix, String namespaceUri, String localName, Iterator<? extends Attribute> attributes, Iterator<? extends Namespace> namespaces)

创建一个新的StartElement。

abstract StartElement

XMLEventFactory.createStartElement​(String prefix, String namespaceUri, String localName, Iterator<? extends Attribute> attributes, Iterator<? extends Namespace> namespaces, NamespaceContext context)

创建一个新的StartElement。

abstract XMLEventReader

XMLInputFactory.createXMLEventReader​(InputStream stream, String encoding)

从java.io.InputStream创建一个新的XMLEventReader

abstract XMLEventReader

XMLInputFactory.createXMLEventReader​(String systemId, InputStream stream)

从java.io.InputStream创建一个新的XMLEventReader

abstract XMLEventReader

XMLInputFactory.createXMLEventReader​(String systemId, Reader reader)

从阅读器创建一个新的XMLEventReader

abstract XMLEventWriter

XMLOutputFactory.createXMLEventWriter​(OutputStream stream, String encoding)

创建一个写入流的新XMLEventWriter

abstract XMLStreamReader

XMLInputFactory.createXMLStreamReader​(InputStream stream, String encoding)

从java.io.InputStream创建一个新的XMLStreamReader

abstract XMLStreamReader

XMLInputFactory.createXMLStreamReader​(String systemId, InputStream stream)

从java.io.InputStream创建一个新的XMLStreamReader

abstract XMLStreamReader

XMLInputFactory.createXMLStreamReader​(String systemId, Reader reader)

从java.io.InputStream创建一个新的XMLStreamReader

abstract XMLStreamWriter

XMLOutputFactory.createXMLStreamWriter​(OutputStream stream, String encoding)

创建一个写入流的新XMLStreamWriter

String

XMLStreamReader.getAttributeValue​(String namespaceURI, String localName)

返回具有命名空间和localName的属性的归一化属性值如果namespaceURI为空，则不会检查命名空间是否相等

String

XMLStreamReader.getNamespaceURI​(String prefix)

返回给定前缀的uri。

String

XMLEventWriter.getPrefix​(String uri)

获取uri绑定的前缀

String

XMLStreamWriter.getPrefix​(String uri)

获取uri绑定的前缀

Object

XMLEventReader.getProperty​(String name)

从底层实现获取特征/属性的值

abstract Object

XMLInputFactory.getProperty​(String name)

从底层实现获取特征/属性的值

abstract Object

XMLOutputFactory.getProperty​(String name)

获取底层实现的功能/属性

Object

XMLStreamReader.getProperty​(String name)

从底层实现获取特征/属性的值

Object

XMLStreamWriter.getProperty​(String name)

从底层实现获取特征/属性的值

abstract boolean

XMLInputFactory.isPropertySupported​(String name)

查询此工厂支持的属性集。

abstract boolean

XMLOutputFactory.isPropertySupported​(String name)

查询此工厂支持的属性集。

static XMLEventFactory

XMLEventFactory.newFactory​(String factoryId, ClassLoader classLoader)

创建一个新的工厂实例。

static XMLInputFactory

XMLInputFactory.newFactory​(String factoryId, ClassLoader classLoader)

创建一个新的工厂实例。

static XMLOutputFactory

XMLOutputFactory.newFactory​(String factoryId, ClassLoader classLoader)

创建一个新的工厂实例。

static XMLEventFactory

XMLEventFactory.newInstance​(String factoryId, ClassLoader classLoader)

已过时。
该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替代XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。

static XMLInputFactory

XMLInputFactory.newInstance​(String factoryId, ClassLoader classLoader)

已过时。
该方法已被弃用，以保持API的一致性。 所有newInstance方法已被替换为相应的newFactory方法。 替换XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader)方法定义行为没有变化。

static XMLInputFactory

XMLOutputFactory.newInstance​(String factoryId, ClassLoader classLoader)

已过时。
此方法已被弃用，因为它返回一个XMLInputFactory的实例，该实例是错误的类。 改用新的方法XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) 。

void

XMLReporter.report​(String message, String errorType, Object relatedInformation, Location location)

以应用程序特定格式报告所需的消息。

void

XMLStreamReader.require​(int type, String namespaceURI, String localName)

测试当前事件是否为给定类型，如果命名空间和名称与当前命名空间和当前事件的名称相匹配。

Object

XMLResolver.resolveEntity​(String publicID, String systemID, String baseURI, String namespace)

检索资源。

void

XMLEventWriter.setDefaultNamespace​(String uri)

将URI绑定到默认命名空间此URI绑定在当前START_ELEMENT / END_ELEMENT对的范围内。

void

XMLStreamWriter.setDefaultNamespace​(String uri)

将URI绑定到默认命名空间此URI绑定在当前START_ELEMENT / END_ELEMENT对的范围内。

void

XMLEventWriter.setPrefix​(String prefix, String uri)

设置uri所绑定的前缀。

void

XMLStreamWriter.setPrefix​(String prefix, String uri)

设置uri所绑定的前缀。

abstract void

XMLInputFactory.setProperty​(String name, Object value)

允许用户在底层实现上设置特定的功能/属性。

abstract void

XMLOutputFactory.setProperty​(String name, Object value)

允许用户在底层实现上设置特定的功能/属性。

void

XMLStreamWriter.writeAttribute​(String localName, String value)

将不带前缀的属性写入输出流。

void

XMLStreamWriter.writeAttribute​(String namespaceURI, String localName, String value)

将一个属性写入输出流

void

XMLStreamWriter.writeAttribute​(String prefix, String namespaceURI, String localName, String value)

将一个属性写入输出流

void

XMLStreamWriter.writeCData​(String data)

写一个CData部分

void

XMLStreamWriter.writeCharacters​(String text)

将文本写入输出

void

XMLStreamWriter.writeComment​(String data)

用附带的数据写入一个xml注释

void

XMLStreamWriter.writeDefaultNamespace​(String namespaceURI)

将默认命名空间写入流

void

XMLStreamWriter.writeDTD​(String dtd)

写一个DTD部分。

void

XMLStreamWriter.writeEmptyElement​(String localName)

将一个空的元素标签写入输出

void

XMLStreamWriter.writeEmptyElement​(String namespaceURI, String localName)

将一个空的元素标签写入输出

void

XMLStreamWriter.writeEmptyElement​(String prefix, String localName, String namespaceURI)

将一个空的元素标签写入输出

void

XMLStreamWriter.writeEntityRef​(String name)

写实体引用

void

XMLStreamWriter.writeNamespace​(String prefix, String namespaceURI)

将命名空间写入输出流如果此方法的前缀参数为空字符串“xmlns”，或为null，则此方法将委托为writeDefaultNamespace

void

XMLStreamWriter.writeProcessingInstruction​(String target)

写一个处理指令

void

XMLStreamWriter.writeProcessingInstruction​(String target, String data)

写一个处理指令

void

XMLStreamWriter.writeStartDocument​(String version)

编写XML声明

void

XMLStreamWriter.writeStartDocument​(String encoding, String version)

编写XML声明

void

XMLStreamWriter.writeStartElement​(String localName)

将开始标签写入输出。

void

XMLStreamWriter.writeStartElement​(String namespaceURI, String localName)

将开始标签写入输出

void

XMLStreamWriter.writeStartElement​(String prefix, String localName, String namespaceURI)

将开始标签写入输出

Constructors in javax.xml.stream with parameters of type String

Constructor

描述

FactoryConfigurationError​(异常 e, String msg)

使用嵌套的内部异常和消息构造异常

FactoryConfigurationError​(String msg)

使用关联的消息构造异常

FactoryConfigurationError​(String msg, 异常 e)

使用嵌套的内部异常和消息构造异常

XMLStreamException​(String msg)

使用关联的消息构造异常。

XMLStreamException​(String msg, Throwable th)

使用关联的消息和异常构造异常

XMLStreamException​(String msg, Location location)

使用关联的消息，异常和位置构造异常。

XMLStreamException​(String msg, Location location, Throwable th)

使用关联的消息，异常和位置构造异常。

Uses of String in javax.xml.stream.events

Methods in javax.xml.stream.events that return String

Modifier and Type

方法

描述

String

EntityDeclaration.getBaseURI​()

获取此引用的基本URI，如果此信息不可用，则为null

String

StartDocument.getCharacterEncodingScheme​()

返回XML数据的编码样式

String

Characters.getData​()

获取此事件的字符数据

String

ProcessingInstruction.getData​()

处理指令的数据部分

String

DTD.getDocumentTypeDeclaration​()

以字符串形式返回整个文档类型声明，包括内部DTD子集。

String

Attribute.getDTDType​()

获取此属性的类型，默认为String“CDATA”

String

EntityDeclaration.getName​()

实体的名字

String

EntityReference.getName​()

实体的名称

String

NotationDeclaration.getName​()

符号名称。

String

Namespace.getNamespaceURI​()

获取绑定到此名称空间前缀的uri

String

StartElement.getNamespaceURI​(String prefix)

在该元素的上下文中获取前缀所绑定的值。

String

EntityDeclaration.getNotationName​()

关联符号的名称。

String

Namespace.getPrefix​()

获取前缀，如果这是默认命名空间声明，则返回“”。

String

EntityDeclaration.getPublicId​()

实体的公共标识符，如果没有给定，则为null

String

NotationDeclaration.getPublicId​()

符号的公共标识符，如果没有给定，则为null。

String

EntityDeclaration.getReplacementText​()

实体的替换文本。

String

EntityDeclaration.getSystemId​()

实体的系统标识符。

String

NotationDeclaration.getSystemId​()

符号的系统标识符，如果没有给定，则为null。

String

StartDocument.getSystemId​()

返回XML数据的系统ID

String

ProcessingInstruction.getTarget​()

处理指令的目标部分

String

Comment.getText​()

返回注释的字符串数据，如果不存在则返回空字符串

String

Attribute.getValue​()

获取此属性的归一化值

String

StartDocument.getVersion​()

返回此XML流的XML版本

Methods in javax.xml.stream.events with parameters of type String

Modifier and Type

方法

描述

String

StartElement.getNamespaceURI​(String prefix)

在该元素的上下文中获取前缀所绑定的值。

Uses of String in javax.xml.stream.util

Methods in javax.xml.stream.util that return String

Modifier and Type

方法

描述

String

StreamReaderDelegate.getAttributeLocalName​(int index)

String

StreamReaderDelegate.getAttributeNamespace​(int index)

String

StreamReaderDelegate.getAttributePrefix​(int index)

String

StreamReaderDelegate.getAttributeType​(int index)

String

StreamReaderDelegate.getAttributeValue​(int index)

String

StreamReaderDelegate.getAttributeValue​(String namespaceUri, String localName)

String

StreamReaderDelegate.getCharacterEncodingScheme​()

String

EventReaderDelegate.getElementText​()

String

StreamReaderDelegate.getElementText​()

String

StreamReaderDelegate.getEncoding​()

String

StreamReaderDelegate.getLocalName​()

String

StreamReaderDelegate.getNamespacePrefix​(int index)

String

StreamReaderDelegate.getNamespaceURI​()

String

StreamReaderDelegate.getNamespaceURI​(int index)

String

StreamReaderDelegate.getNamespaceURI​(String prefix)

String

StreamReaderDelegate.getPIData​()

String

StreamReaderDelegate.getPITarget​()

String

StreamReaderDelegate.getPrefix​()

String

StreamReaderDelegate.getText​()

String

StreamReaderDelegate.getVersion​()

Methods in javax.xml.stream.util with parameters of type String

Modifier and Type

方法

描述

String

StreamReaderDelegate.getAttributeValue​(String namespaceUri, String localName)

String

StreamReaderDelegate.getNamespaceURI​(String prefix)

Object

EventReaderDelegate.getProperty​(String name)

Object

StreamReaderDelegate.getProperty​(String name)

void

StreamReaderDelegate.require​(int type, String namespaceURI, String localName)

Uses of String in javax.xml.transform

Fields in javax.xml.transform declared as String

Modifier and Type

Field

描述

static String

OutputKeys.CDATA_SECTION_ELEMENTS

cdata-section-elements = 扩展名 。

static String

OutputKeys.DOCTYPE_PUBLIC

doctype-public = string 。

static String

OutputKeys.DOCTYPE_SYSTEM

doctype-system = string 。

static String

OutputKeys.ENCODING

encoding = string 。

static String

OutputKeys.INDENT

indent =“yes”| “没有”。

static String

OutputKeys.MEDIA_TYPE

media-type = string 。

static String

OutputKeys.METHOD

method =“xml”| “html”| “text”| 扩展名称

static String

OutputKeys.OMIT_XML_DECLARATION

omit-xml-declaration =“yes”| “没有”。

static String

Result.PI_DISABLE_OUTPUT_ESCAPING

如果结果树禁用输出转义，则发送的处理指令的名称。

static String

Result.PI_ENABLE_OUTPUT_ESCAPING

如果结果树在接收到PI_DISABLE_OUTPUT_ESCAPING处理指令之后在某个时间点使输出转义，则发送的处理指令的名称。

static String

OutputKeys.STANDALONE

standalone =“yes”| “没有”。

static String

OutputKeys.VERSION

version = nmtoken 。

Methods in javax.xml.transform that return String

Modifier and Type

方法

描述

String

TransformerException.getLocationAsString​()

以字符串形式获取位置信息。

String

TransformerFactoryConfigurationError.getMessage​()

返回此错误的消息（如果有）。

String

TransformerException.getMessageAndLocation​()

获取附加位置信息的错误消息。

abstract String

Transformer.getOutputProperty​(String name)

获取对变压器有效的输出属性。

String

SourceLocator.getPublicId​()

返回当前文档事件的公共标识符。

String

Result.getSystemId​()

获取使用setSystemId设置的系统标识符。

String

Source.getSystemId​()

获取使用setSystemId设置的系统标识符。

String

SourceLocator.getSystemId​()

返回当前文档事件的系统标识符。

Methods in javax.xml.transform with parameters of type String

Modifier and Type

方法

描述

abstract Source

TransformerFactory.getAssociatedStylesheet​(Source source, String media, String title, String charset)

通过符合给定条件的 xml-stylesheet processing instruction获取与XML Source文档相关联的样式表规范。

abstract Object

TransformerFactory.getAttribute​(String name)

允许用户检索底层实现的特定属性。

abstract boolean

TransformerFactory.getFeature​(String name)

查找功能的值。

abstract String

Transformer.getOutputProperty​(String name)

获取对变压器有效的输出属性。

abstract Object

Transformer.getParameter​(String name)

获取使用setParameter显式设置的参数。

static TransformerFactory

TransformerFactory.newInstance​(String factoryClassName, ClassLoader classLoader)

从工厂类名称获取一个新的实例 TransformerFactory 。

Source

URIResolver.resolve​(String href, String base)

处理器遇到xsl：include，xsl：import或document（）函数时调用。

abstract void

TransformerFactory.setAttribute​(String name, Object value)

允许用户在底层实现上设置特定属性。

abstract void

TransformerFactory.setFeature​(String name, boolean value)

设置此工厂创建的 TransformerFactory和 Transformer s或 Template的功能。

abstract void

Transformer.setOutputProperty​(String name, String value)

设置一个对转换有效的输出属性。

abstract void

Transformer.setParameter​(String name, Object value)

添加转换参数。

void

Result.setSystemId​(String systemId)

设置此结果的系统标识符。

void

Source.setSystemId​(String systemId)

设置此源的系统标识符。

Constructors in javax.xml.transform with parameters of type String

Constructor

描述

TransformerConfigurationException​(String msg)

创建一个新的 TransformerConfigurationException ，其中 String指定为错误消息。

TransformerConfigurationException​(String msg, Throwable e)

创建一个新的 TransformerConfigurationException与给定的 异常基本原因和详细信息。

TransformerConfigurationException​(String message, SourceLocator locator)

从消息和定位器创建一个新的TransformerConfigurationException。

TransformerConfigurationException​(String message, SourceLocator locator, Throwable e)

在TransformerConfigurationException中包装一个现有的异常。

TransformerException​(String message)

创建一个新的TransformerException。

TransformerException​(String message, Throwable e)

在TransformerException中包含一个现有的异常。

TransformerException​(String message, SourceLocator locator)

从消息和定位器创建一个新的TransformerException。

TransformerException​(String message, SourceLocator locator, Throwable e)

在TransformerException中包含一个现有的异常。

TransformerFactoryConfigurationError​(异常 e, String msg)

创建一个新的 TransformerFactoryConfigurationError与给定的 异常基本原因和详细信息。

TransformerFactoryConfigurationError​(String msg)

创建一个新的 TransformerFactoryConfigurationError ，其中 String指定为错误消息。

Uses of String in javax.xml.transform.dom

Fields in javax.xml.transform.dom declared as String

Modifier and Type

Field

描述

static String

DOMResult.FEATURE

如果 TransformerFactory.getFeature(java.lang.String)通过该值作为参数返回 true ，则 Transformer支持此类型的 Result输出。

static String

DOMSource.FEATURE

如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer支持此类型的Source输入。

Methods in javax.xml.transform.dom that return String

Modifier and Type

方法

描述

String

DOMResult.getSystemId​()

获取系统标识符。

String

DOMSource.getSystemId​()

获取基址（URL或系统ID），从中解析URL。

Methods in javax.xml.transform.dom with parameters of type String

Modifier and Type

方法

描述

void

DOMResult.setSystemId​(String systemId)

设置可能与节点关联使用的systemId。

void

DOMSource.setSystemId​(String systemID)

设置基址（URL或系统ID）从哪里解决URL。

Constructors in javax.xml.transform.dom with parameters of type String

Constructor

描述

DOMResult​(Node node, String systemId)

使用DOM节点创建具有指定的系统ID的新的输出目标。

DOMResult​(Node node, Node nextSibling, String systemId)

使用DOM节点创建一个新的输出目标，指定要在其中插入结果节点的子节点和指定的系统ID。

DOMSource​(Node node, String systemID)

使用DOM节点创建一个新的输入源，并且系统ID也作为基本URI传入。

Uses of String in javax.xml.transform.sax

Fields in javax.xml.transform.sax declared as String

Modifier and Type

Field

描述

static String

SAXResult.FEATURE

如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer支持此类型的Result输出。

static String

SAXSource.FEATURE

如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer支持此类型的Source输入。

static String

SAXTransformerFactory.FEATURE

如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则可以将从 TransformerFactory.newInstance()返回的TransformerFactory安全地转换为SAXTransformerFactory。

static String

SAXTransformerFactory.FEATURE_XMLFILTER

如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则支持 SAXTransformerFactory.newXMLFilter(Source src)和 SAXTransformerFactory.newXMLFilter(Templates templates)方法。

Methods in javax.xml.transform.sax that return String

Modifier and Type

方法

描述

String

SAXResult.getSystemId​()

获取使用setSystemId设置的系统标识符。

String

SAXSource.getSystemId​()

获取URI将被解析的基本ID（URI或系统ID）。

String

TemplatesHandler.getSystemId​()

获取从其中相对URL被解析的基本ID（URI或系统ID）。

String

TransformerHandler.getSystemId​()

获取从其中相对URL被解析的基本ID（URI或系统ID）。

Methods in javax.xml.transform.sax with parameters of type String

Modifier and Type

方法

描述

void

SAXResult.setSystemId​(String systemId)

方法setSystemId设置可以与ContentHandler相关联使用的systemID 。

void

SAXSource.setSystemId​(String systemId)

设置此源的系统标识符。

void

TemplatesHandler.setSystemId​(String systemID)

设置由此构建器创建的Templates对象的基本ID（URI或系统ID）。

void

TransformerHandler.setSystemId​(String systemID)

设置相对URL将被解析的基本ID（URI或系统ID）。

Uses of String in javax.xml.transform.stax

Fields in javax.xml.transform.stax declared as String

Modifier and Type

Field

描述

static String

StAXResult.FEATURE

如果 TransformerFactory.getFeature(String name)将该值作为参数传递时返回true，则Transformer将支持此类型的Result输出。

static String

StAXSource.FEATURE

如果 TransformerFactory.getFeature(String name)在将此值作为参数传递时返回true，则Transformer支持此类型的Source输入。

Methods in javax.xml.transform.stax that return String

Modifier and Type

方法

描述

String

StAXResult.getSystemId​()

返回的系统标识符始终为 null 。

String

StAXSource.getSystemId​()

获取此 StAXSource使用的系统标识符。

Methods in javax.xml.transform.stax with parameters of type String

Modifier and Type

方法

描述

void

StAXResult.setSystemId​(String systemId)

在 StAXResult的上下文中，显式设置系统标识符是不合适的。

void

StAXSource.setSystemId​(String systemId)

在 StAXSource的上下文中，明确设置系统标识符是不合适的。

Uses of String in javax.xml.transform.stream

Fields in javax.xml.transform.stream declared as String

Modifier and Type

Field

描述

static String

StreamResult.FEATURE

如果 TransformerFactory.getFeature(java.lang.String)将该值作为参数传递时返回true，则Transformer将支持此类型的Result输出。

static String

StreamSource.FEATURE

如果在传递此值作为参数时， TransformerFactory.getFeature(java.lang.String)返回true，则Transformer支持此类型的Source输入。

Methods in javax.xml.transform.stream that return String

Modifier and Type

方法

描述

String

StreamSource.getPublicId​()

获取使用setPublicId设置的公共标识符。

String

StreamResult.getSystemId​()

获取使用setSystemId设置的系统标识符。

String

StreamSource.getSystemId​()

获取使用setSystemId设置的系统标识符。

Methods in javax.xml.transform.stream with parameters of type String

Modifier and Type

方法

描述

void

StreamSource.setPublicId​(String publicId)

设置此源的公共标识符。

void

StreamResult.setSystemId​(String systemId)

设置可以与字节或字符流相关联使用的systemID，或者如果两者都不设置，则将该值用作可写URI（可能是文件名）。

void

StreamSource.setSystemId​(String systemId)

设置此源的系统标识符。

Constructors in javax.xml.transform.stream with parameters of type String

Constructor

描述

StreamResult​(String systemId)

从URL构造一个StreamResult。

StreamSource​(InputStream inputStream, String systemId)

从字节流构造一个StreamSource。

StreamSource​(Reader reader, String systemId)

从字符读取器构造一个StreamSource。

StreamSource​(String systemId)

从URL构造一个StreamSource。

Uses of String in javax.xml.validation

Methods in javax.xml.validation with parameters of type String

Modifier and Type

方法

描述

boolean

SchemaFactory.getFeature​(String name)

查找特征标记的值。

boolean

Validator.getFeature​(String name)

查找特征标记的值。

boolean

ValidatorHandler.getFeature​(String name)

查找特征标记的值。

Object

SchemaFactory.getProperty​(String name)

查找属性的值。

Object

Validator.getProperty​(String name)

查找属性的值。

Object

ValidatorHandler.getProperty​(String name)

查找属性的值。

abstract boolean

SchemaFactory.isSchemaLanguageSupported​(String schemaLanguage)

是这个 SchemaFactory支持的指定模式？

abstract SchemaFactory

SchemaFactoryLoader.newFactory​(String schemaLanguage)

为指定的模式语言创建一个新的SchemaFactory对象。

static SchemaFactory

SchemaFactory.newInstance​(String schemaLanguage)

查找支持指定模式语言并返回它的 SchemaFactory的实现。

static SchemaFactory

SchemaFactory.newInstance​(String schemaLanguage, String factoryClassName, ClassLoader classLoader)

从类名获取一个新的实例 SchemaFactory 。

void

SchemaFactory.setFeature​(String name, boolean value)

设置了一个功能，这个SchemaFactory ， Schema个此工厂创建S，推而广之， Validator个 S和ValidatorHandler那些创建小号Schema秒。

void

Validator.setFeature​(String name, boolean value)

设置特征标志的值。

void

ValidatorHandler.setFeature​(String name, boolean value)

为此设置一个功能 ValidatorHandler 。

void

SchemaFactory.setProperty​(String name, Object object)

设置属性的值。

void

Validator.setProperty​(String name, Object object)

设置属性的值。

void

ValidatorHandler.setProperty​(String name, Object object)

设置属性的值。

Constructors in javax.xml.validation with parameters of type String

Constructor

描述

SchemaFactoryConfigurationError​(String message)

创建一个新的 SchemaFactoryConfigurationError ，其中 String指定为错误消息。

SchemaFactoryConfigurationError​(String message, Throwable cause)

创建一个新的 SchemaFactoryConfigurationError与给定的 Throwable基本原因和详细信息。

Uses of String in javax.xml.ws

Fields in javax.xml.ws declared as String

Modifier and Type

Field

描述

static String

BindingProvider.ENDPOINT_ADDRESS_PROPERTY

标准属性：目标服务端点地址。

static String

RespectBindingFeature.ID

识别RespectBindingFeature的常量值

static String

BindingProvider.PASSWORD_PROPERTY

标准属性：验证密码。

static String

BindingProvider.SESSION_MAINTAIN_PROPERTY

标准属性：此布尔属性由服务客户端用于指示是否要参与与服务端点的会话。

static String

BindingProvider.SOAPACTION_URI_PROPERTY

SOAPAction的标准属性。

static String

BindingProvider.SOAPACTION_USE_PROPERTY

SOAPAction的标准属性。

static String

BindingProvider.USERNAME_PROPERTY

标准属性：认证用户名。

static String

Endpoint.WSDL_PORT

标准属性：WSDL端口的名称。

static String

Endpoint.WSDL_SERVICE

标准属性：WSDL服务的名称。

Methods in javax.xml.ws that return String

Modifier and Type

方法

描述

String

Binding.getBindingID​()

获取此绑定实例的URI。

String

RespectBindingFeature.getID​()

获取此WebServiceFeature的唯一标识符。

abstract String

WebServiceFeature.getID​()

获取此WebServiceFeature的唯一标识符。

String

EndpointReference.toString​()

显示EPR信息，方便调试。

Methods in javax.xml.ws that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,Object>

Response.getContext​()

获取包含的响应上下文。

abstract Map<String,Object>

Endpoint.getProperties​()

返回此 Endpoint实例的资源袋。

Map<String,Object>

BindingProvider.getRequestContext​()

获取用于初始化请求消息的消息上下文的上下文。

Map<String,Object>

BindingProvider.getResponseContext​()

获取处理响应消息产生的上下文。

Methods in javax.xml.ws with parameters of type String

Modifier and Type

方法

描述

void

Service.addPort​(QName portName, String bindingId, String endpointAddress)

为服务创建一个新的端口。

static Endpoint

Endpoint.create​(String bindingId, Object implementor)

创建具有指定绑定类型和实现方对象的端点。

static Endpoint

Endpoint.create​(String bindingId, Object implementor, WebServiceFeature... features)

创建具有指定绑定类型，实现方对象和Web服务功能的端点。

boolean

WebServiceContext.isUserInRole​(String role)

返回一个布尔值，指示经过身份验证的用户是否包含在指定的逻辑角色中。

abstract void

Endpoint.publish​(String address)

在给定地址发布此端点。

static Endpoint

Endpoint.publish​(String address, Object implementor)

在给定的地址创建并发布指定的实现者对象的端点。

static Endpoint

Endpoint.publish​(String address, Object implementor, WebServiceFeature... features)

在给定的地址创建并发布指定的实现者对象的端点。

static Service.Mode

Service.Mode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in javax.xml.ws with type arguments of type String

Modifier and Type

方法

描述

abstract void

Endpoint.setProperties​(Map<String,Object> properties)

设置此 Endpoint实例的属性包。

Constructors in javax.xml.ws with parameters of type String

Constructor

描述

ProtocolException​(String message)

使用指定的详细消息构造新的协议异常。

ProtocolException​(String message, Throwable cause)

构造一个新的运行时异常与指定的详细信息和原因。

WebServiceException​(String message)

使用指定的详细消息构造新的异常。

WebServiceException​(String message, Throwable cause)

构造一个新的异常与指定的详细信息和原因。

WebServicePermission​(String name)

创建具有指定名称的新权限。

WebServicePermission​(String name, String actions)

创建具有指定名称和操作的新权限。

Uses of String in javax.xml.ws.handler

Fields in javax.xml.ws.handler declared as String

Modifier and Type

Field

描述

static String

MessageContext.HTTP_REQUEST_HEADERS

标准属性：HTTP请求头。

static String

MessageContext.HTTP_REQUEST_METHOD

标准属性：HTTP请求方法。

static String

MessageContext.HTTP_RESPONSE_CODE

标准属性：HTTP响应状态码。

static String

MessageContext.HTTP_RESPONSE_HEADERS

标准属性：HTTP响应头。

static String

MessageContext.INBOUND_MESSAGE_ATTACHMENTS

标准属性：入站邮件的邮件附件地图，密钥是MIME Content-ID，值是DataHandler。

static String

MessageContext.MESSAGE_OUTBOUND_PROPERTY

标准属性：消息方向， true为出站消息， false入站。

static String

MessageContext.OUTBOUND_MESSAGE_ATTACHMENTS

标准属性：出站邮件的邮件附件地图，密钥是MIME Content-ID，值是DataHandler。

static String

MessageContext.PATH_INFO

标准属性：请求路径信息

static String

MessageContext.QUERY_STRING

标准属性：请求的查询字符串。

static String

MessageContext.REFERENCE_PARAMETERS

标准属性：WS寻址参考参数。

static String

MessageContext.SERVLET_CONTEXT

标准属性：servlet上下文对象。

static String

MessageContext.SERVLET_REQUEST

标准属性：servlet请求对象。

static String

MessageContext.SERVLET_RESPONSE

标准属性：servlet响应对象。

static String

MessageContext.WSDL_DESCRIPTION

标准属性：WSDL文档的输入源。

static String

MessageContext.WSDL_INTERFACE

标准属性：wsdl接口（2.0）或端口类型（1.1）的名称。

static String

MessageContext.WSDL_OPERATION

标准属性：WSDL操作的名称。

static String

MessageContext.WSDL_PORT

标准属性：WSDL端口的名称。

static String

MessageContext.WSDL_SERVICE

标准属性：WSDL服务的名称。

Methods in javax.xml.ws.handler that return String

Modifier and Type

方法

描述

String

PortInfo.getBindingID​()

获取标识被访问端口使用的绑定的URI。

Methods in javax.xml.ws.handler with parameters of type String

Modifier and Type

方法

描述

MessageContext.Scope

MessageContext.getScope​(String name)

获取属性的范围。

void

MessageContext.setScope​(String name, MessageContext.Scope scope)

设置属性的范围。

static MessageContext.Scope

MessageContext.Scope.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in javax.xml.ws.handler.soap

Methods in javax.xml.ws.handler.soap that return types with arguments of type String

Modifier and Type

方法

描述

Set<String>

SOAPMessageContext.getRoles​()

获取与执行处理程序链相关联的SOAP actor角色。

Uses of String in javax.xml.ws.http

Fields in javax.xml.ws.http declared as String

Modifier and Type

Field

描述

static String

HTTPBinding.HTTP_BINDING

表示XML / HTTP绑定的身份的常量。

Uses of String in javax.xml.ws.soap

Fields in javax.xml.ws.soap declared as String

Modifier and Type

Field

描述

static String

AddressingFeature.ID

识别寻址功能的常数值

static String

MTOMFeature.ID

识别MTOMFeature的恒定值

static String

SOAPBinding.SOAP11HTTP_BINDING

表示SOAP 1.1通过HTTP绑定的身份的常量。

static String

SOAPBinding.SOAP11HTTP_MTOM_BINDING

默认情况下，表示使用MTOM的HTTP 1.1绑定的SOAP 1.1的身份的常量。

static String

SOAPBinding.SOAP12HTTP_BINDING

一个表示SOAP 1.2通过HTTP绑定的身份的常量。

static String

SOAPBinding.SOAP12HTTP_MTOM_BINDING

默认情况下，表示通过HTTP绑定的SOAP 1.2身份的常量，MTOM启用。

Methods in javax.xml.ws.soap that return String

Modifier and Type

方法

描述

String

AddressingFeature.getID​()

获取此WebServiceFeature的唯一标识符。

String

MTOMFeature.getID​()

获取此WebServiceFeature的唯一标识符。

Methods in javax.xml.ws.soap that return types with arguments of type String

Modifier and Type

方法

描述

Set<String>

SOAPBinding.getRoles​()

获取SOAP绑定实例扮演的角色。

Methods in javax.xml.ws.soap with parameters of type String

Modifier and Type

方法

描述

static AddressingFeature.Responses

AddressingFeature.Responses.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in javax.xml.ws.soap with type arguments of type String

Modifier and Type

方法

描述

void

SOAPBinding.setRoles​(Set<String> roles)

设置SOAP绑定实例扮演的角色。

Uses of String in javax.xml.ws.spi

Methods in javax.xml.ws.spi with parameters of type String

Modifier and Type

方法

描述

abstract void

ServiceDelegate.addPort​(QName portName, String bindingId, String endpointAddress)

为服务创建一个新的端口。

abstract Endpoint

Provider.createAndPublishEndpoint​(String address, Object implementor)

创建并发布具有指定地址和实现对象的端点对象。

Endpoint

Provider.createAndPublishEndpoint​(String address, Object implementor, WebServiceFeature... features)

创建并发布具有指定地址，实现对象和Web服务功能的端点对象。

Endpoint

Provider.createEndpoint​(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)

使用提供的绑定，实现类，调用者和Web服务功能创建端点对象。

abstract Endpoint

Provider.createEndpoint​(String bindingId, Object implementor)

使用提供的绑定和实现对象创建端点对象。

Endpoint

Provider.createEndpoint​(String bindingId, Object implementor, WebServiceFeature... features)

使用提供的绑定，实现对象和Web服务功能创建端点对象。

abstract W3CEndpointReference

Provider.createW3CEndpointReference​(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)

工厂方法创建一个 W3CEndpointReference 。

W3CEndpointReference

Provider.createW3CEndpointReference​(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)

工厂方法创建一个 W3CEndpointReference 。

Method parameters in javax.xml.ws.spi with type arguments of type String

Modifier and Type

方法

描述

W3CEndpointReference

Provider.createW3CEndpointReference​(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)

工厂方法创建一个 W3CEndpointReference 。

Uses of String in javax.xml.ws.spi.http

Fields in javax.xml.ws.spi.http declared as String

Modifier and Type

Field

描述

static String

HttpExchange.REQUEST_CIPHER_SUITE

标准属性：通过HTTPS接收请求时的密码套件值

static String

HttpExchange.REQUEST_KEY_SIZE

标准属性：通过HTTPS接收请求时算法的位大小

static String

HttpExchange.REQUEST_X509CERTIFICATE

标准属性：与请求相关联的SSL证书（如果有）

Methods in javax.xml.ws.spi.http that return String

Modifier and Type

方法

描述

abstract String

HttpExchange.getContextPath​()

返回应用程序中所有端点的上下文路径。

abstract String

HttpContext.getPath​()

返回此上下文的路径。

abstract String

HttpExchange.getPathInfo​()

返回Web服务路径后面的额外路径信息，但在请求URI中的查询字符串之前，将以“/”字符开头。

abstract String

HttpExchange.getProtocol​()

从请求中以 协议/ majorVersion.minorVersion的形式返回协议串。

abstract String

HttpExchange.getQueryString​()

返回路径后请求URI中包含的查询字符串。

abstract String

HttpExchange.getRequestHeader​(String name)

返回指定请求标头的值。

abstract String

HttpExchange.getRequestMethod​()

获取HTTP请求方法

abstract String

HttpExchange.getRequestURI​()

将请求的URI的一部分从协议名称返回到HTTP请求的第一行中的查询字符串。

abstract String

HttpExchange.getScheme​()

返回用于创建此请求的方案的名称，例如：http或https。

Methods in javax.xml.ws.spi.http that return types with arguments of type String

Modifier and Type

方法

描述

abstract Set<String>

HttpContext.getAttributeNames​()

返回容器配置的所有属性名称和jax-ws运行时可以使用的其他数据。

abstract Set<String>

HttpExchange.getAttributeNames​()

提供与此 HttpExchange相关联的所有属性名称。

abstract Map<String,List<String>>

HttpExchange.getRequestHeaders​()

返回包含此请求中包含的HTTP标头的不可变地图。

abstract Map<String,List<String>>

HttpExchange.getRequestHeaders​()

返回包含此请求中包含的HTTP标头的不可变地图。

abstract Map<String,List<String>>

HttpExchange.getResponseHeaders​()

返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。

abstract Map<String,List<String>>

HttpExchange.getResponseHeaders​()

返回一个可变地图，可以存储HTTP响应标头，哪个将作为此响应的一部分进行传输。

Methods in javax.xml.ws.spi.http with parameters of type String

Modifier and Type

方法

描述

abstract void

HttpExchange.addResponseHeader​(String name, String value)

添加具有给定名称和值的响应头。

abstract Object

HttpContext.getAttribute​(String name)

返回容器配置的属性值和jax-ws运行时可以使用的其他数据。

abstract Object

HttpExchange.getAttribute​(String name)

返回与此 HttpExchange相关联的属性。

abstract String

HttpExchange.getRequestHeader​(String name)

返回指定请求标头的值。

abstract boolean

HttpExchange.isUserInRole​(String role)

指示经过身份验证的用户是否包含在指定的逻辑“角色”中。

Uses of String in javax.xml.ws.wsaddressing

Fields in javax.xml.ws.wsaddressing declared as String

Modifier and Type

Field

描述

protected static String

W3CEndpointReference.NS

寻址命名空间

Methods in javax.xml.ws.wsaddressing with parameters of type String

Modifier and Type

方法

描述

W3CEndpointReferenceBuilder

W3CEndpointReferenceBuilder.address​(String address)

设置 address至 W3CEndpointReference实例的 wsa:Address 。

W3CEndpointReferenceBuilder

W3CEndpointReferenceBuilder.attribute​(QName name, String value)

将扩展属性添加到 W3CEndpointReference实例的 wsa:EndpointReference元素。

W3CEndpointReferenceBuilder

W3CEndpointReferenceBuilder.wsdlDocumentLocation​(String wsdlDocumentLocation)

设置 wsdlDocumentLocation ，将作为被引用 wsa:Metadata/@wsdli:wsdlLocation 。

Uses of String in javax.xml.xpath

Fields in javax.xml.xpath declared as String

Modifier and Type

Field

描述

static String

XPathFactory.DEFAULT_OBJECT_MODEL_URI

默认对象模型URI。

static String

XPathFactory.DEFAULT_PROPERTY_NAME

根据JAXP规范的默认属性名称。

static String

XPathConstants.DOM_OBJECT_MODEL

DOM对象模型的URI，“http://java.sun.com/jaxp/xpath/dom”。

Methods in javax.xml.xpath that return String

Modifier and Type

方法

描述

String

XPath.evaluate​(String expression, Object item)

评估指定上下文中的XPath表达式，并将结果作为 String返回。

String

XPath.evaluate​(String expression, InputSource source)

在指定的 InputSource的上下文中评估XPath表达式，并将结果作为 String返回。

String

XPathExpression.evaluate​(Object item)

在指定的上下文中评估编译的XPath表达式，并将结果作为 String返回。

String

XPathExpression.evaluate​(InputSource source)

在指定的 InputSource的上下文中评估编译的XPath表达式，并将结果作为 String返回。

Methods in javax.xml.xpath with parameters of type String

Modifier and Type

方法

描述

XPathExpression

XPath.compile​(String expression)

编译XPath表达式供以后评估。

String

XPath.evaluate​(String expression, Object item)

在指定上下文中评估XPath表达式，并将结果作为 String返回。

Object

XPath.evaluate​(String expression, Object item, QName returnType)

在指定的上下文中评估一个 XPath表达式，并将结果作为指定的类型返回。

String

XPath.evaluate​(String expression, InputSource source)

在指定的 InputSource的上下文中评估XPath表达式，并将结果作为 String返回。

Object

XPath.evaluate​(String expression, InputSource source, QName returnType)

在指定的 InputSource的上下文中评估XPath表达式，并将结果作为指定的类型返回。

default XPathEvaluationResult<?>

XPath.evaluateExpression​(String expression, Object item)

评估指定上下文中的XPath表达式。

default <T> T

XPath.evaluateExpression​(String expression, Object item, Class<T> type)

在指定的上下文中评估XPath表达式，并返回结果，并使用通过 class type指定的类型

default XPathEvaluationResult<?>

XPath.evaluateExpression​(String expression, InputSource source)

评估指定上下文中的XPath表达式。

default <T> T

XPath.evaluateExpression​(String expression, InputSource source, Class<T> type)

在指定的 source的上下文中评估XPath表达式， source指定返回结果。

abstract boolean

XPathFactory.getFeature​(String name)

获取命名功能的状态。

abstract boolean

XPathFactory.isObjectModelSupported​(String objectModel)

这个 XPathFactory是否支持指定的对象模型？

static XPathFactory

XPathFactory.newInstance​(String uri)

使用指定的对象模型获取新的 XPathFactory实例。

static XPathFactory

XPathFactory.newInstance​(String uri, String factoryClassName, ClassLoader classLoader)

从工厂类名称获取一个新的实例 XPathFactory 。

abstract void

XPathFactory.setFeature​(String name, boolean value)

为这个工厂创建的这个 XPathFactory和 XPath设置了一个功能。

static XPathEvaluationResult.XPathResultType

XPathEvaluationResult.XPathResultType.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in javax.xml.xpath with parameters of type String

Constructor

描述

XPathException​(String message)

构造一个新的 XPathException与指定的细节 message 。

XPathExpressionException​(String message)

构造一个新的 XPathExpressionException与指定的细节 message 。

XPathFactoryConfigurationException​(String message)

构造一个新的 XPathFactoryConfigurationException与指定的细节 message 。

XPathFunctionException​(String message)

构造一个新的 XPathFunctionException与指定的细节 message 。

Uses of String in jdk.dynalink

Fields in jdk.dynalink declared as String

Modifier and Type

Field

描述

static String

SecureLookupSupplier.GET_LOOKUP_PERMISSION_NAME

成功调用 SecureLookupSupplier.getLookup()方法所需的运行时权限的名称。

Methods in jdk.dynalink that return String

Modifier and Type

方法

描述

String

CallSiteDescriptor.toString​()

返回此调用站点描述符的字符串表示形式，格式为 name(parameterTypes)returnType@lookup 。

String

NamedOperation.toString​()

返回此命名操作的字符串表示形式。

String

NamespaceOperation.toString​()

返回此命名空间操作的字符串表示形式。

Methods in jdk.dynalink with parameters of type String

Modifier and Type

方法

描述

NamedOperation

NamedOperation.changeName​(String newName)

查找或创建与名称不同的命名操作。

static StandardNamespace

StandardNamespace.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static StandardOperation

StandardOperation.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in jdk.dynalink with parameters of type String

Constructor

描述

NoSuchDynamicMethodException​(String message)

创建一个新的NoSuchDynamicMethodException

Uses of String in jdk.dynalink.beans

Methods in jdk.dynalink.beans that return String

Modifier and Type

方法

描述

String

StaticClass.toString​()

Methods in jdk.dynalink.beans that return types with arguments of type String

Modifier and Type

方法

描述

static Set<String>

BeansLinker.getInstanceMethodNames​(Class<?> clazz)

返回一组类的所有实例方法的名称。

static Set<String>

BeansLinker.getReadableInstancePropertyNames​(Class<?> clazz)

返回一组类的所有可读实例属性的名称。

static Set<String>

BeansLinker.getReadableStaticPropertyNames​(Class<?> clazz)

返回一组类的所有可读静态属性的名称。

static Set<String>

BeansLinker.getStaticMethodNames​(Class<?> clazz)

返回类的所有静态方法的一组名称。

static Set<String>

BeansLinker.getWritableInstancePropertyNames​(Class<?> clazz)

返回一组类的所有可写实例属性的名称。

static Set<String>

BeansLinker.getWritableStaticPropertyNames​(Class<?> clazz)

返回一组类的所有可写静态属性的名称。

Methods in jdk.dynalink.beans with parameters of type String

Modifier and Type

方法

描述

static Object

BeansLinker.getConstructorMethod​(Class<?> clazz, String signature)

返回给定类的构造函数的动态方法和给定的签名。

Uses of String in jdk.dynalink.linker

Fields in jdk.dynalink.linker declared as String

Modifier and Type

Field

描述

static String

GuardingDynamicLinkerExporter.AUTOLOAD_PERMISSION_NAME

创建此类实例的运行时权限的名称。

Methods in jdk.dynalink.linker with parameters of type String

Modifier and Type

方法

描述

static ConversionComparator.Comparison

ConversionComparator.Comparison.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in jdk.dynalink.linker.support

Methods in jdk.dynalink.linker.support with parameters of type String

Modifier and Type

方法

描述

MethodHandle

Lookup.findGetter​(Class<?> refc, String name, Class<?> type)

执行MethodHandles.Lookup.findGetter(Class, String, Class) ，将任何遇到的IllegalAccessException转换成IllegalAccessError和NoSuchFieldException转换为NoSuchFieldError 。

static MethodHandle

Lookup.findOwnSpecial​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)

给定一个查找，找到使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。

MethodHandle

Lookup.findOwnSpecial​(String name, Class<?> rtype, Class<?>... ptypes)

查找使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。

static MethodHandle

Lookup.findOwnStatic​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)

给定一个查找，找到使用 Lookup.findStatic(Class, String, MethodType)该查找的类的方法。

MethodHandle

Lookup.findOwnStatic​(String name, Class<?> rtype, Class<?>... ptypes)

查找使用 Lookup.findStatic(Class, String, MethodType)该查找的类的方法。

MethodHandle

Lookup.findSpecial​(Class<?> declaringClass, String name, MethodType type)

对基础查找执行 MethodHandles.Lookup.findSpecial(Class, String, MethodType, Class) 。

MethodHandle

Lookup.findStatic​(Class<?> declaringClass, String name, MethodType type)

对底层查找执行 MethodHandles.Lookup.findStatic(Class, String, MethodType) 。

MethodHandle

Lookup.findVirtual​(Class<?> declaringClass, String name, MethodType type)

对底层查找执行 MethodHandles.Lookup.findVirtual(Class, String, MethodType) 。

static Class<?>

TypeUtilities.getPrimitiveTypeByName​(String name)

给定一个原始类型的名称返回表示它的类。

Uses of String in jdk.incubator.http

Methods in jdk.incubator.http that return String

Modifier and Type

方法

描述

String

WebSocket.getSubprotocol​()

返回一个 subprotocol已被选为这个 WebSocket 。

abstract String

HttpRequest.method​()

返回此请求的请求方法。

Methods in jdk.incubator.http that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

HttpHeaders.allValues​(String name)

返回给定的命名头的所有值的不可修改的列表。

static HttpResponse.BodyHandler<String>

HttpResponse.BodyHandler.asString​()

返回BodyHandler<String>返回一个BodyProcessor <String>从获得BodyProcessor.asString(Charset) 。

static HttpResponse.BodyHandler<String>

HttpResponse.BodyHandler.asString​(Charset charset)

返回一个BodyHandler<String> ，返回一个从 <String>获得的BodyProcessor <String> 。

static HttpResponse.BodyProcessor<String>

HttpResponse.BodyProcessor.asString​(Charset charset)

返回一个主体处理器，其存储响应主体作为 String使用给定的转换 Charset 。

Optional<String>

HttpHeaders.firstValue​(String name)

返回一个Optional，其中包含给定的命名（可能是多值）头的第一个值。

Map<String,List<String>>

HttpHeaders.map​()

返回此HttpHeaders的不可修改的多Map视图。

Map<String,List<String>>

HttpHeaders.map​()

返回此HttpHeaders的不可修改的多Map视图。

Methods in jdk.incubator.http with parameters of type String

Modifier and Type

方法

描述

List<String>

HttpHeaders.allValues​(String name)

返回给定的命名头的所有值的不可修改的列表。

Optional<String>

HttpHeaders.firstValue​(String name)

返回一个Optional，其中包含给定的已命名（可能是多值）头的第一个值。

OptionalLong

HttpHeaders.firstValueAsLong​(String name)

返回包含命名头字段的第一个值的OptionalLong 。

static HttpRequest.BodyProcessor

HttpRequest.BodyProcessor.fromString​(String body)

返回一个请求体处理器，其身体是给定的 String ，使用 UTF_8字符集进行转换。

static HttpRequest.BodyProcessor

HttpRequest.BodyProcessor.fromString​(String s, Charset charset)

返回一个请求体处理器，其身体是给定的 String ，使用给定的字符集进行转换。

abstract HttpRequest.Builder

HttpRequest.Builder.header​(String name, String value)

将给定的名称值对添加到此请求的头文件集中。

WebSocket.Builder

WebSocket.Builder.header​(String name, String value)

将给定的名称 - 值对添加到开启握手的附加标题列表中。

abstract HttpRequest.Builder

HttpRequest.Builder.headers​(String... headers)

将给定的名称值对添加到此请求的标题集。

abstract HttpRequest.Builder

HttpRequest.Builder.method​(String method, HttpRequest.BodyProcessor body)

将此构建器的请求方法和请求体设置为给定值。

default CompletionStage<?>

WebSocket.Listener.onClose​(WebSocket webSocket, int statusCode, String reason)

接收到一条关闭消息。

CompletableFuture<WebSocket>

WebSocket.sendClose​(int statusCode, String reason)

发送关闭消息与给定的状态代码和原因。

abstract HttpRequest.Builder

HttpRequest.Builder.setHeader​(String name, String value)

将给定的名称值对设置为此请求的标题集。

WebSocket.Builder

WebSocket.Builder.subprotocols​(String mostPreferred, String... lesserPreferred)

在开放握手期间包括给定子协议的请求。

static HttpClient.Redirect

HttpClient.Redirect.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static HttpClient.Version

HttpClient.Version.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static WebSocket.MessagePart

WebSocket.MessagePart.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in jdk.incubator.http with parameters of type String

Constructor

描述

HttpTimeoutException​(String message)

Uses of String in jdk.javadoc.doclet

Methods in jdk.javadoc.doclet that return String

Modifier and Type

方法

描述

String

Doclet.Option.getDescription​()

返回该选项的描述。

String

Doclet.getName​()

返回标识doclet的名称。

String

StandardDoclet.getName​()

String

Taglet.getName​()

返回标签的名称。

String

Doclet.Option.getParameters​()

返回该选项的参数。

String

Taglet.toString​(List<? extends DocTree> tags, Element element)

返回要包含在生成的输出中的该标签的一系列实例的字符串表示形式。

Methods in jdk.javadoc.doclet that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

Doclet.Option.getNames​()

返回可用于标识该选项的名称列表。

Methods in jdk.javadoc.doclet with parameters of type String

Modifier and Type

方法

描述

void

Reporter.print​(Diagnostic.Kind kind, DocTreePath path, String msg)

打印错误消息并增加错误计数。

void

Reporter.print​(Diagnostic.Kind kind, String msg)

打印错误消息和增量错误计数。

void

Reporter.print​(Diagnostic.Kind kind, Element e, String msg)

打印错误消息并增加错误计数。

boolean

Doclet.Option.process​(String option, List<String> arguments)

根据需要处理选项和参数。

static Doclet.Option.Kind

Doclet.Option.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static DocletEnvironment.ModuleMode

DocletEnvironment.ModuleMode.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Taglet.Location

Taglet.Location.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Method parameters in jdk.javadoc.doclet with type arguments of type String

Modifier and Type

方法

描述

boolean

Doclet.Option.process​(String option, List<String> arguments)

根据需要处理选项和参数。

Uses of String in jdk.jshell

Methods in jdk.jshell that return String

Modifier and Type

方法

描述

abstract String

SourceCodeAnalysis.analyzeType​(String code, int cursor)

推断给定表达式的类型。

String

SourceCodeAnalysis.Suggestion.continuation​()

候选人延续给定用户的输入。

String

SourceCodeAnalysis.SnippetWrapper.fullClassName​()

返回 SourceCodeAnalysis.SnippetWrapper.wrapped()类的完全限定类名。

String

ImportSnippet.fullname​()

进口的合格名称。

abstract String

Diag.getCode​()

返回指示诊断类型的诊断代码。

String

EvalException.getExceptionClassName​()

返回在执行客户机中抛出的Throwable子类的名称。

abstract String

Diag.getMessage​(Locale locale)

返回给定区域设置的本地化消息。

String

Snippet.id​()

代码段的唯一标识符。

String

SourceCodeAnalysis.Documentation.javadoc​()

给定元素的javadoc。

String

ExpressionSnippet.name​()

变量名称是表达式的值。

String

ImportSnippet.name​()

导入的识别名称。

String

PersistentSnippet.name​()

代码片段的名称

String

MethodSnippet.parameterTypes​()

方法的参数类型的字符串表示形式。

String

SourceCodeAnalysis.CompletionInfo.remaining​()

完整部分源后输入剩余。

String

MethodSnippet.signature​()

方法的完整类型签名，包括返回类型。

String

SourceCodeAnalysis.Documentation.signature​()

给定元素的签名。

String

Snippet.source​()

返回代码段的源代码。

String

SourceCodeAnalysis.CompletionInfo.source​()

第一个代码片段的源代码输入。

String

SourceCodeAnalysis.SnippetWrapper.source​()

返回包装的输入。

String

MethodSnippet.toString​()

String

Snippet.toString​()

String

SnippetEvent.toString​()

返回事件的字符串表示形式

String

ExpressionSnippet.typeName​()

表达式的类型

String

VarSnippet.typeName​()

变量类型的字符串表示形式。

String

SnippetEvent.value​()

成功运行的结果值。

String

JShell.varValue​(VarSnippet snippet)

获取变量的当前值。

String

SourceCodeAnalysis.SnippetWrapper.wrapped​()

返回包含 SourceCodeAnalysis.SnippetWrapper.source()的Java类定义，如果导入，则返回导入源。

Methods in jdk.jshell that return types with arguments of type String

Modifier and Type

方法

描述

List<String>

SourceCodeAnalysis.QualifiedNames.getNames​()

原始代码中给定简单名称的已知限定名称。

Stream<String>

JShell.unresolvedDependencies​(DeclarationSnippet snippet)

对于 RECOVERABLE_DEFINED或 RECOVERABLE_NOT_DEFINED声明，代码片段的当前未解析的依赖关系的名称。

Methods in jdk.jshell with parameters of type String

Modifier and Type

方法

描述

void

JShell.addToClasspath​(String path)

指定的路径被添加到eval（）中使用的类路径的末尾。

abstract SourceCodeAnalysis.CompletionInfo

SourceCodeAnalysis.analyzeCompletion​(String input)

给定一个输入字符串，找到第一个代码片段（一个语句，定义，导入或表达式），并评估它是否完整。

abstract String

SourceCodeAnalysis.analyzeType​(String code, int cursor)

推断给定表达式的类型。

JShell.Builder

JShell.Builder.compilerOptions​(String... options)

添加编译器选项。

abstract List<SourceCodeAnalysis.Suggestion>

SourceCodeAnalysis.completionSuggestions​(String input, int cursor, int[] anchor)

计算给定输入的可能跟踪。

abstract List<SourceCodeAnalysis.Documentation>

SourceCodeAnalysis.documentation​(String input, int cursor, boolean computeJavadoc)

计算给定用户输入的文档。

List<SnippetEvent>

JShell.eval​(String input)

评估输入字符串，包括定义和/或执行（如果适用）。

JShell.Builder

JShell.Builder.executionEngine​(String executionControlSpec)

设置要执行的自定义引擎。

abstract SourceCodeAnalysis.QualifiedNames

SourceCodeAnalysis.listQualifiedNames​(String code, int cursor)

列出给定代码中简单名称的限定名称，直接指定给定光标位置的左侧。

JShell.Builder

JShell.Builder.remoteVMOptions​(String... options)

设置启动VM的其他VM选项。

static Snippet.Kind

Snippet.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Snippet.Status

Snippet.Status.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Snippet.SubKind

Snippet.SubKind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static SourceCodeAnalysis.Completeness

SourceCodeAnalysis.Completeness.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

abstract List<SourceCodeAnalysis.SnippetWrapper>

SourceCodeAnalysis.wrappers​(String input)

返回输入源字符串中代码段的包装器信息。

Method parameters in jdk.jshell with type arguments of type String

Modifier and Type

方法

描述

JShell.Builder

JShell.Builder.executionEngine​(ExecutionControlProvider executionControlProvider, Map<String,String> executionControlParameters)

设置要执行的自定义引擎。

JShell.Builder

JShell.Builder.executionEngine​(ExecutionControlProvider executionControlProvider, Map<String,String> executionControlParameters)

设置要执行的自定义引擎。

JShell.Builder

JShell.Builder.idGenerator​(BiFunction<Snippet,Integer,String> generator)

设置代码段识别名称的生成器。

JShell.Builder

JShell.Builder.tempVariableNameGenerator​(Supplier<String> generator)

为VarSnippet的Snippet.SubKind.TEMP_VAR_EXPRESSION_SUBKIND设置一个临时变量名称的生成器。

Uses of String in jdk.jshell.execution

Fields in jdk.jshell.execution declared as String

Modifier and Type

Field

描述

static String

JdiExecutionControlProvider.PARAM_HOST_NAME

要连接的本地主机名。

static String

JdiExecutionControlProvider.PARAM_LAUNCH

应该使用JDI控制发射吗？

static String

JdiExecutionControlProvider.PARAM_REMOTE_AGENT

远程代理启动。

static String

JdiExecutionControlProvider.PARAM_TIMEOUT

连接超时前的毫秒数。

Methods in jdk.jshell.execution that return String

Modifier and Type

方法

描述

protected String

DirectExecutionControl.invoke​(方法 doitMethod)

调用指定的“doit-method”，一个没有参数的静态方法。

String

DirectExecutionControl.invoke​(String className, String methodName)

String

JdiDefaultExecutionControl.invoke​(String classname, String methodname)

protected String

LocalExecutionControl.invoke​(方法 doitMethod)

protected String

RemoteExecutionControl.invoke​(方法 doitMethod)

String

StreamingExecutionControl.invoke​(String classname, String methodname)

String

FailOverExecutionControlProvider.name​()

这个独特的名字 ExecutionControlProvider 。

String

JdiExecutionControlProvider.name​()

这个独特的名字 ExecutionControlProvider 。

String

LocalExecutionControlProvider.name​()

这个独特的名字 ExecutionControlProvider 。

protected String

DirectExecutionControl.throwConvertedInvocationException​(Throwable cause)

将用户代码中的传入异常转换为ExecutionControl.ExecutionControlException的子类型，并抛出转换的异常。

protected String

RemoteExecutionControl.throwConvertedInvocationException​(Throwable cause)

protected String

DirectExecutionControl.throwConvertedOtherException​(Throwable ex)

将代理代码中的传入异常转换为ExecutionControl.ExecutionControlException的子类型，并抛出转换的异常。

protected String

RemoteExecutionControl.throwConvertedOtherException​(Throwable ex)

protected static String

DirectExecutionControl.valueString​(Object value)

将 Object值从 ExecutionControl.invoke(String, String)或 ExecutionControl.varValue(String, String)转换为 String 。

String

DirectExecutionControl.varValue​(String className, String varName)

String

RemoteExecutionControl.varValue​(String className, String varName)

String

StreamingExecutionControl.varValue​(String classname, String varname)

Methods in jdk.jshell.execution that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,String>

FailOverExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

Map<String,String>

FailOverExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

Map<String,String>

JdiExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

Map<String,String>

JdiExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

Map<String,String>

LocalExecutionControlProvider.defaultParameters​()

创建并返回默认参数图 LocalExecutionControlProvider 。

Map<String,String>

LocalExecutionControlProvider.defaultParameters​()

创建并返回 LocalExecutionControlProvider的默认参数图。

Methods in jdk.jshell.execution with parameters of type String

Modifier and Type

方法

描述

void

DirectExecutionControl.addToClasspath​(String cp)

void

LoaderDelegate.addToClasspath​(String path)

将路径添加到执行类路径。

void

StreamingExecutionControl.addToClasspath​(String path)

Object

DirectExecutionControl.extensionCommand​(String command, Object arg)

Object

StreamingExecutionControl.extensionCommand​(String command, Object arg)

protected Class<?>

DirectExecutionControl.findClass​(String name)

查找具有指定二进制名称的类。

Class<?>

LoaderDelegate.findClass​(String name)

查找具有指定二进制名称的类。

String

DirectExecutionControl.invoke​(String className, String methodName)

String

JdiDefaultExecutionControl.invoke​(String classname, String methodname)

String

StreamingExecutionControl.invoke​(String classname, String methodname)

static void

RemoteExecutionControl.main​(String[] args)

启动代理，通过命令行参数指定的套接字连接到JShell核心。

protected ReferenceType

JdiExecutionControl.referenceType​(VirtualMachine vm, String name)

返回对应于指定类名的JDI ReferenceType 。

String

DirectExecutionControl.varValue​(String className, String varName)

String

RemoteExecutionControl.varValue​(String className, String varName)

String

StreamingExecutionControl.varValue​(String classname, String varname)

Method parameters in jdk.jshell.execution with type arguments of type String

Modifier and Type

方法

描述

static void

Util.detectJdiExitEvent​(VirtualMachine vm, Consumer<String> unbiddenExitHandler)

监控JDI事件流VMDeathEvent和VMDisconnectEvent 。

static void

Util.forwardExecutionControlAndIO​(ExecutionControl ec, InputStream inStream, OutputStream outStream, Map<String,Consumer<OutputStream>> outputStreamMap, Map<String,Consumer<InputStream>> inputStreamMap)

将命令从输入转发到指定的ExecutionControl实例，然后响应回输出。

ExecutionControl

FailOverExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回一个本地执行的 ExecutionControl实例。

ExecutionControl

FailOverExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回本地执行的 ExecutionControl实例。

ExecutionControl

JdiExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

ExecutionControl

JdiExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

ExecutionControl

LocalExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回本地执行的 ExecutionControl实例。

ExecutionControl

LocalExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回一个本地执行的 ExecutionControl实例。

static ExecutionControl

Util.remoteInputOutput​(InputStream input, OutputStream output, Map<String,OutputStream> outputStreamMap, Map<String,InputStream> inputStreamMap, BiFunction<ObjectInput,ObjectOutput,ExecutionControl> factory)

为给定的分组化输入和输出创建一个ExecutionControl。

Constructors in jdk.jshell.execution with parameters of type String

Constructor

描述

JdiInitiator​(int port, List<String> remoteVMOptions, String remoteAgent, boolean isLaunch, String host, int timeout, Map<String,String> customConnectorArgs)

启动远程代理并建立一个JDI连接。

Constructor parameters in jdk.jshell.execution with type arguments of type String

Constructor

描述

JdiInitiator​(int port, List<String> remoteVMOptions, String remoteAgent, boolean isLaunch, String host, int timeout, Map<String,String> customConnectorArgs)

启动远程代理并建立一个JDI连接。

JdiInitiator​(int port, List<String> remoteVMOptions, String remoteAgent, boolean isLaunch, String host, int timeout, Map<String,String> customConnectorArgs)

启动远程代理并建立一个JDI连接。

JdiInitiator​(int port, List<String> remoteVMOptions, String remoteAgent, boolean isLaunch, String host, int timeout, Map<String,String> customConnectorArgs)

启动远程代理并建立一个JDI连接。

Uses of String in jdk.jshell.spi

Methods in jdk.jshell.spi that return String

Modifier and Type

方法

描述

String

ExecutionControl.UserException.causeExceptionClass​()

返回用户异常的类。

String

ExecutionControl.invoke​(String className, String methodName)

通过调用指定的包装类上的方法来调用可执行代码段。

String

ExecutionControl.ClassBytecodes.name​()

班级名称

String

ExecutionControlProvider.name​()

这个独特的名字 ExecutionControlProvider 。

String

ExecutionControl.varValue​(String className, String varName)

返回变量的值。

Methods in jdk.jshell.spi that return types with arguments of type String

Modifier and Type

方法

描述

default Map<String,String>

ExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

default Map<String,String>

ExecutionControlProvider.defaultParameters​()

创建并返回此 ExecutionControlProvider的默认参数图。

List<String>

ExecutionEnv.extraRemoteVMOptions​()

返回启动远程JVM时要使用的其他VM选项。

Methods in jdk.jshell.spi with parameters of type String

Modifier and Type

方法

描述

void

ExecutionControl.addToClasspath​(String path)

将路径添加到执行类路径。

Object

ExecutionControl.extensionCommand​(String command, Object arg)

运行非标准命令（或较新版本的标准命令）。

static ExecutionControl

ExecutionControl.generate​(ExecutionEnv env, String spec)

搜索提供商，然后创建并返回 ExecutionControl实例。

static ExecutionControl

ExecutionControl.generate​(ExecutionEnv env, String name, Map<String,String> parameters)

搜索提供者，然后创建并返回 ExecutionControl实例。

String

ExecutionControl.invoke​(String className, String methodName)

通过调用指定的包装类上的方法来调用可执行代码段。

String

ExecutionControl.varValue​(String className, String varName)

返回变量的值。

Method parameters in jdk.jshell.spi with type arguments of type String

Modifier and Type

方法

描述

static ExecutionControl

ExecutionControl.generate​(ExecutionEnv env, String name, Map<String,String> parameters)

搜索提供者，然后创建并返回 ExecutionControl实例。

static ExecutionControl

ExecutionControl.generate​(ExecutionEnv env, String name, Map<String,String> parameters)

搜索提供者，然后创建并返回 ExecutionControl实例。

ExecutionControl

ExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回 ExecutionControl实例。

ExecutionControl

ExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)

创建并返回 ExecutionControl实例。

Constructors in jdk.jshell.spi with parameters of type String

Constructor

描述

ClassBytecodes​(String name, byte[] bytecodes)

创建一个名称/字节码对。

ClassInstallException​(String message, boolean[] installed)

EngineTerminationException​(String message)

ExecutionControlException​(String message)

InternalException​(String message)

NotImplementedException​(String message)

UserException​(String message, String causeExceptionClass, StackTraceElement[] stackElements)

Uses of String in jdk.jshell.tool

Methods in jdk.jshell.tool with parameters of type String

Modifier and Type

方法

描述

void

JavaShellToolBuilder.run​(String... arguments)

运行该接口中其他方法配置的Java Shell工具实例。

Method parameters in jdk.jshell.tool with type arguments of type String

Modifier and Type

方法

描述

JavaShellToolBuilder

JavaShellToolBuilder.env​(Map<String,String> vars)

设置环境变量的源。

JavaShellToolBuilder

JavaShellToolBuilder.env​(Map<String,String> vars)

设置环境变量的源。

JavaShellToolBuilder

JavaShellToolBuilder.persistence​(Map<String,String> prefsMap)

设置包含输入历史记录和保留设置的持久信息的存储机制。

JavaShellToolBuilder

JavaShellToolBuilder.persistence​(Map<String,String> prefsMap)

设置包含输入历史记录和保留设置的持久信息的存储机制。

Uses of String in jdk.nashorn.api.scripting

Fields in jdk.nashorn.api.scripting declared as String

Modifier and Type

Field

描述

static String

NashornScriptEngine.NASHORN_GLOBAL

用于将Nashorn全局对象镜像与任意Bindings实例相关联的关键字。

Methods in jdk.nashorn.api.scripting that return String

Modifier and Type

方法

描述

static String

ScriptUtils.format​(String format, Object[] args)

将JavaScript类型转换为String.format方法（jrunscript函数sprintf）的java类型的方法。

String

AbstractJSObject.getClassName​()

String

JSObject.getClassName​()

ECMA [[Class]]属性

String

ScriptObjectMirror.getClassName​()

String

NashornScriptEngineFactory.getEngineName​()

String

NashornScriptEngineFactory.getEngineVersion​()

String

NashornException.getFileName​()

获取此 NashornException的源文件名

String

NashornScriptEngineFactory.getLanguageName​()

String

NashornScriptEngineFactory.getLanguageVersion​()

String

NashornScriptEngineFactory.getMethodCallSyntax​(String obj, String method, String... args)

String

NashornScriptEngineFactory.getOutputStatement​(String toDisplay)

String[]

ScriptObjectMirror.getOwnKeys​(boolean all)

返回与对象关联的自己的属性键的数组。

String

NashornScriptEngineFactory.getProgram​(String... statements)

static String

NashornException.getScriptStackString​(Throwable exception)

返回格式化的脚本堆栈跟踪字符串，框架信息由“\ n”分隔

static String

ScriptUtils.parse​(String code, String name, boolean includeLoc)

将AST返回为JSON兼容字符串。

String

ScriptObjectMirror.toString​()

Methods in jdk.nashorn.api.scripting that return types with arguments of type String

Modifier and Type

方法

描述

Set<Map.Entry<String,Object>>

ScriptObjectMirror.entrySet​()

List<String>

NashornScriptEngineFactory.getExtensions​()

List<String>

NashornScriptEngineFactory.getMimeTypes​()

List<String>

NashornScriptEngineFactory.getNames​()

Set<String>

AbstractJSObject.keySet​()

Set<String>

JSObject.keySet​()

返回此对象的所有属性名称集。

Set<String>

ScriptObjectMirror.keySet​()

Methods in jdk.nashorn.api.scripting with parameters of type String

Modifier and Type

方法

描述

Object

ScriptObjectMirror.callMember​(String functionName, Object... args)

调用成员函数

CompiledScript

NashornScriptEngine.compile​(String str)

Object

AbstractJSObject.eval​(String s)

Object

JSObject.eval​(String s)

评估JavaScript表达式。

Object

NashornScriptEngine.eval​(String script, ScriptContext ctxt)

Object

ScriptObjectMirror.eval​(String s)

boolean

ClassFilter.exposeToScripts​(String className)

应该将指定名称的Java类暴露给脚本吗？

static String

ScriptUtils.format​(String format, Object[] args)

将JavaScript类型转换为String.format方法（jrunscript函数sprintf）的java类型的方法。

Object

AbstractJSObject.getMember​(String name)

Object

JSObject.getMember​(String name)

检索此JavaScript对象的命名成员。

Object

ScriptObjectMirror.getMember​(String name)

String

NashornScriptEngineFactory.getMethodCallSyntax​(String obj, String method, String... args)

String

NashornScriptEngineFactory.getOutputStatement​(String toDisplay)

Object

ScriptObjectMirror.getOwnPropertyDescriptor​(String key)

ECMA 8.12.1 [[GetOwnProperty]]（P）

Object

NashornScriptEngineFactory.getParameter​(String key)

String

NashornScriptEngineFactory.getProgram​(String... statements)

ScriptEngine

NashornScriptEngineFactory.getScriptEngine​(String... args)

创建一个使用给定参数初始化的新脚本引擎。

ScriptEngine

NashornScriptEngineFactory.getScriptEngine​(String[] args, ClassLoader appLoader)

创建一个新的Script引擎，并使用给定的参数和给定的类加载器进行初始化。

ScriptEngine

NashornScriptEngineFactory.getScriptEngine​(String[] args, ClassLoader appLoader, ClassFilter classFilter)

创建一个使用给定参数，类加载器和类过滤器初始化的新脚本引擎。

boolean

AbstractJSObject.hasMember​(String name)

boolean

JSObject.hasMember​(String name)

该对象是否具有命名成员？

boolean

ScriptObjectMirror.hasMember​(String name)

Object

NashornScriptEngine.invokeFunction​(String name, Object... args)

Object

NashornScriptEngine.invokeMethod​(Object thiz, String name, Object... args)

static String

ScriptUtils.parse​(String code, String name, boolean includeLoc)

将AST返回为JSON兼容字符串。

Object

ScriptObjectMirror.put​(String key, Object value)

void

AbstractJSObject.removeMember​(String name)

void

JSObject.removeMember​(String name)

从此JavaScript对象中删除一个已命名的成员

void

ScriptObjectMirror.removeMember​(String name)

void

NashornException.setFileName​(String fileName)

设置这个 NashornException的源文件名

void

AbstractJSObject.setMember​(String name, Object value)

void

JSObject.setMember​(String name, Object value)

在此JavaScript对象中设置一个命名成员

void

ScriptObjectMirror.setMember​(String name, Object value)

Method parameters in jdk.nashorn.api.scripting with type arguments of type String

Modifier and Type

方法

描述

void

ScriptObjectMirror.putAll​(Map<? extends String,? extends Object> map)

Constructors in jdk.nashorn.api.scripting with parameters of type String

Constructor

描述

NashornException​(String msg, String fileName, int line, int column)

构造函数初始化错误消息，文件名，行和列号。

NashornException​(String msg, Throwable cause)

构造器初始化错误消息并导致异常。

NashornException​(String msg, Throwable cause, String fileName, int line, int column)

构造器初始化错误消息，导致异常，文件名，行和列号。

URLReader​(URL url, String charsetName)

构造函数

Uses of String in jdk.nashorn.api.tree

Methods in jdk.nashorn.api.tree that return String

Modifier and Type

方法

描述

String

Diagnostic.getCode​()

获取指示诊断类型的诊断代码。

String

Diagnostic.getFileName​()

获取源文件名。

String

MemberSelectTree.getIdentifier​()

返回属性的名称。

String

BreakTree.getLabel​()

与此break语句关联的标签。

String

ContinueTree.getLabel​()

与此continue语句关联的标签。

String

GotoTree.getLabel​()

与此goto语句关联的标签。

String

LabeledStatementTree.getLabel​()

返回与此语句关联的标签。

String

Diagnostic.getMessage​()

获取此诊断的消息。

String

IdentifierTree.getName​()

返回此标识符的名称。

String

RegExpLiteralTree.getOptions​()

正则表达式匹配选项。

String

RegExpLiteralTree.getPattern​()

正则表达式模式匹配。

String

CompilationUnitTree.getSourceName​()

返回此脚本编译单元的源名称。

Methods in jdk.nashorn.api.tree with parameters of type String

Modifier and Type

方法

描述

static Parser

Parser.create​(String... options)

Factory方法创建一个新的Parser实例。

CompilationUnitTree

Parser.parse​(String name, Reader reader, DiagnosticListener listener)

解读读者并返回编译单元树

CompilationUnitTree

Parser.parse​(String name, String code, DiagnosticListener listener)

解析字符串源并返回编译单元树

static Diagnostic.Kind

Diagnostic.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

static Tree.Kind

Tree.Kind.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Uses of String in jdk.net

Methods in jdk.net that return String

Modifier and Type

方法

描述

String

SocketFlow.toString​()

Methods in jdk.net with parameters of type String

Modifier and Type

方法

描述

static SocketFlow.Status

SocketFlow.Status.valueOf​(String name)

以指定的名称返回此类型的枚举常量。

Constructors in jdk.net with parameters of type String

Constructor

描述

NetworkPermission​(String name)

使用给定的目标名称创建一个NetworkPermission。

NetworkPermission​(String name, String actions)

使用给定的目标名称创建一个NetworkPermission。

Uses of String in jdk.packager.services

Methods in jdk.packager.services that return types with arguments of type String

Modifier and Type

方法

描述

Map<String,String>

UserJvmOptionsService.getUserJVMOptionDefaults​()

UserJVMOptions的“默认”集合。

Map<String,String>

UserJvmOptionsService.getUserJVMOptionDefaults​()

UserJVMOptions的“默认”集合。

Map<String,String>

UserJvmOptionsService.getUserJVMOptions​()

UserJVMOptions的“当前”集合。

Map<String,String>

UserJvmOptionsService.getUserJVMOptions​()

UserJVMOptions的“当前”集合。

Method parameters in jdk.packager.services with type arguments of type String

Modifier and Type

方法

描述

void

UserJvmOptionsService.setUserJVMOptions​(Map<String,String> options)

将传入的选项设置为UserJVMOptions。

void

UserJvmOptionsService.setUserJVMOptions​(Map<String,String> options)

将传入的选项设置为UserJVMOptions。

Uses of String in jdk.security.jarsigner

Methods in jdk.security.jarsigner that return String

Modifier and Type

方法

描述

static String

JarSigner.Builder.getDefaultDigestAlgorithm​()

获取默认摘要算法。

static String

JarSigner.Builder.getDefaultSignatureAlgorithm​(PrivateKey key)

获取私钥的默认签名算法。

String

JarSigner.getDigestAlgorithm​()

返回此 JarSigner的摘要算法。

String

JarSigner.getProperty​(String key)

返回由指定键指示的附加实现特定属性的值。

String

JarSigner.getSignatureAlgorithm​()

返回此 JarSigner的签名算法。

String

JarSigner.getSignerName​()

返回此 JarSigner的签名者名称。

Methods in jdk.security.jarsigner with parameters of type String

Modifier and Type

方法

描述

JarSigner.Builder

JarSigner.Builder.digestAlgorithm​(String algorithm)

设置摘要算法。

JarSigner.Builder

JarSigner.Builder.digestAlgorithm​(String algorithm, Provider provider)

从指定的提供者设置摘要算法。

String

JarSigner.getProperty​(String key)

返回由指定键指示的附加实现特定属性的值。

JarSigner.Builder

JarSigner.Builder.setProperty​(String key, String value)

设置由指定键指示的附加实现特定属性。

JarSigner.Builder

JarSigner.Builder.signatureAlgorithm​(String algorithm)

设置签名算法。

JarSigner.Builder

JarSigner.Builder.signatureAlgorithm​(String algorithm, Provider provider)

从指定的提供者设置签名算法。

JarSigner.Builder

JarSigner.Builder.signerName​(String name)

设置签名者名称。

Method parameters in jdk.security.jarsigner with type arguments of type String

Modifier and Type

方法

描述

JarSigner.Builder

JarSigner.Builder.eventHandler​(BiConsumer<String,String> handler)

设置当在签名过程中添加，签名或更新JarEntry时将触发的事件处理程序。

JarSigner.Builder

JarSigner.Builder.eventHandler​(BiConsumer<String,String> handler)

设置当在签名过程中添加，签名或更新JarEntry时触发的事件处理程序。

Constructors in jdk.security.jarsigner with parameters of type String

Constructor

描述

JarSignerException​(String message, Throwable cause)

构造一个新的 JarSignerException具有指定的详细信息和原因。

Uses of String in netscape.javascript

Methods in netscape.javascript with parameters of type String

Modifier and Type

方法

描述

abstract Object

JSObject.call​(String methodName, Object... args)

调用JavaScript方法。

abstract Object

JSObject.eval​(String s)

评估JavaScript表达式。

abstract Object

JSObject.getMember​(String name)

检索JavaScript对象的命名成员。

abstract void

JSObject.removeMember​(String name)

删除一个JavaScript对象的命名成员。

abstract void

JSObject.setMember​(String name, Object value)

设置一个JavaScript对象的命名成员。

Constructors in netscape.javascript with parameters of type String

Constructor

描述

JSException​(String s)

使用指定的详细消息构造新的JavaScript异常。

Uses of String in org.ietf.jgss

Methods in org.ietf.jgss that return String

Modifier and Type

方法

描述

String

GSSException.getMajorString​()

返回一个解释GSS-API级别主要错误代码的字符串。

String

GSSException.getMessage​()

返回主要和次要状态代码的文本表示。

String

GSSException.getMinorString​()

返回一个解释机制特定错误代码的字符串。

String

MessageProp.getMinorString​()

检索一个解释次要状态代码的字符串。

String

GSSException.toString​()

返回主要和次要状态代码的文本表示。

String

GSSName.toString​()

返回 GSSName对象的文本表示。

String

Oid.toString​()

以点分隔的符号返回oid的整数分量的字符串表示形式。

Methods in org.ietf.jgss with parameters of type String

Modifier and Type

方法

描述

abstract GSSName

GSSManager.createName​(String nameStr, Oid nameType)

将字符串名称从指定的命名空间转换为GSSName对象的Factory方法。

abstract GSSName

GSSManager.createName​(String nameStr, Oid nameType, Oid mech)

将字符串名称从指定的命名空间转换为GSSName对象并将其同时用于机制进行规范化的Factory方法。

void

GSSException.setMinor​(int minorCode, String message)

由异常thrower用于设置机制级别的小错误代码及其字符串说明。

void

MessageProp.setSupplementaryStates​(boolean duplicate, boolean old, boolean unseq, boolean gap, int minorStatus, String minorString)

该方法设置补充信息标志的状态和MessageProp中的次要状态。

Constructors in org.ietf.jgss with parameters of type String

Constructor

描述

GSSException​(int majorCode, int minorCode, String minorString)

创建具有指定主要代码，次要代码和次要代码文本说明的GSSException对象。

Oid​(String strOid)

从其整数组件的字符串表示形式构造一个Oid对象。

Uses of String in org.omg.CORBA

Fields in org.omg.CORBA declared as String

Modifier and Type

Field

描述

String

ValueMember.defined_in

该成员被定义的 value的存储库ID。

String

NameValuePair.id

要与此 NameValuePair对象的值相关联的名称。

String

ValueMember.id

ValueMember对象描述的 value成员的存储库ID;

String

StructMember.name

由该 StructMember对象描述的结构体成员的名称。

String

UnionMember.name

由该 UnionMember对象描述的联盟成员的名称。

String

ValueMember.name

由该 ValueMember对象描述的 value成员的名称。

String

StringHolder.value

由 StringHolder对象持有的 String值。

String[]

StringSeqHolder.value

String[]

WStringSeqHolder.value

String

ValueMember.version

该成员定义的版本为 value 。

Methods in org.omg.CORBA that return String

Modifier and Type

方法

描述

String[]

_IDLTypeStub._ids​()

String[]

_PolicyStub._ids​()

String[]

DynamicImplementation._ids​()

已过时。

abstract String

Context.context_name​()

检索此 Context对象的名称。

String

DynStruct.current_member_name​()

已过时。

在遍历期间，返回当前成员的名称。

String

DynValue.current_member_name​()

已过时。

在遍历表示Value对象的 DynAny对象时返回当前成员的名称。

static String

FieldNameHelper.extract​(Any a)

static String

IdentifierHelper.extract​(Any a)

static String

RepositoryIdHelper.extract​(Any a)

static String[]

StringSeqHelper.extract​(Any a)

static String

StringValueHelper.extract​(Any a)

static String

VersionSpecHelper.extract​(Any a)

static String[]

WStringSeqHelper.extract​(Any a)

static String

WStringValueHelper.extract​(Any a)

abstract String

Any.extract_string​()

在此 Any对象的 value字段中提取 String对象。

abstract String

Any.extract_wstring​()

提取 String在这个对象 Any对象 value场。

String

StringValueHelper.get_id​()

String

WStringValueHelper.get_id​()

String

DynAny.get_string​()

已过时。

检索 String包含在此 DynAny对象。

String

DynAny.get_wstring​()

已过时。

检索 String包含在此 DynAny对象。

static String

AnySeqHelper.id​()

static String

BooleanSeqHelper.id​()

static String

BoundsHelper.id​()

static String

CharSeqHelper.id​()

static String

CompletionStatusHelper.id​()

static String

CurrentHelper.id​()

static String

DefinitionKindHelper.id​()

static String

DoubleSeqHelper.id​()

static String

FieldNameHelper.id​()

static String

FloatSeqHelper.id​()

static String

IdentifierHelper.id​()

static String

IDLTypeHelper.id​()

static String

LongLongSeqHelper.id​()

static String

LongSeqHelper.id​()

static String

NameValuePairHelper.id​()

static String

ObjectHelper.id​()

static String

OctetSeqHelper.id​()

static String

ParameterModeHelper.id​()

static String

PolicyErrorCodeHelper.id​()

static String

PolicyErrorHelper.id​()

static String

PolicyHelper.id​()

static String

PolicyListHelper.id​()

static String

PolicyTypeHelper.id​()

static String

RepositoryIdHelper.id​()

static String

ServiceDetailHelper.id​()

static String

ServiceInformationHelper.id​()

static String

SetOverrideTypeHelper.id​()

static String

ShortSeqHelper.id​()

static String

StringSeqHelper.id​()

static String

StringValueHelper.id​()

static String

StructMemberHelper.id​()

abstract String

TypeCode.id​()

检索RepositoryId，全局标识此 TypeCode对象的类型。

static String

ULongLongSeqHelper.id​()

static String

ULongSeqHelper.id​()

static String

UnionMemberHelper.id​()

static String

UnknownUserExceptionHelper.id​()

static String

UShortSeqHelper.id​()

static String

ValueBaseHelper.id​()

static String

ValueMemberHelper.id​()

static String

VersionSpecHelper.id​()

static String

VisibilityHelper.id​()

static String

WCharSeqHelper.id​()

static String

WrongTransactionHelper.id​()

static String

WStringSeqHelper.id​()

static String

WStringValueHelper.id​()

abstract String

ContextList.item​(int index)

返回给定索引处的 String对象。

abstract String[]

ORB.list_initial_services​()

返回最初可用的CORBA对象引用的列表，例如“NameService”和“InterfaceRepository”。

String

DynUnion.member_name​()

已过时。

允许检查该联合成员的名称，而不检查鉴别器的值。

abstract String

TypeCode.member_name​(int index)

检索由给定索引识别的成员的简单名称。

abstract String

NamedValue.name​()

检索此 NamedValue对象的名称。

abstract String

TypeCode.name​()

检索在其封闭范围内识别此 TypeCode对象的简单名称。

abstract String

ORB.object_to_string​(Object obj)

将给定的CORBA对象引用转换为字符串。

String

ServerRequest.op_name​()

已过时。
使用操作（）

abstract String

Request.operation​()

检索要调用的方法的名称。

String

ServerRequest.operation​()

抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。

static String

FieldNameHelper.read​(InputStream istream)

static String

IdentifierHelper.read​(InputStream istream)

static String

RepositoryIdHelper.read​(InputStream istream)

static String[]

StringSeqHelper.read​(InputStream istream)

static String

StringValueHelper.read​(InputStream istream)

static String

VersionSpecHelper.read​(InputStream istream)

static String[]

WStringSeqHelper.read​(InputStream istream)

static String

WStringValueHelper.read​(InputStream istream)

String

DataInputStream.read_string​()

从输入流读取IDL字符串。

String

DataInputStream.read_wstring​()

从输入流读取IDL宽字符串。

String

SystemException.toString​()

将此异常转换为代表字符串。

String

DynEnum.value_as_string​()

已过时。

将此 DynEnum存储的IDL枚举的值作为字符串返回。

Methods in org.omg.CORBA with parameters of type String

Modifier and Type

方法

描述

Request

LocalObject._create_request​(Context ctx, String operation, NVList arg_list, NamedValue result)

抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部约束的对象”。

Request

LocalObject._create_request​(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)

使用消息“这是一个局部受限的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。

Request

Object._create_request​(Context ctx, String operation, NVList arg_list, NamedValue result)

创建一个 Request实例，使用给定的上下文，方法名称，参数列表以及方法返回值的容器进行初始化。

Request

Object._create_request​(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)

创建一个使用给定上下文，方法名称，参数列表，方法返回值的容器，可能的异常列表以及需要解析的上下文串列表初始化的 Request实例。

boolean

LocalObject._is_a​(String repository_id)

抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部约束的对象”。

boolean

Object._is_a​(String repositoryIdentifier)

检查此对象是否是实现给定接口的类的实例。

Request

LocalObject._request​(String operation)

抛出一个 org.omg.CORBA.NO_IMPLEMENT异常消息“这是一个局部约束的对象”。

OutputStream

LocalObject._request​(String operation, boolean responseExpected)

使用消息“这是一个本地约束的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。

Request

Object._request​(String operation)

创建用于动态调用接口的 Request实例。

ServantObject

LocalObject._servant_preinvoke​(String operation, Class expectedType)

使用消息“这是一个局部受限的对象”抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。

abstract void

ContextList.add​(String ctx)

添加一个 String对象本 ContextList对象。

abstract NamedValue

NVList.add_item​(String item_name, int flags)

创建一个新的 NamedValue对象，使用给定的名称和标志进行初始化，并将其添加到此 NVList对象的末尾。

abstract Any

Request.add_named_in_arg​(String name)

使用给定的名称创建输入参数，并将其添加到此 Request对象。

abstract Any

Request.add_named_inout_arg​(String name)

将给定名称的输入/输出参数添加到此 Request对象。

abstract Any

Request.add_named_out_arg​(String name)

将给定名称的输出参数添加到此 Request对象。

abstract NamedValue

NVList.add_value​(String item_name, Any val, int flags)

创建一个新的 NamedValue对象，使用给定的名称，值和标志初始化，并将其添加到此 NVList对象的末尾。

TypeCode

ORB.create_abstract_interface_tc​(String id, String name)

为IDL抽象接口创建一个 TypeCode对象。

abstract TypeCode

ORB.create_alias_tc​(String id, String name, TypeCode original_type)

创建一个表示IDL alias （ typedef ）的 TypeCode对象。

abstract Context

Context.create_child​(String child_ctx_name)

创建一个 Context对象，其中给定的字符串作为其名称，并将此 Context对象设置为其父对象。

abstract TypeCode

ORB.create_enum_tc​(String id, String name, String[] members)

创建一个 TypeCode对象，代表IDL 枚举 。

abstract TypeCode

ORB.create_exception_tc​(String id, String name, StructMember[] members)

创建一个表示IDL exception的 TypeCode对象。

abstract TypeCode

ORB.create_interface_tc​(String id, String name)

创建一个表示IDL interface的 TypeCode对象。

abstract NamedValue

ORB.create_named_value​(String s, Any any, int flags)

使用给定的名称，值和参数模式标志创建一个 NamedValue对象。

TypeCode

ORB.create_native_tc​(String id, String name)

为IDL本机类型创建一个 TypeCode对象。

TypeCode

ORB.create_recursive_tc​(String id)

在创建包含递归的TypeCode的过程中，创建一个递归的 TypeCode对象，该对象用作具体TypeCode的占位符。

abstract TypeCode

ORB.create_struct_tc​(String id, String name, StructMember[] members)

创建一个表示IDL struct的 TypeCode对象。

abstract TypeCode

ORB.create_union_tc​(String id, String name, TypeCode discriminator_type, UnionMember[] members)

创建一个表示IDL union的 TypeCode对象。

TypeCode

ORB.create_value_box_tc​(String id, String name, TypeCode boxed_type)

为IDL值框创建一个 TypeCode对象。

TypeCode

ORB.create_value_tc​(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)

为IDL值类型创建一个 TypeCode对象。

abstract void

Context.delete_values​(String propname)

从此 Context对象中删除其 name字段与给定属性名称匹配的 NamedValue对象。

abstract NVList

Context.get_values​(String start_scope, int op_flags, String pattern)

检索其 name字段与给定名称或名称模式匹配的 NamedValue对象。

static ORB

ORB.init​(String[] args, Properties props)

为独立应用程序创建一个新的 ORB实例。

static void

FieldNameHelper.insert​(Any a, String that)

static void

IdentifierHelper.insert​(Any a, String that)

static void

RepositoryIdHelper.insert​(Any a, String that)

static void

StringSeqHelper.insert​(Any a, String[] that)

static void

StringValueHelper.insert​(Any a, String that)

static void

VersionSpecHelper.insert​(Any a, String that)

static void

WStringSeqHelper.insert​(Any a, String[] that)

static void

WStringValueHelper.insert​(Any a, String that)

abstract void

Any.insert_string​(String s)

将给定的 String对象插入到此 Any对象的 value字段中。

void

DynAny.insert_string​(String value)

已过时。

将给定的 String对象插入作为此 DynAny对象的值。

abstract void

Any.insert_wstring​(String s)

将给定的 String对象插入到此 Any对象的 value字段中。

void

DynAny.insert_wstring​(String value)

已过时。

将给定的 String作为该 DynAny对象的值插入。

void

DynUnion.member_name​(String arg)

已过时。

允许分配该联盟成员的名称。

abstract Object

ORB.resolve_initial_references​(String object_name)

从可用的初始服务名称集中解析特定的对象引用。

abstract void

Context.set_one_value​(String propname, Any propvalue)

创建一个 NamedValue对象，并将其添加到此 Context对象。

protected abstract void

ORB.set_parameters​(String[] args, Properties props)

允许使用给定的参数和属性初始化ORB实现。

abstract Object

ORB.string_to_object​(String str)

将由方法 object_to_string生成的字符串转换回CORBA对象引用。

void

DynEnum.value_as_string​(String arg)

已过时。

在这个 DynEnum设置一个特定的枚举。

static void

FieldNameHelper.write​(OutputStream ostream, String value)

static void

IdentifierHelper.write​(OutputStream ostream, String value)

static void

RepositoryIdHelper.write​(OutputStream ostream, String value)

static void

StringSeqHelper.write​(OutputStream ostream, String[] value)

static void

StringValueHelper.write​(OutputStream ostream, String value)

static void

VersionSpecHelper.write​(OutputStream ostream, String value)

static void

WStringSeqHelper.write​(OutputStream ostream, String[] value)

static void

WStringValueHelper.write​(OutputStream ostream, String value)

void

DataOutputStream.write_string​(String value)

将IDL字符串值写入输出流。

void

DataOutputStream.write_wstring​(String value)

将IDL宽字符串值（表示为Java字符串）写入输出流。

Constructors in org.omg.CORBA with parameters of type String

Constructor

描述

ACTIVITY_COMPLETED​(String detailMessage)

使用指定的消息构造一个 ACTIVITY_COMPLETED异常。

ACTIVITY_COMPLETED​(String detailMessage, int minorCode, CompletionStatus completionStatus)

构造具有指定消息，次要代码和完成状态的 ACTIVITY_COMPLETED异常。

ACTIVITY_REQUIRED​(String detailMessage)

使用指定的消息构造一个 ACTIVITY_REQUIRED异常。

ACTIVITY_REQUIRED​(String detailMessage, int minorCode, CompletionStatus completionStatus)

构造具有指定消息，次要代码和完成状态的 ACTIVITY_REQUIRED异常。

BAD_CONTEXT​(String s)

构造具有指定详细消息的 BAD_CONTEXT异常，次要代码为0，完成状态为COMPLETED_NO。

BAD_CONTEXT​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 BAD_CONTEXT异常。

BAD_INV_ORDER​(String s)

构造一个 BAD_INV_ORDER异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

BAD_INV_ORDER​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 BAD_INV_ORDER异常。

BAD_OPERATION​(String s)

构造一个 BAD_OPERATION异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

BAD_OPERATION​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 BAD_OPERATION异常。

BAD_PARAM​(String s)

构造一个 BAD_PARAM异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

BAD_PARAM​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 BAD_PARAM异常。

BAD_QOS​(String detailMessage)

使用指定的消息构造一个 BAD_QOS异常。

BAD_QOS​(String detailMessage, int minorCode, CompletionStatus completionStatus)

构造具有指定消息，次要代码和完成状态的 BAD_QOS异常。

BAD_TYPECODE​(String s)

构造一个 BAD_TYPECODE异常，指定的细节，次要代码为0，完成状态为COMPLETED_NO。

BAD_TYPECODE​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 BAD_TYPECODE异常。

Bounds​(String reason)

构造具有指定详细消息的 Bounds 。

CODESET_INCOMPATIBLE​(String detailMessage)

使用指定的消息构造一个 CODESET_INCOMPATIBLE异常。

CODESET_INCOMPATIBLE​(String detailMessage, int minorCode, CompletionStatus completionStatus)

构造具有指定消息，次要代码和完成状态的 CODESET_INCOMPATIBLE异常。

COMM_FAILURE​(String s)

构造一个 COMM_FAILURE异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

COMM_FAILURE​(String s, int minor, CompletionStatus completed)

构造一个 COMM_FAILURE异常，指定的详细消息，次要代码和完成状态。

DATA_CONVERSION​(String s)

构造具有指定详细信息的 DATA_CONVERSION异常。

DATA_CONVERSION​(String s, int minor, CompletionStatus completed)

构造具有指定的详细信息，次要代码和完成状态的 DATA_CONVERSION异常。

FREE_MEM​(String s)

构造一个 FREE_MEM异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

FREE_MEM​(String s, int minor, CompletionStatus completed)

构造一个 FREE_MEM异常，指定的详细信息，次要代码和完成状态。

IMP_LIMIT​(String s)

构造一个 IMP_LIMIT异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

IMP_LIMIT​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 IMP_LIMIT异常。

INITIALIZE​(String s)

构造具有指定详细消息的 INITIALIZE异常，次要代码为0，完成状态为 CompletionStatus.COMPLETED_NO 。

INITIALIZE​(String s, int minor, CompletionStatus completed)

构造一个 INITIALIZE异常，指定的详细消息，次要代码和完成状态。

INTERNAL​(String s)

构造一个 INTERNAL异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INTERNAL​(String s, int minor, CompletionStatus completed)

构造一个 INTERNAL异常，指定的详细消息，次要代码和完成状态。

INTF_REPOS​(String s)

构造具有指定详细信息的 INTF_REPOS异常。

INTF_REPOS​(String s, int minor, CompletionStatus completed)

构造一个 INTF_REPOS异常，其中包含指定的详细消息，次要代码和完成状态。

INV_FLAG​(String s)

构造一个 INV_FLAG异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INV_FLAG​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 INV_FLAG异常。

INV_IDENT​(String s)

构造一个 INV_IDENT异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INV_IDENT​(String s, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 INV_IDENT异常。

INV_OBJREF​(String s)

构造一个 INV_OBJREF异常，指定的详细消息，次要代码为0，完成状态为COMPLETED_NO。

INV_OBJREF​(String s, int minor, CompletionStatus completed)

构造一个 INV_OBJREF异常，指定的详细消息，次要代码和完成状态。

INV_POLICY​(String s)

构造一个 INV_POLICY异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

INV_POLICY​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 INV_POLICY异常。

INVALID_ACTIVITY​(String detailMessage)

使用指定的消息构造一个 INVALID_ACTIVITY异常。

INVALID_ACTIVITY​(String detailMessage, int minorCode, CompletionStatus completionStatus)

构造具有指定消息，次要代码和完成状态的 INVALID_ACTIVITY异常。

INVALID_TRANSACTION​(String s)

构造具有指定详细消息的 INVALID_TRANSACTION异常。

INVALID_TRANSACTION​(String s, int minor, CompletionStatus completed)

构造一个 INVALID_TRANSACTION异常，指定的详细消息，次要代码和完成状态。

MARSHAL​(String s)

构造一个 MARSHAL异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

MARSHAL​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 MARSHAL异常。

NameValuePair​(String __id, Any __value)

构造一个 NameValuePair对象，该对象将给定的名称与给定的 org.omg.CORBA.Any对象相关联。

NO_IMPLEMENT​(String s)

构造一个 NO_IMPLEMENT异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

NO_IMPLEMENT​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 NO_IMPLEMENT异常。

NO_MEMORY​(String s)

构造一个 NO_MEMORY异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

NO_MEMORY​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 NO_MEMORY异常。

NO_PERMISSION​(String s)

构造一个 NO_PERMISSION异常，指定的描述，次要代码为0，完成状态为COMPLETED_NO。

NO_PERMISSION​(String s, int minor, CompletionStatus completed)

构造一个 NO_PERMISSION异常，其中包含指定的描述消息，次要代码和完成状态。

NO_RESOURCES​(String s)

构造一个 NO_RESOURCES异常，指定描述，次要代码为0，完成状态为COMPLETED_NO。

NO_RESOURCES​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 NO_RESOURCES异常。

NO_RESPONSE​(String s)

构造一个 NO_RESPONSE异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

NO_RESPONSE​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 NO_RESPONSE异常。

OBJ_ADAPTER​(String s)

构造一个 OBJ_ADAPTER异常，指定的描述，次要代码为0，完成状态为COMPLETED_NO。

OBJ_ADAPTER​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 OBJ_ADAPTER异常。

OBJECT_NOT_EXIST​(String s)

构造一个 OBJECT_NOT_EXIST异常，指定描述，次要代码为0，完成状态为COMPLETED_NO。

OBJECT_NOT_EXIST​(String s, int minor, CompletionStatus completed)

构造一个 OBJECT_NOT_EXIST异常，其中包含指定的描述消息，次要代码和完成状态。

PERSIST_STORE​(String s)

构造一个 PERSIST_STORE异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

PERSIST_STORE​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 PERSIST_STORE异常。

PolicyError​(String reason_string, short __reason)

构造一个 PolicyError用户异常，它使用给定的原因详细信息和原因代码进行初始化。

REBIND​(String detailMessage)

使用指定的消息构造一个 REBIND异常。

REBIND​(String detailMessage, int minorCode, CompletionStatus completionStatus)

构造一个 REBIND异常与指定的消息，次要代码和完成状态。

StringHolder​(String initial)

构造一个新的 StringHolder对象，其 value字段初始化为给定的 String 。

StringSeqHolder​(String[] initialValue)

StructMember​(String __name, TypeCode __type, IDLType __type_def)

构造一个用给定值初始化的一个 StructMember对象。

SystemException​(String reason, int minor, CompletionStatus completed)

构造具有指定的详细消息，次要代码和完成状态的 SystemException异常。

TIMEOUT​(String detailMessage)

使用指定的消息构造一个 TIMEOUT异常。

TIMEOUT​(String detailMessage, int minorCode, CompletionStatus completionStatus)

构造具有指定消息，次要代码和完成状态的 TIMEOUT异常。

TRANSACTION_MODE​(String s)

构造一个 TRANSACTION_MODE异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_MODE​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_MODE异常。

TRANSACTION_REQUIRED​(String s)

构造一个 TRANSACTION_REQUIRED异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_REQUIRED​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_REQUIRED异常。

TRANSACTION_ROLLEDBACK​(String s)

构造一个 TRANSACTION_ROLLEDBACK异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_ROLLEDBACK​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_ROLLEDBACK异常。

TRANSACTION_UNAVAILABLE​(String s)

构造一个 TRANSACTION_UNAVAILABLE异常，其中包含指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSACTION_UNAVAILABLE​(String s, int minor, CompletionStatus completed)

构造具有指定的描述消息，次要代码和完成状态的 TRANSACTION_UNAVAILABLE异常。

TRANSIENT​(String s)

构造一个 TRANSIENT异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

TRANSIENT​(String s, int minor, CompletionStatus completed)

构造一个 TRANSIENT异常，其中包含指定的描述消息，次要代码和完成状态。

UnionMember​(String __name, Any __label, TypeCode __type, IDLType __type_def)

构造一个新的 UnionMember对象，其字段初始化为给定的值。

UNKNOWN​(String s)

构造一个 UNKNOWN异常，指定的描述消息，次要代码为0，完成状态为COMPLETED_NO。

UNKNOWN​(String s, int minor, CompletionStatus completed)

构造一个 UNKNOWN异常，其中包含指定的描述消息，次要代码和完成状态。

UserException​(String reason)

构造具有详细消息的 UserException对象。

ValueMember​(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)

构造一个用给定值初始化的 ValueMember对象。

WrongTransaction​(String reason)

构造具有给定详细消息的WrongTransaction对象。

WStringSeqHolder​(String[] initialValue)

Uses of String in org.omg.CORBA_2_3

Methods in org.omg.CORBA_2_3 with parameters of type String

Modifier and Type

方法

描述

Object

ORB.get_value_def​(String repid)

ValueFactory

ORB.lookup_value_factory​(String id)

ValueFactory

ORB.register_value_factory​(String id, ValueFactory factory)

void

ORB.unregister_value_factory​(String id)

Uses of String in org.omg.CORBA_2_3.portable

Methods in org.omg.CORBA_2_3.portable that return String

Modifier and Type

方法

描述

String

ObjectImpl._get_codebase​()

返回此对象引用的代码库。

String

Delegate.get_codebase​(Object self)

返回提供的对象引用的代码库。

Methods in org.omg.CORBA_2_3.portable with parameters of type String

Modifier and Type

方法

描述

Serializable

InputStream.read_value​(String rep_id)

从输入流解组值类型。

void

OutputStream.write_value​(Serializable value, String repository_id)

为输出流调度值类型。

Uses of String in org.omg.CORBA.DynAnyPackage

Constructors in org.omg.CORBA.DynAnyPackage with parameters of type String

Constructor

描述

Invalid​(String reason)

构造一个 Invalid对象。

InvalidSeq​(String reason)

构造一个 InvalidSeq对象。

InvalidValue​(String reason)

构造一个 InvalidValue对象。

TypeMismatch​(String reason)

构造一个 TypeMismatch对象。

Uses of String in org.omg.CORBA.ORBPackage

Methods in org.omg.CORBA.ORBPackage that return String

Modifier and Type

方法

描述

static String

InvalidNameHelper.id​()

Constructors in org.omg.CORBA.ORBPackage with parameters of type String

Constructor

描述

InconsistentTypeCode​(String reason)

构造具有指定原因消息的 InconsistentTypeCode用户异常。

InvalidName​(String reason)

构造具有指定原因消息的 InvalidName异常。

Uses of String in org.omg.CORBA.portable

Methods in org.omg.CORBA.portable that return String

Modifier and Type

方法

描述

abstract String[]

ObjectImpl._ids​()

检索包含此 ObjectImpl对象支持的存储库标识符的字符串数组。

String[]

ValueBase._truncatable_ids​()

提供可截断的存储库ID。

String

BoxedValueHelper.get_id​()

String

ApplicationException.getId​()

返回异常的CORBA存储库ID，而不从异常输入流中删除它。

abstract String

InputStream.read_string​()

从此输入流读取字符串值。

abstract String

InputStream.read_wstring​()

从此输入流读取一个宽字符串值。

String

Delegate.toString​(Object self)

提供实现来覆盖委托CORBA对象的toString（）方法。

String

ObjectImpl.toString​()

返回 String对象，它表示此 ObjectImpl对象。

Methods in org.omg.CORBA.portable with parameters of type String

Modifier and Type

方法

描述

Request

ObjectImpl._create_request​(Context ctx, String operation, NVList arg_list, NamedValue result)

创建一个 Request对象，其中包含给定的上下文，方法，参数列表和容器的结果。

Request

ObjectImpl._create_request​(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)

创建一个 Request对象，其中包含给定的上下文，方法，参数列表，结果容器，异常以及用于解析上下文字符串的属性名称列表。

OutputStream

InvokeHandler._invoke​(String method, InputStream input, ResponseHandler handler)

由ORB调用，向仆人发出请求。

boolean

ObjectImpl._is_a​(String repository_id)

检查由给定的存储库标识符标识的对象是否为 ObjectImpl对象。

Request

ObjectImpl._request​(String operation)

创建一个包含可以与动态调用接口一起使用的给定方法的 Request对象。

OutputStream

ObjectImpl._request​(String operation, boolean responseExpected)

返回一个用于编组给定方法的参数的 OutputStream对象。

ServantObject

ObjectImpl._servant_preinvoke​(String operation, Class expectedType)

返回对本地servant的Java引用，该引用应用于发送请求方法。

abstract Request

Delegate.create_request​(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)

创建一个要在动态调用接口中使用的请求实例。

abstract Request

Delegate.create_request​(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)

创建一个要在动态调用接口中使用的请求实例。

abstract boolean

Delegate.is_a​(Object obj, String repository_id)

检查对象引用是否是给定接口的实例。

abstract Request

Delegate.request​(Object obj, String operation)

创建一个要在动态调用接口中使用的请求实例。

OutputStream

Delegate.request​(Object self, String operation, boolean responseExpected)

请求被stub调用以获取用于封送参数的OutputStream。

ServantObject

Delegate.servant_preinvoke​(Object self, String operation, Class expectedType)

返回应用于此请求的servant的Java引用。 servant_preinvoke（）由本地存根调用。

void

ValueOutputStream.start_value​(String rep_id)

start_value方法结束任何当前打开的块，为嵌套的自定义值类型（具有空代码库和指定的存储库ID）写入值类型头，并增加值类型嵌套深度。

abstract void

OutputStream.write_string​(String value)

将字符串值写入此流。

abstract void

OutputStream.write_wstring​(String value)

为此流写入一个宽字符串值。

Constructors in org.omg.CORBA.portable with parameters of type String

Constructor

描述

ApplicationException​(String id, InputStream ins)

从异常的CORBA存储库ID中构造一个ApplicationException，以及可以读取异常数据作为参数的输入流。

Uses of String in org.omg.CORBA.TypeCodePackage

Methods in org.omg.CORBA.TypeCodePackage that return String

Modifier and Type

方法

描述

static String

BadKindHelper.id​()

static String

BoundsHelper.id​()

Constructors in org.omg.CORBA.TypeCodePackage with parameters of type String

Constructor

描述

BadKind​(String reason)

使用指定的原因消息构造一个 BadKind异常。

Bounds​(String reason)

构造具有指定原因消息的 Bounds异常。

Uses of String in org.omg.CosNaming

Fields in org.omg.CosNaming declared as String

Modifier and Type

Field

描述

String

NameComponent.id

String

NameComponent.kind

Methods in org.omg.CosNaming that return String

Modifier and Type

方法

描述

String[]

BindingIteratorPOA._all_interfaces​(POA poa, byte[] objectId)

String[]

NamingContextExtPOA._all_interfaces​(POA poa, byte[] objectId)

String[]

NamingContextPOA._all_interfaces​(POA poa, byte[] objectId)

String[]

_BindingIteratorImplBase._ids​()

String[]

_BindingIteratorStub._ids​()

String[]

_NamingContextExtStub._ids​()

String[]

_NamingContextImplBase._ids​()

String[]

_NamingContextStub._ids​()

static String

IstringHelper.extract​(Any a)

static String

BindingHelper.id​()

static String

BindingIteratorHelper.id​()

static String

BindingListHelper.id​()

static String

BindingTypeHelper.id​()

static String

IstringHelper.id​()

static String

NameComponentHelper.id​()

static String

NameHelper.id​()

static String

NamingContextExtHelper.id​()

static String

NamingContextHelper.id​()

static String

IstringHelper.read​(InputStream istream)

String

_NamingContextExtStub.to_string​(NameComponent[] n)

此操作从名称组件数组中创建一个带字符串的名称。

String

NamingContextExtOperations.to_string​(NameComponent[] n)

此操作从名称组件数组中创建一个带字符串的名称。

String

_NamingContextExtStub.to_url​(String addr, String sn)

此操作将从对象的Stringified Name创建一个基于URL的“iiopname：//”格式名称。

String

NamingContextExtOperations.to_url​(String addr, String sn)

此操作将从对象的Stringified Name创建一个基于URL的“iiopname：//”格式名称。

Methods in org.omg.CosNaming with parameters of type String

Modifier and Type

方法

描述

OutputStream

BindingIteratorPOA._invoke​(String $method, InputStream in, ResponseHandler $rh)

OutputStream

NamingContextExtPOA._invoke​(String $method, InputStream in, ResponseHandler $rh)

OutputStream

NamingContextPOA._invoke​(String $method, InputStream in, ResponseHandler $rh)

static void

IstringHelper.insert​(Any a, String that)

Object

_NamingContextExtStub.resolve_str​(String sn)

此操作将Stringified名称解析为对象引用。

Object

NamingContextExtOperations.resolve_str​(String sn)

此操作将Stringified名称解析为对象引用。

NameComponent[]

_NamingContextExtStub.to_name​(String sn)

此操作将字符串名称转换为等效的名称组件数组。

NameComponent[]

NamingContextExtOperations.to_name​(String sn)

此操作将字符串名称转换为等效的名称组件数组。

String

_NamingContextExtStub.to_url​(String addr, String sn)

此操作将从对象的Stringified Name创建一个基于URL的“iiopname：//”格式名称。

String

NamingContextExtOperations.to_url​(String addr, String sn)

此操作将从对象的Stringified Name创建一个基于URL的“iiopname：//”格式名称。

static void

IstringHelper.write​(OutputStream ostream, String value)

Constructors in org.omg.CosNaming with parameters of type String

Constructor

描述

NameComponent​(String _id, String _kind)

Uses of String in org.omg.CosNaming.NamingContextExtPackage

Methods in org.omg.CosNaming.NamingContextExtPackage that return String

Modifier and Type

方法

描述

static String

AddressHelper.extract​(Any a)

static String

StringNameHelper.extract​(Any a)

static String

URLStringHelper.extract​(Any a)

static String

AddressHelper.id​()

static String

InvalidAddressHelper.id​()

static String

StringNameHelper.id​()

static String

URLStringHelper.id​()

static String

AddressHelper.read​(InputStream istream)

static String

StringNameHelper.read​(InputStream istream)

static String

URLStringHelper.read​(InputStream istream)

Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type String

Modifier and Type

方法

描述

static void

AddressHelper.insert​(Any a, String that)

static void

StringNameHelper.insert​(Any a, String that)

static void

URLStringHelper.insert​(Any a, String that)

static void

AddressHelper.write​(OutputStream ostream, String value)

static void

StringNameHelper.write​(OutputStream ostream, String value)

static void

URLStringHelper.write​(OutputStream ostream, String value)

Constructors in org.omg.CosNaming.NamingContextExtPackage with parameters of type String

Constructor

描述

InvalidAddress​(String $reason)

Uses of String in org.omg.CosNaming.NamingContextPackage

Methods in org.omg.CosNaming.NamingContextPackage that return String

Modifier and Type

方法

描述

static String

AlreadyBoundHelper.id​()

static String

CannotProceedHelper.id​()

static String

InvalidNameHelper.id​()

static String

NotEmptyHelper.id​()

static String

NotFoundHelper.id​()

static String

NotFoundReasonHelper.id​()

Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type String

Constructor

描述

AlreadyBound​(String $reason)

CannotProceed​(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)

InvalidName​(String $reason)

NotEmpty​(String $reason)

NotFound​(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)

Uses of String in org.omg.DynamicAny

Fields in org.omg.DynamicAny declared as String

Modifier and Type

Field

描述

String

NameDynAnyPair.id

与DynAny关联的名称。

String

NameValuePair.id

与Any相关联的名称。

Methods in org.omg.DynamicAny that return String

Modifier and Type

方法

描述

String[]

_DynAnyFactoryStub._ids​()

String[]

_DynAnyStub._ids​()

String[]

_DynArrayStub._ids​()

String[]

_DynEnumStub._ids​()

String[]

_DynFixedStub._ids​()

String[]

_DynSequenceStub._ids​()

String[]

_DynStructStub._ids​()

String[]

_DynUnionStub._ids​()

String[]

_DynValueStub._ids​()

String

_DynStructStub.current_member_name​()

返回当前位置的成员名称。

String

_DynValueStub.current_member_name​()

返回当前位置的成员名称。

String

DynStructOperations.current_member_name​()

返回当前位置的成员名称。

String

DynValueOperations.current_member_name​()

返回当前位置的成员名称。

static String

FieldNameHelper.extract​(Any a)

String

_DynEnumStub.get_as_string​()

将DynEnum的值作为IDL标识符返回。

String

DynEnumOperations.get_as_string​()

将DynEnum的值作为IDL标识符返回。

String

_DynAnyStub.get_string​()

从此DynAny中提取字符串值。

String

_DynArrayStub.get_string​()

从此DynAny中提取字符串值。

String

_DynEnumStub.get_string​()

从此DynAny中提取字符串值。

String

_DynFixedStub.get_string​()

从此DynAny中提取字符串值。

String

_DynSequenceStub.get_string​()

从此DynAny中提取字符串值。

String

_DynStructStub.get_string​()

从此DynAny中提取字符串值。

String

_DynUnionStub.get_string​()

从此DynAny中提取字符串值。

String

_DynValueStub.get_string​()

从此DynAny中提取字符串值。

String

DynAnyOperations.get_string​()

从此DynAny中提取字符串值。

String

_DynFixedStub.get_value​()

返回DynFixed的值。

String

DynFixedOperations.get_value​()

返回DynFixed的值。

String

_DynAnyStub.get_wstring​()

从此DynAny中提取字符串值。

String

_DynArrayStub.get_wstring​()

从此DynAny中提取字符串值。

String

_DynEnumStub.get_wstring​()

从此DynAny中提取字符串值。

String

_DynFixedStub.get_wstring​()

从此DynAny中提取字符串值。

String

_DynSequenceStub.get_wstring​()

从此DynAny中提取字符串值。

String

_DynStructStub.get_wstring​()

从此DynAny中提取字符串值。

String

_DynUnionStub.get_wstring​()

从此DynAny中提取字符串值。

String

_DynValueStub.get_wstring​()

从此DynAny中提取字符串值。

String

DynAnyOperations.get_wstring​()

从此DynAny中提取字符串值。

static String

AnySeqHelper.id​()

static String

DynAnyFactoryHelper.id​()

static String

DynAnyHelper.id​()

static String

DynAnySeqHelper.id​()

static String

DynArrayHelper.id​()

static String

DynEnumHelper.id​()

static String

DynFixedHelper.id​()

static String

DynSequenceHelper.id​()

static String

DynStructHelper.id​()

static String

DynUnionHelper.id​()

static String

DynValueHelper.id​()

static String

FieldNameHelper.id​()

static String

NameDynAnyPairHelper.id​()

static String

NameDynAnyPairSeqHelper.id​()

static String

NameValuePairHelper.id​()

static String

NameValuePairSeqHelper.id​()

String

_DynUnionStub.member_name​()

返回当前活动成员的名称。

String

DynUnionOperations.member_name​()

返回当前活动成员的名称。

static String

FieldNameHelper.read​(InputStream istream)

Methods in org.omg.DynamicAny with parameters of type String

Modifier and Type

方法

描述

static void

FieldNameHelper.insert​(Any a, String that)

void

_DynAnyStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynArrayStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynEnumStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynFixedStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynSequenceStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynStructStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynUnionStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynValueStub.insert_string​(String value)

在DynAny中插入一个字符串值。

void

DynAnyOperations.insert_string​(String value)

在DynAny中插入一个字符串值。

void

_DynAnyStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynArrayStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynEnumStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynFixedStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynSequenceStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynStructStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynUnionStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynValueStub.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

DynAnyOperations.insert_wstring​(String value)

在DynAny中插入一个字符串值。

void

_DynEnumStub.set_as_string​(String value)

将DynEnum的值设置为在值参数中传递IDL标识符的枚举值。

void

DynEnumOperations.set_as_string​(String value)

将DynEnum的值设置为在值参数中传递IDL标识符的枚举值。

boolean

_DynFixedStub.set_value​(String val)

设置DynFixed的值。

boolean

DynFixedOperations.set_value​(String val)

设置DynFixed的值。

static void

FieldNameHelper.write​(OutputStream ostream, String value)

Constructors in org.omg.DynamicAny with parameters of type String

Constructor

描述

NameDynAnyPair​(String _id, DynAny _value)

NameValuePair​(String _id, Any _value)

Uses of String in org.omg.DynamicAny.DynAnyFactoryPackage

Methods in org.omg.DynamicAny.DynAnyFactoryPackage that return String

Modifier and Type

方法

描述

static String

InconsistentTypeCodeHelper.id​()

Constructors in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type String

Constructor

描述

InconsistentTypeCode​(String $reason)

Uses of String in org.omg.DynamicAny.DynAnyPackage

Methods in org.omg.DynamicAny.DynAnyPackage that return String

Modifier and Type

方法

描述

static String

InvalidValueHelper.id​()

static String

TypeMismatchHelper.id​()

Constructors in org.omg.DynamicAny.DynAnyPackage with parameters of type String

Constructor

描述

InvalidValue​(String $reason)

TypeMismatch​(String $reason)

Uses of String in org.omg.IOP

Fields in org.omg.IOP declared as String

Modifier and Type

Field

描述

String

IOR.type_id

类型id，表示为字符串。

Methods in org.omg.IOP that return String

Modifier and Type

方法

描述

static String

CodecFactoryHelper.id​()

static String

ComponentIdHelper.id​()

static String

IORHelper.id​()

static String

MultipleComponentProfileHelper.id​()

static String

ProfileIdHelper.id​()

static String

ServiceContextHelper.id​()

static String

ServiceContextListHelper.id​()

static String

ServiceIdHelper.id​()

static String

TaggedComponentHelper.id​()

static String

TaggedProfileHelper.id​()

Constructors in org.omg.IOP with parameters of type String

Constructor

描述

IOR​(String _type_id, TaggedProfile[] _profiles)

Uses of String in org.omg.IOP.CodecFactoryPackage

Methods in org.omg.IOP.CodecFactoryPackage that return String

Modifier and Type

方法

描述

static String

UnknownEncodingHelper.id​()

Constructors in org.omg.IOP.CodecFactoryPackage with parameters of type String

Constructor

描述

UnknownEncoding​(String $reason)

Uses of String in org.omg.IOP.CodecPackage

Methods in org.omg.IOP.CodecPackage that return String

Modifier and Type

方法

描述

static String

FormatMismatchHelper.id​()

static String

InvalidTypeForEncodingHelper.id​()

static String

TypeMismatchHelper.id​()

Constructors in org.omg.IOP.CodecPackage with parameters of type String

Constructor

描述

FormatMismatch​(String $reason)

InvalidTypeForEncoding​(String $reason)

TypeMismatch​(String $reason)

Uses of String in org.omg.Messaging

Methods in org.omg.Messaging that return String

Modifier and Type

方法

描述

static String

SyncScopeHelper.id​()

Uses of String in org.omg.PortableInterceptor

Methods in org.omg.PortableInterceptor that return String

Modifier and Type

方法

描述

String[]

ObjectReferenceTemplate.adapter_name​()

String[]

ServerRequestInfoOperations.adapter_name​()

返回标识正在处理此请求的对象适配器实例的字符串序列。

String[]

ORBInitInfoOperations.arguments​()

返回传递给 ORB.init的参数。

String[]

RequestInfoOperations.contexts​()

返回描述可以在此操作调用中传递的上下文的 String对象的数组。

static String[]

AdapterNameHelper.extract​(Any a)

static String

ORBIdHelper.extract​(Any a)

static String

ServerIdHelper.extract​(Any a)

static String

AdapterManagerIdHelper.id​()

static String

AdapterNameHelper.id​()

static String

AdapterStateHelper.id​()

static String

CurrentHelper.id​()

static String

ForwardRequestHelper.id​()

static String

InvalidSlotHelper.id​()

static String

IORInterceptor_3_0Helper.id​()

static String

ObjectIdHelper.id​()

static String

ObjectReferenceFactoryHelper.id​()

static String

ObjectReferenceTemplateHelper.id​()

static String

ObjectReferenceTemplateSeqHelper.id​()

static String

ORBIdHelper.id​()

static String

ServerIdHelper.id​()

String

InterceptorOperations.name​()

返回拦截器的名称。

String

RequestInfoOperations.operation​()

返回被调用的操作的名称。

String[]

RequestInfoOperations.operation_context​()

返回一个 String对象的数组，包含在请求中发送的上下文。

String

ObjectReferenceTemplate.orb_id​()

String

ORBInitInfoOperations.orb_id​()

返回正在初始化的ORB的ID。

String

ServerRequestInfoOperations.orb_id​()

返回用于创建ORB的ID。

static String[]

AdapterNameHelper.read​(InputStream istream)

static String

ORBIdHelper.read​(InputStream istream)

static String

ServerIdHelper.read​(InputStream istream)

String

ClientRequestInfoOperations.received_exception_id​()

返回要返回给客户端的异常的存储库ID。

String

ObjectReferenceTemplate.server_id​()

String

ServerRequestInfoOperations.server_id​()

返回使用-ORBServerId参数在ORB :: init上指定的服务器ID。

String

ServerRequestInfoOperations.target_most_derived_interface​()

返回servant最传导接口的存储库ID。

Methods in org.omg.PortableInterceptor with parameters of type String

Modifier and Type

方法

描述

static void

AdapterNameHelper.insert​(Any a, String[] that)

static void

ORBIdHelper.insert​(Any a, String that)

static void

ServerIdHelper.insert​(Any a, String that)

Object

ObjectReferenceFactory.make_object​(String repositoryId, byte[] object_id)

make_object根据此模板中的数据，使用给定的存储库ID和对象ID创建CORBA对象引用。

void

ORBInitInfoOperations.register_initial_reference​(String id, Object obj)

与 ORB.register_initial_reference相同。

Object

ORBInitInfoOperations.resolve_initial_references​(String id)

与 ORB.resolve_initial_references相同。

boolean

ServerRequestInfoOperations.target_is_a​(String id)

如果servant是给定的存储库id，则返回true，否则返回false。

static void

AdapterNameHelper.write​(OutputStream ostream, String[] value)

static void

ORBIdHelper.write​(OutputStream ostream, String value)

static void

ServerIdHelper.write​(OutputStream ostream, String value)

Constructors in org.omg.PortableInterceptor with parameters of type String

Constructor

描述

ForwardRequest​(String $reason, Object _forward)

InvalidSlot​(String $reason)

Uses of String in org.omg.PortableInterceptor.ORBInitInfoPackage

Fields in org.omg.PortableInterceptor.ORBInitInfoPackage declared as String

Modifier and Type

Field

描述

String

DuplicateName.name

已经有一个拦截器的名字已经注册了。

Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return String

Modifier and Type

方法

描述

static String

ObjectIdHelper.extract​(Any a)

static String

DuplicateNameHelper.id​()

static String

InvalidNameHelper.id​()

static String

ObjectIdHelper.id​()

static String

ObjectIdHelper.read​(InputStream istream)

Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type String

Modifier and Type

方法

描述

static void

ObjectIdHelper.insert​(Any a, String that)

static void

ObjectIdHelper.write​(OutputStream ostream, String value)

Constructors in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type String

Constructor

描述

DuplicateName​(String _name)

DuplicateName​(String $reason, String _name)

InvalidName​(String $reason)

Uses of String in org.omg.PortableServer

Methods in org.omg.PortableServer that return String

Modifier and Type

方法

描述

abstract String[]

Servant._all_interfaces​(POA poa, byte[] objectId)

由ORB用于从仆人获取完整的类型信息。

String[]

ServantActivatorPOA._all_interfaces​(POA poa, byte[] objectId)

String[]

ServantLocatorPOA._all_interfaces​(POA poa, byte[] objectId)

String[]

_ServantActivatorStub._ids​()

String[]

_ServantLocatorStub._ids​()

static String

CurrentHelper.id​()

static String

ForwardRequestHelper.id​()

static String

POAHelper.id​()

static String

ServantActivatorHelper.id​()

static String

ServantLocatorHelper.id​()

String

POAOperations.the_name​()

此属性标识相对于其父项的POA。

Methods in org.omg.PortableServer with parameters of type String

Modifier and Type

方法

描述

OutputStream

ServantActivatorPOA._invoke​(String $method, InputStream in, ResponseHandler $rh)

OutputStream

ServantLocatorPOA._invoke​(String $method, InputStream in, ResponseHandler $rh)

boolean

Servant._is_a​(String repository_id)

检查是否指定 repository_id存在通过返回的列表上 _all_interfaces()或为 repository_id的通用CORBA对象。

POA

POAOperations.create_POA​(String adapter_name, POAManager a_POAManager, Policy[] policies)

此操作将创建一个新的POA作为目标POA的子代。

Object

POAOperations.create_reference​(String intf)

此操作创建一个对象引用，该引用封装了POA生成的对象标识值和指定的接口存储库标识。

Object

POAOperations.create_reference_with_id​(byte[] oid, String intf)

此操作创建一个对象引用，该引用封装了指定的对象标识和接口存储库标识值。

POA

POAOperations.find_POA​(String adapter_name, boolean activate_it)

如果目标POA是具有指定名称（相对于目标POA）的子级POA的父级，则返回该子级POA。

void

_ServantLocatorStub.postinvoke​(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)

在服务器完成请求时调用此操作。

void

ServantLocatorOperations.postinvoke​(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)

在服务器完成请求时调用此操作。

Servant

_ServantLocatorStub.preinvoke​(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)

此操作用于获取将用于处理引起preinvoke调用的请求的servant。

Servant

ServantLocatorOperations.preinvoke​(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)

此操作用于获取将用于处理引起preinvoke调用的请求的servant。

boolean

AdapterActivatorOperations.unknown_adapter​(POA parent, String name)

当ORB接收到用于标识不存在的目标POA的对象引用的请求时，调用此操作。

Constructors in org.omg.PortableServer with parameters of type String

Constructor

描述

ForwardRequest​(String $reason, Object _forward_reference)

Uses of String in org.omg.PortableServer.CurrentPackage

Methods in org.omg.PortableServer.CurrentPackage that return String

Modifier and Type

方法

描述

static String

NoContextHelper.id​()

Constructors in org.omg.PortableServer.CurrentPackage with parameters of type String

Constructor

描述

NoContext​(String $reason)

Uses of String in org.omg.PortableServer.POAManagerPackage

Methods in org.omg.PortableServer.POAManagerPackage that return String

Modifier and Type

方法

描述

static String

AdapterInactiveHelper.id​()

Constructors in org.omg.PortableServer.POAManagerPackage with parameters of type String

Constructor

描述

AdapterInactive​(String $reason)

Uses of String in org.omg.PortableServer.POAPackage

Methods in org.omg.PortableServer.POAPackage that return String

Modifier and Type

方法

描述

static String

AdapterAlreadyExistsHelper.id​()

static String

AdapterNonExistentHelper.id​()

static String

InvalidPolicyHelper.id​()

static String

NoServantHelper.id​()

static String

ObjectAlreadyActiveHelper.id​()

static String

ObjectNotActiveHelper.id​()

static String

ServantAlreadyActiveHelper.id​()

static String

ServantNotActiveHelper.id​()

static String

WrongAdapterHelper.id​()

static String

WrongPolicyHelper.id​()

Constructors in org.omg.PortableServer.POAPackage with parameters of type String

Constructor

描述

AdapterAlreadyExists​(String $reason)

AdapterNonExistent​(String $reason)

InvalidPolicy​(String $reason, short _index)

NoServant​(String $reason)

ObjectAlreadyActive​(String $reason)

ObjectNotActive​(String $reason)

ServantAlreadyActive​(String $reason)

ServantNotActive​(String $reason)

WrongAdapter​(String $reason)

WrongPolicy​(String $reason)

Uses of String in org.omg.PortableServer.portable

Methods in org.omg.PortableServer.portable with parameters of type String

Modifier and Type

方法

描述

boolean

Delegate.is_a​(Servant Self, String Repository_Id)

此方法检查_all_interfaces（）返回的列表中是否存在指定的repid，或者是通用CORBA对象的存储库标识。

Uses of String in org.omg.stub.java.rmi

Methods in org.omg.stub.java.rmi that return String

Modifier and Type

方法

描述

String[]

_Remote_Stub._ids​()

返回对象实现的存储库ID数组。

Uses of String in org.w3c.dom

Methods in org.w3c.dom that return String

Modifier and Type

方法

描述

String

Element.getAttribute​(String name)

按名称检索属性值。

String

Element.getAttributeNS​(String namespaceURI, String localName)

通过本地名称和命名空间URI检索属性值。

String

Node.getBaseURI​()

该节点的绝对基本URI或 null如果实现无法获取绝对URI。

String

CharacterData.getData​()

实现此接口的节点的字符数据。

String

ProcessingInstruction.getData​()

该处理指令的内容。

String

Document.getDocumentURI​()

文件的位置或 null如果未定义）或 Document是使用 DOMImplementation.createDocument创建的。

String

Document.getInputEncoding​()

指定在解析时用于此文档的编码的属性。

String

Entity.getInputEncoding​()

指定在解析时用于该实体的编码的属性，当它是外部解析实体时。

String

DocumentType.getInternalSubset​()

内部子集为字符串，如果没有， null 。

String

Node.getLocalName​()

返回此节点的限定名称的本地部分。

String

DOMError.getMessage​()

描述发生错误的实现特定字符串。

String

Attr.getName​()

返回此属性的名称。

String

DocumentType.getName​()

DTD的名称 即紧随DOCTYPE关键字后的名称。

String

NameList.getName​(int index)

返回集合中的 index th名称项。

String

NameList.getNamespaceURI​(int index)

返回集合中的 index th namespaceURI项。

String

Node.getNamespaceURI​()

该节点的命名空间URI，如果未指定， null （请参阅）。

String

Node.getNodeName​()

该节点的名称取决于其类型; 见上表。

String

Node.getNodeValue​()

该节点的值取决于其类型; 见上表。

String

Entity.getNotationName​()

对于未解析的实体，该实体的符号的名称。

String

Node.getPrefix​()

该节点的命名空间前缀，如果未指定， null 。

String

DocumentType.getPublicId​()

外部子集的公共标识符。

String

Entity.getPublicId​()

与实体相关联的公共标识符，如果指定， null 。

String

Notation.getPublicId​()

这个符号的公共标识符。

String

DocumentType.getSystemId​()

外部子集的系统标识符。

String

Entity.getSystemId​()

如果指定了与实体关联的系统标识符，否则为 null 。

String

Notation.getSystemId​()

该符号的系统标识符。

String

Element.getTagName​()

元素的名称。

String

ProcessingInstruction.getTarget​()

该处理指令的目标。

String

Node.getTextContent​()

此属性返回此节点及其后代的文本内容。

String

DOMError.getType​()

A DOMString指出在 relatedData预期哪些相关数据。

String

TypeInfo.getTypeName​()

为关联的元素或属性声明的类型的名称，如果未知， null 。

String

TypeInfo.getTypeNamespace​()

如果元素没有声明或没有命名空间信息可用， null相关元素或属性声明的类型的名称空间或 null 。

String

DOMLocator.getUri​()

该定位器指向的URI，如果没有URI可用， null 。

String

Attr.getValue​()

在检索时，属性的值作为字符串返回。

String

Text.getWholeText​()

返回所有文本的 Text节点逻辑相邻文本节点到此节点，以文档顺序连接。

String

Document.getXmlEncoding​()

作为 XML declaration的一部分的属性，指定此文档的编码。

String

Entity.getXmlEncoding​()

作为文本声明的一部分的属性，指定该实体的编码，当它是外部解析实体时。

String

Document.getXmlVersion​()

作为 XML declaration的一部分的属性，指定此文档的版本号。

String

Entity.getXmlVersion​()

作为文本声明的一部分的属性，当作为外部解析实体时，指定该实体的版本号。

String

DOMStringList.item​(int index)

返回集合中的 index项。

String

Node.lookupNamespaceURI​(String prefix)

从该节点开始，查找与给定前缀相关联的命名空间URI。

String

Node.lookupPrefix​(String namespaceURI)

从该节点开始查找与给定名称空间URI关联的前缀。

String

CharacterData.substringData​(int offset, int count)

从节点中提取一系列数据。

Methods in org.w3c.dom with parameters of type String

Modifier and Type

方法

描述

void

CharacterData.appendData​(String arg)

将字符串附加到节点的字符数据的末尾。

boolean

DOMConfiguration.canSetParameter​(String name, Object value)

检查是否将参数设置为特定值。

boolean

DOMStringList.contains​(String str)

测试一个字符串是否是这个 DOMStringList一部分。

boolean

NameList.contains​(String str)

测试一个名字是否是这个 NameList一部分。

boolean

NameList.containsNS​(String namespaceURI, String name)

测试对象namespaceURI / name是否是这个 NameList一部分。

Attr

Document.createAttribute​(String name)

创建给定名称的 Attr 。

Attr

Document.createAttributeNS​(String namespaceURI, String qualifiedName)

创建给定的限定名称和命名空间URI的属性。

CDATASection

Document.createCDATASection​(String data)

创建一个值为指定字符串的 CDATASection节点。

Comment

Document.createComment​(String data)

创建给定指定字符串的 Comment节点。

Document

DOMImplementation.createDocument​(String namespaceURI, String qualifiedName, DocumentType doctype)

使用其文档元素创建指定类型的DOM文档对象。

DocumentType

DOMImplementation.createDocumentType​(String qualifiedName, String publicId, String systemId)

创建一个空的 DocumentType节点。

Element

Document.createElement​(String tagName)

创建指定类型的元素。

Element

Document.createElementNS​(String namespaceURI, String qualifiedName)

创建给定限定名称和命名空间URI的元素。

EntityReference

Document.createEntityReference​(String name)

创建一个 EntityReference对象。

ProcessingInstruction

Document.createProcessingInstruction​(String target, String data)

创建指定名称和数据字符串的 ProcessingInstruction节点。

Text

Document.createTextNode​(String data)

创建给定指定字符串的 Text节点。

String

Element.getAttribute​(String name)

按名称检索属性值。

Attr

Element.getAttributeNode​(String name)

按名称检索属性节点。

Attr

Element.getAttributeNodeNS​(String namespaceURI, String localName)

通过本地名称和命名空间URI检索 Attr节点。

String

Element.getAttributeNS​(String namespaceURI, String localName)

通过本地名称和命名空间URI检索属性值。

DOMImplementation

DOMImplementationSource.getDOMImplementation​(String features)

一种请求支持指定功能的第一个DOM实现的方法。

DOMImplementationList

DOMImplementationSource.getDOMImplementationList​(String features)

一种方法来请求支持指定特征和版本的DOM实现的列表，如

Element

Document.getElementById​(String elementId)

返回具有给定值的ID属性的 Element 。

NodeList

Document.getElementsByTagName​(String tagname)

返回 NodeList所有的 Elements文档顺序与给定的标签名称，包含在文档中。

NodeList

Element.getElementsByTagName​(String name)

返回 NodeList所有子孙的 Elements具有给定标记名称，在文档顺序。

NodeList

Document.getElementsByTagNameNS​(String namespaceURI, String localName)

返回 NodeList的所有 Elements具有给定本地名称和命名空间URI在文档顺序。

NodeList

Element.getElementsByTagNameNS​(String namespaceURI, String localName)

返回 NodeList所有后代的 Elements具有给定本地名称和命名空间URI在文档顺序。

Object

DOMImplementation.getFeature​(String feature, String version)

此方法返回一个专门的对象，该对象实现了特定功能和版本的专用API，如 DOM Features中所述 。

Object

Node.getFeature​(String feature, String version)

该方法返回一个专门的对象，该对象实现指定的特征和版本的专门API，如

Node

NamedNodeMap.getNamedItem​(String name)

检索由name指定的节点。

Node

NamedNodeMap.getNamedItemNS​(String namespaceURI, String localName)

检索由本地名称和命名空间URI指定的节点。

Object

DOMConfiguration.getParameter​(String name)

如果已知，返回参数的值。

Object

Node.getUserData​(String key)

检索与该节点上的键相关联的对象。

void

UserDataHandler.handle​(short operation, String key, Object data, Node src, Node dst)

每当注册此处理程序的节点被导入或克隆时，都会调用此方法。

boolean

Element.hasAttribute​(String name)

返回 true在此元素上被指定给定名称的属性或具有默认值， false否则。

boolean

Element.hasAttributeNS​(String namespaceURI, String localName)

返回 true在此元素上被指定或具有默认值，与给定的本地名称和命名空间的属性URI false否则。

boolean

DOMImplementation.hasFeature​(String feature, String version)

测试DOM实现是否实现了特定功能和版本，如 DOM Features中所述 。

void

CharacterData.insertData​(int offset, String arg)

以指定的16位单位偏移量插入字符串。

boolean

Node.isDefaultNamespace​(String namespaceURI)

此方法检查指定的 namespaceURI是否为默认命名空间。

boolean

TypeInfo.isDerivedFrom​(String typeNamespaceArg, String typeNameArg, int derivationMethod)

如果引用类型定义之间有一个派生，即 TypeInfo该方法的 TypeInfo和另一个类型定义（即作为参数传递的定义）之间的派生，则返回此方法。

boolean

Node.isSupported​(String feature, String version)

测试DOM实现是否实现特定功能，并且此节点支持该功能，如下所述。

String

Node.lookupNamespaceURI​(String prefix)

从该节点开始，查找与给定前缀相关联的命名空间URI。

String

Node.lookupPrefix​(String namespaceURI)

从该节点开始查找与给定名称空间URI关联的前缀。

void

Element.removeAttribute​(String name)

按名称删除属性。

void

Element.removeAttributeNS​(String namespaceURI, String localName)

通过本地名称和命名空间URI删除属性。

Node

NamedNodeMap.removeNamedItem​(String name)

删除由name指定的节点。

Node

NamedNodeMap.removeNamedItemNS​(String namespaceURI, String localName)

删除由本地名称和命名空间URI指定的节点。

Node

Document.renameNode​(Node n, String namespaceURI, String qualifiedName)

重命名 ELEMENT_NODE或 ATTRIBUTE_NODE的现有节点。

void

CharacterData.replaceData​(int offset, int count, String arg)

用指定的字符串替换从指定的16位单位偏移开始的字符。

Text

Text.replaceWholeText​(String content)

用指定的文本替换当前节点和所有逻辑上相邻的文本节点的文本。

void

Element.setAttribute​(String name, String value)

添加一个新属性。

void

Element.setAttributeNS​(String namespaceURI, String qualifiedName, String value)

添加一个新属性。

void

CharacterData.setData​(String data)

实现此接口的节点的字符数据。

void

ProcessingInstruction.setData​(String data)

该处理指令的内容。

void

Document.setDocumentURI​(String documentURI)

文件的位置或 null如果未定义，或者如果 Document是使用 DOMImplementation.createDocument创建的。

void

Element.setIdAttribute​(String name, boolean isId)

如果参数 isId为 true ，则此方法将指定的属性声明为用户确定的ID属性。

void

Element.setIdAttributeNS​(String namespaceURI, String localName, boolean isId)

如果参数 isId为 true ，则此方法将指定的属性声明为用户确定的ID属性。

void

Node.setNodeValue​(String nodeValue)

该节点的值取决于其类型; 见上表。

void

DOMConfiguration.setParameter​(String name, Object value)

设置参数的值。

void

Node.setPrefix​(String prefix)

该节点的命名空间前缀，如果未指定， null 。

void

Node.setTextContent​(String textContent)

此属性返回此节点及其后代的文本内容。

Object

Node.setUserData​(String key, Object data, UserDataHandler handler)

将对象与此节点上的键相关联。

void

Attr.setValue​(String value)

在检索时，属性的值作为字符串返回。

void

Document.setXmlVersion​(String xmlVersion)

作为 XML declaration的一部分的属性，指定此文档的版本号。

Constructors in org.w3c.dom with parameters of type String

Constructor

描述

DOMException​(short code, String message)

Uses of String in org.w3c.dom.bootstrap

Fields in org.w3c.dom.bootstrap declared as String

Modifier and Type

Field

描述

static String

DOMImplementationRegistry.PROPERTY

系统属性指定DOMImplementationSource类名。

Methods in org.w3c.dom.bootstrap with parameters of type String

Modifier and Type

方法

描述

DOMImplementation

DOMImplementationRegistry.getDOMImplementation​(String features)

返回具有所需功能的第一个实现，如果没有找到，则返回 null 。

DOMImplementationList

DOMImplementationRegistry.getDOMImplementationList​(String features)

返回支持所需功能的实现列表。

Uses of String in org.w3c.dom.css

Methods in org.w3c.dom.css that return String

Modifier and Type

方法

描述

String

CSS2Properties.getAzimuth​()

请参阅CSS2中的方位属性定义。

String

CSS2Properties.getBackground​()

请参阅CSS2中的background属性定义。

String

CSS2Properties.getBackgroundAttachment​()

请参阅CSS2中的background-attachment属性定义。

String

CSS2Properties.getBackgroundColor​()

请参阅CSS2中的background-color属性定义。

String

CSS2Properties.getBackgroundImage​()

请参阅CSS2中的background-image属性定义。

String

CSS2Properties.getBackgroundPosition​()

请参阅CSS2中的background-position属性定义。

String

CSS2Properties.getBackgroundRepeat​()

请参阅CSS2中的background-repeat属性定义。

String

CSS2Properties.getBorder​()

请参阅CSS2中的border属性定义。

String

CSS2Properties.getBorderBottom​()

请参阅CSS2中的border-bottom属性定义。

String

CSS2Properties.getBorderBottomColor​()

请参阅CSS2中的border-bottom-color属性定义。

String

CSS2Properties.getBorderBottomStyle​()

请参阅CSS2中的border-bottom-style属性定义。

String

CSS2Properties.getBorderBottomWidth​()

请参阅CSS2中的border-bottom-width属性定义。

String

CSS2Properties.getBorderCollapse​()

请参阅CSS2中的border-collapse属性定义。

String

CSS2Properties.getBorderColor​()

请参阅CSS2中的border-color属性定义。

String

CSS2Properties.getBorderLeft​()

请参阅CSS2中的border-left属性定义。

String

CSS2Properties.getBorderLeftColor​()

请参阅CSS2中的border-left-color属性定义。

String

CSS2Properties.getBorderLeftStyle​()

请参阅CSS2中的border-left-style属性定义。

String

CSS2Properties.getBorderLeftWidth​()

请参阅CSS2中的border-left-width属性定义。

String

CSS2Properties.getBorderRight​()

请参阅CSS2中的border-right属性定义。

String

CSS2Properties.getBorderRightColor​()

请参阅CSS2中的border-right-color属性定义。

String

CSS2Properties.getBorderRightStyle​()

请参阅CSS2中的border-right-style属性定义。

String

CSS2Properties.getBorderRightWidth​()

请参阅CSS2中的border-right-width属性定义。

String

CSS2Properties.getBorderSpacing​()

请参阅CSS2中的border-spacing属性定义。

String

CSS2Properties.getBorderStyle​()

请参阅CSS2中的border-style属性定义。

String

CSS2Properties.getBorderTop​()

请参阅CSS2中的border-top属性定义。

String

CSS2Properties.getBorderTopColor​()

请参阅CSS2中的border-top-color属性定义。

String

CSS2Properties.getBorderTopStyle​()

请参阅CSS2中的border-top-style属性定义。

String

CSS2Properties.getBorderTopWidth​()

请参阅CSS2中的border-top-width属性定义。

String

CSS2Properties.getBorderWidth​()

请参阅CSS2中的border-width属性定义。

String

CSS2Properties.getBottom​()

请参阅CSS2中的底层属性定义。

String

CSS2Properties.getCaptionSide​()

请参阅CSS2中的标题侧属性定义。

String

CSS2Properties.getClear​()

请参阅CSS2中的清除属性定义。

String

CSS2Properties.getClip​()

请参阅CSS2中的剪辑属性定义。

String

CSS2Properties.getColor​()

请参阅CSS2中的颜色属性定义。

String

CSS2Properties.getContent​()

请参阅CSS2中的content属性定义。

String

CSS2Properties.getCounterIncrement​()

请参阅CSS2中的counter-increment属性定义。

String

CSS2Properties.getCounterReset​()

请参阅CSS2中的counter-reset属性定义。

String

CSS2Properties.getCssFloat​()

请参阅CSS2中的float属性定义。

String

CSSRule.getCssText​()

规则的可理解的文本表示。

String

CSSStyleDeclaration.getCssText​()

声明块的可解释文本表示（不包括周围的花括号）。

String

CSSValue.getCssText​()

当前值的字符串表示形式。

String

CSS2Properties.getCue​()

请参阅CSS2中的cue属性定义。

String

CSS2Properties.getCueAfter​()

请参阅CSS2中的cue-after属性定义。

String

CSS2Properties.getCueBefore​()

请参阅CSS2中的cue-before属性定义。

String

CSS2Properties.getCursor​()

请参阅CSS2中的cursor属性定义。

String

CSS2Properties.getDirection​()

请参阅CSS2中的方向属性定义。

String

CSS2Properties.getDisplay​()

请参阅CSS2中的显示属性定义。

String

CSS2Properties.getElevation​()

请参阅CSS2中的elevation属性定义。

String

CSS2Properties.getEmptyCells​()

请参阅CSS2中的empty-cells属性定义。

String

CSSCharsetRule.getEncoding​()

这个 @charset规则中使用的编码信息。

String

CSS2Properties.getFont​()

请参阅CSS2中的font属性定义。

String

CSS2Properties.getFontFamily​()

请参阅CSS2中的font-family属性定义。

String

CSS2Properties.getFontSize​()

请参阅CSS2中的font-size属性定义。

String

CSS2Properties.getFontSizeAdjust​()

请参阅CSS2中的font-size-adjust属性定义。

String

CSS2Properties.getFontStretch​()

请参阅CSS2中的font-stretch属性定义。

String

CSS2Properties.getFontStyle​()

请参阅CSS2中的font-style属性定义。

String

CSS2Properties.getFontVariant​()

请参阅CSS2中的font-variant属性定义。

String

CSS2Properties.getFontWeight​()

请参阅CSS2中的font-weight属性定义。

String

CSS2Properties.getHeight​()

请参阅CSS2中的height属性定义。

String

CSSImportRule.getHref​()

要导入的样式表的位置。

String

Counter.getIdentifier​()

该属性用于计数器的标识符。

String

CSS2Properties.getLeft​()

请参阅CSS2中的左侧属性定义。

String

CSS2Properties.getLetterSpacing​()

请参阅CSS2中的letter-spacing属性定义。

String

CSS2Properties.getLineHeight​()

请参阅CSS2中的line-height属性定义。

String

Counter.getListStyle​()

该属性用于列表的样式。

String

CSS2Properties.getListStyle​()

请参阅CSS2中的list-style属性定义。

String

CSS2Properties.getListStyleImage​()

请参阅CSS2中的list-style-image属性定义。

String

CSS2Properties.getListStylePosition​()

请参阅CSS2中的list-style-position属性定义。

String

CSS2Properties.getListStyleType​()

请参阅CSS2中的list-style-type属性定义。

String

CSS2Properties.getMargin​()

请参阅CSS2中的margin属性定义。

String

CSS2Properties.getMarginBottom​()

请参阅CSS2中的margin-bottom属性定义。

String

CSS2Properties.getMarginLeft​()

请参阅CSS2中的margin-left属性定义。

String

CSS2Properties.getMarginRight​()

请参阅CSS2中的margin-right属性定义。

String

CSS2Properties.getMarginTop​()

请参阅CSS2中的margin-top属性定义。

String

CSS2Properties.getMarkerOffset​()

请参阅CSS2中的marker-offset属性定义。

String

CSS2Properties.getMarks​()

请参阅CSS2中的标记属性定义。

String

CSS2Properties.getMaxHeight​()

请参阅CSS2中的max-height属性定义。

String

CSS2Properties.getMaxWidth​()

请参阅CSS2中的max-width属性定义。

String

CSS2Properties.getMinHeight​()

请参阅CSS2中的min-height属性定义。

String

CSS2Properties.getMinWidth​()

请参阅CSS2中的min-width属性定义。

String

CSS2Properties.getOrphans​()

请参阅CSS2中的孤儿属性定义。

String

CSS2Properties.getOutline​()

请参阅CSS2中的大纲属性定义。

String

CSS2Properties.getOutlineColor​()

请参阅CSS2中的outline-color属性定义。

String

CSS2Properties.getOutlineStyle​()

请参阅CSS2中的outline-style属性定义。

String

CSS2Properties.getOutlineWidth​()

请参阅CSS2中的outline-width属性定义。

String

CSS2Properties.getOverflow​()

请参阅CSS2中的overflow属性定义。

String

CSS2Properties.getPadding​()

请参阅CSS2中的padding属性定义。

String

CSS2Properties.getPaddingBottom​()

请参阅CSS2中的padding-bottom属性定义。

String

CSS2Properties.getPaddingLeft​()

请参阅CSS2中的padding-left属性定义。

String

CSS2Properties.getPaddingRight​()

请参阅CSS2中的padding-right属性定义。

String

CSS2Properties.getPaddingTop​()

请参阅CSS2中的padding-top属性定义。

String

CSS2Properties.getPage​()

请参阅CSS2中的页面属性定义。

String

CSS2Properties.getPageBreakAfter​()

请参阅CSS2中的page-break-after属性定义。

String

CSS2Properties.getPageBreakBefore​()

请参阅CSS2中的page-break-before属性定义。

String

CSS2Properties.getPageBreakInside​()

请参阅CSS2中的page-break-inside属性定义。

String

CSS2Properties.getPause​()

请参阅CSS2中的pause属性定义。

String

CSS2Properties.getPauseAfter​()

请参阅CSS2中的pause-after属性定义。

String

CSS2Properties.getPauseBefore​()

请参阅CSS2中的pause-before属性定义。

String

CSS2Properties.getPitch​()

请参阅CSS2中的音高属性定义。

String

CSS2Properties.getPitchRange​()

请参阅CSS2中的音高范围属性定义。

String

CSS2Properties.getPlayDuring​()

请参阅CSS2中的play-during属性定义。

String

CSS2Properties.getPosition​()

请参阅CSS2中的position属性定义。

String

CSSStyleDeclaration.getPropertyPriority​(String propertyName)

如果在该声明块中已经明确设置了优先级，则用于检索CSS属性的优先级（例如， "important"限定符）。

String

CSSStyleDeclaration.getPropertyValue​(String propertyName)

用于检索CSS属性的值（如果在该声明块中已经显式设置）。

String

CSS2Properties.getQuotes​()

请参阅CSS2中的引号属性定义。

String

CSS2Properties.getRichness​()

请参阅CSS2中的richness属性定义。

String

CSS2Properties.getRight​()

请参阅CSS2中的正确的属性定义。

String

CSSPageRule.getSelectorText​()

规则的页面选择器的可解析文本表示。

String

CSSStyleRule.getSelectorText​()

规则集的选择器的文本表示。

String

Counter.getSeparator​()

该属性用于嵌套计数器的分隔符。

String

CSS2Properties.getSize​()

请参阅CSS2中的size属性定义。

String

CSS2Properties.getSpeak​()

请参阅CSS2中的说话属性定义。

String

CSS2Properties.getSpeakHeader​()

请参阅CSS2中的speak-header属性定义。

String

CSS2Properties.getSpeakNumeral​()

请参阅CSS2中的speak-numbers属性定义。

String

CSS2Properties.getSpeakPunctuation​()

请参阅CSS2中的说话标点属性定义。

String

CSS2Properties.getSpeechRate​()

请参阅CSS2中的语速率属性定义。

String

CSS2Properties.getStress​()

请参阅CSS2中的stress属性定义。

String

CSSPrimitiveValue.getStringValue​()

此方法用于获取字符串值。

String

CSS2Properties.getTableLayout​()

请参阅CSS2中的table-layout属性定义。

String

CSS2Properties.getTextAlign​()

请参阅CSS2中的text-align属性定义。

String

CSS2Properties.getTextDecoration​()

请参阅CSS2中的text-decoration属性定义。

String

CSS2Properties.getTextIndent​()

请参阅CSS2中的text-indent属性定义。

String

CSS2Properties.getTextShadow​()

请参阅CSS2中的text-shadow属性定义。

String

CSS2Properties.getTextTransform​()

请参阅CSS2中的text-transform属性定义。

String

CSS2Properties.getTop​()

请参阅CSS2中的顶层属性定义。

String

CSS2Properties.getUnicodeBidi​()

请参阅CSS2中的unicode-bidi属性定义。

String

CSS2Properties.getVerticalAlign​()

请参阅CSS2中的vertical-align属性定义。

String

CSS2Properties.getVisibility​()

请参阅CSS2中的visibility属性定义。

String

CSS2Properties.getVoiceFamily​()

请参阅CSS2中的voice-family属性定义。

String

CSS2Properties.getVolume​()

请参阅CSS2中的卷属性定义。

String

CSS2Properties.getWhiteSpace​()

请参阅CSS2中的空格属性定义。

String

CSS2Properties.getWidows​()

请参阅CSS2中的widows属性定义。

String

CSS2Properties.getWidth​()

请参阅CSS2中的width属性定义。

String

CSS2Properties.getWordSpacing​()

请参阅CSS2中的word-spacing属性定义。

String

CSS2Properties.getZIndex​()

请参阅CSS2中的z-index属性定义。

String

CSSStyleDeclaration.item​(int index)

用于检索在此声明块中已显式设置的属性。

String

CSSStyleDeclaration.removeProperty​(String propertyName)

用于删除CSS属性（如果在该声明块中已经显式设置）。

Methods in org.w3c.dom.css with parameters of type String

Modifier and Type

方法

描述

CSSStyleSheet

DOMImplementationCSS.createCSSStyleSheet​(String title, String media)

创建一个新的 CSSStyleSheet 。

CSSStyleDeclaration

ViewCSS.getComputedStyle​(Element elt, String pseudoElt)

该方法用于获取[ CSS2 ]中定义的计算样式。

CSSStyleDeclaration

DocumentCSS.getOverrideStyle​(Element elt, String pseudoElt)

该方法用于检索指定元素和指定伪元素的覆盖样式声明。

CSSValue

CSSStyleDeclaration.getPropertyCSSValue​(String propertyName)

用于检索CSS属性值的对象表示，如果在该声明块中已经显式设置。

String

CSSStyleDeclaration.getPropertyPriority​(String propertyName)

用于检索CSS属性的优先级（如 "important"限定符），如果该声明块中已明确设置优先级。

String

CSSStyleDeclaration.getPropertyValue​(String propertyName)

用于检索CSS属性的值（如果在该声明块中已经显式设置）。

int

CSSMediaRule.insertRule​(String rule, int index)

用于在媒体块中插入新的规则。

int

CSSStyleSheet.insertRule​(String rule, int index)

用于在样式表中插入新规则。

String

CSSStyleDeclaration.removeProperty​(String propertyName)

用于删除CSS属性（如果在该声明块中已经显式设置）。

void

CSS2Properties.setAzimuth​(String azimuth)

请参阅CSS2中的方位属性定义。

void

CSS2Properties.setBackground​(String background)

请参阅CSS2中的background属性定义。

void

CSS2Properties.setBackgroundAttachment​(String backgroundAttachment)

请参阅CSS2中的background-attachment属性定义。

void

CSS2Properties.setBackgroundColor​(String backgroundColor)

请参阅CSS2中的background-color属性定义。

void

CSS2Properties.setBackgroundImage​(String backgroundImage)

请参阅CSS2中的background-image属性定义。

void

CSS2Properties.setBackgroundPosition​(String backgroundPosition)

请参阅CSS2中的background-position属性定义。

void

CSS2Properties.setBackgroundRepeat​(String backgroundRepeat)

请参阅CSS2中的background-repeat属性定义。

void

CSS2Properties.setBorder​(String border)

请参阅CSS2中的border属性定义。

void

CSS2Properties.setBorderBottom​(String borderBottom)

请参阅CSS2中的border-bottom属性定义。

void

CSS2Properties.setBorderBottomColor​(String borderBottomColor)

请参阅CSS2中的border-bottom-color属性定义。

void

CSS2Properties.setBorderBottomStyle​(String borderBottomStyle)

请参阅CSS2中的border-bottom-style属性定义。

void

CSS2Properties.setBorderBottomWidth​(String borderBottomWidth)

请参阅CSS2中的border-bottom-width属性定义。

void

CSS2Properties.setBorderCollapse​(String borderCollapse)

请参阅CSS2中的border-collapse属性定义。

void

CSS2Properties.setBorderColor​(String borderColor)

请参阅CSS2中的border-color属性定义。

void

CSS2Properties.setBorderLeft​(String borderLeft)

请参阅CSS2中的border-left属性定义。

void

CSS2Properties.setBorderLeftColor​(String borderLeftColor)

请参阅CSS2中的border-left-color属性定义。

void

CSS2Properties.setBorderLeftStyle​(String borderLeftStyle)

请参阅CSS2中的border-left-style属性定义。

void

CSS2Properties.setBorderLeftWidth​(String borderLeftWidth)

请参阅CSS2中的border-left-width属性定义。

void

CSS2Properties.setBorderRight​(String borderRight)

请参阅CSS2中的border-right属性定义。

void

CSS2Properties.setBorderRightColor​(String borderRightColor)

请参阅CSS2中的border-right-color属性定义。

void

CSS2Properties.setBorderRightStyle​(String borderRightStyle)

请参阅CSS2中的border-right-style属性定义。

void

CSS2Properties.setBorderRightWidth​(String borderRightWidth)

请参阅CSS2中的border-right-width属性定义。

void

CSS2Properties.setBorderSpacing​(String borderSpacing)

请参阅CSS2中的border-spacing属性定义。

void

CSS2Properties.setBorderStyle​(String borderStyle)

请参阅CSS2中的border-style属性定义。

void

CSS2Properties.setBorderTop​(String borderTop)

请参阅CSS2中的border-top属性定义。

void

CSS2Properties.setBorderTopColor​(String borderTopColor)

请参阅CSS2中的border-top-color属性定义。

void

CSS2Properties.setBorderTopStyle​(String borderTopStyle)

请参阅CSS2中的border-top-style属性定义。

void

CSS2Properties.setBorderTopWidth​(String borderTopWidth)

请参阅CSS2中的border-top-width属性定义。

void

CSS2Properties.setBorderWidth​(String borderWidth)

请参阅CSS2中的border-width属性定义。

void

CSS2Properties.setBottom​(String bottom)

请参阅CSS2中的底层属性定义。

void

CSS2Properties.setCaptionSide​(String captionSide)

请参阅CSS2中的标题侧属性定义。

void

CSS2Properties.setClear​(String clear)

请参阅CSS2中的清除属性定义。

void

CSS2Properties.setClip​(String clip)

请参阅CSS2中的剪辑属性定义。

void

CSS2Properties.setColor​(String color)

请参阅CSS2中的颜色属性定义。

void

CSS2Properties.setContent​(String content)

请参阅CSS2中的content属性定义。

void

CSS2Properties.setCounterIncrement​(String counterIncrement)

请参阅CSS2中的counter-increment属性定义。

void

CSS2Properties.setCounterReset​(String counterReset)

请参阅CSS2中的counter-reset属性定义。

void

CSS2Properties.setCssFloat​(String cssFloat)

请参阅CSS2中的float属性定义。

void

CSSRule.setCssText​(String cssText)

规则的可理解的文本表示。

void

CSSStyleDeclaration.setCssText​(String cssText)

声明块的可解释文本表示（不包括周围的花括号）。

void

CSSValue.setCssText​(String cssText)

当前值的字符串表示形式。

void

CSS2Properties.setCue​(String cue)

请参阅CSS2中的cue属性定义。

void

CSS2Properties.setCueAfter​(String cueAfter)

请参阅CSS2中的cue-after属性定义。

void

CSS2Properties.setCueBefore​(String cueBefore)

请参阅CSS2中的cue-before属性定义。

void

CSS2Properties.setCursor​(String cursor)

请参阅CSS2中的cursor属性定义。

void

CSS2Properties.setDirection​(String direction)

请参阅CSS2中的方向属性定义。

void

CSS2Properties.setDisplay​(String display)

请参阅CSS2中的显示属性定义。

void

CSS2Properties.setElevation​(String elevation)

请参阅CSS2中的elevation属性定义。

void

CSS2Properties.setEmptyCells​(String emptyCells)

请参阅CSS2中的empty-cells属性定义。

void

CSSCharsetRule.setEncoding​(String encoding)

在这个 @charset规则中使用的编码信息。

void

CSS2Properties.setFont​(String font)

请参阅CSS2中的font属性定义。

void

CSS2Properties.setFontFamily​(String fontFamily)

请参阅CSS2中的font-family属性定义。

void

CSS2Properties.setFontSize​(String fontSize)

请参阅CSS2中的font-size属性定义。

void

CSS2Properties.setFontSizeAdjust​(String fontSizeAdjust)

请参阅CSS2中的font-size-adjust属性定义。

void

CSS2Properties.setFontStretch​(String fontStretch)

请参阅CSS2中的font-stretch属性定义。

void

CSS2Properties.setFontStyle​(String fontStyle)

请参阅CSS2中的font-style属性定义。

void

CSS2Properties.setFontVariant​(String fontVariant)

请参阅CSS2中的font-variant属性定义。

void

CSS2Properties.setFontWeight​(String fontWeight)

请参阅CSS2中的font-weight属性定义。

void

CSS2Properties.setHeight​(String height)

请参阅CSS2中的height属性定义。

void

CSS2Properties.setLeft​(String left)

请参阅CSS2中的左侧属性定义。

void

CSS2Properties.setLetterSpacing​(String letterSpacing)

请参阅CSS2中的letter-spacing属性定义。

void

CSS2Properties.setLineHeight​(String lineHeight)

请参阅CSS2中的line-height属性定义。

void

CSS2Properties.setListStyle​(String listStyle)

请参阅CSS2中的list-style属性定义。

void

CSS2Properties.setListStyleImage​(String listStyleImage)

请参阅CSS2中的list-style-image属性定义。

void

CSS2Properties.setListStylePosition​(String listStylePosition)

请参阅CSS2中的list-style-position属性定义。

void

CSS2Properties.setListStyleType​(String listStyleType)

请参阅CSS2中的list-style-type属性定义。

void

CSS2Properties.setMargin​(String margin)

请参阅CSS2中的margin属性定义。

void

CSS2Properties.setMarginBottom​(String marginBottom)

请参阅CSS2中的margin-bottom属性定义。

void

CSS2Properties.setMarginLeft​(String marginLeft)

请参阅CSS2中的margin-left属性定义。

void

CSS2Properties.setMarginRight​(String marginRight)

请参阅CSS2中的margin-right属性定义。

void

CSS2Properties.setMarginTop​(String marginTop)

请参阅CSS2中的margin-top属性定义。

void

CSS2Properties.setMarkerOffset​(String markerOffset)

请参阅CSS2中的marker-offset属性定义。

void

CSS2Properties.setMarks​(String marks)

请参阅CSS2中的标记属性定义。

void

CSS2Properties.setMaxHeight​(String maxHeight)

请参阅CSS2中的max-height属性定义。

void

CSS2Properties.setMaxWidth​(String maxWidth)

请参阅CSS2中的max-width属性定义。

void

CSS2Properties.setMinHeight​(String minHeight)

请参阅CSS2中的min-height属性定义。

void

CSS2Properties.setMinWidth​(String minWidth)

请参阅CSS2中的min-width属性定义。

void

CSS2Properties.setOrphans​(String orphans)

请参阅CSS2中的孤儿属性定义。

void

CSS2Properties.setOutline​(String outline)

请参阅CSS2中的大纲属性定义。

void

CSS2Properties.setOutlineColor​(String outlineColor)

请参阅CSS2中的outline-color属性定义。

void

CSS2Properties.setOutlineStyle​(String outlineStyle)

请参阅CSS2中的outline-style属性定义。

void

CSS2Properties.setOutlineWidth​(String outlineWidth)

请参阅CSS2中的outline-width属性定义。

void

CSS2Properties.setOverflow​(String overflow)

请参阅CSS2中的overflow属性定义。

void

CSS2Properties.setPadding​(String padding)

请参阅CSS2中的padding属性定义。

void

CSS2Properties.setPaddingBottom​(String paddingBottom)

请参阅CSS2中的padding-bottom属性定义。

void

CSS2Properties.setPaddingLeft​(String paddingLeft)

请参阅CSS2中的padding-left属性定义。

void

CSS2Properties.setPaddingRight​(String paddingRight)

请参阅CSS2中的padding-right属性定义。

void

CSS2Properties.setPaddingTop​(String paddingTop)

请参阅CSS2中的padding-top属性定义。

void

CSS2Properties.setPage​(String page)

请参阅CSS2中的页面属性定义。

void

CSS2Properties.setPageBreakAfter​(String pageBreakAfter)

请参阅CSS2中的page-break-after属性定义。

void

CSS2Properties.setPageBreakBefore​(String pageBreakBefore)

请参阅CSS2中的page-break-before属性定义。

void

CSS2Properties.setPageBreakInside​(String pageBreakInside)

请参阅CSS2中的page-break-inside属性定义。

void

CSS2Properties.setPause​(String pause)

请参阅CSS2中的pause属性定义。

void

CSS2Properties.setPauseAfter​(String pauseAfter)

请参阅CSS2中的pause-after属性定义。

void

CSS2Properties.setPauseBefore​(String pauseBefore)

请参阅CSS2中的pause-before属性定义。

void

CSS2Properties.setPitch​(String pitch)

请参阅CSS2中的音高属性定义。

void

CSS2Properties.setPitchRange​(String pitchRange)

请参阅CSS2中的音高范围属性定义。

void

CSS2Properties.setPlayDuring​(String playDuring)

请参阅CSS2中的play-during属性定义。

void

CSS2Properties.setPosition​(String position)

请参阅CSS2中的position属性定义。

void

CSSStyleDeclaration.setProperty​(String propertyName, String value, String priority)

用于在此声明块中设置属性值和优先级。

void

CSS2Properties.setQuotes​(String quotes)

请参阅CSS2中的引号属性定义。

void

CSS2Properties.setRichness​(String richness)

请参阅CSS2中的richness属性定义。

void

CSS2Properties.setRight​(String right)

请参阅CSS2中的正确的属性定义。

void

CSSPageRule.setSelectorText​(String selectorText)

规则的页面选择器的可解析文本表示。

void

CSSStyleRule.setSelectorText​(String selectorText)

规则集的选择器的文本表示。

void

CSS2Properties.setSize​(String size)

请参阅CSS2中的size属性定义。

void

CSS2Properties.setSpeak​(String speak)

请参阅CSS2中的说话属性定义。

void

CSS2Properties.setSpeakHeader​(String speakHeader)

请参阅CSS2中的speak-header属性定义。

void

CSS2Properties.setSpeakNumeral​(String speakNumeral)

请参阅CSS2中的speak-numbers属性定义。

void

CSS2Properties.setSpeakPunctuation​(String speakPunctuation)

请参阅CSS2中的说话标点属性定义。

void

CSS2Properties.setSpeechRate​(String speechRate)

请参阅CSS2中的语速率属性定义。

void

CSS2Properties.setStress​(String stress)

请参阅CSS2中的stress属性定义。

void

CSSPrimitiveValue.setStringValue​(short stringType, String stringValue)

用指定单位设置字符串值的方法。

void

CSS2Properties.setTableLayout​(String tableLayout)

请参阅CSS2中的table-layout属性定义。

void

CSS2Properties.setTextAlign​(String textAlign)

请参阅CSS2中的text-align属性定义。

void

CSS2Properties.setTextDecoration​(String textDecoration)

请参阅CSS2中的text-decoration属性定义。

void

CSS2Properties.setTextIndent​(String textIndent)

请参阅CSS2中的text-indent属性定义。

void

CSS2Properties.setTextShadow​(String textShadow)

请参阅CSS2中的text-shadow属性定义。

void

CSS2Properties.setTextTransform​(String textTransform)

请参阅CSS2中的text-transform属性定义。

void

CSS2Properties.setTop​(String top)

请参阅CSS2中的顶层属性定义。

void

CSS2Properties.setUnicodeBidi​(String unicodeBidi)

请参阅CSS2中的unicode-bidi属性定义。

void

CSS2Properties.setVerticalAlign​(String verticalAlign)

请参阅CSS2中的vertical-align属性定义。

void

CSS2Properties.setVisibility​(String visibility)

请参阅CSS2中的visibility属性定义。

void

CSS2Properties.setVoiceFamily​(String voiceFamily)

请参阅CSS2中的voice-family属性定义。

void

CSS2Properties.setVolume​(String volume)

请参阅CSS2中的卷属性定义。

void

CSS2Properties.setWhiteSpace​(String whiteSpace)

请参阅CSS2中的空格属性定义。

void

CSS2Properties.setWidows​(String widows)

请参阅CSS2中的widows属性定义。

void

CSS2Properties.setWidth​(String width)

请参阅CSS2中的width属性定义。

void

CSS2Properties.setWordSpacing​(String wordSpacing)

请参阅CSS2中的word-spacing属性定义。

void

CSS2Properties.setZIndex​(String zIndex)

请参阅CSS2中的z-index属性定义。

Uses of String in org.w3c.dom.events

Methods in org.w3c.dom.events that return String

Modifier and Type

方法

描述

String

MutationEvent.getAttrName​()

attrName表示DOMAttrModified事件中更改的 Attr节点的名称。

String

MutationEvent.getNewValue​()

newValue表示的新值 Attr在DOMAttrModified事件节点和的 CharacterData在DOMCharacterDataModified事件节点。

String

MutationEvent.getPrevValue​()

prevValue指示的先前值 Attr在DOMAttrModified事件点，并且其的 CharacterData在DOMCharacterDataModified事件节点。

String

Event.getType​()

事件的名称（不区分大小写）。

Methods in org.w3c.dom.events with parameters of type String

Modifier and Type

方法

描述

void

EventTarget.addEventListener​(String type, EventListener listener, boolean useCapture)

该方法允许在事件目标上注册事件侦听器。

Event

DocumentEvent.createEvent​(String eventType)

void

Event.initEvent​(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg)

该 initEvent方法用于初始化的值 Event通过创建 DocumentEvent接口。

void

MouseEvent.initMouseEvent​(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)

initMouseEvent方法用于初始化通过 MouseEvent创建的 DocumentEvent接口的值。

void

MutationEvent.initMutationEvent​(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)

该 initMutationEvent方法用于初始化的值 MutationEvent通过创建 DocumentEvent接口。

void

UIEvent.initUIEvent​(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg)

该 initUIEvent方法用于初始化的值 UIEvent通过创建 DocumentEvent接口。

void

EventTarget.removeEventListener​(String type, EventListener listener, boolean useCapture)

此方法允许从事件目标中删除事件侦听器。

Constructors in org.w3c.dom.events with parameters of type String

Constructor

描述

EventException​(short code, String message)

Uses of String in org.w3c.dom.html

Methods in org.w3c.dom.html that return String

Modifier and Type

方法

描述

String

HTMLTableCellElement.getAbbr​()

标题单元的缩写。

String

HTMLInputElement.getAccept​()

服务器处理此表单的内容类型的逗号分隔列表将会正确处理。

String

HTMLFormElement.getAcceptCharset​()

服务器支持的字符集列表。

String

HTMLAnchorElement.getAccessKey​()

单个字符访问键可以访问表单控件。

String

HTMLAreaElement.getAccessKey​()

单个字符访问键可以访问表单控件。

String

HTMLButtonElement.getAccessKey​()

单个字符访问键可以访问表单控件。

String

HTMLInputElement.getAccessKey​()

单个字符访问键可以访问表单控件。

String

HTMLLabelElement.getAccessKey​()

单个字符访问键可以访问表单控件。

String

HTMLLegendElement.getAccessKey​()

单个字符访问键可以访问表单控件。

String

HTMLTextAreaElement.getAccessKey​()

单个字符访问键可以访问表单控件。

String

HTMLFormElement.getAction​()

服务器端表单处理程序。

String

HTMLAppletElement.getAlign​()

将对象（垂直或水平）与其周围文本对齐。

String

HTMLDivElement.getAlign​()

水平文本对齐。

String

HTMLHeadingElement.getAlign​()

水平文本对齐。

String

HTMLHRElement.getAlign​()

将规则对齐在页面上。

String

HTMLIFrameElement.getAlign​()

将对象（垂直或水平）与其周围文本对齐。

String

HTMLImageElement.getAlign​()

将对象（垂直或水平）与其周围文本对齐。

String

HTMLInputElement.getAlign​()

将对象（垂直或水平）与其周围文本对齐。

String

HTMLLegendElement.getAlign​()

文本对齐相对于 FIELDSET 。

String

HTMLObjectElement.getAlign​()

将对象（垂直或水平）与其周围文本对齐。

String

HTMLParagraphElement.getAlign​()

水平文本对齐。

String

HTMLTableCaptionElement.getAlign​()

相对于表的字幕对齐。

String

HTMLTableCellElement.getAlign​()

数据在单元格中的水平对齐。

String

HTMLTableColElement.getAlign​()

列中单元格数据的水平对齐。

String

HTMLTableElement.getAlign​()

指定表的相对于文档的其余部分的位置。

String

HTMLTableRowElement.getAlign​()

此行的单元格内的数据的水平对齐。

String

HTMLTableSectionElement.getAlign​()

单元格中数据的水平对齐。

String

HTMLBodyElement.getALink​()

活动链接的颜色（鼠标按钮向下，但在鼠标左键之前）。

String

HTMLAppletElement.getAlt​()

用户代理的替代文本不呈现此元素的正常内容。

String

HTMLAreaElement.getAlt​()

用户代理的替代文本不呈现此元素的正常内容。

String

HTMLImageElement.getAlt​()

用户代理的替代文本不呈现此元素的正常内容。

String

HTMLInputElement.getAlt​()

用户代理的替代文本不呈现此元素的正常内容。

String

HTMLAppletElement.getArchive​()

逗号分隔的档案列表。

String

HTMLObjectElement.getArchive​()

空格分隔的档案清单。

String

HTMLTableCellElement.getAxis​()

命名相关标题组。

String

HTMLBodyElement.getBackground​()

背景纹理图像的URI。

String

HTMLBodyElement.getBgColor​()

文件背景颜色。

String

HTMLTableCellElement.getBgColor​()

单元格背景颜色。

String

HTMLTableElement.getBgColor​()

单元格背景颜色。

String

HTMLTableRowElement.getBgColor​()

行的背景颜色。

String

HTMLImageElement.getBorder​()

图像边框宽度。

String

HTMLObjectElement.getBorder​()

对象边框宽度。

String

HTMLTableElement.getBorder​()

表格边框的宽度。

String

HTMLTableElement.getCellPadding​()

指定单元格内容和单元格边框之间的水平和垂直间距。

String

HTMLTableElement.getCellSpacing​()

指定单元格之间的水平和垂直间隔。

String

HTMLTableCellElement.getCh​()

列中单元格的对齐字符。

String

HTMLTableColElement.getCh​()

列中单元格的对齐字符。

String

HTMLTableRowElement.getCh​()

列中单元格的对齐字符。

String

HTMLTableSectionElement.getCh​()

列中单元格的对齐字符。

String

HTMLAnchorElement.getCharset​()

链接资源的字符编码。

String

HTMLLinkElement.getCharset​()

链接到的资源的字符编码。

String

HTMLScriptElement.getCharset​()

链接资源的字符编码。

String

HTMLTableCellElement.getChOff​()

对齐角色偏移

String

HTMLTableColElement.getChOff​()

对齐角色偏移

String

HTMLTableRowElement.getChOff​()

对齐角色偏移

String

HTMLTableSectionElement.getChOff​()

对齐角色偏移

String

HTMLModElement.getCite​()

指定描述更改原因的文档的URI。

String

HTMLQuoteElement.getCite​()

指定源文档或消息的URI。

String

HTMLElement.getClassName​()

元素的类属性。

String

HTMLBRElement.getClear​()

控制浮动文字的流动。

String

HTMLAppletElement.getCode​()

Applet类文件。

String

HTMLObjectElement.getCode​()

Applet类文件。

String

HTMLAppletElement.getCodeBase​()

小程序的可选基本URI。

String

HTMLObjectElement.getCodeBase​()

classid基本URI， data和 archive属性。

String

HTMLObjectElement.getCodeType​()

通过 classid属性下载的数据的内容类型。

String

HTMLBaseFontElement.getColor​()

字体颜色。

String

HTMLFontElement.getColor​()

字体颜色。

String

HTMLFrameSetElement.getCols​()

框架集中的帧列数。

String

HTMLMetaElement.getContent​()

相关信息。

String

HTMLDocument.getCookie​()

与此文档相关联的Cookie。

String

HTMLAnchorElement.getCoords​()

逗号分隔的长度列表，定义活动区域几何。

String

HTMLAreaElement.getCoords​()

逗号分隔的长度列表，定义活动区域几何。

String

HTMLObjectElement.getData​()

指定对象数据位置的URI。

String

HTMLModElement.getDateTime​()

变更的日期和时间。

String

HTMLInputElement.getDefaultValue​()

当元素的 type属性具有值“文本”，“文件”或“密码”时，表示元素的HTML值属性。

String

HTMLTextAreaElement.getDefaultValue​()

表示元素的内容。

String

HTMLElement.getDir​()

指定定向中性文本的基本方向和表的方向性。

String

HTMLDocument.getDomain​()

服务于该文档的服务器的域名，如果服务器无法通过域名标识， null 。

String

HTMLFormElement.getEnctype​()

提交表单的内容类型一般为“application / x-www-form-urlencoded”。

String

HTMLScriptElement.getEvent​()

留作将来使用。

String

HTMLBaseFontElement.getFace​()

字体识别符

String

HTMLFontElement.getFace​()

字体识别符

String

HTMLTableElement.getFrame​()

指定要呈现的外部表格边框。

String

HTMLFrameElement.getFrameBorder​()

请求帧边框。

String

HTMLIFrameElement.getFrameBorder​()

请求帧边框。

String

HTMLTableCellElement.getHeaders​()

标题单元格的属性值为 id列表。

String

HTMLAppletElement.getHeight​()

覆盖高度

String

HTMLIFrameElement.getHeight​()

镜架高度

String

HTMLImageElement.getHeight​()

覆盖高度

String

HTMLObjectElement.getHeight​()

覆盖高度

String

HTMLTableCellElement.getHeight​()

细胞高度

String

HTMLAnchorElement.getHref​()

链接资源的URI。

String

HTMLAreaElement.getHref​()

链接资源的URI。

String

HTMLBaseElement.getHref​()

基本URI。

String

HTMLLinkElement.getHref​()

链接资源的URI。

String

HTMLAnchorElement.getHreflang​()

链接资源的语言代码。

String

HTMLLinkElement.getHreflang​()

链接资源的语言代码。

String

HTMLAppletElement.getHspace​()

此图像左侧和右侧的水平空间，小程序或对象。

String

HTMLImageElement.getHspace​()

此图像左侧和右侧的水平空间。

String

HTMLObjectElement.getHspace​()

此图像左侧和右侧的水平空间，小程序或对象。

String

HTMLLabelElement.getHtmlFor​()

此属性通过 id属性将此标签与另一个窗体控件链接。

String

HTMLScriptElement.getHtmlFor​()

留作将来使用。

String

HTMLMetaElement.getHttpEquiv​()

HTTP响应头名称。

String

HTMLElement.getId​()

元素的标识符。

String

HTMLOptGroupElement.getLabel​()

为此选项组分配一个标签。

String

HTMLOptionElement.getLabel​()

分层菜单中使用的选项标签。

String

HTMLElement.getLang​()

RFC 1766中定义的语言代码。

String

HTMLBodyElement.getLink​()

没有活动和未访问的链接的颜色。

String

HTMLFrameElement.getLongDesc​()

URI指定此图像或框架的长描述。

String

HTMLIFrameElement.getLongDesc​()

URI指定此图像或框架的长描述。

String

HTMLImageElement.getLongDesc​()

URI指定此图像或框架的长描述。

String

HTMLImageElement.getLowSrc​()

URI指定此图像的来源，用于低分辨率输出。

String

HTMLFrameElement.getMarginHeight​()

帧边距高度，以像素为单位。

String

HTMLIFrameElement.getMarginHeight​()

帧边距高度，以像素为单位。

String

HTMLFrameElement.getMarginWidth​()

帧边距宽度，以像素为单位。

String

HTMLIFrameElement.getMarginWidth​()

帧边距宽度，以像素为单位。

String

HTMLLinkElement.getMedia​()

设计用于一个或多个目标介质。

String

HTMLStyleElement.getMedia​()

设计用于一个或多个目标介质。

String

HTMLFormElement.getMethod​()

用于提交表单的HTTP方法。

String

HTMLAnchorElement.getName​()

锚点名称

String

HTMLAppletElement.getName​()

小程序的名称。

String

HTMLButtonElement.getName​()

表单控件或表单提交时的对象名称。

String

HTMLFormElement.getName​()

命名表格。

String

HTMLFrameElement.getName​()

框架名称（ target属性的对象）。

String

HTMLIFrameElement.getName​()

框架名称（ target属性的对象）。

String

HTMLImageElement.getName​()

元素的名称（用于向后兼容）。

String

HTMLInputElement.getName​()

表单控件或表单提交时的对象名称。

String

HTMLMapElement.getName​()

命名地图（与 usemap一起使用）。

String

HTMLMetaElement.getName​()

元信息名称。

String

HTMLObjectElement.getName​()

表单控件或表单提交时的对象名称。

String

HTMLParamElement.getName​()

运行时参数的名称。

String

HTMLSelectElement.getName​()

表单控件或表单提交时的对象名称。

String

HTMLTextAreaElement.getName​()

表单控件或表单提交时的对象名称。

String

HTMLAppletElement.getObject​()

序列化小程序文件。

String

HTMLHeadElement.getProfile​()

指定元数据配置文件的URI。

String

HTMLIsIndexElement.getPrompt​()

提示信息。

String

HTMLDocument.getReferrer​()

返回链接到此页面的页面的URI。

String

HTMLAnchorElement.getRel​()

转发链接类型

String

HTMLLinkElement.getRel​()

转发链接类型

String

HTMLAnchorElement.getRev​()

反向链接类型。

String

HTMLLinkElement.getRev​()

反向链接类型。

String

HTMLFrameSetElement.getRows​()

框架集中的帧数。

String

HTMLTableElement.getRules​()

指定要呈现的内部表格边框。

String

HTMLMetaElement.getScheme​()

选择内容形式。

String

HTMLTableCellElement.getScope​()

标题单元覆盖的范围。

String

HTMLFrameElement.getScrolling​()

指定框架是否应该有滚动条。

String

HTMLIFrameElement.getScrolling​()

指定框架是否应该有滚动条。

String

HTMLAnchorElement.getShape​()

活动区域的形状。

String

HTMLAreaElement.getShape​()

活动区域的形状。

String

HTMLBaseFontElement.getSize​()

字体大小。

String

HTMLFontElement.getSize​()

字体大小。

String

HTMLHRElement.getSize​()

规则的高度。

String

HTMLInputElement.getSize​()

尺寸信息。

String

HTMLFrameElement.getSrc​()

指定初始帧内容的URI。

String

HTMLIFrameElement.getSrc​()

指定初始帧内容的URI。

String

HTMLImageElement.getSrc​()

URI指定此图像的来源。

String

HTMLInputElement.getSrc​()

当 type属性具有值“Image”时，此属性指定要用于装饰图形提交按钮的图像的位置。

String

HTMLScriptElement.getSrc​()

URI指定外部脚本。

String

HTMLObjectElement.getStandby​()

加载对象时要呈现的消息。

String

HTMLTableElement.getSummary​()

关于表的目的或结构的描述。

String

HTMLAnchorElement.getTarget​()

框架来渲染资源。

String

HTMLAreaElement.getTarget​()

框架来渲染资源。

String

HTMLBaseElement.getTarget​()

默认目标框架。

String

HTMLFormElement.getTarget​()

框架来渲染资源。

String

HTMLLinkElement.getTarget​()

框架来渲染资源。

String

HTMLBodyElement.getText​()

记录文字颜色。

String

HTMLOptionElement.getText​()

选项元素中包含的文本。

String

HTMLScriptElement.getText​()

元素的脚本内容。

String

HTMLTitleElement.getText​()

指定的标题为字符串。

String

HTMLDocument.getTitle​()

由文件头中的 TITLE元素指定的文档的标题。

String

HTMLElement.getTitle​()

该元素的咨询标题。

String

HTMLAnchorElement.getType​()

咨询内容类型。

String

HTMLButtonElement.getType​()

按钮的类型。

String

HTMLInputElement.getType​()

创建的控件类型。

String

HTMLLIElement.getType​()

列出项目项目符号样式。

String

HTMLLinkElement.getType​()

咨询内容类型。

String

HTMLObjectElement.getType​()

通过 data属性下载的数据的内容类型。

String

HTMLOListElement.getType​()

编号风格

String

HTMLParamElement.getType​()

当 valuetype具有值“ref”时，内容类型为 value属性。

String

HTMLScriptElement.getType​()

脚本语言的内容类型。

String

HTMLSelectElement.getType​()

此表单控件的类型。

String

HTMLStyleElement.getType​()

内容类型pf样式表语言。

String

HTMLTextAreaElement.getType​()

此表单控件的类型。

String

HTMLUListElement.getType​()

子弹风格。

String

HTMLDocument.getURL​()

文档的完整URI。

String

HTMLImageElement.getUseMap​()

使用客户端图像映射。

String

HTMLInputElement.getUseMap​()

使用客户端图像映射。

String

HTMLObjectElement.getUseMap​()

使用客户端图像映射。

String

HTMLTableCellElement.getVAlign​()

数据在单元格中的垂直对齐。

String

HTMLTableColElement.getVAlign​()

列中的单元格数据的垂直对齐。

String

HTMLTableRowElement.getVAlign​()

此行的单元格内的数据的垂直对齐方式。

String

HTMLTableSectionElement.getVAlign​()

数据在单元格中的垂直对齐。

String

HTMLButtonElement.getValue​()

当前窗体控件的值。

String

HTMLInputElement.getValue​()

当元素的 type属性具有值“文本”，“文件”或“密码”时，表示交互式用户代理中相应表单控件的当前内容。

String

HTMLOptionElement.getValue​()

当前窗体控件的值。

String

HTMLParamElement.getValue​()

运行时参数的值。

String

HTMLSelectElement.getValue​()

当前窗体控件的值。

String

HTMLTextAreaElement.getValue​()

在交互式用户代理中表示相应表单控件的当前内容。

String

HTMLParamElement.getValueType​()

关于 value属性值的含义的信息。

String

HTMLHtmlElement.getVersion​()

有关文档DTD的版本信息。

String

HTMLBodyElement.getVLink​()

用户访问过的链接的颜色。

String

HTMLAppletElement.getVspace​()

这个图像，小程序或对象之上和之下的垂直空间。

String

HTMLImageElement.getVspace​()

此图像上下方向的垂直空间。

String

HTMLObjectElement.getVspace​()

这个图像，小程序或对象之上和之下的垂直空间。

String

HTMLAppletElement.getWidth​()

覆盖宽度

String

HTMLHRElement.getWidth​()

规则的宽度。

String

HTMLIFrameElement.getWidth​()

框宽。

String

HTMLImageElement.getWidth​()

覆盖宽度

String

HTMLObjectElement.getWidth​()

覆盖宽度

String

HTMLTableCellElement.getWidth​()

单元宽度。

String

HTMLTableColElement.getWidth​()

默认列宽。

String

HTMLTableElement.getWidth​()

指定所需的表格宽度。

Methods in org.w3c.dom.html with parameters of type String

Modifier and Type

方法

描述

HTMLDocument

HTMLDOMImplementation.createHTMLDocument​(String title)

创建一个 HTMLDocument与由以下元素的最小树对象： HTML ， HEAD ， TITLE ，和 BODY 。

NodeList

HTMLDocument.getElementsByName​(String elementName)

返回（ name值由（ elementName ）给出的（可能为空）的元素集合。

Node

HTMLCollection.namedItem​(String name)

此方法使用名称检索 Node 。

void

HTMLTableCellElement.setAbbr​(String abbr)

void

HTMLInputElement.setAccept​(String accept)

void

HTMLFormElement.setAcceptCharset​(String acceptCharset)

void

HTMLAnchorElement.setAccessKey​(String accessKey)

void

HTMLAreaElement.setAccessKey​(String accessKey)

void

HTMLButtonElement.setAccessKey​(String accessKey)

void

HTMLInputElement.setAccessKey​(String accessKey)

void

HTMLLabelElement.setAccessKey​(String accessKey)

void

HTMLLegendElement.setAccessKey​(String accessKey)

void

HTMLTextAreaElement.setAccessKey​(String accessKey)

void

HTMLFormElement.setAction​(String action)

void

HTMLAppletElement.setAlign​(String align)

void

HTMLDivElement.setAlign​(String align)

void

HTMLHeadingElement.setAlign​(String align)

void

HTMLHRElement.setAlign​(String align)

void

HTMLIFrameElement.setAlign​(String align)

void

HTMLImageElement.setAlign​(String align)

void

HTMLInputElement.setAlign​(String align)

void

HTMLLegendElement.setAlign​(String align)

void

HTMLObjectElement.setAlign​(String align)

void

HTMLParagraphElement.setAlign​(String align)

void

HTMLTableCaptionElement.setAlign​(String align)

void

HTMLTableCellElement.setAlign​(String align)

void

HTMLTableColElement.setAlign​(String align)

void

HTMLTableElement.setAlign​(String align)

void

HTMLTableRowElement.setAlign​(String align)

void

HTMLTableSectionElement.setAlign​(String align)

void

HTMLBodyElement.setALink​(String aLink)

void

HTMLAppletElement.setAlt​(String alt)

void

HTMLAreaElement.setAlt​(String alt)

void

HTMLImageElement.setAlt​(String alt)

void

HTMLInputElement.setAlt​(String alt)

void

HTMLAppletElement.setArchive​(String archive)

void

HTMLObjectElement.setArchive​(String archive)

void

HTMLTableCellElement.setAxis​(String axis)

void

HTMLBodyElement.setBackground​(String background)

void

HTMLBodyElement.setBgColor​(String bgColor)

void

HTMLTableCellElement.setBgColor​(String bgColor)

void

HTMLTableElement.setBgColor​(String bgColor)

void

HTMLTableRowElement.setBgColor​(String bgColor)

void

HTMLImageElement.setBorder​(String border)

void

HTMLObjectElement.setBorder​(String border)

void

HTMLTableElement.setBorder​(String border)

void

HTMLTableElement.setCellPadding​(String cellPadding)

void

HTMLTableElement.setCellSpacing​(String cellSpacing)

void

HTMLTableCellElement.setCh​(String ch)

void

HTMLTableColElement.setCh​(String ch)

void

HTMLTableRowElement.setCh​(String ch)

void

HTMLTableSectionElement.setCh​(String ch)

void

HTMLAnchorElement.setCharset​(String charset)

void

HTMLLinkElement.setCharset​(String charset)

void

HTMLScriptElement.setCharset​(String charset)

void

HTMLTableCellElement.setChOff​(String chOff)

void

HTMLTableColElement.setChOff​(String chOff)

void

HTMLTableRowElement.setChOff​(String chOff)

void

HTMLTableSectionElement.setChOff​(String chOff)

void

HTMLModElement.setCite​(String cite)

void

HTMLQuoteElement.setCite​(String cite)

void

HTMLElement.setClassName​(String className)

void

HTMLBRElement.setClear​(String clear)

void

HTMLAppletElement.setCode​(String code)

void

HTMLObjectElement.setCode​(String code)

void

HTMLAppletElement.setCodeBase​(String codeBase)

void

HTMLObjectElement.setCodeBase​(String codeBase)

void

HTMLObjectElement.setCodeType​(String codeType)

void

HTMLBaseFontElement.setColor​(String color)

void

HTMLFontElement.setColor​(String color)

void

HTMLFrameSetElement.setCols​(String cols)

void

HTMLMetaElement.setContent​(String content)

void

HTMLDocument.setCookie​(String cookie)

void

HTMLAnchorElement.setCoords​(String coords)

void

HTMLAreaElement.setCoords​(String coords)

void

HTMLObjectElement.setData​(String data)

void

HTMLModElement.setDateTime​(String dateTime)

void

HTMLInputElement.setDefaultValue​(String defaultValue)

void

HTMLTextAreaElement.setDefaultValue​(String defaultValue)

void

HTMLElement.setDir​(String dir)

void

HTMLFormElement.setEnctype​(String enctype)

void

HTMLScriptElement.setEvent​(String event)

void

HTMLBaseFontElement.setFace​(String face)

void

HTMLFontElement.setFace​(String face)

void

HTMLTableElement.setFrame​(String frame)

void

HTMLFrameElement.setFrameBorder​(String frameBorder)

void

HTMLIFrameElement.setFrameBorder​(String frameBorder)

void

HTMLTableCellElement.setHeaders​(String headers)

void

HTMLAppletElement.setHeight​(String height)

void

HTMLIFrameElement.setHeight​(String height)

void

HTMLImageElement.setHeight​(String height)

void

HTMLObjectElement.setHeight​(String height)

void

HTMLTableCellElement.setHeight​(String height)

void

HTMLAnchorElement.setHref​(String href)

void

HTMLAreaElement.setHref​(String href)

void

HTMLBaseElement.setHref​(String href)

void

HTMLLinkElement.setHref​(String href)

void

HTMLAnchorElement.setHreflang​(String hreflang)

void

HTMLLinkElement.setHreflang​(String hreflang)

void

HTMLAppletElement.setHspace​(String hspace)

void

HTMLImageElement.setHspace​(String hspace)

void

HTMLObjectElement.setHspace​(String hspace)

void

HTMLLabelElement.setHtmlFor​(String htmlFor)

void

HTMLScriptElement.setHtmlFor​(String htmlFor)

void

HTMLMetaElement.setHttpEquiv​(String httpEquiv)

void

HTMLElement.setId​(String id)

void

HTMLOptGroupElement.setLabel​(String label)

void

HTMLOptionElement.setLabel​(String label)

void

HTMLElement.setLang​(String lang)

void

HTMLBodyElement.setLink​(String link)

void

HTMLFrameElement.setLongDesc​(String longDesc)

void

HTMLIFrameElement.setLongDesc​(String longDesc)

void

HTMLImageElement.setLongDesc​(String longDesc)

void

HTMLImageElement.setLowSrc​(String lowSrc)

void

HTMLFrameElement.setMarginHeight​(String marginHeight)

void

HTMLIFrameElement.setMarginHeight​(String marginHeight)

void

HTMLFrameElement.setMarginWidth​(String marginWidth)

void

HTMLIFrameElement.setMarginWidth​(String marginWidth)

void

HTMLLinkElement.setMedia​(String media)

void

HTMLStyleElement.setMedia​(String media)

void

HTMLFormElement.setMethod​(String method)

void

HTMLAnchorElement.setName​(String name)

void

HTMLAppletElement.setName​(String name)

void

HTMLButtonElement.setName​(String name)

void

HTMLFormElement.setName​(String name)

void

HTMLFrameElement.setName​(String name)

void

HTMLIFrameElement.setName​(String name)

void

HTMLImageElement.setName​(String name)

void

HTMLInputElement.setName​(String name)

void

HTMLMapElement.setName​(String name)

void

HTMLMetaElement.setName​(String name)

void

HTMLObjectElement.setName​(String name)

void

HTMLParamElement.setName​(String name)

void

HTMLSelectElement.setName​(String name)

void

HTMLTextAreaElement.setName​(String name)

void

HTMLAppletElement.setObject​(String object)

void

HTMLHeadElement.setProfile​(String profile)

void

HTMLIsIndexElement.setPrompt​(String prompt)

void

HTMLAnchorElement.setRel​(String rel)

void

HTMLLinkElement.setRel​(String rel)

void

HTMLAnchorElement.setRev​(String rev)

void

HTMLLinkElement.setRev​(String rev)

void

HTMLFrameSetElement.setRows​(String rows)

void

HTMLTableElement.setRules​(String rules)

void

HTMLMetaElement.setScheme​(String scheme)

void

HTMLTableCellElement.setScope​(String scope)

void

HTMLFrameElement.setScrolling​(String scrolling)

void

HTMLIFrameElement.setScrolling​(String scrolling)

void

HTMLAnchorElement.setShape​(String shape)

void

HTMLAreaElement.setShape​(String shape)

void

HTMLBaseFontElement.setSize​(String size)

void

HTMLFontElement.setSize​(String size)

void

HTMLHRElement.setSize​(String size)

void

HTMLInputElement.setSize​(String size)

void

HTMLFrameElement.setSrc​(String src)

void

HTMLIFrameElement.setSrc​(String src)

void

HTMLImageElement.setSrc​(String src)

void

HTMLInputElement.setSrc​(String src)

void

HTMLScriptElement.setSrc​(String src)

void

HTMLObjectElement.setStandby​(String standby)

void

HTMLTableElement.setSummary​(String summary)

void

HTMLAnchorElement.setTarget​(String target)

void

HTMLAreaElement.setTarget​(String target)

void

HTMLBaseElement.setTarget​(String target)

void

HTMLFormElement.setTarget​(String target)

void

HTMLLinkElement.setTarget​(String target)

void

HTMLBodyElement.setText​(String text)

void

HTMLScriptElement.setText​(String text)

void

HTMLTitleElement.setText​(String text)

void

HTMLDocument.setTitle​(String title)

void

HTMLElement.setTitle​(String title)

void

HTMLAnchorElement.setType​(String type)

void

HTMLLIElement.setType​(String type)

void

HTMLLinkElement.setType​(String type)

void

HTMLObjectElement.setType​(String type)

void

HTMLOListElement.setType​(String type)

void

HTMLParamElement.setType​(String type)

void

HTMLScriptElement.setType​(String type)

void

HTMLStyleElement.setType​(String type)

void

HTMLUListElement.setType​(String type)

void

HTMLImageElement.setUseMap​(String useMap)

void

HTMLInputElement.setUseMap​(String useMap)

void

HTMLObjectElement.setUseMap​(String useMap)

void

HTMLTableCellElement.setVAlign​(String vAlign)

void

HTMLTableColElement.setVAlign​(String vAlign)

void

HTMLTableRowElement.setVAlign​(String vAlign)

void

HTMLTableSectionElement.setVAlign​(String vAlign)

void

HTMLButtonElement.setValue​(String value)

void

HTMLInputElement.setValue​(String value)

void

HTMLOptionElement.setValue​(String value)

void

HTMLParamElement.setValue​(String value)

void

HTMLSelectElement.setValue​(String value)

void

HTMLTextAreaElement.setValue​(String value)

void

HTMLParamElement.setValueType​(String valueType)

void

HTMLHtmlElement.setVersion​(String version)

void

HTMLBodyElement.setVLink​(String vLink)

void

HTMLAppletElement.setVspace​(String vspace)

void

HTMLImageElement.setVspace​(String vspace)

void

HTMLObjectElement.setVspace​(String vspace)

void

HTMLAppletElement.setWidth​(String width)

void

HTMLHRElement.setWidth​(String width)

void

HTMLIFrameElement.setWidth​(String width)

void

HTMLImageElement.setWidth​(String width)

void

HTMLObjectElement.setWidth​(String width)

void

HTMLTableCellElement.setWidth​(String width)

void

HTMLTableColElement.setWidth​(String width)

void

HTMLTableElement.setWidth​(String width)

void

HTMLDocument.write​(String text)

将一串文本写入由 open()打开的文档流。

void

HTMLDocument.writeln​(String text)

在 open()打开的文件流中写入一串文本，后跟换行符。

Uses of String in org.w3c.dom.ls

Methods in org.w3c.dom.ls that return String

Modifier and Type

方法

描述

String

LSInput.getBaseURI​()

要使用的基址URI（参见[ IETF RFC 2396 ]中的第5.1.4节），用于将相对的 systemId解析为绝对URI。

String

LSInput.getEncoding​()

字符编码，如果知道。

String

LSOutput.getEncoding​()

用于输出的字符编码。

String

LSSerializer.getNewLine​()

要在XML中使用的字符的行尾序列被写出。

String

LSInput.getPublicId​()

该输入源的公共标识符。

String

LSInput.getStringData​()

要解析的字符串数据。

String

LSInput.getSystemId​()

该输入源的系统标识符，URI参考[ IETF RFC 2396 ]。

String

LSOutput.getSystemId​()

系统标识符，一个URI参考[ IETF RFC 2396 ]，用于此输出目标。

String

LSSerializer.writeToString​(Node nodeArg)

按照 LSSerializer界面的一般说明，按照上述的 LSSerializer序列化指定的节点。

Methods in org.w3c.dom.ls with parameters of type String

Modifier and Type

方法

描述

LSParser

DOMImplementationLS.createLSParser​(short mode, String schemaType)

创建一个新的 LSParser 。

Document

LSParser.parseURI​(String uri)

从由URI引用[ IETF RFC 2396 ]标识的位置解析XML文档。

LSInput

LSResourceResolver.resolveResource​(String type, String namespaceURI, String publicId, String systemId, String baseURI)

允许应用程序解决外部资源。

void

LSInput.setBaseURI​(String baseURI)

要使用的基址URI（见[ IETF RFC 2396 ]中的5.1.4），用于将相对的 systemId解析为绝对URI。

void

LSInput.setEncoding​(String encoding)

字符编码，如果知道。

void

LSOutput.setEncoding​(String encoding)

用于输出的字符编码。

void

LSSerializer.setNewLine​(String newLine)

要在XML中使用的字符的行尾序列被写出。

void

LSInput.setPublicId​(String publicId)

该输入源的公共标识符。

void

LSInput.setStringData​(String stringData)

要解析的字符串数据。

void

LSInput.setSystemId​(String systemId)

该输入源的系统标识符，URI参考[ IETF RFC 2396 ]。

void

LSOutput.setSystemId​(String systemId)

系统标识符，一个URI引用[ IETF RFC 2396 ]，用于此输出目标。

boolean

LSSerializer.writeToURI​(Node nodeArg, String uri)

一个方便的方法，就像 LSSerializer.write ，用一个 LSOutput ，没有指定编码，而 LSOutput.systemId设置为 uri参数。

Constructors in org.w3c.dom.ls with parameters of type String

Constructor

描述

LSException​(short code, String message)

Uses of String in org.w3c.dom.ranges

Methods in org.w3c.dom.ranges that return String

Modifier and Type

方法

描述

String

Range.toString​()

以Range作为字符串返回Range的内容。

Constructors in org.w3c.dom.ranges with parameters of type String

Constructor

描述

RangeException​(short code, String message)

Uses of String in org.w3c.dom.stylesheets

Methods in org.w3c.dom.stylesheets that return String

Modifier and Type

方法

描述

String

StyleSheet.getHref​()

如果样式表是链接的样式表，其属性的值就是它的位置。

String

MediaList.getMediaText​()

媒体列表的可解析文本表示。

String

StyleSheet.getTitle​()

咨询标题。

String

StyleSheet.getType​()

这将指定此样式表的样式表语言。

String

MediaList.item​(int index)

返回列表中的 index th。

Methods in org.w3c.dom.stylesheets with parameters of type String

Modifier and Type

方法

描述

void

MediaList.appendMedium​(String newMedium)

将媒体 newMedium添加到列表的末尾。

void

MediaList.deleteMedium​(String oldMedium)

从列表中删除 oldMedium所示的媒体。

void

MediaList.setMediaText​(String mediaText)

媒体列表的可解析文本表示。

Uses of String in org.w3c.dom.xpath

Methods in org.w3c.dom.xpath that return String

Modifier and Type

方法

描述

String

XPathResult.getStringValue​()

该字符串的值为result。

String

XPathNSResolver.lookupNamespaceURI​(String prefix)

查找与给定名称空间前缀相关联的命名空间URI。

Methods in org.w3c.dom.xpath with parameters of type String

Modifier and Type

方法

描述

XPathExpression

XPathEvaluator.createExpression​(String expression, XPathNSResolver resolver)

使用解析的命名空间创建一个已解析的XPath表达式。

Object

XPathEvaluator.evaluate​(String expression, Node contextNode, XPathNSResolver resolver, short type, Object result)

评估XPath表达式字符串，如果可能，返回指定类型的结果。

String

XPathNSResolver.lookupNamespaceURI​(String prefix)

查找与给定名称空间前缀相关联的命名空间URI。

Constructors in org.w3c.dom.xpath with parameters of type String

Constructor

描述

XPathException​(short code, String message)

Uses of String in org.xml.sax

Methods in org.xml.sax that return String

Modifier and Type

方法

描述

String

InputSource.getEncoding​()

获取字节流或URI的字符编码。

String

Attributes.getLocalName​(int index)

通过索引查找属性的本地名称。

String

SAXException.getMessage​()

返回此异常的详细消息。

String

AttributeList.getName​(int i)

已过时。

返回此列表中的属性名称（按位置）。

String

InputSource.getPublicId​()

获取此输入源的公共标识符。

String

Locator.getPublicId​()

返回当前文档事件的公共标识符。

String

SAXParseException.getPublicId​()

获取发生异常的实体的公共标识符。

String

Attributes.getQName​(int index)

通过索引查找属性的XML限定（前缀）名称。

String

InputSource.getSystemId​()

获取此输入源的系统标识符。

String

Locator.getSystemId​()

返回当前文档事件的系统标识符。

String

SAXParseException.getSystemId​()

获取发生异常的实体的系统标识符。

String

AttributeList.getType​(int i)

已过时。

返回列表中的属性类型（按位置）。

String

AttributeList.getType​(String name)

已过时。

返回列表中的属性类型（按名称）。

String

Attributes.getType​(int index)

通过索引查找属性的类型。

String

Attributes.getType​(String qName)

通过XML合格（前缀）名称查找属性的类型。

String

Attributes.getType​(String uri, String localName)

通过命名空间名称查找属性的类型。

String

Attributes.getURI​(int index)

通过索引查找属性的Namespace URI。

String

AttributeList.getValue​(int i)

已过时。

返回列表中的属性值（按位置）。

String

AttributeList.getValue​(String name)

已过时。

返回列表中的属性值（按名称）。

String

Attributes.getValue​(int index)

通过索引查找属性的值。

String

Attributes.getValue​(String qName)

通过XML限定（前缀）名称查找属性的值。

String

Attributes.getValue​(String uri, String localName)

通过命名空间名称查找属性的值。

String

SAXException.toString​()

覆盖toString以接收任何嵌入式异常。

String

SAXParseException.toString​()

覆盖toString以提供更详细的错误消息。

Methods in org.xml.sax with parameters of type String

Modifier and Type

方法

描述

void

ContentHandler.endElement​(String uri, String localName, String qName)

接收元素结尾的通知。

void

DocumentHandler.endElement​(String name)

已过时。

接收元素结尾的通知。

void

HandlerBase.endElement​(String name)

已过时。

接收元素结尾的通知。

void

ContentHandler.endPrefixMapping​(String prefix)

结束前缀URI映射的范围。

boolean

XMLReader.getFeature​(String name)

查找特征标记的值。

int

Attributes.getIndex​(String qName)

通过XML合格（前缀）名称查找属性的索引。

int

Attributes.getIndex​(String uri, String localName)

通过命名空间名称查找属性的索引。

Object

XMLReader.getProperty​(String name)

查找属性的值。

String

AttributeList.getType​(String name)

已过时。

返回列表中的属性类型（按名称）。

String

Attributes.getType​(String qName)

通过XML合格（前缀）名称查找属性的类型。

String

Attributes.getType​(String uri, String localName)

通过命名空间名称查找属性的类型。

String

AttributeList.getValue​(String name)

已过时。

返回列表中的属性值（按名称）。

String

Attributes.getValue​(String qName)

通过XML限定（前缀）名称查找属性的值。

String

Attributes.getValue​(String uri, String localName)

通过命名空间名称查找属性的值。

void

DTDHandler.notationDecl​(String name, String publicId, String systemId)

接收符号声明事件的通知。

void

HandlerBase.notationDecl​(String name, String publicId, String systemId)

已过时。

接收符号声明的通知。

void

Parser.parse​(String systemId)

已过时。

从系统标识符（URI）解析XML文档。

void

XMLReader.parse​(String systemId)

从系统标识符（URI）解析XML文档。

void

ContentHandler.processingInstruction​(String target, String data)

接收处理指令的通知。

void

DocumentHandler.processingInstruction​(String target, String data)

已过时。

接收处理指令的通知。

void

HandlerBase.processingInstruction​(String target, String data)

已过时。

接收处理指令的通知。

InputSource

EntityResolver.resolveEntity​(String publicId, String systemId)

允许应用程序解析外部实体。

InputSource

HandlerBase.resolveEntity​(String publicId, String systemId)

已过时。

解决外部实体。

void

InputSource.setEncoding​(String encoding)

设置字符编码，如果已知。

void

XMLReader.setFeature​(String name, boolean value)

设置特征标志的值。

void

XMLReader.setProperty​(String name, Object value)

设置属性的值。

void

InputSource.setPublicId​(String publicId)

设置此输入源的公共标识符。

void

InputSource.setSystemId​(String systemId)

设置此输入源的系统标识符。

void

ContentHandler.skippedEntity​(String name)

接收跳过实体的通知。

void

ContentHandler.startElement​(String uri, String localName, String qName, Attributes atts)

接收元素开头的通知。

void

DocumentHandler.startElement​(String name, AttributeList atts)

已过时。

接收元素开头的通知。

void

HandlerBase.startElement​(String name, AttributeList attributes)

已过时。

接收元素开始的通知。

void

ContentHandler.startPrefixMapping​(String prefix, String uri)

开始一个prefix-URI命名空间映射的范围。

void

DTDHandler.unparsedEntityDecl​(String name, String publicId, String systemId, String notationName)

接收未解析的实体声明事件的通知。

void

HandlerBase.unparsedEntityDecl​(String name, String publicId, String systemId, String notationName)

已过时。

收到未分类实体声明的通知。

Constructors in org.xml.sax with parameters of type String

Constructor

描述

InputSource​(String systemId)

创建一个带有系统标识符的新输入源。

SAXException​(String message)

创建一个新的SAXException。

SAXException​(String message, 异常 e)

从现有异常创建新的SAXException。

SAXNotRecognizedException​(String message)

使用给定的消息构造一个新的异常。

SAXNotSupportedException​(String message)

使用给定的消息构造一个新的异常。

SAXParseException​(String message, String publicId, String systemId, int lineNumber, int columnNumber)

创建一个新的SAXParseException。

SAXParseException​(String message, String publicId, String systemId, int lineNumber, int columnNumber, 异常 e)

创建一个新的SAXParseException与嵌入式异常。

SAXParseException​(String message, Locator locator)

从消息和定位器创建新的SAXParseException。

SAXParseException​(String message, Locator locator, 异常 e)

在SAXParseException中包装一个现有的异常。

Uses of String in org.xml.sax.ext

Methods in org.xml.sax.ext that return String

Modifier and Type

方法

描述

String

Locator2.getEncoding​()

返回实体的字符编码的名称。

String

Locator2Impl.getEncoding​()

返回encoding属性的当前值。

String

Locator2.getXMLVersion​()

返回实体使用的XML版本。

String

Locator2Impl.getXMLVersion​()

返回version属性的当前值。

Methods in org.xml.sax.ext with parameters of type String

Modifier and Type

方法

描述

void

Attributes2Impl.addAttribute​(String uri, String localName, String qName, String type, String value)

将属性添加到列表的末尾，将其“指定”标志设置为true。

void

DeclHandler.attributeDecl​(String eName, String aName, String type, String mode, String value)

报告属性类型声明。

void

DefaultHandler2.attributeDecl​(String eName, String aName, String type, String mode, String value)

void

DeclHandler.elementDecl​(String name, String model)

报告元素类型声明。

void

DefaultHandler2.elementDecl​(String name, String model)

void

DefaultHandler2.endEntity​(String name)

void

LexicalHandler.endEntity​(String name)

报告实体的结束。

void

DeclHandler.externalEntityDecl​(String name, String publicId, String systemId)

报告被解析的外部实体声明。

void

DefaultHandler2.externalEntityDecl​(String name, String publicId, String systemId)

InputSource

DefaultHandler2.getExternalSubset​(String name, String baseURI)

告诉解析器，如果在文档文本中没有声明外部子集，则不应使用任何外部子集。

InputSource

EntityResolver2.getExternalSubset​(String name, String baseURI)

允许应用程序为未明确定义的文档提供外部子集。

void

DeclHandler.internalEntityDecl​(String name, String value)

报告内部实体声明。

void

DefaultHandler2.internalEntityDecl​(String name, String value)

boolean

Attributes2.isDeclared​(String qName)

返回false，除非属性在DTD中声明。

boolean

Attributes2.isDeclared​(String uri, String localName)

返回false，除非属性在DTD中声明。

boolean

Attributes2Impl.isDeclared​(String qName)

返回属性的“声明”标志的当前值。

boolean

Attributes2Impl.isDeclared​(String uri, String localName)

返回属性的“声明”标志的当前值。

boolean

Attributes2.isSpecified​(String qName)

返回true，除非属性值由DTD默认提供。

boolean

Attributes2.isSpecified​(String uri, String localName)

返回true，除非属性值由DTD默认提供。

boolean

Attributes2Impl.isSpecified​(String qName)

返回属性的“指定”标志的当前值。

boolean

Attributes2Impl.isSpecified​(String uri, String localName)

返回属性的“指定”标志的当前值。

InputSource

DefaultHandler2.resolveEntity​(String publicId, String systemId)

使用空实体名称和基本URI调用 EntityResolver2.resolveEntity() 。

InputSource

DefaultHandler2.resolveEntity​(String name, String publicId, String baseURI, String systemId)

告诉解析器根据baseURI解析systemId，并从该结果的绝对URI中读取实体文本。

InputSource

EntityResolver2.resolveEntity​(String name, String publicId, String baseURI, String systemId)

允许应用程序将对外部实体的引用映射到输入源中，或者告诉解析器它应该使用传统的URI解析。

void

Locator2Impl.setEncoding​(String encoding)

分配编码属性的当前值。

void

Locator2Impl.setXMLVersion​(String version)

分配版本属性的当前值。

void

DefaultHandler2.startDTD​(String name, String publicId, String systemId)

void

LexicalHandler.startDTD​(String name, String publicId, String systemId)

报告DTD声明的开始，如果有的话。

void

DefaultHandler2.startEntity​(String name)

void

LexicalHandler.startEntity​(String name)

报告一些内部和外部XML实体的开始。

Uses of String in org.xml.sax.helpers

Fields in org.xml.sax.helpers declared as String

Modifier and Type

Field

描述

static String

NamespaceSupport.NSDECL

命名空间声明URI为常量。

static String

NamespaceSupport.XMLNS

XML命名空间URI作为常量。

Methods in org.xml.sax.helpers that return String

Modifier and Type

方法

描述

String

AttributesImpl.getLocalName​(int index)

返回属性的本地名称。

String

AttributeListImpl.getName​(int i)

已过时。

获取属性的名称（按位置）。

String

NamespaceSupport.getPrefix​(String uri)

返回映射到命名空间URI的前缀之一。

String

LocatorImpl.getPublicId​()

返回保存的公共标识符。

String

AttributesImpl.getQName​(int index)

返回属性的合格（前缀）名称。

String

LocatorImpl.getSystemId​()

返回保存的系统标识符。

String

AttributeListImpl.getType​(int i)

已过时。

获取属性的类型（按位置）。

String

AttributeListImpl.getType​(String name)

已过时。

获取属性的类型（按名称）。

String

AttributesImpl.getType​(int index)

通过索引返回属性的类型。

String

AttributesImpl.getType​(String qName)

通过合格（前缀）名称查找属性的类型。

String

AttributesImpl.getType​(String uri, String localName)

通过Namespace限定名称查找属性的类型。

String

AttributesImpl.getURI​(int index)

返回属性的命名空间URI。

String

NamespaceSupport.getURI​(String prefix)

查找前缀并获取当前映射的命名空间URI。

String

AttributeListImpl.getValue​(int i)

已过时。

获取属性的值（按位置）。

String

AttributeListImpl.getValue​(String name)

已过时。

获取属性的值（按名称）。

String

AttributesImpl.getValue​(int index)

通过索引返回属性的值。

String

AttributesImpl.getValue​(String qName)

通过合格（前缀）名称查找属性的值。

String

AttributesImpl.getValue​(String uri, String localName)

通过Namespace限定名查找属性的值。

String[]

NamespaceSupport.processName​(String qName, String[] parts, boolean isAttribute)

处理原始XML限定名称，在当前上下文中的所有声明都由 declarePrefix()处理。

Methods in org.xml.sax.helpers with parameters of type String

Modifier and Type

方法

描述

void

AttributeListImpl.addAttribute​(String name, String type, String value)

已过时。

将属性添加到属性列表。

void

AttributesImpl.addAttribute​(String uri, String localName, String qName, String type, String value)

将属性添加到列表的末尾。

static XMLReader

XMLReaderFactory.createXMLReader​(String className)

已过时。

尝试从类名创建XML阅读器。

boolean

NamespaceSupport.declarePrefix​(String prefix, String uri)

声明一个命名空间前缀。

void

DefaultHandler.endElement​(String uri, String localName, String qName)

接收元素结尾的通知。

void

ParserAdapter.endElement​(String qName)

适配器实现方法; 不要打电话。

void

XMLFilterImpl.endElement​(String uri, String localName, String qName)

过滤结束元素事件。

void

XMLReaderAdapter.endElement​(String uri, String localName, String qName)

修改SAX2终端元素事件。

void

DefaultHandler.endPrefixMapping​(String prefix)

接收命名空间映射结束的通知。

void

XMLFilterImpl.endPrefixMapping​(String prefix)

过滤结束命名空间前缀映射事件。

void

XMLReaderAdapter.endPrefixMapping​(String prefix)

修改SAX2结束前缀映射事件。

boolean

ParserAdapter.getFeature​(String name)

检查解析器功能标志。

boolean

XMLFilterImpl.getFeature​(String name)

查找功能的值。

int

AttributesImpl.getIndex​(String qName)

通过合格（前缀）名称查找属性的索引。

int

AttributesImpl.getIndex​(String uri, String localName)

通过命名空间名称查找属性的索引。

String

NamespaceSupport.getPrefix​(String uri)

返回映射到命名空间URI的前缀之一。

Enumeration

NamespaceSupport.getPrefixes​(String uri)

返回给定URI的所有前缀的枚举，其声明在当前上下文中处于活动状态。

Object

ParserAdapter.getProperty​(String name)

获取解析器属性。

Object

XMLFilterImpl.getProperty​(String name)

查找属性的值。

String

AttributeListImpl.getType​(String name)

已过时。

获取属性的类型（按名称）。

String

AttributesImpl.getType​(String qName)

通过合格（前缀）名称查找属性的类型。

String

AttributesImpl.getType​(String uri, String localName)

通过Namespace限定名称查找属性的类型。

String

NamespaceSupport.getURI​(String prefix)

查找前缀并获取当前映射的命名空间URI。

String

AttributeListImpl.getValue​(String name)

已过时。

获取属性的值（按名称）。

String

AttributesImpl.getValue​(String qName)

通过合格（前缀）名称查找属性的值。

String

AttributesImpl.getValue​(String uri, String localName)

通过Namespace限定名查找属性的值。

static Parser

ParserFactory.makeParser​(String className)

已过时。

使用提供的类名创建一个新的SAX解析器对象。

void

DefaultHandler.notationDecl​(String name, String publicId, String systemId)

接收符号声明的通知。

void

XMLFilterImpl.notationDecl​(String name, String publicId, String systemId)

过滤符号声明事件。

void

ParserAdapter.parse​(String systemId)

解析一个XML文档。

void

XMLFilterImpl.parse​(String systemId)

解析文件

void

XMLReaderAdapter.parse​(String systemId)

解析文件。

void

DefaultHandler.processingInstruction​(String target, String data)

接收处理指令的通知。

void

ParserAdapter.processingInstruction​(String target, String data)

适配器实现方法; 不要打电话。

void

XMLFilterImpl.processingInstruction​(String target, String data)

过滤处理指令事件。

void

XMLReaderAdapter.processingInstruction​(String target, String data)

修改SAX2处理指令事件。

String[]

NamespaceSupport.processName​(String qName, String[] parts, boolean isAttribute)

在当前上下文中的所有声明都由 declarePrefix()处理后，处理原始的XML限定名称。

void

AttributeListImpl.removeAttribute​(String name)

已过时。

从列表中删除一个属性。

InputSource

DefaultHandler.resolveEntity​(String publicId, String systemId)

解决外部实体。

InputSource

XMLFilterImpl.resolveEntity​(String publicId, String systemId)

过滤外部实体分辨率。

void

AttributesImpl.setAttribute​(int index, String uri, String localName, String qName, String type, String value)

在列表中设置一个属性。

void

ParserAdapter.setFeature​(String name, boolean value)

为解析器设置功能标志。

void

XMLFilterImpl.setFeature​(String name, boolean value)

设置功能的值。

void

AttributesImpl.setLocalName​(int index, String localName)

设置特定属性的本地名称。

void

ParserAdapter.setProperty​(String name, Object value)

设置解析器属性。

void

XMLFilterImpl.setProperty​(String name, Object value)

设置属性的值。

void

LocatorImpl.setPublicId​(String publicId)

设置此定位器的公共标识符。

void

AttributesImpl.setQName​(int index, String qName)

设置特定属性的限定名称。

void

LocatorImpl.setSystemId​(String systemId)

设置此定位器的系统标识符。

void

AttributesImpl.setType​(int index, String type)

设置特定属性的类型。

void

AttributesImpl.setURI​(int index, String uri)

设置特定属性的命名空间URI。

void

AttributesImpl.setValue​(int index, String value)

设置特定属性的值。

void

DefaultHandler.skippedEntity​(String name)

接收跳过实体的通知。

void

XMLFilterImpl.skippedEntity​(String name)

过滤跳过的实体事件。

void

XMLReaderAdapter.skippedEntity​(String name)

修改SAX2跳过的实体事件。

void

DefaultHandler.startElement​(String uri, String localName, String qName, Attributes attributes)

接收元素开始的通知。

void

ParserAdapter.startElement​(String qName, AttributeList qAtts)

适配器实现方法; 不要打电话。

void

XMLFilterImpl.startElement​(String uri, String localName, String qName, Attributes atts)

过滤起始元素事件。

void

XMLReaderAdapter.startElement​(String uri, String localName, String qName, Attributes atts)

修改SAX2启动元素事件。

void

DefaultHandler.startPrefixMapping​(String prefix, String uri)

接收命名空间映射开始的通知。

void

XMLFilterImpl.startPrefixMapping​(String prefix, String uri)

过滤起始命名空间前缀映射事件。

void

XMLReaderAdapter.startPrefixMapping​(String prefix, String uri)

修改SAX2启动前缀映射事件。

void

DefaultHandler.unparsedEntityDecl​(String name, String publicId, String systemId, String notationName)

收到未分类实体声明的通知。

void

XMLFilterImpl.unparsedEntityDecl​(String name, String publicId, String systemId, String notationName)

过滤未解析的实体声明事件。

Skip navigation links

概述

Module

软件包

Class

使用

树

已过时的

索引

帮助

Java SE 9 & JDK 9

Prev

Next

框架

无框架

所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StringBuffer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StringBuffer

  • Packages that use StringBuffer
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。

    • Uses of StringBuffer in java.io

      Methods in java.io that return StringBuffer
      Modifier and Type 方法 描述
      StringBuffer StringWriter.getBuffer​()
      返回字符串缓冲区本身。

    • Uses of StringBuffer in java.lang

      Methods in java.lang that return StringBuffer
      Modifier and Type | 方法 | 描述
      StringBuffer | StringBuffer.append​(boolean b)
      StringBuffer | StringBuffer.append​(char c)
      StringBuffer | StringBuffer.append​(char[] str)
      StringBuffer | StringBuffer.append​(char[] str, int offset, int len)
      StringBuffer | StringBuffer.append​(double d)
      StringBuffer | StringBuffer.append​(float f)
      StringBuffer | StringBuffer.append​(int i)
      StringBuffer | StringBuffer.append​(long lng)
      StringBuffer StringBuffer.append​(CharSequence s)
      追加指定的 CharSequence到这个序列。
      StringBuffer | StringBuffer.append​(CharSequence s, int start, int end)
      StringBuffer | StringBuffer.append​(Object obj)
      StringBuffer | StringBuffer.append​(String str)
      StringBuffer StringBuffer.append​(StringBuffer sb)
      追加指定的 StringBuffer到这个序列。
      StringBuffer | StringBuffer.appendCodePoint​(int codePoint)
      StringBuffer | StringBuffer.delete​(int start, int end)
      StringBuffer | StringBuffer.deleteCharAt​(int index)
      StringBuffer | StringBuffer.insert​(int offset, boolean b)
      StringBuffer | StringBuffer.insert​(int offset, char c)
      StringBuffer | StringBuffer.insert​(int offset, char[] str)
      StringBuffer | StringBuffer.insert​(int index, char[] str, int offset, int len)
      StringBuffer | StringBuffer.insert​(int offset, double d)
      StringBuffer | StringBuffer.insert​(int offset, float f)
      StringBuffer | StringBuffer.insert​(int offset, int i)
      StringBuffer | StringBuffer.insert​(int offset, long l)
      StringBuffer | StringBuffer.insert​(int dstOffset, CharSequence s)
      StringBuffer | StringBuffer.insert​(int dstOffset, CharSequence s, int start, int end)
      StringBuffer | StringBuffer.insert​(int offset, Object obj)
      StringBuffer | StringBuffer.insert​(int offset, String str)
      StringBuffer | StringBuffer.replace​(int start, int end, String str)
      StringBuffer | StringBuffer.reverse​()
      Methods in java.lang with parameters of type StringBuffer
      Modifier and Type 方法 描述
      StringBuffer StringBuffer.append​(StringBuffer sb)
      追加指定的 StringBuffer到这个序列。
      StringBuilder StringBuilder.append​(StringBuffer sb)
      追加指定的 StringBuffer到这个序列。
      boolean String.contentEquals​(StringBuffer sb)
      将此字符串与指定的 StringBuffer 。
      Constructors in java.lang with parameters of type StringBuffer
      Constructor 描述
      String​(StringBuffer buffer)
      分配一个新的字符串，其中包含当前包含在字符串缓冲区参数中的字符序列。

    • Uses of StringBuffer in java.text

      Methods in java.text that return StringBuffer
      Modifier and Type 方法 描述
      StringBuffer ChoiceFormat.format​(double number, StringBuffer toAppendTo, FieldPosition status)
      返回格式为double的模式。
      StringBuffer ChoiceFormat.format​(long number, StringBuffer toAppendTo, FieldPosition status)
      专业化格式。
      StringBuffer DateFormat.format​(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition)
      覆盖格式。
      abstract StringBuffer DateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition)
      将日期格式化成日期/时间字符串。
      StringBuffer DecimalFormat.format​(double number, StringBuffer result, FieldPosition fieldPosition)
      格式化为一个字符串。
      StringBuffer DecimalFormat.format​(long number, StringBuffer result, FieldPosition fieldPosition)
      格式化一个长的字符串。
      StringBuffer DecimalFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      abstract StringBuffer Format.format​(Object obj, StringBuffer toAppendTo, FieldPosition pos)
      格式化对象并将生成的文本附加到给定的字符串缓冲区。
      StringBuffer MessageFormat.format​(Object[] arguments, StringBuffer result, FieldPosition pos)
      格式化一组对象，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。
      StringBuffer MessageFormat.format​(Object arguments, StringBuffer result, FieldPosition pos)
      格式化一组对象，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。
      abstract StringBuffer NumberFormat.format​(double number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      abstract StringBuffer NumberFormat.format​(long number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      StringBuffer NumberFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      StringBuffer SimpleDateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition pos)
      将给定的 Date为日期/时间字符串，并将结果追加到给定的 StringBuffer 。
      Methods in java.text with parameters of type StringBuffer
      Modifier and Type 方法 描述
      StringBuffer ChoiceFormat.format​(double number, StringBuffer toAppendTo, FieldPosition status)
      返回格式为double的模式。
      StringBuffer ChoiceFormat.format​(long number, StringBuffer toAppendTo, FieldPosition status)
      专业化格式。
      StringBuffer DateFormat.format​(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition)
      覆盖格式。
      abstract StringBuffer DateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition)
      将日期格式化成日期/时间字符串。
      StringBuffer DecimalFormat.format​(double number, StringBuffer result, FieldPosition fieldPosition)
      格式化为一个字符串。
      StringBuffer DecimalFormat.format​(long number, StringBuffer result, FieldPosition fieldPosition)
      格式化一个长的字符串。
      StringBuffer DecimalFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      abstract StringBuffer Format.format​(Object obj, StringBuffer toAppendTo, FieldPosition pos)
      格式化对象并将生成的文本附加到给定的字符串缓冲区。
      StringBuffer MessageFormat.format​(Object[] arguments, StringBuffer result, FieldPosition pos)
      格式化一组对象，并将 MessageFormat的格式元素替换为格式化的对象，并提供给所提供的 StringBuffer 。
      StringBuffer MessageFormat.format​(Object arguments, StringBuffer result, FieldPosition pos)
      格式化一组对象，并将 MessageFormat的格式（格式化元素替换为格式化对象） StringBuffer到所提供的 StringBuffer 。
      abstract StringBuffer NumberFormat.format​(double number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      abstract StringBuffer NumberFormat.format​(long number, StringBuffer toAppendTo, FieldPosition pos)
      专业化格式。
      StringBuffer NumberFormat.format​(Object number, StringBuffer toAppendTo, FieldPosition pos)
      格式化一个数字，并将生成的文本附加到给定的字符串缓冲区。
      StringBuffer SimpleDateFormat.format​(Date date, StringBuffer toAppendTo, FieldPosition pos)
      将给定的 Date成日期/时间字符串，并将结果追加到给定的 StringBuffer 。

    • Uses of StringBuffer in java.util.regex

      Methods in java.util.regex that return StringBuffer
      Modifier and Type 方法 描述
      StringBuffer Matcher.appendTail​(StringBuffer sb)
      实施终端附加和替换步骤。
      Methods in java.util.regex with parameters of type StringBuffer
      Modifier and Type 方法 描述
      Matcher Matcher.appendReplacement​(StringBuffer sb, String replacement)
      实施非终端附加和替换步骤。
      StringBuffer Matcher.appendTail​(StringBuffer sb)
      实施终端附加和替换步骤。

    • Uses of StringBuffer in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser with parameters of type StringBuffer
      Modifier and Type 方法 描述
      protected boolean Parser.parseMarkupDeclarations​(StringBuffer strBuff)
      解析标记声明。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StringBuilder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StringBuilder

  • Packages that use StringBuilder
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。

    • Uses of StringBuilder in java.lang

      Methods in java.lang that return StringBuilder
      Modifier and Type | 方法 | 描述
      StringBuilder | StringBuilder.append​(boolean b)
      StringBuilder | StringBuilder.append​(char c)
      StringBuilder | StringBuilder.append​(char[] str)
      StringBuilder | StringBuilder.append​(char[] str, int offset, int len)
      StringBuilder | StringBuilder.append​(double d)
      StringBuilder | StringBuilder.append​(float f)
      StringBuilder | StringBuilder.append​(int i)
      StringBuilder | StringBuilder.append​(long lng)
      StringBuilder | StringBuilder.append​(CharSequence s)
      StringBuilder | StringBuilder.append​(CharSequence s, int start, int end)
      StringBuilder | StringBuilder.append​(Object obj)
      StringBuilder | StringBuilder.append​(String str)
      StringBuilder StringBuilder.append​(StringBuffer sb)
      追加指定的 StringBuffer到这个序列。
      StringBuilder | StringBuilder.appendCodePoint​(int codePoint)
      StringBuilder | StringBuilder.delete​(int start, int end)
      StringBuilder | StringBuilder.deleteCharAt​(int index)
      StringBuilder | StringBuilder.insert​(int offset, boolean b)
      StringBuilder | StringBuilder.insert​(int offset, char c)
      StringBuilder | StringBuilder.insert​(int offset, char[] str)
      StringBuilder | StringBuilder.insert​(int index, char[] str, int offset, int len)
      StringBuilder | StringBuilder.insert​(int offset, double d)
      StringBuilder | StringBuilder.insert​(int offset, float f)
      StringBuilder | StringBuilder.insert​(int offset, int i)
      StringBuilder | StringBuilder.insert​(int offset, long l)
      StringBuilder | StringBuilder.insert​(int dstOffset, CharSequence s)
      StringBuilder | StringBuilder.insert​(int dstOffset, CharSequence s, int start, int end)
      StringBuilder | StringBuilder.insert​(int offset, Object obj)
      StringBuilder | StringBuilder.insert​(int offset, String str)
      StringBuilder | StringBuilder.replace​(int start, int end, String str)
      StringBuilder | StringBuilder.reverse​()
      Constructors in java.lang with parameters of type StringBuilder
      Constructor 描述
      String​(StringBuilder builder)
      分配一个新的字符串，其中包含当前包含在字符串构建器参数中的字符序列。

    • Uses of StringBuilder in java.util.regex

      Methods in java.util.regex that return StringBuilder
      Modifier and Type 方法 描述
      StringBuilder Matcher.appendTail​(StringBuilder sb)
      实施终端附加和替换步骤。
      Methods in java.util.regex with parameters of type StringBuilder
      Modifier and Type 方法 描述
      Matcher Matcher.appendReplacement​(StringBuilder sb, String replacement)
      实施非终端附加和替换步骤。
      StringBuilder Matcher.appendTail​(StringBuilder sb)
      Implements a terminal append-and-replace step.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.StringIndexOutOfBoundsException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.StringIndexOutOfBoundsException

No usage of java.lang.StringIndexOutOfBoundsException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.SuppressWarnings (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.SuppressWarnings

  • Packages that use SuppressWarnings
    软件包 描述
    com.sun.java.accessibility.util
    提供组成Java辅助功能实用程序的接口和类的集合。
    com.sun.security.auth.module
    提供LoginModule的实现。
    java.applet
    提供创建applet所需的类以及applet用于与其applet上下文进行通信的类。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.net
    提供实现网络应用程序的类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.atomic
    一个小型工具包，支持单个变量上的无锁线程安全编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.cell
    所述javafx.scene.control.cell包是所有细胞相关的类的位置，比所述核心类如其他Cell ， IndexedCell ， ListCell ， TreeCell ，和TableCell 。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming包以提供访问目录服务的功能。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.naming.spi
    提供通过 javax.naming及相关软件包动态插入支持访问命名和目录服务的 javax.naming 。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.border
    提供用于绘制Swing组件周围特殊边框的类和接口。
    javax.swing.colorchooser
    包含 JColorChooser组件使用的类和接口。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.plaf.multi
    提供组合两种或多种外观和感觉的用户界面对象。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.plaf.synth
    合成是一种可以让所有绘画委托的外观和感觉。
    javax.swing.table
    提供处理 javax.swing.JTable类和接口。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.swing.text.html.parser
    提供默认的HTML解析器以及支持类。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方法。
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.xml.sax.helpers
    提供帮助类，包括支持引导基于SAX的应用程序。

    • Uses of SuppressWarnings in com.sun.java.accessibility.util

      Methods in com.sun.java.accessibility.util with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      boolean Translator.isFocusTraversable​()
      返回此对象是否可以接受焦点。

    • Uses of SuppressWarnings in com.sun.security.auth.module

      Methods in com.sun.security.auth.module with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      boolean SolarisLoginModule.abort​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      中止身份验证（第二阶段）。
      void JndiLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      void KeyStoreLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      void Krb5LoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化这个 LoginModule 。
      void LdapLoginModule.initialize​(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      初始化 LoginModule 。
      boolean SolarisLoginModule.login​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      验证用户（第一阶段）。
      boolean SolarisLoginModule.logout​()
      不推荐用于删除：此API元素将在以后的版本中被删除。
      注销用户

    • Uses of SuppressWarnings in java.applet

      Methods in java.applet with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      void Applet.resize​(int width, int height)
      已过时。
      请求这个小程序调整大小。
      void Applet.resize​(Dimension d)
      已过时。
      请求这个小程序调整大小。

    • Uses of SuppressWarnings in java.awt

      Methods in java.awt with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static ActionListener AWTEventMulticaster.add​(ActionListener a, ActionListener b)
      添加action-listener-a与action-listener-b，并返回生成的组播侦听器。
      static AdjustmentListener AWTEventMulticaster.add​(AdjustmentListener a, AdjustmentListener b)
      使用adjust-listener-b添加调整监听器a，并返回生成的组播侦听器。
      static HierarchyListener AWTEventMulticaster.add​(HierarchyListener a, HierarchyListener b)
      添加具有hierarchy-listener-b的hierarchy-listener-a并返回生成的组播侦听器。
      static ItemListener AWTEventMulticaster.add​(ItemListener a, ItemListener b)
      将item-listener-a与item-listener-b相加，并返回生成的组播监听器。
      static MouseWheelListener AWTEventMulticaster.add​(MouseWheelListener a, MouseWheelListener b)
      添加鼠标滚轮监听器a和鼠标滚轮监听器b并返回结果组播侦听器。
      static TextListener AWTEventMulticaster.add​(TextListener a, TextListener b)
      将text-listener-a与text-listener-b相加，并返回生成的多播侦听器。
      static WindowStateListener AWTEventMulticaster.add​(WindowStateListener a, WindowStateListener b)
      将window-state-listener-a与window-state-listener-b相加，并返回结果组播监听器。
      int FontMetrics.bytesWidth​(byte[] data, int off, int len)
      返回在此 Font显示指定字节数组的总进位宽度。
      Object RenderingHints.clone​()
      创建此的克隆 RenderingHints具有相同的内容，因为这对象 RenderingHints对象。
      void Graphics.drawBytes​(byte[] data, int offset, int length, int x, int y)
      绘制由指定字节数组给出的文本，使用此图形上下文的当前字体和颜色。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke​(String s)
      解析一个字符串并返回一个 AWTKeyStroke 。
      static AWTKeyStroke AWTKeyStroke.getAWTKeyStrokeForEvent​(KeyEvent anEvent)
      返回一个 AWTKeyStroke ，表示生成给定的 KeyEvent 。
      Set<AWTKeyStroke> Window.getFocusTraversalKeys​(int id)
      获取此窗口的焦点遍历键。
      URL SplashScreen.getImageURL​()
      返回当前的闪屏图像。
      protected List<KeyEventDispatcher> KeyboardFocusManager.getKeyEventDispatchers​()
      将此KeyboardFocusManager的KeyEventDispatcher链作为列表返回。
      protected List<KeyEventPostProcessor> KeyboardFocusManager.getKeyEventPostProcessors​()
      将此KeyboardFocusManager的KeyEventPostProcessor链返回为列表。
      static <T extends EventListener>
      T[]             		AWTEventMulticaster.getListeners​(EventListener l, Class<T> listenerType)
      返回链作为所有对象的数组 FooListener由该指定S java.util.EventListener 。
      <T extends EventListener>
      T[]             		Component.getListeners​(Class<T> listenerType)
      返回此 Component当前注册为 FooListener的所有对象的数组。
      int Toolkit.getMenuShortcutKeyMask​()
      确定哪个修饰键是菜单快捷键的适当加速键。
      void Window.pack​()
      使此窗口的大小适合其子组件的首选大小和布局。
      static ActionListener AWTEventMulticaster.remove​(ActionListener l, ActionListener oldl)
      从action-listener-l中删除旧的action-listener，并返回生成的组播侦听器。
      static AdjustmentListener AWTEventMulticaster.remove​(AdjustmentListener l, AdjustmentListener oldl)
      从调整监听器l中删除旧的调整监听器，并返回结果组播监听器。
      static HierarchyListener AWTEventMulticaster.remove​(HierarchyListener l, HierarchyListener oldl)
      从hierarchy-listener-l中删除旧的层次结构监听器，并返回结果组播监听器。
      static ItemListener AWTEventMulticaster.remove​(ItemListener l, ItemListener oldl)
      从item-listener-l中删除旧的项目监听器，并返回生成的组播侦听器。
      static MouseWheelListener AWTEventMulticaster.remove​(MouseWheelListener l, MouseWheelListener oldl)
      从mouse-wheel-listener-l中删除旧的鼠标滚轮监听器，并返回生成的组播侦听器。
      static TextListener AWTEventMulticaster.remove​(TextListener l, TextListener oldl)
      从text-listener-l中删除旧的文本侦听器，并返回生成的组播侦听器。
      static WindowStateListener AWTEventMulticaster.remove​(WindowStateListener l, WindowStateListener oldl)
      从window-state-listener-l中删除旧的window-state-listener，并返回结果组播监听器。
      void Component.remove​(MenuComponent popup)
      从组件中删除指定的弹出菜单。
      void Window.setOpacity​(float opacity)
      设置窗口的不透明度。
      void PopupMenu.show​(Component origin, int x, int y)
      在相对于原始组件的x，y位置显示弹出式菜单。
      String MenuShortcut.toString​()
      返回MenuShortcut的国际化描述。
      Constructors in java.awt with annotations of type SuppressWarnings
      Constructor 描述
      FlipBufferStrategy​(int numBuffers, BufferCapabilities caps)
      为此组件创建一个新的翻转缓冲区策略。

    • Uses of SuppressWarnings in java.awt.dnd

      Methods in java.awt.dnd with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      Iterator<InputEvent> DragGestureEvent.iterator​()
      返回一个包含手势的事件的 Iterator 。
      Object[] DragGestureEvent.toArray​(Object[] array)
      返回包含拖动手势的事件数组。
      protected void DragSourceContext.updateCurrentCursor​(int sourceAct, int targetAct, int status)
      如果默认拖动光标行为处于活动状态，则此方法将为拖动源支持的指定操作，放置目标操作和状态设置默认拖动光标，否则此方法不执行任何操作。

    • Uses of SuppressWarnings in java.awt.event

      Methods in java.awt.event with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static String MouseEvent.getMouseModifiersText​(int modifiers)
      返回描述在事件期间关闭的修改键和鼠标按钮的 String实例，例如“Shift”或“Ctrl + Shift”。
      String ActionEvent.paramString​()
      返回标识此操作事件的参数字符串。
      String KeyEvent.paramString​()
      返回标识此事件的参数字符串。
      String MouseEvent.paramString​()
      返回标识此事件的参数字符串。
      Constructors in java.awt.event with annotations of type SuppressWarnings
      Constructor 描述
      KeyEvent​(Component source, int id, long when, int modifiers, int keyCode, char keyChar, int keyLocation)
      构造一个 KeyEvent对象。
      MouseEvent​(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int button)
      构造具有指定源组件，类型，时间，修饰符，坐标，绝对坐标，点击计数，弹出触发标志和按钮编号的 MouseEvent对象。

    • Uses of SuppressWarnings in java.awt.geom

      Methods in java.awt.geom with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      void AffineTransform.concatenate​(AffineTransform Tx)
      将 AffineTransform Tx连接到这个 AffineTransform Cx中，最常用的方式是提供一个新的用户空间，映射到 Tx的前一个用户空间。
      double AffineTransform.getDeterminant​()
      返回变换的矩阵表示的行列式。
      Point2D AffineTransform.inverseTransform​(Point2D ptSrc, Point2D ptDst)
      反转换指定的 ptSrc ，并将结果存储在 ptDst 。
      void AffineTransform.preConcatenate​(AffineTransform Tx)
      串接的 AffineTransform Tx本 AffineTransform CX在一个不常用的方式，使得 Tx坐标变换相对于绝对像素空间而不是相对于现有的用户空间修改。
      void AffineTransform.scale​(double sx, double sy)
      使用缩放变换连接此变换。

    • Uses of SuppressWarnings in java.awt.image.renderable

      Methods in java.awt.image.renderable with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      Object ParameterBlock.clone​()
      创建一个 ParameterBlock的副本。

    • Uses of SuppressWarnings in java.beans

      Methods in java.beans with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      PropertyEditor PropertyDescriptor.createPropertyEditor​(Object bean)
      使用当前的属性编辑器类构造一个属性编辑器的实例。
      static Object Beans.instantiate​(ClassLoader cls, String beanName, BeanContext beanContext)
      实例化JavaBean。

    • Uses of SuppressWarnings in java.beans.beancontext

      Classes in java.beans.beancontext with annotations of type SuppressWarnings
      Modifier and Type 接口 描述
      interface  BeanContext
      BeanContext对JavaBeans起着逻辑分层容器的作用。
      Fields in java.beans.beancontext with annotations of type SuppressWarnings
      Modifier and Type Field 描述
      protected Collection BeanContextMembershipEvent.children
      受此事件通知影响的小孩列表。
      Methods in java.beans.beancontext with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      boolean BeanContextSupport.addAll​(Collection c)
      将集合添加到子集（不支持）的集合实现必须在层次结构锁和“children”保护字段上同步
      boolean BeanContextSupport.containsAll​(Collection c)
      测试看看所有的对象在指定的 Collection是这个 BeanContext孩子。
      protected void BeanContextSupport.deserialize​(ObjectInputStream ois, Collection coll)
      由readObject用于反序列化集合。
      Iterator BeanContextMembershipEvent.iterator​()
      获取受此事件影响的子项数组。
      boolean BeanContextSupport.removeAll​(Collection c)
      删除所有指定的子（不支持）实现必须在层次结构锁和“children”保护字段上同步
      boolean BeanContextSupport.retainAll​(Collection c)
      只保留指定的子级（不支持）实现必须在层次结构锁和“children”保护字段上同步
      Constructors in java.beans.beancontext with annotations of type SuppressWarnings
      Constructor 描述
      BeanContextMembershipEvent​(BeanContext bc, Collection changes)
      引发BeanContextMembershipEvent

    • Uses of SuppressWarnings in java.io

      Methods in java.io with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      void | BufferedWriter.close​()
      int LineNumberInputStream.read​()
      已过时。
      从该输入流读取下一个数据字节。
      int LineNumberReader.read​()
      读一个字符
      int LineNumberReader.read​(char[] cbuf, int off, int len)
      将字符读入数组的一部分。
      int StringBufferInputStream.read​(byte[] b, int off, int len)
      已过时。
      从该输入流读取最多 len字节的数据到字节数组。
      void RandomAccessFile.writeBytes​(String s)
      将字符串作为字节序列写入文件。

    • Uses of SuppressWarnings in java.lang

      Classes in java.lang with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  Enum<E extends Enum<E>>
      这是所有Java语言枚举类型的公共基类。
      class  EnumConstantNotPresentException
      当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。
      Fields in java.lang with annotations of type SuppressWarnings
      Modifier and Type Field 描述
      static Class<Boolean> Boolean.TYPE
      表示原始类型的类对象布尔值。
      static Class<Byte> Byte.TYPE
      Class表示原始类型 byte实例。
      static Class<Character> Character.TYPE
      Class表示原始类型 char实例。
      static Class<Double> Double.TYPE
      Class实例，表示原始类型 double 。
      static Class<Float> Float.TYPE
      Class实例代表原始类型 float 。
      static Class<Integer> Integer.TYPE
      代表 int原始类型的 Class实例。
      static Class<Long> Long.TYPE
      所述 Class实例表示基本类型 long 。
      static Class<Short> Short.TYPE
      所述 Class实例表示基本类型 short 。
      static Class<Void> Void.TYPE
      表示对应于关键字 void的伪类型的 Class对象。
      Methods in java.lang with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      <U> Class<? extends U> Class.asSubclass​(Class<U> clazz)
      Class这个 Class对象来表示由指定的类对象表示的类的子类。
      T Class.cast​(Object obj)
      将对象转换为由该 Class对象表示的类或接口。
      protected void Enum.finalize​()
      枚举类不能有finalize方法。
      <A extends Annotation>
      A             		Class.getAnnotation​(Class<A> annotationClass)
      <A extends Annotation>
      A             		Class.getDeclaredAnnotation​(Class<A> annotationClass)
      Class<E> Enum.getDeclaringClass​()
      返回与此枚举常量的枚举类型相对应的Class对象。
      static 软件包 Package.getPackage​(String name)
      已过时。
      如果多个类加载器彼此委托并定义具有相同包名称的类，并且一个这样的加载器依赖于getPackage的查找行为从父加载器返回一个软件包 ，则由软件包公开的属性可能不如预期的那样其余的程序。 例如， 软件包将仅显示由父加载程序定义的package-info.class文件中的注释，即使注释存在于由子加载器定义的package-info.class文件中。 更健壮的方法是使用ClassLoader.getDefinedPackage(java.lang.String)方法，该方法为指定的类加载器返回一个软件包 。
      TypeVariable<Class<T>>[] Class.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。
      void ThreadGroup.resume​()
      已过时。
      这种方法仅与Thread.suspend和ThreadGroup.suspend一起使用，因为它们本身就是死锁倾向。 详见Thread.suspend() 。
      static void System.runFinalizersOnExit​(boolean value)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      这种方法本质上是不安全的。 它可能导致在活动对象上调用finalizer，而其他线程同时操作这些对象，导致不稳定的行为或死锁。 此方法在将来的Java SE版本中可能会被删除。
      void ThreadGroup.suspend​()
      已过时。
      这种方法本质上是死锁的。 详见Thread.suspend() 。

    • Uses of SuppressWarnings in java.lang.instrument

      Methods in java.lang.instrument with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      Class[] Instrumentation.getAllLoadedClasses​()
      返回当前由JVM加载的所有类的数组。
      Class[] Instrumentation.getInitiatedClasses​(ClassLoader loader)
      返回一个 loader是起始加载程序的所有类的数组。

    • Uses of SuppressWarnings in java.lang.reflect

      Methods in java.lang.reflect with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      TypeVariable<Constructor<T>>[] Constructor.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。
      TypeVariable<方法>[] Method.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

    • Uses of SuppressWarnings in java.math

      Classes in java.math with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  RoundingMode
      指定能够丢弃精度的数值运算的 舍入行为 。

    • Uses of SuppressWarnings in java.net

      Methods in java.net with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      Object ContentHandler.getContent​(URLConnection urlc, Class[] classes)
      给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。
      long | HttpURLConnection.getHeaderFieldDate​(String name, long Default)
      long URLConnection.getHeaderFieldDate​(String name, long Default)
      返回以日期解析的命名字段的值。
      protected <T> T DatagramSocketImpl.getOption​(SocketOption<T> name)
      被称为获取套接字选项。
      <T> T Socket.getOption​(SocketOption<T> name)
      返回套接字选项的值。
      protected <T> T SocketImpl.getOption​(SocketOption<T> name)
      被称为获取套接字选项。

    • Uses of SuppressWarnings in java.rmi.server

      Methods in java.rmi.server with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static Remote RemoteObject.toStub​(Remote obj)
      返回作为参数传递的远程对象 obj的存根。

    • Uses of SuppressWarnings in java.sql

      Methods in java.sql with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      LocalDate Date.toLocalDate​()
      使用此 Date对象的年，月和日创建 LocalDate实例。
      LocalDateTime Timestamp.toLocalDateTime​()
      将此 Timestamp对象转换为 LocalDateTime 。
      LocalTime Time.toLocalTime​()
      将此 Time对象转换为 LocalTime 。
      String Date.toString​()
      格式化日期转义格式yyyy-mm-dd。
      String Time.toString​()
      以JDBC时间转义格式格式化。
      String Timestamp.toString​()
      以JDBC时间戳转义格式格式化时间戳。
      static Date Date.valueOf​(LocalDate date)
      从LocalDate对象中获取Date的实例，具有与给定的LocalDate相同的年份，月份和日期。
      static Time Time.valueOf​(LocalTime time)
      从LocalTime对象获取Time的实例，具有与给定的LocalTime相同的小时，分钟和第二时间值。
      static Timestamp Timestamp.valueOf​(LocalDateTime dateTime)
      获取的实例 Timestamp从 LocalDateTime对象，以相同的年，月，月日，时，分，秒和毫微秒日期时间值作为提供 LocalDateTime 。

    • Uses of SuppressWarnings in java.text

      Methods in java.text with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      void MessageFormat.applyPattern​(String pattern)
      设置此消息格式使用的模式。
      void CollationElementIterator.setOffset​(int newOffset)
      将迭代器设置为指向与指定字符对应的排序规则元素（参数是原始字符串中的CHARACTER偏移量，而不是其对应的排序规则元素序列中的偏移量）。

    • Uses of SuppressWarnings in java.time

      Methods in java.time with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static ZoneOffset ZoneOffset.of​(String offsetId)
      使用ID获取 ZoneOffset的实例。
      <R> R DayOfWeek.query​(TemporalQuery<R> query)
      使用指定的查询查询此星期几。
      <R> R Instant.query​(TemporalQuery<R> query)
      使用指定的查询查询此即时。
      <R> R LocalDate.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期。
      <R> R LocalDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      <R> R LocalTime.query​(TemporalQuery<R> query)
      此时使用指定的查询进行查询。
      <R> R Month.query​(TemporalQuery<R> query)
      使用指定的查询查询此月份的一年。
      <R> R MonthDay.query​(TemporalQuery<R> query)
      使用指定的查询查询此月日。
      <R> R OffsetDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      <R> R OffsetTime.query​(TemporalQuery<R> query)
      此时使用指定的查询进行查询。
      <R> R Year.query​(TemporalQuery<R> query)
      今年查询使用指定的查询。
      <R> R YearMonth.query​(TemporalQuery<R> query)
      使用指定的查询查询今年。
      <R> R ZonedDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      <R> R ZoneOffset.query​(TemporalQuery<R> query)
      使用指定的查询查询此偏移量。

    • Uses of SuppressWarnings in java.time.chrono

      Methods in java.time.chrono with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      default ChronoLocalDateTime<?> ChronoLocalDate.atTime​(LocalTime localTime)
      结合此日期与时间创建一个 ChronoLocalDateTime 。
      ChronoLocalDateTime<HijrahDate> | HijrahDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<JapaneseDate> | JapaneseDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<MinguoDate> | MinguoDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistDate.atTime​(LocalTime localTime)
      ChronoLocalDateTime<HijrahDate> | HijrahChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<JapaneseDate> | JapaneseChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<MinguoDate> | MinguoChronology.localDateTime​(TemporalAccessor temporal)
      ChronoLocalDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.localDateTime​(TemporalAccessor temporal)
      default <R> R ChronoLocalDate.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期。
      default <R> R ChronoLocalDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      default <R> R ChronoZonedDateTime.query​(TemporalQuery<R> query)
      使用指定的查询查询此日期时间。
      default <R> R Era.query​(TemporalQuery<R> query)
      使用指定的查询查询此时代。
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<HijrahDate> | HijrahChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<JapaneseDate> | JapaneseChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<MinguoDate> | MinguoChronology.zonedDateTime​(TemporalAccessor temporal)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(Instant instant, ZoneId zone)
      ChronoZonedDateTime<ThaiBuddhistDate> | ThaiBuddhistChronology.zonedDateTime​(TemporalAccessor temporal)

    • Uses of SuppressWarnings in java.time.temporal

      Methods in java.time.temporal with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      <R extends Temporal>
      R             		ChronoUnit.addTo​(R temporal, long amount)
      <R extends Temporal>
      R             		ChronoField.adjustInto​(R temporal, long newValue)

    • Uses of SuppressWarnings in java.util

      Classes in java.util with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      Fields in java.util with annotations of type SuppressWarnings
      Modifier and Type Field 描述
      protected boolean Calendar.areFieldsSet
      如果 fields[]与当前设置的时间同步， fields[]真。
      static List Collections.EMPTY_LIST
      空列表（不可变）。
      static Map Collections.EMPTY_MAP
      空地图（immutable）。
      static Set Collections.EMPTY_SET
      空集（不可变）。
      protected int[] Calendar.fields
      该日历的当前设置时间的日历字段值。
      protected boolean[] Calendar.isSet
      说明是否设置日历的指定日历字段的标志。
      protected boolean Calendar.isTimeSet
      如果那么 time的值是有效的， time真。
      protected long Calendar.time
      这个日历的当前设定时间，以1970年1月1日，格林尼治标准时间0:00:00之后的毫秒表示。
      Methods in java.util with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      static <T> List<T> Arrays.asList​(T... a)
      返回由指定数组支持的固定大小的列表。
      static <T> int Collections.binarySearch​(List<? extends T> list, T key, Comparator<? super T> c)
      使用二叉搜索算法搜索指定对象的指定列表。
      EnumMap<K,V> EnumMap.clone​()
      返回此枚举映射的浅拷贝。
      EnumSet<E> EnumSet.clone​()
      返回此集合的副本。
      Object HashMap.clone​()
      返回此 HashMap实例的浅拷贝：键和值本身不被克隆。
      Object HashSet.clone​()
      返回此 HashSet实例的浅拷贝：元素本身不被克隆。
      Object TreeSet.clone​()
      返回此 TreeSet实例的浅拷贝。
      static <T> T[] Arrays.copyOf​(T[] original, int newLength)
      复制指定的数组，用空值截断或填充（如有必要），以便复制具有指定的长度。
      static <T> T[] Arrays.copyOfRange​(T[] original, int from, int to)
      将指定数组的指定范围复制到新数组中。
      static <T> Enumeration<T> Collections.emptyEnumeration​()
      返回没有元素的枚举。
      static <T> Iterator<T> Collections.emptyIterator​()
      返回没有元素的迭代器。
      static <T> List<T> Collections.emptyList​()
      返回空列表（immutable）。
      static <T> ListIterator<T> Collections.emptyListIterator​()
      返回没有元素的列表迭代器。
      static <K,V> Map<K,V> Collections.emptyMap​()
      返回空的地图（不可变）。
      static <K,V> NavigableMap<K,V> Collections.emptyNavigableMap​()
      返回空导航地图（不可变）。
      static <E> NavigableSet<E> Collections.emptyNavigableSet​()
      返回一个空导航集（immutable）。
      static <T> Set<T> Collections.emptySet​()
      返回一个空集（immutable）。
      static <K,V> SortedMap<K,V> Collections.emptySortedMap​()
      返回空的排序映射（immutable）。
      static <E> SortedSet<E> Collections.emptySortedSet​()
      返回一个空的排序集（immutable）。
      static <T> Spliterator<T> Spliterators.emptySpliterator​()
      创建一个空的 Spliterator
      String Base64.Encoder.encodeToString​(byte[] src)
      使用Base64编码方案将指定的字节数组编码为字符串。
      boolean Calendar.equals​(Object obj)
      将此 Calendar与指定的 Object 。
      void | Hashtable.forEach​(BiConsumer<? super K,? super V> action)
      void | IdentityHashMap.forEach​(BiConsumer<? super K,? super V> action)
      void | WeakHashMap.forEach​(BiConsumer<? super K,? super V> action)
      void PrimitiveIterator.forEachRemaining​(T_CONS action)
      对每个剩余的元素执行给定的动作，按照迭代时发生的顺序，直到所有元素都被处理或动作引发异常。
      default void Spliterator.OfPrimitive.forEachRemaining​(T_CONS action)
      在当前线程中依次执行每个剩余元素的给定操作，直到所有元素都被处理或动作引发异常。
      V Hashtable.get​(Object key)
      返回指定键映射到的值，如果此映射不包含键的映射，则返回 null 。
      V IdentityHashMap.get​(Object key)
      返回指定键映射到的值，如果此映射不包含该键的映射，则返回 null 。
      static <T> T Collections.max​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最大元素。
      static <T> T Collections.min​(Collection<? extends T> coll, Comparator<? super T> comp)
      根据指定的比较器引发的顺序返回给定集合的最小元素。
      static <T extends Comparable<? super T>>
      Comparator<T>             		Comparator.naturalOrder​()
      返回一个以自然顺序比较Comparable对象的比较器。
      static <E> List<E> List.of​(E... elements)
      返回包含任意数量元素的不可变列表。
      static <E> Set<E> Set.of​(E... elements)
      返回一个包含任意数量元素的不可变集合。
      static <K,V> Map<K,V> Map.ofEntries​(Map.Entry<? extends K,? extends V>... entries)
      返回包含从给定条目提取的键和值的不可变地图。
      static <T extends Comparable<? super T>>
      void             		Arrays.parallelSort​(T[] a)
      根据其元素的natural ordering按照升序排列指定的对象数组。
      static <T extends Comparable<? super T>>
      void             		Arrays.parallelSort​(T[] a, int fromIndex, int toIndex)
      根据其元素的natural ordering按照升序排列指定数组对象的指定范围。
      static <T> void Arrays.parallelSort​(T[] a, int fromIndex, int toIndex, Comparator<? super T> cmp)
      根据指定的比较器引发的顺序对指定的对象数组的指定范围进行排序。
      static <T> void Arrays.parallelSort​(T[] a, Comparator<? super T> cmp)
      根据指定的比较器引发的顺序对指定的对象数组进行排序。
      E | PriorityQueue.peek​()
      E | PriorityQueue.poll​()
      protected void Hashtable.rehash​()
      增加这个散列表的内部重组能力，从而更有效地适应和访问其条目。
      void | Hashtable.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      void | IdentityHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      void | WeakHashMap.replaceAll​(BiFunction<? super K,? super V,? extends V> function)
      static void Collections.reverse​(List<?> list)
      反转指定列表中元素的顺序。
      static <T> Comparator<T> Collections.reverseOrder​()
      返回一个比较器， Comparable实现 Comparable接口的对象集合施加了 自然排序的相反。
      static void Collections.shuffle​(List<?> list, Random rnd)
      使用指定的随机源随机排列指定的列表。
      void | ArrayList.sort​(Comparator<? super E> c)
      static <T extends Comparable<? super T>>
      void             		Collections.sort​(List<T> list)
      根据其元素的natural ordering对指定的列表进行升序排序。
      static <T> void Collections.sort​(List<T> list, Comparator<? super T> c)
      根据指定的比较器引起的顺序对指定的列表进行排序。
      default void List.sort​(Comparator<? super E> c)
      根据指定的Comparator引发的顺序排列此列表。
      void | Vector.sort​(Comparator<? super E> c)
      static void Collections.swap​(List<?> list, int i, int j)
      交换指定列表中指定位置的元素。
      <T> T[] AbstractCollection.toArray​(T[] a)
      返回一个包含此集合中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] ArrayDeque.toArray​(T[] a)
      以正确的顺序返回一个包含此deque中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] ArrayList.toArray​(T[] a)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] LinkedList.toArray​(T[] a)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] PriorityQueue.toArray​(T[] a)
      返回一个包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] Vector.toArray​(T[] a)
      以正确的顺序返回一个包含此Vector中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      boolean Spliterator.OfPrimitive.tryAdvance​(T_CONS action)
      如果剩余的元素存在，执行给定的操作，返回true ; 否则返回false 。
      Constructors in java.util with annotations of type SuppressWarnings
      Constructor 描述
      PriorityQueue​(Collection<? extends E> c)
      创建包含指定集合中的元素的 PriorityQueue 。
      PriorityQueue​(PriorityQueue<? extends E> c)
      创建包含指定优先级队列中的元素的 PriorityQueue 。
      PriorityQueue​(SortedSet<? extends E> c)
      创建包含指定排序集中的元素的 PriorityQueue 。
      PropertyResourceBundle​(InputStream stream)
      从InputStream创建属性资源包。
      PropertyResourceBundle​(Reader reader)
      从Reader创建属性资源包。

    • Uses of SuppressWarnings in java.util.concurrent

      Classes in java.util.concurrent with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  PriorityBlockingQueue<E>
      无限blocking queue使用与类别PriorityQueue相同的排序规则，并提供阻止检索操作。
      Methods in java.util.concurrent with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      V Exchanger.exchange​(V x)
      等待另一个线程到达此交换点（除非当前线程是 interrupted ），然后将给定对象传输给它，接收其对象作为回报。
      V Exchanger.exchange​(V x, long timeout, TimeUnit unit)
      等待另一个线程到达此交换点（除非当前线程为 interrupted或指定的等待时间过去），然后将给定对象传输给它，接收其对象作为回报。
      T CompletableFuture.get​()
      等待这个未来完成的必要，然后返回结果。
      T CompletableFuture.get​(long timeout, TimeUnit unit)
      如果有必要等待这个未来完成的给定时间，然后返回其结果（如果有的话）。
      T CompletableFuture.getNow​(T valueIfAbsent)
      如果已完成，则返回结果值（或抛出任何遇到的异常），否则返回给定的值IfAbsent。
      T CompletableFuture.join​()
      完成后返回结果值，如果完成异常，则返回（未检查）异常。
      <T> T[] ArrayBlockingQueue.toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] ConcurrentLinkedDeque.toArray​(T[] a)
      以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] ConcurrentLinkedQueue.toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] CopyOnWriteArrayList.toArray​(T[] a)
      以正确的顺序返回一个包含此列表中所有元素的数组（从第一个到最后一个元素）; 返回的数组的运行时类型是指定数组的运行时类型。
      Object[] LinkedBlockingDeque.toArray​()
      以适当的顺序（从第一个到最后一个元素）返回一个包含此deque中所有元素的数组。
      <T> T[] LinkedBlockingDeque.toArray​(T[] a)
      以适当的顺序返回一个包含此deque中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] LinkedBlockingQueue.toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。
      <T> T[] LinkedTransferQueue.toArray​(T[] a)
      以适当的顺序返回包含此队列中所有元素的数组; 返回的数组的运行时类型是指定数组的运行时类型。

    • Uses of SuppressWarnings in java.util.concurrent.atomic

      Methods in java.util.concurrent.atomic with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      E AtomicReferenceArray.get​(int i)
      返回index位置的元件的电流值 i如通过指定，记忆效应 VarHandle.getVolatile(java.lang.Object...) 。
      V AtomicReference.getAndSet​(V newValue)
      将该值原子设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。
      E AtomicReferenceArray.getAndSet​(int i, E newValue)
      将索引 i为 newValue的元素原子设置为 newValue并返回旧值，具有 VarHandle.getAndSet(java.lang.Object...)指定的内存效果。

    • Uses of SuppressWarnings in java.util.jar

      Methods in java.util.jar with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      void Manifest.write​(OutputStream out)
      将清单写入指定的OutputStream。

    • Uses of SuppressWarnings in java.util.stream

      Methods in java.util.stream with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static <T> Stream<T> Stream.of​(T... values)
      返回其元素是指定值的顺序排序流。

    • Uses of SuppressWarnings in javafx.animation

      Methods in javafx.animation with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      Object Interpolator.interpolate​(Object startValue, Object endValue, double fraction)
      这个方法有两个 Objects与沿 fraction之间 0.0和 1.0并返回插补值。

    • Uses of SuppressWarnings in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      T JavaBeanObjectProperty.get​()
      获取包装的值。

    • Uses of SuppressWarnings in javafx.collections

      Methods in javafx.collections with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static <T> void FXCollections.copy​(ObservableList<? super T> dest, List<? extends T> src)
      将元素从src复制到dest。
      static <E> ObservableList<E> FXCollections.emptyObservableList​()
      创建和清空不可修改的可观察列表。
      static <K,V> ObservableMap<K,V> FXCollections.emptyObservableMap​()
      创建和清空不可修改的可观测地图。
      static <E> ObservableSet<E> FXCollections.emptyObservableSet​()
      创建和清空不可修改的可观察集。
      static <T> void FXCollections.fill​(ObservableList<? super T> list, T obj)
      用obj填写提供的列表。
      static <E> ObservableList<E> FXCollections.observableArrayList​()
      创建一个由数组列表支持的新的可观察列表。
      static <T> boolean FXCollections.replaceAll​(ObservableList<T> list, T oldVal, T newVal)
      用newVal元素替换列表中的所有oldVal元素。
      static void FXCollections.reverse​(ObservableList list)
      反转列表中的顺序列表中仅发送 一个更改通知。
      static void FXCollections.rotate​(ObservableList list, int distance)
      按距离旋转列表。
      static void FXCollections.shuffle​(ObservableList list, Random rnd)
      随机播放可观察列表中的所有元素。
      static <T extends Comparable<? super T>>
      void             		FXCollections.sort​(ObservableList<T> list)
      对提供的可观察列表进行排序。
      static <T> void FXCollections.sort​(ObservableList<T> list, Comparator<? super T> c)
      使用c比较器对提供的可观察列表进行排序。

    • Uses of SuppressWarnings in javafx.collections.transformation

      Constructors in javafx.collections.transformation with annotations of type SuppressWarnings
      Constructor 描述
      SortedList​(ObservableList<? extends E> source, Comparator<? super E> comparator)
      创建一个围绕源列表的新SortedList。
      TransformationList​(ObservableList<? extends F> source)
      创建一个围绕源列表的新的Transformation列表。

    • Uses of SuppressWarnings in javafx.css

      Methods in javafx.css with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      T ParsedValue.convert​(Font font)
      在这个 ParsedValue上调用 convert的方便方法。
      T StyleConverter.convert​(ParsedValue<F,T> value, Font font)
      从解析的CSS值转换为目标属性类型。
      static StyleConverter<?,?> StyleConverter.readBinary​(DataInputStream is, String[] strings)
      读取二进制数据流。

    • Uses of SuppressWarnings in javafx.fxml

      Methods in javafx.fxml with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      <T> T FXMLLoader.getController​()
      返回与根对象关联的控制器。
      <T> T FXMLLoader.getRoot​()
      返回对象层次结构的根。

    • Uses of SuppressWarnings in javafx.scene.control

      Methods in javafx.scene.control with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.branchCollapsedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于折叠状态。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.branchExpandedEvent​()
      当TreeItem接收到其扩展属性的修改时使用的EventType，使得TreeItem现在处于展开状态。
      static <T> EventType<CheckBoxTreeItem.TreeModificationEvent<T>> CheckBoxTreeItem.checkBoxSelectionChangedEvent​()
      当CheckBoxTreeItem选择/不确定状态改变时使用的EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.childrenModificationEvent​()
      当TreeItem接收到对其子列表的直接修改时使用的EventType。
      static <T> EventType<ListView.EditEvent<T>> ListView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editAnyEvent​()
      任何TableColumn编辑事件的父事件。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editAnyEvent​()
      任何TreeTableColumn编辑事件的父事件。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editAnyEvent​()
      指示发生一些编辑事件的EventType。
      static <T> EventType<ListView.EditEvent<T>> ListView.editCancelEvent​()
      一个EventType，用于指示在事件触发的ListView中刚刚取消了编辑事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editCancelEvent​()
      表示编辑已被取消，这意味着不应对后备数据源进行任何更改。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editCancelEvent​()
      EventType用于指示事件被触发的TreeTableView中刚刚取消了编辑事件。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editCancelEvent​()
      EventType用于指示事件被触发的TreeView中刚刚取消了编辑事件。
      static <T> EventType<ListView.EditEvent<T>> ListView.editCommitEvent​()
      EventType用于指示已在触发事件的ListView中提交了编辑事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editCommitEvent​()
      表示编辑已由用户提交，这意味着应对后备数据源进行更改以反映新数据。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editCommitEvent​()
      用于指示TreeTableView中的编辑已提交的EventType。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editCommitEvent​()
      用于指示TreeView中的编辑已提交的EventType。
      static <T> EventType<ListView.EditEvent<T>> ListView.editStartEvent​()
      EventType用于指示在事件被触发的ListView中启动编辑事件。
      static <S,T> EventType<TableColumn.CellEditEvent<S,T>> TableColumn.editStartEvent​()
      表示用户已经执行了一些交互来启动编辑事件，或者已经调用了 TableView.edit(int, javafx.scene.control.TableColumn)方法。
      static <S,T> EventType<TreeTableColumn.CellEditEvent<S,T>> TreeTableColumn.editStartEvent​()
      表示用户已经执行了一些交互来启动编辑事件，或者已经调用了 TreeTableView.edit(int, javafx.scene.control.TreeTableColumn)方法。
      static <S> EventType<TreeTableView.EditEvent<S>> TreeTableView.editStartEvent​()
      EventType用于指示在触发事件的TreeTableView中启动了编辑事件。
      static <T> EventType<TreeView.EditEvent<T>> TreeView.editStartEvent​()
      EventType用于指示在事件触发的TreeView中启动了编辑事件。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.expandedItemCountChangeEvent​()
      当TreeItem接收到一个修改，导致孩子数目可见的更改时使用的常规EventType。
      EventType<DialogEvent> | DialogEvent.getEventType​()
      Callback<TableView<S>,Boolean> TableView.getSortPolicy​()
      获取属性sortPolicy的值。
      Callback<TreeTableView<S>,Boolean> TreeTableView.getSortPolicy​()
      获取属性sortPolicy的值。
      C | SortEvent.getSource​()
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.graphicChangedEvent​()
      当TreeItem接收到其图形属性的修改时使用的EventType。
      static <T extends TableColumnBase<?,?>>
      EventType<ScrollToEvent<T>>             		ScrollToEvent.scrollToColumn​()
      如果用户请求滚动一个TableColumnBase （即
      static <C> EventType<SortEvent<C>> | SortEvent.sortEvent​()
      ObjectProperty<Callback<TableView<S>,Boolean>> TableView.sortPolicyProperty​()
      排序策略指定如何执行此TableView中的排序。
      ObjectProperty<Callback<TreeTableView<S>,Boolean>> TreeTableView.sortPolicyProperty​()
      排序策略指定如何执行此TreeTableView中的排序。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.treeNotificationEvent​()
      用于指示事件在TreeItem中发生的基本EventType。
      static <T> EventType<TreeItem.TreeModificationEvent<T>> TreeItem.valueChangedEvent​()
      当TreeItem接收到对其value属性的修改时使用的EventType。
      Constructor parameters in javafx.scene.control with annotations of type SuppressWarnings
      Constructor 描述
      ChoiceDialog​(T defaultChoice, T... choices)
      创建一个新的ChoiceDialog实例，第一个参数指定应向用户显示的默认选项，并且所有以下参数都被视为用户所有可用选项的varargs数组。

    • Uses of SuppressWarnings in javafx.scene.control.cell

      Methods in javafx.scene.control.cell with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      void CheckBoxTableCell.updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。
      void CheckBoxTreeTableCell.updateItem​(T item, boolean empty)
      updateItem方法不应该被开发人员调用，但它是开发人员覆盖的最佳方式，以允许它们自定义单元格的视觉效果。

    • Uses of SuppressWarnings in javafx.scene.layout

      Classes in javafx.scene.layout with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  Background
      一个Region的背景。
      class  Border
      边界的一个Region 。

    • Uses of SuppressWarnings in javax.lang.model.util

      Constructors in javax.lang.model.util with annotations of type SuppressWarnings
      Constructor 描述
      AbstractAnnotationValueVisitor7​()
      具体子类调用的构造方法。
      AbstractElementVisitor7​()
      具体子类调用的构造方法。
      AbstractTypeVisitor7​()
      具体子类调用的构造方法。
      ElementKindVisitor7​()
      具体子类的构造方法 使用null作为默认值。
      ElementKindVisitor7​(R defaultValue)
      具体子类的构造方法 使用参数作为默认值。
      ElementScanner7​()
      具体子类的构造方法 使用null作为默认值。
      ElementScanner7​(R defaultValue)
      具体子类的构造方法 使用参数作为默认值。
      SimpleAnnotationValueVisitor7​()
      具体子类的构造方法 使用默认值null 。
      SimpleAnnotationValueVisitor7​(R defaultValue)
      具体子类的构造方法 使用参数作为默认值。
      SimpleElementVisitor7​()
      具体子类的构造方法 使用null作为默认值。
      SimpleElementVisitor7​(R defaultValue)
      具体子类的构造方法 使用参数作为默认值。
      SimpleTypeVisitor7​()
      具体子类的构造方法 使用null作为默认值。
      SimpleTypeVisitor7​(R defaultValue)
      具体子类的构造方法 使用参数作为默认值。
      TypeKindVisitor7​()
      具体子类调用的构造方法 使用null作为默认值。
      TypeKindVisitor7​(R defaultValue)
      具体子类调用的构造方法 使用参数作为默认值。

    • Uses of SuppressWarnings in javax.management

      Classes in javax.management with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  MBeanAttributeInfo
      描述为管理而公开的MBean属性。
      class  Notification
      Notification类表示由MBean发出的通知。
      class  ObjectName
      表示MBean的对象名称，或可匹配多个MBean名称的模式。
      Methods in javax.management with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      List<Attribute> AttributeList.asList​()
      将此列表的视图作为 List<Attribute> 。

    • Uses of SuppressWarnings in javax.management.modelmbean

      Classes in javax.management.modelmbean with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  DescriptorSupport
      此类表示一个ModelMBean元素的元数据集。
      class  InvalidTargetObjectTypeException
      指定无效目标对象类型时抛出异常。
      class  ModelMBeanAttributeInfo
      ModelMBeanAttributeInfo对象描述了ModelMBean的属性。
      class  ModelMBeanConstructorInfo
      ModelMBeanConstructorInfo对象描述了ModelMBean的构造函数。
      class  ModelMBeanInfoSupport
      此类表示ModelMBeans的元数据。
      class  ModelMBeanNotificationInfo
      ModelMBeanNotificationInfo对象描述了由ModelMBean发出的通知。
      class  ModelMBeanOperationInfo
      ModelMBeanOperationInfo对象描述了ModelMBean的管理操作。
      class  XMLParseException
      当将XML格式化的字符串解析为ModelMBean对象或从ModelMBean对象创建XML格式的字符串时，将抛出此异常。

    • Uses of SuppressWarnings in javax.management.openmbean

      Methods in javax.management.openmbean with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      Set<Map.Entry<Object,Object>> TabularDataSupport.entrySet​()
      返回此 TabularDataSupport实例中包含的行映射索引的集合视图。
      static <T> ArrayType<T> ArrayType.getPrimitiveArrayType​(Class<T> arrayClass)
      以类型安全的方式创建一个 ArrayType实例。
      Collection<Object> TabularDataSupport.values​()
      返回此 TabularDataSupport实例中包含的行的集合视图。

    • Uses of SuppressWarnings in javax.management.relation

      Classes in javax.management.relation with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  MBeanServerNotificationFilter
      过滤器为MBeanServerNotification 。
      class  RelationNotification
      关系服务变更通知。
      class  RelationTypeSupport
      RelationTypeSupport对象实现RelationType接口。
      class  Role
      表示角色：包括角色名称和引用的MBean（通过其ObjectNames）。
      class  RoleInfo
      RoleInfo对象总结了关系类型中的角色。
      class  RoleResult
      表示多次访问关系的几个角色（用于阅读或写入）的结果。
      class  RoleUnresolved
      代表一个未解决的角色：由于问题而无法从关系中检索到的角色。
      Methods in javax.management.relation with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      List<Role> RoleList.asList​()
      将此列表的视图作为 List<Role> 。
      List<RoleUnresolved> RoleUnresolvedList.asList​()
      将此列表的视图作为 List<RoleUnresolved> 。

    • Uses of SuppressWarnings in javax.management.remote.rmi

      Classes in javax.management.remote.rmi with annotations of type SuppressWarnings
      Modifier and Type 接口 描述
      interface  RMIConnection
      用于将MBeanServer请求从客户端转发到其在服务器端的MBeanServer实现的RMI对象。
      Methods in javax.management.remote.rmi with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      void | RMIConnectionImpl.addNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Integer[] | RMIConnectionImpl.addNotificationListeners​(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance | RMIConnectionImpl.createMBean​(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Object | RMIConnectionImpl.invoke​(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Set<ObjectInstance> | RMIConnectionImpl.queryMBeans​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectName> | RMIConnectionImpl.queryNames​(ObjectName name, MarshalledObject query, Subject delegationSubject)
      void | RMIConnectionImpl.removeNotificationListener​(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      void | RMIConnectionImpl.setAttribute​(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      AttributeList | RMIConnectionImpl.setAttributes​(ObjectName name, MarshalledObject attributes, Subject delegationSubject)

    • Uses of SuppressWarnings in javax.naming

      Methods in javax.naming with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static <T> T InitialContext.doLookup​(String name)
      一种用于检索命名对象的静态方法。
      static <T> T InitialContext.doLookup​(Name name)
      一种用于检索命名对象的静态方法。
      protected void InitialContext.init​(Hashtable<?,?> environment)
      使用提供的环境初始化初始上下文。

    • Uses of SuppressWarnings in javax.naming.directory

      Methods in javax.naming.directory with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      Object | BasicAttribute.clone​()
      Object | BasicAttributes.clone​()

    • Uses of SuppressWarnings in javax.naming.ldap

      Constructors in javax.naming.ldap with annotations of type SuppressWarnings
      Constructor 描述
      InitialLdapContext​(Hashtable<?,?> environment, Control[] connCtls)
      使用环境属性和连接请求控件构造初始上下文。

    • Uses of SuppressWarnings in javax.naming.spi

      Methods in javax.naming.spi with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static Context NamingManager.getContinuationContext​(CannotProceedException cpe)
      创建一个上下文来继续上下文操作。
      static DirContext DirectoryManager.getContinuationDirContext​(CannotProceedException cpe)
      创建一个上下文，继续操作 DirContext 。

    • Uses of SuppressWarnings in javax.print

      Methods in javax.print with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static PrintService ServiceUI.printDialog​(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      向用户呈现一个对话框，用于选择打印服务（打印机）。

    • Uses of SuppressWarnings in javax.sound.midi

      Methods in javax.sound.midi with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      Map<String,Object> MidiFileFormat.properties​()
      获取不可修改的属性地图。

    • Uses of SuppressWarnings in javax.sound.sampled

      Methods in javax.sound.sampled with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      Map<String,Object> AudioFileFormat.properties​()
      获取不可修改的属性地图。
      Map<String,Object> AudioFormat.properties​()
      获取不可修改的属性地图。

    • Uses of SuppressWarnings in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeArray​(Array x)
      将Java编程语言中的一个 Array对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeAsciiStream​(InputStream x)
      向这个 SQLOutputImpl对象写入一串ASCII字符。
      void SQLOutputImpl.writeBigDecimal​(BigDecimal x)
      将Java编程语言中的一个 java.math.BigDecimal对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBinaryStream​(InputStream x)
      将一串未解释的字节写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBlob​(Blob x)
      将Java编程语言中的一个 Blob对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBoolean​(boolean x)
      将Java编程语言中的 boolean写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeByte​(byte x)
      将Java编程语言中的 byte写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeBytes​(byte[] x)
      将Java编程语言中的 bytes数组写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeCharacterStream​(Reader x)
      将Unicode字符串写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeClob​(Clob x)
      将Java编程语言中的 Clob对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeDate​(Date x)
      将Java编程语言中的 java.sql.Date对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeDouble​(double x)
      将Java编程语言中的 double写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeFloat​(float x)
      将Java编程语言中的 float写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeInt​(int x)
      将Java编程语言中的 int写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeLong​(long x)
      将Java编程语言中的 long写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeNClob​(NClob x)
      写入一个SQL NCLOB值到流。
      void SQLOutputImpl.writeNString​(String x)
      将下一个属性作为Java编程语言中的 String写入流。
      void SQLOutputImpl.writeObject​(SQLData x)
      向流中写入包含在给定的 SQLData对象中的数据。
      void SQLOutputImpl.writeRef​(Ref x)
      将Java编程语言中的一个 Ref对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeRowId​(RowId x)
      写入一个SQL ROWID值到流。
      void SQLOutputImpl.writeShort​(short x)
      将Java编程语言中的 short写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeSQLXML​(SQLXML x)
      向流中写入一个SQL XML值。
      void SQLOutputImpl.writeString​(String x)
      将Java编程语言中的 String写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeStruct​(Struct x)
      将Java编程语言中的一个 Struct对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeTime​(Time x)
      将Java编程语言中的一个 java.sql.Time对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeTimestamp​(Timestamp x)
      将Java编程语言中的一个 java.sql.Timestamp对象写入此 SQLOutputImpl对象。
      void SQLOutputImpl.writeURL​(URL url)
      将Java编程语言中的一个 java.sql.Type.DATALINK对象写入此 SQLOutputImpl对象。

    • Uses of SuppressWarnings in javax.swing

      Classes in javax.swing with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AbstractAction
      该类提供了JFC Action接口的默认实现。
      class  AbstractButton
      定义按钮和菜单项的常见行为。
      protected class  AbstractButton.AccessibleAbstractButton
      这个类实现 AbstractButton类的可访问性支持。
      protected class  AbstractButton.ButtonChangeListener
      扩展 ChangeListener可串行化。
      class  AbstractCellEditor
      CellEditors的基类，为 CellEditor接口中的方法提供默认实现，除了 getCellEditorValue() 。
      class  AbstractListModel<E>
      数据模型的抽象定义为其内容提供了一个 List 。
      class  AbstractSpinnerModel
      此类提供了SpinnerModel接口的ChangeListener部分，该接口应适用于大多数具体的SpinnerModel实现。
      class  ActionMap
      ActionMap提供从 Object s（称为 密钥或 Action名称 ）到 Action 。
      class  Box
      一个使用BoxLayout对象作为其布局管理器的轻量级容器。
      protected class  Box.AccessibleBox
      这个类实现 Box类的可访问性支持。
      static class  Box.Filler
      参与布局但没有视图的轻量级组件的实现。
      protected class  Box.Filler.AccessibleBoxFiller
      该类实现 Box.Filler类的可访问性支持。
      class  BoxLayout
      一个布局管理器，可以将多个组件垂直或水平放置。
      class  ButtonGroup
      此类用于为一组按钮创建多重排除范围。
      class  CellRendererPane
      此类插入到单元格渲染器和使用它们的组件之间。
      class  ComponentInputMap
      甲 ComponentInputMap是 InputMap与特定关联 JComponent 。
      class  DefaultBoundedRangeModel
      BoundedRangeModel的一般实现。
      class  DefaultButtonModel
      默认实现的一个 Button组件的数据模型。
      class  DefaultCellEditor
      表和树单元格的默认编辑器。
      class  DefaultComboBoxModel<E>
      组合框的默认模型。
      class  DefaultDesktopManager
      这是一个 DesktopManager的实现。
      class  DefaultFocusManager
      这个类已被1.4焦点API过时了。
      class  DefaultListCellRenderer
      渲染列表中的项目。
      static class  DefaultListCellRenderer.UIResource
      实现UIResource的DefaultListCellRenderer的子类。
      class  DefaultListModel<E>
      该类松散地实现了 java.util.Vector API，因为它实现了1.1.x版本的 java.util.Vector ，没有收集类支持，并在发生更改时通知 ListDataListener 。
      class  DefaultListSelectionModel
      列表选择的默认数据模型。
      class  DefaultSingleSelectionModel
      SingleSelectionModel的一般实现。
      class  ImageIcon
      从图像绘制图标的图标界面的实现。
      protected class  ImageIcon.AccessibleImageIcon
      这个类实现 ImageIcon类的可访问性支持。
      class  InputMap
      InputMap提供了输入事件（目前仅使用 KeyStroke s）和 Object 。
      class  JApplet
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。
      class  JButton
      实现“推”按钮。
      protected class  JButton.AccessibleJButton
      该类为 JButton类实现可访问性支持。
      class  JCheckBox
      复选框的实现 - 可以选择或取消选择的项目，并向用户显示其状态。
      protected class  JCheckBox.AccessibleJCheckBox
      这个类实现 JCheckBox类的可访问性支持。
      class  JCheckBoxMenuItem
      可以选择或取消选择的菜单项。
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      该类实现 JCheckBoxMenuItem类的可访问性支持。
      class  JColorChooser
      JColorChooser提供了一个设计用于允许用户操纵和选择颜色的控件窗格。
      class  JComboBox<E>
      组合按钮或可编辑字段和下拉列表的组件。
      protected class  JComboBox.AccessibleJComboBox
      这个类实现 JComboBox类的可访问性支持。
      class  JComponent
      除顶级容器之外的所有Swing组件的基类。
      class  JComponent.AccessibleJComponent
      JComponent的内部类用于为辅助功能提供默认支持。
      class  JDesktopPane
      用于创建多文档界面或虚拟桌面的容器。
      protected class  JDesktopPane.AccessibleJDesktopPane
      这个类实现 JDesktopPane类的可访问性支持。
      class  JDialog
      创建对话窗口的主要类。
      class  JEditorPane
      用于编辑各种内容的文本组件。
      protected class  JEditorPane.AccessibleJEditorPane
      该类实现 JEditorPane类的可访问性支持。
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      此类提供对 AccessibleHypertext支持，并且用于在此 EditorKit安装的 JEditorPane是 JEditorPane的实例的 HTMLEditorKit 。
      class  JFileChooser
      JFileChooser为用户提供了一种简单的选择文件的机制。
      protected class  JFileChooser.AccessibleJFileChooser
      这个类实现 JFileChooser类的可访问性支持。
      class  JFormattedTextField
      JFormattedTextField扩展 JTextField添加对格式化任意值的支持，以及一旦用户编辑文本，检索特定对象。
      class  JFrame
      扩展版本的 java.awt.Frame增加了对JFC / Swing组件架构的支持。
      class  JInternalFrame
      一个轻量级对象，提供了本机框架的许多功能，包括拖动，关闭，成为图标，调整大小，标题显示以及对菜单栏的支持。
      protected class  JInternalFrame.AccessibleJInternalFrame
      这个类实现 JInternalFrame类的可访问性支持。
      static class  JInternalFrame.JDesktopIcon
      该组件代表 JInternalFrame的图标化版本。
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      该类为 JInternalFrame.JDesktopIcon类实现可访问性支持。
      class  JLabel
      用于短文本字符串或图像的显示区域，或两者。
      protected class  JLabel.AccessibleJLabel
      该类用于获取此对象的可访问角色。
      class  JLayer<V extends Component>
      JLayer是用于Swing组件的通用装饰器，可以实现各种先进的绘画效果，并接收在其边框内生成的所有 AWTEvent的通知。
      class  JLayeredPane
      JLayeredPane增加了JFC / Swing容器的深度，允许组件在需要时重叠。
      protected class  JLayeredPane.AccessibleJLayeredPane
      该类为 JLayeredPane类实现可访问性支持。
      class  JList<E>
      显示对象列表并允许用户选择一个或多个项目的组件。
      protected class  JList.AccessibleJList
      这个类实现 JList类的可访问性支持。
      class  JMenu
      一个菜单的实现 - 一个包含 JMenuItem的弹出窗口，当用户在 JMenuBar上选择一个项目时 JMenuBar 。
      protected class  JMenu.AccessibleJMenu
      这个类实现 JMenu类的辅助功能支持。
      protected class  JMenu.WinListener
      监听一个弹出窗口关闭的监听器类。
      class  JMenuBar
      一个菜单栏的实现。
      protected class  JMenuBar.AccessibleJMenuBar
      这个类实现 JMenuBar类的可访问性支持。
      class  JMenuItem
      菜单中项目的实现。
      protected class  JMenuItem.AccessibleJMenuItem
      这个类实现 JMenuItem类的可访问性支持。
      class  JOptionPane
      JOptionPane可以方便地弹出一个标准对话框，提示用户获取值或通知他们某些东西。
      protected class  JOptionPane.AccessibleJOptionPane
      这个类实现 JOptionPane类的辅助功能支持。
      class  JPanel
      JPanel是一个通用的轻量级容器。
      protected class  JPanel.AccessibleJPanel
      该类为 JPanel类实现可访问性支持。
      class  JPasswordField
      JPasswordField是一个轻量级组件，允许编辑单行文本，其中视图表示某些内容是键入的，但不显示原始字符。
      class  JPopupMenu
      弹出菜单的一个实现 - 弹出一个小窗口并显示一系列选择。
      protected class  JPopupMenu.AccessibleJPopupMenu
      这个类实现 JPopupMenu类的可访问性支持。
      static class  JPopupMenu.Separator
      弹出菜单特定的分隔符。
      class  JProgressBar
      可视化显示某些任务进度的组件。
      protected class  JProgressBar.AccessibleJProgressBar
      这个类实现 JProgressBar类的可访问性支持。
      class  JRadioButton
      单选按钮的实现 - 可以选择或取消选择的项目，并将其状态显示给用户。
      protected class  JRadioButton.AccessibleJRadioButton
      这个类实现 JRadioButton类的可访问性支持。
      class  JRadioButtonMenuItem
      单选按钮菜单项的实现。
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      这个类实现 JRadioButtonMenuItem类的可访问性支持。
      class  JRootPane
      通过在后台使用一个轻量级容器 JFrame ， JDialog ， JWindow ， JApplet ，并 JInternalFrame 。
      protected class  JRootPane.AccessibleJRootPane
      这个类实现 JRootPane类的可访问性支持。
      protected class  JRootPane.RootLayout
      一个自定义布局管理器，负责分层面，玻璃面和菜单栏的布局。
      class  JScrollBar
      一个滚动条的实现。
      protected class  JScrollBar.AccessibleJScrollBar
      这个类实现 JScrollBar类的可访问性支持。
      class  JScrollPane
      提供轻量级组件的可滚动视图。
      protected class  JScrollPane.AccessibleJScrollPane
      该类为 JScrollPane类实现可访问性支持。
      protected class  JScrollPane.ScrollBar
      默认情况下， JScrollPane创建作为此类的实例的滚动条。
      class  JSeparator
      JSeparator提供了一种用于实现分割线的通用组件 - 通常用作将其分解为逻辑分组的菜单项之间的分隔符。
      protected class  JSeparator.AccessibleJSeparator
      这个类实现 JSeparator类的可访问性支持。
      class  JSlider
      允许用户通过在有界间隔内滑动旋钮图形地选择值的组件。
      protected class  JSlider.AccessibleJSlider
      该类为 JSlider类实现可访问性支持。
      class  JSpinner
      单行输入字段，允许用户从有序序列中选择一个数字或一个对象值。
      class  JSplitPane
      JSplitPane用于划分两个（只有两个） Component s。
      protected class  JSplitPane.AccessibleJSplitPane
      这个类实现 JSplitPane类的可访问性支持。
      class  JTabbedPane
      通过点击具有给定标题和/或图标的选项卡，用户可以在一组组件之间切换的组件。
      protected class  JTabbedPane.AccessibleJTabbedPane
      该类为 JTabbedPane类实现可访问性支持。
      class  JTable
      JTable用于显示和编辑单元格的常规二维表。
      protected class  JTable.AccessibleJTable
      该类实现 JTable类的可访问性支持。
      class  JTextArea
      A JTextArea是显示纯文本的多行区域。
      protected class  JTextArea.AccessibleJTextArea
      这个类实现 JTextArea类的辅助功能支持。
      class  JTextField
      JTextField是一个轻量级组件，允许编辑单行文本。
      protected class  JTextField.AccessibleJTextField
      这个类实现 JTextField类的可访问性支持。
      class  JTextPane
      可以用图形化的属性标记的文本组件。
      class  JToggleButton
      一个两状态按钮的实现。
      protected class  JToggleButton.AccessibleJToggleButton
      该类实现 JToggleButton类的可访问性支持。
      static class  JToggleButton.ToggleButtonModel
      ToggleButton模型
      class  JToolBar
      JToolBar提供了一个组件，可用于显示常用的 Action或控件。
      class  JToolTip
      用于显示组件的“提示”。
      protected class  JToolTip.AccessibleJToolTip
      这个类实现 JToolTip类的可访问性支持。
      class  JTree
      将一组分层数据显示为轮廓的控件。
      protected class  JTree.AccessibleJTree
      这个类实现 JTree类的可访问性支持。
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode可以包装向量/哈希表/数组/字符串，并根据需要创建适当的子树节点。
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel是一个 TreeSelectionModel ，不允许任何东西被选中。
      protected class  JTree.TreeSelectionRedirector
      手柄创建一个新的 TreeSelectionEvent与 JTree作为来源，并将其传递给所有的听众。
      class  JViewport
      您可以通过它查看基础信息的“视口”或“舷窗”。
      protected class  JViewport.AccessibleJViewport
      该类为 JViewport类实现可访问性支持。
      protected class  JViewport.ViewListener
      视图的监听器。
      class  JWindow
      A JWindow是可以在用户桌面上的任何位置显示的容器。
      protected class  JWindow.AccessibleJWindow
      这个类实现了 JWindow类的可访问性支持。
      class  KeyStroke
      KeyStroke表示键盘或等效输入设备上的关键操作。
      class  LayoutFocusTraversalPolicy
      一个SortingFocusTraversalPolicy，它根据大小，位置和方向对组件进行排序。
      class  OverlayLayout
      布局管理器将组件排列在彼此的顶部。
      class  ScrollPaneLayout
      由 JScrollPane使用的布局管理器。
      class  SizeRequirements
      为了方便布局管理器，计算有关组件的大小和位置的信息。
      class  SpinnerDateModel
      甲 SpinnerModel为序列 Date秒。
      class  SpinnerListModel
      SpinnerModel的简单实现，其值由数组或 List定义。
      class  SpinnerNumberModel
      A SpinnerModel用于数字序列。
      class  Spring
      Spring类的一个实例包含表征其行为的三个属性： 最小值 ， 首选值和 最大值 。
      class  SpringLayout
      A SpringLayout根据一组约束规定了其关联容器的子项。
      class  Timer
      以指定的间隔触发一个或多个 ActionEvent s。
      class  TransferHandler
      该类用于处理从Swing组件传送 Transferable 。
      class  UIDefaults
      Swing组件的默认表。
      class  UIManager
      UIManager管理目前的外观和感觉，一组可用的外观和感觉， PropertyChangeListeners ，当外观和感觉变化，外观和感觉默认值以及获取各种默认值的便利方法时通知。
      class  UnsupportedLookAndFeelException
      表示所请求的外观和感觉管理类的异常不在用户系统上。
      class  ViewportLayout
      默认布局管理器为 JViewport 。
      Methods in javax.swing with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      static MouseEvent SwingUtilities.convertMouseEvent​(Component source, MouseEvent sourceEvent, Component destination)
      返回类似于 sourceEvent的MouseEvent，但其x和y成员已转换为 destination的坐标系。
      static void SwingUtilities.convertPointFromScreen​(Point p, Component c)
      将一个点从屏幕坐标转换为组件的坐标系
      static void SwingUtilities.convertPointToScreen​(Point p, Component c)
      将点从组件的坐标系转换为屏幕坐标。
      static EditorKit JEditorPane.createEditorKitForContentType​(String type)
      从编辑器工具箱的默认注册表创建给定类型的处理程序。
      static LookAndFeel UIManager.createLookAndFeel​(String name)
      创建由给定的 L&F name名称指定的受支持的内置Java LookAndFeel 。
      protected void JComboBox.fireActionEvent​()
      通知所有在此事件类型上通知有兴趣的听众。
      protected void JFileChooser.fireActionPerformed​(String command)
      通知所有在此事件类型上通知有兴趣的听众。
      protected void JTextField.fireActionPerformed​()
      通知所有在此事件类型上通知有兴趣的听众。
      protected void JTabbedPane.fireStateChanged​()
      发送一个 ChangeEvent ，以这个 JTabbedPane作为源，给每个注册的听众。
      AccessibleContext JLayer.getAccessibleContext​()
      获取与此 JLayer相关联的AccessibleContext。
      JPopupMenu JComponent.getComponentPopupMenu​()
      返回分配给此组件的 JPopupMenu 。
      Dictionary JSlider.getLabelTable​()
      返回要在哪些值绘制哪些标签的字典。
      <T extends EventListener>
      T[]             		JComponent.getListeners​(Class<T> listenerType)
      返回此 JComponent当前注册为 FooListener的所有对象的数组。
      static Component SwingUtilities.getRoot​(Component c)
      返回当前组件树的根组件。
      String JList.getToolTipText​(MouseEvent event)
      返回用于给定事件的工具提示文本。
      Container JComponent.getTopLevelAncestor​()
      返回此组件的顶级祖先（包含 Window或 Applet ），如果此组件尚未添加到任何容器，则 null 。
      void | JInternalFrame.hide​()
      void Popup.hide​()
      隐藏和处置的 Popup 。
      boolean | JList.AccessibleJList.AccessibleJListChild.isFocusTraversable​()
      boolean | JTable.AccessibleJTable.AccessibleJTableCell.isFocusTraversable​()
      boolean | JTree.AccessibleJTree.AccessibleJTreeNode.isFocusTraversable​()
      Component JTable.prepareEditor​(TableCellEditor editor, int row, int column)
      准备通过在查询的单元格的值和选择状态数据模型中的编辑器 row ， column 。
      protected boolean JComponent.processKeyBinding​(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      调用以处理键绑定为 ks作为的结果 KeyEvent e 。
      static boolean SwingUtilities.processKeyBindings​(KeyEvent event)
      处理用于在所述键绑定 Component关联 event 。
      void JMenuItem.processKeyEvent​(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      处理从 MenuSelectionManager转发的密钥事件，并根据需要通过使用 MenuSelectionManager的API更改菜单选择。
      void JPopupMenu.processKeyEvent​(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      处理从 MenuSelectionManager转发的密钥事件，并根据需要通过使用 MenuSelectionManager的API更改菜单选项。
      void JMenuItem.processMouseEvent​(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      处理从 MenuSelectionManager转发的鼠标事件，如有必要，可以使用 MenuSelectionManager的API更改菜单选项。
      void MenuSelectionManager.processMouseEvent​(MouseEvent event)
      当MenuElement从MouseListener接收到一个事件时，它不应该直接处理该事件。
      protected void SwingWorker.publish​(V... chunks)
      发送数据块到 SwingWorker.process(java.util.List<V>)方法。
      void JTabbedPane.removeTabAt​(int index)
      删除标签 index 。
      void JInternalFrame.reshape​(int x, int y, int width, int height)
      移动并调整此组件的大小。
      void JViewport.reshape​(int x, int y, int w, int h)
      设置此视口的边界。
      void JEditorPane.scrollToReference​(String reference)
      将视图滚动到给定的参考位置（即，所显示的URL的 URL.getRef方法返回的值）。
      void JTabbedPane.setComponentAt​(int index, Component component)
      将组件设置为 index至 component 。
      void JSlider.setLabelTable​(Dictionary labels)
      用于指定在任何给定值下绘制什么标签。
      static void UIManager.setLookAndFeel​(String className)
      加载由给定的类名称指定的 LookAndFeel ，使用当前线程的上下文类加载器，并将其传递给 setLookAndFeel(LookAndFeel) 。
      void DefaultButtonModel.setPressed​(boolean b)
      将按钮设置为按下或未按下。
      void JToggleButton.ToggleButtonModel.setPressed​(boolean b)
      设置切换按钮的按下状态。
      void ProgressMonitor.setProgress​(int nv)
      指示正在监控的操作进度。
      void JInternalFrame.show​()
      如果内部框架不可见，将内部框架放在前面，使其可见，并尝试选择它。
      void Popup.show​()
      使 Popup可见。
      static Color JColorChooser.showDialog​(Component component, String title, Color initialColor, boolean colorTransparencySelectionEnabled)
      显示模态颜色选择器对话框并阻塞，直到对话框被隐藏。
      int JFileChooser.showDialog​(Component parent, String approveButtonText)
      使用自定义批准按钮弹出自定义文件选择器对话框。
      static Object JOptionPane.showInputDialog​(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      在阻止对话框中提示用户输入，可以指定初始选择，可能的选择和所有其他选项。
      static int JOptionPane.showOptionDialog​(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      启动具有指定图标的对话框，其中初始选择由 initialValue参数确定，选择次数由 optionType参数确定。
      Constructors in javax.swing with annotations of type SuppressWarnings
      Constructor 描述
      JTable​(Vector<? extends Vector> rowData, Vector<?> columnNames)
      构造一个 JTable以显示的值 Vector的 Vectors ， rowData ，其列名称为 columnNames 。
      SpinnerNumberModel​(Number value, Comparable<?> minimum, Comparable<?> maximum, Number stepSize)
      构造一个 SpinnerModel ，表示从 minimum到 maximum的封闭序列。

    • Uses of SuppressWarnings in javax.swing.border

      Classes in javax.swing.border with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AbstractBorder
      实现无大小空白边框的类。
      class  BevelBorder
      一个实现一个简单的两行斜角边框的类。
      class  CompoundBorder
      一个复合的Border类，用于通过在Border对象的外部嵌套内嵌一个Border对象来将两个Border对象组合成一个单一的边框。
      class  EmptyBorder
      一个提供一个空的透明边框的类，占用空间但不绘图。
      class  EtchedBorder
      一个实现一个简单蚀刻边界的课程，可以被蚀刻或蚀刻出来。
      class  LineBorder
      实现任意厚度和单一颜色的线边框的类。
      class  MatteBorder
      一个提供纯色或平铺图标的无光泽边框的课程。
      class  SoftBevelBorder
      实现具有软化拐角的凸起或降低的斜面的课程。
      class  StrokeBorder
      实现任意笔画边框的课程。
      class  TitledBorder
      一个实现一个任意边框的类，在一个指定的位置添加一个String标题和对齐。

    • Uses of SuppressWarnings in javax.swing.colorchooser

      Classes in javax.swing.colorchooser with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AbstractColorChooserPanel
      这是颜色选择器的抽象超类。
      class  ColorChooserComponentFactory
      一个设计用于生产预配置的“附件”对象以插入到颜色选择器中的类。
      class  DefaultColorSelectionModel
      通用实现 ColorSelectionModel 。

    • Uses of SuppressWarnings in javax.swing.event

      Classes in javax.swing.event with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AncestorEvent
      向组件层级中的祖先发送的子组件的事件。
      class  CaretEvent
      CaretEvent用于通知有关方面事件源文本插入符已更改。
      class  ChangeEvent
      ChangeEvent用于通知有关方面事件来源状态已更改。
      class  EventListenerList
      一个持有EventListener列表的类。
      class  HyperlinkEvent
      HyperlinkEvent用于通知有关方面，超文本链接发生了一些事情。
      class  InternalFrameEvent
      一个 AWTEvent添加了对 JInternalFrame对象的支持作为事件源。
      class  ListDataEvent
      定义将更改封装到列表的事件。
      class  ListSelectionEvent
      表征选择变化的事件。
      class  MenuDragMouseEvent
      MenuDragMouseEvent用于通知有关方面，菜单元素已经在拖动条件下接收到转发给它的MouseEvent。
      class  MenuEvent
      MenuEvent用于通知有关方面，事件源的菜单已经过滤，选择或取消。
      class  MenuKeyEvent
      MenuKeyEvent用于通知有关方菜单元素已经在菜单树中收到转发给它的KeyEvent。
      class  PopupMenuEvent
      PopupMenuEvent仅包含发送事件的JPopupMenu事件的源
      class  RowSorterEvent
      RowSorterEvent提供改变到的通知 RowSorter 。
      class  TableColumnModelEvent
      TableColumnModelEvent用于通知侦听器表列模型已更改，例如添加，删除或移动列。
      class  TableModelEvent
      TableModelEvent用于通知侦听器表模型已更改。
      class  TreeExpansionEvent
      用于标识树中单个路径的事件。
      class  TreeModelEvent
      将描述更改的信息封装到树模型，并用于通知树型模型侦听器的更改。
      class  TreeSelectionEvent
      表示当前选择的变化的事件。
      class  UndoableEditEvent
      发生可以撤消的操作的事件。

    • Uses of SuppressWarnings in javax.swing.plaf

      Classes in javax.swing.plaf with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  ActionMapUIResource
      实现UIResource的javax.swing.ActionMap的子类。
      class  BorderUIResource
      实现UIResource的边界包装类。
      class  ColorUIResource
      实现UIResource的Color子类。
      class  ComponentInputMapUIResource
      实现UIResource的javax.swing.ComponentInputMap的子类。
      class  DimensionUIResource
      Dimension一个子类，实现 UIResource 。
      class  FontUIResource
      实现UIResource的java.awt.Font的子类。
      class  IconUIResource
      一个实现UIResource的图标包装类。
      class  InputMapUIResource
      实现UIResource的javax.swing.InputMap的子类。
      class  InsetsUIResource
      Insets实现UIResource的子类。
      class  LayerUI<V extends Component>
      所有JLayer的UI代表的基类。
      Methods in javax.swing.plaf with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      boolean ComponentUI.contains​(JComponent c, int x, int y)
      如果指定的 x，y位置包含在指定组件的外观和定义的形状内 ，则返回 true 。

    • Uses of SuppressWarnings in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  BasicArrowButton
      JButton对象在其中一个主要方向上绘制了一个缩放的箭头。
      static class  BasicBorders.ButtonBorder
      画一个按钮周围的边框。
      static class  BasicBorders.FieldBorder
      绘制一个字段周围的边框。
      static class  BasicBorders.MarginBorder
      围绕支持边距的组件绘制边框。
      static class  BasicBorders.MenuBarBorder
      绘制菜单栏周围的边框。
      static class  BasicBorders.RadioButtonBorder
      绘制单选按钮周围的边框。
      static class  BasicBorders.RolloverButtonBorder
      特殊的细边框，用于翻转工具栏按钮。
      static class  BasicBorders.ToggleButtonBorder
      绘制切换按钮周围的边框。
      class  BasicCheckBoxUI
      BasicCheckboxUI的CheckboxUI实现
      static class  BasicComboBoxEditor.UIResource
      BasicComboBoxEditor的子类实现UIResource。
      class  BasicComboBoxRenderer
      ComboBox渲染器
      static class  BasicComboBoxRenderer.UIResource
      BasicComboBoxRenderer的子类实现UIResource。
      class  BasicComboPopup
      这是 ComboPopup接口的基本实现。
      protected class  BasicDesktopPaneUI.CloseAction
      处理关闭内部框架。
      protected class  BasicDesktopPaneUI.MaximizeAction
      处理最大化内部框架。
      protected class  BasicDesktopPaneUI.MinimizeAction
      处理最小化内部框架。
      protected class  BasicDesktopPaneUI.NavigateAction
      处理导航到下一个内部框架。
      protected class  BasicDesktopPaneUI.OpenAction
      处理恢复最小化或最大化的内部框架。
      class  BasicDirectoryModel
      文件列表的基本实现。
      class  BasicEditorPaneUI
      为JEditorPane提供外观和感觉。
      protected class  BasicFileChooserUI.ApproveSelectionAction
      响应打开或保存请求
      protected class  BasicFileChooserUI.CancelSelectionAction
      回复取消请求。
      protected class  BasicFileChooserUI.ChangeToParentDirectoryAction
      更改为父目录操作。
      protected class  BasicFileChooserUI.GoHomeAction
      在“家”键事件或等效事件上行事。
      protected class  BasicFileChooserUI.NewFolderAction
      创建一个新文件夹。
      protected class  BasicFileChooserUI.UpdateAction
      重新扫描当前目录中的文件
      class  BasicIconFactory
      工厂对象可以将图标适用于基本的L＆F
      class  BasicInternalFrameTitlePane
      管理基本标题栏的类
      class  BasicInternalFrameTitlePane.SystemMenuBar
      这个类应该被视为一个“受保护”的内部类。
      class  BasicListUI.ListDataHandler
      该 ListDataListener被添加到 JLists型号在 installUI time ，并且每当JList.model属性更改。
      class  BasicListUI.ListSelectionHandler
      在installUI时添加到JLists选择模型的ListSelectionListener，以及JList.selectionModel属性更改时。
      class  BasicListUI.MouseInputHandler
      鼠标输入和JList的焦点处理。
      class  BasicListUI.PropertyChangeHandler
      在InstallUI时添加到JList的PropertyChangeListener。
      class  BasicLookAndFeel
      用于创建Swing的外观的基础类。
      class  BasicSliderUI.ActionScroller
      从Java 2平台v1.3开始，这个未记录的类就不再使用了。
      class  BasicSplitPaneDivider
      BasicSplitPaneUI使用的分隔符。
      protected class  BasicSplitPaneDivider.DragController
      在针对HORIZONTAL_SPLIT的拆分窗格的拖动会话期间处理事件。
      class  BasicTextAreaUI
      提供纯文本编辑器的外观和感觉。
      class  BasicTextFieldUI
      JTextField的外观和感觉的基础。
      class  BasicTextPaneUI
      为风格的文本编辑器提供外观和感觉。
      class  BasicTextUI
      文本元素的外观和感觉的基础。
      protected class  BasicToolBarUI.DragWindow
      在拖动 JToolBar期间出现的窗口。
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener在执行操作时调用cancelEditing。
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction用于处理结束/ home操作。
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction用于处理上/下动作。
      class  BasicTreeUI.TreePageAction
      TreePageAction处理页面向上和向下翻页事件。
      class  BasicTreeUI.TreeToggleAction
      对于第一个选定的行展开将被切换。
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction是用于左/右键的动作。
      interface  ComboPopup
      定义实现组合框的弹出部分所需的方法的界面。
      class  DefaultMenuLayout
      弹出菜单和菜单栏的默认布局管理器。
      Methods in javax.swing.plaf.basic with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      protected void BasicTreeUI.completeEditing​(boolean messageStop, boolean messageCancel, boolean messageTree)
      停止编辑会话。
      protected Component BasicSplitPaneUI.createDefaultNonContinuousLayoutDivider​()
      返回默认的非连续布局分隔符，这是一个 Canvas的实例，用灰色填充背景。
      protected void BasicToolBarUI.dragTo​(Point position, Point origin)
      该方法是用来拖动 DragWindow在 JToolBar被拖动。
      String BasicTextUI.getToolTipText​(JTextComponent t, Point pt)
      返回要用作传入位置的工具提示的字符串。
      void BasicComboPopup.hide​()
      实现ComboPopup.hide（）。
      protected void BasicSplitPaneUI.installDefaults​()
      安装UI默认值。
      boolean BasicArrowButton.isFocusTraversable​()
      返回箭头按钮是否应该获得焦点。
      boolean BasicComboPopup.isFocusTraversable​()
      覆盖无条件返回假。
      boolean | BasicPopupMenuUI.isPopupTrigger​(MouseEvent e)
      void BasicTabbedPaneUI.TabbedPaneLayout.layoutContainer​(Container parent)
      放出指定的容器。
      void | BasicInternalFrameUI.BorderListener.mouseDragged​(MouseEvent e)
      protected void BasicToolBarUI.navigateFocusedComp​(int direction)
      浏览关注的组件。
      void BasicToolBarUI.setFloating​(boolean b, Point p)
      设置浮动属性。
      void BasicComboPopup.show​()
      实现ComboPopup.show（）。

    • Uses of SuppressWarnings in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal with annotations of type SuppressWarnings
      Modifier and Type | Class | 描述
      class  DefaultMetalTheme
      具体实现了 MetalTheme提供了Java Look and Feel的原创外观，代号为“Steel”。
      static class  MetalBorders.ButtonBorder
      该类代表 JButton的边界。
      static class  MetalBorders.Flush3DBorder
      该类代表3D边框。
      static class  MetalBorders.InternalFrameBorder
      该类代表一个 JInternalFrame的边界。
      static class  MetalBorders.MenuBarBorder
      该类代表一个 JMenuBar的边界。
      static class  MetalBorders.MenuItemBorder
      该类代表一个 JMenuItem的边界。
      static class  MetalBorders.OptionDialogBorder
      该类表示选项对话框的边框。
      static class  MetalBorders.PaletteBorder
      边框的调色板。
      static class  MetalBorders.PopupMenuBorder
      该类代表 JPopupMenu的边界。
      static class  MetalBorders.RolloverButtonBorder
      该类代表翻转的边界 Button 。
      static class  MetalBorders.ScrollPaneBorder
      该类代表 JScrollPane的边界。
      static class  MetalBorders.TableHeaderBorder
      表头的边框
      static class  MetalBorders.TextFieldBorder
      该类代表一个 JTestField的边界。
      static class  | MetalBorders.ToggleButtonBorder
      static class  MetalBorders.ToolBarBorder
      该类代表一个 JToolBar的边界。
      class  MetalButtonUI
      MetalButtonUI实现
      class  MetalCheckBoxIcon
      OrganicCheckBoxUI的CheckboxIcon实现
      class  MetalCheckBoxUI
      MetalCheckboxUI的CheckboxUI实现
      class  MetalComboBoxButton
      JButton子类来帮助MetalComboBoxUI
      class  MetalComboBoxEditor
      Metal可编辑组合框的默认编辑器
      static class  MetalComboBoxEditor.UIResource
      BasicComboBoxEditor的子类实现UIResource。
      class  MetalComboBoxIcon
      此实用程序类绘制指示MetalComboBox的水平条
      class  MetalComboBoxUI
      JComboBox的金属UI
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      当DirectoryComboBox更改所选项目时使用。
      protected class  MetalFileChooserUI.DirectoryComboBoxModel
      类型面部选择组合框的数据模型。
      protected class  MetalFileChooserUI.FileRenderer
      已过时。
      截至JDK版本9.过时的课程。
      protected class  MetalFileChooserUI.FilterComboBoxModel
      类型面部选择组合框的数据模型。
      class  MetalFileChooserUI.FilterComboBoxRenderer
      渲染不同类型的尺寸和样式。
      class  MetalIconFactory
      工厂对象为Java“¢”外观（金属）提供 Icon秒。
      static class  MetalIconFactory.FileIcon16
      警告：此类的序列化对象与将来的Swing版本不兼容。
      static class  MetalIconFactory.FolderIcon16
      警告：此类的序列化对象与将来的Swing版本不兼容。
      static class  MetalIconFactory.TreeControlIcon
      警告：此类的序列化对象与将来的Swing版本不兼容。
      static class  MetalIconFactory.TreeFolderIcon
      警告：此类的序列化对象与将来的Swing版本不兼容。
      class  MetalInternalFrameTitlePane
      管理JLF标题栏的类
      class  MetalLookAndFeel
      Java外观和感觉，也称为金属。
      class  MetalProgressBarUI
      ProgressBarUI的Metal实现。
      class  MetalRadioButtonUI
      MetalBadtonButtonUI的RadioButtonUI实现
      class  MetalRootPaneUI
      提供 RootPaneUI的金属外观和实现。
      class  MetalScrollButton
      金属滚动条箭头的JButton对象。
      class  MetalScrollPaneUI
      ScrollPaneUI的金属L＆F实现。
      class  MetalSeparatorUI
      SeparatorUI的金属L＆F实现。
      class  MetalSliderUI
      SliderUI的Java L＆F实现。
      class  MetalSplitPaneUI
      金属分割窗格。
      class  MetalTabbedPaneUI
      BasicTabbedPaneUI的Metal子类。
      class  MetalTextFieldUI
      JTextField的外观和感觉的基础。
      class  MetalToggleButtonUI
      MetalToggleButton实现
      class  MetalToolTipUI
      BasicToolTipUI的金属L＆F扩展。
      class  OceanTheme
      默认主题为 MetalLookAndFeel 。
      Methods in javax.swing.plaf.metal with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      String MetalToolTipUI.getAcceleratorString​()
      返回加速器字符串。
      boolean | MetalComboBoxButton.isFocusTraversable​()

    • Uses of SuppressWarnings in javax.swing.plaf.multi

      Classes in javax.swing.plaf.multi with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  MultiLookAndFeel
      复用外观和感觉，允许多个UI同时与组件相关联。
      Methods in javax.swing.plaf.multi with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      String MultiTextUI.getToolTipText​(JTextComponent a, Point b)
      在此对象处理的每个UI上调用 getToolTipText方法。

    • Uses of SuppressWarnings in javax.swing.plaf.nimbus

      Classes in javax.swing.plaf.nimbus with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  NimbusLookAndFeel
      NimbusLookAndFeel类。

    • Uses of SuppressWarnings in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  SynthLookAndFeel
      SynthLookAndFeel提供了创建自定义外观的基础。
      class  SynthTextAreaUI
      为Synth的外观和感觉提供纯文本编辑器的外观和感觉。
      class  SynthTextFieldUI
      为JTextField提供Synth L＆F UI代表。
      class  SynthTextPaneUI
      为Synth外观和风格的样式文本编辑器提供外观和感觉。
      Methods in javax.swing.plaf.synth with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      protected Component SynthSplitPaneUI.createDefaultNonContinuousLayoutDivider​()
      返回默认的非连续布局分隔符，这是一个 Canvas的实例，用灰色填充背景。
      protected void SynthSplitPaneUI.installDefaults​()
      安装UI默认值。

    • Uses of SuppressWarnings in javax.swing.table

      Classes in javax.swing.table with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AbstractTableModel
      这个抽象类为 TableModel界面中的大多数方法提供了默认实现。
      class  DefaultTableCellRenderer
      在 JTable渲染（显示）单个单元格的标准类。
      static class  DefaultTableCellRenderer.UIResource
      实现 UIResource的 DefaultTableCellRenderer的子类。
      class  DefaultTableColumnModel
      JTable的标准列处理程序。
      class  DefaultTableModel
      这是 TableModel一个实现，它使用 Vector的 Vectors来存储单元格值对象。
      class  JTableHeader
      这是管理 JTable的标题的 JTable 。
      protected class  JTableHeader.AccessibleJTableHeader
      该类实现 JTableHeader类的可访问性支持。
      class  TableColumn
      甲 TableColumn表示在所述列的所有属性 JTable ，诸如宽度，可调整大小，最小和最大宽度。
      Fields in javax.swing.table with annotations of type SuppressWarnings
      Modifier and Type Field 描述
      protected Vector DefaultTableModel.columnIdentifiers
      Vector的列标识符。
      protected Vector<Vector> DefaultTableModel.dataVector
      Vector的 Vectors的 Object值。
      Methods in javax.swing.table with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      void DefaultTableModel.addColumn​(Object columnName, Vector<?> columnData)
      向模型添加一列。
      Vector<Vector> DefaultTableModel.getDataVector​()
      返回包含表的数据值的 Vector的 Vectors 。
      String JTableHeader.getToolTipText​(MouseEvent event)
      允许渲染器的提示被使用，如果有文本集。
      boolean | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.isFocusTraversable​()
      void DefaultTableModel.setDataVector​(Vector<? extends Vector> dataVector, Vector<?> columnIdentifiers)
      用新的 Vector行替代当前的 dataVector实例变量， dataVector 。
      Constructors in javax.swing.table with annotations of type SuppressWarnings
      Constructor 描述
      DefaultTableModel​(Vector<? extends Vector> data, Vector<?> columnNames)
      构造一个 DefaultTableModel并通过将 data和 columnNames通过 setDataVector方法初始化表。

    • Uses of SuppressWarnings in javax.swing.text

      Classes in javax.swing.text with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AbstractDocument
      实现文档界面，作为实施各种文件的基础。
      class  AbstractDocument.AbstractElement
      实现元素的抽象部分。
      class  AbstractDocument.BranchElement
      实现一个包含其他元素的复合元素。
      class  AbstractDocument.LeafElement
      实现直接表示某种内容的元素。
      class  BadLocationException
      此异常是报告文档模型中的不良位置（即尝试引用不存在的位置）。
      class  ChangedCharSetException
      ChangedCharSetException作为名称指示是在更改字符集时抛出的异常。
      class  DateFormatter
      DateFormatter是一个 InternationalFormatter ，它通过 java.text.DateFormat的实例进行 java.text.DateFormat 。
      class  DefaultCaret
      默认的Caret实现。
      class  DefaultEditorKit
      这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。
      static class  DefaultEditorKit.BeepAction
      发出哔声
      static class  DefaultEditorKit.CopyAction
      复制所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.CutAction
      剪切所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.DefaultKeyTypedAction
      如果接收到 键入类型的事件并且没有键映射条目，则默认执行的操作。
      static class  DefaultEditorKit.InsertBreakAction
      在文档中放置一个行/段落。
      static class  DefaultEditorKit.InsertContentAction
      将内容放入相关的文档。
      static class  DefaultEditorKit.InsertTabAction
      将标签字符放在文档中。
      static class  DefaultEditorKit.PasteAction
      将系统剪贴板的内容粘贴到所选区域中，或者如果没有选择任何内容，则将其插入插入符号之前。
      class  DefaultFormatter
      DefaultFormatter格式化任意对象。
      class  DefaultFormatterFactory
      执行 JFormattedTextField.AbstractFormatterFactory 。
      class  DefaultStyledDocument
      可以以与RTF格式相似的方式标记字符和段落样式的文档。
      class  DefaultStyledDocument.ElementBuffer
      用于管理元素层次结构更改的类。
      static class  DefaultStyledDocument.ElementSpec
      建筑元素规范。
      protected class  DefaultStyledDocument.SectionElement
      文档的默认根元素...映射包含的段落/行。
      class  EditorKit
      将文本组件所需的一组事物建立为某种 类型的文本内容的合理功能的编辑器。
      class  GapContent
      AbstractDocument.Content接口的实现使用与emacs使用的类似的间隙缓冲区来实现。
      class  InternationalFormatter
      InternationalFormatter延伸 DefaultFormatter ，使用的实例 java.text.Format来处理转换为字符串，并从字符串的转换。
      class  JTextComponent
      JTextComponent是swing文本组件的基类。
      class  JTextComponent.AccessibleJTextComponent
      这个类实现 JTextComponent类的可访问性支持。
      static class  JTextComponent.KeyBinding
      用于创建密钥绑定的绑定记录。
      class  MaskFormatter
      MaskFormatter用于格式化和编辑字符串。
      class  NumberFormatter
      NumberFormatter子类 InternationalFormatter增加了数字的特殊行为。
      class  PlainDocument
      一个不保留字符属性的简单文档。
      class  SimpleAttributeSet
      使用哈希表直接实现MutableAttributeSet。
      class  StringContent
      AbstractDocument.Content接口的实现是一种强大的强制实现，对于较小的文档和/或调试很有用。
      class  StyleContext
      一组风格及其相关资源。
      class  StyleContext.NamedStyle
      属性集合，通常用于表示字符和段落样式。
      class  StyledEditorKit
      这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。
      static class  StyledEditorKit.AlignmentAction
      设置段落对齐的动作。
      static class  StyledEditorKit.BoldAction
      用于切换粗体属性的操作。
      static class  StyledEditorKit.FontFamilyAction
      在关联的JEditorPane中设置字体系列的操作。
      static class  StyledEditorKit.FontSizeAction
      在关联的JEditorPane中设置字体大小的操作。
      static class  StyledEditorKit.ForegroundAction
      设置前景色的动作。
      static class  StyledEditorKit.ItalicAction
      切换斜体属性的动作。
      static class  StyledEditorKit.StyledTextAction
      一个假定它被安装在一个带有StyledEditorKit（或子类）的JEditorPane上被触发的动作。
      static class  StyledEditorKit.UnderlineAction
      切换下划线属性的动作。
      class  TabSet
      TabSet由许多TabStops组成。
      class  TabStop
      这个类封装了一个制表符停止（基本上就是标签停止被RTF认为）。
      class  TextAction
      对于跨多个不同文本组件共享的键绑定的Action实现。
      Methods in javax.swing.text with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      protected int WrappedPlainView.calculateBreakPosition​(int p0, int p1)
      这被嵌套的包装线视图调用来确定断点位置。
      Object SimpleAttributeSet.clone​()
      克隆一组属性。
      protected int ParagraphView.getClosestPositionTo​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
      返回最接近的模型位置为 x 。
      FontMetrics StyleContext.getFontMetrics​(Font f)
      返回字体的字体指标。
      protected int ParagraphView.getNextNorthSouthVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      返回光标的下一个视觉位置，以东或西方向。
      int View.getNextVisualPositionFrom​(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      提供一种方法来确定下一个可视表示的模型位置，在该位置可以放置插入符。
      protected Vector GapContent.getPositionsInRange​(Vector v, int offset, int length)
      返回一个Vector，其中包含UndoPosRef的实例，其位置范围为 offset至 offset + length 。
      protected Vector StringContent.getPositionsInRange​(Vector v, int offset, int length)
      返回一个Vector，其中包含UndoPosRef的实例，其位置范围为 offset至 offset + length 。
      float FieldView.getPreferredSpan​(int axis)
      确定沿着轴的此视图的首选跨度。
      static int Utilities.getRowEnd​(JTextComponent c, int offs)
      确定包含指定模型位置的行的结束行模型位置。
      static int Utilities.getRowStart​(JTextComponent c, int offs)
      确定包含指定模型位置的行的起始行模型位置。
      String JTextComponent.getToolTipText​(MouseEvent event)
      返回要用作 event的工具提示的 event 。
      Shape PlainView.modelToView​(int pos, Shape a, Position.Bias b)
      提供从文档模型坐标空间映射到映射到它的视图的坐标空间的映射。
      void DefaultCaret.mouseClicked​(MouseEvent e)
      当鼠标点击时调用。
      protected void DefaultCaret.moveCaret​(MouseEvent e)
      尝试使用viewToModel（）从鼠标事件的坐标移动插入符的位置。
      void DefaultCaret.paint​(Graphics g)
      将插入符号作为垂直线。
      void DefaultHighlighter.DefaultHighlightPainter.paint​(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c)
      画亮点
      protected void DefaultCaret.positionCaret​(MouseEvent e)
      尝试使用viewToModel（）从鼠标事件的坐标设置插入符号的位置。
      protected void | JTextComponent.processInputMethodEvent​(InputMethodEvent e)
      void DefaultCaret.setVisible​(boolean e)
      设置插入符的可见性，并重新绘制插入符号。
      protected void GapContent.updateUndoPositions​(Vector positions, int offset, int length)
      重置 positions所有UndoPosRef实例的 positions 。
      protected void StringContent.updateUndoPositions​(Vector positions)
      重置 positions所有UndoPosRef实例的 positions 。

    • Uses of SuppressWarnings in javax.swing.text.html

      Classes in javax.swing.text.html with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  CSS
      将一组 CSS attributes定义为类型安全枚举。
      class  FormSubmitEvent
      FormSubmitEvent用于通知有关方面提交表单。
      static class  HTML.UnknownTag
      类代表未知的HTML标签。
      class  HTMLDocument
      建立HTML的文档。
      class  HTMLEditorKit
      Swing JEditorPane文本组件通过称为EditorKit的插件机制来支持不同类型的内容。
      static class  HTMLEditorKit.HTMLTextAction
      一个抽象的Action提供了一些方便的方法，可能有助于将HTML插入到现有文档中。
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction可用于将HTML的任意字符串插入到现有的HTML文档中。
      static class  HTMLEditorKit.LinkController
      在适当的时候，类可以观看相关组件并在其上触发超链接事件。
      class  HTMLFrameHyperlinkEvent
      HTMLFrameHyperlinkEvent用于通知相关方链接已在一帧中激活。
      class  Option
      用于表示<option>元素的ListModel的值。
      class  StyleSheet
      支持定义正在渲染的HTML视图的视觉特征。
      static class  StyleSheet.BoxPainter
      课程执行CSS格式的一些职责。
      static class  StyleSheet.ListPainter
      课程执行CSS列表格式的一些职责。
      Methods in javax.swing.text.html with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      protected Component ObjectView.createComponent​()
      创建组件。
      void HTMLEditorKit.LinkController.mouseClicked​(MouseEvent e)
      被称为鼠标点击事件。
      void | HTMLEditorKit.LinkController.mouseMoved​(MouseEvent e)

    • Uses of SuppressWarnings in javax.swing.text.html.parser

      Classes in javax.swing.text.html.parser with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AttributeList
      该类使用ATTLIST构造在DTD中描述了SGML元素的属性。
      class  ContentModel
      内容模型的表示。
      class  Element
      使用ELEMENT构造在DTD中描述的元素。
      class  ParserDelegator
      每次调用它的解析方法时，负责启动一个新的DocumentParser。

    • Uses of SuppressWarnings in javax.swing.text.rtf

      Classes in javax.swing.text.rtf with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  RTFEditorKit
      这是RTF编辑功能的默认实现。

    • Uses of SuppressWarnings in javax.swing.tree

      Classes in javax.swing.tree with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AbstractLayoutCache
      警告：此类的序列化对象与将来的Swing版本不兼容。
      class  DefaultMutableTreeNode
      A DefaultMutableTreeNode是树状数据结构中的通用节点。
      class  DefaultTreeCellEditor.DefaultTextField
      TextField未提供编辑器时使用。
      class  DefaultTreeCellEditor.EditorContainer
      集装箱负责放置 editingComponent 。
      class  DefaultTreeCellRenderer
      在树中显示一个条目。
      class  DefaultTreeModel
      一个使用TreeNodes的简单树数据模型。
      class  DefaultTreeSelectionModel
      TreeSelectionModel的默认实现。
      class  ExpandVetoException
      用于阻止扩展/崩溃的异常发生。
      class  FixedHeightLayoutCache
      注意：在将来的版本中这将变得更加开放。
      class  TreePath
      TreePath表示唯一标识树中某个节点的路径的对象数组。
      class  VariableHeightLayoutCache
      注意：在将来的版本中这将变得更加开放。

    • Uses of SuppressWarnings in javax.swing.undo

      Classes in javax.swing.undo with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  AbstractUndoableEdit
      UndoableEdit的抽象实现， UndoableEdit接口中的所有布尔方法执行简单的响应。
      class  CannotRedoException
      抛出一个UndoableEdit被告知 redo()并且不能。
      class  CannotUndoException
      抛出一个UndoableEdit被告知 undo()并且不能。
      class  CompoundEdit
      AbstractUndoableEdit的一个具体子类，用于将小的UndoableEdits组合成大型的。
      class  StateEdit
      StateEdit是更改状态的对象的一般编辑。
      class  UndoManager
      UndoManager管理列表 UndoableEdits ，提供了一种方法来撤消或恢复适当的编辑。

    • Uses of SuppressWarnings in javax.transaction

      Classes in javax.transaction with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  InvalidTransactionException
      此异常表示请求携带无效的事务上下文。
      class  TransactionRequiredException
      此异常指示请求携带空事务上下文，但目标对象需要激活事务。
      class  TransactionRolledbackException
      此异常表示与请求的处理关联的事务已回滚，或标记为回滚。

    • Uses of SuppressWarnings in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static MethodHandle Guards.isArray​(int pos, MethodType type)
      创建方法句柄，如果指定位置的参数是Java数组，则返回true。
      static MethodHandle Guards.isInstance​(Class<?> clazz, int pos, MethodType type)
      使用指定类型的参数创建方法句柄，但使用布尔值返回值。
      static MethodHandle Guards.isOfClass​(Class<?> clazz, MethodType type)
      使用指定类型的参数创建一个保护方法句柄，但使用布尔返回值。

    • Uses of SuppressWarnings in jdk.jshell

      Classes in jdk.jshell with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  EvalException
      封装在远程执行客户机中抛出的异常。
      class  JShellException
      JShell的超类生成异常
      class  UnresolvedReferenceException
      报告了尝试执行一个 RECOVERABLE_DEFINED片段的异常。

    • Uses of SuppressWarnings in jdk.jshell.execution

      Methods in jdk.jshell.execution with annotations of type SuppressWarnings
      Modifier and Type | 方法 | 描述
      void | LocalExecutionControl.stop​()

    • Uses of SuppressWarnings in jdk.jshell.spi

      Classes in jdk.jshell.spi with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  SPIResolutionException
      该异常的构造和抛出嵌入在JShell核心实现中生成的代码中，使得在执行 RECOVERABLE_DEFINED用户方法时，会抛出此异常。

    • Uses of SuppressWarnings in jdk.nashorn.api.scripting

      Classes in jdk.nashorn.api.scripting with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  NashornException
      这是所有Nashorn异常的基础例外。

    • Uses of SuppressWarnings in netscape.javascript

      Classes in netscape.javascript with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  JSObject
      允许Java代码来操纵JavaScript对象。
      Methods in netscape.javascript with annotations of type SuppressWarnings
      Modifier and Type 方法 描述
      static JSObject JSObject.getWindow​(Applet applet)
      已过时。
      Applet API已被弃用。 有关详细信息，请参阅java.applet package documentation 。

    • Uses of SuppressWarnings in org.xml.sax.helpers

      Classes in org.xml.sax.helpers with annotations of type SuppressWarnings
      Modifier and Type Class 描述
      class  ParserFactory
      已过时。
      此类与已弃用的Parser接口配合使用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.System (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.System

No usage of java.lang.System
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.System.Logger.Level (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.System.Logger.Level

  • Packages that use System.Logger.Level
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of System.Logger.Level in java.lang

      Methods in java.lang that return System.Logger.Level
      Modifier and Type 方法 描述
      static System.Logger.Level System.Logger.Level.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static System.Logger.Level[] System.Logger.Level.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.lang with parameters of type System.Logger.Level
      Modifier and Type 方法 描述
      boolean System.Logger.isLoggable​(System.Logger.Level level)
      检查该记录器是否记录给定级别的消息。
      default void System.Logger.log​(System.Logger.Level level, Object obj)
      记录从给定对象生成的消息。
      default void System.Logger.log​(System.Logger.Level level, String msg)
      记录消息。
      default void System.Logger.log​(System.Logger.Level level, String format, Object... params)
      使用可选参数列表记录消息。
      default void System.Logger.log​(System.Logger.Level level, String msg, Throwable thrown)
      记录与给定的可抛弃关联的消息。
      default void System.Logger.log​(System.Logger.Level level, Supplier<String> msgSupplier)
      记录一个懒惰的提供的消息。
      default void System.Logger.log​(System.Logger.Level level, Supplier<String> msgSupplier, Throwable thrown)
      记录与给定的可抛物线相关联的延迟提供的消息。
      void System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String format, Object... params)
      使用资源束和可选的参数列表记录消息。
      void System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String msg, Throwable thrown)
      记录与给定的可抛物线相关联的本地化消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.System.LoggerFinder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.System.LoggerFinder

  • Packages that use System.LoggerFinder
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of System.LoggerFinder in java.lang

      Methods in java.lang that return System.LoggerFinder
      Modifier and Type 方法 描述
      static System.LoggerFinder System.LoggerFinder.getLoggerFinder​()
      返回 LoggerFinder实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Thread (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Thread

  • Packages that use Thread
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.concurrent.locks
    接口和类提供了一个框架，用于锁定和等待与内置同步和监视器不同的条件。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Thread in java.lang

      Methods in java.lang that return Thread
      Modifier and Type 方法 描述
      static Thread Thread.currentThread​()
      返回对当前正在执行的线程对象的引用。
      Methods in java.lang that return types with arguments of type Thread
      Modifier and Type 方法 描述
      static Map<Thread,StackTraceElement[]> Thread.getAllStackTraces​()
      返回所有活动线程的堆栈跟踪图。
      Methods in java.lang with parameters of type Thread
      Modifier and Type 方法 描述
      void Runtime.addShutdownHook​(Thread hook)
      注册一个新的虚拟机关机挂钩。
      void SecurityManager.checkAccess​(Thread t)
      如果调用线程不允许修改线程参数，则抛出一个 SecurityException 。
      static int Thread.enumerate​(Thread[] tarray)
      将当前线程的线程组及其子组中的每个活动线程复制到指定的数组中。
      int ThreadGroup.enumerate​(Thread[] list)
      将此线程组及其子组中的每个活动线程复制到指定的数组中。
      int ThreadGroup.enumerate​(Thread[] list, boolean recurse)
      将此线程组中的每个活动线程复制到指定的数组中。
      boolean Runtime.removeShutdownHook​(Thread hook)
      取消注册以前注册的虚拟机关闭挂接。
      void Thread.UncaughtExceptionHandler.uncaughtException​(Thread t, Throwable e)
      当给定的线程由于给定的未捕获异常而终止时调用方法。
      void ThreadGroup.uncaughtException​(Thread t, Throwable e)
      当该线程组中的线程由于未捕获的异常而停止时，由Java虚拟机调用，并且线程没有安装特定的Thread.UncaughtExceptionHandler 。

    • Uses of Thread in java.util.concurrent

      Subclasses of Thread in java.util.concurrent
      Modifier and Type Class 描述
      class  ForkJoinWorkerThread
      一个线程由一个ForkJoinPool管理，执行ForkJoinTask s。
      Methods in java.util.concurrent that return Thread
      Modifier and Type 方法 描述
      Thread ThreadFactory.newThread​(Runnable r)
      构造新的 Thread 。
      Methods in java.util.concurrent that return types with arguments of type Thread
      Modifier and Type 方法 描述
      protected Collection<Thread> Semaphore.getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      Methods in java.util.concurrent with parameters of type Thread
      Modifier and Type 方法 描述
      protected void ThreadPoolExecutor.beforeExecute​(Thread t, Runnable r)
      在给定的线程中执行给定的Runnable之前调用方法。
      void TimeUnit.timedJoin​(Thread thread, long timeout)
      使用此时间单位执行定时 Thread.join 。

    • Uses of Thread in java.util.concurrent.locks

      Methods in java.util.concurrent.locks that return Thread
      Modifier and Type 方法 描述
      protected Thread AbstractOwnableSynchronizer.getExclusiveOwnerThread​()
      返回最后设置的线程 setExclusiveOwnerThread ，如果从未设置，则返回 null 。
      Thread AbstractQueuedLongSynchronizer.getFirstQueuedThread​()
      返回队列中的第一个（最长等待）线程，如果没有线程当前排队，则 null 。
      Thread AbstractQueuedSynchronizer.getFirstQueuedThread​()
      返回队列中的第一个（最长等待）线程，如果没有线程当前排队，则 null 。
      protected Thread ReentrantLock.getOwner​()
      返回当前拥有此锁的线程，如果不拥有，则返回 null 。
      protected Thread ReentrantReadWriteLock.getOwner​()
      返回当前拥有写锁的线程，如果不拥有，则返回 null 。
      Methods in java.util.concurrent.locks that return types with arguments of type Thread
      Modifier and Type 方法 描述
      Collection<Thread> AbstractQueuedLongSynchronizer.getExclusiveQueuedThreads​()
      返回一个包含可能正在等待以独占模式获取的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getExclusiveQueuedThreads​()
      返回一个包含可能正在等待以独占模式获取的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getQueuedReaderThreads​()
      返回一个包含可能正在等待获取读取锁的线程的集合。
      Collection<Thread> AbstractQueuedLongSynchronizer.getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getQueuedThreads​()
      返回一个包含可能正在等待获取的线程的集合。
      protected Collection<Thread> ReentrantLock.getQueuedThreads​()
      返回包含可能正在等待获取此锁的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getQueuedThreads​()
      返回一个包含可能正在等待获取读取或写入锁定的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getQueuedWriterThreads​()
      返回一个包含可能正在等待获取写入锁的线程的集合。
      Collection<Thread> AbstractQueuedLongSynchronizer.getSharedQueuedThreads​()
      返回包含可能正在等待在共享模式下获取的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getSharedQueuedThreads​()
      返回包含可能正在等待在共享模式下获取的线程的集合。
      protected Collection<Thread> AbstractQueuedLongSynchronizer.ConditionObject.getWaitingThreads​()
      返回一个包含可能在此条件下等待的线程的集合。
      Collection<Thread> AbstractQueuedLongSynchronizer.getWaitingThreads​(AbstractQueuedLongSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      protected Collection<Thread> AbstractQueuedSynchronizer.ConditionObject.getWaitingThreads​()
      返回一个包含可能在此条件下等待的线程的集合。
      Collection<Thread> AbstractQueuedSynchronizer.getWaitingThreads​(AbstractQueuedSynchronizer.ConditionObject condition)
      返回一个集合，其中包含可能正在等待与此同步器相关联的给定条件的线程。
      protected Collection<Thread> ReentrantLock.getWaitingThreads​(Condition condition)
      返回包含可能在与此锁相关联的给定条件下等待的线程的集合。
      protected Collection<Thread> ReentrantReadWriteLock.getWaitingThreads​(Condition condition)
      返回包含可能在与写锁相关联的给定条件下等待的线程的集合。
      Methods in java.util.concurrent.locks with parameters of type Thread
      Modifier and Type 方法 描述
      static Object LockSupport.getBlocker​(Thread t)
      返回提供给最近调用尚未解除阻塞的park方法的阻止程序对象，如果不阻止则返回null。
      boolean ReentrantLock.hasQueuedThread​(Thread thread)
      查询给定线程是否等待获取此锁。
      boolean ReentrantReadWriteLock.hasQueuedThread​(Thread thread)
      查询给定线程是否等待获取读取或写入锁定。
      boolean AbstractQueuedLongSynchronizer.isQueued​(Thread thread)
      如果给定的线程当前排队，则返回true。
      boolean AbstractQueuedSynchronizer.isQueued​(Thread thread)
      如果给定的线程当前排队，则返回true。
      protected void AbstractOwnableSynchronizer.setExclusiveOwnerThread​(Thread thread)
      设置当前拥有独占访问权限的线程。
      static void LockSupport.unpark​(Thread thread)
      为给定的线程提供许可证（如果尚未提供）。

    • Uses of Thread in javax.swing.text

      Methods in javax.swing.text that return Thread
      Modifier and Type 方法 描述
      protected Thread AbstractDocument.getCurrentWriter​()
      获取当前的书写线程，如果有的话。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Thread.State (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Thread.State

  • Packages that use Thread.State
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of Thread.State in java.lang

      Methods in java.lang that return Thread.State
      Modifier and Type 方法 描述
      Thread.State Thread.getState​()
      返回此线程的状态。
      static Thread.State Thread.State.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Thread.State[] Thread.State.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

    • Uses of Thread.State in java.lang.management

      Methods in java.lang.management that return Thread.State
      Modifier and Type 方法 描述
      Thread.State ThreadInfo.getThreadState​()
      返回与此 ThreadInfo相关联的线程的状态。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ThreadDeath (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ThreadDeath

No usage of java.lang.ThreadDeath
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ThreadGroup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ThreadGroup

  • Packages that use ThreadGroup
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ThreadGroup in java.lang

      Methods in java.lang that return ThreadGroup
      Modifier and Type 方法 描述
      ThreadGroup ThreadGroup.getParent​()
      返回此线程组的父级。
      ThreadGroup SecurityManager.getThreadGroup​()
      返回要在其被调用时实例化任何正在创建的新线程的线程组。
      ThreadGroup Thread.getThreadGroup​()
      返回此线程所属的线程组。
      Methods in java.lang with parameters of type ThreadGroup
      Modifier and Type 方法 描述
      void SecurityManager.checkAccess​(ThreadGroup g)
      如果调用线程不允许修改线程组参数，则抛出一个 SecurityException 。
      int ThreadGroup.enumerate​(ThreadGroup[] list)
      复制到该线程组及其子组中每个活动子组的指定数组引用。
      int ThreadGroup.enumerate​(ThreadGroup[] list, boolean recurse)
      复制到该线程组中每个活动子组的指定数组引用。
      boolean ThreadGroup.parentOf​(ThreadGroup g)
      测试此线程组是线程组参数还是其祖先线程组之一。
      Constructors in java.lang with parameters of type ThreadGroup
      Constructor 描述
      Thread​(ThreadGroup group, Runnable target)
      分配一个新的 Thread对象。
      Thread​(ThreadGroup group, Runnable target, String name)
      分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于由 group引用的线程组。
      Thread​(ThreadGroup group, Runnable target, String name, long stackSize)
      分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于由 group引用的线程组，并具有指定的 堆栈大小 。
      Thread​(ThreadGroup group, Runnable target, String name, long stackSize, boolean inheritThreadLocals)
      分配一个新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于由group引用的线程组，具有指定的stackSize ，并且如果inheritThreadLocals为true ，则继承inheritable thread-local变量的初始值。
      Thread​(ThreadGroup group, String name)
      分配一个新的 Thread对象。
      ThreadGroup​(ThreadGroup parent, String name)
      创建一个新的线程组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ThreadLocal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ThreadLocal

  • Packages that use ThreadLocal
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ThreadLocal in java.lang

      Subclasses of ThreadLocal in java.lang
      Modifier and Type Class 描述
      class  InheritableThreadLocal<T>
      该类扩展了 ThreadLocal以提供从父线程到子线程的值的继承：当创建子线程时，子接收到父值具有值的所有可继承线程局部变量的初始值。
      Methods in java.lang that return ThreadLocal
      Modifier and Type 方法 描述
      static <S> ThreadLocal<S> ThreadLocal.withInitial​(Supplier<? extends S> supplier)
      创建线程局部变量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Throwable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Throwable

  • Packages that use Throwable
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.jdi.connect
    该包定义了使用JDI的虚拟机与目标虚拟机之间的连接。
    com.sun.jdi.connect.spi
    该包包括用于开发新的TransportService实现的接口和类。
    com.sun.jdi.request
    该包用于请求在指定条件下发送JDI事件。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.tools.attach
    提供API附加到Java的虚拟机。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.color
    提供颜色空间的类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.dnd
    拖放是在许多图形用户界面系统中发现的直接操纵手势，它提供了一种在逻辑上与GUI中的表示元素相关联的实体之间传递信息的机制。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.print
    提供通用打印API的类和接口。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.rmi
    提供RMI包。
    java.rmi.activation
    提供对RMI对象激活的支持。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.prefs
    该软件包允许应用程序存储和检索用户和系统首选项和配置数据。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.application
    提供应用程序生命周期类。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.fxml
    包含用于从标记加载对象层次结构的类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.transform
    提供一组方便的类来执行 Affine对象的旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javax.activation
    javax.activity
    包含ORB机械在解组时抛出的活动服务相关异常。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio
    Java Image I / O API的主要包。
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.imageio.spi
    包含用于读取器，写入器，代码转换器和流以及运行时注册表的插件接口的Java Image I / O API包。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.jnlp
    JNLP API旨在为Java Plugin中运行的JNLP应用程序提供附加服务，或者由Java Web Start启动。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.monitor
    提供监视器类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming包以提供访问目录服务的功能。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.net.ssl
    为安全套接字包提供类。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.rmi.CORBA
    包含RMI-IIOP的可移植API。
    javax.script
    脚本API由定义Java脚本引擎的接口和类组成，并为Java应用程序中的使用提供了框架。
    javax.security.auth
    此软件包提供了认证和授权的框架。
    javax.security.auth.callback
    该包提供了服务与应用程序交互所需的类，以便检索信息（例如，包括用户名或密码的身份验证数据）或显示信息（例如错误和警告消息）。
    javax.security.auth.login
    该包提供了一个可插拔的认证框架。
    javax.security.cert
    提供公钥证书类。
    javax.security.sasl
    包含用于支持SASL的类和接口。
    javax.smartcardio
    Java™智能卡I / O API
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.swing.undo
    允许开发人员在文本编辑器等应用程序中提供撤消/重做的支持。
    javax.transaction
    包含ORB机械在解组期间抛出的三个异常。
    javax.transaction.xa
    提供定义事务管理器和资源管理器之间的契约的API，这允许事务管理器在JTA事务中引用和删除资源对象（由资源管理器驱动程序提供）。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.bind.helpers
    仅限JAXB提供程序使用：为部分 javax.xml.bind接口提供部分默认实现。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.crypto.dsig
    用于生成和验证XML数字签名的类。
    javax.xml.datatype
    定义XML / Java类型映射。
    javax.xml.parsers
    提供使用SAX（Simple API for XML）解析器或DOM（文档对象模型）文档构建器处理XML文档的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    javax.xml.stream
    定义Streaming API for XML（StAX）的接口和类。
    javax.xml.transform
    定义用于处理转换指令的通用API，以及执行从源到结果的转换。
    javax.xml.validation
    提供用于验证XML文档的API。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.http
    该包定义了特定于HTTP绑定的API。
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.security.jarsigner
    netscape.javascript
    使Java代码能够访问Web浏览器中的JavaScript引擎和HTML DOM。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，其实现为程序员可以将其用作全功能对象请求代理（ORB）。
    org.omg.CORBA.DynAnyPackage
    提供与使用的异常 DynAny接口（ InvalidValue ， Invalid ， InvalidSeq ，和 TypeMismatch ）。
    org.omg.CORBA.ORBPackage
    提供异常 InvalidName ，由方法 ORB.resolve_initial_references抛出，异常 InconsistentTypeCode由ORB类中的动态任何创建方法抛出。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
    org.omg.CORBA.TypeCodePackage
    提供用户定义的异常 BadKind和 Bounds ，它们由类 TypeCode中的方法抛出。
    org.omg.CosNaming.NamingContextExtPackage
    此包包含以下类别，其用于 org.omg.CosNaming.NamingContextExt ： AddressHelper StringNameHelper URLStringHelper InvalidAddress
    org.omg.CosNaming.NamingContextPackage
    该包包含 org.omg.CosNaming包的异常类。
    org.omg.DynamicAny.DynAnyFactoryPackage
    该包包含OMG “通用对象请求代理：体系结构和规范 ” formal/99-10-07第9.2.2节中指定的 DynamicAny模块的 DynAnyFactory接口的类和异常。
    org.omg.DynamicAny.DynAnyPackage
    该包包含OMG “公共对象请求代理：体系结构和规范 ” formal/99-10-07第9.2节中指定的 DynamicAny模块的 DynAny接口的类和异常。
    org.omg.IOP.CodecFactoryPackage
    该包包含IOP :: CodeFactory接口中指定的异常（作为便携式拦截器规范的一部分）。
    org.omg.IOP.CodecPackage
    该包是从IOP :: Codec IDL接口定义生成的。
    org.omg.PortableInterceptor
    提供一种注册ORB钩子的机制，ORB服务可以通过该钩子拦截ORB的正常执行流程。
    org.omg.PortableInterceptor.ORBInitInfoPackage
    该包包含OMG便携式拦截器规范 ptc/2000-08-06第21.7.2节中指定的 PortableInterceptor模块的 ORBInitInfo本地接口的异常和typedef。
    org.omg.PortableServer
    提供类和接口，使您的应用程序的服务器端可跨多厂商ORBs移植。
    org.omg.PortableServer.CurrentPackage
    提供方法实现，访问方法被调用的对象的标识。
    org.omg.PortableServer.POAManagerPackage
    封装与之相关的POA的处理状态。
    org.omg.PortableServer.POAPackage
    允许程序员构建可在不同ORB产品之间移植的对象实现。
    org.w3c.dom
    提供文档对象模型（DOM）的接口。
    org.w3c.dom.events
    提供DOM Level 2事件的接口。
    org.w3c.dom.ls
    提供DOM Level 3加载和保存的界面。
    org.w3c.dom.ranges
    提供DOM Level 2范围的界面。
    org.w3c.dom.xpath
    提供DOM Level 3 XPath规范的接口。
    org.xml.sax
    提供核心SAX API。

    • Uses of Throwable in com.sun.jdi

      Subclasses of Throwable in com.sun.jdi
      Modifier and Type Class 描述
      class  AbsentInformationException
      抛出以表示行号或变量信息不可用。
      class  ClassNotLoadedException
      抛出，表示请求的类尚未通过适当的类加载器加载。
      class  ClassNotPreparedException
      抛出以指示由于指定的类尚未准备而请求的操作无法完成。
      class  IncompatibleThreadStateException
      抛出以指示所请求的操作在指定线程处于当前状态时无法完成。
      class  InconsistentDebugInfoException
      被抛出以表明目标VM提供的调试信息有不一致之处。
      class  InternalException
      抛出，表示出现意外的内部错误。
      class  InvalidCodeIndexException
      已过时。
      不再抛出此异常
      class  InvalidLineNumberException
      已过时。
      不再抛出此异常
      class  InvalidModuleException
      抛出以表明所请求的模块在卸载模块后无效或无效。
      class  InvalidStackFrameException
      抛出以指示所请求的操作无法完成，因为指定的堆栈帧不再有效。
      class  InvalidTypeException
      抛出以指示在设置字段或变量的值时或在指定方法的返回值时的类型不匹配。
      class  InvocationException
      抛出以指示目标VM中的调用方法中发生异常。
      class  NativeMethodException
      抛出表示操作无法完成，因为它对本机方法无效。
      class  ObjectCollectedException
      抛出以指示所请求的操作无法完成，因为指定的对象已被垃圾回收。
      class  VMCannotBeModifiedException
      抛出以表示操作无效，因为它会修改VM，VM是只读的。
      class  VMDisconnectedException
      抛出未经检查的异常，指示所请求的操作无法完成，因为不再连接到目标VM。
      class  VMMismatchException
      抛出以指示所请求的操作无法完成，因为来自一个目标VM的镜像与另一个目标VM的镜像组合。
      class  VMOutOfMemoryException
      抛出以指示所请求的操作无法完成，因为目标VM的内存已用尽。

    • Uses of Throwable in com.sun.jdi.connect

      Subclasses of Throwable in com.sun.jdi.connect
      Modifier and Type Class 描述
      class  IllegalConnectorArgumentsException
      抛出表示无效参数或不一致传递给Connector 。
      class  TransportTimeoutException
      当附加到目标虚拟机或等待接受来自目标虚拟机的连接时，可能会抛出此异常。
      class  VMStartException
      目标VM已成功启动，但在建立连接之前会发生错误。

    • Uses of Throwable in com.sun.jdi.connect.spi

      Subclasses of Throwable in com.sun.jdi.connect.spi
      Modifier and Type Class 描述
      class  ClosedConnectionException
      在进行I / O操作时，由于异步关闭Connection可能会抛出此异常。

    • Uses of Throwable in com.sun.jdi.request

      Subclasses of Throwable in com.sun.jdi.request
      Modifier and Type Class 描述
      class  DuplicateRequestException
      抛出以表示重复的事件请求。
      class  InvalidRequestStateException
      抛出以表示所请求的事件由于启用而无法修改。

    • Uses of Throwable in com.sun.nio.sctp

      Subclasses of Throwable in com.sun.nio.sctp
      Modifier and Type Class 描述
      class  IllegalReceiveException
      当试图调用未经检查的异常receive的方法SctpChannel或SctpMultiChannel从通知处理程序。
      class  IllegalUnbindException
      尝试删除未绑定到该通道的地址时删除未检查的异常，或从仅具有一个地址的通道中删除地址。
      class  InvalidStreamException
      尝试将消息发送到无效流时抛出未检查的异常。

    • Uses of Throwable in com.sun.tools.attach

      Subclasses of Throwable in com.sun.tools.attach
      Modifier and Type Class 描述
      class  AgentInitializationException
      当代理程序无法在目标Java虚拟机中初始化时抛出异常。
      class  AgentLoadException
      代理无法加载到目标Java虚拟机时抛出的异常。
      class  AttachNotSupportedException
      在尝试附加到兼容的AttachProvider不存在的Java虚拟机时抛出VirtalMachine.attach 。
      class  AttachOperationFailedException
      异常类型表示目标虚拟机中附着操作失败。

    • Uses of Throwable in java.awt

      Subclasses of Throwable in java.awt
      Modifier and Type Class 描述
      class  AWTError
      当出现严重的抽象窗口工具包错误时抛出。
      class  AWTException
      表示发生抽象窗口工具包异常。
      class  FontFormatException
      在 Font类中通过 Font方法抛出，指示指定的字体不好。
      class  HeadlessException
      在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
      class  IllegalComponentStateException
      表示AWT组件对于请求的操作不在适当的状态。

    • Uses of Throwable in java.awt.color

      Subclasses of Throwable in java.awt.color
      Modifier and Type Class 描述
      class  CMMException
      如果本机CMM返回错误，则抛出此异常。
      class  ProfileDataException
      在访问或处理ICC_Profile对象时发生错误时抛出此异常。

    • Uses of Throwable in java.awt.datatransfer

      Subclasses of Throwable in java.awt.datatransfer
      Modifier and Type Class 描述
      class  MimeTypeParseException
      封装MimeType解析相关异常的类。
      class  UnsupportedFlavorException
      表示在此风格中不支持请求的数据。

    • Uses of Throwable in java.awt.dnd

      Subclasses of Throwable in java.awt.dnd
      Modifier and Type Class 描述
      class  InvalidDnDOperationException
      java.awt.dnd包中的各种方法抛出此异常。

    • Uses of Throwable in java.awt.event

      Methods in java.awt.event that return Throwable
      Modifier and Type 方法 描述
      Throwable InvocationEvent.getThrowable​()
      返回在执行Runnable的 run()方法时捕获的任何Throwable。

    • Uses of Throwable in java.awt.geom

      Subclasses of Throwable in java.awt.geom
      Modifier and Type Class 描述
      class  IllegalPathStateException
      如果在相对于执行的特定操作处于非法状态的路径上执行操作，则IllegalPathStateException表示抛出异常，例如在没有初始移动的情况下将路径段追加到GeneralPath 。
      class  NoninvertibleTransformException
      NoninvertibleTransformException类表示如果执行操作需要AffineTransform对象的反向但AffineTransform处于非可逆状态时抛出的异常。

    • Uses of Throwable in java.awt.image

      Subclasses of Throwable in java.awt.image
      Modifier and Type Class 描述
      class  ImagingOpException
      所述ImagingOpException ，如果所述一个被抛出BufferedImageOp种或RasterOp过滤方法不能处理图像。
      class  RasterFormatException
      如果RasterFormatException中有无效的布局信息，则抛出RasterFormatException 。

    • Uses of Throwable in java.awt.print

      Subclasses of Throwable in java.awt.print
      Modifier and Type Class 描述
      class  PrinterAbortException
      所述PrinterAbortException类是的一个子类PrinterException ，并用于指示用户或应用程序终止打印作业，而这是在打印的过程中。
      class  PrinterException
      PrinterException类及其子类用于指示打印系统中出现异常情况。
      class  PrinterIOException
      该PrinterIOException类的子类PrinterException ，用来表示某种IO错误而发生的打印。
      Methods in java.awt.print that return Throwable
      Modifier and Type 方法 描述
      Throwable PrinterIOException.getCause​()
      返回此异常的原因（终止打印作业的 IOException ）。

    • Uses of Throwable in java.beans

      Subclasses of Throwable in java.beans
      Modifier and Type Class 描述
      class  IntrospectionException
      内省时发生异常时抛出。
      class  PropertyVetoException
      当对属性的建议更改表示不可接受的值时，将抛出PropertyVetoException。

    • Uses of Throwable in java.io

      Subclasses of Throwable in java.io
      Modifier and Type Class 描述
      class  CharConversionException
      字符转换异常的基类。
      class  EOFException
      表示在输入过程中意外地到达文件结束或流结束。
      class  FileNotFoundException
      指示尝试打开由指定路径名表示的文件失败。
      class  InterruptedIOException
      表示I / O操作已中断。
      class  InvalidClassException
      当序列化运行时检测到类中的以下问题之一时抛出。
      class  InvalidObjectException
      表示一个或多个反序列化对象失败的验证测试。
      class  IOError
      当出现严重I / O错误时抛出。
      class  IOException
      表示发生某种类型的I / O异常。
      class  NotActiveException
      序列化或反序列化不活跃时抛出。
      class  NotSerializableException
      抛出一个实例需要一个Serializable接口。
      class  ObjectStreamException
      对象流类别特有的所有异常的超类。
      class  OptionalDataException
      表示由于未读原始数据导致的对象读取操作失败的异常，或属于流中序列化对象的数据的结束。
      class  StreamCorruptedException
      当从对象流读取的控制信息违反内部一致性检查时抛出。
      class  SyncFailedException
      发出同步操作失败的信号。
      class  UncheckedIOException
      包装一个IOException与未检查的异常。
      class  UnsupportedEncodingException
      字符编码不支持。
      class  UTFDataFormatException
      表示 modified UTF-8格式的格式不正确的字符串已被读入数据输入流或实现数据输入接口的任何类。
      class  WriteAbortedException
      指示在写入操作期间抛出ObjectStreamExceptions之一。
      Methods in java.io that return Throwable
      Modifier and Type 方法 描述
      Throwable WriteAbortedException.getCause​()
      返回终止操作的异常（ 原因 ）。
      Constructors in java.io with parameters of type Throwable
      Constructor 描述
      IOError​(Throwable cause)
      构造具有指定原因的新的IOError实例。
      IOException​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的 IOException 。
      IOException​(Throwable cause)
      构造一个 IOException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in java.lang

      Subclasses of Throwable in java.lang
      Modifier and Type Class 描述
      class  AbstractMethodError
      当应用程序尝试调用抽象方法时抛出。
      class  ArithmeticException
      抛出异常算术条件时抛出。
      class  ArrayIndexOutOfBoundsException
      抛出以表示使用非法索引访问数组。
      class  ArrayStoreException
      抛出以表示尝试将错误类型的对象存储到对象数组中。
      class  AssertionError
      抛出以表明断言失败。
      class  BootstrapMethodError
      抛出以指示invokedynamic指令找不到引导方法，或引导方法未能提供call site与target的正确method type 。
      class  ClassCastException
      抛出表示代码尝试将对象转换为不属于实例的子类。
      class  ClassCircularityError
      当Java虚拟机检测到正在加载的类的超类层次结构中的循环性时抛出。
      class  ClassFormatError
      当Java虚拟机尝试读取类文件并确定文件格式不正确或不能解释为类文件时抛出。
      class  ClassNotFoundException
      的：当应用程序试图加载在通过其字符串名称使用类抛出 forName在类方法 Class 。
      class  CloneNotSupportedException
      抛出，表明该 clone类方法 Object被称为克隆对象，但该对象的类无法实现 Cloneable接口。
      class  EnumConstantNotPresentException
      当应用程序尝试通过名称访问枚举常量时抛出，枚举类型不包含指定名称的常量。
      class  Error
      一个 Error是的子类 Throwable表示严重的问题，合理的应用程序不应该试图捕获。
      class  异常
      异常及其子类是 Throwable的形式，表示合理应用程序可能想要捕获的条件。
      class  ExceptionInInitializerError
      表示在静态初始化程序中发生意外异常。
      class  IllegalAccessError
      如果应用程序尝试访问或修改某个字段，或调用无法访问的方法，则抛出此异常。
      class  IllegalAccessException
      当应用程序尝试反射创建实例（数组除外），设置或获取字段或调用方法时，会抛出IllegalAccessException，但是当前执行的方法无法访问指定类，字段的定义，方法或构造函数。
      class  IllegalArgumentException
      抛出表示一种方法已经通过了非法或不正确的参数。
      class  IllegalCallerException
      被抛出来表示一个方法已被不适当的调用者调用。
      class  IllegalMonitorStateException
      抛出以表示线程已尝试在对象的监视器上等待或通知其他线程等待对象的监视器，而不拥有指定的监视器。
      class  IllegalStateException
      表示在非法或不适当的时间调用了一种方法。
      class  IllegalThreadStateException
      抛出以指示线程不处于所请求操作的适当状态。
      class  IncompatibleClassChangeError
      当一些类定义发生不兼容的类更改时抛出。
      class  IndexOutOfBoundsException
      抛出以表示某种索引（例如数组，字符串或向量）的索引超出范围。
      class  InstantiationError
      当应用程序尝试使用Java new构造来实例化抽象类或接口时抛出。
      class  InstantiationException
      当应用程序试图创建使用一个类的实例抛出 newInstance方法在类 Class ，而指定的类对象不能被实例化。
      class  InternalError
      在Java虚拟机中引发了一些意外的内部错误。
      class  InterruptedException
      线程在等待，睡眠或以其他方式占用时抛出，线程在活动之前或活动期间中断。
      class  LayerInstantiationException
      创建module layer时抛出失败。
      class  LinkageError
      LinkageError子类表示一个类对另一个类有一些依赖; 然而，后期课程在前班的汇编之后不配变。
      class  NegativeArraySizeException
      抛出一个应用程序尝试创建一个负数大小的数组。
      class  NoClassDefFoundError
      如果Java虚拟机或 ClassLoader实例尝试在类的定义中加载（作为普通方法调用的一部分或作为使用 new表达式创建新实例的 new ），则不会发现类的定义。
      class  NoSuchFieldError
      如果应用程序尝试访问或修改对象的指定字段，并且该对象不再具有该字段，则抛出。
      class  NoSuchFieldException
      表示该类没有指定名称的字段。
      class  NoSuchMethodError
      如果应用程序尝试调用类（静态或实例）的指定方法，并且该类不再具有该方法的定义，则抛出。
      class  NoSuchMethodException
      当无法找到特定方法时抛出。
      class  NullPointerException
      当应用程序在需要对象的情况下尝试使用 null时抛出。
      class  NumberFormatException
      抛出以表示应用程序已尝试将字符串转换为其中一个数字类型，但该字符串不具有相应的格式。
      class  OutOfMemoryError
      当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。
      class  ReflectiveOperationException
      核心反射中的反射操作抛出的异常的常见超类。
      class  RuntimeException
      RuntimeException是在Java虚拟机的正常操作期间可以抛出的异常的超类。
      class  SecurityException
      由安全管理员抛出，表示安全违规。
      class  StackOverflowError
      当堆栈溢出发生时抛出一个应用程序递归太深。
      class  StringIndexOutOfBoundsException
      抛出 String方法来指示索引为负或大于字符串的大小。
      class  ThreadDeath
      当调用（不推荐使用）的 Thread.stop()方法时，将在受害者线程中抛出 ThreadDeath的实例。
      class  TypeNotPresentException
      当应用程序尝试使用表示类型名称的字符串访问类型时抛出，但没有找到具有指定名称的类型的定义。
      class  UnknownError
      当Java虚拟机中出现未知但严重的异常时抛出。
      class  UnsatisfiedLinkError
      如果Java虚拟机找不到声明为 native的方法的适当的本地语言定义，则 native 。
      class  UnsupportedClassVersionError
      当Java虚拟机尝试读取类文件并确定文件中的主要和次要版本号不受支持时抛出。
      class  UnsupportedOperationException
      抛出以表示不支持请求的操作。
      class  VerifyError
      当“验证者”检测到一个类文件（尽管形成良好）包含某种内部不一致或安全问题时抛出。
      class  VirtualMachineError
      抛出以表明Java虚拟机已损坏或已耗尽资源以使其继续运行。
      Methods in java.lang that return Throwable
      Modifier and Type 方法 描述
      Throwable Throwable.fillInStackTrace​()
      填写执行堆栈跟踪。
      Throwable ClassNotFoundException.getCause​()
      返回此异常的原因（尝试加载类时发生错误时引发的异常;否则为 null ）。
      Throwable ExceptionInInitializerError.getCause​()
      返回此错误的原因（导致此错误创建的静态初始化期间发生的异常）。
      Throwable Throwable.getCause​()
      如果原因不存在或未知，则返回此throwable的原因或 null 。
      Throwable ClassNotFoundException.getException​()
      返回在尝试加载类时发生错误时引发的异常。
      Throwable ExceptionInInitializerError.getException​()
      返回在静态初始化期间发生的异常，导致此错误被创建。
      Throwable[] Throwable.getSuppressed​()
      通过 try -with-resources语句返回一个包含所有被抑制的异常的数组，以便传递这个异常。
      Throwable Throwable.initCause​(Throwable cause)
      将此throwable的 原因初始化为指定值。
      Methods in java.lang with parameters of type Throwable
      Modifier and Type 方法 描述
      void Throwable.addSuppressed​(Throwable exception)
      将指定的异常附加到为了传递此异常而被抑制的异常。
      Throwable Throwable.initCause​(Throwable cause)
      将此throwable的 原因初始化为指定值。
      default void System.Logger.log​(System.Logger.Level level, String msg, Throwable thrown)
      记录与给定的可抛弃关联的消息。
      default void System.Logger.log​(System.Logger.Level level, Supplier<String> msgSupplier, Throwable thrown)
      记录与给定的可抛物线相关联的延迟提供的消息。
      void System.Logger.log​(System.Logger.Level level, ResourceBundle bundle, String msg, Throwable thrown)
      记录与给定的可抛物线相关联的本地化消息。
      void Thread.stop​(Throwable obj)
      不推荐用于删除：此API元素将在以后的版本中被删除。
      该方法最初是为了强制线程停止并抛出一个给定的Throwable作为例外。 它本质上是不安全的（详见Thread.stop() ），此外还可用于生成目标线程未准备处理的异常。 有关详细信息，请参阅Why are Thread.stop, Thread.suspend and Thread.resume Deprecated? 。 此方法在将来的Java SE版本中可能会被删除。
      void Thread.UncaughtExceptionHandler.uncaughtException​(Thread t, Throwable e)
      当给定的线程由于给定的未捕获异常而终止时调用方法。
      void ThreadGroup.uncaughtException​(Thread t, Throwable e)
      当该线程组中的线程由于未捕获的异常而停止时，由Java虚拟机调用，并且该线程没有安装特定的Thread.UncaughtExceptionHandler 。
      Methods in java.lang that throw Throwable
      Modifier and Type 方法 描述
      protected void Object.finalize​()
      已过时。
      定稿机制本质上是有问题的。 定稿可能导致性能问题，死锁和挂起。 敲定错误可能导致资源泄漏; 如果不再需要，无法取消定稿; 并且在对不同对象的finalize方法的调用中没有指定排序。 此外，关于定稿的时间并不保证。 只有在无限期延迟之后， finalize方法才可能在可终止对象上调用。 其实例持有非堆资源的类应提供一种方法来实现这些资源的显式释放，如果适用，它们还应实现AutoCloseable 。 当对象变得不可达时， Cleaner和PhantomReference提供了更灵活和更有效的方式来释放资源。
      Constructors in java.lang with parameters of type Throwable
      Constructor 描述
      AssertionError​(String message, Throwable cause)
      构造一个新的 AssertionError具有指定的详细信息和原因。
      BootstrapMethodError​(String s, Throwable cause)
      构造具有指定的详细信息和原因的 BootstrapMethodError 。
      BootstrapMethodError​(Throwable cause)
      构造具有指定原因的 BootstrapMethodError 。
      ClassNotFoundException​(String s, Throwable ex)
      构造一个 ClassNotFoundException其中包含指定的详细消息和加载类时引发的可选异常。
      Error​(String message, Throwable cause)
      构造一个新的错误与指定的详细信息和原因。
      Error​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个新的错误指定的详细信息，原因，抑制启用或禁用，可写栈跟踪启用或禁用。
      Error​(Throwable cause)
      构造具有指定的原因和详细消息的新的错误 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      异常​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      异常​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个新的异常，指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
      异常​(Throwable cause)
      构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      ExceptionInInitializerError​(Throwable thrown)
      构造一个新的 ExceptionInInitializerError类，保存对 Throwable对象的引用，以供稍后通过 ExceptionInInitializerError.getException()方法检索。
      IllegalArgumentException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      IllegalArgumentException​(Throwable cause)
      构造具有指定原因的新异常和详细消息 (cause==null ? null : cause.toString()) （通常包含类和详细消息为 cause ）。
      IllegalCallerException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      IllegalCallerException​(Throwable cause)
      构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      IllegalStateException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      IllegalStateException​(Throwable cause)
      构造具有指定原因的新异常和详细消息 (cause==null ? null : cause.toString()) （通常包含类和详细消息 cause ）。
      InternalError​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的 InternalError 。
      InternalError​(Throwable cause)
      构造一个 InternalError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      LayerInstantiationException​(String msg, Throwable cause)
      构造一个 LayerInstantiationException与给定的详细信息和原因。
      LayerInstantiationException​(Throwable cause)
      构造一个 LayerInstantiationException与给定的原因。
      LinkageError​(String s, Throwable cause)
      构造一个具有指定的详细信息和原因的 LinkageError 。
      ReflectiveOperationException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      ReflectiveOperationException​(Throwable cause)
      构造具有指定原因的新异常和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细消息为 cause ）。
      RuntimeException​(String message, Throwable cause)
      构造一个新的运行时异常与指定的详细信息和原因。
      RuntimeException​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个新的运行时异常，其中包含指定的详细消息，启用或禁用抑制，启用或禁用可写栈跟踪。
      RuntimeException​(Throwable cause)
      构造一个新的运行时异常，其中指定的原因和详细信息为 (cause==null ? null : cause.toString()) （通常包含类和详细信息为 cause ）。
      SecurityException​(String message, Throwable cause)
      创建一个 SecurityException与指定的详细信息和原因。
      SecurityException​(Throwable cause)
      创建 SecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      Throwable​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      Throwable​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个具有指定的详细信息的新的throwable，因为启用或禁用了 suppression和启用或禁用可写栈跟踪。
      Throwable​(Throwable cause)
      构造一个具有指定原因的新throwable和一个详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。
      TypeNotPresentException​(String typeName, Throwable cause)
      构造具有指定原因的命名类型的 TypeNotPresentException 。
      UnsupportedOperationException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      UnsupportedOperationException​(Throwable cause)
      构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      VirtualMachineError​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的 VirtualMachineError 。
      VirtualMachineError​(Throwable cause)
      构造一个一个 VirtualMachineError与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in java.lang.annotation

      Subclasses of Throwable in java.lang.annotation
      Modifier and Type Class 描述
      class  AnnotationFormatError
      当注释解析器尝试从类文件读取注释并确定注释格式错误时抛出。
      class  AnnotationTypeMismatchException
      抛出以指示程序已尝试访问注释编辑（或序列化）后类型已更改的注释元素。
      class  IncompleteAnnotationException
      抛出以指示程序已尝试访问在编辑（或序列化）注释后添加到注释类型定义的注释类型的元素。
      Constructors in java.lang.annotation with parameters of type Throwable
      Constructor 描述
      AnnotationFormatError​(String message, Throwable cause)
      构造一个新的 AnnotationFormatError具有指定的详细信息和原因。
      AnnotationFormatError​(Throwable cause)
      构造一个新的 AnnotationFormatError与指定的原因和详细消息 (cause == null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in java.lang.instrument

      Subclasses of Throwable in java.lang.instrument
      Modifier and Type Class 描述
      class  IllegalClassFormatException
      当其输入参数无效时，通过执行 ClassFileTransformer.transform抛出。
      class  UnmodifiableClassException
      当其中一个指定的类不能修改时，通过执行 Instrumentation.redefineClasses抛出。
      class  UnmodifiableModuleException
      抛出以表示模块无法修改。

    • Uses of Throwable in java.lang.invoke

      Subclasses of Throwable in java.lang.invoke
      Modifier and Type Class 描述
      class  LambdaConversionException
      LambdaConversionException
      class  StringConcatException
      当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。
      class  WrongMethodTypeException
      抛出以表示代码尝试通过错误的方法类型调用方法句柄。
      Method parameters in java.lang.invoke with type arguments of type Throwable
      Modifier and Type 方法 描述
      static MethodHandle MethodHandles.catchException​(MethodHandle target, Class<? extends Throwable> exType, MethodHandle handler)
      通过在异常处理程序中运行它来创建适应目标方法句柄的方法句柄。
      Methods in java.lang.invoke that throw Throwable
      Modifier and Type 方法 描述
      Object MethodHandle.invoke​(Object... args)
      调用方法句柄，允许任何调用者类型描述符，以及可选地对参数和返回值执行转换。
      Object MethodHandle.invokeExact​(Object... args)
      调用方法句柄，允许任何调用者类型描述符，但需要确切的类型匹配。
      Object MethodHandle.invokeWithArguments​(Object... arguments)
      执行变量arity调用，将给定列表中的参数传递给方法句柄，好像通过来自调用站点的不精确的 invoke ，其中仅提及类型 Object ，其特征是参数列表的长度。
      Object MethodHandle.invokeWithArguments​(List<?> arguments)
      执行变量arity调用，将给定数组中的参数传递给方法句柄，好像通过来自调用站点的不精确的 invoke ，其中仅提及类型为 Object ，其参数是参数数组的长度。
      Constructors in java.lang.invoke with parameters of type Throwable
      Constructor 描述
      LambdaConversionException​(String message, Throwable cause)
      构造一个 LambdaConversionException的消息和原因。
      LambdaConversionException​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个 LambdaConversionException的消息，原因和其他设置。
      LambdaConversionException​(Throwable cause)
      构造一个 LambdaConversionException的原因。
      StringConcatException​(String msg, Throwable cause)
      使用消息和链接的throwable构造异常
      Constructors in java.lang.invoke that throw Throwable
      Constructor 描述
      ConstantCallSite​(MethodType targetType, MethodHandle createTargetHook)
      创建具有永久目标的呼叫站点，可能绑定到呼叫站点本身。

    • Uses of Throwable in java.lang.module

      Subclasses of Throwable in java.lang.module
      Modifier and Type Class 描述
      class  FindException
      抛出一个ModuleFinder发生错误时发现一个模块。
      class  InvalidModuleDescriptorException
      读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。
      class  ResolutionException
      在解析一组模块或解析一组具有服务绑定的模块时抛出失败。
      Constructors in java.lang.module with parameters of type Throwable
      Constructor 描述
      FindException​(String msg, Throwable cause)
      构造一个 FindException与给定的详细信息和原因。
      FindException​(Throwable cause)
      构造一个 FindException与给定的原因。
      ResolutionException​(String msg, Throwable cause)
      构造一个 ResolutionException与给定的详细信息和原因。
      ResolutionException​(Throwable cause)
      使用给定的原因构造此异常的实例。

    • Uses of Throwable in java.lang.reflect

      Subclasses of Throwable in java.lang.reflect
      Modifier and Type Class 描述
      class  GenericSignatureFormatError
      当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。
      class  InaccessibleObjectException
      Java语言访问检查无法被抑制时抛出。
      class  InvocationTargetException
      InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
      class  MalformedParameterizedTypeException
      当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。
      class  MalformedParametersException
      当 the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。
      class  UndeclaredThrowableException
      通过方法调用代理实例时抛出的调用处理程序的 invoke方法抛出检查异常（一 Throwable不是分配给 RuntimeException或者 Error ）是不能分配给任何中声明的异常类型 throws方法的条款，在代理实例上调用并分派到调用处理程序。
      Methods in java.lang.reflect that return Throwable
      Modifier and Type 方法 描述
      Throwable InvocationTargetException.getCause​()
      返回此异常的原因（抛出的目标异常，可能是 null ）。
      Throwable UndeclaredThrowableException.getCause​()
      返回此异常的原因（ Throwable实例包装在此 UndeclaredThrowableException ，可能是 null ）。
      Throwable InvocationTargetException.getTargetException​()
      获取抛出的目标异常。
      Throwable UndeclaredThrowableException.getUndeclaredThrowable​()
      返回包含在这个 UndeclaredThrowableException中的 Throwable实例，可能是 null 。
      Methods in java.lang.reflect that throw Throwable
      Modifier and Type 方法 描述
      Object InvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)
      处理代理实例上的方法调用并返回结果。
      Constructors in java.lang.reflect with parameters of type Throwable
      Constructor 描述
      InvocationTargetException​(Throwable target)
      构造一个具有目标异常的InvocationTargetException。
      InvocationTargetException​(Throwable target, String s)
      构造一个具有目标异常和详细消息的InvocationTargetException。
      UndeclaredThrowableException​(Throwable undeclaredThrowable)
      构造一个 UndeclaredThrowableException与指定的 Throwable 。
      UndeclaredThrowableException​(Throwable undeclaredThrowable, String s)
      构造一个 UndeclaredThrowableException其中包含指定的 Throwable和详细消息。

    • Uses of Throwable in java.net

      Subclasses of Throwable in java.net
      Modifier and Type Class 描述
      class  BindException
      指示尝试将套接字绑定到本地地址和端口时发生错误。
      class  ConnectException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  HttpRetryException
      抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。
      class  MalformedURLException
      抛出以表示发生格式不正确的网址。
      class  NoRouteToHostException
      指示尝试将套接字连接到远程地址和端口时发生错误。
      class  PortUnreachableException
      指示在连接的数据报上收到了ICMP端口不可达消息。
      class  ProtocolException
      抛出以表示底层协议有错误，如TCP错误。
      class  SocketException
      抛出以表示创建或访问Socket时出错。
      class  SocketTimeoutException
      指示在套接字上发生超时时读取或接受。
      class  UnknownHostException
      抛出以表示无法确定主机的IP地址。
      class  UnknownServiceException
      抛出以表示发生未知服务异常。
      class  URISyntaxException
      检查的异常抛出以指示不能将字符串解析为URI引用。

    • Uses of Throwable in java.nio

      Subclasses of Throwable in java.nio
      Modifier and Type Class 描述
      class  BufferOverflowException
      相对 放置操作达到目标缓冲区限制时抛出的未检查异常。
      class  BufferUnderflowException
      当相对 get操作达到源缓冲区的限制时抛出未检查的异常。
      class  InvalidMarkException
      当未定义其标记时尝试复位缓冲区时抛出未检查的异常。
      class  ReadOnlyBufferException
      在只读缓冲区中调用内容突变方法（如 put或 compact ）时调用未检查的异常。

    • Uses of Throwable in java.nio.channels

      Subclasses of Throwable in java.nio.channels
      Modifier and Type Class 描述
      class  AcceptPendingException
      尝试在通道上启动接受操作并且以前的接受操作尚未完成时抛出未检查的异常。
      class  AlreadyBoundException
      尝试将套接字绑定到已绑定的面向网络的通道时抛出未经检查的异常。
      class  AlreadyConnectedException
      当尝试连接已连接的SocketChannel时 ，会抛出未检查的异常。
      class  AsynchronousCloseException
      当线程在I / O操作中关闭通道或阻塞其通道的部分时，由线程检查异常。
      class  CancelledKeyException
      当试图使用不再有效的选择键时抛出未检查的异常。
      class  ClosedByInterruptException
      另一个线程在通道上的I / O操作中被阻塞时，由线程接收到的异常检查。
      class  ClosedChannelException
      当尝试在关闭或至少关闭该操作的通道上调用或完成I / O操作时，检查的异常抛出。
      class  ClosedSelectorException
      尝试在闭合选择器上调用I / O操作时抛出未检查的异常。
      class  ConnectionPendingException
      尝试连接未阻塞连接操作的SocketChannel时，会抛出未检查的异常。
      class  FileLockInterruptionException
      另一个线程在等待获取文件锁时中断它时线程接收到的异常检查。
      class  IllegalBlockingModeException
      当在不正确的阻塞模式下在通道上调用特定于阻止模式的操作时抛出未检查的异常。
      class  IllegalChannelGroupException
      尝试打开不是由同一提供商创建的组中的通道时抛出未检查的异常。
      class  IllegalSelectorException
      当尝试向创建该通道的提供商创建的选择器注册一个通道时抛出未检查的异常。
      class  InterruptedByTimeoutException
      在异步操作完成之前经过一段时间后线程接收到的异常检查。
      class  NoConnectionPendingException
      当未经检查的异常finishConnect一个方法SocketChannel没有首先成功调用被调用connect方法。
      class  NonReadableChannelException
      尝试从最初打开阅读的频道中读取时未抛出的异常。
      class  NonWritableChannelException
      尝试写入最初未打开的通道进行写入时抛出未检查的异常。
      class  NotYetBoundException
      尝试在尚未绑定的服务器套接字通道上调用I / O操作时抛出未检查的异常。
      class  NotYetConnectedException
      当尝试在尚未连接的套接字通道上调用I / O操作时抛出未检查的异常。
      class  OverlappingFileLockException
      当尝试获取与已经被同一Java虚拟机锁定的区域重叠的文件的区域上，或者当另一个线程已经在等待锁定同一文件的重叠区域时尝试获取未锁定的异常。
      class  ReadPendingException
      尝试从异步套接字通道读取并且之前的读取尚未完成时抛出未检查的异常。
      class  ShutdownChannelGroupException
      当尝试构造一个关闭组的通道或I / O操作的完成处理程序无法调用时，抛出未检查的异常，因为通道组已终止。
      class  UnresolvedAddressException
      尝试在未解析的套接字地址上调用网络操作时抛出未检查的异常。
      class  UnsupportedAddressTypeException
      尝试绑定或连接到不支持的类型的套接字地址时抛出未检查的异常。
      class  WritePendingException
      尝试写入异步套接字通道并且之前的写入尚未完成时抛出未检查的异常。
      Methods in java.nio.channels with parameters of type Throwable
      Modifier and Type 方法 描述
      void CompletionHandler.failed​(Throwable exc, A attachment)
      当操作失败时调用。

    • Uses of Throwable in java.nio.charset

      Subclasses of Throwable in java.nio.charset
      Modifier and Type Class 描述
      class  CharacterCodingException
      发生字符编码或解码错误时抛出的检查异常。
      class  CoderMalfunctionError
      错误抛出当decodeLoop方法的CharsetDecoder ，或encodeLoop一个的方法CharsetEncoder ，抛出意外的异常。
      class  IllegalCharsetNameException
      使用不是 legal charset name的字符串时抛出未检查的异常。
      class  MalformedInputException
      当输入字节序列对于给定的字符集不合法时，检查的异常抛出，或输入字符序列不是合法的16位Unicode序列。
      class  UnmappableCharacterException
      输入字符（或字节）序列有效但无法映射到输出字节（或字符）序列时抛出的检查异常。
      class  UnsupportedCharsetException
      对于请求的字符集，当没有可用的支持时抛出未检查的异常。

    • Uses of Throwable in java.nio.file

      Subclasses of Throwable in java.nio.file
      Modifier and Type Class 描述
      class  AccessDeniedException
      文件系统操作被拒绝时引发的检查异常，通常是由于文件权限或其他访问检查。
      class  AtomicMoveNotSupportedException
      当文件不能作为原子文件系统操作移动时，检查的异常抛出。
      class  ClosedDirectoryStreamException
      尝试在关闭的目录流上调用操作时抛出未检查的异常。
      class  ClosedFileSystemException
      尝试在文件上调用操作并关闭文件系统时抛出未检查的异常。
      class  ClosedWatchServiceException
      尝试在关闭的手表服务上调用操作时抛出未检查的异常。
      class  DirectoryIteratorException
      如果在遍历目录中的条目时遇到I / O错误，则抛出运行时异常。
      class  DirectoryNotEmptyException
      由于目录不为空，文件系统操作失败时抛出的检查异常。
      class  FileAlreadyExistsException
      尝试创建文件或目录并且该名称的文件已存在时，检查的异常抛出。
      class  FileSystemAlreadyExistsException
      新新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新200新
      class  FileSystemException
      在一个或两个文件上的文件系统操作失败时抛出。
      class  FileSystemLoopException
      当遇到文件系统循环或循环时抛出的检查异常。
      class  FileSystemNotFoundException
      无法找到文件系统时抛出的运行时异常。
      class  InvalidPathException
      当路径字符串不能转换为Path时，由于路径字符串包含无效字符或路径字符串对于其他文件系统特定的原因无效，因此抛出未检查的异常。
      class  NoSuchFileException
      当尝试访问不存在的文件时抛出检查的异常。
      class  NotDirectoryException
      当文件系统操作用于目录时，由于文件不是目录而导致失败的检查异常。
      class  NotLinkException
      由于文件不是符号链接，文件系统操作失败时抛出的检查异常。
      class  ProviderMismatchException
      当尝试使用由不同文件系统提供程序创建的参数在一个文件系统提供程序创建的对象上调用方法时抛出未检查的异常。
      class  ProviderNotFoundException
      无法找到所需类型的提供者时抛出的运行时异常。
      class  ReadOnlyFileSystemException
      尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。

    • Uses of Throwable in java.nio.file.attribute

      Subclasses of Throwable in java.nio.file.attribute
      Modifier and Type Class 描述
      class  UserPrincipalNotFoundException
      当查找UserPrincipal失败，因为主体不存在时抛出的检查异常。

    • Uses of Throwable in java.rmi

      Subclasses of Throwable in java.rmi
      Modifier and Type Class 描述
      class  AccessException
      一个 AccessException通过一定的方法抛出 java.rmi.Naming类（具体 bind ， rebind ，和 unbind ）和方法 java.rmi.activation.ActivationSystem接口，以指示主叫方不必执行由方法调用所请求的操作。
      class  AlreadyBoundException
      如果尝试将注册表中的对象绑定到已经具有关联绑定的名称，则抛出一个 AlreadyBoundException 。
      class  ConnectException
      如果连接拒绝远程主机进行远程方法调用，则会抛出 ConnectException 。
      class  ConnectIOException
      如果在与远程主机进行远程方法调用的连接时发生 ConnectIOException则抛出 IOException 。
      class  MarshalException
      如果在编组远程调用头，远程方法调用的参数或返回值时发生 MarshalException则抛出 java.io.IOException 。
      class  NoSuchObjectException
      如果尝试调用远程虚拟机中不再存在的对象上的方法，则抛出 NoSuchObjectException 。
      class  NotBoundException
      如果尝试在注册表中查找或取消绑定没有关联绑定的名称，则抛出 NotBoundException 。
      class  RemoteException
      A RemoteException是在执行远程方法调用期间可能发生的许多通信相关异常的常见超类。
      class  RMISecurityException
      已过时。
      改用SecurityException 。 应用程式代码不应该直接引用这个类，而RMISecurityManager不再抛出这个子类的java.lang.SecurityException 。
      class  ServerError
      甲 ServerError被抛出作为远程方法调用的结果，当一个 Error任而解编参数，执行远程方法本身，或编组返回值在处理服务器上的调用，被抛出。
      class  ServerException
      在处理服务器上的调用时抛出 RemoteException ，或者在解组参数或执行远程方法本身时，抛出 ServerException作为远程方法调用的结果。
      class  ServerRuntimeException
      已过时。
      没有替换
      class  StubNotFoundException
      如果远程对象导出时无法找到有效的存根类，则抛出 StubNotFoundException 。
      class  UnexpectedException
      一个 UnexpectedException抛出如果远程方法调用的客户端接收，作为呼叫，检查异常不属于中声明的检查的异常类型的一个结果 throws在远程接口的方法的子句。
      class  UnknownHostException
      如果在创建与远程主机的远程方法调用的连接时发生 UnknownHostException则抛出 java.net.UnknownHostException 。
      class  UnmarshalException
      如果发生以下任何一种 UnmarshalException可以在解组远程方法调用的参数或结果时抛出 UnmarshalException ：如果发生异常时 java.io.IOException调用头，如果返回值的协议无效，如果 java.io.IOException发生解组参数（on服务器端）或返回值（在客户端）。
      Fields in java.rmi declared as Throwable
      Modifier and Type Field 描述
      Throwable RemoteException.detail
      远程异常的原因。
      Methods in java.rmi that return Throwable
      Modifier and Type 方法 描述
      Throwable RemoteException.getCause​()
      返回此异常的原因。
      Constructors in java.rmi with parameters of type Throwable
      Constructor 描述
      RemoteException​(String s, Throwable cause)
      构造一个具有指定的详细信息和原因的 RemoteException 。

    • Uses of Throwable in java.rmi.activation

      Subclasses of Throwable in java.rmi.activation
      Modifier and Type Class 描述
      class  ActivateFailedException
      在远程调用可激活对象时激活失败时，RMI运行时抛出此异常。
      class  ActivationException
      激活界面使用的常规异常。
      class  UnknownGroupException
      一个 UnknownGroupException通过在类和接口方法抛出 java.rmi.activation包时 ActivationGroupID参数的方法被确定为是无效的，即，不通过已知 ActivationSystem 。
      class  UnknownObjectException
      当方法的 ActivationID参数被确定为无效时，通过 java.rmi.activation包中的类和接口的方法抛出一个 UnknownObjectException 。
      Fields in java.rmi.activation declared as Throwable
      Modifier and Type Field 描述
      Throwable ActivationException.detail
      激活异常的原因。
      Methods in java.rmi.activation that return Throwable
      Modifier and Type 方法 描述
      Throwable ActivationException.getCause​()
      返回此异常的原因。
      Constructors in java.rmi.activation with parameters of type Throwable
      Constructor 描述
      ActivationException​(String s, Throwable cause)
      构造一个具有指定的详细信息和原因的 ActivationException 。

    • Uses of Throwable in java.rmi.server

      Subclasses of Throwable in java.rmi.server
      Modifier and Type Class 描述
      class  ExportException
      如果尝试导出远程对象失败，那么 ExportException是抛出的一个 RemoteException 。
      class  ServerCloneException
      甲 ServerCloneException如果一个的克隆过程中发生远程抛出异常 UnicastRemoteObject 。
      class  ServerNotActiveException
      如果在服务远程方法调用之外调用getClientHost方法，则 ServerNotActiveException是在调用 异常期间抛出的 RemoteServer.getClientHost 。
      class  SkeletonMismatchException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SkeletonNotFoundException
      已过时。
      没有替换。 在Java 2平台v1.2及更高版本中，远程方法调用不再需要骷髅。
      class  SocketSecurityException
      已过时。
      这个班已经过时了 改用ExportException 。
      Methods in java.rmi.server that return Throwable
      Modifier and Type 方法 描述
      Throwable ServerCloneException.getCause​()
      返回此异常的原因。
      Methods in java.rmi.server that throw Throwable
      Modifier and Type 方法 描述
      Object RemoteObjectInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)
      处理封装代理实例 proxy上的方法调用，并返回结果。

    • Uses of Throwable in java.security

      Subclasses of Throwable in java.security
      Modifier and Type Class 描述
      class  AccessControlException
      AccessController抛出此异常，以指示所请求的访问（对关键系统资源（如文件系统或网络））被拒绝。
      class  DigestException
      这是通用的消息摘要异常。
      class  GeneralSecurityException
      GeneralSecurityException类是一种通用的安全性异常类，为所有与其扩展的与安全性相关的异常类提供类型安全性。
      class  InvalidAlgorithmParameterException
      这是无效或不合适的算法参数的例外。
      class  InvalidKeyException
      这是无效键（无效编码，长度错误，未初始化等）的例外。
      class  InvalidParameterException
      当将无效参数传递给方法时，将抛出此异常，设计为由JCA / JCE引擎类使用。
      class  KeyException
      这是基本的关键例外。
      class  KeyManagementException
      这是处理密钥管理的所有操作的一般密钥管理例外。
      class  KeyStoreException
      这是通用的KeyStore异常。
      class  NoSuchAlgorithmException
      当请求特定的加密算法但在环境中不可用时抛出此异常。
      class  NoSuchProviderException
      当特定安全提供程序被请求但在环境中不可用时抛出此异常。
      class  PrivilegedActionException
      这个异常是由 doPrivileged(PrivilegedExceptionAction)和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context)抛出的，表示正在执行的操作会抛出一个被检查的异常。
      class  ProviderException
      提供者异常的运行时异常（例如错误配置错误或不可恢复的内部错误），它们可能由提供程序子类化以抛出专门的提供者特定的运行时错误。
      class  SignatureException
      这是一般的签名异常。
      class  UnrecoverableEntryException
      如果密钥库中的条目无法恢复，则抛出此异常。
      class  UnrecoverableKeyException
      如果密钥存储库中的密钥无法恢复，则抛出此异常。
      Methods in java.security that return Throwable
      Modifier and Type 方法 描述
      Throwable PrivilegedActionException.getCause​()
      返回此异常的原因（导致此 PrivilegedActionException的特权计算抛出的异常）。
      Constructors in java.security with parameters of type Throwable
      Constructor 描述
      DigestException​(String message, Throwable cause)
      创建一个 DigestException与指定的详细信息和原因。
      DigestException​(Throwable cause)
      创建 DigestException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      GeneralSecurityException​(String message, Throwable cause)
      创建一个具有指定的详细消息和原因的 GeneralSecurityException 。
      GeneralSecurityException​(Throwable cause)
      创建 GeneralSecurityException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      InvalidAlgorithmParameterException​(String message, Throwable cause)
      创建一个 InvalidAlgorithmParameterException具有指定的详细消息和原因。
      InvalidAlgorithmParameterException​(Throwable cause)
      创建一个 InvalidAlgorithmParameterException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      InvalidKeyException​(String message, Throwable cause)
      创建一个具有指定的详细信息和原因的 InvalidKeyException 。
      InvalidKeyException​(Throwable cause)
      创建一个 InvalidKeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      KeyException​(String message, Throwable cause)
      创建一个 KeyException与指定的详细信息和原因。
      KeyException​(Throwable cause)
      创建 KeyException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      KeyManagementException​(String message, Throwable cause)
      创建一个 KeyManagementException具有指定的详细信息和原因。
      KeyManagementException​(Throwable cause)
      创建 KeyManagementException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      KeyStoreException​(String message, Throwable cause)
      创建一个 KeyStoreException具有指定的详细消息和原因。
      KeyStoreException​(Throwable cause)
      创建 KeyStoreException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      NoSuchAlgorithmException​(String message, Throwable cause)
      创建一个 NoSuchAlgorithmException与指定的详细信息和原因。
      NoSuchAlgorithmException​(Throwable cause)
      创建 NoSuchAlgorithmException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      ProviderException​(String message, Throwable cause)
      创建一个 ProviderException与指定的详细信息和原因。
      ProviderException​(Throwable cause)
      创建 ProviderException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      SignatureException​(String message, Throwable cause)
      创建一个 SignatureException具有指定的详细消息和原因。
      SignatureException​(Throwable cause)
      创建 SignatureException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in java.security.acl

      Subclasses of Throwable in java.security.acl
      Modifier and Type Class 描述
      class  AclNotFoundException
      已过时。
      自1.2以来，该软件包已被java.security.Policy及相关课程所取代。
      class  LastOwnerException
      已过时。
      自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。
      class  NotOwnerException
      已过时。
      自1.2版本以来，该软件包已被java.security.Policy及相关课程所取代。

    • Uses of Throwable in java.security.cert

      Subclasses of Throwable in java.security.cert
      Modifier and Type Class 描述
      class  CertificateEncodingException
      证书编码异常。
      class  CertificateException
      此异常表示各种证书问题之一。
      class  CertificateExpiredException
      证书过期例外
      class  CertificateNotYetValidException
      证书还没有有效的例外。
      class  CertificateParsingException
      证书解析异常。
      class  CertificateRevokedException
      表示X.509证书的异常被撤销。
      class  CertPathBuilderException
      一个例外，指出使用 CertPathBuilder构建认证路径时遇到的各种问题 CertPathBuilder 。
      class  CertPathValidatorException
      表示验证认证路径时遇到的各种问题之一的异常。
      class  CertStoreException
      一个例外，指出从 CertStore检索证书和CRL的各种问题 CertStore 。
      class  CRLException
      CRL（证书撤销列表）异常。
      Constructors in java.security.cert with parameters of type Throwable
      Constructor 描述
      CertificateEncodingException​(String message, Throwable cause)
      创建一个 CertificateEncodingException与指定的详细信息和原因。
      CertificateEncodingException​(Throwable cause)
      创建 CertificateEncodingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      CertificateException​(String message, Throwable cause)
      创建一个 CertificateException具有指定的详细信息和原因。
      CertificateException​(Throwable cause)
      创建 CertificateException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      CertificateParsingException​(String message, Throwable cause)
      创建一个 CertificateParsingException与指定的详细信息和原因。
      CertificateParsingException​(Throwable cause)
      创建 CertificateParsingException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      CertPathBuilderException​(String msg, Throwable cause)
      创建一个 CertPathBuilderException与指定的详细信息和原因。
      CertPathBuilderException​(Throwable cause)
      创建一个包裹指定的throwable的 CertPathBuilderException 。
      CertPathValidatorException​(String msg, Throwable cause)
      创建一个 CertPathValidatorException与指定的详细信息和原因。
      CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index)
      创建具有指定的详细消息，原因，认证路径和索引的 CertPathValidatorException 。
      CertPathValidatorException​(String msg, Throwable cause, CertPath certPath, int index, CertPathValidatorException.Reason reason)
      创建一个 CertPathValidatorException具有指定的详细消息，原因，认证路径，索引和原因。
      CertPathValidatorException​(Throwable cause)
      创建一个 CertPathValidatorException ，它包装指定的throwable。
      CertStoreException​(String msg, Throwable cause)
      创建一个 CertStoreException与指定的详细信息和原因。
      CertStoreException​(Throwable cause)
      创建一个 CertStoreException包装指定的throwable。
      CRLException​(String message, Throwable cause)
      创建一个 CRLException与指定的详细信息和原因。
      CRLException​(Throwable cause)
      创建 CRLException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in java.security.spec

      Subclasses of Throwable in java.security.spec
      Modifier and Type Class 描述
      class  InvalidKeySpecException
      这是无效密钥规范的例外。
      class  InvalidParameterSpecException
      这是无效参数规范的例外。
      Constructors in java.security.spec with parameters of type Throwable
      Constructor 描述
      InvalidKeySpecException​(String message, Throwable cause)
      创建一个 InvalidKeySpecException与指定的详细信息和原因。
      InvalidKeySpecException​(Throwable cause)
      创建一个 InvalidKeySpecException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in java.sql

      Subclasses of Throwable in java.sql
      Modifier and Type Class 描述
      class  BatchUpdateException
      在批量更新操作期间发生错误时，抛出SQLException的子类。
      class  DataTruncation
      由于 DataTruncation异常超出 MaxFieldSize数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取时）。
      class  SQLClientInfoException
      当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。
      class  SQLDataException
      当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLException
      提供有关数据库访问错误或其他错误的信息的异常。
      class  SQLFeatureNotSupportedException
      当SQLState类的值为' 0A '（值为'零'A）时，抛出SQLException的子类。
      class  SQLIntegrityConstraintViolationException
      当SQLState类值为“ 23 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLInvalidAuthorizationSpecException
      当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLNonTransientConnectionException
      抛出SQLState类值为“ 08 ”的SQLException的子类，或者在供应商指定的条件下。
      class  SQLNonTransientException
      SQLException的子类在同一操作的重试实例失败的情况下抛出，除非修正了SQLException的原因。
      class  SQLRecoverableException
      如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，先前失败的操作可能能够成功的情况下抛出SQLException的子类。
      class  SQLSyntaxErrorException
      当SQLState类值为' 42 '时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTimeoutException
      的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。
      class  SQLTransactionRollbackException
      当SQLState类值为“ 40 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTransientConnectionException
      SQLState类值为“ 08 ”的SQLException的子类，或供应商指定的条件。
      class  SQLTransientException
      SQLException的子类在以前失败的操作可能能够成功的情况下被抛出，当操作被重试而没有任何应用程序级功能的干预。
      class  SQLWarning
      提供有关数据库访问警告的信息的异常。
      Methods in java.sql that return types with arguments of type Throwable
      Modifier and Type 方法 描述
      Iterator<Throwable> SQLException.iterator​()
      返回链接的SQLExceptions的迭代器。
      Constructors in java.sql with parameters of type Throwable
      Constructor 描述
      BatchUpdateException​(int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException对象，初始化为给定的 cause和 updateCounts 。
      BatchUpdateException​(String reason, int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， cause和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， cause ，和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。
      BatchUpdateException​(String reason, String SQLState, int vendorCode, long[] updateCounts, Throwable cause)
      构造一个 BatchUpdateException与给定的初始化的对象 reason ， SQLState ， vendorCode cause和 updateCounts 。
      BatchUpdateException​(Throwable cause)
      构造一个 BatchUpdateException对象，用给定的 cause初始化。
      DataTruncation​(int index, boolean parameter, boolean read, int dataSize, int transferSize, Throwable cause)
      创建 DataTruncation与初始化为01004时的SQLState对象 read设定为 true时和22001 read设定为 false ，设置为“数据截断”，供应商代码设置为0的原因，而其他字段被设置为给定值。
      SQLClientInfoException​(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause ， vendorCode和 failedProperties 。
      SQLClientInfoException​(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， SQLState ， cause和 failedProperties 。
      SQLClientInfoException​(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException与给定的初始化的对象 reason ， cause和 failedProperties 。
      SQLClientInfoException​(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
      构造一个 SQLClientInfoException对象，初始化为给定的 cause和 failedProperties 。
      SQLDataException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLDataException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLDataException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLDataException与给定对象 reason ， SQLState和 cause 。
      SQLDataException​(String reason, Throwable cause)
      构造一个 SQLDataException对象与给定的 reason和 cause 。
      SQLDataException​(Throwable cause)
      构造一个 SQLDataException对象与给定的 cause 。
      SQLException​(String reason, String sqlState, int vendorCode, Throwable cause)
      构造一个 SQLException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLException​(String reason, String sqlState, Throwable cause)
      构造一个 SQLException与给定对象 reason ， SQLState和 cause 。
      SQLException​(String reason, Throwable cause)
      构造一个 SQLException对象，给定的 reason和 cause 。
      SQLException​(Throwable cause)
      使用给定的 cause构造一个 SQLException对象。
      SQLFeatureNotSupportedException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLFeatureNotSupportedException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLFeatureNotSupportedException与给定对象 reason ， SQLState和 cause 。
      SQLFeatureNotSupportedException​(String reason, Throwable cause)
      构造一个 SQLFeatureNotSupportedException对象，给定的 reason和 cause 。
      SQLFeatureNotSupportedException​(Throwable cause)
      构造一个 SQLFeatureNotSupportedException对象与给定的 cause 。
      SQLIntegrityConstraintViolationException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLIntegrityConstraintViolationException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLIntegrityConstraintViolationException与给定对象 reason ， SQLState和 cause 。
      SQLIntegrityConstraintViolationException​(String reason, Throwable cause)
      构造一个 SQLIntegrityConstraintViolationException对象与给定的 reason和 cause 。
      SQLIntegrityConstraintViolationException​(Throwable cause)
      使用给定的 cause构造一个 SQLIntegrityConstraintViolationException对象。
      SQLInvalidAuthorizationSpecException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLInvalidAuthorizationSpecException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException与给定对象 reason ， SQLState和 cause 。
      SQLInvalidAuthorizationSpecException​(String reason, Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException对象，给定的 reason和 cause 。
      SQLInvalidAuthorizationSpecException​(Throwable cause)
      构造一个 SQLInvalidAuthorizationSpecException对象与给定的 cause 。
      SQLNonTransientConnectionException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLNonTransientConnectionException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLNonTransientConnectionException与给定对象 reason ， SQLState和 cause 。
      SQLNonTransientConnectionException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTransientException对象。
      SQLNonTransientConnectionException​(Throwable cause)
      构造一个 SQLNonTransientConnectionException对象与给定的 cause 。
      SQLNonTransientException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLNonTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLNonTransientException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLNonTransientException与给定对象 reason ， SQLState和 cause 。
      SQLNonTransientException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTransientException对象。
      SQLNonTransientException​(Throwable cause)
      构造一个 SQLNonTransientException对象与给定的 cause 。
      SQLRecoverableException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLRecoverableException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLRecoverableException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLRecoverableException与给定对象 reason ， SQLState和 cause 。
      SQLRecoverableException​(String reason, Throwable cause)
      构造一个 SQLRecoverableException对象与给定的 reason和 cause 。
      SQLRecoverableException​(Throwable cause)
      构造一个 SQLRecoverableException对象与给定的 cause 。
      SQLSyntaxErrorException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLSyntaxErrorException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLSyntaxErrorException与给定对象 reason ， SQLState和 cause 。
      SQLSyntaxErrorException​(String reason, Throwable cause)
      构造一个 SQLSyntaxErrorException对象，给定的 reason和 cause 。
      SQLSyntaxErrorException​(Throwable cause)
      构造一个 SQLSyntaxErrorException对象与给定的 cause 。
      SQLTimeoutException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTimeoutException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTimeoutException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTimeoutException与给定对象 reason ， SQLState和 cause 。
      SQLTimeoutException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTimeoutException对象。
      SQLTimeoutException​(Throwable cause)
      构造一个 SQLTimeoutException对象与一个给定的 cause 。
      SQLTransactionRollbackException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTransactionRollbackException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTransactionRollbackException与给定对象 reason ， SQLState和 cause 。
      SQLTransactionRollbackException​(String reason, Throwable cause)
      构造一个 SQLTransactionRollbackException对象与给定的 reason和 cause 。
      SQLTransactionRollbackException​(Throwable cause)
      构造一个 SQLTransactionRollbackException对象与给定的 cause 。
      SQLTransientConnectionException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTransientConnectionException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTransientConnectionException与给定对象 reason ， SQLState和 cause 。
      SQLTransientConnectionException​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLTransientConnectionException对象。
      SQLTransientConnectionException​(Throwable cause)
      构造一个 SQLTransientConnectionException对象与给定的 cause 。
      SQLTransientException​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLTransientException与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLTransientException​(String reason, String SQLState, Throwable cause)
      构造一个 SQLTransientException与给定对象 reason ， SQLState和 cause 。
      SQLTransientException​(String reason, Throwable cause)
      构造一个 SQLTransientException对象与给定的 reason和 cause 。
      SQLTransientException​(Throwable cause)
      构造一个 SQLTransientException对象与给定的 cause 。
      SQLWarning​(String reason, String SQLState, int vendorCode, Throwable cause)
      构造一个 SQLWarning与给定对象 reason ， SQLState ， vendorCode和 cause 。
      SQLWarning​(String reason, String SQLState, Throwable cause)
      构造一个 SQLWarning与给定对象 reason ， SQLState和 cause 。
      SQLWarning​(String reason, Throwable cause)
      使用给定的 reason和 cause构造一个 SQLWarning对象。
      SQLWarning​(Throwable cause)
      构造一个 SQLWarning对象与给定的 cause 。

    • Uses of Throwable in java.text

      Subclasses of Throwable in java.text
      Modifier and Type Class 描述
      class  ParseException
      表示解析时意外出现错误。

    • Uses of Throwable in java.time

      Subclasses of Throwable in java.time
      Modifier and Type Class 描述
      class  DateTimeException
      用于在计算日期时间时指示问题的异常。
      Constructors in java.time with parameters of type Throwable
      Constructor 描述
      DateTimeException​(String message, Throwable cause)
      构造一个新的日期时间异常与指定的消息和原因。

    • Uses of Throwable in java.time.format

      Subclasses of Throwable in java.time.format
      Modifier and Type Class 描述
      class  DateTimeParseException
      解析期间发生错误时抛出异常。
      Constructors in java.time.format with parameters of type Throwable
      Constructor 描述
      DateTimeParseException​(String message, CharSequence parsedData, int errorIndex, Throwable cause)
      构造一个新的异常与指定的消息和原因。

    • Uses of Throwable in java.time.temporal

      Subclasses of Throwable in java.time.temporal
      Modifier and Type Class 描述
      class  UnsupportedTemporalTypeException
      UnsupportedTemporalTypeException表示Temporal类不支持ChronoField或ChronoUnit。
      Constructors in java.time.temporal with parameters of type Throwable
      Constructor 描述
      UnsupportedTemporalTypeException​(String message, Throwable cause)
      构造一个新的UnsupportedTemporalTypeException与指定的消息和原因。

    • Uses of Throwable in java.time.zone

      Subclasses of Throwable in java.time.zone
      Modifier and Type Class 描述
      class  ZoneRulesException
      抛出指示时区配置的问题。
      Constructors in java.time.zone with parameters of type Throwable
      Constructor 描述
      ZoneRulesException​(String message, Throwable cause)
      构造一个新的日期时间异常与指定的消息和原因。

    • Uses of Throwable in java.util

      Subclasses of Throwable in java.util
      Modifier and Type Class 描述
      class  ConcurrentModificationException
      当不允许这样的修改时，可以通过检测到对象的并发修改的方法来抛出此异常。
      class  DuplicateFormatFlagsException
      在格式说明符中提供重复标志时抛出未经检查的异常。
      class  EmptyStackException
      由 Stack类中的方法抛出，表示堆栈为空。
      class  FormatFlagsConversionMismatchException
      转换和标志不兼容时抛出未经检查的异常。
      class  FormatterClosedException
      格式化程序已关闭时抛出未检查的异常。
      class  IllegalFormatCodePointException
      当Character.isValidCodePoint(int)定义的具有无效Unicode代码点的字符传递给Formatter时，会抛出未检查的异常。
      class  IllegalFormatConversionException
      当对应于格式说明符的参数是不兼容的类型时抛出未检查的异常。
      class  IllegalFormatException
      当格式字符串包含与给定参数不兼容的非法语法或格式说明符时抛出未检查的异常。
      class  IllegalFormatFlagsException
      提供非法组合标志时抛出未检查的异常。
      class  IllegalFormatPrecisionException
      当精度为 -1以外的值时，抛出未检查的异常，转换不支持精度，否则不支持该值。
      class  IllegalFormatWidthException
      当格式宽度为 -1以外的负值时，将抛出未检查的异常，否则不受支持。
      class  IllformedLocaleException
      由Locale和Locale.Builder中的方法抛出，以表明参数不是一个格式正确的BCP 47标签。
      class  InputMismatchException
      由 Scanner抛出，表示检索到的令牌与预期类型的模式不匹配，或令牌超出预期类型的范围。
      class  InvalidPropertiesFormatException
      抛出以表示操作无法完成，因为输入不符合属性集合的相应XML文档类型，按照Properties规范。
      class  MissingFormatArgumentException
      当有格式说明符没有相应的参数或参数索引引用不存在的参数时抛出未检查的异常。
      class  MissingFormatWidthException
      需要格式宽度时抛出未检查的异常。
      class  MissingResourceException
      表示资源丢失。
      class  NoSuchElementException
      被各种访问器方法抛出，表示被请求的元素不存在。
      class  ServiceConfigurationError
      在查找，加载或实例化服务提供商时发生错误时发生错误。
      class  TooManyListenersException
      TooManyListenersException异常用作Java事件模型的一部分，用于注释和实现组播事件源的单播特殊情况。
      class  UnknownFormatConversionException
      给出未知转换时抛出未检查的异常。
      class  UnknownFormatFlagsException
      给定未知标志时抛出未检查的异常。
      Methods in java.util with type parameters of type Throwable
      Modifier and Type 方法 描述
      <X extends Throwable>
      T             		Optional.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      double             		OptionalDouble.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      int             		OptionalInt.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      long             		OptionalLong.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      Methods in java.util that throw Throwable
      Modifier and Type 方法 描述
      <X extends Throwable>
      T             		Optional.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      double             		OptionalDouble.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      int             		OptionalInt.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      <X extends Throwable>
      long             		OptionalLong.orElseThrow​(Supplier<? extends X> exceptionSupplier)
      如果存在值，则返回值，否则将抛出由异常提供函数产生的异常。
      Constructors in java.util with parameters of type Throwable
      Constructor 描述
      ConcurrentModificationException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      ConcurrentModificationException​(Throwable cause)
      构造具有指定的原因和详细消息的新异常 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause 。
      InvalidPropertiesFormatException​(Throwable cause)
      构造具有指定原因的InvalidPropertiesFormatException。
      ServiceConfigurationError​(String msg, Throwable cause)
      构造具有指定消息和原因的新实例。

    • Uses of Throwable in java.util.concurrent

      Subclasses of Throwable in java.util.concurrent
      Modifier and Type Class 描述
      class  BrokenBarrierException
      当线程尝试等待处于断开状态的屏障或线程等待时进入断开状态时抛出异常。
      class  CancellationException
      异常表示由于任务被取消，无法检索值生成任务的结果，如FutureTask 。
      class  CompletionException
      在完成结果或任务的过程中遇到错误或其他异常时抛出异常。
      class  ExecutionException
      尝试检索通过抛出异常中止的任务的结果时抛出的异常。
      class  RejectedExecutionException
      当任务不能被接受执行时，由一个Executor抛出异常。
      class  TimeoutException
      阻塞操作超时时抛出异常。
      Methods in java.util.concurrent that return Throwable
      Modifier and Type 方法 描述
      Throwable SubmissionPublisher.getClosedException​()
      返回与 closeExceptionally相关联的异常，如果未关闭或正常关闭，则返回null。
      Throwable ForkJoinTask.getException​()
      返回由基本计算引发的异常，如果已取消，则返回 CancellationException ，否则 null ，否则 null方法尚未完成。
      Methods in java.util.concurrent with parameters of type Throwable
      Modifier and Type 方法 描述
      protected void ThreadPoolExecutor.afterExecute​(Runnable r, Throwable t)
      完成指定Runnable的执行后调用方法。
      void SubmissionPublisher.closeExceptionally​(Throwable error)
      除非已经关闭，问题 onError向给定的错误的当前用户发出信号，并且不允许随后的尝试发布。
      boolean CompletableFuture.completeExceptionally​(Throwable ex)
      如果还没有完成，会导致调用 CompletableFuture.get()和相关方法来抛出给定的异常。
      void ForkJoinTask.completeExceptionally​(Throwable ex)
      完成此任务异常，如果尚未中止或取消，将导致给定异常在 join和相关操作。
      static <U> CompletableFuture<U> CompletableFuture.failedFuture​(Throwable ex)
      返回一个已经完成的新的CompletableFuture，特别是给定的异常。
      static <U> CompletionStage<U> CompletableFuture.failedStage​(Throwable ex)
      返回一个已经完成的新的CompletionStage，特别是给定异常，并且仅支持接口CompletionStage中的那些方法。
      void CompletableFuture.obtrudeException​(Throwable ex)
      强制导致后续调用方法 CompletableFuture.get()和相关方法来抛出给定的异常，无论是否已经完成。
      void Flow.Subscriber.onError​(Throwable throwable)
      由发布商或订阅者遇到的不可恢复错误调用方法，之后订阅不会调用其他订阅者方法。
      boolean CountedCompleter.onExceptionalCompletion​(Throwable ex, CountedCompleter<?> caller)
      方法 ForkJoinTask.completeExceptionally(Throwable)被调用或方法 CountedCompleter.compute()抛出异常，并且此任务尚未正常完成时执行操作。
      protected void ForkJoinWorkerThread.onTermination​(Throwable exception)
      执行与该工作线程的终止相关联的清除。
      protected void FutureTask.setException​(Throwable t)
      导致这个未来报告一个ExecutionException作为其原因，除非这个未来已经被设置或被取消。
      Method parameters in java.util.concurrent with type arguments of type Throwable
      Modifier and Type | 方法 | 描述
      CompletableFuture<T> CompletableFuture.exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletableFuture，当CompletableFuture完成时完成，结果是异常触发此CompletableFuture的完成特殊功能的给定功能; 否则，如果此CompletableFuture正常完成，则返回的CompletableFuture也会以相同的值正常完成。
      CompletionStage<T> CompletionStage.exceptionally​(Function<Throwable,? extends T> fn)
      返回一个新的CompletionStage，当此阶段完成异常时，将以此阶段的异常作为提供函数的参数执行。
      <U> CompletableFuture<U> | CompletableFuture.handle​(BiFunction<? super T,Throwable,? extends U> fn)
      <U> CompletionStage<U> CompletionStage.handle​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用此阶段的结果和异常作为所提供函数的参数执行。
      <U> CompletableFuture<U> | CompletableFuture.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      <U> CompletableFuture<U> | CompletableFuture.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      <U> CompletionStage<U> CompletionStage.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn)
      返回一个新的CompletionStage，当该阶段完成正常或异常时，将使用此阶段的默认异步执行工具执行，此阶段的结果和异常作为提供函数的参数。
      <U> CompletionStage<U> CompletionStage.handleAsync​(BiFunction<? super T,Throwable,? extends U> fn, Executor executor)
      返回一个新的CompletionStage，当此阶段正常或异常完成时，将使用提供的执行程序执行此阶段的结果和异常作为提供的函数的参数。
      CompletableFuture<T> | CompletableFuture.whenComplete​(BiConsumer<? super T,? super Throwable> action)
      CompletionStage<T> CompletionStage.whenComplete​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同的结果或异常的新CompletionStage，当此阶段完成时，它将执行给定的操作。
      CompletableFuture<T> | CompletableFuture.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      CompletableFuture<T> | CompletableFuture.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      CompletionStage<T> CompletionStage.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，将使用此阶段的默认异步执行工具执行给定操作。
      CompletionStage<T> CompletionStage.whenCompleteAsync​(BiConsumer<? super T,? super Throwable> action, Executor executor)
      返回与此阶段相同结果或异常的新CompletionStage，当此阶段完成时，使用提供的执行程序执行给定操作。
      Constructors in java.util.concurrent with parameters of type Throwable
      Constructor 描述
      CompletionException​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的 CompletionException 。
      CompletionException​(Throwable cause)
      构造具有指定原因的 CompletionException 。
      ExecutionException​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的 ExecutionException 。
      ExecutionException​(Throwable cause)
      构造具有指定原因的 ExecutionException 。
      RejectedExecutionException​(String message, Throwable cause)
      构造具有指定的详细信息和原因的 RejectedExecutionException 。
      RejectedExecutionException​(Throwable cause)
      构造具有指定原因的 RejectedExecutionException 。
      Constructor parameters in java.util.concurrent with type arguments of type Throwable
      Constructor 描述
      SubmissionPublisher​(Executor executor, int maxBufferCapacity, BiConsumer<? super Flow.Subscriber<? super T>,? super Throwable> handler)
      使用给定的Executor创建一个新的SubmissionPublisher，以便为订阅者提供异步传递，给定每个用户的最大缓冲区大小，如果非空，则在任何订阅者在方法 onNext中引发异常时调用给定的处理程序。

    • Uses of Throwable in java.util.jar

      Subclasses of Throwable in java.util.jar
      Modifier and Type Class 描述
      class  JarException
      表示在读取或写入JAR文件时发生了某种错误。

    • Uses of Throwable in java.util.logging

      Methods in java.util.logging that return Throwable
      Modifier and Type 方法 描述
      Throwable LogRecord.getThrown​()
      获取与日志记录相关联的任何可抛出的值。
      Methods in java.util.logging with parameters of type Throwable
      Modifier and Type 方法 描述
      void Logger.log​(Level level, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息。
      void Logger.log​(Level level, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，并附带相关的Throwable信息。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类和方法。
      void Logger.logp​(Level level, String sourceClass, String sourceMethod, Throwable thrown, Supplier<String> msgSupplier)
      记录一个懒惰构造的消息，指定源类和方法以及相关联的Throwable信息。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown)
      已过时。
      改用Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) 。
      void Logger.logrb​(Level level, String sourceClass, String sourceMethod, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void Logger.logrb​(Level level, ResourceBundle bundle, String msg, Throwable thrown)
      使用相关联的Throwable信息记录消息，指定源类，方法和资源包。
      void LogRecord.setThrown​(Throwable thrown)
      设置与日志事件相关联的可抛出。
      void Logger.throwing​(String sourceClass, String sourceMethod, Throwable thrown)
      日志抛出异常。

    • Uses of Throwable in java.util.prefs

      Subclasses of Throwable in java.util.prefs
      Modifier and Type Class 描述
      class  BackingStoreException
      抛出以表示由于后备存储中的故障而无法完成首选项操作，或无法联系后备存储。
      class  InvalidPreferencesFormatException
      抛出以表示操作无法完成，因为输入符合Preferences规范的首选项集合的相应XML文档类型。
      Constructors in java.util.prefs with parameters of type Throwable
      Constructor 描述
      BackingStoreException​(Throwable cause)
      构造具有指定原因的BackingStoreException。
      InvalidPreferencesFormatException​(String message, Throwable cause)
      构造一个InvalidPreferencesFormatException与指定的详细信息和原因。
      InvalidPreferencesFormatException​(Throwable cause)
      构造具有指定原因的InvalidPreferencesFormatException。

    • Uses of Throwable in java.util.regex

      Subclasses of Throwable in java.util.regex
      Modifier and Type Class 描述
      class  PatternSyntaxException
      抛出未经检查的异常，以指示正则表达式模式中的语法错误。

    • Uses of Throwable in java.util.zip

      Subclasses of Throwable in java.util.zip
      Modifier and Type Class 描述
      class  DataFormatException
      发出数据格式错误的信号。
      class  ZipError
      表示发生了不可恢复的错误。
      class  ZipException
      表示发生了某种类型的Zip异常。

    • Uses of Throwable in javafx.application

      Methods in javafx.application that return Throwable
      Modifier and Type 方法 描述
      Throwable Preloader.ErrorNotification.getCause​()
      检索与此错误通知相关联的异常或错误（如果有）。
      Constructors in javafx.application with parameters of type Throwable
      Constructor 描述
      ErrorNotification​(String location, String details, Throwable cause)
      构造错误通知。

    • Uses of Throwable in javafx.concurrent

      Methods in javafx.concurrent that return Throwable
      Modifier and Type 方法 描述
      Throwable Service.getException​()
      获取属性异常的值。
      Throwable Task.getException​()
      获取属性异常的值。
      Throwable Worker.getException​()
      表示工人运行时发生的异常（如果有）。
      Methods in javafx.concurrent that return types with arguments of type Throwable
      Modifier and Type | 方法 | 描述
      ReadOnlyObjectProperty<Throwable> | Service.exceptionProperty​()
      ReadOnlyObjectProperty<Throwable> | Task.exceptionProperty​()
      ReadOnlyObjectProperty<Throwable> Worker.exceptionProperty​()
      获取表示发生的任何异常的ReadOnlyObjectProperty。

    • Uses of Throwable in javafx.fxml

      Subclasses of Throwable in javafx.fxml
      Modifier and Type Class 描述
      class  LoadException
      在加载操作期间遇到错误时抛出。
      Constructors in javafx.fxml with parameters of type Throwable
      Constructor 描述
      LoadException​(String message, Throwable cause)
      LoadException​(Throwable cause)

    • Uses of Throwable in javafx.scene.media

      Subclasses of Throwable in javafx.scene.media
      Modifier and Type Class 描述
      class  MediaException
      甲MediaException描述了在运行时错误条件Media ， MediaPlayer或MediaView 。

    • Uses of Throwable in javafx.scene.transform

      Subclasses of Throwable in javafx.scene.transform
      Modifier and Type Class 描述
      class  NonInvertibleTransformException
      NonInvertibleTransformException类表示如果执行的操作需要处于非可逆状态的 Transform对象的倒数时抛出异常。

    • Uses of Throwable in javafx.scene.web

      Methods in javafx.scene.web that return Throwable
      Modifier and Type 方法 描述
      Throwable WebErrorEvent.getException​()
      返回与此事件关联的异常。
      Constructors in javafx.scene.web with parameters of type Throwable
      Constructor 描述
      WebErrorEvent​(Object source, EventType<WebErrorEvent> type, String message, Throwable exception)
      创建一个新的 WebErrorEvent 。

    • Uses of Throwable in javax.activation

      Subclasses of Throwable in javax.activation
      Modifier and Type Class 描述
      class  MimeTypeParseException
      封装MimeType解析相关异常的类。
      class  UnsupportedDataTypeException
      表示请求的操作不支持请求的数据类型。

    • Uses of Throwable in javax.activity

      Subclasses of Throwable in javax.activity
      Modifier and Type Class 描述
      class  ActivityCompletedException
      可能会在访问活动上下文的任何方法上抛出此异常，并指示活动中正在进行的工作是不可能的。
      class  ActivityRequiredException
      如果活动上下文是强制性的方法未收到活动上下文，则容器将抛出此异常。
      class  InvalidActivityException
      可以在访问Activity上下文的任何方法上抛出此异常，并指示与尝试调用相关联的尝试调用或活动上下文与Activity的当前状态不兼容。
      Constructors in javax.activity with parameters of type Throwable
      Constructor 描述
      ActivityCompletedException​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      ActivityCompletedException​(Throwable cause)
      构造具有指定原因的新的throwable。
      ActivityRequiredException​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      ActivityRequiredException​(Throwable cause)
      构造具有指定原因的新的throwable。
      InvalidActivityException​(String message, Throwable cause)
      构造一个新的可抛出指定的详细信息和原因。
      InvalidActivityException​(Throwable cause)
      构造具有指定原因的新的throwable。

    • Uses of Throwable in javax.annotation.processing

      Subclasses of Throwable in javax.annotation.processing
      Modifier and Type Class 描述
      class  FilerException
      表示Filer检测到尝试打开文件将违反Filer提供的保证。

    • Uses of Throwable in javax.crypto

      Subclasses of Throwable in javax.crypto
      Modifier and Type Class 描述
      class  AEADBadTagException
      当以AEAD模式运行的Cipher （例如GCM / CCM）无法验证提供的认证标记时，会抛出此异常。
      class  BadPaddingException
      当期望输入数据的特定填充机制但数据未正确填充时，会抛出此异常。
      class  ExemptionMechanismException
      这是通用的ExemptionMechanism异常。
      class  IllegalBlockSizeException
      当提供给块密码的数据长度不正确时，抛出此异常，即与密码的块大小不匹配。
      class  NoSuchPaddingException
      当请求特定的填充机制但在环境中不可用时抛出此异常。
      class  ShortBufferException
      当用户提供的输出缓冲区太短而不能保存操作结果时，抛出此异常。

    • Uses of Throwable in javax.imageio

      Subclasses of Throwable in javax.imageio
      Modifier and Type Class 描述
      class  IIOException
      用于发信号读取和写入操作失败的异常类。
      Constructors in javax.imageio with parameters of type Throwable
      Constructor 描述
      IIOException​(String message, Throwable cause)
      构造一个 IIOException与给定的消息 String和一个 Throwable这是其根本原因。

    • Uses of Throwable in javax.imageio.metadata

      Subclasses of Throwable in javax.imageio.metadata
      Modifier and Type Class 描述
      class  IIOInvalidTreeException
      一个 IIOInvalidTreeException当被试图抛出 IIOMetadata对象来解析树 IIOMetadataNode小号失败。
      Constructors in javax.imageio.metadata with parameters of type Throwable
      Constructor 描述
      IIOInvalidTreeException​(String message, Throwable cause, Node offendingNode)
      构造一个 IIOInvalidTreeException其中包含一条消息字符串，引用此异常的异常的引用，以及引用该解析错误的 Node引用。

    • Uses of Throwable in javax.imageio.spi

      Methods in javax.imageio.spi that throw Throwable
      Modifier and Type 方法 描述
      void ServiceRegistry.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应该修改为使用替代清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of Throwable in javax.imageio.stream

      Methods in javax.imageio.stream that throw Throwable
      Modifier and Type 方法 描述
      protected void FileCacheImageInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void FileImageInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理而覆盖finalize子类应该修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void FileImageOutputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void ImageInputStreamImpl.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应被修改为使用替代的清理机制，并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确地确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。
      protected void MemoryCacheImageInputStream.finalize​()
      已过时。
      finalize方法已被弃用。 为了执行清理，覆盖finalize子类应该被修改为使用替代的清理机制并删除覆盖的finalize方法。 当覆盖finalize方法时，其实现必须明确确保按照super.finalize()中所述调用super.finalize() 。 有关迁移选项的更多信息，请参阅Object.finalize()的规范。

    • Uses of Throwable in javax.jnlp

      Subclasses of Throwable in javax.jnlp
      Modifier and Type Class 描述
      class  UnavailableServiceException
      该 UnavailableServiceException被抛出 ServiceManager当不存在或无法使用服务抬头。

    • Uses of Throwable in javax.lang.model

      Subclasses of Throwable in javax.lang.model
      Modifier and Type Class 描述
      class  UnknownEntityException
      例外的超类，表示遇到一个未知类型的实体。

    • Uses of Throwable in javax.lang.model.element

      Subclasses of Throwable in javax.lang.model.element
      Modifier and Type Class 描述
      class  UnknownAnnotationValueException
      表示遇到未知类型的注释值。
      class  UnknownDirectiveException
      表示遇到未知类型的模块指令。
      class  UnknownElementException
      表示遇到未知类型的元素。

    • Uses of Throwable in javax.lang.model.type

      Subclasses of Throwable in javax.lang.model.type
      Modifier and Type Class 描述
      class  MirroredTypeException
      当应用程序尝试访问对应于TypeMirror的Class对象时抛出 。
      class  MirroredTypesException
      当应用程序试图访问的序列抛出Class个每一个对应于对象TypeMirror 。
      class  UnknownTypeException
      表示遇到未知类型的类型。

    • Uses of Throwable in javax.management

      Subclasses of Throwable in javax.management
      Modifier and Type Class 描述
      class  AttributeNotFoundException
      指定的属性不存在或无法检索。
      class  BadAttributeValueExpException
      当无效的MBean属性传递给查询构造方法时抛出。
      class  BadBinaryOpValueExpException
      当无效表达式传递给构造查询的方法时抛出。
      class  BadStringOperationException
      当无效的字符串操作传递给构造查询的方法时抛出。
      class  InstanceAlreadyExistsException
      MBean已经在存储库中注册。
      class  InstanceNotFoundException
      存储库中不存在指定的MBean。
      class  IntrospectionException
      在MBean的内省期间发生了一个例外。
      class  InvalidApplicationException
      当尝试应用以下任一操作时抛出：将MBean的子查询表达式或对错误类的MBean的限定属性表达式。
      class  InvalidAttributeValueException
      指定的值对属性无效。
      class  JMException
      JMX实现抛出异常。
      class  JMRuntimeException
      JMX实现发出的运行时异常。
      class  ListenerNotFoundException
      存储库中不存在指定的MBean侦听器。
      class  MalformedObjectNameException
      字符串的格式不对应于有效的ObjectName。
      class  MBeanException
      表示代理中MBean方法抛出的“用户定义”异常。
      class  MBeanRegistrationException
      包含由预寄存器（），preDeregister（）方法抛出的异常 MBeanRegistration接口。
      class  NotCompliantMBeanException
      尝试在不符合JMX的MBean的MBean服务器中注册对象时发生的异常。
      class  OperationsException
      表示对MBean执行操作时MBean服务器中抛出的异常。
      class  ReflectionException
      表示在使用java.lang.reflect类调用MBean方法时，MBean服务器中抛出的异常。
      class  RuntimeErrorException
      当 java.lang.Error发生 java.lang.Error时，应该被捕获并重新抛出为 RuntimeErrorException 。
      class  RuntimeMBeanException
      表示代理中MBean方法抛出的运行时异常。
      class  RuntimeOperationsException
      表示在对MBean执行操作时在代理中抛出的运行时异常。
      class  ServiceNotFoundException
      表示不支持请求的服务时引发的异常。
      Methods in javax.management that return Throwable
      Modifier and Type 方法 描述
      Throwable MBeanException.getCause​()
      返回实际抛出异常 。
      Throwable ReflectionException.getCause​()
      返回实际抛出的异常 。
      Throwable RuntimeErrorException.getCause​()
      返回实际抛出的Error 。
      Throwable RuntimeMBeanException.getCause​()
      返回实际抛出的RuntimeException 。
      Throwable RuntimeOperationsException.getCause​()
      返回实际抛出的RuntimeException 。
      Methods in javax.management that throw Throwable
      Modifier and Type | 方法 | 描述
      Object | MBeanServerInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

    • Uses of Throwable in javax.management.modelmbean

      Subclasses of Throwable in javax.management.modelmbean
      Modifier and Type Class 描述
      class  InvalidTargetObjectTypeException
      指定无效目标对象类型时抛出异常。
      class  XMLParseException
      当将XML格式化的字符串解析为ModelMBean对象或从ModelMBean对象创建XML格式的字符串时，将抛出此异常。

    • Uses of Throwable in javax.management.monitor

      Subclasses of Throwable in javax.management.monitor
      Modifier and Type Class 描述
      class  MonitorSettingException
      监视器设置在监视器运行时无效时由监视器抛出异常。

    • Uses of Throwable in javax.management.openmbean

      Subclasses of Throwable in javax.management.openmbean
      Modifier and Type Class 描述
      class  InvalidKeyException
      抛出此运行时异常以指示预期为 复合数据的项名称或 表格数据的行索引的方法参数无效。
      class  InvalidOpenTypeException
      抛出此运行时异常以指示 打开的类型的 打开数据值不是预期的。
      class  KeyAlreadyExistsException
      抛出此运行时异常以指示要添加到 表格数据实例的行的索引已被用于引用此 表格数据实例中的另一行。
      class  OpenDataException
      当 打开类型 ， 打开数据或 打开的MBean元数据信息实例无法构造时，抛出此检查的异常，因为一个或多个有效性约束不被满足。
      Methods in javax.management.openmbean that throw Throwable
      Modifier and Type | 方法 | 描述
      Object | CompositeDataInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

    • Uses of Throwable in javax.management.relation

      Subclasses of Throwable in javax.management.relation
      Modifier and Type Class 描述
      class  InvalidRelationIdException
      当已经使用关系id提供给关系时，引发异常。
      class  InvalidRelationServiceException
      当提供无效的关系服务时，引发异常。
      class  InvalidRelationTypeException
      关系类型无效
      class  InvalidRoleInfoException
      当在角色信息中，其最小度大于其最大度时，会引发此异常。
      class  InvalidRoleValueException
      角色值无效。
      class  RelationException
      这个类是在关系管理期间可以提出的任何异常的超类。
      class  RelationNotFoundException
      当关系服务中的给定关系ID没有关系时，会引发此异常。
      class  RelationServiceNotRegisteredException
      当对关系服务进行访问并且没有注册时，会引发此异常。
      class  RelationTypeNotFoundException
      当在关系服务中没有给定名称的关系类型时，引发异常。
      class  RoleInfoNotFoundException
      当给定的关系类型中没有给定名称的角色信息时，会引发此异常。
      class  RoleNotFoundException
      当关系中的角色不存在或不可读或不可设置时，引发此异常。

    • Uses of Throwable in javax.management.remote

      Subclasses of Throwable in javax.management.remote
      Modifier and Type Class 描述
      class  JMXProviderException
      当提供者存在所需协议但不能由于某种原因使用时，由JMXConnectorFactory和JMXConnectorServerFactory抛出异常。
      class  JMXServerErrorException
      在处理远程MBean服务器中的调用时抛出Error时抛出的异常作为远程MBeanServer方法调用的结果。
      Methods in javax.management.remote that return Throwable
      Modifier and Type | 方法 | 描述
      Throwable | JMXProviderException.getCause​()
      Throwable | JMXServerErrorException.getCause​()
      Constructors in javax.management.remote with parameters of type Throwable
      Constructor 描述
      JMXProviderException​(String message, Throwable cause)
      构造具有指定的详细消息和嵌套异常的 JMXProviderException 。

    • Uses of Throwable in javax.naming

      Subclasses of Throwable in javax.naming
      Modifier and Type Class 描述
      class  AuthenticationException
      访问命名或目录服务时发生身份验证错误时抛出此异常。
      class  AuthenticationNotSupportedException
      当不支持所请求的身份验证的特定风格时，会抛出此异常。
      class  CannotProceedException
      抛出此异常以指示操作达到操作无法继续进行的名称中的一个点。
      class  CommunicationException
      当客户端无法与目录或命名服务通信时，抛出此异常。
      class  ConfigurationException
      出现配置问题时抛出此异常。
      class  ContextNotEmptyException
      尝试销毁不为空的上下文时抛出此异常。
      class  InsufficientResourcesException
      当资源不可用来完成请求的操作时，抛出此异常。
      class  InterruptedNamingException
      正在调用的命名操作已被中断时抛出此异常。
      class  InvalidNameException
      此异常表示指定的名称不符合命名系统的命名语法。
      class  LimitExceededException
      当方法由于用户或系统指定的限制而异常终止时，会抛出此异常。
      class  LinkException
      此异常用于描述解决链接时遇到的问题。
      class  LinkLoopException
      当尝试解析链接时检测到一个循环，或者达到链接计数的实现特定限制时，会抛出此异常。
      class  MalformedLinkException
      当解决或构建链接时遇到格式错误的链接时抛出此异常。
      class  NameAlreadyBoundException
      通过方法抛出此异常，表示无法添加绑定，因为该名称已被绑定到另一个对象。
      class  NameNotFoundException
      当名称的组件由于未绑定而无法解析时抛出此异常。
      class  NamingException
      这是Context和DirContext接口中的操作抛出的所有异常的超类。
      class  NamingSecurityException
      这是Context和DirContext接口中的操作抛出的与安全相关异常的超类。
      class  NoInitialContextException
      当不能创建初始上下文实现时，抛出此异常。
      class  NoPermissionException
      尝试执行客户端没有权限的操作时抛出此异常。
      class  NotContextException
      当命名操作进行到需要上下文以继续操作的点时抛出此异常，但解析的对象不是上下文。
      class  OperationNotSupportedException
      当上下文实现不支持正在调用的操作时，抛出此异常。
      class  PartialResultException
      抛出此异常以指示到目前为止返回或返回的结果是部分的，并且该操作无法完成。
      class  ReferralException
      此抽象类用于表示引用异常，该引用异常是响应于LDAP v3服务器返回的 引用而生成的。
      class  ServiceUnavailableException
      尝试与目录或命名服务通信并且该服务不可用时，会抛出此异常。
      class  SizeLimitExceededException
      当方法产生超过大小相关限制的结果时，抛出此异常。
      class  TimeLimitExceededException
      当方法不在指定的时间限制内终止时，抛出此异常。
      Fields in javax.naming declared as Throwable
      Modifier and Type Field 描述
      protected Throwable NamingException.rootException
      包含导致此NamingException被抛出的原始异常。
      Methods in javax.naming that return Throwable
      Modifier and Type 方法 描述
      Throwable NamingException.getCause​()
      返回此异常的原因。
      Throwable NamingException.getRootCause​()
      检索此NamingException的根本原因（如果有）。
      Throwable NamingException.initCause​(Throwable cause)
      将此异常的原因初始化为指定的值。
      Methods in javax.naming with parameters of type Throwable
      Modifier and Type 方法 描述
      Throwable NamingException.initCause​(Throwable cause)
      将此异常的原因初始化为指定的值。
      void NamingException.setRootCause​(Throwable e)
      记录此NamingException的根本原因。

    • Uses of Throwable in javax.naming.directory

      Subclasses of Throwable in javax.naming.directory
      Modifier and Type Class 描述
      class  AttributeInUseException
      当操作尝试添加已经存在的属性时，抛出此异常。
      class  AttributeModificationException
      当尝试添加，删除或修改与属性（模式）定义或属性状态相冲突的属性，其标识符或其值时，将抛出此异常。
      class  InvalidAttributeIdentifierException
      当尝试添加以创建具有无效属性标识符的属性时，会抛出此异常。
      class  InvalidAttributesException
      尝试添加或修改不完整或不正确指定的属性集时，会抛出此异常。
      class  InvalidAttributeValueException
      当尝试向属性添加与属性的模式定义冲突的值时，将抛出此类。
      class  InvalidSearchControlsException
      当搜索操作的SearchControls的规范无效时，抛出此异常。
      class  InvalidSearchFilterException
      当搜索过滤器的规范无效时抛出此异常。
      class  NoSuchAttributeException
      尝试访问不存在的属性时抛出此异常。
      class  SchemaViolationException
      当某种方法违反模式时，抛出此异常。

    • Uses of Throwable in javax.naming.ldap

      Subclasses of Throwable in javax.naming.ldap
      Modifier and Type Class 描述
      class  LdapReferralException
      此抽象类用于表示LDAP引用异常。

    • Uses of Throwable in javax.net.ssl

      Subclasses of Throwable in javax.net.ssl
      Modifier and Type Class 描述
      class  SSLException
      表示由SSL子系统检测到的某种错误。
      class  SSLHandshakeException
      表示客户端和服务器无法协商所需的安全级别。
      class  SSLKeyException
      报告错误的SSL密钥。
      class  SSLPeerUnverifiedException
      表示对等体的身份尚未验证。
      class  SSLProtocolException
      报告SSL协议操作中的错误。
      Constructors in javax.net.ssl with parameters of type Throwable
      Constructor 描述
      SSLException​(String message, Throwable cause)
      创建一个 SSLException与指定的详细信息和原因。
      SSLException​(Throwable cause)
      创建 SSLException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in javax.print

      Subclasses of Throwable in javax.print
      Modifier and Type Class 描述
      class  PrintException
      PrintException类封装了在使用Print Service实例时发生的与打印相关的错误条件。

    • Uses of Throwable in javax.print.attribute

      Subclasses of Throwable in javax.print.attribute
      Modifier and Type Class 描述
      class  UnmodifiableSetException
      抛出以表示所请求的操作无法执行，因为该集合是不可修改的。

    • Uses of Throwable in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type Throwable
      Modifier and Type 方法 描述
      static RemoteException Util.wrapException​(Throwable orig)
      包装一个实现方法抛出的异常。
      RemoteException UtilDelegate.wrapException​(Throwable obj)
      代表团要求 Util.wrapException(java.lang.Throwable) 。

    • Uses of Throwable in javax.script

      Subclasses of Throwable in javax.script
      Modifier and Type Class 描述
      class  ScriptException
      脚本API的通用 异常类。

    • Uses of Throwable in javax.security.auth

      Subclasses of Throwable in javax.security.auth
      Modifier and Type Class 描述
      class  DestroyFailedException
      表示 destroy操作失败。
      class  RefreshFailedException
      表示 refresh操作失败。

    • Uses of Throwable in javax.security.auth.callback

      Subclasses of Throwable in javax.security.auth.callback
      Modifier and Type Class 描述
      class  UnsupportedCallbackException
      信号一个 CallbackHandler不识别一个特定的 Callback 。

    • Uses of Throwable in javax.security.auth.login

      Subclasses of Throwable in javax.security.auth.login
      Modifier and Type Class 描述
      class  AccountException
      通用帐户异常。
      class  AccountExpiredException
      表示用户帐户已过期。
      class  AccountLockedException
      指示帐户被锁定。
      class  AccountNotFoundException
      表示找不到帐户。
      class  CredentialException
      通用凭证异常。
      class  CredentialExpiredException
      信号，一个 Credential已经过期。
      class  CredentialNotFoundException
      表示没有找到凭据。
      class  FailedLoginException
      表示用户身份验证失败。
      class  LoginException
      这是基本的登录异常。

    • Uses of Throwable in javax.security.cert

      Subclasses of Throwable in javax.security.cert
      Modifier and Type Class 描述
      class  CertificateEncodingException
      已过时。
      使用java.security.cert的类。
      class  CertificateException
      已过时。
      使用java.security.cert的类。
      class  CertificateExpiredException
      已过时。
      使用java.security.cert的类。
      class  CertificateNotYetValidException
      已过时。
      使用java.security.cert的类。
      class  CertificateParsingException
      已过时。
      使用java.security.cert的类。

    • Uses of Throwable in javax.security.sasl

      Subclasses of Throwable in javax.security.sasl
      Modifier and Type Class 描述
      class  AuthenticationException
      由SASL机制实现引发此异常，以指示SASL交换机由于与认证有关的原因（例如无效的身份，密码或密钥）而失败。
      class  SaslException
      此类表示使用SASL时发生的错误。
      Methods in javax.security.sasl that return Throwable
      Modifier and Type | 方法 | 描述
      Throwable | SaslException.getCause​()
      Throwable | SaslException.initCause​(Throwable cause)
      Methods in javax.security.sasl with parameters of type Throwable
      Modifier and Type | 方法 | 描述
      Throwable | SaslException.initCause​(Throwable cause)
      Constructors in javax.security.sasl with parameters of type Throwable
      Constructor 描述
      AuthenticationException​(String detail, Throwable ex)
      构造一个新的实例 AuthenticationException其中包含详细的消息和根异常。
      SaslException​(String detail, Throwable ex)
      构造一个新的实例 SaslException其中包含详细的消息和根异常。

    • Uses of Throwable in javax.smartcardio

      Subclasses of Throwable in javax.smartcardio
      Modifier and Type Class 描述
      class  CardException
      在与智能卡堆栈或卡本身通信期间发生的错误异常。
      class  CardNotPresentException
      当应用程序尝试与没有存在卡的终端建立连接时抛出异常。
      Constructors in javax.smartcardio with parameters of type Throwable
      Constructor 描述
      CardException​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的新CardException。
      CardException​(Throwable cause)
      构造一个具有指定原因的新CardException和一个详细信息 (cause==null ?
      CardNotPresentException​(String message, Throwable cause)
      构造一个新的具有指定的详细信息和原因的CardNotPresentException。
      CardNotPresentException​(Throwable cause)
      构造新的具有指定原因的 (cause==null ?和详细信息 (cause==null ?

    • Uses of Throwable in javax.sound.midi

      Subclasses of Throwable in javax.sound.midi
      Modifier and Type Class 描述
      class  InvalidMidiDataException
      一个 InvalidMidiDataException表示遇到不适当的MIDI数据。
      class  MidiUnavailableException
      当请求的MIDI组件由于不可用而无法打开或创建时，将抛出 MidiUnavailableException 。

    • Uses of Throwable in javax.sound.sampled

      Subclasses of Throwable in javax.sound.sampled
      Modifier and Type Class 描述
      class  LineUnavailableException
      A LineUnavailableException是一个例外，指示无法打开行，因为它不可用。
      class  UnsupportedAudioFileException
      一个 UnsupportedAudioFileException是一个例外，指示操作失败，因为文件不包含已识别的文件类型和格式的有效数据。

    • Uses of Throwable in javax.sql.rowset

      Subclasses of Throwable in javax.sql.rowset
      Modifier and Type Class 描述
      class  RowSetWarning
      SQLException的扩展名，它提供有关 RowSet对象上设置的数据库警告的信息。

    • Uses of Throwable in javax.sql.rowset.serial

      Subclasses of Throwable in javax.sql.rowset.serial
      Modifier and Type Class 描述
      class  SerialException
      指示和错误的序列化或 BLOB, CLOB, STRUCT or ARRAY序列化的SQL类型，如 BLOB, CLOB, STRUCT or ARRAY除了SQL类型，如 DATALINK and JAVAOBJECT

    • Uses of Throwable in javax.sql.rowset.spi

      Subclasses of Throwable in javax.sql.rowset.spi
      Modifier and Type Class 描述
      class  SyncFactoryException
      表示错误 SyncFactory机制。
      class  SyncProviderException
      表示 SyncProvider机制出现错误。

    • Uses of Throwable in javax.swing

      Subclasses of Throwable in javax.swing
      Modifier and Type Class 描述
      class  UnsupportedLookAndFeelException
      表示所请求的外观和感觉管理类的异常不在用户系统上。

    • Uses of Throwable in javax.swing.text

      Subclasses of Throwable in javax.swing.text
      Modifier and Type Class 描述
      class  BadLocationException
      此异常是报告文档模型中的不良位置（即尝试引用不存在的位置）。
      class  ChangedCharSetException
      ChangedCharSetException作为名称指示是在更改字符集时抛出的异常。

    • Uses of Throwable in javax.swing.tree

      Subclasses of Throwable in javax.swing.tree
      Modifier and Type Class 描述
      class  ExpandVetoException
      用于阻止扩展/崩溃的异常发生。

    • Uses of Throwable in javax.swing.undo

      Subclasses of Throwable in javax.swing.undo
      Modifier and Type Class 描述
      class  CannotRedoException
      抛出一个UndoableEdit被告知到 redo()而不能。
      class  CannotUndoException
      抛出一个UndoableEdit被告知 undo()并且不能。

    • Uses of Throwable in javax.transaction

      Subclasses of Throwable in javax.transaction
      Modifier and Type Class 描述
      class  InvalidTransactionException
      此异常表示请求携带无效的事务上下文。
      class  TransactionRequiredException
      此异常指示请求携带空事务上下文，但目标对象需要激活事务。
      class  TransactionRolledbackException
      此异常表示与请求的处理关联的事务已回滚，或标记为回滚。

    • Uses of Throwable in javax.transaction.xa

      Subclasses of Throwable in javax.transaction.xa
      Modifier and Type Class 描述
      class  XAException
      资源管理器（RM）抛出XAException，以通知事务管理器涉及的事务遇到的错误。

    • Uses of Throwable in javax.xml.bind

      Subclasses of Throwable in javax.xml.bind
      Modifier and Type Class 描述
      class  DataBindingException
      表示JAXB操作失败的异常。
      class  JAXBException
      这是所有JAXB异常的根异常类。
      class  MarshalException
      此异常表示在执行提供程序无法恢复的组织操作时发生错误。
      class  PropertyException
      此异常表示获取或设置属性时遇到错误。
      class  TypeConstraintException
      此异常表示检测到违反动态检查的类型约束。
      class  UnmarshalException
      此异常表示执行卸载操作时发生错误，阻止JAXB提供程序完成操作。
      class  ValidationException
      此异常表示执行验证操作时发生错误。
      Methods in javax.xml.bind that return Throwable
      Modifier and Type | 方法 | 描述
      Throwable | JAXBException.getCause​()
      Throwable JAXBException.getLinkedException​()
      获取链接的异常
      Throwable TypeConstraintException.getLinkedException​()
      获取链接的异常
      Throwable ValidationEvent.getLinkedException​()
      检索此警告/错误的链接异常。
      Methods in javax.xml.bind with parameters of type Throwable
      Modifier and Type 方法 描述
      void JAXBException.setLinkedException​(Throwable exception)
      添加链接异常。
      void TypeConstraintException.setLinkedException​(Throwable exception)
      添加链接异常。
      Constructors in javax.xml.bind with parameters of type Throwable
      Constructor 描述
      DataBindingException​(String message, Throwable cause)
      DataBindingException​(Throwable cause)
      JAXBException​(String message, String errorCode, Throwable exception)
      构造具有指定的详细消息，供应商特定的错误代码和linkedException的JAXBException。
      JAXBException​(String message, Throwable exception)
      构造具有指定的详细消息和linkedException的JAXBException。
      JAXBException​(Throwable exception)
      使用linkedException构造一个JAXBException。
      MarshalException​(String message, String errorCode, Throwable exception)
      构造具有指定的详细消息，供应商特定的错误代码和linkedException的MarshalException。
      MarshalException​(String message, Throwable exception)
      使用指定的详细消息和linkedException构造MarshalException。
      MarshalException​(Throwable exception)
      使用linkedException构造MarshalException。
      PropertyException​(String message, String errorCode, Throwable exception)
      使用指定的详细消息，供应商特定的错误代码和linkedException构造PropertyException。
      PropertyException​(String message, Throwable exception)
      使用指定的详细消息和linkedException构造PropertyException。
      PropertyException​(Throwable exception)
      使用linkedException构造PropertyException。
      TypeConstraintException​(String message, String errorCode, Throwable exception)
      构造具有指定的详细消息，供应商特定的错误代码和linkedException的TypeConstraintException。
      TypeConstraintException​(String message, Throwable exception)
      使用指定的详细消息和linkedException构造TypeConstraintException。
      TypeConstraintException​(Throwable exception)
      构造一个带有LinkedException的TypeConstraintException。
      UnmarshalException​(String message, String errorCode, Throwable exception)
      构造具有指定的详细消息，供应商特定的错误代码和linkedException的UnmarshalException。
      UnmarshalException​(String message, Throwable exception)
      使用指定的详细消息和linkedException构造UnmarshalException。
      UnmarshalException​(Throwable exception)
      使用linkedException构造UnmarshalException。
      ValidationException​(String message, String errorCode, Throwable exception)
      使用指定的详细消息，供应商特定的错误代码和linkedException构造ValidationException。
      ValidationException​(String message, Throwable exception)
      使用指定的详细消息和linkedException构造ValidationException。
      ValidationException​(Throwable exception)
      使用linkedException构造ValidationException。

    • Uses of Throwable in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Throwable
      Modifier and Type | 方法 | 描述
      Throwable | ValidationEventImpl.getLinkedException​()
      Methods in javax.xml.bind.helpers with parameters of type Throwable
      Modifier and Type 方法 描述
      void ValidationEventImpl.setLinkedException​(Throwable _linkedException)
      设置此事件的链接异常字段。
      Constructors in javax.xml.bind.helpers with parameters of type Throwable
      Constructor 描述
      NotIdentifiableEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      创建一个新的NotIdentifiableEventImpl。
      ParseConversionEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      创建一个新的ParseConversionEventImpl。
      PrintConversionEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      创建一个新的PrintConversionEventImpl。
      ValidationEventImpl​(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      创建一个新的ValidationEventImpl。

    • Uses of Throwable in javax.xml.catalog

      Subclasses of Throwable in javax.xml.catalog
      Modifier and Type Class 描述
      class  CatalogException
      异常类处理在处理或使用目录时可能发生的错误。
      Constructors in javax.xml.catalog with parameters of type Throwable
      Constructor 描述
      CatalogException​(String message, Throwable cause)
      构造一个具有指定的详细信息和原因的新的CatalogException。

    • Uses of Throwable in javax.xml.crypto

      Subclasses of Throwable in javax.xml.crypto
      Modifier and Type Class 描述
      class  KeySelectorException
      表示KeySelector抛出的异常情况。
      class  MarshalException
      表示在XML编组或解组过程中发生的异常情况。
      class  NoSuchMechanismException
      当请求特定的XML机制但在环境中不可用时抛出此异常。
      class  URIReferenceException
      表示在取消引用URIReference时抛出异常情况。
      Methods in javax.xml.crypto that return Throwable
      Modifier and Type 方法 描述
      Throwable KeySelectorException.getCause​()
      如果原因不存在或未知，则返回 KeySelectorException或 null的原因。
      Throwable MarshalException.getCause​()
      如果原因不存在或未知，则返回 MarshalException或 null的原因。
      Throwable NoSuchMechanismException.getCause​()
      如果原因不存在或未知，则返回 NoSuchMechanismException或 null的原因。
      Throwable URIReferenceException.getCause​()
      如果原因不存在或未知，则返回 URIReferenceException或 null的原因。
      Constructors in javax.xml.crypto with parameters of type Throwable
      Constructor 描述
      KeySelectorException​(String message, Throwable cause)
      构造一个新的 KeySelectorException具有指定的详细信息和原因。
      KeySelectorException​(Throwable cause)
      构造一个新的 KeySelectorException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      MarshalException​(String message, Throwable cause)
      构造一个新的 MarshalException具有指定的详细信息和原因。
      MarshalException​(Throwable cause)
      构造一个新的 MarshalException具有指定的原因和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。
      NoSuchMechanismException​(String message, Throwable cause)
      构造一个新的 NoSuchMechanismException具有指定的详细信息和原因。
      NoSuchMechanismException​(Throwable cause)
      构造一个新的 NoSuchMechanismException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。
      URIReferenceException​(String message, Throwable cause)
      构造一个新的 URIReferenceException具有指定的详细信息和原因。
      URIReferenceException​(String message, Throwable cause, URIReference uriReference)
      构造一个新的 URIReferenceException具有指定的详细信息，原因和 URIReference 。
      URIReferenceException​(Throwable cause)
      构造一个新的 URIReferenceException与指定的原因和详细消息 (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in javax.xml.crypto.dsig

      Subclasses of Throwable in javax.xml.crypto.dsig
      Modifier and Type Class 描述
      class  TransformException
      表示执行变换算法时发生的异常情况。
      class  XMLSignatureException
      表示在XML签名生成或验证过程中发生的特殊情况。
      Methods in javax.xml.crypto.dsig that return Throwable
      Modifier and Type 方法 描述
      Throwable TransformException.getCause​()
      如果原因不存在或未知，则返回 TransformException或 null的原因。
      Throwable XMLSignatureException.getCause​()
      如果原因不存在或未知，则返回 XMLSignatureException或 null的原因。
      Constructors in javax.xml.crypto.dsig with parameters of type Throwable
      Constructor 描述
      TransformException​(String message, Throwable cause)
      构造一个新的 TransformException具有指定的详细信息和原因。
      TransformException​(Throwable cause)
      构造一个新的 TransformException具有指定的原因和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。
      XMLSignatureException​(String message, Throwable cause)
      构造一个新的 XMLSignatureException与指定的详细信息和原因。
      XMLSignatureException​(Throwable cause)
      构造一个新的 XMLSignatureException与指定的原因和详细信息 (cause==null ? null : cause.toString()) （通常包含类和详细信息 cause ）。

    • Uses of Throwable in javax.xml.datatype

      Subclasses of Throwable in javax.xml.datatype
      Modifier and Type Class 描述
      class  DatatypeConfigurationException
      表示严重的配置错误。
      Constructors in javax.xml.datatype with parameters of type Throwable
      Constructor 描述
      DatatypeConfigurationException​(String message, Throwable cause)
      创建一个新的 DatatypeConfigurationException具有指定的详细信息和原因。
      DatatypeConfigurationException​(Throwable cause)
      创建一个新的 DatatypeConfigurationException指定的原因。

    • Uses of Throwable in javax.xml.parsers

      Subclasses of Throwable in javax.xml.parsers
      Modifier and Type Class 描述
      class  FactoryConfigurationError
      当与Parser工厂存在配置问题时抛出。
      class  ParserConfigurationException
      表示严重的配置错误。
      Methods in javax.xml.parsers that return Throwable
      Modifier and Type 方法 描述
      Throwable FactoryConfigurationError.getCause​()
      使用JDK1.4的异常链接机制

    • Uses of Throwable in javax.xml.soap

      Subclasses of Throwable in javax.xml.soap
      Modifier and Type Class 描述
      class  SOAPException
      发生SOAP异常发生的异常。
      Methods in javax.xml.soap that return Throwable
      Modifier and Type 方法 描述
      Throwable SOAPException.getCause​()
      返回 Throwable对象嵌入在这个 SOAPException如果有的话。
      Throwable SOAPException.initCause​(Throwable cause)
      使用给定的 Throwable对象初始化 SOAPException对象的 cause字段。
      Methods in javax.xml.soap with parameters of type Throwable
      Modifier and Type 方法 描述
      Throwable SOAPException.initCause​(Throwable cause)
      使用给定的 Throwable对象初始化 SOAPException对象的 cause字段。
      Constructors in javax.xml.soap with parameters of type Throwable
      Constructor 描述
      SOAPException​(String reason, Throwable cause)
      构造一个 SOAPException对象，其中给出了 String作为抛出异常的原因，给定的 Throwable对象作为嵌入式异常。
      SOAPException​(Throwable cause)
      构造一个 SOAPException给定初始化的对象 Throwable对象。

    • Uses of Throwable in javax.xml.stream

      Subclasses of Throwable in javax.xml.stream
      Modifier and Type Class 描述
      class  FactoryConfigurationError
      报告工厂配置错误的错误类。
      class  XMLStreamException
      基于异常的意外处理错误。
      Fields in javax.xml.stream declared as Throwable
      Modifier and Type | Field | 描述
      protected Throwable | XMLStreamException.nested
      Methods in javax.xml.stream that return Throwable
      Modifier and Type 方法 描述
      Throwable FactoryConfigurationError.getCause​()
      使用JDK1.4的异常链接机制
      Throwable XMLStreamException.getNestedException​()
      获取嵌套的异常。
      Constructors in javax.xml.stream with parameters of type Throwable
      Constructor 描述
      XMLStreamException​(String msg, Throwable th)
      使用关联的消息和异常构造异常
      XMLStreamException​(String msg, Location location, Throwable th)
      使用关联的消息，异常和位置构造异常。
      XMLStreamException​(Throwable th)
      构造与异常异常的异常

    • Uses of Throwable in javax.xml.transform

      Subclasses of Throwable in javax.xml.transform
      Modifier and Type Class 描述
      class  TransformerConfigurationException
      表示严重的配置错误。
      class  TransformerException
      此类指定在转换过程中发生的异常情况。
      class  TransformerFactoryConfigurationError
      当Transformer工厂存在配置问题时抛出。
      Methods in javax.xml.transform that return Throwable
      Modifier and Type 方法 描述
      Throwable TransformerException.getCause​()
      如果原因不存在或未知，则返回此throwable的原因或 null 。
      Throwable TransformerFactoryConfigurationError.getCause​()
      使用JDK1.4的异常链接机制
      Throwable TransformerException.getException​()
      此方法检索此异常包装的异常。
      Throwable TransformerException.initCause​(Throwable cause)
      将此throwable的 原因初始化为指定值。
      Methods in javax.xml.transform with parameters of type Throwable
      Modifier and Type 方法 描述
      Throwable TransformerException.initCause​(Throwable cause)
      将此throwable的 原因初始化为指定值。
      Constructors in javax.xml.transform with parameters of type Throwable
      Constructor 描述
      TransformerConfigurationException​(String msg, Throwable e)
      创建一个新的 TransformerConfigurationException与给定的 异常基本原因和详细信息。
      TransformerConfigurationException​(String message, SourceLocator locator, Throwable e)
      在TransformerConfigurationException中包装一个现有的异常。
      TransformerConfigurationException​(Throwable e)
      创建一个新的 TransformerConfigurationException与给定的 异常基本原因的错误。
      TransformerException​(String message, Throwable e)
      在TransformerException中包含一个现有的异常。
      TransformerException​(String message, SourceLocator locator, Throwable e)
      在TransformerException中包含一个现有的异常。
      TransformerException​(Throwable e)
      创建一个包含现有异常的新TransformerException。

    • Uses of Throwable in javax.xml.validation

      Subclasses of Throwable in javax.xml.validation
      Modifier and Type Class 描述
      class  SchemaFactoryConfigurationError
      当存在具有Schema工厂的配置问题时抛出。
      Constructors in javax.xml.validation with parameters of type Throwable
      Constructor 描述
      SchemaFactoryConfigurationError​(String message, Throwable cause)
      创建一个新的 SchemaFactoryConfigurationError与给定的 Throwable基本原因和详细信息。
      SchemaFactoryConfigurationError​(Throwable cause)
      创建一个新的 SchemaFactoryConfigurationError与给定的 Throwable基础原因。

    • Uses of Throwable in javax.xml.ws

      Subclasses of Throwable in javax.xml.ws
      Modifier and Type Class 描述
      class  ProtocolException
      ProtocolException类是与特定协议绑定相关的异常的基类。
      class  WebServiceException
      WebServiceException类是所有JAX-WS API运行时异常的基础异常类。
      Constructors in javax.xml.ws with parameters of type Throwable
      Constructor 描述
      ProtocolException​(String message, Throwable cause)
      构造一个新的运行时异常与指定的详细信息和原因。
      ProtocolException​(Throwable cause)
      构造一个具有指定原因的新的运行时异常和一个 (cause==null ? null : cause.toString())的详细消息（通常包含原因的类和详细消息）。
      WebServiceException​(String message, Throwable cause)
      构造一个新的异常与指定的详细信息和原因。
      WebServiceException​(Throwable cause)
      构造具有指定cause和详细消息的新WebServiceException (cause==null ? null : cause.toString()) （它通常包含的类和详细消息 cause ）。

    • Uses of Throwable in javax.xml.ws.http

      Subclasses of Throwable in javax.xml.ws.http
      Modifier and Type Class 描述
      class  HTTPException
      HTTPException异常表示XML / HTTP故障。

    • Uses of Throwable in javax.xml.ws.soap

      Subclasses of Throwable in javax.xml.ws.soap
      Modifier and Type Class 描述
      class  SOAPFaultException
      SOAPFaultException异常表示SOAP 1.1或1.2故障。

    • Uses of Throwable in javax.xml.xpath

      Subclasses of Throwable in javax.xml.xpath
      Modifier and Type Class 描述
      class  XPathException
      XPathException表示一个通用的XPath异常。
      class  XPathExpressionException
      XPathExpressionException表示XPath表达式中的错误。
      class  XPathFactoryConfigurationException
      XPathFactoryConfigurationException表示 XPathFactory环境中的配置错误。
      class  XPathFunctionException
      XPathFunctionException表示XPath函数的错误。
      Methods in javax.xml.xpath that return Throwable
      Modifier and Type 方法 描述
      Throwable XPathException.getCause​()
      得到这个XPathException的原因。
      Constructors in javax.xml.xpath with parameters of type Throwable
      Constructor 描述
      XPathException​(Throwable cause)
      构造一个新的 XPathException与指定的 cause 。
      XPathExpressionException​(Throwable cause)
      构造一个新的 XPathExpressionException与指定的 cause 。
      XPathFactoryConfigurationException​(Throwable cause)
      构造一个新的 XPathFactoryConfigurationException与指定的 cause 。
      XPathFunctionException​(Throwable cause)
      构造一个新的 XPathFunctionException与指定的 cause 。

    • Uses of Throwable in jdk.dynalink

      Subclasses of Throwable in jdk.dynalink
      Modifier and Type Class 描述
      class  NoSuchDynamicMethodException
      如果呼叫站点无法通过任何可用的GuardingDynamicLinker链接，则在调用时抛出。

    • Uses of Throwable in jdk.dynalink.linker

      Methods in jdk.dynalink.linker that return types with arguments of type Throwable
      Modifier and Type 方法 描述
      Class<? extends Throwable> GuardedInvocation.getException​()
      返回异常类型，如果调用抛出应该使该被守卫的调用的链接失效。
      Constructor parameters in jdk.dynalink.linker with type arguments of type Throwable
      Constructor 描述
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint[] switchPoints, Class<? extends Throwable> exception)
      创建一个新的有保护的调用，具有保护方法句柄，可以使用任何数量的切换点来使其无效，以及如果在调用时抛出的异常也会使其失效。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint switchPoint, Class<? extends Throwable> exception)
      创建一个新的守卫调用，具有保护方法句柄，可用于使其无效的切换点，以及如果在调用时抛出也会使其失效的异常。

    • Uses of Throwable in jdk.incubator.http

      Subclasses of Throwable in jdk.incubator.http
      Modifier and Type Class 描述
      class  HttpTimeoutException
      在指定时间段内没有收到回应时抛出。
      class  WebSocketHandshakeException
      用于表示开启握手的异常失败。
      Methods in jdk.incubator.http with parameters of type Throwable
      Modifier and Type | 方法 | 描述
      WebSocketHandshakeException | WebSocketHandshakeException.initCause​(Throwable cause)
      void HttpResponse.MultiProcessor.onError​(HttpRequest request, Throwable t)
      如果接收到响应发生错误，则调用。
      default void WebSocket.Listener.onError​(WebSocket webSocket, Throwable error)
      通知发生I / O或协议错误。

    • Uses of Throwable in jdk.jshell

      Subclasses of Throwable in jdk.jshell
      Modifier and Type Class 描述
      class  EvalException
      封装在远程执行客户机中抛出的异常。
      class  JShellException
      JShell的超类生成异常
      class  UnresolvedReferenceException
      在尝试执行 RECOVERABLE_DEFINED代码段时报告异常。

    • Uses of Throwable in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type Throwable
      Modifier and Type | 方法 | 描述
      protected String DirectExecutionControl.throwConvertedInvocationException​(Throwable cause)
      将用户代码中的传入异常转换为ExecutionControl.ExecutionControlException的子类型，并抛出转换的异常。
      protected String | RemoteExecutionControl.throwConvertedInvocationException​(Throwable cause)
      protected String DirectExecutionControl.throwConvertedOtherException​(Throwable ex)
      将代理代码中的传入异常转换为ExecutionControl.ExecutionControlException的子类型的实例，并抛出转换的异常。
      protected String | RemoteExecutionControl.throwConvertedOtherException​(Throwable ex)
      Methods in jdk.jshell.execution that throw Throwable
      Modifier and Type 方法 描述
      ExecutionControl FailOverExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)
      创建并返回一个本地执行的 ExecutionControl实例。

    • Uses of Throwable in jdk.jshell.spi

      Subclasses of Throwable in jdk.jshell.spi
      Modifier and Type Class 描述
      static class  ExecutionControl.ClassInstallException
      类安装（加载或重新定义）遇到问题。
      static class  ExecutionControl.EngineTerminationException
      未执行引擎终止已发生。
      static class  ExecutionControl.ExecutionControlException
      所有 ExecutionControl例外的抽象基础。
      static class  ExecutionControl.InternalException
      发生内部问题。
      static class  ExecutionControl.NotImplementedException
      该命令未实现。
      static class  ExecutionControl.ResolutionException
      一个例外，表示已经遇到了一个未解决的引用的 DeclarationSnippet 。
      static class  ExecutionControl.RunException
      特定于运行用户代码的异常的抽象基础。
      static class  ExecutionControl.StoppedException
       表示
ExecutionControl.invoke(java.lang.String, java.lang.String) （或理论上为
ExecutionControl.varValue(java.lang.String, java.lang.String) ）已被
ExecutionControl.stop()中断的
例外 。
      static class  ExecutionControl.UserException
      发生“正常”用户异常。
      class  SPIResolutionException
      该异常的构造和抛出嵌入在JShell核心实现中生成的代码中，以便在执行 RECOVERABLE_DEFINED用户方法时抛出此异常。
      Methods in jdk.jshell.spi that throw Throwable
      Modifier and Type 方法 描述
      static ExecutionControl ExecutionControl.generate​(ExecutionEnv env, String spec)
      搜索提供者，然后创建并返回 ExecutionControl实例。
      static ExecutionControl ExecutionControl.generate​(ExecutionEnv env, String name, Map<String,String> parameters)
      搜索提供者，然后创建并返回 ExecutionControl实例。
      ExecutionControl ExecutionControlProvider.generate​(ExecutionEnv env, Map<String,String> parameters)
      创建并返回 ExecutionControl实例。

    • Uses of Throwable in jdk.nashorn.api.scripting

      Subclasses of Throwable in jdk.nashorn.api.scripting
      Modifier and Type Class 描述
      class  NashornException
      这是所有Nashorn异常的基础例外。
      Methods in jdk.nashorn.api.scripting with parameters of type Throwable
      Modifier and Type 方法 描述
      static StackTraceElement[] NashornException.getScriptFrames​(Throwable exception)
      从给定的异常对象返回数组JavaScript堆栈帧。
      static String NashornException.getScriptStackString​(Throwable exception)
      返回格式化的脚本堆栈跟踪字符串，框架信息由“\ n”分隔
      Constructors in jdk.nashorn.api.scripting with parameters of type Throwable
      Constructor 描述
      NashornException​(String msg, Throwable cause)
      构造器初始化错误消息并导致异常。
      NashornException​(String msg, Throwable cause, String fileName, int line, int column)
      构造器初始化错误消息，导致异常，文件名，行和列号。

    • Uses of Throwable in jdk.nashorn.api.tree

      Subclasses of Throwable in jdk.nashorn.api.tree
      Modifier and Type Class 描述
      class  UnknownTreeException
      表示遇到了一种未知类型的树。

    • Uses of Throwable in jdk.security.jarsigner

      Subclasses of Throwable in jdk.security.jarsigner
      Modifier and Type Class 描述
      class  JarSignerException
      当 JarSigner.sign(java.util.zip.ZipFile, java.io.OutputStream)失败时抛出此异常。
      Constructors in jdk.security.jarsigner with parameters of type Throwable
      Constructor 描述
      JarSignerException​(String message, Throwable cause)
      构造一个新的 JarSignerException具有指定的详细信息和原因。

    • Uses of Throwable in netscape.javascript

      Subclasses of Throwable in netscape.javascript
      Modifier and Type Class 描述
      class  JSException
      在JavaScript引擎中引发异常时抛出。
      Constructors in netscape.javascript with parameters of type Throwable
      Constructor 描述
      JSException​(Throwable t)
      构造具有指定原因的新JavaScript异常。

    • Uses of Throwable in org.ietf.jgss

      Subclasses of Throwable in org.ietf.jgss
      Modifier and Type Class 描述
      class  GSSException
      发生GSS-API错误时会抛出此异常，包括任何机制特定的错误。

    • Uses of Throwable in org.omg.CORBA

      Subclasses of Throwable in org.omg.CORBA
      Modifier and Type Class 描述
      class  ACTIVITY_COMPLETED
      可以在任何访问Activity上下文的方法上引发 ACTIVITY_COMPLETED系统异常。
      class  ACTIVITY_REQUIRED
      可能会在需要Activity上下文的任何方法上引发 ACTIVITY_REQUIRED系统异常。
      class  BAD_CONTEXT
      当客户端调用操作时抛出异常，但传递的上下文不包含操作所需的上下文值。
      class  BAD_INV_ORDER
      这个异常表示调用者以错误的顺序调用了操作。
      class  BAD_OPERATION
      当对象引用表示现有对象但该对象不支持被调用的操作时抛出异常。
      class  BAD_PARAM
      传递给调用的参数超出范围或以其他方式被视为非法时引发的异常。
      class  BAD_QOS
      当对象不能支持具有与其相关联的服务质量语义的调用参数所需的服务质量时，引发 BAD_QOS异常。
      class  BAD_TYPECODE
      当ORB遇到格式错误的代码时（例如，具有无效 TCKind值的类型代码），抛出异常。
      class  Bounds
      当参数不在方法尝试访问的对象的合法范围内时抛出用户异常。
      class  CODESET_INCOMPATIBLE
      无论客户端和服务器本机代码集之间无法进行有意义的通信，都会引发此异常。
      class  COMM_FAILURE
      在客户端发送请求后，服务器的回复已经返回到客户端之前，在进行中的通信丢失时发生异常。
      class  DATA_CONVERSION
      如果ORB无法将封送的数据的表示形式转换为其本机表示形式，反之亦然，则会引发此异常。
      class  FREE_MEM
      ORB在尝试释放动态内存时失败，例如由于堆损坏或内存段被锁定而导致异常。
      class  IMP_LIMIT
      此异常表示在ORB运行时间中超出了实施限制。
      class  INITIALIZE
      当ORB在其初始化期间遇到故障（例如无法获取网络资源或检测到配置错误）时抛出异常。
      class  INTERNAL
      此异常指示ORB中的内部故障，例如，如果ORB检测到其内部数据结构的损坏。
      class  INTF_REPOS
      当ORB无法到达接口存储库或检测到与接口存储库相关的某些其他故障时引发异常。
      class  INV_FLAG
      当一个无效标志传递给一个操作时（例如创建一个DII请求）时抛出异常。
      class  INV_IDENT
      此异常表示IDL标识符在语法上无效。
      class  INV_OBJREF
      此异常表示对象引用在内部格式错误。
      class  INV_POLICY
      由于 Policy覆盖适用于特定调用的不兼容性，因此无法进行调用时抛出标准异常。
      class  INVALID_ACTIVITY
      如果事务或活动在与其挂起的环境不同的上下文中恢复，则可能会在“活动”或“事务服务”恢复方法上引发 INVALID_ACTIVITY系统异常。
      class  INVALID_TRANSACTION
      当请求携带无效的事务上下文时抛出异常。
      class  MARSHAL
      来自网络的请求或回复在结构上是无效的。
      class  NO_IMPLEMENT
      此异常表示即使已调用的操作存在（它具有IDL定义），也不存在该操作的实现。
      class  NO_MEMORY
      ORB运行时内存不足时抛出异常。
      class  NO_PERMISSION
      调用失败时引发异常，因为调用者的权限不足。
      class  NO_RESOURCES
      当ORB遇到一些一般资源限制时抛出异常。
      class  NO_RESPONSE
      如果客户端尝试检索延迟同步调用的结果，但该请求的响应尚不可用，则会引发此异常。
      class  OBJ_ADAPTER
      此异常通常表示管理不匹配，例如，服务器可能尝试以已经在使用的名称或对存储库未知的实现存储库注册自身。
      class  OBJECT_NOT_EXIST
      每当执行对被删除对象的调用时，就会引发异常。
      class  PERSIST_STORE
      此异常表示持续存储故障，例如，无法建立数据库连接或数据库损坏。
      class  PolicyError
      发生策略错误时抛出的用户异常。
      class  REBIND
      REBIND上升时电流有效RebindPolicy，具有NO_REBIND或NO_RECONNECT的值和上一个绑定的对象引用在消息LocateReply具有状态OBJECT_FORWARD或状态为LOCATION_FORWARD一个应答消息的调用。
      class  SystemException
      所有CORBA标准异常的根类。
      class  TIMEOUT
      TIMEOUT在没有交货和已经超过指定的生存时间时被提出。
      class  TRANSACTION_MODE
      如果检测到IOR中的InvocationPolicy与所选择的调用路径（即，直接或路由调用）之间的不匹配，则客户端ORB会抛出CORBA TRANSACTION_MODE异常。
      class  TRANSACTION_REQUIRED
      异常表示请求携带一个空事务上下文，但需要一个活动事务。
      class  TRANSACTION_ROLLEDBACK
      与请求相关联的事务已经回滚或标记回滚时抛出异常。
      class  TRANSACTION_UNAVAILABLE
      由于ORB与事务服务的连接已异常终止，所以ORB无法处理事务服务上下文时抛出CORBA TRANSACTION_UNAVAILABLE异常。
      class  TRANSIENT
      当ORB尝试到达对象并失败时抛出异常。
      class  UNKNOWN
      如果操作实现抛出非CORBA异常（例如特定于实现的编程语言的异常），或者操作引发不在操作的引用表达式中出现的用户异常，则会引发此异常。
      class  UnknownUserException
      包含服务器返回的用户异常的类。
      class  UserException
      CORBA IDL定义用户异常的根类。
      class  WrongTransaction
      CORBA WrongTransaction用户定义的异常。

    • Uses of Throwable in org.omg.CORBA.DynAnyPackage

      Subclasses of Throwable in org.omg.CORBA.DynAnyPackage
      Modifier and Type | Class | 描述
      class  Invalid
      当传递错误的 DynAny或 Any作为参数时，动态的任何操作都会抛出无效。
      class  InvalidSeq
      InvalidSeq异常被所有操作抛出，在动态任务中，当序列无效时，它将一个序列（Java数组）作为参数。
      class  | InvalidValue
      class  TypeMismatch
      当实际内容的类型与尝试访问的内容不匹配时，TypeMismatch将被动态的任何访问器方法抛出。

    • Uses of Throwable in org.omg.CORBA.ORBPackage

      Subclasses of Throwable in org.omg.CORBA.ORBPackage
      Modifier and Type Class 描述
      class  InconsistentTypeCode
      尝试使用不符合 DynAny特定子类的类型代码创建动态任务时，会抛出 DynAny 。
      class  InvalidName
      InvalidName异常在 ORB.resolve_initial_references传递一个没有初始引用的名称时被提出。

    • Uses of Throwable in org.omg.CORBA.portable

      Subclasses of Throwable in org.omg.CORBA.portable
      Modifier and Type Class 描述
      class  ApplicationException
      此类用于报告ORB和存根之间的应用程序级异常。
      class  IndirectionException
      间接异常是一个Java特定的系统异常。
      class  RemarshalException
      该类用于将向前的异常和对象前向GIOP消息定位回ORB。
      class  UnknownException
      org.omg.CORBA.portable.UnknownException用于报告关系和ORB之间以及ORB和存根之间的未知异常。
      Fields in org.omg.CORBA.portable declared as Throwable
      Modifier and Type Field 描述
      Throwable UnknownException.originalEx
      一个可抛出的 - 包含在CORBA UnknownException中的原始异常。
      Constructors in org.omg.CORBA.portable with parameters of type Throwable
      Constructor 描述
      UnknownException​(Throwable ex)
      构造一个UnknownException对象。

    • Uses of Throwable in org.omg.CORBA.TypeCodePackage

      Subclasses of Throwable in org.omg.CORBA.TypeCodePackage
      Modifier and Type Class 描述
      class  BadKind
      在 TypeCode对象上调用不正确的操作时，抛出异常 BadKind 。
      class  Bounds
      提供 TypeCode操作 member_name() ， member_type() ，并 member_label 。

    • Uses of Throwable in org.omg.CosNaming.NamingContextExtPackage

      Subclasses of Throwable in org.omg.CosNaming.NamingContextExtPackage
      Modifier and Type Class 描述
      class  InvalidAddress
      org / omg / CosNaming / NamingContextExtPackage / InvalidAddress.java。

    • Uses of Throwable in org.omg.CosNaming.NamingContextPackage

      Subclasses of Throwable in org.omg.CosNaming.NamingContextPackage
      Modifier and Type Class 描述
      class  AlreadyBound
      org / omg / CosNaming / NamingContextPackage / AlreadyBound.java。
      class  CannotProceed
      org / omg / CosNaming / NamingContextPackage / CannotProceed.java。
      class  InvalidName
      org / omg / CosNaming / NamingContextPackage / InvalidName.java。
      class  NotEmpty
      org / omg / CosNaming / NamingContextPackage / NotEmpty.java。
      class  NotFound
      org / omg / CosNaming / NamingContextPackage / NotFound.java。

    • Uses of Throwable in org.omg.DynamicAny.DynAnyFactoryPackage

      Subclasses of Throwable in org.omg.DynamicAny.DynAnyFactoryPackage
      Modifier and Type Class 描述
      class  InconsistentTypeCode
      org / omg / DynamicAny / DynAnyFactoryPackage / InconsistentTypeCode.java。

    • Uses of Throwable in org.omg.DynamicAny.DynAnyPackage

      Subclasses of Throwable in org.omg.DynamicAny.DynAnyPackage
      Modifier and Type Class 描述
      class  InvalidValue
      org / omg / DynamicAny / DynAnyPackage / InvalidValue.java。
      class  TypeMismatch
      org / omg / DynamicAny / DynAnyPackage / TypeMismatch.java。

    • Uses of Throwable in org.omg.IOP.CodecFactoryPackage

      Subclasses of Throwable in org.omg.IOP.CodecFactoryPackage
      Modifier and Type Class 描述
      class  UnknownEncoding
      org / omg / IOP / CodecFactoryPackage / UnknownEncoding.java。

    • Uses of Throwable in org.omg.IOP.CodecPackage

      Subclasses of Throwable in org.omg.IOP.CodecPackage
      Modifier and Type Class 描述
      class  FormatMismatch
      org / omg / IOP / CodecPackage / FormatMismatch.java。
      class  InvalidTypeForEncoding
      org / omg / IOP / CodecPackage / InvalidTypeForEncoding.java。
      class  TypeMismatch
      org / omg / IOP / CodecPackage / TypeMismatch.java。

    • Uses of Throwable in org.omg.PortableInterceptor

      Subclasses of Throwable in org.omg.PortableInterceptor
      Modifier and Type Class 描述
      class  ForwardRequest
      org / omg / PortableInterceptor / ForwardRequest.java。
      class  InvalidSlot
      org / omg / PortableInterceptor / InvalidSlot.java。

    • Uses of Throwable in org.omg.PortableInterceptor.ORBInitInfoPackage

      Subclasses of Throwable in org.omg.PortableInterceptor.ORBInitInfoPackage
      Modifier and Type Class 描述
      class  DuplicateName
      org / omg / PortableInterceptor / ORBInitInfoPackage / DuplicateName.java。
      class  InvalidName
      org / omg / PortableInterceptor / ORBInitInfoPackage / InvalidName.java。

    • Uses of Throwable in org.omg.PortableServer

      Subclasses of Throwable in org.omg.PortableServer
      Modifier and Type Class 描述
      class  ForwardRequest
      org / omg / PortableServer / ForwardRequest.java。

    • Uses of Throwable in org.omg.PortableServer.CurrentPackage

      Subclasses of Throwable in org.omg.PortableServer.CurrentPackage
      Modifier and Type Class 描述
      class  NoContext
      org / omg / PortableServer / CurrentPackage / NoContext.java。

    • Uses of Throwable in org.omg.PortableServer.POAManagerPackage

      Subclasses of Throwable in org.omg.PortableServer.POAManagerPackage
      Modifier and Type Class 描述
      class  AdapterInactive
      org / omg / PortableServer / POAManagerPackage / AdapterInactive.java。

    • Uses of Throwable in org.omg.PortableServer.POAPackage

      Subclasses of Throwable in org.omg.PortableServer.POAPackage
      Modifier and Type Class 描述
      class  AdapterAlreadyExists
      org / omg / PortableServer / POAPackage / AdapterAlreadyExists.java。
      class  AdapterNonExistent
      org / omg / PortableServer / POAPackage / AdapterNonExistent.java。
      class  InvalidPolicy
      org / omg / PortableServer / POAPackage / InvalidPolicy.java。
      class  NoServant
      org / omg / PortableServer / POAPackage / NoServant.java。
      class  ObjectAlreadyActive
      org / omg / PortableServer / POAPackage / ObjectAlreadyActive.java。
      class  ObjectNotActive
      org / omg / PortableServer / POAPackage / ObjectNotActive.java。
      class  ServantAlreadyActive
      org / omg / PortableServer / POAPackage / ServantAlreadyActive.java。
      class  ServantNotActive
      org / omg / PortableServer / POAPackage / ServantNotActive.java。
      class  WrongAdapter
      org / omg / PortableServer / POAPackage / WrongAdapter.java。
      class  WrongPolicy
      org / omg / PortableServer / POAPackage / WrongPolicy.java。

    • Uses of Throwable in org.w3c.dom

      Subclasses of Throwable in org.w3c.dom
      Modifier and Type Class 描述
      class  DOMException
      DOM操作只会在“异常”情况下引发异常，即当操作无法执行时（出于逻辑原因，因为数据丢失，或者由于实现变得不稳定））。

    • Uses of Throwable in org.w3c.dom.events

      Subclasses of Throwable in org.w3c.dom.events
      Modifier and Type Class 描述
      class  EventException
      事件操作可能会抛出其方法描述中指定的 EventException 。

    • Uses of Throwable in org.w3c.dom.ls

      Subclasses of Throwable in org.w3c.dom.ls
      Modifier and Type Class 描述
      class  LSException
      如果处理停止，解析器或写入操作可能会抛出 LSException 。

    • Uses of Throwable in org.w3c.dom.ranges

      Subclasses of Throwable in org.w3c.dom.ranges
      Modifier and Type Class 描述
      class  RangeException
      范围操作可能会抛出其方法描述中指定的 RangeException 。

    • Uses of Throwable in org.w3c.dom.xpath

      Subclasses of Throwable in org.w3c.dom.xpath
      Modifier and Type Class 描述
      class  XPathException
      为这些XPath接口特定的异常创建了一个新的异常。

    • Uses of Throwable in org.xml.sax

      Subclasses of Throwable in org.xml.sax
      Modifier and Type Class 描述
      class  SAXException
      封装一般的SAX错误或警告。
      class  SAXNotRecognizedException
      无法识别的标识符的异常类。
      class  SAXNotSupportedException
      不受支持的操作的异常类。
      class  SAXParseException
      封装XML解析错误或警告。
      Methods in org.xml.sax that return Throwable
      Modifier and Type 方法 描述
      Throwable SAXException.getCause​()
      返回异常的原因
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.TypeNotPresentException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.TypeNotPresentException

  • Packages that use TypeNotPresentException
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

    • Uses of TypeNotPresentException in java.lang.invoke

      Methods in java.lang.invoke that throw TypeNotPresentException
      Modifier and Type 方法 描述
      static MethodType MethodType.fromMethodDescriptorString​(String descriptor, ClassLoader loader)
      查找或创建方法类型的实例，给定其字节码描述符的拼写。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.UnknownError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.UnknownError

No usage of java.lang.UnknownError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.UnsatisfiedLinkError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.UnsatisfiedLinkError

No usage of java.lang.UnsatisfiedLinkError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.UnsupportedClassVersionError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.UnsupportedClassVersionError

No usage of java.lang.UnsupportedClassVersionError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.UnsupportedOperationException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.UnsupportedOperationException

  • Packages that use UnsupportedOperationException
    软件包 描述
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    javax.imageio
    Java Image I / O API的主要包。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.xml.soap
    提供用于创建和构建SOAP消息的API。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of UnsupportedOperationException in com.sun.jdi

      Subclasses of UnsupportedOperationException in com.sun.jdi
      Modifier and Type Class 描述
      class  VMCannotBeModifiedException
      抛出以表示操作无效，因为它会修改VM，VM是只读的。

    • Uses of UnsupportedOperationException in java.awt

      Subclasses of UnsupportedOperationException in java.awt
      Modifier and Type Class 描述
      class  HeadlessException
      在不支持键盘，显示或鼠标的环境中调用依赖于键盘，显示器或鼠标的代码时，会抛出此异常。
      Methods in java.awt that throw UnsupportedOperationException
      Modifier and Type 方法 描述
      boolean Toolkit.getLockingKeyState​(int keyCode)
      返回键盘上给定的锁定键是否处于“开启”状态。
      void Toolkit.setLockingKeyState​(int keyCode, boolean on)
      设置键盘上给定锁定键的状态。

    • Uses of UnsupportedOperationException in java.nio

      Subclasses of UnsupportedOperationException in java.nio
      Modifier and Type Class 描述
      class  ReadOnlyBufferException
      当在只读缓冲区上调用诸如 put或 compact类的内容突变方法时抛出未经检查的异常。

    • Uses of UnsupportedOperationException in java.nio.file

      Subclasses of UnsupportedOperationException in java.nio.file
      Modifier and Type Class 描述
      class  ReadOnlyFileSystemException
      尝试更新与 read-only FileSystem相关联的对象时抛出未检查的异常。

    • Uses of UnsupportedOperationException in javax.imageio

      Methods in javax.imageio that throw UnsupportedOperationException
      Modifier and Type 方法 描述
      void ImageReadParam.setSourceRenderSize​(Dimension size)
      如果图像能够以任意大小呈现，请将源宽度和高度设置为提供的值。

    • Uses of UnsupportedOperationException in javax.management.loading

      Methods in javax.management.loading that throw UnsupportedOperationException
      Modifier and Type 方法 描述
      void MLet.readExternal​(ObjectInput in)
      从给定的ObjectInput恢复这个MLet的内容。
      void MLet.writeExternal​(ObjectOutput out)
      将此MLet的内容保存到给定的ObjectOutput 。

    • Uses of UnsupportedOperationException in javax.xml.soap

      Methods in javax.xml.soap that throw UnsupportedOperationException
      Modifier and Type 方法 描述
      static SOAPConnectionFactory SOAPConnectionFactory.newInstance​()
      创建默认 SOAPConnectionFactory对象的实例。

    • Uses of UnsupportedOperationException in jdk.nashorn.api.scripting

      Methods in jdk.nashorn.api.scripting that throw UnsupportedOperationException
      Modifier and Type 方法 描述
      default Object JSObject.getDefaultValue​(Class<?> hint)
      Implements this object's [[DefaultValue]] method as per ECMAScript 5.1 section 8.6.2.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.VerifyError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.VerifyError

No usage of java.lang.VerifyError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.VirtualMachineError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.VirtualMachineError

  • Packages that use VirtualMachineError
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。

    • Uses of VirtualMachineError in java.lang

      Subclasses of VirtualMachineError in java.lang
      Modifier and Type Class 描述
      class  InternalError
      在Java虚拟机中引发了一些意外的内部错误。
      class  OutOfMemoryError
      当Java虚拟机由于内存不足而无法分配对象时抛出，并且垃圾收集器不再有可用的内存。
      class  StackOverflowError
      当堆栈溢出发生时抛出一个应用程序递归太深。
      class  UnknownError
      当Java虚拟机中出现未知但严重的异常时抛出。

    • Uses of VirtualMachineError in java.util.zip

      Subclasses of VirtualMachineError in java.util.zip
      Modifier and Type Class 描述
      class  ZipError
      Signals that an unrecoverable error has occurred.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.Void (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.Void

  • Packages that use Void
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Void in java.lang

      Fields in java.lang with type parameters of type Void
      Modifier and Type Field 描述
      static Class<Void> Void.TYPE
      表示对应于关键字 void的伪类型的 Class对象。

    • Uses of Void in java.nio.channels

      Methods in java.nio.channels that return types with arguments of type Void
      Modifier and Type 方法 描述
      abstract Future<Void> AsynchronousSocketChannel.connect​(SocketAddress remote)
      连接此频道。
      Method parameters in java.nio.channels with type arguments of type Void
      Modifier and Type 方法 描述
      abstract <A> void AsynchronousSocketChannel.connect​(SocketAddress remote, A attachment, CompletionHandler<Void,? super A> handler)
      连接此频道。

    • Uses of Void in java.util.concurrent

      Methods in java.util.concurrent that return Void
      Modifier and Type 方法 描述
      Void RecursiveAction.getRawResult​()
      始终返回 null 。
      Methods in java.util.concurrent that return types with arguments of type Void
      Modifier and Type | 方法 | 描述
      CompletableFuture<Void> | CompletableFuture.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletionStage<Void> CompletionStage.acceptEither​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行相应的结果作为提供的操作的参数。
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，将使用此阶段的默认异步执行工具执行，其中相应的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.acceptEitherAsync​(CompletionStage<? extends T> other, Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行，其中相应的结果作为参数提供的操作。
      static CompletableFuture<Void> CompletableFuture.allOf​(CompletableFuture<?>... cfs)
      返回一个新的CompletableFuture，当所有给定的CompletableFutures完成时，完成。
      CompletableFuture<Void> SubmissionPublisher.consume​(Consumer<? super T> consumer)
      使用给定的Consumer功能处理所有已发布的项目。
      CompletableFuture<Void> | CompletableFuture.runAfterBoth​(CompletionStage<?> other, Runnable action)
      CompletionStage<Void> CompletionStage.runAfterBoth​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.runAfterEither​(CompletionStage<?> other, Runnable action)
      CompletionStage<Void> CompletionStage.runAfterEither​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
      static CompletableFuture<Void> CompletableFuture.runAsync​(Runnable runnable)
      返回在运行给定操作后，在 ForkJoinPool.commonPool()中运行的任务异步完成的新的CompletableFuture。
      static CompletableFuture<Void> CompletableFuture.runAsync​(Runnable runnable, Executor executor)
      返回一个新的CompletableFuture，它在运行给定操作之后由在给定执行程序中运行的任务异步完成。
      CompletableFuture<Void> | CompletableFuture.thenAccept​(Consumer<? super T> action)
      CompletionStage<Void> CompletionStage.thenAccept​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，以该阶段的结果作为提供的操作的参数执行。
      CompletableFuture<Void> | CompletableFuture.thenAcceptAsync​(Consumer<? super T> action)
      CompletableFuture<Void> | CompletableFuture.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      CompletionStage<Void> CompletionStage.thenAcceptAsync​(Consumer<? super T> action)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用此阶段的默认异步执行工具执行，此阶段的结果作为提供的操作的参数。
      CompletionStage<Void> CompletionStage.thenAcceptAsync​(Consumer<? super T> action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，将使用提供的执行程序执行此阶段的结果作为提供的操作的参数。
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletionStage<Void> CompletionStage.thenAcceptBoth​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，两个结果作为提供的操作的参数被执行。
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      <U> CompletableFuture<Void> | CompletableFuture.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，将使用此阶段的默认异步执行工具执行，其中两个结果作为提供的操作的参数。
      <U> CompletionStage<Void> CompletionStage.thenAcceptBothAsync​(CompletionStage<? extends U> other, BiConsumer<? super T,? super U> action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，将使用提供的执行器执行，其中两个结果作为提供的操作的参数。
      CompletableFuture<Void> | CompletableFuture.thenRun​(Runnable action)
      CompletionStage<Void> CompletionStage.thenRun​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。
      CompletableFuture<Void> | CompletableFuture.thenRunAsync​(Runnable action)
      CompletableFuture<Void> | CompletableFuture.thenRunAsync​(Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.thenRunAsync​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.thenRunAsync​(Runnable action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。
      Methods in java.util.concurrent with parameters of type Void
      Modifier and Type 方法 描述
      protected void RecursiveAction.setRawResult​(Void mustBeNull)
      需要空完成值。

    • Uses of Void in javafx.scene

      Method parameters in javafx.scene with type arguments of type Void
      Modifier and Type 方法 描述
      void Node.snapshot​(Callback<SnapshotResult,Void> callback, SnapshotParameters params, WritableImage image)
      在下一帧获取该节点的快照，并在映像准备就绪时调用指定的回调方法。
      void Scene.snapshot​(Callback<SnapshotResult,Void> callback, WritableImage image)
      在下一帧拍摄此场景的快照，并在图像准备就绪时调用指定的回调方法。

    • Uses of Void in javafx.scene.web

      Methods in javafx.scene.web that return types with arguments of type Void
      Modifier and Type 方法 描述
      Worker<Void> WebEngine.getLoadWorker​()
      返回可用于跟踪加载进度的Worker对象。

    • Uses of Void in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type Void
      Modifier and Type Field 描述
      static SimpleType<Void> SimpleType.VOID
      描述Java类名称为 java.lang.Void值的 SimpleType实例。

    • Uses of Void in jdk.incubator.http

      Methods in jdk.incubator.http that return types with arguments of type Void
      Modifier and Type 方法 描述
      static HttpResponse.BodyHandler<Void> HttpResponse.BodyHandler.asByteArrayConsumer​(Consumer<Optional<byte[]>> consumer)
      返回一个BodyHandler<Void> ，返回一个从 <Void>获得的BodyProcessor <Void> 。
      static HttpResponse.BodyProcessor<Void> HttpResponse.BodyProcessor.asByteArrayConsumer​(Consumer<Optional<byte[]>> consumer)
      返回一个 BodyProcessor ，它将传入的身体数据提供给提供的消费者 Optional<byte[]> 。
      Method parameters in jdk.incubator.http with type arguments of type Void
      Modifier and Type 方法 描述
      CompletableFuture<U> HttpResponse.MultiProcessor.completion​(CompletableFuture<Void> onComplete, CompletableFuture<Void> onFinalPushPromise)
      当聚合结果对象本身可用时，返回CompletableFuture <U> 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.Appendable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.Appendable

  • Packages that use Appendable
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.time.format
    提供打印和解析日期和时间的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。

    • Uses of Appendable in java.io

      Classes in java.io that implement Appendable
      Modifier and Type Class 描述
      class  BufferedWriter
      将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
      class  CharArrayWriter
      该类实现了可以用作Writer的字符缓冲区。
      class  FileWriter
      方便课写字符文件。
      class  FilterWriter
      用于编写过滤后的字符流的抽象类。
      class  OutputStreamWriter
      OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入的字符编码为字节。
      class  PipedWriter
      流水字符输出流。
      class  PrintStream
      A PrintStream为另一个输出流添加了功能，即方便地打印各种数据值的表示的能力。
      class  PrintWriter
      将对象的格式表示打印到文本输出流。
      class  StringWriter
      在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。
      class  Writer
      用于写入字符流的抽象类。

    • Uses of Appendable in java.lang

      Classes in java.lang that implement Appendable
      Modifier and Type Class 描述
      class  StringBuffer
      线程安全，可变的字符序列。
      class  StringBuilder
      一个可变的字符序列。
      Methods in java.lang that return Appendable
      Modifier and Type 方法 描述
      Appendable Appendable.append​(char c)
      将指定的字符追加到此 Appendable 。
      Appendable Appendable.append​(CharSequence csq)
      将指定的字符序列追加到此 Appendable 。
      Appendable Appendable.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列追加到此 Appendable 。

    • Uses of Appendable in java.nio

      Classes in java.nio that implement Appendable
      Modifier and Type Class 描述
      class  CharBuffer
      一个char缓冲区。

    • Uses of Appendable in java.rmi.server

      Classes in java.rmi.server that implement Appendable
      Modifier and Type Class 描述
      class  LogStream
      已过时。
      没有替换

    • Uses of Appendable in java.time.format

      Methods in java.time.format with parameters of type Appendable
      Modifier and Type 方法 描述
      void DateTimeFormatter.formatTo​(TemporalAccessor temporal, Appendable appendable)
      使用此格式化程序将日期时间对象格式化为 Appendable 。

    • Uses of Appendable in java.util

      Methods in java.util that return Appendable
      Modifier and Type 方法 描述
      Appendable Formatter.out​()
      返回输出的目的地。
      Constructors in java.util with parameters of type Appendable
      Constructor 描述
      Formatter​(Appendable a)
      构造具有指定目的地的新格式化程序。
      Formatter​(Appendable a, Locale l)
      构造一个具有指定目的地和区域设置的新格式化程序。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.AutoCloseable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.AutoCloseable

  • Packages that use AutoCloseable
    软件包 描述
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.net
    提供实现网络应用程序的类。
    java.nio.channels
    定义通道，其表示与能够执行I / O操作的实体的连接，例如文件和套接字; 定义选择器，用于多路复用，非阻塞I / O操作。
    java.nio.channels.spi
    服务提供商类为 java.nio.channels包。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    java.security
    提供安全框架的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio.stream
    Java Image I / O API的一个封装，处理来自文件和流的低级I / O。
    javax.management.loading
    提供实现高级动态加载的类。
    javax.management.remote
    用于远程访问JMX MBean服务器的接口。
    javax.management.remote.rmi
    RMI连接器是JMX Remote API的连接器，它使用RMI将客户端请求传输到远程MBean服务器。
    javax.net.ssl
    为安全套接字包提供类。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sound.sampled
    提供用于捕获，处理和播放采样音频数据的接口和类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
    jdk.jshell.spi
    定义可插拔JShell执行引擎的服务提供程序接口。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。
    org.omg.CORBA_2_3.portable
    提供值类型的输入和输出方法，并包含 org/omg/CORBA/portable包的其他更新。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。

    • Uses of AutoCloseable in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement AutoCloseable
      Modifier and Type Class 描述
      class  SctpChannel
      用于面向消息的连接SCTP套接字的可选通道。
      class  SctpMultiChannel
      用于面向消息的SCTP套接字的可选通道。
      class  SctpServerChannel
      用于面向消息的侦听SCTP插座的可选通道。

    • Uses of AutoCloseable in java.beans

      Classes in java.beans that implement AutoCloseable
      Modifier and Type Class 描述
      class  XMLDecoder
      XMLDecoder类用于读取使用 XMLEncoder创建的XML文档，并且像 ObjectInputStream那样使用。
      class  XMLEncoder
      所述 XMLEncoder类是互补替代 ObjectOutputStream ，并且可以用于产生以相同的方式，该一个 JavaBean的文本表示 ObjectOutputStream可以用来创建的二进制表示 Serializable对象。

    • Uses of AutoCloseable in java.io

      Subinterfaces of AutoCloseable in java.io
      Modifier and Type 接口 描述
      interface  Closeable
      A Closeable是可以关闭的数据源或目的地。
      interface  ObjectInput
      ObjectInput扩展了DataInput接口以包含对象的读取。
      interface  ObjectOutput
      ObjectOutput扩展了DataOutput接口，包括写入对象。
      Classes in java.io that implement AutoCloseable
      Modifier and Type Class 描述
      class  BufferedInputStream
      A BufferedInputStream为另一个输入流添加了功能，即缓冲输入并支持 mark和 reset方法的功能。
      class  BufferedOutputStream
      该类实现缓冲输出流。
      class  BufferedReader
      从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
      class  BufferedWriter
      将文本写入字符输出流，缓冲字符，以提供单个字符，数组和字符串的高效写入。
      class  ByteArrayInputStream
      A ByteArrayInputStream包含一个内部缓冲区，其中包含可以从流中读取的字节。
      class  ByteArrayOutputStream
      该类实现了将数据写入字节数组的输出流。
      class  CharArrayReader
      该类实现了一个字符缓冲区，可以用作字符输入流。
      class  CharArrayWriter
      该类实现了可以用作Writer的字符缓冲区。
      class  DataInputStream
      数据输入流允许应用程序以独立于机器的方式从基础输入流读取原始Java数据类型。
      class  DataOutputStream
      数据输出流使应用程序以便携式方式将原始Java数据类型写入输出流。
      class  FileInputStream
      A FileInputStream从文件系统中的文件获取输入字节。
      class  FileOutputStream
      文件输出流是用于将数据写入 File或 FileDescriptor的输出流。
      class  FileReader
      阅读字符文件的便利课。
      class  FileWriter
      方便课写字符文件。
      class  FilterInputStream
      A FilterInputStream包含一些其他输入流，它用作其基本的数据源，可能会沿着数据方向转换或提供附加功能。
      class  FilterOutputStream
      这个类是过滤输出流的所有类的超类。
      class  FilterReader
      用于读取过滤后的字符流的抽象类。
      class  FilterWriter
      用于编写过滤后的字符流的抽象类。
      class  InputStream
      这个抽象类是表示输入字节流的所有类的超类。
      class  InputStreamReader
      InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。
      class  LineNumberInputStream
      已过时。
      该类错误地假定字节充分表示字符。 从JDK 1.1开始，对字符流进行操作的首选方式是通过新的字符流类，其中包括一个用于计数行号的类。
      class  LineNumberReader
      缓冲字符输入流，跟踪行号。
      class  ObjectInputStream
      ObjectInputStream反序列化先前使用ObjectOutputStream编写的原始数据和对象。
      class  ObjectOutputStream
      ObjectOutputStream将Java对象的原始数据类型和图形写入OutputStream。
      class  OutputStream
      这个抽象类是表示字节输出流的所有类的超类。
      class  OutputStreamWriter
      OutputStreamWriter是从字符流到字节流的桥梁：使用指定的charset将写入其的字符编码为字节。
      class  PipedInputStream
      管道输入流应连接到管道输出流; 管道输入流然后提供写入管道输出流的任何数据字节。
      class  PipedOutputStream
      管道输出流可以连接到管道输入流以创建通信管道。
      class  PipedReader
      流水字符输入流。
      class  PipedWriter
      流水字符输出流。
      class  PrintStream
      A PrintStream将功能添加到另一个输出流，即能够方便地打印各种数据值的表示。
      class  PrintWriter
      将对象的格式表示打印到文本输出流。
      class  PushbackInputStream
      A PushbackInputStream通过将推回的字节存储在内部缓冲区中，将功能添加到另一个输入流，即“推回”或“未读”字节的功能。
      class  PushbackReader
      一个字符流读取器，允许将字符推回到流中。
      class  RandomAccessFile
      该类的实例支持读取和写入随机访问文件。
      class  Reader
      用于读取字符流的抽象类。
      class  SequenceInputStream
      A SequenceInputStream表示其他输入流的逻辑级联。
      class  StringBufferInputStream
      已过时。
      此类不会将字符正确转换为字节。 从JDK 1.1开始，从字符串创建流的首选方法是通过StringReader类。
      class  StringReader
      一个字符流，其源是一个字符串。
      class  StringWriter
      在字符串缓冲区中收集其输出的字符流，然后可以用于构造字符串。
      class  Writer
      用于写入字符流的抽象类。

    • Uses of AutoCloseable in java.lang.module

      Subinterfaces of AutoCloseable in java.lang.module
      Modifier and Type 接口 描述
      interface  ModuleReader
      提供访问模块的内容。

    • Uses of AutoCloseable in java.net

      Classes in java.net that implement AutoCloseable
      Modifier and Type Class 描述
      class  DatagramSocket
      此类表示用于发送和接收数据报数据包的套接字。
      class  MulticastSocket
      组播数据报套接字类对发送和接收IP组播数据包很有用。
      class  ServerSocket
      这个类实现了服务器套接字。
      class  Socket
      该类实现客户端套接字（也称为“套接字”）。
      class  URLClassLoader
      此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。

    • Uses of AutoCloseable in java.nio.channels

      Subinterfaces of AutoCloseable in java.nio.channels
      Modifier and Type 接口 描述
      interface  AsynchronousByteChannel
      一个可以读写字节的异步通道。
      interface  AsynchronousChannel
      支持异步I / O操作的通道。
      interface  ByteChannel
      一个可以读写字节的通道。
      interface  Channel
      I / O操作的联系。
      interface  GatheringByteChannel
      可以从缓冲区序列中写入字节的通道。
      interface  InterruptibleChannel
      可以异步关闭和中断的通道。
      interface  MulticastChannel
      支持互联网协议（IP）组播的网络通道。
      interface  NetworkChannel
      到网络插座的通道。
      interface  ReadableByteChannel
      一个可以读取字节的通道。
      interface  ScatteringByteChannel
      可以将字节读入缓冲区序列的通道。
      interface  SeekableByteChannel
      保持当前 位置并允许更改 位置的字节通道。
      interface  WritableByteChannel
      一个可以写字节的通道。
      Classes in java.nio.channels that implement AutoCloseable
      Modifier and Type Class 描述
      class  AsynchronousFileChannel
      用于读取，写入和操作文件的异步通道。
      class  AsynchronousServerSocketChannel
      用于面向流的侦听套接字的异步通道。
      class  AsynchronousSocketChannel
      用于面向流的连接插座的异步通道。
      class  DatagramChannel
      面向数据报的套接字的可选通道。
      class  FileChannel
      用于读取，写入，映射和操作文件的通道。
      class  FileLock
      表示文件区域上的锁的令牌。
      static class  Pipe.SinkChannel
      一个代表Pipe可写端的通道 。
      static class  Pipe.SourceChannel
      代表Pipe的可读端的通道 。
      class  SelectableChannel
      可通过Selector复用的通道 。
      class  Selector
      SelectableChannel对象的多路复用器。
      class  ServerSocketChannel
      用于面向流的侦听套接字的可选通道。
      class  SocketChannel
      用于面向流的连接插座的可选通道。

    • Uses of AutoCloseable in java.nio.channels.spi

      Classes in java.nio.channels.spi that implement AutoCloseable
      Modifier and Type Class 描述
      class  AbstractInterruptibleChannel
      可中断通道的基本实现类。
      class  AbstractSelectableChannel
      可选通道的基本实现类。
      class  AbstractSelector
      选择器的基本实现类。

    • Uses of AutoCloseable in java.nio.file

      Subinterfaces of AutoCloseable in java.nio.file
      Modifier and Type 接口 描述
      interface  DirectoryStream<T>
      一个对象来迭代目录中的条目。
      interface  SecureDirectoryStream<T>
      A DirectoryStream定义了相对于打开的目录定位的文件的操作。
      interface  WatchService
      手表服务， 手表已注册的对象的变化和事件。
      Classes in java.nio.file that implement AutoCloseable
      Modifier and Type Class 描述
      class  FileSystem
      提供文件系统的接口，并且是工厂用于访问文件系统中的文件和其他对象的对象。

    • Uses of AutoCloseable in java.rmi.server

      Classes in java.rmi.server that implement AutoCloseable
      Modifier and Type Class 描述
      class  LogStream
      已过时。
      没有替换

    • Uses of AutoCloseable in java.security

      Classes in java.security that implement AutoCloseable
      Modifier and Type Class 描述
      class  DigestInputStream
      透明流，使用通过流的位更新关联的消息摘要。
      class  DigestOutputStream
      透明流，使用通过流的位更新关联的消息摘要。

    • Uses of AutoCloseable in java.sql

      Subinterfaces of AutoCloseable in java.sql
      Modifier and Type 接口 描述
      interface  CallableStatement
      用于执行SQL存储过程的界面。
      interface  Connection
      与特定数据库的连接（会话）。
      interface  PreparedStatement
      表示预编译的SQL语句的对象。
      interface  ResultSet
      表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
      interface  Statement
      用于执行静态SQL语句并返回其生成的结果的对象。

    • Uses of AutoCloseable in java.util

      Classes in java.util that implement AutoCloseable
      Modifier and Type Class 描述
      class  Formatter
      printf风格格式字符串的解释器。
      class  Scanner
      一个简单的文本扫描器，可以使用正则表达式解析原始类型和字符串。

    • Uses of AutoCloseable in java.util.concurrent

      Classes in java.util.concurrent that implement AutoCloseable
      Modifier and Type Class 描述
      class  SubmissionPublisher<T>
      A Flow.Publisher异步地将提交的（非空）项目发送到当前订户，直到关闭。

    • Uses of AutoCloseable in java.util.jar

      Classes in java.util.jar that implement AutoCloseable
      Modifier and Type Class 描述
      class  JarFile
      JarFile类用于从可以使用 java.io.RandomAccessFile打开的任何文件中读取jar文件的内容。
      class  JarInputStream
      JarInputStream类用于从任何输入流读取JAR文件的内容。
      class  JarOutputStream
      JarOutputStream类用于将JAR文件的内容写入任何输出流。

    • Uses of AutoCloseable in java.util.stream

      Subinterfaces of AutoCloseable in java.util.stream
      Modifier and Type 接口 描述
      interface  BaseStream<T,S extends BaseStream<T,S>>
      流的基本界面，它们是支持顺序和并行聚合操作的元素序列。
      interface  DoubleStream
      支持顺序和并行聚合操作的原始双值元素序列。
      interface  IntStream
      支持顺序和并行聚合操作的原始int值元素序列。
      interface  LongStream
      支持顺序和并行聚合操作的原始长值元素序列。
      interface  Stream<T>
      支持顺序和并行聚合操作的一系列元素。

    • Uses of AutoCloseable in java.util.zip

      Classes in java.util.zip that implement AutoCloseable
      Modifier and Type Class 描述
      class  CheckedInputStream
      也保持正在读取的数据的校验和的输入流。
      class  CheckedOutputStream
      一个输出流，它还维护正在写入的数据的校验和。
      class  DeflaterInputStream
      实现用于压缩“放气”压缩格式的数据的输入流过滤器。
      class  DeflaterOutputStream
      该类实现了一种用于压缩“放气”压缩格式的数据的输出流过滤器。
      class  GZIPInputStream
      该类实现了一个流过滤器，用于读取GZIP文件格式的压缩数据。
      class  GZIPOutputStream
      该类实现了一个流过滤器，用于以GZIP文件格式写入压缩数据。
      class  InflaterInputStream
      该类实现了一个流过滤器，用于以“deflate”压缩格式解压缩数据。
      class  InflaterOutputStream
      实现输出流过滤器，用于解压缩以“放气”压缩格式存储的数据。
      class  ZipFile
      此类用于从zip文件读取条目。
      class  ZipInputStream
      该类实现了以ZIP文件格式读取文件的输入流过滤器。
      class  ZipOutputStream
      该类实现了以ZIP文件格式写入文件的输出流过滤器。

    • Uses of AutoCloseable in javax.crypto

      Classes in javax.crypto that implement AutoCloseable
      Modifier and Type Class 描述
      class  CipherInputStream
      CipherInputStream由InputStream和Cipher组成，使得read（）方法返回从底层InputStream读入但是由Cipher额外处理的数据。
      class  CipherOutputStream
      CipherOutputStream由OutputStream和Cipher组成，以便write（）方法首先在将数据写入底层OutputStream之前处理数据。

    • Uses of AutoCloseable in javax.imageio.stream

      Subinterfaces of AutoCloseable in javax.imageio.stream
      Modifier and Type 接口 描述
      interface  ImageInputStream
      一个可寻求的输入流接口，供 ImageReader使用。
      interface  ImageOutputStream
      一个可寻求的输出流接口，供 ImageWriter使用。
      Classes in javax.imageio.stream that implement AutoCloseable
      Modifier and Type Class 描述
      class  FileCacheImageInputStream
      一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
      class  FileCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。
      class  FileImageInputStream
      一个 ImageInputStream的实现，从 File或 RandomAccessFile获取其输入。
      class  FileImageOutputStream
      实现 ImageOutputStream将其输出直接写入 File或 RandomAccessFile 。
      class  ImageInputStreamImpl
      一个实现 ImageInputStream接口的抽象类。
      class  ImageOutputStreamImpl
      一个实现 ImageOutputStream接口的抽象类。
      class  MemoryCacheImageInputStream
      一个 ImageInputStream的实现，从常规的 InputStream获取它的输入。
      class  MemoryCacheImageOutputStream
      一个 ImageOutputStream的实现，将其输出写入常规的 OutputStream 。

    • Uses of AutoCloseable in javax.management.loading

      Classes in javax.management.loading that implement AutoCloseable
      Modifier and Type Class 描述
      class  MLet
      允许您在来自远程URL的MBean服务器中实例化和注册一个或多个MBean。
      class  PrivateMLet
      没有添加到ClassLoaderRepository的MLet。

    • Uses of AutoCloseable in javax.management.remote

      Subinterfaces of AutoCloseable in javax.management.remote
      Modifier and Type 接口 描述
      interface  JMXConnector
      JMX API连接器的客户端。

    • Uses of AutoCloseable in javax.management.remote.rmi

      Subinterfaces of AutoCloseable in javax.management.remote.rmi
      Modifier and Type 接口 描述
      interface  RMIConnection
      用于将MBeanServer请求从客户端转发到其在服务器端的MBeanServer实现的RMI对象。
      Classes in javax.management.remote.rmi that implement AutoCloseable
      Modifier and Type | Class | 描述
      class  RMIConnectionImpl
      实现RMIConnection界面。
      class  | RMIConnectionImpl_Stub
      class  RMIConnector
      与远程RMI连接器的连接。
      class  RMIIIOPServerImpl
      已过时。
      此运输已不再受支持。
      class  RMIJRMPServerImpl
      一个RMIServer对象，通过JRMP导出并将客户端连接创建为通过JRMP导出的RMI对象。
      class  RMIServerImpl
      表示连接器服务器的RMI对象。

    • Uses of AutoCloseable in javax.net.ssl

      Classes in javax.net.ssl that implement AutoCloseable
      Modifier and Type Class 描述
      class  SSLServerSocket
      该类扩展了 ServerSocket并使用安全套接字层（SSL）或传输层安全（TLS）协议等协议提供安全的服务器套接字。
      class  SSLSocket
      此类扩展了 Socket s，并使用诸如“安全套接字层”（SSL）或IETF“传输层安全”（TLS）协议之类的协议提供安全套接字。

    • Uses of AutoCloseable in javax.sound.midi

      Subinterfaces of AutoCloseable in javax.sound.midi
      Modifier and Type 接口 描述
      interface  MidiDevice
      MidiDevice是所有MIDI设备的基本界面。
      interface  MidiDeviceReceiver
      MidiDeviceReceiver是 Receiver其表示的MIDI输入连接器 MidiDevice （见 MidiDevice.getReceiver() ）。
      interface  MidiDeviceTransmitter
      MidiDeviceTransmitter是 Transmitter其表示的MIDI输入连接器 MidiDevice （见 MidiDevice.getTransmitter() ）。
      interface  Receiver
      A Receiver接收MidiEvent个对象，通常会做出有用的响应，例如解释它们生成声音或原始MIDI输出。
      interface  Sequencer
      播放MIDI sequence的硬件或软件设备被称为音序器 。
      interface  Synthesizer
      A Synthesizer产生声音。
      interface  Transmitter
      A Transmitter将MidiEvent个对象发送到一个或多个Receivers 。

    • Uses of AutoCloseable in javax.sound.sampled

      Subinterfaces of AutoCloseable in javax.sound.sampled
      Modifier and Type 接口 描述
      interface  Clip
      Clip接口代表一种特殊类型的数据线，其音频数据可以在播放之前加载，而不是实时流式传输。
      interface  DataLine
      DataLine添加媒体相关功能， Line 。
      interface  Line
      Line接口表示单声道或多声道音频馈送。
      interface  Mixer
      混音器是具有一行或多行的音频设备。
      interface  Port
      端口是用于输入或输出音频到音频设备的简单线。
      interface  SourceDataLine
      源数据线是可以写入数据的数据线。
      interface  TargetDataLine
      目标数据线是可以读取音频数据的类型DataLine 。
      Classes in javax.sound.sampled that implement AutoCloseable
      Modifier and Type Class 描述
      class  AudioInputStream
      音频输入流是具有指定音频格式和长度的输入流。

    • Uses of AutoCloseable in javax.sql

      Subinterfaces of AutoCloseable in javax.sql
      Modifier and Type 接口 描述
      interface  RowSet
      该接口为JavaBeans组件模型的JDBC API添加了支持。

    • Uses of AutoCloseable in javax.sql.rowset

      Subinterfaces of AutoCloseable in javax.sql.rowset
      Modifier and Type 接口 描述
      interface  CachedRowSet
      CachedRowSet所有标准实现必须实现的接口。
      interface  FilteredRowSet
      FilteredRowSet所有标准实现必须实现的标准接口。
      interface  JdbcRowSet
      JdbcRowSet所有标准实现必须实现的标准接口。
      interface  JoinRowSet
      JoinRowSet接口提供了将不同 RowSet对象的相关数据组合到一个 JoinRowSet对象中的机制，该对象表示SQL JOIN 。
      interface  WebRowSet
      WebRowSet所有实现必须实现的标准接口。

    • Uses of AutoCloseable in javax.sql.rowset.spi

      Subinterfaces of AutoCloseable in javax.sql.rowset.spi
      Modifier and Type 接口 描述
      interface  SyncResolver
      定义一个框架，允许应用程序使用手动决策树来决定在发生同步冲突时应该做什么。

    • Uses of AutoCloseable in javax.swing

      Classes in javax.swing that implement AutoCloseable
      Modifier and Type Class 描述
      class  ProgressMonitorInputStream
      监视从一些InputStream读取进度。

    • Uses of AutoCloseable in javax.tools

      Subinterfaces of AutoCloseable in javax.tools
      Modifier and Type 接口 描述
      interface  JavaFileManager
      用于Java编程语言源和类文件的工具的文件管理器。
      interface  StandardJavaFileManager
      文件管理器基于java.io.File和java.nio.file.Path 。
      Classes in javax.tools that implement AutoCloseable
      Modifier and Type Class 描述
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      转发给给定的文件管理器。

    • Uses of AutoCloseable in jdk.jshell

      Classes in jdk.jshell that implement AutoCloseable
      Modifier and Type Class 描述
      class  JShell
      JShell评估状态引擎。

    • Uses of AutoCloseable in jdk.jshell.execution

      Classes in jdk.jshell.execution that implement AutoCloseable
      Modifier and Type Class 描述
      class  DirectExecutionControl
      在当前进程中运行的一个ExecutionControl实现。
      class  JdiDefaultExecutionControl
      默认情况下，JShell-core使用的是ExecutionControl的实现。
      class  JdiExecutionControl
      摘要JDI实现ExecutionControl 。
      class  LocalExecutionControl
      执行ExecutionControl ，它在与JShell核心相同的JVM中执行。
      class  RemoteExecutionControl
      远程代理在执行过程中运行（与主JShell进程分开）。
      class  StreamingExecutionControl
      ExecutionControl执行引擎SPI的实现， 它将请求传送到执行发生的远程代理。

    • Uses of AutoCloseable in jdk.jshell.spi

      Subinterfaces of AutoCloseable in jdk.jshell.spi
      Modifier and Type 接口 描述
      interface  ExecutionControl
      该接口指定了实现可插拔JShell执行引擎必须提供的功能。

    • Uses of AutoCloseable in jdk.nashorn.api.scripting

      Classes in jdk.nashorn.api.scripting that implement AutoCloseable
      Modifier and Type Class 描述
      class  URLReader
      从URL读取的读者。

    • Uses of AutoCloseable in org.omg.CORBA_2_3.portable

      Classes in org.omg.CORBA_2_3.portable that implement AutoCloseable
      Modifier and Type Class 描述
      class  InputStream
      InputStream提供从流中读取所有映射的IDL类型。
      class  OutputStream
      OutputStream提供了将所有映射的IDL类型写入流的接口。

    • Uses of AutoCloseable in org.omg.CORBA.portable

      Classes in org.omg.CORBA.portable that implement AutoCloseable
      Modifier and Type Class 描述
      class  InputStream
      InputStream是用于从CDR元数据流读取IDL类型的Java API。
      class  OutputStream
      OuputStream is the Java API for writing IDL types to CDR marshal streams.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.CharSequence (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.CharSequence

  • Packages that use CharSequence
    软件包 描述
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.regex
    匹配字符序列与正则表达式指定的模式的类。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of CharSequence in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CharSequence
      Modifier and Type 方法 描述
      abstract void DocTrees.printMessage​(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息
      abstract void Trees.printMessage​(Diagnostic.Kind kind, CharSequence msg, 树 t, CompilationUnitTree root)
      在提供的编译单元中的树的位置打印指定类型的消息

    • Uses of CharSequence in java.io

      Methods in java.io with parameters of type CharSequence
      Modifier and Type | 方法 | 描述
      CharArrayWriter CharArrayWriter.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      CharArrayWriter CharArrayWriter.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      Writer | OutputStreamWriter.append​(CharSequence csq)
      Writer | OutputStreamWriter.append​(CharSequence csq, int start, int end)
      PrintStream PrintStream.append​(CharSequence csq)
      将指定的字符序列附加到此输出流。
      PrintStream PrintStream.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此输出流。
      PrintWriter PrintWriter.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      PrintWriter PrintWriter.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      StringWriter StringWriter.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      StringWriter StringWriter.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。
      Writer Writer.append​(CharSequence csq)
      将指定的字符序列附加到此作者。
      Writer Writer.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此作者。

    • Uses of CharSequence in java.lang

      Classes in java.lang that implement CharSequence
      Modifier and Type Class 描述
      class  String
      String类代表字符串。
      class  StringBuffer
      线程安全，可变的字符序列。
      class  StringBuilder
      一个可变的字符序列。
      Methods in java.lang that return CharSequence
      Modifier and Type | 方法 | 描述
      CharSequence CharSequence.subSequence​(int start, int end)
      返回一个 CharSequence ，这是这个序列的一个子序列。
      CharSequence String.subSequence​(int beginIndex, int endIndex)
      返回一个字符序列，该序列是该序列的子序列。
      CharSequence | StringBuffer.subSequence​(int start, int end)
      Methods in java.lang with parameters of type CharSequence
      Modifier and Type | 方法 | 描述
      Appendable Appendable.append​(CharSequence csq)
      将指定的字符序列追加到此 Appendable 。
      Appendable Appendable.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列追加到此 Appendable 。
      StringBuffer StringBuffer.append​(CharSequence s)
      追加指定的 CharSequence到这个序列。
      StringBuffer | StringBuffer.append​(CharSequence s, int start, int end)
      StringBuilder | StringBuilder.append​(CharSequence s)
      StringBuilder | StringBuilder.append​(CharSequence s, int start, int end)
      static int Character.codePointAt​(CharSequence seq, int index)
      返回 CharSequence给定索引处的代码点。
      static int Character.codePointBefore​(CharSequence seq, int index)
      返回 CharSequence给定索引之前的代码点。
      static int Character.codePointCount​(CharSequence seq, int beginIndex, int endIndex)
      返回指定字符序列的文本范围内的Unicode代码点数。
      boolean String.contains​(CharSequence s)
      当且仅当此字符串包含指定的char值序列时才返回true。
      boolean String.contentEquals​(CharSequence cs)
      将此字符串与指定的 CharSequence 。
      StringBuffer | StringBuffer.insert​(int dstOffset, CharSequence s)
      StringBuffer | StringBuffer.insert​(int dstOffset, CharSequence s, int start, int end)
      StringBuilder | StringBuilder.insert​(int dstOffset, CharSequence s)
      StringBuilder | StringBuilder.insert​(int dstOffset, CharSequence s, int start, int end)
      static String String.join​(CharSequence delimiter, CharSequence... elements)
      返回一个由连接在一起的 CharSequence elements副本组成的新的字符串，并附带指定的 delimiter的副本。
      static String String.join​(CharSequence delimiter, Iterable<? extends CharSequence> elements)
      返回一个新 String的副本组成 CharSequence elements与指定的副本一起加入 delimiter 。
      static int Character.offsetByCodePoints​(CharSequence seq, int index, int codePointOffset)
      返回给定char序列中的索引，该索引与给定的 index由 codePointOffset代码点偏移。
      static int Integer.parseInt​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数作为有符号int指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
      static long Long.parseLong​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数作为有符号long指定radix ，在指定的开始beginIndex并延伸至endIndex - 1 。
      static int Integer.parseUnsignedInt​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数为一个无符号int在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
      static long Long.parseUnsignedLong​(CharSequence s, int beginIndex, int endIndex, int radix)
      解析CharSequence参数为一个无符号long在指定radix ，在指定的开始beginIndex并延伸到endIndex - 1 。
      String String.replace​(CharSequence target, CharSequence replacement)
      将与字面目标序列匹配的字符串的每个子字符串替换为指定的文字替换序列。
      Method parameters in java.lang with type arguments of type CharSequence
      Modifier and Type 方法 描述
      static String String.join​(CharSequence delimiter, Iterable<? extends CharSequence> elements)
      返回一个新 String的副本组成 CharSequence elements与指定的副本一起加入 delimiter 。
      Constructors in java.lang with parameters of type CharSequence
      Constructor 描述
      StringBuffer​(CharSequence seq)
      构造一个字符串缓冲区，其中包含与指定的 CharSequence相同的字符。
      StringBuilder​(CharSequence seq)
      构造一个字符串构建器，其中包含与指定的 CharSequence相同的字符。

    • Uses of CharSequence in java.nio

      Classes in java.nio that implement CharSequence
      Modifier and Type Class 描述
      class  CharBuffer
      一个char缓冲区。
      Methods in java.nio with parameters of type CharSequence
      Modifier and Type 方法 描述
      CharBuffer CharBuffer.append​(CharSequence csq)
      将指定的字符序列追加到此缓冲区 （可选操作） 。
      CharBuffer CharBuffer.append​(CharSequence csq, int start, int end)
      将指定字符序列的子序列附加到此缓冲区 （可选操作） 。
      static CharBuffer CharBuffer.wrap​(CharSequence csq)
      将字符序列包装到缓冲区中。
      static CharBuffer CharBuffer.wrap​(CharSequence csq, int start, int end)
      将字符序列包装到缓冲区中。

    • Uses of CharSequence in java.nio.charset

      Methods in java.nio.charset with parameters of type CharSequence
      Modifier and Type 方法 描述
      boolean CharsetEncoder.canEncode​(CharSequence cs)
      告知编码器是否可以对给定的字符序列进行编码。

    • Uses of CharSequence in java.nio.file

      Method parameters in java.nio.file with type arguments of type CharSequence
      Modifier and Type 方法 描述
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, OpenOption... options)
      将文本行写入文件。

    • Uses of CharSequence in java.text

      Methods in java.text with parameters of type CharSequence
      Modifier and Type 方法 描述
      static boolean Normalizer.isNormalized​(CharSequence src, Normalizer.Form form)
      确定给定的char值序列是否被归一化。
      static String Normalizer.normalize​(CharSequence src, Normalizer.Form form)
      归一化一个char值序列。

    • Uses of CharSequence in java.time

      Methods in java.time with parameters of type CharSequence
      Modifier and Type 方法 描述
      static Duration Duration.parse​(CharSequence text)
      获得 Duration从文本字符串，如 PnDTnHnMn.nS 。
      static Instant Instant.parse​(CharSequence text)
      从文本字符串（例如 2007-12-03T10:15:30.00Z获取 Instant的实例。
      static LocalDate LocalDate.parse​(CharSequence text)
      从文本字符串（例如 2007-12-03获取 LocalDate的实例。
      static LocalDate LocalDate.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 LocalDate的实例。
      static LocalDateTime LocalDateTime.parse​(CharSequence text)
      从文本字符串（例如 2007-12-03T10:15:30获取 LocalDateTime的实例。
      static LocalDateTime LocalDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalDateTime的实例。
      static LocalTime LocalTime.parse​(CharSequence text)
      从文本字符串（例如 10:15获取 LocalTime的实例。
      static LocalTime LocalTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 LocalTime的实例。
      static MonthDay MonthDay.parse​(CharSequence text)
      从 --12-03等文本字符串获取 MonthDay的实例。
      static MonthDay MonthDay.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定格式化程序从文本字符串获取 MonthDay的实例。
      static OffsetDateTime OffsetDateTime.parse​(CharSequence text)
      从文本字符串（例如 2007-12-03T10:15:30+01:00获取 OffsetDateTime的实例。
      static OffsetDateTime OffsetDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 OffsetDateTime的实例。
      static OffsetTime OffsetTime.parse​(CharSequence text)
      从文本字符串（例如 10:15:30+01:00获取 OffsetTime的实例。
      static OffsetTime OffsetTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 OffsetTime的实例。
      static Period Period.parse​(CharSequence text)
      获得 Period从文本字符串，如 PnYnMnD 。
      static Year Year.parse​(CharSequence text)
      从文本字符串（例如 2007获取 Year的实例。
      static Year Year.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 Year的实例。
      static YearMonth YearMonth.parse​(CharSequence text)
      从文本字符串（例如 2007-12获取 YearMonth的实例。
      static YearMonth YearMonth.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 YearMonth的实例。
      static ZonedDateTime ZonedDateTime.parse​(CharSequence text)
      从 2007-12-03T10:15:30+01:00[Europe/Paris]等文本字符串获取 ZonedDateTime的实例。
      static ZonedDateTime ZonedDateTime.parse​(CharSequence text, DateTimeFormatter formatter)
      使用特定的格式化程序从文本字符串获取 ZonedDateTime的实例。

    • Uses of CharSequence in java.time.format

      Methods in java.time.format with parameters of type CharSequence
      Modifier and Type 方法 描述
      TemporalAccessor DateTimeFormatter.parse​(CharSequence text)
      完全解析产生时间对象的文本。
      TemporalAccessor DateTimeFormatter.parse​(CharSequence text, ParsePosition position)
      使用此格式化器解析文本，提供对文本位置的控制。
      <T> T DateTimeFormatter.parse​(CharSequence text, TemporalQuery<T> query)
      完全解析产生指定类型对象的文本。
      TemporalAccessor DateTimeFormatter.parseBest​(CharSequence text, TemporalQuery<?>... queries)
      完全解析产生指定类型之一的对象的文本。
      TemporalAccessor DateTimeFormatter.parseUnresolved​(CharSequence text, ParsePosition position)
      使用此格式化程序解析文本，而无需解析结果，用于高级用例。
      Constructors in java.time.format with parameters of type CharSequence
      Constructor 描述
      DateTimeParseException​(String message, CharSequence parsedData, int errorIndex)
      使用指定的消息构造新的异常。
      DateTimeParseException​(String message, CharSequence parsedData, int errorIndex, Throwable cause)
      构造一个新的异常与指定的消息和原因。

    • Uses of CharSequence in java.util

      Methods in java.util with parameters of type CharSequence
      Modifier and Type 方法 描述
      StringJoiner StringJoiner.add​(CharSequence newElement)
      将给定的副本 CharSequence值作为下一个元素 StringJoiner值。
      StringJoiner StringJoiner.setEmptyValue​(CharSequence emptyValue)
      设置在确定 StringJoiner的字符串表示时使用的字符序列，并且尚未添加任何元素，即当它为空时。
      Constructors in java.util with parameters of type CharSequence
      Constructor 描述
      StringJoiner​(CharSequence delimiter)
      构造一个 StringJoiner与其中不带字符，没有 prefix或 suffix ，和所提供的副本 delimiter 。
      StringJoiner​(CharSequence delimiter, CharSequence prefix, CharSequence suffix)
      构造一个 StringJoiner使用的供给拷贝在不带字符 prefix ， delimiter和 suffix 。

    • Uses of CharSequence in java.util.regex

      Methods in java.util.regex with parameters of type CharSequence
      Modifier and Type 方法 描述
      Matcher Pattern.matcher​(CharSequence input)
      创建一个匹配器，匹配给定的输入与此模式。
      static boolean Pattern.matches​(String regex, CharSequence input)
      编译给定的正则表达式，并尝试匹配给定的输入。
      Matcher Matcher.reset​(CharSequence input)
      使用新的输入序列重置此匹配器。
      String[] Pattern.split​(CharSequence input)
      将给定的输入序列分成这个模式的匹配。
      String[] Pattern.split​(CharSequence input, int limit)
      将给定的输入序列分成这个模式的匹配。
      Stream<String> Pattern.splitAsStream​(CharSequence input)
      根据给定的输入序列创建一个流，该流与该模式匹配。

    • Uses of CharSequence in java.util.stream

      Methods in java.util.stream that return types with arguments of type CharSequence
      Modifier and Type 方法 描述
      static Collector<CharSequence,?,String> Collectors.joining​()
      返回一个 Collector ，将输入元素连接到一个 String ，按照顺序。
      static Collector<CharSequence,?,String> Collectors.joining​(CharSequence delimiter)
      返回一个 Collector ，按照遇到的顺序连接由指定的分隔符分隔的输入元素。
      static Collector<CharSequence,?,String> Collectors.joining​(CharSequence delimiter, CharSequence prefix, CharSequence suffix)
      返回一个 Collector ，以按照顺序将指定的分隔符分隔的输入元素与指定的前缀和后缀相连接。
      Methods in java.util.stream with parameters of type CharSequence
      Modifier and Type 方法 描述
      static Collector<CharSequence,?,String> Collectors.joining​(CharSequence delimiter)
      返回一个 Collector ，按照遇到的顺序连接由指定的分隔符分隔的输入元素。
      static Collector<CharSequence,?,String> Collectors.joining​(CharSequence delimiter, CharSequence prefix, CharSequence suffix)
      返回一个 Collector ，按照遇到的顺序将指定的分隔符分隔的输入元素与指定的前缀和后缀相连接。

    • Uses of CharSequence in javafx.scene.control

      Methods in javafx.scene.control that return CharSequence
      Modifier and Type 方法 描述
      CharSequence TextField.getCharacters​()
      返回支持文本字段内容的字符序列。
      Methods in javafx.scene.control that return types with arguments of type CharSequence
      Modifier and Type 方法 描述
      ObservableList<CharSequence> TextArea.getParagraphs​()
      返回返回文本区域内容的字符序列的不可修改列表。

    • Uses of CharSequence in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type CharSequence
      Modifier and Type 方法 描述
      JavaFileObject Filer.createClassFile​(CharSequence name, Element... originatingElements)
      创建一个新的类文件，并返回一个对象以允许写入它。
      FileObject Filer.createResource​(JavaFileManager.Location location, CharSequence moduleAndPkg, CharSequence relativeName, Element... originatingElements)
      创建一个新的辅助资源文件进行写入并返回一个文件对象。
      JavaFileObject Filer.createSourceFile​(CharSequence name, Element... originatingElements)
      创建一个新的源文件并返回一个对象以允许写入它。
      FileObject Filer.getResource​(JavaFileManager.Location location, CharSequence moduleAndPkg, CharSequence relativeName)
      返回一个读取现有资源的对象。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg)
      打印指定类型的消息。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e)
      在元素的位置打印指定类型的消息。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a)
      在注释元素的注释镜像的位置打印指定类型的消息。
      void Messager.printMessage​(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
      在注释元素的注释镜像内的注释值的位置打印指定类型的消息。

    • Uses of CharSequence in javax.lang.model

      Methods in javax.lang.model with parameters of type CharSequence
      Modifier and Type 方法 描述
      static boolean SourceVersion.isIdentifier​(CharSequence name)
      返回 name是否是最新源版本中的语法有效的标识符（简称）或关键字。
      static boolean SourceVersion.isKeyword​(CharSequence s)
      返回 s是否是最新源版本中的关键字，布尔文字或空文字。
      static boolean SourceVersion.isKeyword​(CharSequence s, SourceVersion version)
      返回是否 s是一个关键字，布尔值，或在给定的源版本null文本。
      static boolean SourceVersion.isName​(CharSequence name)
      返回 name是否是最新版本的语法上有效的限定名称。
      static boolean SourceVersion.isName​(CharSequence name, SourceVersion version)
      返回是否 name是给定源版本中的语法有效的限定名称。

    • Uses of CharSequence in javax.lang.model.element

      Subinterfaces of CharSequence in javax.lang.model.element
      Modifier and Type 接口 描述
      interface  Name
      一个不可变的人物序列。
      Methods in javax.lang.model.element with parameters of type CharSequence
      Modifier and Type 方法 描述
      boolean Name.contentEquals​(CharSequence cs)
      将此名称与指定的 CharSequence 。

    • Uses of CharSequence in javax.lang.model.util

      Methods in javax.lang.model.util with parameters of type CharSequence
      Modifier and Type 方法 描述
      default Set<? extends PackageElement> Elements.getAllPackageElements​(CharSequence name)
      返回具有给定规范名称的所有包元素。
      default Set<? extends TypeElement> Elements.getAllTypeElements​(CharSequence name)
      返回具有给定规范名称的所有类型元素。
      default ModuleElement Elements.getModuleElement​(CharSequence name)
      返回给出其完全限定名称的模块元素。
      Name Elements.getName​(CharSequence cs)
      返回与参数相同的字符序列的名称。
      PackageElement Elements.getPackageElement​(CharSequence name)
      如果包在环境中是唯一的，则返回给定其全限定名称的包。
      default PackageElement Elements.getPackageElement​(ModuleElement module, CharSequence name)
      如给定模块所示，返回一个给定其全限定名称的包。
      TypeElement Elements.getTypeElement​(CharSequence name)
      如果类型元素在环境中是唯一的，则返回给出其规范名称的类型元素。
      default TypeElement Elements.getTypeElement​(ModuleElement module, CharSequence name)
      返回给定其规范名称的类型元素，从给定的模块中可以看出。

    • Uses of CharSequence in javax.swing.text

      Classes in javax.swing.text that implement CharSequence
      Modifier and Type Class 描述
      class  Segment
      表示文本片段的字符数组的段。
      Methods in javax.swing.text that return CharSequence
      Modifier and Type 方法 描述
      CharSequence Segment.subSequence​(int start, int end)
      返回一个 CharSequence ，这是这个序列的一个子序列。

    • Uses of CharSequence in javax.tools

      Methods in javax.tools that return CharSequence
      Modifier and Type | 方法 | 描述
      CharSequence FileObject.getCharContent​(boolean ignoreEncodingErrors)
      返回此文件对象的字符内容（如果可用）。
      CharSequence | ForwardingFileObject.getCharContent​(boolean ignoreEncodingErrors)
      CharSequence SimpleJavaFileObject.getCharContent​(boolean ignoreEncodingErrors)
      这个实现总是抛出UnsupportedOperationException 。

    • Uses of CharSequence in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type CharSequence
      Modifier and Type 方法 描述
      default CompletionStage<?> WebSocket.Listener.onText​(WebSocket webSocket, CharSequence message, WebSocket.MessagePart part)
      接收短信。
      CompletableFuture<WebSocket> WebSocket.sendText​(CharSequence message, boolean isLast)
      发送带有 CharSequence字符的 CharSequence 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.Cloneable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.Cloneable

  • Packages that use Cloneable
    软件包 描述
    com.sun.security.jgss
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.datatransfer
    提供用于在应用程序之间和之间传输数据的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.awt.geom
    提供用于定义和执行与二维几何相关的对象的操作的Java 2D类。
    java.awt.image
    提供创建和修改图像的类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.awt.print
    提供通用打印API的类和接口。
    java.net
    提供实现网络应用程序的类。
    java.security
    提供安全框架的类和接口。
    java.security.acl
    此包中的类和接口已被弃用。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.jar
    提供用于读取和写入JAR（Java ARchive）文件格式的类，该文件格式基于具有可选清单文件的标准ZIP文件格式。
    java.util.zip
    提供读写标准ZIP和GZIP文件格式的类。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.event
    为FX事件，交付和处理提供基本框架。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javax.activation
    javax.crypto
    提供加密操作的类和接口。
    javax.imageio.plugins.tiff
    内置TIFF插件使用的公共类。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.management.relation
    提供关系服务的定义。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.directory
    扩展 javax.naming软件包以提供访问目录服务的功能。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.print
    提供Java®打印服务API的主要类和接口。
    javax.print.attribute
    提供描述Java“打印服务”属性类型以及如何将其集合到属性集中的类和接口。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.sound.midi
    提供MIDI（乐器数字接口）数据的I / O，排序和综合的接口和类。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.plaf
    提供一个接口和许多抽象类，Swing用来提供其可插拔的外观和感觉功能。
    javax.swing.plaf.basic
    提供根据“基本”外观构建的用户界面对象。
    javax.swing.plaf.metal
    提供根据Java外观构建的用户界面对象（一旦代号为 Metal ），这是默认的外观和感觉。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和支持类创建HTML文本编辑器。
    javax.swing.text.rtf
    提供用于创建Rich-Text-Format文本编辑器的类（ RTFEditorKit ）。
    javax.swing.tree
    提供处理 javax.swing.JTree类和接口。
    javax.xml.datatype
    定义XML / Java类型映射。
    org.ietf.jgss
    该软件包提供了一个框架，允许应用程序开发人员使用诸如Kerberos等各种基础安全机制（使用统一API）的身份验证，数据完整性和数据机密性等安全服务。

    • Uses of Cloneable in com.sun.security.jgss

      Subinterfaces of Cloneable in com.sun.security.jgss
      Modifier and Type 接口 描述
      interface  ExtendedGSSCredential
      扩展的GSSCredential接口，用于支持未由 org.ietf.jgss.GSSCredential定义的附加功能。

    • Uses of Cloneable in java.awt

      Classes in java.awt that implement Cloneable
      Modifier and Type Class 描述
      class  BufferCapabilities
      缓冲区的功能和属性。
      class  Dimension
      Dimension类封装单个对象中组件的宽度和高度（以整数精度）。
      class  GridBagConstraints
      GridBagConstraints类为使用 GridBagLayout类布局的组件指定了约束。
      class  ImageCapabilities
      图像的能力和属性。
      class  Insets
      一个 Insets对象是容器边框的表示。
      class  JobAttributes
      一组控制打印作业的属性。
      class  PageAttributes
      一组控制打印页面输出的属性。
      class  Point
      表示 (x,y)坐标空间中的位置的点，以整数精度指定。
      class  Rectangle
      A Rectangle指定坐标空间中由 Rectangle对象的左上点 (x,y)的区域，坐标空间中的宽度及其高度。
      class  RenderingHints
      RenderingHints类定义和管理密钥和关联值的集合，允许应用程序为执行渲染和图像处理服务的其他类使用的算法选择提供输入。

    • Uses of Cloneable in java.awt.datatransfer

      Classes in java.awt.datatransfer that implement Cloneable
      Modifier and Type Class 描述
      class  DataFlavor
      A DataFlavor提供有关数据的元信息。

    • Uses of Cloneable in java.awt.font

      Classes in java.awt.font that implement Cloneable
      Modifier and Type Class 描述
      class  GlyphVector
      GlyphVector对象是包含几何信息的字形的集合，用于在对应于最终显示 GlyphVector的设备的变换的坐标空间中放置每个字形。
      class  TextLayout
      TextLayout是风格字符数据的不可变图形表示。
      class  TextMeasurer
      TextMeasurer类提供换行所需的原始操作：测量到给定的提前，确定一系列字符的提前，并为一系列字符生成 TextLayout 。

    • Uses of Cloneable in java.awt.geom

      Classes in java.awt.geom that implement Cloneable
      Modifier and Type Class 描述
      class  AffineTransform
      AffineTransform类表示2D仿射变换，其执行从2D坐标到其他2D坐标的线性映射，其保留线的“直线度”和“平行度”。
      class  Arc2D
      Arc2D是用于存储由边界矩形限定的2D弧的所有对象的抽象超，起始角度，角跨越（弧的长度），和一个闭合型（ OPEN ， CHORD ，或 PIE ）。
      static class  Arc2D.Double
      此类定义了 double精度中指定的弧。
      static class  Arc2D.Float
      该类定义了 float精度中指定的弧。
      class  Area
      一个 Area对象存储和操纵二维空间的封闭区域的与分辨率无关的描述。
      class  CubicCurve2D
      CubicCurve2D类定义了 (x,y)坐标空间中的三次参数曲线段。
      static class  CubicCurve2D.Double
      用 double坐标指定的三次参数曲线段。
      static class  CubicCurve2D.Float
      用 float坐标指定的三次参数曲线段。
      class  Dimension2D
      Dimension2D类是封装宽度和高度维度。
      class  Ellipse2D
      Ellipse2D类描述了由框架矩形定义的椭圆。
      static class  Ellipse2D.Double
      Double类定义了 double精度中指定的椭圆。
      static class  Ellipse2D.Float
      Float类定义了 float精度中指定的椭圆。
      class  GeneralPath
      GeneralPath类代表由直线构成的几何路径，以及二次和立方（Bézier）曲线。
      class  Line2D
      此 Line2D表示 (x,y)坐标空间中的线段。
      static class  Line2D.Double
      用双坐标指定的线段。
      static class  Line2D.Float
      用浮点坐标指定的线段。
      class  Path2D
      Path2D类提供了一个简单而又灵活的形状，表示任意的几何路径。
      static class  Path2D.Double
      Double类定义了一个几何路径，坐标存储在双精度浮点中。
      static class  Path2D.Float
      Float类定义了一个几何路径，坐标存储在单精度浮点中。
      class  Point2D
      Point2D类定义了一个表示 (x,y)坐标空间中的位置的点。
      static class  Point2D.Double
      Double类定义了 double精度指定的点。
      static class  Point2D.Float
      Float类定义浮点精度指定的点。
      class  QuadCurve2D
      QuadCurve2D类定义了 (x,y)坐标空间中的二次参数曲线段。
      static class  QuadCurve2D.Double
      用 double坐标指定的二次参数曲线段。
      static class  QuadCurve2D.Float
      用 float坐标指定的二次参数曲线段。
      class  Rectangle2D
      Rectangle2D类描述了由位置 (x,y)和维度 (w x h)定义的矩形。
      static class  Rectangle2D.Double
      Double类定义了一个以双坐标指定的矩形。
      static class  Rectangle2D.Float
      Float类定义了一个以浮点坐标指定的矩形。
      class  RectangularShape
      RectangularShape是几何由矩形框架定义的Shape对象的基类。
      class  RoundRectangle2D
      RoundRectangle2D类定义了一个矩形，其圆角由位置 (x,y)定义，尺寸为 (w x h) ，以及 (w x h)的宽度和高度。
      static class  RoundRectangle2D.Double
      Double类定义了一个带有圆角的矩形，全部在 double指定。
      static class  RoundRectangle2D.Float
      Float类定义了一个具有圆角的矩形，全部在 float坐标中指定。

    • Uses of Cloneable in java.awt.image

      Classes in java.awt.image that implement Cloneable
      Modifier and Type Class 描述
      class  AreaAveragingScaleFilter
      一个ImageFilter类，用于使用简单的区域平均算法对图像进行缩放，该算法产生比最近相邻算法更平滑的结果。
      class  BufferedImageFilter
      所述BufferedImageFilter类的子类的ImageFilter是提供一种使用单一源/单一目标图像操作符（的简单方法BufferedImageOp ）以过滤BufferedImage在图像生产者/消费者/观察员范例。
      class  CropImageFilter
      用于裁剪图像的ImageFilter类。
      class  ImageFilter
      此类实现了一组用于将数据从ImageProducer传递到ImageConsumer的接口方法的过滤器。
      class  Kernel
      Kernel类定义了一个矩阵，描述指定像素及其周围像素如何影响对滤波操作的输出图像中像素的位置计算的值。
      class  ReplicateScaleFilter
      一个ImageFilter类，用于使用最简单的算法缩放图像。
      class  RGBImageFilter
      该类提供了一种简单的方法来创建一个ImageFilter，它可以修改默认RGB ColorModel中图像的像素。

    • Uses of Cloneable in java.awt.image.renderable

      Classes in java.awt.image.renderable that implement Cloneable
      Modifier and Type Class 描述
      class  ParameterBlock
      A ParameterBlock封装了所有关于RenderableImageOp或处理图像的其他类所需的源和参数（对象）的信息。
      class  RenderContext
      RenderContext封装了从RenderableImage生成特定渲染所需的信息。

    • Uses of Cloneable in java.awt.print

      Classes in java.awt.print that implement Cloneable
      Modifier and Type Class 描述
      class  PageFormat
      PageFormat类描述了要打印的页面的大小和方向。
      class  Paper
      Paper类描述了一张纸的物理特性。

    • Uses of Cloneable in java.net

      Classes in java.net that implement Cloneable
      Modifier and Type Class 描述
      class  HttpCookie
      HttpCookie对象表示HTTP cookie，它承载服务器和用户代理之间的状态信息。

    • Uses of Cloneable in java.security

      Classes in java.security that implement Cloneable
      Modifier and Type Class 描述
      class  AuthProvider
      此类为提供程序定义登录和注销方法。
      class  Provider
      该类代表Java Security API的“提供者”，其中提供者实现了Java Security的部分或全部部分。

    • Uses of Cloneable in java.security.acl

      Subinterfaces of Cloneable in java.security.acl
      Modifier and Type 接口 描述
      interface  AclEntry
      已过时。
      自1.2版本以来，该软件包已被java.security.Policy和相关课程所取代。

    • Uses of Cloneable in java.security.cert

      Subinterfaces of Cloneable in java.security.cert
      Modifier and Type 接口 描述
      interface  CertPathBuilderResult
      认证路径构建器算法的结果的规范。
      interface  CertPathParameters
      认证路径算法参数的规范。
      interface  CertPathValidatorResult
      认证路径验证器算法的结果的规范。
      interface  CertSelector
      一个选择器，用于定义一组选择 Certificate的标准。
      interface  CertStoreParameters
      规格参数 CertStore 。
      interface  CRLSelector
      一个选择器，用于定义一组选择 CRL的标准。
      Classes in java.security.cert that implement Cloneable
      Modifier and Type Class 描述
      class  CollectionCertStoreParameters
      参数用作集合 CertStore算法的输入。
      class  LDAPCertStoreParameters
      参数用作LDAP CertStore算法的输入。
      class  PKIXBuilderParameters
      参数用作PKIX CertPathBuilder算法的输入。
      class  PKIXCertPathBuilderResult
      此类表示PKIX认证路径构建器算法的成功结果。
      class  PKIXCertPathChecker
      对 X509Certificate执行一个或多个检查的抽象类。
      class  PKIXCertPathValidatorResult
      该类代表PKIX认证路径验证算法的成功结果。
      class  PKIXParameters
      参数用作PKIX CertPathValidator算法的输入。
      class  PKIXRevocationChecker
      A PKIXCertPathChecker用于使用PKIX算法检查证书的撤销状态。
      class  URICertStoreParameters
      用作 CertStore算法的输入的参数，其使用URI中包含的信息来检索证书和CRL。
      class  X509CertSelector
      A CertSelector ，选择符合所有指定条件的 X509Certificates 。
      class  X509CRLSelector
      A CRLSelector选择符合所有指定条件的 X509CRLs 。

    • Uses of Cloneable in java.sql

      Classes in java.sql that implement Cloneable
      Modifier and Type Class 描述
      class  Date
      大约一毫秒值的薄包装，允许JDBC将其标识为SQL DATE值。
      class  Time
      一个围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
      class  Timestamp
      一个围绕 java.util.Date的薄型封装，允许JDBC API将其标识为SQL TIMESTAMP值。

    • Uses of Cloneable in java.text

      Subinterfaces of Cloneable in java.text
      Modifier and Type 接口 描述
      interface  AttributedCharacterIterator
      AttributedCharacterIterator允许通过文本和相关属性信息进行迭代。
      interface  CharacterIterator
      该接口定义了一种用于文本双向迭代的协议。
      Classes in java.text that implement Cloneable
      Modifier and Type Class 描述
      class  BreakIterator
      BreakIterator类实现了在文本中查找边界位置的方法。
      class  ChoiceFormat
      A ChoiceFormat允许您将格式附加到一系列数字。
      class  Collator
      Collator类执行区域设置敏感的 String比较。
      class  DateFormat
      DateFormat是日期/时间格式化子类的抽象类，它以语言无关的方式格式化和分析日期或时间。
      class  DateFormatSymbols
      DateFormatSymbols是用于封装可本地化的日期时间格式化数据的公共类，例如月份的名称，一周的日期名称和时区数据。
      class  DecimalFormat
      DecimalFormat是格式为十进制数的 NumberFormat的具体子类。
      class  DecimalFormatSymbols
      此类表示 DecimalFormat格式化数字所需的符号集（如小数分隔符，分组分隔符等）。
      class  Format
      Format是用于格式化区域设置敏感信息（如日期，消息和数字）的抽象基类。
      class  MessageFormat
      MessageFormat提供了一种以语言中立的方式产生级联消息的方法。
      class  NumberFormat
      NumberFormat是所有数字格式的抽象基类。
      class  RuleBasedCollator
      所述 RuleBasedCollator类是的具体子类 Collator ，提供了一个简单的，数据驱动的表collator。
      class  SimpleDateFormat
      SimpleDateFormat是用于以区域设置敏感的方式格式化和解析日期的具体类。
      class  StringCharacterIterator
      StringCharacterIterator实现 CharacterIterator协议为 String 。

    • Uses of Cloneable in java.util

      Classes in java.util that implement Cloneable
      Modifier and Type Class 描述
      class  ArrayDeque<E>
      Deque接口的可调整大小的数组实现。
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  BitSet
      该类实现了根据需要增长的位向量。
      class  Calendar
      所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
      class  Date
      Date类代表了一个特定的时刻，毫秒精度。
      class  EnumMap<K extends Enum<K>,V>
      专门用于枚举类型键的Map实现。
      class  EnumSet<E extends Enum<E>>
      一个专门用于枚举类型的Set实现。
      class  GregorianCalendar
      GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。
      class  HashMap<K,V>
      基于哈希表的实现的 Map接口。
      class  HashSet<E>
      该类实现了 Set接口，由哈希表（实际上是一个 HashMap实例）支持。
      class  Hashtable<K,V>
      该类实现了一个哈希表，它将键映射到值。
      class  IdentityHashMap<K,V>
      该类使用哈希表实现 Map接口，在比较键（和值）时，使用引用相等代替对象相等。
      class  LinkedHashMap<K,V>
      哈希表和链表实现的 Map接口，具有可预测的迭代次序。
      class  LinkedHashSet<E>
      哈希表和链表实现的 Set接口，具有可预测的迭代次序。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  Locale
      一个 Locale对象代表一个特定的地理，政治或文化区域。
      class  Properties
      Properties类代表一组持久的属性。
      class  SimpleTimeZone
      SimpleTimeZone是一个具体子类 TimeZone ，表示一个使用格里高利历的时区。
      class  Stack<E>
      Stack类代表了先进先出（LIFO）的堆栈。
      class  TimeZone
      TimeZone代表时区偏移，也可以计算出夏令时。
      class  TreeMap<K,V>
      一个基于红黑树的NavigableMap实现。
      class  TreeSet<E>
      A NavigableSet实现基于TreeMap 。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。

    • Uses of Cloneable in java.util.concurrent

      Classes in java.util.concurrent that implement Cloneable
      Modifier and Type Class 描述
      class  ConcurrentSkipListMap<K,V>
      可扩展并发ConcurrentNavigableMap实现。
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      class  CopyOnWriteArrayList<E>
      的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。

    • Uses of Cloneable in java.util.jar

      Classes in java.util.jar that implement Cloneable
      Modifier and Type Class 描述
      class  Attributes
      属性类将Manifest属性名称映射到关联的字符串值。
      class  JarEntry
      此类用于表示JAR文件条目。
      class  Manifest
      Manifest类用于维护清单条目名称及其相关属性。

    • Uses of Cloneable in java.util.zip

      Classes in java.util.zip that implement Cloneable
      Modifier and Type Class 描述
      class  ZipEntry
      此类用于表示ZIP文件条目。

    • Uses of Cloneable in javafx.concurrent

      Classes in javafx.concurrent that implement Cloneable
      Modifier and Type Class 描述
      class  WorkerStateEvent
      当一个工人状态发生变化时发生的事件。

    • Uses of Cloneable in javafx.event

      Classes in javafx.event that implement Cloneable
      Modifier and Type Class 描述
      class  ActionEvent
      一个Event代表一些类型的动作。
      class  Event
      FX事件的基础类。

    • Uses of Cloneable in javafx.scene.control

      Classes in javafx.scene.control that implement Cloneable
      Modifier and Type Class 描述
      static class  CheckBoxTreeItem.TreeModificationEvent<T>
      一个TreeModificationEvent类，与类似于TreeItem.TreeModificationEvent类的工作类似，因为该事件将引发 CheckBoxTreeItem层次结构，直到父节点为空。
      class  DialogEvent
      与对话框显示/隐藏操作相关的事件。
      static class  ListView.EditEvent<T>
      一个用于表示编辑相关事件的特定于ListView的Event子类。
      class  ScrollToEvent<T>
      事件相关ScrollPane所虚拟化控制，比如ListView ， TableView ， TreeView和TreeTableView 。
      class  SortEvent<C>
      事件涉及TableView和TreeTableView排序。
      static class  TableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TextFormatter.Change
      包含表示TextInputControl的内容或选择更改的状态。
      static class  TreeItem.TreeModificationEvent<T>
      一个Event ，其中包含所有形式的TreeItem修改的相关信息。
      static class  TreeTableColumn.CellEditEvent<S,T>
      用户在表单元格上执行编辑时触发的事件。
      static class  TreeTableView.EditEvent<S>
      一个Event在TreeTableView中专门用于表示编辑相关事件的子类。
      static class  TreeView.EditEvent<T>
      一个Event在TreeView中专门用于表示编辑相关事件的子类。

    • Uses of Cloneable in javafx.scene.input

      Classes in javafx.scene.input that implement Cloneable
      Modifier and Type Class 描述
      class  ClipboardContent
      数据容器Clipboard数据。
      class  ContextMenuEvent
      当用户请求上下文菜单时，会发生此事件。
      class  DragEvent
      拖动事件在拖放手势时替换鼠标事件。
      class  GestureEvent
      表示手势输入的事件。
      class  InputEvent
      指示用户输入的事件。
      class  InputMethodEvent
      一个表示底层输入法在Node中通知其文本更改的事件 。
      class  KeyEvent
      一个事件，表示一个击键发生在一个Node 。
      class  MouseDragEvent
      鼠标拖动事件在全按下按钮释放手势时被传送到潜在的手势目标。
      class  MouseEvent
      当鼠标事件发生时，选择光标下的最顶层节点，并通过EventDispatcher描述的捕获和冒泡阶段将事件传送给它。
      class  RotateEvent
      旋转事件指示用户执行旋转手势，例如在轨迹板，触摸屏或其他类似设备上彼此拖动两个手指。
      class  ScrollEvent
      滚动事件表示用户通过鼠标滚轮，轨迹板，触摸屏或其他类似设备执行滚动。
      class  SwipeEvent
      滑动事件表示用户执行滑动手势，例如在触摸屏上沿一个方向拖动手指。
      class  TouchEvent
      触摸事件表示触摸屏操作。
      class  ZoomEvent
      缩放事件表示用户执行缩放手势，例如在轨迹板，触摸屏或其他类似设备上分开拖动两根手指。

    • Uses of Cloneable in javafx.scene.media

      Classes in javafx.scene.media that implement Cloneable
      Modifier and Type Class 描述
      class  MediaErrorEvent
      一个Event代表在处理媒体时发生错误。
      class  MediaMarkerEvent
      代表媒体标记的ActionEvent 。

    • Uses of Cloneable in javafx.scene.transform

      Classes in javafx.scene.transform that implement Cloneable
      Modifier and Type Class 描述
      class  Affine
      Affine类代表一般的仿射变换。
      class  Rotate
      该类表示一个 Affine对象，它绕坐标点旋转坐标。
      class  Scale
      此类表示一个 Affine对象，可以根据指定的因素对坐标进行缩放。
      class  Shear
      该类表示一个 Affine对象，它通过指定的乘数来剪切坐标。
      class  Transform
      这个类是不同仿射变换的基类。
      class  TransformChangedEvent
      当它的任何属性发生变化时，这个事件被触发。
      class  Translate
      该类表示一个 Affine对象，它根据指定的因素转换坐标。

    • Uses of Cloneable in javafx.scene.web

      Classes in javafx.scene.web that implement Cloneable
      Modifier and Type Class 描述
      class  WebErrorEvent
      一个事件指示WebEngine错误。
      class  WebEvent<T>
      WebEvent实例被传递到EventHandler ，注册小号WebEngine由JavaScript的网页上运行。

    • Uses of Cloneable in javafx.stage

      Classes in javafx.stage that implement Cloneable
      Modifier and Type Class 描述
      class  WindowEvent
      与窗口显示/隐藏操作相关的事件。

    • Uses of Cloneable in javax.activation

      Classes in javax.activation that implement Cloneable
      Modifier and Type Class 描述
      class  ActivationDataFlavor
      ActivationDataFlavor类是 java.awt.datatransfer.DataFlavor的特殊子类。

    • Uses of Cloneable in javax.crypto

      Classes in javax.crypto that implement Cloneable
      Modifier and Type Class 描述
      class  Mac
      该类提供了“消息验证码”（MAC）算法的功能。

    • Uses of Cloneable in javax.imageio.plugins.tiff

      Classes in javax.imageio.plugins.tiff that implement Cloneable
      Modifier and Type Class 描述
      class  TIFFDirectory
      简化与TIFF本地图像元数据交互的便利类。
      class  TIFFField
      表示TIFF 6.0图像文件目录中的字段的类。

    • Uses of Cloneable in javax.management

      Subinterfaces of Cloneable in javax.management
      Modifier and Type 接口 描述
      interface  Descriptor
      JMX元素的附加元数据。
      Classes in javax.management that implement Cloneable
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。
      class  ImmutableDescriptor
      一个不可变的描述符。
      class  MBeanAttributeInfo
      描述为管理而公开的MBean属性。
      class  MBeanConstructorInfo
      描述由MBean公开的构造函数。
      class  MBeanInfo
      描述MBean暴露的管理界面; 即可用于管理操作的一组属性和操作。
      class  MBeanNotificationInfo
      MBeanNotificationInfo类用于描述针对给定Java类通知的MBean发出的不同通知实例的特性。
      class  MBeanOperationInfo
      描述MBean公开的管理操作。
      class  MBeanParameterInfo
      描述MBean暴露的操作的参数。

    • Uses of Cloneable in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement Cloneable
      Modifier and Type Class 描述
      class  DescriptorSupport
      此类表示一个ModelMBean元素的元数据集。
      class  ModelMBeanAttributeInfo
      ModelMBeanAttributeInfo对象描述了ModelMBean的属性。
      class  ModelMBeanConstructorInfo
      ModelMBeanConstructorInfo对象描述了ModelMBean的构造函数。
      class  ModelMBeanInfoSupport
      此类表示ModelMBeans的元数据。
      class  ModelMBeanNotificationInfo
      ModelMBeanNotificationInfo对象描述了由ModelMBean发出的通知。
      class  ModelMBeanOperationInfo
      ModelMBeanOperationInfo对象描述了ModelMBean的管理操作。

    • Uses of Cloneable in javax.management.openmbean

      Classes in javax.management.openmbean that implement Cloneable
      Modifier and Type Class 描述
      class  OpenMBeanAttributeInfoSupport
      描述一个打开的MBean的属性。
      class  OpenMBeanConstructorInfoSupport
      描述一个开放MBean的构造函数。
      class  OpenMBeanInfoSupport
      OpenMBeanInfoSupport类描述了一个开放的MBean的管理信息：它是一个MBeanInfo的子类，它实现了OpenMBeanInfo接口。
      class  OpenMBeanOperationInfoSupport
      描述一个Open MBean的操作。
      class  OpenMBeanParameterInfoSupport
      描述在开放MBean的一个或多个操作或构造函数中使用的参数。
      class  TabularDataSupport
      TabularDataSupport类是实现 TabularData和 Map接口的 开放数据类，它在内部基于散列映射数据结构。

    • Uses of Cloneable in javax.management.relation

      Classes in javax.management.relation that implement Cloneable
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。

    • Uses of Cloneable in javax.naming

      Subinterfaces of Cloneable in javax.naming
      Modifier and Type 接口 描述
      interface  Name
      Name接口表示一个通用名称 - 组件的有序序列。
      Classes in javax.naming that implement Cloneable
      Modifier and Type Class 描述
      class  CompositeName
      此类表示组合名称 - 跨多个命名空间的组件名称序列。
      class  CompoundName
      该类表示复合名称 - 来自分层名称空间的名称。
      class  LinkRef
      此类表示一个引用，其内容是名称，称为链接名称，该名称绑定到上下文中的原子名称。
      class  Reference
      此类表示对在命名/目录系统外部找到的对象的引用。

    • Uses of Cloneable in javax.naming.directory

      Subinterfaces of Cloneable in javax.naming.directory
      Modifier and Type 接口 描述
      interface  Attribute
      此接口表示与命名对象关联的属性。
      interface  Attributes
      此接口表示属性的集合。
      Classes in javax.naming.directory that implement Cloneable
      Modifier and Type Class 描述
      class  BasicAttribute
      该类提供了 Attribute接口的基本实现。
      class  BasicAttributes
      该类提供了Attributes界面的基本实现。

    • Uses of Cloneable in javax.naming.ldap

      Classes in javax.naming.ldap that implement Cloneable
      Modifier and Type Class 描述
      class  LdapName
      该类表示由 RFC 2253指定的专有名称。

    • Uses of Cloneable in javax.print

      Classes in javax.print that implement Cloneable
      Modifier and Type Class 描述
      class  DocFlavor
      DocFlavor类封装了一个对象，它将打印数据的格式指定给一个DocPrintJob 。
      static class  DocFlavor.BYTE_ARRAY
      DocFlavor.BYTE_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字节数组（ byte[] ）作为打印数据表示类的doc风格。
      static class  DocFlavor.CHAR_ARRAY
      DocFlavor.CHAR_ARRAY类提供了预定义的静态常量DocFlavor对象，例如使用字符数组（ char[] ）作为打印数据表示类的doc风格。
      static class  DocFlavor.INPUT_STREAM
      DocFlavor.INPUT_STREAM类提供了预定义的静态常量DocFlavor对象，例如使用字节流（ java.io.InputStream ）作为打印数据表示类的doc 口音 。
      static class  DocFlavor.READER
      DocFlavor.READER类提供了预定义的静态常量DocFlavor对象，例如使用字符流（ java.io.Reader ）作为打印数据表示类的doc风格。
      static class  DocFlavor.SERVICE_FORMATTED
      DocFlavor.SERVICE_FORMATTED类提供了预定义的静态常量DocFlavor对象，例如用于服务格式化打印数据的doc风格。
      static class  DocFlavor.STRING
      DocFlavor.STRING类提供了预定义的静态常量DocFlavor对象，例如使用字符串（ java.lang.String ）作为打印数据表示类的doc风格。
      static class  DocFlavor.URL
      DocFlavor.URL类提供了预定义的静态常量DocFlavor对象。

    • Uses of Cloneable in javax.print.attribute

      Classes in javax.print.attribute that implement Cloneable
      Modifier and Type Class 描述
      class  DateTimeSyntax
      类DateTimeSyntax是一个抽象基类，提供值为日期和时间的所有属性的常见实现。
      class  EnumSyntax
      类EnumSyntax是提供所有“类型安全枚举”对象的通用实现的抽象基类。
      class  IntegerSyntax
      Class IntegerSyntax是一个抽象基类，提供了具有整数值的所有属性的通用实现。
      class  ResolutionSyntax
      Class ResolutionSyntax是一个抽象基类，提供表示打印机分辨率的所有属性的常见实现。
      class  SetOfIntegerSyntax
      类SetOfIntegerSyntax是一个抽象基类，提供了所有属性的常见实现，其值是一组非负整数。
      class  Size2DSyntax
      Class Size2DSyntax是一个抽象基类，提供表示二维大小的所有属性的常见实现。
      class  TextSyntax
      Class TextSyntax是一个抽象基类，提供了值为字符串的所有属性的常见实现。
      class  URISyntax
      类URISyntax是一个抽象基类，提供其值为统一资源标识符（URI）的所有属性的常见实现。

    • Uses of Cloneable in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement Cloneable
      Modifier and Type Class 描述
      class  Chromaticity
      Class Chromaticity是一个打印属性类，一个枚举，用于指定单色或彩色打印。
      class  ColorSupported
      ColorSupported类是一个打印属性类，一个枚举，用于标识设备是否能够进行任何类型的彩色打印，包括突出显示颜色以及全过程颜色。
      class  Compression
      类压缩是打印属性类，枚举，用于指定打印数据的压缩方式。
      class  Copies
      Class Copies是一个整数值的打印属性类，它指定要打印的份数。
      class  CopiesSupported
      Class CopiesSupported是一个打印属性类，一组整数，为Copies属性提供支持的值。
      class  DateTimeAtCompleted
      类DateTimeAtCompleted是打印属性类，日期时间属性，指示打印作业完成（或被取消或中止）的日期和时间。
      class  DateTimeAtCreation
      类DateTimeAtCreation是一个打印属性类，一个日期时间属性，表示创建打印作业的日期和时间。
      class  DateTimeAtProcessing
      类DateTimeAtProcessing是打印属性类，日期时间属性，表示打印作业首次开始处理的日期和时间。
      class  Destination
      类目标是打印属性类（URI），用于指示假脱机打印机格式化数据的备用目标。
      class  DialogTypeSelection
      DialogTypeSelection类是一个打印属性类，一个枚举，指示用于指定打印选项的用户对话框类型。
      class  DocumentName
      DocumentName类是一个打印属性类，一个指定文档名称的文本属性。
      class  Fidelity
      类Fidelity是打印属性类，枚举，指示是否需要对客户端提供的打印请求属性的总保真度。
      class  Finishings
      类完成是打印属性类，枚举，用于标识打印机是否对作业中每个打印文档的每个副本执行某种类型的装订操作。
      class  JobHoldUntil
      JobHoldUntil类是一个打印属性类，一个日期时间属性，用于指定作业必须成为打印候选者的确切日期和时间。
      class  JobImpressions
      JobImpress类是一个整数值打印属性类，它指定要提交的文档的展示次数的总大小。
      class  JobImpressionsCompleted
      JobImpressionsCompleted类是一个整数值的打印属性类，用于指定目前为该作业完成的展示次数。
      class  JobImpressionsSupported
      JobImpressions类支持的是一个打印属性类，一组整数，它为JobImpressions属性提供支持的值。
      class  JobKOctets
      JobKOctets类是一个整数值打印属性类，用于指定以K个八位字节为单位的文档的总大小，即以作业中请求处理的1024个八位字节为单位。
      class  JobKOctetsProcessed
      JobKOctetsProcessed类是一个整数值打印属性类，它指定了目前以K个八位字节处理的打印数据八位字节的总数，即1024个八位字节的单位。
      class  JobKOctetsSupported
      JobKOctetsSupported类是一个打印属性类，一组整数，它为JobKOctets属性提供支持的值。
      class  JobMediaSheets
      JobMediaSheets类是一个整数值打印属性类，它指定要为此作业生成的介质页的总数。
      class  JobMediaSheetsCompleted
      JobMediaSheetsCompleted类是一个整数值的打印属性类，它指定了到目前为止整个作业已经完成标记和堆叠的介质页数，无论这些工作表是在一边还是两者上进行处理。
      class  JobMediaSheetsSupported
      JobMediaSheetsSupported类是一个打印属性类，一组整数，它为JobMediaSheets属性提供支持的值。
      class  JobMessageFromOperator
      JobMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示对作业执行修改或其他管理操作的原因。
      class  JobName
      JobName类是一个打印属性类，一个指定打印作业名称的文本属性。
      class  JobOriginatingUserName
      JobOriginatingUserName类是一个打印属性类，一个文本属性，其中包含提交打印作业的最终用户的名称。
      class  JobPriority
      JobPriority类是一个整数值打印属性类，用于指定打印作业的优先级。
      class  JobPrioritySupported
      JobPrioritySupported类是一个整数值打印属性类，它指定打印服务实例是否支持JobPriority属性和支持的不同作业优先级的数量。
      class  JobSheets
      JobSheets类是打印属性类（枚举），用于确定必须使用作业打印哪些作业开始和结束工作表（如果有）。
      class  JobState
      JobState是一个打印属性类，一个枚举，用于标识打印作业的当前状态。
      class  JobStateReason
      JobStateReason类是一个打印属性类，一个枚举，提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。
      class  Media
      Class Media是一个打印属性类，用于指定要打印的介质。
      class  MediaName
      MediaName类是Media的子类，它是打印属性类（枚举），用于将打印作业的媒体指定为名称。
      class  MediaSize
      MediaSize类是一种二维尺寸值的打印属性类，它以纵向方向指示介质的尺寸，X尺寸沿着底边缘运行，Y尺寸沿着左边缘运行。
      class  MediaSizeName
      MediaSizeName类是Media的子类。
      class  MediaTray
      MediaTray类是Media的一个子类。
      class  MultipleDocumentHandling
      MultipleDocumentHandling类是一个打印属性类，一个枚举，用于控制整理操作，以及将一个或多个打印流页面放置到展示位置和介质页面上。
      class  NumberOfDocuments
      类NumberOfDocuments是一个整数值打印属性，表示打印机已接受此作业的单个文档的数量，无论文档的打印数据是否到达打印机。
      class  NumberOfInterveningJobs
      Class NumberOfInterveningJobs是一个整数值打印属性，它以预期完成时间（即当前调度顺序）的相对时间顺序指示该作业前面的作业数。
      class  NumberUp
      类NumberUp是一个整数值打印属性类，它指定要在所选介质的实例的单侧施加的打印流页数。
      class  NumberUpSupported
      NumberUpSupported类是一个打印属性类，一组整数，为NumberUp属性提供支持的值。
      class  OrientationRequested
      类OrientationRequested是打印属性类，枚举，指示打印的打印流页面的所需方向; 它不描述客户端提供的打印流页面的方向。
      class  OutputDeviceAssigned
      类OutputDeviceAssigned是一个打印属性类，一个文本属性，用于标识服务分配了此作业的输出设备。
      class  PageRanges
      Class PageRanges是一个打印属性类，一组整数，用于标识打印机对象用于打印每个文档的每个副本的打印流页面的范围。
      class  PagesPerMinute
      Class PagesPerMinute是一个整数值打印属性，它表示可能由此打印机生成的最接近的整数的每分钟的标称页数（例如单面，黑白）。
      class  PagesPerMinuteColor
      Class PagesPerMinuteColor是一个整数值打印属性，表示当打印颜色（例如，单色，颜色）时可能由此打印机生成的最近整数的每分钟的标称页数。
      class  PDLOverrideSupported
      类PDLOverrideSupported是打印属性类，枚举，表示打印机尝试覆盖嵌入在文档打印数据中的处理指令的能力，处理指令指定为打印数据之外的属性。
      class  PresentationDirection
      类PresentationDirection是打印属性类，枚举，与NumberUp属性结合使用，以指示多个打印流页面在所选介质的实例的单侧上施加的布局。
      class  PrinterInfo
      PrinterInfo类是一个打印属性类，一个文本属性，它提供有关打印机的描述信息。
      class  PrinterIsAcceptingJobs
      PrinterIsAcceptingJobs类是打印属性类，枚举，指示打印机当前是否能够接受作业。
      class  PrinterLocation
      PrinterLocation类是打印属性类，一个文本属性，用于标识设备的位置。
      class  PrinterMakeAndModel
      PrinterMakeAndModel类是打印属性类，文本属性，即打印机的制造商和型号。
      class  PrinterMessageFromOperator
      PrinterMessageFromOperator类是一个打印属性类，一个文本属性，它提供来自操作员，系统管理员或“智能”过程的消息，以向最终用户指示打印机的信息或状态，例如为什么不可用或何时预计可用。
      class  PrinterMoreInfo
      PrinterMoreInfo类是打印属性类（URI），用于获取有关此特定打印机的更多信息。
      class  PrinterMoreInfoManufacturer
      PrinterMoreInfoManufacturer类是打印属性类（URI），用于获取有关此类设备的更多信息。
      class  PrinterName
      PrinterName类是一个打印属性类，一个指定打印机名称的文本属性。
      class  PrinterResolution
      PrinterResolution类是一个打印属性类，它指定打印机支持的准确分辨率或用于打印作业。
      class  PrinterState
      PrinterState类是打印属性类，枚举，用于标识打印机的当前状态。
      class  PrinterStateReason
      PrinterStateReason类是打印属性类，枚举，提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
      class  PrinterStateReasons
      PrinterStateReasons类是打印属性类，一组枚举值，提供有关打印机当前状态的其他信息，即增加打印机PrinterState属性值的信息。
      class  PrinterURI
      PrinterURI类是一个打印属性类，一个URI，它指定打印机的全局唯一名称。
      class  PrintQuality
      PrintQuality类是打印属性类（枚举），用于指定打印机用于作业的打印质量。
      class  QueuedJobCount
      Class QueuedJobCount是一个整数值打印属性，表示打印机中的作业数量，其中JobState为PENDING，PENDING_HELD，PROCESSING或PROCESSING_STOPPED。
      class  ReferenceUriSchemesSupported
      Class ReferenceUriSchemesSupported是打印属性类，表示打印机可用于检索存储在URI位置的打印数据的“URI方案”（例如“http：”或“ftp：”）的枚举。
      class  RequestingUserName
      Class RequestingUserName是一个打印属性类，一个文本属性，指定提交打印作业的最终用户的名称。
      class  Severity
      Class Severity是一个打印属性类，枚举，表示PrinterStateReason属性的严重性。
      class  SheetCollate
      Sheet SheetCollate是一个打印属性类，一个枚举，用于指定当Copies属性指定文档的多个副本时，作业中每个打印文档的每个副本的介质页是否按顺序排列。
      class  Sides
      Class Sides是一个打印属性类，一个枚举，它指定打印流页面如何被施加到所选介质实例的侧面，即一个印象。

    • Uses of Cloneable in javax.sound.midi

      Classes in javax.sound.midi that implement Cloneable
      Modifier and Type Class 描述
      class  MetaMessage
      A MetaMessage是对合成器无意义的MidiMessage ，但可以存储在MIDI文件中并由音序器程序解释。
      class  MidiMessage
      MidiMessage是MIDI消息的基类。
      class  ShortMessage
      A ShortMessage包含一个MIDI消息，其状态字节后面最多有两个数据字节。
      class  SysexMessage
      一个 SysexMessage对象表示一个MIDI系统独占消息。

    • Uses of Cloneable in javax.sql.rowset

      Classes in javax.sql.rowset that implement Cloneable
      Modifier and Type Class 描述
      class  BaseRowSet
      一个抽象类，提供一个 RowSet对象及其基本功能。

    • Uses of Cloneable in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Cloneable
      Modifier and Type Class 描述
      class  SerialArray
      一个 Array对象的序列化版本，它是Java编程语言中的一个SQL ARRAY值的映射。
      class  SerialBlob
      Java编程语言中的序列化映射为SQL BLOB值。
      class  SerialClob
      一个序列化映射的Java编程语言中的一个SQL CLOB值。
      class  SerialDatalink
      在Java编程语言中的序列化映射SQL DATALINK值。
      class  SerialJavaObject
      一个可编程 JAVA_OBJECT映射的Java编程语言中的一个SQL JAVA_OBJECT值。
      class  SerialRef
      一个 Ref对象的序列化映射，它是Java编程语言中的一个SQL REF值的映射。
      class  SerialStruct
      SQL编程语言中的SQL结构化类型的序列化映射。

    • Uses of Cloneable in javax.swing

      Classes in javax.swing that implement Cloneable
      Modifier and Type Class 描述
      class  AbstractAction
      该类提供了JFC Action接口的默认实现。
      class  DefaultListSelectionModel
      列表选择的默认数据模型。
      class  GrayFilter
      通过将图像转换成灰度图像来“禁用”图像并增亮图像中的像素的图像滤镜。
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode可以包装向量/哈希表/数组/字符串，并根据需要创建适当的子树节点。
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel是一个 TreeSelectionModel ，不允许任何东西被选择。
      class  UIDefaults
      Swing组件的默认表。

    • Uses of Cloneable in javax.swing.plaf

      Classes in javax.swing.plaf that implement Cloneable
      Modifier and Type Class 描述
      class  DimensionUIResource
      Dimension的子类实现 UIResource 。
      class  InsetsUIResource
      Insets实现UIResource的子类。

    • Uses of Cloneable in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Cloneable
      Modifier and Type Class 描述
      protected class  BasicDesktopPaneUI.CloseAction
      处理关闭内部框架。
      protected class  BasicDesktopPaneUI.MaximizeAction
      处理最大化内部框架。
      protected class  BasicDesktopPaneUI.MinimizeAction
      处理最小化内部框架。
      protected class  BasicDesktopPaneUI.NavigateAction
      处理导航到下一个内部框架。
      protected class  BasicDesktopPaneUI.OpenAction
      处理恢复最小化或最大化的内部框架。
      protected class  BasicFileChooserUI.ApproveSelectionAction
      响应打开或保存请求
      protected class  BasicFileChooserUI.CancelSelectionAction
      回复取消请求。
      protected class  BasicFileChooserUI.ChangeToParentDirectoryAction
      更改为父目录操作。
      protected class  BasicFileChooserUI.GoHomeAction
      在“家”键事件或等效事件上行事。
      protected class  BasicFileChooserUI.NewFolderAction
      创建一个新文件夹。
      protected class  BasicFileChooserUI.UpdateAction
      重新扫描当前目录中的文件
      class  BasicInternalFrameTitlePane.CloseAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.IconifyAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MaximizeAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.MoveAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.RestoreAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicInternalFrameTitlePane.SizeAction
      这个类应该被视为一个“受保护”的内部类。
      class  BasicSliderUI.ActionScroller
      从Java 2平台v1.3开始，这个未记录的类就不再使用了。
      static class  BasicTextUI.BasicCaret
      接口默认实现 Caret 。
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener在执行操作时调用cancelEditing。
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction用于处理结束/ home操作。
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction用于处理上/下动作。
      class  BasicTreeUI.TreePageAction
      TreePageAction处理页面向上和向下翻页事件。
      class  BasicTreeUI.TreeToggleAction
      对于第一个选定的行展开将被切换。
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction是用于左/右键的动作。

    • Uses of Cloneable in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement Cloneable
      Modifier and Type Class 描述
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      当DirectoryComboBox更改所选项目时使用。

    • Uses of Cloneable in javax.swing.text

      Classes in javax.swing.text that implement Cloneable
      Modifier and Type Class 描述
      class  DateFormatter
      DateFormatter是一个 InternationalFormatter ，它通过 java.text.DateFormat的实例进行 java.text.DateFormat 。
      class  DefaultCaret
      默认的Caret实现。
      class  DefaultEditorKit
      这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。
      static class  DefaultEditorKit.BeepAction
      发出哔声
      static class  DefaultEditorKit.CopyAction
      复制所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.CutAction
      剪切所选区域并将其内容放入系统剪贴板。
      static class  DefaultEditorKit.DefaultKeyTypedAction
      如果接收到 键入类型的事件并且没有键映射条目，则默认执行的操作。
      static class  DefaultEditorKit.InsertBreakAction
      在文档中放置一个行/段落。
      static class  DefaultEditorKit.InsertContentAction
      将内容放入相关的文档。
      static class  DefaultEditorKit.InsertTabAction
      将标签字符放在文档中。
      static class  DefaultEditorKit.PasteAction
      将系统剪贴板的内容粘贴到所选区域中，或者如果没有选择任何内容，则将其插入插入符号之前。
      class  DefaultFormatter
      DefaultFormatter格式化任意对象。
      class  EditorKit
      将文本组件所需的一组事物建立为某种 类型的文本内容的合理功能的编辑器。
      class  ElementIterator
      ElementIterator，顾名思义，遍历Element树。
      class  GlyphView
      GlyphView是一种风格的文本块，表示在文本模型中映射到元素上的视图。
      class  InternationalFormatter
      InternationalFormatter延伸 DefaultFormatter ，使用的实例 java.text.Format来处理转换为字符串，并从字符串的转换。
      class  LabelView
      A LabelView是一种风格的文本块，表示在文本模型中映射到元素上的视图。
      class  MaskFormatter
      MaskFormatter用于格式化和编辑字符串。
      class  NumberFormatter
      NumberFormatter子类 InternationalFormatter为数字添加特殊行为。
      class  Segment
      表示文本片段的字符数组的段。
      class  SimpleAttributeSet
      使用哈希表直接实现MutableAttributeSet。
      class  StyledEditorKit
      这是文本组件所需的一组事物，作为某种 类型的文本文档的合理功能的编辑器。
      static class  StyledEditorKit.AlignmentAction
      设置段落对齐的动作。
      static class  StyledEditorKit.BoldAction
      用于切换粗体属性的操作。
      static class  StyledEditorKit.FontFamilyAction
      在关联的JEditorPane中设置字体系列的操作。
      static class  StyledEditorKit.FontSizeAction
      在关联的JEditorPane中设置字体大小的操作。
      static class  StyledEditorKit.ForegroundAction
      设置前景色的动作。
      static class  StyledEditorKit.ItalicAction
      切换斜体属性的动作。
      static class  StyledEditorKit.StyledTextAction
      一个假定它被安装在一个带有StyledEditorKit（或子类）的JEditorPane上被触发的动作。
      static class  StyledEditorKit.UnderlineAction
      切换下划线属性的动作。
      class  TextAction
      对于跨多个不同文本组件共享的键绑定的Action实现。

    • Uses of Cloneable in javax.swing.text.html

      Classes in javax.swing.text.html that implement Cloneable
      Modifier and Type Class 描述
      class  HTMLEditorKit
      Swing JEditorPane文本组件通过称为EditorKit的插件机制来支持不同类型的内容。
      static class  HTMLEditorKit.HTMLTextAction
      一个抽象的Action提供了一些方便的方法，可能有助于将HTML插入到现有文档中。
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction可用于将HTML的任意字符串插入到现有的HTML文档中。
      class  InlineView
      基于CSS属性显示 内联元素样式。

    • Uses of Cloneable in javax.swing.text.rtf

      Classes in javax.swing.text.rtf that implement Cloneable
      Modifier and Type Class 描述
      class  RTFEditorKit
      这是RTF编辑功能的默认实现。

    • Uses of Cloneable in javax.swing.tree

      Classes in javax.swing.tree that implement Cloneable
      Modifier and Type Class 描述
      class  DefaultMutableTreeNode
      A DefaultMutableTreeNode是树状数据结构中的通用节点。
      class  DefaultTreeSelectionModel
      TreeSelectionModel的默认实现。

    • Uses of Cloneable in javax.xml.datatype

      Classes in javax.xml.datatype that implement Cloneable
      Modifier and Type Class 描述
      class  XMLGregorianCalendar
      W3C XML Schema 1.0日期/时间数据类型的表示。

    • Uses of Cloneable in org.ietf.jgss

      Subinterfaces of Cloneable in org.ietf.jgss
      Modifier and Type 接口 描述
      interface  GSSCredential
      该接口封装了实体的GSS-API凭据。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.Comparable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.Comparable

  • Packages that use Comparable
    软件包 描述
    com.sun.javadoc
    注意：该包中的声明已被包装 jdk.javadoc.doclet中的声明所取代。
    com.sun.jdi
    这是Java调试接口（JDI）的核心包，它定义了值，类型和目标VirtualMachine本身的镜像以及自举设备。
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    com.sun.nio.sctp
    用于流控制传输协议的Java API。
    com.sun.security.jgss
    com.sun.source.doctree
    提供用于将文档注释表示为抽象语法树（AST）的接口。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    com.sun.tools.jconsole
    此程序包包含JConsole API。
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.desktop
    提供与各种桌面功能交互的接口和类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.font
    提供与字体相关的类和界面。
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
    java.math
    提供用于执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.net
    提供实现网络应用程序的类。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.nio.charset
    定义字符集，解码器和编码器，用于在字节和Unicode字符之间进行转换。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.nio.file.attribute
    提供访问文件和文件系统属性的接口和类。
    java.security
    提供安全框架的类和接口。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.time
    日期，时间，瞬间和持续时间的主要API。
    java.time.chrono
    除默认ISO之外的日历系统的通用API。
    java.time.format
    提供打印和解析日期和时间的类。
    java.time.temporal
    使用字段和单位访问日期和时间，以及日期时间调整器。
    java.time.zone
    支持时区及其规则。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.animation
    提供一组类，便于使用基于过渡的动画。
    javafx.application
    提供应用程序生命周期类。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.css
    提供API，通过CSS使属性变得风格，并支持伪类状态。
    javafx.geometry
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.print
    提供JavaFX Printing API的公共类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.chart
    JavaFX用户界面提供了一组图表组件，这是一种非常方便的数据可视化方式。
    javafx.scene.control
    JavaFX用户界面控件（UI控件或仅控件）是JavaFX场景中的专用节点，特别适用于许多不同应用程序环境中的重用。
    javafx.scene.control.skin
    javafx.scene.control.skin包是皮肤类（通常每个UI控件一个）所在的位置
    javafx.scene.effect
    提供一组用于将图形过滤效果附加到JavaFX Scene Graph节点的类。
    javafx.scene.image
    提供加载和显示图像的一组类。
    javafx.scene.input
    提供一组用于鼠标和键盘输入事件处理的类。
    javafx.scene.layout
    提供类来支持用户界面布局。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javafx.scene.paint
    提供用于在渲染场景图时填充形状和背景的颜色和渐变类的集合。
    javafx.scene.shape
    提供一组2D类，用于定义和执行与二维几何相关的对象的操作。
    javafx.scene.text
    为字体和可渲染的文本节点提供一组类。
    javafx.scene.transform
    提供一组方便的类来对 Affine对象执行旋转，缩放，剪切和转换转换。
    javafx.scene.web
    该软件包提供了加载和显示Web内容的方法。
    javafx.stage
    提供JavaFX内容的顶级容器类。
    javafx.util
    包含各种实用程序和助手类。
    javax.annotation
    javax.imageio.metadata
    处理读写元数据的Java Image I / O API的一个包。
    javax.jws
    javax.jws.soap
    javax.lang.model
    用于建模Java编程语言的软件包的类和层次结构。
    javax.lang.model.element
    用于建模Java编程语言元素的接口。
    javax.lang.model.type
    用于建模Java编程语言类型的接口。
    javax.lang.model.util
    协助处理 program elements及 types的工具 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.naming
    提供用于访问命名服务的类和接口。
    javax.naming.ldap
    提供对LDAPv3扩展操作和控件的支持。
    javax.net.ssl
    为安全套接字包提供类。
    javax.smartcardio
    Java™智能卡I / O API
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.event
    提供Swing组件触发的事件。
    javax.swing.plaf.nimbus
    提供根据跨平台Nimbus外观构建的用户界面对象。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。
    javax.swing.text.html
    提供类 HTMLEditorKit和辅助类创建HTML文本编辑器。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.bind.annotation
    定义用于将Java程序元素定制到XML模式映射的注释。
    javax.xml.catalog
    提供实现 XML Catalogs OASIS Standard V1.1, 7 October 2005的类。
    javax.xml.ws
    此软件包包含核心JAX-WS API。
    javax.xml.ws.handler
    新新新新新旗新新旗新新旗新新新旗新新旗新新旗新新200新新旗新新200新新新新旗新新200新名：
    javax.xml.ws.soap
    该包定义了SOAP绑定专用的API。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API
    jdk.javadoc.doclet
    Doclet API提供了一个环境，结合语言模型API和编译器树API，客户端可以检查程序和库的源代码级结构，包括嵌入在源代码中的API注释。
    jdk.jshell
    提供用于创建工具的界面，例如阅读评估打印循环（REPL），它交互地评估Java编程语言代码的“片断”。
    jdk.nashorn.api.tree
    Nashorn解析器API提供了将ECMAScript源代码表示为抽象语法树（AST）和解析器来解析ECMAScript源脚本的接口。
    jdk.net
    适用于 java.net和 java.nio.channels套接字类的平台特定套接字选项。

    • Uses of Comparable in com.sun.javadoc

      Subinterfaces of Comparable in com.sun.javadoc
      Modifier and Type 接口 描述
      interface  AnnotationTypeDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  AnnotationTypeElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ClassDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ConstructorDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  Doc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ExecutableMemberDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  FieldDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MemberDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  MethodDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  PackageDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  ProgramElementDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  RootDoc
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      interface  SerialFieldTag
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。
      Classes in com.sun.javadoc that implement Comparable
      Modifier and Type Class 描述
      class  LanguageVersion
      已过时。
      该包装中的声明已被包装jdk.javadoc.doclet的声明所取代。 有关详细信息，请参阅该软件包的文档中的“ 迁移指南” 。

    • Uses of Comparable in com.sun.jdi

      Subinterfaces of Comparable in com.sun.jdi
      Modifier and Type 接口 描述
      interface  ArrayType
      提供对数组类的访问及其在目标虚拟机中的组件类型。
      interface  ByteValue
      提供对目标虚拟机中原始数据 byte访问权限。
      interface  CharValue
      提供对目标虚拟机 char语 char值的访问。
      interface  ClassType
      目标VM中的类的镜像。
      interface  DoubleValue
      提供对目标虚拟机中原始的 double值的访问。
      interface  Field
      目标VM中的类或实例变量。
      interface  FloatValue
      提供对目标虚拟机中基元 float值的访问。
      interface  IntegerValue
      提供对目标VM int语 int值的访问。
      interface  InterfaceType
      目标虚拟机中的接口的镜像。
      interface  LocalVariable
      目标VM中的局部变量。
      interface  Location
      目标VM的执行代码中的一个点。
      interface  LongValue
      提供对目标虚拟机中基元 long值的访问。
      interface  方法
      目标VM中的静态或实例方法。
      interface  ReferenceType
      目标虚拟机中对象的类型。
      interface  ShortValue
      提供对目标虚拟机 short语 short值的访问。

    • Uses of Comparable in com.sun.management

      Classes in com.sun.management that implement Comparable
      Modifier and Type Class 描述
      static class  VMOption.Origin
      VM选项的值的起源。

    • Uses of Comparable in com.sun.nio.sctp

      Classes in com.sun.nio.sctp that implement Comparable
      Modifier and Type Class 描述
      static class  AssociationChangeNotification.AssocChangeEvent
      定义关联发生的变更事件的类型。
      class  HandlerResult
      定义通知处理程序结果。
      static class  PeerAddressChangeNotification.AddressChangeEvent
      定义在多宿主对等体遇到更改接口详细信息时发生到目标地址的地址更改事件的类型。

    • Uses of Comparable in com.sun.security.jgss

      Classes in com.sun.security.jgss that implement Comparable
      Modifier and Type Class 描述
      class  InquireType
      可以指定为参数 ExtendedGSSContext.inquireSecContext(com.sun.security.jgss.InquireType)的属性类型

    • Uses of Comparable in com.sun.source.doctree

      Classes in com.sun.source.doctree that implement Comparable
      Modifier and Type Class 描述
      static class  AttributeTree.ValueKind
      属性值的种类。
      static class  DocTree.Kind
      列举各种树木。

    • Uses of Comparable in com.sun.source.tree

      Classes in com.sun.source.tree that implement Comparable
      Modifier and Type Class 描述
      static class  LambdaExpressionTree.BodyKind
      Lambda表达式有两种形式：表达式lambdas，其主体是表达式，语句lambdas，其主体是块
      static class  MemberReferenceTree.ReferenceMode
      有两种成员引用：（i）方法引用和（ii）构造函数引用
      static class  ModuleTree.ModuleKind
      模块的种类。
      static class  Tree.Kind
      列举各种树木。

    • Uses of Comparable in com.sun.source.util

      Classes in com.sun.source.util that implement Comparable
      Modifier and Type Class 描述
      static class  TaskEvent.Kind
      种类的任务事件。

    • Uses of Comparable in com.sun.tools.jconsole

      Classes in com.sun.tools.jconsole that implement Comparable
      Modifier and Type Class 描述
      static class  JConsoleContext.ConnectionState
      ConnectionState绑定属性的值。

    • Uses of Comparable in java.awt

      Classes in java.awt that implement Comparable
      Modifier and Type Class 描述
      static class  Component.BaselineResizeBehavior
      枚举组件的基准线随着大小变化而改变的常见方式。
      static class  Desktop.Action
      表示动作类型。
      static class  Dialog.ModalExclusionType
      任何顶级窗口都可以标记为不被模态对话框阻止。
      static class  Dialog.ModalityType
      模态对话框阻止某些顶级窗口的所有输入。
      static class  GraphicsDevice.WindowTranslucency
      底层系统支持的半透明度。
      static class  MultipleGradientPaint.ColorSpaceType
      执行渐变插值的颜色空间。
      static class  MultipleGradientPaint.CycleMethod
      绘画之外使用的方法边界渐变。
      static class  Taskbar.Feature
      提供功能列表
      static class  Taskbar.State
      可用窗口进度的种类状态。
      static class  TrayIcon.MessageType
      消息类型确定在消息的标题中将显示哪个图标，以及在显示时消息可能产生的可能的系统声音。
      static class  Window.Type
      枚举可用的 窗口类型 。

    • Uses of Comparable in java.awt.desktop

      Classes in java.awt.desktop that implement Comparable
      Modifier and Type Class 描述
      class  QuitStrategy
      如果未启用“突发终止”，则用于关闭应用程序的策略。
      static class  UserSessionEvent.Reason
      用户会话更改的可能原因的种类。

    • Uses of Comparable in java.awt.event

      Classes in java.awt.event that implement Comparable
      Modifier and Type Class 描述
      static class  FocusEvent.Cause
      这个枚举代表了一个 FocusEvent的原因 - 其发生的原因。

    • Uses of Comparable in java.awt.font

      Classes in java.awt.font that implement Comparable
      Modifier and Type Class 描述
      static class  NumericShaper.Range
      A NumericShaper.Range表示具有其自己的十进制数字的脚本的Unicode范围。

    • Uses of Comparable in java.io

      Classes in java.io that implement Comparable
      Modifier and Type Class 描述
      class  File
      文件和目录路径名的抽象表示。
      static class  ObjectInputFilter.Status
      对类的检查状态，数组长度，引用次数，深度和流大小。
      class  ObjectStreamField
      Serializable类的Serializable字段的描述。

    • Uses of Comparable in java.lang

      Subinterfaces of Comparable in java.lang
      Modifier and Type 接口 描述
      interface  ProcessHandle
      ProcessHandle识别并提供对本机进程的控制。
      Classes in java.lang that implement Comparable
      Modifier and Type Class 描述
      class  Boolean
      布尔类将对象中的基元类型 boolean的值进行包装。
      class  Byte
      Byte类包装一个对象中的原始类型为 byte的值。
      class  Character
      Character类包装一个对象中的原始类型 char的值。
      static class  Character.UnicodeScript
      一系列字符子集，表示 Unicode Standard Annex #24: Script Names中定义的字符脚本。
      class  Double
      Double类包装一个对象中的原始类型 double的值。
      class  Enum<E extends Enum<E>>
      这是所有Java语言枚举类型的公共基类。
      class  Float
      Float类在一个对象中包含了一个基本类型 float的值。
      class  Integer
      Integer类包装一个对象中的原始类型 int的值。
      class  Long
      Long类包装一个对象中的基元类型 long的值。
      static class  ProcessBuilder.Redirect.Type
      类型为ProcessBuilder.Redirect 。
      static class  Runtime.Version
      用于实现Java SE平台的版本字符串的表示。
      class  Short
      Short类包装一个对象中的原始类型为 short的值。
      static class  StackWalker.Option
      堆栈步行器选项配置stack frame获取的信息由一个StackWalker 。
      class  String
      String类代表字符串。
      static class  System.Logger.Level
      系统loggers级别。
      static class  Thread.State
      线程状态。

    • Uses of Comparable in java.lang.annotation

      Classes in java.lang.annotation that implement Comparable
      Modifier and Type Class 描述
      class  ElementType
      这个枚举类型的常量提供了在Java程序中可能出现注释的句法位置的简单分类。
      class  RetentionPolicy
      注释保留政策。

    • Uses of Comparable in java.lang.invoke

      Classes in java.lang.invoke that implement Comparable
      Modifier and Type Class 描述
      static class  VarHandle.AccessMode
      指定如何访问由VarHandle引用的变量的访问模式集。

    • Uses of Comparable in java.lang.management

      Classes in java.lang.management that implement Comparable
      Modifier and Type Class 描述
      class  MemoryType
      类型memory pools 。

    • Uses of Comparable in java.lang.module

      Classes in java.lang.module that implement Comparable
      Modifier and Type Class 描述
      class  ModuleDescriptor
      模块描述符。
      static class  ModuleDescriptor.Exports
      由模块导出的包可能有资格或不合格。
      static class  ModuleDescriptor.Exports.Modifier
      导出包上的修饰符。
      static class  ModuleDescriptor.Modifier
      模块上的修饰符。
      static class  ModuleDescriptor.Opens
      由模块打开的包可能有资格或不合格。
      static class  ModuleDescriptor.Opens.Modifier
      打开包装上的修饰符。
      static class  ModuleDescriptor.Provides
      模块提供一个或多个实现的服务。
      static class  ModuleDescriptor.Requires
      对模块的依赖
      static class  ModuleDescriptor.Requires.Modifier
      模块依赖的修饰符。
      static class  ModuleDescriptor.Version
      模块的版本字符串。

    • Uses of Comparable in java.math

      Classes in java.math that implement Comparable
      Modifier and Type Class 描述
      class  BigDecimal
      不变的，任意精度的带符号的十进制数字。
      class  BigInteger
      不可变的任意精度整数。
      class  RoundingMode
      指定能够丢弃精度的数值运算的 舍入行为 。

    • Uses of Comparable in java.net

      Classes in java.net that implement Comparable
      Modifier and Type Class 描述
      static class  Authenticator.RequestorType
      请求认证的实体的类型。
      static class  Proxy.Type
      代表代理类型。
      class  StandardProtocolFamily
      定义通信协议的标准系列。
      class  URI
      表示统一资源标识符（URI）参考。

    • Uses of Comparable in java.nio

      Classes in java.nio that implement Comparable
      Modifier and Type Class 描述
      class  ByteBuffer
      一个字节缓冲区。
      class  CharBuffer
      一个char缓冲区。
      class  DoubleBuffer
      双缓冲。
      class  FloatBuffer
      一个浮动缓冲区。
      class  IntBuffer
      一个int缓冲区
      class  LongBuffer
      一个长缓冲区。
      class  MappedByteBuffer
      直接字节缓冲器，其内容是文件的存储器映射区域。
      class  ShortBuffer
      一个短暂的缓冲。

    • Uses of Comparable in java.nio.charset

      Classes in java.nio.charset that implement Comparable
      Modifier and Type Class 描述
      class  Charset
      16位Unicode code units和字节序列之间的命名映射。

    • Uses of Comparable in java.nio.file

      Subinterfaces of Comparable in java.nio.file
      Modifier and Type 接口 描述
      interface  Path
      可用于在文件系统中定位文件的对象。
      Classes in java.nio.file that implement Comparable
      Modifier and Type Class 描述
      class  AccessMode
      定义用于测试文件可访问性的访问模式。
      class  FileVisitOption
      定义文件树遍历选项。
      class  FileVisitResult
      结果类型为FileVisitor 。
      class  LinkOption
      定义如何处理符号链接的选项。
      class  StandardCopyOption
      定义标准复制选项。
      class  StandardOpenOption
      定义标准的开放选项。

    • Uses of Comparable in java.nio.file.attribute

      Classes in java.nio.file.attribute that implement Comparable
      Modifier and Type Class 描述
      class  AclEntryFlag
      定义ACL entry的标志组件使用的标志。
      class  AclEntryPermission
      定义与ACL entry的权限组件一起使用的权限。
      class  AclEntryType
      访问控制条目类型的类型安全枚举。
      class  FileTime
      表示文件时间戳属性的值。
      class  PosixFilePermission
      定义与 permissions属性一起使用的位。

    • Uses of Comparable in java.security

      Classes in java.security that implement Comparable
      Modifier and Type Class 描述
      class  CryptoPrimitive
      加密原语的枚举。
      static class  DrbgParameters.Capability
      DRBG的可重新预测和预测抵抗能力。
      static class  KeyRep.Type
      钥匙类型

    • Uses of Comparable in java.security.cert

      Classes in java.security.cert that implement Comparable
      Modifier and Type Class 描述
      static class  CertPathValidatorException.BasicReason
      BasicReason列举了任何类型的认证路径可能无效的潜在原因。
      class  CRLReason
      CRLReason枚举指定了撤销证书的原因，如 RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile中所定义。
      class  PKIXReason
      PKIXReason列举了根据PKIX（RFC 5280）标准，X.509认证路径可能无效的潜在PKIX特定原因。
      static class  PKIXRevocationChecker.Option
      可以为吊销检查机制指定的各种撤销选项。

    • Uses of Comparable in java.sql

      Classes in java.sql that implement Comparable
      Modifier and Type Class 描述
      class  ClientInfoStatus
      通过拨打 Connection.setClientInfo无法设置属性的状态的枚举
      class  Date
      一个大约一毫秒值的薄包装，允许JDBC将其标识为SQL DATE值。
      class  JDBCType
      定义用于标识通用SQL类型（称为JDBC类型）的常量。
      class  PseudoColumnUsage
      伪/隐藏列使用枚举。
      class  RowIdLifetime
      RowId寿命值的枚举。
      class  Time
      围绕 java.util.Date类的薄包装，允许JDBC API将其标识为SQL TIME值。
      class  Timestamp
      一个围绕 java.util.Date的薄包装，允许JDBC API将其标识为SQL TIMESTAMP值。

    • Uses of Comparable in java.text

      Classes in java.text that implement Comparable
      Modifier and Type Class 描述
      class  CollationKey
      甲 CollationKey表示 String下一个特定的规则 Collator对象。
      static class  Normalizer.Form
      此枚举提供了 Unicode Standard Annex #15 — Unicode Normalization Forms中描述的四种Unicode归一化表单的常量，以及访问它们的两种方法。

    • Uses of Comparable in java.time

      Classes in java.time that implement Comparable
      Modifier and Type Class 描述
      class  DayOfWeek
      星期几，如“星期二”。
      class  Duration
      基于时间的时间量，如'34.5秒'。
      class  Instant
      在时间线上的瞬间点。
      class  LocalDate
      在ISO- 2007-12-03 ，如 2007-12-03 。
      class  LocalDateTime
      在ISO- 2007-12-03T10:15:30 ，如 2007-12-03T10:15:30 。
      class  LocalTime
      在ISO- 10:15:30 ，如 10:15:30 。
      class  Month
      一个月，如“七月”。
      class  MonthDay
      ISO- --12-03 ，如 --12-03 。
      class  OffsetDateTime
      在ISO- 2007-12-03T10:15:30+01:00 UTC /格林威治偏移的日期时间，如 2007-12-03T10:15:30+01:00 。
      class  OffsetTime
      在ISO- 10:15:30+01:00 UTC /格林威治的时间，如 10:15:30+01:00 。
      class  Year
      一年的ISO- 2007 ，如 2007 。
      class  YearMonth
      ISO- 2007-12 ，如 2007-12 。
      class  ZonedDateTime
      ISO- 2007-12-03T10:15:30+01:00 Europe/Paris ，如 2007-12-03T10:15:30+01:00 Europe/Paris 。
      class  ZoneOffset
      与格林威治/ UTC的时区偏移，如 +02:00 。

    • Uses of Comparable in java.time.chrono

      Subinterfaces of Comparable in java.time.chrono
      Modifier and Type 接口 描述
      interface  ChronoLocalDate
      一个无时间，无时间的日期，用于任意年龄，用于高级全球化用例。
      interface  ChronoLocalDateTime<D extends ChronoLocalDate>
      在任意年代没有时区的日期时间，用于高级全球化用例。
      interface  Chronology
      用于组织和识别日期的日历系统。
      interface  ChronoZonedDateTime<D extends ChronoLocalDate>
      具有时间序列的日期时间，以任意时间顺序排列，用于高级全球化用例。
      Classes in java.time.chrono that implement Comparable
      Modifier and Type Class 描述
      class  AbstractChronology
      用于组织和识别日期的日历系统的抽象实现。
      class  HijrahChronology
      Hijrah日历是支持伊斯兰教日历的农历。
      class  HijrahDate
      日期在Hijrah日历系统。
      class  HijrahEra
      Hijrah日历系统中的一个时代。
      class  IsoChronology
      ISO日历系统。
      class  IsoEra
      ISO日历系统中的一个时代。
      class  JapaneseChronology
      日本帝国历法系统。
      class  JapaneseDate
      在日本帝国日历系统的日期。
      class  MinguoChronology
      国际日历系统。
      class  MinguoDate
      在日语系统中的日期。
      class  MinguoEra
      国际日历系统中的一个时代。
      class  ThaiBuddhistChronology
      泰国佛教日历系统。
      class  ThaiBuddhistDate
      在泰国佛教日历系统的日期。
      class  ThaiBuddhistEra
      泰国佛教日历系统的时代。

    • Uses of Comparable in java.time.format

      Classes in java.time.format that implement Comparable
      Modifier and Type Class 描述
      class  FormatStyle
      枚举本地化日期，时间或日期时间格式化的风格。
      class  ResolverStyle
      列举不同的方式来解决日期和时间。
      class  SignStyle
      列举处理正/负号的方法。
      class  TextStyle
      枚举文本格式和解析的风格。

    • Uses of Comparable in java.time.temporal

      Classes in java.time.temporal that implement Comparable
      Modifier and Type Class 描述
      class  ChronoField
      一套标准的字段。
      class  ChronoUnit
      一组标准的日期单位。

    • Uses of Comparable in java.time.zone

      Classes in java.time.zone that implement Comparable
      Modifier and Type Class 描述
      class  ZoneOffsetTransition
      由本地时间线不连续性引起的两个偏移之间的转换。
      static class  ZoneOffsetTransitionRule.TimeDefinition
      本地时间可以转换为实际转换日期时间的方式的定义。

    • Uses of Comparable in java.util

      Classes in java.util that implement Comparable
      Modifier and Type Class 描述
      class  Calendar
      所述 Calendar类是一个抽象类，可以为在某一特定时刻和一组之间的转换的方法 calendar fields如 YEAR ， MONTH ， DAY_OF_MONTH ， HOUR ，等等，以及用于操纵该日历字段，如获取的日期下个星期。
      class  Date
      Date类代表了一个特定的时间，以毫秒的精度。
      static class  Formatter.BigDecimalLayoutForm
      枚举为 BigDecimal格式化。
      class  GregorianCalendar
      GregorianCalendar是的具体子 Calendar ，并提供了世界上大多数国家使用的标准日历系统。
      static class  Locale.Category
      枚举地区类别。
      static class  Locale.FilteringMode
      此枚举提供常量来选择区域设置匹配的过滤模式。
      static class  Locale.IsoCountryCode
      用于指定ISO 3166中定义的类型的枚举。
      class  UUID
      一个表示不可变的通用唯一标识符（UUID）的类。
      Methods in java.util with type parameters of type Comparable
      Modifier and Type 方法 描述
      static <T extends Comparable<? super T>>
      int             		Arrays.compare​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex)
      比较两个 Object阵列在指定范围内的字典。
      static <T extends Comparable<? super T>>
      int             		Arrays.compare​(T[] a, T[] b)
      比较两个 Object阵列，可比较的元素，按字典顺序。
      static <T,U extends Comparable<? super U>>
      Comparator<T>             		Comparator.comparing​(Function<? super T,? extends U> keyExtractor)
      接受从类型T中提取Comparable排序键的功能，并返回与该排序键进行比较的Comparator<T> 。
      static <K extends Comparable<? super K>,V>
      Comparator<Map.Entry<K,V>>             		Map.Entry.comparingByKey​()
      返回一个比较器， 按键的自然顺序比较Map.Entry 。
      static <K,V extends Comparable<? super V>>
      Comparator<Map.Entry<K,V>>             		Map.Entry.comparingByValue​()
      返回一个比较器，以自然顺序对值进行比较Map.Entry 。
      static <T extends Object & Comparable<? super T>>
      T             		Collections.max​(Collection<? extends T> coll)
      根据其元素的 自然顺序返回给定集合的最大元素。
      static <T extends Object & Comparable<? super T>>
      T             		Collections.min​(Collection<? extends T> coll)
      根据其元素的 自然顺序返回给定集合的最小元素。
      static <T extends Comparable<? super T>>
      Comparator<T>             		Comparator.naturalOrder​()
      返回一个以自然顺序比较Comparable个对象的比较器。
      static <T extends Comparable<? super T>>
      void             		Arrays.parallelSort​(T[] a)
      根据其元素的natural ordering按照升序排列指定的对象数组。
      static <T extends Comparable<? super T>>
      void             		Arrays.parallelSort​(T[] a, int fromIndex, int toIndex)
      根据其元素的natural ordering ，按照升序排列指定数组对象的指定范围。
      static <T extends Comparable<? super T>>
      Comparator<T>             		Comparator.reverseOrder​()
      返回一个与 自然排序相反的比较器。
      static <T extends Comparable<? super T>>
      void             		Collections.sort​(List<T> list)
      按照其要素的natural ordering对指定列表进行排序。
      default <U extends Comparable<? super U>>
      Comparator<T>             		Comparator.thenComparing​(Function<? super T,? extends U> keyExtractor)
      返回具有提取 Comparable排序键的功能的字典顺序比较器。
      Methods in java.util with parameters of type Comparable
      Modifier and Type 方法 描述
      static <T extends Comparable<? super T>>
      int             		Arrays.compare​(T[] a, int aFromIndex, int aToIndex, T[] b, int bFromIndex, int bToIndex)
      比较两个 Object阵列的字典顺序在指定范围内。
      static <T extends Comparable<? super T>>
      int             		Arrays.compare​(T[] a, T[] b)
      比较两个 Object阵列，可比较的元素，按字典顺序。
      static <T extends Comparable<? super T>>
      void             		Arrays.parallelSort​(T[] a)
      根据其元素的natural ordering ，按照升序排列指定的对象数组。
      static <T extends Comparable<? super T>>
      void             		Arrays.parallelSort​(T[] a, int fromIndex, int toIndex)
      根据其元素的natural ordering按照升序排列指定数组对象的指定范围。
      Method parameters in java.util with type arguments of type Comparable
      Modifier and Type 方法 描述
      static <T> int Collections.binarySearch​(List<? extends Comparable<? super T>> list, T key)
      使用二叉搜索算法搜索指定对象的指定列表。

    • Uses of Comparable in java.util.concurrent

      Subinterfaces of Comparable in java.util.concurrent
      Modifier and Type 接口 描述
      interface  Delayed
      一个混合样式界面，用于标记在给定延迟后应该执行的对象。
      interface  RunnableScheduledFuture<V>
      A ScheduledFuture那是Runnable 。
      interface  ScheduledFuture<V>
      可以取消延迟结果的行动。
      Classes in java.util.concurrent that implement Comparable
      Modifier and Type Class 描述
      class  TimeUnit
      A TimeUnit表示给定的粒度单位的持续时间，并提供了跨单元转换的实用方法，并在这些单元中执行定时和延迟操作。

    • Uses of Comparable in java.util.stream

      Classes in java.util.stream that implement Comparable
      Modifier and Type Class 描述
      static class  Collector.Characteristics
      指示 Collector属性的特性，可用于优化还原实现。

    • Uses of Comparable in javafx.animation

      Classes in javafx.animation that implement Comparable
      Modifier and Type Class 描述
      static class  Animation.Status
      可能状态为 status 。
      static class  PathTransition.OrientationType
      指定 node沿 path的直立方向。

    • Uses of Comparable in javafx.application

      Classes in javafx.application that implement Comparable
      Modifier and Type Class 描述
      class  ConditionalFeature
      定义一组条件（可选）功能。
      static class  Preloader.StateChangeNotification.Type
      枚举，定义与此通知相关联的更改类型

    • Uses of Comparable in javafx.collections

      Methods in javafx.collections with type parameters of type Comparable
      Modifier and Type 方法 描述
      static <T extends Comparable<? super T>>
      void             		FXCollections.sort​(ObservableList<T> list)
      对提供的可观察列表进行排序。

    • Uses of Comparable in javafx.concurrent

      Classes in javafx.concurrent that implement Comparable
      Modifier and Type Class 描述
      static class  Worker.State
      工人的状态。

    • Uses of Comparable in javafx.css

      Classes in javafx.css that implement Comparable
      Modifier and Type Class 描述
      class  Match
      由Rule用于确定选择器是否适用于给定的对象。
      class  SizeUnits
      表示特定单位中指定的大小，例如14px或0.2em。
      class  StyleOrigin
      枚举样式表和样式的可能来源或来源。

    • Uses of Comparable in javafx.geometry

      Classes in javafx.geometry that implement Comparable
      Modifier and Type Class 描述
      class  HorizontalDirection
      表示水平方向的枚举。
      class  HPos
      用于描述水平定位和对齐的一组值。
      class  NodeOrientation
      一组用于描述节点视觉数据流的值。
      class  Orientation
      方向
      class  Pos
      一组用于描述垂直和水平定位和对齐的值。
      class  Side
      枚举哪个方面应该是一个矩形。
      class  VerticalDirection
      表示垂直方向的枚举。
      class  VPos
      一组用于描述垂直定位和对齐的值。

    • Uses of Comparable in javafx.print

      Classes in javafx.print that implement Comparable
      Modifier and Type Class 描述
      class  Collation
      排序规则指定作业中打印文档的每个副本的介质页是否是顺序的。
      class  PageOrientation
      指定打印页面的介质页的方向。
      class  PrintColor
      描述打印是单色还是彩色的类。
      static class  Printer.MarginType
      MarginType用于确定PageLayout的可打印区域。
      static class  PrinterJob.JobStatus
      用于报告打印作业状态的枚举类。
      class  PrintQuality
      分类打印质量设置。
      class  PrintSides
      列举可能的双面（双面）打印模式的类。

    • Uses of Comparable in javafx.scene

      Classes in javafx.scene that implement Comparable
      Modifier and Type Class 描述
      class  AccessibleAction
      该枚举描述了屏幕阅读器等辅助技术可以从场景图中请求的动作。
      class  AccessibleAttribute
      该枚举描述了诸如屏幕阅读器之类的辅助技术可以从场景图中请求的属性。
      class  AccessibleRole
      这个枚举描述了一个Node的可访问角色。
      class  CacheHint
      缓存提示与 Node.cacheHint一起使用
      class  DepthTest
      该枚举定义了节点中depthTest标志的可能状态。

    • Uses of Comparable in javafx.scene.chart

      Classes in javafx.scene.chart that implement Comparable
      Modifier and Type Class 描述
      static class  LineChart.SortingPolicy
      此枚举定义了一个 LineChart.axisSortingPolicyProperty()的策略。

    • Uses of Comparable in javafx.scene.control

      Classes in javafx.scene.control that implement Comparable
      Modifier and Type Class 描述
      static class  Alert.AlertType
      包含Alert类可用于预先填充各种属性的可用的预构建警报类型的枚举 。
      static class  ButtonBar.ButtonData
      枚举所有可用的按钮数据注释。
      class  ContentDisplay
      将内容放置在标签内的位置。
      class  OverrunStyle
      当渲染文本的空间小于渲染整个字符串所需的空间时，定义标记的控件的行为。
      static class  ScrollPane.ScrollBarPolicy
      表示可滚动控件在决定是否显示滚动条时使用的策略的枚举。
      class  SelectionMode
      用于指定可以在MultipleSelectionModel中选择多少项目的枚举 。
      static class  TableColumn.SortType
      枚举，指定应用于特定列的排序类型。
      static class  TabPane.TabClosingPolicy
      这指定了TabPane如何处理从最终用户角度看待标签关闭。
      class  TreeSortMode
      指定如何对树状UI控件中的树项进行排序。
      static class  TreeTableColumn.SortType
      枚举，指定应用于特定列的排序类型。

    • Uses of Comparable in javafx.scene.control.skin

      Classes in javafx.scene.control.skin that implement Comparable
      Modifier and Type Class 描述
      static class  TextInputControlSkin.Direction
      方向名称用于插入符号移动。
      static class  TextInputControlSkin.TextUnit
      照相机运动的单位名称。

    • Uses of Comparable in javafx.scene.effect

      Classes in javafx.scene.effect that implement Comparable
      Modifier and Type Class 描述
      class  BlendMode
      混合模式定义混合效果的输入合成在一起的方式，或者如何将节点混合到场景的背景中。
      class  BlurType
      表示用于软化 Shadow效果的模糊算法的类型。

    • Uses of Comparable in javafx.scene.image

      Classes in javafx.scene.image that implement Comparable
      Modifier and Type Class 描述
      static class  PixelFormat.Type
      一个枚举，描述由PixelFormat管理的单个像素的阵列存储格式。

    • Uses of Comparable in javafx.scene.input

      Classes in javafx.scene.input that implement Comparable
      Modifier and Type Class 描述
      class  InputMethodHighlight
      包含输入法文本的枚举突出显示。
      class  KeyCode
      KeyEvent对象的关键码集。
      static class  KeyCombination.ModifierValue
      ModifierValue指定修饰键的状态。
      class  MouseButton
      按钮名称映射
      static class  ScrollEvent.HorizontalTextScrollUnits
      水平文本滚动单元。
      static class  ScrollEvent.VerticalTextScrollUnits
      垂直的基于文本的滚动单元。
      static class  TouchPoint.State
      表示触摸点的当前状态
      class  TransferMode
      描述了相对于拖放手势的数据传输模式。

    • Uses of Comparable in javafx.scene.layout

      Classes in javafx.scene.layout that implement Comparable
      Modifier and Type Class 描述
      class  BackgroundRepeat
      枚举在背景中重复图像的选项
      class  BorderRepeat
      枚举指示边框图像的重复规则。
      class  Priority
      用于确定给定节点的布局区域在其区域具有更多（或更少）空间可用并且多个节点竞争该空间时的增长（或收缩）优先级的枚举。

    • Uses of Comparable in javafx.scene.media

      Classes in javafx.scene.media that implement Comparable
      Modifier and Type Class 描述
      static class  MediaException.Type
      描述错误类别的枚举。
      static class  MediaPlayer.Status
      枚举描述不同状态值的一个MediaPlayer 。

    • Uses of Comparable in javafx.scene.paint

      Classes in javafx.scene.paint that implement Comparable
      Modifier and Type Class 描述
      class  CycleMethod
      该枚举定义了以下方法梯度边界之外绘制时使用的一个： CycleMethod.NO_CYCLE ， CycleMethod.REFLECT ，或 CycleMethod.REPEAT 。

    • Uses of Comparable in javafx.scene.shape

      Classes in javafx.scene.shape that implement Comparable
      Modifier and Type Class 描述
      class  ArcType
      ArcType指定Arc对象的关闭类型。
      class  CullFace
      面部剔除设置与 Shape3D.cullFace一起使用
      class  DrawMode
      定义与 Shape3D.drawMode使用时如何绘制多边形
      class  FillRule
      用于确定路径内部的填充规则。
      class  StrokeLineCap
      定义 Shape的端帽样式。
      class  StrokeLineJoin
      定义一个 Shape的线连接样式。
      class  StrokeType
      定义在Shape节点的边界周围画画的位置。

    • Uses of Comparable in javafx.scene.text

      Classes in javafx.scene.text that implement Comparable
      Modifier and Type Class 描述
      class  FontPosture
      指定字体是否为斜体
      class  FontSmoothingType
      FontSmoothingType枚举用于指定用于平滑屏幕文本字体边缘的首选机制。
      class  FontWeight
      指定在系统上搜索字体时可以使用的不同字体权重。
      class  TextAlignment
      TextAlignment枚举表示水平文本对齐。
      class  TextBoundsType
      指定由 Text节点报告的边界的行为。

    • Uses of Comparable in javafx.scene.transform

      Classes in javafx.scene.transform that implement Comparable
      Modifier and Type Class 描述
      class  MatrixType
      指定转换矩阵的类型。

    • Uses of Comparable in javafx.scene.web

      Classes in javafx.scene.web that implement Comparable
      Modifier and Type Class 描述
      static class  HTMLEditorSkin.Command
      表示可以传递到HTMLEditor Web引擎的命令。

    • Uses of Comparable in javafx.stage

      Classes in javafx.stage that implement Comparable
      Modifier and Type Class 描述
      class  Modality
      此枚举定义了一个 Stage的可能的模式类型。
      static class  PopupWindow.AnchorLocation
      锚定点选择的锚位置常数。
      class  StageStyle
      此枚举定义了一个 Stage的可能样式。

    • Uses of Comparable in javafx.util

      Classes in javafx.util that implement Comparable
      Modifier and Type Class 描述
      class  Duration
      定义持续时间的类。

    • Uses of Comparable in javax.annotation

      Classes in javax.annotation that implement Comparable
      Modifier and Type Class 描述
      static class  Resource.AuthenticationType
      资源的两种可能的认证类型。

    • Uses of Comparable in javax.imageio.metadata

      Methods in javax.imageio.metadata with type parameters of type Comparable
      Modifier and Type 方法 描述
      protected <T extends Object & Comparable<? super T>>
      void             		IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
      允许给定类类型的一个 Object引用存储在实现命名元素的节点中。
      Methods in javax.imageio.metadata that return Comparable
      Modifier and Type | 方法 | 描述
      Comparable<?> IIOMetadataFormat.getObjectMaxValue​(String elementName)
      返回指定元素中的 Object引用的最大合法值。
      Comparable<?> | IIOMetadataFormatImpl.getObjectMaxValue​(String elementName)
      Comparable<?> IIOMetadataFormat.getObjectMinValue​(String elementName)
      返回命名元素中的 Object引用的最小合法值。
      Comparable<?> | IIOMetadataFormatImpl.getObjectMinValue​(String elementName)
      Methods in javax.imageio.metadata with parameters of type Comparable
      Modifier and Type 方法 描述
      protected <T extends Object & Comparable<? super T>>
      void             		IIOMetadataFormatImpl.addObjectValue​(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
      允许给定类类型的一个 Object引用存储在实现命名元素的节点中。

    • Uses of Comparable in javax.jws

      Classes in javax.jws that implement Comparable
      Modifier and Type | Class | 描述
      static class  | WebParam.Mode

    • Uses of Comparable in javax.jws.soap

      Classes in javax.jws.soap that implement Comparable
      Modifier and Type | Class | 描述
      static class  | SOAPBinding.ParameterStyle
      static class  | SOAPBinding.Style
      static class  | SOAPBinding.Use

    • Uses of Comparable in javax.lang.model

      Classes in javax.lang.model that implement Comparable
      Modifier and Type Class 描述
      class  SourceVersion
      源代码版本的Java编程语言。

    • Uses of Comparable in javax.lang.model.element

      Classes in javax.lang.model.element that implement Comparable
      Modifier and Type Class 描述
      class  ElementKind
      一个元素的 kind 。
      class  Modifier
      表示程序元素（如类，方法或字段）上的修饰符。
      static class  ModuleElement.DirectiveKind
      一个指令的 kind 。
      class  NestingKind
      一种类型元素的 嵌套类型。

    • Uses of Comparable in javax.lang.model.type

      Classes in javax.lang.model.type that implement Comparable
      Modifier and Type Class 描述
      class  TypeKind
      一种类型的镜子。

    • Uses of Comparable in javax.lang.model.util

      Classes in javax.lang.model.util that implement Comparable
      Modifier and Type Class 描述
      static class  Elements.Origin
      元素或其他语言模型项目的 起源 。

    • Uses of Comparable in javax.management

      Classes in javax.management that implement Comparable
      Modifier and Type Class 描述
      class  ObjectName
      表示MBean的对象名称，或可匹配多个MBean名称的模式。

    • Uses of Comparable in javax.management.openmbean

      Methods in javax.management.openmbean that return Comparable
      Modifier and Type 方法 描述
      Comparable<?> OpenMBeanAttributeInfoSupport.getMaxValue​()
      返回此 OpenMBeanAttributeInfoSupport实例描述的属性的最大值（如果指定），否则 null 。
      Comparable<?> OpenMBeanParameterInfo.getMaxValue​()
      返回此参数的最大值，如果它有一个，否则 null 。
      Comparable<?> OpenMBeanParameterInfoSupport.getMaxValue​()
      返回此 OpenMBeanParameterInfoSupport实例描述的参数的最大值（如果指定），否则 null 。
      Comparable<?> OpenMBeanAttributeInfoSupport.getMinValue​()
      返回此 OpenMBeanAttributeInfoSupport实例描述的属性的 OpenMBeanAttributeInfoSupport （如果指定），否则 null 。
      Comparable<?> OpenMBeanParameterInfo.getMinValue​()
      返回此参数的最小值（如果为1），否则 null 。
      Comparable<?> OpenMBeanParameterInfoSupport.getMinValue​()
      返回此 OpenMBeanParameterInfoSupport实例描述的参数的 OpenMBeanParameterInfoSupport （如果指定），否则 null 。
      Constructors in javax.management.openmbean with parameters of type Comparable
      Constructor 描述
      OpenMBeanAttributeInfoSupport​(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      构造一个 OpenMBeanAttributeInfoSupport实例，该实例描述了一种开放MBean的属性，与指定 name ， openType ， description ， defaultValue ， minValue和 maxValue 。
      OpenMBeanParameterInfoSupport​(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      构造一个 OpenMBeanParameterInfoSupport实例，该实例描述了在一个或多个操作或open MBean类的构造函数中使用的参数，具有指定 name ， openType ， description ， defaultValue ， minValue和 maxValue 。

    • Uses of Comparable in javax.naming

      Subinterfaces of Comparable in javax.naming
      Modifier and Type 接口 描述
      interface  Name
      Name接口表示通用名称 - 组件的有序序列。
      Classes in javax.naming that implement Comparable
      Modifier and Type Class 描述
      class  CompositeName
      此类表示组合名称 - 跨多个命名空间的组件名称序列。
      class  CompoundName
      该类表示复合名称 - 来自分层名称空间的名称。

    • Uses of Comparable in javax.naming.ldap

      Classes in javax.naming.ldap that implement Comparable
      Modifier and Type Class 描述
      class  LdapName
      此类表示由 RFC 2253指定的专有名称。
      class  Rdn
      此类表示相对可分辨名称，或RDN，它是由 RFC 2253指定的专有名称的组成部分。

    • Uses of Comparable in javax.net.ssl

      Classes in javax.net.ssl that implement Comparable
      Modifier and Type Class 描述
      static class  SSLEngineResult.HandshakeStatus
      一个 SSLEngineResult枚举描述了这个 SSLEngine的当前握手状态。
      static class  SSLEngineResult.Status
      一个 SSLEngineResult枚举描述了 SSLEngine操作的总体结果。

    • Uses of Comparable in javax.smartcardio

      Classes in javax.smartcardio that implement Comparable
      Modifier and Type Class 描述
      static class  CardTerminals.State
      枚举CardTerminal的属性。

    • Uses of Comparable in javax.swing

      Classes in javax.swing that implement Comparable
      Modifier and Type Class 描述
      class  DropMode
      拖放模式，用于确定组件在拖放过程中跟踪并指示放置位置的方法。
      static class  GroupLayout.Alignment
      枚举可能的方式 ParallelGroup可以对 ParallelGroup 。
      static class  JTable.PrintMode
      打印模式，用于打印 JTable s。
      static class  LayoutStyle.ComponentPlacement
      ComponentPlacement是可以相对于彼此放置两个组件的可能方式的列举。
      static class  RowFilter.ComparisonType
      枚举一些默认的 RowFilter s支持的可能比较值。
      class  SortOrder
      SortOrder是可能的排序顺序的枚举。
      static class  SwingWorker.StateValue
      state绑定属性的值。
      Methods in javax.swing that return Comparable
      Modifier and Type 方法 描述
      Comparable<Date> SpinnerDateModel.getEnd​()
      返回序列中的最后一个 Date 。
      Comparable<?> SpinnerNumberModel.getMaximum​()
      返回序列中的最后一个数字。
      Comparable<?> SpinnerNumberModel.getMinimum​()
      返回此序列中的第一个数字。
      Comparable<Date> SpinnerDateModel.getStart​()
      返回序列中的第一个 Date 。
      Methods in javax.swing with parameters of type Comparable
      Modifier and Type 方法 描述
      void SpinnerDateModel.setEnd​(Comparable<Date> end)
      按此顺序更改 Date的上限。
      void SpinnerNumberModel.setMaximum​(Comparable<?> maximum)
      更改此序列中数字的上限。
      void SpinnerNumberModel.setMinimum​(Comparable<?> minimum)
      更改此序列中数字的下限。
      void SpinnerDateModel.setStart​(Comparable<Date> start)
      更改此顺序中日期的下限。
      Constructors in javax.swing with parameters of type Comparable
      Constructor 描述
      SpinnerDateModel​(Date value, Comparable<Date> start, Comparable<Date> end, int calendarField)
      创建一个 SpinnerDateModel ，表示 start和 end之间的日期序列。
      SpinnerNumberModel​(Number value, Comparable<?> minimum, Comparable<?> maximum, Number stepSize)
      构造一个 SpinnerModel ，表示从 minimum到 maximum一个封闭序列。

    • Uses of Comparable in javax.swing.event

      Classes in javax.swing.event that implement Comparable
      Modifier and Type Class 描述
      static class  RowSorterEvent.Type
      枚举类型 RowSorterEvent s。

    • Uses of Comparable in javax.swing.plaf.nimbus

      Classes in javax.swing.plaf.nimbus that implement Comparable
      Modifier and Type Class 描述
      protected static class  AbstractRegionPainter.PaintContext.CacheMode
      缓存模式。

    • Uses of Comparable in javax.swing.text

      Methods in javax.swing.text that return Comparable
      Modifier and Type 方法 描述
      Comparable<?> InternationalFormatter.getMaximum​()
      返回最大允许值。
      Comparable<?> InternationalFormatter.getMinimum​()
      返回最小允许值。
      Methods in javax.swing.text with parameters of type Comparable
      Modifier and Type 方法 描述
      void InternationalFormatter.setMaximum​(Comparable<?> max)
      设置最大允许值。
      void InternationalFormatter.setMinimum​(Comparable<?> minimum)
      设置最小允许值。

    • Uses of Comparable in javax.swing.text.html

      Classes in javax.swing.text.html that implement Comparable
      Modifier and Type Class 描述
      static class  FormSubmitEvent.MethodType
      表示HTML表单方法类型。

    • Uses of Comparable in javax.tools

      Classes in javax.tools that implement Comparable
      Modifier and Type Class 描述
      static class  Diagnostic.Kind
      诊断的种类，例如错误或警告。
      static class  DocumentationTool.Location
      特定于DocumentationTool的地点。
      static class  JavaFileObject.Kind
      种类的JavaFileObjects。
      class  StandardLocation
      文件对象的标准位置。

    • Uses of Comparable in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation that implement Comparable
      Modifier and Type Class 描述
      class  XmlAccessOrder
      由XmlAccessorOrder用于控制JAXB绑定类中的属性和字段的排序。
      class  XmlAccessType
      由XmlAccessorType用于控制字段或属性的序列化。
      class  XmlNsForm
      枚举XML Schema命名空间资格。

    • Uses of Comparable in javax.xml.catalog

      Classes in javax.xml.catalog that implement Comparable
      Modifier and Type Class 描述
      static class  CatalogFeatures.Feature
      Catalog Features table中定义的要素类型。

    • Uses of Comparable in javax.xml.ws

      Classes in javax.xml.ws that implement Comparable
      Modifier and Type Class 描述
      static class  Service.Mode
      动态客户端或服务的方向。

    • Uses of Comparable in javax.xml.ws.handler

      Classes in javax.xml.ws.handler that implement Comparable
      Modifier and Type Class 描述
      static class  MessageContext.Scope
      财产范围

    • Uses of Comparable in javax.xml.ws.soap

      Classes in javax.xml.ws.soap that implement Comparable
      Modifier and Type Class 描述
      static class  AddressingFeature.Responses
      如果启用寻址，则此属性确定端点是否仅需要使用匿名响应，或仅使用非匿名响应或全部。

    • Uses of Comparable in javax.xml.xpath

      Classes in javax.xml.xpath that implement Comparable
      Modifier and Type Class 描述
      static class  XPathEvaluationResult.XPathResultType
      XPathResultType表示XPath评估的可能的返回类型。

    • Uses of Comparable in jdk.dynalink

      Classes in jdk.dynalink that implement Comparable
      Modifier and Type Class 描述
      class  StandardNamespace
      Dynalink定义的标准命名空间的枚举。
      class  StandardOperation
      定义标准动态操作。

    • Uses of Comparable in jdk.dynalink.linker

      Classes in jdk.dynalink.linker that implement Comparable
      Modifier and Type Class 描述
      static class  ConversionComparator.Comparison
      列举将一个转换与另一个转换进行比较的可能结果。

    • Uses of Comparable in jdk.incubator.http

      Classes in jdk.incubator.http that implement Comparable
      Modifier and Type Class 描述
      static class  HttpClient.Redirect
      定义自动重定向策略。
      static class  HttpClient.Version
      HTTP协议版本。
      static class  WebSocket.MessagePart
      WebSocket.Listener在可能收到部分消息的情况下使用的标记。

    • Uses of Comparable in jdk.javadoc.doclet

      Classes in jdk.javadoc.doclet that implement Comparable
      Modifier and Type | Class | 描述
      static class  Doclet.Option.Kind
      这种选择。
      static class  | DocletEnvironment.ModuleMode
      static class  Taglet.Location
      可以使用标签的位置。

    • Uses of Comparable in jdk.jshell

      Classes in jdk.jshell that implement Comparable
      Modifier and Type Class 描述
      static class  Snippet.Kind
      描述一般的片段。
      static class  Snippet.Status
      描述代码段的当前状态。
      static class  Snippet.SubKind
      一个片段的详细种类。
      static class  SourceCodeAnalysis.Completeness
      描述给定输入的完整性。

    • Uses of Comparable in jdk.nashorn.api.tree

      Classes in jdk.nashorn.api.tree that implement Comparable
      Modifier and Type Class 描述
      static class  Diagnostic.Kind
      诊断的种类，例如错误或警告。
      static class  Tree.Kind
      列举各种树木。

    • Uses of Comparable in jdk.net

      Classes in jdk.net that implement Comparable
      Modifier and Type Class 描述
      static class  SocketFlow.Status
      从SO_FLOW_SLA套接字选项枚举返回值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.Iterable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.Iterable

  • Packages that use Iterable
    软件包 描述
    com.sun.jdi.event
    该包定义了JDI事件和事件处理。
    com.sun.source.tree
    提供用于将源代码表示为抽象语法树（AST）的接口。
    com.sun.source.util
    为抽象语法树（AST）的操作提供实用程序。
    java.beans.beancontext
    提供与bean上下文相关的类和接口。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.nio.file
    定义Java虚拟机访问文件，文件属性和文件系统的接口和类。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    javafx.beans.binding
    提供在Binding上创建和操作的类， 该类计算取决于一个或多个来源的值。
    javafx.beans.property
    程序包 javafx.beans.property定义只读属性和可写属性，以及一些实现。
    javafx.beans.value
    包javafx.beans.value包含两个基本接口ObservableValue和WritableValue及其所有子接口。
    javafx.collections
    包含基本的JavaFX集合和集合实用程序
    javafx.collections.transformation
    提供包装和转换（例如，排序或过滤）其他JavaFX集合的JavaFX集合。
    javax.annotation.processing
    用于声明注释处理器和允许注释处理器与注释处理工具环境通信的设施。
    javax.lang.model.util
    协助处理 program elements及 types的公用事业 。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.relation
    提供关系服务的定义。
    javax.print.attribute.standard
    包javax.print.attribute.standard包含特定打印属性的类。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.sql.rowset.spi
    第三方供应商在实施同步提供程序时必须使用的标准类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.tools
    为可以从程序调用的工具提供接口，例如编译器。
    javax.xml.crypto
    XML加密的通用类。
    javax.xml.xpath
    提供用于评估XPath表达式和访问评估环境的 对象模型中性 API。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.incubator.http
    高级HTTP和WebSocket API

    • Uses of Iterable in com.sun.jdi.event

      Subinterfaces of Iterable in com.sun.jdi.event
      Modifier and Type 接口 描述
      interface  EventSet
      可以在给定时间由目标VirtualMachine创建几个Event对象。

    • Uses of Iterable in com.sun.source.tree

      Methods in com.sun.source.tree that return Iterable
      Modifier and Type 方法 描述
      Iterable<? extends Element> Scope.getLocalElements​()
      返回此范围中直接包含的元素。

    • Uses of Iterable in com.sun.source.util

      Classes in com.sun.source.util that implement Iterable
      Modifier and Type Class 描述
      class  DocTreePath
      树节点的路径，通常用于表示直到顶层DocCommentTree节点的树节点的祖先节点序列。
      class  TreePath
      树节点的路径，通常用于表示树节点的祖先节点的序列，直到顶层的CompilationUnitTree节点。
      Methods in com.sun.source.util that return Iterable
      Modifier and Type 方法 描述
      abstract Iterable<? extends Element> JavacTask.analyze​()
      完成所有分析。
      abstract Iterable<? extends JavaFileObject> JavacTask.generate​()
      生成代码。
      abstract Iterable<? extends CompilationUnitTree> JavacTask.parse​()
      解析指定的文件，返回抽象语法树列表。
      Methods in com.sun.source.util with parameters of type Iterable
      Modifier and Type 方法 描述
      abstract TypeMirror JavacTask.getTypeMirror​(Iterable<? extends 树> path)
      返回由指定路径确定的树节点的类型镜像。
      R DocTreeScanner.scan​(Iterable<? extends DocTree> nodes, P p)
      扫描一系列节点。
      R TreeScanner.scan​(Iterable<? extends 树> nodes, P p)
      扫描一系列节点。
      R SimpleDocTreeVisitor.visit​(Iterable<? extends DocTree> nodes, P p)
      在每个节点序列上调用适当的访问方法。
      R SimpleTreeVisitor.visit​(Iterable<? extends 树> nodes, P p)
      在每个节点序列上调用适当的访问方法。

    • Uses of Iterable in java.beans.beancontext

      Subinterfaces of Iterable in java.beans.beancontext
      Modifier and Type 接口 描述
      interface  BeanContext
      BeanContext对JavaBeans起着逻辑分层容器的作用。
      interface  BeanContextServices
      BeanContextServices接口提供了一个机制，让BeanContext将通用的“服务”公开给它的BeanContextChild对象。
      Classes in java.beans.beancontext that implement Iterable
      Modifier and Type Class 描述
      class  BeanContextServicesSupport
      这个助手类提供java.beans.beancontext.BeanContextServices接口的实用程序实现。
      class  BeanContextSupport
      这个帮助类提供java.beans.beancontext.BeanContext接口的实用程序实现。

    • Uses of Iterable in java.lang

      Methods in java.lang with parameters of type Iterable
      Modifier and Type 方法 描述
      static String String.join​(CharSequence delimiter, Iterable<? extends CharSequence> elements)
      返回一个新 String的副本组成 CharSequence elements与指定的副本一起加入 delimiter 。

    • Uses of Iterable in java.nio.file

      Subinterfaces of Iterable in java.nio.file
      Modifier and Type 接口 描述
      interface  DirectoryStream<T>
      一个对象来迭代目录中的条目。
      interface  Path
      可用于在文件系统中定位文件的对象。
      interface  SecureDirectoryStream<T>
      A DirectoryStream ，它定义了相对于打开目录定位的文件的操作。
      Methods in java.nio.file that return Iterable
      Modifier and Type 方法 描述
      abstract Iterable<FileStore> FileSystem.getFileStores​()
      返回一个对象，以遍历底层文件存储。
      abstract Iterable<Path> FileSystem.getRootDirectories​()
      返回一个对象来遍历根目录的路径。
      Methods in java.nio.file with parameters of type Iterable
      Modifier and Type 方法 描述
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, Charset cs, OpenOption... options)
      将文本行写入文件。
      static Path Files.write​(Path path, Iterable<? extends CharSequence> lines, OpenOption... options)
      将文本行写入文件。

    • Uses of Iterable in java.sql

      Classes in java.sql that implement Iterable
      Modifier and Type Class 描述
      class  BatchUpdateException
      在批量更新操作期间发生错误时，抛出SQLException的子类。
      class  DataTruncation
      由于 DataTruncation异常超出 MaxFieldSize原因而导致数据值意外截断时，异常抛出 DataTruncation异常（写入）或报告为 DataTruncation警告（读取时）。
      class  SQLClientInfoException
      当一个或多个客户端信息属性无法在Connection上设置时，抛出SQLException的子类。
      class  SQLDataException
      当SQLState类值为“ 22 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLException
      提供有关数据库访问错误或其他错误的信息的异常。
      class  SQLFeatureNotSupportedException
      当SQLState类值为' 0A '（值为'零'A）时，抛出SQLException的子类。
      class  SQLIntegrityConstraintViolationException
      当SQLState类值为“ 23 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLInvalidAuthorizationSpecException
      当SQLState类值为“ 28 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLNonTransientConnectionException
      抛出SQLState类值为“ 08 ”的SQLException子类，或在供应商指定的条件下。
      class  SQLNonTransientException
      SQLException的子类在抛出相同操作的重试失败的实例时抛出，除非修正了原因SQLException 。
      class  SQLRecoverableException
      如果应用程序执行某些恢复步骤并重试整个事务，或者在分布式事务（即事务分支）的情况下，先前失败的操作可能能够成功的情况下抛出SQLException的子类。
      class  SQLSyntaxErrorException
      当SQLState类值为“ 42 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTimeoutException
      的子类SQLException时指定的超时抛出Statement.setQueryTimeout ， DriverManager.setLoginTimeout ， DataSource.setLoginTimeout ， XADataSource.setLoginTimeout已过期。
      class  SQLTransactionRollbackException
      当SQLState类值为“ 40 ”时，或在供应商指定的条件下，抛出SQLException的子类。
      class  SQLTransientConnectionException
      SQLState类值为“ 08 ”的SQLException的子类，或供应商指定的条件。
      class  SQLTransientException
      SQLException的子类在以前失败的操作可能能够在没有应用程序级功能的任何干预的情况下重试操作时能够成功的情况下抛出。
      class  SQLWarning
      提供有关数据库访问警告的信息的异常。

    • Uses of Iterable in java.util

      Subinterfaces of Iterable in java.util
      Modifier and Type 接口 描述
      interface  Collection<E>
      集合层次结构中的根界面。
      interface  Deque<E>
      支持两端元素插入和移除的线性集合。
      interface  List<E>
      有序集合（也称为 序列 ）。
      interface  NavigableSet<E>
      A SortedSet扩展了导航方法，报告给定搜索目标的最匹配。
      interface  Queue<E>
      设计用于在处理之前保留元素的集合。
      interface  Set<E>
      不包含重复元素的集合。
      interface  SortedSet<E>
      A Set进一步提供了其元素的总排序 。
      Classes in java.util that implement Iterable
      Modifier and Type Class 描述
      class  AbstractCollection<E>
      该类提供了 Collection接口的骨架实现，以最大限度地减少实现此接口所需的工作量。
      class  AbstractList<E>
      该类提供了List接口的骨架实现，以最小化实现由“随机访问”数据存储（例如阵列）支持的此接口所需的工作量。
      class  AbstractQueue<E>
      这个类提供了一些Queue操作的骨架实现。
      class  AbstractSequentialList<E>
      此类提供了 List接口的骨架实现，以最大限度地减少实施由“顺序访问”数据存储（如链接列表）支持的此接口所需的工作量。
      class  AbstractSet<E>
      该类提供了 Set接口的骨架实现，以尽量减少实现此接口所需的工作量。
      class  ArrayDeque<E>
      Deque接口的可调整大小的数组实现。
      class  ArrayList<E>
      List接口的可调整大小的数组实现。
      class  EnumSet<E extends Enum<E>>
      专门用于枚举类型的Set实现。
      class  HashSet<E>
      该类实现 Set接口，由哈希表（实际为 HashMap实例）支持。
      class  LinkedHashSet<E>
      哈希表和链表实现的 Set接口，具有可预测的迭代顺序。
      class  LinkedList<E>
      双链表实现了 List和 Deque接口。
      class  PriorityQueue<E>
      基于优先级堆的无限优先级queue 。
      class  ServiceLoader<S>
      一种加载服务实现的工具。
      class  Stack<E>
      Stack类代表一个最先进先出（LIFO）堆栈的对象。
      class  TreeSet<E>
      一个NavigableSet实现基于一个TreeMap 。
      class  Vector<E>
      Vector类实现了可扩展的对象数组。

    • Uses of Iterable in java.util.concurrent

      Subinterfaces of Iterable in java.util.concurrent
      Modifier and Type 接口 描述
      interface  BlockingDeque<E>
      A Deque另外支持在检索元素时等待deque变为非空的阻塞操作，并且在存储元素时等待空格在deque中可用。
      interface  BlockingQueue<E>
      A Queue另外支持在检索元素时等待队列变为非空的操作，并在存储元素时等待队列中的空间变得可用。
      interface  TransferQueue<E>
      A BlockingQueue ，其中生产者可能等待消费者接收元素。
      Classes in java.util.concurrent that implement Iterable
      Modifier and Type Class 描述
      class  ArrayBlockingQueue<E>
      有限的blocking queue由数组支持。
      static class  ConcurrentHashMap.KeySetView<K,V>
      ConcurrentHashMap视图为Set的密钥，其中可以通过映射到公共值来选择添加。
      class  ConcurrentLinkedDeque<E>
      基于链接节点的无界并发deque 。
      class  ConcurrentLinkedQueue<E>
      基于链接节点的无界线程安全queue 。
      class  ConcurrentSkipListSet<E>
      可扩展的并行NavigableSet实现基于一个ConcurrentSkipListMap 。
      class  CopyOnWriteArrayList<E>
      的一个线程安全的变体ArrayList ，其中所有可变操作（ add ， set ，等等）通过对底层数组的最新副本实现。
      class  CopyOnWriteArraySet<E>
      A Set 对其所有操作使用内部CopyOnWriteArrayList 。
      class  DelayQueue<E extends Delayed>
      一个无限的blocking queue的Delayed元素，其中元素只能在其延迟到期时才被采用。
      class  LinkedBlockingDeque<E>
      基于链接节点的可选限定的blocking deque 。
      class  LinkedBlockingQueue<E>
      基于链接节点的可选限定的blocking queue 。
      class  LinkedTransferQueue<E>
      基于链接节点的无界TransferQueue 。
      class  PriorityBlockingQueue<E>
      无限blocking queue使用与类别PriorityQueue相同的排序规则，并提供阻止检索操作。
      class  SynchronousQueue<E>
      A blocking queue其中每个插入操作必须等待另一个线程的相应删除操作，反之亦然。

    • Uses of Iterable in javafx.beans.binding

      Classes in javafx.beans.binding that implement Iterable
      Modifier and Type Class 描述
      class  ListBinding<E>
      提供实现ObservableList的Binding所需的大部分功能的基类。
      class  ListExpression<E>
      ListExpression是一个ObservableListValue加上额外的便利方法，以流利的风格生成绑定。
      class  SetBinding<E>
      提供实现ObservableSet的Binding所需的大部分功能的基类。
      class  SetExpression<E>
      SetExpression是一个ObservableSetValue加上额外的便利方法，以流利的风格生成绑定。

    • Uses of Iterable in javafx.beans.property

      Classes in javafx.beans.property that implement Iterable
      Modifier and Type Class 描述
      class  ListProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableList 。
      class  ListPropertyBase<E>
      ListPropertyBase类是包装ObservableList的属性的基类。
      class  ReadOnlyListProperty<E>
      超类为所有只读属性包装一个ObservableList 。
      class  ReadOnlyListPropertyBase<E>
      所有只读属性的基类包装一个ObservableList 。
      class  ReadOnlyListWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  ReadOnlySetProperty<E>
      超类为所有只读属性包装一个ObservableSet 。
      class  ReadOnlySetPropertyBase<E>
      所有只读属性的基类包装一个ObservableSet 。
      class  ReadOnlySetWrapper<E>
      该类提供了一个方便的类来定义只读属性。
      class  SetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。
      class  SetPropertyBase<E>
      SetPropertyBase类是包装一个ObservableSet的属性的基类。
      class  SimpleListProperty<E>
      这个类提供了一个Property包装一个ObservableList的完整实现。
      class  SimpleSetProperty<E>
      这个类提供了一个Property的全面实现，包装了一个ObservableSet 。

    • Uses of Iterable in javafx.beans.value

      Subinterfaces of Iterable in javafx.beans.value
      Modifier and Type 接口 描述
      interface  ObservableListValue<E>
      可以参考一个ObservableList 。
      interface  ObservableSetValue<E>
      一个可观察的参考ObservableSet 。
      interface  WritableListValue<E>
      一个可写参考的ObservableList 。
      interface  WritableSetValue<E>
      对ObservableSet的可写参考。

    • Uses of Iterable in javafx.collections

      Subinterfaces of Iterable in javafx.collections
      Modifier and Type 接口 描述
      interface  ObservableList<E>
      允许侦听器发生变化的列表。
      interface  ObservableSet<E>
      一组允许观察者跟踪变化发生时的变化。
      Classes in javafx.collections that implement Iterable
      Modifier and Type Class 描述
      class  ModifiableObservableListBase<E>
      抽象类作为可修改的ObservableList实现的基类。
      class  ObservableListBase<E>
      抽象类作为ObservableList实现的基类。

    • Uses of Iterable in javafx.collections.transformation

      Classes in javafx.collections.transformation that implement Iterable
      Modifier and Type Class 描述
      class  FilteredList<E>
      包装一个ObservableList并使用提供的谓词过滤其内容。
      class  SortedList<E>
      包装一个ObservableList并对其内容进行排序。
      class  TransformationList<E,F>
      所有列表的基类，用于以更改（转换）包装的列表的元素，顺序，大小或结构的方式包装另一个列表。

    • Uses of Iterable in javax.annotation.processing

      Methods in javax.annotation.processing that return Iterable
      Modifier and Type 方法 描述
      Iterable<? extends Completion> AbstractProcessor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回一个空的可迭代的完成。
      Iterable<? extends Completion> Processor.getCompletions​(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
      返回到工具基础结构，可以对注释的建议完成进行迭代。

    • Uses of Iterable in javax.lang.model.util

      Methods in javax.lang.model.util with parameters of type Iterable
      Modifier and Type 方法 描述
      static List<ExecutableElement> ElementFilter.constructorsIn​(Iterable<? extends Element> elements)
      返回 elements中的构造函数列表。
      static List<ModuleElement.ExportsDirective> ElementFilter.exportsIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 exports指令的列表。
      static List<VariableElement> ElementFilter.fieldsIn​(Iterable<? extends Element> elements)
      返回 elements中的字段列表。
      static List<ExecutableElement> ElementFilter.methodsIn​(Iterable<? extends Element> elements)
      返回 elements中的方法列表。
      static List<ModuleElement> ElementFilter.modulesIn​(Iterable<? extends Element> elements)
      返回 elements中的模块列表。
      static List<ModuleElement.OpensDirective> ElementFilter.opensIn​(Iterable<? extends ModuleElement.Directive> directives)
      返回列表 opens的指令 directives 。
      static List<PackageElement> ElementFilter.packagesIn​(Iterable<? extends Element> elements)
      返回 elements中的软件包列表。
      static List<ModuleElement.ProvidesDirective> ElementFilter.providesIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 provides指令的列表。
      static List<ModuleElement.RequiresDirective> ElementFilter.requiresIn​(Iterable<? extends ModuleElement.Directive> directives)
      返回列表 requires的指令 directives 。
      R ElementScanner6.scan​(Iterable<? extends Element> iterable, P p)
      迭代给定元素并调用每个元素 scan(Element, P) 。
      static List<TypeElement> ElementFilter.typesIn​(Iterable<? extends Element> elements)
      返回 elements中的类型列表。
      static List<ModuleElement.UsesDirective> ElementFilter.usesIn​(Iterable<? extends ModuleElement.Directive> directives)
      在 directives返回 uses指令的列表。

    • Uses of Iterable in javax.management

      Classes in javax.management that implement Iterable
      Modifier and Type Class 描述
      class  AttributeList
      表示MBean属性值的列表。

    • Uses of Iterable in javax.management.relation

      Classes in javax.management.relation that implement Iterable
      Modifier and Type Class 描述
      class  RoleList
      RoleList表示角色列表（Role对象）。
      class  RoleUnresolvedList
      RoleUnresolvedList表示RoleUnresolved对象的列表，表示由于在尝试访问（读取或写入）角色时遇到问题，不会从关系中检索到角色。

    • Uses of Iterable in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement Iterable
      Modifier and Type Class 描述
      class  JobStateReasons
      JobStateReasons类是一个打印属性类，一组枚举值，它提供有关作业当前状态的附加信息，即增加作业JobState属性值的信息。

    • Uses of Iterable in javax.sql.rowset

      Classes in javax.sql.rowset that implement Iterable
      Modifier and Type Class 描述
      class  RowSetWarning
      扩展名为 SQLException ，其中提供了有关在 RowSet对象上设置的数据库警告的信息。

    • Uses of Iterable in javax.sql.rowset.serial

      Classes in javax.sql.rowset.serial that implement Iterable
      Modifier and Type Class 描述
      class  SerialException
      指示和错误的序列化或 BLOB, CLOB, STRUCT or ARRAY序列化的SQL类型，如 BLOB, CLOB, STRUCT or ARRAY除了SQL类型，如 DATALINK and JAVAOBJECT

    • Uses of Iterable in javax.sql.rowset.spi

      Classes in javax.sql.rowset.spi that implement Iterable
      Modifier and Type Class 描述
      class  SyncFactoryException
      表示出现错误 SyncFactory机制。
      class  SyncProviderException
      表示 SyncProvider机制出现错误。

    • Uses of Iterable in javax.swing

      Methods in javax.swing with parameters of type Iterable
      Modifier and Type 方法 描述
      static <M,I> RowFilter<M,I> RowFilter.andFilter​(Iterable<? extends RowFilter<? super M,? super I>> filters)
      如果所有提供的过滤器都包含该条目，则返回一个包含条目的 RowFilter 。
      static <M,I> RowFilter<M,I> RowFilter.orFilter​(Iterable<? extends RowFilter<? super M,? super I>> filters)
      返回一个 RowFilter ，如果任何提供的过滤器包含条目，则包含条目。

    • Uses of Iterable in javax.tools

      Methods in javax.tools that return Iterable
      Modifier and Type | 方法 | 描述
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects​(File... files)
      返回表示给定文件的文件对象。
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects​(String... names)
      返回表示给定文件名的文件对象。
      default Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects​(Path... paths)
      返回表示给定路径的文件对象。
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromFiles​(Iterable<? extends File> files)
      返回表示给定文件的文件对象。
      default Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromPaths​(Iterable<? extends Path> paths)
      返回表示给定路径的文件对象。
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromStrings​(Iterable<String> names)
      返回表示给定文件名的文件对象。
      Iterable<? extends File> StandardJavaFileManager.getLocation​(JavaFileManager.Location location)
      返回与给定位置相关联的搜索路径。
      default Iterable<? extends Path> StandardJavaFileManager.getLocationAsPaths​(JavaFileManager.Location location)
      返回与给定位置相关联的搜索路径。
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Iterable<JavaFileObject> JavaFileManager.list​(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      列出与给定的面向对象位置匹配的所有文件对象。
      Iterable<Set<JavaFileManager.Location>> | ForwardingJavaFileManager.listLocationsForModules​(JavaFileManager.Location location)
      default Iterable<Set<JavaFileManager.Location>> JavaFileManager.listLocationsForModules​(JavaFileManager.Location location)
      列出面向模块的位置或输出位置中所有模块的位置。
      Methods in javax.tools with parameters of type Iterable
      Modifier and Type 方法 描述
      void DocumentationTool.DocumentationTask.addModules​(Iterable<String> moduleNames)
      在模块解析期间添加要考虑的根模块。
      void JavaCompiler.CompilationTask.addModules​(Iterable<String> moduleNames)
      在模块解析期间添加要考虑的根模块。
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromFiles​(Iterable<? extends File> files)
      返回表示给定文件的文件对象。
      default Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromPaths​(Iterable<? extends Path> paths)
      返回表示给定路径的文件对象。
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromStrings​(Iterable<String> names)
      返回表示给定文件名的文件对象。
      DocumentationTool.DocumentationTask DocumentationTool.getTask​(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      使用给定的组件和参数为文档任务创建未来。
      JavaCompiler.CompilationTask JavaCompiler.getTask​(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      使用给定的组件和参数创建编译任务的未来。
      void StandardJavaFileManager.setLocation​(JavaFileManager.Location location, Iterable<? extends File> files)
      将给定的搜索路径与给定位置相关联。
      void JavaCompiler.CompilationTask.setProcessors​(Iterable<? extends Processor> processors)
      设置处理器（用于注释处理）。

    • Uses of Iterable in javax.xml.crypto

      Subinterfaces of Iterable in javax.xml.crypto
      Modifier and Type 接口 描述
      interface  NodeSetData<T>
      包含节点集的 Data类型的抽象表示。

    • Uses of Iterable in javax.xml.xpath

      Subinterfaces of Iterable in javax.xml.xpath
      Modifier and Type 接口 描述
      interface  XPathNodes
      XPathNodes表示由 XML Path Language (XPath) Version 1.0, 3.3 Node-sets中指定的位置路径选择的一组节点。

    • Uses of Iterable in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support with parameters of type Iterable
      Modifier and Type 方法 描述
      static List<GuardingDynamicLinker> CompositeTypeBasedGuardingDynamicLinker.optimize​(Iterable<? extends GuardingDynamicLinker> linkers)
      优化基于类型的链接器的列表。
      Constructors in jdk.dynalink.linker.support with parameters of type Iterable
      Constructor 描述
      CompositeGuardingDynamicLinker​(Iterable<? extends GuardingDynamicLinker> linkers)
      创建一个新的复合链接器。
      CompositeTypeBasedGuardingDynamicLinker​(Iterable<? extends TypeBasedGuardingDynamicLinker> linkers)
      创建一个新的基于复合类型的链接器。

    • Uses of Iterable in jdk.incubator.http

      Methods in jdk.incubator.http with parameters of type Iterable
      Modifier and Type 方法 描述
      static HttpRequest.BodyProcessor HttpRequest.BodyProcessor.fromByteArrays​(Iterable<byte[]> iter)
      一个从 Iterable字节数组获取数据的请求体处理器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.ProcessHandle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.ProcessHandle

  • Packages that use ProcessHandle
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ProcessHandle in java.lang

      Methods in java.lang that return ProcessHandle
      Modifier and Type 方法 描述
      static ProcessHandle ProcessHandle.current​()
      返回当前进程的ProcessHandle。
      ProcessHandle Process.toHandle​()
      返回进程的ProcessHandle。
      Methods in java.lang that return types with arguments of type ProcessHandle
      Modifier and Type 方法 描述
      static Stream<ProcessHandle> ProcessHandle.allProcesses​()
      返回当前进程可见的所有进程的快照。
      Stream<ProcessHandle> Process.children​()
      返回进程的直接子节点的快照。
      Stream<ProcessHandle> ProcessHandle.children​()
      返回进程当前直接子节点的快照。
      Stream<ProcessHandle> Process.descendants​()
      返回进程后代的快照。
      Stream<ProcessHandle> ProcessHandle.descendants​()
      返回进程后代的快照。
      static Optional<ProcessHandle> ProcessHandle.of​(long pid)
      返回现有本机进程的 Optional<ProcessHandle> 。
      CompletableFuture<ProcessHandle> ProcessHandle.onExit​()
      返回一个 CompletableFuture<ProcessHandle>用于终止进程。
      Optional<ProcessHandle> ProcessHandle.parent​()
      返回父进程的 Optional<ProcessHandle> 。
      Methods in java.lang with parameters of type ProcessHandle
      Modifier and Type 方法 描述
      int ProcessHandle.compareTo​(ProcessHandle other)
      将此ProcessHandle与指定的ProcessHandle进行比较。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.ProcessHandle.Info (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.ProcessHandle.Info

  • Packages that use ProcessHandle.Info
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of ProcessHandle.Info in java.lang

      Methods in java.lang that return ProcessHandle.Info
      Modifier and Type 方法 描述
      ProcessHandle.Info Process.info​()
      返回有关进程信息的快照。
      ProcessHandle.Info ProcessHandle.info​()
      返回有关进程信息的快照。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.Readable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.Readable

  • Packages that use Readable
    软件包 描述
    java.io
    通过数据流，序列化和文件系统提供系统输入和输出。
    java.nio
    定义缓冲区，它们是数据容器，并提供其他NIO包的概述。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    jdk.nashorn.api.scripting
    这个包提供了 javax.script集成，这是使用Nashorn的首选方式。

    • Uses of Readable in java.io

      Classes in java.io that implement Readable
      Modifier and Type Class 描述
      class  BufferedReader
      从字符输入流读取文本，缓冲字符，以提供字符，数组和行的高效读取。
      class  CharArrayReader
      该类实现了一个字符缓冲区，可以用作字符输入流。
      class  FileReader
      阅读字符文件的便利课。
      class  FilterReader
      用于读取过滤后的字符流的抽象类。
      class  InputStreamReader
      InputStreamReader是从字节流到字符流的桥梁：它读取字节，并使用指定的charset将其解码为字符。
      class  LineNumberReader
      缓冲字符输入流，跟踪行号。
      class  PipedReader
      流水字符输入流。
      class  PushbackReader
      一个字符流读取器，允许将字符推回到流中。
      class  Reader
      用于读取字符流的抽象类。
      class  StringReader
      一个字符流，其源是一个字符串。

    • Uses of Readable in java.nio

      Classes in java.nio that implement Readable
      Modifier and Type Class 描述
      class  CharBuffer
      一个char缓冲区。

    • Uses of Readable in java.util

      Constructors in java.util with parameters of type Readable
      Constructor 描述
      Scanner​(Readable source)
      构造一个新的 Scanner ，产生从指定源扫描的值。

    • Uses of Readable in jdk.nashorn.api.scripting

      Classes in jdk.nashorn.api.scripting that implement Readable
      Modifier and Type Class 描述
      class  URLReader
      从URL读取的读者。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.Runnable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.Runnable

  • Packages that use Runnable
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.awt.event
    提供用于处理AWT组件触发的不同类型事件的接口和类。
    java.awt.image.renderable
    提供用于生成与渲染无关的图像的类和接口。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    java.util.concurrent
    实用程序类通常用于并发编程。
    java.util.logging
    提供Java¢2平台核心日志记录工具的类和接口。
    java.util.stream
    支持元素流功能性操作的类，例如集合上的map-reduce转换。
    javafx.application
    提供应用程序生命周期类。
    javafx.concurrent
    提供javafx.task的一组类。
    javafx.scene
    为JavaFX Scene Graph API提供核心的基类集。
    javafx.scene.media
    提供用于将音频和视频集成到Java FX应用程序中的一组类。
    javax.net.ssl
    为安全套接字包提供类。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.swing.text
    提供处理可编辑和不可编辑文本组件的类和接口。

    • Uses of Runnable in java.awt

      Methods in java.awt with parameters of type Runnable
      Modifier and Type 方法 描述
      static void EventQueue.invokeAndWait​(Runnable runnable)
      导致 runnable要求其 run方法在 dispatch thread的 the system EventQueue中调用 。
      static void EventQueue.invokeLater​(Runnable runnable)
      原因 runnable要求其 run方法在 dispatch thread中被调用 the system EventQueue 。

    • Uses of Runnable in java.awt.event

      Fields in java.awt.event declared as Runnable
      Modifier and Type Field 描述
      protected Runnable InvocationEvent.runnable
      Runnable的run（）方法将被调用。
      Constructors in java.awt.event with parameters of type Runnable
      Constructor 描述
      InvocationEvent​(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables)
      构造一个 InvocationEvent具有指定源和ID将执行可运行的 run时调度方法。
      InvocationEvent​(Object source, Runnable runnable)
      构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。
      InvocationEvent​(Object source, Runnable runnable, Object notifier, boolean catchThrowables)
      构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。
      InvocationEvent​(Object source, Runnable runnable, Runnable listener, boolean catchThrowables)
      构造一个 InvocationEvent与将执行可运行的指定的源 run时调度方法。

    • Uses of Runnable in java.awt.image.renderable

      Classes in java.awt.image.renderable that implement Runnable
      Modifier and Type Class 描述
      class  RenderableImageProducer
      一个实现ImageProducer以允许异步生成RenderableImage的适配器类。

    • Uses of Runnable in java.lang

      Classes in java.lang that implement Runnable
      Modifier and Type Class 描述
      class  Thread
      线程是程序中执行的线程。
      Constructors in java.lang with parameters of type Runnable
      Constructor 描述
      Thread​(Runnable target)
      分配一个新的 Thread对象。
      Thread​(Runnable target, String name)
      分配一个新的 Thread对象。
      Thread​(ThreadGroup group, Runnable target)
      分配一个新的 Thread对象。
      Thread​(ThreadGroup group, Runnable target, String name)
      分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于由 group引用的线程组。
      Thread​(ThreadGroup group, Runnable target, String name, long stackSize)
      分配一个新的 Thread对象，使其具有 target作为其运行对象，具有指定的 name作为其名称，属于 group引用的线程组，并具有指定的 堆栈大小 。
      Thread​(ThreadGroup group, Runnable target, String name, long stackSize, boolean inheritThreadLocals)
      分配一个新的Thread对象，使其具有target作为其运行对象，具有指定的name作为其名称，属于由group引用的线程组，具有指定的stackSize ，并且如果inheritThreadLocals为true ，则继承inheritable thread-local变量的初始值。

    • Uses of Runnable in java.lang.ref

      Methods in java.lang.ref with parameters of type Runnable
      Modifier and Type 方法 描述
      Cleaner.Cleanable Cleaner.register​(Object obj, Runnable action)
      注册一个对象和一个清理动作，以便在对象变为幻像时可以运行。

    • Uses of Runnable in java.util

      Classes in java.util that implement Runnable
      Modifier and Type Class 描述
      class  TimerTask
      可以通过Timer进行一次性或重复执行的任务 。
      Methods in java.util with parameters of type Runnable
      Modifier and Type 方法 描述
      void Optional.ifPresentOrElse​(Consumer<? super T> action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      void OptionalDouble.ifPresentOrElse​(DoubleConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      void OptionalInt.ifPresentOrElse​(IntConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。
      void OptionalLong.ifPresentOrElse​(LongConsumer action, Runnable emptyAction)
      如果存在值，则使用该值执行给定的操作，否则执行给定的基于空的操作。

    • Uses of Runnable in java.util.concurrent

      Subinterfaces of Runnable in java.util.concurrent
      Modifier and Type 接口 描述
      interface  RunnableFuture<V>
      A Future那是Runnable 。
      interface  RunnableScheduledFuture<V>
      A ScheduledFuture那是Runnable 。
      Classes in java.util.concurrent that implement Runnable
      Modifier and Type Class 描述
      class  ForkJoinWorkerThread
      一个由ForkJoinPool管理的线程，执行ForkJoinTask s。
      class  FutureTask<V>
      可取消的异步计算。
      Methods in java.util.concurrent that return types with arguments of type Runnable
      Modifier and Type 方法 描述
      BlockingQueue<Runnable> ScheduledThreadPoolExecutor.getQueue​()
      返回此执行程序使用的任务队列。
      BlockingQueue<Runnable> ThreadPoolExecutor.getQueue​()
      返回此执行程序使用的任务队列。
      List<Runnable> ExecutorService.shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      List<Runnable> ForkJoinPool.shutdownNow​()
      可能尝试取消和/或停止所有任务，并拒绝所有后续提交的任务。
      List<Runnable> ScheduledThreadPoolExecutor.shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      List<Runnable> ThreadPoolExecutor.shutdownNow​()
      尝试停止所有主动执行的任务，停止等待任务的处理，并返回正在等待执行的任务列表。
      Methods in java.util.concurrent with parameters of type Runnable
      Modifier and Type | 方法 | 描述
      static ForkJoinTask<?> ForkJoinTask.adapt​(Runnable runnable)
      返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其操作的 run方法，并在 ForkJoinTask.join()返回一个空结果。
      static <T> ForkJoinTask<T> ForkJoinTask.adapt​(Runnable runnable, T result)
      返回一个新的 ForkJoinTask ，它执行给定的 Runnable作为其操作的 run方法，并将给定的结果返回到 ForkJoinTask.join() 。
      protected void ThreadPoolExecutor.afterExecute​(Runnable r, Throwable t)
      完成指定Runnable的执行后调用方法。
      protected void ThreadPoolExecutor.beforeExecute​(Thread t, Runnable r)
      在给定的线程中执行给定的Runnable之前调用方法。
      static Callable<Object> Executors.callable​(Runnable task)
      返回一个Callable对象，当被调用时，它运行给定的任务并返回null 。
      static <T> Callable<T> Executors.callable​(Runnable task, T result)
      返回一个Callable对象，当被调用时，它运行给定的任务并返回给定的结果。
      protected <V> RunnableScheduledFuture<V> ScheduledThreadPoolExecutor.decorateTask​(Runnable runnable, RunnableScheduledFuture<V> task)
      修改或替换用于执行runnable的任务。
      void Executor.execute​(Runnable command)
      在将来的某个时间执行给定的命令。
      void | ForkJoinPool.execute​(Runnable task)
      void ScheduledThreadPoolExecutor.execute​(Runnable command)
      执行 command零要求延迟。
      void ThreadPoolExecutor.execute​(Runnable command)
      在将来某个时候执行给定的任务。
      protected <T> RunnableFuture<T> AbstractExecutorService.newTaskFor​(Runnable runnable, T value)
      对于给定的可运行和默认值，返回一个 RunnableFuture 。
      protected <T> RunnableFuture<T> | ForkJoinPool.newTaskFor​(Runnable runnable, T value)
      Thread ThreadFactory.newThread​(Runnable r)
      构造新的 Thread 。
      void RejectedExecutionHandler.rejectedExecution​(Runnable r, ThreadPoolExecutor executor)
      ThreadPoolExecutor当execute无法接受任务时可能调用的方法。
      void ThreadPoolExecutor.AbortPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      总是抛出RejectedExecutionException。
      void ThreadPoolExecutor.CallerRunsPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      执行调用者线程中的任务r，除非执行程序已经被关闭，否则任务被丢弃。
      void ThreadPoolExecutor.DiscardOldestPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      获取并忽略执行者否则将执行的下一个任务，如果一个可以立即可用，然后重试任务r的执行，除非执行程序关闭，否则任务r被替换为丢弃。
      void ThreadPoolExecutor.DiscardPolicy.rejectedExecution​(Runnable r, ThreadPoolExecutor e)
      什么也没有，具有丢弃任务r的效果。
      boolean ThreadPoolExecutor.remove​(Runnable task)
      如果此任务存在，则从执行程序的内部队列中删除此任务，从而导致该任务尚未运行。
      CompletableFuture<Void> | CompletableFuture.runAfterBoth​(CompletionStage<?> other, Runnable action)
      CompletionStage<Void> CompletionStage.runAfterBoth​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个和另一个给定阶段都正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterBothAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个和另一个给定的阶段都正常完成时，使用提供的执行器执行给定的动作。
      CompletableFuture<Void> | CompletableFuture.runAfterEither​(CompletionStage<?> other, Runnable action)
      CompletionStage<Void> CompletionStage.runAfterEither​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，执行给定的操作。
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      CompletableFuture<Void> | CompletableFuture.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.runAfterEitherAsync​(CompletionStage<?> other, Runnable action, Executor executor)
      返回一个新的CompletionStage，当这个或另一个给定阶段正常完成时，使用提供的执行器执行给定的操作。
      static CompletableFuture<Void> CompletableFuture.runAsync​(Runnable runnable)
      返回一个新的CompletableFuture，它在运行给定操作后由运行在 ForkJoinPool.commonPool()中的任务异步完成。
      static CompletableFuture<Void> CompletableFuture.runAsync​(Runnable runnable, Executor executor)
      返回一个新的CompletableFuture，它在运行给定操作之后由在给定执行程序中运行的任务异步完成。
      ScheduledFuture<?> ScheduledExecutorService.schedule​(Runnable command, long delay, TimeUnit unit)
      创建并执行在给定延迟后启用的单次操作。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.schedule​(Runnable command, long delay, TimeUnit unit)
      ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      创建并执行在给定的初始延迟之后，随后以给定的时间段首先启用的周期性动作; 也就是说，执行将在initialDelay之后开始，然后是initialDelay + period ，然后是initialDelay + 2 * period ，等等。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.scheduleAtFixedRate​(Runnable command, long initialDelay, long period, TimeUnit unit)
      ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
      创建并执行在给定的初始延迟之后首先启用的定期动作，随后在一个执行的终止和下一个执行的开始之间给定的延迟。
      ScheduledFuture<?> | ScheduledThreadPoolExecutor.scheduleWithFixedDelay​(Runnable command, long initialDelay, long delay, TimeUnit unit)
      Future<?> | AbstractExecutorService.submit​(Runnable task)
      <T> Future<T> | AbstractExecutorService.submit​(Runnable task, T result)
      Future<V> CompletionService.submit​(Runnable task, V result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      Future<V> | ExecutorCompletionService.submit​(Runnable task, V result)
      Future<?> ExecutorService.submit​(Runnable task)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      <T> Future<T> ExecutorService.submit​(Runnable task, T result)
      提交一个可运行的任务执行，并返回一个表示该任务的未来。
      ForkJoinTask<?> | ForkJoinPool.submit​(Runnable task)
      <T> ForkJoinTask<T> | ForkJoinPool.submit​(Runnable task, T result)
      Future<?> | ScheduledThreadPoolExecutor.submit​(Runnable task)
      <T> Future<T> | ScheduledThreadPoolExecutor.submit​(Runnable task, T result)
      CompletableFuture<Void> | CompletableFuture.thenRun​(Runnable action)
      CompletionStage<Void> CompletionStage.thenRun​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，执行给定的操作。
      CompletableFuture<Void> | CompletableFuture.thenRunAsync​(Runnable action)
      CompletableFuture<Void> | CompletableFuture.thenRunAsync​(Runnable action, Executor executor)
      CompletionStage<Void> CompletionStage.thenRunAsync​(Runnable action)
      返回一个新的CompletionStage，当此阶段正常完成时，使用此阶段的默认异步执行工具执行给定的操作。
      CompletionStage<Void> CompletionStage.thenRunAsync​(Runnable action, Executor executor)
      返回一个新的CompletionStage，当此阶段正常完成时，使用提供的执行程序执行给定的操作。
      Constructors in java.util.concurrent with parameters of type Runnable
      Constructor 描述
      CyclicBarrier​(int parties, Runnable barrierAction)
      创建一个新的 CyclicBarrier ，当给定数量的线程（线程）等待时，它将跳闸，当屏障跳闸时执行给定的屏障动作，由最后一个线程进入屏障执行。
      FutureTask​(Runnable runnable, V result)
      创建一个 FutureTask ，将在运行时执行给定的 Runnable ，并安排 get将在成功完成后返回给定的结果。
      Constructor parameters in java.util.concurrent with type arguments of type Runnable
      Constructor 描述
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂和拒绝的执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认线程工厂。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
      创建一个新的 ThreadPoolExecutor与给定的初始参数和默认拒绝执行处理程序。
      ThreadPoolExecutor​(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
      使用给定的初始参数创建一个新的 ThreadPoolExecutor 。

    • Uses of Runnable in java.util.logging

      Methods in java.util.logging with parameters of type Runnable
      Modifier and Type 方法 描述
      LogManager LogManager.addConfigurationListener​(Runnable listener)
      添加每次读取日志配置时调用的配置监听器。
      void LogManager.removeConfigurationListener​(Runnable listener)
      删除以前注册的配置监听器。

    • Uses of Runnable in java.util.stream

      Methods in java.util.stream with parameters of type Runnable
      Modifier and Type 方法 描述
      S BaseStream.onClose​(Runnable closeHandler)
      返回带有附加关闭处理程序的等效流。

    • Uses of Runnable in javafx.application

      Methods in javafx.application with parameters of type Runnable
      Modifier and Type 方法 描述
      static void Platform.runLater​(Runnable runnable)
      在将来某些未指定的时间运行JavaFX应用程序线程上指定的Runnable。
      static void Platform.startup​(Runnable runnable)
      此方法启动JavaFX运行时。

    • Uses of Runnable in javafx.concurrent

      Classes in javafx.concurrent that implement Runnable
      Modifier and Type Class 描述
      class  Task<V>
      一个完全可观察到的一个FutureTask的实现。

    • Uses of Runnable in javafx.scene

      Methods in javafx.scene that return types with arguments of type Runnable
      Modifier and Type 方法 描述
      ObservableMap<KeyCombination,Runnable> Scene.getAccelerators​()
      获取此 Scene的加速器列表。
      Methods in javafx.scene with parameters of type Runnable
      Modifier and Type 方法 描述
      void Scene.addPostLayoutPulseListener​(Runnable r)
      在这个场景中添加一个新的场景布局脉冲侦听器。
      void Scene.addPreLayoutPulseListener​(Runnable r)
      在这个场景中添加一个新的场景预布置脉冲监听器。
      void Scene.removePostLayoutPulseListener​(Runnable r)
      从这个场景中的脉冲中删除先前注册的场景布局脉冲侦听器。
      void Scene.removePreLayoutPulseListener​(Runnable r)
      从此场景中的脉冲中删除先前注册的场景预布置脉冲侦听器。

    • Uses of Runnable in javafx.scene.media

      Methods in javafx.scene.media that return Runnable
      Modifier and Type 方法 描述
      Runnable MediaPlayer.getOnEndOfMedia​()
      检索媒体事件处理程序的结束。
      Runnable Media.getOnError​()
      如果发生错误，则检索要调用的错误处理程序。
      Runnable MediaPlayer.getOnError​()
      检索错误的事件处理程序。
      Runnable MediaPlayer.getOnHalted​()
      检索 MediaPlayer.Status.HALTED事件处理程序。
      Runnable MediaPlayer.getOnPaused​()
      检索 MediaPlayer.Status.PAUSED事件处理程序。
      Runnable MediaPlayer.getOnPlaying​()
      检索 MediaPlayer.Status.PLAYING事件处理程序。
      Runnable MediaPlayer.getOnReady​()
      检索 MediaPlayer.Status.READY事件处理程序。
      Runnable MediaPlayer.getOnRepeat​()
      检索重复事件处理程序。
      Runnable MediaPlayer.getOnStalled​()
      检索 MediaPlayer.Status.STALLED事件处理程序。
      Runnable MediaPlayer.getOnStopped​()
      检索 MediaPlayer.Status.STOPPED事件处理程序。
      Methods in javafx.scene.media that return types with arguments of type Runnable
      Modifier and Type 方法 描述
      ObjectProperty<Runnable> MediaPlayer.onEndOfMediaProperty​()
      当播放器 currentTime达到 stopTime时调用事件处理程序。
      ObjectProperty<Runnable> Media.onErrorProperty​()
      发生错误时调用事件处理程序。
      ObjectProperty<Runnable> MediaPlayer.onErrorProperty​()
      发生错误时调用事件处理程序。
      ObjectProperty<Runnable> MediaPlayer.onHaltedProperty​()
      事件处理程序在状态更改为 HALTED时调用。
      ObjectProperty<Runnable> MediaPlayer.onPausedProperty​()
      事件处理程序在状态更改为 PAUSED时调用。
      ObjectProperty<Runnable> MediaPlayer.onPlayingProperty​()
      当状态更改为 PLAYING时调用事件处理程序。
      ObjectProperty<Runnable> MediaPlayer.onReadyProperty​()
      事件处理程序在状态更改为 READY时调用。
      ObjectProperty<Runnable> MediaPlayer.onRepeatProperty​()
      当玩家的事件处理函数调用 currentTime达到 stopTime ， 将被重复。
      ObjectProperty<Runnable> MediaPlayer.onStalledProperty​()
      事件处理程序在状态更改为 STALLED时调用。
      ObjectProperty<Runnable> MediaPlayer.onStoppedProperty​()
      事件处理程序在状态更改为 STOPPED时调用。
      Methods in javafx.scene.media with parameters of type Runnable
      Modifier and Type 方法 描述
      void MediaPlayer.setOnEndOfMedia​(Runnable value)
      设置媒体事件处理程序的结束。
      void Media.setOnError​(Runnable value)
      设置发生错误时调用的事件处理程序。
      void MediaPlayer.setOnError​(Runnable value)
      设置发生错误时调用的事件处理程序。
      void MediaPlayer.setOnHalted​(Runnable value)
      设置 MediaPlayer.Status.HALTED事件处理程序。
      void MediaPlayer.setOnPaused​(Runnable value)
      设置 MediaPlayer.Status.PAUSED事件处理程序。
      void MediaPlayer.setOnPlaying​(Runnable value)
      设置 MediaPlayer.Status.PLAYING事件处理程序。
      void MediaPlayer.setOnReady​(Runnable value)
      设置 MediaPlayer.Status.READY事件处理程序。
      void MediaPlayer.setOnRepeat​(Runnable value)
      设置重复事件处理程序。
      void MediaPlayer.setOnStalled​(Runnable value)
      设置 MediaPlayer.Status.STALLED事件处理程序。
      void MediaPlayer.setOnStopped​(Runnable value)
      设置 MediaPlayer.Status.STOPPED事件处理程序。

    • Uses of Runnable in javax.net.ssl

      Methods in javax.net.ssl that return Runnable
      Modifier and Type 方法 描述
      abstract Runnable SSLEngine.getDelegatedTask​()
      返回此 SSLEngine的委托 Runnable任务。

    • Uses of Runnable in javax.swing

      Classes in javax.swing that implement Runnable
      Modifier and Type Class 描述
      class  SwingWorker<T,V>
      在后台线程中执行冗长的GUI交互任务的抽象类。
      Methods in javax.swing with parameters of type Runnable
      Modifier and Type 方法 描述
      static void SwingUtilities.invokeAndWait​(Runnable doRun)
      导致在AWT事件调度线程上同步执行 doRun.run() 。
      static void SwingUtilities.invokeLater​(Runnable doRun)
      导致 doRun.run（）在AWT事件分派线程上异步执行。

    • Uses of Runnable in javax.swing.text

      Classes in javax.swing.text that implement Runnable
      Modifier and Type Class 描述
      class  AsyncBoxView.ChildState
      表示子视图的布局状态的记录。
      Methods in javax.swing.text that return Runnable
      Modifier and Type 方法 描述
      protected Runnable LayoutQueue.waitForWork​()
      由工作线程用来获取一个新的任务来执行。
      Methods in javax.swing.text with parameters of type Runnable
      Modifier and Type 方法 描述
      void LayoutQueue.addTask​(Runnable task)
      添加一个不需要立即执行的任务，因为结果不被认为是可见的。
      void AbstractDocument.render​(Runnable r)
      如果模型支持异步更新，则可以在存在货币的情况下安全地呈现模型。
      void Document.render​(Runnable r)
      如果模型支持异步更新，则允许在存在并发性的情况下安全地呈现模型。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.StackWalker.StackFrame (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.StackWalker.StackFrame

  • Packages that use StackWalker.StackFrame
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of StackWalker.StackFrame in java.lang

      Method parameters in java.lang with type arguments of type StackWalker.StackFrame
      Modifier and Type 方法 描述
      void StackWalker.forEach​(Consumer<? super StackWalker.StackFrame> action)
      对当前线程的 StackFrame流的每个元素执行给定的动作，从堆栈的顶部框架遍历，这是调用这个 forEach方法的方法。
      <T> T StackWalker.walk​(Function<? super Stream<StackWalker.StackFrame>,? extends T> function)
      将给定的函数应用于当前线程的 StackFrame s的流，从堆栈的顶部框架遍历，这是调用此 walk方法的方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.System.Logger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.System.Logger

  • Packages that use System.Logger
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。

    • Uses of System.Logger in java.lang

      Methods in java.lang that return System.Logger
      Modifier and Type 方法 描述
      System.Logger System.LoggerFinder.getLocalizedLogger​(String name, ResourceBundle bundle, Module module)
      返回一个本地化的实例Logger对于给定module 。
      static System.Logger System.getLogger​(String name)
      返回一个Logger的调用者使用的实例。
      static System.Logger System.getLogger​(String name, ResourceBundle bundle)
      返回可调用者使用的本地化实例Logger 。
      abstract System.Logger System.LoggerFinder.getLogger​(String name, Module module)
      为给定的module返回一个Logger的实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.Thread.UncaughtExceptionHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.Thread.UncaughtExceptionHandler

  • Packages that use Thread.UncaughtExceptionHandler
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.util.concurrent
    实用程序类通常用于并发编程。

    • Uses of Thread.UncaughtExceptionHandler in java.lang

      Classes in java.lang that implement Thread.UncaughtExceptionHandler
      Modifier and Type Class 描述
      class  ThreadGroup
      线程组代表一组线程。
      Methods in java.lang that return Thread.UncaughtExceptionHandler
      Modifier and Type 方法 描述
      static Thread.UncaughtExceptionHandler Thread.getDefaultUncaughtExceptionHandler​()
      返回当线程由于未捕获异常突然终止而调用的默认处理程序。
      Thread.UncaughtExceptionHandler Thread.getUncaughtExceptionHandler​()
      返回由于未捕获的异常，此线程突然终止时调用的处理程序。
      Methods in java.lang with parameters of type Thread.UncaughtExceptionHandler
      Modifier and Type 方法 描述
      static void Thread.setDefaultUncaughtExceptionHandler​(Thread.UncaughtExceptionHandler eh)
      设置当线程由于未捕获的异常突然终止而调用的默认处理程序，并且没有为该线程定义其他处理程序。
      void Thread.setUncaughtExceptionHandler​(Thread.UncaughtExceptionHandler eh)
      设置当该线程由于未捕获的异常而突然终止时调用的处理程序。

    • Uses of Thread.UncaughtExceptionHandler in java.util.concurrent

      Methods in java.util.concurrent that return Thread.UncaughtExceptionHandler
      Modifier and Type 方法 描述
      Thread.UncaughtExceptionHandler ForkJoinPool.getUncaughtExceptionHandler​()
      返回由于在执行任务时遇到不可恢复的错误而终止的内部工作线程的处理程序。
      Constructors in java.util.concurrent with parameters of type Thread.UncaughtExceptionHandler
      Constructor 描述
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode)
      使用给定的参数创建一个 ForkJoinPool （使用默认 值为其他参数 - 参见 ForkJoinPool(int, ForkJoinWorkerThreadFactory, UncaughtExceptionHandler, boolean, int, int, int, Predicate, long, TimeUnit) ）。
      ForkJoinPool​(int parallelism, ForkJoinPool.ForkJoinWorkerThreadFactory factory, Thread.UncaughtExceptionHandler handler, boolean asyncMode, int corePoolSize, int maximumPoolSize, int minimumRunnable, Predicate<? super ForkJoinPool> saturate, long keepAliveTime, TimeUnit unit)
      使用给定的参数创建一个 ForkJoinPool 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Java Thread Primitive Deprecation

Why is Thread.stop deprecated?

Because it is inherently unsafe. Stopping a thread causes it to unlock all the monitors that it has locked. (The monitors are unlocked as the ThreadDeath exception propagates up the stack.) If any of the objects previously protected by these monitors were in an inconsistent state, other threads may now view these objects in an inconsistent state. Such objects are said to be damaged. When threads operate on damaged objects, arbitrary behavior can result. This behavior may be subtle and difficult to detect, or it may be pronounced. Unlike other unchecked exceptions, ThreadDeath kills threads silently; thus, the user has no warning that his program may be corrupted. The corruption can manifest itself at any time after the actual damage occurs, even hours or days in the future.

Couldn't I just catch the ThreadDeath exception and fix the damaged object?

In theory, perhaps, but it would vastly complicate the task of writing correct multithreaded code. The task would be nearly insurmountable for two reasons:

  1. A thread can throw a ThreadDeath exception almost anywhere. All synchronized methods and blocks would have to be studied in great detail, with this in mind.
  2. A thread can throw a second ThreadDeath exception while cleaning up from the first (in the catch or finally clause). Cleanup would have to be repeated till it succeeded. The code to ensure this would be quite complex.
In sum, it just isn't practical.

What about Thread.stop(Throwable)?

In addition to all of the problems noted above, this method may be used to generate exceptions that its target thread is unprepared to handle (including checked exceptions that the thread could not possibly throw, were it not for this method). For example, the following method is behaviorally identical to Java's throw operation, but circumvents the compiler's attempts to guarantee that the calling method has declared all of the checked exceptions that it may throw:

    static void sneakyThrow(Throwable t) {
        Thread.currentThread().stop(t);
    }

What should I use instead of Thread.stop?

Most uses of stop should be replaced by code that simply modifies some variable to indicate that the target thread should stop running. The target thread should check this variable regularly, and return from its run method in an orderly fashion if the variable indicates that it is to stop running. To ensure prompt communication of the stop-request, the variable must be volatile (or access to the variable must be synchronized).

For example, suppose your applet contains the following start, stop and run methods:

    private Thread blinker;

    public void start() {
        blinker = new Thread(this);
        blinker.start();
    }

    public void stop() {
        blinker.stop();  // UNSAFE!
    }

    public void run() {
        while (true) {
            try {
                Thread.sleep(interval);
            } catch (InterruptedException e){
            }
            repaint();
        }
    }
You can avoid the use of Thread.stop by replacing the applet's stop and run methods with:
    private volatile Thread blinker;

    public void stop() {
        blinker = null;
    }

    public void run() {
        Thread thisThread = Thread.currentThread();
        while (blinker == thisThread) {
            try {
                Thread.sleep(interval);
            } catch (InterruptedException e){
            }
            repaint();
        }
    }

How do I stop a thread that waits for long periods (e.g., for input)?

That's what the Thread.interrupt method is for. The same "state based" signaling mechanism shown above can be used, but the state change (blinker = null, in the previous example) can be followed by a call to Thread.interrupt, to interrupt the wait:

    public void stop() {
        Thread moribund = waiter;
        waiter = null;
        moribund.interrupt();
    }
For this technique to work, it's critical that any method that catches an interrupt exception and is not prepared to deal with it immediately reasserts the exception. We say reasserts rather than rethrows, because it is not always possible to rethrow the exception. If the method that catches the InterruptedException is not declared to throw this (checked) exception, then it should "reinterrupt itself" with the following incantation:
    Thread.currentThread().interrupt();
This ensures that the Thread will reraise the InterruptedException as soon as it is able.

What if a thread doesn't respond to Thread.interrupt?

In some cases, you can use application specific tricks. For example, if a thread is waiting on a known socket, you can close the socket to cause the thread to return immediately. Unfortunately, there really isn't any technique that works in general. It should be noted that in all situations where a waiting thread doesn't respond to Thread.interrupt, it wouldn't respond to Thread.stop either. Such cases include deliberate denial-of-service attacks, and I/O operations for which thread.stop and thread.interrupt do not work properly.

Why are Thread.suspend and Thread.resume deprecated?

Thread.suspend is inherently deadlock-prone. If the target thread holds a lock on the monitor protecting a critical system resource when it is suspended, no thread can access this resource until the target thread is resumed. If the thread that would resume the target thread attempts to lock this monitor prior to calling resume, deadlock results. Such deadlocks typically manifest themselves as "frozen" processes.

What should I use instead of Thread.suspend and Thread.resume?

As with Thread.stop, the prudent approach is to have the "target thread" poll a variable indicating the desired state of the thread (active or suspended). When the desired state is suspended, the thread waits using Object.wait. When the thread is resumed, the target thread is notified using Object.notify.

For example, suppose your applet contains the following mousePressed event handler, which toggles the state of a thread called blinker:

    private boolean threadSuspended;

    Public void mousePressed(MouseEvent e) {
        e.consume();

        if (threadSuspended)
            blinker.resume();
        else
            blinker.suspend();  // DEADLOCK-PRONE!

        threadSuspended = !threadSuspended;
    }
You can avoid the use of Thread.suspend and Thread.resume by replacing the event handler above with:
    public synchronized void mousePressed(MouseEvent e) {
        e.consume();

        threadSuspended = !threadSuspended;

        if (!threadSuspended)
            notify();
    }
and adding the following code to the "run loop":
                synchronized(this) {
                    while (threadSuspended)
                        wait();
                }
The wait method throws the InterruptedException, so it must be inside a try ... catch clause. It's fine to put it in the same clause as the sleep. The check should follow (rather than precede) the sleep so the window is immediately repainted when the thread is "resumed." The resulting run method follows:
    public void run() {
        while (true) {
            try {
                Thread.sleep(interval);

                synchronized(this) {
                    while (threadSuspended)
                        wait();
                }
            } catch (InterruptedException e){
            }
            repaint();
        }
    }
Note that the notify in the mousePressed method and the wait in the run method are inside synchronized blocks. This is required by the language, and ensures that wait and notify are properly serialized. In practical terms, this eliminates race conditions that could cause the "suspended" thread to miss a notify and remain suspended indefinitely.

While the cost of synchronization in Java is decreasing as the platform matures, it will never be free. A simple trick can be used to remove the synchronization that we've added to each iteration of the "run loop." The synchronized block that was added is replaced by a slightly more complex piece of code that enters a synchronized block only if the thread has actually been suspended:

                if (threadSuspended) {
                    synchronized(this) {
                        while (threadSuspended)
                            wait();
                    }
                }

In the absence of explicit synchronization, threadSuspended must be made volatile to ensure prompt communication of the suspend-request.

The resulting run method is:
    private volatile boolean threadSuspended;

    public void run() {
        while (true) {
            try {
                Thread.sleep(interval);

                if (threadSuspended) {
                    synchronized(this) {
                        while (threadSuspended)
                            wait();
                    }
                }
            } catch (InterruptedException e){
            }
            repaint();
        }
    }

Can I combine the two techniques to produce a thread that may be safely "stopped" or "suspended"?

Yes, it's reasonably straightforward. The one subtlety is that the target thread may already be suspended at the time that another thread tries to stop it. If the stop method merely sets the state variable ( blinker) to null, the target thread will remain suspended (waiting on the monitor), rather than exiting gracefully as it should. If the applet is restarted, multiple threads could end up waiting on the monitor at the same time, resulting in erratic behavior.

To rectify this situation, the stop method must ensure that the target thread resumes immediately if it is suspended. Once the target thread resumes, it must recognize immediately that it has been stopped, and exit gracefully. Here's how the resulting run and stop methods look:

    public void run() {
        Thread thisThread = Thread.currentThread();
        while (blinker == thisThread) {
            try {
                Thread.sleep(interval);

                synchronized(this) {
                    while (threadSuspended && blinker==thisThread)
                        wait();
                }
            } catch (InterruptedException e){
            }
            repaint();
        }
    }

    public synchronized void stop() {
        blinker = null;
        notify();
    }
If the stop method calls Thread.interrupt, as described above, it needn't call notify as well, but it still must be synchronized. This ensures that the target thread won't miss an interrupt due to a race condition.

What about Thread.destroy?

Thread.destroy was never implemented and has been deprecated. If it were implemented, it would be deadlock-prone in the manner of Thread.suspend. (In fact, it is roughly equivalent to Thread.suspend without the possibility of a subsequent Thread.resume.)

Why is Runtime.runFinalizersOnExit deprecated?

Because it is inherently unsafe. It may result in finalizers being called on live objects while other threads are concurrently manipulating those objects, resulting in erratic behavior or deadlock. While this problem could be prevented if the class whose objects are being finalized were coded to "defend against" this call, most programmers do not defend against it. They assume that an object is dead at the time that its finalizer is called.

Further, the call is not "thread-safe" in the sense that it sets a VM-global flag. This forces every class with a finalizer to defend against the finalization of live objects!


Value-based Classes

Some classes, such as java.util.Optional and java.time.LocalDateTime, are value-based. Instances of a value-based class:
  • are final and immutable (though may contain references to mutable objects);
  • have implementations of equals, hashCode, and toString which are computed solely from the instance's state and not from its identity or the state of any other object or variable;
  • make no use of identity-sensitive operations such as reference equality (==) between instances, identity hash code of instances, or synchronization on an instances's intrinsic lock;
  • are considered equal solely based on equals(), not based on reference equality (==);
  • do not have accessible constructors, but are instead instantiated through factory methods which make no committment as to the identity of returned instances;
  • are freely substitutable when equal, meaning that interchanging any two instances x and y that are equal according to equals() in any computation or method invocation should produce no visible change in behavior.

A program may produce unpredictable results if it attempts to distinguish two references to equal values of a value-based class, whether directly via reference equality or indirectly via an appeal to synchronization, identity hashing, serialization, or any other identity-sensitive mechanism. Use of such identity-sensitive operations on instances of value-based classes may have unpredictable effects and should be avoided.


ClassDefinition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.instrument
软件包 java.lang.instrument

Class ClassDefinition

  • java.lang.Object
    • java.lang.instrument.ClassDefinition

  • public final class ClassDefinition
extends Object
    该类作为Instrumentation.redefineClasses方法的参数块。 用于绑定需要与新类文件字节重新定义的Class 。
    从以下版本开始：
    1.5
    另请参见：
    Instrumentation.redefineClasses(java.lang.instrument.ClassDefinition...)

    • 构造方法摘要

      构造方法
      Constructor 描述
      ClassDefinition​(Class<?> theClass, byte[] theClassFile)
      使用提供的类和类文件字节创建一个新的 ClassDefinition绑定。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<?> getDefinitionClass​()
      返回类。
      byte[] getDefinitionClassFile​()
      返回包含新类文件的字节数组。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ClassDefinition

        public ClassDefinition​(Class<?> theClass,
                       byte[] theClassFile)
        使用提供的类和类文件字节创建新的ClassDefinition绑定。 不复制提供的缓冲区，只捕获对它的引用。
        参数
        theClass - 需要重新定义的 Class
        theClassFile - 新的类文件字节
        异常
        NullPointerException - 如果提供的类或数组是 null 。

    • 方法详细信息

      • getDefinitionClass

        public Class<?> getDefinitionClass​()
        返回类。
        结果
        所提及的 Class对象。

      • getDefinitionClassFile

        public byte[] getDefinitionClassFile​()
        返回包含新类文件的字节数组。
        结果
        类文件字节。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassFileTransformer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.instrument
软件包 java.lang.instrument

Interface ClassFileTransformer

  • public interface ClassFileTransformer
    类文件的变压器。 代理使用addTransformer方法注册该接口的实现，以便在加载类redefined或retransformed时调用变压器的transform方法。 实现应该覆盖这里定义的一个transform方法。 在类由Java虚拟机定义之前调用变形金刚。

    有两种变压器，由canRetransform参数确定： Instrumentation.addTransformer(ClassFileTransformer,boolean) ：

    • 添加与再转化能变压器canRetransform为真
    • 重新变形无能力的变压器，加上canRetransform为假，或加上Instrumentation.addTransformer(ClassFileTransformer)

    一旦变压器已经注册了addTransformer ，变压器将被要求每一个新的类定义和每个类重新定义。 每个类重新转换也将调用具有转换能力的变换器。 新的类定义的请求是使用ClassLoader.defineClass或其本机等价物。 类重新定义的请求是用Instrumentation.redefineClasses或其本机等价物进行的。 类重新转换的请求是用Instrumentation.retransformClasses或其本机等价物进行的。 在处理请求之前，在验证或应用类文件字节之前调用变压器。 当有多个变压器时，通过链接transform呼叫组成变换。 也就是说，通过一次调用transform返回的字节数组成为下一次调用的输入（通过classfileBuffer参数）。

    转换按以下顺序应用：

    • 转换无变压器
    • 重新转换无能力的原生变压器
    • 可转换变压器
    • 可转换能力的天生变压器

    对于重新形成，不调用不可转换的变换器，而是重新使用先前转换的结果。 在所有其他情况下，调用此方法。 在这些分组中的每一个中，变压器按照登记的顺序进行调用。 本机变压器由Java虚拟机工具接口中的ClassFileLoadHook事件提供）。

    第一个变压器的输入（通过classfileBuffer参数）为：

    • 对于新的类定义，字节传递给ClassLoader.defineClass
    • 类重定义， definitions.getDefinitionClassFile()其中definitions是参数Instrumentation.redefineClasses
    • 对于类重新转换，传递给新类定义的字节，或者如果重新定义，则是最后的重新定义，所有由重新形成的变换不能自动重新应用并且不变; 详情见Instrumentation.retransformClasses

    如果实现方法确定不需要转换，则应返回null 。 否则，它应该创建一个新的byte[]阵列，将输入classfileBuffer复制到其中，以及所有所需的转换，并返回新的数组。 输入classfileBuffer不得修改。

    在重新定义和重新定义的情况下，变压器必须支持重新定义语义：如果在初始定义期间变换器变化的类稍后被重新定义或重新定义，变压器必须确保第二类输出类文件是第一个输出的合法重新定义类文件。

    如果变压器引发异常（它没有捕获），则后续的变压器仍将被调用，并且还将尝试加载，重新定义或重新转换。 因此，抛出异常与返回null具有相同的效果。 为了防止在变压器代码中产生未经检查的异常时的意外行为，变压器可以捕获Throwable 。 如果变压器认为classFileBuffer不表示有效格式化的类文件，则应该抛出一个IllegalClassFormatException ; 而这与返回null具有相同的效果。 它有助于格式化破坏的日志记录或调试。

    请注意，术语类文件按The Java™ Virtual Machine Specification的 3.1节定义使用，表示类文件格式的字节序列，无论它们是否位于文件中。

    从以下版本开始：
    1.5
    另请参见：
    Instrumentation

    • 方法摘要

      所有方法 接口方法 Default Methods
      Modifier and Type 方法 描述
      default byte[] transform​(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
      default byte[] transform​(Module module, ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。

    • 方法详细信息

      • transform

        default byte[] transform​(ClassLoader loader,
                         String className,
                         Class<?> classBeingRedefined,
                         ProtectionDomain protectionDomain,
                         byte[] classfileBuffer)
                  throws IllegalClassFormatException
        转换给定的类文件并返回一个新的替换类文件。 当Module轴承transform不被覆盖时，将调用此方法。
        实现要求：
        默认实现返回null。
        参数
        loader - 要转换的类的定义加载器，可以是 null如果引导加载程序
        className - Java虚拟机规范中定义的完全限定类和接口名称的内部形式的类的名称。 例如， "java/util/List" 。
        classBeingRedefined - 如果这是由重新定义或重新转换触发的，则重新定义或重新转换该类; 如果这是一个类加载， null
        protectionDomain - 定义或重新定义类的保护域
        classfileBuffer - 类文件格式的输入字节缓冲区 - 不能修改
        结果
        一个格式良好的类文件缓冲区（转换结果），如果没有进行转换， null
        异常
        IllegalClassFormatException - 如果输入不表示一个格式良好的类文件

      • transform

        default byte[] transform​(Module module,
                         ClassLoader loader,
                         String className,
                         Class<?> classBeingRedefined,
                         ProtectionDomain protectionDomain,
                         byte[] classfileBuffer)
                  throws IllegalClassFormatException
        转换给定的类文件并返回一个新的替换类文件。
        实现要求：
        此方法的默认实现将调用 transform方法。
        参数
        module - 要转换的类的模块
        loader - 要转换的类的定义加载器，可以是 null如果引导加载程序
        className - Java虚拟机规范中定义的完全限定类和接口名称的内部形式的类的名称。 例如， "java/util/List" 。
        classBeingRedefined - 如果这是由重新定义或重新转换触发的，则重新定义或重新转换类; 如果这是一个类加载， null
        protectionDomain - 正在定义或重新定义类的保护域
        classfileBuffer - 类文件格式的输入字节缓冲区 - 不能修改
        结果
        一个格式良好的类文件缓冲区（转换的结果），如果没有进行转换， null
        异常
        IllegalClassFormatException - 如果输入不代表格式良好的类文件
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IllegalClassFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.instrument
软件包 java.lang.instrument

Class IllegalClassFormatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.instrument.IllegalClassFormatException
  • All Implemented Interfaces:
    Serializable

    public class IllegalClassFormatException
extends 异常
    当其输入参数无效时，通过执行ClassFileTransformer.transform抛出。 这可能是因为初始类文件字节无效或先前应用的转换损坏了字节。
    从以下版本开始：
    1.5
    另请参见：
    ClassFileTransformer.transform(java.lang.ClassLoader, java.lang.String, java.lang.Class<?>, java.security.ProtectionDomain, byte[]) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      IllegalClassFormatException​()
      构造一个 IllegalClassFormatException ，没有详细信息。
      IllegalClassFormatException​(String s)
      构造具有指定详细消息的 IllegalClassFormatException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • IllegalClassFormatException

        public IllegalClassFormatException​()
        构造一个 IllegalClassFormatException ，没有详细消息。

      • IllegalClassFormatException

        public IllegalClassFormatException​(String s)
        构造具有指定详细消息的 IllegalClassFormatException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Instrumentation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.instrument
软件包 java.lang.instrument

Interface Instrumentation

  • public interface Instrumentation
    该类提供了用于设计Java编程语言代码所需的服务。 仪器是向方法添加字节码，用于收集工具要使用的数据。 由于这些更改纯粹是加法的，因此这些工具不会修改应用程序的状态或行为。 这种良性工具的示例包括监视代理，剖析器，覆盖分析器和事件记录器。

    有两种获取Instrumentation接口实例的方法：

    1. 当以指示代理类的方式启动JVM时。 在这种情况下，一个Instrumentation实例被传递给代理类的premain方法。

    2. 当JVM在JVM启动后的某个时间提供启动代理的机制时。 在这种情况下，一个Instrumentation实例被传递给代理代码的agentmain方法。

    这些机制在package specification中有描述。

    一旦代理商获取了一个Instrumentation实例，代理可以随时调用实例上的方法。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void addTransformer​(ClassFileTransformer transformer)
      注册提供的变压器。
      void addTransformer​(ClassFileTransformer transformer, boolean canRetransform)
      注册提供的变压器。
      void appendToBootstrapClassLoaderSearch​(JarFile jarfile)
      指定具有由引导类加载器定义的检测类的JAR文件。
      void appendToSystemClassLoaderSearch​(JarFile jarfile)
      指定具有由系统类加载器定义的检测类的JAR文件。
      Class[] getAllLoadedClasses​()
      返回当前由JVM加载的所有类的数组。
      Class[] getInitiatedClasses​(ClassLoader loader)
      返回一个 loader是起始加载程序的所有类的数组。
      long getObjectSize​(Object objectToSize)
      返回指定对象所消耗的存储量的实现特定近似值。
      boolean isModifiableClass​(Class<?> theClass)
      测试课程是否可以修改 retransformation或 redefinition 。
      boolean isModifiableModule​(Module module)
      测试模块是否可以使用 redefineModule进行修改。
      boolean isNativeMethodPrefixSupported​()
      返回当前的JVM配置是否支持 setting a native method prefix 。
      boolean isRedefineClassesSupported​()
      返回当前的JVM配置是否支持重新定义类。
      boolean isRetransformClassesSupported​()
      返回当前JVM配置是否支持对类的重新创建。
      void redefineClasses​(ClassDefinition... definitions)
      使用提供的类文件重新定义提供的一组类。
      void redefineModule​(Module module, Set<Module> extraReads, Map<String,Set<Module>> extraExports, Map<String,Set<Module>> extraOpens, Set<Class<?>> extraUses, Map<Class<?>,List<Class<?>>> extraProvides)
      重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。
      boolean removeTransformer​(ClassFileTransformer transformer)
      注销提供的变压器。
      void retransformClasses​(Class<?>... classes)
      重新转换提供的一组类。
      void setNativeMethodPrefix​(ClassFileTransformer transformer, String prefix)
      此方法通过允许使用应用于名称的前缀进行重试来修改本机方法解析的故障处理。

    • 方法详细信息

      • addTransformer

        void addTransformer​(ClassFileTransformer transformer,
                    boolean canRetransform)
        注册提供的变压器。 所有未来的类定义将被变压器看到，除了任何已注册的变压器所依赖的类的定义。 当类被加载时，当它们是redefined时调用变压器。 如果canRetransform是真的，当他们retransformed 。 ClassFileTransformer定义转换调用的顺序。 如果变压器在执行过程中引发异常，则JVM依然会调用其他已注册的变压器。 相同的变压器可能不止一次添加，但强烈不鼓励 - 通过创建一个新的变压器类实例来避免这种情况。

        该方法用于仪器仪表，如class specification所述 。

        参数
        transformer - 要注册的变压器
        canRetransform - 可以将该变压器的转换重新转换
        异常
        NullPointerException - 如果通过了一个 null变压器
        UnsupportedOperationException - 如果 canRetransform为真，并且JVM的当前配置不允许重新转换（ isRetransformClassesSupported()为假）
        从以下版本开始：
        1.6

      • addTransformer

        void addTransformer​(ClassFileTransformer transformer)
        注册提供的变压器。

        与addTransformer(transformer, false)相同。

        参数
        transformer - 要注册的变压器
        异常
        NullPointerException - 如果通过了一个 null变压器
        另请参见：
        addTransformer(ClassFileTransformer,boolean)

      • removeTransformer

        boolean removeTransformer​(ClassFileTransformer transformer)
        注销提供的变压器。 未来类定义将不会显示给变压器。 删除最新添加的变压器匹配实例。 由于类加载的多线程特性，变压器可以在其被移除之后接收呼叫。 应该防范变形金刚来预期这种情况。
        参数
        transformer - 变压器取消注册
        结果
        如果发现和移除变压器，则为真，如果没有找到变压器，则为真
        异常
        NullPointerException - 如果通过一个 null变压器

      • isRetransformClassesSupported

        boolean isRetransformClassesSupported​()
        返回当前JVM配置是否支持对类的重新创建。 转载已加载类的能力是JVM的可选功能。 只有当代理JAR文件中的Can-Retransform-Classes清单属性设置为true （如package specification中所述）并且JVM支持此功能时， 才会支持重新转换。 在单个JVM的单个实例化过程中，对此方法的多次调用将始终返回相同的答案。
        结果
        如果当前的JVM配置支持重新传递类，则为true，否则为false。
        从以下版本开始：
        1.6
        另请参见：
        retransformClasses(java.lang.Class<?>...)

      • retransformClasses

        void retransformClasses​(Class<?>... classes)
                 throws UnmodifiableClassException
        重新转换提供的一组类。

        此功能有助于已加载类的检测。 当类最初加载或者当它们是redefined时 ，初始类文件字节可以用ClassFileTransformer进行转换。 此函数重新运行转换过程（无论以前是否发生转换）。 此转发遵循以下步骤：

        • 从初始类文件字节开始
        • 对于添加了canRetransform每个变压器，在最后一个类加载或重定义期间由transform返回的字节被重新用作转换的输出; 请注意，这相当于重新应用以前的转换，未改变; 除了不调用transform方法。
        • 对于添加了canRetransform每个变压器， transform方法在这些变压器中被调用
        • 转换的类文件字节作为类的新定义安装

        转换顺序在ClassFileTransformer中有所描述。 在重新编码无法转换的自动重新应用中使用相同的顺序。

        初始类文件字节表示传递给ClassLoader.defineClass或redefineClasses （在应用任何转换之前）的字节，但它们可能不完全匹配它们。 常量池可能不具有相同的布局或内容。 常量池可能有更多或更少的条目。 常量池条目可能有不同的顺序; 然而，方法的字节码中的常量池索引将对应。 某些属性可能不存在。 如果订单无意义，例如方法的顺序，订单可能不会被保留。

        该方法对一组进行操作，以允许同时对多个类进行相互依赖的更改（类A的重新转换可能需要对类B进行重新转换）。

        如果重新转换的方法具有活动堆栈帧，则这些活动帧将继续运行原始方法的字节码。 重新构建的方法将用于新的调用。

        该方法不会导致任何初始化，除了在常规JVM语义下会发生。 换句话说，重新定义一个类并不会导致它的初始化器被运行。 静态变量的值将保持在调用之前。

        转载类的实例不受影响。

        重新转换可能会改变方法体，常量池和属性。 重新传输不能添加，删除或重命名字段或方法，更改方法的签名或更改继承。 这些限制可能在将来的版本中解除。 类文件字节不会被检查，验证和安装，直到应用转换为止，如果结果字节错误，则此方法将抛出异常。

        如果此方法抛出异常，则不会重新创建任何类。

        该方法用于仪器仪表，如class specification所述 。

        参数
        classes - 要classes的类的数组; 允许零长度数组，在这种情况下，此方法什么也不做
        异常
        UnmodifiableClassException - 如果指定的类不能被修改（ isModifiableClass(java.lang.Class<?>)将返回 false ）
        UnsupportedOperationException - 如果JVM的当前配置不允许重新传输（ isRetransformClassesSupported()为假）或重新尝试进行不受支持的更改
        ClassFormatError - 如果数据不包含有效的类
        NoClassDefFoundError - 如果类文件中的名称不等于类的名称
        UnsupportedClassVersionError - 如果不支持类文件版本号
        ClassCircularityError - 如果新的类包含循环
        LinkageError - 如果发生链接错误
        NullPointerException - 如果提供的类数组或其任何组件是 null 。
        从以下版本开始：
        1.6
        另请参见：
        isRetransformClassesSupported() ， addTransformer(java.lang.instrument.ClassFileTransformer, boolean) ， ClassFileTransformer

      • isRedefineClassesSupported

        boolean isRedefineClassesSupported​()
        返回当前的JVM配置是否支持重新定义类。 重新定义已加载类的功能是JVM的可选功能。 仅当代理JAR文件中的Can-Redefine-Classes清单属性设置为true （如package specification中所述），并且JVM支持此功能时，才会支持重新定义。 在单个JVM的单个实例化过程中，对此方法的多次调用将始终返回相同的答案。
        结果
        如果当前的JVM配置支持重新定义类，则为true，否则为false。
        另请参见：
        redefineClasses(java.lang.instrument.ClassDefinition...)

      • redefineClasses

        void redefineClasses​(ClassDefinition... definitions)
              throws ClassNotFoundException,
                     UnmodifiableClassException
        使用提供的类文件重新定义提供的一组类。

        该方法用于替换类的定义，而不引用现有的类文件字节，就像从源进行重新编译以进行修复和继续调试时一样。 在现有的类文件字节要转换的地方（例如，在字节码仪器中）应该使用retransformClasses 。

        该方法对一组进行操作，以便同时允许多个类的相互依赖的更改（A类的重新定义可能需要重新定义B类）。

        如果重新定义的方法具有活动堆栈帧，则这些活动帧将继续运行原始方法的字节码。 重新定义的方法将用于新的调用。

        该方法不会导致任何初始化，除了在常规JVM语义下会发生。 换句话说，重新定义一个类并不会导致它的初始化器被运行。 静态变量的值将保持在调用之前。

        重新定义的类的实例不受影响。

        重新定义可能会改变方法体，常量池和属性。 重定义不能添加，删除或重命名字段或方法，更改方法的签名或更改继承。 这些限制可能在将来的版本中解除。 类文件字节不会被检查，验证和安装，直到应用转换为止，如果结果字节错误，则此方法将抛出异常。

        如果此方法抛出异常，则不会重新定义任何类。

        该方法用于仪器仪表，如class specification所述 。

        参数
        definitions - 重新定义相应定义的类的数组; 允许零长度数组，在这种情况下，此方法什么也不做
        异常
        UnmodifiableClassException - 如果指定的类不能被修改（ isModifiableClass(java.lang.Class<?>)将返回 false ）
        UnsupportedOperationException - 如果JVM的当前配置不允许重新定义（ isRedefineClassesSupported()为false）或重新定义尝试进行不受支持的更改
        ClassFormatError - 如果数据不包含有效的类
        NoClassDefFoundError - 如果类文件中的名称不等于类的名称
        UnsupportedClassVersionError - 如果不支持类文件版本号
        ClassCircularityError - 如果新类包含循环
        LinkageError - 如果发生链接错误
        NullPointerException - 如果提供的定义数组或其任何组件是 null
        ClassNotFoundException - 永远不能抛出（仅出于兼容性原因出现）
        另请参见：
        isRedefineClassesSupported() ， addTransformer(java.lang.instrument.ClassFileTransformer, boolean) ， ClassFileTransformer

      • isModifiableClass

        boolean isModifiableClass​(Class<?> theClass)
        测试课程是否可修改retransformation或redefinition 。 如果类是可修改的，那么此方法返回true 。 如果类不可修改，则此方法返回false 。

        对于要重新转换的类， isRetransformClassesSupported()也必须为true。 但是， isRetransformClassesSupported()的值不会影响此函数返回的值。 对于要重新定义的类， isRedefineClassesSupported()也必须为true。 但是， isRedefineClassesSupported()的值不会影响此函数返回的值。

        原始类（例如， java.lang.Integer.TYPE ）和数组类永远不可修改。

        参数
        theClass - 检查可修改的类
        结果
        参数类是否可修改
        异常
        NullPointerException - 如果指定的类是 null 。
        从以下版本开始：
        1.6
        另请参见：
        retransformClasses(java.lang.Class<?>...) ，
isRetransformClassesSupported() ，
redefineClasses(java.lang.instrument.ClassDefinition...) ，
isRedefineClassesSupported()

      • getAllLoadedClasses

        Class[] getAllLoadedClasses​()
        返回当前由JVM加载的所有类的数组。
        结果
        一个包含JVM加载的所有类的数组，如果没有，则为零长度

      • getInitiatedClasses

        Class[] getInitiatedClasses​(ClassLoader loader)
        返回一个loader是起始加载器的所有类的数组。 如果提供的加载程序是null ，则返回由引导类加载器启动的类。
        参数
        loader - 将返回其启动的类列表的加载程序
        结果
        一个包含加载器是启动加载器的所有类的数组，如果没有，则为零长度

      • getObjectSize

        long getObjectSize​(Object objectToSize)
        返回指定对象所消耗的存储量的实现特定近似值。 结果可能包括一些或全部对象的开销，因此对于实现之间的比较而言不是有用的。 在JVM的单次调用期间，估计可能会发生变化。
        参数
        objectToSize - 对象的大小
        结果
        指定对象所消耗的存储量的实现特定近似
        异常
        NullPointerException - 如果提供的对象是 null 。

      • appendToBootstrapClassLoaderSearch

        void appendToBootstrapClassLoaderSearch​(JarFile jarfile)
        指定具有由引导类加载器定义的检测类的JAR文件。

        当虚拟机的内置类加载器（称为“引导类加载器”）失败搜索一个类时， JAR file中的条目也将被搜索。

        该方法可以被多次使用，以按照调用此方法的顺序添加要搜索的多个JAR文件。

        代理应该注意确保JAR不包含除了引导类加载器为了进行检测而定义的类之外的任何类或资源。 不遵守此警告可能导致难以诊断的意外行为。 例如，假设有一个加载器L，并且用于委托的L''s parent是引导类加载器。 此外，类C中由L定义的类的方法引用非公共访问器类C $ 1。 如果JAR文件包含C $ 1类，则引导类加载器的委派将导致C $ 1由引导类加载器定义。 在此示例中，将抛出一个IllegalAccessError可能导致应用程序失败。 避免这些类型问题的一种方法是使用检测类的唯一包名称。

        The Java™ Virtual Machine Specification指定后续尝试解析Java虚拟机以前未成功尝试解决的符号引用始终会失败，并导致与初始解析尝试结果相同的错误。 因此，如果JAR文件包含与Java虚拟机未成功尝试解析引用的类对应的条目，则解析该引用的后续尝试将失败，与初始尝试相同。

        参数
        jarfile - 引导类加载程序无法搜索类时要搜索的JAR文件。
        异常
        NullPointerException - 如果 jarfile是 null 。
        从以下版本开始：
        1.6
        另请参见：
        appendToSystemClassLoaderSearch(java.util.jar.JarFile) ， ClassLoader ， JarFile

      • appendToSystemClassLoaderSearch

        void appendToSystemClassLoaderSearch​(JarFile jarfile)
        指定具有由系统类加载器定义的检测类的JAR文件。 当用于委派的系统类加载器（见getSystemClassLoader() ）不成功搜索类时，也将搜索JarFile中的条目。

        该方法可以被多次使用，以按照调用此方法的顺序添加要搜索的多个JAR文件。

        代理应该注意确保JAR不包含系统类加载器为了进行检测而定义的任何类或资源。 不遵守此警告可能导致难以诊断的意外行为（见appendToBootstrapClassLoaderSearch ）。

        系统类加载器支持添加，如果它实现了一个命名的方法要被搜索的JAR文件appendToClassPathForInstrumentation其中采用类型的单个参数java.lang.String 。 该方法不需要具有public访问权限。 通过调用获得的JAR文件的名称getName()的方法jarfile并且这被设置为参数的appendToClassPathForInstrumentation方法。

        The Java™ Virtual Machine Specification指定后续尝试解析Java虚拟机先前未成功尝试解析的符号引用始终失败，并且出现与初始解析尝试结果相同的错误。 因此，如果JAR文件包含与Java虚拟机未成功尝试解析引用的类对应的条目，则解析该引用的后续尝试将失败，与初始尝试相同。

        此方法不会更改java.class.path system property的值。

        参数
        jarfile - 当系统类加载程序不成功搜索类时要搜索的JAR文件。
        异常
        UnsupportedOperationException - 如果系统类加载器不支持追加要搜索的JAR文件。
        NullPointerException - 如果 jarfile是 null 。
        从以下版本开始：
        1.6
        另请参见：
        appendToBootstrapClassLoaderSearch(java.util.jar.JarFile) ， ClassLoader.getSystemClassLoader() ， JarFile

      • isNativeMethodPrefixSupported

        boolean isNativeMethodPrefixSupported​()
        返回当前的JVM配置是否支持setting a native method prefix 。 设置本机方法前缀的功能是JVM的可选功能。 仅当代理JAR文件中的Can-Set-Native-Method-Prefix清单属性设置为true （如package specification所述 ），并且JVM支持此功能时，才支持设置本机方法前缀。 在单个JVM的单个实例化过程中，对此方法的多次调用将始终返回相同的答案。
        结果
        如果当前的JVM配置支持设置本机方法前缀，则为true，否则为false。
        从以下版本开始：
        1.6
        另请参见：
        setNativeMethodPrefix(java.lang.instrument.ClassFileTransformer, java.lang.String)

      • setNativeMethodPrefix

        void setNativeMethodPrefix​(ClassFileTransformer transformer,
                           String prefix)
        此方法通过允许使用应用于名称的前缀进行重试来修改本机方法解析的故障处理。 当与ClassFileTransformer一起使用时，它可以对本地方法进行检测。

        由于本地方法无法直接进行检测（它们没有字节码），因此必须使用可以进行检测的非本地方法来包装。 例如，如果我们有：

          native boolean foo(int x);

        我们可以转换类文件（在类的初始定义中使用ClassFileTransformer），以便这将变为：

          boolean foo(int x) {
     ... record entry to foo ...
     return wrapped_foo(x);
   }

   native boolean wrapped_foo(int x);

        其中foo成为具有附加前缀“wrapped_”的实际本机方法的包装器。 请注意，“wrapped_”将是一个不好的前缀选择，因为它可能构成现有方法的名称，因此像“$$$ MyAgentWrapped $$$ _”会更好，但会使这些示例变得更不可读。

        包装器将允许在本地方法调用中收集数据，但现在问题就是将包装方法与本地实现相关联。 也就是说，方法wrapped_foo需要解决到本地实现的foo ，这可能是：

          Java_somePackage_someClass_foo(JNIEnv* env, jint x)

        此功能允许指定前缀并发生正确的分辨率。 具体来说，当标准分辨率失败时，会考虑前缀来重试分辨率。 有两种方式可以解决分辨率，使用JNI功能显示分辨率RegisterNatives和正常的自动分辨率。 对于RegisterNatives ，JVM将尝试此关联：

           method(foo) -> nativeImplementation(foo)

        当此失败时，将以方法名称前面的指定前缀重新执行解析，得到正确的解析度：

           method(wrapped_foo) -> nativeImplementation(foo)

        为了自动解析，JVM将尝试：

           method(wrapped_foo) -> nativeImplementation(wrapped_foo)

        当此失败时，将重新执行解析，并从实现名称中删除指定的前缀，得到正确的解析度：

           method(wrapped_foo) -> nativeImplementation(foo)

        请注意，由于前缀仅在标准分辨率失败时使用，因此本地方法可以选择性地进行包装。

        由于每个ClassFileTransformer都可以对字节码进行自己的转换，所以可以应用多层包装。 因此，每个变压器需要自己的前缀。 由于按顺序应用转换，所以应用前缀将以相同的顺序应用（见addTransformer ）。 因此，如果三个变压器应用封装， foo可能会变成$trans3_$trans2_$trans1_foo 。 但是，如果说第二个变压器没有应用一个包装到foo它将只是$trans3_$trans1_foo 。 为了能够有效地确定前缀的顺序，只有当它的非本地包装存在时才应用中间前缀。 因此，在最后一个例子中，即使$trans1_foo不是天然的方法，所述$trans1_前缀被施加因为$trans1_foo存在。

        参数
        transformer - 使用此前缀包装的ClassFileTransformer。
        prefix - 重试本机方法解析失败时应用于包装本地方法的前缀。 如果前缀为null或空字符串，则不会为此变压器重试本机方法分辨率失败。
        异常
        NullPointerException - 如果通过了一个 null变压器。
        UnsupportedOperationException - 如果JVM的当前配置不允许设置本机方法前缀（ isNativeMethodPrefixSupported()为false）。
        IllegalArgumentException - 如果变压器未注册（见 addTransformer ）。
        从以下版本开始：
        1.6

      • redefineModule

        void redefineModule​(Module module,
                    Set<Module> extraReads,
                    Map<String,Set<Module>> extraExports,
                    Map<String,Set<Module>> extraOpens,
                    Set<Class<?>> extraUses,
                    Map<Class<?>,List<Class<?>>> extraProvides)
        重新定义一个模块来扩展它读取的模块集，它导出或打开的一组包，或者它使用或提供的服务。 该方法便于在命名模块中对代码进行检测，其中该工具需要更改读取的模块集，导出或打开的软件包，或使用或提供的服务。

        此方法无法减少模块读取的模块集，也不能减少其导出或打开的软件包集，也不能减少其使用或提供的一组服务。 这个方法是被调用来重新定义一个未命名的模块的无操作。

        当扩展模块所使用或提供的服务时，该代理可以在代理上确保在使用服务类型的每个工具站点都可访问该服务类型。 该方法不检查服务类型是否是模块的成员，或者是由其读取的另一个模块导出到该模块的包中。

        extraExports参数是要导出的其他包的映射。 extraOpens参数是要打开的附加包的地图。 在这两种情况下，映射密钥是The Java™ Language Specification第6.5.3节中定义的软件包的全限定名称，例如"java.lang" 。 映射值是包应该导出或打开的非空集合模块。

        extraProvides参数是模块提供的附加服务提供商。 地图键是服务类型。 映射值是实现类型的非空列表，每个实现类型都是模块的成员和服务的实现。

        该方法对于并发使用是安全的，因此允许多个代理在同一时间进行仪器和更新同一模块。

        参数
        module - 模块重新定义
        extraReads - 要读取的可能空的一组附加模块
        extraExports - 要导出的附加包的可能空的地图
        extraOpens - 要打开的附加包的可能空的地图
        extraUses - 可能是空的一组额外的服务使用
        extraProvides - 可能提供的附加服务的空地图
        异常
        IllegalArgumentException - 如果extraExports或extraOpens包含不是模块中的包的密钥;
如果extraExports或extraOpens将一个键映射到一个空集合;
如果extraProvides映射中的值包含不是模块成员或服务实现的服务提供者类型;
或extraProvides将键映射到空列表
        UnmodifiableModuleException - 如果模块无法修改
        NullPointerException - 如果任何参数是 null或任何集合或地图包含 null键或值
        从以下版本开始：
        9
        另请参见：
        isModifiableModule(Module)

      • isModifiableModule

        boolean isModifiableModule​(Module module)
        测试模块是否可以用redefineModule进行修改。 如果模块是可修改的，那么此方法将返回true 。 如果模块不可修改，则此方法返回false 。 当模块是未命名模块时，该方法总是返回true （因为重新定义未命名的模块是无操作的）。
        参数
        module - 模块测试是否可以修改
        结果
        true如果模块是可修改的，否则为 false
        异常
        NullPointerException - 如果模块是 null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.lang.instrument (Java SE 9 & JDK 9 )

java.lang.instrument

Interfaces

  • ClassFileTransformer
  • Instrumentation

Classes

  • ClassDefinition

Exceptions

  • IllegalClassFormatException
  • UnmodifiableClassException
  • UnmodifiableModuleException


java.lang.instrument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.instrument

Package java.lang.instrument

提供允许Java编程语言代理仪器在JVM上运行程序的服务。 仪器的机制是修改方法的字节码。

代理部署为JAR文件。 JAR文件清单中的一个属性指定将加载以启动代理的代理类。 代理商可以通过几种方式启动：

  1. 对于支持命令行界面的实现，可以通过在命令行中指定选项来启动代理。

  2. 虚拟机启动后，实现可能会支持启动代理的机制。 例如，实现可以提供一种机制，其允许工具附加到正在运行的应用，并且启动将该工具的代理加载到正在运行的应用中。

  3. 代理可以与可执行JAR文件中的应用程序一起打包。

以下描述了启动代理的这些方法中的每一种。

从命令行界面启动代理

如果实现提供了从命令行界面启动代理的方法，则通过向命令行添加以下选项来启动代理：

-javaagent:<jarpath>[=<options>]
其中<jarpath>是代理JAR文件的路径，而<options>是代理选项。

代理JAR文件的清单必须在其主清单中包含属性Premain-Class 。 该属性的值是代理类的名称。 代理类必须实现一个类似于main应用程序入口点的公共静态方法premain方法。 Java虚拟机（JVM）初始化后，将调用premain方法，然后实际应用程序为main方法。 premain方法必须返回，以便启动继续。

premain方法具有两种可能的签名之一。 JVM首先尝试在代理类上调用以下方法：

public static void premain(String agentArgs, Instrumentation inst)

如果代理类不实现此方法，则JVM将尝试调用：

public static void premain(String agentArgs)

代理程序类也可能有一个agentmain方法，用于启动虚拟机启动后的代理（见下文）。 当使用命令行选项启动代理程序时，不会调用agentmain方法。

每个代理通过agentArgs参数传递其代理选项。 代理选项作为单个字符串传递，任何其他解析都应由代理本身执行。

如果代理无法启动（例如，因为代理类无法加载，或者代理类没有适当的premain方法），则JVM将中止。 如果一个premain方法抛出一个未捕获的异常，JVM将中止。

不需要实现提供从命令行界面启动代理的方法。 那么它支持-javaagent选项，如上所述。 -javaagent选项可能会在同一命令行上多次使用，从而启动多个代理。 将按照命令行中指定代理的顺序调用premain方法。 多个代理可以使用相同的<jarpath> 。

对于代理商premain方法可以做什么，没有建模限制。 任何应用程序main可以做，包括创建线程，从premain是合法的。

VM启动后启动代理

实现可以提供在VM启动之后的某个时间启动代理的机制。 关于如何启动的细节是具体实现的，但通常应用程序已经启动，并且已经调用了它的main方法。 在VM启动后，实现支持启动代理的情况适用于以下情况：

  1. 代理JAR的清单必须包含属性Agent-Class在其主manfiest。 该属性的值是代理类的名称。

  2. 代理类必须实现一个公共静态的agentmain方法。

agentmain方法具有两种可能的签名之一。 JVM首先尝试在代理类上调用以下方法：

public static void agentmain(String agentArgs, Instrumentation inst)

如果代理类不实现此方法，则JVM将尝试调用：

public static void agentmain(String agentArgs)

当使用命令行选项启动代理时，代理类也可能具有premain方法。 虚拟机启动后启动代理时，不会调用premain方法。

代理通过agentArgs参数传递其代理选项。 代理选项作为单个字符串传递，任何其他解析都应由代理本身执行。

agentmain方法应该执行启动代理所需的任何必需的初始化。 启动完成后，方法应该返回。 如果代理无法启动（例如，由于代理类不能加载，或者由于代理类不具有一致性agentmain方法），则JVM不会中止。 如果agentmain方法抛出未捕获的异常，则它将被忽略（但为了进行故障排除，可能会被JVM记录）。

在可执行的JAR文件中包含一个代理

JAR文件规范定义了作为可执行JAR文件打包的独立应用程序的清单属性。 如果实现支持将启动应用程序作为可执行JAR的机制，则主清单可能包括Launcher-Agent-Class属性，以指定在调用应用程序main方法之前启动的代理程序的类名。 Java虚拟机尝试在代理类上调用以下方法：

public static void agentmain(String agentArgs, Instrumentation inst)

如果代理类不实现此方法，则JVM将尝试调用：

public static void agentmain(String agentArgs)

agentArgs参数的值始终为空字符串。

agentmain方法应该执行启动代理并返回所需的任何必需的初始化。 如果代理无法启动，例如代理类不能加载，则代理类不定义一致的agentmain方法，或者agentmain方法抛出未捕获的异常或错误，JVM将中止。

加载代理类和可用于代理类的模块/类

从代理JAR文件加载的类由system class loader加载，并且是系统类加载器的成员unnamed module 。 系统类加载器通常定义包含应用程序main方法的类。

代理类可见的类是系统类加载器可见的类，最低限度包括：

  • 包中导出的包中的类在boot layer中 。 引导层是否包含所有平台模块将取决于初始模块或应用程序的启动方式。

  • 可以由系统类加载器（通常是类路径）定义为其未命名模块的成员的类。

  • 代理安排的任何类都由引导类加载器定义为其未命名模块的成员。

如果代理类需要链接到不在引导层的平台（或其他）模块中的类，则可能需要以确保这些模块位于引导层中的方式启动应用程序。 例如，在JDK实现中，可以使用--add-modules命令行选项将模块添加到启动时解析的根模块集。

代理安排由引导类加载器（通过appendToBootstrapClassLoaderSearch或下面指定的Boot-Class-Path属性）加载的支持类必须链接到定义到引导类加载器的类。 不能保证所有平台类都可以由引导类加载器定义。

如果自定义系统类加载器被配置（由系统属性的手段java.system.class.loader作为指定getSystemClassLoader方法），那么它必须定义appendToClassPathForInstrumentation如在指定的方法appendToSystemClassLoaderSearch 。 换句话说，自定义系统类加载器必须支持将代理JAR文件添加到系统类加载器搜索的机制。

清单属性

为代理JAR文件定义了以下清单属性：

Premain-Class
When an agent is specified at JVM launch time this attribute specifies the agent class. That is, the class containing the premain method. When an agent is specified at JVM launch time this attribute is required. If the attribute is not present the JVM will abort. Note: this is a class name, not a file name or path.
Agent-Class
If an implementation supports a mechanism to start agents sometime after the VM has started then this attribute specifies the agent class. That is, the class containing the agentmain method. This attribute is required if it is not present the agent will not be started. Note: this is a class name, not a file name or path.
Launcher-Agent-Class
If an implementation supports a mechanism to start an application as an executable JAR then the main manifest may include this attribute to specify the class name of an agent to start before the application main method is invoked.
Boot-Class-Path
A list of paths to be searched by the bootstrap class loader. Paths represent directories or libraries (commonly referred to as JAR or zip libraries on many platforms). These paths are searched by the bootstrap class loader after the platform specific mechanisms of locating a class have failed. Paths are searched in the order listed. Paths in the list are separated by one or more spaces. A path takes the syntax of the path component of a hierarchical URI. The path is absolute if it begins with a slash character ('/'), otherwise it is relative. A relative path is resolved against the absolute path of the agent JAR file. Malformed and non-existent paths are ignored. When an agent is started sometime after the VM has started then paths that do not represent a JAR file are ignored. This attribute is optional.
Can-Redefine-Classes
Boolean ( true or false, case irrelevant). Is the ability to redefine classes needed by this agent. Values other than true are considered false. This attribute is optional, the default is false.
Can-Retransform-Classes
Boolean ( true or false, case irrelevant). Is the ability to retransform classes needed by this agent. Values other than true are considered false. This attribute is optional, the default is false.
Can-Set-Native-Method-Prefix
Boolean ( true or false, case irrelevant). Is the ability to set native method prefix needed by this agent. Values other than true are considered false. This attribute is optional, the default is false.

代理JAR文件可能具有清单中存在的Premain-Class和Agent-Class属性。 当使用-javaagent选项在命令行启动代理时， Premain-Class属性指定代理类的名称，并忽略Agent-Class属性。 类似地，如果代理在VM启动后的某个时间启动，则Agent-Class属性指定代理类的名称（值为Premain-Class属性的值将被忽略）。

在模块中调用代码

作为在引导类加载器的搜索路径上部署支持类的代理或加载主代理类的类加载器的搜索路径的帮助，Java虚拟机安排转换类的模块读取未命名的模块的两个类装载机。

从以下版本开始：
1.5
  • 接口摘要
    接口 描述
    ClassFileTransformer
    类文件的变压器。
    Instrumentation
    该类提供了用于设计Java编程语言代码所需的服务。
  • 类摘要
    Class 描述
    ClassDefinition
    该类作为 Instrumentation.redefineClasses方法的参数块。
  • 异常摘要
    异常 描述
    IllegalClassFormatException
    当其输入参数无效时，通过执行 ClassFileTransformer.transform进行抛出。
    UnmodifiableClassException
    当其中一个指定的类不能修改时，通过执行 Instrumentation.redefineClasses抛出。
    UnmodifiableModuleException
    Thrown to indicate that a module cannot be modified.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang.instrument Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang.instrument

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.instrument.ClassDefinition
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.instrument.IllegalClassFormatException
        • java.lang.RuntimeException
          • java.lang.instrument.UnmodifiableModuleException
        • java.lang.instrument.UnmodifiableClassException

Interface Hierarchy

  • java.lang.instrument.ClassFileTransformer
  • java.lang.instrument.Instrumentation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


UnmodifiableClassException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.instrument
软件包 java.lang.instrument

Class UnmodifiableClassException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.instrument.UnmodifiableClassException
  • All Implemented Interfaces:
    Serializable

    public class UnmodifiableClassException
extends 异常
    当其中一个指定的类不能被修改时，由 Instrumentation.redefineClasses的实现抛出。
    从以下版本开始：
    1.5
    另请参见：
    Instrumentation.redefineClasses(java.lang.instrument.ClassDefinition...) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnmodifiableClassException​()
      构造一个没有详细消息的 UnmodifiableClassException 。
      UnmodifiableClassException​(String s)
      构造具有指定详细消息的 UnmodifiableClassException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnmodifiableClassException

        public UnmodifiableClassException​()
        构造一个 UnmodifiableClassException ，没有详细信息。

      • UnmodifiableClassException

        public UnmodifiableClassException​(String s)
        构造具有指定详细消息的 UnmodifiableClassException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnmodifiableModuleException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.instrument
软件包 java.lang.instrument

Class UnmodifiableModuleException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.instrument.UnmodifiableModuleException
  • All Implemented Interfaces:
    Serializable

    public class UnmodifiableModuleException
extends RuntimeException
    抛出以表示模块无法修改。
    从以下版本开始：
    9
    另请参见：
    Instrumentation.redefineModule(java.lang.Module, java.util.Set<java.lang.Module>, java.util.Map<java.lang.String, java.util.Set<java.lang.Module>>, java.util.Map<java.lang.String, java.util.Set<java.lang.Module>>, java.util.Set<java.lang.Class<?>>, java.util.Map<java.lang.Class<?>, java.util.List<java.lang.Class<?>>>) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnmodifiableModuleException​()
      构造一个没有详细消息的 UnmodifiableModuleException 。
      UnmodifiableModuleException​(String msg)
      构造具有指定详细消息的 UnmodifiableModuleException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnmodifiableModuleException

        public UnmodifiableModuleException​()
        构造一个没有详细消息的 UnmodifiableModuleException 。

      • UnmodifiableModuleException

        public UnmodifiableModuleException​(String msg)
        构造具有指定详细消息的 UnmodifiableModuleException 。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.lang.instrument (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang.instrument

  • Packages that use java.lang.instrument
    软件包 描述
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。
  • Classes in java.lang.instrument used by java.lang.instrument
    Class 描述
    ClassDefinition
    该类作为 Instrumentation.redefineClasses方法的参数块。
    ClassFileTransformer
    类文件的变压器。
    IllegalClassFormatException
    当其输入参数无效时，通过执行 ClassFileTransformer.transform抛出。
    UnmodifiableClassException
    当其中一个指定的类不能被修改时，通过执行 Instrumentation.redefineClasses抛出。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.instrument.ClassDefinition (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.instrument.ClassDefinition

  • Packages that use ClassDefinition
    软件包 描述
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。

    • Uses of ClassDefinition in java.lang.instrument

      Methods in java.lang.instrument with parameters of type ClassDefinition
      Modifier and Type 方法 描述
      void Instrumentation.redefineClasses​(ClassDefinition... definitions)
      使用提供的类文件重新定义提供的一组类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.instrument.IllegalClassFormatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.instrument.IllegalClassFormatException

  • Packages that use IllegalClassFormatException
    软件包 描述
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。

    • Uses of IllegalClassFormatException in java.lang.instrument

      Methods in java.lang.instrument that throw IllegalClassFormatException
      Modifier and Type 方法 描述
      default byte[] ClassFileTransformer.transform​(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
      default byte[] ClassFileTransformer.transform​(Module module, ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
      转换给定的类文件并返回一个新的替换类文件。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.instrument.UnmodifiableClassException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.instrument.UnmodifiableClassException

  • Packages that use UnmodifiableClassException
    软件包 描述
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。

    • Uses of UnmodifiableClassException in java.lang.instrument

      Methods in java.lang.instrument that throw UnmodifiableClassException
      Modifier and Type 方法 描述
      void Instrumentation.redefineClasses​(ClassDefinition... definitions)
      使用提供的类文件重新定义提供的一组类。
      void Instrumentation.retransformClasses​(Class<?>... classes)
      重新转换提供的一组类。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.instrument.UnmodifiableModuleException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.instrument.UnmodifiableModuleException

No usage of java.lang.instrument.UnmodifiableModuleException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.instrument.ClassFileTransformer (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.instrument.ClassFileTransformer

  • Packages that use ClassFileTransformer
    软件包 描述
    java.lang.instrument
    提供允许Java编程语言代理仪器在JVM上运行程序的服务。

    • Uses of ClassFileTransformer in java.lang.instrument

      Methods in java.lang.instrument with parameters of type ClassFileTransformer
      Modifier and Type 方法 描述
      void Instrumentation.addTransformer​(ClassFileTransformer transformer)
      注册提供的变压器。
      void Instrumentation.addTransformer​(ClassFileTransformer transformer, boolean canRetransform)
      注册提供的变压器。
      boolean Instrumentation.removeTransformer​(ClassFileTransformer transformer)
      注销提供的变压器。
      void Instrumentation.setNativeMethodPrefix​(ClassFileTransformer transformer, String prefix)
      此方法通过允许使用应用于名称的前缀进行重试来修改本机方法解析的故障处理。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.instrument.Instrumentation (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.instrument.Instrumentation

No usage of java.lang.instrument.Instrumentation
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


CallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class CallSite

  • java.lang.Object
    • java.lang.invoke.CallSite
  • 已知直接子类：
    ConstantCallSite ， MutableCallSite ， VolatileCallSite

    public abstract class CallSite
extends Object
    A CallSite是变量MethodHandle的持有人，它被称为其target 。 链接到CallSite的invokedynamic指令将对站点的当前目标的所有调用委托。 A CallSite可能与几个invokedynamic指令相关联，或者它可能是“自由浮动”，与无关联。 在任何情况下，它可以通过称为其dynamic invoker的关联方法句柄来调用。

    CallSite是一个抽象类，不允许用户直接进行子类化。 它有三个立即具体的子类，可以被实例化或子类化。

    • 如果不需要一个可变的靶， invokedynamic指令可永久地用的手段结合constant call site 。
    • 如果需要具有易变性语义的可变目标，因为目标的更新必须立即可靠地被其他线程目击， 所以可以使用volatile call site 。
    • 否则，如果需要可变目标，可以使用mutable call site 。

    通过更改其目标可以重新链接非常数呼叫站点。 新的目标必须与以前的目标相同的type 。 因此，虽然呼叫站点可以重新链接到一系列连续的目标，但它不能改变其类型。

    以下是使用呼叫站点和引导方法的示例，它们链接每个动态调用站点以打印其参数：

static void test() throws Throwable {
    // THE FOLLOWING LINE IS PSEUDOCODE FOR A JVM INSTRUCTION
    InvokeDynamic[#bootstrapDynamic].baz("baz arg", 2, 3.14);
}
private static void printArgs(Object... args) {
  System.out.println(java.util.Arrays.deepToString(args));
}
private static final MethodHandle printArgs;
static {
  MethodHandles.Lookup lookup = MethodHandles.lookup();
  Class thisClass = lookup.lookupClass();  // (who am I?)
  printArgs = lookup.findStatic(thisClass,
      "printArgs", MethodType.methodType(void.class, Object[].class));
}
private static CallSite bootstrapDynamic(MethodHandles.Lookup caller, String name, MethodType type) {
  // ignore caller and name, but match the type:
  return new ConstantCallSite(printArgs.asType(type));
}
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract MethodHandle dynamicInvoker​()
      生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
      abstract MethodHandle getTarget​()
      根据此调用站点的特定类定义的行为，返回调用站点的目标方法。
      abstract void setTarget​(MethodHandle newTarget)
      根据此呼叫站点的特定类定义的行为，更新此呼叫站点的目标方法。
      MethodType type​()
      返回此呼叫站点目标的类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • type

        public MethodType type​()
        返回此呼叫站点目标的类型。 虽然目标可能会改变，任何呼叫站点的类型是永久性的，永远不会改变为不平等的类型。 setTarget方法通过拒绝任何没有上一个目标类型的新目标来强制执行此不变式。
        结果
        当前目标的类型，也是任何未来目标的类型

      • getTarget

        public abstract MethodHandle getTarget​()
        根据此调用站点的特定类定义的行为，返回调用站点的目标方法。 CallSite的直接子类记录了此方法的类特定行为。
        结果
        当前链接状态的调用站点，其目标方法句柄
        另请参见：
        ConstantCallSite ， VolatileCallSite ， setTarget(java.lang.invoke.MethodHandle) ， ConstantCallSite.getTarget() ， MutableCallSite.getTarget() ， VolatileCallSite.getTarget()

      • setTarget

        public abstract void setTarget​(MethodHandle newTarget)
        根据此呼叫站点的特定类定义的行为，更新此呼叫站点的目标方法。 CallSite的直接子类记录了此方法的类特定行为。

        新目标的类型必须是equal to旧目标的类型。

        参数
        newTarget - 新的目标
        异常
        NullPointerException - 如果提出的新目标为null
        WrongMethodTypeException - 如果所提出的新目标具有与先前目标不同的方法类型
        另请参见：
        getTarget() ，
ConstantCallSite.setTarget(java.lang.invoke.MethodHandle) ，
MutableCallSite.setTarget(java.lang.invoke.MethodHandle) ，
VolatileCallSite.setTarget(java.lang.invoke.MethodHandle)

      • dynamicInvoker

        public abstract MethodHandle dynamicInvoker​()
        生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。

        此方法等同于以下代码：

 MethodHandle getTarget, invoker, result;
 getTarget = MethodHandles.publicLookup().bind(this, "getTarget", MethodType.methodType(MethodHandle.class));
 invoker = MethodHandles.exactInvoker(this.type());
 result = MethodHandles.foldArguments(invoker, getTarget)
        结果
        a method handle which always invokes this call site's current target
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ConstantCallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class ConstantCallSite

  • java.lang.Object
    • java.lang.invoke.CallSite
      • java.lang.invoke.ConstantCallSite

  • public class ConstantCallSite
extends CallSite
    A ConstantCallSite是一个CallSite，其目标是永久性的，永远不能更改。 链接到ConstantCallSite的invokedynamic指令永久绑定到呼叫站点的目标。
    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        ConstantCallSite​(MethodHandle target)
      创建一个具有永久目标的呼叫站点。
      protected ConstantCallSite​(MethodType targetType, MethodHandle createTargetHook)
      创建具有永久目标的呼叫站点，可能绑定到呼叫站点本身。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MethodHandle dynamicInvoker​()
      返回此呼叫站点的永久目标。
      MethodHandle getTarget​()
      返回调用点，其行为类似于目标方法 final的领域 ConstantCallSite 。
      void setTarget​(MethodHandle ignore)
      总是扔一个UnsupportedOperationException 。

      • Methods inherited from class java.lang.invoke.CallSite

        type

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ConstantCallSite

        public ConstantCallSite​(MethodHandle target)
        创建一个具有永久目标的呼叫站点。
        参数
        target - 与此呼叫站点永久关联的目标
        异常
        NullPointerException - 如果提出的目标为null

      • ConstantCallSite

        protected ConstantCallSite​(MethodType targetType,
                           MethodHandle createTargetHook)
                    throws Throwable
        创建具有永久目标的呼叫站点，可能绑定到呼叫站点本身。

        在建设通话地点期间，调用createTargetHook以产生实际目标，好像通过(MethodHandle) createTargetHook.invoke(this)表格的(MethodHandle) createTargetHook.invoke(this) 。

        请注意，用户代码不能直接在子类构造函数中执行此类操作，因为目标必须在构建器返回ConstantCallSite之前ConstantCallSite 。

        挂钩被称为将呼叫站点绑定到目标方法句柄，典型的动作是someTarget.bindTo(this) 。 然而，钩子可以随意采取任何行动，包括忽略呼叫站点并返回一个恒定的目标。

        钩子返回的结果必须是与调用站点完全相同类型的方法句柄。

        当钩子被调用时，新的ConstantCallSite对象处于部分构造状态。 在这种状态下，调用getTarget或任何其他使用目标的尝试将导致一个IllegalStateException 。 在任何时候使用type方法获取通话网站的类型是type 。

        参数
        targetType - 与此呼叫站点永久关联的方法句柄的类型
        createTargetHook - 调用（在呼叫站点上）产生呼叫站点目标的方法句柄
        异常
        WrongMethodTypeException - 如果不能在所需的参数上调用钩子，或者如果钩子返回的目标不是给定的 targetType
        NullPointerException - 如果钩子返回一个空值
        ClassCastException - 如果钩子返回 MethodHandle以外的 MethodHandle
        Throwable - 钩子函数抛出的其他东西

    • 方法详细信息

      • getTarget

        public final MethodHandle getTarget​()
        返回调用点，其行为类似于目标方法final的领域ConstantCallSite 。 也就是说，目标始终是传递给创建此实例的构造函数调用的原始值。
        Specified by:
        getTarget在 CallSite
        结果
        这个调用站点的不变的链接状态，一个恒定的方法句柄
        异常
        IllegalStateException - 如果 ConstantCallSite构造函数尚未完成
        另请参见：
        ConstantCallSite ， VolatileCallSite ， CallSite.setTarget(java.lang.invoke.MethodHandle) ， getTarget() ， MutableCallSite.getTarget() ， VolatileCallSite.getTarget()

      • setTarget

        public final void setTarget​(MethodHandle ignore)
        总是抛出一个UnsupportedOperationException 。 这种呼叫站点不能改变其目标。
        Specified by:
        setTarget在 CallSite
        参数
        ignore - 为呼叫网站提出的新目标，被忽略
        异常
        UnsupportedOperationException - 因为这种呼叫站点不能改变其目标
        另请参见：
        CallSite.getTarget() ，
setTarget(java.lang.invoke.MethodHandle) ，
MutableCallSite.setTarget(java.lang.invoke.MethodHandle) ，
VolatileCallSite.setTarget(java.lang.invoke.MethodHandle)

      • dynamicInvoker

        public final MethodHandle dynamicInvoker​()
        返回此呼叫站点的永久目标。 既然这个目标永远不会改变，这是正确的CallSite.dynamicInvoker的实现。
        Specified by:
        dynamicInvoker在 CallSite
        结果
        这个调用站点的不变的链接状态，一个恒定的方法句柄
        异常
        IllegalStateException - if the ConstantCallSite constructor has not completed
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.lang.invoke (Java SE 9 & JDK 9 )

java.lang.invoke

Interfaces

  • MethodHandleInfo

Classes

  • CallSite
  • ConstantCallSite
  • LambdaMetafactory
  • MethodHandle
  • MethodHandleProxies
  • MethodHandles
  • MethodHandles.Lookup
  • MethodType
  • MutableCallSite
  • SerializedLambda
  • StringConcatFactory
  • SwitchPoint
  • VarHandle
  • VolatileCallSite

Enums

  • VarHandle.AccessMode

Exceptions

  • LambdaConversionException
  • StringConcatException
  • WrongMethodTypeException


java.lang.invoke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.lang.invoke

java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。

如Java虚拟机规范中所述，此包中的某些类型与虚拟机中的动态语言支持具有特殊关系：

  • MethodHandle VarHandle包含signature polymorphic methods ，无论其类型描述符如何，都可以链接。 通常，方法链接需要类型描述符的精确匹配。
  • JVM字节码格式支持类别MethodHandle和MethodType的即时常量。

相关Java虚拟机更改摘要

以下低级信息总结了Java虚拟机规范的相关部分。 有关详细信息，请参阅该规范的当前版本。 每次发生invokedynamic指令称为动态呼叫站点 。

invokedynamic说明

动态呼叫站点最初处于未连接状态。 在这种状态下，呼叫站点没有调用的目标方法。

在JVM可以执行动态呼叫站点（ invokedynamic指令）之前，呼叫站点必须首先被链接 。 链接是通过调用引用方法来实现的，该方法被赋予呼叫站点的静态信息内容，并且必须产生给出呼叫站点行为的method handle 。

每个invokedynamic指令静态地将其自己的引导方法指定为常量池引用。 常量池引用还指定了调用站点的名称和类型描述符，就像invokevirtual和其他调用指令一样。

链接起始于解决引导方法的常量池条目，并为动态调用站点的类型描述符解析MethodType对象。 该解析过程可能会触发类加载。 如果类无法加载，它可能会抛出错误。 该错误成为动态呼叫站点执行的异常终止。 Linkage不会触发类初始化。

至少三个值调用引导方法：

  • 一个MethodHandles.Lookup ，一个在动态调用站点发生的调用者类上的查找对象
  • 一个String ，呼叫站点中提到的方法名称
  • 一个MethodType ，解析了类型描述符的调用
  • 可选地，从常量池获取1到251个额外的静态参数
调用就像MethodHandle.invoke一样 。 返回的结果必须是一个CallSite （或一个子类），否则抛出一个BootstrapMethodError 。 呼叫站点目标的类型必须与从动态调用站点的类型描述符派生的类型完全相同，并传递给引导方法，否则抛出一个BootstrapMethodError 。 成功后，呼叫站点将永久链接到动态呼叫站点。

如果一个异常， E说，当链接调用站点时，链接失败并异常终止。 E是重新抛出如果类型E是Error或子类，否则BootstrapMethodError ，它包装E被抛出。 如果发生这种情况，相同的Error或子类将被抛出，用于执行动态调用站点的所有后续尝试。

联动时机

动态呼叫站点在其第一次执行之前已链接。 引导程序调用实现链接发生在正在尝试执行第一次的线程中。

如果有多个这样的线程，引导方法可能会同时在多个线程中调用。 因此，访问全局应用程序数据的引导方法必须采取针对竞争条件的通常预防措施。 无论如何，每个invokedynamic指令都将被取消链接或链接到唯一的CallSite对象。

在需要具有单独可变行为的动态调用站点的应用程序中，它们的引导方法应该产生不同的CallSite对象，每个链接请求一个。 或者，应用程序可以将单个CallSite对象链接到多个invokedynamic指令，在这种情况下，目标方法的更改将在每个指令处显示。

如果多个线程同时为单个动态调用站点执行引导方法，那么JVM必须选择一个CallSite对象并将其可见地安装到所有线程。 允许任何其他引导方法调用完成，但其结果将被忽略，并且其动态调用站点调用继续处理原始选择的目标对象。

讨论：这些规则不能使JVM重复动态调用站点，也不会发出“无效”引导方法调用。 每个动态调用站点在其第一次调用之前，最多只能从一个链接转换为一个链接。 没有办法撤销完成的引导方法调用的效果。

引导方式的类型

只要每个引导方法可以通过MethodHandle.invoke正确调用，其详细类型是任意的。 例如，第一个参数可以是Object而不是MethodHandles.Lookup ，返回类型也可以是Object而不是CallSite 。 （请注意，堆栈参数的类型和数量限制了合法类型的引导方法，以适当类型的静态方法和CallSite子类的构造函数。）

如果给定的invokedynamic指令没有指定静态参数，则将在三个参数上调用指令的引导方法，传达指令的调用者类，名称和方法类型。 如果invokedynamic指令指定一个或多个静态参数，那些值将作为附加参数传递给方法句柄。 （请注意，因为任何方法都有255个参数的限制，因此可以提供最多251个额外的参数，因为引导方法处理本身，并且前三个参数也必须被堆叠。）引导方法将被调用，就像通过或者是MethodHandle.invoke或invokeWithArguments 。 （没有办法说出差异。）

MethodHandle.invoke的常规参数转换规则适用于所有堆栈参数。 例如，如果推送的值是原始类型，则可以通过拳击转换将其转换为引用。 如果引导方法是一个变量arity方法（它的修饰符位0x0080为0x0080 ），那么这里指定的一些或全部参数可能会被收集到尾随数组参数中。 （这不是一个特殊的规则，而是CONSTANT_MethodHandle常量之间的相互作用的有用后果，变量arity方法的修改位和asVarargsCollector变换。）

给定这些规则，这里是法定引导方法声明的示例，给出了各种数字N的额外参数。 第一行（标记为* ）将适用于任何数量的额外参数。

Static argument types N Sample bootstrap method * CallSite bootstrap(Lookup caller, String name, MethodType type, Object... args) * CallSite bootstrap(Object... args) * CallSite bootstrap(Object caller, Object... nameAndTypeWithArgs) 0 CallSite bootstrap(Lookup caller, String name, MethodType type) 0 CallSite bootstrap(Lookup caller, Object... nameAndType) 1 CallSite bootstrap(Lookup caller, String name, MethodType type, Object arg) 2 CallSite bootstrap(Lookup caller, String name, MethodType type, Object... args) 2 CallSite bootstrap(Lookup caller, String name, MethodType type, String... args) 2 CallSite bootstrap(Lookup caller, String name, MethodType type, String x, int y)
最后一个例子假设额外的参数分别是CONSTANT_String和CONSTANT_Integer 。 第二个到最后一个例子假定所有额外的参数都是类型CONSTANT_String 。 其他示例适用于所有类型的额外参数。

如上所述，引导方法的实际方法类型可以变化。 例如，第四个参数可以是MethodHandle ，如果是CONSTANT_InvokeDynamic条目中对应的常量的类型。 在这种情况下， MethodHandle.invoke调用将通过额外的方法句柄常数作为Object ，但是在调用引导方法之前，类型匹配机制为MethodHandle.invoke将引用返回到MethodHandle 。 （如果传递一个字符串常量，那么通过生成的代码不大，那么该转换将失败，导致一个BootstrapMethodError ））

请注意，作为上述规则的结果，引导方法可以接受原始参数，如果它可以由常量池条目表示。 然而，类型的参数boolean ， byte ， short ，或char不能自举方法来创建的，因为这样的常量不能直接在常量池中表示，并且自举方法的调用将不执行必要的基本收缩转换。

额外的引导方法参数旨在允许语言实现者安全和紧凑地编码元数据。 原则上，名称和额外的参数是冗余的，因为每个调用站点都可以被赋予自己独特的引导方法。 这种做法很可能会产生大型的类文件和常量池。

从以下版本开始：
1.7
  • 接口摘要
    接口 描述
    MethodHandleInfo
    通过将直接方法句柄破解成其宪法符号部分获得的象征性参考。
  • 类摘要
    Class 描述
    CallSite
    A CallSite是变量MethodHandle的持有人，称为其target 。
    ConstantCallSite
    A ConstantCallSite是一个CallSite，其目标是永久性的，永远不会被更改。
    LambdaMetafactory
    方便创建通过委派给所提供的MethodHandle实现一个或多个接口的简单“功能对象”，可能在类型适配和参数的部分评估之后。
    MethodHandle
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
    MethodHandleProxies
    此类仅由静态方法组成，可帮助将方法句柄修改为其他JVM类型（如接口）。
    MethodHandles
    该类仅由静态方法组成，或者返回方法句柄。
    MethodHandles.Lookup
    查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。
    MethodType
    方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。
    MutableCallSite
    A MutableCallSite是一个CallSite，其目标变量的行为像一个普通字段。
    SerializedLambda
    lambda表达式的序列化形式。
    StringConcatFactory
    有助于创建String连接方法的方法，可用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
    SwitchPoint
    A SwitchPoint是可以将状态转换发布到其他线程的对象。
    VarHandle
    VarHandle是对变量或参数定义的变量系列的动态强类型引用，包括静态字段，非静态字段，数组元素或非堆组数据结构的组件。
    VolatileCallSite
    A VolatileCallSite是一个CallSite，其目标像一个volatile变量。
  • 枚举摘要
    Enum 描述
    VarHandle.AccessMode
    指定如何访问由VarHandle引用的变量的访问模式集。
  • 异常摘要
    异常 描述
    LambdaConversionException
    LambdaConversionException
    StringConcatException
    当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。
    WrongMethodTypeException
    抛出以表示代码尝试通过错误的方法类型调用方法句柄。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang.invoke Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang.invoke

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.invoke.CallSite
      • java.lang.invoke.ConstantCallSite
      • java.lang.invoke.MutableCallSite
      • java.lang.invoke.VolatileCallSite
    • java.lang.invoke.LambdaMetafactory
    • java.lang.invoke.MethodHandle
    • java.lang.invoke.MethodHandleProxies
    • java.lang.invoke.MethodHandles
    • java.lang.invoke.MethodHandles.Lookup
    • java.lang.invoke.MethodType (implements java.io.Serializable)
    • java.lang.invoke.SerializedLambda (implements java.io.Serializable)
    • java.lang.invoke.StringConcatFactory
    • java.lang.invoke.SwitchPoint
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.invoke.LambdaConversionException
        • java.lang.RuntimeException
          • java.lang.invoke.WrongMethodTypeException
        • java.lang.invoke.StringConcatException
    • java.lang.invoke.VarHandle

Interface Hierarchy

  • java.lang.invoke.MethodHandleInfo

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.invoke.VarHandle.AccessMode
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


LambdaConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class LambdaConversionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.invoke.LambdaConversionException
  • All Implemented Interfaces:
    Serializable

    public class LambdaConversionException
extends 异常
    LambdaConversionException
    从以下版本开始：
    1.8
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      LambdaConversionException​()
      构造一个 LambdaConversionException 。
      LambdaConversionException​(String message)
      构造一个 LambdaConversionException的消息。
      LambdaConversionException​(String message, Throwable cause)
      构造一个 LambdaConversionException与消息和原因。
      LambdaConversionException​(String message, Throwable cause, boolean enableSuppression, boolean writableStackTrace)
      构造一个 LambdaConversionException的消息，原因和其他设置。
      LambdaConversionException​(Throwable cause)
      构造一个 LambdaConversionException的原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • LambdaConversionException

        public LambdaConversionException​()
        构造一个 LambdaConversionException 。

      • LambdaConversionException

        public LambdaConversionException​(String message)
        构造一个 LambdaConversionException的消息。
        参数
        message - 详细信息

      • LambdaConversionException

        public LambdaConversionException​(String message,
                                 Throwable cause)
        构造一个 LambdaConversionException的消息和原因。
        参数
        message - 详细信息
        cause - 原因

      • LambdaConversionException

        public LambdaConversionException​(Throwable cause)
        构造一个 LambdaConversionException的原因。
        参数
        cause - 原因

      • LambdaConversionException

        public LambdaConversionException​(String message,
                                 Throwable cause,
                                 boolean enableSuppression,
                                 boolean writableStackTrace)
        构造一个 LambdaConversionException与消息，原因和其他设置。
        参数
        message - 详细信息
        cause - 原因
        enableSuppression - 是否启用抑制异常
        writableStackTrace - 堆栈跟踪是否可写
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


LambdaMetafactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class LambdaMetafactory

  • java.lang.Object
    • java.lang.invoke.LambdaMetafactory

  • public final class LambdaMetafactory
extends Object

    方法通过委派给所提供的MethodHandle来实现一个或多个接口的简单“功能对象”的创建，可能在类型适配和参数的部分评估之后。 这些方法通常用作invokedynamic调用站点的引导方法 ，以支持Java编程语言的lambda表达式和方法引用表达式功能。

    对所提供的MethodHandle指定行为的间接访问按顺序分三个阶段进行：

    • 当调用此类中的方法时，会发生链接 。 它们将要实现的接口（通常是功能接口 ，具有单个抽象方法的接口 ），从要实现的接口的方法的名称和签名，描述该方法的所需实现行为的方法句柄，以及可能还有其他的元数据，并产生一个CallSite，其目标可以用于创建合适的功能对象。 链接可能涉及动态加载实现目标接口的新类。 CallSite可以被认为是功能对象的“工厂”，因此这些连接方法被称为“元件”。
    • 当CallSite的目标被调用时，通常通过invokedynamic调用站点生成一个函数对象，就会发生捕获 。 对于单个工厂可能会发生多次CallSite 。 Capture可能涉及分配一个新的函数对象，或者可能返回一个现有的函数对象。 行为MethodHandle可能具有超出指定接口方法的附加参数; 这些被称为捕获参数 ，它们必须作为CallSite目标的参数提供，并且可能早于行为MethodHandle 。 在联动期间确定捕获的参数及其类型的数量。
    • 当实现的接口方法的功能对象调用发生调用 。 对于单个函数对象可能会发生多次。 使用捕获的参数和调用时提供的任何其他参数调用由行为MethodHandle引用的方法，如MethodHandle.invoke(Object...)所示 。

    限制在调用时允许的输入或结果集有时是有用的。 例如，当通用接口Predicate<T>被参数化为Predicate<String> ，输入必须是String ，即使实现的方法允许任何Object 。 在链接时，额外的MethodType参数描述了“实例化”方法类型; 在调用时，将根据此MethodType检查参数和最终结果。

    该类提供两种形式的联动方法：使用优化协议的标准版本（ metafactory(MethodHandles.Lookup, String, MethodType, MethodType, MethodHandle, MethodType) ）和替代版本altMetafactory(MethodHandles.Lookup, String, MethodType, Object...) ）。 备用版本是标准版本的泛化，通过标志和附加参数提供对生成的函数对象的行为的附加控制。 备用版本增加了管理功能对象的以下属性的功能：

    • 桥接。 实现方法签名的多个变体有时是有用的，包括参数或返回类型适配。 当方法的多个不同VM签名在逻辑上被认为是语言相同的方法时，会发生这种情况。 标志FLAG_BRIDGES指示将提供额外的MethodType的列表，其中每个将由所得到的功能对象来实现。 这些方法将共享相同的名称和实例化的类型。
    • 多个接口 如果需要，功能对象可以实现多个接口。 （这些附加接口通常是没有方法的标记接口。）标志FLAG_MARKERS指示将提供附加接口的列表，每个附加接口应由生成的函数对象来实现。
    • 串行化。 生成的函数对象通常不支持序列化。 如果需要，可以使用FLAG_SERIALIZABLE来表示功能对象应该是可序列化的。 可串行化的函数对象将使用SerializedLambda类的实例，该类实例需要捕获类（ MethodHandles.Lookup参数caller描述的类）的附加帮助。 详见SerializedLambda 。

    假设链接参数如下：

    • invokedType （描述CallSite签名）具有类型（D1..Dk）和返回类型Rd的K个参数;
    • samMethodType （描述实现的方法类型）具有N个参数，类型（U1..Un）和返回类型Ru;
    • implMethod （ MethodHandle提供的实现具有M个参数，类型（A1..Am）和返回类型Ra（如果该方法描述了一个实例方法，此方法句柄的方法类型已经包含与接收器对应的额外的第一个参数） ;
    • instantiatedMethodType （允许调用限制）具有N个参数，类型（T1..Tn）和返回类型Rt。

    那么以下链接不变量必须保持：

    • Rd是一个接口
    • implMethod是一种直接方法句柄
    • samMethodType和instantiatedMethodType具有相同的instantiatedMethodType N，对于i = 1..N，Ti和Ui是相同类型，或Ti和Ui都是参考类型，Ti是Ui的亚型
    • Rt和Ru是相同的类型，或者两者都是参考类型，Rt是Ru的子类型
    • K + N = M
    • 对于i = 1..K，Di = Ai
    • 对于i = 1..N，Ti适用于Aj，其中j = i + k
    • 返回类型Rt为void，或者返回类型Ra不为空，并且适用于Rt

    此外，在捕获时间，如果implMethod对应于一个实例方法，并且有任何捕获参数（ K > 0 ），则第一个捕获参数（对应于接收器）必须是非空值。

    Q类型被认为适应于S，如下所示：

    adaptable types Q S Link-time checks Invocation-time checks Primitive Primitive Q can be converted to S via a primitive widening conversion None Primitive Reference S is a supertype of the Wrapper(Q) Cast from Wrapper(Q) to S Reference Primitive for parameter types: Q is a primitive wrapper and Primitive(Q) can be widened to S
    for return types: If Q is a primitive wrapper, check that Primitive(Q) can be widened to S If Q is not a primitive wrapper, cast Q to the base Wrapper(S); for example Number for numeric types Reference Reference for parameter types: S is a supertype of Q
    for return types: none Cast from Q to S
    API Note:
    这些链接方法旨在支持Java语言中的lambda表达式和方法引用的评估。 对于源代码中的每个lambda表达式或方法引用，都有一个目标类型，它是一个功能界面。 评估lambda表达式会产生其目标类型的对象。 推荐的lambda表达式的机制是将lambda体拖放到一个方法中，调用一个invokedynamic调用站点，该静态参数列表描述了功能接口和desugared实现方法的唯一方法，并返回一个对象（lambda对象），实现目标类型。 （对于方法引用，实现方法只是引用的方法;不需要desugaring）。

    实现方法的参数列表和接口方法的参数列表可能有多种不同。 实现方法可能有其他参数来适应lambda表达式捕获的参数; 还可能会因允许的参数调整而产生差异，如铸造，拳击，拆箱和原始拓宽。 （Varargs修改不由metafactories处理;这些调整将被调用者处理。）

    Invokedynamic调用站点有两个参数列表：静态参数列表和动态参数列表。 静态参数列表存储在常量池中; 动态参数在捕获时被推送到操作数堆栈上。 引导方法可以访问整个静态参数列表（在这种情况下，包括描述实现方法，目标接口和目标接口方法的信息），以及描述数字和静态类型的方法签名（但不是值）的动态参数和调用动态站点的静态返回类型。

    Implementation Note:
    使用方法句柄描述实现方法。 理论上可以使用任何方法句柄。 目前支持的是直接方法处理，表示虚拟，接口，构造函数和静态方法的调用。
    从以下版本开始：
    1.8

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int FLAG_BRIDGES
      指示lambda对象的备用元素的标志需要额外的桥接方法
      static int FLAG_MARKERS
      指示lambda对象的替代元素的标志实现除Serializable之外的其他标记接口
      static int FLAG_SERIALIZABLE
      指示lambda对象的替代元素的标志必须是可序列化的

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CallSite altMetafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)
      通过委托给所提供的MethodHandle ，在适当的类型适应和参数的部分评估之后，便于创建简单的“功能对象”，实现一个或多个接口。
      static CallSite metafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType)
      在适当的类型适配和参数的部分评估之后，便于创建简单的“功能对象”，通过委派给所提供的MethodHandle实现一个或多个接口。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FLAG_SERIALIZABLE

        public static final int FLAG_SERIALIZABLE
        指示lambda对象的替代元素的标志必须是可序列化的
        另请参见：
        Constant Field Values

      • FLAG_MARKERS

        public static final int FLAG_MARKERS
        指示lambda对象的替代元素的标志实现除Serializable之外的其他标记接口
        另请参见：
        Constant Field Values

      • FLAG_BRIDGES

        public static final int FLAG_BRIDGES
        指示lambda对象的备用元素的标志需要额外的桥接方法
        另请参见：
        Constant Field Values

    • 方法详细信息

      • metafactory

        public static CallSite metafactory​(MethodHandles.Lookup caller,
                                   String invokedName,
                                   MethodType invokedType,
                                   MethodType samMethodType,
                                   MethodHandle implMethod,
                                   MethodType instantiatedMethodType)
                            throws LambdaConversionException
        通过委派给所提供的MethodHandle ，在适当的类型适应和参数的部分评估之后，便于创建简单的“功能对象”，实现一个或多个接口。 通常用作invokedynamic调用站点的引导方法 ，以支持Java编程语言的lambda表达式和方法引用表达式功能。

        这是标准的流线型meta factory; 额外的灵活性由altMetafactory(MethodHandles.Lookup, String, MethodType, Object...)提供。 above提供了该方法的一般描述。

        当目标CallSite调用此方法返回的结果函数对象是它们实现了的返回类型命名的接口的类的实例invokedType ，声明由指定的名称的方法invokedName ，并给出签名samMethodType 。 它也可以从Object覆盖其他方法。

        参数
        caller - 表示具有调用者的辅助功能权限的查找上下文。 当与invokedynamic使用时，VM将自动堆叠。
        invokedName - 要实现的方法的名称。 与invokedynamic使用时，由NameAndType的InvokeDynamic提供，并由VM自动堆叠。
        invokedType -的的预期的签名CallSite 。 参数类型表示捕获变量的类型; 返回类型是要实现的接口。 与invokedynamic使用时，由NameAndType的InvokeDynamic提供，由VM自动堆叠。 在实现方法是实例方法且该签名具有任何参数的情况下，调用签名中的第一个参数必须对应于接收方。
        samMethodType - 由函数对象执行的方法的签名和返回类型。
        implMethod - 一个直接方法句柄，用于描述在调用时应该调用的实现方法（在参数类型，返回类型以及调用参数前面带有捕获参数的适当适配）。
        instantiatedMethodType - 在调用时动态执行的签名和返回类型。 这可能与samMethodType相同，或可能是其专业化。
        结果
        一个CallSite，其目标可以用于执行捕获，生成由 invokedType命名的接口的 invokedType
        异常
        LambdaConversionException - 如果违反了描述的任何链接不变量above

      • altMetafactory

        public static CallSite altMetafactory​(MethodHandles.Lookup caller,
                                      String invokedName,
                                      MethodType invokedType,
                                      Object... args)
                               throws LambdaConversionException
        在适当的类型适应和参数的部分评估后，便于创建简单的“功能对象”，通过委派给所提供的MethodHandle来实现一个或多个接口。 通常用作invokedynamic调用站点的引导方法 ，以支持Java编程语言的lambda表达式和方法引用表达式功能。

        这是一般的，更灵活的meta factory; 精简版本由metafactory(java.lang.invoke.MethodHandles.Lookup, String, MethodType, MethodType, MethodHandle, MethodType)提供。 above提供了这种方法的一般描述。

        该方法的参数列表包括三个固定参数，对应于由invokedynamic调用中的引导方法自动堆叠的参数，以及包含其他参数的Object[]参数。 该方法的声明参数列表是：

           CallSite altMetafactory(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)

        但它的行为就好像参数列表如下所示：

           CallSite altMetafactory(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType, int flags, int markerInterfaceCount, // IF flags has MARKERS set Class... markerInterfaces, // IF flags has MARKERS set int bridgeCount, // IF flags has BRIDGES set MethodType... bridges // IF flags has BRIDGES set )

        出现在metafactory(MethodHandles.Lookup, String, MethodType, MethodType, MethodHandle, MethodType)的参数列表中的参数与该方法具有相同的规范。 附加论据解释如下：

        • flags表示附加选项; 这是所需标志的按位OR。 定义的标志为FLAG_BRIDGES ， FLAG_MARKERS ，并FLAG_SERIALIZABLE 。
        • markerInterfaceCount是函数对象应该实现的附加接口的数量，并且当且仅当设置了FLAG_MARKERS标志时才存在。
        • markerInterfaces是要实现的附加接口的可变长度列表，其长度等于markerInterfaceCount ，并且当且仅当设置了FLAG_MARKERS标志时才存在。
        • bridgeCount是函数对象应该实现的附加方法签名的数量，并且当且仅当设置了FLAG_BRIDGES标志时才存在。
        • bridges是要实现的附加方法签名的可变长度列表，其长度等于bridgeCount ，并且当且仅当设置了FLAG_BRIDGES标志时才存在。

        由markerInterfaces命名的每个类别受到与Rd相同的限制，返回类型为invokedType ，如above所述。 每个MethodType由名为bridges受到相同的限制samMethodType ，如所描述above 。

        当在flags中设置flags ，函数对象将实现Serializable ，并将具有返回适当的SerializedLambda的writeReplace方法。 caller课程必须具有适当的$deserializeLambda$方法，如SerializedLambda中所述 。

        当调用从此方法返回的CallSite的目标时，生成的函数对象是具有以下属性的类的实例：

        • 该类实现了由返回类型invokedType命名的接口和由markerInterfaces命名的任何接口
        • 这个类声明与定名为方法invokedName ，用特定的签名samMethodType给出的和额外的签名bridges
        • 该类可以覆盖Object方法，并且可以实现与序列化相关的方法。
        参数
        caller - 表示具有调用者的辅助功能权限的查找上下文。 当与invokedynamic使用时，VM将自动堆叠。
        invokedName - 要实现的方法的名称。 当与invokedynamic使用时，由NameAndType的InvokeDynamic提供，并由VM自动堆叠。
        invokedType -的的预期的签名CallSite 。 参数类型表示捕获变量的类型; 返回类型是要实现的接口。 当与invokedynamic使用时，由NameAndType的InvokeDynamic提供，并由VM自动堆叠。 在实现方法是实例方法且该签名具有任何参数的情况下，调用签名中的第一个参数必须对应于接收方。
        args -一个 Object[]含有所需参数阵列 samMethodType ， implMethod ， instantiatedMethodType ， flags ，和任何任选的参数，如所描述 altMetafactory(MethodHandles.Lookup, String, MethodType, Object...)以上}
        结果
        一个CallSite，其目标可以用于执行捕获，生成由 invokedType命名的接口的 invokedType
        异常
        LambdaConversionException - If any of the linkage invariants described above are violated
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodHandle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class MethodHandle

  • java.lang.Object
    • java.lang.invoke.MethodHandle

  • public abstract class MethodHandle
extends Object
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。 这些转换是相当普遍的，并且包括这样的模式为conversion ， insertion ， deletion ，并substitution 。

    方法句柄内容

    根据其参数和返回类型，方法句柄是动态和强类型的。 它们不被其基础方法的名称或定义类区分。 必须使用与方法句柄自己的type descriptor相匹配的符号类型描述符来调用方法句柄。

    每个方法句柄通过type访问器报告其类型描述符。 该类型描述符是一个MethodType对象，其结构是一系列类，其中一个是方法的返回类型（如果没有， void.class ）。

    方法句柄的类型控制它接受的调用类型，以及适用于它的转换种类。

    方法句柄包含一对称为invokeExact和invoke的特殊调用方法。 这两个调用方法都可以直接访问方法句柄的底层方法，构造函数，字段或其他操作，通过参数和返回值的转换进行修改。 两个调用者接受与方法句柄自己的类型完全匹配的调用。 普通的，不精确的调用者也接受一系列其他呼叫类型。

    方法句柄是不可变的，没有可见状态。 当然，它们可以绑定到显示状态的底层方法或数据。 对于Java内存模型，任何方法句柄的行为就好像它的所有（内部）字段都是最终变量。 这意味着对应用程序可见的任何方法句柄将始终完全形成。 即使在数据竞赛中通过共享变量发布方法句柄也是如此。

    方法句柄不能被用户子类化。 实现可能（或可能不）创建MethodHandle内部子类，这可以通过Object.getClass操作看到。 程序员不应该从其特定的类中得出关于方法句柄的结论，因为方法句柄类层次结构（如果有的话）可能会不时地或跨不同供应商的实现发生变化。

    方法句柄编译

    命名为invokeExact或invoke Java方法调用表达式可以从Java源代码调用方法句柄。 从源代码的角度来看，这些方法可以接受任何参数，并将其结果转换为任何返回类型。 正式地，这是通过给出调用方法Object返回类型和变量arity Object参数来实现的，但是它们具有称为签名多态性的附加质量，其将该调用自由直接连接到JVM执行堆栈。

    像虚拟方法一样，源级调用invokeExact和invoke编译为一个invokevirtual指令。 更奇怪的是，编译器必须记录实际的参数类型，并且可能不会对参数执行方法调用转换。 相反，它必须根据自己的未转换类型生成将它们推送到堆栈的指令。 方法handle对象本身被推送到栈前的参数。 然后，编译器将生成一个invokevirtual指令，该指令用描述参数和返回类型的符号类型描述符调用方法句柄。

    要发出完整的符号类型描述符，编译器还必须确定返回类型。 这是基于对方法调用表达一个演员，如果有，否则Object如果调用是一个表达式，否则void如果调用的声明。 演员可能是原始类型（但不是void ）。

    为角情况下，uncasted null给出参数的象征性类型描述符java.lang.Void 。 与类型Void的歧义是无害的，因为没有引用类型Void除了空引用。

    方法句柄调用

    第一次执行invokevirtual指令时，它通过符号解析指令中的名称并验证方法调用是静态合法的。 这也适用于拨打invokeExact和invoke 。 在这种情况下，检查编译器发出的符号类型描述符是否正确的语法，并且解析其包含的名称。 因此，只要符号类型描述符在语法上形成良好并且类型存在，则调用方法句柄的invokevirtual指令将始终链接。

    当链接后执行invokevirtual ，接收方法句柄的类型首先由JVM检查，以确保它符合符号类型描述符。 如果类型匹配失败，则意味着调用者调用的方法不会在被调用的单个方法句柄上显示。

    在invokeExact的情况下，调用的类型描述符（解析符号类型名称后）必须与接收方法句柄的方法类型完全匹配。 在普通的情况下，不精确的invoke ，解析的类型描述符必须是接收方的asType方法的有效参数。 因此，平原invoke比invokeExact更invokeExact 。

    类型匹配后，直接调用invokeExact并立即调用方法句柄的底层方法（或其他行为，视情况而定）。

    如果调用者指定的符号类型描述符与方法句柄自己的类型完全匹配，则调用plain invoke工作方式与调用invokeExact相同。 如果有类型不匹配， invoke尝试调整接收方法句柄的类型，好像通过调用asType ，以获得一个精确可调用的方法句柄M2 。 这允许在调用者和被调用者之间进行更强大的方法类型协商。

    （ 注意：调整后的方法句柄M2是不可直接观察到的，因此实现不需要实现。）

    调用检查

    在典型的程序中，方法句柄类型匹配通常会成功。 但是，如果地址不匹配时，JVM将抛出一个WrongMethodTypeException ，直接（在的情况下invokeExact ）或间接仿佛被一个失败的调用asType （在的情况下invoke ）。

    因此，在静态类型程序中可能显示为链接错误的方法类型不匹配可以在使用方法句柄的程序中显示为动态的WrongMethodTypeException 。

    由于方法类型包含“live” Class对象，方法类型匹配同时考虑了类型名称和类加载器。 因此，即使一个方法手柄M在一个类加载器创建L1和使用另一L2 ，方法句柄调用是类型安全的，因为调用者的符号类型描述符，如解决L2 ，与最初的被叫方法的符号类型匹配描述符，解决于L1 。 决议L1时发生M被创建，其类型分配，而在分辨率L2当发生invokevirtual指令链接。

    除了类型描述符检查，方法句柄调用其底层方法的能力是不受限制的。 如果方法句柄是通过访问该方法的类在非公共方法上形成的，那么生成的句柄可以由任何接收到它的引用的调用者在任何地方使用。

    与Core Reflection API不同，每次调用反射方法时都会检查访问权限，因此执行方法句柄访问检查when the method handle is created 。 在ldc （见下文）的情况下，访问检查作为链接恒定方法句柄下的常量池条目的一部分执行。

    因此，非公共方法的处理方式或非公共类的方法一般应保密。 它们不应该传递给不受信任的代码，除非它们来自不受信任的代码的使用将是无害的。

    方法句柄创建

    Java代码可以创建一个方法句柄，直接访问该代码可访问的任何方法，构造函数或字段。 这是通过一个反映出基于能力的API MethodHandles.Lookup完成的 。 例如，静态方法句柄可以从Lookup.findStatic获得。 还有Core Reflection API对象的转换方法，如Lookup.unreflect 。

    像类和字符串一样，对应于可访问字段，方法和构造函数的方法句柄也可以直接在类文件的常量池中表示为要由ldc字节码加载的ldc 。 一种新型的常量存储库项，的CONSTANT_MethodHandle ，直接指的是相关的CONSTANT_Methodref ， CONSTANT_InterfaceMethodref ，或CONSTANT_Fieldref常量存储库项。 （有关方法句柄常量的详细信息，请参阅Java虚拟机规范的第4.4.8和5.4.3.5节。）

    通过查找方法或通过具有变量arity修饰符位（ 0x0080 ）的方法或构造函数产生的方法句柄具有相应的变量特征，就像在asVarargsCollector或withVarargs的帮助下定义一样 。

    方法引用可以指静态方法或非静态方法。 在非静态情况下，方法句柄类型包括一个显式的接收器参数，在任何其他参数之前。 在方法句柄的类型中，初始的接收者参数根据初始请求方法的类来键入。 （例如，如果通过ldc获得非静态方法句柄，则接收器的类型是在常量池条目中命名的类。）

    方法句柄常量受到相同的链接时间访问检查其对应的字节码指令，如果字节码行为将抛出此类错误，则ldc指令将抛出相应的链接错误。

    作为其推论，对受保护成员的访问仅限于访问类或其子类之一的接收者，而访问类又必须是受保护成员的定义类的子类（或包兄弟）。 如果方法引用是指当前包以外的类的受保护的非静态方法或字段，则接收方参数将被缩小为访问类的类型。

    当调用一个虚拟方法的方法句柄时，方法总是在接收器中查找（也就是第一个参数）。

    也可以创建特定虚拟方法实现的非虚拟方法句柄。 这些不执行基于接收器类型的虚拟查找。 这种方法句柄可以模拟invokespecial指令对同一方法的影响。

    用法示例

    以下是一些使用示例：

Object x, y; String s; int i;
MethodType mt; MethodHandle mh;
MethodHandles.Lookup lookup = MethodHandles.lookup();
// mt is (char,char)String
mt = MethodType.methodType(String.class, char.class, char.class);
mh = lookup.findVirtual(String.class, "replace", mt);
s = (String) mh.invokeExact("daddy",'d','n');
// invokeExact(Ljava/lang/String;CC)Ljava/lang/String;
assertEquals(s, "nanny");
// weakly typed invocation (using MHs.invoke)
s = (String) mh.invokeWithArguments("sappy", 'p', 'v');
assertEquals(s, "savvy");
// mt is (Object[])List
mt = MethodType.methodType(java.util.List.class, Object[].class);
mh = lookup.findStatic(java.util.Arrays.class, "asList", mt);
assert(mh.isVarargsCollector());
x = mh.invoke("one", "two");
// invoke(Ljava/lang/String;Ljava/lang/String;)Ljava/lang/Object;
assertEquals(x, java.util.Arrays.asList("one","two"));
// mt is (Object,Object,Object)Object
mt = MethodType.genericMethodType(3);
mh = mh.asType(mt);
x = mh.invokeExact((Object)1, (Object)2, (Object)3);
// invokeExact(Ljava/lang/Object;Ljava/lang/Object;Ljava/lang/Object;)Ljava/lang/Object;
assertEquals(x, java.util.Arrays.asList(1,2,3));
// mt is ()int
mt = MethodType.methodType(int.class);
mh = lookup.findVirtual(java.util.List.class, "size", mt);
i = (int) mh.invokeExact(java.util.Arrays.asList(1,2,3));
// invokeExact(Ljava/util/List;)I
assert(i == 3);
mt = MethodType.methodType(void.class, String.class);
mh = lookup.findVirtual(java.io.PrintStream.class, "println", mt);
mh.invokeExact(System.out, "Hello, world.");
// invokeExact(Ljava/io/PrintStream;Ljava/lang/String;)V
    以上对invokeExact或普通的invoke每个调用生成一个带有下列注释中指示的符号类型描述符的单个invoke指令。 在这些示例中，辅助方法assertEquals被假定为在其参数上调用Objects.equals的方法，并且断言结果为真。

    例外

    方法invokeExact和invoke被声明为抛出Throwable ，这就是说方法句柄可以抛出什么没有静态限制。 由于JVM不区分被检查和未检查的异常（当然，除了它们的类之外），因此将检查的异常归因于方法句柄调用对字节码形状没有特别的影响。 但是在Java源代码中，执行方法处理调用的方法必须明确地抛出Throwable ，否则必须在本地捕获所有可抛出的值，重新抛出仅在上下文中合法的那些，并且包装非法的那些。

    签名多态性

    invokeExact和普通的invoke的异常编译和链接行为由术语签名多态性引用。 如Java语言规范中定义的，签名多态方法是可以与广泛的呼叫签名和返回类型中的任何一种进行操作的方法。

    在源代码中，对签名多态方法的调用将编译，而不管请求的符号类型描述符如何。 像往常一样，Java编译器使用给定的符号类型描述符针对命名方法发出一个invokevirtual指令。 不寻常的部分是符号类型描述符是从实际的参数和返回类型派生而不是方法声明。

    当JVM处理包含签名多态调用的字节码时，它将成功链接任何此类调用，而不管其符号类型描述符如何。 （为了保持类型安全性，JVM将通过适当的动态类型检查来保护此类呼叫，如其他地方所述）。

    字节码生成器（包括编译器后端）需要为这些方法发出未转换的符号类型描述符。 确定符号链接的工具需要接受这些未转换的描述符，而不报告链接错误。

    方法手柄和Core Reflection API之间的互操作

    在Lookup API中使用工厂方法，由Core Reflection API对象表示的任何类成员都可以转换为行为上等效的方法句柄。 例如，反射方法可以使用Lookup.unreflect转换为方法句柄。 所得到的方法句柄通常提供对基础类成员的更直接和有效的访问。

    作为特殊情况，当Core Reflection API用于查看invokeExact的签名多态方法invokeExact或纯invoke时，它们显示为普通非多态方法。 它们的反射外观，如Class.getDeclaredMethod所示 ，不受其在该API中的特殊状态的影响。 例如， Method.getModifiers将准确报告任何类似声明的方法所需的修改位，包括在这种情况下为native和varargs位。

    与任何反映的方法一样，这些方法（反映时）可以通过java.lang.reflect.Method.invoke调用。 但是，这种反射调用不会导致方法句柄调用。 这样的一个调用，如果传递所需的参数（一个单一的，类型为Object[] ），将忽略该参数，并将抛出一个UnsupportedOperationException 。

    由于invokevirtual指令可以在任何符号类型描述符下本地调用方法句柄，所以这种反射视图与通过字节码的这些方法的正常呈现相冲突。 因此，当Class.getDeclaredMethod反映出来时，这两种原生方法可能只被视为占位符。

    为了获得特定类型描述符的调用者方法，请使用MethodHandles.exactInvoker或MethodHandles.invoker 。 对于任何指定的类型描述符， Lookup.findVirtual API还能够返回一个方法句柄来调用invokeExact或者简单的invoke 。

    方法句柄和Java泛型之间的互操作

    可以使用Java通用类型声明的方法，构造函数或字段获取方法句柄。 与Core Reflection API一样，方法句柄的类型将由源级类型的擦除构成。 调用方法句柄时，其参数或返回值转换类型的类型可能是通用类型或类型实例。 如果发生这种情况，编译器将在构建invokevirtual指令的符号类型描述符时，通过其擦除来替换这些类型。

    方法句柄在Java参数化（通用）类型方面并不表示其类似函数的类型，因为类函数类型和参数化Java类型之间存在三个不匹配。

    • 方法类型涵盖所有可能的概率，从无参数到最多允许参数的maximum number 。 泛型不是可变的，所以不能代表这一点。
    • 方法类型可以指定原始类型的参数，哪些Java通用类型不能覆盖。
    • 方法手柄（组合器）的高阶函数通常在广泛的函数类型（包括多个特征的函数类型）中是通用的。 使用Java类型参数来表示这种通用性是不可能的。

    Arity limit

    JVM对任何类型的所有方法和构造函数都施加255个堆栈参数的绝对限制。 在某些情况下，这个限制可能会更具限制性：
    • A long或double参数计数（用于特性限制）作为两个参数插槽。
    • 非静态方法为调用该方法的对象消耗额外的参数。
    • 构造函数为正在构造的对象消耗额外的参数。
    • 由于方法句柄invoke方法（或其他签名 - 多态方法）是非虚拟的，除了任何非虚拟接收方对象之外，它还为方法句柄本身消耗额外的参数。
    这些限制意味着无法创建某些方法句柄，仅因为堆栈参数的JVM限制。 例如，如果静态JVM方法完全接受255个参数，则无法为其创建方法句柄。 尝试使用不可能的方法类型创建方法句柄导致一个IllegalArgumentException 。 特别地，方法句柄的类型不能具有最大255的精确度。
    从以下版本开始：
    1.7
    另请参见：
    MethodType ， MethodHandles

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MethodHandle asCollector​(int collectArgPos, Class<?> arrayType, int arrayLength)
      创建一个 数组收集方法句柄，它接收从给定位置开始的给定数量的位置参数，并将它们收集到数组参数中。
      MethodHandle asCollector​(Class<?> arrayType, int arrayLength)
      使 数组收集方法句柄接受给定数量的尾随位置参数并将其收集到数组参数中。
      MethodHandle asFixedArity​()
      创建一个 固定的arity方法句柄，否则相当于当前的方法句柄。
      MethodHandle asSpreader​(int spreadArgPos, Class<?> arrayType, int arrayLength)
      创建一个 数组扩展方法句柄，它可以在给定的位置接受一个数组参数，并将其元素作为位置参数扩展代替数组。
      MethodHandle asSpreader​(Class<?> arrayType, int arrayLength)
      创建一个 数组扩展方法句柄，它接受一个尾随数组参数，并将其元素作为位置参数传播。
      MethodHandle asType​(MethodType newType)
      生成一个适配器方法句柄，该句柄将当前方法句柄的类型适配为新类型。
      MethodHandle asVarargsCollector​(Class<?> arrayType)
      创建一个 可变的arity适配器，它可以接受任意数量的尾随位置参数并将其收集到数组参数中。
      MethodHandle bindTo​(Object x)
      将值 x绑定到方法句柄的第一个参数，而不调用它。
      Object invoke​(Object... args)
      调用方法句柄，允许任何调用者类型描述符，以及可选地对参数和返回值执行转换。
      Object invokeExact​(Object... args)
      调用方法句柄，允许任何调用者类型描述符，但需要确切的类型匹配。
      Object invokeWithArguments​(Object... arguments)
      执行可变元数调用，传递的参数在给定列表的方法处理，就好像通过不精确 invoke从呼叫位点，其仅提到类型 Object ，且其元数是参数列表的长度。
      Object invokeWithArguments​(List<?> arguments)
      执行变量arity调用，将给定数组中的参数传递给方法句柄，好像通过来自调用站点的不精确的 invoke ，该 引用站点仅提及类型 Object ，其特征是参数数组的长度。
      boolean isVarargsCollector​()
      确定此方法是否支持 variable arity调用。
      String toString​()
      返回方法句柄的字符串表示形式，从字符串 "MethodHandle"开始，以方法句柄类型的字符串表示形式结束。
      MethodType type​()
      报告此方法句柄的类型。
      MethodHandle withVarargs​(boolean makeVarargs)
      如果布尔标志为真，则将此方法的句柄改为 variable arity ，否则为 fixed arity 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • type

        public MethodType type​()
        报告此方法句柄的类型。 通过invokeExact每次调用此方法句柄必须与此类型完全匹配。
        结果
        方法句柄类型

      • invokeExact

        public final Object invokeExact​(Object... args)
                         throws Throwable
        调用方法句柄，允许任何调用者类型描述符，但需要确切的类型匹配。 invokeExact调用站点上的符号类型描述符必须与此方法句柄的type完全匹配。 参数或返回值不允许转换。

        当通过Core Reflection API观察此方法时，它将显示为单个本机方法，获取对象数组并返回一个对象。 如果通过java.lang.reflect.Method.invoke直接通过JNI或间接通过Lookup.unreflect直接调用此本机方法，则会抛出一个UnsupportedOperationException 。

        参数
        args - 使用varargs静态表示的签名 - 多态参数列表
        结果
        签名多态结果，静态表示使用 Object
        异常
        WrongMethodTypeException - 如果目标的类型与调用者的符号类型描述符不相同
        Throwable - 底层方法抛出的东西通过方法句柄调用传播不变

      • invoke

        public final Object invoke​(Object... args)
                    throws Throwable
        调用方法句柄，允许任何调用者类型描述符，以及可选地对参数和返回值执行转换。

        如果呼叫站点的符号类型描述符与此方法句柄的type完全匹配，则呼叫如invokeExact所示 。

        否则，通过调用asType首先调整该方法句柄以将该方法句柄调整为所需类型，然后在调整后的方法句柄上调用invokeExact进行调用。

        实际上没有保证asType电话。 如果JVM可以预测进行调用的结果，则可以直接对调用者的参数进行调整，并根据自己的确切类型调用目标方法句柄。

        调用站点invoke处的解析类型描述符必须是接收器asType方法的有效参数。 特别地，如果被调用者不是variable arity collector ，则调用者必须指定与被调用者的类型相同的参数。

        当通过Core Reflection API观察此方法时，它将显示为单个本机方法，获取对象数组并返回一个对象。 如果通过java.lang.reflect.Method.invoke直接通过JNI或间接通过Lookup.unreflect直接调用此本机方法，则会抛出一个UnsupportedOperationException 。

        参数
        args - 使用varargs静态表示的签名 - 多态参数列表
        结果
        签名多态结果，静态表示为 Object
        异常
        WrongMethodTypeException - 如果目标的类型无法调整到调用者的符号类型描述符
        ClassCastException - 如果目标的类型可以调整到调用者，但参考转换失败
        Throwable - 底层方法抛出的东西通过方法句柄调用传播不变

      • invokeWithArguments

        public Object invokeWithArguments​(Object... arguments)
                           throws Throwable
        执行变量arity调用，将给定列表中的参数传递给方法句柄，好像通过来自调用站点的不精确的invoke ，其中仅提及类型为Object ，其特征是参数列表的长度。

        具体来说，执行如下，通过以下步骤进行，尽管如果JVM可以预测它们的效果，则不保证调用这些方法。

        • 确定参数数组的长度为N 。 对于null引用， N=0 。
        • 确定N参数的一般类型TN ，如TN=MethodType.genericMethodType(N) 。
        • 将原始目标方法手柄MH0为所需类型，如MH1 = MH0.asType(TN) 。
        • 将数组扩展为N独立参数A0, ... 。
        • 调用解压缩参数的类型调整方法句柄：MH1.invokeExact（A0，...）。
        • 取返回值作为Object参考。

        由于asType步骤的操作，必要时将应用以下参数转换：

        • 参考铸造
        • 拆箱
        • 拓宽原始转换

        如果调用返回的结果是原始的，则调用返回的结果为boxed，如果返回类型为void，则强制为null。

        此呼叫等同于以下代码：

 MethodHandle invoker = MethodHandles.spreadInvoker(this.type(), 0);
 Object result = invoker.invokeExact(this, arguments);

        与签名多态方法invokeExact和invoke ， invokeWithArguments可以通过Core Reflection API和JNI正常访问。 因此，它可以用作本机或反射代码和方法句柄之间的桥梁。

        参数
        arguments - 传递给目标的参数
        结果
        目标返回的结果
        异常
        ClassCastException - 如果参数无法通过引用转换转换
        WrongMethodTypeException - 如果目标的类型无法调整为采用给定数量的 Object参数
        Throwable - 目标方法调用抛出的东西
        另请参见：
        MethodHandles.spreadInvoker(java.lang.invoke.MethodType, int)

      • invokeWithArguments

        public Object invokeWithArguments​(List<?> arguments)
                           throws Throwable
        执行变量arity调用，将给定数组中的参数传递给方法句柄，好像通过来自调用站点的不精确的invoke ，其中仅提及类型为Object ，其特征是参数数组的长度。

        此方法也等效于以下代码：

   invokeWithArguments(arguments.toArray())
        参数
        arguments - 传递给目标的参数
        结果
        目标返回的结果
        异常
        NullPointerException - 如果 arguments是空引用
        ClassCastException - 如果参数无法通过引用转换转换
        WrongMethodTypeException - 如果目标的类型不能被调整为采用给定数量的 Object参数
        Throwable - 目标方法调用抛出的东西

      • asType

        public MethodHandle asType​(MethodType newType)
        生成一个适配器方法句柄，该句柄将当前方法句柄的类型适配为新类型。 生成的方法句柄保证报告一个等于所需新类型的类型。

        如果原始类型和新类型相同，则返回this 。

        新方法句柄被调用时，将执行以下步骤：

        • 转换传入参数列表以匹配原始方法句柄的参数列表。
        • 在转换的参数列表中调用原始方法句柄。
        • 将原始方法句柄返回的任何结果转换为新方法句柄的返回类型。

        这种方法提供了invokeExact与普通，不准确的invoke之间的关键行为差异。 当调用者的类型描述符与被调用者完全匹配时，两种方法执行相同的步骤，但是当类型不同时，普通的invoke也会调用asType （或一些内部等效的）来匹配调用者和被调用者的类型。

        如果当前方法是一个可变的arity方法，那么handle参数列表转换可能涉及将数个参数转换并收集到一个数组中，如described elsewhere 。 在所有其他情况下，所有转换都将成对应用，这意味着每个参数或返回值都将转换为一个参数或返回值（或不返回值）。 应用的转换通过查看旧方法和新方法句柄类型的相应组件类型进行定义。

        令T0和T1是相应的新旧参数类型，或旧的和新的返回类型。 具体来说，对于一些有效的索引i ，让T0 =newType.parameterType(i)和T1 =this.type().parameterType(i) 。 否则，以另一种方式返回值，让T0 =this.type().returnType()和T1 =newType.returnType() 。 如果类型相同，则新方法句柄将不会更改相应的参数或返回值（如果有）。 否则，如果可能，将应用以下转换之一：

        • 如果T0和T1是引用，则应用到T1的转换。 （这些类型不需要以任何特定的方式相关联，这是因为null的动态值可以转换为任何引用类型。）
        • 如果T0和T1是原语，则应用Java方法调用转换（JLS 5.3）（如果存在）。 （具体来说， T0必须通过扩展的原语转换转换为T1 ）
        • 如果T0是原语， T1是引用，则如果存在Java转换（JLS 5.5），则应用它。 （具体来说，该值从T0到其包装类包装，然后根据需要加宽到T1） 。
        • 如果T0是引用， T1是原语，则在运行时将应用拆箱转换，可能之后是对基本值进行Java方法调用转换（JLS 5.3）。 （这些是原始的扩展转换。） T0必须是包装类或超类型。 （在T0是Object的情况下，这些是java.lang.reflect.Method.invoke允许的转换。）拆箱转换必须有成功的可能性，这意味着如果T0本身不是封装类，则必须至少存在一个包装类TW是T0的子类型，其未装箱原始值可以扩大到T1 。
        • 如果返回类型T1被标记为void，则返回的值将被丢弃
        • 如果返回类型T0为空， T1为引用，则引入空值。
        • 如果返回类型T0为空， T1为原语，则引入零值。
        （ 注意： T0和T1都可以被视为静态类型，因为它们都不具体对应于任何实际参数或返回值的动态类型 。）

        如果无法进行任何一个所需的成对转换，则无法进行方法句柄转换。

        在运行时，应用于引用参数或返回值的转换可能需要额外的运行时检查，这可能会失败。 拆箱操作可能会失败，因为原始引用为null，导致NullPointerException 。 一个拆箱操作或一个引用转换也可能引用一个错误类型的对象，导致一个ClassCastException 。 虽然拆箱操作可能会接受几种包装，但是如果没有可用的话，那么ClassCastException将被抛出。

        参数
        newType - 新方法句柄的预期类型
        结果
        一个方法句柄，在执行任何必要的参数转换后委托给 this ，并安排任何必要的返回值转换
        异常
        NullPointerException - 如果 newType是空引用
        WrongMethodTypeException - 如果不能进行转换
        另请参见：
        MethodHandles.explicitCastArguments(java.lang.invoke.MethodHandle, java.lang.invoke.MethodType)

      • asSpreader

        public MethodHandle asSpreader​(Class<?> arrayType,
                               int arrayLength)
        创建一个数组扩展方法句柄，它接受一个尾随数组参数，并将其元素作为位置参数传播。 新的方法句柄适应当前方法句柄的目标 。 适配器的类型将与目标的类型相同，但目标类型的最终arrayLength参数被替换为arrayType型的单个数组参数。

        如果数组元素类型与原始目标上的任何相应参数类型不同，则原始目标适用于直接获取数组元素，就像通过调用asType一样 。

        调用时，适配器将数组元素的尾随数组参数替换为每个对象的自身参数。 （参数的顺序保留。）它们通过转换和/或取消装箱成对转换为目标的尾随参数的类型。 最后调用目标。 目标最终返回的内容不会被适配器返回。

        在调用目标之前，适配器会验证数组是否包含足够的元素，以便为目标方法句柄提供正确的参数计数。 200的X-454545新新新新新200新新200新新200新新200新新新200新新200新新200新新200新新200新新新200新新新200新新200新新新新新新评名新旗

        如果调用适配器时，提供的数组参数不具有正确数量的元素，则适配器将抛出一个IllegalArgumentException而不是调用该目标。

        以下是阵列扩展方法句柄的一些简单示例：

MethodHandle equals = publicLookup()
  .findVirtual(String.class, "equals", methodType(boolean.class, Object.class));
assert( (boolean) equals.invokeExact("me", (Object)"me"));
assert(!(boolean) equals.invokeExact("me", (Object)"thee"));
// spread both arguments from a 2-array:
MethodHandle eq2 = equals.asSpreader(Object[].class, 2);
assert( (boolean) eq2.invokeExact(new Object[]{ "me", "me" }));
assert(!(boolean) eq2.invokeExact(new Object[]{ "me", "thee" }));
// try to spread from anything but a 2-array:
for (int n = 0; n <= 10; n++) {
  Object[] badArityArgs = (n == 2 ? null : new Object[n]);
  try { assert((boolean) eq2.invokeExact(badArityArgs) && false); }
  catch (IllegalArgumentException ex) { } // OK
}
// spread both arguments from a String array:
MethodHandle eq2s = equals.asSpreader(String[].class, 2);
assert( (boolean) eq2s.invokeExact(new String[]{ "me", "me" }));
assert(!(boolean) eq2s.invokeExact(new String[]{ "me", "thee" }));
// spread second arguments from a 1-array:
MethodHandle eq1 = equals.asSpreader(Object[].class, 1);
assert( (boolean) eq1.invokeExact("me", new Object[]{ "me" }));
assert(!(boolean) eq1.invokeExact("me", new Object[]{ "thee" }));
// spread no arguments from a 0-array or null:
MethodHandle eq0 = equals.asSpreader(Object[].class, 0);
assert( (boolean) eq0.invokeExact("me", (Object)"me", new Object[0]));
assert(!(boolean) eq0.invokeExact("me", (Object)"thee", (Object[])null));
// asSpreader and asCollector are approximate inverses:
for (int n = 0; n <= 2; n++) {
    for (Class<?> a : new Class<?>[]{Object[].class, String[].class, CharSequence[].class}) {
        MethodHandle equals2 = equals.asSpreader(a, n).asCollector(a, n);
        assert( (boolean) equals2.invokeWithArguments("me", "me"));
        assert(!(boolean) equals2.invokeWithArguments("me", "thee"));
    }
}
MethodHandle caToString = publicLookup()
  .findStatic(Arrays.class, "toString", methodType(String.class, char[].class));
assertEquals("[A, B, C]", (String) caToString.invokeExact("ABC".toCharArray()));
MethodHandle caString3 = caToString.asCollector(char[].class, 3);
assertEquals("[A, B, C]", (String) caString3.invokeExact('A', 'B', 'C'));
MethodHandle caToString2 = caString3.asSpreader(char[].class, 2);
assertEquals("[A, B, C]", (String) caToString2.invokeExact('A', "BC".toCharArray()));
        参数
        arrayType - 通常是 Object[] ，从中提取扩展参数的数组参数的类型
        arrayLength - 从传入数组参数传播的参数数
        结果
        一个新的方法句柄，在调用原始方法句柄之前扩展其最后的数组参数
        异常
        NullPointerException - 如果 arrayType是空引用
        IllegalArgumentException - 如果 arrayType不是数组类型，或者如果目标不具有至少 arrayLength参数类型，或者如果 arrayLength为负，或者如果生成的方法句柄的类型将具有 too many parameters
        WrongMethodTypeException - 如果隐含的 asType调用失败
        另请参见：
        asCollector(java.lang.Class<?>, int)

      • asSpreader

        public MethodHandle asSpreader​(int spreadArgPos,
                               Class<?> arrayType,
                               int arrayLength)
        创建一个数组扩展方法句柄，它可以在给定的位置接受一个数组参数，并将其元素作为位置参数扩展代替数组。 新的方法句柄适应当前方法句柄的目标 。 适配器的类型将与目标的类型相同，不同之处在于从零spreadArgPos位置spreadArgPos开始的目标类型的arrayLength参数由spreadArgPos的单个数组参数arrayType 。

        该方法的行为非常像asSpreader(Class, int) ，但是接受一个额外的spreadArgPos参数来指示参数列表中哪个位置应该发生扩展。

        API Note:
        例：

    MethodHandle compare = LOOKUP.findStatic(Objects.class, "compare", methodType(int.class, Object.class, Object.class, Comparator.class));
    MethodHandle compare2FromArray = compare.asSpreader(0, Object[].class, 2);
    Object[] ints = new Object[]{3, 9, 7, 7};
    Comparator<Integer> cmp = (a, b) -> a - b;
    assertTrue((int) compare2FromArray.invoke(Arrays.copyOfRange(ints, 0, 2), cmp) < 0);
    assertTrue((int) compare2FromArray.invoke(Arrays.copyOfRange(ints, 1, 3), cmp) > 0);
    assertTrue((int) compare2FromArray.invoke(Arrays.copyOfRange(ints, 2, 4), cmp) == 0);
        参数
        spreadArgPos - 扩展应该开始的参数列表中的位置（从零开始的索引）。
        arrayType - 通常是 Object[] ，从中提取扩展参数的数组参数的类型
        arrayLength - 从传入数组参数传播的参数数
        结果
        在调用原始方法句柄之前，将新的方法句柄扩展到给定位置的数组参数
        异常
        NullPointerException - 如果 arrayType是空引用
        IllegalArgumentException - 如果 arrayType不是数组类型，或者如果目标不具有至少 arrayLength参数类型，或者如果 arrayLength为负数，或者如果 spreadArgPos具有非法值（负数或与arrayLength超过参数数量一起），或如果结果方法句柄的类型将具有 too many parameters
        WrongMethodTypeException - 如果隐含的 asType调用失败
        从以下版本开始：
        9
        另请参见：
        asSpreader(Class, int)

      • withVarargs

        public MethodHandle withVarargs​(boolean makeVarargs)
        如果布尔标志为真，则将此方法的句柄改为variable arity ，否则为fixed arity 。 如果方法句柄已经是正确的arity模式，则返回不变。
        API Note:

        当适应可能是可变的方法句柄时，这种方法有时是有用的，以确保当且只有原始句柄时，生成的适配器也是可变的。 例如，该代码将句柄mh的第一个参数更改为int而不会影响其可变的arity属性： mh.asType(mh.type().changeParameterType(0,int.class)) .withVarargs(mh.isVarargsCollector())

        参数
        makeVarargs - 如果返回方法句柄应具有变量arity行为， makeVarargs true
        结果
        相同类型的方法句柄，具有可能调整的变量特征行为
        异常
        IllegalArgumentException - 如果 makeVarargs为真，并且此方法句柄没有尾数组参数
        从以下版本开始：
        9
        另请参见：
        asVarargsCollector(java.lang.Class<?>) ， asFixedArity()

      • asCollector

        public MethodHandle asCollector​(Class<?> arrayType,
                                int arrayLength)
        使数组收集方法句柄接受给定数量的尾随位置参数并将其收集到数组参数中。 新的方法句柄适应当前方法句柄的目标 。 适配器的类型与目标的类型相同，不同之处在于单个尾随参数（通常为arrayType ）由arrayLength类型的元素类型为arrayType参数替换。

        如果数组类型与原始目标的最终参数类型不同，则原始目标适合直接采用数组类型，就像通过调用asType一样 。

        当被调用时，该适配器替换其尾随arrayLength由类型的单个新数组参数arrayType ，其元素包括（按顺序）被替换的参数。 最后调用目标。 目标最终返回的内容不会被适配器返回。

        （当arrayLength为零时，数组也可能是共享常量。）

        （ 注意： arrayType通常与原始目标的最后一个参数类型相同，是asSpreader对称性的明确参数，也允许目标使用简单的Object作为其最后一个参数类型。）

        为了创建不限于特定数量的收集参数的收集适配器，请改用asVarargsCollector或withVarargs 。

        以下是数组收集方法句柄的一些示例：

MethodHandle deepToString = publicLookup()
  .findStatic(Arrays.class, "deepToString", methodType(String.class, Object[].class));
assertEquals("[won]",   (String) deepToString.invokeExact(new Object[]{"won"}));
MethodHandle ts1 = deepToString.asCollector(Object[].class, 1);
assertEquals(methodType(String.class, Object.class), ts1.type());
//assertEquals("[won]", (String) ts1.invokeExact(         new Object[]{"won"})); //FAIL
assertEquals("[[won]]", (String) ts1.invokeExact((Object) new Object[]{"won"}));
// arrayType can be a subtype of Object[]
MethodHandle ts2 = deepToString.asCollector(String[].class, 2);
assertEquals(methodType(String.class, String.class, String.class), ts2.type());
assertEquals("[two, too]", (String) ts2.invokeExact("two", "too"));
MethodHandle ts0 = deepToString.asCollector(Object[].class, 0);
assertEquals("[]", (String) ts0.invokeExact());
// collectors can be nested, Lisp-style
MethodHandle ts22 = deepToString.asCollector(Object[].class, 3).asCollector(String[].class, 2);
assertEquals("[A, B, [C, D]]", ((String) ts22.invokeExact((Object)'A', (Object)"B", "C", "D")));
// arrayType can be any primitive array type
MethodHandle bytesToString = publicLookup()
  .findStatic(Arrays.class, "toString", methodType(String.class, byte[].class))
  .asCollector(byte[].class, 3);
assertEquals("[1, 2, 3]", (String) bytesToString.invokeExact((byte)1, (byte)2, (byte)3));
MethodHandle longsToString = publicLookup()
  .findStatic(Arrays.class, "toString", methodType(String.class, long[].class))
  .asCollector(long[].class, 1);
assertEquals("[123]", (String) longsToString.invokeExact((long)123));

        注意：即使原始目标方法句柄是，生成的适配器从不是variable-arity method handle 。

        参数
        arrayType - 通常是 Object[] ，将会收集参数的数组参数的类型
        arrayLength - 要收集到新数组参数中的参数数
        结果
        一个新的方法句柄，在调用原始方法句柄之前，将一些尾随参数收集到数组中
        异常
        NullPointerException - 如果 arrayType是空引用
        IllegalArgumentException - 如果 arrayType不是数组类型，或者 arrayType不能分配给该方法句柄的尾随参数类型，或者 arrayLength不是合法的数组大小，或者结果方法句柄的类型将具有 too many parameters
        WrongMethodTypeException - 如果隐含的 asType调用失败
        另请参见：
        asSpreader(java.lang.Class<?>, int) ， asVarargsCollector(java.lang.Class<?>)

      • asCollector

        public MethodHandle asCollector​(int collectArgPos,
                                Class<?> arrayType,
                                int arrayLength)
        创建一个数组收集方法句柄，它接收从给定位置开始的给定数量的位置参数，并将它们收集到数组参数中。 新的方法句柄适应当前方法句柄的目标 。 适配器的类型与目标的类型相同，不同之处在于collectArgPos （通常为arrayType ）所示位置的参数被arrayLength的元素类型为arrayType参数所取代。

        此方法的行为非常像asCollector(Class, int) ，但其不同之处在于其collectArgPos参数表示应在哪个位置参数列表参数中收集。 此索引为零。

        API Note:
        例子：

    StringWriter swr = new StringWriter();
    MethodHandle swWrite = LOOKUP.findVirtual(StringWriter.class, "write", methodType(void.class, char[].class, int.class, int.class)).bindTo(swr);
    MethodHandle swWrite4 = swWrite.asCollector(0, char[].class, 4);
    swWrite4.invoke('A', 'B', 'C', 'D', 1, 2);
    assertEquals("BC", swr.toString());
    swWrite4.invoke('P', 'Q', 'R', 'S', 0, 4);
    assertEquals("BCPQRS", swr.toString());
    swWrite4.invoke('W', 'X', 'Y', 'Z', 3, 1);
    assertEquals("BCPQRSZ", swr.toString());

        注意：即使原始的目标方法句柄是，生成的适配器从不是variable-arity method handle 。

        参数
        collectArgPos - 参数列表中从零开始收集的位置。
        arrayType - 通常是 Object[] ，将收集参数的数组参数的类型
        arrayLength - 要收集到新数组参数中的参数数
        结果
        在调用原始方法句柄之前，将一些参数收集到数组中的新方法句柄
        异常
        NullPointerException - 如果 arrayType是空引用
        IllegalArgumentException - 如果 arrayType不是数组类型，或 arrayType不能分配给该方法句柄的数组参数类型，或者 arrayLength不是合法的数组大小，或者 collectArgPos具有非法值（负数或大于参数数），或结果方法句柄的类型将具有 too many parameters
        WrongMethodTypeException - 如果隐含的 asType调用失败
        从以下版本开始：
        9
        另请参见：
        asCollector(Class, int)

      • asVarargsCollector

        public MethodHandle asVarargsCollector​(Class<?> arrayType)
        创建一个可变的arity适配器，它可以接受任意数量的尾随位置参数并将其收集到数组参数中。

        适配器的类型和行为将与目标的类型和行为相同，但某些invoke和asType请求可能会导致尾随的位置参数被收集到目标的尾随参数中。 此外，适配器的最后一个参数类型将为arrayType ，即使目标具有不同的最后一个参数类型。

        这种转化可以返回this ，如果该方法是手柄元数可变的已和它的尾部参数类型是相同的arrayType 。

        当用invokeExact调用时，适配器调用目标，而不改变参数。 （ 注意：此行为与fixed arity collector不同，因为它接受一个不确定长度的整个数组，而不是固定数量的参数）。

        当使用普通的，不准确的invoke调用时，如果调用者类型与适配器相同，则适配器会像invokeExact一样调用目标。 （这是类型匹配时invoke的正常行为。）

        否则，如果调用者和适配器类型相同，并且调用者的尾部参数类型是与适配器的尾部参数类型相同或可分配的引用类型，则参数和返回值将成对转换，如同通过asType在固定的方法手柄上。

        否则，电平不一致，或适配器的尾随参数类型不能从相应的呼叫者类型分配。 在这种情况下，适配器将从原始的尾随参数位置arrayType新的arrayType型arrayType ，其元素包括（按顺序）替换的参数。

        调用者类型必须提供足够的参数和正确类型，以满足目标对尾随数组参数之前位置参数的要求。 因此，呼叫者必须至少提供N-1参数，其中N是目标的真实性。 此外，必须存在从传入参数到目标参数的转换。 与普通invoke其他用途invoke ，如果这些基本要求不能满足，可能会抛出一个WrongMethodTypeException 。

        在所有情况下，最终返回的目标将由适配器保持不变。

        在最后的情况下，正好像目标方法句柄暂时适应了呼叫者类型所要求的一个fixed arity collector 。 （与asCollector ，如果数组长度为零，则可以使用共享常量而不是新数组，如果对asCollector的隐含调用将抛出一个IllegalArgumentException或WrongMethodTypeException ，则对变量arity适配器的调用必须抛出WrongMethodTypeException ））

        asType的行为也是专门针对可变局域适配器，维持不变量，平坦，不精确的invoke总是相当于一个asType调用调整目标类型，其次是invokeExact 。 因此，当且仅当适配器和请求的类型在正态分布或尾随参数类型不同时，可变地区适配器才能响应asType请求。 所得到的固定收集器的类型通过成对转换进一步调整（如果需要）到所请求的类型，好像另外应用了asType 。

        当通过执行CONSTANT_MethodHandle常量的ldc指令获取方法句柄，并将目标方法标记为可变方法（具有修饰符位0x0080 ）时，方法句柄将接受多个特征，就好像方法句柄常数为通过调用asVarargsCollector 。

        为了创建收集预定数量的参数并且其类型反映该预定数量的收集适配器，代之以使用asCollector 。

        没有方法句柄转换可以产生具有可变原型的新方法句柄，除非它们被记录为这样做。 因此，除了asVarargsCollector和withVarargs ，在所有方法MethodHandle和MethodHandles将返回一个方法手柄固定元数，除非他们被指定为返回原来的操作数（例如，案件asType的方法处理自己的类型）。

        调用asVarargsCollector的方法句柄已经是可变的，将产生一个具有相同类型和行为的方法句柄。 它可能（或可能不）返回原始变量arity方法句柄。

        这是一个例子，一个列表制作变量arity方法句柄：

MethodHandle deepToString = publicLookup()
  .findStatic(Arrays.class, "deepToString", methodType(String.class, Object[].class));
MethodHandle ts1 = deepToString.asVarargsCollector(Object[].class);
assertEquals("[won]",   (String) ts1.invokeExact(    new Object[]{"won"}));
assertEquals("[won]",   (String) ts1.invoke(         new Object[]{"won"}));
assertEquals("[won]",   (String) ts1.invoke(                      "won" ));
assertEquals("[[won]]", (String) ts1.invoke((Object) new Object[]{"won"}));
// findStatic of Arrays.asList(...) produces a variable arity method handle:
MethodHandle asList = publicLookup()
  .findStatic(Arrays.class, "asList", methodType(List.class, Object[].class));
assertEquals(methodType(List.class, Object[].class), asList.type());
assert(asList.isVarargsCollector());
assertEquals("[]", asList.invoke().toString());
assertEquals("[1]", asList.invoke(1).toString());
assertEquals("[two, too]", asList.invoke("two", "too").toString());
String[] argv = { "three", "thee", "tee" };
assertEquals("[three, thee, tee]", asList.invoke(argv).toString());
assertEquals("[three, thee, tee]", asList.invoke((Object[])argv).toString());
List ls = (List) asList.invoke((Object)argv);
assertEquals(1, ls.size());
assertEquals("[three, thee, tee]", Arrays.toString((Object[])ls.get(0)));

        讨论：这些规则被设计为可变方法的Java规则的动态类型变体。 在这两种情况下，调用变量arity方法或方法句柄都可以传递零个或多个位置参数，否则可以传递任何长度的预先收集的数组。 用户应该意识到最终参数的特殊角色，以及类型匹配对最终参数的影响，该参数决定了单个尾随参数是否被解释为数组的整个数组或单个元素。集。 请注意，尾随参数的动态类型对此决定没有影响，只是调用站点的符号类型描述符和方法句柄的类型描述符之间的比较。）

        参数
        arrayType - 通常是 Object[] ，将收集参数的数组参数的类型
        结果
        一个新的方法句柄，可以在调用原始方法句柄之前收集任意数量的尾随参数到数组中
        异常
        NullPointerException - 如果 arrayType是空引用
        IllegalArgumentException - 如果 arrayType不是数组类型或 arrayType不能分配给该方法句柄的尾随参数类型
        另请参见：
        asCollector(java.lang.Class<?>, int) ， isVarargsCollector() ， withVarargs(boolean) ， asFixedArity()

      • isVarargsCollector

        public boolean isVarargsCollector​()
        确定此方法是否支持variable arity调用。 这种方法处理来自以下来源：
        • 致电asVarargsCollector
        • 调用一个lookup method ，它解析为一个可变的arity Java方法或构造函数
        • 一个ldc一个的指令CONSTANT_MethodHandle其解析为一个可变参数数量的Java方法或构造
        结果
        如果这个方法句柄接受多于一个的纯粹的，不准确的 invoke调用， invoke
        另请参见：
        asVarargsCollector(java.lang.Class<?>) ， asFixedArity()

      • asFixedArity

        public MethodHandle asFixedArity​()
        创建一个固定的arity方法句柄，否则相当于当前的方法句柄。

        如果当前方法句柄不是variable arity ，则返回当前的方法句柄。 即使当前的方法句柄不能是有效的输入到asVarargsCollector 。

        否则，所得到的固定方法句柄具有与当前方法句柄相同的类型和行为，但isVarargsCollector将为false。 固定方法句柄可以（或可能不是）是asVarargsCollector的先前参数。

        这是一个例子，一个列表制作变量arity方法句柄：

MethodHandle asListVar = publicLookup()
  .findStatic(Arrays.class, "asList", methodType(List.class, Object[].class))
  .asVarargsCollector(Object[].class);
MethodHandle asListFix = asListVar.asFixedArity();
assertEquals("[1]", asListVar.invoke(1).toString());
Exception caught = null;
try { asListFix.invoke((Object)1); }
catch (Exception ex) { caught = ex; }
assert(caught instanceof ClassCastException);
assertEquals("[two, too]", asListVar.invoke("two", "too").toString());
try { asListFix.invoke("two", "too"); }
catch (Exception ex) { caught = ex; }
assert(caught instanceof WrongMethodTypeException);
Object[] argv = { "three", "thee", "tee" };
assertEquals("[three, thee, tee]", asListVar.invoke(argv).toString());
assertEquals("[three, thee, tee]", asListFix.invoke(argv).toString());
assertEquals(1, ((List) asListVar.invoke((Object)argv)).size());
assertEquals("[three, thee, tee]", asListFix.invoke((Object)argv).toString());
        结果
        一个只接受固定数量参数的新方法句柄
        另请参见：
        asVarargsCollector(java.lang.Class<?>) ，
isVarargsCollector() ，
withVarargs(boolean)

      • bindTo

        public MethodHandle bindTo​(Object x)
        将值x绑定到方法句柄的第一个参数，而不调用它。 新的方法句柄通过将其绑定到给定的参数来适配当前方法句柄作为其目标 。 绑定句柄的类型将与目标的类型相同，不同之处在于单个引用参考参数将被省略。

        当被调用时，绑定的句柄将给定值x作为新的引导参数插入目标。 其他论点也不变。 目标最终返回的结果由绑定句柄返回。

        参考x必须可转换为目标的第一个参数类型。

        注意：由于方法句柄是不可变的，所以目标方法句柄保留其原始类型和行为。

        注意：即使原始目标方法句柄是，生成的适配器从不是一个variable-arity method handle 。

        参数
        x - 绑定到目标的第一个参数的值
        结果
        一个新的方法句柄，在调用原始方法句柄之前，将给定值添加到传入参数列表
        异常
        IllegalArgumentException - 如果目标不具有引用类型的引导参数类型
        ClassCastException - 如果 x无法转换为目标的引导参数类型
        另请参见：
        MethodHandles.insertArguments(java.lang.invoke.MethodHandle, int, java.lang.Object...)

      • toString

        public String toString​()
        返回方法句柄的字符串表示形式，从字符串"MethodHandle"开始，以方法句柄类型的字符串表示结束。 换句话说，这个方法返回一个等于下列值的字符串：

 "MethodHandle" + type().toString()

        （ 注意：此API的未来版本可能会向字符串表示形式添加更多信息，因此，本语法不应由应用程序解析。）

        重写：
        toString在 Object
        结果
        方法句柄的字符串表示法
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodHandleInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Interface MethodHandleInfo

  • public interface MethodHandleInfo
    通过将直接方法句柄破解成其宪法符号部分获得的象征性参考。 要破解直接方法句柄，请致电Lookup.revealDirect 。

    直接方法句柄

    直接方法句柄表示一个方法，构造函数或字段，没有任何介入参数绑定或其他转换。 直接方法句柄引用的方法，构造函数或字段称为其基础成员 。 可以通过以下任何方式获得直接方法句柄：
    • 通过在CONSTANT_MethodHandle常数上执行ldc指令。 （请参阅Java虚拟机规范，第4.4.8和5.4.3节。）
    • 通过调用Lookup Factory Methods之一 ，如Lookup.findVirtual ，将一个符号引用解析成方法句柄。 符号引用由类，名称字符串和类型组成。
    • 通过调用Lookup.unreflect或Lookup.unreflectSpecial的工厂方法将方法转换为方法句柄。
    • 通过调用工厂方法Lookup.unreflectConstructor将一个Constructor转换成方法句柄。
    • 通过调用工厂方法Lookup.unreflectGetter或Lookup.unreflectSetter将Field转换为方法句柄。

    开裂限制

    给定一个合适的Lookup对象，可以破解任何直接方法句柄来恢复基础方法，构造函数或字段的符号引用。 必须通过与创建目标方法句柄的对象相当的Lookup对象进行破解，或者具有足够的访问权限来重新创建等效的方法句柄。

    如果底层方法是caller sensitive ，直接方法句柄将被“绑定”到特定的调用者类，用于创建它的查找对象的lookup class 。 即使底层方法是公开的（如Class.forName ），用不同的查找类破解此方法句柄也将失败。

    查找对象匹配的要求为程序提供了一个“快速失败”行为，否则可能会从意外的范围信任符号信息（或调用者绑定）的方法句柄的错误启发。 使用MethodHandles.reflectAs(java.lang.Class<T>, java.lang.invoke.MethodHandle)来覆盖此限制。

    参考种类

    Lookup Factory Methods对应于方法，构造函数和字段的所有主要用例。 这些用例可以使用小整数来区分如下： reference kinds reference kind descriptive name scope member behavior 1 REF_getField class FT f; (T) this.f; 2 REF_getStatic class or interface static
    FT f; (T) C.f; 3 REF_putField class FT f; this.f = x; 4 REF_putStatic class static
    FT f; C.f = arg; 5 REF_invokeVirtual class T m(A*); (T) this.m(arg*); 6 REF_invokeStatic class or interface static
    T m(A*); (T) C.m(arg*); 7 REF_invokeSpecial class or interface T m(A*); (T) super.m(arg*); 8 REF_newInvokeSpecial class C(A*); new C(arg*); 9 REF_invokeInterface interface T m(A*); (T) this.m(arg*);
    从以下版本开始：
    1.8

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int REF_getField
      一个直接方法句柄参考类型，如 table above所定义。
      static int REF_getStatic
      一个直接方法句柄参考类，如 table above所定义。
      static int REF_invokeInterface
      一个直接方法句柄参考类，如 table above所定义。
      static int REF_invokeSpecial
      一个直接方法句柄参考类，如 table above所定义。
      static int REF_invokeStatic
      一个直接方法句柄参考类，如 table above所定义。
      static int REF_invokeVirtual
      一个直接方法句柄参考类，如 table above所定义。
      static int REF_newInvokeSpecial
      一个直接方法句柄参考类，如 table above所定义。
      static int REF_putField
      一个直接方法句柄参考类，如 table above所定义。
      static int REF_putStatic
      一个直接方法句柄参考类，如 table above所定义。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      Class<?> getDeclaringClass​()
      返回定义了破解方法句柄的基础成员的类。
      MethodType getMethodType​()
      返回破解的符号引用的标称类型，表示为方法类型。
      int getModifiers​()
      返回底层成员的访问修饰符。
      String getName​()
      返回破解方法句柄的底层成员的名称。
      int getReferenceKind​()
      返回破解方法句柄的引用类型，这反过来确定方法句柄的底层成员是构造函数，方法还是字段。
      default boolean isVarArgs​()
      确定底层成员是变量arity方法还是构造函数。
      static String referenceKindToString​(int referenceKind)
      返回给定参考类型的描述性名称，如 table above中所定义。
      <T extends Member>
      T             		reflectAs​(Class<T> expected, MethodHandles.Lookup lookup)
      将基础成员反映为方法，构造函数或字段对象。
      static String toString​(int kind, Class<?> defc, String name, MethodType type)
      给出 MethodHandleInfo的字符串表示，给出其符号参考的四个部分。

    • 字段详细信息

      • REF_getField

        static final int REF_getField
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_getStatic

        static final int REF_getStatic
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_putField

        static final int REF_putField
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_putStatic

        static final int REF_putStatic
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_invokeVirtual

        static final int REF_invokeVirtual
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_invokeStatic

        static final int REF_invokeStatic
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_invokeSpecial

        static final int REF_invokeSpecial
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_newInvokeSpecial

        static final int REF_newInvokeSpecial
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

      • REF_invokeInterface

        static final int REF_invokeInterface
        一个直接方法句柄参考类，如 table above所定义。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getReferenceKind

        int getReferenceKind​()
        返回破解方法句柄的引用类型，这反过来确定方法句柄的底层成员是构造函数，方法还是字段。 有关定义，请参阅table above 。
        结果
        用于访问底层成员的引用类的整数代码

      • getDeclaringClass

        Class<?> getDeclaringClass​()
        返回定义了破解方法句柄的基础成员的类。
        结果
        底层成员的声明类

      • getName

        String getName​()
        返回破解方法句柄的底层成员的名称。 这是"<init>"如果底层成员是构造函数，否则它是一个简单的方法名称或字段名称。
        结果
        底层成员的简单名称

      • getMethodType

        MethodType getMethodType​()
        返回破解的符号引用的标称类型，表示为方法类型。 如果引用是构造函数，则返回类型将为void 。 如果是非静态方法，方法类型不会提及this参数。 如果是一个字段，并且所请求的访问是读取该字段，那么方法类型将没有参数并返回字段类型。 如果是一个字段，并且所请求的访问是写入该字段，则方法类型将具有字段类型的一个参数并返回void 。

        请注意，原始直接方法句柄可能包含一个前导的this参数，或者（在构造函数的情况下）将用构造的类替换void返回类型。 标称类型不包括任何this参数，（在构造函数的情况下）将返回void 。

        结果
        底层成员的类型，表示为方法类型

      • reflectAs

        <T extends Member> T reflectAs​(Class<T> expected,
                               MethodHandles.Lookup lookup)
        将基础成员反映为方法，构造函数或字段对象。 如果基础构件是公开的，它被反射，好像被getMethod ， getConstructor ，或getField 。 否则，它被反映为如果由getDeclaredMethod ， getDeclaredConstructor ，或getDeclaredField 。 给定的查找对象必须可访问底层成员。
        参数类型
        T - 所需类型的结果， Member或子类型
        参数
        expected - 表示所需结果类型的类对象 T
        lookup - 创建此MethodHandleInfo或具有等效访问权限的查找对象
        结果
        对方法，构造函数或字段对象的引用
        异常
        ClassCastException - 如果成员不是预期类型
        NullPointerException - 如果任一参数是 null
        IllegalArgumentException - 如果基础成员不可访问给定的查找对象

      • getModifiers

        int getModifiers​()
        返回底层成员的访问修饰符。
        结果
        基础成员的Java语言修饰符，如果成员无法访问，则为-1
        另请参见：
        Modifier ， reflectAs(java.lang.Class<T>, java.lang.invoke.MethodHandles.Lookup)

      • isVarArgs

        default boolean isVarArgs​()
        确定底层成员是变量arity方法还是构造函数。 这些成员由方法句柄表示，它们是可变量收集器。
        实现要求：
        这产生的结果相当于：
           getReferenceKind() >= REF_invokeVirtual && Modifier.isTransient(getModifiers())
        结果
        true当且仅当底层成员被声明为可变的。

      • referenceKindToString

        static String referenceKindToString​(int referenceKind)
        返回给定参考类型的描述性名称，如table above所定义。 常规的前缀“REF_”被省略。
        参数
        referenceKind - 用于访问类成员的一种引用类型的整数代码
        结果
        一个混合大小写的字符串，如 "getField"
        异常
        IllegalArgumentException - 如果参数不是有效的 reference kind number

      • toString

        static String toString​(int kind,
                       Class<?> defc,
                       String name,
                       MethodType type)
        给出MethodHandleInfo的字符串表示，给出其符号参考的四个部分。 这被定义为是这样的形式的"RK C.N:MT" ，其中RK是reference kind string为kind ， C是name的defc N是name ，和MT是type 。 这四个值可以从获得reference kind ， declaring class ， member name ，和method type一个的MethodHandleInfo对象。
        实现要求：
        这产生的结果相当于：
           String.format("%s %s.%s:%s", referenceKindToString(kind), defc.getName(), name, type)
        参数
        kind - reference kind部分符号参考
        defc - declaring class部分符号引用
        name - member name部分符号参考
        type - method type部分符号参考
        结果
        一个字符串形式为 "RK C.N:MT"
        异常
        IllegalArgumentException - 如果第一个参数不是有效的 reference kind number
        NullPointerException - if any reference argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodHandleProxies (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class MethodHandleProxies

  • java.lang.Object
    • java.lang.invoke.MethodHandleProxies

  • public class MethodHandleProxies
extends Object
    此类仅由静态方法组成，可帮助将方法句柄修改为其他JVM类型（如接口）。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static <T> T asInterfaceInstance​(Class<T> intfc, MethodHandle target)
      生成给定的单一方法接口的实例，将其调用重定向到给定的方法句柄。
      static boolean isWrapperInstance​(Object x)
      确定给定对象是否通过调用 asInterfaceInstance生成 。
      static MethodHandle wrapperInstanceTarget​(Object x)
      产生或恢复目标方法句柄，其行为上等同于此包装器实例的唯一方法。
      static Class<?> wrapperInstanceType​(Object x)
      恢复创建此包装器实例的唯一的单一方法接口类型。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • asInterfaceInstance

        public static <T> T asInterfaceInstance​(Class<T> intfc,
                                        MethodHandle target)
        生成给定的单一方法接口的实例，将其调用重定向到给定的方法句柄。

        单一方法接口是一个声明唯一命名方法的接口。 当确定单方法接口的唯一命名的方法，所述公共Object方法（ toString ， equals ， hashCode ）被忽略。 例如， Comparator是单方法接口，即使它重新声明了Object.equals方法。

        界面必须是公开的。 不执行其他访问检查。

        所需类型的结果实例将通过调用传入参数上的给定目标来响应对类型唯一命名方法的调用，并返回或抛出目标返回或抛出的任何内容。 调用将像target.invoke 。 在创建实例之前，将检查目标的类型，就像通过调用asType ，这可能会导致一个WrongMethodTypeException 。

        允许唯一命名的方法被多重声明，具有不同的类型描述符。 （例如，它可能是超载的，或者可以拥有桥接方法。）所有这些声明都直接连接到目标方法句柄。 参数和返回类型由每个单独的声明调整为asType 。

        包装器实例将实现所请求的接口及其超类型，但没有其他单方法接口。 这意味着实例不会意外地通过任何未请求类型的instanceof测试。

        实现注意：因此，每个实例必须实现一个唯一的单一方法接口。 实现可能不会将多个单一方法接口捆绑在单个实现类上，格式为AWTEventMulticaster 。

        方法句柄可能会抛出未声明的异常 ，这意味着未被请求类型的单个抽象方法声明的任何已检查异常（或其他已检查的可抛出异常）。 如果发生这种情况，throwable将被包装在一个UndeclaredThrowableException的实例中，并以该包装形式抛出。

        像Integer.valueOf一样， asInterfaceInstance是一种工厂方法，其结果由其行为定义。 不能保证每次呼叫都返回一个新的实例。

        由于bridge methods和其他角色情况的可能性，该接口也可能具有几个具有相同名称但具有不同描述符（返回和参数类型）的抽象方法。 在这种情况下，所有的方法都与一个给定的目标相同。 类型检查和有效的asType转换应用于每个方法类型描述符，所有抽象方法都与目标共同绑定。 除了这种类型的检查之外，还没有进一步的检查来确定抽象方法是以任何方式相关的。

        此API的未来版本可以接受其他类型，例如具有单个抽象方法的抽象类。 此API的未来版本也可能为包装器实例提供一个或多个其他公共“标记”接口。

        如果安装了一个安全管理器，这个方法是调用者敏感的。 在通过返回的包装器调用目标方法句柄期间，包装器（调用者）的原始创建者对安全管理器请求的上下文检查将可见。

        参数类型
        T - 所需类型的包装器，单一方法接口
        参数
        intfc - 表示 T的类对象
        target - 从包装器调用的方法句柄
        结果
        给定目标的正确类型的包装器
        异常
        NullPointerException - 如果任一参数为空
        IllegalArgumentException - 如果 intfc不是此方法的有效参数
        WrongMethodTypeException - 如果目标无法转换为请求的接口所需的类型

      • isWrapperInstance

        public static boolean isWrapperInstance​(Object x)
        确定给定对象是否通过调用 asInterfaceInstance生成 。
        参数
        x - 任何参考
        结果
        如果引用不为null并且指向由 asInterfaceInstance生成的对象， asInterfaceInstance

      • wrapperInstanceTarget

        public static MethodHandle wrapperInstanceTarget​(Object x)
        产生或恢复目标方法句柄，其行为上等同于此包装器实例的唯一方法。 对象x必须通过调用asInterfaceInstance生成 。 该要求可以通过isWrapperInstance进行测试。
        参数
        x - 任何参考
        结果
        实现唯一方法的方法句柄
        异常
        IllegalArgumentException - 如果引用x不是包装实例

      • wrapperInstanceType

        public static Class<?> wrapperInstanceType​(Object x)
        恢复创建此包装器实例的唯一的单一方法接口类型。 对象x必须通过调用asInterfaceInstance生成 。 此要求可通过isWrapperInstance进行测试。
        参数
        x - 任何参考
        结果
        创建包装器的单一方法接口类型
        异常
        IllegalArgumentException - if the reference x is not to a wrapper instance
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodHandles (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class MethodHandles

  • java.lang.Object
    • java.lang.invoke.MethodHandles

  • public class MethodHandles
extends Object
    该类仅由静态方法组成，或者返回方法句柄。 它们分为几类：
    • 有助于创建方法和字段的方法句柄的查找方法。
    • 组合方法，将预先存在的方法句柄组合或转换为新的方法。
    • 其他工厂方法来创建方法句柄来模拟其他常见的JVM操作或控制流模式。
    从以下版本开始：
    1.7

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  MethodHandles.Lookup
      查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static MethodHandle arrayConstructor​(Class<?> arrayClass)
      生成构造所需类型的数组的方法句柄。
      static MethodHandle arrayElementGetter​(Class<?> arrayClass)
      产生方法句柄，提供对数组元素的读取访问。
      static MethodHandle arrayElementSetter​(Class<?> arrayClass)
      生成方法句柄，为数组的元素提供写访问权限。
      static VarHandle arrayElementVarHandle​(Class<?> arrayClass)
      产生一个VarHandle，可以访问arrayClass类型的数组的 arrayClass 。
      static MethodHandle arrayLength​(Class<?> arrayClass)
      产生返回数组长度的方法句柄。
      static VarHandle byteArrayViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生一个VarHandle，可以访问 byte[]数组的元素，就像它是不同的基元数组类型一样，如 int[]或 long[] 。
      static VarHandle byteBufferViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生VarHandle给予访问的元素 ByteBuffer视为好像它是一个不同的基本组件类型到的元件的阵列 byte ，如 int[]或 long[] 。
      static MethodHandle catchException​(MethodHandle target, Class<? extends Throwable> exType, MethodHandle handler)
      通过在异常处理程序中运行它来创建适应目标方法句柄的方法句柄。
      static MethodHandle collectArguments​(MethodHandle target, int pos, MethodHandle filter)
      通过使用过滤器（另一种方法句柄）预处理其参数的子序列来适应目标方法句柄。
      static MethodHandle constant​(Class<?> type, Object value)
      生成请求的返回类型的方法句柄，每次调用时返回给定的常量值。
      static MethodHandle countedLoop​(MethodHandle iterations, MethodHandle init, MethodHandle body)
      构造一个运行给定次数迭代的循环。
      static MethodHandle countedLoop​(MethodHandle start, MethodHandle end, MethodHandle init, MethodHandle body)
      构造一个计数一系列数字的循环。
      static MethodHandle doWhileLoop​(MethodHandle init, MethodHandle body, MethodHandle pred)
      从初始化器，身体和谓词构造一个 do-while循环。
      static MethodHandle dropArguments​(MethodHandle target, int pos, Class<?>... valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle dropArguments​(MethodHandle target, int pos, List<Class<?>> valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle dropArgumentsToMatch​(MethodHandle target, int skip, List<Class<?>> newTypes, int pos)
      适应目标方法句柄以匹配给定的参数类型列表。
      static MethodHandle empty​(MethodType type)
      产生一个忽略任何参数的请求类型的方法句柄，不执行任何操作，并根据返回类型返回合适的默认值。
      static MethodHandle exactInvoker​(MethodType type)
      生成一个特殊的 调用方法句柄 ，可以用于调用给定类型的任何方法句柄，如同通过 invokeExact一样 。
      static MethodHandle explicitCastArguments​(MethodHandle target, MethodType newType)
      生成方法句柄，通过成对参数和返回类型转换将给定方法句柄的类型适配为新类型。
      static MethodHandle filterArguments​(MethodHandle target, int pos, MethodHandle... filters)
      通过预处理其一个或多个参数来适应目标方法句柄，每个参数具有自己的一元过滤器函数，然后使用每个预处理的参数替换为相应过滤器函数的结果来调用目标。
      static MethodHandle filterReturnValue​(MethodHandle target, MethodHandle filter)
      通过使用过滤器（另一种方法句柄）对其返回值（如果有的话）进行后处理来适应目标方法句柄。
      static MethodHandle foldArguments​(MethodHandle target, int pos, MethodHandle combiner)
      通过预先处理一些参数，从给定的位置开始，然后调用具有预处理结果的目标，将其插入原来的参数序列之前，使其适用于目标方法句柄。
      static MethodHandle foldArguments​(MethodHandle target, MethodHandle combiner)
      通过预处理一些参数来适应目标方法句柄，然后调用具有预处理结果的目标，插入到原始的参数序列中。
      static MethodHandle guardWithTest​(MethodHandle test, MethodHandle target, MethodHandle fallback)
      使用方法句柄来调整目标方法句柄，通过用测试保护它，一个布尔值方法句柄。
      static MethodHandle identity​(Class<?> type)
      生成方法句柄，在调用时返回其唯一参数。
      static MethodHandle insertArguments​(MethodHandle target, int pos, Object... values)
      在方法句柄的调用之前提供一个具有一个或多个 绑定参数的目标方法句柄。
      static MethodHandle invoker​(MethodType type)
      生成一个特殊的 调用方法句柄 ，可以用来调用与给定类型兼容的任何方法句柄，就像通过 invoke一样 。
      static MethodHandle iteratedLoop​(MethodHandle iterator, MethodHandle init, MethodHandle body)
      构造一个范围超过由 Iterator<T>生成的值的 Iterator<T> 。
      static MethodHandles.Lookup lookup​()
      返回一个具有完整功能的lookup object ，以模拟调用者的所有支持的字节码行为。
      static MethodHandle loop​(MethodHandle[]... clauses)
      构造一个表示循环的方法句柄，该循环具有在每次迭代时更新和检查的多个循环变量。
      static MethodHandle permuteArguments​(MethodHandle target, MethodType newType, int... reorder)
      生成方法句柄，通过重新排序参数，将方法句柄调整到新类型的调用顺序。
      static MethodHandles.Lookup privateLookupIn​(Class<?> targetClass, MethodHandles.Lookup lookup)
      返回一个lookup object，具有完整功能，可以模拟目标类上的所有支持的字节码行为，包括private access 。
      static MethodHandles.Lookup publicLookup​()
      返回值得信赖的lookup object 。
      static <T extends Member>
      T             		reflectAs​(Class<T> expected, MethodHandle target)
      执行一个未经检查的“裂缝”的 direct method handle 。
      static MethodHandle spreadInvoker​(MethodType type, int leadingArgCount)
      产生一个方法句柄，它将调用给定的 type任何方法句柄，给定数量的尾随参数被单个尾随的 Object[]数组替换。
      static MethodHandle throwException​(Class<?> returnType, Class<? extends Throwable> exType)
      产生方法句柄，将抛出给定的异常 exType 。
      static MethodHandle tryFinally​(MethodHandle target, MethodHandle cleanup)
      创建一个方法句柄，通过将其包装在一个 try-finally块中来适应 target方法句柄。
      static MethodHandle varHandleExactInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
      static MethodHandle varHandleInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
      static MethodHandle whileLoop​(MethodHandle init, MethodHandle pred, MethodHandle body)
      从初始化器，身体和谓词构造一个 while循环。
      static MethodHandle zero​(Class<?> type)
      生成请求的返回类型的常量方法句柄，每次调用时返回该类型的默认值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • lookup

        public static MethodHandles.Lookup lookup​()
        返回一个lookup object，具有完整的功能，可以模拟调用者的所有支持的字节码行为。 这些功能包括来电者的private access 。 查找对象上的工厂方法可以为调用者通过字节码（包括受保护和私有字段和方法）访问的任何成员创建direct method handles 。 该查找对象是可以被委托给可信代理的能力 。 不要将其存储在不受信任的代码可以访问的位置。

        这种方法是调用者敏感的，这意味着它可能会向不同的呼叫者返回不同的值。

        对于任何给定的调用者类别C ，此调用返回的查找对象具有与JVM提供的任何查找对象相同的功能，即在同一调用方类别C执行的invokedynamic instruction的引导方法。

        结果
        一个用于此方法的调用者的查找对象，具有私有访问权限

      • publicLookup

        public static MethodHandles.Lookup publicLookup​()
        返回值得信赖的lookup object 。 查找具有PUBLIC和UNCONDITIONAL模式。 它只能用于在无条件导出的包中为公共类的公共成员创建方法句柄。

        作为纯粹的约定，这个查找对象的lookup class将是Object 。

        API Note:
        Object的使用是常规的，并且由于查找模式有限，所以没有向Object，其包或其模块的内部提供特殊访问。 因此，该查找对象的查找上下文将是引导类加载器，这意味着它无法找到用户类。

        讨论：查找类可以使用C表达式更改为任何其他类C 。 但是可以通过更改类加载器来更改查找上下文。 公共查找对象总是受到security manager checks的约束 。 另外，它不能访问caller sensitive methods 。

        结果
        一个可信赖的查找对象

      • privateLookupIn

        public static MethodHandles.Lookup privateLookupIn​(Class<?> targetClass,
                                                   MethodHandles.Lookup lookup)
                                            throws IllegalAccessException
        返回一个lookup object，具有完整功能，可以在目标类上模拟所有支持的字节码行为，包括private access 。 此方法检查指定为Lookup对象的调用者是否允许对目标类进行深层反射 。 如果m1是包含模块lookup class ，和m2是包含目标类的模块，则该检查可确保
        • m1 reads m2 。
        • m2 opens包含目标类的包至少m1 。
        • 查找具有MODULE查找模式。

        如果有一个安全管理器，它的checkPermission方法被调用来检查ReflectPermission("suppressAccessChecks") 。

        API Note:
        MODULE查找模式用于验证查找对象是由调用者模块中的代码创建的（或从最初由调用者创建的查找对象派生）。 具有MODULE查找模式的查找对象可以与受信任方共享，而不会给予呼叫者PRIVATE和PACKAGE访问。
        参数
        targetClass - 目标类
        lookup - 调用者查找对象
        结果
        目标类的查找对象，具有私有访问权限
        异常
        IllegalArgumentException - 如果 targetClass是primitve类型或数组类
        NullPointerException - 如果 targetClass或 caller是 null
        IllegalAccessException - 如果以上指定的访问检查失败
        SecurityException - 如果安全管理员否认
        从以下版本开始：
        9
        另请参见：
        MethodHandles.Lookup.dropLookupMode(int)

      • reflectAs

        public static <T extends Member> T reflectAs​(Class<T> expected,
                                             MethodHandle target)
        执行一个未经检查的“裂纹”的direct method handle 。 结果就好像用户已经获得了足够能够破解目标方法句柄的查找对象，目标上称为Lookup.revealDirect ，以获取其符号引用，然后称为MethodHandleInfo.reflectAs来解析对成员的符号引用。

        如果有安全管理员，它的checkPermission方法被调用了一个ReflectPermission("suppressAccessChecks")权限。

        参数类型
        T - 所需类型的结果， Member或子类型
        参数
        target - 一种直接的方法手柄来破解符号参考组件
        expected - 表示所需结果类型 T的类对象
        结果
        对方法，构造函数或字段对象的引用
        异常
        SecurityException - 如果呼叫者没有权限调用 setAccessible
        NullPointerException - 如果任一参数是 null
        IllegalArgumentException - 如果目标不是直接方法句柄
        ClassCastException - 如果成员不是预期类型
        从以下版本开始：
        1.8

      • arrayConstructor

        public static MethodHandle arrayConstructor​(Class<?> arrayClass)
                                     throws IllegalArgumentException
        生成构造所需类型的数组的方法句柄。 方法句柄的返回类型将是数组类型。 其唯一参数的类型为int ，它指定数组的大小。
        参数
        arrayClass - 数组类型
        结果
        一个可以创建给定类型的数组的方法句柄
        异常
        NullPointerException - 如果参数是 null
        IllegalArgumentException - 如果 arrayClass不是数组类型
        从以下版本开始：
        9
        另请参见：
        Array.newInstance(Class, int)

      • arrayLength

        public static MethodHandle arrayLength​(Class<?> arrayClass)
                                throws IllegalArgumentException
        产生返回数组长度的方法句柄。 方法句柄的类型将具有int作为返回类型，其唯一的参数将是数组类型。
        参数
        arrayClass - 数组类型
        结果
        一个方法句柄，可以检索给定数组类型的数组的长度
        异常
        NullPointerException - 如果参数是 null
        IllegalArgumentException - 如果arrayClass不是数组类型
        从以下版本开始：
        9

      • arrayElementGetter

        public static MethodHandle arrayElementGetter​(Class<?> arrayClass)
                                       throws IllegalArgumentException
        产生方法句柄，提供对数组元素的读取访问。 方法句柄的类型将具有数组的元素类型的返回类型。 它的第一个参数将是数组类型，第二个参数将是int 。
        参数
        arrayClass - 数组类型
        结果
        一个方法句柄，可以从给定的数组类型加载值
        异常
        NullPointerException - 如果参数为null
        IllegalArgumentException - 如果arrayClass不是数组类型

      • arrayElementSetter

        public static MethodHandle arrayElementSetter​(Class<?> arrayClass)
                                       throws IllegalArgumentException
        生成方法句柄，为数组的元素提供写访问权限。 方法句柄的类型将具有void返回类型。 它的最后一个参数将是数组的元素类型。 第一个和第二个参数将是数组类型和int。
        参数
        arrayClass - 数组的类
        结果
        一个可以将值存储到数组类型中的方法句柄
        异常
        NullPointerException - 如果参数为空
        IllegalArgumentException - 如果arrayClass不是数组类型

      • arrayElementVarHandle

        public static VarHandle arrayElementVarHandle​(Class<?> arrayClass)
                                       throws IllegalArgumentException
        产生一个VarHandle，可以访问arrayClass类型的数组的arrayClass 。 VarHandle的变量类型是组件类型arrayClass ，坐标类型列表为(arrayClass, int) ，其中int坐标类型对应于作为数组索引的参数。

        在以下情况下，不支持返回的VarHandle的某些访问模式：

        • 如果组件类型以外的任何其他byte ， short ， char ， int ， long ， float ，或double然后数字原子更新的接入方式是不受支持的。
        • 如果字段的类型是以外的任何其他boolean ， byte ， short ， char ， int或long然后逐位原子更新的接入方式是不受支持的。

        如果组件类型为float或double则数字和原子更新访问模式使用其按位表示比较值（分别见Float.floatToRawIntBits(float)和Double.doubleToRawLongBits(double) ）。

        API Note:
        由数字和原子更新访问模式执行的float值或double值的按位比较不同于原语==运算符和Float.equals(java.lang.Object)和Double.equals(java.lang.Object)方法，特别是关于比较NaN值或比较-0.0与+0.0 。 当执行比较和设置或与这些值的比较和交换操作时，应注意，因为操作可能会意外失败。 在Java中，许多可能的NaN值被认为是NaN ，尽管Java提供的IEEE 754浮点运算没有区别它们。 如果预期值或见证值为NaN值，并且将其转换（可能以平台特定方式）为另一个NaN值，因此具有不同的逐位表示（参见Float.intBitsToFloat(int)或Double.longBitsToDouble(long)更多详细信息），则可能会发生操作失败。 值-0.0和+0.0具有不同的位图表示，但在使用基元==运算符时被认为是相等的。 如果，例如，数字算法计算的预期值是说可能会出现操作故障-0.0和先前计算的见证价值被说+0.0 。
        参数
        arrayClass - 一个数组的类，类型为 T[]
        结果
        一个VarHandle可以访问数组的元素
        异常
        NullPointerException - 如果arrayClass为空
        IllegalArgumentException - 如果arrayClass不是数组类型
        从以下版本开始：
        9

      • byteArrayViewVarHandle

        public static VarHandle byteArrayViewVarHandle​(Class<?> viewArrayClass,
                                               ByteOrder byteOrder)
                                        throws IllegalArgumentException
        产生一个VarHandle，可以访问byte[]数组的元素，就像它是一个不同的基本数组类型，如int[]或long[] 。 VarHandle的变量类型是组件类型viewArrayClass ，坐标类型列表为(byte[], int) ，其中int坐标类型对应于作为byte[]数组的索引的参数。 返回的VarHandle将访问byte[]数组中的索引处的字节，根据给定的字节顺序组合字节到组件类型viewArrayClass的值。

        支持的组件类型（变量类型）是short ， char ， int ， long ， float和double 。

        一个给定的索引处的字节的访问将导致IndexOutOfBoundsException ，如果指数小于0比大于或byte[]的阵列长度减去的大小（以字节计） T 。

        对于T ，索引中的字节访问可能对齐或不对齐，相对于与阵列和索引相关联的底层内存地址A 。 如果访问未对齐，则访问除get和set访问模式之外的任何内容将导致IllegalStateException 。 在这种情况下，原子访问只能保证二分之一的最大功率为A ，GCD为A ，而大小（以字节为单位）为T 。 如果访问对齐，则支持以下访问模式，并保证支持原子访问：

        • 读取所有T写访问模式，但访问模式get和set用于long和double在32位平台上。
        • 原子更新的接入方式为int ， long ， float或double 。 （JDK的未来主要平台版本可能会支持某些当前不支持的访问模式的其他类型。）
        • int和long数字原子更新访问模式。 （JDK的未来主要平台版本可能会支持某些当前不支持的访问模式的附加数字类型。）
        • int和long逐位原子更新访问模式。 （JDK的未来主要平台版本可能会支持某些当前不支持的访问模式的附加数字类型。）

        对于byte[]阵列， byte[]不对齐的访问，因此原子性保证，而不在特定数组上操作。 给定一个index ， T和它的对应的盒装类型， T_BOX ，如下错位可以被确定：

           int sizeOfT = T_BOX.BYTES; // size in bytes of T int misalignedAtZeroIndex = ByteBuffer.wrap(new byte[0]). alignmentOffset(0, sizeOfT); int misalignedAtIndex = (misalignedAtZeroIndex + index) % sizeOfT; boolean isMisaligned = misalignedAtIndex != 0;

        如果变量类型是float或double那么原子更新访问模式使用它们的按位表示比较值（分别见Float.floatToRawIntBits(float)和Double.doubleToRawLongBits(double) ）。

        参数
        viewArrayClass - 视图数组类，组件类型为 T
        byteOrder - 视图数组元素的字节顺序，存储在底层的 byte数组中
        结果
        一个VarHandle可以访问一个 byte[]数组的元素，如同对应于视图数组类的组件类型的元素
        异常
        NullPointerException - 如果viewArrayClass或byteOrder为null
        IllegalArgumentException - 如果viewArrayClass不是数组类型
        UnsupportedOperationException - 如果 UnsupportedOperationException的组件类型不支持作为变量类型
        从以下版本开始：
        9

      • byteBufferViewVarHandle

        public static VarHandle byteBufferViewVarHandle​(Class<?> viewArrayClass,
                                                ByteOrder byteOrder)
                                         throws IllegalArgumentException
        产生VarHandle给予访问的元素ByteBuffer视为好像它是一个不同的基本组件类型到的元件的阵列byte ，如int[]或long[] 。 VarHandle的变量类型是组件类型viewArrayClass ，坐标类型列表为(ByteBuffer, int) ，其中int坐标类型对应于作为byte[]数组的索引的参数。 返回VarHandle的指数下访问以字节ByteBuffer ，构成字节或从的部件类型的值viewArrayClass根据给定的字节顺序。

        支持的组件类型（变量类型）是short ， char ， int ， long ， float和double 。

        如果ByteBuffer为只读，访问将导致ReadOnlyBufferException用于读取访问模式之外的任何其他操作。

        一个给定的索引处的字节的访问将导致IndexOutOfBoundsException ，如果指数小于0比大于或ByteBuffer的限值减去的大小（以字节计） T 。

        对于T ，索引中的字节访问可能对齐或不对齐，相对于底层内存地址， A表示与ByteBuffer和索引相关联。 如果访问未对齐，则访问除get和set访问模式之外的任何内容将导致IllegalStateException 。 在这种情况下的原子访问仅相对于划分的GCD的两个最大功率保证A的和的大小（以字节计） T 。 如果访问对齐，则支持以下访问模式，并保证支持原子访问：

        • 读取所有T写入访问模式，除了访问模式get和set用于long和double在32位平台上。
        • 原子更新的接入方式为int ， long ， float或double 。 （JDK的未来主要平台版本可能会支持某些当前不支持的访问模式的其他类型。）
        • int和long数字原子更新访问模式。 （JDK的未来主要平台版本可能会支持某些当前不支持的访问模式的附加数字类型。）
        • 按位原子更新访问模式为int和long 。 （JDK的未来主要平台版本可能会支持某些当前不支持的访问模式的附加数字类型。）

        未对齐存取，因此原子性保证，可以为被确定ByteBuffer ， bb （直接或以其它方式），一个index ， T和它的对应的盒装类型， T_BOX ，如下所示：

           int sizeOfT = T_BOX.BYTES; // size in bytes of T ByteBuffer bb = ... int misalignedAtIndex = bb.alignmentOffset(index, sizeOfT); boolean isMisaligned = misalignedAtIndex != 0;

        如果变量类型为float或double那么原子更新访问模式使用其逐位表示比较值（分别见Float.floatToRawIntBits(float)和Double.doubleToRawLongBits(double) ）。

        参数
        viewArrayClass - 视图数组类，组件类型为 T
        byteOrder - 视图数组元素的字节顺序，存储在底层的 ByteBuffer （注意这覆盖了一个 ByteBuffer的字节顺序）
        结果
        一个VarHandle给予访问的元素 ByteBuffer仿佛对应于该部件类型的视图阵列类的元素观察
        异常
        NullPointerException - 如果viewArrayClass或byteOrder为null
        IllegalArgumentException - 如果viewArrayClass不是数组类型
        UnsupportedOperationException - 如果 UnsupportedOperationException的组件类型不支持作为变量类型
        从以下版本开始：
        9

      • spreadInvoker

        public static MethodHandle spreadInvoker​(MethodType type,
                                         int leadingArgCount)
        产生一个方法句柄，它将调用给定的type任何方法句柄，给定的尾随参数被单个尾随的Object[]数组替换。 生成的调用者将是一个方法句柄，其中包含以下参数：
        • 一个MethodHandle目标
        • 零个或多个领先价值（按leadingArgCount计算）
        • 一个包含尾随参数的Object[]数组

        调用者将调用其目标像一个电话invoke与指示type 。 也就是说，如果目标是给定的type ，它的行为就像invokeExact ; 否则表现为使用asType将目标转换为所需的type 。

        类型返回调用者将不给定type ，而是将具有除第一所有参数leadingArgCount由类型的单个阵列代替Object[] ，这将是最终的参数。

        在调用其目标之前，调用者将传播最终的数组，根据需要应用引用转换，并解开并扩展原始参数。 如果调用调用者时，所提供的数组参数不具有正确数量的元素，调用者将抛出一个IllegalArgumentException而不是调用目标。

        此方法等同于以下代码（尽管可能更有效）：

MethodHandle invoker = MethodHandles.invoker(type);
int spreadArgCount = type.parameterCount() - leadingArgCount;
invoker = invoker.asSpreader(Object[].class, spreadArgCount);
return invoker;
        此方法不会引发反思或安全异常。
        参数
        type - 所需的目标类型
        leadingArgCount - 固定参数的数量，不会更改为目标
        结果
        适用于调用给定类型的任何方法句柄的方法句柄
        异常
        NullPointerException - 如果 type为空
        IllegalArgumentException - 如果 leadingArgCount不在0到 type.parameterCount() ，或者如果所得到的方法手柄的类型将具有 too many parameters

      • exactInvoker

        public static MethodHandle exactInvoker​(MethodType type)
        生成一个特殊的调用者方法句柄 ，可以用于调用给定类型的任何方法句柄，如invokeExact所示 。 所得到的调用者将具有与所需类型完全相同的类型，除了它将接受类型为MethodHandle的另外的前导参数。

        此方法相当于以下代码（尽管可能更有效）： publicLookup().findVirtual(MethodHandle.class, "invokeExact", type)

        讨论：当使用未知类型的变量方法句柄时，Invoker方法句柄可能很有用。 例如，要模拟一个invokeExact调用变量方法句柄M ，提取其类型为T ，查询调用方法X为T ，并调用invoker方法，如X.invoke(T, A...) 。 （调用X.invokeExact ，因为类型为T未知。）如果需要进行扩展，收集或其他参数转换，则可以将其应用于调用者X ，并重用于许多M方法句柄值，只要它们与X的类型兼容。

        （注意：通过Core Reflection API不能使用调用者方法，在声明的invokeExact或invoke方法上调用java.lang.reflect.Method.invoke的方法将会产生一个UnsupportedOperationException ））

        此方法不会引发反思或安全异常。

        参数
        type - 所需的目标类型
        结果
        适用于调用给定类型的任何方法句柄的方法句柄
        异常
        IllegalArgumentException - 如果生成的方法句柄的类型将具有 too many parameters

      • invoker

        public static MethodHandle invoker​(MethodType type)
        生成一个特殊的调用方法句柄 ，可以用于调用与给定类型兼容的任何方法句柄，就像通过invoke一样 。 生成的调用者将具有与所需类型完全相同的类型，但它将接受类型为MethodHandle的其他前导参数。

        在调用其目标之前，如果目标与预期的类型不同，则调用者将根据需要应用引用转换，并且将box，unbox或者扩展原始值，如同通过asType一样 。 类似地，返回值将根据需要进行转换。 如果目标是variable arity method handle ，则将进行所需的转换，再次如asType所示 。

        此方法等同于以下代码（尽管可能更有效）： publicLookup().findVirtual(MethodHandle.class, "invoke", type)

        讨论： A general method type是一个仅提及Object参数和返回值的参数。 这种类型的调用者能够调用与一般类型相同的任何方法句柄。

        （注意：通过Core Reflection API不可以使用调用者方法，在声明的invokeExact或invoke方法上调用java.lang.reflect.Method.invoke的方式将会引发一个UnsupportedOperationException ））

        此方法不会引发反思或安全异常。

        参数
        type - 所需的目标类型
        结果
        适用于调用可转换为给定类型的任何方法句柄的方法句柄
        异常
        IllegalArgumentException - 如果结果方法句柄的类型将具有 too many parameters

      • varHandleExactInvoker

        public static MethodHandle varHandleExactInvoker​(VarHandle.AccessMode accessMode,
                                                 MethodType type)
        产生一个特殊的调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。 生成的调用者将具有与所需给定类型完全相同的类型，但它将接受类型为VarHandle的其他前导参数。
        参数
        accessMode - VarHandle访问模式
        type - 所需的目标类型
        结果
        适用于调用其访问模式类型为给定类型的任何VarHandle的访问模式方法的方法句柄。
        从以下版本开始：
        9

      • varHandleInvoker

        public static MethodHandle varHandleInvoker​(VarHandle.AccessMode accessMode,
                                            MethodType type)
        产生一个特殊的调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。 生成的调用者将具有与所需给定类型完全相同的类型，但它将接受类型为VarHandle的其他前导参数。

        在调用其目标之前，如果访问模式类型与所需的给定类型不同，则调用者将根据需要应用引用转换，并且将box，unbox或者扩展原始值，如同通过asType一样 。 类似地，返回值将根据需要进行转换。

        此方法等效于以下代码（尽管可能会更有效）： publicLookup().findVirtual(VarHandle.class, accessMode.name(), type)

        参数
        accessMode - VarHandle访问模式
        type - 所需的目标类型
        结果
        适用于调用其访问模式类型可转换为给定类型的任何VarHandle的访问模式方法的方法句柄。
        从以下版本开始：
        9

      • explicitCastArguments

        public static MethodHandle explicitCastArguments​(MethodHandle target,
                                                 MethodType newType)
        生成方法句柄，通过成对参数和返回类型转换将给定方法句柄的类型适配为新类型。 原始类型和新类型必须具有相同数量的参数。 生成的方法句柄保证报告一个等于所需新类型的类型。

        如果原始类型和新类型相等，则返回目标。

        允许使用与MethodHandle.asType相同的转换，如果这些转换失败，还会应用一些其他转化。 给定类型T0 ， T1 ，如果可能，应用以下转换之一，之前或代替asType完成的任何转换：

        • 如果T0和T1是引用，并且T1是接口类型，则类型T0的值作为T1传递，而不进行转换。 （这种接口的处理遵循字节码验证器的使用。）
        • 如果T0是布尔值， T1是另一个原语，则布尔值转换为字节值，1为真，0为false。 （此处理遵循字节码验证器的使用。）
        • 如果T1是布尔值， T0是另一个原语，则通过Java转换（JLS 5.5）将T0转换为字节，并测试结果的低位，如同(x & 1) != 0 。
        • 如果T0和T1是除布尔值之外的基元，则应用Java转换（JLS 5.5）。 （具体来说， T0将通过加宽和/或变窄而转换为T1 ）
        • 如果T0是引用， T1是原语，则在运行时将应用拆箱转换，可能之后是对原始值进行Java转换（JLS 5.5），之后可以通过测试低阶转换为字节到布尔位。
        • 如果T0是引用， T1是一个原语，并且如果引用在运行时为空，则引入零值。
        参数
        target - 重新输入参数后调用的方法句柄
        newType - 新方法句柄的预期类型
        结果
        在执行任何必要的参数转换后委托给目标的方法句柄，并安排任何必要的返回值转换
        异常
        NullPointerException - 如果任一参数为空
        WrongMethodTypeException - 如果不能进行转换
        另请参见：
        MethodHandle.asType(java.lang.invoke.MethodType)

      • permuteArguments

        public static MethodHandle permuteArguments​(MethodHandle target,
                                            MethodType newType,
                                            int... reorder)
        生成方法句柄，通过重新排序参数，将方法句柄调整到新类型的调用顺序。 生成的方法句柄保证报告一个等于所需新类型的类型。

        给定的数组控制重新排序。 调用#I输入参数的数量（值newType.parameterCount() ，并调用#O输出参数的数量（值target.type().parameterCount() ），然后重新排序数组的长度必须为#O ，每个元素必须为小于#I的非负数对于每N小于#O ，所述N个传出参数将被从所拍摄的I个传入的参数，其中I是reorder[N] 。

        不应用参数或返回值转换。 由newType确定的每个传入参数的类型必须与目标方法句柄中对应的传出参数或参数的类型相同。 newType的返回类型必须与原始目标的返回类型相同。

        重排序数组不需要指定实际的排列。 如果其索引在数组中出现多次，则传入的参数将被重复，如果引用参数的索引未出现在数组中，则传入参数将被删除。 与dropArguments的情况一样 ，重新排序数组中未提及的传入参数可以是任何类型，仅由newType确定。

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodType intfn1 = methodType(int.class, int.class);
MethodType intfn2 = methodType(int.class, int.class, int.class);
MethodHandle sub = ... (int x, int y) -> (x-y) ...;
assert(sub.type().equals(intfn2));
MethodHandle sub1 = permuteArguments(sub, intfn2, 0, 1);
MethodHandle rsub = permuteArguments(sub, intfn2, 1, 0);
assert((int)rsub.invokeExact(1, 100) == 99);
MethodHandle add = ... (int x, int y) -> (x+y) ...;
assert(add.type().equals(intfn2));
MethodHandle twice = permuteArguments(add, intfn1, 0, 0);
assert(twice.type().equals(intfn1));
assert((int)twice.invokeExact(21) == 42);

        注意：即使原始的目标方法句柄是，生成的适配器从不是一个variable-arity method handle 。

        参数
        target - 在参数之后调用的方法句柄被重新排序
        newType - 新方法句柄的预期类型
        reorder - 控制重新排序的索引数组
        结果
        一个方法句柄，它在它删除未使用的参数并移动和/或复制其他参数之后委托给目标
        异常
        NullPointerException - 如果任何参数为空
        IllegalArgumentException - 如果索引数组长度不等于目标的arity，或者如果任何索引数组元素不是 newType的参数的有效索引，或者如果 target.type()和 newType中的两个对应的参数类型不相同，

      • constant

        public static MethodHandle constant​(Class<?> type,
                                    Object value)
        生成请求的返回类型的方法句柄，每次调用时返回给定的常量值。

        在返回方法句柄之前，将传入值转换为请求的类型。 如果请求的类型是原始的，则尝试扩大原始转换，否则尝试参考转换。

        返回的方法句柄相当于identity(type).bindTo(value) 。

        参数
        type - 所需方法句柄的返回类型
        value - 要返回的值
        结果
        给定返回类型的方法句柄，并且没有参数，它始终返回给定的值
        异常
        NullPointerException - 如果 type参数为空
        ClassCastException - 如果该值无法转换为所需的返回类型
        IllegalArgumentException - 如果给定类型是 void.class

      • identity

        public static MethodHandle identity​(Class<?> type)
        生成方法句柄，在调用时返回其唯一参数。
        参数
        type - 所需方法句柄的唯一参数和返回值的类型
        结果
        接受并返回给定类型的一元方法句柄
        异常
        NullPointerException - 如果参数为空
        IllegalArgumentException - 如果给定类型是 void.class

      • zero

        public static MethodHandle zero​(Class<?> type)
        生成请求的返回类型的常量方法句柄，每次调用时返回该类型的默认值。 得到的常量方法句柄将没有副作用。

        返回的方法句柄相当于empty(methodType(type)) 。 它也相当于explicitCastArguments(constant(Object.class, null), methodType(type)) ，因为explicitCastArguments将null转换为默认值。

        参数
        type - 期望的方法句柄的返回类型
        结果
        一个常量方法句柄，不带参数并返回给定类型的默认值（如果该类型为void，则为void）
        异常
        NullPointerException - 如果参数为空
        从以下版本开始：
        9
        另请参见：
        constant(java.lang.Class<?>, java.lang.Object) ，
empty(java.lang.invoke.MethodType) ，
explicitCastArguments(java.lang.invoke.MethodHandle, java.lang.invoke.MethodType)

      • empty

        public static MethodHandle empty​(MethodType type)
        产生一个忽略任何参数的请求类型的方法句柄，不执行任何操作，并根据返回类型返回合适的默认值。 也就是说，它返回一个零原始值，一个null或void 。

        返回的方法句柄相当于dropArguments(zero(type.returnType()), 0, type.parameterList()) 。

        API Note:
        给定一个谓词和目标，一个有用的“if-then”结构可以生成为 guardWithTest(pred, target, empty(target.type()) 。
        参数
        type - 所需方法句柄的类型
        结果
        给定类型的常量方法句柄，它返回给定返回类型的默认值
        异常
        NullPointerException - 如果参数为空
        从以下版本开始：
        9
        另请参见：
        zero(java.lang.Class<?>) ， constant(java.lang.Class<?>, java.lang.Object)

      • insertArguments

        public static MethodHandle insertArguments​(MethodHandle target,
                                           int pos,
                                           Object... values)
        在方法句柄的调用之前提供一个具有一个或多个绑定参数的目标方法句柄。 对应于绑定参数的目标的形式参数称为绑定参数 。 返回一个新的方法句柄，可以省去绑定的参数。 当它被调用时，它会接收任何非绑定参数的参数，将保存的参数绑定到其对应的参数，并调用原始目标。

        新方法句柄的类型将从原始目标类型中删除绑定参数的类型，因为新方法句柄将不再需要这些参数由其调用者提供。

        每个给定的参数对象必须匹配相应的绑定参数类型。 如果绑定的参数类型是一个原语，则参数对象必须是包装器，并且将被取消装箱以产生原始值。

        pos参数选择要绑定的参数。 它可以在零和NL之间（包括），其中N是目标方法句柄的粗细， L是值数组的长度。

        注意：即使原始的目标方法句柄是，生成的适配器永远不会是variable-arity method handle 。

        参数
        target - 插入参数后调用的方法句柄
        pos - 在哪里插入参数（零为第一个）
        values - 插入的一系列参数
        结果
        在调用原始方法句柄之前插入附加参数的方法句柄
        异常
        NullPointerException - 如果目标或 values数组为空
        另请参见：
        MethodHandle.bindTo(java.lang.Object)

      • dropArguments

        public static MethodHandle dropArguments​(MethodHandle target,
                                         int pos,
                                         List<Class<?>> valueTypes)
        产生的方法处理这将调用一些其他指定的目标方法句柄之前丢弃一些伪参数。 新方法句柄的类型将与目标类型相同，但在某些给定位置，它也包括虚拟参数类型。

        pos参数可以介于零和N之间，其中N是目标的空间。 如果pos为零，则虚拟参数将在目标的实pos之前; 如果pos是N，他们会来。

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle cat = lookup().findVirtual(String.class,
  "concat", methodType(String.class, String.class));
assertEquals("xy", (String) cat.invokeExact("x", "y"));
MethodType bigType = cat.type().insertParameterTypes(0, int.class, String.class);
MethodHandle d0 = dropArguments(cat, 0, bigType.parameterList().subList(0,2));
assertEquals(bigType, d0.type());
assertEquals("yz", (String) d0.invokeExact(123, "x", "y", "z"));

        此方法也等效于以下代码：

         dropArguments(target, pos, valueTypes.toArray(new Class[0]))
        参数
        target - 删除参数后调用的方法句柄
        valueTypes - 要删除的参数的类型
        pos - 第一个参数的位置（最左边为零）
        结果
        一个方法句柄，在调用原始方法句柄之前删除给定类型的参数
        异常
        NullPointerException - 如果目标为null，或者如果 valueTypes列表或其任何元素为null
        IllegalArgumentException -如果任何元素 valueTypes为 void.class ，或者如果 pos比目标的元数负或更大，或者如果新的方法处理的类型将有太多的参数

      • dropArguments

        public static MethodHandle dropArguments​(MethodHandle target,
                                         int pos,
                                         Class<?>... valueTypes)
        产生的方法处理这将调用一些其他指定的目标方法句柄之前丢弃一些伪参数。 新方法句柄的类型将与目标类型相同，但在某些给定位置，它也包括虚拟参数类型。

        pos参数的范围可以介于零和N之间，其中N是目标的概率。 如果pos为零，则虚拟参数将在目标的实pos之前; 如果pos是N，他们会来。

        API Note:

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle cat = lookup().findVirtual(String.class,
  "concat", methodType(String.class, String.class));
assertEquals("xy", (String) cat.invokeExact("x", "y"));
MethodHandle d0 = dropArguments(cat, 0, String.class);
assertEquals("yz", (String) d0.invokeExact("x", "y", "z"));
MethodHandle d1 = dropArguments(cat, 1, String.class);
assertEquals("xz", (String) d1.invokeExact("x", "y", "z"));
MethodHandle d2 = dropArguments(cat, 2, String.class);
assertEquals("xy", (String) d2.invokeExact("x", "y", "z"));
MethodHandle d12 = dropArguments(cat, 1, int.class, boolean.class);
assertEquals("xz", (String) d12.invokeExact("x", 12, true, "z"));

        此方法也等效于以下代码：

         dropArguments(target, pos, Arrays.asList(valueTypes))
        参数
        target - 删除参数后调用的方法句柄
        valueTypes - 要删除的参数的类型
        pos - 第一个参数的位置（最左边为零）
        结果
        一个方法句柄，在调用原始方法句柄之前删除给定类型的参数
        异常
        NullPointerException - 如果目标为空，或者如果 valueTypes数组或其任何元素为空
        IllegalArgumentException -如果任何元素 valueTypes为 void.class ，或者如果 pos比目标的元数负或更大，或者如果新的方法处理的类型将有 too many parameters

      • dropArgumentsToMatch

        public static MethodHandle dropArgumentsToMatch​(MethodHandle target,
                                                int skip,
                                                List<Class<?>> newTypes,
                                                int pos)
        适应目标方法句柄以匹配给定的参数类型列表。 如有必要，添加虚拟参数。 匹配开始之前可以跳过一些引导参数。 target的参数类型列表中的其余类型必须是起始位置pos处的newTypes类型列表的子列表。 所得到的句柄将具有目标句柄的参数类型列表，其中插入到目标原始参数的相应位置中的任何不匹配的参数类型（匹配子列表之前或之后），如同通过dropArguments(MethodHandle, int, Class[])一样 。

        所得到的句柄将具有与目标句柄相同的返回类型。

        在更正式的术语中，假设这两个类型列表：

        • 目标句柄具有参数类型列表S..., M... ，其中S类型与S所示的类型skip 。 M类型是那些应该匹配给定类型列表newTypes一部分的类型。
        • 该newTypes列表包含类型P..., M..., A... ，与许多类型P所指示pos 。 M类型正是目标句柄的参数类型列表中的M类型应该匹配的类型。 A中的类型是匹配子列表后面的其他类型。
        给出这些假设，调用dropArgumentsToMatch的结果将具有参数类型列表S..., P..., M..., A... ，其中P和A类型被插入，如同通过dropArguments(MethodHandle, int, Class[]) 。

        API Note:
        其参数列表“有效地相同”（即，在公共前缀中相同）的两个方法句柄可以通过对dropArgumentsToMatch的两次调用相互转换为公共类型，如下所示：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
...
MethodHandle h0 = constant(boolean.class, true);
MethodHandle h1 = lookup().findVirtual(String.class, "concat", methodType(String.class, String.class));
MethodType bigType = h1.type().insertParameterTypes(1, String.class, int.class);
MethodHandle h2 = dropArguments(h1, 0, bigType.parameterList());
if (h1.type().parameterCount() < h2.type().parameterCount())
    h1 = dropArgumentsToMatch(h1, 0, h2.type().parameterList(), 0);  // lengthen h1
else
    h2 = dropArgumentsToMatch(h2, 0, h1.type().parameterList(), 0);    // lengthen h2
MethodHandle h3 = guardWithTest(h0, h1, h2);
assertEquals("xy", h3.invoke("x", "y", 1, "a", "b", "c"));
        参数
        target - 适应的方法句柄
        skip - 要忽略的目标参数数（它们将保持不变）
        newTypes - 匹配 target的参数类型列表的类型列表
        pos - 位于 newTypes ，其中必须发生非跳过的目标参数
        结果
        一个可能适应的方法句柄
        异常
        NullPointerException - 如果任一参数为空
        IllegalArgumentException -如果任何元件 newTypes是 void.class ，或者如果 skip比目标的元数负或更大，或者如果 pos比newTypes列表尺寸负或更大，或者如果 newTypes不包含 target的非跳过位置 pos参数类型。
        从以下版本开始：
        9

      • filterArguments

        public static MethodHandle filterArguments​(MethodHandle target,
                                           int pos,
                                           MethodHandle... filters)
        通过预处理其一个或多个参数来适应目标方法句柄，每个参数具有自己的一元过滤器函数，然后使用每个预处理的参数替换为相应过滤器函数的结果来调用目标。

        预处理由一个或多个方法手柄执行，在filters数组的元素中指定。 过滤器阵列的第一个元素对应于目标的pos参数，依次类推。

        数组中的空参数被视为身份函数，相应的参数保持不变。 （如果数组中没有非空元素，则返回原始目标。）每个过滤器都应用于适配器的相应参数。

        如果过滤器F适用于目标的N参数，那么F必须是一个方法句柄， F需要一个参数。 F的唯一参数的类型将替换生成的适应方法句柄中的对象的相应参数类型。 F的返回类型必须与目标的相应参数类型相同。

        如果有filters （null或not）的元素与目标中的参数位置不对应，则是错误的。

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle cat = lookup().findVirtual(String.class,
  "concat", methodType(String.class, String.class));
MethodHandle upcase = lookup().findVirtual(String.class,
  "toUpperCase", methodType(String.class));
assertEquals("xy", (String) cat.invokeExact("x", "y"));
MethodHandle f0 = filterArguments(cat, 0, upcase);
assertEquals("Xy", (String) f0.invokeExact("x", "y")); // Xy
MethodHandle f1 = filterArguments(cat, 1, upcase);
assertEquals("xY", (String) f1.invokeExact("x", "y")); // xY
MethodHandle f2 = filterArguments(cat, 0, upcase, upcase);
assertEquals("XY", (String) f2.invokeExact("x", "y")); // XY

        这里是生成的适配器的伪代码。 在代码中， T表示target和最终的适配器的返回类型。 P / p和B / b表示之前和之后过滤器位置的参数和变量的类型和值pos ，分别。 A[i] / a[i]支架，用于将滤波参数和参数的类型和值; 它们也代表了filter[i]句柄的返回类型。 后者接受类型为V[i]参数v[i] ，这也出现在生成的适配器的签名中。

 T target(P... p, A[i]... a[i], B... b);
 A[i] filter[i](V[i]);
 T adapter(P... p, V[i]... v[i], B... b) {
   return target(p..., filter[i](v[i])..., b...);
 }

        注意：即使原始的目标方法句柄是，生成的适配器从不是variable-arity method handle 。

        参数
        target - 过滤参数后调用的方法句柄
        pos - 要过滤的第一个参数的位置
        filters - 最初调用过滤参数的方法句柄
        结果
        方法句柄包含指定的参数过滤逻辑
        异常
        NullPointerException - 如果目标为null或者如果 filters数组为空
        IllegalArgumentException -如果非空元件 filters如上所述不匹配目标的对应的参数类型，或者如果 pos+filters.length大于 target.type().parameterCount() ，或者如果产生的方法手柄的类型将具有 too many parameters

      • collectArguments

        public static MethodHandle collectArguments​(MethodHandle target,
                                            int pos,
                                            MethodHandle filter)
        通过使用过滤器（另一种方法句柄）预处理其参数的子序列来适应目标方法句柄。 预处理参数被过滤器函数的结果（如果有）替换。 然后在修改的（通常缩短的）参数列表上调用目标。

        如果过滤器返回一个值，则目标必须接受该值作为位置pos参数，前后和/或之后是未传递给过滤器的任何参数。 如果过滤器返回void，则目标必须接受所有不传递给过滤器的参数。 没有参数被重新排序，并且从过滤器返回的结果替换原来传递给适配器的参数的整个子序列（按顺序）。

        过滤器的参数类型（如果有）替换了零或一个参数类型的目标，在位置pos ，在生成的修改方法句柄。 过滤器的返回类型（如果有）必须与目标位置pos的参数类型相同，该目标参数由过滤器的返回值提供。

        在所有情况下， pos必须大于或等于零，而pos也必须小于或等于目标的空间。

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle deepToString = publicLookup()
  .findStatic(Arrays.class, "deepToString", methodType(String.class, Object[].class));

MethodHandle ts1 = deepToString.asCollector(String[].class, 1);
assertEquals("[strange]", (String) ts1.invokeExact("strange"));

MethodHandle ts2 = deepToString.asCollector(String[].class, 2);
assertEquals("[up, down]", (String) ts2.invokeExact("up", "down"));

MethodHandle ts3 = deepToString.asCollector(String[].class, 3);
MethodHandle ts3_ts2 = collectArguments(ts3, 1, ts2);
assertEquals("[top, [up, down], strange]",
             (String) ts3_ts2.invokeExact("top", "up", "down", "strange"));

MethodHandle ts3_ts2_ts1 = collectArguments(ts3_ts2, 3, ts1);
assertEquals("[top, [up, down], [strange]]",
             (String) ts3_ts2_ts1.invokeExact("top", "up", "down", "strange"));

MethodHandle ts3_ts2_ts3 = collectArguments(ts3_ts2, 1, ts3);
assertEquals("[top, [[up, down, strange], charm], bottom]",
             (String) ts3_ts2_ts3.invokeExact("top", "up", "down", "strange", "charm", "bottom"));

        这里是生成的适配器的伪代码。 在代码中， T表示的返回类型target并导致适配器。 V / v支架的的返回类型和值filter ，它们也在的签名和参数发现target分别，除非V是void 。 A / a和C / c代表参数的类型和值之前和之后的收集位置， pos ，在target的签名。 他们所得到的适配器的签名和论据，在那里他们还围绕转动起来B / b ，它代表的参数类型和参数为filter （如果有的话）。

 T target(A...,V,C...);
 V filter(B...);
 T adapter(A... a,B... b,C... c) {
   V v = filter(b...);
   return target(a...,v,c...);
 }
 // and if the filter has no arguments:
 T target2(A...,V,C...);
 V filter2();
 T adapter2(A... a,C... c) {
   V v = filter2();
   return target2(a...,v,c...);
 }
 // and if the filter has a void return:
 T target3(A...,C...);
 void filter3(B...);
 T adapter3(A... a,B... b,C... c) {
   filter3(b...);
   return target3(a...,c...);
 }

        收集适配器collectArguments(mh, 0, coll)等效于首先“折叠”受影响的参数，然后将它们分离出来，单独的步骤如下：

 mh = MethodHandles.dropArguments(mh, 1, coll.type().parameterList()); //step 2
 mh = MethodHandles.foldArguments(mh, coll); //step 1
        如果目标方法句柄除了过滤器coll的结果（如果有的话）以外没有任何参数，则collectArguments(mh, 0, coll)相当于filterReturnValue(coll, mh) 。 如果过滤器方法句柄coll消耗一个参数并产生无效结果，则collectArguments(mh, N, coll)相当于filterArguments(mh, N, coll) 。 其他等价是可能的，但需要参数置换。

        注意：即使原始的目标方法句柄是，生成的适配器从不是一个variable-arity method handle 。

        参数
        target - 过滤参数子序列后调用的方法句柄
        pos - 传递给过滤器的第一个适配器参数的位置和/或接收过滤器结果的目标参数
        filter - 方法句柄来调用参数的子序列
        结果
        方法句柄，其包含指定的参数子序列过滤逻辑
        异常
        NullPointerException - 如果任一参数为空
        IllegalArgumentException -如果的返回类型 filter为非空隙和不一样的 pos目标的参数，或者如果 pos不为0之间以及在目标的元数，包括端值，或者如果产生的方法手柄的类型将具有 too many parameters
        另请参见：
        foldArguments(java.lang.invoke.MethodHandle, java.lang.invoke.MethodHandle) ，
filterArguments(java.lang.invoke.MethodHandle, int, java.lang.invoke.MethodHandle...) ，
filterReturnValue(java.lang.invoke.MethodHandle, java.lang.invoke.MethodHandle)

      • filterReturnValue

        public static MethodHandle filterReturnValue​(MethodHandle target,
                                             MethodHandle filter)
        通过使用过滤器（另一种方法句柄）对其返回值（如果有的话）进行后处理来适应目标方法句柄。 从适配器返回过滤器的结果。

        如果目标返回值，则过滤器必须接受该值作为其唯一参数。 如果目标返回void，则过滤器不能接受参数。

        过滤器的返回类型替换生成的适应方法句柄中的目标的返回类型。 过滤器的参数类型（如果有）必须与目标的返回类型相同。

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle cat = lookup().findVirtual(String.class,
  "concat", methodType(String.class, String.class));
MethodHandle length = lookup().findVirtual(String.class,
  "length", methodType(int.class));
System.out.println((String) cat.invokeExact("x", "y")); // xy
MethodHandle f0 = filterReturnValue(cat, length);
System.out.println((int) f0.invokeExact("x", "y")); // 2

        这里是生成的适配器的伪代码。 中的代码， T / t表示的结果类型和值target ; V ，结果类型为filter ; 和A / a ，类型和所述参数和所述参数的值target以及所得到的适配器。

 T target(A...);
 V filter(T);
 V adapter(A... a) {
   T t = target(a...);
   return filter(t);
 }
 // and if the target has a void return:
 void target2(A...);
 V filter2();
 V adapter2(A... a) {
   target2(a...);
   return filter2();
 }
 // and if the filter has a void return:
 T target3(A...);
 void filter3(V);
 void adapter3(A... a) {
   T t = target3(a...);
   filter3(t);
 }

        注意：即使原始的目标方法句柄是，生成的适配器永远不会是variable-arity method handle 。

        参数
        target - 过滤返回值之前调用的方法句柄
        filter - 方法句柄来调用返回值
        结果
        方法句柄，其包含指定的返回值过滤逻辑
        异常
        NullPointerException - 如果任一参数为空
        IllegalArgumentException -如果参数列表 filter不匹配目标的返回类型如上所述

      • foldArguments

        public static MethodHandle foldArguments​(MethodHandle target,
                                         MethodHandle combiner)
        通过预处理一些参数来适应目标方法句柄，然后调用具有预处理结果的目标，插入到原始的参数序列中。

        预处理由combiner执行，第二个方法句柄。 传递给适配器的参数中，第一个N参数被复制到组合器，然后调用它。 （这里， N被定义为组合器的参数计数）。此后，控制传递给目标，任何来自组合器的结果在原始N传入参数之前插入。

        如果组合器返回一个值，则目标的第一个参数类型必须与组合器的返回类型相同，而下一个N参数类型必须与组合器的参数完全匹配。

        如果组合N返回，则不会插入结果，并且目标的第一个N参数类型必须与组合器的参数完全匹配。

        生成的适配器与目标的类型相同，不同之处在于，如果第一个参数类型与组合器的结果相对应，那么它将被删除。

        （请注意， dropArguments可用于删除组合器或目标不希望接收的任何参数。如果某些传入的参数仅用于组合器，请考虑使用asCollector ，因为这些参数不需要生活在堆栈上进入目标。）

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle trace = publicLookup().findVirtual(java.io.PrintStream.class,
  "println", methodType(void.class, String.class))
    .bindTo(System.out);
MethodHandle cat = lookup().findVirtual(String.class,
  "concat", methodType(String.class, String.class));
assertEquals("boojum", (String) cat.invokeExact("boo", "jum"));
MethodHandle catTrace = foldArguments(cat, trace);
// also prints "boo":
assertEquals("boojum", (String) catTrace.invokeExact("boo", "jum"));

        这里是生成的适配器的伪代码。 在代码中， T表示target和结果适配器的结果类型。 V / v代表类型和所述参数和参数的值target先于折叠位置; V也就是结果类型combiner 。 A / a表示类型和值N参数和变量在折叠位置。 B / b表示的类型和值target参数和变量的随后的折叠参数和参数。

 // there are N arguments in A...
 T target(V, A[N]..., B...);
 V combiner(A...);
 T adapter(A... a, B... b) {
   V v = combiner(a...);
   return target(v, a..., b...);
 }
 // and if the combiner has a void return:
 T target2(A[N]..., B...);
 void combiner2(A...);
 T adapter2(A... a, B... b) {
   combiner2(a...);
   return target2(a..., b...);
 }

        注意：即使原始的目标方法句柄是，生成的适配器从不是一个variable-arity method handle 。

        参数
        target - 组合参数后调用的方法句柄
        combiner - 最初调用传入参数的方法句柄
        结果
        包含指定参数折叠逻辑的方法句柄
        异常
        NullPointerException - 如果任一参数为空
        IllegalArgumentException -如果 combiner的返回类型为非空隙和不一样的第一个参数类型的目标，或者如果初始 N参数类型的目标（跳过一个匹配 combiner的返回类型）不具有相同的参数类型为 combiner

      • foldArguments

        public static MethodHandle foldArguments​(MethodHandle target,
                                         int pos,
                                         MethodHandle combiner)
        通过预先处理一些参数，从给定的位置开始，然后调用具有预处理结果的目标，将其插入原来的参数序列之前，使其适用于目标方法句柄。

        该方法与foldArguments(MethodHandle, MethodHandle)密切相关，但允许控制在折叠发生的参数列表中的位置。 控制这个的参数， pos ，是一个零为基础的指数。 上述方法foldArguments(MethodHandle, MethodHandle)假定为位置0。

        API Note:
        例：

    import static java.lang.invoke.MethodHandles.*;
    import static java.lang.invoke.MethodType.*;
    ...
    MethodHandle trace = publicLookup().findVirtual(java.io.PrintStream.class,
    "println", methodType(void.class, String.class))
    .bindTo(System.out);
    MethodHandle cat = lookup().findVirtual(String.class,
    "concat", methodType(String.class, String.class));
    assertEquals("boojum", (String) cat.invokeExact("boo", "jum"));
    MethodHandle catTrace = foldArguments(cat, 1, trace);
    // also prints "jum":
    assertEquals("boojum", (String) catTrace.invokeExact("boo", "jum"));

        这里是生成的适配器的伪代码。 在代码中， T表示target和结果适配器的结果类型。 V / v代表类型和所述参数和参数的值target先于折叠位置; V也就是结果类型combiner 。 A / a表示类型和值N参数和变量在折叠位置。 Z / z和B / b表示的类型和值target参数和自变量之前和之后的折叠参数和自变量开始pos分别。

 // there are N arguments in A...
 T target(Z..., V, A[N]..., B...);
 V combiner(A...);
 T adapter(Z... z, A... a, B... b) {
   V v = combiner(a...);
   return target(z..., v, a..., b...);
 }
 // and if the combiner has a void return:
 T target2(Z..., A[N]..., B...);
 void combiner2(A...);
 T adapter2(Z... z, A... a, B... b) {
   combiner2(a...);
   return target2(z..., a..., b...);
 }

        注意：即使原始的目标方法句柄是，生成的适配器永远不会是variable-arity method handle 。

        参数
        target - 组合参数后调用的方法句柄
        pos - 开始折叠的位置，插入折叠结果的位置; 如果是0 ，效果与foldArguments(MethodHandle, MethodHandle)相同。
        combiner - 最初调用传入参数的方法句柄
        结果
        包含指定参数折叠逻辑的方法句柄
        异常
        NullPointerException - 如果任一参数为空
        IllegalArgumentException -如果满足以下两个条件成立：（1） combiner的返回类型是非void和不一样在位置参数类型pos目标签名的; （2）目标签名的位置pos的N参数类型（跳过一个匹配combiner的返回类型）与combiner的参数类型combiner 。
        从以下版本开始：
        9
        另请参见：
        foldArguments(MethodHandle, MethodHandle)

      • guardWithTest

        public static MethodHandle guardWithTest​(MethodHandle test,
                                         MethodHandle target,
                                         MethodHandle fallback)
        使用方法句柄来调整目标方法句柄，通过用测试保护它，一个布尔值方法句柄。 如果防守失败，则会调用后备句柄。 所有三个方法句柄必须具有相同的对应参数和返回类型，除了测试的返回类型必须为布尔值，并且允许测试具有比其他两个方法句柄少的参数。

        这里是生成的适配器的伪代码。 在代码中， T代表三个手柄的统一结果类型; A / a ，类型和值target参数和参数是由消耗test ; 和B / b ，这些类型和值target参数和自变量不是由消耗test 。

 boolean test(A...);
 T target(A...,B...);
 T fallback(A...,B...);
 T adapter(A... a,B... b) {
   if (test(a...))
     return target(a..., b...);
   else
     return fallback(a..., b...);
 }
        请注意，测试参数（伪代码中的a... ）不能通过执行测试进行修改，所以根据需要，从调用者不变地传递到目标或后备。
        参数
        test - 用于测试的方法句柄，必须返回布尔值
        target - 如果测试通过，调用方法句柄
        fallback - 如果测试失败，则调用方法句柄
        结果
        方法句柄包含指定的if / then / else逻辑
        异常
        NullPointerException - 如果任何参数为空
        IllegalArgumentException - 如果 test不返回布尔值，或者如果所有三种方法类型都不匹配（返回类型为 test更改为匹配目标）。

      • catchException

        public static MethodHandle catchException​(MethodHandle target,
                                          Class<? extends Throwable> exType,
                                          MethodHandle handler)
        通过在异常处理程序中运行它来创建适应目标方法句柄的方法句柄。 如果目标返回正常，则适配器返回该值。 如果抛出与指定类型匹配的异常，则会在异常时调用回退句柄，再加上原始参数。

        目标和处理程序必须具有相同的对应参数和返回类型，但处理程序可能会忽略拖尾参数（与guardWithTest中的谓词相似 ）。 另外，处理程序必须有一个额外的引导参数exType或超类型。

        这里是生成的适配器的伪代码。 在代码中， T代表target和handler的返回类型，相应地代表所生成的适配器; A / a ，类型和参数，以通过所消耗的所得句柄值handler ; 和B / b ，那些参数，以通过丢弃所产生的手柄handler 。

 T target(A..., B...);
 T handler(ExType, A...);
 T adapter(A... a, B... b) {
   try {
     return target(a..., b...);
   } catch (ExType ex) {
     return handler(ex, a...);
   }
 }
        请注意，保存的参数（伪代码中的a... ）无法通过执行目标进行修改，如果调用处理程序，则从调用程序到处理程序不变地传递。

        目标和处理程序必须返回相同的类型，即使处理程序总是抛出。 （这可能会发生，例如，因为处理程序正在模拟一个finally子句）。 要创建这样的抛出处理程序，请使用throwException编写处理程序创建逻辑，以创建正确返回类型的方法句柄。

        参数
        target - 方法句柄调用
        exType - 处理程序将捕获的异常类型
        handler - 如果抛出匹配的异常，则调用方法句柄
        结果
        包含指定的try / catch逻辑的方法句柄
        异常
        NullPointerException - 如果任何参数为空
        IllegalArgumentException - 如果 handler不接受给定的异常类型，或者方法句柄类型在其返回类型及其相应参数中不匹配
        另请参见：
        tryFinally(MethodHandle, MethodHandle)

      • throwException

        public static MethodHandle throwException​(Class<?> returnType,
                                          Class<? extends Throwable> exType)
        产生一个方法句柄，它将抛出给定的异常exType 。 方法句柄将接受一个单独的参数exType ，并立即将其作为例外。 方法类型将名义上指定返回值为returnType 。 返回类型可能是任何方便的：方法句柄的行为无关紧要，因为它将永远不会正常返回。
        参数
        returnType - 所需方法句柄的返回类型
        exType - 所需方法句柄的参数类型
        结果
        方法句柄可以抛出给定的异常
        异常
        NullPointerException - 如果任一参数为空

      • loop

        public static MethodHandle loop​(MethodHandle[]... clauses)
        构造一个表示循环的方法句柄，该循环具有在每次迭代时更新和检查的多个循环变量。 在由于其中一个谓词终止循环后，运行相应的终结器，并传递循环的结果，循环的结果是结果句柄的返回值。

        直观地，每个循环由一个或多个“子句”形成，每个“子句”指定本地迭代变量和/或循环出口。 循环的每次迭代按顺序执行每个子句。 一个子句可以选择更新其迭代变量; 它还可以选择执行测试和条件循环退出。 为了在方法句柄方面表达这个逻辑，每个子句最多可以指定四个独立的动作：

        • 初始化：在循环执行之前，一个迭代变量的初始化v类型的V 。
        • 步骤：当一个子句执行时，迭代变量v的更新步骤。
        • pred：当一个子句执行时，一个谓词执行来测试循环退出。
        • fini：如果一个子句导致循环退出，则执行终结器来计算循环的返回值。
        所有迭代变量类型的完整序列按照子句顺序将被标记为(V...) 。 值本身将为(v...) 。 当我们说“参数列表”时，我们通常会指向类型，但在某些上下文（描述执行）中，列表将是实际值。

        这些条款部分中的一些可以根据某些规则被省略，并且在这种情况下提供有用的默认行为。 详见下文。

        参数可选无处不在：每个子句函数是允许的，但不需要接受每个迭代变量v的参数。 作为一个例外，init函数不能采用任何v参数，因为这些值在执行init函数时尚未计算。 任何条款函数都可能忽略其有权采取的参数的任何后续子序列。 实际上，任何子句函数都不会有参数。

        循环参数：一个子句函数可以使用它所有的迭代变量值，在这种情况下，它也可能需要更多的拖尾参数。 这样的额外值被称为循环参数 ，其类型和值被标记为(A...)和(a...) 。 这些将成为所产生的循环句柄的参数，每当执行循环时，它将被提供。 （由于init函数不接受迭代变量v ，init函数的任何参数都将自动为循环参数a ）。与迭代变量一样，子句函数是允许的，但不需要接受循环参数。 这些循环参数用作整个循环中可见的循环不变值。

        参数可见无处不在：允许每个非init子句函数观察整个循环状态，因为它可以传递当前迭代变量值和传入循环参数的完整列表(v... a...) 。 init函数可以观察初始的预循环状态，形式为(a...) 。 大多数子句功能不需要所有这些信息，但它们将正式连接到它，就像dropArguments(java.lang.invoke.MethodHandle, int, java.util.List<java.lang.Class<?>>)一样 。 更具体地说，我们将使用符号(V*)来表达一个完整序列的任意前缀(V...) （且同样(v*) ， (A*) ， (a*) ）。 在该符号中，init函数参数列表的一般形式为(A*) ，非init函数参数列表的一般形式为(V*)或(V... A*) 。

        检查子句结构：给定一组子句，执行多个检查和调整，以连接循环的所有部分。 它们在下面的步骤中详细说明。 在这些步骤中，如果循环组合器的输入不满足所需的约束，则单词“必须”的每次出现都对应于将抛出IllegalArgumentException的位置。

        有效地相同的序列： 如果A和B是相同的，或者如果A较短并且与适当的前缀为B相同，则参数列表A被定义为与另一个参数列表B 有效地相同 。 当说出一组无序的参数列表时，我们认为如果集合包含最长列表，则该集合的整体“完全相同”，并且集合的所有成员与最长列表实际上相同。 例如，任何一组的形式的型序列的(V*)是有效相同的，并且如果窗体的多个序列也是如此(V... A*)相加。

        步骤0：确定子句结构。

        1. 子句数组（型号为MethodHandle[][] ）必须为非null并且至少包含一个元素。
        2. 子句数组可能不包含长于四个元素的null或子数组。
        3. 短于四个元素的条款被视为被填充null元素长达四个。 填充通过将元素附加到数组来进行。
        4. 条款与所有null s被忽略。
        5. 每个子句被视为一个四元组的函数，称为“init”，“step”，“pred”和“fini”。

        步骤1A：确定迭代变量类型(V...) 。

        1. 每个子句的迭代变量类型使用子句的init和step返回类型来确定。
        2. 如果省略了两个函数，则对应的子句不存在迭代变量（ void用作指示的类型）。 如果其中一个被忽略，其他的返回类型定义子句的迭代变量类型。 如果两者都给出，那么常用的返回类型（它们必须相同）定义子句的迭代变量类型。
        3. 形成返回类型列表（按子句顺序），省略所有出现的void 。
        4. 这种类型的列表称为“迭代变量类型”（ (V...) ）。

        步骤1B：确定循环参数(A...) 。

        • 检查并收集init函数参数列表（其格式为(A*) ）。
        • 在删除迭代变量类型后，检查并收集step，pred和fini参数列表的后缀。 （他们必须具有(V... A*)的形式;仅收集(A*)部分。）
        • 不要从没有以所有迭代变量类型开头的step，pred和fini参数列表收集后缀。 （这些类型将在步骤2中检查，以及所有子句函数类型。）
        • 省略的子句功能被忽略。 （等同地，它们被认为具有空参数列表。）
        • 所有收集的参数列表必须有效地相同。
        • 最长参数列表（必须是唯一的）称为“外部参数列表”（ (A...) ）。
        • 如果没有这样的参数列表，则将外部参数列表作为空序列。
        • 由外部参数类型后面的迭代变量类型组成的组合列表称为“内部参数列表”。

        步骤1C：确定回路返回类型。

        1. 检查fini函数返回类型，忽略忽略fini函数。
        2. 如果没有fini功能，循环返回类型为void 。
        3. 否则，fini函数的公共返回类型（它们的返回类型必须相同）的类型为R定义了循环返回类型。

        步骤1D：检查其他类型。

        1. 必须至少有一个非省略的pred函数。
        2. 每个非省略的pred函数都必须有一个boolean返回类型。

        步骤2：确定参数列表。

        1. 结果循环句柄的参数列表将是外部参数列表(A...) 。
        2. init函数的参数列表将被调整为外部参数列表。 （请注意，它们的参数列表已经与此列表有效相同）
        3. 每个非省略，非init（step，pred和fini）函数的参数列表必须与内部参数列表(V... A...)有效地相同。

        步骤3：填写省略功能。

        1. 如果省略了一个init函数， 那么对于子句的迭代变量类型，请使用default value 。
        2. 如果省略步骤功能，请使用该子句的迭代变量类型的identity function ; 在前面的子句的非void迭代变量的identity函数之前插入参数参数。 （这将使循环变量变为本地循环不变量。）
        3. 如果省略pred函数，请使用常数true函数。 （这将保持循环，就本条而言，请注意，在这种情况下，相应的fini函数是无法访问的。
        4. 如果省略fini功能，请使用default value作为循环返回类型。

        步骤4：填写缺少的参数类型。

        1. 此时，每个init函数参数列表与外部参数列表(A...)有效地相同，但是一些列表可能更短。 对于具有短参数列表的每个初始化函数，请填写列表的末尾。
        2. 此时，每个非init函数参数列表与内部参数列表(V... A...)有效地相同，但是一些列表可能更短。 对于每个具有短参数列表的非init函数，请填写列表的末尾。
        3. 参数列表由dropping unused trailing arguments填充。

        最终观察。

        1. 在这些步骤之后，通过提供省略的函数和参数来调整所有子句。
        2. 所有init函数都有一个常见的参数类型列表(A...) ，最后的循环句柄也将具有。
        3. 所有fini函数都有一个常见的返回类型R ，最后的循环句柄也将具有。
        4. 所有非init函数都有一个公共参数类型列表(V... A...) ，（非void ）迭代变量V后跟循环参数。
        5. 每对init和step函数在返回类型V 。
        6. 每个非init函数都能够观察到所有迭代变量的当前值(v...) 。
        7. 每个功能都能够观察所有循环参数的输入值(a...) 。

        例。 作为上述步骤1A的结果， loop组合器具有以下属性：

        • 给予N条款Cn = {null, Sn, Pn}与n = 1..N 。
        • 假设谓词句柄Pn是null或没有参数。 （只有一个Pn必须是非null ）
        • 假设步骤Sn具有签名(B1..BX)Rn ，对于一些常数X>=N 。
        • 假设Q是非空类型的Rn ，而这些类型的序列是(V1...VQ) 。
        • 它必须是Vn == Bn为n = 1..min(X,Q) 。
        • 参数类型Vn将被解释为循环本地状态元素(V...) 。
        • 任何剩余的类型BQ+1..BX （如果为Q<X ）将确定生成的循环句柄的参数类型(A...) 。
        在这个例子中，循环句柄参数(A...)是从步骤函数中得出的，如果大部分循环计算发生在步骤中，这是很自然的。 对于某些循环，计算的负担可能在pred函数中最重，因此pred函数可能需要接受循环参数值。 对于具有复杂退出逻辑的循环，fini函数可能需要接受循环参数，同样对于具有复杂入口逻辑的循环，init函数将需要额外的参数。 由于这些原因，在所有条款部分中，确定这些参数的规则尽可能对称。 通常，循环参数作为整个循环中的公共不变值，而迭代变量用作常用变量值，或（如果没有步长函数）作为内部循环不变量临时值。

        循环执行。

        1. 当循环被调用时，循环输入值被保存在本地，被传递给每个子句函数。 这些本地是循环不变的。
        2. 每个init函数按子句顺序执行（传递外部参数(a...) ），非void值（作为迭代变量(v...) ）保存到本地文件中。 这些本地人将是循环变化的（除非他们的步骤表现为身份功能，如上所述）。
        3. 所有函数执行（init函数除外）将通过内部参数列表，由非void迭代值(v...) （按子句顺序），然后循环输入(a...) （以参数顺序）组成。
        4. 然后按照子句顺序（pred before pred）执行step和pred函数，直到pred函数返回false 。
        5. 来自步骤函数调用的非void结果用于更新循环变量序列(v...)中的相应值。 所有后续的函数调用都会立即显示已更新的值。
        6. 如果pred函数返回false ，则调用相应的fini函数，并从循环返回结果值（类型为R ）。
        7. 如果所有的pred函数总是返回true，那么没有调用fini函数，除了抛出异常，循环不能退出。

        使用提示。

        • 虽然每个step函数都将接收所有循环变量的当前值，但有时一个step函数只需要观察自己变量的当前值。 在这种情况下，步骤功能可能需要明确地drop all preceding loop variables 。 这将需要提及它们的类型，像dropArguments(step, 0, V0.class, ...)这样的表达式。
        • 循环变量不需要变化; 它们可以是循环不变的。 一个子句可以通过没有step，pred或者fini函数的合适的init函数创建一个不变的循环。 将传入的循环参数“连接”到相邻循环变量的step或pred函数中可能很有用。
        • 如果一些子句函数是实例上的虚拟方法，则实例本身可以方便地放置在初始不变循环“variable”中，使用初始条款，如new MethodHandle[]{identity(ObjType.class)} 。 在这种情况下，实例引用将是第一个迭代变量值，它将很容易使用虚方法作为子句部分，因为它们都将采用匹配该值的引导式实例引用。

        这里是生成的循环句柄的伪代码。 如上所述， V和v表示循环变量的类型和值; A和a表示传递给整个循环的参数; 而R是所有终结器以及结果循环的常见结果类型。

 V... init...(A...);
 boolean pred...(V..., A...);
 V... step...(V..., A...);
 R fini...(V..., A...);
 R loop(A... a) {
   V... v... = init...(a...);
   for (;;) {
     for ((v, p, s, f) in (v..., pred..., step..., fini...)) {
       v = s(v..., a...);
       if (!p(v..., a...)) {
         return f(v..., a...);
       }
     }
   }
 }
        请注意，参数类型列表(V...)和(A...)已经扩展到其全长，即使各个子句功能可能忽略将其全部占用。 如上所述，缺少的参数被填充，如同dropArgumentsToMatch(java.lang.invoke.MethodHandle, int, java.util.List<java.lang.Class<?>>, int, boolean)一样 。

        API Note:
        例：

 // iterative implementation of the factorial function as a loop handle
 static int one(int k) { return 1; }
 static int inc(int i, int acc, int k) { return i + 1; }
 static int mult(int i, int acc, int k) { return i * acc; }
 static boolean pred(int i, int acc, int k) { return i < k; }
 static int fin(int i, int acc, int k) { return acc; }
 // assume MH_one, MH_inc, MH_mult, MH_pred, and MH_fin are handles to the above methods
 // null initializer for counter, should initialize to 0
 MethodHandle[] counterClause = new MethodHandle[]{null, MH_inc};
 MethodHandle[] accumulatorClause = new MethodHandle[]{MH_one, MH_mult, MH_pred, MH_fin};
 MethodHandle loop = MethodHandles.loop(counterClause, accumulatorClause);
 assertEquals(120, loop.invoke(5));
        同样的例子，放弃参数并使用组合器：

 // simplified implementation of the factorial function as a loop handle
 static int inc(int i) { return i + 1; } // drop acc, k
 static int mult(int i, int acc) { return i * acc; } //drop k
 static boolean cmp(int i, int k) { return i < k; }
 // assume MH_inc, MH_mult, and MH_cmp are handles to the above methods
 // null initializer for counter, should initialize to 0
 MethodHandle MH_one = MethodHandles.constant(int.class, 1);
 MethodHandle MH_pred = MethodHandles.dropArguments(MH_cmp, 1, int.class); // drop acc
 MethodHandle MH_fin = MethodHandles.dropArguments(MethodHandles.identity(int.class), 0, int.class); // drop i
 MethodHandle[] counterClause = new MethodHandle[]{null, MH_inc};
 MethodHandle[] accumulatorClause = new MethodHandle[]{MH_one, MH_mult, MH_pred, MH_fin};
 MethodHandle loop = MethodHandles.loop(counterClause, accumulatorClause);
 assertEquals(720, loop.invoke(6));
        一个类似的例子，使用一个帮助对象来保存一个循环参数：

 // instance-based implementation of the factorial function as a loop handle
 static class FacLoop {
   final int k;
   FacLoop(int k) { this.k = k; }
   int inc(int i) { return i + 1; }
   int mult(int i, int acc) { return i * acc; }
   boolean pred(int i) { return i < k; }
   int fin(int i, int acc) { return acc; }
 }
 // assume MH_FacLoop is a handle to the constructor
 // assume MH_inc, MH_mult, MH_pred, and MH_fin are handles to the above methods
 // null initializer for counter, should initialize to 0
 MethodHandle MH_one = MethodHandles.constant(int.class, 1);
 MethodHandle[] instanceClause = new MethodHandle[]{MH_FacLoop};
 MethodHandle[] counterClause = new MethodHandle[]{null, MH_inc};
 MethodHandle[] accumulatorClause = new MethodHandle[]{MH_one, MH_mult, MH_pred, MH_fin};
 MethodHandle loop = MethodHandles.loop(instanceClause, counterClause, accumulatorClause);
 assertEquals(5040, loop.invoke(7));
        参数
        clauses - 符合上述规则的MethodHandle的阵列阵列（4元组）。
        结果
        一个体现循环行为的方法句柄，由参数定义。
        异常
        IllegalArgumentException - 在上述任何约束被违反的情况下。
        从以下版本开始：
        9
        另请参见：
        whileLoop(MethodHandle, MethodHandle, MethodHandle) ，
doWhileLoop(MethodHandle, MethodHandle, MethodHandle) ，
countedLoop(MethodHandle, MethodHandle, MethodHandle) ，
iteratedLoop(MethodHandle, MethodHandle, MethodHandle)

      • whileLoop

        public static MethodHandle whileLoop​(MethodHandle init,
                                     MethodHandle pred,
                                     MethodHandle body)
        从初始化器，身体和谓词构造一个while循环。 这是generic loop combinator的便利包装。

        pred句柄描述了循环条件; 和body ，它的身体。 由此方法产生的循环将在每次迭代中首先评估谓词，然后执行其主体（如果谓词计算为true ）。 一旦谓词计算为false （在这种情况下将不执行正文），循环将终止。

        init句柄描述了附加可选循环局部变量的初始值。 在每次迭代中，此循环局部变量（如果存在）将被传递给body并使用从其调用返回的值进行更新。 循环执行的结果将是附加循环局部变量（如果存在）的最终值。

        以下规则适用于这些参数句柄：

        • body手柄不能是null ; 其类型必须为(V A...)V ，其中V为非void ，否则为(A...)void 。 （在void情况下，我们将类型void分配给名称V ，我们将写入(V A...)V ，理解是void类型的V从参数列表中V地删除，留下(A...)V 。
        • 身体的参数列表(V A...)称为内部参数列表 。 它将限制其他循环部件的参数列表。
        • 如果从内部参数列表中删除迭代变量类型V ，则生成的较短列表(A...)被称为外部参数列表 。
        • 身体返回类型V ，如果void ，则确定循环的附加状态变量的类型。 身体必须同时接受并返回此类型的值V 。
        • 如果init是非null ，它必须具有返回类型V 。 其参数表（一些form (A*) ）必须是effectively identical到外部参数列表(A...) 。
        • 如果init为null ，则循环变量将初始化为其default value 。
        • pred手柄不能是null 。 它必须具有boolean作为其返回类型。 其参数列表（空或格式为(V A*) ）必须与内部参数列表完全相同。

        结果循环句柄的结果类型和参数签名如下确定：

        • 循环句柄的结果类型是身体的结果类型V 。
        • 循环句柄的参数类型是类型(A...) ，来自外部参数列表。

        这里是生成的循环句柄的伪代码。 在代码中， V / v表示唯一循环变量的类型/值以及循环的结果类型; 和A / a ，该参数传递给循环。

 V init(A...);
 boolean pred(V, A...);
 V body(V, A...);
 V whileLoop(A... a...) {
   V v = init(a...);
   while (pred(v, a...)) {
     v = body(v, a...);
   }
   return v;
 }

        API Note:
        例：

 // implement the zip function for lists as a loop handle
 static List<String> initZip(Iterator<String> a, Iterator<String> b) { return new ArrayList<>(); }
 static boolean zipPred(List<String> zip, Iterator<String> a, Iterator<String> b) { return a.hasNext() && b.hasNext(); }
 static List<String> zipStep(List<String> zip, Iterator<String> a, Iterator<String> b) {
   zip.add(a.next());
   zip.add(b.next());
   return zip;
 }
 // assume MH_initZip, MH_zipPred, and MH_zipStep are handles to the above methods
 MethodHandle loop = MethodHandles.whileLoop(MH_initZip, MH_zipPred, MH_zipStep);
 List<String> a = Arrays.asList("a", "b", "c", "d");
 List<String> b = Arrays.asList("e", "f", "g", "h");
 List<String> zipped = Arrays.asList("a", "e", "b", "f", "c", "g", "d", "h");
 assertEquals(zipped, (List<String>) loop.invoke(a.iterator(), b.iterator()));

        ，这种方法的实现可以表达如下：

 MethodHandle whileLoop(MethodHandle init, MethodHandle pred, MethodHandle body) {
     MethodHandle fini = (body.type().returnType() == void.class
                         ? null : identity(body.type().returnType()));
     MethodHandle[]
         checkExit = { null, null, pred, fini },
         varBody   = { init, body };
     return loop(checkExit, varBody);
 }
        参数
        init - 可选的初始化程序，提供循环变量的初始值。 可能是null ，意味着默认的初始值。 见上文其他约束。
        pred - 循环的条件，可能不是null 。 其结果类型必须为boolean 。 见上文其他约束。
        body - 循环体，可能不是null 。 它控制循环参数和结果类型。 见上文其他约束。
        结果
        实现由参数描述的 while循环的方法句柄。
        异常
        IllegalArgumentException - 如果参数的规则被违反。
        NullPointerException - 如果 pred或 body是 null 。
        从以下版本开始：
        9
        另请参见：
        loop(MethodHandle[][]) ， doWhileLoop(MethodHandle, MethodHandle, MethodHandle)

      • doWhileLoop

        public static MethodHandle doWhileLoop​(MethodHandle init,
                                       MethodHandle body,
                                       MethodHandle pred)
        从初始化器，身体和谓词构造一个do-while循环。 这是generic loop combinator的便利包装。

        pred句柄描述了循环条件; 和body ，它的身体。 由此方法产生的循环将在每次迭代中首先执行其身体，然后评估谓词。 一旦执行身体后，谓词计算为false ，循环将终止。

        init句柄描述了附加可选循环局部变量的初始值。 在每次迭代中，此循环局部变量（如果存在）将被传递给body并使用从其调用返回的值进行更新。 循环执行的结果将是附加循环局部变量（如果存在）的最终值。

        以下规则适用于这些参数句柄：

        • body手柄不能是null ; 其类型必须为(V A...)V ，其中V为非void ，否则为(A...)void 。 （在void情况下，我们将类型void分配给名称V ，我们将写入(V A...)V ，理解是void类型V从参数列表中V地删除，留下(A...)V ））
        • 身体的参数列表(V A...)称为内部参数列表 。 它将限制其他循环部件的参数列表。
        • 如果从内部参数列表中删除迭代变量类型V ，则生成的较短列表(A...)称为外部参数列表 。
        • 身体返回类型V ，如果void ，则确定循环的附加状态变量的类型。 身体必须同时接受并返回此类型的值V 。
        • 如果init是非null ，它必须具有返回类型V 。 其参数列表（约form (A*) ）必须为effectively identical ，外部参数列表(A...) 。
        • 如果init是null ，则循环变量将被初始化为其default value 。
        • pred手柄不能是null 。 它必须有boolean作为其返回类型。 其参数列表（空白或格式为(V A*) ）必须与内部参数列表完全相同。

        结果循环句柄的结果类型和参数签名如下确定：

        • 循环句柄的结果类型是身体的结果类型V 。
        • 循环句柄的参数类型是类型(A...) ，来自外部参数列表。

        这里是生成的循环句柄的伪代码。 在代码中， V / v表示唯一循环变量的类型/值以及循环的结果类型; 和A / a ，该参数传递给循环。

 V init(A...);
 boolean pred(V, A...);
 V body(V, A...);
 V doWhileLoop(A... a...) {
   V v = init(a...);
   do {
     v = body(v, a...);
   } while (pred(v, a...));
   return v;
 }

        API Note:
        例：

 // int i = 0; while (i < limit) { ++i; } return i; => limit
 static int zero(int limit) { return 0; }
 static int step(int i, int limit) { return i + 1; }
 static boolean pred(int i, int limit) { return i < limit; }
 // assume MH_zero, MH_step, and MH_pred are handles to the above methods
 MethodHandle loop = MethodHandles.doWhileLoop(MH_zero, MH_step, MH_pred);
 assertEquals(23, loop.invoke(23));

        ，这种方法的实现可以表达如下：

 MethodHandle doWhileLoop(MethodHandle init, MethodHandle body, MethodHandle pred) {
     MethodHandle fini = (body.type().returnType() == void.class
                         ? null : identity(body.type().returnType()));
     MethodHandle[] clause = { init, body, pred, fini };
     return loop(clause);
 }
        参数
        init - 可选的初始化程序，提供循环变量的初始值。 可能是null ，意味着默认的初始值。 见上文其他约束。
        body - 循环体，可能不是null 。 它控制循环参数和结果类型。 见上文其他约束。
        pred - 循环的条件，可能不是null 。 其结果类型必须为boolean 。 见上文其他约束。
        结果
        实现 while循环的方法句柄，如参数所述。
        异常
        IllegalArgumentException - 如果参数的规则被违反。
        NullPointerException - 如果 pred或 body是 null 。
        从以下版本开始：
        9
        另请参见：
        loop(MethodHandle[][]) ， whileLoop(MethodHandle, MethodHandle, MethodHandle)

      • countedLoop

        public static MethodHandle countedLoop​(MethodHandle iterations,
                                       MethodHandle init,
                                       MethodHandle body)
        构造一个运行给定次数迭代的循环。 这是一个方便的包装器generic loop combinator 。

        迭代次数由iterations句柄评估结果确定。 循环计数器i的类型是一个额外的循环迭代变量int 。 它将被初始化为0，并在每次迭代中递增1。

        如果body句柄返回非void类型的V ，则该类型的前导循环迭代变量也存在。 这个变量是使用初始化的可选init手柄，或到default value类型的V如果该句柄是null 。

        在每次迭代中，迭代变量被传递给body句柄的调用。 从主体（类型V ）返回的非void值更新前导迭代变量。 环形手柄执行的结果将是最终V该变量的值（或void如果没有V变量）。

        以下规则适用于参数句柄：

        • iterations句柄不能为null ，必须返回int ，参考类型列表中的I 。
        • body句柄不能是null ; 其类型必须为(V I A...)V ，其中V为非void ，否则为(I A...)void 。 （在void情况下，我们将类型void分配给名称V ，我们将写(V I A...)V ，理解是void类型V从参数列表中V地删除，留下(I A...)V ）
        • 身体的参数列表(V I A...)对称为内部参数列表的类型列表做出贡献。 它将限制其他循环部件的参数列表。
        • 作为一种特殊情况，如果机构仅提供V和I类型，则不附加A类型，则内部参数列表将通过iterations句柄的参数类型A...进行iterations 。
        • 如果从内部参数列表中删除迭代变量类型(V I) ，则生成的较短列表(A...)称为外部参数列表 。
        • 身体返回类型V ，如果void ，则确定循环的附加状态变量的类型。 身体必须同时接受一个前导参数，并返回一个V类型的值。
        • 如果init非null ，它必须具有返回类型V 。 其参数列表（约form (A*) ）必须是effectively identical ，外部参数列表(A...) 。
        • 如果init为null ，则循环变量将初始化为其default value 。
        • iterations （某种形式为(A*) ）的参数表必须与外部参数表(A...)有效相同。

        结果循环句柄的结果类型和参数签名如下确定：

        • 循环手柄的结果类型是身体的结果类型V 。
        • 循环句柄的参数类型是类型(A...) ，来自外部参数列表。

        这里是生成的循环句柄的伪代码。 在代码中， V / v表示第二个循环变量的类型/值以及循环的结果类型; 和A... / a...代表传递给循环论证。

 int iterations(A...);
 V init(A...);
 V body(V, int, A...);
 V countedLoop(A... a...) {
   int end = iterations(a...);
   V v = init(a...);
   for (int i = 0; i < end; ++i) {
     v = body(v, i, a...);
   }
   return v;
 }

        API Note:
        具有完全符合身体方法的示例：

 // String s = "Lambdaman!"; for (int i = 0; i < 13; ++i) { s = "na " + s; } return s;
 // => a variation on a well known theme
 static String step(String v, int counter, String init) { return "na " + v; }
 // assume MH_step is a handle to the method above
 MethodHandle fit13 = MethodHandles.constant(int.class, 13);
 MethodHandle start = MethodHandles.identity(String.class);
 MethodHandle loop = MethodHandles.countedLoop(fit13, start, MH_step);
 assertEquals("na na na na na na na na na na na na na Lambdaman!", loop.invoke("Lambdaman!"));

        ，使用最简单的body方法类型的示例，并将迭代次数传递给循环调用：

 // String s = "Lambdaman!"; for (int i = 0; i < 13; ++i) { s = "na " + s; } return s;
 // => a variation on a well known theme
 static String step(String v, int counter ) { return "na " + v; }
 // assume MH_step is a handle to the method above
 MethodHandle count = MethodHandles.dropArguments(MethodHandles.identity(int.class), 1, String.class);
 MethodHandle start = MethodHandles.dropArguments(MethodHandles.identity(String.class), 0, int.class);
 MethodHandle loop = MethodHandles.countedLoop(count, start, MH_step);  // (v, i) -> "na " + v
 assertEquals("na na na na na na na na na na na na na Lambdaman!", loop.invoke(13, "Lambdaman!"));

        ，将迭代次数，要追加的字符串和字符串作为循环参数附加的示例：

 // String s = "Lambdaman!", t = "na"; for (int i = 0; i < 13; ++i) { s = t + " " + s; } return s;
 // => a variation on a well known theme
 static String step(String v, int counter, int iterations_, String pre, String start_) { return pre + " " + v; }
 // assume MH_step is a handle to the method above
 MethodHandle count = MethodHandles.identity(int.class);
 MethodHandle start = MethodHandles.dropArguments(MethodHandles.identity(String.class), 0, int.class, String.class);
 MethodHandle loop = MethodHandles.countedLoop(count, start, MH_step);  // (v, i, _, pre, _) -> pre + " " + v
 assertEquals("na na na na na na na na na na na na na Lambdaman!", loop.invoke(13, "na", "Lambdaman!"));

        ，示例说明了使用dropArgumentsToMatch(MethodHandle, int, List, int)强制循环类型的示例：

 // String s = "Lambdaman!", t = "na"; for (int i = 0; i < 13; ++i) { s = t + " " + s; } return s;
 // => a variation on a well known theme
 static String step(String v, int counter, String pre) { return pre + " " + v; }
 // assume MH_step is a handle to the method above
 MethodType loopType = methodType(String.class, String.class, int.class, String.class);
 MethodHandle count = MethodHandles.dropArgumentsToMatch(MethodHandles.identity(int.class),    0, loopType.parameterList(), 1);
 MethodHandle start = MethodHandles.dropArgumentsToMatch(MethodHandles.identity(String.class), 0, loopType.parameterList(), 2);
 MethodHandle body  = MethodHandles.dropArgumentsToMatch(MH_step,                              2, loopType.parameterList(), 0);
 MethodHandle loop = MethodHandles.countedLoop(count, start, body);  // (v, i, pre, _, _) -> pre + " " + v
 assertEquals("na na na na na na na na na na na na na Lambdaman!", loop.invoke("na", 13, "Lambdaman!"));

        ，这种方法的实现可以表达如下：

 MethodHandle countedLoop(MethodHandle iterations, MethodHandle init, MethodHandle body) {
     return countedLoop(empty(iterations.type()), iterations, init, body);
 }
        参数
        iterations - 一个非null句柄，用于返回此循环应运行的迭代次数。 手柄的结果类型必须是int 。 见上文其他约束。
        init - 可选的初始化程序，提供循环变量的初始值。 可能是null ，意味着默认的初始值。 见上文其他约束。
        body - 循环体，可能不是null 。 它在标准情况下控制循环参数和结果类型（详见上文）。 它必须接受自己的返回类型（如果非空）加上一个int参数（对于计数器），并且可以接受任何数量的附加类型。 见上文其他约束。
        结果
        表示循环的方法句柄。
        异常
        NullPointerException - 如果 iterations或 body句柄中的任何一个是 null 。
        IllegalArgumentException - 如果有任何论据违反上述规则。
        从以下版本开始：
        9
        另请参见：
        countedLoop(MethodHandle, MethodHandle, MethodHandle, MethodHandle)

      • countedLoop

        public static MethodHandle countedLoop​(MethodHandle start,
                                       MethodHandle end,
                                       MethodHandle init,
                                       MethodHandle body)
        构造一个计数一系列数字的循环。 这是一个方便的包装器generic loop combinator 。

        循环计数器i是类型为int的循环迭代变量。 start和end句柄确定循环计数器的起始（包括）和结束（排除）值。 循环计数器将初始化为从start句柄的评估返回的int值，并运行到步长为1的end （排他）返回的值。

        如果body句柄返回非void类型的V ，则该类型的前导循环迭代变量也存在。 这个变量是使用初始化的可选init手柄，或到default value类型的V如果该句柄是null 。

        在每次迭代中，迭代变量被传递到调用body句柄。 从主体（类型为V ）返回的非void值更新了前导迭代变量。 环形手柄执行的结果将是最终V该变量的值（或void如果没有V变量）。

        以下规则适用于参数句柄：

        • start和end句柄不能是null ，并且必须都返回公共类型int ，在这里称为参数类型列表中的I 。
        • body手柄不能是null ; 其类型必须为(V I A...)V ，其中V为非void ，否则为(I A...)void 。 （在void情况下，我们将类型void分配给名称V ，我们将写(V I A...)V ，理解是void类型V从参数列表中V地删除，留下(I A...)V ）
        • 身体的参数列表(V I A...)有助于称为内部参数列表的类型的列表 。 它将限制其他循环部件的参数列表。
        • 作为一种特殊情况，如果机构仅提供V和I类型，而不附加A类型，则内部参数列表将通过end句柄的参数类型A...进行end 。
        • 如果从内部参数列表中删除迭代变量类型(V I) ，则生成的较短列表(A...)称为外部参数列表 。
        • 身体返回类型V ，如果非void ，则确定循环的附加状态变量的类型。 主体必须同时接受一个前导参数，并返回一个V类型的值。
        • 如果init是非null ，它必须具有返回类型V 。 其参数表（一些form (A*) ）必须是effectively identical到外部参数列表(A...) 。
        • 如果init为null ，则循环变量将被初始化为其default value 。
        • start （某种形式为(A*) ）的参数表必须与外部参数表(A...)有效地相同。
        • 同样， end的参数表必须与外部参数列表有效地相同。

        结果循环句柄的结果类型和参数签名如下确定：

        • 循环手柄的结果类型是身体的结果类型V 。
        • 循环句柄的参数类型是类型(A...) ，来自外部参数列表。

        这里是生成的循环句柄的伪代码。 在代码中， V / v表示第二个循环变量的类型/值以及循环的结果类型; 和A... / a...代表传递给循环论证。

 int start(A...);
 int end(A...);
 V init(A...);
 V body(V, int, A...);
 V countedLoop(A... a...) {
   int e = end(a...);
   int s = start(a...);
   V v = init(a...);
   for (int i = s; i < e; ++i) {
     v = body(v, i, a...);
   }
   return v;
 }

        API Note:
        该方法的实现可以表达如下：

 MethodHandle countedLoop(MethodHandle start, MethodHandle end, MethodHandle init, MethodHandle body) {
     MethodHandle returnVar = dropArguments(identity(init.type().returnType()), 0, int.class, int.class);
     // assume MH_increment and MH_predicate are handles to implementation-internal methods with
     // the following semantics:
     // MH_increment: (int limit, int counter) -> counter + 1
     // MH_predicate: (int limit, int counter) -> counter < limit
     Class<?> counterType = start.type().returnType();  // int
     Class<?> returnType = body.type().returnType();
     MethodHandle incr = MH_increment, pred = MH_predicate, retv = null;
     if (returnType != void.class) {  // ignore the V variable
         incr = dropArguments(incr, 1, returnType);  // (limit, v, i) => (limit, i)
         pred = dropArguments(pred, 1, returnType);  // ditto
         retv = dropArguments(identity(returnType), 0, counterType); // ignore limit
     }
     body = dropArguments(body, 0, counterType);  // ignore the limit variable
     MethodHandle[]
         loopLimit  = { end, null, pred, retv }, // limit = end(); i < limit || return v
         bodyClause = { init, body },            // v = init(); v = body(v, i)
         indexVar   = { start, incr };           // i = start(); i = i + 1
     return loop(loopLimit, bodyClause, indexVar);
 }
        参数
        start - 一个非null句柄返回循环计数器的int ，它必须是int 。 见上文其他约束。
        end - 一个非null句柄来返回循环计数器的结束值（循环将运行到end-1 ）。 结果类型必须是int 。 见上文其他约束。
        init - 可选的初始化程序，提供循环变量的初始值。 可能是null ，意味着默认的初始值。 见上文其他约束。
        body - 循环体，可能不是null 。 它在标准情况下控制循环参数和结果类型（详见上文）。 它必须接受自己的返回类型（如果是非int ）加上一个int参数（对于计数器），并且可以接受任何数量的附加类型。 见上文其他约束。
        结果
        表示循环的方法句柄。
        异常
        NullPointerException -如果任何的 start ， end ，或 body手柄为 null 。
        IllegalArgumentException - 如果有任何争议违反上述规则。
        从以下版本开始：
        9
        另请参见：
        countedLoop(MethodHandle, MethodHandle, MethodHandle)

      • iteratedLoop

        public static MethodHandle iteratedLoop​(MethodHandle iterator,
                                        MethodHandle init,
                                        MethodHandle body)
        构造一个范围超过由Iterator<T>生成的值的Iterator<T> 。 这是generic loop combinator的便利包装。

        迭代器本身将由iterator句柄的评估来确定。 它产生的每个值都将存储在类型为T的循环迭代变量中。

        如果body句柄返回一个非void类型的V ，则该类型的前导循环迭代变量也存在。 该变量使用可选的init句柄进行初始化，或V的V如果该句柄为null 。

        在每次迭代中，迭代变量被传递到调用body句柄。 从主体（类型V ）返回的非void值更新前导迭代变量。 环形手柄执行的结果将是最终V该变量的值（或void如果没有V变量）。

        以下规则适用于参数句柄：

        • body手柄不能是null ; 其类型必须为(V T A...)V ，其中V为非void ，否则为(T A...)void 。 （在void情况下，我们将void的类型分配给V ，我们将写入(V T A...)V ，理解是void类型的V从参数列表中(T A...)V ，留下(T A...)V 。
        • 身体的参数列表(V T A...)对称为内部参数列表的类型的列表做出贡献。 它将限制其他循环部件的参数列表。
        • 作为一种特殊情况，如果机构仅提供V和T类型，不附加A类型，则内部参数列表将通过iterator句柄的参数类型A...进行iterator ; 如果是null ，添加单个类型Iterable ，构成A...列表。
        • 如果从内部参数列表中删除迭代变量类型(V T) ，则生成的较短列表(A...)称为外部参数列表 。
        • 身体返回类型V ，如果void ，则确定循环的附加状态变量的类型。 主体必须同时接受一个前导参数，并返回一个V类型的值。
        • 如果init是非null ，它必须具有返回类型V 。 其参数列表（约form (A*) ）必须为effectively identical ，外部参数列表为(A...) 。
        • 如果init为null ，则循环变量将初始化为其default value 。
        • 如果iterator句柄为非null ，则必须具有返回类型java.util.Iterator或其子类型。 执行循环时产生的迭代器将被假定为产生可转换为类型T 。
        • 一个的参数列表iterator即非null （的某种形式的(A*) ）必须有效地等同于外部参数列表(A...) 。
        • 如果iterator为null则默认为方法句柄，其行为类似于Iterable.iterator() 。 在这种情况下，内部参数表(V T A...)必须至少有一个A类型，并且默认的迭代器句柄参数被调整为接受前导的A类型，好像通过asType转换方法。 领先的A类型必须是Iterable或其子类型。 这个转换步骤，在循环施工时完成，不能抛出一个WrongMethodTypeException 。

        类型T可以是原语或参考。 由于类型Iterator<T>在该方法手柄表示被擦除到原始类型Iterator ，所述iteratedLoop组合子调整为主导参数类型body到Object仿佛由asType转换方法。 因此，如果循环执行时出现错误类型的迭代器，则可能会由于MethodHandle.asType(MethodType)执行的动态转换而导致运行时异常。

        结果循环句柄的结果类型和参数签名如下确定：

        • 循环手柄的结果类型是身体的结果类型V 。
        • 循环句柄的参数类型是类型(A...) ，来自外部参数列表。

        这里是生成的循环句柄的伪代码。 在代码中， V / v表示循环变量的类型/值以及循环的结果类型; T / t ，该结构的循环迭代的元素，和A... / a...表示传递给循环参数。

 Iterator<T> iterator(A...);  // defaults to Iterable::iterator
 V init(A...);
 V body(V,T,A...);
 V iteratedLoop(A... a...) {
   Iterator<T> it = iterator(a...);
   V v = init(a...);
   while (it.hasNext()) {
     T t = it.next();
     v = body(v, t, a...);
   }
   return v;
 }

        API Note:
        例：

 // get an iterator from a list
 static List<String> reverseStep(List<String> r, String e) {
   r.add(0, e);
   return r;
 }
 static List<String> newArrayList() { return new ArrayList<>(); }
 // assume MH_reverseStep and MH_newArrayList are handles to the above methods
 MethodHandle loop = MethodHandles.iteratedLoop(null, MH_newArrayList, MH_reverseStep);
 List<String> list = Arrays.asList("a", "b", "c", "d", "e");
 List<String> reversedList = Arrays.asList("e", "d", "c", "b", "a");
 assertEquals(reversedList, (List<String>) loop.invoke(list));

        ，该方法的实现可以大致表示如下：

 MethodHandle iteratedLoop(MethodHandle iterator, MethodHandle init, MethodHandle body) {
     // assume MH_next, MH_hasNext, MH_startIter are handles to methods of Iterator/Iterable
     Class<?> returnType = body.type().returnType();
     Class<?> ttype = body.type().parameterType(returnType == void.class ? 0 : 1);
     MethodHandle nextVal = MH_next.asType(MH_next.type().changeReturnType(ttype));
     MethodHandle retv = null, step = body, startIter = iterator;
     if (returnType != void.class) {
         // the simple thing first:  in (I V A...), drop the I to get V
         retv = dropArguments(identity(returnType), 0, Iterator.class);
         // body type signature (V T A...), internal loop types (I V A...)
         step = swapArguments(body, 0, 1);  // swap V <-> T
     }
     if (startIter == null)  startIter = MH_getIter;
     MethodHandle[]
         iterVar    = { startIter, null, MH_hasNext, retv }, // it = iterator; while (it.hasNext())
         bodyClause = { init, filterArguments(step, 0, nextVal) };  // v = body(v, t, a)
     return loop(iterVar, bodyClause);
 }
        参数
        iterator - 返回迭代器启动循环的可选句柄。 如果非null ，手柄必须返回Iterator或一个子类型。 见上文其他约束。
        init - 可选的初始化器，提供循环变量的初始值。 可能是null ，暗示默认的初始值。 见上文其他约束。
        body - 循环体，可能不是null 。 它在标准情况下控制循环参数和结果类型（详见上文）。 它必须接受自己的返回类型（如果是非T ）加上一个T参数（对于迭代值），并且可以接受任何数量的其他类型。 见上文其他约束。
        结果
        体现迭代循环功能的方法句柄。
        异常
        NullPointerException - 如果 body句柄是 null 。
        IllegalArgumentException - 如果任何参数违反上述要求。
        从以下版本开始：
        9

      • tryFinally

        public static MethodHandle tryFinally​(MethodHandle target,
                                      MethodHandle cleanup)
        创建一个方法句柄，通过将其包装在一个try-finally块中来适应target方法句柄。 另一个方法手柄， cleanup ，代表finally块的功能。 在执行target句柄期间抛出的任何异常都将传递给cleanup句柄。 除非cleanup处理会引发异常，否则将被cleanup抛出异常。 从返回的值cleanup手柄的执行将是执行的结果try-finally手柄。

        cleanup句柄将被传递一个或两个额外的前导参数。 第一个是在执行target句柄期间抛出的异常，或者如果没有抛出异常， null 。 第二个是执行target句柄的结果，或者如果它引发异常，则需要一个null或false所需类型的值作为占位符。 如果target句柄具有void返回类型，则第二个参数不存在。 （需要注意的是，除了参数类型转换，组合子表示void通过省略相应的自相矛盾的论点，而不是通过插入在参数列表值null或零值）。

        target和cleanup句柄必须具有相同的对应参数和返回类型，不同之处在于cleanup句柄可以省略尾随参数。 此外， cleanup句柄必须有一个或两个额外的前导参数：

        • 一个Throwable ，它将携带由target句柄（如果有的话）抛出的异常; 和
        • 与target和cleanup的返回类型相同类型的参数，其将携带执行target句柄的结果。 如果target返回void ，则此参数不存在。

        生成的适配器的伪代码如下。 在代码中， V代表try/finally结构的结果类型; A / a ，类型和参数，以由所述的清理消耗所得句柄值; 和B ，那些通过清理b的结果句柄的参数。

 V target(A..., B...);
 V cleanup(Throwable, V, A...);
 V adapter(A... a, B... b) {
   V result = (zero value for V);
   Throwable throwable = null;
   try {
     result = target(a..., b...);
   } catch (Throwable t) {
     throwable = t;
     throw t;
   } finally {
     result = cleanup(throwable, result, a...);
   }
   return result;
 }

        请注意，保存的参数（伪代码中的a... ）无法通过执行目标进行修改，如果调用该引用，参数将从调用程序不a...改为清理。

        目标和清理必须返回相同的类型，即使清理总是抛出。 要创建这样一个抛出的清理，使用throwException编写清理逻辑，以创建正确返回类型的方法句柄。

        请注意， tryFinally不会将异常转换为正常返回。 在极少数情况下，必须以这种方式转换异常，首先用catchException(MethodHandle, Class, MethodHandle)包装目标以捕获传出的异常，然后用tryFinally包装。

        参数
        target - 其执行将包装在一个 try块中的 try 。
        cleanup - finally块中调用的句柄。
        结果
        一个体现 try-finally块的方法句柄由两个参数组成。
        异常
        NullPointerException - 如果任何参数为空
        IllegalArgumentException - 如果 cleanup不接受所需的前导参数，或者方法句柄类型在其返回类型及其对应的尾随参数中不匹配
        从以下版本开始：
        9
        另请参见：
        catchException(MethodHandle, Class, MethodHandle)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodHandles.Lookup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class MethodHandles.Lookup

  • java.lang.Object
    • java.lang.invoke.MethodHandles.Lookup
  • Enclosing class:
    MethodHandles

    public static final class MethodHandles.Lookup
extends Object
    查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。 方法句柄在调用时不执行访问检查，而是在创建时执行访问检查。 因此，当创建方法句柄时，必须强制执行方法句柄访问限制。 这些限制被强制执行的调用类被称为lookup class 。

    需要创建方法句柄的查找类将调用MethodHandles.lookup为自己创建一个工厂。 当创建Lookup工厂对象时，确定查找类的标识，并将其安全地存储在Lookup对象中。 查找类（或其Lookup ）可以使用Lookup对象上的工厂方法来创建访问检查成员的方法句柄。 这包括允许查找类的所有方法，构造函数和字段，甚至是私有的。

    查找工厂方法

    Lookup对象上的工厂方法对应于方法，构造函数和字段的所有主要用例。 由工厂方法创建的每个方法句柄都是特定字节码行为的功能等价物。 （字节码行为在Java虚拟机规范的5.4.3.5节中描述。）这是这些工厂方法与生成的方法句柄的行为之间的对应关系的总结： lookup method behaviors lookup expression member bytecode behavior lookup.findGetter(C.class,"f",FT.class) FT f; (T) this.f; lookup.findStaticGetter(C.class,"f",FT.class) static
    FT f; (T) C.f; lookup.findSetter(C.class,"f",FT.class) FT f; this.f = x; lookup.findStaticSetter(C.class,"f",FT.class) static
    FT f; C.f = arg; lookup.findVirtual(C.class,"m",MT) T m(A*); (T) this.m(arg*); lookup.findStatic(C.class,"m",MT) static
    T m(A*); (T) C.m(arg*); lookup.findSpecial(C.class,"m",MT,this.class) T m(A*); (T) super.m(arg*); lookup.findConstructor(C.class,MT) C(A*); new C(arg*); lookup.unreflectGetter(aField) (static)?
    FT f; (FT) aField.get(thisOrNull); lookup.unreflectSetter(aField) (static)?
    FT f; aField.set(thisOrNull, arg); lookup.unreflect(aMethod) (static)?
    T m(A*); (T) aMethod.invoke(thisOrNull, arg*); lookup.unreflectConstructor(aConstructor) C(A*); (C) aConstructor.newInstance(arg*); lookup.unreflect(aMethod) (static)?
    T m(A*); (T) aMethod.invoke(thisOrNull, arg*); lookup.findClass("C") class C { ... } C.class;
    这里，类型C是搜索成员的类或接口，在查找方法中被记录为名为refc的参数。 方法类型MT由返回类型T和参数类型序列A* 。 构造函数还具有一系列参数类型A* ，并被视为返回新创建的类型为C对象。 MT和字段类型FT都记录为名称为type的参数。 形式参数this代表C型的自参照; 如果它存在，它始终是方法句柄调用的主要参数。 （在某些protected成员的情况下， this可能在类型中被限制到查找类;见下文）。名称arg代表所有其他方法句柄参数。 在Core Reflection API的代码示例中，如果访问的方法或字段为静态，则名称为thisOrNull表示空引用，否则为this 。 名称aMethod ， aField和aConstructor支架对应于给定的成员反射物体。

    findClass操作的字节码行为是一个常量类的负载，好像通过ldc CONSTANT_Class 。 行为被表示，而不是方法句柄，而是直接作为一个Class常量。

    在给定成员具有可变权限（即，方法或构造方法）的情况下，返回的方法句柄也将为variable arity 。 在所有其他情况下，返回的方法句柄将是固定的。

    讨论：查找方法句柄和底层类成员和字节码行为之间的等价性可以通过以下几种方法分解：

    • 如果C不能从查找类的加载器中进行符号访问，即使没有等效的Java表达式或字节码常量，查找仍然可以成功。
    • 同样，如果T或MT不能从查找类的加载器中进行符号访问，则查找仍然可以成功。 例如，无论请求类型如何， MethodHandle.invokeExact和MethodHandle.invoke查找将始终成功。
    • 如果安装了一个安全管理器，它可以禁止在各种情况下查找（ see below ）。 相比之下， ldc指令对CONSTANT_MethodHandle常数不进行安全管理员检查。
    • 如果查找方法有一个very large arity ，方法句柄创建可能会失败，因为方法句柄类型具有太多的参数。

    访问检查

    当创建方法句柄时，访问检查应用于工厂方法Lookup 。 这是与Core Reflection API的关键区别，因为java.lang.reflect.Method.invoke对每个呼叫者进行每次呼叫的访问检查。

    所有访问检查从Lookup对象开始，它将其记录的查找类与所有请求进行比较，以创建方法句柄。 单个Lookup对象可用于创建任意数量的访问检查方法句柄，所有这些都针对单个查找类进行检查。

    一个Lookup对象可以与其他可信代码共享，如元对象协议。 共享的Lookup对象委派了在查找类的私有成员上创建方法句柄的功能。 即使特权代码使用Lookup对象，访问检查仅限于原始查找类的权限。

    查找可能会失败，因为查找类不能访问包含的类，或者因为缺少所需的类成员，或者因为查找类不能访问所需的类成员，或者因为查找对象不够信任访问会员 在任何这些情况下，将从尝试查找中抛出ReflectiveOperationException 。 确切的课程将是以下之一：

    • NoSuchMethodException - 如果请求但不存在的方法
    • NoSuchFieldException - 如果一个字段被请求但不存在
    • IllegalAccessException - 如果成员存在，但访问检查失败

    通常，可以查找方法方法M的方法句柄的条件不比查找类可以编译，验证和解析到M的调用的条件更多的限制。 JVM会引发像NoSuchMethodError这样的NoSuchMethodError ，方法句柄查找通常会引发相应的检查异常，如NoSuchMethodException 。 并且调用由查找产生的方法句柄的效果是exactly equivalent执行编译，验证和解析的调用M 。 字段和构造函数也是一样的。

    讨论：访问检查仅适用于命名和反映的方法，构造函数和字段。 其他方法句柄创建方法，如MethodHandle.asType ，不需要任何访问检查，并且独立于任何Lookup对象使用。

    如果所需的成员是protected ，通常的JVM规则将适用，包括要求查找类必须与所需成员位于同一个包中，或者必须继承该成员。 （请参阅Java虚拟机规范，第4.9.2,5.4.3.5和6.4节）。另外，如果所需成员是不同包中的非静态字段或方法，则生成的方法句柄只能应用于查找类的对象或其子类之一。 这一要求通过缩窄导致的类型强制this参数从C （将必然是查找类的超类）到查找类本身。

    JVM对invokespecial指令提出了类似的要求，接收方参数必须与已解析方法和当前类匹配。 同样，通过将引导参数的类型缩小到生成的方法句柄来强制执行此要求。 （请参阅Java虚拟机规范，第4.10.1.9节。）

    JVM表示作为具有特殊名称的内部方法（ "<init>"和"<clinit>" ）的构造函数和静态初始化程序块。 调用指令的内部语法允许它们引用这些内部方法，就像它们是正常方法一样，但是JVM字节码验证器拒绝它们。 这种内部方法的查找将产生一个NoSuchMethodException 。

    在某些情况下，Java编译器可以通过创建包装方法来访问同一顶层声明中另一个类的私有方法来获取嵌套类之间的访问。 例如，一个嵌套类C.D可以其他相关的类如内访问私有成员C ， C.D.E ，或C.B ，但是Java编译器可能需要生成在这些相关的类包装方法。 在这种情况下，一个Lookup的对象C.E将无法将这些私有成员。 此限制的解决方法是Lookup.in方法，可以将C.E的查找C.E为任何其他类中的查找，而不特别提升权限。

    允许给定查找对象的访问可以根据其集合lookupModes限制到查找类通常可访问的成员的子集。 例如， publicLookup方法生成一个查找对象，该对象只允许访问导出包的公共类中的公共成员。 调用者敏感方法lookup产生一个查找对象，具有相对于其调用者类的完整功能，以模拟所有支持的字节码行为。 此外， Lookup.in方法可能产生一个查找对象，其访问模式比原始查找对象少。

    私人访问 讨论：如果lookup modes包含访问private成员的可能性，我们认为查找具有私有访问权限 。 如其他相关方法中所述，只有具有私有访问权限的查询具有以下功能：

    • 访问查找类的私有字段，方法和构造函数
    • 创建方法手柄，调用caller sensitive方法，如Class.forName
    • 创建方法处理哪些emulate invokespecial指令
    • 避免package access checks查找类可访问的类
    • 创建delegated lookup objects ，它们具有对同一个包成员内的其他类的私有访问

    这些权限中的每一个都是这样一个事实的结果：具有私有访问的查找对象可以安全地追溯到一个始发类，其起始类可以可靠地确定其bytecode behaviors和Java语言访问权限并通过方法句柄进行仿真。

    安全管理器交互

    虽然字节码指令只能引用相关类加载器中的类，但是该API可以搜索任何类中的方法，只要对其Class对象的引用可用即可。 Core Reflection API也可以使用这种跨装载程序引用，并且不可能使用诸如invokestatic或getfield字节码指令。 有一个security manager API允许应用程序检查这样的跨装载程序引用。 这些检查适用于MethodHandles.Lookup API和Core Reflection API（见Class ）。

    如果存在安全管理员，则成员和类查找需要额外的检查。 从一到三个电话是安全管理员。 任何这些电话可以通过抛出一个SecurityException拒绝访问。 限定smgr作为安全管理器， lookc作为查找类的当前查找对象，的refc作为其中成员正在寻求包含类，和defc作为其中构件被实际定义的类。 （如果一个类或其他类型的被存取时， refc个defc值是类本身。）的值lookc被定义为不存在 ，如果当前查找对象不具有private access 。 呼叫是按照以下规则进行的：

    • 步骤1：如果lookc不存在，或者如果它的类加载器是不一样的或的类加载器的祖先refc ，然后smgr.checkPackageAccess(refcPkg)被调用，其中refcPkg是的包refc 。
    • 步骤2a：如果检索的成员不是公开的，并且lookc不存在，则RuntimePermission("accessDeclaredMembers")与RuntimePermission("accessDeclaredMembers")被调用。
    • 步骤2b：如果检索到的类有一个null类加载器，并且lookc不存在，则smgr.checkPermission与RuntimePermission("getClassLoader")被调用。
    • 步骤3：如果所检索的部件是不公开的，而如果lookc不存在，并且如果defc和refc不同，则smgr.checkPackageAccess(defcPkg)被调用，其中defcPkg是的包defc 。
    在通过其他访问检查之后执行安全检查。 因此，上述规则预先假定是一个公共的成员或类，或者正在从具有访问成员或类的权限的查找类访问。

    来电者敏感方法

    少量的Java方法有一个特殊的属性叫做呼叫者敏感性。 来电者敏感的方法可以根据其直接呼叫者的身份而有所不同。

    如果请求了一个方法的方法句柄，则应用bytecode behaviors的一般规则，但以特殊方式考虑查找类。 生成的方法句柄就像从查找类中包含的指令调用一样，以便调用者敏感的方法检测查找类。 （相比之下，方法句柄的调用者被忽略。）因此，在调用者敏感方法的情况下，不同的查找类可能会产生不同行为的方法句柄。

    在查找对象为publicLookup()或其他没有private access的查找对象的情况下 ，查找类被忽略。 在这种情况下，不能创建调用者敏感方法句柄，禁止访问，并且查找失败，并使用IllegalAccessException 。

    讨论：例如，呼叫者敏感的方法Class.forName(x)可以返回不同的类或抛出不同的异常，这取决于调用它的类的类加载器。 Class.forName的公开查询将失败，因为没有合理的方式来确定其字节码行为。

    如果应用程序缓存方法句柄进行广泛共享，则应使用publicLookup()创建它们。 如果有一个Class.forName的查找，它将失败，并且应用程序必须在这种情况下采取适当的措施。 可能是在引用引导方法的调用期间的后续查找可以包含调用者的特定身份，从而使该方法可访问。

    功能MethodHandles.lookup是调用者敏感的，因此可以有一个用于查找的安全基础。 JSR 292 API中几乎所有其他方法都依赖于查找对象来检查访问请求。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int MODULE
      代表 module访问（默认访问）的单位掩码，这可能有助于 lookupModes的结果。
      static int PACKAGE
      代表 package访问（默认访问）的单位掩码，这可能有助于 lookupModes的结果。
      static int PRIVATE
      代表 private访问的单位掩码，可能有助于 lookupModes的结果。
      static int PROTECTED
      代表 protected访问的单位掩码，这可能有助于 lookupModes的结果。
      static int PUBLIC
      一个表示 public访问的单位掩码，这可能有助于 lookupModes的结果。
      static int UNCONDITIONAL
      代表 unconditional访问的单位掩码可能有助于 lookupModes的结果。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Class<?> accessClass​(Class<?> targetClass)
      确定是否可以从此 Lookup对象定义的查找上下文中访问类。
      MethodHandle bind​(Object receiver, String name, MethodType type)
      为非静态方法生成早期绑定的方法句柄。
      Class<?> defineClass​(byte[] bytes)
      定义一个类到同一个类加载器，并在同一个运行时包和protection domain作为这个查找的lookup class 。
      MethodHandles.Lookup dropLookupMode​(int modeToDrop)
      在同一查找类中创建一个查找，该查找对象查找成员，但查找模式已丢失给定的查找模式。
      Class<?> findClass​(String targetName)
      从这个 Lookup对象定义的查找上下文中按名称查找一个类。
      MethodHandle findConstructor​(Class<?> refc, MethodType type)
      使用指定类型的构造函数生成创建对象并初始化它的方法句柄。
      MethodHandle findGetter​(Class<?> refc, String name, Class<?> type)
      产生方法句柄，给非静态字段的读访问权限。
      MethodHandle findSetter​(Class<?> refc, String name, Class<?> type)
      产生一个给非静态字段写入访问权限的方法句柄。
      MethodHandle findSpecial​(Class<?> refc, String name, MethodType type, Class<?> specialCaller)
      为虚拟方法生成早期绑定的方法句柄。
      MethodHandle findStatic​(Class<?> refc, String name, MethodType type)
      为静态方法生成方法句柄。
      MethodHandle findStaticGetter​(Class<?> refc, String name, Class<?> type)
      产生一个给静态字段读取访问权限的方法句柄。
      MethodHandle findStaticSetter​(Class<?> refc, String name, Class<?> type)
      生成方法句柄，给静态字段写权限。
      VarHandle findStaticVarHandle​(Class<?> decl, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的静态字段 decl 。
      VarHandle findVarHandle​(Class<?> recv, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的非静态字段 recv 。
      MethodHandle findVirtual​(Class<?> refc, String name, MethodType type)
      为虚拟方法生成方法句柄。
      boolean hasPrivateAccess​()
      如果此查找具有 PRIVATE访问权限，则返回 true 。
      MethodHandles.Lookup in​(Class<?> requestedLookupClass)
      在指定的新查找类上创建一个查找。
      Class<?> lookupClass​()
      告诉哪个类执行查找。
      int lookupModes​()
      告诉这个查找对象可以产生哪些访问保护类的成员。
      MethodHandleInfo revealDirect​(MethodHandle target)
      破解由此查找对象或类似的对象创建的一个 direct method handle 。
      String toString​()
      显示要从中进行查找的类的名称。
      MethodHandle unreflect​(方法 m)
      如果查找类有权限，则创建一个 direct method handle的 m 。
      MethodHandle unreflectConstructor​(Constructor<?> c)
      为反射的构造函数生成方法句柄。
      MethodHandle unreflectGetter​(Field f)
      产生方法句柄，给予反映字段的读访问权限。
      MethodHandle unreflectSetter​(Field f)
      产生一个方法句柄，给一个反射的字段写权限。
      MethodHandle unreflectSpecial​(方法 m, Class<?> specialCaller)
      为反映的方法生成方法句柄。
      VarHandle unreflectVarHandle​(Field f)
      产生一个VarHandle，可以访问 f类中声明的类型为 T的反射字段 R 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • PUBLIC

        public static final int PUBLIC
        代表public访问的单位掩码，这可能有助于lookupModes的结果。 该值0x01恰好与public modifier bit的值相同。
        另请参见：
        Constant Field Values

      • PRIVATE

        public static final int PRIVATE
        代表private访问的单位掩码，可能有助于lookupModes的结果。 该值0x02恰好与private modifier bit的值相同。
        另请参见：
        Constant Field Values

      • PROTECTED

        public static final int PROTECTED
        代表protected访问的单位掩码，可能有助于lookupModes的结果。 该值0x04恰好与protected modifier bit的值相同。
        另请参见：
        Constant Field Values

      • PACKAGE

        public static final int PACKAGE
        代表package访问（默认访问）的单位掩码，这可能有助于lookupModes的结果。 该值为0x08 ，与任何特定的modifier bit无关 。
        另请参见：
        Constant Field Values

      • MODULE

        public static final int MODULE
        代表module访问（默认访问）的单位掩码，这可能有助于lookupModes的结果。 该值为0x10 ，与任何特定的modifier bit无关 。 结合PUBLIC修饰符位，具有此查找模式的Lookup可以访问查找类的模块中的所有公共类型以及其他模块导出的包中的公共类型到查找类的模块。
        从以下版本开始：
        9
        另请参见：
        Constant Field Values

      • UNCONDITIONAL

        public static final int UNCONDITIONAL
        代表unconditional访问的单位掩码可能有助于lookupModes的结果。 该值为0x20 ，与任何特定的modifier bit无关 。 一个Lookup这种查找模式取得readability 。 结合PUBLIC修改者位，具有此查找模式的Lookup可以访问所有公钥类型的所有公共成员，其中类型为exported unconditionally的包。
        从以下版本开始：
        9
        另请参见：
        MethodHandles.publicLookup() ， Constant Field Values

    • 方法详细信息

      • lookupClass

        public Class<?> lookupClass​()
        告诉哪个类执行查找。 正是这种针对哪些检查执行可见性和访问权限的类。

        该类意味着访问许可的最大级别，但是该权限可能另外受到位掩码lookupModes的限制，该位掩码控制是否可以访问非公共成员。

        结果
        查找类，代表此查找对象查找成员

      • lookupModes

        public int lookupModes​()
        告诉这个查找对象可以产生哪些访问保护类的成员。 结果是比特的位掩码PUBLIC (0x01) ， PRIVATE (0x02) ， PROTECTED (0x04) ， PACKAGE (0x08) ， MODULE (0x10) ，和UNCONDITIONAL (0x20) 。

        caller's class上新创建的查找对象具有所有可能的位，除了UNCONDITIONAL 。 查找可用于访问调用者类的所有成员，调用者模块中的所有公共类型以及其他模块导出到调用者模块的包中的所有公共类型。 新查找类created from a previous lookup object上的查找对象可能将某些模式位设置为零。 模式位也可以是directly cleared 。 一旦清除，模式位不能从降级的查找对象恢复。 这样做的目的是通过新的查找对象限制访问，以便它只能访问原始查找对象可以访问的名称，也可以访问新的查找类。

        结果
        查找模式，限制由该查找对象执行的访问的种类
        另请参见：
        in(java.lang.Class<?>) ， dropLookupMode(int)

      • in

        public MethodHandles.Lookup in​(Class<?> requestedLookupClass)
        在指定的新查找类上创建一个查找。 生成的对象将报告指定的类作为自己的lookupClass 。

        但是，所得到的Lookup对象保证没有比原来更多的访问能力。 特别是，访问功能可能会丢失如下：

        • 如果旧查找类在一个named模块中，并且新的查找类位于不同的模块M ，则M的导出包中的任何成员甚至公共成员也不可访问。 这个例外是当这个查找是publicLookup ，在这种情况下， PUBLIC访问不会丢失。
        • 如果旧的查找类在一个未命名的模块中，并且新的查找类是不同的模块，那么MODULE访问将丢失。
        • 如果新的查找类与旧的查找类不同，则丢失UNCONDITIONAL 。
        • 如果新的查找类与旧的查找类不同，则保护和默认（包）成员将无法访问。
        • 如果新的查找类与旧的查找类不在同一个包成员内，则私有成员将无法访问，受保护的成员将无法通过继承访问。 （受保护的成员可能因为包的共享而可以访问。）
        • 如果旧的查找类不能访问新的查找类，那么任何成员，甚至公共成员都不可访问。 （在所有其他情况下，公共成员将继续可访问。）

        结果查找的加载类（在findClass(java.lang.String)调用期间使用）的功能由查找类'加载器确定，这可能由于此操作而改变。

        参数
        requestedLookupClass - 新查找对象所需的查找类
        结果
        报告所需查找类的查找对象，如果没有变化则是相同的对象
        异常
        NullPointerException - 如果参数为空

      • dropLookupMode

        public MethodHandles.Lookup dropLookupMode​(int modeToDrop)
        在同一查找类中创建一个查找，该查找对象查找成员，但查找模式已丢失给定的查找模式。 查找模式下降是一个PUBLIC ， MODULE ， PACKAGE ， PROTECTED或PRIVATE 。 PROTECTED和UNCONDITIONAL总是丢弃，因此所得到的查找模式将永远不具有这些访问功能。 当丢弃PACKAGE ，所得到的查找将不具有PACKAGE或PRIVATE访问权限。 当拖放MODULE然后将得到的查找不会有MODULE ， PACKAGE ，或PRIVATE访问。 如果PUBLIC被删除，则生成的查找将无法访问。
        参数
        modeToDrop - 查找模式下降
        结果
        缺少指示模式的查找对象，如果没有变化则是相同的对象
        异常
        IllegalArgumentException -如果 modeToDrop不是一个 PUBLIC ， MODULE ， PACKAGE ， PROTECTED ， PRIVATE或 UNCONDITIONAL
        从以下版本开始：
        9
        另请参见：
        MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • defineClass

        public Class<?> defineClass​(byte[] bytes)
                     throws IllegalAccessException
        将类定义到相同的类加载器，并在同一个运行时包中，以及protection domain作为此查找的lookup class 。

        该查找的lookup modes必须包括PACKAGE访问作为默认（包）成员可以访问该类。 PACKAGE查找模式用于验证查找对象是由运行时程序包中的调用者创建的（或从最初由适当的特权代码创建的查找派生到运行时程序包中的目标类）创建的。

        bytes参数是与查找类在同一个包中的类名称的有效类文件（由Java虚拟机规范定义）的类字节。

        此方法不运行类初始化程序。 类初始化程序可以在稍后的时间运行，如“Java语言规范”第12.4节所述。

        如果有安全管理员，则首先要求其checkPermission方法检查RuntimePermission("defineClass") 。

        参数
        bytes - 类字节
        结果
        Class对象
        异常
        IllegalArgumentException - 字节是针对查找类的不同包中的类
        IllegalAccessException - 如果此查找没有 PACKAGE访问
        LinkageError - 如果类格式错误（ ClassFormatError ），无法验证（ VerifyError ），已经定义，或者发生另一个链接错误
        SecurityException - 如果安全管理员否认
        NullPointerException - 如果 bytes是 null
        从以下版本开始：
        9
        另请参见：
        MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup) ， dropLookupMode(int) ， ClassLoader.defineClass(String,byte[],int,int,ProtectionDomain)

      • toString

        public String toString​()
        显示要从中进行查找的类的名称。 （该名称是由Class.getName报告的。）如果对该查找允许的访问有限制，则通过在类名称中添加一个后缀（由斜杠和关键字组成）来指示。 该关键字表示最强的访问权限，选择如下：
        • 如果不允许访问，则后缀为“/ noaccess”。
        • 如果只允许对导出包中的类型进行公共访问，则后缀为“/ public”。
        • 如果只允许公共访问和无条件访问，则后缀为“/ publicLookup”。
        • 如果只允许公共和模块访问，则后缀为“/ module”。
        • 如果只允许公共，模块和包访问，则后缀为“/ package”。
        • 如果只允许public，module，package和private访问，则后缀为“/ private”。
        如果没有上述情况适用，则允许完全访问（public，module，package，private和protected）的情况。 在这种情况下，不添加后缀。 这只是原始从MethodHandles.lookup获得的对象。 Lookup.in创建的对象总是有限制访问，并显示一个后缀。

        （看起来很奇怪，受保护的访问应该比私有访问更强大，独立于包访问，受保护访问是首先丢失的，因为它需要调用者和被调用方之间的直接子类关系。

        重写：
        toString在 Object
        结果
        对象的字符串表示形式。
        另请参见：
        in(java.lang.Class<?>)

      • findStatic

        public MethodHandle findStatic​(Class<?> refc,
                               String name,
                               MethodType type)
                        throws NoSuchMethodException,
                               IllegalAccessException
        为静态方法生成方法句柄。 方法句柄的类型将是该方法的类型。 （由于静态方法不接收接收器，所以在方法句柄类型中没有插入附加的接收器参数，因为将使用findVirtual或findSpecial） 。查找对象的方法及其所有参数类型必须可访问。

        当且仅当方法的变量修饰符位（ 0x0080 ）被设置时，返回的方法句柄将具有variable arity 。

        如果调用返回的方法句柄，方法的类将被初始化，如果尚未被初始化。

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle MH_asList = publicLookup().findStatic(Arrays.class,
  "asList", methodType(List.class, Object[].class));
assertEquals("[x, y]", MH_asList.invoke("x", "y").toString());
        参数
        refc - 访问该方法的类
        name - 方法的名称
        type - 方法的类型
        结果
        所需的方法句柄
        异常
        NoSuchMethodException - 如果方法不存在
        IllegalAccessException - 如果访问检查失败，或者方法不是 static ，或者方法的变量arity修饰符位是否设置并且 asVarargsCollector失败
        SecurityException - 如果一个安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空

      • findVirtual

        public MethodHandle findVirtual​(Class<?> refc,
                                String name,
                                MethodType type)
                         throws NoSuchMethodException,
                                IllegalAccessException
        为虚拟方法生成方法句柄。 方法句柄的类型将是该方法的类型，接收器类型（通常为refc ）为前缀。 查询对象必须可访问该方法及其所有参数类型。

        当被调用时，句柄会将第一个参数视为接收者，并在接收者的类型上进行调度，以确定要输入的方法实现。 （调度动作与invokevirtual或invokeinterface指令执行的动作相同）

        如果查找类具有访问该成员的完整权限，则第一个参数将为refc 。 否则该成员必须是protected并且第一个参数将被限制在查找类的类型中。

        返回的方法句柄将会有variable arity，如果且仅当方法的变量arity修饰符位（ 0x0080 ）被设置。

        由于由findVirtual生成的invokevirtual指令和方法句柄之间的一般equivalence ，如果类为MethodHandle ，名称字符串为invokeExact或invoke ，则生成的方法句柄相当于由MethodHandles.exactInvoker或MethodHandles.invoker生成的相同的type参数。

        如果类是VarHandle ，并且名称字符串对应于签名多态访问模式方法的名称，则生成的方法句柄等效于由MethodHandles.varHandleInvoker(java.lang.invoke.VarHandle.AccessMode, java.lang.invoke.MethodType)生成的访问模式对应于名称字符串并具有相同的type参数的type 。

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle MH_concat = publicLookup().findVirtual(String.class,
  "concat", methodType(String.class, String.class));
MethodHandle MH_hashCode = publicLookup().findVirtual(Object.class,
  "hashCode", methodType(int.class));
MethodHandle MH_hashCode_String = publicLookup().findVirtual(String.class,
  "hashCode", methodType(int.class));
assertEquals("xy", (String) MH_concat.invokeExact("x", "y"));
assertEquals("xy".hashCode(), (int) MH_hashCode.invokeExact((Object)"xy"));
assertEquals("xy".hashCode(), (int) MH_hashCode_String.invokeExact("xy"));
// interface method:
MethodHandle MH_subSequence = publicLookup().findVirtual(CharSequence.class,
  "subSequence", methodType(CharSequence.class, int.class, int.class));
assertEquals("def", MH_subSequence.invoke("abcdefghi", 3, 6).toString());
// constructor "internal method" must be accessed differently:
MethodType MT_newString = methodType(void.class); //()V for new String()
try { assertEquals("impossible", lookup()
        .findVirtual(String.class, "<init>", MT_newString));
 } catch (NoSuchMethodException ex) { } // OK
MethodHandle MH_newString = publicLookup()
  .findConstructor(String.class, MT_newString);
assertEquals("", (String) MH_newString.invokeExact());
        参数
        refc - 访问该方法的类或接口
        name - 方法的名称
        type - 方法的类型，省略了接收方参数
        结果
        所需的方法句柄
        异常
        NoSuchMethodException - 如果方法不存在
        IllegalAccessException - 如果访问检查失败，或者方法是 static ，或者方法是 private接口方法，或者方法的变量arity修饰符位置位，并且 asVarargsCollector失败
        SecurityException - 如果安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空

      • findConstructor

        public MethodHandle findConstructor​(Class<?> refc,
                                    MethodType type)
                             throws NoSuchMethodException,
                                    IllegalAccessException
        使用指定类型的构造函数生成创建对象并初始化它的方法句柄。 方法句柄的参数类型将是构造函数的参数类型，而返回类型将是对构造函数类的引用。 查询对象必须可以访问构造函数及其所有参数类型。

        请求的类型必须具有void的返回类型。 （这与JVM处理构造函数类型描述符一致。）

        当且仅当构造函数的变量arity修饰符位（ 0x0080 ）被设置时，返回的方法句柄将具有variable arity 。

        如果调用返回的方法句柄，那么构造函数的类将被初始化，如果还没有被初始化。

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle MH_newArrayList = publicLookup().findConstructor(
  ArrayList.class, methodType(void.class, Collection.class));
Collection orig = Arrays.asList("x", "y");
Collection copy = (ArrayList) MH_newArrayList.invokeExact(orig);
assert(orig != copy);
assertEquals(orig, copy);
// a variable-arity constructor:
MethodHandle MH_newProcessBuilder = publicLookup().findConstructor(
  ProcessBuilder.class, methodType(void.class, String[].class));
ProcessBuilder pb = (ProcessBuilder)
  MH_newProcessBuilder.invoke("x", "y", "z");
assertEquals("[x, y, z]", pb.command().toString());
        参数
        refc - 访问该方法的类或接口
        type - 方法的类型，省略了接收者参数，并返回一个void返回类型
        结果
        所需的方法句柄
        异常
        NoSuchMethodException - 如果构造函数不存在
        IllegalAccessException - 如果访问检查失败，或者方法的变量arity修饰符位置位，并且 asVarargsCollector失败
        SecurityException - 如果安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空

      • findClass

        public Class<?> findClass​(String targetName)
                   throws ClassNotFoundException,
                          IllegalAccessException
        从这个Lookup对象定义的查找上下文中按名称查找一个类。 该类的静态初始化程序未运行。

        这里的查找上下文由lookup class ，其类加载器和lookup modes决定 。 特别地，该方法首先尝试加载所请求的类，然后确定该类是否可被该查找对象访问。

        参数
        targetName - 要查找的类的完全限定名称。
        结果
        所请求的类。
        异常
        SecurityException - 如果安全管理器存在，它是 refuses access
        LinkageError - 如果链接失败
        ClassNotFoundException - 如果类不能由查找类'loader加载。
        IllegalAccessException - 如果类不可访问，则使用允许的访问模式。
        SecurityException - 如果安全管理员存在，它是 refuses access
        从以下版本开始：
        9

      • accessClass

        public Class<?> accessClass​(Class<?> targetClass)
                     throws IllegalAccessException
        确定是否可以从此Lookup对象定义的查找上下文中访问类。 该类的静态初始化程序未运行。

        这里的查找上下文由lookup class和lookup modes确定。

        参数
        targetClass - 要进行访问检查的类
        结果
        已经访问检查的类
        异常
        IllegalAccessException - 如果类不能从查找类访问，则使用允许的访问模式。
        SecurityException - 如果一个安全管理器存在，它是 refuses access
        从以下版本开始：
        9

      • findSpecial

        public MethodHandle findSpecial​(Class<?> refc,
                                String name,
                                MethodType type,
                                Class<?> specialCaller)
                         throws NoSuchMethodException,
                                IllegalAccessException
        为虚拟方法生成早期绑定的方法句柄。 它会绕过检查重写在接收机，方法as if called从invokespecial从明确内指令指定specialCaller 。 方法句柄的类型将是该方法的类型，前面加上适当受限的接收器类型。 （接收器类型将为specialCaller或子类型。）查找对象必须可访问该方法及其所有参数类型。

        在方法解析之前，如果显式指定的调用者类与lookup类不相同，或者该查找对象没有private access权限，则访问失败。

        当且仅当方法的变量arity修饰符位（ 0x0080 ）被设置时，返回的方法句柄将具有variable arity 。

        （注：即使在特殊情况下， invokespecial指令可以引用它们，这个API也不可见JVM内部方法，名称为"<init>" ，使用findConstructor可以安全地访问实例初始化方法。）

        例：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
static class Listie extends ArrayList {
  public String toString() { return "[wee Listie]"; }
  static Lookup lookup() { return MethodHandles.lookup(); }
}
...
// no access to constructor via invokeSpecial:
MethodHandle MH_newListie = Listie.lookup()
  .findConstructor(Listie.class, methodType(void.class));
Listie l = (Listie) MH_newListie.invokeExact();
try { assertEquals("impossible", Listie.lookup().findSpecial(
        Listie.class, "<init>", methodType(void.class), Listie.class));
 } catch (NoSuchMethodException ex) { } // OK
// access to super and self methods via invokeSpecial:
MethodHandle MH_super = Listie.lookup().findSpecial(
  ArrayList.class, "toString" , methodType(String.class), Listie.class);
MethodHandle MH_this = Listie.lookup().findSpecial(
  Listie.class, "toString" , methodType(String.class), Listie.class);
MethodHandle MH_duper = Listie.lookup().findSpecial(
  Object.class, "toString" , methodType(String.class), Listie.class);
assertEquals("[]", (String) MH_super.invokeExact(l));
assertEquals(""+l, (String) MH_this.invokeExact(l));
assertEquals("[]", (String) MH_duper.invokeExact(l)); // ArrayList method
try { assertEquals("inaccessible", Listie.lookup().findSpecial(
        String.class, "toString", methodType(String.class), Listie.class));
 } catch (IllegalAccessException ex) { } // OK
Listie subl = new Listie() { public String toString() { return "[subclass]"; } };
assertEquals(""+l, (String) MH_this.invokeExact(subl)); // Listie method
        参数
        refc - 访问该方法的类或接口
        name - 方法的名称（不能为“<init>”）
        type - 方法的类型，省略了接收方参数
        specialCaller - 提出的调用类来执行 invokespecial
        结果
        所需的方法句柄
        异常
        NoSuchMethodException - 如果方法不存在
        IllegalAccessException - 如果访问检查失败，或者方法为 static ，或者方法的变量arity修饰符位是否设置并且 asVarargsCollector失败
        SecurityException - 如果安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空

      • findGetter

        public MethodHandle findGetter​(Class<?> refc,
                               String name,
                               Class<?> type)
                        throws NoSuchFieldException,
                               IllegalAccessException
        产生方法句柄，给非静态字段的读访问权限。 方法句柄的类型将具有字段值类型的返回类型。 方法句柄的单个参数将是包含该字段的实例。 代表查找类立即执行访问检查。
        参数
        refc - 访问该方法的类或接口
        name - 该字段的名称
        type - 字段的类型
        结果
        一个可以从字段加载值的方法句柄
        异常
        NoSuchFieldException - 如果该字段不存在
        IllegalAccessException - 如果访问检查失败，或者该字段是 static
        SecurityException - 如果安全管理器存在，它是 refuses access
        NullPointerException - 如果任何参数为空
        另请参见：
        findVarHandle(Class, String, Class)

      • findSetter

        public MethodHandle findSetter​(Class<?> refc,
                               String name,
                               Class<?> type)
                        throws NoSuchFieldException,
                               IllegalAccessException
        产生一个给非静态字段写入访问权限的方法句柄。 方法句柄的类型将具有void返回类型。 方法句柄将使用两个参数，包含该字段的实例和要存储的值。 第二个参数将是字段的值类型。 代表查找类立即执行访问检查。
        参数
        refc - 访问该方法的类或接口
        name - 该字段的名称
        type - 字段的类型
        结果
        一个可以将值存储到字段中的方法句柄
        异常
        NoSuchFieldException - 如果该字段不存在
        IllegalAccessException - 如果访问检查失败，或者该字段是 static
        SecurityException - 如果一个安全管理器存在，它是 refuses access
        NullPointerException - 如果任何参数为空
        另请参见：
        findVarHandle(Class, String, Class)

      • findVarHandle

        public VarHandle findVarHandle​(Class<?> recv,
                               String name,
                               Class<?> type)
                        throws NoSuchFieldException,
                               IllegalAccessException
        产生一个VarHandle，可访问name类中声明的类型为type的非静态字段recv 。 VarHandle的变量类型是type ，它有一个坐标类型， recv 。

        代表查找类立即执行访问检查。

        在以下情况下，不支持返回的VarHandle的某些访问模式：

        • 如果该字段声明为final ，则不支持写入，原子更新，数字原子更新和逐位原子更新访问模式。
        • 如果字段的类型是比其他任何byte ， short ， char ， int ， long ， float ，或double然后数字原子更新的接入方式是不受支持的。
        • 如果字段的类型是以外的任何其他boolean ， byte ， short ， char ， int或long然后逐位原子更新的接入方式是不受支持的。

        如果该字段声明为volatile则返回的VarHandle将根据其指定的访问模式覆盖对该字段的访问（有效地忽略volatile声明）。

        如果字段类型为float或double则数字和原子更新访问模式使用其逐位表示比较值（分别为Float.floatToRawIntBits(float)和Double.doubleToRawLongBits(double) ）。

        API Note:
        由数字和原子更新访问模式执行的float值或double值的float比较不同于原语==运算符和Float.equals(java.lang.Object)和Double.equals(java.lang.Object)方法，特别是关于比较NaN值或比较-0.0与+0.0 。 当执行比较和设置或与这些值的比较和交换操作时，应注意，因为操作可能会意外失败。 在Java中，许多可能的NaN值被认为是NaN ，尽管Java提供的IEEE 754浮点运算没有区别它们。 如果预期值或见证值为NaN值，并且将其转换（可能以平台特定的方式）为另一个NaN值，因此具有不同的按位表示（参见Float.intBitsToFloat(int)或Double.longBitsToDouble(long)了解更多详细信息），则可能会发生操作失败。 值-0.0和+0.0具有不同的位表示，但在使用基元==运算符时被认为是相等的。 如果，例如，数字算法计算的预期值是说可能会出现操作故障-0.0和先前计算的见证价值被说+0.0 。
        参数
        recv - 类型为 R的接收器类，声明非静态字段
        name - 该字段的名称
        type - 字段的类型，类型为 T
        结果
        一个VarHandle可以访问非静态字段。
        异常
        NoSuchFieldException - 如果该字段不存在
        IllegalAccessException - 如果访问检查失败，或者该字段是 static
        SecurityException - 如果一个安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空
        从以下版本开始：
        9

      • findStaticGetter

        public MethodHandle findStaticGetter​(Class<?> refc,
                                     String name,
                                     Class<?> type)
                              throws NoSuchFieldException,
                                     IllegalAccessException
        产生一个给静态字段读取访问权限的方法句柄。 方法句柄的类型将具有字段值类型的返回类型。 方法句柄将不会引用任何参数。 代表查找类立即执行访问检查。

        如果调用了返回的方法句柄，则该字段的类将被初始化，如果尚未初始化。

        参数
        refc - 访问该方法的类或接口
        name - 该字段的名称
        type - 字段的类型
        结果
        一个可以从字段加载值的方法句柄
        异常
        NoSuchFieldException - 如果该字段不存在
        IllegalAccessException - 如果访问检查失败，或者该字段不是 static
        SecurityException - 如果一个安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空

      • findStaticSetter

        public MethodHandle findStaticSetter​(Class<?> refc,
                                     String name,
                                     Class<?> type)
                              throws NoSuchFieldException,
                                     IllegalAccessException
        生成方法句柄，给静态字段写权限。 方法句柄的类型将具有void返回类型。 方法句柄将使用单个参数，字段的值类型，要存储的值。 代表查找类立即执行访问检查。

        如果调用了返回的方法句柄，则该字段的类将被初始化，如果尚未初始化。

        参数
        refc - 访问该方法的类或接口
        name - 该字段的名称
        type - 字段的类型
        结果
        一个可以将值存储到字段中的方法句柄
        异常
        NoSuchFieldException - 如果该字段不存在
        IllegalAccessException - 如果访问检查失败，或者该字段不是 static
        SecurityException - 如果一个安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空

      • findStaticVarHandle

        public VarHandle findStaticVarHandle​(Class<?> decl,
                                     String name,
                                     Class<?> type)
                              throws NoSuchFieldException,
                                     IllegalAccessException
        产生一个VarHandle，可以访问name类中声明的类型为type的静态字段decl 。 VarHandle的变量类型是type ，它没有坐标类型。

        代表查找类立即执行访问检查。

        如果返回的VarHandle操作，则声明类将被初始化，如果尚未初始化。

        在以下情况下，不支持返回的VarHandle的某些访问模式：

        • 如果该字段声明为final ，则不支持写入，原子更新，数字原子更新和按位原子更新访问模式。
        • 如果字段的类型是比其他任何byte ， short ， char ， int ， long ， float ，或double ，然后数字原子更新的接入方式是不受支持的。
        • 如果字段的类型是以外的任何其他boolean ， byte ， short ， char ， int或long然后逐位原子更新的接入方式是不受支持的。

        如果该字段声明为volatile则返回的VarHandle将根据其指定的访问模式覆盖该字段的访问（有效地忽略volatile声明）。

        如果字段类型为float或double则数字和原子更新访问模式使用其逐位表示比较值（分别见Float.floatToRawIntBits(float)和Double.doubleToRawLongBits(double) ）。

        API Note:
        按照数字和原子更新访问模式执行的float值或double值的比较比较，不同于原语==运算符和Float.equals(java.lang.Object)和Double.equals(java.lang.Object)方法，特别是关于比较NaN值或比较-0.0与+0.0 。 当执行比较和设置或与这些值的比较和交换操作时，应注意，因为操作可能会意外失败。 在Java中，许多可能的NaN值被认为是NaN ，尽管Java提供的IEEE 754浮点运算没有区别它们。 如果预期值或见证值为NaN值，并且将其转换（可能以平台特定方式）转换为另一个NaN值，并因此具有不同的逐位表示（参见Float.intBitsToFloat(int)或Double.longBitsToDouble(long)了解更多详细信息），则可能会发生操作失败。 值-0.0和+0.0具有不同的位表示，但在使用基元==运算符时被认为是相等的。 如果，例如，数字算法计算的预期值是说可能会出现操作故障-0.0和先前计算的见证价值被说+0.0 。
        参数
        decl - 声明静态字段的类
        name - 该字段的名称
        type - 字段的类型，类型为 T
        结果
        一个VarHandle可以访问静态字段
        异常
        NoSuchFieldException - 如果该字段不存在
        IllegalAccessException - 如果访问检查失败，或者该字段不是 static
        SecurityException - 如果一个安全管理员存在，它是 refuses access
        NullPointerException - 如果任何参数为空
        从以下版本开始：
        9

      • bind

        public MethodHandle bind​(Object receiver,
                         String name,
                         MethodType type)
                  throws NoSuchMethodException,
                         IllegalAccessException
        为非静态方法生成早期绑定的方法句柄。 接收者必须有一个超类型defc ，其中给定名称和类型的方法可以被查找类访问。 查询对象必须可访问该方法及其所有参数类型。 方法句柄的类型将是该方法的类型，而不插入附加的接收器参数。 给定的接收器将被绑定到方法句柄中，以便每次调用方法句柄将在给定的接收器上调用请求的方法。

        如果且仅当方法的变量arity修饰符位（ 0x0080 ）被设置且尾数组参数不是唯一的参数时，返回的方法句柄将具有variable arity 。 （如果尾数组参数是唯一的参数，给定的接收器值将被绑定到它。）

        这几乎等同于以下代码，下面有一些区别：

import static java.lang.invoke.MethodHandles.*;
import static java.lang.invoke.MethodType.*;
...
MethodHandle mh0 = lookup().findVirtual(defc, name, type);
MethodHandle mh1 = mh0.bindTo(receiver);
mh1 = mh1.withVarargs(mh0.isVarargsCollector());
return mh1;
        其中defc是receiver.getClass()或receiver.getClass()的超类型，其中所请求的方法可以被查找类访问。 （不像bind ， bindTo不保留变量元数。另外， bindTo可能抛出ClassCastException中的实例，其中bind将引发IllegalAccessException ，如在其中所述构件是所述壳体protected和接收器通过限制findVirtual到查找类）。
        参数
        receiver - 访问该方法的对象
        name - 方法的名称
        type - 方法的类型，省略了接收方参数
        结果
        所需的方法句柄
        异常
        NoSuchMethodException - 如果方法不存在
        IllegalAccessException - 如果访问检查失败，或者方法的变量 asVarargsCollector修饰符位置位，并且 asVarargsCollector失败
        SecurityException - 如果安全管理器存在，它是 refuses access
        NullPointerException - 如果任何参数为空
        另请参见：
        MethodHandle.bindTo(java.lang.Object) ， findVirtual(java.lang.Class<?>, java.lang.String, java.lang.invoke.MethodType)

      • unreflect

        public MethodHandle unreflect​(方法 m)
                       throws IllegalAccessException
        做一个direct method handle的m ，如果查找类有权限。 如果m是非静态的，则接收者参数被视为初始参数。 如果m是虚拟的，则在每次呼叫时都应该重写。 与Core Reflection API不同，异常不包装。 方法句柄的类型将是方法的类型，接收器类型为前缀（但仅当它是非静态的）时。 如果方法的accessible标志未设置，则代表查找类立即执行访问检查。 如果m不是公开的，不要与不信任方共享所产生的句柄。

        当且仅当方法的变量arity修饰符位（ 0x0080 ）被设置时，返回的方法句柄将具有variable arity 。

        如果m是静态的，并且如果返回的方法句柄被调用，那么方法的类将被初始化，如果它还没有被初始化。

        参数
        m - 反映的方法
        结果
        可以调用反射方法的方法句柄
        异常
        IllegalAccessException - 如果访问检查失败，或者如果方法的变量arity修饰符位被设置并且 asVarargsCollector失败
        NullPointerException - 如果参数为空

      • unreflectSpecial

        public MethodHandle unreflectSpecial​(方法 m,
                                     Class<?> specialCaller)
                              throws IllegalAccessException
        为反映的方法生成方法句柄。 它会绕过检查重写在接收机，方法as if called从invokespecial从明确内指令指定specialCaller 。 方法句柄的类型将是该方法的类型，前面加上适当受限的接收器类型。 （接收器类型为specialCaller或子类型。）如果未设置方法的accessible标志，则代表查找类立即执行访问检查，就像invokespecial指令被链接一样。

        在方法解析之前，如果显式指定的调用者类与lookup类不相同，或者该查找对象没有private access权限，则访问失败。

        如果且仅当方法的变量arity修饰符位（ 0x0080 ）被设置时，返回的方法句柄将具有variable arity 。

        参数
        m - 反映的方法
        specialCaller - 这个类 specialCaller叫做方法
        结果
        可以调用反射方法的方法句柄
        异常
        IllegalAccessException - 如果访问检查失败，或者方法为 static ，或者方法的变量arity修饰符位是否设置并且 asVarargsCollector发生故障
        NullPointerException - 如果任何参数为空

      • unreflectConstructor

        public MethodHandle unreflectConstructor​(Constructor<?> c)
                                  throws IllegalAccessException
        为反射的构造函数生成方法句柄。 方法句柄的类型将是构造函数的类型，返回类型更改为声明类。 方法句柄将执行一个newInstance操作，在传递给方法句柄的参数上创建构造函数类的新实例。

        如果未设置构造函数的accessible标志，则代表查找类立即执行访问检查。

        当且仅当构造函数的变量arity修饰符位（ 0x0080 ）被设置时，返回的方法句柄将具有variable arity 。

        如果调用返回的方法句柄，那么构造函数的类将被初始化，如果还没有被初始化。

        参数
        c - 反映的构造函数
        结果
        可以调用反射的构造函数的方法句柄
        异常
        IllegalAccessException - 如果访问检查失败或方法的变量修改位置1，并且 asVarargsCollector失败
        NullPointerException - 如果参数为空

      • unreflectGetter

        public MethodHandle unreflectGetter​(Field f)
                             throws IllegalAccessException
        产生方法句柄，给予反映字段的读访问权限。 方法句柄的类型将具有字段值类型的返回类型。 如果该字段是静态的，方法句柄将不会引用任何参数。 否则，其单个参数将是包含该字段的实例。 如果字段的accessible标志未设置，则代表查找类立即执行访问检查。

        如果该字段是静态的，并且如果返回的方法句柄被调用，则该字段的类将被初始化，如果它还没有被初始化。

        参数
        f - 反射场
        结果
        一个方法句柄，可以从反射的字段加载值
        异常
        IllegalAccessException - 如果访问检查失败
        NullPointerException - 如果参数为空

      • unreflectSetter

        public MethodHandle unreflectSetter​(Field f)
                             throws IllegalAccessException
        产生一个方法句柄，给一个反射的字段写权限。 方法句柄的类型将具有void返回类型。 如果该字段是静态的，那么方法句柄将使用一个参数，即字段的值类型，要存储的值。 否则，两个参数将是包含该字段的实例和要存储的值。 如果字段的accessible标志未设置，则代表查找类立即执行访问检查。

        如果该字段是静态的，并且如果返回的方法句柄被调用，则该字段的类将被初始化，如果它还没有被初始化。

        参数
        f - 反映的领域
        结果
        一种可以将值存储到反射场中的方法句柄
        异常
        IllegalAccessException - 如果访问检查失败
        NullPointerException - 如果参数为null

      • unreflectVarHandle

        public VarHandle unreflectVarHandle​(Field f)
                             throws IllegalAccessException
        产生一个VarHandle，可以访问f类中声明的类型为T的反射字段R 。 VarHandle的变量类型是T 。 如果该字段是非静态的，则VarHandle有一个坐标类型， R 。 否则，该字段是静态的，并且VarHandle没有坐标类型。

        代表查找类立即执行访问检查，而不管字段的accessible标志的值。

        如果该字段是静态的，并且如果返回的VarHandle被操作，则该字段的声明类将被初始化，如果它还没有被初始化。

        在以下情况下，不支持返回的VarHandle的某些访问模式：

        • 如果该字段声明为final ，则不支持写入，原子更新，数字原子更新和逐位原子更新访问模式。
        • 如果字段的类型是比其他任何byte ， short ， char ， int ， long ， float ，或double然后数字原子更新的接入方式是不受支持的。
        • 如果字段的类型是以外的任何其他boolean ， byte ， short ， char ， int或long然后逐位原子更新的接入方式是不受支持的。

        如果该字段声明为volatile则返回的VarHandle将根据其指定的访问模式覆盖该字段的访问（有效地忽略volatile声明）。

        如果字段类型为float或double则数字和原子更新访问模式使用其逐位表示比较值（分别见Float.floatToRawIntBits(float)和Double.doubleToRawLongBits(double) ）。

        API Note:
        由数字和原子更新访问模式执行的float值或double值的按位比较与原语==运算符和Float.equals(java.lang.Object)和Double.equals(java.lang.Object)方法的不同之处 在于 ，特别是关于比较NaN值或比较-0.0与+0.0 。 当执行比较和设置或与这些值的比较和交换操作时，应注意，因为操作可能会意外失败。 在Java中，有许多可能的NaN值被认为是NaN ，尽管Java提供的IEEE 754浮点运算没有区分它们。 如果预期值或见证值是NaN值，并且它被转换（可能以平台特定的方式）到另一个NaN值，并且因此具有不同的位方式表示（参见Float.intBitsToFloat(int)或Double.longBitsToDouble(long)了解更多细节），则可能会发生操作失败。 值-0.0和+0.0具有不同的逐位表示，但在使用基元==运算符时被认为是相等的。 如果，例如，数字算法计算的预期值是说可能会出现操作故障-0.0和先前计算的见证价值被说+0.0 。
        参数
        f - 反射字段，字段类型为 T ，声明类型为 R
        结果
        一个VarHandle可以访问非静态字段或静态字段
        异常
        IllegalAccessException - 如果访问检查失败
        NullPointerException - 如果参数为空
        从以下版本开始：
        9

      • revealDirect

        public MethodHandleInfo revealDirect​(MethodHandle target)
        破解由此查找对象或类似的对象创建的一个direct method handle 。 执行安全和访问检查以确保该查找对象能够再现目标方法句柄。 这意味着如果目标是一个直接的方法句柄但是由一个不相关的查找对象创建，则破解可能会失败。 如果方法句柄是caller sensitive，并且由不同类的查找对象创建，则可能会发生这种情况。
        参数
        target - 一种直接的方法手柄来破解符号参考组件
        结果
        一个符号引用，可用于从此查找对象重建此方法句柄
        异常
        SecurityException - 如果一个安全管理器存在，它是 refuses access
        IllegalArgumentException - 如果目标不是直接方法句柄或访问检查失败
        NullPointerException - 如果目标是 null
        从以下版本开始：
        1.8
        另请参见：
        MethodHandleInfo

      • hasPrivateAccess

        public boolean hasPrivateAccess​()
        如果此查找具有 PRIVATE访问权限，则返回 true 。
        结果
        true如果这个查找有 PRIVATE访问。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MethodType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class MethodType

  • java.lang.Object
    • java.lang.invoke.MethodType
  • All Implemented Interfaces:
    Serializable

    public final class MethodType
extends Object
implements Serializable
    方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。 方法类型必须在方法句柄和其所有调用者之间进行正确匹配，并且JVM的操作在执行MethodHandle.invokeExact和MethodHandle.invoke以及在执行invokedynamic指令期间执行此匹配。

    该结构是一个返回类型，伴随着任意数量的参数类型。 类型（原始， void和参考）由Class对象表示。 （为了便于说明，我们把void看成是一个类型，实际上它表示没有返回类型。）

    MethodType所有实例都是不可变的。 如果比较相等，则两个实例可以完全互换。 平等取决于返回值和参数类型的成对对应关系，而不取决于任何其他值。

    此类型只能通过工厂方法创建。 所有工厂方法都可以缓存值，尽管不能保证缓存。 一些工厂方法是静态的，而其他工厂方法是修改前体方法类型的虚拟方法，例如通过更改选定的参数。

    以两个版本的方式系统地显示了对参数类型组进行操作的工厂方法，从而可以使用Java数组和Java列表来处理参数类型组。 查询方法parameterArray和parameterList还提供了数组和列表之间的选择。

    MethodType对象有时从诸如invokedynamic字节码指令invokedynamic ，特别是从与类文件的常量池中的指令相关联的类型描述符字符串。

    像类和字符串一样，方法类型也可以直接在类文件的常量池中表示为常量。 方法类型可以由指向适当的CONSTANT_MethodType常量池条目的ldc指令加载。 该条目是指描述符字符串的CONSTANT_Utf8拼写。 （有关方法类型常量的详细信息，请参阅Java虚拟机规范的第4.4.8和5.4.3.5节。）

    当JVM从描述符字符串中实现MethodType ，描述符中命名的所有类都必须可访问，并将被加载。 （但是类不需要初始化，与CONSTANT_Class的情况CONSTANT_Class 。此加载可能会在MethodType对象首次导出之前的任何时间发生。

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MethodType appendParameterTypes​(Class<?>... ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      MethodType appendParameterTypes​(List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      MethodType changeParameterType​(int num, Class<?> nptype)
      查找或创建具有单个不同参数类型的方法类型。
      MethodType changeReturnType​(Class<?> nrtype)
      查找或创建具有不同返回类型的方法类型。
      MethodType dropParameterTypes​(int start, int end)
      查找或创建一种省略某些参数类型的方法类型。
      boolean equals​(Object x)
      将指定的对象与此类型进行比较以获得相等性。
      MethodType erase​()
      删除所有引用类型到 Object 。
      static MethodType fromMethodDescriptorString​(String descriptor, ClassLoader loader)
      查找或创建方法类型的实例，给定其字节码描述符的拼写。
      MethodType generic​()
      将所有类型（引用和原始）转换为 Object 。
      static MethodType genericMethodType​(int objectArgCount)
      查找或创建组件全部为 Object的方法类型。
      static MethodType genericMethodType​(int objectArgCount, boolean finalArray)
      查找或创建一个方法类型，其组件为 Object ，带有可选的尾部 Object[]阵列。
      int hashCode​()
      返回此方法类型的哈希码值。
      boolean hasPrimitives​()
      报告此类型是否包含原始参数或返回值。
      boolean hasWrappers​()
      报告此类型是否包含包装器参数或返回值。
      MethodType insertParameterTypes​(int num, Class<?>... ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      MethodType insertParameterTypes​(int num, List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      static MethodType methodType​(Class<?> rtype)
      查找或创建具有给定组件的方法类型。
      static MethodType methodType​(Class<?> rtype, Class<?> ptype0)
      查找或创建具有给定组件的方法类型。
      static MethodType methodType​(Class<?> rtype, Class<?>[] ptypes)
      查找或创建给定方法类型的实例。
      static MethodType methodType​(Class<?> rtype, Class<?> ptype0, Class<?>... ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodType methodType​(Class<?> rtype, MethodType ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodType methodType​(Class<?> rtype, List<Class<?>> ptypes)
      查找或创建具有给定组件的方法类型。
      Class<?>[] parameterArray​()
      将参数类型显示为数组（方便方法）。
      int parameterCount​()
      返回此方法类型中的参数类型数。
      List<Class<?>> parameterList​()
      将参数类型显示为列表（方便方法）。
      Class<?> parameterType​(int num)
      在此方法类型中返回指定索引处的参数类型。
      Class<?> returnType​()
      返回此方法类型的返回类型。
      String toMethodDescriptorString​()
      生成方法类型的字节码描述符表示。
      String toString​()
      返回方法类型的字符串表示形式，格式为 "(PT0,PT1...)RT" 。
      MethodType unwrap​()
      将所有包装类型转换为相应的原始类型。
      MethodType wrap​()
      将所有原始类型转换为相应的包装类型。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • methodType

        public static MethodType methodType​(Class<?> rtype,
                                    Class<?>[] ptypes)
        查找或创建给定方法类型的实例。
        参数
        rtype - 返回类型
        ptypes - 参数类型
        结果
        具有给定组件的方法类型
        异常
        NullPointerException -如果 rtype或 ptypes或任何元件 ptypes为空
        IllegalArgumentException -如果任何元件 ptypes是 void.class

      • methodType

        public static MethodType methodType​(Class<?> rtype,
                                    List<Class<?>> ptypes)
        查找或创建具有给定组件的方法类型。 方便methodType 。
        参数
        rtype - 返回类型
        ptypes - 参数类型
        结果
        具有给定组件的方法类型
        异常
        NullPointerException -如果 rtype或 ptypes或任何元件 ptypes为空
        IllegalArgumentException -如果任何元件 ptypes是 void.class

      • methodType

        public static MethodType methodType​(Class<?> rtype,
                                    Class<?> ptype0,
                                    Class<?>... ptypes)
        查找或创建具有给定组件的方法类型。 方便methodType的方法。 前导参数类型被添加到剩余的数组中。
        参数
        rtype - 返回类型
        ptype0 - 第一个参数类型
        ptypes - 剩余的参数类型
        结果
        具有给定组件的方法类型
        异常
        NullPointerException -如果 rtype或 ptype0或 ptypes或任何元件 ptypes为空
        IllegalArgumentException -如果 ptype0或 ptypes或任何元件 ptypes是 void.class

      • methodType

        public static MethodType methodType​(Class<?> rtype)
        查找或创建具有给定组件的方法类型。 方便methodType 。 所得到的方法没有参数类型。
        参数
        rtype - 返回类型
        结果
        具有给定返回值的方法类型
        异常
        NullPointerException - 如果 rtype为空

      • methodType

        public static MethodType methodType​(Class<?> rtype,
                                    Class<?> ptype0)
        查找或创建具有给定组件的方法类型。 方便methodType 。 所得到的方法具有单个给定的参数类型。
        参数
        rtype - 返回类型
        ptype0 - 参数类型
        结果
        具有给定返回值和参数类型的方法类型
        异常
        NullPointerException - 如果 rtype或 ptype0为空
        IllegalArgumentException - 如果 ptype0是 void.class

      • methodType

        public static MethodType methodType​(Class<?> rtype,
                                    MethodType ptypes)
        查找或创建具有给定组件的方法类型。 方便methodType 。 生成的方法具有与ptypes相同的参数类型和指定的返回类型。
        参数
        rtype - 返回类型
        ptypes - 提供参数类型的方法类型
        结果
        具有给定组件的方法类型
        异常
        NullPointerException - 如果 rtype或 ptypes为空

      • genericMethodType

        public static MethodType genericMethodType​(int objectArgCount,
                                           boolean finalArray)
        查找或创建一个方法类型，其组件为Object并具有可选的尾部Object[]数组。 方便方法methodType 。 所有参数和返回类型将为Object ，除了最后的数组参数，否则为Object[] 。
        参数
        objectArgCount - 参数数（不包括最终数组参数（如果有））
        finalArray - 是否会有一个尾随数组参数，类型为 Object[]
        结果
        一个普遍适用的方法类型，用于给定固定参数计数的所有调用以及收集的其他参数数组
        异常
        IllegalArgumentException - 如果 objectArgCount为负数或大于255（或254，如果为 finalArray为真）
        另请参见：
        genericMethodType(int)

      • genericMethodType

        public static MethodType genericMethodType​(int objectArgCount)
        查找或创建组件全部为Object的方法类型。 方便methodType 。 所有参数和返回类型将为Object。
        参数
        objectArgCount - 参数数量
        结果
        一个普遍适用的方法类型，用于给定参数计数的所有调用
        异常
        IllegalArgumentException - 如果 objectArgCount为负数或大于255
        另请参见：
        genericMethodType(int, boolean)

      • changeParameterType

        public MethodType changeParameterType​(int num,
                                      Class<?> nptype)
        查找或创建具有单个不同参数类型的方法类型。 方便methodType 。
        参数
        num - 要更改的参数类型的索引（从零开始）
        nptype - 用于替换旧参数的新参数类型
        结果
        相同类型，除了所选参数更改
        异常
        IndexOutOfBoundsException - 如果 num不是有效的索引到 parameterArray()
        IllegalArgumentException - 如果 nptype是 void.class
        NullPointerException - 如果 nptype为空

      • insertParameterTypes

        public MethodType insertParameterTypes​(int num,
                                       Class<?>... ptypesToInsert)
        查找或创建具有其他参数类型的方法类型。 方便methodType 。
        参数
        num - 插入的参数类型的位置（从零开始）
        ptypesToInsert - 要插入参数列表的零个或多个新参数类型
        结果
        相同的类型，除了插入所选的参数
        异常
        IndexOutOfBoundsException - 如果 num为负数或大于 parameterCount()
        IllegalArgumentException -如果任何元件 ptypesToInsert是 void.class ，或者如果所产生的方法类型将具有255个以上的参数时隙
        NullPointerException - 如果 ptypesToInsert或其任何元素为空

      • appendParameterTypes

        public MethodType appendParameterTypes​(Class<?>... ptypesToInsert)
        查找或创建具有其他参数类型的方法类型。 方便methodType 。
        参数
        ptypesToInsert - 在参数列表结束后插入的零个或多个新参数类型
        结果
        相同的类型，除了附加了所选参数
        异常
        IllegalArgumentException -如果任何元件 ptypesToInsert是 void.class ，或者如果所产生的方法类型将具有255个以上的参数时隙
        NullPointerException - 如果 ptypesToInsert或其任何元素为空

      • insertParameterTypes

        public MethodType insertParameterTypes​(int num,
                                       List<Class<?>> ptypesToInsert)
        查找或创建具有其他参数类型的方法类型。 方便methodType 。
        参数
        num - 插入的参数类型的位置（从零开始）
        ptypesToInsert - 要插入参数列表的零个或多个新参数类型
        结果
        相同的类型，除了插入所选的参数
        异常
        IndexOutOfBoundsException - 如果 num为负数或大于 parameterCount()
        IllegalArgumentException -如果任何元件 ptypesToInsert是 void.class ，或者如果所产生的方法类型将具有255个以上的参数时隙
        NullPointerException - 如果 ptypesToInsert或其任何元素为空

      • appendParameterTypes

        public MethodType appendParameterTypes​(List<Class<?>> ptypesToInsert)
        查找或创建具有其他参数类型的方法类型。 方便methodType 。
        参数
        ptypesToInsert - 在参数列表结束后插入的零个或多个新参数类型
        结果
        相同的类型，除了附加了所选参数
        异常
        IllegalArgumentException -如果任何元件 ptypesToInsert是 void.class ，或者如果所产生的方法类型将具有255个以上的参数时隙
        NullPointerException - 如果 ptypesToInsert或其任何元素为空

      • dropParameterTypes

        public MethodType dropParameterTypes​(int start,
                                     int end)
        查找或创建一种省略某些参数类型的方法类型。 methodType的方便方法。
        参数
        start - 要删除的第一个参数类型的索引（从零开始）
        end - 第一个参数类型的索引（大于 start ）不要删除
        结果
        相同的类型，除去所选参数被删除
        异常
        IndexOutOfBoundsException - 如果 start为负数或大于 parameterCount()或如果 end为负数或大于 parameterCount()或如果 start大于 end

      • changeReturnType

        public MethodType changeReturnType​(Class<?> nrtype)
        查找或创建具有不同返回类型的方法类型。 methodType的方便方法。
        参数
        nrtype - 一个返回参数类型替换旧的
        结果
        相同类型，除了返回类型更改
        异常
        NullPointerException - 如果 nrtype为空

      • hasPrimitives

        public boolean hasPrimitives​()
        报告此类型是否包含原始参数或返回值。 返回类型void计数为原始数。
        结果
        如果任何类型是原语，则为真

      • hasWrappers

        public boolean hasWrappers​()
        报告此类型是否包含包装器参数或返回值。 包装器是包含原始值的类型，例如Integer 。 引用类型java.lang.Void计算为包装器，如果它作为返回类型出现。
        结果
        如果任何类型是包装器，则为true

      • erase

        public MethodType erase​()
        删除所有引用类型到Object 。 方便methodType 。 所有原始类型（包括void ）将保持不变。
        结果
        所有引用类型被替换的原始类型的版本

      • generic

        public MethodType generic​()
        将所有类型（引用和原始）转换为Object 。 方便genericMethodType 。 表达type.wrap().erase()产生相同的值type.generic() 。
        结果
        所有类型的原始类型的版本被替换

      • wrap

        public MethodType wrap​()
        将所有原始类型转换为相应的包装类型。 方便methodType 。 所有引用类型（包括包装类型）将保持不变。 A void返回类型更改为java.lang.Void 。 表达type.wrap().erase()产生相同的值type.generic() 。
        结果
        所有原始类型的原始类型的版本被替换

      • unwrap

        public MethodType unwrap​()
        将所有包装类型转换为相应的原始类型。 方便methodType 。 所有原始类型（包括void ）将保持不变。 java.lang.Void的返回类型更改为void 。
        结果
        一个版本的原始类型，所有的包装类型被替换

      • parameterType

        public Class<?> parameterType​(int num)
        在此方法类型中返回指定索引处的参数类型。
        参数
        num - 所需参数类型的索引（从零开始）
        结果
        所选参数类型
        异常
        IndexOutOfBoundsException - 如果 num不是有效的索引到 parameterArray()

      • parameterCount

        public int parameterCount​()
        返回此方法类型中的参数类型数。
        结果
        参数类型的数量

      • returnType

        public Class<?> returnType​()
        返回此方法类型的返回类型。
        结果
        返回类型

      • parameterList

        public List<Class<?>> parameterList​()
        将参数类型显示为列表（方便方法）。 该列表将是不可变的。
        结果
        参数类型（作为不可变列表）

      • parameterArray

        public Class<?>[] parameterArray​()
        将参数类型显示为数组（方便方法）。 对数组的更改不会导致类型的更改。
        结果
        参数类型（如有必要，作为新的副本）

      • equals

        public boolean equals​(Object x)
        将指定的对象与此类型进行比较以获得相等性。 也就是说，当且仅当指定的对象也是具有完全相同的参数和返回类型的方法类型时，它返回true 。
        重写：
        equals在 Object
        参数
        x - 对象进行比较
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.equals(Object)

      • hashCode

        public int hashCode​()
        返回此方法类型的哈希码值。 它被定义为与列表的哈希码相同，其元素是返回类型，后跟参数类型。
        重写：
        hashCode在 Object
        结果
        该方法类型的哈希码值
        另请参见：
        Object.hashCode() ， equals(Object) ， List.hashCode()

      • toString

        public String toString​()
        返回方法类型的字符串表示形式，格式为"(PT0,PT1...)RT" 。 方法类型的字符串表示形式是括号，以逗号分隔的类型名称列表，紧接着是返回类型。

        每种类型由其simple name表示。

        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • fromMethodDescriptorString

        public static MethodType fromMethodDescriptorString​(String descriptor,
                                                    ClassLoader loader)
                                             throws IllegalArgumentException,
                                                    TypeNotPresentException
        查找或创建方法类型的实例，给定其字节码描述符的拼写。 方便methodType 。 嵌入在描述符字符串中的任何类或接口名称将通过在给定的加载程序上调用ClassLoader.loadClass(java.lang.String)来解决（或者如果在系统类加载器上为null）。

        请注意，可能遇到无法通过此方法构造的方法类型，因为它们的组件类型并不都可以从普通类加载器访问。

        包括这种方法是为了生成必须生成处理方法句柄的字节码和invokedynamic的应用程序。

        参数
        descriptor - 字节码类型描述符字符串“（T ...）T”
        loader - 查找类型的类加载器
        结果
        一种匹配字节码类型描述符的方法类型
        异常
        NullPointerException - 如果字符串为空
        IllegalArgumentException - 如果字符串格式不正确
        TypeNotPresentException - 如果找不到命名类型

      • toMethodDescriptorString

        public String toMethodDescriptorString​()
        生成方法类型的字节码描述符表示。

        请注意，这不是fromMethodDescriptorString的严格倒数。 在描述符字符串中查看时，共享一个通用名称但具有不同类加载器的两个不同的类将显示相同。

        包括这种方法是为了生成必须生成处理方法句柄和invokedynamic字节码的应用程序。 fromMethodDescriptorString ，因为后者需要一个合适的类加载器参数。

        结果
        字节码类型描述符表示
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MutableCallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class MutableCallSite

  • java.lang.Object
    • java.lang.invoke.CallSite
      • java.lang.invoke.MutableCallSite
  • 已知直接子类：
    AbstractRelinkableCallSite

    public class MutableCallSite
extends CallSite
    A MutableCallSite是一个CallSite，其目标变量的行为像一个普通字段。 链接到MutableCallSite的invokedynamic指令将对站点的当前目标的所有调用委托。 可变电话网站的dynamic invoker还会将每个呼叫委托给该网站的当前目标。

    以下是将状态变量引入到方法句柄链中的可变调用站点的示例。

MutableCallSite name = new MutableCallSite(MethodType.methodType(String.class));
MethodHandle MH_name = name.dynamicInvoker();
MethodType MT_str1 = MethodType.methodType(String.class);
MethodHandle MH_upcase = MethodHandles.lookup()
    .findVirtual(String.class, "toUpperCase", MT_str1);
MethodHandle worker1 = MethodHandles.filterReturnValue(MH_name, MH_upcase);
name.setTarget(MethodHandles.constant(String.class, "Rocky"));
assertEquals("ROCKY", (String) worker1.invokeExact());
name.setTarget(MethodHandles.constant(String.class, "Fred"));
assertEquals("FRED", (String) worker1.invokeExact());
// (mutation can be continued indefinitely)

    同一个呼叫站点可以同时在几个地方使用。

MethodType MT_str2 = MethodType.methodType(String.class, String.class);
MethodHandle MH_cat = lookup().findVirtual(String.class,
  "concat", methodType(String.class, String.class));
MethodHandle MH_dear = MethodHandles.insertArguments(MH_cat, 1, ", dear?");
MethodHandle worker2 = MethodHandles.filterReturnValue(MH_name, MH_dear);
assertEquals("Fred, dear?", (String) worker2.invokeExact());
name.setTarget(MethodHandles.constant(String.class, "Wilma"));
assertEquals("WILMA", (String) worker1.invokeExact());
assertEquals("Wilma, dear?", (String) worker2.invokeExact());

    目标值的不同步：对可变的调用站点的目标的写入不会强制其他线程意识到更新的值。 相对于更新的呼叫站点不执行适当的同步动作的线程可以缓存旧的目标值并且无限期地延迟其对新的目标值的使用。 （这是应用于对象字段的Java内存模型的正常结果。）

    syncAll操作提供了强制线程接受新的目标值的方法，即使没有其他同步。

    对于经常更新的目标值，请考虑使用volatile call site 。

    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Constructor 描述
      MutableCallSite​(MethodHandle target)
      创建一个具有初始目标方法句柄的调用站点对象。
      MutableCallSite​(MethodType type)
      使用给定的方法类型创建一个空白的调用站点对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MethodHandle dynamicInvoker​()
      生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
      MethodHandle getTarget​()
      返回调用站点的目标方法，其行为类似于 MutableCallSite的正常字段。
      void setTarget​(MethodHandle newTarget)
      将此呼叫站点的目标方法更新为常规变量。
      static void syncAll​(MutableCallSite[] sites)
      在给定数组中的每个调用站点上执行同步操作，强制所有其他线程丢弃先前从任何呼叫站点的目标加载的缓存值。

      • Methods inherited from class java.lang.invoke.CallSite

        type

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MutableCallSite

        public MutableCallSite​(MethodType type)
        使用给定的方法类型创建一个空白的调用站点对象。 初始目标设置为给定类型的方法句柄，如果调用该方法句柄将抛出一个IllegalStateException 。

        呼叫站点的类型永久设置为给定类型。

        在从引导方法返回CallSite对象之前，或者以其他方式调用该对象，通常会通过调用setTarget提供更有用的目标方法。

        参数
        type - 此呼叫站点将具有的方法类型
        异常
        NullPointerException - 如果提议的类型为空

      • MutableCallSite

        public MutableCallSite​(MethodHandle target)
        创建一个具有初始目标方法句柄的调用站点对象。 呼叫站点的类型永久设置为初始目标的类型。
        参数
        target - 将作为呼叫站点初始目标的方法句柄
        异常
        NullPointerException - 如果提议的目标为空

    • 方法详细信息

      • getTarget

        public final MethodHandle getTarget​()
        返回调用站点的目标方法，其行为类似于MutableCallSite的正常字段。

        getTarget与存储器的交互与从普通变量读取的相同，例如数组元素或非易失性非最终字段。

        特别地，当前线程可以选择从存储器重用先前读取目标的结果，并且可能无法看到另一个线程对目标的最新更新。

        Specified by:
        getTarget在类 CallSite
        结果
        此呼叫站点的链接状态，可随时间变化的方法句柄
        另请参见：
        setTarget(java.lang.invoke.MethodHandle)

      • setTarget

        public void setTarget​(MethodHandle newTarget)
        将此呼叫站点的目标方法更新为常规变量。 新目标的类型必须符合旧目标的类型。

        与存储器的交互与对普通变量的写入相同，例如数组元素或非易失性非最终字段。

        特别地，不相关的线程可能无法看到更新的目标，直到它们执行从内存读取。 可以通过将适当的操作放入引导方法和/或在任何给定的呼叫站点使用的目标方法来创建更强大的保证。

        Specified by:
        setTarget在 CallSite
        参数
        newTarget - 新的目标
        异常
        NullPointerException - 如果提议的新目标为null
        WrongMethodTypeException - 如果提出的新目标具有与先前目标不同的方法类型
        另请参见：
        getTarget()

      • dynamicInvoker

        public final MethodHandle dynamicInvoker​()
        生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。

        此方法等同于以下代码：

 MethodHandle getTarget, invoker, result;
 getTarget = MethodHandles.publicLookup().bind(this, "getTarget", MethodType.methodType(MethodHandle.class));
 invoker = MethodHandles.exactInvoker(this.type());
 result = MethodHandles.foldArguments(invoker, getTarget)
        Specified by:
        dynamicInvoker在 CallSite
        结果
        总是调用此调用站点的当前目标的方法句柄

      • syncAll

        public static void syncAll​(MutableCallSite[] sites)
        在给定数组中的每个调用站点上执行同步操作，强制所有其他线程丢弃先前从任何呼叫站点的目标加载的缓存值。

        此操作不会反转任何已经在旧目标值上启动的呼叫。 （Java仅支持forward time travel ）

        整体效果是迫使每个呼叫站点的所有未来读者接受最近存储的值。 （“最近”是相对于syncAll本身计算的。）相反， syncAll调用可能会阻塞，直到所有读者都以某种方式解除了每个呼叫站点目标的所有先前版本。

        为避免竞争条件，通常应以某种互斥方式执行对setTarget和syncAll通话。 请注意，读者线程可以在安装该值的setTarget调用之前（以及确认该值的syncAll之前）观察更新的目标。 另一方面，读者线程可以观察目标的先前版本，直到syncAll呼叫返回（并且在尝试传达更新版本的setTarget之后）。

        这个操作可能是昂贵的，应该谨慎使用。 如果可能的话，应该对一组呼叫站点进行缓冲以进行批处理。

        如果sites包含一个空元素，则会产生一个NullPointerException 。 在这种情况下，方法返回异常之前，可能会处理数组中的一些非空元素。 哪些元素（如果有的话）是依赖于实现的。

        Java内存模型详细信息

        在Java内存模型方面，此操作执行与当前线程写入易失性变量相当的同步操作，以及可能访问受影响的呼叫站点之一的每个其他线程的最终易失性读取。

        以下效果显而易见，对于每个个人呼叫站点S ：

        • 创建一个新的volatile变量V ，并由当前线程写入。 由JMM定义，此写入是全局同步事件。
        • 由于写入事件的线程本地排序是正常的，所以当前线程已经执行的每个动作都在易失性写入V之前被V 。 （在某些实现中，这意味着当前线程执行全局释放操作。）
        • 具体来说，写入S的当前目标是在易失性写入V之前发生的。
        • V的易失性写入以全局同步顺序放置（以实现特定的方式）。
        • 考虑一个任意的线程T （除了当前线程）。 如果T在易失性写入V （全局同步顺序）之后执行同步动作A ，则需要查看当前目标值为S或稍后对该目标进行写入，如果它在目标上执行读取的S 。 （此约束称为“同步顺序一致性”。）
        • JMM专门允许优化编译器来删除已知无用的变量的读取或写入。 这种缓和的读取和写入对于发生之前的关系没有影响。 不管这个事实如何，易失性的V将不会被消除，即使它的写入值是不确定的，并且其读取值不被使用。
        由于最后一点，执行的行为就好像在V的动作A之后立即执行T的易失性读取。 在T的本地订购行动中，此读取发生在任何未来读取目标的S 。 这是因为如果执行任意地挑选的读取S的目标由T ，和强制的读V先于它，从而保证了新的目标值的通信。

        只要遵循Java内存模型的约束，实现可能会延迟完成syncAll操作，而其他线程（上述的T ）继续使用S的先前值。 然而，一直鼓励实施方式避免活动锁，并最终要求所有线程考虑更新的目标。

        讨论：出于性能原因， syncAll不是单个呼叫站点上的虚拟方法，而是适用于一组呼叫站点。 一些实现可能产生用于处理一个或多个同步操作的大的固定开销成本，但是每个附加呼叫站点的增量成本较小。 在任何情况下，该操作可能是昂贵的，因为其他线程可能必须以某种方式被中断，以便使它们注意更新的目标值。 然而，可以观察到，同步多个站点的单个调用与许多调用具有相同的正式效果，每个调用仅在其中一个站点上。

        实现注意： MutableCallSite简单实现可能会为易变的调用站点的目标使用volatile变量。 在这种实现中， syncAll方法可以是无操作的，但它将符合上述JMM行为。

        参数
        sites - 要同步的呼叫站点数组
        异常
        NullPointerException - if the sites array reference is null or the array contains a null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SerializedLambda (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class SerializedLambda

  • java.lang.Object
    • java.lang.invoke.SerializedLambda
  • All Implemented Interfaces:
    Serializable

    public final class SerializedLambda
extends Object
implements Serializable
    lambda表达式的序列化形式。 该类的属性表示在lambda工厂现场存在的信息，包括静态元验证参数，例如主功能接口方法的标识和实现方法的身份，以及动态元嗅觉参数，例如从在λ捕获时的词汇范围。

    可序列化的lambdas的实现者，如编译器或语言运行时库，有望确保反序列化的实例正确。 一种方法是确保writeReplace方法返回一个SerializedLambda的实例，而不是允许默认序列化继续。

    SerializedLambda有一个readResolve方法，在捕获类中查找一个名为$deserializeLambda$(SerializedLambda)的（可能是私有的）静态方法，并将其自身调用为第一个参数，并返回结果。 实施LAMBDA类$deserializeLambda$负责验证了的性质SerializedLambda是由该类实际拍摄的拉姆达一致。

    从以下版本开始：
    1.8
    另请参见：
    LambdaMetafactory ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SerializedLambda​(Class<?> capturingClass, String functionalInterfaceClass, String functionalInterfaceMethodName, String functionalInterfaceMethodSignature, int implMethodKind, String implClass, String implMethodName, String implMethodSignature, String instantiatedMethodType, Object[] capturedArgs)
      从lambda工厂现场的低级信息创建一个 SerializedLambda 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object getCapturedArg​(int i)
      获取lambda捕获站点的动态参数。
      int getCapturedArgCount​()
      获取lambda捕获站点的动态参数计数。
      String getCapturingClass​()
      获取捕获此lambda的类的名称。
      String getFunctionalInterfaceClass​()
      获取此lambda已转换到的调用类型的名称
      String getFunctionalInterfaceMethodName​()
      获取此lambda已转换的功能界面的主要方法的名称。
      String getFunctionalInterfaceMethodSignature​()
      获取此lambda已转换的功能界面的主要方法的签名。
      String getImplClass​()
      获取包含实现方法的类的名称。
      int getImplMethodKind​()
      获取方法处理类（见MethodHandleInfo ）的实现方法。
      String getImplMethodName​()
      获取实现方法的名称。
      String getImplMethodSignature​()
      获取实现方法的签名。
      String getInstantiatedMethodType​()
      在使用捕获站点的实例化代替类型变量后，获取主要功能接口方法的签名。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SerializedLambda

        public SerializedLambda​(Class<?> capturingClass,
                        String functionalInterfaceClass,
                        String functionalInterfaceMethodName,
                        String functionalInterfaceMethodSignature,
                        int implMethodKind,
                        String implClass,
                        String implMethodName,
                        String implMethodSignature,
                        String instantiatedMethodType,
                        Object[] capturedArgs)
        从lambda工厂现场的低级信息创建一个 SerializedLambda 。
        参数
        capturingClass - lambda表达式出现的类
        functionalInterfaceClass - 以斜杠分隔的形式，返回的lambda对象的静态类型的名称
        functionalInterfaceMethodName - 在lambda工厂现场的功能接口方法的名称
        functionalInterfaceMethodSignature - 在lambda工厂现场的功能接口方法的签名
        implMethodKind - 实现方法的方法句柄类
        implClass - 以斜杠分隔的形式，用于持有实现方法的类的名称
        implMethodName - 实现方法的名称
        implMethodSignature - 签名的实现方法
        instantiatedMethodType - 类型变量之后的主要功能接口方法的签名由其捕获站点的实例化代替
        capturedArgs - lambda工厂站点的动态参数，表示由lambda捕获的变量

    • 方法详细信息

      • getCapturingClass

        public String getCapturingClass​()
        获取捕获此lambda的类的名称。
        结果
        捕获此lambda的类的名称

      • getFunctionalInterfaceClass

        public String getFunctionalInterfaceClass​()
        获取此lambda已转换到的调用类型的名称
        结果
        此lambda已转换到的功能界面类的名称

      • getFunctionalInterfaceMethodName

        public String getFunctionalInterfaceMethodName​()
        获取此lambda已转换的功能界面的主要方法的名称。
        结果
        功能界面的主要方法的名称

      • getFunctionalInterfaceMethodSignature

        public String getFunctionalInterfaceMethodSignature​()
        获取此lambda已转换的功能界面的主要方法的签名。
        结果
        功能界面的主要方法的签名

      • getImplClass

        public String getImplClass​()
        获取包含实现方法的类的名称。
        结果
        包含实现方法的类的名称

      • getImplMethodName

        public String getImplMethodName​()
        获取实现方法的名称。
        结果
        实现方法的名称

      • getImplMethodSignature

        public String getImplMethodSignature​()
        获取实现方法的签名。
        结果
        执行方法的签名

      • getImplMethodKind

        public int getImplMethodKind​()
        获取方法句柄（见MethodHandleInfo ）的实现方法。
        结果
        该方法处理类的实现方法

      • getInstantiatedMethodType

        public final String getInstantiatedMethodType​()
        在使用捕获站点的实例化代替类型变量后，获取主要功能接口方法的签名。
        结果
        主要功能界面方法的签名在类型变量处理后

      • getCapturedArgCount

        public int getCapturedArgCount​()
        获取lambda捕获站点的动态参数计数。
        结果
        lambda捕获站点的动态参数计数

      • getCapturedArg

        public Object getCapturedArg​(int i)
        获取lambda捕获站点的动态参数。
        参数
        i - 要捕获的参数
        结果
        lambda捕获站点的动态参数

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个“ toString代表”这个对象的字符串。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringConcatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class StringConcatException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.invoke.StringConcatException
  • All Implemented Interfaces:
    Serializable

    public class StringConcatException
extends 异常
    当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。
    从以下版本开始：
    9
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      StringConcatException​(String msg)
      使用消息构造异常
      StringConcatException​(String msg, Throwable cause)
      使用消息和链接的throwable构造异常

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • StringConcatException

        public StringConcatException​(String msg)
        使用消息构造异常
        参数
        msg - 异常消息

      • StringConcatException

        public StringConcatException​(String msg,
                             Throwable cause)
        使用消息和链接的throwable构造异常
        参数
        msg - 异常消息
        cause - 可抛出的原因
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StringConcatFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class StringConcatFactory

  • java.lang.Object
    • java.lang.invoke.StringConcatFactory

  • public final class StringConcatFactory
extends Object

    有助于创建String连接方法的方法，可用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。 这些方法通常用作invokedynamic调用站点的引导方法 ，以支持Java编程语言的字符串连接功能。

    间接访问由所提供的MethodHandle指定的行为按顺序进行两个阶段：

    1. 当调用此类中的方法时，会发生链接 。 它们以参数形式描述连接参数的计数和类型，以及可选的String 配方 ，以及参与String连接的常量。 关于接受的食谱形状的细节将在下面进一步描述。 链接可能涉及动态加载实现预期连接行为的新类。 CallSite持有MethodHandle指向精确的级联方法。 连接方法可以在不同的CallSite之间共享，例如，如果链接方法产生它们作为纯函数。
    2. 当所生成的级联方法与精确动态参数调用发生调用 。 对于单个级联方法，这可能会发生多次。 使用静态参数和调用时提供的任何其他动态参数调用行为MethodHandle引用的方法，如MethodHandle.invoke(Object...)所示 。

    这个类提供了两种形式的链接方法：一个使用动态参数的简单版本（ makeConcat(java.lang.invoke.MethodHandles.Lookup, String, MethodType) ）和一个高级版本（ makeConcatWithConstants(java.lang.invoke.MethodHandles.Lookup, String, MethodType, String, Object...)使用高级形式捕获常量参数）。高级策略可以产生稍微更好的调用字节码爆炸了运行时存在的字符串连接方法的形状数量，因为这些形状也将包含常量静态参数。

    API Note:

    有一个JVM限制（类文件结构约束）：没有方法可以调用超过255个插槽。 这限制了可以传递给引导方法的静态和动态参数的数量。 由于存在使用MethodHandle组合器的潜在串联策略，因此我们需要在参数列表上保留几个空插槽以捕获时间结果。 这就是为什么这个工厂的引导方法不能接受超过200个参数插槽。 在连接中需要超过200个参数插槽的用户将会在较小的表达式中拆分大级连接。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static CallSite makeConcat​(MethodHandles.Lookup lookup, String name, MethodType concatType)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite makeConcatWithConstants​(MethodHandles.Lookup lookup, String name, MethodType concatType, String recipe, Object... constants)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • makeConcat

        public static CallSite makeConcat​(MethodHandles.Lookup lookup,
                                  String name,
                                  MethodType concatType)
                           throws StringConcatException
        促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。 通常用作invokedynamic调用站点的引导方法 ，以支持Java编程语言的字符串连接功能。

        当调用从该方法返回的CallSite的目标时，它返回String连接的结果，将传递给链接方法的所有函数参数作为连接的输入。 目标签名由concatType给出。 参数按照JLS 15.18.1“串联连接运算符+”中的要求进行连接。 值得注意的是，输入按照JLS 5.1.11“字符串转换”进行转换，并从左到右组合。

        假设链接参数如下：

        • concatType ，描述CallSite签名

        那么以下链接不变量必须保持：

        • concatType的参数计数小于等于200
        • concatType的返回类型可从String分配
        参数
        lookup - 表示具有调用者的可访问性特权的查找上下文。 当与invokedynamic使用时，由VM自动堆叠。
        name - 要实现的方法的名称。 这个名字是任意的，对于这种链接方法没有意义。 当与invokedynamic使用时，由NameAndType的InvokeDynamic提供，并由VM自动堆叠。
        concatType -的的预期的签名CallSite 。 参数类型表示级联参数的类型; 返回类型始终可从String分配。 当与invokedynamic使用时，由NameAndType的InvokeDynamic提供，并由VM自动堆叠。
        结果
        一个CallSite，其目标可用于执行字符串连接，具有由给定的 concatType描述的动态连接参数。
        异常
        StringConcatException - 如果这里描述的任何链接不变量被违反。
        NullPointerException - 如果任何传入的参数为空。 当使用invokedynamic调用引导方法时，这将永远不会发生。
        See The Java™ Language Specification:
        5.1.11字符串转换，15.18.1字符串连接运算符+

      • makeConcatWithConstants

        public static CallSite makeConcatWithConstants​(MethodHandles.Lookup lookup,
                                               String name,
                                               MethodType concatType,
                                               String recipe,
                                               Object... constants)
                                        throws StringConcatException
        促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。 通常用作invokedynamic调用站点的引导方法 ，以支持Java编程语言的字符串连接功能。

        当从该方法返回的CallSite的目标被调用时，它返回String连接的结果，将传递给链接方法的所有函数参数和常量作为连接的输入。 目标签名由concatType给出，不包括常数。 参数按照JLS 15.18.1“串联连接运算符+”中的要求进行连接。 值得注意的是，输入按照JLS 5.1.11“字符串转换”进行转换，并从左到右组合。

        连接配方是从参数和常量构造连接的String的方法的String描述。 配方从左到右处理，每个字符代表连接的输入。 食谱字符意味着：

        • \ 1（Unicode点0001） ：一个普通参数。 此输入通过动态参数传递，并在连接方法调用期间提供。 该输入可以为空。
        • \ 2（Unicode点0002）：一个常数。 此输入通过静态引导参数。 该常数可以是常量池中可表示的任何值。 如有必要，工厂将致电toString执行一次性字符串转换。
        • 任何其他char值：单个字符常量。

        假设链接参数如下：

        • concatType ，描述CallSite签名
        • recipe ，描述字符串配方
        • constants ，vararg数组的常量

        那么以下链接不变量必须保持：

        • concatType的参数计数小于或等于200
        • concatType的参数计数等于concatType中\ 1标签的recipe
        • concatType的返回类型可从String分配，并匹配返回的返回类型MethodHandle
        • constants的元素constants等于constants的\ 2标签recipe
        API Note:
        代码生成器有三种不同的方式来处理字符串连接表达式中的常量字符串操作数S。 首先，S可以作为参考（使用ldc）实现，并作为普通参数（配方“\ 1”）传递。 或者，S可以存储在常量池中并作为常数传递（配方“\ 2”）。 最后，如果S不包含配方标记字符（'\ 1'，'\ 2'），则S可以内插到配方本身，从而使其字符插入到结果中。
        参数
        lookup - 表示具有调用者的辅助功能权限的查找上下文。 当与invokedynamic使用时，VM将自动堆叠。
        name - 要实现的方法的名称。 这个名字是任意的，对于这种链接方法没有意义。 当与invokedynamic使用时，由NameAndType的InvokeDynamic提供，并由VM自动堆叠。
        concatType -的的预期的签名CallSite 。 参数类型表示动态级联参数的类型; 返回类型始终可从String分配。 当与invokedynamic使用时，由NameAndType的InvokeDynamic提供，并由VM自动堆叠。
        recipe - 连锁配方，如上所述。
        constants - 表示传递给链接方法的常量的vararg参数。
        结果
        一个CallSite，其目标可用于执行字符串连接，具有由给定的 concatType描述的动态连接参数。
        异常
        StringConcatException - 如果这里描述的任何链接不变量被违反。
        NullPointerException - 如果任何传入的参数为空，或者recipe任何常量为空。 当使用invokedynamic调用引导方法时，这将永远不会发生。
        See The Java™ Language Specification:
        5.1.11字符串转换，15.18.1字符串连接运算符+
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SwitchPoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class SwitchPoint

  • java.lang.Object
    • java.lang.invoke.SwitchPoint

  • public class SwitchPoint
extends Object

    A SwitchPoint是可以将状态转换发布到其他线程的对象。 切换点最初处于有效状态，但可随时更改为无效状态。 无效无法撤销。 切换点可以将守卫的一对方法句柄组合成守卫的委托者 。 守卫的委托者是一个方法句柄，它将一个旧的方法句柄委托。 切换点的状态确定两者中的哪一个获得授权。

    单个切换点可用于控制任意数量的方法句柄。 （间接地，它可以控制任何数量的呼叫站点）。这是通过使用单个切换点作为工厂来完成的，将任意数量的守卫方法句柄对组合成守卫的委托者。

    当一个守卫的委托者是从一个守卫的对创建的时候，该对被包裹在一个新的方法句柄M ，它与创建它的切换点永久关联。 每一对由目标T和后退F 。 当切换点有效时，调用M被委派给T 。 无效后，调用将被委派给F 。

    无效是全局和立即的，就像在每次调用M时，切换点包含一个易失性布尔变量M 。 无效也是永久的，这意味着切换点只能改变一次状态。 切换点将无效后始终委托给F 。 那时guardWithTest可能会忽略T并返回F 。

    下面是一个切换点的例子：

       MethodHandle MH_strcat = MethodHandles.lookup() .findVirtual(String.class, "concat", MethodType.methodType(String.class, String.class)); SwitchPoint spt = new SwitchPoint(); assert(!spt.hasBeenInvalidated()); // the following steps may be repeated to re-use the same switch point: MethodHandle worker1 = MH_strcat; MethodHandle worker2 = MethodHandles.permuteArguments(MH_strcat, MH_strcat.type(), 1, 0); MethodHandle worker = spt.guardWithTest(worker1, worker2); assertEquals("method", (String) worker.invokeExact("met", "hod")); SwitchPoint.invalidateAll(new SwitchPoint[]{ spt }); assert(spt.hasBeenInvalidated()); assertEquals("hodmet", (String) worker.invokeExact("met", "hod"));

    讨论：切换点在没有子类化的情况下是有用的。 他们也可能被分类。 这可能是有用的，以便将应用程序特定的无效逻辑与切换点相关联。 请注意，切换点与其生成和使用的方法句柄之间没有永久关联。 垃圾收集器可以独立于开关点本身的寿命，收集切换点产生或消耗的方法手柄。

    实现注意：切换点的行为就像在MutableCallSite之上实现一样 ，大致如下：

       public class SwitchPoint { private static final MethodHandle K_true = MethodHandles.constant(boolean.class, true), K_false = MethodHandles.constant(boolean.class, false); private final MutableCallSite mcs; private final MethodHandle mcsInvoker; public SwitchPoint() { this.mcs = new MutableCallSite(K_true); this.mcsInvoker = mcs.dynamicInvoker(); } public MethodHandle guardWithTest( MethodHandle target, MethodHandle fallback) { // Note: mcsInvoker is of type ()boolean. // Target and fallback may take any arguments, but must have the same type. return MethodHandles.guardWithTest(this.mcsInvoker, target, fallback); } public static void invalidateAll(SwitchPoint[] spts) { List<MutableCallSite> mcss = new ArrayList<>(); for (SwitchPoint spt : spts) mcss.add(spt.mcs); for (MutableCallSite mcs : mcss) mcs.setTarget(K_false); MutableCallSite.syncAll(mcss.toArray(new MutableCallSite[0])); } }
    从以下版本开始：
    1.7

    • 构造方法摘要

      构造方法
      Constructor 描述
      SwitchPoint​()
      创建一个新的切换点。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MethodHandle guardWithTest​(MethodHandle target, MethodHandle fallback)
      返回一个方法句柄，它始终将它们委托给目标或后备。
      boolean hasBeenInvalidated​()
      确定此切换点是否已被无效。
      static void invalidateAll​(SwitchPoint[] switchPoints)
      将所有给定的切换点设置为无效状态。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SwitchPoint

        public SwitchPoint​()
        创建一个新的切换点。

    • 方法详细信息

      • hasBeenInvalidated

        public boolean hasBeenInvalidated​()
        确定此切换点是否已被无效。

        讨论：由于无效的单向性质，一旦hasBeenInvalidated开关点开始返回true， hasBeenInvalidated会一直这样做。 另一方面，由于另一个线程的请求，其他线程可见的有效切换点可能在任何时候无效。

        由于无效是一个全局和立即的操作，所以在有效的切换点上执行此查询必须与可能导致无效的任何其他线程进行内部排序。 因此，该查询可能是昂贵的。 建立一个查询交换点s的无效状态的布尔值方法句柄的建议方法是调用s.guardWithTest的constant真假方法句柄。

        结果
        如果此切换点已失效，则为true

      • guardWithTest

        public MethodHandle guardWithTest​(MethodHandle target,
                                  MethodHandle fallback)
        返回一个方法句柄，它始终将它们委托给目标或后备。 只要切换点有效，方法句柄将正确地委派给目标。 之后，它将永久地委托回退。

        目标和后备必须是完全相同的方法类型，结果组合方法句柄也将是这种类型。

        参数
        target - 切换点选择的方法句柄，只要它有效
        fallback - 切换点无效后选择的方法句柄
        结果
        总是调用目标或后备的组合方法句柄
        异常
        NullPointerException - 如果任一参数为空
        IllegalArgumentException - 如果两种方法类型不匹配
        另请参见：
        MethodHandles.guardWithTest(java.lang.invoke.MethodHandle, java.lang.invoke.MethodHandle, java.lang.invoke.MethodHandle)

      • invalidateAll

        public static void invalidateAll​(SwitchPoint[] switchPoints)
        将所有给定的切换点设置为无效状态。 执行此呼叫后，任何线程都不会发现任何切换点处于有效状态。

        这个操作可能是昂贵的，应该谨慎使用。 如果可能，应对缓冲器进行缓冲，以便对交换点集合进行批处理。

        如果switchPoints包含一个空元素，则会产生一个NullPointerException 。 在这种情况下，方法返回异常之前，可能会处理数组中的一些非空元素。 哪些元素（如果有的话）是依赖于实现的。

        讨论：出于性能原因， invalidateAll不是单个切换点上的虚拟方法，而是适用于一组切换点。 一些实现可能产生用于处理一个或多个无效操作的大的固定开销成本，但是对于每个额外的无效，都需要较小的增量成本。 在任何情况下，该操作可能是昂贵的，因为其他线程可能必须以某种方式中断，以便使它们注意更新的切换点状态。 然而，可以观察到，使多个切换点无效的单个呼叫与多个呼叫具有相同的形式效果，每个呼叫仅在一个切换点上。

        实现注意： SwitchPoint简单实现可能会使用私有的MutableCallSite来发布切换点的状态。 在这种实现中， invalidateAll方法可以简单地更改呼叫站点的目标，并发出一个呼叫到所有私人呼叫站点的synchronize 。

        参数
        switchPoints - 要同步的呼叫站点数组
        异常
        NullPointerException - if the switchPoints array reference is null or the array contains a null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.lang.invoke (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang.invoke

  • Packages that use java.lang.invoke
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.dynalink.support
    包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。
  • Classes in java.lang.invoke used by java.lang.invoke
    Class 描述
    CallSite
    A CallSite是变量MethodHandle的持有人，称为其target 。
    LambdaConversionException
    LambdaConversionException
    MethodHandle
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
    MethodHandleInfo
    通过将直接方法句柄破解成其宪法符号部分获得的象征性参考。
    MethodHandles.Lookup
    查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。
    MethodType
    方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。
    MutableCallSite
    A MutableCallSite是一个CallSite，其目标变量的行为像一个普通字段。
    StringConcatException
    当链接不变量被违反时，StringConcatException抛出StringConcatFactory 。
    SwitchPoint
    A SwitchPoint是可以将状态转换发布到其他线程的对象。
    VarHandle
    VarHandle是对变量或参数定义的变量系列的动态强类型引用，包括静态字段，非静态字段，数组元素或非堆组数据结构的组件。
    VarHandle.AccessMode
    指定如何访问由VarHandle引用的变量的访问模式集。
  • Classes in java.lang.invoke used by jdk.dynalink
    Class 描述
    MethodHandle
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
    MethodHandles.Lookup
    查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。
    MethodType
    方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。
  • Classes in java.lang.invoke used by jdk.dynalink.beans
    Class 描述
    MethodHandle
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
  • Classes in java.lang.invoke used by jdk.dynalink.linker
    Class 描述
    MethodHandle
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
    MethodHandles.Lookup
    查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。
    MethodType
    方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。
    SwitchPoint
    A SwitchPoint是可以将状态转换发布到其他线程的对象。
  • Classes in java.lang.invoke used by jdk.dynalink.linker.support
    Class 描述
    MethodHandle
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
    MethodHandles.Lookup
    查找对象是用于创建方法句柄的工厂，当创建需要访问检查时。
    MethodType
    方法类型表示方法句柄接受和返回的参数和返回类型，或方法句柄调用者传递和预期的参数和返回类型。
  • Classes in java.lang.invoke used by jdk.dynalink.support
    Class 描述
    CallSite
    A CallSite是变量MethodHandle的持有人，称为其target 。
    MethodHandle
    方法句柄是一个类型化的，直接可执行的对底层方法，构造函数，字段或类似低级操作的引用，具有参数或返回值的可选转换。
    MutableCallSite
    A MutableCallSite is a CallSite whose target variable behaves like an ordinary field.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


VarHandle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class VarHandle

  • java.lang.Object
    • java.lang.invoke.VarHandle

  • public abstract class VarHandle
extends Object
    VarHandle是对变量或参数定义的变量系列的动态强类型引用，包括静态字段，非静态字段，数组元素或非堆组数据结构的组件。 在各种访问模式下支持对这些变量的访问 ，包括简单的读/写访问，易读/写访问和比较和交换。

    VarHandles是不可变的，没有可见的状态。 VarHandles不能被用户子类化。

    VarHandle有：

    • 一个variable type T，这个VarHandle引用的每个变量的类型; 和
    • coordinate types CT1, CT2, ..., CTn的列表，共同定位由该VarHandle引用的变量的坐标表达式 。
    变量和坐标类型可能是原始或参考，并由Class对象表示。 坐标类型列表可能为空。

    产生的工厂方法或lookup VarHandle实例记录支持的变量类型和坐标类型列表。

    每个访问模式都与一个访问模式方法相关联，一个signature polymorphic方法以访问模式命名。 当在VarHandle实例上调用访问模式方法时，调用的初始参数是坐标表达式，用于准确指出要访问变量的对象。 调用的跟踪参数表示对访问模式很重要的值。 例如，各种比较和设置或比较和交换访问模式需要变量的预期值和新值的两个尾随参数。

    调用访问模式方法的参数的类型和类型不会静态检查。 相反，每个访问模式方法指定一个表示为MethodType的实例的access mode type ，用作一种方法签名，动态检查参数。 访问模式类型根据VarHandle实例的坐标类型和对访问模式重要的值的类型给出形式参数类型。 访问模式类型还给出返回类型，通常以VarHandle实例的变量类型。 当在VarHandle实例上调用访问模式方法时，调用站点上的符号类型描述符，调用参数的运行时类型以及返回值的运行时类型必须为访问模式中给出的类型match类型。 如果匹配失败，将抛出运行时异常。 例如，访问模式方法compareAndSet(java.lang.Object...)指定如果其接收者是具有坐标类型为CT1, ..., CTn和可变类型T的VarHandle实例，则其访问模式类型为(CT1 c1, ..., CTn cn, T expectedValue, T newValue)boolean 。 假设一个VarHandle实例可以访问数组元素，它的坐标类型是String[]和int而其变量类型是String 。 对于接入模式类型compareAndSet这个VarHandle实例是(String[] c1, int c2, String expectedValue, String newValue)boolean 。 这样的VarHandle实例可能由array factory method和访问阵列元素产生，如下所示：

       String[] sa = ... VarHandle avh = MethodHandles.arrayElementVarHandle(String[].class); boolean r = avh.compareAndSet(sa, 10, "expected", "new");

    访问模式控制原子性和一致性。 普通读取（ get ）和写入（ set ）访问保证仅对于引用和最多32位的原始值是按位原子，并且对执行线程以外的线程不施加可观察的排序约束。 相对于对同一变量的访问， 不透明的操作是按位原子和相干排列的。 除了遵守Opaque属性之外， Acquire模式读取及其后续访问在匹配Release模式写入及其之前的访问之后被排序。 除了遵守Acquire和Release属性之外，所有的Volatile操作都是完全相互排列的。

    访问模式分为以下几类：

    • 读取访问模式，在指定的内存排序效果下获取变量的值。 该组对应属于该组的访问模式的方法的组成的方法get ， getVolatile ， getAcquire ， getOpaque 。
    • 写访问模式，用于在指定的内存排序效果下设置变量的值。 该组对应属于该组的访问模式的方法的组成的方法set ， setVolatile ， setRelease ， setOpaque 。
    • 原子更新访问模式，例如，在指定的内存排序效果下，原子比较和设置变量的值。 该组对应属于该组的访问模式的方法的组成的方法compareAndSet ， weakCompareAndSetPlain ， weakCompareAndSet ， weakCompareAndSetAcquire ， weakCompareAndSetRelease ， compareAndExchangeAcquire ， compareAndExchange ， compareAndExchangeRelease ， getAndSet ， getAndSetAcquire ， getAndSetRelease 。
    • 数字原子更新访问模式，例如，原子获取和设置添加指定内存排序效果下的变量的值。 该组的属于该组的相应的访问模式的方法由方法getAndAdd ， getAndAddAcquire ， getAndAddRelease ，
    • 比特原子更新访问模式，例如，原子获取和按位OR或指定内存排序效果下的变量的值。 该组对应属于该组的访问模式的方法的组成的方法getAndBitwiseOr ， getAndBitwiseOrAcquire ， getAndBitwiseOrRelease ， getAndBitwiseAnd ， getAndBitwiseAndAcquire ， getAndBitwiseAndRelease ， getAndBitwiseXor ， getAndBitwiseXorAcquire ， getAndBitwiseXorRelease 。

    产生的工厂方法或lookup VarHandle实例记录了支持的访问模式集，其中还可能包括基于变量类型的文档限制以及变量是否为只读。 如果不支持访问模式，则相应的访问模式方法将在调用时抛出一个UnsupportedOperationException 。 工厂方法应记录访问模式方法可能抛出的任何其他未声明的异常。 所有VarHandle实例支持get访问模式，相应的方法不会抛出UnsupportedOperationException 。 如果VarHandle引用只读变量（例如final字段），则不支持写入，原子更新，数字原子更新和按位原子更新访问模式，并且相应的方法抛出UnsupportedOperationException 。 读/写访问模式（如果支持），除了get和set ，为参考类型和所有原始类型提供原子访问。 除非在工厂方法的文档中另有说明，否则访问模式get和set （如果支持）为32位平台上的long和double提供了引用类型和所有原语类型的原子访问。

    访问模式将覆盖变量声明站点上指定的任何内存排序效果。 例如，使用get访问模式访问aa域的get将访问其访问模式指定的字段，即使该字段声明为volatile 。 当执行混合访问时，应该非常小心，因为Java内存模型可能允许令人惊讶的结果。

    除了支持对各种访问模式下的变量的访问之外，还提供了一组静态方法，称为内存栅栏方法，用于对存储器排序的细粒度控制。 Java语言规范允许其他线程观察操作，就像它们是按照程序源代码中显而易见的顺序执行的，受制于例如使用锁， volatile字段或VarHandles的限制。 静态方法， fullFence ， acquireFence ， releaseFence ， loadLoadFence和storeStoreFence ，还可以用来施加约束。 他们的规格与特定访问模式的情况一样，是以缺乏“重新排序”的方式表达的 - 如果栅栏不存在可能会发生可能发生的排序效应。 访问模式方法和内存围栏方法规范的更准确的措辞可能与Java语言规范的未来更新有关。

    编译访问模式方法的调用

    命名访问模式方法的Java方法调用表达式可以从Java源代码调用VarHandle。 从源代码的角度来看，这些方法可以采用任何参数，并且可以将它们的多态结果（如果表达式）转换为任何返回类型。 正式地，这是通过给出访问模式方法变量Object参数和Object返回类型（如果返回类型是多态的），但它们具有称为签名多态性的附加质量，将这种调用自由直接连接到JVM执行堆栈。

    像虚拟方法一样，源级调用访问模式方法编译为一个invokevirtual指令。 更奇怪的是，编译器必须记录实际的参数类型，并且可能不会对参数执行方法调用转换。 相反，它必须根据自己的未转换类型生成指令，将其推送到堆栈上。 在参数之前，VarHandle对象本身将被推送到栈上。 编译器然后生成一个invokevirtual指令，该指令使用描述参数和返回类型的符号类型描述符来调用访问模式方法。

    要发出一个完整的符号类型描述符，编译器还必须确定返回类型（如果是多态）。 这是基于对方法调用表达一个演员，如果有，否则Object如果调用是一个表达式，否则void如果调用的声明。 演员可能是原始类型（但不是void ）。

    为角情况下，uncasted null给出参数的象征性类型描述符java.lang.Void 。 与类型Void的歧义是无害的，因为没有引用类型Void除了空引用。

    Performing invocation of access mode methods

    第一次执行invokevirtual指令时，它通过符号解析指令中的名称并验证方法调用是静态合法的。 这也适用于访问模式方法的调用。 在这种情况下，检查编译器发出的符号类型描述符是否正确的语法，并且解析其包含的名称。 因此，只要符号类型描述符在语法上形成良好并且类型存在，则调用访问模式方法的invokevirtual指令将始终链接。

    当链接后执行invokevirtual ，接收到的VarHandle的访问模式类型首先由JVM检查，以确保它符合符号类型描述符。 如果类型匹配失败，这意味着调用者调用的访问模式方法不会在调用的单个VarHandle中存在。

    访问模式方法的调用就像调用MethodHandle.invoke(java.lang.Object...)一样 ，其中接收方法句柄接受VarHandle实例作为前导参数。 更具体地说，以下， {access-mode}对应于访问模式方法名称：

       VarHandle vh = .. R r = (R) vh.{access-mode}(p1, p2, ..., pN);
    表现如下：
       VarHandle vh = .. VarHandle.AccessMode am = VarHandle.AccessMode.valueFromMethodName("{access-mode}"); MethodHandle mh = MethodHandles.varHandleExactInvoker( am, vh.accessModeType(am)); R r = (R) mh.invoke(vh, p1, p2, ..., pN)
    （模数访问模式方法不声明抛出Throwable ）。 这相当于：
       MethodHandle mh = MethodHandles.lookup().findVirtual( VarHandle.class, "{access-mode}", MethodType.methodType(R, p1, p2, ..., pN)); R r = (R) mh.invokeExact(vh, p1, p2, ..., pN)
    其中所需的方法类型是符号类型描述符，并且执行一个MethodHandle.invokeExact(java.lang.Object...) ，因为在调用目标之前，句柄将根据需要应用引用转换，并且box，unbox或扩展原始值，如同通过asType （另见MethodHandles.varHandleInvoker(java.lang.invoke.VarHandle.AccessMode, java.lang.invoke.MethodType) ） 。 更简洁，这样的行为相当于：
       VarHandle vh = .. VarHandle.AccessMode am = VarHandle.AccessMode.valueFromMethodName("{access-mode}"); MethodHandle mh = vh.toMethodHandle(am); R r = (R) mh.invoke(p1, p2, ..., pN)
    在这种情况下，方法句柄绑定到VarHandle实例。

    调用检查

    在典型的程序中，VarHandle访问模式类型匹配通常会成功。 但是如果匹配失败，JVM将会抛出一个WrongMethodTypeException 。

    因此，接入模式类型不匹配可能显示为在一个静态类型节目联动误差最多可以显示作为动态WrongMethodTypeException在使用VarHandles的程序。

    因为访问模式类型包含“live” Class对象，方法类型匹配同时考虑了类型名称和类加载器。 因此，即使VarHandle VH在一个类加载器创建L1和使用另一L2 ，VarHandle接入方式方法调用是类型安全的，因为调用者的符号类型描述符，如解决L2 ，是对匹配原被叫方法的符号类型描述符，如L1所解析。 决议L1时发生VH创建和访问模式类型分配，而在分辨率L2当发生invokevirtual指令链接。

    除了类型描述符检查，VarHandles访问它的变量的能力是不受限制的。 如果通过可访问该变量的类在非公开变量上形成VarHandle，那么生成的VarHandle可以被任何接收到引用的调用者在任何地方使用。

    与Core Reflection API不同，每次调用反射方法时都会检查访问权限，因此执行VarHandle访问检查when the VarHandle is created 。 因此，VarHandles对非公共变量或非公共类中的变量通常应该保密。 它们不应该传递给不受信任的代码，除非它们来自不受信任的代码的使用将是无害的。

    创建VarHandle

    Java代码可以创建一个VarHandle，直接访问该代码可访问的任何字段。 这是通过一个反映出基于能力的API MethodHandles.Lookup完成的 。 例如，可以从Lookup.findVarHandle获取非静态字段的VarHandle 。 Core Reflection API对象也有一个转换方法， Lookup.unreflectVarHandle 。

    对受保护的字段成员的访问仅限于访问类或其子类之一的接收者，而访问类又必须是受保护成员定义类的子类（或包兄弟）。 如果VarHandle是指当前包之外的声明类的受保护非静态字段，则接收器参数将被缩小为访问类的类型。

    VarHandles与Core Reflection API的互操作

    在Lookup API中使用工厂方法，由Core Reflection API对象表示的任何字段都可以转换为行为上等效的VarHandle。 例如，反射Field可以使用Lookup.unreflectVarHandle转换为VarHandle 。 所产生的VarHandles通常提供更直接和有效的访问底层字段。

    作为一种特殊情况，当Core Reflection API用于查看此类中的签名多态访问模式方法时，它们显示为普通非多态方法。 由Class.getDeclaredMethod所观察到的反光外观不受其在该API中的特殊状态的影响。 例如， Method.getModifiers将精确地报告任何类似声明的方法所需的修改位，包括在这种情况下为native和varargs位。

    与任何反映的方法一样，这些方法（反映时）可以通过JNI直接通过java.lang.reflect.Method.invoke调用，或通过Lookup.unreflect间接调用 。 但是，这种反射调用不会导致访问模式方法调用。 这样一个调用，如果通过必需的参数（一个单一的，类型为Object[] ），将忽略该参数，并将抛出一个UnsupportedOperationException 。

    由于invokevirtual指令可以在任何符号类型描述符下本地调用VarHandle访问模式方法，因此这种反射视图与通过字节码的这些方法的正常呈现相冲突。 因此，当由Class.getDeclaredMethod反射观察时，这些本机方法可能仅被视为占位符。

    为了获得特定访问模式类型的调用方法，请使用MethodHandles.varHandleExactInvoker(java.lang.invoke.VarHandle.AccessMode, java.lang.invoke.MethodType)或MethodHandles.varHandleInvoker(java.lang.invoke.VarHandle.AccessMode, java.lang.invoke.MethodType) 。 Lookup.findVirtual API还能够返回一个方法句柄来为任何指定的访问模式类型调用访问模式方法，并且在行为上相当于MethodHandles.varHandleInvoker(java.lang.invoke.VarHandle.AccessMode, java.lang.invoke.MethodType) 。

    VarHandles和Java泛型之间的互操作

    可以为变量获取VarHandle，例如aa字段，它使用Java通用类型声明。 与Core Reflection API一样，VarHandle的变量类型将由源级类型的擦除构成。 当调用VarHandle访问模式方法时，其参数或返回值转换类型的类型可能是通用类型或类型实例。 如果发生这种情况，编译器将在构建invokevirtual指令的符号类型描述符时，通过其擦除来替换这些类型。
    从以下版本开始：
    9
    另请参见：
    MethodHandle ， MethodHandles ， MethodType

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  VarHandle.AccessMode
      指定如何访问由VarHandle引用的变量的访问模式集。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MethodType accessModeType​(VarHandle.AccessMode accessMode)
      获取此VarHandle和给定访问模式的访问模式类型。
      static void acquireFence​()
      确保栅栏之前的载荷在栅栏后不会被装载和存储重新排序。
      Object compareAndExchange​(Object... args)
      以原子方式设置的变量的值 newValue用的存储器语义 setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 getVolatile(java.lang.Object...) 。
      Object compareAndExchangeAcquire​(Object... args)
      以原子方式设置的变量的值 newValue用的存储器语义 set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 getAcquire(java.lang.Object...) 。
      Object compareAndExchangeRelease​(Object... args)
      以原子方式设置的变量的值 newValue用的存储器语义 setRelease(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 get(java.lang.Object...) 。
      boolean compareAndSet​(Object... args)
      以原子方式设置的变量的值 newValue用的存储器语义 setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 getVolatile(java.lang.Object...) 。
      List<Class<?>> coordinateTypes​()
      返回此VarHandle的坐标类型。
      static void fullFence​()
      确保围墙之前的装载和商店不会在围栏后面加载和存储重新排序。
      Object get​(Object... args)
      返回变量的值，读取的内存语义就好像变量被声明为非 volatile 。
      Object getAcquire​(Object... args)
      返回变量的值，并确保后续加载和存储在此访问之前未重新排序。
      Object getAndAdd​(Object... args)
      以原子添加 value用的内存语义变量的当前值 setVolatile(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 getVolatile(java.lang.Object...) 。
      Object getAndAddAcquire​(Object... args)
      以原子添加 value用的内存语义变量的当前值 set(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 getAcquire(java.lang.Object...) 。
      Object getAndAddRelease​(Object... args)
      以原子添加 value用的内存语义变量的当前值 setRelease(java.lang.Object...) ，并返回变量的前值，与记忆语义访问 get(java.lang.Object...) 。
      Object getAndBitwiseAnd​(Object... args)
      将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间按位AND的结果，并返回变量的上一个值，内存语义为 getVolatile(java.lang.Object...) 。
      Object getAndBitwiseAndAcquire​(Object... args)
      将变量的值原子设置为变量当前值与 mask之间按位AND的结果，其内存语义为 set(java.lang.Object...)，并返回变量的上一个值，内存语义为 getAcquire(java.lang.Object...) 。
      Object getAndBitwiseAndRelease​(Object... args)
      将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间按位AND的结果，并返回变量的先前值，如使用 get(java.lang.Object...)的存储器语义访问的。
      Object getAndBitwiseOr​(Object... args)
      将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的上一个值，内存语义为 getVolatile(java.lang.Object...) 。
      Object getAndBitwiseOrAcquire​(Object... args)
      原子地将变量的值设置为变量当前值与 mask的内存语义的 mask之间的按位OR的结果，并返回变量的上一个值，如同内存语义为 getAcquire(java.lang.Object...)一样访问。
      Object getAndBitwiseOrRelease​(Object... args)
      原子地将变量的值设置为变量当前值与 mask的存储器语义的 mask之间的按位OR的结果，并返回变量的先前值，如使用内存语义 get(java.lang.Object...)访问的。
      Object getAndBitwiseXor​(Object... args)
      将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为 getVolatile(java.lang.Object...) 。
      Object getAndBitwiseXorAcquire​(Object... args)
      将变量的值原子设置为变量的当前值与 mask的存储器语义的 mask之间的按位XOR的结果，并返回变量的上一个值，如使用内存语义 getAcquire(java.lang.Object...)访问的。
      Object getAndBitwiseXorRelease​(Object... args)
      将变量的值原子设置为变量当前值与 mask的存储器语义的 mask之间的按位XOR的结果，并返回变量的上一个值，如使用内存语义 get(java.lang.Object...)访问的。
      Object getAndSet​(Object... args)
      原子地将变量的值设置为 newValue ，其内存语义为 setVolatile(java.lang.Object...)，并返回变量的先前值，如使用内存语义 getVolatile(java.lang.Object...)访问的。
      Object getAndSetAcquire​(Object... args)
      原子地将变量的值设置为 newValue ，其内存语义为 set(java.lang.Object...)，并返回变量的先前值，如使用内存语义 getAcquire(java.lang.Object...)访问的。
      Object getAndSetRelease​(Object... args)
      将变量的值原子设置为 newValue ，其内存语义为 setRelease(java.lang.Object...)，并返回变量的先前值，如使用内存语义 get(java.lang.Object...)访问的。
      Object getOpaque​(Object... args)
      返回以程序顺序访问的变量的值，但不能保证相对于其他线程的内存排序效果。
      Object getVolatile​(Object... args)
      返回变量的值，读取的内存语义就像变量声明为 volatile 。
      boolean isAccessModeSupported​(VarHandle.AccessMode accessMode)
      如果给定的访问模式被支持，则返回 true ，否则 false 。
      static void loadLoadFence​()
      确保栅栏之前的载荷在栅栏后不会被重新排列。
      static void releaseFence​()
      确保栅栏之前的货物和商店在栅栏后不会与商店重新排序。
      void set​(Object... args)
      将变量的值设置为 newValue ，具有设置的内存语义，就像变量被声明为非 volatile final 。
      void setOpaque​(Object... args)
      以程序顺序将变量的值设置为 newValue ，但不能保证相对于其他线程的内存排序效果。
      void setRelease​(Object... args)
      将变量的值设置为 newValue ，并确保先前的加载和存储在此访问后不重新排序。
      void setVolatile​(Object... args)
      将变量的值设置为 newValue ，其内存语义设置为变量已声明为 volatile 。
      static void storeStoreFence​()
      确保栅栏之前的商店在栅栏后不会与商店重新排列。
      MethodHandle toMethodHandle​(VarHandle.AccessMode accessMode)
      获取绑定到此VarHandle和给定访问模式的方法句柄。
      Class<?> varType​()
      返回此VarHandle引用的变量的变量类型。
      boolean weakCompareAndSet​(Object... args)
      可能原子将变量到值 newValue用的存储器语义 setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 getVolatile(java.lang.Object...) 。
      boolean weakCompareAndSetAcquire​(Object... args)
      可能原子将变量到值 newValue用的语义 set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 getAcquire(java.lang.Object...) 。
      boolean weakCompareAndSetPlain​(Object... args)
      可能原子将变量到值 newValue用的语义 set(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 get(java.lang.Object...) 。
      boolean weakCompareAndSetRelease​(Object... args)
      可能原子将变量到值 newValue用的语义 setRelease(java.lang.Object...) ，如果该变量的当前值，被称为 证人值 ， ==的 expectedValue ，与的存储器访问语义 get(java.lang.Object...) 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • get

        public final Object get​(Object... args)
        返回一个变量的值，读取的内存语义就好像变量被声明为非volatile 。 通常被称为普通读取访问。

        方法签名的格式为(CT1 ct1, ..., CTn ctn)T 。

        get呼叫站点上的符号类型描述符必须与在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET)的结果匹配访问模式类型。

        所有VarHandle实例支持此访问模式，并且不会抛出UnsupportedOperationException 。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn)的签名 - 多态参数列表。
        结果
        作为变量值的签名 - 多态结果，使用 Object静态表示。
        异常
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • set

        public final void set​(Object... args)
        将变量的值设置为newValue ，具有设置的内存语义，就像变量被声明为非volatile和非final 。 通常被称为普通写访问。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T newValue)void

        set呼叫站点上的符号类型描述符必须与该accessModeType(VarHandle.AccessMode.SET)上调用accessModeType(VarHandle.AccessMode.SET)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T newValue)的签名 - 多态参数列表。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • getVolatile

        public final Object getVolatile​(Object... args)
        返回变量的值，读取的内存语义就像变量声明为volatile 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn)T 。

        getVolatile的呼叫站点的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_VOLATILE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn)的签名 - 多态参数列表。
        结果
        作为变量值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • setVolatile

        public final void setVolatile​(Object... args)
        将变量的值设置为newValue ，其内存语义设置为变量已声明为volatile 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T newValue)void 。

        setVolatile呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.SET_VOLATILE)的结果。

        API Note:
        忽略C和C ++的许多语义差异，该方法具有与 memory_order_seq_cst兼容的内存排序效果。
        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T newValue)的签名 - 多态参数列表。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • getOpaque

        public final Object getOpaque​(Object... args)
        返回以程序顺序访问的变量的值，但不能保证相对于其他线程的内存排序效果。

        方法签名的格式为(CT1 ct1, ..., CTn ctn)T 。

        呼叫站点getOpaque处的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_OPAQUE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn)的签名 - 多态参数列表。
        结果
        作为变量值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • setOpaque

        public final void setOpaque​(Object... args)
        以程序顺序将变量的值设置为newValue ，但不能保证与其他线程相关的内存排序效果。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T newValue)void 。

        setOpaque呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.SET_OPAQUE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T newValue)的签名 - 多态参数列表。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • getAcquire

        public final Object getAcquire​(Object... args)
        返回变量的值，并确保后续加载和存储在此访问之前未重新排序。

        方法签名的格式为(CT1 ct1, ..., CTn ctn)T 。

        getAcquire呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是此accessModeType(VarHandle.AccessMode.GET_ACQUIRE)上调用accessModeType(VarHandle.AccessMode.GET_ACQUIRE)的结果。

        API Note:
        忽略C和C ++的许多语义差异，该方法具有与 memory_order_acquire订购兼容的内存订购效果。
        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn)的签名 - 多态参数列表。
        结果
        作为变量值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • setRelease

        public final void setRelease​(Object... args)
        将变量的值设置为newValue ，并确保先前的加载和存储在此访问后不重新排序。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T newValue)void 。

        呼叫站点setRelease的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.SET_RELEASE)的结果。

        API Note:
        忽略C和C ++的许多语义差异，该方法具有与 memory_order_release订购兼容的存储器排序效果。
        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T newValue)的签名 - 多态参数列表。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。

      • compareAndSet

        public final boolean compareAndSet​(Object... args)
        以原子方式设置的变量的值newValue用的存储器语义setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义getVolatile(java.lang.Object...) 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)boolean 。

        compareAndSet呼叫站点上的符号类型描述符必须与此accessModeType(VarHandle.AccessMode.COMPARE_AND_SET)上调用accessModeType(VarHandle.AccessMode.COMPARE_AND_SET)结果的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名多态参数列表。
        结果
        true如果成功，否则 false如果见证值与 expectedValue不一样。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • compareAndExchange

        public final Object compareAndExchange​(Object... args)
        以原子方式设置的变量的值newValue用的存储器语义setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义getVolatile(java.lang.Object...) 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)T 。

        compareAndExchange呼叫站点的符号类型描述符必须与该accessModeType(VarHandle.AccessMode.COMPARE_AND_EXCHANGE)上调用accessModeType(VarHandle.AccessMode.COMPARE_AND_EXCHANGE)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名 - 多态参数列表。
        结果
        作为见证值的签名多态结果，如果成功，将与 expectedValue相同，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与呼叫者的符号类型描述符不兼容。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符兼容，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • compareAndExchangeAcquire

        public final Object compareAndExchangeAcquire​(Object... args)
        以原子方式设置的变量的值newValue用的存储器语义set(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义getAcquire(java.lang.Object...) 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)T 。

        compareAndExchangeAcquire呼叫站点上的符号类型描述符必须与访问模式类型相匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.COMPARE_AND_EXCHANGE_ACQUIRE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名 - 多态参数列表。
        结果
        作为见证值的签名多态结果，如果成功，将与 expectedValue相同，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        set(Object...) ， getAcquire(Object...)

      • compareAndExchangeRelease

        public final Object compareAndExchangeRelease​(Object... args)
        以原子方式设置的变量的值newValue用的存储器语义setRelease(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义get(java.lang.Object...) 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)T 。

        compareAndExchangeRelease的呼叫站点上的符号类型描述符必须与此accessModeType(VarHandle.AccessMode.COMPARE_AND_EXCHANGE_RELEASE)上调用accessModeType(VarHandle.AccessMode.COMPARE_AND_EXCHANGE_RELEASE)结果的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名 - 多态参数列表。
        结果
        作为见证值的签名多态结果，如果成功，将与 expectedValue相同，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setRelease(Object...) ， get(Object...)

      • weakCompareAndSetPlain

        public final boolean weakCompareAndSetPlain​(Object... args)
        可能原子将变量到值newValue用的语义set(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义get(java.lang.Object...) 。

        即使证人值与预期值相符，此操作也可能会虚假地失败（通常是由于内存争用）。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)boolean 。

        weakCompareAndSetPlain呼叫站点上的符号类型描述符必须与在此VarHandle上调用accessModeType(VarHandle.AccessMode.WEAK_COMPARE_AND_SET_PLAIN)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名 - 多态参数列表。
        结果
        true如果成功，否则 false如果见证值与 expectedValue或者这个操作是否虚假失败。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        set(Object...) ， get(Object...)

      • weakCompareAndSet

        public final boolean weakCompareAndSet​(Object... args)
        可能原子将变量到值newValue用的存储器语义setVolatile(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义getVolatile(java.lang.Object...) 。

        即使证人值与预期值相符，此操作也可能会虚假地失败（通常是由于内存争用）。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)boolean 。

        weakCompareAndSet呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.WEAK_COMPARE_AND_SET)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名 - 多态参数列表。
        结果
        true如果成功，否则为 false如果见证值与 expectedValue或者这个操作是否虚假失败。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • weakCompareAndSetAcquire

        public final boolean weakCompareAndSetAcquire​(Object... args)
        可能原子将变量到值newValue用的语义set(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义getAcquire(java.lang.Object...) 。

        即使证人值与预期值相符，此操作也可能会虚假地失败（通常是由于内存争用）。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)boolean 。

        weakCompareAndSetAcquire呼叫站点上的符号类型描述符必须与该accessModeType(VarHandle.AccessMode.WEAK_COMPARE_AND_SET_ACQUIRE)上调用accessModeType(VarHandle.AccessMode.WEAK_COMPARE_AND_SET_ACQUIRE)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名 - 多态参数列表。
        结果
        true如果成功，否则为 false如果见证值与 expectedValue或者这个操作是否虚假失败。
        异常
        UnsupportedOperationException - 如果该VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        set(Object...) ， getAcquire(Object...)

      • weakCompareAndSetRelease

        public final boolean weakCompareAndSetRelease​(Object... args)
        可能原子将变量到值newValue用的语义setRelease(java.lang.Object...) ，如果该变量的当前值，被称为证人值 ， ==的expectedValue ，与的存储器访问语义get(java.lang.Object...) 。

        即使证人值与预期值相符，此操作也可能会虚假地失败（通常是由于内存争用）。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)boolean 。

        weakCompareAndSetRelease呼叫站点上的符号类型描述符必须与此accessModeType(VarHandle.AccessMode.WEAK_COMPARE_AND_SET_RELEASE)上调用accessModeType(VarHandle.AccessMode.WEAK_COMPARE_AND_SET_RELEASE)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T expectedValue, T newValue)的签名 - 多态参数列表。
        结果
        true如果成功，否则 false如果见证值与 expectedValue或者这个操作是否虚假失败。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setRelease(Object...) ， get(Object...)

      • getAndSet

        public final Object getAndSet​(Object... args)
        原子地将变量的值设置为newValue ，其内存语义为setVolatile(java.lang.Object...)，并返回变量的先前值，如使用getVolatile(java.lang.Object...)的内存语义访问的。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T newValue)T 。

        getAndSet的呼叫站点上的符号类型描述符必须与此accessModeType(VarHandle.AccessMode.GET_AND_SET)上调用accessModeType(VarHandle.AccessMode.GET_AND_SET)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T newValue)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndSetAcquire

        public final Object getAndSetAcquire​(Object... args)
        将变量的值原子设置为newValue ，其内存语义为set(java.lang.Object...)，并返回变量的上一个值，内存语义为getAcquire(java.lang.Object...) 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T newValue)T 。

        getAndSetAcquire的呼叫站点的符号类型描述符必须与访问模式类型匹配，该类型是此accessModeType(VarHandle.AccessMode.GET_AND_SET_ACQUIRE)上调用accessModeType(VarHandle.AccessMode.GET_AND_SET_ACQUIRE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T newValue)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果该VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndSetRelease

        public final Object getAndSetRelease​(Object... args)
        原子地将变量的值设置为newValue ，其内存语义为setRelease(java.lang.Object...)，并返回变量的先前值，如使用内存语义get(java.lang.Object...)访问的。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T newValue)T 。

        呼叫站点getAndSetRelease处的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_SET_RELEASE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T newValue)的签名 - 多态参数列表。
        结果
        作为变量前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndAdd

        public final Object getAndAdd​(Object... args)
        以原子添加value用的内存语义变量的当前值setVolatile(java.lang.Object...) ，并返回变量的前值，与记忆语义访问getVolatile(java.lang.Object...) 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T value)T 。

        getAndAdd的呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_ADD)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T value)的签名 - 多态参数列表。
        结果
        使用 Object静态表示的变量的前一个值的签名 - 多态结果。
        异常
        UnsupportedOperationException - 如果该VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndAddAcquire

        public final Object getAndAddAcquire​(Object... args)
        原子value添加到存储器语义为set(java.lang.Object...)的变量的当前值，并返回变量的先前值，如使用内存语义getAcquire(java.lang.Object...)访问的。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T value)T 。

        getAndAddAcquire呼叫站点上的符号类型描述符必须与该accessModeType(VarHandle.AccessMode.GET_AND_ADD_ACQUIRE)上调用accessModeType(VarHandle.AccessMode.GET_AND_ADD_ACQUIRE)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T value)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndAddRelease

        public final Object getAndAddRelease​(Object... args)
        以原子添加value用的内存语义变量的当前值setRelease(java.lang.Object...) ，并返回变量的前值，与记忆语义访问get(java.lang.Object...) 。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T value)T 。

        getAndAddRelease的呼叫站点上的符号类型描述符必须与该accessModeType(VarHandle.AccessMode.GET_AND_ADD_RELEASE)上调用accessModeType(VarHandle.AccessMode.GET_AND_ADD_RELEASE)结果的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T value)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndBitwiseOr

        public final Object getAndBitwiseOr​(Object... args)
        在变量的当前值和mask的存储器语义为setVolatile(java.lang.Object...)之间，将变量的值原子设置为按位OR的结果，并返回变量的上一个值，并使用存储器语义getVolatile(java.lang.Object...)访问。

        如果变量类型是非整数boolean类型，则执行逻辑或代替按位OR。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseOr呼叫站点上的符号类型描述符必须与此accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_OR)上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_OR)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndBitwiseOrAcquire

        public final Object getAndBitwiseOrAcquire​(Object... args)
        将变量的值原子设置为变量当前值与mask的存储器语义的mask之间的按位OR的结果，并返回变量的先前值，如使用内存语义getAcquire(java.lang.Object...)访问的。

        如果变量类型是非整数boolean类型，则执行逻辑或代替按位OR。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseOrAcquire的呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_OR_ACQUIRE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        set(Object...) ， getAcquire(Object...)

      • getAndBitwiseOrRelease

        public final Object getAndBitwiseOrRelease​(Object... args)
        将变量的值原子设置为变量的当前值与mask的存储器语义的mask之间的按位OR的结果，并返回变量的先前值，如使用内存语义get(java.lang.Object...)访问的。

        如果变量类型是非整数boolean类型，则执行逻辑或代替按位OR。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseOrRelease呼叫站点上的符号类型描述符必须与在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_OR_RELEASE)的结果匹配访问模式类型。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setRelease(Object...) ， get(Object...)

      • getAndBitwiseAnd

        public final Object getAndBitwiseAnd​(Object... args)
        原子地将变量的值设置为变量当前值与mask的存储器语义的mask之间的按位AND的结果，并返回变量的先前值，如使用存储器语义getVolatile(java.lang.Object...)访问的。

        如果变量类型是非整数boolean类型，则执行逻辑“与”而不是按位AND。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseAnd的呼叫站点上的符号类型描述符必须与该accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_AND)上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_AND)的访问模式类型相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndBitwiseAndAcquire

        public final Object getAndBitwiseAndAcquire​(Object... args)
        原子地将变量的值设置为变量当前值与mask的内存语义的mask之间的按位AND的结果，并返回变量的先前值，如使用内存语义getAcquire(java.lang.Object...)访问的。

        如果变量类型是非整数boolean类型，则执行逻辑与而不是按位AND。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseAndAcquire呼叫站点的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_AND_ACQUIRE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果该VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        set(Object...) ， getAcquire(Object...)

      • getAndBitwiseAndRelease

        public final Object getAndBitwiseAndRelease​(Object... args)
        原子地将变量的值设置为变量当前值与mask的存储器语义的mask之间的按位AND的结果，并返回变量的先前值，内存语义为get(java.lang.Object...) 。

        如果变量类型是非整数boolean类型，则执行逻辑“与”而不是按位“和”。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseAndRelease的呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_AND_RELEASE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setRelease(Object...) ， get(Object...)

      • getAndBitwiseXor

        public final Object getAndBitwiseXor​(Object... args)
        将变量的值原子地设置为变量当前值与mask的存储器语义的mask之间的按位XOR的结果，并返回变量的上一个值，如getVolatile(java.lang.Object...)的存储器语义访问。

        如果变量类型是非整数boolean类型，则执行逻辑异或，而不是按位XOR。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseXor呼叫站点上的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_XOR)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setVolatile(Object...) ， getVolatile(Object...)

      • getAndBitwiseXorAcquire

        public final Object getAndBitwiseXorAcquire​(Object... args)
        将变量的值原子设置为变量当前值与mask的内存语义的mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为getAcquire(java.lang.Object...) 。

        如果变量类型是非整数boolean类型，则执行逻辑异或，而不是按位XOR。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        getAndBitwiseXorAcquire呼叫站点上的符号类型描述符必须与该accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_XOR_ACQUIRE)上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_XOR_ACQUIRE)的结果相匹配。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        set(Object...) ， getAcquire(Object...)

      • getAndBitwiseXorRelease

        public final Object getAndBitwiseXorRelease​(Object... args)
        将变量的值原子设置为变量当前值与mask的存储器语义的mask之间的按位XOR的结果，并返回变量的上一个值，内存语义为get(java.lang.Object...) 。

        如果变量类型是非整数boolean类型，则执行逻辑异或，而不是按位XOR。

        方法签名的格式为(CT1 ct1, ..., CTn ctn, T mask)T 。

        呼叫站点getAndBitwiseXorRelease的符号类型描述符必须与访问模式类型匹配，该类型是在此VarHandle上调用accessModeType(VarHandle.AccessMode.GET_AND_BITWISE_XOR_RELEASE)的结果。

        参数
        args - 使用varargs静态表示的表单 (CT1 ct1, ..., CTn ctn, T mask)的签名 - 多态参数列表。
        结果
        该变量的前一个值的签名 - 多态结果，使用 Object静态表示。
        异常
        UnsupportedOperationException - 如果此VarHandle不支持访问模式。
        WrongMethodTypeException - 如果访问模式类型与调用者的符号类型描述符不匹配。
        ClassCastException - 如果访问模式类型与调用者的符号类型描述符匹配，但参考转换失败。
        另请参见：
        setRelease(Object...) ， get(Object...)

      • varType

        public final Class<?> varType​()
        返回此VarHandle引用的变量的变量类型。
        结果
        该VarHandle引用的变量变量类型

      • coordinateTypes

        public final List<Class<?>> coordinateTypes​()
        返回此VarHandle的坐标类型。
        结果
        这个VarHandle的坐标类型。 返回的列表是不可修改的

      • accessModeType

        public final MethodType accessModeType​(VarHandle.AccessMode accessMode)
        获取此VarHandle和给定访问模式的访问模式类型。

        访问模式类型的参数类型将包含一个前缀，该前缀是该VarHandle的坐标类型，后面是由访问模式方法定义的其他类型。 访问模式类型的返回类型由访问模式方法的返回类型定义。

        参数
        accessMode - 访问模式，对应于同名的签名 - 多态方法
        结果
        给定访问模式的访问模式类型

      • isAccessModeSupported

        public final boolean isAccessModeSupported​(VarHandle.AccessMode accessMode)
        如果支持给定的访问模式，则返回true ，否则为false 。

        给定访问模式返回一个false值表示在调用相应的访问模式方法时抛出一个UnsupportedOperationException 。

        参数
        accessMode - 访问模式，对应于同名的签名 - 多态方法
        结果
        true如果给定的访问模式被支持，否则为 false 。

      • toMethodHandle

        public final MethodHandle toMethodHandle​(VarHandle.AccessMode accessMode)
        获取绑定到此VarHandle和给定访问模式的方法句柄。
        API Note:
        此方法对于VarHandle vh和访问模式{access-mode} ，返回一个等同于以下代码中方法句柄bmh方法句柄（尽管可能会更有效）：
           MethodHandle mh = MethodHandles.varHandleExactInvoker( vh.accessModeType(VarHandle.AccessMode.{access-mode})); MethodHandle bmh = mh.bindTo(vh);
        参数
        accessMode - 访问模式，对应于同名的签名 - 多态方法
        结果
        绑定到此VarHandle的方法句柄和给定的访问模式

      • fullFence

        public static void fullFence​()
        确保围墙之前的装载和商店不会在围栏后面加载和存储重新排序。
        API Note:
        忽略C和C ++的许多语义差异，该方法具有与 atomic_thread_fence(memory_order_seq_cst)兼容的内存排序效果

      • acquireFence

        public static void acquireFence​()
        确保栅栏之前的载荷在栅栏后不会被装载和存储重新排序。
        API Note:
        忽略C和C ++的许多语义差异，该方法具有与 atomic_thread_fence(memory_order_acquire)兼容的内存排序效果

      • releaseFence

        public static void releaseFence​()
        确保栅栏之前的货物和商店在栅栏后不会与商店重新排序。
        API Note:
        忽略C和C ++的许多语义差异，该方法具有与 atomic_thread_fence(memory_order_release)兼容的存储器排序效果

      • loadLoadFence

        public static void loadLoadFence​()
        确保栅栏之前的载荷在栅栏后不会被重新排列。

      • storeStoreFence

        public static void storeStoreFence​()
        确保栅栏之前的商店在栅栏后不会与商店重新排列。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


VarHandle.AccessMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang.invoke

Enum VarHandle.AccessMode

  • java.lang.Object
    • java.lang.Enum<VarHandle.AccessMode>
      • java.lang.invoke.VarHandle.AccessMode
  • All Implemented Interfaces:
    Serializable ， Comparable<VarHandle.AccessMode>
    Enclosing class:
    VarHandle

    public static enum VarHandle.AccessMode
extends Enum<VarHandle.AccessMode>
    指定如何访问由VarHandle引用的变量的访问模式集。

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      COMPARE_AND_EXCHANGE
      访问模式的访问由相应的方法 VarHandle.compareAndExchange指定
      COMPARE_AND_EXCHANGE_ACQUIRE
      访问模式的访问由相应的方法 VarHandle.compareAndExchangeAcquire指定
      COMPARE_AND_EXCHANGE_RELEASE
      访问模式，其访问由相应的方法 VarHandle.compareAndExchangeRelease指定
      COMPARE_AND_SET
      访问模式，其访问由相应的方法 VarHandle.compareAndSet指定
      GET
      访问模式的访问由相应的方法 VarHandle.get指定
      GET_ACQUIRE
      访问模式，其访问由相应的方法 VarHandle.getAcquire指定
      GET_AND_ADD
      访问模式的访问由相应的方法 VarHandle.getAndAdd指定
      GET_AND_ADD_ACQUIRE
      访问模式的访问由相应的方法 VarHandle.getAndAddAcquire指定
      GET_AND_ADD_RELEASE
      访问模式的访问由相应的方法 VarHandle.getAndAddRelease指定
      GET_AND_BITWISE_AND
      访问模式，其访问由相应的方法 VarHandle.getAndBitwiseAnd指定
      GET_AND_BITWISE_AND_ACQUIRE
      访问模式，其访问由相应的方法 VarHandle.getAndBitwiseAndAcquire指定
      GET_AND_BITWISE_AND_RELEASE
      访问模式的访问由相应的方法 VarHandle.getAndBitwiseAndRelease指定
      GET_AND_BITWISE_OR
      访问模式的访问由相应的方法 VarHandle.getAndBitwiseOr指定
      GET_AND_BITWISE_OR_ACQUIRE
      访问模式的访问由相应的方法 VarHandle.getAndBitwiseOrAcquire指定
      GET_AND_BITWISE_OR_RELEASE
      访问模式的访问由相应的方法 VarHandle.getAndBitwiseOrRelease指定
      GET_AND_BITWISE_XOR
      访问模式的访问由相应的方法 VarHandle.getAndBitwiseXor指定
      GET_AND_BITWISE_XOR_ACQUIRE
      访问模式的访问由相应的方法 VarHandle.getAndBitwiseXorAcquire指定
      GET_AND_BITWISE_XOR_RELEASE
      访问模式的访问由相应的方法 VarHandle.getAndBitwiseXorRelease指定
      GET_AND_SET
      访问模式的访问由相应的方法 VarHandle.getAndSet指定
      GET_AND_SET_ACQUIRE
      访问模式的访问由相应的方法 VarHandle.getAndSetAcquire指定
      GET_AND_SET_RELEASE
      访问模式的访问由相应的方法 VarHandle.getAndSetRelease指定
      GET_OPAQUE
      访问模式的访问由相应的方法 VarHandle.getOpaque指定
      GET_VOLATILE
      访问模式的访问由相应的方法 VarHandle.getVolatile指定
      SET
      访问模式的访问由相应的方法 VarHandle.set指定
      SET_OPAQUE
      访问模式的访问由相应的方法 VarHandle.setOpaque指定
      SET_RELEASE
      访问模式的访问由相应的方法 VarHandle.setRelease指定
      SET_VOLATILE
      访问模式的访问由相应的方法 VarHandle.setVolatile指定
      WEAK_COMPARE_AND_SET
      访问模式的访问由相应的方法 VarHandle.weakCompareAndSet指定
      WEAK_COMPARE_AND_SET_ACQUIRE
      访问模式的访问由相应的方法 VarHandle.weakCompareAndSetAcquire指定
      WEAK_COMPARE_AND_SET_PLAIN
      访问模式的访问由相应的方法 VarHandle.weakCompareAndSetPlain指定
      WEAK_COMPARE_AND_SET_RELEASE
      访问模式的访问由相应的方法 VarHandle.weakCompareAndSetRelease指定

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String methodName​()
      返回与该 AccessMode值相关联的 VarHandle签名 - 多态方法名称。
      static VarHandle.AccessMode valueFromMethodName​(String methodName)
      返回与指定的 VarHandle签名 - 多态方法名称相关联的 AccessMode值。
      static VarHandle.AccessMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VarHandle.AccessMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • GET

        public static final VarHandle.AccessMode GET
        访问模式的访问由相应的方法 VarHandle.get指定

      • SET

        public static final VarHandle.AccessMode SET
        访问模式的访问由相应的方法 VarHandle.set指定

      • GET_VOLATILE

        public static final VarHandle.AccessMode GET_VOLATILE
        访问模式的访问由相应的方法 VarHandle.getVolatile指定

      • SET_VOLATILE

        public static final VarHandle.AccessMode SET_VOLATILE
        访问模式的访问由相应的方法 VarHandle.setVolatile指定

      • GET_ACQUIRE

        public static final VarHandle.AccessMode GET_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.getAcquire指定

      • SET_RELEASE

        public static final VarHandle.AccessMode SET_RELEASE
        访问模式，其访问由相应的方法 VarHandle.setRelease指定

      • GET_OPAQUE

        public static final VarHandle.AccessMode GET_OPAQUE
        访问模式的访问由相应的方法 VarHandle.getOpaque指定

      • SET_OPAQUE

        public static final VarHandle.AccessMode SET_OPAQUE
        访问模式的访问由相应的方法 VarHandle.setOpaque指定

      • COMPARE_AND_SET

        public static final VarHandle.AccessMode COMPARE_AND_SET
        访问模式的访问由相应的方法 VarHandle.compareAndSet指定

      • COMPARE_AND_EXCHANGE

        public static final VarHandle.AccessMode COMPARE_AND_EXCHANGE
        访问模式的访问由相应的方法 VarHandle.compareAndExchange指定

      • COMPARE_AND_EXCHANGE_ACQUIRE

        public static final VarHandle.AccessMode COMPARE_AND_EXCHANGE_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.compareAndExchangeAcquire指定

      • COMPARE_AND_EXCHANGE_RELEASE

        public static final VarHandle.AccessMode COMPARE_AND_EXCHANGE_RELEASE
        访问模式的访问由相应的方法 VarHandle.compareAndExchangeRelease指定

      • WEAK_COMPARE_AND_SET_PLAIN

        public static final VarHandle.AccessMode WEAK_COMPARE_AND_SET_PLAIN
        访问模式的访问由相应的方法 VarHandle.weakCompareAndSetPlain指定

      • WEAK_COMPARE_AND_SET

        public static final VarHandle.AccessMode WEAK_COMPARE_AND_SET
        访问模式的访问由相应的方法 VarHandle.weakCompareAndSet指定

      • WEAK_COMPARE_AND_SET_ACQUIRE

        public static final VarHandle.AccessMode WEAK_COMPARE_AND_SET_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.weakCompareAndSetAcquire指定

      • WEAK_COMPARE_AND_SET_RELEASE

        public static final VarHandle.AccessMode WEAK_COMPARE_AND_SET_RELEASE
        访问模式的访问由相应的方法 VarHandle.weakCompareAndSetRelease指定

      • GET_AND_SET

        public static final VarHandle.AccessMode GET_AND_SET
        访问模式的访问由相应的方法 VarHandle.getAndSet指定

      • GET_AND_SET_ACQUIRE

        public static final VarHandle.AccessMode GET_AND_SET_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.getAndSetAcquire指定

      • GET_AND_SET_RELEASE

        public static final VarHandle.AccessMode GET_AND_SET_RELEASE
        访问模式的访问由相应的方法 VarHandle.getAndSetRelease指定

      • GET_AND_ADD

        public static final VarHandle.AccessMode GET_AND_ADD
        访问模式的访问由相应的方法 VarHandle.getAndAdd指定

      • GET_AND_ADD_ACQUIRE

        public static final VarHandle.AccessMode GET_AND_ADD_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.getAndAddAcquire指定

      • GET_AND_ADD_RELEASE

        public static final VarHandle.AccessMode GET_AND_ADD_RELEASE
        访问模式的访问由相应的方法 VarHandle.getAndAddRelease指定

      • GET_AND_BITWISE_OR

        public static final VarHandle.AccessMode GET_AND_BITWISE_OR
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseOr指定

      • GET_AND_BITWISE_OR_RELEASE

        public static final VarHandle.AccessMode GET_AND_BITWISE_OR_RELEASE
        访问模式，其访问由相应的方法 VarHandle.getAndBitwiseOrRelease指定

      • GET_AND_BITWISE_OR_ACQUIRE

        public static final VarHandle.AccessMode GET_AND_BITWISE_OR_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseOrAcquire指定

      • GET_AND_BITWISE_AND

        public static final VarHandle.AccessMode GET_AND_BITWISE_AND
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseAnd指定

      • GET_AND_BITWISE_AND_RELEASE

        public static final VarHandle.AccessMode GET_AND_BITWISE_AND_RELEASE
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseAndRelease指定

      • GET_AND_BITWISE_AND_ACQUIRE

        public static final VarHandle.AccessMode GET_AND_BITWISE_AND_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseAndAcquire指定

      • GET_AND_BITWISE_XOR

        public static final VarHandle.AccessMode GET_AND_BITWISE_XOR
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseXor指定

      • GET_AND_BITWISE_XOR_RELEASE

        public static final VarHandle.AccessMode GET_AND_BITWISE_XOR_RELEASE
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseXorRelease指定

      • GET_AND_BITWISE_XOR_ACQUIRE

        public static final VarHandle.AccessMode GET_AND_BITWISE_XOR_ACQUIRE
        访问模式的访问由相应的方法 VarHandle.getAndBitwiseXorAcquire指定

    • 方法详细信息

      • values

        public static VarHandle.AccessMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (VarHandle.AccessMode c : VarHandle.AccessMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static VarHandle.AccessMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • methodName

        public String methodName​()
        返回与此 AccessMode值相关联的 VarHandle签名 - 多态方法名称。
        结果
        签名 - 多态方法名称
        另请参见：
        valueFromMethodName(java.lang.String)

      • valueFromMethodName

        public static VarHandle.AccessMode valueFromMethodName​(String methodName)
        返回与指定的 VarHandle签名 - 多态方法名称相关联的 AccessMode值。
        参数
        methodName - 签名 - 多态方法名称
        结果
        价值 AccessMode
        异常
        IllegalArgumentException -如果没有 AccessMode与方法名（指示不对应于一个方法名相关联的值 VarHandle签名多态性方法名）。
        另请参见：
        methodName
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


VolatileCallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class VolatileCallSite

  • java.lang.Object
    • java.lang.invoke.CallSite
      • java.lang.invoke.VolatileCallSite

  • public class VolatileCallSite
extends CallSite
    A VolatileCallSite是一个CallSite，其目标像一个volatile变量。 链接到VolatileCallSite的invokedynamic指令即使在另一个线程中发生更新，也会立即查看其呼叫站点目标的更新。 螺纹之间的这种紧密耦合可能会造成性能损失。

    与MutableCallSite不同，在易失性调用站点上没有syncAll operation ，因为对易失性变量的每次写入都与读取器线程隐式同步。

    在其他方面， VolatileCallSite可与MutableCallSite互换。

    从以下版本开始：
    1.7
    另请参见：
    MutableCallSite

    • 构造方法摘要

      构造方法
      Constructor 描述
      VolatileCallSite​(MethodHandle target)
      创建一个具有对其目标的易失性绑定的调用站点。
      VolatileCallSite​(MethodType type)
      创建一个具有对其目标的易失性绑定的调用站点。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      MethodHandle dynamicInvoker​()
      生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
      MethodHandle getTarget​()
      返回调用点，其行为类似于目标方法 volatile的领域 VolatileCallSite 。
      void setTarget​(MethodHandle newTarget)
      将此调用站点的目标方法更新为volatile变量。

      • Methods inherited from class java.lang.invoke.CallSite

        type

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • VolatileCallSite

        public VolatileCallSite​(MethodType type)
        创建一个具有对其目标的易失性绑定的调用站点。 初始目标设置为给定类型的方法句柄，如果调用该方法句柄将抛出一个IllegalStateException 。
        参数
        type - 此呼叫站点将具有的方法类型
        异常
        NullPointerException - 如果提议的类型为空

      • VolatileCallSite

        public VolatileCallSite​(MethodHandle target)
        创建一个具有对其目标的易失性绑定的调用站点。 目标设置为给定的值。
        参数
        target - 将作为呼叫站点初始目标的方法句柄
        异常
        NullPointerException - 如果提议的目标为null

    • 方法详细信息

      • getTarget

        public final MethodHandle getTarget​()
        返回调用点，其行为类似于目标方法volatile的领域VolatileCallSite 。

        getTarget与内存的交互与volatile字段的读取相同。

        特别地，当前线程需要从内存中发出目标的新鲜读取，并且不能看不到另一个线程对目标的最新更新。

        Specified by:
        getTarget在 CallSite
        结果
        此呼叫站点的链接状态，可随时间变化的方法句柄
        另请参见：
        setTarget(java.lang.invoke.MethodHandle)

      • setTarget

        public void setTarget​(MethodHandle newTarget)
        将此调用站点的目标方法更新为volatile变量。 新目标的类型必须符合旧目标的类型。

        与存储器的交互与对易失性字段的写入相同。 特别地，任何线程在下一次调用getTarget时都可以看到更新的目标。

        Specified by:
        setTarget在 CallSite
        参数
        newTarget - 新的目标
        异常
        NullPointerException - 如果建议的新目标为null
        WrongMethodTypeException - 如果提出的新目标具有与先前目标不同的方法类型
        另请参见：
        getTarget()

      • dynamicInvoker

        public final MethodHandle dynamicInvoker​()
        生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。

        此方法等同于以下代码：

 MethodHandle getTarget, invoker, result;
 getTarget = MethodHandles.publicLookup().bind(this, "getTarget", MethodType.methodType(MethodHandle.class));
 invoker = MethodHandles.exactInvoker(this.type());
 result = MethodHandles.foldArguments(invoker, getTarget)
        Specified by:
        dynamicInvoker在 CallSite
        结果
        总是调用此调用站点的当前目标的方法句柄
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


WrongMethodTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.invoke

Class WrongMethodTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.invoke.WrongMethodTypeException
  • All Implemented Interfaces:
    Serializable

    public class WrongMethodTypeException
extends RuntimeException
    抛出以表示代码尝试通过错误的方法类型调用方法句柄。 与正常Java方法调用的字节码表示一样，方法句柄调用强烈类型与与调用站点相关联的特定类型描述符。

    当组合两个方法句柄时，也可能会抛出此异常，并且系统检测到它们的类型无法正确匹配。 这相当于在方法句柄构建时间对类型不匹配的早期评估，而不是调用不匹配的方法句柄时。

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      WrongMethodTypeException​()
      构造一个 WrongMethodTypeException ，没有详细信息。
      WrongMethodTypeException​(String s)
      构造具有指定详细消息的 WrongMethodTypeException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • WrongMethodTypeException

        public WrongMethodTypeException​()
        构造一个 WrongMethodTypeException ，没有详细信息。

      • WrongMethodTypeException

        public WrongMethodTypeException​(String s)
        构造具有指定详细消息的 WrongMethodTypeException 。
        参数
        s - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.CallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.CallSite

  • Packages that use CallSite
    软件包 描述
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    jdk.dynalink.support
    包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。

    • Uses of CallSite in java.lang.invoke

      Subclasses of CallSite in java.lang.invoke
      Modifier and Type Class 描述
      class  ConstantCallSite
      A ConstantCallSite是一个CallSite，其目标是永久性的，永远不能更改。
      class  MutableCallSite
      A MutableCallSite是一个CallSite，其目标变量的行为像一个普通字段。
      class  VolatileCallSite
      A VolatileCallSite是一个CallSite，其目标像一个volatile变量。
      Methods in java.lang.invoke that return CallSite
      Modifier and Type 方法 描述
      static CallSite LambdaMetafactory.altMetafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)
      通过委托给所提供的MethodHandle ，在适当的类型适配和参数的部分评估之后，便于创建简单的“功能对象”，实现一个或多个接口。
      static CallSite StringConcatFactory.makeConcat​(MethodHandles.Lookup lookup, String name, MethodType concatType)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite StringConcatFactory.makeConcatWithConstants​(MethodHandles.Lookup lookup, String name, MethodType concatType, String recipe, Object... constants)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite LambdaMetafactory.metafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType)
      通过委托给所提供的MethodHandle ，在适当的类型适配和参数的部分评估后，便于创建简单的“功能对象”，实现一个或多个接口。

    • Uses of CallSite in jdk.dynalink.support

      Subclasses of CallSite in jdk.dynalink.support
      Modifier and Type Class 描述
      class  AbstractRelinkableCallSite
      一个基本实现的RelinkableCallSite作为一个MutableCallSite 。
      class  ChainedCallSite
      实现多态内联缓存策略的可重新链接的调用站点。
      class  SimpleRelinkableCallSite
      一个可重新链接的调用站点，实现单态内联缓存策略，只能在任何给定时间链接到单个GuardedInvocation 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.ConstantCallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.ConstantCallSite

No usage of java.lang.invoke.ConstantCallSite
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.LambdaConversionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.LambdaConversionException

  • Packages that use LambdaConversionException
    软件包 描述
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。

    • Uses of LambdaConversionException in java.lang.invoke

      Methods in java.lang.invoke that throw LambdaConversionException
      Modifier and Type 方法 描述
      static CallSite LambdaMetafactory.altMetafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)
      通过委派给所提供的MethodHandle ，在适当的类型适配和参数的部分评估之后，便于创建简单的“功能对象”，实现一个或多个接口。
      static CallSite LambdaMetafactory.metafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType)
      通过委派给所提供的MethodHandle ，在适当的类型适应和参数的部分评估之后，便于创建实现一个或多个接口的简单“功能对象”。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.LambdaMetafactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.LambdaMetafactory

No usage of java.lang.invoke.LambdaMetafactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.MethodHandle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.MethodHandle

  • Packages that use MethodHandle
    软件包 描述
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.beans
    包含普通Java对象的链接器。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.dynalink.support
    包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。

    • Uses of MethodHandle in java.lang.invoke

      Methods in java.lang.invoke that return MethodHandle
      Modifier and Type 方法 描述
      static MethodHandle MethodHandles.arrayConstructor​(Class<?> arrayClass)
      生成构造所需类型的数组的方法句柄。
      static MethodHandle MethodHandles.arrayElementGetter​(Class<?> arrayClass)
      产生方法句柄，提供对数组元素的读取访问。
      static MethodHandle MethodHandles.arrayElementSetter​(Class<?> arrayClass)
      生成方法句柄，为数组的元素提供写访问权限。
      static MethodHandle MethodHandles.arrayLength​(Class<?> arrayClass)
      产生返回数组长度的方法句柄。
      MethodHandle MethodHandle.asCollector​(int collectArgPos, Class<?> arrayType, int arrayLength)
      创建一个 数组收集方法句柄，它接收从给定位置开始的给定数量的位置参数，并将它们收集到数组参数中。
      MethodHandle MethodHandle.asCollector​(Class<?> arrayType, int arrayLength)
      使 数组收集方法句柄接受给定数量的尾随位置参数并将其收集到数组参数中。
      MethodHandle MethodHandle.asFixedArity​()
      创建一个 固定的arity方法句柄，否则相当于当前的方法句柄。
      MethodHandle MethodHandle.asSpreader​(int spreadArgPos, Class<?> arrayType, int arrayLength)
      创建一个 数组扩展方法句柄，它可以在给定的位置接受一个数组参数，并将其元素作为位置参数扩展代替数组。
      MethodHandle MethodHandle.asSpreader​(Class<?> arrayType, int arrayLength)
      创建一个 数组扩展方法句柄，它接受一个尾随数组参数，并将其元素作为位置参数传播。
      MethodHandle MethodHandle.asType​(MethodType newType)
      生成一个适配器方法句柄，该句柄将当前方法句柄的类型适配为新类型。
      MethodHandle MethodHandle.asVarargsCollector​(Class<?> arrayType)
      创建一个 可变的arity适配器，它可以接受任意数量的尾随位置参数并将其收集到数组参数中。
      MethodHandle MethodHandles.Lookup.bind​(Object receiver, String name, MethodType type)
      为非静态方法生成早期绑定的方法句柄。
      MethodHandle MethodHandle.bindTo​(Object x)
      将值 x绑定到方法句柄的第一个参数，而不调用它。
      static MethodHandle MethodHandles.catchException​(MethodHandle target, Class<? extends Throwable> exType, MethodHandle handler)
      通过在异常处理程序中运行它来创建适应目标方法句柄的方法句柄。
      static MethodHandle MethodHandles.collectArguments​(MethodHandle target, int pos, MethodHandle filter)
      通过使用过滤器（另一种方法句柄）预处理其参数的子序列来适应目标方法句柄。
      static MethodHandle MethodHandles.constant​(Class<?> type, Object value)
      生成请求的返回类型的方法句柄，每次调用时返回给定的常量值。
      static MethodHandle MethodHandles.countedLoop​(MethodHandle iterations, MethodHandle init, MethodHandle body)
      构造一个运行给定次数迭代的循环。
      static MethodHandle MethodHandles.countedLoop​(MethodHandle start, MethodHandle end, MethodHandle init, MethodHandle body)
      构造一个计数一系列数字的循环。
      static MethodHandle MethodHandles.doWhileLoop​(MethodHandle init, MethodHandle body, MethodHandle pred)
      从初始化器，身体和谓词构造一个 do-while循环。
      static MethodHandle MethodHandles.dropArguments​(MethodHandle target, int pos, Class<?>... valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle MethodHandles.dropArguments​(MethodHandle target, int pos, List<Class<?>> valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle MethodHandles.dropArgumentsToMatch​(MethodHandle target, int skip, List<Class<?>> newTypes, int pos)
      适应目标方法句柄以匹配给定的参数类型列表。
      abstract MethodHandle CallSite.dynamicInvoker​()
      生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
      MethodHandle ConstantCallSite.dynamicInvoker​()
      返回此呼叫站点的永久目标。
      MethodHandle MutableCallSite.dynamicInvoker​()
      生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
      MethodHandle VolatileCallSite.dynamicInvoker​()
      生成等效于已经链接到此调用站点的invokedynamic指令的方法句柄。
      static MethodHandle MethodHandles.empty​(MethodType type)
      产生一个忽略任何参数的请求类型的方法句柄，不执行任何操作，并根据返回类型返回合适的默认值。
      static MethodHandle MethodHandles.exactInvoker​(MethodType type)
      生成一个特殊的 调用方法句柄 ，可以用于调用给定类型的任何方法句柄，如同通过 invokeExact一样 。
      static MethodHandle MethodHandles.explicitCastArguments​(MethodHandle target, MethodType newType)
      生成方法句柄，通过成对参数和返回类型转换将给定方法句柄的类型适配为新类型。
      static MethodHandle MethodHandles.filterArguments​(MethodHandle target, int pos, MethodHandle... filters)
      通过预处理其一个或多个参数来适应目标方法句柄，每个参数具有自己的一元过滤器函数，然后使用每个预处理的参数替换为相应过滤器函数的结果来调用目标。
      static MethodHandle MethodHandles.filterReturnValue​(MethodHandle target, MethodHandle filter)
      通过使用过滤器（另一种方法句柄）对其返回值（如果有的话）进行后处理来适应目标方法句柄。
      MethodHandle MethodHandles.Lookup.findConstructor​(Class<?> refc, MethodType type)
      使用指定类型的构造函数生成创建对象并初始化它的方法句柄。
      MethodHandle MethodHandles.Lookup.findGetter​(Class<?> refc, String name, Class<?> type)
      产生方法句柄，给非静态字段的读访问权限。
      MethodHandle MethodHandles.Lookup.findSetter​(Class<?> refc, String name, Class<?> type)
      产生一个给非静态字段写入访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findSpecial​(Class<?> refc, String name, MethodType type, Class<?> specialCaller)
      为虚拟方法生成早期绑定的方法句柄。
      MethodHandle MethodHandles.Lookup.findStatic​(Class<?> refc, String name, MethodType type)
      为静态方法生成方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticGetter​(Class<?> refc, String name, Class<?> type)
      产生一个给静态字段读取访问权限的方法句柄。
      MethodHandle MethodHandles.Lookup.findStaticSetter​(Class<?> refc, String name, Class<?> type)
      生成方法句柄，给静态字段写权限。
      MethodHandle MethodHandles.Lookup.findVirtual​(Class<?> refc, String name, MethodType type)
      为虚拟方法生成方法句柄。
      static MethodHandle MethodHandles.foldArguments​(MethodHandle target, int pos, MethodHandle combiner)
      通过预先处理一些参数，从给定的位置开始，然后调用具有预处理结果的目标，将其插入原来的参数序列之前，使其适用于目标方法句柄。
      static MethodHandle MethodHandles.foldArguments​(MethodHandle target, MethodHandle combiner)
      通过预处理一些参数来适应目标方法句柄，然后调用具有预处理结果的目标，插入到原始的参数序列中。
      abstract MethodHandle CallSite.getTarget​()
      根据此调用站点的特定类定义的行为，返回调用站点的目标方法。
      MethodHandle ConstantCallSite.getTarget​()
      返回调用点，其行为类似于目标方法 final的领域 ConstantCallSite 。
      MethodHandle MutableCallSite.getTarget​()
      返回调用站点的目标方法，其行为类似于 MutableCallSite的正常字段。
      MethodHandle VolatileCallSite.getTarget​()
      返回调用点，其行为类似于目标方法 volatile的领域 VolatileCallSite 。
      static MethodHandle MethodHandles.guardWithTest​(MethodHandle test, MethodHandle target, MethodHandle fallback)
      使用方法句柄来调整目标方法句柄，通过用测试保护它，一个布尔值方法句柄。
      MethodHandle SwitchPoint.guardWithTest​(MethodHandle target, MethodHandle fallback)
      返回一个方法句柄，它始终将它们委托给目标或后备。
      static MethodHandle MethodHandles.identity​(Class<?> type)
      生成方法句柄，在调用时返回其唯一参数。
      static MethodHandle MethodHandles.insertArguments​(MethodHandle target, int pos, Object... values)
      在方法句柄的调用之前提供一个具有一个或多个 绑定参数的目标方法句柄。
      static MethodHandle MethodHandles.invoker​(MethodType type)
      产生一个特殊的 调用方法句柄 ，可以用来调用与给定类型兼容的任何方法句柄，如同 invoke一样 。
      static MethodHandle MethodHandles.iteratedLoop​(MethodHandle iterator, MethodHandle init, MethodHandle body)
      构造一个范围超过 Iterator<T>生成的值的 Iterator<T> 。
      static MethodHandle MethodHandles.loop​(MethodHandle[]... clauses)
      构造一个表示循环的方法句柄，该循环具有在每次迭代时更新和检查的多个循环变量。
      static MethodHandle MethodHandles.permuteArguments​(MethodHandle target, MethodType newType, int... reorder)
      生成方法句柄，通过重新排序参数，将方法句柄调整到新类型的调用顺序。
      static MethodHandle MethodHandles.spreadInvoker​(MethodType type, int leadingArgCount)
      产生一个方法句柄，它将调用给定的 type任何方法句柄，给定数量的尾随参数由单个尾随的 Object[]数组替换。
      static MethodHandle MethodHandles.throwException​(Class<?> returnType, Class<? extends Throwable> exType)
      产生一个方法句柄，它将抛出给定的异常 exType 。
      MethodHandle VarHandle.toMethodHandle​(VarHandle.AccessMode accessMode)
      获取绑定到此VarHandle和给定访问模式的方法句柄。
      static MethodHandle MethodHandles.tryFinally​(MethodHandle target, MethodHandle cleanup)
      创建一个方法句柄，通过将其包装在一个 try-finally块中来适应 target方法句柄。
      MethodHandle MethodHandles.Lookup.unreflect​(方法 m)
      做一个 direct method handle到 m ，如果查找类有权限。
      MethodHandle MethodHandles.Lookup.unreflectConstructor​(Constructor<?> c)
      为反射的构造函数生成方法句柄。
      MethodHandle MethodHandles.Lookup.unreflectGetter​(Field f)
      产生方法句柄，给予反映字段的读访问权限。
      MethodHandle MethodHandles.Lookup.unreflectSetter​(Field f)
      产生一个方法句柄，给一个反射的字段写权限。
      MethodHandle MethodHandles.Lookup.unreflectSpecial​(方法 m, Class<?> specialCaller)
      为反映的方法生成方法句柄。
      static MethodHandle MethodHandles.varHandleExactInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
      static MethodHandle MethodHandles.varHandleInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
      static MethodHandle MethodHandles.whileLoop​(MethodHandle init, MethodHandle pred, MethodHandle body)
      从初始化器，身体和谓词构造一个 while循环。
      MethodHandle MethodHandle.withVarargs​(boolean makeVarargs)
      如果布尔标志为true，则将此方法句柄改为 variable arity ，否则为 fixed arity 。
      static MethodHandle MethodHandleProxies.wrapperInstanceTarget​(Object x)
      产生或恢复目标方法句柄，其行为上等同于此包装器实例的唯一方法。
      static MethodHandle MethodHandles.zero​(Class<?> type)
      生成请求的返回类型的常量方法句柄，每次调用时返回该类型的默认值。
      Methods in java.lang.invoke with parameters of type MethodHandle
      Modifier and Type 方法 描述
      static <T> T MethodHandleProxies.asInterfaceInstance​(Class<T> intfc, MethodHandle target)
      生成给定的单一方法接口的实例，将其调用重定向到给定的方法句柄。
      static MethodHandle MethodHandles.catchException​(MethodHandle target, Class<? extends Throwable> exType, MethodHandle handler)
      通过在异常处理程序中运行它来创建适应目标方法句柄的方法句柄。
      static MethodHandle MethodHandles.collectArguments​(MethodHandle target, int pos, MethodHandle filter)
      通过使用过滤器（另一种方法句柄）预处理其参数的子序列来适应目标方法句柄。
      static MethodHandle MethodHandles.countedLoop​(MethodHandle iterations, MethodHandle init, MethodHandle body)
      构造一个运行给定次数迭代的循环。
      static MethodHandle MethodHandles.countedLoop​(MethodHandle start, MethodHandle end, MethodHandle init, MethodHandle body)
      构造一个计数一系列数字的循环。
      static MethodHandle MethodHandles.doWhileLoop​(MethodHandle init, MethodHandle body, MethodHandle pred)
      从初始化程序，正文和谓词构造一个 do-while循环。
      static MethodHandle MethodHandles.dropArguments​(MethodHandle target, int pos, Class<?>... valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle MethodHandles.dropArguments​(MethodHandle target, int pos, List<Class<?>> valueTypes)
      产生的方法处理这将调用一些其他指定的 目标方法句柄之前丢弃一些伪参数。
      static MethodHandle MethodHandles.dropArgumentsToMatch​(MethodHandle target, int skip, List<Class<?>> newTypes, int pos)
      适应目标方法句柄以匹配给定的参数类型列表。
      static MethodHandle MethodHandles.explicitCastArguments​(MethodHandle target, MethodType newType)
      生成方法句柄，通过成对参数和返回类型转换将给定方法句柄的类型适配为新类型。
      static MethodHandle MethodHandles.filterArguments​(MethodHandle target, int pos, MethodHandle... filters)
      通过预处理其一个或多个参数来适应目标方法句柄，每个参数具有自己的一元过滤器函数，然后使用每个预处理的参数替换为相应过滤器函数的结果来调用目标。
      static MethodHandle MethodHandles.filterReturnValue​(MethodHandle target, MethodHandle filter)
      通过使用过滤器（另一种方法句柄）对其返回值（如果有的话）进行后处理来适应目标方法句柄。
      static MethodHandle MethodHandles.foldArguments​(MethodHandle target, int pos, MethodHandle combiner)
      通过预先处理一些参数，从给定的位置开始，然后调用具有预处理结果的目标，将其插入原来的参数序列之前，使其适用于目标方法句柄。
      static MethodHandle MethodHandles.foldArguments​(MethodHandle target, MethodHandle combiner)
      通过预处理一些参数来适应目标方法句柄，然后调用具有预处理结果的目标，插入到原始的参数序列中。
      static MethodHandle MethodHandles.guardWithTest​(MethodHandle test, MethodHandle target, MethodHandle fallback)
      使用方法句柄来调整目标方法句柄，通过用测试保护它，一个布尔值方法句柄。
      MethodHandle SwitchPoint.guardWithTest​(MethodHandle target, MethodHandle fallback)
      返回一个方法句柄，它始终将它们委托给目标或后备。
      static MethodHandle MethodHandles.insertArguments​(MethodHandle target, int pos, Object... values)
      在方法句柄的调用之前提供一个具有一个或多个 绑定参数的目标方法句柄。
      static MethodHandle MethodHandles.iteratedLoop​(MethodHandle iterator, MethodHandle init, MethodHandle body)
      构造一个范围超过由 Iterator<T>生成的值的 Iterator<T> 。
      static MethodHandle MethodHandles.loop​(MethodHandle[]... clauses)
      构造一个表示循环的方法句柄，该循环具有在每次迭代时更新和检查的多个循环变量。
      static CallSite LambdaMetafactory.metafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType)
      有利于通过委派实现一个或多个接口所提供的简单的“函数对象”的创建MethodHandle ，经过适当的适应型和参数部分的评价。
      static MethodHandle MethodHandles.permuteArguments​(MethodHandle target, MethodType newType, int... reorder)
      生成方法句柄，通过重新排序参数，将方法句柄调整到新类型的调用顺序。
      static <T extends Member>
      T             		MethodHandles.reflectAs​(Class<T> expected, MethodHandle target)
      执行一个未经检查的“裂纹”的 direct method handle 。
      MethodHandleInfo MethodHandles.Lookup.revealDirect​(MethodHandle target)
      破解由此查找对象或类似的对象创建的一个 direct method handle 。
      abstract void CallSite.setTarget​(MethodHandle newTarget)
      根据此呼叫站点的特定类定义的行为，更新此呼叫站点的目标方法。
      void ConstantCallSite.setTarget​(MethodHandle ignore)
      总是扔一个UnsupportedOperationException 。
      void MutableCallSite.setTarget​(MethodHandle newTarget)
      将此呼叫站点的目标方法更新为常规变量。
      void VolatileCallSite.setTarget​(MethodHandle newTarget)
      将此调用站点的目标方法更新为volatile变量。
      static MethodHandle MethodHandles.tryFinally​(MethodHandle target, MethodHandle cleanup)
      创建一个方法句柄，通过将其包装在一个 try-finally块中来适应 target方法句柄。
      static MethodHandle MethodHandles.whileLoop​(MethodHandle init, MethodHandle pred, MethodHandle body)
      从初始化器，身体和谓词构造一个 while循环。
      Constructors in java.lang.invoke with parameters of type MethodHandle
      Constructor 描述
      ConstantCallSite​(MethodHandle target)
      创建一个具有永久目标的呼叫站点。
      ConstantCallSite​(MethodType targetType, MethodHandle createTargetHook)
      创建具有永久目标的呼叫站点，可能绑定到呼叫站点本身。
      MutableCallSite​(MethodHandle target)
      创建一个具有初始目标方法句柄的调用站点对象。
      VolatileCallSite​(MethodHandle target)
      创建一个具有对其目标的易失性绑定的调用站点。

    • Uses of MethodHandle in jdk.dynalink

      Methods in jdk.dynalink with parameters of type MethodHandle
      Modifier and Type 方法 描述
      void RelinkableCallSite.initialize​(MethodHandle relinkAndInvoke)
      由动态链接器调用，通过设置relink-and-invoke方法句柄来初始化可重新链接的调用站点。
      void RelinkableCallSite.relink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)
      每次调用站点重新链接时，动态链接器都会调用此方法（但是有关异常，请参阅 RelinkableCallSite.resetAndRelink(GuardedInvocation, MethodHandle) ）。
      void RelinkableCallSite.resetAndRelink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)
      每次调用站点重新链接时，动态链接器将调用此方法 ，并且链接器希望调用站点丢弃任何先前的链接状态（即它与 RelinkableCallSite.relink(GuardedInvocation, MethodHandle)的区别 ）。

    • Uses of MethodHandle in jdk.dynalink.beans

      Methods in jdk.dynalink.beans that return MethodHandle
      Modifier and Type 方法 描述
      MethodHandle MissingMemberHandlerFactory.createMissingMemberHandler​(LinkRequest linkRequest, LinkerServices linkerServices)
      返回适用于为特定链接请求实现丢失成员行为的方法句柄。

    • Uses of MethodHandle in jdk.dynalink.linker

      Methods in jdk.dynalink.linker that return MethodHandle
      Modifier and Type 方法 描述
      MethodHandle LinkerServices.asType​(MethodHandle handle, MethodType fromType)
      类似于asType(MethodType)，除了它也挂钩由所有可用的GuardingTypeConverterFactory实现产生的方法句柄，提供参数的语言特定类型的强制。
      MethodHandle MethodTypeConversionStrategy.asType​(MethodHandle target, MethodType newType)
      将方法句柄转换为新类型。
      default MethodHandle LinkerServices.asTypeLosslessReturn​(MethodHandle handle, MethodType fromType)
      类似于 LinkerServices.asType(MethodHandle, MethodType)，除了它特别处理返回值类型转换。
      MethodHandle GuardedInvocation.compose​(MethodHandle fallback)
      将调用，保护，切换点和异常组合到复合方法句柄中，该句柄知道当保护失败或调用无效时如何退回。
      MethodHandle GuardedInvocation.compose​(MethodHandle guardFallback, MethodHandle switchpointFallback, MethodHandle catchFallback)
      将调用，保护，切换点和异常组合到复合方法句柄中，该句柄知道当保护失败或调用无效时如何退回。
      MethodHandle LinkerServices.filterInternalObjects​(MethodHandle target)
      修改方法句柄，以便可以接收潜在的内部语言运行时对象的任何参数都将添加一个过滤器，以防止它们转义，可能通过包装它们。
      MethodHandle GuardedInvocation.getGuard​()
      返回保护方法句柄。
      MethodHandle GuardedInvocation.getInvocation​()
      返回调用方法句柄。
      MethodHandle LinkerServices.getTypeConverter​(Class<?> sourceType, Class<?> targetType)
      给定一个源和目标类型，返回一个在它们之间进行转换的方法句柄。
      MethodHandle MethodHandleTransformer.transform​(MethodHandle target)
      转换方法句柄。
      Methods in jdk.dynalink.linker with parameters of type MethodHandle
      Modifier and Type 方法 描述
      MethodHandle LinkerServices.asType​(MethodHandle handle, MethodType fromType)
      类似于asType(MethodType)，除了它也挂钩所有可用的GuardingTypeConverterFactory实现产生的方法句柄，提供了特定于语言的类型强制参数。
      MethodHandle MethodTypeConversionStrategy.asType​(MethodHandle target, MethodType newType)
      将方法句柄转换为新类型。
      default MethodHandle LinkerServices.asTypeLosslessReturn​(MethodHandle handle, MethodType fromType)
      类似于 LinkerServices.asType(MethodHandle, MethodType)，除了它特别处理返回值类型转换。
      MethodHandle GuardedInvocation.compose​(MethodHandle fallback)
      将调用，保护，切换点和异常组合到复合方法句柄中，该句柄知道当保护失败或调用无效时如何退回。
      MethodHandle GuardedInvocation.compose​(MethodHandle guardFallback, MethodHandle switchpointFallback, MethodHandle catchFallback)
      将调用，保护，切换点和异常组合到复合方法句柄中，该句柄知道当保护失败或调用无效时如何退回。
      GuardedInvocation GuardedInvocation.filterArguments​(int pos, MethodHandle... filters)
      将参数过滤器应用于调用和保护（如果存在并具有至少 pos + 1参数）与 MethodHandles.filterArguments(MethodHandle, int, MethodHandle...) 。
      MethodHandle LinkerServices.filterInternalObjects​(MethodHandle target)
      修改方法句柄，以便可以接收潜在的内部语言运行时对象的任何参数都将添加一个过滤器，以防止它们转义，可能通过包装它们。
      GuardedInvocation GuardedInvocation.replaceMethods​(MethodHandle newInvocation, MethodHandle newGuard)
      用不同的方法创建一个新的守卫调用，保留切换点。
      MethodHandle MethodHandleTransformer.transform​(MethodHandle target)
      转换方法句柄。
      Constructors in jdk.dynalink.linker with parameters of type MethodHandle
      Constructor 描述
      GuardedInvocation​(MethodHandle invocation)
      创建一个新的无条件守卫调用。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard)
      创建一个新的守卫调用，具有保护方法句柄。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint switchPoint)
      创建一个新的守卫调用，同时具有保护方法句柄和可用于使其无效的切换点。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint[] switchPoints, Class<? extends Throwable> exception)
      创建一个新的有保护的调用，具有保护方法句柄，可以使用任何数量的切换点来使其无效，以及如果在调用时抛出的异常也会使其失效。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint switchPoint, Class<? extends Throwable> exception)
      创建一个新的守卫调用，具有保护方法句柄，可用于使其无效的切换点，以及如果在调用时抛出也会使其失效的异常。
      GuardedInvocation​(MethodHandle invocation, SwitchPoint switchPoint)
      创建一个新的受保护的调用，可以由切换点无效。

    • Uses of MethodHandle in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support that return MethodHandle
      Modifier and Type | 方法 | 描述
      static MethodHandle Guards.asType​(MethodHandle test, MethodType type)
      使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
      static MethodHandle Guards.asType​(LinkerServices linkerServices, MethodHandle test, MethodType type)
      使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
      MethodHandle Lookup.findGetter​(Class<?> refc, String name, Class<?> type)
      执行一个MethodHandles.Lookup.findGetter(Class, String, Class) ，将任何遇到的IllegalAccessException转换成IllegalAccessError和NoSuchFieldException成NoSuchFieldError 。
      static MethodHandle Lookup.findOwnSpecial​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)
      给定一个查找，找到使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。
      MethodHandle Lookup.findOwnSpecial​(String name, Class<?> rtype, Class<?>... ptypes)
      查找使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。
      static MethodHandle Lookup.findOwnStatic​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)
      给定一个查找，找到使用 Lookup.findStatic(Class, String, MethodType)一个方法在该查找的类。
      MethodHandle Lookup.findOwnStatic​(String name, Class<?> rtype, Class<?>... ptypes)
      查找使用 Lookup.findStatic(Class, String, MethodType)该查找的类的方法。
      MethodHandle Lookup.findSpecial​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行一个 MethodHandles.Lookup.findSpecial(Class, String, MethodType, Class) 。
      MethodHandle Lookup.findStatic​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行一个 MethodHandles.Lookup.findStatic(Class, String, MethodType) 。
      MethodHandle Lookup.findVirtual​(Class<?> declaringClass, String name, MethodType type)
      对基础查找执行 MethodHandles.Lookup.findVirtual(Class, String, MethodType) 。
      static MethodHandle Guards.getClassGuard​(Class<?> clazz)
      创建一个保护方法，测试其唯一的参数是一个确切的特定类。
      static MethodHandle Guards.getIdentityGuard​(Object obj)
      创建一个保护方法，测试其唯一的参数与其他对象的位置相同
      static MethodHandle Guards.getInstanceOfGuard​(Class<?> clazz)
      创建一个保护方法，测试其唯一的参数作为特定类的实例。
      static MethodHandle Guards.isArray​(int pos, MethodType type)
      创建方法句柄，如果指定位置的参数是Java数组，则返回true。
      static MethodHandle Guards.isInstance​(Class<?> clazz, int pos, MethodType type)
      使用指定类型的参数创建方法句柄，但使用布尔值返回值。
      static MethodHandle Guards.isInstance​(Class<?> clazz, MethodType type)
      使用指定类型的参数创建方法句柄，但使用布尔值返回值。
      static MethodHandle Guards.isNotNull​()
      返回一个检测第一个参数是否不为空的警戒。
      static MethodHandle Guards.isNull​()
      返回一个检测第一个参数是否为空的警戒。
      static MethodHandle Guards.isOfClass​(Class<?> clazz, MethodType type)
      使用指定类型的参数创建一个保护方法句柄，但使用布尔返回值。
      MethodHandle | DefaultInternalObjectFilter.transform​(MethodHandle target)
      static MethodHandle Lookup.unreflect​(MethodHandles.Lookup lookup, 方法 m)
      执行MethodHandles.Lookup.unreflect(Method) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      MethodHandle Lookup.unreflect​(方法 m)
      执行一个MethodHandles.Lookup.unreflect(Method) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      static MethodHandle Lookup.unreflectConstructor​(MethodHandles.Lookup lookup, Constructor<?> c)
      执行MethodHandles.Lookup.unreflectConstructor(Constructor) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      MethodHandle Lookup.unreflectConstructor​(Constructor<?> c)
      执行MethodHandles.Lookup.unreflectConstructor(Constructor) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      MethodHandle Lookup.unreflectGetter​(Field f)
      执行MethodHandles.Lookup.unreflectGetter(Field) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      MethodHandle Lookup.unreflectSetter​(Field f)
      执行MethodHandles.Lookup.unreflectSetter(Field) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      Methods in jdk.dynalink.linker.support with parameters of type MethodHandle
      Modifier and Type | 方法 | 描述
      static MethodHandle Guards.asType​(MethodHandle test, MethodType type)
      使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
      static MethodHandle Guards.asType​(LinkerServices linkerServices, MethodHandle test, MethodType type)
      使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
      MethodHandle | DefaultInternalObjectFilter.transform​(MethodHandle target)
      Constructors in jdk.dynalink.linker.support with parameters of type MethodHandle
      Constructor 描述
      DefaultInternalObjectFilter​(MethodHandle parameterFilter, MethodHandle returnFilter)
      创建一个新的过滤器。

    • Uses of MethodHandle in jdk.dynalink.support

      Methods in jdk.dynalink.support with parameters of type MethodHandle
      Modifier and Type | 方法 | 描述
      void | AbstractRelinkableCallSite.initialize​(MethodHandle relinkAndInvoke)
      void | ChainedCallSite.relink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)
      void | SimpleRelinkableCallSite.relink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)
      void | ChainedCallSite.resetAndRelink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)
      void | SimpleRelinkableCallSite.resetAndRelink​(GuardedInvocation guardedInvocation, MethodHandle relinkAndInvoke)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.MethodHandleProxies (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.MethodHandleProxies

No usage of java.lang.invoke.MethodHandleProxies
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.MethodHandles (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.MethodHandles

No usage of java.lang.invoke.MethodHandles
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.MethodHandles.Lookup (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.MethodHandles.Lookup

  • Packages that use MethodHandles.Lookup
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    jdk.dynalink
    包含用于链接 invokedynamic调用站点的接口和类。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。

    • Uses of MethodHandles.Lookup in java.lang.invoke

      Methods in java.lang.invoke that return MethodHandles.Lookup
      Modifier and Type 方法 描述
      MethodHandles.Lookup MethodHandles.Lookup.dropLookupMode​(int modeToDrop)
      在同一查找类中创建一个查找，该查找对象查找成员，但查找模式已丢失给定的查找模式。
      MethodHandles.Lookup MethodHandles.Lookup.in​(Class<?> requestedLookupClass)
      在指定的新查找类上创建一个查找。
      static MethodHandles.Lookup MethodHandles.lookup​()
      返回一个具有完整功能的lookup object ，以模拟调用者的所有支持的字节码行为。
      static MethodHandles.Lookup MethodHandles.privateLookupIn​(Class<?> targetClass, MethodHandles.Lookup lookup)
      返回一个lookup object，具有完整功能，可以在目标类上模拟所有支持的字节码行为，包括private access 。
      static MethodHandles.Lookup MethodHandles.publicLookup​()
      返回最低可信度的lookup object 。
      Methods in java.lang.invoke with parameters of type MethodHandles.Lookup
      Modifier and Type 方法 描述
      static CallSite LambdaMetafactory.altMetafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)
      通过委派给所提供的MethodHandle ，在适当的类型适应和参数的部分评估后，便于创建简单的“功能对象”，实现一个或多个接口。
      static CallSite StringConcatFactory.makeConcat​(MethodHandles.Lookup lookup, String name, MethodType concatType)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite StringConcatFactory.makeConcatWithConstants​(MethodHandles.Lookup lookup, String name, MethodType concatType, String recipe, Object... constants)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite LambdaMetafactory.metafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType)
      通过委派给所提供的MethodHandle ，在适当的类型适应和参数的部分评估后，便于创建简单的“功能对象”，实现一个或多个接口。
      static MethodHandles.Lookup MethodHandles.privateLookupIn​(Class<?> targetClass, MethodHandles.Lookup lookup)
      返回一个lookup object，具有完整功能，可以在目标类上模拟所有支持的字节码行为，包括private access 。
      <T extends Member>
      T             		MethodHandleInfo.reflectAs​(Class<T> expected, MethodHandles.Lookup lookup)
      将基础成员反映为方法，构造函数或字段对象。

    • Uses of MethodHandles.Lookup in jdk.dynalink

      Methods in jdk.dynalink that return MethodHandles.Lookup
      Modifier and Type 方法 描述
      MethodHandles.Lookup SecureLookupSupplier.getLookup​()
      返回由此 SecureLookupSupplier保护的查找。
      protected MethodHandles.Lookup SecureLookupSupplier.getLookupPrivileged​()
      返回 SecureLookupSupplier.getLookup()的值，无需安全检查。
      Constructors in jdk.dynalink with parameters of type MethodHandles.Lookup
      Constructor 描述
      CallSiteDescriptor​(MethodHandles.Lookup lookup, Operation operation, MethodType methodType)
      创建一个新的呼叫站点描述符。
      SecureLookupSupplier​(MethodHandles.Lookup lookup)
      创建一个新的安全查找供应商，确保传递的查找。

    • Uses of MethodHandles.Lookup in jdk.dynalink.linker

      Method parameters in jdk.dynalink.linker with type arguments of type MethodHandles.Lookup
      Modifier and Type 方法 描述
      GuardedInvocation GuardingTypeConverterFactory.convertToType​(Class<?> sourceType, Class<?> targetType, Supplier<MethodHandles.Lookup> lookupSupplier)
      返回受保护的类型转换，它接收指定的源类型的值，并返回转换为指定的目标类型的值。

    • Uses of MethodHandles.Lookup in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support with parameters of type MethodHandles.Lookup
      Modifier and Type 方法 描述
      static MethodHandle Lookup.findOwnSpecial​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)
      给定一个查找，找到使用 Lookup.findSpecial(Class, String, MethodType)该查找的类的方法。
      static MethodHandle Lookup.findOwnStatic​(MethodHandles.Lookup lookup, String name, Class<?> rtype, Class<?>... ptypes)
      给定一个查找，找到使用 Lookup.findStatic(Class, String, MethodType)一个方法在该查找的类。
      static MethodHandle Lookup.unreflect​(MethodHandles.Lookup lookup, 方法 m)
      执行unreflect(Method) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      static MethodHandle Lookup.unreflectConstructor​(MethodHandles.Lookup lookup, Constructor<?> c)
      执行unreflectConstructor(Constructor) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      Constructors in jdk.dynalink.linker.support with parameters of type MethodHandles.Lookup
      Constructor 描述
      Lookup​(MethodHandles.Lookup lookup)
      Creates a new instance, bound to an instance of MethodHandles.Lookup.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.MethodType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.MethodType

  • Packages that use MethodType
    软件包 描述
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    jdk.dynalink
    包含用于链接 invokedynamic呼叫站点的接口和类。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。

    • Uses of MethodType in java.lang.invoke

      Methods in java.lang.invoke that return MethodType
      Modifier and Type 方法 描述
      MethodType VarHandle.accessModeType​(VarHandle.AccessMode accessMode)
      获取此VarHandle和给定访问模式的访问模式类型。
      MethodType MethodType.appendParameterTypes​(Class<?>... ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      MethodType MethodType.appendParameterTypes​(List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      MethodType MethodType.changeParameterType​(int num, Class<?> nptype)
      查找或创建具有单个不同参数类型的方法类型。
      MethodType MethodType.changeReturnType​(Class<?> nrtype)
      查找或创建具有不同返回类型的方法类型。
      MethodType MethodType.dropParameterTypes​(int start, int end)
      查找或创建一种省略某些参数类型的方法类型。
      MethodType MethodType.erase​()
      删除所有引用类型到 Object 。
      static MethodType MethodType.fromMethodDescriptorString​(String descriptor, ClassLoader loader)
      查找或创建方法类型的实例，给定其字节码描述符的拼写。
      MethodType MethodType.generic​()
      将所有类型（参考和原始）转换为 Object 。
      static MethodType MethodType.genericMethodType​(int objectArgCount)
      查找或创建一个方法类型，其组件全部为 Object 。
      static MethodType MethodType.genericMethodType​(int objectArgCount, boolean finalArray)
      查找或创建一个方法类型，其组件为 Object并具有可选的尾部 Object[]数组。
      MethodType MethodHandleInfo.getMethodType​()
      返回破解的符号引用的标称类型，表示为方法类型。
      MethodType MethodType.insertParameterTypes​(int num, Class<?>... ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      MethodType MethodType.insertParameterTypes​(int num, List<Class<?>> ptypesToInsert)
      查找或创建具有其他参数类型的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, Class<?> ptype0)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, Class<?>[] ptypes)
      查找或创建给定方法类型的实例。
      static MethodType MethodType.methodType​(Class<?> rtype, Class<?> ptype0, Class<?>... ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, MethodType ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodType MethodType.methodType​(Class<?> rtype, List<Class<?>> ptypes)
      查找或创建具有给定组件的方法类型。
      MethodType CallSite.type​()
      返回此呼叫站点目标的类型。
      MethodType MethodHandle.type​()
      报告此方法句柄的类型。
      MethodType MethodType.unwrap​()
      将所有包装类型转换为相应的原始类型。
      MethodType MethodType.wrap​()
      将所有原始类型转换为相应的包装类型。
      Methods in java.lang.invoke with parameters of type MethodType
      Modifier and Type 方法 描述
      static CallSite LambdaMetafactory.altMetafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, Object... args)
      通过委派给所提供的MethodHandle ，在适当的类型适应和参数的部分评估之后，便于创建简单的“功能对象”，实现一个或多个接口。
      MethodHandle MethodHandle.asType​(MethodType newType)
      生成一个适配器方法句柄，该句柄将当前方法句柄的类型适配为新类型。
      MethodHandle MethodHandles.Lookup.bind​(Object receiver, String name, MethodType type)
      为非静态方法生成早期绑定的方法句柄。
      static MethodHandle MethodHandles.empty​(MethodType type)
      产生一个忽略任何参数的请求类型的方法句柄，不执行任何操作，并根据返回类型返回合适的默认值。
      static MethodHandle MethodHandles.exactInvoker​(MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用来调用给定类型的任何方法句柄，如同通过 invokeExact一样 。
      static MethodHandle MethodHandles.explicitCastArguments​(MethodHandle target, MethodType newType)
      生成方法句柄，通过成对参数和返回类型转换将给定方法句柄的类型适配为新类型。
      MethodHandle MethodHandles.Lookup.findConstructor​(Class<?> refc, MethodType type)
      使用指定类型的构造函数生成创建对象并初始化它的方法句柄。
      MethodHandle MethodHandles.Lookup.findSpecial​(Class<?> refc, String name, MethodType type, Class<?> specialCaller)
      为虚拟方法生成早期绑定的方法句柄。
      MethodHandle MethodHandles.Lookup.findStatic​(Class<?> refc, String name, MethodType type)
      为静态方法生成方法句柄。
      MethodHandle MethodHandles.Lookup.findVirtual​(Class<?> refc, String name, MethodType type)
      为虚拟方法生成方法句柄。
      static MethodHandle MethodHandles.invoker​(MethodType type)
      产生一个特殊的 调用方法句柄 ，可以用于调用与给定类型兼容的任何方法句柄，如同通过 invoke一样 。
      static CallSite StringConcatFactory.makeConcat​(MethodHandles.Lookup lookup, String name, MethodType concatType)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite StringConcatFactory.makeConcatWithConstants​(MethodHandles.Lookup lookup, String name, MethodType concatType, String recipe, Object... constants)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite LambdaMetafactory.metafactory​(MethodHandles.Lookup caller, String invokedName, MethodType invokedType, MethodType samMethodType, MethodHandle implMethod, MethodType instantiatedMethodType)
      通过委派给所提供的MethodHandle ，在适当的类型适应和部分评估参数之后，便于创建简单的“功能对象”，实现一个或多个接口。
      static MethodType MethodType.methodType​(Class<?> rtype, MethodType ptypes)
      查找或创建具有给定组件的方法类型。
      static MethodHandle MethodHandles.permuteArguments​(MethodHandle target, MethodType newType, int... reorder)
      生成方法句柄，通过重新排序参数，将方法句柄调整到新类型的调用顺序。
      static MethodHandle MethodHandles.spreadInvoker​(MethodType type, int leadingArgCount)
      产生一个方法句柄，它将调用给定的 type任何方法句柄，给定数量的尾随参数被单个尾随的 Object[]数组替换。
      static String MethodHandleInfo.toString​(int kind, Class<?> defc, String name, MethodType type)
      给出 MethodHandleInfo的字符串表示，给出其符号引用的四个部分。
      static MethodHandle MethodHandles.varHandleExactInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
      static MethodHandle MethodHandles.varHandleInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
      Constructors in java.lang.invoke with parameters of type MethodType
      Constructor 描述
      ConstantCallSite​(MethodType targetType, MethodHandle createTargetHook)
      创建具有永久目标的呼叫站点，可能绑定到呼叫站点本身。
      MutableCallSite​(MethodType type)
      使用给定的方法类型创建一个空白的调用站点对象。
      VolatileCallSite​(MethodType type)
      创建一个具有对其目标的易失性绑定的调用站点。

    • Uses of MethodType in jdk.dynalink

      Methods in jdk.dynalink that return MethodType
      Modifier and Type 方法 描述
      MethodType CallSiteDescriptor.getMethodType​()
      呼叫站点的方法类型。
      Methods in jdk.dynalink with parameters of type MethodType
      Modifier and Type 方法 描述
      CallSiteDescriptor CallSiteDescriptor.changeMethodType​(MethodType newMethodType)
      查找或创建仅在其描述符的方法类型中不同的调用站点描述符。
      protected CallSiteDescriptor CallSiteDescriptor.changeMethodTypeInternal​(MethodType newMethodType)
      查找或创建仅在其描述符的方法类型中不同的调用站点描述符。
      Constructors in jdk.dynalink with parameters of type MethodType
      Constructor 描述
      CallSiteDescriptor​(MethodHandles.Lookup lookup, Operation operation, MethodType methodType)
      创建一个新的呼叫站点描述符。

    • Uses of MethodType in jdk.dynalink.linker

      Methods in jdk.dynalink.linker with parameters of type MethodType
      Modifier and Type 方法 描述
      GuardedInvocation GuardedInvocation.asType​(MethodType newType)
      改变调用的类型，仿佛 MethodHandle.asType(MethodType)施加到它的调用和它的后卫，如果它有一个（具有变更为布尔返回类型和参数计数潜在截断，挡板）。
      GuardedInvocation GuardedInvocation.asType​(LinkerServices linkerServices, MethodType newType)
      更改调用的类型，就好像应用了它的调用的 LinkerServices.asType(MethodHandle, MethodType)及其保护，如果它有一个（返回类型更改为布尔值，并且参数计数可能被截断）。
      MethodHandle LinkerServices.asType​(MethodHandle handle, MethodType fromType)
      类似于MethodHandle.asType(MethodType)，除了它也钩在由所有可用的GuardingTypeConverterFactory实现产生的方法句柄中，提供参数的语言特定类型的强制。
      MethodHandle MethodTypeConversionStrategy.asType​(MethodHandle target, MethodType newType)
      将方法句柄转换为新类型。
      default MethodHandle LinkerServices.asTypeLosslessReturn​(MethodHandle handle, MethodType fromType)
      类似于 LinkerServices.asType(MethodHandle, MethodType)，除了它特别处理返回值类型转换。
      GuardedInvocation GuardedInvocation.asTypeSafeReturn​(LinkerServices linkerServices, MethodType newType)
      改变调用的类型，仿佛 LinkerServices.asTypeLosslessReturn(MethodHandle, MethodType)施加到它的调用和 LinkerServices.asType(MethodHandle, MethodType)施加到其后卫，如果它有一个（与返回类型更改为布尔型，和参数计数潜在截断，挡板）。

    • Uses of MethodType in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support with parameters of type MethodType
      Modifier and Type 方法 描述
      static MethodHandle Guards.asType​(MethodHandle test, MethodType type)
      使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
      static MethodHandle Guards.asType​(LinkerServices linkerServices, MethodHandle test, MethodType type)
      使用一个方法句柄，用来作为一个保护，并使其适应所请求的类型，但返回一个布尔值。
      MethodHandle Lookup.findSpecial​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行 MethodHandles.Lookup.findSpecial(Class, String, MethodType, Class) 。
      MethodHandle Lookup.findStatic​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行一个 MethodHandles.Lookup.findStatic(Class, String, MethodType) 。
      MethodHandle Lookup.findVirtual​(Class<?> declaringClass, String name, MethodType type)
      对底层查找执行 MethodHandles.Lookup.findVirtual(Class, String, MethodType) 。
      static MethodHandle Guards.isArray​(int pos, MethodType type)
      创建方法句柄，如果指定位置的参数是Java数组，则返回true。
      static MethodHandle Guards.isInstance​(Class<?> clazz, int pos, MethodType type)
      使用指定类型的参数创建方法句柄，但使用布尔值返回值。
      static MethodHandle Guards.isInstance​(Class<?> clazz, MethodType type)
      使用指定类型的参数创建方法句柄，但使用布尔值返回值。
      static MethodHandle Guards.isOfClass​(Class<?> clazz, MethodType type)
      使用指定类型的参数创建一个保护方法句柄，但使用布尔返回值。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.MutableCallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.MutableCallSite

  • Packages that use MutableCallSite
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    jdk.dynalink.support
    包含通过提供某些类的基本实现以及各种实用程序使Dynalink更方便的类。

    • Uses of MutableCallSite in java.lang.invoke

      Methods in java.lang.invoke with parameters of type MutableCallSite
      Modifier and Type 方法 描述
      static void MutableCallSite.syncAll​(MutableCallSite[] sites)
      在给定数组中的每个调用站点上执行同步操作，强制所有其他线程丢弃先前从任何呼叫站点的目标加载的缓存值。

    • Uses of MutableCallSite in jdk.dynalink.support

      Subclasses of MutableCallSite in jdk.dynalink.support
      Modifier and Type Class 描述
      class  AbstractRelinkableCallSite
      基本实现了RelinkableCallSite作为MutableCallSite 。
      class  ChainedCallSite
      实现多态内联缓存策略的可重新链接的调用站点。
      class  SimpleRelinkableCallSite
      一个可重用的调用站点，实现单态内联缓存策略，只能在任何给定的时间链接到一个单独的GuardedInvocation 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.SerializedLambda (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.SerializedLambda

No usage of java.lang.invoke.SerializedLambda
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.StringConcatException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.StringConcatException

  • Packages that use StringConcatException
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

    • Uses of StringConcatException in java.lang.invoke

      Methods in java.lang.invoke that throw StringConcatException
      Modifier and Type 方法 描述
      static CallSite StringConcatFactory.makeConcat​(MethodHandles.Lookup lookup, String name, MethodType concatType)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
      static CallSite StringConcatFactory.makeConcatWithConstants​(MethodHandles.Lookup lookup, String name, MethodType concatType, String recipe, Object... constants)
      促进创建优化的字符串连接方法，可以用于有效地连接已知数量的已知类型的参数，可能在类型适配和参数的部分评估之后。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.StringConcatFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.StringConcatFactory

No usage of java.lang.invoke.StringConcatFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.SwitchPoint (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.SwitchPoint

  • Packages that use SwitchPoint
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    jdk.dynalink.linker
    包含语言运行时所需的接口和类，以实现自己的特定于语言的对象模型和类型转换。

    • Uses of SwitchPoint in java.lang.invoke

      Methods in java.lang.invoke with parameters of type SwitchPoint
      Modifier and Type 方法 描述
      static void SwitchPoint.invalidateAll​(SwitchPoint[] switchPoints)
      将所有给定的切换点设置为无效状态。

    • Uses of SwitchPoint in jdk.dynalink.linker

      Methods in jdk.dynalink.linker that return SwitchPoint
      Modifier and Type 方法 描述
      SwitchPoint[] GuardedInvocation.getSwitchPoints​()
      返回可用于使该调用句柄的链接无效的切换点。
      Methods in jdk.dynalink.linker with parameters of type SwitchPoint
      Modifier and Type 方法 描述
      GuardedInvocation GuardedInvocation.addSwitchPoint​(SwitchPoint newSwitchPoint)
      使用添加的切换点创建新的守卫调用。
      Constructors in jdk.dynalink.linker with parameters of type SwitchPoint
      Constructor 描述
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint switchPoint)
      创建一个新的守卫调用，同时具有保护方法句柄和可用于使其无效的切换点。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint[] switchPoints, Class<? extends Throwable> exception)
      创建一个新的有保护的调用，具有保护方法句柄，可以使用任何数量的切换点来使其无效，以及如果在调用时抛出的异常也会使其失效。
      GuardedInvocation​(MethodHandle invocation, MethodHandle guard, SwitchPoint switchPoint, Class<? extends Throwable> exception)
      创建一个新的守卫调用，具有保护方法句柄，可用于使其无效的切换点，以及如果在调用时抛出也会使其失效的异常。
      GuardedInvocation​(MethodHandle invocation, SwitchPoint switchPoint)
      创建一个新的受保护的调用，可以由切换点无效。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.VarHandle (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.VarHandle

  • Packages that use VarHandle
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

    • Uses of VarHandle in java.lang.invoke

      Methods in java.lang.invoke that return VarHandle
      Modifier and Type 方法 描述
      static VarHandle MethodHandles.arrayElementVarHandle​(Class<?> arrayClass)
      产生一个VarHandle，可以访问arrayClass类型的数组的 arrayClass 。
      static VarHandle MethodHandles.byteArrayViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生一个VarHandle，访问 byte[]数组的元素，看起来像是不同的基元数组类型，如 int[]或 long[] 。
      static VarHandle MethodHandles.byteBufferViewVarHandle​(Class<?> viewArrayClass, ByteOrder byteOrder)
      产生VarHandle给予访问的元素 ByteBuffer视为好像它是一个不同的基本组件类型到的元件的阵列 byte ，如 int[]或 long[] 。
      VarHandle MethodHandles.Lookup.findStaticVarHandle​(Class<?> decl, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的静态字段 decl 。
      VarHandle MethodHandles.Lookup.findVarHandle​(Class<?> recv, String name, Class<?> type)
      产生一个VarHandle，可以访问 name类中声明的类型为 type的非静态字段 recv 。
      VarHandle MethodHandles.Lookup.unreflectVarHandle​(Field f)
      Produces a VarHandle giving access to a reflected field f of type T declared in a class of type R.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.VarHandle.AccessMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.VarHandle.AccessMode

  • Packages that use VarHandle.AccessMode
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

    • Uses of VarHandle.AccessMode in java.lang.invoke

      Methods in java.lang.invoke that return VarHandle.AccessMode
      Modifier and Type 方法 描述
      static VarHandle.AccessMode VarHandle.AccessMode.valueFromMethodName​(String methodName)
      返回与指定的 VarHandle签名 - 多态方法名称相关联的 AccessMode值。
      static VarHandle.AccessMode VarHandle.AccessMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static VarHandle.AccessMode[] VarHandle.AccessMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.lang.invoke with parameters of type VarHandle.AccessMode
      Modifier and Type 方法 描述
      MethodType VarHandle.accessModeType​(VarHandle.AccessMode accessMode)
      获取此VarHandle和给定访问模式的访问模式类型。
      boolean VarHandle.isAccessModeSupported​(VarHandle.AccessMode accessMode)
      如果给定访问模式受支持，则返回 true ，否则 false 。
      MethodHandle VarHandle.toMethodHandle​(VarHandle.AccessMode accessMode)
      获取绑定到此VarHandle和给定访问模式的方法句柄。
      static MethodHandle MethodHandles.varHandleExactInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
      static MethodHandle MethodHandles.varHandleInvoker​(VarHandle.AccessMode accessMode, MethodType type)
      产生一个特殊的 调用者方法句柄 ，可以用于在任何与其给定类型相关联的访问模式类型的VarHandle上调用签名多态访问模式方法。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.VolatileCallSite (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.VolatileCallSite

No usage of java.lang.invoke.VolatileCallSite
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.invoke.WrongMethodTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.invoke.WrongMethodTypeException

No usage of java.lang.invoke.WrongMethodTypeException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.invoke.MethodHandleInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.invoke.MethodHandleInfo

  • Packages that use MethodHandleInfo
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。

    • Uses of MethodHandleInfo in java.lang.invoke

      Methods in java.lang.invoke that return MethodHandleInfo
      Modifier and Type 方法 描述
      MethodHandleInfo MethodHandles.Lookup.revealDirect​(MethodHandle target)
      破解由此查找对象或类似的对象创建的一个 direct method handle 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


BufferPoolMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface BufferPoolMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface BufferPoolMXBean
extends PlatformManagedObject
    缓冲池的管理界面，例如direct或mapped缓冲区的池。

    实现此接口的类是MXBean 。 Java虚拟机具有该接口的一个或多个实现。 该getPlatformMXBeans方法可用于获得列表BufferPoolMXBean表示用于如下缓冲器池管理接口的对象：

      List<BufferPoolMXBean> pools = ManagementFactory.getPlatformMXBeans(BufferPoolMXBean.class);

    管理界面也在平台MBeanServer注册。 所述ObjectName唯一标识内的管理接口MBeanServer采用以下形式：

      java.nio:type=BufferPool,name=pool name
    其中池名称是缓冲池的name 。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getCount​()
      返回池中缓冲区数量的估计值。
      long getMemoryUsed​()
      返回Java虚拟机正在为此缓冲池使用的内存估计值。
      String getName​()
      返回表示此缓冲池的名称。
      long getTotalCapacity​()
      返回此池中缓冲区总容量的估计值。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getName

        String getName​()
        返回表示此缓冲池的名称。
        结果
        这个缓冲池的名称。

      • getCount

        long getCount​()
        返回池中缓冲区数量的估计值。
        结果
        这个池中缓冲区数量的估计

      • getTotalCapacity

        long getTotalCapacity​()
        返回此池中缓冲区总容量的估计值。 缓冲区的容量是其包含的元素数量，此方法返回的值是池中缓冲区的总容量（以字节为单位）的估计。
        结果
        这个池中缓冲区的总容量的估计（以字节为单位）

      • getMemoryUsed

        long getMemoryUsed​()
        返回Java虚拟机正在为此缓冲池使用的内存估计值。 此方法返回的值可以从总的估计不同capacity该池中的缓冲器。 这种差异是通过对齐，内存分配器和其他实现的具体原因来解释的。
        结果
        Java虚拟机正在使用这个缓冲池的内存（以字节为单位）的估计值，如果内存使用率的估计不可用， -1L
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ClassLoadingMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface ClassLoadingMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface ClassLoadingMXBean
extends PlatformManagedObject
    Java虚拟机的类加载系统的管理界面。

    Java虚拟机具有此接口的实现类的单个实例。 实现此接口的实例是一个MXBean ，可以通过调用ManagementFactory.getClassLoadingMXBean()方法或从platform MBeanServer获取 。

    该ObjectName用于唯一地识别的MXBean为类加载系统中的内MBeanServer是：

    java.lang:type=ClassLoading
    可以通过调用PlatformManagedObject.getObjectName()方法获得。
    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      int getLoadedClassCount​()
      返回当前在Java虚拟机中加载的类的数量。
      long getTotalLoadedClassCount​()
      返回从Java虚拟机开始执行以来已加载的类的总数。
      long getUnloadedClassCount​()
      返回从Java虚拟机开始执行以来卸载的类的总数。
      boolean isVerbose​()
      测试类加载系统的详细输出是否启用。
      void setVerbose​(boolean value)
      启用或禁用类加载系统的详细输出。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getTotalLoadedClassCount

        long getTotalLoadedClassCount​()
        返回从Java虚拟机开始执行以来已加载的类的总数。
        结果
        加载的总数。

      • getLoadedClassCount

        int getLoadedClassCount​()
        返回当前在Java虚拟机中加载的类的数量。
        结果
        当前加载的类的数量。

      • getUnloadedClassCount

        long getUnloadedClassCount​()
        返回从Java虚拟机开始执行以来卸载的类的总数。
        结果
        卸载类的总数。

      • isVerbose

        boolean isVerbose​()
        测试类加载系统的详细输出是否启用。
        结果
        true如果启用类加载系统的详细输出; 否则为false 。

      • setVerbose

        void setVerbose​(boolean value)
        启用或禁用类加载系统的详细输出。 发出详细信息的详细输出信息和输出流是依赖于实现的。 通常，Java虚拟机实现在每次加载类文件时打印消息。

        此方法可以同时由多个线程调用。 此方法的每次调用都可以全局启用或禁用详细输出。

        参数
        value - true启用详细输出; false禁用。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CompilationMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface CompilationMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface CompilationMXBean
extends PlatformManagedObject
    Java虚拟机编译系统的管理界面。

    Java虚拟机具有此接口的实现类的单个实例。 实现此接口的实例是一个MXBean ，可以通过调用ManagementFactory.getCompilationMXBean()方法或从platform MBeanServer方法获得。

    用于唯一识别MBeanServer中编译系统的MXBean的ObjectName是：

    java.lang:type=Compilation
    可以通过调用PlatformManagedObject.getObjectName()方法获得。
    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getName​()
      返回即时（JIT）编译器的名称。
      long getTotalCompilationTime​()
      返回在编译中花费的大概累积的经过时间（以毫秒为单位）。
      boolean isCompilationTimeMonitoringSupported​()
      测试Java虚拟机是否支持对编译时间的监视。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getName

        String getName​()
        返回即时（JIT）编译器的名称。
        结果
        JIT编译器的名称。

      • isCompilationTimeMonitoringSupported

        boolean isCompilationTimeMonitoringSupported​()
        测试Java虚拟机是否支持对编译时间的监视。
        结果
        true如果支持编译时间的监视; 否则为false 。

      • getTotalCompilationTime

        long getTotalCompilationTime​()
        返回在编译中花费的大概累积的经过时间（以毫秒为单位）。 如果使用多个线程进行编译，则该值是每个线程在编译中花费的大概时间的总和。

        该方法可选地由平台支持。 Java虚拟机实现可能不支持编译时间监视。 可以使用isCompilationTimeMonitoringSupported()方法来确定Java虚拟机是否支持此操作。

        此值不表示Java虚拟机的性能级别，不适用于不同虚拟机实现的性能比较。 这些实现可能具有不同的定义和编译时间的不同测量。

        结果
        编译时间（毫秒）
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持此操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GarbageCollectorMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface GarbageCollectorMXBean

  • All Superinterfaces:
    MemoryManagerMXBean ， PlatformManagedObject
    All Known Subinterfaces:
    GarbageCollectorMXBean

    public interface GarbageCollectorMXBean
extends MemoryManagerMXBean
    用于Java虚拟机垃圾收集的管理界面。 垃圾收集是Java虚拟机用来查找和回收不可达对象以释放内存空间的过程。 一个垃圾收集器是一种类型的memory manager 。

    Java虚拟机可能具有此接口的实现类的一个或多个实例。 实现此接口的实例是一个MXBean ，可以通过调用能够得到ManagementFactory.getGarbageCollectorMXBeans()方法或从platform MBeanServer方法。

    用于唯一标识MBeanServer中垃圾收集器的MXBean的ObjectName是：

    java.lang:type=GarbageCollector ,name= collector's name
    可以通过调用PlatformManagedObject.getObjectName()方法获得。 平台通常包括特定于垃圾收集算法的额外的平台相关信息，用于监控。
    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， MemoryMXBean ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      long getCollectionCount​()
      返回已发生的集合总数。
      long getCollectionTime​()
      返回以毫秒为单位的大概累积收集时间。

      • Methods inherited from interface java.lang.management.MemoryManagerMXBean

        getMemoryPoolNames, getName, isValid

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getCollectionCount

        long getCollectionCount​()
        返回已发生的集合总数。 如果收集器的收集计数未定义，则此方法返回-1 。
        结果
        已发生的集合总数。

      • getCollectionTime

        long getCollectionTime​()
        返回以毫秒为单位的大概累积收集时间。 如果此收集器的收集已用时间未定义，则此方法返回-1 。

        Java虚拟机实现可以使用高分辨率定时器来测量经过的时间。 即使收集计数已经增加，如果收集时间非常短，该方法也可能返回相同的值。

        结果
        大概累积收集时间以毫秒为单位。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.lang.management (Java SE 9 & JDK 9 )

java.lang.management

Interfaces

  • BufferPoolMXBean
  • ClassLoadingMXBean
  • CompilationMXBean
  • GarbageCollectorMXBean
  • MemoryManagerMXBean
  • MemoryMXBean
  • MemoryPoolMXBean
  • OperatingSystemMXBean
  • PlatformLoggingMXBean
  • PlatformManagedObject
  • RuntimeMXBean
  • ThreadMXBean

Classes

  • LockInfo
  • ManagementFactory
  • ManagementPermission
  • MemoryNotificationInfo
  • MemoryUsage
  • MonitorInfo
  • ThreadInfo

Enums

  • MemoryType


java.lang.management (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.management

Package java.lang.management

提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。 它允许本地和远程监视和管理正在运行的Java虚拟机。

Platform MXBean

平台MXBean是符合JMX仪器规范的托管bean ，仅使用一组基本数据类型。 每个平台MXBean是一个PlatformManagedObject具有独特的name 。

ManagementFactory

ManagementFactory类是Java平台的管理工厂类。 此类提供了一组静态工厂方法来获取Java平台的MXBeans，以允许应用程序直接访问MXBean。

可以使用getPlatformMBeanServer方法访问平台MBeanServer 。 在首次调用此方法时，它将创建平台MBeanServer并注册所有平台MXBeans，包括platform MXBeans 。 每个平台MXBean都使用管理界面规范中定义的唯一名称进行注册。 这是一个单独的MBeanServer，可以在同一个Java虚拟机中运行的不同托管组件共享。

互通性

运行虚拟机的管理应用程序和平台MBeanServer可以互操作，而不需要平台MXBean接口使用的类。 在JMX连接器服务器和连接器客户端之间传输的数据类型是JMX open types ，这允许跨版本进行互操作。 当通过MBeanServer接口访问时，MXBean接口使用的数据类型将映射到打开类型。 有关详细信息，请参阅MXBean规范。

Ways to Access MXBeans

应用程序可以通过以下方式监视Java虚拟机和运行时的工具：

1.直接访问MXBean界面

  • 在运行的Java虚拟机中本地获取MXBean实例：
      RuntimeMXBean mxbean = ManagementFactory.getRuntimeMXBean();

   // Get the standard attribute "VmVendor"
   String vendor = mxbean.getVmVendor();

    或者通过调用getPlatformMXBean或getPlatformMXBeans方法：

      RuntimeMXBean mxbean = ManagementFactory.getPlatformMXBean(RuntimeMXBean.class);

   // Get the standard attribute "VmVendor"
   String vendor = mxbean.getVmVendor();
  • 构造一个将方法调用转发给给定的MBeanServer的MXBean代理实例：
      MBeanServerConnection mbs;

   // Connect to a running JVM (or itself) and get MBeanServerConnection
   // that has the JVM MBeans registered in it
   ...

   // Get a MBean proxy for RuntimeMXBean interface
   RuntimeMXBean proxy =
       ManagementFactory.getPlatformMXBean(mbs,
                                           RuntimeMXBean.class);
   // Get standard attribute "VmVendor"
   String vendor = proxy.getVmVendor();

    代理通常用于访问远程Java虚拟机中的MXBean。 创建MXBean代理的另一种方法是：

      RuntimeMXBean proxy =
       ManagementFactory.newPlatformMXBeanProxy(mbs,
                                                ManagementFactory.RUNTIME_MXBEAN_NAME,
                                                RuntimeMXBean.class);

2.通过MBeanServer间接访问MXBean接口

  • 通过platform MBeanServer访问本地的MBeanServerConnection或特定的MBeanServerConnection以远程访问MBeanServerConnection 。 MXBean的属性和操作仅使用JMX打开类型 ，其中包括OpenType中定义的基本数据类型CompositeData和TabularData 。
      MBeanServerConnection mbs;

   // Connect to a running JVM (or itself) and get MBeanServerConnection
   // that has the JVM MXBeans registered in it
   ...

   try {
       // Assuming the RuntimeMXBean has been registered in mbs
       ObjectName oname = new ObjectName(ManagementFactory.RUNTIME_MXBEAN_NAME);

       // Get standard attribute "VmVendor"
       String vendor = (String) mbs.getAttribute(oname, "VmVendor");
   } catch (....) {
       // Catch the exceptions thrown by ObjectName constructor
       // and MBeanServer.getAttribute method
       ...
   }

Platform Extension

Java虚拟机实现可以通过定义依赖于平台的接口将其平台扩展添加到管理接口，扩展标准管理接口以包括平台特定的度量和管理操作。 ManagementFactory类中的静态工厂方法将返回具有平台扩展名的ManagementFactory 。

建议使用供应商特定的前缀（如供应商名称）来命名特定于平台的属性，以避免将来的扩展到标准管理界面和平台扩展之间的属性名称冲突。 如果标准管理接口的未来扩展定义了管理界面的新属性，并且属性名称与某些特定于供应商的属性的名称相同，则访问该供应商特定属性的应用程序将必须进行修改以应对版本和兼容性问题。

以下是展示如何从平台扩展程序访问属性的示例：

1）直接访问Oracle特定的MXBean界面

   List<com.sun.management.GarbageCollectorMXBean> mxbeans =
       ManagementFactory.getPlatformMXBeans(com.sun.management.GarbageCollectorMXBean.class);

   for (com.sun.management.GarbageCollectorMXBean gc : mxbeans) {
       // Get the standard attribute "CollectionCount"
       String count = mxbean.getCollectionCount();

       // Get the platform-specific attribute "LastGcInfo"
       GcInfo gcinfo = gc.getLastGcInfo();
       ...
   }

2）通过代理通过MBeanServer访问Oracle特定的MXBean接口

   MBeanServerConnection mbs;

   // Connect to a running JVM (or itself) and get MBeanServerConnection
   // that has the JVM MXBeans registered in it
   ...

   List<com.sun.management.GarbageCollectorMXBean> mxbeans =
       ManagementFactory.getPlatformMXBeans(mbs, com.sun.management.GarbageCollectorMXBean.class);

   for (com.sun.management.GarbageCollectorMXBean gc : mxbeans) {
       // Get the standard attribute "CollectionCount"
       String count = mxbean.getCollectionCount();

       // Get the platform-specific attribute "LastGcInfo"
       GcInfo gcinfo = gc.getLastGcInfo();
       ...
   }

除非另有说明，否则将null参数传递给此程序包中任何类或接口中的构造函数或方法将导致抛出NullPointerException 。

java.lang.management API是线程安全的。

从以下版本开始：
1.5
  • 接口摘要
    接口 描述
    BufferPoolMXBean
    缓冲池的管理界面，例如direct或mapped缓冲区的池。
    ClassLoadingMXBean
    Java虚拟机的类加载系统的管理界面。
    CompilationMXBean
    Java虚拟机编译系统的管理界面。
    GarbageCollectorMXBean
    用于Java虚拟机垃圾收集的管理界面。
    MemoryManagerMXBean
    内存管理器的管理界面。
    MemoryMXBean
    Java虚拟机的内存系统的管理界面。
    MemoryPoolMXBean
    内存池的管理界面。
    OperatingSystemMXBean
    运行Java虚拟机的操作系统的管理界面。
    PlatformLoggingMXBean
    logging设施的管理界面。
    PlatformManagedObject
    平台管理对象是用于监视和管理Java平台中的组件的JMX MXBean 。
    RuntimeMXBean
    Java虚拟机的运行时系统的管理界面。
    ThreadMXBean
    Java虚拟机线程系统的管理界面。
  • 类摘要
    Class 描述
    LockInfo
    有关 锁的信息。
    ManagementFactory
    ManagementFactory类是用于获取Java平台的托管Bean的工厂类。
    ManagementPermission
    当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。
    MemoryNotificationInfo
    有关内存通知的信息。
    MemoryUsage
    MemoryUsage对象表示内存使用的快照。
    MonitorInfo
    有关对象监视器锁的信息。
    ThreadInfo
    线程信息。
  • 枚举摘要
    Enum 描述
    MemoryType
    类型memory pools 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang.management Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang.management

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.management.LockInfo
      • java.lang.management.MonitorInfo
    • java.lang.management.ManagementFactory
    • java.lang.management.MemoryNotificationInfo
    • java.lang.management.MemoryUsage
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.lang.management.ManagementPermission
    • java.lang.management.ThreadInfo

Interface Hierarchy

  • java.lang.management.PlatformManagedObject
    • java.lang.management.BufferPoolMXBean
    • java.lang.management.ClassLoadingMXBean
    • java.lang.management.CompilationMXBean
    • java.lang.management.MemoryManagerMXBean
      • java.lang.management.GarbageCollectorMXBean
    • java.lang.management.MemoryMXBean
    • java.lang.management.MemoryPoolMXBean
    • java.lang.management.OperatingSystemMXBean
    • java.lang.management.PlatformLoggingMXBean
    • java.lang.management.RuntimeMXBean
    • java.lang.management.ThreadMXBean

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.management.MemoryType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


LockInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Class LockInfo

  • java.lang.Object
    • java.lang.management.LockInfo
  • 已知直接子类：
    MonitorInfo

    public class LockInfo
extends Object
    有关锁的信息。 锁可以是一个内置的对象监视器，一个可自带的同步器或与同步器相关联的Condition对象。

    An ownable synchronizer是可以由线程专有的同步器，并使用AbstractOwnableSynchronizer （或其子类）来实现其同步属性。 ReentrantLock和的写锁定（而不是读锁） ReentrantReadWriteLock是由平台提供可拥有同步的两个例子。

    MXBean Mapping

    LockInfo映射到CompositeData，如from中所述。
    从以下版本开始：
    1.6
    另请参见：
    AbstractOwnableSynchronizer ， Condition

    • 构造方法摘要

      构造方法
      Constructor 描述
      LockInfo​(String className, int identityHashCode)
      构造一个 LockInfo对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static LockInfo from​(CompositeData cd)
      返回由给定的 CompositeData表示的 LockInfo对象。
      String getClassName​()
      返回锁定对象的类的完全限定名称。
      int getIdentityHashCode​()
      返回从 System.identityHashCode(java.lang.Object)方法返回的锁对象的标识哈希码。
      String toString​()
      返回一个锁的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LockInfo

        public LockInfo​(String className,
                int identityHashCode)
        构造一个 LockInfo对象。
        参数
        className - 锁定对象的类的完全限定名称。
        identityHashCode - 锁定对象的 identity hash code 。

    • 方法详细信息

      • getClassName

        public String getClassName​()
        返回锁定对象的类的完全限定名称。
        结果
        锁定对象的类的完全限定名称。

      • getIdentityHashCode

        public int getIdentityHashCode​()
        返回从 System.identityHashCode(java.lang.Object)方法返回的锁对象的标识哈希码。
        结果
        锁定对象的身份哈希码。

      • from

        public static LockInfo from​(CompositeData cd)
        返回由给定的CompositeData表示的LockInfo对象。 给定的CompositeData必须包含以下属性：
        The attributes and the types the given CompositeData contains
        Attribute Name | Type
        className | java.lang.String
        identityHashCode | java.lang.Integer
        参数
        cd - CompositeData代表 LockInfo
        结果
        一个LockInfo对象，由cd表示，如果cd不是null ; 否则为null 。
        异常
        IllegalArgumentException - 如果 cd不代表具有上述属性的 LockInfo 。
        从以下版本开始：
        1.8

      • toString

        public String toString​()
        返回一个锁的字符串表示形式。 返回的字符串表示由对象的类的名称，标记字符“@”和对象的标识哈希码的无符号十六进制表示形式组成。 此方法返回一个字符串等于以下值：
         lock.getClass().getName() + '@' + Integer.toHexString(System.identityHashCode(lock))
        其中lock是锁定对象。
        重写：
        toString在 Object
        结果
        锁的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ManagementFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Class ManagementFactory

  • java.lang.Object
    • java.lang.management.ManagementFactory

  • public class ManagementFactory
extends Object
    ManagementFactory类是用于获取Java平台的受管Bean的工厂类。 该类由静态方法组成，每个方法返回一个或多个表示Java虚拟机组件的管理接口的平台MXBeans 。

    Platform MXBeans

    平台MXBean是符合JMX仪器规范的托管bean ，仅使用一组基本数据类型。 JMX管理应用程序和platform MBeanServer可以互操作，而不需要MXBean特定数据类型的类。 在JMX连接器服务器和连接器客户端之间传输的数据类型是open types ，这允许跨版本进行互操作。 详见the specification of MXBeans 。

    每个平台MXBean是一个PlatformManagedObject ，它有一个独特的ObjectName注册在平台MBeanServer由getObjectName方法返回。

    应用程序可以通过以下方式访问平台MXBean：

    1.直接访问MXBean界面

    • Get an MXBean instance by calling the getPlatformMXBean or getPlatformMXBeans method and access the MXBean locally in the running virtual machine.
    • Construct an MXBean proxy instance that forwards the method calls to a given MBeanServer by calling the getPlatformMXBean(MBeanServerConnection, Class) or getPlatformMXBeans(MBeanServerConnection, Class) method. The newPlatformMXBeanProxy method can also be used to construct an MXBean proxy instance of a given ObjectName. A proxy is typically constructed to remotely access an MXBean of another running virtual machine.

    2. Indirect access to an MXBean interface via MBeanServer

    • Go through the platform MBeanServer to access MXBeans locally or a specific MBeanServerConnection to access MXBeans remotely. The attributes and operations of an MXBean use only JMX open types which include basic data types, CompositeData, and TabularData defined in OpenType. The mapping is specified in the MXBean specification for details.

    getPlatformManagementInterfaces方法返回Java虚拟机中支持的所有管理接口，包括下表中列出的标准管理界面以及由JDK实现扩展的管理接口。

    Java虚拟机具有以下管理接口的单个实例：

    The list of Management Interfaces and their single instances
    Management Interface ObjectName
    ClassLoadingMXBean java.lang:type=ClassLoading
    MemoryMXBean java.lang:type=Memory
    ThreadMXBean java.lang:type=Threading
    RuntimeMXBean java.lang:type=Runtime
    OperatingSystemMXBean java.lang:type=OperatingSystem
    PlatformLoggingMXBean java.util.logging:type=Logging

    Java虚拟机具有以下管理接口的零个或单个实例。

    The list of Management Interfaces and their single instances
    Management Interface ObjectName
    CompilationMXBean java.lang:type=Compilation

    Java虚拟机可能具有以下管理接口的一个或多个实例。

    The list of Management Interfaces and their single instances
    Management Interface | ObjectName
    GarbageCollectorMXBean | java.lang:type=GarbageCollector ,name=collector's name
    MemoryManagerMXBean | java.lang:type=MemoryManager ,name=manager's name
    MemoryPoolMXBean | java.lang:type=MemoryPool ,name=pool's name
    BufferPoolMXBean | java.nio:type=BufferPool,name=pool name
    从以下版本开始：
    1.5
    另请参见：
    JMX Specification ， Ways to Access Management Metrics ， MXBean

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String CLASS_LOADING_MXBEAN_NAME
      字符串表示的ObjectName为ClassLoadingMXBean 。
      static String COMPILATION_MXBEAN_NAME
      字符串表示的ObjectName为CompilationMXBean 。
      static String GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE
      域名和类型密钥属性在ObjectName为GarbageCollectorMXBean 。
      static String MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE
      域名和类型密钥属性在ObjectName为MemoryManagerMXBean 。
      static String MEMORY_MXBEAN_NAME
      字符串表示的ObjectName为MemoryMXBean 。
      static String MEMORY_POOL_MXBEAN_DOMAIN_TYPE
      域名和类型密钥属性在ObjectName为MemoryPoolMXBean 。
      static String OPERATING_SYSTEM_MXBEAN_NAME
      字符串表示的ObjectName为OperatingSystemMXBean 。
      static String RUNTIME_MXBEAN_NAME
      字符串表示的ObjectName为RuntimeMXBean 。
      static String THREAD_MXBEAN_NAME
      ObjectName字符串表示为ThreadMXBean 。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ClassLoadingMXBean getClassLoadingMXBean​()
      返回Java虚拟机的类加载系统的托管bean。
      static CompilationMXBean getCompilationMXBean​()
      返回Java虚拟机编译系统的受管Bean。
      static List<GarbageCollectorMXBean> getGarbageCollectorMXBeans​()
      返回Java虚拟机中的GarbageCollectorMXBean对象的列表。
      static List<MemoryManagerMXBean> getMemoryManagerMXBeans​()
      返回Java虚拟机中的MemoryManagerMXBean对象的列表。
      static MemoryMXBean getMemoryMXBean​()
      返回Java虚拟机的内存系统的托管bean。
      static List<MemoryPoolMXBean> getMemoryPoolMXBeans​()
      返回Java虚拟机中的MemoryPoolMXBean对象的列表。
      static OperatingSystemMXBean getOperatingSystemMXBean​()
      返回运行Java虚拟机的操作系统的托管bean。
      static Set<Class<? extends PlatformManagedObject>> getPlatformManagementInterfaces​()
      返回Class对象的集合，子界面为PlatformManagedObject ，表示用于监视和管理Java平台的所有管理界面。
      static MBeanServer getPlatformMBeanServer​()
      返回平台MBeanServer 。
      static <T extends PlatformManagedObject>
      T             		getPlatformMXBean​(Class<T> mxbeanInterface)
      返回实现给定的 mxbeanInterface的平台MXBean，该 mxbeanInterface被指定为在Java虚拟机中具有一个实例。
      static <T extends PlatformManagedObject>
      T             		getPlatformMXBean​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回 mxbeanInterface的平台MXBean代理，该代理被指定为在Java虚拟机中具有一个实例，代理将通过给定的 MBeanServerConnection转发方法调用。
      static <T extends PlatformManagedObject>
      List<T>             		getPlatformMXBeans​(Class<T> mxbeanInterface)
      返回在Java虚拟机中实现给定的 mxbeanInterface的平台 mxbeanInterface的列表。
      static <T extends PlatformManagedObject>
      List<T>             		getPlatformMXBeans​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回平台MXBean代理的列表，用于通过给定的 MBeanServerConnection转发 mxbeanInterface的方法调用。
      static RuntimeMXBean getRuntimeMXBean​()
      返回Java虚拟机的运行时系统的托管bean。
      static ThreadMXBean getThreadMXBean​()
      返回Java虚拟机的线程系统的托管bean。
      static <T> T newPlatformMXBeanProxy​(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
      返回给定的平台MXBean接口的代理 MXBean name转发其方法调用通过给定 MBeanServerConnection 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • CLASS_LOADING_MXBEAN_NAME

        public static final String CLASS_LOADING_MXBEAN_NAME
        ObjectName字符串表示为ClassLoadingMXBean 。
        另请参见：
        Constant Field Values

      • COMPILATION_MXBEAN_NAME

        public static final String COMPILATION_MXBEAN_NAME
        字符串表示的ObjectName为CompilationMXBean 。
        另请参见：
        Constant Field Values

      • MEMORY_MXBEAN_NAME

        public static final String MEMORY_MXBEAN_NAME
        字符串表示的ObjectName为MemoryMXBean 。
        另请参见：
        Constant Field Values

      • OPERATING_SYSTEM_MXBEAN_NAME

        public static final String OPERATING_SYSTEM_MXBEAN_NAME
        字符串表示的ObjectName为OperatingSystemMXBean 。
        另请参见：
        Constant Field Values

      • RUNTIME_MXBEAN_NAME

        public static final String RUNTIME_MXBEAN_NAME
        字符串表示的ObjectName为RuntimeMXBean 。
        另请参见：
        Constant Field Values

      • THREAD_MXBEAN_NAME

        public static final String THREAD_MXBEAN_NAME
        字符串表示的ObjectName为ThreadMXBean 。
        另请参见：
        Constant Field Values

      • GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE

        public static final String GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE
        ObjectName的域名和类型密钥属性为GarbageCollectorMXBean 。 可以通过将此字符串附加到“ ,name= 收藏家的名称 ”来形成GarbageCollectorMXBean的独特ObjectName 。
        另请参见：
        Constant Field Values

      • MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE

        public static final String MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE
        域名和类型密钥属性在ObjectName为MemoryManagerMXBean 。 ObjectName的MemoryManagerMXBean可以通过将此字符串附加到“ ,name= 经理的名字 ”来形成。
        另请参见：
        Constant Field Values

      • MEMORY_POOL_MXBEAN_DOMAIN_TYPE

        public static final String MEMORY_POOL_MXBEAN_DOMAIN_TYPE
        该域名和类型密钥属性在ObjectName为MemoryPoolMXBean 。 ObjectName的MemoryPoolMXBean可以通过将这个字符串追加到,name= 池的名字来形成。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getClassLoadingMXBean

        public static ClassLoadingMXBean getClassLoadingMXBean​()
        返回Java虚拟机的类加载系统的托管bean。
        结果
        一个用于Java虚拟机的ClassLoadingMXBean对象。

      • getMemoryMXBean

        public static MemoryMXBean getMemoryMXBean​()
        返回Java虚拟机的内存系统的托管bean。
        结果
        一个用于Java虚拟机的MemoryMXBean对象。

      • getThreadMXBean

        public static ThreadMXBean getThreadMXBean​()
        返回Java虚拟机的线程系统的托管bean。
        结果
        一个用于Java虚拟机的ThreadMXBean对象。

      • getRuntimeMXBean

        public static RuntimeMXBean getRuntimeMXBean​()
        返回Java虚拟机的运行时系统的托管bean。
        结果
        一个用于Java虚拟机的RuntimeMXBean对象。

      • getCompilationMXBean

        public static CompilationMXBean getCompilationMXBean​()
        返回Java虚拟机编译系统的受管Bean。 如果Java虚拟机没有编译系统，此方法返回null 。
        结果
        一个用于Java虚拟机的CompilationMXBean对象，如果Java虚拟机没有编译系统， null 。

      • getOperatingSystemMXBean

        public static OperatingSystemMXBean getOperatingSystemMXBean​()
        返回运行Java虚拟机的操作系统的托管bean。
        结果
        一个用于Java虚拟机的OperatingSystemMXBean对象。

      • getMemoryPoolMXBeans

        public static List<MemoryPoolMXBean> getMemoryPoolMXBeans​()
        返回Java虚拟机中的MemoryPoolMXBean个对象的列表。 Java虚拟机可以有一个或多个内存池。 它可能会在执行期间添加或删除内存池。
        结果
        一个 MemoryPoolMXBean对象的列表。

      • getMemoryManagerMXBeans

        public static List<MemoryManagerMXBean> getMemoryManagerMXBeans​()
        返回Java虚拟机中的MemoryManagerMXBean对象的列表。 Java虚拟机可以有一个或多个内存管理器。 它可能会在执行期间添加或删除内存管理器。
        结果
        一个 MemoryManagerMXBean对象的列表。

      • getGarbageCollectorMXBeans

        public static List<GarbageCollectorMXBean> getGarbageCollectorMXBeans​()
        返回Java虚拟机中的GarbageCollectorMXBean个对象的列表。 Java虚拟机可能具有一个或多个GarbageCollectorMXBean对象。 它可能在执行期间添加或删除GarbageCollectorMXBean 。
        结果
        GarbageCollectorMXBean对象的列表。

      • getPlatformMBeanServer

        public static MBeanServer getPlatformMBeanServer​()
        返回平台MBeanServer 。 在第一次调用此方法时，首先通过调用270535983103959方法创建平台MBeanServer ，并在其平台MBeanServer注册了每个平台MXBean MBeanServer及其ObjectName 。 此方法在后续调用中将简单地返回最初创建的平台MBeanServer 。

        动态创建和销毁的MXBeans （例如，内存pools和managers ）将自动注册并注销到平台MBeanServer 。

        如果设置了系统属性javax.management.builder.initial ，则平台MBeanServer创建将由指定的MBeanServerBuilder完成 。

        建议该平台MBeanServer也可用于注册除平台MXBeans之外的其他应用程序托管bean。 这将允许所有MBean通过相同的MBeanServer ，从而允许更容易的网络发布和发现。 应避免与平台MXBeans的名称冲突。

        结果
        平台MBeanServer ; 平台MBeanServer在第一次调用此方法时被注册到平台MBeanServer中。
        异常
        SecurityException - 如果有安全管理员，并且呼叫者没有 MBeanServerFactory.createMBeanServer()所要求的权限。
        另请参见：
        MBeanServerFactory ， MBeanServerFactory.createMBeanServer()

      • newPlatformMXBeanProxy

        public static <T> T newPlatformMXBeanProxy​(MBeanServerConnection connection,
                                           String mxbeanName,
                                           Class<T> mxbeanInterface)
                                    throws IOException
        返回给定的平台MXBean接口的代理MXBean name转发其方法调用通过给定MBeanServerConnection 。

        此方法相当于：

        Proxy.newProxyInstance (mxbeanInterface.getClassLoader(), new Class[] { mxbeanInterface }, handler)
        其中handler是一个InvocationHandler ，调用MXBean接口的方法调用。 handler将MXBean数据类型的输入参数转换为映射的打开类型，然后转发到MBeanServer ，并将来自MXBean方法调用的返回值通过MBeanServer从打开类型转换为在MXBean接口中声明的相应返回类型。

        如果MXBean是通知发布者（即实现NotificationEmitter ），则此代理将实现mxbeanInterface和NotificationEmitter 。

        笔记：

        1. 使用MXBean代理可以方便地远程访问正在运行的虚拟机的MXBean平台。 对MXBean代理的所有方法调用将转发到MBeanServerConnection ，当连接器服务器发生通信问题时，可能会抛出IOException 。 如果抛出， IOException将被包装在UndeclaredThrowableException 。 使用代理远程访问平台UndeclaredThrowableException的应用程序应准备捕获UndeclaredThrowableException并处理其cause ，就像该原因是由MBeanServerConnection接口抛出的。
        2. 当客户端应用程序被设计为远程访问版本与应用程序运行版本不同的正在运行的虚拟机的MXBeans时 ，应准备捕获InvalidObjectException ，当MXBean代理接收到枚举常量的名称时，在客户端应用程序中加载的枚举类中缺少。 如果抛出， InvalidObjectException将被包装在UndeclaredThrowableException 。
        3. MBeanServerInvocationHandler或其newProxyInstance方法无法用于为平台MXBean创建代理。 由MBeanServerInvocationHandler创建的代理对象不处理MBeanServerInvocationHandler中描述的平台MXBeans的属性 。
        参数类型
        T - 一个 mxbeanInterface类型的参数
        参数
        connection - 要转发的 MBeanServerConnection 。
        mxbeanName - 要转发到connection内的平台MXBean的名称。 mxbeanName必须格式为ObjectName 。
        mxbeanInterface - 要由代理实现的MXBean接口。
        结果
        给定的 MXBean name的平台MXBean接口的代理，通过给定的 MBeanServerConnection或 null转发其方法调用（如果不存在）。
        异常
        IllegalArgumentException - 如果
        • mxbeanName不具有有效的ObjectName格式，或
        • 在connection命名的MXBean不是由平台提供的MXBean，或者
        • 该名称的MXBean未注册在MBeanServerConnection或
        • 命名的MXBean不是给定的mxbeanInterface一个实例
        IOException - 访问 MBeanServerConnection时是否发生通信问题。

      • getPlatformMXBean

        public static <T extends PlatformManagedObject> T getPlatformMXBean​(Class<T> mxbeanInterface)
        返回实现给定的mxbeanInterface的平台MXBean，它被指定为在Java虚拟机中具有一个实例。 如果Java虚拟机中没有实现管理接口，则此方法可能返回null （例如，没有编译系统的Java虚拟机不实现CompilationMXBean ）; 否则，此方法相当于调用：
          getPlatformMXBeans(mxbeanInterface).get(0);
        参数类型
        T - 一个 mxbeanInterface类型的参数
        参数
        mxbeanInterface - 如果实现了Java虚拟机中具有一个实例的平台MXBean的管理界面。
        结果
        实现 mxbeanInterface的平台MXBean，如果不存在， null 。
        异常
        IllegalArgumentException - 如果 mxbeanInterface不是一个平台管理界面或不是一个单一平台MXBean。
        从以下版本开始：
        1.7

      • getPlatformMXBeans

        public static <T extends PlatformManagedObject> List<T> getPlatformMXBeans​(Class<T> mxbeanInterface)
        返回在Java虚拟机中实现给定的mxbeanInterface的平台mxbeanInterface的列表。 返回的列表可能包含零个，一个或多个实例。 在给定的管理界面的规范中定义了返回列表中的实例数。 订单未定义，并且不保证返回的列表与以前的调用的顺序相同。
        参数类型
        T - 一个 mxbeanInterface类型的参数
        参数
        mxbeanInterface - 平台MXBean的管理界面
        结果
        实现 mxbeanInterface的平台 mxbeanInterface列表。
        异常
        IllegalArgumentException - 如果 mxbeanInterface不是平台管理界面。
        从以下版本开始：
        1.7

      • getPlatformMXBean

        public static <T extends PlatformManagedObject> T getPlatformMXBean​(MBeanServerConnection connection,
                                                                    Class<T> mxbeanInterface)
                                                             throws IOException
        返回mxbeanInterface的平台MXBean代理，该代理被指定为在Java虚拟机中具有一个实例，代理将通过给定的MBeanServerConnection转发方法调用。 如果在被监视的Java虚拟机中未实现管理接口，则此方法可能返回null （例如，没有编译系统的Java虚拟机不实现CompilationMXBean ）; 否则，此方法相当于调用：
          getPlatformMXBeans(connection, mxbeanInterface).get(0);
        参数类型
        T - 一个 mxbeanInterface类型的参数
        参数
        connection - 要转发的 MBeanServerConnection 。
        mxbeanInterface - 如果已实施，将监视Java虚拟机中的一个实例的平台MXBean的管理界面。
        结果
        平台MXBean代理通过给定的 MBeanServerConnection或 null转发 mxbeanInterface的方法调用，如果不存在的话。
        异常
        IllegalArgumentException - 如果 mxbeanInterface不是一个平台管理界面或不是一个单一平台的MXBean。
        IOException - 访问 MBeanServerConnection时是否发生通信问题。
        从以下版本开始：
        1.7
        另请参见：
        newPlatformMXBeanProxy(javax.management.MBeanServerConnection, java.lang.String, java.lang.Class<T>)

      • getPlatformMXBeans

        public static <T extends PlatformManagedObject> List<T> getPlatformMXBeans​(MBeanServerConnection connection,
                                                                           Class<T> mxbeanInterface)
                                                                    throws IOException
        返回平台MXBean代理的列表，用于通过给定的MBeanServerConnection转发mxbeanInterface的方法调用。 返回的列表可能包含零个，一个或多个实例。 在给定的管理界面的规范中定义了返回列表中的实例数。 订单未定义，并且不保证返回的列表与以前的调用的顺序相同。
        参数类型
        T - 一个 mxbeanInterface型参数
        参数
        connection - MBeanServerConnection 。
        mxbeanInterface - 平台MXBean的管理界面
        结果
        通过给定的 MBeanServerConnection转发 mxbeanInterface的方法调用的平台MXBean代理列表。
        异常
        IllegalArgumentException - 如果 mxbeanInterface不是平台管理界面。
        IOException - 如果在访问 MBeanServerConnection时发生通信问题。
        从以下版本开始：
        1.7
        另请参见：
        newPlatformMXBeanProxy(javax.management.MBeanServerConnection, java.lang.String, java.lang.Class<T>)

      • getPlatformManagementInterfaces

        public static Set<Class<? extends PlatformManagedObject>> getPlatformManagementInterfaces​()
        返回Class对象的集合，子界面为PlatformManagedObject ，表示用于监视和管理Java平台的所有管理接口。
        结果
        该组Class对象，子界面PlatformManagedObject表示用于监视和管理Java平台的管理界面。
        从以下版本开始：
        1.7
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ManagementPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Class ManagementPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.lang.management.ManagementPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class ManagementPermission
extends BasicPermission
    当SecurityManager运行的代码调用在Java平台的管理界面中定义的方法时，SecurityManager将检查的权限。

    下表提供了许可允许的简要说明，并讨论了授予代码许可的风险。

    Table shows permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission control Ability to control the runtime characteristics of the Java virtual machine, for example, enabling and disabling the verbose output for the class loading or memory system, setting the threshold of a memory pool, and enabling and disabling the thread contention monitoring support. Some actions controlled by this permission can disclose information about the running application, like the -verbose:class flag. This allows an attacker to control the runtime characteristics of the Java virtual machine and cause the system to misbehave. An attacker can also access some information related to the running application. monitor Ability to retrieve runtime information about the Java virtual machine such as thread stack trace, a list of all loaded class names, and input arguments to the Java virtual machine. This allows malicious code to monitor runtime information and uncover vulnerabilities.

    程序员通常不会直接创建ManagementPermission对象。 相反，它们是基于阅读安全策略文件的安全策略代码创建的。

    从以下版本开始：
    1.5
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ManagementPermission​(String name)
      构造具有指定名称的ManagementPermission。
      ManagementPermission​(String name, String actions)
      构造一个新的ManagementPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • ManagementPermission

        public ManagementPermission​(String name)
        构造具有指定名称的ManagementPermission。
        参数
        name - 权限名称。 必须是“监视器”或“控制”。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空或无效。

      • ManagementPermission

        public ManagementPermission​(String name,
                            String actions)
                     throws IllegalArgumentException
        构造一个新的ManagementPermission对象。
        参数
        name - 权限名称。 必须是“监视器”或“控制”。
        actions - 必须为null或空字符串。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空或参数无效。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemoryManagerMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface MemoryManagerMXBean

  • All Superinterfaces:
    PlatformManagedObject
    All Known Subinterfaces:
    GarbageCollectorMXBean ， GarbageCollectorMXBean

    public interface MemoryManagerMXBean
extends PlatformManagedObject
    内存管理器的管理界面。 内存管理器管理Java虚拟机的一个或多个内存池。

    Java虚拟机具有一个或多个内存管理器。 实现该接口的一个实例是一个MXBean ，可以通过调用ManagementFactory.getMemoryManagerMXBeans()方法或从platform MBeanServer方法获得。

    用于唯一标识MBeanServer内存管理器的MXBean的ObjectName是：

    java.lang:type=MemoryManager ,name= manager's name
    可以通过调用PlatformManagedObject.getObjectName()方法获得。
    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， MemoryMXBean ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String[] getMemoryPoolNames​()
      返回此内存管理器管理的内存池的名称。
      String getName​()
      返回表示此内存管理器的名称。
      boolean isValid​()
      测试此内存管理器是否在Java虚拟机中有效。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getName

        String getName​()
        返回表示此内存管理器的名称。
        结果
        这个内存管理器的名字。

      • isValid

        boolean isValid​()
        测试此内存管理器是否在Java虚拟机中有效。 一旦Java虚拟机将其从内存系统中删除，内存管理器将变为无效。
        结果
        true如果内存管理器在Java虚拟机中有效; 否则为false 。

      • getMemoryPoolNames

        String[] getMemoryPoolNames​()
        返回此内存管理器管理的内存池的名称。
        结果
        一个 String对象的数组，每个都是内存管理器管理的内存池的名称。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemoryMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface MemoryMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface MemoryMXBean
extends PlatformManagedObject
    Java虚拟机的内存系统的管理界面。

    Java虚拟机具有此接口的实现类的单个实例。 这种情况下实现此接口是MXBean ，可以通过调用能够得到ManagementFactory.getMemoryMXBean()方法或从platform MBeanServer方法。

    用于唯一标识MBeanServer内存系统的MXBean的ObjectName是：

    java.lang:type=Memory
    可以通过调用PlatformManagedObject.getObjectName()方法获得。

    记忆

    Java虚拟机的内存系统管理以下几种内存：

    堆

    Java虚拟机有一个堆 ，它是运行时数据区域，从中分配了所有类实例和数组的内存。 它是在Java虚拟机启动时创建的。 用于对象的堆内存由被称为垃圾回收器的自动内存管理系统进行回收 。

    堆可能是一个固定的大小或可能扩大和缩小。 堆的内存不需要是连续的。

    2.非堆存储器

    Java虚拟机管理堆以外的内存（称为非堆内存 ）。

    Java虚拟机具有在所有线程之间共享的方法区域 。 方法区属于非堆内存。 它存储每个类的结构，例如运行时常量池，字段和方法数据，以及方法和构造函数的代码。 它是在Java虚拟机启动时创建的。

    方法区域在逻辑上是堆的一部分，但Java虚拟机实现可以选择不要垃圾收集或压缩它。 类似于堆，方法区域可以是固定大小的，或者可以被扩展和缩小。 方法区域的内存不需要是连续的。

    除了方法区域之外，Java虚拟机实现可能需要用于内部处理或优化的内存，这也是非堆内存。 例如，JIT编译器需要内存来存储从Java虚拟机代码转换的本地机器代码以实现高性能。

    内存池和内存管理器

    Memory pools和memory managers是监视和管理Java虚拟机的内存系统的抽象实体。

    内存池代表Java虚拟机管理的内存区域。 Java虚拟机具有至少一个内存池，并且可以在执行期间创建或删除内存池。 内存池可以属于堆或非堆内存。

    内存管理器负责管理一个或多个内存池。 垃圾收集器是负责回收由不可达对象占用的内存的一种内存管理器。 Java虚拟机可能具有一个或多个内存管理器。 它可能会在执行期间添加或删除内存管理器。 内存池可以由多个内存管理器管理。

    内存使用监控

    内存使用是内存系统非常重要的监控属性。 例如，内存使用可能表示：
    • 应用程序的内存使用情况，
    • 对自动存储器管理系统施加的工作量，
    • 潜在的内存泄漏。

    可以通过三种方式监视内存使用情况：

    • 轮询
    • 使用阈值通知
    • 集合使用阈值通知
    详细信息在MemoryPoolMXBean界面中指定。

    内存使用监视机制旨在用于负载平衡或工作负载分配使用。 例如，当应用程序的内存使用量超过某个阈值时，应用程序将停止接收任何新的工作负载。 它不适用于应用程序从低内存条件检测和恢复。

    通知

    该MemoryMXBean是NotificationEmitter ， 其中如果任何一个存储器池支持usage threshold或collection usage threshold ，其可以通过调用MemoryPoolMXBean.isUsageThresholdSupported()和MemoryPoolMXBean.isCollectionUsageThresholdSupported()方法来确定。

    • usage threshold exceeded notification - 用于通知内存池的内存使用量增加并已达到或超过其usage threshold值。
    • collection usage threshold exceeded notification - 用于在Java虚拟机花费了在该内存池中回收未使用对象的努力之后通知内存池的内存使用大于或等于其内存池的内存使用量为collection usage threshold 。

    发出的通知是一个Notification实例，其user data设置为CompositeData ，表示一个MemoryNotificationInfo对象，该对象包含有关构建通知时内存池的信息。 所述CompositeData含有作为中描述的属性MemoryNotificationInfo 。

    的NotificationEmitter

    所述MemoryMXBean通过返回对象ManagementFactory.getMemoryMXBean()实现NotificationEmitter接口，允许听者的内注册MemoryMXBean为通知侦听。 以下是注册MyListener以处理由MemoryMXBean发出的通知的示例代码。
     class MyListener implements javax.management.NotificationListener {
     public void handleNotification(Notification notif, Object handback) {
         // handle notification
         ....
     }
 }

 MemoryMXBean mbean = ManagementFactory.getMemoryMXBean();
 NotificationEmitter emitter = (NotificationEmitter) mbean;
 MyListener listener = new MyListener();
 emitter.addNotificationListener(listener, null, null);
    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void gc​()
      运行垃圾回收器。
      MemoryUsage getHeapMemoryUsage​()
      返回用于对象分配的堆的当前内存使用情况。
      MemoryUsage getNonHeapMemoryUsage​()
      新新新新旗新新新新旗新新旗新新旗新新旗新新旗旗新新旗新新200新新新旗200新新新新旗：
      int getObjectPendingFinalizationCount​()
      返回正在等待完成的对象的大致数量。
      boolean isVerbose​()
      测试是否启用了内存系统的详细输出。
      void setVerbose​(boolean value)
      启用或禁用内存系统的详细输出。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getObjectPendingFinalizationCount

        int getObjectPendingFinalizationCount​()
        返回正在等待完成的对象的大致数量。
        结果
        最终定案待处理的大致数字对象。

      • getHeapMemoryUsage

        MemoryUsage getHeapMemoryUsage​()
        返回用于对象分配的堆的当前内存使用情况。 堆由一个或多个内存池组成。 返回的内存使用量的used和committed大小是所有堆内存池的值的总和，而返回的内存使用量的init和max大小表示堆内存的设置，可能不是所有堆的堆的总和内存池。

        返回的内存使用量中使用的内存量是未被收集的活动对象和垃圾对象占用的内存量（如果有的话）。

        MBeanServer访问 ：
        MemoryUsage的映射类型为CompositeData ，其属性在MemoryUsage中指定。

        结果
        表示堆内存使用的MemoryUsage对象。

      • getNonHeapMemoryUsage

        MemoryUsage getNonHeapMemoryUsage​()
        新新新新旗新新新新旗新新旗新新旗新新旗新新旗旗新新旗新新200新新新旗200新新新新旗： 非堆存储器由一个或多个内存池组成。 返回的内存使用量的used和committed大小是所有非堆内存池的值的总和，而返回的内存使用量的init和max大小表示非堆内存的设置，可能不是所有非堆内存池的那些。

        MBeanServer访问 ：
        MemoryUsage的映射类型为CompositeData ，属性如MemoryUsage所述 。

        结果
        表示非堆内存使用的MemoryUsage对象。

      • isVerbose

        boolean isVerbose​()
        测试是否启用了内存系统的详细输出。
        结果
        true如果启用了内存系统的详细输出; 否则为false 。

      • setVerbose

        void setVerbose​(boolean value)
        启用或禁用内存系统的详细输出。 发出详细信息的详细输出信息和输出流是依赖于实现的。 通常，当Java虚拟机实现在垃圾收集时释放内存时，将打印出一条消息。

        此方法的每次调用都可以全局启用或禁用详细输出。

        参数
        value - true启用详细输出; false禁用。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。

      • gc

        void gc​()
        运行垃圾回收器。 电话gc()有效地等效于通话：
         System.gc()
        另请参见：
        System.gc()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemoryNotificationInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Class MemoryNotificationInfo

  • java.lang.Object
    • java.lang.management.MemoryNotificationInfo

  • public class MemoryNotificationInfo
extends Object
    有关内存通知的信息。

    当Java虚拟机检测到内存池的内存使用量超过阈值时， MemoryMXBean会发出内存通知。 发出的通知将包含有关检测到的条件的内存通知信息：

    • 内存池的名称。
    • 构建通知时内存池的内存使用情况。
    • 构建通知时内存使用量超过阈值的次数。 对于使用阈值通知，此计数将为usage threshold count 。 对于采集阈值通知，此计数将为collection usage threshold count 。

    A CompositeData表示MemoryNotificationInfo对象存储在user data的notification中 。 提供from方法将其从CompositeData转换为MemoryNotificationInfo对象。 例如：

          Notification notif;

      // receive the notification emitted by MemoryMXBean and set to notif
      ...

      String notifType = notif.getType();
      if (notifType.equals(MemoryNotificationInfo.MEMORY_THRESHOLD_EXCEEDED) ||
          notifType.equals(MemoryNotificationInfo.MEMORY_COLLECTION_THRESHOLD_EXCEEDED)) {
          // retrieve the memory notification information
          CompositeData cd = (CompositeData) notif.getUserData();
          MemoryNotificationInfo info = MemoryNotificationInfo.from(cd);
          ....
      }

    MemoryMXBean发出的通知类型有：

    • A usage threshold exceeded notification 。
      当内存池的内存使用量增加并达到或超过其usage threshold值时，将发出此通知。 随后交叉使用阈值直到存储器使用已经返回到小于使用阈值为止才进一步通知。
    • A collection usage threshold exceeded notification 。
      当Java虚拟机花费了回收该内存池中未使用的对象的努力时，内存池的内存使用大于或等于其collection usage threshold时，将会发出此通知。
    从以下版本开始：
    1.5

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static String MEMORY_COLLECTION_THRESHOLD_EXCEEDED
      通知类型表示在Java虚拟机已经花费了回收该内存池中的未使用对象的努力之后，内存池的内存使用大于或等于其 collection usage threshold 。
      static String MEMORY_THRESHOLD_EXCEEDED
      通知类型表示内存池的内存使用量已达到或超过其 usage threshold值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MemoryNotificationInfo​(String poolName, MemoryUsage usage, long count)
      构造一个 MemoryNotificationInfo对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static MemoryNotificationInfo from​(CompositeData cd)
      返回由给定的 CompositeData表示的 MemoryNotificationInfo对象。
      long getCount​()
      返回构建通知时内存使用量超过阈值的次数。
      String getPoolName​()
      返回触发此通知的内存池的名称。
      MemoryUsage getUsage​()
      构建此通知时返回内存池的内存使用情况。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • MEMORY_THRESHOLD_EXCEEDED

        public static final String MEMORY_THRESHOLD_EXCEEDED
        指示内存池的内存使用量达到或超过其usage threshold值的通知类型。 该通知由MemoryMXBean发出。 随后交叉使用阈值直到存储器使用已经返回到小于使用阈值为止才进一步通知。 此通知类型的值为java.management.memory.threshold.exceeded 。
        另请参见：
        Constant Field Values

      • MEMORY_COLLECTION_THRESHOLD_EXCEEDED

        public static final String MEMORY_COLLECTION_THRESHOLD_EXCEEDED
        通知类型表示内存池的内存使用大于或等于其collection usage threshold之后，Java虚拟机已经花费了在该内存池中回收未使用的对象的努力。 此通知由MemoryMXBean发出。 此通知类型的值为java.management.memory.collection.threshold.exceeded 。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • MemoryNotificationInfo

        public MemoryNotificationInfo​(String poolName,
                              MemoryUsage usage,
                              long count)
        构造一个 MemoryNotificationInfo对象。
        参数
        poolName - 触发此通知的内存池的名称。
        usage - 内存池的内存使用情况。
        count - 临界值计数。

    • 方法详细信息

      • getPoolName

        public String getPoolName​()
        返回触发此通知的内存池的名称。 内存池的使用率已超过阈值。
        结果
        触发此通知的内存池的名称。

      • getUsage

        public MemoryUsage getUsage​()
        构建此通知时返回内存池的内存使用情况。
        结果
        构建此通知时内存池的内存使用情况。

      • getCount

        public long getCount​()
        返回构建通知时内存使用量超过阈值的次数。 对于使用阈值通知，此计数将为threshold count 。 对于收集阈值通知，此计数将为collection usage threshold count 。
        结果
        构建通知时内存使用量超过阈值的次数。

      • from

        public static MemoryNotificationInfo from​(CompositeData cd)
        返回由给定的CompositeData表示的MemoryNotificationInfo对象。 给定的CompositeData必须包含以下属性：
        The attributes and the types the given CompositeData contains
        Attribute Name | Type
        poolName | java.lang.String
        usage | javax.management.openmbean.CompositeData
        count | java.lang.Long
        参数
        cd - CompositeData代表 MemoryNotificationInfo
        结果
        一个MemoryNotificationInfo对象，由cd表示，如果cd不是null ; null否则。
        异常
        IllegalArgumentException - 如果 cd不表示 MemoryNotificationInfo对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemoryPoolMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface MemoryPoolMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface MemoryPoolMXBean
extends PlatformManagedObject
    内存池的管理界面。 内存池代表Java虚拟机管理的内存资源，由一个或多个memory managers管理 。

    Java虚拟机具有此接口的实现类的一个或多个实例。 实现此接口的实例是一个MXBean ，可以通过调用ManagementFactory.getMemoryPoolMXBeans()方法或从platform MBeanServer方法获得。

    用于唯一标识ObjectName内存池的MXBean的MBeanServer是：

    java.lang:type=MemoryPool ,name= pool's name
    可以通过调用PlatformManagedObject.getObjectName()方法获得。

    内存类型

    Java虚拟机具有用于对象分配的堆，并且还维护方法区域和Java虚拟机执行的非堆内存。 Java虚拟机可以有一个或多个内存池。 每个内存池代表以下类型之一的内存区域：

    • heap
    • non-heap

    内存使用监控

    内存池具有以下属性：
    • Memory usage
    • Peak memory usage
    • Usage Threshold
    • Collection Usage Threshold （仅由一些垃圾回收的内存池支持）

    1. Memory Usage

    getUsage()方法提供了对内存池当前使用情况的估计。 对于垃圾回收的内存池，使用的内存量包括池中所有对象占用的内存，包括可访问和不可访问的对象。

    一般来说，这种方法是一个轻量级的操作来获得大致的内存使用。 对于一些内存池，例如，当对象不是连续打包时，该方法可能是一个昂贵的操作，需要一些计算来确定当前的内存使用情况。 在这种情况下，实施应该记录。

    2. Peak Memory Usage

    虚拟机启动或峰值重置后，Java虚拟机维护内存池的高峰内存使用情况。 峰值内存使用量由返回getPeakUsage()方法和复位通过调用resetPeakUsage()方法。

    3. Usage Threshold

    每个内存池都有一个可管理的属性，称为使用阈值 ，具有由Java虚拟机提供的默认值。 默认值取决于平台。 可以通过setUsageThreshold方法设置使用阈值。 如果阈值设置为正值，则在该内存池中启用使用阈值交叉检查。 如果使用阈值设置为零，则禁用此内存池上的使用阈值交叉检查。 可以使用isUsageThresholdSupported()方法来确定是否支持此功能。

    Java虚拟机在其最佳适当时间（通常在垃圾收集时间）的基础上执行基于内存池的使用阈值交叉检查。 每个内存池维护一个usage threshold count ，每当Java虚拟机检测到内存池使用率正在超过阈值时，它将会增加。

    这种可管理的使用阈值属性设计用于以低开销监视内存使用的增长趋势。 某些内存池的使用阈值可能不合适。 例如，一代代垃圾回收器是许多Java虚拟机实现中使用的常见的垃圾收集算法，它根据年龄管理两代或多代隔离对象。 大多数的对象分配在最年轻的一代 （比如一个托儿所记忆库）中。 托儿所内存池被设计为填充并收集托儿所内存池将释放其大部分内存空间，因为它预计主要包含短命的对象，并且大部分在垃圾收集时无法访问。 在这种情况下，更适合于苗圃内存池不支持使用阈值。 另外，如果一个内存池中的对象分配成本非常低（例如，只是原子指针交换），则Java虚拟机可能不支持该内存池的使用阈值，因为将使用率与阈值高于对象分配的成本。

    可以使用polling或threshold notification机制来监控系统的内存使用情况。

    1. Polling

      通过为所有内存池调用getUsage()方法或支持使用阈值的那些内存池的isUsageThresholdExceeded()方法，应用程序可以持续监控其内存使用情况。 以下是具有专用于任务分发和处理的线程的示例代码。 在每个时间间隔内，它将根据其内存使用情况确定是否应该接收和处理新任务。 如果内存使用量超过其使用阈值，它会将所有未完成的任务重新分配给其他虚拟机，并停止接收新任务，直到内存使用率低于其使用阈值。

        // Assume the usage threshold is supported for this pool.
       // Set the threshold to myThreshold above which no new tasks
       // should be taken.
       pool.setUsageThreshold(myThreshold);
       ....

       boolean lowMemory = false;
       while (true) {
          if (pool.isUsageThresholdExceeded()) {
              // potential low memory, so redistribute tasks to other VMs
              lowMemory = true;
              redistributeTasks();
              // stop receiving new tasks
              stopReceivingTasks();
          } else {
              if (lowMemory) {
                  // resume receiving tasks
                  lowMemory = false;
                  resumeReceivingTasks();
              }
              // processing outstanding task
              ...
          }
          // sleep for sometime
          try {
              Thread.sleep(sometime);
          } catch (InterruptedException e) {
              ...
          }
       }
      上述示例不区分从两次迭代之间的存储器使用率保持高于阈值的情况下，存储器使用量暂时降低到使用阈值以下的情况。 可以使用getUsageThresholdCount()方法返回的使用阈值计数来确定两次轮询之间的内存使用情况是否已恢复到阈值以下。

      下面显示另一个例子，如果内存池处于低内存下并且在动作处理时间内忽略内存使用情况的变化，则需要采取一些措施。

        // Assume the usage threshold is supported for this pool.
       // Set the threshold to myThreshold which determines if
       // the application will take some action under low memory condition.
       pool.setUsageThreshold(myThreshold);

       int prevCrossingCount = 0;
       while (true) {
           // A busy loop to detect when the memory usage
           // has exceeded the threshold.
           while (!pool.isUsageThresholdExceeded() ||
                  pool.getUsageThresholdCount() == prevCrossingCount) {
               try {
                   Thread.sleep(sometime)
               } catch (InterruptException e) {
                   ....
               }
           }

           // Do some processing such as check for memory usage
           // and issue a warning
           ....

           // Gets the current threshold count. The busy loop will then
           // ignore any crossing of threshold happens during the processing.
           prevCrossingCount = pool.getUsageThresholdCount();
       }
    2. Usage Threshold Notifications

      MemoryMXBean将发出使用阈值通知。 当Java虚拟机检测到内存池的内存使用量达到或超过使用阈值时，虚拟机将触发MemoryMXBean发出usage threshold exceeded notification 。 超出使用阈值超过通知将不会生成，直到使用率已经低于阈值，然后再次超过它。

      下面是一个实现与上述第一个例子相同逻辑的示例代码，但使用使用阈值通知机制来检测低内存条件而不是轮询。 在该示例代码中，在接收到通知时，通知侦听器通知另一线程以执行实际动作，例如重新分配未完成的任务，停止接收任务或恢复接收任务。 handleNotification方法应设计为执行非常少量的工作并无延迟地返回，以避免导致后续通知的延迟。 耗时的操作应该由单独的线程执行。 通知侦听器可以由多个线程同时调用; 所以侦听器执行的任务应该被正确同步。

        class MyListener implements javax.management.NotificationListener {
            public void handleNotification(Notification notification, Object handback)  {
                String notifType = notification.getType();
                if (notifType.equals(MemoryNotificationInfo.MEMORY_THRESHOLD_EXCEEDED)) {
                    // potential low memory, notify another thread
                    // to redistribute outstanding tasks to other VMs
                    // and stop receiving new tasks.
                    lowMemory = true;
                    notifyAnotherThread(lowMemory);
                }
            }
       }

       // Register MyListener with MemoryMXBean
       MemoryMXBean mbean = ManagementFactory.getMemoryMXBean();
       NotificationEmitter emitter = (NotificationEmitter) mbean;
       MyListener listener = new MyListener();
       emitter.addNotificationListener(listener, null, null);

       // Assume this pool supports a usage threshold.
       // Set the threshold to myThreshold above which no new tasks
       // should be taken.
       pool.setUsageThreshold(myThreshold);

       // Usage threshold detection is enabled and notification will be
       // handled by MyListener.  Continue for other processing.
       ....

      不能保证MemoryMXBean何时发出门槛通知，何时通知。 当调用通知侦听器时，内存池的内存使用量可能会超过使用阈值多次。 MemoryNotificationInfo.getCount()方法返回在构建通知时内存使用量超过使用阈值的次数。 可以与getUsageThresholdCount()方法返回的当前使用阈值进行比较，以确定是否发生了这种情况。

    4. Collection Usage Threshold

    集合使用阈值是一个可管理的属性，仅适用于某些垃圾回收的内存池。 在Java虚拟机通过在垃圾回收时间内循环使用内存池中的未使用对象，已经花费了回收内存空间的努力时，收集的停堆内存池中的某些字节数仍将被使用。 回收使用量阈值允许的值，以用于这个号码，使得如果超过了阈值，一个字节被设置collection usage threshold exceeded notification将由发射MemoryMXBean 。 此外， collection usage threshold count将会增加。

    可以使用isCollectionUsageThresholdSupported()方法来确定是否支持此功能。

    Java虚拟机基于内存池执行收集使用阈值检查。 如果集合使用阈值设置为正值，则启用此检查。 如果集合使用阈值设置为零，则此内存池将禁用此检查。 默认值为零。 Java虚拟机在垃圾收集时执行收集使用阈值检查。

    一些垃圾回收的内存池可能选择不支持收集使用阈值。 例如，内存池仅由连续的并发垃圾回收器管理。 对象可以通过一些线程在此内存池中分配，而未使用的对象同时由并发垃圾回收器进行回收。 除非有明确的垃圾回收时间是检查内存使用的最佳时间，否则不应该支持收集使用率阈值。

    集合使用阈值用于在Java虚拟机花费回收内存空间后，监视内存使用情况。 也可以通过类似于usage threshold描述的轮询和阈值通知机制监视收集使用情况。

    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      MemoryUsage getCollectionUsage​()
      返回Java虚拟机最近花费在回收此内存池中未使用对象的努力后的内存使用情况。
      long getCollectionUsageThreshold​()
      以字节为单位返回此内存池的集合使用阈值。
      long getCollectionUsageThresholdCount​()
      返回Java虚拟机检测到内存使用量达到或超过集合使用率阈值的次数。
      String[] getMemoryManagerNames​()
      返回管理此内存池的内存管理器的名称。
      String getName​()
      返回表示此内存池的名称。
      MemoryUsage getPeakUsage​()
      从Java虚拟机启动或从峰值重置以来，返回此内存池的高峰内存使用情况。
      MemoryType getType​()
      返回此内存池的类型。
      MemoryUsage getUsage​()
      返回此内存池的内存使用情况的估计。
      long getUsageThreshold​()
      以字节为单位返回此内存池的使用阈值。
      long getUsageThresholdCount​()
      返回内存使用量超过使用率阈值的次数。
      boolean isCollectionUsageThresholdExceeded​()
      测试Java虚拟机所耗费的最新集合之后的内存池的内存使用情况是否已达到或超过其集合使用率阈值。
      boolean isCollectionUsageThresholdSupported​()
      测试此内存池是否支持集合使用阈值。
      boolean isUsageThresholdExceeded​()
      测试此内存池的内存使用情况是否达到或超过其使用阈值。
      boolean isUsageThresholdSupported​()
      测试此内存池是否支持使用阈值。
      boolean isValid​()
      测试此内存池是否在Java虚拟机中有效。
      void resetPeakUsage​()
      将此内存池的高峰内存使用率统计信息重置为当前内存使用情况。
      void setCollectionUsageThreshold​(long threshold)
      将此内存池的收集使用阈值设置为给定的 threshold值。
      void setUsageThreshold​(long threshold)
      如果此内存池支持使用阈值，则将此内存池的阈值设置为给定的 threshold值。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getName

        String getName​()
        返回表示此内存池的名称。
        结果
        这个内存池的名称。

      • getType

        MemoryType getType​()
        返回此内存池的类型。

        MBeanServer访问 ：
        的映射类型MemoryType是String并且该值是所述的名称MemoryType 。

        结果
        这个内存池的类型。

      • getUsage

        MemoryUsage getUsage​()
        返回此内存池的内存使用情况的估计。 如果此内存池无效（即不再存在），此方法返回null 。

        此方法请求Java虚拟机尽力估计此内存池的当前内存使用情况。 对于一些内存池，该方法可能是一个昂贵的操作，需要一些计算来确定估计。 在这种情况下，实施应该记录。

        该方法设计用于监控系统内存使用情况和检测低内存条件。

        MBeanServer访问 ：
        MemoryUsage的映射类型为CompositeData ，其属性如MemoryUsage中所述 。

        结果
        一个MemoryUsage对象; 或null如果此池无效。

      • getPeakUsage

        MemoryUsage getPeakUsage​()
        从Java虚拟机启动或从峰值重置以来，返回此内存池的高峰内存使用情况。 如果此内存池无效（即不再存在），此方法返回null 。

        MBeanServer访问 ：
        MemoryUsage的映射类型为CompositeData ，其属性如MemoryUsage中所述 。

        结果
        表示峰值内存使用的MemoryUsage对象; 或null如果此池无效。

      • resetPeakUsage

        void resetPeakUsage​()
        将此内存池的高峰内存使用率统计信息重置为当前内存使用情况。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。

      • isValid

        boolean isValid​()
        测试此内存池是否在Java虚拟机中有效。 一旦Java虚拟机将其从内存系统中删除，内存池将变为无效。
        结果
        true如果内存池在正在运行的Java虚拟机中有效; 否则为false 。

      • getMemoryManagerNames

        String[] getMemoryManagerNames​()
        返回管理此内存池的内存管理器的名称。 每个内存池将由至少一个内存管理器管理。
        结果
        一组 String对象，每个都是管理此内存池的内存管理器的名称。

      • getUsageThreshold

        long getUsageThreshold​()
        以字节为单位返回此内存池的使用阈值。 每个内存池具有平台相关的默认阈值。 可以通过setUsageThreshold方法更改当前使用阈值。
        结果
        该内存池的使用阈值以字节为单位。
        异常
        UnsupportedOperationException - 如果此内存池不支持使用阈值。
        另请参见：
        isUsageThresholdSupported()

      • setUsageThreshold

        void setUsageThreshold​(long threshold)
        如果此内存池支持使用阈值，则将此内存池的阈值设置为给定的threshold值。 如果阈值设置为正值，则在该内存池中启用使用阈值交叉检查。 如果设置为零，则禁用使用阈值交叉检查。
        参数
        threshold - 新的阈值（以字节为单位）。 必须是非负数。
        异常
        IllegalArgumentException - 如果 threshold为负数或大于此内存池的最大内存量（如果已定义）。
        UnsupportedOperationException - 如果此内存池不支持使用阈值。
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。
        另请参见：
        isUsageThresholdSupported() ， Usage threshold

      • isUsageThresholdExceeded

        boolean isUsageThresholdExceeded​()
        测试此内存池的内存使用情况是否达到或超过其使用阈值。
        结果
        如果该内存池的内存使用量达到或超过阈值， true ; 否则为false 。
        异常
        UnsupportedOperationException - 如果此内存池不支持使用阈值。

      • getUsageThresholdCount

        long getUsageThresholdCount​()
        返回内存使用量超过使用率阈值的次数。
        结果
        内存使用量超过其使用阈值的次数。
        异常
        UnsupportedOperationException - 如果此内存池不支持使用阈值。

      • isUsageThresholdSupported

        boolean isUsageThresholdSupported​()
        测试此内存池是否支持使用阈值。
        结果
        true如果此内存池支持使用阈值; 否则为false 。

      • getCollectionUsageThreshold

        long getCollectionUsageThreshold​()
        以字节为单位返回此内存池的集合使用阈值。 默认值为零。 可以通过setCollectionUsageThreshold方法更改收集使用阈值。
        结果
        此内存池的收集使用阈值（以字节为单位）。
        异常
        UnsupportedOperationException - 如果此内存池不支持集合使用阈值。
        另请参见：
        isCollectionUsageThresholdSupported()

      • setCollectionUsageThreshold

        void setCollectionUsageThreshold​(long threshold)
        将此内存池的集合使用阈值设置为给定的threshold值。 当此阈值设置为正值时，Java虚拟机将在其在回收此内存池中未使用的对象的努力之后，在其最佳适当时间内检查内存使用情况。

        如果阈值设置为正值，则在此内存池中启用集合使用阈值交叉检查。 如果设置为零，则禁用集合使用阈值交叉检查。

        参数
        threshold - 新的集合使用阈值（以字节为单位）。 必须是非负数。
        异常
        IllegalArgumentException - 如果 threshold为负数或大于此内存池的最大内存量（如果已定义）。
        UnsupportedOperationException - 如果此内存池不支持集合使用阈值。
        SecurityException - 如果安全管理器存在，并且调用者没有ManagementPermission（“控制”）。
        另请参见：
        isCollectionUsageThresholdSupported() ， Collection usage threshold

      • isCollectionUsageThresholdExceeded

        boolean isCollectionUsageThresholdExceeded​()
        测试Java虚拟机所耗费的最新集合之后的内存池的内存使用情况是否已达到或超过其集合使用率阈值。 该方法不要求Java虚拟机执行除正常自动内存管理之外的任何垃圾收集。
        结果
        true如果此内存池的内存使用量达到或超过最近集合中的集合使用阈值; 否则为false 。
        异常
        UnsupportedOperationException - 如果此内存池不支持使用阈值。

      • getCollectionUsageThresholdCount

        long getCollectionUsageThresholdCount​()
        返回Java虚拟机检测到内存使用量达到或超过集合使用率阈值的次数。
        结果
        内存使用量达到或超过集合使用率阈值的次数。
        异常
        UnsupportedOperationException - 如果此内存池不支持集合使用阈值。
        另请参见：
        isCollectionUsageThresholdSupported()

      • getCollectionUsage

        MemoryUsage getCollectionUsage​()
        返回Java虚拟机最近花费在回收此内存池中未使用对象的努力后的内存使用情况。 该方法不要求Java虚拟机执行除正常自动内存管理之外的任何垃圾收集。 如果Java虚拟机不支持此方法，则此方法返回null 。

        MBeanServer访问 ：
        MemoryUsage的映射类型为CompositeData ，其属性在MemoryUsage中指定。

        结果
        一个MemoryUsage表示Java虚拟机最近花费在回收未使用对象之后努力的内存池的内存使用情况; null如果不支持此方法。

      • isCollectionUsageThresholdSupported

        boolean isCollectionUsageThresholdSupported​()
        测试此内存池是否支持集合使用阈值。
        结果
        true如果此内存池支持集合使用阈值; 否则为false 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MemoryType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.management
软件包 java.lang.management

Enum MemoryType

  • java.lang.Object
    • java.lang.Enum<MemoryType>
      • java.lang.management.MemoryType
  • All Implemented Interfaces:
    Serializable ， Comparable<MemoryType>

    public enum MemoryType
extends Enum<MemoryType>
    类型memory pools 。
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      HEAP
      堆内存类型。
      NON_HEAP
      非堆内存类型。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String toString​()
      返回此 MemoryType的字符串表示 MemoryType 。
      static MemoryType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MemoryType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • HEAP

        public static final MemoryType HEAP
        堆内存类型。

        Java虚拟机有一个堆 ，它是运行时数据区域，从中分配了所有类实例和数组的内存。

      • NON_HEAP

        public static final MemoryType NON_HEAP
        非堆内存类型。

        Java虚拟机管理堆以外的内存（称为非堆内存 ）。 非堆内存包括Java虚拟机的内部处理或优化所需的方法区域和内存。 它存储每个类的结构，例如运行时常量池，字段和方法数据，以及方法和构造函数的代码。

    • 方法详细信息

      • values

        public static MemoryType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (MemoryType c : MemoryType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static MemoryType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • toString

        public String toString​()
        返回此 MemoryType的字符串表示 MemoryType 。
        重写：
        toString在 Enum<MemoryType>
        结果
        该字符串表示为 MemoryType 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


MemoryUsage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Class MemoryUsage

  • java.lang.Object
    • java.lang.management.MemoryUsage

  • public class MemoryUsage
extends Object
    MemoryUsage对象表示内存使用的快照。 MemoryUsage类的实例通常由用于获取关于Java虚拟机的单个内存池或整个Java虚拟机的堆或非堆内存的内存使用信息的方法构建。

    A MemoryUsage对象包含四个值：

    Describes the MemoryUsage object content init represents the initial amount of memory (in bytes) that the Java virtual machine requests from the operating system for memory management during startup. The Java virtual machine may request additional memory from the operating system and may also release memory to the system over time. The value of init may be undefined. used represents the amount of memory currently used (in bytes). committed represents the amount of memory (in bytes) that is guaranteed to be available for use by the Java virtual machine. The amount of committed memory may change over time (increase or decrease). The Java virtual machine may release memory to the system and committed could be less than init. committed will always be greater than or equal to used. max represents the maximum amount of memory (in bytes) that can be used for memory management. Its value may be undefined. The maximum amount of memory may change over time if defined. The amount of used and committed memory will always be less than or equal to max if max is defined. A memory allocation may fail if it attempts to increase the used memory such that used > committed even if used <= max would still be true (for example, when the system is low on virtual memory).
    以下是显示内存池示例的图片：
      +----------------------------------------------+
        +////////////////           |                  +
        +////////////////           |                  +
        +----------------------------------------------+

        |--------|
           init
        |---------------|
               used
        |---------------------------|
                  committed
        |----------------------------------------------|
                            max

    MXBean映射

    MemoryUsage被映射到CompositeData作为指定具有属性from方法。
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      MemoryUsage​(long init, long used, long committed, long max)
      构造一个 MemoryUsage对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static MemoryUsage from​(CompositeData cd)
      返回由给定的 CompositeData表示的 MemoryUsage对象。
      long getCommitted​()
      返回为Java虚拟机提供的内存量（以字节计）。
      long getInit​()
      返回Java虚拟机最初从操作系统请求进行内存管理的以字节为单位的内存量。
      long getMax​()
      返回可用于内存管理的最大内存量（以字节为单位）。
      long getUsed​()
      以字节为单位返回使用的内存量。
      String toString​()
      返回此内存使用情况的描述性表示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MemoryUsage

        public MemoryUsage​(long init,
                   long used,
                   long committed,
                   long max)
        构造一个 MemoryUsage对象。
        参数
        init - Java虚拟机分配的初始内存量（以字节为单位） 或-1如果未定义。
        used - 以字节为单位的已用内存量。
        committed - 提交的内存量（以字节为单位）。
        max - 可以使用的最大内存量（以字节为单位） 或-1如果未定义。
        异常
        IllegalArgumentException - 如果
        • init或max值为负数，而不是-1 ; 要么
        • used或committed值为负数; 要么
        • used大于值committed ; 要么
        • committed如果被定义，大于max max的值。

    • 方法详细信息

      • getInit

        public long getInit​()
        返回Java虚拟机最初从操作系统请求进行内存管理的以字节为单位的内存量。 如果初始内存大小未定义，则此方法返回-1 。
        结果
        内存的初始大小（以字节为单位） -1如果未定义。

      • getUsed

        public long getUsed​()
        以字节为单位返回使用的内存量。
        结果
        使用的内存量（以字节为单位）。

      • getCommitted

        public long getCommitted​()
        返回为Java虚拟机提供的内存量（以字节计）。 Java虚拟机可以使用这种内存量。
        结果
        提交的内存量以字节为单位。

      • getMax

        public long getMax​()
        返回可用于内存管理的最大内存量（以字节为单位）。 如果最大内存大小未定义，则此方法返回-1 。

        如果内存量大于已提交内存量，则不能保证此内存量可用于内存管理。 即使所使用的内存量不超过此最大大小，Java虚拟机也可能无法分配内存。

        结果
        最大内存量（以字节为单位） -1如果未定义。

      • toString

        public String toString​()
        返回此内存使用情况的描述性表示。
        重写：
        toString在 Object
        结果
        对象的字符串表示形式。

      • from

        public static MemoryUsage from​(CompositeData cd)
        返回由给定的CompositeData表示的MemoryUsage对象。 给定的CompositeData必须包含以下属性：
        The attributes and the types the given CompositeData contains
        Attribute Name | Type
        init | java.lang.Long
        used | java.lang.Long
        committed | java.lang.Long
        max | java.lang.Long
        参数
        cd - CompositeData代表 MemoryUsage
        结果
        一个MemoryUsage通过表示对象cd如果cd不是null ; 否则为null 。
        异常
        IllegalArgumentException - 如果 cd不代表具有上述属性的 MemoryUsage 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MonitorInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Class MonitorInfo

  • java.lang.Object
    • java.lang.management.LockInfo
      • java.lang.management.MonitorInfo

  • public class MonitorInfo
extends LockInfo
    有关对象监视器锁的信息。 在该对象上输入同步块或方法时，对象监视器被锁定。

    MXBean映射

    MonitorInfo被映射到CompositeData作为指定具有属性from方法。
    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      MonitorInfo​(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)
      构造一个 MonitorInfo对象。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static MonitorInfo from​(CompositeData cd)
      返回由给定的 CompositeData表示的 MonitorInfo对象。
      int getLockedStackDepth​()
      返回堆栈跟踪中对象监视器被锁定的深度。
      StackTraceElement getLockedStackFrame​()
      返回锁定对象监视器的堆栈帧。

      • Methods inherited from class java.lang.management.LockInfo

        getClassName, getIdentityHashCode, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MonitorInfo

        public MonitorInfo​(String className,
                   int identityHashCode,
                   int stackDepth,
                   StackTraceElement stackFrame)
        构造一个 MonitorInfo对象。
        参数
        className - 锁定对象的类的完全限定名称。
        identityHashCode - 锁定对象的 identity hash code 。
        stackDepth - 对象监视器被锁定的堆栈跟踪中的深度。
        stackFrame - 锁定对象监视器的堆栈框架。
        异常
        IllegalArgumentException - 如果 stackDepth 0，但 stackFrame为 null ，或 stackDepth <0，但 stackFrame不为 null 。

    • 方法详细信息

      • getLockedStackDepth

        public int getLockedStackDepth​()
        返回堆栈跟踪中对象监视器被锁定的深度。 深度是ThreadInfo.getStackTrace()方法返回的StackTraceElement数组的索引。
        结果
        堆栈跟踪中对象监视器被锁定的深度，或负数，如果不可用。

      • getLockedStackFrame

        public StackTraceElement getLockedStackFrame​()
        返回锁定对象监视器的堆栈帧。
        结果
        StackTraceElement锁定对象监视器，或 null如果不可用）。

      • from

        public static MonitorInfo from​(CompositeData cd)
        返回由给定的CompositeData表示的MonitorInfo对象。 给定的CompositeData必须包含以下属性以及LockInfo类别中的mapped type中指定的属性：
        The attributes and their types the given CompositeData contains
        Attribute Name | Type
        lockedStackFrame | CompositeData as specified in the stackTrace attribute defined in the ThreadInfo.from method.
        lockedStackDepth | java.lang.Integer
        参数
        cd - CompositeData代表 MonitorInfo
        结果
        一个MonitorInfo通过表示对象cd如果cd不是null ; null否则。
        异常
        IllegalArgumentException - 如果 cd不代表具有上述属性的 MonitorInfo 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


OperatingSystemMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface OperatingSystemMXBean

  • All Superinterfaces:
    PlatformManagedObject
    All Known Subinterfaces:
    OperatingSystemMXBean ， UnixOperatingSystemMXBean

    public interface OperatingSystemMXBean
extends PlatformManagedObject
    运行Java虚拟机的操作系统的管理界面。

    Java虚拟机具有此接口的实现类的单个实例。 实现此接口的实例是一个MXBean ，可以通过调用ManagementFactory.getOperatingSystemMXBean()方法或从platform MBeanServer方法获得。

    用于在MBeanServer中唯一标识操作系统的MXBean的ObjectName是：

    java.lang:type=OperatingSystem
    可以通过调用PlatformManagedObject.getObjectName()方法获得。

    该接口定义了几个方便的方法来访问有关运行Java虚拟机的操作系统的系统属性。

    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getArch​()
      返回操作系统架构。
      int getAvailableProcessors​()
      返回可用于Java虚拟机的处理器数量。
      String getName​()
      返回操作系统名称。
      double getSystemLoadAverage​()
      返回最后一分钟的系统负载平均值。
      String getVersion​()
      返回操作系统版本。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getName

        String getName​()
        返回操作系统名称。 此方法相当于System.getProperty("os.name") 。
        结果
        操作系统名称。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getArch

        String getArch​()
        返回操作系统架构。 此方法相当于System.getProperty("os.arch") 。
        结果
        操作系统架构。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getVersion

        String getVersion​()
        返回操作系统版本。 此方法相当于System.getProperty("os.version") 。
        结果
        操作系统版本。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getAvailableProcessors

        int getAvailableProcessors​()
        返回可用于Java虚拟机的处理器数量。 这种方法相当于Runtime.availableProcessors()方法。

        在虚拟机的特定调用期间，此值可能会更改。

        结果
        虚拟机可用的处理器数量; 从不小于一个。

      • getSystemLoadAverage

        double getSystemLoadAverage​()
        返回最后一分钟的系统负载平均值。 系统负载平均值是排队到available processors的可运行实体的数量和在一段时间内平均的可用处理器上运行的可运行实体的数量之和。 计算负载平均值的方式是操作系统特定的，但通常是阻尼的时间依赖平均值。

        如果负载平均值不可用，则返回负值。

        该方法旨在提供有关系统负载的提示，并可能经常查询。 负载平均可能在实现这种方法昂贵的某些平台上是不可用的。

        结果
        系统负载平均; 或如果不可用，则为负值。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PlatformLoggingMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface PlatformLoggingMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface PlatformLoggingMXBean
extends PlatformManagedObject
    logging设施的管理界面。

    PlatformLoggingMXBean有一个全局实例。 ManagementFactory.getPlatformMXBean方法可用于获取PlatformLoggingMXBean对象，如下所示：

      PlatformLoggingMXBean logging = ManagementFactory.getPlatformMXBean(PlatformLoggingMXBean.class);
    该PlatformLoggingMXBean对象也注册到平台MBeanServer 。 该ObjectName用于唯一地识别PlatformLoggingMXBean MBeanServer中是：
      java.util.logging:type=Logging
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getLoggerLevel​(String loggerName)
      获取与指定记录器关联的日志 level的名称。
      List<String> getLoggerNames​()
      返回当前注册的logger名称的列表。
      String getParentLoggerName​(String loggerName)
      返回指定记录器的 parent的名称。
      void setLoggerLevel​(String loggerName, String levelName)
      将指定的记录器设置为指定的新的 level 。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getLoggerNames

        List<String> getLoggerNames​()
        返回当前注册的logger名称的列表。 该方法调用LogManager.getLoggerNames()并返回一个记录器名称列表。
        结果
        一份 String的名单，目前已注册 Logger 。

      • getLoggerLevel

        String getLoggerLevel​(String loggerName)
        获取与指定记录器关联的日志level的名称。 如果指定的记录器不存在，则返回null 。 此方法首先找到给定名称的记录器，然后通过调用以下命令返回日志级别的名称：
        Logger.getLevel(). getName();

        如果Level指定logger是null ，这意味着此logger的有效级别从其父继承，一个空字符串将被退回。

        参数
        loggerName - 要检索的 Logger的名称。
        结果
        指定记录器的日志级别的名称; 如果指定的记录器的日志级别为null空字符串。 如果指定的记录器不存在，则返回null 。
        另请参见：
        Logger.getLevel()

      • setLoggerLevel

        void setLoggerLevel​(String loggerName,
                    String levelName)
        将指定的记录器设置为指定的新的level 。 如果levelName不是null ，指定logger的级别设置为解析Level匹配levelName 。 如果levelName为null ，则指定记录器的级别设置为null并且记录器的有效级别从具有（非空）级别值的最近祖先继承。
        参数
        loggerName - 要设置的Logger的名称。 必须非空。
        levelName - 在指定记录器上设置的级别的名称，如果将级别设置为从其最近的祖先继承， null 。
        异常
        IllegalArgumentException - 如果指定的记录器不存在，或者 levelName不是有效的级别名称。
        SecurityException - 如果安全管理器存在，并且调用者没有LoggingPermission（“control”）。
        另请参见：
        Logger.setLevel(java.util.logging.Level)

      • getParentLoggerName

        String getParentLoggerName​(String loggerName)
        返回指定记录器的parent的名称。 如果指定的记录器不存在，则返回null 。 如果指定的记录器是命名空间中的根Logger ，结果将是一个空字符串。
        参数
        loggerName - 一个 Logger的名字。
        结果
        最近的现有父记录器的名称; 一个空字符串，如果指定的记录器是根记录器。 如果指定的记录器不存在，则返回null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PlatformManagedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface PlatformManagedObject

  • All Known Subinterfaces:
    BufferPoolMXBean ， ClassLoadingMXBean ， CompilationMXBean ， GarbageCollectorMXBean ， GarbageCollectorMXBean ， HotSpotDiagnosticMXBean ， MemoryManagerMXBean ， MemoryMXBean ， MemoryPoolMXBean ， OperatingSystemMXBean ， OperatingSystemMXBean ， PlatformLoggingMXBean ， RuntimeMXBean ， ThreadMXBean ， ThreadMXBean ， UnixOperatingSystemMXBean

    public interface PlatformManagedObject
    平台管理对象是用于监视和管理Java平台中的组件的JMX MXBean 。 每个平台的管理对象都有一个独特的object name用于platform MBeanServer访问。 所有平台MXBeans都将实现此接口。

    注意：平台MXBean接口（即PlatformManagedObject所有子接口）仅由Java平台实现。 未来的Java SE版本可能会在这些接口中添加新的方法。 此外，此PlatformManagedObject接口仅适用于平台的管理界面，但不适用于应用程序。

    从以下版本开始：
    1.7
    另请参见：
    ManagementFactory

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ObjectName getObjectName​()
      返回表示此平台管理对象的对象名称的ObjectName实例。

    • 方法详细信息

      • getObjectName

        ObjectName getObjectName​()
        返回表示此平台管理对象的对象名称的ObjectName实例。
        结果
        an ObjectName instance representing the object name of this platform managed object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RuntimeMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface RuntimeMXBean

  • All Superinterfaces:
    PlatformManagedObject

    public interface RuntimeMXBean
extends PlatformManagedObject
    Java虚拟机的运行时系统的管理界面。

    Java虚拟机具有此接口的实现类的单个实例。 这种情况下实现此接口是MXBean ，可以通过调用能够得到ManagementFactory.getRuntimeMXBean()方法或从platform MBeanServer方法。

    用于唯一标识MBeanServer中运行时系统的MXBean的ObjectName是：

    java.lang:type=Runtime
    可以通过调用PlatformManagedObject.getObjectName()方法获得。

    该界面定义了访问Java虚拟机的系统属性的几种方便的方法。

    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getBootClassPath​()
      返回bootstrap类加载器用于搜索类文件的引导类路径。
      String getClassPath​()
      返回系统类加载器用于搜索类文件的Java类路径。
      List<String> getInputArguments​()
      返回传递给Java虚拟机的输入参数，该虚拟机不包括 main方法的参数。
      String getLibraryPath​()
      返回Java库路径。
      String getManagementSpecVersion​()
      返回由运行的Java虚拟机实现的管理接口的规范版本。
      String getName​()
      返回表示正在运行的Java虚拟机的名称。
      String getSpecName​()
      返回Java虚拟机规范名称。
      String getSpecVendor​()
      返回Java虚拟机规范供应商。
      String getSpecVersion​()
      返回Java虚拟机规范版本。
      long getStartTime​()
      以毫秒为单位返回Java虚拟机的开始时间。
      Map<String,String> getSystemProperties​()
      返回所有系统属性的名称和值的映射。
      long getUptime​()
      以毫秒为单位返回Java虚拟机的正常运行时间。
      String getVmName​()
      返回Java虚拟机实现名称。
      String getVmVendor​()
      返回Java虚拟机实现供应商。
      String getVmVersion​()
      返回Java虚拟机实现版本。
      boolean isBootClassPathSupported​()
      测试Java虚拟机是否支持bootstrap类加载器用于搜索类文件的引导类路径机制。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getName

        String getName​()
        返回表示正在运行的Java虚拟机的名称。 返回的名称字符串可以是任意任意的字符串，Java虚拟机实现可以选择在返回的名称字符串中嵌入特定于平台的有用信息。 每个正在运行的虚拟机可能有不同的名称。
        结果
        代表正在运行的Java虚拟机的名称。

      • getVmName

        String getVmName​()
        返回Java虚拟机实现名称。 这个方法相当于System.getProperty("java.vm.name") 。
        结果
        Java虚拟机实现名称。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getVmVendor

        String getVmVendor​()
        返回Java虚拟机实现供应商。 此方法相当于System.getProperty("java.vm.vendor") 。
        结果
        Java虚拟机实现供应商。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getVmVersion

        String getVmVersion​()
        返回Java虚拟机实现版本。 此方法相当于System.getProperty("java.vm.version") 。
        结果
        Java虚拟机实现版本。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getSpecName

        String getSpecName​()
        返回Java虚拟机规范名称。 此方法相当于System.getProperty("java.vm.specification.name") 。
        结果
        Java虚拟机规范名称。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getSpecVendor

        String getSpecVendor​()
        返回Java虚拟机规范供应商。 此方法相当于System.getProperty("java.vm.specification.vendor") 。
        结果
        Java虚拟机规范供应商。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getSpecVersion

        String getSpecVersion​()
        返回Java虚拟机规范版本。 这个方法相当于System.getProperty("java.vm.specification.version") 。
        结果
        Java虚拟机规范版本。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getManagementSpecVersion

        String getManagementSpecVersion​()
        返回由运行的Java虚拟机实现的管理接口的规范版本。
        结果
        由运行的Java虚拟机实现的管理接口的规范版本。

      • getClassPath

        String getClassPath​()
        返回系统类加载器用于搜索类文件的Java类路径。 此方法相当于System.getProperty("java.class.path") 。

        Java类路径中的多个路径由被监视的Java虚拟机的平台的路径分隔符分隔。

        结果
        Java类路径。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • getLibraryPath

        String getLibraryPath​()
        返回Java库路径。 此方法相当于System.getProperty("java.library.path") 。

        Java库路径中的多个路径由被监视的Java虚拟机的平台的路径分隔符分隔。

        结果
        Java库路径。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问此系统属性。
        另请参见：
        SecurityManager.checkPropertyAccess(java.lang.String) ， System.getProperty(java.lang.String)

      • isBootClassPathSupported

        boolean isBootClassPathSupported​()
        测试Java虚拟机是否支持bootstrap类加载器用于搜索类文件的引导类路径机制。
        结果
        true如果Java虚拟机支持类路径机制; 否则为false 。

      • getBootClassPath

        String getBootClassPath​()
        返回bootstrap类加载器用于搜索类文件的引导类路径。

        引导类路径中的多个路径由运行Java虚拟机的平台的路径分隔符分隔。

        Java虚拟机实现可能不支持bootstrap类加载器搜索类文件的引导类路径机制。 可以使用isBootClassPathSupported()方法来确定Java虚拟机是否支持此方法。

        结果
        引导类路径。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持此操作。
        SecurityException - 如果安全管理器存在，并且调用者没有ManagementPermission（“监视器”）。

      • getInputArguments

        List<String> getInputArguments​()
        返回传递给Java虚拟机的输入参数，该参数不包括main方法的参数。 如果Java虚拟机没有输入参数，则此方法返回一个空列表。

        一些Java虚拟机实现可以从多个不同的来源获取输入参数：例如，从启动Java虚拟机的应用程序传递的参数，例如“java”命令，环境变量，配置文件等。

        通常，“java”命令的所有命令行选项都不会传递给Java虚拟机。 因此，返回的输入参数可能不包括所有命令行选项。

        MBeanServer访问 ：
        List<String>的映射类型为String[] 。

        结果
        一个String对象的列表; 每个元素都是传递给Java虚拟机的参数。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“监视器”）。

      • getUptime

        long getUptime​()
        以毫秒为单位返回Java虚拟机的正常运行时间。
        结果
        Java虚拟机的正常运行时间（以毫秒为单位）。

      • getStartTime

        long getStartTime​()
        以毫秒为单位返回Java虚拟机的开始时间。 此方法返回Java虚拟机启动时的大致时间。
        结果
        Java虚拟机的开始时间（以毫秒为单位）。

      • getSystemProperties

        Map<String,String> getSystemProperties​()
        返回所有系统属性的名称和值的映射。 此方法调用System.getProperties()获取所有系统属性。 名称或值不是String被省略。

        MBeanServer访问 ：
        的映射类型Map<String,String>是TabularData与每行中的如下两个项目：

        Name and Type for each item
        Item Name | Item Type
        key | String
        value | String
        结果
        所有系统属性的名称和值的映射。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPropertiesAccess方法不允许访问系统属性。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Class ThreadInfo

  • java.lang.Object
    • java.lang.management.ThreadInfo

  • public class ThreadInfo
extends Object
    线程信息。 ThreadInfo包含有关线程的信息，包括：

    一般线程信息

    • 线程ID。
    • 线程名称
    • 线程是否是守护线程

    执行信息

    • 线程状态。
    • 由于以下原因导致线程被阻塞的对象：
      • 等待输入同步块/方法，或
      • 等待通过Object.wait方法通知，或
      • 由于LockSupport.park电话停车。
    • 拥有线程被阻止的对象的线程的ID。
    • 堆栈跟踪的线程。
    • 由线程锁定的对象监视器列表。
    • 列表ownable synchronizers被线程锁定。
    • 线程优先级

    Synchronization Statistics

    • 线程阻塞同步或等待通知的次数。
    • 自启用thread contention monitoring以来，线程已阻止同步或等待通知的累积经过时间。 某些Java虚拟机实现可能不支持此功能。 可以使用ThreadMXBean.isThreadContentionMonitoringSupported()方法来确定Java虚拟机是否支持此功能。

    该线程信息类设计用于监视系统，不用于同步控制。

    MXBean映射

    ThreadInfo被映射到CompositeData作为指定具有属性from方法。
    从以下版本开始：
    1.5
    另请参见：
    ThreadMXBean.getThreadInfo(long) ， ThreadMXBean.dumpAllThreads(boolean, boolean)

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static ThreadInfo from​(CompositeData cd)
      返回由给定的 CompositeData表示的 ThreadInfo对象。
      long getBlockedCount​()
      返回与此 ThreadInfo相关联的线程阻止进入或重新输入监视器的总次数。
      long getBlockedTime​()
      返回与启用线程争用监控功能相关联的与此 ThreadInfo相关联的线程阻止进入或重新输入监视器的大致累积已用时间（以毫秒为单位）。
      MonitorInfo[] getLockedMonitors​()
      返回一个MonitorInfo个对象的数组，每个对象表示当前由与此ThreadInfo相关联的线程锁定的对象监视器。
      LockInfo[] getLockedSynchronizers​()
      返回的数组LockInfo对象，每个对象的表示ownable synchronizer当前由与此相关联的线程锁定ThreadInfo 。
      LockInfo getLockInfo​()
      返回一个对象的 LockInfo ，该对象与此 ThreadInfo相关联的线程被阻止等待。
      String getLockName​()
      返回 string representation ，与此相关的线程的对象的 ThreadInfo被阻塞等待。
      long getLockOwnerId​()
      返回拥有与此 ThreadInfo相关联的线程被阻止等待的对象的线程的ID。
      String getLockOwnerName​()
      返回拥有与此 ThreadInfo相关联的线程被阻止等待的对象的线程的名称。
      int getPriority​()
      返回 thread priority与此相关的线程 ThreadInfo 。
      StackTraceElement[] getStackTrace​()
      返回与此 ThreadInfo相关联的线程的堆栈跟踪。
      long getThreadId​()
      返回与此 ThreadInfo相关联的线程的ID。
      String getThreadName​()
      返回与此 ThreadInfo相关联的线程的名称。
      Thread.State getThreadState​()
      返回与此 ThreadInfo相关联的线程的状态。
      long getWaitedCount​()
      返回与此 ThreadInfo相关联的线程等待通知的总次数。
      long getWaitedTime​()
      返回与此 ThreadInfo相关联的线程等待通知的大致累积经过时间（以毫秒为单位），因为启用了线程争用监控。
      boolean isDaemon​()
      测试与此 ThreadInfo相关联的线程是否为 daemon thread 。
      boolean isInNative​()
      测试与此 ThreadInfo相关联的线程是否通过Java Native Interface（JNI）执行本机代码。
      boolean isSuspended​()
      测试与此 ThreadInfo相关联的线程是否暂停。
      String toString​()
      返回此线程信息的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getThreadId

        public long getThreadId​()
        返回与此 ThreadInfo相关联的线程的ID。
        结果
        相关线程的ID。

      • getThreadName

        public String getThreadName​()
        返回与此 ThreadInfo相关联的线程的名称。
        结果
        相关线程的名称。

      • getThreadState

        public Thread.State getThreadState​()
        返回与此 ThreadInfo相关联的线程的状态。
        结果
        Thread.State的相关线程。

      • getBlockedTime

        public long getBlockedTime​()
        返回与此ThreadInfo相关联的线程已阻止进入或重新进入监视器的线程争用监视的大致累积经过时间（以毫秒为单位），因为线程争用监视已启用。 即线程争用监控最后一次启用后线程已经处于BLOCKED状态的总累计时间。 如果线程争用监控被禁用，此方法返回-1 。

        Java虚拟机可以使用高分辨率定时器来测量时间。 当重新启用线程争用监控时，此统计信息将重置。

        结果
        线程进入BLOCKED状态的近似累计消耗时间（以毫秒为单位）; -1如果线程争用监控被禁用。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持此操作。
        另请参见：
        ThreadMXBean.isThreadContentionMonitoringSupported() ， ThreadMXBean.setThreadContentionMonitoringEnabled(boolean)

      • getBlockedCount

        public long getBlockedCount​()
        返回与此ThreadInfo关联的线程阻塞进入或重新输入监视器的总次数。 也就是线程已经处于BLOCKED状态的次数。
        结果
        线程进入 BLOCKED状态的总次数。

      • getWaitedTime

        public long getWaitedTime​()
        返回与此ThreadInfo相关联的线程等待通知的大致累积经过时间（以毫秒为单位），因为启用了线程争用监控。 即线程争用监控启用后，线程已经处于WAITING或TIMED_WAITING状态的总累计时间。 如果线程争用监控被禁用，此方法返回-1 。

        Java虚拟机可以使用高分辨率定时器来测量时间。 当重新启用线程争用监控时，此统计信息将重置。

        结果
        线程已处于WAITING或TIMED_WAITING状态的大致累计消耗时间（以毫秒为单位）; -1如果线程争用监控被禁用。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持此操作。
        另请参见：
        ThreadMXBean.isThreadContentionMonitoringSupported() ， ThreadMXBean.setThreadContentionMonitoringEnabled(boolean)

      • getWaitedCount

        public long getWaitedCount​()
        返回与此ThreadInfo关联的线程等待通知的总次数。 即线程在WAITING或TIMED_WAITING状态下的次数。
        结果
        线程在 WAITING或 TIMED_WAITING状态的总次数。

      • getLockInfo

        public LockInfo getLockInfo​()
        返回LockInfo ，与此相关的线程的对象的ThreadInfo被阻塞等待。 一个线程可以被阻止等待以下之一：
        • 要获取用于输入或重新进入同步块/方法的对象监视器。
          线程处于BLOCKED状态，等待输入synchronized语句或方法。
        • 一个对象监视器被另一个线程通知。
          线程在WAITING或TIMED_WAITING状态由于调用了Object.wait方法。
        • 负责线程停车的同步对象。
          线程在WAITING或TIMED_WAITING状态由于调用了LockSupport.park方法。 同步对象是从LockSupport.getBlocker方法返回的对象。 通常是ownable synchronizer或Condition 。

        该方法返回null如果线程不在上述任何一种情况。

        结果
        LockInfo的线程被阻塞等待的对象; 否则为null 。
        从以下版本开始：
        1.6

      • getLockName

        public String getLockName​()
        返回string representation ，与此相关的线程的对象的ThreadInfo被阻塞等待。 这个方法相当于调用：
         getLockInfo().toString()

        此方法将返回null如果此线程不阻塞等待任何对象或者对象不是任何线程所有。

        结果
        线程阻塞的对象的字符串表示; 否则为null 。
        另请参见：
        getLockInfo()

      • getLockOwnerId

        public long getLockOwnerId​()
        返回拥有与此ThreadInfo相关联的线程被阻止等待的对象的线程的ID。 此方法将返回-1如果此线程不阻塞等待任何对象，或者该对象不是任何线程所有。
        结果
        该线程被阻止的对象的所有者线程的线程ID; -1如果此线程未被阻止或者该对象不是任何线程所有。
        另请参见：
        getLockInfo()

      • getLockOwnerName

        public String getLockOwnerName​()
        返回拥有与此ThreadInfo相关联的线程被阻止等待的对象的线程的名称。 此方法将返回null如果此线程不阻塞等待任何对象，或者该对象不是任何线程所有。
        结果
        拥有该线程被阻止的对象的线程的名称; null如果此线程未被阻止或者对象不是任何线程所有。
        另请参见：
        getLockInfo()

      • getStackTrace

        public StackTraceElement[] getStackTrace​()
        返回与该ThreadInfo相关联的线程的堆栈跟踪。 如果没有为此线程信息请求堆栈跟踪，则此方法将返回零长度数组。 如果返回的数组非零长度，则数组的第一个元素表示堆栈的顶部，这是序列中最近的方法调用。 数组的最后一个元素表示堆栈的底部，这是序列中最近最少的方法调用。

        在某些情况下，某些Java虚拟机可能会从堆栈跟踪中省略一个或多个堆栈帧。 在极端情况下，允许没有关于与该ThreadInfo相关联的线程的堆栈跟踪信息的虚拟机从该方法返回零长度数组。

        结果
        一个数组的 StackTraceElement对象的线程。

      • isSuspended

        public boolean isSuspended​()
        测试与此ThreadInfo相关联的线程是否暂停。 如果调用了Thread.suspend()，此方法返回true 。
        结果
        true如果线程暂停; false否则。

      • isInNative

        public boolean isInNative​()
        测试与此ThreadInfo相关联的线程是否通过Java Native Interface（JNI）执行本机代码。 JNI本机代码不包括虚拟机支持代码或虚拟机生成的已编译本机代码。
        结果
        true如果线程正在执行本机代码; false否则。

      • isDaemon

        public boolean isDaemon​()
        测试与此 ThreadInfo相关联的线程是否为 daemon thread 。
        结果
        true如果线程是守护线程，否则为 false 。
        从以下版本开始：
        9
        另请参见：
        Thread.isDaemon()

      • getPriority

        public int getPriority​()
        返回 thread priority与此相关的线程 ThreadInfo 。
        结果
        与此 ThreadInfo相关联的线程的优先级。
        从以下版本开始：
        9

      • toString

        public String toString​()
        返回此线程信息的字符串表示形式。 此字符串的格式取决于实现。 返回的字符串将通常包括thread name ，该thread ID ，其state和stack trace （如有）。
        重写：
        toString在 Object
        结果
        这个线程信息的字符串表示形式。

      • from

        public static ThreadInfo from​(CompositeData cd)
        返回由给定的CompositeData表示的ThreadInfo对象。 给定的CompositeData必须包含以下属性，除非另有规定：
        The attributes and their types the given CompositeData contains
        Attribute Name | Type
        threadId | java.lang.Long
        threadName | java.lang.String
        threadState | java.lang.String
        suspended | java.lang.Boolean
        inNative | java.lang.Boolean
        blockedCount | java.lang.Long
        blockedTime | java.lang.Long
        waitedCount | java.lang.Long
        waitedTime | java.lang.Long
        lockInfo javax.management.openmbean.CompositeData - the mapped type for LockInfo as specified in the LockInfo.from(javax.management.openmbean.CompositeData) method.

        If cd does not contain this attribute, the LockInfo object will be constructed from the value of the lockName attribute.

        lockName | java.lang.String
        lockOwnerId | java.lang.Long
        lockOwnerName | java.lang.String
        stackTrace javax.management.openmbean.CompositeData[]

        Each element is a CompositeData representing StackTraceElement containing the following attributes:

        The attributes and their types the given CompositeData contains
        Attribute Name | Type
        moduleName | java.lang.String
        moduleVersion | java.lang.String
        className | java.lang.String
        methodName | java.lang.String
        fileName | java.lang.String
        lineNumber | java.lang.Integer
        nativeMethod | java.lang.Boolean
        lockedMonitors javax.management.openmbean.CompositeData[] whose element type is the mapped type for MonitorInfo as specified in the Monitor.from method.

        If cd does not contain this attribute, this attribute will be set to an empty array.

        lockedSynchronizers javax.management.openmbean.CompositeData[] whose element type is the mapped type for LockInfo as specified in the LockInfo.from(javax.management.openmbean.CompositeData) method.

        If cd does not contain this attribute, this attribute will be set to an empty array.

        daemon | java.lang.Boolean
        priority | java.lang.Integer
        参数
        cd - CompositeData代表 ThreadInfo
        结果
        一个ThreadInfo对象由cd表示，如果cd不是null ; null否则。
        异常
        IllegalArgumentException - 如果 cd不表示具有上述属性的 ThreadInfo 。

      • getLockedMonitors

        public MonitorInfo[] getLockedMonitors​()
        返回一个MonitorInfo个对象的数组，每个对象表示当前由与此ThreadInfo相关联的线程锁定的对象监视器。 如果没有为此线程信息请求锁定的监视器，或者线程未锁定监视器，则此方法将返回零长度的数组。
        结果
        表示由线程锁定的对象监视器的 MonitorInfo对象的数组。
        从以下版本开始：
        1.6

      • getLockedSynchronizers

        public LockInfo[] getLockedSynchronizers​()
        返回的数组LockInfo对象，每个对象的表示ownable synchronizer当前由与此相关联的线程锁定ThreadInfo 。 如果没有为此线程信息请求锁定的同步器，或线程未锁定同步器，则此方法将返回零长度的数组。
        结果
        一组 LockInfo对象，表示线程锁定的自己的同步器。
        从以下版本开始：
        1.6
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ThreadMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.management
软件包 java.lang.management

Interface ThreadMXBean

  • All Superinterfaces:
    PlatformManagedObject
    All Known Subinterfaces:
    ThreadMXBean

    public interface ThreadMXBean
extends PlatformManagedObject
    Java虚拟机线程系统的管理界面。

    Java虚拟机具有此接口的实现类的单个实例。 这种情况下实现此接口是MXBean ，可以通过调用能够得到ManagementFactory.getThreadMXBean()方法或从platform MBeanServer方法。

    用于唯一标识MBeanServer中线程系统的MXBean的ObjectName是：

    java.lang:type=Threading
    可以通过调用PlatformManagedObject.getObjectName()方法获得。

    线程ID

    线程ID是通过为线程调用Thread.getId()方法返回的正长值。 线程ID在其一生中是唯一的。 当线程被终止时，该线程ID可以被重用。

    该接口中的一些方法采用线程ID或线程ID数组作为输入参数，并返回每线程信息。

    线程CPU时间

    Java虚拟机实现可以支持测量当前线程的CPU时间，对于任何线程，或者无线程。

    可以使用isThreadCpuTimeSupported()方法来确定Java虚拟机是否支持测量任何线程的CPU时间。 可以使用isCurrentThreadCpuTimeSupported()方法来确定Java虚拟机是否支持测量当前线程的CPU时间。 支持任何线程的CPU时间测量的Java虚拟机实现也将支持当前线程。

    该接口提供的CPU时间具有纳秒精度，但不一定是纳秒精度。

    默认情况下，Java虚拟机可能会禁用CPU时间测量。 isThreadCpuTimeEnabled()和setThreadCpuTimeEnabled(boolean)方法可用于测试是否启用CPU时间测量，并分别启用/禁用此支持。 在一些Java虚拟机实现中启用线程CPU测量可能是昂贵的。

    线程争用监控

    一些Java虚拟机可能支持线程争用监控。 当线程争用监控启用时，线程已阻止同步或等待通知的累计经过时间将被收集并返回给ThreadInfo对象。

    可以使用isThreadContentionMonitoringSupported()方法来确定Java虚拟机是否支持线程争用监控。 默认情况下禁用线程争用监控。 setThreadContentionMonitoringEnabled(boolean)方法可用于启用线程争用监控。

    同步信息和死锁检测

    一些Java虚拟机可能支持监视object monitor usage和ownable synchronizer usage 。 的getThreadInfo(long[], boolean, boolean)种dumpAllThreads(boolean, boolean)方法可用于获得包括所述线程堆栈跟踪和同步信息lock一个线程被阻塞以获取或等待上并锁定线程当前拥有。

    ThreadMXBean接口提供了findMonitorDeadlockedThreads()和findDeadlockedThreads()方法来查找正在运行的应用程序中的死锁。

    从以下版本开始：
    1.5
    另请参见：
    ManagementFactory.getPlatformMXBeans(Class) ， JMX Specification. ， Ways to Access MXBeans

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ThreadInfo[] dumpAllThreads​(boolean lockedMonitors, boolean lockedSynchronizers)
      使用堆栈跟踪和同步信息返回所有实时线程的线程信息。
      long[] findDeadlockedThreads​()
      查找处于死锁等待获取对象监视器的线程的周期，或 ownable synchronizers 。
      long[] findMonitorDeadlockedThreads​()
      查找处于死锁等待获取对象监视器的线程的循环。
      long[] getAllThreadIds​()
      返回所有活动线程ID。
      long getCurrentThreadCpuTime​()
      以纳秒为单位返回当前线程的总CPU时间。
      long getCurrentThreadUserTime​()
      返回当前线程以纳秒为单位在用户模式下执行的CPU时间。
      int getDaemonThreadCount​()
      返回当前的守护进程线程数。
      int getPeakThreadCount​()
      返回Java虚拟机启动或峰值复位后的峰值活动线程数。
      int getThreadCount​()
      返回当前线程数，包括守护进程线程和非守护程序线程数。
      long getThreadCpuTime​(long id)
      以纳秒为单位返回指定ID的线程的总CPU时间。
      ThreadInfo getThreadInfo​(long id)
      返回没有堆栈跟踪的指定 id的线程的线程信息。
      ThreadInfo[] getThreadInfo​(long[] ids)
      返回其ID位于输入数组 ids中的每个线程的线程信息，不带堆栈跟踪。
      ThreadInfo[] getThreadInfo​(long[] ids, boolean lockedMonitors, boolean lockedSynchronizers)
      返回其ID为输入数组 ids每个线程的线程信息，具有堆栈跟踪和同步信息。
      ThreadInfo[] getThreadInfo​(long[] ids, int maxDepth)
      返回其ID位于输入数组 ids中的每个线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素。
      ThreadInfo getThreadInfo​(long id, int maxDepth)
      返回指定 id的线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素。
      long getThreadUserTime​(long id)
      返回指定ID的线程在用户模式下以纳秒为单位的CPU时间。
      long getTotalStartedThreadCount​()
      返回自Java虚拟机启动以来创建并启动的线程总数。
      boolean isCurrentThreadCpuTimeSupported​()
      测试Java虚拟机是否支持当前线程的CPU时间测量。
      boolean isObjectMonitorUsageSupported​()
      测试Java虚拟机是否支持监视对象监视器的使用情况。
      boolean isSynchronizerUsageSupported​()
      测试Java虚拟机是否支持对 ownable synchronizer的使用情况进行监控。
      boolean isThreadContentionMonitoringEnabled​()
      测试是否启用线程争用监控。
      boolean isThreadContentionMonitoringSupported​()
      测试Java虚拟机是否支持线程争用监控。
      boolean isThreadCpuTimeEnabled​()
      测试线程CPU时间测量是否启用。
      boolean isThreadCpuTimeSupported​()
      测试Java虚拟机实现是否支持任何线程的CPU时间测量。
      void resetPeakThreadCount​()
      将峰值线程计数重置为当前线程数。
      void setThreadContentionMonitoringEnabled​(boolean enable)
      启用或禁用线程争用监控。
      void setThreadCpuTimeEnabled​(boolean enable)
      启用或禁用线程CPU时间测量。

      • Methods inherited from interface java.lang.management.PlatformManagedObject

        getObjectName

    • 方法详细信息

      • getThreadCount

        int getThreadCount​()
        返回当前线程数，包括守护进程线程和非守护程序线程数。
        结果
        当前线程数。

      • getPeakThreadCount

        int getPeakThreadCount​()
        返回Java虚拟机启动或峰值复位后的峰值活动线程数。
        结果
        峰值线程数。

      • getTotalStartedThreadCount

        long getTotalStartedThreadCount​()
        返回自Java虚拟机启动以来创建并启动的线程总数。
        结果
        总线程数已启动。

      • getDaemonThreadCount

        int getDaemonThreadCount​()
        返回当前的守护进程线程数。
        结果
        当前的守护进程线程数。

      • getAllThreadIds

        long[] getAllThreadIds​()
        返回所有活动线程ID。 返回的数组中包含的某些线程可能会在该方法返回时被终止。
        结果
        一个 long的数组，每个都是一个线程ID。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“监视器”）。

      • getThreadInfo

        ThreadInfo getThreadInfo​(long id)
        返回没有堆栈跟踪的指定的id的线程的线程信息。 这个方法相当于调用：
        getThreadInfo(id, 0);

        此方法返回一个ThreadInfo对象，该对象表示指定ID的线程的线程信息。 返回的ThreadInfo对象中的堆栈跟踪，锁定的监视器和锁定的同步器将为空。 如果给定ID的线程不存在或不存在，则此方法将返回null 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        MBeanServer访问 ：
        的映射类型ThreadInfo是CompositeData与作为指定属性ThreadInfo.from方法。

        参数
        id - 线程的线程ID。 必须是积极的。
        结果
        一个ThreadInfo对象，给定ID的线程没有堆栈跟踪，没有锁定的监视器，没有同步器信息; null如果给定ID的线程不存在或不存在。
        异常
        IllegalArgumentException - 如果是 id <= 0 。
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“监视器”）。

      • getThreadInfo

        ThreadInfo[] getThreadInfo​(long[] ids)
        返回其ID为输入数组ids中的每个线程的线程信息，不带堆栈跟踪。 这个方法相当于调用：
           getThreadInfo(ids, 0);

        此方法返回ThreadInfo对象的数组。 每个ThreadInfo对象中的堆栈跟踪，锁定的监视器和锁定的同步器将为空。 如果给定ID的线程不存在或不存在，则返回的数组中的相应元素将包含null 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        MBeanServer访问 ：
        的映射类型ThreadInfo是CompositeData与作为指定属性ThreadInfo.from方法。

        参数
        ids - 一个线程ID数组。
        结果
        一个ThreadInfo对象的数组，每个对象包含一个线程的信息，该线程的ID位于ID的输入数组的相应元素中，没有堆栈跟踪，没有锁定的监视器，没有同步器信息。
        异常
        IllegalArgumentException - 如果输入阵列中的任何元素 ids为 <= 0 。
        SecurityException - 如果安全管理器存在，并且调用者没有ManagementPermission（“监视器”）。

      • getThreadInfo

        ThreadInfo getThreadInfo​(long id,
                         int maxDepth)
        返回指定的id的线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素。 maxDepth参数指示要从堆栈跟踪中检索的最大数量StackTraceElement 。 如果maxDepth == Integer.MAX_VALUE ，线程的整个堆栈跟踪将被转储。 如果是maxDepth == 0 ，那么线程的堆栈跟踪不会被转储。 该方法不能获得线程锁定的监视器和锁定的同步器。

        当Java虚拟机具有关于一个线程或没有堆栈跟踪信息maxDepth == 0 ，在堆栈跟踪ThreadInfo对象将是空数组StackTraceElement 。

        如果给定ID的线程不存在或不存在，则此方法将返回null 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        MBeanServer访问 ：
        ThreadInfo的映射类型为CompositeData ，其属性在ThreadInfo.from方法中指定。

        参数
        id - 线程的线程ID。 必须是积极的。
        maxDepth - 要转储的堆栈跟踪中的最大条目数。 可以使用Integer.MAX_VALUE请求整个堆栈进行转储。
        结果
        一个ThreadInfo的给定ID的线程，没有锁定的监视器和同步器信息。 null如果给定ID的线程不存在或不存在。
        异常
        IllegalArgumentException - 如果是 id <= 0 。
        IllegalArgumentException - 如果是 maxDepth is negative 。
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“监视器”）。

      • getThreadInfo

        ThreadInfo[] getThreadInfo​(long[] ids,
                           int maxDepth)
        返回ID为输入数组ids每个线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素。 maxDepth参数指示要从堆栈跟踪中检索的最大数量StackTraceElement 。 如果是maxDepth == Integer.MAX_VALUE ，线程的整个堆栈跟踪将被转储。 如果是maxDepth == 0 ，线程的堆栈跟踪不会被转储。 该方法不能获得锁定的监视器和锁定的线程的同步器。

        当Java虚拟机具有关于一个线程或没有堆栈跟踪信息maxDepth == 0 ，在堆栈跟踪ThreadInfo对象将是空数组StackTraceElement 。

        该方法返回一个ThreadInfo对象的数组，每个对象是与ids数组相同索引的线程的线程信息。 如果给定ID的线程不存在或不存在， null在返回的数组的相应元素中设置null 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        MBeanServer访问 ：
        的映射类型ThreadInfo是CompositeData与作为指定属性ThreadInfo.from方法。

        参数
        ids - 一个线程ID数组
        maxDepth - 要转储的堆栈跟踪中的最大条目数。 可以使用Integer.MAX_VALUE请求整个堆栈被转储。
        结果
        一个ThreadInfo对象的数组，每个对象包含一个线程的信息，该线程的ID位于ID的输入数组的相应元素中，没有锁定的监视器和同步器信息。
        异常
        IllegalArgumentException - 如果是 maxDepth is negative 。
        IllegalArgumentException - 如果输入数组中的任何元素 ids为 <= 0 。
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“监视器”）。

      • isThreadContentionMonitoringSupported

        boolean isThreadContentionMonitoringSupported​()
        测试Java虚拟机是否支持线程争用监控。
        结果
        true如果Java虚拟机支持线程争用监控; 否则为false 。

      • isThreadContentionMonitoringEnabled

        boolean isThreadContentionMonitoringEnabled​()
        测试是否启用线程争用监控。
        结果
        true如果启用线程争用监控; 否则为false 。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持线程争用监控。
        另请参见：
        isThreadContentionMonitoringSupported()

      • setThreadContentionMonitoringEnabled

        void setThreadContentionMonitoringEnabled​(boolean enable)
        启用或禁用线程争用监控。 默认情况下，线程争用监控被禁用。
        参数
        enable - true启用; false禁用。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持线程争用监控。
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。
        另请参见：
        isThreadContentionMonitoringSupported()

      • getCurrentThreadCpuTime

        long getCurrentThreadCpuTime​()
        以纳秒为单位返回当前线程的总CPU时间。 返回的值为纳秒精度，但不一定是纳秒精度。 如果实现区分用户模式时间和系统模式时间，则返回的CPU时间是当前线程在用户模式或系统模式下执行的时间量。

        这是一种方便本地管理使用的方法，相当于调用：

           getThreadCpuTime(Thread.currentThread().getId());
        结果
        如果启用了CPU时间测量，则当前线程的总CPU时间; 否则为-1 。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持当前线程的CPU时间测量。
        另请参见：
        getCurrentThreadUserTime() ，
isCurrentThreadCpuTimeSupported() ，
isThreadCpuTimeEnabled() ，
setThreadCpuTimeEnabled(boolean)

      • getCurrentThreadUserTime

        long getCurrentThreadUserTime​()
        返回当前线程以纳秒为单位在用户模式下执行的CPU时间。 返回的值为纳秒精度，但不一定是纳秒精度。

        这是一种方便本地管理使用的方法，相当于调用：

           getThreadUserTime(Thread.currentThread().getId());
        结果
        如果启用了CPU时间测量，则当前线程的用户级CPU时间; -1否则。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持当前线程的CPU时间测量。
        另请参见：
        getCurrentThreadCpuTime() ，
isCurrentThreadCpuTimeSupported() ，
isThreadCpuTimeEnabled() ，
setThreadCpuTimeEnabled(boolean)

      • getThreadCpuTime

        long getThreadCpuTime​(long id)
        以纳秒为单位返回指定ID的线程的总CPU时间。 返回的值为纳秒精度，但不一定是纳秒精度。 如果实现区分用户模式时间和系统模式时间，则返回的CPU时间是线程在用户模式或系统模式下执行的时间量。

        如果指定ID的线程不存在或不存在，则此方法返回-1 。 如果禁用CPU时间测量，此方法返回-1 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        如果在线程启动后启用CPU时间测量，则Java虚拟机实现可以选择任何时间，并将能力启用的时间包括在CPU时间测量开始的时间。

        参数
        id - 线程的线程ID
        结果
        指定ID的线程的线程的总CPU时间存在，线程存活，CPU时间测量被使能; 否则为-1 。
        异常
        IllegalArgumentException - 如果是 id <= 0 。
        UnsupportedOperationException - 如果Java虚拟机不支持其他线程的CPU时间测量。
        另请参见：
        getThreadUserTime(long) ，
isThreadCpuTimeSupported() ，
isThreadCpuTimeEnabled() ，
setThreadCpuTimeEnabled(boolean)

      • getThreadUserTime

        long getThreadUserTime​(long id)
        返回指定ID的线程在用户模式下以纳秒为单位的CPU时间。 返回的值为纳秒精度，但不一定是纳秒精度。

        如果指定ID的线程不存在或不存在，则此方法返回-1 。 如果禁用CPU时间测量，此方法返回-1 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        如果在线程启动后启用CPU时间测量，则Java虚拟机实现可以选择任何时间，并将能力启用的时间包括在CPU时间测量开始的时间。

        参数
        id - 线程的线程ID
        结果
        用户级CPU时间为指定ID的线程，如果指定的线程存在，线程处于活动状态，并且CPU时间测量被使能; 否则为-1 。
        异常
        IllegalArgumentException - 如果是 id <= 0 。
        UnsupportedOperationException - 如果Java虚拟机不支持其他线程的CPU时间测量。
        另请参见：
        getThreadCpuTime(long) ，
isThreadCpuTimeSupported() ，
isThreadCpuTimeEnabled() ，
setThreadCpuTimeEnabled(boolean)

      • isThreadCpuTimeSupported

        boolean isThreadCpuTimeSupported​()
        测试Java虚拟机实现是否支持任何线程的CPU时间测量。 支持任何线程的CPU时间测量的Java虚拟机实现也将支持当前线程的CPU时间测量。
        结果
        true如果Java虚拟机支持任何线程的CPU时间测量; 否则为false 。

      • isCurrentThreadCpuTimeSupported

        boolean isCurrentThreadCpuTimeSupported​()
        测试Java虚拟机是否支持当前线程的CPU时间测量。 该方法返回true如果isThreadCpuTimeSupported()回报true 。
        结果
        true如果Java虚拟机支持当前线程的CPU时间测量; 否则为false 。

      • isThreadCpuTimeEnabled

        boolean isThreadCpuTimeEnabled​()
        测试线程CPU时间测量是否启用。
        结果
        true如果线程CPU时间测量被使能; 否则为false 。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持其他线程或当前线程的CPU时间测量。
        另请参见：
        isThreadCpuTimeSupported() ， isCurrentThreadCpuTimeSupported()

      • setThreadCpuTimeEnabled

        void setThreadCpuTimeEnabled​(boolean enable)
        启用或禁用线程CPU时间测量。 默认值取决于平台。
        参数
        enable - true启用; false禁用。
        异常
        UnsupportedOperationException - 如果Java虚拟机不支持任何线程或当前线程的CPU时间测量。
        SecurityException - 如果安全管理器存在且调用者没有ManagementPermission（“控制”）。
        另请参见：
        isThreadCpuTimeSupported() ， isCurrentThreadCpuTimeSupported()

      • findMonitorDeadlockedThreads

        long[] findMonitorDeadlockedThreads​()
        查找处于死锁等待获取对象监视器的线程的循环。 也就是说，在Object.wait调用之后阻止等待进入同步块或等待重新进入同步块的线程，其中每个线程拥有一个监视器，同时尝试获取另一个线程在一个周期中已经持有的另一个监视器。

        更正式地，如果线程是“正在等待拥有的对象监视器”的关系中的循环的一部分，则线程是监视器死锁 。 在最简单的情况下，线程A被阻塞等待线程B拥有的监视器，并且线程B被阻塞等待线程A拥有的监视器。

        此方法专门用于故障排除，但不用于同步控制。 这可能是一个昂贵的操作。

        此方法发现只涉及对象监视器的死锁。 要查找涉及对象监视器和ownable synchronizers的死锁，应使用findDeadlockedThreads方法。

        结果
        监视死锁的线程的数组（如果有的话）; 否则为null 。
        异常
        SecurityException - 如果安全管理器存在且呼叫者没有ManagementPermission（“监视器”）。
        另请参见：
        findDeadlockedThreads()

      • resetPeakThreadCount

        void resetPeakThreadCount​()
        将峰值线程计数重置为当前线程数。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“控制”）。
        另请参见：
        getPeakThreadCount() ， getThreadCount()

      • findDeadlockedThreads

        long[] findDeadlockedThreads​()
        查找处于死锁等待获取对象监视器的线程的周期，或ownable synchronizers 。 线程就被死锁在一个循环，等待这两种类型的锁，如果每个线程拥有一个锁，同时试图获取已经由周期中的另一线程持有另一把锁。

        此方法专门用于故障排除，但不用于同步控制。 这可能是一个昂贵的操作。

        结果
        死锁的线程的数组，等待对象监视器或拥有的同步器（如果有的话）; 否则为null 。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“监视器”）。
        UnsupportedOperationException - 如果Java虚拟机不支持监视可用的同步器使用情况。
        从以下版本开始：
        1.6
        另请参见：
        isSynchronizerUsageSupported() ， findMonitorDeadlockedThreads()

      • isObjectMonitorUsageSupported

        boolean isObjectMonitorUsageSupported​()
        测试Java虚拟机是否支持监视对象监视器的使用情况。
        结果
        true如果Java虚拟机支持监视对象监视器的使用情况; 否则为false 。
        从以下版本开始：
        1.6
        另请参见：
        dumpAllThreads(boolean, boolean)

      • isSynchronizerUsageSupported

        boolean isSynchronizerUsageSupported​()
        测试Java虚拟机是否支持 ownable synchronizer使用情况的监控。
        结果
        true如果Java虚拟机支持监视自己的同步器使用情况; 否则为false 。
        从以下版本开始：
        1.6
        另请参见：
        dumpAllThreads(boolean, boolean)

      • getThreadInfo

        ThreadInfo[] getThreadInfo​(long[] ids,
                           boolean lockedMonitors,
                           boolean lockedSynchronizers)
        返回其ID为输入数组ids每个线程的线程信息，具有堆栈跟踪和同步信息。

        该方法获取每个线程的线程信息的快照，包括：

        • 整个堆栈跟踪，
        • 如果lockedMonitors是true ，那么当前由线程锁定的对象监视器，以及
        • 该ownable synchronizers线程当前锁定的，如果lockedSynchronizers为true 。

        此方法返回一个ThreadInfo对象的数组，每个对象是与ids数组相同索引的线程的线程信息。 如果给定ID的线程不存在或不存在， null在返回的数组的相应元素中设置null 。 如果一个线程已经启动并且尚未死亡，那么线程是活着的。

        如果一个线程没有锁定任何对象监视器，或者lockedMonitors是false ，则返回的ThreadInfo对象将具有一个空的MonitorInfo数组。 同样，如果一个线程没有锁定任何同步器，或者lockedSynchronizers是false ，返回的ThreadInfo对象将有一个空的LockInfo数组。

        当lockedMonitors和lockedSynchronizers参数均为false ，相当于调用：

             getThreadInfo(ids, Integer.MAX_VALUE)

        此方法专门用于故障排除，但不用于同步控制。 这可能是一个昂贵的操作。

        MBeanServer访问 ：
        的映射类型ThreadInfo是CompositeData与作为指定属性ThreadInfo.from方法。

        参数
        ids - 一个线程ID数组。
        lockedMonitors - 如果是 true ，则检索所有锁定的监视器。
        lockedSynchronizers - 如果是 true ，则检索所有锁定的可同步同步器。
        结果
        ThreadInfo对象的数组，每个对象包含有关其ID位于ID的输入数组的相应元素中的线程的信息。
        异常
        SecurityException - 如果安全管理器存在，并且调用者没有ManagementPermission（“监视器”）。
        UnsupportedOperationException -
        • 如果lockedMonitors是true但Java虚拟机不支持监视object monitor usage ; 要么
        • 如果lockedSynchronizers是true但Java虚拟机不支持监视ownable synchronizer usage 。
        从以下版本开始：
        1.6
        另请参见：
        isObjectMonitorUsageSupported() ， isSynchronizerUsageSupported()

      • dumpAllThreads

        ThreadInfo[] dumpAllThreads​(boolean lockedMonitors,
                            boolean lockedSynchronizers)
        使用堆栈跟踪和同步信息返回所有实时线程的线程信息。 返回的数组中包含的某些线程可能会在该方法返回时被终止。

        此方法返回的数组ThreadInfo个作为指定对象getThreadInfo(long[], boolean, boolean)方法。

        参数
        lockedMonitors - 如果是 true ，转储所有锁定的监视器。
        lockedSynchronizers - 如果是 true ，转储所有锁定的所有同步器。
        结果
        一个ThreadInfo的所有活动线程的数组。
        异常
        SecurityException - 如果安全管理器存在并且调用者没有ManagementPermission（“监视器”）。
        UnsupportedOperationException -
        • 如果lockedMonitors是true但Java虚拟机不支持监控object monitor usage ; 要么
        • 如果lockedSynchronizers是true但Java虚拟机不支持监视ownable synchronizer usage 。
        从以下版本开始：
        1.6
        另请参见：
        isObjectMonitorUsageSupported() ， isSynchronizerUsageSupported()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.lang.management (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang.management

  • Packages that use java.lang.management
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。
  • Classes in java.lang.management used by com.sun.management
    Class 描述
    GarbageCollectorMXBean
    用于Java虚拟机垃圾收集的管理界面。
    MemoryManagerMXBean
    内存管理器的管理界面。
    MemoryUsage
    MemoryUsage对象表示内存使用的快照。
    OperatingSystemMXBean
    运行Java虚拟机的操作系统的管理界面。
    PlatformManagedObject
    平台管理对象是用于监视和管理Java平台中的组件的JMX MXBean 。
    ThreadMXBean
    Java虚拟机线程系统的管理界面。
  • Classes in java.lang.management used by java.lang.management
    Class 描述
    ClassLoadingMXBean
    Java虚拟机的类加载系统的管理界面。
    CompilationMXBean
    Java虚拟机编译系统的管理界面。
    GarbageCollectorMXBean
    用于Java虚拟机垃圾收集的管理界面。
    LockInfo
    有关 锁的信息。
    MemoryManagerMXBean
    内存管理器的管理界面。
    MemoryMXBean
    Java虚拟机的内存系统的管理界面。
    MemoryNotificationInfo
    有关内存通知的信息。
    MemoryPoolMXBean
    内存池的管理界面。
    MemoryType
    类型memory pools 。
    MemoryUsage
    MemoryUsage对象表示内存使用的快照。
    MonitorInfo
    有关对象监视器锁的信息。
    OperatingSystemMXBean
    运行Java虚拟机的操作系统的管理界面。
    PlatformManagedObject
    平台管理对象是用于监视和管理Java平台中的组件的JMX MXBean 。
    RuntimeMXBean
    Java虚拟机的运行时系统的管理界面。
    ThreadInfo
    线程信息。
    ThreadMXBean
    Java虚拟机线程系统的管理界面。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.LockInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.LockInfo

  • Packages that use LockInfo
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of LockInfo in java.lang.management

      Subclasses of LockInfo in java.lang.management
      Modifier and Type Class 描述
      class  MonitorInfo
      有关对象监视器锁的信息。
      Methods in java.lang.management that return LockInfo
      Modifier and Type 方法 描述
      static LockInfo LockInfo.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 LockInfo对象。
      LockInfo[] ThreadInfo.getLockedSynchronizers​()
      返回的数组LockInfo对象，每个对象的表示ownable synchronizer当前由与此相关联的线程锁定ThreadInfo 。
      LockInfo ThreadInfo.getLockInfo​()
      返回 LockInfo ，与此相关的线程的对象的 ThreadInfo被阻塞等待。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.ManagementFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.ManagementFactory

No usage of java.lang.management.ManagementFactory
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.ManagementPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.ManagementPermission

No usage of java.lang.management.ManagementPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.MemoryNotificationInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.MemoryNotificationInfo

  • Packages that use MemoryNotificationInfo
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of MemoryNotificationInfo in java.lang.management

      Methods in java.lang.management that return MemoryNotificationInfo
      Modifier and Type 方法 描述
      static MemoryNotificationInfo MemoryNotificationInfo.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 MemoryNotificationInfo对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.MemoryType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.MemoryType

  • Packages that use MemoryType
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of MemoryType in java.lang.management

      Methods in java.lang.management that return MemoryType
      Modifier and Type 方法 描述
      MemoryType MemoryPoolMXBean.getType​()
      返回此内存池的类型。
      static MemoryType MemoryType.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static MemoryType[] MemoryType.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.MemoryUsage (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.MemoryUsage

  • Packages that use MemoryUsage
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of MemoryUsage in com.sun.management

      Methods in com.sun.management that return types with arguments of type MemoryUsage
      Modifier and Type 方法 描述
      Map<String,MemoryUsage> GcInfo.getMemoryUsageAfterGc​()
      返回此GC结尾处的所有内存池的内存使用情况。
      Map<String,MemoryUsage> GcInfo.getMemoryUsageBeforeGc​()
      返回此GC开头的所有内存池的内存使用情况。

    • Uses of MemoryUsage in java.lang.management

      Methods in java.lang.management that return MemoryUsage
      Modifier and Type 方法 描述
      static MemoryUsage MemoryUsage.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 MemoryUsage对象。
      MemoryUsage MemoryPoolMXBean.getCollectionUsage​()
      返回Java虚拟机最近花费在回收此内存池中未使用对象的努力后的内存使用情况。
      MemoryUsage MemoryMXBean.getHeapMemoryUsage​()
      返回用于对象分配的堆的当前内存使用情况。
      MemoryUsage MemoryMXBean.getNonHeapMemoryUsage​()
      新新新新旗新新新新旗新新旗新新旗新新旗新新旗旗新新旗新新200新新新旗200新新新新旗：
      MemoryUsage MemoryPoolMXBean.getPeakUsage​()
      从Java虚拟机启动或从峰值重置以来，返回此内存池的高峰内存使用情况。
      MemoryUsage MemoryNotificationInfo.getUsage​()
      构建此通知时返回内存池的内存使用情况。
      MemoryUsage MemoryPoolMXBean.getUsage​()
      返回此内存池的内存使用情况的估计。
      Constructors in java.lang.management with parameters of type MemoryUsage
      Constructor 描述
      MemoryNotificationInfo​(String poolName, MemoryUsage usage, long count)
      构造一个 MemoryNotificationInfo对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.MonitorInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.MonitorInfo

  • Packages that use MonitorInfo
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of MonitorInfo in java.lang.management

      Methods in java.lang.management that return MonitorInfo
      Modifier and Type 方法 描述
      static MonitorInfo MonitorInfo.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 MonitorInfo对象。
      MonitorInfo[] ThreadInfo.getLockedMonitors​()
      返回一个MonitorInfo个对象的数组，每个对象表示当前由与此ThreadInfo相关联的线程锁定的对象监视器。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.management.ThreadInfo (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.management.ThreadInfo

  • Packages that use ThreadInfo
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of ThreadInfo in java.lang.management

      Methods in java.lang.management that return ThreadInfo
      Modifier and Type 方法 描述
      ThreadInfo[] ThreadMXBean.dumpAllThreads​(boolean lockedMonitors, boolean lockedSynchronizers)
      使用堆栈跟踪和同步信息返回所有实时线程的线程信息。
      static ThreadInfo ThreadInfo.from​(CompositeData cd)
      返回由给定的 CompositeData表示的 ThreadInfo对象。
      ThreadInfo ThreadMXBean.getThreadInfo​(long id)
      返回没有堆栈跟踪的指定的 id的线程的线程信息。
      ThreadInfo[] ThreadMXBean.getThreadInfo​(long[] ids)
      返回其ID位于输入数组 ids中的每个线程的线程信息，不带堆栈跟踪。
      ThreadInfo[] ThreadMXBean.getThreadInfo​(long[] ids, boolean lockedMonitors, boolean lockedSynchronizers)
      返回其ID为输入数组 ids每个线程的线程信息，具有堆栈跟踪和同步信息。
      ThreadInfo[] ThreadMXBean.getThreadInfo​(long[] ids, int maxDepth)
      返回ID为输入数组 ids每个线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素数。
      ThreadInfo ThreadMXBean.getThreadInfo​(long id, int maxDepth)
      返回指定 id的线程的线程信息，堆栈跟踪指定数量的堆栈跟踪元素。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.BufferPoolMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.BufferPoolMXBean

No usage of java.lang.management.BufferPoolMXBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.ClassLoadingMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.ClassLoadingMXBean

  • Packages that use ClassLoadingMXBean
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of ClassLoadingMXBean in java.lang.management

      Methods in java.lang.management that return ClassLoadingMXBean
      Modifier and Type 方法 描述
      static ClassLoadingMXBean ManagementFactory.getClassLoadingMXBean​()
      返回Java虚拟机的类加载系统的托管bean。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.CompilationMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.CompilationMXBean

  • Packages that use CompilationMXBean
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of CompilationMXBean in java.lang.management

      Methods in java.lang.management that return CompilationMXBean
      Modifier and Type 方法 描述
      static CompilationMXBean ManagementFactory.getCompilationMXBean​()
      返回Java虚拟机编译系统的受管Bean。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.GarbageCollectorMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.GarbageCollectorMXBean

  • Packages that use GarbageCollectorMXBean
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of GarbageCollectorMXBean in com.sun.management

      Subinterfaces of GarbageCollectorMXBean in com.sun.management
      Modifier and Type 接口 描述
      interface  GarbageCollectorMXBean
      用于垃圾收集器的特定于平台的管理界面，用于循环执行集合。

    • Uses of GarbageCollectorMXBean in java.lang.management

      Methods in java.lang.management that return types with arguments of type GarbageCollectorMXBean
      Modifier and Type 方法 描述
      static List<GarbageCollectorMXBean> ManagementFactory.getGarbageCollectorMXBeans​()
      返回Java虚拟机中的GarbageCollectorMXBean对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.MemoryManagerMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.MemoryManagerMXBean

  • Packages that use MemoryManagerMXBean
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of MemoryManagerMXBean in com.sun.management

      Subinterfaces of MemoryManagerMXBean in com.sun.management
      Modifier and Type 接口 描述
      interface  GarbageCollectorMXBean
      用于垃圾收集器的特定于平台的管理界面，用于循环执行集合。

    • Uses of MemoryManagerMXBean in java.lang.management

      Subinterfaces of MemoryManagerMXBean in java.lang.management
      Modifier and Type 接口 描述
      interface  GarbageCollectorMXBean
      用于Java虚拟机垃圾收集的管理界面。
      Methods in java.lang.management that return types with arguments of type MemoryManagerMXBean
      Modifier and Type 方法 描述
      static List<MemoryManagerMXBean> ManagementFactory.getMemoryManagerMXBeans​()
      返回Java虚拟机中的MemoryManagerMXBean对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.MemoryMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.MemoryMXBean

  • Packages that use MemoryMXBean
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of MemoryMXBean in java.lang.management

      Methods in java.lang.management that return MemoryMXBean
      Modifier and Type 方法 描述
      static MemoryMXBean ManagementFactory.getMemoryMXBean​()
      返回Java虚拟机的内存系统的托管bean。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.MemoryPoolMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.MemoryPoolMXBean

  • Packages that use MemoryPoolMXBean
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of MemoryPoolMXBean in java.lang.management

      Methods in java.lang.management that return types with arguments of type MemoryPoolMXBean
      Modifier and Type 方法 描述
      static List<MemoryPoolMXBean> ManagementFactory.getMemoryPoolMXBeans​()
      返回Java虚拟机中的MemoryPoolMXBean个对象的列表。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.OperatingSystemMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.OperatingSystemMXBean

  • Packages that use OperatingSystemMXBean
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of OperatingSystemMXBean in com.sun.management

      Subinterfaces of OperatingSystemMXBean in com.sun.management
      Modifier and Type 接口 描述
      interface  OperatingSystemMXBean
      运行Java虚拟机的操作系统的平台特定管理界面。
      interface  UnixOperatingSystemMXBean
      适用于运行Java虚拟机的Unix操作系统的平台特定管理界面。

    • Uses of OperatingSystemMXBean in java.lang.management

      Methods in java.lang.management that return OperatingSystemMXBean
      Modifier and Type 方法 描述
      static OperatingSystemMXBean ManagementFactory.getOperatingSystemMXBean​()
      返回运行Java虚拟机的操作系统的托管bean。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.PlatformLoggingMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.PlatformLoggingMXBean

No usage of java.lang.management.PlatformLoggingMXBean
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.PlatformManagedObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.PlatformManagedObject

  • Packages that use PlatformManagedObject
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of PlatformManagedObject in com.sun.management

      Subinterfaces of PlatformManagedObject in com.sun.management
      Modifier and Type 接口 描述
      interface  GarbageCollectorMXBean
      用于垃圾收集器的特定于平台的管理界面，用于循环执行集合。
      interface  HotSpotDiagnosticMXBean
      HotSpot虚拟机的诊断管理界面。
      interface  OperatingSystemMXBean
      运行Java虚拟机的操作系统的平台特定管理界面。
      interface  ThreadMXBean
      针对Java虚拟机线程系统的平台特定管理界面。
      interface  UnixOperatingSystemMXBean
      适用于运行Java虚拟机的Unix操作系统的平台特定管理界面。

    • Uses of PlatformManagedObject in java.lang.management

      Subinterfaces of PlatformManagedObject in java.lang.management
      Modifier and Type 接口 描述
      interface  BufferPoolMXBean
      缓冲池的管理界面，例如direct或mapped缓冲区的池。
      interface  ClassLoadingMXBean
      Java虚拟机的类加载系统的管理界面。
      interface  CompilationMXBean
      Java虚拟机编译系统的管理界面。
      interface  GarbageCollectorMXBean
      用于Java虚拟机垃圾收集的管理界面。
      interface  MemoryManagerMXBean
      内存管理器的管理界面。
      interface  MemoryMXBean
      Java虚拟机的内存系统的管理界面。
      interface  MemoryPoolMXBean
      内存池的管理界面。
      interface  OperatingSystemMXBean
      运行Java虚拟机的操作系统的管理界面。
      interface  PlatformLoggingMXBean
      logging设施的管理界面。
      interface  RuntimeMXBean
      Java虚拟机的运行时系统的管理界面。
      interface  ThreadMXBean
      Java虚拟机线程系统的管理界面。
      Methods in java.lang.management with type parameters of type PlatformManagedObject
      Modifier and Type 方法 描述
      static <T extends PlatformManagedObject>
      T             		ManagementFactory.getPlatformMXBean​(Class<T> mxbeanInterface)
      返回实现给定的 mxbeanInterface的平台MXBean，它被指定为在Java虚拟机中具有一个实例。
      static <T extends PlatformManagedObject>
      T             		ManagementFactory.getPlatformMXBean​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回 mxbeanInterface的平台MXBean代理，该代理被指定为在Java虚拟机中具有一个实例，代理将通过给定的 MBeanServerConnection转发方法调用。
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans​(Class<T> mxbeanInterface)
      返回在Java虚拟机中实现给定的 mxbeanInterface的平台 mxbeanInterface列表。
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans​(MBeanServerConnection connection, Class<T> mxbeanInterface)
      返回平台MXBean代理的列表，用于通过给定的 MBeanServerConnection转发 mxbeanInterface的方法调用。
      Methods in java.lang.management that return types with arguments of type PlatformManagedObject
      Modifier and Type 方法 描述
      static Set<Class<? extends PlatformManagedObject>> ManagementFactory.getPlatformManagementInterfaces​()
      返回Class对象的集合，子接口为PlatformManagedObject ，表示用于监视和管理Java平台的所有管理接口。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.RuntimeMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.RuntimeMXBean

  • Packages that use RuntimeMXBean
    软件包 描述
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of RuntimeMXBean in java.lang.management

      Methods in java.lang.management that return RuntimeMXBean
      Modifier and Type 方法 描述
      static RuntimeMXBean ManagementFactory.getRuntimeMXBean​()
      返回Java虚拟机的运行时系统的托管bean。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.management.ThreadMXBean (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.management.ThreadMXBean

  • Packages that use ThreadMXBean
    软件包 描述
    com.sun.management
    该软件包包含JDK对 java.lang.management API的标准实现的扩展，并定义了该平台的其他组件的管理界面。
    java.lang.management
    提供用于监视和管理Java虚拟机和Java运行时中其他组件的管理界面。

    • Uses of ThreadMXBean in com.sun.management

      Subinterfaces of ThreadMXBean in com.sun.management
      Modifier and Type 接口 描述
      interface  ThreadMXBean
      针对Java虚拟机线程系统的平台特定管理界面。

    • Uses of ThreadMXBean in java.lang.management

      Methods in java.lang.management that return ThreadMXBean
      Modifier and Type 方法 描述
      static ThreadMXBean ManagementFactory.getThreadMXBean​()
      返回Java虚拟机的线程系统的托管bean。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Configuration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class Configuration

  • java.lang.Object
    • java.lang.module.Configuration

  • public final class Configuration
extends Object
    的构造的结果是resolution或分辨率service binding 。

    一个配置封装了作为分辨率输出的可读性图 。 可读性图是一个有向图，其顶点是类型为ResolvedModule ，边缘表示模块之间的可读性。 Configuration定义了modules()方法来获取图中解析的模块集。 ResolvedModule定义了reads()方法来获取已解析模块读取的一组模块。 读取的模块可能处于相同的配置中，也可能在parent配置中。

    配置定义resolve方法来解析根模块的集合，而resolveAndBind方法可以使用服务绑定进行解析。 这两种方法都有实例和静态变体。 实例方法创建配置，接收方作为父配置。 静态方法适用于可以有多个父配置的更高级的情况。

    Java虚拟机中的每个layer模块都是从配置创建的。 boot层的配置通过调用ModuleLayer.boot().configuration()获得。 在创建新配置时，引导层的配置通常是父级。

    例

    以下示例使用resolve方法将引导层配置作为父配置来解析名为myapp的模块。 它打印每个解析模块的名称和每个模块读取的模块的名称。

       ModuleFinder finder = ModuleFinder.of(dir1, dir2, dir3); Configuration parent = ModuleLayer.boot().configuration(); Configuration cf = parent.resolve(finder, ModuleFinder.of(), Set.of("myapp")); cf.modules().forEach(m -> { System.out.format("%s -> %s%n", m.name(), m.reads().stream() .map(ResolvedModule::name) .collect(Collectors.joining(", "))); });
    从以下版本开始：
    9
    另请参见：
    ModuleLayer

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Configuration empty​()
      返回 空配置。
      Optional<ResolvedModule> findModule​(String name)
      在此配置中查找已解决的模块，或者如果不在此配置中，则配置 parent 。
      Set<ResolvedModule> modules​()
      在此配置中返回一组不可变的已解析模块。
      List<Configuration> parents​()
      按照搜索顺序返回此配置的父母的不可修改列表。
      Configuration resolve​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一个根模块的集合，以此配置为其父级，以创建新的配置。
      static Configuration resolve​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解析根模块的集合以创建配置。
      Configuration resolveAndBind​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定，并将此配置作为其父配置来创建新配置。
      static Configuration resolveAndBind​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定功能，以创建配置。
      String toString​()
      返回描述此配置的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • resolve

        public Configuration resolve​(ModuleFinder before,
                             ModuleFinder after,
                             Collection<String> roots)
        解决一个根模块的集合，以此配置为其父级，以创建新的配置。 当使用此配置作为父配置调用时，此方法的工作原理与静态的resolve方法一样。 换句话说，如果这个配置是cf那么这个方法相当于调用：
           Configuration.resolve(before, List.of(cf), after, roots);
        参数
        before - 以前的模块查找器找到模块
        after -模块取景 后定位模块时不位于由 before模块取景器或在父配置
        roots - 要解析的模块的模块名称可能为空的集合
        结果
        解决给定根模块的结果的配置
        异常
        FindException - 如果静态 resolve方法指定的任何可观察性相关原因的解决方案失败
        ResolutionException - 如果解决方案无法通过静态 resolve方法指定的任何一致性检查
        SecurityException - 如果定位模块被安全管理器拒绝

      • resolveAndBind

        public Configuration resolveAndBind​(ModuleFinder before,
                                    ModuleFinder after,
                                    Collection<String> roots)
        解决一系列根模块，具有服务绑定，并将此配置作为其父配置来创建新配置。 当使用此配置作为父级调用时，此方法的工作原理与静态resolveAndBind方法所指定。 换句话说，如果这个配置是cf那么这个方法相当于调用：
           Configuration.resolveAndBind(before, List.of(cf), after, roots);
        参数
        before - 之前的模块查找器找到模块
        after -模块取景 后定位模块时不位于由 before模块取景器或在父配置
        roots - 要解决的模块的模块名称可能为空的集合
        结果
        解决结果的配置，与服务绑定，给定的根模块
        异常
        FindException - 如果由静态 resolve方法指定的任何可观察性相关原因解析失败
        ResolutionException - 如果解决方案无法通过静态 resolve方法指定的任何一致性检查
        SecurityException - 如果定位模块被安全管理器拒绝

      • resolve

        public static Configuration resolve​(ModuleFinder before,
                                    List<Configuration> parents,
                                    ModuleFinder after,
                                    Collection<String> roots)
        解析根模块的集合以创建配置。

        每个根模块都使用给定的before模块查找器。 如果未找到模块，那么它位于父配置中，就好像通过以迭代顺序调用每个父项的findModule方法。 如果没有找到，则使用给定的after模块查找器after模块。 相同的搜索顺序用于定位传递依赖关系。 位于父配置中的根模块或依赖关系不再被解析，并且不包括在生成的配置中。

        当所有模块都被枚举，然后计算可读性图表，并结合模块导出和服务使用，检查一致性。

        由于以下可观察性原因，解决方案可能会因为FindException而失败：

        • 找不到根模块或直接或传递依赖关系。

        • 尝试查找模块时发生错误。 可能的错误包括I / O错误，检测到解析模块描述符（ module-info.class ）的错误或同一模块的两个版本在同一目录中。

        如果下列任何一致性检查失败，则分辨率可能会与ResolutionException失败：

        • 检测到一个周期，例如模块m1要求模块m2和m2需要m1 。

        • 模块读取两个或多个具有相同名称的模块。 这包括一个模块读取另一个与其自身相同名称的情况。

        • 配置中的两个或多个模块将同一个包导出到读取两者的模块。 这包括其中一个模块的情况下M含有包p读取出口另一个模块p到M 。

        • 模块M声明其“ uses p.S ”或“ provides p.S with ... ”，但是包p既不在模块M也不能由M读取的任何模块导出到M 。

        Implementation Note:
        在实现中，模块的可观察性可能取决于引用完整性或其他检查，以确保特定操作系统或架构的紧密耦合模块或模块的不同构建不被组合在同一配置中。
        参数
        before - 之前的模块查找器找到模块
        parents - 搜索顺序列表父配置
        after -模块取景 后定位模块时不位于由 before模块取景器或在父配置
        roots - 要解析的模块的模块名称可能为空的集合
        结果
        解决给定根模块的结果的配置
        异常
        FindException - 如果上述任何可观测性相关原因的解决方案失败
        ResolutionException - 如果上述任何一致性检查的解析失败
        IllegalArgumentException - 如果父母列表为空，或列表中有两个或多个父母，其中包含用于不同目标操作系统，体系结构或版本的模块
        SecurityException - 如果定位模块被安全管理器拒绝

      • resolveAndBind

        public static Configuration resolveAndBind​(ModuleFinder before,
                                           List<Configuration> parents,
                                           ModuleFinder after,
                                           Collection<String> roots)
        解决一系列根模块，具有服务绑定功能，以创建配置。

        该方法的工作原理与resolve完全相同，只是解析模块的图形被增加了由服务使用依赖关系引起的模块。

        更具体地说，根模块被解析成通过调用resolve 。 然后检查已解析的模块以及父配置中的所有模块，以及service dependences 。 给定模块找到的所有模块找到provide一个或多个服务类型的实现被添加到模块图中，然后通过调用resolve方法来解析。 将模块添加到模块图可能会引入新的服务使用依赖关系，因此该过程将反复运行，直到不再添加模块。

        作为服务绑定涉及的分辨率，然后它可能会失败， FindException或者ResolutionException整整规定的同样的理由resolve 。

        参数
        before - 以前的模块查找器找到模块
        parents - 搜索顺序列表父配置
        after -模块取景 后定位模块时不位于由 before模块取景器或在父配置
        roots - 要解析的模块的模块名称可能为空的集合
        结果
        解决结果的配置，与服务绑定，给定的根模块
        异常
        FindException - 如果静态 resolve方法指定的任何可观察性相关原因的解决方案失败
        ResolutionException - 如果解决方案无法通过静态 resolve方法指定的任何一致性检查
        IllegalArgumentException - 如果父母列表为空，或列表中有两个或更多父母，其中包含用于不同目标操作系统，体系结构或版本的模块
        SecurityException - 如果定位模块被安全管理器拒绝

      • empty

        public static Configuration empty​()
        返回空配置。 空配置中没有模块。 没有父母
        结果
        空配置

      • parents

        public List<Configuration> parents​()
        按照搜索顺序返回此配置的父母的不可修改列表。 如果这是empty configuration，那么返回一个空列表。
        结果
        这个父配置可能是空的不可修改的列表

      • modules

        public Set<ResolvedModule> modules​()
        在此配置中返回一组不可变的已解析模块。
        结果
        在此配置中可能为空的不可修改的已解析模块集

      • findModule

        public Optional<ResolvedModule> findModule​(String name)
        在此配置中找到一个已解决的模块，或者在此配置中找不到parent配置。 在父配置中查找模块等同于按照搜索顺序调用每个父findModule上的findModule ，直到找到该模块或已搜索所有父项。 在配置树中，这相当于深度优先搜索。
        参数
        name - 要查找的解析模块的模块名称
        结果
        具有给定名称的解析模块或空 Optional如果在此配置中没有此名称的模块或任何父配置

      • toString

        public String toString​()
        返回描述此配置的字符串。
        重写：
        toString在类 Object
        结果
        A possibly empty string describing this configuration
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FindException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class FindException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.module.FindException
  • All Implemented Interfaces:
    Serializable

    public class FindException
extends RuntimeException
    抛出一个ModuleFinder发生错误时发现一个模块。 由于可观察性相关的原因，当解决方案失败时，由Configuration.resolve抛出。
    从以下版本开始：
    9
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      FindException​()
      构造一个 FindException没有详细消息。
      FindException​(String msg)
      构造具有给定详细信息的 FindException 。
      FindException​(String msg, Throwable cause)
      构造一个 FindException与给定的详细信息和原因。
      FindException​(Throwable cause)
      构造一个 FindException与给定的原因。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • FindException

        public FindException​()
        构造一个 FindException ，没有详细信息。

      • FindException

        public FindException​(String msg)
        构造具有给定详细消息的 FindException 。
        参数
        msg - 详细信息; 可以是null

      • FindException

        public FindException​(Throwable cause)
        构造一个 FindException与给定的原因。
        参数
        cause - 原因; 可以是null

      • FindException

        public FindException​(String msg,
                     Throwable cause)
        构造一个 FindException与给定的详细信息和原因。
        参数
        msg - 详细信息; 可以是null
        cause - 原因; 可以是null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvalidModuleDescriptorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class InvalidModuleDescriptorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.module.InvalidModuleDescriptorException
  • All Implemented Interfaces:
    Serializable

    public class InvalidModuleDescriptorException
extends RuntimeException
    读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。
    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.read(java.io.InputStream, java.util.function.Supplier<java.util.Set<java.lang.String>>) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InvalidModuleDescriptorException​()
      构造一个 InvalidModuleDescriptorException没有详细消息。
      InvalidModuleDescriptorException​(String msg)
      构造具有指定详细消息的 InvalidModuleDescriptorException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvalidModuleDescriptorException

        public InvalidModuleDescriptorException​()
        构造一个 InvalidModuleDescriptorException ，没有详细信息。

      • InvalidModuleDescriptorException

        public InvalidModuleDescriptorException​(String msg)
        构造具有指定详细消息的 InvalidModuleDescriptorException 。
        参数
        msg - 详细信息; 可以是null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.lang.module (Java SE 9 & JDK 9 )

java.lang.module

Interfaces

  • ModuleFinder
  • ModuleReader

Classes

  • Configuration
  • ModuleDescriptor
  • ModuleDescriptor.Builder
  • ModuleDescriptor.Exports
  • ModuleDescriptor.Opens
  • ModuleDescriptor.Provides
  • ModuleDescriptor.Requires
  • ModuleDescriptor.Version
  • ModuleReference
  • ResolvedModule

Enums

  • ModuleDescriptor.Exports.Modifier
  • ModuleDescriptor.Modifier
  • ModuleDescriptor.Opens.Modifier
  • ModuleDescriptor.Requires.Modifier

Exceptions

  • FindException
  • InvalidModuleDescriptorException
  • ResolutionException


java.lang.module (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.lang.module

通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

除非另有说明，否则将null参数传递给此程序包中任何类或接口的构造函数或方法将导致抛出NullPointerException 。 另外，除非另有说明，否则调用包含null元素的数组或集合的方法将导致一个NullPointerException 。

Resolution

分辨率是计算模块如何相互依赖的过程。 该过程发生在编译时和运行时。

分辨率是一个两步的过程。 第一步递归地枚举一组根模块的“require”指令。 如果所有枚举的模块都是可观察的，则第二步计算其可读性图。 可读性图表示了模块如何相互依赖，从而控制跨模块边界的访问。

步骤1：递归枚举

递归枚举采用一组模块名称，查找每个模块声明，对于每个模块声明，递归枚举：

  • 'require'指令与'传递'修饰符给出的模块名称，以及

  • 在主机系统的判断下，由“require”指令给出的模块名称没有“传递”修饰符。

模块声明在一组可观察模块中查找。 可视化模块的集合以实现特定的方式确定。 可观察模块的集合可以包括具有明确声明的模块（即，具有module-info.java源文件或module-info.class文件）和具有隐式声明的模块（即automatic modules ）。 因为一个自动模块没有明确的模块声明，所以它没有自己的'require'指令，尽管它的名字可以由显式模块声明的'requires'指令给出。

根据模块的名称作为该算法的初始输入，根据实现特定的方式确定。 该组模块可以包括自动模块。

如果至少有一个自动模块被这个算法枚举，那么每个可观察的自动模块都必须被枚举，无论他们的名字是否由显式模块声明的'require'指令给出。

如果发生以下任何一种情况，则解决方法失败：

  • 任何根模块都不可观察。

  • 名称由“要求”指令与“传递”修饰符赋予的任何模块都不可观察。

  • 由主机系统决定，任何名称由“require”指令而不带“传递”修饰符的模块都不可观察。

  • 此步骤中的算法枚举了相同的模块名称两次。 这表示'require'指令中的一个循环，忽略任何'传递'修饰符。

否则，决议进入步骤2。

步骤2：计算可读性图

'require'指令（不管'传递'）表示一个模块依赖于其他模块。 “传递”修饰符的作用是使附加模块也依赖于其他模块。 如果模块M'需要传递性N'，那么M不仅取决于N，而且取决于M的任何模块也取决于N。这允许M被重构，使得其内容的一些或全部可以被移动到新的模块N不会破坏具有'require M'指令的模块。

模块依赖性由可读性图表示。 可读性图是一个有向图，其顶点是在步骤1中列举的模块，其边缘表示模块对之间的可读性。 边缘的规定如下：

首先，可读性由枚举模块的“require”指令决定，忽略任何“传递”修饰符：

  • 对于每个需要“B：A”的枚举模块A，读取“B.

  • 对于自动的每个枚举模块X：X“读取”每隔一个枚举的模块（这就像“自动模块对每个其他枚举模块都有”require“指令）一样。

第二，可读性被增加以考虑“传递性”修饰符：

  • 对于每个列举的模块A，“读取”B：

    • 如果B'需要传递'C'，那么A“读取”C“以及”B“。这个扩展是递归的：因为A”读取“C”，如果C'需要传递'D'，那么A“读取”D“以及”C“ B.

    • 如果B是自动模块，则A“读取”每隔一个枚举的自动模块。 （“仿佛”自动模块对每个其他枚举的自动模块都有“需要传递”指令）。

最后，每个模块“读”本身。

如果可读性图中出现以下任何一种情况，则解析失败：

  • 模块“读取”两个或多个具有相同名称的模块。 这包括模块“读”另一个与其自身名称相同的情况。

  • 两个或多个模块将具有相同名称的包导出到“读取”两者的模块。 这包括包含包p的模块M“读取”将p导出到M的另一个模块的情况。

  • 模块M声明它使用pS'或'提供pS与...'，但是包p不是模块M，也不会由M“读取”的任何模块导出到M。

否则，分辨率成功，解析结果是可读性图。

根模块

编译时根组件通常是正在编译的一组模块。 在运行时，根组件通常是指定给“java”启动器的应用程序模块。 当在未命名的模块中编译代码时，或者在从类路径加载主应用程序类时的运行时，默认的根模块是实现特定的（在JDK实现中它是模块“java.se”，如果可观察，以及导出API的每个可观察模块）。

可观察模块

编译时和运行时的可观察模块可以通过搜索几个不同的路径，也可以通过搜索内置到环境中的编译模块来确定。 搜索顺序如下：

  1. 在编译时只有编译模块的路径。 此路径包含源代码形式的模块定义。

  2. 升级模块路径。 该路径包含模块的编译定义，优先于（3）和（4）中存在的任何可升级模块的编译定义。 请参阅Java SE平台，指定哪些标准模块可升级。

  3. 系统模块是内置于环境中的编译定义。

  4. 应用程序模块路径。 此路径包含库和应用程序模块的编译定义。

'require'指令与'static'修饰符

'require'指令具有'static'修饰符在运行时表达可选依赖。 如果模块声明它需要静态M'，那么分辨率不会搜索可观察模块M以满足依赖性。 然而，如果在步骤1中递归地枚举M，那么枚举的所有模块和“需要静态M”将读取M.

完整性

解决方案在编译时可能是部分的，因为完整的传递闭包可能不需要编译一组模块。 最小程度上，在编译时构建和验证的可读性图包括正在编译的模块，它们的直接依赖关系以及所有隐式声明的依赖性（需要传递）。

在运行时，分辨率是一个加法过程。 步骤1中的递归枚举可能与先前的分辨率相关，因此当由以前（或父级）分辨率枚举时，不会枚举根模块或“require”指令中命名的模块。 因此，作为分辨率结果的可读性图可以具有在步骤1中枚举的模块的顶点，但是具有表示模块读取由先前（或父级）分辨率枚举的模块的边缘。

从以下版本开始：
9
  • 接口摘要
    接口 描述
    ModuleFinder
    模块的取景器。
    ModuleReader
    提供访问模块的内容。
  • 类摘要
    Class 描述
    Configuration
    的构造的结果是 resolution或分辨率 service binding 。
    ModuleDescriptor
    模块描述符。
    ModuleDescriptor.Builder
    构建ModuleDescriptor对象的构建器。
    ModuleDescriptor.Exports
    由模块导出的包可能有资格或不合格。
    ModuleDescriptor.Opens
    由模块打开的包可能有资格或不合格。
    ModuleDescriptor.Provides
    模块提供一个或多个实现的服务。
    ModuleDescriptor.Requires
    对模块的依赖
    ModuleDescriptor.Version
    模块的版本字符串。
    ModuleReference
    参考模块的内容。
    ResolvedModule
    解析模块图中的 模块 。
  • 枚举摘要
    Enum 描述
    ModuleDescriptor.Exports.Modifier
    导出包上的修饰符。
    ModuleDescriptor.Modifier
    模块上的修饰符。
    ModuleDescriptor.Opens.Modifier
    打开包装上的修饰符。
    ModuleDescriptor.Requires.Modifier
    模块依赖的修饰符。
  • 异常摘要
    异常 描述
    FindException
    抛出一个ModuleFinder发生错误时发现一个模块。
    InvalidModuleDescriptorException
    读取模块描述符时抛出，并且发现模块描述符格式不正确或不能解释为模块描述符。
    ResolutionException
    在解析一组模块或解析一组具有服务绑定的模块时抛出失败。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang.module Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang.module

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.module.Configuration
    • java.lang.module.ModuleDescriptor (implements java.lang.Comparable<T>)
    • java.lang.module.ModuleDescriptor.Builder
    • java.lang.module.ModuleDescriptor.Exports (implements java.lang.Comparable<T>)
    • java.lang.module.ModuleDescriptor.Opens (implements java.lang.Comparable<T>)
    • java.lang.module.ModuleDescriptor.Provides (implements java.lang.Comparable<T>)
    • java.lang.module.ModuleDescriptor.Requires (implements java.lang.Comparable<T>)
    • java.lang.module.ModuleDescriptor.Version (implements java.lang.Comparable<T>)
    • java.lang.module.ModuleReference
    • java.lang.module.ResolvedModule
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.lang.RuntimeException
          • java.lang.module.FindException
          • java.lang.module.InvalidModuleDescriptorException
          • java.lang.module.ResolutionException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • java.lang.module.ModuleReader
  • java.lang.module.ModuleFinder

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.module.ModuleDescriptor.Exports.Modifier
      • java.lang.module.ModuleDescriptor.Modifier
      • java.lang.module.ModuleDescriptor.Opens.Modifier
      • java.lang.module.ModuleDescriptor.Requires.Modifier
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


ModuleDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleDescriptor

  • java.lang.Object
    • java.lang.module.ModuleDescriptor
  • All Implemented Interfaces:
    Comparable<ModuleDescriptor>

    public class ModuleDescriptor
extends Object
implements Comparable<ModuleDescriptor>
    模块描述符。

    模块描述符描述了一个命名模块，并定义了获取每个组件的方法。 Java虚拟机中命名模块的模块描述符是通过调用Module的getDescriptor方法获得的。 也可以使用ModuleDescriptor.Builder类创建模块描述符，或者使用这里定义的read方法读取模块声明的二进制形式（ module-info.class ）。

    模块描述符描述一个正常的 ，开放的或自动的模块。 普通模块和开放式模块描述他们dependences ， exported-packages ，服务他们use或者provide ，和其他组件。 正常模块可能是open具体包。 开放模块的模块描述符不声明任何打开的软件包（其opens方法返回一个空集合），但是在Java虚拟机中实例化时，将被视为打开所有软件包。 自动模块的模块描述符不声明任何依赖关系（除了对java.base的强制依赖性），也不声明任何导出或打开的包。 自动模块在分辨率期间接收特殊处理，以便它们读取配置中的所有其他模块。 当在Java虚拟机中实例化自动模块时，它会读取每个未命名的模块，并将其视为导出并打开所有软件包。

    ModuleDescriptor对象是不可变的，安全的可供多个并发线程使用。

    从以下版本开始：
    9
    另请参见：
    Module

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ModuleDescriptor.Builder
      一个建筑物，用于建造ModuleDescriptor个物体。
      static class  ModuleDescriptor.Exports
      由模块导出的包可能有资格或不合格。
      static class  ModuleDescriptor.Modifier
      模块上的修饰符。
      static class  ModuleDescriptor.Opens
      由模块打开的包可能有资格或不合格。
      static class  ModuleDescriptor.Provides
      模块提供一个或多个实现的服务。
      static class  ModuleDescriptor.Requires
      对模块的依赖
      static class  ModuleDescriptor.Version
      模块的版本字符串。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(ModuleDescriptor that)
      将此模块描述符与其他描述符进行比较
      boolean equals​(Object ob)
      测试此模块描述符与给定对象的相等性。
      Set<ModuleDescriptor.Exports> exports​()
      返回表示导出的包的 Exports对象的集合。
      int hashCode​()
      计算此模块描述符的哈希码。
      boolean isAutomatic​()
      如果这是自动模块，则返回 true 。
      boolean isOpen​()
      如果这是一个开放模块，则返回 true 。
      Optional<String> mainClass​()
      返回模块主类。
      Set<ModuleDescriptor.Modifier> modifiers​()
      返回一组模块修饰符。
      String name​()
      返回模块名称。
      static ModuleDescriptor.Builder newAutomaticModule​(String name)
      实例化构建器为自动模块构建模块描述符。
      static ModuleDescriptor.Builder newModule​(String name)
      实例化构建器以构建 正常模块的模块描述符。
      static ModuleDescriptor.Builder newModule​(String name, Set<ModuleDescriptor.Modifier> ms)
      实例化构建器以构建模块描述符。
      static ModuleDescriptor.Builder newOpenModule​(String name)
      实例化构建器为开放模块构建模块描述符。
      Set<ModuleDescriptor.Opens> opens​()
      返回表示开放包的 Opens对象集。
      Set<String> packages​()
      返回模块中的一组包。
      Set<ModuleDescriptor.Provides> provides​()
      返回表示模块提供的服务的 Provides对象集。
      Optional<String> rawVersion​()
      返回具有可能不可粗体版本的模块的字符串
      static ModuleDescriptor read​(InputStream in)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor read​(InputStream in, Supplier<Set<String>> packageFinder)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor read​(ByteBuffer bb)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor read​(ByteBuffer bb, Supplier<Set<String>> packageFinder)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
      Set<ModuleDescriptor.Requires> requires​()
      返回表示模块依赖关系的 Requires对象的集合。
      String toNameAndVersion​()
      返回一个包含模块名称的字符串，如果存在，则显示其版本。
      String toString​()
      返回描述模块的字符串。
      Set<String> uses​()
      返回一组服务依赖关系。
      Optional<ModuleDescriptor.Version> version​()
      返回模块版本。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • name

        public String name​()

        返回模块名称。

        结果
        模块名称

      • modifiers

        public Set<ModuleDescriptor.Modifier> modifiers​()

        返回一组模块修饰符。

        结果
        一个可能是空的不可修改的一组修饰符

      • isOpen

        public boolean isOpen​()

        如果这是一个开放模块，则返回true 。

        此方法等效于测试，如果modifiers的集合包含OPEN修饰符。

        结果
        true如果这是一个开放的模块

      • isAutomatic

        public boolean isAutomatic​()

        如果这是自动模块，则返回true 。

        此方法等效于测试，如果modifiers的集合包含AUTOMATIC修饰符。

        结果
        true如果这是一个自动模块

      • requires

        public Set<ModuleDescriptor.Requires> requires​()

        返回表示模块依赖关系的Requires对象集。

        当该模块未命名为“ java.base ”时，该集合包含对“ java.base ”的依赖。 如果该模块是自动模块，那么它不具有“ java.base ”以外的任何模块的依赖。

        结果
        一个可能是空的不可修改的一组ModuleDescriptor.Requires个对象

      • exports

        public Set<ModuleDescriptor.Exports> exports​()

        返回表示导出的包的Exports对象的集合。

        如果此模块是自动模块，则导出集合为空。

        结果
        可能是空的不可修改的一组导出的包

      • opens

        public Set<ModuleDescriptor.Opens> opens​()

        返回表示开放包的Opens对象集。

        如果此模块是开放模块或自动模块，则该组开放软件包为空。

        结果
        一个可能是空的不可修改的开放包的集合

      • uses

        public Set<String> uses​()

        返回一组服务依赖关系。

        如果该模块是自动模块，那么服务依赖关系集是空的。

        结果
        可能为空的不可修改的一组使用的服务类型的全限定类名

      • provides

        public Set<ModuleDescriptor.Provides> provides​()

        返回表示模块提供的服务的Provides对象的集合。

        结果
        该模块提供的可能为空的不可修改的服务集

      • version

        public Optional<ModuleDescriptor.Version> version​()

        返回模块版本。

        结果
        该模块的版本，或空的 Optional如果模块没有版本或版本是 unparseable

      • rawVersion

        public Optional<String> rawVersion​()

        返回具有可能不可粗体版本的模块的字符串

        结果
        包含模块版本的字符串或空的 Optional如果模块没有版本
        另请参见：
        version()

      • toNameAndVersion

        public String toNameAndVersion​()

        返回一个包含模块名称的字符串，如果存在，则显示其版本。

        结果
        包含模块名称的字符串，如果存在，则为其版本

      • mainClass

        public Optional<String> mainClass​()

        返回模块主类。

        结果
        模块主类的完全限定类名

      • packages

        public Set<String> packages​()
        返回模块中的一组包。

        该套组包括所有导出和打开的包，以及任何服务提供者的包，以及主类的包。

        结果
        模块中可能为空的不可修改的包的集合

      • compareTo

        public int compareTo​(ModuleDescriptor that)
        将此模块描述符与其他描述符进行比较

        比较两个ModuleDescriptor对象，比较它们的模块名称。 如果模块名称相等，则比较模块版本。 当比较模块版本时，具有版本的模块描述符被认为是使没有版本的模块描述符成功。 如果两个版本都是unparseable，那么raw version strings在字典上被比较。 如果模块名称相等并且版本相等（或两者都不存在），则比较一组修饰符。 通过比较为每个集合计算的二进制值来比较一组修饰符。 如果改性剂是存在于所述组，然后在它的顺序的位置的位是1二进制值，否则0 。 如果两组修饰符也相等，则与equals一致的方式比较模块描述符的其他组件。

        Specified by:
        compareTo在接口 Comparable<ModuleDescriptor>
        参数
        that - 要比较的模块描述符
        结果
        如果该模块描述符小于，等于或大于给定的模块描述符，则为负整数，零或正整数

      • equals

        public boolean equals​(Object ob)
        测试此模块描述符与给定对象的相等性。

        如果给定的对象不是一个ModuleDescriptor那么这个方法返回false 。 如果两个模块描述符的每个相应的组件相等，则相等。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在类 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果并且只有给定的对象是等于该模块描述符的模块描述符
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此模块描述符的哈希码。

        散列码基于模块描述符的组件，并满足Object.hashCode方法的一般合同。

        重写：
        hashCode在类 Object
        结果
        该模块描述符的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()

        返回描述模块的字符串。

        重写：
        toString在 Object
        结果
        描述模块的字符串

      • newModule

        public static ModuleDescriptor.Builder newModule​(String name,
                                                 Set<ModuleDescriptor.Modifier> ms)
        实例化构建器以构建模块描述符。
        参数
        name - 模块名称
        ms - 一组模块修饰符
        结果
        一个新的建设者
        异常
        IllegalArgumentException - 如果模块名称为 null或不是合法模块名称，或者该组修饰符包含其他修饰符 AUTOMATIC

      • newModule

        public static ModuleDescriptor.Builder newModule​(String name)
        实例化构建器以构建正常模块的模块描述符。 此方法等效于调用newModule一个空集的modifiers 。
        参数
        name - 模块名称
        结果
        一个新的建设者
        异常
        IllegalArgumentException - 如果模块名称为 null或不是合法的模块名称

      • newOpenModule

        public static ModuleDescriptor.Builder newOpenModule​(String name)
        实例化构建器为开放模块构建模块描述符。 此方法相当于使用OPEN修饰符调用newModule 。

        打开模块的构建器不能用于声明任何打开的包。

        参数
        name - 模块名称
        结果
        构建开放模块的新构建器
        异常
        IllegalArgumentException - 如果模块名称为 null或不是合法的模块名称

      • newAutomaticModule

        public static ModuleDescriptor.Builder newAutomaticModule​(String name)
        实例化构建器为自动模块构建模块描述符。 此方法相当于使用AUTOMATIC修改器调用newModule 。

        自动模块的构建器不能用于声明模块或服务依赖关系。 它也不能用于声明任何导出或打开的包。

        参数
        name - 模块名称
        结果
        构建自动模块的新构建器
        异常
        IllegalArgumentException - 如果模块名称是 null或不是合法的模块名称
        另请参见：
        ModuleFinder.of(Path[])

      • read

        public static ModuleDescriptor read​(InputStream in,
                                    Supplier<Set<String>> packageFinder)
                             throws IOException
        从输入流读取模块声明的二进制形式作为模块描述符。

        如果在输入流中编码的描述符不表示模块中的一组程序包，则将调用packageFinder 。 packageFinder返回的包的packageFinder必须包括模块导出的所有包，打开，以及模块提供的服务实现的包以及主类的包（如果该模块有一个主类） 。 如果packageFinder抛出一个UncheckedIOException，那么IOException的原因会被重新抛出。

        如果在模块描述符之后有字节，那么这个字节是否被读取，忽略或报告为InvalidModuleDescriptorException是InvalidModuleDescriptorException 。 如果这个方法失败了一个InvalidModuleDescriptorException或IOException那么它可以在从输入流读取一些但不是全部的字节之后这样做。 强烈建议如果发生异常，则会立即关闭该流。

        API Note:
        当从传统模块 - 工件格式读取模块描述符时，不会在描述符本身中记录一组程序包时使用 packageFinder参数。
        参数
        in - 输入流
        packageFinder - 可以生产一套包装的供应商
        结果
        模块描述符
        异常
        InvalidModuleDescriptorException - 如果检测到无效的模块描述符，或由 packageFinder返回的软件包集不包括从模块描述符获得的所有软件包
        IOException - 如果从输入流读取I / O错误，或者由查找器抛出 UncheckedIOException

      • read

        public static ModuleDescriptor read​(InputStream in)
                             throws IOException
        从输入流读取模块声明的二进制形式作为模块描述符。 该方法的工作原理与2-arg read方法所指定的不同，当从流读取的模块描述符未显示该包的集合时，不使用packager finder来查找其他包。
        参数
        in - 输入流
        结果
        模块描述符
        异常
        InvalidModuleDescriptorException - 如果检测到无效的模块描述符
        IOException - 如果从输入流读取I / O错误

      • read

        public static ModuleDescriptor read​(ByteBuffer bb,
                                    Supplier<Set<String>> packageFinder)
        从字节缓冲区中读取模块声明的二进制形式作为模块描述符。

        如果在字节缓冲区中编码的描述符不表示模块中的一组包，那么将调用packageFinder 。 packageFinder返回的包的packageFinder必须包括模块导出的所有包，打开，以及模块提供的服务实现的包以及主类的包（如果该模块有一个主类） 。 如果packageFinder抛出一个UncheckedIOException，那么IOException的原因会被重新抛出。

        从缓冲区读取模块描述符，说明索引号为p ，其中当调用此方法时， p是缓冲区的position 。 一旦返回缓冲区的位置将等于p + n ，其中n是从缓冲区读取的字节数。

        如果模块描述符后面有字节，那么这个字节是否被读取，忽略或报告为InvalidModuleDescriptorException是InvalidModuleDescriptorException 。 如果这个方法失败了一个InvalidModuleDescriptorException那么它可能会在一些但不是全部的字节被读取之后这样做。

        API Note:
        当从传统的模块 - 工件格式读取模块描述符时，不会在描述符本身中记录一组程序包时使用 packageFinder参数。
        参数
        bb - 字节缓冲区
        packageFinder - 可以生产该套装的供应商
        结果
        模块描述符
        异常
        InvalidModuleDescriptorException - 如果检测到无效的模块描述符，或由 packageFinder返回的包的 packageFinder不包括从模块描述符获得的所有软件包

      • read

        public static ModuleDescriptor read​(ByteBuffer bb)
        从字节缓冲区中读取模块声明的二进制形式作为模块描述符。 该方法的工作原理与2-arg read方法所指定的相同，但是当缓冲区中编码的模块描述符不表示包的集合时，不使用packager finder来查找其他包。
        参数
        bb - 字节缓冲区
        结果
        模块描述符
        异常
        InvalidModuleDescriptorException - 如果检测到无效的模块描述符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleDescriptor.Builder

  • java.lang.Object
    • java.lang.module.ModuleDescriptor.Builder
  • Enclosing class:
    ModuleDescriptor

    public static final class ModuleDescriptor.Builder
extends Object
    用于构建ModuleDescriptor对象的构建器。

    ModuleDescriptor定义newModule ， newOpenModule和newAutomaticModule方法用于构建正常 ，打开和自动模块创建助洗剂。

    这组模块中封装的由累积Builder为exports ， opens ， packages ， provides ，并mainClass点被调用的方法。

    为构建器方法指定的参数的模块名称，软件包名称和类名称是The Java™ Language Specification中定义的类（名称包）中的模块名称，软件包名称和限定名称。

    使用示例

       ModuleDescriptor descriptor = ModuleDescriptor.newModule("stats.core") .requires("java.base") .exports("org.acme.stats.core.clustering") .exports("org.acme.stats.core.regression") .packages(Set.of("org.acme.stats.core.internal")) .build();
    API Note:
    A Builder在组件被添加到构建器时检查组件和不变量。 其理由是尽早发现错误，而不是将所有验证推迟到build方法。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      ModuleDescriptor build​()
      构建并从其组件返回 ModuleDescriptor 。
      ModuleDescriptor.Builder exports​(ModuleDescriptor.Exports e)
      添加导出的包。
      ModuleDescriptor.Builder exports​(String pn)
      添加导出的包。
      ModuleDescriptor.Builder exports​(String pn, Set<String> targets)
      添加导出的包。
      ModuleDescriptor.Builder exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn)
      使用给定（可能为空）的修饰符集添加导出的包。
      ModuleDescriptor.Builder exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn, Set<String> targets)
      使用给定（可能为空）的修饰符集添加导出的包。
      ModuleDescriptor.Builder mainClass​(String mc)
      设置模块主类。
      ModuleDescriptor.Builder opens​(ModuleDescriptor.Opens obj)
      添加一个开放的包。
      ModuleDescriptor.Builder opens​(String pn)
      添加一个开放的包。
      ModuleDescriptor.Builder opens​(String pn, Set<String> targets)
      添加一个开放的包。
      ModuleDescriptor.Builder opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn)
      添加一个带有给定（可能为空）的修饰符集的开放包。
      ModuleDescriptor.Builder opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn, Set<String> targets)
      添加一个带有给定（可能为空）的修饰符集的开放包。
      ModuleDescriptor.Builder packages​(Set<String> pns)
      将包添加到模块。
      ModuleDescriptor.Builder provides​(ModuleDescriptor.Provides p)
      为一个或多个实现提供服务。
      ModuleDescriptor.Builder provides​(String service, List<String> providers)
      提供服务的实现。
      ModuleDescriptor.Builder requires​(ModuleDescriptor.Requires req)
      增加对模块的依赖。
      ModuleDescriptor.Builder requires​(String mn)
      使用一组空白的修饰符添加对模块的依赖。
      ModuleDescriptor.Builder requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      ModuleDescriptor.Builder requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn, ModuleDescriptor.Version compiledVersion)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      ModuleDescriptor.Builder uses​(String service)
      增加服务依赖性。
      ModuleDescriptor.Builder version​(ModuleDescriptor.Version v)
      设置模块版本。
      ModuleDescriptor.Builder version​(String vs)
      设置模块版本。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • requires

        public ModuleDescriptor.Builder requires​(ModuleDescriptor.Requires req)
        增加对模块的依赖。
        参数
        req - 依赖
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果依赖于此构建器初始化构建的模块
        IllegalStateException - 如果已经声明对模块的依赖，或者该构建器用于自动模块

      • requires

        public ModuleDescriptor.Builder requires​(Set<ModuleDescriptor.Requires.Modifier> ms,
                                         String mn,
                                         ModuleDescriptor.Version compiledVersion)
        使用给定（可能为空）的修饰符集添加对模块的依赖。 依赖性包括在编译时记录的模块版本。
        参数
        ms - 一组修饰符
        mn - 模块名称
        compiledVersion - 在编译时记录的模块版本
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果模块名称为 null ，则不是合法的模块名称，或等于此构建器初始化以构建的模块名称
        IllegalStateException - 如果已经声明对模块的依赖，或者该构建器用于自动模块

      • requires

        public ModuleDescriptor.Builder requires​(Set<ModuleDescriptor.Requires.Modifier> ms,
                                         String mn)
        使用给定（可能为空）的修饰符集添加对模块的依赖。
        参数
        ms - 一组修饰符
        mn - 模块名称
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果模块名称为 null ，则不是合法的模块名称，或者等于此构建器初始化构建的模块名称
        IllegalStateException - 如果已经声明对模块的依赖，或者该构建器用于自动模块

      • requires

        public ModuleDescriptor.Builder requires​(String mn)
        使用一组空白的修饰符添加对模块的依赖。
        参数
        mn - 模块名称
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果模块名称为 null ，则不是合法的模块名称，或等于此构建器初始化以构建的模块名称
        IllegalStateException - 如果已经声明对模块的依赖，或者该构建器用于自动模块

      • exports

        public ModuleDescriptor.Builder exports​(ModuleDescriptor.Exports e)
        添加导出的包。
        参数
        e - 出口
        结果
        这个建设者
        异常
        IllegalStateException - 如果 package已被声明为导出，或此构建器用于自动模块

      • exports

        public ModuleDescriptor.Builder exports​(Set<ModuleDescriptor.Exports.Modifier> ms,
                                        String pn,
                                        Set<String> targets)
        使用给定（可能为空）的修饰符集添加导出的包。 软件包导出到一组目标模块。
        参数
        ms - 一组修饰符
        pn - 包名称
        targets - 目标模块名称集
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果程序包名称为 null或不是合法程序包名称，那么目标模块的集合为空，或者目标模块的集合包含不是合法模块名称的名称
        IllegalStateException - 如果程序包已经声明为导出，或此构建器用于自动模块

      • exports

        public ModuleDescriptor.Builder exports​(Set<ModuleDescriptor.Exports.Modifier> ms,
                                        String pn)
        使用给定（可能为空）的修饰符集添加导出的包。 软件包导出到所有模块。
        参数
        ms - 一组修饰符
        pn - 包名称
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果包名是 null或不是合法的包名称
        IllegalStateException - 如果程序包已经声明为导出，或此构建器用于自动模块

      • exports

        public ModuleDescriptor.Builder exports​(String pn,
                                        Set<String> targets)
        添加导出的包。 软件包导出到一组目标模块。
        参数
        pn - 包名称
        targets - 目标模块名称集
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果软件包名称为 null或不是合法的软件包名称，那么目标模块的集合为空，或者目标模块集合包含不是合法模块名称的名称
        IllegalStateException - 如果软件包已被声明为导出，或此构建器用于自动模块

      • exports

        public ModuleDescriptor.Builder exports​(String pn)
        添加导出的包。 软件包导出到所有模块。
        参数
        pn - 包名称
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果包名是 null或不是合法的包名称
        IllegalStateException - 如果包已经声明为导出，或此构建器用于自动模块

      • opens

        public ModuleDescriptor.Builder opens​(ModuleDescriptor.Opens obj)
        添加一个开放的包。
        参数
        obj - Opens对象
        结果
        这个建设者
        异常
        IllegalStateException - 如果程序包已经声明为open，或者是打开模块或自动模块的构建器

      • opens

        public ModuleDescriptor.Builder opens​(Set<ModuleDescriptor.Opens.Modifier> ms,
                                      String pn,
                                      Set<String> targets)
        添加一个带有给定（可能为空）的修饰符集的开放包。 该软件包对一组目标模块开放。
        参数
        ms - 一组修饰符
        pn - 包名称
        targets - 目标模块名称集
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果软件包名称为 null或不是合法软件包名称，那么目标模块集合为空，或者目标模块集合包含不是合法模块名称的名称
        IllegalStateException - 如果程序包已经声明为open，或者是打开的模块或自动模块的构建器

      • opens

        public ModuleDescriptor.Builder opens​(Set<ModuleDescriptor.Opens.Modifier> ms,
                                      String pn)
        添加一个带有给定（可能为空）的修饰符集的开放包。 该软件包对所有模块都可用。
        参数
        ms - 一组修饰符
        pn - 包名称
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果包名是 null或不是合法的包名称
        IllegalStateException - 如果程序包已经声明为open，或者是打开模块或自动模块的构建器

      • opens

        public ModuleDescriptor.Builder opens​(String pn,
                                      Set<String> targets)
        添加一个开放的包。 该软件包对一组目标模块开放。
        参数
        pn - 包名称
        targets - 目标模块名称集
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果软件包名称为 null或不是合法的软件包名称，那么目标模块的集合为空，或者目标模块集合包含不是合法模块名称的名称
        IllegalStateException - 如果程序包已经声明为open，或者是打开模块或自动模块的构建器

      • opens

        public ModuleDescriptor.Builder opens​(String pn)
        添加一个开放的包。 该软件包对所有模块都可用。
        参数
        pn - 包名称
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果包名是 null或不是合法的包名称
        IllegalStateException - 如果程序包已经声明为open，或者是打开模块或自动模块的构建器

      • uses

        public ModuleDescriptor.Builder uses​(String service)
        增加服务依赖性。
        参数
        service - 服务类型
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果服务类型为 null或不是命名包中的类的限定名称
        IllegalStateException - 如果已经声明对服务类型的依赖，或者这是自动模块的构建器

      • provides

        public ModuleDescriptor.Builder provides​(ModuleDescriptor.Provides p)
        为一个或多个实现提供服务。 如果尚未添加，则每个provider （或提供者工厂）的包将被添加到模块中。
        参数
        p - 提供
        结果
        这个建设者
        异常
        IllegalStateException - 如果服务类型的提供者已经被声明

      • provides

        public ModuleDescriptor.Builder provides​(String service,
                                         List<String> providers)
        提供服务的实现。 如果还没有添加，每个提供者（或提供者工厂）的包将被添加到模块中。
        参数
        service - 服务类型
        providers - 提供者或提供者工厂类名的列表
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果服务类型或任何提供者类名称是 null或者不是命名包中的类的限定名称，或者提供者类名称列表为空
        IllegalStateException - 如果服务类型的提供者已经被声明

      • packages

        public ModuleDescriptor.Builder packages​(Set<String> pns)
        将包添加到模块。 不在模块中的包名称集合中的所有包都添加到模块中。
        参数
        pns - （可能为空）的包名称集合
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果任何包名是 null或不是合法的包名称

      • version

        public ModuleDescriptor.Builder version​(ModuleDescriptor.Version v)
        设置模块版本。
        参数
        v - 版本
        结果
        这个建设者

      • version

        public ModuleDescriptor.Builder version​(String vs)
        设置模块版本。
        参数
        vs - 要解析的版本字符串
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果 vs为 null或无法解析为版本字符串
        另请参见：
        ModuleDescriptor.Version.parse(String)

      • mainClass

        public ModuleDescriptor.Builder mainClass​(String mc)
        设置模块主类。 如果还没有添加，主类的包将被添加到模块中。 换句话说，这个方法相当于首先调用这个构建器的packages方法来添加主类的包名。
        参数
        mc - 模块主类
        结果
        这个建设者
        异常
        IllegalArgumentException - 如果 mainClass是 null或不是命名包中的类的限定名称

      • build

        public ModuleDescriptor build​()
        构建并从其组件返回ModuleDescriptor 。

        即使尚未声明依赖关系，该模块也将需要“ java.base ”（构建名为“ java.base ”的模块时是例外，因为它不能要求自身）。 如果没有声明依赖关系，对“ java.base ”的依赖将具有MANDATED修饰符。

        结果
        模块描述符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Exports (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleDescriptor.Exports

  • java.lang.Object
    • java.lang.module.ModuleDescriptor.Exports
  • All Implemented Interfaces:
    Comparable<ModuleDescriptor.Exports>
    Enclosing class:
    ModuleDescriptor

    public static final class ModuleDescriptor.Exports
extends Object
implements Comparable<ModuleDescriptor.Exports>

    由模块导出的包可能有资格或不合格。

    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.exports()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ModuleDescriptor.Exports.Modifier
      导出包上的修饰符。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(ModuleDescriptor.Exports that)
      将此模块导出与另一个进行比较。
      boolean equals​(Object ob)
      测试此模块导出与给定对象的相等性。
      int hashCode​()
      计算此模块导出的哈希码。
      boolean isQualified​()
      如果这是合格的出口，则返回 true 。
      Set<ModuleDescriptor.Exports.Modifier> modifiers​()
      返回一组修饰符。
      String source​()
      返回包名称。
      Set<String> targets​()
      对于合格的导出，返回导出包的模块名称的非空和不可变的集合。
      String toString​()
      返回描述导出包的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • modifiers

        public Set<ModuleDescriptor.Exports.Modifier> modifiers​()
        返回一组修饰符。
        结果
        一个可能是空的不可修改的一组修饰符

      • isQualified

        public boolean isQualified​()
        如果这是合格的导出，则返回 true 。
        结果
        true如果这是合格的出口

      • source

        public String source​()
        返回包名称。
        结果
        包名称

      • targets

        public Set<String> targets​()
        对于合格的导出，返回导出包的模块名称的非空和不可变的集合。 对于不合格的导出，返回一个空集。
        结果
        目标模块名称集合或不合格导出的集合，一个空集合

      • compareTo

        public int compareTo​(ModuleDescriptor.Exports that)
        将此模块导出与另一个进行比较。

        通过比较包名称来比较两个Exports对象。 在包名称相等的地方，以与模块修饰符进行比较的相同方式比较修饰符集（参见ModuleDescriptor.compareTo ）。 在包名称相等并且修饰符集合相等的情况下，比较目标模块的集合。 这是通过按照升序对目标模块的名称进行排序，并根据其自然顺序进行排序，然后按照字面顺序对相应的元素进行比较。 其中集合的大小不同，较大的集合包含较小集合的所有元素，则较大的集合被认为是使较小集合成功。

        Specified by:
        compareTo在接口 Comparable<ModuleDescriptor.Exports>
        参数
        that - 模块导出比较
        结果
        如果此模块导出小于，等于或大于给定的导出依赖关系，则为负整数，零或正整数

      • hashCode

        public int hashCode​()
        计算此模块导出的哈希码。

        散列码基于修饰符，包名称和限定导出，导出包的组件名称集。 符合Object.hashCode法的一般合同。

        重写：
        hashCode在类 Object
        结果
        此模块导出的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        测试此模块导出与给定对象的相等性。

        如果给定的对象不是一个Exports那么这个方法返回false 。 两个模块导出对象如果它们的修饰符集相等，则包名称相等，并且目标模块名称的集合相等。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在类 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果，并且只有当给定对象是等于该模块依赖的模块依赖性
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回描述导出包的字符串。
        重写：
        toString在类 Object
        结果
        描述导出的包的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Exports.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang.module

Enum ModuleDescriptor.Exports.Modifier

  • java.lang.Object
    • java.lang.Enum<ModuleDescriptor.Exports.Modifier>
      • java.lang.module.ModuleDescriptor.Exports.Modifier
  • All Implemented Interfaces:
    Serializable ， Comparable<ModuleDescriptor.Exports.Modifier>
    Enclosing class:
    ModuleDescriptor.Exports

    public static enum ModuleDescriptor.Exports.Modifier
extends Enum<ModuleDescriptor.Exports.Modifier>
    导出包上的修饰符。
    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.Exports.modifiers()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MANDATED
      导出在模块声明的来源中被隐式声明。
      SYNTHETIC
      导出未在模块声明的来源中明确或隐含地声明。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ModuleDescriptor.Exports.Modifier valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Exports.Modifier[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SYNTHETIC

        public static final ModuleDescriptor.Exports.Modifier SYNTHETIC
        导出未在模块声明的来源中明确或隐含地声明。

      • MANDATED

        public static final ModuleDescriptor.Exports.Modifier MANDATED
        导出在模块声明的来源中被隐式声明。

    • 方法详细信息

      • values

        public static ModuleDescriptor.Exports.Modifier[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ModuleDescriptor.Exports.Modifier c : ModuleDescriptor.Exports.Modifier.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ModuleDescriptor.Exports.Modifier valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang.module

Enum ModuleDescriptor.Modifier

  • java.lang.Object
    • java.lang.Enum<ModuleDescriptor.Modifier>
      • java.lang.module.ModuleDescriptor.Modifier
  • All Implemented Interfaces:
    Serializable ， Comparable<ModuleDescriptor.Modifier>
    Enclosing class:
    ModuleDescriptor

    public static enum ModuleDescriptor.Modifier
extends Enum<ModuleDescriptor.Modifier>
    模块上的修饰符。
    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.modifiers()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      AUTOMATIC
      自动模块
      MANDATED
      该模块被隐式声明。
      OPEN
      一个开放模块。
      SYNTHETIC
      该模块未被明确或隐含地声明。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ModuleDescriptor.Modifier valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Modifier[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • OPEN

        public static final ModuleDescriptor.Modifier OPEN
        一个开放模块。 一个开放模块不声明任何开放的软件包，但所得到的模块被视为打开所有软件包。

      • AUTOMATIC

        public static final ModuleDescriptor.Modifier AUTOMATIC
        自动模块 自动模块被视为导出并打开所有包。
        API Note:
        该修饰符与模块声明（ module-info.class ）的二进制形式的模块标志不对应。

      • SYNTHETIC

        public static final ModuleDescriptor.Modifier SYNTHETIC
        该模块未被明确或隐含地声明。

      • MANDATED

        public static final ModuleDescriptor.Modifier MANDATED
        该模块被隐式声明。

    • 方法详细信息

      • values

        public static ModuleDescriptor.Modifier[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ModuleDescriptor.Modifier c : ModuleDescriptor.Modifier.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ModuleDescriptor.Modifier valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Opens (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleDescriptor.Opens

  • java.lang.Object
    • java.lang.module.ModuleDescriptor.Opens
  • All Implemented Interfaces:
    Comparable<ModuleDescriptor.Opens>
    Enclosing class:
    ModuleDescriptor

    public static final class ModuleDescriptor.Opens
extends Object
implements Comparable<ModuleDescriptor.Opens>

    由模块打开的包可能有资格或不合格。

    将打开指令在模块声明声明一个包是开放的，允许在包中的所有类型，以及他们的所有成员，而不仅仅是公共类型和他们的公众成员由支持私有访问或方法来绕过或API来反映禁止默认的Java语言访问控制检查。

    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.opens()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ModuleDescriptor.Opens.Modifier
      打开包装上的修饰符。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(ModuleDescriptor.Opens that)
      比较这个模块打开另一个。
      boolean equals​(Object ob)
      测试此模块打开以与给定对象相等。
      int hashCode​()
      计算此模块的哈希码打开。
      boolean isQualified​()
      如果这是合格的打开，则返回 true 。
      Set<ModuleDescriptor.Opens.Modifier> modifiers​()
      返回一组修饰符。
      String source​()
      返回包名称。
      Set<String> targets​()
      对于合格的打开，返回打包该包的模块名称的非空和不可变的集合。
      String toString​()
      返回描述打开包的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • modifiers

        public Set<ModuleDescriptor.Opens.Modifier> modifiers​()
        返回一组修饰符。
        结果
        一个可能是空的不可修改的一组修饰符

      • isQualified

        public boolean isQualified​()
        返回 true如果这是合格的打开。
        结果
        true如果这是合格的打开

      • source

        public String source​()
        返回包名称。
        结果
        包名称

      • targets

        public Set<String> targets​()
        对于合格的打开，返回打包该包的模块名称的非空和不可变的集合。 对于不合格的打开，返回一个空集。
        结果
        一组目标模块名称或不合格打开，一个空集

      • compareTo

        public int compareTo​(ModuleDescriptor.Opens that)
        比较这个模块打开另一个。

        通过比较包名称来比较两个Opens对象。 在包名称相等的地方，以与模块修饰符进行比较相同的方式比较修饰符集（参见ModuleDescriptor.compareTo ）。 在包名称相等并且修饰符集合相等的情况下，比较目标模块的集合。 这是通过按照升序对目标模块的名称进行排序，并根据其自然顺序进行排序，然后按照字面顺序对相应的元素进行比较。 其中集合的大小不同，较大的集合包含较小集合的所有元素，则较大的集合被认为是使较小集合成功。

        Specified by:
        compareTo在接口 Comparable<ModuleDescriptor.Opens>
        参数
        that - 该模块打开比较
        结果
        如果此模块打开，负整数，零或正整数小于，等于或大于给定模块打开

      • hashCode

        public int hashCode​()
        计算此模块的哈希码打开。

        哈希码基于修饰符，包名称，对于合格的打开，打包该包的模块名称集。 符合Object.hashCode法的一般合同。

        重写：
        hashCode在 Object
        结果
        此模块的哈希码值将打开
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        测试此模块打开以与给定对象相等。

        如果给定的对象不是一个Opens那么这个方法返回false 。 两个Opens对象如果它们的修饰符集相等，则包名称相等，并且目标模块名称的集合相等。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果，并且只有当给定对象是等于该模块依赖性的模块依赖性
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回描述打开包的字符串。
        重写：
        toString在 Object
        结果
        描述开放包的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Opens.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang.module

Enum ModuleDescriptor.Opens.Modifier

  • java.lang.Object
    • java.lang.Enum<ModuleDescriptor.Opens.Modifier>
      • java.lang.module.ModuleDescriptor.Opens.Modifier
  • All Implemented Interfaces:
    Serializable ， Comparable<ModuleDescriptor.Opens.Modifier>
    Enclosing class:
    ModuleDescriptor.Opens

    public static enum ModuleDescriptor.Opens.Modifier
extends Enum<ModuleDescriptor.Opens.Modifier>
    打开包装上的修饰符。
    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.Opens.modifiers()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MANDATED
      开放包被隐式声明在模块声明的源中。
      SYNTHETIC
      开放包未在模块声明的来源中明确或隐式声明。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ModuleDescriptor.Opens.Modifier valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Opens.Modifier[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SYNTHETIC

        public static final ModuleDescriptor.Opens.Modifier SYNTHETIC
        开放包未在模块声明的来源中明确或隐式声明。

      • MANDATED

        public static final ModuleDescriptor.Opens.Modifier MANDATED
        开放包被隐式声明在模块声明的源中。

    • 方法详细信息

      • values

        public static ModuleDescriptor.Opens.Modifier[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ModuleDescriptor.Opens.Modifier c : ModuleDescriptor.Opens.Modifier.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ModuleDescriptor.Opens.Modifier valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Provides (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleDescriptor.Provides

  • java.lang.Object
    • java.lang.module.ModuleDescriptor.Provides
  • All Implemented Interfaces:
    Comparable<ModuleDescriptor.Provides>
    Enclosing class:
    ModuleDescriptor

    public static final class ModuleDescriptor.Provides
extends Object
implements Comparable<ModuleDescriptor.Provides>

    模块提供一个或多个实现的服务。

    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.provides()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(ModuleDescriptor.Provides that)
      比较这提供给另一个。
      boolean equals​(Object ob)
      测试这提供了与给定对象的相等性。
      int hashCode​()
      计算这个提供的哈希码。
      List<String> providers​()
      返回提供商或提供者工厂的完全限定类名的列表。
      String service​()
      返回服务类型的完全限定类名。
      String toString​()
      返回描述此提供的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • service

        public String service​()
        返回服务类型的完全限定类名。
        结果
        服务类型的全限定类名

      • providers

        public List<String> providers​()
        返回提供商或提供者工厂的完全限定类名的列表。
        结果
        提供商或提供商工厂的完全限定类名称的非空且不可修改的列表

      • compareTo

        public int compareTo​(ModuleDescriptor.Provides that)
        比较这提供给另一个。

        比较两个Provides对象，通过字典顺序比较服务类型的完全限定类名称。 在类名称相等的地方，通过比较两个列表中相应的元素的顺序和顺序来比较提供者类名的列表。 其中列表大小不同， N是较短列表的大小，而第一个N对应的元素相等，则较长的列表被认为是较短的列表。

        Specified by:
        compareTo在接口 Comparable<ModuleDescriptor.Provides>
        参数
        that - Provides进行比较
        结果
        负整数，零或正整数，如果提供的小于，等于或大于给定的提供

      • hashCode

        public int hashCode​()
        计算这个提供的哈希码。

        哈希码基于服务类型和提供者集合。 符合Object.hashCode法的一般合同。

        重写：
        hashCode在 Object
        结果
        该模块的哈希码值提供
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        测试这提供了与给定对象的相等性。

        如果给定的对象不是一个Provides那么这个方法返回false 。 如果服务类型相等并且提供者列表相等，则两个Provides对象相等。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果，只有当给定的对象是一个 Provides等于这个 Provides
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回描述此提供的字符串。
        重写：
        toString在 Object
        结果
        A string describing this provides
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Requires (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleDescriptor.Requires

  • java.lang.Object
    • java.lang.module.ModuleDescriptor.Requires
  • All Implemented Interfaces:
    Comparable<ModuleDescriptor.Requires>
    Enclosing class:
    ModuleDescriptor

    public static final class ModuleDescriptor.Requires
extends Object
implements Comparable<ModuleDescriptor.Requires>

    对模块的依赖

    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.requires()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  ModuleDescriptor.Requires.Modifier
      模块依赖的修饰符。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(ModuleDescriptor.Requires that)
      将此模块的依赖性与另一个模型相比较
      Optional<ModuleDescriptor.Version> compiledVersion​()
      如果在编译时记录，则返回模块的版本。
      boolean equals​(Object ob)
      测试此模块与给定对象的相等性的依赖关系。
      int hashCode​()
      计算此模块依赖的哈希码。
      Set<ModuleDescriptor.Requires.Modifier> modifiers​()
      返回一组修饰符。
      String name​()
      返回模块名称。
      Optional<String> rawCompiledVersion​()
      如果在编译时记录，则返回具有可能不可粗体版本的模块的字符串。
      String toString​()
      返回描述此模块依赖关系的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • modifiers

        public Set<ModuleDescriptor.Requires.Modifier> modifiers​()
        返回一组修饰符。
        结果
        一个可能是空的不可修改的一组修饰符

      • name

        public String name​()
        返回模块名称。
        结果
        模块名称

      • compiledVersion

        public Optional<ModuleDescriptor.Version> compiledVersion​()
        如果在编译时记录，则返回模块的版本。
        结果
        如果在编译时记录模块的版本，或者空的 Optional如果没有记录版本或记录的版本字符串是 unparseable

      • rawCompiledVersion

        public Optional<String> rawCompiledVersion​()
        如果在编译时记录，则返回具有可能不可粗体版本的模块的字符串。
        结果
        包含在编译时记录的模块版本的字符串，如果没有记录版本， Optional空的 Optional
        另请参见：
        compiledVersion()

      • compareTo

        public int compareTo​(ModuleDescriptor.Requires that)
        将此模块的依赖性与另一个模型相比较

        通过比较它们的模块名称进行比较，比较两个Requires对象。 在模块名称相等的地方，以与模块修饰符进行比较相同的方式对修饰符集进行比较（见ModuleDescriptor.compareTo ）。 在模块名称相等并且修饰符集合相等的情况下，比较在编译时记录的模块版本。 当比较在编译时记录的版本时，具有记录版本的依赖被认为是成功的，没有记录版本的依赖。 如果两个记录版本都是unparseable，那么raw version strings在字典上被比较。

        Specified by:
        compareTo在接口 Comparable<ModuleDescriptor.Requires>
        参数
        that - 模块依赖比较
        结果
        如果此模块依赖度小于等于或大于给定模块依赖性，则为负整数，零或正整数

      • equals

        public boolean equals​(Object ob)
        测试此模块与给定对象的相等性的依赖关系。

        如果给定的对象不是一个Requires那么这个方法返回false 。 如果模块名称相等，则两个模块相关对象相等，修饰符集合相等，并且两个模块的编译版本相等或不对两个模块进行记录。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果，并且只有当给定对象是等于该模块依赖性的模块依赖性
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此模块依赖的哈希码。

        哈希代码基于模块名称，修改器和模块版本，如果在编译时记录的话。 符合Object.hashCode法的一般合同。

        重写：
        hashCode在 Object
        结果
        该模块依赖的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回描述此模块依赖关系的字符串。
        重写：
        toString在 Object
        结果
        描述这个模块依赖的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Requires.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.lang.module

Enum ModuleDescriptor.Requires.Modifier

  • java.lang.Object
    • java.lang.Enum<ModuleDescriptor.Requires.Modifier>
      • java.lang.module.ModuleDescriptor.Requires.Modifier
  • All Implemented Interfaces:
    Serializable ， Comparable<ModuleDescriptor.Requires.Modifier>
    Enclosing class:
    ModuleDescriptor.Requires

    public static enum ModuleDescriptor.Requires.Modifier
extends Enum<ModuleDescriptor.Requires.Modifier>
    模块依赖的修饰符。
    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.Requires.modifiers()

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      MANDATED
      依赖性在模块声明的来源中被隐式声明。
      STATIC
      在编译期间，依赖关系在静态阶段是强制性的，但在执行期间在动态阶段是可选的。
      SYNTHETIC
      依赖性没有在模块声明的来源中明确或隐含地声明。
      TRANSITIVE
      依赖性导致任何依赖于 当前模块的模块对由 Requires命名的模块进行隐式声明依赖。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static ModuleDescriptor.Requires.Modifier valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Requires.Modifier[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • TRANSITIVE

        public static final ModuleDescriptor.Requires.Modifier TRANSITIVE
        依赖性导致任何依赖于 当前模块的模块对由 Requires命名的模块隐式声明依赖。

      • STATIC

        public static final ModuleDescriptor.Requires.Modifier STATIC
        在编译期间，依赖关系在静态阶段是强制性的，但在执行期间在动态阶段是可选的。

      • SYNTHETIC

        public static final ModuleDescriptor.Requires.Modifier SYNTHETIC
        依赖性没有在模块声明的来源中明确或隐含地声明。

      • MANDATED

        public static final ModuleDescriptor.Requires.Modifier MANDATED
        依赖性在模块声明的来源中被隐式声明。

    • 方法详细信息

      • values

        public static ModuleDescriptor.Requires.Modifier[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (ModuleDescriptor.Requires.Modifier c : ModuleDescriptor.Requires.Modifier.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static ModuleDescriptor.Requires.Modifier valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ModuleDescriptor.Version (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleDescriptor.Version

  • java.lang.Object
    • java.lang.module.ModuleDescriptor.Version
  • All Implemented Interfaces:
    Comparable<ModuleDescriptor.Version>
    Enclosing class:
    ModuleDescriptor

    public static final class ModuleDescriptor.Version
extends Object
implements Comparable<ModuleDescriptor.Version>
    模块的版本字符串。

    版本字符串有三个组件：版本号本身，可选的预发行版本和可选的构建版本。 每个组件是令牌序列; 每个令牌都是非负整数或一个字符串。 令牌由标点符号字符分隔'.' ， '-' ，或'+' ，或者通过转换从数字序列到既不是数字也不标点符号，或反之亦然的字符序列。

    • 版本号是由'.'字符分隔的令牌序列，由第一个'-'或'+'字符终止。
    • 预发行版本是由'.'或'-'字符分隔的令牌序列，由第一个'+'字符终止。
    • 生成版本是由分隔的标记的序列'.' ， '-' ，或'+'字符。

    当比较两个版本字符串时，将以相应的方式比较其对应组件的元素。 如果一个组件比另一个组件长，否则等于它，则第一个组件被认为是两个组件中的较大者; 否则，如果两个对应的元素是整数，那么它们将被相互比较; 否则，至少有一个元素是一个字符串，所以如果它是一个整数，另一个被转换成一个字符串，并且这两个元素在字面上进行比较。 值为零的跟踪整数元素将被忽略。

    给定两个版本字符串，如果它们的版本号不同，那么比较它们的结果是比较版本号的结果; 否则，如果其中一个具有预发行版本，而另一个则不是第一个，则第一个被认为在第二个版本之前，否则比较它们的结果是比较其预发布版本的结果; 否则，比较它们的结果是比较其构建版本的结果。

    从以下版本开始：
    9
    另请参见：
    ModuleDescriptor.version()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(ModuleDescriptor.Version that)
      将此模块版本与其他模块版本进行比较。
      boolean equals​(Object ob)
      测试此模块版本与给定对象的相等性。
      int hashCode​()
      计算此模块版本的哈希码。
      static ModuleDescriptor.Version parse​(String v)
      将给定的字符串解析为版本字符串。
      String toString​()
      返回解析此版本的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • parse

        public static ModuleDescriptor.Version parse​(String v)
        将给定的字符串解析为版本字符串。
        参数
        v - 要解析的字符串
        结果
        得到的 Version
        异常
        IllegalArgumentException - 如果 v为 null ， null空字符串，或无法解析为版本字符串

      • compareTo

        public int compareTo​(ModuleDescriptor.Version that)
        将此模块版本与其他模块版本进行比较。 模块版本按照类描述中的描述进行比较。
        Specified by:
        compareTo在接口 Comparable<ModuleDescriptor.Version>
        参数
        that - 要比较的模块版本
        结果
        该模块版本小于等于或大于给定模块版本的负整数，零或正整数

      • equals

        public boolean equals​(Object ob)
        测试此模块版本与给定对象的相等性。

        如果给定的对象不是一个Version那么这个方法返回false 。 如果两个模块的相应组件相等，则两个模块版本相同。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果并且只有给定的对象是等于该模块引用的模块引用
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        计算此模块版本的哈希码。

        哈希码基于版本的组件，并满足Object.hashCode方法的一般合同。

        重写：
        hashCode在 Object
        结果
        该模块版本的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回解析此版本的字符串。
        重写：
        toString中的 Object
        结果
        解析此版本的字符串。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleFinder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Interface ModuleFinder

  • public interface ModuleFinder
    模块的取景器。 A ModuleFinder用于在resolution或service binding期间查找模块。

    A ModuleFinder只能找到一个具有给定名称的模块。 例如，查找目录序列中的模块的ModuleFinder将定位给定名称的模块的第一次出现，并将忽略该序列中稍后的目录中出现的该名称的其他模块。

    使用示例

       Path dir1, dir2, dir3; ModuleFinder finder = ModuleFinder.of(dir1, dir2, dir3); Optional<ModuleReference> omref = finder.find("jdk.foo"); omref.ifPresent(mref -> ... );

    这里定义的find和findAll方法可能由于几个原因而失败。 这些包括I / O错误，检测到解析模块描述符（ module-info.class ）的错误，或由ModuleFinder返回的ModuleFinder的情况下，在目录中找到两个或多个具有相同名称的模块。 当检测到错误时，这些方法抛出FindException与适当的cause 。 抛出ModuleFinder之后的一个FindException的行为是未定义的。 例如，抛出异常后调用find可能会扫描或导致异常的相同模块。 建议在抛出异常之后丢弃模块查找器。

    A ModuleFinder不需要线程安全。

    从以下版本开始：
    9

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      static ModuleFinder compose​(ModuleFinder... finders)
      返回由零个或多个模块查找器的序列组成的模块查找器。
      Optional<ModuleReference> find​(String name)
      查找给定名称的模块的引用。
      Set<ModuleReference> findAll​()
      返回此查找器可以找到的所有模块引用的集合。
      static ModuleFinder of​(Path... entries)
      返回通过搜索一系列目录和/或打包模块来定位文件系统上的模块的模块查找器。
      static ModuleFinder ofSystem​()
      返回找到 系统模块的模块查找器。

    • 方法详细信息

      • find

        Optional<ModuleReference> find​(String name)
        查找给定名称的模块的引用。

        A ModuleFinder提供了它所定位的模块的一致视图。 如果find被调用多次以找到相同的模块（按名称），则每次返回相同的结果。 如果一个模块位于，那么它将被保证是由findAll方法返回的一组模块的成员。

        参数
        name - 要查找的模块的名称
        结果
        引用具有给定名称的模块或空的 Optional如果没有找到）
        异常
        FindException - 如果发现错误发现模块
        SecurityException - 如果安全经理否认

      • findAll

        Set<ModuleReference> findAll​()
        返回此查找器可以找到的所有模块引用的集合。

        A ModuleFinder提供了ModuleFinder在模块的一致视图。 如果findAll被调用多次，那么它将每次返回相同的（等于）结果。 对于返回的集合中的每个ModuleReference元素，则保证find将找到ModuleReference如果被调用以找到该模块。

        API Note:
        对于诸如 resolveAndBind之类的方法 来说 ，这对于扫描模块路径来查找提供特定服务的模块非常重要。
        结果
        该查找器定位的所有模块引用的集合
        异常
        FindException - 发现错误发现所有模块
        SecurityException - 如果安全经理否认

      • ofSystem

        static ModuleFinder ofSystem​()
        返回找到系统模块的模块查找器。 系统模块是Java运行时映像中的模块。 模块查找器将始终找到java.base 。

        如果有一个安全管理器设置，那么它的checkPermission方法被调用来检查主叫方是否被授权RuntimePermission("accessSystemModules")访问系统模块。

        结果
        A ModuleFinder定位系统模块
        异常
        SecurityException - 如果安全经理否认

      • of

        static ModuleFinder of​(Path... entries)
        返回通过搜索一系列目录和/或打包模块来定位文件系统上的模块的模块查找器。 给定数组中的每个元素都是以下之一：

        1. 到模块目录的路径。

        2. 分解模块 顶级目录的路径。

        3. 打包模块的路径。

        模块查找器通过以数组索引顺序搜索每个目录，分解模块或打包模块来定位模块。 它发现具有给定名称的模块的第一次出现，并忽略该序列中稍后出现的该名称的其他模块。

        如果元素是模块目录的路径，则目录中的每个条目都是打包的模块或分解模块的顶级目录。 如果目录包含多个具有相同名称的模块，则会出现错误。 如果一个元素是目录的路径，并且该目录包含一个名为module-info.class的文件，则该目录将被视为一个分解模块而不是一个模块目录。

        通过此方法返回的模块查找器支持打包为JAR文件的模块。 用一个JAR文件module-info.class在其顶层目录，或在在一个版本条目multi-release JAR文件，是一个模块化的JAR文件，从而定义了一个明确的模块。 顶级目录中没有一个module-info.class JAR文件定义了一个自动模块 ，如下所示：

        • 如果JAR文件在其主清单中具有属性“ Automatic-Module-Name ”，则其值为module name 。 模块名称否则从JAR文件的名称派生。

        • version和属性“ Automatic-Module-Name ”不存在时的模块名称是从JAR文件的文件名派生的，如下所示：

          • “ .jar ”后缀被删除。

          • 如果名称与正则表达式"-(\\d+(\\.|$))"匹配，则模块名称将从第一次出现连字符之前的子序列导出。 连字符后的序列被解析为Version和忽略，如果它不能被解析为Version 。

          • 模块名称中的所有非字母数字字符（ [^A-Za-z0-9] ）都将替换为点（ "." ），所有重复点都将替换为一个点，并删除所有前导点和尾随点。

          • 例如，名为“ foo-bar.jar ”的JAR文件将导出一个模块名称“ foo.bar ”，没有版本。 名为“ foo-bar-1.2.3-SNAPSHOT.jar ”的JAR文件将导出一个模块名称“ foo.bar ”和“ 1.2.3-SNAPSHOT ”作为版本。

        • 模块中的一组软件包来自JAR文件中的非目录条目，其名称以“ .class ”结尾。 候选包名称是从使用最多但不包括最后正斜杠的字符的名称派生的。 所有剩余的正斜杠都被替换为（ "." ）。 如果生成的字符串是合法的包名称，那么它被认为是一个包名称。 例如，如果JAR文件包含条目“ p/q/Foo.class ”，则派生的包名称为“ p.q ”。

        • 以META-INF/services/开头的条目的内容被假定为服务配置文件（参见ServiceLoader ）。 如果文件的名称（跟随META-INF/services/ ）是合法的类名称，那么它被认为是服务类型的全限定类名称。 文件中的条目被假定为提供者类的完全限定的类名。

        • 如果JAR文件的主清单中有一个Main-Class属性，它的值是一个合法的类名称，其包是在为该模块派生的包的集合中，则该值为模块main class 。

        如果无法通过自动模块创建ModuleDescriptor （通过ModuleDescriptor.Builder API），则抛出FindException 。 当“ Automatic-Module-Name ”属性的值不是合法的模块名称时，可能会出现这种情况，合法模块名称不能从JAR文件的文件名导出，其中JAR文件包含一个.class在顶级目录中JAR文件，其中服务配置文件中的条目不是合法的类名称，或者其包名称不在为该模块派生的包的集合中。

        除了JAR文件，实现还可以支持以其他实现特定模块格式打包的模块。 如果指定为此方法的数组中的元素是模块目录的路径，则将忽略该目录中未识别为模块的条目。 如果数组中的元素是未识别的打包模块的路径，那么遇到该文件时会抛出一个FindException 。 不存在的文件的路径总是被忽略。

        与自动模块一样，可能需要扫描包装或分解模块的内容，以确定模块中的包装。 是否忽略hidden files是否具体实现，因此未指定。 如果在顶级目录中找到了一个.class文件（不是module-info.class ），那么它被假定为未命名的包中的一个类，因此抛出FindException 。

        通过此方法创建的查找器是懒惰的，不要急于检查给定的文件路径是目录或打包的模块。 因此，如果调用这些方法导致搜索目录或打包的模块并遇到错误，则find或findAll方法将失败。

        参数
        entries - 到包装或分解模块的模块或路径的目录的可能空的数组
        结果
        A ModuleFinder ，用于定位文件系统上的模块

      • compose

        static ModuleFinder compose​(ModuleFinder... finders)
        返回由零个或多个模块查找器的序列组成的模块查找器。 所得到的模块查找器的find方法将通过以数组索引顺序调用每个模块查找器的find方法来定位模块，直到找到该模块或已搜索到所有模块查找器。 得到的模块查找器的findAll方法将返回一组模块，其中包含由第一个模块查找器定位的所有模块。 该组模块将包括由第二个或后续模块查找器定位的所有模块，它们不是按照序列中的先前模块查找器定位的。

        当定位模块然后被抛出的异常或错误find或findAll底层模块发现者的方法将被传播到的所产生的模块取景器的呼叫者find或findAll方法。

        参数
        finders - 模块查找器阵列
        结果
        A ModuleFinder组成一系列模块查找器
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Interface ModuleReader

  • All Superinterfaces:
    AutoCloseable ， Closeable

    public interface ModuleReader
extends Closeable
    提供访问模块的内容。

    模块读取器适用于需要访问模块中的资源的情况，而不管模块是否已加载。 例如，扫描文件系统上的打包模块集合的框架可以使用模块读取器来访问每个模块中的特定资源。 模块读取器还旨在由从模块加载类和资源的ClassLoader实现使用。

    模块中的资源由抽象名称标识，它是“ / ” - 分离的路径字符串。 例如，模块java.base可以具有资源“ java/lang/Object.class ”，按照惯例，它是java.lang.Object的类文件。 模块读取器可以将模块内容中的目录视为资源（无论是否具有模块读取器）。 其中模块内容包含可以被定位为资源的目录，则其名称以斜杠（'/'）结尾。 该目录也可以用一个名称来删除尾部斜杠。

    A ModuleReader创建时为open ，并通过调用close方法关闭。 未能关闭模块阅读器可能会导致资源泄漏。 try-with-resources语句提供了一个有用的结构，以确保模块读取器关闭。

    A ModuleReader实现可能需要访问模块中的资源的权限。 因此，该find ， open ， read ，并list方法可能抛出SecurityException如果访问由安全管理器拒绝。

    实现要求：
    将抽象资源名称转换为封装模块或文件系统中资源的位置时， ModuleReader实现应该格外小心。 实现建议的元素，如“对待资源名称. ，” .. ”，包含文件分隔符，或空元素为元素‘未找到’。 更一般来说，如果资源名称不在list方法返回的元素流中，则该资源应被视为“未找到”以避免不一致。
    从以下版本开始：
    9
    另请参见：
    ModuleReference

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      void close​()
      关闭模块阅读器。
      Optional<URI> find​(String name)
      查找资源，将URI返回给模块中的资源。
      Stream<String> list​()
      列出模块的内容，返回作为模块中所有资源名称的元素流。
      default Optional<InputStream> open​(String name)
      打开资源，返回输入流以读取模块中的资源。
      default Optional<ByteBuffer> read​(String name)
      读取资源，返回一个具有资源内容的字节缓冲区。
      default void release​(ByteBuffer bb)
      释放一个字节缓冲区。

    • 方法详细信息

      • find

        Optional<URI> find​(String name)
            throws IOException
        查找资源，将URI返回给模块中的资源。

        如果模块读取器可以确定名称找到目录，则生成的URI将以斜杠（'/'）结尾。

        参数
        name - 要打开阅读的资源的名称
        结果
        资源的URI; 如果找不到资源或者无法构造资源来定位资源，则为空Optional
        异常
        IOException - 如果发生I / O错误或模块读卡器关闭
        SecurityException - 如果安全管理员否认
        另请参见：
        ClassLoader.getResource(String)

      • open

        default Optional<InputStream> open​(String name)
                            throws IOException
        打开资源，返回输入流以读取模块中的资源。

        在模块读取器关闭之后使用输入流的行为是实现特定的，因此未指定。

        实现要求：
        默认实现调用find方法来获取资源的URI。 如果找到，那么它会尝试构建一个URL并打开一个到该资源的连接。
        参数
        name - 要打开阅读的资源的名称
        结果
        一个输入流读取资源或一个空的 Optional如果没有找到
        异常
        IOException - 如果发生I / O错误或模块读卡器关闭
        SecurityException - 如果安全经理否认

      • read

        default Optional<ByteBuffer> read​(String name)
                           throws IOException
        读取资源，返回一个具有资源内容的字节缓冲区。 返回缓冲区位置的元素是资源的第一个字节，缓冲区限制的元素是资源的最后一个字节。 一旦消费，必须调用release方法。 未能调用release方法可能会导致资源泄漏。
        API Note:
        此方法用于高性能类加载。 它不能（或打算）读取可能是2GB或更大的任意大的资源。 结合release方法使用此方法的release是允许模块读取器实现以有效的方式管理缓冲区。
        实现要求：
        默认实现调用 open方法，并将输入流中的所有字节读入字节缓冲区。
        参数
        name - 要读取的资源的名称
        结果
        包含资源内容的字节缓冲区，如果未找到， Optional空 Optional
        异常
        IOException - 如果发生I / O错误或模块阅读器关闭
        SecurityException - 如果安全管理员否认
        OutOfMemoryError - 如果资源大于 Integer.MAX_VALUE ， Integer.MAX_VALUE字节缓冲区的最大容量
        另请参见：
        ClassLoader.defineClass(String, ByteBuffer, java.security.ProtectionDomain)

      • release

        default void release​(ByteBuffer bb)
        释放一个字节缓冲区。 在消费read方法返回的缓冲区的内容后，应调用此方法。 调用释放已经释放的缓冲区的方法的行为，或者在关闭ModuleReader之后调用释放缓冲区的行为是实现特定的，因此未指定。
        实现要求：
        默认的实现不会做任何事情，除非检查字节缓冲区是否为空。
        参数
        bb - 要释放的字节缓冲区

      • list

        Stream<String> list​()
             throws IOException
        列出模块的内容，返回作为模块中所有资源名称的元素流。 元素流是否包含与模块中的目录相对应的名称是具体的模块阅读器。

        在惰性实现中，当使用流列出模块内容时，可能会抛出一个IOException 。 如果发生这种情况，那么IOException将被包装在一个UncheckedIOException中，并引发了导致尝试访问的方法。 当使用流来列出模块内容并且安全管理器拒绝访问时，也可能会抛出SecurityException 。

        在模块读取器关闭之后使用流的行为是实现特定的，因此未指定。

        结果
        作为模块中所有资源名称的元素流
        异常
        IOException - 如果发生I / O错误或模块读卡器关闭
        SecurityException - 如果安全管理员否认

      • close

        void close​()
    throws IOException
        关闭模块阅读器。 一旦关闭，则后续调用定位或读取资源将通过抛出IOException失败。

        模块阅读器不需要异步关闭。 如果线程正在读取资源，而另一个线程调用close方法，则第二个线程可能会阻塞，直到读取操作完成。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - if an I/O error occurs
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ModuleReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ModuleReference

  • java.lang.Object
    • java.lang.module.ModuleReference

  • public abstract class ModuleReference
extends Object
    参考模块的内容。

    一个模块引用是这个类的具体实现，它实现了这个类定义的抽象方法。 它包含模块的描述符及其位置（如果已知）。 它还具有创建ModuleReader以访问模块内容的能力，这些内容可能在Java运行时系统本身内或在诸如模块化JAR文件的工件中。

    从以下版本开始：
    9
    另请参见：
    ModuleFinder ， ModuleReader

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected ModuleReference​(ModuleDescriptor descriptor, URI location)
      构造一个这个类的新实例。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      ModuleDescriptor descriptor​()
      返回模块描述符。
      Optional<URI> location​()
      如果已知，返回此模块内容的位置。
      abstract ModuleReader open​()
      打开模块内容进行阅读。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ModuleReference

        protected ModuleReference​(ModuleDescriptor descriptor,
                          URI location)
        构造一个这个类的新实例。
        参数
        descriptor - 模块描述符
        location - 模块位置或 null如果不知道

    • 方法详细信息

      • descriptor

        public final ModuleDescriptor descriptor​()
        返回模块描述符。
        结果
        模块描述符

      • location

        public final Optional<URI> location​()
        如果已知，返回此模块内容的位置。

        这个URI，当存在时，可以被用作location一个的值CodeSource ，使得模块的类可以在由加载授予特定权限SecureClassLoader 。

        结果
        的位置或一个空的 Optional如果不知道

      • open

        public abstract ModuleReader open​()
                           throws IOException
        打开模块内容进行阅读。
        结果
        A ModuleReader读取模块
        异常
        IOException - 如果发生I / O错误
        SecurityException - 如果安全管理员否认
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ResolutionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ResolutionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.module.ResolutionException
  • All Implemented Interfaces:
    Serializable

    public class ResolutionException
extends RuntimeException
    在解析一组模块或解析一组具有服务绑定的模块时抛出失败。
    从以下版本开始：
    9
    另请参见：
    Configuration ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ResolutionException​()
      构造一个 ResolutionException ，没有详细信息。
      ResolutionException​(String msg)
      构造一个 ResolutionException与给定的详细信息。
      ResolutionException​(String msg, Throwable cause)
      构造一个 ResolutionException与给定的详细信息和原因。
      ResolutionException​(Throwable cause)
      使用给定的原因构造此异常的实例。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ResolutionException

        public ResolutionException​()
        构造一个 ResolutionException ，没有详细信息。

      • ResolutionException

        public ResolutionException​(String msg)
        构造具有给定详细信息的 ResolutionException 。
        参数
        msg - 详细信息; 可以是null

      • ResolutionException

        public ResolutionException​(Throwable cause)
        使用给定的原因构造此异常的实例。
        参数
        cause - 原因; 可以是null

      • ResolutionException

        public ResolutionException​(String msg,
                           Throwable cause)
        构造一个 ResolutionException与给定的详细信息和原因。
        参数
        msg - 详细信息; 可以是null
        cause - 原因; 可以是null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ResolvedModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.module

Class ResolvedModule

  • java.lang.Object
    • java.lang.module.ResolvedModule

  • public final class ResolvedModule
extends Object
    解析模块图中的模块 。

    ResolvedModule定义了configuration方法来获取解析模块所在的配置。它定义了reference方法以获得对模块内容的引用。

    从以下版本开始：
    9
    另请参见：
    Configuration.modules()

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Configuration configuration​()
      返回此已解析模块所在的配置。
      boolean equals​(Object ob)
      测试此已解析模块与给定对象的相等性。
      int hashCode​()
      计算此解析模块的哈希码。
      String name​()
      返回模块名称。
      Set<ResolvedModule> reads​()
      返回已解析模块读取的已解析模块集。
      ModuleReference reference​()
      返回对模块内容的引用。
      String toString​()
      返回描述此已解析模块的字符串。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • configuration

        public Configuration configuration​()
        返回此已解析模块所在的配置。
        结果
        此解析模块所在的配置

      • reference

        public ModuleReference reference​()
        返回对模块内容的引用。
        结果
        参考模块的内容

      • name

        public String name​()
        返回模块名称。 这个方便方法等同于调用：
           reference().descriptor().name()
        结果
        模块名称

      • reads

        public Set<ResolvedModule> reads​()
        返回已解析模块读取的已解析模块集。
        结果
        已解析的模块读取的可能为空的不可修改的解析模块集

      • hashCode

        public int hashCode​()
        计算此解析模块的哈希码。

        散列码基于已解析模块的组件，并满足Object.hashCode方法的一般合同。

        重写：
        hashCode在类 Object
        结果
        此解析模块的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object ob)
        测试此已解析模块与给定对象的相等性。

        如果给定的对象不是一个ResolvedModule那么这个方法返回false 。 两个ResolvedModule对象在相同的配置中是相等的，并且具有对模块内容的相同引用。

        该方法满足Object.equals方法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果并且只有给定的对象是等于该模块引用的模块引用
        另请参见：
        Object.hashCode() ， HashMap

      • toString

        public String toString​()
        返回描述此已解析模块的字符串。
        重写：
        toString在 Object
        结果
        描述此已解析模块的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.lang.module (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang.module

  • Packages that use java.lang.module
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。
  • Classes in java.lang.module used by java.lang
    Class 描述
    Configuration
    的构造的结果是 resolution或分辨率 service binding 。
    ModuleDescriptor
    模块描述符。
  • Classes in java.lang.module used by java.lang.module
    Class 描述
    Configuration
    的构造的结果是 resolution或分辨率 service binding 。
    ModuleDescriptor
    模块描述符。
    ModuleDescriptor.Builder
    构建ModuleDescriptor对象的构建器。
    ModuleDescriptor.Exports
    由模块导出的包可能有资格或不合格。
    ModuleDescriptor.Exports.Modifier
    导出包上的修饰符。
    ModuleDescriptor.Modifier
    模块上的修饰符。
    ModuleDescriptor.Opens
    由模块打开的包可能有资格或不合格。
    ModuleDescriptor.Opens.Modifier
    打开包装上的修饰符。
    ModuleDescriptor.Provides
    模块提供一个或多个实现的服务。
    ModuleDescriptor.Requires
    对模块的依赖
    ModuleDescriptor.Requires.Modifier
    模块依赖的修饰符。
    ModuleDescriptor.Version
    模块的版本字符串。
    ModuleFinder
    模块的取景器。
    ModuleReader
    提供访问模块的内容。
    ModuleReference
    参考模块的内容。
    ResolvedModule
    解析模块图中的 模块 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.Configuration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.Configuration

  • Packages that use Configuration
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of Configuration in java.lang

      Methods in java.lang that return Configuration
      Modifier and Type 方法 描述
      Configuration ModuleLayer.configuration​()
      返回此图层的配置。
      Methods in java.lang with parameters of type Configuration
      Modifier and Type 方法 描述
      ModuleLayer ModuleLayer.defineModules​(Configuration cf, Function<String,ClassLoader> clf)
      通过在给定的Java虚拟机的 Configuration定义模块，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller ModuleLayer.defineModules​(Configuration cf, List<ModuleLayer> parentLayers, Function<String,ClassLoader> clf)
      通过在给定的Java虚拟机的 Configuration定义模块来创建新的模块层。
      ModuleLayer ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithManyLoaders​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。
      ModuleLayer ModuleLayer.defineModulesWithOneLoader​(Configuration cf, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机，创建一个新的模块层，将该层作为其父层。
      static ModuleLayer.Controller ModuleLayer.defineModulesWithOneLoader​(Configuration cf, List<ModuleLayer> parentLayers, ClassLoader parentLoader)
      通过将给定的 Configuration的模块定义到Java虚拟机来创建新的模块层。

    • Uses of Configuration in java.lang.module

      Methods in java.lang.module that return Configuration
      Modifier and Type 方法 描述
      Configuration ResolvedModule.configuration​()
      返回此已解析模块所在的配置。
      static Configuration Configuration.empty​()
      返回 空配置。
      Configuration Configuration.resolve​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一个根模块的集合，以此配置为其父级，以创建新的配置。
      static Configuration Configuration.resolve​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解析根模块的集合以创建配置。
      Configuration Configuration.resolveAndBind​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定，并将此配置作为其父配置来创建新配置。
      static Configuration Configuration.resolveAndBind​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定功能，以创建配置。
      Methods in java.lang.module that return types with arguments of type Configuration
      Modifier and Type 方法 描述
      List<Configuration> Configuration.parents​()
      按照搜索顺序返回此配置的父母的不可修改列表。
      Method parameters in java.lang.module with type arguments of type Configuration
      Modifier and Type 方法 描述
      static Configuration Configuration.resolve​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解析根模块的集合以创建配置。
      static Configuration Configuration.resolveAndBind​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定功能，以创建配置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.FindException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.FindException

No usage of java.lang.module.FindException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.InvalidModuleDescriptorException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.InvalidModuleDescriptorException

No usage of java.lang.module.InvalidModuleDescriptorException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor

  • Packages that use ModuleDescriptor
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor in java.lang

      Methods in java.lang that return ModuleDescriptor
      Modifier and Type 方法 描述
      ModuleDescriptor Module.getDescriptor​()
      如果此模块是未命名模块，则返回此模块的模块描述符或 null 。

    • Uses of ModuleDescriptor in java.lang.module

      Methods in java.lang.module that return ModuleDescriptor
      Modifier and Type 方法 描述
      ModuleDescriptor ModuleDescriptor.Builder.build​()
      构建并从其组件返回一个 ModuleDescriptor 。
      ModuleDescriptor ModuleReference.descriptor​()
      返回模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(InputStream in, Supplier<Set<String>> packageFinder)
      从输入流读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(ByteBuffer bb)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
      static ModuleDescriptor ModuleDescriptor.read​(ByteBuffer bb, Supplier<Set<String>> packageFinder)
      从字节缓冲区中读取模块声明的二进制形式作为模块描述符。
      Methods in java.lang.module with parameters of type ModuleDescriptor
      Modifier and Type 方法 描述
      int ModuleDescriptor.compareTo​(ModuleDescriptor that)
      将此模块描述符与其他描述符进行比较
      Constructors in java.lang.module with parameters of type ModuleDescriptor
      Constructor 描述
      ModuleReference​(ModuleDescriptor descriptor, URI location)
      构造一个这个类的新实例。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Builder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Builder

  • Packages that use ModuleDescriptor.Builder
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Builder in java.lang.module

      Methods in java.lang.module that return ModuleDescriptor.Builder
      Modifier and Type 方法 描述
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(ModuleDescriptor.Exports e)
      添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(String pn)
      添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(String pn, Set<String> targets)
      添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn)
      使用给定（可能为空）的修饰符集添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn, Set<String> targets)
      使用给定（可能为空）的修饰符集添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.mainClass​(String mc)
      设置模块主类。
      static ModuleDescriptor.Builder ModuleDescriptor.newAutomaticModule​(String name)
      实例化构建器为自动模块构建模块描述符。
      static ModuleDescriptor.Builder ModuleDescriptor.newModule​(String name)
      实例化构建器以构建 正常模块的模块描述符。
      static ModuleDescriptor.Builder ModuleDescriptor.newModule​(String name, Set<ModuleDescriptor.Modifier> ms)
      实例化构建器以构建模块描述符。
      static ModuleDescriptor.Builder ModuleDescriptor.newOpenModule​(String name)
      实例化构建器为开放模块构建模块描述符。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(ModuleDescriptor.Opens obj)
      添加一个开放的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(String pn)
      添加一个开放的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(String pn, Set<String> targets)
      添加一个开放的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn)
      添加一个带有给定（可能为空）的修饰符集的开放包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn, Set<String> targets)
      添加一个带有给定（可能为空）的修饰符集的开放包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.packages​(Set<String> pns)
      将包添加到模块。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.provides​(ModuleDescriptor.Provides p)
      为一个或多个实现提供服务。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.provides​(String service, List<String> providers)
      提供服务的实现。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(ModuleDescriptor.Requires req)
      增加对模块的依赖。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(String mn)
      使用一组空白的修饰符添加对模块的依赖。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn, ModuleDescriptor.Version compiledVersion)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.uses​(String service)
      增加服务依赖性。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.version​(ModuleDescriptor.Version v)
      设置模块版本。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.version​(String vs)
      设置模块版本。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Exports (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Exports

  • Packages that use ModuleDescriptor.Exports
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Exports in java.lang.module

      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Exports
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Exports> ModuleDescriptor.exports​()
      返回表示导出的包的 Exports对象的集合。
      Methods in java.lang.module with parameters of type ModuleDescriptor.Exports
      Modifier and Type 方法 描述
      int ModuleDescriptor.Exports.compareTo​(ModuleDescriptor.Exports that)
      将此模块导出与另一个进行比较。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(ModuleDescriptor.Exports e)
      添加导出的包。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Exports.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Exports.Modifier

  • Packages that use ModuleDescriptor.Exports.Modifier
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Exports.Modifier in java.lang.module

      Methods in java.lang.module that return ModuleDescriptor.Exports.Modifier
      Modifier and Type 方法 描述
      static ModuleDescriptor.Exports.Modifier ModuleDescriptor.Exports.Modifier.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Exports.Modifier[] ModuleDescriptor.Exports.Modifier.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Exports.Modifier
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Exports.Modifier> ModuleDescriptor.Exports.modifiers​()
      返回一组修饰符。
      Method parameters in java.lang.module with type arguments of type ModuleDescriptor.Exports.Modifier
      Modifier and Type 方法 描述
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn)
      使用给定（可能为空）的修饰符集添加导出的包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.exports​(Set<ModuleDescriptor.Exports.Modifier> ms, String pn, Set<String> targets)
      使用给定（可能为空）的修饰符集添加导出的包。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Modifier

  • Packages that use ModuleDescriptor.Modifier
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Modifier in java.lang.module

      Methods in java.lang.module that return ModuleDescriptor.Modifier
      Modifier and Type 方法 描述
      static ModuleDescriptor.Modifier ModuleDescriptor.Modifier.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Modifier[] ModuleDescriptor.Modifier.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Modifier
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Modifier> ModuleDescriptor.modifiers​()
      返回一组模块修饰符。
      Method parameters in java.lang.module with type arguments of type ModuleDescriptor.Modifier
      Modifier and Type 方法 描述
      static ModuleDescriptor.Builder ModuleDescriptor.newModule​(String name, Set<ModuleDescriptor.Modifier> ms)
      实例化构建器以构建模块描述符。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Opens (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Opens

  • Packages that use ModuleDescriptor.Opens
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Opens in java.lang.module

      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Opens
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Opens> ModuleDescriptor.opens​()
      返回表示开放包的 Opens对象集。
      Methods in java.lang.module with parameters of type ModuleDescriptor.Opens
      Modifier and Type 方法 描述
      int ModuleDescriptor.Opens.compareTo​(ModuleDescriptor.Opens that)
      比较这个模块打开另一个。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(ModuleDescriptor.Opens obj)
      添加一个开放的包。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Opens.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Opens.Modifier

  • Packages that use ModuleDescriptor.Opens.Modifier
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Opens.Modifier in java.lang.module

      Methods in java.lang.module that return ModuleDescriptor.Opens.Modifier
      Modifier and Type 方法 描述
      static ModuleDescriptor.Opens.Modifier ModuleDescriptor.Opens.Modifier.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Opens.Modifier[] ModuleDescriptor.Opens.Modifier.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Opens.Modifier
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Opens.Modifier> ModuleDescriptor.Opens.modifiers​()
      返回一组修饰符。
      Method parameters in java.lang.module with type arguments of type ModuleDescriptor.Opens.Modifier
      Modifier and Type 方法 描述
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn)
      添加一个带有给定（可能为空）的修饰符集的开放包。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.opens​(Set<ModuleDescriptor.Opens.Modifier> ms, String pn, Set<String> targets)
      添加一个带有给定（可能为空）的修饰符集的开放包。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Provides (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Provides

  • Packages that use ModuleDescriptor.Provides
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Provides in java.lang.module

      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Provides
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Provides> ModuleDescriptor.provides​()
      返回表示模块提供的服务的 Provides对象集。
      Methods in java.lang.module with parameters of type ModuleDescriptor.Provides
      Modifier and Type 方法 描述
      int ModuleDescriptor.Provides.compareTo​(ModuleDescriptor.Provides that)
      比较这提供给另一个。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.provides​(ModuleDescriptor.Provides p)
      为一个或多个实现提供服务。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Requires (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Requires

  • Packages that use ModuleDescriptor.Requires
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Requires in java.lang.module

      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Requires
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Requires> ModuleDescriptor.requires​()
      返回表示模块依赖关系的 Requires对象的集合。
      Methods in java.lang.module with parameters of type ModuleDescriptor.Requires
      Modifier and Type 方法 描述
      int ModuleDescriptor.Requires.compareTo​(ModuleDescriptor.Requires that)
      将此模块的依赖性与另一个模型相比较
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(ModuleDescriptor.Requires req)
      增加对模块的依赖。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Requires.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Requires.Modifier

  • Packages that use ModuleDescriptor.Requires.Modifier
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Requires.Modifier in java.lang.module

      Methods in java.lang.module that return ModuleDescriptor.Requires.Modifier
      Modifier and Type 方法 描述
      static ModuleDescriptor.Requires.Modifier ModuleDescriptor.Requires.Modifier.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static ModuleDescriptor.Requires.Modifier[] ModuleDescriptor.Requires.Modifier.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Requires.Modifier
      Modifier and Type 方法 描述
      Set<ModuleDescriptor.Requires.Modifier> ModuleDescriptor.Requires.modifiers​()
      返回一组修饰符。
      Method parameters in java.lang.module with type arguments of type ModuleDescriptor.Requires.Modifier
      Modifier and Type 方法 描述
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn, ModuleDescriptor.Version compiledVersion)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleDescriptor.Version (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleDescriptor.Version

  • Packages that use ModuleDescriptor.Version
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleDescriptor.Version in java.lang.module

      Methods in java.lang.module that return ModuleDescriptor.Version
      Modifier and Type 方法 描述
      static ModuleDescriptor.Version ModuleDescriptor.Version.parse​(String v)
      将给定的字符串解析为版本字符串。
      Methods in java.lang.module that return types with arguments of type ModuleDescriptor.Version
      Modifier and Type 方法 描述
      Optional<ModuleDescriptor.Version> ModuleDescriptor.Requires.compiledVersion​()
      如果在编译时记录，则返回模块的版本。
      Optional<ModuleDescriptor.Version> ModuleDescriptor.version​()
      返回模块版本。
      Methods in java.lang.module with parameters of type ModuleDescriptor.Version
      Modifier and Type 方法 描述
      int ModuleDescriptor.Version.compareTo​(ModuleDescriptor.Version that)
      将此模块版本与其他模块版本进行比较。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.requires​(Set<ModuleDescriptor.Requires.Modifier> ms, String mn, ModuleDescriptor.Version compiledVersion)
      使用给定（可能为空）的修饰符集添加对模块的依赖。
      ModuleDescriptor.Builder ModuleDescriptor.Builder.version​(ModuleDescriptor.Version v)
      Sets the module version.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ModuleReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ModuleReference

  • Packages that use ModuleReference
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleReference in java.lang.module

      Methods in java.lang.module that return ModuleReference
      Modifier and Type 方法 描述
      ModuleReference ResolvedModule.reference​()
      返回对模块内容的引用。
      Methods in java.lang.module that return types with arguments of type ModuleReference
      Modifier and Type 方法 描述
      Optional<ModuleReference> ModuleFinder.find​(String name)
      查找给定名称的模块的引用。
      Set<ModuleReference> ModuleFinder.findAll​()
      返回此查找器可以找到的所有模块引用的集合。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ResolutionException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ResolutionException

No usage of java.lang.module.ResolutionException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.module.ResolvedModule (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.module.ResolvedModule

  • Packages that use ResolvedModule
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ResolvedModule in java.lang.module

      Methods in java.lang.module that return types with arguments of type ResolvedModule
      Modifier and Type 方法 描述
      Optional<ResolvedModule> Configuration.findModule​(String name)
      在此配置中找到一个已解决的模块，或者在此配置中 找不到parent配置。
      Set<ResolvedModule> Configuration.modules​()
      在此配置中返回一组不可变的已解析模块。
      Set<ResolvedModule> ResolvedModule.reads​()
      返回已解析模块读取的已解析模块集。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.module.ModuleFinder (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.module.ModuleFinder

  • Packages that use ModuleFinder
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleFinder in java.lang.module

      Methods in java.lang.module that return ModuleFinder
      Modifier and Type 方法 描述
      static ModuleFinder ModuleFinder.compose​(ModuleFinder... finders)
      返回由零个或多个模块查找器的序列组成的模块查找器。
      static ModuleFinder ModuleFinder.of​(Path... entries)
      返回通过搜索一系列目录和/或打包模块来定位文件系统上的模块的模块查找器。
      static ModuleFinder ModuleFinder.ofSystem​()
      返回找到 系统模块的模块查找器。
      Methods in java.lang.module with parameters of type ModuleFinder
      Modifier and Type 方法 描述
      static ModuleFinder ModuleFinder.compose​(ModuleFinder... finders)
      返回由零个或多个模块查找器的序列组成的模块查找器。
      Configuration Configuration.resolve​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一个根模块的集合，以此配置为其父级，以创建新的配置。
      static Configuration Configuration.resolve​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解析根模块的集合以创建配置。
      Configuration Configuration.resolveAndBind​(ModuleFinder before, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定，并将此配置作为其父配置来创建新配置。
      static Configuration Configuration.resolveAndBind​(ModuleFinder before, List<Configuration> parents, ModuleFinder after, Collection<String> roots)
      解决一系列根模块，具有服务绑定功能，以创建配置。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.module.ModuleReader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.module.ModuleReader

  • Packages that use ModuleReader
    软件包 描述
    java.lang.module
    通过分辨率和服务绑定来支持模块描述符和创建模块配置的类。

    • Uses of ModuleReader in java.lang.module

      Methods in java.lang.module that return ModuleReader
      Modifier and Type 方法 描述
      abstract ModuleReader ModuleReference.open​()
      打开模块内容进行阅读。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Cleaner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.ref

Class Cleaner

  • java.lang.Object
    • java.lang.ref.Cleaner

  • public final class Cleaner
extends Object
    Cleaner管理一组对象引用和相应的清理操作。

    清洁动作是registered运行后，清洁剂通知对象已经成为幻影可到达。 当reachability更改时，清洁剂使用PhantomReference和ReferenceQueue进行通知。

    每个清洁剂独立操作，管理待处理的清洁操作，并在清洁剂不再使用时处理螺纹和终止。 注册对象引用和相应的清除操作返回一个Cleanable 。 最有效的用途是在对象关闭或不再需要时显式调用clean方法。 清除动作是一个Runnable ，当对象已经成为幻影可达时，除非已被明确清除，否则最多只能调用一次。 请注意，清洁操作不得引用正在注册的对象。 如果是这样，该对象将不会变为幻像，并且不会自动调用清除操作。

    清洁动作的执行由与清洁器相关联的螺纹执行。 清除操作抛出的所有异常都被忽略。 更清洁和其他清洁操作不受清洁操作中的例外的影响。 线程运行直到所有注册的清洁操作完成，并且清洁器本身由垃圾收集器回收。

    System.exit中清洁工的行为是具体的实现。 没有保证是否调用清洁措施。

    除非另有说明，否则将null参数传递给null中的构造函数或方法将导致抛出NullPointerException 。

    API Note:
    只有在关联对象变为幻像可访问之后才调用清除操作，因此执行清除操作的对象不会保留对对象的引用很重要。 在这个例子中，静态类封装了清理状态和操作。 不能使用“内部”类，无法使用，因为它隐含地包含对外部实例的引用，从而阻止它变为幻像可访问。 选择新的清洁剂或共享现有的清洁剂是由用例决定的。

    如果在try-finally块中使用CleaningExample，那么close方法将调用清除操作。 如果未调用close方法，则当CleaningExample实例变为幻像可访问时，Cleaner会调用清理操作。

       public class CleaningExample implements AutoCloseable { // A cleaner, preferably one shared within a library private static final Cleaner cleaner = <cleaner>; static class State implements Runnable { State(...) { // initialize State needed for cleaning action } public void run() { // cleanup action accessing State, executed at most once } } private final State; private final Cleaner.Cleanable cleanable public CleaningExample() { this.state = new State(...); this.cleanable = cleaner.register(this, state); } public void close() { cleanable.clean(); } }
    清洁动作可以是lambda，但是通过参考被清除的对象的字段，可以很容易地捕获对象引用，从而防止对象变得虚幻可到达。 使用静态嵌套类，如上所述，将避免意外保留对象引用。

    清洁行动应准备与其他清洁行动同时调用。 通常，清洁操作应该非常快速地执行而不是阻止。 如果清洁动作阻塞，则可能延迟处理注册到同一清洁剂的其他清洁操作。 注册到清洁剂的所有清洁措施应相互兼容。

    从以下版本开始：
    9

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static interface  Cleaner.Cleanable
      Cleanable表示在 Cleaner注册的对象和清理动作。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Cleaner create​()
      返回一个新的 Cleaner 。
      static Cleaner create​(ThreadFactory threadFactory)
      返回一个新的 Cleaner使用 Thread从 ThreadFactory 。
      Cleaner.Cleanable register​(Object obj, Runnable action)
      注册一个对象和一个清理动作，以便在对象变为幻像时可以运行。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • create

        public static Cleaner create​()
        返回一个新的Cleaner 。

        清洁器创建一个daemon thread来处理幻像可到达对象并调用清理操作。 该context class loader线程设置为system class loader 。 线程没有权限，只有在一个SecurityManager is set执行。

        当幻影可到达并且所有注册的清洁操作都完成时，清洁程序将终止。

        结果
        一个新的 Cleaner
        异常
        SecurityException - 如果当前线程不允许创建或启动线程。

      • create

        public static Cleaner create​(ThreadFactory threadFactory)
        返回一个新的Cleaner使用Thread从ThreadFactory 。

        线程工厂的newThread方法的线程设置为daemon thread，并开始处理幻像可到达对象并调用清理操作。 在每次调用时， thread factory必须提供适合执行清洁操作的线程。

        当幻影可到达并且所有注册的清洁操作都完成时，清洁程序将终止。

        参数
        threadFactory - a ThreadFactory返回新的 Thread处理清洁措施
        结果
        一个新的 Cleaner
        异常
        IllegalThreadStateException - 如果线程工厂的线程是 not a new thread 。
        SecurityException - 如果当前线程不允许创建或启动线程。

      • register

        public Cleaner.Cleanable register​(Object obj,
                                  Runnable action)
        注册一个对象和一个清理动作，以便在对象变为幻像时可以运行。 有关清洁操作的行为的注意事项，请参阅上述API Note 。
        参数
        obj - 要监视的对象
        action - 一个 Runnable当对象变为幻像可到达时调用
        结果
        a Cleanable instance
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Cleaner.Cleanable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.ref

Interface Cleaner.Cleanable

  • Enclosing class:
    Cleaner

    public static interface Cleaner.Cleanable
    Cleanable表示在 Cleaner注册的对象和清洁动作。
    从以下版本开始：
    9

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void clean​()
      取消注册可清洁并调用清洁操作。

    • 方法详细信息

      • clean

        void clean​()
        取消注册可清洁并调用清洁操作。 无论呼叫次数clean ，最多可以调用可清洁的清洁操作。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.lang.ref (Java SE 9 & JDK 9 )

java.lang.ref

Interfaces

  • Cleaner.Cleanable

Classes

  • Cleaner
  • PhantomReference
  • Reference
  • ReferenceQueue
  • SoftReference
  • WeakReference


java.lang.ref (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.lang.ref

提供参考对象类，它支持与垃圾收集器的有限度的交互。 程序可以使用引用对象来维护对某个其他对象的引用，使得后一对象可能仍然被收集器回收。 在收集者确定给定对象的可达性已经改变之后，程序也可以安排通知一段时间。

包装规格

引用对象封装了一些其他对象的引用，使得引用本身可以像任何其他对象一样进行检查和操作。 提供了三种类型的参考对象，一个比一个弱： 软 ， 弱 ，和幻象 。 每种类型对应于不同的可达性级别，如下所述。 软引用用于实现内存敏感缓存，弱引用用于实现不阻止其键（或值）回收的规范化映射，幻像引用用于调度事后清除操作。 验尸清理行动可以通过Cleaner进行注册和管理。

每个引用对象类型由抽象基础Reference类的子类实现。 这些子类之一的实例封装了一个称为对象的特定对象的单引用 。 每个引用对象都提供了获取和清除引用的方法。 除了清算操作之外，参考对象是不可变的，因此不提供set操作。 程序可以进一步子类化这些子类，为其目的添加所需的任何字段和方法，或者可以使用这些子类而不改变。

通知

程序可以通过在创建参考对象时注册具有参考队列的适当参考对象来请求通知对象可达性的变化。 在垃圾回收器确定指示物的可达性已更改为与引用类型相对应的值之后的某个时间，它将清除引用并将其添加到关联的队列中。 在这一点上，引用被认为是入队的 。 该程序可以通过轮询或阻塞直到引用可用来删除队列中的引用。 参考队列由ReferenceQueue类实现。

注册参考对象与其队列之间的关系是片面的。 也就是说，队列不跟踪注册的引用。 如果注册的引用本身不可达，那么它永远不会被排入队列。 使用参考对象的程序有责任确保只要程序对其指示感兴趣，对象仍然可以访问。

虽然一些程序将选择专用线程从一个或多个队列中删除引用对象并处理它们，但这绝对不是必需的。 通常工作良好的策略是在执行其他相当频繁的操作过程中检查参考队列。 例如，使用弱引用来实现弱键的散列表可以在每次访问表时轮询其引用队列。 这是WeakHashMap课程的工作原理。 因为ReferenceQueue.poll方法只是检查一个内部的数据结构，所以这个检查对于哈希表访问方法将增加一点开销。

可达性

从最强到最弱，不同层次的可达性反映了物体的生命周期。 它们的操作定义如下：
  • 如果某个线程可以在没有遍历任何引用对象的情况下达到该对象，则该对象是强大的可访问的 。 新创建的对象由创建它的线程强大可见。
  • 如果物体不可靠，但通过穿过软参考点可以达到，物体可轻松到达 。
  • 一个对象是弱可及 ，如果它是既不坚决也不是软可及的，但通过遍历弱引用可以到达。 当对弱可触及对象的弱引用被清除时，该对象就可以进行定稿。
  • 一个对象是幻影可以到达，如果它既不强烈，轻微，也不弱可达，它已经定稿，一些幻影参考是指它。
  • 最后，一个对象是无法访问的 ，因此，如果以上述任何一种方式都无法访问，就可以进行填海。
从以下版本开始：
1.2
  • 接口摘要
    接口 描述
    Cleaner.Cleanable
    Cleanable表示在 Cleaner注册的对象和清洁动作。
  • 类摘要
    Class 描述
    Cleaner
    Cleaner管理一组对象引用和相应的清理动作。
    PhantomReference<T>
    在收集者确定其指示物可能被回收之后排入队列的Phantom参考对象。
    Reference<T>
    参考对象的抽象基类。
    ReferenceQueue<T>
    在检测到适当的可达性更改后，引用队列被垃圾收集器附加到哪个已注册的参考对象。
    SoftReference<T>
    软参考对象，由垃圾收集器根据内存需求自行清除。
    WeakReference<T>
    弱参考对象，不会阻止其指定对象的最终确定，最终确定，然后被回收。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang.ref Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang.ref

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.ref.Cleaner
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
      • java.lang.ref.SoftReference<T>
      • java.lang.ref.WeakReference<T>
    • java.lang.ref.ReferenceQueue<T>

Interface Hierarchy

  • java.lang.ref.Cleaner.Cleanable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


PhantomReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.ref

Class PhantomReference<T>

  • java.lang.Object
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>

  • public class PhantomReference<T>
extends Reference<T>
    在收集者确定其指示物可能被回收之后排入队列的Phantom参考对象。 幽灵引用通常用于安排事后清除操作。

    假设垃圾收集器在某个时间点确定对象是phantom reachable 。 那时，它将原子地清除对该对象的所有幻影引用，以及对该对象可访问的任何其他可幻像对象的所有幻影引用。 在同一时间或稍后的时间，它将排入在引用队列中注册的新清除的幻像引用。

    为了确保可回收对象保持get可能无法检索幻像引用的引用：幻像引用的get方法始终返回null 。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      PhantomReference​(T referent, ReferenceQueue<? super T> q)
      创建引用给定对象并在给定队列中注册的新幻影引用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T get​()
      返回此引用对象的指示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.lang.ref.Reference

        clear, enqueue, isEnqueued, reachabilityFence

    • 构造方法详细信息

      • PhantomReference

        public PhantomReference​(T referent,
                        ReferenceQueue<? super T> q)
        创建引用给定对象并在给定队列中注册的新幻影引用。

        可以使用null队列创建幻像参考，但是这样的引用是完全无用的：它的get方法将始终返回null并且由于它没有队列，它将永远不会排入队列。

        参数
        referent - 新幻影引用将引用的对象
        q - 要注册的队列，如果不需要注册， null

    • 方法详细信息

      • get

        public T get​()
        返回此引用对象的指示。 因为幻影引用的引用总是无法访问的，所以该方法总是返回null 。
        重写：
        get在 Reference<T>
        结果
        null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Reference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.ref

Class Reference<T>

  • java.lang.Object
    • java.lang.ref.Reference<T>
  • 已知直接子类：
    PhantomReference ， SoftReference ， WeakReference

    public abstract class Reference<T>
extends Object
    参考对象的抽象基类。 该类定义了所有引用对象共同的操作。 由于引用对象与垃圾收集器密切配合实现，所以该类可能不会被直接子类化。
    从以下版本开始：
    1.2

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void clear​()
      清除此参考对象。
      boolean enqueue​()
      清除此引用对象并将其添加到与其注册的队列（如果有）。
      T get​()
      返回此引用对象的指示。
      boolean isEnqueued​()
      通过程序或垃圾收集器来告知这个引用对象是否已经入队。
      static void reachabilityFence​(Object ref)
      确保给定引用引用的对象仍然是strongly reachable ，无论程序的任何先前的操作可能会导致对象变得不可访问; 因此，至少在调用此方法之后，引用的对象不能通过垃圾回收来回收。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • get

        public T get​()
        返回此引用对象的指示。 如果此引用对象已被清除，无论是由程序还是由垃圾回收器清除，则此方法返回null 。
        结果
        该引用引用的对象，如果此引用对象已被清除， null

      • clear

        public void clear​()
        清除此参考对象。 调用此方法不会导致此对象入队。

        此方法仅由Java代码调用; 当垃圾收集器清除引用时，它直接执行，而不调用此方法。

      • isEnqueued

        public boolean isEnqueued​()
        通过程序或垃圾收集器来告知这个引用对象是否已经入队。 如果此引用对象在创建时未注册队列，则此方法将始终返回false 。
        结果
        true当且仅当该引用对象已被入队时

      • enqueue

        public boolean enqueue​()
        清除此引用对象并将其添加到与其注册的队列（如果有）。

        此方法仅由Java代码调用; 当垃圾回收器排队引用时，它直接执行，而不调用此方法。

        结果
        true如果此引用对象成功入队; false如果它已经入队了，或者如果它没有在创建队列时注册

      • reachabilityFence

        public static void reachabilityFence​(Object ref)
        确保给定引用引用的对象仍然是strongly reachable ，而不管程序的任何先前的动作，否则可能导致对象变得不可访问; 因此，至少在调用此方法之后，引用的对象不能通过垃圾回收来回收。 调用此方法本身不会启动垃圾回收或完成。

        该方法建立了关于垃圾收集的strong reachability的排序。 它控制否则仅在程序中隐含的关系 - 触发垃圾回收的可达性条件。 该方法设计用于不常见的过早完成情况，其中使用synchronized块或方法，或使用其他同步设施是不可能的或不提供所需的控制。 该方法仅在回收可能具有可见效果时才适用，这对于具有终结器（见Section 12.6 17 of The Java™ Language Specification ）的对象可能依赖于排序控制的正确性实现。

        API Note:
        只要虚拟机检测到对对象的引用将永远不会存储在堆中，则可能会进行完成：即使该对象的字段仍在使用中，垃圾收集器也可能会回收对象，只要对象已经无法访问。 这在例如与通过数组索引来管理类相关联的簿记的以下示例的情况下可能具有令人惊讶和不期望的效果。 这里，方法action使用reachabilityFence来确保Resource对象在已经执行关联的ExternalResource上的记账之前未被回收; 特别是在这里，为了确保在方法Object.finalize()中保持ExternalResource的阵列槽没有被消除 ，否则可能并行运行。
           class Resource { private static ExternalResource[] externalResourceArray = ... int myIndex; Resource(...) { myIndex = ... externalResourceArray[myIndex] = ...; ... } protected void finalize() { externalResourceArray[myIndex] = null; ... } public void action() { try { // ... int i = myIndex; Resource.update(externalResourceArray[i]); } finally { Reference.reachabilityFence(this); } } private static void update(ExternalResource ext) { ext.status = ...; } }
        这里， reachabilityFence的调用reachabilityFence直观地放置在调用update ，以确保在更新之前Object.finalize()不排除阵列插槽，即使是对这个对象的最后一次使用的调用action 。 如果例如用户程序中的用法的格式为new Resource().action(); ，则不会对此Resource保留其他引用，则可能是这种Resource 。 虽然这里可能是过度的， reachabilityFence被放置在一个finally块中，以确保在方法中的所有路径上调用它。 在具有更复杂控制路径的方法中，您可能需要进一步的预防措施，以确保所有这些reachabilityFence都遇到reachabilityFence 。

        有时可以更好地封装使用reachabilityFence 。 继续上述示例，即使方法update的调用是可接受的，即使终结器已经执行（空出插槽），则可以本地化使用reachabilityFence ：

           public void action2() { // ... Resource.update(getExternalResource()); } private ExternalResource getExternalResource() { ExternalResource ext = externalResourceArray[myIndex]; Reference.reachabilityFence(this); return ext; }

        方法reachabilityFence在其自身确保可达性的结构中不是必需的。 例如，因为被锁定的对象通常不能被回收，所以在Resource所有方法（包括finalize ）中的对象的所有访问都包含在synchronized (this)块中就synchronized (this) 。 （此外，这些块不能包括无限循环，或者它们本身是不可达到的，这些循环落入“一般”免责声明中的角落外的例外。）然而，方法reachabilityFence在这种方法效率不高的情况下仍然是更好的选择，可取的或可能的; 例如因为它会遇到死锁。

        参数
        ref - 参考。 如果是null ，这个方法没有效果。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReferenceQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.ref

Class ReferenceQueue<T>

  • java.lang.Object
    • java.lang.ref.ReferenceQueue<T>

  • public class ReferenceQueue<T>
extends Object
    在检测到适当的可达性更改后，引用队列被垃圾收集器附加到哪个已注册的参考对象。
    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReferenceQueue​()
      构造一个新的引用对象队列。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Reference<? extends T> poll​()
      轮询此队列以查看引用对象是否可用。
      Reference<? extends T> remove​()
      删除此队列中的下一个参考对象，阻塞直到可用。
      Reference<? extends T> remove​(long timeout)
      删除此队列中的下一个参考对象，阻塞，直到任何一个可用或给定的超时期限到期。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ReferenceQueue

        public ReferenceQueue​()
        构造一个新的引用对象队列。

    • 方法详细信息

      • poll

        public Reference<? extends T> poll​()
        轮询此队列以查看引用对象是否可用。 如果没有进一步延迟可用，那么它将从队列中删除并返回。 否则，此方法立即返回null 。
        结果
        一个参考对象，如果一个可以立即可用，否则为 null

      • remove

        public Reference<? extends T> remove​(long timeout)
                              throws IllegalArgumentException,
                                     InterruptedException
        删除此队列中的下一个参考对象，阻塞，直到任何一个可用或给定的超时期限到期。

        此方法不提供实时保证：它调度超时，就像调用Object.wait(long)方法一样。

        参数
        timeout - 如果为正，则在等待引用添加到此队列时，阻塞最多timeout毫秒。 如果为零，则无限期地阻止。
        结果
        参考对象，如果在指定的超时时间内可用，否则为 null
        异常
        IllegalArgumentException - 如果timeout参数的值为负
        InterruptedException - 如果超时等待中断

      • remove

        public Reference<? extends T> remove​()
                              throws InterruptedException
        删除此队列中的下一个参考对象，阻塞直到可用。
        结果
        引用对象，阻塞，直到可用
        异常
        InterruptedException - 如果等待中断
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SoftReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.ref

Class SoftReference<T>

  • java.lang.Object
    • java.lang.ref.Reference<T>
      • java.lang.ref.SoftReference<T>

  • public class SoftReference<T>
extends Reference<T>
    软参考对象，由垃圾收集器根据内存需求自行清除。 软引用通常用于实现对内存敏感的缓存。

    假设垃圾收集器在某个时间点确定对象是softly reachable 。 那时候，它可能会选择原子地清除对该对象的所有软引用，以及对任何其他可轻松访问的对象的所有软引用，通过一个强引用链可以从该对象到达该对象。 在同一时间或稍后的时间，它将排入在引用队列中注册的新清除的软引用。

    虚拟机抛出一个OutOfMemoryError之前，所有对软可达对象的软引用保证被清除。 否则，在清除软引用的时间或者对一组对不同对象的引用将被清除的顺序没有约束。 但是，鼓励虚拟机实现偏离清除最近创建或最近使用的软参考。

    此类的直接实例可用于实现简单的缓存; 此类或派生子类也可用于较大的数据结构以实现更复杂的高速缓存。 只要软参考的指示是强有力的，即实际使用中，软参考将不会被清除。 因此，复杂的缓存可以例如阻止其最近使用的条目被丢弃，通过保持对这些条目的强烈的指示，使剩余的条目由垃圾收集器判断丢弃。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      SoftReference​(T referent)
      创建引用给定对象的新的软引用。
      SoftReference​(T referent, ReferenceQueue<? super T> q)
      创建引用给定对象并在给定队列中注册的新软引用。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      T get​()
      返回此引用对象的指示。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.lang.ref.Reference

        clear, enqueue, isEnqueued, reachabilityFence

    • 构造方法详细信息

      • SoftReference

        public SoftReference​(T referent)
        创建引用给定对象的新的软引用。 新引用未注册到任何队列。
        参数
        referent - 对新的软参考将参考

      • SoftReference

        public SoftReference​(T referent,
                     ReferenceQueue<? super T> q)
        创建引用给定对象并在给定队列中注册的新软引用。
        参数
        referent - 新的软参考将引用的对象
        q - 要注册的队列，如果不需要注册， null

    • 方法详细信息

      • get

        public T get​()
        返回此引用对象的指示。 如果此引用对象已被清除，无论是程序还是垃圾收集器，则此方法返回null 。
        重写：
        get在 Reference<T>
        结果
        The object to which this reference refers, or null if this reference object has been cleared
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.lang.ref (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang.ref

  • Packages that use java.lang.ref
    软件包 描述
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。
  • Classes in java.lang.ref used by java.lang.ref
    Class 描述
    Cleaner
    Cleaner管理一组对象引用和相应的清理动作。
    Cleaner.Cleanable
    Cleanable表示在 Cleaner注册的对象和清洁动作。
    Reference
    参考对象的抽象基类。
    ReferenceQueue
    在检测到适当的可达性更改后，引用队列被垃圾收集器附加到哪个已注册的参考对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


WeakReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.ref

Class WeakReference<T>

  • java.lang.Object
    • java.lang.ref.Reference<T>
      • java.lang.ref.WeakReference<T>

  • public class WeakReference<T>
extends Reference<T>
    弱参考对象，不会阻止其指定对象的最终确定，最终确定，然后被回收。 弱引用最常用于实现规范化映射。

    假设垃圾收集器在某个时间点确定对象是weakly reachable 。 那时，它将原子地清除对该对象的所有弱引用，以及所有弱引用到任何其他弱可触及的对象，通过一连串强软引用可以从该对象到达该对象。 同时，它将声明所有以前弱可触及的对象都是可以确定的。 在同一时间或稍后的时间，它将排列在引用队列中注册的新清除的弱引用。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      WeakReference​(T referent)
      创建引用给定对象的新的弱引用。
      WeakReference​(T referent, ReferenceQueue<? super T> q)
      创建引用给定对象并在给定队列中注册的新的弱引用。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.lang.ref.Reference

        clear, enqueue, get, isEnqueued, reachabilityFence

    • 构造方法详细信息

      • WeakReference

        public WeakReference​(T referent)
        创建引用给定对象的新的弱引用。 新引用未注册到任何队列。
        参数
        referent - 新的弱引用将引用

      • WeakReference

        public WeakReference​(T referent,
                     ReferenceQueue<? super T> q)
        创建引用给定对象并在给定队列中注册的新的弱引用。
        参数
        referent - 新的弱引用将引用
        q - 要注册参考的队列，如果不需要注册， null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class java.lang.ref.Cleaner (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ref.Cleaner

  • Packages that use Cleaner
    软件包 描述
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。

    • Uses of Cleaner in java.lang.ref

      Methods in java.lang.ref that return Cleaner
      Modifier and Type 方法 描述
      static Cleaner Cleaner.create​()
      返回一个新的 Cleaner 。
      static Cleaner Cleaner.create​(ThreadFactory threadFactory)
      返回一个新 Cleaner使用 Thread从 ThreadFactory 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ref.PhantomReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ref.PhantomReference

No usage of java.lang.ref.PhantomReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ref.Reference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ref.Reference

  • Packages that use Reference
    软件包 描述
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。

    • Uses of Reference in java.lang.ref

      Subclasses of Reference in java.lang.ref
      Modifier and Type Class 描述
      class  PhantomReference<T>
      在收集者确定其指示物可能被回收之后排入队列的Phantom参考对象。
      class  SoftReference<T>
      软参考对象，由垃圾收集器根据内存需求自行清除。
      class  WeakReference<T>
      弱参考对象，不会阻止其指定对象的最终确定，最终确定，然后被回收。
      Methods in java.lang.ref that return Reference
      Modifier and Type 方法 描述
      Reference<? extends T> ReferenceQueue.poll​()
      轮询此队列以查看引用对象是否可用。
      Reference<? extends T> ReferenceQueue.remove​()
      删除此队列中的下一个参考对象，阻塞直到可用。
      Reference<? extends T> ReferenceQueue.remove​(long timeout)
      Removes the next reference object in this queue, blocking until either one becomes available or the given timeout period expires.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ref.ReferenceQueue (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ref.ReferenceQueue

  • Packages that use ReferenceQueue
    软件包 描述
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。

    • Uses of ReferenceQueue in java.lang.ref

      Constructors in java.lang.ref with parameters of type ReferenceQueue
      Constructor 描述
      PhantomReference​(T referent, ReferenceQueue<? super T> q)
      创建引用给定对象并在给定队列中注册的新幻影引用。
      SoftReference​(T referent, ReferenceQueue<? super T> q)
      创建引用给定对象并在给定队列中注册的新软引用。
      WeakReference​(T referent, ReferenceQueue<? super T> q)
      创建引用给定对象并在给定队列中注册的新的弱引用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ref.SoftReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ref.SoftReference

No usage of java.lang.ref.SoftReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.ref.WeakReference (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.ref.WeakReference

No usage of java.lang.ref.WeakReference
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.ref.Cleaner.Cleanable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.ref.Cleaner.Cleanable

  • Packages that use Cleaner.Cleanable
    软件包 描述
    java.lang.ref
    提供参考对象类，它支持与垃圾收集器的有限度的交互。

    • Uses of Cleaner.Cleanable in java.lang.ref

      Methods in java.lang.ref that return Cleaner.Cleanable
      Modifier and Type 方法 描述
      Cleaner.Cleanable Cleaner.register​(Object obj, Runnable action)
      注册一个对象和一个清理动作，以便在对象变为幻像时可以运行。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


AccessibleObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class AccessibleObject

  • java.lang.Object
    • java.lang.reflect.AccessibleObject
  • All Implemented Interfaces:
    AnnotatedElement
    已知直接子类：
    Executable ， Field

    public class AccessibleObject
extends Object
implements AnnotatedElement
    所述AccessibleObject类是基础类Field ， 方法 ，和Constructor对象（被称为反射的对象 ）。 它可以将反射对象标记为在使用Java语言访问控制时抑制检查。 这允许具有足够权限的复杂应用程序（例如Java对象序列化或其他持久性机制）以通常被禁止的方式操纵对象。

    Java语言访问控制防止在其课外使用私人成员; 包裹访问成员在包装外; 受保护的成员在其包或子类之外; 和公共成员之外的模块，除非它们被声明在一个exported包和用户reads他们的模块。 默认情况下，当Field s， 方法 s或Constructor用于获取或设置字段，调用方法或分别创建和初始化新的实例时，Java语言访问控制将被强制执行（有一个变体）。 每个反射对象检查使用它的代码是否在适当的类，包或模块中。

    Java语言访问控制的一个变体是反射对象的检查是可读性的。 也就是说，假设使用反射对象的模块读取其中声明了基础字段，方法或构造函数的模块。

    是否可以抑制对Java语言访问控制的检查（从而可以启用访问）取决于反射对象是否对应于导出或打开的包中的成员（请参阅setAccessible(boolean) ）。

    从以下版本开始：
    1.2
    See The Java™ Language Specification:
    6.6访问控制

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected AccessibleObject​()
      构造函数：仅由Java虚拟机使用。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      boolean canAccess​(Object obj)
      测试调用者是否可以访问此反射对象。
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getAnnotations​()
      返回此元素上 存在的注释。
      <T extends Annotation>
      T[]             		getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T             		getDeclaredAnnotation​(Class<T> annotationClass)
      如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      <T extends Annotation>
      T[]             		getDeclaredAnnotationsByType​(Class<T> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      boolean isAccessible​()
      已过时。
      此方法已被弃用，因为它的名称提示它检查反射对象是否可访问，当它实际指示是否抑制对Java语言访问控制的检查。 此方法可能会在调用者可访问的反射对象上返回false 。 要测试此反射对象是否可访问，应使用canAccess(Object) 。
      boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。
      void setAccessible​(boolean flag)
      将此反射对象的 accessible标志设置为指示的布尔值。
      static void setAccessible​(AccessibleObject[] array, boolean flag)
      方便的方法来设置 accessible标志的反射对象数组，并进行单次安全检查（以提高效率）。
      boolean trySetAccessible​()
      设置 accessible标志这反映了反对 true如果可能的话。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AccessibleObject

        protected AccessibleObject​()
        构造函数：仅由Java虚拟机使用。

    • 方法详细信息

      • setAccessible

        public static void setAccessible​(AccessibleObject[] array,
                                 boolean flag)
        方便的方法来设置accessible标志的反射对象数组，并进行一次安全检查（以提高效率）。

        当setAccessible(boolean)指定可以启用对每个反射对象的访问时，此方法可用于启用对阵列中所有反射对象的访问。

        如果有一个安全管理器，它的checkPermission方法首先被调用一个ReflectPermission("suppressAccessChecks")权限。

        如果输入array任何元素是java.lang.Class和flag类的Constructor对象，则也抛出A SecurityException 。

        参数
        array - AccessibleObjects的数组
        flag - 每个对象中的 accessible标志的新值
        异常
        InaccessibleObjectException - 如果无法为阵列中的所有对象启用访问权限
        SecurityException - 如果请求被安全管理器拒绝，或者阵列中的元素是一个构造函数，用于 java.lang.Class
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， ReflectPermission

      • setAccessible

        public void setAccessible​(boolean flag)
        将此反射对象的accessible标志设置为指示的布尔值。 值为true表示反射对象应该在使用Java语言访问控制时抑制检查。 值为false表示反射对象应该在使用Java语言访问控制时执行检查，并在类描述中注明变体。

        呼叫者可以使用该方法在类别C中启用declaring class D D访问，如果以下任何一项保持：

        • C和D在相同的模块中。
        • 所述构件是public和D是public在于包含模块的封装D exports到至少包含模块C 。
        • 所述构件是protected static ， D是public在于包含模块的封装D出口到至少包含模块C ，和C是的一个子类D 。
        • D是在一个包中，模块包含D opens至少包含C的模块。 未命名和开放模块中的所有软件包均可对所有模块开放，因此当D处于未命名或打开模块时，此方法始终会成功。

        当声明类与调用者不同的模块时，此方法不能用于启用对私有成员，具有默认（包）访问权限的成员，受保护的实例成员或受保护的构造函数的访问，并且包含声明类的包不能打开呼叫者的模块。

        如果有一个安全管理员，它的checkPermission方法首先被调用一个ReflectPermission("suppressAccessChecks")权限。

        参数
        flag - 新值为 accessible旗帜
        异常
        InaccessibleObjectException - 如果无法启用访问
        SecurityException - 如果请求被安全管理器拒绝
        另请参见：
        trySetAccessible() ， MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • trySetAccessible

        public final boolean trySetAccessible​()
        设置accessible标志这反映了反对true如果可能的话。 该方法设置accessible标志，好像通过调用setAccessible(true) ，并返回可能更新的值为accessible标志。 如果访问无法启用，即支票或Java语言访问控制不能被抑制，这个方法返回false （相对于setAccessible(true)扔InaccessibleObjectException它失败时）。

        此方法是一种无操作如果accessible反射标记该对象是true 。

        例如，呼叫者可以调用trySetAccessible一个上方法对象私有实例方法p.T::privateMethod的时候打压Java语言访问控制检查方法被调用。 如果p.T类在一个不同的模块中，呼叫者和包p至少打开了呼叫者的模块，下面的代码成功地将accessible标志设置为true 。

           p.T obj = ....; // instance of p.T : Method m = p.T.class.getDeclaredMethod("privateMethod"); if (m.trySetAccessible()) { m.invoke(obj); } else { // package p is not opened to the caller to access private member of T ... }

        如果有一个安全管理员，它的checkPermission方法首先被调用了一个ReflectPermission("suppressAccessChecks")权限。

        结果
        true如果accessible标志设置为true ; false如果无法启用访问。
        异常
        SecurityException - 如果请求被安全管理器拒绝
        从以下版本开始：
        9
        另请参见：
        MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • isAccessible

        @Deprecated(since="9")
public boolean isAccessible​()
        已过时。 此方法已被弃用，因为它的名称提示它检查反射对象是否可访问，当它实际指示是否抑制对Java语言访问控制的检查。 此方法可能会在调用者可访问的反射对象上返回false 。 要测试此反射对象是否可访问，应使用canAccess(Object) 。
        获取此反射对象的 accessible标志的值。
        结果
        对象的 accessible标志

      • canAccess

        public final boolean canAccess​(Object obj)
        测试调用者是否可以访问此反射对象。 如果此反射对象对应于实例方法或字段，则此方法将测试调用者是否可以使用反映的对象访问给定的obj 。 对于实例方法或字段则obj参数必须是实例declaring class 。 对于静态成员和构造函数，那么obj必须是null 。

        如果accessible标志设置为true ，则该方法返回true ，即禁止对Java语言访问控制的检查，或者如果呼叫者可以访问The Java™ Language Specification中指定的成员，具有类描述中所述的变体。

        参数
        obj - 反射对象的声明类的实例对象（如果它是实例方法或字段）
        结果
        true如果调用者可以访问此反映的对象。
        异常
        IllegalArgumentException -
        • 如果该反映的对象是静态成员或构造函数，并且给定的obj是非null ，或
        • 如果这个反映的对象是一个实例方法或字段，给定的obj是null或类型，不是该成员的declaring class的子类。
        从以下版本开始：
        9
        另请参见：
        trySetAccessible() ， setAccessible(boolean)
        See The Java™ Language Specification:
        6.6访问控制

      • getAnnotation

        public <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        描述从接口AnnotatedElement复制
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        参数类型
        T - 要查询的注释的类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • isAnnotationPresent

        public boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
        如果此元素上存在指定类型的注释，则返回true，否则返回false。 该方法主要用于方便访问标记注释。

        该方法返回的真值等价于： getAnnotation(annotationClass) != null

        默认方法的主体被指定为上述代码。

        Specified by:
        isAnnotationPresent在接口 AnnotatedElement
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果此元素上存在指定注释类型的注释，则为true，否则为false
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getAnnotationsByType

        public <T extends Annotation> T[] getAnnotationsByType​(Class<T> annotationClass)
        说明从接口AnnotatedElement复制
        返回与此元素相关联的注释。 如果没有与此元素相关联的注释，则返回值为长度为0.的数组。此方法与AnnotatedElement.getAnnotation(Class)之间的区别在于该方法检测其参数是否为可重复注释类型 （JLS 9.6），如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotationsByType在接口 AnnotatedElement
        参数类型
        T - 要查询的注释的类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果与此元素相关联，则指定注释类型的所有元素注释，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getAnnotations

        public Annotation[] getAnnotations​()
        描述从接口AnnotatedElement复制
        返回此元素上存在的注释。 如果没有存在于此元素上注解，返回值是长度为0这种方法的调用者可以随意修改返回的数组的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotations在接口 AnnotatedElement
        结果
        此元素上出现的注释
        从以下版本开始：
        1.5

      • getDeclaredAnnotation

        public <T extends Annotation> T getDeclaredAnnotation​(Class<T> annotationClass)
        说明从接口AnnotatedElement复制
        如果这样的注释直接存在 ，则返回指定类型的元素注释，否则返回null。 此方法忽略继承的注释。 （如果此元素上没有注释，则返回null）
        Specified by:
        getDeclaredAnnotation在接口 AnnotatedElement
        参数类型
        T - 查询的注释类型，如果直接出现则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果直接出现在该元素上，则指定注释类型的元素注释，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotationsByType

        public <T extends Annotation> T[] getDeclaredAnnotationsByType​(Class<T> annotationClass)
        说明从接口AnnotatedElement复制
        如果此类注释直接存在或间接存在，则返回该元素的注释（指定类型）。 此方法忽略继承的注释。 如果此元素上没有直接或间接出现的指定注释，则返回值为长度为0的数组。此方法与AnnotatedElement.getDeclaredAnnotation(Class)之间的区别在于该方法检测其参数是否是可重复注释类型 （JLS 9.6），以及如果是，尝试通过“查看”容器注释（如果存在）来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotationsByType在接口 AnnotatedElement
        参数类型
        T - 直接或间接出现的查询和返回的注释类型
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        指定注释类型的所有这些元素的注释，如果直接或间接地存在于该元素上，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        说明从界面AnnotatedElement复制
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        结果
        此元素上直接显示的注释
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotatedArrayType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface AnnotatedArrayType

  • All Superinterfaces:
    AnnotatedElement ， AnnotatedType

    public interface AnnotatedArrayType
extends AnnotatedType
    AnnotatedArrayType表示阵列类型的潜在注释使用，其组件类型本身可以表示类型的注释使用。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AnnotatedType getAnnotatedGenericComponentType​()
      返回此数组类型的可能注释的通用组件类型。
      AnnotatedType getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotation, getAnnotations, getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotations, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from interface java.lang.reflect.AnnotatedType

        getType

    • 方法详细信息

      • getAnnotatedGenericComponentType

        AnnotatedType getAnnotatedGenericComponentType​()
        返回此数组类型的可能注释的通用组件类型。
        结果
        该数组类型的潜在注释的通用组件类型
        另请参见：
        GenericArrayType.getGenericComponentType()

      • getAnnotatedOwnerType

        AnnotatedType getAnnotatedOwnerType​()
        如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。 例如，如果该类型是@TA O<T>.I<S> ，返回的表示@TA O<T> 。

        返回null为AnnotatedType这是实例AnnotatedArrayType 。

        Specified by:
        getAnnotatedOwnerType在接口 AnnotatedType
        结果
        null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotatedElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface AnnotatedElement

  • All Known Subinterfaces:
    AnnotatedArrayType ， AnnotatedParameterizedType ， AnnotatedType ， AnnotatedTypeVariable ， AnnotatedWildcardType ， GenericDeclaration ， TypeVariable<D>
    所有已知实现类：
    AccessibleObject ， Class ， Constructor ， Executable ， Field ， 方法 ， Module ， 软件包 ， Parameter

    public interface AnnotatedElement
    表示当前在此VM中运行的程序的注释元素。 该界面允许反射读取注释。 该界面中由方法返回的所有注释都是不可变的和可序列化的。 由该接口的方法返回的数组可以由调用者修改，而不会影响返回给其他调用者的数组。

    getAnnotationsByType(Class)和getDeclaredAnnotationsByType(Class)方法支持元素上相同类型的多个注释。 如果任一方法的参数是可重复的注释类型（JLS 9.6），则该方法将“查看”容器注释（JLS 9.7）（如果存在），并返回容器内的任何注释。 容器注释可能在编译时生成，以包装参数类型的多个注释。

    直接呈现 ， 间接存在 ， 呈现和关联的术语在整个界面中被使用以精确描述通过方法返回哪些注释：

    • 如果E具有RuntimeVisibleAnnotations或RuntimeVisibleParameterAnnotations或RuntimeVisibleTypeAnnotations属性，则注释A 直接显示在元素E上 ，并且属性包含A。
    • 如果E具有RuntimeVisibleAnnotations或RuntimeVisibleParameterAnnotations或RuntimeVisibleTypeAnnotations属性，并且A的类型是可重复的，则注释A 间接存在于元素E上 ，并且该属性仅包含一个注释，其值元素包含A ，其类型是包含注释类型A的类型。
    • 注释A存在于元素E上：
      • A直接出现在E上 ; 要么
      • A的类型的注释没有直接出现在E上 ， E是一个类， A的类型是可继承的， A在E的超类上。
    • 注释A与元素E 相关联 ：
      • A直接或间接出现在E上 ; 要么
      • A类型的注释没有直接或间接出现在E上 ， E是一个类， A的类型是可继承的， A与E的超类相关联。

    下表总结了此界面中哪种注释存在不同的方法。

    Overview of kind of presence detected by different AnnotatedElement methods Kind of Presence Method Directly Present Indirectly Present Present Associated T getAnnotation(Class<T>) X Annotation[] getAnnotations() X T[] getAnnotationsByType(Class<T>) X T getDeclaredAnnotation(Class<T>) X Annotation[] getDeclaredAnnotations() X T[] getDeclaredAnnotationsByType(Class<T>) X X

    对于调用get[Declared]AnnotationsByType( Class < T >) ，直接或间接出现在元素E上的注释的顺序被计算，就好像在E上间接存在的注释直接出现在E上， get[Declared]AnnotationsByType( Class < T >)是以它们的容器注释的顺序，以它们出现在容器注释的value元素。

    如果注释类型T最初不可重复，并且稍后被修改为可重复，则需要记住几个兼容性问题。 T的包含注释类型是TC 。

    • 修改T可重复的是源和二进制兼容现有的T使用和TC的现有用途。 也就是说，对于源兼容性，注释类型为T或类型TC的源代码仍将编译。 对于二进制兼容性，与T型TC或类型的（或与其它种类的T类型或类型TC的用途）的注释类文件都会连接T的修改后的版本，如果他们链接的是较早的版本。 （注释类型TC可以在T被修改为正式可重复之前非正式地用作包含注释类型的动作，或者，当T被重复时，可以引入TC作为新类型）。
    • 如果注释类型TC存在于元素上，并且T被修改为可重复，以TC作为其包含的注释类型，则：
      • 对T的改变与get[Declared]Annotation(Class<T>) （称为T或TC的参数）和get[Declared]Annotations()方法的行为兼容，因为由于TC成为T的包含注释类型， get[Declared]Annotations()方法的结果不会改变。
      • 至T的变化而变化的结果get[Declared]AnnotationsByType(Class<T>)方法调用T的说法，因为这些方法现在认识类型TC的注释为容器标注为T和将“透视”，它揭露类型T的注解。
    • 如果类型T的注释存在于元素上，并且T被重复，并且更多的类型T的注释被添加到元素中：
      • 添加类型T的注释是源兼容和二进制兼容。
      • 添加类型T的注释会更改get[Declared]Annotation(Class<T>)方法和get[Declared]Annotations()方法的结果，因为这些方法现在只能在元素上看到容器注释，而不能看到类型T的注释。
      • 添加类型T的注释会改变get[Declared]AnnotationsByType(Class<T>)方法的结果，因为它们的结果将暴露类型T的附加注释，而之前它们仅暴露了单个T型注释。

    如果此接口中的方法返回的注释包含（直接或间接）引用此虚拟机中无法访问的类的一个27054169221932-值成员，则尝试通过在返回的注释上调用相关的Class返回方法来读取该类将导致一个TypeNotPresentException 。

    类似地，如果注释中的枚举常量不再存在于枚举类型中，则尝试读取枚举值成员将导致一个EnumConstantNotPresentException 。

    如果注释类型T （元）用@Repeatable注释（其值元素指示类型TC ）注释，但TC不声明具有返回类型为T []的value()方法，则抛出类型为AnnotationFormatError的异常。

    最后，试图读取其定义不一致的成员将导致一个AnnotationTypeMismatchException或一个IncompleteAnnotationException 。

    从以下版本开始：
    1.5
    另请参见：
    EnumConstantNotPresentException ， TypeNotPresentException ， AnnotationFormatError ， AnnotationTypeMismatchException ， IncompleteAnnotationException

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getAnnotations​()
      返回此元素上 存在的注释。
      default <T extends Annotation>
      T[]             		getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      default <T extends Annotation>
      T             		getDeclaredAnnotation​(Class<T> annotationClass)
      如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      default <T extends Annotation>
      T[]             		getDeclaredAnnotationsByType​(Class<T> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      default boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
      如果此元素上 存在指定类型的注释，则返回true，否则返回false。

    • 方法详细信息

      • isAnnotationPresent

        default boolean isAnnotationPresent​(Class<? extends Annotation> annotationClass)
        如果此元素上存在指定类型的注释，则返回true，否则返回false。 该方法主要用于方便访问标记注释。

        该方法返回的真值相当于： getAnnotation(annotationClass) != null

        默认方法的主体被指定为上述代码。

        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果此元素上存在指定注释类型的注释，则为true，否则为false
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getAnnotation

        <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        参数类型
        T - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getAnnotations

        Annotation[] getAnnotations​()
        返回此元素上存在的注释。 如果没有存在于此元素上注解，返回值是长度为0这种方法的调用者可以随意修改返回的数组的数组; 它将对返回给其他调用者的数组没有影响。
        结果
        此元素上出现的注释
        从以下版本开始：
        1.5

      • getAnnotationsByType

        default <T extends Annotation> T[] getAnnotationsByType​(Class<T> annotationClass)
        返回与此元素相关联的注释。 如果没有与此元素相关联的注释，则返回值为长度为0.的数组。此方法与getAnnotation(Class)之间的区别在于此方法检测其参数是否为可重复注释类型 （JLS 9.6），如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        实现要求：
        默认的实现首先调用getDeclaredAnnotationsByType(Class)传球annotationClass作为参数。 如果返回的数组的长度大于零，则返回数组。 如果返回的数组是零长度，而这个AnnotatedElement是一个类，并且该参数类型是可继承的注释类型，并且该AnnotatedElement的超类是非空的，则返回的结果是在超类上调用getAnnotationsByType(Class)的结果，其结果为annotationClass作为论证。 否则返回零长度的数组。
        参数类型
        T - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果与此元素相关联，则指定注释类型的所有元素注释，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotation

        default <T extends Annotation> T getDeclaredAnnotation​(Class<T> annotationClass)
        如果这样的注释直接存在 ，则返回指定类型的元素注释，否则返回null。 此方法忽略继承的注释。 （如果此元素上没有注释，则返回null）
        实现要求：
        默认实现首先执行空检查，然后循环返回其注释类型与参数类型匹配的第一个注释的结果 getDeclaredAnnotations() 。
        参数类型
        T - 要查询的注释类型，如果直接出现则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果直接出现在该元素上，则指定注释类型的元素注释，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotationsByType

        default <T extends Annotation> T[] getDeclaredAnnotationsByType​(Class<T> annotationClass)
        如果此类注释直接存在或间接存在，则返回该元素的注释（指定类型）。 此方法忽略继承的注释。 如果在该元素上没有直接或间接存在的指定注释，则返回值是长度为0.的数组。此方法与getDeclaredAnnotation(Class)之间的区别在于该方法检测其参数是否是可重复注释类型 （JLS 9.6），以及如果是，尝试通过“查看”容器注释（如果存在）来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        实现要求：
        默认实现可以调用getDeclaredAnnotation(Class)一次或多次以找到直接呈现的注释，如果注释类型是可重复的，则可以找到容器注释。 如果发现注释类型annotationClass的注释都是直接和间接存在的，那么将调用getDeclaredAnnotations()来确定返回的数组中元素的顺序。

        或者，默认实现可以单次调用getDeclaredAnnotations()，并且检查返回的数组直接和间接地呈现注释。 假设调用getDeclaredAnnotations()的结果与调用getDeclaredAnnotation(Class)的结果一致。

        参数类型
        T - 直接或间接出现的查询和返回的注释类型
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        指定注释类型的所有这些元素的注释，如果直接或间接地存在于该元素上，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotations

        Annotation[] getDeclaredAnnotations​()
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        结果
        此元素上直接显示的注释
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotatedParameterizedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface AnnotatedParameterizedType

  • All Superinterfaces:
    AnnotatedElement ， AnnotatedType

    public interface AnnotatedParameterizedType
extends AnnotatedType
    AnnotatedParameterizedType表示参数化类型的潜在注释使用，其类型参数本身可以表示类型的注释使用。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AnnotatedType[] getAnnotatedActualTypeArguments​()
      返回此参数化类型的可能注释的实际类型参数。
      AnnotatedType getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotation, getAnnotations, getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotations, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from interface java.lang.reflect.AnnotatedType

        getType

    • 方法详细信息

      • getAnnotatedActualTypeArguments

        AnnotatedType[] getAnnotatedActualTypeArguments​()
        返回此参数化类型的可能注释的实际类型参数。
        结果
        该参数化类型的可能注释的实际类型参数
        另请参见：
        ParameterizedType.getActualTypeArguments()

      • getAnnotatedOwnerType

        AnnotatedType getAnnotatedOwnerType​()
        如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。 例如，如果该类型是@TA O<T>.I<S> ，返回的表示@TA O<T> 。

        返回null如果这个AnnotatedType表示顶级类型，或本地或匿名类，或原始类型或void。

        Specified by:
        getAnnotatedOwnerType在接口 AnnotatedType
        结果
        一个 AnnotatedType对象，表示此类型是其成员的潜在注释类型，或 null
        异常
        TypeNotPresentException - 如果所有者类型引用不存在的类型声明
        MalformedParameterizedTypeException - 如果所有者类型引用由于任何原因无法实例化的参数化类型
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotatedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface AnnotatedType

  • All Superinterfaces:
    AnnotatedElement
    All Known Subinterfaces:
    AnnotatedArrayType ， AnnotatedParameterizedType ， AnnotatedTypeVariable ， AnnotatedWildcardType

    public interface AnnotatedType
extends AnnotatedElement
    AnnotatedType表示当前在此VM中运行的程序中可能注释的使用类型。 使用可能是Java编程语言中的任何类型，包括数组类型，参数化类型，类型变量或通配符类型。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法 Default Methods
      Modifier and Type 方法 描述
      default AnnotatedType getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。
      Type getType​()
      返回此注释类型表示的基础类型。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotation, getAnnotations, getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotations, getDeclaredAnnotationsByType, isAnnotationPresent

    • 方法详细信息

      • getAnnotatedOwnerType

        default AnnotatedType getAnnotatedOwnerType​()
        如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。 例如，如果该类型是@TA O<T>.I<S> ，返回的表示@TA O<T> 。

        返回null如果这个AnnotatedType表示顶级类型，或本地或匿名类，或原始类型或void。

        返回null如果AnnotatedType是实例AnnotatedArrayType ， AnnotatedTypeVariable ，或AnnotatedWildcardType 。

        实现要求：
        此默认实现返回 null ，不执行其他操作。
        结果
        一个 AnnotatedType对象，表示该类型是其成员的潜在注释类型，或 null
        异常
        TypeNotPresentException - 如果所有者类型引用不存在的类型声明
        MalformedParameterizedTypeException - 如果所有者类型引用了由于任何原因无法实例化的参数化类型
        从以下版本开始：
        9

      • getType

        Type getType​()
        返回此注释类型表示的基础类型。
        结果
        该注释类型表示的类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotatedTypeVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface AnnotatedTypeVariable

  • All Superinterfaces:
    AnnotatedElement ， AnnotatedType

    public interface AnnotatedTypeVariable
extends AnnotatedType
    AnnotatedTypeVariable表示类型变量的潜在注释使用，其声明可能具有其自身表示注释类型使用的界限。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AnnotatedType[] getAnnotatedBounds​()
      返回此类型变量的可能注释的边界。
      AnnotatedType getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotation, getAnnotations, getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotations, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from interface java.lang.reflect.AnnotatedType

        getType

    • 方法详细信息

      • getAnnotatedBounds

        AnnotatedType[] getAnnotatedBounds​()
        返回此类型变量的可能注释的边界。 如果没有明确声明绑定，绑定是未注释的Object 。
        结果
        该类型变量的潜在注释范围
        另请参见：
        TypeVariable.getBounds()

      • getAnnotatedOwnerType

        AnnotatedType getAnnotatedOwnerType​()
        如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。 例如，如果该类型是@TA O<T>.I<S> ，返回的表示@TA O<T> 。

        对于null ，其AnnotatedType的实例返回AnnotatedTypeVariable 。

        Specified by:
        getAnnotatedOwnerType在接口 AnnotatedType
        结果
        null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


AnnotatedWildcardType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface AnnotatedWildcardType

  • All Superinterfaces:
    AnnotatedElement ， AnnotatedType

    public interface AnnotatedWildcardType
extends AnnotatedType
    AnnotatedWildcardType表示通配符类型参数的潜在注释使用，其上限或下限本身可以表示类型的注释使用。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AnnotatedType[] getAnnotatedLowerBounds​()
      返回此通配符类型的潜在注释下限。
      AnnotatedType getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。
      AnnotatedType[] getAnnotatedUpperBounds​()
      返回此通配符类型的可能注释的上限。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotation, getAnnotations, getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotations, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from interface java.lang.reflect.AnnotatedType

        getType

    • 方法详细信息

      • getAnnotatedLowerBounds

        AnnotatedType[] getAnnotatedLowerBounds​()
        返回此通配符类型的潜在注释下限。 如果没有明确声明下限，则下限是null的类型。 在这种情况下，返回零长度数组。
        结果
        这个通配符类型的潜在注释的下限，如果没有明确声明下限，则为空数组。
        另请参见：
        WildcardType.getLowerBounds()

      • getAnnotatedUpperBounds

        AnnotatedType[] getAnnotatedUpperBounds​()
        返回此通配符类型的可能注释的上限。 如果没有明确声明上限，则上限为未注明Object
        结果
        该通配符类型的可能注释的上限
        另请参见：
        WildcardType.getUpperBounds()

      • getAnnotatedOwnerType

        AnnotatedType getAnnotatedOwnerType​()
        如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。 例如，如果该类型是@TA O<T>.I<S> ，返回的表示@TA O<T> 。

        返回null为AnnotatedType这是实例AnnotatedWildcardType 。

        Specified by:
        getAnnotatedOwnerType在接口 AnnotatedType
        结果
        null
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Array (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Array

  • java.lang.Object
    • java.lang.reflect.Array

  • public final class Array
extends Object
    Array类提供静态方法来动态创建和访问Java数组。

    Array允许在获取或设置操作期间扩大转换，但如果发生缩小转换，则抛出IllegalArgumentException 。

    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Object get​(Object array, int index)
      返回指定数组对象中的索引组件的值。
      static boolean getBoolean​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 boolean 。
      static byte getByte​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 byte 。
      static char getChar​(Object array, int index)
      返回指定数组对象中索引组件的值，如 char 。
      static double getDouble​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 double 。
      static float getFloat​(Object array, int index)
      返回指定数组对象中的索引组件的值，如 float 。
      static int getInt​(Object array, int index)
      返回指定数组对象中索引组件的值，如 int 。
      static int getLength​(Object array)
      返回指定数组对象的长度，如 int 。
      static long getLong​(Object array, int index)
      返回指定数组对象中索引组件的值，如 long 。
      static short getShort​(Object array, int index)
      返回指定数组对象中索引组件的值，如 short 。
      static Object newInstance​(Class<?> componentType, int length)
      创建具有指定组件类型和长度的新数组。
      static Object newInstance​(Class<?> componentType, int... dimensions)
      创建具有指定组件类型和尺寸的新数组。
      static void set​(Object array, int index, Object value)
      将指定数组对象的索引组件的值设置为指定的新值。
      static void setBoolean​(Object array, int index, boolean z)
      将指定数组对象的索引组件的值设置为指定的 boolean值。
      static void setByte​(Object array, int index, byte b)
      将指定数组对象的索引组件的值设置为指定的 byte值。
      static void setChar​(Object array, int index, char c)
      将指定数组对象的索引组件的值设置为指定的 char值。
      static void setDouble​(Object array, int index, double d)
      将指定数组对象的索引组件的值设置为指定的 double值。
      static void setFloat​(Object array, int index, float f)
      将指定数组对象的索引组件的值设置为指定的 float值。
      static void setInt​(Object array, int index, int i)
      将指定数组对象的索引组件的值设置为指定的 int值。
      static void setLong​(Object array, int index, long l)
      将指定数组对象的索引组件的值设置为指定的 long值。
      static void setShort​(Object array, int index, short s)
      将指定数组对象的索引组件的值设置为指定的 short值。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • newInstance

        public static Object newInstance​(Class<?> componentType,
                                 int length)
                          throws NegativeArraySizeException
        创建具有指定组件类型和长度的新数组。 调用此方法相当于创建一个数组，如下所示：
         int[] x = {length};
 Array.newInstance(componentType, x);

        新数组的维数不能超过255。

        参数
        componentType - 表示新数组的组件类型的 Class对象
        length - 新数组的长度
        结果
        新数组
        异常
        NullPointerException - 如果指定的 componentType参数为空
        IllegalArgumentException - 如果componentType为 Void.TYPE或者请求的数组实例的维数超过255。
        NegativeArraySizeException - 如果指定的 length为负数

      • newInstance

        public static Object newInstance​(Class<?> componentType,
                                 int... dimensions)
                          throws IllegalArgumentException,
                                 NegativeArraySizeException
        创建具有指定组件类型和尺寸的新数组。 如果componentType表示非数组类或接口，则新数组具有dimensions.length维和componentType作为其组件类型。 如果componentType表示数组类，则新数组的维数等于dimensions.length和维数componentType 。 在这种情况下，新阵列的组件类型是组件类型componentType 。

        新数组的维数不能超过255。

        参数
        componentType - 表示新数组的组件类型的 Class对象
        dimensions - 表示新数组的维度的数组 int
        结果
        新数组
        异常
        NullPointerException - 如果指定的 componentType参数为空
        IllegalArgumentException - 如果指定的 dimensions参数是零维数组，如果componentType为 Void.TYPE ，或者请求的数组实例的维数超过255。
        NegativeArraySizeException - 如果指定的 dimensions参数中的任何组件为负。

      • getLength

        public static int getLength​(Object array)
                     throws IllegalArgumentException
        返回指定数组对象的长度，如 int 。
        参数
        array - 数组
        结果
        数组的长度
        异常
        IllegalArgumentException - 如果对象参数不是数组

      • get

        public static Object get​(Object array,
                         int index)
                  throws IllegalArgumentException,
                         ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值。 如果该对象具有原始类型，则该值将自动包装在对象中。
        参数
        array - 数组
        index - 索引
        结果
        指定数组中的索引组件的（可能包装的）值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度

      • getBoolean

        public static boolean getBoolean​(Object array,
                                 int index)
                          throws IllegalArgumentException,
                                 ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值，如 boolean 。
        参数
        array - 数组
        index - 索引
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素不能通过标识或扩展转换转换为返回类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • getByte

        public static byte getByte​(Object array,
                           int index)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
        返回指定数组对象中索引组件的值，如 byte 。
        参数
        array - 数组
        index - 指数
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素不能通过标识或扩展转换转换为返回类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • getChar

        public static char getChar​(Object array,
                           int index)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值，如 char 。
        参数
        array - 数组
        index - 索引
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素不能通过标识或扩展转换转换为返回类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • getShort

        public static short getShort​(Object array,
                             int index)
                      throws IllegalArgumentException,
                             ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值，如 short 。
        参数
        array - 数组
        index - 索引
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素不能通过标识或扩展转换转换为返回类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • getInt

        public static int getInt​(Object array,
                         int index)
                  throws IllegalArgumentException,
                         ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值，如 int 。
        参数
        array - 数组
        index - 指数
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素不能通过标识或扩展转换转换为返回类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • getLong

        public static long getLong​(Object array,
                           int index)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值，如 long 。
        参数
        array - 数组
        index - 索引
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素不能通过标识或扩展转换转换为返回类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • getFloat

        public static float getFloat​(Object array,
                             int index)
                      throws IllegalArgumentException,
                             ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值，如 float 。
        参数
        array - 数组
        index - 索引
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素无法通过标识转换为返回类型或扩展转换
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • getDouble

        public static double getDouble​(Object array,
                               int index)
                        throws IllegalArgumentException,
                               ArrayIndexOutOfBoundsException
        返回指定数组对象中的索引组件的值，如 double 。
        参数
        array - 数组
        index - 索引
        结果
        指定数组中的索引组件的值
        异常
        NullPointerException - 如果指定的对象为空
        IllegalArgumentException - 如果指定的对象不是数组，或者索引元素无法通过标识转换为返回类型或扩展转换
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        get(java.lang.Object, int)

      • set

        public static void set​(Object array,
                       int index,
                       Object value)
                throws IllegalArgumentException,
                       ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的新值。 如果数组具有原始组件类型，则新值将首先被自动解包。
        参数
        array - 数组
        index - 数组中的索引
        value - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者数组组件类型是原始的，并且展开转换失败
        ArrayIndexOutOfBoundsException -如果指定 index参数为负，或者如果它是大于或等于指定的数组的长度

      • setBoolean

        public static void setBoolean​(Object array,
                              int index,
                              boolean z)
                       throws IllegalArgumentException,
                              ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的 boolean值。
        参数
        array - 数组
        index - 数组中的索引
        z - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或原始加宽转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)

      • setByte

        public static void setByte​(Object array,
                           int index,
                           byte b)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的 byte值。
        参数
        array - 数组
        index - 数组中的索引
        b - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或原始加宽转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)

      • setChar

        public static void setChar​(Object array,
                           int index,
                           char c)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的 char值。
        参数
        array - 数组
        index - 数组中的索引
        c - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或原始加宽转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)

      • setShort

        public static void setShort​(Object array,
                            int index,
                            short s)
                     throws IllegalArgumentException,
                            ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的 short值。
        参数
        array - 数组
        index - 数组中的索引
        s - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或原始加宽转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)

      • setInt

        public static void setInt​(Object array,
                          int index,
                          int i)
                   throws IllegalArgumentException,
                          ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的 int值。
        参数
        array - 数组
        index - 数组中的索引
        i - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或基本扩展转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)

      • setLong

        public static void setLong​(Object array,
                           int index,
                           long l)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
        将指定的数组对象的索引组件的值设置为指定的 long值。
        参数
        array - 数组
        index - 数组中的索引
        l - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或原始加宽转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)

      • setFloat

        public static void setFloat​(Object array,
                            int index,
                            float f)
                     throws IllegalArgumentException,
                            ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的 float值。
        参数
        array - 数组
        index - 数组中的索引
        f - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或原始加宽转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)

      • setDouble

        public static void setDouble​(Object array,
                             int index,
                             double d)
                      throws IllegalArgumentException,
                             ArrayIndexOutOfBoundsException
        将指定数组对象的索引组件的值设置为指定的 double值。
        参数
        array - 数组
        index - 数组中的索引
        d - 索引组件的新值
        异常
        NullPointerException - 如果指定的对象参数为空
        IllegalArgumentException - 如果指定的对象参数不是数组，或者指定的值不能通过标识或原始加宽转换转换为底层数组的组件类型
        ArrayIndexOutOfBoundsException - 如果指定的 index参数为负，或者如果大于或等于指定数组的长度
        另请参见：
        set(java.lang.Object, int, java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Constructor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Constructor<T>

  • java.lang.Object
    • java.lang.reflect.AccessibleObject
      • java.lang.reflect.Executable
        • java.lang.reflect.Constructor<T>
  • 参数类型
    T - 声明构造函数的类
    All Implemented Interfaces:
    AnnotatedElement ， GenericDeclaration ， Member

    public final class Constructor<T>
extends Executable
    Constructor提供了一个类的单个构造函数的信息和访问权限。

    Constructor允许在将实际参数与newInstance（）与底层构造函数的形式参数进行匹配时进行扩展转换，但如果发生缩小转换，则抛出IllegalArgumentException 。

    从以下版本开始：
    1.1
    另请参见：
    Member ， Class ， Class.getConstructors() ， Class.getConstructor(Class[]) ， Class.getDeclaredConstructors()

    • Field Summary

      • Fields inherited from interface java.lang.reflect.Member

        DECLARED, PUBLIC

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此 Constructor与指定对象进行比较。
      AnnotatedType getAnnotatedReceiverType​()
      返回一个 AnnotatedType对象，表示使用类型来指定由此 Executable对象表示的方法/构造函数的接收器类型。
      AnnotatedType getAnnotatedReturnType​()
      返回一个 AnnotatedType对象，该对象表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Class<T> getDeclaringClass​()
      返回表示声明由该对象表示的构造函数的类的 Class对象。
      Class<?>[] getExceptionTypes​()
      返回一个 Class对象的数组， Class表示由该对象表示的底层可执行文件抛出的异常类型。
      Type[] getGenericExceptionTypes​()
      返回一个 Type对象的数组，表示此可执行对象声明抛出的异常。
      Type[] getGenericParameterTypes​()
      返回一个 Type对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。
      int getModifiers​()
      返回由该对象表示的可执行文件的Java语言modifiers 。
      String getName​()
      以字符串形式返回此构造函数的名称。
      Annotation[][] getParameterAnnotations​()
      返回一个 Annotation的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。
      int getParameterCount​()
      返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。
      Class<?>[] getParameterTypes​()
      返回一个 Class对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。
      TypeVariable<Constructor<T>>[] getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。
      int hashCode​()
      返回此 Constructor的哈希 Constructor 。
      boolean isSynthetic​()
      如果此可执行文件是合成结构，则返回true ; 否则返回false 。
      boolean isVarArgs​()
      如果这个可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。
      T newInstance​(Object... initargs)
      使用由此 Constructor对象表示的构造函数，使用指定的初始化参数来创建和初始化构造函数的声明类的新实例。
      void setAccessible​(boolean flag)
      将此反射对象的 accessible标志设置为指示的布尔值。
      String toGenericString​()
      返回一个描述这个 Constructor的字符串，包括类型参数。
      String toString​()
      返回一个描述这个 Constructor的字符串。

      • Methods inherited from class java.lang.reflect.AccessibleObject

        canAccess, getAnnotations, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAccessible, isAnnotationPresent, setAccessible, trySetAccessible

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotations, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from class java.lang.reflect.Executable

        getAnnotatedExceptionTypes, getAnnotatedParameterTypes, getAnnotationsByType, getParameters

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • setAccessible

        public void setAccessible​(boolean flag)
        将此反射对象的accessible标志设置为指示的布尔值。 值为true表示反射对象应该在使用Java语言访问控制时抑制检查。 值为false表示反射对象应该在使用Java语言访问控制时执行检查，并在类描述中指出变体。

        呼叫者可以在C类中使用此方法，以使得能够访问declaring class declaring class D如果有以下任何一项）：

        • C和D在相同的模块中。
        • 所述构件是public和D是public在于包含模块的封装D exports到至少包含模块C 。
        • 所述构件是protected static ， D是public在于包含模块的封装D出口到至少包含模块C ，和C是的一个子类D 。
        • D是在一个包中，模块至少包含D opens ，模块包含C 。 未命名和开放模块中的所有软件包均可对所有模块开放，因此当D处于未命名或打开模块时，此方法始终会成功。

        当声明类与调用者不同的模块时，此方法不能用于启用对私有成员，具有默认（包）访问权限的成员，受保护的实例成员或受保护的构造函数的访问，并且包含声明类的包不能打开呼叫者的模块。

        如果有一个安全管理员，它的checkPermission方法首先被调用一个ReflectPermission("suppressAccessChecks")权限。

        一个SecurityException如果这个对象是也抛出Constructor对象类Class和flag是真的。

        重写：
        setAccessible在 AccessibleObject
        参数
        flag - 新值为 accessible旗帜
        异常
        InaccessibleObjectException - 如果无法启用访问
        SecurityException - 如果请求被安全管理器拒绝，或者是 java.lang.Class的构造 java.lang.Class
        另请参见：
        AccessibleObject.trySetAccessible() ， MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • getDeclaringClass

        public Class<T> getDeclaringClass​()
        返回表示声明由该对象表示的构造函数的类的 Class对象。
        Specified by:
        getDeclaringClass在接口 Member
        Specified by:
        getDeclaringClass在 Executable
        结果
        一个表示底层成员声明类的对象

      • getName

        public String getName​()
        以字符串形式返回此构造函数的名称。 这是构造函数的声明类的二进制名称。
        Specified by:
        getName在接口 Member
        Specified by:
        getName在 Executable
        结果
        底层成员的简单名称

      • getModifiers

        public int getModifiers​()
        返回由该对象表示的可执行文件的Java语言modifiers 。
        Specified by:
        getModifiers在接口 Member
        Specified by:
        getModifiers在 Executable
        结果
        底层成员的Java语言修饰符
        另请参见：
        Modifier

      • getTypeParameters

        public TypeVariable<Constructor<T>>[] getTypeParameters​()
        返回的数组TypeVariable对象表示通过此表示的一般声明声明的类型变量GenericDeclaration目的，在声明的顺序。 如果底层通用声明不声明类型变量，则返回长度为0的数组。
        Specified by:
        getTypeParameters在接口 GenericDeclaration
        Specified by:
        getTypeParameters在 Executable
        结果
        一个 TypeVariable对象的数组，表示由此通用声明声明的类型变量
        异常
        GenericSignatureFormatError - 如果此通用声明的通用签名不符合 The Java™ Virtual Machine Specification中规定的格式
        从以下版本开始：
        1.5

      • getParameterTypes

        public Class<?>[] getParameterTypes​()
        返回一个Class对象的数组， Class以声明顺序表示由该对象表示的可执行文件的形式参数类型。 如果底层可执行文件没有参数，则返回长度为0的数组。
        Specified by:
        getParameterTypes在 Executable
        结果
        该对象表示的可执行文件的参数类型

      • getParameterCount

        public int getParameterCount​()
        返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。
        重写：
        getParameterCount在 Executable
        结果
        该对象表示的可执行文件的形式参数的数量
        从以下版本开始：
        1.8

      • getGenericParameterTypes

        public Type[] getGenericParameterTypes​()
        返回一个Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。 如果底层可执行文件没有参数，则返回长度为0的数组。

        如果形式参数类型是参数化类型，则Type返回的Type对象必须准确反映源代码中使用的实际类型参数。

        如果形式参数类型是类型变量或参数化类型，则会创建它。 否则解决。

        重写：
        getGenericParameterTypes在 Executable
        结果
        一个 Type的数组，以声明顺序表示底层可执行文件的形式参数类型
        异常
        GenericSignatureFormatError - 如果通用方法签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果底层可执行文件的任何参数类型是指不存在的类型声明
        MalformedParameterizedTypeException - 如果任何底层可执行文件的参数类型是指由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • getExceptionTypes

        public Class<?>[] getExceptionTypes​()
        返回一个Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。 如果可执行文件在其throws子句中不声明异常，则返回长度为0的数组。
        Specified by:
        getExceptionTypes在 Executable
        结果
        被该对象表示的可执行文件抛出的异常类型

      • getGenericExceptionTypes

        public Type[] getGenericExceptionTypes​()
        返回一个Type对象的数组，它们表示声明为该可执行对象抛出的异常。 如果底层可执行文件在其throws子句中声明无例外，则返回长度为0的数组。

        如果异常类型是类型变量或参数化类型，则会创建它。 否则解决。

        重写：
        getGenericExceptionTypes在 Executable
        结果
        一组数组，表示底层可执行文件抛出的异常类型
        异常
        GenericSignatureFormatError - 如果通用方法签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果底层可执行文件的 throws子句引用不存在的类型声明
        MalformedParameterizedTypeException - 如果底层可执行文件的 throws子句是指由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • equals

        public boolean equals​(Object obj)
        将此Constructor与指定对象进行比较。 如果对象相同，则返回true。 两个Constructor对象是相同的，如果它们被同一个类声明并具有相同的形式参数类型。
        重写：
        equals在类 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此Constructor的哈希Constructor 。 哈希码与底层构造函数的声明类名称的哈希码相同。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回描述这个Constructor的字符串。 该字符串格式化为构造函数访问修饰符（如果有），后跟声明类的完全限定名称，后跟括号，逗号分隔的构造函数形式参数类型列表。 例如：
           public java.util.Hashtable(int,float)

        如果构造函数被声明为抛出异常，则参数列表后跟一个空格，后面跟有“ throws ”一词，后面是抛出的异常类型的逗号分隔列表。

        对构造方法唯一可能的修饰符是访问修饰符public ， protected或者private 。 只有其中一个可能出现，或者如果构造函数具有默认（包）访问权限，则不会显示。

        重写：
        toString在 Object
        结果
        一个描述这个 Constructor的字符串
        See The Java™ Language Specification:
        8.8.3构造函数修饰符，8.9.2枚举体声明

      • toGenericString

        public String toGenericString​()
        返回描述此Constructor的字符串，包括类型参数。 该字符串格式化为构造函数访问修饰符（如果有），后跟一个由括号括起的逗号分隔的构造函数类型参数列表（如果有），后跟声明类的完全限定名称，后跟括号，构造函数的通用形式参数类型的分隔列表。 如果这个构造函数被声明为可变数量的参数，而不是将最后一个参数表示为“ Type[] ”，则表示为“ Type... ”。 一个空格用于将访问修饰符彼此和类型参数或类名分开。 如果没有类型参数，则类型参数列表将被删除; 如果存在类型参数列表，则将列表与类名称隔开。 如果构造函数被声明为抛出异常，则参数列表后跟一个空格，后跟“ throws ”，后跟通用抛出的异常类型的逗号分隔列表。

        对构造方法唯一可能的修饰符是访问修饰符public ， protected或者private 。 只有其中一个可能出现，或者如果构造函数具有默认（包）访问权限，则不会显示。

        Specified by:
        toGenericString在 Executable
        结果
        一个描述这个 Constructor的字符串，包括类型参数
        从以下版本开始：
        1.5
        See The Java™ Language Specification:
        8.8.3构造函数修饰符，8.9.2枚举体声明

      • newInstance

        public T newInstance​(Object... initargs)
              throws InstantiationException,
                     IllegalAccessException,
                     IllegalArgumentException,
                     InvocationTargetException
        使用由此Constructor对象表示的构造函数，使用指定的初始化参数创建和初始化构造函数的声明类的新实例。 个别参数自动展开以匹配原始形式参数，原始参考参数和参考参数都需要进行方法调用转换。

        如果底层构造函数所需的形式参数的数量为0，则提供的initargs数组的长度为0或为空。

        如果构造函数的声明类是非静态上下文中的内部类，则构造函数的第一个参数需要是封闭实例; 见The Java™ Language Specification的第15.9.3 节 。

        如果所需的访问和参数检查成功，并且实例化将继续进行，那么构造函数的声明类如果尚未被初始化，则将被初始化。

        如果构造函数正常完成，则返回新创建和初始化的实例。

        参数
        initargs - 要作为构造函数调用的参数传递的对象的数组; 原始类型的值被包装在适当类型的包装对象中（例如， float中的float ）
        结果
        通过调用此对象代表的构造函数创建的新对象
        异常
        IllegalAccessException - 如果此 Constructor对象正在执行Java语言访问控制，并且底层构造函数无法访问。
        IllegalArgumentException - 如果实际和正式参数的数量不同;
如果原始参数的解包转换失败;
或者如果在可能的展开之后，通过方法调用转换，参数值不能转换为相应的形式参数类型;
如果此构造函数属于枚举类型。
        InstantiationException - 如果声明底层构造函数的类表示抽象类。
        InvocationTargetException - 如果底层构造函数引发异常。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。

      • isVarArgs

        public boolean isVarArgs​()
        如果这个可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。
        重写：
        isVarArgs在 Executable
        结果
        true如果只有这个可执行文件被声明为一个可变数量的参数。
        从以下版本开始：
        1.5

      • isSynthetic

        public boolean isSynthetic​()
        如果这个可执行文件是一个合成的结构，返回true ; 否则返回false 。
        Specified by:
        isSynthetic在接口 Member
        重写：
        isSynthetic在 Executable
        结果
        如果且仅当此可执行文件是由 The Java™ Language Specification定义的合成结构， 则为true 。
        从以下版本开始：
        1.5
        See The Java™ Language Specification:
        13.1二进制形式

      • getAnnotation

        public <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        重写：
        getAnnotation在 Executable
        参数类型
        T - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        重写：
        getDeclaredAnnotations在 Executable
        结果
        此元素上直接显示的注释
        从以下版本开始：
        1.5

      • getParameterAnnotations

        public Annotation[][] getParameterAnnotations​()
        返回一个Annotation s的数组数组，表示由该对象表示的Executable的形式参数的声明顺序。 合成和强制参数（见下面的说明），如内部类构造函数的外部“this”参数将在返回的数组中表示。 如果可执行文件没有参数（意思是没有正式的，没有合成的，没有强制的参数），那么将返回一个零长度的数组。 如果Executable具有一个或多个参数，则对于没有注释的每个参数，返回长度为零的嵌套数组。 包含在返回的数组中的注释对象是可序列化的。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。 编译器可以添加在源（“强制”）中隐式声明的额外参数，以及在源（“合成”）中既不是隐式也不显式声明方法的参数列表的参数。 详见Parameter 。
        Specified by:
        getParameterAnnotations在 Executable
        结果
        表示由该对象表示的可执行文件的声明顺序的形式和隐式参数上的注释数组
        从以下版本开始：
        1.5
        另请参见：
        Parameter ， Parameter.getAnnotations()

      • getAnnotatedReturnType

        public AnnotatedType getAnnotatedReturnType​()
        返回一个AnnotatedType对象，表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。 如果此Executable对象表示构造函数，则AnnotatedType对象表示构造对象的类型。 如果这个Executable对象表示一个方法，那么AnnotatedType对象表示使用一个类型来指定方法的返回类型。
        Specified by:
        getAnnotatedReturnType在类 Executable
        结果
        表示由该 Executable表示的方法或构造函数的返回类型的对象
        从以下版本开始：
        1.8

      • getAnnotatedReceiverType

        public AnnotatedType getAnnotatedReceiverType​()
        返回一个AnnotatedType对象，表示使用类型来指定由该Executable对象表示的方法/构造函数的接收器类型。 只有方法/构造函数具有接收器参数（JLS 8.4.1），方法/构造函数的接收器类型才可用。 如果此Executable对象表示一个实例方法或表示内部件类的构造 ，并且所述方法/构造或者具有没有接收器参数或与它的类型没有注释的接收器参数，则返回值是一个AnnotatedType表示对象没有注释的元素 如果这个Executable对象表示一个静态方法，或者表示一个顶级，静态成员，本地或匿名类的构造函数，则返回值为null。
        重写：
        getAnnotatedReceiverType在 Executable
        结果
        表示由该 Executable或 null表示的方法或构造函数的接收器类型的对象，如果该 Executable不能具有接收器参数
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Executable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Executable

  • java.lang.Object
    • java.lang.reflect.AccessibleObject
      • java.lang.reflect.Executable
  • All Implemented Interfaces:
    AnnotatedElement ， GenericDeclaration ， Member
    已知直接子类：
    Constructor ， 方法

    public abstract class Executable
extends AccessibleObject
implements Member, GenericDeclaration
    共享超类的共同功能为方法和Constructor 。
    从以下版本开始：
    1.8

    • Field Summary

      • Fields inherited from interface java.lang.reflect.Member

        DECLARED, PUBLIC

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      AnnotatedType[] getAnnotatedExceptionTypes​()
      返回一个 AnnotatedType对象的数组，表示使用类型来指定由此可执行文件表示的方法/构造函数声明的异常。
      AnnotatedType[] getAnnotatedParameterTypes​()
      返回一个 AnnotatedType对象的数组，表示使用类型来指定此可执行文件所表示的方法/构造函数的形式参数类型。
      AnnotatedType getAnnotatedReceiverType​()
      返回一个 AnnotatedType对象，表示使用类型来指定由该 Executable对象表示的方法/构造函数的接收器类型。
      abstract AnnotatedType getAnnotatedReturnType​()
      返回一个 AnnotatedType对象，表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T[]             		getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      abstract Class<?> getDeclaringClass​()
      返回表示由该对象表示的可执行文件的类或接口的 Class对象。
      abstract Class<?>[] getExceptionTypes​()
      返回一个 Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。
      Type[] getGenericExceptionTypes​()
      返回一个 Type对象的数组，它们表示声明为可执行对象抛出的异常。
      Type[] getGenericParameterTypes​()
      返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。
      abstract int getModifiers​()
      返回由该对象表示的可执行文件的Java语言modifiers 。
      abstract String getName​()
      返回由此对象表示的可执行文件的名称。
      abstract Annotation[][] getParameterAnnotations​()
      返回一个 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。
      int getParameterCount​()
      返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。
      Parameter[] getParameters​()
      返回一个 Parameter对象的数组，表示由该对象表示的底层可执行文件的所有参数。
      abstract Class<?>[] getParameterTypes​()
      返回一个 Class对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。
      abstract TypeVariable<?>[] getTypeParameters​()
      返回一个 TypeVariable对象的数组，表示由该 GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。
      boolean isSynthetic​()
      如果这个可执行文件是一个合成结构，则返回true ; 否则返回false 。
      boolean isVarArgs​()
      如果这个可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。
      abstract String toGenericString​()
      返回一个描述这个 Executable的字符串，包括任何类型的参数。

      • Methods inherited from class java.lang.reflect.AccessibleObject

        canAccess, getAnnotations, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAccessible, isAnnotationPresent, setAccessible, setAccessible, trySetAccessible

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotations, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDeclaringClass

        public abstract Class<?> getDeclaringClass​()
        返回表示由该对象表示的可执行文件的类或接口的 Class对象。
        Specified by:
        getDeclaringClass在接口 Member
        结果
        一个表示底层成员声明类的对象

      • getName

        public abstract String getName​()
        返回由此对象表示的可执行文件的名称。
        Specified by:
        getName接口 Member
        结果
        底层成员的简单名称

      • getModifiers

        public abstract int getModifiers​()
        返回由该对象表示的可执行文件的Java语言modifiers 。
        Specified by:
        getModifiers在接口 Member
        结果
        底层成员的Java语言修饰符
        另请参见：
        Modifier

      • getTypeParameters

        public abstract TypeVariable<?>[] getTypeParameters​()
        返回一个TypeVariable对象的数组， TypeVariable以声明顺序表示由该GenericDeclaration对象表示的通用声明声明的类型变量。 如果底层通用声明不声明类型变量，则返回长度为0的数组。
        Specified by:
        getTypeParameters在接口 GenericDeclaration
        结果
        一个 TypeVariable对象的数组，表示此通用声明声明的类型变量
        异常
        GenericSignatureFormatError - 如果此通用声明的通用签名不符合 The Java™ Virtual Machine Specification中指定的格式

      • getParameterTypes

        public abstract Class<?>[] getParameterTypes​()
        返回一个Class对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。 如果底层可执行文件没有参数，则返回长度为0的数组。
        结果
        该对象表示的可执行文件的参数类型

      • getParameterCount

        public int getParameterCount​()
        返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。
        结果
        该对象表示的可执行文件的形式参数的数量

      • getGenericParameterTypes

        public Type[] getGenericParameterTypes​()
        返回一个Type对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。 如果底层可执行文件没有参数，则返回长度为0的数组。

        如果形式参数类型是参数化类型，则Type返回的Type对象必须准确反映源代码中使用的实际类型参数。

        如果形式参数类型是类型变量或参数化类型，则会创建它。 否则解决。

        结果
        一个 Type s的数组，以声明顺序表示底层可执行文件的形式参数类型
        异常
        GenericSignatureFormatError - 如果通用方法签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果底层可执行文件的任何参数类型都是指不存在的类型声明
        MalformedParameterizedTypeException - 如果任何底层可执行文件的参数类型是指由于任何原因无法实例化的参数化类型

      • getParameters

        public Parameter[] getParameters​()
        返回一个Parameter对象的数组，表示由该对象表示的底层可执行文件的所有参数。 如果可执行文件没有参数，则返回长度为0的数组。

        底层可执行文件的参数不一定具有唯一的名称，或者是Java编程语言（JLS 3.8）中的合法标识符的名称。

        结果
        一组 Parameter对象，表示该对象表示的可执行文件的所有参数。
        异常
        MalformedParametersException - 如果类文件包含格式不正确的MethodParameters属性。

      • getExceptionTypes

        public abstract Class<?>[] getExceptionTypes​()
        返回一个Class对象的数组，表示由该对象表示的底层可执行文件抛出的异常类型。 如果可执行程序在其throws子句中不声明异常，则返回长度为0的数组。
        结果
        被该对象表示的可执行文件抛出的异常类型

      • getGenericExceptionTypes

        public Type[] getGenericExceptionTypes​()
        返回一个Type对象的数组，表示此可执行对象声明抛出的异常。 如果底层可执行文件在其throws子句中声明无例外，则返回长度为0的数组。

        如果异常类型是类型变量或参数化类型，则会创建它。 否则解决。

        结果
        一组数组，表示底层可执行文件抛出的异常类型
        异常
        GenericSignatureFormatError - 如果通用方法签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果底层可执行文件的 throws子句引用不存在的类型声明
        MalformedParameterizedTypeException - 如果底层可执行文件的 throws子句引用了由于任何原因无法实例化的参数化类型

      • toGenericString

        public abstract String toGenericString​()
        返回描述此 Executable的字符串，包括任何类型的参数。
        结果
        一个描述这个 Executable的字符串，包括任何类型的参数

      • isVarArgs

        public boolean isVarArgs​()
        如果这个可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。
        结果
        true如果只有这个可执行文件被声明为使用可变数量的参数。

      • isSynthetic

        public boolean isSynthetic​()
        如果此可执行文件是合成结构，则返回true ; 否则返回false 。
        Specified by:
        isSynthetic在接口 Member
        结果
        如果且仅当此可执行文件是由 The Java™ Language Specification定义的合成结构， 则为真 。
        See The Java™ Language Specification:
        13.1二进制形式

      • getParameterAnnotations

        public abstract Annotation[][] getParameterAnnotations​()
        返回一个Annotation s的数组数组，表示由该对象表示的Executable的形式参数的声明顺序。 合成和强制参数（见下面的说明），如内部类构造函数的外部“this”参数将在返回的数组中表示。 如果可执行文件没有参数（意思是没有正式的，没有合成的，没有强制的参数），那么将返回一个零长度的数组。 如果Executable具有一个或多个参数，则对于没有注释的每个参数，返回长度为零的嵌套数组。 包含在返回的数组中的注释对象是可序列化的。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。 编译器可以添加在源（“强制”）中隐式声明的额外参数，以及在源（“合成”）中既不是隐式也不显式声明方法的参数列表的参数。 有关详细信息，请参阅Parameter 。
        结果
        表示由该对象表示的可执行文件的声明顺序的形式和隐式参数上的注释数组
        另请参见：
        Parameter ， Parameter.getAnnotations()

      • getAnnotation

        public <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        重写：
        getAnnotation在 AccessibleObject
        参数类型
        T - 要查询的注释的类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空

      • getAnnotationsByType

        public <T extends Annotation> T[] getAnnotationsByType​(Class<T> annotationClass)
        返回与此元素相关联的注释。 如果没有与此元素相关联的注释，则返回值为长度为0.的数组。此方法与AnnotatedElement.getAnnotation(Class)之间的区别在于此方法检测其参数是否是可重复注释类型 （JLS 9.6），如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotationsByType在接口 AnnotatedElement
        重写：
        getAnnotationsByType在 AccessibleObject
        参数类型
        T - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果与此元素相关联，则指定注释类型的所有元素注释，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        重写：
        getDeclaredAnnotations在 AccessibleObject
        结果
        此元素上直接显示的注释

      • getAnnotatedReturnType

        public abstract AnnotatedType getAnnotatedReturnType​()
        返回一个AnnotatedType对象，该对象表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。 如果此Executable对象表示构造函数，则表示构造的对象的类型为AnnotatedType 。 如果这个Executable对象表示一个方法， AnnotatedType对象表示使用一个类型来指定方法的返回类型。
        结果
        表示由该 Executable表示的方法或构造函数的返回类型的对象

      • getAnnotatedReceiverType

        public AnnotatedType getAnnotatedReceiverType​()
        返回一个AnnotatedType对象，表示使用类型来指定由该Executable对象表示的方法/构造函数的接收器类型。 只有方法/构造函数具有接收器参数（JLS 8.4.1），方法/构造函数的接收器类型才可用。 如果此Executable对象表示一个实例方法或表示内部件类的构造 ，并且所述方法/构造或者具有没有接收器参数或与它的类型没有注释的接收器参数，则返回值是一个AnnotatedType表示对象没有注释的元素 如果此Executable对象表示静态方法或表示顶级，静态成员，本地或匿名类的构造函数，则返回值为null。
        结果
        表示由该 Executable或 null表示的方法或构造器的接收器类型的对象，如果该 Executable不能具有接收器参数

      • getAnnotatedParameterTypes

        public AnnotatedType[] getAnnotatedParameterTypes​()
        返回一个AnnotatedType对象的数组，表示使用类型来指定此可执行文件所表示的方法/构造函数的形式参数类型。 数组中对象的顺序对应于方法/构造函数声明中形式参数类型的顺序。 如果方法/构造函数声明没有参数，则返回长度为0的数组。
        结果
        表示由该 Executable表示的方法或构造函数的形式参数的类型的对象数组

      • getAnnotatedExceptionTypes

        public AnnotatedType[] getAnnotatedExceptionTypes​()
        返回一个AnnotatedType对象的数组，它们表示使用类型来指定由此可执行文件表示的方法/构造函数声明的异常。 数组中对象的顺序对应于方法/构造函数声明中异常类型的顺序。 如果方法/构造函数声明没有异常，则返回长度为0的数组。
        结果
        表示由该 Executable表示的方法或构造函数声明的异常的对象数组
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Field

  • java.lang.Object
    • java.lang.reflect.AccessibleObject
      • java.lang.reflect.Field
  • All Implemented Interfaces:
    AnnotatedElement ， Member

    public final class Field
extends AccessibleObject
implements Member
    A Field提供有关类或接口的单个字段的信息和动态访问。 反射的字段可以是类（静态）字段或实例字段。

    A Field允许在获取或设置访问操作期间扩大转换，但如果发生缩小转换，则抛出IllegalArgumentException 。

    从以下版本开始：
    1.1
    另请参见：
    Member ， Class ， Class.getFields() ， Class.getField(String) ， Class.getDeclaredFields() ， Class.getDeclaredField(String)

    • Field Summary

      • Fields inherited from interface java.lang.reflect.Member

        DECLARED, PUBLIC

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此 Field与指定对象进行比较。
      Object get​(Object obj)
      返回由该 Field表示的字段在指定对象上的值。
      AnnotatedType getAnnotatedType​()
      返回一个AnnotatedType对象，它表示使用一个类型来指定此Field所表示的字段的声明类型。
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      <T extends Annotation>
      T[]             		getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      boolean getBoolean​(Object obj)
      获取静态或实例的值 boolean字段。
      byte getByte​(Object obj)
      获取静态或实例的值 byte字段。
      char getChar​(Object obj)
      获取类型为 char的静态或实例字段的 char或通过加宽转换可转换为类型 char的另一个基本类型的值。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Class<?> getDeclaringClass​()
      返回 Class表示声明此表示的字段的类或接口对象 Field对象。
      double getDouble​(Object obj)
      获取类型为 double的静态或实例字段的值，或通过扩大转换获得可转换为类型 double的另一个原始类型的值。
      float getFloat​(Object obj)
      获取类型为 float的静态或实例字段的值，或通过扩大转换获得可转换为类型 float的另一个原始类型的值。
      Type getGenericType​()
      返回一个 Type对象，表示由该 Field对象表示的字段的声明类型。
      int getInt​(Object obj)
      获取类型为 int的静态或实例字段的值，或通过扩大转换获得可转换为类型 int的另一个原始类型的值。
      long getLong​(Object obj)
      获取类型为 long的静态或实例字段的值，或通过加宽转换获得可转换为类型 long的另一个基元类型的值。
      int getModifiers​()
      返回由该 Field对象表示的字段的Java语言修饰符，作为整数。
      String getName​()
      返回由该 Field对象表示的字段的名称。
      short getShort​(Object obj)
      获取类型为 short的静态或实例字段的 short或通过扩大转换可转换为类型 short的另一个基本类型的值。
      Class<?> getType​()
      返回一个 Class对象，标识由该 Field对象表示的字段的声明类型。
      int hashCode​()
      返回此 Field的哈希 Field 。
      boolean isEnumConstant​()
      如果此字段表示枚举类型的元素，则返回true ; 否则返回false 。
      boolean isSynthetic​()
      如果此字段是合成字段，则返回true ; 否则返回false 。
      void set​(Object obj, Object value)
      将指定的对象参数中由此 Field对象表示的字段设置为指定的新值。
      void setAccessible​(boolean flag)
      将此反射对象的 accessible标志设置为指示的布尔值。
      void setBoolean​(Object obj, boolean z)
      将字段的值设置为指定对象上的 boolean 。
      void setByte​(Object obj, byte b)
      将字段的值设置为指定对象上的 byte 。
      void setChar​(Object obj, char c)
      将字段的值设置为指定对象上的 char 。
      void setDouble​(Object obj, double d)
      将字段的值设置为指定对象上的 double 。
      void setFloat​(Object obj, float f)
      将字段的值设置为指定对象上的 float 。
      void setInt​(Object obj, int i)
      将字段的值设置为指定对象上的 int 。
      void setLong​(Object obj, long l)
      将字段的值设置为指定对象上的 long 。
      void setShort​(Object obj, short s)
      将字段的值设置为指定对象上的 short 。
      String toGenericString​()
      返回描述此 Field的字符串，包括其通用类型。
      String toString​()
      返回一个描述这个 Field的字符串。

      • Methods inherited from class java.lang.reflect.AccessibleObject

        canAccess, getAnnotations, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAccessible, isAnnotationPresent, setAccessible, trySetAccessible

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • setAccessible

        public void setAccessible​(boolean flag)
        描述从类别复制： AccessibleObject
        将此反射对象的accessible标志设置为指示的布尔值。 值为true表示反射对象应该在使用Java语言访问控制时抑制检查。 值为false表示反射对象应该在使用Java语言访问控制时执行检查，并在类描述中指出变体。

        该方法可以通过一个呼叫方在类中使用C以使得能够访问一个member的declaring class D如果任何下列条件成立：

        • C和D在相同的模块中。
        • 所述构件是public和D是public在于包含模块的封装D exports到至少包含模块C 。
        • 所述构件是protected static ， D是public在于包含模块的封装D出口到至少包含模块C ，和C是的一个子类D 。
        • D是在包含该模块的封装D opens到至少包含模块C 。 未命名和开放模块中的所有软件包都可用于所有模块，因此当D处于未命名或开放模块时，此方法始终会成功。

        当声明类与调用者不同的模块时，此方法不能用于启用对私有成员，具有默认（包）访问权限的成员，受保护的实例成员或受保护的构造函数的访问，并且包含声明类的包不能打开呼叫者的模块。

        如果有一个安全管理员，它的checkPermission方法首先被调用一个ReflectPermission("suppressAccessChecks")权限。

        重写：
        setAccessible在 AccessibleObject
        参数
        flag - 新值为 accessible旗帜
        异常
        InaccessibleObjectException - 如果无法启用访问
        SecurityException - 如果请求被安全管理器拒绝
        另请参见：
        AccessibleObject.trySetAccessible() ， MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • getDeclaringClass

        public Class<?> getDeclaringClass​()
        返回 Class表示声明此表示的字段的类或接口对象 Field对象。
        Specified by:
        getDeclaringClass在接口 Member
        结果
        一个表示底层成员声明类的对象

      • getName

        public String getName​()
        返回由该 Field对象表示的字段的名称。
        Specified by:
        getName在接口 Member
        结果
        底层成员的简单名称

      • getModifiers

        public int getModifiers​()
        返回由该Field对象表示的字段的Java语言修饰符，作为整数。 Modifier类应用于解码修饰符。
        Specified by:
        getModifiers在接口 Member
        结果
        底层成员的Java语言修饰符
        另请参见：
        Modifier

      • isEnumConstant

        public boolean isEnumConstant​()
        如果此字段表示枚举类型的元素，则返回true ; 否则返回false 。
        结果
        true当且仅当此字段表示枚举类型的元素时。
        从以下版本开始：
        1.5

      • isSynthetic

        public boolean isSynthetic​()
        如果此字段是合成字段，则返回true ; 否则返回false 。
        Specified by:
        isSynthetic在接口 Member
        结果
        当且仅当该字段是由Java语言规范定义的合成字段时才为真。
        从以下版本开始：
        1.5

      • getType

        public Class<?> getType​()
        返回一个 Class对象，标识由该 Field对象表示的字段的声明类型。
        结果
        标识由该对象表示的字段的声明类型的对象的 Class对象

      • getGenericType

        public Type getGenericType​()
        返回一个Type对象，表示由该Field对象表示的字段的声明类型。

        如果Type是参数化类型，则返回的Type对象必须准确反映源代码中使用的实际类型参数。

        如果底层字段的类型是类型变量或参数化类型，则会创建它。 否则解决。

        结果
        一个 Type对象，表示由该 Field对象表示的字段的声明类型
        异常
        GenericSignatureFormatError - 如果通用字段签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果基础字段的通用类型签名引用不存在的类型声明
        MalformedParameterizedTypeException - 如果基础字段的通用签名是指由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • equals

        public boolean equals​(Object obj)
        将此Field与指定对象进行比较。 如果对象相同，则返回true。 两个Field对象是相同的，如果它们被同一个类声明并具有相同的名称和类型。
        重写：
        equals在 Object
        参数
        obj - 用于比较的参考对象。
        结果
        true如果此对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此Field的哈希Field 。 这被计算为底层字段声明类名称及其名称的排他或哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回一个描述这个Field的字符串。 格式是字段的访问修饰符（如果有），后跟字段类型，后跟一个空格，然后是声明该字段的类的完全限定名称，后跟一个句点，后跟该字段的名称。 例如：
          public static final int java.lang.Thread.MIN_PRIORITY
    private int java.io.FileDescriptor.fd

        修饰符按照“Java语言规范”的规定放置在规范的顺序。 这是public ， protected或private以下顺序，然后再其它改性剂： static ， final ， transient ， volatile 。

        重写：
        toString在 Object
        结果
        一个描述这个 Field的字符串
        See The Java™ Language Specification:
        8.3.1字段修饰符

      • toGenericString

        public String toGenericString​()
        返回描述此Field的字符串，包括其泛型类型。 格式是字段的访问修饰符（如果有的话），后跟通用字段类型，后跟一个空格，然后是声明该字段的类的完全限定名称，后跟一个句点，后跟名称领域。

        修饰符按照“Java语言规范”的规定放置在规范的顺序。 这是public ， protected或private以下顺序，然后再其它改性剂： static ， final ， transient ， volatile 。

        结果
        一个描述这个 Field的字符串，包括它的泛型类型
        从以下版本开始：
        1.5
        See The Java™ Language Specification:
        8.3.1字段修饰符

      • get

        public Object get​(Object obj)
           throws IllegalArgumentException,
                  IllegalAccessException
        返回指定对象上由此Field表示的字段的值。 如果该对象具有原始类型，则该值将自动包装在对象中。

        基础字段的值如下获得：

        如果基础字段是静态字段，则忽略obj参数; 它可能为null。

        否则，底层字段是一个实例字段。 如果指定的obj参数为空，则该方法将抛出一个NullPointerException 。 如果指定的对象不是声明底层字段的类或接口的实例，则该方法将抛出一个IllegalArgumentException 。

        如果这个Field对象正在执行Java语言访问控制，并且底层字段是无法访问的，则该方法将抛出一个IllegalAccessException 。 如果底层字段是静态的，那么声明该字段的类如果尚未被初始化，则会被初始化。

        否则，将从底层实例或静态字段检索该值。 如果该字段具有原始类型，则该值在返回之前被包装在对象中，否则返回原样。

        如果该字段隐藏在obj类型中，则根据前述规则获取该字段的值。

        参数
        obj - 要从中提取表示字段的值的对象
        结果
        对象obj表示字段的值; 原始值被包装在适当的对象之前被返回
        异常
        IllegalAccessException - 如果此 Field对象正在强制执行Java语言访问控制，并且底层字段无法访问。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。

      • getBoolean

        public boolean getBoolean​(Object obj)
                   throws IllegalArgumentException,
                          IllegalAccessException
        获取静态或实例的值 boolean字段。
        参数
        obj - 该对象从中提取 boolean值
        结果
        该值为 boolean字段
        异常
        IllegalAccessException - 如果这个 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者通过扩大转换不能将字段值转换为类型 boolean 。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • getByte

        public byte getByte​(Object obj)
             throws IllegalArgumentException,
                    IllegalAccessException
        获取静态或实例的值 byte字段。
        参数
        obj - 对象提取 byte值
        结果
        该值为 byte字段
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段无法访问。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者如果字段值不能通过扩大转换转换为类型 byte 。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • getChar

        public char getChar​(Object obj)
             throws IllegalArgumentException,
                    IllegalAccessException
        获取类型为 char的静态或实例字段的值，或通过扩展转换获得可转换为类型 char的另一个原始类型的值。
        参数
        obj - 该对象提取 char值
        结果
        该字段的值转换为 char
        异常
        IllegalAccessException - 如果这个 Field对象正在执行Java语言访问控制，并且底层字段是不可访问的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者如果字段值不能通过加宽转换转换为类型 char 。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • getShort

        public short getShort​(Object obj)
               throws IllegalArgumentException,
                      IllegalAccessException
        获取类型为 short的静态或实例字段的 short或通过扩展转换可转换为类型 short的另一个原始类型的值。
        参数
        obj - 对象提取 short值
        结果
        该字段的值转换为 short型
        异常
        IllegalAccessException - 如果这个 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者如果字段值不能通过扩大转换转换为类型 short 。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • getInt

        public int getInt​(Object obj)
           throws IllegalArgumentException,
                  IllegalAccessException
        获取类型为 int的静态或实例字段的值，或通过扩大转换获得可转换为类型 int的另一个原始类型的值。
        参数
        obj - 该对象从中提取 int值
        结果
        该字段的值转换为 int
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段无法访问。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者如果字段值不能通过扩展转换转换为类型 int 。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • getLong

        public long getLong​(Object obj)
             throws IllegalArgumentException,
                    IllegalAccessException
        获取类型为 long的静态或实例字段的值，或通过扩大转换获得可转换为类型 long的另一个原始类型的值。
        参数
        obj - 该对象从中提取 long值
        结果
        该字段的值转换为 long
        异常
        IllegalAccessException - 如果这个 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者如果字段值不能通过扩大转换转换为类型 long 。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • getFloat

        public float getFloat​(Object obj)
               throws IllegalArgumentException,
                      IllegalAccessException
        获取类型为 float的静态或实例字段的 float或通过扩大转换可转换为类型 float的另一个原始类型的值。
        参数
        obj - 该对象从中提取 float值
        结果
        该字段的值转换为 float
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段无法访问。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者如果字段值不能通过扩展转换转换为类型 float 。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • getDouble

        public double getDouble​(Object obj)
                 throws IllegalArgumentException,
                        IllegalAccessException
        获取类型为 double的静态或实例字段的值，或通过扩大转换获得可转换为类型 double的另一个基元类型的值。
        参数
        obj - 该对象从中提取 double值
        结果
        该字段的值转换为类型 double
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段无法访问。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者如果字段值不能通过扩大转换转换为类型 double 。
        NullPointerException - 如果指定的对象为空，并且该字段是实例字段。
        ExceptionInInitializerError - 如果此方法引发的初始化失败。
        另请参见：
        get(java.lang.Object)

      • set

        public void set​(Object obj,
                Object value)
         throws IllegalArgumentException,
                IllegalAccessException
        将指定的对象参数上由此Field对象表示的字段设置为指定的新值。 如果基础字段具有原始类型，则新值将自动解包。

        操作进行如下：

        如果基础字段是静态的，则忽略obj参数; 它可能为null。

        否则底层字段是一个实例字段。 如果指定的对象参数为空，该方法将抛出一个NullPointerException 。 如果指定的对象参数不是声明底层字段的类或接口的实例，则该方法将抛出一个IllegalArgumentException 。

        如果这个Field对象正在执行Java语言访问控制，并且底层字段是无法访问的，则该方法将抛出一个IllegalAccessException 。

        如果底层字段为final，该方法将抛出一个IllegalAccessException除非setAccessible(true)已成功为该Field对象，该字段是非静态的。 以这种方式设置最终字段只有在反序列化或重建具有空白最终字段的类的实例时才有意义，才能使其可用于程序其他部分的访问。 在任何其他情况下使用可能会产生不可预测的影响，包括程序的其他部分继续使用此字段的原始值的情况。

        如果底层字段是原始类型，则尝试展开转换以将新值转换为基本类型的值。 如果此尝试失败，该方法将抛出一个IllegalArgumentException 。

        如果在可能的展开后，新值不能通过标识或扩展转换转换为底层字段的类型，该方法将抛出一个IllegalArgumentException 。

        如果底层字段是静态的，那么声明该字段的类如果尚未被初始化，则会被初始化。

        该字段设置为可能展开和扩大的新值。

        如果该字段隐藏在obj类型中，则该字段的值根据上述规则设置。

        参数
        obj - 其字段应该被修改的对象
        value - 修改了 obj字段的新值
        异常
        IllegalAccessException - 如果此 Field对象正在强制执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者解包转换失败。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果此方法引发的初始化失败。

      • setBoolean

        public void setBoolean​(Object obj,
                       boolean z)
                throws IllegalArgumentException,
                       IllegalAccessException
        将字段的值设置为指定对象上的boolean 。 此方法相当于set(obj, zObj) ，其中zObj是Boolean对象和zObj.booleanValue() == z 。
        参数
        obj - 其字段应该被修改的对象
        z - 修改了 obj字段的新值
        异常
        IllegalAccessException - 如果这个 Field对象正在执行Java语言访问控制，并且底层字段是无法访问或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）或解包转换失败的类或接口的实例。
        NullPointerException - 如果指定的对象为空，并且该字段是实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • setByte

        public void setByte​(Object obj,
                    byte b)
             throws IllegalArgumentException,
                    IllegalAccessException
        将字段的值设置为指定对象上的byte 。 这个方法相当于set(obj, bObj) ，其中bObj是一个Byte对象和bObj.byteValue() == b 。
        参数
        obj - 其字段应该被修改的对象
        b - 修改了 obj字段的新值
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者展开转换失败。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • setChar

        public void setChar​(Object obj,
                    char c)
             throws IllegalArgumentException,
                    IllegalAccessException
        将字段的值设置为指定对象上的char 。 该方法相当于set(obj, cObj) ，其中cObj是Character对象和cObj.charValue() == c 。
        参数
        obj - 其字段应该被修改的对象
        c - 修改了 obj的字段的新值
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者展开转换失败。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • setShort

        public void setShort​(Object obj,
                     short s)
              throws IllegalArgumentException,
                     IllegalAccessException
        将字段的值设置为指定对象上的short 。 该方法相当于set(obj, sObj) ，其中sObj是Short对象和sObj.shortValue() == s 。
        参数
        obj - 其字段应该被修改的对象
        s - 修改了 obj字段的新值
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者展开转换失败。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • setInt

        public void setInt​(Object obj,
                   int i)
            throws IllegalArgumentException,
                   IllegalAccessException
        将字段的值设置为指定对象上的int 。 该方法相当于set(obj, iObj) ，其中iObj是Integer对象和iObj.intValue() == i 。
        参数
        obj - 其字段应该被修改的对象
        i - 修改了 obj的新值
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者展开转换失败。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • setLong

        public void setLong​(Object obj,
                    long l)
             throws IllegalArgumentException,
                    IllegalAccessException
        将字段的值设置为指定对象上的long 。 该方法相当于set(obj, lObj) ，其中lObj为Long对象， lObj.longValue() == l 。
        参数
        obj - 其字段应该被修改的对象
        l - 修改了 obj字段的新值
        异常
        IllegalAccessException - 如果此 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者展开转换失败。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • setFloat

        public void setFloat​(Object obj,
                     float f)
              throws IllegalArgumentException,
                     IllegalAccessException
        将字段的值设置为指定对象上的float 。 该方法相当于set(obj, fObj) ，其中fObj是Float对象和fObj.floatValue() == f 。
        参数
        obj - 其字段应该被修改的对象
        f - 修改了 obj字段的新值
        异常
        IllegalAccessException - 如果这个 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）的类或接口的实例，或者展开转换失败。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • setDouble

        public void setDouble​(Object obj,
                      double d)
               throws IllegalArgumentException,
                      IllegalAccessException
        将字段的值设置为指定对象上的double 。 此方法相当于set(obj, dObj) ，其中dObj是Double对象和dObj.doubleValue() == d 。
        参数
        obj - 应修改其字段的对象
        d - 修改了 obj的新值
        异常
        IllegalAccessException - 如果这个 Field对象正在执行Java语言访问控制，并且底层字段是无法访问的或最终的。
        IllegalArgumentException - 如果指定的对象不是声明底层字段（或其子类或实现者）或解包转换失败的类或接口的实例。
        NullPointerException - 如果指定的对象为空，该字段为实例字段。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。
        另请参见：
        set(java.lang.Object, java.lang.Object)

      • getAnnotation

        public <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        说明从接口AnnotatedElement复制
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        重写：
        getAnnotation在 AccessibleObject
        参数类型
        T - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getAnnotationsByType

        public <T extends Annotation> T[] getAnnotationsByType​(Class<T> annotationClass)
        返回与此元素相关联的注释。 如果没有与此元素相关联的注释，则返回值为长度为0的数组。此方法与AnnotatedElement.getAnnotation(Class)之间的区别在于该方法是否检测其参数是否是可重复注释类型 （JLS 9.6），如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotationsByType在接口 AnnotatedElement
        重写：
        getAnnotationsByType在 AccessibleObject
        参数类型
        T - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果与此元素相关联，则指定注释类型的所有元素注释，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.8

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        重写：
        getDeclaredAnnotations在 AccessibleObject
        结果
        此元素上直接显示的注释

      • getAnnotatedType

        public AnnotatedType getAnnotatedType​()
        返回一个AnnotatedType对象，它表示使用一个类型来指定此Field所表示的字段的声明类型。
        结果
        表示由该字段表示的字段的声明类型的对象
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GenericArrayType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface GenericArrayType

  • All Superinterfaces:
    Type

    public interface GenericArrayType
extends Type
    GenericArrayType表示其组件类型是参数化类型或类型变量的数组类型。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Type getGenericComponentType​()
      返回表示此数组的组件类型的 Type对象。

      • Methods inherited from interface java.lang.reflect.Type

        getTypeName

    • 方法详细信息

      • getGenericComponentType

        Type getGenericComponentType​()
        返回表示此数组的组件类型的Type对象。 此方法创建数组的组件类型。 有关参数化类型的创建过程的语义，请参见ParameterizedType的声明，有关类型变量的创建过程，请参阅TypeVariable 。
        结果
        表示此数组的组件类型的 Type对象
        异常
        TypeNotPresentException - 如果底层数组类型的组件类型引用不存在的类型声明
        MalformedParameterizedTypeException - 如果底层数组类型的组件类型是指由于任何原因无法实例化的参数化类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GenericDeclaration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface GenericDeclaration

  • All Superinterfaces:
    AnnotatedElement
    所有已知实现类：
    Class ， Constructor ， Executable ， 方法

    public interface GenericDeclaration
extends AnnotatedElement
    声明类型变量的所有实体的通用接口。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      TypeVariable<?>[] getTypeParameters​()
      返回一个 TypeVariable对象的数组，表示由该 GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotation, getAnnotations, getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotations, getDeclaredAnnotationsByType, isAnnotationPresent

    • 方法详细信息

      • getTypeParameters

        TypeVariable<?>[] getTypeParameters​()
        返回一个TypeVariable对象的数组，表示由该GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。 如果底层通用声明不声明类型变量，则返回长度为0的数组。
        结果
        一个 TypeVariable对象的数组，表示此通用声明声明的类型变量
        异常
        GenericSignatureFormatError - 如果此通用声明的通用签名不符合 The Java™ Virtual Machine Specification中指定的格式
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


GenericSignatureFormatError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class GenericSignatureFormatError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.ClassFormatError
            • java.lang.reflect.GenericSignatureFormatError
  • All Implemented Interfaces:
    Serializable

    public class GenericSignatureFormatError
extends ClassFormatError
    当需要解释类型，方法或构造函数的通用签名信息的反射方法遇到语法错误的签名属性时抛出。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      GenericSignatureFormatError​()
      构造新的 GenericSignatureFormatError 。
      GenericSignatureFormatError​(String message)
      构造一个新的 GenericSignatureFormatError与指定的消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • GenericSignatureFormatError

        public GenericSignatureFormatError​()
        构造新的 GenericSignatureFormatError 。

      • GenericSignatureFormatError

        public GenericSignatureFormatError​(String message)
        构造一个新的 GenericSignatureFormatError与指定的消息。
        参数
        message - 详细信息，可以是 null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InaccessibleObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class InaccessibleObjectException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.reflect.InaccessibleObjectException
  • All Implemented Interfaces:
    Serializable

    public class InaccessibleObjectException
extends RuntimeException
    Java语言访问检查无法被抑制时抛出。
    从以下版本开始：
    9
    另请参见：
    AccessibleObject.setAccessible(boolean) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InaccessibleObjectException​()
      构造一个 InaccessibleObjectException ，没有详细信息。
      InaccessibleObjectException​(String msg)
      构造具有给定详细消息的 InaccessibleObjectException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InaccessibleObjectException

        public InaccessibleObjectException​()
        构造一个 InaccessibleObjectException ，没有详细信息。

      • InaccessibleObjectException

        public InaccessibleObjectException​(String msg)
        构造具有给定详细消息的 InaccessibleObjectException 。
        参数
        msg - 详细信息
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvocationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface InvocationHandler

  • 所有已知实现类：
    CompositeDataInvocationHandler ， EventHandler ， MBeanServerInvocationHandler ， RemoteObjectInvocationHandler

    public interface InvocationHandler
    InvocationHandler是由代理实例的调用处理程序实现的接口。

    每个代理实例都有一个关联的调用处理程序。 当在代理实例上调用方法时，方法调用将被编码并分派到其调用处理程序的invoke方法。

    从以下版本开始：
    1.3
    另请参见：
    Proxy

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object invoke​(Object proxy, 方法 method, Object[] args)
      处理代理实例上的方法调用并返回结果。

    • 方法详细信息

      • invoke

        Object invoke​(Object proxy,
              方法 method,
              Object[] args)
       throws Throwable
        处理代理实例上的方法调用并返回结果。 当在与之关联的代理实例上调用方法时，将在调用处理程序中调用此方法。
        参数
        proxy - 调用该方法的代理实例
        method - 对应于在代理实例上调用的接口方法的方法实例。 方法对象的声明类将是方法声明的接口，它可以是代理类继承方法的代理接口的超级接口。
        args - 包含代理实例上方法调用中传递的参数值的对象数组，如果接口方法不带参数， null 。 原始类型的参数包含在适当的原始包装器类的实例中，例如java.lang.Integer或java.lang.Boolean 。
        结果
        从代理实例上的方法调用返回的值。 如果接口方法的声明返回类型是原始类型，则此方法返回的值必须是对应的基本包装类的实例; 否则，它必须是可声明返回类型的类型。 如果此方法返回的值为null ，并且接口方法的返回类型是原始的，则代理实例上的方法调用将抛出NullPointerException 。 如果此方法返回的值与上述的接口方法声明的返回类型不兼容，那么代理实例上的方法调用将抛出一个ClassCastException 。
        异常
        Throwable - 从代理实例上的方法调用抛出的异常。 异常类型必须可以分配给接口方法的throws子句中声明的任何异常类型或未检查的异常类型java.lang.RuntimeException或java.lang.Error 。 如果此方法抛出一个检查的异常，该方法不能分配给接口方法的throws子句中声明的任何异常类型，那么包含此方法抛出的异常的UndeclaredThrowableException将被引用在方法调用上代理实例。
        另请参见：
        UndeclaredThrowableException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InvocationTargetException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class InvocationTargetException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.ReflectiveOperationException
          • java.lang.reflect.InvocationTargetException
  • All Implemented Interfaces:
    Serializable

    public class InvocationTargetException
extends ReflectiveOperationException
    InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 在建造时提供并通过getTargetException()方法访问的“目标异常”现在被称为原因 ，并且可以通过Throwable.getCause()方法以及上述“传统方法”来访问。

    从以下版本开始：
    1.1
    另请参见：
    方法 ， Constructor ， Serialized Form

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected InvocationTargetException​()
      构造一个 InvocationTargetException与 null作为目标异常。
        InvocationTargetException​(Throwable target)
      构造一个具有目标异常的InvocationTargetException。
        InvocationTargetException​(Throwable target, String s)
      构造一个具有目标异常和详细消息的InvocationTargetException。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因（抛出的目标异常，可能是 null ）。
      Throwable getTargetException​()
      获取抛出的目标异常。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • InvocationTargetException

        protected InvocationTargetException​()
        构造一个 InvocationTargetException作为目标异常的 null 。

      • InvocationTargetException

        public InvocationTargetException​(Throwable target)
        构造一个具有目标异常的InvocationTargetException。
        参数
        target - 目标异常

      • InvocationTargetException

        public InvocationTargetException​(Throwable target,
                                 String s)
        构造一个具有目标异常和详细消息的InvocationTargetException。
        参数
        target - 目标异常
        s - 详细信息

    • 方法详细信息

      • getTargetException

        public Throwable getTargetException​()
        获取抛出的目标异常。

        这种方法早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

        结果
        抛出的目标异常（导致此异常）。

      • getCause

        public Throwable getCause​()
        返回此异常的原因（抛出的目标异常，可能是 null ）。
        重写：
        getCause在 Throwable
        结果
        这个例外的原因。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.lang.reflect (Java SE 9 & JDK 9 )

java.lang.reflect

Interfaces

  • AnnotatedArrayType
  • AnnotatedElement
  • AnnotatedParameterizedType
  • AnnotatedType
  • AnnotatedTypeVariable
  • AnnotatedWildcardType
  • GenericArrayType
  • GenericDeclaration
  • InvocationHandler
  • Member
  • ParameterizedType
  • Type
  • TypeVariable
  • WildcardType

Classes

  • AccessibleObject
  • Array
  • Constructor
  • Executable
  • Field
  • 方法
  • Modifier
  • Parameter
  • Proxy
  • ReflectPermission

Exceptions

  • InaccessibleObjectException
  • InvocationTargetException
  • MalformedParameterizedTypeException
  • MalformedParametersException
  • UndeclaredThrowableException

Errors

  • GenericSignatureFormatError


java.lang.reflect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.lang.reflect

提供用于获取关于类和对象的反射信息的类和接口。 反射允许对封装类的字段，方法和构造函数的信息进行编程访问，以及在封装和安全限制内使用反射的字段，方法和构造函数对其底层对等体进行操作。

AccessibleObject允许禁止访问检查，如果必要的ReflectPermission可用。

Array提供静态方法来动态创建和访问数组。

该包中的类与java.lang.Class一起适用于诸如调试器，解释器，对象检查器，类浏览器以及需要访问目标对象的公共成员（基于其运行时类）的对象序列化和JavaBeans之类的应用程序或由给定类宣布的成员。

从以下版本开始：
1.1
  • 接口摘要
    接口 描述
    AnnotatedArrayType
    AnnotatedArrayType表示数组类型的潜在注释使用，其组件类型本身可以表示类型的注释使用。
    AnnotatedElement
    表示当前在此VM中运行的程序的注释元素。
    AnnotatedParameterizedType
    AnnotatedParameterizedType表示参数化类型的潜在注释使用，其类型参数本身可以表示类型的注释使用。
    AnnotatedType
    AnnotatedType表示当前在此VM中运行的程序中可能注释的使用类型。
    AnnotatedTypeVariable
    AnnotatedTypeVariable表示类型变量的潜在注释使用，其声明可能具有其自身表示注释类型使用的界限。
    AnnotatedWildcardType
    AnnotatedWildcardType表示通配符类型参数的潜在注释使用，其上限或下限本身可以表示类型的注释使用。
    GenericArrayType
    GenericArrayType表示组件类型为参数化类型或类型变量的数组类型。
    GenericDeclaration
    声明类型变量的所有实体的通用接口。
    InvocationHandler
    InvocationHandler是由代理实例的 调用处理程序实现的接口。
    Member
    Member是一个反映关于单个成员（字段或方法）或构造函数的标识信息的接口。
    ParameterizedType
    ParameterizedType表示一个参数化类型，如Collection <String>。
    Type
    Type是Java编程语言中所有类型的通用超级接口。
    TypeVariable<D extends GenericDeclaration>
    TypeVariable是类型变量的常用超级接口。
    WildcardType
    WildcardType表示一个通配符型表达，如 ? ， ? extends Number ，或 ? super Integer 。
  • 类摘要
    Class 描述
    AccessibleObject
    所述 AccessibleObject类是基础类 Field ， 方法 ，和 Constructor对象（被称为 反射的对象 ）。
    Array
    Array类提供静态方法来动态创建和访问Java数组。
    Constructor<T>
    Constructor提供有关类和单个构造函数的访问权限。
    Executable
    方法和Constructor的共同功能的共享超类。
    Field
    A Field提供有关类或接口的单个字段的信息和动态访问。
    方法
    A 方法在类或接口上提供有关单一方法的信息和访问权限。
    Modifier
    Modifier类提供 static方法和常量来解码类和成员访问修饰符。
    Parameter
    有关方法参数的信息。
    Proxy
    Proxy提供静态方法，用于创建类似于接口实例的对象，但允许自定义的方法调用。
    ReflectPermission
    反思操作的权限类。
  • 异常摘要
    异常 描述
    InaccessibleObjectException
    Java语言访问检查无法被抑制时抛出。
    InvocationTargetException
    InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
    MalformedParameterizedTypeException
    当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。
    MalformedParametersException
    当 the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。
    UndeclaredThrowableException
    通过方法调用代理实例时抛出的调用处理程序的 invoke方法抛出检查异常（一 Throwable不是分配给 RuntimeException或者 Error ）是不能分配给任何中声明的异常类型 throws方法的条款，在代理实例上调用并分派到调用处理程序。
  • Error Summary
    Error 描述
    GenericSignatureFormatError
    Thrown when a syntactically malformed signature attribute is encountered by a reflective method that needs to interpret the generic signature information for a type, method or constructor.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.lang.reflect Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.lang.reflect

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.reflect.AccessibleObject (implements java.lang.reflect.AnnotatedElement)
      • java.lang.reflect.Executable (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
        • java.lang.reflect.Constructor<T>
        • java.lang.reflect.方法
      • java.lang.reflect.Field (implements java.lang.reflect.Member)
    • java.lang.reflect.Array
    • java.lang.reflect.Modifier
    • java.lang.reflect.Parameter (implements java.lang.reflect.AnnotatedElement)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.lang.reflect.ReflectPermission
    • java.lang.reflect.Proxy (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.ClassFormatError
            • java.lang.reflect.GenericSignatureFormatError
      • java.lang.异常
        • java.lang.ReflectiveOperationException
          • java.lang.reflect.InvocationTargetException
        • java.lang.RuntimeException
          • java.lang.reflect.InaccessibleObjectException
          • java.lang.reflect.MalformedParameterizedTypeException
          • java.lang.reflect.MalformedParametersException
          • java.lang.reflect.UndeclaredThrowableException

Interface Hierarchy

  • java.lang.reflect.AnnotatedElement
    • java.lang.reflect.AnnotatedType
      • java.lang.reflect.AnnotatedArrayType
      • java.lang.reflect.AnnotatedParameterizedType
      • java.lang.reflect.AnnotatedTypeVariable
      • java.lang.reflect.AnnotatedWildcardType
    • java.lang.reflect.GenericDeclaration
    • java.lang.reflect.TypeVariable<D> (also extends java.lang.reflect.Type)
  • java.lang.reflect.InvocationHandler
  • java.lang.reflect.Member
  • java.lang.reflect.Type
    • java.lang.reflect.GenericArrayType
    • java.lang.reflect.ParameterizedType
    • java.lang.reflect.TypeVariable<D> (also extends java.lang.reflect.AnnotatedElement)
    • java.lang.reflect.WildcardType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


MalformedParameterizedTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class MalformedParameterizedTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.reflect.MalformedParameterizedTypeException
  • All Implemented Interfaces:
    Serializable

    public class MalformedParameterizedTypeException
extends RuntimeException
    当需要实例化的反射方法遇到语义畸变的参数化类型时抛出。 例如，如果参数化类型的类型参数的数量是错误的。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MalformedParameterizedTypeException​()

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MalformedParameterizedTypeException

        public MalformedParameterizedTypeException​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MalformedParametersException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class MalformedParametersException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.reflect.MalformedParametersException
  • All Implemented Interfaces:
    Serializable

    public class MalformedParametersException
extends RuntimeException
    当the java.lang.reflect package尝试从类文件中读取方法参数并确定一个或多个参数格式错误时抛出。

    以下是可以抛出此异常的条件列表：

    • 参数（parameter_count）的数量对于该方法是错误的
    • 常数池索引超出范围。
    • 常量池索引不涉及UTF-8条目
    • 参数名称为“”，或包含非法字符
    • 标志字段包含非法标志（除了FINAL，SYNTHETIC或MANDATED之外的其他标志）
    有关详细信息，请参阅Executable.getParameters() 。
    从以下版本开始：
    1.8
    另请参见：
    Executable.getParameters() ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MalformedParametersException​()
      创建一个空的原因 MalformedParametersException 。
      MalformedParametersException​(String reason)
      创建一个 MalformedParametersException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MalformedParametersException

        public MalformedParametersException​()
        创建一个空的原因 MalformedParametersException 。

      • MalformedParametersException

        public MalformedParametersException​(String reason)
        创建一个 MalformedParametersException 。
        参数
        reason - 异常的原因。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Member (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface Member

  • 所有已知实现类：
    Constructor ， Executable ， Field ， 方法

    public interface Member
    Member是一个反映关于单个成员（字段或方法）或构造函数的标识信息的接口。
    从以下版本开始：
    1.1
    另请参见：
    Class ， Field ， 方法 ， Constructor

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int DECLARED
      标识类或接口的已声明成员集。
      static int PUBLIC
      标识类或接口的所有公共成员的集合，包括继承的成员。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Class<?> getDeclaringClass​()
      返回表示声明该成员表示的成员或构造函数的类或接口的Class对象。
      int getModifiers​()
      返回由此成员表示的成员或构造函数的Java语言修饰符，作为整数。
      String getName​()
      返回由此成员表示的基础成员或构造函数的简单名称。
      boolean isSynthetic​()
      如果该成员由编译器引入，则返回true ; 否则返回false 。

    • 字段详细信息

      • PUBLIC

        static final int PUBLIC
        标识类或接口的所有公共成员的集合，包括继承的成员。
        另请参见：
        Constant Field Values

      • DECLARED

        static final int DECLARED
        标识类或接口的已声明成员集。 不包括继承的成员。
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getDeclaringClass

        Class<?> getDeclaringClass​()
        返回表示声明该成员表示的成员或构造函数的类或接口的Class对象。
        结果
        一个表示底层成员声明类的对象

      • getName

        String getName​()
        返回由此成员表示的基础成员或构造函数的简单名称。
        结果
        底层成员的简单名称

      • getModifiers

        int getModifiers​()
        返回由此成员表示的成员或构造函数的Java语言修饰符，作为整数。 修饰符类应用于解码整数中的修饰符。
        结果
        底层成员的Java语言修饰符
        另请参见：
        Modifier

      • isSynthetic

        boolean isSynthetic​()
        如果该成员由编译器引入，则返回true ; 否则返回false 。
        结果
        当且仅当该成员由编译器引入时才是真实的。
        从以下版本开始：
        1.5
        See The Java™ Language Specification:
        13.1 The Form of a Binary
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Method (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Method

  • java.lang.Object
    • java.lang.reflect.AccessibleObject
      • java.lang.reflect.Executable
        • java.lang.reflect.Method
  • All Implemented Interfaces:
    AnnotatedElement ， GenericDeclaration ， Member

    public final class 方法
extends Executable
    A 方法在类或接口上提供有关单一方法的信息和访问权限。 反映的方法可以是类方法或实例方法（包括抽象方法）。

    A 方法允许在匹配实际参数以使用底层方法的形式参数进行调用时发生扩展转换，但如果发生缩小转换，则会引发IllegalArgumentException 。

    从以下版本开始：
    1.1
    另请参见：
    Member ， Class ， Class.getMethods() ， Class.getMethod(String, Class[]) ， Class.getDeclaredMethods() ， Class.getDeclaredMethod(String, Class[])

    • Field Summary

      • Fields inherited from interface java.lang.reflect.Member

        DECLARED, PUBLIC

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此 方法与指定对象进行比较。
      AnnotatedType getAnnotatedReturnType​()
      返回一个 AnnotatedType对象，表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      Class<?> getDeclaringClass​()
      返回表示由该对象表示的方法的类或接口的 Class对象。
      Object getDefaultValue​()
      返回由此 方法实例表示的注释成员的默认值。
      Class<?>[] getExceptionTypes​()
      返回一个 Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。
      Type[] getGenericExceptionTypes​()
      返回一个 Type对象的数组，表示此可执行对象声明抛出的异常。
      Type[] getGenericParameterTypes​()
      返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。
      Type getGenericReturnType​()
      返回一个 Type对象，它表示由该表示的方法的正式返回类型 方法对象。
      int getModifiers​()
      返回由该对象表示的可执行文件的Java语言modifiers 。
      String getName​()
      返回由该 方法对象表示的方法的名称，作为 String 。
      Annotation[][] getParameterAnnotations​()
      返回一个 Annotation s的数组数组，表示由该对象表示的 Executable的形式参数的声明顺序。
      int getParameterCount​()
      返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。
      Class<?>[] getParameterTypes​()
      返回一个 Class对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。
      Class<?> getReturnType​()
      返回一个 Class对象，表示由该 方法对象表示的方法的正式返回类型。
      TypeVariable<方法>[] getTypeParameters​()
      返回一个 TypeVariable对象的数组，表示由该 GenericDeclaration对象表示的通用声明以声明顺序声明的类型变量。
      int hashCode​()
      返回此 方法的哈希 方法 。
      Object invoke​(Object obj, Object... args)
      在具有指定参数的指定对象上调用此 方法对象表示的基础方法。
      boolean isBridge​()
      如果此方法是桥接方法，则返回true ; 否则返回false 。
      boolean isDefault​()
      如果此方法是默认方法，则返回true ; 否则返回false 。
      boolean isSynthetic​()
      如果这个可执行文件是一个合成的结构，返回true ; 否则返回false 。
      boolean isVarArgs​()
      如果这个可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。
      void setAccessible​(boolean flag)
      将此反射对象的 accessible标志设置为指示的布尔值。
      String toGenericString​()
      返回一个描述这个 方法的字符串，包括类型参数。
      String toString​()
      返回描述此 方法的字符串。

      • Methods inherited from class java.lang.reflect.AccessibleObject

        canAccess, getAnnotations, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAccessible, isAnnotationPresent, setAccessible, trySetAccessible

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotations, getDeclaredAnnotation, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from class java.lang.reflect.Executable

        getAnnotatedExceptionTypes, getAnnotatedParameterTypes, getAnnotatedReceiverType, getAnnotationsByType, getParameters

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • setAccessible

        public void setAccessible​(boolean flag)
        描述从类别复制： AccessibleObject
        将此反射对象的accessible标志设置为指示的布尔值。 值为true表示反射对象应该在使用Java语言访问控制时抑制检查。 值为false表示反射对象应该在使用Java语言访问控制时执行检查，并在类描述中指出变体。

        该方法可以通过一个呼叫方在类中使用C以使得能够访问一个member的declaring class D如果任何下列条件成立：

        • C和D都在同一个模块中。
        • 所述构件是public和D是public在于包含模块的封装D exports到至少包含模块C 。
        • 所述构件是protected static ， D是public在于包含模块的封装D出口到至少包含模块C ，和C是的一个子类D 。
        • D是在包含该模块的封装D opens到至少包含模块C 。 未命名和开放模块中的所有软件包均可对所有模块开放，因此当D处于未命名或打开模块时，此方法始终会成功。

        当声明类与调用者不同的模块时，此方法不能用于启用对私有成员，具有默认（包）访问权限的成员，受保护的实例成员或受保护的构造函数的访问，并且包含声明类的包不能打开呼叫者的模块。

        如果有一个安全管理员，它的checkPermission方法首先被调用一个ReflectPermission("suppressAccessChecks")权限。

        重写：
        setAccessible在类 AccessibleObject
        参数
        flag - 新值为 accessible旗帜
        异常
        InaccessibleObjectException - 如果无法启用访问权限
        SecurityException - 如果请求被安全管理器拒绝
        另请参见：
        AccessibleObject.trySetAccessible() ， MethodHandles.privateLookupIn(java.lang.Class<?>, java.lang.invoke.MethodHandles.Lookup)

      • getDeclaringClass

        public Class<?> getDeclaringClass​()
        返回表示由该对象表示的方法的类或接口的 Class对象。
        Specified by:
        getDeclaringClass在接口 Member
        Specified by:
        getDeclaringClass在 Executable
        结果
        一个表示底层成员声明类的对象

      • getName

        public String getName​()
        返回由该 方法对象表示的方法的名称，作为 String 。
        Specified by:
        getName在接口 Member
        Specified by:
        getName中的 Executable
        结果
        底层成员的简单名称

      • getModifiers

        public int getModifiers​()
        返回由该对象表示的可执行文件的Java语言modifiers 。
        Specified by:
        getModifiers在接口 Member
        Specified by:
        getModifiers在 Executable
        结果
        底层成员的Java语言修饰符
        另请参见：
        Modifier

      • getTypeParameters

        public TypeVariable<方法>[] getTypeParameters​()
        返回一个TypeVariable对象的数组，表示由该GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。 如果底层通用声明不声明类型变量，则返回长度为0的数组。
        Specified by:
        getTypeParameters在接口 GenericDeclaration
        Specified by:
        getTypeParameters在 Executable
        结果
        一个 TypeVariable对象的数组，表示此通用声明声明的类型变量
        异常
        GenericSignatureFormatError - 如果此通用声明的通用签名不符合 The Java™ Virtual Machine Specification中指定的格式
        从以下版本开始：
        1.5

      • getReturnType

        public Class<?> getReturnType​()
        返回一个 Class对象，表示由该 方法对象表示的方法的正式返回类型。
        结果
        该对象表示的方法的返回类型

      • getGenericReturnType

        public Type getGenericReturnType​()
        返回一个Type对象，表示由该方法对象表示的方法的正式返回类型。

        如果返回类型是参数化类型，则Type对象Type必须准确反映源代码中使用的实际类型参数。

        如果返回类型是类型变量或参数化类型，则创建它。 否则解决。

        结果
        一个 Type对象，代表底层方法的正式返回类型
        异常
        GenericSignatureFormatError - 如果通用方法签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果底层方法的返回类型是指不存在的类型声明
        MalformedParameterizedTypeException - 如果底层方法的返回类型是指由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • getParameterTypes

        public Class<?>[] getParameterTypes​()
        返回一个Class对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。 如果底层可执行文件没有参数，则返回长度为0的数组。
        Specified by:
        getParameterTypes在 Executable
        结果
        该对象表示的可执行文件的参数类型

      • getParameterCount

        public int getParameterCount​()
        返回由此对象表示的可执行文件的形式参数（无论是显式声明还是隐式声明）的数量。
        重写：
        getParameterCount在 Executable
        结果
        该对象表示的可执行文件的形式参数的数量
        从以下版本开始：
        1.8

      • getGenericParameterTypes

        public Type[] getGenericParameterTypes​()
        返回一个Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。 如果底层可执行文件没有参数，则返回长度为0的数组。

        如果形式参数类型是参数化类型，则Type返回的Type对象必须准确反映源代码中使用的实际类型参数。

        如果形式参数类型是类型变量或参数化类型，则会创建它。 否则解决。

        重写：
        getGenericParameterTypes在 Executable
        结果
        一个 Type的数组，以声明顺序表示底层可执行文件的形式参数类型
        异常
        GenericSignatureFormatError - 如果通用方法签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果底层可执行文件的任何参数类型是指不存在的类型声明
        MalformedParameterizedTypeException - 如果任何基础可执行文件的参数类型是指由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • getExceptionTypes

        public Class<?>[] getExceptionTypes​()
        返回一个Class对象的数组，表示由该对象表示的底层可执行文件所声明的异常类型。 如果可执行程序在其throws子句中不声明异常，则返回长度为0的数组。
        Specified by:
        getExceptionTypes在 Executable
        结果
        被该对象表示的可执行文件抛出的异常类型

      • getGenericExceptionTypes

        public Type[] getGenericExceptionTypes​()
        返回一个Type对象的数组，表示该可执行对象声明的异常声明。 如果底层可执行文件在其throws子句中声明不存在异常，则返回长度为0的数组。

        如果异常类型是类型变量或参数化类型，则会创建它。 否则解决。

        重写：
        getGenericExceptionTypes在 Executable
        结果
        一组数组，表示底层可执行文件抛出的异常类型
        异常
        GenericSignatureFormatError - 如果通用方法签名不符合 The Java™ Virtual Machine Specification中指定的格式
        TypeNotPresentException - 如果底层可执行文件的 throws子句引用不存在的类型声明
        MalformedParameterizedTypeException - 如果底层可执行文件的 throws子句是指由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5

      • equals

        public boolean equals​(Object obj)
        将此方法与指定对象进行比较。 如果对象相同，则返回true。 两个Methods是相同的，如果它们被同一个类声明并具有相同的名称和形式的参数类型和返回类型。
        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果该对象与obj参数相同; 否则为false 。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回这个方法的哈希方法 。 哈希码被计算为底层方法声明类名称和方法名称的排他或哈希码。
        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回一个描述这个方法的字符串。 该字符串格式化为方法访问修饰符（如果有），后跟方法返回类型，后跟一个空格，后跟类声明方法，后跟一个句点，后跟方括号，后跟一个括号，逗号该方法的形式参数类型的分离列表。 如果该方法抛出检查异常，则参数列表后跟一个空格，后跟“ throws ”，后面是抛出的异常类型的逗号分隔列表。 例如：
          public boolean java.lang.Object.equals(java.lang.Object)

        访问修饰符按照“Java语言规范”指定的规范顺序放置。 这是public ， protected或private以下顺序，然后再其它改性剂： abstract ， default ， static ， final ， synchronized ， native ， strictfp 。

        重写：
        toString在 Object
        结果
        一个描述这个 方法的字符串
        See The Java™ Language Specification:
        8.4.3方法修饰符，9.4方法声明，9.6.1注释类型元素

      • toGenericString

        public String toGenericString​()
        返回描述此方法的字符串，包括类型参数。 该字符串格式化为方法访问修饰符（如果有），后跟一个方括号的类型参数的角括号括号的逗号分隔列表（如果有），后跟方法的通用返回类型，后跟一个空格，后跟类声明该方法后跟一个句点，后跟方法名称，后跟一个括号，逗号分隔的方法的通用形式参数类型列表。 如果该方法被声明为采用可变数量的参数，而不是将最后一个参数表示为“ Type[] ”，则表示为“ Type... ”。 一个空格用于将访问修饰符彼此和类型参数或返回类型分开。 如果没有类型参数，则类型参数列表将被删除; 如果存在类型参数列表，则将列表与类名称隔开。 如果该方法被声明为抛出异常，则参数列表后跟一个空格，后跟“ throws ”，后跟通用抛出的异常类型的逗号分隔列表。

        访问修饰符按照“Java语言规范”指定的规范顺序放置。 这是public ， protected或private以下顺序，然后再其它改性剂： abstract ， default ， static ， final ， synchronized ， native ， strictfp 。

        Specified by:
        toGenericString在类 Executable
        结果
        一个描述这个 方法的字符串，包括类型参数
        从以下版本开始：
        1.5
        See The Java™ Language Specification:
        8.4.3方法修饰符，9.4方法声明，9.6.1注释类型元素

      • invoke

        public Object invoke​(Object obj,
                     Object... args)
              throws IllegalAccessException,
                     IllegalArgumentException,
                     InvocationTargetException
        使用指定的参数调用由此方法对象表示的基础方法。 个别参数自动展开以匹配原始形式参数，原始参考参数和参考参数都需要进行方法调用转换。

        如果底层方法是静态的，那么指定的obj参数将被忽略。 它可能为null。

        如果底层方法所需的形式参数的数量为0，则提供的args数组的长度为0或为空。

        如果底层方法是一个实例方法，它将使用动态方法查找来调用，如“Java语言规范”第二版第15.12.4.4节所述; 特别是将会发生基于目标对象的运行时类型的覆盖。

        如果底层方法是静态的，则如果尚未初始化该方法，那么声明该方法的类将被初始化。

        如果方法正常完成，则返回的值将返回给调用者; 如果值具有原始类型，则首先将其适当地包装在对象中。 但是，如果该值具有基本类型的数组的类型，则该数组的元素不会包含在对象中; 换句话说，返回一个原始类型的数组。 如果底层方法返回类型为void，则调用返回null。

        参数
        obj - 从底层方法被调用的对象
        args - 用于方法调用的参数
        结果
        由该对象表示的方法调用 obj的参数 args
        异常
        IllegalAccessException - 如果这个 方法对象正在强制执行Java语言访问控制，并且底层方法是无法访问的。
        IllegalArgumentException - 如果方法是一个实例方法，并且指定的对象参数不是声明底层方法（或其子类或实现者）的类或接口的实例;
如果实际和正式参数的数量不同;
如果原始参数的解包转换失败;
或者如果在可能的展开之后，通过方法调用转换，参数值不能转换为相应的形式参数类型。
        InvocationTargetException - 如果底层方法抛出异常。
        NullPointerException - 如果指定的对象为空，该方法为实例方法。
        ExceptionInInitializerError - 如果由此方法引发的初始化失败。

      • isBridge

        public boolean isBridge​()
        如果此方法是桥接方法，则返回true ; 否则返回false 。
        结果
        如果且仅当此方法是由Java语言规范定义的桥接方法，则为true。
        从以下版本开始：
        1.5

      • isVarArgs

        public boolean isVarArgs​()
        如果这个可执行文件被声明为采用可变数量的参数，则返回true ; 否则返回false 。
        重写：
        isVarArgs在 Executable
        结果
        true如果只有这个可执行文件被声明为使用可变数量的参数。
        从以下版本开始：
        1.5

      • isSynthetic

        public boolean isSynthetic​()
        如果这个可执行文件是一个合成的结构，返回true ; 否则返回false 。
        Specified by:
        isSynthetic在接口 Member
        重写：
        isSynthetic在 Executable
        结果
        如果且仅当此可执行文件是由 The Java™ Language Specification定义的合成结构， 则为真 。
        从以下版本开始：
        1.5
        See The Java™ Language Specification:
        13.1二进制形式

      • isDefault

        public boolean isDefault​()
        如果此方法是默认方法，则返回true ; 否则返回false 。 默认方法是公共非抽象实例方法，即具有主体的非静态方法，以接口类型声明。
        结果
        如果且仅当此方法是由Java语言规范定义的默认方法，则为true。
        从以下版本开始：
        1.8

      • getDefaultValue

        public Object getDefaultValue​()
        返回由此方法实例表示的注释成员的默认值。 如果成员是原始类型，则返回相应包装器类型的实例。 如果没有默认与成员关联，或者方法实例不表示注释类型的声明成员，则返回null。
        结果
        由该 方法实例表示的注释成员的默认值。
        异常
        TypeNotPresentException - 如果注释是类型Class，并且没有找到默认类值的定义。
        从以下版本开始：
        1.5

      • getAnnotation

        public <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        重写：
        getAnnotation在 Executable
        参数类型
        T - 要查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空
        从以下版本开始：
        1.5

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        重写：
        getDeclaredAnnotations在类 Executable
        结果
        此元素上直接显示的注释
        从以下版本开始：
        1.5

      • getParameterAnnotations

        public Annotation[][] getParameterAnnotations​()
        返回一个Annotation s的数组数组，表示由该对象表示的Executable的形式参数的声明顺序的注释。 合成和强制参数（见下面的说明），如内部类构造函数的外部“this”参数将在返回的数组中表示。 如果可执行文件没有参数（意思是没有正式的，没有合成的，没有强制的参数），那么将返回一个零长度的数组。 如果Executable具有一个或多个参数，则对于没有注释的每个参数，返回长度为零的嵌套数组。 包含在返回的数组中的注释对象是可序列化的。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。 编译器可以添加在源（“强制”）中隐式声明的额外参数，以及在源（“合成”）中既不是隐式也不显式声明方法的参数列表的参数。 有关详细信息，请参阅Parameter 。
        Specified by:
        getParameterAnnotations在 Executable
        结果
        表示由该对象表示的可执行文件的声明顺序的形式和隐式参数上的注释数组
        从以下版本开始：
        1.5
        另请参见：
        Parameter ， Parameter.getAnnotations()

      • getAnnotatedReturnType

        public AnnotatedType getAnnotatedReturnType​()
        返回一个AnnotatedType对象，表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。 如果此Executable对象表示构造函数，则表示构造的对象的类型为AnnotatedType 。 如果这个Executable对象表示一个方法，那么AnnotatedType对象表示使用一个类型来指定方法的返回类型。
        Specified by:
        getAnnotatedReturnType在 Executable
        结果
        表示由该 Executable表示的方法或构造函数的返回类型的对象
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Modifier

  • java.lang.Object
    • java.lang.reflect.Modifier

  • public class Modifier
extends Object
    Modifier类提供了static方法和常量来解码类和成员访问修饰符。 修饰符集合被表示为具有表示不同修饰符的不同位位置的整数。 表示修饰符的常量的值取自第270,443,476和477的第411,4.4,4.5和4.7中的表 。
    从以下版本开始：
    1.1
    另请参见：
    Class.getModifiers() ， Member.getModifiers()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ABSTRACT
      int值代表 abstract修饰符。
      static int FINAL
      int值代表 final修饰符。
      static int INTERFACE
      int值代表 interface修饰符。
      static int NATIVE
      int值代表 native修饰符。
      static int PRIVATE
      int值代表 private修饰符。
      static int PROTECTED
      int值代表 protected修饰符。
      static int PUBLIC
      int代表 public修正值。
      static int STATIC
      int值代表 static修饰符。
      static int STRICT
      int值代表 strictfp修饰符。
      static int SYNCHRONIZED
      int值代表 synchronized修饰符。
      static int TRANSIENT
      int值代表 transient修饰符。
      static int VOLATILE
      int值代表 volatile修饰符。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Modifier​()

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static int classModifiers​()
      返回一个 int值OR-ing可以应用于类的源语言修饰符。
      static int constructorModifiers​()
      返回一个 int值，将可以应用于构造函数的源语言修饰符OR组合在一起。
      static int fieldModifiers​()
      返回一个 int值将可以应用于字段的源语言修饰符OR组合在一起。
      static int interfaceModifiers​()
      返回一个 int值，将可以应用于接口的源语言修饰符OR组合在一起。
      static boolean isAbstract​(int mod)
      返回 true如果整数参数包括 abstract修改， false否则。
      static boolean isFinal​(int mod)
      返回 true如果整数参数包括 final修改， false否则。
      static boolean isInterface​(int mod)
      返回 true如果整数参数包括 interface修改， false否则。
      static boolean isNative​(int mod)
      返回 true如果整数参数包括 native修改， false否则。
      static boolean isPrivate​(int mod)
      返回 true如果整数参数包括 private修改， false否则。
      static boolean isProtected​(int mod)
      返回 true如果整数参数包括 protected修改， false否则。
      static boolean isPublic​(int mod)
      返回 true如果整数参数包括 public修改， false否则。
      static boolean isStatic​(int mod)
      返回 true如果整数参数包括 static修改， false否则。
      static boolean isStrict​(int mod)
      返回 true如果整数参数包括 strictfp修改， false否则。
      static boolean isSynchronized​(int mod)
      返回 true如果整数参数包括 synchronized修改， false否则。
      static boolean isTransient​(int mod)
      返回 true如果整数参数包括 transient修改， false否则。
      static boolean isVolatile​(int mod)
      返回 true如果整数参数包括 volatile修改， false否则。
      static int methodModifiers​()
      返回一个 int值OR- int可以应用于方法的源语言修饰符。
      static int parameterModifiers​()
      返回一个 int值将可以应用于参数的源语言修饰符OR值组合起来。
      static String toString​(int mod)
      返回描述指定修饰符中的访问修饰符标志的字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • PUBLIC

        public static final int PUBLIC
        int值代表 public修饰符。
        另请参见：
        Constant Field Values

      • PRIVATE

        public static final int PRIVATE
        int值代表 private修饰符。
        另请参见：
        Constant Field Values

      • PROTECTED

        public static final int PROTECTED
        int值代表 protected修饰符。
        另请参见：
        Constant Field Values

      • STATIC

        public static final int STATIC
        int值代表 static修饰符。
        另请参见：
        Constant Field Values

      • FINAL

        public static final int FINAL
        int值代表 final修饰符。
        另请参见：
        Constant Field Values

      • SYNCHRONIZED

        public static final int SYNCHRONIZED
        int值代表 synchronized修饰符。
        另请参见：
        Constant Field Values

      • VOLATILE

        public static final int VOLATILE
        int值代表 volatile修正值。
        另请参见：
        Constant Field Values

      • TRANSIENT

        public static final int TRANSIENT
        代表 transient修正值的 int值。
        另请参见：
        Constant Field Values

      • NATIVE

        public static final int NATIVE
        int值代表 native修饰符。
        另请参见：
        Constant Field Values

      • INTERFACE

        public static final int INTERFACE
        代表 interface修正值的 int值。
        另请参见：
        Constant Field Values

      • ABSTRACT

        public static final int ABSTRACT
        int值代表 abstract修饰符。
        另请参见：
        Constant Field Values

      • STRICT

        public static final int STRICT
        int代表 strictfp修正值。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Modifier

        public Modifier​()

    • 方法详细信息

      • isPublic

        public static boolean isPublic​(int mod)
        返回 true如果整数参数包括 public修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含public修饰符; 否则为false 。

      • isPrivate

        public static boolean isPrivate​(int mod)
        返回 true如果整数参数包括 private修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含private修饰符; 否则为false 。

      • isProtected

        public static boolean isProtected​(int mod)
        返回 true如果整数参数包括 protected修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含protected修饰符; 否则为false 。

      • isStatic

        public static boolean isStatic​(int mod)
        返回 true如果整数参数包括 static修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含static修饰符; 否则为false 。

      • isFinal

        public static boolean isFinal​(int mod)
        返回 true如果整数参数包括 final修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含final修饰符; 否则为false 。

      • isSynchronized

        public static boolean isSynchronized​(int mod)
        返回 true如果整数参数包括 synchronized修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含synchronized修饰符; 否则为false 。

      • isVolatile

        public static boolean isVolatile​(int mod)
        返回 true如果整数参数包括 volatile修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含volatile修饰符; false否则。

      • isTransient

        public static boolean isTransient​(int mod)
        返回 true如果整数参数包括 transient修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含transient修饰符; false否则。

      • isNative

        public static boolean isNative​(int mod)
        返回 true如果整数参数包括 native修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含native修饰符; 否则为false 。

      • isInterface

        public static boolean isInterface​(int mod)
        返回 true如果整数参数包括 interface修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含interface修饰符; 否则为false 。

      • isAbstract

        public static boolean isAbstract​(int mod)
        返回 true如果整数参数包括 abstract修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含abstract修饰符; 否则为false 。

      • isStrict

        public static boolean isStrict​(int mod)
        返回 true如果整数参数包括 strictfp修改， false否则。
        参数
        mod - 一组修饰符
        结果
        true如果mod包含strictfp修饰符; 否则为false 。

      • toString

        public static String toString​(int mod)
        返回描述指定修饰符中的访问修饰符标志的字符串。 例如：
            public final synchronized strictfp
        修饰符名称的返回顺序与The Java™ Language Specification第8.1.1,8.3.1,8.4.3,8.8.3和9.1.1节中给出的建议修改者排序一致。 此方法使用的完整修饰符排序是：
        public protected private abstract static final transient volatile synchronized native strictfp interface
        interface讨论的interface修饰符不是Java语言中的真正修饰符，并且在此方法列出的所有其他修饰符之后出现。 此方法可能返回一个不是Java实体的有效修饰符的修饰符字符串; 换句话说，没有检查由输入表示的修饰符的组合的可能的有效性。 请注意，要进行这样的检查已知类型的实体，诸如构造函数或方法，第一AND的参数toString与的方法等适当的掩模constructorModifiers()或methodModifiers() 。
        参数
        mod - 一组修饰符
        结果
        由 mod表示的一组修饰符的字符串表示

      • classModifiers

        public static int classModifiers​()
        返回一个 int值将可以应用于类的源语言修饰符组合起来。
        结果
        一个 int值将可以应用于类的源语言修饰符OR组合在一起。
        从以下版本开始：
        1.7
        See The Java™ Language Specification:
        8.1.1类修饰符

      • interfaceModifiers

        public static int interfaceModifiers​()
        返回一个 int值将OR-ing组合在一起可以应用于接口的源语言修饰符。
        结果
        一个 int值将可以应用于接口的源语言修饰符OR组合在一起。
        从以下版本开始：
        1.7
        See The Java™ Language Specification:
        9.1.1接口修饰符

      • constructorModifiers

        public static int constructorModifiers​()
        返回一个 int值将可以应用于构造函数的源语言修饰符OR组合在一起。
        结果
        一个 int值将源语言修饰符OR组合在一起可以应用于构造函数。
        从以下版本开始：
        1.7
        See The Java™ Language Specification:
        8.8.3构造函数修饰符

      • methodModifiers

        public static int methodModifiers​()
        返回一个 int值OR- int可以应用于方法的源语言修饰符。
        结果
        一个 int值将可以应用于方法的源语言修饰符OR组合在一起。
        从以下版本开始：
        1.7
        See The Java™ Language Specification:
        8.4.3方法修饰符

      • fieldModifiers

        public static int fieldModifiers​()
        返回一个 int值将可以应用于一个字段的源语言修饰符进行 int组合。
        结果
        一个 int价值 int将源语言修饰符组合在一起可以应用于一个字段。
        从以下版本开始：
        1.7
        See The Java™ Language Specification:
        8.3.1字段修饰符

      • parameterModifiers

        public static int parameterModifiers​()
        返回一个 int值将可以应用于参数的源语言修饰符OR值组合在一起。
        结果
        一个 int值将可以应用于参数的源语言修饰符OR组合在一起。
        从以下版本开始：
        1.8
        See The Java™ Language Specification:
        8.4.1 Formal Parameters
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Parameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Parameter

  • java.lang.Object
    • java.lang.reflect.Parameter
  • All Implemented Interfaces:
    AnnotatedElement

    public final class Parameter
extends Object
implements AnnotatedElement
    有关方法参数的信息。 A Parameter提供有关方法参数的信息，包括其名称和修饰符。 它还提供了获取参数属性的替代方法。
    从以下版本开始：
    1.8

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      基于可执行文件和索引进行比较。
      AnnotatedType getAnnotatedType​()
      返回一个AnnotatedType对象，它表示使用一个类型来指定此参数表示的形式参数的类型。
      <T extends Annotation>
      T             		getAnnotation​(Class<T> annotationClass)
      返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
      Annotation[] getAnnotations​()
      返回此元素上 存在的注释。
      <T extends Annotation>
      T[]             		getAnnotationsByType​(Class<T> annotationClass)
      返回与此元素 相关联的注释。
      <T extends Annotation>
      T             		getDeclaredAnnotation​(Class<T> annotationClass)
      如果这样的注释 直接存在 ，则返回指定类型的元素注释，否则返回null。
      Annotation[] getDeclaredAnnotations​()
      返回 直接存在于此元素上的注释。
      <T extends Annotation>
      T[]             		getDeclaredAnnotationsByType​(Class<T> annotationClass)
      如果此类注释 直接存在或 间接存在，则返回该元素的注释（指定类型）。
      Executable getDeclaringExecutable​()
      返回 Executable ，它声明此参数。
      int getModifiers​()
      获取由此 Parameter对象表示的参数的修饰符标志。
      String getName​()
      返回参数的名称。
      Type getParameterizedType​()
      返回一个 Type对象标识参数化的类型由该表示的参数 Parameter对象。
      Class<?> getType​()
      返回一个 Class对象，该对象标识由此 Parameter对象表示的参数的声明类型。
      int hashCode​()
      根据可执行文件的哈希码和索引返回哈希码。
      boolean isImplicit​()
      如果此参数在源代码中隐式声明，则返回true ; 否则返回false 。
      boolean isNamePresent​()
      如果参数具有根据类文件的名称，则返回true; 否则返回false。
      boolean isSynthetic​()
      返回true如果此参数既不在源代码中隐式也不显式声明; 否则返回false 。
      boolean isVarArgs​()
      如果此参数表示可变参数列表，则返回true ; 否则返回false 。
      String toString​()
      返回描述此参数的字符串。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        isAnnotationPresent

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • equals

        public boolean equals​(Object obj)
        基于可执行文件和索引进行比较。
        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        这是否等于论证。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        根据可执行文件的哈希码和索引返回哈希码。
        重写：
        hashCode在 Object
        结果
        基于可执行程序的哈希码的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • isNamePresent

        public boolean isNamePresent​()
        如果参数具有根据类文件的名称，则返回true; 否则返回false。 参数是否具有名称由声明参数的方法的MethodParameters属性决定。
        结果
        如果且仅当参数具有根据类文件的名称，则为true。

      • toString

        public String toString​()
        返回描述此参数的字符串。 格式是The Java™ Language Specification推荐的规范参数（如果有的话）的修饰符，后面是参数的完全限定类型（如果参数是可变的，不包括最后的[]），后跟“...” “如果参数是可变的，后跟一个空格，后跟参数的名称。
        重写：
        toString在类 Object
        结果
        参数和相关信息的字符串表示形式。

      • getDeclaringExecutable

        public Executable getDeclaringExecutable​()
        返回其中声明此参数的 Executable 。
        结果
        Executable声明此参数。

      • getModifiers

        public int getModifiers​()
        获取由此 Parameter对象表示的参数的修饰符标志。
        结果
        该参数的修饰符标志。

      • getName

        public String getName​()
        返回参数的名称。 如果参数的名称为present ，则此方法返回类文件提供的名称。 否则，该方法合成一个形式为argN的名称，其中N是声明参数的方法的描述符中的参数的索引。
        结果
        该参数的名称，由类文件提供，或者如果类文件不提供名称则合成。

      • getParameterizedType

        public Type getParameterizedType​()
        返回一个 Type对象标识参数化的类型由该表示的参数 Parameter对象。
        结果
        标识由此对象表示的参数的参数化类型的 Type对象

      • getType

        public Class<?> getType​()
        返回一个 Class对象，标识由该 Parameter对象表示的参数的声明类型。
        结果
        标识由此对象表示的参数的声明类型的 Class对象

      • getAnnotatedType

        public AnnotatedType getAnnotatedType​()
        返回一个AnnotatedType对象，它表示使用一个类型来指定此参数表示的形式参数的类型。
        结果
        一个 AnnotatedType对象，表示使用一个类型来指定此参数表示的形式参数的类型

      • isImplicit

        public boolean isImplicit​()
        如果此参数在源代码中隐式声明，则返回true ; 否则返回false 。
        结果
        当且仅当该参数被隐含地声明为 The Java™ Language Specification定义 时才为 真 。

      • isSynthetic

        public boolean isSynthetic​()
        返回true如果此参数既不是在源代码中隐式也不显式声明; 否则返回false 。
        结果
        如果且仅当此参数是由 The Java™ Language Specification定义的合成结构， 则为true 。
        See The Java™ Language Specification:
        13.1二进制形式

      • isVarArgs

        public boolean isVarArgs​()
        如果此参数表示可变参数列表，则返回true ; 否则返回false 。
        结果
        true如果只有这个参数表示一个变量参数列表。

      • getAnnotation

        public <T extends Annotation> T getAnnotation​(Class<T> annotationClass)
        返回该元素的，如果这样的注释 ，否则返回null指定类型的注释。
        Specified by:
        getAnnotation在接口 AnnotatedElement
        参数类型
        T - 查询的注释类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        该元素的注释指定的注释类型，如果存在于此元素，否则为null
        异常
        NullPointerException - 如果给定的注释类为空

      • getAnnotationsByType

        public <T extends Annotation> T[] getAnnotationsByType​(Class<T> annotationClass)
        返回与此元素相关联的注释。 如果没有与此元素相关联的注释，则返回值为长度为0.的数组。此方法与AnnotatedElement.getAnnotation(Class)之间的区别在于该方法检测其参数是否是可重复注释类型 （JLS 9.6），如果是，则尝试通过“查看”容器注释来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotationsByType在接口 AnnotatedElement
        参数类型
        T - 要查询的注释的类型，如果存在则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果与此元素相关联，则指定注释类型的所有元素注释，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空

      • getDeclaredAnnotations

        public Annotation[] getDeclaredAnnotations​()
        返回直接存在于此元素上的注释。 此方法忽略继承的注释。 如果此元素上没有直接显示的注释，则返回值为长度为0的数组。此方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotations在接口 AnnotatedElement
        结果
        此元素上直接显示的注释

      • getDeclaredAnnotation

        public <T extends Annotation> T getDeclaredAnnotation​(Class<T> annotationClass)
        说明从界面AnnotatedElement复制
        如果这样的注释直接存在 ，则返回指定类型的元素注释，否则返回null。 此方法忽略继承的注释。 （如果此元素上没有注释，则返回null）
        Specified by:
        getDeclaredAnnotation在接口 AnnotatedElement
        参数类型
        T - 查询的注释类型，如果直接出现则返回
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        如果直接出现在该元素上，则指定注释类型的元素注释，否则为null
        异常
        NullPointerException - 如果给定的注释类为空

      • getDeclaredAnnotationsByType

        public <T extends Annotation> T[] getDeclaredAnnotationsByType​(Class<T> annotationClass)
        说明从界面AnnotatedElement复制
        如果此类注释直接存在或间接存在，则返回该元素的注释（指定类型）。 此方法忽略继承的注释。 如果在该元素上没有直接或间接存在的指定注释，则返回值是长度为0.的数组。此方法与AnnotatedElement.getDeclaredAnnotation(Class)之间的区别在于该方法检测其参数是否是可重复注释类型 （JLS 9.6），以及如果是，尝试通过“查看”容器注释（如果存在）来查找该类型的一个或多个注释。 该方法的调用者可以自由修改返回的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getDeclaredAnnotationsByType在接口 AnnotatedElement
        参数类型
        T - 直接或间接出现的查询和返回的注释类型
        参数
        annotationClass - 对应于注释类型的Class对象
        结果
        指定注释类型的所有这些元素的注释，如果直接或间接地存在于该元素上，否则为长度为零的数组
        异常
        NullPointerException - 如果给定的注释类为空

      • getAnnotations

        public Annotation[] getAnnotations​()
        返回此元素上存在的注释。 如果没有存在于此元素上注解，返回值是长度为0这种方法的调用者可以随意修改返回的数组的数组; 它将对返回给其他调用者的数组没有影响。
        Specified by:
        getAnnotations在接口 AnnotatedElement
        结果
        此元素上出现的注释
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ParameterizedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface ParameterizedType

  • All Superinterfaces:
    Type

    public interface ParameterizedType
extends Type
    ParameterizedType表示一个参数化类型，如Collection <String>。

    参数化类型在第一次通过反射方法需要时创建，如本包所指定的。 当创建参数化类型p时，p实例化的泛型类型声明被解析，并且p的所有类型参数都是递归创建的。 有关类型变量的创建过程的详细信息，请参阅TypeVariable 。 重复创建参数化类型无效。

    实现此接口的类的实例必须实现一个equals（）方法，它将任何两个共享相同泛型类型声明的实例等同于类型参数。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Type[] getActualTypeArguments​()
      返回一个 Type对象的数组，表示此类型的实际类型参数。
      Type getOwnerType​()
      返回一个 Type对象，表示此类型是其成员的类型。
      Type getRawType​()
      返回表示声明此类型的类或接口的 Type对象。

      • Methods inherited from interface java.lang.reflect.Type

        getTypeName

    • 方法详细信息

      • getActualTypeArguments

        Type[] getActualTypeArguments​()
        返回一个Type对象的数组，表示此类型的实际类型参数。

        请注意，在某些情况下，返回的数组为空。 如果此类型表示嵌套在参数化类型中的非参数化类型，则可能会发生这种情况。

        结果
        一个 Type对象的数组，表示此类型的实际类型参数
        异常
        TypeNotPresentException - 如果任何实际的类型参数是指不存在的类型声明
        MalformedParameterizedTypeException - 如果任何实际的类型参数是指由于任何原因而无法实例化的参数化类型
        从以下版本开始：
        1.5

      • getRawType

        Type getRawType​()
        返回表示此类型的类或接口的 Type对象。
        结果
        表示声明此类型的类或接口的 Type对象
        从以下版本开始：
        1.5

      • getOwnerType

        Type getOwnerType​()
        返回表示此类型Type成员的类型的Type对象。 例如，如果该类型是O<T>.I<S> ，返回的表示O<T> 。

        如果此类型是顶级类型，则返回null 。

        结果
        表示此类型Type成员的类型的Type对象。 如果此类型是顶级类型，则返回null
        异常
        TypeNotPresentException - 如果所有者类型引用不存在的类型声明
        MalformedParameterizedTypeException - 如果所有者类型引用了由于任何原因无法实例化的参数化类型
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Proxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class Proxy

  • java.lang.Object
    • java.lang.reflect.Proxy
  • All Implemented Interfaces:
    Serializable

    public class Proxy
extends Object
implements Serializable
    Proxy提供了静态方法来创建类似于接口实例的对象，但允许自定义的方法调用。 要为某个接口创建代理实例Foo ：
       InvocationHandler handler = new MyInvocationHandler(...); Foo f = (Foo) Proxy.newProxyInstance(Foo.class.getClassLoader(), new Class<?>[] { Foo.class }, handler);

    代理类是在运行时创建的实现指定的接口列表（称为代理接口）的类 。 代理实例是代理类的一个实例。 每个代理实例都有一个关联的调用处理程序对象，它实现接口InvocationHandler 。 通过其代理接口之一的代理实例上的方法调用将被分派到实例调用处理程序的invoke方法，传递代理实例，标识调用方法的java.lang.reflect.Method对象以及包含参数的类型为Object的数组。 调用处理程序适当地处理编码方法调用，并且返回的结果将作为方法在代理实例上调用的结果返回。

    代理类具有以下属性：

    • 代理类的不合格名称未指定。 然而，应该为代理类保留以字符串"$Proxy"开头的类名空间。
    • 指定代理类的包和模块指定为below 。
    • 代理类是最终的和非抽象的 。
    • 代理类扩展为java.lang.reflect.Proxy 。
    • 代理类完全按照相同的顺序实现其创建时指定的接口。 调用getInterfaces其上Class对象将返回包含接口的同一列表的阵列（在其创建时指定的顺序），调用getMethods其上Class对象将返回的数组方法对象，其中包括所有的在这些接口的方法，以及调用getMethod将会在代理接口中找到可以预期的方法。
    • 代理类的ProtectionDomain与引导类加载器加载的系统类（例如java.lang.Object ，因为代理类的代码是由可信系统代码生成的。 这个保护域通常会被授予java.security.AllPermission 。
    • 可以使用Proxy.isProxyClass方法来确定给定的类是否是代理类。

    代理实例具有以下属性：

    • 给定代理实例proxy和由其代理类实现的接口Foo ，以下表达式将返回true：
        proxy instanceof Foo
      并且以下的投射操作将会成功（而不是抛出一个ClassCastException ）：
        (Foo) proxy
    • 每个代理实例都有一个关联的调用处理程序，它被传递给它的构造函数。 静态Proxy.getInvocationHandler方法将返回与作为其参数传递的代理实例关联的调用处理程序。
    • 代理实例上的接口方法调用将被编码并分派到调用处理程序的invoke方法，如该方法的文档所述。
    • 的调用hashCode ， equals ，或toString中声明的方法java.lang.Object上的代理实例将被编码并分派到调用处理程序的invoke中相同的方式方法，接口方法调用进行编码和调度，如上所述。 传递给invoke的方法对象的声明类将为java.lang.Object 。 继承自java.lang.Object的代理实例的其他公共方法不会被代理类覆盖，因此这些方法的调用与java.lang.Object实例java.lang.Object 。

    Package and Module Membership of Proxy Class

    选择代理类所属的包和模块，使得代理类的可访问性与代理接口的可访问性一致。 具体来说，通过getProxyClass(ClassLoader, Class[])或newProxyInstance(ClassLoader, Class[], InvocationHandler)方法定义的代理类的包和模块成员资格规定如下：
    1. 如果所有代理接口都在导出或打开的包中：
      1. 如果所有代理接口都是公共的 ，则代理类在由指定的加载程序的unnamed module导出的包中是公共的 。 包的名称未指定。
      2. 如果所有的代理接口的至少一个是非公 ，则代理类是在非公共接口的包和模块的非公开 。 所有非公共接口必须在同一个包和模块中; 否则，代理它们是not possible 。
    2. 如果至少有一个代理接口位于非导出和非打开的包中 ：
      1. 如果所有的代理接口都是公共的 ，那么代理类在非导出的 非开放包中是公开的 ，这个包是dynamic module.。包和模块的名称是未指定的。
      2. 如果所有的代理接口的至少一个是非公 ，则代理类是在非公共接口的包和模块的非公开 。 所有非公共接口必须在同一个包和模块中; 否则，代理它们是not possible 。

    请注意，如果具有可访问性混合的代理接口（例如，导出的公共接口和非导出的非公共接口）由同一实例代理，则代理类的可访问性由最不可访问的代理接口。

    请注意，任意代码可以通过setAccessible获取对开放包中的代理类的访问，而非打开包中的代理类从不可访问代理类的模块之外的代码。

    在本说明书中，“未导出的软件包”是指不导出到所有模块的软件包，“非开放软件包”是指不对所有模块开放的软件包。 具体来说，这些术语是指其包含的模块不是导出/打开的包，或者通过包含模块以合格的方式导出/打开的包。

    Dynamic Modules

    动态模块是在运行时生成的命名模块。 在动态模块中定义的代理类被封装，不能访问任何模块。 在动态模块中的代理类上调用Constructor.newInstance(Object...)将抛出IllegalAccessException ; 应该使用Proxy.newProxyInstance方法。

    动态模块可以读取代理类的所有超级接口的模块以及代理类的所有公共方法签名引用的类型的模块。 如果超级接口或引用类型（例如T ）处于未导出的软件包中，则T的T将更新为将该软件包T到动态模块。

    多代理接口中复制的方法

    当两个或多个代理接口包含具有相同名称和参数签名的方法时，代理类接口的顺序变得很重要。 当在代理实例上调用这种重复方法时 ，传递给调用处理程序的方法对象不一定是其声明类可以通过调用代理方法的接口的引用类型进行分配的对象。 存在此限制，因为生成的代理类中的相应方法实现无法确定其调用的接口。 因此，当在代理实例上调用重复方法时，代理类的接口列表中包含方法（直接或通过超级接口继承）的方法的方法接口的方法对象被传递到调用处理程序的invoke方法，而不管方法调用发生的引用类型。

    如果代理接口包含具有相同的名称和参数签名的方法hashCode ， equals ，或toString的方法java.lang.Object ，当这种方法在代理实例调用时， 方法传递到调用处理程序对象将java.lang.Object作为其申报班 换句话说， java.lang.Object的公共非最终方法逻辑上先于所有的代理接口，以确定哪个方法对象传递给调用处理程序。

    还要注意，当重复方法被分派到调用处理程序，该invoke方法只能抛出可分配到的异常类型的一个检查的异常类型throws方法的条款中所有可调用的代理接口通过。 如果invoke方法抛出一个检查的异常，该异常不能分配给方法在其可以被调用的代理接口之一中声明的任何异常类型，那么在代理实例上的调用将抛出未经检查的UndeclaredThrowableException 。 此限制意味着，并非所有通过调用返回的异常类型的getExceptionTypes的上方法传递给对象invoke方法一定可以成功地抛出invoke方法。

    从以下版本开始：
    1.3
    另请参见：
    InvocationHandler ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected InvocationHandler h
      该代理实例的调用处理程序。

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected Proxy​(InvocationHandler h)
      从具有指定值的子类（通常为动态代理类）构造新的 Proxy实例。

    • 方法摘要

      所有方法 静态方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      static InvocationHandler getInvocationHandler​(Object proxy)
      返回指定代理实例的调用处理程序。
      static Class<?> getProxyClass​(ClassLoader loader, Class<?>... interfaces)
      已过时。
      在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在不可访问的代理类上调用IllegalAccessException 。 使用newProxyInstance(ClassLoader, Class[], InvocationHandler)代替创建一个代理实例。
      static boolean isProxyClass​(Class<?> cl)
      如果给定的类是代理类，则返回true。
      static Object newProxyInstance​(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
      返回指定接口的代理实例，该代理实例将方法调用分派给指定的调用处理程序。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • h

        protected InvocationHandler h
        该代理实例的调用处理程序。

    • 构造方法详细信息

      • Proxy

        protected Proxy​(InvocationHandler h)
        从具有指定值的子类（通常为动态代理类）构造新的 Proxy实例。
        参数
        h - 此代理实例的调用处理程序
        异常
        NullPointerException - 如果给定的调用处理程序， h ，是 null 。

    • 方法详细信息

      • getProxyClass

        @Deprecated
public static Class<?> getProxyClass​(ClassLoader loader,
                                     Class<?>... interfaces)
                              throws IllegalArgumentException
        已过时。 在命名模块中生成的代理类被封装，并且不能访问其模块外的代码。 Constructor.newInstance将在不可访问的代理类上调用时IllegalAccessException 。 使用newProxyInstance(ClassLoader, Class[], InvocationHandler)代替创建一个代理实例。
        给定类加载器和接口数组的代理类的对象为java.lang.Class 。 代理类将由指定的类加载器定义，并将实现所有提供的接口。 如果任何给定的接口是非公开的，则代理类将是非公开的。 如果类加载器已经定义了接口相同置换的代理类，那么将返回现有的代理类; 否则，这些接口的代理类将被动态生成并由类加载器定义。
        参数
        loader - 类加载器来定义代理类
        interfaces - 代理类实现的接口列表
        结果
        在指定的类加载器中定义并实现指定接口的代理类
        异常
        IllegalArgumentException - 如果任何 restrictions的参数被违反
        SecurityException -如果安全管理器，S存在任何下列条件得到满足：
        • 给定的loader是null ，并且调用者的类加载器不是null ，并且调用s.checkPermission与RuntimePermission("getClassLoader")权限被拒绝访问。
        • 对于每个代理接口， intf ，调用者的类加载器与intf的类加载器的祖先不相同，并且调用s.checkPackageAccess()拒绝访问intf 。
        NullPointerException - 如果 interfaces数组参数或其任何元素是 null
        另请参见：
        Package and Module Membership of Proxy Class

      • newProxyInstance

        public static Object newProxyInstance​(ClassLoader loader,
                                      Class<?>[] interfaces,
                                      InvocationHandler h)
        返回指定接口的代理实例，该代理实例将方法调用分派给指定的调用处理程序。

        IllegalArgumentException will be thrown if any of the following restrictions is violated:

        • 给定的interfaces数组中的所有Class对象必须表示接口，而不是类或基本类型。
        • interfaces阵列中没有两个元素可能指向相同的Class对象。
        • 所有接口类型必须通过指定的类加载器的名称可见。 换句话说，对于类加载器cl和每个接口i ，以下表达式必须为真：

          Class.forName(i.getName(), false, cl) == i

        • 指定接口的所有公共方法签名引用的所有类型和由其超级接口继承的所有类型必须通过指定的类加载器的名称可见。
        • 所有非公共接口必须在同一个包和模块中，由指定的类加载器定义，非公共接口的模块可以访问所有接口类型; 否则代理类将不可能实现所有接口，而不管其中定义了什么包。
        • 对于具有相同签名的指定接口的任何成员方法集合：
          • 如果任何方法的返回类型是原始类型或void，则所有方法必须具有相同的返回类型。
          • 否则，其中一个方法必须具有一个返回类型，该类型可以分配给其余方法的所有返回类型。
        • 生成的代理类不能超过虚拟机对类施加的任何限制。 例如，VM可以将类可以实现的接口数量限制为65535; 在这种情况下， interfaces阵列的大小不得超过65535。

        请注意，指定的代理接口的顺序是重要的：具有相同组合的接口但不同顺序的代理类的两个请求将导致两个不同的代理类。

        参数
        loader - 类加载器来定义代理类
        interfaces - 要实现的代理类的接口列表
        h - 调度方法调用的调用处理函数
        结果
        具有由指定的类加载器定义并实现指定接口的代理类的指定调用处理程序的代理实例
        异常
        IllegalArgumentException - 如果任何 restrictions参数被违反
        SecurityException - 如果存在安全管理员s ，并且满足以下任何条件：
        • 给定的loader是null ，并且调用者的类加载器不是null ，并且调用s.checkPermission与RuntimePermission("getClassLoader")权限拒绝访问;
        • 对于每个代理接口， intf ，调用者的类加载器与intf的类加载器的祖先不相同，并且调用s.checkPackageAccess()拒绝访问intf ;
        • 任何给定的代理接口的是非公和呼叫者类是不在同一runtime package作为本次非公开接口的调用s.checkPermission与ReflectPermission("newProxyInPackage.{package name}")权限拒绝访问。
        NullPointerException - 如果 interfaces数组参数或其任何元素为 null ，或者如果调用处理程序（ h ）为 null
        另请参见：
        Package and Module Membership of Proxy Class

      • isProxyClass

        public static boolean isProxyClass​(Class<?> cl)
        如果给定的类是代理类，则返回true。
        Implementation Note:
        这种方法的可靠性对于使用它来做出安全决策的能力很重要，所以它的实现不应该只是测试所讨论的类是否扩展了 Proxy 。
        参数
        cl - 要测试的班级
        结果
        true如果该类是代理类，否则为 false
        异常
        NullPointerException - 如果 cl是 null

      • getInvocationHandler

        public static InvocationHandler getInvocationHandler​(Object proxy)
                                              throws IllegalArgumentException
        返回指定代理实例的调用处理程序。
        参数
        proxy - 用于返回调用处理程序的代理实例
        结果
        代理实例的调用处理程序
        异常
        IllegalArgumentException - 如果参数不是代理实例
        SecurityException - if a security manager, s, is present and the caller's class loader is not the same as or an ancestor of the class loader for the invocation handler and invocation of s.checkPackageAccess() denies access to the invocation handler's class.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ReflectPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class ReflectPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.lang.reflect.ReflectPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class ReflectPermission
extends BasicPermission
    反思操作的权限类。

    下表提供了许可允许的简要说明，并讨论了授予代码许可的风险。

    Table shows permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission suppressAccessChecks ability to suppress the standard Java language access checks on fields and methods in a class; allow access not only public members but also allow access to default (package) access, protected, and private members. This is dangerous in that information (possibly confidential) and methods normally unavailable would be accessible to malicious code. newProxyInPackage.{package name} ability to create a proxy instance in the specified package of which the non-public interface that the proxy class implements. This gives code access to classes in packages to which it normally does not have access and the dynamic proxy class is in the system protection domain. Malicious code may use these classes to help in its attempt to compromise security in the system.
    从以下版本开始：
    1.2
    另请参见：
    Permission ， BasicPermission ， AccessibleObject ， Field.get(java.lang.Object) ， Field.set(java.lang.Object, java.lang.Object) ， Method.invoke(java.lang.Object, java.lang.Object...) ， Constructor.newInstance(java.lang.Object...) ， Proxy.newProxyInstance(java.lang.ClassLoader, java.lang.Class<?>[], java.lang.reflect.InvocationHandler) ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ReflectPermission​(String name)
      构造具有指定名称的ReflectPermission。
      ReflectPermission​(String name, String actions)
      构造具有指定名称和操作的ReflectPermission。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • ReflectPermission

        public ReflectPermission​(String name)
        构造具有指定名称的ReflectPermission。
        参数
        name - ReflectPermission的名称
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • ReflectPermission

        public ReflectPermission​(String name,
                         String actions)
        构造具有指定名称和操作的ReflectPermission。 行动应为空; 他们被忽视。
        参数
        name - ReflectPermission的名称
        actions - 应为null
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface Type

  • All Known Subinterfaces:
    GenericArrayType ， ParameterizedType ， TypeVariable<D> ， WildcardType
    所有已知实现类：
    Class

    public interface Type
    Type是Java编程语言中所有类型的通用超级接口。 这些包括原始类型，参数化类型，数组类型，类型变量和原始类型。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 Default Methods
      Modifier and Type 方法 描述
      default String getTypeName​()
      返回描述此类型的字符串，包括有关任何类型参数的信息。

    • 方法详细信息

      • getTypeName

        default String getTypeName​()
        返回描述此类型的字符串，包括有关任何类型参数的信息。
        实现要求：
        默认实现调用 toString 。
        结果
        描述这种类型的字符串
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


TypeVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface TypeVariable<D extends GenericDeclaration>

  • 参数类型
    D - 声明底层类型变量的通用声明的类型。
    All Superinterfaces:
    AnnotatedElement ， Type

    public interface TypeVariable<D extends GenericDeclaration>
extends Type, AnnotatedElement
    TypeVariable是类型变量的常用超级接口。 类型变量首次通过反射方法创建，如本包所指定的那样。 如果类型变量t被类型（即类，接口或注释类型）T引用，T由第N个包围类T（参见JLS 8.1.2）声明，则t的创建需要分辨率（参见JVMS 5），对于i = 0到n，包括第i个包围类别。 创建类型变量不能导致创建其边界。 重复创建类型变量没有任何效果。

    可以在运行时实例化多个对象来表示给定的类型变量。 即使只创建一个类型变量一次，这并不意味着缓存表示类型变量的实例的任何要求。 但是，表示类型变量的所有实例必须彼此相等（）。 因此，类型变量的用户不能依赖于实现此接口的类的实例的身份。

    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      AnnotatedType[] getAnnotatedBounds​()
      返回一个AnnotatedType对象的数组，表示使用类型来表示此TypeVariable表示的类型参数的上限。
      Type[] getBounds​()
      返回表示此类型变量的上限的 Type对象的数组。
      D getGenericDeclaration​()
      返回表示此类型变量的通用声明的 GenericDeclaration对象。
      String getName​()
      返回此类型变量的名称，因为它在源代码中出现。

      • Methods inherited from interface java.lang.reflect.AnnotatedElement

        getAnnotation, getAnnotations, getAnnotationsByType, getDeclaredAnnotation, getDeclaredAnnotations, getDeclaredAnnotationsByType, isAnnotationPresent

      • Methods inherited from interface java.lang.reflect.Type

        getTypeName

    • 方法详细信息

      • getBounds

        Type[] getBounds​()
        返回表示此类型变量的上限的Type对象的数组。 如果没有明确声明上限，则上限为Object 。

        对于每个上限B：

        • 如果B是参数化类型或类型变量，则创建它（有关参数化类型的创建过程的详细信息，请参阅ParameterizedType ）。
        • 否则，B被解决。
        结果
        表示此类型变量的上限的 Type s的数组
        异常
        TypeNotPresentException - 如果任何边界引用不存在的类型声明
        MalformedParameterizedTypeException - 如果有任何一个界限指的是由于任何原因无法实例化的参数化类型

      • getGenericDeclaration

        D getGenericDeclaration​()
        返回表示此类型变量的通用声明的 GenericDeclaration对象。
        结果
        为此类型变量声明的通用声明。
        从以下版本开始：
        1.5

      • getName

        String getName​()
        返回此类型变量的名称，因为它在源代码中出现。
        结果
        该类型变量的名称，如它在源代码中所显示的

      • getAnnotatedBounds

        AnnotatedType[] getAnnotatedBounds​()
        返回一个AnnotatedType对象的数组，表示使用类型来表示此TypeVariable表示的类型参数的上限。 数组中的对象的顺序对应于type参数的声明中的边界的顺序。 请注意，如果没有明确声明上限，则上限为未注释Object 。
        结果
        表示类型变量的上限的一组对象
        从以下版本开始：
        1.8
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UndeclaredThrowableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Class UndeclaredThrowableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.reflect.UndeclaredThrowableException
  • All Implemented Interfaces:
    Serializable

    public class UndeclaredThrowableException
extends RuntimeException
    如果调用处理程序的invoke方法抛出一个检查异常（不能分配给RuntimeException或Error ）的异常（ Throwable ，不能分配给RuntimeException或Error ），则在代理实例上的方法调用时抛出，该异常不能分配给方法的throws子句中声明的任何异常类型在代理实例上调用并分派到调用处理程序。

    一个UndeclaredThrowableException实例包含调用处理程序抛出的未声明的检查异常，并且可以使用getUndeclaredThrowable()方法检索。 UndeclaredThrowableException扩展了RuntimeException ，所以它是一个未经检查的异常，包装一个被检查的异常。

    从版本1.4开始，这种异常已被改进以符合通用异常链接机制。 可以在构建时提供并通过getUndeclaredThrowable()方法访问的“由调用处理程序抛出的未声明的检查异常”现在被称为原因 ，并且可以通过Throwable.getCause()方法以及上述“传统方法“。

    从以下版本开始：
    1.3
    另请参见：
    InvocationHandler ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UndeclaredThrowableException​(Throwable undeclaredThrowable)
      构造一个 UndeclaredThrowableException与指定的 Throwable 。
      UndeclaredThrowableException​(Throwable undeclaredThrowable, String s)
      构造一个 UndeclaredThrowableException具有指定 Throwable和详细消息。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Throwable getCause​()
      返回此异常的原因（ Throwable实例包装在此 UndeclaredThrowableException ，可能是 null ）。
      Throwable getUndeclaredThrowable​()
      返回包含在这个 UndeclaredThrowableException中的 Throwable实例，可能是 null 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UndeclaredThrowableException

        public UndeclaredThrowableException​(Throwable undeclaredThrowable)
        构造一个 UndeclaredThrowableException与指定的 Throwable 。
        参数
        undeclaredThrowable - 抛出的未声明的检查异常

      • UndeclaredThrowableException

        public UndeclaredThrowableException​(Throwable undeclaredThrowable,
                                    String s)
        构造一个 UndeclaredThrowableException具有指定 Throwable和详细消息。
        参数
        undeclaredThrowable - 抛出的未声明的检查异常
        s - 详细信息

    • 方法详细信息

      • getUndeclaredThrowable

        public Throwable getUndeclaredThrowable​()
        返回Throwable实例包裹在这个UndeclaredThrowableException ，可能是null 。

        这种方法早于通用异常链接工具。 Throwable.getCause()方法现在是获取此信息的首选方法。

        结果
        未被声明的已检出的异常被抛出

      • getCause

        public Throwable getCause​()
        返回此异常的原因（ Throwable包含的 UndeclaredThrowableException可能为 null ）。
        重写：
        getCause在 Throwable
        结果
        这个例外的原因。
        从以下版本开始：
        1.4
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.lang.reflect (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.lang.reflect

  • Packages that use java.lang.reflect
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。
  • Classes in java.lang.reflect used by java.awt
    Class 描述
    InvocationTargetException
    InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
  • Classes in java.lang.reflect used by java.beans
    Class 描述
    InvocationHandler
    InvocationHandler是由代理实例的 调用处理程序实现的接口。
    方法
    A 方法提供有关类和接口上单个方法的信息和访问权限。
  • Classes in java.lang.reflect used by java.lang
    Class 描述
    AnnotatedElement
    表示当前在此VM中运行的程序的注释元素。
    AnnotatedType
    AnnotatedType表示当前在此VM中运行的程序中可能注释的类型的使用。
    Constructor
    Constructor提供了一个类的单个构造函数的信息和访问权限。
    Field
    A Field提供有关类或接口的单个字段的信息和动态访问。
    GenericDeclaration
    声明类型变量的所有实体的通用接口。
    方法
    A 方法在类或接口上提供有关单一方法的信息和访问权限。
    Type
    Type是Java编程语言中所有类型的通用超级接口。
    TypeVariable
    TypeVariable是类型变量的常用超级接口。
  • Classes in java.lang.reflect used by java.lang.annotation
    Class 描述
    方法
    A 方法提供有关类和接口上单个方法的信息和访问。
  • Classes in java.lang.reflect used by java.lang.invoke
    Class 描述
    Constructor
    Constructor提供了一个类的单个构造函数的信息和访问。
    Field
    A Field提供有关类或接口的单个字段的信息和动态访问。
    Member
    Member是一个反映关于单个成员（字段或方法）或构造函数的标识信息的接口。
    方法
    A 方法在类或接口上提供有关单一方法的信息和访问权限。
  • Classes in java.lang.reflect used by java.lang.reflect
    Class 描述
    AccessibleObject
    所述 AccessibleObject类是基础类 Field ， 方法 ，和 Constructor对象（被称为 反射的对象 ）。
    AnnotatedElement
    表示当前在此VM中运行的程序的注释元素。
    AnnotatedType
    AnnotatedType表示当前在此VM中运行的程序中可能注释的类型使用。
    Constructor
    Constructor提供了一个类的单个构造函数的信息和访问权限。
    Executable
    方法和Constructor的共同功能的共享超类。
    GenericDeclaration
    声明类型变量的所有实体的通用接口。
    InvocationHandler
    InvocationHandler是由代理实例的 调用处理程序实现的接口。
    InvocationTargetException
    InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
    Member
    Member是一个反映关于单个成员（字段或方法）或构造函数的标识信息的接口。
    方法
    A 方法提供有关类和接口上单个方法的信息和访问权限。
    Parameter
    有关方法参数的信息。
    Type
    Type是Java编程语言中所有类型的通用超级接口。
    TypeVariable
    TypeVariable是类型变量的常用超级接口。
  • Classes in java.lang.reflect used by java.rmi.server
    Class 描述
    InvocationHandler
    InvocationHandler是由代理实例的 调用处理程序实现的接口。
    方法
    A 方法在类或接口上提供有关单一方法的信息和访问权限。
  • Classes in java.lang.reflect used by javafx.beans.property.adapter
    Class 描述
    方法
    A 方法提供有关类和接口上单个方法的信息和访问。
  • Classes in java.lang.reflect used by javax.management
    Class 描述
    Constructor
    Constructor提供了一个类的单个构造函数的信息和访问。
    InvocationHandler
    InvocationHandler是由代理实例的 调用处理程序实现的接口。
    方法
    A 方法在类或接口上提供有关单一方法的信息和访问权限。
  • Classes in java.lang.reflect used by javax.management.modelmbean
    Class 描述
    Constructor
    Constructor提供了一个类的单个构造函数的信息和访问权限。
    方法
    A 方法在类或接口上提供有关单一方法的信息和访问权限。
  • Classes in java.lang.reflect used by javax.management.openmbean
    Class 描述
    InvocationHandler
    InvocationHandler是由代理实例的 调用处理程序实现的接口。
    方法
    A 方法提供有关类和接口上单个方法的信息和访问。
  • Classes in java.lang.reflect used by javax.sql.rowset.serial
    Class 描述
    Field
    A Field提供有关类或接口的单个字段的信息和动态访问。
  • Classes in java.lang.reflect used by javax.swing
    Class 描述
    InvocationTargetException
    InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
  • Classes in java.lang.reflect used by javax.xml.ws.spi
    Class 描述
    InvocationTargetException
    InvocationTargetException是一个检查的异常，它包装被调用的方法或构造函数抛出的异常。
    方法
    A 方法提供有关类和接口上单个方法的信息和访问。
  • Classes in java.lang.reflect used by jdk.dynalink.linker.support
    Class 描述
    Constructor
    Constructor提供了一个类的单个构造函数的信息和访问权限。
    Field
    A Field提供有关类或接口的单个字段的信息和动态访问。
    方法
    A 方法提供有关类和接口上单一方法的信息和访问权限。
  • Classes in java.lang.reflect used by jdk.jshell.execution
    Class 描述
    方法
    A 方法提供有关类和接口上单个方法的信息和访问权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


WildcardType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.lang.reflect

Interface WildcardType

  • All Superinterfaces:
    Type

    public interface WildcardType
extends Type
    WildcardType表示一个通配符型表达，如 ? ， ? extends Number ，或 ? super Integer 。
    从以下版本开始：
    1.5

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Type[] getLowerBounds​()
      返回一个 Type对象的数组，表示此类型变量的下限。
      Type[] getUpperBounds​()
      返回表示此类型变量的上限的 Type对象的数组。

      • Methods inherited from interface java.lang.reflect.Type

        getTypeName

    • 方法详细信息

      • getUpperBounds

        Type[] getUpperBounds​()
        返回表示此类型变量的上限的Type对象的数组。 如果没有明确声明上限，则上限为Object 。

        对于每个上限B：

        • 如果B是参数化类型或类型变量，则创建它（有关参数化类型的创建过程的详细信息，请参阅ParameterizedType ）。
        • 否则，B被解决。
        结果
        一个表示此类型变量的上限的类型数组
        异常
        TypeNotPresentException - 如果有任何边界引用不存在的类型声明
        MalformedParameterizedTypeException - 如果有任何一个界限是指由于任何原因而无法实例化的参数化类型

      • getLowerBounds

        Type[] getLowerBounds​()
        返回表示此类型变量下限的Type对象的数组。 如果没有明确声明下限，则下限为null的类型。 在这种情况下，返回零长度数组。

        对于每个下限B：

        • 如果B是参数化类型或类型变量，则创建它（参见ParameterizedType有关参数化类型的创建过程的详细信息）。
        • 否则，B被解决。
        结果
        表示此类型变量的下限的类型数组
        异常
        TypeNotPresentException - 如果有任何边界引用不存在的类型声明
        MalformedParameterizedTypeException - if any of the bounds refer to a parameterized type that cannot be instantiated for any reason
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.AccessibleObject (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.AccessibleObject

  • Packages that use AccessibleObject
    软件包 描述
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of AccessibleObject in java.lang.reflect

      Subclasses of AccessibleObject in java.lang.reflect
      Modifier and Type Class 描述
      class  Constructor<T>
      Constructor提供了关于一个类的单个构造函数的信息和访问。
      class  Executable
      方法和Constructor的共同功能的共享超类。
      class  Field
      A Field提供有关类或接口的单个字段的信息和动态访问。
      class  方法
      A 方法提供有关类和接口上单个方法的信息和访问权限。
      Methods in java.lang.reflect with parameters of type AccessibleObject
      Modifier and Type 方法 描述
      static void AccessibleObject.setAccessible​(AccessibleObject[] array, boolean flag)
      为方便的方法设置 accessible标志的反射对象的数组与一个单一的安全检查（效率）。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Array (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Array

No usage of java.lang.reflect.Array
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Constructor (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Constructor

  • Packages that use Constructor
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。

    • Uses of Constructor in java.lang

      Methods in java.lang that return Constructor
      Modifier and Type 方法 描述
      Constructor<T> Class.getConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由该 Class对象表示的类的指定公共构造函数。
      Constructor<?>[] Class.getConstructors​()
      返回一个包含 Constructor对象的数组， Constructor对象反映由该 Class对象表示的类的所有公共构造函数。
      Constructor<T> Class.getDeclaredConstructor​(Class<?>... parameterTypes)
      返回一个 Constructor对象，该对象反映由该 Class对象表示的类或接口的指定构造函数。
      Constructor<?>[] Class.getDeclaredConstructors​()
      返回一个 Constructor对象的数组，反映由该 Class对象表示的类声明的所有构造函数。
      Constructor<?> Class.getEnclosingConstructor​()
      如果此Class对象表示构造函数中的本地或匿名类，则返回表示基础类的直接包含构造函数的Constructor对象。

    • Uses of Constructor in java.lang.invoke

      Methods in java.lang.invoke with parameters of type Constructor
      Modifier and Type 方法 描述
      MethodHandle MethodHandles.Lookup.unreflectConstructor​(Constructor<?> c)
      为反射的构造函数生成方法句柄。

    • Uses of Constructor in java.lang.reflect

      Methods in java.lang.reflect that return types with arguments of type Constructor
      Modifier and Type 方法 描述
      TypeVariable<Constructor<T>>[] Constructor.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

    • Uses of Constructor in javax.management

      Constructors in javax.management with parameters of type Constructor
      Constructor 描述
      MBeanConstructorInfo​(String description, Constructor<?> constructor)
      构造一个 MBeanConstructorInfo对象。

    • Uses of Constructor in javax.management.modelmbean

      Constructors in javax.management.modelmbean with parameters of type Constructor
      Constructor 描述
      ModelMBeanConstructorInfo​(String description, Constructor<?> constructorMethod)
      使用默认描述符构造一个ModelMBeanConstructorInfo对象。
      ModelMBeanConstructorInfo​(String description, Constructor<?> constructorMethod, Descriptor descriptor)
      构造一个ModelMBeanConstructorInfo对象。

    • Uses of Constructor in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support with parameters of type Constructor
      Modifier and Type 方法 描述
      static MethodHandle Lookup.unreflectConstructor​(MethodHandles.Lookup lookup, Constructor<?> c)
      执行MethodHandles.Lookup.unreflectConstructor(Constructor) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      MethodHandle Lookup.unreflectConstructor​(Constructor<?> c)
      执行一个MethodHandles.Lookup.unreflectConstructor(Constructor) ，将任何遇到的IllegalAccessException转换成IllegalAccessError 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Executable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Executable

  • Packages that use Executable
    软件包 描述
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of Executable in java.lang.reflect

      Subclasses of Executable in java.lang.reflect
      Modifier and Type Class 描述
      class  Constructor<T>
      Constructor提供了一个类的单个构造函数的信息和访问权限。
      class  方法
      A 方法提供有关类和接口上单个方法的信息和访问。
      Methods in java.lang.reflect that return Executable
      Modifier and Type 方法 描述
      Executable Parameter.getDeclaringExecutable​()
      返回其中声明此参数的 Executable 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Field (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Field

  • Packages that use Field
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。

    • Uses of Field in java.lang

      Methods in java.lang that return Field
      Modifier and Type 方法 描述
      Field Class.getDeclaredField​(String name)
      返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定声明字段。
      Field[] Class.getDeclaredFields​()
      返回一个 Field对象的数组，反映由该 Class对象表示的类或接口声明的所有字段。
      Field Class.getField​(String name)
      返回一个 Field对象，该对象反映由该 Class对象表示的类或接口的指定公共成员字段。
      Field[] Class.getFields​()
      返回一个包含 Field对象的数组， Field对象反映由该 Class对象表示的类或接口的所有可访问的公共字段。

    • Uses of Field in java.lang.invoke

      Methods in java.lang.invoke with parameters of type Field
      Modifier and Type 方法 描述
      MethodHandle MethodHandles.Lookup.unreflectGetter​(Field f)
      产生方法句柄，给予反映字段的读访问权限。
      MethodHandle MethodHandles.Lookup.unreflectSetter​(Field f)
      产生一个方法句柄，给一个反射的字段写权限。
      VarHandle MethodHandles.Lookup.unreflectVarHandle​(Field f)
      产生一个VarHandle，可访问 f类中声明的类型为 T的反射字段 R 。

    • Uses of Field in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return Field
      Modifier and Type 方法 描述
      Field[] SerialJavaObject.getFields​()
      返回一个包含 Field对象的数组，其中包含该辅助类序列化的对象的每个字段。

    • Uses of Field in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support with parameters of type Field
      Modifier and Type 方法 描述
      MethodHandle Lookup.unreflectGetter​(Field f)
      执行MethodHandles.Lookup.unreflectGetter(Field) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
      MethodHandle Lookup.unreflectSetter​(Field f)
      执行MethodHandles.Lookup.unreflectSetter(Field) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.GenericSignatureFormatError (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.GenericSignatureFormatError

No usage of java.lang.reflect.GenericSignatureFormatError
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.InaccessibleObjectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.InaccessibleObjectException

No usage of java.lang.reflect.InaccessibleObjectException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.InvocationTargetException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.InvocationTargetException

  • Packages that use InvocationTargetException
    软件包 描述
    java.awt
    包含用于创建用户界面和绘制图形和图像的所有类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    javax.swing
    提供一套“轻量级”（全Java语言）组件，尽可能地在所有平台上工作。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。

    • Uses of InvocationTargetException in java.awt

      Methods in java.awt that throw InvocationTargetException
      Modifier and Type 方法 描述
      static void EventQueue.invokeAndWait​(Runnable runnable)
      导致 runnable在 dispatch thread的 dispatch thread中调用其 run方法。

    • Uses of InvocationTargetException in java.lang.reflect

      Methods in java.lang.reflect that throw InvocationTargetException
      Modifier and Type 方法 描述
      Object Method.invoke​(Object obj, Object... args)
      在具有指定参数的指定对象上调用此 方法对象表示的底层方法。
      T Constructor.newInstance​(Object... initargs)
      使用由此 Constructor对象表示的构造函数，使用指定的初始化参数来创建和初始化构造函数的声明类的新实例。

    • Uses of InvocationTargetException in javax.swing

      Methods in javax.swing that throw InvocationTargetException
      Modifier and Type 方法 描述
      static void SwingUtilities.invokeAndWait​(Runnable doRun)
      导致在AWT事件调度线程上同步执行 doRun.run() 。

    • Uses of InvocationTargetException in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that throw InvocationTargetException
      Modifier and Type 方法 描述
      abstract void Invoker.inject​(WebServiceContext webServiceContext)
      JAX-WS运行时调用此方法来请求容器在端点实例上注入WebServiceContext。
      abstract Object Invoker.invoke​(方法 m, Object... args)
      JAX-WS运行时调用此方法来对端点实例执行实际的Web服务调用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.MalformedParameterizedTypeException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.MalformedParameterizedTypeException

No usage of java.lang.reflect.MalformedParameterizedTypeException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.MalformedParametersException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.MalformedParametersException

No usage of java.lang.reflect.MalformedParametersException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Method (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Method

  • Packages that use 方法
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.annotation
    为Java编程语言注释工具提供库支持。
    java.lang.invoke
    java.lang.invoke包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javafx.beans.property.adapter
    提供各种类，作为常规Java Bean属性和对应的JavaFX Property之间的适配器。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.modelmbean
    提供ModelMBean类的定义。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.xml.ws.spi
    此套件为JAX-WS定义了SPI。
    jdk.dynalink.linker.support
    包含课程，使语言运行时更方便地实现自己的特定于语言的对象模型，并通过提供一些类的基本实现以及各种实用程序来类型转换。
    jdk.jshell.execution
    提供构建JShell执行引擎的实现支持。

    • Uses of 方法 in java.beans

      Methods in java.beans that return 方法
      Modifier and Type 方法 描述
      方法 EventSetDescriptor.getAddListenerMethod​()
      获取用于添加事件侦听器的方法。
      方法 EventSetDescriptor.getGetListenerMethod​()
      获取用于访问已注册事件侦听器的方法。
      方法 IndexedPropertyDescriptor.getIndexedReadMethod​()
      获取应用于读取索引属性值的方法。
      方法 IndexedPropertyDescriptor.getIndexedWriteMethod​()
      获取应用于编写索引属性值的方法。
      方法[] EventSetDescriptor.getListenerMethods​()
      获取目标侦听器接口的方法。
      方法 MethodDescriptor.getMethod​()
      获取此MethodDescriptor封装的方法。
      方法 PropertyDescriptor.getReadMethod​()
      获取应该用于读取属性值的方法。
      方法 EventSetDescriptor.getRemoveListenerMethod​()
      获取用于删除事件侦听器的方法。
      方法 PropertyDescriptor.getWriteMethod​()
      获取应用于写入属性值的方法。
      Methods in java.beans with parameters of type 方法
      Modifier and Type 方法 描述
      Object EventHandler.invoke​(Object proxy, 方法 method, Object[] arguments)
      从事件中提取适当的属性值，并将其传递到与此 EventHandler相关联的操作。
      void IndexedPropertyDescriptor.setIndexedReadMethod​(方法 readMethod)
      设置应用于读取索引属性值的方法。
      void IndexedPropertyDescriptor.setIndexedWriteMethod​(方法 writeMethod)
      设置应用于编写索引属性值的方法。
      void PropertyDescriptor.setReadMethod​(方法 readMethod)
      设置应用于读取属性值的方法。
      void PropertyDescriptor.setWriteMethod​(方法 writeMethod)
      设置应用于写入属性值的方法。
      Constructors in java.beans with parameters of type 方法
      Constructor 描述
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, 方法 addListenerMethod, 方法 removeListenerMethod)
      使用 java.lang.reflect.MethodDescriptor和 java.lang.Class对象从头创建一个 EventSetDescriptor 。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod)
      创建一个 EventSetDescriptor使用从无到有 java.lang.reflect.Method个 java.lang.Class对象。
      EventSetDescriptor​(String eventSetName, Class<?> listenerType, 方法[] listenerMethods, 方法 addListenerMethod, 方法 removeListenerMethod, 方法 getListenerMethod)
      此构造函数从头开始使用java.lang.reflect.Method和java.lang.Class对象创建一个EventSetDescriptor。
      IndexedPropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod, 方法 indexedReadMethod, 方法 indexedWriteMethod)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
      MethodDescriptor​(方法 method)
      构造一个 MethodDescriptor从 方法 。
      MethodDescriptor​(方法 method, ParameterDescriptor[] parameterDescriptors)
      从 方法构造一个 MethodDescriptor ，为每个方法的参数提供描述性信息。
      PropertyDescriptor​(String propertyName, 方法 readMethod, 方法 writeMethod)
      此构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。

    • Uses of 方法 in java.lang

      Methods in java.lang that return 方法
      Modifier and Type 方法 描述
      方法 Class.getDeclaredMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，该对象反映由该 Class对象表示的类或接口的指定声明方法。
      方法[] Class.getDeclaredMethods​()
      返回一个包含 方法对象的数组， 方法对象反映由此 Class对象表示的类或接口的所有声明方法，包括public，protected，default（package）访问和私有方法，但不包括继承方法。
      方法 Class.getEnclosingMethod​()
      如果此Class对象表示方法中的本地或匿名类，则返回表示基础类的即时封闭方法的方法对象。
      方法 Class.getMethod​(String name, Class<?>... parameterTypes)
      返回一个 方法对象，该对象反映由该 Class对象表示的类或接口的指定公共成员方法。
      方法[] Class.getMethods​()
      返回一个包含 方法对象的数组， 方法对象反映由该 Class对象表示的类或接口的所有公共方法，包括由类或接口声明的以及从超类和超级接口继承的类。

    • Uses of 方法 in java.lang.annotation

      Methods in java.lang.annotation that return 方法
      Modifier and Type 方法 描述
      方法 AnnotationTypeMismatchException.element​()
      返回错误类型元素的 方法对象。
      Constructors in java.lang.annotation with parameters of type 方法
      Constructor 描述
      AnnotationTypeMismatchException​(方法 element, String foundType)
      为指定的注释类型元素构造AnnotationTypeMismatchException，并找到数据类型。

    • Uses of 方法 in java.lang.invoke

      Methods in java.lang.invoke with parameters of type 方法
      Modifier and Type 方法 描述
      MethodHandle MethodHandles.Lookup.unreflect​(方法 m)
      做一个 direct method handle到 m ，如果查找类有权限。
      MethodHandle MethodHandles.Lookup.unreflectSpecial​(方法 m, Class<?> specialCaller)
      为反映的方法生成方法句柄。

    • Uses of 方法 in java.lang.reflect

      Methods in java.lang.reflect that return types with arguments of type 方法
      Modifier and Type 方法 描述
      TypeVariable<方法>[] Method.getTypeParameters​()
      返回一个 TypeVariable对象的数组，表示由该 GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。
      Methods in java.lang.reflect with parameters of type 方法
      Modifier and Type 方法 描述
      Object InvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)
      处理代理实例上的方法调用并返回结果。

    • Uses of 方法 in java.rmi.server

      Methods in java.rmi.server with parameters of type 方法
      Modifier and Type 方法 描述
      Object RemoteObjectInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)
      处理封装代理实例 proxy上的方法调用，并返回结果。
      Object RemoteRef.invoke​(Remote obj, 方法 method, Object[] params, long opnum)
      调用方法。

    • Uses of 方法 in javafx.beans.property.adapter

      Methods in javafx.beans.property.adapter with parameters of type 方法
      Modifier and Type 方法 描述
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanBooleanPropertyBuilder ReadOnlyJavaBeanBooleanPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanDoublePropertyBuilder ReadOnlyJavaBeanDoublePropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanFloatPropertyBuilder ReadOnlyJavaBeanFloatPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanIntegerPropertyBuilder ReadOnlyJavaBeanIntegerPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanLongPropertyBuilder ReadOnlyJavaBeanLongPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanObjectPropertyBuilder<T> ReadOnlyJavaBeanObjectPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      ReadOnlyJavaBeanStringPropertyBuilder ReadOnlyJavaBeanStringPropertyBuilder.getter​(方法 getter)
      直接设置getter方法。
      JavaBeanBooleanPropertyBuilder JavaBeanBooleanPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanDoublePropertyBuilder JavaBeanDoublePropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanFloatPropertyBuilder JavaBeanFloatPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanIntegerPropertyBuilder JavaBeanIntegerPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanLongPropertyBuilder JavaBeanLongPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanObjectPropertyBuilder JavaBeanObjectPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。
      JavaBeanStringPropertyBuilder JavaBeanStringPropertyBuilder.setter​(方法 setter)
      直接设置setter方法。

    • Uses of 方法 in javax.management

      Methods in javax.management with parameters of type 方法
      Modifier and Type | 方法 | 描述
      Object | MBeanServerInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)
      Constructors in javax.management with parameters of type 方法
      Constructor 描述
      MBeanAttributeInfo​(String name, String description, 方法 getter, 方法 setter)
      该构造函数使用简单属性的名称，以及用于读取和写入属性的Method对象。
      MBeanOperationInfo​(String description, 方法 method)
      构造一个 MBeanOperationInfo对象。

    • Uses of 方法 in javax.management.modelmbean

      Constructors in javax.management.modelmbean with parameters of type 方法
      Constructor 描述
      ModelMBeanAttributeInfo​(String name, String description, 方法 getter, 方法 setter)
      使用默认描述符构造一个ModelMBeanAttributeInfo对象。
      ModelMBeanAttributeInfo​(String name, String description, 方法 getter, 方法 setter, Descriptor descriptor)
      构造一个ModelMBeanAttributeInfo对象。
      ModelMBeanOperationInfo​(String description, 方法 operationMethod)
      使用默认描述符构造一个ModelMBeanOperationInfo对象。
      ModelMBeanOperationInfo​(String description, 方法 operationMethod, Descriptor descriptor)
      构造一个ModelMBeanOperationInfo对象。

    • Uses of 方法 in javax.management.openmbean

      Methods in javax.management.openmbean with parameters of type 方法
      Modifier and Type | 方法 | 描述
      Object | CompositeDataInvocationHandler.invoke​(Object proxy, 方法 method, Object[] args)

    • Uses of 方法 in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type 方法
      Modifier and Type 方法 描述
      abstract Object Invoker.invoke​(方法 m, Object... args)
      JAX-WS运行时调用此方法来对端点实例执行实际的Web服务调用。

    • Uses of 方法 in jdk.dynalink.linker.support

      Methods in jdk.dynalink.linker.support with parameters of type 方法
      Modifier and Type 方法 描述
      static MethodHandle Lookup.unreflect​(MethodHandles.Lookup lookup, 方法 m)
      执行MethodHandles.Lookup.unreflect(Method) ，将任何遇到的IllegalAccessException转换成IllegalAccessError 。
      MethodHandle Lookup.unreflect​(方法 m)
      执行MethodHandles.Lookup.unreflect(Method) ，将任何遇到的IllegalAccessException转换为IllegalAccessError 。

    • Uses of 方法 in jdk.jshell.execution

      Methods in jdk.jshell.execution with parameters of type 方法
      Modifier and Type | 方法 | 描述
      protected String DirectExecutionControl.invoke​(方法 doitMethod)
      调用指定的“doit-method”，一个没有参数的静态方法。
      protected String | LocalExecutionControl.invoke​(方法 doitMethod)
      protected String | RemoteExecutionControl.invoke​(方法 doitMethod)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Modifier (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Modifier

No usage of java.lang.reflect.Modifier
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Parameter (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Parameter

  • Packages that use Parameter
    软件包 描述
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of Parameter in java.lang.reflect

      Methods in java.lang.reflect that return Parameter
      Modifier and Type 方法 描述
      Parameter[] Executable.getParameters​()
      返回一个 Parameter对象的数组，表示由该对象表示的底层可执行文件的所有参数。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.Proxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.Proxy

No usage of java.lang.reflect.Proxy
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.ReflectPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.ReflectPermission

No usage of java.lang.reflect.ReflectPermission
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.lang.reflect.UndeclaredThrowableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.lang.reflect.UndeclaredThrowableException

No usage of java.lang.reflect.UndeclaredThrowableException
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.AnnotatedArrayType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.AnnotatedArrayType

No usage of java.lang.reflect.AnnotatedArrayType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.AnnotatedElement (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.AnnotatedElement

  • Packages that use AnnotatedElement
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of AnnotatedElement in java.lang

      Classes in java.lang that implement AnnotatedElement
      Modifier and Type Class 描述
      class  Class<T>
      类 Class实例表示正在运行的Java应用程序中的类和接口。
      class  Module
      代表一个运行时模块，无论是 named还是未命名的。
      class  软件包
      表示与类加载器关联的运行时包的元数据。

    • Uses of AnnotatedElement in java.lang.reflect

      Subinterfaces of AnnotatedElement in java.lang.reflect
      Modifier and Type 接口 描述
      interface  AnnotatedArrayType
      AnnotatedArrayType表示数组类型的潜在注释使用，其组件类型本身可以表示类型的注释使用。
      interface  AnnotatedParameterizedType
      AnnotatedParameterizedType表示参数化类型的潜在注释使用，其类型参数本身可以表示类型的注释使用。
      interface  AnnotatedType
      AnnotatedType表示当前在此VM中运行的程序中可能注释的使用类型。
      interface  AnnotatedTypeVariable
      AnnotatedTypeVariable表示类型变量的潜在注释使用，其声明可能具有其自身表示注释类型使用的界限。
      interface  AnnotatedWildcardType
      AnnotatedWildcardType表示通配符类型参数的潜在注释使用，其上限或下限本身可以表示类型的注释使用。
      interface  GenericDeclaration
      声明类型变量的所有实体的通用接口。
      interface  TypeVariable<D extends GenericDeclaration>
      TypeVariable是类型变量的常用超级接口。
      Classes in java.lang.reflect that implement AnnotatedElement
      Modifier and Type Class 描述
      class  AccessibleObject
      所述 AccessibleObject类是基础类 Field ， 方法 ，和 Constructor对象（被称为 反射的对象 ）。
      class  Constructor<T>
      Constructor提供了一个类的单个构造函数的信息和访问权限。
      class  Executable
      方法和Constructor的共同功能的共享超类。
      class  Field
      A Field提供有关类或接口的单个字段的信息和动态访问。
      class  方法
      A 方法提供有关类和接口上单个方法的信息和访问。
      class  Parameter
      有关方法参数的信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.AnnotatedParameterizedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.AnnotatedParameterizedType

No usage of java.lang.reflect.AnnotatedParameterizedType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.AnnotatedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.AnnotatedType

  • Packages that use AnnotatedType
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of AnnotatedType in java.lang

      Methods in java.lang that return AnnotatedType
      Modifier and Type 方法 描述
      AnnotatedType[] Class.getAnnotatedInterfaces​()
      返回一个 AnnotatedType对象的数组，表示使用类型指定由该 Class对象表示的实体的 Class 。
      AnnotatedType Class.getAnnotatedSuperclass​()
      返回一个 AnnotatedType对象，表示使用类型来指定由该 Class对象表示的实体的超类。

    • Uses of AnnotatedType in java.lang.reflect

      Subinterfaces of AnnotatedType in java.lang.reflect
      Modifier and Type 接口 描述
      interface  AnnotatedArrayType
      AnnotatedArrayType表示阵列类型的潜在注释使用，其组件类型本身可以表示类型的注释使用。
      interface  AnnotatedParameterizedType
      AnnotatedParameterizedType表示参数化类型的潜在注释使用，其类型参数本身可以表示类型的注释使用。
      interface  AnnotatedTypeVariable
      AnnotatedTypeVariable表示类型变量的潜在注释用法，其声明可能具有其自身表示注释类型使用的界限。
      interface  AnnotatedWildcardType
      AnnotatedWildcardType表示通配符类型参数的潜在注释使用，其上限或下限本身可以表示类型的注释使用。
      Methods in java.lang.reflect that return AnnotatedType
      Modifier and Type 方法 描述
      AnnotatedType[] AnnotatedParameterizedType.getAnnotatedActualTypeArguments​()
      返回此参数化类型的可能注释的实际类型参数。
      AnnotatedType[] AnnotatedTypeVariable.getAnnotatedBounds​()
      返回此类型变量的可能注释的边界。
      AnnotatedType[] TypeVariable.getAnnotatedBounds​()
      返回一个AnnotatedType对象的数组，表示使用类型来表示此TypeVariable表示的类型参数的上限。
      AnnotatedType[] Executable.getAnnotatedExceptionTypes​()
      返回一个 AnnotatedType对象的数组，表示使用类型来指定由此可执行文件表示的方法/构造函数声明的异常。
      AnnotatedType AnnotatedArrayType.getAnnotatedGenericComponentType​()
      返回此数组类型的可能注释的通用组件类型。
      AnnotatedType[] AnnotatedWildcardType.getAnnotatedLowerBounds​()
      返回此通配符类型的潜在注释下限。
      AnnotatedType AnnotatedArrayType.getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。
      AnnotatedType AnnotatedParameterizedType.getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。
      default AnnotatedType AnnotatedType.getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。
      AnnotatedType AnnotatedTypeVariable.getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。
      AnnotatedType AnnotatedWildcardType.getAnnotatedOwnerType​()
      如果此类型表示嵌套类型，则返回此类型为其成员的潜在注释类型。
      AnnotatedType[] Executable.getAnnotatedParameterTypes​()
      返回一个表示使用类型的 AnnotatedType对象的数组，用于指定此可执行文件所表示的方法/构造函数的形式参数类型。
      AnnotatedType Constructor.getAnnotatedReceiverType​()
      返回一个 AnnotatedType对象，表示使用类型来指定由该 Executable对象表示的方法/构造函数的接收器类型。
      AnnotatedType Executable.getAnnotatedReceiverType​()
      返回一个 AnnotatedType对象，表示使用类型来指定由该 Executable对象表示的方法/构造函数的接收器类型。
      AnnotatedType Constructor.getAnnotatedReturnType​()
      返回一个 AnnotatedType对象，表示使用一个类型来指定此可执行文件所表示的方法/构造函数的返回类型。
      abstract AnnotatedType Executable.getAnnotatedReturnType​()
      返回一个 AnnotatedType对象，该对象表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。
      AnnotatedType Method.getAnnotatedReturnType​()
      返回一个 AnnotatedType对象，该对象表示使用类型来指定此可执行文件所表示的方法/构造函数的返回类型。
      AnnotatedType Field.getAnnotatedType​()
      返回一个AnnotatedType对象，它表示使用一个类型来指定此Field所表示的字段的声明类型。
      AnnotatedType Parameter.getAnnotatedType​()
      返回一个AnnotatedType对象，它表示使用一个类型来指定此参数表示的形式参数的类型。
      AnnotatedType[] AnnotatedWildcardType.getAnnotatedUpperBounds​()
      返回此通配符类型的可能注释的上限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.AnnotatedTypeVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.AnnotatedTypeVariable

No usage of java.lang.reflect.AnnotatedTypeVariable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.AnnotatedWildcardType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.AnnotatedWildcardType

No usage of java.lang.reflect.AnnotatedWildcardType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.GenericArrayType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.GenericArrayType

No usage of java.lang.reflect.GenericArrayType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.GenericDeclaration (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.GenericDeclaration

  • Packages that use GenericDeclaration
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of GenericDeclaration in java.lang

      Classes in java.lang that implement GenericDeclaration
      Modifier and Type Class 描述
      class  Class<T>
      类 Class实例表示正在运行的Java应用程序中的类和接口。

    • Uses of GenericDeclaration in java.lang.reflect

      Classes in java.lang.reflect with type parameters of type GenericDeclaration
      Modifier and Type 接口 描述
      interface  TypeVariable<D extends GenericDeclaration>
      TypeVariable是类型变量的常用超级接口。
      Classes in java.lang.reflect that implement GenericDeclaration
      Modifier and Type Class 描述
      class  Constructor<T>
      Constructor提供了一个类的单个构造函数的信息和访问权限。
      class  Executable
      一个共享超类的共同功能方法和Constructor 。
      class  方法
      A 方法 provides information about, and access to, a single method on a class or interface.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.InvocationHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.InvocationHandler

  • Packages that use InvocationHandler
    软件包 描述
    java.beans
    包含与开发 bean相关的类 - 基于JavaBeans架构的组件。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。
    java.rmi.server
    提供用于支持RMI服务器端的类和接口。
    javax.management
    提供Java管理扩展的核心类。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。

    • Uses of InvocationHandler in java.beans

      Classes in java.beans that implement InvocationHandler
      Modifier and Type Class 描述
      class  EventHandler
      EventHandler类提供对动态生成事件侦听器的支持，该侦听器的方法执行涉及传入事件对象和目标对象的简单语句。

    • Uses of InvocationHandler in java.lang.reflect

      Fields in java.lang.reflect declared as InvocationHandler
      Modifier and Type Field 描述
      protected InvocationHandler Proxy.h
      该代理实例的调用处理程序。
      Methods in java.lang.reflect that return InvocationHandler
      Modifier and Type 方法 描述
      static InvocationHandler Proxy.getInvocationHandler​(Object proxy)
      返回指定代理实例的调用处理程序。
      Methods in java.lang.reflect with parameters of type InvocationHandler
      Modifier and Type 方法 描述
      static Object Proxy.newProxyInstance​(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
      返回指定接口的代理实例，该代理实例将方法调用分派给指定的调用处理程序。
      Constructors in java.lang.reflect with parameters of type InvocationHandler
      Constructor 描述
      Proxy​(InvocationHandler h)
      从一个子类（通常是一个动态代理类）构造一个新的 Proxy实例，并为其调用处理程序指定了一个值。

    • Uses of InvocationHandler in java.rmi.server

      Classes in java.rmi.server that implement InvocationHandler
      Modifier and Type Class 描述
      class  RemoteObjectInvocationHandler
      用于Java Remote Method Invocation（Java RMI）的 InvocationHandler接口的实现。

    • Uses of InvocationHandler in javax.management

      Classes in javax.management that implement InvocationHandler
      Modifier and Type Class 描述
      class  MBeanServerInvocationHandler
      InvocationHandler将MBean管理界面中的方法通过MBean服务器转发到MBean。

    • Uses of InvocationHandler in javax.management.openmbean

      Classes in javax.management.openmbean that implement InvocationHandler
      Modifier and Type Class 描述
      class  CompositeDataInvocationHandler
      An InvocationHandler that forwards getter methods to a CompositeData.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.Member (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.Member

  • Packages that use Member
    软件包 描述
    java.lang.invoke
    java.lang.invoke软件包包含由Java核心类库和虚拟机直接提供的动态语言支持。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of Member in java.lang.invoke

      Methods in java.lang.invoke with type parameters of type Member
      Modifier and Type 方法 描述
      <T extends Member>
      T             		MethodHandleInfo.reflectAs​(Class<T> expected, MethodHandles.Lookup lookup)
      将基础成员反映为方法，构造函数或字段对象。
      static <T extends Member>
      T             		MethodHandles.reflectAs​(Class<T> expected, MethodHandle target)
      执行一个未经检查的“裂缝”的 direct method handle 。

    • Uses of Member in java.lang.reflect

      Classes in java.lang.reflect that implement Member
      Modifier and Type Class 描述
      class  Constructor<T>
      Constructor提供了一个类的单个构造函数的信息和访问权限。
      class  Executable
      方法和Constructor的共同功能的共享超类。
      class  Field
      A Field提供有关类或接口的单个字段的信息和动态访问。
      class  方法
      A 方法提供有关类和接口上单个方法的信息和访问权限。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.ParameterizedType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.ParameterizedType

No usage of java.lang.reflect.ParameterizedType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.Type

  • Packages that use Type
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of Type in java.lang

      Classes in java.lang that implement Type
      Modifier and Type Class 描述
      class  Class<T>
      Class类的实例表示正在运行的Java应用程序中的类和接口。
      Methods in java.lang that return Type
      Modifier and Type 方法 描述
      Type[] Class.getGenericInterfaces​()
      返回表示由该对象表示的类或接口直接实现的接口的 Type s。
      Type Class.getGenericSuperclass​()
      返回表示由该 Type表示的实体（类，接口，原语类型或空白）的直接超类的 Class 。

    • Uses of Type in java.lang.reflect

      Subinterfaces of Type in java.lang.reflect
      Modifier and Type 接口 描述
      interface  GenericArrayType
      GenericArrayType表示组件类型是参数化类型或类型变量的数组类型。
      interface  ParameterizedType
      ParameterizedType表示一个参数化类型，如Collection <String>。
      interface  TypeVariable<D extends GenericDeclaration>
      TypeVariable是类型变量的常用超级接口。
      interface  WildcardType
      WildcardType表示一个通配符型表达，如 ? ， ? extends Number ，或 ? super Integer 。
      Methods in java.lang.reflect that return Type
      Modifier and Type 方法 描述
      Type[] ParameterizedType.getActualTypeArguments​()
      返回表示此类型的实际类型参数的 Type对象的数组。
      Type[] TypeVariable.getBounds​()
      返回一个 Type对象的数组，表示此类型变量的上限。
      Type GenericArrayType.getGenericComponentType​()
      返回表示此数组的组件类型的 Type对象。
      Type[] Constructor.getGenericExceptionTypes​()
      返回一个 Type对象的数组，表示此可执行对象声明抛出的异常。
      Type[] Executable.getGenericExceptionTypes​()
      返回一个 Type对象的数组，表示此可执行对象声明抛出的异常。
      Type[] Method.getGenericExceptionTypes​()
      返回一个 Type对象的数组，表示此可执行对象声明抛出的异常。
      Type[] Constructor.getGenericParameterTypes​()
      返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。
      Type[] Executable.getGenericParameterTypes​()
      返回一个 Type对象的数组， Type以声明顺序表示由该对象表示的可执行文件的形式参数类型。
      Type[] Method.getGenericParameterTypes​()
      返回一个 Type对象的数组，表示由该对象表示的可执行文件的声明顺序的形式参数类型。
      Type Method.getGenericReturnType​()
      返回一个 Type对象，表示由该 方法对象表示的方法的正式返回类型。
      Type Field.getGenericType​()
      返回一个 Type对象，表示由该 Field对象表示的字段的声明类型。
      Type[] WildcardType.getLowerBounds​()
      返回一个 Type对象的数组，表示此类型变量的下限。
      Type ParameterizedType.getOwnerType​()
      返回表示此类型 Type成员的类型的 Type对象。
      Type Parameter.getParameterizedType​()
      返回一个 Type对象标识参数化的类型由该表示的参数 Parameter对象。
      Type ParameterizedType.getRawType​()
      返回表示声明此类型的类或接口的 Type对象。
      Type AnnotatedType.getType​()
      返回此注释类型表示的基础类型。
      Type[] WildcardType.getUpperBounds​()
      返回表示此类型变量的上限的 Type对象的数组。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.TypeVariable (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.TypeVariable

  • Packages that use TypeVariable
    软件包 描述
    java.lang
    提供对Java编程语言设计至关重要的类。
    java.lang.reflect
    提供用于获取关于类和对象的反射信息的类和接口。

    • Uses of TypeVariable in java.lang

      Methods in java.lang that return TypeVariable
      Modifier and Type 方法 描述
      TypeVariable<Class<T>>[] Class.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。

    • Uses of TypeVariable in java.lang.reflect

      Methods in java.lang.reflect that return TypeVariable
      Modifier and Type 方法 描述
      TypeVariable<Constructor<T>>[] Constructor.getTypeParameters​()
      返回一个 TypeVariable对象的数组，表示由该 GenericDeclaration对象表示的通用声明声明的类型变量，声明顺序。
      abstract TypeVariable<?>[] Executable.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。
      TypeVariable<?>[] GenericDeclaration.getTypeParameters​()
      返回一个 TypeVariable对象的数组， TypeVariable以声明顺序表示由该 GenericDeclaration对象表示的通用声明声明的类型变量。
      TypeVariable<方法>[] Method.getTypeParameters​()
      Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Interface java.lang.reflect.WildcardType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Interface
java.lang.reflect.WildcardType

No usage of java.lang.reflect.WildcardType
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


BigDecimal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.math

Class BigDecimal

  • java.lang.Object
    • java.lang.Number
      • java.math.BigDecimal
  • All Implemented Interfaces:
    Serializable ， Comparable<BigDecimal>

    public class BigDecimal
extends Number
implements Comparable<BigDecimal>
    不变的，任意精度的带符号的十进制数字。 A BigDecimal由任意精度整数未缩放值和32位整数比例组成 。 如果为零或正数，则刻度是小数点右侧的位数。 如果是负数，则数字的非标定值乘以10，以达到等级的否定的幂。 因此， (unscaledValue × 10-scale)代表的BigDecimal值为(unscaledValue × 10-scale) 。

    BigDecimal类提供了算术，缩放操作，舍入，比较，散列和格式转换的操作。 toString()方法提供了一个BigDecimal的规范表示。

    BigDecimal类使其用户完全控制舍入行为。 如果未指定舍入模式，并且无法表示确切的结果，则抛出异常; 否则，可以通过向操作提供适当的MathContext对象来进行计算，以选择精度和舍入模式。 在这两种情况下，都提供八种舍入方式来控制舍入。 不建议使用此类中的整数字段（如ROUND_HALF_UP ）表示舍入模式; 应该使用RoundingMode 枚举的枚举值（如RoundingMode.HALF_UP ）。

    当一个MathContext对象的精度设置为0（例如， MathContext.UNLIMITED ）时，算术运算是精确的，而不需要MathContext对象的算术方法也是MathContext 。 （这是在5之前的版本中唯一支持的行为。）作为计算精确结果的推论，不使用精度设置为0的MathContext对象的舍入模式设置，因此无关紧要。 在分割的情况下，精确的商可以具有无限长的十进制扩展; 例如，1除以3.如果商具有非终止十进制扩展，并且指定操作返回精确结果，则抛出ArithmeticException 。 否则，返回除法的确切结果，与其他操作一样。

    当精度设置不为0时， BigDecimal算术的规则与ANSI X3.274-1996和ANSI X3.274-1996 / AM 1-2000（第7.4节）中定义的算法的选定操作模式大致兼容。 与这些标准不同， BigDecimal包括许多舍入模式，这些模式在BigDecimal之前的BigDecimal版本中是强制性的。这些ANSI标准与BigDecimal规范之间的任何冲突均得到解决，有利于BigDecimal 。

    由于相同的数值可以具有不同的表示（具有不同的尺度），所以算术和舍入规则必须既指定结果表示中使用的数值结果和比例。

    通常，舍入模式和精确度设置确定了当精确结果具有更多数字（在分割和平方根的情况下可能无限多））时，操作将返回有限数字的结果，而不是返回的位数。 首先，要返回的总位数由MathContext的precision设置指定; 这决定了结果的精度 。 数字计数从精确结果的最左边的非零数字开始。 舍入模式确定任何丢弃的尾随数字如何影响返回的结果。

    对于所有算术运算符，执行操作，就像首先计算精确的中间结果，然后使用选择的舍入模式，舍入为精度设置（如果需要）指定的位数。 如果没有返回确切的结果，则会丢弃精确结果的一些数字位置。 当舍入增加返回结果的大小时，可以通过传播到前导“9”位的进位创建新的数字位置。 例如，将999.9值舍入到三位四舍五入，数值等于一千，表示为100×10 1 。 在这种情况下，新的“1”是返回结果的前导位数。

    除了逻辑精确的结果之外，每个算术运算都具有用于表示结果的优选标度。 下表列出了每个操作的首选比例。

    Preferred Scales for Results of Arithmetic Operations Operation Preferred Scale of Result Add max(addend.scale(), augend.scale()) Subtract max(minuend.scale(), subtrahend.scale()) Multiply multiplier.scale() + multiplicand.scale() Divide dividend.scale() - divisor.scale() Square root radicand.scale()/2
    这些尺度是返回精确算术结果的方法使用的尺度; 除了精确的除法可能需要使用更大的比例，因为确切的结果可能有更多的数字。 例如， 1/32是0.03125 。

    在舍入前，逻辑精确中间结果的比例是该操作的首选比例。 如果精确的数值结果不能在precision数字中表示，则舍入选择要返回的数字集合，并将结果的比例从中间结果的比例减小到可表示实际返回的precision数字的最小比例。 如果确切的结果可以用最多precision数字表示，则返回最接近首选比例的比例的结果的表示。 特别地，可以通过删除尾随零和缩小比例来表示精确可表示的商在少于precision数字中。 例如，使用floor舍入模式舍入到三位数字，
    19/100 = 0.19 // integer=19, scale=2
    但
    21/110 = 0.190 // integer=190, scale=3

    请注意，对于加法，减法和乘法，缩放比例将等于被丢弃的精确结果的数位数。 如果舍入导致进位传播以创建新的高位数字位置，则与没有创建新的数字位置相比，结果的附加数字被丢弃。

    其他方法可能略有不同的舍入语义。 例如，使用specified algorithm的pow方法的结果偶尔可能与最后一个位置的多个单位的舍入数学结果不同，一个ulp 。

    提供了两种类型的操作来操作BigDecimal缩放/缩小操作和小数点运动操作。 缩放/舍入操作（ setScale和round ）返回一个BigDecimal其值约为（或者恰好等于操作数的数值），但其缩放或精度是指定值; 也就是说，它们增加或减少存储数量的精度，对其值的影响最小。 小数点运动操作（ movePointLeft和movePointRight ）返回一个从操作数创建的BigDecimal ，通过在指定方向移动小数点指定的距离。

    为了简洁起见，在代码BigDecimal的描述中使用伪代码。 的伪代码表达(i + j)是简写“一个BigDecimal ，其值是，的BigDecimal i添加到的BigDecimal j ”。 的伪代码表达(i == j)被简写“ true当且仅当所述BigDecimal i表示相同的值作为BigDecimal j ”。 类似地解释其他伪代码表达式。 方括号用于表示特定的BigInteger和缩放对定义BigDecimal值; 例如[ BigDecimal ]是BigDecimal数字等于0.19，具有2的比例。

    对于任何输入参数传递一个null对象引用时，此类的所有方法和构造函数抛出NullPointerException 。

    API Note:
    如果BigDecimal对象用作BigDecimal中的键或SortedSet中的元素， 则应谨慎行事，因为BigDecimal的自然排序 与equals不一致 。 见Comparable ， SortedMap或者SortedSet了解更多信息。
    从以下版本开始：
    1.1
    另请参见：
    BigInteger ， MathContext ， RoundingMode ， SortedMap ， SortedSet ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static BigDecimal ONE
      值1，标度为0。
      static int ROUND_CEILING
      已过时。
      改用RoundingMode.CEILING 。
      static int ROUND_DOWN
      已过时。
      改用RoundingMode.DOWN 。
      static int ROUND_FLOOR
      已过时。
      改用RoundingMode.FLOOR 。
      static int ROUND_HALF_DOWN
      已过时。
      改用RoundingMode.HALF_DOWN 。
      static int ROUND_HALF_EVEN
      已过时。
      改用RoundingMode.HALF_EVEN 。
      static int ROUND_HALF_UP
      已过时。
      改用RoundingMode.HALF_UP 。
      static int ROUND_UNNECESSARY
      已过时。
      改用RoundingMode.UNNECESSARY 。
      static int ROUND_UP
      已过时。
      改用RoundingMode.UP 。
      static BigDecimal TEN
      值为10，标度为0。
      static BigDecimal ZERO
      值为0，标度为0。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BigDecimal​(char[] in)
      将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列。
      BigDecimal​(char[] in, int offset, int len)
      将 BigDecimal的字符阵列表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，同时允许指定子数组。
      BigDecimal​(char[] in, int offset, int len, MathContext mc)
      将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，同时允许根据上下文设置指定子数组并进行舍入。
      BigDecimal​(char[] in, MathContext mc)
      将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，并根据上下文设置进行舍入。
      BigDecimal​(double val)
      将 double转换为 BigDecimal ，它是 double的二进制浮点值的精确十进制表示。
      BigDecimal​(double val, MathContext mc)
      将 double转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(int val)
      将 int翻译成 BigDecimal 。
      BigDecimal​(int val, MathContext mc)
      将 int转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(long val)
      将 long翻译成 BigDecimal 。
      BigDecimal​(long val, MathContext mc)
      将 long转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(String val)
      将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal 。
      BigDecimal​(String val, MathContext mc)
      将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符串，根据上下文设置进行舍入。
      BigDecimal​(BigInteger val)
      将 BigInteger翻译成 BigDecimal 。
      BigDecimal​(BigInteger unscaledVal, int scale)
      将 BigInteger值和 int量表翻译成 BigDecimal 。
      BigDecimal​(BigInteger unscaledVal, int scale, MathContext mc)
      将 BigInteger值和 int标度转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(BigInteger val, MathContext mc)
      根据上下文设置将 BigInteger转换为 BigDecimal舍入。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      BigDecimal abs​()
      返回值为 BigDecimal的绝对值的 BigDecimal ，其大小为 this.scale() 。
      BigDecimal abs​(MathContext mc)
      返回一个 BigDecimal其值为此 BigDecimal的绝对值，根据上下文设置进行舍入。
      BigDecimal add​(BigDecimal augend)
      返回 BigDecimal ，其值是 (this + augend) ，其标为 max(this.scale(), augend.scale()) 。
      BigDecimal add​(BigDecimal augend, MathContext mc)
      返回 BigDecimal ，其值是 (this + augend) ，根据上下文设置进行舍入。
      byte byteValueExact​()
      将此 BigDecimal转换为 byte ，检查丢失的信息。
      int compareTo​(BigDecimal val)
      将此 BigDecimal与指定的 BigDecimal 。
      BigDecimal divide​(BigDecimal divisor)
      返回一个BigDecimal ，其值是(this / divisor) ，并且其优选的比例为(this.scale() - divisor.scale()) ; 如果确切的商不能被表示（因为它具有非终止的十进制扩展），则抛出一个ArithmeticException 。
      BigDecimal divide​(BigDecimal divisor, int roundingMode)
      已过时。
      应该优先使用方法divide(BigDecimal, RoundingMode) 。
      BigDecimal divide​(BigDecimal divisor, int scale, int roundingMode)
      已过时。
      应该优先使用方法divide(BigDecimal, int, RoundingMode) 。
      BigDecimal divide​(BigDecimal divisor, int scale, RoundingMode roundingMode)
      返回一个 BigDecimal其值为 (this / divisor) ，其比例为指定。
      BigDecimal divide​(BigDecimal divisor, MathContext mc)
      返回 BigDecimal ，其值是 (this / divisor) ，根据上下文设置进行舍入。
      BigDecimal divide​(BigDecimal divisor, RoundingMode roundingMode)
      返回 BigDecimal ，其值是 (this / divisor) ，其标为 this.scale() 。
      BigDecimal[] divideAndRemainder​(BigDecimal divisor)
      返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上的两个操作数。
      BigDecimal[] divideAndRemainder​(BigDecimal divisor, MathContext mc)
      返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上与根据上下文设置进行舍入计算出的两个操作数。
      BigDecimal divideToIntegralValue​(BigDecimal divisor)
      返回一个 BigDecimal其值是 (this / divisor)舍入的商 (this / divisor)的整数部分。
      BigDecimal divideToIntegralValue​(BigDecimal divisor, MathContext mc)
      返回值为 BigDecimal的整数部分的 (this / divisor) 。
      double doubleValue​()
      将此 BigDecimal转换为 double 。
      boolean equals​(Object x)
      将此 BigDecimal与指定的 Object进行比较以获得相等性。
      float floatValue​()
      将此 BigDecimal转换为 float 。
      int hashCode​()
      返回此 BigDecimal的哈希码。
      int intValue​()
      将此 BigDecimal转换为 int 。
      int intValueExact​()
      将此 BigDecimal转换为 int ，检查丢失的信息。
      long longValue​()
      将此 BigDecimal转换为 long 。
      long longValueExact​()
      将此 BigDecimal转换为 long ，检查丢失的信息。
      BigDecimal max​(BigDecimal val)
      返回此 BigDecimal和 val 。
      BigDecimal min​(BigDecimal val)
      返回此 BigDecimal和 val 。
      BigDecimal movePointLeft​(int n)
      返回一个 BigDecimal ，相当于这个小数点 n地方。
      BigDecimal movePointRight​(int n)
      返回一个 BigDecimal ，相当于这个小数点移动了 n地方。
      BigDecimal multiply​(BigDecimal multiplicand)
      返回 BigDecimal ，其值是 (this × multiplicand) ，其标为 (this.scale() + multiplicand.scale()) 。
      BigDecimal multiply​(BigDecimal multiplicand, MathContext mc)
      返回 BigDecimal ，其值是 (this × multiplicand) ，根据上下文设置进行舍入。
      BigDecimal negate​()
      返回 BigDecimal ，其值是 (-this) ，其标为 this.scale() 。
      BigDecimal negate​(MathContext mc)
      返回 BigDecimal ，其值是 (-this) ，根据上下文设置进行舍入。
      BigDecimal plus​()
      返回 BigDecimal ，其值是 (+this) ，其标为 this.scale() 。
      BigDecimal plus​(MathContext mc)
      返回 BigDecimal ，其值是 (+this) ，根据上下文设置进行舍入。
      BigDecimal pow​(int n)
      返回一个 BigDecimal ，值为 (thisn) ，功率计算精确到无限精度。
      BigDecimal pow​(int n, MathContext mc)
      返回 BigDecimal ，其值是 (thisn) 。
      int precision​()
      返回此 BigDecimal的 精度 。
      BigDecimal remainder​(BigDecimal divisor)
      返回 BigDecimal ，其值是 (this % divisor) 。
      BigDecimal remainder​(BigDecimal divisor, MathContext mc)
      返回一个 BigDecimal其值为 (this % divisor) ，根据上下文设置进行舍入。
      BigDecimal round​(MathContext mc)
      根据 MathContext设置返回一个 BigDecimal 。
      int scale​()
      返回这个 BigDecimal的 比例 。
      BigDecimal scaleByPowerOfTen​(int n)
      返回一个BigDecimal，其数值等于（ this * 10 n ）。
      BigDecimal setScale​(int newScale)
      返回一个 BigDecimal其缩放比例是指定值，其值在数字上等于此 BigDecimal 。
      BigDecimal setScale​(int newScale, int roundingMode)
      已过时。
      应该优先使用方法setScale(int, RoundingMode)用于该传统方法。
      BigDecimal setScale​(int newScale, RoundingMode roundingMode)
      返回一个 BigDecimal其规模是指定值，其缩放值通过将该 BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。
      short shortValueExact​()
      将此 BigDecimal转换为 short ，检查丢失的信息。
      int signum​()
      返回这个 BigDecimal的signum函数。
      BigDecimal sqrt​(MathContext mc)
      根据上下文设置返回近似值为 this平方根。
      BigDecimal stripTrailingZeros​()
      返回一个 BigDecimal ，它在数字上等于此值，但从表示中删除任何尾随的零。
      BigDecimal subtract​(BigDecimal subtrahend)
      返回 BigDecimal ，其值是 (this - subtrahend) ，其标为 max(this.scale(), subtrahend.scale()) 。
      BigDecimal subtract​(BigDecimal subtrahend, MathContext mc)
      返回 BigDecimal ，其值是 (this - subtrahend) ，根据上下文设置进行舍入。
      BigInteger toBigInteger​()
      将此 BigDecimal转换为 BigInteger 。
      BigInteger toBigIntegerExact​()
      将此 BigDecimal转换为 BigInteger ，检查丢失的信息。
      String toEngineeringString​()
      返回此 BigDecimal的字符串表示，如果需要指数，则使用工程符号。
      String toPlainString​()
      返回没有指数字段的 BigDecimal的字符串表示形式。
      String toString​()
      返回此 BigDecimal的字符串表示 BigDecimal ，如果需要指数则使用科学记数法。
      BigDecimal ulp​()
      返回此 BigDecimal的ulp（最后一个单位）的 BigDecimal 。
      BigInteger unscaledValue​()
      返回 BigInteger其值是此的 非标度值 BigDecimal 。
      static BigDecimal valueOf​(double val)
      转换一个 double成 BigDecimal ，使用 double通过所提供的规范的字符串表示 Double.toString(double)方法。
      static BigDecimal valueOf​(long val)
      将 long值转换为 BigDecimal ，其大小为零。
      static BigDecimal valueOf​(long unscaledVal, int scale)
      将 long值和 int标度转换为 BigDecimal 。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ZERO

        public static final BigDecimal ZERO
        值为0，标度为0。
        从以下版本开始：
        1.5

      • ONE

        public static final BigDecimal ONE
        值1，标度为0。
        从以下版本开始：
        1.5

      • TEN

        public static final BigDecimal TEN
        值为10，标度为0。
        从以下版本开始：
        1.5

      • ROUND_UP

        @Deprecated(since="9")
public static final int ROUND_UP
        已过时。 改用RoundingMode.UP 。
        舍入模式从零开始。 始终在非零丢弃分数之前增加数字。 请注意，该舍入模式不会降低计算值的大小。
        另请参见：
        Constant Field Values

      • ROUND_DOWN

        @Deprecated(since="9")
public static final int ROUND_DOWN
        已过时。 改用RoundingMode.DOWN 。
        舍入模式向零舍入。 不要在丢弃的分数之前递增数字（即截断）。 请注意，该舍入模式不会增加计算值的大小。
        另请参见：
        Constant Field Values

      • ROUND_CEILING

        @Deprecated(since="9")
public static final int ROUND_CEILING
        已过时。 改用RoundingMode.CEILING 。
        圆形模式向正无穷大转弯。 如果BigDecimal为正，则表现为ROUND_UP ; 如果为负，表现为ROUND_DOWN 。 请注意，舍入模式不会降低计算值。
        另请参见：
        Constant Field Values

      • ROUND_FLOOR

        @Deprecated(since="9")
public static final int ROUND_FLOOR
        已过时。 改用RoundingMode.FLOOR 。
        舍入模式向负无穷大转弯。 如果BigDecimal为正，表现为ROUND_DOWN ; 如果为负，表现为ROUND_UP 。 请注意，舍入模式不会增加计算值。
        另请参见：
        Constant Field Values

      • ROUND_HALF_UP

        @Deprecated(since="9")
public static final int ROUND_HALF_UP
        已过时。 改用RoundingMode.HALF_UP 。
        四舍五入模式向“最近邻居”转弯，除非两个邻居都是等距的，在这种情况下是圆括弧的。 如果废弃分数为0.5‰，则为ROUND_UP ; 否则，表现为ROUND_DOWN 。 请注意，这是我们大多数人在小学教学的舍入模式。
        另请参见：
        Constant Field Values

      • ROUND_HALF_DOWN

        @Deprecated(since="9")
public static final int ROUND_HALF_DOWN
        已过时。 改用RoundingMode.HALF_DOWN 。
        四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，这是倒圆的。 如果废弃的分数> 0.5，则表示为ROUND_UP ; 否则，表现为ROUND_DOWN 。
        另请参见：
        Constant Field Values

      • ROUND_HALF_EVEN

        @Deprecated(since="9")
public static final int ROUND_HALF_EVEN
        已过时。 改用RoundingMode.HALF_EVEN 。
        四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，朝向偶数邻居。 行为为ROUND_HALF_UP如果丢弃的分数左边的数字是奇数的; 表现为ROUND_HALF_DOWN如果它是均匀的。 请注意，这是在一系列计算中重复应用时最小化累积误差的舍入模式。
        另请参见：
        Constant Field Values

      • ROUND_UNNECESSARY

        @Deprecated(since="9")
public static final int ROUND_UNNECESSARY
        已过时。 改用RoundingMode.UNNECESSARY 。
        舍入模式来确定所请求的操作具有精确的结果，因此不需要舍入。 如果在产生不精确结果的操作上指定了舍入模式，则抛出ArithmeticException 。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BigDecimal

        public BigDecimal​(char[] in,
                  int offset,
                  int len)
        将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，同时允许指定子数组。
        Implementation Note:
        如果字符序列在字符数组中已经可用，则使用此构造函数的速度要快于将 char数组转换为字符串并使用 BigDecimal(String)构造函数。
        参数
        in - char数组是字符源。
        offset - 要检查的数组中的第一个字符。
        len - 要考虑的字符数
        异常
        NumberFormatException -如果 in不是的有效表示 BigDecimal或所定义的子阵列是不完全内 in 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(char[] in,
                  int offset,
                  int len,
                  MathContext mc)
        将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，同时允许指定子数组并根据上下文设置进行舍入。
        Implementation Note:
        如果字符序列在字符数组中已经可用，则使用此构造函数的速度要快于将 char数组转换为字符串并使用 BigDecimal(String)构造函数。
        参数
        in - char作为字符源的数组。
        offset - 要检查的数组中的第一个字符。
        len - 要考虑的字符数
        mc - 要使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        NumberFormatException -如果 in不是的有效表示 BigDecimal或所定义的子阵列是不完全内 in 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(char[] in)
        将 BigDecimal的字符数组表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列。
        Implementation Note:
        如果字符序列已经可以作为字符数组使用，那么使用此构造函数的速度要快于将 char数组转换为字符串并使用 BigDecimal(String)构造函数。
        参数
        in - char作为字符源的数组。
        异常
        NumberFormatException -如果 in不是的有效表示 BigDecimal 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(char[] in,
                  MathContext mc)
        将 BigDecimal的字符阵列表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，并根据上下文设置进行舍入。
        Implementation Note:
        如果字符序列已经可以作为字符数组使用，那么使用此构造函数的速度要快于将 char数组转换为字符串并使用 BigDecimal(String)构造函数。
        参数
        in - char数组的字符源。
        mc - 要使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        NumberFormatException -如果 in不是的有效表示 BigDecimal 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(String val)
        将BigDecimal的字符串表示BigDecimal转换为BigDecimal 。 字符串表示由可选符号'+' （ '\u002B' ）或'-' （ '\u002D' ）组成，后面是零个或多个十进制数字（“整数”）的序列，可选地后跟一个分数，可选地后跟指数。

        小数部分包含一个小数点，后跟零个或多个十进制数字。 字符串必须包含整数或分数中的至少一个数字。 由符号，整数和分数形成的数字称为有效数 。

        指数由字符'e' （ '\u0065' ）或'E' （ '\u0045' ）组成，后跟一个或多个十进制数字。 指数的值必须在 - Integer.MAX_VALUE （ Integer.MIN_VALUE +1）和Integer.MAX_VALUE之间 。

        更正式地，此构造函数接受的字符串由以下语法描述：

        BigDecimalString:
        Signopt Significand Exponentopt
        Sign:
        +
        -
        Significand:
        IntegerPart . FractionPartopt
        . FractionPart
        IntegerPart
        IntegerPart:
        Digits
        FractionPart:
        Digits
        Exponent:
        ExponentIndicator SignedInteger
        ExponentIndicator:
        e
        E
        SignedInteger:
        Signopt Digits
        Digits:
        Digit
        Digits Digit
        Digit:
        any character for which Character.isDigit(char) returns true, including 0, 1, 2 ...

        返回的BigDecimal将是分数中的位数，如果字符串不包含小数点，则为零，可以对任何指数进行调整; 如果字符串包含指数，则从标度中减去指数。 所得比例的值必须在Integer.MIN_VALUE和Integer.MAX_VALUE之间。

        字符到数字映射由Character.digit(char, int)提供，设置为转换为基数10.字符串可能不包含任何无关的字符（例如，空格）。

        例子：
        返回的BigDecimal值等于有效数 ×10 指数 。 对于左边的每个字符串，所得到的表示[ BigInteger ， scale ]被示在右边。

          "0"            [0,0]
 "0.00"         [0,2]
 "123"          [123,0]
 "-123"         [-123,0]
 "1.23E3"       [123,-1]
 "1.23E+3"      [123,-1]
 "12.3E+7"      [123,-6]
 "12.0"         [120,1]
 "12.3"         [123,1]
 "0.00123"      [123,5]
 "-1.23E-12"    [-123,14]
 "1234.5E-4"    [12345,5]
 "0E+7"         [0,-7]
 "-0"           [0,0]
        API Note:
        对于float和double NaN和±Infinity之外的值，此构造函数与Float.toString(float)和Double.toString(double)返回的值兼容。 这通常是将float或double转换为BigDecimal的首选方式，因为它不会遭受BigDecimal(double)构造函数的不可预测性。
        参数
        val - 字符串表示形式 BigDecimal 。
        异常
        NumberFormatException -如果 val不是的有效表示 BigDecimal 。

      • BigDecimal

        public BigDecimal​(String val,
                  MathContext mc)
        将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符串，根据上下文设置进行舍入。
        参数
        val - 一个 BigDecimal字符串表示 BigDecimal 。
        mc - 要使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但舍入方式为 UNNECESSARY 。
        NumberFormatException - 如果 val不是BigDecimal的有效表示。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(double val)
        将double转换为BigDecimal ，它是double的二进制浮点值的精确十进制表示。 返回的BigDecimal是(10scale × val)是一个整数的最小值。

        笔记：

        1. 这个构造函数的结果可能有些不可预测。 可以假设在Java中写入new BigDecimal(0.1)创建了一个BigDecimal ，它完全等于0.1（非标尺值为1，比例为1），但实际上等于0.1000000000000000055511151231257827021181583404541015625。 这是因为0.1不能像double那样精确地表示（或者，就此而言，作为任何有限长度的二进制分数）。 因此，正在被传递给构造的值不是正好等于0.1，虽然表面上。
        2. 另一方面， String构造函数是完全可预测的：写入new BigDecimal("0.1")创建一个完全等于0.1的BigDecimal ，如预期的那样。 因此，一般建议使用String constructor 。
        3. 当double必须用作源为BigDecimal ，注意，此构造提供了一个精确的转换; 它没有给出相同的结果转换double为String使用Double.toString(double)方法，然后使用BigDecimal(String)构造。 要获得该结果，请使用static valueOf(double)方法。
        参数
        val - double要转换为 BigDecimal值。
        异常
        NumberFormatException - 如果 val是无限或NaN。

      • BigDecimal

        public BigDecimal​(double val,
                  MathContext mc)
        将double转换为BigDecimal ，根据上下文设置进行舍入。 BigDecimal的比例是(10scale × val)是一个整数的最小值。

        该构造函数的结果可能有些不可预测，一般不推荐使用它; 请参阅BigDecimal(double)构造函数下的注释 。

        参数
        val - double值转换为 BigDecimal 。
        mc - 使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但RoundingMode是UNNECESSARY。
        NumberFormatException - 如果 val是无限或NaN。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(BigInteger val)
        将BigInteger翻译成BigDecimal 。 BigDecimal的规模为零。
        参数
        val - BigInteger要转换为 BigDecimal值。

      • BigDecimal

        public BigDecimal​(BigInteger val,
                  MathContext mc)
        根据上下文设置将BigInteger转换为BigDecimal舍入。 BigDecimal的规模为零。
        参数
        val - BigInteger值转换为 BigDecimal 。
        mc - 要使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(BigInteger unscaledVal,
                  int scale)
        将BigInteger值和int标度转换为BigDecimal 。 BigDecimal值为(unscaledVal × 10-scale) 。
        参数
        unscaledVal - unscaledVal值 BigDecimal 。
        scale - 规模 BigDecimal 。

      • BigDecimal

        public BigDecimal​(BigInteger unscaledVal,
                  int scale,
                  MathContext mc)
        将BigInteger缩放值和int刻度转换为BigDecimal ，根据上下文设置进行舍入。 BigDecimal值为(unscaledVal × 10-scale) ，根据precision和舍入模式设置舍入。
        参数
        unscaledVal - unscaled value的 BigDecimal 。
        scale - 规模 BigDecimal 。
        mc - 要使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(int val)
        将int翻译成BigDecimal 。 BigDecimal的规模为零。
        参数
        val - int值转换为 BigDecimal 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(int val,
                  MathContext mc)
        将int转换为BigDecimal ，根据上下文设置进行舍入。 BigDecimal的规模，在任何四舍五入之前为零。
        参数
        val - int要转换为 BigDecimal值。
        mc - 要使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(long val)
        将long转换成BigDecimal 。 BigDecimal的规模为零。
        参数
        val - long值转换为 BigDecimal 。
        从以下版本开始：
        1.5

      • BigDecimal

        public BigDecimal​(long val,
                  MathContext mc)
        将long转换为BigDecimal ，根据上下文设置进行舍入。 BigDecimal的规模，在任何四舍五入之前为零。
        参数
        val - long要转换为 BigDecimal值。
        mc - 要使用的上下文。
        异常
        ArithmeticException - 如果结果不正确，但舍入方式为 UNNECESSARY 。
        从以下版本开始：
        1.5

    • 方法详细信息

      • valueOf

        public static BigDecimal valueOf​(long unscaledVal,
                                 int scale)
        将 long标度值和 int刻度转换为 BigDecimal 。
        API Note:
        优先提供给（此静态工厂法 long ， int ）构造，因为它允许使用频率重用 BigDecimal值。
        参数
        unscaledVal - unscaled value的 BigDecimal 。
        scale - 规模 BigDecimal 。
        结果
        一个 BigDecimal其值为 (unscaledVal × 10-scale) 。

      • valueOf

        public static BigDecimal valueOf​(long val)
        将 long值转换为 BigDecimal ，其大小为零。
        API Note:
        这种静态工厂方法优先于（ long ）构造函数，因为它允许重用常用的 BigDecimal值。
        参数
        val - 值 BigDecimal 。
        结果
        一个 BigDecimal的值是 val 。

      • valueOf

        public static BigDecimal valueOf​(double val)
        转换一个 double成 BigDecimal ，使用 double通过所提供的规范的字符串表示 Double.toString(double)方法。
        API Note:
        这通常是转换的首选方法 double （或 float ）成 BigDecimal ，作为返回的值等于从构造得到 BigDecimal使用的结果 Double.toString(double) 。
        参数
        val - double转换为 BigDecimal 。
        结果
        一个 BigDecimal的值等于或大约等于 val的值。
        异常
        NumberFormatException - 如果 val是无限或NaN。
        从以下版本开始：
        1.5

      • add

        public BigDecimal add​(BigDecimal augend)
        返回 BigDecimal ，其值是 (this + augend) ，其标为 max(this.scale(), augend.scale()) 。
        参数
        augend - 要添加到这个 BigDecimal 。
        结果
        this + augend

      • add

        public BigDecimal add​(BigDecimal augend,
                      MathContext mc)
        返回BigDecimal ，其值是(this + augend) ，根据上下文设置进行舍入。 如果任一数字为零，并且精度设置为非零，则使用其他数字（如果需要舍入）作为结果。
        参数
        augend - 要添加到此 BigDecimal 。
        mc - 使用的上下文。
        结果
        this + augend ，必要时舍入。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5

      • subtract

        public BigDecimal subtract​(BigDecimal subtrahend)
        返回 BigDecimal ，其值是 (this - subtrahend) ，其标为 max(this.scale(), subtrahend.scale()) 。
        参数
        subtrahend - 从此 BigDecimal扣除的值。
        结果
        this - subtrahend

      • subtract

        public BigDecimal subtract​(BigDecimal subtrahend,
                           MathContext mc)
        返回BigDecimal ，其值是(this - subtrahend) ，根据上下文设置进行舍入。 如果subtrahend为零，则作为结果使用，如果需要，则舍入。 如果这是零，那么结果是subtrahend.negate(mc) 。
        参数
        subtrahend - 要从此 BigDecimal扣除的值。
        mc - 要使用的上下文。
        结果
        this - subtrahend ，必要时舍入。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5

      • multiply

        public BigDecimal multiply​(BigDecimal multiplicand)
        返回 BigDecimal ，其值是 (this × multiplicand) ，其标为 (this.scale() + multiplicand.scale()) 。
        参数
        multiplicand - 值乘以 BigDecimal 。
        结果
        this * multiplicand

      • multiply

        public BigDecimal multiply​(BigDecimal multiplicand,
                           MathContext mc)
        返回 BigDecimal ，其值是 (this × multiplicand) ，根据上下文设置进行舍入。
        参数
        multiplicand - 值乘以 BigDecimal 。
        mc - 要使用的上下文。
        结果
        this * multiplicand ，根据需要舍入。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5

      • divide

        @Deprecated(since="9")
public BigDecimal divide​(BigDecimal divisor,
                         int scale,
                         int roundingMode)
        已过时。 应该优先使用方法divide(BigDecimal, int, RoundingMode) 。
        返回BigDecimal ，其值是(this / divisor) ，其标度为指定。 如果必须执行舍入以生成指定刻度的结果，则应用指定的舍入模式。
        参数
        divisor - 这个 BigDecimal将被划分的值。
        scale - 要返回的 BigDecimal 。
        roundingMode - 舍入模式申请。
        结果
        this / divisor
        异常
        ArithmeticException - 如果 divisor为零，则表示 roundingMode==ROUND_UNNECESSARY并且指定的比例不足以表示精确的除法结果。
        IllegalArgumentException - 如果 roundingMode不表示有效的舍入模式。
        另请参见：
        ROUND_UP ， ROUND_DOWN ， ROUND_CEILING ， ROUND_FLOOR ， ROUND_HALF_UP ， ROUND_HALF_DOWN ， ROUND_HALF_EVEN ， ROUND_UNNECESSARY

      • divide

        public BigDecimal divide​(BigDecimal divisor,
                         int scale,
                         RoundingMode roundingMode)
        返回一个BigDecimal其值为(this / divisor) ，其比例为指定。 如果必须执行舍入以生成指定刻度的结果，则应用指定的舍入模式。
        参数
        divisor - 这个 BigDecimal要被划分的值。
        scale - 要返回的 BigDecimal 。
        roundingMode - 舍入模式申请。
        结果
        this / divisor
        异常
        ArithmeticException - 如果 divisor为零，则表示 roundingMode==RoundingMode.UNNECESSARY ，并且指定的比例不足以准确表示分割的结果。
        从以下版本开始：
        1.5

      • divide

        @Deprecated(since="9")
public BigDecimal divide​(BigDecimal divisor,
                         int roundingMode)
        已过时。 应该优先使用方法divide(BigDecimal, RoundingMode) ，这种传统方法。
        返回BigDecimal ，其值是(this / divisor) ，其标为this.scale() 。 如果必须执行舍入以产生给定刻度的结果，则应用指定的舍入模式。
        参数
        divisor - 这个 BigDecimal要被划分的值。
        roundingMode - 舍入方式申请。
        结果
        this / divisor
        异常
        ArithmeticException - 如果是 divisor==0或 roundingMode==ROUND_UNNECESSARY和 this.scale()不足以精确地表示除法的结果。
        IllegalArgumentException - 如果 roundingMode不表示有效的舍入模式。
        另请参见：
        ROUND_UP ， ROUND_DOWN ， ROUND_CEILING ， ROUND_FLOOR ， ROUND_HALF_UP ， ROUND_HALF_DOWN ， ROUND_HALF_EVEN ， ROUND_UNNECESSARY

      • divide

        public BigDecimal divide​(BigDecimal divisor,
                         RoundingMode roundingMode)
        返回BigDecimal ，其值是(this / divisor) ，其标为this.scale() 。 如果必须执行舍入以产生给定刻度的结果，则应用指定的舍入模式。
        参数
        divisor - 这个 BigDecimal要划分的值。
        roundingMode - 舍入模式申请。
        结果
        this / divisor
        异常
        ArithmeticException - 如果 divisor==0或 roundingMode==RoundingMode.UNNECESSARY和 this.scale()不足以精确地表示划分的结果。
        从以下版本开始：
        1.5

      • divide

        public BigDecimal divide​(BigDecimal divisor)
        返回一个BigDecimal ，其值是(this / divisor) ，并且其优选的比例为(this.scale() - divisor.scale()) ; 如果确切的商不能被表示（因为它具有非终止的十进制扩展），则抛出一个ArithmeticException 。
        参数
        divisor - 这个 BigDecimal将被划分的值。
        结果
        this / divisor
        异常
        ArithmeticException - 如果确切商没有终止十进制扩展
        从以下版本开始：
        1.5

      • divide

        public BigDecimal divide​(BigDecimal divisor,
                         MathContext mc)
        返回 BigDecimal ，其值是 (this / divisor) ，根据上下文设置进行舍入。
        参数
        divisor - 这个 BigDecimal将被划分的值。
        mc - 要使用的上下文。
        结果
        this / divisor ，根据需要舍入。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式为 UNNECESSARY或 mc.precision == 0 ，商为非终止十进制扩展。
        从以下版本开始：
        1.5

      • divideToIntegralValue

        public BigDecimal divideToIntegralValue​(BigDecimal divisor)
        返回一个BigDecimal其值是(this / divisor)舍入的商(this / divisor)的整数部分。 结果的首选尺度为(this.scale() - divisor.scale()) 。
        参数
        divisor - 这个 BigDecimal将被划分的价值。
        结果
        整数部分为 this / divisor 。
        异常
        ArithmeticException - 如果是 divisor==0
        从以下版本开始：
        1.5

      • divideToIntegralValue

        public BigDecimal divideToIntegralValue​(BigDecimal divisor,
                                        MathContext mc)
        返回值为BigDecimal的整数部分的(this / divisor) 。 由于精确商的整数部分不依赖舍入模式，因此舍入模式不影响此方法返回的值。 结果的首选尺度为(this.scale() - divisor.scale()) 。 如果确切商的整数部分需要超过mc.precision位数，则抛出一个ArithmeticException 。
        参数
        divisor - 这个 BigDecimal将被划分的值。
        mc - 使用的上下文。
        结果
        整数部分为 this / divisor 。
        异常
        ArithmeticException - 如果是 divisor==0
        ArithmeticException - 如果 mc.precision > 0，结果要求精度超过 mc.precision位数。
        从以下版本开始：
        1.5

      • remainder

        public BigDecimal remainder​(BigDecimal divisor)
        返回BigDecimal ，其值是(this % divisor) 。

        余数由this.subtract(this.divideToIntegralValue(divisor).multiply(divisor))给出。 请注意，这不是模运算（结果可能为负）。

        参数
        divisor - 这个 BigDecimal将被划分的值。
        结果
        this % divisor 。
        异常
        ArithmeticException - divisor==0
        从以下版本开始：
        1.5

      • remainder

        public BigDecimal remainder​(BigDecimal divisor,
                            MathContext mc)
        返回BigDecimal ，其值是(this % divisor) ，根据上下文设置进行舍入。 MathContext设置影响用于计算余数的隐含分隔。 其余的计算本身就是按照准确的。 因此，余数可能包含多达mc.getPrecision()位数。

        余数由this.subtract(this.divideToIntegralValue(divisor, mc).multiply(divisor))给出。 请注意，这不是模运算（结果可能为负）。

        参数
        divisor - 这个 BigDecimal要被划分的值。
        mc - 要使用的上下文。
        结果
        this % divisor ，根据需要舍入。
        异常
        ArithmeticException - 如果是 divisor==0
        ArithmeticException - 如果结果不正确，但舍入模式为 UNNECESSARY ，或 mc.precision > 0，并且 this.divideToIntgralValue(divisor)的结果将需要超过 mc.precision位数的精度。
        从以下版本开始：
        1.5
        另请参见：
        divideToIntegralValue(java.math.BigDecimal, java.math.MathContext)

      • divideAndRemainder

        public BigDecimal[] divideAndRemainder​(BigDecimal divisor)
        返回一个两元件BigDecimal阵列含有的结果divideToIntegralValue随后的结果remainder上的两个操作数。

        请注意，如果需要整数商和余数，则该方法比单独使用divideToIntegralValue和remainder方法更快，因为除法仅需执行一次。

        参数
        divisor - 这个 BigDecimal将被划分的值，其余的是计算的。
        结果
        一个二元素 BigDecimal数组：商（ divideToIntegralValue的结果）是初始元素，余数是最后一个元素。
        异常
        ArithmeticException - 如果是 divisor==0
        从以下版本开始：
        1.5
        另请参见：
        divideToIntegralValue(java.math.BigDecimal, java.math.MathContext) ， remainder(java.math.BigDecimal, java.math.MathContext)

      • divideAndRemainder

        public BigDecimal[] divideAndRemainder​(BigDecimal divisor,
                                       MathContext mc)
        返回一个包含BigDecimal的结果的二元素BigDecimal数组， divideToIntegralValue跟随根据上下文设置舍入计算的两个操作数的remainder的结果。

        请注意，如果需要整数商和余数，则该方法比单独使用divideToIntegralValue和remainder方法更快，因为除法只需执行一次。

        参数
        divisor - 这个 BigDecimal要被划分的值，其余的是计算的。
        mc - 要使用的上下文。
        结果
        一个二元素 BigDecimal数组：商（ divideToIntegralValue的结果）是初始元素，余数是最后一个元素。
        异常
        ArithmeticException - 如果是 divisor==0
        ArithmeticException - 如果结果不准确，但舍入模式为 UNNECESSARY ，或 mc.precision > 0，并且 this.divideToIntgralValue(divisor)的结果将需要超过 mc.precision位数的精度。
        从以下版本开始：
        1.5
        另请参见：
        divideToIntegralValue(java.math.BigDecimal, java.math.MathContext) ， remainder(java.math.BigDecimal, java.math.MathContext)

      • sqrt

        public BigDecimal sqrt​(MathContext mc)
        根据上下文设置返回近似值， this为this平方根。

        返回结果的首选比例等于this.scale()/2 。 返回结果的值始终在所讨论的精度的精确十进制值的一个ulp内。 如果舍入模式为HALF_UP ， HALF_DOWN ，或HALF_EVEN ，结果是二分之一精确十进制值的ulp内。

        特例：

        • 数字等于ZERO的数字的ZERO数字等于ZERO ，具有根据上述一般规则的优选标度。 特别是，对于ZERO ， ZERO.sqrt(mc).equals(ZERO)与任何真实MathContext作为参数。
        参数
        mc - 要使用的上下文。
        结果
        平方根 this 。
        异常
        ArithmeticException - 如果 this小于零。
        ArithmeticException - 如果要求确切的结果（ mc.getPrecision()==0 ），并且没有精确结果的有限十进制扩展
        ArithmeticException - 如果是 (mc.getRoundingMode()==RoundingMode.UNNECESSARY ），确切的结果不能符合 mc.getPrecision()数字。
        从以下版本开始：
        9
        另请参见：
        BigInteger.sqrt()

      • pow

        public BigDecimal pow​(int n)
        返回一个BigDecimal其值为(thisn) ，电源精确计算，达到无限精度。

        参数n的范围必须在0到999999999（含）之间。 ZERO.pow(0)返回ONE 。 请注意，将来的版本可能会扩大此方法的允许指数范围。

        参数
        n - 提高这个 BigDecimal权力。
        结果
        thisn
        异常
        ArithmeticException - 如果 n超出范围。
        从以下版本开始：
        1.5

      • pow

        public BigDecimal pow​(int n,
                      MathContext mc)
        返回BigDecimal ，其值是(thisn) 。 目前的实现使用ANSI标准X3.274-1996中定义的核心算法，根据上下文设置进行舍入。 通常，返回的数值在所选精度的精确数值的两个ul内。 请注意，未来的版本可能会使用不同的算法，减少了允许的误差范围和增加的允许指数范围。

        X3.274-1996算法是：

        • 抛出一个ArithmeticException异常
          • abs(n) > 999999999
          • mc.precision == 0和n < 0
          • mc.precision > 0和n具有超过mc.precision十进制数字
        • 如果n为零， ONE返回即使this为零，否则
          • 如果n为正，则将结果通过重复的平方技术计算到单个累加器中。 与蓄能器的各个乘法中使用相同的数学上下文设置为mc除了一个精度提高到mc.precision + elength + 1其中elength是十进制数字的数量n 。
          • 如果n为负数，则计算结果为n为正数; 然后使用上述工作精度将该值分为一个。
          • 然后将正值或负数情况下的最终值四舍五入为目标精度。
        参数
        n - 提高这个 BigDecimal权力。
        mc - 要使用的上下文。
        结果
        thisn采用ANSI标准X3.274-1996算法
        异常
        ArithmeticException - 如果结果不正确，但舍入方式为 UNNECESSARY ，或 n超出范围。
        从以下版本开始：
        1.5

      • abs

        public BigDecimal abs​()
        返回一个 BigDecimal其值为该 BigDecimal的绝对值，其大小为 this.scale() 。
        结果
        abs(this)

      • abs

        public BigDecimal abs​(MathContext mc)
        返回一个 BigDecimal其值为此 BigDecimal的绝对值，根据上下文设置进行舍入。
        参数
        mc - 要使用的上下文。
        结果
        abs(this) ，必要时舍入。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5

      • negate

        public BigDecimal negate​()
        返回 BigDecimal ，其值是 (-this) ，其标为 this.scale() 。
        结果
        -this 。

      • negate

        public BigDecimal negate​(MathContext mc)
        返回 BigDecimal ，其值是 (-this) ，根据上下文设置进行舍入。
        参数
        mc - 要使用的上下文。
        结果
        -this ，必要时舍入。
        异常
        ArithmeticException - 如果结果不正确，但舍入方式为 UNNECESSARY 。
        从以下版本开始：
        1.5

      • plus

        public BigDecimal plus​()
        返回BigDecimal ，其值是(+this) ，其标为this.scale() 。

        这个方法，简单地返回这个BigDecimal包含与一元负法negate()的对称性 。

        结果
        this 。
        从以下版本开始：
        1.5
        另请参见：
        negate()

      • plus

        public BigDecimal plus​(MathContext mc)
        返回BigDecimal ，其值是(+this) ，根据上下文设置进行舍入。

        该方法的效果与round(MathContext)方法的效果相同。

        参数
        mc - 要使用的上下文。
        结果
        this ，根据需要舍入。 零结果将具有0的比例。
        异常
        ArithmeticException - 如果结果不正确，但舍入模式是 UNNECESSARY 。
        从以下版本开始：
        1.5
        另请参见：
        round(MathContext)

      • signum

        public int signum​()
        返回此 BigDecimal的signum函数。
        结果
        -1,0或1，因为该 BigDecimal值为负，为零或正。

      • scale

        public int scale​()
        返回此BigDecimal的比例 。 如果为零或正数，则刻度是小数点右侧的位数。 如果是负数，则数字的非标定值乘以10，以达到等级的否定的幂。 例如， -3的比例表示未-3值乘以1000。
        结果
        这个规模 BigDecimal 。

      • precision

        public int precision​()
        返回此BigDecimal的精度 。 （精度是未缩放值的位数）

        零值的精度为1。

        结果
        这个 BigDecimal的精度。
        从以下版本开始：
        1.5

      • unscaledValue

        public BigInteger unscaledValue​()
        返回一个BigInteger其值是此BigDecimal的非缩放值 。 （计算(this * 10this.scale()) ）
        结果
        这是 BigDecimal值。
        从以下版本开始：
        1.2

      • round

        public BigDecimal round​(MathContext mc)
        根据MathContext设置返回一个BigDecimal 。 如果精度设置为0，则不进行舍入。

        该方法的效果与plus(MathContext)方法的效果相同。

        参数
        mc - 要使用的上下文。
        结果
        一个 BigDecimal根据 MathContext设置舍入。
        异常
        ArithmeticException - 如果舍入模式为 UNNECESSARY ，而 BigDecimal操作将需要舍入。
        从以下版本开始：
        1.5
        另请参见：
        plus(MathContext)

      • setScale

        public BigDecimal setScale​(int newScale,
                           RoundingMode roundingMode)
        返回其规模为指定值的BigDecimal其BigDecimal的值通过将该BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。 如果通过操作缩小比例，则将非标定值除以（而不是乘以），并且该值可能会被更改; 在这种情况下，指定的舍入模式被应用于该划分。
        API Note:
        由于BigDecimal对象是不可变的，所以这种方法的调用不会导致原始对象被修改，这与通常使用名称为setX mutate字段X方法X 。 相反， setScale返回具有适当比例的对象; 返回的对象可能被新分配，也可能不会被新分配。
        参数
        newScale - 要退回的 BigDecimal值的比例。
        roundingMode - 要舍入的舍入模式。
        结果
        一个 BigDecimal其规模是指定值，其非标度值通过将该 BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。
        异常
        ArithmeticException - 如果 roundingMode==UNNECESSARY和指定的缩放操作将需要四舍五入。
        从以下版本开始：
        1.5
        另请参见：
        RoundingMode

      • setScale

        @Deprecated(since="9")
public BigDecimal setScale​(int newScale,
                           int roundingMode)
        已过时。 应该优先使用方法setScale(int, RoundingMode)用于该传统方法。
        返回一个BigDecimal其尺度是指定值，其BigDecimal的值通过将该BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。 如果通过操作缩小比例，则将非标定值除以（而不是乘以），并且该值可能会被更改; 在这种情况下，指定的舍入模式被应用于该划分。
        API Note:
        由于BigDecimal对象是不可变的，所以这种方法的调用不会导致原始对象被修改，这与通常使用命名为setX mutate字段X方法X 。 相反， setScale返回具有适当比例的对象; 返回的对象可能被新分配，也可能不会被新分配。
        参数
        newScale - 要返回的 BigDecimal值的比例。
        roundingMode - 要应用的舍入模式。
        结果
        一个 BigDecimal其规模是指定值，其非标度值通过将该 BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。
        异常
        ArithmeticException - 如果是 roundingMode==ROUND_UNNECESSARY ，并且指定的缩放操作将需要四舍五入。
        IllegalArgumentException - 如果 roundingMode不表示有效的舍入模式。
        另请参见：
        ROUND_UP ， ROUND_DOWN ， ROUND_CEILING ， ROUND_FLOOR ， ROUND_HALF_UP ， ROUND_HALF_DOWN ， ROUND_HALF_EVEN ， ROUND_UNNECESSARY

      • setScale

        public BigDecimal setScale​(int newScale)
        返回一个BigDecimal其缩放比例是指定值，其值在数字上等于BigDecimal 。 抛出一个ArithmeticException如果这是不可能的。

        此调用通常用于增加比例，在这种情况下，可以确保存在指定比例的BigDecimal和正确的值。 如果呼叫者知道BigDecimal在其小数部分结尾处具有足够多的零（即，其整数值中的十个因子）以允许重新调整而不改变其值，那么该呼叫也可以用于减小比例。

        此方法返回与双参数版本setScale相同的结果，但是在不相关的情况下，将调用者保存指定舍入模式的麻烦。

        API Note:
        由于BigDecimal对象是不可变的，所以这种方法的调用不会导致原始对象被修改，这与通常使用名称为setX字段X 。 相反， setScale返回具有适当比例的对象; 返回的对象可能被新分配，也可能不会被新分配。
        参数
        newScale - 要退回的 BigDecimal值的比例。
        结果
        一个 BigDecimal其规模是指定值，其非标度值通过将该 BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。
        异常
        ArithmeticException - 如果指定的缩放操作需要四舍五入。
        另请参见：
        setScale(int, int) ， setScale(int, RoundingMode)

      • movePointLeft

        public BigDecimal movePointLeft​(int n)
        返回一个BigDecimal ，相当于这个小数点，向左移动了n地方。 如果n是非负数，则调用仅添加n到比例。 如果n为负数，则该呼叫相当于movePointRight(-n) 。 此呼叫返回的BigDecimal具有值(this × 10-n)和比例尺max(this.scale()+n, 0) 。
        参数
        n - 将小数点向左移动的位数。
        结果
        一个 BigDecimal相当于这个与小数点的位置移动了 n左边。
        异常
        ArithmeticException - 如果规模溢出。

      • movePointRight

        public BigDecimal movePointRight​(int n)
        返回一个BigDecimal ，相当于这个小数点，移动了n地方。 如果n是非负数，则呼叫n比例中减去n 。 如果n为负，则该呼叫相当于movePointLeft(-n) 。 此呼叫返回的BigDecimal具有值(this × 10n)和规模max(this.scale()-n, 0) 。
        参数
        n - 将小数点向右移动的位数。
        结果
        一个 BigDecimal相当于这个与小数点的位置移动了 n地方。
        异常
        ArithmeticException - 如果比例溢出。

      • scaleByPowerOfTen

        public BigDecimal scaleByPowerOfTen​(int n)
        返回一个BigDecimal，其数值等于（ this * 10 n ）。 结果的比例为(this.scale() - n) 。
        参数
        n - 十个指数幂的比例
        结果
        其数值等于（ this * 10 n ）的BigDecimal
        异常
        ArithmeticException - 如果缩放比例在32位整数的范围之外。
        从以下版本开始：
        1.5

      • stripTrailingZeros

        public BigDecimal stripTrailingZeros​()
        返回一个BigDecimal ，它在数字上等于此值，但从表示中删除任何尾随的零。 例如，从汽提尾随零BigDecimal值600.0 ，其具有[ BigInteger ， scale ]组件等于[6000，1]，产率6E2与[ BigInteger ， scale ]组分等于[6，-2]。 如果此BigDecimal在数字上等于零，则返回BigDecimal.ZERO 。
        结果
        一个数字相等的 BigDecimal ，任何尾随零被删除。
        从以下版本开始：
        1.5

      • compareTo

        public int compareTo​(BigDecimal val)
        将此BigDecimal与指定的BigDecimal 。 两个BigDecimal对象的价值相等但具有不同的比例（如2.0和2.00）被认为是相等的这种方法。 该方法优先于六个布尔比较运算符（<，==，>，> =，！=，<=）中的每一个的各个方法。 用于执行这些比较的建议成语是： (x.compareTo(y) < op > 0) ，其中< op >是六个比较运算符之一。
        Specified by:
        compareTo在接口 Comparable<BigDecimal>
        参数
        val - BigDecimal要比较这个 BigDecimal 。
        结果
        -1,0或1，因为这个 BigDecimal在数字上小于，等于或大于 val 。

      • equals

        public boolean equals​(Object x)
        将此BigDecimal与指定的Object进行比较，以获得相等性。 与compareTo不同，该方法认为两个BigDecimal对象只有在值和比例相等时才相等（因此，当通过此方法比较时，2.0不等于2.00）。
        重写：
        equals在 Object
        参数
        x - Object到这个 BigDecimal被比较。
        结果
        true当且仅当指定的 Object是一个 BigDecimal其值和比例等于此 BigDecimal的。
        另请参见：
        compareTo(java.math.BigDecimal) ， hashCode()

      • min

        public BigDecimal min​(BigDecimal val)
        返回此 BigDecimal和 val 。
        参数
        val - 要计算最小值的值。
        结果
        在BigDecimal其值是此的较小BigDecimal和val 。 如果它们相同，则由compareTo方法定义，则返回this 。
        另请参见：
        compareTo(java.math.BigDecimal)

      • max

        public BigDecimal max​(BigDecimal val)
        返回此 BigDecimal和 val 。
        参数
        val - 要计算最大值的值。
        结果
        在BigDecimal其值是此的更大BigDecimal和val 。 如果它们相同，则由compareTo方法定义，则返回this 。
        另请参见：
        compareTo(java.math.BigDecimal)

      • hashCode

        public int hashCode​()
        返回此BigDecimal的哈希码。 请注意，两个BigDecimal对象在数字上相等但尺度不同（如2.0和2.00）通常不会有相同的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 BigDecimal哈希码。
        另请参见：
        equals(Object)

      • toString

        public String toString​()
        返回此BigDecimal的字符串表示BigDecimal ，如果需要指数，则使用科学记数法。

        通过以下步骤创建BigDecimal标准规范字符串形式：首先，使用'0'至'9'的字符，将BigDecimal值的BigDecimal转换为基数为10的字符串，不带前导零（除其值为零，在这种情况下使用单个'0'字符）。

        接下来，计算调整后的指数 ; 这是否定的比例，加上转换的未缩放值中的字符数，少于1。 即-scale+(ulength-1) ，其中ulength是以十进制数字表示的非标度值的绝对值的长度（其精度 ）。

        如果刻度大于或等于零，并且调整后的指数大于或等于-6 ，则该数字将转换为字符形式而不使用指数符号。 在这种情况下，如果刻度为零，则不加小数点，如果刻度为正，则将插入小数点，刻度指定小数点右侧的字符数。 '0'字符根据需要添加到转换的未缩放值的左侧。 如果在插入后没有字符在小数点之前，那么常规的'0'字符是前缀。

        否则（即，如果比例为负数，或调整后的指数小于-6 ），则该数字将使用指数符号转换为字符形式。 在这种情况下，如果转换后的BigInteger有多个数字，则在第一个数字后插入一个小数点。 然后，字符形式的指数后缀到转换的未缩放值（可能带有插入的小数点）; 这包括字母'E'紧随其后，被调整的指数转换为字符形式。 后者基于十进制，使用没有前导零的字符'0'至'9' ，如果调整的指数为负，则总是以符号字符'-' （ '\u002D' ）为前缀，否则为'+' （ '\u002B' ））。

        最后，如果未缩放的值小于零，则整个字符串的前缀为负号字符'-' （ '\u002D' ）。 如果未标定值为零或正数，则不会标记符号。

        例子：

        对于左侧的每个表示[未缩放值 ， 缩放 ]，生成的字符串显示在右侧。

          [123,0]      "123"
 [-123,0]     "-123"
 [123,-1]     "1.23E+3"
 [123,-3]     "1.23E+5"
 [123,1]      "12.3"
 [123,5]      "0.00123"
 [123,10]     "1.23E-8"
 [-123,12]    "-1.23E-10"
        笔记：
        1. 可区分的BigDecimal值与此转换的结果之间存在一对一映射。 也就是说，作为使用toString的结果，每个可区分的BigDecimal值（未缩放的值和比例）具有唯一的字符串表示。 如果该字符串表示转换回BigDecimal使用BigDecimal(String)构造，则原始值将被回收。
        2. 给定数字产生的字符串总是相同的; 它不受区域设置的影响。 这意味着它可以用作交换十进制数据的标准字符串表示形式，也可以用作Hashtable等的键。区域设置敏感数字格式化和解析由NumberFormat类及其子类来处理。
        3. toEngineeringString()方法可用于以工程符号表示数字，并且setScale方法可用于舍入BigDecimal以便在小数点后具有已知数字的数字。
        4. 使用由Character.forDigit提供的数字到字符映射。
        重写：
        toString在 Object
        结果
        字符串表示的这个 BigDecimal 。
        另请参见：
        Character.forDigit(int, int) ， BigDecimal(java.lang.String)

      • toEngineeringString

        public String toEngineeringString​()
        返回此BigDecimal的字符串表示BigDecimal ，如果需要指数则使用工程符号。

        返回表示一个字符串BigDecimal如在所描述的toString()方法，不同之处在于，如果使用指数表示法，10的功率被调整为3（工程符号）的倍数，使得非零值的整数部分将在范围1到999.如果指数符号用于零值，则使用小数点和一个或两个小数零数字，以保持零值的比例。 注意，与输出toString() ，这种方法的输出是不能保证恢复相同[整数，标度]对本的BigDecimal如果输出串转换回一BigDecimal使用string constructor 。 该方法的结果满足了通过将字符串构造函数应用于方法的输出来总是产生数值相等的结果的较弱约束。

        结果
        这个 BigDecimal字符串表示法，如果需要指数，则使用工程符号。
        从以下版本开始：
        1.5

      • toPlainString

        public String toPlainString​()
        返回没有指数字段的BigDecimal的字符串表示形式。 对于正比例的值，小数点右侧的位数用于表示比例。 对于零或负比例的值，生成的字符串就像将值转换为数字相等的零标度值一样生成，并且如果零比例值的所有尾部零都存在于结果中。 如果未缩放的值小于零，则整个字符串前加一个减号字符' - '（ '\u002D' ）。 如果未标定值为零或正数，则不会标记符号。 注意，如果该方法的结果被传递到string constructor ，仅此的数值BigDecimal将必然被回收; 新的BigDecimal的表示可能有不同的比例。 特别是，如果这个BigDecimal具有负比例尺，则由该方法生成的字符串将在字符串构造函数处理时具有0的比例。 （该方法类似于1.4及更早版本中的toString方法）。
        结果
        这个没有指数字段的 BigDecimal的字符串表示。
        从以下版本开始：
        1.5
        另请参见：
        toString() ， toEngineeringString()

      • toBigInteger

        public BigInteger toBigInteger​()
        将此BigDecimal转换为BigInteger 。 此转换类似于从基本收缩转换 double到long如The Java™ Language Specification定义：此的任何小数部分BigDecimal将被丢弃。 请注意，此转换可能会丢失有关BigDecimal值的精度的信息。

        如果转换不正确（换句话说，如果非零分数部分被丢弃），则抛出异常 ，请使用toBigIntegerExact()方法。

        结果
        这 BigDecimal转为 BigInteger 。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • toBigIntegerExact

        public BigInteger toBigIntegerExact​()
        将此BigDecimal转换为BigInteger ，检查丢失的信息。 如果此BigDecimal具有非零小数部分，则抛出异常。
        结果
        这 BigDecimal转为 BigInteger 。
        异常
        ArithmeticException - 如果 this具有非零分数部分。
        从以下版本开始：
        1.5

      • longValue

        public long longValue​()
        将此BigDecimal转换为long 。 此转换类似于从基本收缩转换 double到short如The Java™ Language Specification定义：此的任何小数部分BigDecimal将被丢弃，并且如果产生的“ BigInteger ”是太大而不适合在long ，仅低阶64返回位。 请注意，此转换可能会丢失有关此BigDecimal值的总体大小和精度的信息，并返回相反符号的结果。
        Specified by:
        longValue在 Number
        结果
        这 BigDecimal转为 long 。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • longValueExact

        public long longValueExact​()
        将此BigDecimal转换为long ，检查丢失的信息。 如果这个BigDecimal具有非零小数部分，或者超出long结果的可能范围，则抛出一个ArithmeticException 。
        结果
        这个 BigDecimal转换成 long 。
        异常
        ArithmeticException - 如果 this具有非零分数部分，或者不符合 long 。
        从以下版本开始：
        1.5

      • intValue

        public int intValue​()
        将此BigDecimal转换为int 。 此转换类似于从基本收缩转换 double到short如The Java™ Language Specification定义：此的任何小数部分BigDecimal将被丢弃，并且如果产生的“ BigInteger ”是太大而不适合在int ，只有低32返回位。 请注意，此转换可能会丢失有关此BigDecimal值的总体大小和精度的信息，并返回相反符号的结果。
        Specified by:
        intValue在 Number
        结果
        此 BigDecimal转换为 int 。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • intValueExact

        public int intValueExact​()
        将此BigDecimal转换为int ，检查丢失的信息。 如果该BigDecimal具有非零小数部分，或者超出int结果的可能范围，则抛出ArithmeticException 。
        结果
        这 BigDecimal转为 int 。
        异常
        ArithmeticException - 如果 this具有非零小数部分，或者不符合 int 。
        从以下版本开始：
        1.5

      • shortValueExact

        public short shortValueExact​()
        将此BigDecimal转换为short ，检查丢失的信息。 如果该BigDecimal具有非零小数部分，或者超出short结果的可能范围，则抛出一个ArithmeticException 。
        结果
        这 BigDecimal转换为 short 。
        异常
        ArithmeticException - 如果 this具有非零小数部分，或者不符合 short 。
        从以下版本开始：
        1.5

      • byteValueExact

        public byte byteValueExact​()
        将此BigDecimal转换为byte ，检查丢失的信息。 如果这个BigDecimal具有非零小数部分，或者超出byte结果的可能范围，则抛出一个ArithmeticException 。
        结果
        这个 BigDecimal转换成 byte 。
        异常
        ArithmeticException - 如果 this具有非零小数部分，或者不适合 byte 。
        从以下版本开始：
        1.5

      • floatValue

        public float floatValue​()
        将此BigDecimal转换为float 。 这种转换是类似于从基本收缩转换 double到float如The Java™ Language Specification定义：如果此BigDecimal有太大的幅度来表示作为float ，它会被转换为Float.NEGATIVE_INFINITY或Float.POSITIVE_INFINITY适当。 请注意，即使返回值有限，此转换也可能会丢失有关BigDecimal值精度的信息。
        Specified by:
        floatValue在 Number
        结果
        这 BigDecimal转换成 float 。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • doubleValue

        public double doubleValue​()
        将此BigDecimal转换为double 。 这种转换是类似于从基本收缩转换 double到float如The Java™ Language Specification定义：如果此BigDecimal有太大的幅度表示为double ，它会被转换为Double.NEGATIVE_INFINITY或Double.POSITIVE_INFINITY适当。 请注意，即使返回值有限，此转换也可能会丢失有关BigDecimal的精度的信息。
        Specified by:
        doubleValue在 Number
        结果
        这个 BigDecimal转换成 double 。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • ulp

        public BigDecimal ulp​()
        返回此BigDecimal的ulp（最后一个单位）的BigDecimal 。 非零的ulp BigDecimal值是该值和之间的正距离BigDecimal值下在幅度上具有相同数目的位数大。 零值的ulp在数值上等于1，刻度为this 。 结果存储的this与this相同，因此零和非零值的结果等于[1, this.scale()] 。
        结果
        尺寸为ulp的 this
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


BigInteger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.math

Class BigInteger

  • java.lang.Object
    • java.lang.Number
      • java.math.BigInteger
  • All Implemented Interfaces:
    Serializable ， Comparable<BigInteger>

    public class BigInteger
extends Number
implements Comparable<BigInteger>
    不可变的任意精度整数。 所有操作的行为就好像BigIntegers以二进制补码表示（如Java的原始整数类型）表示。 BigInteger提供了所有Java的原始整数运算符和java.lang.Math中所有相关方法的类比。 此外，BigInteger还提供了模数运算，GCD计算，原始测试，初级生成，位操作以及其他一些其他操作的操作。

    算术运算的语义完全模仿Java的整数运算符，如Java语言规范中定义的那样。 例如，除以零，抛出一个ArithmeticException ，并且一个负数除以一个正数产生负数（或零）余数。 Spec中关于溢出的所有细节都将被忽略，因为BigInteger是必要的，以适应操作的结果。

    移位操作的语义扩展了Java的移位运算符，以允许负移位距离。 具有负移位距离的右移导致左移，反之亦然。 未签名的右移位运算符（ >>> ）被省略，因为该操作与由该类提供的“无限字大小”抽象结合很少。

    按位逻辑运算的语义完全模仿Java的按位整数运算符。 二进制运算符（ and ， or ， xor ）隐式地对两个操作数的较短执行操作之前执行符号扩展。

    比较操作执行带符号的整数比较，类似于Java关系和等式运算符执行的整数比较。

    提供模块化算术运算以计算残差，执行取幂和计算乘法反转。 这些方法总是返回一个非负的结果，包括0和(modulus - 1)之间。

    位操作对其操作数的二进制补码表示的一位进行操作。 如有必要，操作数将被扩展，以便它包含指定的位。 没有一个单位操作可以产生一个BigInteger，它与正在操作的BigInteger具有不同的符号，因为它们只影响一个位，并且此类提供的“无限大小”抽象确保了无限多的“虚拟每个BigInteger之前的符号位“。

    为了简洁起见，在整个BigInteger方法的描述中都使用伪代码。 伪代码表达式(i + j)是“BigInteger的缩写，它的值是BigInteger i加上BigInteger j 。 如果且仅当BigInteger i表示与BigInteger i相同的值时，伪代码表达式(i == j)是“ true ”的j 。 类似地解释其他伪代码表达式。

    当传递任何输入参数的空对象引用时，此类中的所有方法和构造函数抛出NullPointerException 。 BigInteger必须支持-2 Integer.MAX_VALUE （排他）范围内的值到+2 Integer.MAX_VALUE （排他），并且可以支持该范围之外的值。 可能的素数值的范围是有限的，可能小于完全支持的正值范围BigInteger 。 范围必须至少为1到2.5 亿 。

    Implementation Note:
    当BigInteger构造函数和操作抛出 ArithmeticException时，结果超出了支持的范围-2 Integer.MAX_VALUE （排他）到+2 Integer.MAX_VALUE （排他）。
    从以下版本开始：
    1.1
    另请参见：
    BigDecimal ， Serialized Form
    See The Java™ Language Specification:
    4.2.2整数运算

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static BigInteger ONE
      BigInteger常数。
      static BigInteger TEN
      BigInteger常数十。
      static BigInteger TWO
      BigInteger常数二。
      static BigInteger ZERO
      BigInteger常数为零。

    • 构造方法摘要

      构造方法
      Constructor 描述
      BigInteger​(byte[] val)
      将包含BigInteger的二进制补码二进制表达式的字节数组转换为BigInteger。
      BigInteger​(byte[] val, int off, int len)
      将包含BigInteger的二进制补码二进制表示的字节子数组转换为BigInteger。
      BigInteger​(int signum, byte[] magnitude)
      将BigInteger的符号大小表示形式转换为BigInteger。
      BigInteger​(int signum, byte[] magnitude, int off, int len)
      将BigInteger的符号大小表示形式转换为BigInteger。
      BigInteger​(int bitLength, int certainty, Random rnd)
      构造一个随机生成的正BigInteger，它可能是素数，具有指定的bitLength。
      BigInteger​(int numBits, Random rnd)
      构造一个随机生成的BigInteger，均匀分布在0到（2 numBits - 1）的范围内。
      BigInteger​(String val)
      将BigInteger的十进制字符串表示形式转换为BigInteger。
      BigInteger​(String val, int radix)
      将指定基数中的BigInteger的String表示形式转换为BigInteger。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      BigInteger abs​()
      返回一个BigInteger，它的值是此BigInteger的绝对值。
      BigInteger add​(BigInteger val)
      返回值为 (this + val)的BigInteger。
      BigInteger and​(BigInteger val)
      返回值为 (this & val)的BigInteger。
      BigInteger andNot​(BigInteger val)
      返回值为 (this & ~val)的BigInteger。
      int bitCount​()
      返回与其符号位不同的BigInteger的二进制补码表示中的位数。
      int bitLength​()
      返回此BigInteger的最小二进制补码表示中的位数， 不包括符号位。
      byte byteValueExact​()
      将此 BigInteger转换为 byte ，检查丢失的信息。
      BigInteger clearBit​(int n)
      返回一个BigInteger，其值等于此BigInteger，指定的位被清零。
      int compareTo​(BigInteger val)
      将此BigInteger与指定的BigInteger进行比较。
      BigInteger divide​(BigInteger val)
      返回值为 (this / val)的BigInteger。
      BigInteger[] divideAndRemainder​(BigInteger val)
      返回两个BigInteger的数组，其中包含 (this / val)后跟 (this % val) 。
      double doubleValue​()
      将此BigInteger转换为 double 。
      boolean equals​(Object x)
      将此BigInteger与指定的对象进行比较以实现相等。
      BigInteger flipBit​(int n)
      返回一个BigInteger，其值等于此BigInteger，指定的位被翻转。
      float floatValue​()
      将此BigInteger转换为 float 。
      BigInteger gcd​(BigInteger val)
      返回一个BigInteger，其值是 abs(this)和 abs(val) 。
      int getLowestSetBit​()
      返回此BigInteger中最右（最低位）一位的索引（最右边一位右侧的零位数）。
      int hashCode​()
      返回此BigInteger的哈希码。
      int intValue​()
      将此BigInteger转换为 int 。
      int intValueExact​()
      将此 BigInteger转换为 int ，检查丢失的信息。
      boolean isProbablePrime​(int certainty)
      返回 true如果这个BigInteger可能是素数， false如果它是绝对复合的。
      long longValue​()
      将此BigInteger转换为 long 。
      long longValueExact​()
      将此 BigInteger转换为 long ，检查丢失的信息。
      BigInteger max​(BigInteger val)
      返回此BigInteger和 val 。
      BigInteger min​(BigInteger val)
      返回此BigInteger和 val 。
      BigInteger mod​(BigInteger m)
      返回值为 (this mod m的BigInteger）。
      BigInteger modInverse​(BigInteger m)
      返回值为 (this -1 mod m)的BigInteger。
      BigInteger modPow​(BigInteger exponent, BigInteger m)
      返回值为 (thisexponent mod m)的BigInteger。
      BigInteger multiply​(BigInteger val)
      返回值为 (this * val)的BigInteger。
      BigInteger negate​()
      返回值为 (-this)的BigInteger。
      BigInteger nextProbablePrime​()
      返回大于此 BigInteger的第一个整数 BigInteger 。
      BigInteger not​()
      返回值为 (~this)的BigInteger。
      BigInteger or​(BigInteger val)
      返回值为 (this | val)的BigInteger。
      BigInteger pow​(int exponent)
      返回值为 (thisexponent)的BigInteger。
      static BigInteger probablePrime​(int bitLength, Random rnd)
      返回一个正的BigInteger，它可能是素数，具有指定的位长度。
      BigInteger remainder​(BigInteger val)
      返回值为 (this % val)的BigInteger。
      BigInteger setBit​(int n)
      返回一个BigInteger，其值等于具有指定位集合的BigInteger。
      BigInteger shiftLeft​(int n)
      返回值为 (this << n)的BigInteger。
      BigInteger shiftRight​(int n)
      返回值为 (this >> n)的BigInteger。
      short shortValueExact​()
      将此 BigInteger转换为 short ，检查丢失的信息。
      int signum​()
      返回此BigInteger的signum函数。
      BigInteger sqrt​()
      返回此BigInteger的整数平方根。
      BigInteger[] sqrtAndRemainder​()
      返回两个BigInteger的数组，它们分别包含 s的整数平方根 this及其余数 this - s*s 。
      BigInteger subtract​(BigInteger val)
      返回值为 (this - val)的BigInteger。
      boolean testBit​(int n)
      当且仅当指定的位被置位时，返回 true 。
      byte[] toByteArray​()
      返回一个包含此BigInteger的二进制补码表示的字节数组。
      String toString​()
      返回此BigInteger的十进制字符串表示形式。
      String toString​(int radix)
      返回给定基数中BigInteger的String表示形式。
      static BigInteger valueOf​(long val)
      返回一个BigInteger，其值等于指定的 long 。
      BigInteger xor​(BigInteger val)
      返回值为 (this ^ val)的BigInteger。

      • Methods inherited from class java.lang.Number

        byteValue, shortValue

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ZERO

        public static final BigInteger ZERO
        BigInteger常数为零。
        从以下版本开始：
        1.2

      • ONE

        public static final BigInteger ONE
        BigInteger常数。
        从以下版本开始：
        1.2

      • TWO

        public static final BigInteger TWO
        BigInteger常数二。
        从以下版本开始：
        9

      • TEN

        public static final BigInteger TEN
        BigInteger常数十。
        从以下版本开始：
        1.5

    • 构造方法详细信息

      • BigInteger

        public BigInteger​(byte[] val,
                  int off,
                  int len)
        将包含BigInteger的二进制补码二进制表示的字节子数组转换为BigInteger。 子数组通过数组中的偏移量和长度来指定。 子阵列假定为大字节字节顺序：最高有效字节是索引号为off的元素。 假设在构造函数调用期间， val数组不变。 一个IndexOutOfBoundsException如果数组的长度被抛出val是非零的并且或者off是否定的， len为负，或者off+len比的长度大val 。
        参数
        val - 包含作为BigInteger的big-endian二进制补码二进制表示的子数组的字节数组。
        off - 二进制表示的起始偏移量。
        len - 要使用的字节数。
        异常
        NumberFormatException - val为零字节长。
        IndexOutOfBoundsException - 如果提供的数组偏移量和长度将导致字节数组中的索引为负数或大于或等于数组长度。
        从以下版本开始：
        9

      • BigInteger

        public BigInteger​(byte[] val)
        将包含BigInteger的二进制补码二进制表达式的字节数组转换为BigInteger。 输入数组被假定为大字节顺序：最高有效字节在第零个元素中。 假设在构造函数调用的持续时间内， val数组是不变的。
        参数
        val - BigInteger的big-endian二进制补码二进制表示法。
        异常
        NumberFormatException - val为零字节长。

      • BigInteger

        public BigInteger​(int signum,
                  byte[] magnitude,
                  int off,
                  int len)
        将BigInteger的符号大小表示形式转换为BigInteger。 符号表示为整数值：-1表示负数，0表示零，或表示1表示正数。 幅度是大字节序列中的字节数组的子阵列：最高有效字节是索引off处的元素。 长度为len零值是允许的，并且将导致BigInteger值为0，无论signum为-1，0还是1.在构造函数调用期间，假定magnitude数组不变。 一个IndexOutOfBoundsException如果数组的长度被抛出magnitude是非零的并且或者off是否定的， len为负，或者off+len比的长度大magnitude 。
        参数
        signum - 数字的符号（-1为负，0为零，1为正）。
        magnitude - 大端二进制表示的数量的大小。
        off - 二进制表示的起始偏移量。
        len - 要使用的字节数。
        异常
        NumberFormatException - signum不是三个合法值（-1，0和1）之一，或 signum为0，而 magnitude包含一个或多个非零字节。
        IndexOutOfBoundsException - 如果提供的数组偏移量和长度将导致字节数组中的索引为负数或大于或等于数组长度。
        从以下版本开始：
        9

      • BigInteger

        public BigInteger​(int signum,
                  byte[] magnitude)
        将BigInteger的符号大小表示形式转换为BigInteger。 符号表示为整数值：-1表示负数，0表示零，或表示1表示正数。 幅度是大字节字节顺序的字节数组：最高有效字节是第零个元素。 零长度幅度阵列是允许的，并且将导致BigInteger值为0，无论signum为-1，0还是1.在构造函数调用的持续时间内假定magnitude数组不变。
        参数
        signum - 数字的符号（-1表示负数，0表示零，1表示正数）。
        magnitude - 大端二进制表示的数量的大小。
        异常
        NumberFormatException - signum不是三个合法值（-1，0和1）中的一个，或者 signum是0，而 magnitude包含一个或多个非零字节。

      • BigInteger

        public BigInteger​(String val,
                  int radix)
        将指定基数中的BigInteger的String表示形式转换为BigInteger。 字符串表示由可选的减号或加号后面是指定基数中的一个或多个数字的序列组成。 字符到数字映射由Character.digit提供。 字符串可能不包含任何无关的字符（例如，空格）。
        参数
        val - BigInteger的字符串表示形式。
        radix - 用于解释的基数 val 。
        异常
        NumberFormatException - val不是指定基数中BigInteger的有效表示，或者 radix在 Character.MIN_RADIX到 Character.MAX_RADIX之间 ，包括在内。
        另请参见：
        Character.digit(char, int)

      • BigInteger

        public BigInteger​(String val)
        将BigInteger的十进制字符串表示形式转换为BigInteger。 字符串表示由一个可选的减号，后跟一个或多个十进制数字的序列组成。 字符到数字映射由Character.digit提供。 字符串可能不包含任何无关的字符（例如，空格）。
        参数
        val - 十进制BigInteger的字符串表示形式。
        异常
        NumberFormatException - val不是BigInteger的有效表示。
        另请参见：
        Character.digit(char, int)

      • BigInteger

        public BigInteger​(int numBits,
                  Random rnd)
        构造一个随机生成的BigInteger，均匀分布在0到（2 numBits ）的范围内。 分布的均匀性假设在rnd提供了公平的随机比特rnd 。 注意，这个构造函数总是构造一个非负的BigInteger。
        参数
        numBits - 新BigInteger的最大位长度。
        rnd - 用于计算新BigInteger的随机源。
        异常
        IllegalArgumentException - numBits为负数。
        另请参见：
        bitLength()

      • BigInteger

        public BigInteger​(int bitLength,
                  int certainty,
                  Random rnd)
        构造一个随机生成的正BigInteger，它可能是素数，具有指定的bitLength。
        API Note:
        建议使用 probablePrime方法优先于此构造函数，除非有强制性的需要指定确定性。
        参数
        bitLength - 返回的BigInteger的bitLength。
        certainty - 衡量呼叫者愿意容忍的不确定性。 新BigInteger代表素数的概率将超过（1 - 1/2 certainty ）。 该构造函数的执行时间与该参数的值成比例。
        rnd - 用于选择要测试原始候选者的随机比特来源。
        异常
        ArithmeticException - bitLength < 2或者 bitLength太大。
        另请参见：
        bitLength()

    • 方法详细信息

      • probablePrime

        public static BigInteger probablePrime​(int bitLength,
                                       Random rnd)
        返回一个正的BigInteger，它可能是素数，具有指定的位长度。 BigInteger通过此方法返回的概率是复合的不超过2 -100 。
        参数
        bitLength - 返回的BigInteger的bitLength。
        rnd - 用于选择要测试原始候选人的随机比特来源。
        结果
        一个BigInteger的 bitLength位，这可能是首要的
        异常
        ArithmeticException - bitLength < 2或 bitLength太大。
        从以下版本开始：
        1.4
        另请参见：
        bitLength()

      • nextProbablePrime

        public BigInteger nextProbablePrime​()
        返回大于这个大概素数的第一个整数BigInteger 。 此方法返回的数字的复合概率不超过2 -100 。 该方法在搜索时不会跳过素数：如果返回p ，则没有q这样this < q < p 。
        结果
        大于这个 BigInteger的第一个整数大概是素数。
        异常
        ArithmeticException - this < 0或 this太大。
        从以下版本开始：
        1.5

      • valueOf

        public static BigInteger valueOf​(long val)
        返回一个BigInteger，其值等于指定的 long 。
        API Note:
        这种静态工厂方法优先于（ long ）构造函数，因为它允许重用常用的BigInteger。
        参数
        val - 返回BigInteger的值。
        结果
        具有指定值的BigInteger。

      • add

        public BigInteger add​(BigInteger val)
        返回值为 (this + val)的BigInteger。
        参数
        val - 要添加到此BigInteger的值。
        结果
        this + val

      • subtract

        public BigInteger subtract​(BigInteger val)
        返回值为 (this - val)的BigInteger。
        参数
        val - 要从此BigInteger中减去的值。
        结果
        this - val

      • multiply

        public BigInteger multiply​(BigInteger val)
        返回值为 (this * val)的BigInteger。
        Implementation Note:
        当 val == this时，实现可以提供更好的算法性能。
        参数
        val - 要乘以此BigInteger的值。
        结果
        this * val

      • divide

        public BigInteger divide​(BigInteger val)
        返回值为 (this / val)的BigInteger。
        参数
        val - 这个BigInteger将被划分的值。
        结果
        this / val
        异常
        ArithmeticException - 如果 val为零。

      • divideAndRemainder

        public BigInteger[] divideAndRemainder​(BigInteger val)
        返回两个BigInteger的数组，其中包含 (this / val)后跟 (this % val) 。
        参数
        val - 这个BigInteger要被划分的值，其余的是计算的。
        结果
        一个两个BigIntegers的数组：商 (this / val)是初始元素，剩余的 (this % val)是最后一个元素。
        异常
        ArithmeticException - 如果 val为零。

      • remainder

        public BigInteger remainder​(BigInteger val)
        返回值为 (this % val)的BigInteger。
        参数
        val - 这个BigInteger要被划分的值，其余的是计算的。
        结果
        this % val
        异常
        ArithmeticException - 如果 val为零。

      • pow

        public BigInteger pow​(int exponent)
        返回值为(thisexponent)的BigInteger。 请注意， exponent是一个整数而不是BigInteger。
        参数
        exponent - 这个BigInteger要被引发的指数。
        结果
        thisexponent
        异常
        ArithmeticException - exponent为负数。 （这将导致操作产生一个非整数值。）

      • sqrt

        public BigInteger sqrt​()
        返回此BigInteger的整数平方根。 相应的数学整数n的整数n是最大的数学整数s ，使得s*s <= n 。 它等于的值floor(sqrt(n)) ，其中sqrt(n)表示的实平方根n作为一个真正的处理。 注意，如果后者不能表示为整数值，整数平方根将小于实数平方根。
        结果
        整数平方根为 this
        异常
        ArithmeticException - 如果this为负数。 （负整数val为(i * sqrt(-val)) ，其中i为虚数单位 ，等于sqrt(-1) ）
        从以下版本开始：
        9

      • sqrtAndRemainder

        public BigInteger[] sqrtAndRemainder​()
        返回两个BigInteger的数组，它们分别包含 s的整数平方根 this及其余数 this - s*s 。
        结果
        两个BigInteger的数组，其中偏移量为0的整数平方根，余数在偏移量为1
        异常
        ArithmeticException - 如果this为负数。 （负整数val为(i * sqrt(-val)) ，其中i为虚数单位 ，等于sqrt(-1) ）
        从以下版本开始：
        9
        另请参见：
        sqrt()

      • gcd

        public BigInteger gcd​(BigInteger val)
        返回一个BigInteger，其值是abs(this)和abs(val) 。 如果是this == 0 && val == 0返回0。
        参数
        val - 要计算GCD的值。
        结果
        GCD(abs(this), abs(val))

      • abs

        public BigInteger abs​()
        返回一个BigInteger，它的值是此BigInteger的绝对值。
        结果
        abs(this)

      • negate

        public BigInteger negate​()
        返回值为 (-this)的BigInteger。
        结果
        -this

      • signum

        public int signum​()
        返回此BigInteger的signum函数。
        结果
        -1，0或1，因为此BigInteger的值为负，为零或为正。

      • mod

        public BigInteger mod​(BigInteger m)
        返回值为(this mod m的BigInteger）。 该方法与remainder不同之处在于它总是返回一个非负的 BigInteger。
        参数
        m - 模数。
        结果
        this mod m
        异常
        ArithmeticException - m
        另请参见：
        remainder(java.math.BigInteger)

      • modPow

        public BigInteger modPow​(BigInteger exponent,
                         BigInteger m)
        返回值为(thisexponent mod m)的BigInteger。 （与pow不同，此方法允许负指数。）
        参数
        exponent - 指数。
        m - 模数。
        结果
        thisexponent mod m
        异常
        ArithmeticException - m 0或指数为负，而此BigInteger不是 m 主要 m 。
        另请参见：
        modInverse(java.math.BigInteger)

      • modInverse

        public BigInteger modInverse​(BigInteger m)
        返回一个BigInteger，其值为 (this -1 mod m) 。
        参数
        m - 模数。
        结果
        this -1 mod m 。
        异常
        ArithmeticException - m 0，或者这个BigInteger没有乘法逆模态（即，这个BigInteger不是m的 相对主要的 ）。

      • shiftLeft

        public BigInteger shiftLeft​(int n)
        返回值为(this << n)的BigInteger。 移动距离n可能为负，在这种情况下，该方法执行右移。 （计算floor(this * 2n) ）
        参数
        n - 移位距离，以位为单位。
        结果
        this << n
        另请参见：
        shiftRight(int)

      • shiftRight

        public BigInteger shiftRight​(int n)
        返回值为(this >> n)的BigInteger。 执行符号扩展。 移动距离n可能为负，在这种情况下，该方法执行左移。 （计算floor(this / 2n) ）
        参数
        n - 移位距离，以位为单位。
        结果
        this >> n
        另请参见：
        shiftLeft(int)

      • and

        public BigInteger and​(BigInteger val)
        返回值为(this & val)的BigInteger。 （这个方法返回一个负的BigInteger，当且仅当这个和val都是负的。）
        参数
        val - 值与此BigInteger进行AND val 。
        结果
        this & val

      • or

        public BigInteger or​(BigInteger val)
        返回值为(this | val)的BigInteger。 （当且仅当这个或val是负数时，此方法返回一个负的BigInteger。）
        参数
        val - 要与此BigInteger进行OR val值。
        结果
        this | val

      • xor

        public BigInteger xor​(BigInteger val)
        返回值为(this ^ val)的BigInteger。 （当且仅当这个和val中的一个为负时，该方法返回一个负的BigInteger。）
        参数
        val - 值将与此BigInteger异或。
        结果
        this ^ val

      • not

        public BigInteger not​()
        返回值为(~this)的BigInteger。 （当且仅当BigInteger为非负值时，此方法返回负值。）
        结果
        ~this

      • andNot

        public BigInteger andNot​(BigInteger val)
        返回值为(this & ~val)的BigInteger。 该方法等同于and(val.not()) ，作为掩蔽操作的便利。 （当且仅当this为负数时，此方法返回负BigInteger，而val为正）。
        参数
        val - 这个BigInteger的补充和AND的值。
        结果
        this & ~val

      • testBit

        public boolean testBit​(int n)
        当且仅当指定的位被置位时，返回true 。 （计算((this & (1<<n)) != 0) ）
        参数
        n - 要测试的位的索引。
        结果
        true当且仅当指定的位被置位时。
        异常
        ArithmeticException - n是否定的。

      • setBit

        public BigInteger setBit​(int n)
        返回一个BigInteger，其值等于具有指定位集合的BigInteger。 （计算(this | (1<<n)) ）
        参数
        n - 要设置的位的索引。
        结果
        this | (1<<n)
        异常
        ArithmeticException - n为负数。

      • clearBit

        public BigInteger clearBit​(int n)
        返回一个BigInteger，其值等于此BigInteger，指定的位被清零。 （计算(this & ~(1<<n)) ）
        参数
        n - 要清除的位的索引。
        结果
        this & ~(1<<n)
        异常
        ArithmeticException - n是否定的。

      • flipBit

        public BigInteger flipBit​(int n)
        返回一个BigInteger，其值等于此BigInteger，指定的位被翻转。 （计算(this ^ (1<<n)) ）
        参数
        n - 要翻转的位的索引。
        结果
        this ^ (1<<n)
        异常
        ArithmeticException - n为负。

      • getLowestSetBit

        public int getLowestSetBit​()
        返回此BigInteger中最右（最低位）一位的索引（最右边一位右侧的零位数）。 如果此BigInteger不包含一个位，则返回-1。 （计算(this == 0? -1 : log2(this & -this)) ）
        结果
        这个BigInteger中最右边一位的索引。

      • bitLength

        public int bitLength​()
        返回此BigInteger的最小二进制补码表示中的位数， 不包括符号位。 对于正的BigInteger，这相当于普通二进制表示中的位数。 （计算(ceil(log2(this < 0 ? -this : this+1))) ）
        结果
        该BigInteger的最小二进制补码表示中的位数， 不包括符号位。

      • bitCount

        public int bitCount​()
        返回与其符号位不同的BigInteger的二进制补码表示中的位数。 当在BigInteger上面实现位矢量样式集时，此方法非常有用。
        结果
        该BigInteger的二进制补码表示中与其符号位不同的位数。

      • isProbablePrime

        public boolean isProbablePrime​(int certainty)
        返回true如果这个BigInteger可能是素数， false如果它是绝对复合的。 如果certainty为0，则返回true 。
        参数
        certainty - 呼叫者愿意容忍的不确定性的度量：如果该呼叫返回true ，该BigInteger为素数的概率超过（1 - 1/2 certainty ）。 该方法的执行时间与该参数的值成正比。
        结果
        true如果这个BigInteger可能是素数， false如果它是绝对复合。

      • compareTo

        public int compareTo​(BigInteger val)
        将此BigInteger与指定的BigInteger进行比较。 该方法优先于六个布尔比较运算符（<，==，>，> =，！=，<=）中的每一个的各个方法。 用于执行这些比较的建议成语是： (x.compareTo(y) < op > 0) ，其中< op >是六个比较运算符之一。
        Specified by:
        compareTo在接口 Comparable<BigInteger>
        参数
        val - BigInteger要比较这个BigInteger。
        结果
        -1，0或1，因为这个BigInteger数值小于，等于或大于 val 。

      • equals

        public boolean equals​(Object x)
        将此BigInteger与指定的对象进行比较以实现相等。
        重写：
        equals在 Object
        参数
        x - 要比较BigInteger的对象。
        结果
        true如果且仅当指定的对象是BigInteger，其值在数字上等于该BigInteger。
        另请参见：
        Object.hashCode() ， HashMap

      • min

        public BigInteger min​(BigInteger val)
        返回此BigInteger和 val 。
        参数
        val - 要计算最小值的值。
        结果
        BigInteger的值是该BigInteger和val的较小者。 如果他们相等，可以退还。

      • max

        public BigInteger max​(BigInteger val)
        返回此BigInteger和 val 。
        参数
        val - 要计算最大值的值。
        结果
        BigInteger的值是这个和val的较大值。 如果他们相等，可以退还。

      • hashCode

        public int hashCode​()
        返回此BigInteger的哈希码。
        重写：
        hashCode在 Object
        结果
        这个BigInteger的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​(int radix)
        返回给定基数中BigInteger的String表示形式。 如果基数在Character.MIN_RADIX到Character.MAX_RADIX之间 ，则默认为10（如Integer.toString ）。 使用由Character.forDigit提供的数字到字符映射，如果合适，则使用减号。 （此表示与(String, int)构造函数兼容。）
        参数
        radix - 字符串表示的基数。
        结果
        此BigInteger在给定基数中的字符串表示形式。
        另请参见：
        Integer.toString(int, int) ，
Character.forDigit(int, int) ，
BigInteger(java.lang.String, int)

      • toString

        public String toString​()
        返回此BigInteger的十进制字符串表示形式。 使用Character.forDigit提供的数字到字符映射，如果合适，则添加减号。 （该表示与(String)构造函数兼容，并允许使用Java +运算符进行字符串连接。）
        重写：
        toString在 Object
        结果
        decimal这个BigInteger的字符串表示形式。
        另请参见：
        Character.forDigit(int, int) ， BigInteger(java.lang.String)

      • toByteArray

        public byte[] toByteArray​()
        返回一个包含此BigInteger的二进制补码表示的字节数组。 字节数组将以大字节顺序排列：最高字节位于第零个元素中。 该数组将包含表示此BigInteger所需的最少字节数，包括至少一个符号位，即(ceil((this.bitLength() + 1)/8)) 。 （此表示与(byte[])构造函数兼容。）
        结果
        一个包含这个BigInteger的二进制补码表示的字节数组。
        另请参见：
        BigInteger(byte[])

      • intValue

        public int intValue​()
        将此BigInteger转换为int 。 此转换类似于从一个基本收缩转换 long到int如The Java™ Language Specification定义：如果此BigInteger太大而不适合用int ，只返回低位32位。 请注意，此转换可能会丢失有关BigInteger值的总体大小的信息，并返回具有相反符号的结果。
        Specified by:
        intValue在 Number
        结果
        这个BigInteger转换为 int 。
        另请参见：
        intValueExact()
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • longValue

        public long longValue​()
        将此BigInteger转换为long 。 此转换类似于从一个基本收缩转换 long到int如The Java™ Language Specification定义：如果此BigInteger太大而不适合在一个long ，只返回低位64位。 请注意，此转换可能会丢失有关BigInteger值的总体大小的信息，并返回具有相反符号的结果。
        Specified by:
        longValue在 Number
        结果
        这个BigInteger转换为 long 。
        另请参见：
        longValueExact()
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • floatValue

        public float floatValue​()
        将此BigInteger转换为float 。 这种转换是类似于从基本收缩转换 double到float如The Java™ Language Specification定义：如果此BigInteger有太大的幅度来表示作为float ，它会被转换为Float.NEGATIVE_INFINITY或Float.POSITIVE_INFINITY适当。 请注意，即使返回值是有限的，此转换也可能丢失有关BigInteger值精度的信息。
        Specified by:
        floatValue在 Number
        结果
        这个BigInteger转换为 float 。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • doubleValue

        public double doubleValue​()
        将此BigInteger转换为double 。 这种转换是类似于从基本收缩转换 double到float如The Java™ Language Specification定义：如果此BigInteger有太大的幅度来表示作为double ，它会被转换为Double.NEGATIVE_INFINITY或Double.POSITIVE_INFINITY适当。 请注意，即使返回值是有限的，此转换也可能丢失有关BigInteger值精度的信息。
        Specified by:
        doubleValue在 Number
        结果
        这个BigInteger转换为 double 。
        See The Java™ Language Specification:
        5.1.3缩小原始转换

      • longValueExact

        public long longValueExact​()
        将此BigInteger转换为long ，检查丢失的信息。 如果这个BigInteger的值超出了long的范围，那么抛出一个ArithmeticException 。
        结果
        这个 BigInteger转换为 long 。
        异常
        ArithmeticException -如果值 this将不完全适合在 long 。
        从以下版本开始：
        1.8
        另请参见：
        longValue()

      • intValueExact

        public int intValueExact​()
        将此BigInteger转换为int ，检查丢失的信息。 如果这个BigInteger的值超出了int的范围，那么抛出一个ArithmeticException 。
        结果
        此 BigInteger转换为 int 。
        异常
        ArithmeticException -如果值 this将不完全适合在 int 。
        从以下版本开始：
        1.8
        另请参见：
        intValue()

      • shortValueExact

        public short shortValueExact​()
        将此BigInteger转换为short ，检查丢失的信息。 如果这个BigInteger的值超出了short的范围，那么抛出一个ArithmeticException 。
        结果
        这个 BigInteger转换成 short 。
        异常
        ArithmeticException -如果值 this将不完全适合在 short 。
        从以下版本开始：
        1.8
        另请参见：
        Number.shortValue()

      • byteValueExact

        public byte byteValueExact​()
        将此BigInteger转换为byte ，检查丢失的信息。 如果此BigInteger的值超出了byte类型的范围，则抛出ArithmeticException 。
        结果
        这个 BigInteger转换成 byte 。
        异常
        ArithmeticException -如果值 this将不完全适合在 byte 。
        从以下版本开始：
        1.8
        另请参见：
        Number.byteValue()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.math (Java SE 9 & JDK 9 )

java.math

Classes

  • BigDecimal
  • BigInteger
  • MathContext

Enums

  • RoundingMode


java.math (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.math

提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。 BigInteger类似于原始整数类型，除了它提供任意精度，因此对BigInteger的操作不会溢出或丢失精度。 除了标准算术运算之外， BigInteger还提供了模数运算，GCD计算，原始测试，初级生成，位操作以及其他一些杂项操作。 BigDecimal提供了适用于货币计算等的任意精度有符号的十进制数字。 BigDecimal给用户完全控制舍入行为，允许用户从全面的八种舍入模式中进行选择。
从以下版本开始：
1.1
  • 类摘要
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
    BigInteger
    不可变的任意精度整数。
    MathContext
    不可变的对象封装了描述数值算子的某些规则的上下文设置，例如由BigDecimal类实现的那些规则。
  • 枚举摘要
    Enum 描述
    RoundingMode
    指定能够丢弃精度的数值运算的 舍入行为 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.math Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.math

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.math.MathContext (implements java.io.Serializable)
    • java.lang.Number (implements java.io.Serializable)
      • java.math.BigDecimal (implements java.lang.Comparable<T>)
      • java.math.BigInteger (implements java.lang.Comparable<T>)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.math.RoundingMode
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


MathContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.math

Class MathContext

  • java.lang.Object
    • java.math.MathContext
  • All Implemented Interfaces:
    Serializable

    public final class MathContext
extends Object
implements Serializable
    封装描述数值运算符某些规则的上下文设置的不可变对象，例如由BigDecimal类实现的那些规则。

    独立于基地的设置有：

    1. precision ：用于操作的位数; 结果四舍五入到这个精度
    2. roundingMode ：一个RoundingMode对象，其指定用于舍入的算法。
    从以下版本开始：
    1.5
    另请参见：
    BigDecimal ， RoundingMode ， Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static MathContext DECIMAL128
      A MathContext对象，其精度设置与IEEE 754R Decimal128格式，34位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。
      static MathContext DECIMAL32
      A MathContext对象，其精度设置与IEEE 754R Decimal32格式，7位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。
      static MathContext DECIMAL64
      A MathContext对象，其精度设置与IEEE 754R Decimal64格式，16位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）相匹配。
      static MathContext UNLIMITED
      一个 MathContext对象，其设置具有无限精度算术所需的值。

    • 构造方法摘要

      构造方法
      Constructor 描述
      MathContext​(int setPrecision)
      构造新的 MathContext具有指定的精度和 HALF_UP舍入模式。
      MathContext​(int setPrecision, RoundingMode setRoundingMode)
      构造新的 MathContext具有指定的精度和舍入模式。
      MathContext​(String val)
      从一个字符串构造一个新的 MathContext 。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object x)
      将此 MathContext与指定的 Object进行比较以获得相等性。
      int getPrecision​()
      返回 precision设置。
      RoundingMode getRoundingMode​()
      返回roundingMode设置。
      int hashCode​()
      返回此 MathContext的哈希码。
      String toString​()
      返回此 MathContext的字符串表示 MathContext 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNLIMITED

        public static final MathContext UNLIMITED
        一个MathContext对象，其设置具有无限精度算术所需的值。 设置的值为： precision=0 roundingMode=HALF_UP

      • DECIMAL32

        public static final MathContext DECIMAL32
        A MathContext对象，具有匹配IEEE 754R Decimal32格式，7位数的精度设置和 HALF_EVEN的舍入模式，IEEE 754R默认值。

      • DECIMAL64

        public static final MathContext DECIMAL64
        A MathContext对象，其精度设置与IEEE 754R Decimal64格式，16位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。

      • DECIMAL128

        public static final MathContext DECIMAL128
        A MathContext对象，其精度设置与IEEE 754R Decimal128格式，34位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。

    • 构造方法详细信息

      • MathContext

        public MathContext​(int setPrecision)
        构造新的 MathContext具有指定的精度和 HALF_UP舍入模式。
        参数
        setPrecision - 非负 int精度设置。
        异常
        IllegalArgumentException - 如果 setPrecision参数小于零。

      • MathContext

        public MathContext​(int setPrecision,
                   RoundingMode setRoundingMode)
        构造新的 MathContext ，具有指定的精度和舍入模式。
        参数
        setPrecision - 非负 int精度设置。
        setRoundingMode - 使用的舍入模式。
        异常
        IllegalArgumentException - 如果 setPrecision参数小于零。
        NullPointerException - 如果舍入模式参数为 null

      • MathContext

        public MathContext​(String val)
        从一个字符串构造一个新的MathContext 。 字符串必须与toString()方法所生成的格式相同。

        一个IllegalArgumentException抛出如果字符串的精度部分超出范围（ < 0 ）或字符串不是在由创建的格式toString()方法。

        参数
        val - 要解析的字符串
        异常
        IllegalArgumentException - 如果精度部分超出范围或格式不正确
        NullPointerException - 如果参数是 null

    • 方法详细信息

      • getPrecision

        public int getPrecision​()
        返回precision设置。 该值始终为非负数。
        结果
        一个 int这是 precision设置的值

      • getRoundingMode

        public RoundingMode getRoundingMode​()
        返回roundingMode设置。 这将是一个RoundingMode.CEILING ， RoundingMode.DOWN ， RoundingMode.FLOOR ， RoundingMode.HALF_DOWN ， RoundingMode.HALF_EVEN ， RoundingMode.HALF_UP ， RoundingMode.UNNECESSARY ，或RoundingMode.UP 。
        结果
        一个 RoundingMode对象这是的值 roundingMode设置

      • equals

        public boolean equals​(Object x)
        将此 MathContext与指定的 Object进行比较，以获得相等性。
        重写：
        equals在 Object
        参数
        x - Object要比较这个 MathContext 。
        结果
        true如果且仅当指定的 Object是具有与此对象完全相同设置的 MathContext对象
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此 MathContext的哈希码。
        重写：
        hashCode在 Object
        结果
        这个 MathContext哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        返回此MathContext的字符串表示MathContext 。 返回的String表示MathContext对象的设置，作为两个空格分隔的单词（由单个空格字符分隔， '\u0020' ，没有前导或尾随空格），如下所示：
        1. 字符串"precision=" ，紧接着是精度设置的值作为数字字符串，就像Integer.toString方法生成一样 。
        2. 字符串"roundingMode=" ，紧随其后的值为roundingMode设置为一个字。 这个字将与RoundingMode枚举中对应的公共常量的名称相同。

        例如：

          precision=9 roundingMode=HALF_UP
        如果将更多属性添加到此类中，则可能会在未来添加toString的结果。
        重写：
        toString在 Object
        结果
        一个表示上下文设置的 String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


RoundingMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.math

Enum RoundingMode

  • java.lang.Object
    • java.lang.Enum<RoundingMode>
      • java.math.RoundingMode
  • All Implemented Interfaces:
    Serializable ， Comparable<RoundingMode>

    public enum RoundingMode
extends Enum<RoundingMode>
    指定能够丢弃精度的数值运算的舍入行为 。 每个舍入模式指示如何计算舍入结果的最低有效返回数字。 如果返回的数字少于表示确切数值结果所需的数字，则丢弃的数字将被称为丢弃的分数，而不管数字对数字值的贡献。 换句话说，被考虑为数值，被丢弃的分数可以具有大于1的绝对值。

    每个舍入模式描述包括一个表，列出了在所讨论的四舍五入模式下，不同的两位十进制值将如何舍入一位数十进制值。 表中的结果列可以通过创建具有指定值的BigDecimal号码获得，形成一个具有适当设置的MathContext对象（ precision设置为1 ，而roundingMode设置为相关舍入模式），并在此处调用round数字与正确的MathContext 。 显示所有舍入模式的这些舍入操作的结果的汇总表如下所示。

    Summary of Rounding Operations Under Different Rounding Modes Result of rounding input to one digit with the given rounding mode Input Number UP DOWN CEILING FLOOR HALF_UP HALF_DOWN HALF_EVEN UNNECESSARY 5.5 6 5 6 5 6 5 6 throw ArithmeticException 2.5 3 2 3 2 3 2 2 throw ArithmeticException 1.6 2 1 2 1 2 2 2 throw ArithmeticException 1.1 2 1 2 1 1 1 1 throw ArithmeticException 1.0 1 1 1 1 1 1 1 1 -1.0 -1 -1 -1 -1 -1 -1 -1 -1 -1.1 -2 -1 -1 -2 -1 -1 -1 throw ArithmeticException -1.6 -2 -1 -1 -2 -2 -2 -2 throw ArithmeticException -2.5 -3 -2 -2 -3 -3 -2 -2 throw ArithmeticException -5.5 -6 -5 -5 -6 -6 -5 -6 throw ArithmeticException

    此枚举旨在替换在舍入模式常量的基于整数的枚举BigDecimal （ BigDecimal.ROUND_UP ， BigDecimal.ROUND_DOWN ，等等）。

    从以下版本开始：
    1.5
    另请参见：
    BigDecimal ， MathContext

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      CEILING
      圆形模式向正无穷大转弯。
      DOWN
      舍入模式向零舍入。
      FLOOR
      舍入模式向负无穷大转弯。
      HALF_DOWN
      四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，这是倒圆的。
      HALF_EVEN
      四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，朝向偶数邻居。
      HALF_UP
      四舍五入模式向“最近邻居”转弯，除非两个邻居都是等距的，在这种情况下是圆括弧的。
      UNNECESSARY
      舍入模式来确定所请求的操作具有精确的结果，因此不需要舍入。
      UP
      舍入模式从零开始。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static RoundingMode valueOf​(int rm)
      返回RoundingMode对应于遗留整数舍入模式恒定对象BigDecimal 。
      static RoundingMode valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static RoundingMode[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UP

        public static final RoundingMode UP
        舍入模式从零开始。 始终在非零丢弃分数之前增加数字。 请注意，该舍入模式不会降低计算值的大小。

        例：

        Rounding mode UP Examples Input Number Input rounded to one digit
        with UP rounding 5.5 6 2.5 3 1.6 2 1.1 2 1.0 1 -1.0 -1 -1.1 -2 -1.6 -2 -2.5 -3 -5.5 -6

      • DOWN

        public static final RoundingMode DOWN
        舍入模式向零舍入。 不要在丢弃的分数之前递增数字（即截断）。 请注意，该舍入模式不会增加计算值的大小。

        例：

        Rounding mode DOWN Examples Input Number Input rounded to one digit
        with DOWN rounding 5.5 5 2.5 2 1.6 1 1.1 1 1.0 1 -1.0 -1 -1.1 -1 -1.6 -1 -2.5 -2 -5.5 -5

      • CEILING

        public static final RoundingMode CEILING
        圆形模式向正无穷大转弯。 如果结果为正，则表现为RoundingMode.UP ; 如果为负，表现为RoundingMode.DOWN 。 请注意，舍入模式不会降低计算值。

        例：

        Rounding mode CEILING Examples Input Number Input rounded to one digit
        with CEILING rounding 5.5 6 2.5 3 1.6 2 1.1 2 1.0 1 -1.0 -1 -1.1 -1 -1.6 -1 -2.5 -2 -5.5 -5

      • FLOOR

        public static final RoundingMode FLOOR
        舍入模式向负无穷大转弯。 如果结果为正，则表现为RoundingMode.DOWN ; 如果为负，表现为RoundingMode.UP 。 请注意，舍入模式不会增加计算值。

        例：

        Rounding mode FLOOR Examples Input Number Input rounded to one digit
        with FLOOR rounding 5.5 5 2.5 2 1.6 1 1.1 1 1.0 1 -1.0 -1 -1.1 -2 -1.6 -2 -2.5 -3 -5.5 -6

      • HALF_UP

        public static final RoundingMode HALF_UP
        四舍五入模式向“最近邻居”转弯，除非两个邻居都是等距的，在这种情况下是圆括弧的。 如果丢弃的分数为RoundingMode.UP则表示为RoundingMode.UP ; 否则，表现为RoundingMode.DOWN 。 请注意，这是通常在学校教授的舍入模式。

        例：

        Rounding mode HALF_UP Examples Input Number Input rounded to one digit
        with HALF_UP rounding 5.5 6 2.5 3 1.6 2 1.1 1 1.0 1 -1.0 -1 -1.1 -1 -1.6 -2 -2.5 -3 -5.5 -6

      • HALF_DOWN

        public static final RoundingMode HALF_DOWN
        四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，这是倒圆的。 如果丢弃的分数> 0.5，则表示为RoundingMode.UP ; 否则，表现为RoundingMode.DOWN 。

        例：

        Rounding mode HALF_DOWN Examples Input Number Input rounded to one digit
        with HALF_DOWN rounding 5.5 5 2.5 2 1.6 2 1.1 1 1.0 1 -1.0 -1 -1.1 -1 -1.6 -2 -2.5 -2 -5.5 -5

      • HALF_EVEN

        public static final RoundingMode HALF_EVEN
        四舍五入模式向“最近邻居”转弯，除非这两个邻居都是等距离的，在这种情况下，朝向偶数邻居。 对于RoundingMode.HALF_UP行为，如果丢弃的分数的左边的数字是奇数的; 像RoundingMode.HALF_DOWN如果它是RoundingMode.HALF_DOWN行为。 请注意，这是舍入模式，统计最小化在一系列计算中重复应用时的累积误差。 有时被称为“银行家四舍五入”，主要用于美国。 这种舍入模式类似于Java中用于float和double算术的舍入策略。

        例：

        Rounding mode HALF_EVEN Examples Input Number Input rounded to one digit
        with HALF_EVEN rounding 5.5 6 2.5 2 1.6 2 1.1 1 1.0 1 -1.0 -1 -1.1 -1 -1.6 -2 -2.5 -2 -5.5 -6

      • UNNECESSARY

        public static final RoundingMode UNNECESSARY
        舍入模式来确定所请求的操作具有精确的结果，因此不需要舍入。 如果在产生不精确结果的操作上指定了舍入模式，则抛出ArithmeticException 。

        例：

        Rounding mode UNNECESSARY Examples Input Number Input rounded to one digit
        with UNNECESSARY rounding 5.5 throw ArithmeticException 2.5 throw ArithmeticException 1.6 throw ArithmeticException 1.1 throw ArithmeticException 1.0 1 -1.0 -1 -1.1 throw ArithmeticException -1.6 throw ArithmeticException -2.5 throw ArithmeticException -5.5 throw ArithmeticException

    • 方法详细信息

      • values

        public static RoundingMode[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (RoundingMode c : RoundingMode.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static RoundingMode valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常数的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空

      • valueOf

        public static RoundingMode valueOf​(int rm)
        返回对应于RoundingMode中的遗留整数舍入模式常量的RoundingMode对象 。
        参数
        rm - 传统整数舍入模式进行转换
        结果
        RoundingMode对应于给定的整数。
        异常
        IllegalArgumentException - 整数超出范围
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


Uses of Package java.math (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Package
java.math

  • Packages that use java.math
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.security.cert
    提供公钥证书类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理元素和结构的类别KeyInfo 。
    javax.xml.datatype
    定义XML / Java类型映射。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括 ORB类，它被实现为使得程序员可以将其用作全功能的对象请求代理（ORB）。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。
  • Classes in java.math used by java.awt.image
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by java.math
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
    BigInteger
    不可变的任意精度整数。
    MathContext
    封装了描述数值运算符某些规则的上下文设置的不可变对象，例如由BigDecimal类实现的那些规则。
    RoundingMode
    指定能够丢弃精度的数值运算的 舍入行为 。
  • Classes in java.math used by java.security.cert
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by java.security.interfaces
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by java.security.spec
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by java.sql
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
  • Classes in java.math used by java.text
    Class 描述
    RoundingMode
    指定能够丢弃精度的数值运算的 舍入行为 。
  • Classes in java.math used by java.util
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javafx.util.converter
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javax.crypto.interfaces
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javax.crypto.spec
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javax.management.openmbean
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javax.security.cert
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javax.sql
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
  • Classes in java.math used by javax.sql.rowset
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
  • Classes in java.math used by javax.sql.rowset.serial
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
  • Classes in java.math used by javax.xml.bind
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javax.xml.crypto.dsig.keyinfo
    Class 描述
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by javax.xml.datatype
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
    BigInteger
    不可变的任意精度整数。
  • Classes in java.math used by org.omg.CORBA
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
  • Classes in java.math used by org.omg.CORBA.portable
    Class 描述
    BigDecimal
    不变的，任意精度的带符号的十进制数字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.math.BigDecimal (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.math.BigDecimal

  • Packages that use BigDecimal
    软件包 描述
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.sql
    提供使用Java编程语言访问和处理存储在数据源（通常是关系数据库）中的数据的API。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.sql
    通过Java编程语言为服务器端数据源访问和处理提供API。
    javax.sql.rowset
    JDBC RowSet实现的标准接口和基类。
    javax.sql.rowset.serial
    提供实用程序类以允许Java编程语言中的SQL类型和数据类型之间的可序列化映射。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.datatype
    定义XML / Java类型映射。
    org.omg.CORBA
    提供OMG CORBA API与Java ORB编程语言的映射，包括类别 ORB ，该类实现为程序员可以将其用作全功能对象请求代理（ORB）。
    org.omg.CORBA.portable
    提供可移植性层，即一组ORB API，使一个供应商生成的代码可以在另一个供应商的ORB上运行。

    • Uses of BigDecimal in java.math

      Fields in java.math declared as BigDecimal
      Modifier and Type Field 描述
      static BigDecimal BigDecimal.ONE
      值1，标度为0。
      static BigDecimal BigDecimal.TEN
      值为10，标度为0。
      static BigDecimal BigDecimal.ZERO
      值为0，标度为0。
      Methods in java.math that return BigDecimal
      Modifier and Type 方法 描述
      BigDecimal BigDecimal.abs​()
      返回值为 BigDecimal的绝对值的 BigDecimal ，其大小为 this.scale() 。
      BigDecimal BigDecimal.abs​(MathContext mc)
      返回一个 BigDecimal其值为此 BigDecimal的绝对值，根据上下文设置进行舍入。
      BigDecimal BigDecimal.add​(BigDecimal augend)
      返回 BigDecimal ，其值是 (this + augend) ，其标为 max(this.scale(), augend.scale()) 。
      BigDecimal BigDecimal.add​(BigDecimal augend, MathContext mc)
      返回 BigDecimal ，其值是 (this + augend) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.divide​(BigDecimal divisor)
      返回一个BigDecimal ，其值是(this / divisor) ，并且其优选的比例为(this.scale() - divisor.scale()) ; 如果确切的商不能被表示（因为它具有非终止的十进制扩展），则抛出一个ArithmeticException 。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int roundingMode)
      已过时。
      应该优先使用方法divide(BigDecimal, RoundingMode) 。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int scale, int roundingMode)
      已过时。
      应该优先使用方法divide(BigDecimal, int, RoundingMode) ，这种传统方法。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int scale, RoundingMode roundingMode)
      返回 BigDecimal ，其值是 (this / divisor) ，其标度为指定。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, MathContext mc)
      返回 BigDecimal ，其值是 (this / divisor) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, RoundingMode roundingMode)
      返回 BigDecimal ，其值是 (this / divisor) ，其标为 this.scale() 。
      BigDecimal[] BigDecimal.divideAndRemainder​(BigDecimal divisor)
      返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上的两个操作数。
      BigDecimal[] BigDecimal.divideAndRemainder​(BigDecimal divisor, MathContext mc)
      返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上与根据上下文设置进行舍入计算出的两个操作数。
      BigDecimal BigDecimal.divideToIntegralValue​(BigDecimal divisor)
      返回一个 BigDecimal其值是 (this / divisor)舍入的商 (this / divisor)的整数部分。
      BigDecimal BigDecimal.divideToIntegralValue​(BigDecimal divisor, MathContext mc)
      返回值为 BigDecimal的整数部分的 (this / divisor) 。
      BigDecimal BigDecimal.max​(BigDecimal val)
      返回此 BigDecimal和 val 。
      BigDecimal BigDecimal.min​(BigDecimal val)
      返回此 BigDecimal和 val 。
      BigDecimal BigDecimal.movePointLeft​(int n)
      返回一个 BigDecimal ，相当于这个小数点左边移动了 n地方。
      BigDecimal BigDecimal.movePointRight​(int n)
      返回一个 BigDecimal ，相当于这个小数点移动了 n地方。
      BigDecimal BigDecimal.multiply​(BigDecimal multiplicand)
      返回 BigDecimal ，其值是 (this × multiplicand) ，其标为 (this.scale() + multiplicand.scale()) 。
      BigDecimal BigDecimal.multiply​(BigDecimal multiplicand, MathContext mc)
      返回 BigDecimal ，其值是 (this × multiplicand) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.negate​()
      返回 BigDecimal ，其值是 (-this) ，其标为 this.scale() 。
      BigDecimal BigDecimal.negate​(MathContext mc)
      返回 BigDecimal ，其值是 (-this) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.plus​()
      返回 BigDecimal ，其值是 (+this) ，其标为 this.scale() 。
      BigDecimal BigDecimal.plus​(MathContext mc)
      返回 BigDecimal ，其值是 (+this) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.pow​(int n)
      返回 BigDecimal ，其值是 (thisn) ，该电源，准确计算，使其具有无限精度。
      BigDecimal BigDecimal.pow​(int n, MathContext mc)
      返回 BigDecimal ，其值是 (thisn) 。
      BigDecimal BigDecimal.remainder​(BigDecimal divisor)
      返回 BigDecimal ，其值是 (this % divisor) 。
      BigDecimal BigDecimal.remainder​(BigDecimal divisor, MathContext mc)
      返回 BigDecimal ，其值是 (this % divisor) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.round​(MathContext mc)
      返回 BigDecimal根据四舍五入 MathContext设置。
      BigDecimal BigDecimal.scaleByPowerOfTen​(int n)
      返回一个BigDecimal，其数值等于（ this * 10 n ）。
      BigDecimal BigDecimal.setScale​(int newScale)
      返回一个 BigDecimal其缩放比例是指定值，其值在数字上等于该 BigDecimal 。
      BigDecimal BigDecimal.setScale​(int newScale, int roundingMode)
      已过时。
      应该优先使用方法setScale(int, RoundingMode) ，这种传统方法。
      BigDecimal BigDecimal.setScale​(int newScale, RoundingMode roundingMode)
      返回一个 BigDecimal其缩放比例是指定值，并且其缩放值通过将该 BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。
      BigDecimal BigDecimal.sqrt​(MathContext mc)
      根据上下文设置返回近似值为 this平方根。
      BigDecimal BigDecimal.stripTrailingZeros​()
      返回一个 BigDecimal ，它在数字上等于此值，但从表示中删除任何尾随的零。
      BigDecimal BigDecimal.subtract​(BigDecimal subtrahend)
      返回 BigDecimal ，其值是 (this - subtrahend) ，其标为 max(this.scale(), subtrahend.scale()) 。
      BigDecimal BigDecimal.subtract​(BigDecimal subtrahend, MathContext mc)
      返回 BigDecimal ，其值是 (this - subtrahend) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.ulp​()
      返回此 BigDecimal的最后一个单位的ulp的大小。
      static BigDecimal BigDecimal.valueOf​(double val)
      转换一个 double成 BigDecimal ，使用 double通过所提供的规范的字符串表示 Double.toString(double)方法。
      static BigDecimal BigDecimal.valueOf​(long val)
      将 long值转换为 BigDecimal ，其大小为零。
      static BigDecimal BigDecimal.valueOf​(long unscaledVal, int scale)
      将 long值和 int标度转换为 BigDecimal 。
      Methods in java.math with parameters of type BigDecimal
      Modifier and Type 方法 描述
      BigDecimal BigDecimal.add​(BigDecimal augend)
      返回 BigDecimal ，其值是 (this + augend) ，其标为 max(this.scale(), augend.scale()) 。
      BigDecimal BigDecimal.add​(BigDecimal augend, MathContext mc)
      返回 BigDecimal ，其值是 (this + augend) ，根据上下文设置进行舍入。
      int BigDecimal.compareTo​(BigDecimal val)
      将此 BigDecimal与指定的 BigDecimal 。
      BigDecimal BigDecimal.divide​(BigDecimal divisor)
      返回一个BigDecimal ，其值是(this / divisor) ，并且其优选的比例为(this.scale() - divisor.scale()) ; 如果确切的商不能被表示（因为它具有非终止的十进制扩展），则抛出一个ArithmeticException 。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int roundingMode)
      已过时。
      应该优先使用方法divide(BigDecimal, RoundingMode) 。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int scale, int roundingMode)
      已过时。
      应该优先使用方法divide(BigDecimal, int, RoundingMode) 。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int scale, RoundingMode roundingMode)
      返回 BigDecimal ，其值是 (this / divisor) ，其标度为指定。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, MathContext mc)
      返回 BigDecimal ，其值是 (this / divisor) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, RoundingMode roundingMode)
      返回 BigDecimal ，其值是 (this / divisor) ，其标为 this.scale() 。
      BigDecimal[] BigDecimal.divideAndRemainder​(BigDecimal divisor)
      返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上的两个操作数。
      BigDecimal[] BigDecimal.divideAndRemainder​(BigDecimal divisor, MathContext mc)
      返回一个包含 BigDecimal的结果的二元素 BigDecimal ， divideToIntegralValue跟随根据上下文设置舍入计算的两个操作数的 remainder的结果。
      BigDecimal BigDecimal.divideToIntegralValue​(BigDecimal divisor)
      返回一个 BigDecimal它的值是商品 (this / divisor)的整数部分 (this / divisor)取整。
      BigDecimal BigDecimal.divideToIntegralValue​(BigDecimal divisor, MathContext mc)
      返回值为 BigDecimal的整数部分的 (this / divisor) 。
      BigDecimal BigDecimal.max​(BigDecimal val)
      返回此 BigDecimal和 val 。
      BigDecimal BigDecimal.min​(BigDecimal val)
      返回此 BigDecimal和 val 。
      BigDecimal BigDecimal.multiply​(BigDecimal multiplicand)
      返回 BigDecimal ，其值是 (this × multiplicand) ，其标为 (this.scale() + multiplicand.scale()) 。
      BigDecimal BigDecimal.multiply​(BigDecimal multiplicand, MathContext mc)
      返回 BigDecimal ，其值是 (this × multiplicand) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.remainder​(BigDecimal divisor)
      返回 BigDecimal ，其值是 (this % divisor) 。
      BigDecimal BigDecimal.remainder​(BigDecimal divisor, MathContext mc)
      返回 BigDecimal ，其值是 (this % divisor) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.subtract​(BigDecimal subtrahend)
      返回 BigDecimal ，其值是 (this - subtrahend) ，其标为 max(this.scale(), subtrahend.scale()) 。
      BigDecimal BigDecimal.subtract​(BigDecimal subtrahend, MathContext mc)
      返回 BigDecimal ，其值是 (this - subtrahend) ，根据上下文设置进行舍入。

    • Uses of BigDecimal in java.sql

      Methods in java.sql that return BigDecimal
      Modifier and Type 方法 描述
      BigDecimal CallableStatement.getBigDecimal​(int parameterIndex)
      将指定的JDBC NUMERIC参数的值作为 java.math.BigDecimal对象 NUMERIC ，该对象的值包含小数点右侧的位数。
      BigDecimal CallableStatement.getBigDecimal​(int parameterIndex, int scale)
      已过时。
      使用getBigDecimal(int parameterIndex)或getBigDecimal(String parameterName)
      BigDecimal CallableStatement.getBigDecimal​(String parameterName)
      检索JDBC NUMERIC参数的值作为 java.math.BigDecimal对象，其值包含小数点右侧的数字。
      BigDecimal ResultSet.getBigDecimal​(int columnIndex)
      在 ResultSet对象的当前行中指定列的值作为 java.math.BigDecimal以完全精确的方式获取。
      BigDecimal ResultSet.getBigDecimal​(int columnIndex, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      BigDecimal ResultSet.getBigDecimal​(String columnLabel)
      在 ResultSet对象的当前行中指定列的值作为 java.math.BigDecimal以完全精确的方式获取。
      BigDecimal ResultSet.getBigDecimal​(String columnLabel, int scale)
      已过时。
      使用getBigDecimal(int columnIndex)或getBigDecimal(String columnLabel)
      BigDecimal SQLInput.readBigDecimal​()
      读取流中的下一个属性，并将其作为Java编程语言中的一个 java.math.BigDecimal对象返回。
      Methods in java.sql with parameters of type BigDecimal
      Modifier and Type 方法 描述
      void CallableStatement.setBigDecimal​(String parameterName, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      void PreparedStatement.setBigDecimal​(int parameterIndex, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。
      void ResultSet.updateBigDecimal​(int columnIndex, BigDecimal x)
      使用 java.math.BigDecimal值更新指定的列。
      void ResultSet.updateBigDecimal​(String columnLabel, BigDecimal x)
      使用 java.sql.BigDecimal值更新指定的列。
      void SQLOutput.writeBigDecimal​(BigDecimal x)
      将下一个属性作为java.math.BigDecimal对象写入流。

    • Uses of BigDecimal in java.util

      Methods in java.util that return BigDecimal
      Modifier and Type 方法 描述
      BigDecimal Scanner.nextBigDecimal​()
      将输入的下一个标记扫描为BigDecimal 。

    • Uses of BigDecimal in javafx.util.converter

      Methods in javafx.util.converter that return BigDecimal
      Modifier and Type 方法 描述
      BigDecimal BigDecimalStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type BigDecimal
      Modifier and Type 方法 描述
      String BigDecimalStringConverter.toString​(BigDecimal value)
      将提供的对象转换为其字符串形式。

    • Uses of BigDecimal in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type BigDecimal
      Modifier and Type Field 描述
      static SimpleType<BigDecimal> SimpleType.BIGDECIMAL
      描述Java类名称为 java.math.BigDecimal值的 SimpleType实例。

    • Uses of BigDecimal in javax.sql

      Methods in javax.sql with parameters of type BigDecimal
      Modifier and Type 方法 描述
      void RowSet.setBigDecimal​(int parameterIndex, BigDecimal x)
      将此 RowSet对象的命令中的指定参数设置为给定的 java.math.BigDecimal值。
      void RowSet.setBigDecimal​(String parameterName, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。

    • Uses of BigDecimal in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type BigDecimal
      Modifier and Type 方法 描述
      void BaseRowSet.setBigDecimal​(int parameterIndex, BigDecimal x)
      将指定的参数设置为给定的 java.lang.BigDecimal值。
      void BaseRowSet.setBigDecimal​(String parameterName, BigDecimal x)
      将指定的参数设置为给定的 java.math.BigDecimal值。

    • Uses of BigDecimal in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that return BigDecimal
      Modifier and Type 方法 描述
      BigDecimal SQLInputImpl.readBigDecimal​()
      检索此 SQLInputImpl对象中的下一个属性为 java.math.BigDecimal 。
      Methods in javax.sql.rowset.serial with parameters of type BigDecimal
      Modifier and Type 方法 描述
      void SQLOutputImpl.writeBigDecimal​(BigDecimal x)
      将Java编程语言中的一个 java.math.BigDecimal对象写入此 SQLOutputImpl对象。

    • Uses of BigDecimal in javax.xml.bind

      Methods in javax.xml.bind that return BigDecimal
      Modifier and Type 方法 描述
      static BigDecimal DatatypeConverter.parseDecimal​(String lexicalXSDDecimal)
      将字符串参数转换为BigDecimal值。
      BigDecimal DatatypeConverterInterface.parseDecimal​(String lexicalXSDDecimal)
      将字符串参数转换为BigDecimal值。
      Methods in javax.xml.bind with parameters of type BigDecimal
      Modifier and Type 方法 描述
      static String DatatypeConverter.printDecimal​(BigDecimal val)
      将BigDecimal值转换为字符串。
      String DatatypeConverterInterface.printDecimal​(BigDecimal val)
      将BigDecimal值转换为字符串。

    • Uses of BigDecimal in javax.xml.datatype

      Methods in javax.xml.datatype that return BigDecimal
      Modifier and Type 方法 描述
      abstract BigDecimal XMLGregorianCalendar.getFractionalSecond​()
      返回小数秒。
      Methods in javax.xml.datatype with parameters of type BigDecimal
      Modifier and Type 方法 描述
      abstract Duration Duration.multiply​(BigDecimal factor)
      计算一个新的持续时间，其值是该持续时间的值的 factor倍。
      abstract Duration DatatypeFactory.newDuration​(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)
      获取一个新的 Duration实例，指定 Duration为isPositive，年，月，日，小时，分钟，秒。
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar​(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone)
      允许W3C XML Schema 1.0允许的完整值空间的构造方法，用于xsd：dateTime和相关的内置数据类型。
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarTime​(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone)
      创建XML Schema内置数据类型时间的Java实例。
      abstract void XMLGregorianCalendar.setFractionalSecond​(BigDecimal fractional)
      设置小数秒。
      void XMLGregorianCalendar.setTime​(int hour, int minute, int second, BigDecimal fractional)
      将时间设置为一个单位，包括可选的无限精度小数秒。

    • Uses of BigDecimal in org.omg.CORBA

      Fields in org.omg.CORBA declared as BigDecimal
      Modifier and Type Field 描述
      BigDecimal FixedHolder.value
      FixedHolder持有的值
      Methods in org.omg.CORBA that return BigDecimal
      Modifier and Type 方法 描述
      BigDecimal Any.extract_fixed​()
      提取 java.math.BigDecimal在这个对象 Any对象 value场。
      Methods in org.omg.CORBA with parameters of type BigDecimal
      Modifier and Type 方法 描述
      void Any.insert_fixed​(BigDecimal value)
      抛出一个 org.omg.CORBA.NO_IMPLEMENT例外。
      void Any.insert_fixed​(BigDecimal value, TypeCode type)
      抛出一个 org.omg.CORBA.NO_IMPLEMENT异常。
      Constructors in org.omg.CORBA with parameters of type BigDecimal
      Constructor 描述
      FixedHolder​(BigDecimal initial)
      构造FixedHolder并用给定的值初始化它。

    • Uses of BigDecimal in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return BigDecimal
      Modifier and Type 方法 描述
      BigDecimal InputStream.read_fixed​()
      读取一个BigDecimal数字。
      Methods in org.omg.CORBA.portable with parameters of type BigDecimal
      Modifier and Type 方法 描述
      void OutputStream.write_fixed​(BigDecimal value)
      写入一个BigDecimal数字。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.math.BigInteger (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.math.BigInteger

  • Packages that use BigInteger
    软件包 描述
    java.awt.image
    提供创建和修改图像的类。
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.security.cert
    提供用于解析和管理证书，证书撤销列表（CRL）和认证路径的类和接口。
    java.security.interfaces
    提供用于生成RSA实验室技术说明PKCS＃1中定义的RSA（Rivest，Shamir和Adleman非对称密码算法）密钥以及NIST FIPS-186中定义的DSA（数字签名算法）密钥的接口。
    java.security.spec
    提供关键规范和算法参数规范的类和接口。
    java.util
    包含集合框架，一些国际化支持类，一个服务加载器，属性，随机数生成，字符串解析和扫描类，base64编码和解码，一个位数组和几个其他实用程序类。
    javafx.util.converter
    此包用于JavaFX的标准字符串转换器。
    javax.crypto.interfaces
    提供RSA实验室PKCS＃3中定义的Diffie-Hellman密钥的接口。
    javax.crypto.spec
    提供关键规范和算法参数规范的类和接口。
    javax.management.openmbean
    提供打开的数据类型和Open MBean描述符类。
    javax.security.cert
    提供公钥证书类。
    javax.xml.bind
    为客户端应用程序提供运行时绑定框架，包括解组，编组和验证功能。
    javax.xml.crypto.dsig.keyinfo
    用于解析和处理元素和结构的类别KeyInfo 。
    javax.xml.datatype
    定义XML / Java类型映射。

    • Uses of BigInteger in java.awt.image

      Methods in java.awt.image that return BigInteger
      Modifier and Type 方法 描述
      BigInteger IndexColorModel.getValidPixels​()
      返回一个 BigInteger ，表示 BigInteger映射中有效/无效的像素。
      Constructors in java.awt.image with parameters of type BigInteger
      Constructor 描述
      IndexColorModel​(int bits, int size, int[] cmap, int start, int transferType, BigInteger validBits)
      从 int阵列构造一个 IndexColorModel ，其中每个 int由默认RGB颜色模型格式的红色，绿色，蓝色和Alpha组件组成。

    • Uses of BigInteger in java.math

      Fields in java.math declared as BigInteger
      Modifier and Type Field 描述
      static BigInteger BigInteger.ONE
      BigInteger常数。
      static BigInteger BigInteger.TEN
      BigInteger常数十。
      static BigInteger BigInteger.TWO
      BigInteger常数二。
      static BigInteger BigInteger.ZERO
      BigInteger常数为零。
      Methods in java.math that return BigInteger
      Modifier and Type 方法 描述
      BigInteger BigInteger.abs​()
      返回一个BigInteger，它的值是此BigInteger的绝对值。
      BigInteger BigInteger.add​(BigInteger val)
      返回值为 (this + val)的BigInteger。
      BigInteger BigInteger.and​(BigInteger val)
      返回值为 (this & val)的BigInteger。
      BigInteger BigInteger.andNot​(BigInteger val)
      返回值为 (this & ~val)的BigInteger。
      BigInteger BigInteger.clearBit​(int n)
      返回一个BigInteger，其值等于此BigInteger，指定的位被清零。
      BigInteger BigInteger.divide​(BigInteger val)
      返回值为 (this / val)的BigInteger。
      BigInteger[] BigInteger.divideAndRemainder​(BigInteger val)
      返回两个BigInteger的数组，其中包含 (this / val)后跟 (this % val) 。
      BigInteger BigInteger.flipBit​(int n)
      返回一个BigInteger，其值等于此BigInteger，指定的位被翻转。
      BigInteger BigInteger.gcd​(BigInteger val)
      返回一个BigInteger，其值是 abs(this)和 abs(val) 。
      BigInteger BigInteger.max​(BigInteger val)
      返回此BigInteger和 val 。
      BigInteger BigInteger.min​(BigInteger val)
      返回此BigInteger和 val 。
      BigInteger BigInteger.mod​(BigInteger m)
      返回值为 (this mod m的BigInteger）。
      BigInteger BigInteger.modInverse​(BigInteger m)
      返回值为 (this -1的BigInteger mod m) 。
      BigInteger BigInteger.modPow​(BigInteger exponent, BigInteger m)
      返回值为 (thisexponent mod m)的BigInteger。
      BigInteger BigInteger.multiply​(BigInteger val)
      返回值为 (this * val)的BigInteger。
      BigInteger BigInteger.negate​()
      返回值为 (-this)的BigInteger。
      BigInteger BigInteger.nextProbablePrime​()
      返回大于此 BigInteger的第一个整数 BigInteger 。
      BigInteger BigInteger.not​()
      返回值为 (~this)的BigInteger。
      BigInteger BigInteger.or​(BigInteger val)
      返回值为 (this | val)的BigInteger。
      BigInteger BigInteger.pow​(int exponent)
      返回值为 (thisexponent)的BigInteger。
      static BigInteger BigInteger.probablePrime​(int bitLength, Random rnd)
      返回一个正的BigInteger，它可能是素数，具有指定的位长度。
      BigInteger BigInteger.remainder​(BigInteger val)
      返回值为 (this % val)的BigInteger。
      BigInteger BigInteger.setBit​(int n)
      返回一个BigInteger，其值等于具有指定位集合的BigInteger。
      BigInteger BigInteger.shiftLeft​(int n)
      返回值为 (this << n)的BigInteger。
      BigInteger BigInteger.shiftRight​(int n)
      返回值为 (this >> n)的BigInteger。
      BigInteger BigInteger.sqrt​()
      返回此BigInteger的整数平方根。
      BigInteger[] BigInteger.sqrtAndRemainder​()
      返回两个BigIntegers的数组，它们分别包含 s的整数平方根 this及其余数 this - s*s 。
      BigInteger BigInteger.subtract​(BigInteger val)
      返回值为 (this - val)的BigInteger。
      BigInteger BigDecimal.toBigInteger​()
      将此 BigDecimal转换为 BigInteger 。
      BigInteger BigDecimal.toBigIntegerExact​()
      将此 BigDecimal转换为 BigInteger ，检查丢失的信息。
      BigInteger BigDecimal.unscaledValue​()
      返回一个 BigInteger其值是此 BigDecimal的未 缩放值 。
      static BigInteger BigInteger.valueOf​(long val)
      返回一个BigInteger，其值等于指定的 long 。
      BigInteger BigInteger.xor​(BigInteger val)
      返回值为 (this ^ val)的BigInteger。
      Methods in java.math with parameters of type BigInteger
      Modifier and Type 方法 描述
      BigInteger BigInteger.add​(BigInteger val)
      返回值为 (this + val)的BigInteger。
      BigInteger BigInteger.and​(BigInteger val)
      返回值为 (this & val)的BigInteger。
      BigInteger BigInteger.andNot​(BigInteger val)
      返回值为 (this & ~val)的BigInteger。
      int BigInteger.compareTo​(BigInteger val)
      将此BigInteger与指定的BigInteger进行比较。
      BigInteger BigInteger.divide​(BigInteger val)
      返回值为 (this / val)的BigInteger。
      BigInteger[] BigInteger.divideAndRemainder​(BigInteger val)
      返回两个BigInteger的数组，其中包含 (this / val)后跟 (this % val) 。
      BigInteger BigInteger.gcd​(BigInteger val)
      返回一个BigInteger，其值是 abs(this)和 abs(val) 。
      BigInteger BigInteger.max​(BigInteger val)
      返回此BigInteger和 val 。
      BigInteger BigInteger.min​(BigInteger val)
      返回此BigInteger和 val 。
      BigInteger BigInteger.mod​(BigInteger m)
      返回值为 (this mod m的BigInteger）。
      BigInteger BigInteger.modInverse​(BigInteger m)
      返回值为 (this -1 mod m)的BigInteger。
      BigInteger BigInteger.modPow​(BigInteger exponent, BigInteger m)
      返回值为 (thisexponent mod m)的BigInteger。
      BigInteger BigInteger.multiply​(BigInteger val)
      返回值为 (this * val)的BigInteger。
      BigInteger BigInteger.or​(BigInteger val)
      返回值为 (this | val)的BigInteger。
      BigInteger BigInteger.remainder​(BigInteger val)
      返回值为 (this % val)的BigInteger。
      BigInteger BigInteger.subtract​(BigInteger val)
      返回值为 (this - val)的BigInteger。
      BigInteger BigInteger.xor​(BigInteger val)
      返回值为 (this ^ val)的BigInteger。
      Constructors in java.math with parameters of type BigInteger
      Constructor 描述
      BigDecimal​(BigInteger val)
      将 BigInteger翻译成 BigDecimal 。
      BigDecimal​(BigInteger unscaledVal, int scale)
      将 BigInteger标度值和 int刻度转换为 BigDecimal 。
      BigDecimal​(BigInteger unscaledVal, int scale, MathContext mc)
      将 BigInteger缩放值和 int刻度转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(BigInteger val, MathContext mc)
      根据上下文设置将 BigInteger转换为 BigDecimal舍入。

    • Uses of BigInteger in java.security.cert

      Methods in java.security.cert that return BigInteger
      Modifier and Type 方法 描述
      BigInteger X509CRLSelector.getMaxCRL​()
      返回maxCRLNumber标准。
      BigInteger X509CRLSelector.getMinCRL​()
      返回minCRLNumber标准。
      abstract BigInteger X509Certificate.getSerialNumber​()
      从证书中获得 serialNumber价值。
      BigInteger X509CertSelector.getSerialNumber​()
      返回serialNumber标准。
      abstract BigInteger X509CRLEntry.getSerialNumber​()
      从这个X509CRLEntry， userCertificate获取序列号。
      Methods in java.security.cert with parameters of type BigInteger
      Modifier and Type 方法 描述
      abstract X509CRLEntry X509CRL.getRevokedCertificate​(BigInteger serialNumber)
      获取给定证书serialNumber的CRL条目（如果有）。
      void X509CRLSelector.setMaxCRLNumber​(BigInteger maxCRL)
      设置maxCRLNumber标准。
      void X509CRLSelector.setMinCRLNumber​(BigInteger minCRL)
      设置minCRLNumber标准。
      void X509CertSelector.setSerialNumber​(BigInteger serial)
      设置serialNumber标准。

    • Uses of BigInteger in java.security.interfaces

      Methods in java.security.interfaces that return BigInteger
      Modifier and Type 方法 描述
      BigInteger RSAMultiPrimePrivateCrtKey.getCrtCoefficient​()
      返回crtCoefficient。
      BigInteger RSAPrivateCrtKey.getCrtCoefficient​()
      返回crtCoefficient。
      BigInteger DSAParams.getG​()
      返回基地， g 。
      BigInteger RSAKey.getModulus​()
      返回模数。
      BigInteger DSAParams.getP​()
      返回素数， p 。
      BigInteger RSAMultiPrimePrivateCrtKey.getPrimeExponentP​()
      返回primeExponentP。
      BigInteger RSAPrivateCrtKey.getPrimeExponentP​()
      返回primeExponentP。
      BigInteger RSAMultiPrimePrivateCrtKey.getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger RSAPrivateCrtKey.getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger RSAMultiPrimePrivateCrtKey.getPrimeP​()
      返回primeP。
      BigInteger RSAPrivateCrtKey.getPrimeP​()
      返回primeP。
      BigInteger RSAMultiPrimePrivateCrtKey.getPrimeQ​()
      返回primeQ。
      BigInteger RSAPrivateCrtKey.getPrimeQ​()
      返回primeQ。
      BigInteger RSAPrivateKey.getPrivateExponent​()
      返回私有指数。
      BigInteger RSAMultiPrimePrivateCrtKey.getPublicExponent​()
      返回公共指数。
      BigInteger RSAPrivateCrtKey.getPublicExponent​()
      返回公共指数。
      BigInteger RSAPublicKey.getPublicExponent​()
      返回公共指数。
      BigInteger DSAParams.getQ​()
      返回次贷， q 。
      BigInteger ECPrivateKey.getS​()
      返回私有值S.
      BigInteger DSAPrivateKey.getX​()
      返回私钥的值， x 。
      BigInteger DSAPublicKey.getY​()
      返回公钥的值， y 。

    • Uses of BigInteger in java.security.spec

      Fields in java.security.spec declared as BigInteger
      Modifier and Type Field 描述
      static BigInteger RSAKeyGenParameterSpec.F0
      公众指数值F0 = 3。
      static BigInteger RSAKeyGenParameterSpec.F4
      公共指数值F4 = 65537。
      Methods in java.security.spec that return BigInteger
      Modifier and Type 方法 描述
      BigInteger EllipticCurve.getA​()
      返回椭圆曲线的第一个系数 a 。
      BigInteger ECPoint.getAffineX​()
      返回仿射x坐标 x 。
      BigInteger ECPoint.getAffineY​()
      返回仿射y坐标 y 。
      BigInteger EllipticCurve.getB​()
      返回椭圆曲线的第二个系数 b 。
      BigInteger RSAMultiPrimePrivateCrtKeySpec.getCrtCoefficient​()
      返回crtCoefficient。
      BigInteger RSAOtherPrimeInfo.getCrtCoefficient​()
      返回素数的crtCoefficient。
      BigInteger RSAPrivateCrtKeySpec.getCrtCoefficient​()
      返回crtCoefficient。
      BigInteger RSAOtherPrimeInfo.getExponent​()
      返回素数的指数。
      BigInteger DSAParameterSpec.getG​()
      返回底座 g 。
      BigInteger DSAPrivateKeySpec.getG​()
      返回底座 g 。
      BigInteger DSAPublicKeySpec.getG​()
      返回底座 g 。
      BigInteger RSAPrivateKeySpec.getModulus​()
      返回模数。
      BigInteger RSAPublicKeySpec.getModulus​()
      返回模数。
      BigInteger ECParameterSpec.getOrder​()
      返回发生器的顺序。
      BigInteger DSAParameterSpec.getP​()
      退货 p 。
      BigInteger DSAPrivateKeySpec.getP​()
      退货 p 。
      BigInteger DSAPublicKeySpec.getP​()
      返回素数 p 。
      BigInteger ECFieldFp.getP​()
      返回这个主要有限域的素数 p 。
      BigInteger RSAOtherPrimeInfo.getPrime​()
      返回素数。
      BigInteger RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentP​()
      返回primeExponentP。
      BigInteger RSAPrivateCrtKeySpec.getPrimeExponentP​()
      返回primeExponentP。
      BigInteger RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger RSAPrivateCrtKeySpec.getPrimeExponentQ​()
      返回primeExponentQ。
      BigInteger RSAMultiPrimePrivateCrtKeySpec.getPrimeP​()
      返回primeP。
      BigInteger RSAPrivateCrtKeySpec.getPrimeP​()
      返回primeP。
      BigInteger RSAMultiPrimePrivateCrtKeySpec.getPrimeQ​()
      返回primeQ。
      BigInteger RSAPrivateCrtKeySpec.getPrimeQ​()
      返回primeQ。
      BigInteger RSAPrivateKeySpec.getPrivateExponent​()
      返回私有指数。
      BigInteger RSAKeyGenParameterSpec.getPublicExponent​()
      返回public-exponent值。
      BigInteger RSAMultiPrimePrivateCrtKeySpec.getPublicExponent​()
      返回公共指数。
      BigInteger RSAPrivateCrtKeySpec.getPublicExponent​()
      返回公共指数。
      BigInteger RSAPublicKeySpec.getPublicExponent​()
      返回公共指数。
      BigInteger DSAParameterSpec.getQ​()
      返回次级 q 。
      BigInteger DSAPrivateKeySpec.getQ​()
      返回子素数 q 。
      BigInteger DSAPublicKeySpec.getQ​()
      返回子素数 q 。
      BigInteger ECFieldF2m.getReductionPolynomial​()
      返回一个BigInteger，其第i个位对应于多项式基础的缩小多项式的第i个系数，或者为正常值，返回null。
      BigInteger ECPrivateKeySpec.getS​()
      返回私有值S.
      BigInteger DSAPrivateKeySpec.getX​()
      返回私钥 x 。
      BigInteger DSAPublicKeySpec.getY​()
      返回公钥 y 。
      Constructors in java.security.spec with parameters of type BigInteger
      Constructor 描述
      DSAParameterSpec​(BigInteger p, BigInteger q, BigInteger g)
      使用指定的参数值创建新的DSAParameterSpec。
      DSAPrivateKeySpec​(BigInteger x, BigInteger p, BigInteger q, BigInteger g)
      用指定的参数值创建一个新的DSAPrivateKeySpec。
      DSAPublicKeySpec​(BigInteger y, BigInteger p, BigInteger q, BigInteger g)
      用指定的参数值创建一个新的DSAPublicKeySpec。
      ECFieldF2m​(int m, BigInteger rp)
      创建椭圆曲线特征2有限域，其具有多项式基础的2 ^ m元素。
      ECFieldFp​(BigInteger p)
      创建具有指定素数的椭圆曲线初始有限域 p 。
      ECParameterSpec​(EllipticCurve curve, ECPoint g, BigInteger n, int h)
      根据指定的值创建椭圆曲线域参数。
      ECPoint​(BigInteger x, BigInteger y)
      从指定的仿射x坐标 x和仿射y坐标 y创建一个 y 。
      ECPrivateKeySpec​(BigInteger s, ECParameterSpec params)
      用指定的参数值创建一个新的ECPrivateKeySpec。
      EllipticCurve​(ECField field, BigInteger a, BigInteger b)
      创建具有指定的椭圆场 field和系数 a和 b的椭圆曲线。
      EllipticCurve​(ECField field, BigInteger a, BigInteger b, byte[] seed)
      创建具有指定的椭圆场 field ，系数 a和 b以及用于曲线生成的 seed的椭圆曲线。
      RSAKeyGenParameterSpec​(int keysize, BigInteger publicExponent)
      从给定的keysize和public-exponent值构造一个新的 RSAParameterSpec对象。
      RSAMultiPrimePrivateCrtKeySpec​(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
      创建一个新的 RSAMultiPrimePrivateCrtKeySpec给定在PKCS＃1 v2.1中定义的模数，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ，crtCoefficient和otherPrimeInfo。
      RSAOtherPrimeInfo​(BigInteger prime, BigInteger primeExponent, BigInteger crtCoefficient)
      创建一个新的 RSAOtherPrimeInfo给定在PKCS＃1中定义的素数，primeExponent和crtCoefficient。
      RSAPrivateCrtKeySpec​(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient)
      创建一个新的 RSAPrivateCrtKeySpec给定在PKCS＃1中定义的模数，publicExponent，privateExponent，primeP，primeQ，primeExponentP，primeExponentQ和crtCoefficient。
      RSAPrivateKeySpec​(BigInteger modulus, BigInteger privateExponent)
      创建一个新的RSAPrivateKeySpec。
      RSAPublicKeySpec​(BigInteger modulus, BigInteger publicExponent)
      创建一个新的RSAPublicKeySpec。

    • Uses of BigInteger in java.util

      Methods in java.util that return BigInteger
      Modifier and Type 方法 描述
      BigInteger Scanner.nextBigInteger​()
      将输入的下一个标记扫描为BigInteger 。
      BigInteger Scanner.nextBigInteger​(int radix)
      将输入的下一个标记扫描为BigInteger 。

    • Uses of BigInteger in javafx.util.converter

      Methods in javafx.util.converter that return BigInteger
      Modifier and Type 方法 描述
      BigInteger BigIntegerStringConverter.fromString​(String value)
      将提供的字符串转换为由特定转换器定义的对象。
      Methods in javafx.util.converter with parameters of type BigInteger
      Modifier and Type 方法 描述
      String BigIntegerStringConverter.toString​(BigInteger value)
      将提供的对象转换为其字符串形式。

    • Uses of BigInteger in javax.crypto.interfaces

      Methods in javax.crypto.interfaces that return BigInteger
      Modifier and Type 方法 描述
      BigInteger DHPrivateKey.getX​()
      返回私有值， x 。
      BigInteger DHPublicKey.getY​()
      返回公共值， y 。

    • Uses of BigInteger in javax.crypto.spec

      Methods in javax.crypto.spec that return BigInteger
      Modifier and Type 方法 描述
      BigInteger DHParameterSpec.getG​()
      返回基本生成器 g 。
      BigInteger DHPrivateKeySpec.getG​()
      返回基本生成器 g 。
      BigInteger DHPublicKeySpec.getG​()
      返回基本生成器 g 。
      BigInteger DHParameterSpec.getP​()
      返回质数模数 p 。
      BigInteger DHPrivateKeySpec.getP​()
      返回素数模数 p 。
      BigInteger DHPublicKeySpec.getP​()
      返回质数模数 p 。
      BigInteger DHPrivateKeySpec.getX​()
      返回私有值 x 。
      BigInteger DHPublicKeySpec.getY​()
      返回公开值 y 。
      Constructors in javax.crypto.spec with parameters of type BigInteger
      Constructor 描述
      DHParameterSpec​(BigInteger p, BigInteger g)
      使用质数模数 p和基本生成器 g构造Diffie-Hellman的参数集。
      DHParameterSpec​(BigInteger p, BigInteger g, int l)
      使用素数 p ，基本产生器 g和随机指数（私有值）的大小（ l构造Diffie-Hellman的参数集。
      DHPrivateKeySpec​(BigInteger x, BigInteger p, BigInteger g)
      具有私有值 x ，素数模数 p和基本生成器 g 。
      DHPublicKeySpec​(BigInteger y, BigInteger p, BigInteger g)
      具有公开值 y ，质数模数 p和基本生成器 g 。

    • Uses of BigInteger in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type BigInteger
      Modifier and Type Field 描述
      static SimpleType<BigInteger> SimpleType.BIGINTEGER
      描述Java类名称为 java.math.BigInteger值的 SimpleType实例。

    • Uses of BigInteger in javax.security.cert

      Methods in javax.security.cert that return BigInteger
      Modifier and Type 方法 描述
      abstract BigInteger X509Certificate.getSerialNumber​()
      已过时。
      从证书中获取 serialNumber值。

    • Uses of BigInteger in javax.xml.bind

      Methods in javax.xml.bind that return BigInteger
      Modifier and Type 方法 描述
      static BigInteger DatatypeConverter.parseInteger​(String lexicalXSDInteger)
      将字符串参数转换为BigInteger值。
      BigInteger DatatypeConverterInterface.parseInteger​(String lexicalXSDInteger)
      将字符串参数转换为BigInteger值。
      Methods in javax.xml.bind with parameters of type BigInteger
      Modifier and Type 方法 描述
      static String DatatypeConverter.printInteger​(BigInteger val)
      将BigInteger值转换为字符串。
      String DatatypeConverterInterface.printInteger​(BigInteger val)
      将BigInteger值转换为字符串。

    • Uses of BigInteger in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return BigInteger
      Modifier and Type 方法 描述
      BigInteger X509IssuerSerial.getSerialNumber​()
      返回此 X509IssuerSerial的序列号。
      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type BigInteger
      Modifier and Type 方法 描述
      abstract X509IssuerSerial KeyInfoFactory.newX509IssuerSerial​(String issuerName, BigInteger serialNumber)
      从指定的X.500发行人可分辨名称和序列号创建 X509IssuerSerial 。

    • Uses of BigInteger in javax.xml.datatype

      Methods in javax.xml.datatype that return BigInteger
      Modifier and Type 方法 描述
      abstract BigInteger XMLGregorianCalendar.getEon​()
      返回 year XML Schema 1.0 dateTime数据类型字段的 year 。
      abstract BigInteger XMLGregorianCalendar.getEonAndYear​()
      返回 year的XML Schema 1.0 dateTime数据类型字段。
      Methods in javax.xml.datatype with parameters of type BigInteger
      Modifier and Type 方法 描述
      abstract Duration DatatypeFactory.newDuration​(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)
      获取 Duration的新实例，指定 Duration为isPositive，年，月，日，小时，分钟，秒。
      Duration DatatypeFactory.newDurationDayTime​(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second)
      创建 Duration类型的 xdt:dayTimeDuration使用指定 day ， hour ， minute和 second中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 。
      Duration DatatypeFactory.newDurationYearMonth​(boolean isPositive, BigInteger year, BigInteger month)
      创建 Duration类型的 xdt:yearMonthDuration使用指定 year和 month中定义 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 。
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar​(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone)
      允许W3C XML Schema 1.0允许的完整值空间的构造方法，用于xsd：dateTime和相关的内置数据类型。
      abstract void XMLGregorianCalendar.setYear​(BigInteger year)
      设置XSD dateTime年期的低阶和高阶分量。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.math.MathContext (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.math.MathContext

  • Packages that use MathContext
    软件包 描述
    java.math
    提供用于执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。

    • Uses of MathContext in java.math

      Fields in java.math declared as MathContext
      Modifier and Type Field 描述
      static MathContext MathContext.DECIMAL128
      甲 MathContext对象与精度设置相匹配的IEEE 754R DECIMAL128格式，34位，和舍入模式 HALF_EVEN ，在IEEE 754R的默认。
      static MathContext MathContext.DECIMAL32
      A MathContext对象，精度设置与IEEE 754R Decimal32格式，7位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。
      static MathContext MathContext.DECIMAL64
      A MathContext对象，其精度设置与IEEE 754R Decimal64格式，16位数字以及 HALF_EVEN的舍入模式（IEEE 754R默认值）匹配。
      static MathContext MathContext.UNLIMITED
      一个 MathContext对象，其设置具有无限精度算术所需的值。
      Methods in java.math with parameters of type MathContext
      Modifier and Type 方法 描述
      BigDecimal BigDecimal.abs​(MathContext mc)
      返回一个 BigDecimal其值为此 BigDecimal的绝对值，根据上下文设置进行舍入。
      BigDecimal BigDecimal.add​(BigDecimal augend, MathContext mc)
      返回 BigDecimal ，其值是 (this + augend) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, MathContext mc)
      返回 BigDecimal ，其值是 (this / divisor) ，根据上下文设置进行舍入。
      BigDecimal[] BigDecimal.divideAndRemainder​(BigDecimal divisor, MathContext mc)
      返回一个两元件 BigDecimal阵列含有的结果 divideToIntegralValue随后的结果 remainder上与根据上下文设置进行舍入计算出的两个操作数。
      BigDecimal BigDecimal.divideToIntegralValue​(BigDecimal divisor, MathContext mc)
      返回值为 BigDecimal的整数部分的 (this / divisor) 。
      BigDecimal BigDecimal.multiply​(BigDecimal multiplicand, MathContext mc)
      返回 BigDecimal ，其值是 (this × multiplicand) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.negate​(MathContext mc)
      返回 BigDecimal ，其值是 (-this) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.plus​(MathContext mc)
      返回 BigDecimal ，其值是 (+this) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.pow​(int n, MathContext mc)
      返回 BigDecimal ，其值是 (thisn) 。
      BigDecimal BigDecimal.remainder​(BigDecimal divisor, MathContext mc)
      返回 BigDecimal ，其值是 (this % divisor) ，根据上下文设置进行舍入。
      BigDecimal BigDecimal.round​(MathContext mc)
      返回 BigDecimal根据四舍五入 MathContext设置。
      BigDecimal BigDecimal.sqrt​(MathContext mc)
      根据上下文设置返回近似值为 this平方根。
      BigDecimal BigDecimal.subtract​(BigDecimal subtrahend, MathContext mc)
      返回 BigDecimal ，其值是 (this - subtrahend) ，根据上下文设置进行舍入。
      Constructors in java.math with parameters of type MathContext
      Constructor 描述
      BigDecimal​(char[] in, int offset, int len, MathContext mc)
      将 BigDecimal的字符阵列表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，同时允许指定子数组并根据上下文设置进行舍入。
      BigDecimal​(char[] in, MathContext mc)
      将 BigDecimal的字符阵列表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符序列，并根据上下文设置进行舍入。
      BigDecimal​(double val, MathContext mc)
      将 double转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(int val, MathContext mc)
      将 int转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(long val, MathContext mc)
      将 long转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(String val, MathContext mc)
      将 BigDecimal的字符串表示 BigDecimal转换为 BigDecimal ，接受与 BigDecimal(String)构造函数相同的字符串，并根据上下文设置进行舍入。
      BigDecimal​(BigInteger unscaledVal, int scale, MathContext mc)
      将 BigInteger缩放值和 int刻度转换为 BigDecimal ，根据上下文设置进行舍入。
      BigDecimal​(BigInteger val, MathContext mc)
      根据上下文设置将 BigInteger转换为 BigDecimal舍入。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Uses of Class java.math.RoundingMode (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Uses of Class
java.math.RoundingMode

  • Packages that use RoundingMode
    软件包 描述
    java.math
    提供执行任意精度整数运算（ BigInteger ）和任意精度十进制运算（ BigDecimal ）的类。
    java.text
    提供用于以独立于自然语言的方式处理文本，日期，数字和消息的类和接口。

    • Uses of RoundingMode in java.math

      Methods in java.math that return RoundingMode
      Modifier and Type 方法 描述
      RoundingMode MathContext.getRoundingMode​()
      返回roundingMode设置。
      static RoundingMode RoundingMode.valueOf​(int rm)
      返回对应于RoundingMode中的遗留整数舍入模式常量的RoundingMode对象 。
      static RoundingMode RoundingMode.valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static RoundingMode[] RoundingMode.values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。
      Methods in java.math with parameters of type RoundingMode
      Modifier and Type 方法 描述
      BigDecimal BigDecimal.divide​(BigDecimal divisor, int scale, RoundingMode roundingMode)
      返回 BigDecimal ，其值是 (this / divisor) ，其标度为指定。
      BigDecimal BigDecimal.divide​(BigDecimal divisor, RoundingMode roundingMode)
      返回 BigDecimal ，其值是 (this / divisor) ，其标为 this.scale() 。
      BigDecimal BigDecimal.setScale​(int newScale, RoundingMode roundingMode)
      返回一个 BigDecimal其缩放比例是指定值，其缩放值通过将该 BigDecimal的非标度值乘以10的适当功率来确定，以维持其整体值。
      Constructors in java.math with parameters of type RoundingMode
      Constructor 描述
      MathContext​(int setPrecision, RoundingMode setRoundingMode)
      构造一个新的 MathContext具有指定的精度和舍入模式。

    • Uses of RoundingMode in java.text

      Methods in java.text that return RoundingMode
      Modifier and Type 方法 描述
      RoundingMode DecimalFormat.getRoundingMode​()
      获取此DecimalFormat中使用的RoundingMode 。
      RoundingMode NumberFormat.getRoundingMode​()
      获取此NumberFormat中使用的RoundingMode 。
      Methods in java.text with parameters of type RoundingMode
      Modifier and Type 方法 描述
      void DecimalFormat.setRoundingMode​(RoundingMode roundingMode)
      设置此DecimalFormat中使用的RoundingMode 。
      void NumberFormat.setRoundingMode​(RoundingMode roundingMode)
      设置此NumberFormat中使用的RoundingMode 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


Authenticator (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class Authenticator

  • java.lang.Object
    • java.net.Authenticator

  • public abstract class Authenticator
extends Object
    Authenticator类代表一个知道如何获取网络连接认证的对象。 通常，它将通过提示用户提供信息来做到这一点。

    应用程序通过在子类中覆盖getPasswordAuthentication()来使用此类。 该方法通常将使用各种getXXX（）访问器方法来获取有关请求身份验证的实体的信息。 然后必须通过与用户交互或通过其他非交互方式获取用户名和密码。 凭证返回值为PasswordAuthentication 。

    然后通过调用setDefault(Authenticator)向系统注册此具体子类的一个实例。 当需要身份验证时，系统将调用requestPasswordAuthentication（）方法之一，这又将调用注册对象的getPasswordAuthentication（）方法。

    请求身份验证的所有方法都具有失败的默认实现。

    从以下版本开始：
    1.2
    另请参见：
    setDefault(java.net.Authenticator) ， getPasswordAuthentication()

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Authenticator.RequestorType
      请求认证的实体的类型。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Authenticator​()

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static Authenticator getDefault​()
      获取默认验证器。
      protected PasswordAuthentication getPasswordAuthentication​()
      当需要密码授权时调用。
      protected String getRequestingHost​()
      获取 hostname的网站或代理请求验证的，或 null如果不可用。
      protected int getRequestingPort​()
      获取请求的连接的端口号。
      protected String getRequestingPrompt​()
      获取请求者给出的提示字符串。
      protected String getRequestingProtocol​()
      给出请求连接的协议。
      protected String getRequestingScheme​()
      获取请求者的方案（例如HTTP防火墙的HTTP方案）。
      protected InetAddress getRequestingSite​()
      获取 InetAddress请求授权的站点，或者 null如果不可用。
      protected URL getRequestingURL​()
      返回导致此请求验证的URL。
      protected Authenticator.RequestorType getRequestorType​()
      返回请求者是Proxy还是Server。
      static PasswordAuthentication requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication requestPasswordAuthentication​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      请向系统注册的验证者询问密码。
      static PasswordAuthentication requestPasswordAuthentication​(Authenticator authenticator, String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      询问给定的 authenticator密码。
      static PasswordAuthentication requestPasswordAuthentication​(InetAddress addr, int port, String protocol, String prompt, String scheme)
      请向系统注册的验证者询问密码。
      PasswordAuthentication requestPasswordAuthenticationInstance​(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
      向该验证者询问密码。
      static void setDefault​(Authenticator a)
      设置代理或HTTP服务器要求进行身份验证时由网络代码使用的身份验证器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Authenticator

        public Authenticator​()

    • 方法详细信息

      • setDefault

        public static void setDefault​(Authenticator a)
        设置代理或HTTP服务器要求进行身份验证时由网络代码使用的身份验证器。

        首先，如果有一个安全管理员，它的checkPermission方法被调用一个NetPermission("setDefaultAuthenticator")权限。 这可能会导致java.lang.SecurityException异常。

        参数
        a - 要设置的认证器。 如果a是null那么任何先前设置的认证器将被删除。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许设置默认验证器。
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， NetPermission

      • getDefault

        public static Authenticator getDefault​()
        获取默认验证器。 首先，如果有一个安全管理器，它的checkPermission方法被调用一个NetPermission("requestPasswordAuthentication")权限。 这可能会导致java.lang.SecurityException异常。 然后返回默认认证器（如果设置）。 否则返回null 。
        结果
        缺省认证方，如果设置， null 。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许请求密码认证。
        从以下版本开始：
        9
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， NetPermission

      • requestPasswordAuthentication

        public static PasswordAuthentication requestPasswordAuthentication​(InetAddress addr,
                                                                   int port,
                                                                   String protocol,
                                                                   String prompt,
                                                                   String scheme)
        请向系统注册的验证者询问密码。

        首先，如果有一个安全管理器，它的checkPermission方法被调用一个NetPermission("requestPasswordAuthentication")权限。 这可能会导致java.lang.SecurityException异常。

        参数
        addr - 请求授权的站点的InetAddress，如果不知道，则为null。
        port - 请求连接的端口
        protocol - 请求连接的协议（ getRequestingProtocol() ）
        prompt - 用户的提示字符串
        scheme - 认证方案
        结果
        用户名/密码，如果不能得到，则为null。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许密码认证请求。
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， NetPermission

      • requestPasswordAuthentication

        public static PasswordAuthentication requestPasswordAuthentication​(String host,
                                                                   InetAddress addr,
                                                                   int port,
                                                                   String protocol,
                                                                   String prompt,
                                                                   String scheme)
        请向系统注册的验证者询问密码。 这是申请密码的首选方法，因为在InetAddress不可用的情况下可以提供主机名。

        首先，如果有一个安全管理员，它的checkPermission方法被调用一个NetPermission("requestPasswordAuthentication")权限。 这可能会导致java.lang.SecurityException异常。

        参数
        host - 请求身份验证的站点的主机名。
        addr - 请求认证的站点的InetAddress，如果不知道，则为null。
        port - 所请求连接的端口。
        protocol - 请求连接的协议（ getRequestingProtocol() ）
        prompt - 用于标识身份验证领域的用户的提示字符串。
        scheme - 认证方案
        结果
        用户名/密码，如果不能得到，则为null。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许密码认证请求。
        从以下版本开始：
        1.4
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， NetPermission

      • requestPasswordAuthentication

        public static PasswordAuthentication requestPasswordAuthentication​(String host,
                                                                   InetAddress addr,
                                                                   int port,
                                                                   String protocol,
                                                                   String prompt,
                                                                   String scheme,
                                                                   URL url,
                                                                   Authenticator.RequestorType reqType)
        请向系统注册的验证者询问密码。

        首先，如果有一个安全管理员，它的checkPermission方法被调用一个NetPermission("requestPasswordAuthentication")权限。 这可能会导致java.lang.SecurityException异常。

        参数
        host - 请求身份验证的站点的主机名。
        addr - 请求授权的站点的InetAddress，如果不知道则为null。
        port - 所请求连接的端口
        protocol - 请求连接的协议（ getRequestingProtocol() ）
        prompt - 用户的提示字符串
        scheme - 认证方案
        url - 导致身份验证的请求URL
        reqType - 请求身份验证的实体的类型（服务器或代理）。
        结果
        用户名/密码，如果不能得到，则为null。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许密码认证请求。
        从以下版本开始：
        1.5
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， NetPermission

      • requestPasswordAuthentication

        public static PasswordAuthentication requestPasswordAuthentication​(Authenticator authenticator,
                                                                   String host,
                                                                   InetAddress addr,
                                                                   int port,
                                                                   String protocol,
                                                                   String prompt,
                                                                   String scheme,
                                                                   URL url,
                                                                   Authenticator.RequestorType reqType)
        询问给定的authenticator密码。 如果给定的authenticator为空，则使用已使用setDefault向系统注册的认证方（如果有）。

        首先，如果有一个安全管理员，它的checkPermission方法被调用一个NetPermission("requestPasswordAuthentication")权限。 这可能会导致java.lang.SecurityException异常。

        参数
        authenticator - 认证者，或 null 。
        host - 请求身份验证的站点的主机名。
        addr - 请求授权的站点的InetAddress，如果不知道，则为null。
        port - 所请求连接的端口
        protocol - 请求连接的协议（ getRequestingProtocol() ）
        prompt - 用户的提示字符串
        scheme - 认证方案
        url - 导致身份验证的请求URL
        reqType - 请求身份验证的实体的类型（服务器或代理）。
        结果
        用户名/密码，或 null如果不能得到。
        异常
        SecurityException - 如果安全管理器存在，并且其 checkPermission方法不允许密码认证请求。
        从以下版本开始：
        9
        另请参见：
        SecurityManager.checkPermission(java.security.Permission) ， NetPermission

      • requestPasswordAuthenticationInstance

        public PasswordAuthentication requestPasswordAuthenticationInstance​(String host,
                                                                    InetAddress addr,
                                                                    int port,
                                                                    String protocol,
                                                                    String prompt,
                                                                    String scheme,
                                                                    URL url,
                                                                    Authenticator.RequestorType reqType)
        向该验证者询问密码。
        参数
        host - 请求身份验证的站点的主机名。
        addr - 请求授权的站点的InetAddress，如果不知道，则为null。
        port - 所请求连接的端口
        protocol - 请求连接的协议（ getRequestingProtocol() ）
        prompt - 用户的提示字符串
        scheme - 认证方案
        url - 导致身份验证的请求URL
        reqType - 请求身份验证的实体的类型（服务器或代理）。
        结果
        用户名/密码，如果不能得到，则为null
        从以下版本开始：
        9

      • getRequestingHost

        protected final String getRequestingHost​()
        获取 hostname的网站或代理请求验证的，或 null如果不可用。
        结果
        需要验证的连接的主机名，如果不可用，则为null。
        从以下版本开始：
        1.4

      • getRequestingSite

        protected final InetAddress getRequestingSite​()
        获取 InetAddress请求授权的站点，或者 null如果不可用。
        结果
        请求授权的站点的InetAddress，如果不可用，则为null。

      • getRequestingPort

        protected final int getRequestingPort​()
        获取请求的连接的端口号。
        结果
        一个 int指示所请求连接的端口。

      • getRequestingProtocol

        protected final String getRequestingProtocol​()
        给出请求连接的协议。 通常这将基于一个URL，但在未来的JDK中，例如可能是一个受密码保护的SOCKS5防火墙的“SOCKS”。
        结果
        协议，可选地后跟“/ version”，其中version是版本号。
        另请参见：
        URL.getProtocol()

      • getRequestingPrompt

        protected final String getRequestingPrompt​()
        获取请求者给出的提示字符串。
        结果
        请求者提供的提示字符串（http请求的领域）

      • getRequestingScheme

        protected final String getRequestingScheme​()
        获取请求者的方案（例如HTTP防火墙的HTTP方案）。
        结果
        请求者的方案

      • getPasswordAuthentication

        protected PasswordAuthentication getPasswordAuthentication​()
        当需要密码授权时调用。 子类应该覆盖默认的实现，返回null。
        结果
        从用户收集的PasswordAuthentication，如果没有提供，则为null。

      • getRequestingURL

        protected URL getRequestingURL​()
        返回导致此请求验证的URL。
        结果
        请求的URL
        从以下版本开始：
        1.5

      • getRequestorType

        protected Authenticator.RequestorType getRequestorType​()
        返回请求者是Proxy还是Server。
        结果
        请求者的身份验证类型
        从以下版本开始：
        1.5
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Authenticator.RequestorType (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.net

Enum Authenticator.RequestorType

  • java.lang.Object
    • java.lang.Enum<Authenticator.RequestorType>
      • java.net.Authenticator.RequestorType
  • All Implemented Interfaces:
    Serializable ， Comparable<Authenticator.RequestorType>
    Enclosing class:
    Authenticator

    public static enum Authenticator.RequestorType
extends Enum<Authenticator.RequestorType>
    请求认证的实体的类型。
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      PROXY
      请求身份验证的实体是HTTP代理服务器。
      SERVER
      请求身份验证的实体是HTTP源服务器。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Authenticator.RequestorType valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Authenticator.RequestorType[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PROXY

        public static final Authenticator.RequestorType PROXY
        请求身份验证的实体是HTTP代理服务器。

      • SERVER

        public static final Authenticator.RequestorType SERVER
        请求身份验证的实体是HTTP源服务器。

    • 方法详细信息

      • values

        public static Authenticator.RequestorType[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Authenticator.RequestorType c : Authenticator.RequestorType.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Authenticator.RequestorType valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


BindException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class BindException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.SocketException
            • java.net.BindException
  • All Implemented Interfaces:
    Serializable

    public class BindException
extends SocketException
    指示尝试将套接字绑定到本地地址和端口时发生错误。 通常，端口正在使用中，或者无法分配请求的本地地址。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      BindException​()
      构造一个新的BindException，没有详细的消息。
      BindException​(String msg)
      构造一个新的BindException与指定的详细信息为什么绑定错误发生。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • BindException

        public BindException​(String msg)
        构造一个新的BindException与指定的详细信息为什么绑定错误发生。 详细信息是一个字符串，它给出了该错误的具体描述。
        参数
        msg - 详细信息

      • BindException

        public BindException​()
        构造一个新的BindException，没有详细的消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CacheRequest (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class CacheRequest

  • java.lang.Object
    • java.net.CacheRequest

  • public abstract class CacheRequest
extends Object
    表示在ResponseCache中存储资源的通道。 这种类的实例提供了一个由协议处理程序调用以将资源数据存储到缓存中的OutputStream对象，还有一个允许高速缓存存储操作被中断和放弃的abort（）方法。 如果在读取响应或写入高速缓存时遇到IOException，则当前高速缓存存储操作将被中止。
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      CacheRequest​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract void abort​()
      中止缓存响应的尝试。
      abstract OutputStream getBody​()
      返回一个可以写入响应体的OutputStream。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CacheRequest

        public CacheRequest​()

    • 方法详细信息

      • getBody

        public abstract OutputStream getBody​()
                              throws IOException
        返回一个可以写入响应体的OutputStream。
        结果
        一个可以写入响应主体的OutputStream
        异常
        IOException - 如果在编写响应正文时发生I / O错误

      • abort

        public abstract void abort​()
        中止缓存响应的尝试。 如果在读取响应或写入高速缓存时遇到IOException，则当前缓存存储操作将被放弃。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CacheResponse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class CacheResponse

  • java.lang.Object
    • java.net.CacheResponse
  • 已知直接子类：
    SecureCacheResponse

    public abstract class CacheResponse
extends Object
    代表从ResponseCache中检索资源的通道。 这种类的实例提供一个返回实体主体的InputStream，还有一个getHeaders（）方法，返回相应的响应头。
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      CacheResponse​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract InputStream getBody​()
      将响应体作为InputStream返回。
      abstract Map<String,List<String>> getHeaders​()
      将响应标头作为Map返回。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CacheResponse

        public CacheResponse​()

    • 方法详细信息

      • getHeaders

        public abstract Map<String,List<String>> getHeaders​()
                                             throws IOException
        将响应标头作为Map返回。
        结果
        从响应标题字段名称到字段值列表的不可变映射。 状态行的字段名称为空。
        异常
        IOException - 如果在获取响应标头时发生I / O错误

      • getBody

        public abstract InputStream getBody​()
                             throws IOException
        将响应体作为InputStream返回。
        结果
        一个可以访问响应主体的InputStream
        异常
        IOException - 如果在获取响应正文时发生I / O错误
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ConnectException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class ConnectException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.SocketException
            • java.net.ConnectException
  • All Implemented Interfaces:
    Serializable

    public class ConnectException
extends SocketException
    指示尝试将套接字连接到远程地址和端口时发生错误。 通常，连接被远程拒绝（例如，没有进程正在监听远程地址/端口）。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ConnectException​()
      构造一个没有详细消息的新ConnectException。
      ConnectException​(String msg)
      构造一个新的ConnectException与指定的详细信息，为什么连接错误发生。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ConnectException

        public ConnectException​(String msg)
        构造一个新的ConnectException与指定的详细信息，为什么连接错误发生。 详细信息是一个字符串，它给出了该错误的具体描述。
        参数
        msg - 详细信息

      • ConnectException

        public ConnectException​()
        构造一个没有详细消息的新ConnectException。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContentHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class ContentHandler

  • java.lang.Object
    • java.net.ContentHandler

  • public abstract class ContentHandler
extends Object
    抽象类ContentHandler是从URLConnection读取Object的所有类的超类。

    应用程序通常不会直接在此类中调用getContent方法。 相反，应用程序会在URL或URLConnection调用getContent方法。 应用程序的内容处理程序工厂（实现接口的类的实例ContentHandlerFactory通过调用设置为setContentHandler ）是带一个String给套接字上接收的MIME类型的对象。 工厂返回一个ContentHandler子类的ContentHandler ，并调用其getContent方法来创建该对象。

    如果没有内容处理程序可以是found ，则URLConnection将在用户可定义的一组位置中查找内容处理程序。 用户可以通过定义URLConnection.contentPathProp属性来定义垂直条分隔的类前缀集来进行搜索。 班级的名称必须是：

    {package-prefix}.{major}.{minor}

    where {major}.{minor} is formed by taking the content-type string, replacing all slash characters with a period ('.'), and all other non-alphanumeric characters with the underscore character '_'. The alphanumeric characters are specifically the 26 uppercase ASCII letters 'A' through 'Z', the 26 lowercase ASCII letters 'a' through 'z', and the 10 ASCII digits '0' through '9'.

    e.g. YoyoDyne.experimental.text.plain

    如果没有找到用户定义的内容处理程序，那么系统会尝试从内置处理程序之一加载特定的内容类型处理程序（如果存在）。

    如果内容处理程序类的加载将由调用者的委派链之外的类加载器执行，则JVM将需要RuntimePermission“getClassLoader”。

    从以下版本开始：
    1.0
    另请参见：
    getContent(java.net.URLConnection) ， ContentHandlerFactory ， URL.getContent() ， URLConnection ， URLConnection.getContent() ， URLConnection.setContentHandlerFactory(java.net.ContentHandlerFactory)

    • 构造方法摘要

      构造方法
      Constructor 描述
      ContentHandler​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Object getContent​(URLConnection urlc)
      给定位于对象表示开头的URL连接流，该方法读取该流并从中创建一个对象。
      Object getContent​(URLConnection urlc, Class[] classes)
      给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ContentHandler

        public ContentHandler​()

    • 方法详细信息

      • getContent

        public abstract Object getContent​(URLConnection urlc)
                           throws IOException
        给定位于对象表示开头的URL连接流，该方法读取该流并从中创建一个对象。
        参数
        urlc - 一个URL连接。
        结果
        该对象由 ContentHandler读取。
        异常
        IOException - 如果读取对象时发生I / O错误。

      • getContent

        public Object getContent​(URLConnection urlc,
                         Class[] classes)
                  throws IOException
        给定位于对象表示开始处的URL连接流，该方法读取该流并创建一个与指定类型匹配的对象。 该方法的默认实现应该调用getContent（）并屏幕显示与建议类型匹配的返回类型。
        参数
        urlc - 一个URL连接。
        classes - 请求的类型数组
        结果
        由 ContentHandler读取的对象是建议类型的第一个匹配项，如果不支持请求， null 。
        异常
        IOException - 读取对象时是否发生I / O错误。
        从以下版本开始：
        1.3
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ContentHandlerFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface ContentHandlerFactory

  • public interface ContentHandlerFactory
    该界面为内容处理程序定义了一个工厂。 此接口的实现应将MIME类型映射到ContentHandler的实例。

    该接口由URLStreamHandler类用于为MIME类型创建一个ContentHandler 。

    从以下版本开始：
    1.0
    另请参见：
    ContentHandler ， URLStreamHandler

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      ContentHandler createContentHandler​(String mimetype)
      创建一个新的 ContentHandler从 URLStreamHandler读取一个对象。

    • 方法详细信息

      • createContentHandler

        ContentHandler createContentHandler​(String mimetype)
        创建一个新的 ContentHandler从 URLStreamHandler读取一个对象。
        参数
        mimetype - 需要内容处理程序的MIME类型。
        结果
        一个新的 ContentHandler从 URLStreamHandler读取一个对象。
        另请参见：
        ContentHandler ， URLStreamHandler
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CookieHandler (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class CookieHandler

  • java.lang.Object
    • java.net.CookieHandler
  • 已知直接子类：
    CookieManager

    public abstract class CookieHandler
extends Object
    CookieHandler对象提供一个回调机制，将HTTP状态管理策略实现连接到HTTP协议处理程序中。 HTTP状态管理机制指定了一种使用HTTP请求和响应创建有状态会话的方法。

    可以通过执行CookieHandler.setDefault（CookieHandler）来注册由HTTP协议处理程序使用的系统级CookieHandler。 可以通过调用CookieHandler.getDefault（）来检索当前注册的CookieHandler。 有关HTTP状态管理的更多信息，请参阅RFC 2965: HTTP State Management Mechanism

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      CookieHandler​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract Map<String,List<String>> get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      static CookieHandler getDefault​()
      获取系统范围的Cookie处理程序。
      abstract void put​(URI uri, Map<String,List<String>> responseHeaders)
      设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
      static void setDefault​(CookieHandler cHandler)
      设置（或取消）系统范围的Cookie处理程序。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CookieHandler

        public CookieHandler​()

    • 方法详细信息

      • getDefault

        public static CookieHandler getDefault​()
        获取系统范围的Cookie处理程序。
        结果
        系统范围的Cookie处理程序; 空返回意味着当前没有设置系统范围的cookie处理程序。
        异常
        SecurityException - 如果安全管理器已安装，并且它拒绝NetPermission ("getCookieHandler")
        另请参见：
        setDefault(CookieHandler)

      • setDefault

        public static void setDefault​(CookieHandler cHandler)
        设置（或取消）系统范围的Cookie处理程序。 注意：非标准的http协议处理程序可能会忽略此设置。
        参数
        cHandler - HTTP cookie处理程序，或 null取消设置。
        异常
        SecurityException - 如果安全管理员已经安装并且它拒绝NetPermission ("setCookieHandler")
        另请参见：
        getDefault()

      • get

        public abstract Map<String,List<String>> get​(URI uri,
                                             Map<String,List<String>> requestHeaders)
                                      throws IOException
        从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。

        作为参数传递的URI指定了Cookie的预期用途。 特别地，该方案应反映Cookie是否通过http，https发送或在其他上下文中使用，如javascript。 在javascript的情况下，主机部分应反映cookie的目的地或其原点。

        考虑到URI和cookies属性和安全设置来确定哪些应该返回，这取决于实现。

        HTTP协议实现者应确保在添加与选择cookie相关的所有请求头之后，以及发送请求之前调用此方法。

        参数
        uri - 表示Cookie的预期用途的 URI
        requestHeaders - - 从请求头字段名称映射到表示当前请求头的字段值的列表
        结果
        来自状态管理标题的不可变地图，字段名称为“Cookie”或“Cookie2”到包含状态信息的Cookie列表
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果任一参数为空
        另请参见：
        put(URI, Map)

      • put

        public abstract void put​(URI uri,
                         Map<String,List<String>> responseHeaders)
                  throws IOException
        设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
        参数
        uri - 一个 URI ，其中饼干来自
        responseHeaders - 从字段名称到表示返回的响应头字段的字段值的列表的不可变映射
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果任一参数为空
        另请参见：
        get(URI, Map)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CookieManager (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class CookieManager

  • java.lang.Object
    • java.net.CookieHandler
      • java.net.CookieManager

  • public class CookieManager
extends CookieHandler
    CookieManager提供了一个CookieHandler的具体实现， 它将 cookie的存储与接受和拒绝Cookie的策略分开。 那么CookieManager初始化为CookieStore ，其管理存储和CookiePolicy对象，这使得上的cookie接受/拒绝决策。

    java.net包中的HTTP Cookie管理如下所示：

                  use
 CookieHandler <------- HttpURLConnection
       ^
       | impl
       |         use
 CookieManager -------> CookiePolicy
             |   use
             |--------> HttpCookie
             |              ^
             |              | use
             |   use        |
             |--------> CookieStore
                            ^
                            | impl
                            |
                  Internal in-memory implementation
    • CookieHandler is at the core of cookie management. User can call CookieHandler.setDefault to set a concrete CookieHanlder implementation to be used.
    • CookiePolicy.shouldAccept will be called by CookieManager.put to see whether or not one cookie should be accepted and put into cookie store. User can use any of three pre-defined CookiePolicy, namely ACCEPT_ALL, ACCEPT_NONE and ACCEPT_ORIGINAL_SERVER, or user can define his own CookiePolicy implementation and tell CookieManager to use it.
    • CookieStore is the place where any accepted HTTP cookie is stored in. If not specified when created, a CookieManager instance will use an internal in-memory implementation. Or user can implements one and tell CookieManager to use it.
    • Currently, only CookieStore.add(URI, HttpCookie) and CookieStore.get(URI) are used by CookieManager. Others are for completeness and might be needed by a more sophisticated CookieStore implementation, e.g. a NetscapeCookieStore.

    用户可以通过各种方式连接自己的HTTP cookie管理行为，例如

    • Use CookieHandler.setDefault to set a brand new CookieHandler implementation
    • Let CookieManager be the default CookieHandler implementation, but implement user's own CookieStore and CookiePolicy and tell default CookieManager to use them:
             // this should be done at the beginning of an HTTP session
       CookieHandler.setDefault(new CookieManager(new MyCookieStore(), new MyCookiePolicy()));
    • Let CookieManager be the default CookieHandler implementation, but use customized CookiePolicy:
             // this should be done at the beginning of an HTTP session
       CookieHandler.setDefault(new CookieManager());
       // this can be done at any point of an HTTP session
       ((CookieManager)CookieHandler.getDefault()).setCookiePolicy(new MyCookiePolicy());

    实施符合RFC 2965第3.3节。

    从以下版本开始：
    1.6
    另请参见：
    CookiePolicy

    • 构造方法摘要

      构造方法
      Constructor 描述
      CookieManager​()
      创建一个新的cookie管理器。
      CookieManager​(CookieStore store, CookiePolicy cookiePolicy)
      使用指定的Cookie存储和Cookie策略创建一个新的cookie管理器。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Map<String,List<String>> get​(URI uri, Map<String,List<String>> requestHeaders)
      从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。
      CookieStore getCookieStore​()
      检索当前cookie存储。
      void put​(URI uri, Map<String,List<String>> responseHeaders)
      设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
      void setCookiePolicy​(CookiePolicy cookiePolicy)
      设置此Cookie管理器的Cookie策略。

      • Methods inherited from class java.net.CookieHandler

        getDefault, setDefault

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CookieManager

        public CookieManager​()
        创建一个新的cookie管理器。

        此构造函数将创建具有默认Cookie存储并接受策略的新Cookie管理器。 效果与CookieManager(null, null)相同。

      • CookieManager

        public CookieManager​(CookieStore store,
                     CookiePolicy cookiePolicy)
        使用指定的Cookie存储和Cookie策略创建一个新的cookie管理器。
        参数
        store - 一个CookieStore被cookie管理器使用。 如果是null ，cookie管理器将使用默认值，这是一个内存中的CookieStore实现。
        cookiePolicy - 由cookie管理器用作策略回调的CookiePolicy实例。 如果是null ，将使用ACCEPT_ORIGINAL_SERVER。

    • 方法详细信息

      • setCookiePolicy

        public void setCookiePolicy​(CookiePolicy cookiePolicy)
        设置此Cookie管理器的Cookie策略。

        默认情况下， CookieManager的实例将具有ACCEPT_ORIGINAL_SERVER的Cookie策略。 用户总是可以调用此方法来设置另一个cookie策略。

        参数
        cookiePolicy - cookie政策。 可以是null ，这对当前的cookie策略没有影响。

      • getCookieStore

        public CookieStore getCookieStore​()
        检索当前cookie存储。
        结果
        cookie管理器当前使用的cookie存储。

      • get

        public Map<String,List<String>> get​(URI uri,
                                    Map<String,List<String>> requestHeaders)
                             throws IOException
        描述从类别复制： CookieHandler
        从请求标头中指定的uri的cookie缓存获取所有适用的Cookie。

        作为参数传递的URI指定了Cookie的预期用途。 特别地，该方案应反映Cookie是否通过http，https发送或在其他上下文中使用，如javascript。 在javascript的情况下，主机部分应反映cookie的目的地或其原点。

        考虑到URI和cookies属性和安全设置来确定哪些应该返回，这取决于实现。

        HTTP协议实现者应确保在添加与选择cookie相关的所有请求头之后，以及发送请求之前调用此方法。

        Specified by:
        get在 CookieHandler
        参数
        uri - 表示Cookie的预期用途的 URI
        requestHeaders - - 从请求头字段名称映射到表示当前请求头的字段值的列表
        结果
        来自状态管理标题的不可变地图，字段名称为“Cookie”或“Cookie2”到包含状态信息的Cookie列表
        异常
        IOException - 如果发生I / O错误
        另请参见：
        CookieHandler.put(URI, Map)

      • put

        public void put​(URI uri,
                Map<String,List<String>> responseHeaders)
         throws IOException
        描述从类别复制： CookieHandler
        设置所有适用的Cookie，示例是响应头字段，名为Set-Cookie2，存在于响应头中的cookie缓存中。
        Specified by:
        put在 CookieHandler
        参数
        uri - 一个 URI ，其中饼干来自
        responseHeaders - 从字段名称到表示返回的响应标头字段的字段值的列表的不可变映射
        异常
        IOException - 如果发生I / O错误
        另请参见：
        CookieHandler.get(URI, Map)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CookiePolicy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface CookiePolicy

  • public interface CookiePolicy
    CookiePolicy实现决定哪些Cookie应该被接受，哪些应该被拒绝。 提供了三个预定义的策略实现，即ACCEPT_ALL，ACCEPT_NONE和ACCEPT_ORIGINAL_SERVER。

    参见RFC 2965秒。 3.3和7更详细。

    从以下版本开始：
    1.6

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static CookiePolicy ACCEPT_ALL
      一个预定义的政策接受所有的cookies。
      static CookiePolicy ACCEPT_NONE
      一个预先定义的政策，不接受Cookie。
      static CookiePolicy ACCEPT_ORIGINAL_SERVER
      一个预先定义的政策，只接受来自原始服务器的Cookie。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      boolean shouldAccept​(URI uri, HttpCookie cookie)
      将被调用来查看是否应该接受该cookie。

    • 字段详细信息

      • ACCEPT_ALL

        static final CookiePolicy ACCEPT_ALL
        一个预定义的政策接受所有的cookies。

      • ACCEPT_NONE

        static final CookiePolicy ACCEPT_NONE
        一个预先定义的政策，不接受Cookie。

      • ACCEPT_ORIGINAL_SERVER

        static final CookiePolicy ACCEPT_ORIGINAL_SERVER
        一个预先定义的政策，只接受来自原始服务器的Cookie。

    • 方法详细信息

      • shouldAccept

        boolean shouldAccept​(URI uri,
                     HttpCookie cookie)
        将被调用来查看是否应该接受该cookie。
        参数
        uri - 用于咨询接受策略的URI
        cookie - 有问题的HttpCookie对象
        结果
        true if this cookie should be accepted; otherwise, false
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


CookieStore (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface CookieStore

  • public interface CookieStore
    CookieStore对象表示Cookie的存储。 可以存储和检索Cookie。

    CookieManager将调用CookieStore.add为每个传入的HTTP响应保存cookie，并调用CookieStore.get为每个传出的HTTP请求检索cookie。 CookieStore负责删除已过期的HttpCookie实例。

    从以下版本开始：
    1.6

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      void add​(URI uri, HttpCookie cookie)
      向商店添加一个HTTP cookie。
      List<HttpCookie> get​(URI uri)
      检索与给定URI相关联的Cookie，或者其域与给定的URI匹配。
      List<HttpCookie> getCookies​()
      在Cookie商店中获取所有未过期的Cookie。
      List<URI> getURIs​()
      获取标识Cookie存储区中的Cookie的所有URI。
      boolean remove​(URI uri, HttpCookie cookie)
      从商店中删除一个cookie。
      boolean removeAll​()
      删除此Cookie商店中的所有Cookie。

    • 方法详细信息

      • add

        void add​(URI uri,
         HttpCookie cookie)
        向商店添加一个HTTP cookie。 这是为每个传入的HTTP响应调用的。

        要存储的cookie可以与URI相关联，也可能不与URI相关联。 如果它不与URI相关联，则cookie的域和路径属性将指示它来自哪里。 如果与URI相关联，并且未指定其域和路径属性，则给定URI将指示该cookie来自哪里。

        如果对应于给定URI的cookie已经存在，那么它将被替换为新的。

        参数
        uri - 这个cookie关联的uri。 如果是null ，这个cookie不会与URI关联
        cookie - 要存储的cookie
        异常
        NullPointerException - 如果 cookie是 null
        另请参见：
        get(java.net.URI)

      • get

        List<HttpCookie> get​(URI uri)
        检索与给定URI相关联的Cookie，或者其域与给定的URI匹配。 只返回未过期的Cookie。 每个传出HTTP请求都调用这个。
        参数
        uri - 与要返回的Cookie相关联的uri
        结果
        一个不可变的HttpCookie列表，如果没有cookie匹配给定的URI，返回空列表
        异常
        NullPointerException - 如果 uri是 null
        另请参见：
        add(java.net.URI, java.net.HttpCookie)

      • getCookies

        List<HttpCookie> getCookies​()
        在Cookie商店中获取所有未过期的Cookie。
        结果
        一个不可变的http cookie清单; 如果商店中没有http cookie，则返回空列表

      • getURIs

        List<URI> getURIs​()
        获取标识Cookie存储区中的Cookie的所有URI。
        结果
        一个不可变的URI列表; 如果此cookie存储区中没有cookie与URI相关联，则返回空列表

      • remove

        boolean remove​(URI uri,
               HttpCookie cookie)
        从商店中删除一个cookie。
        参数
        uri - 这个cookie关联的uri。 如果是null ，要删除的cookie与添加的URI不相关联; 如果不是null ， null删除的Cookie与添加的给定URI相关联。
        cookie - 要删除的cookie
        结果
        true如果这个商店包含指定的cookie
        异常
        NullPointerException - 如果 cookie是 null

      • removeAll

        boolean removeAll​()
        删除此Cookie商店中的所有Cookie。
        结果
        true如果该商店因呼叫而更改
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DatagramPacket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class DatagramPacket

  • java.lang.Object
    • java.net.DatagramPacket

  • public final class DatagramPacket
extends Object
    该类表示数据报包。

    数据报包用于实现无连接分组传送服务。 仅基于该数据包中包含的信息，每个消息从一台机器路由到另一台机器。 从一台机器发送到另一台机器的多个分组可能会有不同的路由，并且可能以任何顺序到达。 包传送不能保证。

    从以下版本开始：
    1.0

    • 构造方法摘要

      构造方法
      Constructor 描述
      DatagramPacket​(byte[] buf, int length)
      构造一个 DatagramPacket用于接收长度为 length数据包。
      DatagramPacket​(byte[] buf, int offset, int length)
      构造一个 DatagramPacket用于接收长度为 length数据包，指定缓冲区的偏移量。
      DatagramPacket​(byte[] buf, int offset, int length, InetAddress address, int port)
      构造一个数据包，发送长度为 length的数据包，其中偏移量为 ioffset到指定主机上的指定端口号。
      DatagramPacket​(byte[] buf, int offset, int length, SocketAddress address)
      构造一个数据报包，发送长度为 length的数据包，偏移量为 ioffset到指定主机上的指定端口号。
      DatagramPacket​(byte[] buf, int length, InetAddress address, int port)
      构造一个数据包，发送长度为 length的数据包到指定主机上的指定端口号。
      DatagramPacket​(byte[] buf, int length, SocketAddress address)
      构造一个数据包，发送长度为 length的数据包到指定主机上的指定端口号。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      InetAddress getAddress​()
      返回该数据报发送或接收数据报的计算机的IP地址。
      byte[] getData​()
      返回数据缓冲区。
      int getLength​()
      返回要发送的数据的长度或接收到的数据的长度。
      int getOffset​()
      返回要发送的数据的偏移量或接收到的数据的偏移量。
      int getPort​()
      返回发送数据报的远程主机上的端口号，或从中接收数据报的端口号。
      SocketAddress getSocketAddress​()
      获取该数据包发送到或正在从其发送的远程主机的SocketAddress（通常为IP地址+端口号）。
      void setAddress​(InetAddress iaddr)
      设置该数据报发送到的机器的IP地址。
      void setData​(byte[] buf)
      设置此数据包的数据缓冲区。
      void setData​(byte[] buf, int offset, int length)
      设置此数据包的数据缓冲区。
      void setLength​(int length)
      设置此数据包的长度。
      void setPort​(int iport)
      设置发送此数据报的远程主机上的端口号。
      void setSocketAddress​(SocketAddress address)
      设置该数据报发送到的远程主机的SocketAddress（通常是IP地址+端口号）。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DatagramPacket

        public DatagramPacket​(byte[] buf,
                      int offset,
                      int length)
        构造一个DatagramPacket用于接收长度为length数据包，指定缓冲区中的偏移量。

        length参数必须小于或等于buf.length 。

        参数
        buf - 用于保存传入数据报的缓冲区。
        offset - 缓冲区的偏移量
        length - 要读取的字节数。
        从以下版本开始：
        1.2

      • DatagramPacket

        public DatagramPacket​(byte[] buf,
                      int length)
        构造一个DatagramPacket用于接收长度为length数据包。

        length参数必须小于或等于buf.length 。

        参数
        buf - 用于保存传入数据报的缓冲区。
        length - 要读取的字节数。

      • DatagramPacket

        public DatagramPacket​(byte[] buf,
                      int offset,
                      int length,
                      InetAddress address,
                      int port)
        构造一个数据报包，发送长度为length的数据包，偏移量为ioffset到指定主机上的指定端口号。 length参数必须小于或等于buf.length 。
        参数
        buf - 数据包数据。
        offset - 数据包数据偏移量。
        length - 数据包的数据长度。
        address - 目的地址。
        port - 目的端口号。
        从以下版本开始：
        1.2
        另请参见：
        InetAddress

      • DatagramPacket

        public DatagramPacket​(byte[] buf,
                      int offset,
                      int length,
                      SocketAddress address)
        构造一个数据包数据包，发送长度为length的数据包，偏移量为ioffset到指定主机上的指定端口号。 length参数必须小于或等于buf.length 。
        参数
        buf - 分组数据。
        offset - 分组数据偏移量。
        length - 数据包的数据长度。
        address - 目标套接字地址。
        异常
        IllegalArgumentException - 如果不支持地址类型
        从以下版本开始：
        1.4
        另请参见：
        InetAddress

      • DatagramPacket

        public DatagramPacket​(byte[] buf,
                      int length,
                      InetAddress address,
                      int port)
        构建一个数据包，发送长度为length的数据包到指定主机上的指定端口号。 length参数必须小于或等于buf.length 。
        参数
        buf - 分组数据。
        length - 包长度。
        address - 目的地址。
        port - 目的端口号。
        另请参见：
        InetAddress

      • DatagramPacket

        public DatagramPacket​(byte[] buf,
                      int length,
                      SocketAddress address)
        构造一个数据包，发送长度为length的数据包到指定主机上的指定端口号。 length参数必须小于或等于buf.length 。
        参数
        buf - 数据包数据。
        length - 包长度。
        address - 目的地址。
        异常
        IllegalArgumentException - 如果不支持地址类型
        从以下版本开始：
        1.4
        另请参见：
        InetAddress

    • 方法详细信息

      • getAddress

        public InetAddress getAddress​()
        返回该数据报发送或接收数据报的计算机的IP地址。
        结果
        该数据报正在发送或接收数据报的机器的IP地址。
        另请参见：
        InetAddress ， setAddress(java.net.InetAddress)

      • getPort

        public int getPort​()
        返回发送数据报的远程主机上的端口号，或从中接收数据报的端口号。
        结果
        该数据报正在发送或从其接收数据报的远程主机上的端口号。
        另请参见：
        setPort(int)

      • getData

        public byte[] getData​()
        返回数据缓冲区。 收到的数据或要发送的数据从缓冲区中的offset开始运行， length为length 。
        结果
        用于接收或发送数据的缓冲区
        另请参见：
        setData(byte[], int, int)

      • getOffset

        public int getOffset​()
        返回要发送的数据的偏移量或接收到的数据的偏移量。
        结果
        要发送的数据的偏移量或接收的数据的偏移量。
        从以下版本开始：
        1.2

      • getLength

        public int getLength​()
        返回要发送的数据的长度或接收到的数据的长度。
        结果
        要发送的数据的长度或接收到的数据的长度。
        另请参见：
        setLength(int)

      • setData

        public void setData​(byte[] buf,
                    int offset,
                    int length)
        设置此数据包的数据缓冲区。 这设置数据包的数据，长度和偏移量。
        参数
        buf - 为此数据包设置的缓冲区
        offset - 数据的偏移量
        length - 数据的长度和/或用于接收数据的缓冲区的长度
        异常
        NullPointerException - 如果参数为空
        从以下版本开始：
        1.2
        另请参见：
        getData() ，
getOffset() ，
getLength()

      • setAddress

        public void setAddress​(InetAddress iaddr)
        设置该数据报发送到的机器的IP地址。
        参数
        iaddr - InetAddress
        从以下版本开始：
        1.1
        另请参见：
        getAddress()

      • setPort

        public void setPort​(int iport)
        设置发送此数据报的远程主机上的端口号。
        参数
        iport - 端口号
        从以下版本开始：
        1.1
        另请参见：
        getPort()

      • setSocketAddress

        public void setSocketAddress​(SocketAddress address)
        设置该数据报发送到的远程主机的SocketAddress（通常是IP地址+端口号）。
        参数
        address - SocketAddress
        异常
        IllegalArgumentException - 如果地址为空，或者是此套接字不支持的SocketAddress子类
        从以下版本开始：
        1.4
        另请参见：
        getSocketAddress()

      • getSocketAddress

        public SocketAddress getSocketAddress​()
        获取该数据包发送到或正在从其发送的远程主机的SocketAddress（通常为IP地址+端口号）。
        结果
        SocketAddress
        从以下版本开始：
        1.4
        另请参见：
        setSocketAddress(java.net.SocketAddress)

      • setData

        public void setData​(byte[] buf)
        设置此数据包的数据缓冲区。 将此DatagramPacket的偏移设置为0，并将长度设置为长度为buf 。
        参数
        buf - 为此数据包设置的缓冲区。
        异常
        NullPointerException - 如果参数为空。
        从以下版本开始：
        1.1
        另请参见：
        getLength() ， getData()

      • setLength

        public void setLength​(int length)
        设置此数据包的长度。 分组的长度是要发送的数据包的数据缓冲区中的字节数，或将用于接收数据的数据包的数据缓冲区的字节数。 长度必须小于或等于偏移量加上数据包缓冲区的长度。
        参数
        length - 为此数据包设置的长度。
        异常
        IllegalArgumentException - 如果长度大于数据包的数据缓冲区长度，则为长度。
        从以下版本开始：
        1.1
        另请参见：
        getLength() ， setData(byte[], int, int)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DatagramSocket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class DatagramSocket

  • java.lang.Object
    • java.net.DatagramSocket
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    MulticastSocket

    public class DatagramSocket
extends Object
implements Closeable
    此类表示用于发送和接收数据报数据包的套接字。

    数据报套接字是分组传送服务的发送或接收点。 在数据报套接字上发送或接收的每个数据包都被单独寻址和路由。 从一个机器发送到另一个机器的多个分组可以不同地路由，并且可以以任何顺序到达。

    在可能的情况下，新构建的DatagramSocket启用了SO_BROADCAST套接字选项，以允许传输广播数据报。 为了接收广播数据包，DatagramSocket应该绑定到通配符地址。 在一些实现中，当DatagramSocket绑定到更具体的地址时，也可以接收广播分组。

    示例： DatagramSocket s = new DatagramSocket(null); s.bind(new InetSocketAddress(8888));其中相当于： DatagramSocket s = new DatagramSocket(8888);这两种情况都将创建一个DatagramSocket能够在UDP端口8888上接收广播。

    从以下版本开始：
    1.0
    另请参见：
    DatagramPacket ， DatagramChannel

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        DatagramSocket​()
      构造数据报套接字并将其绑定到本地主机上的任何可用端口。
        DatagramSocket​(int port)
      构造数据报套接字并将其绑定到本地主机上的指定端口。
        DatagramSocket​(int port, InetAddress laddr)
      创建一个数据报套接字，绑定到指定的本地地址。
      protected DatagramSocket​(DatagramSocketImpl impl)
      使用指定的DatagramSocketImpl创建一个未绑定的数据报套接字。
        DatagramSocket​(SocketAddress bindaddr)
      创建一个数据报套接字，绑定到指定的本地套接字地址。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bind​(SocketAddress addr)
      将此DatagramSocket绑定到特定的地址和端口。
      void close​()
      关闭此数据报套接字。
      void connect​(InetAddress address, int port)
      将套接字连接到此套接字的远程地址。
      void connect​(SocketAddress addr)
      将此套接字连接到远程套接字地址（IP地址+端口号）。
      void disconnect​()
      断开插座。
      boolean getBroadcast​()
      测试是否启用了SO_BROADCAST。
      DatagramChannel getChannel​()
      返回与该数据报套接字相关联的唯一的DatagramChannel对象（如果有）。
      InetAddress getInetAddress​()
      返回此套接字连接到的地址。
      InetAddress getLocalAddress​()
      获取套接字所绑定的本地地址。
      int getLocalPort​()
      返回此套接字绑定到的本地主机上的端口号。
      SocketAddress getLocalSocketAddress​()
      返回此套接字绑定到的端点的地址。
      <T> T getOption​(SocketOption<T> name)
      返回套接字选项的值。
      int getPort​()
      返回此套接字连接到的端口号。
      int getReceiveBufferSize​()
      获取此 DatagramSocket的SO_RCVBUF选项的值，即该平台在此 DatagramSocket上输入的缓冲区大小。
      SocketAddress getRemoteSocketAddress​()
      返回此套接字连接到的端点的地址，如果未连接，则 null 。
      boolean getReuseAddress​()
      测试是否启用了SO_REUSEADDR。
      int getSendBufferSize​()
      获取此 DatagramSocket的SO_SNDBUF选项的值，即平台在此 DatagramSocket上输出使用的缓冲区大小。
      int getSoTimeout​()
      检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。
      int getTrafficClass​()
      在从该DatagramSocket发送的数据包的IP数据报头中获取流量类或服务类型。
      boolean isBound​()
      返回套接字的绑定状态。
      boolean isClosed​()
      返回套接字是否关闭。
      boolean isConnected​()
      返回套接字的连接状态。
      void receive​(DatagramPacket p)
      从此套接字接收数据报包。
      void send​(DatagramPacket p)
      从此套接字发送数据报包。
      void setBroadcast​(boolean on)
      启用/禁用SO_BROADCAST。
      static void setDatagramSocketImplFactory​(DatagramSocketImplFactory fac)
      设置应用程序的数据报套接字实现工厂。
      <T> DatagramSocket setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      void setReceiveBufferSize​(int size)
      将SO_RCVBUF选项设置为此 DatagramSocket的指定值。
      void setReuseAddress​(boolean on)
      启用/禁用SO_REUSEADDR套接字选项。
      void setSendBufferSize​(int size)
      将SO_SNDBUF选项设置为此 DatagramSocket的指定值。
      void setSoTimeout​(int timeout)
      以指定的超时（以毫秒为单位）启用/禁用SO_TIMEOUT。
      void setTrafficClass​(int tc)
      在从该DatagramSocket发送的数据报的IP数据报头中设置流量类别或服务类型的八位字节。
      Set<SocketOption<?>> supportedOptions​()
      返回此套接字支持的一组套接字选项。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DatagramSocket

        public DatagramSocket​()
               throws SocketException
        构造数据报套接字并将其绑定到本地主机上的任何可用端口。 套接字将绑定到wildcard地址，由内核选择的IP地址。

        如果有一个安全管理器，它的checkListen方法首先被调用为0作为参数，以确保操作是允许的。 这可能会导致SecurityException。

        异常
        SocketException - 如果套接字无法打开，或套接字无法绑定到指定的本地端口。
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许操作。
        另请参见：
        SecurityManager.checkListen(int)

      • DatagramSocket

        protected DatagramSocket​(DatagramSocketImpl impl)
        使用指定的DatagramSocketImpl创建一个未绑定的数据报套接字。
        参数
        impl - 子类希望在DatagramSocket上使用的 DatagramSocketImpl的一个实例。
        从以下版本开始：
        1.4

      • DatagramSocket

        public DatagramSocket​(SocketAddress bindaddr)
               throws SocketException
        创建一个数据报套接字，绑定到指定的本地套接字地址。

        如果地址为null ，则创建未绑定的套接字。

        如果有一个安全管理器，它的checkListen方法首先被调用来自套接字地址的端口作为其参数，以确保允许操作。 这可能会导致SecurityException。

        参数
        bindaddr - 要绑定的本地套接字地址，或未绑定套接字的 null 。
        异常
        SocketException - 如果套接字无法打开，或套接字无法绑定到指定的本地端口。
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许操作。
        从以下版本开始：
        1.4
        另请参见：
        SecurityManager.checkListen(int)

      • DatagramSocket

        public DatagramSocket​(int port)
               throws SocketException
        构造数据报套接字并将其绑定到本地主机上的指定端口。 套接字将绑定到wildcard地址，一个由内核选择的IP地址。

        如果有安全管理器，则首先调用其checkListen方法，其参数为port ，以确保操作是允许的。 这可能会导致SecurityException。

        参数
        port - 要使用的端口。
        异常
        SocketException - 如果套接字无法打开，或套接字无法绑定到指定的本地端口。
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许该操作。
        另请参见：
        SecurityManager.checkListen(int)

      • DatagramSocket

        public DatagramSocket​(int port,
                      InetAddress laddr)
               throws SocketException
        创建一个数据报套接字，绑定到指定的本地地址。 本地端口必须介于0和65535之间。 如果IP地址为0.0.0.0，则套接字将绑定到wildcard地址，由内核选择的IP地址。

        如果有一个安全管理器，它的checkListen方法首先被调用，以port参数作为参数，以确保操作是允许的。 这可能会导致SecurityException。

        参数
        port - 本地端口使用
        laddr - 要绑定的本地地址
        异常
        SocketException - 如果套接字无法打开，或套接字无法绑定到指定的本地端口。
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许操作。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkListen(int)

    • 方法详细信息

      • bind

        public void bind​(SocketAddress addr)
          throws SocketException
        将此DatagramSocket绑定到特定的地址和端口。

        如果地址为null ，则系统将接收临时端口和有效的本地地址来绑定套接字。

        参数
        addr - 绑定到的地址和端口。
        异常
        SocketException - 如果在绑定期间发生任何错误，或者套接字已经绑定。
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许操作。
        IllegalArgumentException - 如果addr是此套接字不支持的SocketAddress子类。
        从以下版本开始：
        1.4

      • connect

        public void connect​(InetAddress address,
                    int port)
        将套接字连接到此套接字的远程地址。 当套接字连接到远程地址时，数据包只能发送到或从该地址接收。 默认情况下，数据报套接字未连接。

        如果连接到套接字的远程目的地不存在，否则无法访问，并且如果已经收到该地址的ICMP目标不可达分组，则后续的发送或接收调用可能会引发PortUnreachableException。 注意，不能保证会抛出异常。

        如果已经安装了安全管理器，则调用它来检查对远程地址的访问。 具体来说，如果给定的address是一个multicast address ，安全管理员的checkMulticast方法将使用给定的address调用。 否则，将使用给定的address和port来调用安全管理器的checkConnect和checkAccept方法，以验证是否允许分别发送和接收数据报。

        当连接套接字时， receive和send 将不会对传入和传出数据包执行任何安全检查 ，而不是匹配数据包和套接字的地址和端口。 在发送操作中，如果分组的地址被设置，并且数据包的地址和套接字的地址不匹配，则将抛出一个IllegalArgumentException 。 连接到组播地址的套接字只能用于发送数据包。

        参数
        address - 套接字的远程地址
        port - 套接字的远程端口。
        异常
        IllegalArgumentException - 如果地址为空，或者端口超出范围。
        SecurityException - 如果已安装安全管理器，并且不允许访问给定的远程地址
        另请参见：
        disconnect()

      • connect

        public void connect​(SocketAddress addr)
             throws SocketException
        将此套接字连接到远程套接字地址（IP地址+端口号）。

        如果给出了一个InetSocketAddress ，该方法就像调用具有给定套接字地址IP地址和端口号的connect(InetAddress,int)一样。

        参数
        addr - 远程地址。
        异常
        SocketException - 如果连接失败
        IllegalArgumentException - 如果 addr是 null ，或 addr是这个套接字不支持的SocketAddress子类
        SecurityException - 如果已安装安全管理器，并且不允许访问指定的远程地址
        从以下版本开始：
        1.4

      • disconnect

        public void disconnect​()
        断开插座。 如果插座关闭或未连接，则此方法无效。
        另请参见：
        connect(java.net.InetAddress, int)

      • isBound

        public boolean isBound​()
        返回套接字的绑定状态。

        如果套接字被绑定在closed之前，则该方法将在套接字关闭后继续返回true 。

        结果
        如果套接字成功绑定到一个地址，则为true
        从以下版本开始：
        1.4

      • isConnected

        public boolean isConnected​()
        返回套接字的连接状态。

        如果插座在closed之前已连接，则该方法将在套接字关闭后继续返回true 。

        结果
        如果套接字成功连接到服务器，则为true
        从以下版本开始：
        1.4

      • getInetAddress

        public InetAddress getInetAddress​()
        返回此套接字连接到的地址。 如果套接字未连接，则返回null 。

        如果插座在closed之前已连接，则该方法将在插座关闭后继续返回连接的地址。

        结果
        该插座连接到的地址。

      • getPort

        public int getPort​()
        返回此套接字连接到的端口号。 如果套接字未连接，则返回-1 。

        如果插座在closed之前已连接，则该方法将在插座关闭后继续返回连接的端口号。

        结果
        该套接字连接的端口号。

      • getRemoteSocketAddress

        public SocketAddress getRemoteSocketAddress​()
        返回此套接字连接到的端点的地址，如果未连接，则null 。

        如果插座在closed之前连接，则该方法将在插座关闭后继续返回连接的地址。

        结果
        一个 SocketAddress表示此套接字的远程端点，或 null ，如果它尚未连接。
        从以下版本开始：
        1.4
        另请参见：
        getInetAddress() ，
getPort() ，
connect(SocketAddress)

      • getLocalSocketAddress

        public SocketAddress getLocalSocketAddress​()
        返回此套接字绑定到的端点的地址。
        结果
        一个 SocketAddress表示此套接字的本地端点，如果是封闭或未绑定， null 。
        从以下版本开始：
        1.4
        另请参见：
        getLocalAddress() ，
getLocalPort() ，
bind(SocketAddress)

      • send

        public void send​(DatagramPacket p)
          throws IOException
        从此套接字发送数据报包。 DatagramPacket包括指示要发送的数据，其长度，远程主机的IP地址和远程主机上的端口号的信息。

        如果有安全管理器，并且套接字当前未连接到远程地址，则此方法首先执行一些安全检查。 首先，如果p.getAddress().isMulticastAddress()为真，则该方法调用安全管理器的checkMulticast方法，其中参数为p.getAddress() 。 如果表达式的计算是错误的，这种方法改为调用安全管理器的checkConnect方法与参数p.getAddress().getHostAddress()和p.getPort() 。 每次调用安全管理器方法都可能导致SecurityException，如果不允许操作。

        参数
        p - 要发送的 DatagramPacket 。
        异常
        IOException - 如果发生I / O错误。
        SecurityException - 如果存在安全管理员，并且其 checkMulticast或 checkConnect方法不允许发送。
        PortUnreachableException - 如果套接字连接到当前不可达目的地，则可能会抛出。 注意，不能保证会抛出异常。
        IllegalBlockingModeException - 如果此套接字具有关联的通道，并且通道处于非阻塞模式。
        IllegalArgumentException - 如果套接字连接，并且连接的地址和数据包地址不同。
        另请参见：
        DatagramPacket ， SecurityManager.checkMulticast(InetAddress) ， SecurityManager.checkConnect(java.lang.String, int)

      • receive

        public void receive​(DatagramPacket p)
             throws IOException
        从此套接字接收数据报包。 当此方法返回时， DatagramPacket的缓冲区将填充接收到的数据。 数据包数据包还包含发送者的IP地址和发件人机器上的端口号。

        该方法阻塞，直到接收到数据报。 数据报包对象的length字段包含接收到的消息的长度。 如果消息长于数据包的长度，消息将被截断。

        如果有安全管理员，如果安全管理员的checkAccept方法不允许，则无法接收到数据包。

        参数
        p - 要放入传入数据的 DatagramPacket 。
        异常
        IOException - 如果发生I / O错误。
        SocketTimeoutException - 如果以前调用了setSoTimeout，并且超时已过期。
        PortUnreachableException - 如果套接字连接到当前不可达目的地，可能会抛出。 注意，不能保证会抛出异常。
        IllegalBlockingModeException - 如果此套接字具有关联的通道，并且通道处于非阻塞模式。
        另请参见：
        DatagramPacket ， DatagramSocket

      • getLocalAddress

        public InetAddress getLocalAddress​()
        获取套接字所绑定的本地地址。

        如果有一个安全管理器，它的checkConnect方法首先被调用与主机地址和-1作为参数来查看是否允许操作。

        结果
        套接字绑定的本地地址， null如果套接字关闭，或 InetAddress表示 wildcard地址，如果套接字未绑定，或安全管理器 checkConnect方法不允许操作
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • getLocalPort

        public int getLocalPort​()
        返回此套接字绑定到的本地主机上的端口号。
        结果
        此套接字绑定的本地主机上的端口号， -1如果套接字被关闭，或者 0如果没有约束。

      • setSoTimeout

        public void setSoTimeout​(int timeout)
                  throws SocketException
        以指定的超时（以毫秒为单位）启用/禁用SO_TIMEOUT。 使用此选项设置为非零超时时，此DatagramSocket的receive（）调用将仅阻止此时间。 如果超时超时，则会引发java.net.SocketTimeoutException ，尽管DatagramSocket仍然有效。 必须先启用该选项才能进入阻止操作才能生效。 超时时间必须为> 0 。 超时为零被解释为无限超时。
        参数
        timeout - 以毫秒为单位的指定超时。
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        从以下版本开始：
        1.1
        另请参见：
        getSoTimeout()

      • getSoTimeout

        public int getSoTimeout​()
                 throws SocketException
        检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。
        结果
        SO_TIMEOUT的设置
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        从以下版本开始：
        1.1
        另请参见：
        setSoTimeout(int)

      • setSendBufferSize

        public void setSendBufferSize​(int size)
                       throws SocketException
        将SO_SNDBUF选项设置为此DatagramSocket的指定值。 网络实现使用SO_SNDBUF选项作为底层网络I / O缓冲区大小的提示。 网络实现也可以使用SO_SNDBUF设置来确定可以在此套接字上发送的数据包的最大大小。

        由于SO_SNDBUF是一个提示，想要验证缓冲区大小的应用程序应该调用getSendBufferSize() 。

        当发送速率高时，增加缓冲区大小可允许多个输出数据包被网络实现排队。

        注意：如果使用send(DatagramPacket)发送大于SO_SNDBUF的设置的DatagramPacket ，那么如果发送或丢弃数据包，则它是实现特定的。

        参数
        size - 设置发送缓冲区大小的大小。 该值必须大于0。
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        IllegalArgumentException - 如果值为0或为负数。
        另请参见：
        getSendBufferSize()

      • getSendBufferSize

        public int getSendBufferSize​()
                      throws SocketException
        获取此 DatagramSocket的SO_SNDBUF选项的值，即该平台用于在此 DatagramSocket上输出的缓冲区大小。
        结果
        这个 DatagramSocket的SO_SNDBUF选项的值
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        另请参见：
        setSendBufferSize(int)

      • setReceiveBufferSize

        public void setReceiveBufferSize​(int size)
                          throws SocketException
        将SO_RCVBUF选项设置为此DatagramSocket的指定值。 网络实现使用SO_RCVBUF选项作为底层网络I / O缓冲区大小的提示。 网络实现也可以使用SO_RCVBUF设置来确定可以在此套接字上接收的数据包的最大大小。

        因为SO_RCVBUF是一个提示，想要确定缓冲区的大小设置的应用程序应该调用getReceiveBufferSize() 。

        增加SO_RCVBUF可能允许网络实现缓存多个数据包，当数据包到达的速度比使用receive(DatagramPacket)接收的速度快。

        注意：如果可以接收到大于SO_RCVBUF的数据包，则是实现特定的。

        参数
        size - 设置接收缓冲区大小的大小。 该值必须大于0。
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        IllegalArgumentException - 如果值为0或为负数。
        另请参见：
        getReceiveBufferSize()

      • getReceiveBufferSize

        public int getReceiveBufferSize​()
                         throws SocketException
        获取此 DatagramSocket的SO_RCVBUF选项的值，即该平台在此 DatagramSocket上输入的缓冲区大小。
        结果
        此 DatagramSocket的SO_RCVBUF选项的值
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        另请参见：
        setReceiveBufferSize(int)

      • setReuseAddress

        public void setReuseAddress​(boolean on)
                     throws SocketException
        启用/禁用SO_REUSEADDR套接字选项。

        对于UDP套接字，可能需要将多个套接字绑定到相同的套接字地址。 这通常是为了接收组播数据包（见MulticastSocket ）。 如果在使用bind(SocketAddress)绑定套接字之前启用了SO_REUSEADDR套接字选项，则SO_REUSEADDR套接字选项允许将多个套接字绑定到相同的套接字地址。

        注意：所有现有平台不支持此功能，因此具体实现该选项是否被忽略。 但是如果不支持，那么getReuseAddress()将永远返回false 。

        创建DatagramSocket ，初始设置为SO_REUSEADDR被禁用。

        套接字绑定后启用或禁用SO_REUSEADDR的行为（见isBound() ）未定义。

        参数
        on - 是否启用或禁用
        异常
        SocketException - 如果在启用或禁用 SO_RESUEADDR套接字选项时发生错误，或者套接字已关闭。
        从以下版本开始：
        1.4
        另请参见：
        getReuseAddress() ， bind(SocketAddress) ， isBound() ， isClosed()

      • getReuseAddress

        public boolean getReuseAddress​()
                        throws SocketException
        测试是否启用了SO_REUSEADDR。
        结果
        一个表示是否启用了SO_REUSEADDR的 boolean 。
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        从以下版本开始：
        1.4
        另请参见：
        setReuseAddress(boolean)

      • setBroadcast

        public void setBroadcast​(boolean on)
                  throws SocketException
        启用/禁用SO_BROADCAST。

        某些操作系统可能要求Java虚拟机启动具有实现特定权限以启用此选项或发送广播数据报。

        参数
        on - 是否开启广播。
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        从以下版本开始：
        1.4
        另请参见：
        getBroadcast()

      • getBroadcast

        public boolean getBroadcast​()
                     throws SocketException
        测试是否启用了SO_BROADCAST。
        结果
        一个表示 boolean是否被使能的boolean。
        异常
        SocketException - 如果底层协议有错误，例如UDP错误。
        从以下版本开始：
        1.4
        另请参见：
        setBroadcast(boolean)

      • setTrafficClass

        public void setTrafficClass​(int tc)
                     throws SocketException
        在从该DatagramSocket发送的数据报的IP数据报头中设置流量类别或服务类型的八位字节。 由于底层网络实现可能会忽略此值，应用程序应该考虑一个提示。

        tc 必须在0 <= tc <= 255范围内， 0 <= tc <= 255将抛出IllegalArgumentException异常。

        笔记：

        对于互联网协议v4，该值由integer组成，其最低有效8位表示由套接字发送的IP数据包中的TOS字节的值。 RFC 1349定义了TOS值如下：

        • IPTOS_LOWCOST (0x02)
        • IPTOS_RELIABILITY (0x04)
        • IPTOS_THROUGHPUT (0x08)
        • IPTOS_LOWDELAY (0x10)
        最后一个低位位总是被忽略，因为它对应于MBZ（必须为零）位。

        在优先级字段中设置位可能会导致SocketException表示不允许该操作。

        对于互联网协议v6 tc是将被放置到IP头的sin6_flowinfo字段中的值。

        参数
        tc - 一个 int数值。
        异常
        SocketException - 如果在流量类或服务类型上设置错误
        从以下版本开始：
        1.4
        另请参见：
        getTrafficClass()

      • getTrafficClass

        public int getTrafficClass​()
                    throws SocketException
        在从该DatagramSocket发送的数据包的IP数据报头中获取流量类或服务类型。

        由于底层网络实现可能会忽略使用setTrafficClass(int)的流量类或服务类型， 因此此方法可能会返回与先前使用此DatagramSocket上的setTrafficClass(int)方法设置的值不同的值。

        结果
        流量类或服务类型已经设置
        异常
        SocketException - 如果获取流量类或服务类型值时出错。
        从以下版本开始：
        1.4
        另请参见：
        setTrafficClass(int)

      • close

        public void close​()
        关闭此数据报套接字。

        任何线程当前阻止在receive(java.net.DatagramPacket)这个套接字将抛出一个SocketException 。

        如果此套接字具有关联的通道，则通道也将关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable

      • isClosed

        public boolean isClosed​()
        返回套接字是否关闭。
        结果
        如果套接字已关闭，则为true
        从以下版本开始：
        1.4

      • getChannel

        public DatagramChannel getChannel​()
        返回与该数据报套接字相关联的唯一的DatagramChannel对象（如果有）。

        如果通道本身是通过DatagramChannel.open方法创建的，则只有通道本身才能使用数据报套接字。

        结果
        与该数据报套接字关联的数据报通道，如果此通道未创建此套接字， null
        从以下版本开始：
        1.4

      • setDatagramSocketImplFactory

        public static void setDatagramSocketImplFactory​(DatagramSocketImplFactory fac)
                                         throws IOException
        设置应用程序的数据报套接字实现工厂。 工厂只能指定一次。

        当应用程序创建新的数据报套接字时，将调用套接字实现工厂的createDatagramSocketImpl方法来创建实际的数据报套接字实现。

        通过null的方法是一个无操作，除非工厂已经设置。

        如果有安全管理员，则该方法首先调用安全管理员的checkSetFactory方法，以确保允许操作。 这可能会导致SecurityException。

        参数
        fac - 所需工厂。
        异常
        IOException - 如果在设置数据报套接字工厂时发生I / O错误。
        SocketException - 如果工厂已经定义。
        SecurityException - 如果安全管理器存在，并且其 checkSetFactory方法不允许操作。
        从以下版本开始：
        1.3
        另请参见：
        DatagramSocketImplFactory.createDatagramSocketImpl() ， SecurityManager.checkSetFactory()

      • setOption

        public <T> DatagramSocket setOption​(SocketOption<T> name,
                                    T value)
                             throws IOException
        设置套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能对某些选项有效。
        结果
        这个DatagramSocket
        异常
        UnsupportedOperationException - 如果数据报套接字不支持该选项。
        IllegalArgumentException - 如果该值对该选项无效。
        IOException - 如果发生I / O错误，或者套接字关闭。
        SecurityException - 如果设置了安全管理器，并且套接字选项是否需要安全许可，并且主叫方没有必要的权限。 StandardSocketOptions不需要任何安全许可。
        NullPointerException - 如果名字是 null
        从以下版本开始：
        9

      • getOption

        public <T> T getOption​(SocketOption<T> name)
                throws IOException
        返回套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        套接字选项的值。
        异常
        UnsupportedOperationException - 如果数据报套接字不支持该选项。
        IOException - 如果发生I / O错误，或者套接字关闭。
        NullPointerException - 如果名字是 null
        SecurityException - 如果设置了安全管理器，并且套接字选项是否需要安全许可，并且主叫方没有必要的权限。 StandardSocketOptions不需要任何安全许可。
        从以下版本开始：
        9

      • supportedOptions

        public Set<SocketOption<?>> supportedOptions​()
        返回此套接字支持的一组套接字选项。 即使在套接字关闭后，此方法也将继续返回该选项。
        结果
        该套接字支持的一组套接字选项。 如果套接字的DatagramSocketImpl无法创建，则此集合可能为空。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DatagramSocketImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class DatagramSocketImpl

  • java.lang.Object
    • java.net.DatagramSocketImpl
  • All Implemented Interfaces:
    SocketOptions

    public abstract class DatagramSocketImpl
extends Object
implements SocketOptions
    抽象数据报和组播套接字实现基类。
    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected FileDescriptor fd
      文件描述符对象。
      protected int localPort
      本地端口号。

      • Fields inherited from interface java.net.SocketOptions

        IP_MULTICAST_IF, IP_MULTICAST_IF2, IP_MULTICAST_LOOP, IP_TOS, SO_BINDADDR, SO_BROADCAST, SO_KEEPALIVE, SO_LINGER, SO_OOBINLINE, SO_RCVBUF, SO_REUSEADDR, SO_REUSEPORT, SO_SNDBUF, SO_TIMEOUT, TCP_NODELAY

    • 构造方法摘要

      构造方法
      Constructor 描述
      DatagramSocketImpl​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      protected abstract void bind​(int lport, InetAddress laddr)
      将数据报套接字绑定到本地端口和地址。
      protected abstract void close​()
      关闭插座。
      protected void connect​(InetAddress address, int port)
      将数据报套接字连接到远程目标。
      protected abstract void create​()
      创建数据报套接字。
      protected void disconnect​()
      从其远程目标断开数据报套接字。
      protected FileDescriptor getFileDescriptor​()
      获取数据报套接字文件描述符。
      protected int getLocalPort​()
      获取本地端口。
      protected <T> T getOption​(SocketOption<T> name)
      被称为获取套接字选项。
      protected abstract int getTimeToLive​()
      检索TTL（生存时间）选项。
      protected abstract byte getTTL​()
      已过时。
      使用getTimeToLive代替。
      protected abstract void join​(InetAddress inetaddr)
      加入组播组。
      protected abstract void joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      加入组播组。
      protected abstract void leave​(InetAddress inetaddr)
      离开组播组。
      protected abstract void leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      离开组播组。
      protected abstract int peek​(InetAddress i)
      仔细看看它是从哪里来的。
      protected abstract int peekData​(DatagramPacket p)
      仔细看看它是从哪里来的。
      protected abstract void receive​(DatagramPacket p)
      接收数据报包。
      protected abstract void send​(DatagramPacket p)
      发送数据报包。
      protected <T> void setOption​(SocketOption<T> name, T value)
      调用设置套接字选项。
      protected abstract void setTimeToLive​(int ttl)
      设置TTL（生存时间）选项。
      protected abstract void setTTL​(byte ttl)
      已过时。
      使用setTimeToLive代替。
      protected Set<SocketOption<?>> supportedOptions​()
      返回一个由此impl和该impl的套接字（DatagramSocket或MulticastSocket）支持的SocketOptions，

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.net.SocketOptions

        getOption, setOption

    • 字段详细信息

      • localPort

        protected int localPort
        本地端口号。

      • fd

        protected FileDescriptor fd
        文件描述符对象。

    • 构造方法详细信息

      • DatagramSocketImpl

        public DatagramSocketImpl​()

    • 方法详细信息

      • create

        protected abstract void create​()
                        throws SocketException
        创建数据报套接字。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。

      • bind

        protected abstract void bind​(int lport,
                             InetAddress laddr)
                      throws SocketException
        将数据报套接字绑定到本地端口和地址。
        参数
        lport - 本地端口
        laddr - 本地地址
        异常
        SocketException - 如果底层协议有错误，如TCP错误。

      • send

        protected abstract void send​(DatagramPacket p)
                      throws IOException
        发送数据报包。 该数据包包含要发送数据包的数据和目标地址。
        参数
        p - 要发送的数据包。
        异常
        IOException - 如果在发送数据报包时发生I / O异常。
        PortUnreachableException - 如果套接字连接到当前不可达的目的地，则可能会抛出。 注意，不能保证会抛出异常。

      • connect

        protected void connect​(InetAddress address,
                       int port)
                throws SocketException
        将数据报套接字连接到远程目标。 这将远程地址与本地套接字相关联，以便数据报只能发送到此目的地并从此目的地接收。 这可能会被覆盖以调用本机系统连接。

        如果连接到套接字的远程目的地不存在，否则无法访问，并且如果已经收到该地址的ICMP目标不可达分组，则后续的发送或接收调用可能会引发PortUnreachableException。 注意，不能保证会抛出异常。

        参数
        address - 要连接的远程InetAddress
        port - 远程端口号
        异常
        SocketException - 如果套接字无法连接到远程目标，可能会抛出
        从以下版本开始：
        1.4

      • disconnect

        protected void disconnect​()
        从其远程目标断开数据报套接字。
        从以下版本开始：
        1.4

      • peek

        protected abstract int peek​(InetAddress i)
                     throws IOException
        仔细看看它是从哪里来的。 将指定的InetAddress更新为数据包来自的地址。
        参数
        i - 一个InetAddress对象
        结果
        分组来自的端口号。
        异常
        IOException - 如果发生I / O异常
        PortUnreachableException - 如果套接字连接到当前不可达的目的地，可能会抛出。 注意，不能保证会抛出异常。

      • peekData

        protected abstract int peekData​(DatagramPacket p)
                         throws IOException
        仔细看看它是从哪里来的。 数据被复制到指定的DatagramPacket 。 数据被返回但不被消耗，以便随后的peekData / receive操作将看到相同的数据。
        参数
        p - 分组接收。
        结果
        分组来自的端口号。
        异常
        IOException - 如果发生I / O异常
        PortUnreachableException - 如果套接字连接到当前无法访问的目的地，则可能会抛出。 注意，不能保证会抛出异常。
        从以下版本开始：
        1.4

      • receive

        protected abstract void receive​(DatagramPacket p)
                         throws IOException
        接收数据报包。
        参数
        p - 分组接收。
        异常
        IOException - 如果在接收到数据报包时发生I / O异常。
        PortUnreachableException - 如果套接字连接到当前不可达的目的地，则可能会抛出。 注意，不能保证会抛出异常。

      • setTTL

        @Deprecated
protected abstract void setTTL​(byte ttl)
                        throws IOException
        已过时。 使用setTimeToLive代替。
        设置TTL（生存时间）选项。
        参数
        ttl - 指定TTL值的字节
        异常
        IOException - 如果在设置生存时间选项时发生I / O异常。
        另请参见：
        getTTL()

      • getTTL

        @Deprecated
protected abstract byte getTTL​()
                        throws IOException
        已过时。 使用getTimeToLive代替。
        检索TTL（生存时间）选项。
        结果
        一个表示TTL值的字节
        异常
        IOException - 如果在检索生存时间选项时发生I / O异常
        另请参见：
        setTTL(byte)

      • setTimeToLive

        protected abstract void setTimeToLive​(int ttl)
                               throws IOException
        设置TTL（生存时间）选项。
        参数
        ttl - 指定生存时间值的 int
        异常
        IOException - 如果在设置生存时间选项时发生I / O异常。
        另请参见：
        getTimeToLive()

      • getTimeToLive

        protected abstract int getTimeToLive​()
                              throws IOException
        检索TTL（生存时间）选项。
        结果
        一个 int代表生存时间价值
        异常
        IOException - 如果在检索生存时间选项时发生I / O异常
        另请参见：
        setTimeToLive(int)

      • join

        protected abstract void join​(InetAddress inetaddr)
                      throws IOException
        加入组播组。
        参数
        inetaddr - 要加入的组播地址。
        异常
        IOException - 加入多播组时是否发生I / O异常。

      • leave

        protected abstract void leave​(InetAddress inetaddr)
                       throws IOException
        离开组播组。
        参数
        inetaddr - 多播地址要离开。
        异常
        IOException - 如果在离开多播组时发生I / O异常。

      • joinGroup

        protected abstract void joinGroup​(SocketAddress mcastaddr,
                                  NetworkInterface netIf)
                           throws IOException
        加入组播组。
        参数
        mcastaddr - 加入地址。
        netIf - 指定接收组播数据报包的本地接口
        异常
        IOException - 加入多播组时是否发生I / O异常
        从以下版本开始：
        1.4

      • leaveGroup

        protected abstract void leaveGroup​(SocketAddress mcastaddr,
                                   NetworkInterface netIf)
                            throws IOException
        离开组播组。
        参数
        mcastaddr - 地址离开。
        netIf - 指定本地界面离开组
        异常
        IOException - 如果在离开多播组时发生I / O异常
        从以下版本开始：
        1.4

      • close

        protected abstract void close​()
        关闭插座。

      • getLocalPort

        protected int getLocalPort​()
        获取本地端口。
        结果
        一个表示本地端口值的 int

      • getFileDescriptor

        protected FileDescriptor getFileDescriptor​()
        获取数据报套接字文件描述符。
        结果
        一个表示数据报套接字文件描述符的 FileDescriptor对象

      • setOption

        protected <T> void setOption​(SocketOption<T> name,
                             T value)
                      throws IOException
        调用设置套接字选项。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能对某些选项有效。
        异常
        UnsupportedOperationException - 如果DatagramSocketImpl不支持该选项
        NullPointerException - 如果名字是 null
        IOException - 如果尝试设置选项时发生I / O问题
        从以下版本开始：
        9

      • getOption

        protected <T> T getOption​(SocketOption<T> name)
                   throws IOException
        被称为获取套接字选项。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        套接字选项
        异常
        UnsupportedOperationException - 如果DatagramSocketImpl不支持该选项
        NullPointerException - 如果名字是 null
        IOException - 如果尝试设置选项时发生I / O问题
        从以下版本开始：
        9

      • supportedOptions

        protected Set<SocketOption<?>> supportedOptions​()
        返回一个由此impl和该impl的套接字（DatagramSocket或MulticastSocket）支持的SocketOptions，
        结果
        一套SocketOptions
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


DatagramSocketImplFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface DatagramSocketImplFactory

  • public interface DatagramSocketImplFactory
    该接口为数据报套接字实现定义了一个工厂。 它由类DatagramSocket用于创建实际的套接字实现。
    从以下版本开始：
    1.3
    另请参见：
    DatagramSocket

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      DatagramSocketImpl createDatagramSocketImpl​()
      创建一个新的 DatagramSocketImpl实例。

    • 方法详细信息

      • createDatagramSocketImpl

        DatagramSocketImpl createDatagramSocketImpl​()
        创建一个新的 DatagramSocketImpl实例。
        结果
        一个新的实例 DatagramSocketImpl 。
        另请参见：
        DatagramSocketImpl
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


FileNameMap (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface FileNameMap

  • public interface FileNameMap
    一个简单的界面，提供了一种在文件名和MIME类型字符串之间映射的机制。
    从以下版本开始：
    1.1

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String getContentTypeFor​(String fileName)
      获取指定文件名的MIME类型。

    • 方法详细信息

      • getContentTypeFor

        String getContentTypeFor​(String fileName)
        获取指定文件名的MIME类型。
        参数
        fileName - 指定的文件名
        结果
        一个表示指定文件名的MIME类型的 String 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpCookie (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class HttpCookie

  • java.lang.Object
    • java.net.HttpCookie
  • All Implemented Interfaces:
    Cloneable

    public final class HttpCookie
extends Object
implements Cloneable
    HttpCookie对象表示HTTP cookie，它承载服务器和用户代理之间的状态信息。 Cookie被广泛采用来创建有状态会话。

    有3个HTTP cookie规范：

    Netscape draft
    RFC 2109 - http://www.ietf.org/rfc/rfc2109.txt
    RFC 2965 - http://www.ietf.org/rfc/rfc2965.txt

    HttpCookie类可以接受所有这三种形式的语法。

    从以下版本开始：
    1.6

    • 构造方法摘要

      构造方法
      Constructor 描述
      HttpCookie​(String name, String value)
      构造具有指定名称和值的cookie。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Object clone​()
      创建并返回此对象的副本。
      static boolean domainMatches​(String domain, String host)
      检查主机名是否在域中的实用方法。
      boolean equals​(Object obj)
      测试两个HTTP Cookie的相等性。
      String getComment​()
      返回描述此cookie的目的的注释，如果cookie没有注释，则返回 null 。
      String getCommentURL​()
      返回描述此cookie目的的注释URL，如果cookie没有注释URL，则返回 null 。
      boolean getDiscard​()
      返回cookie的丢弃属性
      String getDomain​()
      返回为此cookie设置的域名。
      long getMaxAge​()
      返回cookie的最大使用年限，以秒为单位。
      String getName​()
      返回cookie的名称。
      String getPath​()
      返回浏览器返回此Cookie的服务器上的路径。
      String getPortlist​()
      返回cookie的端口列表属性
      boolean getSecure​()
      返回 true如果发送此cookie应该被限制为一个安全协议，或者 false如果可以使用任何协议发送。
      String getValue​()
      返回cookie的值。
      int getVersion​()
      返回该Cookie符合的协议版本。
      boolean hasExpired​()
      报告此HTTP Cookie是否已过期。
      int hashCode​()
      返回此HTTP cookie的哈希码。
      boolean isHttpOnly​()
      如果此cookie包含 HttpOnly属性，则返回 true 。
      static List<HttpCookie> parse​(String header)
      从set-cookie或set-cookie2头字符串构造cookie。
      void setComment​(String purpose)
      指定描述Cookie目的的注释。
      void setCommentURL​(String purpose)
      指定描述Cookie目的的注释URL。
      void setDiscard​(boolean discard)
      指定用户代理是否无条件丢弃该cookie。
      void setDomain​(String pattern)
      指定应显示此Cookie的域。
      void setHttpOnly​(boolean httpOnly)
      指示Cookie是否应被视为仅HTTP。
      void setMaxAge​(long expiry)
      设置cookie的最大年龄（秒）。
      void setPath​(String uri)
      指定客户端应该返回cookie的cookie的路径。
      void setPortlist​(String ports)
      指定cookie的端口列表，该端口列表限制Cookie可以在Cookie头中发回的端口。
      void setSecure​(boolean flag)
      指示Cookie是否应仅使用安全协议（如HTTPS或SSL）发送。
      void setValue​(String newValue)
      在创建cookie之后为cookie分配一个新值。
      void setVersion​(int v)
      设置cookie符合的cookie协议的版本。
      String toString​()
      构造此Cookie的Cookie标题字符串表示形式，其格式为相应Cookie规范定义的格式，但不包含前导“Cookie：”标记。

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HttpCookie

        public HttpCookie​(String name,
                  String value)
        构造具有指定名称和值的cookie。

        该名称必须符合RFC 2965.这意味着它只能包含ASCII字母数字字符，不能包含逗号，分号或空格或以$字符开头。 创建后无法更改Cookie的名称。

        该值可以是服务器选择发送的任何值。 它的价值可能仅对服务器感兴趣。 使用setValue方法创建后，cookie的值可以更改。

        默认情况下，根据RFC 2965 cookie规范创建Cookie。 该版本可以通过setVersion方法更改。

        参数
        name - 一个指定cookie名称的 String
        value - 一个 String指定cookie的值
        异常
        IllegalArgumentException - 如果cookie名称包含非法字符
        NullPointerException -如果 name为 null
        另请参见：
        setValue(java.lang.String) ， setVersion(int)

    • 方法详细信息

      • parse

        public static List<HttpCookie> parse​(String header)
        从set-cookie或set-cookie2头字符串构造cookie。 RFC 2965第3.2.2节set-cookie2语法表示一个标题行可能包含多个cookie定义，因此这是一个静态实用程序方法，而不是另一个构造函数。
        参数
        header - 一个String指定set-cookie标题。 标题应以“set-cookie”或“set-cookie2”标记开头; 或者它应该没有领先的标记。
        结果
        从标题行字符串中解析的Cookie列表
        异常
        IllegalArgumentException - 如果头字符串违反了cookie规范的语法，或者cookie名称包含非法字符。
        NullPointerException - 如果标题字符串是 null

      • hasExpired

        public boolean hasExpired​()
        报告此HTTP Cookie是否已过期。
        结果
        true表示此HTTP cookie已过期; 否则， false

      • setComment

        public void setComment​(String purpose)
        指定描述Cookie目的的注释。 如果浏览器向用户显示cookie，则该注释很有用。 Netscape Version 0 cookies不支持评论。
        参数
        purpose - 指定要向用户显示的注释的 String
        另请参见：
        getComment()

      • getComment

        public String getComment​()
        返回描述此cookie的目的的注释，如果cookie没有注释，则返回 null 。
        结果
        一个 String包含注释，或者 null如果没有
        另请参见：
        setComment(java.lang.String)

      • setCommentURL

        public void setCommentURL​(String purpose)
        指定描述Cookie目的的注释URL。 如果浏览器向用户显示cookie，则注释URL很有用。 评论URL仅限于RFC 2965。
        参数
        purpose - 一个 String指定要向用户显示的注释URL
        另请参见：
        getCommentURL()

      • getCommentURL

        public String getCommentURL​()
        返回描述此cookie的目的的注释URL，如果cookie没有注释URL，则返回 null 。
        结果
        一个 String包含注释URL，或者 null如果没有
        另请参见：
        setCommentURL(java.lang.String)

      • setDiscard

        public void setDiscard​(boolean discard)
        指定用户代理是否无条件丢弃该cookie。 这是RFC 2965 only属性。
        参数
        discard - true表示无条件丢弃cookie
        另请参见：
        getDiscard()

      • getDiscard

        public boolean getDiscard​()
        返回cookie的丢弃属性
        结果
        一个 boolean代表这个cookie的丢弃属性
        另请参见：
        setDiscard(boolean)

      • setPortlist

        public void setPortlist​(String ports)
        指定cookie的端口列表，该端口列表限制Cookie可以在Cookie头中发回的端口。
        参数
        ports - a String指定端口列表，它是逗号分隔的数字系列
        另请参见：
        getPortlist()

      • getPortlist

        public String getPortlist​()
        返回cookie的端口列表属性
        结果
        一个 String包含端口列表或 null如果没有
        另请参见：
        setPortlist(java.lang.String)

      • setDomain

        public void setDomain​(String pattern)
        指定应显示此Cookie的域。

        域名的格式由RFC 2965指定。域名以点（ .foo.com ）开头，意味着cookie对于指定的域名系统（DNS）区域中的服务器是可见的（例如， www.foo.com ，但不是a.b.foo.com ）。 默认情况下，Cookie只返回给发送它们的服务器。

        参数
        pattern - 一个String其中包含该cookie可见的域名; 形式根据RFC 2965
        另请参见：
        getDomain()

      • getDomain

        public String getDomain​()
        返回为此cookie设置的域名。 域名的形式由RFC 2965设定。
        结果
        一个包含域名的 String
        另请参见：
        setDomain(java.lang.String)

      • setMaxAge

        public void setMaxAge​(long expiry)
        设置cookie的最大年龄（秒）。

        一个正值表示cookie会在经过很多秒后过期。 请注意，该值是cookie将过期的最大年龄，而不是Cookie的当前年龄。

        负值表示Cookie不会持久存储，并且Web浏览器退出时将被删除。 零值会导致cookie被删除。

        参数
        expiry - 指定cookie的最大年龄（以秒为单位）的整数; 如果为零，则应立即丢弃该cookie; 否则，cookie的最大年龄未指定。
        另请参见：
        getMaxAge()

      • getMaxAge

        public long getMaxAge​()
        返回cookie的最大使用年限，以秒为单位。 默认情况下， -1表示cookie将持续到浏览器关机。
        结果
        一个整数，指定cookie的最大年龄（以秒为单位）
        另请参见：
        setMaxAge(long)

      • setPath

        public void setPath​(String uri)
        指定客户端应该返回cookie的cookie的路径。

        该cookie对于您指定的目录中的所有页面以及该目录子目录中的所有页面都是可见的。 cookie的路径必须包含设置cookie的servlet，例如/ catalog ，这使得cookie可以在/ catalog下的服务器上的所有目录中看到。

        有关设置cookie路径名称的更多信息，请参阅RFC 2965（Internet上可用）。

        参数
        uri - 指定路径的一个 String
        另请参见：
        getPath()

      • getPath

        public String getPath​()
        返回浏览器返回此Cookie的服务器上的路径。 cookie对服务器上的所有子路径都可见。
        结果
        一个 String指定包含servlet名称的路径，例如 / catalog
        另请参见：
        setPath(java.lang.String)

      • setSecure

        public void setSecure​(boolean flag)
        指示Cookie是否应仅使用安全协议（如HTTPS或SSL）发送。

        默认值为false 。

        参数
        flag - 如果是true ，则只能通过HTTPS等安全协议发送cookie。 如果是false ，可以通过任何协议发送。
        另请参见：
        getSecure()

      • getSecure

        public boolean getSecure​()
        返回 true如果发送这个cookie应该被限制在一个安全的协议中，或者是 false如果它可以使用任何协议发送。
        结果
        false如果cookie可以通过任何标准协议发送; 否则， true
        另请参见：
        setSecure(boolean)

      • getName

        public String getName​()
        返回cookie的名称。 创建后无法更改名称。
        结果
        一个 String指定cookie的名称

      • setValue

        public void setValue​(String newValue)
        在创建cookie之后为cookie分配一个新值。 如果使用二进制值，则可能需要使用BASE64编码。

        使用版本0的Cookie，值不应包含空格，括号，括号，等号，逗号，双引号，斜线，问号，符号，冒号和分号。 空值在所有浏览器上的行为可能不一样。

        参数
        newValue - 一个 String指定新值
        另请参见：
        getValue()

      • getValue

        public String getValue​()
        返回cookie的值。
        结果
        一个 String包含cookie的当前值
        另请参见：
        setValue(java.lang.String)

      • getVersion

        public int getVersion​()
        返回该Cookie符合的协议版本。 版本1符合RFC 2965/2109，版本0符合Netscape起草的原始cookie规范。 浏览器提供的Cookie使用浏览器的Cookie版本。
        结果
        0如果cookie符合原始的Netscape规范; 1如果cookie符合RFC 2965/2109
        另请参见：
        setVersion(int)

      • setVersion

        public void setVersion​(int v)
        设置cookie符合的cookie协议的版本。 版本0符合原始的Netscape cookie规范。 版本1符合RFC 2965/2109。
        参数
        v - 0如果cookie应符合原始的Netscape规范; 1如果cookie应符合RFC 2965/2109
        异常
        IllegalArgumentException - 如果 v既不是0也不是1
        另请参见：
        getVersion()

      • isHttpOnly

        public boolean isHttpOnly​()
        如果此cookie包含HttpOnly属性，则返回true 。 这意味着脚本引擎不能访问cookie，比如javascript。
        结果
        true如果这个cookie应该被认为是HTTPOnly
        另请参见：
        setHttpOnly(boolean)

      • setHttpOnly

        public void setHttpOnly​(boolean httpOnly)
        指示Cookie是否应被视为仅HTTP。 如果设置为true则意味着脚本引擎（如JavaScript）不能访问该cookie。
        参数
        httpOnly - 如果 true仅使用cookie HTTP，即仅作为HTTP请求的一部分可见。
        另请参见：
        isHttpOnly()

      • domainMatches

        public static boolean domainMatches​(String domain,
                                    String host)
        检查主机名是否在域中的实用方法。

        这个概念在cookie规范中描述。 要理解这个概念，需要首先定义一些术语：

        effective host name = hostname if host name contains dot
        or = hostname.local if not

        主机A的名称域 - 匹配主机B的，如果：

        • their host name strings string-compare equal; or
        • A is a HDN string and has the form NB, where N is a non-empty name string, B has the form .B', and B' is a HDN string. (So, x.y.com domain-matches .Y.com but not Y.com.)

        如果主机不在域中（RFC 2965秒3.3.2）：

        • The value for the Domain attribute contains no embedded dots, and the value is not .local.
        • The effective host name that derives from the request-host does not domain-match the Domain attribute.
        • The request-host is a HDN (not IP address) and has the form HD, where D is the value of the Domain attribute, and H is a string that contains one or more dots.

        例子：

        • A Set-Cookie2 from request-host y.x.foo.com for Domain=.foo.com would be rejected, because H is y.x and contains a dot.
        • A Set-Cookie2 from request-host x.foo.com for Domain=.foo.com would be accepted.
        • A Set-Cookie2 with Domain=.com or Domain=.com., will always be rejected, because there is no embedded dot.
        • A Set-Cookie2 from request-host example for Domain=.local will be accepted, because the effective host name for the request- host is example.local, and example.local domain-matches .local.
        参数
        domain - 用于检查主机名的域名
        host - 有问题的主机名
        结果
        true如果他们的域匹配; false如果没有

      • toString

        public String toString​()
        构造此Cookie的Cookie标题字符串表示形式，其格式为相应Cookie规范定义的格式，但不包含前导“Cookie：”标记。
        重写：
        toString在类 Object
        结果
        一个字符串形式的cookie。 该字符串具有定义的格式

      • equals

        public boolean equals​(Object obj)
        测试两个HTTP Cookie的相等性。

        结果是true只有两个cookie来自同一个域（不区分大小写），具有相同的名称（不区分大小写），并且具有相同的路径（区分大小写）。

        重写：
        equals在 Object
        参数
        obj - 与之比较的参考对象。
        结果
        true如果两个HTTP cookies相互等价; 否则， false
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此HTTP cookie的哈希码。 结果是这个cookie的三个重要组件的哈希码值的总和：名称，域和路径。 也就是说，哈希码是表达式的值：
        getName().toLowerCase().hashCode()
        + getDomain().toLowerCase().hashCode()
        + getPath().hashCode()
        重写：
        hashCode在 Object
        结果
        这个HTTP cookie的哈希码
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • clone

        public Object clone​()
        创建并返回此对象的副本。
        重写：
        clone在类 Object
        结果
        这个HTTP Cookie的克隆
        另请参见：
        Cloneable
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpRetryException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class HttpRetryException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.HttpRetryException
  • All Implemented Interfaces:
    Serializable

    public class HttpRetryException
extends IOException
    抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      HttpRetryException​(String detail, int code)
      从指定的响应代码和异常详细消息构造一个新的 HttpRetryException
      HttpRetryException​(String detail, int code, String location)
      构造一个新的 HttpRetryException与详细的消息responseCode和位置响应标题字段的内容。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      String getLocation​()
      如果由重定向导致错误，则返回“位置”头域的值。
      String getReason​()
      返回一个字符串，解释为什么不能重试http请求。
      int responseCode​()
      返回http响应代码

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • HttpRetryException

        public HttpRetryException​(String detail,
                          int code)
        从指定的响应代码和异常详细信息构造一个新的 HttpRetryException
        参数
        detail - 详细信息。
        code - 来自服务器的HTTP响应代码。

      • HttpRetryException

        public HttpRetryException​(String detail,
                          int code,
                          String location)
        构造一个新的 HttpRetryException其中包含详细消息responseCode和Location响应头域的内容。
        参数
        detail - 详细信息。
        code - 来自服务器的HTTP响应代码。
        location - 要重定向到的URL

    • 方法详细信息

      • responseCode

        public int responseCode​()
        返回http响应代码
        结果
        http响应代码。

      • getReason

        public String getReason​()
        返回一个字符串，解释为什么不能重试http请求。
        结果
        原因串

      • getLocation

        public String getLocation​()
        如果由重定向导致错误，则返回“位置”头域的值。
        结果
        位置字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


HttpURLConnection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class HttpURLConnection

  • java.lang.Object
    • java.net.URLConnection
      • java.net.HttpURLConnection
  • 已知直接子类：
    HttpsURLConnection

    public abstract class HttpURLConnection
extends URLConnection
    支持HTTP特定功能的URLConnection。 详见the spec 。

    每个HttpURLConnection实例用于单个请求，但是到HTTP服务器的底层网络连接可能被其他实例透明地共享。 在请求之后，在HttpURLConnection的InputStream或OutputStream上调用close（）方法可以释放与该实例关联的网络资源，但对任何共享持久连接没有影响。 调用disconnect（）方法可能会关闭底层套接字，如果持久连接当时是空闲的。

    HTTP协议处理程序有一些可以通过系统属性访问的设置。 这包括Proxy settings以及various other settings 。

    安全权限

    如果安装了一个安全管理器，并且如果调用了一种方法，导致尝试打开一个连接，调用方必须拥有：

    • 将“连接” SocketPermission连接到目标网址的主机/端口组合
    • 一个URLPermission允许这个请求。

    如果启用了自动重定向，并且此请求被重定向到另一目的地，则呼叫者还必须具有连接到重定向主机/ URL的权限。

    从以下版本开始：
    1.1
    另请参见：
    disconnect()

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected int chunkLength
      使用分块编码流模式进行输出时的块长度。
      protected int fixedContentLength
      使用固定长度流式传输模式时的固定内容长度。
      protected long fixedContentLengthLong
      使用固定长度流式传输模式时的固定内容长度。
      static int HTTP_ACCEPTED
      HTTP状态码202：接受。
      static int HTTP_BAD_GATEWAY
      HTTP状态码502：坏网关。
      static int HTTP_BAD_METHOD
      HTTP状态代码405：不允许的方法。
      static int HTTP_BAD_REQUEST
      HTTP状态代码400：错误请求。
      static int HTTP_CLIENT_TIMEOUT
      HTTP状态码408：请求超时。
      static int HTTP_CONFLICT
      HTTP状态代码409：冲突。
      static int HTTP_CREATED
      HTTP状态代码201：创建。
      static int HTTP_ENTITY_TOO_LARGE
      HTTP状态码413：请求实体太大。
      static int HTTP_FORBIDDEN
      HTTP状态码403：禁止。
      static int HTTP_GATEWAY_TIMEOUT
      HTTP状态代码504：网关超时。
      static int HTTP_GONE
      HTTP状态代码410：没有。
      static int HTTP_INTERNAL_ERROR
      HTTP状态码500：内部服务器错误。
      static int HTTP_LENGTH_REQUIRED
      HTTP状态码411：需要长度。
      static int HTTP_MOVED_PERM
      HTTP状态代码301：永久移动。
      static int HTTP_MOVED_TEMP
      HTTP状态码302：临时重定向。
      static int HTTP_MULT_CHOICE
      HTTP状态代码300：多个选择。
      static int HTTP_NO_CONTENT
      HTTP状态代码204：无内容。
      static int HTTP_NOT_ACCEPTABLE
      HTTP状态码406：不可接受
      static int HTTP_NOT_AUTHORITATIVE
      HTTP状态码203：非授权信息。
      static int HTTP_NOT_FOUND
      HTTP状态码404：未找到。
      static int HTTP_NOT_IMPLEMENTED
      HTTP状态码501：未实现。
      static int HTTP_NOT_MODIFIED
      HTTP状态码304：未修改。
      static int HTTP_OK
      HTTP状态码200：确定。
      static int HTTP_PARTIAL
      HTTP状态码206：部分内容。
      static int HTTP_PAYMENT_REQUIRED
      HTTP状态码402：需要支付。
      static int HTTP_PRECON_FAILED
      HTTP状态码412：前提条件失败。
      static int HTTP_PROXY_AUTH
      HTTP状态码407：需要代理验证。
      static int HTTP_REQ_TOO_LONG
      HTTP状态代码414：请求URI太大。
      static int HTTP_RESET
      HTTP状态码205：重置内容。
      static int HTTP_SEE_OTHER
      HTTP状态码303：查看其他。
      static int HTTP_SERVER_ERROR
      已过时。
      它是错误的，不应该存在。
      static int HTTP_UNAUTHORIZED
      HTTP状态码401：未经授权
      static int HTTP_UNAVAILABLE
      HTTP状态码503：服务不可用。
      static int HTTP_UNSUPPORTED_TYPE
      HTTP状态码415：不支持的媒体类型。
      static int HTTP_USE_PROXY
      HTTP状态码305：使用代理。
      static int HTTP_VERSION
      HTTP状态码505：不支持HTTP版本。
      protected boolean instanceFollowRedirects
      如果是 true ，协议会自动跟随重定向。
      protected String method
      HTTP方法（GET，POST，PUT等）。
      protected int responseCode
      一个 int代表三位数的HTTP状态码。
      protected String responseMessage
      HTTP响应消息。

      • Fields inherited from class java.net.URLConnection

        allowUserInteraction, connected, doInput, doOutput, ifModifiedSince, url, useCaches

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected HttpURLConnection​(URL u)
      HttpURLConnection的构造方法。

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void disconnect​()
      表示在不久的将来不太可能对服务器的其他请求。
      InputStream getErrorStream​()
      如果连接失败但服务器发送有用的数据，则返回错误流。
      static boolean getFollowRedirects​()
      返回一个 boolean指示是否应自动遵循HTTP重定向（3xx）。
      String getHeaderField​(int n)
      返回的值 n th头字段。
      long getHeaderFieldDate​(String name, long Default)
      返回以日期解析的命名字段的值。
      String getHeaderFieldKey​(int n)
      返回的关键 n th头字段。
      boolean getInstanceFollowRedirects​()
      返回此 HttpURLConnection的 instanceFollowRedirects字段的值。
      Permission getPermission​()
      返回一个SocketPermission对象，表示连接到目标主机和端口所需的权限。
      String getRequestMethod​()
      获取请求方法。
      int getResponseCode​()
      从HTTP响应消息获取状态代码。
      String getResponseMessage​()
      获取与服务器的响应代码一起返回的HTTP响应消息（如果有）。
      void setAuthenticator​(Authenticator auth)
      提供一个Authenticator ，通过HTTP协议为此HttpURLConnection请求认证时使用。
      void setChunkedStreamingMode​(int chunklen)
      当内容长度 未提前知道时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。
      void setFixedLengthStreamingMode​(int contentLength)
      当预先知道内容长度时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。
      void setFixedLengthStreamingMode​(long contentLength)
      当预先知道内容长度时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。
      static void setFollowRedirects​(boolean set)
      设置HTTP重定向（具有响应代码3xx的请求）是否应该在该类之后自动跟随。
      void setInstanceFollowRedirects​(boolean followRedirects)
      设置HTTP重定向（响应代码为3xx的请求）是否应该由此 HttpURLConnection实例自动跟随。
      void setRequestMethod​(String method)
      设置URL请求的方法，其中之一是：GET POST HEAD OPTIONS PUT DELETE TRACE是符合协议限制的合法的。
      abstract boolean usingProxy​()
      指示连接正在通过代理。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.net.URLConnection

        addRequestProperty, connect, getAllowUserInteraction, getConnectTimeout, getContent, getContent, getContentEncoding, getContentLength, getContentLengthLong, getContentType, getDate, getDefaultAllowUserInteraction, getDefaultRequestProperty, getDefaultUseCaches, getDefaultUseCaches, getDoInput, getDoOutput, getExpiration, getFileNameMap, getHeaderField, getHeaderFieldInt, getHeaderFieldLong, getHeaderFields, getIfModifiedSince, getInputStream, getLastModified, getOutputStream, getReadTimeout, getRequestProperties, getRequestProperty, getURL, getUseCaches, guessContentTypeFromName, guessContentTypeFromStream, setAllowUserInteraction, setConnectTimeout, setContentHandlerFactory, setDefaultAllowUserInteraction, setDefaultRequestProperty, setDefaultUseCaches, setDefaultUseCaches, setDoInput, setDoOutput, setFileNameMap, setIfModifiedSince, setReadTimeout, setRequestProperty, setUseCaches, toString

    • 字段详细信息

      • method

        protected String method
        HTTP方法（GET，POST，PUT等）。

      • chunkLength

        protected int chunkLength
        使用分块编码流模式进行输出时的块长度。 值为-1表示分块编码被禁用输出。
        从以下版本开始：
        1.5

      • fixedContentLength

        protected int fixedContentLength
        使用固定长度流式传输模式时的固定内容长度。 值-1意味着固定长度流模式被禁用输出。

        注意：建议使用fixedContentLengthLong而不是此字段，因为它允许设置更大的内容长度。

        从以下版本开始：
        1.5

      • fixedContentLengthLong

        protected long fixedContentLengthLong
        使用固定长度流式传输模式时的固定内容长度。 值为-1意味着固定长度流模式被禁用输出。
        从以下版本开始：
        1.7

      • responseCode

        protected int responseCode
        一个int代表三位数的HTTP状态码。
        • 1xx：信息
        • 2xx：成功
        • 3xx：重定向
        • 4xx：客户端错误
        • 5xx：服务器错误

      • responseMessage

        protected String responseMessage
        HTTP响应消息。

      • instanceFollowRedirects

        protected boolean instanceFollowRedirects
        如果true ，协议将自动跟随重定向。 如果是false ，协议不会自动跟随重定向。

        该字段由setInstanceFollowRedirects方法设置。 其值由getInstanceFollowRedirects方法返回。

        其默认值基于HttpURLConnection构建时间的静态followRedirect的值。

        另请参见：
        setInstanceFollowRedirects(boolean) ， getInstanceFollowRedirects() ， setFollowRedirects(boolean)

      • HTTP_OK

        public static final int HTTP_OK
        HTTP状态码200：确定。
        另请参见：
        Constant Field Values

      • HTTP_CREATED

        public static final int HTTP_CREATED
        HTTP状态代码201：创建。
        另请参见：
        Constant Field Values

      • HTTP_ACCEPTED

        public static final int HTTP_ACCEPTED
        HTTP状态码202：接受。
        另请参见：
        Constant Field Values

      • HTTP_NOT_AUTHORITATIVE

        public static final int HTTP_NOT_AUTHORITATIVE
        HTTP状态码203：非授权信息。
        另请参见：
        Constant Field Values

      • HTTP_NO_CONTENT

        public static final int HTTP_NO_CONTENT
        HTTP状态代码204：无内容。
        另请参见：
        Constant Field Values

      • HTTP_RESET

        public static final int HTTP_RESET
        HTTP状态码205：重置内容。
        另请参见：
        Constant Field Values

      • HTTP_PARTIAL

        public static final int HTTP_PARTIAL
        HTTP状态码206：部分内容。
        另请参见：
        Constant Field Values

      • HTTP_MULT_CHOICE

        public static final int HTTP_MULT_CHOICE
        HTTP状态代码300：多个选择。
        另请参见：
        Constant Field Values

      • HTTP_MOVED_PERM

        public static final int HTTP_MOVED_PERM
        HTTP状态代码301：永久移动。
        另请参见：
        Constant Field Values

      • HTTP_MOVED_TEMP

        public static final int HTTP_MOVED_TEMP
        HTTP状态码302：临时重定向。
        另请参见：
        Constant Field Values

      • HTTP_SEE_OTHER

        public static final int HTTP_SEE_OTHER
        HTTP状态码303：查看其他。
        另请参见：
        Constant Field Values

      • HTTP_NOT_MODIFIED

        public static final int HTTP_NOT_MODIFIED
        HTTP状态码304：未修改。
        另请参见：
        Constant Field Values

      • HTTP_USE_PROXY

        public static final int HTTP_USE_PROXY
        HTTP状态码305：使用代理。
        另请参见：
        Constant Field Values

      • HTTP_BAD_REQUEST

        public static final int HTTP_BAD_REQUEST
        HTTP状态代码400：错误请求。
        另请参见：
        Constant Field Values

      • HTTP_UNAUTHORIZED

        public static final int HTTP_UNAUTHORIZED
        HTTP状态码401：未经授权
        另请参见：
        Constant Field Values

      • HTTP_PAYMENT_REQUIRED

        public static final int HTTP_PAYMENT_REQUIRED
        HTTP状态码402：需要支付。
        另请参见：
        Constant Field Values

      • HTTP_FORBIDDEN

        public static final int HTTP_FORBIDDEN
        HTTP状态码403：禁止。
        另请参见：
        Constant Field Values

      • HTTP_NOT_FOUND

        public static final int HTTP_NOT_FOUND
        HTTP状态码404：未找到。
        另请参见：
        Constant Field Values

      • HTTP_BAD_METHOD

        public static final int HTTP_BAD_METHOD
        HTTP状态代码405：不允许的方法。
        另请参见：
        Constant Field Values

      • HTTP_NOT_ACCEPTABLE

        public static final int HTTP_NOT_ACCEPTABLE
        HTTP状态码406：不可接受
        另请参见：
        Constant Field Values

      • HTTP_PROXY_AUTH

        public static final int HTTP_PROXY_AUTH
        HTTP状态码407：需要代理验证。
        另请参见：
        Constant Field Values

      • HTTP_CLIENT_TIMEOUT

        public static final int HTTP_CLIENT_TIMEOUT
        HTTP状态码408：请求超时。
        另请参见：
        Constant Field Values

      • HTTP_CONFLICT

        public static final int HTTP_CONFLICT
        HTTP状态代码409：冲突。
        另请参见：
        Constant Field Values

      • HTTP_GONE

        public static final int HTTP_GONE
        HTTP状态代码410：没有。
        另请参见：
        Constant Field Values

      • HTTP_LENGTH_REQUIRED

        public static final int HTTP_LENGTH_REQUIRED
        HTTP状态码411：需要长度。
        另请参见：
        Constant Field Values

      • HTTP_PRECON_FAILED

        public static final int HTTP_PRECON_FAILED
        HTTP状态码412：前提条件失败。
        另请参见：
        Constant Field Values

      • HTTP_ENTITY_TOO_LARGE

        public static final int HTTP_ENTITY_TOO_LARGE
        HTTP状态码413：请求实体太大。
        另请参见：
        Constant Field Values

      • HTTP_REQ_TOO_LONG

        public static final int HTTP_REQ_TOO_LONG
        HTTP状态代码414：请求URI太大。
        另请参见：
        Constant Field Values

      • HTTP_UNSUPPORTED_TYPE

        public static final int HTTP_UNSUPPORTED_TYPE
        HTTP状态码415：不支持的媒体类型。
        另请参见：
        Constant Field Values

      • HTTP_SERVER_ERROR

        @Deprecated
public static final int HTTP_SERVER_ERROR
        已过时。 它是错误的，不应该存在。
        HTTP状态码500：内部服务器错误。
        另请参见：
        Constant Field Values

      • HTTP_INTERNAL_ERROR

        public static final int HTTP_INTERNAL_ERROR
        HTTP状态码500：内部服务器错误。
        另请参见：
        Constant Field Values

      • HTTP_NOT_IMPLEMENTED

        public static final int HTTP_NOT_IMPLEMENTED
        HTTP状态码501：未实现。
        另请参见：
        Constant Field Values

      • HTTP_BAD_GATEWAY

        public static final int HTTP_BAD_GATEWAY
        HTTP状态码502：坏网关。
        另请参见：
        Constant Field Values

      • HTTP_UNAVAILABLE

        public static final int HTTP_UNAVAILABLE
        HTTP状态码503：服务不可用。
        另请参见：
        Constant Field Values

      • HTTP_GATEWAY_TIMEOUT

        public static final int HTTP_GATEWAY_TIMEOUT
        HTTP状态代码504：网关超时。
        另请参见：
        Constant Field Values

      • HTTP_VERSION

        public static final int HTTP_VERSION
        HTTP状态码505：不支持HTTP版本。
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • HttpURLConnection

        protected HttpURLConnection​(URL u)
        HttpURLConnection的构造方法。
        参数
        u - 网址

    • 方法详细信息

      • setAuthenticator

        public void setAuthenticator​(Authenticator auth)
        提供一个Authenticator ，通过HTTP协议为此HttpURLConnection请求认证时使用。 如果没有提供验证码，将使用default authenticator 。
        实现要求：
        该方法的默认行为是无条件抛出UnsupportedOperationException 。 的具体实现HttpURLConnection支持供给Authenticator特定HttpURLConnection实例应该重写此方法来实现不同的行为。
        Implementation Note:
        根据认证方案，实现可能需要使用提供的认证器来获取密码。 例如，如果这些库被配置为这样做，依赖于第三方安全库的实现可能仍然会调用默认验证器。 同样，支持透明NTLM身份验证的实现可能会在调用提供的身份验证者之前先尝试使用系统用户凭据进行连接。
        然而，如果具体提供的认证，则底层的连接可以仅针对重用HttpURLConnection实例共享同一Authenticator实例，认证信息，如果高速缓存，可以仅重新使用用于HttpURLConnection共享同一Authenticator 。
        参数
        auth - Authenticator应该由这个 HttpURLConnection 。
        异常
        UnsupportedOperationException - 如果底层实现不支持设置Authenticator。
        IllegalStateException - 如果URLConnection已连接。
        NullPointerException - 如果提供的 auth是 null 。
        从以下版本开始：
        9

      • getHeaderFieldKey

        public String getHeaderFieldKey​(int n)
        返回的关键n th头字段。 一些实现可以治疗0 th头字段作为特殊的，即由HTTP服务器返回的状态行。 在这种情况下， getHeaderField(0)返回状态行，但是getHeaderFieldKey(0)返回null。
        重写：
        getHeaderFieldKey在 URLConnection
        参数
        n - 一个索引，其中 n >=0 。
        结果
        的键控 n th头字段，或者 null如果键不存在。

      • setFixedLengthStreamingMode

        public void setFixedLengthStreamingMode​(int contentLength)
        当预先知道内容长度时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。

        如果应用程序尝试写入比指定的内容长度更多的数据，或者如果应用程序在写入指定的数量之前关闭OutputStream，则会抛出异常。

        启用输出流时，无法自动处理身份验证和重定向。 当需要验证或重定向时读取响应时，将抛出HttpRetryException异常。 可以查询错误的详细信息。

        必须在连接URLConnection之前调用此方法。

        注意：建议使用setFixedLengthStreamingMode(long)代替此方法，因为它允许设置较大的内容长度。

        参数
        contentLength - 将要写入OutputStream的字节数。
        异常
        IllegalStateException - 如果URLConnection已连接，或者是否已启用不同的流式传输模式。
        IllegalArgumentException - 如果指定内容长度小于零。
        从以下版本开始：
        1.5
        另请参见：
        setChunkedStreamingMode(int)

      • setFixedLengthStreamingMode

        public void setFixedLengthStreamingMode​(long contentLength)
        当预先知道内容长度时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。

        如果应用程序尝试写入比指定的内容长度更多的数据，或者如果应用程序在写入指定的数量之前关闭OutputStream，则会抛出异常。

        启用输出流时，无法自动处理身份验证和重定向。 如果需要验证或重定向，则在读取响应时将抛出HttpRetryException 。 可以查询错误的详细信息。

        必须在连接URLConnection之前调用此方法。

        通过调用此方法设置的内容长度优先于由setFixedLengthStreamingMode(int)设置的任何值。

        参数
        contentLength - 将要写入OutputStream的字节数。
        异常
        IllegalStateException - 如果URLConnection已连接或者已启用不同的流式传输模式。
        IllegalArgumentException - 如果指定了小于零的内容长度。
        从以下版本开始：
        1.7

      • setChunkedStreamingMode

        public void setChunkedStreamingMode​(int chunklen)
        当内容长度未提前知道时，此方法用于启用HTTP请求体的流式传输，而无需内部缓冲。 在这种模式下，使用分块传输编码来发送请求体。 请注意，并非所有HTTP服务器都支持此模式。

        启用输出流时，无法自动处理身份验证和重定向。 当需要验证或重定向时读取响应时，将抛出HttpRetryException异常。 可以查询错误的详细信息。

        必须在连接URLConnection之前调用此方法。

        参数
        chunklen - 要在每个块中写入的字节数。 如果chunklen小于或等于零，将使用默认值。
        异常
        IllegalStateException - 如果URLConnection已连接或者已启用不同的流式传输模式。
        从以下版本开始：
        1.5
        另请参见：
        setFixedLengthStreamingMode(int)

      • getHeaderField

        public String getHeaderField​(int n)
        返回的值n th头字段。 一些实现可以治疗0 th头字段作为特殊的，即由HTTP服务器返回的状态行。

        该方法可以与getHeaderFieldKey方法结合使用，以遍历消息中的所有头。

        重写：
        getHeaderField在 URLConnection
        参数
        n - 一个索引，其中 n>=0 。
        结果
        所述的值 n th头字段，或者 null如果该值不存在。
        另请参见：
        getHeaderFieldKey(int)

      • setFollowRedirects

        public static void setFollowRedirects​(boolean set)
        设置HTTP重定向（具有响应代码3xx的请求）是否应该在该类之后自动跟随。 默认为true。 Applet无法更改此变量。

        如果有安全管理员，则该方法首先调用安全管理员的checkSetFactory方法，以确保允许操作。 这可能会导致SecurityException。

        参数
        set - 表示是否遵循HTTP重定向的 boolean 。
        异常
        SecurityException - 如果存在安全管理员，并且其 checkSetFactory方法不允许该操作。
        另请参见：
        SecurityManager.checkSetFactory() ， getFollowRedirects()

      • getFollowRedirects

        public static boolean getFollowRedirects​()
        返回一个 boolean指示是否应自动跟踪HTTP重定向（3xx）。
        结果
        true如果HTTP重定向应该自动跟随， false如果没有。
        另请参见：
        setFollowRedirects(boolean)

      • setInstanceFollowRedirects

        public void setInstanceFollowRedirects​(boolean followRedirects)
        设置HTTP重定向（响应代码为3xx的请求）是否应该由此HttpURLConnection实例自动跟随。

        默认值来自followRedirects，默认值为true。

        参数
        followRedirects - 一个表示是否遵循HTTP重定向的 boolean 。
        从以下版本开始：
        1.3
        另请参见：
        instanceFollowRedirects ， getInstanceFollowRedirects()

      • getInstanceFollowRedirects

        public boolean getInstanceFollowRedirects​()
        返回此 HttpURLConnection的 instanceFollowRedirects字段的值。
        结果
        该值为 HttpURLConnection的 instanceFollowRedirects字段。
        从以下版本开始：
        1.3
        另请参见：
        instanceFollowRedirects ， setInstanceFollowRedirects(boolean)

      • setRequestMethod

        public void setRequestMethod​(String method)
                      throws ProtocolException
        设置URL请求的方法，其中之一：
        • 得到
        • POST
        • 头
        • OPTIONS
        • 放
        • 删除
        • 跟踪
        符合协议限制。 默认方法是GET。
        参数
        method - HTTP方法
        异常
        ProtocolException - 如果方法无法重置或请求的方法对HTTP无效。
        SecurityException - 如果设置了安全管理器，并且方法为“TRACE”，但未授予“allowHttpTrace”NetPermission。
        另请参见：
        getRequestMethod()

      • getRequestMethod

        public String getRequestMethod​()
        获取请求方法。
        结果
        HTTP请求方法
        另请参见：
        setRequestMethod(java.lang.String)

      • getResponseCode

        public int getResponseCode​()
                    throws IOException
        从HTTP响应消息获取状态代码。 例如，在以下状态行的情况下：
          HTTP/1.0 200 OK
 HTTP/1.0 401 Unauthorized
        它将分别返回200和401。 如果不能从响应中识别出代码（即响应无效），则返回-1。
        结果
        HTTP状态代码或-1
        异常
        IOException - 如果连接到服务器发生错误。

      • getResponseMessage

        public String getResponseMessage​()
                          throws IOException
        获取与服务器的响应代码一起返回的HTTP响应消息（如果有）。 从响应如：
          HTTP/1.0 200 OK
 HTTP/1.0 404 Not Found
        分别提取字符串“确定”和“未找到”。 如果无法从响应中识别出结果（结果无效HTTP），则返回null。
        结果
        HTTP响应消息，或 null
        异常
        IOException - 如果连接到服务器发生错误。

      • getHeaderFieldDate

        public long getHeaderFieldDate​(String name,
                               long Default)
        说明从类别复制URLConnection
        返回以日期解析的命名字段的值。 结果是自1970年1月1日GMT以指定字段表示的毫秒数。

        存在此形式的getHeaderField ，因为某些连接类型（例如， http-ng ）具有预解析头。 该连接类型的类可以覆盖此方法并使解析短路。

        重写：
        getHeaderFieldDate在 URLConnection
        参数
        name - 标题字段的名称。
        Default - 默认值。
        结果
        该字段的值被解析为日期。 如果字段丢失或格式错误，则返回Default参数的值。

      • disconnect

        public abstract void disconnect​()
        表示在不久的将来不太可能对服务器的其他请求。 调用disconnect（）不应该意味着这个HttpURLConnection实例可以重用于其他请求。

      • usingProxy

        public abstract boolean usingProxy​()
        指示连接正在通过代理。
        结果
        一个布尔值，指示连接是否正在使用代理。

      • getPermission

        public Permission getPermission​()
                         throws IOException
        返回表示连接到目标主机和端口所需的权限的SocketPermission对象。
        重写：
        getPermission在 URLConnection
        结果
        一个 SocketPermission对象，表示连接到目标主机和端口所需的权限。
        异常
        IOException - 计算权限时是否发生错误。

      • getErrorStream

        public InputStream getErrorStream​()
        如果连接失败但服务器发送有用的数据，则返回错误流。 典型的例子是当一个HTTP服务器响应一个404，这将导致FileNotFoundException在连接中抛出，但是服务器发送了一个HTML帮助页面，并提供了关于该做什么的建议。

        此方法不会导致连接启动。 如果连接未连接，或者服务器在连接时没有出现错误，或者服务器发生错误但没有发送错误数据，则此方法将返回null。 这是默认值。

        结果
        错误流（如果有），如果没有出现错误，则为null，连接未连接或服务器没有发送有用数据。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


IDN (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class IDN

  • java.lang.Object
    • java.net.IDN

  • public final class IDN
extends Object
    提供在正常Unicode表示和ASCII兼容编码（ACE）表示之间转换国际化域名（IDN）的方法。 国际化的域名可以使用整个Unicode范围内的字符，而传统的域名仅限于ASCII字符。 ACE是仅使用ASCII字符的Unicode字符串的编码，可以与仅了解传统域名的软件（如域名系统）一起使用。

    国际化域名定义在RFC 3490 。 RFC 3490定义了两个操作：ToASCII和ToUnicode。 这两个操作采用Nameprep算法，它是Stringprep和Punycode算法的轮廓来转换域名字符串的算法。

    上述转换过程的行为可以通过各种标志进行调整：

    • 如果使用ALLOW_UNASSIGNED标志，则要转换的域名字符串可以包含Unicode 3.2中未分配的代码点，这是以IDN转换为基础的Unicode版本。 如果不使用标志，则将这种未分配的代码点的存在视为错误。
    • 如果使用USE_STD3_ASCII_RULES标志，则会对RFC 1122和RFC 1123检查ASCII字符串。 如果不符合要求，这是一个错误。
    这些标志可以在逻辑上进行OR。

    安全考虑在国际化域名支持方面很重要。 例如，英文域名可homographed -以非拉丁字母取代恶意拼写错误。 Unicode Technical Report #36讨论了IDN支持的安全问题以及可能的解决方案。 应用程序负责在使用国际域名时采取足够的安全措施。

    从以下版本开始：
    1.6

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int ALLOW_UNASSIGNED
      标志允许处理未分配的代码点
      static int USE_STD3_ASCII_RULES
      标志打开对STD-3 ASCII规则的检查

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static String toASCII​(String input)
      将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。
      static String toASCII​(String input, int flag)
      将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作 RFC 3490定义。
      static String toUnicode​(String input)
      将字符串从ASCII兼容编码（ACE）转换为Unicode，由ToUnicode操作 RFC 3490定义。
      static String toUnicode​(String input, int flag)
      将字符串从ASCII兼容编码（ACE）转换为Unicode，由ToUnicode操作定义为 RFC 3490 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ALLOW_UNASSIGNED

        public static final int ALLOW_UNASSIGNED
        标志允许处理未分配的代码点
        另请参见：
        Constant Field Values

      • USE_STD3_ASCII_RULES

        public static final int USE_STD3_ASCII_RULES
        标志打开对STD-3 ASCII规则的检查
        另请参见：
        Constant Field Values

    • 方法详细信息

      • toASCII

        public static String toASCII​(String input,
                             int flag)
        将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作RFC 3490定义。

        ToASCII操作可能会失败。 如果任何一个步骤失败，ToASCII将失败。 如果ToASCII操作失败，将抛出IllegalArgumentException异常。 在这种情况下，输入字符串不应该在国际化的域名中使用。

        标签是域名的独立部分。 原始的ToASCII操作，如RFC 3490中定义的，仅在单个标签上运行。 该方法可以通过假设域名中的标签总是以点分隔来处理标签和整个域名。 以下字符被识别为点：\ u002E（全停），\ u3002（表意全部停止），\ uFF0E（全宽完全停止）和\ uFF61（半角表意全部停止）。 如果使用点作为标签分隔符，则该方法也会在输出翻译的字符串中将其全部更改为\ u002E（全停）。

        参数
        input - 要处理的字符串
        flag - 进程标志 可以是0或任何逻辑OR可能的标志
        结果
        翻译的 String
        异常
        IllegalArgumentException - 如果输入字符串不符合RFC 3490规范

      • toASCII

        public static String toASCII​(String input)
        将字符串从Unicode转换为ASCII兼容编码（ACE），由ToASCII操作RFC 3490定义。

        这种方便的方法就像通过调用双参数对应方法一样工作，如下所示：

        toASCII(input, 0);
        参数
        input - 要处理的字符串
        结果
        翻译 String
        异常
        IllegalArgumentException - 如果输入字符串不符合RFC 3490规范

      • toUnicode

        public static String toUnicode​(String input,
                               int flag)
        将字符串从ASCII兼容编码（ACE）转换为Unicode，由ToUnicode操作RFC 3490定义。

        ToUnicode永远不会失败 在任何错误的情况下，输入字符串未修改。

        标签是域名的独立部分。 RFC 3490中定义的原始ToUnicode操作仅在单个标签上运行。 该方法可以通过假设域名中的标签总是以点分隔来处理标签和整个域名。 以下字符被识别为点：\ u002E（全停），\ u3002（表意全部停止），\ uFF0E（全宽完全停止）和\ uFF61（半角表意全部停止）。

        参数
        input - 要处理的字符串
        flag - 进程标志 可以是0或任何逻辑OR可能的标志
        结果
        翻译 String

      • toUnicode

        public static String toUnicode​(String input)
        将字符串从ASCII兼容编码（ACE）转换为Unicode，由ToUnicode操作RFC 3490定义。

        这种方便的方法就像通过调用双参数对应方法一样工作，如下所示：

        toUnicode(input, 0);
        参数
        input - 要处理的字符串
        结果
        翻译 String
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Inet4Address (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class Inet4Address

  • java.lang.Object
    • java.net.InetAddress
      • java.net.Inet4Address
  • All Implemented Interfaces:
    Serializable

    public final class Inet4Address
extends InetAddress
    该类表示Internet协议版本4（IPv4）地址。 通过定义RFC 790: Assigned Numbers ， RFC 1918: Address Allocation for Private Internets ，并RFC 2365: Administratively Scoped IP Multicast

    Textual representation of IP addresses

    用作方法输入的IPv4地址的文本表示方式采用以下形式之一：
    • d.d.d.d
    • d.d.d
    • d.d
    • d

    当指定四个部分时，每个被解释为数据的字节，并从IPv4到IPv4地址的四个字节从左到右分配。

    当指定三部分地址时，最后一部分被解释为16位数量，并放置在网络地址的最右边两个字节。 这使得三部分地址格式方便地将B类网络地址指定为128.net.host。

    当提供两部分地址时，最后一部分被解释为24位数量，并放置在网络地址的最右边三个字节。 这使得两部分地址格式方便地将A类网络地址指定为net.host。

    当仅给出一部分时，该值直接存储在网络地址中，无需任何字节重排。

    对于返回文本表示作为输出值的方法，使用第一种形式，即点划线字符串。

    组播地址的范围

    历史上，IP报头中的IPv4 TTL字段作为组播范围字段翻了一番：TTL为0表示节点本地，1表示链路本地，直到32表示站点本地，直到64表示区域本地，向上128表示大陆本地，最多255个是全局的。 但是，行政范围是首选。 请参考RFC 2365: Administratively Scoped IP Multicast
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      byte[] getAddress​()
      返回此 InetAddress对象的原始IP地址。
      String getHostAddress​()
      以文本表示形式返回IP地址字符串。
      int hashCode​()
      返回此IP地址的哈希码。
      boolean isAnyLocalAddress​()
      检查InetAddress是否为通配符地址的实用程序。
      boolean isLinkLocalAddress​()
      检查InetAddress是否是链接本地地址的实用程序。
      boolean isLoopbackAddress​()
      检查InetAddress是否是环回地址的实用程序。
      boolean isMCGlobal​()
      检查多播地址是否具有全局范围的实用程序。
      boolean isMCLinkLocal​()
      检查组播地址是否具有链路范围的实用程序。
      boolean isMCNodeLocal​()
      检查多播地址是否具有节点范围的实用程序。
      boolean isMCOrgLocal​()
      检查组播地址是否具有组织范围的实用程序。
      boolean isMCSiteLocal​()
      检查多播地址是否具有站点范围的实用程序。
      boolean isMulticastAddress​()
      检查InetAddress是否是IP组播地址的实用程序。
      boolean isSiteLocalAddress​()
      检查InetAddress是否是站点本地地址的实用程序。

      • Methods inherited from class java.net.InetAddress

        getAllByName, getByAddress, getByAddress, getByName, getCanonicalHostName, getHostName, getLocalHost, getLoopbackAddress, isReachable, isReachable, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • isMulticastAddress

        public boolean isMulticastAddress​()
        检查InetAddress是否是IP组播地址的实用程序。 IP组播地址是D类地址，即地址的前四位为1110。
        重写：
        isMulticastAddress在 InetAddress
        结果
        一个 boolean指示InetAddress是否是IP组播地址

      • isAnyLocalAddress

        public boolean isAnyLocalAddress​()
        检查InetAddress是否为通配符地址的实用程序。
        重写：
        isAnyLocalAddress在 InetAddress
        结果
        一个 boolean指示Inetaddress是否是通配符地址。

      • isLoopbackAddress

        public boolean isLoopbackAddress​()
        检查InetAddress是否是环回地址的实用程序。
        重写：
        isLoopbackAddress在 InetAddress
        结果
        一个boolean指示InetAddress是否是一个环回地址; 否则为false。

      • isLinkLocalAddress

        public boolean isLinkLocalAddress​()
        检查InetAddress是否是链接本地地址的实用程序。
        重写：
        isLinkLocalAddress在 InetAddress
        结果
        一个boolean指示InetAddress是否是链路本地地址; 如果地址不是链路本地单播地址，则为false。

      • isSiteLocalAddress

        public boolean isSiteLocalAddress​()
        检查InetAddress是否是站点本地地址的实用程序。
        重写：
        isSiteLocalAddress在 InetAddress
        结果
        一个boolean指示InetAddress是否是一个站点本地地址; 如果地址不是站点本地单播地址，则为false。

      • isMCGlobal

        public boolean isMCGlobal​()
        检查多播地址是否具有全局范围的实用程序。
        重写：
        isMCGlobal在 InetAddress
        结果
        一个 boolean指示地址是否是全局范围的多播地址，如果不是全局范围，则为false，或者不是多播地址

      • isMCNodeLocal

        public boolean isMCNodeLocal​()
        检查多播地址是否具有节点范围的实用程序。
        重写：
        isMCNodeLocal在 InetAddress
        结果
        一个 boolean指示地址是否是节点本地作用域的多播地址，如果不是节点本地作用域，则为false，或者不是多播地址

      • isMCLinkLocal

        public boolean isMCLinkLocal​()
        检查组播地址是否具有链路范围的实用程序。
        重写：
        isMCLinkLocal在 InetAddress
        结果
        一个 boolean指示地址是否是链路本地范围的多播地址，如果不是链路本地范围或不是多播地址，则为false

      • isMCSiteLocal

        public boolean isMCSiteLocal​()
        检查多播地址是否具有站点范围的实用程序。
        重写：
        isMCSiteLocal在 InetAddress
        结果
        一个 boolean指示地址是否是站点本地范围的多播地址，如果不是站点本地作用域，则为false，或者不是多播地址

      • isMCOrgLocal

        public boolean isMCOrgLocal​()
        检查组播地址是否具有组织范围的实用程序。
        重写：
        isMCOrgLocal在 InetAddress
        结果
        一个 boolean指示地址是否是组织本地作用域的组播地址，如果不是组织本地作用域，或者不是组播地址，则为false

      • getAddress

        public byte[] getAddress​()
        返回此InetAddress对象的原始IP地址。 结果是网络字节顺序：地址的最高位字节在getAddress()[0] 。
        重写：
        getAddress在 InetAddress
        结果
        该对象的原始IP地址。

      • getHostAddress

        public String getHostAddress​()
        以文本表示形式返回IP地址字符串。
        重写：
        getHostAddress在 InetAddress
        结果
        原始IP地址为字符串格式。

      • hashCode

        public int hashCode​()
        返回此IP地址的哈希码。
        重写：
        hashCode在 InetAddress
        结果
        该IP地址的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 如果且仅当参数不是null并且表示与此对象相同的IP地址时，结果为true 。

        如果getAddress返回的字节数组的长度相同，则InetAddress两个实例表示相同的IP地址，并且每个数组组件对于字节数组是相同的。

        重写：
        equals在 InetAddress
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        InetAddress.getAddress()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Inet6Address (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class Inet6Address

  • java.lang.Object
    • java.net.InetAddress
      • java.net.Inet6Address
  • All Implemented Interfaces:
    Serializable

    public final class Inet6Address
extends InetAddress
    该类表示Internet协议版本6（IPv6）地址。 由RFC 2373: IP Version 6 Addressing Architecture定义。

    Textual representation of IP addresses

    用作方法输入的IPv6地址的文本表示采用以下形式之一：

    1. The preferred form是x：x：x：x：x：x：x：x，其中x是地址的8个16位的十六进制值。 这是完整的形式。 例如，

      • 1080:0:0:0:8:800:200C:417A

      请注意，不必在单个字段中写入前导零。 但是，除了下面所述外，每个字段中必须至少有一个数字。

    2. 由于一些分配某些类型的IPv6地址的方法，地址包含长字符串的零位将是常见的。 为了使写入包含零位的地址更容易，可以使用特殊语法来压缩零。 使用“::”表示多组16位的零。 “::”只能在地址中出现一次。 “::”也可用于压缩地址中的前导和/或尾部零。 例如，

      • 1080::8:800:200C:417A

    3. 在处理IPv4和IPv6节点的混合环境时，有时更方便的替代形式是x：x：x：x：x：x：dddd，其中x是六个高阶16位的十六进制值，地址的位，而'd'是标准IPv4表示地址的四个低8位的十进制值，例如，

      • ::FFFF:129.144.52.38
      • ::129.144.52.38

      其中“:: FFFF：dddd”和“:: dddd”分别是IPv4映射IPv6地址和IPv4兼容的IPv6地址的一般形式。 请注意，IPv4部分必须是“dddd”形式。 以下表格无效：

      • ::FFFF:d.d.d
      • ::FFFF:d.d
      • ::d.d.d
      • ::d.d

      以下形式：

      • ::FFFF:d

      是有效的，但它是IPv4兼容IPv6地址的非常规表示形式，

      • ::255.255.0.d

      而“:: d”对应于通用IPv6地址“0：0：0：0：0：0：0：d”。

    对于返回文本表示作为输出值的方法，使用完整的表单。 Inet6Address将返回整个表单，因为它与其他文本数据结合使用时是明确的。

    特殊的IPv6地址

    Description of IPv4-mapped address
    IPv4-mapped address Of the form ::ffff:w.x.y.z, this IPv6 address is used to represent an IPv4 address. It allows the native program to use the same address data structure and also the same socket when communicating with both IPv4 and IPv6 nodes.

    In InetAddress and Inet6Address, it is used for internal representation; it has no functional role. Java will never return an IPv4-mapped address. These classes can take an IPv4-mapped address as input, both in byte array and text representation. However, it will be converted into an IPv4 address.

    Textual representation of IPv6 scoped addresses

    如上所述的IPv6地址的文本表示可以扩展到指定IPv6作用域地址。 在[draft-ietf-ipngwg-scoping-arch-04.txt]中描述了对基本寻址架构的这种扩展。

    由于链路本地和站点本地地址是非全局地址，因此不同的主机可能具有相同的目的地址，并且可能通过同一始发系统上的不同接口可达。 在这种情况下，始发系统被称为连接到相同范围的多个区域。 为了消除哪个是目的地区域，可以将一个区域标识符（或scope_id ）附加到IPv6地址。

    用于指定scope_id的一般格式如下：

    IPv6-address% scope_id

    如上所述，IPv6地址是一个文字的IPv6地址。 scope_id是指本地系统上的接口，可以通过两种方式指定。

    1. 作为数字标识符。 这必须是一个正整数，用于标识系统所理解的特定接口和范围。 通常，数值可以通过系统上的管理工具确定。 每个接口可以有多个值，每个范围一个。 如果范围未指定，则使用的默认值为零。
    2. 作为一个字符串。 这必须是NetworkInterface.getName()针对特定接口返回的确切字符串。 当以这种方式创建Inet6Address时，通过查询相关的NetworkInterface在创建对象时确定数字scope-id。

    还要注意，可以从NetworkInterface类返回的Inet6Address实例检索数字scope_id 。 这可以用于查找系统上配置的当前范围ID。

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      byte[] getAddress​()
      返回此 InetAddress对象的原始IP地址。
      static Inet6Address getByAddress​(String host, byte[] addr, int scope_id)
      在的确切方式创建Inet6Address， InetAddress.getByAddress(String,byte[])不同之处在于将IPv6 scope_id设置为给定数值。
      static Inet6Address getByAddress​(String host, byte[] addr, NetworkInterface nif)
      在的确切方式创建Inet6Address， InetAddress.getByAddress(String,byte[])不同之处在于将IPv6 scope_id设置为对应于在指定的地址类型的给定接口的值 addr 。
      String getHostAddress​()
      返回文本显示中的IP地址字符串。
      NetworkInterface getScopedInterface​()
      如果此实例是使用范围界面创建的，则返回范围界面。
      int getScopeId​()
      如果此实例与接口相关联，则返回数字scopeId。
      int hashCode​()
      返回此IP地址的哈希码。
      boolean isAnyLocalAddress​()
      检查InetAddress是否为通配符地址的实用程序。
      boolean isIPv4CompatibleAddress​()
      检查InetAddress是否与IPv4兼容的IPv6地址的实用程序。
      boolean isLinkLocalAddress​()
      检查InetAddress是否是链接本地地址的实用程序。
      boolean isLoopbackAddress​()
      检查InetAddress是否是环回地址的实用程序。
      boolean isMCGlobal​()
      检查多播地址是否具有全局范围的实用程序。
      boolean isMCLinkLocal​()
      检查组播地址是否具有链路范围的实用程序。
      boolean isMCNodeLocal​()
      检查多播地址是否具有节点范围的实用程序。
      boolean isMCOrgLocal​()
      检查组播地址是否具有组织范围的实用程序。
      boolean isMCSiteLocal​()
      检查多播地址是否具有站点范围的实用程序。
      boolean isMulticastAddress​()
      检查InetAddress是否是IP组播地址的实用程序。 11111111在地址开头将该地址标识为多播地址。
      boolean isSiteLocalAddress​()
      检查InetAddress是否是站点本地地址的实用程序。

      • Methods inherited from class java.net.InetAddress

        getAllByName, getByAddress, getByAddress, getByName, getCanonicalHostName, getHostName, getLocalHost, getLoopbackAddress, isReachable, isReachable, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getByAddress

        public static Inet6Address getByAddress​(String host,
                                        byte[] addr,
                                        NetworkInterface nif)
                                 throws UnknownHostException
        在的确切方式创建Inet6Address， InetAddress.getByAddress(String,byte[])不同之处在于将IPv6 scope_id设置为对应于在指定的地址类型的给定接口的值addr 。 如果给定的接口没有为给定的地址类型（例如link-local或site-local）分配一个数字scope_id，那么调用将失败，并显示UnknownHostException。 有关IPv6作用域的描述，请参见here 。
        参数
        host - 指定的主机
        addr - 网络字节顺序中的原始IP地址
        nif
        结果
        从原始IP地址创建的Inet6Address对象。
        异常
        UnknownHostException - 如果IP地址为非法长度，或者接口没有为给定地址类型分配数字scope_id。
        从以下版本开始：
        1.5

      • getByAddress

        public static Inet6Address getByAddress​(String host,
                                        byte[] addr,
                                        int scope_id)
                                 throws UnknownHostException
        以InetAddress.getByAddress(String,byte[])的确切方式创建Inet6Address，但将IPv6范围_id设置为给定的数值。 不检查scope_id以确定它是否对应于系统上的任何接口。 有关IPv6作用域的描述，请参见here 。
        参数
        host - 指定的主机
        addr - 网络字节顺序中的原始IP地址
        scope_id - 地址的数值scope_id。
        结果
        从原始IP地址创建的Inet6Address对象。
        异常
        UnknownHostException - 如果IP地址是非法的长度。
        从以下版本开始：
        1.5

      • isMulticastAddress

        public boolean isMulticastAddress​()
        检查InetAddress是否是IP组播地址的实用程序。 11111111在地址开头将该地址标识为多播地址。
        重写：
        isMulticastAddress在 InetAddress
        结果
        一个 boolean指示InetAddress是否是IP组播地址

      • isAnyLocalAddress

        public boolean isAnyLocalAddress​()
        检查InetAddress是否为通配符地址的实用程序。
        重写：
        isAnyLocalAddress在 InetAddress
        结果
        一个 boolean指示Inetaddress是否是通配符地址。

      • isLoopbackAddress

        public boolean isLoopbackAddress​()
        检查InetAddress是否是环回地址的实用程序。
        重写：
        isLoopbackAddress在 InetAddress
        结果
        一个boolean指示InetAddress是否是一个环回地址; 否则为false。

      • isLinkLocalAddress

        public boolean isLinkLocalAddress​()
        检查InetAddress是否是链接本地地址的实用程序。
        重写：
        isLinkLocalAddress在 InetAddress
        结果
        一个boolean指示InetAddress是否是链路本地地址; 如果地址不是链路本地单播地址，则为false。

      • isSiteLocalAddress

        public boolean isSiteLocalAddress​()
        检查InetAddress是否是站点本地地址的实用程序。
        重写：
        isSiteLocalAddress中的 InetAddress
        结果
        一个boolean指示InetAddress是否是站点本地地址; 如果地址不是站点本地单播地址，则为false。

      • isMCGlobal

        public boolean isMCGlobal​()
        检查多播地址是否具有全局范围的实用程序。
        重写：
        isMCGlobal在 InetAddress
        结果
        一个 boolean指示地址是否是全局范围的多播地址，如果不是全局范围，则为false，或者不是多播地址

      • isMCNodeLocal

        public boolean isMCNodeLocal​()
        检查多播地址是否具有节点范围的实用程序。
        重写：
        isMCNodeLocal在 InetAddress
        结果
        一个 boolean指示地址是否是节点本地范围的多播地址，如果不是节点本地作用域，则为false，或者不是多播地址

      • isMCLinkLocal

        public boolean isMCLinkLocal​()
        检查组播地址是否具有链路范围的实用程序。
        重写：
        isMCLinkLocal在 InetAddress
        结果
        一个 boolean指示地址是否是链路本地范围的多播地址，如果不是链路本地范围或不是多播地址，则为false

      • isMCSiteLocal

        public boolean isMCSiteLocal​()
        检查多播地址是否具有站点范围的实用程序。
        重写：
        isMCSiteLocal在 InetAddress
        结果
        一个 boolean指示地址是否是站点本地范围的多播地址，如果不是站点本地范围，则为false，或者不是多播地址

      • isMCOrgLocal

        public boolean isMCOrgLocal​()
        检查组播地址是否具有组织范围的实用程序。
        重写：
        isMCOrgLocal在 InetAddress
        结果
        一个 boolean指示地址是否是组织本地作用域的组播地址，如果不是组织本地作用域或不是组播地址，则为false

      • getAddress

        public byte[] getAddress​()
        返回此InetAddress对象的原始IP地址。 结果是网络字节顺序：地址的最高位字节在getAddress()[0] 。
        重写：
        getAddress在 InetAddress
        结果
        该对象的原始IP地址。

      • getScopeId

        public int getScopeId​()
        如果此实例与接口相关联，则返回数字scopeId。 如果没有设置scoped_id，返回值为零。
        结果
        scopeId，如果未设置，则为零。
        从以下版本开始：
        1.5

      • getScopedInterface

        public NetworkInterface getScopedInterface​()
        如果此实例是使用范围界面创建的，则返回范围界面。
        结果
        范围界面，如果未设置则为null。
        从以下版本开始：
        1.5

      • getHostAddress

        public String getHostAddress​()
        返回文本显示中的IP地址字符串。 如果创建的实例指定了作用域标识符，则将作用域ID附加到以“％”（百分号）字符前面的IP地址中。 这可以是数值或字符串，具体取决于用于创建实例的值。
        重写：
        getHostAddress在 InetAddress
        结果
        原始IP地址为字符串格式。

      • hashCode

        public int hashCode​()
        返回此IP地址的哈希码。
        重写：
        hashCode中的 InetAddress
        结果
        该IP地址的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 当且仅当参数不是null并且它表示与该对象相同的IP地址时，结果为true 。

        如果getAddress返回的字节数组的长度相同，则InetAddress两个实例表示相同的IP地址，并且每个数组组件对于字节数组是相同的。

        重写：
        equals在 InetAddress
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        InetAddress.getAddress()

      • isIPv4CompatibleAddress

        public boolean isIPv4CompatibleAddress​()
        检查InetAddress是否与IPv4兼容的IPv6地址的实用程序。
        结果
        一个boolean指示InetAddress是否是IPv4兼容的IPv6地址; 如果地址是IPv4地址，则为false。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InetAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class InetAddress

  • java.lang.Object
    • java.net.InetAddress
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    Inet4Address ， Inet6Address

    public class InetAddress
extends Object
implements Serializable
    此类表示Internet协议（IP）地址。

    IP地址是由IP使用的32位或128位无符号数字，构建UDP和TCP协议的低级协议。 IP地址结构由定义RFC 790: Assigned Numbers ， RFC 1918: Address Allocation for Private Internets ， RFC 2365: Administratively Scoped IP Multicast ，并RFC 2373: IP Version 6 Addressing Architecture 。 InetAddress的一个实例由一个IP地址和可能的相应主机名组成（取决于它是用主机名构造还是已经完成了反向主机名解析）。

    地址类型

    Description of unicast and multicast address types
    unicast An identifier for a single interface. A packet sent to a unicast address is delivered to the interface identified by that address.

    The Unspecified Address -- Also called anylocal or wildcard address. It must never be assigned to any node. It indicates the absence of an address. One example of its use is as the target of bind, which allows a server to accept a client connection on any interface, in case the server host has multiple interfaces.

    The unspecified address must not be used as the destination address of an IP packet.

    The Loopback Addresses -- This is the address assigned to the loopback interface. Anything sent to this IP address loops around and becomes IP input on the local host. This address is often used when testing a client.
    multicast An identifier for a set of interfaces (typically belonging to different nodes). A packet sent to a multicast address is delivered to all interfaces identified by that address.

    IP地址范围

    链路本地地址被设计为用于单个链路上的寻址，例如自动地址配置，邻居发现或当没有路由器存在时。

    站点本地地址被设计为用于在站点内部寻址，而不需要全局前缀。

    全球地址在互联网上是独一无二的。

    IP地址的文字表示

    IP地址的文本表示是特定于地址的。

    IPv4地址格式请参考Inet4Address#format ; IPv6地址格式请参考Inet6Address#format 。

    有一个couple of System Properties影响如何使用IPv4和IPv6地址。

    主机名解析

    主机名称到IP地址解析是通过使用本地机器配置信息和网络命名服务（如域名系统（DNS）和网络信息服务（NIS））的组合来实现的。 所使用的特定命名服务是默认配置的本地机器。 对于任何主机名，返回其对应的IP地址。

    反向名称解析意味着对于任何IP地址，返回与IP地址关联的主机。

    InetAddress类提供了将主机名解析为其IP地址的方法，反之亦然。

    InetAddress缓存

    InetAddress类具有高速缓存以存储成功以及不成功的主机名解析。

    默认情况下，安装安全管理器时，为防止DNS欺骗攻击，主机名正确解决的结果永远被缓存。 当没有安装安全管理器时，默认的行为是缓存条目以获得有限的（实现依赖的）时间段。 不成功的主机名解析的结果被缓存很短的时间（10秒），以提高性能。

    如果不需要默认行为，则可以将Java安全属性设置为不同的生存时间（TTL）值进行正缓存。 同样，系统管理员可以在需要时配置不同的缓存缓存TTL值。

    两个Java安全属性控制用于正负主机名解析缓存的TTL值：

    networkaddress.cache.ttl
    Indicates the caching policy for successful name lookups from the name service. The value is specified as an integer to indicate the number of seconds to cache the successful lookup. The default setting is to cache for an implementation specific period of time.

    A value of -1 indicates "cache forever".

    networkaddress.cache.negative.ttl (default: 10)
    Indicates the caching policy for un-successful name lookups from the name service. The value is specified as an integer to indicate the number of seconds to cache the failure for un-successful lookups.

    A value of 0 indicates "never cache". A value of -1 indicates "cache forever".

    从以下版本开始：
    1.0
    另请参见：
    getByAddress(byte[]) ，
getByAddress(java.lang.String, byte[]) ，
getAllByName(java.lang.String) ，
getByName(java.lang.String) ，
getLocalHost() ，
Serialized Form

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      byte[] getAddress​()
      返回此 InetAddress对象的原始IP地址。
      static InetAddress[] getAllByName​(String host)
      给定主机的名称，根据系统上配置的名称服务返回其IP地址数组。
      static InetAddress getByAddress​(byte[] addr)
      给出原始IP地址的 InetAddress对象。
      static InetAddress getByAddress​(String host, byte[] addr)
      根据提供的主机名和IP地址创建InetAddress。
      static InetAddress getByName​(String host)
      确定主机名称的IP地址。
      String getCanonicalHostName​()
      获取此IP地址的完全限定域名。
      String getHostAddress​()
      返回文本显示中的IP地址字符串。
      String getHostName​()
      获取此IP地址的主机名。
      static InetAddress getLocalHost​()
      返回本地主机的地址。
      static InetAddress getLoopbackAddress​()
      返回回送地址。
      int hashCode​()
      返回此IP地址的哈希码。
      boolean isAnyLocalAddress​()
      检查InetAddress是否为通配符地址的实用程序。
      boolean isLinkLocalAddress​()
      检查InetAddress是否是链接本地地址的实用程序。
      boolean isLoopbackAddress​()
      检查InetAddress是否是环回地址的实用程序。
      boolean isMCGlobal​()
      检查多播地址是否具有全局范围的实用程序。
      boolean isMCLinkLocal​()
      检查组播地址是否具有链路范围的实用程序。
      boolean isMCNodeLocal​()
      检查多播地址是否具有节点范围的实用程序。
      boolean isMCOrgLocal​()
      检查组播地址是否具有组织范围的实用程序。
      boolean isMCSiteLocal​()
      检查多播地址是否具有站点范围的实用程序。
      boolean isMulticastAddress​()
      检查InetAddress是否是IP组播地址的实用程序。
      boolean isReachable​(int timeout)
      测试该地址是否可达。
      boolean isReachable​(NetworkInterface netif, int ttl, int timeout)
      测试该地址是否可达。
      boolean isSiteLocalAddress​()
      检查InetAddress是否是站点本地地址的实用程序。
      String toString​()
      将此IP地址转换为 String 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • isMulticastAddress

        public boolean isMulticastAddress​()
        检查InetAddress是否是IP组播地址的实用程序。
        结果
        一个 boolean指示InetAddress是否是IP组播地址
        从以下版本开始：
        1.1

      • isAnyLocalAddress

        public boolean isAnyLocalAddress​()
        检查InetAddress是否为通配符地址的实用程序。
        结果
        一个 boolean指示Inetaddress是否是通配符地址。
        从以下版本开始：
        1.4

      • isLoopbackAddress

        public boolean isLoopbackAddress​()
        检查InetAddress是否是环回地址的实用程序。
        结果
        一个boolean指示InetAddress是否是一个回送地址; 否则为false。
        从以下版本开始：
        1.4

      • isLinkLocalAddress

        public boolean isLinkLocalAddress​()
        检查InetAddress是否是链接本地地址的实用程序。
        结果
        一个boolean指示InetAddress是否是链路本地地址; 如果地址不是链路本地单播地址，则为false。
        从以下版本开始：
        1.4

      • isSiteLocalAddress

        public boolean isSiteLocalAddress​()
        检查InetAddress是否是站点本地地址的实用程序。
        结果
        一个boolean指示InetAddress是否是站点本地地址; 如果地址不是站点本地单播地址，则为false。
        从以下版本开始：
        1.4

      • isMCGlobal

        public boolean isMCGlobal​()
        检查多播地址是否具有全局范围的实用程序。
        结果
        一个 boolean指示地址是否是全局范围的多播地址，如果不是全局范围，则为false，或者不是多播地址
        从以下版本开始：
        1.4

      • isMCNodeLocal

        public boolean isMCNodeLocal​()
        检查多播地址是否具有节点范围的实用程序。
        结果
        一个 boolean指示地址是否是节点本地作用域的多播地址，如果不是节点本地作用域，则为false，或者不是多播地址
        从以下版本开始：
        1.4

      • isMCLinkLocal

        public boolean isMCLinkLocal​()
        检查组播地址是否具有链路范围的实用程序。
        结果
        一个 boolean指示地址是否是链路本地作用域的组播地址，如果不是链路本地作用域，则为false，或者不是多播地址
        从以下版本开始：
        1.4

      • isMCSiteLocal

        public boolean isMCSiteLocal​()
        检查多播地址是否具有站点范围的实用程序。
        结果
        一个 boolean指示地址是否是站点本地范围的多播地址，如果不是站点本地范围，则为false，否则为多播地址
        从以下版本开始：
        1.4

      • isMCOrgLocal

        public boolean isMCOrgLocal​()
        检查组播地址是否具有组织范围的实用程序。
        结果
        一个 boolean指示地址是否是组织本地范围的组播地址，如果不是组织本地作用域，则不为false，否则为多播地址
        从以下版本开始：
        1.4

      • isReachable

        public boolean isReachable​(int timeout)
                    throws IOException
        测试该地址是否可达。 通过实现尽最大努力尝试到达主机，但防火墙和服务器配置可能会阻止请求，从而导致无法访问的状态，而某些特定端口可以访问。 如果可以获得特权，典型的实现将使用ICMP ECHO REQUEST，否则将尝试在目标主机的端口7（Echo）上建立TCP连接。

        超时值（以毫秒为单位）表示尝试所需的最长时间。 如果操作在得到答案之前超时，则该主机被视为无法访问。 负值将导致抛出IllegalArgumentException异常。

        参数
        timeout - 呼叫中止之前的时间（以毫秒为单位）
        结果
        一个 boolean指示地址是否可达。
        异常
        IOException - 如果发生网络错误
        IllegalArgumentException - 如果 timeout为负数。
        从以下版本开始：
        1.5

      • isReachable

        public boolean isReachable​(NetworkInterface netif,
                           int ttl,
                           int timeout)
                    throws IOException
        测试该地址是否可达。 通过实现尽最大努力尝试到达主机，但防火墙和服务器配置可能会阻止请求，从而导致无法访问的状态，而某些特定端口可以访问。 如果可以获得特权，典型的实现将使用ICMP ECHO REQUEST，否则将尝试在目标主机的端口7（Echo）上建立TCP连接。

        network interface和ttl参数让呼叫者指定测试将通过哪个网络接口以及数据包应该通过的最大跳数。 ttl将导致抛出IllegalArgumentException异常。

        超时值（以毫秒为单位）表示尝试所需的最长时间。 如果操作在得到答案之前超时，则该主机被视为无法访问。 负值将导致抛出IllegalArgumentException异常。

        参数
        netif - 测试完成的NetworkInterface，或任何接口为null
        ttl - 尝试的最大跳数或默认值为0
        timeout - 呼叫中止之前的时间（以毫秒为单位）
        结果
        一个 boolean指示地址是否可达。
        异常
        IllegalArgumentException - 如果 timeout或 ttl为负数。
        IOException - 如果发生网络错误
        从以下版本开始：
        1.5

      • getHostName

        public String getHostName​()
        获取此IP地址的主机名。

        如果此InetAddress是使用主机名创建的，则该主机名将被记住并返回; 否则，将执行反向名称查找，并将基于系统配置的名称查找服务返回结果。 如果需要查找名称服务，请致电getCanonicalHostName 。

        如果有一个安全管理器，它的checkConnect方法首先被调用主机名和-1作为参数来查看是否允许操作。 如果不允许操作，它将返回IP地址的文本表示。

        结果
        该IP地址的主机名，或者安全检查不允许操作时，IP地址的文本表示。
        另请参见：
        getCanonicalHostName() ， SecurityManager.checkConnect(java.lang.String, int)

      • getCanonicalHostName

        public String getCanonicalHostName​()
        获取此IP地址的完全限定域名。 最好的方法，意味着我们可能无法返回FQDN取决于底层的系统配置。

        如果有安全管理器，则该方法首先使用主机-1来表示其checkConnect方法，其参数为-1 ，以查看是否允许调用代码知道该IP地址的主机名，即连接到主机。 如果不允许操作，它将返回IP地址的文本表示。

        结果
        该IP地址的完全限定域名，或者安全检查不允许操作时，该IP地址的文本表示。
        从以下版本开始：
        1.4
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • getAddress

        public byte[] getAddress​()
        返回此InetAddress对象的原始IP地址。 结果是网络字节顺序：地址的最高位字节在getAddress()[0] 。
        结果
        该对象的原始IP地址。

      • getHostAddress

        public String getHostAddress​()
        返回文本显示中的IP地址字符串。
        结果
        原始IP地址为字符串格式。
        从以下版本开始：
        1.0.2

      • hashCode

        public int hashCode​()
        返回此IP地址的哈希码。
        重写：
        hashCode在类 Object
        结果
        该IP地址的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 当且仅当参数不是null并且它表示与此对象相同的IP地址时，结果为true 。

        如果getAddress返回的字节数组的长度相同， InetAddress两个InetAddress实例表示相同的IP地址，并且每个数组组件对于字节数组是相同的。

        重写：
        equals中的 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        getAddress()

      • toString

        public String toString​()
        将此IP地址转换为String 。 返回的字符串格式为：hostname / literal IP地址。 如果主机名未解决，则不执行反向名称服务查找。 主机名部分将用空字符串表示。
        重写：
        toString在 Object
        结果
        该IP地址的字符串表示形式。

      • getByAddress

        public static InetAddress getByAddress​(String host,
                                       byte[] addr)
                                throws UnknownHostException
        根据提供的主机名和IP地址创建InetAddress。 检查地址的有效性的名称服务。

        主机名称可以是机器名称，例如“ java.sun.com ”或其IP地址的文本表示。

        对主机名也不进行有效性检查。

        如果addr指定IPv4地址，则返回Inet4Address的实例; 否则将返回Inet6Address的一个实例。

        IPv4地址字节数组必须为4个字节长，IPv6字节数组必须长度为16个字节

        参数
        host - 指定的主机
        addr - 网络字节顺序中的原始IP地址
        结果
        从原始IP地址创建的InetAddress对象。
        异常
        UnknownHostException - 如果IP地址是非法的长度
        从以下版本开始：
        1.4

      • getByName

        public static InetAddress getByName​(String host)
                             throws UnknownHostException
        确定主机名称的IP地址。

        主机名称可以是机器名称，例如“ java.sun.com ”或其IP地址的文本表示。 如果提供了文字IP地址，则只会检查地址格式的有效性。

        对于在文字IPv6地址中指定的host ，RFC 2732中定义的格式或RFC 2373中定义的文字IPv6地址格式被接受。 还支持IPv6作用域地址。 有关IPv6作用域的描述，请参见here 。

        如果主机为null则InetAddress表示环回接口地址的InetAddress 。 见RFC 3330第2节和RFC 2373第2.5.3节。

        参数
        host - 指定的主机，或 null 。
        结果
        给定主机名的IP地址。
        异常
        UnknownHostException - 如果没有找到 host IP地址，或者是否为全局IPv6地址指定了scope_id。
        SecurityException - 如果安全管理器存在，并且其checkConnect方法不允许操作

      • getAllByName

        public static InetAddress[] getAllByName​(String host)
                                  throws UnknownHostException
        给定主机的名称，根据系统上配置的名称服务返回其IP地址数组。

        主机名称可以是机器名称，例如“ java.sun.com ”或其IP地址的文本表示。 如果提供了文字IP地址，则只会检查地址格式的有效性。

        对于在文字IPv6地址中指定的host ，RFC 2732中定义的格式或RFC 2373中定义的文字IPv6地址格式被接受。 也可以通过附加范围区域标识符或scope_id来限定文字IPv6地址。 描述了scope_ids的语法和用法here 。

        如果主机是null则返回一个表示环回接口地址的InetAddress 。 见RFC 3330第2节和RFC 2373第2.5.3节。

        如果有安全管理员，并且host不为null，并且host.length()不等于零，则使用主机名和-1作为参数来调用安全管理器的checkConnect方法，以查看是否允许该操作。

        参数
        host - 主机的名称，或 null 。
        结果
        一个给定主机名的所有IP地址的数组。
        异常
        UnknownHostException - 如果没有找到 host IP地址，或者如果为全局IPv6地址指定了scope_id。
        SecurityException - 如果安全管理器存在，并且其 checkConnect方法不允许操作。
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • getLoopbackAddress

        public static InetAddress getLoopbackAddress​()
        返回回送地址。

        返回的InetAddress将表示IPv4环回地址127.0.0.1或IPv6环回地址:: 1。 返回的IPv4环回地址只能是127，*。*。*

        结果
        InetAddress环回实例。
        从以下版本开始：
        1.7

      • getByAddress

        public static InetAddress getByAddress​(byte[] addr)
                                throws UnknownHostException
        给出原始IP地址的InetAddress对象。 参数是网络字节顺序：地址的最高位字节在getAddress()[0] 。

        该方法不阻止，即不执行反向名称服务查找。

        IPv4地址字节数组必须为4个字节长，IPv6字节数组必须长度为16个字节

        参数
        addr - 网络字节顺序中的原始IP地址
        结果
        从原始IP地址创建的InetAddress对象。
        异常
        UnknownHostException - 如果IP地址是非法的长度
        从以下版本开始：
        1.4

      • getLocalHost

        public static InetAddress getLocalHost​()
                                throws UnknownHostException
        返回本地主机的地址。 这是通过从系统中检索主机的名称，然后将该名称解析为InetAddress 。

        注意：解决的地址可能会缓存一段时间。

        如果有安全管理器，则使用本地主机名称调用其checkConnect方法，并以-1作为参数来查看是否允许该操作。 如果不允许操作，则返回表示环回地址的InetAddress。

        结果
        本地主机的地址。
        异常
        UnknownHostException - 如果本地主机名无法解析为地址。
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int) ， getByName(java.lang.String)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InetSocketAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class InetSocketAddress

  • java.lang.Object
    • java.net.SocketAddress
      • java.net.InetSocketAddress
  • All Implemented Interfaces:
    Serializable

    public class InetSocketAddress
extends SocketAddress
    该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。 如果解决方案失败，那么该地址被认为是未解决的，但在某些情况下仍可以使用，例如通过代理连接。

    它提供了用于绑定，连接或返回值的套接字所使用的不可变对象。

    通配符是一个特殊的本地IP地址。 通常意味着“任何”，只能用于bind操作。

    从以下版本开始：
    1.4
    另请参见：
    Socket ， ServerSocket ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      InetSocketAddress​(int port)
      创建一个套接字地址，其中IP地址为通配符地址，端口号为指定值。
      InetSocketAddress​(String hostname, int port)
      从主机名和端口号创建套接字地址。
      InetSocketAddress​(InetAddress addr, int port)
      从IP地址和端口号创建套接字地址。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      static InetSocketAddress createUnresolved​(String host, int port)
      从主机名和端口号创建未解析的套接字地址。
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      InetAddress getAddress​()
      获得 InetAddress 。
      String getHostName​()
      获得 hostname 。
      String getHostString​()
      如果没有主机名（使用文字创建），则返回主机名或地址的String形式。
      int getPort​()
      获取端口号。
      int hashCode​()
      返回此套接字地址的哈希码。
      boolean isUnresolved​()
      检查地址是否已解决。
      String toString​()
      构造此InetSocketAddress的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InetSocketAddress

        public InetSocketAddress​(int port)
        创建一个套接字地址，其中IP地址为通配符地址，端口号为指定值。

        有效的端口值介于0和65535之间。端口号为zero将允许系统在bind操作中拾取临时端口。

        参数
        port - 端口号
        异常
        IllegalArgumentException - 如果端口参数超出了有效端口值的指定范围。

      • InetSocketAddress

        public InetSocketAddress​(InetAddress addr,
                         int port)
        从IP地址和端口号创建套接字地址。

        有效的端口值介于0到65535之间。端口号为zero将允许系统在bind操作中拾取临时端口。

        A null地址将分配通配符地址。

        参数
        addr - IP地址
        port - 端口号
        异常
        IllegalArgumentException - 如果端口参数在有效端口值的指定范围之外。

      • InetSocketAddress

        public InetSocketAddress​(String hostname,
                         int port)
        从主机名和端口号创建套接字地址。

        将尝试将主机名解析为InetAddress。 如果尝试失败，该地址将被标记为未解决 。

        如果有一个安全管理器，它的checkConnect方法被调用主机名称作为它的参数来检查权限来解决它。 这可能会导致SecurityException。

        有效端口值介于0和65535之间。端口号为zero将允许系统在bind操作中拾取临时端口。

        参数
        hostname - 主机名
        port - 端口号
        异常
        IllegalArgumentException - 如果端口参数超出有效端口值的范围，或者主机名参数是 null 。
        SecurityException - 如果存在安全管理员，并且拒绝解析主机名的权限。
        另请参见：
        isUnresolved()

    • 方法详细信息

      • createUnresolved

        public static InetSocketAddress createUnresolved​(String host,
                                                 int port)
        从主机名和端口号创建未解析的套接字地址。

        不会尝试将主机名解析为InetAddress。 该地址将被标记为未解决 。

        有效的端口值介于0和65535之间。端口号为zero将允许系统在bind操作中拾取临时端口。

        参数
        host - 主机名
        port - 端口号
        结果
        一个表示未解决的套接字地址的 InetSocketAddress
        异常
        IllegalArgumentException - 如果端口参数超出有效端口值的范围，或者主机名参数是否为 null 。
        从以下版本开始：
        1.5
        另请参见：
        isUnresolved()

      • getPort

        public final int getPort​()
        获取端口号。
        结果
        端口号。

      • getAddress

        public final InetAddress getAddress​()
        获得 InetAddress 。
        结果
        InetAdress或 null如果尚未解决。

      • getHostName

        public final String getHostName​()
        获得hostname 。 注意：如果地址是使用文字IP地址创建的，则此方法可能会触发名称服务反向查找。
        结果
        地址的主机名部分。

      • getHostString

        public final String getHostString​()
        如果没有主机名（使用文字创建），则返回主机名或地址的String形式。 这样做不利于不尝试反向查找。
        结果
        主机名或字符串表示的地址。
        从以下版本开始：
        1.7

      • isUnresolved

        public final boolean isUnresolved​()
        检查地址是否已解决。
        结果
        true如果主机名无法解析为 InetAddress 。

      • toString

        public String toString​()
        构造此InetSocketAddress的字符串表示形式。 此字符串是通过在InetAddress上调用toString（）并连接端口号（带冒号）来构造的。 如果地址未解决，则冒号之前的部分将只包含主机名。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式。

      • equals

        public final boolean equals​(Object obj)
        将此对象与指定对象进行比较。 结果是true当且仅当参数不是null并且它表示与该对象相同的地址。

        如果InetAddresses（或主机名未解决）和端口号相等，则InetSocketAddress两个实例表示相同的地址。 如果两个地址都未解决，则比较主机名和端口号。 注意：主机名不区分大小写。 例如“FooBar”和“foobar”被认为是相等的。

        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是相同的; 否则为false 。
        另请参见：
        InetAddress.equals(java.lang.Object)

      • hashCode

        public final int hashCode​()
        返回此套接字地址的哈希码。
        重写：
        hashCode在 Object
        结果
        该套接字地址的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


InterfaceAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class InterfaceAddress

  • java.lang.Object
    • java.net.InterfaceAddress

  • public class InterfaceAddress
extends Object
    此类表示网络接口地址。 简而言之，当地址是IPv4地址时，它是一个IP地址，一个子网掩码和一个广播地址。 在IPv6地址的情况下，IP地址和网络前缀长度。
    从以下版本开始：
    1.6
    另请参见：
    NetworkInterface

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      InetAddress getAddress​()
      返回此地址的 InetAddress 。
      InetAddress getBroadcast​()
      为此InterfaceAddress的广播地址返回 InetAddress 。
      short getNetworkPrefixLength​()
      返回此地址的网络前缀长度。
      int hashCode​()
      返回此接口地址的哈希码。
      String toString​()
      将此接口地址转换为 String 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getAddress

        public InetAddress getAddress​()
        返回此地址的 InetAddress 。
        结果
        该地址的 InetAddress 。

      • getBroadcast

        public InetAddress getBroadcast​()
        为此InterfaceAddress的广播地址返回InetAddress 。

        因此，只有IPv4网络具有广播地址，在IPv6网络的情况下，将返回null 。

        结果
        该 InetAddress表示广播地址或 null如果没有广播地址。

      • getNetworkPrefixLength

        public short getNetworkPrefixLength​()
        返回此地址的网络前缀长度。 这在IPv4地址的上下文中也被称为子网掩码。 典型的IPv4值为8（255.0.0.0），16（255.255.0.0）或24（255.255.255.0）。

        典型的IPv6值为128（:: 1/128）或10（fe80 :: 203：baff：fe27：1243/10）

        结果
        一个 short表示该地址子网的前缀长度。

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 结果是true当且仅当参数不是null并且它表示与该对象相同的接口地址。

        如果InetAddress，前缀长度和广播两者都相同，则InterfaceAddress两个实例表示相同的地址。

        重写：
        equals在类 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        hashCode()

      • hashCode

        public int hashCode​()
        返回此接口地址的哈希码。
        重写：
        hashCode在 Object
        结果
        该接口地址的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        将此接口地址转换为String 。 返回的字符串的格式为：InetAddress / prefix length [broadcast address]。
        重写：
        toString在 Object
        结果
        该接口地址的字符串表示形式。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


JarURLConnection (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class JarURLConnection

  • java.lang.Object
    • java.net.URLConnection
      • java.net.JarURLConnection

  • public abstract class JarURLConnection
extends URLConnection
    与Java ARchive（JAR）文件或JAR文件中的条目的URL连接。

    JAR URL的语法是：

      jar:<url>!/{entry}

    例如：

    jar:http://www.foo.com/bar/baz.jar!/COM/foo/Quux.class

    JAR URL应用于引用JAR文件或JAR文件中的条目。 上面的示例是一个引用JAR条目的JAR URL。 如果省略条目名称，则URL引用整个JAR文件： jar:http://www.foo.com/bar/baz.jar!/

    当他们知道他们创建的URL是一个JAR URL，并且他们需要JAR特定的功能时，用户应该将通用URLConnection转换为JarURLConnection。 例如：

      URL url = new URL("jar:file:/home/duke/duke.jar!/");
 JarURLConnection jarConnection = (JarURLConnection)url.openConnection();
 Manifest manifest = jarConnection.getManifest();

    JarURLConnection实例只能用于从JAR文件读取。 使用此类不可能获得一个OutputStream修改或写入底层JAR文件。

    例子：

    罐子入口
    jar:http://www.foo.com/bar/baz.jar!/COM/foo/Quux.class
    一个jar文件
    jar:http://www.foo.com/bar/baz.jar!/
    一个罐子目录
    jar:http://www.foo.com/bar/baz.jar!/COM/foo/

    !/被称为分离器 。

    通过new URL(context, spec)构建JAR网址时，适用以下规则：

    • 如果没有上下文URL，并且传递给URL构造函数的规范不包含分隔符，则该URL被认为是引用JarFile。
    • 如果存在上下文URL，则假定上下文URL是指JAR文件或Jar目录。
    • 如果规范以'/'开始，Jar目录将被忽略，并且该规范被认为是Jar文件的根目录。

      例子：

      上下文： jar：http：//www.foo.com/bar/jar.jar！/ ，spec： baz / entry.txt
      url： jar：http：//www.foo.com/bar/jar.jar！/baz/entry.txt
      上下文： jar：http：//www.foo.com/bar/jar.jar！/ baz ，spec： entry.txt
      url： jar：http：//www.foo.com/bar/jar.jar！/baz/entry.txt
      上下文： jar：http：//www.foo.com/bar/jar.jar！/ baz ，spec： /entry.txt
      url： jar：http：//www.foo.com/bar/jar.jar！/entry.txt
    从以下版本开始：
    1.2
    另请参见：
    URL ， URLConnection ， JarFile ， JarInputStream ， Manifest ， ZipEntry

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected URLConnection jarFileURLConnection
      与JAR文件URL的连接，如果连接已启动。

      • Fields inherited from class java.net.URLConnection

        allowUserInteraction, connected, doInput, doOutput, ifModifiedSince, url, useCaches

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
      protected JarURLConnection​(URL url)
      创建新的JarURLConnection到指定的URL。

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      Attributes getAttributes​()
      如果该连接的URL指向JAR文件条目，则返回此连接的Attributes对象，否则返回null。
      Certificate[] getCertificates​()
      如果它的URL指向JAR文件条目，则返回此连接的证书对象，否则返回null。
      String getEntryName​()
      返回此连接的条目名称。
      JarEntry getJarEntry​()
      返回此连接的JAR条目对象（如果有）。
      abstract JarFile getJarFile​()
      返回此连接的JAR文件。
      URL getJarFileURL​()
      返回此连接的Jar文件的URL。
      Attributes getMainAttributes​()
      返回此连接的JAR文件的主要属性。
      Manifest getManifest​()
      返回此连接的清单，否则返回null。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.net.URLConnection

        addRequestProperty, connect, getAllowUserInteraction, getConnectTimeout, getContent, getContent, getContentEncoding, getContentLength, getContentLengthLong, getContentType, getDate, getDefaultAllowUserInteraction, getDefaultRequestProperty, getDefaultUseCaches, getDefaultUseCaches, getDoInput, getDoOutput, getExpiration, getFileNameMap, getHeaderField, getHeaderField, getHeaderFieldDate, getHeaderFieldInt, getHeaderFieldKey, getHeaderFieldLong, getHeaderFields, getIfModifiedSince, getInputStream, getLastModified, getOutputStream, getPermission, getReadTimeout, getRequestProperties, getRequestProperty, getURL, getUseCaches, guessContentTypeFromName, guessContentTypeFromStream, setAllowUserInteraction, setConnectTimeout, setContentHandlerFactory, setDefaultAllowUserInteraction, setDefaultRequestProperty, setDefaultUseCaches, setDefaultUseCaches, setDoInput, setDoOutput, setFileNameMap, setIfModifiedSince, setReadTimeout, setRequestProperty, setUseCaches, toString

    • 字段详细信息

      • jarFileURLConnection

        protected URLConnection jarFileURLConnection
        与JAR文件URL的连接，如果连接已启动。 这应该通过连接设置。

    • 构造方法详细信息

      • JarURLConnection

        protected JarURLConnection​(URL url)
                    throws MalformedURLException
        创建新的JarURLConnection到指定的URL。
        参数
        url - 网址
        异常
        MalformedURLException - 如果在规范字符串中找不到合法协议，或者无法解析字符串。

    • 方法详细信息

      • getJarFileURL

        public URL getJarFileURL​()
        返回此连接的Jar文件的URL。
        结果
        该连接的Jar文件的URL。

      • getEntryName

        public String getEntryName​()
        返回此连接的条目名称。 如果与此连接相对应的JAR文件URL指向JAR文件而不是JAR文件条目，则此方法返回null。
        结果
        此连接的条目名称（如果有）。

      • getJarFile

        public abstract JarFile getJarFile​()
                            throws IOException
        返回此连接的JAR文件。
        结果
        该连接的JAR文件。 如果连接是与JAR文件的条目的连接，则返回JAR文件对象
        异常
        IOException - 如果在尝试连接到此连接的JAR文件时发生IOException。
        另请参见：
        URLConnection.connect()

      • getManifest

        public Manifest getManifest​()
                     throws IOException
        返回此连接的清单，否则返回null。
        结果
        对应于此连接的JAR文件对象的清单对象。
        异常
        IOException - 如果获取此连接的JAR文件将导致抛出IOException。
        另请参见：
        getJarFile()

      • getJarEntry

        public JarEntry getJarEntry​()
                     throws IOException
        返回此连接的JAR条目对象（如果有）。 如果与此连接相对应的JAR文件URL指向JAR文件而不是JAR文件条目，则此方法返回null。
        结果
        此连接的JAR条目对象，如果此连接的JAR URL指向JAR文件，则为null。
        异常
        IOException - 如果获取此连接的JAR文件导致抛出IOException。
        另请参见：
        getJarFile() ， getJarEntry()

      • getAttributes

        public Attributes getAttributes​()
                         throws IOException
        如果该连接的URL指向JAR文件条目，则返回此连接的Attributes对象，否则返回null。
        结果
        这个连接的Attributes对象，如果它的URL指向一个JAR文件条目，否则为空。
        异常
        IOException - 如果获取JAR条目导致抛出IOException。
        另请参见：
        getJarEntry()

      • getMainAttributes

        public Attributes getMainAttributes​()
                             throws IOException
        返回此连接的JAR文件的主要属性。
        结果
        此连接的JAR文件的主要属性。
        异常
        IOException - 如果获取清单导致抛出IOException。
        另请参见：
        getJarFile() ， getManifest()

      • getCertificates

        public Certificate[] getCertificates​()
                              throws IOException
        如果它的URL指向JAR文件条目，则返回此连接的证书对象，否则返回null。 一旦通过从输入流读取直到流已经到达结束，连接已被完全验证，才能调用此方法。 否则，此方法将返回null
        结果
        此连接的证书对象，如果其URL指向JAR文件条目，否则为空。
        异常
        IOException - 如果获取JAR条目导致抛出IOException。
        另请参见：
        getJarEntry()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


java.net (Java SE 9 & JDK 9 )

java.net

Interfaces

  • ContentHandlerFactory
  • CookiePolicy
  • CookieStore
  • DatagramSocketImplFactory
  • FileNameMap
  • ProtocolFamily
  • SocketImplFactory
  • SocketOption
  • SocketOptions
  • URLStreamHandlerFactory

Classes

  • Authenticator
  • CacheRequest
  • CacheResponse
  • ContentHandler
  • CookieHandler
  • CookieManager
  • DatagramPacket
  • DatagramSocket
  • DatagramSocketImpl
  • HttpCookie
  • HttpURLConnection
  • IDN
  • Inet4Address
  • Inet6Address
  • InetAddress
  • InetSocketAddress
  • InterfaceAddress
  • JarURLConnection
  • MulticastSocket
  • NetPermission
  • NetworkInterface
  • PasswordAuthentication
  • Proxy
  • ProxySelector
  • ResponseCache
  • SecureCacheResponse
  • ServerSocket
  • Socket
  • SocketAddress
  • SocketImpl
  • SocketPermission
  • StandardSocketOptions
  • URI
  • URL
  • URLClassLoader
  • URLConnection
  • URLDecoder
  • URLEncoder
  • URLPermission
  • URLStreamHandler

Enums

  • Authenticator.RequestorType
  • Proxy.Type
  • StandardProtocolFamily

Exceptions

  • BindException
  • ConnectException
  • HttpRetryException
  • MalformedURLException
  • NoRouteToHostException
  • PortUnreachableException
  • ProtocolException
  • SocketException
  • SocketTimeoutException
  • UnknownHostException
  • UnknownServiceException
  • URISyntaxException


java.net (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
Module java.base

Package java.net

提供实现网络应用程序的类。

java.net包可以大致分为两部分：

  • 低级API ，涉及以下抽象：

    • 地址 ，它们是网络标识符，如IP地址。

    • 套接字是基本的双向数据通信机制。

    • 接口 ，描述网络接口。

  • 高级API ，涉及以下抽象：

    • URI ，表示通用资源标识符。

    • 网址 ，代表普遍资源定位器。

    • 连接 ，表示与URL指向的资源的连接。

地址

java.net API中的地址用作主机标识符或套接字端点标识符。

InetAddress类是代表IP（互联网协议）地址的抽象。 它有两个子类：

  • Inet4Address的IPv4地址。
  • Inet6Address的IPv6地址。

但是，在大多数情况下，不需要直接处理子类，因为InetAddress抽象应该涵盖大部分所需的功能。

关于IPv6

并非所有系统都支持IPv6协议，而当Java网络堆栈尝试检测到它并在可用时可以透明地使用它，也可以使用系统属性禁用它。 在IPv6不可用或显式禁用的情况下，Inet6Address对于大多数网络操作来说不是有效参数。 尽管如InetAddress.getByName(java.lang.String)这样的方法保证在查找主机名时不会返回Inet6Address，但通过传递文字可以创建这样一个对象。 在这种情况下，大多数方法在使用Inet6Address调用时都会抛出异常。

套接字

插座是通过网络在机器之间建立通信链路的手段。 java.net包提供了4种套接字：

  • Socket是TCP客户端API，通常用于远程主机的connect 。
  • ServerSocket是一个TCP服务器API，通常来自客户端套接字的accept连接。
  • DatagramSocket是UDP端点API，用于send和receive datagram packets 。
  • MulticastSocket是处理组播组时使用的DatagramSocket的子类。

使用TCP套接字发送和接收通过InputStreams和OutputStreams完成，可以通过Socket.getInputStream()和Socket.getOutputStream()方法获取。

接口

NetworkInterface类提供API来浏览和查询本地机器的所有网络接口（例如以太网连接或PPP端点）。 通过该类，您可以检查是否有任何本地接口配置为支持IPv6。

注意，所有一致的实现必须至少支持一个NetworkInterface对象，它们必须连接到网络，或者是一个“回送”接口，只能与同一机器上的实体进行通信。

高级API

java.net包中的一些类确实提供了更高级别的抽象，并允许轻松访问网络上的资源。 课程是：

  • URI是表示通用资源标识符的类，如RFC 2396所规定。如名称所示，这只是一个标识符，不直接提供访问资源的方法。
  • URL是代表通用资源定位器的类，它是URI的老概念和访问资源的一种手段。
  • URLConnection是从URL创建的，并且是用于访问由URL指向的资源的通信链接。 这个抽象类将大部分的工作委托给底层的协议处理程序，如http或https。
  • HttpURLConnection是URLConnection的子类，并提供了一些特定于HTTP协议的附加功能。 该API已经被上一节中描述的较新的HTTP客户端API所取代。

推荐的用法是使用URI来识别资源，然后将其转换为URL，当它是时候访问资源。 从该URL，您可以获得URLConnection进行精细控制，或直接获取InputStream。

这是一个例子：

  URI uri = new URI("http://java.sun.com/");
 URL url = uri.toURL();
 InputStream in = url.openStream();

协议处理程序

如前所述，URL和URLConnection依赖于必须存在的协议处理程序，否则抛出异常。 这是与仅识别资源的URI的主要区别，因此不需要访问协议处理程序。 因此，尽管可以使用任何类型的协议方案（例如， myproto://myhost.mydomain/resource/ ）创建URI，但类似的URL将尝试实例化指定协议的处理程序; 如果不存在，将抛出异常。

默认情况下，协议处理程序是从默认位置动态加载的。 然而，可以部署其他协议处理程序为services 。 类型为URLStreamHandlerProvider的服务提供商位于运行时，如URL constructor中所述。

附加规格

  • Networking System Properties
从以下版本开始：
1.0
  • 接口摘要
    接口 描述
    ContentHandlerFactory
    该界面为内容处理程序定义了一个工厂。
    CookiePolicy
    CookiePolicy实现决定哪些Cookie应该被接受，哪些应该被拒绝。
    CookieStore
    CookieStore对象表示Cookie的存储。
    DatagramSocketImplFactory
    该接口为数据报套接字实现定义了一个工厂。
    FileNameMap
    一个简单的界面，提供了一种在文件名和MIME类型字符串之间映射的机制。
    ProtocolFamily
    代表一系列通信协议。
    SocketImplFactory
    该接口定义了一个工厂用于套接字实现。
    SocketOption<T>
    与套接字关联的套接字选项。
    SocketOptions
    获取/设置套接字选项的方法的接口。
    URLStreamHandlerFactory
    该接口为 URL流协议处理程序定义了一个工厂。
  • 类摘要
    Class 描述
    Authenticator
    Authenticator类代表一个知道如何获取网络连接认证的对象。
    CacheRequest
    表示在ResponseCache中存储资源的通道。
    CacheResponse
    代表从ResponseCache中检索资源的通道。
    ContentHandler
    抽象类 ContentHandler是从 URLConnection读取 Object的所有类的超类。
    CookieHandler
    CookieHandler对象提供一个回调机制，将HTTP状态管理策略实现连接到HTTP协议处理程序中。
    CookieManager
    CookieManager提供了一个CookieHandler的具体实现， 它将 cookie的存储与接受和拒绝Cookie的策略分开。
    DatagramPacket
    该类表示数据报包。
    DatagramSocket
    此类表示用于发送和接收数据报数据包的套接字。
    DatagramSocketImpl
    抽象数据报和组播套接字实现基类。
    HttpCookie
    HttpCookie对象表示HTTP cookie，它承载服务器和用户代理之间的状态信息。
    HttpURLConnection
    支持HTTP特定功能的URLConnection。
    IDN
    提供在正常Unicode表示和ASCII兼容编码（ACE）表示之间转换国际化域名（IDN）的方法。
    Inet4Address
    该类表示Internet协议版本4（IPv4）地址。
    Inet6Address
    该类表示Internet协议版本6（IPv6）地址。
    InetAddress
    此类表示Internet协议（IP）地址。
    InetSocketAddress
    该类实现IP套接字地址（IP地址+端口号）它也可以是一对（主机名+端口号），在这种情况下将尝试解析主机名。
    InterfaceAddress
    此类表示网络接口地址。
    JarURLConnection
    与Java ARchive（JAR）文件或JAR文件中的条目的URL连接。
    MulticastSocket
    组播数据报套接字类对发送和接收IP组播数据包很有用。
    NetPermission
    此类用于各种网络权限。
    NetworkInterface
    此类表示由名称组成的网络接口和分配给此接口的IP地址列表。
    PasswordAuthentication
    PasswordAuthentication类是Authenticator使用的数据持有者。
    Proxy
    此类表示代理设置，通常是类型（http，socks）和套接字地址。
    ProxySelector
    选择在连接到URL引用的网络资源时使用的代理服务器（如果有）。
    ResponseCache
    表示URLConnection缓存的实现。
    SecureCacheResponse
    表示最初通过安全手段（例如TLS）检索的缓存响应。
    ServerSocket
    这个类实现了服务器套接字。
    Socket
    该类实现客户端套接字（也称为“套接字”）。
    SocketAddress
    这个类代表一个没有协议附件的Socket地址。
    SocketImpl
    抽象类 SocketImpl是实际实现套接字的所有类的公共超类。
    SocketPermission
    此类表示通过套接字访问网络。
    StandardSocketOptions
    定义 标准套接字选项。
    URI
    表示统一资源标识符（URI）参考。
    URL
    URL类代表统一资源定位器，指向万维网上“资源”的指针。
    URLClassLoader
    此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。
    URLConnection
    抽象类 URLConnection是表示应用程序和URL之间的通信链接的所有类的超类。
    URLDecoder
    HTML表单解码的实用类。
    URLEncoder
    HTML表单编码的实用类。
    URLPermission
    表示访问由给定网址定义的资源或资源集的权限，以及给定的一组用户可设置的请求方法和请求标头。
    URLStreamHandler
    抽象类 URLStreamHandler是所有流协议处理程序的通用超类。
  • 枚举摘要
    Enum 描述
    Authenticator.RequestorType
    请求认证的实体的类型。
    Proxy.Type
    代表代理类型。
    StandardProtocolFamily
    定义通信协议的标准系列。
  • 异常摘要
    异常 描述
    BindException
    指示尝试将套接字绑定到本地地址和端口时发生错误。
    ConnectException
    指示尝试将套接字连接到远程地址和端口时发生错误。
    HttpRetryException
    抛出表示HTTP请求需要重试，但由于启用了流式传输模式，因此无法自动重试。
    MalformedURLException
    抛出以表示发生格式不正确的网址。
    NoRouteToHostException
    指示尝试将套接字连接到远程地址和端口时发生错误。
    PortUnreachableException
    指示在连接的数据报上收到了ICMP端口不可达消息。
    ProtocolException
    抛出以表示底层协议有错误，如TCP错误。
    SocketException
    抛出以表示创建或访问Socket时出错。
    SocketTimeoutException
    指示在套接字上发生超时时读取或接受。
    UnknownHostException
    抛出以表示无法确定主机的IP地址。
    UnknownServiceException
    抛出以表示发生未知服务异常。
    URISyntaxException
    检查的异常抛出以指示不能将字符串解析为URI引用。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev Package
  • Next Package
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


java.net Class Hierarchy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类
  • SEARCH:

Hierarchy For Package java.net

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.net.Authenticator
    • java.net.CacheRequest
    • java.net.CacheResponse
      • java.net.SecureCacheResponse
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader (implements java.io.Closeable)
    • java.net.ContentHandler
    • java.net.CookieHandler
      • java.net.CookieManager
    • java.net.DatagramPacket
    • java.net.DatagramSocket (implements java.io.Closeable)
      • java.net.MulticastSocket
    • java.net.DatagramSocketImpl (implements java.net.SocketOptions)
    • java.net.HttpCookie (implements java.lang.Cloneable)
    • java.net.IDN
    • java.net.InetAddress (implements java.io.Serializable)
      • java.net.Inet4Address
      • java.net.Inet6Address
    • java.net.InterfaceAddress
    • java.net.NetworkInterface
    • java.net.PasswordAuthentication
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.net.NetPermission
      • java.net.SocketPermission (implements java.io.Serializable)
      • java.net.URLPermission
    • java.net.Proxy
    • java.net.ProxySelector
    • java.net.ResponseCache
    • java.net.ServerSocket (implements java.io.Closeable)
    • java.net.Socket (implements java.io.Closeable)
    • java.net.SocketAddress (implements java.io.Serializable)
      • java.net.InetSocketAddress
    • java.net.SocketImpl (implements java.net.SocketOptions)
    • java.net.StandardSocketOptions
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.异常
        • java.io.IOException
          • java.net.HttpRetryException
          • java.io.InterruptedIOException
            • java.net.SocketTimeoutException
          • java.net.MalformedURLException
          • java.net.ProtocolException
          • java.net.SocketException
            • java.net.BindException
            • java.net.ConnectException
            • java.net.NoRouteToHostException
            • java.net.PortUnreachableException
          • java.net.UnknownHostException
          • java.net.UnknownServiceException
        • java.net.URISyntaxException
    • java.net.URI (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.net.URL (implements java.io.Serializable)
    • java.net.URLConnection
      • java.net.HttpURLConnection
      • java.net.JarURLConnection
    • java.net.URLDecoder
    • java.net.URLEncoder
    • java.net.URLStreamHandler

Interface Hierarchy

  • java.net.ContentHandlerFactory
  • java.net.CookiePolicy
  • java.net.CookieStore
  • java.net.DatagramSocketImplFactory
  • java.net.FileNameMap
  • java.net.ProtocolFamily
  • java.net.SocketImplFactory
  • java.net.SocketOption<T>
  • java.net.SocketOptions
  • java.net.URLStreamHandlerFactory

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.net.Authenticator.RequestorType
      • java.net.Proxy.Type
      • java.net.StandardProtocolFamily (implements java.net.ProtocolFamily)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • Prev
  • Next
  • 框架
  • 无框架
  • 所有类

Report a bug or suggest an enhancement


MalformedURLException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class MalformedURLException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.MalformedURLException
  • All Implemented Interfaces:
    Serializable

    public class MalformedURLException
extends IOException
    抛出以表示发生格式不正确的网址。 在规范字符串中找不到任何合法协议，或者无法解析字符串。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      MalformedURLException​()
      构造一个 MalformedURLException ，没有详细消息。
      MalformedURLException​(String msg)
      构造具有指定详细消息的 MalformedURLException 。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • MalformedURLException

        public MalformedURLException​()
        构造一个 MalformedURLException ，没有详细消息。

      • MalformedURLException

        public MalformedURLException​(String msg)
        构造具有指定详细消息的 MalformedURLException 。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


MulticastSocket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class MulticastSocket

  • java.lang.Object
    • java.net.DatagramSocket
      • java.net.MulticastSocket
  • All Implemented Interfaces:
    Closeable ， AutoCloseable

    public class MulticastSocket
extends DatagramSocket
    组播数据报套接字类对发送和接收IP组播数据包很有用。 MulticastSocket是一个（UDP）DatagramSocket，具有加入互联网上其他组播主机的“组”的附加功能。

    组播组由D类IP地址和标准UDP端口号指定。 D类IP地址范围为224.0.0.0至239.255.255.255 （含）。 地址224.0.0.0是保留的，不应该使用。

    一个可以通过首先创建具有所需端口的MulticastSocket来加入多播组，然后调用joinGroup(InetAddress groupAddr)方法：

      // join a Multicast group and send the group salutations
 ...
 String msg = "Hello";
 InetAddress group = InetAddress.getByName("228.5.6.7");
 MulticastSocket s = new MulticastSocket(6789);
 s.joinGroup(group);
 DatagramPacket hi = new DatagramPacket(msg.getBytes(), msg.length(),
                             group, 6789);
 s.send(hi);
 // get their responses!
 byte[] buf = new byte[1000];
 DatagramPacket recv = new DatagramPacket(buf, buf.length);
 s.receive(recv);
 ...
 // OK, I'm done talking - leave the group...
 s.leaveGroup(group);
    当向多播组发送消息时，向该主机和端口发送的所有订阅的收件人都将收到消息（在数据包的生存时间内，请参见下文）。 套接字不需要是组播组的成员来向其发送消息。

    当一个套接字订阅一个组播组/端口时，它接收其他主机发送到组/端口的数据报，组和端口的所有其他成员也同样。 套接字通过leaveGroup（InetAddress addr）方法放弃组中的成员资格。 多个MulticastSocket可以同时订阅组播组和端口，并且它们都将接收组数据报。

    目前applet不允许使用组播套接字。

    从以下版本开始：
    1.1

    • 构造方法摘要

      构造方法
      Constructor 描述
      MulticastSocket​()
      创建组播套接字。
      MulticastSocket​(int port)
      创建组播套接字并将其绑定到特定端口。
      MulticastSocket​(SocketAddress bindaddr)
      创建一个绑定到指定套接字地址的MulticastSocket。

    • 方法摘要

      所有方法 接口方法 具体的方法 弃用的方法
      Modifier and Type 方法 描述
      InetAddress getInterface​()
      检索用于组播数据包的网络接口的地址。
      boolean getLoopbackMode​()
      获取组播数据报的本地环回设置。
      NetworkInterface getNetworkInterface​()
      获取组播网络接口集。
      int getTimeToLive​()
      获取在套接字上发送的组播数据包的默认生存时间。
      byte getTTL​()
      已过时。
      使用getTimeToLive方法，它返回一个int而不是一个字节 。
      void joinGroup​(InetAddress mcastaddr)
      加入组播组。
      void joinGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的接口加入指定的组播组。
      void leaveGroup​(InetAddress mcastaddr)
      离开多播组。
      void leaveGroup​(SocketAddress mcastaddr, NetworkInterface netIf)
      在指定的本地接口上留下组播组。
      void send​(DatagramPacket p, byte ttl)
      已过时。
      使用以下代码或其等价物：...... int ttl = mcastSocket.getTimeToLive（）;
mcastSocket.setTimeToLive（newttl）;
mcastSocket.send（P）;
mcastSocket.setTimeToLive（TTL）;
......
      void setInterface​(InetAddress inf)
      设置由行为受网络接口值影响的方法使用的组播网络接口。
      void setLoopbackMode​(boolean disable)
      禁用/启用组播数据报的本地环回该选项由平台的网络代码用作设置组播数据是否将环回到本地套接字的提示。
      void setNetworkInterface​(NetworkInterface netIf)
      指定在此套接字上发送的出站组播数据报的网络接口。
      void setTimeToLive​(int ttl)
      为此 MulticastSocket发送的组播数据包的默认生存时间为了控制组播的范围。
      void setTTL​(byte ttl)
      已过时。
      使用setTimeToLive方法，它使用int而不是byte作为ttl的类型。
      Set<SocketOption<?>> supportedOptions​()
      返回此套接字支持的一组套接字选项。

      • Methods inherited from class java.net.DatagramSocket

        bind, close, connect, connect, disconnect, getBroadcast, getChannel, getInetAddress, getLocalAddress, getLocalPort, getLocalSocketAddress, getOption, getPort, getReceiveBufferSize, getRemoteSocketAddress, getReuseAddress, getSendBufferSize, getSoTimeout, getTrafficClass, isBound, isClosed, isConnected, receive, send, setBroadcast, setDatagramSocketImplFactory, setOption, setReceiveBufferSize, setReuseAddress, setSendBufferSize, setSoTimeout, setTrafficClass

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MulticastSocket

        public MulticastSocket​()
                throws IOException
        创建组播套接字。

        如果有一个安全管理器，它的checkListen方法首先被调用为0作为参数，以确保操作是允许的。 这可能会导致SecurityException。

        当创建套接字时，将调用DatagramSocket.setReuseAddress(boolean)方法来启用SO_REUSEADDR套接字选项。

        异常
        IOException - 如果在创建MulticastSocket时发生I / O异常
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许该操作。
        另请参见：
        SecurityManager.checkListen(int) ，
DatagramSocket.setReuseAddress(boolean) ，
DatagramSocketImpl.setOption(SocketOption, Object)

      • MulticastSocket

        public MulticastSocket​(int port)
                throws IOException
        创建组播套接字并将其绑定到特定端口。

        如果有安全管理器，则首先调用其checkListen方法，其参数为port ，以确保允许操作。 这可能会导致SecurityException。

        当创建套接字时，将调用DatagramSocket.setReuseAddress(boolean)方法来启用SO_REUSEADDR套接字选项。

        参数
        port - 要使用的端口
        异常
        IOException - 如果在创建MulticastSocket时发生I / O异常
        SecurityException - 如果安全管理器存在，并且其 checkListen方法不允许操作。
        另请参见：
        SecurityManager.checkListen(int) ， DatagramSocket.setReuseAddress(boolean)

      • MulticastSocket

        public MulticastSocket​(SocketAddress bindaddr)
                throws IOException
        创建一个绑定到指定套接字地址的MulticastSocket。

        或者，如果地址为null ，请创建未绑定的套接字。

        如果有安全管理器，则首先使用SocketAddress端口调用其checkListen方法作为参数，以确保允许操作。 这可能会导致SecurityException。

        当创建套接字时，将调用DatagramSocket.setReuseAddress(boolean)方法来启用SO_REUSEADDR套接字选项。

        参数
        bindaddr - 要绑定的套接字地址，或 null用于未绑定的套接字。
        异常
        IOException - 如果在创建MulticastSocket时发生I / O异常
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许操作。
        从以下版本开始：
        1.4
        另请参见：
        SecurityManager.checkListen(int) ， DatagramSocket.setReuseAddress(boolean)

    • 方法详细信息

      • setTTL

        @Deprecated
public void setTTL​(byte ttl)
            throws IOException
        已过时。 使用setTimeToLive方法，它使用int而不是byte作为ttl的类型。
        为此MulticastSocket发送的组播数据包的默认生存时间为了控制组播的范围。

        ttl是一个无符号的 8位数，因此必须在0 <= ttl <= 0xFF范围内。

        参数
        ttl - 生存时间
        异常
        IOException - 如果在设置默认生存时间值时发生I / O异常
        另请参见：
        getTTL()

      • setTimeToLive

        public void setTimeToLive​(int ttl)
                   throws IOException
        为此MulticastSocket发送的组播数据包的默认生存时间为了控制组播的范围。

        ttl 必须在0 <= ttl <= 255范围内， IllegalArgumentException将抛出IllegalArgumentException 。 发送TTL为0不在网络上传输，但可能在本地传送。

        参数
        ttl - 生存时间
        异常
        IOException - 如果在设置默认生存时间值时发生I / O异常
        另请参见：
        getTimeToLive()

      • getTTL

        @Deprecated
public byte getTTL​()
            throws IOException
        已过时。 使用getTimeToLive方法，它返回一个int而不是一个字节 。
        获取在套接字上发送的组播数据包的默认生存时间。
        结果
        默认的生存时间值
        异常
        IOException - 如果在获取默认生存时间值的情况下发生I / O异常
        另请参见：
        setTTL(byte)

      • getTimeToLive

        public int getTimeToLive​()
                  throws IOException
        获取在套接字上发送的组播数据包的默认生存时间。
        结果
        默认的生存时间值
        异常
        IOException - 如果在获取默认生存时间值时发生I / O异常
        另请参见：
        setTimeToLive(int)

      • joinGroup

        public void joinGroup​(InetAddress mcastaddr)
               throws IOException
        加入组播组。 其行为可能受到setInterface或setNetworkInterface影响。

        如果有安全管理器，则该方法首先使用mcastaddr参数作为参数来调用其checkMulticast方法。

        参数
        mcastaddr - 是要加入的组播地址
        异常
        IOException - 如果加入错误，或者地址不是组播地址，或平台不支持组播
        SecurityException - 如果存在安全管理员，并且其 checkMulticast方法不允许连接。
        另请参见：
        SecurityManager.checkMulticast(InetAddress)

      • leaveGroup

        public void leaveGroup​(InetAddress mcastaddr)
                throws IOException
        离开多播组。 其行为可能受到setInterface或setNetworkInterface影响。

        如果有一个安全管理器，这个方法首先调用它的checkMulticast方法，其中参数为mcastaddr 。

        参数
        mcastaddr - 是要离开的组播地址
        异常
        IOException - 如果出现错误或地址不是组播地址时出现错误。
        SecurityException - 如果存在安全管理员，并且其 checkMulticast方法不允许操作。
        另请参见：
        SecurityManager.checkMulticast(InetAddress)

      • joinGroup

        public void joinGroup​(SocketAddress mcastaddr,
                      NetworkInterface netIf)
               throws IOException
        在指定的接口加入指定的组播组。

        如果有一个安全管理器，这个方法首先调用它的checkMulticast方法，其参数为mcastaddr 。

        参数
        mcastaddr - 是要加入的组播地址
        netIf - 指定接收组播数据报包的本地接口，否则为 null ，延迟到 setInterface(InetAddress)或 setNetworkInterface(NetworkInterface)设置的接口
        异常
        IOException - 如果加入错误，或地址不是组播地址，或平台不支持组播
        SecurityException - 如果存在安全管理员，并且其 checkMulticast方法不允许连接。
        IllegalArgumentException - 如果mcastaddr为null或是此套接字不支持的SocketAddress子类
        从以下版本开始：
        1.4
        另请参见：
        SecurityManager.checkMulticast(InetAddress)

      • leaveGroup

        public void leaveGroup​(SocketAddress mcastaddr,
                       NetworkInterface netIf)
                throws IOException
        在指定的本地接口上留下组播组。

        如果有一个安全管理器，这个方法首先调用它的checkMulticast方法，其中参数为mcastaddr 。

        参数
        mcastaddr - 是要离开的组播地址
        netIf - 指定本地接口或 空值为 setInterface(InetAddress)或 setNetworkInterface(NetworkInterface)设置的接口
        异常
        IOException - 如果出现错误或地址不是组播地址。
        SecurityException - 如果安全管理器存在，并且其 checkMulticast方法不允许该操作。
        IllegalArgumentException - 如果mcastaddr为null或是此套接字不支持的SocketAddress子类
        从以下版本开始：
        1.4
        另请参见：
        SecurityManager.checkMulticast(InetAddress)

      • setInterface

        public void setInterface​(InetAddress inf)
                  throws SocketException
        设置由行为受网络接口值影响的方法使用的组播网络接口。 适用于多宿主主机。
        参数
        inf - InetAddress
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        另请参见：
        getInterface()

      • getInterface

        public InetAddress getInterface​()
                         throws SocketException
        检索用于组播数据包的网络接口的地址。
        结果
        表示用于组播数据包的网络接口地址的 InetAddress 。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        另请参见：
        setInterface(java.net.InetAddress)

      • setNetworkInterface

        public void setNetworkInterface​(NetworkInterface netIf)
                         throws SocketException
        指定在此套接字上发送的出站组播数据报的网络接口。
        参数
        netIf - 界面
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.4
        另请参见：
        getNetworkInterface()

      • getNetworkInterface

        public NetworkInterface getNetworkInterface​()
                                     throws SocketException
        获取组播网络接口集。
        结果
        组播 NetworkInterface当前设置
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.4
        另请参见：
        setNetworkInterface(NetworkInterface)

      • setLoopbackMode

        public void setLoopbackMode​(boolean disable)
                     throws SocketException
        禁用/启用组播数据报的本地环回该选项由平台的网络代码用作设置组播数据是否将环回到本地套接字的提示。

        因为这个选项是一个提示，想要验证什么环回模式设置的应用程序应该调用getLoopbackMode()

        参数
        disable - true禁用LoopbackMode
        异常
        SocketException - 如果在设置值时发生错误
        从以下版本开始：
        1.4
        另请参见：
        getLoopbackMode()

      • getLoopbackMode

        public boolean getLoopbackMode​()
                        throws SocketException
        获取组播数据报的本地环回设置。
        结果
        如果LoopbackMode被禁用则为true
        异常
        SocketException - 如果在获取值时发生错误
        从以下版本开始：
        1.4
        另请参见：
        setLoopbackMode(boolean)

      • send

        @Deprecated
public void send​(DatagramPacket p,
                 byte ttl)
          throws IOException
        已过时。
使用以下代码或其等价物：...... int ttl = mcastSocket.getTimeToLive（）;
mcastSocket.setTimeToLive（newttl）;
mcastSocket.send（P）;
mcastSocket.setTimeToLive（TTL）;
......
        将数据报包发送到目的地，TTL（生存时间）不是套接字的默认值。 该方法只需要在需要特定TTL的情况下使用; 否则最好在套接字上设置TTL一次，并对所有数据包使用该默认TTL。 此方法不改变套接字的默认TTL。 其行为可能受到setInterface影响。

        如果有安全管理器，则该方法首先执行一些安全检查。 首先，如果p.getAddress().isMulticastAddress()为真，则该方法调用安全管理器的checkMulticast方法，其中p.getAddress()和ttl作为参数。 如果该表达式的评估为false，则该方法会调用安全性管理器的checkConnect方法，其参数为p.getAddress().getHostAddress()和p.getPort() 。 每次调用安全管理器方法都可能导致SecurityException，如果不允许操作。

        参数
        p - 是要发送的数据包。 数据包应包含目标组播IP地址和要发送的数据。 一个不需要是组的成员发送报文到目的组播地址。
        ttl - 组播数据包的可选时间。 默认ttl为1。
        异常
        IOException - 如果发生错误，即设置ttl时发生错误，则会引发。
        SecurityException - 如果存在安全管理员，并且其 checkMulticast或 checkConnect方法不允许发送。
        另请参见：
        DatagramSocket.send(java.net.DatagramPacket) ，
DatagramSocket.receive(java.net.DatagramPacket) ，
SecurityManager.checkMulticast(java.net.InetAddress, byte) ，
SecurityManager.checkConnect(java.lang.String, int)

      • supportedOptions

        public Set<SocketOption<?>> supportedOptions​()
        描述从类复制： DatagramSocket
        返回此套接字支持的一组套接字选项。 即使在套接字关闭后，此方法也将继续返回该选项。
        重写：
        supportedOptions在 DatagramSocket
        结果
        该套接字支持的一组套接字选项。 如果套接字的DatagramSocketImpl无法创建，则此集合可能为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NetPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class NetPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • java.net.NetPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class NetPermission
extends BasicPermission
    此类用于各种网络权限。 NetPermission包含一个名称（也称为“目标名称”），但没有操作列表; 你有指定的权限，或者你没有。

    目标名称是网络许可的名称（见下文）。 命名约定遵循层次化属性命名约定。 此外，星号可能会出现在名称的末尾，遵循“。”或本身表示通配符匹配。 例如：“foo。*”和“*”表示通配符匹配，而“* foo”和“a * b”则不表示。

    下表列出了所有可能的NetPermission目标名称，每个都提供了许可允许的描述，并讨论授予代码的权限。

    Permission target name, what the permission allows, and associated risks Permission Target Name What the Permission Allows Risks of Allowing this Permission allowHttpTrace The ability to use the HTTP TRACE method in HttpURLConnection. Malicious code using HTTP TRACE could get access to security sensitive information in the HTTP headers (such as cookies) that it might not otherwise have access to. getCookieHandler The ability to get the cookie handler that processes highly security sensitive cookie information for an Http session. Malicious code can get a cookie handler to obtain access to highly security sensitive cookie information. Some web servers use cookies to save user private information such as access control information, or to track user browsing habit. getNetworkInformation The ability to retrieve all information about local network interfaces. Malicious code can read information about network hardware such as MAC addresses, which could be used to construct local IPv6 addresses. getProxySelector The ability to get the proxy selector used to make decisions on which proxies to use when making network connections. Malicious code can get a ProxySelector to discover proxy hosts and ports on internal networks, which could then become targets for attack. getResponseCache The ability to get the response cache that provides access to a local response cache. Malicious code getting access to the local response cache could access security sensitive information. requestPasswordAuthentication The ability to ask the authenticator registered with the system for a password Malicious code may steal this password. setCookieHandler The ability to set the cookie handler that processes highly security sensitive cookie information for an Http session. Malicious code can set a cookie handler to obtain access to highly security sensitive cookie information. Some web servers use cookies to save user private information such as access control information, or to track user browsing habit. setDefaultAuthenticator The ability to set the way authentication information is retrieved when a proxy or HTTP server asks for authentication Malicious code can set an authenticator that monitors and steals user authentication input as it retrieves the input from the user. setProxySelector The ability to set the proxy selector used to make decisions on which proxies to use when making network connections. Malicious code can set a ProxySelector that directs network traffic to an arbitrary network host. setResponseCache The ability to set the response cache that provides access to a local response cache. Malicious code getting access to the local response cache could access security sensitive information, or create false entries in the response cache. specifyStreamHandler The ability to specify a stream handler when constructing a URL Malicious code may create a URL with resources that it would normally not have access to (like file:/foo/fum/), specifying a stream handler that gets the actual bytes from someplace it does have access to. Thus it might be able to trick the system into creating a ProtectionDomain/CodeSource for a class even though that class really didn't come from that location.
    从以下版本开始：
    1.2
    另请参见：
    BasicPermission ， Permission ， Permissions ， PermissionCollection ， SecurityManager ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NetPermission​(String name)
      创建一个具有指定名称的新NetPermission。
      NetPermission​(String name, String actions)
      创建具有指定名称的新NetPermission对象。

    • 方法摘要

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • NetPermission

        public NetPermission​(String name)
        创建一个具有指定名称的新NetPermission。 名称是NetPermission的符号名称，例如“setDefaultAuthenticator”等。星号可能会出现在名称的末尾，跟随“。”，或者本身表示通配符匹配。
        参数
        name - NetPermission的名称。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。

      • NetPermission

        public NetPermission​(String name,
                     String actions)
        创建具有指定名称的新NetPermission对象。 该名称是NetPermission的符号名称，并且操作String当前未使用，并且应为null。
        参数
        name - NetPermission的名称。
        actions - 应为null。
        异常
        NullPointerException - 如果 name是 null 。
        IllegalArgumentException - 如果 name为空。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NetworkInterface (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class NetworkInterface

  • java.lang.Object
    • java.net.NetworkInterface

  • public final class NetworkInterface
extends Object
    此类表示由名称组成的网络接口和分配给此接口的IP地址列表。 用于标识组播组所在的本地接口。 接口通常由诸如“le0”的名称所知。
    从以下版本开始：
    1.4

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      static NetworkInterface getByIndex​(int index)
      获取一个网络接口给它的索引。
      static NetworkInterface getByInetAddress​(InetAddress addr)
      搜索具有绑定到指定的Internet协议（IP）地址的网络接口的便利方法。
      static NetworkInterface getByName​(String name)
      搜索具有指定名称的网络接口。
      String getDisplayName​()
      获取此网络接口的显示名称。
      byte[] getHardwareAddress​()
      返回接口的硬件地址（通常是MAC），如果它有一个，如果可以访问给定当前权限。
      int getIndex​()
      返回此网络接口的索引。
      Enumeration<InetAddress> getInetAddresses​()
      获取绑定到此网络接口的所有或一部分InetAddress的枚举。
      List<InterfaceAddress> getInterfaceAddresses​()
      获取此网络接口的 InterfaceAddresses的全部或部分的列表。
      int getMTU​()
      返回此接口的最大传输单元（MTU）。
      String getName​()
      获取此网络接口的名称。
      static Enumeration<NetworkInterface> getNetworkInterfaces​()
      返回此机器上所有接口的 Enumeration 。
      NetworkInterface getParent​()
      如果这是一个子接口，则返回此接口的父网络接口，如果它是物理（非虚拟）接口或没有父接口，则返回 null 。
      Enumeration<NetworkInterface> getSubInterfaces​()
      获取连接到此网络接口的所有子接口（也称为虚拟接口）的枚举。
      int hashCode​()
      返回对象的哈希码值。
      Stream<InetAddress> inetAddresses​()
      获取绑定到此网络接口的InetAddresses的全部或一部分子流。
      boolean isLoopback​()
      返回网络接口是否是环回接口。
      boolean isPointToPoint​()
      返回网络接口是否是点对点接口。
      boolean isUp​()
      返回网络接口是否启动并运行。
      boolean isVirtual​()
      返回此接口是否为虚拟接口（也称为子接口）。
      static Stream<NetworkInterface> networkInterfaces​()
      返回此机器上所有接口的 Stream 。
      Stream<NetworkInterface> subInterfaces​()
      获取附加到此网络接口的所有子接口（也称为虚拟接口）的流。
      boolean supportsMulticast​()
      返回网络接口是否支持多播。
      String toString​()
      返回对象的字符串表示形式。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getName

        public String getName​()
        获取此网络接口的名称。
        结果
        这个网络接口的名称

      • getInetAddresses

        public Enumeration<InetAddress> getInetAddresses​()
        获取绑定到此网络接口的所有或一部分InetAddress的枚举。

        如果有安全管理器，则为每个InetAddress调用其checkConnect方法。 枚举中只会返回checkConnect不抛出SecurityException的InetAddress。 但是，如果调用者具有NetPermission （“getNetworkInformation”）权限，则返回所有InetAddresses。

        结果
        一个Enumeration对象，其中包含绑定到此网络接口的InetAddresses的全部或一部分子集
        另请参见：
        inetAddresses()

      • inetAddresses

        public Stream<InetAddress> inetAddresses​()
        获取绑定到此网络接口的InetAddresses的全部或一部分子流。

        如果有安全管理器，则为每个InetAddress调用其checkConnect方法。 只有在checkConnect不会引发SecurityException的InetAddress将在Stream中返回。 但是，如果调用者具有NetPermission （“getNetworkInformation”）权限，则返回所有InetAddresses。

        结果
        一个Stream对象，其全部或一部分InetAddresses绑定到此网络接口
        从以下版本开始：
        9

      • getInterfaceAddresses

        public List<InterfaceAddress> getInterfaceAddresses​()
        获取此网络接口的InterfaceAddresses的全部或部分的列表。

        如果有一个安全管理器，它的checkConnect方法将使用每个InterfaceAddress的InetAddress进行调用。 只有checkConnect不会引发SecurityException的InterfaceAddress才会在列表中返回。

        结果
        一个 List对象，具有此网络接口的所有或一部分InterfaceAddresss
        从以下版本开始：
        1.6

      • getSubInterfaces

        public Enumeration<NetworkInterface> getSubInterfaces​()
        获取连接到此网络接口的所有子接口（也称为虚拟接口）的枚举。

        例如eth0：1将是eth0的子接口。

        结果
        一个具有该网络接口的所有子接口的枚举对象
        从以下版本开始：
        1.6
        另请参见：
        subInterfaces()

      • subInterfaces

        public Stream<NetworkInterface> subInterfaces​()
        获取附加到此网络接口的所有子接口（也称为虚拟接口）的流。
        结果
        一个Stream对象与该网络接口的所有子接口
        从以下版本开始：
        9

      • getParent

        public NetworkInterface getParent​()
        如果这是一个子接口，则返回此接口的父网络接口，如果它是物理（非虚拟）接口或没有父接口，则返回 null 。
        结果
        这个接口是 NetworkInterface 。
        从以下版本开始：
        1.6

      • getIndex

        public int getIndex​()
        返回此网络接口的索引。 索引为大于或等于零的整数，或-1为-1 。 这是一个系统特定的值，具有相同名称的接口可以在不同的机器上具有不同的索引。
        结果
        该网络接口的索引或 -1如果索引未知
        从以下版本开始：
        1.7
        另请参见：
        getByIndex(int)

      • getDisplayName

        public String getDisplayName​()
        获取此网络接口的显示名称。 显示名称是描述网络设备的人类可读字符串。
        结果
        表示此网络接口的显示名称的非空字符串，如果没有显示名称可用，则为空。

      • getByName

        public static NetworkInterface getByName​(String name)
                                  throws SocketException
        搜索具有指定名称的网络接口。
        参数
        name - 网络接口的名称。
        结果
        甲 NetworkInterface具有指定名称，或 null如果不存在具有指定名称的网络接口。
        异常
        SocketException - 如果发生I / O错误。
        NullPointerException - 如果指定的名称为 null 。

      • getByIndex

        public static NetworkInterface getByIndex​(int index)
                                   throws SocketException
        获取一个网络接口给它的索引。
        参数
        index - 一个整数，接口的索引
        结果
        NetworkInterface从其索引中获取，或者如果没有接口，则系统上有这样一个索引的 null
        异常
        SocketException - 如果发生I / O错误。
        IllegalArgumentException - 如果索引具有负值
        从以下版本开始：
        1.7
        另请参见：
        getIndex()

      • getByInetAddress

        public static NetworkInterface getByInetAddress​(InetAddress addr)
                                         throws SocketException
        搜索具有绑定到指定的Internet协议（IP）地址的网络接口的便利方法。

        如果指定的IP地址绑定到多个网络接口，则不会定义哪个网络接口返回。

        参数
        addr - 要搜索的 InetAddress 。
        结果
        A NetworkInterface或 null如果没有指定IP地址的网络接口。
        异常
        SocketException - 如果发生I / O错误。
        NullPointerException - 如果指定的地址是 null 。

      • getNetworkInterfaces

        public static Enumeration<NetworkInterface> getNetworkInterfaces​()
                                                          throws SocketException
        返回此机器上所有接口的Enumeration 。 Enumeration包含至少一个元素，可能表示仅支持本机器上的实体之间的通信的回送接口。
        API Note:
        该方法可以与 getInetAddresses()组合使用，以获取此节点的所有IP地址
        结果
        在本机上找到的NetworkInterfaces枚举
        异常
        SocketException - 如果发生I / O错误，或者平台至少没有一个配置的网络接口。
        另请参见：
        networkInterfaces()

      • networkInterfaces

        public static Stream<NetworkInterface> networkInterfaces​()
                                                  throws SocketException
        返回此机器上所有接口的Stream 。 Stream包含至少一个接口，可能表示仅支持本机器上的实体之间的通信的环回接口。
        API Note:
        该方法可以与inetAddresses()一起使用，以获得该节点的所有IP地址流，例如：
           Stream<InetAddress> addrs = NetworkInterface.networkInterfaces() .flatMap(NetworkInterface::inetAddresses);
        结果
        在本机上发现的一个NetworkInterfaces流
        异常
        SocketException - 如果发生I / O错误，或者平台至少没有一个配置的网络接口。
        从以下版本开始：
        9

      • isUp

        public boolean isUp​()
             throws SocketException
        返回网络接口是否启动并运行。
        结果
        true如果接口已启动并运行。
        异常
        SocketException - 如果发生I / O错误。
        从以下版本开始：
        1.6

      • isLoopback

        public boolean isLoopback​()
                   throws SocketException
        返回网络接口是否是环回接口。
        结果
        true如果接口是环回接口。
        异常
        SocketException - 如果发生I / O错误。
        从以下版本开始：
        1.6

      • isPointToPoint

        public boolean isPointToPoint​()
                       throws SocketException
        返回网络接口是否是点对点接口。 典型的点对点接口是通过调制解调器的PPP连接。
        结果
        true如果接口是点对点接口。
        异常
        SocketException - 如果发生I / O错误。
        从以下版本开始：
        1.6

      • supportsMulticast

        public boolean supportsMulticast​()
                          throws SocketException
        返回网络接口是否支持多播。
        结果
        true如果接口支持多播。
        异常
        SocketException - 如果发生I / O错误。
        从以下版本开始：
        1.6

      • getHardwareAddress

        public byte[] getHardwareAddress​()
                          throws SocketException
        返回接口的硬件地址（通常是MAC），如果它有一个，如果可以访问给定当前权限。 如果设置了安全管理员，则呼叫者必须具有权限NetPermission （“getNetworkInformation”）。
        结果
        一个包含地址的字节数组，如果地址不存在，则为 null ，不可访问或设置安全管理器，并且调用者没有权限NetPermission（“getNetworkInformation”）
        异常
        SocketException - 如果发生I / O错误。
        从以下版本开始：
        1.6

      • getMTU

        public int getMTU​()
           throws SocketException
        返回此接口的最大传输单元（MTU）。
        结果
        该接口的MTU值。
        异常
        SocketException - 如果发生I / O错误。
        从以下版本开始：
        1.6

      • isVirtual

        public boolean isVirtual​()
        返回此接口是否为虚拟接口（也称为子接口）。 在一些系统上，虚拟接口是作为物理接口的子节点创建的接口，并给出不同的设置（如地址或MTU）。 通常，接口的名称将是父类的名称，后跟冒号（:)和标识子级的数字，因为可以有多个虚拟接口连接到单个物理接口。
        结果
        true如果这个接口是一个虚拟接口。
        从以下版本开始：
        1.6

      • equals

        public boolean equals​(Object obj)
        将此对象与指定对象进行比较。 当且仅当参数不是null并且它表示与此对象相同的NetworkInterface时，结果为true 。

        NetworkInterface两个实例表示相同的NetworkInterface，如果两个名称和addrs都相同。

        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是一样的; 否则为false 。
        另请参见：
        InetAddress.getAddress()

      • hashCode

        public int hashCode​()
        描述从类别复制： Object
        返回对象的哈希码值。 支持这种方法有利于哈希表，如HashMap提供的那样 。

        hashCode的总合同是：

        • 无论何时在执行Java应用程序时多次在同一个对象上调用该对象，则hashCode方法必须始终返回相同的整数，前提是修改了对象中equals比较中的信息。 该整数不需要从一个应用程序的执行到相同应用程序的另一个执行保持一致。
        • 如果根据equals(Object)方法两个对象相等，则在两个对象中的每个对象上调用hashCode方法必须产生相同的整数结果。
        • 不要求如果两个对象根据Object.equals(java.lang.Object)方法不相等，则在两个对象中的每个对象上调用hashCode方法必须产生不同的整数结果。 但是，程序员应该意识到，为不等对象生成不同的整数结果可能会提高哈希表的性能。

        尽可能多的合理实用，由类Object定义的hashCode方法确实为不同对象返回不同的整数。 （在某个时间点，hashCode可能或可能不被实现为对象的存储器地址的某些功能。）

        重写：
        hashCode在 Object
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • toString

        public String toString​()
        描述从类别复制： Object
        返回对象的字符串表示形式。 一般来说， toString方法返回一个字符串，“文本地表示”此对象。 结果应该是一个简明扼要的表达，容易让人阅读。 建议所有子类覆盖此方法。

        该toString类方法Object返回一个由类的名称，其中所述对象是其实例，该符号字符`的字符串@ ”，并且对象的哈希码的无符号的十六进制表示。 换句话说，这个方法返回一个等于下列值的字符串：

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重写：
        toString在 Object
        结果
        a string representation of the object.
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


NoRouteToHostException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class NoRouteToHostException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.SocketException
            • java.net.NoRouteToHostException
  • All Implemented Interfaces:
    Serializable

    public class NoRouteToHostException
extends SocketException
    指示尝试将套接字连接到远程地址和端口时发生错误。 通常，由于介入的防火墙或中间路由器关闭，无法访问远程主机。
    从以下版本开始：
    1.1
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      NoRouteToHostException​()
      构造一个没有详细消息的新的NoRouteToHostException。
      NoRouteToHostException​(String msg)
      构造一个新的NoRouteToHostException，其中指定的详细信息是为什么无法访问远程主机。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • NoRouteToHostException

        public NoRouteToHostException​(String msg)
        构造一个新的NoRouteToHostException，其中指定的详细信息是为什么无法访问远程主机。 详细信息是一个字符串，它给出了该错误的具体描述。
        参数
        msg - 详细信息

      • NoRouteToHostException

        public NoRouteToHostException​()
        构造一个没有详细消息的新的NoRouteToHostException。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PasswordAuthentication (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class PasswordAuthentication

  • java.lang.Object
    • java.net.PasswordAuthentication

  • public final class PasswordAuthentication
extends Object
    PasswordAuthentication类是Authenticator使用的数据持有者。 它只是用户名和密码的存储库。
    从以下版本开始：
    1.2
    另请参见：
    Authenticator ， Authenticator.getPasswordAuthentication()

    • 构造方法摘要

      构造方法
      Constructor 描述
      PasswordAuthentication​(String userName, char[] password)
      从给定的用户名和密码创建一个新的 PasswordAuthentication对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      char[] getPassword​()
      返回用户密码。
      String getUserName​()
      返回用户名。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PasswordAuthentication

        public PasswordAuthentication​(String userName,
                              char[] password)
        从给定的用户名和密码创建一个新的PasswordAuthentication对象。

        请注意，给定的用户密码在存储在新的PasswordAuthentication对象之前被克隆。

        参数
        userName - 用户名
        password - 用户密码

    • 方法详细信息

      • getUserName

        public String getUserName​()
        返回用户名。
        结果
        用户名

      • getPassword

        public char[] getPassword​()
        返回用户密码。

        请注意，此方法返回对密码的引用。 呼叫者有责任在不再需要密码信息后将其清除。

        结果
        the password
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


PortUnreachableException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class PortUnreachableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.SocketException
            • java.net.PortUnreachableException
  • All Implemented Interfaces:
    Serializable

    public class PortUnreachableException
extends SocketException
    指示在连接的数据报上收到了ICMP端口不可达消息。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      PortUnreachableException​()
      构造一个新的 PortUnreachableException没有详细的消息。
      PortUnreachableException​(String msg)
      构造一个新的 PortUnreachableException与详细信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • PortUnreachableException

        public PortUnreachableException​(String msg)
        构造一个新的 PortUnreachableException与一个详细的消息。
        参数
        msg - 详细信息

      • PortUnreachableException

        public PortUnreachableException​()
        构造一个新的 PortUnreachableException没有详细的消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProtocolException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class ProtocolException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.ProtocolException
  • All Implemented Interfaces:
    Serializable

    public class ProtocolException
extends IOException
    抛出以表示底层协议有错误，如TCP错误。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProtocolException​()
      构造一个新的 ProtocolException ，没有详细的消息。
      ProtocolException​(String message)
      构造一个新的 ProtocolException与指定的详细信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • ProtocolException

        public ProtocolException​(String message)
        构造一个新的 ProtocolException具有指定的详细信息。
        参数
        message - 详细信息。

      • ProtocolException

        public ProtocolException​()
        构造一个新的 ProtocolException没有详细的消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ProtocolFamily (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface ProtocolFamily

  • 所有已知实现类：
    StandardProtocolFamily

    public interface ProtocolFamily
    代表一系列通信协议。
    从以下版本开始：
    1.7

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回协议族的名称。

    • 方法详细信息

      • name

        String name​()
        返回协议族的名称。
        结果
        协议族的名称
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Proxy (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class Proxy

  • java.lang.Object
    • java.net.Proxy

  • public class Proxy
extends Object
    此类表示代理设置，通常是类型（http，socks）和套接字地址。 A Proxy是一个不可变的对象。
    从以下版本开始：
    1.5
    另请参见：
    ProxySelector

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class 描述
      static class  Proxy.Type
      代表代理类型。

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static Proxy NO_PROXY
      代理设置代表一个 DIRECT连接，基本上告诉协议处理程序不使用任何代理。

    • 构造方法摘要

      构造方法
      Constructor 描述
      Proxy​(Proxy.Type type, SocketAddress sa)
      创建一个表示PROXY连接的条目。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      SocketAddress address​()
      返回代理的套接字地址，或 null如果它的直接连接。
      boolean equals​(Object obj)
      将此对象与指定对象进行比较。
      int hashCode​()
      返回此代理的哈希码。
      String toString​()
      构造此代理的字符串表示形式。
      Proxy.Type type​()
      返回代理类型。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NO_PROXY

        public static final Proxy NO_PROXY
        一个代理设置，代表一个DIRECT连接，基本上告诉协议处理程序不使用任何代理。 例如，用于绕过任何其他全局代理设置（如SOCKS）创建套接字：

        Socket s = new Socket(Proxy.NO_PROXY);

    • 构造方法详细信息

      • Proxy

        public Proxy​(Proxy.Type type,
             SocketAddress sa)
        创建一个表示PROXY连接的条目。 某些组合是非法的。 例如，对于类型Http和Socks， 必须提供SocketAddress。

        使用Proxy.NO_PROXY常量来表示直接连接。

        参数
        type - 代理的 Type
        sa - 该代理的 SocketAddress
        异常
        IllegalArgumentException - 当类型和地址不兼容时

    • 方法详细信息

      • type

        public Proxy.Type type​()
        返回代理类型。
        结果
        表示代理类型的类型

      • address

        public SocketAddress address​()
        返回代理的套接字地址，如果是 null则直接连接。
        结果
        一个 SocketAddress代表代理的套接字端点

      • toString

        public String toString​()
        构造此代理的字符串表示形式。 这个String是通过调用类型的toString（）来构造的，并且如果它的类型不是DIRECT则从它的地址连接“@”和toString（）结果。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式。

      • equals

        public final boolean equals​(Object obj)
        将此对象与指定对象进行比较。 结果是true当且仅当参数不是null并且它代表与该对象相同的代理。

        如果两个SocketAddresses和类型相同，则Proxy两个实例表示相同的地址。

        重写：
        equals在 Object
        参数
        obj - 要比较的对象。
        结果
        true如果对象是相同的; 否则为false 。
        另请参见：
        InetSocketAddress.equals(java.lang.Object)

      • hashCode

        public final int hashCode​()
        返回此代理的哈希码。
        重写：
        hashCode在 Object
        结果
        此代理的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • Nested |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Proxy.Type (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.net

Enum Proxy.Type

  • java.lang.Object
    • java.lang.Enum<Proxy.Type>
      • java.net.Proxy.Type
  • All Implemented Interfaces:
    Serializable ， Comparable<Proxy.Type>
    Enclosing class:
    Proxy

    public static enum Proxy.Type
extends Enum<Proxy.Type>
    代表代理类型。
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      DIRECT
      代表一个直接连接，或代表不存在。
      HTTP
      代表HTTP或FTP等高级协议的代理。
      SOCKS
      代表SOCKS（V4或V5）代理。

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static Proxy.Type valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static Proxy.Type[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DIRECT

        public static final Proxy.Type DIRECT
        代表一个直接连接，或代表不存在。

      • HTTP

        public static final Proxy.Type HTTP
        代表HTTP或FTP等高级协议的代理。

      • SOCKS

        public static final Proxy.Type SOCKS
        代表SOCKS（V4或V5）代理。

    • 方法详细信息

      • values

        public static Proxy.Type[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (Proxy.Type c : Proxy.Type.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static Proxy.Type valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - if the argument is null
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


ProxySelector (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class ProxySelector

  • java.lang.Object
    • java.net.ProxySelector

  • public abstract class ProxySelector
extends Object
    选择在连接到URL引用的网络资源时使用的代理服务器（如果有）。 代理选择器是此类的具体子类，并通过调用setDefault方法进行注册。 可以通过调用getDefault方法检索当前注册的代理选择器。

    例如，当注册代理选择器时，URLConnection类的子类应为每个URL请求调用select方法，以便代理选择器可以决定是否应该使用直接或代理的连接。 select方法通过首选的连接方法返回一个集合的迭代器。

    如果连接不能建立到代理（PROXY或SOCKS）服务器，则呼叫者应该调用代理选择器的connectFailed方法来通知代理选择器代理服务器不可用。

    默认代理选择器强制执行与代理设置相关的set of System Properties 。

    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      ProxySelector​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract void connectFailed​(URI uri, SocketAddress sa, IOException ioe)
      被称为表示连接不能建立到代理/袜子服务器。
      static ProxySelector getDefault​()
      获取系统范围的代理选择器。
      static ProxySelector of​(InetSocketAddress proxyAddress)
      返回一个ProxySelector，它为所有HTTP和HTTPS请求使用给定的代理地址。
      abstract List<Proxy> select​(URI uri)
      根据访问资源的协议选择所有适用的代理以及访问资源的目标地址。
      static void setDefault​(ProxySelector ps)
      设置（或取消）系统范围的代理选择器。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ProxySelector

        public ProxySelector​()

    • 方法详细信息

      • getDefault

        public static ProxySelector getDefault​()
        获取系统范围的代理选择器。
        结果
        系统范围 ProxySelector
        异常
        SecurityException - 如果安全管理器已安装，并且它拒绝NetPermission ("getProxySelector")
        从以下版本开始：
        1.5
        另请参见：
        setDefault(ProxySelector)

      • setDefault

        public static void setDefault​(ProxySelector ps)
        设置（或取消）系统范围的代理选择器。 注意：非标准协议处理程序可能会忽略此设置。
        参数
        ps - HTTP代理选择器，或 null取消设置代理选择器。
        异常
        SecurityException - 如果安全管理器已安装并且它已拒绝NetPermission ("setProxySelector")
        从以下版本开始：
        1.5
        另请参见：
        getDefault()

      • select

        public abstract List<Proxy> select​(URI uri)
        根据访问资源的协议选择所有适用的代理以及访问资源的目标地址。 URI的格式定义如下：
        • http连接的http URI
        • https连接https URI
        • socket://host:port
          用于tcp客户端套接字连接
        参数
        uri - 需要连接的URI
        结果
        代理人名单。 列表中的每个元素都是类型Proxy ; 当没有代理可用时，该列表将包含一个表示直接连接的类型为Proxy的元素。
        异常
        IllegalArgumentException - 如果参数为空

      • connectFailed

        public abstract void connectFailed​(URI uri,
                                   SocketAddress sa,
                                   IOException ioe)
        被称为表示连接不能建立到代理/袜子服务器。 该方法的实现可以临时删除代理或重新排序由select(URI)返回的代理序列，使用地址和尝试连接时捕获的IOException。
        参数
        uri - 代理服务器上的 uri URI。
        sa - 代理/ SOCKS服务器的套接字地址
        ioe - 连接失败时抛出的I / O异常。
        异常
        IllegalArgumentException - 如果任一参数为空

      • of

        public static ProxySelector of​(InetSocketAddress proxyAddress)
        返回一个ProxySelector，它为所有HTTP和HTTPS请求使用给定的代理地址。 如果代理是null则禁用代理。
        参数
        proxyAddress - 代理的地址
        结果
        一个ProxySelector
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ResponseCache (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class ResponseCache

  • java.lang.Object
    • java.net.ResponseCache

  • public abstract class ResponseCache
extends Object
    表示URLConnection缓存的实现。 可以通过执行ResponseCache.setDefault（ResponseCache）向系统注册此类的实例，并且系统将调用此对象以便：
    • 将从外部源检索的资源数据存储到高速缓存中
    • 尝试获取可能存储在缓存中的请求资源
    ResponseCache实现决定应该缓存哪些资源，以及应该缓存多长时间。 如果无法从缓存中检索到请求资源，则协议处理程序将从其原始位置获取资源。 URLConnection＃useCaches的设置控制协议是否允许使用缓存的响应。 有关HTTP缓存的更多信息，请参阅RFC 2616: Hypertext Transfer Protocol -- HTTP/1.1
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      ResponseCache​()

    • 方法摘要

      所有方法 静态方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      abstract CacheResponse get​(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
      根据请求的uri，请求方法和请求标头检索缓存的响应。
      static ResponseCache getDefault​()
      获取系统范围的响应缓存。
      abstract CacheRequest put​(URI uri, URLConnection conn)
      协议处理程序在检索到资源后调用此方法，ResponseCache必须决定是否将资源存储在其缓存中。
      static void setDefault​(ResponseCache responseCache)
      设置（或取消）系统级缓存。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ResponseCache

        public ResponseCache​()

    • 方法详细信息

      • getDefault

        public static ResponseCache getDefault​()
        获取系统范围的响应缓存。
        结果
        系统范围 ResponseCache
        异常
        SecurityException - 如果已安装安全管理员，并且它已拒绝NetPermission ("getResponseCache")
        从以下版本开始：
        1.5
        另请参见：
        setDefault(ResponseCache)

      • setDefault

        public static void setDefault​(ResponseCache responseCache)
        设置（或取消）系统级缓存。 注意：非标准procotol处理程序可能会忽略此设置。
        参数
        responseCache - 响应缓存，或 null取消设置缓存。
        异常
        SecurityException - 如果安全管理器已安装，并且它已拒绝NetPermission ("setResponseCache")
        从以下版本开始：
        1.5
        另请参见：
        getDefault()

      • get

        public abstract CacheResponse get​(URI uri,
                                  String rqstMethod,
                                  Map<String,List<String>> rqstHeaders)
                           throws IOException
        根据请求的uri，请求方法和请求标头检索缓存的响应。 通常，该方法在协议处理程序发出请求以获取网络资源之前被调用。 如果返回缓存的响应，则使用该资源。
        参数
        uri - 用于引用所请求的网络资源的 URI
        rqstMethod - 表示请求方法的 String
        rqstHeaders - - 从请求头字段名称映射到表示当前请求头的字段值的列表
        结果
        一个 CacheResponse实例，如果从缓存可用，否则为空
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果任何一个参数为空
        另请参见：
        URLConnection.setUseCaches(boolean) ，
URLConnection.getUseCaches() ，
URLConnection.setDefaultUseCaches(boolean) ，
URLConnection.getDefaultUseCaches()

      • put

        public abstract CacheRequest put​(URI uri,
                                 URLConnection conn)
                          throws IOException
        协议处理程序在检索到资源后调用此方法，ResponseCache必须决定是否将资源存储在其缓存中。 如果要缓存资源，那么put（）必须返回一个CacheRequest对象，该对象包含一个OutputStream，协议处理程序用于将资源写入高速缓存。 如果资源不被缓存，那么put必须返回null。
        参数
        uri - 一个 URI用于引用请求的网络资源
        conn - 用于获取要缓存的响应的URLConnection实例
        结果
        一个用于记录要缓存的响应的CacheRequest 。 空返回表示呼叫者不打算缓存响应。
        异常
        IOException - 如果发生I / O错误
        IllegalArgumentException - 如果任何一个参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SecureCacheResponse (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class SecureCacheResponse

  • java.lang.Object
    • java.net.CacheResponse
      • java.net.SecureCacheResponse

  • public abstract class SecureCacheResponse
extends CacheResponse
    表示最初通过安全手段（例如TLS）检索的缓存响应。
    从以下版本开始：
    1.5

    • 构造方法摘要

      构造方法
      Constructor 描述
      SecureCacheResponse​()

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      abstract String getCipherSuite​()
      返回在检索网络资源的原始连接上使用的加密套件。
      abstract List<Certificate> getLocalCertificateChain​()
      返回在握手检索网络资源的原始连接期间发送到服务器的证书链。
      abstract Principal getLocalPrincipal​()
      返回在检索网络资源的原始连接中握手期间发送到服务器的主体。
      abstract Principal getPeerPrincipal​()
      返回作为在检索网络资源的原始连接期间定义会话的一部分而建立的服务器的主体。
      abstract List<Certificate> getServerCertificateChain​()
      返回服务器的证书链，它是作为在检索网络资源的原始连接中从缓存定义会话的一部分而建立的。

      • Methods inherited from class java.net.CacheResponse

        getBody, getHeaders

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SecureCacheResponse

        public SecureCacheResponse​()

    • 方法详细信息

      • getCipherSuite

        public abstract String getCipherSuite​()
        返回在检索网络资源的原始连接上使用的加密套件。
        结果
        一个表示密码套件的字符串

      • getLocalCertificateChain

        public abstract List<Certificate> getLocalCertificateChain​()
        返回在握手检索网络资源的原始连接期间发送到服务器的证书链。 注意：此方法仅在使用基于证书的密码套件时有用。
        结果
        表示发送到服务器的证书链的不可变证书列表。 如果没有发送证书链，则返回null。
        另请参见：
        getLocalPrincipal()

      • getServerCertificateChain

        public abstract List<Certificate> getServerCertificateChain​()
                                                     throws SSLPeerUnverifiedException
        返回服务器的证书链，它是作为在检索网络资源的原始连接中从缓存定义会话的一部分而建立的。 注意：此方法只能在使用基于证书的密码套件时使用; 与非基于证书的密码套件（如Kerberos）一起使用，将抛出SSLPeerUnverifiedException异常。
        结果
        代表服务器证书链的不可变证书列表。
        异常
        SSLPeerUnverifiedException - 如果对等体未被验证。
        另请参见：
        getPeerPrincipal()

      • getPeerPrincipal

        public abstract Principal getPeerPrincipal​()
                                    throws SSLPeerUnverifiedException
        返回作为在检索网络资源的原始连接期间定义会话的一部分而建立的服务器的主体。
        结果
        服务器的主体。 返回基于X509的密码套件的终端实体认证的X500Principal，以及Kerberos密码套件的KerberosPrincipal。
        异常
        SSLPeerUnverifiedException - 如果对等体未被验证。
        另请参见：
        getServerCertificateChain() ， getLocalPrincipal()

      • getLocalPrincipal

        public abstract Principal getLocalPrincipal​()
        返回在检索网络资源的原始连接中握手期间发送到服务器的主体。
        结果
        委托人发送到服务器。 返回基于X509的密码套件的终端实体证书的X500Principal，Kerberos密码套件的KerberosPrincipal。 如果没有发送主体，则返回null。
        另请参见：
        getLocalCertificateChain() ， getPeerPrincipal()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


ServerSocket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class ServerSocket

  • java.lang.Object
    • java.net.ServerSocket
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    SSLServerSocket

    public class ServerSocket
extends Object
implements Closeable
    这个类实现了服务器套接字。 服务器套接字等待通过网络进入的请求。 它根据该请求执行一些操作，然后可能将结果返回给请求者。

    服务器套接字的实际工作由SocketImpl类的实例执行。 应用程序可以更改创建套接字实现的套接字工厂，以配置自己创建适合本地防火墙的套接字。

    从以下版本开始：
    1.0
    另请参见：
    SocketImpl ， setSocketFactory(java.net.SocketImplFactory) ， ServerSocketChannel

    • 构造方法摘要

      构造方法
      Constructor 描述
      ServerSocket​()
      创建未绑定的服务器套接字。
      ServerSocket​(int port)
      创建绑定到指定端口的服务器套接字。
      ServerSocket​(int port, int backlog)
      创建服务器套接字并将其绑定到指定的本地端口号，并指定了积压。
      ServerSocket​(int port, int backlog, InetAddress bindAddr)
      创建一个具有指定端口的服务器，侦听backlog和本地IP地址绑定。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      Socket accept​()
      侦听要连接到此套接字并接受它。
      void bind​(SocketAddress endpoint)
      将 ServerSocket绑定到特定地址（IP地址和端口号）。
      void bind​(SocketAddress endpoint, int backlog)
      将 ServerSocket绑定到特定地址（IP地址和端口号）。
      void close​()
      关闭此套接字。
      ServerSocketChannel getChannel​()
      返回与此套接字相关联的唯一的ServerSocketChannel对象（如果有）。
      InetAddress getInetAddress​()
      返回此服务器套接字的本地地址。
      int getLocalPort​()
      返回此套接字正在侦听的端口号。
      SocketAddress getLocalSocketAddress​()
      返回此套接字绑定到的端点的地址。
      <T> T getOption​(SocketOption<T> name)
      返回套接字选项的值。
      int getReceiveBufferSize​()
      获取此 ServerSocket的 SO_RCVBUF选项的值，即将用于从该 ServerSocket接受的套接字的缓冲区大小。
      boolean getReuseAddress​()
      测试是否启用了 SO_REUSEADDR 。
      int getSoTimeout​()
      检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。
      protected void implAccept​(Socket s)
      ServerSocket的子类使用这个方法来覆盖accept（）来返回自己的套接字子类。
      boolean isBound​()
      返回ServerSocket的绑定状态。
      boolean isClosed​()
      返回ServerSocket的关闭状态。
      <T> ServerSocket setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      void setPerformancePreferences​(int connectionTime, int latency, int bandwidth)
      设置此ServerSocket的性能首选项。
      void setReceiveBufferSize​(int size)
      设置为默认建议值 SO_RCVBUF选择从该接受的套接字 ServerSocket 。
      void setReuseAddress​(boolean on)
      启用/禁用 SO_REUSEADDR套接字选项。
      static void setSocketFactory​(SocketImplFactory fac)
      设置应用程序的服务器套接字实现工厂。
      void setSoTimeout​(int timeout)
      启用/禁用 SO_TIMEOUT与指定的超时，以毫秒为单位。
      Set<SocketOption<?>> supportedOptions​()
      返回此服务器套接字支持的一组套接字选项。
      String toString​()
      将此套接字的实现地址和实现端口作为 String 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ServerSocket

        public ServerSocket​()
             throws IOException
        创建未绑定的服务器套接字。
        异常
        IOException - 打开插槽时出现IO错误。

      • ServerSocket

        public ServerSocket​(int port)
             throws IOException
        创建绑定到指定端口的服务器套接字。 端口号为0意味着端口号被自动分配，通常是从短暂的端口范围。 这个端口号可以通过调用getLocalPort来检索。

        输入连接指示（连接请求）的最大队列长度设置为50 。 如果连接指示在队列已满时到达，则连接被拒绝。

        如果应用程序指定了服务器套接字工厂，则会调用该工厂的createSocketImpl方法来创建实际的套接字实现。 否则，将创建一个“普通”套接字。

        如果有安全管理器， checkListen port参数作为参数调用其checkListen方法，以确保允许操作。 这可能会导致SecurityException。

        参数
        port - 端口号，或 0使用自动分配的端口号。
        异常
        IOException - 如果打开插座时发生I / O错误。
        SecurityException - 如果安全管理器存在，并且其 checkListen方法不允许操作。
        IllegalArgumentException - 如果端口参数超出了在0到65535之间的有效端口值的指定范围（包括0和65535之间）。
        另请参见：
        SocketImpl ， SocketImplFactory.createSocketImpl() ， setSocketFactory(java.net.SocketImplFactory) ， SecurityManager.checkListen(int)

      • ServerSocket

        public ServerSocket​(int port,
                    int backlog)
             throws IOException
        创建服务器套接字并将其绑定到指定的本地端口号，并指定了积压。 端口号为0意味着端口号被自动分配，通常是从短暂的端口范围。 这个端口号可以通过调用getLocalPort来检索。

        传入连接指示（连接请求）的最大队列长度设置为backlog参数。 如果连接指示在队列已满时到达，则连接被拒绝。

        如果应用程序指定了服务器套接字工厂，则会调用该工厂的createSocketImpl方法来创建实际的套接字实现。 否则，将创建一个“普通”套接字。

        如果有安全管理器，则使用port参数作为参数来调用其checkListen方法，以确保允许操作。 这可能会导致SecurityException。 backlog参数是套接字上请求的最大挂起连接数。 其确切语义是实现具体的。 特别地，实现可以施加最大长度，或者可以选择忽略参数altogther。 所提供的价值应大于0 。 如果小于或等于0 ，则将使用实现特定的默认值。

        参数
        port - 端口号，或 0使用自动分配的端口号。
        backlog - 请求进入连接队列的最大长度。
        异常
        IOException - 打开插槽时是否发生I / O错误。
        SecurityException - 如果安全管理器存在，并且其 checkListen方法不允许操作。
        IllegalArgumentException - 如果端口参数超出了指定的有效端口值范围（介于0到65535之间）。
        另请参见：
        SocketImpl ， SocketImplFactory.createSocketImpl() ， setSocketFactory(java.net.SocketImplFactory) ， SecurityManager.checkListen(int)

      • ServerSocket

        public ServerSocket​(int port,
                    int backlog,
                    InetAddress bindAddr)
             throws IOException
        创建一个具有指定端口的服务器，侦听backlog和本地IP地址绑定。 bindAddr参数可以在多宿主主机上用于ServerSocket，该主机将只接受对其地址之一的连接请求。 如果bindAddr为null，它将默认接受任何/所有本地地址上的连接。 端口必须在0和65535之间，包括端点。 端口号为0意味着端口号被自动分配，通常是从短暂的端口范围。 然后可以通过调用getLocalPort检索该端口号。

        如果有安全管理器，则该方法调用其checkListen方法，其参数为port ，以确保操作是允许的。 这可能会导致SecurityException。 backlog参数是套接字上请求的最大挂起连接数。 其确切语义是实现具体的。 特别地，实现可以施加最大长度，或者可以选择忽略参数altogther。 提供的值应大于0 。 如果小于或等于0 ，则将使用实现特定的默认值。

        参数
        port - 端口号，或 0使用自动分配的端口号。
        backlog - 请求进入连接队列的最大长度。
        bindAddr - 服务器将绑定到的本地InetAddress
        异常
        SecurityException - 如果存在安全管理员，并且其 checkListen方法不允许操作。
        IOException - 如果打开套接字时发生I / O错误。
        IllegalArgumentException - 如果端口参数超出了在0到65535之间的有效端口值的指定范围（包括0和65535之间）。
        从以下版本开始：
        1.1
        另请参见：
        SocketOptions ， SocketImpl ， SecurityManager.checkListen(int)

    • 方法详细信息

      • bind

        public void bind​(SocketAddress endpoint)
          throws IOException
        将ServerSocket绑定到特定地址（IP地址和端口号）。

        如果地址为null ，则系统将拾取临时端口和有效的本地地址来绑定套接字。

        参数
        endpoint - 绑定到的IP地址和端口号。
        异常
        IOException - 如果绑定操作失败，或者套接字已经绑定。
        SecurityException - 如果一个 SecurityManager存在，其 checkListen方法不允许操作。
        IllegalArgumentException - 如果端点是此套接字不支持的SocketAddress子类
        从以下版本开始：
        1.4

      • bind

        public void bind​(SocketAddress endpoint,
                 int backlog)
          throws IOException
        将ServerSocket绑定到特定地址（IP地址和端口号）。

        如果地址为null ，则系统将接收临时端口和有效的本地地址来绑定套接字。

        backlog参数是套接字上请求的最大挂起连接数。 其确切语义是实现具体的。 特别地，实现可以施加最大长度，或者可以选择忽略参数altogther。 提供的价值应大于0 。 如果小于或等于0 ，则将使用实现特定的默认值。

        参数
        endpoint - 绑定到的IP地址和端口号。
        backlog - 请求进入连接队列的最大长度。
        异常
        IOException - 如果绑定操作失败，或者套接字已经绑定。
        SecurityException - 如果一个 SecurityManager存在，其 checkListen方法不允许操作。
        IllegalArgumentException - 如果端点是此套接字不支持的SocketAddress子类
        从以下版本开始：
        1.4

      • getInetAddress

        public InetAddress getInetAddress​()
        返回此服务器套接字的本地地址。

        如果套接字被绑定在closed之前，则该方法将在套接字关闭后继续返回本地地址。

        如果有一个安全管理器集，它的checkConnect方法被调用本地地址和-1作为参数来查看是否允许该操作。 如果不允许操作，则返回loopback地址。

        结果
        该套接字绑定到的地址，如果安全管理器被拒绝的环回地址，或者如果套接字未绑定， null 。
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • getLocalPort

        public int getLocalPort​()
        返回此套接字正在侦听的端口号。

        如果套接字被绑定在closed之前，则该方法将在套接字关闭后继续返回端口号。

        结果
        该套接字正在侦听的端口号，如果套接字尚未绑定，则为-1。

      • getLocalSocketAddress

        public SocketAddress getLocalSocketAddress​()
        返回此套接字绑定到的端点的地址。

        如果套接字被绑定在closed之前，则该方法将在套接字关闭后继续返回端点的地址。

        如果有一个安全管理器集，其checkConnect方法将以本地地址和-1作为参数来调用，以查看是否允许该操作。 如果不允许操作，则SocketAddress表示loopback地址的SocketAddress和该套接字所绑定的本地端口。

        结果
        一个 SocketAddress表示此套接字的本地端点，或 SocketAddress表示如果安全管理器拒绝的环回地址，或 null如果套接字尚未绑定）。
        从以下版本开始：
        1.4
        另请参见：
        getInetAddress() ， getLocalPort() ， bind(SocketAddress) ， SecurityManager.checkConnect(java.lang.String, int)

      • accept

        public Socket accept​()
              throws IOException
        侦听要连接到此套接字并接受它。 该方法将阻塞直到建立连接。

        将创建一个新的套接字s ，如果有安全管理器，则使用s.getInetAddress().getHostAddress()和s.getPort()作为其参数调用安全管理器的checkAccept方法，以确保允许操作。 这可能会导致SecurityException。

        结果
        新的Socket
        异常
        IOException - 如果在等待连接时发生I / O错误。
        SecurityException - 如果存在安全管理员，并且其 checkAccept方法不允许该操作。
        SocketTimeoutException - 如果先前使用setSoTimeout设置了超时并且达到超时。
        IllegalBlockingModeException - 如果此套接字具有关联的通道，则该通道处于非阻塞模式，并且没有准备接受的连接
        另请参见：
        SecurityManager.checkAccept(java.lang.String, int)

      • implAccept

        protected final void implAccept​(Socket s)
                         throws IOException
        ServerSocket的子类使用这个方法来覆盖accept（）来返回自己的套接字子类。 所以一个FooServerSocket通常会把这个方法变成一个空的 FooSocket。 从implAccept返回FooSocket将连接到客户端。
        参数
        s - 套接字
        异常
        IllegalBlockingModeException - 如果此套接字具有相关通道，并且通道处于非阻塞模式
        IOException - 如果在等待连接时发生I / O错误。
        从以下版本开始：
        1.1

      • close

        public void close​()
           throws IOException
        关闭此套接字。 任何当前在accept()中被阻止的线程都会抛出一个SocketException 。

        如果此套接字具有关联的通道，则通道也将关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果关闭套接字时发生I / O错误。

      • getChannel

        public ServerSocketChannel getChannel​()
        返回与此套接字相关联的唯一的ServerSocketChannel对象（如果有）。

        如果通道本身是通过ServerSocketChannel.open方法创建的，并且只有通道本身才能使用服务器套接字。

        结果
        与此套接字关联的服务器套接字通道，如果未为通道创建此套接字， null
        从以下版本开始：
        1.4

      • isBound

        public boolean isBound​()
        返回ServerSocket的绑定状态。
        结果
        如果ServerSocket成功绑定到一个地址，则为true
        从以下版本开始：
        1.4

      • isClosed

        public boolean isClosed​()
        返回ServerSocket的关闭状态。
        结果
        如果套接字已关闭，则为true
        从以下版本开始：
        1.4

      • setSoTimeout

        public void setSoTimeout​(int timeout)
                  throws SocketException
        使用指定的超时时间启用/禁用SO_TIMEOUT （以毫秒为单位）。 使用此选项设置为非零超时，对此ServerSocket的accept（）的调用将仅阻止此时间。 如果超时超时，则会引发java.net.SocketTimeoutException ，尽管ServerSocket仍然有效。 必须先启用该选项才能进入阻止操作才能生效。 超时必须是> 0 。 超时为零被解释为无限超时。
        参数
        timeout - 指定的超时，以毫秒为单位
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.1
        另请参见：
        getSoTimeout()

      • getSoTimeout

        public int getSoTimeout​()
                 throws IOException
        检索SO_TIMEOUT的设置。 0返回意味着该选项被禁用（即无限超时）。
        结果
        SO_TIMEOUT的价值
        异常
        IOException - 如果发生I / O错误
        从以下版本开始：
        1.1
        另请参见：
        setSoTimeout(int)

      • setReuseAddress

        public void setReuseAddress​(boolean on)
                     throws SocketException
        启用/禁用SO_REUSEADDR套接字选项。

        当TCP连接关闭时，连接可能在连接关闭后一段时间内保持在超时状态（通常称为TIME_WAIT状态或2MSL等待状态）。 对于使用众所周知的套接字地址或端口的应用程序，如果在涉及插座地址或端口的超时状态中存在连接，可能无法将套接字绑定到所需的SocketAddress 。

        在使用bind(SocketAddress)绑定套接字之前启用SO_REUSEADDR允许套接字绑定，即使以前的连接处于超时状态。

        当ServerSocket创建的初始设定SO_REUSEADDR没有定义。 应用程序可以使用getReuseAddress()确定的初始设置SO_REUSEADDR 。

        套接字绑定后启用或禁用SO_REUSEADDR时的行为（参见isBound() ）未定义。

        参数
        on - 是否启用或禁用套接字选项
        异常
        SocketException - 如果出现错误，启用或禁用 SO_REUSEADDR套接字选项，或者套接字关闭。
        从以下版本开始：
        1.4
        另请参见：
        getReuseAddress() ， bind(SocketAddress) ， isBound() ， isClosed()

      • getReuseAddress

        public boolean getReuseAddress​()
                        throws SocketException
        测试是否启用了 SO_REUSEADDR 。
        结果
        一个 boolean表示是否启用了 SO_REUSEADDR 。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.4
        另请参见：
        setReuseAddress(boolean)

      • toString

        public String toString​()
        将此套接字的实现地址和实现端口作为String 。

        如果有一个安全管理器集，其checkConnect方法将以本地地址和-1作为参数来调用，以查看是否允许该操作。 如果不允许的操作， InetAddress表示loopback个地址返回作为实现地址。

        重写：
        toString在 Object
        结果
        这个套接字的字符串表示形式。

      • setSocketFactory

        public static void setSocketFactory​(SocketImplFactory fac)
                             throws IOException
        设置应用程序的服务器套接字实现工厂。 工厂只能指定一次。

        当应用程序创建一个新的服务器套接字时，将调用套接字实现工厂的createSocketImpl方法来创建实际的套接字实现。

        通过null的方法是无操作，除非工厂已经设置。

        如果有安全管理员，则该方法首先调用安全管理员的checkSetFactory方法来确保操作是允许的。 这可能会导致SecurityException。

        参数
        fac - 所需工厂。
        异常
        IOException - 设置插座工厂时是否发生I / O错误。
        SocketException - 如果工厂已经定义。
        SecurityException - 如果安全管理器存在，并且其 checkSetFactory方法不允许操作。
        另请参见：
        SocketImplFactory.createSocketImpl() ， SecurityManager.checkSetFactory()

      • setReceiveBufferSize

        public void setReceiveBufferSize​(int size)
                          throws SocketException
        设置为默认建议值SO_RCVBUF选择从该接受的套接字ServerSocket 。 在接受的套接字中实际设置的值必须通过调用确定Socket.getReceiveBufferSize()插座被退回后accept() 。

        SO_RCVBUF的值用于设置内部套接字接收缓冲区的大小，并设置通告给远程对等体的TCP接收窗口的大小。

        可以通过调用Socket.setReceiveBufferSize(int)随后更改该值。 然而，如果应用程序希望允许大于64K字节的接收窗口，如RFC1323定义的那样，则在ServerSocket绑定到本地地址之前必须设置建议值。 这意味着必须使用无参数构造函数创建ServerSocket，那么必须调用setReceiveBufferSize（），最后调用bind（）将ServerSocket绑定到一个地址。

        否则不会导致错误，并且缓冲区大小可能设置为请求的值，但从该ServerSocket接受的套接字中的TCP接收窗口将不会大于64K字节。

        参数
        size - 设置接收缓冲区大小的大小。 该值必须大于0。
        异常
        SocketException - 如果底层协议有错误，例如TCP错误。
        IllegalArgumentException - 如果值为0或为负数。
        从以下版本开始：
        1.4
        另请参见：
        getReceiveBufferSize()

      • getReceiveBufferSize

        public int getReceiveBufferSize​()
                         throws SocketException
        获取此ServerSocket的SO_RCVBUF选项的值，即将用于从该ServerSocket接受的套接字的建议缓冲区大小。

        请注意，在接受的套接字中实际设置的值是通过调用Socket.getReceiveBufferSize()确定的。

        结果
        该值为 SO_RCVBUF的这个 Socket选项。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.4
        另请参见：
        setReceiveBufferSize(int)

      • setPerformancePreferences

        public void setPerformancePreferences​(int connectionTime,
                                      int latency,
                                      int bandwidth)
        设置此ServerSocket的性能首选项。

        套接字默认使用TCP / IP协议。 一些实现可以提供具有与TCP / IP不同的性能特征的替代协议。 该方法允许应用程序表达自己的偏好，以便在实现从可用协议中选择时应如何进行这些权衡。

        性能偏好由三个整数描述，其值表示短连接时间，低延迟和高带宽的相对重要性。 整数的绝对值是无关紧要的; 为了选择协议，简单地比较值，较大的值表示较强的偏好。 例如，如果应用程序优先考虑低延迟和高带宽的短连接时间，那么它可以使用值为(1, 0, 0)来调用此方法。 如果应用程序优先于低延迟的高带宽，并且在短的连接时间以上的低延迟，则可以使用值(0, 1, 2)调用此方法。

        在此套接字绑定后调用此方法将不起作用。 这意味着为了使用此功能，需要使用无参数构造函数创建套接字。

        参数
        connectionTime - 表示短连接时间的相对重要性的 int
        latency - 表示低延迟的相对重要性的 int
        bandwidth - 表示高带宽的相对重要性的 int
        从以下版本开始：
        1.5

      • setOption

        public <T> ServerSocket setOption​(SocketOption<T> name,
                                  T value)
                           throws IOException
        设置套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 某些选项的值为null可能有效。
        结果
        这个ServerSocket
        异常
        UnsupportedOperationException - 如果服务器套接字不支持该选项。
        IllegalArgumentException - 如果该值对该选项无效。
        IOException - 如果发生I / O错误，或者套接字关闭。
        NullPointerException - 如果名字是 null
        SecurityException - 如果设置了安全管理器，并且套接字选项是否需要安全许可，并且主叫方没有必要的权限。 StandardSocketOptions不需要任何安全许可。
        从以下版本开始：
        9

      • getOption

        public <T> T getOption​(SocketOption<T> name)
                throws IOException
        返回套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        套接字选项的值。
        异常
        UnsupportedOperationException - 如果服务器套接字不支持该选项。
        IOException - 如果发生I / O错误，或者套接字关闭。
        NullPointerException - 如果名字是 null
        SecurityException - 如果设置了安全管理器，并且套接字选项是否需要安全许可，并且主叫方没有必要的权限。 StandardSocketOptions不需要任何安全许可。
        从以下版本开始：
        9

      • supportedOptions

        public Set<SocketOption<?>> supportedOptions​()
        返回此服务器套接字支持的一组套接字选项。 即使在套接字关闭后，此方法也将继续返回该选项。
        结果
        该套接字支持的一组套接字选项。 如果套接字的SocketImpl无法创建，则此集合可能为空。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


Socket (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class Socket

  • java.lang.Object
    • java.net.Socket
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    SSLSocket

    public class Socket
extends Object
implements Closeable
    该类实现客户端套接字（也称为“套接字”）。 套接字是两台机器之间通讯的端点。

    套接字的实际工作由SocketImpl类的实例执行。 应用程序通过更改创建套接字实现的套接字工厂，可以配置自己创建适合本地防火墙的套接字。

    从以下版本开始：
    1.0
    另请参见：
    setSocketImplFactory(java.net.SocketImplFactory) ， SocketImpl ， SocketChannel

    • 构造方法摘要

      构造方法
      Modifier Constructor 描述
        Socket​()
      创建一个未连接的套接字，并使用系统默认类型的SocketImpl。
        Socket​(String host, int port)
      创建流套接字并将其连接到指定主机上的指定端口号。
        Socket​(String host, int port, boolean stream)
      已过时。
      使用DatagramSocket代替UDP传输。
        Socket​(String host, int port, InetAddress localAddr, int localPort)
      创建套接字并将其连接到指定远程端口上的指定远程主机。
        Socket​(InetAddress address, int port)
      创建流套接字并将其连接到指定IP地址的指定端口号。
        Socket​(InetAddress host, int port, boolean stream)
      已过时。
      使用DatagramSocket代替UDP传输。
        Socket​(InetAddress address, int port, InetAddress localAddr, int localPort)
      创建套接字并将其连接到指定的远程端口上指定的远程地址。
        Socket​(Proxy proxy)
      创建一个未连接的套接字，指定应该使用的代理类型（如果有的话），无论其他任何设置如何。
      protected Socket​(SocketImpl impl)
      使用用户指定的SocketImpl创建一个未连接的Socket。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      void bind​(SocketAddress bindpoint)
      将套接字绑定到本地地址。
      void close​()
      关闭此套接字。
      void connect​(SocketAddress endpoint)
      将此套接字连接到服务器。
      void connect​(SocketAddress endpoint, int timeout)
      将此套接字连接到具有指定超时值的服务器。
      SocketChannel getChannel​()
      返回与此套接字相关联的唯一的SocketChannel对象（如果有）。
      InetAddress getInetAddress​()
      返回套接字所连接的地址。
      InputStream getInputStream​()
      返回此套接字的输入流。
      boolean getKeepAlive​()
      测试是否启用了 SO_KEEPALIVE 。
      InetAddress getLocalAddress​()
      获取套接字所绑定的本地地址。
      int getLocalPort​()
      返回此套接字绑定到的本地端口号。
      SocketAddress getLocalSocketAddress​()
      返回此套接字绑定到的端点的地址。
      boolean getOOBInline​()
      测试是否启用了 SO_OOBINLINE 。
      <T> T getOption​(SocketOption<T> name)
      返回套接字选项的值。
      OutputStream getOutputStream​()
      返回此套接字的输出流。
      int getPort​()
      返回此套接字连接到的远程端口号。
      int getReceiveBufferSize​()
      获取此 Socket的 SO_RCVBUF选项的值，即该平台在此 Socket上输入的缓冲区大小。
      SocketAddress getRemoteSocketAddress​()
      返回此套接字连接到的端点的地址，如果未连接，则 null 。
      boolean getReuseAddress​()
      测试是否启用了 SO_REUSEADDR 。
      int getSendBufferSize​()
      获取此 Socket的 SO_SNDBUF选项的值，即平台在此 Socket上输出使用的缓冲区大小。
      int getSoLinger​()
      退货设置为 SO_LINGER 。
      int getSoTimeout​()
      退货设置为SO_TIMEOUT 。 0返回意味着该选项被禁用（即无限超时）。
      boolean getTcpNoDelay​()
      测试是否启用了 TCP_NODELAY 。
      int getTrafficClass​()
      在从此Socket发送的数据包的IP头中获取流量类或服务类型
      boolean isBound​()
      返回套接字的绑定状态。
      boolean isClosed​()
      返回套接字的关闭状态。
      boolean isConnected​()
      返回套接字的连接状态。
      boolean isInputShutdown​()
      返回套接字连接的一半是否关闭。
      boolean isOutputShutdown​()
      返回套接字连接的写半是否关闭。
      void sendUrgentData​(int data)
      在套接字上发送一个字节的紧急数据。
      void setKeepAlive​(boolean on)
      启用/禁用 SO_KEEPALIVE 。
      void setOOBInline​(boolean on)
      启用/禁用 SO_OOBINLINE （接收TCP紧急数据）默认情况下，此选项被禁用，并且在套接字上接收的TCP紧急数据被静默地丢弃。
      <T> Socket setOption​(SocketOption<T> name, T value)
      设置套接字选项的值。
      void setPerformancePreferences​(int connectionTime, int latency, int bandwidth)
      设置此套接字的性能首选项。
      void setReceiveBufferSize​(int size)
      设置 SO_RCVBUF选项，此规定值 Socket 。
      void setReuseAddress​(boolean on)
      启用/禁用 SO_REUSEADDR套接字选项。
      void setSendBufferSize​(int size)
      设置 SO_SNDBUF选项，此规定值 Socket 。
      static void setSocketImplFactory​(SocketImplFactory fac)
      设置应用程序的客户端套接字实现工厂。
      void setSoLinger​(boolean on, int linger)
      启用/禁用 SO_LINGER具有指定的逗留时间（以秒为单位）。
      void setSoTimeout​(int timeout)
      启用/禁用 SO_TIMEOUT与指定的超时，以毫秒为单位。
      void setTcpNoDelay​(boolean on)
      启用/禁用 TCP_NODELAY （禁用/启用Nagle的算法）。
      void setTrafficClass​(int tc)
      在从此Socket发送的数据包的IP头中设置流量类或服务类型字节。
      void shutdownInput​()
      将此套接字的输入流放置在“流的末尾”。
      void shutdownOutput​()
      禁用此套接字的输出流。
      Set<SocketOption<?>> supportedOptions​()
      返回此套接字支持的一组套接字选项。
      String toString​()
      将此套接字转换为 String 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Socket

        public Socket​()
        创建一个未连接的套接字，并使用系统默认类型的SocketImpl。
        从以下版本开始：
        1.1

      • Socket

        public Socket​(Proxy proxy)
        创建一个未连接的套接字，指定应该使用的代理类型（如果有的话），无论其他任何设置如何。

        如果有安全管理器，则使用代理主机地址和端口号作为参数调用其checkConnect方法。 这可能会导致SecurityException。

        例子：

        • Socket s = new Socket(Proxy.NO_PROXY);将创建一个忽略任何其他代理配置的普通套接字。
        • Socket s = new Socket(new Proxy(Proxy.Type.SOCKS, new InetSocketAddress("socks.mydom.com", 1080)));将创建一个通过指定的SOCKS代理服务器连接的套接字。
        参数
        proxy - 一个Proxy对象，指定应该使用什么样的代理。
        异常
        IllegalArgumentException - 如果代理是无效的类型或 null 。
        SecurityException - 如果存在安全管理员，并且拒绝连接到代理的权限。
        从以下版本开始：
        1.5
        另请参见：
        ProxySelector ， Proxy

      • Socket

        protected Socket​(SocketImpl impl)
          throws SocketException
        使用用户指定的SocketImpl创建一个未连接的Socket。
        参数
        impl - 子类希望在Socket上使用的 SocketImpl的实例。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.1

      • Socket

        public Socket​(String host,
              int port)
       throws UnknownHostException,
              IOException
        创建流套接字并将其连接到指定主机上的指定端口号。

        如果指定的主机是null ，则相当于指定地址为InetAddress.getByName (null) 。 换句话说，它相当于指定回送接口的地址。

        如果应用程序指定了服务器套接字工厂，则会调用该工厂的createSocketImpl方法来创建实际的套接字实现。 否则，将创建一个“普通”套接字。

        如果有一个安全管理器，它的checkConnect方法被调用主机地址和port作为其参数。 这可能会导致SecurityException。

        参数
        host - 主机名，或 null的环回地址。
        port - 端口号。
        异常
        UnknownHostException - 如果无法确定主机的IP地址。
        IOException - 如果在创建套接字时发生I / O错误。
        SecurityException - 如果存在安全管理员，并且其 checkConnect方法不允许操作。
        IllegalArgumentException - 如果端口参数超出指定的有效端口值范围（介于0和65535之间），包括0和65535之间。
        另请参见：
        setSocketImplFactory(java.net.SocketImplFactory) ， SocketImpl ， SocketImplFactory.createSocketImpl() ， SecurityManager.checkConnect(java.lang.String, int)

      • Socket

        public Socket​(InetAddress address,
              int port)
       throws IOException
        创建流套接字并将其连接到指定IP地址的指定端口号。

        如果应用程序指定了套接字工厂，则会调用该工厂的createSocketImpl方法来创建实际的套接字实现。 否则，将创建一个“普通”套接字。

        如果有一个安全管理器，它的checkConnect方法被调用主机地址和port作为其参数。 这可能会导致SecurityException。

        参数
        address - IP地址。
        port - 端口号。
        异常
        IOException - 如果在创建套接字时发生I / O错误。
        SecurityException - 如果安全管理器存在，并且其 checkConnect方法不允许操作。
        IllegalArgumentException - 如果端口参数超出了指定的有效端口值范围（介于0到65535之间）。
        NullPointerException - 如果 address为空。
        另请参见：
        setSocketImplFactory(java.net.SocketImplFactory) ， SocketImpl ， SocketImplFactory.createSocketImpl() ， SecurityManager.checkConnect(java.lang.String, int)

      • Socket

        public Socket​(String host,
              int port,
              InetAddress localAddr,
              int localPort)
       throws IOException
        创建套接字并将其连接到指定远程端口上的指定远程主机。 Socket还将bind（）绑定到本地提供的地址和端口。

        如果指定的主机是null ，则相当于指定地址为InetAddress.getByName (null) 。 换句话说，它相当于指定回送接口的地址。

        本地端口号码为zero ，系统将在bind操作中接收一个空闲端口。

        如果有一个安全管理器，它的checkConnect方法被调用主机地址和port作为其参数。 这可能会导致SecurityException。

        参数
        host - 远程主机的名称，或 null的环回地址。
        port - 远程端口
        localAddr -本地地址的套接字绑定到，或 null为 anyLocal地址。
        localPort - 套接字绑定的本地端口，或 zero用于系统选择的自由端口。
        异常
        IOException - 如果在创建套接字时发生I / O错误。
        SecurityException - 如果安全管理器存在，并且其 checkConnect方法不允许连接到目标，或者其 checkListen方法不允许绑定到本地端口。
        IllegalArgumentException - 如果端口参数或localPort参数超出了介于0和65535之间的有效端口值的指定范围（包括0和65535）。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • Socket

        public Socket​(InetAddress address,
              int port,
              InetAddress localAddr,
              int localPort)
       throws IOException
        创建套接字并将其连接到指定的远程端口上指定的远程地址。 Socket还将bind（）绑定到本地提供的地址和端口。

        如果指定的本地地址为null ，则相当于将该地址指定为AnyLocal地址（请参阅InetAddress.isAnyLocalAddress () ）。

        本地端口号码为zero ，系统将在bind操作中选择一个空闲端口。

        如果有一个安全管理器，它的checkConnect方法被调用主机地址和port作为其参数。 这可能会导致SecurityException。

        参数
        address - 远程地址
        port - 远程端口
        localAddr -本地地址的套接字绑定到，或 null为 anyLocal地址。
        localPort - 套接字绑定的本地端口或系统选择的自由端口的 zero 。
        异常
        IOException - 如果在创建套接字时发生I / O错误。
        SecurityException - 如果存在安全管理员，并且其 checkConnect方法不允许连接到目标，或者其 checkListen方法不允许绑定到本地端口。
        IllegalArgumentException - 如果端口参数或localPort参数超出了介于0和65535之间的有效端口值的指定范围（包括0和65535之间）。
        NullPointerException - 如果 address为空。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • Socket

        @Deprecated
public Socket​(String host,
              int port,
              boolean stream)
       throws IOException
        已过时。 使用DatagramSocket代替UDP传输。
        创建流套接字并将其连接到指定主机上的指定端口号。

        如果指定的主机是null ，则相当于指定地址为InetAddress.getByName (null) 。 换句话说，它相当于指定回送接口的地址。

        如果流参数为true ，则会创建一个流套接字。 如果流参数为false ，则会创建一个数据报套接字。

        如果应用程序指定了服务器套接字工厂，则会调用该工厂的createSocketImpl方法来创建实际的套接字实现。 否则，将创建一个“普通”套接字。

        如果有一个安全管理器，它的checkConnect方法被调用主机地址和port作为参数。 这可能会导致SecurityException。

        如果使用UDP套接字，TCP / IP相关套接字选项将不适用。

        参数
        host - 主机名，或 null的环回地址。
        port - 端口号。
        stream - 表示这是流套接字还是数据报套接字的 boolean 。
        异常
        IOException - 如果在创建套接字时发生I / O错误。
        SecurityException - 如果存在安全管理员，并且其 checkConnect方法不允许操作。
        IllegalArgumentException - 如果端口参数超出了介于0和65535之间的有效端口值的指定范围（包括0和65535之间）。
        另请参见：
        setSocketImplFactory(java.net.SocketImplFactory) ， SocketImpl ， SocketImplFactory.createSocketImpl() ， SecurityManager.checkConnect(java.lang.String, int)

      • Socket

        @Deprecated
public Socket​(InetAddress host,
              int port,
              boolean stream)
       throws IOException
        已过时。 使用DatagramSocket代替UDP传输。
        创建套接字并将其连接到指定IP地址的指定端口号。

        如果流参数为true ，则会创建一个流套接字。 如果stream参数是false ，它将创建一个数据报套接字。

        如果应用程序指定了服务器套接字工厂，则会调用该工厂的createSocketImpl方法来创建实际的套接字实现。 否则，将创建一个“普通”套接字。

        如果有安全管理员，则其checkConnect方法以host.getHostAddress()和port作为参数。 这可能会导致SecurityException。

        如果使用UDP套接字，TCP / IP相关套接字选项将不适用。

        参数
        host - IP地址。
        port - 端口号。
        stream - 如果是true ，创建一个流套接字; 否则，创建一个数据报套接字。
        异常
        IOException - 创建套接字时是否发生I / O错误。
        SecurityException - 如果存在安全管理员，并且其 checkConnect方法不允许操作。
        IllegalArgumentException - 如果端口参数超出了介于0和65535之间的有效端口值的指定范围（包括0和65535之间）。
        NullPointerException - 如果 host为空。
        另请参见：
        setSocketImplFactory(java.net.SocketImplFactory) ， SocketImpl ， SocketImplFactory.createSocketImpl() ， SecurityManager.checkConnect(java.lang.String, int)

    • 方法详细信息

      • connect

        public void connect​(SocketAddress endpoint)
             throws IOException
        将此套接字连接到服务器。
        参数
        endpoint - SocketAddress
        异常
        IOException - 如果在连接期间发生错误
        IllegalBlockingModeException - 如果此套接字具有关联的通道，并且通道处于非阻塞模式
        IllegalArgumentException - 如果端点为空或是此套接字不支持的SocketAddress子类
        从以下版本开始：
        1.4

      • connect

        public void connect​(SocketAddress endpoint,
                    int timeout)
             throws IOException
        将此套接字连接到具有指定超时值的服务器。 超时为零被解释为无限超时。 然后，连接将阻塞，直到建立或发生错误。
        参数
        endpoint - SocketAddress
        timeout - 以毫秒为单位的超时值。
        异常
        IOException - 如果在连接期间发生错误
        SocketTimeoutException - 如果超时连接前超时
        IllegalBlockingModeException - 如果此套接字具有关联的通道，并且通道处于非阻塞模式
        IllegalArgumentException - 如果端点为空或是此套接字不支持的SocketAddress子类
        从以下版本开始：
        1.4

      • bind

        public void bind​(SocketAddress bindpoint)
          throws IOException
        将套接字绑定到本地地址。

        如果地址为null ，则系统将接收临时端口和有效的本地地址来绑定套接字。

        参数
        bindpoint - 要绑定的 SocketAddress
        异常
        IOException - 如果绑定操作失败，或者套接字已经绑定。
        IllegalArgumentException - 如果bindpoint是此套接字不支持的SocketAddress子类
        SecurityException - 如果安全管理器存在，并且其 checkListen方法不允许绑定到本地端口。
        从以下版本开始：
        1.4
        另请参见：
        isBound()

      • getInetAddress

        public InetAddress getInetAddress​()
        返回套接字所连接的地址。

        如果插座在closed之前连接，则该方法将在插座关闭后继续返回连接的地址。

        结果
        该套接字连接的远程IP地址，如果套接字未连接， null 。

      • getLocalAddress

        public InetAddress getLocalAddress​()
        获取套接字所绑定的本地地址。

        如果有一个安全管理器集，其checkConnect方法将以本地地址和-1作为参数来调用，以查看是否允许该操作。 如果不允许操作，则返回loopback地址。

        结果
        套接字绑定到的本地地址，如果安全管理器被拒绝的环回地址，或者如果套接字关闭或未绑定，则为通配符地址。
        从以下版本开始：
        1.1
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • getPort

        public int getPort​()
        返回此套接字连接到的远程端口号。

        如果套接字在closed之前被连接，那么这个方法将在套接字关闭后继续返回连接的端口号。

        结果
        该套接字连接的远程端口号，如果套接字尚未连接，则为0。

      • getLocalPort

        public int getLocalPort​()
        返回此套接字绑定到的本地端口号。

        如果套接字被绑定在closed之前，则该方法将在套接字关闭后继续返回本地端口号。

        结果
        该套接字绑定到的本地端口号，如果套接字未绑定，则为-1。

      • getRemoteSocketAddress

        public SocketAddress getRemoteSocketAddress​()
        返回此套接字连接到的端点的地址，如果未连接，则null 。

        如果套接字在closed之前被连接，则该方法将在套接字关闭后继续返回连接的地址。

        结果
        一个 SocketAddress表示此套接字的远程端点，或 null ，如果它尚未连接。
        从以下版本开始：
        1.4
        另请参见：
        getInetAddress() ，
getPort() ，
connect(SocketAddress, int) ，
connect(SocketAddress)

      • getLocalSocketAddress

        public SocketAddress getLocalSocketAddress​()
        返回此套接字绑定到的端点的地址。

        如果绑定到由InetSocketAddress表示的端点的InetSocketAddress为closed ，则该方法将在套接字关闭后继续返回InetSocketAddress 。 在这种情况下，返回的InetSocketAddress的地址是wildcard地址，其端口是绑定到的本地端口。

        如果有一个安全管理器集，其checkConnect方法将以本地地址和-1作为参数来调用，以查看是否允许该操作。 如果不允许操作，则SocketAddress表示loopback地址的SocketAddress和该套接字所绑定的本地端口。

        结果
        一个 SocketAddress表示该套接字的本地端点，或 SocketAddress表示如果安全管理器被拒绝的环回地址，或 null如果该套接字尚未绑定。
        从以下版本开始：
        1.4
        另请参见：
        getLocalAddress() ， getLocalPort() ， bind(SocketAddress) ， SecurityManager.checkConnect(java.lang.String, int)

      • getChannel

        public SocketChannel getChannel​()
        返回与此套接字相关联的唯一的SocketChannel对象（如果有）。

        如果只有通道本身是通过SocketChannel.open或ServerSocketChannel.accept方法创建的，则套接字将具有通道。

        结果
        与此套接字关联的套接字通道，如果此通道未创建此套接字， null
        从以下版本开始：
        1.4

      • getInputStream

        public InputStream getInputStream​()
                           throws IOException
        返回此套接字的输入流。

        如果此套接字具有相关联的通道，则所得到的输入流将其所有操作委派给通道。 如果通道处于非阻塞模式，那么输入流的read操作将会抛出一个IllegalBlockingModeException 。

        在异常情况下，远程主机或网络软件可能会破坏底层连接（例如TCP连接情况下的连接重置）。 当网络软件检测到断开的连接时，以下内容适用于返回的输入流：

        • 网络软件可以丢弃由套接字缓冲的字节。 不能被网络软件丢弃的字节可以使用read读取。

        • 如果在套接字上没有字节缓冲，或者所有缓冲字节已被read消耗掉，那么对read的所有后续调用将抛出一个IOException 。

        • 如果套接字上没有字节缓冲，并且套接字尚未使用close关闭，则available将返回0 。

        关闭返回的InputStream将关闭相关的套接字。

        结果
        用于从该套接字读取字节的输入流。
        异常
        IOException - 如果在创建输入流时发生I / O错误，则套接字关闭，插座未连接，或插座输入已使用 shutdownInput()关闭

      • getOutputStream

        public OutputStream getOutputStream​()
                             throws IOException
        返回此套接字的输出流。

        如果此套接字具有相关联的通道，则生成的输出流将其所有操作委派给通道。 如果通道处于非阻塞模式，那么输出流的write操作将会抛出一个IllegalBlockingModeException 。

        关闭返回的OutputStream将关闭相关的套接字。

        结果
        用于将字节写入此套接字的输出流。
        异常
        IOException - 如果创建输出流时发生I / O错误或未连接套接字。

      • setTcpNoDelay

        public void setTcpNoDelay​(boolean on)
                   throws SocketException
        启用/禁用 TCP_NODELAY （禁用/启用Nagle的算法）。
        参数
        on - true启用TCP_NODELAY， false禁用。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.1
        另请参见：
        getTcpNoDelay()

      • getTcpNoDelay

        public boolean getTcpNoDelay​()
                      throws SocketException
        测试是否启用了 TCP_NODELAY 。
        结果
        一个 boolean指示是否 TCP_NODELAY启用。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.1
        另请参见：
        setTcpNoDelay(boolean)

      • setSoLinger

        public void setSoLinger​(boolean on,
                        int linger)
                 throws SocketException
        启用/禁用SO_LINGER具有指定的逗留时间（以秒为单位）。 最大超时值是平台特定的。 该设置仅影响套接字关闭。
        参数
        on - 是否 on来
        linger - 如果是真的，多久才能停留。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        IllegalArgumentException - 如果 IllegalArgumentException值为负数。
        从以下版本开始：
        1.1
        另请参见：
        getSoLinger()

      • getSoLinger

        public int getSoLinger​()
                throws SocketException
        退货设置为SO_LINGER 。 -1返回意味着该选项被禁用。 该设置仅影响套接字关闭。
        结果
        设置为 SO_LINGER 。
        异常
        SocketException - 如果底层协议有错误，例如TCP错误。
        从以下版本开始：
        1.1
        另请参见：
        setSoLinger(boolean, int)

      • sendUrgentData

        public void sendUrgentData​(int data)
                    throws IOException
        在套接字上发送一个字节的紧急数据。 要发送的字节是数据参数的最低8位。 紧急字节在任何先前写入套接字OutputStream之后以及将来写入OutputStream之前发送。
        参数
        data - 要发送的数据字节
        异常
        IOException - 发送数据是否有错误。
        从以下版本开始：
        1.4

      • setOOBInline

        public void setOOBInline​(boolean on)
                  throws SocketException
        启用/禁用SO_OOBINLINE （接收TCP紧急数据）默认情况下，此选项被禁用，并且在套接字上接收的TCP紧急数据被静默地丢弃。 如果用户希望接收紧急数据，则必须启用此选项。 启用后，紧急数据将与正常数据一致。

        注意，仅提供有限的支持来处理传入的紧急数据。 具体而言，不提供进入的紧急数据的通知，除非由较高级协议提供，否则不能区分正常数据和紧急数据。

        参数
        on - true ，使 SO_OOBINLINE ， false禁用。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.4
        另请参见：
        getOOBInline()

      • getOOBInline

        public boolean getOOBInline​()
                     throws SocketException
        测试是否启用了 SO_OOBINLINE 。
        结果
        一个 boolean指示是否 SO_OOBINLINE启用。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.4
        另请参见：
        setOOBInline(boolean)

      • setSoTimeout

        public void setSoTimeout​(int timeout)
                  throws SocketException
        启用/禁用SO_TIMEOUT与指定的超时，以毫秒为单位。 使用此选项设置为非零超时时，与此Socket相关联的InputStream上的read（）调用将仅阻止此时间。 如果超时超时，则引发java.net.SocketTimeoutException ，尽管Socket仍然有效。 必须先启用该选项才能进入阻止操作才能生效。 超时时间必须为> 0 。 超时为零被解释为无限超时。
        参数
        timeout - 指定的超时时间，以毫秒为单位。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.1
        另请参见：
        getSoTimeout()

      • getSoTimeout

        public int getSoTimeout​()
                 throws SocketException
        退货设置为SO_TIMEOUT 。 0返回意味着该选项被禁用（即无限超时）。
        结果
        设置为 SO_TIMEOUT
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.1
        另请参见：
        setSoTimeout(int)

      • setSendBufferSize

        public void setSendBufferSize​(int size)
                       throws SocketException
        设置SO_SNDBUF选项，此规定值Socket 。 SO_SNDBUF选项被平台的网络代码用作大小设置底层网络I / O缓冲区的提示。

        因为SO_SNDBUF是一个提示，想要验证缓冲区设置大小的应用程序应该调用getSendBufferSize() 。

        参数
        size - 设置发送缓冲区大小的大小。 该值必须大于0。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        IllegalArgumentException - 如果值为0或为负数。
        从以下版本开始：
        1.2
        另请参见：
        getSendBufferSize()

      • getSendBufferSize

        public int getSendBufferSize​()
                      throws SocketException
        获取此 Socket的 SO_SNDBUF选项的值，即该平台用于在此 Socket上输出的缓冲区大小。
        结果
        该值为 SO_SNDBUF的此 Socket 。
        异常
        SocketException - 如果底层协议有错误，例如TCP错误。
        从以下版本开始：
        1.2
        另请参见：
        setSendBufferSize(int)

      • setReceiveBufferSize

        public void setReceiveBufferSize​(int size)
                          throws SocketException
        设置SO_RCVBUF选项，此规定值Socket 。 SO_RCVBUF选项被平台的网络代码用作大小设置底层网络I / O缓冲区的提示。

        增加接收缓冲区大小可以提高大容量连接的网络I / O的性能，同时减少它可以帮助减少输入数据的积压。

        因为SO_RCVBUF是一个提示，想要验证缓冲区设置大小的应用程序应该调用getReceiveBufferSize() 。

        SO_RCVBUF的值也用于设置向远程对等体发布的TCP接收窗口。 通常，可以随时连接一个套接字来修改窗口大小。 但是，如果接收窗口大于64K，则必须在套接字连接到远程对等体之前请求。 有两种情况需要注意：

        1. 对于从ServerSocket接受的套接字，必须通过在ServerSocket绑定到本地地址之前调用ServerSocket.setReceiveBufferSize(int)来完成。
        2. 对于客户端套接字，在将套接字连接到其远程对等体之前，必须调用setReceiveBufferSize（）。
        参数
        size - 设置接收缓冲区大小的大小。 该值必须大于0。
        异常
        IllegalArgumentException - 如果值为0或为负数。
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.2
        另请参见：
        getReceiveBufferSize() ， ServerSocket.setReceiveBufferSize(int)

      • getReceiveBufferSize

        public int getReceiveBufferSize​()
                         throws SocketException
        获取此 Socket的 SO_RCVBUF选项的值，即平台在此 Socket上输入的缓冲区大小。
        结果
        该值为 SO_RCVBUF的这个 Socket选项。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.2
        另请参见：
        setReceiveBufferSize(int)

      • setKeepAlive

        public void setKeepAlive​(boolean on)
                  throws SocketException
        启用/禁用 SO_KEEPALIVE 。
        参数
        on - 是否使套接字保持活动状态。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.3
        另请参见：
        getKeepAlive()

      • getKeepAlive

        public boolean getKeepAlive​()
                     throws SocketException
        测试是否启用了 SO_KEEPALIVE 。
        结果
        一个 boolean指示是否 SO_KEEPALIVE启用。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.3
        另请参见：
        setKeepAlive(boolean)

      • setTrafficClass

        public void setTrafficClass​(int tc)
                     throws SocketException
        在从此Socket发送的数据包的IP头中设置流量类或服务类型字节。 由于底层网络实现可能会忽略此值，应用程序应该考虑一个提示。

        tc 必须在0 <= tc <= 255范围内， 0 <= tc <= 255将抛出IllegalArgumentException。

        笔记：

        对于Internet协议v4，该值由integer组成，其最低有效8位表示由套接字发送的IP数据包中的TOS字节的值。 RFC 1349定义了TOS值如下：

        • IPTOS_LOWCOST (0x02)
        • IPTOS_RELIABILITY (0x04)
        • IPTOS_THROUGHPUT (0x08)
        • IPTOS_LOWDELAY (0x10)
        最后一个低位位总是被忽略，因为它对应于MBZ（必须为零）位。

        在优先级字段中设置位可能会导致SocketException表示不允许该操作。

        根据RFC 1122第4.2.4.2节的规定，一个兼容的TCP实现应该是但不是必须的，让应用程序在连接的生存期内更改TOS字段。 因此，在建立TCP连接后是否可以更改服务类型字段是否取决于底层平台中的实现。 应用程序不应假设在连接后可以更改TOS字段。

        对于Internet协议v6 tc是将被放置到IP头的sin6_flowinfo字段中的值。

        参数
        tc - 一个 int数值。
        异常
        SocketException - 如果在设置流量类或服务类型时出错
        从以下版本开始：
        1.4
        另请参见：
        getTrafficClass() ， SocketOptions.IP_TOS

      • getTrafficClass

        public int getTrafficClass​()
                    throws SocketException
        在从此Socket发送的数据包的IP头中获取流量类或服务类型

        由于底层网络实现可能会忽略使用setTrafficClass(int)的流量类或服务类型，该方法可能会返回与先前使用此套接字上的setTrafficClass(int)方法设置的值不同的值。

        结果
        流量类或服务类型已经设置
        异常
        SocketException - 如果在获取流量类或服务类型值时出错。
        从以下版本开始：
        1.4
        另请参见：
        setTrafficClass(int) ， SocketOptions.IP_TOS

      • setReuseAddress

        public void setReuseAddress​(boolean on)
                     throws SocketException
        启用/禁用SO_REUSEADDR套接字选项。

        当TCP连接关闭时，连接可能会在连接关闭后一段时间内保持在超时状态（通常称为TIME_WAIT状态或2MSL等待状态）。 对于使用众所周知的套接字地址或端口的应用程序，如果在涉及插座地址或端口的超时状态中存在连接，可能无法将套接字绑定到所需的SocketAddress 。

        在使用bind(SocketAddress)绑定套接字之前启用SO_REUSEADDR允许套接字绑定，即使以前的连接处于超时状态。

        创建Socket ，初始设置为SO_REUSEADDR被禁用。

        在套接字绑定后启用或禁用SO_REUSEADDR的行为（参见isBound() ）未定义。

        参数
        on - 是否启用或禁用套接字选项
        异常
        SocketException - 如果出现错误，启用或禁用 SO_REUSEADDR套接字选项，或者套接字关闭。
        从以下版本开始：
        1.4
        另请参见：
        getReuseAddress() ， bind(SocketAddress) ， isClosed() ， isBound()

      • getReuseAddress

        public boolean getReuseAddress​()
                        throws SocketException
        测试是否启用了 SO_REUSEADDR 。
        结果
        一个 boolean指示是否 SO_REUSEADDR启用。
        异常
        SocketException - 如果底层协议有错误，如TCP错误。
        从以下版本开始：
        1.4
        另请参见：
        setReuseAddress(boolean)

      • close

        public void close​()
           throws IOException
        关闭此套接字。

        任何线程当前被阻塞在这个套接字上的I / O操作将抛出一个SocketException 。

        一旦一个套接字被关闭，它不可用于进一步的网络使用（即不能重新连接或反弹）。 需要创建一个新的套接字。

        关闭此插座也将关闭插座的InputStream和OutputStream 。

        如果此套接字具有关联的通道，则通道也将关闭。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果在关闭此套接字时发生I / O错误。
        另请参见：
        isClosed()

      • shutdownInput

        public void shutdownInput​()
                   throws IOException
        将此套接字的输入流放置在“流的末尾”。 发送到套接字的输入流侧的任何数据都被确认，然后静默丢弃。

        如果您在套接字上调用此方法后从套接字输入流中读取，则该流的available方法将返回0，而其read方法将返回-1 （结束流）。

        异常
        IOException - 如果在关闭此套接字时发生I / O错误。
        从以下版本开始：
        1.3
        另请参见：
        shutdownOutput() ，
close() ，
setSoLinger(boolean, int) ，
isInputShutdown()

      • shutdownOutput

        public void shutdownOutput​()
                    throws IOException
        禁用此套接字的输出流。 对于TCP套接字，任何先前写入的数据将被发送，随后是TCP的正常连接终止序列。 如果在套接字上调用shutdownOutput（）之后写入套接字输出流，则流将抛出IOException。
        异常
        IOException - 如果在关闭此套接字时发生I / O错误。
        从以下版本开始：
        1.3
        另请参见：
        shutdownInput() ，
close() ，
setSoLinger(boolean, int) ，
isOutputShutdown()

      • toString

        public String toString​()
        将此套接字转换为 String 。
        重写：
        toString在 Object
        结果
        这个套接字的字符串表示形式。

      • isConnected

        public boolean isConnected​()
        返回套接字的连接状态。

        注意：关闭套接字不会清除其连接状态，这意味着如果在关闭之前成功连接，此方法将返回true的封闭套接字（请参阅isClosed() ）。

        结果
        如果套接字成功连接到服务器，则为true
        从以下版本开始：
        1.4

      • isBound

        public boolean isBound​()
        返回套接字的绑定状态。

        注意：关闭套接字不会清除其绑定状态，这意味着如果在关闭之前成功绑定，此方法将返回true的封闭套接字（请参阅isClosed() ）。

        结果
        如果套接字成功绑定到地址，则为true
        从以下版本开始：
        1.4
        另请参见：
        bind(java.net.SocketAddress)

      • isClosed

        public boolean isClosed​()
        返回套接字的关闭状态。
        结果
        如果套接字已关闭，则为true
        从以下版本开始：
        1.4
        另请参见：
        close()

      • isInputShutdown

        public boolean isInputShutdown​()
        返回套接字连接的一半是否关闭。
        结果
        如果套接字的输入已关闭，则为true
        从以下版本开始：
        1.4
        另请参见：
        shutdownInput()

      • isOutputShutdown

        public boolean isOutputShutdown​()
        返回套接字连接的写半是否关闭。
        结果
        如果套接字的输出已经关闭，则为true
        从以下版本开始：
        1.4
        另请参见：
        shutdownOutput()

      • setSocketImplFactory

        public static void setSocketImplFactory​(SocketImplFactory fac)
                                 throws IOException
        设置应用程序的客户端套接字实现工厂。 工厂只能指定一次。

        当应用程序创建一个新的客户端套接字时，将调用套接字实现工厂的createSocketImpl方法来创建实际的套接字实现。

        传递null的方法是无操作的，除非工厂已经设置。

        如果有安全管理员，则该方法首先调用安全管理员的checkSetFactory方法，以确保允许操作。 这可能会导致SecurityException。

        参数
        fac - 所需工厂。
        异常
        IOException - 设置插座工厂时是否发生I / O错误。
        SocketException - 如果工厂已经定义。
        SecurityException - 如果存在安全管理员，并且其 checkSetFactory方法不允许该操作。
        另请参见：
        SocketImplFactory.createSocketImpl() ， SecurityManager.checkSetFactory()

      • setPerformancePreferences

        public void setPerformancePreferences​(int connectionTime,
                                      int latency,
                                      int bandwidth)
        设置此套接字的性能首选项。

        套接字默认使用TCP / IP协议。 一些实现可以提供具有与TCP / IP不同的性能特征的替代协议。 该方法允许应用程序表达自己的偏好，以便在实现从可用协议中选择时应如何进行这些权衡。

        性能偏好由三个整数描述，其值表示短连接时间，低延迟和高带宽的相对重要性。 整数的绝对值是无关紧要的; 为了选择协议，简单地比较值，较大的值表示较强的偏好。 负值表示比正值低的优先级。 例如，如果应用程序优先考虑低延迟和高带宽的短连接时间，那么它可以使用值为(1, 0, 0)来调用此方法。 如果应用程序优先于低延迟的高带宽，并且在短的连接时间(0, 1, 2)低延迟，那么它可以使用值为(0, 1, 2)来调用此方法。

        在此套接字连接后调用此方法将不起作用。

        参数
        connectionTime - 表示短连接时间的相对重要性的 int
        latency - 表示低延迟的相对重要性的 int
        bandwidth - 表示高带宽的相对重要性的 int
        从以下版本开始：
        1.5

      • setOption

        public <T> Socket setOption​(SocketOption<T> name,
                            T value)
                     throws IOException
        设置套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值为null可能对某些选项有效。
        结果
        这个Socket
        异常
        UnsupportedOperationException - 如果套接字不支持该选项。
        IllegalArgumentException - 如果该值对该选项无效。
        IOException - 如果发生I / O错误，或者套接字关闭。
        NullPointerException - 如果名字是 null
        SecurityException - 如果设置了安全管理器，并且套接字选项是否需要安全许可，并且主叫方没有必要的权限。 StandardSocketOptions不需要任何安全许可。
        从以下版本开始：
        9

      • getOption

        public <T> T getOption​(SocketOption<T> name)
                throws IOException
        返回套接字选项的值。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        套接字选项的值。
        异常
        UnsupportedOperationException - 如果套接字不支持该选项。
        IOException - 如果发生I / O错误，或者套接字关闭。
        NullPointerException - 如果名字是 null
        SecurityException - 如果设置了安全管理器，并且套接字选项是否需要安全许可，并且主叫方没有必要的权限。 StandardSocketOptions不需要任何安全许可。
        从以下版本开始：
        9

      • supportedOptions

        public Set<SocketOption<?>> supportedOptions​()
        返回此套接字支持的一组套接字选项。 即使在套接字关闭后，此方法也将继续返回该选项。
        结果
        该套接字支持的一组套接字选项。 如果套接字的SocketImpl无法创建，则此集合可能为空。
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketAddress (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class SocketAddress

  • java.lang.Object
    • java.net.SocketAddress
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    InetSocketAddress

    public abstract class SocketAddress
extends Object
implements Serializable
    这个类代表一个没有协议附件的Socket地址。 作为一个抽象类，它的意思是使用特定的，依赖于协议的实现进行子类化。

    它提供了用于绑定，连接或返回值的套接字所使用的不可变对象。

    从以下版本开始：
    1.4
    另请参见：
    Socket ， ServerSocket ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SocketAddress​()

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SocketAddress

        public SocketAddress​()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class SocketException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.SocketException
  • All Implemented Interfaces:
    Serializable
    已知直接子类：
    BindException ， ConnectException ， NoRouteToHostException ， PortUnreachableException

    public class SocketException
extends IOException
    抛出以表示创建或访问Socket时出错。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      SocketException​()
      构造一个新的 SocketException ，没有详细的消息。
      SocketException​(String msg)
      构造一个新的 SocketException与指定的详细信息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SocketException

        public SocketException​(String msg)
        构造一个新的 SocketException与指定的详细信息。
        参数
        msg - 详细信息。

      • SocketException

        public SocketException​()
        构造一个新的 SocketException ，没有详细的消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketImpl (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class SocketImpl

  • java.lang.Object
    • java.net.SocketImpl
  • All Implemented Interfaces:
    SocketOptions

    public abstract class SocketImpl
extends Object
implements SocketOptions
    抽象类SocketImpl是实际实现套接字的所有类的公共超类。 它用于创建客户端和服务器套接字。

    “plain”套接字完全按照所描述的方式实现这些方法，而不尝试通过防火墙或代理。

    从以下版本开始：
    1.0

    • Field Summary

      Fields
      Modifier and Type Field 描述
      protected InetAddress address
      该套接字远端的IP地址。
      protected FileDescriptor fd
      该套接字的文件描述符对象。
      protected int localport
      此套接字连接到的本地端口号。
      protected int port
      此套接字连接到的远程主机上的端口号。

      • Fields inherited from interface java.net.SocketOptions

        IP_MULTICAST_IF, IP_MULTICAST_IF2, IP_MULTICAST_LOOP, IP_TOS, SO_BINDADDR, SO_BROADCAST, SO_KEEPALIVE, SO_LINGER, SO_OOBINLINE, SO_RCVBUF, SO_REUSEADDR, SO_REUSEPORT, SO_SNDBUF, SO_TIMEOUT, TCP_NODELAY

    • 构造方法摘要

      构造方法
      Constructor 描述
      SocketImpl​()

    • 方法摘要

      所有方法 接口方法 抽象方法 具体的方法
      Modifier and Type 方法 描述
      protected abstract void accept​(SocketImpl s)
      接受连接。
      protected abstract int available​()
      返回可从该套接字读取而不阻塞的字节数。
      protected abstract void bind​(InetAddress host, int port)
      将此套接字绑定到指定的本地IP地址和端口号。
      protected abstract void close​()
      关闭此套接字。
      protected abstract void connect​(String host, int port)
      将此套接字连接到指定主机上的指定端口。
      protected abstract void connect​(InetAddress address, int port)
      将此套接字连接到指定主机上的指定端口号。
      protected abstract void connect​(SocketAddress address, int timeout)
      将此套接字连接到指定主机上的指定端口号。
      protected abstract void create​(boolean stream)
      创建流或数据报套接字。
      protected FileDescriptor getFileDescriptor​()
      返回此套接字 fd字段的值。
      protected InetAddress getInetAddress​()
      返回此套接字 address字段的值。
      protected abstract InputStream getInputStream​()
      返回此套接字的输入流。
      protected int getLocalPort​()
      返回此套接字 localport字段的值。
      protected <T> T getOption​(SocketOption<T> name)
      被称为获取套接字选项。
      protected abstract OutputStream getOutputStream​()
      返回此套接字的输出流。
      protected int getPort​()
      返回此套接字 port字段的值。
      protected abstract void listen​(int backlog)
      将传入连接指示（连接请求）的最大队列长度设置为 count参数。
      protected abstract void sendUrgentData​(int data)
      在套接字上发送一个字节的紧急数据。
      protected <T> void setOption​(SocketOption<T> name, T value)
      调用设置套接字选项。
      protected void setPerformancePreferences​(int connectionTime, int latency, int bandwidth)
      设置此套接字的性能首选项。
      protected void shutdownInput​()
      将此套接字的输入流放置在“流的末尾”。
      protected void shutdownOutput​()
      禁用此套接字的输出流。
      protected Set<SocketOption<?>> supportedOptions​()
      返回一个由此impl和该impl的套接字支持的SocketOptions（Socket或ServerSocket）
      protected boolean supportsUrgentData​()
      返回SocketImpl是否支持发送紧急数据。
      String toString​()
      将此套接字的地址和端口作为 String 。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.net.SocketOptions

        getOption, setOption

    • 字段详细信息

      • fd

        protected FileDescriptor fd
        该套接字的文件描述符对象。

      • address

        protected InetAddress address
        该套接字远端的IP地址。

      • port

        protected int port
        此套接字连接到的远程主机上的端口号。

      • localport

        protected int localport
        此套接字连接到的本地端口号。

    • 构造方法详细信息

      • SocketImpl

        public SocketImpl​()

    • 方法详细信息

      • create

        protected abstract void create​(boolean stream)
                        throws IOException
        创建流或数据报套接字。
        参数
        stream - 如果是true ，创建一个流套接字; 否则，创建一个数据报套接字。
        异常
        IOException - 如果在创建套接字时发生I / O错误。

      • connect

        protected abstract void connect​(String host,
                                int port)
                         throws IOException
        将此套接字连接到指定主机上的指定端口。
        参数
        host - 远程主机的名称。
        port - 端口号。
        异常
        IOException - 如果连接到远程主机时发生I / O错误。

      • connect

        protected abstract void connect​(InetAddress address,
                                int port)
                         throws IOException
        将此套接字连接到指定主机上的指定端口号。
        参数
        address - 远程主机的IP地址。
        port - 端口号。
        异常
        IOException - 如果尝试连接时发生I / O错误。

      • connect

        protected abstract void connect​(SocketAddress address,
                                int timeout)
                         throws IOException
        将此套接字连接到指定主机上的指定端口号。 超时为零被解释为无限超时。 然后，连接将阻塞，直到建立或发生错误。
        参数
        address - 远程主机的Socket地址。
        timeout - 无超时的超时值（以毫秒为单位）或零。
        异常
        IOException - 如果尝试连接时发生I / O错误。
        从以下版本开始：
        1.4

      • bind

        protected abstract void bind​(InetAddress host,
                             int port)
                      throws IOException
        将此套接字绑定到指定的本地IP地址和端口号。
        参数
        host - 属于本地接口的IP地址。
        port - 端口号。
        异常
        IOException - 如果绑定此套接字时发生I / O错误。

      • listen

        protected abstract void listen​(int backlog)
                        throws IOException
        将传入连接指示（请求连接）的最大队列长度设置为count参数。 如果连接指示在队列已满时到达，则连接被拒绝。
        参数
        backlog - 队列的最大长度。
        异常
        IOException - 如果在创建队列时发生I / O错误。

      • accept

        protected abstract void accept​(SocketImpl s)
                        throws IOException
        接受连接。
        参数
        s - 接受的连接。
        异常
        IOException - 如果接受连接时发生I / O错误。

      • getInputStream

        protected abstract InputStream getInputStream​()
                                       throws IOException
        返回此套接字的输入流。
        结果
        从该套接字读取的流。
        异常
        IOException - 创建输入流时是否发生I / O错误。

      • getOutputStream

        protected abstract OutputStream getOutputStream​()
                                         throws IOException
        返回此套接字的输出流。
        结果
        用于写入此插座的输出流。
        异常
        IOException - 创建输出流时是否发生I / O错误。

      • available

        protected abstract int available​()
                          throws IOException
        返回可从该套接字读取而不阻塞的字节数。
        结果
        可以从该套接字读取但不阻塞的字节数。
        异常
        IOException - 确定可用字节数时是否发生I / O错误。

      • close

        protected abstract void close​()
                       throws IOException
        关闭此套接字。
        异常
        IOException - 如果在关闭此套接字时发生I / O错误。

      • shutdownInput

        protected void shutdownInput​()
                      throws IOException
        将此套接字的输入流放置在“流的末尾”。 发送到此套接字的任何数据都被确认，然后静默丢弃。 如果您在套接字上调用此方法后从套接字输入流中读取，则该流的available方法将返回0，而其read方法将返回-1 （流结束）。
        异常
        IOException - 如果在关闭此套接字时发生I / O错误。
        从以下版本开始：
        1.3
        另请参见：
        Socket.shutdownOutput() ，
Socket.close() ，
Socket.setSoLinger(boolean, int)

      • shutdownOutput

        protected void shutdownOutput​()
                       throws IOException
        禁用此套接字的输出流。 对于TCP套接字，任何先前写入的数据将被发送，随后是TCP的正常连接终止序列。 如果在套接字上调用shutdownOutput（）之后写入套接字输出流，则流将抛出IOException。
        异常
        IOException - 如果在关闭此套接字时发生I / O错误。
        从以下版本开始：
        1.3
        另请参见：
        Socket.shutdownInput() ，
Socket.close() ，
Socket.setSoLinger(boolean, int)

      • getFileDescriptor

        protected FileDescriptor getFileDescriptor​()
        返回此套接字 fd字段的值。
        结果
        该套接字的 fd字段。
        另请参见：
        fd

      • getInetAddress

        protected InetAddress getInetAddress​()
        返回此套接字 address字段的值。
        结果
        该套接字的 address字段。
        另请参见：
        address

      • getPort

        protected int getPort​()
        返回此套接字 port字段的值。
        结果
        该套接字的 port字段。
        另请参见：
        port

      • supportsUrgentData

        protected boolean supportsUrgentData​()
        返回SocketImpl是否支持发送紧急数据。 默认情况下，返回false，除非方法在子类中被覆盖
        结果
        如果紧急数据支持，则为true
        从以下版本开始：
        1.4
        另请参见：
        address

      • sendUrgentData

        protected abstract void sendUrgentData​(int data)
                                throws IOException
        在套接字上发送一个字节的紧急数据。 要发送的字节是该参数的低8位
        参数
        data - 发送数据的字节
        异常
        IOException - 发送数据是否有错误。
        从以下版本开始：
        1.4

      • getLocalPort

        protected int getLocalPort​()
        返回此套接字 localport字段的值。
        结果
        该套接字的 localport字段。
        另请参见：
        localport

      • toString

        public String toString​()
        将此套接字的地址和端口作为 String 。
        重写：
        toString在 Object
        结果
        这个套接字的字符串表示形式。

      • setPerformancePreferences

        protected void setPerformancePreferences​(int connectionTime,
                                         int latency,
                                         int bandwidth)
        设置此套接字的性能首选项。

        套接字默认使用TCP / IP协议。 一些实现可以提供具有与TCP / IP不同的性能特征的替代协议。 该方法允许应用程序表达自己的偏好，以便在实现从可用协议中选择时应如何进行这些权衡。

        性能偏好由三个整数描述，其值表示短连接时间，低延迟和高带宽的相对重要性。 整数的绝对值是无关紧要的; 为了选择协议，简单地比较值，较大的值表示较强的偏好。 负值表示比正值低的优先级。 例如，如果应用程序优先考虑低延迟和高带宽的短连接时间，则可以使用值(1, 0, 0)调用此方法。 如果应用程序喜欢高于低延迟的高带宽，并且在短的连接时间以上的低延迟，则可以使用值为(0, 1, 2)调用此方法。 默认情况下，此方法不执行任何操作，除非在aa子类中被覆盖。

        参数
        connectionTime - 表示短连接时间的相对重要性的 int
        latency - 表示低延迟的相对重要性的 int
        bandwidth - 表示高带宽的相对重要性的 int
        从以下版本开始：
        1.5

      • setOption

        protected <T> void setOption​(SocketOption<T> name,
                             T value)
                      throws IOException
        调用设置套接字选项。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        value - 套接字选项的值。 值null可能对某些选项有效。
        异常
        UnsupportedOperationException - 如果SocketImpl不支持该选项
        IOException - 如果发生I / O错误，或者套接字关闭。
        从以下版本开始：
        9

      • getOption

        protected <T> T getOption​(SocketOption<T> name)
                   throws IOException
        被称为获取套接字选项。
        参数类型
        T - 套接字选项值的类型
        参数
        name - 套接字选项
        结果
        命名选项的值
        异常
        UnsupportedOperationException - 如果SocketImpl不支持该选项。
        IOException - 如果发生I / O错误，或者套接字关闭。
        从以下版本开始：
        9

      • supportedOptions

        protected Set<SocketOption<?>> supportedOptions​()
        返回一个由此impl和该impl的套接字支持的SocketOptions（Socket或ServerSocket）
        结果
        一套SocketOptions
        从以下版本开始：
        9
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketImplFactory (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface SocketImplFactory

  • public interface SocketImplFactory
    该接口定义了一个工厂用于套接字实现。 它由类Socket和ServerSocket用于创建实际的套接字实现。
    从以下版本开始：
    1.0
    另请参见：
    Socket ， ServerSocket

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      SocketImpl createSocketImpl​()
      创建一个新的 SocketImpl实例。

    • 方法详细信息

      • createSocketImpl

        SocketImpl createSocketImpl​()
        创建一个新的 SocketImpl实例。
        结果
        一个新的例子 SocketImpl 。
        另请参见：
        SocketImpl
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketOption (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface SocketOption<T>

  • 参数类型
    T - 套接字选项值的类型。
    All Known Subinterfaces:
    SctpSocketOption<T>

    public interface SocketOption<T>
    与套接字关联的套接字选项。

    在channels包中， NetworkChannel接口定义了setOption和getOption方法来设置和查询通道的套接字选项。

    从以下版本开始：
    1.7
    另请参见：
    StandardSocketOptions

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      String name​()
      返回套接字选项的名称。
      Class<T> type​()
      返回套接字选项值的类型。

    • 方法详细信息

      • name

        String name​()
        返回套接字选项的名称。
        结果
        套接字选项的名称

      • type

        Class<T> type​()
        返回套接字选项值的类型。
        结果
        套接字选项值的类型
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Interface SocketOptions

  • 所有已知实现类：
    DatagramSocketImpl ， SocketImpl

    public interface SocketOptions
    获取/设置套接字选项的方法的接口。 该接口由SocketImpl和DatagramSocketImpl实现 。 这些子类应该覆盖此接口的方法，以支持自己的选项。

    在此界面中指定选项的方法和常量仅用于实现。 如果你不是子类化SocketImpl或DatagramSocketImpl， 你不会直接使用这些。 有一些类型安全的方法可以在Socket，ServerSocket，DatagramSocket和MulticastSocket中获取/设置这些选项。

    从以下版本开始：
    1.1

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static int IP_MULTICAST_IF
      设置发送组播数据包的出接口。
      static int IP_MULTICAST_IF2
      与上述相同。
      static int IP_MULTICAST_LOOP
      此选项启用或禁用组播数据报的本地环回。
      static int IP_TOS
      此选项将TCP或UDP套接字的IP头中的服务类型或流量类别字段设置。
      static int SO_BINDADDR
      获取套接字的本地地址绑定（此选项不能仅“设置”，因为套接字在创建时绑定，因此本地绑定的地址不能被更改）。
      static int SO_BROADCAST
      为套接字设置SO_BROADCAST。
      static int SO_KEEPALIVE
      当为TCP套接字设置keepalive选项，并且没有数据在两个方向上通过套接字交换2小时（注意：实际值取决于实现），TCP自动向对等体发送keepalive探测。
      static int SO_LINGER
      指定一个随叫随到的超时时间。
      static int SO_OOBINLINE
      当设置OOBINLINE选项时，将通过套接字输入流接收在套接字上接收的任何TCP紧急数据。
      static int SO_RCVBUF
      设置平台为传入网络I / O使用的底层缓冲区的大小。
      static int SO_REUSEADDR
      为套接字设置SO_REUSEADDR。
      static int SO_REUSEPORT
      为套接字设置SO_REUSEPORT。
      static int SO_SNDBUF
      设置平台用于传出网络I / O的底层缓冲区的大小。
      static int SO_TIMEOUT
      在阻塞Socket操作上设置一个超时：
      static int TCP_NODELAY
      禁用Nagle的这个连接的算法。

    • 方法摘要

      所有方法 接口方法 抽象方法
      Modifier and Type 方法 描述
      Object getOption​(int optID)
      获取选项的值。
      void setOption​(int optID, Object value)
      启用/禁用 optID指定的选项。

    • 字段详细信息

      • TCP_NODELAY

        @Native
static final int TCP_NODELAY
        禁用Nagle的这个连接的算法。 到网络的书面数据不会缓冲以前写入的数据的确认。

        仅适用于TCP：SocketImpl。

        另请参见：
        Socket.setTcpNoDelay(boolean) ， Socket.getTcpNoDelay() ， Constant Field Values

      • SO_BINDADDR

        @Native
static final int SO_BINDADDR
        获取套接字的本地地址绑定（此选项不能仅“设置”，因为套接字在创建时绑定，因此本地绑定的地址不能被更改）。 套接字的默认本地地址为INADDR_ANY，表示多宿主主机上的任何本地地址。 多宿主主机可以使用此选项来接受仅与其一个地址的连接（在ServerSocket或DatagramSocket的情况下），或者指定其对等体（对于Socket或DatagramSocket）的返回地址。 此选项的参数是InetAddress。

        必须在构造函数中指定此选项。

        适用于：SocketImpl，DatagramSocketImpl

        另请参见：
        Socket.getLocalAddress() ， DatagramSocket.getLocalAddress() ， Constant Field Values

      • SO_REUSEADDR

        @Native
static final int SO_REUSEADDR
        为套接字设置SO_REUSEADDR。 这仅用于Java中的MulticastSockets，默认情况下为MulticastSockets设置。

        适用于：DatagramSocketImpl

        另请参见：
        Constant Field Values

      • SO_REUSEPORT

        @Native
static final int SO_REUSEPORT
        为套接字设置SO_REUSEPORT。 此选项启用和禁用多个套接字侦听相同的地址和端口的能力。

        适用于：SocketImpl，DatagramSocketImpl

        从以下版本开始：
        9
        另请参见：
        StandardSocketOptions.SO_REUSEPORT ， Constant Field Values

      • SO_BROADCAST

        @Native
static final int SO_BROADCAST
        为套接字设置SO_BROADCAST。 此选项启用和禁用进程发送广播消息的功能。 仅支持数据报套接字，仅支持支持广播消息（例如以太网，令牌环等）概念的网络，DatagramSockets默认设置。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • IP_MULTICAST_IF

        @Native
static final int IP_MULTICAST_IF
        设置发送组播数据包的出接口。 适用于具有多个网络接口的主机，其中应用程序希望使用除系统默认值。 获取/返回InetAddress。

        适用于组播：DatagramSocketImpl

        另请参见：
        MulticastSocket.setInterface(InetAddress) ， MulticastSocket.getInterface() ， Constant Field Values

      • IP_MULTICAST_IF2

        @Native
static final int IP_MULTICAST_IF2
        与上述相同。 引入此选项，以便IP_MULTICAST_IF的行为将保持与以前相同，而此新选项可以支持使用IPv4和IPv6地址设置输出接口。 注意：确保没有与此冲突
        从以下版本开始：
        1.4
        另请参见：
        MulticastSocket.setNetworkInterface(NetworkInterface) ， MulticastSocket.getNetworkInterface() ， Constant Field Values

      • IP_MULTICAST_LOOP

        @Native
static final int IP_MULTICAST_LOOP
        此选项启用或禁用组播数据报的本地环回。 此选项默认启用多播套接字。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • IP_TOS

        @Native
static final int IP_TOS
        此选项将TCP或UDP套接字的IP头中的服务类型或流量类别字段设置。
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • SO_LINGER

        @Native
static final int SO_LINGER
        指定一个随叫随到的超时时间。 此选项禁用/启用TCP Socket的close（））的即时返回。 使用非零整数启用此选项意味着close（）将阻止发送和确认写入对等体的所有数据，此时套接字优雅地关闭。 在达到停留超时时，插座被强制关闭，并带有TCP RST。 启用超时为零的选项将立即强制关闭。 如果指定的超时值超过65,535，则减少到65,535。

        仅适用于TCP：SocketImpl

        另请参见：
        Socket.setSoLinger(boolean, int) ， Socket.getSoLinger() ， Constant Field Values

      • SO_TIMEOUT

        @Native
static final int SO_TIMEOUT
        在阻塞Socket操作上设置一个超时：
          ServerSocket.accept();
 SocketInputStream.read();
 DatagramSocket.receive();

        必须先设置该选项才能进入阻止操作才能生效。 如果超时过期，并且操作将继续阻止，则引发java.io.InterruptedIOException 。 在这种情况下，Socket不关闭。

        适用于所有套接字：SocketImpl，DatagramSocketImpl

        另请参见：
        Socket.setSoTimeout(int) ，
ServerSocket.setSoTimeout(int) ，
DatagramSocket.setSoTimeout(int) ，
Constant Field Values

      • SO_SNDBUF

        @Native
static final int SO_SNDBUF
        设置平台用于传出网络I / O的底层缓冲区的大小。 当在集合中使用时，这是从应用程序向内核提供的用于通过套接字发送的数据的缓冲区大小的建议。 当在get中使用时，必须返回在该套接字上发送数据时平台实际使用的缓冲区的大小。 适用于所有套接字：SocketImpl，DatagramSocketImpl
        另请参见：
        Socket.setSendBufferSize(int) ，
Socket.getSendBufferSize() ，
DatagramSocket.setSendBufferSize(int) ，
DatagramSocket.getSendBufferSize() ，
Constant Field Values

      • SO_RCVBUF

        @Native
static final int SO_RCVBUF
        设置平台为传入网络I / O使用的底层缓冲区的大小。 当在集合中使用时，这是从应用程序到内核的关于用于通过套接字接收的数据的缓冲区的大小的建议。 当在get中使用时，必须返回平台实际使用的缓冲区的大小，才能在该套接字上的数据中接收数据。 适用于所有套接字：SocketImpl，DatagramSocketImpl
        另请参见：
        Socket.setReceiveBufferSize(int) ，
Socket.getReceiveBufferSize() ，
DatagramSocket.setReceiveBufferSize(int) ，
DatagramSocket.getReceiveBufferSize() ，
Constant Field Values

      • SO_KEEPALIVE

        @Native
static final int SO_KEEPALIVE
        当为TCP套接字设置keepalive选项，并且没有数据在两个方向上通过套接字交换2小时（注意：实际值取决于实现），TCP自动向对等体发送keepalive探测。 该探测器是对等体必须响应的TCP段。 预期三种响应之一：1.对端以预期的ACK进行响应。 该应用程序未通知（因为一切正常）。 TCP将在另外2个小时不活动之后发送另一个探测器。 2.对等体用RST响应，该RST通知本地TCP对等体主机已经崩溃并重新启动。 插座关闭。 3.同行没有回应。 插座关闭。 此选项的目的是检测对等主机是否崩溃。 仅适用于TCP套接字：SocketImpl
        另请参见：
        Socket.setKeepAlive(boolean) ， Socket.getKeepAlive() ， Constant Field Values

      • SO_OOBINLINE

        @Native
static final int SO_OOBINLINE
        当设置OOBINLINE选项时，将通过套接字输入流接收在套接字上接收的任何TCP紧急数据。 当该选项被禁用（这是默认值）时，紧急数据被静默地丢弃。
        另请参见：
        Socket.setOOBInline(boolean) ， Socket.getOOBInline() ， Constant Field Values

    • 方法详细信息

      • setOption

        void setOption​(int optID,
               Object value)
        throws SocketException
        启用/禁用optID指定的选项。 如果选项是启用的，它需要一个特定期权“价值”，这是值传递。 值的实际类型是特定于选项的，传递不是预期类型的东西是错误的：
          SocketImpl s;
 ...
 s.setOption(SO_LINGER, new Integer(10));
    // OK - set SO_LINGER w/ timeout of 10 sec.
 s.setOption(SO_LINGER, new Double(10));
    // ERROR - expects java.lang.Integer
        如果所请求的选项是二进制的，则可以使用java.lang.Boolean的此方法设置它：
          s.setOption(TCP_NODELAY, Boolean.TRUE);
    // OK - enables TCP_NODELAY, a binary option

        可以使用Boolean.FALSE的此方法禁用任何选项：
          s.setOption(TCP_NODELAY, Boolean.FALSE);
    // OK - disables TCP_NODELAY
 s.setOption(SO_LINGER, Boolean.FALSE);
    // OK - disables SO_LINGER

        对于具有的开启和关闭一个概念，需要非布尔参数，它的值设置为比Boolean.FALSE隐含使其以外的任何一个选项。
        如果该选项无法识别，套接字关闭或发生一些低级错误，则抛出SocketException异常
        参数
        optID - 标识该选项
        value - 套接字选项的参数
        异常
        SocketException - 如果该选项无法识别，则套接字关闭，或发生一些低级错误
        另请参见：
        getOption(int)

      • getOption

        Object getOption​(int optID)
          throws SocketException
        获取选项的值。 如果启用，二进制选项将返回java.lang.Boolean.TRUE，如果禁用，则返回java.lang.Boolean.FALSE，例如：
          SocketImpl s;
 ...
 Boolean noDelay = (Boolean)(s.getOption(TCP_NODELAY));
 if (noDelay.booleanValue()) {
     // true if TCP_NODELAY is enabled...
 ...
 }

        对于将特定类型作为参数的选项，getOption（int）将返回参数的值，否则返回java.lang.Boolean.FALSE：

          Object o = s.getOption(SO_LINGER);
 if (o instanceof Integer) {
     System.out.print("Linger time is " + ((Integer)o).intValue());
 } else {
   // the true type of o is java.lang.Boolean.FALSE;
 }
        参数
        optID - 标识提取选项的 int
        结果
        该选项的值
        异常
        SocketException - 如果套接字关闭
        SocketException - 如果 optID在协议栈（包括SocketImpl）中是未知的，
        另请参见：
        setOption(int, java.lang.Object)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketPermission (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class SocketPermission

  • java.lang.Object
    • java.security.Permission
      • java.net.SocketPermission
  • All Implemented Interfaces:
    Serializable ， Guard

    public final class SocketPermission
extends Permission
implements Serializable
    此类表示通过套接字访问网络。 SocketPermission由主机规范和一组指定连接到该主机的方式的“动作”组成。 主机被指定为
      host = (hostname | IPv4address | iPv6reference) [:portrange]
    portrange = portnumber | -portnumber | portnumber-[portnumber]
    主机表示为DNS名称，数字IP地址或“localhost”（用于本地机器）。 通配符“*”可以包含在DNS名称主机规范中。 如果包含在内，它必须位于最左侧的位置，如“* .sun.com”中所示。

    IPv6引用的格式应遵循RFC 2732: Format for Literal IPv6 Addresses in URLs中规定的格式 ：

      ipv6reference = "[" IPv6address "]"
    例如，您可以构造一个SocketPermission实例，如下所示：
      String hostAddress = inetaddress.getHostAddress();
    if (inetaddress instanceof Inet6Address) {
        sp = new SocketPermission("[" + hostAddress + "]:" + port, action);
    } else {
        sp = new SocketPermission(hostAddress + ":" + port, action);
    }
    要么
      String host = url.getHost();
    sp = new SocketPermission(host + ":" + port, action);

    一个IPv6文字地址的full uncompressed form也是有效的。

    端口或portrange是可选的。 “N”形式的端口规范，其中N是端口号，表示所有编号为N及以上的端口，而“-N”形式的规格表示所有编号为N及更小的端口。 特殊端口值0是指整个临时端口范围。 这是系统可用于分配动态端口的固定端口范围。 实际范围可能取决于系统。

    连接到主机的可能方式是

      accept
 connect
 listen
 resolve
    “listen”操作仅在与“localhost”一起使用时有意义，意味着绑定到指定端口的能力。 当存在任何其他操作时，暗示“解决”行为。 操作“解决”是指主机/ IP名称服务查找。

    操作字符串在处理之前转换为小写。

    作为SocketPermissions的创建和意义的一个例子，请注意，如果以下权限：

      p1 = new SocketPermission("puffin.eng.sun.com:7777", "connect,accept");
    被授予一些代码，它允许代码连接到端口7777在puffin.eng.sun.com ，并接受该端口上的连接。

    同样，如果以下许可：

      p2 = new SocketPermission("localhost:1024-", "accept,connect,listen");
    被授予某些代码，它允许该代码在本地主机上接受1024到65535之间的任何端口上的连接，连接或监听。

    注意：授予接受或连接到远程主机的代码权限可能是危险的，因为恶意代码可以更容易地在可能无法访问数据的各方之间传输和共享机密数据。

    从以下版本开始：
    1.2
    另请参见：
    Permissions ， SocketPermission

    • 构造方法摘要

      构造方法
      Constructor 描述
      SocketPermission​(String host, String action)
      使用指定的操作创建一个新的SocketPermission对象。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      检查两个SocketPermission对象是否相等。
      String getActions​()
      返回动作的规范字符串表示形式。
      int hashCode​()
      返回此对象的哈希码值。
      boolean implies​(Permission p)
      检查此套接字许可对象是否“暗示”指定的权限。
      PermissionCollection newPermissionCollection​()
      返回一个新的PermissionCollection对象，用于存储SocketPermission对象。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

    • 构造方法详细信息

      • SocketPermission

        public SocketPermission​(String host,
                        String action)
        使用指定的操作创建一个新的SocketPermission对象。 主机以DNS名称或数字IP地址表示。 可选地，可以提供端口或端口（通过冒号与DNS名称或IP地址分离）。

        要指定本地机器，请使用“localhost”作为主机 。 另请注意：空主机 String（“”）等同于“localhost”。

        actions参数包含为指定的主机（和端口）授予的操作的逗号分隔列表。 可能的行为是“连接”，“听”，“接受”，“解决”或其组合。 当指定其他三个中的任何一个时，将自动添加“resolve”。

        SocketPermission实例化示例如下：

          nr = new SocketPermission("www.catalog.com", "connect");
    nr = new SocketPermission("www.sun.com:80", "connect");
    nr = new SocketPermission("*.sun.com", "connect");
    nr = new SocketPermission("*.edu", "resolve");
    nr = new SocketPermission("204.160.241.0", "connect");
    nr = new SocketPermission("localhost:1024-65535", "listen");
    nr = new SocketPermission("204.160.241.0:1024-65535", "connect");
        参数
        host - 计算机的主机名或 host ，可选地包括冒号后跟端口或端口范围。
        action - 操作字符串。

    • 方法详细信息

      • implies

        public boolean implies​(Permission p)
        检查此套接字许可对象是否“暗示”指定的权限。

        更具体地说，该方法首先确保以下所有内容都是真实的（如果它们中没有一个则返回false）：

        • p是SocketPermission的一个实例，
        • p的动作是这个对象的动作的一个子集，
        • p的端口范围包含在此端口范围内。 注意：当p仅包含操作'resolve'时，将忽略端口范围。
        然后implies按顺序检查以下各项，如果所述条件为真，则每个返回true：
        • 如果该对象使用单个IP地址进行初始化， p的IP地址之一等于该对象的IP地址。
        • 如果此对象是通配符域（例如* .sun.com），并且p的规范名称（没有前面*的名称）以该对象的规范主机名结尾。 例如，* .sun.com意味着* .eng.sun.com。
        • 如果此对象未使用单个IP地址进行初始化，并且该对象的IP地址之一等于p的IP地址之一。
        • 如果这个规范名称等于p的规范名称。
        如果上述都不是， implies返回false。
        Specified by:
        implies在 Permission
        参数
        p - 允许检查。
        结果
        如果此对象隐含指定的权限，则为true，否则为false。

      • equals

        public boolean equals​(Object obj)
        检查两个SocketPermission对象是否相等。
        Specified by:
        equals在 Permission
        参数
        obj - 测试与此对象相等的对象。
        结果
        如果obj是SocketPermission，则为true，并且具有与此SocketPermission对象相同的主机名，端口范围和操作。 但是，如果obj只包含动作“resolve”，则在比较中忽略端口范围。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此对象的哈希码值。
        Specified by:
        hashCode在 Permission
        结果
        该对象的哈希码值。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions​()
        返回动作的规范字符串表示形式。 始终按以下顺序返回当前操作：连接，侦听，接受，解决。
        Specified by:
        getActions在 Permission
        结果
        规范字符串表示的动作。

      • newPermissionCollection

        public PermissionCollection newPermissionCollection​()
        返回一个新的PermissionCollection对象，用于存储SocketPermission对象。

        SocketPermission对象必须以允许以任何顺序插入到集合中的方式进行存储，但这也允许以有效（一致）的方式实现PermissionCollection implies方法。

        重写：
        newPermissionCollection在 Permission
        结果
        一个适用于存储SocketPermissions的新PermissionCollection对象。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


SocketTimeoutException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class SocketTimeoutException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.io.InterruptedIOException
            • java.net.SocketTimeoutException
  • All Implemented Interfaces:
    Serializable

    public class SocketTimeoutException
extends InterruptedIOException
    指示在套接字上发生超时时读取或接受。
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • Field Summary

      • Fields inherited from class java.io.InterruptedIOException

        bytesTransferred

    • 构造方法摘要

      构造方法
      Constructor 描述
      SocketTimeoutException​()
      构造一个新的SocketTimeoutException，没有详细的消息。
      SocketTimeoutException​(String msg)
      构造一个带有详细消息的新SocketTimeoutException。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • SocketTimeoutException

        public SocketTimeoutException​(String msg)
        构造一个带有详细消息的新SocketTimeoutException。
        参数
        msg - 详细信息

      • SocketTimeoutException

        public SocketTimeoutException​()
        构造一个新的SocketTimeoutException，没有详细的消息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


StandardProtocolFamily (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
Module java.base
软件包 java.net

Enum StandardProtocolFamily

  • java.lang.Object
    • java.lang.Enum<StandardProtocolFamily>
      • java.net.StandardProtocolFamily
  • All Implemented Interfaces:
    Serializable ， Comparable<StandardProtocolFamily> ， ProtocolFamily

    public enum StandardProtocolFamily
extends Enum<StandardProtocolFamily>
implements ProtocolFamily
    定义通信协议的标准系列。
    从以下版本开始：
    1.7

    • Enum Constant Summary

      Enum Constants
      Enum Constant 描述
      INET
      互联网协议版本4（IPv4）
      INET6
      互联网协议版本6（IPv6）

    • 方法摘要

      所有方法 静态方法 具体的方法
      Modifier and Type 方法 描述
      static StandardProtocolFamily valueOf​(String name)
      以指定的名称返回此类型的枚举常量。
      static StandardProtocolFamily[] values​()
      按照它们声明的顺序返回一个包含此枚举类型常量的数组。

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface java.net.ProtocolFamily

        name

    • Enum Constant Detail

      • INET

        public static final StandardProtocolFamily INET
        互联网协议版本4（IPv4）

      • INET6

        public static final StandardProtocolFamily INET6
        互联网协议版本6（IPv6）

    • 方法详细信息

      • values

        public static StandardProtocolFamily[] values​()
        按照它们声明的顺序返回一个包含此枚举类型常量的数组。 该方法可用于遍历常量如下：
          for (StandardProtocolFamily c : StandardProtocolFamily.values())
    System.out.println(c);
        结果
        一个包含这个枚举类型的常量的数组，按照它们被声明的顺序

      • valueOf

        public static StandardProtocolFamily valueOf​(String name)
        以指定的名称返回此类型的枚举常量。 字符串必须完全匹配用于声明此类型的枚举常量的标识符。 （不允许使用外来空白字符。）
        参数
        name - 要返回的枚举常量的名称。
        结果
        具有指定名称的枚举常数
        异常
        IllegalArgumentException - 如果此枚举类型没有指定名称的常量
        NullPointerException - 如果参数为空
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

Report a bug or suggest an enhancement


StandardSocketOptions (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class StandardSocketOptions

  • java.lang.Object
    • java.net.StandardSocketOptions

  • public final class StandardSocketOptions
extends Object
    定义标准套接字选项。

    由此类定义的每个套接字选项的name是其字段名称。

    在此版本中，这里定义的插座选项由使用network个在通道channels包。

    从以下版本开始：
    1.7

    • Field Summary

      Fields
      Modifier and Type Field 描述
      static SocketOption<NetworkInterface> IP_MULTICAST_IF
      互联网协议（IP）组播数据报的网络接口。
      static SocketOption<Boolean> IP_MULTICAST_LOOP
      互联网协议（IP）组播数据报的环回。
      static SocketOption<Integer> IP_MULTICAST_TTL
      互联网协议（IP）组播数据报 的生存时间 。
      static SocketOption<Integer> IP_TOS
      互联网协议（IP）头中的服务类型（ToS）八位字节。
      static SocketOption<Boolean> SO_BROADCAST
      允许传输广播数据报。
      static SocketOption<Boolean> SO_KEEPALIVE
      保持连接活着。
      static SocketOption<Integer> SO_LINGER
      如果数据存在，则关闭。
      static SocketOption<Integer> SO_RCVBUF
      套接字的大小接收缓冲区。
      static SocketOption<Boolean> SO_REUSEADDR
      重用地址。
      static SocketOption<Boolean> SO_REUSEPORT
      重新使用端口。
      static SocketOption<Integer> SO_SNDBUF
      套接字发送缓冲区的大小。
      static SocketOption<Boolean> TCP_NODELAY
      禁用Nagle算法。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • SO_BROADCAST

        public static final SocketOption<Boolean> SO_BROADCAST
        允许传输广播数据报。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 该选项特定于面向数据包的套接字发送到IPv4广播地址。 当套接字选项被启用时，套接字可以用于发送广播数据报 。

        此套接字选项的初始值为FALSE 。 套接字选项可以随时启用或禁用。 某些操作系统可能要求Java虚拟机启动具有实现特定权限以启用此选项或发送广播数据报。

        另请参见：
        RFC 929: Broadcasting Internet Datagrams ， DatagramSocket.setBroadcast(boolean)

      • SO_KEEPALIVE

        public static final SocketOption<Boolean> SO_KEEPALIVE
        保持连接活着。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 当启用SO_KEEPALIVE选项时，当连接否则空闲时，操作系统可以使用保持活动机制来周期性地探测连接的另一端。 保持活动机制的确切语义是系统依赖的，因此未指定。

        此套接字选项的初始值为FALSE 。 套接字选项可以随时启用或禁用。

        另请参见：
        RFC 1122 Requirements for Internet Hosts -- Communication Layers ， Socket.setKeepAlive(boolean)

      • SO_SNDBUF

        public static final SocketOption<Integer> SO_SNDBUF
        套接字发送缓冲区的大小。

        此套接字选项的值为Integer ，即套接字发送缓冲区的大小（以字节为单位）。 套接字发送缓冲区是由网络实现使用的输出缓冲区。 可能需要增加大容量连接。 套接字选项的值是实现缓冲区大小的一个暗示 ，实际大小可能不同。 可以查询套接字选项来检索实际大小。

        对于面向数据包的套接字，发送缓冲区的大小可能会限制套接字发送的数据报的大小。 是否发送或丢弃大于缓冲区大小的数据报与系统有关。

        套接字发送缓冲区的初始/默认大小和允许值的范围是系统依赖的，尽管不允许负数大小。 将套接字发送缓冲区设置为大于其最大大小的尝试将使其设置为其最大大小。

        一个实现允许在套接字绑定或连接之前设置此套接字选项。 一个实现是否允许在套接字绑定后更改套接字发送缓冲区是系统依赖的。

        另请参见：
        Socket.setSendBufferSize(int)

      • SO_RCVBUF

        public static final SocketOption<Integer> SO_RCVBUF
        套接字的大小接收缓冲区。

        此套接字选项的值为Integer ，即套接字接收缓冲区的大小（以字节为单位）。 套接字接收缓冲区是由网络实现使用的输入缓冲区。 对于大容量连接可能需要增加或减少以限制可能积压的输入数据。 套接字选项的值是实现缓冲区大小的一个暗示 ，实际大小可能不同。

        对于面向数据报的套接字，接收缓冲区的大小可能会限制可以接收的数据报的大小。 是否可以接收到大于缓冲区大小的数据报是系统依赖的。 增加套接字接收缓冲区可能对于数据报以比它们可以处理的更快的速度到达的情况很重要。

        在面向流的套接字和TCP / IP协议的情况下，当向远程对等体广告TCP接收窗口的大小时，可以使用套接字接收缓冲区的大小。

        套接字接收缓冲区的初始/默认大小和允许值的范围是系统依赖的，尽管不允许负数大小。 将套接字接收缓冲区设置为大于其最大大小的尝试将使其设置为其最大大小。

        一个实现允许在套接字绑定或连接之前设置此套接字选项。 一个实现是否允许在套接字绑定之后更改套接字接收缓冲区是系统依赖的。

        另请参见：
        RFC 1323: TCP Extensions for High Performance ， Socket.setReceiveBufferSize(int) ， ServerSocket.setReceiveBufferSize(int)

      • SO_REUSEADDR

        public static final SocketOption<Boolean> SO_REUSEADDR
        重用地址。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 此套接字选项的确切语义是套接字类型和系统相关。

        在面向流的套接字的情况下，当涉及该套接字地址的先前连接处于TIME_WAIT状态时，此套接字选项通常将决定套接字是否可以绑定到套接字地址。 在语义不同的实现中，并且不需要启用套接字选项以便在先前连接处于此状态时绑定套接字，则实现可能会选择忽略此选项。

        对于面向数据报的套接字，套接字选项用于允许多个程序绑定到相同的地址。 当套接字用于互联网协议（IP）组播时，应启用此选项。

        一个实现允许在套接字绑定或连接之前设置此套接字选项。 套接字绑定后更改此套接字选项的值不起作用。 此套接字选项的默认值与系统相关。

        另请参见：
        RFC 793: Transmission Control Protocol ， ServerSocket.setReuseAddress(boolean)

      • SO_REUSEPORT

        public static final SocketOption<Boolean> SO_REUSEPORT
        重新使用端口。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 此套接字选项的确切语义是套接字类型和系统相关。

        在面向流的套接字的情况下，此套接字选项通常允许多个监听套接字绑定到相同的地址和相同的端口。

        对于面向数据报的套接字，套接字选项通常允许多个UDP套接字绑定到相同的地址和端口。

        一个实现允许在套接字绑定或连接之前设置此套接字选项。 套接字绑定后更改此套接字选项的值不起作用。

        从以下版本开始：
        9

      • SO_LINGER

        public static final SocketOption<Integer> SO_LINGER
        如果数据存在，则关闭。

        此套接字选项的值为Integer ，用于控制未发送数据在套接字上排队时所采取的操作，并调用关闭套接字的方法。 如果套接字选项的值为零或更大，则表示超时值（以秒为单位），称为间隔时间间隔 。 close间隔是close方法在操作系统尝试发送未发送数据或者决定无法发送数据时阻止的超时。 如果套接字选项的值小于零，则禁用该选项。 在这种情况下， close方法不等待未发送的数据被发送; 如果可能，操作系统将在连接关闭之前传输任何未发送的数据。

        此套接字选项仅适用于仅在blocking模式下配置的套接字。 close在非阻塞套接字上启用此选项时， close方法的行为。

        此套接字选项的初始值为负值，表示该选项被禁用。 该选项可以在任何时间被启用，或延迟间隔更改。 滞后间隔的最大值取决于系统。 将逗留间隔设置为大于其最大值的值会导致延迟间隔被设置为其最大值。

        另请参见：
        Socket.setSoLinger(boolean, int)

      • IP_TOS

        public static final SocketOption<Integer> IP_TOS
        互联网协议（IP）头中的服务类型（ToS）八位字节。

        此套接字选项的值为Integer表示套接字发送到IPv4套接字的IP数据包中ToS字节的值。 ToS八位字节的解释是网络特定的，并没有被这个类定义。 有关ToS八位字节的更多信息，请参见RFC 1349和RFC 2474 。 套接字选项的值是一个提示 。 实现可以忽略该值，或忽略特定值。

        ToS字节中的TOS字段的初始值/默认值是实现特定的，但通常为0 。 对于面向数据报的套接字，可以在套接字绑定后随时配置该选项。 在发送后续数据报时，会使用八位字节的新值。 系统是否依赖此选项是否可以在绑定套接字之前查询或更改。

        此版本中未定义面向流的套接字或IPv6套接字上的此套接字选项的行为。

        另请参见：
        DatagramSocket.setTrafficClass(int)

      • IP_MULTICAST_IF

        public static final SocketOption<NetworkInterface> IP_MULTICAST_IF
        互联网协议（IP）组播数据报的网络接口。

        此套接字选项的值为NetworkInterface ，表示由面向数据报的套接字发送的组播数据报的出站接口。 对于IPv6套接字，则依赖于系统是否设置此选项也设置发送到IPv4地址的组播数据报的出接口。

        此套接字选项的初始值/默认值可能为null ，表示操作系统将通常基于网络路由表选择输出接口。 一个实现允许在套接字绑定后设置此套接字选项。 系统依赖于套接字选项是否可以在绑定套接字之前进行查询或更改。

        另请参见：
        MulticastChannel ， MulticastSocket.setInterface(java.net.InetAddress)

      • IP_MULTICAST_TTL

        public static final SocketOption<Integer> IP_MULTICAST_TTL
        互联网协议（IP）组播数据报的生存时间 。

        此套接字选项的值是Integer范围内的0 <= value <= 255 。 它用于控制由面向数据报的套接字发送的组播数据报的范围。 在IPv4套接字的情况下，该选项是套接字发送的组播数据报的生存时间（TTL）。 TTL为零的数据报不会在网络上传输，但可能在本地传送。 在IPv6套接字的情况下，该选项是跳数限制 ，它是数据报可以在网络到期之前通过的跳数 。 对于IPv6套接字，系统依赖于该选项是否也设置发送到IPv4地址的组播数据报上的生存时间。

        生存时间设置的初始值/默认值通常为1 。 一个实现允许在套接字绑定后设置此套接字选项。 系统依赖于套接字选项是否可以在绑定套接字之前进行查询或更改。

        另请参见：
        MulticastChannel ， MulticastSocket.setTimeToLive(int)

      • IP_MULTICAST_LOOP

        public static final SocketOption<Boolean> IP_MULTICAST_LOOP
        互联网协议（IP）组播数据报的环回。

        该套接字选项的值是一个Boolean ，它控制组播数据报的环回 。 套接字选项的值表示该选项是启用还是禁用。

        此套接字选项的确切语义与系统相关。 特别地，系统是否依赖于环回是否适用于从套接字发送或由套接字接收的组播数据报。 对于IPv6套接字，则系统依赖于该选项是否也适用于发送到IPv4地址的组播数据报。

        此套接字选项的初始值/默认值为TRUE 。 一个实现允许在套接字绑定后设置此套接字选项。 系统依赖于套接字选项是否可以在绑定套接字之前进行查询或更改。

        另请参见：
        MulticastChannel ， MulticastSocket.setLoopbackMode(boolean)

      • TCP_NODELAY

        public static final SocketOption<Boolean> TCP_NODELAY
        禁用Nagle算法。

        此套接字选项的值为Boolean ，表示该选项是启用还是禁用。 套接字选项特定于使用TCP / IP协议的面向流的套接字。 TCP / IP使用称为Nagle算法的算法来聚合短片段并提高网络效率。

        此套接字选项的默认值为FALSE 。 只有在已知聚结影响性能的情况下，才能启用套接字选项。 可以随时启用套接字选项。 换句话说，Nagle算法可以被禁用。 启用该选项后，系统是否可以随后禁用。 如果不能，那么调用setOption方法来禁用该选项就没有效果。

        另请参见：
        RFC 1122: Requirements for Internet Hosts -- Communication Layers ， Socket.setTcpNoDelay(boolean)
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • Field |
  • 构造方法 |
  • 方法
  • 详细信息：
  • Field |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnknownHostException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class UnknownHostException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.UnknownHostException
  • All Implemented Interfaces:
    Serializable

    public class UnknownHostException
extends IOException
    抛出以表示无法确定主机的IP地址。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownHostException​()
      构造一个新的 UnknownHostException ，没有详细信息。
      UnknownHostException​(String message)
      构造一个新的 UnknownHostException具有指定的详细消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownHostException

        public UnknownHostException​(String message)
        构造一个新的 UnknownHostException具有指定的详细信息。
        参数
        message - 详细信息。

      • UnknownHostException

        public UnknownHostException​()
        构造一个新的 UnknownHostException ，没有详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


UnknownServiceException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class UnknownServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.net.UnknownServiceException
  • All Implemented Interfaces:
    Serializable

    public class UnknownServiceException
extends IOException
    抛出以表示发生未知服务异常。 URL连接返回的MIME类型无效，或者应用程序正在尝试写入只读URL连接。
    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      UnknownServiceException​()
      构造一个新的 UnknownServiceException没有详细信息。
      UnknownServiceException​(String msg)
      构造一个新的 UnknownServiceException具有指定的详细消息。

    • 方法摘要

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • UnknownServiceException

        public UnknownServiceException​()
        构造一个新的 UnknownServiceException ，没有详细信息。

      • UnknownServiceException

        public UnknownServiceException​(String msg)
        构造一个新的 UnknownServiceException具有指定的详细消息。
        参数
        msg - 详细信息。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


URI (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URI

  • java.lang.Object
    • java.net.URI
  • All Implemented Interfaces:
    Serializable ， Comparable<URI>

    public final class URI
extends Object
implements Comparable<URI>, Serializable
    表示统一资源标识符（URI）参考。

    除了下面指出的一些微小偏差，这个类的一个实例表示由所定义的URI引用RFC 2396: Uniform Resource Identifiers (URI): Generic Syntax ，通过修正RFC 2732: Format for Literal IPv6 Addresses in URLs 。 文字IPv6地址格式也支持scope_ids。 scope_ids的语法和用法描述为here 。 该类提供了用于从其组件创建URI实例或通过解析其字符串表单，访问实例的各种组件的方法以及用于归一化，解析和相对化URI实例的方法的构造函数。 这个类的实例是不可变的。

    URI语法和组件

    在最高级别，字符串形式的URI引用（以下简称为“URI”）具有语法
    [ scheme :] scheme-specific-part[ # fragment]
    其中方括号[...]描绘可选组件，字符:和#代表自己。

    绝对 URI指定方案; 一个不是绝对的URI被认为是相对的 。 URI也根据它们是不透明还是分层次分类 。

    不透明 URI是一个绝对URI，其特定于方案的部分不以斜杠字符开头（ '/' ）。 不透明的URI不需要进一步解析。 不透明URI的一些示例是：

    • mailto:java-net@java.sun.com
    • news:comp.lang.java
    • urn:isbn:096139210x

    分层 URI是绝对URI，其方案特定部分以斜杠字符开头，或相对URI，即不指定方案的URI。 分层URI的一些示例是：

    http://example.com/languages/java/
    sample/a/index.html#28
    ../../demo/b/index.html
    file:///~/calendar

    分层URI根据语法进行进一步解析

    [ scheme :][ // authority][ path][ ? query][ # fragment]
    里的人物: ， / ， ? ，并#代表它们自身。 分层URI的方案特定部分由方案和片段组件之间的字符组成。

    如果指定了分层URI的权限组件，则基于服务器或基于 注册表 。 基于服务器的权限根据熟悉的语法进行分析

    [ user-info @] host[ : port]
    字符@和:代表自己。 目前使用的几乎所有URI方案都是基于服务器的。 不以这种方式解析的权限组件被认为是基于注册表的。

    如果分层URI的路径组件以斜杠字符（ '/' ）开始，则它本身被称为绝对路径组件; 否则是相对的。 绝对的或指定权限的分层URI的路径总是绝对的。

    总而言之，一个URI实例有以下九个组件：

    Describes the components of a URI:scheme,scheme-specific-part,authority,user-info,host,port,path,query,fragment
    Component | Type
    scheme | String
    scheme-specific-part | String
    authority | String
    user-info | String
    host | String
    port | int
    path | String
    query | String
    fragment | String
    在给定的实例中，任何特定的组件是未定义的或者用不同的值定义 。 未定义的字符串组件由null表示，而未定义的整数组件由-1表示。 可以将字符串组件定义为将空字符串作为其值; 这不等于该组件未定义。

    特定组件是否在实例中定义取决于所表示的URI的类型。 绝对URI具有方案组件。 不透明URI具有方案，方案特定部分和可能的片段，但没有其他组件。 分层URI总是具有路径（虽然它可以是空的）和方案特定部分（至少包含路径），并且可以具有任何其他组件。 如果权限组件存在并且基于服务器，则将定义主机组件，并且可以定义用户信息和端口组件。

    URI实例的操作

    这一类支持的关键操作是规范化 ， 解决和相对化 。

    归一化是从分层URI的路径组件中删除不必要的"."和".."段的过程。 每个"."段都被简单地删除。 A ".."段仅在前面带有非".."段时被删除。 规范化对不透明的URI没有影响。

    分辨率是对另一个解决一个URI的过程中， 基本 URI。 生成的URI由RFC 2396指定的方式由两个URI的组件构成，从原始URI中未指定的基本URI获取组件。 对于分层URI，原始路径将根据基础路径进行解析，然后进行归一化。 结果，例如，解决

    sample/a/index.html#28 (1)
    对于基础URI http://example.com/languages/java/是结果URI
    http://example.com/languages/java/sample/a/index.html#28
    解析相对URI
    ../../demo/b/index.html (2)
    反过来，
    http://example.com/languages/java/demo/b/index.html
    支持绝对和相对URI的分辨率，以及分层URI情况下的绝对路径和相对路径的分辨率。 对任何其他URI解析URI file:///~calendar只是产生原始URI，因为它是绝对的。 解析相对URI（2）相对于相对基本URI（1）产生归一化但仍然相对的URI
    demo/b/index.html

    相对论最后是分辨率的倒数：对于任何两个归一化的URI u和v ，

    u .relativize( u .resolve( v )).equals( v ) and
    u .resolve( u .relativize( v )).equals( v ) .
    在可能的情况下，构建包含必须相对于文档的基本URI的URI的文档时，此操作通常很有用。 例如，相对于URI
    http://example.com/languages/java/sample/a/index.html#28
    针对基本URI
    http://example.com/languages/java/
    产生相对URI sample/a/index.html#28 。

    字符类别

    RFC 2396精确地指定在URI引用的各种组件中允许哪些字符。 以下类别，大部分来自该规范，在下面用于描述这些约束：
    Describes categories alpha,digit,alphanum,unreserved,punct,reserved,escaped,and other
    alpha | The US-ASCII alphabetic characters, 'A' through 'Z' and 'a' through 'z'
    digit | The US-ASCII decimal digit characters, '0' through '9'
    alphanum | All alpha and digit characters
    unreserved | All alphanum characters together with those in the string "_-!.~'()*"
    punct | The characters in the string ",;:$&+="
    reserved | All punct characters together with those in the string "?/[]@"
    escaped | Escaped octets, that is, triplets consisting of the percent character ('%') followed by two hexadecimal digits ('0'-'9', 'A'-'F', and 'a'-'f')
    other | The Unicode characters that are not in the US-ASCII character set, are not control characters (according to the Character.isISOControl method), and are not space characters (according to the Character.isSpaceChar method) (Deviation from RFC 2396, which is limited to US-ASCII)

    所有合法URI字符集由未保留 ， 保留 ， 转义和其他字符组成。

    转义八位字节，引号，编码和解码

    RFC 2396允许转义的八位字节出现在用户信息，路径，查询和片段组件中。 转义在URI中有两个目的：

    • 当URI需要严格遵守RFC 2396时不包含任何其他字符，以对非US-ASCII字符进行编码 。

    • 引用组件中其他非法的字符。 用户信息，路径，查询和片段组件在哪些角色被视为合法和非法的情况下略有不同。

    这些目的通过三个相关的操作在这个课程中提供：

    • 通过用UTF-8字符集中代表该字符的转义八位字节序列替换字符进行编码 。 例如，欧元货币符号（ '\u20AC' ）编码为"%E2%82%AC" 。 （ 偏离RFC 2396 ，不指定任何特定字符集。）

    • 非法字符简单地通过编码引用 。 例如，空格字符被替换为"%20"引用。 UTF-8包含US-ASCII，因此对于US-ASCII字符，此转换完全符合RFC 2396所要求的效果。

    • 通过用UTF-8字符集中表示的字符序列替换转义的八位字节序列来解码 。 UTF-8包含US-ASCII，因此解码具有取消引用任何引用的US-ASCII字符以及解码任何编码的非US-ASCII字符的解码效果。 如果decoding error解码转义八位组，则错误的八位位组被更换时发生'\uFFFD' ，Unicode替换字符。

    这些操作在此类的构造函数和方法中暴露如下：

    • single-argument constructor要求引用其参数中的任何非法字符，并保留任何转义的八位字节和其他存在的字符。

    • multi-argument constructors根据其出现的组件的要求引用非法字符。 百分比字符（ '%' ）始终由这些构造函数引用。 任何其他字符都被保留。

    • 的getRawUserInfo ， getRawPath ， getRawQuery ， getRawFragment ， getRawAuthority和getRawSchemeSpecificPart方法返回原始形式及其相应的分量的值，而不用解释任何转义八位组。 这些方法返回的字符串可能包含转义的八位字节和其他字符，并且不会包含任何非法字符。

    • 的getUserInfo ， getPath ， getQuery ， getFragment ， getAuthority和getSchemeSpecificPart方法解码任何逃脱在它们的对应部件的八位字节。 这些方法返回的字符串可能包含其他字符和非法字符，并且不会包含任何转义的八位字节。

    • toString方法返回一个包含所有必要引号的URI字符串，但可能包含其他字符。

    • toASCIIString方法返回一个不包含任何其他字符的完全引用和编码的URI字符串。

    身份

    对于任何URI U，它始终是情况
    new URI( u .toString()).equals( u ) .
    对于任何URIÜ不包含一个空的机构（如在之前的冗余语法如两个斜杠file:///tmp/以下一个主机名，但没有端口（如在）或冒号http://java.sun.com: ），并且不除了那些必须是字符进行编码引用，以下身份也符合：
      new URI(u.getScheme(),
             u.getSchemeSpecificPart(),
             u.getFragment())
     .equals(u)
    在所有情况下，
      new URI(u.getScheme(),
             u.getAuthority(),
             u.getPath(), u.getQuery(),
             u.getFragment())
     .equals(u)
    如果你是分层的，和
      new URI(u.getScheme(),
             u.getUserInfo(), u.getHost(), u.getPort(),
             u.getPath(), u.getQuery(),
             u.getFragment())
     .equals(u)
    如果u是分层的，并且没有权限或基于服务器的权限。

    URI，URL和URN

    URI是统一的资源标识符，而URL是统一的资源定位符 。 因此，每个URL都是一个URI，而不是每个URI都是URL。 这是因为还有另一个URI类别，统一资源名称 （URN），它们命名资源但不指定如何定位它们。 的mailto ， news ，和isbn上面所示URI是的URN的例子。

    URI和URL之间的概念区别反映在此类与URL类之间的差异中。

    该类的实例表示RFC 2396定义的句法意义中的URI引用。URI可以是绝对的或相对的。 根据通用语法解析URI字符串，而不考虑它指定的方案（如果有的话）。 不执行主机的查找（如果有的话），并且不构造与方案相关的流处理程序。 平等，散列和比较严格按照实例的字符内容进行定义。 换句话说，一个URI实例只是一个结构化的字符串，它支持语法，方案无关的比较，归一化，分辨率和相对性化的操作。

    相比之下， URL类的一个实例表示URL的句法组件以及访问其描述的资源所需的某些信息。 URL必须是绝对的，也就是说，它必须始终指定一个方案。 根据其方案解析URL字符串。 始终为URL建立流处理程序，实际上不可能为没有处理程序可用的方案创建一个URL实例。 平等和散列取决于主机的方案和互联网地址（如果有的话）; 比较没有定义。 换句话说，URL是一个结构化字符串，支持分辨率的语法操作以及查找主机并打开与指定资源的连接的网络I / O操作。

    从以下版本开始：
    1.4
    另请参见：
    RFC 2279: UTF-8, a transformation format of ISO 10646 ，
    RFC 2373: IPv6 Addressing Architecture ，
    RFC 2396: Uniform Resource Identifiers (URI): Generic Syntax ，
    RFC 2732: Format for Literal IPv6 Addresses in URLs ，
    URISyntaxException ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      URI​(String str)
      通过解析给定的字符串构造一个URI。
      URI​(String scheme, String ssp, String fragment)
      从给定的组件构造一个URI。
      URI​(String scheme, String userInfo, String host, int port, String path, String query, String fragment)
      从给定的组件构造一个分层URI。
      URI​(String scheme, String host, String path, String fragment)
      从给定的组件构造一个分层URI。
      URI​(String scheme, String authority, String path, String query, String fragment)
      从给定的组件构造一个分层URI。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int compareTo​(URI that)
      将此URI与另一个对象进行比较，该对象必须是URI。
      static URI create​(String str)
      通过解析给定的字符串创建一个URI。
      boolean equals​(Object ob)
      测试此URI以与另一个对象相等。
      String getAuthority​()
      返回此URI的已解码权限组件。
      String getFragment​()
      返回此URI的解码片段组件。
      String getHost​()
      返回此URI的主机组件。
      String getPath​()
      返回此URI的解码路径组件。
      int getPort​()
      返回此URI的端口号。
      String getQuery​()
      返回此URI的解码查询组件。
      String getRawAuthority​()
      返回此URI的原始权限组件。
      String getRawFragment​()
      返回此URI的原始片段组件。
      String getRawPath​()
      返回此URI的原始路径组件。
      String getRawQuery​()
      返回此URI的原始查询组件。
      String getRawSchemeSpecificPart​()
      返回此URI的原始方案特定部分。
      String getRawUserInfo​()
      返回此URI的原始用户信息组件。
      String getScheme​()
      返回此URI的方案组件。
      String getSchemeSpecificPart​()
      返回此URI的解码方案特定部分。
      String getUserInfo​()
      返回此URI的解码的用户信息组件。
      int hashCode​()
      返回此URI的哈希码值。
      boolean isAbsolute​()
      告诉这个URI是否是绝对的。
      boolean isOpaque​()
      告知这个URI是否不透明。
      URI normalize​()
      规范此URI的路径。
      URI parseServerAuthority​()
      尝试将此URI的权限组件（如果已定义）解析为用户信息，主机和端口组件。
      URI relativize​(URI uri)
      相对于此URI的给定URI。
      URI resolve​(String str)
      通过解析给定的字符串构造一个新的URI，然后根据此URI进行解析。
      URI resolve​(URI uri)
      根据此URI解析给定的URI。
      String toASCIIString​()
      将此URI的内容作为US-ASCII字符串返回。
      String toString​()
      以字符串形式返回此URI的内容。
      URL toURL​()
      从此URI构造一个URL。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • URI

        public URI​(String str)
    throws URISyntaxException
        通过解析给定的字符串构造一个URI。

        该构造函数完全按照RFC 2396附录A中的语法所指定的字符串进行解析， 但以下偏差除外：

        • 只要后面跟着非空路径，查询组件或片段组件，就允许使用空的权限组件。 这样就可以解析诸如"file:///foo/bar"这样的URI，尽管语法不允许它，但似乎是RFC 2396的意图。 如果权限组件为空，则用户信息，主机和端口组件未定义。

        • 允许空的相对路径; 这似乎是RFC 2396的意图，尽管语法不允许。 这种偏离的主要后果是，诸如"#foo"类的独立片段将解析为具有空路径和给定片段的相对URI，并且对基本URI可以有用地为resolved 。

        • 主机组件中的IPv4地址被严格地解析，如RFC 2732所指定的： 虚拟地址的每个元素必须包含不超过三位十进制数字。 每个元素被进一步限制为不大于255的值。

        • 仅包含单个域标签的主机组件中的主机名允许以字母字符开头。 这似乎是RFC 2396第3.2.2节的意图，尽管语法不允许它。 这种偏差的后果是分层URI（如s://123的权限组件将解析为基于服务器的权限。

        • 主机组件允许IPv6地址。 IPv6地址必须由RFC 2732所指定的方括号（ '['和']' ） 括起来 。 IPv6地址本身必须根据RFC 2373进行解析。 IPv6地址被进一步限制为描述不超过十六个字节的地址信息，RFC 2373中隐含的约束，但在语法中不能表达。

        • 在RFC 2396允许转义的八位字节（即用户信息，路径，查询和片段组件）以及权限组件（如果权限是基于注册表的）中，则允许其他类别中的字符。 这允许URI包含除US-ASCII字符集之外的Unicode字符。

        参数
        str - 要解析为URI的字符串
        异常
        NullPointerException - 如果 str是 null
        URISyntaxException - 如果给定的字符串违反RFC 2396，则由上述偏差所增加

      • URI

        public URI​(String scheme,
           String userInfo,
           String host,
           int port,
           String path,
           String query,
           String fragment)
    throws URISyntaxException
        从给定的组件构造一个分层URI。

        如果给出了一个方案，那么路径（如果也是给定的）必须是空的，或者以斜杠字符开头（ '/' ）。 否则，通过传递null相应的参数，或者在port参数的情况下，通过传递-1可能不定义新URI的组件。

        此构造函数首先根据RFC 2396第5.2节第7步中规定的规则从给定的组件生成URI字符串：

        1. 最初，结果字符串为空。

        2. 如果给出了一个方案，那么它将被附加到结果后跟一个冒号字符（ ':' ）。

        3. 如果给出用户信息，主机或端口，则附加字符串"//" 。

        4. 如果给出了用户信息，则会附加用户信息，后跟广告字符（ '@' ）。 任何字符不是在毫无保留的 ，PUNCT， 逃脱 ，或其他类别为quoted 。

        5. 如果给出主机，那么它被附加。 如果主机是一个文字的IPv6地址，但不包含在方括号（ '['和']' ）中，则会添加方括号。

        6. 如果给出端口号，则附加冒号字符（ ':' ），后跟端口号以十进制形式。

        7. 如果给出一个路径，那么它被附加。 引用了不保留 ， 标点 ， 转义或其他类别，不等于斜杠字符（ '/' ）或商业字符（ '@' ）的任何字符。

        8. 如果给出了一个查询，则附加一个问号字符（ '?' ），后跟查询。 任何不是legal URI character的字符均被引用。

        9. 最后，如果给出了一个片段，则附加一个散列字符（ '#' ），后跟片段。 引用不符合法定URI字符的任何字符。

        然后，结果URI字符串将被解析为通过调用URI(String)构造函数，然后根据结果调用parseServerAuthority()方法; 这可能会导致抛出URISyntaxException 。

        参数
        scheme - 方案名称
        userInfo - 用户名和授权信息
        host - 主机名
        port - 端口号
        path - 路径
        query - 查询
        fragment - 片段
        异常
        URISyntaxException - 如果给定方案和路径，但路径是相对的，如果从给定组件构造的URI字符串违反RFC 2396，或者如果字符串的权限组件存在但不能被解析为基于服务器的权限

      • URI

        public URI​(String scheme,
           String authority,
           String path,
           String query,
           String fragment)
    throws URISyntaxException
        从给定的组件构造一个分层URI。

        如果给出一个方案，那么如果给定的路径必须为空，或者用斜杠字符开头（ '/' ）。 否则，通过传递null相应的参数，新URI的组件可能未定义。

        该构造函数首先根据RFC 2396第5.2节第7步中规定的规则从给定的组件生成URI字符串：

        1. 最初，结果字符串为空。

        2. 如果给出一个方案，那么它将被附加到结果，后跟一个冒号字符（ ':' ）。

        3. 如果给出"//"则追加字符串"//" ，后跟权限。 如果权限包含文字IPv6地址，那么地址必须用方括号（ '['和']' ）括起来。 任何不在未保留 ， 标点 ， 转义或其他类别中的字符，不等于商业字符（ '@' ）的字符为quoted 。

        4. 如果给出一个路径，那么它被附加。 任何字符不是在毫无保留的 ，PUNCT， 逃脱 ，或其他类别，以及不等于斜线字符（ '/' ）或商用的字符（ '@' ），是引用。

        5. 如果给出查询，则附加一个问号字符（ '?' ），后跟该查询。 任何不是legal URI character的字符均被引用。

        6. 最后，如果给出一个片段，则附加一个散列字符（ '#' ），然后是片段。 引用不符合法定URI字符的任何字符。

        结果URI字符串的解析就好像是通过调用URI(String)构造函数，然后根据结果调用parseServerAuthority()方法; 这可能会导致抛出URISyntaxException 。

        参数
        scheme - 方案名称
        authority - 权限
        path - 路径
        query - 查询
        fragment - 片段
        异常
        URISyntaxException - 如果给定方案和路径，但路径是相对的，如果从给定组件构造的URI字符串违反RFC 2396，或者如果字符串的权限组件存在但不能被解析为基于服务器的权限

      • URI

        public URI​(String scheme,
           String host,
           String path,
           String fragment)
    throws URISyntaxException
        从给定的组件构造一个分层URI。

        一个组件可能通过传递null未定义。

        这个方便的构造函数就像调用七参数构造函数一样工作，如下所示：

        new URI (scheme, null, host, -1, path, null, fragment);
        参数
        scheme - 方案名称
        host - 主机名
        path - 路径
        fragment - 片段
        异常
        URISyntaxException - 如果从给定组件构造的URI字符串违反RFC 2396

      • URI

        public URI​(String scheme,
           String ssp,
           String fragment)
    throws URISyntaxException
        从给定的组件构造一个URI。

        一个组件可能通过传递null未定义。

        此构造函数首先使用给定的组件以字符串形式构建一个URI，如下所示：

        1. 最初，结果字符串为空。

        2. 如果给出一个方案，那么它将被附加到结果，后跟一个冒号字符（ ':' ）。

        3. 如果给出了一个方案特定的部分，那么它被附加。 任何不是legal URI character的字符都是quoted 。

        4. 最后，如果给出了一个片段，那么一个散列字符（ '#' ）被附加到字符串，后跟片段。 引用不符合法定URI字符的任何字符。

        然后解析生成的URI字符串，以便通过调用URI(String)构造函数来创建新的URI实例; 这可能会导致URISyntaxException被抛出。

        参数
        scheme - 方案名称
        ssp - 方案特定部分
        fragment - 片段
        异常
        URISyntaxException - 如果从给定组件构造的URI字符串违反RFC 2396

    • 方法详细信息

      • create

        public static URI create​(String str)
        通过解析给定的字符串创建一个URI。

        这种方便的工厂方法好像通过调用URI(String)构造函数; 任何由构造函数抛出的URISyntaxException被捕获并包裹在一个新的IllegalArgumentException对象中，然后抛出该对象。

        该方法被提供用于已知给定字符串是合法URI的情况，例如对于在程序中声明的URI常量，因此它将被视为不解析的字符串的编程错误。 使用直接抛出URISyntaxException的构造函数应该用于使用用户输入或可能容易发生错误的其他源构建URI的情况。

        参数
        str - 要解析为URI的字符串
        结果
        新的URI
        异常
        NullPointerException - 如果 str是 null
        IllegalArgumentException - 如果给定的字符串违反RFC 2396

      • parseServerAuthority

        public URI parseServerAuthority​()
                         throws URISyntaxException
        尝试将此URI的权限组件（如果已定义）解析为用户信息，主机和端口组件。

        如果该URI的权限组件已经被识别为基于服务器的组件，那么它已经被解析为用户信息，主机和端口组件。 在这种情况下，或者如果此URI没有权限组件，则此方法只返回此URI。

        否则，此方法再次尝试将权限组件解析为用户信息，主机和端口组件，并抛出一个异常，描述为什么无法以这种方式解析权限组件。

        提供这种方法是因为在RFC 2396中指定的通用URI语法不能总是将基于服务器的权限与基于注册表的权限合法。 因此，它必须将前者的一些实例视为后者的实例。 例如，URI字符串"//foo:bar"的权限组件不是合法的基于服务器的权限，但它作为基于注册表的权限是合法的。

        在许多常见情况下，例如，当工作已知是URN或URL的URI时，所使用的分层URI将始终是基于服务器的。 因此，它们必须被解析为或被视为错误。 在这些情况下，如

        URI u = new URI(str).parseServerAuthority();

        可以用于确保u始终引用一个URI，如果它具有权限组件，则具有适当的用户信息，主机和端口组件的基于服务器的权限。 调用此方法还可确保如果无法以该方式解析权限，则可以基于抛出的异常发出适当的诊断消息。

        结果
        其权限字段已被解析为基于服务器的权限的URI
        异常
        URISyntaxException - 如果此URI的权限组件被定义，但根据RFC 2396不能被解析为基于服务器的权限

      • normalize

        public URI normalize​()
        规范此URI的路径。

        如果该URI是不透明的，或者如果其路径已经是正常形式，则返回此URI。 否则，构造与该URI相同的新URI，除了通过以符合RFC 2396 ，第5.2节，步骤6，子步骤c至f的方式归一化该URI的路径来计算其路径; 那是：

        1. 全部删除"."段。

        2. 如果一个".."段前面有一个非".."段，那么这两个段都被删除。 重复此步骤直到不再适用。

        3. 如果路径是相对的，并且如果其第一个段包含冒号字符（ ':' ），则会添加一个"."段。 这样可以防止具有诸如"a:b/c/d"的路径的相对URI稍后被重新解析为具有方案"a"和方案专用部分"b/c/d"的不透明URI。 （偏离RFC 2396）

        如果在它们之前没有足够的非".."段以允许其移除，则归一化路径将从一个或多个".."段开始。 如果通过上面的步骤3插入了标准化路径，则将以"."段开头。 否则，归一化路径将不包含任何"."或".."段。

        结果
        与此URI相当的URI，但其路径为正常形式

      • resolve

        public URI resolve​(URI uri)
        根据此URI解析给定的URI。

        如果给定的URI已经是绝对的，或者这个URI是不透明的，那么返回给定的URI。

        如果定义了给定的URI的片段组件，则其路径组件为空，并且其方案，权限和查询组件未定义，则返回具有给定片段但具有与此URI相同的所有其他组件的URI。 这允许代表独立片段引用的URI（例如"#foo"有效地针对基本URI进行解析。

        否则，该方法将以符合RFC 2396 5.2节的方式构建新的分层URI; 那是：

        1. 使用此URI的方案和给定的URI的查询和片段组件构建一个新的URI。

        2. 如果给定的URI具有一个权限组件，那么新的URI的权限和路径将从给定的URI中获取。

        3. 否则，将从该URI复制新的URI的权限组件，其路径计算如下：

          1. 如果给定的URI的路径是绝对的，那么新的URI的路径是从给定的URI中获取的。

          2. 否则给定的URI的路径是相对的，因此，通过根据该URI的路径解析给定URI的路径来计算新的URI的路径。 这是通过将URI的路径（如果有的话）的所有除了最后一个段与所给定的URI的路径相连 ，然后将结果归一化，就像调用normalize方法一样。

        这个方法的结果是绝对的，只有这个URI是绝对的或给定的URI是绝对的。

        参数
        uri - 要针对此URI解析的URI
        结果
        生成的URI
        异常
        NullPointerException - 如果 uri是 null

      • resolve

        public URI resolve​(String str)
        通过解析给定的字符串构造一个新的URI，然后根据此URI进行解析。

        这种方便的方法就像调用它相当于评估表达式resolve (URI. create (str)) 。

        参数
        str - 要解析为URI的字符串
        结果
        生成的URI
        异常
        NullPointerException - 如果 str是 null
        IllegalArgumentException - 如果给定的字符串违反RFC 2396

      • relativize

        public URI relativize​(URI uri)
        相对于此URI的给定URI。

        给定URI相对于该URI的相对性计算如下：

        1. 如果这个URI或给定的URI是不透明的，或者两个URI的方案和权限组件不相同，或者如果该URI的路径不是给定URI的路径的前缀，则给定的URI是回。

        2. 否则，使用从给定URI获取的查询和片段组件以及通过从给定的URI的路径的开头移除该URI的路径而计算的路径组件来构建新的相对分层URI。

        参数
        uri - 相对于此URI的URI
        结果
        生成的URI
        异常
        NullPointerException - 如果 uri是 null

      • toURL

        public URL toURL​()
          throws MalformedURLException
        从此URI构造一个URL。

        这种便利方法的工作原理就像调用它相当于首先检查此URI是绝对值后，评估表达式new URL(this.toString()) 。

        结果
        由此URI构造的URL
        异常
        IllegalArgumentException - 如果此URL不是绝对的
        MalformedURLException - 如果无法找到URL的协议处理程序，或者在构建URL时发生其他错误

      • getScheme

        public String getScheme​()
        返回此URI的方案组件。

        URI的方案组件（如果已定义）仅包含字母类别和字符串"-.+"中的字符。 方案始终以字母字符开头。

        URI的方案组件不能包含转义的八位字节，因此此方法不执行任何解码。

        结果
        该URI的方案组件，如果方案未定义， null

      • isAbsolute

        public boolean isAbsolute​()
        告诉这个URI是否是绝对的。

        一个URI是绝对的，只有当它有一个方案组件。

        结果
        true如果，只有这个URI是绝对的

      • isOpaque

        public boolean isOpaque​()
        告知这个URI是否不透明。

        一个URI是不透明的，如果且仅当它是绝对的，并且其特定于方案的部分不以斜杠字符（'/'）开头。 不透明URI具有方案，方案特定部分和可能的片段; 所有其他组件未定义。

        结果
        true如果，只有这个URI是不透明的

      • getRawSchemeSpecificPart

        public String getRawSchemeSpecificPart​()
        返回此URI的原始方案特定部分。 方案特定的部分永远不会被定义，尽管它可能是空的。

        URI的方案特定部分只包含合法的URI字符。

        结果
        该URI的原始方案特定部分（从不 null ）

      • getSchemeSpecificPart

        public String getSchemeSpecificPart​()
        返回此URI的解码方案特定部分。

        该方法返回的字符串与getRawSchemeSpecificPart方法返回的字符串相同，只是转义的八位字节的所有序列都为decoded 。

        结果
        该URI的解码方案特定部分（从不 null ）

      • getRawAuthority

        public String getRawAuthority​()
        返回此URI的原始权限组件。

        URI的权限组件（如果已定义）只包含商业字符（ '@' ）和未保留 ， 标点 ， 转义和其他类别中的字符。 如果权限是基于服务器的，则进一步限制为具有有效的用户信息，主机和端口组件。

        结果
        该URI的原始权限组件，如果权限未定义， null

      • getAuthority

        public String getAuthority​()
        返回此URI的已解码权限组件。

        该方法返回的字符串与getRawAuthority方法返回的字符串相同，只是转义的八位字节的所有序列都为decoded 。

        结果
        该URI的解码权限组件，如果权限未定义， null

      • getRawUserInfo

        public String getRawUserInfo​()
        返回此URI的原始用户信息组件。

        URI的用户信息组件（如果已定义）仅包含未保留 ， 标记 ， 转义和其他类别中的字符。

        结果
        该URI的原始用户信息组件，如果用户信息未定义， null

      • getUserInfo

        public String getUserInfo​()
        返回此URI的解码的用户信息组件。

        该方法返回的字符串与getRawUserInfo方法返回的字符串相同，只是转义的八位字节的所有序列都为decoded 。

        结果
        该URI的解码的用户信息组件，如果用户信息未定义， null

      • getHost

        public String getHost​()
        返回此URI的主机组件。

        URI的主机组件（如果已定义）将具有以下形式之一：

        • 由一个或多个由句点字符（ '.' ）分隔的标签组成的域名，可选地后跟一个句点字符。 每个标签由字母字母和连字符（ '-' ）组成，尽管连字符不会作为标签中的第一个或最后一个字符出现。 由两个或多个标签组成的域名的最右标签以字母字符开头。

        • 形式数字 +. 数字 +. 数字 +. 数字 +的四边形IPv4地址，其中没有数字序列长于三个字符，没有序列的值大于255。

        • 一个由方括号（ '['和']' ）括起来'['十六进制数字，冒号字符（ ':' ）组成的IPv6地址，也可能包含一个嵌入式IPv4地址。 IPv6地址的完整语法规定在RFC 2373: IPv6 Addressing Architecture中 。

        URI的主机组件不能包含转义的八位字节，因此此方法不执行任何解码。
        结果
        该URI的主机组件，如果主机未定义， null

      • getPort

        public int getPort​()
        返回此URI的端口号。

        URI的端口组件（如果已定义）是非负整数。

        结果
        该URI的端口组件，如果端口未定义， -1

      • getRawPath

        public String getRawPath​()
        返回此URI的原始路径组件。

        URI的路径组件（如果已定义）仅包含斜线字符（ '/' ），商业字符（ '@' ）以及未保留 ， 标点 ， 转义和其他类别中的字符。

        结果
        该URI的路径组件，如果路径未定义， null

      • getPath

        public String getPath​()
        返回此URI的解码路径组件。

        该方法返回的字符串与getRawPath方法返回的字符串相同，只是转义的八位字节的所有序列都为decoded 。

        结果
        该URI的解码路径组件，如果路径未定义， null

      • getRawQuery

        public String getRawQuery​()
        返回此URI的原始查询组件。

        URI的查询组件（如果已定义）仅包含合法的URI字符。

        结果
        该URI的原始查询组件，如果查询未定义， null

      • getQuery

        public String getQuery​()
        返回此URI的解码查询组件。

        该方法返回的字符串等于getRawQuery方法返回的字符串，除了转义的八位字节的所有序列都是decoded 。

        结果
        该URI的解码查询组件，如果查询未定义， null

      • getRawFragment

        public String getRawFragment​()
        返回此URI的原始片段组件。

        URI的片段组件（如果已定义）仅包含合法的URI字符。

        结果
        该URI的原始片段组件，如果片段未定义， null

      • getFragment

        public String getFragment​()
        返回此URI的解码片段组件。

        由该方法返回的字符串等于getRawFragment方法返回的字符串，除了转义的八位字节的所有序列都是decoded 。

        结果
        该URI的解码片段组件，如果片段未定义， null

      • equals

        public boolean equals​(Object ob)
        测试此URI以与另一个对象相等。

        如果给定的对象不是一个URI，那么这个方法立即返回false 。

        对于两个被认为相等的URI要求两者都是不透明的，或者两者都是分层的。 他们的计划既不是未定义的，要么是平等的，不管情况如何。 他们的片段必须既未定义也可以相等。

        对于两个不相容的URI来说，它们的方案特定部分必须相等。

        对于被认为是相等的两个分层URI，它们的路径必须相等，并且它们的查询既不必定义也可以不相等。 他们的权限必须是未定义的，或者两者都是基于注册表的，或者两者都是基于服务器的。 如果他们的权限被定义并且是基于注册表的，那么它们必须相等。 如果他们的权限被定义并且是基于服务器的，那么他们的主机必须相等，而不考虑这种情况，它们的端口号必须相等，并且它们的用户信息组件必须相等。

        当测试两个URI的用户信息，路径，查询，片段，权限或方案特定的部分以进行相等时，比较原始形式而不是这些组件的编码形式，并比较转义八位字节的十六进制数字，而不考虑情况。

        该方法满足Object.equals法的一般合同。

        重写：
        equals在 Object
        参数
        ob - 要比较此对象的对象
        结果
        true如果并且只有给定的对象是与该URI相同的URI
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        返回此URI的哈希码值。 哈希代码基于所有URI的组件，并满足Object.hashCode方法的一般合同。
        重写：
        hashCode Object
        结果
        此URI的哈希码值
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • compareTo

        public int compareTo​(URI that)
        将此URI与另一个对象进行比较，该对象必须是URI。

        当比较两个URI的相应组件时，如果一个组件未定义，而另一个组件被定义，则第一个组件被认为小于第二个组件。 除非另有说明，否则字符串组件根据其自然，区分大小写的排序按照String.compareTo方法定义。 要编码的字符串组件通过比较其原始形式而不是其编码形式进行比较。

        URI的排序定义如下：

        • 具有不同方案的两个URI根据其方案的顺序进行排序，而不考虑情况。

        • 分层URI被认为小于具有相同方案的不透明URI。

        • 具有相同方案的两个不透明的URI根据其特定于方案的部件的顺序进行排序。

        • 具有相同方案和方案特定部分的两个不透明URI按照其片段的顺序排列。

        • 具有相同方案的两个分层URI根据其权限组件的顺序进行排序：

          • 如果两个权限组件都是基于服务器的，则URI根据其用户信息组件进行排序; 如果这些组件是相同的，则URI是根据其主机的顺序排序的，而不考虑情况; 如果主机是相同的，则URI根据其端口的顺序进行排序。

          • 如果一个或两个权限组件是基于注册表的，则URI根据其权限组件的顺序排序。

        • 最后，具有相同方案和权限组件的两个分层URI根据其路径的顺序排序; 如果他们的路径是相同的，那么他们根据他们的查询的顺序被排序; 如果查询是相同的，那么它们根据它们的片段的顺序被排序。

        该方法满足Comparable.compareTo法的一般合同。

        Specified by:
        compareTo在接口 Comparable<URI>
        参数
        that - 要比较此URI的对象
        结果
        负整数，零或正整数，因为此URI小于，等于或大于给定的URI
        异常
        ClassCastException - 如果给定的对象不是URI

      • toString

        public String toString​()
        以字符串形式返回此URI的内容。

        如果此URI是通过调用此类中的其中一个构造函数创建的，那么将返回相当于原始输入字符串的字符串，或根据原始给定组件计算的字符串。 否则，该URI是通过归一化，解析或相对化创建的，因此根据RFC 2396第5.2节第7步中规定的规则，从该URI的组件构造字符串。

        重写：
        toString在 Object
        结果
        这个URI的字符串形式

      • toASCIIString

        public String toASCIIString​()
        将此URI的内容作为US-ASCII字符串返回。

        如果此URI不包含其他类别中的任何字符，则此方法的调用将返回与调用toString方法相同的值。 否则，这个方法的工作原理就是通过调用该方法，然后再结果encoding 。

        结果
        此URI的字符串形式，根据需要进行编码，以使其仅包含US-ASCII字符集中的字符
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


URISyntaxException (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URISyntaxException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.net.URISyntaxException
  • All Implemented Interfaces:
    Serializable

    public class URISyntaxException
extends 异常
    检查的异常抛出以指示不能将字符串解析为URI引用。
    从以下版本开始：
    1.4
    另请参见：
    URI ， Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      URISyntaxException​(String input, String reason)
      从给定的输入字符串构造一个实例和原因。
      URISyntaxException​(String input, String reason, int index)
      从给定的输入字符串，原因和错误索引构造一个实例。

    • 方法摘要

      所有方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      int getIndex​()
      将索引返回到发生解析错误的位置的输入字符串，如果此位置 -1则 -1 。
      String getInput​()
      返回输入字符串。
      String getMessage​()
      返回描述解析错误的字符串。
      String getReason​()
      返回一个字符串，解释为什么无法解析输入字符串。

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

    • 构造方法详细信息

      • URISyntaxException

        public URISyntaxException​(String input,
                          String reason,
                          int index)
        从给定的输入字符串，原因和错误索引构造一个实例。
        参数
        input - 输入字符串
        reason - 一个解释为什么无法解析输入的字符串
        index - 发生解析错误的索引，如果索引未知， -1
        异常
        NullPointerException - 输入或原因字符串是否为 null
        IllegalArgumentException - 如果错误索引小于 -1

      • URISyntaxException

        public URISyntaxException​(String input,
                          String reason)
        从给定的输入字符串构造一个实例和原因。 结果对象的错误索引为-1 。
        参数
        input - 输入字符串
        reason - 一个解释为什么无法解析输入的字符串
        异常
        NullPointerException - 输入或原因字符串是否为 null

    • 方法详细信息

      • getInput

        public String getInput​()
        返回输入字符串。
        结果
        输入字符串

      • getReason

        public String getReason​()
        返回一个字符串，解释为什么无法解析输入字符串。
        结果
        原因串

      • getIndex

        public int getIndex​()
        将索引返回到发生解析错误的位置的输入字符串，如果此位置 -1则 -1 。
        结果
        错误指数

      • getMessage

        public String getMessage​()
        返回描述解析错误的字符串。 生成的字符串由原因字符串后面跟冒号字符（ ':' ），空格和输入字符串组成。 如果定义了错误索引，则字符串" at index "后跟索引（十进制）插入到原因字符串之后和冒号字符之前。
        重写：
        getMessage在 Throwable
        结果
        描述解析错误的字符串
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


URL (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URL

  • java.lang.Object
    • java.net.URL
  • All Implemented Interfaces:
    Serializable

    public final class URL
extends Object
implements Serializable
    URL代表统一资源定位器，指向万维网上“资源”的指针。 资源可以像文件或目录一样简单，或者可以是对更复杂的对象的引用，例如对数据库或搜索引擎的查询。 有关URL类型及其格式的更多信息，请参见： Types of URL

    一般来说，URL可以分为几个部分。 请考虑以下示例：

         http://www.example.com/docs/resource1.html

    上面的URL表示要使用的协议是http （超文本传输协议），并且信息驻留在名为www.example.com的主机上。 该主机上的信息名为/docs/resource1.html 。 主机上此名称的确切含义取决于协议和主机。 信息通常驻留在一个文件中，但它可以在飞行中生成。 该URL的这个组件称为路径组件。

    URL可以选择指定一个“端口”，它是在远程主机上进行TCP连接的端口号。 如果未指定端口，则使用协议的默认端口。 例如， http的默认端口为80 。 另一个端口可以指定为：

         http://www.example.com:1080/docs/resource1.html

    的语法URL由下式定义RFC 2396: Uniform Resource Identifiers (URI): Generic Syntax ，通过修正RFC 2732: Format for Literal IPv6 Addresses in URLs 。 文字IPv6地址格式也支持scope_ids。 scope_ids的语法和用法描述为here 。

    URL可能附加了一个“片段”，也称为“ref”或“reference”。 片段由尖锐的符号字符“＃”表示，后跟更多的字符。 例如，

         http://java.sun.com/index.html#chapter1

    该片段在技术上不是URL的一部分。 相反，它表示在检索到指定的资源之后，应用程序对chapter1附加有标签chapter1的文档的该部分特别感兴趣。 标签的含义是资源特定的。

    一个应用程序还可以指定一个“相对URL”，它只包含相对于另一个URL访问资源的足够的信息。 HTML页面中经常使用相对URL。 例如，如果URL的内容：

         http://java.sun.com/index.html
    在其中包含相对URL：
         FAQ.html
    这将是一个速记：
         http://java.sun.com/FAQ.html

    相对URL不需要指定URL的所有组件。 如果协议，主机名或端口号丢失，该值将从完全指定的URL继承。 必须指定文件组件。 可选片段不被继承。

    URL类本身不会根据RFC2396中定义的转义机制对任何URL组件进行编码或解码。 来电者有责任编码任何需要在调用URL之前进行转义的字段，并对从URL返回的任何转义字段进行解码。 此外，由于URL不具有URL转义的知识，因此不能识别同一URL的编码或解码形式之间的等同性。 例如，两个URL：

      http://foo.com/hello world/ and http://foo.com/hello%20world
    将被视为不相等。

    请注意， URI类在某些情况下确实执行其组件字段的转义。 管理URL编码和解码的推荐方法是使用URI ，并使用toURI()和URI.toURL()在这两个类之间进行转换。

    也可以使用URLEncoder和URLDecoder类，但仅适用于HTML格式编码，这与RFC2396中定义的编码方案不同。

    从以下版本开始：
    1.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      构造方法
      Constructor 描述
      URL​(String spec)
      从 String表示中创建一个 URL对象。
      URL​(String protocol, String host, int port, String file)
      创建 URL从指定对象 protocol ， host ， port号码，和 file 。
      URL​(String protocol, String host, int port, String file, URLStreamHandler handler)
      创建 URL从指定对象 protocol ， host ， port号码， file ，和 handler 。
      URL​(String protocol, String host, String file)
      从指定的 protocol名称， host名称和 file名称创建一个URL。
      URL​(URL context, String spec)
      通过在指定的上下文中解析给定的规范来创建一个URL。
      URL​(URL context, String spec, URLStreamHandler handler)
      通过在指定上下文中使用指定的处理程序解析给定规范来创建URL。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      boolean equals​(Object obj)
      将此URL与其他对象进行比较。
      String getAuthority​()
      获得这个 URL的权限部分。
      Object getContent​()
      获取此URL的内容。
      Object getContent​(Class<?>[] classes)
      获取此URL的内容。
      int getDefaultPort​()
      获取与此 URL关联的协议的默认端口号。
      String getFile​()
      获取此 URL的文件名。
      String getHost​()
      获取此 URL的主机名（如果适用）。
      String getPath​()
      获取此 URL的路径部分。
      int getPort​()
      获取此 URL的端口号。
      String getProtocol​()
      获取此协议名称 URL 。
      String getQuery​()
      获取 URL的查询部分。
      String getRef​()
      获得这个 URL的锚点（也称为“参考”）。
      String getUserInfo​()
      获取这个 URL的userInfo部分。
      int hashCode​()
      创建适合哈希表索引的整数。
      URLConnection openConnection​()
      返回一个URLConnection实例表示由所引用的远程对象的连接URL 。
      URLConnection openConnection​(Proxy proxy)
      与openConnection()相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。
      InputStream openStream​()
      打开与这个 URL的连接，并返回一个 InputStream用于从该连接读取。
      boolean sameFile​(URL other)
      比较两个URL，不包括片段组件。
      static void setURLStreamHandlerFactory​(URLStreamHandlerFactory fac)
      设置应用程序的 URLStreamHandlerFactory 。
      String toExternalForm​()
      构造此 URL的字符串表示 URL 。
      String toString​()
      构造一个 URL的字符串表示 URL 。
      URI toURI​()
      返回相当于此URL的URI 。

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • URL

        public URL​(String protocol,
           String host,
           int port,
           String file)
    throws MalformedURLException
        创建URL从指定对象protocol ， host ， port号码，和file 。

        host可以表示为主机名或字面IP地址。 如果使用IPv6文字地址，则应包含在方括号（ '['和']' ）中，如RFC 2732所述 ; 但是， RFC 2373: IP Version 6 Addressing Architecture中定义的文字IPv6地址格式也被接受。

        指定port号-1表明URL应使用的默认端口的协议。

        如果这是使用指定协议创建的第一个URL对象，则会为该协议创建一个流协议处理程序对象，一个类别为URLStreamHandler的实例：

        1. 如果应用程序先前设置了一个URLStreamHandlerFactory作为流处理程序工厂的实例，那么该实例的createURLStreamHandler方法将以协议字符串作为参数来调用，以创建流协议处理程序。
        2. 如果尚未设置URLStreamHandlerFactory ，或者如果工厂的createURLStreamHandler方法返回null ，则使用ServiceLoader机制来使用系统类加载器来定位URLStreamHandlerProvider实现。 提供者所在的顺序是具体的实现，并且实现可以自由缓存定位的提供者。 一个ServiceConfigurationError ， Error或者RuntimeException从抛出createURLStreamHandler ，如果遇到，将传播到调用线程。 每个提供者的createURLStreamHandler方法（如果已实例化）都使用协议字符串进行调用，直到提供程序返回非空，或者所有提供程序都已用尽。
        3. 如果上一步无法找到协议处理程序，构造函数将读取系统属性的值：
          java.protocol.handler.pkgs
          如果该系统属性的值不是null ，它将被解释为由一个垂直斜杠字符' | '分隔的包的列表。 构造函数尝试加载名为
          <package>.<protocol>.Handler
          其中<package>被替换为包的名称，而<protocol>被替换为协议的名称。 如果此类不存在，或者类存在但不是URLStreamHandler的子类， URLStreamHandler尝试列表中的下一个包。
        4. 如果上一步无法找到协议处理程序，则构造函数尝试加载内置的协议处理程序。 如果此类不存在，或者类存在但不是URLStreamHandler的子类，则抛出一个MalformedURLException 。

        以下协议的协议处理程序保证存在于搜索路径上：

             http, https, file, and jar
        还可以提供附加协议的协议处理程序。 一些协议处理程序，例如用于加载平台类或类路径上的类的协议处理程序可能不会被覆盖。 这些限制的细节以及这些限制（例如在运行时的初始化期间）是具体的，因此没有指定

        这个构造函数不会对输入进行验证。

        参数
        protocol - 要使用的协议的名称。
        host - 主机的名称。
        port - 主机上的端口号。
        file - 主机上的文件
        异常
        MalformedURLException - 如果未知协议或端口为-1以外的负数
        另请参见：
        System.getProperty(java.lang.String) ， setURLStreamHandlerFactory( java.net.URLStreamHandlerFactory) ， URLStreamHandler ， URLStreamHandlerFactory.createURLStreamHandler( java.lang.String)

      • URL

        public URL​(String protocol,
           String host,
           String file)
    throws MalformedURLException
        从指定的protocol名称， host名称和file名称创建一个URL。 使用指定协议的默认端口。

        这个构造函数等同于四参数构造函数，与使用指定协议的默认端口的唯一区别是。 这个构造函数不会对输入进行验证。

        参数
        protocol - 要使用的协议的名称。
        host - 主机的名称。
        file - 主机上的文件。
        异常
        MalformedURLException - 如果指定了未知协议。
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String)

      • URL

        public URL​(String protocol,
           String host,
           int port,
           String file,
           URLStreamHandler handler)
    throws MalformedURLException
        创建URL从指定对象protocol ， host ， port号码， file ，和handler 。 指定port号码为-1表示该URL应使用协议的默认端口。 指定handler的null表示URL应该使用协议的默认流处理程序，如下所述：java.net.URL＃URL（java.lang.String，java.lang.String，int，java.lang.String ）

        如果处理程序不为空，并且有一个安全管理器，那么安全管理器的checkPermission方法将被调用NetPermission("specifyStreamHandler")权限。 这可能会导致SecurityException。 这个构造函数不会对输入进行验证。

        参数
        protocol - 要使用的协议的名称。
        host - 主机的名称。
        port - 主机上的端口号。
        file - 主机上的文件
        handler - URL的流处理程序。
        异常
        MalformedURLException - 如果未知协议或端口为-1以外的负数
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许明确指定流处理程序。
        另请参见：
        System.getProperty(java.lang.String) ， setURLStreamHandlerFactory( java.net.URLStreamHandlerFactory) ， URLStreamHandler ， URLStreamHandlerFactory.createURLStreamHandler( java.lang.String) ， SecurityManager.checkPermission(java.security.Permission) ， NetPermission

      • URL

        public URL​(String spec)
    throws MalformedURLException
        从String表示形成一个URL对象。

        这个构造函数相当于使用一个null第一个参数调用双参数构造函数。

        参数
        spec - 要解析为URL的 String 。
        异常
        MalformedURLException - 如果未指定协议或未找到协议，或者 spec为 null ，或者解析的URL不符合相关协议的具体语法。
        另请参见：
        URL(java.net.URL, java.lang.String)

      • URL

        public URL​(URL context,
           String spec)
    throws MalformedURLException
        通过在指定的上下文中解析给定的规范来创建一个URL。 新URL是根据RFC2396“统一资源标识符：通用*语法”中描述的给定上下文URL和规范参数创建的：
                  <scheme>://<authority><path>?<query>#<fragment>
        引用被解析为方案，权限，路径，查询和片段部分。 如果路径组件为空，并且方案，权限和查询组件未定义，则新URL是对当前文档的引用。 否则，规范中存在的片段和查询部分将用于新的URL。

        如果方案组件在给定规范中定义，并且与上下文方案不匹配，则根据规范单独创建新URL作为绝对URL。 否则，方案组件从上下文URL继承。

        如果权限组件存在于规范中，则规范被视为绝对的，规范权限和路径将替换上下文权限和路径。 如果规范中缺少权限组件，则新URL的权限将从上下文继承。

        如果规范的路径组件以斜杠字符“/”开头，那么该路径将被视为绝对路径，并且规范路径将替换上下文路径。

        否则，将路径视为相对路径，并附加到上下文路径，如RFC2396中所述。 此外，在这种情况下，通过删除由“..”和“。”发生的目录更改来规范路径。

        有关URL解析的更详细的描述，请参阅RFC2396。

        参数
        context - 解析规范的上下文。
        spec - 要解析为URL的 String 。
        异常
        MalformedURLException - 如果未指定协议或未找到协议，或者 spec为 null ，或者解析的URL不符合相关协议的具体语法。
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String) ， URLStreamHandler ， URLStreamHandler.parseURL(java.net.URL, java.lang.String, int, int)

      • URL

        public URL​(URL context,
           String spec,
           URLStreamHandler handler)
    throws MalformedURLException
        通过在指定上下文中使用指定的处理程序解析给定规范来创建URL。 如果处理程序为空，则解析与两个参数构造函数一样发生。
        参数
        context - 解析规范的上下文。
        spec - 要解析为URL的 String 。
        handler - URL的流处理程序。
        异常
        MalformedURLException - 如果未指定协议或未知协议，或者 spec为 null ，或者解析的URL不符合相关协议的具体语法。
        SecurityException - 如果存在安全管理员，并且其 checkPermission方法不允许指定流处理程序。
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String) ， URLStreamHandler ， URLStreamHandler.parseURL(java.net.URL, java.lang.String, int, int)

    • 方法详细信息

      • getQuery

        public String getQuery​()
        获取此 URL的查询部分。
        结果
        查询这个 URL部分，或者是 null如果不存在的话
        从以下版本开始：
        1.3

      • getPath

        public String getPath​()
        获取此 URL的路径部分。
        结果
        这个 URL的路径部分，或一个空字符串（如果不存在）
        从以下版本开始：
        1.3

      • getUserInfo

        public String getUserInfo​()
        获取这个 URL的userInfo部分。
        结果
        该用户信息部分为 URL ，或 null如果不存在
        从以下版本开始：
        1.3

      • getAuthority

        public String getAuthority​()
        获得这个 URL的权限部分。
        结果
        该权限部分为 URL
        从以下版本开始：
        1.3

      • getPort

        public int getPort​()
        获取此 URL的端口号。
        结果
        端口号，如果端口未设置，则为-1

      • getDefaultPort

        public int getDefaultPort​()
        获取与此URL关联的协议的默认端口号。 如果URL方案或URL的URLStreamHandler未定义默认端口号，则返回-1。
        结果
        端口号
        从以下版本开始：
        1.4

      • getProtocol

        public String getProtocol​()
        获取此协议名称 URL 。
        结果
        该协议 URL 。

      • getHost

        public String getHost​()
        获取此URL的主机名（如适用）。 主机的格式符合RFC 2732，即对于一个文字的IPv6地址，该方法将返回包含在方括号（ '['和']' ）中的IPv6地址。
        结果
        该主机名称为 URL 。

      • getFile

        public String getFile​()
        获取此URL的文件名。 返回的文件部分将与getPath()相同，加上值为getQuery()的连接（如果有）。 如果没有查询部分，此方法和getPath()将返回相同的结果。
        结果
        该文件名为 URL ，如果不存在，则为空字符串

      • getRef

        public String getRef​()
        获得这个 URL的锚点（也称为“参考”）。
        结果
        该 URL的锚点（也称为“参考”）或 null如果不存在

      • equals

        public boolean equals​(Object obj)
        将此URL与其他对象进行比较。

        如果给定的对象不是一个URL，那么这个方法将立即返回false 。

        如果两个URL对象具有相同的协议，引用等效主机，主机上具有相同的端口号，以及该文件的相同文件和片段，则它们是相等的。

        如果两个主机名都可以解析成相同的IP地址，则两台主机被认为是等效的; 否则如果任一主机名无法解析，主机名必须相等而不考虑大小写; 或两个主机名等于null。

        由于主机比较需要名称解析，因此此操作是阻塞操作。

        注意：已知与equals的定义行为与HTTP中的虚拟主机不一致。

        重写：
        equals在 Object
        参数
        obj - 要比较的URL。
        结果
        true如果对象是一样的; false否则。
        另请参见：
        Object.hashCode() ， HashMap

      • hashCode

        public int hashCode​()
        创建适合哈希表索引的整数。

        哈希码基于与URL比较相关的所有URL组件。 因此，该操作是阻塞操作。

        重写：
        hashCode在 Object
        结果
        这个 URL的哈希码。
        另请参见：
        Object.equals(java.lang.Object) ， System.identityHashCode(java.lang.Object)

      • sameFile

        public boolean sameFile​(URL other)
        比较两个URL，不包括片段组件。

        如果这个URL和other参数是相等的，而不考虑片段组件，则返回true 。

        参数
        other - 与 URL进行比较。
        结果
        true如果他们引用同一个远程对象; false否则。

      • toString

        public String toString​()
        构造一个URL的字符串表示URL 。 该字符串是通过调用该对象的流协议处理程序的toExternalForm方法创建的。
        重写：
        toString在 Object
        结果
        该对象的字符串表示形式。
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String) ， URLStreamHandler.toExternalForm(java.net.URL)

      • toExternalForm

        public String toExternalForm​()
        构造此URL的字符串表示URL 。 该字符串是通过调用该对象的流协议处理程序的toExternalForm方法创建的。
        结果
        该对象的字符串表示形式。
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String) ， URLStreamHandler.toExternalForm(java.net.URL)

      • toURI

        public URI toURI​()
          throws URISyntaxException
        返回相当于此URL的URI 。 该方法的功能与new URI (this.toString())相同。

        请注意，符合RFC 2396的任何URL实例都可以转换为URI。 但是，一些不严格遵守的URL不能转换为URI。

        结果
        与此URL相当的URI实例。
        异常
        URISyntaxException - 如果此URL严格按照RFC2396进行格式化，不能转换为URI。
        从以下版本开始：
        1.5

      • openConnection

        public URLConnection openConnection​()
                             throws IOException
        返回一个URLConnection实例表示由所引用的远程对象的连接URL 。

        每次当调用此URL的协议处理程序的URLStreamHandler.openConnection(URL)方法时， 都会创建一个新的URLConnection实例。

        应该注意的是，URLConnection实例在创建时不会建立实际的网络连接。 这只会在调用URLConnection.connect()时发生。

        如果对于URL的协议（如HTTP或JAR），则存在一个属于以下软件包或其子包之一的公共专用URLConnection子类：java.lang，java.io，java.util，java.net，返回的连接将是该子类。 例如，对于HTTP，将返回一个HttpURLConnection，对于JAR，将返回一个JarURLConnection。

        结果
        链接到URL的一个URLConnection 。
        异常
        IOException - 如果发生I / O异常。
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String)

      • openConnection

        public URLConnection openConnection​(Proxy proxy)
                             throws IOException
        与openConnection()相同，但连接将通过指定的代理进行; 不支持代理的协议处理程序将忽略代理参数并进行正常连接。 调用此方法会抢占系统默认的ProxySelector设置。
        参数
        proxy - 将通过该连接进行的代理。 如果需要直接连接，则应指定Proxy.NO_PROXY。
        结果
        一个 URLConnection的URL。
        异常
        IOException - 如果发生I / O异常。
        SecurityException - 如果存在安全管理器，并且呼叫者没有连接到代理的权限。
        IllegalArgumentException - 如果代理为空，或者代理的类型不正确，则会抛出
        UnsupportedOperationException - 如果实现协议处理程序的子类不支持此方法。
        从以下版本开始：
        1.5
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String) ， URLConnection ， URLStreamHandler.openConnection(java.net.URL, java.net.Proxy)

      • openStream

        public final InputStream openStream​()
                             throws IOException
        打开与此URL的连接，并返回一个InputStream用于从该连接读取。 这个方法是一个简写：
             openConnection().getInputStream()
        结果
        用于从URL连接读取的输入流。
        异常
        IOException - 如果发生I / O异常。
        另请参见：
        openConnection() ， URLConnection.getInputStream()

      • getContent

        public final Object getContent​()
                        throws IOException
        获取此URL的内容。 这个方法是一个简写：
             openConnection().getContent()
        结果
        这个URL的内容。
        异常
        IOException - 如果发生I / O异常。
        另请参见：
        URLConnection.getContent()

      • getContent

        public final Object getContent​(Class<?>[] classes)
                        throws IOException
        获取此URL的内容。 这个方法是一个简写：
             openConnection().getContent(classes)
        参数
        classes - 一个Java类型的数组
        结果
        该URL的内容对象是类数组中指定的类型的第一个匹配项。 如果不支持请求的类型，则为null。
        异常
        IOException - 如果发生I / O异常。
        从以下版本开始：
        1.3
        另请参见：
        URLConnection.getContent(Class[])

      • setURLStreamHandlerFactory

        public static void setURLStreamHandlerFactory​(URLStreamHandlerFactory fac)
        设置应用程序的URLStreamHandlerFactory 。 在给定的Java虚拟机中最多可以调用此方法。

        URLStreamHandlerFactory实例用于从协议名称构造流协议处理程序。

        如果有安全管理员，则该方法首先调用安全管理器的checkSetFactory方法，以确保允许操作。 这可能会导致SecurityException。

        参数
        fac - 所需工厂。
        异常
        Error - 如果应用程序已经设置了工厂。
        SecurityException - 如果存在安全管理员，并且其 checkSetFactory方法不允许该操作。
        另请参见：
        URL(java.lang.String, java.lang.String, int, java.lang.String) ， URLStreamHandlerFactory ， SecurityManager.checkSetFactory()
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement


URLClassLoader (Java SE 9 & JDK 9 )

  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • SEARCH:
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
Module java.base
软件包 java.net

Class URLClassLoader

  • java.lang.Object
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader
  • All Implemented Interfaces:
    Closeable ， AutoCloseable
    已知直接子类：
    MLet

    public class URLClassLoader
extends SecureClassLoader
implements Closeable
    此类加载器用于从引用JAR文件和目录的URL的搜索路径加载类和资源。 假定任何jar:方案URL（见JarURLConnection ）是指JAR文件。 以'/'结尾的任何file:方案URL假定是指一个目录。 否则，URL被认为是指根据需要打开的JAR文件。

    该类加载器支持从给定URL引用的multi-release JAR文件的内容中加载类和资源。

    当后续加载类和资源时，将使用创建URLClassLoader实例的线程的AccessControlContext。

    加载的类默认授权只能访问URLClassLoader创建时指定的URL。

    从以下版本开始：
    1.2

    • 构造方法摘要

      构造方法
      Constructor 描述
      URLClassLoader​(String name, URL[] urls, ClassLoader parent)
      为指定的URL构造一个新的命名为 URLClassLoader 。
      URLClassLoader​(String name, URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的命名为 URLClassLoader 。
      URLClassLoader​(URL[] urls)
      使用默认委托父母 ClassLoader为指定的URL构造一个新的URLClassLoader。
      URLClassLoader​(URL[] urls, ClassLoader parent)
      为给定的URL构造一个新的URLClassLoader。
      URLClassLoader​(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的URLClassLoader。

    • 方法摘要

      所有方法 静态方法 接口方法 具体的方法
      Modifier and Type 方法 描述
      protected void addURL​(URL url)
      将指定的URL附加到URL列表中以搜索类和资源。
      void close​()
      关闭此URLClassLoader，以使其不能再用于加载由此加载程序定义的新类或资源。
      protected 软件包 definePackage​(String name, Manifest man, URL url)
      在这个 URLClassLoader按名称定义一个新的包。
      protected Class<?> findClass​(String name)
      从URL搜索路径查找并加载具有指定名称的类。
      URL findResource​(String name)
      在URL搜索路径上查找具有指定名称的资源。
      Enumeration<URL> findResources​(String name)
      返回表示URL搜索路径上具有指定名称的所有资源的URL的枚举。
      protected PermissionCollection getPermissions​(CodeSource codesource)
      返回给定的代码源对象的权限。
      InputStream getResourceAsStream​(String name)
      返回用于读取指定资源的输入流。
      URL[] getURLs​()
      返回加载类和资源的URL的搜索路径。
      static URLClassLoader newInstance​(URL[] urls)
      为指定的URL和默认父类加载器创建URLClassLoader的新实例。
      static URLClassLoader newInstance​(URL[] urls, ClassLoader parent)
      为指定的URL和父类加载器创建URLClassLoader的新实例。

      • Methods inherited from class java.lang.ClassLoader

        clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findResource, findSystemClass, getClassLoadingLock, getDefinedPackage, getDefinedPackages, getName, getPackage, getPackages, getParent, getPlatformClassLoader, getResource, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, getUnnamedModule, isRegisteredAsParallelCapable, loadClass, loadClass, registerAsParallelCapable, resolveClass, resources, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from class java.security.SecureClassLoader

        defineClass, defineClass

    • 构造方法详细信息

      • URLClassLoader

        public URLClassLoader​(URL[] urls,
                      ClassLoader parent)
        为给定的URL构造一个新的URLClassLoader。 在首次搜索指定的父类加载器后，将按照为类和资源指定的顺序搜索URL。 假定任何jar:方案URL是指JAR文件。 以“/”结尾的任何file:方案URL假定是指一个目录。 否则，URL被认为是指根据需要下载并打开的JAR文件。

        如果有一个安全管理器，这个方法首先调用安全管理器的checkCreateClassLoader方法，以确保允许创建一个类加载器。

        参数
        urls - 加载类和资源的URL
        parent - 用于委派的父类加载器
        异常
        SecurityException - 如果安全管理器存在，并且其 checkCreateClassLoader方法不允许创建类加载器。
        NullPointerException - 如果 urls是 null 。
        另请参见：
        SecurityManager.checkCreateClassLoader()

      • URLClassLoader

        public URLClassLoader​(URL[] urls)
        使用默认委托父母ClassLoader为指定的URL构造一个新的URLClassLoader。 在首次搜索父类加载器后，将按照为类和资源指定的顺序搜索URL。 任何以“/”结尾的URL都假定是指一个目录。 否则，URL被认为是指根据需要下载并打开的JAR文件。

        如果有安全管理员，则该方法首先调用安全管理器的checkCreateClassLoader方法，以确保允许创建类加载器。

        参数
        urls - 加载类和资源的URL
        异常
        SecurityException - 如果安全管理器存在，并且其 checkCreateClassLoader方法不允许创建类加载器。
        NullPointerException - 如果 urls是 null 。
        另请参见：
        SecurityManager.checkCreateClassLoader()

      • URLClassLoader

        public URLClassLoader​(URL[] urls,
                      ClassLoader parent,
                      URLStreamHandlerFactory factory)
        为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的URLClassLoader。 父参数将被用作委托的父类加载器。 在创建新的jar URL时，factory参数将用作流处理程序工厂来获取协议处理程序。

        如果有安全管理员，则该方法首先调用安全管理器的checkCreateClassLoader方法，以确保允许创建类加载器。

        参数
        urls - 加载类和资源的URL
        parent - 用于委派的父类加载器
        factory - 创建URL时要使用的URLStreamHandlerFactory
        异常
        SecurityException - 如果存在安全管理员，并且其 checkCreateClassLoader方法不允许创建类加载器。
        NullPointerException - 如果 urls是 null 。
        另请参见：
        SecurityManager.checkCreateClassLoader()

      • URLClassLoader

        public URLClassLoader​(String name,
                      URL[] urls,
                      ClassLoader parent)
        为指定的URL构造一个新的命名为URLClassLoader 。 在首次搜索指定的父类加载器后，将按照为类和资源指定的顺序搜索URL。 任何以“/”结尾的URL都假定是指一个目录。 否则，URL被认为是指根据需要下载并打开的JAR文件。
        参数
        name - 类加载器名称; 或null如果没有命名
        urls - 加载类和资源的URL
        parent - 用于委派的父类加载器
        异常
        IllegalArgumentException - 如果给定的名称为空。
        NullPointerException - 如果 urls是 null 。
        SecurityException - 如果安全管理器存在，并且其 SecurityManager.checkCreateClassLoader()方法不允许创建类加载器。
        从以下版本开始：
        9

      • URLClassLoader

        public URLClassLoader​(String name,
                      URL[] urls,
                      ClassLoader parent,
                      URLStreamHandlerFactory factory)
        为指定的URL，父类加载器和URLStreamHandlerFactory构造一个新的命名为URLClassLoader 。 父参数将被用作委托的父类加载器。 在创建新的jar URL时，factory参数将用作流处理程序工厂来获取协议处理程序。
        参数
        name - 类加载器名称; 或null如果没有命名
        urls - 加载类和资源的URL
        parent - 用于委派的父类加载器
        factory - 创建URL时要使用的URLStreamHandlerFactory
        异常
        IllegalArgumentException - 如果给定的名称为空。
        NullPointerException - 如果 urls是 null 。
        SecurityException - 如果存在安全管理员，并且其 checkCreateClassLoader方法不允许创建类加载器。
        从以下版本开始：
        9

    • 方法详细信息

      • getResourceAsStream

        public InputStream getResourceAsStream​(String name)
        返回用于读取指定资源的输入流。 如果此加载程序关闭，则此方法打开的任何资源将被关闭。

        搜索顺序在ClassLoader.getResource(String)的文档中有所描述。

        重写：
        getResourceAsStream在 ClassLoader
        参数
        name - 资源名称
        结果
        用于读取资源的输入流，如果资源无法找到， null
        异常
        NullPointerException - 如果 name是 null
        从以下版本开始：
        1.7

      • close

        public void close​()
           throws IOException
        关闭此URLClassLoader，以使其不能再用于加载由此加载程序定义的新类或资源。 任何这种加载程序的父代在委派层次结构中定义的类和资源仍然可以访问。 此外，任何已加载的类或资源仍可访问。

        在jar：和file：URL的情况下，它也会关闭它打开的任何文件。 如果另一个线程在调用close方法时加载了一个类，那么该负载的结果是未定义的。

        该方法通过在内部捕获IOException来尽最大努力关闭所有已打开的文件。 未被检查的异常和错误未被捕获。 在已关闭的加载程序上关闭呼叫没有任何影响。

        Specified by:
        close在接口 AutoCloseable
        Specified by:
        close在接口 Closeable
        异常
        IOException - 如果关闭此类加载器打开的任何文件导致IOException。 任何此类异常都在内部被捕获。 如果只有一个被捕获，那么它被重新抛出。 如果捕获了多个异常，则将第二个和以下异常作为被捕获的第一个异常的被抑制异常添加，然后被重新抛出。
        SecurityException - 如果设置了安全管理员，并且它拒绝了RuntimePermission ("closeClassLoader")
        从以下版本开始：
        1.7

      • addURL

        protected void addURL​(URL url)
        将指定的URL附加到URL列表中以搜索类和资源。

        如果指定的URL是null或已经在URL列表中，或者如果此加载程序关闭，则调用此方法将不起作用。

        参数
        url - 要添加到URL搜索路径的URL

      • getURLs

        public URL[] getURLs​()
        返回加载类和资源的URL的搜索路径。 这包括为构造函数指定的URL的原始列表，以及随后由addURL（）方法附加的任何URL。
        结果
        用于加载类和资源的URL的搜索路径。

      • findClass

        protected Class<?> findClass​(String name)
                      throws ClassNotFoundException
        从URL搜索路径查找并加载具有指定名称的类。 任何引用JAR文件的URL将根据需要进行加载和打开，直到找到该类。
        重写：
        findClass在 ClassLoader
        参数
        name ，
        结果
        结果课
        异常
        ClassNotFoundException - 如果找不到类，或者装载器关闭。
        NullPointerException - 如果 name是 null 。

      • definePackage

        protected 软件包 definePackage​(String name,
                                Manifest man,
                                URL url)
        在这个URLClassLoader按名称定义一个新的包。 包含在指定的Manifest的属性将用于获取包版本和密封信息。 对于密封包，附加URL指定加载包的代码源URL。
        参数
        name - 包名称
        man - 包含封装版本和密封信息的 Manifest
        url - 包的代码源URL，如果没有则为null
        结果
        新定义的 软件包对象
        异常
        IllegalArgumentException - 如果包名已经由此类加载器定义

      • findResource

        public URL findResource​(String name)
        在URL搜索路径上查找具有指定名称的资源。
        重写：
        findResource在 ClassLoader
        参数
        name - 资源的名称
        结果
        一个 URL的资源，或 null如果资源无法找到，或者如果装载程序关闭。

      • findResources

        public Enumeration<URL> findResources​(String name)
                               throws IOException
        返回表示URL搜索路径上具有指定名称的所有资源的URL的枚举。
        重写：
        findResources在 ClassLoader
        参数
        name - 资源名称
        结果
        一个 Enumeration的 URL s如果加载程序关闭，枚举将为空。
        异常
        IOException - 如果发生I / O异常

      • getPermissions

        protected PermissionCollection getPermissions​(CodeSource codesource)
        返回给定的代码源对象的权限。 该方法的实现首先调用super.getPermissions，然后根据代码源的URL添加权限。

        如果此URL的协议是“jar”，则授予的权限基于Jar文件的URL所需的权限。

        如果协议是“文件”，并且有一个权限组件，则可以授予连接到并接受来自该授权机构的连接的权限。 如果协议是“文件”，并且路径指定了一个文件，则授予读取该文件的权限。 如果协议是“文件”并且路径是目录，则授予许可以读取所有文件，并递归地递送该目录中包含的所有文件和子目录。

        如果协议不是“文件”，则授予连接到并接受URL主机的连接的权限。

        重写：
        getPermissions在 SecureClassLoader
        参数
        codesource - 代码源
        结果
        授予代码源的权限
        异常
        NullPointerException - 如果 codesource是 null 。

      • newInstance

        public static URLClassLoader newInstance​(URL[] urls,
                                         ClassLoader parent)
        为指定的URL和父类加载器创建URLClassLoader的新实例。 如果安装了安全管理器，该loadClass的URLClassLoader的方法此方法返回的将调用SecurityManager.checkPackageAccess加载类方法之前。
        参数
        urls - 搜索类和资源的URL
        parent - 用于委派的父类加载器
        结果
        生成的类加载器
        异常
        NullPointerException - 如果 urls是 null 。

      • newInstance

        public static URLClassLoader newInstance​(URL[] urls)
        为指定的URL和默认父类加载器创建URLClassLoader的新实例。 如果安装了安全管理器，该loadClass的URLClassLoader的方法此方法返回的将调用SecurityManager.checkPackageAccess加载类之前。
        参数
        urls - 搜索课程和资源的URL
        结果
        生成的类加载器
        异常
        NullPointerException - 如果 urls是 null 。
Skip navigation links
  • 概述
  • Module
  • 软件包
  • Class
  • 使用
  • 树
  • 已过时的
  • 索引
  • 帮助
Java SE 9 & JDK 9
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有类
  • 概要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

Report a bug or suggest an enhancement